ZWAPIOPEN: Welcome to ZW3D API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Welcome to ZW3D API

This manual tells you what ZW3D is and how to use it.
The topics in the ZW3D Installation and Registration section explain how to get ZW3D up and running on your system, and the Help Manual describes how to work with ZW3D and what ZW3D can do for you.
You can also find documentation for all ZW3D commands in the Help Manual section.

Introductions

  • Release Notes
  • API Structure Introduction
  • Introduction to the ZW3D API
  • Frequently Asked Questions
  • Remote Communication with ZW3D

Modules

  • Common
  • File
  • Part Objects
  • Assembly Objects
  • Drawing Objects
  • Sketch Objects
  • Cam
  • Brep
  • Math
  • UI
  • Command Definition
  • Commands Creation

Files

  • The tab page of files is mainly a list of all files.
  • Through this page, user can directly see the source code of the header file that does not contain the description information.
  • This page does not do redundant classification, and user can directly find the information

Examples

  • The examples tab page is mainly a list of all the example files.
  • If you want to view an example of an interface, user can jump directly from the link at the bottom of the interface introduction page.
  • Every example function can be used directly.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: ListPages

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
ListPages
  • Release Notes
  • API Structure Introduction
  • Introduction to the ZW3D API
  • Frequently Asked Questions
  • Remote Communication with ZW3D
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Release Notes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ListPages
Release Notes
2800
New functions:
evxErrors cvxCrvGetPntAtLenFraction(int idCurve, double Fraction, svxPoint* Point);
evxErrors cvxPartReplaceInit(svxReplaceData* data);
evxErrors cvxPartReplace(const svxReplaceData* Replace, int* idReplace);
evxErrors cvxPartMorphToCrvInit(svxMorphToCrvData* data);
evxErrors cvxPartMorphToCrv(const svxMorphToCrvData* MorphToCrv, int* idMorphToCrv);
evxErrors cvxPartCfgTblAdd(vxName cfgName, char* cfgDes, int* idCfg);
evxErrors cvxPartStretchInit(svxStretchData* data);
evxErrors cvxPartStretch(const svxStretchData* Stretch, int* idStretch);
evxErrors cvxPartTaperInit(svxTaperData* data);
evxErrors cvxPartTaper(const svxTaperData* Taper, int* idTaper);
evxErrors cvxPartTwistInit(svxTwistData* data);
evxErrors cvxPartTwist(const svxTwistData* Twist, int* idTwist);
evxErrors cvxDispSceneUpdate();
evxErrors cvxPartFilletBlendInit(svxFilletBlendData* data);
evxErrors cvxPartFilletBlend(const svxFilletBlendData* FilletBlend, int* idFilletBlend);
void cvxLastWarningMsgEnable(int enable);
evxErrors cvxTplInqFieldOptions(const vxName Name, int idField, int NumBytes, char* Options);
evxErrors cvxPartInqEdgeType(int idEdge, evxEdgeType* EdgeType);
evxErrors cvxDataInqParent(int* idData);
evxErrors cvxTplInqFields(const vxName Name, int* NumFld, int** idFields);
evxErrors cvxTplInqFieldType(const vxName Name, int idField, evxCmdFldClass * Type);
evxErrors cvxPartInqTexts(int* count, int** idTexts);
evxErrors cvxSliderLimitGet(const char* Form, int idfield, double* min, double* max);
evxErrors cvxSliderLimitSet(const char* Form, int idfield, double min, double max);
void cvxAuxFrameSetOrigin(const svxPoint* Origin);
void cvxAuxFrameSetAxisVec(evxAxisType AxisType, const svxVector* AxisDir);
evxErrors cvxCrvPlaneParallelChk(const svxPoint* plnPnt, const svxVector* plnNormal, const svxCurve* Crv, double tol, int* isParallel, double* Distance);
void cvxPartClosePreview();
evxErrors cvxPartShowPartAt(const vxLongPath File, const vxRootName Root);
void cvxPartClosePartAt();
evxErrors cvxFileNameLenIsOverrange(const char* file_name);
evxErrors cvxFilePathLenIsOverrange(const char* file_path);
evxErrors cvxPartInqReversedCurve(int idEnt, svxCurve* data);
evxErrors cvxPartCrvProjToFaceInit(svxCrvProjToFace* data);
evxErrors cvxPartCrvProjToFace(const svxCrvProjToFace* data, int* cntEnts, int** pEnts);
evxErrors cvxPartCrvOnFaceThruPtsInit(svxCrvOnFaceThuPts* data);
evxErrors cvxPartCrvOnFaceThruPts(const svxCrvOnFaceThuPts* data, int* idEnt);
evxErrors cvxPartFaceCurve(const svxFaceCrvData* data, int* cntEnts, int** idEnts);
evxErrors cvxPartExtractCenterlines(int cntFaces, int* idFaces, int extractAxis, int* cntEnts, int** idEnts);
evxErrors cvxPartSpiralCurve(const svxSpiralCrvData* data, int* idEnt);
evxErrors cvxPartCrvTrimToFaces(const svxCrvTrimToFacesData* data, int* idTrim);
evxErrors cvxPartCrvTrimWithCrv(const svxTrimWithCrvData* data, int* CountCrvs, int** NewCrvs);
evxErrors cvxPartCrvConvertToArcsInit(svxCrvConvertTocData* data);
evxErrors cvxPartCrvConvertToArcs(const svxCrvConvertTocData* data, int* cntArcs, int** idArcs);
evxErrors cvxPartBlendCrvsConsInit(svxCrvBlendCons* consData, int objType);
evxErrors cvxPartBlendCrvsInit(svxCrvBlendData *data);
evxErrors cvxPartBlendCrvs(const svxCrvBlendData *data, int *idEnt);
evxErrors cvxPartCrvChamferChainInit(svxCrvChamferChainData* data);
evxErrors cvxPartCrvChamferChain(const svxCrvChamferChainData* data, int* idChamfer);
evxErrors cvxPartConcentricArc(int refArc, double Radius, int* idEnt);
evxErrors cvxPartIsoCurveOnFace(const svxIsoCrvOnFaceData* data, int* cntEnts, int** idEnts);
evxErrors cvxPartIsoclineCurve(const svxIsoclineCrvData* Crv, int* cntEnts, int** idEnts);
evxErrors cvxPartCombinedProj(const svxCrvCombinedProjData* Crv, int* cntEnts, int** idEnts);
evxErrors cvxDwgViewAlignedSectionInit(svxAlignSecViewData* data);
evxErrors cvxDwgViewAlignedSection(const svxAlignSecViewData* alignSecViewData, int* idView);
evxErrors cvxLicRemove(const char* pzEntitlement);
evxErrors cvxDwgViewRefBlankGet(int idRefEnt, int* blank);
evxErrors cvxDwgViewRefBlankSet(int idRefEnt, int blank);
evxErrors cvxTabWidgetItemVisibleSet(const char* Form, int tabIdField, int tabIndex, char bVisible);
evxErrors cvxPartPublishSet(const vxName Name, int Count, const int* idEnts, int* idPubSet);
evxErrors cvxPartInqPublishSets(const vxLongPath File, const vxRootName Part, int* Count, int** idPubSets);
evxErrors cvxPartInqPublishSet(const vxLongPath File, const vxRootName Part, int idPubSet, vxName Name, int* Count, int** idEnts);
evxErrors cvxPartPublishSetDel(int Count, const int* idPubSets);
evxErrors cvxCompSuppressGetByPath(svxEntPath* path, int* suppress);
evxErrors cvxCmHolderInsertAsTemplate(const vxLongPath template_path, const vxLongName file_name,
const vxLongName library_name, const vxLongName holder_name, int* idx_holder);
evxErrors cvxCmSpeedInsertAsTemplate(const vxLongPath template_path, const vxLongName file_name,
const vxLongName library_name,const vxLongName spdfd_name, int* idx_speed);
evxErrors cvxFormInsertTo(const svxFormInfo* FormInfo, int Index, evxFormAddTo AddTo);
evxErrors cvxFormVisibleSet(int idEnvironment, const char* Form, int State, evxFormAddTo Type);
evxErrors cvxPartInqCSYSAxis(int idCSYS, evxAxisType AxisType, int* idAxis);
evxErrors cvxPartInqCSYSPlane(int idCSYS, evxPlaneType PlnType, int* idPlane);
evxErrors cvxDataSetPntOnCrvPath(int idData, int idField, int critPnt, const svxEntPath* crvPath, const svxPoint* pnt);
evxErrors cvxCompAddGearCons(const svxEntPath* Gear1, const svxEntPath* Gear2, const svxGearConsData* ConsData, int* idCons);
evxErrors cvxCompAddPathCons(const svxPntOnEntPath* Pnt, int nPaths, const svxEntPath* Paths, const svxPathConsData* ConsData, int* idCons);
evxErrors cvxCompAddLinearCoupleCons(const svxEntPath* Comp1, const svxEntPath* Dir1, const svxEntPath* Comp2, const svxEntPath* Dir2, const svxLinearCpData* ConsData, int* idCons);
evxErrors cvxCompAddRackPinionCons(const svxEntPath* Rack, const svxEntPath* Pinion, const svxRackPinionData* ConsData, int* idCons);
evxErrors cvxCompAddScrewCons(const svxEntPath* ScrewEnt, const svxEntPath* LinearEnt, const svxScrewConsData* ConsData, int* idCons);
evxErrors cvxCompAddSlotCons(const svxEntPath* Ent, int nSlots, const svxEntPath* Slots, const svxSlotConsData* ConsData, int* idCons);
evxErrors cvxCompAddCamCons(const svxEntPath* Ent, int nCamFaces, const svxEntPath* CamFaces, int* idCons);
evxErrors cvxCompAddUniJointCons(const svxEntPath* Shaft1, const svxPntOnEntPath* HingePnt1, const svxEntPath* Shaft2, const svxPntOnEntPath* HingePnt2, const svxUniJointData* ConsData, int* idCons);
evxErrors cvxDatumDispAttrGet(int idDatum, svxWireAt* DispAt);
evxErrors cvxDatumDispAttrSet(int idDatum, const svxWireAt* DispAt);
evxErrors cvxAxisLengthGet(int idAxis, double* Length);
evxErrors cvxAxisLengthSet(int idAxis, double Length);
evxErrors cvxAxisDispModeGet(int idAxis, evxAxisDispMode* DspMode);
evxErrors cvxAxisDispModeSet(int idAxis, evxAxisDispMode DspMode);
evxErrors cvxPartLineInit(svxLineData* lineData);
evxErrors cvxPartLine(const svxLineData* lineData, int* idLine);
evxErrors cvxPartArcInit(svxArcData* arcData);
evxErrors cvxPartArc(const svxArcData* arcData, int* idArc);
evxErrors cvxPartCircleInit(svxCircleData* circleData);
evxErrors cvxPartCircle(const svxCircleData* circleData, int* idCircle);
evxErrors cvxPartPntNew(int Count, const svxPntOnEnt* PntData, int idAlignPln, int PrjToPln, int* idPntFtr);
evxErrors cvxRootCustomDataAdd(const vxLongPath file, const vxRootName root, const char* data, int* idCustomData);
evxErrors cvxRootCustomDataGetAll(const vxLongPath file, const vxRootName root, int* count, char*** data);
evxErrors cvxRootCustomDataGetById(const vxLongPath file, const vxRootName root, int idCustomData, char** data);
evxErrors cvxRootCustomDataModById(const vxLongPath file, const vxRootName root, int idCustomData, const char* data);
evxErrors cvxRootCustomDataDelById(const vxLongPath file, const vxRootName root, int count, const int* idCustomDatas);
evxErrors cvxRootInqCustomData(const vxLongPath file, const vxRootName root, int* count, int** idCustomDatas);
evxErrors cvxPartDelFaceTx(int Count, const int* idFaces);
void cvxLayerRefresh();
int cvxLicStandaloneEvaluationGet();
evxErrors cvxPartHistInqGroup(int idHistObj, int* idGroup);
evxErrors cvxCmFtrInqType(int idx_Ftr, evxCmFtrType* ftrType);
evxErrors cvxCmOpSetBasicAttr(int idx_op, int field, int item, const char* value);
evxErrors cvxCmOpInqClass(int idx_Op, evxCmOpClass* opClass);
evxErrors cvxCmOpSetClass(int idx_Op, evxCmOpClass opClass);
evxErrors cvxCmOpInqTypeS(int idx_Op,char* opType, int nByte);
evxErrors cvxPartInqFaceGeom(int idFace, int* idGeom);
evxErrors cvxPartSpiralSweepInit(svxSpiralSweepData* data);
evxErrors cvxPartSpiralSweep(const svxSpiralSweepData* SpiralSwp, int* idShape);
evxErrors cvxCompMakeVirtual(svxEntPath* CompPath);
evxErrors cvxCompIsVirtual(svxEntPath* CompPath, int* isVirtual);
evxErrors cvxAxisCrvDistance(const svxAxis* Axis, const svxCurve* Crv, svxPoint* pntOnAxis, svxPoint* pntOnCrv, double* Distance);
evxErrors cvxPartRuledInit(svxRuledData* data);
evxErrors cvxPartRuled(const svxRuledData* data, int* idFace);
evxErrors cvxPartCircularBiRailInit(evxCircularBiRailMethod method, svxCircularBiRailData* data);
evxErrors cvxPartCircularBiRail(const svxCircularBiRailData* data, int* idFace);
evxErrors cvxPartConicBiRailInit(evxConicBiRailMethod method, svxConicBiRailData* data);
evxErrors cvxPartConicBiRail(const svxConicBiRailData* data, int* idFace);
evxErrors cvxPartSetFaceDir(int count, int* idFaces, const svxVector* dir);
evxErrors cvxPartModifyIsolineNum(int count, int* idFaces, int Uisoline, int Visoline);
evxErrors cvxPartEnlargeFaceInit(svxEnlargeFaceData* data);
evxErrors cvxPartEnlargeFace(const svxEnlargeFaceData* data, int* idFace);
evxErrors cvxPartExtendShapeInit(svxExtendShapeData* data);
evxErrors cvxPartExtendShape(const svxExtendShapeData* data, int* idFtr);
evxErrors cvxPartSplitWithCrvInit(svxSplitWithCrvData* data);
evxErrors cvxPartSplitWithCrv(const svxSplitWithCrvData* data, int* idFtr);
evxErrors cvxPartCrvFilletInit(svxCrvFilletData* data);
evxErrors cvxPartCrvFillet(const svxCrvFilletData* data, int* idFillet);
evxErrors cvxPartCrvFilletChainInit(svxCrvFilletChainData* data);
evxErrors cvxPartCrvFilletChain(const svxCrvFilletChainData* data, int* idFilletChain);
evxErrors cvxPartCrvChamferInit(svxCrvChamferData* data);
evxErrors cvxPartCrvChamfer(const svxCrvChamferData* data, int* idChamfer);
evxErrors cvxConsEnable(int count, int* idCons, int enable);
evxErrors cvxConsDel(int count, int* idCons);
evxErrors cvxDwgSheetDel(int count, int* idSheet);
evxErrors cvxSkReferenceInit(svxSkRefData* data);
evxErrors cvxSkReference(const svxSkRefData* data, int* count, int** idRefEnts);
evxErrors cvxDataSetPntOnEntPath(int idData, int idField, const svxPntOnEntPath* pntData);
evxErrors cvxCompFolderIns(int cnt, const int* idCom, const vxLongName folderName, int* idFolder);
evxErrors cvxPartSmdFlangeInit(svxSmdFlangeData* data);
evxErrors cvxPartSmdFlange(const svxSmdFlangeData* data, int* idFlange);
evxErrors cvxAsmReorder(const vxLongPath fileName, vxRootName rootName, int idEnt, evxReorderLoc reorderLoc, int idPreEnt);
evxErrors cvxTableSetHorHeaderList(const char* Form, int idTable, int num, const char** pHeaderList);
evxErrors cvxTableSetVerHeaderList(const char* Form, int idTable, int num, const char** pHeaderList);
evxErrors cvxTableSetHeaderAlignment(const char* Form, int idTable, int isVertical, evxTableAlignFlag align);
evxErrors cvxTableSetHeaderColResizeMode(const char* Form, int idTable, int col, evxTableResizeMode mode);
evxErrors cvxTableSetHeaderSectionSize(const char* Form, int idTable, int size, int isMin);
evxErrors cvxTableHeaderCellCheck(const char* Form, int idTable, int isVertical, int item, int check);
evxErrors cvxTableGetText(const char* Form, int idTable, int row, int col, char* text, int sizeText);
evxErrors cvxCompBomSettingSet(svx3DBomSettingsData* data);
evxErrors cvxCompBomSettingGet(svx3DBomSettingsData* data);
evxErrors cvxCompBomDispDataGet(svx3DBomData* data);
void cvxBomDataFree(svx3DBomData* data);
evxErrors cvxPartCfgTblAttrSet(int markDel,int idCfg, int cnt, evxAtItemId* types, svxAttribute* attrs);
evxErrors cvxPartCfgTblColorSet(int markDelClr, int idCfg, svxColor color);
evxErrors cvxPartCfgTblInstNameSet(int markDelInstName, int idCfg, vxLongName instanceName);
evxErrors cvxPartCfgTblVarsSet(int markDelVars, int idCfg, int cnt, svxVariable* vars);
evxErrors cvxCompBomPathByPart(const vxLongName part, int* cnt, svxEntPath** paths);
evxErrors cvxDataSetDirOnEntPath(int idData, int idField, const svxDirOnEntPath* dirData);
evxErrors cvxEntPathInit(int idEntity, int idParent, svxEntPath* entPath);
evxErrors cvxEntPathInqActive(svxEntPath* entPath);
evxErrors cvxEntPathAppendEnt(svxEntPath* entPath, int idEntity);
evxErrors cvxEntPathAppendPath(svxEntPath* dstPath, const svxEntPath *srcPath);
int cvxEntPathCmp(const svxEntPath* EntPath1, const svxEntPath* EntPath2);
int cvxEntPathGetParentComp(const svxEntPath* entPath, svxEntPath* parentComp);
void cvxPartInqLCSMat(svxMatrix* mat);
evxErrors cvxPartUDFWizardPathGetByLongPath(char* Dir, int sizeDir);
evxErrors cvxMacroInqPathByLongPath(char* path, int sizepath, char* file, int sizefile);
evxErrors cvxPartUDFInqLongPath(int idFtr, char *file,int sizefile);
evxErrors cvxCompInqPartByPathByLongPath(svxEntPath* CompPath, char* fileName,int sizeDir,vxRootName partName);
evxErrors cvxPartInqFaceTxFileByLongPath(int idFace, char* Path, int sizePath);
evxErrors cvxConfigPathGet(char *path,int sizepath);
evxErrors cvxDwgSymLinkGetByLongPath(const int idSymLink, char* filePath, int sizefile)
evxErrors cvxDwgSymLinkExportByLongPath(const int idSymLink, char* filePath, int sizefile);
evxErrors cvxDwgViewInqPartConfigByLongName(int idView, char* partCfg, int size);
void cvxFileDirectoryByLongPath(char* Directory, int sizeDire);
evxErrors cvxPathCheck(const vxLongPath srcPath, char* desPath,int sizedes);
int cvxPathApiLibByLongPath(const vxLongName LibName, char* LibDirectory,int sizeLib);
void cvxPathDirByLongPath(const vxLongPath FullPath, char* Directory,int sizeDir);
void cvxPathFileByLongPath(const vxLongPath FullPath, char* FileName,int sizeFile);
int cvxPathFindByLongPath(const vxLongName FileName, char* FullPath,int sizeFull);
void cvxPathInstallByLongPath(char*InstallDirectory,int sizeIns);
void cvxPathTempByLongPath(char* Directory,int sizeDir);
void cvxPathUserFolderByLongPath(char* Directory, int sizeDir);
evxErrors cvxPartInqFacetsTxFileByLongPath(int idBlock, char* Path,int sizePath);
int cvxPartInqFtrAssoPartByLongPath(int idFeature, char* file,int sizePath ,char* rootName,int sizeRName);
evxErrors cvxSkInqExternalSkByLongPath(int idSketch, char* fileName, int sizefile, vxRootName rootName, vxLongName skName)
void cvxGetFileByLongPath(int Open, const char* Prompt, const char* Default, const char* Filter, char* Path,int sizePath);
void cvxGetFolderByLongPath(const char* Prompt, char* Default, char* Path,int sizePath);
evxErrors cvxPartInqCompsInfoByLongPath(const vxLongPath Path,const vxRootName Name, int* Count, vxLongPath** Paths, vxRootName** Names);
evxErrors cvxCompGetRefPartByLongPath(int* Count, vxLongPath** BinName, vxRootName** RootName);
evxErrors cvxCmCompInqInfoByLongPath(int* compCnt, vxLongPath** compNames, vxLongPath** compPaths);
void cvxFileOpenListByLongPath(int* count, vxLongPath** fileList);
evxErrors cvxFileLoadListByLongPath(const int state, int* count, vxLongPath** fileList);
evxErrors cvxFileInqAssociatedListByLongPath(int* count, vxLongPath** fileList);
evxErrors cvxFileInqAssociatedListByLongName(const char* fileName, int nDepth, int* count, vxLongPath** fileList);
evxErrors cvxUDFFileInqAssociatedListByLongPath(const vxLongPath path, const vxLongPath file, int* count, vxLongPath** fileList);
evxErrors cvxPluginRegPathGetByLongPath(vxLongPath** pathList, int* pCnt, int is64);
evxErrors cvxPartUDFInsPathGetByLongPath(char* Dir, int sizeDir);
evxErrors cvxFilesSaveToByLongPath(int Count, const vxLongPath* FileList, const vxLongPath Path);
evxErrors cvxRootRenameMultiByLongPath(int Count, const vxLongPath* BinName,vxRootName* RootName,const vxLongPath* NewBinName,vxRootName* NewRootName, int fDelOrign);
evxErrors cvxFileImportMultiByLongPath(int Count, const vxLongPath* PathList, int SubFolder, const vxLongPath SavePath, evxImportType Type, const void* Setting);
evxErrors cvxFileExportMultiByLongPath(int Count, const vxLongPath* FileList, evxFileType Filter, evxExportType Type, const vxLongPath Path, void* Data);
evxErrors cvxPathComposeByLongPath(char* Path, int sizePath, const char* Name);
void cvxPathDelimByLongPath(char* Path, int sizePath);
evxErrors cvxEntBndBoxByPath(svxEntPath* path, int fTartCord, svxBndBox* bndBox);
evxErrors cvxRootSeparate(svxRootSepData* data);
evxErrors cvxRootSeparateInit(svxRootSepData* data);
evxErrors cvxAsmAddToFavorites(svxEntPath* path);
evxErrors cvxAsmRemoveFromFavorites(svxEntPath* path);
int cvxAsmFavoritesEnable(svxEntPath* path);
evxErrors cvxPartFaceFilletInit(svxFaceFlltData* data);
evxErrors cvxPartFaceFillet(const svxFaceFlltData* data, int* idFillet);
evxErrors cvxPathSearchBeginAdd(const vxLongPath SearchDirectory);
extern evxErrors cvxCompIsLightweightByPath(const svxEntPath* compPath, int* isLightweight);
extern evxErrors cvxCompLightweightSetByPath(const svxEntPath* compPaths, int compCount, int load, int isRecursive);
extern evxErrors cvxHelpDocLoad(const vxLongPath filePath);
New types:
evxOverflowType - overflow types.
svxReplaceData - shape replace data.
svxMorphToCrvData - shape morph to curve data.
svxStretchData - faces stretch data.
svxTaperData - faces taper data.
svxTwistData - faces twist data.
evxSpineType - spine type.
evxCroSecType - cross-section type.
evxSewingType - sewing type.
evxCappingType - capping type.
svxFilletBlendData - freeForm filletBlend data.
evxEdgeType - edge type.
svxCrvConvertTocData - curves convert to arc/line.
svxCrvBlendData - curve blend data
svxCrvBlendCons - curve blend constraints data
svxCrvBlendData - curve blend data
svxChamferChainData - chamfer chain data
svxIsoCrvOnFaceData - iso-curve on face data
svxIsoclineCrvData - isocline curve data
svxCrvCombinedProjData - combined projection data
svxAlignSecViewData - aligned section view data
evxCmOpClass - operation class types.
evxSmdBendType - smd bend type
evxSmdReliefLengthType - smd relief length type
svxSmdFlangeData - smd flange data
svxPntOnEntPath - point definition data
svxDirOnEntPath - direction definition data
svxRootSepData - separate root to file
svxFaceFlltData - face fillet data
svxImportPTSData - setting properties if import points from ASCII file
Modified functions:
Note:
cvxSubPartFlag - Discard this api cause the platform doesn't support this operation any more and cvxSubPartIns can do the similar things as well.
cvxXnBundle - Add return value for reporting function result.
cvxDwgTableCellsMerge - rename minRow to startRow, maxRow to endRow, minCol to startCol and endCol to endCol.
cvxPartBox, cvxPartCyl, cvxPartCone, cvxPartSphere, cvxPartEllipsoid, cvxPartExtrude, cvxPartRevolve, cvxPartSweep, cvxPartSpiralSweep,
cvxPartLoft, - command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first,
and then add a 'Add shape' feature to do the boolean add operation.
cvxPartSmdDimple, cvxPartSmdLouver, cvxPartNSided, cvxPartFilletBlend - 2800 has removed auto sew, api function need to ensure compatibility.
cvxFileImport - add support for import points from ASCII file.
This version modify the return type form "int" to "evxErrors" of many functions defined before 2800.
This version add "vxLongPath"(512 bytes) to instead of "vxPath"(256 bytes). The current file path length limit in zw3d is 256 bytes,
(256 characters for file name). For multi-byte languages like Chinese, the supported file path is too short, so we extend the file
path length limit to be consistent with Windows limit.
Modified types:
svxAttribute - change char data[256] to char data[512].
svxPartAttribute - Add a variable to store sheet code.
svxExtrudeData - add a variable FlipBoolRemoveDir for flipping bool remove direction.
svxExtrudeData - rename FlipBoolRemoveDir to FlipRemoveArea.
svxSmdReliefData - add variables upToBend, lengthType and lengthVal.
svxJTData - add variables ExportPMI to set whether to export PMI.
svxDimpleData - add a variable 'notSew' to flag whether sew shapes or not
svxLouverData - add a variable 'notSew' to flag whether sew shapes or not
svxRibData - add a variable 'idShape' to set boolean shape.
-------------------------------------------------------------------------
2731
New functions:
int cvxPartInqFaceFacets2ByTol(svxRefineFacets* RefineData, svxFacets* Facets);
int cvxPartRefineFacetsInit(svxRefineFacets* data);
int cvxCompInclude(const svxCompIncludeData* Comp, int* idComp);
int cvxCompSuppress(int idComp, int suppress);
int cvxPartHistScrollTo(int idEnt);
int cvxSkNesting(const svxSkNestingData* data);
int cvxSkNestingProfileDataInit(svxSkNestingProfileData* data);
int cvxSkNestingBlankDataInit(svxSkNestingBlankData* data);
int cvxSkNestingInit(svxSkNestingData* data);
int cvxPartEdgeDispData(int idEdge, svxEdgeDispData* data);
void cvxPartEdgeDispDataFree(svxEdgeDispData* data);
int cvxCrvInqMultiContinuity(int cnt, const int* curves, const svxCrvContinuityTolList* tols, int* cntContinuity, svxCrvContinuityData** data);
int cvxPartEqnSetWithName(const vxLongName setName, int count, svxVariable* vars);
int cvxPartEqnMoveToEqnSet(int idEqnSet, int cnt, const int* idListEqn);
int cvxPartVarAddToEqnSet(int idEqnSet, int cnt, const svxVariable* vars);
int cvxDimInqTypeEx(int idDim, evxDimTypeEx* typeEx);
int cvxCompFromAsmFtr(svxEntPath* path, int* isFromAsmFtr);
int cvxSkAddPerimeterDim(svxPerimeterDimData* data, int* idDim);
int cvxSkInqPlanes(int idSketch, int* count, int** idFaces);
int cvxMsgAreaStateGet(int* action);
int cvxDwgStyleManagerWithTextAtGet(evxDwgStyleManagerMethod type, void* data);
int cvxCrvContinuityTolListInit(svxCrvContinuityTolList* data);
int cvxMatGetPntVecs(const svxMatrix* Mat, svxPoint* Origin, svxVector* xAxis, svxVector* yAxis, svxVector* zAxis);
int cvxBndBoxCenter(const svxBndBox *Box, svxPoint* CenterPnt);
double cvxBndBoxVolume(const svxBndBox *Box);
int cvxBndBoxPntLoc(const svxBndBox* Box, const svxPoint* Point, evxPntLocation* PntLoc);
int cvxBndBoxPntDist(const svxBndBox* Box, const svxPoint* Point, double* DistMin, double* DistMax);
int cvxBndBoxDist(const svxBndBox* Box1, const svxBndBox* Box2, double* DistMin, double* DistMax);
int cvxBndBoxContain(const svxBndBox* BaseBox, const svxBndBox* OtherBox);
int cvxAxisPntProject(const svxAxis* Axis, const svxPoint* Pnt, svxPoint* ProjPnt);
int cvxAxisPntDistance(const svxAxis* Axis, const svxPoint* Pnt, double* Distance);
int cvxAxisDistance(const svxAxis* Axis1, const svxAxis* Axis2, svxPoint* PntOnAxis1, svxPoint* PntOnAxis2, int* Flag);
int cvxAxisEvalPoint(const svxAxis* Axis, double Distance, svxPoint* Point);
int cvxPlanePntProject(const svxPoint* PlnPnt, const svxVector* PlnNormal, const svxPoint* Point, const svxVector* ProjectDir, svxPoint* ProjPnt);
int cvxPlanePntDistance(const svxPoint* PlnPnt, const svxVector* PlnNormal, const svxPoint* Point, double* Distance, svxPoint* ProjPnt);
int cvxPlaneDistance(const svxPoint* PntOnPln1, const svxVector* NormalOfPln1, const svxPoint* PntOnPln2, const svxVector* NormalOfPln2, double* Distance);
int cvxPlaneEvalPoint(const svxPoint* Origin, const svxVector* xAxis, const svxVector* yAxis, double xDist, double yDist, svxPoint* Point);
int cvxIsectRayBndBox(const svxAxis* Ray, const svxBndBox* Box, svxPoint* IsectPnt);
int cvxIsectPlanePlane(const svxPoint* PntOnPln1, const svxVector* NormalOfPln1, const svxPoint* PntOnPln2, const svxVector* NormalOfPln2, svxAxis* IsectLine);
int cvxIsectBndBoxPlane(const svxBndBox* Box, const svxPoint* PntOnPln, const svxVector* NormalOfPln);
int cvxIsectBndBoxBndBox(const svxBndBox* Box1, const svxBndBox* Box2);
int cvxPartSelfXInit(svxPartSelfX* data);
int cvxPartSelfX(const svxPartSelfX* data, int* idShape);
int cvxPartPunchInit(svxPunch* data);
int cvxPartPunch(const svxPunch* data, int* idPunch);
int cvxPartDEMoveInit(evxDEMoveCopyType type, svxDEMove* data);
int cvxPartDEMove(const svxDEMove* data, int* idMove);
int cvxPartDEAlignMoveInit(evxDEAlignMoveType type, svxDEAlignMove* data);
int cvxPartDEAlignMove(const svxDEAlignMove* data, int* idMove);
int cvxPartDEDimMoveInit(evxDEDimMoveType type, svxDEDimMove* data);
int cvxPartDEDimMove(const svxDEDimMove* data, int* idMove);
int cvxPartDEOffsetInit(svxDEOffset* data);
int cvxPartDEOffset(const svxDEOffset* data, int* idOffset);
int cvxPartDEDraftInit(svxDEDraft* data);
int cvxPartDEDraft(const svxDEDraft* data, int* idDraft);
int cvxPartDECopyInit(evxDEMoveCopyType type, svxDECopy* data);
int cvxPartDECopy(const svxDECopy* data, int* idCopy);
int cvxPartDEMirrorInit(svxDEMirror* data);
int cvxPartDEMirror(const svxDEMirror* data, int* idMirror);
int cvxPartDEPtnInit(evxDEPtnType type, svxDEPattern* data);
int cvxPartDEPtn(const svxDEPattern* data, int* idPtn);
int cvxPartDEFlltInit(svxDEFllt* data);
int cvxPartDEFllt(const svxDEFllt* data, int* idFllt);
int cvxPartDERadInit(svxDERad* data);
int cvxPartDERad(const svxDERad* data, int* idRad);
int cvxCompPtnInit(evxAsmPatternType type, svxAsmPtnData* data);
int cvxCompPtn(const svxAsmPtnData* data, int* idPattern);
int cvxCompMoveInit(evxAsmMoveType type, svxAsmMove* data);
int cvxCompMove(const svxAsmMove* data);
int cvxCompMirrorInit(evxAsmMirrorType type, svxAsmMirror* data);
int cvxCompMirror(const svxAsmMirror* data, int* idMirror);
int cvxAsmCutInit(svxAsmCut* data);
int cvxAsmCut(const svxAsmCut* data, int *idCut);
int cvxAsmFilletInit(evxChamFlltType type, svxAsmFllt* data);
int cvxAsmFillet(const svxAsmFllt* data, int* idFllt);
int cvxAsmChamferInit(evxAsmChmfType type, svxAsmChmf* data);
int cvxAsmChamfer(const svxAsmChmf* data, int* idChmf);
int cvxDwgIsectSym(const svxDwgIsectSym* data, int* idSym);
int cvxDwgHoleMarkInit(evxDwgHoleMarkType type, svxDwgHoleMark* data);
int cvxDwgHoleMark(const svxDwgHoleMark* data);
int cvxSkPtnDataInit(evxSkPatternType type, svxSkPtnData* data);
int cvxSkPattern(const svxSkPtnData* Pattern, int* cnt, int** idEnts);
int cvxSkPowerTrim(const svxSkPowerTrim* pwTrim);
int cvxSkOneTouchTrim(const svxPntOnEnt* pnt);
int cvxSkTrimExtInit(svxSkTrimExt* trimExt);
int cvxSkTrimExt(const svxSkTrimExt* trimExt);
int cvxSkTrimSplitInit(svxSkTrimSplit* trimSpl);
int cvxSkTrimSplitCrv(const svxSkTrimSplit* trimSpl);
int cvxSkTrimSplitPnt(const svxSkTrimSplitPnt* trimSpl);
int cvxSkTrimSplitCorInit(svxSkTrimSplitCor* trimSpl);
int cvxSkTrimSplitCor(const svxSkTrimSplitCor* trimSpl);
int cvxSkDelBowties(const int numCrv, const int* idCrv);
int cvxSkSplitIsectInit(svxSkSplitIsect* Spl);
int cvxSkSplitIsect(const svxSkSplitIsect* Spl);
int cvxSkNgonsInit(evxSkNgonsType type, svxSkNgons* data);
int cvxSkNgons(const svxSkNgons* Spl, int* cnt, int** idEnts);
int cvxSkCopyInit(evxSkCopyType type, svxSkCopy* data);
int cvxSkCopy(const svxSkCopy* Spl, int* cnt, int** idEnts);
int cvxPartFacetsConvertToSTL(const svxFacets* facets, svxSTL* stl);
int cvxPartSTLConvertToFacets(const svxSTL* stl, svxFacets* facets);
void cvxCrashPromptDisable();
void cvxCrashPromptEnable();
int cvxPartFacetsConvertToSTL(const svxFacets* facets, svxSTL* stl);
int cvxPartSTLConvertToFacets(const svxSTL* stl, svxFacets* facets);
evxErrors cvxPartCrvIntScaleInit(int nPnt, const svxPoint* pPnts, double* startScale, double* endScale);
evxErrors cvxPtnVarTblInit(int firstNum, int secondNum, const char* dimName, svxPtnVarTbl* ptnVarTbl);
evxErrors cvxPartSmdProfFlangeProfMatInit(int idEdge, double angle, svxMatrix* skMat);
evxErrors cvxPartCrvIntScaleInit(int nPnt, const svxPoint* pPnts, double* startScale, double* endScale);
New types:
evxRefineFacetsTolType - toleranct type of refine facets.
svxRefineFacets - refine facets data.
evxSkPatternType - sketch pattern method
evxSkSpacingType - sketch pattern spacing method
evxTrimExtension - trim/extend extension method
evxTrimSplit - trim/extend extension method
evxTrimSplitCor - trim/split to corner option method
evxMechCons - assembly mechanical constraint alignment option method
evxMechConsItf - assembly mechanical constraint interference option method
evxMechConsRat - assembly mechanical constraint ratio option method
evxMechConsPath - assembly mechanical constraint path option method
evxMechConsPitch - assembly mechanical constraint pitch/yaw option method
evxMechConsRoll - assembly mechanical constraint roll option method
evxMechConsDir - assembly mechanical constraint direction option method
evxMechConsScrew - assembly mechanical constraint screw option method
evxMechConsFlip - assembly mechanical constraint flip option method
evxMechConsSlot - assembly mechanical constraint slot option method
evxMechConsVloc - assembly mechanical constraint velocity option method
evxAsmPatternType - assembly pattern method
evxAsmPtnStagger - assembly pattern stagger method
evxAsmPtnDrv - assembly pattern derive method
evxAsmPtnAlg - assembly pattern alignment method
evxAsmPtnCrv - assembly pattern curves method
evxAsmPtnBnd - assembly pattern boundary method
evxAsmMoveType - assembly move method
evxAsmMoveFrame - assembly move frame method
evxAsmMoveZSpine - assembly move z-spine method
evxAsmMoveXOrnt - assembly move x-orient method
evxAsmMirrorType - assembly mirror method
evxAsmMirrorSymm - assembly mirror self-symmetric method
evxAsmMirrorCenter - assembly mirror center method
evxAsmMirrorCategory - assembly mirror category method
evxAsmFlltArc - assembly fillet arc method
evxAsmFlltBase - assembly fillet base faces method
evxAsmFlltFace - assembly fillet fillet face method
evxAsmFlltLoop - assembly fillet loop method
evxAsmChmfType - assembly chamfer method
evxAsmChmfBase - assembly chamfer base faces method
evxAsmChmfFace - assembly chamfer fillet face method
svxSkPtnData - sketch pattern data
svxSkPowerTrim - sketch power trim data
svxSkTrimExt - sketch trim or extend data
svxSkTrimSplit - sketch trim or split data
svxSkTrimSplitPnt - sketch trim or split at point data
svxSkTrimSplitCor - sketch trim or split to corner data
svxSkSplitIsect - sketch split at intersection data
svxMechCons - part assembly mechanical constraints data
svxAsmPtnData - assembly pattern data
svxAsmMove - assembly move data
svxAsmMirror - assembly mirror data
svxAsmCut - assembly cut data
svxAsmFllt - assembly fillet data
svxAsmChmf - assembly chamfer data
svxPartSelfX - part resolveSelfX data
svxPunch - part punch data
evxDEMoveCopyType - part or assembly de move or copy method
evxDEFaceOverflow - part or assembly de move overflow method
evxDEMoveCopyFrame - part or assembly de move or copy frame method
evxDEMoveCopyZSpine - part or assembly de move or copy Z-spine method
evxDEMoveCopyXOrient - part or assembly de move or copy X-orient method
svxDEMove - part or assembly DE move data
evxDEAlignMoveType - part or assembly de align move method
svxDEAlignMove - part or assembly DE align move data
evxDEDimMoveType - part or assembly de dim move method
svxDEDimMove - part or assembly DE dim move data
evxDESideFaceType - part or assembly de side face method
evxDEIsectType - part or assembly de intersection method
svxDEOffset - part or assembly DE face offset data
evxDEDraftSideType - part or assembly de draft about side method
svxDEDraft - part or assembly DE draft data
svxDECopy - part or assembly DE copy data
svxDEMirror - part or assembly DE mirror data
evxDEPtnType - part or assembly de pattern method
evxDEPtnDerive - part or assembly de pattern derive method
evxDEPtnCrv - part or assembly de pattern at curve method
evxDEPtnBound - part or assembly de pattern boundary method
svxDEPattern - part or assembly DE pattern data
svxDEFllt - part or assembly DE modify fillet data
svxDERad - part or assembly DE modify radius data
svxDwgIsectSym - drawing intersection symbol data
evxDwgHoleMarkType - drawing sheet hole mark method
evxDwgHoleMarkPtn - drawing sheet hole mark pattern method
svxDwgHoleMark - drawing sheet hole mark data
evxSkNgonsType - sketch polygon method
svxSkNgons - sketch polygon data
evxSkCopyType - sketch copy method
evxSkCopyDir - sketch copy from point to point direction method
svxSkCopy - sketch copy data
svxCrvContinuityData - data of curve continuity.
svxCrvContinuityTolList - curve continuity tolerance list.
evxColorAppFlag - color by layer.
evxDimTypeEx - dimension type, more detailed than evxDimType.
evxDwgStyleManagerMethod - style manager type.
svxPerimeterDimData - data of perimeter dimension.
Modify types:
svxData - Add a variable to determine whether entities can be added repeatedly.
evxLineWidth - Add a variable to represent "by layer".
svxDwgSymmetryDimData - Add a variable "autoSwitchAttr".
-------------------------------------------------------------------------
2730
New functions:
int cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
int cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
int cvxPartBoxInit(svxBoxData* data);
int cvxPartInterXCurveInit(svxInterCrvData* data);
int cvxPartCylInit(svxCylData* data);
int cvxPartConeInit(svxConeData* data);
int cvxPartSphereInit(svxSphereData* data);
int cvxPartEllipsoidInit(svxEllsoData* data);
int cvxPartExtrudeInit(svxExtrudeData* data);
int cvxPartRevolveInit(svxRevolveData* data);
int cvxPartSweepInit(svxSweepData* data);
int cvxPartTrimmedPlaneInit(svxTrimPlnData* data);
int cvxPartExtendFaceInit(svxExtendData* data);
int cvxPartNSidedInit(svxNSidedData* data);
int cvxPartExplodeInit(svxExplodeData* data);
int cvxPartSetFaceAtInit(svxFaceAt* data);
int cvxPartTrimToFacesInit(svxTrimToFacesData* data);
int cvxPartChamferAllInit(svxChamFlltData* data);
int cvxChamFlltSetDataInit(svxChamFlltSetData* data);
int cvxPartFilletAllInit(svxChamFlltData* data);
int cvxPartHoleInit(evxHoleOpt HoleOpt, int type, svxHoleData* data);
int cvxPartThreadAtInit(svxThreadData* data);
int cvxPartFacesOffsetInit(svxFcsOffsetData* data);
int cvxPartFacesetSewInit(svxSewData* data);
int cvxPartShellInit(svxShellData* data);
int cvxPartCopyInit(svxCopyData* data);
int cvxPartDraftInit(evxDraftMethods method, svxDraftData* data);
int cvxPartRibInit(svxRibData* data);
int cvxPartLipInit(svxLipData* data);
int cvxPartStockInit(svxStockData* data);
int cvxPartThickenInit(svxThickenData* data);
int cvxPartDivideInit(svxDivideData* data);
int cvxPartTrimInit(svxTrimData* data);
int cvxPartInlayInit(svxInlayData* data);
int cvxPartLoftInit(svxLoftData* data);
int cvxPartShapeFaceOffsetInit(svxFaceOffData* data);
int cvxPtnDataInit(evxPatternType type, svxPtnData* data);
int cvxPartFlagHolesInit(svxFlagHoleData* data);
int cvxPartFlagExtThreadInit(svxFlagExtThreadData* data);
int cvxPartViewAddInit(svxView* data);
int cvxPartMirrorGeominit(svxMirrorGeom* data);
int cvxPartMirrorFtrInit(svxMirrorFtr* data);
int cvxPartSmdDimpleInit(svxDimpleData* data);
int cvxPartSmdCloseCornerInit(int type, svxCloseCornerData* data);
int cvxPartSmdLouverInit(svxLouverData* data);
int cvxPartSmdNormalCutinit(svxNormalCutData* data);
int cvxPartSmdPunchInit(svxPunchData* data);
int cvxPartSmdExtrudeTabInit(svxSmdExtrudeTabData* data);
int cvxPartSmdExtrudeFlangeinit(svxExtrudeFlangeData* data);
int cvxPartSmdFullFlangeInit(svxSmdFullFlangeData* data);
int cvxPartSmdProfFlangeInit(svxSmdFlangeProfData* data);
int cvxPartSmdPartialFlangeInit(svxSmdPartialFlangeData* data);
int cvxPartSmdHemFlangeInit(int hemType, svxSmdHemFlangeData* data);
int cvxPartEcadRgnSetInit(svxEcadRgnSetData* data);
int cvxSkMoveInit(evxMoveType2D type, svxMoveData2D* data);
int cvxSkEllipseInit(svxEllipse* data);
int cvxSkChamferInit(svxSkChamferData* data);
int cvxSkFilletInit(svxSkFilletData* data);
int cvxSkReadyTextInit(evxReadyTextMethods method, svxReadyText* data);
int cvxDwgCenMarkCirDimAddInit(svxCenMarkCirDimData* data);
int cvxDwgDatumTargDimAddInit(svxDatumTargDimData* data);
int cvxDwgAutoBlnAddInit(svxDwgAtBlnData* data);
int cvxDwgStkBlnAddInit(svxDwgStkBlnData* data);
int cvxDwgSymSurfNewInit(svxSymSurf* data);
int cvxDwgSymWeldNewInit(svxSymWeld* data);
int cvxDwgSymImgNewInit(svxSymImg* data);
int cvxDwgHoleCallOutDimAddinit(svxDwgHoleCallOutDim* data);
int cvxDwgCenterMarkDimAddInit(svxCenterMark* data);
int cvxDwgCenterLineDimAddInit(svxCenterLine* data);
int cvxDwgRotateViewinit(svxDwgRotView* data);
int cvxDwgTableBomInit(svxDwgBom* data);
int cvxDwgAutoDimAddInit(svxDimAuto* data);
int cvxDwgViewLayoutInit(svxViewLayoutData* data);
int cvxDwgViewAuxiliaryInit(svxAuxViewData* data);
int cvxDwgViewFullSectionInit(svxFulSecViewData* data);
int cvxDwgViewBrokenSectionInit(svxDwgBrokenSectionData* data);
int cvxDwgViewDetailInit(svxDwgDetailData* data);
int cvxDwgViewBrkLineInit(svxBrkLineData* data);
int cvxDwgViewStandardInit(svxViewStandardData* data);
int cvxTableAtSetInit(svxTableAt* data);
int cvxDwgCrossHatchInit(svxHatchAttr* data);
int cvxDwgLnrChmDimAddInit(svxDwgLnrChmDimData* data);
int cvxDispSetLightsInit(svxLight* data);
int cvxPartAddBalloon(svxPoint *TextPnt, char *text, int fImage, int idPlane, int *idDim);
int cvxPartAddCenLinDim(int idEnt, int idPlane, int *idDim);
int cvxPartAddCenMarkDim(int idEnt, int idPlane, int *idDim);
int cvxPartAddPMIText(svxPoint *TextPnt, char *text, int idPlane, int *idDim);
int cvxItemVisibleSet(const char* Form, int idField, int idItem, int state);
int cvxItemVisibleGet(const char* Form, int idField, int idItem, int* state);
int cvxPartInqCfgListByName(vxLongName fileName, vxLongName rootName, int* count, int** cfgList);
int cvxPartInqActiveCfgByName(vxLongName fileName, vxLongName rootName, int* idCfg);
int cvxPathFindByFileName(const char* fileName, char* fullPath, int sizeFullPath);
int cvxComboCurrentText(const char* sForm, int idField, char* text, int sizeText);
int cvxComboCurrentTextSet(const char* sForm, int idField, const char* text);
int cvxComboItemCount(const char* sForm, int idField, int* count);
int cvxPartInqCfgTblInfosByName(vxLongName fileName, vxLongName rootName, int idCfg, svxPartCfgInfo** partCfg);
int cvxFieldTipSet(const char* sForm, int idField, const char* tip);
int cvxPartFacetsBySTL(const vxLongName name, const svxSTL* stl, int* idBlock);
int cvxPartPntByOffsetInit(svxPntByOffset* data, int useCirPnt);
int cvxPartPntBy2LinesInit(svxPntBy2Lines* data, int useCirPnt);
int cvxPartSmdJog(const svxSmdJogData* data, int* idJog);
int cvxPartSmdJogInit(svxSmdJogData* data);
int cvxPartSmdLftFlangeInit(evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData* data);
int cvxPartSmdLftFlange(const svxSmdLoftedFlangeData* data, int* idLft);
int cvxPartSmdFoldByLineInit(svxSmdFoldByLineData* data);
int cvxPartSmdFoldByLine(const svxSmdFoldByLineData* data, int* idFbl);
int cvxPartSmdSweptFlangeInit(evxSmdCornerRelief corType, svxSmdSweptFlangeData* data);
int cvxPartSmdSweptFlange(const svxSmdSweptFlangeData* data, int* idSwept);
int cvxPartSmdExtendFlangeInit(evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData* data);
int cvxPartSmdExtendFlange(const svxSmdExtendFlangeData* data, int* idFtr);
int cvxPartSmdBendTaperDefDataInit(int taperType, svxSmdBendTaperData* data);
int cvxPartSmdBendTaperInit(evxSmdTaperSideMethod method, svxSmdBendTaperData* data);
int cvxPartSmdBendTaper(const svxSmdBendTaperData* data, int* idFtr);
int cvxPartSmdFlattenInit(svxSmdFlattenData* data);
int cvxPartSmdFlatten(const svxSmdFlattenData* data, int* idFtr);
int cvxPartSmdLnUnfoldInit(svxSmdLinearUnfoldData* data);
int cvxPartSmdLnUnfold(const svxSmdLinearUnfoldData* data, int* idFtr);
int cvxPartSmdChangeBendInit(evxSmdChangeBendType type,svxSmdChangeBendData* data);
int cvxPartSmdChangeBend(const svxSmdChangeBendData* data, int* idFtr);
int cvxPartSmdRipInit(svxSmdRipData* data);
int cvxPartSmdRip(const svxSmdRipData* data, int* idFtr);
int cvxPartSmdMarkBendInit(svxSmdMarkBendData* data);
int cvxPartSmdMarkBend(const svxSmdMarkBendData* data, int* idFtr);
int cvxEntNewAll(int startOp, evxEntType type, int* count, int** idEnts);
int cvxPntEntDist(svxPoint* Point, int idEntity, svxPoint* TargetPnt, double* Distance);
int cvxCompClearCheck(int Count, svxEntPath *Comps, double Clear, int, int, int , int *ClrCnt, svxClrChkData **ClrDatas);
int cvxUDFFileInqAssociatedList(const vxLongName path, const vxLongName file, int* count, vxPath** fileList);
int cvxPartUDFWizardPathGet(vxPath Dir);
int cvxPartUDFInsPathGet(vxPath Dir);
int cvxPartSmdReliefDataInit(svxSmdReliefData* data);
int cvxEntUserAtGet(int idEnt, int *count, svxAttribute** At);
int cvxEntUserAtSet(int idEnt, int count, svxAttribute* At);
int cvxEntUserAtDel(int idEnt, int count, svxAttribute* At);
int cvxFileExportMulti(int Count, const vxLongName* FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void* Data);
int cvxFileImportMulti(int Count, const vxLongName* PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void* Setting);
int cvxDataGetPaths(int idData, int idField, int* count, svxEntPath** paths);
int cvxDataGetPntOnEnt(int idData, int idField, svxPoint* pnt, svxEntPath* path);
int cvxDataGetPntsOnEnts(int idData, int idField, int* count, svxPoint** pnts, svxEntPath** paths);
int cvxGetPointOnEnt(const char* prompt, evxPntInpOpt opt, int emptyOk, svxPoint* point, svxEntPath* path);
int cvxGetPointsOnEnts(const char* prompt, evxPntInpOpt opt, int emptyOk, int* count, svxPoint** points, svxEntPath** paths);
int cvxPartInqPMIs(evxPMIEntType type, int* count, int** idPMIs);
int cvxPMIInqType(int idPMI, evxPMIEntType *type);
int cvxPMIInqBaseEnt(int idPMI, int* idBaseObj);
int cvxPMIInqAssoEnts(int idPMI, int* count, svxEntPath** entPaths);
int cvxPMIInqValid(int idPMI, int* isValid);
int cvxDimInqDimPnts(int idDim, int *count, svxPoint** DimPnts);
int cvxDimInqDimLines(int idDim, int *count, svxCurve** DimCrvs);
int cvxDimInqExtLines(int idDim, int *count, svxCurve** ExtCrvs);
int cvxSymInqRefPnt(int idSym, svxPoint* RefPnt);
int cvxSymInqLeadLines(int idSym, int* count, svxCurve** LeadCrvs);
int cvxDimFCSDataGet(int idFCS, int* numOfFcs, svxFCSData** FcsData, vxLongName Note1, vxLongName Note2);
int cvxPntPreEdgeDist(const svxPoint* Point, int idPreEdge, double* T, svxPoint* TargetPnt, double* Distance);
int cvxPreEdgeEval(const int idPreEdge, const double t, const int level, svxEvalCurv* eval);
int cvxFaceEvalGeom(int idFace, double U, double V, int Level, svxEvalSurf* EvalSrf);
int cvxPartHistAdd(const int idData, const vxName FtrName, const int Option, int* idFtr);
int cvxPartFaceMod(int idFace, svxSurface*, int NumCurves, svxCurve *TrimCurves, int Sew, double Tol);
int cvxAsmDissolve(const svxEntPath* path);
int cvxPartInqFtrRegenStatus(int idFtr, evxFtrRegenStatus* status);
int cvxCompIsFileLost(const svxEntPath* path, int* isFileLost);
int cvxSkMirr(const svxMirrData2D* data,int *cnt,int **idEnts);
int cvxSkMirrInit(svxMirrData2D* data);
int cvxSkConic3pt(const svxConic3ptData* Data,int* idEnt);
int cvxSkConic3ptInit(svxConic3ptData* Data);
int cvxCmOpInsFolder(int* idx_out);
int cvxCmOpDrag(int drag_idx, evxCmTreeType drag_type, int drop_idx, evxCmTreeType drop_type,int iPos);
int cvxCmObjGetTreeId(int idx_in, int* tree_id, evxCmTreeType treeType);
int cvxCmFldRename(int idx_fld, vxLongName fld_newName);
int cvxCmFrameGetActive(int* idx_actFrame);
int cvxCmFtrRename(int idx_ftr, vxLongName newFtrName);
int cvxCmProfSetAttr(int prof_idx, int curve_idx, double newOffset, double newDraft, int tolloc);
int cvxCmOpRename(int idx_op, vxLongName op_newName);
int cvxCmOpsOutputNc(int op_cnt,int* idx_opList,int* idx_nc);
int cvxCmMsgClear();
int cvxCmToolGetData(int idx_tool,evxCmToolAttr attr,char* value);
int cvxCrvInqExtreme(int idCurve, const svxVector* Dir, int *isPerp, svxPoint* Point);
int cvxFaceInqExtreme(int idFace, const svxVector* Dir, int* Count, int** idEnts, svxPoint* Point);
int cvxPartInqShapeExtreme(int idShape, const svxVector* Dir, int* Count, int** idEnts, svxPoint* Point);
int cvxDwgViewLockSet(int idView, int lock);
int cvxDwgViewLockGet(int idView, int* isLock);
int cvxSkRotate(const svxRotateData2D* data,int *cnt,int **idEnts);
int cvxFileReOpen(vxPath Name);
int cvxFileReplace(vxPath filePath, vxPath newData, int fDel);
int cvxPartInqFaceFacetsByChord(int idFace, double ChordHeight, int* Count, svxTriangle** Facets);
int cvxDwgDimAtGetBySub(int idDim, int subDim, svxDimAttr* dmAttr);
int cvxIsectRayFaceInfinite(int idFace, evxFaceTrim Trim, const svxAxis* Ray, int Infinite, int *Number, svxPoint** Pnts, svxPoint2** UVs);
void cvxFormAddTo(const char* Form, evxFormAddTo addTo);
void cvxFormRemoveFrom(const char* Form, evxFormAddTo removeFrom);
void cvxSetTitleAppend(const char* pStr);
int cvxPartPolylineInit(svxPolylineData* data);
int cvxPartModifyHoleInit(int idFace, svxHoleData* data);
int cvxPartModifyHole(int cntFace, int* pFace, const svxHoleData* data, int* idFtr));
int cvxFileInqAssociatedListByName(const char* fileName, int nDepth, int* count, vxPath** fileList);
int cvxPartPolyLine(const svxPolylineData* polylinedata, int* Cnt, int** idEnt);
int cvxPartMaterialGet(vxLongName fileName, vxLongName rootName, vxLongName material, svxPartMaterial* data);
int cvxPartMaterialSet(vxLongName fileName, vxLongName rootName, vxLongName material, const svxPartMaterial* data);
int cvxPartMaterialDel(vxLongName fileName, vxLongName rootName, vxLongName material);
Modified functions:
void cvxGetFolder() - Change the "char*" variable to "const char*".
int cvxGetEntPaths() - Change the "char*" variable to "const char*".
int cvxGetEntPath() - Change the "char*" variable to "const char*".
int cvxGetEntPathsMultiFilter() - Change the "char*" variable to "const char*".
int cvxGetEntsMultiFilter() - Change the "char*" variable to "const char*".
New types:
svxSmdJogData - template command Smd Jog data.
evxSmdJogPosition - Smd Jog Parameters Position.
evxSmdLftFlangeMethod - Lofted Flange method.
evxSmdLftCutMethod - Lofted Flange Cutting Method.
svxSmdLoftedFlangeData - template command Smd Lofted Flange data.
svxSmdFoldByLineData - template command Smd Fold by Line data.
svxSmdSweptFlangeData - template command Smd Swept Flange data.
evxSmdExtendFlangeMethod - extend flange method.
evxSmdExtendSideMethod - extend flange side method.
svxSmdExtendFlangeData - template command Smd Extend Flange data.
evxSmdTaperSideMethod - smd bend taper sides.
evxSmdWebTaperType - smd bend web taper type.
svxSmdBendTaperDefData - smd bend taper definition side data.
svxSmdBendTaperData - template command Smd bend taper data.
svxSmdFlattenData - template command Smd flatten data.
svxSmdLinearUnfoldData - template command Smd linear unfold data.
svxSmdChangeBendData - template command Smd change bend data.
evxSmdChangeBendType - change bend type.
evxSmdRipType - smd rip type.
svxSmdRipData - template command Smd rip data.
svxSmdMarkBendData - template command Smd mark bend data.
evxPMIEntType - PMI entity type
evxFCSSymbol - FCS MD&T symbol
evxFCSShapeSym - FCS area shape symbol
evxFCSLmsOption - FCS LMS option
svxFCSTol - FCS tolerance data
svxFCSDatum - FCS datum data
svxFCSData - FCS data
evxFtrRegenStatus - regen status of feature.
svxSTLData - data of export stl file
evxCmTreeType - cam tree node type
evxCmProfileCuvAttr - profile feature curve attribute
evxCmProfileTolLoc - profile feature curve tool location type
svxMirrData2D - Mirror command data
svxConic3ptData - 3 Point Conic command data
svxRotateData2D - Rotate command data
evxRotateType - Rotate type
evxRotateSetting - Rotate Setting
evxConic3PntType - 3 point conic type
svxPartMaterial - Part material physical attributes.
evsResultsAxisMethod - the position of axes
svxPntByOffset - point by "Offset" data
svxPntBy2Lines - point by "From 2 Lines" data
Modified types:
svxDwgHoleCallOutDim - Add a new variable(pnts).
svxDimAttr - Add variable to suppress/unsuppress leaderline.
Add five variables:tolChHgtFac,chSlant,chSpc,chLnSpc,chAsp.
Add symbolClr field to assign color to symbols.
svxSmdAt - Add some variables.
svxNewPlaneData - Add variables to NewPlaneGeometry to support multiple geometries and offset
- Add variables to NewPlaneThreePnt/NewviewPlane/NewPlaneDynamic to support set the points by "Offset" or "From 2 Lines" command
svxCSYSData - Add variables to CSYSByGeom to support multiple geometries, offset and position of axes
Add variables to CSYSThreePnts to support set position of axes, flip the direction of axes and set the points by "Offset" or "From 2 Lines" command
Add variables to CSYSThreeFaces to support set position of axes and flip the direction of axes
Add variables to CSYSPntAnd2Dir to support set position of axes, flip the direction of axes and set the origin point by "Offset" or "From 2 Lines" command
Add variables to CSYSPlanAndDir to support set position of axes, flip the direction and set the points by "Offset" or "From 2 Lines" command
Add variable to CSYSDynamic to support auto orientation and set the postion point by "Offset" or "From 2 Lines" command
svxDimpleData - Add variables radius3, flipFlange, prfOnDimpleTop and postion.
svxDrawingAt - Add a variable to set idSheet of template file.
evxCmOpType - Add variables to ZW_CAM_OPERATION_CORNERFINISH and ZW_CAM_OPERATION_FLATFINISH.
svxAttribute - Add a variable to get value of attribute.
svxHoleData - Add a variable to set whether the "add base" option is selected.
-------------------------------------------------------------------------
2701
New functions:
int cvxAsmGrpComp(svxAsmGrpCompData* data);
int cvxPartEllipseInit(svxRectangleData* data);
int cvxPartRectangleInit(svxRectangleData* data);
int cvxPartSplineInit(svxSplineData* data, int count);
int cvxSkSplineInit(svxSplineData* data, int count);
int cvxSplinePntInit(svxSplinePnt* data);
int cvxPartCrvIntInit(svxCrvIntData* data);
int cvxSkCrvIntInit(svxCrvIntData* data);
int cvxHatchPtnDataInit(svxHatchPtnData* data);
int cvxFileImportInit(svxImportData* data, evxImportType type, void* general);
int cvxFileExportInit(evxExportType type, int imgType, void* data);
int cvxPartViewRecord(int idView, svxView* View);
int cvxDwgSheetAdd(vxLongName Name, int* idSheet);
int cvxCompRegen(svxEntPath* Path, int flag);
int cvxGetEntsMultiFilter(char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, int **idEnts);
int cvxGetEntPathsMultiFilter(char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, svxEntPath **Paths);
int cvxDwgTableInsPntSet(int idTable, svxPoint2* pnt);
int cvxDwgInqTableType(int idTable, evxTableType* type);
int cvxDwgSymInsPointSet(int idSym, svxPoint2* pnt);
int cvxDwgSymInsPointGet(int idSym, svxPoint2* pnt);
int cvxEntGetDistanceByPath(svxEntPath* EntPath1, svxEntPath* EntPath2, svxPoint* Point1, svxPoint* Point2, double* MinDistance);
int cvxDwgTableInsPntGet(int idTable, svxPoint2* pnt);
int cvxPartHistClipbyPath(int Cut, int Count, svxEntPath* paths);
int cvxPartInqEntsArea(int cnt, int* crvList, svxAreaProp* areaProp);
int cvxPartInqEntsAreaByPath(int cnt, svxEntPath* crvList, svxAreaProp* areaProp);
int cvxFileIsUDF(const vxLongName path, const vxLongName file, int* isUDF);
int cvxCompExpandStateGet(const svxEntPath* path, int* isExpand);
int cvxCompExpandStateSet(const svxEntPath* path, int expand);
int cvxCompSelectedStateGet(const svxEntPath* path, int* isSelected);
int cvxCompSelectedStateSet(const svxEntPath* path, int selected);
int cvxUnitMassGet(evxMassUnitType* type, vxName name);
int cvxUnitMassSet(evxMassUnitType type);
int cvxSkGridSpacingGet(double* spacing);
int cvxSkGridSpacingSet(double spacing);
int cvxDwgSheetScaleGet(int idSheet, double* scale);
int cvxDwgSheetScaleSet(int idSheet, double scale);
int cvxEntUnPickByPath(const svxEntPath* path);
New types:
svxAsmGrpCompData - group as sub-assembly data.
svxImportDwgDxfData - setting properties if import dwg/dxf file.
evxDWGDXFExcludeColor - import dwg dxf file, exclude color.
evxDWGDXFConvertMeshTo - dwg dxf file import of convert polygon mesh to.
evxDWGDXFReadAsUnits - dwg dxf import options of read as units.
svxAreaProp - area property data
-------------------------------------------------------------------------
2700
New functions:
int cvxDwgAutoDimAdd(const svxDimAuto* pDimData, int* idDim);
int cvxDwgLabelDimAdd(const svxDimLabel* pLabel, int* idDim);
int cvxDwgBomTable(const svxDwgBom* pData, int idTbl);
int cvxDwgTableInsert(const svxDwgTblInsert* pData);
int cvxDwgRotateView(const svxDwgRotView* pData);
int cvxDwgLineOffsetDimAdd(const svxDwgLineOffsetDim* pData, int* idDim);
int cvxDwgHoleCallOutDimAdd(const svxDwgHoleCallOutDim* pData,int* numDim, int** idDims);
int cvxDwgLineDimAdd(const svxDwgConsDim* pData, int* idDim);
int cvxDwgBaseLineDimAdd(const svxDwgLineGrpDim* pData, int* idDim);
int cvxDwgContinuousDimAdd(const svxDwgLineGrpDim* pData, int* idDim);
int cvxDwgOrdinateDimAdd(const svxDwgOrdinateDim* pData, int* idDim);
int cvxDwgBalloonDimAdd(const svxDwgBalloonDim* pData, int* idDim);
int cvxDwgFtrCtrlDimAdd(const svxDwgFtrCtrl* pData, int* idDim);
int cvxDwgCenterMarkDimAdd(const svxCenterMark *pzCentMark, int* idDim);
int cvxDwgCenterLineDimAdd(const svxCenterLine* pzCenterLine, int* idDim);
int cvxCfgTblInfosSet(int Id,svxPartCfgInfo* info);
void cvxPartFreeCfgTbl(svxPartCfgInfo **cfginfo);
int cvxPartInqCfgTblInfos(int Id, svxPartCfgInfo** partcfg);
int cvxCompBomExcludedGet(svxEntPath EntPath, int* exclude);
int cvxPartInqAsmIsFlex(int idComp, int* isFlexible);
int cvxPartInqFlexAsmMat(svxEntPath AsmPath, svxMatrix* AsmMat);
int cvxPartInqAsmIsFlexByPath(svxEntPath AsmPath, int* isFlexible);
int cvxDispZoomLimits(void);
int cvxDispZoomIn(int ZoomIn, const svxPoint2f StartPoint, const svxPoint2f EndPoint);
int cvxDwgViewInqChildView(int idView, int* count, int** idViews);
int cvxDwgViewEntitiesAssociate(int idView, int count, int* idEnts);
int cvxDwgRegen(int count, int* idViews, int isRegenUnModifiedView, int isRegenTable, int isPrompt, int isRegenSketch);
int cvxDwgViewDottedBorderGet(int idView, svxPoint2* UpperLeft, svxPoint2* UpperRight, svxPoint2* BottomLeft, svxPoint2* BottomRight);
int cvxDwgViewLocationGet(int idView, svxPoint2* point);
int cvxDwgEntMovePntToPnt(int idEnt, svxPoint2* Start, svxPoint2* End, evxDrawingMoveDirType type, double angle, double scale);
int cvxDwgEntMoveAlongDirection(int idEnt, svxVector2* Direction, double Distance, svxPoint2* BasePoint, double angle, double scale);
int cvxDwgAlignmentGet(int idView, int* align);
int cvxDwgSymAtGet(int idSym, svxSymAttr *symAttr);
int cvxDwgSymAtSet(int idSym, svxSymAttr *symAttr);
int cvxDwgSymSurfNew(int idEnt, svxPoint2* refPoint, const svxSymSurf* data, int *idSymSurf);
int cvxDwgSymWeldNew(int idEnt, svxPoint2* refPoint, const svxSymWeld* data, int *idSymWeld);
void cvxSymWeldFree(svxSymWeld *WeldData);
int cvxDwgViewBrokenSection(svxDwgBrokenSectionData* data, int* idView);
int cvxDwgCrossHatch(int countEnts, int* idEnts, int countPnts, svxPoint2* insides, int isSplit, svxHatchAttr* hatch, int* idEnt);
int cvxDwgInqHatchAttr(int idHatch, svxHatchAttr* HatchAttr);
int cvxDwgHatchAttrSet(int idHatch, svxHatchAttr HatchAttr);
int cvxDwgHatchAssoCrvsGet(int idHatch, int* count, int** AssocCrvs);
int cvxDwgInqHatchIdByView(int idView, int* count, int** idHatchs);
int cvxDwgInqHatchIdByDrawing(int idDrawing, int* count, int** idHatchs);
void cvxBndBoxMerge(const svxBndBox *Box1, svxBndBox *Box2);
int cvxDwgCenMarkCirDimAdd(const svxCenMarkCirDimData* cmcDimData, int* idDim);
int cvxDwgDatumTargDimAdd(const svxDatumTDimData* datumTData, int* idDim);
int cvxDwgDatumDimAdd(const svxDatumDimData* datumData, int* idDim);
int cvxDwgSymmDimAdd(const svxDwgSymmDimData* dimData, int* idDim);
int cvxDwgAngDimAdd(const svxDwgAngDimData* dimData, int* idDim);
int cvxDwgArcDimAdd(const svxDwgArcDimData* dimData, int* idDim);
int cvxDwgViewDetail(const svxDwgDetailData* data, int* idView);
int cvxDwgRadDimAdd(const svxRadDimData* radDimData, int* idDim);
int cvxDwgLabelCoorDimAdd(const svxLabelCoorDimData* coorDimData, int* idDim);
int cvxDwgStkBlnAdd(const svxDwgStkBlnData* stkBlnData, int* idDimCount, int** idDimList);
int cvxDwgAutoBlnAdd(const svxDwgAtBlnData* atBlnData, int* idDimCount, int** idDimList);
int cvxDwgInqViewTypeEx(int viewId, evxViewTypeEx* viewType);
int cvxDwgLnrChmDimAdd(const svxDwgLnrChmDimData* DimData, int* idDim);
int cvxDwgViewBrkLine(const svxBrkLineData* brkLineData, int* brkLnViewId);
int cvxDwgBrkLineAtSet(int brkLnViewId, const svxDwgBrkLineAt* brkLineAt);
int cvxDwgBrkLineAtGet(int brkLnViewId, svxDwgBrkLineAt* brkLineAt);
int cvxDwgViewLayout(svxViewLayoutData* data);
int cvxDwgViewProjection(int idBaseView, svxPoint2* location, int Projection, int DimType, svxViewAt* ViewAttr, int* idProjView);
int cvxListItemToolTipSet(const char* form, int field, int row, const char* toolTip);
int cvxListItemToolTipGet(const char* form, int field, int row, char* toolTip, int size);
int cvxDataSetPntOnEnt(int idx_data, int idFld, const svxPntOnEnt* data);
int cvxConsInqConsData(int idCons, svxConsData *ConsData);
int cvxCompAddTangentCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons);
int cvxCompAddConcentricCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons);
int cvxCompAddParallelCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons);
int cvxCompAddPerpendicularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons);
int cvxCompAddAngularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons);
int cvxCompAddLockCons(svxEntPath *Comp1, svxEntPath *Comp2, svxConsData *ConsData, int *idCons);
int cvxCompAddDistanceCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons);
int cvxCompAddMiddleCons(svxEntPath *BaseEnt1, svxEntPath *BaseEnt2, int nCenter, svxEntPath *CenterEnts, svxConsData *ConsData, int *idCons);
int cvxCompAddSymmetryCons(svxEntPath *Plane, svxEntPath *SymEnt1, svxEntPath *SymEnt2, svxConsData *ConsData, int *idCons);
int cvxCompAddFrameCons(svxEntPath *Datum1, svxEntPath *Datum2, svxConsData *ConsData, int *idCons);
int cvxConsRedefine(int idCons);
int cvxDwgUserSymNew(int count, int *idEnt, svxPoint2 *BasePnt, vxLongName Name, int *idBlock);
int cvxDwgViewInqProjection(int idView, evxViewProjAngle* projection);
int cvxSkChamfer(const svxSkChamferData* chmData,int* idChamfer);
int cvxSkFillet(const svxSkFilletData* filletData, int* idFillet);int cvxDwgViewStandard(const svxViewStandardData* data, int* idView);
int cvxDwgViewStandard(const svxViewStandardData* data, int* idView);
int cvxPartGetFlatSolids(int* cnts, int** solids);
int cvxDataGetAll(int idData, int *numFld, svxFldData **fldData);
void cvxFldDataFree(int Count, svxFldData **fldData);
int cvxPartFtrInqInpEnts(int idFeature, evxEntType type, int *cnt, int **list);
int cvxPartInqFtrTol(int idFeature, double *Tolerance);
void cvxBndBoxTransform(svxMatrix *Mat, svxBndBox*Box);
int cvxDwgViewAuxiliary(const svxAuxViewData* auxViewData, int* idView);
int cvxDwgViewFullSection(const svxFulSecViewData* fulSecViewData, int* idView);
int cvxPartAxisNew(svxAxisData *Axis, int *idAxis);
int cvxCompFileSaveAs(svxEntPath* CompPath, int UpdateFlag, vxPath File);
int cvxPartCSYSNew(svxCSYSData *CSYS, int *idCSYS);
int cvxPartPlaneNew(svxPlaneData *Plane, int *idPlane);
int cvxDataSetMatrix(int idData, int idField, const svxMatrix* mat);
int cvxCmFtrInsertWithoutHoles(evxCmFtrType ftrType,vxName ftrName,int cnt,int *geom,int *idxFtrGrp);
int cvxCmFtrInsertSK(evxCmFtrType ftrType,vxName ftrName,int idxSk,int cnt,int *geom,int *idxFtrGrp);
int cvxCmFtrGetComp(int *comp_cnt,int **idxComp);
int cvxCmGetCrvId(int *numLine,int **lstLines);
int cvxCmFtrInsertHole(vxName ftrName,int cnt,int *geom,double *depths,int *idxFtrGrp);
int cvxCmPlanDispSetMode(evxCmPlanDispMode iMode);
int cvxCmFrameGetMatrix(int idxFrame,svxMatrix *frameMat);
int cvxCmOpAddFrame(int idxOp,int idxFrame);
int cvxCmPlanSkNew(svxMatrix *Plane, int *idEnt);
int cvxPartFaceMesh(int idFace, double chord, double sideSize, int *count, svxTriangle **pnts);
int cvxPartFaceMeshPnts(int idFace, double chord, double sideSize, int *count, svxPoint **pnts);
int cvxPartFtrSuppress(int count, int* idFeatures, char suppress);
int cvxFaceReverseDir(int numFaces, int *idFaces)
int cvxPartSpline(const svxSplineData* PntData, int *idEnt);
int cvxSkSpline(const svxSplineData* PntData, int *idEnt);
int cvxPartNSided(const svxNSidedData * NSidedData, int *idShape);
int cvxPartExplode(const svxExplodeData *ExplodeData, int *numShape, int **idShapes);
int cvxDimIsRadius(int idDim, int* isRadius);
int cvxPopupDefine(const char* name);
int cvxPopupSubMenuSetVisible(const char* name, const char* sub, int visible);
int cvxPopupSubMenuItemInsert(const char* Name, const char* Sub, int index, const char* ActName, const char* Label, const char* Script, const char* Icon);
int cvxPopupSubMenuSeparatorInsert(const char* Name, const char* Sub);
int cvxPopupSubMenuItemRemove(const char* name, const char* Sub, int index);
int cvxPopupMenuCnt(const char* Name, int* cnt);
int cvxPopupSubMenuCnt(const char* Name, const char* Sub, int* cnt);
int cvxPopupSubMenuActionsRemove(const char* Name, const char* Sub, int iFirst, int iLast);
int cvxPopupItemSetVisibleByAction(const char* name, const char* action, int visible);
int cvxPopupItemSetEnabledByAction(const char* name, const char* action, int enabled);
int cvxPopupItemSetCheckedByAction(const char* name, const char* action, int checked);
int cvxPopupItemIsExist(const char* name, const char* action);
int cvxPopupUpdate(const char* Name);
int cvxPopupItemActionGet(const char* name, int item, char* Action, int nByte);
int cvxPopupItemLabelGet(const char* name, int item, char* Label, int nByte);
int cvxPopupItemVisibleGet(const char* name, int item, int* Visible);
int cvxPopupItemRemove(const char* name, int index);
int cvxPopupItemInsert(const char* name, int index, const char* Label, const char* Action);
int cvxPopupItemSetAction(const char* name, int index, const char* Action);
int cvxPopupItemCheckedGet(const char* name, int group, int item, int* Check);
void cvxTreeSetHeaderIcon(const char* name, int field, int section, const char* icon);
int cvxPartInqSmdStatFace(int idShape, int* idFace);
int cvxPartSmdStatFaceSet(int idFace, int* idFtr);
int cvxPartInqFlattens(int* count, int** idFlattens, vxLongName** flattenNames);
int cvxPartSmdFlatSolidExport(int idFlatten, evxExportType type, vxPath filePath,void* data);
int cvxPartSmdFlatPatternExport(int idFlatten, vxPath filePath, const svxDWGData* data);
int cvxPartFtrIsUDF(int idFtr, int* isUDF);
int cvxPartUDFReplace(int idFtr, const vxPath file);
int cvxCmFolderInqOps(vxLongName folder_name,int *op_cnt,int **op_list);
int cvxPartInqSmdStatFcs(int idShape, int* countStat, int** statFcs, int* countPair, int** pairStatFcs);
int cvxRootInqSheetMetal(vxLongName file, vxLongName part, int *shtMetal);
int cvxPartInqShtMetalThick(int idShape, double* thick);
int cvxPartInqSmdPairFaces(int idFace, int *count, int **faces);
int cvxPartInqSmdSrfType(int idFace, evxSmdSurfaceType* type);
int cvxDwgViewInqPartConfig(int idView, vxName partCfg);
void cvxNotifyExit(int opt);
void cvxVersionNum(vxLongName verNum);
int cvxSkAxis(const svxSkAxisData *Axis, int *idAxis);
int cvxPartShell(const svxShellData *Shell, int *idShell);
int cvxPartMove(const svxMoveData *Move, int *idMove);
int cvxPartCopy(const svxCopyData *Copy, int *idCopy);
int cvxPartDraft(const svxDraftData *Draft, int *idDraft);
int cvxSkReadyText(const svxReadyText *RdText, int *idRdText);
int cvxFtrIsSubPart(int idFtr);
int cvxMatToEuler(evxEulerAngSeq Seq, svxMatrix *pMat, svxMatEuler *pzMatEuler);
int cvxMatFromEuler(evxEulerAngSeq Seq, const svxMatEuler *pzMatEuler, svxMatrix*pMat);
int cvxPartEcadRgnSet(const svxEcadRgnSetData* pRgnSetData, int *idFtr);
int cvxPartEcadRgnCut(int idSketch, int *idFtr);
void cvxFontMap(const char* zw3dFont, vxLongName font);
int cvxSkAutoCons(svxConsGeom *BasePnt, int Count, int *idEnts);
int cvxSrfFindPoles(svxSurface*, double tol, int poles[4]);
int cvxSrfGetPole(svxSurface*srf, const svxPoint *dir, svxPoint*pnt);
void cvxSrfPrimFree(svxSrfPrim *SrfPrim);
int cvxComboCurrentItem(const char* sForm, int fldId, int* curIdx);
int cvxComboSetCurrentItem(const char* sForm, int field, int item);
int cvxPartFtrInqAuxFtrs(int idFtr, int* count, int** idAuxFtrs);
int cvxPartFacesOffset(const svxFcsOffsetData* data, int* idFtr);
int cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
int cvxPartTrimToCrvs(const svxTrimToCurvesData* trimData, int* idTrim);
int cvxPartInqGroupFtrs(int idGroup, int* count, int** ftrList);
int cvxPartInqGroupList(int* count, int** groups);
int cvxPartCosSkPlane(const svxSketchData* SkData, int isAddHatPtn, const svxHatchPtnData* PatData, int *idSketch);
int cvxSkMove(const svxMoveData2D* data);
int cvxPartTrimToFaces(const svxTrimToFacesData *data, int *idTrim);
int cvxPartFlagHoles(const svxFlagHoleData* data, int* idFtr);
int cvxPartFlagExtThread(const svxFlagExtThreadData* data, int* idFtr);
int cvxCompIsectShpShp(const svxEntPath* basePath, const svxEntPath* opPath, evxFaceTrim trim, int* count, svxCurve** curves);
int cvxRootActivateLoadAsmCtx(vxLongName File, vxLongName Name, int isLoad);
int cvxCompInqOpenShapes(svxEntPath *CompPath, int IgnoreHide, int *numShps, svxEntPath **shpPaths);
int cvxCompShapeInqOpenEdges(svxEntPath *ShpPath, int *numEdg, svxEntPath **edgPaths);
int cvxDwgInqSymObjList(int idSym, int* count, int** listId);
int cvxSkInqAllAxisById(int idSketch, int* count, int** idEnts);
int cvxSkInqCnsById(int idSketch, int* count, int** idEnts);
int cvxSkInqGeomById(int idSketch, int* count, int** idEnts);
int cvxSkInqGeomXById(int idSketch, int* count, int** idEnts);
int cvxSkInqPntById(int idSketch, int* count, int** idEnts);
int cvxSkInqRefById(int idSketch, int* count, int** idEnts);
int cvxSkInqTextById(int idSketch, int* count, int** idEnts);
int cvxPlaneGetData(int idPlane, svxPlaneData* Plane);
int cvxAxisGetData(int idAxis, svxAxisData* Axis);
int cvxCSYSGetData(int idCSYS, svxCSYSData* CSYS);
int cvxViewIsSection(int idView);
int cvxPartInqTempData(int idPart, int* count, int** datas);
int cvxDwgInqBundleDataByDim(int idDim, int* count, svxDwgBundlDimData** data);
int cvxEntInqPicked(int* Count, int** Ents);
int cvxEntInqPathPicked(int* Count, svxEntPath** Paths);
int cvxCompIsUnplacedByPath(const svxEntPath* path, int* isUnplaced);
int cvxCompCfgIdGet(const svxEntPath* path, int* idCfg);
int cvxCompCfgIdSet(const svxEntPath* path, int idCfg);
int cvxPartFtrIsMissRef(int idFeature, char* status);
int cvxPartShowPreview(vxLongName fileName, vxLongName rootName);
int cvxRootInqModByName(vxLongName fileName, vxLongName rootName, int* mod);
int cvxCompEditPartByPath(svxEntPath *compPath);
int cvxPartUDFWizardPathSet(const vxPath path);
int cvxPartUDFInsPathSet(const vxPath path);
int cvxSkAutoAddCoinConsSkipRefGeom(int idSketch, int skipFlag, int solveFlag);
int cvxViewIsStandard(int idView);
int cvxViewActivate(int idView);
int cvxViewInqStandardType(int idView, evxViewStd* type);
int cvxDwgInqDimByView(int idView, int* count, int** idDims);
int cvxDwgInqDimByDrawing(int idDrawing, int* count, int** idDims);
Modify types:
svxRevolveData - Add idAxis and idParent to support that the Axis can be on an entity.
svxViewAt - Add fScaleType to support that the scale type can be selected.
Add dSclRatioX ,dSclRatioY and dScale to support that the view scale can be set.
svxSymSurf - Add some variables to support leader point.
svxSymWeld - Add some variables to support jog points and leader points.
svxPdfData - Add three variables to support set text output, line width scale factor and export multiple sheet to one pdf file.
svxImportData - Add a variable to support that the general properties can be set.
svxDimAttr - Add five variables.
svxReadyText - Add some variables to support create the ready skethc text by different methods.
svxExtrudeData - Add some variables to support set the start/end value by different methods, set the start/end offset value, set the cap type and offset type.
svxRevolveData - Add some variables to support set the start/end value by different methods, offset type and end cap type.
svxSweepData - Add some variables to support set the X-axis/Z-axis by different methods, offset type and end cap type.
svxChamFlltData - Add some variables to support set-list data, set the radius/setback by "To Point", the offset type of the Chamer feature.
evxExtNumMethod - rename it evxDistanceMethod, this method can be used with many commands.
svxPartCalcAttrData - Add two variables.
svxHoleData - Add some variable.
svxPtnData - Add some variable to support set the toggle position.
svxSmdExtrudeTabData - Add new variable "idMergeShape", the mereged shape must be set since 2700.
New types:
evxAutoEntType - Auto Dimension select geometry entity type
evxAutoDimType - Auto Dimension dimension type
evxAutoPlacement - Auto Dimension placement
evxAutoInclude - Auto Dimension Including
svxAutoSet - Auto Dimension seting
svxDimAuto - Auto Dimension data
svxDimLabel - Label data
svxDwgBom - BOM Data
evxBomset - BOM Settings
evxOrderType - BOM Order
evxIndentedType - BOM Indented
evxLevelSet - BOM Level Settings
svxDwgTblInsert - Insert Table
evxOriginType - Insert Table Origin
evxRotViewType - Rotate View Type
evxAxisType - axis type
svxDwgRotView - Rotate View
svxDwgHoleCallOutDim - Hole callout data
svxDwgConsDim - constraint data
svxDwgLineOffsetDim - Linear Offset data
svxDwgLineDim - Linear data
svxDwgLineGrpDim - BaseLine Continuous data
svxDwgOrdinateDim - Ordinate data
svxDwgBalloonDim - Balloon data
evxDimLineOffset - DmOff type
evxDimLineType - DmLin type
evxDimLineMode - DmLinGrp mode
evxBalloonCon - Balloon text condition
evxCalloutEmt - Hole callout element
svxDwgFtrCtrl - Feature Control data
svxCenterMark - Center Mark data
svxCenterLine - Center Line data
evxCenterLineType - Center Line type
evxCentDimType - Center Mark type
evxDrawingMoveDirType - Drawing move direction type.
evxCfgThreadCmd - Hole type
svxCf - conversion factor
svxPartCfgInfo - config table infos
evxDwgBndMethod - Drawing Broken Section Boundary Method
evxDwgDepthType - Drawing Broken Section Depth type
svxDwgBrokenSectionData - Drawing Broken Section input infos
svxSymAttr - Attribute data of symbol in drawing.
svxHatchAttr - hatch attributes
evxLineWidth - line width
evxHatchType - hatch type
evxHatchPtnType - hatch pattern method
svxPartDimAttr - dimension attribute data in part
evxViewLocationType - drawing view location type
svxViewLocationData - drawing view location data
svxViewLayoutMethod - drawing view layout method
svxViewLayoutData - drawing view layout data
svxConsData - custom data of assembly constraint
svxCenMarkCirDimData - center mark circle dim data
evxDatumTargDimType - datum target dim type
svxDatumTargDimData - datum target dim data
svxDwgDetailData - detail data
evxDatumDimType - datum dim type
svxDatumDimData - datum dim data
evxSymmDimType - symmetry dim type
svxDwgSymmDimData - symmetry dim data
evxAngDimType - angular dim type
svxDwgAngDimData - angular dim data
svxDwgArcDimData - arc dim data
evxRadDimType - radial or diametric dim type
svxRadDimData - radial or diametric dim data
svxLabelCoorDimData - label coordinate dimension data
svxPntOnEnt - point on the entity data
evxViewProjAngle - drawing view projection angle
svxViewStandardData - drawing view standard data
svxFldData - data of the field
evxPlaneMethods - Plane Methods
evxPlaneAlign - Plane Orientation Align type
svxImportUGData - setting properties if import prt file
svxImportSTEPData - setting general properties if import stp/step file
svxPlaneData - template command Plane input data
evxAxisMethods - Axis Methods
svxAxisData - template command Axis input data
evxCSYSMethods - CSYS Methods
svxCSYSData - template command CSYS input data
svxSplineData - 3d/2d spline data
svxSplinePnt - 3d/2d spline points data
evxPlacingType - placing type of spline command
svxNSidedData - N-Sided command data
evxRefitOpt - refit option of N-Sided command
svxExplodeData - Explode command data
svxSkAxisData - sketch axis command data
evxExportExcludeColor - exclude color
evxExportExcludeWidthStyle - exclude width and style
svxFcsOffsetData - faces offset data
evxNewPlaneMethods - New Plane Methods
evxOnCrvDirType - Plane direction type
svxNewPlaneData - New template command Plane input data
svxTrimToCurvesData - template command Trim to Curves input data
evxTrimCrvsProjtype - projection types of "trim to curves"
svxHatchPtnData - cosmetic sketch hatch pattern definition data.
evxMoveType2D - Move and Copy Methods(2D)
svxMoveData2D - template command Move data(2D)
svxMovePntToPnt2D - copy/move entities form point to point (2D)
svxAlongDir2D - copy/move entities along a direction (2D)
svxShellData - sShell command data
svxMoveData - Move command data
svxCopyData - Copy command data
svxDraftData - Draft command data
evxSmdSurfaceType - Sheet Metal surface type
evxEulerAngSeq - two categories of rotation sequences for Euler angles
svxMatEuler - euler angles and translate vector
evxClearHoleType - hole type of clearance hole
evxHoleOpt - hole option
evxFlagThreadDepthType - flagged as thread hole depth type
svxFlagHoleData - flag hole data
evxThreadHoleClass - thread class for flag holes
svxEcadRgnSetData - Ecad regen set data
svxDwgBundleDimData - data of dimension bundle
svxTrimToFacesData - Trim to faces command data
-------------------------------------------------------------------------
26.31
New functions:
int cvxDataSetPntOnEnt(int idx_data, int idFld, const svxPntOnEnt* data);
int cvxPartSmdUnfold(const svxUnfoldData *Unfold, int *idSmdUnfold);
int cvxPartSmdFold(const svxFoldData *Fold, int *idSmdFold);
int cvxPartSmdCloseCorner(const svxCloseCornerData* CornerData, int *idSmdCorner);
int cvxPartSmdAtGet(svxSmdAt* at);
int cvxPartSmdAtSet(const svxSmdAt* at);
int cvxPartSmdLouver(const svxLouverData *LouverData, int *idSmdLouver);
int cvxPartMkEntExternal(int idEnt, int external);
int cvxPartSmdNormalCut(const svxNormalCutData* pData, int* numShape, int** idShapes);
int cvxPartSmdPunch(const svxPunchData* pData, int* idShape);
void cvxSkRegen();
int cvxSkInqDimType(int idDim, evxConsDimType *type);
int cvxSkAutoAddCoinCons(int idSketch)
int cvxCrvMinMaxRad(int idCurve, double* minRad, double* maxRad, int* isFlat);
int cvxPartSmdExtrudeTab(const svxSmdExtrudeTabData* data, int* idExtTab);
int cvxPartSmdExtrudeFlange(const svxExtrudeFlangeData* data, int* idExtFlange);
int cvxPartSmdFullFlange(const svxSmdFullFlangeData* data, int* idFull);
int cvxPartSmdProfFlange(const svxSmdFlangeProfData* data, int* idFlange);
int cvxPartSmdPartialFlange(const svxSmdPartialFlangeData* data, int* idPartial);
int cvxPartSmdHemFlange(const svxSmdHemFlangeData* data, int* idHem);
int cvxFilesSaveTo(int Count, vxLongName *FileList, vxPath Path);
int cvxEqLoadFile(vxPath Path,evxEqnSetOpt option);
New types:
svxPntOnEnt - point on the entity data
svxUnfoldData - unfold command data
svxFoldData - fold command data
svxCloseCornerData - close corner data
svxSmdAt - sheet metal attribute
evxSkChamferOpt - option of chamfer
evxSkChamferTrimOpt - option of trim in chamfer
evxSkChamferExtenOpt - control the path of extended curves and faces in chamfer
svxSkChamferData - information of chamfer
svxSkFilletData - information of fillet
svxLouverData - louver command data
svxNormalCutData - normal cut command data
svxPunchData - punch command data
evxSmdKFactorType - K-factor Definition type
evxSmdPosition - Smd Flange Parameters Position
evxSmdBendLengthType - Smd Bend Attributes Length type
evxSmdRelief - Smd Relief type
svxSmdReliefData - Smd Relief data
evxSmdCornerRelief - Smd Relief type of Corner Attributes
svxSmdFullFlangeData - template command Smd Full Flange data
evxSmdHemBendType - Smd Bend Type of Hem Flange
svxSmdFlangeProfData - template command Smd Flange with Profile data
svxSmdPartialFlangeData - template command Smd Partial Flange data
svxSmdHemFlangeData - template command Smd Hem Flange data
evxSmdCalCustom - the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom
evxExtFlangeType - Smd extrude type
evxViewPrjAngType - view projection type
evxViewDimType - view dimension type
svxPrjSetting - Projection or Auxiliary view's projection settings
svxViewArrow - view projection arrow
svxAuxViewData - Auxiliary view data
evxSecMtdType - section method type
evxLocType - section location
svxViewSecMtd - section method
svxViewSecLine - section line
svxViewSecOp - section option
svxFulSecViewData - full section view data
evxExtNumMethod - the distance method of the distance field
svxSrfPrim - add svxSurface data
-------------------------------------------------------------------------
26.30
New functions:
int cvxSkInqAllAxis(int *Count, int **idEnts);
int cvxAxisInqDir(int idAxis, svxPoint *pPnt, svxPoint *pDir);
int cvxSkInqAxisDir(int idAxis, svxPoint2 *pPnt, svxPoint2 *pDir);
int cvxPartInqDimIdxs(vxLongName File, vxLongName Part, int *Count, int**IdList);
int cvxPartFacesetSew(int count, int *shapes, svxSewData* param, int *newFtr);
int cvxPartTrimmedPlane(svxTrimPlnData *data, int *newShp);
int cvxFileInqSubType(vxPath fileName, evxFileSubtype *fileSubtype);
int cvxSkIsExternal(int IdSketch);
int cvxSkInqExternalSk(int idSketch, vxLongName fileName, vxLongName rootName, vxLongName skName);
int cvxPartInqFtrAssoPart(int idFeature, vxLongName file, vxLongName part);
int cvxDwgUserSymObjGet(const int idSymUser, int *nObj, int** idObjs);
int cvxDwgSetRefPart(const char *File, const char *Root, int idxView, svxCompName *oldPart, svxCompName *newPart);
int cvxFaceIsPlanar(int idFace);
int cvxCrvIsLine(int idCurve);
int cvxPartRib(svxRibData *Rib, int *idRib);
int cvxPartLip(svxLipData *Lip, int *idLip);
int cvxPartStock(svxStockData *Stock, int *idShape);
int cvxPartThicken(svxThickenData *Thicken, int *idShape);
int cvxPartDivide(svxDivideData *Divide, int *numShape, int **idShapes);
int cvxPartSimplify(int numEnts, int *idEnts, int *idSimplify);
int cvxPartInlay(svxInlayData *Inlay, int *idInlay);
int cvxPartSmdDimple(svxDimpleData *Dimple, int *idDimple);
int cvxPartMirrorGeom(svxMirrorGeom *Mirror, int *NumNewEnts, int **idNewEnts);
int cvxPartMirrorFtr(svxMirrorFtr *Mirror, int *idFtr);
int cvxFaceRadialIntegrity(int idFace, double *URatio, double *VRatio);
int cvxVecParallelChk(int Orient, svxVector *V1, svxVector *V2, double CosTol);
int cvxPntEntLoc(svxPoint *Pnt, int idEntity, evxPntLocation *PntLoc);
int cvxMatPntVecs(svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxMatrix *Mat);
int cvxPartInqEdgeOpen(int idEdge);
int cvxPartCurveChainFind(int nSeeds, int *idSeeds, int type, int *Count, int **idCrvs);
int cvxPartFaceEdgesFind(int nSeeds, int *idSeeds, evxEdgeLoopType type, int *Count, int **idEdges);
int cvxPartActiveAsLCS(int id);
int cvxPartInqEdgeShape(int idEdge, int *idShape);
int cvxPartExtendFace(svxExtendData *data, int*newFtr);
int cvxPartInqEqnAssociatedSet(int idEqn, int* idSet);
int cvxPartEqnDelete(int idEqn);
int cvxPartVarGetById(int idEqn, svxVariable* Variable);
int cvxEqGetDescById(int idEqn, char* desc, int size);
int cvxEqSetDescById(int idEqn, char* desc);
int cvxEqRegen(int idEqn);
int cvxPartInqEqnAllId(int* cntList, int** idList, int* cntSets, int** idSets);
int cvxPartInqEqnSetMembers(int idSet, int* count, int** idList);
int cvxFormGetSize(const char* Form, int *Width, int *Height);
int cvxFormResize(char* Form, int Width, int Height);
int cvxFormAdjustSize(const char* Form);
int cvxTreeGetColumnCount(const char* form, int field);
int cvxTreeGetColumnWidth(const char* form, int field, int col);
void cvxTreeSetColumnHidden(const char* form, int field, int col, int hide);
int cvxTreeIsColumnHidden(const char* form, int field, int col);
int cvxTreeSetItemFlag(const char*form, int field, int count, int *ids, int flag);
int cvxTreeGetItemFlag(const char*form, int field, int id, int* flag);
int cvxTreeSetItemTextColor(const char*form, int field, int id, int col, svxColor* color);
int cvxTreeDeleteSubItem(const char*form, int field, int id);
int cvxTreeEditItemByComboBox(const char *form, int field, int id, int col, const char *Options, const char *Images, int curIndex);
int cvxTreeItemIsExpand(const char*form, int field, int id);
int cvxTreeExpandItem(const char*form, int field, int id, int option);
void cvxTreeExpandAll(const char*form, int field);
void cvxTreeCollapseAll(const char*form, int field);
int cvxTreeAutoResizeColumn(const char *form, int field, int col);
int cvxCmdExecWithOut(int idData, int *idOut);
int cvxSkEllipse(svxEllipse *ellipse, int *idEnt);
int cvxPartSkPlane(svxSketchData *SkData, int *idSketch);
int cvxPartLoft(svxLoftData *Loft, int *idShape);
int cvxPartShapeFaceOffset(svxFaceOffData *Offset, int *idOffset);
int cvxPartPatternGeom(int Count, int *idEnts, const svxPtnGeom *Pattern, int *idPattern);
int cvxPartPatternFtr(int Count, int *idFtrs, const svxPtnFtr *Pattern, int *idPattern);
int cvxPartInterXCurve(const svxInterCrvData *pSurf, int *idFtr);
int cvxPartCone(svxConeData *Cone, int *idShape);
int cvxPartSphere(svxSphereData *Sphere, int *idShape);
int cvxPartEllipsoid(svxEllsoData *Ellso, int *idShape);
int cvxEntPathAddPick(svxEntPath *entPath);
int cvxSkPnt(svxPoint2 *Point, int *idEnt);
int cvxSkSetWireType(int nEnt, int *idEnt, int type);
int cvxMacroInqPath(vxPath path, vxLongName file);
int cvxListCallbackParamGet(const char* form, int idField, svxListCallBackParam* param);
int cvxPartTrim(svxTrimData *Trim, int *numShape, int **idShapes);
int cvxDimInqTxtPnt(int idDim, svxPoint *TextPnt);
int cvxDimModTxtPnt(int idDim, int center, svxPoint *TextPnt);
int cvxDimInqDimBundles(int idDim, int *Number, int **idBundles);
int cvxDimInqTextType(int idDim, int *Type);
int cvxDimModTextType(int idDim, int Type, char* text);
int cvxPartChamferAll(const svxChamFlltData *Chamfer, int *idChamfer);
int cvxPartFilletAll(const svxChamFlltData *Fillet, int *idFillet);
void cvxTableCellTipSet(const char* Form, int idTable, int Row, int Col, const char* tip);
void cvxTableCellTipGet(const char* Form, int idTable, int Row, int Col, char* tip, int nBytes);
int cvxPartFtrUserAtGet(int idFeature, int *Count, svxAttribute** UserAt);
int cvxPartFtrUserAtSet(int idFeature, int Count, svxAttribute* UserAt);
int cvxPartFtrUserAtDel(int idFeature, int Count, svxAttribute* UserAt);
int cvxCompUserAtGet(svxEntPath *Comp, int *Count, svxAttribute** UserAt);
int cvxCompUserAtSet(svxEntPath *Comp, int Count, svxAttribute* UserAt);
int cvxCompUserAtDel(svxEntPath *Comp, int Count, svxAttribute* UserAt);
int cvxCmCompInqInfo(int *compCnt,vxLongName **compNames,vxLongName **compPaths);
int cvxCmSetOpPoint(int idx_op,svxPoint p0,int field);
int cvxCmSetOpPoints(int idx_op,int num,svxPoint *pts,int field);
int cvxCmFtrInsertNew(evxCmFtrType ftrType,int cnt,int *geom,double *depths,int *idx_FtrGrp);
New types:
svxSewData - faceset sew data
svxTrimPlnData - trimmed plane data
svxExtendData - Extend face data
svxPARAData - Parasolid export data
svxCAT5Data - CATIA V5 export data
svxHTMLData - Html export data
svxListCallBackParam - Listwidget Event data
evxUiEvt - Listwidget Event type
svxDivideData - Divide command data
svxTrimData - Trim command data
svxPtnGeom - Pattern geometry data
svxPtnFtr - Pattern feature data
svxPtnData - Pattern command base input data(the same input of "Pattern geometry" and "Pattern feature")
-------------------------------------------------------------------------
26.11
New functions:
int cvxPartInqAsmFtrList( vxLongName File, vxLongName Part, int *Count, int **Features);
int cvxPartUDFInit(vxPath udfPath);
int cvxPartUDFInqFlds(int *cnt, svxUDFParam** fldParams);
void cvxPartUDFTerm();
int cvxPartUDFExplode(int idFtr);
int cvxPartUDFInqPath(int idFtr, vxPath file);
int cvxPartUDFInqSubFtrs(int idFtr, int* count, int** ftrList);
int cvxPartInqFaceSrfPrim(int idFace, svxSrfPrim *SrfPrim);
int cvxFaceIsConcave(int idFace);
int cvxIsectRayShapes(int nShapes, int *idShapes, evxFaceTrim, svxAxis*, int *Number, svxPoint**, int**);
int cvxIsectRayComps(int nComps, svxEntPath *CompPaths, evxFaceTrim, svxAxis*, int *Number, svxPoint** Points, svxEntPath** FacePaths);
int cvxCompInqPartByPath(svxEntPath *CompPath, vxLongName fileName, vxLongName partName);
int cvxDwgInqViewMod(int idDrawing, int *modified);
int cvxViewSetBndBox(double Scale, const svxBndBox *BndBox);
int cvxSkInqPlane(int idSketch, svxEntPath *plnPath);
int cvxPartInqAsmFolders(vxLongName File, vxLongName Part, int type, int *count, int **Folders);
int cvxPartInqAsmFldChildEnts(vxLongName File, vxLongName Part, int idFolder, int incSubFld, int *count, int **Ents);
int cvxSkInqReadyText(int idSketch, int *Count, int **idEnts);
int cvxSkReadyTextInqText(int idRdText, char **Text, vxLongName Font, double *Size, int *Style, double *Spacing);
int cvxSkReadyTextModText(int idRdText, char *Text, vxLongName Font, double Size, int Style, double Spacing);
int cvxSkReadyTextInqCrvs(int idRdText, int *Count, int **idCrvs);
int cvxSkAddGeomCons(evxGeomConsType type, int subType, int nGeoms, svxConsGeom *geoms, int *Count, int **idCons);
int cvxSkInqCnsType(int idCons, evxGeomConsType *type, int *subType);
int cvxSkInqCnsGeoms(int idCons, int *Count, svxConsGeom **geoms);
int cvxPartInqPMIDimEnts(int idDim, int *Count, svxEntPath **EntPaths);
int cvxSkInqAxis(int idSketch, int *xAxis, int* yAxis);
int cvxDimInqState(int idDim, evxDimState *state);
void cvxReadyTextFree(svxReadyText *RdText);
int cvxPartInqEntBox(int idEnt, svxMatrix *Mat, svxBndBox *Box);
int cvxPartFaceFind(svxFaceFind *findData, int *Count, int **idFaces);
New types:
svxSrfPrim - 3D NURB surface type
-------------------------------------------------------------------------
26.00
New functions:
int cvxLayerInqEnts(int Number, int *numEnt, int **idEnts);
int cvxDwgViewRefCompVisSet(int idView, vxLongName fileName, vxLongName partName, int show);
int cvxPartAddAngleDim(int idEnt1, int idEnt2, svxPoint *TextPnt, int idPlane, int *idDim);
int cvxPartAddChamferDim(int idEnt1, int idEnt2, svxPoint *TextPos, int idPlane, int *idDim);
int cvxPartAddRadDim(int idEnt1, int radRype, const char *, svxPoint *TextPos, int idPlane, int *idDim);
int cvxPartAddArcDim(int idEnt, const char *text, svxPoint *TextPnt, int idPlane, int *idDim);
int cvxPartAddDatumDim(int idEnt1, svxPoint *leadPnt, svxPoint *TextPos, char *text, int idPlane, int *idDim);
int cvxPartAddDatumTargetDim(int idEnt1, int radRype, double diameter, double width, double height, svxPoint *leadPnt, svxPoint *txtPos, char *text, int idPlane, int *idDim);
int cvxPartAddFcsDim(int idEnt1, svxPoint *leadPnt, svxPoint *TextPos, char *text, int idPlane, int *idDim);
int cvxPartAddSymSrfDim(int idEnt1, svxPoint *leadPnt, svxPoint *TextPos, svxRoughTexts *textGrp, int idPlane, int *idDim);
int cvxPartAddLabelDim(int idEnt1, svxPoint *leadPnt, svxPoint *TextPos, char *text, int idPlane, int *idDim);
int cvxAppAction(evxAppAction type, svxAppActionParam* param);
int cvxDwgViewRefEntAtGet(int idRefEnt, int *clrByView, int *typeByView, int *widthByView, svxLineAt *entAt);
int cvxDwgViewRefEntAtSet(int idRefEnt, int clrByView, int typeByView, int widthByView, const svxLineAt *entAt);
int cvxDwgUserTableCreateByTemplate(vxName name, vxPath tplPath, svxPoint2 *pnt, int origin, int *idTable);
int cvxDwgTableRowHeightSet(int idTable, int Row, double Height);
int cvxDwgTableColWidthSet(int idTable, int Col, double Width);
int cvxDwgGetTableSize(int iTblIdx, int *pRowNum, int *pColNum);
int cvxDwgTableRowInsert(int idTable, int Row);
int cvxDwgTableRowDelete(int idTable, int Row);
int cvxDwgTableColInsert(int idTable, int Col);
int cvxDwgTableColDelete(int idTable, int Col);
int cvxDwgTableCellAtGet(int idTable, int Row, int Col, svxTextAt *TextAt);
int cvxDwgTableCellAtSet(int idTable, int Row, int Col, svxTextAt *TextAt);
int cvxTreeSetItemCheckable(const char *form, int field, int id, int checkable);
evxTreeCheckState cvxTreeGetItemCheckState(const char *form, int field, int id);
void cvxTreeSetItemCheckState(const char *form, int field, int id, evxTreeCheckState checkState, int extToChild);
int cvxTreeGetPrevSiblingItem(const char*form, int field, int id, int* prevId);
int cvxTreeGetNextSiblingItem(const char*form, int field, int id, int* nextId);
int cvxTreeMoveItems(const char *form, int field, int numNodes, int *ids, int insParentId, int siblingId);
int cvxLayerGetAllCategory(int *numCate, vxLongName** categories);
int cvxLayerInfoExport(vxPath file);
int cvxLayerInfoImport(vxPath file, int overWrite);
int cvxCmFrameInsert2(vxName frame_name, svxMatrix frame_mat, int *idx_frame);
int cvxCmOpGetIdxFromName(vxLongName op_name,int *op_index);
int cvxCmInqIndexFromName(evxCmObjType objClass, vxLongName sName, int *index);
int cvxFileNewSingle(vxPath fileName, evxFileType fileType, evxFileSubtype fileSubtype, const char * templateName, char* fileDescription);
int cvxDataGetItemList(int idData, int idField, int *Count, int **idItems);
int cvxDataGetItemData(int idItem, svxData *Data);
void cvxDataInqActive(int *idData);
int cvxCmdAction(evxCmdAction type, svxCmdActionParam* param);
int cvxFileKeep(int fKeepOpen);
int cvxPartUserAtGet(vxLongName File, vxLongName Root, int *Count, svxAttribute** UserAt);
int cvxPartUserAtSet(vxLongName File, vxLongName Root, int DelOrgAt, int Count, svxAttribute* UserAt);
int cvxPartAtItemGetInFile(vxLongName File, vxLongName Root, evxAtItemId itemId, svxAttribute *At);
int cvxPartAtItemSetInFile(vxLongName File, vxLongName Root, evxAtItemId itemId, svxAttribute *At);
int cvxPartAtItemLockGetInFile(vxLongName File, vxLongName Root, char* AtLable, evxAtItemLockStatus* AtLockState);
int cvxPartAtItemLockSetInFile(vxLongName File, vxLongName Root, char* AtLable, evxAtItemLockStatus AtLockState);
int cvxPartInqFtrGroup(int idFeature, int *idGroup);
int cvxSrfAxis(svxSurface*, svxPoint *startPnt, svxPoint *endPnt);
int cvxFileLoadList(int state, int *count, vxLongName **fileList);
int cvxFileSessionClear(vxLongName file);
int cvxCompInqConstraints(svxEntPath *CompPath, int *count, int **cons);
int cvxConsInqType(int idCons, evxConsType *consType);
int cvxConsInqRefEnts(int idCons, int *count, svxEntPath **entPaths);
int cvxPartInqConstraints(vxLongName File, vxLongName Part, int *count, int **cons);
int cvxEntClassNumByPath(svxEntPath *entPath);
int cvxFaceInqBend(int idFace, int *bendFlag, double *bendRad, double *neutralRad, double *angle, double *thick, double *kFactor, double *flatTol);
int cvxCompInqConsState(int idComp, evxConsState *consState);
int cvxPartInqFtrParentFtrs(int idFeature, int getAll, int *cnt, int **list);
int cvxPartInqFtrChildFtrs(int idFeature, int *cnt, int **list);
int cvxDwgInqSymType(int idSym, evxSymbolType *type);
int cvxDwgSymLinkGet(const int idSymLink, vxPath filePath);
int cvxDwgSymLinkExport(const int idSymLink, vxPath filePath);
int cvxDwgInqSymEnts(int idSym, int *Count, int **idEnts);
int cvxDwgInqViewType(int idView, evxViewType *type);
int cvxDwgInqDimGripPnts(int idDim, int *Num, svxPoint **Pnts);
int cvxDwgDimAtGet(int idDim, svxDimAttr *dmAttr);
int cvxDwgDimAtSet(int idDim, svxDimAttr *dmAttr);
int cvxDwgViewInqRefEnts(int viewId, int *count, int **idRefEnts);
int cvxDwgRefEntDataGet(int idRefEnt, svxRefEntData *data);
int cvxRootAtItemGet(vxLongName file, vxLongName root, evxAtItemId itemId, svxAttribute *at);
int cvxRootAtItemSet(vxLongName file, vxLongName root, evxAtItemId itemId, svxAttribute *at);
void cvxAuxFrameSetDirXYZOrgBuddy(int idData, int idXFld, int idYFld, int idZFld, int idOrgFld);
void cvxMoveSetAuxFrameElem(int iElem);
int cvxFormFieldGetCallback(const char* form, int field, void** callback);
void cvxDatumLocalVis(int iVisible);
int cvxTableUnselectAll(const char* Form, int idTable);
int cvxDataDelItem(int idData, int idField, int iEnt);
void cvxPickDataClear();
int cvxMoldCompGetBndBox(int iCompCnt, int* pCompList, svxBndBox* pBnd);
Modified functions:
int cvxFileAction(evxDocAction type, svxDocActionParam *param);
int cvxDataGrpRem(int idData, int idField, int index);
int cvxDwgInqBorderTitle(int idDrawing, int *idBorder, int *idBorderSkt, int *idTitle, int *idTitleSkt);
int cvxDwgViewGeomInqList(int viewId, int option, int *count, int **indices);
int cvxCmFtrInsert(evxCmFtrType ftrType,int idx_CmComp,int cnt,int *geom,int *idx_FtrGrp);
Modified types:
svxCompData - Add a variable CopyPart for to indicate if it needs to copy part.
evxDocAction - Add newFile action type of enumeration.
svxDocActionParam - modify callback function.
evxTableType - Add a new type of revision table.
evxCmFtrType - Add some new feature types.
New types:
svxRoughTexts - surface roughness text data.
evxAppAction - application action type.
svxAppActionParam - application action parameters.
evxCmdAction - command action type.
svxCmdActionParam - command action parameters.
Notes:
cvxDataGetItem() - The previously undocumented function cvxDataGetItem has
been renamed to cvxDataGetItemData and is now published in the API documentation
under that new name.
-------------------------------------------------------------------------
25.00
New functions:
int cvxTableSetSelRange(const char* Form, int idTable, svxRectangle *SelRange, int bSelect);
int cvxPartInqShapeOpen(int idShape, int *isOpen);
int cvxIsectFaceFace(int idFace1, int idFace2, evxFaceTrim Trim, int TangentOk, int *Count, svxCurve **Curves);
int cvxFilterActiveGet(vxName Filter);
int cvxFileNameCheck(char* fileName,int nBytes);
int cvxPartCalcAttrGet(int idPart,svxPartCalcAttrData* attr);
int cvxCompGetRefPart(int *Count, vxLongName** FileName, vxLongName** RootName);
int cvxRootRenameMulti(int Count, vxLongName *FileName, vxLongName *RootName, vxLongName *NewFileName, vxLongName *NewRootName, int fDelOriginal);
int cvxPartAtItemDel(evxAtItemId itemId, vxLongName label);
int cvxDwgUserTableCreate(vxName name, int iRow, int iCol, svxPoint2 *pnt, int origin, int *idTable);
void cvxDwgTableCellsMerge(int idTable, int minRow, int maxRow, int minCol, int maxCol, int kFirstData);
void cvxDwgTableCellsUnMerge(int idTable, int minRow, int maxRow, int minCol, int maxCol);
int cvxCompVisGet(svxEntPath *CompPath, int *Vis);
int cvxCompVisSet(svxEntPath *CompPath, int Vis);
void cvxCompHighlight(svxEntPath*CompPath, svxColor *color);
void cvxCompUnHighlight(svxEntPath*CompPath);
int cvxGetEntPath(char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path);
int cvxGetEntPaths(char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths);
int cvxEntInqPathSelected(int *Count, svxEntPath **Paths);
int cvxPartUserAtExport(vxLongName filePath);
int cvxCompInqRenderMode(svxEntPath *CompPath, int *RenderMode);
int cvxCompIsUnplaced(int idx_Comp, int* isUnplaced);
int cvxCompSetRenderMode(svxEntPath *CompPath, int RenderMode);
int cvxCrvLen2(int idCurve, double T1, double T2, double *Length);
int cvxCrvGetPntAtDist(int idCurve, double StartT, double Length, double *T, svxPoint *Point);
int cvxPartInqVertexEdges(int idEdge, int EndPnt, int *Count, int **Edges);
int cvxPartInqAxis(int *Count, int **Axis);
int cvxPartInqCsys(int *Count, int **Csys);
int cvxPartInqFaceFillet(int idFace, int *isFilletFace);
int cvxFaceRadius(int idFace, double *Radius);
int cvxDwgGeomGetView(int idGeom, int *idView);
int cvxDwgInqBorderTitle(int idDrawing, int *idBorder, int *idBorderSkt, int *idTitle, int *idTitleSkt);
int cvxDwgSymWeldDataGet(const int idSymWeld, svxSymWeld* data);
int cvxDwgSymWeldDataSet(const int idSymWeld, const svxSymWeld* data);
int cvxCrvInqContinuity(int Count, int *Curves, int *Continuity);
int cvxCustomViewAdd(char *Name, int LyrVis, int ObjVis, int *idView);
int cvxCustomViewActivate(int idView);
int cvxCustomViewDel(int idView);
int cvxCustomViewId(vxName Name, int *idView);
int cvxCompFaceAtGet(const svxEntPath *CompPath, svxFaceAt *At);
int cvxCompFaceAtSet(int Count, svxEntPath *CompPath, svxFaceAt *At);
void cvxFormLogKill(char *Form);
int cvxLicTypeCheck();
int cvxDatumDispModeGet(int idDatum, evxDatumDispMode *DispMode);
void cvxDatumDispModeSet(int idDatum, evxDatumDispMode DispMode);
int cvxPartAtItemDesGet(evxAtItemId itemId, char* AtLable, char* AtDes, int nBytes);
int cvxPartAtItemDesSet(evxAtItemId itemId, char* AtLable, char* AtDes);
int cvxPartAtItemLockGet(char* AtLable, evxAtItemLockStatus* AtLockState);
int cvxPartAtItemLockSet(char* AtLable, evxAtItemLockStatus AtLockState);
int cvxPartInqLoopInner(int idLoop, int *isInner);
void cvxRibbonSetStatus(int enable);
int cvxSrfDiameterEval(svxSurface*, double U, double V, double *Diameter);
int cvxEntGetAngle(int ent1, int ent2, double *angle);
int cvxDwgInqDimEnts(int idDim, int *count, int **idEnts);
int cvxCmInqOpName(int idx_op, vxLongName opName);
int cvxSkIsCosmetic(int IdSketch);
int cvxFileAction(evxDocAction type, svxDocActionParam *param);
Modified functions:
int cvxFileExport(evxExportType Type, vxPath Path, void* Data);
Modified types:
svxImportData - Add a reserved variable, which should be NULL for API developers currently.
New types:
evxDocAction - File action type.
svxDocActionParam - File action parameters.
-------------------------------------------------------------------------
24.00
New functions:
void cvxEchoColorAtSet(svxWireAt *at);
void cvxEchoColorAtGet(svxWireAt *at);
int cvxEntLayerId(int idEntity, int* LayerId);
int cvxTableComboSet2(const char* Form, int idTable, int Row, int Col, char *Options, char *Images);
int cvxTableIndexComboSet2(const char* Form, int idTable, int Row, int Col, char *Options, char *Images);
int cvxTableInputComboSet2(const char* Form, int idTable, int Row, int Col, char *Options, char *Images);
int cvxTableComboSetOption(const char* Form, int idTable, int Row, int Col, int Index, char *IdxText);
int cvxTableComboGet(const char* Form, int idTable, int Row, int Col, int* Index, char* Text, int nBytes);
int cvxTableCellTextSet2(const char* Form, int idTable, int Row, int Col, char* Text, char* Image);
int cvxTableCheckSet(const char* Form, int idTable, int Row, int Col, int Check);
int cvxTableIsCheck(const char* Form, int idTable, int Row, int Col);
int cvxTableDateSet(const char* Form, int idTable, int Row, int Col, int Date, evxDateType DateType);
int cvxTableDateGet(const char* Form, int idTable, int Row, int Col, int* Date, evxDateType* DateType);
int cvxTableColorSet(const char* Form, int idTable, int Row, int Col, const svxColor* Color, int ClrIdx, uchar Type);
int cvxTableColorGet(const char* Form, int idTable, int Row, int Col, svxColor* Color, int ClrIdx, uchar* Type);
int cvxTableNumSet(const char* Form, int idTable, int Row, int Col, const char* Num);
int cvxTableNumGet(const char* Form, int idTable, int Row, int Col, char* Num, int Bytes);
int cvxTableTypeGet(const char* Form, int idTable, int Row, int Col, evxTableCellType* Type);
int cvxTableCallBackParamGet(const char* Form, int idTable, svxTableCallBackParam* Param);
void cvxTableCallBackParamFree(svxTableCallBackParam *param);
void cvxTableCellEnableSet(const char* Form, int idTable, int Row, int Col, int State);
int cvxTableRowInsert(const char* Form, int idTable, int Row);
int cvxTableRowRemove(const char* Form, int idTable, int Row);
int cvxTableRowCnt(const char* Form, int idTable);
int cvxTableColInsert(const char* Form, int idTable, int Col);
int cvxTableColRemove(const char* Form, int idTable, int Col);
int cvxTableColCnt(const char* Form, int idTable);
int cvxMessageBox(int MsgType, int WndMode, const char* Title, const char* Message, const char* Btn1Str, const char* Btn2Str, int* Action);
int cvxEntLineAtGet(int idLine, svxLineAt* At);
int cvxEntLineAtSet(svxLineAt* At, int Count, int* idEnts);
int cvxPartCopyTransformList(const int Count, const int* Entities, const svxMatrix *Mat, int* EntCnt, int **idList);
void cvxFilterListGet(int *count, vxName *filterList);
void cvxDispZoomAllIncludeDim(int Redraw);
void cvxEntUnPickAll();
void cvxEntUnPickLast();
void cvxAuxFrameShow(int idData, int entField, int matField);
void cvxVisDispStatusGet(evxVisualDispItem Item, int *isOn);
int cvxDataGetMatrix(int idData, int idField, svxMatrix *Matrix);
int cvxEntIsElectrode(int idEntity);
int cvxTableGetSelRange(const char* Form, int idTable, int *RangeCnt, svxRectangle **SelRange);
int cvxPartInqCrvLists(int *Count, int **CrvLists);
int cvxPartInqAnnoTexts(int *Count, int **Texts);
int cvxPartAddLineDim(int idEnt1, int idEnt2, svxPoint *TextPos, int idPlane, int *idDim);
int cvxPartAddSymmetryDim(svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int* idDim);
int cvxPartAddCoorDim(svxPoint *LeaderPnt, int idParent, svxPoint *TextPnt, int idDatum, int idPlane, int *idDim);
int cvxEntGetDistance(int ent1, int ent2, svxPoint *p1, svxPoint *p2, double *dist);
int cvxDimInqPos(int idDim, svxPoint *pPos);
void cvxColorFilter(int colorIdx);
int cvxCrvEval2(const int idCurve, const double t, const int level, svxEvalCurv* eval);
int cvxCrvEvalCrvtr(const int idCurve, const double t, svxPoint *point, svxPoint *normal, double *curvature);
int cvxFaceGetMaxCurvature(const int, const svxPoint2, svxPoint *, svxPoint *, svxPoint *, double *, double *, double *, svxPoint *, svxPoint *);
int cvxFaceGetArea(const int faceId, const double tolerance, double *area);
void cvxDispZoomAt(const svxPoint point, const float factor);
int cvxDispWindowRectGet(const int includeFrame, const int isGlobal, int* x, int* y, int* h, int* w);
int cvxDimInqType(int idDim, evxDimType *type);
int cvxDwgSymSurfDataGet(int idSymSurf, svxSymSurf*data);
int cvxDwgSymSurfDataSet(int idSymSurf, svxSymSurf*data);
int cvxEntRgbSetNoAt(svxColor Color, int Count, int *idEnts);
int cvxCompIferCheck(svxEntPath *BaseComp, svxEntPath *ChkComp, int SubAsmAsWhole, int IgnoreHidden, int *IferCnt, svxIferChkResData **IferResults);
int cvxCompInqPaths(svxEntPath *CompPath, int Depth, int IgnoreHidden, int *PathCnt, svxEntPath **lstPath);
Modified functions:
int cvxDwgDimAtGet(int idDim, svxDimAttr *dmAttr);
int cvxDwgDimAtSet(int idDim, svxDimAttr *dmAttr);
int cvxLayerInfoGet(int number, svxLayerInfo *pLayerInfo);
int cvxLayerInfoSet(int number, const svxLayerInfo *pLayerInfo);
int cvxFieldInitFont(const char *Form, int idField, const char *Name, int hasZwFont);
int cvxPartSkIns2(vxLongName File,vxLongName Name,int idPlane,int iAsso,int*idSketch);
New types:
svxWireAt - wire attribute for echo.
svxLineAt - entity line attribute
evxVisualDispItem - visual display item
svxSymSurf - surface roughness data
Modified types:
evxInfoLayerFlag - Add VX_LAYER_INFOR_FLTR types.
svxLayerInfo - Add category to store filter information of layer.
svxConsDim - Add dimTxtOrient, LeaderAlign, trmTyp1, trmTyp2, dimLineSize, extLineSize, dimLineType, extLineType, dimTxtBold, dimPrefixFlag.
evxDimType - Add some new types.
-------------------------------------------------------------------------
23.10
New functions:
int cvxSkAddPolyline(int cntPnt, svxPoint2* pnts, int addCns);
int cvxTableCellTextSet(char *Form, int idTable, int Row, int Col, char*text);
int cvxTableCellTextGet(char *Form, int idTable, int Row, int Col, char*text, int nBytes);
int cvxPathSet(vxPath path);
char cvxFileInqAssemMode(void);
int cvxPartInqFtrRegenStat(int idFeature, char *stat);
int cvxDwgGetDimTextBox(int idDim, double *tbWid, double *tbHgt, double *chSlp, svxPoint2 *txtPt);
int cvxDimValModNoUpdate(int idDim, char* exp);
int cvxRootIsAsm(vxLongName File,vxLongName Part,int *isAsm);
int cvxEntTextLocGet(int idText, svxTextLoc *loc);
int cvxDimInqText(int idDim, int subDim, char **pStr);
int cvxDwgViewPnt3DTo2D(int viewId, svxPoint pnt3D, svxPoint2 *pnt2D);
int cvxUserActionStatusSet2(int type, int value);
Modified types:
evxExportType - Add VX_EXPORT_TYPE_IGES and VX_EXPORT_TYPE_STEP types.
evxAtItemId - Add VX_AT_SHEETPATH, VX_AT_CAMPATH and VX_AT_SHEETCODE.
-------------------------------------------------------------------------
23.00
Modified types:
svxExtrudeData - Add numBooleanEnts and *BooleanEnts to support combine extrusion with
specified shapes.
Modified functions:
cvxPartEncapsulate - Two new arguments were added to control the form of encapsulation
used and to specify whether or not to keep feature dimensions.
New function:
void cvxSetMSMMoldInstalled(int IsInstalled);
void cvxSetMSMPressInstalled(int IsInstalled);
int cvxDataSetPntByPath(int idData, int idField, svxEntPath *, svxPoint*);
int cvxShellAtGet(int, svxPartAttribute *At);
int cvxShellAtItemGet(int, evxAtItemId itemId, svxAttribute *At);
int cvxShellAtItemSet(int, evxAtItemId itemId, svxAttribute *At);
int cvxPartDelGrpFtr(int idFtr, int delFtrs);
int cvxPartFtrPlayTo(int, int);
int cvxPartInqPoints(int *count, int **histObjIdx);
int cvxXnUndoCount();
void cvxXnBundle(int iCount, const char* xn_name);
int cvxConfigSetColor(const char *Name, evxColor Color);
int cvxConfigSetInteger(const char *Name, int Value);
int cvxConfigSetNumber(const char *Name, double Value);
int cvxConfigSetOption(const char *Name, const char* Option);
int cvxConfigSetRgb(const char *Name, svxColor *Rgb);
int cvxConfigSetString(const char *Name, char *Str);
int cvxConfigSetYesNo(const char *Name, int YesNo);
int cvxDwgViewRotate(int idView, double angle);
int cvxDwgTableAdjustSize(int idTable);
int cvxDwgViewGeomGetShapeId(int geomId, char *fileName, int fileNameBytes, char *partName, int partNameBytes, svxEntPath *pickPath, int *geom3DId, int *shapeId);
int cvxDwgViewGeomInqList(int viewId, int option, int *count, int **indices);
int cvxDwgViewPnt2DTo3D(int pnt2DId, svxPoint *pnt3D);
int cvxItemGetCheckState(char *Form, int idField, int idItem, int *checkState);
int cvxDimModTxt(int idDim, int subDim, char *pStr);
int cvxPathIsDebug(const char *FolderName);
int cvxAssemCompVisAll(int *nSize, int **ppath_mode);
int cvxEntGetInhSubIdx(int idx_ent, int klass, int sub_class, int *subIdx);
int cvxInstPartAsShp(const svxCompData *,);
int cvxInstShpGetMatrix(int idShape, svxMatrix *Matrix);
void cvxFileInqOpen(char* Name, int nBytes);
int cvxFieldEnableGet(char *Form, int idField);
int cvxAsmUpdateCompRef(const char *, const char *);
int cvxLibPartIns(const svxCompData *Comp, const char *InstanceName, const char *ValStr, int fFileType, int fInsShape, int *idComp);
int cvxLibPartAdjust(int idComp, const vxLongName File, const vxLongName Part, const char *ValStr, const char *InstanceName);
int cvxEntSetNameTag(int idx_ent, char *name);
int cvxTreeItemsCount(const char*form, int field);
void cvxTreeSetColumnCount(const char* form, int field, int count);
int cvxTreeHeaderGetSize(const char* form, int field, int* wid, int* hi);
void cvxTreeSetHeaderText(const char* form, int field, int col, const char* text);
int cvxTreeSetHeaderTextAlignment(const char* form, int field, int col, evxAlignFlag align);
void cvxTreeSetColumnWidth(const char* form, int field, int col, int width);
int cvxTreeSetSelectionMode(const char* form, int field, int mode);
int cvxTreeSetSelectionBehavior(const char* form, int field, int behavior);
int cvxTreeAddItem(const char *form,int field,int parentId,int siblingId,const char *label,
int imgIdx,int folderIdx,evxTreeItemType itemType,int dbIdx,int itemflag,int *outItemId,const char* cmdName);
int cvxTreeSetItemIconNameByColumn(const char *form, int field, int id, int col, const char* iconName);
int cvxTreeSetItemTextByColumn(const char* form, int field, int id, int col, const char* text);
void cvxTreeGetItemTextByColumn(const char* form, int field, int id, int col, char* text, int size);
int cvxTreeSelectItem(const char *form, int field, int id);
int cvxTreeUnselectAll(const char *form, int field);
int cvxTreeIsItemSelected(const char*form, int field, int id);
int cvxTreeGetDBIdByItem(const char *form, int field, int id, int*dbid);
int cvxTreeGetCbParam(const char*form, int field, int id, svxTreeCbParam* param);
int cvxTreeDeleteItem(const char*form, int field, int id);
int cvxTreeEditItemByLineEdit(const char *form, int field, int id, int col, const char *defaultLabel);
int cvxTreeGetChildItem(const char*form, int field, int id,int index, int*child);
int cvxTreeGetChildrenCount(const char*form, int field, int id,int *count);
int cvxTreeGetParentItem(const char*form, int field, int id, int *parent);
int cvxTreeGetDescendants(const char *sName, int field, int isAll, int parent, int *num, int **ids);
int cvxTreeGetSelectedItems(const char *form, int field, int *count, int **ids);
-------------------------------------------------------------------------
22.10
New functions:
int cvxSkAddConsDim(evxConsDimType type, svxConsDim* pData);
int cvxSkBlockInqRefs(int idBlock, int*count, int**idEnts);
int cvxDwgViewInqOrgPnt(int idView, svxPoint2*pnt, int *idEnt);
int cvxFileInqAsm(char* Name, int nBytes);
void cvxMsgDisp2(char *Text, int leval);
int cvxLayerExists2(int Number);
int cvxLayerIdModify(int srcNumber,int tarNumber);
--------------------------------------------------------------------------
22.00
New functions:
int cvxPartCfgActivate(int idCfg);
int cvxPartPhyAttrCalc(vxLongName Name);
int cvxPartAtItemGet(evxAtItemId itemId, svxAttribute *At);
int cvxPartAtItemSet(evxAtItemId itemId, svxAttribute *At);
int cvxPartShapeStructGet(int idShape, svxWeldAttr *at);
int cvxCompSuppressGet(int idComp, int *suppress)
int cvxPartInqCfgList(int *Count, int **CfgList);
int cvxPartInqActiveCfg(int *idCfg);
int cvxFileInqAssociatedList(int *count, vxPath ** fileList);
int cvxEntTextNew(char* String, int Type, svxPoint2 Pnt[2], int*idEnt);
int cvxEntTextAtGet(int idText, svxTextAt*At);
int cvxEntTextAtSet(int idText, svxTextAt*At);
int cvxDwgTableExport(int idTable, vxPath path);
int cvxDwgInqGeom(int idDrawing, int *count, int **idEnts)
int cvxDwgSymImgNew(svxSymImg*data, int embed, int locked, int *idSymImg);
int cvxDwgSymImgAtSet(int idSymImg, svxSymImg*data);
int cvxDwgSymImgAtGet(int idSymImg, svxSymImg*data);
int cvxDwgInqText(int idDrawing, int *count, int **idEnts)
int cvxDwgAtItemGet(evxAtItemId itemId, svxAttribute *At);
int cvxCmdMacro2(char *path);
void cvxUserActionStatusGet(int *disableStatus);
void cvxUserActionStatusSet(int disable);
int cvxDwgTableLinkToExcel(int idTable, vxPath path);
int cvxDwgTableCellSet(int idTable, int Row, int Col, char* Value);
int cvxCompSuppress(int idComp, int suppress);
int cvxDwgTableCellGet(int idTable, int Row, int Col, char* Value, int nBytes);
int cvxFileImport(svxImportData *importData);
int cvxSkBlockInqDim(vxLongName blockName, int *Count, int **idEnts);
int cvxDwgDimAtGet(int idDim, svxDimAttr *dmAttr);
int cvxDwgDimAtSet(int idDim, svxDimAttr *dmAttr);
int cvxSkBlockInqGeomX(vxLongName blockName, int *Count, int **idEnts);
int cvxSkInqCrvConnect(int iCount, int *idCrvs, int *iUnMatch, int *iOverMatch);
int cvxSkEntWireType(int entId, int *type);
int cvxRootInqSymbol(vxLongName file, int *iCount, vxLongName**names);
int cvxDwgInsertSymbol(vxLongName fileName, vxLongName symName, svxPoint2 *pnt, int*symId);
int cvxPartSetCustomStr(int idComp, const char *CustomString, int *idStr);
int cvxPartGetCustomStr(int idComp, int *idStr, char **CustomString);
int cvxEntNameByPath(const svxEntPath *Path, vxLongName Name);
int cvxSkAddConsDim(evxConsDimType type, svxConsDim* pData);
Modified functions:
int cvxCmCompGetAttr(int idx_Cmcomp,int cnt,evxCmCompAtrr *attr,svxCmAttrValue *value)-
int cvxCmCompGetAttr(int idx_Cmcomp,int cnt,evxCmCompAtrr *attr,svxCmAttrValue **pValue),
output the component's attributes list accrodiong to the input evxCmCompAtrr list.
--------------------------------------------------------------------------
21.10
New functions:
int cvxPartInqTagNames(int *Count,vxLongName** Names);
int cvxSkInqBlockReferences(int idSketch, int *Count, int **idEnts);
int cvxSkInqSketchBlocks(int *Count, int **idEnts, vxLongName **Names);
int cvxSkBlockActivate(int idBlock, int UpdateGUI);
int cvxSkBlockGetSketch(int idBlock, int *idSketch);
int cvxSkBlockRefGetDefinition(int idRef, int *idBlock);
int cvxSkBlockInqGeom(vxLongName blockName, int *Count, int **idEnts);
int cvxSkBlockInqPnt(vxLongName blockName, int *Count, int **idEnts);
void cvxFileDescriptionSet(vxPath Name, char *Description);
int cvxFileDescriptionGet(vxPath Name, vxLongName Description);
int cvxSkInqDimRefFlag(int idDim,int* refFlag);
int cvxDimInqVar(int idDim, svxVariable* Var);
int cvxDimValMod(int idDim, char* exp);
Modified functions:
cvxPartInqShapeBox - If the target object class is VPART, get tight fitting bounding box instead of
merging the bounding box with the shape's faces bounding box. If the second parameter is NULL,
initializes it to the identity matrix.
--------------------------------------------------------------------------
21.00
New functions:
void cvxPathDelAll(void);
void cvxEntSetTrans (int iTrans, int Count, int *idEnts);
int cvxDwgInqPart(char* rootName, int *iCount, svxCompName **partList);
int cvxPartVolumAndMassGet(vxLongName Name, double *dVolume, double *dMass );
int cvxDwgAtGet(int idDrawing, svxDrawingAt *drawingAt);
int cvxPartDatum2(svxMatrix *Frame, int iCode, int *idDatum);
void cvxUnitTypeGet(char*,char*,char*);
int cvxDwgAtSet(int idDrawing, svxDrawingAt *drawingAt);
Modified functions:
cvxMsgDisable - Disabling messages now suppresses some message
dialogs, too.
cvxPartInqFaceTx - Texture map origin point is now output correctly in
world coordinates.
cvxFileOpen - Root status doesn't need to be initialized
New types:
evxTextureLoc - Relative location of texture map.
svxDrawingAt - Sheet Format Attributes structure
Modified types:
svxTextureAt - Add location field to define texture map's location
relative to its origin.
--------------------------------------------------------------------------
20.10
New functions:
void cvxConfigGetColor(const char *Name, evxColor *Color);
int cvxConfigGetInteger(const char *Name, int *Value);
int cvxConfigGetNumber(const char *Name, double *Value);
int cvxConfigGetOption(const char *Name, const char *Options);
int cvxConfigGetRgb(const char *Name, svxColor *Rgb);
int cvxConfigGetString(const char *Name, char *Str, int nBytes);
int cvxConfigGetYesNo(const char *Name, int *YesNo);
void cvxDispRgbGet(evxDispAttrib Type, svxColor *Rgb);
void cvxDispRgbSet(evxDispAttrib Type, const svxColor *Rgb);
int cvxEntByUid(const svxUid *Uid, int *idEntity);
int cvxEntUidGet(int idEntity, svxUid* Uid);
int cvxEntUidSet(int idEntity, const svxUid* Uid);
int cvxFieldInitFont(const char *Form, int idField, const char *Name);
int cvxPartVarSubstitute(char *Str, int nBytes, int *Truncated);
int cvxPartVarSubstituteResize(char **Str);
int cvxEqGetExpByName(char* name, char *exp, int size);
int cvxRootInqMod(int *mod);
int cvxRootInqModSinceRegen(int *mod);
--------------------------------------------------------------------------
20.00
New functions:
int cvxCmdStateGet(vxName CmdName, evxCmdState *isEnable);
int cvxCmdStateSet(vxName CmdName, evxCmdState State);
void cvxColorfToColor(const svxColorf* rgbf, svxColor* rgb);
void cvxColorToColorf(const svxColor* rgb, svxColorf* rgbf);
evxColor cvxColorNear(const svxColor* rgb);
int cvxColorRGB(evxColor color, svxColor* rgb);
int cvxDwgActivate(vxLongName drawingName);
int cvxDwgFind(vxLongName rootName, vxLongName drawingName, int *idDrawing);
int cvxDwgInqActive(char *drawingName, int nBytes);
int cvxDwgInqDims(int idDrawing, evxDimType *dimTypeList, int dimTypeCount, int *count, int **dims);
int cvxDwgInqTables(int idDrawing, evxTableType type, int *count, int **tables );
int cvxDwgInqList(int idRoot, int *count, int **idDrawings);
int cvxDwgInqName(int idDrawing, char *drawingName, int nBytes);
int cvxDwgInqViews(int idDrawing, evxViewType type, int *count, int **views);
int cvxDwgViewInqPart(int idView, svxCompName *part);
void cvxEchoEscDisable();
void cvxEchoEscRestore();
int cvxEntInqSelected(int *Count, int **Ents);
void cvxFileOpenList(int *count, vxLongPath **fileList);
int cvxFileSave3(int Close, int DisPrompt, int Related);
int cvxFileVersionGet(vxPath file, int* version);
int cvxFileIsModified(vxPath Name, int* Modified);
int cvxPartFacetsMod(int idBlock, svxFacets *Facets);
int cvxPartFacetsSetAt(int idBlock, const svxFaceAt *At);
int cvxPartFacetsSetTx(int idBlock, const svxTextureAt *Tx);
int cvxPartInqFaceTxFile(int idFace, vxPath Path);
int cvxPartInqFacetsTxFile(int idBlock, vxPath Path);
int cvxPartInqFtrEnts(int idFeature, evxEntType EntType, int *Count, int **Ents);
double cvxRoundNumber(double Num, double Step, double Tol, int Dir);
int cvxShtInqSymbol(evxSymbolType type, int *Count, int **idEnts);
int cvxSkVarAdd(svxVariable *Variable);
int cvxSkVarGet(svxVariable *Variable);
int cvxSkVarSet(int Count, svxVariable *Variables);
int cvxSkInqVars(int *Count, svxVariable **Variables);
int cvxSkInqArea(int nCrv, int *idCrvs, svxPoint2 *innerPnt,
svxPrfAreaProp *aboutCM, svxPrfAreaProp *aboutRf);
Modified functions:
cvxEntName - add a new string size input to support long object name.
cvxFileInqActive - add a new string size input to support long object name.
cvxRootInqActive - add a new string size input to support long object name.
cvxRootInqAsm - add a new string size input to support long object name.
New types:
svxColorf - RGB color components defined as floating point numbers.
Modified types:
evxColor - add VX_COLOR_PURPLE value.
svxFacets - add optional RGB field to define color at each vertex.
svxTextureAt - add use_embed field to use embedded image instead of file.
--------------------------------------------------------------------------
19.10
"#define VX_API_VERSION 1910" was added to VxApi.h so that a dynamically-loaded
DLL can compare the version of the API it was compiled with against the version
of ZW3D that is invoking it.
New functions:
void cvxGetFileActiveField(int Open, const char* Prompt, const char* Default, const char* Filter);
void cvxGetFolderActiveField(const char* Prompt, const char* Default);
void cvxItemModify(const char* Form, int idField, int idItem, const char* Text);
int cvxMatEigen(const double Mat3x3[3][3], double *Values, svxVector *Vectors);
int cvxPartCopyTransform(int idEntity, const svxMatrix *Mat, int *idCopy);
int cvxPartMoveTransform(int idEntity, const svxMatrix *Mat);
int cvxPartMoveTransformList(int Count, const int *Entities, const svxMatrix *Mat);
int cvxPolyToTri(int PntCount, svxPoint *PntList, int* VtxCount, int** VtxList);
Modified functions:
cvxCmdFunc - An integer return value was added to this function. It returns 0
if the input function was successfully registered. It returns 1 if a symbol
with the same name as the input function already exists. In this case, the
pre-existing symbol is kept and the input function is ignored. Note that
cvxCmdFuncUnload() can be used to deregister a pre-existing function.
--------------------------------------------------------------------------
19.05
New functions:
int cvxPartCrvSplitAtPnts(int idCurve, int CountPnts, svxPoint *Points, int *CountCrvs, int **NewCrvs);
int cvxCrvGetInflections(int idCurve, int *Count, double **T, svxPoint **InfPnts);
int cvxCrvGetCusps(int idCurve, int *Count, double **T, svxPoint **Cusps);
int cvxPartSetFaceTx(int idFace, svxTextureAt *Tx);
int cvxDispSetLights(int Count, svxLight *Lights);
--------------------------------------------------------------------------
19.0
New functions:
void cvxEchoColorGet(evxColor *Color);
void cvxEchoColorSet(evxColor Color);
int cvxFaceReverse(int numFaces, int *idFaces);
void cvxFormActiveField(int *idField);
int cvxIsectCrvFace(int idCurve, int idFace, int Trim, int TangentOk, int *Count, svxPoint**);
int cvxPartRedefineIsActive(void);
int cvxPartRegenIsActive(void);
int cvxPlnThruPnts(int PntCount, svxPoint *PntList, svxVector *Normal, double *D);
void cvxVecAngle(svxVector *V1, svxVector *V2, double *Angle);
--------------------------------------------------------------------------
18.10
New functions:
void cvxBndBoxInit2(svxBndBox *Box);
int cvxDataGetColor(int idData, int idField, svxColor *Color);
int cvxDataSetColor(int idData, int idField, svxColor *Color);
int cvxDataToFeature(int idData, int idFeature, int ExcludeRegen);
void cvxPartPartialResults(int Disable);
int cvxTplInqFnCust(vxName Name, int NumBytes, char *FnName);
int cvxTplInqFnEcho(vxName Name, int NumBytes, char *FnName);
int cvxTplInqFnInit(vxName Name, int NumBytes, char *FnName);
int cvxTplInqFnTerm(vxName Name, int NumBytes, char *FnName);
void cvxEchoCustomStart();
void cvxEchoCustomEnd();
int cvxGetViewRect(int includeFrame, int isGlobal, int* tlX, int* tlY, int* brX, int* brY);
void cvxGetFolder(char*Prompt, char*Default, char*Path);
int cvxPartRegenFacets(int Count, int *idFaces, int Assembly, int LOD, double Tol);
int cvxSrfEval(svxSurface*Srf,double U,double V,svxPoint*,svxVector*Normal);
Modified functions:
cvxFileClose2 -- Added new option 3 to close file without wiping out all undo-redo data.
Modified structures:
typedef struct svxFacets (added support for UV coordinates corresponding to XYZ vertices)
--------------------------------------------------------------------------
18.05
New functions:
void cvxCmdBuffer(const char *String, int Priority);
int cvxEntBndBox(int idEntity, svxBndBox *Box);
int cvxCompSetPart(int idComp, vxName File, vxName Part);
void cvxDispDataUpdate(void);
int cvxEntMatrixSet(int idEntity, svxMatrix *Matrix);
int cvxEntPathToRoot(svxEntPath *EntPath);
void cvxStlFree(svxSTL *Stl);
--------------------------------------------------------------------------
18.00
New functions:
int cvxDispState(int Option, vxDispState);
void cvxFileClose2(vxName Name, int Option);
int cvxPartFacets(svxFacets *Facets, int *idBlock);
int cvxPartInqBlockPnts(int idBlock, int *Count, svxPointf **Points);
int cvxPartInqBlocks(int *Count, int **Blocks);
int cvxPartInqBlockType(int idBlock, evxBlockType *Type);
int cvxPartInqCrvList(int idCrvList, int *Count, svxEntPick **Curves);
int cvxPartInqEdgePreEdges(int idEdge, int *Count, int **PreEdges);
int cvxPartInqFacets2(int idBlock, svxFacets *Facets);
int cvxPartInqFtrList(int *Count, int **Features);
int cvxPartInqLoopFace(int idLoop, int *idFace);
int cvxPartInqPreEdgeInfo(int idPreEdge, svxPreEdge *PreEdge);
int cvxPartInqShapeFtrs(int idShape,int Option,int *Count,int **Features);
int cvxPartInqView(int idView, svxView *View);
int cvxPartInqViews(int *Count, int **Views);
int cvxPartPntBlock(vxName, int Count, svxPointf *Points, int *idEnt);
int cvxPartRefGeom(svxEntPath*, int Associative, int *idGeom);
int cvxPartViewAdd(svxView *View, int *idView);
int cvxSkActivate(int idSketch, int UpdateGUI);
Modified functions:
void cvxUndoBundleEnd(int RefreshDisplay, int Settings[], int isError);
cvxPartInqFaceFacets2 - Upgraded to retrieve face display, texture and shader attributes
along with facet data.
Modified structures:
typedef struct svxFacets (added display, texture and shader attribute bundles)
--------------------------------------------------------------------------
17.15
New functions:
void cvxEntSketch(int idEntity, int *idSketch);
int cvxPartInqLoopPreEdges(int idLoop, int *Count, int **PreEdges);
int cvxPartInqPreEdgeStartPnt(int idPreEdge, int *idEdge, svxPoint *StartPoint);
int cvxSkInqCns(int *Count, int *idEnts);
int cvxSkInqDim(int *Count, int *idEnts);
int cvxSkInqGeom(int *Count, int *idEnts);
int cvxSkInqGeomX(int *Count, int *idEnts);
int cvxSkInqPnt(int *Count, int *idEnts);
int cvxSkInqRef(int *Count, int *idEnts);
extern int cvxSkInqText(int *Count, int *idEnts);
Modified functions:
cvxPartInqEdgeCrv(); Now queries UV geometry by either parent loop or parent face.
cvxPartInqLoopEdges(); Now outputs edges in the order they occur in the loop.
--------------------------------------------------------------------------
17.10
New functions:
void cvxUndoBundleEnd(int RefreshDisplay, int Settings[]);
void cvxUndoBundleStart(int DisableManager, int Settings[]);
int cvxCompMerge2(evxBoolType Combine,int idComp,int MergeDim, int MergeWire, int *idShape);
int cvxCmHolderInsertAsTemplate(vxPath template_path, vxName file_name, vxName libriary_name,
vxName holder_name, int *idx_holder);
int cvxCmSpeedInsertAsTemplate(vxPath template_path, vxName file_name, vxName libriary_name,
vxName speed_name, int *idx_speed);
int cvxFileImportStl(const char *path, int *idOut);
int cvxPartCurveOffset(int idCurve, double Dis, int *idOut);
int cvxPartEllipse(svxRectangleData *ellipseData, int *idEnt);
int cvxPartRectangle(svxRectangleData *rectData, int *iCnt, int **idEnt);
int cvxPartProjStl(int idStl, int idPln, double tol, double smth, int *idCurve);
int cvxPartCurveSilh(int idCurve, svxPoint *dir, int *iCnt, int **idList);
int cvxPartFittingCrv(int iCnt, svxPoint *pnts, double tol, double smth, int *idEnt);
void cvxProgress(int iprogress);
int cvxPartInqFacets(int idBlock, svxSTL *zStl);
Deleted functions:
int cvxTplContAdd(int Id,int Opt,char*Name,char*Prompt);
int cvxTplEntAdd(int Id,int Opt,char*Name,char*Prompt,int isList);
int cvxTplEntOpt(int Id,evxEntInpOpt Option,char *Callback,int EmptyOk);
int cvxTplInit(evxCmdType Type,char *Name,char *Description);
int cvxTplInit2(char *ExecFunc,char *StartFunc,char *EndFunc,int Update);
int cvxTplInit3(int NoOptForm, int AutoRepeat, int MidClickRepeat);
int cvxTplInqFld(vxName Name, int *Count, svxTplFld **Fields);
int cvxTplInqFnCust(vxName Name, char *FnName);
int cvxTplInqFnEcho(vxName Name, char *FnName);
int cvxTplInqFnInit(vxName Name, char *FnName);
int cvxTplInqFnTerm(vxName Name, char *FnName);
int cvxTplNumAdd(int Id,int Opt,char*Name,char*Prompt,evxFldNumType);
int cvxTplNumOpt(int Id,char*Global,int Integer,double Step,double Min,double Max);
int cvxTplNumOpt2(int Id,char*Callback,int Slider,int EmptyOk);
int cvxTplOptAdd(int Id,int Opt,char*Name,char*Prompt);
int cvxTplOptItem(int Opt,char *Item);
int cvxTplOptOpt(int Id,char*Global,char*Callback,int CheckBox,int EmptyOk);
int cvxTplPntAdd(int Id,int Opt,char*Name,char*Prompt,int isList);
int cvxTplPntOpt(int Id,evxPntInpOpt Option,char*Callback,int EmptyOk);
int cvxTplStrAdd(int Id,int Opt,char*Name,char*Prompt);
int cvxTplStrOpt(int Id,char*Callback,int EmptyOk);
int cvxTplRegister(void);
Notes:
Add a member variable "iKeep" to struct svxExtrudeData.
--------------------------------------------------------------------------
17.00
New functions:
int cvxCmdFuncUnload(const vxName Name);
int cvxCmdVariableUnload(const vxName Name);
int cvxCmdTemplateUnload(vxPath File);
int cvxActiveLayerNumGet(int* Number);
int cvxActiveLayerNumSet(int Number);
int cvxLayerInfoGet(int Number, svxLayerInfo* pLayerInfo);
int cvxLayerInfoSet(int Number, const svxLayerInfo* pLayerInfo);
int cvxLayerAdd2(const svxLayerInfo* psLayerInfo, int *Number);
int cvxLayerDel2(int Number);
void cvxPathUserFolder(vxPath Directory);
int cvxRootInqAsm(vxName Name);
int cvxPartFaceOffset(int idFace, double Dis, int Keep);
int cvxPartCopyDirDis(int idEntity,svxVector*Dir,double Dis,int*idCopy);
int cvxPartInqDims(vxName File, vxName Part, int *Count, svxVariable**);
int cvxPartHistList(int Type, int *Cnts, int **HistList);
int cvxPartSetFaceAt(int Count, int *idFaces, const svxFaceAt *At);
int cvxEntParent(int idEntity, int *idParent);
int cvxCrvExtremum(int idCurve,int *Count,svxPoint **Pnts,svxBndBox *BndBox);
Add 53 APIs for CAM development.
Modified functions:
int cvxUiSettingsApply(char* Name);
Deleted functions:
int cvxFormsPrecompiled(vxPath File);
int cvxFormTemplate(vxPath File);
int cvxUiUpdate();
--------------------------------------------------------------------------
16.20
New functions:
int cvxPartScale2(int Count, int*idEnts, double X, double Y, double Z,
int idDatum, svxPoint *CentPnt);
--------------------------------------------------------------------------
16.10
New functions:
void cvxEchoStart();
void cvxEchoEnd();
int cvxHistSkipTo(char *Expression, vxName Operation, int *idOp);
--------------------------------------------------------------------------
16.00
New functions:
int cvxUiUpdate();
int cvxUiSettingsCreate(char* Name, char* Base);
int cvxUiSettingsRename(char* Name, char* Dest);
int cvxUiSettingsRemove(char* Name);
int cvxUiSettingsImport(char* Path);
int cvxUiSettingsExport(char* Name, char* Path);
int cvxUiSettingsExists(char* Name);
int cvxUiSettingsApply(char* Name, int SaveLast, int LoadCurr);
int cvxUiSettingsReset(char* Name);
int cvxUiSettingsCount(void);
int cvxUiSettingsFetch(int i, char* Name);
int cvxFileExport(evxExportType Type, vxPath Path, void* Data);
int cvxFileSave2(int Close);
int cvxFileSaveAll(void);
int cvxFilePreviewExtract(vxPath SrcFile, vxPath BmpFile);
int cvxFileCustomDataSet(vxName file, char* data, int dataLength);
int cvxFileCustomDataGet(vxName file, char** data, int* dataLength);
int cvxFileCustomDataDel(vxName file);
int cvxRootCustomDataSet(vxName file, vxName objectName, char* data,
int dataLength);
int cvxRootCustomDataGet(vxName file, vxName objectName, char** data,
int* dataLength);
int cvxRootCustomDataDel(vxName file, vxName objectName);
int cvxPartInqCompsInfo(vxPath Path, vxName Name, int* Count,
vxPath** Paths, vxName** Names);
extern int cvxLicModulesGet(char szModules[1024]);
--------------------------------------------------------------------------
15.20
New functions:
int cvxCrvLen(int idCurve, double *Len);
int cvxDataSetPntOnCrv(int idData, int idField, int idCrv, svxPoint*);
int cvxEntByName2(vxName File, vxName Root, vxName Name, int *idEntity);
int cvxEntFind2(svxEntFind *Data);
void cvxFieldCaretSet(char *Form, int idField, int Position);
int cvxFieldFocusSet(char *Form, int idField);
void cvxFormWaitExit(int ReturnValue);
int cvxHistBackup(void);
int cvxHistRedefine(vxName Operation);
int cvxIsectRayCrv(svxAxis*,int Crv,int Tan,int*Count,svxPoint**Points);
int cvxPartAtMod(vxName Name, svxPartAttribute *At);
int cvxPartPlnCrv2(int idCrv,svxData*Origin,svxData*Xaxis,int Flip,int *idPln);
int cvxPartPntsOnCrv(int idCrv, svxPoint*, int Num, double Dist, evxExtendOpt,
int *Count, int **idEnts);
int cvxSkPntsOnCrv(int idCrv, svxPoint*, int Num, double Dist, evxExtendOpt,
int *Count, int **idEnts);
int cvxTableAtSet(char *Form, int idTable, svxTableAt *At);
int cvxTableComboSet(char *Form, int idTable, int Row, int Col, char *Options);
int cvxTableSizeSet(char *Form, int idTable, int NumRow, Numint Col);
void cvxTableVisSet(char *Form, int idTable, int Row, int Col);
int cvxUndoRedo(int Undo);
Notes:
cvxPartAtSet() no longer errors out if part name is a blank string
in the input part attributes structure. The function description has
been updated to give more info about its behavior.
cvxFileSaveAs() upgraded to suppress prompts.
Upgraded cvxLayerStateSet() so that the "isFrozen" argument can be
overloaded to disable logging of a "LayerState" operation in the active
part history when a layer's visibility is modified.
Upgraded cvxSubPartFlag() with "isSubPart = -1" to allow a part to be
hidden in the root object list (like a sub-part) but still be counted
for BoM or assembly-part-list purposes.
Added the case "VX_EXACT_MATCH" to API enum evxGlobal. It allows you to
get and set the global flag that controls exact label matching during
history regeneration.
--------------------------------------------------------------------------
15.10
New functions:
int cvxPartInqFaceFacets2(int idFace, svxFacets *Facets);
void cvxFacetsFree(svxFacets *Facets);
int cvxCrvLen(int idCurve, double *Len);
--------------------------------------------------------------------------
15.00
New functions:
void cvxCrvTransform(svxMatrix *Mat, svxCurve *Crv);
int cvxEntActivate(svxEntPath*NewPath, int UpdateGUI, int*idEntity,
svxEntPath*OldPath);
int cvxEntExists(int idEntity, evxEntType EntType);
int cvxGetExternalPick(const char *Prompt, evxPntInpOpt Opt, int EmptyOk,
svxPoint *Point, svxEntPath *EntPath, svxMatrix *Matrix);
void cvxMatTransform(svxMatrix *Mat, svxMatrix *Frame);
void cvxSrfTransform(svxMatrix *Mat, svxSurface *Srf);
int cvxSkScale(int Count, int*idEnts, double X, double Y, svxPoint2*Pnt);
int cvxPartBool2(evxBoolType, int, int*, int, int*, int*, int**);
int cvxPartBool3(evxBoolType, int, int*, int, int*, int, int*, int*, int**);
int cvxPartPlnSrf2(int idFace,svxPoint*Origin,svxPoint*XZ,int Flip,int*idPln);
int cvxPartScale(int Count,int*idEnts,double X,double Y,double Z,int idDatum);
int cvxPartSkIns2(vxName File,vxName Name,int idPlane,int*idSketch);
int cvxCmdInteract(vxName Name);
int cvxCmdRestore(void);
New options:
Added VX_INP_PNT_ASSEM_FACE, VX_INP_PNT_ASSEM_EDGE and VX_INP_PNT_ASSEM_CURVE
to "enum evxPntInpOpt". Added "Face" option to the pick filter associated
with the VX_INP_PNT_ASSEMBLY option.
--------------------------------------------------------------------------
14.80
New functions:
int cvxPartThreadAt(int idFace, svxPoint *Pnt, svxThreadData *Thread);
void cvxDispSwitchGet(evxDispItem, int *isOn);
extern void cvxFormTitleGet(char *Form, int NumBytes, char *Title);
extern void cvxFormTitleSet(char *Form, char *Title);
--------------------------------------------------------------------------
14.70
New functions:
int cvxEscCheck(void);
void cvxEscEnd(void);
void cvxEscStart(void);
int cvxFormWait(char *Form);
void cvxPathFile2(char*,int,char*);
Modified functions:
Upgraded the "Working" input argument to cvxRootVarSet() and
cvxPartVarSet() so it can be used to disable the object
regeneration normally triggered by those function. The
descriptions of these functions were updated to specify the
variable names used to identify various part parameters and
attributes.
--------------------------------------------------------------------------
14.50
New functions:
int cvxEntRefEnt(int idRefEnt, int *idEnt);
--------------------------------------------------------------------------
14.40
New functions:
void cvxCmdSend(char *CommandString);
int cvxIsectRayPartVis(svxAxis*,svxMatrix*,svxPoint*);
int cvxIsectRayPlane(svxAxis*,svxMatrix*,svxPoint*);
void cvxLayerSync(void);
int cvxPartInqFaceFacets(int idFace, int *Count, svxTriangle **Facets);
int cvxPartSewForce(double Tol);
void cvxPromptDisable(void);
void cvxPromptEnable(void);
void cvxTranStatusDisable(void);
void cvxTranStatusEnable(void);
Modified functions:
Added arguments "vxName File" and "vxName Parent" to cvxEntComp().
Changed cvxFileSave() from type "void" to type "int". It now returns
an integer error code.
Added "VX_FIND_3D_BLOCK" option to "evxEntFind".
--------------------------------------------------------------------------
14.30 - Feb 2009
New functions:
int cvxPartMassProp(void);
int cvxPartPlnCrv(int idCurve, svxPoint *Origin, svxPoint *Xaxis);
int cvxPartPlnSrf(int idFace, svxPoint*Origin, int *idPln);
int cvxDispGetLights(int *Count, svxLight *Lights);
int cvxPartInqFaceAt(int idFace, svxFaceAt *At);
int cvxPartInqFaceSh(int idFace, svxShaderAt *Sh);
int cvxPartInqFaceTx(int idFace, svxTextureAt *Tx);
--------------------------------------------------------------------------
14.20 - Oct 2009
New functions:
int cvxCompEditPart(int idComp);
int cvxCrvPntProj(int idCurve, svxPoint*, double *T, svxPoint*);
int cvxDataGetPromote(int idData, int idField, int *Promote);
int cvxDataSetPromote(int idData, int idField, int Promote);
int cvxEntComp(int idEntity, int idComp);
void cvxPartExit(void);
int cvxPartSweep(svxSweepData *Swp, void *Options, int *idShape);
--------------------------------------------------------------------------
14.05 - May 2009
New functions:
int cvxEntTextInq(int idText, char **Text);
int cvxEntTextMod(int idText, char *Text);
int cvxDataGetText(int idData, int idField, int NumBytes, char*);
--------------------------------------------------------------------------
14.01 - April 2009
Structure changes:
Replaced "vxName Name" with "char Name[65]" in the "svxTplFld" structure.
Added a "svxAttribute No_bom" field to the "svxPartAttribute" structure.
New functions:
int cvxRootVisibility(vxName Name, int Visible);
void cvxShowDisp(int SlideNumber);
void cvxShowOpen(vxPath File);
--------------------------------------------------------------------------
14.00 - Dec 2008
New functions:
void cvxCellColorBack(char *Form,int idField,int Row,int Col,svxColor);
void cvxCellColorFront(char *Form,int idField,int Row,int Col,svxColor);
void cvxCellCombo(char *Form,int idField,int Row,int Col,char *Labels);
void cvxCellFromItem(int idItem, int *Row, int *Col);
void cvxCellMode(char *Form,int idField,int Row,int Col,int Edit);
void cvxCellToItem(int Row, int Col, int *idItem);
int cvxEntByLabel(int *Label, int Exact, int *idEntity);
int cvxEntLabelGet(int idEntity, int **Label);
int cvxEntLabelSet(int idEntity, int *Label);
int cvxEntRgbGet(int idEntity, svxColor *Color);
int cvxEntRgbSet(svxColor Color, int Count, int *idEnts);
int cvxFaceEval2(int idFace,double U,double V,svxPoint*,svxVector*Normal,
svxVector*Utan,svxVector*Vtan);
int cvxFacePntLoc(int idFace, double U, double V, evxPntLocation *);
int cvxFacePntProj(int idFace, svxPoint*, double *U, double *V);
void cvxItemToRC(int idItem, int *Row, int *Column);
void cvxItemFromRC(int Row, int Column, int *idItem);
int cvxLabelMatch(int *Label1, int *Label2);
int cvxPartFace(svxSurface*, int NumCurves, svxCurve *TrimCurves,
int Code, int Sew, double Tol, int *idFace);
int cvxPartHistEnd(void);
int cvxPartHistStart(vxName);
int cvxPartInqEdgeCrv(int idEdge, int idFace, svxCurve *Crv);
int cvxPartInqFaceSrf(int idFace, svxSurface *Srf);
int cvxPartInqFaceCrvs(int idFace,int *Count,int **TrimCurves);
int cvxPartSew(double Tol, int *OpenEdges, double *MaxGap);
void cvxSurfaceFree(svxSurface *Srf);
void cvxVecReverse(svxVector *Vector);
--------------------------------------------------------------------------
14.00 - Aug 2008
New functions:
extern int cvxPartHistRename(int idOp, vxName Name, char *Descript);
extern int cvxRootAdd2(evxRootType, vxName Name, vxName Template, char *Desc);
extern int cvxRootRename2(vxName Name,vxName NewName,char *Descript,int Update);
--------------------------------------------------------------------------
13.65 - June 3, 2008
New functions:
int cvxPartChamAng(int Cnt,int*Edges,int idFace,double Sb,double Angle);
int cvxPartChamAsym(int Cnt,int*Edges,int idFace,double Sb1,double Sb2);
int cvxPartChamConst(int Count, int *Edges, double Sb);
int cvxPartInqShapeMass(int idShape, double Density, svxMassProp*);
int cvxDataGetNum(int idData, int idField, double *Number);
int cvxDataSetPntOnFace(int idData, int idField, int idComp, int idFace);
Modified functions:
int cvxSubPartIns(vxName Name, int AutoRegen, int MergeDimen);
--------------------------------------------------------------------------
14.00 - Feb 17, 2008
Modified the svxPartAttribute structure defined in VxApi.h.
--------------------------------------------------------------------------
13.55 - March 10, 2008
New functions:
void cvxAutoRegenGet(int *Status);
void cvxAutoRegenSet(int Status);
int cvxCompRegenSet(int idComp, int Regen);
int cvxEntMatrix2(svxEntPath Entity, svxMatrix *Matrix);
int cvxPartHistDel(int Count, int *Operations);
int cvxPartMovePntToPnt(int idEntity,svxAxis*S,svxAxis*E);
int cvxRootActivate2(vxName File, vxName Name);
void cvxSubPartFlag(vxName File, vxName Part, int isSubPart);
--------------------------------------------------------------------------
Version 13.43 - Dec 10, 2007
New functions:
int cvxDataGetEnt(int idData, int idField, int *idEnt);
int cvxDataGetPnt(int idData, int idField, svxPoint*);
void cvxFileTypeGet(int *MultiObject);
void cvxFileTypeSet(int MultiObject);
--------------------------------------------------------------------------
Version 13.42 - Oct 24, 2007
New functions:
void cvxHistDisable(void);
void cvxHistEnable(void);
--------------------------------------------------------------------------
Version 13.4 - Sept 28, 2007
New functions:
void cvxMsgDisable(void);
void cvxMsgEnable(void);
void cvxErrDisable(void);
void cvxErrEnable(void);
--------------------------------------------------------------------------
Version 13.4 - August 29, 2007
New functions:
void cvxPntOnFace(int idComp, int idFace, double Param[2], svxPoint *Point);
--------------------------------------------------------------------------
Version 13.38 - July 11, 2007
New functions:
void cvxMenuItemState(vxName Menu, int Item, int State);
This function can be used to enable/disable a button or icon on
a ZW3D menu or toolbar, including custom toolbars.
Structure changes:
Added "vxName DestFile" to the "svxCompData" structure. This field may
be used to specify the destination file when "Copy=1". The field is
ignored if it contains an empty or blank string (DestFile[0]=0).
--------------------------------------------------------------------------
Version 12.90 - June 27, 2007
New functions:
void cvxCmdMarker(vxName Okay, vxName Cancel);
--------------------------------------------------------------------------
Version 12.82 - Feb 21, 2006
Retired function:
void cvxDispPreview(evxPreviewMode Mode, vxName File, vxName Object);
New functions:
int cvxPartCurve(svxCurve *Crv, int *idEnt);
int cvxPartInqCurve(int idEntity, int Nurb, svxCurve *Crv);
int cvxPartInqLoopEdges(int idLoop,int *Count,int **Edges);
int cvxPartInqShapeEdges(int idShape,int *Count,int **Edges);
int cvxPartInqFaceLoops(int idFace,int Inner, int *Count,int **Loops);
void cvxRootPreviewSet(evxPreviewMode Mode, vxName File, vxName Object);
evxPreviewMode cvxRootPreviewGet(void);
Fixed functions:
cvxHostId(void);
int cvxPartInqVars(...);
--------------------------------------------------------------------------
Version 12.70 - Dec 1, 2006
New functions:
void cvxDispPreview(evxPreviewMode Mode, vxName File, vxName Object);
void cvxHostId(double *idNetwork, double *idDongle);
int cvxPartInqHoles(vxName File,vxName Part,int *Count,svxHoleData**);
int cvxPartFreeHoles(int Count,svxHoleData**);
int cvxPartInqFtrTemplate(int idFeature, vxName Template);
int cvxPartInqVars(vxName File, vxName Part, int *Count, svxVariable**);
Modified functions:
int cvxRootList(vxPath File, int *Count, vxName **Names);
--------------------------------------------------------------------------
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: API Structure Introduction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ListPages
API Structure Introduction

API Structure

Remark：We will continue to expand API structure

1. Basic Modules

General modules including general interface, structure, enumeration, ect.

1.1 General Data

General interface, structure, and enumeration. Define header file in zwapi_util.h.

1.2 Configuration

Corresponding to function of configuration in ZW3D, this can get or modifiy the current configuration. The default configuration locates at install directory:supp/config.xml, and name is corresponding to the first input parameter and header file defined in zwapi_config.h

1.3 Global Application

Global settings or global tools, sucn as configuration of unit, color, software version, language, sketch grid, etc. And tools of inquiring name and label matching. Define header file in zwapi_global_apply.h

1.4 Authorization

Authorization related API. Define header file in zwapi_license.h

1.5 Display

Software display area related API. Display on/off, light and scale, etc. Define header file in zwapi_display.h

1.6 Message

Message processing module, such as printing different type of error and warning message. Define head file in zwapi_message.h

1.7 View

General view API. Define header file in zwapi_view.h

1.8 Memory

Memory released API. Define header file in zwapi_memory.h

1.9 File Root

File root related API, and general interface for single file and multi-root file. Define header file in zwapi_root.h

1.10 Layer

Layer general API. Define header file in zwapi_layer.h

1.11 Event

Event related API, such as undo and redo, ect. Define header file in zwapi_xn.h

1.12 Standard General API

Dimension general API, such as operation of dimension attribute, dimension text and value, etc. Define header file in zwapi_dim.h
Creating dimension interface is in "Command Creation" module, which classifies in different environments and ZW3D Ribbon.
In different environments, API about dimension inquire is in "Environment Object" module.

1.13 Expression General API

Expression general API and expression, etc. Define header file in zwapi_var.h
In different environments, API about expression inquire is in "Environment Object" module.

1.14 Text General API

Text general API, such as operation of dimension attribute, dimension text and value, etc. Define header file in zwapi_text.h
Creating text interface is in "Command Creation" module, which classifies in different environments and ZW3D Ribbon.
In different environments, API about text inquire is in "Environment Object" module.

1.15 Entity General API

All object general API, such as inquiring object name, id, and setting color, etc. Define header file in zwapi_general_ent.h
In general, these history objects are created by modeling commands in "Command Creation" module.

1.16 User Interaction Module

Interaction API of user pick and selection. Define header file in zwapi_userinput.h

2. File Module

File related operation, such as close, open, save, import and export, file operation and file path operation.

2.1 File Data

File module is applied to structure and enumeration, etc. Define header file in zwapi_file_data.h

2.2 File Operation

File basic operation and inquire API. Define header file in zwapi_file.h

2.3 Path Operation

Operation of file path or user search path and inquiring API. Define header file in zwapi_file_path.h

3. Topology Entity Module

Generate Brep entity by modeling in part environment, including entity objects like shape, face, edge, loop, and vertex, etc.

3.1 Brep Data

Structure and enumeration used in topology entity module. Define header file in zwapi_brep_data.h

3.2 Shape API

Shape attribute and inquire related API. Define header file in zwapi_brep_shape.h
Modeling commands that generated by general shape entitys are defined in "Command Creation" -> "Part Assembly Commands" -> "Shape"

3.3 Face API

Face attribute and inquire related API. Define header file in zwapi_brep_face.h
Modeling commands that generated by general surfaces are defined in "Command Creation" -> "Part Assembly Commands" -> "Surface"

3.4 Edge API

Edge inquire related API. Define header file in zwapi_brep_edge.h

3.5 UV Edge API

UV edge inquire related API. Define header file in zwapi_brep_preedge.h

3.6 Vertex API

Vertex inquire related API. Define header file in zwapi_brep_vertex.h

4. Algorithm Module

4.1 Algorithm Module Data

Structure and enumeration that are used to calculate geometry(point, line, face,etc), matrix, bounding box, and interference. Define header file in zwapi_math_data.h

4.2 General Calculation

Calculation tools and API that is not clearly classified. Define header file in zwapi_math.h

4.3 Bounding Box Calculation API

Bounding box related API, such as initialization, combination, endpoint, etc. Define header file in zwapi_math_bndbox.h

4.4 Interference Before Entity API

Entities between entities, interference calculation before entities and rays. Define header file in zwapi_math_insect.h

4.5 Point Related Algorithm API

Point position, distance, and projection light. Define header file in zwapi_math_point.h

4.6 Vector API

Vector calculation API. Define header file in zwapi_math_vector.h

4.7 Matrix API

Matrix calculation API. Define header file in zwapi_math_matrix.h

5. Interface Module

5.1 UI Data Module

Structure and enumeration that are used in UI control related API. Define header file in zwapi_ui_data.h

5.2 Form

Basic operations on form. Define header file in zwapi_ui_form.h

5.3 ComboBox

Basic operations on ComboBox. Define header file in zwapi_ui_combobox.h

5.4 List Widget

Basic operations on list. Define header file in zwapi_ui_listwidget.h

5.5 Table Widget

Basic operations on table. Define header file in zwapi_ui_tablewidget.h

5.6 Tab Widget

Basic operations on tab. Define header file in zwapi_ui_tabwidget.h

5.6 Tree View

Basic operations on tree. Define header file in zwapi_ui_treeview.h

5.7 Slider

Basic operations on slider. Define header file in zwapi_ui_slider.h

5.8 Ribbon

Basic operations on Ribbon interface. Define header file in zwapi_ui_ribbon.h

5.9 Popup Window

Basic operations on right-clicking popup window. Define header file in zwapi_ui_popupform.h

5.10 Graphics UI Setting

User role and user interface general settings. Header file is included in zwapi_ui_guiset.h

6. Part Object Module

Basic operations of inquiring, modifying, and attribute of part and storage entity object in the part environment. Use modeling command to create entity object that defined in "Command Creation" -> "Part Assembly Command".

6.1 Part Object Data

Structure and enumeration used in part object module. Define in zwapi_part_data.h

6.2 Part Attribute

Part attribute API. Define header file in zwapi_part_attribute.h

6.3 Sheet Metal Attribute

Sheet metal attribute API. Define header file in zwapi_part_sheetmetal_attribute.h
Sheet metal command is defined in "Command Creation"->"Part Assembly Command"->"Sheet Metal".

6.4 Hole Attribute

Hole attribute API. Define header file in zwapi_part_hole.h

6.5 Block/Facet

Block and facet related API. Define header file in zwapi_part_facets.h

6.6 History Tree Object

History tree object inquiring, setting, attribute, etc. API in part. Define header file in zwapi_part_history.h
Operations of edition and deletion of history object that defined in "Command Creation"->"Part Assembly Command"->"Part Contect Menu Command".

6.7 Datum Object

Data access API of datum axis, datum plane, and CSYS. Define header file in zwapi_part_datum_query.h
Datum object creation that defined in "Command Creation"->"Part Assembly Command"->"Datum".

6.8 Dimension

Dimension inquiring object API in the part environment. Define header file in zwapi_part_dim.h
In the part environment PMI creation is defined in "Command Creation"->"Part Assembly Command"->"PMI".
Dimension general API module of dimension attribute. Define header file in zwapi_dim.h

6.9 Expression

Expression inquiring and increasing API in the part environment. Define header file in zwapi_part_var.h
Expression general API defined in zwapi_var.h

6.10 Other Object

Other objects in part such as object assess API of curve, text, point, etc. Define header file in zwapi_part_var.h

6.11 View

View inquiring and creating API in the part. Define header file in zwapi_part_var.h
View general API defined in zwapi_view.h

6.12 Part Configuration

Part configuration table increasing and inquiring API. Define header file in zwapi_part_config.h

6.13 Part Operation

Pop-up menu, history operation, entity operation, etc. in the part environment. Define header file in zwapi_part_opts.h

7. Assembly Object Module

Basic operations of storage entity object inquiring, modifying, and attribute, etc. Use modeling command creating entity object that defined in "Command Creation"->"Part Assembly Command"->"Assembly".

7.1 Assembly Object Data

Structure and enumeration used in assembly object module. Define header file in zwapi_asm_data.h

7.2 Component Attribute

Component attribute API. Define header file in zwapi_asm_comp_attribute.h

7.3 Component

Component inquiring and setting API. Define header file in zwapi_asm_comp.h
Component insertion and combination commands that defined in "Command Creation"->"Part Assembly Command"->"Assembly".

7.4 Constraint

Assembly constraint API. Define header file in zwapi_asm_constraint.h
Assembly constraint creating commands that defined in "Command Creation"->"Part Assembly Command"->"Assembly".

7.5 Reuse Library

Reuse library related API. Define header file in zwapi_asm_reuselibrary.h

7.6 Assembly Operation

Pop-up menu, component operation, constraint operation in the assembly environment. Define header file in zwapi_asm_opts.h

8. Drawing Sheet Object Module

Basic operations on stored entity object inquiring, modifying, attribute, etc. in the drawing sheet environment. Using modeling command to create entity objects that defined in "Command Creation"->"Drawing Sheet".

8.1 Drawing Sheet Object Data

Structure and enumeration that used the object module in the drawing sheet environment. Define header file in zwapi_dwg_data.h

8.2 Drawing Sheet Attribute

Drawing sheet attribute. Define header file in zwapi_dwg_attribute.h

8.3 Drawing Sheet

Drawing sheet related API. Define header file in zwapi_dwg_drawing.h

8.4 View

View inquiring and setting API of the drawing sheet. Define header file in zwapi_dwg_drawing.h
Drawing sheet view creating command that defined in "Command Creation"->"Drawing Sheet Command"->"Layout".

8.5 Dimension

Dimension inquiring API of drawing sheet. Define header file in zwapi_dwg_dim.h
Dimension creation comm of drawing sheet that defined in "Command Creation"->"Drawing Sheet Command"->"Dimension".
Dimension attribute in dimension general API modules that defined in zwapi_dim.h

8.6 Symbol

Symbol object inquiring and setting API of drawing sheet. Define header file in zwapi_dwg_symbol.h
Symbol object creating command of drawing sheet that defined in "Command Creation"->"Drawing Sheet Command"->"Dimension".

8.7 Table

Table object inquiring and setting API of drawing sheet. Define header file in zwapi_dwg_table.h
Table object creating command of function drawing sheet is defined in "Command Creation"->"Drawing Sheet Command"->"Layout".

8.8 Geometry Object

Geometry object(point, line, text, etc.) inquiring and setting in drawing sheet. Define header file in zwapi_dwg_geometry.h
Geometry object creating command of drawing sheet that defined in "Command Creation"->"Drawing Sheet Command"->"Drawing".

9. Sketch Object Module

Basic operations of entity object inquiring, modifying, attribute, etc. in the sketch environment. Use modeling command creating entity object that defined in "Command Creation"->"Sketch Command".

9.1 Sketch Object Data

Structure and enumeration that used in the sketch object module. Define header file in zwapi_sk_data.h

9.2 Sketch Attribute

Sketch attribute. Define header file in zwapi_sk_attribute.h

9.3 Geometry Object

Geometry object (point, line, text, ect.) inquiring and setting API in the sketch. Define header file in zwapi_sk_objs.h
Sketch's geometry object creating commands that defined in "Command Creation"->"Sketch Command"->"Sketch".

9.4 Dimension

Sketch's dimension object inquiring and setting API. Define header file in zwapi_sk_dim.h
Sketch's dimension object creating commands that defined in "Command Creation"->"Sketch Command"->"Sketch".
Dimension general API module of dimension attribute which is defined in zwapi_dim.h

9.5 Expression

Sketch's expression inquiring and setting API. Define header file in zwapi_sk_var.h
Expression general API defined in zwapi_var.h

9.6 Sketch Operation

Geometry object operation in the sketch environment. Define header file in zwapi_sk_opts.h

10. CAM Module

Basic operations of creating, inquiring, and modifying of part, feature, operation, machining, etc. in the CAM environment.

10.1 CAM Part

Attribute inquiring and setting API for CAM part. Define header file in zwapi_cm_comp.h

10.2 CAM Tree

Creating, moving, and setting API of CAM tree's folder in the CAM part environment. Define header file in zwapi_cm_folder.h

10.3 CAM Interface

UI and setting API in the CAM part environment. Define header file in zwapi_cm_forms.h

10.4 CAM Feature

Feature's creating, attribute inquiring, and setting API in the CAM part environment. Define header file in zwapi_cm_ftr.h

10.5 CAM Inquire

General attributes(name, type, etc.) inquiring API in the CAM part environment. Define header file in zwapi_cm_query.h

10.6 CAM Machine

Machine's creating, attribute inquiring, and setting API in the CAM part environment. Define header file zwapi_cm_machine.h

10.7 CAM Operation

Creating, parameter inquiring, and setting API in the CAM part environment. Define header file in zwapi_cm_machine.h

10.8 CAM Tool

Creating, parameter inquiring, and setting API in the CAM part environment. Define header file in zwapi_cm_tool.h

11.Command Creation

Classify by command Ribbon of ZW3D and environments

11.1 Command Parameter

11.1.1 Command Data

Structure and enumeration that used in command module. Define header file in zwapi_cmd_data.h

11.1.2 Command API

Template/Custom command common API, command send, function register, macro etc. Define header file in zwapi_cmd.h

11.1.3 Template

  • 11.1.3.1 Template Container
    Template related API of template commands. Define header file in zwapi_cmd_paramdefine_tpl.h
  • 11.1.3.2 Command Parameter
    All fields of parameter related API in template commands. Define header file in zwapi_cmd_paramdefine_param.h

11.2 Part and Assembly Commands (ZW3D Modeling)

11.2.1 General Commands

  • 11.2.1.1 Datum
    Commands such as datum axis, datum plane, and CSYS. Define header file in zwapi_cmd_datum.h
  • 11.2.1.2 Sketch
    Creating commands of sketch and cosmetic sketch. Define header file in zwapi_cmd_paramdefine_param.h
  • 11.2.1.3 UDF
    UDF command related API. Define graphic file in zwapi_cmd_paramdefine_param.h

11.2.2 Ribbon Command

  • 11.2.2.1 Shape
    Commands in Basic Shape, Engineering Feature, Edit Shape, Morph, Basic Editing, etc. Define header file in zwapi_cmd_shape.h
  • 11.2.2.2 FreeFrom
    Commands in Basic Face, Edit Face, Editing Edge, Basic Editing, etc. Define header file in zwapi_cmd_freeform.h
  • 11.2.2.3 Wireframe
    Commands in Drawing, Curve, Edit Curve, Basic Editing, etc. Define header file in zwapi_cmd_wireframe.h
  • 11.2.2.4 Assembly
    Commands in Component, Constraint, Basic Editing, etc. Define header file in zwapi_cmd_assembly.h
  • 11.2.2.5 Sheet Metal
    Commands in Base, Flange, Editing, Corner, Form, Bend, etc. Define header file in zwapi_cmd_sheetmetal.h
  • 11.2.2.6 Data Exchange
    Commands in Import, Export, Engineering Feature, etc. Define header file in zwapi_cmd_dataexchange.h
  • 11.2.2.7 ECAD
    Commands in Basic Editing, Basic Shape, Engineering Feature, etc. Define header file in zwapi_cmd_ecadboard.h

11.3 Drawing Sheet Commands

11.3.1 Ribbon Commands

  • 11.3.1.1 Layout
    Commands in View, Table, Edit View, ect. Define header file in zwapi_cmd_dwg_layout.h
  • 11.3.1.2 Dimension
    Commands in Dimension, Annotation, Symbol, etc. Define header file in zwapi_cmd_dwg_dimension.h
  • 11.3.1.3 Drawing
    Commands in Drawing, Curve, Edit Curve, Basic Editing, etc. Define header file in zwapi_cmd_dwg_drawing.h

11.4 Sketch Commands

11.4.1 Menu Commands

  • 11.4.1.1 Sketch
    Commands in Exit, Drawing, Curve, Edit Curve, Constraint, Dimension, etc. Define header file in zwapi_cmd_sk_cmds.h
  1. Tool Module

General basic interface, such as the basic interface of entity path, ect.

12.1 Entity Path The basic interface of entity path, Define header file in zwapi_tool_entpath.h

Commonly used abbreviations

First Header | Second Header | Third Header
Asm - assembly | Dwg - drawing | Sk - sketch
Cm - cam | Dim - dimension | Var - variable
Crv - curve | Srf - surface | Ent - Entity
Obj - Object | Pnt - Point | Shp - Shape
Fac - face | Edg - Edge | Parm - parameter
Tpl - template | Comp - Component | At - attribute
Vis - visibility | Mod - Modify | Cmd - command
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Introduction to the ZW3D API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ListPages
Introduction to the ZW3D API

Introduction

The ZW3D API is a basic set of C functions for implementing custom commands and operations in ZW3D.

The ZW3D API is used to create DLL's that are dynamically loaded by ZW3D at runtime. Functions in a ZW3D API DLL may be invoked from the ZW3D user interface directly.

"Hello World" Example

Example

The following example shows how to create a ZW3D API DLL with a function that prints "Hello World" in the ZW3D message area.

1) Copy zw3d.lib from the ZW3D installation folder to a local folder (i.e. "MyFolder"). The path of the installation folder is listed under the "About..." option on the ZW3D "Help" pulldown menu.

2) Copy zwapi_**.h from the "api" folder to "MyFolder".

3) Create a simple text file named MyLib.c in "MyFolder" using Notepad or a similar text editor. Type the following code in the file. You may ignore the comments, which are included here for your instruction.

#include "zwapi_cmd.h"
#include "zwapi_message.h"
void MyFunction(void);
/*
* You must supply an initialization function whose name
* is the name of your DLL suffixed with "Init" (MyLibInit).
*
* This function is automatically called by ZW3D when it
* loads your DLL at startup.
*
* It should perform whatever initializations your DLL
* requires, such as registering your callback functions.
*
* The function must be declared with the arguments shown.
*
* The function should return 0 if it is successful; 1 if it fails.
*/
int MyLibInit(int format, void *data)
{
/* register your function with ZW3D */
cvxCmdFunc("MyFunction",(void*)MyFunction,VX_CODE_GENERAL);
return(0);
}
/*
* You must also supply an exit (i.e. cleanup) function whose
* name is the name of your DLL suffixed with "Exit" (MyLibExit).
*
* This function is automatically called by ZW3D during its
* shutdown (i.e. exit) process.
*
* It should perform whatever cleanup your DLL requires
* before ZW3D is shutdown.
*
* This function should always return 0.
*/
int MyLibExit(void)
{
/* put your cleanup code here */
cvxCmdFuncUnload("MyFunction");
return(0);
}
/*
* This is the function registered in MyLibInit().
*/
void MyFunction(void)
{
cvxMsgDisp("Hello world!");
}
cvxCmdFuncUnload
evxErrors cvxCmdFuncUnload(const vxName Name)
cvxCmdFunc
evxErrors cvxCmdFunc(const vxName Name, void *Function, double Code)
cvxMsgDisp
void cvxMsgDisp(char *Text)
zwapi_cmd.h
zwapi_message.h

4) Create another text file named "MyLib.def" in "MyFolder". This file must specify all functions "exported" by your library. Type the following text in it.

  • LIBRARY MyLib.dll
  • EXPORTS
  • MyLibInit
  • MyLibExit
  • MyFunction

5) Build MyLib.dll using the following commands:

cl.exe /nologo /c /MT /LD /Z7 MyLib.c
link /DEF:MyLib.def /DLL /OUT:MyLib.dll *.obj zw3dmain.lib

6) Copy MyLib.dll from "MyFolder" to a sub-folder named "apilibs" in your ZW3D user folder or main ZW3D program folder. The paths to these folders are shown at the bottom of the first tab of the ZW3D Configuration menu (see Utilities/Configuration... or Help/About...).

7) Start ZW3D. It will automatically load DLL's found in an "apilibs" folder.

8) Type "~MyFunction" at the ZW3D command line. ZW3D invokes MyFunction(), which prints "Hello World" in the ZW3D message area. This command string (~MyFunction) can be assigned to an icon or button on a custom toolbar. An example showing how to register a custom toolbar with ZW3D is given later in this section.

Please refer to Frequently Asked Questions page for more details.

Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Frequently Asked Questions

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ListPages
Frequently Asked Questions

How to configure the DLL project?

Step 1: Build an empty DLL project with Vsiual Studio 2019.

Step 2: Add project files. The following files should be added to the DLL project:

VxApi.h : header file provided by ZW3D (The header file can be found in "api" folder of ZW3D install directory)
zw3d.lib : library file provided by ZW3D (The library file can be found in ZW3D install directory)
XXX.def : module definition file used to define interfaces that DLL exports
XXX.c/XXX.cpp: source code files
XXX.tcmd : resource files of ZW3D command (There's no necessary to add any .tcmd file to DLL project if the application has no need to show any command that has a ZW3D-style GUI.)
XXX.ui : resource files of ZW3D-style command form or dialig (There's no necessary to add any .ui file to DLL project if the application has no need to show any ZW3D-style command form or dialig.)
XXX.zcui : menu file. (There's no necessary to add any .zcui file to DLL project if developer does not need to show the new command in the menu.)
XXX.png/XXX.bmp : icon file.
zrc.exe : resource tool that compile your *.tcmd, *.ui, *.zcui and icon files into a binary data file named as XXX.zrc

Step 3: Specify module definition file.

How to compile the resource files into a zrc file?

Use the cmd.exe and specify the directory and output name to compile the resource files.

For example, supposing your project directory is "D:\project",
"cd" to ZW3D's install directory in cmd, and execute the command line
"zrc.exe D:\project -o D:\project\XXX.zrc". zrc.exe will search your
project directory to find out all resource files(*.tcmd and so on).

Please note that the zrc file name must be the same as the DLL file name.

Which folder shall I put the DLL and resource file in to let ZW3D load them when startup?

Put the DLL and zrc to the apilibs folder in ZW3D install directory, which name is "apilibs".

"apilibs" folder is not exist after installing ZW3D, developer need to create it manually.

How to debug the DLL project?

Method 1:

  1. Open the "Attach to Process" dialog via menu: "Debug" | "Attach to Process...".
  2. Choose "zw3d.exe" from the available processes list and click "Attach" button.

Method 2:

  1. Open the properties dialog of the project.
  2. Enter the path of "zw3d.exe" at "Debugging" | "Command".
    Enter "_No_Debug_Heap=1" at "Debugging" | "Environment".
    Click "OK" button to save and apply configuration.
    Press "F5" key to start debugging.

When executing the command, ZW3D shows "ALERT: Unable to find XXXXX: No such symbol" or "ALERT: [XXXXX] is not a valid command" in tip area, how to resolve the problem?

There are several reasons for this problem to come into being:

  1. The initialization function name is not correct and ZW3D can not find it when loading the DLL. The initialization function name must be the name of your DLL suffixed with "Init". For example, the initialized function name must be "DrawBoxInit" if the DLL name is "DrawBox".
  2. The DLL does not export the functions. Third party developer need to declare DLL export functions in module definition file (.def file).
  3. The command has not been registered. Third party developer need use cvxCmdFunc() to registering command.
  4. If a command associate with a command file (.tcmd), call it with an exclamation point(!) prefix, else call it with a tilda(~) prefix.
  5. If ZW3D fail in activing command with an exclamation point(!) prefix, it is possible that the zrc file does not in the apilibs folder or you forget to re-compile the resource files.

How to uninstall the DLL application?

ZW3D load and unload Dll dynamically, so delete the DLL file and the other file(s) it uses can uninstall the DLL application completely.

How many DLL files ZW3D can load at the same time?

Sixteen.

What is the registered command name?

The registered command name is a keyword used to register function.
The registered command name must be the same as the name used in command and UI file (XXX.tcmd and XXX.ui file). For example:

cvxCmdFunc("CreateHole", (void*)ModelAddHole, VX_CODE_GENERAL);
cvxCmdFunc
evxErrors cvxCmdFunc(const vxName Name, void *Function, double Code)

"CreateHole" is the registered command name.
"ModelAddHole" is the implementation function pointer of command.
VX_CODE_GENERAL indicates the operation type of command.

What is the maximum length of registered command name?

No more than 15 ASCII characters. For example, "CreateMySurface" is a valid name while "CreateFilletFace" is not.

What's "Custom Feature"? What's difference from common feature?

In ZW3D, developer can combine two or more features into one and the combined feature is custom feature. Using the following keyword in command file (XXX.tcmd) to declare the registered command name, and then all features created with "FilletBox" command will be combined into a custom feature:

<property name="function">CustomOp</property>
<property name="custom">FilletBox.c</property>

"FilletBox" is the registered command name. the suffix ".c" indicates that implementation function related to the registered command is a C language function.

The command template for a custom feature should include the parameter "op_type=X", where "X" is one of the following values. If "op_type" is not specified, "op_type=0" is used by default.

  • -1 - Flag the feature as invisible in the history
  • 0 - This feature's type is not classified (i.e. options 1, 2 or 11 do not apply)
  • 1 - This feature modifies the visibility or display attributes of existing entities, including entities not explicitly referenced in the feature's input data.
  • 2 - This feature may geometrically modify entities explicitly listed in the input data (this does not include entity deletions, unless a delete may modify an entity without completely moving it, like deleting a face from a shape).
  • -2 - This option is the same as option 2 except that, like option 11, it prevents explicit entity picks from being cleaned from the feature's input data.
  • 3 - Erase/Delete operation. This is treated as a special-case in code that traces feature networks.
  • 11 - This feature does not modify entities explicitly referenced in its input data, but it may create new entities or modify entities not explicitly documented in the input data.
    THIS OPTION PREVENTS EXPLICIT ENTITY PICKS FROM BEING CLEANED FROM VDATA.
  • 12 - This feature contains static geometry restored each time the feature is regenerated.
    The feature cannot be redefined. It has no parent dependencies, but downstream history operations can be dependent on it.

Why some API functions generate history while the other not?

If the API function does not modify any entities like query or create a Z3 file, it won't generate history.
In principle, if an operation will generate history through interact with ZW3D, the API function do the same operation will generate history too.

Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Remote Communication with ZW3D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ListPages
Remote Communication with ZW3D

You can send a command string to ZW3D from a command console using the following syntax:

zw3dremote -r local cmd="this is my command string"

Or, you can send the command to ZW3D from your separately running executable using the system() function as follows:

system("zw3dremote -r local cmd=\"this is my command string\"");

If ZW3D is not running, it will start ZW3D up and then execute the command.
Otherwise, it will pass the command to the active instance of ZW3D.

If you copy "zw3dremote.exe" from the ZW3D installed folder to the folder your application is running from, you can pass the command string to the local copy of "zw3dremote.exe", which is a relatively small executable (~400 KB).
"zw3dremote.exe" will locate the actively running instance of ZW3D and pass the command string to it.
If it can't find a running instance of ZW3D, it will look for ZW3D in the active folder.
If it doesn't find it there, it will look in the Windows registry for the last installed version of ZW3D.
It will startup whatever version of ZW3D it finds first.

A ZW3D command template can be executed using a command string composed of an exclamation character "!" followed by the template name.
For example, the following command would start up ZW3D and execute the command template named "MyTemplate", presuming it was registered with ZW3D by the "Init" function of your ZW3D API DLL.

zw3dremote -r local cmd="!MyTemplate"

If a command is preceded by a tilda (~), it is assumed to be the name of a void function with void arguments (void function(void)).
Passing this command string to ZW3D causes the specified function to be called, including custom functions implemented and registered by your ZW3D API DLL.

zw3dremote -r local cmd="~MyFunction"

The ZW3D GUI invokes the internal functionality of ZW3D via command strings.
You can see the strings by typing "$report" (without quotes) in the ZW3D text input area.
As you press icons and buttons in the ZW3D GUI, you will see corresponding command strings in the ZW3D message area.

You can also send macro commands to ZW3D from a remote application.
There is information on this topic in the online help for the ZW3D macro language (i.e. Design Automation Language) under the section named "Passing Macro Commands to ZW3D from Remote Applications".
This includes a mechanism for returning data queried using macro commands.

You can remotely shut down ZW3D by send it the "CdPrjQuit4" command string.

zw3dremote -r local cmd="CdPrjQuit4"

You can bring up ZW3D in "hidden" mode (i.e. its window is not displayed) by including "-hide" in the ZW3D startup command.

zw3dremote -hide

You can bring up ZW3D with its window minimized using the "-minimized" argument.

zw3dremote -minimized
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Modules

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Here is a list of all modules:
[detail level 1234]
► Common
Configuration
Dimension Common API
Display
General Entity API
Global Apply
Layer
License
Memory
Message
File Root
Text Common API
User Input
Common Data
Variable Common API
View
Transaction
► File
File
File Data
Path Operation
► Part Objects
Part Attribute
Part Configuration
Part Data
Datum Query
Part Dimension API
Part Facets/Block
History API
Hole Attribute
Part Objects API
Part Objects Operation
Sheet Metal Attribute
Part Variable API
Part View API
► Assembly Objects
Assembly Component API
Component Attribute
Assembly Constraint API
Assembly Data
Assembly Objects Operation
Reuse Library
► Drawing Objects
Drawing Attribute
Drawing Data
Drawing Dimension API
Sheet/Drawing API
Drawing Geometry API
Drawing Symbol API
Drawing Table API
Drawing View API
► Sketch Objects
Sketch Attribute
Sketch Data
Sketch Dimension API
Sketch Object API
Sketch Objects Operation
Sketch Variable API
► Cam
Cam Component API
Cam Folder API
Cam Forms API
Cam Frame API
Cam Feature API
Cam Machine
Cam Operation
Cam Query
Cam Tool
► Brep
Brep Data
Edge API
Face API
Loop API
Preedge API
Shape API
Vertex API
► Math
Math Common API
Bounding Box Math API
Math Data
Entities Intersection API
Matrix API
NURBS Curve
NURBS Surface
Point Math API
Vector API
► UI
Combobox
UI Data
Form
Gui Set
List Widget
Popup Form
Ribbon
Slider
Table Widget
Tab Widget
Tree View
► Commands Creation
► Command Definition
Command API
Command Data
► Template Command
Template Field API
Template API
► Part and Assembly Commands
Assembly Commands
Assembly Commands Data
Data Exchange Commands
Data Exchange Commands Data
Datum Commands
Datum Commands Data
Direct Edit
Direct Edit Commands Data
ECAD Board Commands
ECAD Board Commands Data
Free Form Commands
Free Form Commands Data
PMI Commands
PMI Commands Data
Shape Commands
Shape Commands Data
Sheet Metal Commands
Sheet Metal Commands Data
Create Sketch Commands
Create Sketch Commands Data
Sub Commands
Sub Commands Data
UDF API
UDF Data
Wireframe Commands
Wireframe Commands Data
► Drawing Commands
Drawing Commands Data
Drawing Dimension Commands
Drawing Commands
Layout Commands
► Sketch Commands
Sketch Apps
Sketch Commands Data
Sketch Commands
► Tool
Entity Path
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: Common

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Common

Detailed Description

Modules

Configuration
Dimension Common API
Display
General Entity API
Global Apply
Layer
License
Memory
Message
File Root
Text Common API
User Input
Common Data
Variable Common API
View
Transaction
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Configuration

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Configuration
Common

Detailed Description

THE MODULE FOR THE ZW3D Global Config API, the input "Name" of the following functions defined in "zw3d installation dir\\supp\\config.xml".

Config Get

void | cvxConfigGetColor (const char *Name, evxColor *Color)
evxErrors | cvxConfigGetInteger (const char *Name, int *Value)
evxErrors | cvxConfigGetNumber (const char *Name, double *Value)
int | cvxConfigGetOption (const char *Name, const char *Options)
evxErrors | cvxConfigGetRgb (const char *Name, svxColor *Rgb)
evxErrors | cvxConfigGetString (const char *Name, char *Str, int nBytes)
evxErrors | cvxConfigGetYesNo (const char *Name, int *YesNo)
evxErrors | cvxConfigPathGet (char *path, int sizepath)

Config Set

evxErrors | cvxConfigSetColor (const char *Name, evxColor Color)
evxErrors | cvxConfigSetInteger (const char *Name, int Value)
evxErrors | cvxConfigSetNumber (const char *Name, double Value)
evxErrors | cvxConfigSetOption (const char *Name, const char *Option)
evxErrors | cvxConfigSetRgb (const char *Name, svxColor *Rgb)
evxErrors | cvxConfigSetString (const char *Name, char *Str)
evxErrors | cvxConfigSetYesNo (const char *Name, int YesNo)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetColor()

void cvxConfigGetColor | ( | const char * | Name,
 |  | evxColor * | Color
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file.

VX_COLOR_BLACK is output if the variable value is not one of the standard color names.

This function should not be used to get the color from a variable whose value is a 3-integer RGB color.

Use the cvxConfigGetRgb() function for variables whose values are defined by their RGB components.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[out] | Color | value of the specified variable
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetInteger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetInteger()

evxErrors cvxConfigGetInteger | ( | const char * | Name,
 |  | int * | Value
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file. The variable value is assumed to be an integer (0 is assigned to "Value" when the value is not a number).

Note
The input "Name" is defined in "zw3d installation dir\\supp\\config.xml. @param [in] Name name of config file variable @param [out] Value value of the specified variable @retval succeeds - ZW_API_NO_ERROR @retval fail - ZW_API_GENERAL_ERROR - variable does not exist and set "value" to 0
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetNumber

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetNumber()

evxErrors cvxConfigGetNumber | ( | const char * | Name,
 |  | double * | Value
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file. The variable value is assumed to be a number (0 is assigned to "Value" when the value is not a number).

Note
The input "Name" is defined in "zw3d installation dir\\supp\\config.xml. @param [in] Name name of config file variable @param [out] Value value of the specified variable @retval succeeds - ZW_API_NO_ERROR @retval fail - ZW_API_GENERAL_ERROR - variable does not exist and set "value" to 0
  • ZW_API_INVALID_OUPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetOption()

int cvxConfigGetOption | ( | const char * | Name,
 |  | const char * | Options
 | ) |  |

#include <zwapi_config.h>

Given the variable name of a setting in the config file, look up the variable and compare its value as a string to the sub-strings
contained in the comma-delimited "Options" string, and return the index (numbered from 1) of the matching sub-string. The string comparison is case-insensitive.

For example, if "Options" is "mm,meter,mil,inch" and the value of the config file variable of interest is "meter", this function will return 2.

If the value of the config file variable is "foot", this function will return 0.

The "Options" string should have no more than 32 sub-strings, no sub-string should be longer than 31 bytes, and the sub-strings should not contain blank spaces.
If "Options" has more than 32 sub-strings, only the first 32 will be compared to the variable value.
If any sub-string is longer than 31 bytes, only its first 31 bytes will be compared to the variable value (the variable value must also be 31 bytes or less).

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Options | 0-terminated, comma-delimited allowed values
Return values
return
  • the index (numbered from 1) of the matching sub-string.
  • 0 - either the variable or sub-string cannot be found
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALD_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetRgb

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetRgb()

evxErrors cvxConfigGetRgb | ( | const char * | Name,
 |  | svxColor * | Rgb
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file.

The variable value is assumed to be the RGB components of a color, i.e. a comma-separated list of 3 integers between 0 and 255.

This function should not be used to get the color from a variable whose value is one of the standard color names rather than a 3-integer RGB color.

Use the cvxConfigGetColor() function for variables whose values are color names.

Note
The input "Name" is defined in "zw3d installation dir\\supp\\config.xml. @param [in] Name name of config file variable @param [out] Rgb value of the specified variable @retval succeeds - ZW_API_NO_ERROR - variable exists and has a value of 3 integers @retval fail - ZW_API_GENERAL_ERROR - variable does not exist and set "Rgb" to 0, 0, 0 (black)
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetString

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetString()

evxErrors cvxConfigGetString | ( | const char * | Name,
 |  | char * | Str,
 |  | int | nBytes
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file. The variable value is simply copied as a string to "Str".
If the value is longer than nBytes-1, the value is truncated to fit "Str".

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[out] | Str | 0-terminated value of the specified variable
[in] | nBytes | max size of Str array in bytes
Return values
succeeds
  • ZW_API_NO_ERROR - variable exists
fail
  • ZW_API_GENERAL_ERROR - variable does not exist and outputs an empty string
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Examples
drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigGetYesNo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigGetYesNo()

evxErrors cvxConfigGetYesNo | ( | const char * | Name,
 |  | int * | YesNo
 | ) |  |

#include <zwapi_config.h>

Outputs the value of a setting from the Configuration form/config file. The variable value must be one of the strings "Yes" or "No" (case is ignored). If the value is "Yes", 1 is output. If the value is "No", 0 is output.

Note
The input "Name" is defined in "zw3d installation dir\\supp\\config.xml. @param [in] Name name of config file variable @param [out] YesNo 1 if value is "Yes", 0 if value is "No" @retval succeeds - ZW_API_NO_ERROR - variable exists and has a value that is either "Yes" or "No"
Return values
fail
  • ZW_API_GENERAL_ERROR - variable does not exist and sets the output to 0
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigPathGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigPathGet()

evxErrors cvxConfigPathGet | ( | char * | path,
 |  | int | sizepath
 | ) |  |

#include <zwapi_config.h>

Get config path for api developer. Api developers should save their config files here, if they have.

A path that is too long (longer than "sizepath") is truncated.

It is assumed that the input "path" is no longer than 512 bytes.

Parameters
[out] | path | config path
[in] | sizepath | max size of path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetColor()

evxErrors cvxConfigSetColor | ( | const char * | Name,
 |  | evxColor | Color
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file.

This function should not be used to set the color from a variable whose value is a 3-integer RGB color. Use the cvxConfigSetRgb() function for variables whose values are defined by their RGB components.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Color | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetInteger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetInteger()

evxErrors cvxConfigSetInteger | ( | const char * | Name,
 |  | int | Value
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file. The variable value is assumed to be an integer (0 is assigned to "Value" when the value is not a number).

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Value | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetNumber

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetNumber()

evxErrors cvxConfigSetNumber | ( | const char * | Name,
 |  | double | Value
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file. The variable value is assumed to be a number (0 is assigned to "Value" when the value is not a number).

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Value | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetOption()

evxErrors cvxConfigSetOption | ( | const char * | Name,
 |  | const char * | Option
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file.

The "Option" should not be longer than 31 bytes, and it should not contain blank spaces.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Option | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetRgb

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetRgb()

evxErrors cvxConfigSetRgb | ( | const char * | Name,
 |  | svxColor * | Rgb
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file. The variable value is assumed to be the RGB components of a color, i.e. a comma-separated list of 3 integers between 0 and 255.

This function should not be used to set the color from a variable whose value is one of the standard color names rather than a 3-integer RGB color. Use the cvxConfigSetColor() function for variables whose values are color names.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Rgb | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetString

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetString()

evxErrors cvxConfigSetString | ( | const char * | Name,
 |  | char * | Str
 | ) |  |

#include <zwapi_config.h>

Sets the string value of a setting from the Configuration form/config file.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | Str | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxConfigSetYesNo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Configuration
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ cvxConfigSetYesNo()

evxErrors cvxConfigSetYesNo | ( | const char * | Name,
 |  | int | YesNo
 | ) |  |

#include <zwapi_config.h>

Sets the value of a setting from the Configuration form/config file. The variable value must be one of the strings "Yes" or "No" (case is ignored). 1-Yes, 0-No.

Note
The input "Name" is defined in "zw3d installation dir\supp\config.xml.
Parameters
[in] | Name | name of config file variable
[in] | YesNo | value of the specified variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Dimension Common API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Dimension Common API
Common

Detailed Description

THE Module For The ZW3D Dimension API
Note – The common functions of dimension are defined in this header file.
The function declarations of the dimension in the part are defined in "ZwApiPart.h"
The function declarations of the dimension in the sketch are defined in "ZwApiSkDim.h"
The function declarations of the dimension in the drawing are defined in "zwapi_dwg_dim.h"

Dimension Query

evxErrors | cvxDimInqType (int idDim, evxDimType *type)
evxErrors | cvxDimInqTypeEx (int idDim, evxDimTypeEx *typeEx)
evxErrors | cvxDimIsRadius (int idDim, int *isRadius)
evxErrors | cvxDimInqState (int idDim, evxDimState *state)
evxErrors | cvxDimInqDimBundles (int idDim, int *Count, int **idBundles)
evxErrors | cvxDimFCSDataGet (int idFCS, int *numOfFcs, svxFCSData **FcsData, vxLongName Note1, vxLongName Note2)

Dimension value

evxErrors | cvxDimInqVar (int idDim, svxVariable *Var)
evxErrors | cvxDimValMod (int idDim, char *exp)
evxErrors | cvxDimValModNoUpdate (int idDim, char *exp)

Dimension text

evxErrors | cvxDimInqText (int idDim, int subDim, char **pStr)
evxErrors | cvxDimModTxt (int idDim, int subDim, char *pStr)
evxErrors | cvxDimInqTextType (int idDim, int *Type)
evxErrors | cvxDimModTextType (int idDim, int Type, char *text)
evxErrors | cvxDimInqTxtPnt (int idDim, svxPoint *TextPnt)
evxErrors | cvxDimModTxtPnt (int idDim, int center, svxPoint *TextPnt)

Dimension Point

evxErrors | cvxDimInqPos (int idDim, svxPoint *pPos)
evxErrors | cvxDimInqDimPnts (int idDim, int *count, svxPoint **DimPnts)

Dimension Line

evxErrors | cvxDimInqDimLines (int idDim, int *count, svxCurve **DimCrvs)
evxErrors | cvxDimInqExtLines (int idDim, int *count, svxCurve **DimCrvs)

Dimension Attribute

evxErrors cvxDimAtGetBySub (int idDim, int subDim, svxDimAttr *dmAttr)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimAtGetBySub

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimAtGetBySub()

evxErrors cvxDimAtGetBySub | ( | int | idDim,
 |  | int | subDim,
 |  | svxDimAttr * | dmAttr
 | ) |  |

#include <zwapi_dim.h>

Gets the attributes data of specified dimension. The different between this function and cvxDwgDimAtGet() is that this function get the element attribute of the input dimension.

Parameters
[in] | idDim | id of dimension
[in] | subDim | serial number of sub dimension(0,1,2...), refer to evxHoleDimDataItem for sub-data item of hole dimension
[out] | dmAttr | dimension attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimFCSDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimFCSDataGet()

evxErrors cvxDimFCSDataGet | ( | int | idFCS,
 |  | int * | numOfFcs,
 |  | svxFCSData ** | FcsData,
 |  | vxLongName | Note1,
 |  | vxLongName | Note2
 | ) |  |

#include <zwapi_dim.h>

Get data of specified FCS dimension object.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFCS | index of FCS dimension
[out] | numOfFcs | number of FCS data (NULL to ignore)
[out] | FcsData | list of FCS data (NULL to ignore)
[out] | Note1 | FCS annotation text1 (NULL to ignore)
[out] | Note2 | FCS annotation text2 (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqDimBundles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqDimBundles()

evxErrors cvxDimInqDimBundles | ( | int | idDim,
 |  | int * | Count,
 |  | int ** | idBundles
 | ) |  |

#include <zwapi_dim.h>

Outputs a list of indices of dimension bundles in specified dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDim | index of dimension
[out] | Count | number of dimension bundles in dimension
[out] | idBundles | list of index of dimension bundles
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqDimLines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqDimLines()

evxErrors cvxDimInqDimLines | ( | int | idDim,
 |  | int * | count,
 |  | svxCurve ** | DimCrvs
 | ) |  |

#include <zwapi_dim.h>

Outputs a list of dimension curves of specified dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Note
All points in svxCurve are the points in Frame that the local coordinate system of the curve, the function cvxPntTransform() can be used to convert points into points in the global coordinate system.
Parameters
[in] | idDim | index of dimension or PMI of dimension type
[out] | count | number of dimension curves
[out] | DimCrvs | list of dimension curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqDimPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqDimPnts()

evxErrors cvxDimInqDimPnts | ( | int | idDim,
 |  | int * | count,
 |  | svxPoint ** | DimPnts
 | ) |  |

#include <zwapi_dim.h>

Outputs a list of dimension point coordinates of specified dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDim | index of dimension or PMI of dimension type
[out] | count | number of dimension points
[out] | DimPnts | list of dimension point coordinates
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqExtLines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqExtLines()

evxErrors cvxDimInqExtLines | ( | int | idDim,
 |  | int * | count,
 |  | svxCurve ** | DimCrvs
 | ) |  |

#include <zwapi_dim.h>

Outputs a list of extension curves of specified dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Note
all points in svxCurve are the points in Frame that the local coordinate system of the curve, the function cvxPntTransform() can be used to convert points into points in the global coordinate system.
Parameters
[in] | idDim | index of dimension or PMI of dimension type
[out] | count | number of extension curves
[out] | DimCrvs | list of extension curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqPos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqPos()

evxErrors cvxDimInqPos | ( | int | idDim,
 |  | svxPoint * | pPos
 | ) |  |

#include <zwapi_dim.h>

This function is to inquire the point which this dimension points to, The parent of dimension should be PMI in part.

Parameters
[in] | idDim | id of dimension
[out] | pPos | stretchable point coordinate
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqState()

evxErrors cvxDimInqState | ( | int | idDim,
 |  | evxDimState * | state
 | ) |  |

#include <zwapi_dim.h>

Get the state(evxDimState) of specified dimension.

Parameters
[in] | idDim | the index of dimension
[out] | state | the state of specified dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqText()

evxErrors cvxDimInqText | ( | int | idDim,
 |  | int | subDim,
 |  | char ** | pStr
 | ) |  |

#include <zwapi_dim.h>

This function is to inquire dimension text content for the dimension with index idDim.

The calling procedure MUST deallocate the output string with cvxMemFree().

Parameters
[in] | idDim | id of dimension
[in] | subDim | serial number of sub dimension(0,1,2...), refer to evxHoleDimDataItem for sub-data item of hole dimension
[out] | pStr | output destination text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqTextType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqTextType()

evxErrors cvxDimInqTextType | ( | int | idDim,
 |  | int * | Type
 | ) |  |

#include <zwapi_dim.h>

Get current user text type of specified dimension.

Parameters
[in] | idDim | index of dimension or dimension bundle
[out] | Type | text type (0-value, 1-user text, 2-override value)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqTxtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqTxtPnt()

evxErrors cvxDimInqTxtPnt | ( | int | idDim,
 |  | svxPoint * | TextPnt
 | ) |  |

#include <zwapi_dim.h>

Get dimension text point location of specified dimension.

Parameters
[in] | idDim | index of dimension
[out] | TextPnt | dimension text origin
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqType()

evxErrors cvxDimInqType | ( | int | idDim,
 |  | evxDimType * | type
 | ) |  |

#include <zwapi_dim.h>

Get the type(evxDimType) of specified dimension. It can't get the corresponding type if "*type = VX_DIM_LAST".

Parameters
[in] | idDim | the index of dimension
[out] | type | the type of specified dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqTypeEx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqTypeEx()

evxErrors cvxDimInqTypeEx | ( | int | idDim,
 |  | evxDimTypeEx * | typeEx
 | ) |  |

#include <zwapi_dim.h>

Get the type(evxDimTypeEx) of specified dimension.

It can't get the corresponding type if "*type = VX_DIM_EX_LAST".

Parameters
[in] | idDim | the index of dimension
[out] | typeEx | the type of specified dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimInqVar

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimInqVar()

evxErrors cvxDimInqVar | ( | int | idDim,
 |  | svxVariable * | Var
 | ) |  |

#include <zwapi_dim.h>

Outputs the variable that belong to the specified id. The parent of dimension can be part,sketch or drawing.

Parameters
[in] | idDim | id of dimension or dimension bundle to inquire
[out] | Var | the variable of specified dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_aPI_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimIsRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimIsRadius()

evxErrors cvxDimIsRadius | ( | int | idDim,
 |  | int * | isRadius
 | ) |  |

#include <zwapi_dim.h>

Determine whether the label is diameter or radius.

Parameters
[in] | idDim | the index of dimension
[out] | isRadius | 1 is radius, 0 is diameter
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimModTextType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimModTextType()

evxErrors cvxDimModTextType | ( | int | idDim,
 |  | int | Type,
 |  | char * | text
 | ) |  |

#include <zwapi_dim.h>

Set user text type and text string or override expression of specified dimension.

Parameters
[in] | idDim | index of dimension or dimension bundle
[in] | Type | text type (0-value, 1-user text, 2-override value)
[in] | text | text string or override expression (NULL to ignore when Type=0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimModTxt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimModTxt()

evxErrors cvxDimModTxt | ( | int | idDim,
 |  | int | subDim,
 |  | char * | pStr
 | ) |  |

#include <zwapi_dim.h>

This function is to modify dimension text for the dimension with index idDim.

Parameters
[in] | idDim | id of dimension
[in] | subDim | number to indicate which sub-dimension to be modified. The first sub-dimension starts from 0
[in] | pStr | new destination text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimModTxtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimModTxtPnt()

evxErrors cvxDimModTxtPnt | ( | int | idDim,
 |  | int | center,
 |  | svxPoint * | TextPnt
 | ) |  |

#include <zwapi_dim.h>

This function is to modify dimension text point location of specified dimension.

Parameters
[in] | idDim | index of dimension or dimension bundle
[in] | center | center flag (1-center, 0-not center)
[in] | TextPnt | new dimension text origin
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimValMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimValMod()

evxErrors cvxDimValMod | ( | int | idDim,
 |  | char * | exp
 | ) |  |

#include <zwapi_dim.h>

Modify the value of the specified dimension.

The parent of dimension can be part or sketch.

If the dimension belongs to a block and the expression is referenced by another file or current part, you can not use the expression name as the second parameter directly, use the correct form of the expression reference(File Name:Root Name:Expression or Root Name:Expression).

Parameters
[in] | idDim | the index of the dimension object
[in] | exp | the expression of the dimension object
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDimValModNoUpdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Dimension Common API
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ cvxDimValModNoUpdate()

evxErrors cvxDimValModNoUpdate | ( | int | idDim,
 |  | char * | exp
 | ) |  |

#include <zwapi_dim.h>

Modify the value of the specified dimension. it is similar to cvxDimValMod(), the difference is no update/eval/redraw in this function so as to speed up. It needs to call cvxDimValMod() for the last dim for update all previous changes.

Parameters
[in] | idDim | the index of the dimension object
[in] | exp | the expression of the dimension object
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Display

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Display
Common

Detailed Description

THE MODULE FOR THE ZW3D Display API and Generic Data Types and Structures of these functions

Display Data

enum | evxDispAttrib { VX_DISP_POINT = 0 , VX_DISP_LINE = 1 , VX_DISP_FACE = 2 }
display attribute types More...
enum evxDispMode {
VX_DISP_WIRE = 1 , VX_DISP_SHADE = 2 , VX_DISP_HIDD_APPROX = 3 , VX_DISP_HIDD_EXACT = 4 ,
VX_DISP_EDGE = 5
}
display mode More...
enum | evxDispItem { VX_DISP_SCREEN = 0 , VX_DISP_PREVIEW = 1 , VX_DISP_FORMS = 2 , VX_DISP_ALL = 3 }
display (i.e. GUI) item More...
enum | evxVisualDispItem { VX_VISUAL_DISP_FRAME_TRIAD = 0 , VX_VISUAL_DISP_COMPASS_TRIAD = 1 , VX_VISUAL_DISP_TRIAD_TRANS = 2 }
visual display item More...
typedef int | vxDispState[10]
display state settings More...
typedef enum evxDispAttrib | evxDispAttrib
display attribute types
typedef enum evxDispMode | evxDispMode
display mode
typedef enum evxDispItem | evxDispItem
display (i.e. GUI) item
typedef enum evxVisualDispItem | evxVisualDispItem
visual display item

Lights Data

enum evxLightType {
V_LIGHT_NULL = 0 , V_LIGHT_AMB = 1 , V_LIGHT_DIR = 2 , V_LIGHT_POS = 3 ,
V_LIGHT_SPOT = 4 , V_LIGHT_EYE = 5
}
light source type More...
typedef enum evxLightType | evxLightType
light source type
typedef struct svxLight | svxLight
light source

Frame and Datum Data

enum evxDatumDispMode {
VX_DSP_PLN_XY = 0 , VX_DSP_PLN_RECT_XY = 1 , VX_DSP_PLN_RECT_XYZ = 2 , VX_DSP_PLN_RECT = 3 ,
VX_DSP_PLN_QURT = 4 , VX_DSP_PLN_RECT_XY_FIX = 5 , VX_DSP_PLN_RECT_XYZ_FIX = 6 , VX_DSP_PLN_RECT_FIX = 7 ,
VX_DSP_PLN_XYZ = 8
}
display mode of datum plane More...
enum | evxAxisDispMode { VX_DSP_AXIS_ARROW_LINE = 0 , VX_DSP_AXIS_DASH_LINE = 1 }
display mode of datum axis More...
typedef enum evxDatumDispMode | evxDatumDispMode
display mode of datum plane
typedef enum evxAxisDispMode | evxAxisDispMode
display mode of datum axis

Display

void | cvxDispRedraw (void)
void | cvxDispDataUpdate (void)
void | cvxDispModeGet (evxDispMode *Mode)
void | cvxDispModeSet (evxDispMode Mode)
void | cvxDispRgbGet (evxDispAttrib Type, svxColor *Rgb)
void | cvxDispRgbSet (evxDispAttrib Type, const svxColor *Rgb)
void | cvxDispColorGet (evxDispAttrib Type, evxColor *Color)
void | cvxDispColorSet (evxDispAttrib Type, evxColor Color)
void | cvxDispSwitch (evxDispItem Item, int isOn)
void | cvxDispSwitchGet (evxDispItem Item, int *isOn)
void | cvxDispState (int Option, vxDispState State)
void | cvxVisDispStatusGet (evxVisualDispItem Item, int *isOn)
evxErrors cvxDispSceneUpdate ()
evxErrors | cvxDispWindowRectGet (const int includeFrame, const int isGlobal, int *x, int *y, int *w, int *h)

Lights

evxErrors | cvxDispGetLights (int *Count, svxLight **Lights)
evxErrors | cvxDispSetLightsInit (svxLight *data)
evxErrors | cvxDispSetLights (int Count, svxLight *Lights)

Show-n_Tell

void | cvxShowOpen (const vxLongPath File)
void | cvxShowDisp (int SlideNumber)

Zoom

void | cvxDispZoomAll (int Redraw)
void | cvxDispZoomAllIncludeDim (int Redraw)
void | cvxDispZoomAt (const svxPoint point, const float factor)
evxErrors | cvxDispZoomLimits (void)
evxErrors | cvxDispZoomIn (int ZoomIn, const svxPoint2f StartPoint, const svxPoint2f EndPoint)

Frame and Datum

void | cvxDatumLocalVis (int iVisible)
void | cvxDatumDispModeSet (int idDatum, evxDatumDispMode DispMode)
evxErrors | cvxDatumDispModeGet (int idDatum, evxDatumDispMode *DispMode)
evxErrors | cvxDatumDispAttrGet (int idDatum, svxWireAt *DispAt)
evxErrors | cvxDatumDispAttrSet (int idDatum, const svxWireAt *DispAt)
evxErrors | cvxAxisDispModeGet (int idAxis, evxAxisDispMode *DspMode)
evxErrors | cvxAxisDispModeSet (int idAxis, evxAxisDispMode DspMode)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: vxDispState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ vxDispState

typedef int vxDispState[10]

#include <zwapi_display.h>

display state settings

Definition at line 32 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisDispModeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxAxisDispModeGet()

evxErrors cvxAxisDispModeGet | ( | int | idAxis,
 |  | evxAxisDispMode * | DspMode
 | ) |  |

#include <zwapi_display.h>

Get display mode of the specified datum axis.

Parameters
[in] | idAxis | id of datum axis
[out] | DspMode | display mode of datum axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisDispModeSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxAxisDispModeSet()

evxErrors cvxAxisDispModeSet | ( | int | idAxis,
 |  | evxAxisDispMode | DspMode
 | ) |  |

#include <zwapi_display.h>

Set display mode of the specified datum axis.

Parameters
[in] | idAxis | id of datum axis
[in] | DspMode | display mode of datum axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDatumDispAttrGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDatumDispAttrGet()

evxErrors cvxDatumDispAttrGet | ( | int | idDatum,
 |  | svxWireAt * | DispAt
 | ) |  |

#include <zwapi_display.h>

Get display attribute of the specified datum entity, including datum plane, datum axis and datum CSYS.

Parameters
[in] | idDatum | id of datum entity
[out] | DispAt | display attribute of datum entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDatumDispAttrSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDatumDispAttrSet()

evxErrors cvxDatumDispAttrSet | ( | int | idDatum,
 |  | const svxWireAt * | DispAt
 | ) |  |

#include <zwapi_display.h>

Set display attribute of the specified datum entity, including datum plane, datum axis and datum CSYS.

Parameters
[in] | idDatum | id of datum entity
[in] | DispAt | display attribute of datum entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDatumDispModeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDatumDispModeGet()

evxErrors cvxDatumDispModeGet | ( | int | idDatum,
 |  | evxDatumDispMode * | DispMode
 | ) |  |

#include <zwapi_display.h>

Get display mode of the specified datum plane.

Parameters
[in] | idDatum | id of datum plane
[out] | DispMode | display mode of datum plane
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDatumDispModeSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDatumDispModeSet()

void cvxDatumDispModeSet | ( | int | idDatum,
 |  | evxDatumDispMode | DispMode
 | ) |  |

#include <zwapi_display.h>

Set display mode of the specified datum plane.

Parameters
[in] | idDatum | id of datum plane
[in] | DispMode | display mode of datum plane
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOR_ENV
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDatumLocalVis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDatumLocalVis()

void cvxDatumLocalVis ( int iVisible )

#include <zwapi_display.h>

Set visible of the local datum.

Parameters
[in] iVisible visible flag of local datum
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispColorGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispColorGet()

void cvxDispColorGet | ( | evxDispAttrib | Type,
 |  | evxColor * | Color
 | ) |  |

#include <zwapi_display.h>

Gets the default point/wireframe/face color.

Face colors may be defined over a broader range of RGB components than can be represented by the evxColor type. If the default face color is not one of the standard colors, this function outputs the nearest evxColor value that approximates it.

See also
cvxDispRgbGet().
Parameters
[in] | Type | display attribute type
[out] | Color | color id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispColorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispColorSet()

void cvxDispColorSet | ( | evxDispAttrib | Type,
 |  | evxColor | Color
 | ) |  |

#include <zwapi_display.h>

Sets the default point/wireframe/face color.

See also
cvxDispRgbSet().
Parameters
[in] | Type | display attribute type
[in] | Color | color id to use as default
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispDataUpdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispDataUpdate()

void cvxDispDataUpdate ( void )

#include <zwapi_display.h>

Calling this function during a command will cause the data used to display part faces and edges to update/regenerate at the end of the command.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispGetLights

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispGetLights()

evxErrors cvxDispGetLights | ( | int * | Count,
 |  | svxLight ** | Lights
 | ) |  |

#include <zwapi_display.h>

Gets a list of light sources associated with the active part or assembly.

This function allocates memory for the list of light sources. This memory MUST be deallocated by the calling procedure.

//Example
int Count=0;
svxLight *Lights=NULL;
cvxLightGetAll(&Count, &Lights);
for (int i=0; i < Count; i++) {Light[i]...}
cvxMemFree((void**)&Lights);
cvxMemFree
void cvxMemFree(void **MemPointer)
svxLight
light source
Definition: zwapi_display.h:105
Parameters
[out] | Count | number of light sources
[out] | Lights | list of light sources
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispModeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispModeGet()

void cvxDispModeGet ( evxDispMode * Mode )

#include <zwapi_display.h>

Outputs the active display mode.

Parameters
[out] Mode active display mode
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispModeSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispModeSet()

void cvxDispModeSet ( evxDispMode Mode )

#include <zwapi_display.h>

Sets the active display mode.

Parameters
[in] Mode display mode
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispRedraw

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispRedraw()

void cvxDispRedraw ( void )

#include <zwapi_display.h>

Initiates a screen redraw if display update is not disabled and if a redraw is not going to be forced at the end of the current operation.

Active inputs (i.e. picks and previews) are not redrawn. If you desire a redraw that includes redisplay of active inputs, use cvxCmdSend("$CdRedrawAll").

Note
This function must be called on the main thread.
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispRgbGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispRgbGet()

void cvxDispRgbGet | ( | evxDispAttrib | Type,
 |  | svxColor * | Rgb
 | ) |  |

#include <zwapi_display.h>

Gets the RGB components of the specified default point/wireframe/face color.

See also
cvxDispColorGet().
Parameters
[in] | Type | display attribute type
[out] | Rgb | default color RGB components
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispRgbSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispRgbSet()

void cvxDispRgbSet | ( | evxDispAttrib | Type,
 |  | const svxColor * | Rgb
 | ) |  |

#include <zwapi_display.h>

Sets the default point/wireframe/face color from RGB components.

Note
Only faces support the full range of possible RGB colors. Points and wireframe entities can have only the colors corresponding to those predefined by the evxColor type.
If "Type" is VX_DISP_POINT or VX_DISP_LINE, this function finds the evxColor that is closest to the given RGB components and uses that standard color for the specified default.
See also
cvxDispColorSet().
Parameters
[in] | Type | display attribute type
[in] | Rgb | color RGB components to use as default
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispSceneUpdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispSceneUpdate()

evxErrors cvxDispSceneUpdate ( )

#include <zwapi_display.h>

After using the cvxCmdMacro() command and entering the new environment, user can use this interface to update various UI controls of the environment.

void example()
{
// create new part file.
char* partName = (char*)"Demo";
cvxFileNew(partName);
cvxRootAdd(VX_ROOT_PART, partName, NULL);
// After this code is executed, it is in the environment of the part.
// create new drawing file.
char cmd[1024] = "\0";
sprintf_s(cmd, sizeof(cmd), "%s\n%s\n%s\n%s\n%s\n%s", cmd,
"[vxSend,\"$CdPartSheet\"]", "BUFFER", "[vxSendEvt, \"UiTplList\", 1, 2, 2]",
"[vxSendEvt, \"UiTplList\", -1, 0, 0]", "ENDBUFFER");
if (cvxCmdMacro(cmd, NULL)) {
cvxMsgDisp((char*)"Failed to create drawing sheet!");
return;
}
// After this code is executed,a drawing file will be created in the form of a macro,
// and the environment will be switched to the drawing environment.
// Because the previous code switched the environment through cvxCmdMacro(),
// user need to call this interface to update.
cvxDispSceneUpdate();
cvxMsgDisp((char*)"Create drawing sheet successfully.");
return;
}
cvxCmdMacro
evxErrors cvxCmdMacro(char *Input, char **Output)
cvxDispSceneUpdate
evxErrors cvxDispSceneUpdate()
cvxFileNew
evxErrors cvxFileNew(const vxLongPath Name)
cvxMsgDisp
void cvxMsgDisp(char *Text)
cvxRootAdd
evxErrors cvxRootAdd(evxRootType Type, vxRootName Name, const char *Template)
VX_ROOT_PART
@ VX_ROOT_PART
part
Definition: zwapi_root.h:33
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispSetLights

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispSetLights()

evxErrors cvxDispSetLights | ( | int | Count,
 |  | svxLight * | Lights
 | ) |  |

#include <zwapi_display.h>

Set light sources associated with the active part or assembly. New light sources will replace the existing ones.

Note
Interface cvxDispSetLightsInit() can initialize variables of this function.
Parameters
[in] | Count | number of light sources
[in] | Lights | list of light sources
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispSetLightsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispSetLightsInit()

evxErrors cvxDispSetLightsInit ( svxLight * data )

#include <zwapi_display.h>

Initialize the parameters of the cvxDispSetLights().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data light source data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispState()

void cvxDispState | ( | int | Option,
 |  | vxDispState | State
 | ) |  |

#include <zwapi_display.h>

This function should ALWAYS be called in pairs to disable display/UI update (Option=0) and then to re-enable it (Option=1).
The first call to disable display/UI update records current display settings in "State", then disables them.
The second call uses the settings previously recorded in "State" to re-enable display/UI update.

Note
If this function is being used to re-enable display/UI update after an error occurred in application code, always use "Option = 1". In this case "Option = 2" could cause further errors by attempting to refresh the display from an erroneous database.
Parameters
[in] Option 0 to disable display/UI update;
1 to re-enable display/UI update;
2 to re-enable AND refresh the display/UI
[in,out] State storage for display states
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispSwitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispSwitch()

void cvxDispSwitch | ( | evxDispItem | Item,
 |  | int | isOn
 | ) |  |

#include <zwapi_display.h>

Switches OFF automatic display update of the specified GUI item when "isOn=0". Switches it back ON when "isOn=1".

Each call to this function with "isOn=0" MUST be paired with a subsequent call to this same function with the same "Item" setting and "isOn=1" in order to restore the setting to its original state. This is CRITICAL for the ZW3D display to function properly after your application is done.

By default, display update is ON, so this function should ALWAYS be called first with "isOn=0" followed by a call with "isOn=1".

Parameters
[in] | Item | display/gui item
[in] | isOn | 0=OFF, 1=ON
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispSwitchGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispSwitchGet()

void cvxDispSwitchGet | ( | evxDispItem | Item,
 |  | int * | isOn
 | ) |  |

#include <zwapi_display.h>

Outputs the state of a switch set using cvxDispSwitch(). If "Item = VX_DISP_ALL", "isOn" is output as zero unless VX_DISP_SCREEN, VX_DISP_PREVIEW and VX_DISP_FORMS are all ON.

Parameters
[in] | Item | display/gui item
[out] | isOn | 0=OFF, 1=ON
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispWindowRectGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispWindowRectGet()

evxErrors cvxDispWindowRectGet | ( | const int | includeFrame,
 |  | const int | isGlobal,
 |  | int * | x,
 |  | int * | y,
 |  | int * | w,
 |  | int * | h
 | ) |  |

#include <zwapi_display.h>

Get the global or client coordinates of the active display window.

Parameters
[in] | includeFrame | Include window frame; 0, Exclude window frame
[in] | isGlobal | Get the global coordinates; 0, Get the client coordinates
[out] | x | top left X. If don't get this value, set it nullptr.
[out] | y | top left Y. If don't get this value, set it nullptr.
[out] | w | active display window's width. If don't get this value, set it nullptr.
[out] | h | active display window's height. If don't get this value, set it nullptr.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispZoomAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispZoomAll()

void cvxDispZoomAll ( int Redraw )

#include <zwapi_display.h>

Sets active view to encompass all visible geometry.

Parameters
[in] Redraw 1 to redraw after zoom all; else 0
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispZoomAllIncludeDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispZoomAllIncludeDim()

void cvxDispZoomAllIncludeDim ( int Redraw )

#include <zwapi_display.h>

Sets active view to encompass all visible geometry including dimensions.

Parameters
[in] Redraw 1 to redraw after zoom all; else 0
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispZoomAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispZoomAt()

void cvxDispZoomAt | ( | const svxPoint | point,
 |  | const float | factor
 | ) |  |

#include <zwapi_display.h>

Zoom at a specific location on the active view using the zoom factor.

Parameters
[in] | point | point to zoom at
[in] | factor | the factor to zoom at, mostly to be 0.8
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispZoomIn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispZoomIn()

evxErrors cvxDispZoomIn | ( | int | ZoomIn,
 |  | const svxPoint2f | StartPoint,
 |  | const svxPoint2f | EndPoint
 | ) |  |

#include <zwapi_display.h>

Window zoom in or out. StartPoint and endpoint are on the diagonal of the rectangle.

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | ZoomIn | 1 to zoom-in, 0 to zoom-out
[in] | StartPoint | start point
[in] | EndPoint | end point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDispZoomLimits

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxDispZoomLimits()

evxErrors cvxDispZoomLimits ( void )

#include <zwapi_display.h>

Set active view to construction limits of target object.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxShowDisp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxShowDisp()

void cvxShowDisp ( int SlideNumber )

#include <zwapi_display.h>

Displays the specified "Show-n-Tell" slide, numbered from 1.

Parameters
[in] SlideNumber Show-n-Tell slide number ( >= 1)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxShowOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxShowOpen()

void cvxShowOpen ( const vxLongPath File )

#include <zwapi_display.h>

Loads the specified "Show-n-Tell" file. Use cvxShowDisplay() to activate a specific "Show-n-Tell" slide.

Parameters
[in] File path to Show-n-Tell file
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxVisDispStatusGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ cvxVisDispStatusGet()

void cvxVisDispStatusGet | ( | evxVisualDispItem | Item,
 |  | int * | isOn
 | ) |  |

#include <zwapi_display.h>

Get the current display status of specified visual display item .

Parameters
[in] | Item | visual display Item
[in] | isOn | on = 1, off = 0
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: General Entity API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
General Entity API
Common

Detailed Description

THE MODULE FOR THE ZW3D Object's(Entity) Common API

Entity Calculate Data

typedef struct svxAreaProp svxAreaProp
area properties

Entity New

int | cvxEntNew (int StartOp, evxEntType Type)
void | cvxEntNewList (int StartOp, evxEntType Type, int *Count, int **idEnts)
evxErrors | cvxEntNewAll (int startOp, evxEntType type, int *count, int **idEnts)

Name Tag Query

evxErrors cvxPartInqTagNames (int *Count, vxLongName **Names)

Entity State

evxErrors | cvxEntBlank (int Show, int Count, int *idEnts)
int | cvxEntIsBlanked (int idEntity)
void | cvxEntHighlight (int idEntity)
void | cvxEntUnHighlight (int idEntity)
void | cvxEntUnhighlightAll (void)
int | cvxEntExists (int idEntity, evxEntType EntType)
evxErrors | cvxEntInqSelected (int *Count, int **Ents)
evxErrors | cvxEntInqPicked (int *Count, int **Ents)
evxErrors | cvxEntInqPathSelected (int *Count, svxEntPath **Paths)
evxErrors | cvxEntInqPathPicked (int *Count, svxEntPath **Paths)
void | cvxEntUnPickAll ()
void | cvxEntUnPickLast ()
evxErrors | cvxEntUnPickByPath (const svxEntPath *path)
evxErrors | cvxEntAddPick (int idx_ent)
evxErrors | cvxEntPathAddPick (svxEntPath *entPath)
void | cvxPickDataClear ()

Entity Attribute

evxErrors | cvxEntUserAtGet (int idEnt, int *count, svxAttribute **At)
evxErrors | cvxEntUserAtSet (int idEnt, int count, svxAttribute *At)
evxErrors | cvxEntUserAtDel (int idEnt, int count, svxAttribute *At)
evxErrors | cvxEntColorGet (int idEntity, evxColor *Color)
evxErrors | cvxEntColorSet (evxColor Color, int Count, int *idEnts)
evxErrors | cvxEntRgbGet (int idEntity, svxColor *Color)
evxErrors | cvxEntRgbSet (svxColor Color, int Count, int *idEnts)
evxErrors | cvxEntRgbSetNoAt (svxColor Color, int Count, int *idEnts)
evxErrors | cvxEntTransSet (int iTrans, int Count, int *idEnts)
evxErrors | cvxEntLineAtGet (int idLine, svxLineAt *At)
evxErrors | cvxEntLineAtSet (svxLineAt *At, int Count, int *idEnts)

Entity Info Get/Set

evxErrors | cvxEntUidGet (int idEntity, svxUid *Uid)
evxErrors | cvxEntUidSet (int idEntity, const svxUid *Uid)
evxErrors | cvxPartInqEntLabel (int idEntity, int **Label)
evxErrors | cvxEntLabelGet (int idEntity, int **Label)
evxErrors | cvxEntLabelSet (int idEntity, int *Label)
evxErrors | cvxEntName (int idEntity, char *Name, int nBytes)
evxErrors | cvxEntNameSet (int idEntity, const char *Name)
evxErrors | cvxEntSetNameTag (int idx_ent, char *name)
evxErrors | cvxEntLayer (int idEntity, vxName Layer)
evxErrors | cvxEntLayerId (int idEntity, int *LayerId)
evxErrors | cvxEntMatrix (int idEntity, svxMatrix *Matrix)
evxErrors | cvxEntMatrix2 (svxEntPath Entity, svxMatrix *Matrix)
evxErrors | cvxEntMatrixSet (int idEntity, svxMatrix *Matrix)
evxErrors | cvxPartInqEntFtr (int idEntity, int *idFeature)
evxErrors | cvxEntBndBox (int idEntity, svxBndBox *Box)
evxErrors | cvxEntBndBoxByPath (svxEntPath *path, int fTartCord, svxBndBox *bndBox)
evxErrors | cvxPartInqEntBox (int idEnt, const svxMatrix *Mat, svxBndBox *Box)

Entity Find

evxErrors | cvxEntByLabel (int *Label, int Exact, int *idEntity)
evxErrors | cvxPartInqEntByLabel (int *Label, int flag, int *idEntity)
evxErrors | cvxEntByName (const char *Name, int *idEntity)
evxErrors | cvxEntByName2 (const vxLongPath File, const vxRootName Root, const vxName Name, int *idEntity)
evxErrors | cvxEntNameByPath (const svxEntPath *Path, vxLongName Name)
evxErrors | cvxEntByUid (const svxUid *Uid, int *idEntity)
evxErrors | cvxEntFind (evxEntFind EntType, svxPoint *RefPnt, int *idEntity, svxPoint *Pnt, double *Dist)
evxErrors | cvxEntFind2 (svxEntFind *Data)

Entity Type

void | cvxEntClassName (int ClassNumber, char *ClassName)
int | cvxEntClassNum (int idEntity)
int | cvxEntClassNumByPath (svxEntPath *entPath)
int | cvxEntIsCurve (int idEntity)
int | cvxEntIsElectrode (int idEntity)

Entity Query

evxErrors | cvxEntPnt (int idEntity, svxPoint *Pnt)
evxErrors | cvxEntEndPnt (int idEntity, svxPoint *Start, svxPoint *End)
void | cvxEntSketch (int idEntity, int *idSketch)
evxErrors | cvxEntParent (int idEntity, int *idParent)
evxErrors | cvxEntRefEnt (int idRefEnt, int *idEnt)
evxErrors | cvxEntGetInhSubIdx (int idx_ent, int klass, int sub_class, int *subIdx)
evxErrors | cvxEntComp (int idEntity, int *idComp, char *File, int nFileBytes, char *Parent, int nParentBytes)

Entity Edit

evxErrors cvxEntErase (svxEntPath *Ent)

Entity Pick Path Operation

int cvxEntActivate (svxEntPath *NewPath, int UpdateGUI, int *idEntity, svxEntPath *OldPath)

Entity Calculate

evxErrors cvxPartInqEntsArea (int cnt, int *crvList, svxAreaProp *areaProp)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntActivate()

int cvxEntActivate | ( | svxEntPath * | NewPath,
 |  | int | UpdateGUI,
 |  | int * | idEntity,
 |  | svxEntPath * | OldPath
 | ) |  |

#include <zwapi_general_ent.h>

Activates the last target object in the specified path (NewPath) and outputs the path of the active target object (OldPath).
If "OldPath" is input as a NULL point, the active target path is not output.
After activating a new target object with this function, you can pass "OldPath" back into this function as "NewPath" in order to re-activate the original target object.

If "UpdateGUI" is non-zero, this function updates the GUI menus to reflect a change in the target object.
Otherwise, the menus of the original target object remain active.

The id of the entity referenced by "NewPath" is output via "idEntity".
This id can be used to query the entity once its parent object is activated by this function.

Parameters
[in] | NewPath | path into new target object
[in] | UpdateGUI | 1 to update GUI, else 0
[out] | idEntity | entity id(input NULL to ignore)
[out] | OldPath | path of original target(input NULL to ignore)
Return values
return
  • 1 - target object was modified
  • 0 - target object was not modified or error occurs
Warning
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntAddPick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntAddPick()

evxErrors cvxEntAddPick ( int idx_ent )

#include <zwapi_general_ent.h>

Add the specified entity to the pick list.

Parameters
[in] idx_ent index of entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OBJ
Examples
drawing\dwgDimTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntBlank

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntBlank()

evxErrors cvxEntBlank | ( | int | Show,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Blanks or unblanks the specified entities.

Call this function during echoing will not log any blank/unblank operation to the history, for example:

cvxEchoStart();
cvxEntBlank(1, nEntity, &idEntity);
cvxEchoEnd();
cvxEchoEnd
void cvxEchoEnd()
cvxEchoStart
void cvxEchoStart()
cvxEntBlank
evxErrors cvxEntBlank(int Show, int Count, int *idEnts)

Besides, input "Count" as a negative number can prevent a blank/unblank operation from being logged to the history in the case that this function is being applied to a part entity.

Parameters
[in] | Show | 1 to unblank entities; 0 to blank
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntBndBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntBndBox()

evxErrors cvxEntBndBox | ( | int | idEntity,
 |  | svxBndBox * | Box
 | ) |  |

#include <zwapi_general_ent.h>

This function gets the bounding box of the specified entity in the target file.

Parameters
[in] | idEntity | entity id
[out] | Box | bounding box of specified entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntBndBoxByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntBndBoxByPath()

evxErrors cvxEntBndBoxByPath | ( | svxEntPath * | path,
 |  | int | fTartCord,
 |  | svxBndBox * | bndBox
 | ) |  |

#include <zwapi_general_ent.h>

This function gets the bounding box of the specified entity in the pick path.

Interface cvxBndBoxTransform can convert envelope boxes to different matrices.
Interface cvxBndBoxPnts can convert the envelope box to the coordinate value under the current world coordinate system.
Interface cvxPntTransform can convert points under different coordinate systems.

Note
When the matrix of the specified entity is not orthogonal to the matrix of the current world coordinate system, it is recommended that fTartCord=0, otherwise fTartCord=1.
When fTartCord=1, the envelope box output from the interface can be directly converted to points. The envelope box drawn according to the coordinates of these points is correct.
When fTartCord=0, you need to convert the envelope box to the point coordinates first, and then convert the point to the point coordinates under the current coordinate system. At this time, the envelope box drawn according to the point coordinates is correct.
Parameters
[in] | path | entity pick path
[in] | fTartCord | the boundary box in target coordinate(1 or 0)
[out] | bndBox | bounding box of specified entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntByLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntByLabel()

evxErrors cvxEntByLabel | ( | int * | Label,
 |  | int | Exact,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_general_ent.h>

Searches the active part for an entity with the specified label.

Parameters
[in] | Label | persistent label as null-terminated array of integers
[in] | Exact | 1 for exact match; 0 if partial match is okay
[out] | idEntity | entity id (0 is output if no entity is found)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntByName()

evxErrors cvxEntByName | ( | const char * | Name,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_general_ent.h>

Searches the active object for the entity with the specified name.
If it is found, its id is output via "idEntity". If it is not found, "idEntity = 0" is output.

Parameters
[in] | Name | entity name
[out] | idEntity | entity id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntByName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntByName2()

evxErrors cvxEntByName2 | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | const vxName | Name,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_general_ent.h>

Searches the specified root object in the specified file for the entity with the specified name.
If it is found, its id is output via "idEntity".
If it is not found, "idEntity = 0" is output.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | Name | entity name
[out] | idEntity | entity id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntByUid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntByUid()

evxErrors cvxEntByUid | ( | const svxUid * | Uid,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_general_ent.h>

Searches the active target for an entity with the specified unique identifier.

Parameters
[in] | Uid | unique id of entity to find
[out] | idEntity | entity id (0 is output if no entity is found)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntClassName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntClassName()

void cvxEntClassName | ( | int | ClassNumber,
 |  | char * | ClassName
 | ) |  |

#include <zwapi_general_ent.h>

Outputs an ascii text string describing the entity class identified by "ClassNumber".
The string is stored in the memory referenced by "ClassName", which is assumed to be sufficient (min = 64 bytes).

Parameters
[in] | ClassNumber | entity class number
[out] | ClassName | class name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntClassNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntClassNum()

int cvxEntClassNum ( int idEntity )

#include <zwapi_general_ent.h>

Returns the class number of the specified entity in the active object.

Parameters
[in] idEntity entity id
Return values
return
  • "evxEntType" defines a subset of the possible entity class numbers returned by this function
  • -1 if the entity cannot be located or error occurs
Warning
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_INPUT
Examples
drawing\dwgDimTest.cpp, part\baseFtrCrtTest.cpp, part\partUtils.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntClassNumByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntClassNumByPath()

int cvxEntClassNumByPath ( svxEntPath * entPath )

#include <zwapi_general_ent.h>

Returns the class number of the specified entity in the active object.

Parameters
[in] entPath entity path
Return values
return
  • "evxEntType" defines a subset of the possible entity class numbers returned by this function
  • -1 if the entity cannot be located or error occurs
Warning
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_INPUT
Examples
part\partUtils.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntColorGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntColorGet()

evxErrors cvxEntColorGet | ( | int | idEntity,
 |  | evxColor * | Color
 | ) |  |

#include <zwapi_general_ent.h>

Gets the standard color number assigned to "idEntity".

See also
cvxEntRgbGet().
Parameters
[in] | idEntity | entity id (in active file)
[out] | Color | entity color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntColorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntColorSet()

evxErrors cvxEntColorSet | ( | evxColor | Color,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Assigns the specified color to the specified entities in the active object.

See also
cvxEntRgbSet().
Parameters
[in] | Color | entity color
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntComp()

evxErrors cvxEntComp | ( | int | idEntity,
 |  | int * | idComp,
 |  | char * | File,
 |  | int | nFileBytes,
 |  | char * | Parent,
 |  | int | nParentBytes
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the id of the assembly component associated with the specified entity in a 2D drawing view layout from a 3D assembly.

Assumes that "idEntity" resides in the active target file.

Outputs "idComp = 0" if no assembly component is found.

Outputs the names of the component's parent file and object (i.e. part) if non-NULL pointers are input to the "char *" variables for "File" and "Parent".

Parameters
[in] | idEntity | entity id
[out] | idComp | component id
[out] | File | if not NULL, output name of component's parent file
[in] | nFileBytes | string size of file name
[out] | Parent | if not NULL, output name of component's parent object
[in] | nParentBytes | string size of parent object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOR_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntEndPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntEndPnt()

evxErrors cvxEntEndPnt | ( | int | idEntity,
 |  | svxPoint * | Start,
 |  | svxPoint * | End
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the end points of the specified curve entity.

Parameters
[in] | idEntity | entity id (in active file)
[out] | Start | start point
[out] | End | end point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, and part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntErase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntErase()

evxErrors cvxEntErase ( svxEntPath * Ent )

#include <zwapi_general_ent.h>

Erase the specified entity in the active root object (part, sketch or drawing sheet).

Parameters
[in] Ent path to entity to erase
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMM_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntExists

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntExists()

int cvxEntExists | ( | int | idEntity,
 |  | evxEntType | EntType
 | ) |  |

#include <zwapi_general_ent.h>

Determine whether a valid entity with the specified type exists in the active root.

Parameters
[in] | idEntity | entity id
[in] | EntType | entity type
Note
Some of evxEntType(VX_ENT_BREP, VX_ENT_OP, VX_ENT_POINT, VX_ENT_WIRE) are banned in this function.
Return values
succeeds
  • 1 - if a valid entity with the specified type and id exists in the active file
  • 0 - the entity is not found/invalid input/current root is wrong
Warning
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntFind()

evxErrors cvxEntFind | ( | evxEntFind | EntType,
 |  | svxPoint * | RefPnt,
 |  | int * | idEntity,
 |  | svxPoint * | Pnt,
 |  | double * | Dist
 | ) |  |

#include <zwapi_general_ent.h>

Finds the closest entity of the specified type to "RefPnt" and outputs its index via "idEntity" (0 is output if no entity is found).
If "Pnt" is not NULL, the coordinates of "RefPnt" projected onto the entity are output via "Pnt".
If "Dist" is not NULL, the shortest distance between the entity and "RefPnt" is output via "Dist".

Parameters
[in] | EntType | type of entity to search for
[in] | RefPnt | reference point
[out] | idEntity | entity id (0 if undefined)
[out] | Pnt | point on entity (or NULL to ignore)
[out] | Dist | distance (mm) from RefPnt (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntFind2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntFind2()

evxErrors cvxEntFind2 ( svxEntFind * Data )

#include <zwapi_general_ent.h>

Finds the closest entity of the type specified in "Data" to a reference point specified in "Data" using filtering parameters specified in "Data".

Parameters
[in,out] Data entity search data (input and output)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntGetInhSubIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntGetInhSubIdx()

evxErrors cvxEntGetInhSubIdx | ( | int | idx_ent,
 |  | int | klass,
 |  | int | sub_class,
 |  | int * | subIdx
 | ) |  |

#include <zwapi_general_ent.h>

This function get the index of the first object inherited by "idx_ent" with the specified class and sub-class.

Parameters
[in] | idx_ent | index of entity
[in] | klass | object class
[in] | sub_class | object sub-class
[out] | subIdx | index of inherited object
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntHighlight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntHighlight()

void cvxEntHighlight ( int idEntity )

#include <zwapi_general_ent.h>

Highlights the specified entity in the active root object.

Parameters
[in] idEntity entity id (in active file)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntInqPathPicked

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntInqPathPicked()

evxErrors cvxEntInqPathPicked | ( | int * | Count,
 |  | svxEntPath ** | Paths
 | ) |  |

#include <zwapi_general_ent.h>

Outputs a list of the picked entity path. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of entity path
[out] | Paths | list of the entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR - function fails or no entity was picked
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INVALID_OBJ
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntInqPathSelected

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntInqPathSelected()

evxErrors cvxEntInqPathSelected | ( | int * | Count,
 |  | svxEntPath ** | Paths
 | ) |  |

#include <zwapi_general_ent.h>

Outputs a list of the selected entity path. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of entity path
[out] | Paths | list of the entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntInqPicked

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntInqPicked()

evxErrors cvxEntInqPicked | ( | int * | Count,
 |  | int ** | Ents
 | ) |  |

#include <zwapi_general_ent.h>

Outputs a list of the Picked entity IDs. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of entities
[out] | Ents | list of the entity IDs
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR - function fails or no entity was picked
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_OBJ
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntInqSelected

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntInqSelected()

evxErrors cvxEntInqSelected | ( | int * | Count,
 |  | int ** | Ents
 | ) |  |

#include <zwapi_general_ent.h>

Outputs a list of the selected entity IDs. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of entities
[out] | Ents | list of the entity IDs
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntIsBlanked

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntIsBlanked()

int cvxEntIsBlanked ( int idEntity )

#include <zwapi_general_ent.h>

Parameters
[in] idEntity entity id (in active file)

Determine whether the specific entity is blanked.

Return values
return
  • 1 - the specified entity is blanked
  • 0 - the specified entity is visible or error occurs
Warning
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntIsCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntIsCurve()

int cvxEntIsCurve ( int idEntity )

#include <zwapi_general_ent.h>

Determine whether an entity is curve(includes edges and parting lines).

Parameters
[in] idEntity entity id (in active file)
Return values
succeeds
  • 1 - the specified entity is curvilinear
  • 0 - the specified entity is not curvilinear or error occurs
Warning
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\partUtils.cpp, part\shapeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntIsElectrode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntIsElectrode()

int cvxEntIsElectrode ( int idEntity )

#include <zwapi_general_ent.h>

Determine whether an entity is electrode.

Parameters
[in] idEntity entity id (in active file)
Return values
return
  • 1 - if the specified entity is electrode
  • 0 - if the specified entity is not electrode or error occurs
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLabelGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLabelGet()

evxErrors cvxEntLabelGet | ( | int | idEntity,
 |  | int ** | Label
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the persistent label of the specified entity in the active file, or a NULL pointer if the entity does not have a label.
Currently, only entities generated by a part history have persistent labels.

The label is a null-terminated list of integers.

The calling procedure is responsible for deallocating the memory out via "Label" as shown below:

int *Label=NULL;
cvxEntLabelGet(idEntity,&Label);
cvxMemFree((void**)&Label);
cvxEntLabelGet
evxErrors cvxEntLabelGet(int idEntity, int **Label)
cvxMemFree
void cvxMemFree(void **MemPointer)
See also
cvxLabelMatch() and cvxEntByLabel().
Parameters
[in] | idEntity | entity id
[out] | Label | persistent label as null-terminated array of integers
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLabelSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLabelSet()

evxErrors cvxEntLabelSet | ( | int | idEntity,
 |  | int * | Label
 | ) |  |

#include <zwapi_general_ent.h>

Assigns a copy of the input label (i.e. integer null-terminated list of integers) to the specified object. If the object already has a label, the existing label is overwritten. If "label=NULL", this function returns without doing anything (no error).

Parameters
[in] | idEntity | entity id
[in] | Label | persistent label as null-terminated array of integers
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLayer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLayer()

evxErrors cvxEntLayer | ( | int | idEntity,
 |  | vxName | Layer
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the name of the specified entity's layer.

Parameters
[in] | idEntity | entity id
[out] | Layer | layer name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLayerId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLayerId()

evxErrors cvxEntLayerId | ( | int | idEntity,
 |  | int * | LayerId
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the id of the specified entity's layer.

Parameters
[in] | idEntity | entity id
[out] | LayerId | layer id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLineAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLineAtGet()

evxErrors cvxEntLineAtGet | ( | int | idLine,
 |  | svxLineAt * | At
 | ) |  |

#include <zwapi_general_ent.h>

Get the attributes of specified line.

Parameters
[in] | idLine | index of entity
[out] | At | line attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntLineAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntLineAtSet()

evxErrors cvxEntLineAtSet | ( | svxLineAt * | At,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Sets the attributes of specified lines.if you only need to update some of the attributes,you can first get the original attributes through cvxEntLineAtGet().

Parameters
[in] | At | line attribute
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntMatrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntMatrix()

evxErrors cvxEntMatrix | ( | int | idEntity,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the transformation matrix associated with the specified entity.

Parameters
[in] | idEntity | entity id
[out] | Matrix | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\baseFtrCrtTest.cpp, part\shapeFtrCrtTest.cpp, and part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntMatrix2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntMatrix2()

evxErrors cvxEntMatrix2 | ( | svxEntPath | Entity,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the transformation matrix of the specified entity as defined by the input pick-path.
The transformation locates the entity relative to the path's root object.

Parameters
[in] | Entity | entity pick path
[out] | Matrix | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntMatrixSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntMatrixSet()

evxErrors cvxEntMatrixSet | ( | int | idEntity,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_general_ent.h>

Sets the transformation matrix associated with the specified entity in the active file.
If the entity does not support a transformation matrix, nothing is done.

Parameters
[in] | idEntity | entity id
[in] | Matrix | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntName()

evxErrors cvxEntName | ( | int | idEntity,
 |  | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the name of the specified entity.
It is assumed the entity resides in the active file.
A blank string is output if the entity doesn't have a name.

Parameters
[in] | idEntity | entity id
[out] | Name | entity name
[in] | nBytes | string max size of entity name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntNameByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntNameByPath()

evxErrors cvxEntNameByPath | ( | const svxEntPath * | Path,
 |  | vxLongName | Name
 | ) |  |

#include <zwapi_general_ent.h>

This function gets the name of the entity specified by a pick path.

Parameters
[in] | Path | entity pick path
[out] | Name | entity name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntNameSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntNameSet()

evxErrors cvxEntNameSet | ( | int | idEntity,
 |  | const char * | Name
 | ) |  |

#include <zwapi_general_ent.h>

Assigns the specified name to the specified entity.
It is assumed the entity resides in the active file.
It is assumed the entity has a "name" field.

This function is often used to set the name of dimension/datum/texture/block/config/sheet/equation...
You can use function "cvxEntSetNameTag()" to set the name tag of shell/face...

Parameters
[in] | idEntity | entity id
[in] | Name | entity name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntNew()

int cvxEntNew | ( | int | StartOp,
 |  | evxEntType | Type
 | ) |  |

#include <zwapi_general_ent.h>

Returns the id of the last entity of the specified type created since the specified operation (StartOp) of the current transaction.
Use cvxOpCount() to get the current number of operations in the current transaction.

Note
All values of evxEntType can be used in this function.
If "Type > 0", the specified entity is flagged.
If "Type = 0", to signal all entity are valid.
If "Type = -1", curve entity (e.g. line,circle, arc,curve) are flagged.
If "Type = -2", point entity are flagged.
If "Type = -3", history entity (e.g. feature, sketch, datum) are flagged.
If "Type = -4", b-rep entity are flagged.
Parameters
[in] | StartOp | starting operation number ( >= 0 )
[in] | Type | entity type
Return values
return
  • > 0 - index of new entity
  • 0 - no entity of the specified type is found or error occurs
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntNewAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntNewAll()

evxErrors cvxEntNewAll | ( | int | startOp,
 |  | evxEntType | type,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Return a list of the id's of the entities of the specified type created since the specified operation (StartOp) of the current transaction.

Use cvxOpCount() to get the current number of operations in the current transaction.

Note
This interface can get all newly generated IDs.
cvxEntNewList() can only get the new ID on the feature tree.
All values of evxEntType can be used in this function.
If "Type > 0", the specified entity is flagged.
If "Type = 0", to signal all entity are valid.
If "Type = -1", curve entity (e.g. line,circle, arc,curve) are flagged.
If "Type = -2", point entity are flagged.
If "Type = -3", history entity (e.g. feature, sketch, datum) are flagged.
If "Type = -4", b-rep entity are flagged.
Parameters
[in] | startOp | starting operation number ( >= 0)
[in] | type | entity type
[out] | count | number of new entities
[out] | idEnts | list of new entities (by id)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntNewList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntNewList()

void cvxEntNewList | ( | int | StartOp,
 |  | evxEntType | Type,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Returns a list of the id's of the entities of the specified type created since the specified operation (StartOp) of the current transaction.

Use cvxOpCount() to get the current number of operations in the current transaction.

Note
This interface can only get the new ID on the feature tree. cvxEntNewAll() can get all newly generated IDs.
All values of evxEntType can be used in this function.
If "Type > 0", the specified entity is flagged.
If "Type = 0", to signal all entity are valid.
If "Type = -1", curve entity (e.g. line,circle, arc,curve) are flagged.
If "Type = -2", point entity are flagged.
If "Type = -3", history entity (e.g. feature, sketch, datum) are flagged.
If "Type = -4", b-rep entity are flagged.
Parameters
[in] | StartOp | starting operation number ( >= 0)
[in] | Type | entity type
[out] | Count | number of new entities
[out] | idEnts | list of new entities (by id)
Warning
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntParent()

evxErrors cvxEntParent | ( | int | idEntity,
 |  | int * | idParent
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the id of the parent feature of the specified entity in the active part.

Parameters
[in] | idEntity | entity id
[out] | idParent | parent feature id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathAddPick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntPathAddPick()

evxErrors cvxEntPathAddPick ( svxEntPath * entPath )

#include <zwapi_general_ent.h>

Add the specified entity to the pick list.

Parameters
[in] entPath pick path of entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntPnt()

evxErrors cvxEntPnt | ( | int | idEntity,
 |  | svxPoint * | Pnt
 | ) |  |

#include <zwapi_general_ent.h>

Gets the coordinates of the first "critical" point for the specified entity.
For a point entity, it is the entity's coordinates.
For a line, edge or interpolated curve, it is the start point.
For a circle or arc, it is the center point.
For a control-point-defined curve, it is the first control point.
For a shape, it is the center of the shape's bounding box.
For a datum plane, it is the origin. For a dimension, it is the first point of display data.
For a symbol, it is the insertion point.

Parameters
[in] | idEntity | entity id (in active file)
[out] | Pnt | point coordinates
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\datumCrtTest.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntRefEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntRefEnt()

evxErrors cvxEntRefEnt | ( | int | idRefEnt,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_general_ent.h>

If "idRefEnt" is a valid parametric reference entity (i.e. reference geometry) in the active file, this function outputs the database id of the entity (i.e. geometry) that it defines.

"idEnt" is output as zero if it is undefined for "idRefEnt".

Parameters
[in] | idRefEnt | parametric reference entity id
[out] | idEnt | id of entity defined by reference entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntRgbGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntRgbGet()

evxErrors cvxEntRgbGet | ( | int | idEntity,
 |  | svxColor * | Color
 | ) |  |

#include <zwapi_general_ent.h>

Gets the color assigned to "idEntity" in RGB format.

See also
cvxEntColorGet().
Parameters
[in] | idEntity | entity id (in active file)
[out] | Color | entity RGB color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntRgbSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntRgbSet()

evxErrors cvxEntRgbSet | ( | svxColor | Color,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Assigns the specified RGB color to the specified entities in the active object.
Presently, only face entities support true RGB color.
For other entities, the specified RGB color is mapped to the closest standard color (evxColor).

See also
cvxEntColorSet().
Parameters
[in] | Color | entity RGB color
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntRgbSetNoAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntRgbSetNoAt()

evxErrors cvxEntRgbSetNoAt | ( | svxColor | Color,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Same as cvxEntRgbSet() except that no display attribute created.

Parameters
[in] | Color | entity RGB color
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntSetNameTag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntSetNameTag()

evxErrors cvxEntSetNameTag | ( | int | idx_ent,
 |  | char * | name
 | ) |  |

#include <zwapi_general_ent.h>

Assign the input name tag to the specified entity.
name:empty-delete the name tag, else add the name tag.

Parameters
[in] | idx_ent | index of entity
[in] | name | name tag
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntSketch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntSketch()

void cvxEntSketch | ( | int | idEntity,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_general_ent.h>

Searches sketches within the active part for the specified entity (idEntity).
If the entity is found within a sketch, the id of the sketch is output.
If the entity is not found inside a sketch, "idSketch" is output as zero.

Parameters
[in] | idEntity | entity id
[out] | idSketch | id of entity's parent sketch (0 if undefined)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\partUtils.cpp, part\shapeFtrCrtTest.cpp, and part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTransSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntTransSet()

evxErrors cvxEntTransSet | ( | int | iTrans,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_general_ent.h>

Assigns the specified transparency to the specified entities in the active object.

If the input transparency value exceeds 0-100, this function will fail.

Parameters
[in] | iTrans | Entity transparency value, from 0 to 100, both ends included
[in] | Count | number of entities
[in] | idEnts | entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUidGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUidGet()

evxErrors cvxEntUidGet | ( | int | idEntity,
 |  | svxUid * | Uid
 | ) |  |

#include <zwapi_general_ent.h>

Output the unique identifier of the specified entity.
The unique identifier is a tuple of three numbers that, taken together, identify the entity in a persistent way across sessions.
In contrast to "idEntity" (the entity ID), which usually changes from session to session, "Uid" (the unique ID) does not change between sessions and can be used to identify the entity in any session.

A unique ID is unique in the sense that no other entity in the same root object should have the same unique ID, but it is possible for two entities in different root objects to have the same unique ID.

See also
cvxRootCopy().
Parameters
[in] | idEntity | entity id
[out] | Uid | unique id for the specified entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUidSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUidSet()

evxErrors cvxEntUidSet | ( | int | idEntity,
 |  | const svxUid * | Uid
 | ) |  |

#include <zwapi_general_ent.h>

Assign a unique identifier to the specified entity.
Refer to cvxEntUidGet() for a description of unique identifiers and how the entity ID differs from the entity's unique ID.

A unique ID should be unique in the sense that no other entity in the same root object should have the same unique ID, although it is possible for two entities in different root objects to have the same unique ID.

See also
cvxRootCopy().
Parameters
[in] | idEntity | entity id
[in] | Uid | unique id to assign to the specified entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUnHighlight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUnHighlight()

void cvxEntUnHighlight ( int idEntity )

#include <zwapi_general_ent.h>

Un-Highlight the specified entity in the active root object.

Parameters
[in] idEntity entity id (in active file)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUnhighlightAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUnhighlightAll()

void cvxEntUnhighlightAll ( void )

#include <zwapi_general_ent.h>

Unhighlights all entities.

Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUnPickAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUnPickAll()

void cvxEntUnPickAll ( )

#include <zwapi_general_ent.h>

Unpick the entity list in active field.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUnPickByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUnPickByPath()

evxErrors cvxEntUnPickByPath ( const svxEntPath * path )

#include <zwapi_general_ent.h>

Unpick the entity list in active field.

Parameters
[in] path pick path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUnPickLast

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUnPickLast()

void cvxEntUnPickLast ( )

#include <zwapi_general_ent.h>

Unpick the last entity in active field.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUserAtDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUserAtDel()

evxErrors cvxEntUserAtDel | ( | int | idEnt,
 |  | int | count,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_general_ent.h>

Delete user attribute of the specified entity(ONLY SHELL, FACE and EDGE) in the current active part.
the function does not delete any attributes if the specified label is an empty string or the attribute specified label is not found.

Parameters
[in] | idEnt | the entity(ONLY SHELL, FACE and EDGE) index
[in] | count | number of user attributes (0 to delete all user attributes)
[in] | At | list of user attributes (NULL to delete all user attributes)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUserAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUserAtGet()

evxErrors cvxEntUserAtGet | ( | int | idEnt,
 |  | int * | count,
 |  | svxAttribute ** | At
 | ) |  |

#include <zwapi_general_ent.h>

Retrieves attribute data from the specified entity in the active file.

Parameters
[in] | idEnt | the entity index
[out] | count | number of user attributes
[out] | At | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OBJ
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntUserAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxEntUserAtSet()

evxErrors cvxEntUserAtSet | ( | int | idEnt,
 |  | int | count,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_general_ent.h>

Sets the user attribute for the specified entity(only shape, face and edge) in the current active part.
A new user attribute is inserted if the user attribute for the specified label does not exist.

Parameters
[in] | idEnt | the entity(ONLY SHAPE, FACE and EDGE) index
[in] | count | number of user attributes
[in] | At | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPartInqEntBox()

evxErrors cvxPartInqEntBox | ( | int | idEnt,
 |  | const svxMatrix * | Mat,
 |  | svxBndBox * | Box
 | ) |  |

#include <zwapi_general_ent.h>

Gets the bounding box of the specified entity in the active part.
currently, only shape, face and component are support. If "*Mat = NULL", initializes "Mat" to the identity matrix.
a bounding box relative to the specified local coordinate frame is output.

Parameters
[in] | idEnt | entity id (supported entity: shape,face,component)
[in] | Mat | optional local frame (or NULL)
[out] | Box | shape bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntByLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPartInqEntByLabel()

evxErrors cvxPartInqEntByLabel | ( | int * | Label,
 |  | int | flag,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_general_ent.h>

Searches the active part for an entity with the specified label.

Parameters
[in] | Label | persistent label as null-terminated array of integers
[in] | flag | 1 for exact match; 0 if partial match is okay
[out] | idEntity | entity id (0 is output if no entity is found)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR - function fails or entity is not found.
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPartInqEntFtr()

evxErrors cvxPartInqEntFtr | ( | int | idEntity,
 |  | int * | idFeature
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the id of the parent feature of the specified entity in the active part.

Parameters
[in] | idEntity | entity id
[out] | idFeature | parent feature id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPartInqEntLabel()

evxErrors cvxPartInqEntLabel | ( | int | idEntity,
 |  | int ** | Label
 | ) |  |

#include <zwapi_general_ent.h>

Outputs the persistent label of the specified entity in the active part.

The label is a null-terminated list of integers.

The calling procedure is responsible for deallocating the memory out via "Label".

// Example
int *Label=NULL;
int idEntity = 99;
cvxPartInqEntLabel(idEntity, &Label);
cvxMemFree((void**)&Label);
cvxPartInqEntLabel
evxErrors cvxPartInqEntLabel(int idEntity, int **Label)
cvxMemFree
void cvxMemFree(void **MemPointer)
See also
cvxLabelSame() and cvxPartInqEntByLabel().
Parameters
[in] | idEntity | entity id
[out] | Label | persistent label as null-terminated array of integers
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntsArea

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxPartInqEntsArea()

evxErrors cvxPartInqEntsArea | ( | int | cnt,
 |  | int * | crvList,
 |  | svxAreaProp * | areaProp
 | ) |  |

#include <zwapi_math.h>

Inquires a planar area bounded by curves in 3d space.

The input boundaries may consist of 3d-curves, edges, sketch profiles, and curve lists.

The input just support one plane face.

Note
The calling procedure MUST deallocate the output(pAreaRef and pAreaCA) with cvxMemFree().
Use cvxPartInqEntsAreaByPath() to inquire the area of the entities of sketch/component.
Parameters
[in] | cnt | count of curves/face (only one face)
[in] | crvList | id list of curves/face
[out] | areaProp | area property
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqTagNames

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPartInqTagNames()

evxErrors cvxPartInqTagNames | ( | int * | Count,
 |  | vxLongName ** | Names
 | ) |  |

#include <zwapi_general_ent.h>

Outputs a list of tag names that belong to the current active part. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of tag names
[out] | Names | list of tag names
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPickDataClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • General Entity API
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ cvxPickDataClear()

void cvxPickDataClear ( )

#include <zwapi_general_ent.h>

Clear the pick data for ray casting

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Global Apply

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Global Apply
Common

Detailed Description

THE MODULE FOR THE ZW3D Global Tools API

Global Apply Data

enum evxGlobal {
VX_TOLERANCE = 1 , VX_AUTO_MERGE = 2 , VX_EXACT_MATCH = 3 , VX_LOCALCOORDIDX = 4 ,
VX_CONS_DELAY_SOLVE = 5 , VX_DIM_ATTR = 6
}
global settings More...
typedef struct svxPartDimAttr | svxPartDimAttr
part dimension attribute
typedef enum evxGlobal | evxGlobal
global settings

App Action Data

enum | _evxAppAction { VX_APP_PRECLOSE = 0 , VX_APP_STARTED }
application action type More...
typedef enum _evxAppAction | evxAppAction
application action type
typedef struct _svxAppActionParam | svxAppActionParam
application action parameter

Global Apply

evxErrors | cvxGlobalGet (evxGlobal Global, void *Data)
evxErrors | cvxGlobalSet (evxGlobal Global, void *Data)
evxErrors | cvxNoteGet (char **Note)
evxErrors | cvxNoteSet (char *Note)
void | cvxAutoRegenGet (int *Status)
void | cvxAutoRegenSet (int Status)
void | cvxLangGet (vxName Language)
void | cvxFontMap (const char *zw3dFont, vxLongName mapFont)

Unit

void | cvxUnitGet (evxUnitType *Type, vxName Name)
void | cvxUnitTypeGet (char *unit_str, char *sub_type, char *unit_type)
void | cvxUnitSet (evxUnitType Type)
void | cvxUnitToSys (double *Distance)
void | cvxUnitToUser (double *Distance)
evxErrors | cvxUnitMassGet (evxMassUnitType *type, vxName name)
evxErrors | cvxUnitMassSet (evxMassUnitType type)

Sketch Grid Spacing

evxErrors | cvxSkGridSpacingGet (double *spacing)
evxErrors | cvxSkGridSpacingSet (double spacing)

Color Utilities

void | cvxColorfToColor (const svxColorf *rgbf, svxColor *rgb)
void | cvxColorToColorf (const svxColor *rgb, svxColorf *rgbf)
evxErrors | cvxColorRGB (evxColor color, svxColor *rgb)
evxColor | cvxColorNear (const svxColor *rgb)

Escape Checking

int | cvxEscCheck (void)
void | cvxEscDisable (int *EscapeState)
void | cvxEscRestore (int EscapeState)
void | cvxEscStart (void)
void | cvxEscEnd (void)

Version

int | cvxVersion (char *vxStatus)
void | cvxVersionNum (vxLongName verNum)

Filter

void | cvxFilterListGet (int *count, vxName *filterList)
void | cvxColorFilter (int colorIdx)
evxErrors | cvxFilterActiveGet (vxName Filter)

Tools

int | cvxLabelMatch (int *Label1, int *Label2)
int | cvxNameIsOkay (char *name, int size, int option)
void | cvxHostId (double *idNetwork, double *idDongle)
void | cvxNotifyExit (int opt)
void | cvxSetMSMMoldInstalled (int IsInstalled)
void | cvxSetMSMPressInstalled (int IsInstalled)
evxErrors | cvxPluginRegPathGet (vxPath **pathList, int *pCnt, int is64)
evxErrors | cvxPluginRegPathGetByLongPath (vxLongPath **pathList, int *pCnt, int is64)
evxErrors | cvxHelpDocLoad (const vxLongPath filePath)

App Action

evxErrors cvxAppAction (evxAppAction type, svxAppActionParam *param)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAppAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxAppAction()

evxErrors cvxAppAction | ( | evxAppAction | type,
 |  | svxAppActionParam * | param
 | ) |  |

#include <zwapi_global_apply.h>

Set a callback function. When processing the target application option, the callback function will be called.

If this function called many times with the same 'type', only the last will take effect.

If param->pfn is null, the original callback function, if there exists, will be removed.

Note
If one call this function to register a callback in a dll module, he must call this function again, with argument param set as NULL, to unregister the callback for each action before the dll module exit. Usually we can do this in the exit function of the dll module.
Parameters
[in] | type | action type
[in] | param | callback function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAutoRegenGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxAutoRegenGet()

void cvxAutoRegenGet ( int * Status )

#include <zwapi_global_apply.h>

Gets the status of part "auto regen" (1=ON; 0=OFF).

Parameters
[out] Status 1 if "auto regen" is ON; 0 if OFF
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAutoRegenSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxAutoRegenSet()

void cvxAutoRegenSet ( int Status )

#include <zwapi_global_apply.h>

Sets the status of part "auto regen" (1=ON; 0=OFF).

Parameters
[in] Status 1 if "auto regen" is ON; 0 if OFF
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxColorFilter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxColorFilter()

void cvxColorFilter ( int colorIdx )

#include <zwapi_global_apply.h>

Set the color filter according to color index, this value is the index of color picker in ZW3D, and it should in the range of V_COLOR_NULL ~ V_COLOR_LAST, it will reset the filter to pick all if index is out of this range.

Parameters
[in] colorIdx the index of color filter
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxColorfToColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxColorfToColor()

void cvxColorfToColor | ( | const svxColorf * | rgbf,
 |  | svxColor * | rgb
 | ) |  |

#include <zwapi_global_apply.h>

This function copies the input svxColorf structure, in which the color components are floating point values defined over 0.0 to 1.0, to the output svxColor structure, where the color component values are defined over 0 to 255.

See also
cvxColorToColorf() to copy svxColor to svxColorf.
Parameters
[in] | rgbf | input color (each float component defined over 0.0 to 1.0)
[out] | rgb | output color (each component defined over 0 to 255)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxColorNear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxColorNear()

evxColor cvxColorNear ( const svxColor * rgb )

#include <zwapi_global_apply.h>

This function returns the color defined by evxColor type that is the nearest match to the input RGB components. The return value is never VX_COLOR_NULL or VX_COLOR_RGB.

See also
cvxColorRGB() for a function that outputs RGB components when given a standard color's evxColor value.
Parameters
[in] rgb RGB components of a color to match to a standard color or an index color
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxColorRGB

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxColorRGB()

evxErrors cvxColorRGB | ( | evxColor | color,
 |  | svxColor * | rgb
 | ) |  |

#include <zwapi_global_apply.h>

Output the RGB components of a standard color or an index color.

See also
cvxColorNear() for a function that finds the evxColor value of the nearest standard color when given a color's RGB components.
Parameters
[in] | color | one of the evxColor values for a standard color or an index color
[out] | rgb | RGB components for the input color
Return values
succeeds
  • ZW_API_NO_ERROR - if the input is an unambiguous color, as defined by the evxColor type.
fail
  • ZW_API_GENERAL_ERROR - if the input is not a valid evxColor value or is ambiguous
  • (VX_COLOR_NULL or VX_COLOR_RGB). The output will be black.
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxColorToColorf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxColorToColorf()

void cvxColorToColorf | ( | const svxColor * | rgb,
 |  | svxColorf * | rgbf
 | ) |  |

#include <zwapi_global_apply.h>

This function copies the input svxColor structure, in which the color component values are defined over 0 to 255, to the output svxColorf structure, where the color components are floating point values defined over 0.0 to 1.0.

See also
cvxColorfToColor() to copy svxColorf to svxColor.
Parameters
[in] | rgb | input color (each component defined over 0 to 255)
[out] | rgbf | output color (each float component defined over 0.0 to 1.0)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEscCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxEscCheck()

int cvxEscCheck ( void )

#include <zwapi_global_apply.h>

When escape checking has been enabled using cvxEscStart(), this function returns a non-zero value if the user has pressed the <Esc> key or other menu item that generates and "Escape" event with the intention of terminating execution of the active command.

If no "Escape" event has been triggered by the user, this function returns 0.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEscDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxEscDisable()

void cvxEscDisable ( int * EscapeState )

#include <zwapi_global_apply.h>

Disables checking for "Escape" events overriding cvxEscStart(). This function MUST ALWAYS be paired with a subsequent call to cvxEscRestore(). The "integer" value output by this function (EscapeState) must be passed to the corresponding call to cvxEscRestore().

Parameters
[out] EscapeState current escape checking state
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEscEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxEscEnd()

void cvxEscEnd ( void )

#include <zwapi_global_apply.h>

This function is used to end "Escape" checking after it has been previously initialized with CdEscStart(). Calls to CdEscStart() MUST ALWAYS be paired with a call to CdEscEnd().

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEscRestore

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxEscRestore()

void cvxEscRestore ( int EscapeState )

#include <zwapi_global_apply.h>

Re-enables checking for "Escape" events after cvxEscDisable() has been called. "EscapeState" should be the value output by a previous call to cvxEscDisable(). This function MUST ALWAYS be paired with a prior call to cvxEscDisable().

Parameters
[in] EscapeState original escape checking state
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEscStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxEscStart()

void cvxEscStart ( void )

#include <zwapi_global_apply.h>

This function is used to start "Escape" checking, whereby execution of a command is aborted if the user presses the <Esc> button or other menu item that generates an "Escape" event. This presumes that the currently executing code is calling cvxEscCheck() periodically to allow escape events to be processed.

THE CALLING PROCEDURE MUST PAIR A CALL TO cvxEscStart() WITH A SUBSEQUENT CALL TO cvxEscEnd().

You should put escape checking in a callback function or other code that could take a long time to execute, but that you want to abort if the user tries to initiate a new input or action through the user interface. Put cvxEscStart() at the beginning of your function and cvxEscEnd() at the end. Add calls to cvxEscCheck() between cvxEscStart() and cvxEscEnd(). If a call to cvxEscCheck() returns a non-zero value, clean up whatever your function has started (including all dynamically allocated memory), call cvxEscEnd() and exit your function.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilterActiveGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxFilterActiveGet()

evxErrors cvxFilterActiveGet ( vxName Filter )

#include <zwapi_global_apply.h>

Get current active filter name.

Parameters
[out] Filter the name of current active filter
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilterListGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxFilterListGet()

void cvxFilterListGet | ( | int * | count,
 |  | vxName * | filterList
 | ) |  |

#include <zwapi_global_apply.h>

Get a list of filters' names.

int count = 0;
vxName filterList[30] = {};
cvxFilterListGet(&count, filterList);
cvxFilterListGet
void cvxFilterListGet(int *count, vxName *filterList)
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
Parameters
[out] | count | the count of filters
[out] | filterList | list of filters' names, request vxName[30]
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFontMap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxFontMap()

void cvxFontMap | ( | const char * | zw3dFont,
 |  | vxLongName | mapFont
 | ) |  |

#include <zwapi_global_apply.h>

Map the zw3d font name to the general font.

Such as:

  • "ZW3D Simplex" - "simplex";
  • "ZW3D Simplex Roman" - "romans";
  • "ZW3D Complex Roman" - "romanc";
  • "ZW3D Duplex Roman" - "romand";
  • "ZW3D Triplex Roman" - "romant";
  • "ZW3D Simplex Script" - "scripts";
  • "ZW3D Complex Script" - "scriptc";
  • "ZW3D Simplex Greek" - "greeks";
  • "ZW3D Complex Greek" - "greekc";
  • "ZW3D Gothic German" - "gothicg";
  • "ZW3D Gothic Italian" - "gothici";
  • "ZW3D Gothic English" - "gothice";
  • "ZW3D Complex Italics" - "italicc";
  • "ZW3D Triplex Italics" - "italict";
  • "宋体" - "SimSun";
Parameters
[in] | zw3dFont | font name of zw3d
[out] | mapFont | mapped font name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxGlobalGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxGlobalGet()

evxErrors cvxGlobalGet | ( | evxGlobal | Global,
 |  | void * | Data
 | ) |  |

#include <zwapi_global_apply.h>

Retrieves the value of the specified setting. To accommodate different data types, "Data" is a void pointer. Make sure it references the appropriate storage type. Look at "enum evxGlobal" to see what type of storage is required for each setting.

Parameters
[in] | Global | global setting to modify
[out] | Data | data to assign to global setting
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxGlobalSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxGlobalSet()

evxErrors cvxGlobalSet | ( | evxGlobal | Global,
 |  | void * | Data
 | ) |  |

#include <zwapi_global_apply.h>

Assigns the specified data to the specified setting. To accommodate different data types, "Data" is a void pointer. Make sure it references the appropriate data type. Look at "enum evxGlobal" to see what type of data is required for each setting.

Be careful using this function to change global settings. It is only meant for temporary modification of a setting while an API function is executing. Always restore the original setting when your function is done.

Parameters
[in] | Global | global setting to modify
[in] | Data | data to assign to global setting
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxHelpDocLoad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxHelpDocLoad()

evxErrors cvxHelpDocLoad ( const vxLongPath filePath )

#include <zwapi_global_apply.h>

Load the context file associated with help chm file in memory.

Note
There are two files should be prepared. The first one is a context file and the second is a help document file with 'chm' format. These two files should be put in the same directory. The content of context file should be like as below: Line 1: Line 2: CommandNameA xx.html Line 3: CommandNameB xx.html Line 4: FormNameA xx.html ...
Parameters
[in] filePath the context file path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxHostId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxHostId()

void cvxHostId | ( | double * | idNetwork,
 |  | double * | idDongle
 | ) |  |

#include <zwapi_global_apply.h>

Outputs the network card id and/or dongle id of the host computer for the instance of ZW3D currently executing.

Note
Dongle id is not supported from version 14.6 onward.

Outputs zero for an undefined ID.

Parameters
[out] | idNetwork | decimal encoded network id
[out] | idDongle | decimal encoded dongle id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLabelMatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxLabelMatch()

int cvxLabelMatch | ( | int * | Label1,
 |  | int * | Label2
 | ) |  |

#include <zwapi_global_apply.h>

Determine whether label are matched.

Parameters
[in] | Label1 | first persistent label (null-terminated integer array)
[in] | Label2 | second persistent label (null-terminated integer array)
Return values
return
  • 0 - the input labels do not match
  • 1 - the input labels are the same
  • 2 - the input labels are "close" match
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLangGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxLangGet()

void cvxLangGet ( vxName Language )

#include <zwapi_global_apply.h>

Outputs the name of the active language. The following are supported language names: Danish, Dutch, English, French, German, Italian, Japanese, Korean, Portuguese, Spanish, Chinese-simplified.936, Chinese-traditional.950, Chinese.936, Thai.874, Greek.1253, Finnish

Parameters
[out] Language name of active language
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxNameIsOkay

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxNameIsOkay()

int cvxNameIsOkay | ( | char * | name,
 |  | int | size,
 |  | int | option
 | ) |  |

#include <zwapi_global_apply.h>

Leading and trailing blank spaces are removed from "name".

If an positive integer number (4 digits or less) is input as name", it is padded with zero's until it is 4 digits long. A name that is too long (longer than "size") is truncated. It is assumed that the input "name" is no longer than 512 bytes.

Invalid characters are replaced with underscores.

Parameters
[in,out] | name | name to check
[in] | size | max size (bytes) of a valid name
[in] | option | -2 - check and fix name without warning messages -1 - check and fix name with warning messages 0 - check name without fixes and messages 1 - check name with messages indicating problems
Return values
return
  • 1 - the input name is OK and/or repaired.
  • 0 - the input name is not OK/ empty.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxNoteGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxNoteGet()

evxErrors cvxNoteGet ( char ** Note )

#include <zwapi_global_apply.h>

Retrieves the "Notes" associated with the active root object (or the active file if no root is active) and outputs them via "Notes". The memory referenced by "Note" is allocated by this function and must be deallocated by the calling procedure.

If there are not any notes, no memory is allocated by this function, and "*Note" is set to NULL.

Parameters
[out] Note null-terminated text string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxNoteSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxNoteSet()

evxErrors cvxNoteSet ( char * Note )

#include <zwapi_global_apply.h>

Assigns the specified text to the "Notes" associated with the active root object – or to the active file there is not an active root object.

Parameters
[in] Note null-terminated text string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxNotifyExit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxNotifyExit()

void cvxNotifyExit ( int opt )

#include <zwapi_global_apply.h>

Notify zw3d to exit.

Parameters
[in] opt whether inform the user that zw3d will exit. 0-no, 1-yes
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPluginRegPathGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxPluginRegPathGet()

evxErrors cvxPluginRegPathGet | ( | vxPath ** | pathList,
 |  | int * | pCnt,
 |  | int | is64
 | ) |  |

#include <zwapi_global_apply.h>

Get plugin path of ZW3D in regedit.

Note
Release memory of pathList is the caller's responsibility. There is an example named 'DllRegister' in ApiExample.
Parameters
[out] | pathList | plugin path, an array
[out] | pCnt | count of pathList
[in] | is64 | if 0, paths of 32-bit plugin are acquired, else 64-bit plugin path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPluginRegPathGetByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxPluginRegPathGetByLongPath()

evxErrors cvxPluginRegPathGetByLongPath | ( | vxLongPath ** | pathList,
 |  | int * | pCnt,
 |  | int | is64
 | ) |  |

#include <zwapi_global_apply.h>

Get plugin path of ZW3D in regedit.

Note
Release memory of pathList is the caller's responsibility. There is an example named 'DllRegister' in ApiExample.
Parameters
[out] | pathList | plugin path, an array
[out] | pCnt | count of pathList
[in] | is64 | if 0, paths of 32-bit plugin are acquired, else 64-bit plugin path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSetMSMMoldInstalled

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxSetMSMMoldInstalled()

void cvxSetMSMMoldInstalled ( int IsInstalled )

#include <zwapi_global_apply.h>

Set the value of the Misumi Mold installed mark "VgMoldInstalled".

Parameters
[in] IsInstalled 1 if Misumi Mold is installed, 0 otherwise
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSetMSMPressInstalled

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxSetMSMPressInstalled()

void cvxSetMSMPressInstalled ( int IsInstalled )

#include <zwapi_global_apply.h>

Set the value of the Misumi Press installed mark "VgPressInstalled".

Parameters
[in] IsInstalled 1 if Misumi Press is installed, 0 otherwise
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkGridSpacingGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxSkGridSpacingGet()

evxErrors cvxSkGridSpacingGet ( double * spacing )

#include <zwapi_global_apply.h>

Output grid spacing.

Parameters
[out] spacing grid spacing
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkGridSpacingSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxSkGridSpacingSet()

evxErrors cvxSkGridSpacingSet ( double spacing )

#include <zwapi_global_apply.h>

Set grid spacing.

Parameters
[in] spacing grid spacing
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitGet()

void cvxUnitGet | ( | evxUnitType * | Type,
 |  | vxName | Name
 | ) |  |

#include <zwapi_global_apply.h>

Outputs an integer id that identifies the active user units for linear measure (0-microns, 1-millimeters, 2-centimeters, 3-meters, 4-inches, 5-feet).

If "Name" is not NULL, it is used to output an abbreviation for the name of the active units.

Parameters
[out] | Type | active linear units type
[out] | Name | abbreviation for active units (NULL to ignore)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitMassGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitMassGet()

evxErrors cvxUnitMassGet | ( | evxMassUnitType * | type,
 |  | vxName | name
 | ) |  |

#include <zwapi_global_apply.h>

Outputs an integer id that identifies the active user units for linear measure.

If "name" is not NULL, it is used to output an abbreviation for the name of the active units.

Parameters
[out] | type | active mass units type
[out] | name | abbreviation for active mass units (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitMassSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitMassSet()

evxErrors cvxUnitMassSet ( evxMassUnitType type )

#include <zwapi_global_apply.h>

Sets the active user units for mass measure based on the input "type".

Parameters
[in] type mass unit type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitSet()

void cvxUnitSet ( evxUnitType Type )

#include <zwapi_global_apply.h>

Sets the active user units for linear measure based on the input "Type" (0-microns, 1-millimeters, 2-centimeters, 3-meters, 4-inches, 5-feet).

Parameters
[in] Type linear unit type
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitToSys

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitToSys()

void cvxUnitToSys ( double * Distance )

#include <zwapi_global_apply.h>

Converts specified distance from the active user units to system units (millimeters).

Parameters
[in,out] Distance distance
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitToUser

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitToUser()

void cvxUnitToUser ( double * Distance )

#include <zwapi_global_apply.h>

Converts the specified distance from system units (millimeters) to the active user units.

Parameters
[in,out] Distance distance
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUnitTypeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxUnitTypeGet()

void cvxUnitTypeGet | ( | char * | unit_str,
 |  | char * | sub_type,
 |  | char * | unit_type
 | ) |  |

#include <zwapi_global_apply.h>

Get the unit type and sub type for the specified unit string .

Parameters
[in] | unit_str | the string of unit
[out] | sub_type | the string of sub type,0/1/2:Constant/Length/Angle
[out] | unit_type | the string of unit type,Length(1~9):mic/mm/cm/dm/m/mil/in/ft/yd;Angle(1~2):radians/degrees
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxVersion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxVersion()

int cvxVersion ( char * vxStatus )

#include <zwapi_global_apply.h>

Returns the active ZW3D version number as an integer (one-hundreths). If "vxStatus" is not NULL, a string describing the version is output that indicates whether it is Alpha or Beta along with a revision number. If "vxStatus" is not NULL, it should point to at least 80 bytes of memory.

Parameters
[out] vxStatus status
Return values
return
  • the active ZW3D version number as an integer
Warning
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxVersionNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ cvxVersionNum()

void cvxVersionNum ( vxLongName verNum )

#include <zwapi_global_apply.h>

Get version number string of ZW3D. This is the VERNUM date and internal version number that ZW3D displays in its "About" box to identify a specify build of ZW3D.

See also
cvxVersion() to get the current release number for the version of ZW3D that is in use.
Parameters
[out] verNum version number
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Layer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Layer
Common

Detailed Description

THE MODULE FOR THE ZW3D Layer API

Layer Info Data

enum evxInfoLayerFlag {
VX_LAYER_INFOR_NAME = 0x00000001 , VX_LAYER_INFOR_DESC = 0x00000002 , VX_LAYER_INFOR_ID = 0x00000004 , VX_LAYER_INFOR_VISIBLE = 0x00000008 ,
VX_LAYER_INFOR_FREEZE = 0x000000010 , VX_LAYER_INFOR_DISABLE = 0x00000020 , VX_LAYER_INFOR_COLOR = 0x00000040 , VX_LAYER_INFOR_LINETYPE = 0x00000080 ,
VX_LAYER_INFOR_LINEWIDTH = 0x0000100 , VX_LAYER_INFOR_NUMOBJ = 0x0000200 , VX_LAYER_INFOR_FLTR = 0x0000400 , VX_LAYER_INFOR_ALL = 0xFFFFFFFF
}
layer mask information More...
typedef enum evxInfoLayerFlag | evxInfoLayerFlag
layer mask information
typedef struct svxLayerInfo | svxLayerInfo
layer information

Layer Operation

evxErrors | cvxLayerAdd (char *Name)
evxErrors | cvxLayerAdd2 (const svxLayerInfo *psLayerInfo, int *Number)
evxErrors | cvxLayerDel (vxName Name)
evxErrors | cvxLayerDel2 (int Number)
evxErrors | cvxLayerActivate (vxName Name)
evxErrors | cvxLayerSync (void)
evxErrors | cvxLayerShowAll (void)
evxErrors | cvxLayerIdModify (int srcNumber, int tarNumber)

Layer Query/Set

void | cvxLayerInqActive (vxName Name)
int | cvxLayerExists (vxName Name)
int | cvxLayerExists2 (int Number)
evxErrors | cvxLayerId (vxName name, int *id)
evxErrors | cvxLayerInqEnts (int Number, int *numEnt, svxEntPath **Paths)
evxErrors | cvxLayerAssign (char *Name, int numEnt, int *idEnts)
evxErrors | cvxLayerList (int *Count, vxName **Names)
evxErrors | cvxLayerName (int Number, vxName Name)
evxErrors | cvxLayerNum (vxName Name, int *Number)
evxErrors | cvxLayerGetAllCategory (int *numCate, vxLongName **categories)
evxErrors | cvxActiveLayerNumGet (int *Number)
evxErrors | cvxActiveLayerNumSet (int Number)
evxErrors | cvxLayerStateGet (vxName Name, int *isVisible, int *isFrozen)
evxErrors | cvxLayerStateSet (vxName Name, int isVisible, int isFrozen)

Layer Information

evxErrors | cvxLayerInfoGet (int Number, svxLayerInfo *pLayerInfo)
evxErrors | cvxLayerInfoSet (int Number, const svxLayerInfo *pLayerInfo)
evxErrors | cvxLayerInfoExport (const vxLongPath file)
evxErrors | cvxLayerInfoImport (const vxLongPath file, int overWrite)
void | cvxLayerRefresh ()
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxActiveLayerNumGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxActiveLayerNumGet()

evxErrors cvxActiveLayerNumGet ( int * Number )

#include <zwapi_layer.h>

Get the activate layer number.

Parameters
[out] Number layer number (0-255)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxActiveLayerNumSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxActiveLayerNumSet()

evxErrors cvxActiveLayerNumSet ( int Number )

#include <zwapi_layer.h>

Set the activate layer.

Parameters
[in] Number layer number (0-255)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerActivate()

evxErrors cvxLayerActivate ( vxName Name )

#include <zwapi_layer.h>

Activates the specified layer so that newly-created entities are automatically assigned to it.

Parameters
[in] Name layer name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerAdd()

evxErrors cvxLayerAdd ( char * Name )

#include <zwapi_layer.h>

Creates a new layer with the specified name.

Parameters
[in] Name layer name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerAdd2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerAdd2()

evxErrors cvxLayerAdd2 | ( | const svxLayerInfo * | psLayerInfo,
 |  | int * | Number
 | ) |  |

#include <zwapi_layer.h>

Create a layer entity with layer info.

Parameters
[in] | psLayerInfo | layer info
[out] | Number | layer number (0-255)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerAssign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerAssign()

evxErrors cvxLayerAssign | ( | char * | Name,
 |  | int | numEnt,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_layer.h>

Assigns the specified entities to the specified layer.

Parameters
[in] | Name | layer name
[in] | numEnt | no. of entities to assign to layer
[in] | idEnts | list of id's of entities to assign to layer
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerDel()

evxErrors cvxLayerDel ( vxName Name )

#include <zwapi_layer.h>

Deletes the specified layer.

Parameters
[in] Name layer name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerDel2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerDel2()

evxErrors cvxLayerDel2 ( int Number )

#include <zwapi_layer.h>

Delete a layer.

Parameters
[in] Number layer number (0-255)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerExists

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerExists()

int cvxLayerExists ( vxName Name )

#include <zwapi_layer.h>

Determine whether the layer exists in the active target object by name.

Parameters
[in] Name layer name
Return values
succeeds
  • 1 - the layer exists in the active target object
  • 0 - it does not exist or function fails
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerExists2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerExists2()

int cvxLayerExists2 ( int Number )

#include <zwapi_layer.h>

The number(layer id) must be 0-255.

Parameters
[in] Number layer id
Return values
succeeds
  • 1 - the layer exists in the active target object
  • 0 - it does not exist or function fails
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerGetAllCategory

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerGetAllCategory()

evxErrors cvxLayerGetAllCategory | ( | int * | numCate,
 |  | vxLongName ** | categories
 | ) |  |

#include <zwapi_layer.h>

Get all categories in layer manager.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | numCate | number of categories
[out] | categories | name of categories
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerId()

evxErrors cvxLayerId | ( | vxName | name,
 |  | int * | id
 | ) |  |

#include <zwapi_layer.h>

Output the layer id of a specified name.

Parameters
[in] | name | name
[out] | id | layer id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerIdModify

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerIdModify()

evxErrors cvxLayerIdModify | ( | int | srcNumber,
 |  | int | tarNumber
 | ) |  |

#include <zwapi_layer.h>

Modify the layer id of layer and related objects, source layer id and target layer id must be 0-255.

Note
The function does not allow layer id 0 to be modified.
Parameters
[in] | srcNumber | source layer id
[in] | tarNumber | target layer id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInfoExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInfoExport()

evxErrors cvxLayerInfoExport ( const vxLongPath file )

#include <zwapi_layer.h>

Export layers information to specified file.

Parameters
[in] file export target file full path with extension "zwlyr"
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInfoGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInfoGet()

evxErrors cvxLayerInfoGet | ( | int | Number,
 |  | svxLayerInfo * | pLayerInfo
 | ) |  |

#include <zwapi_layer.h>

Get the layer info.

You should initialze the 'mask' of 'pLayerInfo' to get the specified information of the input layer. If pLayerInfo->mask = 0, it will be set to VX_LAYER_INFOR_ALL in this function to get all information.

Parameters
[in] | Number | layer number (0-255)
[in,out] | pLayerInfo | layer info
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInfoImport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInfoImport()

evxErrors cvxLayerInfoImport | ( | const vxLongPath | file,
 |  | int | overWrite
 | ) |  |

#include <zwapi_layer.h>

Import layers information from specified file.

Parameters
[in] | file | import target file full path with extension "zwlyr"
[in] | overWrite | 1 to overwrite existing layers; 0 to append existing layers
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInfoSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInfoSet()

evxErrors cvxLayerInfoSet | ( | int | Number,
 |  | const svxLayerInfo * | pLayerInfo
 | ) |  |

#include <zwapi_layer.h>

Set the layer info.

Note
This function will redraw the screen, if you will call this function many times, you can call cvxDispState() to disable the display and update the display later.
vxDispState state ={};
cvxDispState(0, state);
for(;;) cvxLayerInfoSet();
cvxDispState(2, state);
cvxDispState
void cvxDispState(int Option, vxDispState State)
vxDispState
int vxDispState[10]
display state settings
Definition: zwapi_display.h:32
cvxLayerInfoSet
evxErrors cvxLayerInfoSet(int Number, const svxLayerInfo *pLayerInfo)
Parameters
[in] | Number | layer number (0-255)
[in] | pLayerInfo | layer info
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInqActive()

void cvxLayerInqActive ( vxName Name )

#include <zwapi_layer.h>

Outputs the name of the active layer.

Parameters
[out] Name active layer name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerInqEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerInqEnts()

evxErrors cvxLayerInqEnts | ( | int | Number,
 |  | int * | numEnt,
 |  | svxEntPath ** | Paths
 | ) |  |

#include <zwapi_layer.h>

Get all entities on the specified layer.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | Number | layer number (0-255)
[out] | numEnt | no. of entities on the specified layer
[out] | Paths | pick-path list of entities on the specified layer
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerList()

evxErrors cvxLayerList | ( | int * | Count,
 |  | vxName ** | Names
 | ) |  |

#include <zwapi_layer.h>

Outputs a list of all layers in the active part or sheet.
The calling procedure must deallocate the output list.

Parameters
[out] | Count | layer count
[out] | Names | list of layers
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerName()

evxErrors cvxLayerName | ( | int | Number,
 |  | vxName | Name
 | ) |  |

#include <zwapi_layer.h>

Outputs the name of the layer with the specified number.

Parameters
[in] | Number | layer number (0-255)
[out] | Name | layer name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerNum()

evxErrors cvxLayerNum | ( | vxName | Name,
 |  | int * | Number
 | ) |  |

#include <zwapi_layer.h>

Outputs the number of the layer with the specified name. Outputs "Number = -1" if the layer is not found.

Parameters
[in] | Name | layer name
[out] | Number | layer number (0-255)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerRefresh

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerRefresh()

void cvxLayerRefresh ( )

#include <zwapi_layer.h>

Refreshes display of the layer manager form.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerShowAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerShowAll()

evxErrors cvxLayerShowAll ( void )

#include <zwapi_layer.h>

Makes all layers visible.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerStateGet()

evxErrors cvxLayerStateGet | ( | vxName | Name,
 |  | int * | isVisible,
 |  | int * | isFrozen
 | ) |  |

#include <zwapi_layer.h>

Gets the state of the specified layer.

Parameters
[in] | Name | layer name
[out] | isVisible | 1 = visible; 0 = blanked
[out] | isFrozen | 1 = frozen, 0 = not frozen
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerStateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerStateSet()

evxErrors cvxLayerStateSet | ( | vxName | Name,
 |  | int | isVisible,
 |  | int | isFrozen
 | ) |  |

#include <zwapi_layer.h>

Sets the state of the specified layer.

The input argument "isFrozen" can be overloaded (set it to -2) to prevent this function from logging a "LayerState" history operation to record a change in layer visibility if a part is active.
In this case, the frozen status of the specified layer remains the same.

Note
Some history and entity selection operations are only applied to visible entities, so be careful using "isFrozen = -2".
This function will redraw the screen, if you will call this function many times, you can call cvxDispState() to disable the display and update the display later.
vxDispState state ={};
cvxDispState(0, state);
for(;;) cvxLayerStateSet();
cvxDispState(2, state);
cvxDispState
void cvxDispState(int Option, vxDispState State)
vxDispState
int vxDispState[10]
display state settings
Definition: zwapi_display.h:32
cvxLayerStateSet
evxErrors cvxLayerStateSet(vxName Name, int isVisible, int isFrozen)
Parameters
[in] | Name | layer name
[in] | isVisible | 1 = visible, 0 = blanked, -1 = leave the same
[in] | isFrozen | 1 = frozen, 0 = not frozen, -1 = leave the same
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLayerSync

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ cvxLayerSync()

evxErrors cvxLayerSync ( void )

#include <zwapi_layer.h>

Synchronizes entity visibility with layer visibility.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: License

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
License
Common

Detailed Description

THE MODULE FOR THE ZW3D License API

License

evxErrors | cvxLicModulesGet (char szModules[1024])
evxErrors | cvxLicIdentifierGet (char szIdentifier[36])
int | cvxLicEvaluationGet (char szEvaluation[36])
int | cvxLicStandaloneEvaluationGet ()
evxErrors | cvxLicActivate (const char *pzEntitlement)
evxErrors | cvxLicRemove (const char *pzEntitlement)
int | cvxLicTypeCheck ()
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicActivate()

evxErrors cvxLicActivate ( const char * pzEntitlement )

#include <zwapi_license.h>

Activate license by entitlement.
See cvxLicRemove() to remove the license for the current ZW3D session.

Parameters
[in] pzEntitlement the license entitlement.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicEvaluationGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicEvaluationGet()

int cvxLicEvaluationGet ( char szEvaluation[36] )

#include <zwapi_license.h>

Get days before trial license expired.
cvxLicStandaloneEvaluationGet() has the similar function as well.

Parameters
[out] szEvaluation[36] currently not used, leave it as NULL
Return values
return
  • > 0 number of days before trial license expired.
  • = 0 the trial license has been expired.
  • < 0 fail to get expire days.
Warning
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicIdentifierGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicIdentifierGet()

evxErrors cvxLicIdentifierGet ( char szIdentifier[36] )

#include <zwapi_license.h>

Get current valid license identifier string.

Parameters
[out] szIdentifier[36] the license identifier string.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicModulesGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicModulesGet()

evxErrors cvxLicModulesGet ( char szModules[1024] )

#include <zwapi_license.h>

Get current authorized module list, the "szModules" is split by '
', e.g. "ZW3D_BASE_MODULES\nZW3D_2AXIS_TURNING\nZW3D_3AXIS_TURNING". If fail to check current license, the license is trial(szModules will be set to "Trial").

Parameters
[out] szModules[1024] the module name list to be return.(e.g. "ZW3D_BASE_MODULES\nZW3D_2AXIS_TURNING\nZW3D_3AXIS_TURNING").
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicRemove()

evxErrors cvxLicRemove ( const char * pzEntitlement )

#include <zwapi_license.h>

Remove license by entitlement.
See cvxLicActivate() to activate the license for the current ZW3D session.

Parameters
[in] pzEntitlement the license entitlement.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicStandaloneEvaluationGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicStandaloneEvaluationGet()

int cvxLicStandaloneEvaluationGet ( )

#include <zwapi_license.h>

Get days before standalone license expired.
cvxLicEvaluationGet() has the similar function as well.

Return values
return
  • > 0 number of days before standalone license expired.
  • = 0 the standalone license has been expired.
  • < 0 fail to get expire days.
Warning
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxLicTypeCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • License
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ cvxLicTypeCheck()

int cvxLicTypeCheck ( )

#include <zwapi_license.h>

Check the current authorization type.
It can check the type except when using trial license.

Return values
return
  • 0 The current authorization type is Soft-key license.(include Soft-key Singleton license and Floating license)
  • 1 The current authorization type is Dongle license.
  • -1 Check failed.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Memory

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Memory
Common

Detailed Description

THE MODULE FOR THE ZW3D Memory API

Memory Allocate

evxErrors | cvxMemAlloc (int NumBytes, void **MemPointer)
evxErrors | cvxMemResize (int NumBytes, void **MemPointer)

Memory Zero

void cvxMemZero (void *MemPointer, int NumBytes)

Memory Free

void cvxMemFree (void **MemPointer)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMemAlloc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Memory
cvxMemAlloc
cvxMemFree
cvxMemResize
cvxMemZero

◆ cvxMemAlloc()

evxErrors cvxMemAlloc | ( | int | NumBytes,
 |  | void ** | MemPointer
 | ) |  |

#include <zwapi_memory.h>

Allocates chunk of memory of requested size from system heap.
Returns void pointer to specified amount of memory.

Parameters
[in] | NumBytes | no. of bytes to allocate
[out] | MemPointer | pointer to allocated memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMemFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Memory
cvxMemAlloc
cvxMemFree
cvxMemResize
cvxMemZero

◆ cvxMemFree()

void cvxMemFree ( void ** MemPointer )

#include <zwapi_memory.h>

Frees memory at specified pointer.
Sets pointer to NULL if memory was freed successfully.
If the input pointer is already NULL, this function does nothing.

Parameters
[in] MemPointer address of pointer to be Free'd
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgTableTest.cpp, drawing\dwgViewTest.cpp, part\asmConsTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMemResize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Memory
cvxMemAlloc
cvxMemFree
cvxMemResize
cvxMemZero

◆ cvxMemResize()

evxErrors cvxMemResize | ( | int | NumBytes,
 |  | void ** | MemPointer
 | ) |  |

#include <zwapi_memory.h>

Resizes memory chunk that was allocated via VxMemAlloc().
If input pointer is NULL, allocates new memory.
Outputs pointer to resized memory.
If memory cannot not be resized, the input pointer is not modified.

Parameters
[in] | NumBytes | new memory size in bytes
[out] | MemPointer | address of pointer to memory to be resized
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMemZero

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Memory
cvxMemAlloc
cvxMemFree
cvxMemResize
cvxMemZero

◆ cvxMemZero()

void cvxMemZero | ( | void * | MemPointer,
 |  | int | NumBytes
 | ) |  |

#include <zwapi_memory.h>

Zero "NumBytes" of data beginning with "MemPointer".

Parameters
[in] | MemPointer | pointer to memory
[in] | NumBytes | number of bytes to zero
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Message

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Message
Common

Detailed Description

THE MODULE FOR THE ZW3D Message API

Message Disable Data

enum | evxDialogType { VX_DIALOG_SAVE_AS = 1 }
dialog form type of user prompt More...
typedef enum evxDialogType | evxDialogType
dialog form type of user prompt

Message Disable

void | cvxErrDisable (void)
void | cvxErrEnable (void)
void | cvxMsgDisable (void)
void | cvxMsgEnable (void)
void | cvxLastWarningMsgEnable (int enable)
void | cvxPromptDisable (void)
void | cvxPromptEnable (void)
void | cvxTranStatusDisable (void)
void | cvxTranStatusEnable (void)
void | cvxUserActionStatusGet (int *disableStatus)
void | cvxUserActionStatusSet (int disable)
void | cvxCrashPromptDisable ()
void | cvxCrashPromptEnable ()
int | cvxUserActionStatusSet2 (evxDialogType type, int value)

Message Area State

void | cvxMsgAreaClose (void)
void | cvxMsgAreaOpen (void)
void | cvxMsgAreaState (int)
evxErrors | cvxMsgAreaStateGet (int *action)

Message Display

evxErrors | cvxMsgFileLoad (const vxLongPath File, int *idFile)
char * | cvxMsgPtr (int idFile, int MessageNum)
void | cvxMsgDisp (char *Text)
void | cvxMsgDisp2 (char *Text, int level)
evxErrors | cvxMessageBox (int MsgType, int WndMode, const char *Title, const char *Message, const char *Btn1Str, const char *Btn2Str, int *Action)

Function Fail Message

evxErrors cvxLastErrGet ()
void | cvxLastErrSet (evxErrors error)
const char * | cvxErrMsgGet (evxErrors error)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrashPromptDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxCrashPromptDisable()

void cvxCrashPromptDisable ( )

#include <zwapi_message.h>

Disable the crash prompt dialog.

See also
cvxCrashPromptEnable() to enable.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrashPromptEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxCrashPromptEnable()

void cvxCrashPromptEnable ( )

#include <zwapi_message.h>

Enable the crash prompt dialog.

See also
cvxCrashPromptDisable() to disable.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxErrDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxErrDisable()

void cvxErrDisable ( void )

#include <zwapi_message.h>

Disable display of error messages in the ZW3D message area.

The application that uses this function is ALWAYS responsible for re-enabling error message display using cvxErrEnable().

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxErrEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxErrEnable()

void cvxErrEnable ( void )

#include <zwapi_message.h>

Re-enable display of error messages in the ZW3D message area.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxErrMsgGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxErrMsgGet()

const char * cvxErrMsgGet ( evxErrors error )

#include <zwapi_message.h>

Return the error message, return NULL if fails to get.

Parameters
[in] error Get the error message
Return values
return
  • error message or NULL.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxLastErrGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxLastErrGet()

evxErrors cvxLastErrGet ( )

#include <zwapi_message.h>

Get the last error type.

Return values
return
  • The last error type.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxLastErrSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxLastErrSet()

void cvxLastErrSet ( evxErrors error )

#include <zwapi_message.h>

Set the last error type.

Parameters
[in] error set the last error type
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxLastWarningMsgEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxLastWarningMsgEnable()

void cvxLastWarningMsgEnable ( int enable )

#include <zwapi_message.h>

Enable/Disable display the warning message when API function fails.

Note
Default is disabled
Parameters
[in] enable 1 - enable the warning message, else 0
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMessageBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMessageBox()

evxErrors cvxMessageBox | ( | int | MsgType,
 |  | int | WndMode,
 |  | const char * | Title,
 |  | const char * | Message,
 |  | const char * | Btn1Str,
 |  | const char * | Btn2Str,
 |  | int * | Action
 | ) |  |

#include <zwapi_message.h>

Function to display message window. A message window is used for common
interaction tasks, which include giving information, asking questions, and
reporting errors.

Valid MsgType is shown below:

MsgType=1: An error window warns users of action consequences and gives them a choice of resolutions.

MsgType=2: An information window gives the user information, such as the status of an action.

MsgType=3: A message window is used for common interaction tasks.

MsgType=4: A Question window is used to get the answer to a question from the user.

MsgType=5: A warning window warns users of action consequences and gives them a choice of resolutions.

MsgType=6: A working window informs users that there is atime-consuming operation in progress and allows them to cancel the operation.

Parameters
[in] | MsgType | Message box type
[in] | WndMode | 0 = modeless, 1 = full application modal
[in] | Title | Window title; set to NULL if not applicable
[in] | Message | Message string
[in] | Btn1Str | Button1 string; set to NULL if not applicable
[in] | Btn2Str | Button2 string; set to NULL if not applicable
[out] | Action | Action
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgAreaClose

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgAreaClose()

void cvxMsgAreaClose ( void )

#include <zwapi_message.h>

Closes the ZW3D message area.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgAreaOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgAreaOpen()

void cvxMsgAreaOpen ( void )

#include <zwapi_message.h>

Opens the ZW3D message area.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgAreaState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgAreaState()

void cvxMsgAreaState ( int )

#include <zwapi_message.h>

Calling this function with "Disable=1" prevents the message
window from automatically opening.

Calling the function again with "Disable=0" re-enables the
normal operation of the message window.

This function MUST always be called in pairs – the first
call with "Disable=1" and the second call with "Disable=0".

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgAreaStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgAreaStateGet()

evxErrors cvxMsgAreaStateGet ( int * action )

#include <zwapi_message.h>

Get the hidden or displayed status of the output list
through this interface.

Parameters
[out] action action; 1-displayed, 2-hidden
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgDisable()

void cvxMsgDisable ( void )

#include <zwapi_message.h>

Disable display of general messages in the ZW3D message area.

The application that uses this function is ALWAYS responsible
for re-enabling general message display using cvxMsgEnable().

Use cvxErrDisable() to disable display of error messages.
Use cvxPromptDisable() to disable display of command prompts.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgDisp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgDisp()

void cvxMsgDisp ( char * Text )

#include <zwapi_message.h>

Displays the specified text in the ZW3D message area.

Parameters
[in] Text text string
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgDisp2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgDisp2()

void cvxMsgDisp2 | ( | char * | Text,
 |  | int | level
 | ) |  |

#include <zwapi_message.h>

Displays the specified text in the output area with specified level.

level: 0-information
       1-note
       2-debug
       3-warning
       4-alert
       5-error
       6-fatal
Parameters
[in] | Text | text string
[in] | level | message level (0-6)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgEnable()

void cvxMsgEnable ( void )

#include <zwapi_message.h>

Re-enable display of general messages in the ZW3D message area.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgFileLoad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgFileLoad()

evxErrors cvxMsgFileLoad | ( | const vxLongPath | File,
 |  | int * | idFile
 | ) |  |

#include <zwapi_message.h>

Load the messages in the specified file (File) in memory
and return an id (idFile) that identifies the file.

Parameters
[in] | File | path to message file
[out] | idFile | loaded message file id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxMsgPtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxMsgPtr()

char * cvxMsgPtr | ( | int | idFile,
 |  | int | MessageNum
 | ) |  |

#include <zwapi_message.h>

Returns a pointer to a static memory area containing the text of
the message identified by "idFile" and "MessageNum".

Parameters
[in] | idFile | message file id (see cvxMsgFileLoad())
[in] | MessageNum | message number within message file
Return values
return
  • a pointer to a static memory area
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPromptDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxPromptDisable()

void cvxPromptDisable ( void )

#include <zwapi_message.h>

Disables the display of command prompts (when it is possible).

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPromptEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxPromptEnable()

void cvxPromptEnable ( void )

#include <zwapi_message.h>

Re-enables display of command prompts.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxTranStatusDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxTranStatusDisable()

void cvxTranStatusDisable ( void )

#include <zwapi_message.h>

Disables the translator status window.
Always pair a call to this function with a subsequent
call to cvxTranslatorStatusEnable().

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxTranStatusEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxTranStatusEnable()

void cvxTranStatusEnable ( void )

#include <zwapi_message.h>

Re-enables the translator status window.
A call to cvxTranslatorStatusDisable() should always
be paired with a subsequent call to this function.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxUserActionStatusGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxUserActionStatusGet()

void cvxUserActionStatusGet ( int * disableStatus )

#include <zwapi_message.h>

Get the value of prompt dialog status. This function must be called before
cvxUserActionStatusSet().

Parameters
[out] disableStatus current disable status
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxUserActionStatusSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxUserActionStatusSet()

void cvxUserActionStatusSet ( int disable )

#include <zwapi_message.h>

Set the status of prompt dialog. disable: 0-enable
2-disable: the default action is "Yes"
3-disable: the default action is "Yes All", if the option does not have this,
it is "Yes"
-1-disable: the default action is "Cancel" ,if the option does not have this,
it is "No"
-2-disable: the default action is "No"

If the option is "Continue", as long as disable is non-zero, it will choice the action "Continue".

Make sure cvxUserActionStatusGet()has been called before you call this function.
After your operation finished, please called this function again to restore the status.
The "integer" value (disable) should be output by cvxUserActionStatusGet().

Parameters
[in] disable disable or enable the prompt dialog
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxUserActionStatusSet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ cvxUserActionStatusSet2()

int cvxUserActionStatusSet2 | ( | evxDialogType | type,
 |  | int | value
 | ) |  |

#include <zwapi_message.h>

Enhanced API for disable or enable the prompt dialog, as cvxUserActionStatusSet() could only set yes / no.

Type: When type is VX_DIALOG_SAVE_AS, parameter value controls the prompt dialog for "Save as the file":
value == 0: Prompt dialog
value == 3: The default action is select "Save as new and replace original one" then push ok button, not prompt dialog
value == 4: The default action is select "Save as copy and close", then push ok button, not prompt dialog
value == 5: The default action is select "Save as copy and open" then push ok button, not prompt dialog
value == 6: The default action is "Cancel", not prompt dialog

Other values for parameter type are reserved for future usage.

Parameters
[in] | type | prompt window type
[in] | value | flag value to disable or enable the prompt dialog
Return values
return
  • Old value before set.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: File Root

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
File Root
Common

Detailed Description

THE MODULE FOR THE ZW3D Root API

Root Edit Data

enum evxRootType {
VX_ROOT_NULL = 0 , VX_ROOT_PART = 89 , VX_ROOT_PART_NEW = -VX_ROOT_PART , VX_ROOT_SHEET = 90 ,
VX_ROOT_DRAWING = 91 , VX_ROOT_SKETCH = 70 , VX_ROOT_EQUATION_SET = 121 , VX_ROOT_CAM_PLAN = 200
}
root object type More...
typedef enum evxRootType evxRootType
root object type

Root Query Data

enum | evxPreviewMode { VX_PREVIEW_OFF = 0 , VX_PREVIEW_GEOM = 1 , VX_PREVIEW_ATTRIB = 2 }
root object preview mode More...
typedef enum evxPreviewMode | evxPreviewMode
root object preview mode

root separate

typedef struct svxRootSepData | svxRootSepData
separate root to file
evxErrors | cvxRootSeparate (svxRootSepData *data)
evxErrors | cvxRootSeparateInit (svxRootSepData *data)

Root Activate

evxErrors | cvxRootActivate (vxRootName Name)
evxErrors | cvxRootActivate2 (const vxLongPath File, const vxRootName Name)
evxErrors | cvxRootActivateLoadAsmCtx (const vxLongPath File, const vxRootName Name, int isLoad)

Root Edit

evxErrors | cvxRootAdd (evxRootType Type, vxRootName Name, const char *Template)
evxErrors | cvxRootAdd2 (evxRootType, vxRootName Name, const char *Template, char *Description)
int | cvxRootAdd2Bg (evxRootType Type, vxRootName Name)
evxErrors | cvxRootCopy (const vxLongPath SourceFile, const vxRootName SourceName, const vxLongPath DestFile, vxRootName DestName, int Overwrite, int UpdateUid)
evxErrors | cvxRootDel (vxRootName Name)
void | cvxRootExit (void)

Root Query

evxErrors | cvxRootId (vxRootName Name, int *idRoot, evxRootType *Type)
void | cvxRootInqActive (char *Name, int nBytes)
evxErrors | cvxRootInqAsm (char *Name, int nBytes)
evxErrors | cvxRootInqMod (int *Mod)
evxErrors | cvxRootInqModByName (const vxLongPath fileName, const vxRootName rootName, int *mod)
evxErrors | cvxRootInqModSinceRegen (int *Mod)
evxErrors | cvxRootInqSymbol (const vxLongPath file, int *iCount, vxRootName **names)
evxErrors | cvxRootIsAsm (const vxLongPath File, const vxRootName Part, int *isAsm)
evxErrors | cvxRootList (const vxLongPath File, int *Count, vxRootName **Names)
evxPreviewMode | cvxRootPreviewGet (void)
void | cvxRootPreviewSet (evxPreviewMode Mode, const vxLongPath File, vxRootName Object)
void | cvxRootTemplateFile (const vxLongPath File)

File/Root Rename

evxErrors | cvxRootRename (vxRootName Name, vxRootName NewName, int Update)
evxErrors | cvxRootRename2 (vxRootName Name, vxRootName NewName, char *Descript, int Update)
evxErrors | cvxRootRenameMulti (int Count, const vxPath *FileName, const vxRootName *RootName, const vxPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)
evxErrors | cvxRootRenameMultiByLongPath (int Count, const vxLongPath *FileName, const vxRootName *RootName, const vxLongPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)

Root Variable

evxErrors | cvxRootVarGet (vxRootName Name, svxVariable *Variable)
evxErrors | cvxRootVarSet (vxRootName Name, int Count, svxVariable *Var, int Working)

Root Attribute

void | cvxRootVisibility (vxRootName Name, int Visible)
evxErrors | cvxRootInqSheetMetal (const vxLongPath file, const vxRootName part, int *shtMetal)
evxErrors | cvxRootAtItemGet (const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
evxErrors | cvxRootAtItemSet (const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
evxErrors | cvxRootCustomDataSet (const vxLongPath file, vxRootName objectName, char *data, int dataLength)
evxErrors | cvxRootCustomDataGet (const vxLongPath file, const vxRootName objectName, char **data, int *dataLength)
evxErrors | cvxRootCustomDataDel (const vxLongPath file, vxRootName objectName)
evxErrors | cvxRootCustomDataAdd (const vxLongPath file, const vxRootName root, const char *data, int *idCustomData)
evxErrors | cvxRootInqCustomData (const vxLongPath file, const vxRootName root, int *count, int **idCustomDatas)
evxErrors | cvxRootCustomDataGetAll (const vxLongPath file, const vxRootName root, int *count, char ***data)
evxErrors | cvxRootCustomDataGetById (const vxLongPath file, const vxRootName root, int idCustomData, char **data)
evxErrors | cvxRootCustomDataModById (const vxLongPath file, const vxRootName root, int idCustomData, const char *data)
evxErrors | cvxRootCustomDataDelById (const vxLongPath file, const vxRootName root, int count, const int *idCustomDatas)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootActivate()

evxErrors cvxRootActivate ( vxRootName Name )

#include <zwapi_root.h>

Activates the specified root object in the active file for editing.

Parameters
[in] Name root object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROE
  • ZW_API_INPUT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootActivate2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootActivate2()

evxErrors cvxRootActivate2 | ( | const vxLongPath | File,
 |  | const vxRootName | Name
 | ) |  |

#include <zwapi_root.h>

Activates the root object specified by "File" and "Root" as the
target object and backs up information about the current target
object to an internal stack (up to 16 calls deep).

This function will activate the specified file in the memory and
the target object will be activated. cvxFileActivate() will activate
the file and open it in the window.

When this function is called with "File=NULL" and "Root=NULL",
the last target object on the stack is restored. The calling
application MUST reliably pair calls to this function to set
and restore target objects.

When this function is called with "File="*" and "Name=NULL",
the stack is cleared.

for example:
...(coding)
cvxRootActivate2(File,Name);
...(coding)
...(when no code is needed to execute in the current environment, the interface closure file needs to be called again)
cvxRootActivate2(NULL,NULL);
...(coding)
Note
If cvxRootActivate2(NULL,NULL) is not called,unpredictable errors can occur.
Parameters
[in] | File | root object file
[in] | Name | root object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootActivateLoadAsmCtx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootActivateLoadAsmCtx()

evxErrors cvxRootActivateLoadAsmCtx | ( | const vxLongPath | File,
 |  | const vxRootName | Name,
 |  | int | isLoad
 | ) |  |

#include <zwapi_root.h>

Activates the root object specified by "File" and "Name" as the
target object and backs up information about the current target
object to an internal stack (up to 16 calls deep).

When this function is called with "File=NULL" and "Name=NULL",
the last target object on the stack is restored.
When this function is called with "File="*" and "Name=NULL",
the stack is cleared.

The calling application MUST reliably pair calls to this function to set
and restore target objects.

for example:
...(coding)
cvxRootActivateLoadAsmCtx(File,Name,1);
...(coding)
...(when no code is needed to execute in the current environment, the interface closure file needs to be called again)
cvxRootActivateLoadAsmCtx(NULL,NULL,1);
...(coding)
Note
If cvxRootActivateLoadAsmCtx(NULL,NULL,) is not called,unpredictable errors can occur.
cvxRootActivateLoadAsmCtx(File,Name,0) and cvxRootActivate2(File,Name) have the same function.
Parameters
[in] | File | root object file
[in] | Name | root object name
[in] | isLoad | 1 is load assembly context data, 0 is not load
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootAdd()

evxErrors cvxRootAdd | ( | evxRootType | Type,
 |  | vxRootName | Name,
 |  | const char * | Template
 | ) |  |

#include <zwapi_root.h>

Creates and inserts a root object of the specified type
in the active file. It becomes the active object for editing.

Note
User need to call cvxRootExit() after one root
object is added if inserts two root objects at the
same time, for example:
err1 = cvxRootAdd(VX_ROOT_PART, "Part001", NULL);
cvxRootExit();
err2 = cvxRootAdd(VX_ROOT_PART, "Part002", NULL);
cvxRootAdd
evxErrors cvxRootAdd(evxRootType Type, vxRootName Name, const char *Template)
VX_ROOT_PART
@ VX_ROOT_PART
part
Definition: zwapi_root.h:33
cvxRootExit
void cvxRootExit(void)
An optional template object name may be input for a part,
sheet or plan. If it is specified, the new root object
is a copy of the template object. It is assumed that
the template object resides in the template file registered
with cvxRootTemplateFile() before this function is called.
Parameters
[in] | Type | root object type
[in] | Name | root object name
[in] | Template | optional template object name (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootAdd2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootAdd2()

evxErrors cvxRootAdd2 | ( | evxRootType | ,
 |  | vxRootName | Name,
 |  | const char * | Template,
 |  | char * | Description
 | ) |  |

#include <zwapi_root.h>

The function is same as cvxRootAdd() but add a parameter Description to add
description for part

Parameters
[in] | Type | root object type
[in] | Name | root object name
[in] | Template | optional template object name (or NULL)
[in] | Description | optional object description (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootAdd2Bg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootAdd2Bg()

int cvxRootAdd2Bg | ( | evxRootType | Type,
 |  | vxRootName | Name
 | ) |  |

#include <zwapi_root.h>

Adds a root object into the "background" of the active file – that is, the new root object
is not displayed in the file's root object list. If a root object with the input name already
exists in the active file, a new root object is not added.

Presently, this function only supports part objects (Type = VX_ROOT_PART).

Parameters
[in] | Type | root object type (presently only VX_ROOT_PART is supported)
[in] | Name | part name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
other
  • 2 - if a root object with the specified name already exists
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootAtItemGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootAtItemGet()

evxErrors cvxRootAtItemGet | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | at
 | ) |  |

#include <zwapi_root.h>

Outputs an attribute from a specified root.

The itemId includes the following items of evxAtItemId: VX_AT_USER VX_AT_NAME VX_AT_NUMBER VX_AT_DESIGNER VX_AT_MANAGER VX_AT_SUPPLIER VX_AT_KEYWORD VX_AT_DESCRIPT VX_AT_START VX_AT_END

When itemId is VX_AT_USER, the name of the user-defined attribute must be assigned to at->label before calling this function. For all other itemId values, at->label can be an empty string (at->label[0]=0) when this function is called.

If the specified file is not already open, this function will open it to access the attribute, and will then close the file. If you want to keep the file open, use the cvxFileKeep() function, before calling this function, to set a flag that prevents cvxRootAtItemGet() and cvxRootAtItemSet() from closing the files that they open. (Files that are already open before cvxRootAtItemGet() or cvxRootAtItemSet() is called are never closed by these functions.) Keeping files open is a more efficient way to access multiple attributes in a file, but you must remember to call cvxFileKeep() again to reset the flag after you have finished your calls to cvxRootAtItemGet() and cvxRootAtItemSet(), and you also become responsible for closing the files, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | file | object file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active target object)
[in] | itemId | item id
[in,out] | at | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootAtItemSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootAtItemSet()

evxErrors cvxRootAtItemSet | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | at
 | ) |  |

#include <zwapi_root.h>

Sets an attribute value in a specified root.

The itemId includes the following items of evxAtItemId: VX_AT_USER VX_AT_NAME VX_AT_NUMBER VX_AT_DESIGNER VX_AT_MANAGER VX_AT_SUPPLIER VX_AT_KEYWORD VX_AT_DESCRIPT

When itemId is VX_AT_USER, the name of the user-defined attribute must be assigned to at->label before calling this function. For all other itemId values, at->label can be an empty string (at->label[0]=0) when this function is called.

If the specified file is not already open, this function will open it to access the attribute, and will then close the file. If you want to keep the file open, use the cvxFileKeep() function, before calling this function, to set a flag that prevents cvxRootAtItemGet() and cvxRootAtItemSet() from closing the files that they open. (Files that are already open before cvxRootAtItemGet() or cvxRootAtItemSet() is called are never closed by these functions.) Keeping files open is a more efficient way to access multiple attributes in a file, but you must remember to call cvxFileKeep() again to reset the flag after you have finished your calls to cvxRootAtItemGet() and cvxRootAtItemSet(), and you also become responsible for closing the files, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | file | object file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active target object)
[in] | itemId | item id
[in] | at | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCopy()

evxErrors cvxRootCopy | ( | const vxLongPath | SourceFile,
 |  | const vxRootName | SourceName,
 |  | const vxLongPath | DestFile,
 |  | vxRootName | DestName,
 |  | int | Overwrite,
 |  | int | UpdateUid
 | ) |  |

#include <zwapi_root.h>

Copies the specified root object from "SourceFile" to "DestFile".
Both files must already exist and must reside in one of the
directories specified in "vxpaths" (see cvxPathAdd() and
cvxPathSearchFirst()).

Normally, when a root object is copied, the unique id's in the copied
object are the same as the original object. When "UpdateUid=1", the
the unique id's of the copied object are updated so they are different
from the original object. You should input "UpdateUid=0", unless you
have a specific purpose for generating copies with different unique id's.
In normal usage, ZW3D is able to differentiate entities in a copied object
from the original object without changing unique id's.

Parameters
[in] | SourceFile | name of file to copy from
[in] | SourceName | name of root object in source file
[in] | DestFile | name of file to copy to
[in] | DestName | name to assign copied root object
[in] Overwrite 0 = upgrade DestName to avoid naming conflict,
1 = prompt before overwriting existing object.
-1 = automatically overwrite existing object.
[in] | UpdateUid | 1 to make UID's of copied geometry unique, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataAdd()

evxErrors cvxRootCustomDataAdd | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | const char * | data,
 |  | int * | idCustomData
 | ) |  |

#include <zwapi_root.h>

Add user custom data to a specific root object of an existing ZW3D file.

Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[in] | data | customization data (pointer to null-terminated ascii string)
[out] | idCustomData | index of new customization data object (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_STRING
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataDel()

evxErrors cvxRootCustomDataDel | ( | const vxLongPath | file,
 |  | vxRootName | objectName
 | ) |  |

#include <zwapi_root.h>

Delete the first user custom data from a existing root object of an existing ZW3D file.

Parameters
[in] | file | ZW3D or VX file name (file[0]=0 or NULL for active file)
[in] | objectName | root object name (objName[0]=0 or NULL for active object)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataDelById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataDelById()

evxErrors cvxRootCustomDataDelById | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | int | count,
 |  | const int * | idCustomDatas
 | ) |  |

#include <zwapi_root.h>

Delete specified customization data from a existing root object of an existing ZW3D file.

Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[in] | count | number of customization data (0 to delete all)
[in] | idCustomDatas | index list of customization data (NULL to delete all)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataGet()

evxErrors cvxRootCustomDataGet | ( | const vxLongPath | file,
 |  | const vxRootName | objectName,
 |  | char ** | data,
 |  | int * | dataLength
 | ) |  |

#include <zwapi_root.h>

Get the first user custom data from a existing root object of an existing ZW3D file.
The list referenced by "**data" is allocated by this function and must
be deallocated by the calling procedure by cvxMemFree() function. A NULL
pointer is output if no data is found.

Parameters
[in] | file | ZW3D or VX file name (file[0]=0 or NULL for active file)
[in] | objectName | root object name (objName[0]=0 or NULL for active object)
[out] | data | customization data
[out] | dataLength | length of customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataGetAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataGetAll()

evxErrors cvxRootCustomDataGetAll | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | int * | count,
 |  | char *** | data
 | ) |  |

#include <zwapi_root.h>

Get all customization data from a existing root object of an existing ZW3D file.
The referenced by "***data" and "**dataLength" is allocated by this function and
must be deallocated by the calling procedure by cvxMemFree() function. the use case
is as follows:

int count = 0;
char** data = NULL;
cvxRootCustomDataGetAll(NULL, NULL, &count, &data);
...
for (int i = 0; i < count; i++)
{
cvxMemFree((void**)&data[i]);
}
cvxMemFree((void**)&data);
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxRootCustomDataGetAll
evxErrors cvxRootCustomDataGetAll(const vxLongPath file, const vxRootName root, int *count, char ***data)
Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[out] | count | number of customization data
[out] | data | list of customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INVALID_OBJ
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataGetById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataGetById()

evxErrors cvxRootCustomDataGetById | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | int | idCustomData,
 |  | char ** | data
 | ) |  |

#include <zwapi_root.h>

Get specified customization data from a existing root object of an existing ZW3D file.
The referenced by "**data" is allocated by this function and must be deallocated by the
calling procedure by cvxMemFree() function. NULL pointer is output if no data is found.

Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[in] | idCustomData | index of customization data object
[out] | data | customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataModById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataModById()

evxErrors cvxRootCustomDataModById | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | int | idCustomData,
 |  | const char * | data
 | ) |  |

#include <zwapi_root.h>

Modify specified customization data from a existing root object of an existing ZW3D file.

Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[in] | idCustomData | index of customization data object
[in] | data | customization data (pointer to null-terminated ascii string)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootCustomDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootCustomDataSet()

evxErrors cvxRootCustomDataSet | ( | const vxLongPath | file,
 |  | vxRootName | objectName,
 |  | char * | data,
 |  | int | dataLength
 | ) |  |

#include <zwapi_root.h>

Set user custom data to a specific root object of an existing ZW3D file.
Program will overwrite the first custom data if root object already has custom data.

Parameters
[in] | file | ZW3D or VX file name (file[0]=0 or NULL for active file)
[in] | objectName | root object name (objName[0]=0 or NULL for active object)
[in] | data | customization data
[in] | dataLength | length of customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootDel()

evxErrors cvxRootDel ( vxRootName Name )

#include <zwapi_root.h>

Deletes the specified root object from the active file.

Parameters
[in] Name root object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootExit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootExit()

void cvxRootExit ( void )

#include <zwapi_root.h>

Exits the active root object to either the parent object or the parent file.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootId()

evxErrors cvxRootId | ( | vxRootName | Name,
 |  | int * | idRoot,
 |  | evxRootType * | Type
 | ) |  |

#include <zwapi_root.h>

Gets the database id of the specified root object (Name) in
the active file. "idRoot = 0" is output if root object is
not found.

Parameters
[in] | Name | root object name
[out] | idRoot | root object id
[out] | Type | root object type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\partUtils.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqActive()

void cvxRootInqActive | ( | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_root.h>

Outputs the name of the active root object.
Outputs "Name[0]=0" if there is not an active root object.

Parameters
[out] | Name | name of active root object
[in] | nBytes | string max size of root object name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_OUTPUT
Examples
part\partUtils.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqAsm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqAsm()

evxErrors cvxRootInqAsm | ( | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_root.h>

Outputs the name of the top root object in assembly.
Outputs "Name[0]=0" if error.

Parameters
[out] | Name | name of top root object in assembly
[in] | nBytes | string max size of root object
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqCustomData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqCustomData()

evxErrors cvxRootInqCustomData | ( | const vxLongPath | file,
 |  | const vxRootName | root,
 |  | int * | count,
 |  | int ** | idCustomDatas
 | ) |  |

#include <zwapi_root.h>

Outputs a list of indices of the customization data that belong to a existing root object of an existing ZW3D file. The calling procedure MUST deallocate the output list with cvxMemFree.

Parameters
[in] | file | ZW3D file name (file[0]=0 or NULL for active file)
[in] | root | root object name (root[0]=0 or NULL for active object)
[out] | count | number of customization data
[out] | idCustomDatas | id's list of customization data objects
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OBJ
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqMod()

evxErrors cvxRootInqMod ( int * Mod )

#include <zwapi_root.h>

Outputs 1 if the active root object has been modified since it was
last activated, otherwise outputs 0.

See also
cvxRootInqModSinceRegen() and cvxFileIsModified().
Parameters
[out] Mod 1 if active root object has been modified
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqModByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqModByName()

evxErrors cvxRootInqModByName | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | int * | mod
 | ) |  |

#include <zwapi_root.h>

Outputs 1 if the specified root object has been modified since it was
last activated, otherwise outputs 0.

See also
cvxRootInqModSinceRegen() and cvxFileIsModified().
Parameters
[in] | fileName | Z3/VX file name (fileName[0]=0 or NULL for active file)
[in] | rootName | root object name (rootName[0]=0 or NULL for active object)
[out] | mod | 1 if active root object has been modified
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqModSinceRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqModSinceRegen()

evxErrors cvxRootInqModSinceRegen ( int * Mod )

#include <zwapi_root.h>

Outputs 1 if the active root object has been modified since it was
regenerated, otherwise outputs 0.

See also
also cvxRootInqMod() and cvxFileIsModified().
Parameters
[out] Mod 1 if active root object has been modified since last regen
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqSheetMetal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqSheetMetal()

evxErrors cvxRootInqSheetMetal | ( | const vxLongPath | file,
 |  | const vxRootName | part,
 |  | int * | shtMetal
 | ) |  |

#include <zwapi_root.h>

Check that whether there is sheet metal in specified part.

Parameters
[in] | file | file name (file[0]=0 or NULL for active file)
[in] | part | part name (part[0]=0 or NULL for active part)
[out] | shtMetal | whether there is sheet metal in the part (1: exist; 0: NOT exist)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootInqSymbol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootInqSymbol()

evxErrors cvxRootInqSymbol | ( | const vxLongPath | file,
 |  | int * | iCount,
 |  | vxRootName ** | names
 | ) |  |

#include <zwapi_root.h>

If "file" is input as NULL, this function gets a list of the symbol names in the active file.

If the path of a valid ZW3D file is input via "file", this function gets a
list of symbol names in the specified file.

The list referenced by "**names" is allocated by this function and must
be deallocated by the calling procedure. A NULL pointer is output if
no data is found.

Parameters
[in] | file | file path (pass in NULL if undefined)
[out] | iCount | number of symbol names
[out] | names | list of symbol names
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootIsAsm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootIsAsm()

evxErrors cvxRootIsAsm | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | isAsm
 | ) |  |

#include <zwapi_root.h>

Get the type of part root object: part or assembly.

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | isAsm | 1 = Assembly; 0 = Part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootList()

evxErrors cvxRootList | ( | const vxLongPath | File,
 |  | int * | Count,
 |  | vxRootName ** | Names
 | ) |  |

#include <zwapi_root.h>

if "File" is input as NULL, this function gets a list of the names of all
the root objects in the active file.

If the path of a valid ZW3D file is input via "File", this function gets a
list of the root objects in the specified file.

The list referenced by "**Names" is allocated by this function and must
be deallocated by the calling procedure. A NULL pointer is output if
no data is found.

Parameters
[in] | File | optional ZW3D file path (pass in NULL if undefined)
[out] | Count | no. of root objects output via "Names"
[out] | Names | list of root object names
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootPreviewGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootPreviewGet()

evxPreviewMode cvxRootPreviewGet ( void )

#include <zwapi_root.h>

Determine whether a graphical root object preview is enabled.

Return values
return
  • 1 - if a graphical root object preview is enabled.
  • 0 - Otherwise .
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootPreviewSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootPreviewSet()

void cvxRootPreviewSet | ( | evxPreviewMode | Mode,
 |  | const vxLongPath | File,
 |  | vxRootName | Object
 | ) |  |

#include <zwapi_root.h>

Displays the specified preview for the specified root object.

Parameters
[in] | Mode | preview mode
[in] | File | file (NULL if VX_PREVIEW_OFF)
[in] | Object | object (NULL if VX_PREVIEW_OFF)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootRename()

evxErrors cvxRootRename | ( | vxRootName | Name,
 |  | vxRootName | NewName,
 |  | int | Update
 | ) |  |

#include <zwapi_root.h>

Renames a root object in the active file. If "Update" is input
as a non-zero value, references to "Name" in the active file are
changed to "NewName".

It's also can be used to rename the 2d sketch block in the active file.

Note
Can only rename the root name of .Z3 File.
Parameters
[in] | Name | name of root object to rename (in active file)
[in] | NewName | new name for root object
[in] | Update | 1 to update references by name, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootRename2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootRename2()

evxErrors cvxRootRename2 | ( | vxRootName | Name,
 |  | vxRootName | NewName,
 |  | char * | Descript,
 |  | int | Update
 | ) |  |

#include <zwapi_root.h>

Renames a root object in the active file and assigns the specified
description to it (if defined). If "Update" is input as a non-zero
value, references to "Name" in the active file are changed to "NewName".
Passing in a blank string for "Descript" will clear the current
description associated with the specified root object.

Note
Can only rename the root name of .Z3 File.
Parameters
[in] | Name | name of root object to rename (in active file)
[in] | NewName | new name for root object
[in] | Descript | new description for root object (NULL if undefined)
[in] | Update | 1 to update references by name, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootRenameMulti

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootRenameMulti()

evxErrors cvxRootRenameMulti | ( | int | Count,
 |  | const vxPath * | FileName,
 |  | const vxRootName * | RootName,
 |  | const vxPath * | NewFileName,
 |  | const vxRootName * | NewRootName,
 |  | int | fDelOriginal
 | ) |  |

#include <zwapi_root.h>

Rename the given files and/or root objects. If neither the new file name nor the new root object name is specified, the function does nothing and returns ZW_API_INVALID_INPUT.

In the active file and files referenced by the active file, references to the given names are updated to use the new names.

Renaming a root object with this function clears the object's description. Refer to cvxRootRename2() for a function that can assign a description to a root object while renaming it.

When files are renamed, a new copy of each file is saved using the new name rather than actually changing the name of the original file. If the fDelOriginal argument is 1, this function deletes the original files for which new files have been created. If fDelOriginal is 0, the original files are preserved.

If a n error does occur, some files and objects might be renamed and others might still have their original names when this function returns.

Parameters
[in] | Count | the number of names in each input array
[in] | FileName | array of "Count" file names or full paths to rename. each file that needs to be renamed must have add file name or full path to the array.
[in] | RootName | array of "Count" root object names to rename, may be NULL. multi-objects files must specify the root object to be renamed. single-object files do not need to be specified.
[in] | NewFileName | array of "Count" new file names or full paths, may be NULL. if don't specify new file name, the original file name is used by default. single-object file should always specify new file name.
[in] | NewRootName | array of "Count" new root object names, may be NULL. if no new root object name is specified for multi-objects file, the original root object name is used by default. single-object files do not need to be specified.
[in] | fDelOriginal | 1 to delete original files after renaming, 0 to keep them
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootRenameMultiByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootRenameMultiByLongPath()

evxErrors cvxRootRenameMultiByLongPath | ( | int | Count,
 |  | const vxLongPath * | FileName,
 |  | const vxRootName * | RootName,
 |  | const vxLongPath * | NewFileName,
 |  | const vxRootName * | NewRootName,
 |  | int | fDelOriginal
 | ) |  |

#include <zwapi_root.h>

Rename the given files and/or root objects. If neither the new file name nor the new root object name
is specified, the function does nothing and returns ZW_API_INVALID_INPUT.

In the active file and files referenced by the active file, references to the given names are updated to
use the new names.

Renaming a root object with this function clears the object's description. Refer to cvxRootRename2()
for a function that can assign a description to a root object while renaming it.

When files are renamed, a new copy of each file is saved using the new name rather than actually changing
the name of the original file. If the fDelOriginal argument is 1, this function deletes the original files
for which new files have been created. If fDelOriginal is 0, the original files are preserved.

If an error does occur, some files and objects might be renamed and others might
still have their original names when this function returns.

Note
Normally, this function is used to rename components/roots in the current activate file.
Don't use cvxRootActivate2 to active the files you want to rename!!!
This function will active them inside.
Parameters
[in] | Count | the number of names in each input array
[in] FileName array of "Count" file names or full paths to rename.
each file that needs to be renamed must have add file name or full path to the array.
[in] RootName array of "Count" root object names to rename, may be NULL.
multi-objects files must specify the root object to be renamed.
single-object files do not need to be specified.
[in] NewFileName array of "Count" new file names or full paths, may be NULL.
if don't specify new file name, the original file name is used by default.
single-object file should always specify new file name.
[in] NewRootName array of "Count" new root object names, may be NULL.
if no new root object name is specified for multi-objects file, the original root object name is used by default.
single-object files do not need to be specified.
[in] | fDelOriginal | 1 to delete original files after renaming, 0 to keep them
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootSeparate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootSeparate()

evxErrors cvxRootSeparate ( svxRootSepData * data )

#include <zwapi_root.h>

The function of this interface is to split the selected roots in multiple files into multiple single files.

Interface cvxRootSeparateInit can initialize the structure.

Parameters
[in] data separate data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootSeparateInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootSeparateInit()

evxErrors cvxRootSeparateInit ( svxRootSepData * data )

#include <zwapi_root.h>

Initialize the structure svxRootSepData.

See also
cvxRootSeparate
Parameters
[out] data separate data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootTemplateFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootTemplateFile()

void cvxRootTemplateFile ( const vxLongPath File )

#include <zwapi_root.h>

Registers the specified object file name as the file from
which cvxRootAdd() retrieves template objects. The file
should reside in one of the active search directories
(see cvxPathAdd()). Input NULL or a blank string to
use the default template file name (defined in config).

Parameters
[in] File template object file name (NULL for default name)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootVarGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootVarGet()

evxErrors cvxRootVarGet | ( | vxRootName | Name,
 |  | svxVariable * | Variable
 | ) |  |

#include <zwapi_root.h>

Searches the specified root object in the active file
for the variable named "Variable->Name".

The value of the specified variable is output via
"Variable->Value" in database units (mm, deg).
The "isDistance" parameter is not set by this function.

If "Variable->Name" is a string variable, the associated
text is output via "Variable->Expression". Strings longer
than 256 bytes are truncated.

Note
"Variable->Expression" is not used to output the
expression that defines a variable. It is used to output
text associated with a "string" variable.
Parameters
[in] | Name | root object name
[in,out] | Variable | variable data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootVarSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootVarSet()

evxErrors cvxRootVarSet | ( | vxRootName | Name,
 |  | int | Count,
 |  | svxVariable * | Var,
 |  | int | Working
 | ) |  |

#include <zwapi_root.h>

Updates the variables (e.g. dimensions, parameters) specified
by "Variables" in the specified root object within the active
file. The root object is then regenerated.

You can disable the object regeneration normally performed by
this function by inputing "Working = -1".

A field of a history operation's input data is identified by a
variable name encoded as follows (brackets included):

  <operation_name:field_number>

Part attributes may be modified using the following variable names,
with the new attribute value or data assigned to the "Expression" field
of the "svxVariable" data structure.

  part_number, part_class, part_designer, part_cost, part_supplier
  part_description, part_keyword, part_manager, part_material

User-defined data stored in a part's attributes can be modified
using a variable name composed from "part_" and a user-data label.
For example, if an item of user data were labeled "my_data", the
corresponding variable name would be "part_my_data". The new user
data would be defined via the "Expression" field of the "svxVariable"
data structure.

The part "density" attribute is modified via the variable name "part_density".
The new density (kg/mm3) is defined via the "Value" field of the "svxVariable"
data structure.

The color of all faces in a part may be modified via the "part_color"
variable with "Expression" set to "Aluminum", "Brass", "Bronze", "Copper",
"Silver", "Steel", "Stainless", "Gold", "Gray", "Red", "Green", "Blue",
"Brown", "Orange" or RGB values (0-255) encoded as "R.G.B" (e.g. 136.255.0).

Custom variables :
Expression format of string type :"\"str\"";
Expression format of point type :"Point(1,2,3)";
Expression format of vector type :"Vector(1,2,3)";

If the type of variable is set to 0,then the sub_type must be set,else ignore.
If the sub_type of variable is set to 1 or 2,then the unit_type must be set,else ignore.

evxUnitType for length unit and evxAngUnitType for angle unit.

Parameters
[in] | Name | root object name
[in] | Count | number of variables
[in] | Var | list of variables
[in] | Working | 1 to display "Working..." message, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxRootVisibility

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ cvxRootVisibility()

void cvxRootVisibility | ( | vxRootName | Name,
 |  | int | Visible
 | ) |  |

#include <zwapi_root.h>

If "Visible = 0", suppress display of the specified
root object in the root object browser.

If "Visible = 1", enable display of the specified
root object in the root object browser.

If is assumed "Name" identifies a valid root object
in the active file.

Parameters
[in] | Name | root object name
[in] | Visible | 1 to show; 0 to hide
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Text Common API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Text Common API
Common

Detailed Description

THE MODULE FOR THE ZW3D Text API

Text Data

typedef struct svxTextLoc svxTextLoc
text location

Text

evxErrors | cvxEntTextInq (int idText, char **Text)
evxErrors | cvxEntTextMod (int idText, char *Text)
evxErrors | cvxEntTextAtGet (int idText, svxTextAt *At)
evxErrors | cvxEntTextAtSet (int idText, svxTextAt *At)
evxErrors | cvxEntTextLocGet (int idText, svxTextLoc *loc)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Text Common API
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ cvxEntTextAtGet()

evxErrors cvxEntTextAtGet | ( | int | idText,
 |  | svxTextAt * | At
 | ) |  |

#include <zwapi_text.h>

Outputs the attributes of specified text.

Parameters
[in] | idText | text id
[out] | At | attributes if text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Text Common API
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ cvxEntTextAtSet()

evxErrors cvxEntTextAtSet | ( | int | idText,
 |  | svxTextAt * | At
 | ) |  |

#include <zwapi_text.h>

Sets the attributes of specified text.

Parameters
[in] | idText | text id
[in] | At | attributes if text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZE_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextInq

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Text Common API
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ cvxEntTextInq()

evxErrors cvxEntTextInq | ( | int | idText,
 |  | char ** | Text
 | ) |  |

#include <zwapi_text.h>

Gets a copy of the null-terminated ascii text string associated with
the specified entity (idText) in the active target file.

This function allocates memory for the text string and outputs a pointer
to the memory via "char **Text". The calling procedure is responsible
for deallocating the memory. A NULL pointer is output if no text is
found.

int idText = XXX;
char *Text=NULL;
cvxEntTextInq(idText,&Text);
printf("Text = %s",Text);
cvxMemFree((void**)&Text);
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxEntTextInq
evxErrors cvxEntTextInq(int idText, char **Text)
Parameters
[in] | idText | id of text entity
[out] | Text | copy of entity text string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextLocGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Text Common API
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ cvxEntTextLocGet()

evxErrors cvxEntTextLocGet | ( | int | idText,
 |  | svxTextLoc * | loc
 | ) |  |

#include <zwapi_text.h>

Outputs the location of specified text.

Parameters
[in] | idText | text id
[out] | loc | location
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Text Common API
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ cvxEntTextMod()

evxErrors cvxEntTextMod | ( | int | idText,
 |  | char * | Text
 | ) |  |

#include <zwapi_text.h>

Replaces the text currently associated with "idText" with the input text string (Text).

Parameters
[in] | idText | id of text entity
[in] | Text | null-terminated ascii text string to assign to entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: User Input

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
User Input
Common

Detailed Description

THE MODULE FOR THE ZW3D User Input API

Get Entity Data

enum evxEntInpOpt {
VX_INP_UNDEFINED = 0 , VX_INP_GENERAL_3D = 1 , VX_INP_GENERAL_2D = 2 , VX_INP_SHAPE = 3 ,
VX_INP_FACE = 4 , VX_INP_SHAPE_OR_FACE = 5 , VX_INP_EDGE = 6 , VX_INP_CURVE = 7 ,
VX_INP_EDGE_OR_CURVE = 8 , VX_INP_CURVE_LIST = 9 , VX_INP_PARTING_CURVE = 10 , VX_INP_POINT = 11 ,
VX_INP_FEATURE = 12 , VX_INP_SKETCH = 13 , VX_INP_DATUM_PLANE = 14 , VX_INP_REF_PLANE = 15 ,
VX_INP_3D_BLOCK = 16 , VX_INP_LIGHT = 17 , VX_INP_LAYER = 18 , VX_INP_REF_GEOM = 19 ,
VX_INP_WIREFRAME = 20 , VX_INP_MOVE = 21 , VX_INP_BLANK = 22 , VX_INP_ERASE = 23 ,
VX_INP_INQUIRE = 24 , VX_INP_3D_GEOM = 25 , VX_INP_TEXT = 26 , VX_INP_PROF = 27 ,
VX_INP_COMP = 28 , VX_INP_ASM_SHAPE = 29 , VX_INP_FACE_ON_SHAPE = 30 , VX_INP_SUB_COMP = 31 ,
VX_INP_CSYS = 32 , VX_INP_AXIS_3D = 33 , VX_INP_AXIS_2D = 34
}
entity input options More...
typedef enum evxEntInpOpt evxEntInpOpt
entity input options

Get Point Data

enum evxPntInpOpt {
VX_INP_PNT_GENERAL = 0 , VX_INP_PNT_ON_ENTITY = 1 , VX_INP_PNT_ON_CURVE = 2 , VX_INP_PNT_ON_EDGE = 3 ,
VX_INP_PNT_ON_CURVE_OR_EDGE = 4 , VX_INP_PNT_ON_ANY_FACE = 5 , VX_INP_PNT_ON_FIELD_1_FACE = 6 , VX_INP_PNT_END = 7 ,
VX_INP_PNT_ASSEMBLY = 8 , VX_INP_PNT_DIRECTION = 9 , VX_INP_PNT_ON_CRV_OR_PROF = 10 , VX_INP_PNT_ASSEM_FACE = 11 ,
VX_INP_PNT_ASSEM_EDGE = 12 , VX_INP_PNT_ASSEM_CURVE = 13
}
point input options More...
typedef enum evxPntInpOpt evxPntInpOpt
point input options

Get Number

evxErrors | cvxGetAngle (const char *Prompt, double *Angle)
evxErrors | cvxGetDistance (const char *Prompt, double *Distance)
evxErrors | cvxGetNumber (const char *Prompt, double *Number)

Get Entity

evxErrors | cvxGetEnt (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
evxErrors | cvxGetEnts (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
evxErrors | cvxGetEntPath (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
evxErrors | cvxGetEntPaths (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths)
evxErrors | cvxGetEntsMultiFilter (const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, int **idEnts)
evxErrors | cvxGetEntPathsMultiFilter (const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, svxEntPath **Paths)
evxErrors | cvxGetExternalPick (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, svxEntPath *EntPath, svxMatrix *Matrix)

Get Point

evxErrors | cvxGetPoint (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
evxErrors | cvxGetPoints (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
evxErrors | cvxGetPointOnEnt (const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
evxErrors | cvxGetPointsOnEnts (const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)

Get File

void | cvxGetFile (int Open, const char *Prompt, const char *Default, const char *Filter, char *Path)
void | cvxGetFileByLongPath (int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
void | cvxGetFileActiveField (int Open, const char *Prompt, const char *Default, const char *Filter)
void | cvxGetFolder (const char *Prompt, char *Default, vxPath path)
void | cvxGetFolderByLongPath (const char *Prompt, char *Default, char *Path, int sizePath)
void | cvxGetFolderActiveField (const char *Prompt, const char *Default)

Get Message

int | cvxGetResponse (int Option, const char *Message)
int | cvxGetString (const char *Prompt, const char *Default, int NumBytes, char *String)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetAngle()

evxErrors cvxGetAngle | ( | const char * | Prompt,
 |  | double * | Angle
 | ) |  |

#include <zwapi_userinput.h>

Gets angle input from the user, using the specified prompt.

Parameters
[in] | Prompt | text prompt
[out] | Angle | angle (deg)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetDistance()

evxErrors cvxGetDistance | ( | const char * | Prompt,
 |  | double * | Distance
 | ) |  |

#include <zwapi_userinput.h>

Gets distance input from the user, using the specified prompt.

Parameters
[in] | Prompt | text prompt
[out] | Distance | distance (mm)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEnt()

evxErrors cvxGetEnt | ( | const char * | Prompt,
 |  | evxEntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick an entity whose id is output via "idEntity".

Parameters
[in] | Prompt | text prompt
[in] | Opt | entity input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | idEntity | entity id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEntPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEntPath()

evxErrors cvxGetEntPath | ( | const char * | Prompt,
 |  | evxEntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | svxEntPath * | Path
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick an entity whose path is output via "Path".

Parameters
[in] | Prompt | text prompt
[in] | Opt | entity input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Path | entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Examples
part\asmConsTest.cpp, part\datumCrtTest.cpp, part\partUtils.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEntPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEntPaths()

evxErrors cvxGetEntPaths | ( | const char * | Prompt,
 |  | evxEntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | int * | Count,
 |  | svxEntPath ** | Paths
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick
a list of entities, which is output via "Paths". The calling
procedure is responsible for deallocating the entity path list.

Parameters
[in] | Prompt | text prompt
[in] | Opt | entity input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Count | number of entity picks
[out] | Paths | list of entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
part\asmConsTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEntPathsMultiFilter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEntPathsMultiFilter()

evxErrors cvxGetEntPathsMultiFilter | ( | const char * | Prompt,
 |  | evxEntInpOpt * | pOpt,
 |  | int | npOpt,
 |  | int | EmptyOk,
 |  | int * | Count,
 |  | svxEntPath ** | Paths
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick
a list of entities whose type already exists in the entity option array by himself, which is output via "Paths".
The calling procedure is responsible for deallocating the entity path list.

Parameters
[in] | Prompt | text prompt
[in] | pOpt | entity input option array pointer
[in] | npOpt | entity input option array elements` number
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Count | number of entity picks
[out] | Paths | list of entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEnts()

evxErrors cvxGetEnts | ( | const char * | Prompt,
 |  | evxEntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick
a list of entities, which is output via "idEnts". The calling
procedure is responsible for deallocating the entity list.

Parameters
[in] | Prompt | text prompt
[in] | Opt | entity input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Count | number of entity picks
[out] | idEnts | list of entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, part\baseFtrCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, and sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetEntsMultiFilter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetEntsMultiFilter()

evxErrors cvxGetEntsMultiFilter | ( | const char * | Prompt,
 |  | evxEntInpOpt * | pOpt,
 |  | int | npOpt,
 |  | int | EmptyOk,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to pick
a list of entities whose type already exists in the entity option array by himself, which is output via "idEnts". The calling
procedure is responsible for deallocating the entity list.

Parameters
[in] | Prompt | text prompt
[in] | pOpt | entity input option array pointer
[in] | npOpt | entity input option array elements` number
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Count | number of entity picks
[out] | idEnts | list of entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetExternalPick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetExternalPick()

evxErrors cvxGetExternalPick | ( | const char * | Prompt,
 |  | evxPntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | svxPoint * | Point,
 |  | svxEntPath * | EntPath,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "prompt" and waits for the user to select
a point based on the input option (evxPntInpOpt). This function
is especially designed to manage the selection of points on entities
that lie outside of the active target object, such as a point on a
face of an assembly component. Your objective may be to get the
coordinates of a point that lies external to the active object (e.g. part),
the pick-path of an external entity (e.g. an assembly face), or both.

The selected point's coordinates are output in the local space of the point's
parent entity. "Matrix" may be used to transform the point (and entity)
coordinates from their local space to the space of the target object that
was active at the time the point was selected (see cvxPntTransform(),
cvxCrvTransform()and cvxSrfTransform()).

If the point was selected by snapping to an entity, the pick-path of the
entity is output via "EntPath". A pick-path defines the sequence of object
references (i.e. nested assembly components) that locate the entity relative
to the active target object. A pick-path could lead to an entity that lies
in a different file or object than the active file/object.

API functions for querying entities generally require that an entity's parent
file and object(i.e. part, sketch, plan, drawing) be active. If you want to
query information about an entity, such as its geometry, use cvxEntPathActivate()
to activate the entity's parent file and object, and to get the entity's id.
Query the geometry and, if desired, transform it into the space of the original
target object using "Matrix". When you are done querying the geometry, restore
the original target file and object with cvxEntPathActivate().

Parameters
[in] | Prompt | text prompt
[in] | Opt | point input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Point | point defined in the local space of its parent entity
[out] | EntPath | entity pick-path (Entity->Count=0 if undefined)
[out] | Matrix | transform that maps point from local space to space of active target
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFile()

void cvxGetFile | ( | int | Open,
 |  | const char * | Prompt,
 |  | const char * | Default,
 |  | const char * | Filter,
 |  | char * | Path
 | ) |  |

#include <zwapi_userinput.h>

Displays the file browser with the specified "Prompt" and initialized
to the "Default" folder. The browser will display the files specified
by "Filter", which is a string like the following examples:

Show all files: "All Files (*.*)|*.*|"
Show DXF and DWG files: "DWG File (*.dwg)|*.dwg|DXF File (*.dxf)|*.dxf|"

If "Open = 1", the file browser will come up in the configuration
used to select a file to be opened.

If "Open = 0", the file browser will come up in the configuration
used to specify a file to be saved. If the file already exists, the
user will be asked whether he wants to overwrite it.

To initialize the file browser to both a default directory and file selection, input "Default" as the desired directory, followed by a comma, followed by the desired file name.

Note
The path of the file selected by the user is output via the string
variable "Path". If there is an error, or the user presses cancel,
an empty string is output.
"Path" must reference 512 bytes of memory.
Better to use cvxGetFileByLongPath(), this function needs to set the length of the path.
See also
cvxGetFileActiveField().
Parameters
[in] | Open | 1 to open files, 0 to save files
[in] | Prompt | null-terminated text prompt
[in] | Default | default directory (null-terminated string)
[in] | Filter | file filter (null-terminated string)
[out] | Path | user-selected file path(must be 512 bytes)
Warning
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFileActiveField

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFileActiveField()

void cvxGetFileActiveField | ( | int | Open,
 |  | const char * | Prompt,
 |  | const char * | Default,
 |  | const char * | Filter
 | ) |  |

#include <zwapi_userinput.h>

Similar to cvxGetFile(), this function is intended for use when a form
is open and a string field is active. The file browser is initialized
using the parent folder of the file path from the active field. If
the active field is empty, the file browser is initialized using the
"Default" folder string. The specified "Prompt" is shown to the user
when the file browser opens, and the browser displays the files
specified by "Filter". Refer to cvxGetFile() for more information about
the syntax of the "Filter" string.

When the user closes the file browser, the path to the file selected
by the user is sent to the active field. If the user cancels the
browser, or if an error occurs, the active field is not changed.

If "Open = 1", the file browser will be configured to select a file to be opened.

If "Open = 0", the file browser will be configured to select or name a
file to be saved. If the file already exists, the user will be asked
to confirm that the file is to be replaced.

A default will be provided if the "Prompt", "Default" or "Filter"
argument is NULL. When "Open" is 1, the default filter allows any
file to be selected, but when "Open" is 0 the caller should always
provide the filter, although this function will use a default in this
case, too, if necessary guessing at the type of file to be saved.

When saving ("Open" is 0), the file browser can be configured to show
a default folder and also pre-select a specified file. Do this by
assigning the path to the desired folder to "Default", followed by a
comma, followed by the desired file name.

Unlike the cvxGetFile() function, this function does not allow multiple
selections. Only a single file selection is sent to the active field
when the user closes the file browser.

This function is particularly helpful for implementing command
functions that automatically display the file browser when the user
activates a string input field. For example, a function that displays
the file browser to open a text file might look like this:

void TextFileCB(void) {
cvxGetFileActiveField(1,"Select a text file",NULL,
"Text Files|*.txt|All Files|*.*|");
}
cvxGetFileActiveField
void cvxGetFileActiveField(int Open, const char *Prompt, const char *Default, const char *Filter)

and after installing a symbol with the same name as the function,
using the cvxCmdFunc() function, it can be referenced in the string
field's options property by preceding the symbol name with a tilde
character:

~TextFileCb,

See also
cvxGetFile().
Parameters
[in] | Open | 1 to open files, 0 to save files
[in] | Prompt | null-terminated text prompt
[in] | Default | default directory (null-terminated string)
[in] | Filter | file filter (null-terminated string)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFileByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFileByLongPath()

void cvxGetFileByLongPath | ( | int | Open,
 |  | const char * | Prompt,
 |  | const char * | Default,
 |  | const char * | Filter,
 |  | char * | Path,
 |  | int | sizePath
 | ) |  |

#include <zwapi_userinput.h>

Displays the file browser with the specified "Prompt" and initialized to the "Default" folder. The browser will display the files specified by "Filter", which is a string like the following examples:

Show all files: "All Files (*.*)|*.*|" Show DXF and DWG files: "DWG File (*.dwg)|*.dwg|DXF File (*.dxf)|*.dxf|"

If "Open = 1", the file browser will come up in the configuration used to select a file to be opened.

If "Open = 0", the file browser will come up in the configuration used to specify a file to be saved. If the file already exists, the user will be asked whether he wants to overwrite it.

The path of the file selected by the user is output via the string variable "Path". If there is an error, or the user presses cancel, an empty string is output. It is assumed that "Path" references sufficient memory to hold the output path (max = 512 bytes).

To initialize the file browser to both a default directory and file selection, input "Default" as the desired directory, followed by a comma, followed by the desired file name.

A Path that is too long (longer than "sizePath") is truncated.

It is assumed that the input "Path" is no longer than 512 bytes.

See also
cvxGetFileActiveField().
Parameters
[in] | Open | 1 to open files, 0 to save files
[in] | Prompt | null-terminated text prompt
[in] | Default | default directory (null-terminated string)
[in] | Filter | file filter (null-terminated string)
[out] | Path | user-selected file path
[int] | sizePath max size of Path user-selected file path
Warning
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFolder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFolder()

void cvxGetFolder | ( | const char * | Prompt,
 |  | char * | Default,
 |  | vxPath | path
 | ) |  |

#include <zwapi_userinput.h>

Displays a dialogue for browsing and selecting a file folder.
This function grabs all events and does not return until "OK" or "Cancel" is selected.

The path of the folder selected by the user is output via the string
variable "Path". If there is an error, or the user presses cancel,
an empty string is output. It is assumed that "Path" references
sufficient memory to hold the output path (max = 512 bytes).

See also
cvxGetFolderActiveField().
Parameters
[in] | Prompt | prompt displayed on directory browser title bar
[in] | Default | default folder (null-terminated string)
[out] | Path | path of selected folder (outputs NULL pointer if "Cancel" is selected)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFolderActiveField

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFolderActiveField()

void cvxGetFolderActiveField | ( | const char * | Prompt,
 |  | const char * | Default
 | ) |  |

#include <zwapi_userinput.h>

Similar to cvxGetFolder(), this function is intended for use when a form
is open and a string field is active. The folder browser is
initialized using the path found in the active field. If the active
field is empty, the folder browser is initialized using the "Default"
folder string. The specified "Prompt" is shown to the user when the
folder browser opens.

When the user closes the folder browser, the path to the folder
selected by the user is sent to the active field. If the user cancels
the browser, or if an error occurs, the active field is not changed.

If the "Prompt" or "Default" argument is NULL, a default will be provided.

This function is particularly helpful for implementing command
functions that automatically display the folder browser when the user
activates a string input field. For example, a function that displays
the browser for selecting an output folder might look like this:

void OutputDirCB(void) {
cvxGetFolderActiveField("Select output folder",NULL);
}
cvxGetFolderActiveField
void cvxGetFolderActiveField(const char *Prompt, const char *Default)

and after installing a symbol with the same name as the function,
using the cvxCmdFunc() function, it can be referenced in the string
field's options property by preceding the symbol name with a tilde
character:

~OutputDirCb,

See also
cvxGetFolder().
Parameters
[in] | Prompt | prompt displayed on folder browser title bar
[in] | Default | default folder (null-terminated string)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetFolderByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetFolderByLongPath()

void cvxGetFolderByLongPath | ( | const char * | Prompt,
 |  | char * | Default,
 |  | char * | Path,
 |  | int | sizePath
 | ) |  |

#include <zwapi_userinput.h>

Displays a dialogue for browsing and selecting a file folder. This function grabs all events and does not return until "OK" or "Cancel" is selected.

The path of the folder selected by the user is output via the string variable "Path". If there is an error, or the user presses cancel, an empty string is output. It is assumed that "Path" references sufficient memory to hold the output path (max = 512 bytes).

A Path that is too long (longer than "sizePath") is truncated.

It is assumed that the input "Path" is no longer than 512 bytes.

See also
cvxGetFolderActiveField().
Parameters
[in] | Prompt | prompt displayed on directory browser title bar
[in] | Default | default folder (null-terminated string)
[out] | Path | path of selected folder (outputs NULL pointer if "Cancel" is selected)
[in] | sizePath | max size of path
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetNumber

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetNumber()

evxErrors cvxGetNumber | ( | const char * | Prompt,
 |  | double * | Number
 | ) |  |

#include <zwapi_userinput.h>

Gets numeric input from the user, using the specified prompt.

Parameters
[in] | Prompt | text prompt
[out] | Number | number (dimensionless)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\asmConsTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetPoint()

evxErrors cvxGetPoint | ( | const char * | Prompt,
 |  | evxPntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | svxPoint * | Point,
 |  | int * | idEntity
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "prompt" and waits for the user to input
a point, which is output via "Point". If the user used a
"point-on-entity" option, the entity index is output via "idEntity".

Parameters
[in] | Prompt | text prompt
[in] | Opt | point input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Point | point input
[out] | idEntity | entity id (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetPointOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetPointOnEnt()

evxErrors cvxGetPointOnEnt | ( | const char * | prompt,
 |  | evxPntInpOpt | opt,
 |  | int | emptyOk,
 |  | svxPoint * | point,
 |  | svxEntPath * | path
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "prompt" and waits for the user to input
a point, which is output via "Point".
If the user used a "point-on-entity" option, the entity index is output via "path".

Parameters
[in] | prompt | text prompt
[in] | opt | point input option
[in] | emptyOk | 1 if <middle-click> without input is okay; else 0
[out] | point | point input
[out] | path | entity path (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetPoints()

evxErrors cvxGetPoints | ( | const char * | Prompt,
 |  | evxPntInpOpt | Opt,
 |  | int | EmptyOk,
 |  | int * | Count,
 |  | svxPoint ** | Points
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to input
a list of points, which is output via "Points". The calling
procedure is responsible for deallocating the point list.

Parameters
[in] | Prompt | text prompt
[in] | Opt | point input option
[in] | EmptyOk | 1 if <middle-click> without input is okay; else 0
[out] | Count | number of point picks
[out] | Points | list of points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetPointsOnEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetPointsOnEnts()

evxErrors cvxGetPointsOnEnts | ( | const char * | prompt,
 |  | evxPntInpOpt | opt,
 |  | int | emptyOk,
 |  | int * | count,
 |  | svxPoint ** | points,
 |  | svxEntPath ** | paths
 | ) |  |

#include <zwapi_userinput.h>

Displays the specified "Prompt" and waits for the user to input
a list of points and paths, which is output via "points" and "paths".
The calling procedure is responsible for deallocating the point and path list.

Parameters
[in] | prompt | text prompt
[in] | opt | point input option
[in] | emptyOk | 1 if <middle-click> without input is okay; else 0
[out] | count | number of point picks
[out] | points | list of points
[out] | paths | list of paths(path of point on entity, NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR : error or user-escape
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp, part\datumCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetResponse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetResponse()

int cvxGetResponse | ( | int | Option,
 |  | const char * | Message
 | ) |  |

#include <zwapi_userinput.h>

Displays the input message string in a GUI window and waits for a user
response based on "Option". Occurrences of the "@" character
in the message string will be replaced with a newline character.

A numeric value indicating the user's response is returned.
Valid options and corresponding return values are shown below:

Option=1: Display "Continue". Return 1 when the user selects "Continue".
Option=2: Display "Yes" and "No". Return 1 for "Yes", 0 for "No".
Option=3: Display "Yes", "No" and "Cancel". Return 1 for "Yes", 0 for "No" and -1 for "Cancel".
Option=4: Display "Yes", "Yes All", "No" and "Cancel". Return 1 for "Yes", 2 for "Yes All", 0 for "No" and -1 for "Cancel".

Parameters
[in] | Option | see "DESCRIPTION"
[in] | Message | null-terminated text message
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetString

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ cvxGetString()

int cvxGetString | ( | const char * | Prompt,
 |  | const char * | Default,
 |  | int | NumBytes,
 |  | char * | String
 | ) |  |

#include <zwapi_userinput.h>

Gets string input from the user.
The string input is placed in the memory referenced by "String".
If necessary, the input string is truncated to fit the memory.

Parameters
[in] | Prompt | null-terminated text prompt
[in] | Default | default input string (or empty string)
[in] | NumBytes | no. bytes of storage referenced by "String"
[out] | String | user input text string
Return values
return
  • 0 - user pressed "Cancel" or did not input a string
  • 1 - otherwise
Examples
drawing\dwgDimTest.cpp, part\baseFtrCrtTest.cpp, part\shapeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Common Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Macros
Common Data
Common

Detailed Description

THE MODULE FOR THE ZW3D Generic Data Types and Structures

Macros

#define VX_API_VERSION 2800
API version number. More...

Function Return Error Type

enum evxErrors {
ZW_API_NO_ERROR = 0 , ZW_API_GENERAL_ERROR = -10000 , ZW_API_ROOT_OBJ_ACT_FAIL = -5 , ZW_API_WRONG_ROOT_ENV = -6 ,
ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR = -7 , ZW_API_ROOT_ERROR = -8 , ZW_API_INVALID_INPUT = -31 , ZW_API_INPUT_ERROR = -32 ,
ZW_API_INPUT_TYPE_ERROR = -33 , ZW_API_INVALID_OUTPUT = -34 , ZW_API_FILE_LOCATE_FAIL = -61 , ZW_API_FILE_ERROR = -62 ,
ZW_API_OBJ_TYPE_ERROR = -91 , ZW_API_OBJ_DATA_GET_ERROR = -92 , ZW_API_OBJ_DATA_SET_ERROR = -93 , ZW_API_INVALID_OBJ = -94 ,
ZW_API_ENT_PATH_ERROR = -121 , ZW_API_INVALID_ENT_PATH = -122 , ZW_API_CMMD_INIT_ERROR = -151 , ZW_API_CMMD_EXEC_ERROR = -152 ,
ZW_API_CMMD_DATA_ERROR = -153 , ZW_API_FUN_REGISTER_ERROR = -160 , ZW_API_FUN_UNLOAD_ERROR = -161 , ZW_API_MEMORY_ERROR = -181 ,
ZW_API_OUT_OF_RANGE = -182 , ZW_API_MODELING_DATA_ERROR = -211 , ZW_API_BOOLEAN_ADD_BASE_ERROR = -212 , ZW_API_INVALID_NAME = -241 ,
ZW_API_INVALID_PATH = -242 , ZW_API_INVALID_STRING = -243 , ZW_API_PATH_LEN_OVER_RANGE = -244 , ZW_API_NAME_LEN_OVER_RANGE = -245 ,
ZW_API_PATH_LEN_LESS_RANGE = -246 , ZW_API_NAME_LEN_LESS_RANGE = -247 , ZW_API_FORM_CREATE_FAIL = -271 , ZW_API_FORM_SHOW_FAIL = -272 ,
ZW_API_FORM_EXIST_ERROR = -273 , ZW_API_FORM_INIT_ERROR = -274 , ZW_API_TABLE_SETDATA_ERROR = -281 , ZW_API_TABLE_GETDATA_ERROR = -282 ,
ZW_API_LICENSE_NESTING_ERROR = -301 , ZW_API_FUNCTION_CB_GET_ERROR = -401 , ZW_API_FUCNTION_CB_EXIST_ERROR = -402 , ZW_API_FUCNTION_CB_EXECUTION_ERROR = -403 ,
ZW_API_CAM_OPTYPE_ERROR = -1001 , ZW_API_CAM_GETOPNAME_ERROR = -1002 , ZW_API_CAM_GETOPBYTAC_ERROR = -1003 , ZW_API_CAM_GETOPERATION_ERROR = -1004 ,
ZW_API_CAM_GETVDATA_ERROR = -1011 , ZW_API_CAM_SETVDATA_ERROR = -1012 , ZW_API_CAM_UPVADTA_ERROR = -1013 , ZW_API_CAM_GETTACNAME_ERROR = -1021 ,
ZW_API_CAM_GETTACTIC_ERROR = -1022 , ZW_API_CAM_GETFTRGRP_ERROR = -1031 , ZW_API_CAM_GETFTRDBNAME_ERROR = -1032 , ZW_API_CAM_GETFTR_ERROR = -1033 ,
ZW_API_CAM_GETSETUP_ERROR = -1041 , ZW_API_CAM_GETMACH_ERROR = -1051 , ZW_API_CAM_GETMACHNAME_ERROR = -1052 , ZW_API_CAM_GETFOLDER_ERROR = -1061 ,
ZW_API_CAM_GETFOLDERNAME_ERROR = -1062 , ZW_API_CAM_GETFOLDERSUB_ERROR = -1063 , ZW_API_CAM_GETTOOL_ERROR = -1072 , ZW_API_CAM_GETTOOLNAME_ERROR = -1073 ,
ZW_API_CAM_GETHOLDER_ERROR = -1073 , ZW_API_CAM_GETTOOLTYPE_ERROR = -1074 , ZW_API_CAM_GETTOOLSUBTYPE_ERROR = -1075 , ZW_API_CAM_GETTOOLID_ERROR = -1076 ,
ZW_API_CAM_GETTOOLLEN_ERROR = -1077 , ZW_API_CAM_GETTOOLDIA_ERROR = -1078 , ZW_API_CAM_GETCMCOMP_ERROR = -1081 , ZW_API_CAM_GETCOMPCLASS_ERROR = -1082 ,
ZW_API_CAM_GETCOMPINDEX_ERROR = -1083 , ZW_API_CAM_GETCOMPVDATA_ERROR = -1084 , ZW_API_CAM_GETFRAME_ERROR = -1091 , ZW_API_CAM_GETACTFRAME_ERROR = -1092 ,
ZW_API_CAM_GETOUT_ERROR = -1101 , ZW_API_CAM_OUTCL_ERROR = -1102 , ZW_API_CAM_OUTNC_ERROR = -1103 , ZW_API_CAM_OUTOPLIST_ERROR = -1104 ,
ZW_API_CAM_OUTOPHTML_ERROR = -1105 , ZW_API_CAM_OUTOPXML_ERROR = -1106 , ZW_API_CAM_OUTTOOL_ERROR = -1107 , ZW_API_CAM_GUITOTXT_ERROR = -1111 ,
ZW_API_CAM_GUIFROMTXT_ERROR = -1112 , ZW_API_CAM_GETFORMSTATE_ERROR = -1121 , ZW_API_CAM_FORMDEFINE_ERROR = -1122 , ZW_API_CAM_GETFORMITEM_ERROR = -1123 ,
ZW_API_CAM_SETFORMITEM_ERROR = -1124 , ZW_API_CAM_GETTPATH_ERROR = -1131 , ZW_API_CAM_GETTPATHINFO_ERROR = -1132 , ZW_API_CAM_GETSPDFD_ERROR = -1141
}
the return value of the API interfaces More...
typedef enum evxErrors evxErrors
the return value of the API interfaces

Point/Vector

enum | evxAxisType { VX_AXIS_X = 1 , VX_AXIS_Y = 2 , VX_AXIS_Z = 3 }
type of axis More...
typedef struct svxPoint2 | svxPoint2
2D point
typedef struct svxPoint2f | svxPoint2f
2D point(single precision floating point)
typedef struct svxPoint | svxPoint
3D point
typedef struct svxPointf | svxPointf
3D point (single precision floating point)
typedef struct svxVector2 | svxVector2
2D vector
typedef struct svxVector | svxVector
3D vector
typedef struct svxAxis | svxAxis
3D axis
typedef enum evxAxisType | evxAxisType
type of axis
typedef struct svxTriangle | svxTriangle
3D triangle

Unit

enum evxUnitType {
VX_UNIT_MICRON = 0 , VX_UNIT_MILLIMETER = 1 , VX_UNIT_CENTIMETER = 2 , VX_UNIT_METER = 3 ,
VX_UNIT_INCH = 4 , VX_UNIT_FOOT = 5 , VX_UNIT_YD = 6 , VX_UNIT_DM = 7 ,
VX_UNIT_MIL = 10
}
system of linear units More...
enum | evxMassUnitType { VX_UNIT_GM = 11 , VX_UNIT_KG = 12 , VX_UNIT_OZ = 13 , VX_UNIT_LB = 14 }
system of mass units More...
enum evxDensityUnitType {
VX_UNIT_DEN_KG_M3 = 0 , VX_UNIT_DEN_KG_MM3 = 1 , VX_UNIT_DEN_G_MM3 = 2 , VX_UNIT_DEN_G_CM3 = 3 ,
VX_UNIT_DEN_LB_IN3 = 4 , VX_UNIT_DEN_LB_FT3 = 5 , VX_UNIT_DEN_LB_YD3 = 6 , VX_UNIT_DEN_OZ_IN3 = 7 ,
VX_UNIT_DEN_OZ_FT3 = 8 , VX_UNIT_DEN_OZ_YD3 = 9 , VX_UNIT_DEN_KG_DM3 = 10 , VX_UNIT_DEN_G_DM3 = 11
}
system of density units More...
enum evxMassMomentUnitType {
VX_UNIT_MASSMOMENT_KGMM2 = 0 , VX_UNIT_MASSMOMENT_KGM2 = 1 , VX_UNIT_MASSMOMENT_GMM2 = 2 , VX_UNIT_MASSMOMENT_GCM2 = 3 ,
VX_UNIT_MASSMOMENT_LBIN2 = 4 , VX_UNIT_MASSMOMENT_LBFT2 = 5 , VX_UNIT_MASSMOMENT_LBYD2 = 6 , VX_UNIT_MASSMOMENT_OZIN2 = 7 ,
VX_UNIT_MASSMOMENT_OZFT2 = 8 , VX_UNIT_MASSMOMENT_OZYD2 = 9 , VX_UNIT_MASSMOMENT_KGDM2 = 10 , VX_UNIT_MASSMOMENT_GDM2 = 11
}
system of mass moment units More...
typedef enum evxUnitType | evxUnitType
system of linear units
typedef enum evxMassUnitType | evxMassUnitType
system of mass units
typedef enum evxDensityUnitType | evxDensityUnitType
system of density units
typedef enum evxMassMomentUnitType | evxMassMomentUnitType
system of mass moment units

Matrix

enum evxEulerAngSeq {
VX_XYX = 121 , VX_XZX = 131 , VX_YXY = 212 , VX_YZY = 232 ,
VX_ZXZ = 313 , VX_ZYZ = 323 , VX_RPY = 123 , VX_RYP = 132 ,
VX_PRY = 213 , VX_PYR = 231 , VX_YRP = 312 , VX_YPR = 321
}
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type. More...
typedef struct svxMatrix | svxMatrix
3D transformation matrix or coordinate frame (local to world)
typedef struct svxMatEuler | svxMatEuler
Euler angles and translate vector.
typedef enum evxEulerAngSeq | evxEulerAngSeq
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.

Point On Entity

enum evxGeomCritPnt {
VX_NO_POINT , VX_FREE_POINT = 0 , VX_START_POINT , VX_END_POINT ,
VX_CENTER_POINT , VX_SPLINE_DEFINING_POINT , VX_MIDDLE_POINT , VX_ORIGIN_POINT
}
type of sketch geometry critical point More...
enum | evxDirType { VX_START_DIR , VX_END_DIR , VX_PNT_DIR }
type of direction More...
enum | evxPntLocation { VX_PNT_OUT = -1 , VX_PNT_ON = 0 , VX_PNT_IN = 1 , VX_PNT_NULL = -2 }
point location More...
typedef enum evxGeomCritPnt | evxGeomCritPnt
type of sketch geometry critical point
typedef struct svxPntOnEnt | svxPntOnEnt
point on entity definition, also can use to set a dynamic point
typedef struct svxPntOnEntPath | svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
typedef enum evxDirType | evxDirType
type of direction
typedef struct svxDirOnEntPath | svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
typedef enum evxPntLocation | evxPntLocation
point location

Color

enum evxColor {
VX_COLOR_RGB = -1 , VX_COLOR_NULL = 0 , VX_COLOR_GREEN = 1 , VX_COLOR_RED = 2 ,
VX_COLOR_BROWN = 3 , VX_COLOR_GOLDENROD = 4 , VX_COLOR_MED_BLUE = 5 , VX_COLOR_DARK_MAGENTA = 6 ,
VX_COLOR_DARK_GREY = 7 , VX_COLOR_DARK_BLUE = 8 , VX_COLOR_VIOLET = 9 , VX_COLOR_LIGHT_GREEN = 10 ,
VX_COLOR_LIGHT_BLUE = 11 , VX_COLOR_ROSE = 12 , VX_COLOR_LIGHT_MAGENTA = 13 , VX_COLOR_LIGHT_GREY = 14 ,
VX_COLOR_WHITE = 15 , VX_COLOR_BLACK = 16 , VX_COLOR_YELLOW = 17 , VX_COLOR_MED_GREY = 18 ,
VX_COLOR_PURPLE = 19 , VX_COLOR_STANDARD_LAST = VX_COLOR_PURPLE , VX_COLOR_INDEX_BEGIN , VX_COLOR_INDEX20 = VX_COLOR_INDEX_BEGIN ,
VX_COLOR_INDEX21 , VX_COLOR_INDEX22 , VX_COLOR_INDEX23 , VX_COLOR_INDEX24 ,
VX_COLOR_INDEX25 , VX_COLOR_INDEX26 , VX_COLOR_INDEX27 , VX_COLOR_INDEX28 ,
VX_COLOR_INDEX29 , VX_COLOR_INDEX30 , VX_COLOR_INDEX31 , VX_COLOR_INDEX32 ,
VX_COLOR_INDEX33 , VX_COLOR_INDEX34 , VX_COLOR_INDEX35 , VX_COLOR_INDEX36 ,
VX_COLOR_INDEX37 , VX_COLOR_INDEX38 , VX_COLOR_INDEX39 , VX_COLOR_INDEX40 ,
VX_COLOR_INDEX41 , VX_COLOR_INDEX42 , VX_COLOR_INDEX43 , VX_COLOR_INDEX44 ,
VX_COLOR_INDEX45 , VX_COLOR_INDEX46 , VX_COLOR_INDEX47 , VX_COLOR_INDEX48 ,
VX_COLOR_INDEX49 , VX_COLOR_INDEX50 , VX_COLOR_INDEX51 , VX_COLOR_INDEX52 ,
VX_COLOR_INDEX53 , VX_COLOR_INDEX54 , VX_COLOR_INDEX55 , VX_COLOR_INDEX56 ,
VX_COLOR_INDEX57 , VX_COLOR_INDEX58 , VX_COLOR_INDEX59 , VX_COLOR_INDEX60 ,
VX_COLOR_INDEX61 , VX_COLOR_INDEX62 , VX_COLOR_INDEX63 , VX_COLOR_INDEX64 ,
VX_COLOR_INDEX65 , VX_COLOR_INDEX66 , VX_COLOR_INDEX67 , VX_COLOR_INDEX68 ,
VX_COLOR_INDEX69 , VX_COLOR_INDEX70 , VX_COLOR_INDEX71 , VX_COLOR_INDEX72 ,
VX_COLOR_INDEX73 , VX_COLOR_INDEX74 , VX_COLOR_INDEX75 , VX_COLOR_INDEX76 ,
VX_COLOR_INDEX77 , VX_COLOR_INDEX78 , VX_COLOR_INDEX79 , VX_COLOR_INDEX80 ,
VX_COLOR_INDEX81 , VX_COLOR_INDEX82 , VX_COLOR_INDEX83 , VX_COLOR_INDEX84 ,
VX_COLOR_INDEX85 , VX_COLOR_INDEX86 , VX_COLOR_INDEX87 , VX_COLOR_INDEX88 ,
VX_COLOR_INDEX89 , VX_COLOR_INDEX90 , VX_COLOR_INDEX91 , VX_COLOR_INDEX92 ,
VX_COLOR_INDEX93 , VX_COLOR_INDEX94 , VX_COLOR_INDEX95 , VX_COLOR_INDEX96 ,
VX_COLOR_INDEX97 , VX_COLOR_INDEX98 , VX_COLOR_INDEX99 , VX_COLOR_INDEX100 ,
VX_COLOR_INDEX101 , VX_COLOR_INDEX102 , VX_COLOR_INDEX103 , VX_COLOR_INDEX104 ,
VX_COLOR_INDEX105 , VX_COLOR_INDEX106 , VX_COLOR_INDEX107 , VX_COLOR_INDEX108 ,
VX_COLOR_INDEX109 , VX_COLOR_INDEX110 , VX_COLOR_INDEX111 , VX_COLOR_INDEX112 ,
VX_COLOR_INDEX113 , VX_COLOR_INDEX114 , VX_COLOR_INDEX115 , VX_COLOR_INDEX116 ,
VX_COLOR_INDEX117 , VX_COLOR_INDEX118 , VX_COLOR_INDEX119 , VX_COLOR_INDEX120 ,
VX_COLOR_INDEX121 , VX_COLOR_INDEX122 , VX_COLOR_INDEX123 , VX_COLOR_INDEX124 ,
VX_COLOR_INDEX125 , VX_COLOR_INDEX126 , VX_COLOR_INDEX127 , VX_COLOR_INDEX128 ,
VX_COLOR_INDEX129 , VX_COLOR_INDEX130 , VX_COLOR_INDEX131 , VX_COLOR_INDEX132 ,
VX_COLOR_INDEX133 , VX_COLOR_INDEX134 , VX_COLOR_INDEX135 , VX_COLOR_INDEX136 ,
VX_COLOR_INDEX137 , VX_COLOR_INDEX138 , VX_COLOR_INDEX139 , VX_COLOR_INDEX140 ,
VX_COLOR_INDEX141 , VX_COLOR_INDEX142 , VX_COLOR_INDEX143 , VX_COLOR_INDEX144 ,
VX_COLOR_INDEX145 , VX_COLOR_INDEX146 , VX_COLOR_INDEX147 , VX_COLOR_INDEX148 ,
VX_COLOR_INDEX149 , VX_COLOR_INDEX150 , VX_COLOR_INDEX151 , VX_COLOR_INDEX152 ,
VX_COLOR_INDEX153 , VX_COLOR_INDEX154 , VX_COLOR_INDEX155 , VX_COLOR_INDEX156 ,
VX_COLOR_INDEX157 , VX_COLOR_INDEX158 , VX_COLOR_INDEX159 , VX_COLOR_INDEX160 ,
VX_COLOR_INDEX161 , VX_COLOR_INDEX162 , VX_COLOR_INDEX163 , VX_COLOR_INDEX164 ,
VX_COLOR_INDEX165 , VX_COLOR_INDEX166 , VX_COLOR_INDEX167 , VX_COLOR_INDEX168 ,
VX_COLOR_INDEX169 , VX_COLOR_INDEX170 , VX_COLOR_INDEX171 , VX_COLOR_INDEX172 ,
VX_COLOR_INDEX173 , VX_COLOR_INDEX174 , VX_COLOR_INDEX175 , VX_COLOR_INDEX176 ,
VX_COLOR_INDEX177 , VX_COLOR_INDEX178 , VX_COLOR_INDEX179 , VX_COLOR_INDEX180 ,
VX_COLOR_INDEX181 , VX_COLOR_INDEX182 , VX_COLOR_INDEX183 , VX_COLOR_INDEX184 ,
VX_COLOR_INDEX185 , VX_COLOR_INDEX186 , VX_COLOR_INDEX187 , VX_COLOR_INDEX188 ,
VX_COLOR_INDEX189 , VX_COLOR_INDEX190 , VX_COLOR_INDEX191 , VX_COLOR_INDEX192 ,
VX_COLOR_INDEX193 , VX_COLOR_INDEX194 , VX_COLOR_INDEX195 , VX_COLOR_INDEX196 ,
VX_COLOR_INDEX197 , VX_COLOR_INDEX198 , VX_COLOR_INDEX199 , VX_COLOR_INDEX200 ,
VX_COLOR_INDEX201 , VX_COLOR_INDEX202 , VX_COLOR_INDEX203 , VX_COLOR_INDEX204 ,
VX_COLOR_INDEX205 , VX_COLOR_INDEX206 , VX_COLOR_INDEX207 , VX_COLOR_INDEX208 ,
VX_COLOR_INDEX209 , VX_COLOR_INDEX210 , VX_COLOR_INDEX211 , VX_COLOR_INDEX212 ,
VX_COLOR_INDEX213 , VX_COLOR_INDEX214 , VX_COLOR_INDEX215 , VX_COLOR_INDEX216 ,
VX_COLOR_INDEX217 , VX_COLOR_INDEX218 , VX_COLOR_INDEX219 , VX_COLOR_INDEX220 ,
VX_COLOR_INDEX221 , VX_COLOR_INDEX222 , VX_COLOR_INDEX223 , VX_COLOR_INDEX224 ,
VX_COLOR_INDEX225 , VX_COLOR_INDEX226 , VX_COLOR_INDEX227 , VX_COLOR_INDEX228 ,
VX_COLOR_INDEX229 , VX_COLOR_INDEX230 , VX_COLOR_INDEX231 , VX_COLOR_INDEX232 ,
VX_COLOR_INDEX233 , VX_COLOR_INDEX234 , VX_COLOR_INDEX235 , VX_COLOR_INDEX236 ,
VX_COLOR_INDEX237 , VX_COLOR_INDEX238 , VX_COLOR_INDEX239 , VX_COLOR_INDEX240 ,
VX_COLOR_INDEX241 , VX_COLOR_INDEX242 , VX_COLOR_INDEX243 , VX_COLOR_INDEX244 ,
VX_COLOR_INDEX_LAST = VX_COLOR_INDEX244 , VX_COLOR_LAST
}
standard colors + index colors (see cvxColorRGB() for RGB color components) More...
enum | evxColorAppFlag { VX_COLOR_BYLAYER = 253 }
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for the detail view More...
typedef struct svxColor | svxColor
RGB color (each component defined over 0 to 255)
typedef struct svxColorf | svxColorf
RGB color (floating point components defined over 0.0 to 1.0)
typedef enum evxColor | evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
typedef enum evxColorAppFlag | evxColorAppFlag
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for the detail view

Entity

enum evxEntType {
VX_ENT_BREP = -4 , VX_ENT_OP = -3 , VX_ENT_POINT = -2 , VX_ENT_WIRE = -1 ,
VX_ENT_ALL = 0 , VX_ENT_SHAPE = 42 , VX_ENT_FACE = 43 , VX_ENT_EDGE = 46 ,
VX_ENT_FTR = 48 , VX_ENT_NRB_CRV = 54 , VX_ENT_LINE3 = 56 , VX_ENT_LINE2 = 58 ,
VX_ENT_CIRCLE3 = 60 , VX_ENT_CIRCLE2 = 61 , VX_ENT_ARC3 = 62 , VX_ENT_ARC2 = 63 ,
VX_ENT_POINT3 = 64 , VX_ENT_POINT2 = 65 , VX_ENT_LAYER = 67 , VX_ENT_SKETCH = 70 ,
VX_ENT_REF_GEOM = 72 , VX_ENT_TEXT = 76 , VX_ENT_DIMEN = 77 , VX_ENT_ANNO = 83 ,
VX_ENT_BLOCK = 86 , VX_ENT_DWG_VIEW = 87 , VX_ENT_COMP = 88 , VX_ENT_PART = 89 ,
VX_ENT_SHEET = 90 , VX_ENT_PACKET = 91 , VX_ENT_DATUM = 95 , VX_ENT_CRV_LIST = 102 ,
VX_ENT_PART_LINE = 106 , VX_ENT_HATCH = 111 , VX_ENT_LIGHT = 118 , VX_ENT_INT_CRV = 119 ,
VX_ENT_VAR = 120 , VX_ENT_EQN_SET = 121 , VX_ENT_SYMBOL = 123 , VX_ENT_TRACE = 133 ,
VX_ENT_TABLE = 144 , VX_ENT_VBREAKLINE = 182 , VX_ENT_RDTXT = 185 , VX_ENT_BALLOON = 168 ,
VX_ENT_DRAWING = 169 , VX_ENT_PMIENT = 190 , VX_ENT_BLOCK2D = 197 , VX_ENT_BLKREF = 198 ,
VX_ENT_AXIS = 311 , VX_ENT_CSYS = 312 , VX_ENT_AXIS_2D = 313
}
entity types More...
enum evxEntFind {
VX_FIND_POINT = 1 , VX_FIND_CURVE = 2 , VX_FIND_EDGE = 3 , VX_FIND_WIRE = 4 ,
VX_FIND_FACE = 5 , VX_FIND_SKETCH = 6 , VX_FIND_CRV_LIST = 7 , VX_FIND_SKETCH_OR_CRV_LIST = 8 ,
VX_FIND_PROFILE = 9 , VX_FIND_EDGE_OR_CRV = 10 , VX_FIND_3D_BLOCK = 14 , VX_FIND_DIM = 15
}
entity search types More...
enum evxFindRule {
VX_STOP_FACE_FILLET = 0x00000001 , VX_STOP_EDGE_INNER_LOOP = 0x00000002 , VX_STOP_CONVEX_FLLT = 0x00000004 , VX_STOP_CONCAVE_FLLT = 0x00000008 ,
VX_STOP_CONVEX_EDGE = 0x00000010 , VX_STOP_CONCAVE_EDGE = 0x00000020 , VX_STOP_ADJACENCY_LEVEL = 0x00000040 , VX_STOP_BOUNDARY_FACE = 0x00000080 ,
VX_FIND_COAXIAL = 0x00000001 , VX_FIND_TANGENT = 0x00000002 , VX_FIND_COPLANAR = 0x00000004 , VX_FIND_COPL_AXES = 0x00000008 ,
VX_FIND_EQU_RAD = 0x00000010 , VX_FIND_SYMMETRIC = 0x00000020 , VX_FIND_OFFSET = 0x00000040
}
face search rules More...
enum | evxEdgeType { VX_EDGE_UNKNOWN = -1 , VX_EDGE_STANDARD = 0 , VX_EDGE_SEAM = 1 , VX_EDGE_DEGEN = 2 }
type of edge More...
typedef enum evxEntType | evxEntType
entity types
typedef struct svxEntPick | svxEntPick
entity pick (includes optional parent entity)
typedef struct svxUid | svxUid
entity unique identifier
typedef enum evxEntFind | evxEntFind
entity search types
typedef struct svxEntFind | svxEntFind
entity search data
typedef enum evxFindRule | evxFindRule
face search rules
typedef enum evxEdgeType | evxEdgeType
type of edge

Variable

enum | evxVarType { VX_VAR_NUM = 0 , VX_VAR_STR = 1 , VX_VAR_PNT = 2 , VX_VAR_VEC = 3 }
variable types More...
enum evxVarNumType {
VX_VAR_CONS = 0 , VX_VAR_DST = 1 , VX_VAR_ANG = 2 , VX_VAR_MASS = 3 ,
VX_VAR_DENSITY = 4 , VX_VAR_AREA = 5 , VX_VAR_VOLUME = 6 , VX_VAR_MASS_MOMENT = 7
}
sub types of numeric variable More...
typedef enum evxVarType | evxVarType
variable types
typedef enum evxVarNumType | evxVarNumType
sub types of numeric variable
typedef struct svxVariable | svxVariable
numeric variable

Wire Attribute

enum evxViewLineAttrIdx {
VX_VIS_LINE_ATTR = 0 , VX_HID_LINE_ATTR = 1 , VX_TAN_LINE_ATTR = 2 , VX_SECT_LINE_ATTR = 3 ,
VX_DET_LINE_ATTR = 4 , VX_CENT_LINE_ATTR = 5 , VX_THRD_LINE_ATTR = 6 , VX_VIEW_LINE_ATTR = 7 ,
VX_WIRE_LINE_ATTR = 8 , VX_TAN_HID_LINE_ATTR = 9 , VX_WIRE_HID_LINE_ATTR = 10 , VX_CENT_HID_LINE_ATTR = 11 ,
VX_THRD_HID_LINE_ATTR = 12 , VX_BEND_LINE_ATTR = 13 , VX_BEND_HID_LINE_ATTR = 14 , VX_THRD_END_LINE_ATTR = 15 ,
VX_THRD_END_HID_LINE_ATTR = 16 , VX_CROP_LINE_ATTR = 17
}
line type ids for view attribute line types More...
typedef enum evxViewLineAttrIdx | evxViewLineAttrIdx
line type ids for view attribute line types
typedef struct svxWireAt | svxWireAt
wire display attributes

Text Attribute

enum evxTextureOpt {
V_TEXTURE_NULL = 0 , V_TEXTURE_BLEND = 1 , V_TEXTURE_DECAL = 2 , V_TEXTURE_MODULATE = 3 ,
V_TEXTURE_REPLACE = 4
}
texture map option More...
enum evxTextureLoc {
V_TEXTURE_LOWER_LEFT = 0 , V_TEXTURE_UPPER_LEFT = 1 , V_TEXTURE_UPPER_RIGHT = 2 , V_TEXTURE_LOWER_RIGHT = 3 ,
V_TEXTURE_CENTER = 4
}
texture map origin point with respect to texture map rectangle More...
typedef enum evxTextureOpt | evxTextureOpt
texture map option
typedef enum evxTextureLoc | evxTextureLoc
texture map origin point with respect to texture map rectangle
typedef struct svxTextureAt | svxTextureAt
texture attribute
typedef struct svxTextAt | svxTextAt
text attribute

Part Attribute

enum evxAtItemId {
VX_AT_USER = 0 , VX_AT_NAME = 1 , VX_AT_NUMBER = 2 , VX_AT_CLASS ,
VX_AT_DESIGNER , VX_AT_COST , VX_AT_SUPPLIER , VX_AT_DESCRIPT ,
VX_AT_KEYWORD , VX_AT_MANAGER , VX_AT_MATERIAL , VX_AT_START ,
VX_AT_END , VX_AT_DERIVED , VX_AT_NO_SECTION , VX_AT_NO_HATCH ,
VX_AT_NO_BOM , VX_AT_NO_ROOTSHOW , VX_AT_DENSITY = 18 , VX_AT_FILEPATH = 20 ,
VX_AT_SHEETPATH = 21 , VX_AT_CAMPATH = 22 , VX_AT_SHEETCODE = 23 , VX_AT_AREA = 25 ,
VX_AT_VOLUME = 26 , VX_AT_MASS = 27 , VX_AT_LENGTH = 28 , VX_AT_WIDTH = 29 ,
VX_AT_HEIGHT = 30 , VX_AT_STOCK_SIZE = 43 , VX_AT_REVISION = 47 , VX_AT_SHEET_SCALE = 200 ,
VX_AT_SHEET_SEQUENCE = 201 , VX_AT_SHEET_AMOUNT , VX_AT_SHEET_SIZE , VX_AT_SHEET_PROJECTION ,
VX_AT_SHEET_FILEPATH
}
standard id of attribute item More...
enum evxAttributeType {
VX_ATTR_STRING = 0 , VX_ATTR_BOOL = 1 , VX_ATTR_INT = 2 , VX_ATTR_REAL = 3 ,
VX_ATTR_DATE = 4
}
attribute data type More...
enum evxDateFormat {
VX_DATE_FROMAT_SHORT = 0 , VX_DATE_FROMAT_LONG = 1 , VX_DATE_FROMAT1 = 2 , VX_DATE_FROMAT2 = 3 ,
VX_DATE_FROMAT3 = 4 , VX_DATE_FROMAT4 = 5 , VX_DATE_FROMAT5 = 6 , VX_DATE_FROMAT6 = 7
}
date attribute format More...
typedef enum evxAtItemId | evxAtItemId
standard id of attribute item
typedef enum evxAttributeType | evxAttributeType
attribute data type
typedef enum evxDateFormat | evxDateFormat
date attribute format
typedef struct svxAttribute | svxAttribute
standard attribute data
typedef struct svxPartAttribute | svxPartAttribute
part attribute structure

Line Attribute

enum evxLineWidth {
VX_WIDTH_UNDEFINED , VX_WIDTH_018 , VX_WIDTH_025 , VX_WIDTH_035 ,
VX_WIDTH_050 , VX_WIDTH_070 , VX_WIDTH_100 , VX_WIDTH_BYLAYER = 0xFF
}
line width More...
typedef struct svxLineAt | svxLineAt
Line attributes.
typedef enum evxLineWidth | evxLineWidth
line width

Command Input Data

enum evxNumType {
VX_NUM_UNDEFINED = -1 , VX_NUM_NULL = 0 , VX_NUM_TO_FACE = 1 , VX_NUM_FACE_BND = 2 ,
VX_NUM_TO_PNT = 3 , VX_NUM_THRU_PLUS = 4 , VX_NUM_THRU_MINUS = 5 , VX_NUM_CURVE_BND = 6 ,
VX_NUM_DATA = 7 , VX_UNDEF = 0 , VX_NUM = 1 , VX_DST = 2 ,
VX_ANG = 3 , VX_MASS = 4 , VX_DENSITY = 5 , VX_AREA = 6 ,
VX_VOLUME = 7 , VX_MASS_MOMENT = 8
}
numeric input data types More...
enum evxPntType {
VX_PNT3_ABS = 0 , VX_PNT3_ENT = 1 , VX_PNT3_ON = 2 , VX_PNT3_TO = 3 ,
VX_PNT3_MID = 4 , VX_PNT3_NUM = 5 , VX_PNT3_DST = 6 , VX_PNT3_ANG = 7 ,
VX_PNT3_TAN = 8 , VX_PNT3_FRAC = 9 , VX_PNT3_REL = 10 , VX_PNT3_DATA = 11 ,
VX_PNT3_ABS_COMP = 12
}
point input data types More...
enum | evxAngUnitType { VX_UNIT_DEG = 8 , VX_UNIT_RAD = 9 }
system of angle units More...
typedef enum evxNumType | evxNumType
numeric input data types
typedef enum evxPntType | evxPntType
point input data types
typedef enum evxAngUnitType | evxAngUnitType
system of angle units
typedef struct svxData | svxData
command input data item

Curve Data

enum evxCurveType {
VX_CRV_UNDEFINED = 0 , VX_CRV_LINE = 1 , VX_CRV_ARC = 2 , VX_CRV_CIRCLE = 3 ,
VX_CRV_NURB = 4
}
curve types More...
typedef enum evxCurveType | evxCurveType
curve types
typedef struct svxParameters | svxParameters
curve parameter space data
typedef struct svxControlPoints | svxControlPoints
curve control point data
typedef struct svxCrvContinuityData | svxCrvContinuityData
data of curve continuity.
typedef struct svxCrvContinuityTolList | svxCrvContinuityTolList
curve continuity tolerance list
typedef struct svxCurve | svxCurve
2D or 3D curvilinear geometry

Surface Data

enum evxSurfaceType {
VX_SRF_PLANE , VX_SRF_SPHERE , VX_SRF_CONE , VX_SRF_GRID ,
VX_SRF_CYLINDER , VX_SRF_EXTRUDE , VX_SRF_REVOLVE , VX_SRF_SWEEP_NOT_USED ,
VX_SRF_GEN , VX_SRF_OFFSET , VX_SRF_MESH , VX_SRF_RULED ,
VX_SRF_HEMIS , VX_SRF_FRUSTRUM , VX_SRF_DRAFT , VX_SRF_DRAFT_NPLN ,
VX_SRF_DRAFT_NUV , VX_SRF_ELLIPSOID , VX_SRF_3PT_PLANE , VX_SRF_BILIN_CNVX ,
VX_SRF_EXTRUDE_DRFT , VX_SRF_REVOLVE_PLN , VX_SRF_TORUS , VX_SRF_SMD_THCK_FC ,
VX_SRF_BEND_GEN , VX_SRF_PLANE_STAT_FC , VX_SRF_GEN_STAT_FC , VX_SRF_CIR_OFF ,
VX_SRF_VAR_OFF , VX_SRF_THRD_THDFC , VX_SRF_THRD_NTHDFC , VX_SRF_THRD_CONFC
}
surface types More...
enum evxSrfPrimType {
VX_SF_PRIM_PLN , VX_SF_PRIM_SPH , VX_SF_PRIM_CON , VX_SF_PRIM_CYL ,
VX_SF_PRIM_NURB , VX_SF_PRIM_ELLSO , VX_SF_PRIM_TORUS
}
3D NURB surface type More...
typedef enum evxSurfaceType | evxSurfaceType
surface types
typedef struct svxSurface | svxSurface
3D NURB surface (untrimmed)
typedef enum evxSrfPrimType | evxSrfPrimType
3D NURB surface type
typedef struct svxPlane | svxPlane
data of plane
typedef struct svxSphere | svxSphere
spherical surface data
typedef struct svxCone | svxCone
conical surface data
typedef struct svxCylinder | svxCylinder
cylindrical surface data
typedef struct svxTorus | svxTorus
circular surface data
typedef struct svxEllipsoid | svxEllipsoid
ellipsoid surface data
typedef struct svxSrfPrim | svxSrfPrim
3D NURB surface data

Dimension

enum evxDimType {
VX_DIM_LINEAR = 1 , VX_DIM_BASELINE = 2 , VX_DIM_CONTINUOUS = 3 , VX_DIM_ORDINATE = 4 ,
VX_DIM_LINEAR_OFFSET = 5 , VX_DIM_LINEAR_CHAMFER = 6 , VX_DIM_ANGULAR = 7 , VX_DIM_RADIAL_DIAMETRIC = 8 ,
VX_DIM_ARC_LENGTH = 9 , VX_DIM_SYMMETRY , VX_DIM_HLCALL , VX_DIM_LABEL ,
VX_DIM_BALLOON , VX_DIM_DATUMF , VX_DIM_DATUMT , VX_DIM_FCS ,
VX_DIM_CLCM , VX_DIM_INTERSYM , VX_DIM_LAST
}
dimension type More...
enum evxDimTypeEx {
VX_DIM_EX_FIRST = 0 , VX_DIM_EX_LH = 1 , VX_DIM_EX_LV = 5 , VX_DIM_EX_LA = 9 ,
VX_DIM_EX_LR = 13 , VX_DIM_EX_LP = 17 , VX_DIM_EX_LHB = 2 , VX_DIM_EX_LVB = 6 ,
VX_DIM_EX_LAB = 10 , VX_DIM_EX_LRB = 14 , VX_DIM_EX_LPB = 18 , VX_DIM_EX_LHC = 3 ,
VX_DIM_EX_LVC = 7 , VX_DIM_EX_LAC = 11 , VX_DIM_EX_LRC = 15 , VX_DIM_EX_LPC = 19 ,
VX_DIM_EX_LHO = 4 , VX_DIM_EX_LVO = 8 , VX_DIM_EX_LAO = 12 , VX_DIM_EX_LRO = 16 ,
VX_DIM_EX_LPO = 20 , VX_DIM_EX_LHVO = 88 , VX_DIM_EX_LO = 21 , VX_DIM_EX_LOS = 25 ,
VX_DIM_EX_LSY = 90 , VX_DIM_EX_ASY = 93 , VX_DIM_EX_LCHV = 26 , VX_DIM_EX_LCA = 29 ,
VX_DIM_EX_LCL = 30 , VX_DIM_EX_LCLP = 80 , VX_DIM_EX_LCLA = 83 , VX_DIM_EX_ANG = 48 ,
VX_DIM_EX_ANGH = 52 , VX_DIM_EX_ANGV = 56 , VX_DIM_EX_ANGA = 60 , VX_DIM_EX_ANG3PT = 74 ,
VX_DIM_EX_RAD = 31 , VX_DIM_EX_RADBG = 35 , VX_DIM_EX_RADBK = 39 , VX_DIM_EX_DIA = 44 ,
VX_DIM_EX_RADL = 76 , VX_DIM_EX_GDH = 70 , VX_DIM_EX_GDV = 71 , VX_DIM_EX_GDHS = 77 ,
VX_DIM_EX_GDVS = 78 , VX_DIM_EX_GDL = 81 , VX_DIM_EX_GDLS = 82 , VX_DIM_EX_GDTP = 72 ,
VX_DIM_EX_GDTC = 73 , VX_DIM_EX_GDTR = 84 , VX_DIM_EX_GDTL = 85 , VX_DIM_EX_LOB = 22 ,
VX_DIM_EX_LOC = 23 , VX_DIM_EX_LOO = 24 , VX_DIM_EX_LCH = 27 , VX_DIM_EX_LCV = 28 ,
VX_DIM_EX_RADB = 32 , VX_DIM_EX_RADC = 33 , VX_DIM_EX_RADO = 34 , VX_DIM_EX_RADBGB = 36 ,
VX_DIM_EX_RADBGC = 37 , VX_DIM_EX_RADBGO = 38 , VX_DIM_EX_RADBKB = 40 , VX_DIM_EX_RADBKC = 41 ,
VX_DIM_EX_RADBKO = 42 , VX_DIM_EX_RADS = 43 , VX_DIM_EX_DIAB = 45 , VX_DIM_EX_DIAC = 46 ,
VX_DIM_EX_DIAO = 47 , VX_DIM_EX_ANGB = 49 , VX_DIM_EX_ANGC = 50 , VX_DIM_EX_ANGO = 51 ,
VX_DIM_EX_ANGHB = 53 , VX_DIM_EX_ANGHC = 54 , VX_DIM_EX_ANGHO = 55 , VX_DIM_EX_ANGVB = 57 ,
VX_DIM_EX_ANGVC = 58 , VX_DIM_EX_ANGVO = 59 , VX_DIM_EX_ANGAB = 61 , VX_DIM_EX_ANGAC = 62 ,
VX_DIM_EX_ANGAO = 63 , VX_DIM_EX_LEAD = 64 , VX_DIM_EX_BALL = 65 , VX_DIM_EX_CM = 66 ,
VX_DIM_EX_GF = 67 , VX_DIM_EX_GFL = 68 , VX_DIM_EX_GFP = 69 , VX_DIM_EX_LCLS = 75 ,
VX_DIM_EX_CLC = 79 , VX_DIM_EX_CLBS = 86 , VX_DIM_EX_ARCL = 87 , VX_DIM_EX_INTSYM = 89 ,
VX_DIM_EX_LORD = 91 , VX_DIM_EX_DPLS = 92 , VX_DIM_EX_CRVL = 94 , VX_DIM_EX_RHO = 95 ,
VX_DIM_EX_CRVL3D = 96 , VX_DIM_EX_ELEV = 97 , VX_DIM_EX_AUTO_LSY = 98 , VX_DIM_EX_LAST = 99
}
dimension type, more detailed than evxDimType More...
enum | evxDimLineMode { VX_DIM_LINE_MODE_B = 2 , VX_DIM_LINE_MODE_C = 3 , VX_DIM_LINE_MODE_O = 4 }
dimension Line Mode More...
enum evxDimState {
VX_DM_REVISION = -4 , VX_DM_NOSCALE = -3 , VX_DM_MODIFIED = -2 , VX_DM_DANGLING = -1 ,
VX_DM_NORMAL = 0 , VX_DM_IN_OBJ = 1
}
dimension state More...
enum evxFCSSymbol {
VX_FCSSYM_NONE = 0 , VX_FCSSYM_STRAIGHTNESS , VX_FCSSYM_FLATNESS , VX_FCSSYM_CIRCULARITY ,
VX_FCSSYM_CYLINDRICITY , VX_FCSSYM_PARALLELISM , VX_FCSSYM_PERPENDICULARITY , VX_FCSSYM_ANGULARITY ,
VX_FCSSYM_POSITION , VX_FCSSYM_CONCENTRICITY , VX_FCSSYM_SYMMETRY , VX_FCSSYM_PROFILE_OF_LINE ,
VX_FCSSYM_PROFILE_OF_SURFACE , VX_FCSSYM_CIRCULAR_RUNOUT , VX_FCSSYM_TOTAL_RUNOUT
}
FCS MD&T symbol. More...
enum | evxFCSShapeSym { VX_SHP_NONE = 0 , VX_SHP_DIAMETER , VX_SHP_SPHERICAL_DIA , VX_SHP_SQUARE }
FCS area shape symbol. More...
enum | evxFCSLmsOption { VX_LMS_NONE = 0 , VX_LMS_MAX_MATERIAL , VX_LMS_MIN_MATERIAL , VX_LMS_FTR_SIZE_REGARDLESS }
FCS LMS option. More...
enum evxTermType {
VX_TERM_OFF = 0 , VX_TERM_ARROW_15 = 1 , VX_TERM_ARROW_30 , VX_TERM_ARROW_60 ,
VX_TERM_ARROW_H15 , VX_TERM_ARROW_H30 , VX_TERM_ARROW_H60 , VX_TERM_ARROW_HF15 ,
VX_TERM_ARROW_HF30 , VX_TERM_ARROW_HF60 , VX_TERM_TICK , VX_TERM_DOT ,
VX_TERM_DOTF
}
terminator types More...
enum evxHoleDimDataItem {
VX_HOLE_DIM_ITEM_ORG , VX_HOLE_DIM_ITEM_QTY , VX_HOLE_DIM_ITEM_DIA , VX_HOLE_DIM_ITEM_DIA2 ,
VX_HOLE_DIM_ITEM_LABEL , VX_HOLE_DIM_ITEM_DPTH , VX_HOLE_DIM_ITEM_DPTH2 , VX_HOLE_DIM_ITEM_ANG ,
VX_HOLE_DIM_ITEM_THRD_DIA , VX_HOLE_DIM_ITEM_THRD_DPTH , VX_HOLE_DIM_ITEM_PITCH , VX_HOLE_DIM_THRD_STD ,
VX_HOLE_DIM_THRD_SIZ
}
data sub-items of hole dimension More...
typedef enum evxDimType | evxDimType
dimension type
typedef enum evxDimTypeEx | evxDimTypeEx
dimension type, more detailed than evxDimType
typedef enum evxDimLineMode | evxDimLineMode
dimension Line Mode
typedef enum evxDimState | evxDimState
dimension state
typedef enum evxFCSSymbol | evxFCSSymbol
FCS MD&T symbol.
typedef enum evxFCSShapeSym | evxFCSShapeSym
FCS area shape symbol.
typedef enum evxFCSLmsOption | evxFCSLmsOption
FCS LMS option.
typedef struct svxFCSTol | svxFCSTol
FCS tolerance data.
typedef struct svxFCSDatum | svxFCSDatum
FCS datum data.
typedef struct svxFCSData | svxFCSData
FCS data.
typedef enum evxTermType | evxTermType
terminator types
typedef enum evxHoleDimDataItem | evxHoleDimDataItem
data sub-items of hole dimension
typedef struct svxDimAttr | svxDimAttr
Dimension attributes structure.

Curve/Surface Extension Options

enum | evxExtendOpt { VX_EXTEND_UNDEFINED = 0 , VX_EXTEND_LINEAR = 1 , VX_EXTEND_CIRCULAR = 2 , VX_EXTEND_REFLECT = 3 }
curve/surface extension options More...
typedef enum evxExtendOpt | evxExtendOpt
curve/surface extension options

2D/3D Curve Data

enum evxFairingType {
VX_FAIRING_NONE = 0 , VX_FAIRING_ENERGY = 1 , VX_FAIRING_VARIATION = 2 , VX_FAIRING_JERK = 3 ,
VX_FAIRING_BEND = 4 , VX_FAIRING_TENSION = 5
}
fairing modes More...
enum | evxContinuityTyp { VX_CONTIN_NONE = 0 , VX_CONTIN_G1 = 1 , VX_CONTIN_G2 = 2 , VX_CONTIN_G3 = 3 }
Continuity option. More...
enum evxPlacingType {
VX_PLACING_NONE = -1 , VX_PLACING_VIEW = 0 , VX_PLACING_VECTOR = 1 , VX_PLACING_WCS = 2 ,
VX_PLACING_PLANE = 3
}
placing adjustment type More...
typedef enum evxFairingType | evxFairingType
fairing modes
typedef struct svxCrvIntData | svxCrvIntData
2D/3D interpolated curve
typedef enum evxContinuityTyp | evxContinuityTyp
Continuity option.
typedef struct svxSplinePnt | svxSplinePnt
Spline point.
typedef enum evxPlacingType | evxPlacingType
placing adjustment type
typedef struct svxSplineData | svxSplineData
Spline command data.

View Data

enum evxViewStd {
VX_VIEW_FRONT = 0 , VX_VIEW_BACK = 1 , VX_VIEW_TOP = 2 , VX_VIEW_BOTTOM = 3 ,
VX_VIEW_RIGHT = 4 , VX_VIEW_LEFT = 5 , VX_VIEW_ISO = 6 , VX_VIEW_AUX = 7 ,
VX_VIEW_PLANE = 8
}
standard 3D view orientations More...
typedef struct svxView | svxView
view data(Z3PRT,Z3ASM)
typedef enum evxViewStd | evxViewStd
standard 3D view orientations

ZW3D environment

enum evxEnvironment {
VX_ENV_Z3FILE = 2 , VX_ENV_SKETCH , VX_ENV_SHEET , VX_ENV_PACKET ,
VX_ENV_CAM , VX_ENV_ANIMATION , VX_ENV_EXPLODEDVIEW , VX_ENV_3DSKETCH ,
VX_ENV_PART , VX_ENV_ECAD_PART , VX_ENV_ECAD_ASSEMBLY , VX_ENV_ASSEMBLY ,
VX_ENV_PIPING
}
zw3d environment More...
typedef enum evxEnvironment evxEnvironment
zw3d environment

Cam Data

enum | evxCmAttrValueType { ZW_CAM_ATTR_VALUE_TYPE_INVALID = -1 , ZW_CAM_ATTR_VALUE_TYPE_INTEGER = 0 , ZW_CAM_ATTR_VALUE_TYPE_DOUBLE , ZW_CAM_ATTR_VALUE_TYPE_STRING }
cam data attribute type More...
enum evxCmPlanDispMode {
CM_ACTIVE_LOCK = 0 , CM_ACTIVE_PART = 1 , CM_ACTIVE_PROCESS = 2 , CM_ACTIVE_SETUP = 3 ,
CM_ACTIVE_TOOLPATH = 4 , CM_ACTIVE_MACHINE = 5 , CM_ACTIVE_TOOL = 6 , CM_ACTIVE_TACTIC = 7 ,
CM_ACTIVE_SPDFD = 8 , CM_ACTIVE_CMCOMP = 9 , CM_ACTIVE_FTRGRP = 10 , CM_ACTIVE_FTRSET = 11 ,
CM_ACTIVE_NEST = 12 , CM_ACTIVE_WIZARD = 13 , CM_ACTIVE_PUNCH = 14 , CM_ACTIVE_HOLDER = 15
}
cam plan display mode More...
enum | evxCmTreeType { CM_TREE_OP = 0 , CM_TREE_COMP = 1 , CM_TREE_FLD = 2 , CM_TREE_FTR = 3 }
cam tree type More...
typedef enum evxCmAttrValueType | evxCmAttrValueType
cam data attribute type
typedef struct svxCmAttrValue | svxCmAttrValue
cam data attribute value
typedef enum evxCmPlanDispMode | evxCmPlanDispMode
cam plan display mode
typedef enum evxCmTreeType | evxCmTreeType
cam tree type

Basic String Types

typedef char | vxName[32]
object name (null-terminated text string) More...
typedef char | vxLongName[256]
long object name (null-terminated text string) More...
typedef char | vxPath[256]
file path or file name (null-terminated text string) More...
typedef char | vxRootName[256]
root object name (null-terminated text string) More...
typedef char | vxExp[256]
arithmetic expression (null-terminated text string) More...
typedef char | vxVarExp[1024]
variable expression (null-terminated text string) More...
typedef char | vxLongPath[512]
file path or file name (null-terminated text string) More...

Basic Integer Types

typedef unsigned int vxUint32
32 bit unsigned integer More...

Entity Pick Path

typedef struct svxEntPath | svxEntPath
entity pick path(sync with VsPickPath)
#define | V_PP_LEN 400
maximum length of a non-persistent (i.e. evaluated) pick path More...

Limits/3D Bounding Box

typedef struct svxLimit | svxLimit
limits
typedef struct svxBndBox | svxBndBox
3D bounding box

Face Attribute

typedef struct svxFaceAt svxFaceAt
face display attributes

Profile Attribute

typedef struct svxPrfAreaProp svxPrfAreaProp
profile area property

Facets

typedef struct svxShaderAt | svxShaderAt
shader attribute
typedef struct svxFacets | svxFacets
3D facets defined by triangle strips

Component Info

typedef struct svxCompName svxCompName
brief component info
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: V_PP_LEN

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ V_PP_LEN

#define V_PP_LEN 400

#include <zwapi_util.h>

maximum length of a non-persistent (i.e. evaluated) pick path

Definition at line 260 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: VX_API_VERSION

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ VX_API_VERSION

#define VX_API_VERSION 2800

#include <zwapi_util.h>

API version number.

Definition at line 25 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxExp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxExp

typedef char vxExp[256]

#include <zwapi_util.h>

arithmetic expression (null-terminated text string)

Definition at line 228 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxLongName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxLongName

typedef char vxLongName[256]

#include <zwapi_util.h>

long object name (null-terminated text string)

Examples
drawing\dwgDimTest.cpp, drawing\dwgTableTest.cpp, part\partUtils.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 209 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxLongPath

typedef char vxLongPath[512]

#include <zwapi_util.h>

file path or file name (null-terminated text string)

Examples
drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\smdFtrCrtTest.cpp.

Definition at line 240 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxName

typedef char vxName[32]

#include <zwapi_util.h>

object name (null-terminated text string)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 202 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxPath

typedef char vxPath[256]

#include <zwapi_util.h>

file path or file name (null-terminated text string)

Definition at line 216 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxRootName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxRootName

typedef char vxRootName[256]

#include <zwapi_util.h>

root object name (null-terminated text string)

Definition at line 222 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxUint32

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxUint32

typedef unsigned int vxUint32

#include <zwapi_util.h>

32 bit unsigned integer

Definition at line 250 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: vxVarExp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ vxVarExp

typedef char vxVarExp[1024]

#include <zwapi_util.h>

variable expression (null-terminated text string)

Definition at line 234 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Variable Common API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Variable Common API
Common

Detailed Description

THE MODULE FOR THE ZW3D Variable API Note – The common functions of variable are defined in this header file.

Equations Edit Data

enum | evxEqnSetOpt { VX_EQN_MANUAL_SET_EQN = 0 , VX_EQN_AUTO_OVERWRITE_ALL_EQN = 1 , VX_EQN_AUTO_NEW_ALL_EQN = 2 , VX_EQN_AUTO_CANCEL_ALL_EQN = -1 }
equation set option More...
typedef enum evxEqnSetOpt | evxEqnSetOpt
equation set option

Equation Query

evxErrors | cvxPartInqEqnSetMembers (int idSet, int *count, int **idList)
evxErrors | cvxPartInqEqnAssociatedSet (int idEqn, int *idSet)
evxErrors | cvxEqGetExpByName (char *name, char *exp, int size)
evxErrors | cvxEqGetDescById (int idEqn, char *desc, int size)
evxErrors | cvxEqSetDescById (int idEqn, char *desc)

Equation Edit

evxErrors | cvxPartVarSubstitute (char *Str, int nBytes, int *Truncated)
evxErrors | cvxPartVarSubstituteResize (char **Str)
evxErrors | cvxEqLoadFile (const vxLongPath fullpath, evxEqnSetOpt option)
evxErrors | cvxEqRegen (int idEqn)
evxErrors | cvxPartEqnDelete (int idEqn)
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxEqGetDescById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxEqGetDescById()

evxErrors cvxEqGetDescById | ( | int | idEqn,
 |  | char * | desc,
 |  | int | size
 | ) |  |

#include <zwapi_var.h>

Looking for an equation object(VEQ) whose variable id matches the input id.
Output description of the equation object with variable "desc".

Parameters
[in] | idEqn | object id
[in,out] | desc | output of description
[in] | size | size of description
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxEqGetExpByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxEqGetExpByName()

evxErrors cvxEqGetExpByName | ( | char * | name,
 |  | char * | exp,
 |  | int | size
 | ) |  |

#include <zwapi_var.h>

Looking for an equation object(VEQ) whose variable name matches the input name.
Output expression of the equation object with variable "exp".

Parameters
[in] | name | object name
[in,out] | exp | output of expression
[in] | size | size of expression
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_OBJ_DATE_GET_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxEqLoadFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxEqLoadFile()

evxErrors cvxEqLoadFile | ( | const vxLongPath | fullpath,
 |  | evxEqnSetOpt | option
 | ) |  |

#include <zwapi_var.h>

Use this function to add equations by importing excel.

Parameters
[in] | fullpath | fullpath of excel to import
[in] | option | option of equation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_FORM_CREATE_FAIL
  • ZW_API_FORM_SHOW_FAIL
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxEqRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxEqRegen()

evxErrors cvxEqRegen ( int idEqn )

#include <zwapi_var.h>

Regenerate all/specified equations.

Parameters
[in] idEqn -1 to regen all equation; equation id to regen specified equation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxEqSetDescById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxEqSetDescById()

evxErrors cvxEqSetDescById | ( | int | idEqn,
 |  | char * | desc
 | ) |  |

#include <zwapi_var.h>

Update the specified equation's description without regard for how
the equation was generated.

Parameters
[in] | idEqn | equation id
[in] | desc | description that defines the equation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEqnDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxPartEqnDelete()

evxErrors cvxPartEqnDelete ( int idEqn )

#include <zwapi_var.h>

Delete all equation if idEqn = -1. Delete equation set or equation by specified idEqn.

Parameters
[in] idEqn equation id or equation set id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEqnAssociatedSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxPartInqEqnAssociatedSet()

evxErrors cvxPartInqEqnAssociatedSet | ( | int | idEqn,
 |  | int * | idSet
 | ) |  |

#include <zwapi_var.h>

Get equation set containing specified equation.
If cannot find, *idSet = -1.

Parameters
[in] | idEqn | equation id
[out] | idSet | equation set id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEqnSetMembers

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxPartInqEqnSetMembers()

evxErrors cvxPartInqEqnSetMembers | ( | int | idSet,
 |  | int * | count,
 |  | int ** | idList
 | ) |  |

#include <zwapi_var.h>

Output all the equations of equation set. In specified equation set,if no equation, *count=0 and *idList=NULL.

The memory referenced by "idList" is allocated by this function. The calling procedure is responsible to free it (cvxMemFree((void**)idList)).

Parameters
[in] | idSet | equation set id
[out] | count | number of idList
[out] | idList | list of equation id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarSubstitute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxPartVarSubstitute()

evxErrors cvxPartVarSubstitute | ( | char * | Str,
 |  | int | nBytes,
 |  | int * | Truncated
 | ) |  |

#include <zwapi_var.h>

Substitute variable values into a string for all occurrences of
variable references. The syntax for each variable reference is [$VAR]
where VAR is the name of a variable in the active target. References
for which the variable cannot be found are left in the string.

This function is not limited to parts, but can be used when the active
target is any type of root object in which variables may exist.

The maximum number of bytes allowed in the "Str" character array is
"nBytes" including a terminating '\0' byte. When this function
returns, "Truncated" is set to 0 if the string with variable
substitutions fits within this maximum size. If a variable
substitution would cause the string to exceed this size, the string is
truncated and "Truncated" is set to 1. The caller may pass NULL in
place of the "Truncated" argument if this result is not of interest.

It is not an error if "Str" is NULL or empty, nor is it an error if the
string has no [$VAR] references, but it is an error if a variable
specified in such a reference cannot be found in the active target.

See also
cvxPartVarSubstituteResize() for a similar function that never
truncates, but instead resizes a string.
Parameters
[in,out] | Str | null-terminated string, may be NULL
[in] | nBytes | maximum size of Str array in bytes
[out] | Truncated | 1 if string was truncated, 0 if not; may be NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarSubstituteResize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ cvxPartVarSubstituteResize()

evxErrors cvxPartVarSubstituteResize ( char ** Str )

#include <zwapi_var.h>

Substitute variable values into a string for all occurrences of
variable references. The syntax for each variable reference is [$VAR]
where VAR is the name of a variable in the active target. References
for which the variable cannot be found are left in the string.

This function is not limited to parts, but can be used when the active
target is any type of root object in which variables may exist.

The string will be reallocated (if necessary) to insert the variable values.

It is not an error if "Str" is NULL or empty, nor is it an error if the
string has no [$VAR] references, but it is an error if a variable
specified in such a reference cannot be found in the active target.

The string is reallocated if substituting the variable values produces
a longer string. The string is not reallocated if it becomes shorter
or stays the same length.

If the block of memory used for the string is larger than needed for
the string (i.e. larger than the number of bytes in the string plus
1), this function might make the block smaller. That is because
reallocation requests only the amount of memory needed for the string,
and might not consider unused space in the block. There is no need to
allocate more memory than the string needs before calling this function.

See also
cvxPartVarSubstitute() for a similar function that truncates a string instead of resizing it.
Parameters
[in,out] Str null-terminated string, may be NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: View

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
View
Common

Detailed Description

THE MODULE FOR THE ZW3D View API

View Query

int | cvxViewIsSection (int idView)
int | cvxViewIsStandard (int idView)
evxErrors | cvxViewInqStandardType (int idView, evxViewStd *type)

View Operation

evxErrors | cvxViewActivate (int idView)
void | cvxViewExtent (double Extent)
void | cvxViewGet (svxMatrix *Frame, double *Extent)
void | cvxViewSet (svxMatrix *Frame, double Extent)
void | cvxViewOrigin (svxPoint *Origin)
void | cvxViewStd (evxViewStd Type, double NullExtent)
evxErrors | cvxViewSetBndBox (double Scale, const svxBndBox *BndBox)
evxErrors | cvxGetViewRect (int includeFrame, int isGlobal, int *tlX, int *tlY, int *brX, int *brY)

Custom View

evxErrors | cvxCustomViewAdd (char *Name, int LyrVis, int ObjVis, int *idView)
evxErrors | cvxCustomViewActivate (int idView)
evxErrors | cvxCustomViewDel (int idView)
evxErrors | cvxCustomViewId (vxName Name, int *idView)
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxCustomViewActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxCustomViewActivate()

evxErrors cvxCustomViewActivate ( int idView )

#include <zwapi_view.h>

Changes the orientation of the active view (part, sketch, cam plan)
to the specified custom view type and then does a "zoom all".

Note
the input view extent is only used if the "zoom all" doesn't find any geometry.
Parameters
[in] idView index of custom view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxCustomViewAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxCustomViewAdd()

evxErrors cvxCustomViewAdd | ( | char * | Name,
 |  | int | LyrVis,
 |  | int | ObjVis,
 |  | int * | idView
 | ) |  |

#include <zwapi_view.h>

Add a custom view.

Parameters
[in] | Name | custom view name
[in] | LyrVis | store current layer visibility(1 to store, 0 not to store)
[in] | ObjVis | store current object visibility(1 to store, 0 not to store)
[out] | idView | index of view (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxCustomViewDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxCustomViewDel()

evxErrors cvxCustomViewDel ( int idView )

#include <zwapi_view.h>

Delete specified custom view.

Note
the view can not be the current active view.
Parameters
[in] idView index of custom view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxCustomViewId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxCustomViewId()

evxErrors cvxCustomViewId | ( | vxName | Name,
 |  | int * | idView
 | ) |  |

#include <zwapi_view.h>

Get index of custom view of specified name.

Parameters
[in] | Name | custom view name
[out] | idView | index of custom view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxGetViewRect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxGetViewRect()

evxErrors cvxGetViewRect | ( | int | includeFrame,
 |  | int | isGlobal,
 |  | int * | tlX,
 |  | int * | tlY,
 |  | int * | brX,
 |  | int * | brY
 | ) |  |

#include <zwapi_view.h>

Get the global or client coordinates of active View.

Parameters
[in] | includeFrame | 1=include window frame; 0=exclude window frame;
[in] | isGlobal | 1=get global coordinates; 0=get client coordinates;
[out] | tlX | top left X
[out] | tlY | top left Y
[out] | brX | bottom right X
[out] | brY | bottom right Y
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewActivate()

evxErrors cvxViewActivate ( int idView )

#include <zwapi_view.h>

Activate the specified view.

Parameters
[in] idView id view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewExtent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewExtent()

void cvxViewExtent ( double Extent )

#include <zwapi_view.h>

Sets the active view extent.

Parameters
[in] Extent view extent (mm)
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewGet()

void cvxViewGet | ( | svxMatrix * | Frame,
 |  | double * | Extent
 | ) |  |

#include <zwapi_view.h>

Retrieves the position, orientation and extent of the active view.

Parameters
[out] | Frame | align active view with specified coordinate frame
[out] | Extent | view extent
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_MEMORY
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewInqStandardType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewInqStandardType()

evxErrors cvxViewInqStandardType | ( | int | idView,
 |  | evxViewStd * | type
 | ) |  |

#include <zwapi_view.h>

Gets the specified type of the standard view.

Parameters
[in] | idView | id view
[out] | type | view type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewIsSection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewIsSection()

int cvxViewIsSection ( int idView )

#include <zwapi_view.h>

Determine whether the view is a section view.

Parameters
[in] idView id view
Return values
succeeds
  • 1 - it is section view
  • 0 - it is not section view
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewIsStandard

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewIsStandard()

int cvxViewIsStandard ( int idView )

#include <zwapi_view.h>

Determine whether the view is a standard view.

Parameters
[in] idView id view
Return values
succeeds
  • 1 - it is standard view
  • 0 - it is not standard view
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewOrigin()

void cvxViewOrigin ( svxPoint * Origin )

#include <zwapi_view.h>

Moves the origin of the active view to the specified point.

Parameters
[in] Origin new view origin
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewSet()

void cvxViewSet | ( | svxMatrix * | Frame,
 |  | double | Extent
 | ) |  |

#include <zwapi_view.h>

Aligns the active view with the specified frame and sets the specified view extent.

Parameters
[in] | Frame | align active view with specified coordinate frame
[in] | Extent | view extent
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewSetBndBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewSetBndBox()

evxErrors cvxViewSetBndBox | ( | double | Scale,
 |  | const svxBndBox * | BndBox
 | ) |  |

#include <zwapi_view.h>

Make specified bounding box visible in world coordinates.

Parameters
[in] | Scale | scale factor
[in] | BndBox | the 3D bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxViewStd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • View
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ cvxViewStd()

void cvxViewStd | ( | evxViewStd | Type,
 |  | double | NullExtent
 | ) |  |

#include <zwapi_view.h>

Changes the orientation of the active view (part, sketch, cam plan)
to the specified standard view type and then does a "zoom all".

Note
the input view extent is only used if the "zoom all" doesn't find any geometry.
Parameters
[in] | Type | standard view type
[in] | NullExtent | view extent used if no geometry
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Transaction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Transaction
Common

Detailed Description

THE MODULE FOR THE ZW3D Transaction Operation API

Undo/Redo

int | cvxOpCount (void)
int | cvxXnUndoCount ()
evxErrors | cvxUndoRedoMarker (vxName Name)
evxErrors | cvxUndoRedo (int Undo)
evxErrors | cvxUndoRedoTo (int Undo, vxName Name)
evxErrors | cvxPartNameLastOp (vxName NewName)

Transaction Bundle

evxErrors | cvxXnBundle (int iCount, const char *xn_name)
void | cvxUndoBundleStart (int DisableManager, int Settings[])
void | cvxUndoBundleEnd (int RefreshDisplay, int Settings[], int isError)
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxOpCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxOpCount()

int cvxOpCount ( void )

#include <zwapi_xn.h>

Returns the current number of operations in the current transaction.
This number is passed to cvxEntNew() or cvxEntNewList() as a
reference point for finding entities created after completion of a
particular operation.

Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartNameLastOp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxPartNameLastOp()

evxErrors cvxPartNameLastOp ( vxName NewName )

#include <zwapi_xn.h>

If history regen is not active, the input name is assigned to
the last operation in the active part's history. The name is
forced to be unique within the active history by appending an
id to it if necessary. The seed name should be short enough
that a 4 character id can be appended to it without making the
name longer than 31 single-byte characters.

Parameters
[in] NewName new name for last history operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxUndoBundleEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxUndoBundleEnd()

void cvxUndoBundleEnd | ( | int | RefreshDisplay,
 |  | int | Settings[],
 |  | int | isError
 | ) |  |

#include <zwapi_xn.h>

Terminates undo-redo transaction bundling initiated by a previous call to
cvxUndoBundleStart(). Refreshes the display if "Redraw" is non-zero.
This function MUST ALWAYS be paired with a call to cvxUndoBundleStart()
and absolutely requires the "Settings" output by cvxUndoBundleStart()
as input in order to properly restore the original settings.

If a custom operation is not active at the time this function is
called, the current undo-redo transaction will be closed.

Parameters
[in] | RefreshDisplay | 1 to refresh the display, else 0
[in] | Settings[] | array of 8 integer settings output by cvxUndoBundleStart()
[in] | isError | 1 if there was an error during the transaction, else 0
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxUndoBundleStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxUndoBundleStart()

void cvxUndoBundleStart | ( | int | DisableManager,
 |  | int | Settings[]
 | ) |  |

#include <zwapi_xn.h>

This function causes subsequent undo-redo transactions to be
bundled into one transaction with display update disabled.
The input array "Settings" is used to back up settings modified
by this function. This function MUST ALWAYS be paired with a
subsequent call to cvxUndoBundleEnd() which requires "Settings"
as input.

If a custom operation is not active at the time this function is
called, a new undo-redo transaction will automatically be initiated.

Parameters
[in] | DisableManager | 1 to disable update of the Manager form, else 0
[in,out] | Settings[] | pointer to an empty array of 8 integers
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxUndoRedo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxUndoRedo()

evxErrors cvxUndoRedo ( int Undo )

#include <zwapi_xn.h>

If "Undo" is non-zero, undo the last operation.
If "Undo" is zero, redo the last undone operation.

Parameters
[in] Undo 1-undo, 0-redo
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxUndoRedoMarker

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxUndoRedoMarker()

evxErrors cvxUndoRedoMarker ( vxName Name )

#include <zwapi_xn.h>

Creates and logs an undo-redo transaction with a unique name,
which is output via "Name". The transaction is essentially
empty, but serves as a marker in the undo-redo transaction
list. The marker can be passed to cvxUndoRedoTo() to undo or redo
all transactions up to, and including, the marker.

This function will cause any recently-logged database operations
to be flushed to an undo-redo transaction linked to the last-logged
transaction.

This function assumes "Name" is a character pointer to at least
sizeof(vxName) bytes of memory allocated by the calling procedure.

See also
cvxCmdMarker().
Parameters
[out] Name name of undo-redo transaction marker
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxUndoRedoTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxUndoRedoTo()

evxErrors cvxUndoRedoTo | ( | int | Undo,
 |  | vxName | Name
 | ) |  |

#include <zwapi_xn.h>

Undo/redo up to, and including, the specified transaction –
or to the start/end of the undo-redo transaction list –
whichever is encountered first.

See also
cvxCmdMarker().
Parameters
[in] | Undo | 1-undo, 0-redo
[in] | Name | undo-redo transaction name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxXnBundle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxXnBundle()

evxErrors cvxXnBundle | ( | int | iCount,
 |  | const char * | xn_name
 | ) |  |

#include <zwapi_xn.h>

Bundle the steps from the iCount+1 to the present into a new step(transaction).

Make sure the present steps is greater than iCount, use cvxXnUndoCount() to get it.

Parameters
[in] | iCount | special step count
[in] | xn_name | transaction name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: cvxXnUndoCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Transaction
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ cvxXnUndoCount()

int cvxXnUndoCount ( )

#include <zwapi_xn.h>

Get the present undo step count.

Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
File

Detailed Description

Modules

File
File Data
Path Operation
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
File
File

Detailed Description

THE MODULE FOR THE ZW3D File API

File New

int | cvxFileNameCheck (char *fileName, int nBytes)
evxErrors | cvxFileNew (const vxLongPath Name)
evxErrors | cvxFileNew2 (const vxLongPath Name, char *Description)
evxErrors | cvxFileNewSingle (const vxLongPath fileName, evxFileType fileType, evxFileSubtype fileSubtype, const char *templateName, char *fileDescription)

File Open

int | cvxFileKeep (int fKeepOpen)
evxErrors | cvxFileOpen (const vxLongPath File)
evxErrors | cvxFileReOpen (const vxLongPath Name)
evxErrors | cvxFileReplace (const vxLongPath filePath, const vxLongPath newData, int fDel)

File Save

evxErrors | cvxFileSave (int Close)
evxErrors | cvxFileSave2 (int Close)
evxErrors | cvxFileSave3 (int Close, int DisPrompt, int Related)
evxErrors | cvxFileSaveAll (void)
evxErrors | cvxFileSaveAs (const vxLongPath File)
evxErrors | cvxFilesSaveTo (int Count, const vxPath *FileList, const vxPath Path)
evxErrors | cvxFilesSaveToByLongPath (int Count, const vxLongPath *FileList, const vxLongPath Path)
evxErrors | cvxCompFileSaveAs (svxEntPath *CompPath, int UpdateFlag, const vxLongPath File)

File Close

void | cvxFileClose (void)
void | cvxFileClose2 (const vxLongPath Name, int Option)

Session

evxErrors | cvxSessionClear (void)
evxErrors | cvxFileSessionClear (const vxLongPath file)
evxErrors | cvxSessionSave (void)
evxErrors | cvxSessionRestore (void)

File Import/Export

evxErrors | cvxFileImportInit (svxImportData *data, evxImportType type, void *general)
evxErrors | cvxFileImport (svxImportData *importData)
evxErrors | cvxFileImportMulti (int Count, const vxPath *PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void *Setting)
evxErrors | cvxFileImportMultiByLongPath (int Count, const vxLongPath *PathList, int SubFolder, const vxLongPath SavePath, evxImportType Type, const void *Setting)
evxErrors | cvxFileImportStl (const char *path, int *idOut)
evxErrors | cvxFileExportInit (evxExportType type, int imgType, void *data)
evxErrors | cvxFileExport (evxExportType Type, const vxLongPath Path, void *Data)
evxErrors | cvxFileExportMulti (int Count, const vxPath *FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void *Data)
evxErrors | cvxFileExportMultiByLongPath (int Count, const vxLongPath *FileList, evxFileType Filter, evxExportType Type, const vxLongPath Path, void *Data)
evxErrors | cvxPartSmdFlatSolidExport (int idFlatten, evxExportType type, const vxLongPath filePath, void *data)
evxErrors | cvxPartSmdFlatPatternExport (int idFlatten, const vxLongPath filePath, const svxDWGData *data)

File Action

evxErrors cvxFileAction (evxDocAction type, svxDocActionParam *param)

File Query/Edit

evxErrors | cvxFileActivate (const vxLongPath Name)
void | cvxFileDirectory (vxPath Directory)
void | cvxFileDirectoryByLongPath (char *Directory, int sizeDire)
void | cvxFileInqActive (char *Name, int nBytes)
void | cvxFileTypeGet (int *MultiObject)
void | cvxFileTypeSet (int MultiObject)
evxErrors | cvxFileInqSubType (const vxLongPath fileName, evxFileSubtype *fileSubtype)
void | cvxFileInqOpen (char *Name, int nBytes)
void | cvxFileOpenList (int *count, vxPath **fileList)
void | cvxFileOpenListByLongPath (int *count, vxLongPath **fileList)
evxErrors | cvxFileLoadList (const int state, int *count, vxPath **fileList)
evxErrors | cvxFileLoadListByLongPath (int state, int *count, vxLongPath **fileList)
evxErrors | cvxFileVersionGet (const vxLongPath file, int *version)
evxErrors | cvxFileIsModified (const vxLongPath Name, int *Modified)
evxErrors | cvxFileInqAssociatedList (int *count, vxPath **fileList)
evxErrors | cvxFileInqAssociatedListByLongPath (int *count, vxLongPath **fileList)
evxErrors | cvxFileInqAssociatedListByName (const char *fileName, int nDepth, int *count, vxPath **fileList)
evxErrors | cvxFileInqAssociatedListByLongName (const char *fileName, int nDepth, int *count, vxLongPath **fileList)
evxErrors | cvxFilePreviewExtract (const vxLongPath SrcFile, const vxLongPath BmpFile)
evxErrors | cvxFileInqAsm (char *Name, int nBytes)
char | cvxFileInqAssemMode (void)

UDF File Query/Edit

evxErrors | cvxFileIsUDF (const vxLongPath path, const vxLongPath file, int *isUDF)
evxErrors | cvxUDFFileInqAssociatedList (const vxPath path, const vxPath file, int *count, vxPath **fileList)
evxErrors | cvxUDFFileInqAssociatedListByLongPath (const vxLongPath path, const vxLongPath file, int *count, vxLongPath **fileList)

File Attribute

void | cvxFileDescriptionSet (const vxLongPath Name, const char *Description)
evxErrors | cvxFileDescriptionGet (const vxLongPath Name, vxLongName Description)
evxErrors | cvxFileCustomDataSet (const vxLongPath file, const char *data, int dataLength)
evxErrors | cvxFileCustomDataGet (const vxLongPath file, char **data, int *dataLength)
evxErrors | cvxFileCustomDataDel (const vxLongPath file)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFileSaveAs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxCompFileSaveAs()

evxErrors cvxCompFileSaveAs | ( | svxEntPath * | CompPath,
 |  | int | UpdateFlag,
 |  | const vxLongPath | File
 | ) |  |

#include <zwapi_file.h>

Saves the file referred by the specified component to the specified path/filename.

UpdateFlag is 0 to just update the specified component only, 1 to update all the
components refer to the same part in the same parent assembly, and -1 to update all
as cvxFileSaveAs (no prompt, save as new and replace original one).

Parameters
[in] | CompPath | pick-path of component
[in] | UpdateFlag | update flag, please see the description
[in] | File | path name to save file (must include the new file name)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_MEMORY_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOACATE_FAIL
  • ZW_aPI_FILE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileAction()

evxErrors cvxFileAction | ( | evxDocAction | type,
 |  | svxDocActionParam * | param
 | ) |  |

#include <zwapi_file.h>

Set a callback function. When processing the target file option, the callback function will be called.

If this function called many times with the same 'type', only the last will take effect.

If param->pfn is null, the original callback function, if there exists, will be removed.

If param->pfn isn't null, the first parameter is caller's data, it can be null, the second parameter is actual file, the last parameter may be null, it's used as the path for output file sometimes. lastly, if param->pfn invokes successes, the function will return 0, else 1.

Note
If one call this function to register a callback in a dll module, he must call this function again, with argument param set as NULL, to unregister the callback for each action before the dll module exit.
Usually we can do this in the exit function of the dll module.
Parameters
[in] | type | action type
[in] | param | callback function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileActivate()

evxErrors cvxFileActivate ( const vxLongPath Name )

#include <zwapi_file.h>

Activates the specified ZW3D file for editing. The file must already have been opened, or it must reside in one of the default search directories (cvxPathSearchFirst()).
If the Name carries the specific path which is not in the default search path, this function will add it to the default search path and set it as the priority search path.

See also
cvxRootActivate2s() will activate the specified file in the memory and the target object will be activated.
Parameters
[in] Name ZW3D file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FILE_LOACTE_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileClose

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileClose()

void cvxFileClose ( void )

#include <zwapi_file.h>

Closes the active ZW3D file, prompting the user whether to save or discard changes before closing the file.

See also
cvxFileClose2() for a version of this function with more options.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileClose2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileClose2()

void cvxFileClose2 | ( | const vxLongPath | Name,
 |  | int | Option
 | ) |  |

#include <zwapi_file.h>

Closes the specified file, whether or not it is the active file.
The active file will remain active after the specified file is closed.
If the specified file (Name) is the active file, no attempt is made to select another file for activation after "Name" is closed.

Parameters
[in] Name file name (input NULL or empty string to close the active file)
[in] Option 0 - prompt whether to save or discard changes before closing file;
1 - automatically save changes before closing file;
2 - automatically discard changes before closing file; if the undo-redo
log references the file, undo-redo information is cleared for all files
in the active session.
3 - automatically discard changes before closing file; existing undo-redo
information will be kept, but will ignore the closed file; if you use this
option, it is on you to be certain that no harm will come from undoing or
redoing transactions without regard for how the closed file may have been
involved in them.
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileCustomDataDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileCustomDataDel()

evxErrors cvxFileCustomDataDel ( const vxLongPath file )

#include <zwapi_file.h>

Delete user custom data from an existing ZW3D or VX file.

Parameters
[in] file ZW3D or VX file name (file[0]=0 or NULL for active file)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileCustomDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileCustomDataGet()

evxErrors cvxFileCustomDataGet | ( | const vxLongPath | file,
 |  | char ** | data,
 |  | int * | dataLength
 | ) |  |

#include <zwapi_file.h>

Get user custom data from an existing ZW3D or VX file.
The list referenced by "**data" is allocated by this function and must
be deallocated by the calling procedure by cvxMemFree() function.
A NULL pointer is output if no data is found.

Parameters
[in] | file | ZW3D or VX file name (file[0]=0 or NULL for active file)
[out] | data | customization data
[out] | dataLength | length of customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileCustomDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileCustomDataSet()

evxErrors cvxFileCustomDataSet | ( | const vxLongPath | file,
 |  | const char * | data,
 |  | int | dataLength
 | ) |  |

#include <zwapi_file.h>

Set user custom data to an existing ZW3D or VX file. Program will overwrite existing custom data if file already has custom data.

Parameters
[in] | file | ZW3D or VX file name (file[0]=0 or NULL for active file)
[in] | data | customization data
[in] | dataLength | length of customization data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileDescriptionGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileDescriptionGet()

evxErrors cvxFileDescriptionGet | ( | const vxLongPath | Name,
 |  | vxLongName | Description
 | ) |  |

#include <zwapi_file.h>

Gets the description of specified file.
The file description here is different from the attribute "Description" of root object. To get the attribute "Description" of root object, you can use the attribute getting functions, such as cvxPartAtItemGet and cvxPartAtItemGetInFile.

Parameters
[in] | Name | ZW3D or VX file name (Name[0]=0 or NULL for active file)
[out] | Description | object description
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileDescriptionSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileDescriptionSet()

void cvxFileDescriptionSet | ( | const vxLongPath | Name,
 |  | const char * | Description
 | ) |  |

#include <zwapi_file.h>

Sets description of specified file.
The file description here is different from the attribute "Description" of root object. To set the attribute "Description" of root object, you can use the attribute setting functions, such as cvxPartAtItemSet and cvxPartAtItemSetInFile.

Parameters
[in] | Name | ZW3D or VX file name (Name[0]=0 or NULL for active file)
[in] | Description | object description. no longer than 32 bytes.
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_FILE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileDirectory

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileDirectory()

void cvxFileDirectory ( vxPath Directory )

#include <zwapi_file.h>

If the active file has been saved, the directory where it resides is output. Otherwise, Dir[0]=0 is output.

Parameters
[out] Directory source directory for the active file
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileDirectoryByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileDirectoryByLongPath()

void cvxFileDirectoryByLongPath | ( | char * | Directory,
 |  | int | sizeDire
 | ) |  |

#include <zwapi_file.h>

If the active file has been saved, the directory where it resides is output. Otherwise, Dir[0]=0 is output.

A Directory that is too long (longer than "sizeDire") is truncated.

It is assumed that the input "Directory" is no longer than 512 bytes.

Parameters
[out] | Directory | source directory for the active file
[int] | sizeDire max size of Directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileExport()

evxErrors cvxFileExport | ( | evxExportType | Type,
 |  | const vxLongPath | Path,
 |  | void * | Data
 | ) |  |

#include <zwapi_file.h>

Exports the specified file to specified path.
If the Type is VX_EXPORT_TYPE_IMG, the data is defined by struct svxImgData,
else if the Type is VX_EXPORT_TYPE_PDF, the data is defined by struct svxPdfData,
else if the Type is VX_EXPORT_TYPE_GRP, the data is svxGRPData(can be ignored),
else if the Type is VX_EXPORT_TYPE_DWG, the data is svxDWGData.
else if the Type is VX_EXPORT_TYPE_IGES, the data is svxIGESData.
else if the Type is VX_EXPORT_TYPE_STEP, the data is svxSTEPData.
else if the Type is VX_EXPORT_TYPE_JT, the data is svxJTData.
else if the Type is VX_EXPORT_TYPE_PARA_TEXT, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_PARA_BINARY, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_CAT5_PART, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_CAT5_ASM, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_HTML, the data is svxHTMLData.
else if the Type is VX_EXPORT_TYPE_STL, the data is svxSTLData.

Interface cvxFileExportInit() initializes the corresponding structure.

Parameters
[in] | Type | type of export
[in] | Path | path of export file
[in] | Data | data of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileExportInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileExportInit()

evxErrors cvxFileExportInit | ( | evxExportType | type,
 |  | int | imgType,
 |  | void * | data
 | ) |  |

#include <zwapi_file.h>

Initialize the parameters of the cvxFileExport().

Set "imgType" only when the "type" is VX_EXPORT_TYPE_IMG or VX_EXPORT_TYPE_PDF. Otherwise, set it to 0.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | type of export
[in] | imgType | see description(evxImgType)
[out] | data | data of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileExportMulti

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileExportMulti()

evxErrors cvxFileExportMulti | ( | int | Count,
 |  | const vxPath * | FileList,
 |  | evxFileType | Filter,
 |  | evxExportType | Type,
 |  | const vxPath | Path,
 |  | void * | Data
 | ) |  |

#include <zwapi_file.h>

Exports the specified files to specified path.
If the Type is VX_EXPORT_TYPE_IMG, the data is defined by struct svxImgData,
else if the Type is VX_EXPORT_TYPE_PDF, the data is defined by struct svxPdfData,
else if the Type is VX_EXPORT_TYPE_DWG, the data is svxDWGData.
else if the Type is VX_EXPORT_TYPE_IGES, the data is svxIGESData.
else if the Type is VX_EXPORT_TYPE_STEP, the data is svxSTEPData.
else if the Type is VX_EXPORT_TYPE_JT, the data is svxJTData.
else if the Type is VX_EXPORT_TYPE_PARA_TEXT, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_PARA_BINARY, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_CAT5_PART, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_CAT5_ASM, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_STL, the data is svxSTLData.

Interface cvxFileExportInit() initializes the corresponding structure.

Note
VX_EXPORT_TYPE_GRP and VX_EXPORT_TYPE_HTML are not supported by the function. CAM Plan don't support export.
Parameters
[in] | Count | count of the files list to export (0 to export all currently open files)
[in] FileList list of files to export (NULL to export all currently open and newly files)
  1. loaded file and newly created file need only file name
  2. unloaded file need the full path of file
[in] | Filter | type of object to export, VX_FILE_ALL to export all object
[in] | Type | type of export
[in] | Path | destination path for exporting files (excluding file name)
[in] | Data | export parameter
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileExportMultiByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileExportMultiByLongPath()

evxErrors cvxFileExportMultiByLongPath | ( | int | Count,
 |  | const vxLongPath * | FileList,
 |  | evxFileType | Filter,
 |  | evxExportType | Type,
 |  | const vxLongPath | Path,
 |  | void * | Data
 | ) |  |

#include <zwapi_file.h>

Exports the specified files to specified path. If the Type is VX_EXPORT_TYPE_IMG, the data is defined by struct svxImgData, else if the Type is VX_EXPORT_TYPE_PDF, the data is defined by struct svxPdfData, else if the Type is VX_EXPORT_TYPE_DWG, the data is svxDWGData. else if the Type is VX_EXPORT_TYPE_IGES, the data is svxIGESData. else if the Type is VX_EXPORT_TYPE_STEP, the data is svxSTEPData. else if the Type is VX_EXPORT_TYPE_JT, the data is svxJTData. else if the Type is VX_EXPORT_TYPE_PARA_TEXT, the data is svxPARAData. else if the Type is VX_EXPORT_TYPE_PARA_BINARY, the data is svxPARAData. else if the Type is VX_EXPORT_TYPE_CAT5_PART, the data is svxCAT5Data. else if the Type is VX_EXPORT_TYPE_CAT5_ASM, the data is svxCAT5Data. else if the Type is VX_EXPORT_TYPE_STL, the data is svxSTLData.

Interface cvxFileExportInit() initializes the corresponding structure.

Note
VX_EXPORT_TYPE_GRP and VX_EXPORT_TYPE_HTML are not supported by the function. CAM Plan don't support export.
Parameters
[in] | Count | count of the files list to export (0 to export all currently open files)
[in] FileList list of files to export (NULL to export all currently open and newly files)
  1. loaded file and newly created file need only file name
  2. unloaded file need the full path of file
[in] | Filter | type of object to export, VX_FILE_ALL to export all object
[in] | Type | type of export
[in] | Path | destination path for exporting files (excluding file name)
[in] | Data | export parameter
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileImport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileImport()

evxErrors cvxFileImport ( svxImportData * importData )

#include <zwapi_file.h>

Import specified file to specified object.

You can use function cvxOpCount() before importing the file,
and then use cvxEntNewList()/cvxEntNew() to get the new specified
entities after importing the file.

Note
Interface cvxFileImportInit() can initialize variables of this function.
Parameters
[in] importData import data of specified file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileImportInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileImportInit()

evxErrors cvxFileImportInit | ( | svxImportData * | data,
 |  | evxImportType | type,
 |  | void * | general
 | ) |  |

#include <zwapi_file.h>

Initialize the parameters of the cvxFileImport().

"general" supports initialization of the following import types, which correspond to the following data types:
If the type = VX_IMPORT_TYPE_UG, the general is svxImportUGData.
If the type = VX_IMPORT_TYPE_STEP, the general is svxImportSTEPData.
If the type = VX_IMPORT_TYPE_DWG_DXF, the general is svxImportDwgDxfData.
If the type = VX_IMPORT_TYPE_STL, the general is svxImportSTLData. if the Type = VX_IMPORT_PTS_FROM_FILE, the general is svxImportPTSData.

Note
Do not assign a value to variable "data" before calling this function.
The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | import file data
[in] | type | import file type
[out] | general | setting general properties(NULL to use default settings)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileImportMulti

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileImportMulti()

evxErrors cvxFileImportMulti | ( | int | Count,
 |  | const vxPath * | PathList,
 |  | int | SubFolder,
 |  | const vxPath | SavePath,
 |  | evxImportType | Type,
 |  | const void * | Setting
 | ) |  |

#include <zwapi_file.h>

Use this function to import non-ZW3D files types such as Catia V4, JT,NX etc. into ZW3D as parts, sketches, or drawing sheets. the files will be imported and save as Z3 file automatically.

Currently, "Setting" only supports the following import type, and the data type matching the type is as follows:
If type = VX_IMPORT_TYPE_UG, Setting is svxImportUGData.
If type = VX_IMPORT_TYPE_STEP, Setting is svxImportSTEPData.
If type = VX_IMPORT_TYPE_DWG_DXF, Setting is svxImportDwgDxfData.
If type = VX_IMPORT_TYPE_STL, Setting is svxImportSTLData.

Note
VX_IMPORT_TYPE_JT and VX_IMPORT_PTS_FROM_FILE are not supported by the function.
Parameters
[in] | Count | count of files or directories list to import
[in] | PathList | list of files or directories to import
[in] | SubFolder | whether to include sub-folders files (1: yes; 0: no)
[in] | SavePath | output path that does not contain file name, NULL to output file to input folder
[in] | Type | the import file types
[in] | Setting | the import setting data (NULL to use default setting)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileImportMultiByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileImportMultiByLongPath()

evxErrors cvxFileImportMultiByLongPath | ( | int | Count,
 |  | const vxLongPath * | PathList,
 |  | int | SubFolder,
 |  | const vxLongPath | SavePath,
 |  | evxImportType | Type,
 |  | const void * | Setting
 | ) |  |

#include <zwapi_file.h>

Use this function to import non-ZW3D files types such as Catia V4, JT,NX etc.
into ZW3D as parts, sketches, or drawing sheets. the files will be imported
and save as Z3 file automatically.

Currently, "Setting" only supports the following import type, and the data type matching the type is as follows:
If type = VX_IMPORT_TYPE_UG, Setting is svxImportUGData.
If type = VX_IMPORT_TYPE_STEP, Setting is svxImportSTEPData.
If type = VX_IMPORT_TYPE_DWG_DXF, Setting is svxImportDwgDxfData.
If type = VX_IMPORT_TYPE_STL, Setting is svxImportSTLData.

Note
VX_IMPORT_TYPE_JT and VX_IMPORT_PTS_FROM_FILE are not supported by the function.
Parameters
[in] | Count | count of files or directories list to import
[in] | PathList | list of files or directories to import
[in] | SubFolder | whether to include sub-folders files (1: yes; 0: no)
[in] | SavePath | output path that does not contain file name, NULL to output file to input folder
[in] | Type | the import file types
[in] | Setting | the import setting data (NULL to use default setting)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileImportStl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileImportStl()

evxErrors cvxFileImportStl | ( | const char * | path,
 |  | int * | idOut
 | ) |  |

#include <zwapi_file.h>

Import a STL file to active part.

Parameters
[in] | path | STL file path
[out] | idOut | id of Imported STL Block
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqActive()

void cvxFileInqActive | ( | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_file.h>

Outputs the name of the active file.
Outputs Name[0]=0 if there is no active file.

Parameters
[out] | Name | name of active file
[in] | nBytes | string max size of active file name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
Examples
part\shapeFtrCrtTest.cpp, and part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAsm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAsm()

evxErrors cvxFileInqAsm | ( | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_file.h>

Outputs the file name of top root object in assembly. Outputs "Name[0]=0" if error.

Parameters
[out] | Name | file name of top root object in assembly
[in] | nBytes | string max size of file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAssemMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAssemMode()

char cvxFileInqAssemMode ( void )

#include <zwapi_file.h>

Get target part's assembly mode, if no target is active, return the value in configuration.

Return values
return
  • 1 - if new assembly mode (version 17).
  • 0 - otherwise.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAssociatedList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAssociatedList()

evxErrors cvxFileInqAssociatedList | ( | int * | count,
 |  | vxPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get associated file list with the target object.This includes
assembly component files, drawing view files, imported files (IGES,
STEP,...) and links.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAssociatedListByLongName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAssociatedListByLongName()

evxErrors cvxFileInqAssociatedListByLongName | ( | const char * | fileName,
 |  | int | nDepth,
 |  | int * | count,
 |  | vxLongPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get associated file list with the target object or the specified file.This includes assembly component files, drawing view files, imported files (IGES, STEP,...) and links.

If iDepth is >=0, then the link files will be ignore for the depth more than it. Set it as -1 to get all (ignore the depth checking).

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | fileName | file name to inquire, NULL for just the active target
[in] | nDepth | max depth to inquire the linked files, -1 to ignore (see description)
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAssociatedListByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAssociatedListByLongPath()

evxErrors cvxFileInqAssociatedListByLongPath | ( | int * | count,
 |  | vxLongPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get associated file list with the target object.This includes assembly component files, drawing view files, imported files (IGES, STEP,...) and links.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqAssociatedListByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqAssociatedListByName()

evxErrors cvxFileInqAssociatedListByName | ( | const char * | fileName,
 |  | int | nDepth,
 |  | int * | count,
 |  | vxPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get associated file list with the target object or the specified file.This includes assembly component files, drawing view files, imported files (IGES, STEP,...) and links.

If iDepth is >=0, then the link files will be ignore for the depth more than it. Set it as -1 to get all (ignore the depth checking).

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | fileName | file name to inquire, NULL for just the active target
[in] | nDepth | max depth to inquire the linked files, -1 to ignore (see description)
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqOpen()

void cvxFileInqOpen | ( | char * | Name,
 |  | int | nBytes
 | ) |  |

#include <zwapi_file.h>

Outputs the name of the open file.
Outputs Name[0]=0 if there is no open file.

Parameters
[out] | Name | name of active file
[in] | nBytes | string max size of active file name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileInqSubType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileInqSubType()

evxErrors cvxFileInqSubType | ( | const vxLongPath | fileName,
 |  | evxFileSubtype * | fileSubtype
 | ) |  |

#include <zwapi_file.h>

Get the specified file subtype.
If fileName is NULL or blank string, get current file subtype.

Note
Multi-object files do not have a subtype.
Parameters
[in] | fileName | file name (or NULL)
[out] | fileSubtype | file subtype
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileIsModified

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileIsModified()

evxErrors cvxFileIsModified | ( | const vxLongPath | Name,
 |  | int * | Modified
 | ) |  |

#include <zwapi_file.h>

Get modification status of the specified VX or ZW3D file.

See also
cvxRootInqMod() and cvxRootInqModSinceRegen().
Parameters
[in] | Name | VX or ZW3D file name
[out] | Modified | 1-modified, 0-unmodified
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileIsUDF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileIsUDF()

evxErrors cvxFileIsUDF | ( | const vxLongPath | path,
 |  | const vxLongPath | file,
 |  | int * | isUDF
 | ) |  |

#include <zwapi_file.h>

Determine whether a file is a UDF file.

Parameters
[in] | path | file path(NULL to use default path)
[in] | file | file name(contains the file extension)
[out] | isUDF | 1 is UDF file,else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileKeep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileKeep()

int cvxFileKeep ( int fKeepOpen )

#include <zwapi_file.h>

Set the flag that allows files to remain open after certain functions
have accessed them. When the cvxPartAtItemGetInFile() or
cvxPartAtItemSetInFile() function must open a file to access an
attribute, by default it will also close the file when that function
returns. However, if cvxFileKeep(1) is called first,
cvxPartAtItemGetInFile() and cvxPartAtItemSetInFile() will leave the file
open, which makes subsequent calls more efficient when accessing other
attributes in the same file. Calling cvxFileKeep(0) restores the
default behavior, i.e. cvxPartAtItemGetInFile() and
cvxPartAtItemSetInFile() will close any files that they must open.

This function does not affect files that are already open when
cvxPartAtItemGetInFile() or cvxPartAtItemSetInFile() is called. Files
that are already open will remain open when accessed by those
functions, regardless of how the fKeepOpen flag is set.

This function returns the previous state of the fKeepOpen flag. In
typical usage, the returned value should be given back to this
function the second time this function is called, which will restore
the original state of the flag. For example:

int fOldKeepOpen = cvxFileKeep(1);
... multiple calls to cvxPartAtItemGetInFile() or cvxPartAtItemSetInFile() ...;
cvxFileOpen(fOldKeepOpen);
cvxFileKeep
int cvxFileKeep(int fKeepOpen)
cvxFileOpen
evxErrors cvxFileOpen(const vxLongPath File)
cvxPartAtItemSetInFile
evxErrors cvxPartAtItemSetInFile(const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
cvxPartAtItemGetInFile
evxErrors cvxPartAtItemGetInFile(const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
See also
cvxFileClose(), cvxFileSave(), and similarly named functions to close
files that may have been opened by cvxPartAtItemGetInFile() or
cvxPartAtItemSetInFile().
Parameters
[in] fKeepOpen 1 to keep files open, 0 to let files close
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileLoadList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileLoadList()

evxErrors cvxFileLoadList | ( | const int | state,
 |  | int * | count,
 |  | vxPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get the loaded file list, including front-open and background-loaded files.

The list referenced by "**fileList" is allocated by this function. And must be deallocated by the calling procedure.

Parameters
[in] state 0 to get all loaded files;
1 to get all files loaded and in use
2 to get all loaded but unused files
[out] | count | count of the list
[out] | fileList | file list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileLoadListByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileLoadListByLongPath()

evxErrors cvxFileLoadListByLongPath | ( | int | state,
 |  | int * | count,
 |  | vxLongPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get the loaded file list, including front-open and background-loaded files.

The list referenced by "**fileList" is allocated by this function. And must be deallocated by the calling procedure.

Parameters
[in] | state | 0 to get all loaded files; 1 to get all files loaded and in use 2 to get all loaded but unused files
[out] | count | count of the list
[out] | fileList | file list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileNameCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileNameCheck()

int cvxFileNameCheck | ( | char * | fileName,
 |  | int | nBytes
 | ) |  |

#include <zwapi_file.h>

Check and fix name without warning messages,
If the name contains some of \/:*?"<>|,~!@$# it is invalid, <br> this function will replace those character with _ to repair it. <br> It is assumed that the input "fileName" is no longer than 512 bytes.

Note
Normally, this function used to check the file name when new a file.
Parameters
[in,out] | fileName | file name
[in] | nBytes | max size of file name(no longer than 512 bytes)
Return values
return
  • 1 - if the input name is OK or repaired.
  • 0 - otherwise.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileNew()

evxErrors cvxFileNew ( const vxLongPath Name )

#include <zwapi_file.h>

Creates a new ZW3D file with the specified name and makes it active,
add root object using cvxRootAdd() after creating the file. If you
need to create a single object file, cvxFileNewSingle() is recommended.

Note
User can call cvxFileNameCheck() to check the Name first.
Parameters
[in] Name ZW3D file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileNew2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileNew2()

evxErrors cvxFileNew2 | ( | const vxLongPath | Name,
 |  | char * | Description
 | ) |  |

#include <zwapi_file.h>

This function is the same as cvxFileNew2(), but it also allows you
to assign a text string description to the new object file. The
description must not be longer than 32 bytes, including the null-
terminator.

Note
User can call cvxFileNameCheck() to check the Name first.
Parameters
[in] | Name | ZW3D file name
[in] | Description | optional object description (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileNewSingle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileNewSingle()

evxErrors cvxFileNewSingle | ( | const vxLongPath | fileName,
 |  | evxFileType | fileType,
 |  | evxFileSubtype | fileSubtype,
 |  | const char * | templateName,
 |  | char * | fileDescription
 | ) |  |

#include <zwapi_file.h>

Creates a new single-root file with the specified name, file type, subtype, template name and description.
and makes it active.

Note
User can call cvxFileNameCheck() to check the Name first.
Parameters
[in] | fileName | file name
[in] | fileType | single-root file type
[in] | fileSubtype | single-root file subtype
[in] | templateName | optional template object name (or NULL)
[in] | fileDescription | optional object description (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileOpen()

evxErrors cvxFileOpen ( const vxLongPath File )

#include <zwapi_file.h>

Opens an existing VX or ZW3D file. It is assumed the file resides
somewhere in the active search directories (see cvxPathSet()).
Use cvxPathSearchFirst() to force a particular directory to
be searched first.

Parameters
[in] File ZW3D file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileOpenList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileOpenList()

void cvxFileOpenList | ( | int * | count,
 |  | vxPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get all of the open file list.
The list referenced by "**fileList" is allocated by this function.
And must be deallocated by the calling procedure.
A NULL pointer is output if no data is found.

Parameters
[out] | count | count of the list
[out] | fileList | file list
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileOpenListByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileOpenListByLongPath()

void cvxFileOpenListByLongPath | ( | int * | count,
 |  | vxLongPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get all of the open file list. The list referenced by "**fileList" is allocated by this function. And must be deallocated by the calling procedure. A NULL pointer is output if no data is found.

Parameters
[out] | count | count of the list
[out] | fileList | file list
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilePreviewExtract

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFilePreviewExtract()

evxErrors cvxFilePreviewExtract | ( | const vxLongPath | SrcFile,
 |  | const vxLongPath | BmpFile
 | ) |  |

#include <zwapi_file.h>

Extract the preview bitmap from a source file. For example: BmpFile = "D:\\fileName.bmp".

Parameters
[in] | SrcFile | pathname to source file
[in] | BmpFile | pathname to bitmap file to be extracted (include bitmap name and the extension)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileReOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileReOpen()

evxErrors cvxFileReOpen ( const vxLongPath Name )

#include <zwapi_file.h>

If the specified file is not in the memory, then just open it as cvxFileOpen().

If the specified file is already opened in the memory, try to reload the data from the physical file.

Parameters
[in] Name ZW3D file name (not include file path)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileReplace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileReplace()

evxErrors cvxFileReplace | ( | const vxLongPath | filePath,
 |  | const vxLongPath | newData,
 |  | int | fDel
 | ) |  |

#include <zwapi_file.h>

Replace the file data of filePath with newData. The newData file will be deleted if fDel is not 0.

Note
newData cannot be already located/opened in ZW3D.
The filePath and newData must the full path of the file.
Parameters
[in] | filePath | path of the file to be replaced
[in] | newData | path of the file contains the new data
[in] | fDel | 1 if want to delete newData, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSave

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSave()

evxErrors cvxFileSave ( int Close )

#include <zwapi_file.h>

Saves the active ZW3D file to the location it was previously saved at.

Parameters
[in] Close 1 = close file after saving it; 0 = leave it open
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSave2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSave2()

evxErrors cvxFileSave2 ( int Close )

#include <zwapi_file.h>

Saves the active ZW3D file and its relevant files to the location they were previously saved at.

Parameters
[in] Close 1 = close file after saving it; 0 = leave it open
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSave3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSave3()

evxErrors cvxFileSave3 | ( | int | Close,
 |  | int | DisPrompt,
 |  | int | Related
 | ) |  |

#include <zwapi_file.h>

Saves the active file. You can control keep/close, pop-out/disable prompt and save the related files by parameters.

Parameters
[in] | Close | 1 = close file after saving it; 0 = leave it open
[in] | DisPrompt | 1 = no prompt during saving it; 0 = leave it open
[in] | Related | 1 = save the related files; 0 = save current file only
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSaveAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSaveAll()

evxErrors cvxFileSaveAll ( void )

#include <zwapi_file.h>

Saves all active ZW3D files to the specified path/filename.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSaveAs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSaveAs()

evxErrors cvxFileSaveAs ( const vxLongPath File )

#include <zwapi_file.h>

Saves the active ZW3D file to the specified path/filename.
If there is prompt dialog, please use "cvxUserActionStatusSet2()" to avoid interrupt.

Parameters
[in] File pathname to save file under
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileSessionClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileSessionClear()

evxErrors cvxFileSessionClear ( const vxLongPath file )

#include <zwapi_file.h>

Removes unused files from the cache.

Parameters
[in] file file name (file[0]=0 or NULL to clear all unused files)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilesSaveTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFilesSaveTo()

evxErrors cvxFilesSaveTo | ( | int | Count,
 |  | const vxPath * | FileList,
 |  | const vxPath | Path
 | ) |  |

#include <zwapi_file.h>

Saves the specified files in memory saved to the specified directory. The file name will not be changed.

Note
If the file is not opened in ZW3D and it can be found in the search path, just copy it to the specified directory.
Parameters
[in] | Count | count of the files list to save
[in] | FileList | name list of files to save (only file name)
[in] | Path | path to save files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilesSaveToByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFilesSaveToByLongPath()

evxErrors cvxFilesSaveToByLongPath | ( | int | Count,
 |  | const vxLongPath * | FileList,
 |  | const vxLongPath | Path
 | ) |  |

#include <zwapi_file.h>

Saves the specified files in memory saved to the specified directory. The file name will not be changed.

Note
If the file is not opened in ZW3D and it can be found in the search path, just copy it to the specified directory.
Parameters
[in] | Count | count of the files list to save
[in] | FileList | name list of files to save (only file name)
[in] | Path | path to save files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileTypeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileTypeGet()

void cvxFileTypeGet ( int * MultiObject )

#include <zwapi_file.h>

Gets flag indicating whether the active file is multi-object or single object.

Parameters
[out] MultiObject 1=multi-object file; 0=single-object file
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileTypeSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileTypeSet()

void cvxFileTypeSet ( int MultiObject )

#include <zwapi_file.h>

Sets flag indicating whether the active file is multi-object or single object.

Parameters
[in] MultiObject 1=multi-object file; 0=single-object file
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileVersionGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxFileVersionGet()

evxErrors cvxFileVersionGet | ( | const vxLongPath | file,
 |  | int * | version
 | ) |  |

#include <zwapi_file.h>

Get the version of the current file.
If file=NULL, it means return the version of the current active file.
This function will return a four digits value.
the front two means the annual version. The last two means the upgrade. Like:
1800 means ZW3D 2014
1810 means ZW3D 2014 SP
1900 means ZW3D 2015
1910 means ZW3D 2015 SP
......

Parameters
[in] | file | full file path
[out] | version | version number
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlatPatternExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxPartSmdFlatPatternExport()

evxErrors cvxPartSmdFlatPatternExport | ( | int | idFlatten,
 |  | const vxLongPath | filePath,
 |  | const svxDWGData * | data
 | ) |  |

#include <zwapi_file.h>

Exports the specified flat pattern to specified path. This function can only export *.dwg/*.dxf files.

Note
Interface cvxFileExportInit(VX_EXPORT_TYPE_DWG,0,data) can initialize variables of this function.
Parameters
[in] | idFlatten | id of flatten
[in] | filePath | file path
[in] | data | data of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlatSolidExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxPartSmdFlatSolidExport()

evxErrors cvxPartSmdFlatSolidExport | ( | int | idFlatten,
 |  | evxExportType | type,
 |  | const vxLongPath | filePath,
 |  | void * | data
 | ) |  |

#include <zwapi_file.h>

Exports the specified flat solid to specified path.
If the Type is VX_EXPORT_TYPE_IMG, the data is defined by struct svxImgData,
else if the Type is VX_EXPORT_TYPE_PDF, the data is defined by struct svxPdfData,
else if the Type is VX_EXPORT_TYPE_GRP, the data is svxGRPData(can be ignored),
else if the Type is VX_EXPORT_TYPE_DWG, the data is svxDWGData.
else if the Type is VX_EXPORT_TYPE_IGES, the data is svxIGESData.
else if the Type is VX_EXPORT_TYPE_STEP, the data is svxSTEPData.
else if the Type is VX_EXPORT_TYPE_JT, the data is svxJTData.
else if the Type is VX_EXPORT_TYPE_PARA_TEXT, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_PARA_BINARY, the data is svxPARAData.
else if the Type is VX_EXPORT_TYPE_CAT5_PART, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_CAT5_ASM, the data is svxCAT5Data.
else if the Type is VX_EXPORT_TYPE_HTML, the data is svxHTMLData.

Parameters
[in] | idFlatten | id of flatten
[in] | type | export type
[in] | filePath | file path
[in] | data | data of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSessionClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxSessionClear()

evxErrors cvxSessionClear ( void )

#include <zwapi_file.h>

Clears the active session.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSessionRestore

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxSessionRestore()

evxErrors cvxSessionRestore ( void )

#include <zwapi_file.h>

Restores the last session backup.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSessionSave

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxSessionSave()

evxErrors cvxSessionSave ( void )

#include <zwapi_file.h>

Saves the active session.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUDFFileInqAssociatedList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxUDFFileInqAssociatedList()

evxErrors cvxUDFFileInqAssociatedList | ( | const vxPath | path,
 |  | const vxPath | file,
 |  | int * | count,
 |  | vxPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get the associated file list of the specified UDF file.

The calling procedure MUST deallocate the output fileList with cvxMemFree().

Note
This function will open the UDF file in the memory if it doesn't locate before, you can use cvxFileSessionClear() to remove it form the cache.
Parameters
[in] | path | file path(NULL to use default path)
[in] | file | file name(contains the file extension)
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxUDFFileInqAssociatedListByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ cvxUDFFileInqAssociatedListByLongPath()

evxErrors cvxUDFFileInqAssociatedListByLongPath | ( | const vxLongPath | path,
 |  | const vxLongPath | file,
 |  | int * | count,
 |  | vxLongPath ** | fileList
 | ) |  |

#include <zwapi_file.h>

Get the associated file list of the specified UDF file.

The calling procedure MUST deallocate the output fileList with cvxMemFree().

Note
This function will open the UDF file in the memory if it doesn't locate before, you can use cvxFileSessionClear() to remove it form the cache.
Parameters
[in] | path | file path(NULL to use default path)
[in] | file | file name(contains the file extension)
[out] | count | number of files in list
[out] | fileList | list of files
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: File Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
File Data
File

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of File and Path functions.

File New Data

enum evxFileType {
VX_FILE_ALL = 0 , VX_FILE_PART = 1 , VX_FILE_ASSEMBLY , VX_FILE_SHEET ,
VX_FILE_SKETCH , VX_FILE_CAMPLAN
}
file type More...
enum evxFileSubtype {
VX_SUBTYPE_NONE = 0 , VX_NORMAL_PART , VX_ECAD_BOARD_PART , VX_NORMAL_ASSEMBLY ,
VX_ECAD_ASSEMBLY , VX_ROUTING_ASSEMBLY , VX_SMD_PART , VX_HARNESS_ASSEMBLY ,
VX_HARNESS_PART , VX_MASTERLAYOUT_PART
}
file sub-type More...
typedef enum evxFileType | evxFileType
file type
typedef enum evxFileSubtype | evxFileSubtype
file sub-type

File Import/Export Data

enum evxImgColorMode {
VX_EXPORT_IMG_COLOR_MODE_24BITS = 0 , VX_EXPORT_IMG_COLOR_MODE_8BITS = 1 , VX_EXPORT_IMG_COLOR_MODE_COlORIZED = 0 , VX_EXPORT_IMG_COLOR_MODE_MONOCHROME = 2 ,
VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE = 3
}
export image color mode More...
enum | evxImgBkgndMode { VX_EXPORT_IMG_BKGND_MODE_CURRENT = 0 , VX_EXPORT_IMG_BKGND_MODE_CUSTOM }
export image background mode More...
enum | evxImgRangeMode { VX_EXPORT_IMG_RANGE_MODE_NORMAL = 0 , VX_EXPORT_IMG_RANGE_MODE_EXTENTS , VX_EXPORT_IMG_RANGE_MODE_CUSTOM }
export image range mode More...
enum evxImgType {
VX_EXPORT_IMG_TYPE_BMP = 1 , VX_EXPORT_IMG_TYPE_GIF , VX_EXPORT_IMG_TYPE_PNG , VX_EXPORT_IMG_TYPE_TIFF ,
VX_EXPORT_IMG_TYPE_JPEG
}
export image type More...
enum | evxPdfType { VX_EXPORT_PDF_TYPE_RASTER = 1 , VX_EXPORT_PDF_TYPE_VECTOR , VX_EXPORT_PDF_TYPE_OBJECT }
export pdf type More...
enum | evxPdfRangeMode { VX_EXPORT_PDF_RANGE_MODE_NORMAL = 0 , VX_EXPORT_PDF_RANGE_MODE_EXTENTS , VX_EXPORT_PDF_RANGE_MODE_CUSTOM }
export pdf range mode More...
enum evxDWGVer {
VX_DWG_VERSION_2018 = 1 , VX_DWG_VERSION_2013 = 2 , VX_DWG_VERSION_2010 = 3 , VX_DWG_VERSION_2007 ,
VX_DWG_VERSION_2004 , VX_DWG_VERSION_2000 , VX_DWG_VERSION_R14 , VX_DWG_VERSION_R13 ,
VX_DWG_VERSION_R11_R12
}
version of DWG More...
enum evxExportExcludeWidthStyle {
VX_EXCLUDE_WIDTH_STYLE_1 = 0x1 , VX_EXCLUDE_WIDTH_STYLE_2 = 0x2 , VX_EXCLUDE_WIDTH_STYLE_3 = 0x4 , VX_EXCLUDE_WIDTH_STYLE_4 = 0x8 ,
VX_EXCLUDE_WIDTH_STYLE_5 = 0x10
}
exclude attribute(no color) of *.dwg/*.dxf More...
enum evxExportExcludeColor {
VX_EXCLUDE_COLOR_GREEN = 0x1 , VX_EXCLUDE_COLOR_RED = 0x2 , VX_EXCLUDE_COLOR_BROWN = 0x4 , VX_EXCLUDE_COLOR_GOLDENROD = 0x8 ,
VX_EXCLUDE_COLOR_MED_BLUE = 0x10 , VX_EXCLUDE_COLOR_DARK_MAGENTA = 0x20 , VX_EXCLUDE_COLOR_DARK_GREY = 0x40 , VX_EXCLUDE_COLOR_DARK_BLUE = 0x80 ,
VX_EXCLUDE_COLOR_VIOLET = 0x100 , VX_EXCLUDE_COLOR_LIGHT_GREEN = 0x200 , VX_EXCLUDE_COLOR_LIGHT_BLUE = 0x400 , VX_EXCLUDE_COLOR_ROSE = 0x800 ,
VX_EXCLUDE_COLOR_LIGHT_MAGENTA = 0x1000 , VX_EXCLUDE_COLOR_LIGHT_GREY = 0x2000 , VX_EXCLUDE_COLOR_WHITE = 0x4000
}
exclude attribute(color) of *.dwg/*.dxf More...
enum | evxRemoveTextFontType { VX_TEXT_FONT_TYPE_NONE = 0 , VX_TEXT_FONT_TYPE_ALL = 1 , VX_TEXT_FONT_TYPE_EXCLUDE = 2 }
remove text font info type. More...
enum evxJTVer {
VX_JT_VER_6_4 , VX_JT_VER_7_0 , VX_JT_VER_8_0 , VX_JT_VER_8_1 ,
VX_JT_VER_8_2 , VX_JT_VER_8_3 , VX_JT_VER_9_0 , VX_JT_VER_9_1 ,
VX_JT_VER_9_2 , VX_JT_VER_9_3 , VX_JT_VER_9_4 , VX_JT_VER_9_5 ,
VX_JT_VER_10_0 , VX_JT_VER_10_1 , VX_JT_VER_10_2 , VX_JT_VER_10_3 ,
VX_JT_VER_10_4
}
version of JT More...
enum | evxDWGDXFConvertMeshTo { VX_DWGDXF_MESHTO_STL_BLOCKS = 1 , VX_DWGDXF_MESHTO_LINES = 2 , VX_DWGDXF_MESHTO_PLANAR_FACES = 3 }
dwg dxf file import of convert polygon mesh to More...
enum evxDWGDXFExcludeColor {
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED = 0x1 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN = 0x2 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE = 0x4 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW = 0x8 ,
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA = 0x10 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN = 0x20 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE = 0x40
}
import dwg dxf file, exclude color More...
enum evxImportType {
VX_IMPORT_TYPE_ALL = 0 , VX_IMPORT_TYPE_PARASOLID = 1 , VX_IMPORT_TYPE_DWG_DXF = 2 , VX_IMPORT_TYPE_STEP ,
VX_IMPORT_TYPE_SAT , VX_IMPORT_TYPE_IGES , VX_IMPORT_TYPE_CATIA4 , VX_IMPORT_TYPE_CATIA5 ,
VX_IMPORT_TYPE_INVENTOR , VX_IMPORT_TYPE_JT , VX_IMPORT_TYPE_PROE_CERO , VX_IMPORT_TYPE_SOLIDEDGE ,
VX_IMPORT_TYPE_SOLIDWORKS , VX_IMPORT_TYPE_UG , VX_IMPORT_TYPE_STL , VX_IMPORT_TYPE_GPH ,
VX_IMPORT_PTS_FROM_FILE
}
file import type More...
enum evxDWGDXFReadAsUnits {
VX_UNIT_DWGDXF_INCHES = 1 , VX_UNIT_DWGDXF_FEET = 2 , VX_UNIT_DWGDXF_MILES = 3 , VX_UNIT_DWGDXF_MILIMETERS = 4 ,
VX_UNIT_DWGDXF_CENTIMETERS = 5 , VX_UNIT_DWGDXF_METERS = 6 , VX_UNIT_DWGDXF_KILOMETERS = 7 , VX_UNIT_DWGDXF_MICROINCHES = 8 ,
VX_UNIT_DWGDXF_MILS = 9 , VX_UNIT_DWGDXF_YARDS = 10 , VX_UNIT_DWGDXF_ANGSTROMS = 11 , VX_UNIT_DWGDXF_NANOMETERS = 12 ,
VX_UNIT_DWGDXF_MICRONS = 13 , VX_UNIT_DWGDXF_DECIMETERS = 14 , VX_UNIT_DWGDXF_DEKAMETERS = 15 , VX_UNIT_DWGDXF_HECTOMETERS = 16 ,
VX_UNIT_DWGDXF_GIGAMETERS = 17 , VX_UNIT_DWGDXF_ASTRONOMICAL = 18 , VX_UNIT_DWGDXF_LIGHTYEARS = 19 , VX_UNIT_DWGDXF_PARSECS = 20
}
dwg dxf import options of read as units More...
enum | evxPTSHistoryType { VX_PTS_HISTORY_SUBPART = 0 , VX_PTS_HISTORY_BACKUP = 1 , VX_PTS_HISTORY_ENCAPSULATE = 2 , VX_PTS_HISTORY_NOBACKUP = 3 }
operation type stored in part's history More...
enum evxExportType {
VX_EXPORT_TYPE_IMG = 1 , VX_EXPORT_TYPE_PDF , VX_EXPORT_TYPE_GRP , VX_EXPORT_TYPE_DWG ,
VX_EXPORT_TYPE_IGES , VX_EXPORT_TYPE_STEP , VX_EXPORT_TYPE_JT , VX_EXPORT_TYPE_PARA_TEXT ,
VX_EXPORT_TYPE_PARA_BINARY , VX_EXPORT_TYPE_CAT5_PART , VX_EXPORT_TYPE_CAT5_ASM , VX_EXPORT_TYPE_HTML ,
VX_EXPORT_TYPE_STL , VX_EXPORT_TYPE_OBJ
}
export file type More...
enum evxExportExcludeGeom {
VX_EXCLUDE_CURVE = 0x1 , VX_EXCLUDE_SURFACE = 0x2 , VX_EXCLUDE_SOLID = 0x4 , VX_EXCLUDE_PLANE = 0x8 ,
VX_EXCLUDE_HATCH = 0x10 , VX_EXCLUDE_DIMEN = 0x20 , VX_EXCLUDE_TEXT = 0x40 , VX_EXCLUDE_BLANKED = 0x80
}
export exclude geometry More...
enum _evxDocAction {
VX_DOC_CREATED = 0 , VX_DOC_SAVING , VX_DOC_SAVED , VX_DOC_PRECHANGE ,
VX_DOC_CHANGED , VX_DOC_PREOPEN , VX_DOC_OPENED , VX_DOC_TITLEUPDATE
}
file action type More...
typedef enum evxImgColorMode | evxImgColorMode
export image color mode
typedef enum evxImgBkgndMode | evxImgBkgndMode
export image background mode
typedef enum evxImgRangeMode | evxImgRangeMode
export image range mode
typedef enum evxImgType | evxImgType
export image type
typedef enum evxPdfType | evxPdfType
export pdf type
typedef enum evxPdfRangeMode | evxPdfRangeMode
export pdf range mode
typedef struct svxImgData | svxImgData
data of export image file
typedef struct svxPdfData | svxPdfData
data of export pdf file
typedef struct svxSTLData | svxSTLData
data of export STL file
typedef enum evxDWGVer | evxDWGVer
version of DWG
typedef struct svxGRPData | svxGRPData
data of export GRP file
typedef enum evxExportExcludeWidthStyle | evxExportExcludeWidthStyle
exclude attribute(no color) of *.dwg/*.dxf
typedef enum evxExportExcludeColor | evxExportExcludeColor
exclude attribute(color) of *.dwg/*.dxf
typedef enum evxRemoveTextFontType | evxRemoveTextFontType
remove text font info type.
typedef struct svxDWGData | svxDWGData
data of export DWG file
typedef struct svxIGESData | svxIGESData
data of export IGEES file
typedef struct svxSTEPData | svxSTEPData
data of export STEP file
typedef enum evxJTVer | evxJTVer
version of JT
typedef struct svxJTData | svxJTData
data of export JT file
typedef struct svxPARAData | svxPARAData
data of export PARA file
typedef struct svxCAT5Data | svxCAT5Data
data of export CAT5 file
typedef struct svxHTMLData | svxHTMLData
data of export HTML file
typedef enum evxDWGDXFConvertMeshTo | evxDWGDXFConvertMeshTo
dwg dxf file import of convert polygon mesh to
typedef enum evxDWGDXFExcludeColor | evxDWGDXFExcludeColor
import dwg dxf file, exclude color
typedef enum evxImportType | evxImportType
file import type
typedef struct svxImportSTEPData | svxImportSTEPData
setting general properties if import stp/step file
typedef struct svxImportUGData | svxImportUGData
setting properties if import prt file
typedef enum evxDWGDXFReadAsUnits | evxDWGDXFReadAsUnits
dwg dxf import options of read as units
typedef struct svxImportDwgDxfData | svxImportDwgDxfData
setting properties if import dwg/dxf file
typedef struct svxImportSTLData | svxImportSTLData
setting properties if import stl file
typedef enum evxPTSHistoryType | evxPTSHistoryType
operation type stored in part's history
typedef struct svxImportPTSData | svxImportPTSData
setting properties if import points form ASCII file
typedef struct svxImportData | svxImportData
file import data
typedef struct svxOBJData | svxOBJData
data of export obj file
typedef enum evxExportType | evxExportType
export file type
typedef enum evxExportExcludeGeom | evxExportExcludeGeom
export exclude geometry
typedef enum _evxDocAction | evxDocAction
file action type
typedef struct svxDocActionParam | svxDocActionParam
file action parameters
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Path Operation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Path Operation
File

Detailed Description

THE MODULE FOR THE ZW3D Path API

Path Add

evxErrors | cvxPathAdd (const vxLongPath SearchDirectory)
evxErrors | cvxPathSearchBeginAdd (const vxLongPath SearchDirectory)
evxErrors | cvxPathAddApiPath (vxName LibName, char *SubFolder)
evxErrors | cvxPathCompose (vxPath Path, const char *Name)
evxErrors | cvxPathComposeByLongPath (char *Path, int sizePath, const char *Name)
evxErrors | cvxPathCheck (const vxLongPath srcPath, char *desPath, int sizedes)

Path Set

evxErrors | cvxPathSet (const vxLongPath path)
void | cvxPathSearchFirst (const vxLongPath Directory)

Path Delete

void | cvxPathDel (const vxLongPath Path)
void | cvxPathDelAll (void)
void | cvxPathDelim (vxPath Path)
void | cvxPathDelimByLongPath (char *Path, int sizePath)

Path Query

int | cvxPathApiLib (vxName LibName, vxPath LibDirectory)
int | cvxPathApiLibByLongPath (const vxName LibName, char *LibDirectory, int sizeLib)
void | cvxPathDir (vxPath FullPath, vxPath Directory)
void | cvxPathDirByLongPath (const vxLongPath FullPath, char *Directory, int sizeDir)
void | cvxPathFile (vxPath FullPath, vxPath FileName)
void | cvxPathFileByLongPath (const vxLongPath FullPath, char *FileName, int sizeFile)
void | cvxPathFile2 (char *FullPath, int MaxNameLen, char *FileName)
int | cvxPathFind (const vxName FileName, vxPath FullPath)
int | cvxPathFindByLongPath (const vxName FileName, char *FullPath, int sizeFull)
int | cvxPathFindByFileName (const char *fileName, char *fullPath, int sizeFullPath)
void | cvxPathInstall (vxPath InstallDirectory)
void | cvxPathInstallByLongPath (char *InstallDirectory, int sizeIns)
void | cvxPathTemp (vxPath Directory)
void | cvxPathTempByLongPath (char *Directory, int sizeDir)
void | cvxPathUserFolder (vxPath Directory)
void | cvxPathUserFolderByLongPath (char *Directory, int sizeDir)
int | cvxPathIsDebug (const char *FolderName)

Path State Get/Set

void | cvxPathSearchSet (int Value)
int | cvxPathSearchGet ()
void | cvxPathCheckActiveOnlySet (int Value)
int | cvxPathCheckActiveOnlyGet ()
evxErrors | cvxFileNameLenIsOverrange (const char *file_name)
evxErrors | cvxFilePathLenIsOverrange (const char *file_path)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFileNameLenIsOverrange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxFileNameLenIsOverrange()

evxErrors cvxFileNameLenIsOverrange ( const char * file_name )

#include <zwapi_file_path.h>

Check if the length of file name is over ranging.

Parameters
[in] file_name name to check
Return values
succeeds
  • ZW_API_NO_ERROR - name is ok
fails
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_NAME_LEN_OVER_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilePathLenIsOverrange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxFilePathLenIsOverrange()

evxErrors cvxFilePathLenIsOverrange ( const char * file_path )

#include <zwapi_file_path.h>

Check if the length of file path is over ranging.

Parameters
[in] file_path path to check
Return values
succeeds
  • ZW_API_NO_ERROR - path is ok
fails
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_PATH_LEN_OVER_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathAdd()

evxErrors cvxPathAdd ( const vxLongPath SearchDirectory )

#include <zwapi_file_path.h>

Adds the specified file directory to the list of search paths.
These paths are used to find files specified by name only.
The search path added by this interface is used to search resource files

Only when the file path is found through the interface cvxPathFindByFileName(),
the file will be searched from these search directories.

Use interface cvxPathCheck to judge whether the input path is correct.

See also
cvxPathSet() can be used to search drawing files(.Z3,.Z3PRT,.Z3DRW...).
Parameters
[in] SearchDirectory directory pathname
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathAddApiPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathAddApiPath()

evxErrors cvxPathAddApiPath | ( | vxName | LibName,
 |  | char * | SubFolder
 | ) |  |

#include <zwapi_file_path.h>

Logs the specified sub-folder of the "apilibs" directory that contains the specified DLL (LibName) to the list of ZW3D search paths.
It is assumed that the sub-folder name or path is defined relative to the "apilibs" directory.

If "SubFolder" is input as NULL, the path to "apilibs" is added to the ZW3D search paths.
"SubFolder" should not begin with a path delimiter.

Parameters
[in] | LibName | library name (without .dll extension)
[in] | SubFolder | sub-folder name or path (NULL if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathApiLib

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathApiLib()

int cvxPathApiLib | ( | vxName | LibName,
 |  | vxPath | LibDirectory
 | ) |  |

#include <zwapi_file_path.h>

Gets the path of the "apilibs" directory that contains the specified API library.
It is assumed the library resides in a sub-directory named "apilibs" either in the runtime user directory or in the ZW3D installation directory.
The local "apilibs" is checked first, then the "apilibs" in the installation directory.

Parameters
[in] | LibName | library name (without .dll extension)
[out] | LibDirectory | path of directory that contains the library
Return values
return
  • 1 - if the library is found
  • 0 - if not found or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathApiLibByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathApiLibByLongPath()

int cvxPathApiLibByLongPath | ( | const vxName | LibName,
 |  | char * | LibDirectory,
 |  | int | sizeLib
 | ) |  |

#include <zwapi_file_path.h>

Gets the path of the "apilibs" directory that contains the specified API library. It is assumed the library resides in a sub-directory named "apilibs" either in the runtime user directory or in the ZW3D installation directory. The local "apilibs" is checked first, then the "apilibs" in the installation directory.

A LibDirectory that is too long (longer than "sizeLib") is truncated.

It is assumed that the input "LibDirectory" is no longer than 512 bytes.

Parameters
[in] | LibName | library name (without .dll extension)
[out] | LibDirectory | path of directory that contains the library
[in] | sizeLib | max size of LibDirectory
Return values
return
  • 1 - if the library is found
  • 0 - if not found or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathCheck()

evxErrors cvxPathCheck | ( | const vxLongPath | srcPath,
 |  | char * | desPath,
 |  | int | sizedes
 | ) |  |

#include <zwapi_file_path.h>

1. Check the input path to see if it is properly formatted for the target OS.
   Forward or backward slashes are replaced with the appropriate path delimiter for the operating system.
   D:/aa/bb <==> D:\aa\bb

2. If the file name containing the path is passed in, the file path is output.
   D:\aa\bb\cc.Z3PRT  ==> D:\aa\bb

3. Occurrences of ~ expand to the current user's home directory path, and
occurrences of ~user expand to the current user's profile directory path.
   ~user\aa  ==>  %USERPROFILE%\aa
   ~\aa  ==>  %HOME%\aa
   $path\bb  ==> (the directory represented by the system environment variable "path")\bb  <==> %path%\bb

4. The directory is verified to exist and to be accessible. If srcPath specifies the path to a file,
the file is also required to exist and to be accessible.

A desPath that is too long (longer than "sizedes") is truncated.

It is assumed that the input "desPath" is no longer than 512 bytes.
Parameters
[in] | srcPath | path to a file or directory
[out] | desPath | directory part of srcPath
[int] | sizedes max size of desPath
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathCheckActiveOnlyGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathCheckActiveOnlyGet()

int cvxPathCheckActiveOnlyGet ( )

#include <zwapi_file_path.h>

Get the VgCheckActivePathOnly.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathCheckActiveOnlySet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathCheckActiveOnlySet()

void cvxPathCheckActiveOnlySet ( int Value )

#include <zwapi_file_path.h>

Set the VgCheckActivePathOnly.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathCompose

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathCompose()

evxErrors cvxPathCompose | ( | vxPath | Path,
 |  | const char * | Name
 | ) |  |

#include <zwapi_file_path.h>

Combines the input directory name (Path) and file name (Name). Outputs the result via "Path".

See also
cvxPathCheck() can check whether the path is correct.
cvxFileExits() can determine whether a file exists.
Parameters
[in,out] | Path | directory where file is located output directory/file path
[in] | Name | filename
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR - pathname is too long
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathComposeByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathComposeByLongPath()

evxErrors cvxPathComposeByLongPath | ( | char * | Path,
 |  | int | sizePath,
 |  | const char * | Name
 | ) |  |

#include <zwapi_file_path.h>

Combines the input directory name (Path) and file name (Name). Outputs the result via "Path".

See also
cvxPathCheck() can check whether the path is correct.
cvxFileExits() can determine whether a file exists.
Parameters
[in,out] | Path | directory where file is located output directory/file path
[in] | sizePath | Maximum memory space for "Path".
[in] | Name | filename
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDel()

void cvxPathDel ( const vxLongPath Path )

#include <zwapi_file_path.h>

Deletes the specified path from the current list of search paths. No error is logged if the path doesn't exist.

Parameters
[in] Path file search pathname
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDelAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDelAll()

void cvxPathDelAll ( void )

#include <zwapi_file_path.h>

Deletes all paths from the current list of search paths.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDelim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDelim()

void cvxPathDelim ( vxPath Path )

#include <zwapi_file_path.h>

If "Path" does not end with the path delimiter, appends the delimiter.
It is assumed that the memory referenced by "Path" is sufficient to accommodate addition of another character.

Parameters
[in,out] Path file pathname
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDelimByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDelimByLongPath()

void cvxPathDelimByLongPath | ( | char * | Path,
 |  | int | sizePath
 | ) |  |

#include <zwapi_file_path.h>

If "Path" does not end with the path delimiter, appends the delimiter. It is assumed that the memory referenced by "Path" is sufficient to accommodate addition of another character.

Parameters
[in,out] | Path | file pathname
[in] | sizePath | Maximum memory space for "Path".
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDir()

void cvxPathDir | ( | vxPath | FullPath,
 |  | vxPath | Directory
 | ) |  |

#include <zwapi_file_path.h>

Extracts the directory portion of the specified physical path.
If there is no directory specified, outputs "./".

Parameters
[in] | FullPath | full path/file name
[out] | Directory | directory portion of "FullPath"
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathDirByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathDirByLongPath()

void cvxPathDirByLongPath | ( | const vxLongPath | FullPath,
 |  | char * | Directory,
 |  | int | sizeDir
 | ) |  |

#include <zwapi_file_path.h>

Extracts the directory portion of the specified physical path. If there is no directory specified, outputs "./".

Parameters
[in] | FullPath | full path/file name
[out] | Directory | directory portion of "FullPath"
[in] | sizeDir | max size of Directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp, and part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFile()

void cvxPathFile | ( | vxPath | FullPath,
 |  | vxPath | FileName
 | ) |  |

#include <zwapi_file_path.h>

Extracts the filename portion of the specified physical path.
The filename may include an extension, if there is one.

Outputs FileName[0]=0 if a filename could not be extracted or if its length exceeds the size of a "vxPath" string.

Use cvxPathFile2() to extract a file name that may be longer than "vxName".

Parameters
[in] | FullPath | full path/file name
[out] | FileName | filename portion of "FullPath"
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFile2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFile2()

void cvxPathFile2 | ( | char * | FullPath,
 |  | int | MaxNameLen,
 |  | char * | FileName
 | ) |  |

#include <zwapi_file_path.h>

Extracts the filename portion of the specified physical path.
The filename may include an extension, if there is one.

Outputs FileName[0]=0 if a filename could not be extracted or if its length (including the null-terminator) exceeds the size of "MaxNameLen".

It is assumed "FileName" references at least "MaxNameLen" bytes of memory.

Parameters
[in] | FullPath | full path/file name
[in] | MaxNameLen | maximum name length in bytes (including null-terminator)
[out] | FileName | filename portion of "FullPath"
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFileByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFileByLongPath()

void cvxPathFileByLongPath | ( | const vxLongPath | FullPath,
 |  | char * | FileName,
 |  | int | sizeFile
 | ) |  |

#include <zwapi_file_path.h>

Extracts the filename portion of the specified physical path.
The filename may include an extension, if there is one.

Outputs FileName[0]=0 if a filename could not be extracted

A FileName that is too long (longer than "sizeFile") is truncated.

It is assumed that the input "FileName" is no longer than 512 bytes.

Parameters
[in] | FullPath | full path/file name
[out] | FileName | filename portion of "FullPath"
[in] | sizeFile | max size of filename
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp, part\shapeFtrCrtTest.cpp, and part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFind()

int cvxPathFind | ( | const vxName | FileName,
 |  | vxPath | FullPath
 | ) |  |

#include <zwapi_file_path.h>

Given a filename without any directory path (FileName), this function searches default paths for the file and outputs a complete pathname to the file.

Note
When the ZW3D filename exceeds 32bytes,using this function causes ZW3D crashed.
Therefore,this function will be deprecated in the future and is not recommended for use by customers.
User can replace this function with the cvxPathFindByFileName().
Parameters
[in] | FileName | file name
[out] | FullPath | full path to the specified file
Return values
return
  • 1 - if the file is found
  • 0 - if not found or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFindByFileName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFindByFileName()

int cvxPathFindByFileName | ( | const char * | fileName,
 |  | char * | fullPath,
 |  | int | sizeFullPath
 | ) |  |

#include <zwapi_file_path.h>

Given a filename without any directory path (FileName), this function searches default paths for the file and outputs a complete pathname to the file.

Parameters
[in] | fileName | file name
[out] | fullPath | full path to the specified file
[in] | sizeFullPath | max size of fullPath
Return values
return
  • 2 if the file is found and saved;
  • 1 if the file is found but never saved;
  • 0 if not found;
fail
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathFindByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathFindByLongPath()

int cvxPathFindByLongPath | ( | const vxName | FileName,
 |  | char * | FullPath,
 |  | int | sizeFull
 | ) |  |

#include <zwapi_file_path.h>

Given a filename without any directory path (FileName), this function searches default paths for the file and outputs a complete pathname to the file.

Note
When the ZW3D filename exceeds 32bytes,using this function causes ZW3D crashed.
Therefore,this function will be deprecated in the future and is not recommended for use by customers.
User can replace this function with the cvxPathFindByFileName().
Parameters
[in] | FileName | file name
[out] | FullPath | full path to the specified file
Return values
return
  • 1 - if the file is found
  • 0 - if not found or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathInstall

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathInstall()

void cvxPathInstall ( vxPath InstallDirectory )

#include <zwapi_file_path.h>

Outputs the path of the ZW3D installation directory.

Parameters
[out] InstallDirectory installation directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathInstallByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathInstallByLongPath()

void cvxPathInstallByLongPath | ( | char * | InstallDirectory,
 |  | int | sizeIns
 | ) |  |

#include <zwapi_file_path.h>

Outputs the path of the ZW3D installation directory.

A InstallDirectory that is too long (longer than "sizeIns") is truncated.

It is assumed that the input "InstallDirectory" is no longer than 512 bytes.

Parameters
[out] | InstallDirectory | installation directory
[int] | sizeIns max size of InstallDirectory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathIsDebug

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathIsDebug()

int cvxPathIsDebug ( const char * FolderName )

#include <zwapi_file_path.h>

Check whether current environment is debug/release based on the name of folder where zw3d.exe resides in.

Parameters
[in] FolderName name of folder where zw3d.exe resides in
Return values
return
  • 1 - if the folder name contains Debug/Debugx64/Release/Releasex64,
  • 0 - otherwise .
Warning
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathSearchBeginAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathSearchBeginAdd()

evxErrors cvxPathSearchBeginAdd ( const vxLongPath SearchDirectory )

#include <zwapi_file_path.h>

Adds the specified file directory to the begin of list of search paths. These paths are used to find files specified by name only. The search path added by this interface is used to search resource files

Only when the file path is found through the interface cvxPathFindByFileName(), the file will be searched from these search directories.

Use interface cvxPathCheck to judge whether the input path is correct.

See also
cvxPathSet() can be used to search drawing files(.Z3,.Z3PRT,.Z3DRW...).
Parameters
[in] SearchDirectory directory pathname
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathSearchFirst

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathSearchFirst()

void cvxPathSearchFirst ( const vxLongPath Directory )

#include <zwapi_file_path.h>

Causes ZW3D to search the input directory before searching the directories listed in "vxpaths".

See also
cvxPathSet: The search path of the format file supported by ZW3D.
cvxPathAdd: Add search paths for some resource files. Customers are not recommended to use this interface.
cvxPathSearchFirst: Set the search path temporarily. The path set through this interface is easy to be overwritten.Therefore, the path set by this interface is recommended to be used only once.
Parameters
[in] Directory directory pathname
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathSearchGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathSearchGet()

int cvxPathSearchGet ( )

#include <zwapi_file_path.h>

Get the VgSearchPath.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathSearchSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathSearchSet()

void cvxPathSearchSet ( int Value )

#include <zwapi_file_path.h>

Set the VgSearchPath.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathSet()

evxErrors cvxPathSet ( const vxLongPath path )

#include <zwapi_file_path.h>

Add specified path to directory search conducted by DmPathFind and resave search paths.

This interface corresponds to the file->search paths... function of the platform.

Note
When option(Vx.AutoRecordPaths=1) is checked, the interface can add a search path.
Otherwise, the function of the interface is the same as that of the interface cvxPathSearchFirst().
Use interface cvxPathCheck to judge whether the input path is correct.
cvxConfigGetYesNo("Vx.AutoRecordPaths",&YesNo);
cvxConfigSetYesNo("Vx.AutoRecordPaths",YesNo);
cvxConfigGetYesNo
evxErrors cvxConfigGetYesNo(const char *Name, int *YesNo)
cvxConfigSetYesNo
evxErrors cvxConfigSetYesNo(const char *Name, int YesNo)
Parameters
[in] path pathname
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathTemp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathTemp()

void cvxPathTemp ( vxPath Directory )

#include <zwapi_file_path.h>

Outputs the path of the ZW3D "temp" directory for the active session.

Parameters
[out] Directory ZW3D temp directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathTempByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathTempByLongPath()

void cvxPathTempByLongPath | ( | char * | Directory,
 |  | int | sizeDir
 | ) |  |

#include <zwapi_file_path.h>

Outputs the path of the ZW3D "temp" directory for the active session.

A Directory that is too long (longer than "sizeDir") is truncated.

It is assumed that the input "Directory" is no longer than 512 bytes.

Parameters
[out] | Directory | ZW3D temp directory
[in] | sizeDir | max size of Directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathUserFolder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathUserFolder()

void cvxPathUserFolder ( vxPath Directory )

#include <zwapi_file_path.h>

Get user folder path of ZW3D.

Parameters
[out] Directory user path
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPathUserFolderByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Path Operation
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ cvxPathUserFolderByLongPath()

void cvxPathUserFolderByLongPath | ( | char * | Directory,
 |  | int | sizeDir
 | ) |  |

#include <zwapi_file_path.h>

Get user folder path of ZW3D.

A Directory that is too long (longer than "sizeDir") is truncated.

It is assumed that the input "Directory" is no longer than 512 bytes.

Parameters
[out] | Directory | user path
[in] | sizeDir | max size of Directory
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Part Objects

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Part Objects

Detailed Description

Modules

Part Attribute
Part Configuration
Part Data
Datum Query
Part Dimension API
Part Facets/Block
History API
Hole Attribute
Part Objects API
Part Objects Operation
Sheet Metal Attribute
Part Variable API
Part View API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Part Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Attribute
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Attribute API

Part Physical Attribute

evxErrors | cvxPartMassProp (void)
evxErrors | cvxPartCalcAttrGet (int idPart, svxPartCalcAttrData *attr)
evxErrors | cvxPartPhyAttrCalc (vxRootName Name)
evxErrors | cvxPartVolumAndMassGet (vxRootName Name, double *dVolume, double *dMass)
evxErrors | cvxPartMaterialGet (const vxLongPath fileName, const vxRootName rootName, const vxLongName material, svxPartMaterial *data)
evxErrors | cvxPartMaterialSet (const vxLongPath fileName, const vxRootName rootName, const vxLongName material, const svxPartMaterial *data)
evxErrors | cvxPartMaterialDel (const vxLongPath fileName, const vxRootName rootName, const vxLongName material)

Part Attribute

evxErrors | cvxPartAtGet (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartAtMod (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartAtSet (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartShowPartAt (const vxLongPath File, const vxRootName Root)
void | cvxPartClosePartAt ()
evxErrors | cvxPartAtItemGet (evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemSet (evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemGetInFile (const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemSetInFile (const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemDel (evxAtItemId itemId, vxLongName label)
evxErrors | cvxPartAtItemDesGet (evxAtItemId itemId, char *AtLable, char *AtDes, int nBytes)
evxErrors | cvxPartAtItemDesSet (evxAtItemId itemId, char *AtLable, char *AtDes)
evxErrors | cvxPartAtItemLockGet (char *AtLable, evxAtItemLockStatus *AtLockState)
evxErrors | cvxPartAtItemLockSet (char *AtLable, evxAtItemLockStatus AtLockState)
evxErrors | cvxPartAtItemLockGetInFile (const vxLongPath File, const vxRootName Root, char *AtLable, evxAtItemLockStatus *AtLockState)
evxErrors | cvxPartAtItemLockSetInFile (const vxLongPath File, const vxRootName Root, const char *AtLable, evxAtItemLockStatus AtLockState)
evxErrors | cvxPartUserAtGet (const vxLongPath File, const vxRootName Root, int *Count, svxAttribute **UserAt)
evxErrors | cvxPartUserAtSet (const vxLongPath File, const vxRootName Root, int DelOrgAt, int Count, svxAttribute *UserAt)
evxErrors | cvxPartUserAtExport (const vxLongPath filePath)

Part Custom String

evxErrors | cvxPartSetCustomStr (int idEnt, const char *CustomString, int *idStr)
evxErrors | cvxPartGetCustomStr (int idEnt, int *idStr, char **CustomString)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtGet()

evxErrors cvxPartAtGet | ( | vxRootName | Name,
 |  | svxPartAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Retrieves attribute data from the specified part in the active file.
If "Name" is NULL or an empty string, the active target part is used.

Parameters
[in] | Name | name of part in active file
[out] | At | part attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_eRROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemDel()

evxErrors cvxPartAtItemDel | ( | evxAtItemId | itemId,
 |  | vxLongName | label
 | ) |  |

#include <zwapi_part_attribute.h>

Delete the attribute of specified item.

If the itemId = VX_AT_USER, the label can not be NULL and the attribute will
be delete, otherwise it will set the data of At to NULL.

The itemId includes part items of evxAtItemId(VX_AT_USER~VX_AT_HEIGHT).

Parameters
[in] | itemId | item id
[in] | label | lable of item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemDesGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemDesGet()

evxErrors cvxPartAtItemDesGet | ( | evxAtItemId | itemId,
 |  | char * | AtLable,
 |  | char * | AtDes,
 |  | int | nBytes
 | ) |  |

#include <zwapi_part_attribute.h>

Get the description of the specified attribute item.

If the itemId = VX_AT_USER, the parameter AtLable can not be NULL.
The itemId includes part items of evxAtItemId(VX_AT_USER~VX_AT_HEIGHT).

Parameters
[in] | itemId | attribute item id
[in] | AtLable | attribute item name
[out] | AtDes | attribute item description
[in] | nBytes | string max size of attribute item description
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemDesSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemDesSet()

evxErrors cvxPartAtItemDesSet | ( | evxAtItemId | itemId,
 |  | char * | AtLable,
 |  | char * | AtDes
 | ) |  |

#include <zwapi_part_attribute.h>

Set the description of the specified attribute item.

If the itemId = VX_AT_USER, the parameter AtLable can not be NULL.
The itemId includes part items of evxAtItemId(VX_AT_USER~VX_AT_HEIGHT).

Parameters
[in] | itemId | attribute item id
[in] | AtLable | attribute item name
[in] | AtDes | attribute item description
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemGet()

evxErrors cvxPartAtItemGet | ( | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Outputs the specified attribute from the active part.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must
be assigned to At->label before calling this function. For all other
itemId values, At->label can be an empty string (At->label[0]=0) when
this function is called.

Parameters
[in] | itemId | item id
[in,out] | At | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemGetInFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemGetInFile()

evxErrors cvxPartAtItemGetInFile | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Outputs an attribute from a specified part.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must
be assigned to At->label before calling this function. For all other
itemId values, At->label can be an empty string (At->label[0]=0) when
this function is called.

If the specified file is not already open, this function will open it
to access the attribute, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents cvxPartAtItemSetInFile() and
cvxPartAtItemGetInFile() from closing the files that they open. (Files
that are already open before cvxPartAtItemSetInFile() or
cvxPartAtItemGetInFile() is called are never closed by these functions.)
Keeping files open is a more efficient way to access multiple
attributes in a file, but you must remember to call cvxFileKeep() again
to reset the flag after you have finished your calls to
cvxPartAtItemGetInFile() and cvxPartAtItemSetInFile(), and you also become
responsible for closing the files, for example by using one of the
cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | itemId | item id
[in,out] | At | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemLockGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemLockGet()

evxErrors cvxPartAtItemLockGet | ( | char * | AtLable,
 |  | evxAtItemLockStatus * | AtLockState
 | ) |  |

#include <zwapi_part_attribute.h>

Get the locking state of the specified attribute item.
only custom attribute item are supported.

Parameters
[in] | AtLable | custom attribute name
[out] | AtLockState | locking state of attribute item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemLockGetInFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemLockGetInFile()

evxErrors cvxPartAtItemLockGetInFile | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | char * | AtLable,
 |  | evxAtItemLockStatus * | AtLockState
 | ) |  |

#include <zwapi_part_attribute.h>

Get the locking state of the specified attribute item.
only custom attribute item are supported.

If the specified file is not already open, this function will open it
to access attributes, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep() again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | AtLable | custom attribute name
[out] | AtLockState | locking state of attribute item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemLockSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemLockSet()

evxErrors cvxPartAtItemLockSet | ( | char * | AtLable,
 |  | evxAtItemLockStatus | AtLockState
 | ) |  |

#include <zwapi_part_attribute.h>

Set the locking state of the specified attribute item.
only custom attribute item are supported.

Parameters
[in] | AtLable | custom attribute name
[in] | AtLockState | locking state of attribute item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemLockSetInFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemLockSetInFile()

evxErrors cvxPartAtItemLockSetInFile | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | const char * | AtLable,
 |  | evxAtItemLockStatus | AtLockState
 | ) |  |

#include <zwapi_part_attribute.h>

Set the locking state of the specified attribute item.
only custom attribute item are supported.

If the specified file is not already open, this function will open it
to access attributes, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep() again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | AtLable | custom attribute name
[in] | AtLockState | locking state of attribute item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemSet()

evxErrors cvxPartAtItemSet | ( | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Sets the value of the specified attribute in the active part.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must
be assigned to At->label before calling this function. For all other
itemId values, At->label can be an empty string (At->label[0]=0) when
this function is called.

Parameters
[in] | itemId | item id
[in] | At | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtItemSetInFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtItemSetInFile()

evxErrors cvxPartAtItemSetInFile | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Sets an attribute value in a specified part.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must
be assigned to At->label before calling this function. For all other
itemId values, At->label can be an empty string (At->label[0]=0) when
this function is called.

If the specified file is not already open, this function will open it
to access the attribute, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents cvxPartAtItemSetInFile() and
cvxPartAtItemGetInFile() from closing the files that they open. (Files
that are already open before cvxPartAtItemSetInFile() or
cvxPartAtItemGetInFile() is called are never closed by these functions.)
Keeping files open is a more efficient way to access multiple
attributes in a file, but you must remember to call cvxFileKeep() again
to reset the flag after you have finished your calls to
cvxPartAtItemGetInFile() and cvxPartAtItemSetInFile(), and you also become
responsible for closing the files, for example by using one of the
cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | itemId | item id
[in] | At | part item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtMod()

evxErrors cvxPartAtMod | ( | vxRootName | Name,
 |  | svxPartAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Selectively updates attributes of the specified part with the
fields in "At" that have valid ascii strings in their "data"
variables. Any attribute whose "data" is a blank string is
ignored. The "label" strings associated with modified fields
are not reflected into the specified part's attribute info
with the exception of user attributes and driving dimensions.

For this function to update a user attribute, both "label" and "data"
must be defined for "At->UserAttribute[n]". If a user attribute with
the specified "label" already exists in the part's current attribute
info, then the corresponding "data" is updated. If not, then a new
user-attribute is added to part's attribute info.

Entries in "At->Dimen[]" that have blank labels are skipped.
Dimensions listed in "At->Dimen[]" that are not already listed in
the part's attribute info are added. Entries in "At->Dimen[]" with
blank labels are ignored.

It is assumed that labels of driving dimensions listed in "At->Dimen[]"
identify valid dimension or variables in the parent part. It is also
assumed that dimension values stored in "At->Dimen[].data" fields are
within valid ranges. No checking is done to ensure it. When driving
dimension values are changed, the parent part is automatically
regenerated by this function.

You cannot use this function to delete pre-existing dimension names
from a part's attribute info. To do that, you have to get the existing
attribute data with cvxPartAtGet(), clear the "label" and "data" variables
of the driving dimensions you no longer want recorded in the part attributes,
then reset all attributes using cvxPartAtSet().

If "Name" is NULL or an empty string, the active target part is used.

Parameters
[in] | Name | name of part in active file
[in] | At | part attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartAtSet()

evxErrors cvxPartAtSet | ( | vxRootName | Name,
 |  | svxPartAttribute * | At
 | ) |  |

#include <zwapi_part_attribute.h>

Assigns the specified part attribute data to the specified part.
Existing part attribute data is replaced with the contents of
the input attribute data structure.

This function reflects back into the specified part all of the
attribute data in "At", even the blank strings (excluding the
part name field). So, generally speaking, you would want to
initialize "At" by passing it to cvxPartAtGet(), modify select
fields of "At", then pass "At" back into this function.

It is assumed that labels of driving dimensions listed in "At->Dimen[]"
identify valid dimension or variables in the parent part. It is also
assumed that dimension values stored in "At->Dimen[].data" fields are
within valid ranges. No checking is done to ensure it. When driving
dimension values are changed, the parent part is automatically
regenerated by this function.

Use cvxPartAtMod() to selectively update part attribute data.

If "Name" is NULL or an empty string, the active target part is used.

Parameters
[in] | Name | name of part in active file
[in] | At | part attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCalcAttrGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartCalcAttrGet()

evxErrors cvxPartCalcAttrGet | ( | int | idPart,
 |  | svxPartCalcAttrData * | attr
 | ) |  |

#include <zwapi_part_attribute.h>

Calculate length,width,hight,volume,area,mass of part specified by index

Parameters
[in] | idPart | index of part in database
[out] | attr | calculate attribute of part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartClosePartAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartClosePartAt()

void cvxPartClosePartAt ( )

#include <zwapi_part_attribute.h>

Close the part attributes form.

See also
cvxPartShowPartAt().
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartGetCustomStr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartGetCustomStr()

evxErrors cvxPartGetCustomStr | ( | int | idEnt,
 |  | int * | idStr,
 |  | char ** | CustomString
 | ) |  |

#include <zwapi_part_attribute.h>

Get custom string attached to a entity.

The calling procedure MUST deallocate the output string with cvxMemFree().

Parameters
[in] | idEnt | part id
[out] | idStr | custom string id, can be NULL
[out] | CustomString | custom string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • Zw_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMassProp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartMassProp()

evxErrors cvxPartMassProp ( void )

#include <zwapi_part_attribute.h>

Appends an operation to the history of the active part to
calculate mass properties for the part, assigning the results
to the variables named Part_Area, Part_Volume and Part_Mass.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMaterialDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartMaterialDel()

evxErrors cvxPartMaterialDel | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | const vxLongName | material
 | ) |  |

#include <zwapi_part_attribute.h>

This interface is used to delete the specified materials in the material list of the specified file. (Attributes->Material...)

Note
fileName can only have a file name, or it can be a file name that contains a file path.
If fileName only has a file name, user can add a search path through the cvxPathSearchFirst() interface.
Parameters
[in] | fileName | file name(fileName[0]=0 or NULL for active file)
[in] | rootName | root name(rootName[0]=0 or NULL for active target object)
[in] | material | material name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMaterialGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartMaterialGet()

evxErrors cvxPartMaterialGet | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | const vxLongName | material,
 |  | svxPartMaterial * | data
 | ) |  |

#include <zwapi_part_attribute.h>

Obtain the material information in the specified file.
Attributes->Material corresponding to platform functions.
The obtained density is in kg/m^3.

This interface obtains the data in the material list of the specified file.
If the user wants to get material's attribute of the part file, interface cvxPartAtItemGet can be used.

Note
fileName can only have a file name, or it can be a file name
that contains a file path.
If fileName only has a file name, user can add a search path
through the cvxPathSearchFirst() interface.
Parameters
[in] | fileName | file name(fileName[0]=0 or NULL for active file)
[in] | rootName | root name(rootName[0]=0 or NULL for active target object)
[in] | material | material name
[out] | data | material attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMaterialSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartMaterialSet()

evxErrors cvxPartMaterialSet | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | const vxLongName | material,
 |  | const svxPartMaterial * | data
 | ) |  |

#include <zwapi_part_attribute.h>

This interface is used to add materials to the material list of the specified document.
(Attributes->Material...)

If the user wants to set material's attribute of the part file, interface cvxPartAtItemSet can be used.

If the material exists,modify the density corresponding to the existing material name.
Otherwise, add the material name and density that did not exist before.
The unit of density is kg/m^3.

Note
fileName can only have a file name, or it can be a file name that contains a file path.
If fileName only has a file name, user can add a search path through the cvxPathSearchFirst() interface.
Parameters
[in] | fileName | file name(fileName[0]=0 or NULL for active file)
[in] | rootName | root name(rootName[0]=0 or NULL for active target object)
[in] | material | material name
[in] | data | material attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPhyAttrCalc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartPhyAttrCalc()

evxErrors cvxPartPhyAttrCalc ( vxRootName Name )

#include <zwapi_part_attribute.h>

Calculate physical attributes of the specified part.
If Name = "" or NULL, it will calculate current active
part's physical attributes.

Parameters
[in] Name part name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSetCustomStr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartSetCustomStr()

evxErrors cvxPartSetCustomStr | ( | int | idEnt,
 |  | const char * | CustomString,
 |  | int * | idStr
 | ) |  |

#include <zwapi_part_attribute.h>

Set custom string attached to a entity.

Parameters
[in] | idEnt | part id
[in] | CustomString | custom string
[out] | idStr | custom string id, NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShowPartAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartShowPartAt()

evxErrors cvxPartShowPartAt | ( | const vxLongPath | File,
 |  | const vxRootName | Root
 | ) |  |

#include <zwapi_part_attribute.h>

Display the part attributes form for specified root object.

See also
cvxPartClosePartAt().
Parameters
[in] File file name (NULL for active file)
  1. loaded file and newly created file need only file name
  2. unloaded file need the full path of file
[in] Root root object name (NULL for active root object)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUserAtExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartUserAtExport()

evxErrors cvxPartUserAtExport ( const vxLongPath filePath )

#include <zwapi_part_attribute.h>

Export the part user attribute data to the specified file 'filePath'.

Parameters
[in] filePath path of excel file to export
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUserAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartUserAtGet()

evxErrors cvxPartUserAtGet | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | int * | Count,
 |  | svxAttribute ** | UserAt
 | ) |  |

#include <zwapi_part_attribute.h>

Retrieves user attribute data from the specified part in the specified file.

The calling procedure MUST deallocate the output list with cvxMemFree().

If the specified file is not already open, this function will open it
to access attributes, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep() again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[out] | Count | number of user attributes
[out] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUserAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartUserAtSet()

evxErrors cvxPartUserAtSet | ( | const vxLongPath | File,
 |  | const vxRootName | Root,
 |  | int | DelOrgAt,
 |  | int | Count,
 |  | svxAttribute * | UserAt
 | ) |  |

#include <zwapi_part_attribute.h>

Assigns the specified part attribute data to the specified part.
Existing part attribute data is replaced with the contents of
the input attribute data structure.

If the specified file is not already open, this function will open it
to access attributes, and will then close the file. If you want to
keep the file open, use the cvxFileKeep() function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep() again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose() or cvxFileSave() functions.

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Root | root object name (Root[0]=0 or NULL for active target object)
[in] | DelOrgAt | whether to clear original user attribute
[in] | Count | number of user attributes
[in] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVolumAndMassGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Attribute
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ cvxPartVolumAndMassGet()

evxErrors cvxPartVolumAndMassGet | ( | vxRootName | Name,
 |  | double * | dVolume,
 |  | double * | dMass
 | ) |  |

#include <zwapi_part_attribute.h>

Output volume and mass data from the specified part in the active file.
Before you use it, you need to use function cvxPartPhyAttrCalc() to calculate
physical attributes.

Parameters
[in] | Name | name of part in active file(Name[0]=0 or NULL for active part)
[out] | dVolume | volume of part,unit:mm^3
[out] | dMass | mass of part,unit:kg
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Configuration

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Configuration
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Config API

Part Config Activate

evxErrors | cvxPartCfgTblAdd (vxName cfgName, char *cfgDes, int *idCfg)
evxErrors | cvxPartCfgActivate (int idCfg)
evxErrors | cvxPartInqActiveCfg (int *idCfg)
evxErrors | cvxPartInqActiveCfgByName (const vxLongPath fileName, const vxRootName rootName, int *idCfg)

Part Config Query

evxErrors | cvxPartInqCfgList (int *Count, int **CfgList)
evxErrors | cvxPartInqCfgListByName (const vxLongPath fileName, const vxRootName rootName, int *count, int **cfgList)

Part Config Info

evxErrors | cvxCfgTblInfosSet (int idCfg, svxPartCfgInfo *info)
evxErrors | cvxPartInqCfgTblInfos (int idCfg, svxPartCfgInfo **partCfg)
evxErrors | cvxPartInqCfgTblInfosByName (const vxLongPath fileName, const vxRootName rootName, int idCfg, svxPartCfgInfo **partCfg)
void | cvxPartFreeCfgTbl (svxPartCfgInfo **cfginfo)
evxErrors | cvxPartCfgTblAttrSet (int markDel, int idCfg, int cnt, evxAtItemId *types, svxAttribute *attrs)
evxErrors | cvxPartCfgTblColorSet (int markDelClr, int idCfg, svxColor color)
evxErrors | cvxPartCfgTblInstNameSet (int markDelInstName, int idCfg, vxLongName instanceName)
evxErrors | cvxPartCfgTblVarsSet (int markDelVars, int idCfg, int cnt, svxVariable *vars)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxCfgTblInfosSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxCfgTblInfosSet()

evxErrors cvxCfgTblInfosSet | ( | int | idCfg,
 |  | svxPartCfgInfo * | info
 | ) |  |

#include <zwapi_part_config.h>

This interface can modify data that already exists in the configuration table.

Get Id by cvxPartInqCfgList();
Get info by cvxPartInqConfigTableInfos();

Multiple values for each row of configuration can be set at once.

Note
When using this interface to set the configuration table,there are too many structure parameters,
which makes the interface difficult to use.
Therefore ,after all the new interfaces that replace this interface are available,
this interface will be discarded.
Now,it is recommended that customers use cvxPartCfgTblAttrSet() to add, modify, and delete attribute
related items to the configuration table.
Parameters
[in] | idCfg | configuration id
[in] | info | config table info that changed
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgActivate()

evxErrors cvxPartCfgActivate ( int idCfg )

#include <zwapi_part_config.h>

Active the specified configuration to current part.

Parameters
[in] idCfg config id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgTblAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgTblAdd()

evxErrors cvxPartCfgTblAdd | ( | vxName | cfgName,
 |  | char * | cfgDes,
 |  | int * | idCfg
 | ) |  |

#include <zwapi_part_config.h>

Add a configuration id to the configuration table.
COnfiguration properties can be set for through idCfg
and interface cvxCfgTblInfosSet().

Parameters
[in] | cfgName | config name
[in] | cfgDes | config description(Max = 96bytes,NULL to ignore)
[out] | idCfg | id of config
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgTblAttrSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgTblAttrSet()

evxErrors cvxPartCfgTblAttrSet | ( | int | markDel,
 |  | int | idCfg,
 |  | int | cnt,
 |  | evxAtItemId * | types,
 |  | svxAttribute * | attrs
 | ) |  |

#include <zwapi_part_config.h>

User can add, modify, and delete items in the configuration table through the attribute value and attribute type.

The enumerations that can be used for types are:
VX_AT_USER ,VX_AT_NUMBER ,VX_AT_DESIGNER ,VX_AT_COST ,VX_AT_SUPPLIER ,VX_AT_DESCRIPT,
VX_AT_KEYWORD ,VX_AT_MANAGER ,VX_AT_MATERIAL ,VX_AT_NO_SECTION ,VX_AT_NO_HATCH ,VX_AT_NO_BOM,
VX_AT_AREA ,VX_AT_VOLUME ,VX_AT_MASS ,VX_AT_LENGTH ,VX_AT_WIDTH ,VX_AT_HEIGHT.

The value of attrs can be obtained through interface cvxPartAtItemGet(),cvxPartAtItemGetInFile()...

Parameters
[in] markDel 1 is delete attribute, -1 if add attribute(default attribute), else 0 is modify
(If it exists, it will be modified;if it does not exist ,it will be added and modified.).
[in] | idCfg | configuration id
[in] | cnt | count of types(attrs)
[in] | types | attribute type
[in] | attrs | attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgTblColorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgTblColorSet()

evxErrors cvxPartCfgTblColorSet | ( | int | markDelClr,
 |  | int | idCfg,
 |  | svxColor | color
 | ) |  |

#include <zwapi_part_config.h>

User can add, modify, and delete color item in the configuration table.

Parameters
[in] | markDelClr | 1 is delete color, -1 if add color(default color), else 0 is modify (If it exists, it will be modified;if it does not exist ,it will be added and modified.).
[in] | idCfg | configuration id
[in] | color | part color.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgTblInstNameSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgTblInstNameSet()

evxErrors cvxPartCfgTblInstNameSet | ( | int | markDelInstName,
 |  | int | idCfg,
 |  | vxLongName | instanceName
 | ) |  |

#include <zwapi_part_config.h>

User can add, modify, and delete instance name item in the configuration table.

Parameters
[in] | markDelInstName | 1 is delete instance name, -1 if add instance name(default instance name), else 0 is modify (If it exists, it will be modified;if it does not exist ,it will be added and modified.).
[in] | idCfg | configuration id
[in] | instanceName | instance name.NULL to use default value.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCfgTblVarsSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartCfgTblVarsSet()

evxErrors cvxPartCfgTblVarsSet | ( | int | markDelVars,
 |  | int | idCfg,
 |  | int | cnt,
 |  | svxVariable * | vars
 | ) |  |

#include <zwapi_part_config.h>

User can add, modify, and delete variable item in the configuration table.

Note
If the user wants to modify the value of the variable, it is recommended to modify svxVariable.Expression.
Parameters
[in] markDelVars 1 is delete variable, -1 if add variable(default variable), else 0 is modify
(If it exists, it will be modified;if it does not exist ,it will be added and modified.).
[in] | idCfg | configuration id
[in] | cnt | count of vars
[in] | vars | list of variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFreeCfgTbl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartFreeCfgTbl()

void cvxPartFreeCfgTbl ( svxPartCfgInfo ** cfginfo )

#include <zwapi_part_config.h>

Frees memory associated with the input config table infos list.
The input memory pointer (*cfginfo) is set to NULL.

Parameters
[in,out] cfginfo list of config table info
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqActiveCfg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqActiveCfg()

evxErrors cvxPartInqActiveCfg ( int * idCfg )

#include <zwapi_part_config.h>

Outputs the active configuration id of current active part.

Parameters
[out] idCfg the id of current active configuration
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqActiveCfgByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqActiveCfgByName()

evxErrors cvxPartInqActiveCfgByName | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | int * | idCfg
 | ) |  |

#include <zwapi_part_config.h>

Outputs the active configuration id of specified file.

Parameters
[in] | fileName | file name, NULL for active file name
[in] | rootName | root name, NULL for active root name
[out] | idCfg | the id of current active configuration
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCfgList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqCfgList()

evxErrors cvxPartInqCfgList | ( | int * | Count,
 |  | int ** | CfgList
 | ) |  |

#include <zwapi_part_config.h>

Outputs the configuration id list of current active part.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | the number of part configuration
[out] | CfgList | the list of part configuration id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_AIP_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCfgListByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqCfgListByName()

evxErrors cvxPartInqCfgListByName | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | int * | count,
 |  | int ** | cfgList
 | ) |  |

#include <zwapi_part_config.h>

Outputs the configuration id list of specified file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | fileName | file name, NULL for active file name
[in] | rootName | root name, NULL for active root name
[out] | count | the number of part configuration
[out] | cfgList | the list of part configuration id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCfgTblInfos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqCfgTblInfos()

evxErrors cvxPartInqCfgTblInfos | ( | int | idCfg,
 |  | svxPartCfgInfo ** | partCfg
 | ) |  |

#include <zwapi_part_config.h>

Get specified id configuration table infos.
Get Id by cvxPartInqCfgList();

The memory referenced by "partcfg" is allocated by this function.
The calling procedure is responsible to free it (cvxPartFreeCfgTbl(partcfg)).

Parameters
[in] | idCfg | configuration id
[out] | partCfg | configuration infos
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCfgTblInfosByName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Configuration
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ cvxPartInqCfgTblInfosByName()

evxErrors cvxPartInqCfgTblInfosByName | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | int | idCfg,
 |  | svxPartCfgInfo ** | partCfg
 | ) |  |

#include <zwapi_part_config.h>

Get specified id configuration table infos.
Get idCfg by cvxPartInqCfgList()/cvxPartInqCfgListByName();

The memory referenced by "partCfg" is allocated by this function.
The calling procedure is responsible to free it (cvxPartFreeCfgTbl(&partCfg)).

Parameters
[in] | fileName | file name, NULL for active file name
[in] | rootName | root name, NULL for active root name
[in] | idCfg | configuration id
[out] | partCfg | configuration infos
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_MEMORY_ERROR
  • Zw_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Data
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the functions of Part objects.

Feature Query Data

enum evxFtrRegenStatus {
VX_FTR_REGEN_DEFAULT , VX_FTR_REGEN_LINK_LOST , VX_FTR_REGEN_PARTIAL_INP_LOST , VX_FTR_REGEN_VAR_LOST ,
VX_FTR_REGEN_ENT_LOST , VX_FTR_REGEN_OVER_CONSTRAINT , VX_FTR_REGEN_UNDER_CONSTRAINT
}
regen status of feature More...
typedef enum evxFtrRegenStatus evxFtrRegenStatus
regen status of feature

Part Physical Attribute Data

enum | evxAtItemLockStatus { VX_AT_ITEM_UNLOCKED = 0 , VX_AT_ITEM_LOCKED , VX_AT_ITEM_LIMITED }
Locking state of attribute item. More...
typedef struct svxPartCalcAttrData | svxPartCalcAttrData
part physical attributes data
typedef struct svxPartMaterial | svxPartMaterial
Part material physical attributes.
typedef enum evxAtItemLockStatus | evxAtItemLockStatus
Locking state of attribute item.

Block Data

enum | evxBlockType { VX_BLOCK_UNDEFINED = 0 , VX_BLOCK_FACETS = 1 , VX_BLOCK_POINTS = 2 }
3D Block Type More...
enum | evxRefineFacetsTolType { VX_FACETS_TOL_PIXEL , VX_FACETS_TOL_DISTANCE , VX_FACETS_TOL_ANGLE }
tolerance type of refine facets More...
typedef struct svxSTL | svxSTL
3D STL facets
typedef enum evxBlockType | evxBlockType
3D Block Type
typedef enum evxRefineFacetsTolType | evxRefineFacetsTolType
tolerance type of refine facets
typedef struct svxRefineFacets | svxRefineFacets
refine facets data

Part Config Info Data

enum evxCfgThreadCmd {
VX_NO_CMD = 0 , VX_FTHOLEMAIN = 1 , VX_FTTWKHOLE = 2 , VX_FTASSEMHOLE = 3 ,
VX_FTHOLEASGN = 4 , VX_CDHOLEPLUG = 5 , VX_CDTHRDADD = 6
}
Hole type. More...
enum evxCfgTblMethod {
VX_CFGTBL_MEHTOD_FTR , VX_CFGTBL_MEHTOD_FTRDIM , VX_CFGTBL_MEHTOD_FTRVDATA , VX_CFGTBL_MEHTOD_PROFDIM ,
VX_CFGTBL_MEHTOD_VAR , VX_CFGTBL_MEHTOD_ATTR , VX_CFGTBL_MEHTOD_PARTCOLOR , VX_CFGTBL_MEHTOD_THREAD ,
VX_CFGTBL_MEHTOD_THREADDEP , VX_CFGTBL_MEHTOD_COMPPARTCFG , VX_CFGTBL_MEHTOD_COMPSUPP , VX_CFGTBL_MEHTOD_COMPCOLOR ,
VX_CFGTBL_MEHTOD_ALIGNSUPP , VX_CFGTBL_MEHTOD_ALIGNVALUE
}
configuration item method More...
enum evxPMIEntType {
VX_PMI_ALL = 0x0000 , VX_PMI_DIM = 0x0001 , VX_PMI_NOTE = 0x0002 , VX_PMI_DTMF = 0x0004 ,
VX_PMI_DTMT = 0x0008 , VX_PMI_FCS = 0x0010 , VX_PMI_CLCM = 0x0020 , VX_PMI_SYMSRF = 0x0040 ,
VX_PMI_SYMWELD = 0x0080 , VX_PMI_TABLE = 0x0100 , VX_PMI_SYMBLK = 0x0200
}
PMI entity type. More...
typedef enum evxCfgThreadCmd | evxCfgThreadCmd
Hole type.
typedef struct svxCf | svxCf
conversion factor
typedef struct svxPartCfgInfo | svxPartCfgInfo
config table infos
typedef enum evxCfgTblMethod | evxCfgTblMethod
configuration item method
typedef enum evxPMIEntType | evxPMIEntType
PMI entity type.

Sheet Metal Attribute Data

enum evxSmdSurfaceType {
VX_SMD_SURF_NONE , VX_SMD_SURF_OTHER , VX_SMD_SURF_SIDE , VX_SMD_SURF_FLANGE_STAT ,
VX_SMD_SURF_FLANGE_STAT_PAIR
}
Sheet Metal surface type. More...
typedef enum evxSmdSurfaceType evxSmdSurfaceType
Sheet Metal surface type.

Datum Data

enum | evxPlaneType { VX_PLANE_TYPE_XY = 1 , VX_PLANE_TYPE_YZ = 2 , VX_PLANE_TYPE_XZ = 3 }
type of plane More...
typedef enum evxPlaneType | evxPlaneType
type of plane

Edge Display Data

typedef struct svxEdgeDispData svxEdgeDispData
edge display data
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Datum Query

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Datum Query
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Datum Query API

Axis Query

evxErrors | cvxPartInqAxis (int *Count, int **Axis)
evxErrors | cvxAxisInqDir (int idAxis, svxPoint *pPnt, svxPoint *pDir)
evxErrors | cvxAxisGetData (int idAxis, svxAxisData *Axis)
evxErrors | cvxAxisLengthGet (int idAxis, double *Length)
evxErrors | cvxAxisLengthSet (int idAxis, double Length)

Datum Query

evxErrors cvxPlaneGetData (int idPlane, svxPlaneData *Plane)

CSYS Query

evxErrors | cvxPartInqCsys (int *Count, int **Csys)
evxErrors | cvxPartInqDefaultCSYS (int *CSYS)
evxErrors | cvxPartInqCSYSAxis (int idCSYS, evxAxisType AxisType, int *idAxis)
evxErrors | cvxPartInqCSYSPlane (int idCSYS, evxPlaneType PlnType, int *idPlane)
evxErrors | cvxCSYSGetData (int idCSYS, svxCSYSData *CSYS)
void | cvxPartInqLCSMat (svxMatrix *mat)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisGetData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxAxisGetData()

evxErrors cvxAxisGetData | ( | int | idAxis,
 |  | svxAxisData * | Axis
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the Axis data associated with the specified idAxis.

Note
This interface can only retrieve datum data created by interface cvxPartAxisNew().
Parameters
[in] | idAxis | Axis id
[out] | Axis | Axis data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisInqDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxAxisInqDir()

evxErrors cvxAxisInqDir | ( | int | idAxis,
 |  | svxPoint * | pPnt,
 |  | svxPoint * | pDir
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the direction associated with the specified object (idAxis).

Parameters
[in] | idAxis | index of axis
[out] | pPnt | start point of axis
[out] | pDir | direction of axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisLengthGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxAxisLengthGet()

evxErrors cvxAxisLengthGet | ( | int | idAxis,
 |  | double * | Length
 | ) |  |

#include <zwapi_part_datum_query.h>

Get length of the specified datum axis.

Parameters
[in] | idAxis | id of datum axis
[out] | Length | length of datum axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisLengthSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxAxisLengthSet()

evxErrors cvxAxisLengthSet | ( | int | idAxis,
 |  | double | Length
 | ) |  |

#include <zwapi_part_datum_query.h>

Set length of the specified datum axis.

Parameters
[in] | idAxis | id of datum axis
[in] | Length | length of datum axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxCSYSGetData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxCSYSGetData()

evxErrors cvxCSYSGetData | ( | int | idCSYS,
 |  | svxCSYSData * | CSYS
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the CSYS data associated with the specified idCSYS, contained frame and Entity path.

Note
This interface can only retrieve datum data created by interface cvxPartCSYSNew().
Parameters
[in] | idCSYS | CSYS id
[out] | CSYS | CSYS data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqAxis()

evxErrors cvxPartInqAxis | ( | int * | Count,
 |  | int ** | Axis
 | ) |  |

#include <zwapi_part_datum_query.h>

Outputs a list of axis that belong to the current part.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of axis
[out] | Axis | list of index of axises
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCsys

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqCsys()

evxErrors cvxPartInqCsys | ( | int * | Count,
 |  | int ** | Csys
 | ) |  |

#include <zwapi_part_datum_query.h>

Outputs a list of CSYS that belong to the current part.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of CSYS
[out] | Csys | list of index of CSYS
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCSYSAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqCSYSAxis()

evxErrors cvxPartInqCSYSAxis | ( | int | idCSYS,
 |  | evxAxisType | AxisType,
 |  | int * | idAxis
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the id of the specified datum axis of the specified datum CSYS.

Parameters
[in] | idCSYS | id of datum CSYS
[in] | AxisType | axis type to query
[out] | idAxis | id of datum axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCSYSPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqCSYSPlane()

evxErrors cvxPartInqCSYSPlane | ( | int | idCSYS,
 |  | evxPlaneType | PlnType,
 |  | int * | idPlane
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the id of the specified datum plane of the specified datum CSYS.

Parameters
[in] | idCSYS | id of datum CSYS
[in] | PlnType | plane type to query
[out] | idPlane | id of datum plane
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqDefaultCSYS

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqDefaultCSYS()

evxErrors cvxPartInqDefaultCSYS ( int * CSYS )

#include <zwapi_part_datum_query.h>

Get the Default CSYS/Datum ID which Uid is three 10.

Parameters
[out] CSYS Default CSYS/Datum id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqLCSMat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPartInqLCSMat()

void cvxPartInqLCSMat ( svxMatrix * mat )

#include <zwapi_part_datum_query.h>

Gets the local CSYS matrix.

Parameters
[out] mat the local CSYS matrix.
Warning
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlaneGetData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Query
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ cvxPlaneGetData()

evxErrors cvxPlaneGetData | ( | int | idPlane,
 |  | svxPlaneData * | Plane
 | ) |  |

#include <zwapi_part_datum_query.h>

Get the Plane data associated with the specified idPlane, contained frame and Entity path.

Note
This interface can only retrieve datum data created by interface cvxPartPlaneNew().
Parameters
[in] | idPlane | Plane id
[out] | Plane | Plane data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Dimension API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Dimension API
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Dimension API

Dimension

evxErrors | cvxPartInqDims (const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
evxErrors | cvxPartInqPMIDimEnts (int idDim, int *Count, svxEntPath **EntPaths)
evxErrors | cvxPartInqDimIdxs (const vxLongPath File, const vxRootName Part, int *Count, int **IdList)

PMI

evxErrors | cvxPartInqPMIs (evxPMIEntType type, int *count, int **idPMIs)
evxErrors | cvxPMIInqType (int idPMI, evxPMIEntType *type)
evxErrors | cvxPMIInqBaseEnt (int idPMI, int *idBaseObj)
evxErrors | cvxPMIInqAssoEnts (int idPMI, int *count, svxEntPath **entPaths)
evxErrors | cvxPMIInqValid (int idPMI, int *isValid)

Symbol

evxErrors | cvxSymInqRefPnt (int idSym, svxPoint *RefPnt)
evxErrors | cvxSymInqLeadLines (int idSym, int *count, svxCurve **LeadCrvs)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqDimIdxs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPartInqDimIdxs()

evxErrors cvxPartInqDimIdxs | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | int ** | IdList
 | ) |  |

#include <zwapi_part_dim.h>

Outputs a list of dimensions' id that belong to the specified part.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | Count | number of dimensions
[out] | IdList | list of the dimension's index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqDims

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPartInqDims()

evxErrors cvxPartInqDims | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | svxVariable ** | Variables
 | ) |  |

#include <zwapi_part_dim.h>

Outputs a list of dimensions that belong to the specified part.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | Count | number of variables
[out] | Variables | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPMIDimEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPartInqPMIDimEnts()

evxErrors cvxPartInqPMIDimEnts | ( | int | idDim,
 |  | int * | Count,
 |  | svxEntPath ** | EntPaths
 | ) |  |

#include <zwapi_part_dim.h>

Outputs the pick path list of entities associated with the specified PMI dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDim | id of PMI dimension
[out] | Count | number of entities associated with the dimension
[out] | EntPaths | pick path of entities associated with the dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPMIs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPartInqPMIs()

evxErrors cvxPartInqPMIs | ( | evxPMIEntType | type,
 |  | int * | count,
 |  | int ** | idPMIs
 | ) |  |

#include <zwapi_part_dim.h>

Outputs a list of PMI objects that belong to the currently active part.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | type | PMI type to inquire
[out] | count | number of PMI
[out] | idPMIs | list of index of PMI
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPMIInqAssoEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPMIInqAssoEnts()

evxErrors cvxPMIInqAssoEnts | ( | int | idPMI,
 |  | int * | count,
 |  | svxEntPath ** | entPaths
 | ) |  |

#include <zwapi_part_dim.h>

Outputs the pick path list of entities associated with the specified
PMI entity. the function has the same function as cvxPartInqPMIDimEnts(),
but the function can get the associated entities of all types of PMI.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idPMI | index of PMI or base object of PMI
[out] | count | number of entities associated with the PMI
[out] | entPaths | pick path of entities associated with the PMI
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPMIInqBaseEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPMIInqBaseEnt()

evxErrors cvxPMIInqBaseEnt | ( | int | idPMI,
 |  | int * | idBaseObj
 | ) |  |

#include <zwapi_part_dim.h>

Get index of base object of specified PMI entity.

Parameters
[in] | idPMI | index of PMI
[out] | idBaseObj | index of base object of PMI
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPMIInqType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPMIInqType()

evxErrors cvxPMIInqType | ( | int | idPMI,
 |  | evxPMIEntType * | type
 | ) |  |

#include <zwapi_part_dim.h>

Get the type(evxPMIEntType) of specified PMI entity.
It can't get the corresponding type if "*type = VX_PMI_ALL".

Parameters
[in] | idPMI | index of PMI or base object of PMI
[out] | type | type of PMI
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPMIInqValid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxPMIInqValid()

evxErrors cvxPMIInqValid | ( | int | idPMI,
 |  | int * | isValid
 | ) |  |

#include <zwapi_part_dim.h>

Check whether the PMI is valid.

Parameters
[in] | idPMI | index of PMI
[out] | isValid | whether PMI is valid (1: valid; 0: invalid)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSymInqLeadLines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxSymInqLeadLines()

evxErrors cvxSymInqLeadLines | ( | int | idSym,
 |  | int * | count,
 |  | svxCurve ** | LeadCrvs
 | ) |  |

#include <zwapi_part_dim.h>

Outputs a list of leader curves of specified symbol.

Note
all points in svxCurve are the points in Frame that the local
coordinate system of the curve, the function cvxPntTransform() can be
used to convert points into points in the global coordinate system.
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | idSym | index of symbol or PMI of symbol type
[out] | count | number of leader curves
[out] | LeadCrvs | list of leader curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSymInqRefPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Dimension API
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ cvxSymInqRefPnt()

evxErrors cvxSymInqRefPnt | ( | int | idSym,
 |  | svxPoint * | RefPnt
 | ) |  |

#include <zwapi_part_dim.h>

Get the reference point coordinate of specified symbol object.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Facets/Block

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Facets/Block
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Facets/Part Block API

Block Creation

int | cvxPartPntBlock (vxLongName Name, int Count, svxPointf *Points, int *idEnt)
evxErrors | cvxPartFacets (vxLongName Name, svxFacets *Facets, int *idBlock)
evxErrors | cvxPartFacetsBySTL (const vxLongName name, const svxSTL *stl, int *idBlock)

Block Query

evxErrors | cvxPartInqBlocks (int *Count, int **Blocks)
evxErrors | cvxPartInqBlockPnts (int idBlock, int *Count, svxPointf **Points)
evxErrors | cvxPartInqBlockType (int idBlock, evxBlockType *Type)
evxErrors | cvxPartInqFacets (int idBlock, svxSTL *Stl)
evxErrors | cvxPartInqFacets2 (int idBlock, svxFacets *Facets)
evxErrors | cvxPartInqFacetsTxFile (int idBlock, vxPath Path)
evxErrors | cvxPartInqFacetsTxFileByLongPath (int idBlock, char *Path, int sizePath)

Facets Block Edit

evxErrors | cvxPartFacetsMod (int idBlock, svxFacets *Facets)
evxErrors | cvxPartFacetsSetAt (int idBlock, const svxFaceAt *At)
evxErrors | cvxPartFacetsSetTx (int idBlock, const svxTextureAt *Tx)
evxErrors | cvxPartProjStl (int idStl, int idPln, double tol, double smth, int *idCurve)

Face Facets

evxErrors | cvxPartInqFaceFacets (int idFace, int *Count, svxTriangle **Facets)
evxErrors | cvxPartInqFaceFacets2 (int idFace, svxFacets *Facets)
evxErrors | cvxPartInqFaceFacetsByChord (int idFace, double ChordHeight, int *Count, svxTriangle **Facets)
evxErrors | cvxPartRefineFacetsInit (svxRefineFacets *data)
evxErrors | cvxPartInqFaceFacets2ByTol (svxRefineFacets *RefineData, svxFacets *Facets)

svxFacets and svxSTL Convert

evxErrors | cvxPartFacetsConvertToSTL (const svxFacets *facets, svxSTL *stl)
evxErrors | cvxPartSTLConvertToFacets (const svxSTL *stl, svxFacets *facets)

Facets Free

void | cvxFacetsFree (svxFacets *Facets)
void | cvxStlFree (svxSTL *Stl)

Edge Display data

evxErrors | cvxPartEdgeDispData (int idEdge, svxEdgeDispData *data)
void | cvxPartEdgeDispDataFree (svxEdgeDispData *data)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxFacetsFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxFacetsFree()

void cvxFacetsFree ( svxFacets * Facets )

#include <zwapi_part_facets.h>

Frees memory associated with the specified facets structure.

Parameters
[in] Facets 3D facets data structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEdgeDispData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartEdgeDispData()

evxErrors cvxPartEdgeDispData | ( | int | idEdge,
 |  | svxEdgeDispData * | data
 | ) |  |

#include <zwapi_part_facets.h>

Get the display data of the edge in different modes.

Note
The calling procedure MUST deallocate the output(data) with cvxPartEdgeDispDataFree().
Parameters
[in] | idEdge | edge id
[out] | data | display data of edge
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEdgeDispDataFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartEdgeDispDataFree()

void cvxPartEdgeDispDataFree ( svxEdgeDispData * data )

#include <zwapi_part_facets.h>

Frees memory associated with the specified svxEdgeDispData structure.

Parameters
[in] data display data of edge
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacets()

evxErrors cvxPartFacets | ( | vxLongName | Name,
 |  | svxFacets * | Facets,
 |  | int * | idBlock
 | ) |  |

#include <zwapi_part_facets.h>

Creates an explicit (i.e. non-historical) 3D Block containing the input
3D facet data and adds it to the active part.

If "idBlock" is not NULL, the id of the 3D Block created
by this function is output via "idBlock".

If this function successfully creates the Block, the Block takes
ownership of the memory referenced by the vertex data fields in the
"Facets" structure (Vertex, Normal, etc.). This function assigns NULL
to fields that refer to memory that has been transferred to the Block.
After this function returns, use the cvxFacetsFree() function to release
any remaining memory still referenced by the "Facets" structure.

See also
cvxPartFacetsMod() for a function that can modify the facet data of an existing 3D Block.
Parameters
[in] | Name | block name
[in,out] | Facets | set of 3D triangular facets
[out] | idBlock | id of new 3D Block of triangular facets
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacetsBySTL

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacetsBySTL()

evxErrors cvxPartFacetsBySTL | ( | const vxLongName | name,
 |  | const svxSTL * | stl,
 |  | int * | idBlock
 | ) |  |

#include <zwapi_part_facets.h>

Creates an 3D Block and adds it to the active part.

If "idBlock" is not NULL, the id of the 3D Block created
by this function is output via "idBlock".

Due to the lack of some data in svxSTL, I treat each triangle
as a strip and store it in the facet.

Parameters
[in] | name | block name
[in] | stl | STL facets
[out] | idBlock | id of new 3D Block
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacetsConvertToSTL

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacetsConvertToSTL()

evxErrors cvxPartFacetsConvertToSTL | ( | const svxFacets * | facets,
 |  | svxSTL * | stl
 | ) |  |

#include <zwapi_part_facets.h>

The structure svxFacets is converted into the structure svxSTL.

Parameters
[in] | facets | facet data
[out] | stl | STL data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacetsMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacetsMod()

evxErrors cvxPartFacetsMod | ( | int | idBlock,
 |  | svxFacets * | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Modify an explicit (i.e. non-historical) 3D Block in the active part,
replacing the Block's prior triangle and vertex data with data from
the given "Facets" input.

If this function successfully updates the Block, the Block takes
ownership of the memory referenced by the vertex data fields in the
"Facets" structure (Vertex, Normal, etc.). This function assigns NULL
to fields that refer to memory that has been transferred to the Block.
After this function returns, use the cvxFacetsFree() function to release
any remaining memory still referenced by the "Facets" structure.

This function ignores the At, Tx and Sh fields in the "Facets"
structure. It does not update the Block's display attributes, texture
map attributes, or shader attributes. The cvxPartFacetsSetAt() and
cvxPartFacetsSetTx() functions can be used to modify a Block's display
attributes and texture map attributes. Shader attributes are not
currently used by 3D Blocks.

See also
cvxPartFacets() for a function that can create a 3D Block from facet data.
Parameters
[in] | idBlock | id of 3D Block of triangular facets
[in,out] | Facets | set of 3D triangular facets
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacetsSetAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacetsSetAt()

evxErrors cvxPartFacetsSetAt | ( | int | idBlock,
 |  | const svxFaceAt * | At
 | ) |  |

#include <zwapi_part_facets.h>

Modifies display attributes of the specified block. It is assumed the
specified block resides in the active part.

Parameters
[in] | idBlock | id of 3D Block
[in] | At | display attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacetsSetTx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartFacetsSetTx()

evxErrors cvxPartFacetsSetTx | ( | int | idBlock,
 |  | const svxTextureAt * | Tx
 | ) |  |

#include <zwapi_part_facets.h>

Modifies texture map attributes of the specified block. It is assumed
the specified block (idBlock) resides in the active part.

If the "file" field of the svxTextureAt structure is empty (a
zero-length string), the texture map attributes are not saved and any
prior texture map assigned to the block is removed.

The "opt" field of the svxTextureAt structure is not currently supported.

Parameters
[in] | idBlock | id of 3D Block
[in] | Tx | texture map attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqBlockPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqBlockPnts()

evxErrors cvxPartInqBlockPnts | ( | int | idBlock,
 |  | int * | Count,
 |  | svxPointf ** | Points
 | ) |  |

#include <zwapi_part_facets.h>

Outputs a list of points in the specified 3D Point Block.
Memory for the point list is allocated by this function and output
via "Points". It must be deallocated by the calling procedure
with cvxMemFree().

Parameters
[in] | idBlock | id of point block in active part
[out] | Count | number of points
[out] | Points | list of points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqBlocks

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqBlocks()

evxErrors cvxPartInqBlocks | ( | int * | Count,
 |  | int ** | Blocks
 | ) |  |

#include <zwapi_part_facets.h>

Outputs a list of database id's of 3D blocks of the specified type within the
active part. If there are no blocks, "*Count" is output as zero and "*Blocks"
as NULL.

This function allocates memory for the array output via "Blocks". The calling
procedure is responsible for deallocating the memory.

Parameters
[out] | Count | number of 3D blocks in the active part
[out] | Blocks | list of id's of 3D blocks in the active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqBlockType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqBlockType()

evxErrors cvxPartInqBlockType | ( | int | idBlock,
 |  | evxBlockType * | Type
 | ) |  |

#include <zwapi_part_facets.h>

Outputs the id of the parent feature of the specified entity in the active part.

Parameters
[in] | idBlock | 3D block id
[out] | Type | block type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFaceFacets()

evxErrors cvxPartInqFaceFacets | ( | int | idFace,
 |  | int * | Count,
 |  | svxTriangle ** | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Outputs a list of the triangular facets used to display the specified face.

Memory for "Facets" is allocated by this function. It
MUST be deallocated by the calling procedure with cvxMemFree().

It is assumed the specified face (idFace) resides in the active part.

Parameters
[in] | idFace | face id
[out] | Count | number of triangular facets
[out] | Facets | list of triangular facets
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceFacets2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFaceFacets2()

evxErrors cvxPartInqFaceFacets2 | ( | int | idFace,
 |  | svxFacets * | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Outputs the facets used to display the specified face along with
display, texture or shader attributes that may be defined for the
face.

This function allocates memory for lists inside the
input "Facets" structure. The calling procedure is
responsible to free the lists using cvxFacetsFree(Facets).

It is assumed the specified face (idFace) resides in the active part.

The following is sample code for retrieving and traversing a face's facet data:

void TestApi(void){
int k= 0, num, i1, i2, i3, idFace;
svxFacets Fct;
svxPointf v1, v2, v3;
svxPointf n1, n2, n3;
svxPoint p1, p2;
// get a face selection
if (cvxGetEnt("Select face",VX_INP_FACE,0,&idFace)) return;
// retrieve the face's facet data
cvxPartInqFaceFacets2(idFace, &Fct);
// traverse the triangles defined in the facet data
for (int i=0, k=0; i < Fct.numTriStrip; i++){
// get the number of vertices in the next triangle strip
num = Fct.TriStrip[k++];
// get each triangle in the triangle strip
for (int j=0; j < (num-2); j++){
// get the vertex indices that define the next triangle
i1 = Fct.TriStrip[k];
i2 = Fct.TriStrip[k+1];
i3 = Fct.TriStrip[k+2];
// get the triangle's vertices
v1 = Fct.Vertex[i1];
v2 = Fct.Vertex[i2];
v3 = Fct.Vertex[i3];
// get the normal at each vertex
n1 = Fct.Normal[i1];
n2 = Fct.Normal[i2];
n3 = Fct.Normal[i3];
// increment counter to start of next triangle
++k;
}
// increment counter to start of next triangle strip
k += 2;
}
// free the facet data
cvxFacetsFree(&Fct);
return;
}
cvxFacetsFree
void cvxFacetsFree(svxFacets *Facets)
cvxPartInqFaceFacets2
evxErrors cvxPartInqFaceFacets2(int idFace, svxFacets *Facets)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
svxFacets::Vertex
svxPointf * Vertex
list of vertex coordinates (x,y,z)
Definition: zwapi_util.h:1909
svxFacets::Normal
svxPointf * Normal
list of vertex normals (i,j,k unit direction vector); Normal is optional and may be NULL
Definition: zwapi_util.h:1910
svxFacets::TriStrip
int * TriStrip
list of integer indices that define triangle strips
Definition: zwapi_util.h:1894
svxFacets::numTriStrip
int numTriStrip
number of triangle strips in TriStrip list
Definition: zwapi_util.h:1893
svxFacets
3D facets defined by triangle strips
Definition: zwapi_util.h:1892
svxPoint
3D point
Definition: zwapi_util.h:306
svxPointf
3D point (single precision floating point)
Definition: zwapi_util.h:317
Parameters
[in] | idFace | face id
[out] | Facets | facet data set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceFacets2ByTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFaceFacets2ByTol()

evxErrors cvxPartInqFaceFacets2ByTol | ( | svxRefineFacets * | RefineData,
 |  | svxFacets * | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Outputs the facets used to display the specified face along with
display, texture or shader attributes that may be defined for the
specified face at specifies RefineData.

This function allocates memory for lists inside the
input "Facets" structure. The calling procedure is
responsible to free the lists using cvxFacetsFree(Facets).

It is assumed the specified face (RefineData.listFaceId) resides in the active part.

If the value of chord height and angle exceeds the specified range,
the default value will be used instead.

Note
If the face is planar, ChordHeight(VX_FACETS_TOL_DISTANCE,VX_FACETS_TOL_PIXEL) and angle(VX_FACETS_TOL_ANGLE) are ignored.

Structure svxRefineFacets can be initialized through interface cvxPartRefineFacetsInit().

Parameters
[in] | RefineData | refine facets data
[out] | Facets | facet data set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceFacetsByChord

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFaceFacetsByChord()

evxErrors cvxPartInqFaceFacetsByChord | ( | int | idFace,
 |  | double | ChordHeight,
 |  | int * | Count,
 |  | svxTriangle ** | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Outputs a list of the triangular facets used to display the specified face at specified chord height.

Memory for "Facets" is allocated by this function. It
MUST be deallocated by the calling procedure with cvxMemFree().

It is assumed the specified face (idFace) resides in the active part.

Note
if the idFace is planar, ChordHeight is invalid for this function.
Parameters
[in] | idFace | face id
[in] | ChordHeight | chord height for facet generation(min = 0.001, )
[out] | Count | number of triangular facets
[out] | Facets | list of triangular facets
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFacets()

evxErrors cvxPartInqFacets | ( | int | idBlock,
 |  | svxSTL * | Stl
 | ) |  |

#include <zwapi_part_facets.h>

Outputs a list of triangular facets of the specified STL.

Memory for the STL facets is allocated by this function and
assigned to the input data structure (Stl). It MUST be
deallocated by the calling procedure using cvxStlFree().

Parameters
[in] | idBlock | STL id
[out] | Stl | STL facets
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFacets2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFacets2()

evxErrors cvxPartInqFacets2 | ( | int | idBlock,
 |  | svxFacets * | Facets
 | ) |  |

#include <zwapi_part_facets.h>

Outputs the facets stored in the specified 3D block.

This function allocates memory for lists inside the
input "Facets" structure. The calling procedure is
responsible to free the lists using cvxFacetsFree(Facets).

It is assumed the specified 3D block (idBlock) resides in the active part.

See also
the description of cvxPartInqFaceFacets2() for additional information.
Parameters
[in] | idBlock | 3D block id
[out] | Facets | facet data set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFacetsTxFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFacetsTxFile()

evxErrors cvxPartInqFacetsTxFile | ( | int | idBlock,
 |  | vxPath | Path
 | ) |  |

#include <zwapi_part_facets.h>

Outputs path to the original image file if a texture map has been
applied to a facet block. Unlike cvxPartInqFacets2(), which outputs
the path to a copy of the original image file that ZW3D has put in its
temp directory, this function outputs the path that was originally
used to create the texture map. The file might no longer exist,
although the image may still exist as an embedded object.

It is assumed the specified block (idBlock) resides in the active part.

See also
cvxPartInqFacets2() for a function that outputs all texture map attributes.
Parameters
[in] | idBlock | 3D block id
[out] | Path | path to texture map's original image file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFacetsTxFileByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartInqFacetsTxFileByLongPath()

evxErrors cvxPartInqFacetsTxFileByLongPath | ( | int | idBlock,
 |  | char * | Path,
 |  | int | sizePath
 | ) |  |

#include <zwapi_part_facets.h>

Outputs path to the original image file if a texture map has been applied to a facet block. Unlike cvxPartInqFacets2(), which outputs the path to a copy of the original image file that ZW3D has put in its temp directory, this function outputs the path that was originally used to create the texture map. The file might no longer exist, although the image may still exist as an embedded object.

It is assumed the specified block (idBlock) resides in the active part.

A Path that is too long (longer than "sizePath") is truncated.

It is assumed that the input "Path" is no longer than 512 bytes.

See also
cvxPartInqFacets2() for a function that outputs all texture map attributes.
Parameters
[in] | idBlock | 3D block id
[out] | Path | path to texture map's original image file
[in] | sizePath | max size of Path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPntBlock

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartPntBlock()

int cvxPartPntBlock | ( | vxLongName | Name,
 |  | int | Count,
 |  | svxPointf * | Points,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_part_facets.h>

Adds a 3D point block to the active part. If "idEnt" is not NULL, the id of the new block is output.

The active point attribute color is assigned to the new point block.

This function will only add point blocks to parts for which explicit (i.e. history free)
point cloud management is enabled (the default mode for parts created with version 18 or later).

Parameters
[in] | Name | point block name
[in] | Count | number of points
[in] | Points | list of points
[out] | idEnt | id of new point block (input NULL to ignore this output)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
other
  • -1 - explicit mode is not enabled
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartProjStl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartProjStl()

evxErrors cvxPartProjStl | ( | int | idStl,
 |  | int | idPln,
 |  | double | tol,
 |  | double | smth,
 |  | int * | idCurve
 | ) |  |

#include <zwapi_part_facets.h>

Project the STL to a plane, to get its boundary curve.
Output new boundary curve via "idCurve".

Parameters
[in] | idStl | STL id
[in] | idPln | plane id
[in] | tol | refit tolerance
[in] | smth | refit smooth
[out] | idCurve | id of STL boundary curve (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRefineFacetsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartRefineFacetsInit()

evxErrors cvxPartRefineFacetsInit ( svxRefineFacets * data )

#include <zwapi_part_facets.h>

Initialize the parameters of the cvxPartInqFaceFacets2ByTol().

Note
Do not assign a value to variable "data" before calling this function.
The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data refine facets data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSTLConvertToFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxPartSTLConvertToFacets()

evxErrors cvxPartSTLConvertToFacets | ( | const svxSTL * | stl,
 |  | svxFacets * | facets
 | ) |  |

#include <zwapi_part_facets.h>

Structures svxFacets and svxSTL are converted to each other.

Parameters
[in] | stl | STL data
[out] | facets | facet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxStlFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Facets/Block
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ cvxStlFree()

void cvxStlFree ( svxSTL * Stl )

#include <zwapi_part_facets.h>

Frees memory associated with the specified STL structure.

Parameters
[in] Stl 3D "STL" triangle mesh data structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: History API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
History API
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part History Object API

History Regeneration

int | cvxPartRegenIsActive (void)
int | cvxPartRedefineIsActive (void)
evxErrors | cvxPartRegenFacets (int Count, int *idFaces, int Assembly, int LOD, double Tol)
void | cvxPartPartialResults (int Disable)

History Query

evxErrors | cvxPartHistList (int Option, int *Cnts, int **HistList)
evxErrors | cvxPartInqFtrList (int *Count, int **Features)

Feature Query

int | cvxFtrIsSubPart (int idFtr)
int | cvxPartFtrIsMissRef (int idFeature, char *status)
int | cvxPartInqFtrAssoPart (int idFeature, vxPath file, vxRootName rootName)
int | cvxPartInqFtrAssoPartByLongPath (int idFeature, char *file, int sizeFile, char *rootName, int sizeRName)
int | cvxPartInqFtrData (int idFeature, int iNoEval, int *idData)
int | cvxPartFtrInqAuxFtrs (int idFtr, int *count, int **idAuxFtrs)
evxErrors | cvxPartInqFtrTemplate (int idFeature, vxName Template)
evxErrors | cvxPartInqFtrTol (int idFeature, double *Tolerance)
evxErrors | cvxPartInqFtrRegenStat (int idFeature, char *stat)
evxErrors | cvxPartInqFtrRegenStatus (int idFtr, evxFtrRegenStatus *status)
evxErrors | cvxPartInqFtrVersion (int idFeature, int *Version)
evxErrors | cvxPartInqFtrGroup (int idFeature, int *idGroup)

Group Features

evxErrors | cvxPartInqGroupFtrs (int idGroup, int *count, int **ftrList)
evxErrors | cvxPartInqGroupList (int *count, int **groups)

Feature's Parent/Child Features

evxErrors | cvxPartInqFtrParentFtrs (int idFeature, int getAll, int *cnt, int **list)
evxErrors | cvxPartInqFtrChildFtrs (int idFeature, int *cnt, int **list)

Feature's Entities

evxErrors | cvxPartFtrInqInpEnts (int idFeature, evxEntType type, int *cnt, int **list)
evxErrors | cvxPartInqFtrEnts (int idFeature, evxEntType EntType, int *Count, int **Ents)

Feature/Sketch Attribute

evxErrors | cvxPartFtrUserAtGet (int idFeature, int *Count, svxAttribute **UserAt)
evxErrors | cvxPartFtrUserAtSet (int idFeature, int Count, svxAttribute *UserAt)
evxErrors | cvxPartFtrUserAtDel (int idFeature, int Count, svxAttribute *UserAt)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxFtrIsSubPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxFtrIsSubPart()

int cvxFtrIsSubPart ( int idFtr )

#include <zwapi_part_history.h>

Determine whether the feature is a sub-part.

Parameters
[in] idFtr feature id
Return values
return
  • 1 - the feature is sub-part
  • 0 - the feature is not sub-part
fail
  • -1 - function fails
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrInqAuxFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrInqAuxFtrs()

int cvxPartFtrInqAuxFtrs | ( | int | idFtr,
 |  | int * | count,
 |  | int ** | idAuxFtrs
 | ) |  |

#include <zwapi_part_history.h>

Gets a list of auxiliary features for the specified feature.

The memory referenced by "idAuxFtrs" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)idAuxFtrs)).

Parameters
[in] | idFtr | id feature
[out] | count | count of idAuxFtrs
[out] | idAuxFtrs | list of auxiliary feature id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_INPUT_TYPE_ERROR
other
  • -1 - not found auxiliary feature
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrInqInpEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrInqInpEnts()

evxErrors cvxPartFtrInqInpEnts | ( | int | idFeature,
 |  | evxEntType | type,
 |  | int * | cnt,
 |  | int ** | list
 | ) |  |

#include <zwapi_part_history.h>

Get the specified entities of the specified feature. These entities are in the VDATA of the feature.

Note
Usually we need to call cvxPartFtrPlayTo() to rollback to "idFeature" first,
and then call this function to get the input entities.
The feature list (list) is allocated by this function and must be
deallocated by the calling procedure.
Some of evxEntType(VX_ENT_BREP, VX_ENT_OP, VX_ENT_POINT, VX_ENT_WIRE) are banned in this function.
Parameters
[in] | idFeature | index of feature in active bin
[in] | type | entity type id
[out] | cnt | no. of specified entities
[out] | list | list of entities
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrIsMissRef

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrIsMissRef()

int cvxPartFtrIsMissRef | ( | int | idFeature,
 |  | char * | status
 | ) |  |

#include <zwapi_part_history.h>

Determines whether a reference feature has lost external references.

Parameters
[in] | idFeature | reference feature id
[out] | status | feature status. 1 is miss reference, 0 is no miss reference.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
other
  • -1 - idFeature is not a external reference feature
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrUserAtDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrUserAtDel()

evxErrors cvxPartFtrUserAtDel | ( | int | idFeature,
 |  | int | Count,
 |  | svxAttribute * | UserAt
 | ) |  |

#include <zwapi_part_history.h>

Delete user attribute of the specified feature or sketch in the current active part.
the function does not delete any attributes if the specified label is an empty string
or the attribute specified label is not found.

Parameters
[in] | idFeature | index of feature or sketch
[in] | Count | number of user attributes (0 to delete all user attributes)
[in] | UserAt | list of user attributes (NULL to delete all user attributes)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrUserAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrUserAtGet()

evxErrors cvxPartFtrUserAtGet | ( | int | idFeature,
 |  | int * | Count,
 |  | svxAttribute ** | UserAt
 | ) |  |

#include <zwapi_part_history.h>

Retrieves user attribute data of the specified feature or sketch in the current active part.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFeature | index of feature or sketch
[out] | Count | number of user attributes
[out] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_aPI_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrUserAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartFtrUserAtSet()

evxErrors cvxPartFtrUserAtSet | ( | int | idFeature,
 |  | int | Count,
 |  | svxAttribute * | UserAt
 | ) |  |

#include <zwapi_part_history.h>

Set user attribute data of the specified feature or sketch in the current active part.
a new user attribute is inserted if the user attribute for the specified label does not exist.

Parameters
[in] | idFeature | index of feature or sketch
[in] | Count | number of user attributes
[in] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartHistList()

evxErrors cvxPartHistList | ( | int | Option,
 |  | int * | Cnts,
 |  | int ** | HistList
 | ) |  |

#include <zwapi_part_history.h>

Gets a list of history operations in the active part as specified by the input "Option".

The memory referenced by "HistList" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)HistList)).

See also
cvxPartInqFtrList() is the same as cvxPartHistList when Type = 0.
Parameters
[in] Option Option=0 : get history operations that have been played
Option=1 : get history operations that have not been played
Option=2 : get played and unplayed history operations
[out] | Cnts | number of history operations
[out] | HistList | list of history operations
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrAssoPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrAssoPart()

int cvxPartInqFtrAssoPart | ( | int | idFeature,
 |  | vxPath | file,
 |  | vxRootName | rootName
 | ) |  |

#include <zwapi_part_history.h>

Get information about the source file associated with the specified
external reference feature, including file name, root name.

Parameters
[in] | idFeature | index of external feature in active part
[out] | file | associated external file name (NULL to ignore)
[out] | part | associated external root name (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • Zw_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT+OF_RANGE
other
  • -1 - feature is not an external reference feature
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrAssoPartByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrAssoPartByLongPath()

int cvxPartInqFtrAssoPartByLongPath | ( | int | idFeature,
 |  | char * | file,
 |  | int | sizeFile,
 |  | char * | rootName,
 |  | int | sizeRName
 | ) |  |

#include <zwapi_part_history.h>

Get information about the source file associated with the specified external reference feature, including file name, root name.

A file that is too long (longer than "sizeFile") is truncated. A rootName that is too long (longer than "sizeRName") is truncated.

It is assumed that the input "file" is no longer than 512 bytes. It is assumed that the input "rootName" is no longer than 256 bytes.

Parameters
[in] | idFeature | index of external feature in active part
[out] | fileName | associated external file name (NULL to ignore)
[in] | sizePath | max size of fileName
[out] | rootName | associated external root name (NULL to ignore)
[in] | sizeRName | max size of rootName
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • Zw_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT+OF_RANGE
other
  • -1 - feature is not an external reference feature
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrChildFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrChildFtrs()

evxErrors cvxPartInqFtrChildFtrs | ( | int | idFeature,
 |  | int * | cnt,
 |  | int ** | list
 | ) |  |

#include <zwapi_part_history.h>

Get the child features of specified feature.

The feature list (list) is allocated by this function and must be
deallocated by the calling procedure.

Parameters
[in] | idFeature | index of feature in active part
[out] | cnt | no. of children
[out] | list | list of indices of feature's children
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrData()

int cvxPartInqFtrData | ( | int | idFeature,
 |  | int | iNoEval,
 |  | int * | idData
 | ) |  |

#include <zwapi_part_history.h>

Outputs the id of a copy of the specified feature's data container.
The calling procedure MUST deallocate "idData" using cvxDataFree()
after it is done querying "idData" with the cvxDataXXX() functions.

The data associated with a feature is stored in a "persistent" format.
Entity references in the data are stored in a format that uses entity
labels that were current at the time the feature operation was executed.
Before the data can be queried for current entity id's, it must be
re-evaluated. This can fail if it references entities that no longer
exist. Point selections that reference entities (e.g. entity endpoint)
can also fail to re-evaluate if the referenced entities no longer exist.

Re-evaluation of the feature data is done without rolling the history
back to the specified feature. For this reason, the success or failure
of this function is very sensitive to whether the current state of the
model contains all of the geometry that existed at the time that the
feature was originally executed.

If you know that the feature data will not re-evaluate based on the
current state of the model, you can get the last evaluated state of
point and numeric inputs by calling this function with "iNoEval=1".
In this case, you will not be able to successfully query any entity
data fields in "idData".

Parameters
[in] | idFeature | feature id
[in] | iNoEval | 1 to get unevaluated data; else 0
[out] | idData | id of feature data container
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
other
  • -1 - feature data is undefined
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrEnts()

evxErrors cvxPartInqFtrEnts | ( | int | idFeature,
 |  | evxEntType | EntType,
 |  | int * | Count,
 |  | int ** | Ents
 | ) |  |

#include <zwapi_part_history.h>

Outputs a list of indices of the entity IDs that belong to
the specified feature in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Right now, this function only support to get shape, face, curve, point, dimension form the feature.

Parameters
[in] | idFeature | feature id
[in] | EntType | entity type id
[out] | Count | number of entities
[out] | Ents | list of the entity IDs
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrGroup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrGroup()

evxErrors cvxPartInqFtrGroup | ( | int | idFeature,
 |  | int * | idGroup
 | ) |  |

#include <zwapi_part_history.h>

Output the index of the feature group where the specified
feature is located. Output -1 if the specified feature is not
in any feature group.

Parameters
[in] | idFeature | feature id
[out] | idGroup | feature group id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrList()

evxErrors cvxPartInqFtrList | ( | int * | Count,
 |  | int ** | Features
 | ) |  |

#include <zwapi_part_history.h>

Outputs a list of database id's of features (i.e. operations) in the active part's history
in the order they are listed there (including hidden operations). If there are no features,
"*Count" is output as zero and "*Features" as NULL.

This function allocates memory for the array output via "Features". The calling
procedure is responsible for deallocating the memory.

Parameters
[out] | Count | number of features in the active part
[out] | Features | list of id's of features (i.e. operations) in the active part history
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrParentFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrParentFtrs()

evxErrors cvxPartInqFtrParentFtrs | ( | int | idFeature,
 |  | int | getAll,
 |  | int * | cnt,
 |  | int ** | list
 | ) |  |

#include <zwapi_part_history.h>

Get a list of parent features upon with the specified feature is dependent.

The feature list (list) is allocated by this function and must be
deallocated by the calling procedure.

Parameters
[in] | idFeature | index of feature in active part
[in] getAll 1 to get all parent features (parents and grandparents)
0 to get just the immediate parent features
[out] | cnt | no. of parent features
[out] | list | list of indices of parent features
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrRegenStat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrRegenStat()

evxErrors cvxPartInqFtrRegenStat | ( | int | idFeature,
 |  | char * | stat
 | ) |  |

#include <zwapi_part_history.h>

Outputs the regen state of a feature.
Judge the suppression state of the feature.

Note
The functions of cvxPartInqFtrRegenStat() interface and cvxPartInqFtrRegenStatus()
interface are completely different.
Parameters
[in] idFeature feature index
[out] stat feature regen status as below:
0, regen the feature without suppression
1, feature is manually suppressed
2, feature is automatically suppressed due to the failure of regen
4, feature have suppress condition
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrRegenStatus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrRegenStatus()

evxErrors cvxPartInqFtrRegenStatus | ( | int | idFtr,
 |  | evxFtrRegenStatus * | status
 | ) |  |

#include <zwapi_part_history.h>

Get the missing state or constraint state of the feature.

Note
The functions of cvxPartInqFtrRegenStat() interface and cvxPartInqFtrRegenStatus() interface are completely different.
Parameters
[in] | idFtr | feature index
[out] | status | feature regen status
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrTemplate()

evxErrors cvxPartInqFtrTemplate | ( | int | idFeature,
 |  | vxName | Template
 | ) |  |

#include <zwapi_part_history.h>

Outputs the name of the command template that defines the input
parameters of the specified feature.

Parameters
[in] | idFeature | feature id
[out] | Template | feature command template name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrTol()

evxErrors cvxPartInqFtrTol | ( | int | idFeature,
 |  | double * | Tolerance
 | ) |  |

#include <zwapi_part_history.h>

Outputs tolerance used by the specified feature.

Parameters
[in] | idFeature | feature id
[out] | Tolerance | feature tolerance
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFtrVersion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqFtrVersion()

evxErrors cvxPartInqFtrVersion | ( | int | idFeature,
 |  | int * | Version
 | ) |  |

#include <zwapi_part_history.h>

Outputs the product version number associated with the specified
feature. If "idFeature < 1", outputs the version number of the
"active" feature (i.e. the feature currently regenerating).

Parameters
[in] | idFeature | feature id
[out] | Version | feature version number
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqGroupFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqGroupFtrs()

evxErrors cvxPartInqGroupFtrs | ( | int | idGroup,
 |  | int * | count,
 |  | int ** | ftrList
 | ) |  |

#include <zwapi_part_history.h>

Output all feature_id within the specified feature group.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idGroup | feature group id
[out] | count | number of elements in the Feature list
[out] | ftrList | list of feature id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqGroupList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartInqGroupList()

evxErrors cvxPartInqGroupList | ( | int * | count,
 |  | int ** | groups
 | ) |  |

#include <zwapi_part_history.h>

Outputs a list of database id's of feature groups in the active part's history
in the order they are listed there. If there are no groups,
"*count" is output as zero and "*groups" as NULL.

This function allocates memory for the array output via "groups". The calling
procedure is responsible for deallocating the memory.

Parameters
[out] | count | number of features in the active part
[out] | groups | list of id's of groups in the active part history
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPartialResults

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartPartialResults()

void cvxPartPartialResults ( int Disable )

#include <zwapi_part_history.h>

Passing 1 to this function disables the prompt for partial fillet results and
causes a failed fillet to exit rather than attempt to generate partial results.

Passing 0 to this function re-enables the prompt for partial fillet results.

This function MUST be called in pairs, first with "iDisable=1", then with
"iDisable=0". Otherwise partial results could become permanently disabled
during the active session.

Parameters
[in] Disable 1 to disable partial results, 0 to re-enable it
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRedefineIsActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartRedefineIsActive()

int cvxPartRedefineIsActive ( void )

#include <zwapi_part_history.h>

Determine whether a part is currently being redefined.

Return values
return
  • 1 - if a part feature is currently being redefined.
  • 0 - Otherwise.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRegenFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartRegenFacets()

evxErrors cvxPartRegenFacets | ( | int | Count,
 |  | int * | idFaces,
 |  | int | Assembly,
 |  | int | LOD,
 |  | double | Tol
 | ) |  |

#include <zwapi_part_history.h>

Regenerates triangle facet data used to display the specified faces (Count and idFaces).

If no faces are specified (Count=0 and idFaces=NULL), all faces in the active part are
re-tessellated at the specified tolerance (Tol). If "Assembly != 0", all faces in the active assembly are re-tessellated.

If "Tol" is input as zero, a tolerance based on the active view extent is used.

If "LOD != 0", levels of detail are calculated for faces that are retessellated. That
means that facet data is generated at a tight tolerance, then organized into several
levels of detail from coarse to fine. Level-of-Detail generates more data for each
face, but the speed and quality of face display can be optimized based on the size
of a face relative to the active view extent.

Parameters
[in] | Count | number of faces
[in] | idFaces | list of face id's in active part
[in] | Assembly | 1 to regenerate facets for active assembly, else 0
[in] | LOD | 1 to generate level-of-detail, else 0
[in] | Tol | chord-height tolerance for facet generation (0.0 for default)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRegenIsActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • History API
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ cvxPartRegenIsActive()

int cvxPartRegenIsActive ( void )

#include <zwapi_part_history.h>

Determine whether a part is currently regenerating.

Return values
return
  • 1 - if a part feature is currently regenerating.
  • 0 - Otherwise .
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Hole Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Hole Attribute
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Hole Data API

Part Hole

evxErrors | cvxPartInqHoles (const vxLongPath File, const vxRootName Part, int *Count, svxHoleData **Holes)
void | cvxPartFreeHoles (int Count, svxHoleData **Holes)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFreeHoles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Hole Attribute
cvxPartFreeHoles
cvxPartInqHoles

◆ cvxPartFreeHoles()

void cvxPartFreeHoles | ( | int | Count,
 |  | svxHoleData ** | Holes
 | ) |  |

#include <zwapi_part_hole.h>

Frees memory associated with the input hole list.
The input memory pointer (*Holes) is set to NULL.

Parameters
[in] | Count | number of holes
[in,out] | Holes | list of holes
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqHoles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Hole Attribute
cvxPartFreeHoles
cvxPartInqHoles

◆ cvxPartInqHoles()

evxErrors cvxPartInqHoles | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | svxHoleData ** | Holes
 | ) |  |

#include <zwapi_part_hole.h>

Outputs a list of holes that belong to the specified part.
The calling procedure MUST deallocate the output list using
cvxPartFreeHoles(Count, Holes);

The "idInsFace" and "idUntilFace" fields of the "svxHoleData"
structure are not currently supported. They are always output
as zero. "ThreadType" is always output as VX_THREAD_CUSTOM.

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | Count | number of holes
[out] | Holes | list of holes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Objects API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Objects API
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Objects Query API

Curve

evxErrors | cvxPartInqCurves (int *Count, int **Curves)
evxErrors | cvxPartInqCrvLists (int *Count, int **CrvLists)
evxErrors | cvxPartInqCrvList (int idCrvList, int *Count, svxEntPick **Curves)
evxErrors | cvxPartInqCurve (int idEntity, int Nurb, svxCurve *Crv)
void | cvxCurveFree (svxCurve *Crv)

Point

evxErrors cvxPartInqPoints (int *count, int **pointIdx)

Text Query

evxErrors | cvxPartInqAnnoTexts (int *Count, int **Texts)
evxErrors | cvxPartInqTexts (int *count, int **idTexts)

Other Objects

evxErrors | cvxPartInqConstraints (const vxLongPath File, const vxRootName Part, int *count, int **cons)
evxErrors | cvxPartInqTempData (int idPart, int *count, int **datas)

Publish Set

evxErrors | cvxPartInqPublishSets (const vxLongPath File, const vxRootName Part, int *Count, int **idPubSets)
evxErrors | cvxPartInqPublishSet (const vxLongPath File, const vxRootName Part, int idPubSet, vxName Name, int *Count, int **idEnts)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxCurveFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxCurveFree()

void cvxCurveFree ( svxCurve * Crv )

#include <zwapi_part_objs.h>

Frees memory associated with the specified curve structure.

Parameters
[in] Crv curve structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\shapeFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAnnoTexts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqAnnoTexts()

evxErrors cvxPartInqAnnoTexts | ( | int * | Count,
 |  | int ** | Texts
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of the text that belong to
the active part. The calling procedure MUST deallocate
the output list with cvxMemFree().

Note
See cvxPartInqTexts() to get both annotation text and balloon text entities.
Parameters
[out] | Count | number of curves
[out] | Texts | list of text id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqConstraints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqConstraints()

evxErrors cvxPartInqConstraints | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | count,
 |  | int ** | cons
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of the constraints in the specified component.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Part | root object name (Part[0]=0 or NULL for active target object)
[out] | count | number of constraints
[out] | cons | list of constraint ids
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCrvList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqCrvList()

evxErrors cvxPartInqCrvList | ( | int | idCrvList,
 |  | int * | Count,
 |  | svxEntPick ** | Curves
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of the curve or edge entities referenced by the
specified curve-list entity within the active part. The curve
references are output using the "svxEntPick" data structure
so that parent sketches can be identified for sketch curves
instanced by the curve list.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idCrvList | id of curve-list entity in active part
[out] | Count | number of curves (0 if there are no curves)
[out] | Curves | list of curves (NULL if there are no curves)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\partUtils.cpp, and part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCrvLists

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqCrvLists()

evxErrors cvxPartInqCrvLists | ( | int * | Count,
 |  | int ** | CrvLists
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of the curve list that belong to
the active part. The calling procedure MUST deallocate
the output list with cvxMemFree().

Parameters
[out] | Count | number of curves
[out] | CrvLists | list of curve list id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Examples
part\partUtils.cpp, and part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqCurve()

evxErrors cvxPartInqCurve | ( | int | idEntity,
 |  | int | Nurb,
 |  | svxCurve * | Crv
 | ) |  |

#include <zwapi_part_objs.h>

Gets curve geometry for the specified curvilinear entity, including
face edges. If "Nurb" is input as 1, NURBS data is output for
analytic curve types (e.g. line, arc, circle). NURBS data is output
via "Crv" using memory allocated by this function. The memory MUST
be deallocated by the calling procedure using cvxCurveFree(). It
is assumed the curve geometry resides in the active part.

Parameters
[in] | idEntity | id of curvilinear entity (includes edges)
[in] | Nurb | 1=get NURBS data for all curve types; else 0
[out] | Crv | curve data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCurves

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqCurves()

evxErrors cvxPartInqCurves | ( | int * | Count,
 |  | int ** | Curves
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of the curves that belong to
the active part. The calling procedure MUST deallocate
the output list with cvxMemFree().

Parameters
[out] | Count | number of curves
[out] | Curves | list of curve id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqPoints()

evxErrors cvxPartInqPoints | ( | int * | count,
 |  | int ** | pointIdx
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of point objects that belong to
the active part. The calling procedure MUST deallocate the
output list with cvxMemFree().

Parameters
[out] | count | number of points
[out] | pointIdx | list of points' indices
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPublishSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqPublishSet()

evxErrors cvxPartInqPublishSet | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int | idPubSet,
 |  | vxName | Name,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_part_objs.h>

Query data of the specified publication set in the specified part.
The calling procedure MUST deallocate the output list with cvxMemFree().

If the specified file is not already open, this function will open it
to query publish sets, and will then close the file. If you want to
keep the file open, use the cvxFileKeep function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose or cvxFileSave functions.

See also
cvxPartPublishSet(): create a publication set to publish the specified entities.
cvxPartInqPublishSets(): get a list of indices of the publication set.
cvxPartPublishSetDel(): delete the specified publication sets.
Parameters
[in] | File | file name (File[0]=0 or NULL for active file)
[in] | Part | root object name (Part[0]=0 or NULL for active target object or single object file)
[in] | idPubSet | id of publication set to query
[out] | Name | name of publication set (NULL to ignore)
[out] | Count | number of entities published by publication set (NULL to ignore)
[out] | idEnts | list of ids of the entities published by publication set (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPublishSets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqPublishSets()

evxErrors cvxPartInqPublishSets | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | int ** | idPubSets
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of indices of the publication set in the specified part.
The calling procedure MUST deallocate the output list with cvxMemFree().

If the specified file is not already open, this function will open it
to query publish sets, and will then close the file. If you want to
keep the file open, use the cvxFileKeep function, before calling this
function, to set a flag that prevents this function from closing the
files that it opens. (Files that are already open before this function
is called are never closed by this function.) If you will be calling
several functions to access data in the same file, keeping the file open
between calls is more efficient than letting each function open and close
the file. However, you must remember to call cvxFileKeep again to reset
the flag after you have finished all of the function calls that need to
access the specified file, and you also become responsible for closing the
file, for example by using one of the cvxFileClose or cvxFileSave functions.

See also
cvxPartPublishSet(): create a publication set to publish the specified entities.
cvxPartInqPublishSet(): query data of the specified publication set.
cvxPartPublishSetDel(): delete the specified publication sets.
Parameters
[in] | File | file name (File[0]=0 or NULL for active file)
[in] | Part | root object name (Part[0]=0 or NULL for active target object or single object file)
[out] | Count | number of publication sets
[out] | idPubSets | list of publication set ids
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqTempData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqTempData()

evxErrors cvxPartInqTempData | ( | int | idPart,
 |  | int * | count,
 |  | int ** | datas
 | ) |  |

#include <zwapi_part_objs.h>

Get the temp data of the specified part or active part.
Such as the curves' id of the Section View.

The memory referenced by "datas" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)datas)).

Parameters
[in] | idPart | part id (-1 to use the active part)
[out] | count | count of datas
[out] | datas | temp datas
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_YPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqTexts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects API
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ cvxPartInqTexts()

evxErrors cvxPartInqTexts | ( | int * | count,
 |  | int ** | idTexts
 | ) |  |

#include <zwapi_part_objs.h>

Outputs a list of id of the text that belong to the active part,
including annotation, balloon, normal, bit-mapped and ready type.
The calling procedure MUST deallocate the output list with cvxMemFree.

Note
See cvxPartInqAnnoTexts() for a similar function that collects only annotation text entities.
Parameters
[out] | count | number of texts
[out] | idTexts | list of text id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Objects Operation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Objects Operation
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Menu Commands API

Part Exit

void cvxPartExit (void)

Explicit Operation

evxErrors | cvxPartBackup (void)
evxErrors | cvxHistBackup (void)
evxErrors | cvxPartEncapsulate (int Option, int KeepDimen)
evxErrors | cvxPartHistStart (vxName Name)
evxErrors | cvxPartHistEnd (void)

History Operation

evxErrors | cvxHistRedefine (vxName Operation)
evxErrors | cvxHistSkipTo (char *Expression, vxName Operation, int *idOp)
evxErrors | cvxPartFtrPlayTo (int idxFtrPlayTo, int state)
evxErrors | cvxPartFtrSuppress (int count, int *idFeatures, char suppress)
evxErrors | cvxPartHistGroup (int idFirst, int idLast, const vxName Name, int Close)
evxErrors | cvxPartHistInqGroup (int idHistObj, int *idGroup)
evxErrors | cvxPartHistPaste (void)
evxErrors | cvxPartHistClip (int Cut, int Count, int *Operations)
evxErrors | cvxPartHistClipbyPath (int Cut, int Count, svxEntPath *paths)
evxErrors | cvxPartHistRename (int idOp, vxName Name, char *Descript)
evxErrors | cvxPartHistDel (int Count, int *Operations)
evxErrors | cvxPartHistDelUtil (int Count, int *Operations, int OpType)
evxErrors | cvxPartDelGrpFtr (int idFtr, int delFtrs)
evxErrors | cvxPartMkEntExternal (int idEnt, int external)
void | cvxHistDisable (void)
void | cvxHistEnable (void)

Feature Creation

evxErrors cvxPartHistAdd (const int idData, const vxName FtrName, const int Option, int *idFtr)

Entity Operations

evxErrors | cvxPartErase (int Count, int *idEnts)
evxErrors | cvxPartHistScrollTo (int idEnt)

Publish Set Operations

evxErrors cvxPartPublishSetDel (int Count, const int *idPubSets)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxHistBackup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxHistBackup()

evxErrors cvxHistBackup ( void )

#include <zwapi_part_opts.h>

Backs up the current model state in a history operation. Saving model states in the history can speed up history rollback and regen.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxHistDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxHistDisable()

void cvxHistDisable ( void )

#include <zwapi_part_opts.h>

Disable history tree update.

The application that uses this function is ALWAYS responsible for re-enabling history tree update using cvxHistEnable().

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxHistEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxHistEnable()

void cvxHistEnable ( void )

#include <zwapi_part_opts.h>

Re-enable history tree update.

Calls to this function MUST ALWAYS be paired with a prior call to cvxHistDisable().

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxHistRedefine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxHistRedefine()

evxErrors cvxHistRedefine ( vxName Operation )

#include <zwapi_part_opts.h>

Launches interactive redefinition of the specified history operation.

Parameters
[in] Operation name of history operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxHistSkipTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxHistSkipTo()

evxErrors cvxHistSkipTo | ( | char * | Expression,
 |  | vxName | Operation,
 |  | int * | idOp
 | ) |  |

#include <zwapi_part_opts.h>

Logs a history operation that will cause history replay to skip to the specified operation if the specified conditional expression evaluates to a non-zero number (i.e. TRUE). If it evaluates to zero (i.e. FALSE), history execution continues without skipping anything.

Parameters
[in] | Expression | conditional expression (see documentation of "Skip To" command)
[in] | Operation | name of history operation
[in] | idOp | id of history operation created by this function (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBackup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartBackup()

evxErrors cvxPartBackup ( void )

#include <zwapi_part_opts.h>

Inserts a "Backup" operation in the active part's history.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDelGrpFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartDelGrpFtr()

evxErrors cvxPartDelGrpFtr | ( | int | idFtr,
 |  | int | delFtrs
 | ) |  |

#include <zwapi_part_opts.h>

Delete the feature group. delFtrs: 1-delete the features in the folder
0-just delete the folder

Note
You need regen the history after deleting all the features.
Parameters
[in] | idFtr | feature group index
[in] | delFtrs | delete the features in the folder or not
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEncapsulate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartEncapsulate()

evxErrors cvxPartEncapsulate | ( | int | Option,
 |  | int | KeepDimen
 | ) |  |

#include <zwapi_part_opts.h>

Encapsulates the active part's history.

Parameters
[in] Option 0 to encapsulate according to active configuration options;
1 to force encapsulate to use StartData/ExplicitData;
2 to force encapsulate to use ExplicitData and explicit shape features;
3 to force encapsulate to use Explicit data with active config setting for explicit shape features
[in] KeepDimen 1 to save feature dimensions with encapsulated data; 0 to delete them
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartErase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartErase()

evxErrors cvxPartErase | ( | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_part_opts.h>

Erase specified entities of current Part.

Note
This function is the same as cvxEntErase(), cvxEntErase() can erase the entities of part, sketch and drawing.
Parameters
[in] | Count | number of entities
[in] | idEnts | list of entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartExit()

void cvxPartExit ( void )

#include <zwapi_part_opts.h>

Exits the active part to its parent part if it was activated from within an assembly, to its parent CAM plan if it was activated from within a CAM plan, to its parent drawing sheet if it was activated from a drawing sheet view, or to the root object level of its parent file, if it was activated from the level of the root object list.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrPlayTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartFtrPlayTo()

evxErrors cvxPartFtrPlayTo | ( | int | idxFtrPlayTo,
 |  | int | state
 | ) |  |

#include <zwapi_part_opts.h>

Play the feature history to the top of specified feature. If the state is 1, rollback to the specified feature, else play to this feature.

Parameters
[in] | idxFtrPlayTo | id of feature play to
[in] | state | state of feature(1-has played, 0-not)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrSuppress

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartFtrSuppress()

evxErrors cvxPartFtrSuppress | ( | int | count,
 |  | int * | idFeatures,
 |  | char | suppress
 | ) |  |

#include <zwapi_part_opts.h>

Suppress or unSuppress the specified feature (including assembly feature).

Parameters
[in] | count | count of idFeatures
[in] | idFeatures | list of feature id
[in] | suppress | 1-suppress, 0-unSuppress
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistAdd()

evxErrors cvxPartHistAdd | ( | const int | idData,
 |  | const vxName | FtrName,
 |  | const int | Option,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_part_opts.h>

Add the feature defined by idData and FtrName in the active part. the function is used in the execution function of a template command. If a template command modifies or adds entities, a feature will be added to the history manager after the command is executed. the use case is as follows:

int CmdFun(int idData)
{
vxName ftrName = "FtrName";
cvxPartHistAdd(idData, ftrName, 1, NULL);
svxSurface srf = {};
...
cvxPartFace(&srf, 0, NULL, 1, 1, 0.0, NULL);
return 0;
}
cvxPartFace
evxErrors cvxPartFace(svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Code, int Sew, double Tol, int *idFace)
cvxPartHistAdd
evxErrors cvxPartHistAdd(const int idData, const vxName FtrName, const int Option, int *idFtr)
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
Parameters
[in] | idData | index of data container
[in] | FtrName | feature name
[in] | Option | feature type (0: feature may geometrically modify entities 1: feature may create new entities)
[out] | idFtr | index of feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistClip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistClip()

evxErrors cvxPartHistClip | ( | int | Cut,
 |  | int | Count,
 |  | int * | Operations
 | ) |  |

#include <zwapi_part_opts.h>

Cuts or copies the specified operations from the history of the active part to the clipboard, replacing operations previously stored on the clipboard.

Parameters
[in] | Cut | 1 to cut; 0 to copy
[in] | Count | number of history operations to cut or copy
[in] | Operations | list of history operation id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistClipbyPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistClipbyPath()

evxErrors cvxPartHistClipbyPath | ( | int | Cut,
 |  | int | Count,
 |  | svxEntPath * | paths
 | ) |  |

#include <zwapi_part_opts.h>

Cuts or copies the specified path of the active part to the clipboard, replacing operations previously stored on the clipboard.

Parameters
[in] | Cut | 1 to cut; 0 to copy
[in] | Count | number of history operations to cut or copy
[in] | paths | list of history operation path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistDel()

evxErrors cvxPartHistDel | ( | int | Count,
 |  | int * | Operations
 | ) |  |

#include <zwapi_part_opts.h>

Deletes the specified operations from the history of the active part.

Parameters
[in] | Count | number of history operations to delete
[in] | Operations | list of history operation id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistDelUtil

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistDelUtil()

evxErrors cvxPartHistDelUtil | ( | int | Count,
 |  | int * | Operations,
 |  | int | OpType
 | ) |  |

#include <zwapi_part_opts.h>

Deletes the specified operations from the history of the active part.

Parameters
[in] | Count | number of history operations to delete
[in] | Operations | list of history operation id's
[in] OpType OpType=0 : prompt to the user
OpType=1 : auto delete associated history operations
OpType=2 : auto suppress failed feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistEnd()

evxErrors cvxPartHistEnd ( void )

#include <zwapi_part_opts.h>

Used in conjunction with cvxPartHistStart() to bundle all existing part geometry and history to be bundled into a single static "StartData" history operation. It is the equivalent of cvxPartEncapsulate(1, 0).

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistGroup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistGroup()

evxErrors cvxPartHistGroup | ( | int | idFirst,
 |  | int | idLast,
 |  | const vxName | Name,
 |  | int | Close
 | ) |  |

#include <zwapi_part_opts.h>

Group the specified history operations.

Parameters
[in] | idFirst | id of first history operation
[in] | idLast | id of last history operation
[in] | Name | group name (input NULL for default name)
[in] | Close | 1 to close new group, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistInqGroup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistInqGroup()

evxErrors cvxPartHistInqGroup | ( | int | idHistObj,
 |  | int * | idGroup
 | ) |  |

#include <zwapi_part_opts.h>

Output the index of the group where the specified history object is located.

Output -1 if the specified history object is not in any group.

Parameters
[in] | idHistObj | all object ids in the history tree.
[out] | idGroup | group id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistPaste

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistPaste()

evxErrors cvxPartHistPaste ( void )

#include <zwapi_part_opts.h>

Paste operations currently on the clipboard into the history of the active part.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistRename()

evxErrors cvxPartHistRename | ( | int | idOp,
 |  | vxName | Name,
 |  | char * | Descript
 | ) |  |

#include <zwapi_part_opts.h>

Renames an operation in the history of the active part and assigns the specified description to it (if defined). Passing in a blank string for "Descript" will clear the description currently assigned to "idOp".

Parameters
[in] | idOp | id of history operation (i.e. feature)
[in] | Name | new operation name
[in] | Descript | new description (NULL if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistScrollTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistScrollTo()

evxErrors cvxPartHistScrollTo ( int idEnt )

#include <zwapi_part_opts.h>

Use this function to scroll to the feature in the history tree by the special entity.

Parameters
[in] idEnt located entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHistStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartHistStart()

evxErrors cvxPartHistStart ( vxName Name )

#include <zwapi_part_opts.h>

Defines a "static" feature (i.e. history operation) for program-generated geometry (e.g. faces) to attach to. When you are done adding geometry, call cvxPartHistEnd(). This function will cause all existing part geometry and history to be bundled into a single static "StartData" history operation.

Parameters
[in] Name history operation (i.e. feature) name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMkEntExternal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartMkEntExternal()

evxErrors cvxPartMkEntExternal | ( | int | idEnt,
 |  | int | external
 | ) |  |

#include <zwapi_part_opts.h>

Make the specified profile/datum internal/external.

Note
The profile/datum must be used by only one feature.
Parameters
[in] | idEnt | index of the profile/datum to make internal/external
[in] | external | 1-make external, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPublishSetDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Objects Operation
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ cvxPartPublishSetDel()

evxErrors cvxPartPublishSetDel | ( | int | Count,
 |  | const int * | idPubSets
 | ) |  |

#include <zwapi_part_opts.h>

Erase specified publication sets of current Part.

See also
cvxPartPublishSet(): create a publication set to publish the specified entities.
cvxPartInqPublishSets(): get a list of indices of the publication set.
cvxPartInqPublishSet(): query data of the specified publication set.
Parameters
[in] | Count | number of publication sets
[in] | idPubSets | list of publication set id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sheet Metal Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sheet Metal Attribute
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Sheet Metal Attributes API

Sheet Metal Attribute

evxErrors | cvxPartSmdAtGet (svxSmdAt *at)
evxErrors | cvxPartSmdAtSet (const svxSmdAt *at)

Flange Face

int | cvxPartInqSmdStatFcs (int idShape, int *countStat, int **statFcs, int *countPair, int **pairStatFcs)
evxErrors | cvxPartInqSmdStatFace (int idShape, int *idFace)
evxErrors | cvxPartInqSmdPairFaces (int idFace, int *count, int **faces)
evxErrors | cvxPartInqSmdSrfType (int idFace, evxSmdSurfaceType *type)
evxErrors | cvxPartInqShtMetalThick (int idShape, double *thick)
evxErrors | cvxPartSmdStatFaceSet (int idFace, int *idFtr)
evxErrors | cvxPartGetFlatSolids (int *cnts, int **solids)

Sheet Metal Flatten

evxErrors cvxPartInqFlattens (int *count, int **idFlattens, vxLongName **flattenNames)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartGetFlatSolids

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartGetFlatSolids()

evxErrors cvxPartGetFlatSolids | ( | int * | cnts,
 |  | int ** | solids
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Gets a list of sheet metal flat solid id in the active part.

The memory referenced by "solids" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)solids)).

Parameters
[out] | cnts | count of "solids"
[out] | solids | list of sheet metal flat solid id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFlattens

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqFlattens()

evxErrors cvxPartInqFlattens | ( | int * | count,
 |  | int ** | idFlattens,
 |  | vxLongName ** | flattenNames
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Gets a list of sheet metal flatten id and flatten name in the active part.
At least one of idFlattens and flattenNames must exist.

The memory referenced by "idFlattens" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)idFlattens)).
The memory referenced by "FlattenNames" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)FlattenNames)).

Parameters
[out] | count | count of idFlattens(flattenNames).
[out] | idFlattens | list of flatten id
[out] | flattenNames | list of flatten name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShtMetalThick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqShtMetalThick()

evxErrors cvxPartInqShtMetalThick | ( | int | idShape,
 |  | double * | thick
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Get thickness of the specified sheet metal.

Parameters
[in] | idShape | index of shape
[out] | thick | thick
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqSmdPairFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqSmdPairFaces()

evxErrors cvxPartInqSmdPairFaces | ( | int | idFace,
 |  | int * | count,
 |  | int ** | faces
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Outputs a list of indices of the face opposite to the input face in a sheet metal solid.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFace | index of face
[out] | count | number of opposite faces
[out] | faces | list of opposite face id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqSmdSrfType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqSmdSrfType()

evxErrors cvxPartInqSmdSrfType | ( | int | idFace,
 |  | evxSmdSurfaceType * | type
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Get surface type of sheet metal.

Parameters
[in] | idFace | face id
[out] | type | sheet metal surface type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqSmdStatFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqSmdStatFace()

evxErrors cvxPartInqSmdStatFace | ( | int | idShape,
 |  | int * | idFace
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Get the stationary face of the shape specified by idFace.

See also
cvxPartInqSmdStatFcs.
This interface can obtain all faces on one side of the sheet metal stationary face and all faces on the poopsite side.
This interface can obtain all faces except sheet metal thickness faces.
Parameters
[in] | idShape | id of sheet metal solid
[out] | idFace | id of stationary face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqSmdStatFcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartInqSmdStatFcs()

int cvxPartInqSmdStatFcs | ( | int | idShape,
 |  | int * | countStat,
 |  | int ** | statFcs,
 |  | int * | countPair,
 |  | int ** | pairStatFcs
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Get the faces on the same side as the stationary face(statFaces).
Get the faces opposite the stationary face(pairStatFaces).

See also
Interface cvxPartInqSmdStatFace can only obtain one face of sheet metal whose attribute is the stationary face.
Note
Sheet metal must have a stationary face to call this interface.
The memory referenced by "statFcs" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)statFcs)).
The memory referenced by "pairStatFcs" is allocated by this function.
The calling procedure is responsible to free it (cvxMemFree((void**)pairStatFcs)).
Parameters
[in] | idShape | shape id
[out] | countStat | count of "statFcs" (NULL to ignore)
[out] | statFcs | see description(NULL to ignore)
[out] | countPair | count of "pairStatFcs" (NULL to ignore)
[out] | pairStatFcs | see description(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
other
  • -1 - not found stationary face
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartSmdAtGet()

evxErrors cvxPartSmdAtGet ( svxSmdAt * at )

#include <zwapi_part_sheetmetal_attribute.h>

Get the sheet metal attribute values.

Parameters
[out] at sheet metal attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartSmdAtSet()

evxErrors cvxPartSmdAtSet ( const svxSmdAt * at )

#include <zwapi_part_sheetmetal_attribute.h>

Set the sheet metal attribute values. If there is no sheet metal, it will create one.

Note
if you just want to set some specified variables of svxSmdAt, you'd better
call cvxPartSmdAtGet to get the global values to initialize "at" first.
Parameters
[in] at sheet metal attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdStatFaceSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Attribute
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ cvxPartSmdStatFaceSet()

evxErrors cvxPartSmdStatFaceSet | ( | int | idFace,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_part_sheetmetal_attribute.h>

Set the stationary face of a sheet metal part.

Parameters
[in] | idFace | id of face
[out] | idFtr | id of feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part Variable API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part Variable API
Part Objects

Detailed Description

THE MODULE FOR THE ZW3D Part Variables API

Part Variable Query

evxErrors | cvxPartInqVars (const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
evxErrors | cvxPartInqEqnAllId (int *cntList, int **idList, int *cntSets, int **idSets)

Part Variable

evxErrors | cvxPartVarAdd (svxVariable *Variable)
evxErrors | cvxPartVarGet (svxVariable *Variable)
evxErrors | cvxPartVarGetById (int idEqn, svxVariable *Variable)
evxErrors | cvxPartVarSet (int Count, svxVariable *Variables, int Working)
evxErrors | cvxPartEqnMoveToEqnSet (int idEqnSet, int cnt, const int *idListEqn)
evxErrors | cvxPartVarAddToEqnSet (int idEqnSet, int cnt, const svxVariable *vars)
evxErrors | cvxPartEqnSet (int Count, svxVariable *Variables)
evxErrors | cvxPartEqnSetWithName (const vxLongName setName, int count, svxVariable *vars)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEqnMoveToEqnSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartEqnMoveToEqnSet()

evxErrors cvxPartEqnMoveToEqnSet | ( | int | idEqnSet,
 |  | int | cnt,
 |  | const int * | idListEqn
 | ) |  |

#include <zwapi_part_var.h>

Moves some existing expressions to the specified equation set.

Unlike the cvxPartVarAddToEqnSet() interface, this interface changes
the position of original expression.

The cvxPartEqnSet() interface can create a equation set and this interface can not.

Parameters
[in] | idEqnSet | equation set id
[in] | cnt | number of variables
[in] | idListEqn | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEqnSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartEqnSet()

evxErrors cvxPartEqnSet | ( | int | Count,
 |  | svxVariable * | Variables
 | ) |  |

#include <zwapi_part_var.h>

Create an equation set in active part, and add variables into this equation set.

Parameters
[in] | Count | number of variables
[in] | Variables | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEqnSetWithName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartEqnSetWithName()

evxErrors cvxPartEqnSetWithName | ( | const vxLongName | setName,
 |  | int | count,
 |  | svxVariable * | vars
 | ) |  |

#include <zwapi_part_var.h>

DESCRIPTION: Create an equation set in active part, and add variables into this equation set.

This interface can create an empty equation set or specify the name of the equation set.

Parameters
[in] | setName | equation set name(can be NULL)
[in] | count | number of variables
[in] | vars | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INVALID_STRING
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEqnAllId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartInqEqnAllId()

evxErrors cvxPartInqEqnAllId | ( | int * | cntList,
 |  | int ** | idList,
 |  | int * | cntSets,
 |  | int ** | idSets
 | ) |  |

#include <zwapi_part_var.h>

Output all equations and equation sets. If no equation,*cntList=0 and *idList=NULL. If no equation set,*cntSets=0 and *idSets=NULL.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | cntList | number of idList
[out] | idList | list of equation id
[out] | cntSets | number of idSets
[out] | idSets | list of equation set id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqVars

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartInqVars()

evxErrors cvxPartInqVars | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | svxVariable ** | Variables
 | ) |  |

#include <zwapi_part_var.h>

Outputs a list of variables that belong to the specified part.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | Count | number of variables
[out] | Variables | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartVarAdd()

evxErrors cvxPartVarAdd ( svxVariable * Variable )

#include <zwapi_part_var.h>

Adds the specified variable to the active part.

Expression format of string type :"\"str\"";
Expression format of point type :"Point(1,2,3)";
Expression format of vector type :"Vector(1,2,3)";

If the type of variable is set to 0,then the sub_type must be set,else ignore.
If the sub_type of variable is set to 1 or 2,then the unit_type must be set,else ignore.

evxUnitType for length unit and evxAngUnitType for angle unit.

Parameters
[in] Variable definition of a variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarAddToEqnSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartVarAddToEqnSet()

evxErrors cvxPartVarAddToEqnSet | ( | int | idEqnSet,
 |  | int | cnt,
 |  | const svxVariable * | vars
 | ) |  |

#include <zwapi_part_var.h>

Adds some non-existent expressions or copys some existent expressions to the specified equation set.

Unlike the cvxPartEqnMoveToEqnSet() interface, this interface does not change the position of original expression.

Parameters
[in] | idEqnSet | equation set id
[in] | cnt | number of variables
[in] | vars | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_STRING
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartVarGet()

evxErrors cvxPartVarGet ( svxVariable * Variable )

#include <zwapi_part_var.h>

Searches the active part for the variable named "Variable->Name".

The value of the specified variable is output via
"Variable->Value" in database units (mm, deg).

If "Variable->Name" is a string variable, the associated
text is output via "Variable->Expression". Strings longer
than 256 bytes are truncated.

Note
"Variable->Expression" is not used to output the
expression that defines a variable. It is used to output
text associated with a "string" variable.
Parameters
[in,out] Variable variable data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarGetById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartVarGetById()

evxErrors cvxPartVarGetById | ( | int | idEqn,
 |  | svxVariable * | Variable
 | ) |  |

#include <zwapi_part_var.h>

Searches the active part for the equation id.

Note
"Variable->Expression" is not used to output the
expression that defines a variable. It is used to output
text associated with a "string" variable.
Parameters
[in] | idEqn | equation id
[out] | Variable | variable data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartVarSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Variable API
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ cvxPartVarSet()

evxErrors cvxPartVarSet | ( | int | Count,
 |  | svxVariable * | Variables,
 |  | int | Working
 | ) |  |

#include <zwapi_part_var.h>

Updates the part variables (e.g. dimensions, parameters)
specified by "Variables" and regenerates the active part
with the modified values.

You can disable the object regeneration normally performed by
this function by inputing "Working = -1".

See also
the description of "cvxRootVarSet()" for the names
used to identify various part parameters and attributes.

Custom variables : Expression format of string type :"\"str\"";
Expression format of point type :"Point(1,2,3)";
Expression format of vector type :"Vector(1,2,3)";

Parameters
[in] | Count | number of variables
[in] | Variables | list of variables
[in] | Working | 1 to display "Working..." message, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Part View API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Part View API
Part Objects

Detailed Description

MAIN MODULE FOR THE ZW3D Part View API

Part View

evxErrors | cvxPartInqView (int idView, svxView *View)
evxErrors | cvxPartInqViews (int *Count, int **Views)
evxErrors | cvxPartViewAddInit (svxView *data)
evxErrors | cvxPartViewAdd (svxView *View, int *idView)
evxErrors | cvxPartViewRecord (int idView, svxView *View)

Part Display

void | cvxPartShowAll (void)
void | cvxPartShowTarg (void)
evxErrors | cvxPartShowPreview (const vxLongPath fileName, const vxRootName rootName)
void | cvxPartClosePreview ()
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartClosePreview

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartClosePreview()

void cvxPartClosePreview ( )

#include <zwapi_part_view.h>

Close the file preview window.

See also
cvxPartShowPreview()
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartInqView()

evxErrors cvxPartInqView | ( | int | idView,
 |  | svxView * | View
 | ) |  |

#include <zwapi_part_view.h>

Outputs the parameters of the specified view saved in the active part.

Parameters
[in] | idView | database id of view saved in the active part
[out] | View | view information
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqViews

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartInqViews()

evxErrors cvxPartInqViews | ( | int * | Count,
 |  | int ** | Views
 | ) |  |

#include <zwapi_part_view.h>

Outputs all view ids under the view manager for the current part,including
standard views,custom views, and sectional views.

This function allocates memory for the array output via "Views". The calling
procedure is responsible for deallocating the memory.

Parameters
[out] | Count | number of 3D views saved in the active part
[out] | Views | list of id's of 3D views saved in the active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShowAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartShowAll()

void cvxPartShowAll ( void )

#include <zwapi_part_view.h>

Set the scope of display traversal to include all objects, originating
with the root object. This affects operations such as drawing and
picking in all views.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShowPreview

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartShowPreview()

evxErrors cvxPartShowPreview | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName
 | ) |  |

#include <zwapi_part_view.h>

This interface opens a small window to preview the contents of a file.

Note
The fileName cannot be equal to the active file name.
The rootName cannot be equal to the active root name.
If the small window is open, the small window is not refreshed.
See also
cvxPartClosePreview()
Parameters
[in] | fileName | file name
[in] | rootName | root name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShowTarg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartShowTarg()

void cvxPartShowTarg ( void )

#include <zwapi_part_view.h>

Limit the scope of display traversal to only the active target object.
This affects operations such as drawing and picking in all views. For
example, when the root object is an assembly and the active target is
one of its components, this function prevents other components in the
assembly from being drawn. If the root object is the active target,
this function and cvxPartShowAll() produce the same results.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartViewAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartViewAdd()

evxErrors cvxPartViewAdd | ( | svxView * | View,
 |  | int * | idView
 | ) |  |

#include <zwapi_part_view.h>

Creates a new view with the specified definition and adds it to
the active part. Outputs the id of the new view via "idView".

Note
Interface cvxPartViewAddInit() can initialize variables of this function.
Parameters
[in] | View | view definition
[out] | idView | id of new view (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartViewAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartViewAddInit()

evxErrors cvxPartViewAddInit ( svxView * data )

#include <zwapi_part_view.h>

Initialize the parameters of the cvxPartViewAdd().

Note
Do not assign a value to variable "data" before calling this function.
The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data view data(z3prt,z3asm)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartViewRecord

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part View API
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ cvxPartViewRecord()

evxErrors cvxPartViewRecord | ( | int | idView,
 |  | svxView * | View
 | ) |  |

#include <zwapi_part_view.h>

Record the view object in view manager.

Parameters
[in] | idView | view id
[in] | View | view information
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Objects

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Assembly Objects

Detailed Description

Modules

Assembly Component API
Component Attribute
Assembly Constraint API
Assembly Data
Assembly Objects Operation
Reuse Library
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Component API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Component API
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Component Query API Including query the components of the assembly, component's part/state and query the objects of the component etc..

Assembly

evxErrors | cvxPartInqAsmFolders (const vxLongPath File, const vxRootName Part, int type, int *count, int **Folders)
evxErrors | cvxPartInqAsmFldChildEnts (const vxLongPath File, const vxRootName Part, int idFolder, int incSubFld, int *count, int **Ents)

Assembly Feature

evxErrors cvxPartInqAsmFtrList (const vxLongPath File, const vxRootName Part, int *Count, int **Features)

Query Components

evxErrors | cvxPartInqComps (const vxLongPath File, const vxRootName Part, int *Count, int **Comps)
evxErrors | cvxPartInqComps2 (const vxLongPath File, const vxRootName Part, int Option, int *Count, int **Comps)
evxErrors | cvxPartInqCompsInfo (const vxPath Path, const vxRootName Name, int *Count, vxPath **Paths, vxRootName **Names)
evxErrors | cvxPartInqCompsInfoByLongPath (const vxLongPath Path, const vxRootName Name, int *Count, vxLongPath **Paths, vxRootName **Names)
evxErrors | cvxCompInqPaths (svxEntPath *CompPath, int Depth, int IgnoreHidden, int *PathCnt, svxEntPath **lstPath)

Component's Part

evxErrors | cvxCompInqPart (int idComp, char *File, int nFileBytes, char *Part, int nPartBytes)
evxErrors | cvxCompInqPartByPath (const svxEntPath *CompPath, vxPath fileName, vxRootName partName)
evxErrors | cvxCompInqPartByPathByLongPath (const svxEntPath *CompPath, char *fileName, int sizeDir, vxRootName partName)
evxErrors | cvxCompGetRefPart (int *Count, vxPath **BinName, vxRootName **RootName)
evxErrors | cvxCompGetRefPartByLongPath (int *Count, vxLongPath **BinName, vxRootName **RootName)

Component's State

evxErrors | cvxPartInqAsmIsFlex (int idComp, int *isFlexible)
evxErrors | cvxPartInqAsmIsFlexByPath (svxEntPath AsmPath, int *isFlexible)
evxErrors | cvxCompSuppressGet (int idComp, int *suppress)
evxErrors | cvxCompSuppressGetByPath (svxEntPath *path, int *suppress)
evxErrors | cvxAssemCompVisAll (int *nSize, int **ppath_mode)
evxErrors | cvxCompVisGet (svxEntPath *CompPath, int *Vis)
void | cvxCompHighlight (svxEntPath *CompPath, svxColor *color)
void | cvxCompUnHighlight (svxEntPath *CompPath)
evxErrors | cvxCompMakeVirtual (svxEntPath *CompPath)
evxErrors | cvxCompIsVirtual (svxEntPath *CompPath, int *isVirtual)
evxErrors | cvxCompInqRenderMode (svxEntPath *CompPath, evxRenderMode *RenderMode)
evxErrors | cvxCompIsUnplaced (int idx_Comp, int *isUnplaced)
evxErrors | cvxCompIsUnplacedByPath (const svxEntPath *path, int *isUnplaced)
evxErrors | cvxCompIsFileLost (const svxEntPath *path, int *isFileLost)
evxErrors | cvxCompExpandStateGet (const svxEntPath *path, int *isExpand)
evxErrors | cvxCompExpandStateSet (const svxEntPath *path, int expand)
evxErrors | cvxCompSelectedStateGet (const svxEntPath *path, int *isSelected)
evxErrors | cvxCompSelectedStateSet (const svxEntPath *path, int selected)
evxErrors | cvxCompBomExcludedGet (svxEntPath EntPath, int *exclude)
evxErrors | cvxCompBomSettingGet (svx3DBomSettingsData *data)
evxErrors | cvxCompBomSettingSet (svx3DBomSettingsData *data)
evxErrors | cvxCompBomDispDataGet (svx3DBomData *data)
void | cvxBomDataFree (svx3DBomData *data)
evxErrors | cvxCompBomPathByPart (const vxLongName part, int *cnt, svxEntPath **paths)
evxErrors | cvxCompRegenSet (int idComp, int Regen)

Component Query

evxErrors | cvxPartInqFlexAsmMat (svxEntPath AsmPath, svxMatrix *AsmMat)
evxErrors | cvxCompInqOpenShapes (svxEntPath *CompPath, int IgnoreHide, int *numShps, svxEntPath **shpPaths)
evxErrors | cvxCompShapeInqOpenEdges (svxEntPath *ShpPath, int *numEdg, svxEntPath **edgPaths)
evxErrors | cvxCompCfgIdGet (const svxEntPath *path, int *idCfg)
evxErrors | cvxCompFolderIns (int cnt, const int *idCom, const vxLongName folderName, int *idFolder)
evxErrors | cvxCompFromAsmFtr (svxEntPath *path, int *isFromAsmFtr)

Assembly Reorder

evxErrors cvxAsmReorder (const vxLongPath fileName, const vxRootName rootName, int idEnt, evxReorderLoc reorderLoc, int idPreEnt)

sub-part

evxErrors cvxSubPartFlag (const vxLongPath File, const vxRootName Part, int isSubPart)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmReorder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxAsmReorder()

evxErrors cvxAsmReorder | ( | const vxLongPath | fileName,
 |  | const vxRootName | rootName,
 |  | int | idEnt,
 |  | evxReorderLoc | reorderLoc,
 |  | int | idPreEnt
 | ) |  |

#include <zwapi_asm_comp.h>

Reorder the specified assembly object. the function only modifies the order of objects in the assembly tree and does not add new objects. if the previous entity (idPreEnt) is a group folder object, the location refers to the specified folder, otherwise, the location refers to the assembly tree.

Parameters
[in] | fileName | file name (fileName[0] = 0 or NULL for active file)
[in] | rootName | part name (rootName[0] = 0 or NULL for active file or single object file)
[in] | idEnt | index of entity to reorder (component, assembly feature, assembly constraint are support)
[in] | reorderLoc | reorder location method
[in] | idPreEnt | index of the previous entity (0 to ignore, component, assembly feature, assembly constraint, group folder are support)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAssemCompVisAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxAssemCompVisAll()

evxErrors cvxAssemCompVisAll | ( | int * | nSize,
 |  | int ** | ppath_mode
 | ) |  |

#include <zwapi_asm_comp.h>

Get all the component object visibility of active part and encode the pick path and mode.

The caller is responsible for releasing the memory.

Parameters
[out] | nSize | number of int in ppath_mode
[out] | ppath_mode | sum,cnt,pick_path,mode,cnt,pick_path ,mode...
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxBomDataFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxBomDataFree()

void cvxBomDataFree ( svx3DBomData * data )

#include <zwapi_asm_comp.h>

Frees memory associated with the specified svx3DBomData structure.

Parameters
[in,out] data svx3DBomData structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompBomDispDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompBomDispDataGet()

evxErrors cvxCompBomDispDataGet ( svx3DBomData * data )

#include <zwapi_asm_comp.h>

Get row infos for display in bom table. The calling procedure MUST deallocate the output list with cvxBomDataFree.

Parameters
[out] data table data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_FORM_INIT_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_TABLE_GETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompBomExcludedGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompBomExcludedGet()

evxErrors cvxCompBomExcludedGet | ( | svxEntPath | EntPath,
 |  | int * | exclude
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs the Exclude state of specified component. 1-excluded 0-included. The 3D BOM table allows user to exclude and include components.

Parameters
[in] | EntPath | component pick path
[out] | exclude | the component Exclude state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompBomPathByPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompBomPathByPart()

evxErrors cvxCompBomPathByPart | ( | const vxLongName | part,
 |  | int * | cnt,
 |  | svxEntPath ** | paths
 | ) |  |

#include <zwapi_asm_comp.h>

Get the pick path of the specified part in the BOM table.

Parameters
[in] | part | part name in the bom table.
[out] | cnt | count of paths
[out] | paths | list of path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_STRING
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_FORM_CREATE_FAIL
  • ZW_API_FORM_INIT_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompBomSettingGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompBomSettingGet()

evxErrors cvxCompBomSettingGet ( svx3DBomSettingsData * data )

#include <zwapi_asm_comp.h>

Get the display content of the 3D BOM table through the interface.

Parameters
[out] data settings data of 3d bom table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_FORM_CREATE_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FORM_INIT_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompBomSettingSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompBomSettingSet()

evxErrors cvxCompBomSettingSet ( svx3DBomSettingsData * data )

#include <zwapi_asm_comp.h>

Set the display content of the 3D BOM table through the interface.

Parameters
[in] data settings data of 3d bom table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_FORM_CREATE_FAIL
  • ZW_API_FUCNTION_CB_EXECUTION_ERROR
  • ZW_API_FUNCTION_CB_GET_ERROR
  • ZW_API_FUCNTION_CB_EXIST_ERROR
  • ZW_API_FORM_INIT_ERROR
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompCfgIdGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompCfgIdGet()

evxErrors cvxCompCfgIdGet | ( | const svxEntPath * | path,
 |  | int * | idCfg
 | ) |  |

#include <zwapi_asm_comp.h>

Get the id of the specified component configuration.

Parameters
[in] | path | pick path of component
[out] | idCfg | config id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompExpandStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompExpandStateGet()

evxErrors cvxCompExpandStateGet | ( | const svxEntPath * | path,
 |  | int * | isExpand
 | ) |  |

#include <zwapi_asm_comp.h>

Check whether the specified node is expanded.

Parameters
[in] | path | component path
[out] | isExpand | 1 is expand state, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompExpandStateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompExpandStateSet()

evxErrors cvxCompExpandStateSet | ( | const svxEntPath * | path,
 |  | int | expand
 | ) |  |

#include <zwapi_asm_comp.h>

Update whether the specified node's expanded status.

Parameters
[in] | path | component path
[in] | expand | 1 is expanded state ; 0 is collapsed state.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFolderIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompFolderIns()

evxErrors cvxCompFolderIns | ( | int | cnt,
 |  | const int * | idCom,
 |  | const vxLongName | folderName,
 |  | int * | idFolder
 | ) |  |

#include <zwapi_asm_comp.h>

Insert components to a new folder using specific name (null to use default name).

Make sure all the components belong to the same parents. Folder' ids are consisted of start and end, idFolder returns folder start id.

Parameters
[in] | cnt | count of component
[in] | idCom | id of component
[in] | folderName | folder name(fileName[0]=0 or NULL for default name)
[out] | idFolder | id of folder(pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_GENERAL_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFromAsmFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompFromAsmFtr()

evxErrors cvxCompFromAsmFtr | ( | svxEntPath * | path,
 |  | int * | isFromAsmFtr
 | ) |  |

#include <zwapi_asm_comp.h>

Determine whether component are generated through assembly feature.

The cvxPartInqEntFtr interface can obtain the feature id through the component id.

The cvxPartInqFtrTemplate interface can obtain the template command of the feature and determine the feature type through the template command.

Asm Feature Type | Template Command
assembly pattern | AsmPtnAll
assembly mirror  | AsmMirrorAll
pulley           | AsMcmPulley
spur gear        | CdSpurGear
bevel gear       | CdBevelGear
Parameters
[in] | path | pick path of component
[out] | isFromAsmFtr | 1 if this component is from assembly feature. else 0.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompGetRefPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompGetRefPart()

evxErrors cvxCompGetRefPart | ( | int * | Count,
 |  | vxPath ** | BinName,
 |  | vxRootName ** | RootName
 | ) |  |

#include <zwapi_asm_comp.h>

Get the file names and part names in the active assembly or part. This function determines the number of unique parts referenced by the active assembly or part and assigns that value to *Count, then allocates arrays of that size for BinName and RootName, and fills them with the referenced parts' file names and root names, respectively.

The caller is responsible for freeing the output arrays with the cvxMemFree() function.

If an error occurs, *Count will be 0, but either or both BinName and RootName might be a non-NULL pointer to an array that the caller must free.

Parameters
[out] | Count | the number of names in each output array
[out] | BinName | array of "*Count" files referenced by active part
[out] | RootName | array of "*Count" part names referenced by active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompGetRefPartByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompGetRefPartByLongPath()

evxErrors cvxCompGetRefPartByLongPath | ( | int * | Count,
 |  | vxLongPath ** | BinName,
 |  | vxRootName ** | RootName
 | ) |  |

#include <zwapi_asm_comp.h>

Get the file names and part names in the active assembly or part. This function determines the number of unique parts referenced by the active assembly or part and assigns that value to *Count, then allocates arrays of that size for BinName and RootName, and fills them with the referenced parts' file names and root names, respectively.

The caller is responsible for freeing the output arrays with the cvxMemFree() function.

If an error occurs, *Count will be 0, but either or both BinName and RootName might be a non-NULL pointer to an array that the caller must free.

Parameters
[out] | Count | the number of names in each output array
[out] | BinName | array of "*Count" files referenced by active part
[out] | RootName | array of "*Count" part names referenced by active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompHighlight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompHighlight()

void cvxCompHighlight | ( | svxEntPath * | CompPath,
 |  | svxColor * | color
 | ) |  |

#include <zwapi_asm_comp.h>

Highlights the specified component.

Parameters
[in] | CompPath | pick-path of component
[in] | color | color of object to display (NULL to use default)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqOpenShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqOpenShapes()

evxErrors cvxCompInqOpenShapes | ( | svxEntPath * | CompPath,
 |  | int | IgnoreHide,
 |  | int * | numShps,
 |  | svxEntPath ** | shpPaths
 | ) |  |

#include <zwapi_asm_comp.h>

Get the open shapes in input components or shape.

Parameters
[in] | CompPath | pick path of the component/shape in the component, NULL to check all components
[in] | IgnoreHide | whether to ignore hidden components and hidden shapes(1 is ignore hidden, 0 is not ignore hidden)
[out] | numShps | number of open shapes
[out] | shpPaths | pick-paths of open shapes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqPart()

evxErrors cvxCompInqPart | ( | int | idComp,
 |  | char * | File,
 |  | int | nFileBytes,
 |  | char * | Part,
 |  | int | nPartBytes
 | ) |  |

#include <zwapi_asm_comp.h>

Gets the names of the file and part referenced by the specified component.

See also
cvxCompInqPartByPath
Parameters
[in] | idComp | id of component in active file
[out] | File | name of the file instanced by the component
[in] | nFileBytes | string size of file name
[out] | Part | name of the part instanced by the component
[in] | nPartBytes | string size of part name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqPartByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqPartByPath()

evxErrors cvxCompInqPartByPath | ( | const svxEntPath * | CompPath,
 |  | vxPath | fileName,
 |  | vxRootName | partName
 | ) |  |

#include <zwapi_asm_comp.h>

Gets the names of the file and part referenced by the pick path of specified component.

See also
cvxCompInqPart
Parameters
[in] | CompPath | pick path of component in active file
[out] | fileName | name of the file instanced by the component
[out] | partName | name of the part instanced by the component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_aPI_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqPartByPathByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqPartByPathByLongPath()

evxErrors cvxCompInqPartByPathByLongPath | ( | const svxEntPath * | CompPath,
 |  | char * | fileName,
 |  | int | sizeDir,
 |  | vxRootName | partName
 | ) |  |

#include <zwapi_asm_comp.h>

Gets the names of the file and part referenced by the pick path of specified component.

A fileName that is too long (longer than "sizefile") is truncated.

It is assumed that the input "fileName" is no longer than 512 bytes.

Parameters
[in] | CompPath | pick path of component in active file
[out] | fileName | name of the file instanced by the component
[in] | sizeDir | max size of fileName
[out] | partName | name of the part instanced by the component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_aPI_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqPaths()

evxErrors cvxCompInqPaths | ( | svxEntPath * | CompPath,
 |  | int | Depth,
 |  | int | IgnoreHidden,
 |  | int * | PathCnt,
 |  | svxEntPath ** | lstPath
 | ) |  |

#include <zwapi_asm_comp.h>

Traverse all pick-paths of components start with CompPath and store them into lstPath.

The memory referenced by "lstPath" is allocated by this function. The calling procedure is responsible to free it (cvxMemFree((void**)lstPath)).

Parameters
[in] | CompPath | pick-path to start traversal, NULL to traverse current active part
[in] | Depth | depth of traversing, -1 to traverse all pick paths
[in] | IgnoreHidden | whether to ignore the hidden and suppressed components
[out] | PathCnt | number of component paths
[out] | lstPath | list of component paths
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqRenderMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompInqRenderMode()

evxErrors cvxCompInqRenderMode | ( | svxEntPath * | CompPath,
 |  | evxRenderMode * | RenderMode
 | ) |  |

#include <zwapi_asm_comp.h>

Get component render mode.

Parameters
[in] | CompPath | pick path of component
[out] | RenderMode | render mode
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsFileLost

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompIsFileLost()

evxErrors cvxCompIsFileLost | ( | const svxEntPath * | path,
 |  | int * | isFileLost
 | ) |  |

#include <zwapi_asm_comp.h>

Determine whether the component file is missing.

Parameters
[in] | path | path of component
[out] | isFileLost | 1= file is lost; 0= file is not lost.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsUnplaced

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompIsUnplaced()

evxErrors cvxCompIsUnplaced | ( | int | idx_Comp,
 |  | int * | isUnplaced
 | ) |  |

#include <zwapi_asm_comp.h>

Get component unplaced state.

See also
cvxCompIsUnplacedByPath
Parameters
[in] | idx_Comp | index of component
[out] | isUnplaced | component unplaced state(1 is unplaced, else 0.)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERRORS
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsUnplacedByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompIsUnplacedByPath()

evxErrors cvxCompIsUnplacedByPath | ( | const svxEntPath * | path,
 |  | int * | isUnplaced
 | ) |  |

#include <zwapi_asm_comp.h>

Get component unplaced state by pick-path.

See also
cvxCompIsUnplaced
Parameters
[in] | path | pick path of component
[out] | isUnplaced | 1 is unplaced, 0 is not unplaced
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_tYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsVirtual

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompIsVirtual()

evxErrors cvxCompIsVirtual | ( | svxEntPath * | CompPath,
 |  | int * | isVirtual
 | ) |  |

#include <zwapi_asm_comp.h>

Judge whether a component is a virtual component.

Parameters
[in] | CompPath | pick path of component
[out] | isVirtual | true if component is virtual
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMakeVirtual

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompMakeVirtual()

evxErrors cvxCompMakeVirtual ( svxEntPath * CompPath )

#include <zwapi_asm_comp.h>

Make a component into a virtual component.

Parameters
[in] CompPath pick path of component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompRegenSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompRegenSet()

evxErrors cvxCompRegenSet | ( | int | idComp,
 |  | int | Regen
 | ) |  |

#include <zwapi_asm_comp.h>

Flags the input component to regen (Regen=1) or not regen (Regen=0) the part it instances when the it's parent part is regenerated.

The specified component (idComp) should belong to the active part.

Parameters
[in] | idComp | component entity id
[in] | Regen | 1 to enable component regen; 0 to disable it
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSelectedStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompSelectedStateGet()

evxErrors cvxCompSelectedStateGet | ( | const svxEntPath * | path,
 |  | int * | isSelected
 | ) |  |

#include <zwapi_asm_comp.h>

Check whether the specified node is selected.

Parameters
[in] | path | component path
[out] | isSelected | 1 is selected, 0 is non-selected
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSelectedStateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompSelectedStateSet()

evxErrors cvxCompSelectedStateSet | ( | const svxEntPath * | path,
 |  | int | selected
 | ) |  |

#include <zwapi_asm_comp.h>

Update whether the specified node's selected status.

Warning
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | path | component path
[in] | selected | 1 is selected state ; 0 is non-selected state.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompShapeInqOpenEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompShapeInqOpenEdges()

evxErrors cvxCompShapeInqOpenEdges | ( | svxEntPath * | ShpPath,
 |  | int * | numEdg,
 |  | svxEntPath ** | edgPaths
 | ) |  |

#include <zwapi_asm_comp.h>

Get the open edges of the input shape.

Parameters
[in] | ShpPath | pick path of the shape in the component
[out] | numEdg | number of open edges
[out] | edgPaths | path of open edges
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSuppressGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompSuppressGet()

evxErrors cvxCompSuppressGet | ( | int | idComp,
 |  | int * | suppress
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs the suppress state of specified component.
1-suppressed 0-unsuppressed.

Parameters
[in] | idComp | component id
[out] | suppress | the component suppress state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSuppressGetByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompSuppressGetByPath()

evxErrors cvxCompSuppressGetByPath | ( | svxEntPath * | path,
 |  | int * | suppress
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs the suppress state of specified component path.
1-suppressed 0-unsuppressed.

Parameters
[in] | path | component path
[out] | suppress | the component suppress state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_OBJ
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompUnHighlight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompUnHighlight()

void cvxCompUnHighlight ( svxEntPath * CompPath )

#include <zwapi_asm_comp.h>

Un-Highlight the specified component.

Parameters
[in] CompPath pick-path of component
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompVisGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxCompVisGet()

evxErrors cvxCompVisGet | ( | svxEntPath * | CompPath,
 |  | int * | Vis
 | ) |  |

#include <zwapi_asm_comp.h>

Get the visibility of specified component.

See also
cvxAssemCompVisAll
Parameters
[in] | CompPath | pick-path of component
[out] | Vis | 1-visible, 0-blank
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_APPI_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAsmFldChildEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqAsmFldChildEnts()

evxErrors cvxPartInqAsmFldChildEnts | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int | idFolder,
 |  | int | incSubFld,
 |  | int * | count,
 |  | int ** | Ents
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs a list of indices of the entities in the specified assembly folder.

The idFolder can be obtained through the cvxPartInqAsmFolders interface.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Part | root object name (Part[0]=0 or NULL for active target object)
[in] | idFolder | index of assembly folder
[in] | incSubFld | 0 exclude sub folders; 1 include sub folders; 2 only sub folders
[out] | count | number of entities in specified assembly folder
[out] | Ents | list of entities in specified assembly folder
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAsmFolders

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqAsmFolders()

evxErrors cvxPartInqAsmFolders | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int | type,
 |  | int * | count,
 |  | int ** | Folders
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs a list of indices of the assembly folders in the specified assembly file.

The assembly file does not exist by default and can only be obtained after the user create it.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Part | root object name (Part[0]=0 or NULL for active target object)
[in] | type | folder type (0: component folder; 1: cosntraint folder; 2: feature folder)
[out] | count | number of assembly folders
[out] | Folders | list of assembly folders
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAsmFtrList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqAsmFtrList()

evxErrors cvxPartInqAsmFtrList | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | int ** | Features
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs a list of database id's of assembly features in the specified part. If there are no features, "*Count" is output as zero and "*Features" as NULL.

This function allocates memory for the array output via "Features". The calling procedure is responsible for deallocating the memory with cvxMemFree().

Parameters
[in] | File | object file name (File[0]=0 or NULL for active file)
[in] | Part | part/root object name (Part[0]=0 or NULL for active target object)
[out] | Count | number of assembly features in the specified part
[out] | Features | list of id's of assembly features in the specified part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAsmIsFlex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqAsmIsFlex()

evxErrors cvxPartInqAsmIsFlex | ( | int | idComp,
 |  | int * | isFlexible
 | ) |  |

#include <zwapi_asm_comp.h>

Determine whether the component is flexible.

See also
cvxPartInqAsmIsFlexByPath
Parameters
[in] | idComp | index of component
[out] | isFlexible | 1 if flexible; 0 if not
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqAsmIsFlexByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqAsmIsFlexByPath()

evxErrors cvxPartInqAsmIsFlexByPath | ( | svxEntPath | AsmPath,
 |  | int * | isFlexible
 | ) |  |

#include <zwapi_asm_comp.h>

Determine whether the component is flexible.

Parameters
[in] | AsmPath | pick-path of component
[out] | isFlexible | 1 if flexible; 0 if not
See also
cvxPartInqAsmIsFlex
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_APPI_ENT_PATH_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqComps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqComps()

evxErrors cvxPartInqComps | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | int ** | Comps
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs a list of indices of the components that belong to the specified part.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part/root name (Part[0]=0 or NULL for active part)
[out] | Count | number of components
[out] | Comps | list of component id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqComps2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqComps2()

evxErrors cvxPartInqComps2 | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int | Option,
 |  | int * | Count,
 |  | int ** | Comps
 | ) |  |

#include <zwapi_asm_comp.h>

According to the Option to output a list of indices of the components that belong to the specified part.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[in] | Option | 1 for filter suppressed components, otherwise for 0
[out] | Count | number of components
[out] | Comps | list of component id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCompsInfo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqCompsInfo()

evxErrors cvxPartInqCompsInfo | ( | const vxPath | Path,
 |  | const vxRootName | Name,
 |  | int * | Count,
 |  | vxPath ** | Paths,
 |  | vxRootName ** | Names
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs 2 lists of path and root object name of the components that belong to the specified part.

The difference between cvxPartInqComps() and cvxPartInqCompsInfo() is cvxPartInqComps() just get the file name and part name, and cvxPartInqCompsInfo() get the path(include file name) and part name.

Note
Just file name output as the path if the components haven't been saved. The calling procedure MUST deallocate the output lists.
cvxMemFree((void**)Paths);
cvxMemFree((void**)Names);
cvxMemFree
void cvxMemFree(void **MemPointer)
Parameters
[in] | Path | full file path (Null to the active file)
[in] | Name | root object name (Null to all root objects)
[out] | Count | number of components
[out] | Paths | list of components' path
[out] | Names | list of components' root object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqCompsInfoByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqCompsInfoByLongPath()

evxErrors cvxPartInqCompsInfoByLongPath | ( | const vxLongPath | Path,
 |  | const vxRootName | Name,
 |  | int * | Count,
 |  | vxLongPath ** | Paths,
 |  | vxRootName ** | Names
 | ) |  |

#include <zwapi_asm_comp.h>

Outputs 2 lists of path and root object name of the components that belong to the specified part.

The difference between cvxPartInqComps() and cvxPartInqCompsInfo() is cvxPartInqComps() just get the file name and part name, and cvxPartInqCompsInfo() get the path(include file name) and part name.

Note
Just file name output as the path if the components haven't been saved. The calling procedure MUST deallocate the output lists.
cvxMemFree((void**)Paths);
cvxMemFree((void**)Names);
cvxMemFree
void cvxMemFree(void **MemPointer)
Parameters
[in] | Path | full file path (Null to the active file)
[in] | Name | root object name (Null to all root objects)
[out] | Count | number of components
[out] | Paths | list of components' path
[out] | Names | list of components' root object name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFlexAsmMat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxPartInqFlexAsmMat()

evxErrors cvxPartInqFlexAsmMat | ( | svxEntPath | AsmPath,
 |  | svxMatrix * | AsmMat
 | ) |  |

#include <zwapi_asm_comp.h>

Output specified transformation matrix by pick-path. This interface can be used to query the matrix of flexible assembly.

Parameters
[in] | AsmPath | pick-path of assembly
[out] | AsmMat | transformation matrix of assembly
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxSubPartFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Component API
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ cvxSubPartFlag()

evxErrors cvxSubPartFlag | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int | isSubPart
 | ) |  |

#include <zwapi_asm_comp.h>

If "isSubPart = 1", the specified part is flagged as a sub-part. It will be skipped when gathering parts for a BoM or assembly-part-list. It will not be displayed in the parent file's root object list.

If "isSubPart = -1", the specified part is flagged as a pseudo sub-part. It is hidden in the root object list, but is still counted as a free-standing part for BoM or assembly-part-list purposes.

If "isSubPart = 0", the part is assumed to be a standalone part (i.e. not a sub-part inextricably linked to its parent part).

Generally speaking, this function should not be used to change the status of a genuine sub-part unless you 100% know what you are doing, but it may be used to suppress display of a regular part in the root object list (isSubPart = -1).

Note
This interface had been discarded because the platform can no longer support this operation. If there is a need to get a sub-part, use cvxSubPartIns() to do it.
Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[in] | isSubPart | 1=sub-part; 0=ordinary part; -1=ordinary part hidden in root object list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Component Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Component Attribute
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Component Attribute API Including query the user attribute and display attributes of the components.

Component Attribute

evxErrors | cvxCompUserAtGet (svxEntPath *Comp, int *Count, svxAttribute **UserAt)
evxErrors | cvxCompUserAtSet (svxEntPath *Comp, int Count, svxAttribute *UserAt)
evxErrors | cvxCompUserAtDel (svxEntPath *Comp, int Count, svxAttribute *UserAt)
evxErrors | cvxCompFaceAtGet (const svxEntPath *CompPath, svxFaceAt *At)
evxErrors | cvxCompFaceAtSet (int Count, svxEntPath *CompPath, svxFaceAt *At)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFaceAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Component Attribute
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ cvxCompFaceAtGet()

evxErrors cvxCompFaceAtGet | ( | const svxEntPath * | CompPath,
 |  | svxFaceAt * | At
 | ) |  |

#include <zwapi_asm_comp_attribute.h>

Outputs display attributes of the specified component. Attributes are grabbed from the first face in the component.

Parameters
[in] | CompPath | pick path of component
[out] | At | face attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFaceAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Component Attribute
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ cvxCompFaceAtSet()

evxErrors cvxCompFaceAtSet | ( | int | Count,
 |  | svxEntPath * | CompPath,
 |  | svxFaceAt * | At
 | ) |  |

#include <zwapi_asm_comp_attribute.h>

Changes display attributes of the specified components. It is assumed the specified components reside in the active part.

Parameters
[in] | Count | number of component
[in] | CompPath | list of pick path of components
[in] | At | face attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompUserAtDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Component Attribute
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ cvxCompUserAtDel()

evxErrors cvxCompUserAtDel | ( | svxEntPath * | Comp,
 |  | int | Count,
 |  | svxAttribute * | UserAt
 | ) |  |

#include <zwapi_asm_comp_attribute.h>

Delete user attribute of the specified component in the current active file. the function does not delete any attributes if the specified label is an empty string or the attribute specified label is not found.

Parameters
[in] | Comp | pick path of component
[in] | Count | number of user attributes (0 to delete all user attributes)
[in] | UserAt | list of user attributes (NULL to delete all user attributes)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompUserAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Component Attribute
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ cvxCompUserAtGet()

evxErrors cvxCompUserAtGet | ( | svxEntPath * | Comp,
 |  | int * | Count,
 |  | svxAttribute ** | UserAt
 | ) |  |

#include <zwapi_asm_comp_attribute.h>

Retrieves user attribute data of the specified component in the current active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | Comp | pick path of component
[out] | Count | number of user attributes
[out] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompUserAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Component Attribute
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ cvxCompUserAtSet()

evxErrors cvxCompUserAtSet | ( | svxEntPath * | Comp,
 |  | int | Count,
 |  | svxAttribute * | UserAt
 | ) |  |

#include <zwapi_asm_comp_attribute.h>

Set user attribute data of the specified component in the current active file. a new user attribute is inserted if the user attribute for the specified label does not exist.

Parameters
[in] | Comp | pick path of component
[in] | Count | number of user attributes
[in] | UserAt | list of user attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Constraint API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Constraint API
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Component Constraints Query API Including query the constraints of the components.

Assembly Constraint

evxErrors | cvxConsInqType (int idCons, evxConsType *consType)
evxErrors | cvxConsInqRefEnts (int idCons, int *count, svxEntPath **entPaths)
evxErrors | cvxConsInqConsData (int idCons, svxConsData *ConsData)
evxErrors | cvxCompInqConsState (int idComp, evxConsState *consState)
evxErrors | cvxCompInqConstraints (svxEntPath *CompPath, int *count, int **cons)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqConsState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Constraint API
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ cvxCompInqConsState()

evxErrors cvxCompInqConsState | ( | int | idComp,
 |  | evxConsState * | consState
 | ) |  |

#include <zwapi_asm_constraint.h>

Get the constraint state of specified component.

Parameters
[in] | idComp | index of component or shape
[out] | consState | constraint state of component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInqConstraints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Constraint API
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ cvxCompInqConstraints()

evxErrors cvxCompInqConstraints | ( | svxEntPath * | CompPath,
 |  | int * | count,
 |  | int ** | cons
 | ) |  |

#include <zwapi_asm_constraint.h>

Outputs a list of indices of the constraints associated with the specified component.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | CompPath | pick-path of component
[out] | count | number of constraints
[out] | cons | list of constraint ids
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsInqConsData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Constraint API
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ cvxConsInqConsData()

evxErrors cvxConsInqConsData | ( | int | idCons,
 |  | svxConsData * | ConsData
 | ) |  |

#include <zwapi_asm_constraint.h>

Get custom data of the specified constraint.

Parameters
[in] | idCons | index of common constraint
[out] | ConsData | data of common constraint
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsInqRefEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Constraint API
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ cvxConsInqRefEnts()

evxErrors cvxConsInqRefEnts | ( | int | idCons,
 |  | int * | count,
 |  | svxEntPath ** | entPaths
 | ) |  |

#include <zwapi_asm_constraint.h>

Outputs a list of pick path of entities associated with the specified constraint.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idCons | index of constraint
[out] | count | number of entities associated with constraint
[out] | entPaths | list of entity paths associated with constraint
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_tYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsInqType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Constraint API
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ cvxConsInqType()

evxErrors cvxConsInqType | ( | int | idCons,
 |  | evxConsType * | consType
 | ) |  |

#include <zwapi_asm_constraint.h>

Get the constraint type of specified constraint.

Parameters
[in] | idCons | index of constraint
[out] | consType | constraint type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DAT_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Data
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the functions for the assembly's objects.

Assembly Component Data

enum | evxReorderLoc { VX_REORDER_FIRST = 0 , VX_REORDER_LAST = 1 , VX_REORDER_AFTER = 2 }
Reorder location. More...
enum evx3DBomLevelDispMode {
VX_3DBOM_TOP_LEVEL_ONLY = 1 , VX_3DBOM_PARTS_ONLY = 2 , VX_3DBOM_INDENTED = 3 , VX_3DBOM_SHAPE_ONLY = 4 ,
VX_3DBOM_ALLCOMPONENTS = 5
}
level display settings. More...
typedef enum evxReorderLoc | evxReorderLoc
Reorder location.
typedef enum evx3DBomLevelDispMode | evx3DBomLevelDispMode
level display settings. More...
typedef struct svx3DBomSettingsData | svx3DBomSettingsData
3D BOM display settings data
typedef struct svx3DBomData | svx3DBomData
3d BOM row data
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evx3DBomLevelDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Data
evx3DBomLevelDispMode
evx3DBomLevelDispMode
evxReorderLoc
evxReorderLoc
svx3DBomData
svx3DBomSettingsData

◆ evx3DBomLevelDispMode

typedef enum evx3DBomLevelDispMode evx3DBomLevelDispMode

#include <zwapi_asm_data.h>

level display settings.

Note
In the part environment, 3D BOM supports only managing shape attributes.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Objects Operation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Objects Operation
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Assembly Menu Commands API

Assembly Operations

evxErrors | cvxAsmDissolve (const svxEntPath *path)
evxErrors | cvxAsmGrpComp (svxAsmGrpCompData *data)
evxErrors | cvxAsmAddToFavorites (svxEntPath *path)
evxErrors | cvxAsmRemoveFromFavorites (svxEntPath *path)
int | cvxAsmFavoritesEnable (svxEntPath *path)
evxErrors | cvxAsmUpdateCompRef (const char *OldRootName, const char *NewRootName)

Component Operations

evxErrors | cvxCompEditPart (int idComp)
evxErrors | cvxCompEditPartByPath (const svxEntPath *compPath)
evxErrors | cvxCompRegen (svxEntPath *Path, int flag)
evxErrors | cvxCompSetPart (int idComp, const vxLongPath File, const vxRootName Part)
evxErrors | cvxCompIsLightweightByPath (const svxEntPath *compPath, int *isLightweight)
evxErrors | cvxCompLightweightSetByPath (const svxEntPath *compPaths, int compCount, int load, int isRecursive)
evxErrors | cvxCompSetRenderMode (svxEntPath *CompPath, evxRenderMode RenderMode)
evxErrors | cvxCompShift (int idComp)
evxErrors | cvxCompSuppress (int idComp, int suppress)
evxErrors | cvxCompSuppressByPath (int Count, svxEntPath *CompPaths, int suppress)
evxErrors | cvxCompVisSet (svxEntPath *CompPath, int Vis)
evxErrors | cvxCompCfgIdSet (const svxEntPath *path, int idCfg)

Constraint Operations

evxErrors | cvxConsRedefine (int idCons)
evxErrors | cvxConsEnable (int count, int *idCons, int enable)
evxErrors | cvxConsDel (int count, int *idCons)

sub-part

evxErrors cvxSubPartIns (const vxRootName Name, int AutoRegen, int MergeDimen)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmAddToFavorites

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmAddToFavorites()

evxErrors cvxAsmAddToFavorites ( svxEntPath * path )

#include <zwapi_asm_opts.h>

Add the pick component to Favorites.

Note
If the return value is ZW_API_INPUT_ERROR, you can use the interface cvxAsmFavoritesEnable() to determine the reason for the interface failure.
Parameters
[in] path component pick path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmDissolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmDissolve()

evxErrors cvxAsmDissolve ( const svxEntPath * path )

#include <zwapi_asm_opts.h>

Dissolve the picked sub-assembly

e.g, we have a asm-tree like this:
A
|- B
   |- D
   |- E
   |- F
|- C

then we dissolve "B", the asm-tree will look like:

A
|- C
|- D
|- E
|- F
Parameters
[in] path path of sub-assembly
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmFavoritesEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmFavoritesEnable()

int cvxAsmFavoritesEnable ( svxEntPath * path )

#include <zwapi_asm_opts.h>

Determine whether the entered pick-path can be added to the favorites.

Parameters
[in] path component pick path
Return values
succeeds
  • ZW_API_NO_ERROR : if the pick path can add to favorites.
other
  • -1:if the pick path can remove from favorites.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • 2: if the pick path does not belong to the primary assembly node of the current file's assembly tree.
  • 3: if adding to favorites is not supported due to global configuration.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmGrpComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmGrpComp()

evxErrors cvxAsmGrpComp ( svxAsmGrpCompData * data )

#include <zwapi_asm_opts.h>

This function can create a sub-assembly with some several components, and also allow to save sub-assembly with new file format or new object.

Note
The consumer can initialize the structure using the cvxMemZero((void*)data,sizeof(svxAsmGrpCompData)).
data.isPartOnly is used only for components in multi-object files.
data.isVirtual is used only for components in single-object files.
data.file is used only when data.isPartOnly is 0, otherwise data.file is ignored.

e.g, we have a asm-tree like this:

A
|- B
|- C
|- D

then we group "C" and "D" as new component "G", the asm-tree will look like:

A
|- B
|- G
   |- C
   |- D

If A is *.Z3 file, apply data.isPartOnly, else apply data.isVirtual.

Parameters
[in] data group as sub-assembly data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmRemoveFromFavorites

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmRemoveFromFavorites()

evxErrors cvxAsmRemoveFromFavorites ( svxEntPath * path )

#include <zwapi_asm_opts.h>

Remove the pick component from Favorites.

Note
If the return value is ZW_API_INPUT_ERROR, you can use the interface cvxAsmFavoritesEnable() to determine the reason for the interface failure.
Parameters
[in] path component pick path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmUpdateCompRef

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxAsmUpdateCompRef()

evxErrors cvxAsmUpdateCompRef | ( | const char * | OldRootName,
 |  | const char * | NewRootName
 | ) |  |

#include <zwapi_asm_opts.h>

Traverse the assembly of the active part, find components that reference current file name and OldRootName, then replace the old reference (OldRootName) with the new one (NewRootName).

Parameters
[in] | OldRootName | the old root name of the target part
[in] | NewRootName | the new root name of the target part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompCfgIdSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompCfgIdSet()

evxErrors cvxCompCfgIdSet | ( | const svxEntPath * | path,
 |  | int | idCfg
 | ) |  |

#include <zwapi_asm_opts.h>

Set the id of the specified component configuration.

Parameters
[in] | path | pick path of component
[in] | idCfg | config id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompEditPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompEditPart()

evxErrors cvxCompEditPart ( int idComp )

#include <zwapi_asm_opts.h>

Activate the part instanced by the specified component for editing. It is assumed the component (idComp) resides in the active assembly. Use cvxPartExit() to exit the part to its parent assembly part.

See also
cvxCompEditPartByPath()
Parameters
[in] idComp id of component in active file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompEditPartByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompEditPartByPath()

evxErrors cvxCompEditPartByPath ( const svxEntPath * compPath )

#include <zwapi_asm_opts.h>

Activate the part instanced by the specified component path for editing. It is assumed the component (compPath) resides in the active assembly. Use cvxPartExit() to exit the part to its parent assembly part.

See also
cvxCompEditPart()
Parameters
[in] compPath path of component in active file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsLightweightByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompIsLightweightByPath()

evxErrors cvxCompIsLightweightByPath | ( | const svxEntPath * | compPath,
 |  | int * | isLightweight
 | ) |  |

#include <zwapi_asm_opts.h>

Check the specified component from compPath is a lightweight component or not.

Parameters
[in] | compPath | pick path of component in active file
[out] | isLightweight | the status of specified component, 1 is lightweight and else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompLightweightSetByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompLightweightSetByPath()

evxErrors cvxCompLightweightSetByPath | ( | const svxEntPath * | compPaths,
 |  | int | compCount,
 |  | int | load,
 |  | int | isRecursive
 | ) |  |

#include <zwapi_asm_opts.h>

Set the components to be lightweight loading or not, this function tries to upgrade the loading status even if failed in some components.

Parameters
[in] | compPaths | pick paths of component in active file
[in] | compCount | count of compPaths
[in] | load | 0-make the components be light-weight loading, 1-load the components
[in] | isRecursive | 1 if load the components recursively, else 0, the option is used when load=1
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompRegen()

evxErrors cvxCompRegen | ( | svxEntPath * | Path,
 |  | int | flag
 | ) |  |

#include <zwapi_asm_opts.h>

Regenerate specified component. This function activates the parent node of the this entity, if flag = 0.

Parameters
[in] | Path | pick path of component entity
[in] | flag | 1 if activate back to the original node, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSetPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompSetPart()

evxErrors cvxCompSetPart | ( | int | idComp,
 |  | const vxLongPath | File,
 |  | const vxRootName | Part
 | ) |  |

#include <zwapi_asm_opts.h>

Changes the part instanced by the specified component in the active part.

Parameters
[in] | idComp | id of component in active file
[in] | File | name of the file containing the part to instance
[in] | Part | name of the part to instance from "File"
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSetRenderMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompSetRenderMode()

evxErrors cvxCompSetRenderMode | ( | svxEntPath * | CompPath,
 |  | evxRenderMode | RenderMode
 | ) |  |

#include <zwapi_asm_opts.h>

Set component render mode.

Parameters
[in] | CompPath | pick path of component
[in] | RenderMode | render mode
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompShift

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompShift()

evxErrors cvxCompShift ( int idComp )

#include <zwapi_asm_opts.h>

Moves sub-components of a selected component up to the active part. Also merges top-level geometry and/or alignments associated with the specified component (idComp) into the active part.

Parameters
[in] idComp component id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSuppress

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompSuppress()

evxErrors cvxCompSuppress | ( | int | idComp,
 |  | int | suppress
 | ) |  |

#include <zwapi_asm_opts.h>

Suppress or unsuppress the specified component. idComp is the component of the top assembly.

See also
cvxCompSuppressByPath() to suppress the some components by the entity path.
Parameters
[in] | idComp | component id
[in] | suppress | 1-suppress, 0-unsuppress
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompSuppressByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompSuppressByPath()

evxErrors cvxCompSuppressByPath | ( | int | Count,
 |  | svxEntPath * | CompPaths,
 |  | int | suppress
 | ) |  |

#include <zwapi_asm_opts.h>

Suppress or unsuppress the specified components. CompPaths is some components from different depth assembly.

See also
cvxCompSuppress() to suppress the sepicified component by id.
Parameters
[in] | Count | count of input components
[in] | CompPaths | pick-path of component
[in] | suppress | 1-suppress, 0-unsuppress
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompVisSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxCompVisSet()

evxErrors cvxCompVisSet | ( | svxEntPath * | CompPath,
 |  | int | Vis
 | ) |  |

#include <zwapi_asm_opts.h>

Set the visibility of specified component.

Parameters
[in] | CompPath | pick-path of component
[in] | Vis | 1-visible, 0-blank
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxConsDel()

evxErrors cvxConsDel | ( | int | count,
 |  | int * | idCons
 | ) |  |

#include <zwapi_asm_opts.h>

Delete the specified constraints.

Parameters
[in] | count | count of constraints
[in] | idCons | list of constraint ids
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxConsEnable()

evxErrors cvxConsEnable | ( | int | count,
 |  | int * | idCons,
 |  | int | enable
 | ) |  |

#include <zwapi_asm_opts.h>

Enable or disable the specified constraints.

Parameters
[in] | count | count of constraints
[in] | idCons | list of constraint ids
[in] | enable | 1-enable, 0-disable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxConsRedefine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxConsRedefine()

evxErrors cvxConsRedefine ( int idCons )

#include <zwapi_asm_opts.h>

Launches interactive redefinition of the specified assembly constraint.

Parameters
[in] idCons index of constraint
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxSubPartIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Objects Operation
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ cvxSubPartIns()

evxErrors cvxSubPartIns | ( | const vxRootName | Name,
 |  | int | AutoRegen,
 |  | int | MergeDimen
 | ) |  |

#include <zwapi_asm_opts.h>

Inserts and activates a sub-part in the active part. If "Name" is a blank string, a default name is assigned to the new sub-part. Use cvxPartExit() to exit the sub-part, re-activating its parent part.

Note
If "Name" is the name of an existing sub-part in the active part, the existing sub-part is activated.
Parameters
[in] | Name | sub-part name
[in] | AutoRegen | 1 to tag sub-part for automatic regeneration, else 0
[in] | MergeDimen | 1 to merge sub-part dimensions, 2 to merge sub-part wireframe entities, 3 to merge both (0 to merge neither dimensions nor wireframe
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Reuse Library

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Reuse Library
Assembly Objects

Detailed Description

THE MODULE FOR THE ZW3D Reuse Library API

Reuse Library Insert

int | cvxLibPartIns (const svxCompData *Comp, const char *InstanceName, const char *ValStr, int fFileType, int fInsShape, int *idComp)
evxErrors | cvxInstPartAsShp (const svxCompData *Comp)
evxErrors | cvxLibPartAdjust (int idComp, const vxLongPath File, const vxRootName Part, const char *ValStr, const char *InstanceName)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxInstPartAsShp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Reuse Library
cvxInstPartAsShp
cvxLibPartAdjust
cvxLibPartIns

◆ cvxInstPartAsShp()

evxErrors cvxInstPartAsShp ( const svxCompData * Comp )

#include <zwapi_asm_reuselibrary.h>

Insert the specified part at the specified location as shape.

Parameters
[in] Comp component data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxLibPartAdjust

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Reuse Library
cvxInstPartAsShp
cvxLibPartAdjust
cvxLibPartIns

◆ cvxLibPartAdjust()

evxErrors cvxLibPartAdjust | ( | int | idComp,
 |  | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | const char * | ValStr,
 |  | const char * | InstanceName
 | ) |  |

#include <zwapi_asm_reuselibrary.h>

Change component part use the method like part library

Parameters
[in] | idComp | the index of component
[in] | File | the file name (include the file path)
[in] | Part | the Root name
[in] | ValStr | string for the seleceted value, Like this A,20;B,30;C,40
[in] | InstanceName | the instance name, may be null
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxLibPartIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Reuse Library
cvxInstPartAsShp
cvxLibPartAdjust
cvxLibPartIns

◆ cvxLibPartIns()

int cvxLibPartIns | ( | const svxCompData * | Comp,
 |  | const char * | InstanceName,
 |  | const char * | ValStr,
 |  | int | fFileType,
 |  | int | fInsShape,
 |  | int * | idComp
 | ) |  |

#include <zwapi_asm_reuselibrary.h>

Insert the standard part from reuse library to the current assembly/part as component/shape.

The "ValStr" given some parameter value to generate the instance. The name for the parameters can be the really name or the description name. The value should be the value in excel or in config table for the key and normal parameter. For custom value, it can be other value not in the excel or in config table.

Parameters
[in] | Comp | component data
[in] | InstanceName | the instance name, my be null
[in] | ValStr | string for the selecet value, Like this A,20;B,30;C,40
[in] | fFileType | fFileType is the flag to create the part instance as new root(0) or new file(1, 2 if read-only), ignored if fInsShape is 1.
[in] | fInsShape | insert as shape
[out] | idComp | id of new component, or new feature(fInsShape is 1)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
other
  • 2 - get new component fails
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Objects

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Drawing Objects

Detailed Description

Modules

Drawing Attribute
Drawing Data
Drawing Dimension API
Sheet/Drawing API
Drawing Geometry API
Drawing Symbol API
Drawing Table API
Drawing View API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Attribute
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing Attribute API

Drawing Attribute

evxErrors | cvxDwgAtGet (int idDrawing, svxDrawingAt *drawingAt)
evxErrors | cvxDwgAtSet (int idDrawing, svxDrawingAt *drawingAt)
evxErrors | cvxDwgAtItemGet (evxAtItemId itemId, svxAttribute *At)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Attribute
cvxDwgAtGet
cvxDwgAtItemGet
cvxDwgAtSet

◆ cvxDwgAtGet()

evxErrors cvxDwgAtGet | ( | int | idDrawing,
 |  | svxDrawingAt * | drawingAt
 | ) |  |

#include <zwapi_dwg_attribute.h>

Retrieves attribute data from the specified drawing in the active file.

Parameters
[in] | idDrawing | drawing id
[out] | drawingAt | attribute of drawing
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAtItemGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Attribute
cvxDwgAtGet
cvxDwgAtItemGet
cvxDwgAtSet

◆ cvxDwgAtItemGet()

evxErrors cvxDwgAtItemGet | ( | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_dwg_attribute.h>

Outputs the sheet attribute of specified item. The itemId includes all of evxAtItemId. If the sheet has associated parts, this function also can inquire the parts item attribute.

When itemId is VX_AT_USER, the name of the user-defined attribute must be assigned to At->label before calling this function.

Parameters
[in] | itemId | item id
[out] | At | item attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Attribute
cvxDwgAtGet
cvxDwgAtItemGet
cvxDwgAtSet

◆ cvxDwgAtSet()

evxErrors cvxDwgAtSet | ( | int | idDrawing,
 |  | svxDrawingAt * | drawingAt
 | ) |  |

#include <zwapi_dwg_attribute.h>

Set the drawing data. if useTemplate is 1 or templateName is not NULL, add the template to the drawing or replace the template of the drawing else it will create new drawing border and insert block to drawing

Parameters
[in] | idDrawing | drawing id
[in] | drawingAt | attribute of drawing
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Data
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the functions for Drawing objects.

View Query/Set Data

enum evxViewType {
VX_VIEW_ALL = 0 , VX_VIEW_BASE = 1 , VX_VIEW_PROJ = 2 , VX_VIEW_SECT = 3 ,
VX_VIEW_DET = 4 , VX_VIEW_DEFN = 5
}
view type More...
enum evxViewProjAngle {
VX_VIEW_PROJ_ANG_ALL = 0 , VX_VIEW_3RD_UP = 1 , VX_VIEW_3RD_DN = 2 , VX_VIEW_3RD_RT = 3 ,
VX_VIEW_3RD_LT = 4 , VX_VIEW_1ST_UP = 5 , VX_VIEW_1ST_DN = 6 , VX_VIEW_1ST_RT = 7 ,
VX_VIEW_1ST_LT = 8 , VX_VIEW_3RD_PRJ_ANG = 9 , VX_VIEW_1ST_PRJ_ANG = 10
}
drawing view projection angle More...
enum | evxBrkLineCutSty { VX_ZEROZIGZAG_BRKLINE = 0 , VX_ONEZIGZAG_BRKLINE , VX_TWOZIGZAG_BRKLINE , VX_CURVE_BRKLINE }
break Line style More...
typedef enum evxViewType | evxViewType
view type
typedef enum evxViewProjAngle | evxViewProjAngle
drawing view projection angle
typedef enum evxBrkLineCutSty | evxBrkLineCutSty
break Line style
typedef struct svxDwgBrkLineAt | svxDwgBrkLineAt
attribute of break line

Symbol Query Data

enum evxSymbolType {
VX_SYM_ALL = -1 , VX_SYM_USER = 0 , VX_SYM_SURF = 1 , VX_SYM_WELD = 2 ,
VX_SYM_IMAGE = 3 , VX_SYM_ORIGIN = 4 , VX_SYM_BEAD = 5 , VX_SYM_ENDTRT = 6 ,
VX_SYM_OPEN_LINK = 7 , VX_SYM_HOLE_MARK = 8
}
symbol object type More...
typedef enum evxSymbolType | evxSymbolType
symbol object type
typedef struct svxSymAttr | svxSymAttr
symbol attributes structure

Table Query/Set

enum evxTableType {
VX_TABLE_ALL = 0 , VX_TABLE_USER = 1 , VX_TABLE_BOM = 2 , VX_TABLE_HOLE = 3 ,
VX_TABLE_TRODE = 4 , VX_TABLE_WDSEG = 5 , VX_TABLE_WELD = 6 , VX_TABLE_PNT = 7 ,
VX_TABLE_DIM = 8 , VX_TABLE_REV = 9
}
table type More...
typedef enum evxTableType | evxTableType
table type
typedef struct svxDwgBundleDimData | svxDwgBundleDimData
data of dimension bundle

Style Manager Data

enum evxDwgStyleManagerMethod {
VX_STYLEMANAGER_TEXT , VX_STYLEMANAGER_ANNO_LEADER , VX_STYLEMANAGER_ANNO_BALLOON , VX_STYLEMANAGER_ANNO_DATUM_FEATURE ,
VX_STYLEMANAGER_ANNO_DATUM_TARGET , VX_STYLEMANAGER_ANNO_FEATURE_CONTROL , VX_STYLEMANAGER_DIM_LINEAR , VX_STYLEMANAGER_DIM_ANGULAR ,
VX_STYLEMANAGER_DIM_RADIAL , VX_STYLEMANAGER_DIM_ARC , VX_STYLEMANAGER_DIM_CHAMFER , VX_STYLEMANAGER_DIM_HOLECALLOUT ,
VX_STYLEMANAGER_DIM_ORDINATE , VX_STYLEMANAGER_SYM_WELD , VX_STYLEMANAGER_SYM_SRF_FINISH , VX_STYLEMANAGER_TABLE_USER ,
VX_STYLEMANAGER_TABLE_BOM , VX_STYLEMANAGER_TABLE_HOLE , VX_STYLEMANAGER_TABLE_EDM , VX_STYLEMANAGER_TABLE_STRUCTURAL ,
VX_STYLEMANAGER_TABLE_WELD , VX_STYLEMANAGER_TABLE_REVISION , VX_STYLEMANAGER_VIEW_BASE , VX_STYLEMANAGER_VIEW_PROJECTION ,
VX_STYLEMANAGER_VIEW_AUXILIARY , VX_STYLEMANAGER_VIEW_SECTION , VX_STYLEMANAGER_VIEW_DETAIL , VX_STYLEMANAGER_VIEW_ALTERNATE
}
style manager type More...
enum | evxTextFontType { VX_FONTTYPE_NORMAL , VX_FONTTYPE_PROPORTIONAL , VX_FONTTYPE_FIXED }
font type More...
enum | evxTextStroke { VX_STROKE_COARSE , VX_STROKE_MEDIUM , VX_STROKE_FINE }
text precision More...
enum | evxTextAlignWordWrap { VX_TEXTALIGN_NONE , VX_TEXTALIGN_WORDWRAP , VX_TEXTALIGN_AUTOSIZETEXT }
fit method More...
enum | evxHorizontalMethod { VX_HORIZONTAL_NORMAL , VX_HORIZONTAL_LEFT , VX_HORIZONTAL_CENTER , VX_HORIZONTAL_RIGHT }
horizontal method More...
enum evxVerticalMethod {
VX_VERTICAL_NORMAL , VX_VERTICAL_TOP , VX_VERTICAL_CAP , VX_VERTICAL_HALF ,
VX_VERTICAL_BASE , VX_VERTICAL_BOTTOM
}
vertical method More...
enum | evxTextAlignment { VX_ALIGNMENT_LEFT = 1 , VX_ALIGNMENT_CENTER , VX_ALIGNMENT_RIGHT }
justification More...
typedef enum evxDwgStyleManagerMethod | evxDwgStyleManagerMethod
style manager type
typedef enum evxTextFontType | evxTextFontType
font type
typedef enum evxTextStroke | evxTextStroke
text precision
typedef enum evxTextAlignWordWrap | evxTextAlignWordWrap
fit method
typedef enum evxHorizontalMethod | evxHorizontalMethod
horizontal method
typedef enum evxVerticalMethod | evxVerticalMethod
vertical method
typedef struct svxDwgStyleManagerText | svxDwgStyleManagerText
the text attribute of the text in the style manager.
typedef enum evxTextAlignment | evxTextAlignment
justification
typedef struct svxDwgStyleManagerAnnoDimText | svxDwgStyleManagerAnnoDimText
the text attribute of the annotation/dimension in the style manager.
typedef struct svxDwgStyleManagerTableText | svxDwgStyleManagerTableText
the text attribute of the table in the style manager.
typedef struct svxDwgStyleManagerSymText | svxDwgStyleManagerSymText
the text attribute of the weld(or surface finish) in the style manager.
typedef struct svxDwgStyleManagerViewText | svxDwgStyleManagerViewText
the text attribute of the view in the style manager.

Drawing Attribute Data

typedef struct svxDrawingAt svxDrawingAt
Sheet Format Attributes structure.

Drawing Geometry Query/Set Data

typedef struct svxRefEntData svxRefEntData
reference entity data. More...
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ svxRefEntData

typedef struct svxRefEntData svxRefEntData

#include <zwapi_dwg_data.h>

reference entity data.

fileName,partName and entClass parameters of this structure must be filled in, and other parameters are optional according to whether the referenced part or assembly.

if entClass=0,compPath and depth must be entered. if entClass>0,shellName must be entered.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Dimension API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Dimension API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing Dimension API

Drawing Dimension

evxErrors | cvxDwgInqDims (int idDrawing, evxDimType *dimTypeList, int dimTypeCount, int *count, int **dims)
evxErrors | cvxDwgInqDimEnts (int idDim, int *count, int **idEnts)
evxErrors | cvxDwgInqDimGripPnts (int idDim, int *Num, svxPoint **Pnts)
evxErrors | cvxDwgGetDimTextBox (int idDim, double *tbWid, double *tbHgt, double *chSlp, svxPoint2 *txtPt)
evxErrors | cvxDwgInqDimByView (int idView, int *count, int **idDims)
evxErrors | cvxDwgInqDimByDrawing (int idDrawing, int *count, int **idDims)
evxErrors | cvxDwgInqBundleDataByDim (int idDim, int *count, svxDwgBundleDimData **data)

Drawing Dimension Attribute

evxErrors | cvxDwgDimAtGet (int idDim, svxDimAttr *dmAttr)
evxErrors | cvxDwgDimAtSet (int idDim, svxDimAttr *dmAttr)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgDimAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgDimAtGet()

evxErrors cvxDwgDimAtGet | ( | int | idDim,
 |  | svxDimAttr * | dmAttr
 | ) |  |

#include <zwapi_dwg_dim.h>

Gets the attributes data of specified dimension.

Parameters
[in] | idDim | dimension id
[out] | dmAttr | dimension attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgDimAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgDimAtSet()

evxErrors cvxDwgDimAtSet | ( | int | idDim,
 |  | svxDimAttr * | dmAttr
 | ) |  |

#include <zwapi_dwg_dim.h>

Sets the attributes data of specified dimension. To modify some of the attributes of a dimension, it's better to use cvxDwgGetDimAt() to get the origional attribtes first.

Note
This function must be called on the main thread.
Parameters
[in] | idDim | dimension id
[in] | dmAttr | dimension attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgGetDimTextBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgGetDimTextBox()

evxErrors cvxDwgGetDimTextBox | ( | int | idDim,
 |  | double * | tbWid,
 |  | double * | tbHgt,
 |  | double * | chSlp,
 |  | svxPoint2 * | txtPt
 | ) |  |

#include <zwapi_dwg_dim.h>

Get width, height, slope, position for a dimension text box in drawing sheet.

Parameters
[in] | idDim | the index of the dimension object
[out] | tbWid | text box width
[out] | tbHgt | text box height
[out] | chSlp | text box slope
[out] | txtPt | text box position
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqBundleDataByDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqBundleDataByDim()

evxErrors cvxDwgInqBundleDataByDim | ( | int | idDim,
 |  | int * | count,
 |  | svxDwgBundleDimData ** | data
 | ) |  |

#include <zwapi_dwg_dim.h>

Get information about the dimension bundle.

The memory referenced by "data" is allocated by this function.

Parameters
[in] | idDim | dimension id
[out] | count | count of data
[out] | data | dimension bundle data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqDimByDrawing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqDimByDrawing()

evxErrors cvxDwgInqDimByDrawing | ( | int | idDrawing,
 |  | int * | count,
 |  | int ** | idDims
 | ) |  |

#include <zwapi_dwg_dim.h>

Get dimension id by drawing id.

Note
Dimensions and other annotations created prior to version 27.00 (VX_API_VERSION < 2700) might have been attached to either a drawing or to a view within the drawing. Beginning in version 27.00, ZW3D always attaches new dimensions and annotations to the drawing.
The cvxDwgInqDimByDrawing() function gets entities that are directly attached to the drawing, regardless of the version in which the entity was created.
The cvxDwgInqDimByView() function gets only those older entities that are still attached to a view;
The cvxDwgInqDims() function gets all dimension and annotation entities from a drawing regardless of whether they are attached to the drawing or attached to a view within the drawing.
Parameters
[in] | idDrawing | drawing id
[out] | count | count of "idDims"
[out] | idDims | list of dimension id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqDimByView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqDimByView()

evxErrors cvxDwgInqDimByView | ( | int | idView,
 |  | int * | count,
 |  | int ** | idDims
 | ) |  |

#include <zwapi_dwg_dim.h>

Get dimension id by view id.

Note
Dimensions and other annotations created prior to version 27.00 (VX_API_VERSION < 2700) might have been attached to either a drawing or to a view within the drawing. Beginning in version 27.00, ZW3D always attaches new dimensions and annotations to the drawing.
The cvxDwgInqDimByView() function gets only those older entities that are still attached to a view;
The cvxDwgInqDimByDrawing() function gets entities that are directly attached to the drawing, regardless of the version in which the entity was created.
The cvxDwgInqDims() function gets all dimension and annotation entities from a drawing regardless of whether they are attached to the drawing or attached to a view within the drawing.
Parameters
[in] | idView | view id
[out] | count | count of "idDims"
[out] | idDims | list of dimension id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqDimEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqDimEnts()

evxErrors cvxDwgInqDimEnts | ( | int | idDim,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_dwg_dim.h>

Outputs the id list of entities associated with the specified dimension.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDim | index of dimension
[out] | count | number of list
[out] | idEnts | pointer to pointer of entities array
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPR_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqDimGripPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqDimGripPnts()

evxErrors cvxDwgInqDimGripPnts | ( | int | idDim,
 |  | int * | Num,
 |  | svxPoint ** | Pnts
 | ) |  |

#include <zwapi_dwg_dim.h>

Get grip point coordinates of the specified dimension.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idDim | id of dimension
[out] | Num | number of grip points of dimension
[out] | Pnts | list of grip point coordinates of dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqDims

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension API
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ cvxDwgInqDims()

evxErrors cvxDwgInqDims | ( | int | idDrawing,
 |  | evxDimType * | dimTypeList,
 |  | int | dimTypeCount,
 |  | int * | count,
 |  | int ** | dims
 | ) |  |

#include <zwapi_dwg_dim.h>

Outputs a list of the dimension entity IDs in the special drawing.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDrawing | drawing id
[in] | dimTypeList | dimension type list (NULL to get all dimensions)
[in] | dimTypeCount | dimension type count (0 to get all dimensions)
[out] | count | count of the object
[out] | dims | dimension list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sheet/Drawing API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sheet/Drawing API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing API

Sheet Edit

evxErrors | cvxDwgSheetAdd (vxLongName Name, int *idSheet)
evxErrors | cvxDwgSheetDel (int count, int *idSheet)
evxErrors | cvxDwgSheetScaleGet (int idSheet, double *scale)
evxErrors | cvxDwgSheetScaleSet (int idSheet, double scale)

Drawing Query/Set

evxErrors | cvxDwgInqList (int idRoot, int *count, int **idDrawings)
evxErrors | cvxDwgInqName (int idDrawing, char *drawingName, int nBytes)
evxErrors | cvxDwgFind (const vxRootName rootName, const vxLongName drawingName, int *idDrawing)
evxErrors | cvxDwgInqBorderTitle (int idDrawing, int *idBorder, int *idBorderSkt, int *idTitle, int *idTitleSkt)
evxErrors | cvxDwgInqPart (char *rootName, int *iCount, svxCompName **partList)
evxErrors | cvxDwgSetRefPart (const char *File, const char *Root, int idxView, svxCompName *oldPart, svxCompName *newPart)
evxErrors | cvxDwgActivate (vxLongName drawingName)
evxErrors | cvxDwgInqActive (char *drawingName, int nBytes)
evxErrors | cvxDwgRegen (int count, int *idViews, int isRegenUnModifiedView, int isRegenTable, int isPrompt, int isRegenSketch)

Style Manager Data

evxErrors cvxDwgStyleManagerWithTextAtGet (evxDwgStyleManagerMethod type, void *data)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgActivate()

evxErrors cvxDwgActivate ( vxLongName drawingName )

#include <zwapi_dwg_drawing.h>

Active the special drawing in the current open sheet.

Parameters
[in] drawingName drawing name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgFind()

evxErrors cvxDwgFind | ( | const vxRootName | rootName,
 |  | const vxLongName | drawingName,
 |  | int * | idDrawing
 | ) |  |

#include <zwapi_dwg_drawing.h>

Get the id of the special drawing in the current active file. if rootName=NULL, it means using the current sheet.

Parameters
[in] | rootName | root name
[in] | drawingName | drawing name
[out] | idDrawing | drawing id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgInqActive()

evxErrors cvxDwgInqActive | ( | char * | drawingName,
 |  | int | nBytes
 | ) |  |

#include <zwapi_dwg_drawing.h>

Outputs the name of the active drawing.

Parameters
[out] | drawingName | drawing name
[in] | nBytes | string max size of active file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqBorderTitle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgInqBorderTitle()

evxErrors cvxDwgInqBorderTitle | ( | int | idDrawing,
 |  | int * | idBorder,
 |  | int * | idBorderSkt,
 |  | int * | idTitle,
 |  | int * | idTitleSkt
 | ) |  |

#include <zwapi_dwg_drawing.h>

Get index of border and title including block and sketch in specified drawing.

Parameters
[in] | idDrawing | index of drawing
[out] | idBorder | index of Border block(NULL to ignore)
[out] | idBorderSkt | index of Border sketch(NULL to ignore)
[out] | idTitle | index of title block(NULL to ignore)
[out] | idTitleSkt | index of title sketch(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgInqList()

evxErrors cvxDwgInqList | ( | int | idRoot,
 |  | int * | count,
 |  | int ** | idDrawings
 | ) |  |

#include <zwapi_dwg_drawing.h>

Outputs a list of the drawing IDs. The calling procedure MUST deallocate the output list with cvxMemFree(). Use cvxRootId() to get idRoot.

Parameters
[in] | idRoot | root ID
[out] | count | count of the list
[out] | idDrawings | ID list of the drawings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgInqName()

evxErrors cvxDwgInqName | ( | int | idDrawing,
 |  | char * | drawingName,
 |  | int | nBytes
 | ) |  |

#include <zwapi_dwg_drawing.h>

Get the name of the special drawing.

Parameters
[in] | idDrawing | drawing id
[out] | drawingName | drawing name
[in] | nBytes | string max size of active file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgInqPart()

evxErrors cvxDwgInqPart | ( | char * | rootName,
 |  | int * | iCount,
 |  | svxCompName ** | partList
 | ) |  |

#include <zwapi_dwg_drawing.h>

Outputs a list of associated parts .

Parameters
[in] | rootName | root name (rootName[0]=0 or NULL for active sheet)
[out] | iCount | count of associated parts
[out] | partList | part info(part name and file name) list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgRegen()

evxErrors cvxDwgRegen | ( | int | count,
 |  | int * | idViews,
 |  | int | isRegenUnModifiedView,
 |  | int | isRegenTable,
 |  | int | isPrompt,
 |  | int | isRegenSketch
 | ) |  |

#include <zwapi_dwg_drawing.h>

Regenerate drawing.

Parameters
[in] | count | count of idViews (count < 1, regen all views)
[in] | idViews | list of idView
[in] | isRegenUnModifiedView | 1 if regenerate unmodified views,else 0
[in] | isRegenTable | 1 if regenerate tables,else 0
[in] | isPrompt | 1 if auto prompt for view regen ,else 0
[in] | isRegenSketch | 1 if regenerate standalone sketch ,else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSetRefPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgSetRefPart()

evxErrors cvxDwgSetRefPart | ( | const char * | File,
 |  | const char * | Root,
 |  | int | idxView,
 |  | svxCompName * | oldPart,
 |  | svxCompName * | newPart
 | ) |  |

#include <zwapi_dwg_drawing.h>

Set the referenced part for the specified drawing sheet. Root can be NULL if the file extension is .Z3DRW.

If idxView is >0, only update the specified view, -1 to update all drawing views in the drawing sheet.

If oldPart is not specified, suppose to update the referenced part of the specified view (if idxView>0) or the active view of the drawing sheet (mostly the first view).

Parameters
[in] | File | drawing sheet file name (NULL string for the active file)
[in] | Root | drawing sheet root name (NULL string for the active target object)
[in] | idxView | update the specified view, -1 for all in the sheet
[in] | oldPart | old part name to be updated (can be NULL, see the description)
[in] | newPart | new part name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSheetAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgSheetAdd()

evxErrors cvxDwgSheetAdd | ( | vxLongName | Name,
 |  | int * | idSheet
 | ) |  |

#include <zwapi_dwg_drawing.h>

Add a new sheet. Output the sheet id if sheet is not NULL. If sheet name is NULL, the default sheet name is used.

Parameters
[in] | Name | sheet name (NULL to use default sheet name)
[out] | idSheet | id of sheet (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSheetDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgSheetDel()

evxErrors cvxDwgSheetDel | ( | int | count,
 |  | int * | idSheet
 | ) |  |

#include <zwapi_dwg_drawing.h>

Delete the specified sheets.

Parameters
[in] | count | count of sheets
[in] | idSheet | list of sheet ids
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSheetScaleGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgSheetScaleGet()

evxErrors cvxDwgSheetScaleGet | ( | int | idSheet,
 |  | double * | scale
 | ) |  |

#include <zwapi_dwg_drawing.h>

Get the scale of the specified sheet.

Parameters
[in] | idSheet | sheet id, 0(or -1) to use activated sheet
[out] | scale | scale of specified sheet
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSheetScaleSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgSheetScaleSet()

evxErrors cvxDwgSheetScaleSet | ( | int | idSheet,
 |  | double | scale
 | ) |  |

#include <zwapi_dwg_drawing.h>

Set the scale of the specified sheet.

Parameters
[in] | idSheet | sheet id, 0(or -1) to use activated sheet
[in] | scale | scale of specified sheet
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgStyleManagerWithTextAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet/Drawing API
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ cvxDwgStyleManagerWithTextAtGet()

evxErrors cvxDwgStyleManagerWithTextAtGet | ( | evxDwgStyleManagerMethod | type,
 |  | void * | data
 | ) |  |

#include <zwapi_dwg_drawing.h>

Get the properties of the character text in the style manager.

If the type is VX_STYLEMANAGER_TEXT, the data is defined by struct svxDwgStyleManagerText,

else if the type is VX_STYLEMANAGER_ANNO_LEADER~VX_STYLEMANAGER_DIM_ORDINATE, the data is defined by struct svxDwgStyleManagerAnnoDimText,

else if the type is VX_STYLEMANAGER_TABLE_USER~VX_STYLEMANAGER_TABLE_REVISION, the data is svxDwgStyleManagerTableText,

else if the type is VX_STYLEMANAGER_SYM_WELD or VX_STYLEMANAGER_SYM_SRF_FINISH, the data is svxDwgStyleManagerSymText.

else if the type is VX_STYLEMANAGER_VIEW_BASE~VX_STYLEMANAGER_VIEW_ALTERNATE, the data is svxDwgStyleManagerViewText.

Parameters
[in] | type | style maneger method
[out] | data | text attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Geometry API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Geometry API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing Geometry API

Drawing Geometry Query/Set

evxErrors | cvxDwgInqGeom (int idDrawing, int *count, int **idEnts)
evxErrors | cvxDwgInqText (int idDrawing, int *count, int **idEnts)
evxErrors | cvxDwgInqHatchAttr (int idHatch, svxHatchAttr *HatchAttr)
evxErrors | cvxDwgHatchAttrSet (int idHatch, svxHatchAttr HatchAttr)
evxErrors | cvxDwgHatchAssoCrvsGet (int idHatch, int *count, int **AssocCrvs)
evxErrors | cvxDwgInqHatchIdByView (int idView, int *count, int **idHatchs)
evxErrors | cvxDwgInqHatchIdByDrawing (int idDrawing, int *count, int **idHatchs)
evxErrors | cvxDwgRefEntDataGet (int idRefEnt, svxRefEntData *data)
evxErrors | cvxDwgGeomGetView (int idGeom, int *idView)

View Geometry Query/Set

evxErrors | cvxDwgViewGeomInqList (int viewId, int option, int *count, int **indices)
evxErrors | cvxDwgViewGeomGetShapeId (int geomId, char *fileName, int fileNameBytes, char *partName, int partNameBytes, svxEntPath *pickPath, int *geom3DId, int *shapeId)
evxErrors | cvxDwgViewRefCompVisSet (int idView, const vxLongPath fileName, const vxRootName partName, int show)
evxErrors | cvxDwgViewInqRefEnts (int viewId, int *count, int **idRefEnts)
evxErrors | cvxDwgViewRefBlankGet (int idRefEnt, int *blank)
evxErrors | cvxDwgViewRefBlankSet (int idRefEnt, int blank)
evxErrors | cvxDwgViewRefEntAtGet (int idRefEnt, int *clrValid, int *typeValid, int *widthValid, svxLineAt *entAt)
evxErrors | cvxDwgViewRefEntAtSet (int idRefEnt, int clrValid, int typeValid, int widthValid, const svxLineAt *entAt)
evxErrors | cvxDwgViewPnt2DTo3D (int pnt2DId, svxPoint *pnt3D)
evxErrors | cvxDwgViewPnt3DTo2D (int viewId, svxPoint pnt3D, svxPoint2 *pnt2D)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgGeomGetView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgGeomGetView()

evxErrors cvxDwgGeomGetView | ( | int | idGeom,
 |  | int * | idView
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get index of parent view of specified geometry.

Parameters
[in] | idGeom | index of geometry in view
[out] | idView | index of parent view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHatchAssoCrvsGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgHatchAssoCrvsGet()

evxErrors cvxDwgHatchAssoCrvsGet | ( | int | idHatch,
 |  | int * | count,
 |  | int ** | AssocCrvs
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get an array of associative boundary curves of given hatch entity. The memory for boundary curves is allocated in this function, so, the calling function has to deallocate it.

Parameters
[in] | idHatch | id of hatch object
[out] | count | number of associative boundary curves
[out] | AssocCrvs | associative boundary curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHatchAttrSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgHatchAttrSet()

evxErrors cvxDwgHatchAttrSet | ( | int | idHatch,
 |  | svxHatchAttr | HatchAttr
 | ) |  |

#include <zwapi_dwg_geometry.h>

Set hatch attribute.

Parameters
[in] | idHatch | hatch id
[in] | HatchAttr | hatch attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgInqGeom()

evxErrors cvxDwgInqGeom | ( | int | idDrawing,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_dwg_geometry.h>

Outputs a list of indices of geometry entities in the specified drawing.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDrawing | drawing id
[out] | count | count of objects
[out] | idEnts | list of geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqHatchAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgInqHatchAttr()

evxErrors cvxDwgInqHatchAttr | ( | int | idHatch,
 |  | svxHatchAttr * | HatchAttr
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get hatch attribute.

Parameters
[in] | idHatch | hatch id
[out] | HatchAttr | hatch attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqHatchIdByDrawing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgInqHatchIdByDrawing()

evxErrors cvxDwgInqHatchIdByDrawing | ( | int | idDrawing,
 |  | int * | count,
 |  | int ** | idHatchs
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get hatch id by drawing id.

Note
If the hatch belong to a view and not to a drawing, the hatch id cannot be obtained. It can use cvxDwgInqHatchIdByView in this case.
Parameters
[in] | idDrawing | drawing id
[out] | count | count of "idHatchs"
[out] | idHatchs | list of hatch id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqHatchIdByView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgInqHatchIdByView()

evxErrors cvxDwgInqHatchIdByView | ( | int | idView,
 |  | int * | count,
 |  | int ** | idHatchs
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get hatch id by view id.

Note
If the hatch belong to a drawing and not to a view, the hatch id cannot be obtained. It can use cvxDwgInqHatchIdByDrawing in this case.
Parameters
[in] | idView | view id
[out] | count | count of "idHatchs"
[out] | idHatchs | list of hatch id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgInqText()

evxErrors cvxDwgInqText | ( | int | idDrawing,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_dwg_geometry.h>

Outputs the id list of text entities in the specified drawing sheet.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDrawing | drawing id
[in] | count | count of objects
[in] | idEnts | list of text entities id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgRefEntDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgRefEntDataGet()

evxErrors cvxDwgRefEntDataGet | ( | int | idRefEnt,
 |  | svxRefEntData * | data
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get the component or shape data that the reference object points to.

Parameters
[in] | idRefEnt | index of reference entity
[out] | data | data of reference entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewGeomGetShapeId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewGeomGetShapeId()

evxErrors cvxDwgViewGeomGetShapeId | ( | int | geomId,
 |  | char * | fileName,
 |  | int | fileNameBytes,
 |  | char * | partName,
 |  | int | partNameBytes,
 |  | svxEntPath * | pickPath,
 |  | int * | geom3DId,
 |  | int * | shapeId
 | ) |  |

#include <zwapi_dwg_geometry.h>

This function is to get shape id that geometry in view specified by geomId can be traced back to. The file name, part name or pick path is also output if one of them is no NULL.

Parameters
[in] | geomId | index of geometry in view
[out] | fileName | file name of the component of view of line, it can be NULL
[in] | fileNameBytes | maximum bytes that fileName can hold
[out] | partName | part name of the component of view of line, it can be NULL
[in] | partNameBytes | maximum bytes that partName can hold
[out] | pickPath | pick path, it can be NULL
[out] | geom3DId | index of geometry 3D corresponding to geomId, it can be NULL
[out] | shapeId | shape or sketch id that geometry in view specified by geomId can be traced back to, it can be NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OBJ
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
  • ZW_API_FILE_LOCATE_FAIL
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewGeomInqList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewGeomInqList()

evxErrors cvxDwgViewGeomInqList | ( | int | viewId,
 |  | int | option,
 |  | int * | count,
 |  | int ** | indices
 | ) |  |

#include <zwapi_dwg_geometry.h>

This function is to get the geometry indices list depending on the option.

The calling procedure MUST deallocate the output list with cvxMemFree().

Values of option are as follows:
1: shown geometries NOT corresponding to original edges and faces, such as
boundary generated by Broken Section view;
2: shown geometries cooresponding to original edges and faces;
3: hidden geometry;
4: tangent-shown geometry;
5: tangent-hidden geometry;
6: cosmetic thread geometry;
7: section view cutting plane geometry, or for detail view clip boundary
(circle only)
8: centerline geometry;
9: centerline objects;
10: 3D wireframe data;
11: "hidden" wireframe curves;
12: "hidden" top centermarks;
13: "hidden" centerlines;
14: "hidden" threads;
15: 3D point data;
16: xtra def'n stuff (thick line);
17: 3D anno text;
18: xtra def'n stuff (arrows);
19: bend lines of sheet metal;
20: "hidden" bend lines of sheet metal;
21: thread end lines;
22: hidden thread end lines;
23: bend notes of sheet metal;
24: hidden bend notes of sheet metal;
25: lines for weld beads in idx_beads;
26: weld beads;
27: crop line;
28: 3D hatch lines of cosmetic sketch
29: associated entities
30: associated dimensions

Parameters
[in] | viewId | view index
[in] | option | number to indicate which type of geometry to obtain. Detail can refer to description.
[out] | count | number of list
[out] | indices | pointer to pointer of geometry indices array
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqRefEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewInqRefEnts()

evxErrors cvxDwgViewInqRefEnts | ( | int | viewId,
 |  | int * | count,
 |  | int ** | idRefEnts
 | ) |  |

#include <zwapi_dwg_geometry.h>

Outputs a list of the reference entity IDs in the special view.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | viewId | view id in drawing
[out] | count | number of reference entities
[out] | idRefEnts | list of reference entities
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewPnt2DTo3D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewPnt2DTo3D()

evxErrors cvxDwgViewPnt2DTo3D | ( | int | pnt2DId,
 |  | svxPoint * | pnt3D
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get 3D point in part coordinates corresponding to a pick point on an entity in a drawing sheet view.

The 3D coordinates are output in pnt3D. If pzPnt is V_NULL, this function merely determines whether the given pick is on an entity that can be mapped to a 3D point.

Parameters
[in] | pnt2DId | point id in view
[out] | pnt3D | 3D point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewPnt3DTo2D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewPnt3DTo2D()

evxErrors cvxDwgViewPnt3DTo2D | ( | int | viewId,
 |  | svxPoint | pnt3D,
 |  | svxPoint2 * | pnt2D
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get 2D point value in drawing sheet corresponding to a 3D point value in the part. The 2D coordinate is output in pnt2D and it is converted from the matrix of view.

Parameters
[in] | viewId | view id in drawing
[in] | pnt3D | 3D point
[out] | pnt2D | 2D point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRefBlankGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewRefBlankGet()

evxErrors cvxDwgViewRefBlankGet | ( | int | idRefEnt,
 |  | int * | blank
 | ) |  |

#include <zwapi_dwg_geometry.h>

Get the hidden state by referencing the entity id.

Parameters
[in] | idRefEnt | index of reference entity
[out] | blank | status of reference entity(1 is blank,else display)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRefBlankSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewRefBlankSet()

evxErrors cvxDwgViewRefBlankSet | ( | int | idRefEnt,
 |  | int | blank
 | ) |  |

#include <zwapi_dwg_geometry.h>

Set the hidden state by referencing the entity id.

Parameters
[in] | idRefEnt | index of reference entity
[in] | blank | status of reference entity(1 is blank,else display)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRefCompVisSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewRefCompVisSet()

evxErrors cvxDwgViewRefCompVisSet | ( | int | idView,
 |  | const vxLongPath | fileName,
 |  | const vxRootName | partName,
 |  | int | show
 | ) |  |

#include <zwapi_dwg_geometry.h>

Displays or hides the specified reference component in the specified view, Do not support section view and detail view.

Parameters
[in] | idView | view id in drawing
[in] | fileName | file name of component
[in] | partName | part name of component
[in] | show | 1 to unblank component; 0 to blank
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRefEntAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewRefEntAtGet()

evxErrors cvxDwgViewRefEntAtGet | ( | int | idRefEnt,
 |  | int * | clrValid,
 |  | int * | typeValid,
 |  | int * | widthValid,
 |  | svxLineAt * | entAt
 | ) |  |

#include <zwapi_dwg_geometry.h>

Gets the wireframe attributes of specified reference entity.

Parameters
[in] | idRefEnt | index of reference entity
[out] | clrValid | 1 from attribute; 0 inherited from view
[out] | typeValid | 1 from attribute; 0 inherited from view
[out] | widthValid | 1 from attribute; 0 inherited from view
[out] | entAt | wireframe attributes, attribute items that are not inherit from view is valid
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRefEntAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Geometry API
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ cvxDwgViewRefEntAtSet()

evxErrors cvxDwgViewRefEntAtSet | ( | int | idRefEnt,
 |  | int | clrValid,
 |  | int | typeValid,
 |  | int | widthValid,
 |  | const svxLineAt * | entAt
 | ) |  |

#include <zwapi_dwg_geometry.h>

Set the wireframe attributes of specified reference entity.

Parameters
[in] | idRefEnt | index of reference entity
[in] | clrValid | 1 to set base on attribute; 0 to inherit view
[in] | typeValid | 1 to set base on attribute; 0 to inherit view
[in] | widthValid | 1 to set base on attribute; 0 to inherit view
[in] | entAt | wireframe attributes, attribute items that are not inherit from view are set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_aPI_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Symbol API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Symbol API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing Dimension API

Symbol Query

evxErrors | cvxShtInqSymbol (evxSymbolType type, int *Count, int **idEnts)
evxErrors | cvxDwgInqSymObjList (int idSym, int *count, int **listId)
evxErrors | cvxDwgInqSymType (int idSym, evxSymbolType *type)
evxErrors | cvxDwgInqSymEnts (int idSym, int *Count, int **idEnts)

Symbol Attribute

evxErrors | cvxDwgSymAtGet (int idSym, svxSymAttr *symAttr)
evxErrors | cvxDwgSymAtSet (int idSym, svxSymAttr *symAttr)
evxErrors | cvxDwgSymImgAtGet (int idSymImg, svxSymImg *data)
evxErrors | cvxDwgSymImgAtSet (int idSymImg, const svxSymImg *data)

Symbol Data

evxErrors | cvxDwgSymSurfDataGet (int idSymSurf, svxSymSurf *data)
evxErrors | cvxDwgSymSurfDataSet (int idSymSurf, svxSymSurf *data)
evxErrors | cvxDwgSymWeldDataGet (const int idSymWeld, svxSymWeld *data)
evxErrors | cvxDwgSymWeldDataSet (const int idSymWeld, const svxSymWeld *data)
void | cvxSymWeldFree (svxSymWeld *WeldData)
evxErrors | cvxDwgUserSymObjGet (const int idSymUser, int *nObj, int **idObjs)
evxErrors | cvxDwgSymInsPointGet (int idSym, svxPoint2 *pnt)
evxErrors | cvxDwgSymInsPointSet (int idSym, svxPoint2 *pnt)
evxErrors | cvxDwgSymLinkGet (const int idSymLink, vxPath filePath)
evxErrors | cvxDwgSymLinkGetByLongPath (const int idSymLink, char *filePath, int sizePath)
evxErrors | cvxDwgSymLinkExport (const int idSymLink, vxPath filePath)
evxErrors | cvxDwgSymLinkExportByLongPath (const int idSymLink, char *filePath, int sizePath)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqSymEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgInqSymEnts()

evxErrors cvxDwgInqSymEnts | ( | int | idSym,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_dwg_symbol.h>

Outputs the id list of entities associated with the specified symbol.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idSym | index of symbol
[out] | Count | number of list
[out] | idEnts | pointer to pointer of entities array
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqSymObjList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgInqSymObjList()

evxErrors cvxDwgInqSymObjList | ( | int | idSym,
 |  | int * | count,
 |  | int ** | listId
 | ) |  |

#include <zwapi_dwg_symbol.h>

Gets a list of symbol objects.

Parameters
[in] | idSym | id of symbol
[out] | count | count of listId
[out] | listId | list of symbol object id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqSymType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgInqSymType()

evxErrors cvxDwgInqSymType | ( | int | idSym,
 |  | evxSymbolType * | type
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the type(evxSymbolType) of specified symbol. It can't get the corresponding type if "*type = VX_SYM_ALL".

Parameters
[in] | idSym | the index of symbol
[out] | type | the type of specified symbol
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymAtGet()

evxErrors cvxDwgSymAtGet | ( | int | idSym,
 |  | svxSymAttr * | symAttr
 | ) |  |

#include <zwapi_dwg_symbol.h>

Gets the attributes data of specified symbol. the function supports the following 4 symbol types: VX_SYM_SURF, VX_SYM_WELD, VX_SYM_BEAD, VX_SYM_ENDTRT.

Parameters
[in] | idSym | index of symbol
[out] | symAttr | symbol attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymAtSet()

evxErrors cvxDwgSymAtSet | ( | int | idSym,
 |  | svxSymAttr * | symAttr
 | ) |  |

#include <zwapi_dwg_symbol.h>

Sets the attributes data of specified symbol. the function supports the following 4 symbol types: VX_SYM_SURF, VX_SYM_WELD, VX_SYM_BEAD, VX_SYM_ENDTRT.

Parameters
[in] | idSym | index of symbol
[in] | symAttr | symbol attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymImgAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymImgAtGet()

evxErrors cvxDwgSymImgAtGet | ( | int | idSymImg,
 |  | svxSymImg * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Gets the symbol image data of specified image.

Parameters
[in] | idSymImg | image id
[out] | data | image data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymImgAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymImgAtSet()

evxErrors cvxDwgSymImgAtSet | ( | int | idSymImg,
 |  | const svxSymImg * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Sets the symbol image data of specified image.

Parameters
[in] | idSymImg | image id
[in] | data | image data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymInsPointGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymInsPointGet()

evxErrors cvxDwgSymInsPointGet | ( | int | idSym,
 |  | svxPoint2 * | pnt
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the insertion position of the symbol.

Parameters
[in] | idSym | id of symbol
[out] | pnt | symbol insertion point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_eRROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymInsPointSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymInsPointSet()

evxErrors cvxDwgSymInsPointSet | ( | int | idSym,
 |  | svxPoint2 * | pnt
 | ) |  |

#include <zwapi_dwg_symbol.h>

Set the insertion position of the symbol.

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | idSym | id of symbol
[in] | pnt | symbol insertion point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymLinkExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymLinkExport()

evxErrors cvxDwgSymLinkExport | ( | const int | idSymLink,
 |  | vxPath | filePath
 | ) |  |

#include <zwapi_dwg_symbol.h>

Export embedded file from symbol openLink object to specified path. if only the export path is specified, the file uses the original file name.

Parameters
[in] | idSymLink | the index of symbol openLink object
[in,out] | filePath | path of export file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymLinkExportByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymLinkExportByLongPath()

evxErrors cvxDwgSymLinkExportByLongPath | ( | const int | idSymLink,
 |  | char * | filePath,
 |  | int | sizePath
 | ) |  |

#include <zwapi_dwg_symbol.h>

Export embedded file from symbol openLink object to specified path. if only the export path is specified, the file uses the original file name.

A filePath that is too long (longer than "sizePath") is truncated.

It is assumed that the input "Path" is no longer than 512 bytes.

Parameters
[in] | idSymLink | the index of symbol openLink object
[in,out] | filePath | path of export file
[in] | sizePath | max size of filePath
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymLinkGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymLinkGet()

evxErrors cvxDwgSymLinkGet | ( | const int | idSymLink,
 |  | vxPath | filePath
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the linked file path with special symbol.

Parameters
[in] | idSymLink | index of OLE object symbol
[out] | filePath | the linked file path with symbol
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymLinkGetByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymLinkGetByLongPath()

evxErrors cvxDwgSymLinkGetByLongPath | ( | const int | idSymLink,
 |  | char * | filePath,
 |  | int | sizePath
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the linked file path with special symbol.

A filePath that is too long (longer than "sizePath") is truncated.

It is assumed that the input "filePath" is no longer than 512 bytes.

Parameters
[in] | idSymLink | index of OLE object symbol
[out] | filePath | the linked file path with symbol
[in] | sizePath | max size of filePath
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymSurfDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymSurfDataGet()

evxErrors cvxDwgSymSurfDataGet | ( | int | idSymSurf,
 |  | svxSymSurf * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the surface roughness data of specified symbol.

Parameters
[in] | idSymSurf | symbol id
[out] | data | surface roughness data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymSurfDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymSurfDataSet()

evxErrors cvxDwgSymSurfDataSet | ( | int | idSymSurf,
 |  | svxSymSurf * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Set the surface roughness data of specified symbol.

Parameters
[in] | idSymSurf | symbol id
[in] | data | surface roughness data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_EROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymWeldDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymWeldDataGet()

evxErrors cvxDwgSymWeldDataGet | ( | const int | idSymWeld,
 |  | svxSymWeld * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get the weld data of special symbol.

This function allocates memory for "jogPoints" and "leaderPoints" in svxSymWeld struct. The memory MUST be deallocated by the calling procedure using cvxSymWeldFree().

Parameters
[in] | idSymWeld | symbol id
[out] | data | weld data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymWeldDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgSymWeldDataSet()

evxErrors cvxDwgSymWeldDataSet | ( | const int | idSymWeld,
 |  | const svxSymWeld * | data
 | ) |  |

#include <zwapi_dwg_symbol.h>

Set the weld data of special symbol.

Parameters
[in] | idSymWeld | symbol id
[in] | data | weld data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgUserSymObjGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxDwgUserSymObjGet()

evxErrors cvxDwgUserSymObjGet | ( | const int | idSymUser,
 |  | int * | nObj,
 |  | int ** | idObjs
 | ) |  |

#include <zwapi_dwg_symbol.h>

Get a list of indices of the objects in the User Symbol.

This function allocates memory for "list". The calling procedure is responsible for deallocating the memory.

Parameters
[in] | idSymUser | id of user symbol
[out] | nObj | number of objects in group
[out] | idObjs | list of object indices
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_aPI_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxShtInqSymbol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxShtInqSymbol()

evxErrors cvxShtInqSymbol | ( | evxSymbolType | type,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_dwg_symbol.h>

Outputs a list of indices of specified type symbol entities in the active sheet.

The calling procedure MUST deallocate the output list.

Parameters
[in] | type | symbol object type (VX_SYM_ALL to get all)
[out] | Count | number of symbol entities
[out] | idEnts | list of symbol entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSymWeldFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Symbol API
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ cvxSymWeldFree()

void cvxSymWeldFree ( svxSymWeld * WeldData )

#include <zwapi_dwg_symbol.h>

Frees memory associated with the specified weld structure.

Parameters
[in] WeldData weld data structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Table API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Table API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing Table API

Table Query/Set

evxErrors | cvxDwgInqTables (int idDrawing, evxTableType type, int *count, int **tables)
evxErrors | cvxDwgInqTableType (int idTable, evxTableType *type)
evxErrors | cvxDwgGetTableSize (int iTblIdx, int *pRowNum, int *pColNum)
evxErrors | cvxDwgTableAdjustSize (int idTable)
evxErrors | cvxDwgTableInsPntSet (int idTable, svxPoint2 *pnt)
evxErrors | cvxDwgTableInsPntGet (int idTable, svxPoint2 *pnt)
evxErrors | cvxDwgTableExport (int idTable, const vxLongPath path)
evxErrors | cvxDwgTableLinkToExcel (int idTable, const vxLongPath path)

Table Row/column Set

evxErrors | cvxDwgTableRowHeightSet (int idTable, int Row, double Height)
evxErrors | cvxDwgTableRowInsert (int idTable, int Row)
evxErrors | cvxDwgTableRowDelete (int idTable, int Row)
evxErrors | cvxDwgTableColWidthSet (int idTable, int Col, double Width)
evxErrors | cvxDwgTableColInsert (int idTable, int Col)
evxErrors | cvxDwgTableColDelete (int idTable, int Col)

Table Cell Attribute

evxErrors | cvxDwgTableCellAtGet (int idTable, int Row, int Col, svxTextAt *TextAt)
evxErrors | cvxDwgTableCellAtSet (int idTable, int Row, int Col, svxTextAt *TextAt)

Table Cell Operation

evxErrors | cvxDwgTableCellSet (int idTable, int Row, int Col, char *Value)
evxErrors | cvxDwgTableCellGet (int idTable, int Row, int Col, char *Value, int nBytes)
void | cvxDwgTableCellsMerge (int idTable, int startRow, int endRow, int startCol, int endCol, int kFirstData)
void | cvxDwgTableCellsUnMerge (int idTable, int minRow, int maxRow, int minCol, int maxCol)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgGetTableSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgGetTableSize()

evxErrors cvxDwgGetTableSize | ( | int | iTblIdx,
 |  | int * | pRowNum,
 |  | int * | pColNum
 | ) |  |

#include <zwapi_dwg_table.h>

Get the row and column count of table.

Parameters
[in] | iTblIdx | index of table
[out] | pRowNum | row number of table
[out] | pColNum | column number of table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqTables

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgInqTables()

evxErrors cvxDwgInqTables | ( | int | idDrawing,
 |  | evxTableType | type,
 |  | int * | count,
 |  | int ** | tables
 | ) |  |

#include <zwapi_dwg_table.h>

Outputs a list of the table entity IDs in the special drawing. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDrawing | drawing id
[in] | type | table type
[out] | count | count of the object
[out] | tables | table list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqTableType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgInqTableType()

evxErrors cvxDwgInqTableType | ( | int | idTable,
 |  | evxTableType * | type
 | ) |  |

#include <zwapi_dwg_table.h>

Gets the type of the specified table.

Parameters
[in] | idTable | id of table
[out] | type | table type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableAdjustSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableAdjustSize()

evxErrors cvxDwgTableAdjustSize ( int idTable )

#include <zwapi_dwg_table.h>

Adjust table size to minimum.

Parameters
[in] idTable id of table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellAtGet()

evxErrors cvxDwgTableCellAtGet | ( | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | svxTextAt * | TextAt
 | ) |  |

#include <zwapi_dwg_table.h>

Get text attribute of the specified cell in the table.

Parameters
[in] | idTable | index of table
[in] | Row | index of row
[in] | Col | index of column
[out] | TextAt | attribute of text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellAtSet()

evxErrors cvxDwgTableCellAtSet | ( | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | svxTextAt * | TextAt
 | ) |  |

#include <zwapi_dwg_table.h>

Set text attribute of the specified cell in the table.

Row>0 && Col>0: set text attribute of the specified cell, TextAT can be NULL
Row>0 && Col<0: set text attribute of specified row, TextAT can be NULL
Row<0 && Col>0: set text attribute of specified column, TextAT can be NULL
Row<0 && Col<0: set text attribute for the entire table, TextAT can not be NULL

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | idTable | index of table
[in] | Row | index of row
[in] | Col | index of column
[in] | TextAt | attribute of text (NULL to use table attribute)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellGet()

evxErrors cvxDwgTableCellGet | ( | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Value,
 |  | int | nBytes
 | ) |  |

#include <zwapi_dwg_table.h>

Get the value of specified cell of table.

Parameters
[in] | idTable | table id
[in] | Row | row of table
[in] | Col | column of table
[out] | Value | value of specified cell
[in] | nBytes | string max size of value
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellSet()

evxErrors cvxDwgTableCellSet | ( | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Value
 | ) |  |

#include <zwapi_dwg_table.h>

Modify the value of specified cell of table.

Parameters
[in] | idTable | table id
[in] | Row | row of table
[in] | Col | column of table
[in] | Value | modify value
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_aPI_INPUT_TYPE_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellsMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellsMerge()

void cvxDwgTableCellsMerge | ( | int | idTable,
 |  | int | startRow,
 |  | int | endRow,
 |  | int | startCol,
 |  | int | endCol,
 |  | int | kFirstData
 | ) |  |

#include <zwapi_dwg_table.h>

merge the selected (endRow-startRow+1)*(endCol-startCol+1) cells to one cell.

if kFirstData = 0 and the selected cells have a lot of data, it will fail to merge them.

Note
1 <= startRow <= endRow <= maxRow, 1 <= startCol <= endCol <= maxCol. maxRow is the maximum row of the table, maxCol is the maximum column of the table.
Parameters
[in] | idTable | table id
[in] | startRow | start row
[in] | endRow | end row
[in] | startCol | start column
[in] | endCol | end column
[in] | kFirstData | flag of keep the first data when merging some cells
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableCellsUnMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableCellsUnMerge()

void cvxDwgTableCellsUnMerge | ( | int | idTable,
 |  | int | minRow,
 |  | int | maxRow,
 |  | int | minCol,
 |  | int | maxCol
 | ) |  |

#include <zwapi_dwg_table.h>

un-merge the selected cells.

Parameters
[in] | idTable | table id
[in] | minRow | min row
[in] | maxRow | max row
[in] | minCol | min column
[in] | maxCol | max column
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableColDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableColDelete()

evxErrors cvxDwgTableColDelete | ( | int | idTable,
 |  | int | Col
 | ) |  |

#include <zwapi_dwg_table.h>

Delete specified column from table.

Parameters
[in] | idTable | index of table
[in] | Col | index of column
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableColInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableColInsert()

evxErrors cvxDwgTableColInsert | ( | int | idTable,
 |  | int | Col
 | ) |  |

#include <zwapi_dwg_table.h>

Insert a column to the right of the specified column in the table.

Parameters
[in] | idTable | index of table
[in] | Col | index of column
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableColWidthSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableColWidthSet()

evxErrors cvxDwgTableColWidthSet | ( | int | idTable,
 |  | int | Col,
 |  | double | Width
 | ) |  |

#include <zwapi_dwg_table.h>

Set the column width of the specified column in the table.

Parameters
[in] | idTable | index of table
[in] | Col | index of column
[in] | Width | width of column, auto adjust column width when width < 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableExport()

evxErrors cvxDwgTableExport | ( | int | idTable,
 |  | const vxLongPath | path
 | ) |  |

#include <zwapi_dwg_table.h>

Export the specified table to excel file. The file type is '.xls' or '.xlsx'.

Parameters
[in] | idTable | table id
[in] | path | export file full path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableInsPntGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableInsPntGet()

evxErrors cvxDwgTableInsPntGet | ( | int | idTable,
 |  | svxPoint2 * | pnt
 | ) |  |

#include <zwapi_dwg_table.h>

Get the insert position of the table.

Parameters
[in] | idTable | id of table
[out] | pnt | insert point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableInsPntSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableInsPntSet()

evxErrors cvxDwgTableInsPntSet | ( | int | idTable,
 |  | svxPoint2 * | pnt
 | ) |  |

#include <zwapi_dwg_table.h>

Modify the insert position of the table.

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | idTable | id of table
[in] | pnt | new insert point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableLinkToExcel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableLinkToExcel()

evxErrors cvxDwgTableLinkToExcel | ( | int | idTable,
 |  | const vxLongPath | path
 | ) |  |

#include <zwapi_dwg_table.h>

Link the specified table to the specified excel.

Parameters
[in] | idTable | table id
[in] | path | the linked excel file full path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableRowDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableRowDelete()

evxErrors cvxDwgTableRowDelete | ( | int | idTable,
 |  | int | Row
 | ) |  |

#include <zwapi_dwg_table.h>

delete specified row from table.

Parameters
[in] | idTable | index of table
[in] | Row | index of row
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableRowHeightSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableRowHeightSet()

evxErrors cvxDwgTableRowHeightSet | ( | int | idTable,
 |  | int | Row,
 |  | double | Height
 | ) |  |

#include <zwapi_dwg_table.h>

Set the row height of the specified row in the table.

Parameters
[in] | idTable | index of table
[in] | Row | index of row
[in] | Height | height of row, auto adjust row height when Height < 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableRowInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Table API
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ cvxDwgTableRowInsert()

evxErrors cvxDwgTableRowInsert | ( | int | idTable,
 |  | int | Row
 | ) |  |

#include <zwapi_dwg_table.h>

Insert a row below the specified row in the table.

Parameters
[in] | idTable | index of table
[in] | Row | index of row
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing View API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing View API
Drawing Objects

Detailed Description

THE MODULE FOR THE ZW3D Drawing View API

View Query/Set

evxErrors | cvxDwgInqViews (int idDrawing, evxViewType type, int *count, int **views)
evxErrors | cvxDwgInqViewMod (int idDrawing, int *modified)
evxErrors | cvxDwgInqViewType (int idView, evxViewType *type)
evxErrors | cvxDwgInqViewTypeEx (int viewId, evxViewTypeEx *viewType)
evxErrors | cvxDwgViewAtGet (int idView, svxViewAt *viewAttr)
evxErrors | cvxDwgViewAtSet (int idView, svxViewAt *viewAttr)
evxErrors | cvxDwgViewLockSet (int idView, int lock)
evxErrors | cvxDwgViewLockGet (int idView, int *isLock)
evxErrors | cvxDwgViewDottedBorderGet (int idView, svxPoint2 *UpperLeft, svxPoint2 *UpperRight, svxPoint2 *BottomLeft, svxPoint2 *BottomRight)
evxErrors | cvxDwgViewInqPart (int idView, svxCompName *part)
evxErrors | cvxDwgViewInqPartConfig (int idView, vxName partCfg)
evxErrors | cvxDwgViewInqPartConfigByLongName (int idView, char *partCfg, int size)
evxErrors | cvxDwgViewInqChildView (int idView, int *count, int **idViews)
evxErrors | cvxDwgViewEntitiesAssociate (int idView, int count, int *idEnts)
evxErrors | cvxDwgViewInqProjection (int idView, evxViewProjAngle *projection)
evxErrors | cvxDwgViewLocationGet (int idView, svxPoint2 *point)
evxErrors | cvxDwgAlignmentGet (int idView, int *align)
evxErrors | cvxDwgViewInqOrgPnt (int idView, svxPoint2 *pnt, int *idEnt)
evxErrors | cvxDwgBrkLineAtSet (int brkLnViewId, const svxDwgBrkLineAt *brkLineAt)
evxErrors | cvxDwgBrkLineAtGet (int brkLnViewId, svxDwgBrkLineAt *brkLineAt)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAlignmentGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgAlignmentGet()

evxErrors cvxDwgAlignmentGet | ( | int | idView,
 |  | int * | align
 | ) |  |

#include <zwapi_dwg_view.h>

Get alignment by idView.

Parameters
[in] | idView | id of view
[out] | align | 1 if application alignment, else 0.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgBrkLineAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgBrkLineAtGet()

evxErrors cvxDwgBrkLineAtGet | ( | int | brkLnViewId,
 |  | svxDwgBrkLineAt * | brkLineAt
 | ) |  |

#include <zwapi_dwg_view.h>

Get attribute of special break line.
If brkLineAt->layerName = "",it means layer by view.

Parameters
[in] | brkLnViewId | id of break line
[out] | brkLineAt | Attribute of Break Line
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgBrkLineAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgBrkLineAtSet()

evxErrors cvxDwgBrkLineAtSet | ( | int | brkLnViewId,
 |  | const svxDwgBrkLineAt * | brkLineAt
 | ) |  |

#include <zwapi_dwg_view.h>

Set Attribute of special break line.
Before you use this function, you'd better calling cvxDwgBrkLineAtGet() to initialize brkLineAt.

Parameters
[in] | brkLnViewId | id of break line
[in] | brkLineAt | Attribute of Break Line
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqViewMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgInqViewMod()

evxErrors cvxDwgInqViewMod | ( | int | idDrawing,
 |  | int * | modified
 | ) |  |

#include <zwapi_dwg_view.h>

Check whether the views in the specified drawing has outdated and need to be updated,
output 1 if one of the views need to be updated.

Parameters
[in] | idDrawing | the index of drawing
[out] | modified | 1 if one of the views in specified drawing need to be updated
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqViews

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgInqViews()

evxErrors cvxDwgInqViews | ( | int | idDrawing,
 |  | evxViewType | type,
 |  | int * | count,
 |  | int ** | views
 | ) |  |

#include <zwapi_dwg_view.h>

Outputs a list of the view entity IDs in the special drawing.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idDrawing | drawing id
[in] | type | view type
[out] | count | count of the object
[out] | views | view list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqViewType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgInqViewType()

evxErrors cvxDwgInqViewType | ( | int | idView,
 |  | evxViewType * | type
 | ) |  |

#include <zwapi_dwg_view.h>

Get the type(evxViewType) of specified view.
It can't get the corresponding type if "*type = VX_VIEW_ALL".

Parameters
[in] | idView | the index of view
[out] | type | the type of specified view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInqViewTypeEx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgInqViewTypeEx()

evxErrors cvxDwgInqViewTypeEx | ( | int | viewId,
 |  | evxViewTypeEx * | viewType
 | ) |  |

#include <zwapi_dwg_view.h>

Get the type(evxViewTypeEx) of specified view.
Types of view are more detailed than cvxDwgInqViewType().

Parameters
[in] | viewId | index of view in sheeting
[out] | viewType | type of view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewAtGet()

evxErrors cvxDwgViewAtGet | ( | int | idView,
 |  | svxViewAt * | viewAttr
 | ) |  |

#include <zwapi_dwg_view.h>

Gets the attribute data of specified view. if index of view less than 0, the
function will get the global variables for view layout attributes used in CdV3Ins.

Parameters
[in] | idView | index of view (<= 0 to get the global variables)
[out] | viewAttr | view attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewAtSet()

evxErrors cvxDwgViewAtSet | ( | int | idView,
 |  | svxViewAt * | viewAttr
 | ) |  |

#include <zwapi_dwg_view.h>

Set the attribute of specified view. if index of view less than 0, the
function will set the global variables for view layout attributes used in CdV3Ins.

Parameters
[in] | idView | index of view (<= 0 to set the global variables)
[in] | viewAttr | view attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewDottedBorderGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewDottedBorderGet()

evxErrors cvxDwgViewDottedBorderGet | ( | int | idView,
 |  | svxPoint2 * | UpperLeft,
 |  | svxPoint2 * | UpperRight,
 |  | svxPoint2 * | BottomLeft,
 |  | svxPoint2 * | BottomRight
 | ) |  |

#include <zwapi_dwg_view.h>

Gets the coordinates of the four vertices of the border.

Parameters
[in] | idView | index of view
[out] | UpperLeft | top left corner
[out] | UpperRight | top right corner
[out] | BottomLeft | left bottom
[out] | BottomRight | right bottom
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewEntitiesAssociate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewEntitiesAssociate()

evxErrors cvxDwgViewEntitiesAssociate | ( | int | idView,
 |  | int | count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_dwg_view.h>

This function is to associate the entities with the view.

Parameters
[in] | idView | index of view (idView = -1 to disassociate)
[in] | count | number of idEnts
[in] | idEnts | list of entity id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqChildView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqChildView()

evxErrors cvxDwgViewInqChildView | ( | int | idView,
 |  | int * | count,
 |  | int ** | idViews
 | ) |  |

#include <zwapi_dwg_view.h>

Output sub-views of the specified view.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idView | index of view
[out] | count | number of idViews
[out] | idViews | list of child view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqOrgPnt()

evxErrors cvxDwgViewInqOrgPnt | ( | int | idView,
 |  | svxPoint2 * | pnt,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_dwg_view.h>

Get the origin point of specified view.
If idEnt is not NULL, output the id of origin point.

Parameters
[in] | idView | id of view
[out] | pnt | origin point of specified view
[out] | idEnt | id of origin point(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqPart()

evxErrors cvxDwgViewInqPart | ( | int | idView,
 |  | svxCompName * | part
 | ) |  |

#include <zwapi_dwg_view.h>

Outputs source part object of the drawing view.

Parameters
[in] | idView | view id, -1 to get the active view for the target sheet
[out] | part | part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqPartConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqPartConfig()

evxErrors cvxDwgViewInqPartConfig | ( | int | idView,
 |  | vxName | partCfg
 | ) |  |

#include <zwapi_dwg_view.h>

Inquire the name of the active item of configuration table by the source part object of the drawing view.

Parameters
[in] | idView | view id, -1 to get the active view for the target sheet
[out] | partCfg | the name of the active item of configuration table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqPartConfigByLongName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqPartConfigByLongName()

evxErrors cvxDwgViewInqPartConfigByLongName | ( | int | idView,
 |  | char * | partCfg,
 |  | int | size
 | ) |  |

#include <zwapi_dwg_view.h>

Inquire the name of the active item of configuration table by the source part object of the drawing view.

Parameters
[in] | idView | view id, -1 to get the active view for the target sheet
[out] | partCfg | the name of the active item of configuration table
[in] | size | max size of partCfg.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewInqProjection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewInqProjection()

evxErrors cvxDwgViewInqProjection | ( | int | idView,
 |  | evxViewProjAngle * | projection
 | ) |  |

#include <zwapi_dwg_view.h>

Get perspective projection by view id.

Parameters
[in] | idView | id view
[out] | projection | projection angle
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_APPI_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewLocationGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewLocationGet()

evxErrors cvxDwgViewLocationGet | ( | int | idView,
 |  | svxPoint2 * | point
 | ) |  |

#include <zwapi_dwg_view.h>

Gets the starting position of the view.

Parameters
[in] | idView | index of view
[out] | point | position of specified view
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewLockGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewLockGet()

evxErrors cvxDwgViewLockGet | ( | int | idView,
 |  | int * | isLock
 | ) |  |

#include <zwapi_dwg_view.h>

Determine whether the view is locked.

Parameters
[in] | idView | id view
[out] | isLock | 1 is lock ,0 is unlock
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewLockSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing View API
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ cvxDwgViewLockSet()

evxErrors cvxDwgViewLockSet | ( | int | idView,
 |  | int | lock
 | ) |  |

#include <zwapi_dwg_view.h>

Lock/Unlock the location of view

Parameters
[in] | idView | id view
[in] | lock | 1 is lock ,0 is unlock
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Objects

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Sketch Objects

Detailed Description

Modules

Sketch Attribute
Sketch Data
Sketch Dimension API
Sketch Object API
Sketch Objects Operation
Sketch Variable API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Attribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Attribute
Sketch Objects

THE MODULE FOR THE ZW3D Sketch Attribute API

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Data
Sketch Objects

THE MODULE FOR THE ZW3D Generic Data Types and Structures of the functions of Sketch objects.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Dimension API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Dimension API
Sketch Objects

Detailed Description

THE MODULE FOR THE ZW3D Sketch Dimension API

Sketch Dimension Query

evxErrors | cvxSkInqDim (int *Count, int **idEnts)
evxErrors | cvxSkInqDimType (int idDim, evxConsDimType *type)
evxErrors | cvxSkInqDimRefFlag (int idDim, int *refFlag)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Dimension API
cvxSkInqDim
cvxSkInqDimRefFlag
cvxSkInqDimType

◆ cvxSkInqDim()

evxErrors cvxSkInqDim | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_dim.h>

Outputs a list of indices of dimension entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of dimensions
[out] | idEnts | list of dimension entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqDimRefFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Dimension API
cvxSkInqDim
cvxSkInqDimRefFlag
cvxSkInqDimType

◆ cvxSkInqDimRefFlag()

evxErrors cvxSkInqDimRefFlag | ( | int | idDim,
 |  | int * | refFlag
 | ) |  |

#include <zwapi_sk_dim.h>

Outputs the reference flag that belong to the specified id.
1-reference flag, 0-no, -1-function fails.

Parameters
[in] | idDim | id of dimension to inquire
[out] | refFlag | reference dimension flag
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Dimension API
cvxSkInqDim
cvxSkInqDimRefFlag
cvxSkInqDimType

◆ cvxSkInqDimType()

evxErrors cvxSkInqDimType | ( | int | idDim,
 |  | evxConsDimType * | type
 | ) |  |

#include <zwapi_sk_dim.h>

Get the type(evxConsDimType) of specified dimension constraint.
It can't get the corresponding type if "*type = VX_SK_CONSDIM_UNKNOW".

Parameters
[in] | idDim | index of dimension constraint
[out] | type | type of dimension constraint
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Object API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Object API
Sketch Objects

Detailed Description

some query interfaces in the sketch.

Sketch Query/Edit

int | cvxSkInqPlane (int idSketch, svxEntPath *plnPath)
evxErrors | cvxSkInqPlanes (int idSketch, int *count, int **idFaces)
int | cvxSkIsCosmetic (int IdSketch)
int | cvxSkIsExternal (int IdSketch)
evxErrors | cvxSkInqExternalSk (int idSketch, vxPath fileName, vxRootName rootName, vxLongName skName)
evxErrors | cvxSkInqExternalSkByLongPath (int idSketch, char *fileName, int sizefile, vxRootName rootName, vxLongName skName)
int | cvxSkInqArea (int nCrv, int *idCrvs, svxPoint2 *innerPnt, svxPrfAreaProp *aboutCM, svxPrfAreaProp *aboutRf)
evxErrors | cvxSkActivate (int idSketch, int UpdateGUI)

Sketch Geometry Query

evxErrors | cvxSkInqAxis (int idSketch, int *xAxis, int *yAxis)
evxErrors | cvxSkInqAllAxis (int *Count, int **idEnts)
evxErrors | cvxSkInqAllAxisById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqAxisDir (int idAxis, svxPoint2 *pPnt, svxPoint2 *pDir)
evxErrors | cvxSkInqGeom (int *Count, int **idEnts)
evxErrors | cvxSkInqGeomById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqGeomX (int *Count, int **idEnts)
evxErrors | cvxSkInqGeomXById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqPnt (int *Count, int **idEnts)
evxErrors | cvxSkInqPntById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqRef (int *Count, int **idEnts)
evxErrors | cvxSkInqRefById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqText (int *Count, int **idEnts)
evxErrors | cvxSkInqTextById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqCns (int *Count, int **idEnts)
evxErrors | cvxSkInqCnsById (int idSketch, int *count, int **idEnts)

Sketch Curve Type

evxErrors | cvxSkInqCrvConnect (int iCount, int *idCrvs, int *iUnMatch, int *iOverMatch)
evxErrors | cvxSkEntWireType (int entId, int *type)
evxErrors | cvxSkSetWireType (int nEnt, int *idEnt, int type)

Sketch Ready Text

evxErrors | cvxSkInqReadyText (int idSketch, int *Count, int **idEnts)
evxErrors | cvxSkReadyTextInqCrvs (int idRdText, int *Count, int **idCrvs)
evxErrors | cvxSkReadyTextInqText (int idRdText, svxReadyText *RdText)
evxErrors | cvxSkReadyTextModText (int idRdText, svxReadyText *RdText)
void | cvxReadyTextFree (svxReadyText *RdText)

Sketch Block

evxErrors | cvxSkInqBlockReferences (int idSketch, int *Count, int **idEnts)
evxErrors | cvxSkInqSketchBlocks (int *Count, int **idEnts, vxRootName **Names)
evxErrors | cvxSkBlockActivate (int idBlock, int UpdateGUI)
evxErrors | cvxSkBlockGetSketch (int idBlock, int *idSketch)
evxErrors | cvxSkBlockRefGetDefinition (int idRef, int *idBlock)
evxErrors | cvxSkBlockInqGeom (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqPnt (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqDim (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqGeomX (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqRefs (int idBlock, int *count, int **idEnts)

Sketch Constraint

evxErrors | cvxSkInqCnsType (int idCons, evxGeomConsType *type, int *subType)
evxErrors | cvxSkInqCnsGeoms (int idCons, int *Count, svxConsGeom **geoms)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxReadyTextFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxReadyTextFree()

void cvxReadyTextFree ( svxReadyText * RdText )

#include <zwapi_sk_objs.h>

Frees memory associated with the specified ready sketch text structure.

Parameters
[in] RdText ready sketch text structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkActivate()

evxErrors cvxSkActivate | ( | int | idSketch,
 |  | int | UpdateGUI
 | ) |  |

#include <zwapi_sk_objs.h>

Activates the specified sketch for query or editing.

Call this function with "idSketch = 0" to exit the sketch back to its parent object.

Parameters
[in] | idSketch | id of sketch in active file (0 to exit active sketch)
[in] | UpdateGUI | 1 to update GUI; 0 to leave GUI unchanged
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockActivate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockActivate()

evxErrors cvxSkBlockActivate | ( | int | idBlock,
 |  | int | UpdateGUI
 | ) |  |

#include <zwapi_sk_objs.h>

Activates the specified 2d sketch block for query or editing.

In addition, idBlock can also be the index of a sketch block reference.
In this case the definition sketch block will be activated at the position
of the block reference.

Call this function with "idBlock = 0" to exit the sketch block
back to its parent object or previous target object.

Parameters
[in] | idBlock | id of 2d sketch block in active file (0 to exit active sketch block)
[in] | UpdateGUI | 1 to update GUI; 0 to leave GUI unchanged
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockGetSketch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockGetSketch()

evxErrors cvxSkBlockGetSketch | ( | int | idBlock,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_sk_objs.h>

Output the index of the inner sketch of the sketch block, which is invisible in the feature list.

It can be used to generate the pick path of the entity in the block which is formated as
(-1, idBlockReference, idBlock, idSketch, idEntity).

Parameters
[in] | idBlock | id of 2d sketch block
[out] | idSketch | id of the inner sketch of the sketch block
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockInqDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockInqDim()

evxErrors cvxSkBlockInqDim | ( | const vxRootName | blockName,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of dimension entities that belong to the specified block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | blockName | block name
[out] | Count | number of dimension entities
[out] | idEnts | list of dimension entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DTA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockInqGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockInqGeom()

evxErrors cvxSkBlockInqGeom | ( | const vxRootName | blockName,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of geometry entities that belong to the specified block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | blockName | block name
[out] | Count | number of geometry entities
[out] | idEnts | list of geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockInqGeomX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockInqGeomX()

evxErrors cvxSkBlockInqGeomX | ( | const vxRootName | blockName,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of construction geometry entities that belong to the specified block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | blockName | block name
[out] | Count | number of geometry entities
[out] | idEnts | list of geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockInqPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockInqPnt()

evxErrors cvxSkBlockInqPnt | ( | const vxRootName | blockName,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of point entities that belong to the specified block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | blockName | block name
[out] | Count | number of point entities
[out] | idEnts | list of point entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockInqRefs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockInqRefs()

evxErrors cvxSkBlockInqRefs | ( | int | idBlock,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of sketch block reference entity id's that belong to the specified block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idBlock | id of 2d sketch block
[out] | count | number of sketch block reference entities
[out] | idEnts | list of sketch block reference entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkBlockRefGetDefinition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkBlockRefGetDefinition()

evxErrors cvxSkBlockRefGetDefinition | ( | int | idRef,
 |  | int * | idBlock
 | ) |  |

#include <zwapi_sk_objs.h>

Output the index of the definition sketch block of the specified block reference.

Parameters
[in] | idRef | id of sketch block reference
[out] | idBlock | id of the definition sketch block
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkEntWireType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkEntWireType()

evxErrors cvxSkEntWireType | ( | int | entId,
 |  | int * | type
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs the construct type of specified entity.
1-the entity is construct line, 0-no.

Parameters
[in] | entId | id of entity
[out] | type | wire type of specified entity, 1-construct, 0-no
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqAllAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqAllAxis()

evxErrors cvxSkInqAllAxis | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Output the axis list of current sketch.
The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of Axis
[out] | idEnts | list of Axis entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqAllAxisById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqAllAxisById()

evxErrors cvxSkInqAllAxisById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Output the axis list of specified sketch.
The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of Axis
[out] | idEnts | list of Axis entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqArea

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqArea()

int cvxSkInqArea | ( | int | nCrv,
 |  | int * | idCrvs,
 |  | svxPoint2 * | innerPnt,
 |  | svxPrfAreaProp * | aboutCM,
 |  | svxPrfAreaProp * | aboutRf
 | ) |  |

#include <zwapi_sk_objs.h>

Calculates the area properties of closed profile(2D).
If the third argument (innerPnt) is V_NULL, aboutRf will be calculated
about (0,0).

Parameters
[in] | nCrv | number of curve list
[in] | idCrvs | list of boundary curves
[in] | innerPnt | reference point (the inner point)
[out] | aboutCM | Area properties about centroid
[out] | aboutRf | Area properties about ref
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
other
  • 2 - curve list is not closed
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqAxis()

evxErrors cvxSkInqAxis | ( | int | idSketch,
 |  | int * | xAxis,
 |  | int * | yAxis
 | ) |  |

#include <zwapi_sk_objs.h>

Get index of the default x and y axis of the specified sketch.
if the specified default axis is not found, the value is assigned
to -1, such as *xAxis = -1.

Parameters
[in] | idSketch | index of sketch (-1 to inquire active sketch)
[out] | xAxis | index of X axis
[out] | yAxis | index of Y axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqAxisDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqAxisDir()

evxErrors cvxSkInqAxisDir | ( | int | idAxis,
 |  | svxPoint2 * | pPnt,
 |  | svxPoint2 * | pDir
 | ) |  |

#include <zwapi_sk_objs.h>

Get the direction associated with the specified object (idAxis).

Parameters
[in] | idAxis | index of 2d axis
[out] | pPnt | start point of axis
[out] | pDir | direction of axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqBlockReferences

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqBlockReferences()

evxErrors cvxSkInqBlockReferences | ( | int | idSketch,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of sketch block reference entities
in the specified sketch or sketch block.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch or sketch block in active file (<1 for active one)
[out] | Count | number of sketch block reference entities
[out] | idEnts | list of sketch block reference entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqCns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqCns()

evxErrors cvxSkInqCns | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of constraint entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of constraints
[out] | idEnts | list of constraint entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqCnsById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqCnsById()

evxErrors cvxSkInqCnsById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of constraint entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of constraints
[out] | idEnts | list of constraint entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqCnsGeoms

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqCnsGeoms()

evxErrors cvxSkInqCnsGeoms | ( | int | idCons,
 |  | int * | Count,
 |  | svxConsGeom ** | geoms
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs the geom data array of entities associated with the specified
geometry constraint.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idCons | index of geometry constraint
[out] | Count | number of geometry entities
[out] | geoms | data of geometry entities
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqCnsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqCnsType()

evxErrors cvxSkInqCnsType | ( | int | idCons,
 |  | evxGeomConsType * | type,
 |  | int * | subType
 | ) |  |

#include <zwapi_sk_objs.h>

Get the type(evxGeomConsType) of specified geometry constraint. It can't get the corresponding type if "*type = VX_SK_CONS_UNKNOWN".

Parameters
[in] | idCons | index of geometry constraint
[out] | type | type of geometry constraint
[out] subType coordinate constraint type, only fix constraint and
point to midpoint constraint is valid:
0: both the X and Y coordinates are constrained
1: only the X coordinate is constrained
2: only the Y coordinate is constrained
3: point to arc midpoint constraint, used only VX_SK_CONS_MID
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqCrvConnect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqCrvConnect()

evxErrors cvxSkInqCrvConnect | ( | int | iCount,
 |  | int * | idCrvs,
 |  | int * | iUnMatch,
 |  | int * | iOverMatch
 | ) |  |

#include <zwapi_sk_objs.h>

Output the count of unmatched and over-matched points of specified list.

Parameters
[in] | iCount | count of input curves
[in] | idCrvs | id list of curves
[out] | iUnMatch | count of unmatched points
[out] | iOverMatch | count of over-matched points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqExternalSk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqExternalSk()

evxErrors cvxSkInqExternalSk | ( | int | idSketch,
 |  | vxPath | fileName,
 |  | vxRootName | rootName,
 |  | vxLongName | skName
 | ) |  |

#include <zwapi_sk_objs.h>

Get information about the source sketch associated with the specified
external sketch, including file name, root name and sketch name.

Parameters
[in] | idSketch | id of external sketch
[out] | fileName | file name of source sketch
[out] | rootName | root name of source sketch (output an empty string when file is a single object file)
[out] | skName | name of sketch entity (output an empty string when root object is a sketch)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqExternalSkByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqExternalSkByLongPath()

evxErrors cvxSkInqExternalSkByLongPath | ( | int | idSketch,
 |  | char * | fileName,
 |  | int | sizefile,
 |  | vxRootName | rootName,
 |  | vxLongName | skName
 | ) |  |

#include <zwapi_sk_objs.h>

Get information about the source sketch associated with the specified external sketch, including file name, root name and sketch name.

A fileName that is too long (longer than "sizefile") is truncated.

It is assumed that the input "fileName" is no longer than 512 bytes.

Parameters
[in] | idSketch | id of external sketch
[out] | fileName | file name of source sketch
[in] | sizefile | max size of fileName
[out] | rootName | root name of source sketch (output an empty string when file is a single object file)
[out] | skName | name of sketch entity (output an empty string when root object is a sketch)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqGeom()

evxErrors cvxSkInqGeom | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of geometry entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of geometry entities
[out] | idEnts | list of geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqGeomById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqGeomById()

evxErrors cvxSkInqGeomById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of geometry entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of geometry entities
[out] | idEnts | list of geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqGeomX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqGeomX()

evxErrors cvxSkInqGeomX | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of construction geometry entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of construction geometry entities
[out] | idEnts | list of construction geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqGeomXById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqGeomXById()

evxErrors cvxSkInqGeomXById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of construction geometry entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of construction geometry entities
[out] | idEnts | list of construction geometry entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqPlane()

int cvxSkInqPlane | ( | int | idSketch,
 |  | svxEntPath * | plnPath
 | ) |  |

#include <zwapi_sk_objs.h>

Get the insertion plane of the specified sketch.

Parameters
[in] | idSketch | id of sketch in active file
[out] | plnPath | pick path of the sketch insertion plane
Return values
succeeds
  • ZW_API_NO_ERROR
  • -1 - no error, but no entity was retrieved.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUT_PUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqPlanes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqPlanes()

evxErrors cvxSkInqPlanes | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idFaces
 | ) |  |

#include <zwapi_sk_objs.h>

The function of this interface is to obtain the plane on which
the sketch is attached.

If the plane attached to the sketch does not exist, the split
sub face of the plane attached to the original sketch is obtained.

The cvxSkInqPlane interface can obtain the surface attached to the sketch,
but once the attached surface is divided and the original surface does not
exist, the interface cannot be obtained.

The cvxSkInqPlanes interface has all the function of the interfaced cvxSkInqPlane,
and when the cvxSkInqPlane cannot obtain the plane, the cvxSkInqPlanes interface
can obtain the sub split plane of the original plane.

Parameters
[in] | idSketch | id of sketch
[out] | count | count of idFaces
[out] | idFaces | list of idFace
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqPnt()

evxErrors cvxSkInqPnt | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of point entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of point entities
[out] | idEnts | list of point entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqPntById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqPntById()

evxErrors cvxSkInqPntById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of point entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of point entities
[out] | idEnts | list of point entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqReadyText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqReadyText()

evxErrors cvxSkInqReadyText | ( | int | idSketch,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of ready sketch text entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | index of sketch (-1 to inquire active sketch)
[out] | Count | number of ready sketch text entities
[out] | idEnts | list of ready sketch text entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqRef

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqRef()

evxErrors cvxSkInqRef | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of external reference entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of external reference entities
[out] | idEnts | list of external reference entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqRefById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqRefById()

evxErrors cvxSkInqRefById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of external reference entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of external reference entities
[out] | idEnts | list of external reference entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqSketchBlocks

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqSketchBlocks()

evxErrors cvxSkInqSketchBlocks | ( | int * | Count,
 |  | int ** | idEnts,
 |  | vxRootName ** | Names
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of the names of all sketch block objects in the active file.
Also outputs a list of indices of them if needed.

The list referenced by "**Names" or "**idEnts" is allocated by this function and
MUST be deallocated by the calling procedure.

Parameters
[out] | Count | no. of sketch blocks in active file
[out] | idEnts | list of sketch block object id's (NULL to ignore)
[out] | Names | list of sketch block object names (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqText()

evxErrors cvxSkInqText | ( | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of text entities in the active sketch.

The calling procedure MUST deallocate the output list.

Parameters
[out] | Count | number of text entities
[out] | idEnts | list of text entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqTextById

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkInqTextById()

evxErrors cvxSkInqTextById | ( | int | idSketch,
 |  | int * | count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of text entities in specified sketch.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idSketch | id of sketch
[out] | count | number of text entities
[out] | idEnts | list of text entity id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkIsCosmetic

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkIsCosmetic()

int cvxSkIsCosmetic ( int IdSketch )

#include <zwapi_sk_objs.h>

This function is to determine whether the sketch is cosmetic.

Parameters
[in] IdSketch d of sketch
Return values
succeeds
  • 1 - indicates it is cosmetic
  • 0 - indicates it is not cosmetic or error occurs;
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkIsExternal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkIsExternal()

int cvxSkIsExternal ( int IdSketch )

#include <zwapi_sk_objs.h>

This function is to determine whether the sketch is external sketch.

Parameters
[in] IdSketch id of sketch
Return values
succeeds
  • 1 - indicating that it is external Sketch
  • 0 - indicating that it is not external Sketch or error occurs
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReadyTextInqCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkReadyTextInqCrvs()

evxErrors cvxSkReadyTextInqCrvs | ( | int | idRdText,
 |  | int * | Count,
 |  | int ** | idCrvs
 | ) |  |

#include <zwapi_sk_objs.h>

Outputs a list of indices of curve the specified ready sketch text.

The calling procedure MUST deallocate the output list.

Parameters
[in] | idRdText | index of the ready sketch text
[out] | Count | number of curves in the ready sketch text
[out] | idCrvs | list of curve id's in the ready sketch text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReadyTextInqText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkReadyTextInqText()

evxErrors cvxSkReadyTextInqText | ( | int | idRdText,
 |  | svxReadyText * | RdText
 | ) |  |

#include <zwapi_sk_objs.h>

Get string of the specified ready sketch text.

This function allocates memory for the text string. The memory MUST
be deallocated by the calling procedure using cvxReadyTextFree().

Parameters
[in] | idRdText | index of the ready sketch text
[out] | RdText | data of ready sketch text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReadyTextModText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkReadyTextModText()

evxErrors cvxSkReadyTextModText | ( | int | idRdText,
 |  | svxReadyText * | RdText
 | ) |  |

#include <zwapi_sk_objs.h>

Set string of the specified ready sketch text.

Parameters
[in] | idRdText | index of the ready sketch text
[in] | RdText | data of ready sketch text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_APPI_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkSetWireType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Object API
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ cvxSkSetWireType()

evxErrors cvxSkSetWireType | ( | int | nEnt,
 |  | int * | idEnt,
 |  | int | type
 | ) |  |

#include <zwapi_sk_objs.h>

Change geometry wire type, from 2D geometry(lines, arcs, circles, curves, axis) to construction
geometry, or change construction geometry to 2D geometry.

Parameters
[in] | nEnt | number of entity
[in] | idEnt | list of id's of entity
[in] | type | wire type (1-construct line, 0-solid line)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Objects Operation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Objects Operation
Sketch Objects

Detailed Description

THE MODULE FOR THE ZW3D Popup Menu Commands of Sketch API

Sketch Operations

void cvxSkRegen ()
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Objects Operation
cvxSkRegen

◆ cvxSkRegen()

void cvxSkRegen ( )

#include <zwapi_sk_opts.h>

Use the function to solve the current sketch automatically, all constraints, equations, dimensions and variable links associated with the current sketch are executed.

Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Variable API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Variable API
Sketch Objects

Detailed Description

THE MODULE FOR THE ZW3D Sketch Variable API

Sketch Variable

evxErrors | cvxSkVarAdd (svxVariable *Variable)
evxErrors | cvxSkVarGet (svxVariable *Variable)
evxErrors | cvxSkVarSet (int Count, svxVariable *Variables)
evxErrors | cvxSkInqVars (int *Count, svxVariable **Variables)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkInqVars

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Variable API
cvxSkInqVars
cvxSkVarAdd
cvxSkVarGet
cvxSkVarSet

◆ cvxSkInqVars()

evxErrors cvxSkInqVars | ( | int * | Count,
 |  | svxVariable ** | Variables
 | ) |  |

#include <zwapi_sk_var.h>

Outputs a list of variables that belong to the active sketch.
The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[out] | Count | number of variables
[out] | Variables | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkVarAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Variable API
cvxSkInqVars
cvxSkVarAdd
cvxSkVarGet
cvxSkVarSet

◆ cvxSkVarAdd()

evxErrors cvxSkVarAdd ( svxVariable * Variable )

#include <zwapi_sk_var.h>

Adds the specified variable to the active sketch.

Parameters
[in] Variable definition of a variable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkVarGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Variable API
cvxSkInqVars
cvxSkVarAdd
cvxSkVarGet
cvxSkVarSet

◆ cvxSkVarGet()

evxErrors cvxSkVarGet ( svxVariable * Variable )

#include <zwapi_sk_var.h>

Searches the active sketch for the variable named "Variable->Name".

The value of the specified variable is output via
"Variable->Value" in database units (mm, deg).

If "Variable->Name" is a string variable, the associated
text is output via "Variable->Expression". Strings longer
than 256 bytes are truncated.

Parameters
[in,out] Variable variable data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkVarSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Variable API
cvxSkInqVars
cvxSkVarAdd
cvxSkVarGet
cvxSkVarSet

◆ cvxSkVarSet()

evxErrors cvxSkVarSet | ( | int | Count,
 |  | svxVariable * | Variables
 | ) |  |

#include <zwapi_sk_var.h>

Updates the sketch variables specified by "Variables"
and regenerates the active sketch with the modified values.

Parameters
[in] | Count | number of variables
[in] | Variables | list of variables
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Cam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Cam

Detailed Description

Modules

Cam Component API
Cam Folder API
Cam Forms API
Cam Frame API
Cam Feature API
Cam Machine
Cam Operation
Cam Query
Cam Tool
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Cam Component API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Component API
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Components.

Cam Component Data

enum evxCmCompClass {
ZW_CAM_COMP_CLASS_PART , ZW_CAM_COMP_CLASS_CLAMP , ZW_CAM_COMP_CLASS_STOCK , ZW_CAM_COMP_CLASS_TABLE ,
ZW_CAM_COMP_CLASS_TOOLHOLDER , ZW_CAM_COMP_CLASS_ATTACHMENT
}
cam component class More...
enum | evxCmCompAtrr { ZW_CAM_COMP_ATTR_FACES , ZW_CAM_COMP_ATTR_CLASS , ZW_CAM_COMP_ATTR_CDCOMP }
cam component attribute More...
typedef enum evxCmCompClass | evxCmCompClass
cam component class
typedef enum evxCmCompAtrr | evxCmCompAtrr
cam component attribute

Cam Component Fun

evxErrors | cvxCmCompInsert (char *fileName, char *shapeName, int *idx_CmComp)
evxErrors | cvxCmCompDelete (int idx_CmComp)
evxErrors | cvxCmCompGetAttr (int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue **pValue)
evxErrors | cvxCmCompSetAttr (int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue *value)
evxErrors | cvxCmCompInqInfo (int *compCnt, vxPath **compNames, vxPath **compPaths)
evxErrors | cvxCmCompInqInfoByLongPath (int *compCnt, vxLongPath **compNames, vxLongPath **compPaths)
evxErrors | cvxCmPlanSkNew (svxMatrix *Plane, int *idSketch)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompDelete()

evxErrors cvxCmCompDelete ( int idx_CmComp )

#include <zwapi_cm_comp.h>

Delete the component in active CamPlan.

Parameters
[in] idx_CmComp index of the component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompGetAttr()

evxErrors cvxCmCompGetAttr | ( | int | idx_Cmcomp,
 |  | int | cnt,
 |  | evxCmCompAtrr * | attr,
 |  | svxCmAttrValue ** | pValue
 | ) |  |

#include <zwapi_cm_comp.h>

Inquire the component's attributes. Its value is output via "pValue".

If ZW_CAM_COMP_ATTR_CDCOMP is one value of attr, the data of pValue could be used for APIs of "assembly component" in VxApiPart.c(e.g. cvxCompInqPart()...).

If ZW_CAM_COMP_ATTR_CLASS is one value of attr, the data of pValue is one of evxCmCompClass.

The data of svxCmAttrValue should be converted according to the type of svxCmAttrValue.

Parameters
[in] | idx_Cmcomp | index of the component
[in] | cnt | count of attributes user wanna inquire
[in] | attr | the enumerations user wanna inquire
[out] | pValue | the values return; user needs to free the memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_GETCOMPVDATA_ERROR
  • ZW_API_CAM_GETCOMPINDEX_ERROR
  • ZW_API_OBJ_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_GETCOMPCLASS_ERROR
  • ZW_API_CAM_GETCOMPINDEX_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompInqInfo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompInqInfo()

evxErrors cvxCmCompInqInfo | ( | int * | compCnt,
 |  | vxPath ** | compNames,
 |  | vxPath ** | compPaths
 | ) |  |

#include <zwapi_cm_comp.h>

Get the components' information, including name and file path.

Parameters
[out] | compCnt | number of components
[out] | compNames | name of components
[out] | compPaths | path of components
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompInqInfoByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompInqInfoByLongPath()

evxErrors cvxCmCompInqInfoByLongPath | ( | int * | compCnt,
 |  | vxLongPath ** | compNames,
 |  | vxLongPath ** | compPaths
 | ) |  |

#include <zwapi_cm_comp.h>

Get the components' information, including name and file path.

Parameters
[out] | compCnt | number of components
[out] | compNames | name of components
[out] | compPaths | path of components
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompInsert()

evxErrors cvxCmCompInsert | ( | char * | fileName,
 |  | char * | shapeName,
 |  | int * | idx_CmComp
 | ) |  |

#include <zwapi_cm_comp.h>

Insert the component into active CamPlan. Its id is output via "idx_cmcomp".

Parameters
[in] | fileName | name of file for object selection
[in] | shapeName | name of shape in file for object selection
[out] | idx_CmComp | the index of the component object
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmCompSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmCompSetAttr()

evxErrors cvxCmCompSetAttr | ( | int | idx_Cmcomp,
 |  | int | cnt,
 |  | evxCmCompAtrr * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_comp.h>

Set the component attributes.
"attr" should not be "ZW_CAM_COMP_ATTR_FACES".
value->type: ZW_CAM_ATTR_VALUE_TYPE_INTEGER
value->cnt: 1
value->data: evxCmCompClass

Parameters
[in] | idx_Cmcomp | index of the component
[in] | cnt | count of attributes user wanna set
[in] | attr | the enumerations user wanna set
[in] | value | the values needed
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmPlanSkNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ cvxCmPlanSkNew()

evxErrors cvxCmPlanSkNew | ( | svxMatrix * | Plane,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cm_comp.h>

Adds a new sketch to the active cam plan, aligned with the specified insertion plane. The sketch is activated for editing.

If "idSketch" is not NULL, the id of the new sketch is output.

Parameters
[in] | Plane | sketch insertion plane
[out] | idSketch | id of new sketch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Folder API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Folder API
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Folder.

Cam Folder Data

enum | evxCmFolderAttr { CM_FOLDER_NAME , CM_FOLDER_SUB }
cam folder attribute More...
typedef enum evxCmFolderAttr | evxCmFolderAttr
cam folder attribute

Cam Folder Fun

evxErrors | cvxCmFolderGetAttr (int idx_folder, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmFolderInqOps (const vxLongPath folder_name, int *op_cnt, int **op_list)
evxErrors | cvxCmOpInsFolder (int *idx_out)
evxErrors | cvxCmObjGetTreeId (int idx_in, int *tree_id, evxCmTreeType treeType)
evxErrors | cvxCmFldRename (int idx_fld, vxLongName fld_newName)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFldRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ cvxCmFldRename()

evxErrors cvxCmFldRename | ( | int | idx_fld,
 |  | vxLongName | fld_newName
 | ) |  |

#include <zwapi_cm_folder.h>

Change the folder name.

Parameters
[in] | idx_fld | folder index
[in] | fld_newName | new folder name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFolderGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ cvxCmFolderGetAttr()

evxErrors cvxCmFolderGetAttr | ( | int | idx_folder,
 |  | int | cnt,
 |  | int * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_folder.h>

Inquire the attributes of the folder. Its value is output via "value".

value->type    &  value->cnt  &  value->data depend on "attr"
ZW_CAM_ATTR_VALUE_TYPE_STRING    <=32                 CM_FOLDER_NAME
ZW_CAM_ATTR_VALUE_TYPE_INTEGER   number      index    CM_FOLDER_SUB

User needs to allocate memory for "value", and free memory for "value->data".

Parameters
[in] | idx_folder | index of the folder
[in] | cnt | cout of the attributes
[in] | attr | list of evxCmFolderAttr user wanna get
[out] | value | list of values return
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_OPTYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFolderInqOps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ cvxCmFolderInqOps()

evxErrors cvxCmFolderInqOps | ( | const vxLongPath | folder_name,
 |  | int * | op_cnt,
 |  | int ** | op_list
 | ) |  |

#include <zwapi_cm_folder.h>

Get all operations under a folder node.

Parameters
[in] | folder_name | folder name
[out] | op_cnt | count of operations in the folder
[out] | op_list | operations' index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmObjGetTreeId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ cvxCmObjGetTreeId()

evxErrors cvxCmObjGetTreeId | ( | int | idx_in,
 |  | int * | tree_id,
 |  | evxCmTreeType | treeType
 | ) |  |

#include <zwapi_cm_folder.h>

Get tree index by object db index.

Parameters
[in] | idx_in | object index
[out] | tree_id | tree index
[in] | treeType | tree node type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_GETOPNAME_ERROR
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETFOLDERNAME_ERROR
  • ZW_API_CAM_GETFTR_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpInsFolder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ cvxCmOpInsFolder()

evxErrors cvxCmOpInsFolder ( int * idx_out )

#include <zwapi_cm_folder.h>

Insert a Folder to the OPS item.

Parameters
[out] idx_out index of folder
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Forms API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Forms API
Cam

Detailed Description

THE MODULE FOR THE API of the Cam Forms.

Cam Forms Data

enum | evxCmOutFldType { CM_OUTFLD_FLD , CM_OUTFLD_NC }
cam output folder type More...
enum evxCmOutType {
CM_OUT_CL , CM_OUT_NC , CM_OUT_TOOL , CM_OUT_OP ,
CM_OUT_XML , CM_OUT_HTML
}
cam output type More...
typedef struct svxNcSetting | svxNcSetting
cam nc output setting
typedef enum evxCmOutFldType | evxCmOutFldType
cam output folder type
typedef enum evxCmOutType | evxCmOutType
cam output type

Cam Forms Fun

evxErrors | cvxCmSetClearance (double dClearZ, double dAppZ, double dRtZ, double dAutoClear, int iMiniClr)
evxErrors | cvxCmGetClearance (double *dClearZ, double *dAppZ, double *dRtZ, double *dAutoClear, int *iMiniClr)
evxErrors | cvxCmSetSAndF (double FeedRough, double FeedFinish, double SpeedRough, double SpeedFinish, char *pName)
evxErrors | cvxCmOutputManhours (int *idx_opedef, int cnt, double *manhours)
evxErrors | cvxCmOutputInsNC (int idx_fld, int *idx_out, evxCmOutFldType fldType)
evxErrors | cvxCmOutputDelNC (int idx_in, evxCmOutFldType fldType)
evxErrors | cvxCmGetOutputNCSet (int idx_nc, svxNcSetting *ncSet)
evxErrors | cvxCmSetOutputNCSet (int idx_nc, svxNcSetting *ncSet)
evxErrors | cvxCmOutputInsOps (int idx_nc, int cnt, int *idx_op)
evxErrors | cvxCmOutputDelOps (int idx_nc, int cnt, int *idx_op)
evxErrors | cvxCmOutputNC (int idx_nc, evxCmOutType outType)
evxErrors | cvxCmOpsOutputNc (int op_cnt, int *idx_opList, int *idx_nc)
evxErrors cvxCmMsgClear ()
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmGetClearance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmGetClearance()

evxErrors cvxCmGetClearance | ( | double * | dClearZ,
 |  | double * | dAppZ,
 |  | double * | dRtZ,
 |  | double * | dAutoClear,
 |  | int * | iMiniClr
 | ) |  |

#include <zwapi_cm_forms.h>

Get the parameter of the clearances.

Parameters
[in] | dClearZ | Clearances Form's Clear Z
[in] | dAppZ | Clearances Form's Approach Z
[in] | dRtZ | Clearances Form's Retract Z
[in] | dAutoClear | Clearances Form's Auto Clear
[in] | iMiniClr | Clearances Form's Check the status of Auto Clear
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmGetOutputNCSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmGetOutputNCSet()

evxErrors cvxCmGetOutputNCSet | ( | int | idx_nc,
 |  | svxNcSetting * | ncSet
 | ) |  |

#include <zwapi_cm_forms.h>

Get attributes of the NC item. Its value is output via "ncSet".

Parameters
[in] | idx_nc | index of nc
[out] | ncSet | attribute of nc
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_CAM_GETMACH_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMsgClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmMsgClear()

evxErrors cvxCmMsgClear ( )

#include <zwapi_cm_forms.h>

Clear the output form.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpsOutputNc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOpsOutputNc()

evxErrors cvxCmOpsOutputNc | ( | int | op_cnt,
 |  | int * | idx_opList,
 |  | int * | idx_nc
 | ) |  |

#include <zwapi_cm_forms.h>

Insert operations to the NC item.

Parameters
[in] | op_cnt | number of operations
[in] | idx_opList | index of operations
[out] | idx_nc | index of nc node
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_OUTNC_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputDelNC

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputDelNC()

evxErrors cvxCmOutputDelNC | ( | int | idx_in,
 |  | evxCmOutFldType | fldType
 | ) |  |

#include <zwapi_cm_forms.h>

Delete a NC item or NC folder.

Parameters
[in] | idx_in | index of nc or nc folder
[in] | fldType | type of nc
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputDelOps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputDelOps()

evxErrors cvxCmOutputDelOps | ( | int | idx_nc,
 |  | int | cnt,
 |  | int * | idx_op
 | ) |  |

#include <zwapi_cm_forms.h>

Delete operations of the NC item.

Parameters
[in] | idx_nc | index of nc
[in] | cnt | count of operations
[in] | idx_op | list of operations
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputInsNC

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputInsNC()

evxErrors cvxCmOutputInsNC | ( | int | idx_fld,
 |  | int * | idx_out,
 |  | evxCmOutFldType | fldType
 | ) |  |

#include <zwapi_cm_forms.h>

Insert a NC item or NC folder to the NC folder.

Parameters
[in] | idx_fld | index of nc folder to insert. -1:root folder of Output
[out] | idx_out | index of nc or nc folder
[in] | fldType | insert type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputInsOps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputInsOps()

evxErrors cvxCmOutputInsOps | ( | int | idx_nc,
 |  | int | cnt,
 |  | int * | idx_op
 | ) |  |

#include <zwapi_cm_forms.h>

Insert operations to the NC item.

Parameters
[in] | idx_nc | index of nc
[in] | cnt | count of operations
[in] | idx_op | list of operations
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputManhours

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputManhours()

evxErrors cvxCmOutputManhours | ( | int * | idx_opedef,
 |  | int | cnt,
 |  | double * | manhours
 | ) |  |

#include <zwapi_cm_forms.h>

Output the ManHours.

Parameters
[in] | idx_opedef | index list of operations
[in] | cnt | count of operations
[out] | manhours | manhours (in unit : second ) traveled for operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_GETTPATH_ERROR
  • ZW_API_CAM_GETTOOL_ERROR
  • ZW_API_CAM_GETTPATHINFO_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOutputNC

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmOutputNC()

evxErrors cvxCmOutputNC | ( | int | idx_nc,
 |  | evxCmOutType | outType
 | ) |  |

#include <zwapi_cm_forms.h>

Output files of the NC item, depends on evxCmOutType.

Parameters
[in] | idx_nc | index of nc
[in] | outType | out type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CAM_OUTCL_ERROR
  • ZW_API_CAM_OUTNC_ERROR
  • ZW_API_CAM_OUTTOOL_ERROR
  • ZW_API_CAM_OUTOPLIST_ERROR
  • ZW_API_CAM_OUTOPXML_ERROR
  • ZW_API_CAM_OUTOPHTML_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSetClearance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmSetClearance()

evxErrors cvxCmSetClearance | ( | double | dClearZ,
 |  | double | dAppZ,
 |  | double | dRtZ,
 |  | double | dAutoClear,
 |  | int | iMiniClr
 | ) |  |

#include <zwapi_cm_forms.h>

Modify the parameter of the clearances.

Parameters
[in] | dClearZ | Clearances Form's Clear Z
[in] | dAppZ | Clearances Form's Approach Z
[in] | dRtZ | Clearances Form's Retract Z
[in] | dAutoClear | Clearances Form's Auto Clear
[in] | iMiniClr | Clearances Form's Check the status of Auto Clear
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSetOutputNCSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmSetOutputNCSet()

evxErrors cvxCmSetOutputNCSet | ( | int | idx_nc,
 |  | svxNcSetting * | ncSet
 | ) |  |

#include <zwapi_cm_forms.h>

Set attributes of the NC item. Members of ncSet should not be NULL.

Parameters
[in] | idx_nc | index of nc
[in] | ncSet | attribute of nc
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_CAM_GETMACH_ERROR
  • ZW_API_CAM_GETFORMSTATE_ERROR
  • ZW_API_CAM_FORMDEFINE_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_CAM_GUITOTXT_ERROR
  • ZW_API_CAM_GUIFROMTXT_ERROR
  • ZW_API_CAM_GETFORMITEM_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSetSAndF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ cvxCmSetSAndF()

evxErrors cvxCmSetSAndF | ( | double | FeedRough,
 |  | double | FeedFinish,
 |  | double | SpeedRough,
 |  | double | SpeedFinish,
 |  | char * | pName
 | ) |  |

#include <zwapi_cm_forms.h>

Modify the parameter of the speed and feed .

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | FeedRough | The Feed of Rough Operation
[in] | FeedFinish | The Feed of Finish Operation
[in] | SpeedRough | The Speed of Rough Operation
[in] | SpeedFinish | The Speed of Finish Operation
[in] | pName | This is the name of the operation you want to modify
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Frame API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Frame API
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Frame.

Cam Frame Data

enum | evxCmFrameAttr { CM_FRAME_NAME , CM_FRAME_CLEAR_Z , CM_FRAME_APPROACH_Z , CM_FRAME_RETRACT_Z }
cam frame attribute More...
typedef enum evxCmFrameAttr | evxCmFrameAttr
cam frame attribute

Cam Frame Fun

evxErrors | cvxCmFrameInsert (vxName frame_name, svxPoint origin_point, svxPoint x_point, svxPoint y_point, int *idx_frame)
evxErrors | cvxCmFrameDelete (int idx_frame)
evxErrors | cvxCmFrameGetAttr (int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmFrameSetAttr (int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmFrameInsert2 (const vxName frame_name, svxMatrix frame_mat, int *idx_frame)
evxErrors | cvxCmOpAddFrame (int idxOp, int idxFrame)
evxErrors | cvxCmFrameGetMatrix (int idxFrame, svxMatrix *frameMat)
evxErrors | cvxCmFrameGetActive (int *idx_actFrame)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameDelete()

evxErrors cvxCmFrameDelete ( int idx_frame )

#include <zwapi_cm_frame.h>

Delete the frame in CamPlan.

Parameters
[in] idx_frame index of the frame
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameGetActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameGetActive()

evxErrors cvxCmFrameGetActive ( int * idx_actFrame )

#include <zwapi_cm_frame.h>

Get the index of active frame

Parameters
[out] idx_actFrame index of active frame
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETFRAME_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameGetAttr()

evxErrors cvxCmFrameGetAttr | ( | int | idx_frame,
 |  | evxCmFrameAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_frame.h>

Inquire the Frame attributes.

Parameters
[in] | idx_frame | index of the frame
[in] | attr | enumeration of the attribute
[out] | value | return value; user needs to free the memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameGetMatrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameGetMatrix()

evxErrors cvxCmFrameGetMatrix | ( | int | idxFrame,
 |  | svxMatrix * | frameMat
 | ) |  |

#include <zwapi_cm_frame.h>

Get the frame matrix.

Parameters
[in] | idxFrame | index of the frame
[out] | frameMat | frame matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETFRAME_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameInsert()

evxErrors cvxCmFrameInsert | ( | vxName | frame_name,
 |  | svxPoint | origin_point,
 |  | svxPoint | x_point,
 |  | svxPoint | y_point,
 |  | int * | idx_frame
 | ) |  |

#include <zwapi_cm_frame.h>

Insert the Frame based on Cartesian coordinate system in the active CamPlan. The 3 svxPoints are not used at this version.

Parameters
[in] | frame_name | fame name wanna set
[in] | origin_point | origin point to construct the coordinate system
[in] | x_point | point in axis X
[in] | y_point | point in axis Y
[out] | idx_frame | index of the frame
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_FORMDEFINE_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_CAM_GETFORMITEM_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameInsert2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameInsert2()

evxErrors cvxCmFrameInsert2 | ( | const vxName | frame_name,
 |  | svxMatrix | frame_mat,
 |  | int * | idx_frame
 | ) |  |

#include <zwapi_cm_frame.h>

Insert the Frame based on Cartesian coordinate system in the active CamPlan. The 3 svxPoints are not used at this version.

Parameters
[in] | frame_name | frame name wanna set
[in] | frame_mat | frame matrix
[out] | idx_frame | index of the frame
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_FORMDEFINE_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFrameSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmFrameSetAttr()

evxErrors cvxCmFrameSetAttr | ( | int | idx_frame,
 |  | evxCmFrameAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_frame.h>

Set the Frame attributes.

"value->type"                 &     "value->cnt" depends on "attr", as follows:
ZW_CAM_ATTR_VALUE_TYPE_STRING       <=32     CM_FRAME_NAME
ZW_CAM_ATTR_VALUE_TYPE_DOUBLE       1        CM_FRAME_CLEAR_Z
                                             CM_FRAME_APPROACH_Z
                                             CM_FRAME_RETRACT_Z

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_frame | index of the frame
[in] | attr | enumeration of the attribute
[in] | value | the value wanna set
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpAddFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ cvxCmOpAddFrame()

evxErrors cvxCmOpAddFrame | ( | int | idxOp,
 |  | int | idxFrame
 | ) |  |

#include <zwapi_cm_frame.h>

Insert the Frame into the operation

Parameters
[in] | idxOp | index of the operation
[in] | idxFrame | index of the frame
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETFRAME_ERROR
  • ZW_API_CAM_GETTACTIC_ERROR
  • ZW_API_CAM_GETOPERATION_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Feature API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Feature API
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Features.

Cam Features Data

enum evxCmFtrType {
ZW_CAM_FEATURE_SOLID = 1 , ZW_CAM_FEATURE_POCKET = 2 , ZW_CAM_FEATURE_HOLE = 3 , ZW_CAM_FEATURE_SLOT = 4 ,
ZW_CAM_FEATURE_PROFILE = 5 , ZW_CAM_FEATURE_STEP = 6 , ZW_CAM_FEATURE_SURFACE = 7 , ZW_CAM_FEATURE_CHAMFER = 8 ,
ZW_CAM_FEATURE_CRND = 9 , ZW_CAM_FEATURE_FACE = 10 , ZW_CAM_FEATURE_BOSS = 11 , ZW_CAM_FEATURE_FLAT = 12
}
cam feature type More...
enum | evxCmFtrAttr { CM_FEATURE_TYPE }
cam feature attribute More...
enum | evxCmFtrProfileType { PART , CONTAIN }
cam profile feature type More...
enum | evxCmProfileCuvAttr { V_CM_PRF_OFFSET = 0 , V_CM_PRF_DRAFT = 1 , V_CM_PRF_TOOLLOC = 2 }
cam profile feature curve attribute More...
enum | evxCmProfileTolLoc { V_CM_PRF_ON = 0 , V_CM_PRF_TAN = 1 , V_CM_PRF_PAST = 2 }
cam profile feature tool location type More...
typedef enum evxCmFtrType | evxCmFtrType
cam feature type
typedef enum evxCmFtrAttr | evxCmFtrAttr
cam feature attribute
typedef enum evxCmFtrProfileType | evxCmFtrProfileType
cam profile feature type
typedef enum evxCmProfileCuvAttr | evxCmProfileCuvAttr
cam profile feature curve attribute
typedef enum evxCmProfileTolLoc | evxCmProfileTolLoc
cam profile feature tool location type

Cam Features Fun

evxErrors | cvxCmFtrInsert (evxCmFtrType ftrType, int idx_CmComp, int cnt, int *geom, int *idx_FtrGrp)
evxErrors | cvxCmFtrInsertNew (evxCmFtrType ftrType, int cnt, int *geom, double *depths, int *idx_FtrGrp)
evxErrors | cvxCmFtrInsertWithoutHoles (evxCmFtrType ftrType, const vxName ftrName, int cnt, int *geom, int *idxFtrGrp)
evxErrors | cvxCmFtrInsertSK (evxCmFtrType ftrType, const vxName ftrName, int idxSk, int cnt, int *geom, int *idxFtrGrp)
evxErrors | cvxCmFtrGetComp (int *comp_cnt, int **idxComp)
evxErrors | cvxCmGetCrvId (int *numLine, int **lstLines)
evxErrors | cvxCmFtrInsertHole (const vxName ftrName, int cnt, int *geom, double *depths, int *idxFtrGrp)
evxErrors | cvxCmPlanDispSetMode (evxCmPlanDispMode iMode)
evxErrors | cvxCmFtrDelete (int idx_ftrgrp)
evxErrors | cvxCmFtrGetAttr (int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
evxErrors | cvxCmFtrSetAttr (int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
evxErrors | cvxCmFtrRename (int idx_ftr, vxLongName newFtrName)
evxErrors | cvxCmProfSetAttr (int prof_idx, int curve_idx, double newOffset, double newDraft, int tolloc)
evxErrors | cvxCmFtrInqType (int idx_Ftr, evxCmFtrType *ftrType)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrDelete()

evxErrors cvxCmFtrDelete ( int idx_ftrgrp )

#include <zwapi_cm_ftr.h>

Delete the feature.

Parameters
[in] idx_ftrgrp index of the feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrGetAttr()

evxErrors cvxCmFtrGetAttr | ( | int | idx_ftrgrp,
 |  | int | cnt,
 |  | evxCmFtrAttr * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_ftr.h>

Inquire the attribute of the feature.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_ftrgrp | index of the feature
[in] | cnt | count of the attributes
[in] | attr | Attributes of interest
[out] | value | the values return; user needs to free the memory
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrGetComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrGetComp()

evxErrors cvxCmFtrGetComp | ( | int * | comp_cnt,
 |  | int ** | idxComp
 | ) |  |

#include <zwapi_cm_ftr.h>

Get component's geom index.

The idxComp output array must be deallocated with cvxMemFree().

Parameters
[out] | comp_cnt | count of components
[out] | idxComp | index of components
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInqType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInqType()

evxErrors cvxCmFtrInqType | ( | int | idx_Ftr,
 |  | evxCmFtrType * | ftrType
 | ) |  |

#include <zwapi_cm_ftr.h>

Inquire the type of feature

Parameters
[in] | idx_Ftr | profile feature index
[out] | ftrType | feature class
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInsert()

evxErrors cvxCmFtrInsert | ( | evxCmFtrType | ftrType,
 |  | int | idx_CmComp,
 |  | int | cnt,
 |  | int * | geom,
 |  | int * | idx_FtrGrp
 | ) |  |

#include <zwapi_cm_ftr.h>

Add a feature in the component.

Parameters
[in] | ftrType | type of the feature
[in] | idx_CmComp | index of the component
[in] | cnt | count of the geometries
[in] | geom | geometry indexes
[out] | idx_FtrGrp | index of feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInsertHole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInsertHole()

evxErrors cvxCmFtrInsertHole | ( | const vxName | ftrName,
 |  | int | cnt,
 |  | int * | geom,
 |  | double * | depths,
 |  | int * | idxFtrGrp
 | ) |  |

#include <zwapi_cm_ftr.h>

Add a hole feature in the component.

Parameters
[in] | ftrName | feature name
[in] | cnt | count of the geometries
[in] | geom | geometry indexes
[in] | depths | depths of holes
[out] | idxFtrGrp | index of feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETCOMPVDATA_ERROR
  • ZW_API_CAM_GUITOTXT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInsertNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInsertNew()

evxErrors cvxCmFtrInsertNew | ( | evxCmFtrType | ftrType,
 |  | int | cnt,
 |  | int * | geom,
 |  | double * | depths,
 |  | int * | idx_FtrGrp
 | ) |  |

#include <zwapi_cm_ftr.h>

Add a feature in the component.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | ftrType | type of the feature
[in] | cnt | count of the geometries
[in] | geom | geometry indexes
[in] | depths | depths of holes
[out] | idx_FtrGrp | index of feature
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInsertSK

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInsertSK()

evxErrors cvxCmFtrInsertSK | ( | evxCmFtrType | ftrType,
 |  | const vxName | ftrName,
 |  | int | idxSk,
 |  | int | cnt,
 |  | int * | geom,
 |  | int * | idxFtrGrp
 | ) |  |

#include <zwapi_cm_ftr.h>

Add a feature in the sketch.

Parameters
[in] | ftrType | type of the feature
[in] | ftrName | feature name which needs to be added to the new member
[in] | idxSk | index of the sketch where the geom is located.
[in] | cnt | feature data
[in] | geom | index of geom
[out] | idxFtrGrp | index of feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETCOMPVDATA_ERROR
  • ZW_API_CAM_GUITOTXT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrInsertWithoutHoles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrInsertWithoutHoles()

evxErrors cvxCmFtrInsertWithoutHoles | ( | evxCmFtrType | ftrType,
 |  | const vxName | ftrName,
 |  | int | cnt,
 |  | int * | geom,
 |  | int * | idxFtrGrp
 | ) |  |

#include <zwapi_cm_ftr.h>

Add a feature in the component. This function provides the ability to generate features other than holes. Currently, profile,surface,chamfer and cround are supported.

Parameters
[in] | ftrType | type of the feature
[in] | ftrName | feature name which needs to be added to the new member
[in] | cnt | count of the geometries
[in] | geom | geometry indexes
[out] | idxFtrGrp | index of feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETCOMPVDATA_ERROR
  • ZW_API_CAM_GUITOTXT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrRename()

evxErrors cvxCmFtrRename | ( | int | idx_ftr,
 |  | vxLongName | newFtrName
 | ) |  |

#include <zwapi_cm_ftr.h>

Change the feature name.

Parameters
[in] | idx_ftr | cam tree index
[in] | newFtrName | new name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmFtrSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmFtrSetAttr()

evxErrors cvxCmFtrSetAttr | ( | int | idx_ftrgrp,
 |  | int | cnt,
 |  | evxCmFtrAttr * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_ftr.h>

Modify the attribute of the feature.

value->type:   ZW_CAM_ATTR_VALUE_TYPE_INTEGER
value->cnt:    1
value->data:   0("part")
               1("contain")

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_ftrgrp | index of the feature
[in] | cnt | count of the attributes
[in] | attr | Attributes of interest
[in] | value | values to assign to the feature
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmGetCrvId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmGetCrvId()

evxErrors cvxCmGetCrvId | ( | int * | numLine,
 |  | int ** | lstLines
 | ) |  |

#include <zwapi_cm_ftr.h>

Get curves' index in part

Parameters
[out] | numLine | number of curve
[out] | lstLines | list of curve id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmPlanDispSetMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmPlanDispSetMode()

evxErrors cvxCmPlanDispSetMode ( evxCmPlanDispMode iMode )

#include <zwapi_cm_ftr.h>

Set cam plan display mode.

Parameters
[in] iMode display mode
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmProfSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ cvxCmProfSetAttr()

evxErrors cvxCmProfSetAttr | ( | int | prof_idx,
 |  | int | curve_idx,
 |  | double | newOffset,
 |  | double | newDraft,
 |  | int | tolloc
 | ) |  |

#include <zwapi_cm_ftr.h>

Change the profile curve parameters

Parameters
[in] | prof_idx | profile feature index
[in] | curve_idx | curve in profile feature index
[in] | newOffset | offset value
[in] | newDraft | draft value
[in] | tolloc | tool location value
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETFTRGRP_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Machine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Machine
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Machine.

Cam Machine Data

enum | evxCmMachClass { TWO_AXIS_MC , THREE_AXIS_MC }
cam machine class More...
enum | evxCmMachType { CM_MACH_TYPE_VERTICAL , CM_MACH_TYPE_HORIZNTAL }
cam machine type More...
enum | evxCmMachSubType { CM_MACH_SUBTYPE_ROTATING_HEAD , CM_MACH_SUBTYPE_ROTATING_TABLE }
cam machine sub type More...
enum | evxCmMachCutCompenation { CM_MACH_CUT_COMPENSATION_NONE , CM_MACH_CUT_COMPENSATION_LENGTH , CM_MACH_CUT_COMPENSATION_CENTER }
cam machine cut type More...
enum evxCmMachAttr {
CM_MACH_NAME , CM_MACH_CLASS , CM_MACH_TYPE , CM_MACH_SUBTYPE ,
CM_MACH_POST_CONFIGURATION , CM_MACH_CUT_COMPENSATION
}
cam machine attribute More...
typedef enum evxCmMachClass | evxCmMachClass
cam machine class
typedef enum evxCmMachType | evxCmMachType
cam machine type
typedef enum evxCmMachSubType | evxCmMachSubType
cam machine sub type
typedef enum evxCmMachCutCompenation | evxCmMachCutCompenation
cam machine cut type
typedef enum evxCmMachAttr | evxCmMachAttr
cam machine attribute

Cam Machine Fun

evxErrors | cvxCmMachineInsert (evxCmMachClass machine_class, evxCmMachType machine_type, evxCmMachSubType sub_type, int *idx_machine)
evxErrors | cvxCmMachineActive (int idx_machine)
evxErrors | cvxCmMachineDelete (int idx_machine)
evxErrors | cvxCmMachineGetAttr (int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmMachineSetAttr (int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmToolChangerInsert (int idx_toolchanger, int Location, int Diameter, int Height)
evxErrors | cvxCmToolChangerDelete (int idx_toolchanger)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMachineActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmMachineActive()

evxErrors cvxCmMachineActive ( int idx_machine )

#include <zwapi_cm_machine.h>

Set the machine to active.

Parameters
[in] idx_machine machine index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CAM_GETMACHNAME_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMachineDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmMachineDelete()

evxErrors cvxCmMachineDelete ( int idx_machine )

#include <zwapi_cm_machine.h>

Delete the machine.

Parameters
[in] idx_machine machine index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMachineGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmMachineGetAttr()

evxErrors cvxCmMachineGetAttr | ( | int | idx_machine,
 |  | evxCmMachAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_machine.h>

Get attribute of a machine.

Parameters
[in] | idx_machine | index of machine
[in] | attr | type of attribute
[out] | value | value of attribute, user need to free the memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETMACHNAME_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMachineInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmMachineInsert()

evxErrors cvxCmMachineInsert | ( | evxCmMachClass | machine_class,
 |  | evxCmMachType | machine_type,
 |  | evxCmMachSubType | sub_type,
 |  | int * | idx_machine
 | ) |  |

#include <zwapi_cm_machine.h>

Insert a machine to the cam plan.

Parameters
[in] | machine_class | machine class
[in] | machine_type | machine type
[in] | sub_type | machine sub_type
[out] | idx_machine | index of machine
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_FORMDEFINE_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_CAM_GETMACHNAME_ERROR
  • ZW_API_CAM_GETMACH_ERROR
  • ZW_API_CAM_GETFORMITEM_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_CAM_GUITOTXT_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmMachineSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmMachineSetAttr()

evxErrors cvxCmMachineSetAttr | ( | int | idx_machine,
 |  | evxCmMachAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_machine.h>

Modify the machine's attribute .

"value->type"          &     "value->cnt"   &value->data depends on     "attr", as follows:
ZW_CAM_ATTR_VALUE_TYPE_STRING       <=32                                CM_MACH_NAME
                                                                        CM_MACH_POST_CONFIGURATION
ZW_CAM_ATTR_VALUE_TYPE_INTEGER      1       evxCmMachClass              CM_MACH_CLASS
                                            evxCmMachType               CM_MACH_TYPE
                                            evxCmMachSubType            CM_MACH_SUBTYPE
                                            evxCmMachCutCompenation     CM_MACH_CUT_COMPENSATION
Parameters
[in] | idx_machine | index of the machine
[in] | attr | type of attribute
[in] | value | value of attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolChangerDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmToolChangerDelete()

evxErrors cvxCmToolChangerDelete ( int idx_toolchanger )

#include <zwapi_cm_machine.h>

Delete the tool changer in the active machine.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] idx_toolchanger tool index
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolChangerInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ cvxCmToolChangerInsert()

evxErrors cvxCmToolChangerInsert | ( | int | idx_toolchanger,
 |  | int | Location,
 |  | int | Diameter,
 |  | int | Height
 | ) |  |

#include <zwapi_cm_machine.h>

Insert a tool to the active machine's tool changer.

Parameters
[in] | idx_toolchanger | tool index
[in] | Location | location
[in] | Diameter | cutter compensation along Diameter
[in] | Height | cutter compensation along Hight
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Operation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Operation
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Operation.

Cam Operation Data

enum evxCmOpType {
ZW_CAM_OPERATION_CENTER = 0 , ZW_CAM_OPERATION_DRILL , ZW_CAM_OPERATION_PECK , ZW_CAM_OPERATION_CHIP ,
ZW_CAM_OPERATION_REAM , ZW_CAM_OPERATION_BORE , ZW_CAM_OPERATION_FINEBORE , ZW_CAM_OPERATION_COUNTERBORE ,
ZW_CAM_OPERATION_COUNTERSINK , ZW_CAM_OPERATION_TAP , ZW_CAM_OPERATION_PROFILECUT = 20 , ZW_CAM_OPERATION_SPIRAL ,
ZW_CAM_OPERATION_ZIGZAG , ZW_CAM_OPERATION_BOX , ZW_CAM_OPERATION_CONTOUR , ZW_CAM_OPERATION_CHAMFER ,
ZW_CAM_OPERATION_COURNER_ROUND , ZW_CAM_OPERATION_HELICAL , ZW_CAM_OPERATION_RAMP , ZW_CAM_OPERATION_TOPFACE_CUT ,
ZW_CAM_OPERATION_NESTING , ZW_CAM_OPERATION_INTER_PATH_MOVE , ZW_CAM_OPERATION_THREADMILL , ZW_CAM_OPERATION_DRILL_TURNING = 35 ,
ZW_CAM_OPERATION_FACING , ZW_CAM_OPERATION_ROUGH , ZW_CAM_OPERATION_FINISH , ZW_CAM_OPERATION_GROOVE ,
ZW_CAM_OPERATION_THREADING , ZW_CAM_OPERATION_PARTOFF , ZW_CAM_OPERATION_SPIRAL_ROUGH = 50 , ZW_CAM_OPERATION_ZIGZAG_ROUGH ,
ZW_CAM_OPERATION_BOX_ROUGH , ZW_CAM_OPERATION_CONTOUR_ROUGH , ZW_CAM_OPERATION_SPIRAL_CAST = 55 , ZW_CAM_OPERATION_ZIGZAG_CAST ,
ZW_CAM_OPERATION_BOX_CAST , ZW_CAM_OPERATION_CONTOUR_CAST , ZW_CAM_OPERATION_SPIRAL_FINISH = 60 , ZW_CAM_OPERATION_ZIGZAG_FINISH ,
ZW_CAM_OPERATION_BOX_FINISH , ZW_CAM_OPERATION_CONTOUR_FINISH , ZW_CAM_OPERATION_PROFILE_FINISH , ZW_CAM_OPERATION_SIDE ,
ZW_CAM_OPERATION_PEELING , ZW_CAM_OPERATION_ISO , ZW_CAM_OPERATION_3XISO , ZW_CAM_OPERATION_MAP ,
ZW_CAM_OPERATION_REST , ZW_CAM_OPERATION_PENCIL_TRACE , ZW_CAM_OPERATION_SCALLOP_REMOVAL , ZW_CAM_OPERATION_SURFACE_ENGRAVING ,
ZW_CAM_OPERATION_SMOOTHFLOW = 80 , ZW_CAM_OPERATION_OFFSET2D , ZW_CAM_OPERATION_LACE_ROUGH , ZW_CAM_OPERATION_PLUNGE ,
ZW_CAM_OPERATION_PRE_DRILL , ZW_CAM_OPERATION_OFFSET3D , ZW_CAM_OPERATION_LACE_FINISH , ZW_CAM_OPERATION_ANGLE_LIMITING_FINISHING ,
ZW_CAM_OPERATION_DRIVE_CURVE , ZW_CAM_OPERATION_ZLEVEL , ZW_CAM_OPERATION_PENCIL , ZW_CAM_OPERATION_FLOW_3D ,
ZW_CAM_OPERATION_BULGE , ZW_CAM_OPERATION_ENGRAVE_2D , ZW_CAM_OPERATION_SMOOTHFLOW_HSM = 95 , ZW_CAM_OPERATION_OFFSET2D_HSM ,
ZW_CAM_OPERATION_LACE_HSM , ZW_CAM_OPERATION_FLOW_HSM , ZW_CAM_OPERATION_CORNERFINISH , ZW_CAM_OPERATION_FLATFINISH ,
ZW_CAM_OPERATION_PLANE = 110 , ZW_CAM_OPERATION_SWARF , ZW_CAM_OPERATION_DRIVECURVE_5X , ZW_CAM_OPERATION_INTERACTIVE ,
ZW_CAM_OPERATION_FLOW_5X , ZW_CAM_OPERATION_SIDE_5X , ZW_CAM_OPERATION_GUIDE_SURFACE_ISO
}
cam operation type More...
enum | evxCm2XOpAttr { ZW_CAM_2X_OPERATION_ATTR_NAME = 300 , ZW_CAM_2X_OPERATION_ATTR_FRAME , ZW_CAM_2X_OPERATION_ATTR_PATH_TOL }
cam mill2 operation attribute More...
enum evxCmQmOpAttr {
ZW_CAM_QM_OPERATION_ATTR_NAME = 400 , ZW_CAM_QM_OPERATION_ATTR_FRAME , ZW_CAM_QM_OPERATION_ATTR_PATH_TOL , ZW_CAM_QM_OPERATION_ATTR_SURF_THICK ,
ZW_CAM_QM_OPERATION_ATTR_Z_SURF_THICK , ZW_CAM_QM_OPERATION_ATTR_TOOL , ZW_CAM_QM_OPERATION_ATTR_MINTOOLHEIGHT , ZW_CAM_QM_OPERATION_ATTR_CLASS ,
ZW_CAM_QM_OPERATION_ATTR_LIMIT_TOPZ , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOMZ , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_ZDISPLACEMENT ,
ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_OFFSET
}
cam qm operation attribute More...
enum | evxCmOpClass { CM_OP_ROUGH = 0 , CM_OP_FINISH = 1 }
cam operation class: finish or rough More...
typedef enum evxCmOpType | evxCmOpType
cam operation type
typedef enum evxCm2XOpAttr | evxCm2XOpAttr
cam mill2 operation attribute
typedef enum evxCmQmOpAttr | evxCmQmOpAttr
cam qm operation attribute
typedef enum evxCmOpClass | evxCmOpClass
cam operation class: finish or rough

Cam Operation Fun

evxErrors | cvxCmOpInsert (evxCmOpType opType, int *idx_Op)
evxErrors | cvxCmOpDelete (int idx_Op)
evxErrors | cvxCmOpDuplicate (int idx_Op, int *cpyOp)
evxErrors | cvxCmOpAddComp (int idx_Op, int idx_CmComp)
evxErrors | cvxCmOpRemoveComp (int idx_Op, int idx_CmComp)
evxErrors | cvxCmOpAddFtr (int idx_Op, int idx_FtrGrp)
evxErrors | cvxCmOpRemoveFtr (int idx_Op, int idx_ftrgrp)
evxErrors | cvxCmOpCalTPath (int idx_Op)
evxErrors | cvxCmOpAddTool (int idx_Op, int idx_Tool)
evxErrors | cvxCmOpRemoveTool (int idx_Op)
evxErrors | cvxCmOpGetAttr (int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmOpSetAttr (int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmOpSetAttrAsCfg (int idx_Op, const vxLongPath cfg_location)
evxErrors | cvxCmOpSetSpeed (int idx_op, vxName spdfdName)
evxErrors | cvxCmOpSetAttr2 (int idx_op, int field, int item, const char *value)
evxErrors | cvxCmOpGetAttr2 (int idx_op, int field, int item, int *is_on, char *value)
evxErrors | cvxCmOpGetIdxFromName (vxLongName op_name, int *op_index)
evxErrors | cvxCmSetOpPoint (int idx_op, svxPoint p0, int field)
evxErrors | cvxCmSetOpPoints (int idx_op, int num, svxPoint *pts, int field)
evxErrors | cvxCmOpRename (int idx_op, vxLongName op_newName)
evxErrors | cvxCmOpDrag (int drag_idx, evxCmTreeType drag_type, int drop_idx, evxCmTreeType drop_type, int iPos)
evxErrors | cvxCmOpSetBasicAttr (int idx_op, int field, int item, const char *value)
evxErrors | cvxCmOpInqClass (int idx_Op, evxCmOpClass *opClass)
evxErrors | cvxCmOpSetClass (int idx_Op, evxCmOpClass opClass)
evxErrors | cvxCmOpInqTypeS (int idx_Op, char *opType, int nByte)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpAddComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpAddComp()

evxErrors cvxCmOpAddComp | ( | int | idx_Op,
 |  | int | idx_CmComp
 | ) |  |

#include <zwapi_cm_op.h>

Add the component into the operation.

Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CAM_GETOPNAME_ERROR
  • ZW_API_CAM_GETTACNAME_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpAddFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpAddFtr()

evxErrors cvxCmOpAddFtr | ( | int | idx_Op,
 |  | int | idx_FtrGrp
 | ) |  |

#include <zwapi_cm_op.h>

Add the feature into the operation.

Parameters
[in] | idx_Op | index of the operation
[in] | idx_FtrGrp | index of the feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CAM_GETFTRGRP_ERROR
  • ZW_API_CAM_GETFTRDBNAME_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpAddTool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpAddTool()

evxErrors cvxCmOpAddTool | ( | int | idx_Op,
 |  | int | idx_Tool
 | ) |  |

#include <zwapi_cm_op.h>

Add a tool in the target operation.

Parameters
[in] | idx_Op | index of the operation
[in] | idx_Tool | index of the tool
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpCalTPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpCalTPath()

evxErrors cvxCmOpCalTPath ( int idx_Op )

#include <zwapi_cm_op.h>

Calculate the operation.

Parameters
[in] idx_Op index of the operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpDelete()

evxErrors cvxCmOpDelete ( int idx_Op )

#include <zwapi_cm_op.h>

Delete an operation in the active CamPlan.

Parameters
[in] idx_Op index of operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpDrag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpDrag()

evxErrors cvxCmOpDrag | ( | int | drag_idx,
 |  | evxCmTreeType | drag_type,
 |  | int | drop_idx,
 |  | evxCmTreeType | drop_type,
 |  | int | iPos
 | ) |  |

#include <zwapi_cm_op.h>

Replace two tree nodes position.

Parameters
[in] | drag_idx | index of to be drag
[in] | drag_type | type of to be drag
[in] | drop_idx | index of to be drop
[in] | drop_type | type of to be drop
[in] | iPos | position of to be drop 0:in,1:above,2:below
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpDuplicate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpDuplicate()

evxErrors cvxCmOpDuplicate | ( | int | idx_Op,
 |  | int * | cpyOp
 | ) |  |

#include <zwapi_cm_op.h>

Duplicate an operation in the active CamPlan.

Parameters
[in] | idx_Op | index of source operation
[out] | cpyOp | index of destination op
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpGetAttr()

evxErrors cvxCmOpGetAttr | ( | int | idx_Op,
 |  | int | cnt,
 |  | int * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_op.h>

Inquire the attributes of the operation. Output a list of svxCmAttrValue via "value".

Not all evxCmQmOpAttr is available for different type of Operation.
As follows are 5 Operation Type,
   value->type        &             value->cnt   & value->data depend on "attr"
ZW_CAM_OPERATION_PROFILECUT:
   ZW_CAM_ATTR_VALUE_TYPE_STRING    <=32                 ZW_CAM_QM_OPERATION_ATTR_NAME
                                                         ZW_CAM_QM_OPERATION_ATTR_CLASS
                                                         ZW_CAM_QM_OPERATION_ATTR_FRAME
   ZW_CAM_ATTR_VALUE_TYPE_INTEGER   1     index of tool  ZW_CAM_QM_OPERATION_ATTR_TOOL
ZW_CAM_OPERATION_SMOOTHFLOW
ZW_CAM_OPERATION_OFFSET2D
ZW_CAM_OPERATION_OFFSET3D
ZW_CAM_OPERATION_ZLEVEL:
   ZW_CAM_ATTR_VALUE_TYPE_STRING    <=32                 ZW_CAM_QM_OPERATION_ATTR_NAME
                                                         ZW_CAM_QM_OPERATION_ATTR_CLASS
                                                         ZW_CAM_QM_OPERATION_ATTR_FRAME
   ZW_CAM_ATTR_VALUE_TYPE_DOUBLE    1                    ZW_CAM_QM_OPERATION_ATTR_SURF_THICK
                                                         ZW_CAM_QM_OPERATION_ATTR_MINTOOLHEIGHT
   ZW_CAM_ATTR_VALUE_TYPE_INTEGER   1     index of tool  ZW_CAM_QM_OPERATION_ATTR_TOOL

The following is a simple code to get operation's frame and surface thick:

void TestApi(void)
{
int cnt=0, *list=NULL;
cvxCmInqAl(CM_OPERATION, &cnt, &list);
if (cnt > 0)
{
svxCmAttrValue attrs[2];
int num=2;
int types[2]={ZW_CAM_QM_OPERATION_ATTR_FRAME, ZW_CAM_QM_OPERATION_ATTR_SURF_THICK};
cvxCmOpGetAttr(list[0], num, types, attrs);
{
char frame[32];
strcpy(frame, (char *)attrs[0].data);
}
{
double thick;
thick = *(double*)attrs[1].data;
}
cvxMemFree((void **)&attrs[0].data);
cvxMemFree((void **)&attrs[1].data);
}
cvxMemFree((void**)&list);
return;
}
cvxCmOpGetAttr
evxErrors cvxCmOpGetAttr(int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
cvxCmInqAl
evxErrors cvxCmInqAl(evxCmObjType type, int *cnt, int **idx_obj)
cvxMemFree
void cvxMemFree(void **MemPointer)
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514

User needs to allocate memory for "value", and free memory for "value->data".

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_Op | index of the operation
[in] | cnt | count of the attributes
[in] | attr | enumerations user wanna get
[out] | value | the values return
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpGetAttr2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpGetAttr2()

evxErrors cvxCmOpGetAttr2 | ( | int | idx_op,
 |  | int | field,
 |  | int | item,
 |  | int * | is_on,
 |  | char * | value
 | ) |  |

#include <zwapi_cm_op.h>

Inquire the attributes of the operation.

Parameters
[in] | idx_op | index of the operation
[in] | field | field id of the attribute
[in] | item | item id of the attribute
[out] | is_on | on/off flag (MAYBE NULL)
[out] | value | value of the attribute, caller should allocate memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpGetIdxFromName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpGetIdxFromName()

evxErrors cvxCmOpGetIdxFromName | ( | vxLongName | op_name,
 |  | int * | op_index
 | ) |  |

#include <zwapi_cm_op.h>

Get the operation index with the specified name.

Parameters
[in] | op_name | name of operation
[out] | op_index | index of operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_GETOPBYTAC_ERROR
  • ZW_API_CAM_GETOPNAME_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpInqClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpInqClass()

evxErrors cvxCmOpInqClass | ( | int | idx_Op,
 |  | evxCmOpClass * | opClass
 | ) |  |

#include <zwapi_cm_op.h>

Inquire operation's class

Parameters
[in] | idx_Op | index of operation
[out] | opClass | class of operation 0:rough,1:finish
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpInqTypeS

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpInqTypeS()

evxErrors cvxCmOpInqTypeS | ( | int | idx_Op,
 |  | char * | opType,
 |  | int | nByte
 | ) |  |

#include <zwapi_cm_op.h>

Get the operation's type

Parameters
[in] | idx_Op | index of operation
[out] | opType | type of operation
[in] | nByte | size of type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CAM_OPTYPE_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpInsert()

evxErrors cvxCmOpInsert | ( | evxCmOpType | opType,
 |  | int * | idx_Op
 | ) |  |

#include <zwapi_cm_op.h>

Create an operation in the active CamPlan.

Parameters
[in] | opType | Operation type
[out] | idx_Op | index of this inserted Operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CAM_OPTYPE_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpRemoveComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpRemoveComp()

evxErrors cvxCmOpRemoveComp | ( | int | idx_Op,
 |  | int | idx_CmComp
 | ) |  |

#include <zwapi_cm_op.h>

Remove the component of the operation.

Parameters
[in] | idx_Op | index of the operation
[in] | idx_CmComp | index of the component
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpRemoveFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpRemoveFtr()

evxErrors cvxCmOpRemoveFtr | ( | int | idx_Op,
 |  | int | idx_ftrgrp
 | ) |  |

#include <zwapi_cm_op.h>

Remove the feature of the operation.

Parameters
[in] | idx_Op | index of the operation
[in] | idx_ftrgrp | index of the feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpRemoveTool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpRemoveTool()

evxErrors cvxCmOpRemoveTool ( int idx_Op )

#include <zwapi_cm_op.h>

Remove the tool of the target operation.

Parameters
[in] idx_Op index of the operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpRename()

evxErrors cvxCmOpRename | ( | int | idx_op,
 |  | vxLongName | op_newName
 | ) |  |

#include <zwapi_cm_op.h>

Change the operation name.

Parameters
[in] | idx_op | operation index
[in] | op_newName | new name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetAttr()

evxErrors cvxCmOpSetAttr | ( | int | idx_Op,
 |  | int | cnt,
 |  | int * | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_op.h>

Modify the attributes of the operation.

Not all evxCmQmOpAttr is available for different type of Operation.
As follows are 5 Operation Type,
   value->type        &             value->cnt   & value->data depend on "attr"
ZW_CAM_OPERATION_PROFILECUT:
   ZW_CAM_ATTR_VALUE_TYPE_STRING    <=32                 ZW_CAM_QM_OPERATION_ATTR_NAME
ZW_CAM_OPERATION_SMOOTHFLOW
ZW_CAM_OPERATION_OFFSET2D
ZW_CAM_OPERATION_OFFSET3D
ZW_CAM_OPERATION_ZLEVEL:
   ZW_CAM_ATTR_VALUE_TYPE_STRING    <=32                 ZW_CAM_QM_OPERATION_ATTR_NAME
   ZW_CAM_ATTR_VALUE_TYPE_DOUBLE    1                    ZW_CAM_QM_OPERATION_ATTR_SURF_THICK

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_Op | index of the operation
[in] | cnt | count of the attributes
[in] | attr | enumerations user wanna set
[in] | value | the values needed
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetAttr2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetAttr2()

evxErrors cvxCmOpSetAttr2 | ( | int | idx_op,
 |  | int | field,
 |  | int | item,
 |  | const char * | value
 | ) |  |

#include <zwapi_cm_op.h>

Modify the attributes of the operation.

Parameters
[in] | idx_op | index of the operation
[in] | field | field id of the attribute
[in] | item | item id of the attribute
[in] | value | value of the attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_CAM_OPTYPE_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetAttrAsCfg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetAttrAsCfg()

evxErrors cvxCmOpSetAttrAsCfg | ( | int | idx_Op,
 |  | const vxLongPath | cfg_location
 | ) |  |

#include <zwapi_cm_op.h>

Set the attributes of the operation depends on the config file. To get a config file:

  1. Open an operation form, and set your parameters.
  2. Click "Save" button.
    Notice that, config file will ignore those parameters which have their own objects, such as "frame", "point"...

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_Op | index of the operation
[in] | cfg_location | cfg file location with file name
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetBasicAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetBasicAttr()

evxErrors cvxCmOpSetBasicAttr | ( | int | idx_op,
 |  | int | field,
 |  | int | item,
 |  | const char * | value
 | ) |  |

#include <zwapi_cm_op.h>

Modify the attributes of the operation.

Parameters
[in] | idx_op | index of the operation
[in] | field | field id of the attribute
[in] | item | item id of the attribute
[in] | value | value of the attribute
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_CAM_OPTYPE_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetClass()

evxErrors cvxCmOpSetClass | ( | int | idx_Op,
 |  | evxCmOpClass | opClass
 | ) |  |

#include <zwapi_cm_op.h>

Set the operation's class parameter

Parameters
[in] | idx_Op | index of operation
[in] | opClass | class of operation 0:rough,1:finish
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CAM_OPTYPE_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmOpSetSpeed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmOpSetSpeed()

evxErrors cvxCmOpSetSpeed | ( | int | idx_op,
 |  | vxName | spdfdName
 | ) |  |

#include <zwapi_cm_op.h>

Set speed & feed for the operation. The speed & feed is from active Cam plan or current Library or default Library in proper order.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_op | idx of opdef
[in] | spdfdName | name of speed & feed
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSetOpPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmSetOpPoint()

evxErrors cvxCmSetOpPoint | ( | int | idx_op,
 |  | svxPoint | p0,
 |  | int | field
 | ) |  |

#include <zwapi_cm_op.h>

Set one point to operation parameter.

Parameters
[in] | idx_op | index of operation
[in] | p0 | point value
[in] | field | operation parameter's field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_SETVDATA_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSetOpPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ cvxCmSetOpPoints()

evxErrors cvxCmSetOpPoints | ( | int | idx_op,
 |  | int | num,
 |  | svxPoint * | pts,
 |  | int | field
 | ) |  |

#include <zwapi_cm_op.h>

Set points to operation parameter.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_op | index of operation
[in] | num | number of points
[in] | pts | points value
[in] | field | operation parameter's field
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Query

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Query
Cam

Detailed Description

THE MODULE FOR THE ZW3D API of the Cam Query.

Cam Query Data

enum evxCmObjType {
CM_OPERATION , CM_OPFOLDER , CM_TOOL , CM_MACHINE ,
CM_CMCOMP , CM_FTR , CM_FRAME , CM_OUT
}
cam object type More...
typedef enum evxCmObjType evxCmObjType
cam object type

Cam Query Fun

evxErrors | cvxCmInqAl (evxCmObjType type, int *cnt, int **idx_obj)
evxErrors | cvxCmSolidVerify (int *gouge)
evxErrors | cvxCmClashDetect (int partIdx, int stockIdx, int cnt, int *idx_op)
evxErrors | cvxCmGougeDetect (int partIdx, int stockIdx, int cnt, int *idx_op)
evxErrors | cvxCmConfigFileGetString (const char *form, int field, int casesensitive, char *dbstring, char *guistring, int *ifound)
evxErrors | cvxCmInqOpName (int idx_op, vxLongName opName)
evxErrors | cvxCmInqIndexFromName (evxCmObjType objClass, vxLongName sName, int *index)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmClashDetect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmClashDetect()

evxErrors cvxCmClashDetect | ( | int | partIdx,
 |  | int | stockIdx,
 |  | int | cnt,
 |  | int * | idx_op
 | ) |  |

#include <zwapi_cm_query.h>

Detect clash of operations, the operations should have been calculated. If clash happened, corresponding toolpath will change its color.

Parameters
[in] | partIdx | idx of part
[in] | stockIdx | idx of stock
[in] | cnt | number of operations
[in] | idx_op | index list of operations
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETSETUP_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmConfigFileGetString

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmConfigFileGetString()

evxErrors cvxCmConfigFileGetString | ( | const char * | form,
 |  | int | field,
 |  | int | casesensitive,
 |  | char * | dbstring,
 |  | char * | guistring,
 |  | int * | ifound
 | ) |  |

#include <zwapi_cm_query.h>

You can only specify either dbstring or guistring but not both. Whichever one is not specified is returned as output. If the requested string cannot be found then the input string is returned as output.

Parameters
[in] | form | form name
[in] | field | field id number
[in] | casesensitive | case sensitive comparison flag
[in,out] | dbstring | DB string
[in,out] | guistring | GUI string
[out] | ifound | flag to see if item was found
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmGougeDetect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmGougeDetect()

evxErrors cvxCmGougeDetect | ( | int | partIdx,
 |  | int | stockIdx,
 |  | int | cnt,
 |  | int * | idx_op
 | ) |  |

#include <zwapi_cm_query.h>

Detect gouge of operations, the operations should have been calculated. If gouge happened, corresponding toolpath will change its color.

Parameters
[in] | partIdx | idx of part
[in] | stockIdx | idx of stock
[in] | cnt | number of operations
[in] | idx_op | index list of operations
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETSETUP_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmInqAl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmInqAl()

evxErrors cvxCmInqAl | ( | evxCmObjType | type,
 |  | int * | cnt,
 |  | int ** | idx_obj
 | ) |  |

#include <zwapi_cm_query.h>

Inquire the indexes of this type in the active CamPlan.

Parameters
[in] | type | cam object type
[out] | cnt | the amount this type of objects
[out] | idx_obj | the index of the object list, user is response to free this memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETSETUP_ERROR
  • ZW_API_CAM_GETMACH_ERROR
  • ZW_API_CAM_GETFOLDER_ERROR
  • ZW_API_CAM_GETTACTIC_ERROR
  • ZW_API_CAM_GETTOOL_ERROR
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETFTR_ERROR
  • ZW_API_CAM_GETFRAME_ERROR
  • ZW_API_CAM_GETOUT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmInqIndexFromName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmInqIndexFromName()

evxErrors cvxCmInqIndexFromName | ( | evxCmObjType | objClass,
 |  | vxLongName | sName,
 |  | int * | index
 | ) |  |

#include <zwapi_cm_query.h>

Get the object index for the object with the specified name.

Parameters
[in] | objClass | class of object
[in] | sName | name of object
[out] | index | index of object found (or -1 if not found)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETSETUP_ERROR
  • ZW_API_CAM_GETMACH_ERROR
  • ZW_API_CAM_GETOPERATION_ERROR
  • ZW_API_CAM_GETFOLDER_ERROR
  • ZW_API_CAM_GETTACTIC_ERROR
  • ZW_API_CAM_GETTOOL_ERROR
  • ZW_API_CAM_GETCMCOMP_ERROR
  • ZW_API_CAM_GETFTR_ERROR
  • ZW_API_CAM_GETFRAME_ERROR
  • ZW_API_CAM_GETOUT_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmInqOpName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmInqOpName()

evxErrors cvxCmInqOpName | ( | int | idx_op,
 |  | vxLongName | opName
 | ) |  |

#include <zwapi_cm_query.h>

Inquire the name of the operation.

Parameters
[in] | idx_op | index of the operation
[out] | opName | name of the operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSolidVerify

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ cvxCmSolidVerify()

evxErrors cvxCmSolidVerify ( int * gouge )

#include <zwapi_cm_query.h>

Verify all operations. There must be a stock.

Parameters
[out] gouge check gouge value
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Cam Tool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Cam Tool
Cam

Detailed Description

THE MODULE FOR THE API of the Cam Tool.

Cam Tool Data

enum evxCmToolType {
CM_TOOL_TYPE_MILL , CM_TOOL_TYPE_FLAME , CM_TOOL_TYPE_DRILL , CM_TOOL_TYPE_TAP ,
CM_TOOL_TYPE_CENTER , CM_TOOL_TYPE_CHAMFER , CM_TOOL_TYPE_REAM , CM_TOOL_TYPE_BORE
}
cam tool type More...
enum | evxCmToolSubType { CM_TOOL_SUBTYPE_NULL = -1 , CM_TOOL_SUBTYPE_BALLNOSE , CM_TOOL_SUBTYPE_BULLNOSE , CM_TOOL_SUBTYPE_ENDNOSE }
cam tool sub type More...
enum evxCmToolAttr {
CM_TOOL_NAME = 400 , CM_TOOL_TYPE , CM_TOOL_SUBTYPE , CM_TOOL_ID ,
CM_TOOL_LEN , CM_TOOL_CUTTERDIAMETER , CM_TOOL_HOLDER , CM_TOOLCHANGER_LOCATION ,
CM_TOOLCHANGER_DIAMETER , CM_TOOLCHANGER_HEIGHT
}
cam tool attribute More...
typedef enum evxCmToolType | evxCmToolType
cam tool type
typedef enum evxCmToolSubType | evxCmToolSubType
cam tool sub type
typedef enum evxCmToolAttr | evxCmToolAttr
cam tool attribute

Cam Query Fun

evxErrors | cvxCmToolInsert (evxCmToolType tltype, evxCmToolSubType subtype, int *idx_tool)
evxErrors | cvxCmToolInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName tool_name, int *idx_tool)
evxErrors | cvxCmToolDelete (int idx_tool)
evxErrors | cvxCmToolGetAttr (int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmToolSetAttr (int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmHolderInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName holder_name, int *idx_holder)
evxErrors | cvxCmSpeedInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName spdfd_name, int *idx_speed)
evxErrors | cvxCmToolGetData (int idx_tool, evxCmToolAttr attr, char *value)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmHolderInsertAsTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmHolderInsertAsTemplate()

evxErrors cvxCmHolderInsertAsTemplate | ( | const vxLongPath | template_path,
 |  | const vxName | file_name,
 |  | const vxName | library_name,
 |  | const vxName | holder_name,
 |  | int * | idx_holder
 | ) |  |

#include <zwapi_cm_tool.h>

Insert the holder from the library into CamPlan.

Parameters
[in] | template_path | template path
[in] | file_name | file name
[in] | library_name | library name
[in] | holder_name | holder name
[out] | idx_holder | holder index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_GETHOLDER_ERROR
  • ZW_API_CAM_GETVDATA_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmSpeedInsertAsTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmSpeedInsertAsTemplate()

evxErrors cvxCmSpeedInsertAsTemplate | ( | const vxLongPath | template_path,
 |  | const vxName | file_name,
 |  | const vxName | library_name,
 |  | const vxName | spdfd_name,
 |  | int * | idx_speed
 | ) |  |

#include <zwapi_cm_tool.h>

Insert the speed from the library into CamPlan.

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | template_path | template path
[in] | file_name | file name
[in] | library_name | library name
[in] | spdfd_name | speed name
[out] | idx_speed | speed index
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolDelete()

evxErrors cvxCmToolDelete ( int idx_tool )

#include <zwapi_cm_tool.h>

Delete the tool in CamPlan.

Parameters
[in] idx_tool index of the tool
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolGetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolGetAttr()

evxErrors cvxCmToolGetAttr | ( | int | idx_tool,
 |  | evxCmToolAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_tool.h>

Inquire the tool's attribute.

See also
cvxCmToolSetAttr().

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_tool | index of the tool
[in] | attr | enumeration of tool attribute
[out] | value | the values return; user needs to free the memory
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolGetData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolGetData()

evxErrors cvxCmToolGetData | ( | int | idx_tool,
 |  | evxCmToolAttr | attr,
 |  | char * | value
 | ) |  |

#include <zwapi_cm_tool.h>

Inquire the tool's attribute.

Parameters
[in] | idx_tool | index of the tool
[in] | attr | enumeration of tool attribute
[out] | value | value of the attribute, caller should allocate memory
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_GETTOOLNAME_ERROR
  • ZW_API_CAM_GETTOOLTYPE_ERROR
  • ZW_API_CAM_GETTOOLSUBTYPE_ERROR
  • ZW_API_CAM_GETTOOLID_ERROR
  • ZW_API_CAM_GETTOOLLEN_ERROR
  • ZW_API_CAM_GETTOOLDIA_ERROR
  • ZW_API_CAM_GETHOLDER_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolInsert()

evxErrors cvxCmToolInsert | ( | evxCmToolType | tltype,
 |  | evxCmToolSubType | subtype,
 |  | int * | idx_tool
 | ) |  |

#include <zwapi_cm_tool.h>

Insert a tool into active CamPlan.

Parameters
[in] | tltype | tool type
[in] | subtype | sub type of tool
[out] | idx_tool | index of the new tool
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_CAM_FORMDEFINE_ERROR
  • ZW_API_CAM_UPVADTA_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_CAM_GETFORMITEM_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolInsertAsTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolInsertAsTemplate()

evxErrors cvxCmToolInsertAsTemplate | ( | const vxLongPath | template_path,
 |  | const vxName | file_name,
 |  | const vxName | library_name,
 |  | const vxName | tool_name,
 |  | int * | idx_tool
 | ) |  |

#include <zwapi_cm_tool.h>

Insert the tool from the library into CamPlan.

Parameters
[in] | template_path | template path
[in] | file_name | file name
[in] | library_name | library name
[in] | tool_name | tool name
[out] | idx_tool | tool index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CAM_GETFORMITEM_ERROR
  • ZW_API_CAM_SETFORMITEM_ERROR
  • ZW_API_CAM_GETFORMSTATE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmToolSetAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ cvxCmToolSetAttr()

evxErrors cvxCmToolSetAttr | ( | int | idx_tool,
 |  | evxCmToolAttr | attr,
 |  | svxCmAttrValue * | value
 | ) |  |

#include <zwapi_cm_tool.h>

Set the tool's attribute. "attr" can't be CM_TOOL_TYPE or CM_TOOL_SUBTYPE. While "attr" is CM_TOOL_HOLDER, holder (depends on its name) is from active CAM plan or current Library or default Library in proper older.

"value->type"                 &     "value->cnt" depends on "attr", as follows:
ZW_CAM_ATTR_VALUE_TYPE_STRING       <=32     CM_TOOL_NAME
                                             CM_TOOL_ID
                                             CM_TOOL_HOLDER
ZW_CAM_ATTR_VALUE_TYPE_DOUBLE       1        CM_TOOL_LEN
                                             CM_TOOL_CUTTERDIAMETER
ZW_CAM_ATTR_VALUE_TYPE_INTEGER      1        CM_TOOLCHANGER_LOCATION
                                             CM_TOOLCHANGER_DIAMETER
                                             CM_TOOLCHANGER_HEIGHT

The following is a simple code to set tool name and length:

void TestApi(void)
{
svxCmAttrValue attr;
int index=-1;
char toolName[32]={"MillTool"};
double toolLen=99.0;
cvxCmToolInsert(CM_TOOL_TYPE_MILL, CM_TOOL_SUBTYPE_ENDNOSE, &index);
if (index < 0) return;
attr.type = ZW_CAM_ATTR_VALUE_TYPE_STRING;
attr.cnt = 32;
attr.data = (void *)toolName;
cvxCmToolSetAttr(index, CM_TOOL_NAME, &attr);
attr.type = ZW_CAM_ATTR_VALUE_TYPE_DOUBLE;
attr.cnt = 1;
attr.data = (void *)&toolLen;
cvxCmToolSetAttr(index, CM_TOOL_LEN, &attr);
return;
}
CM_TOOL_TYPE_MILL
@ CM_TOOL_TYPE_MILL
mill
Definition: zwapi_cm_tool.h:32
CM_TOOL_LEN
@ CM_TOOL_LEN
tool_length
Definition: zwapi_cm_tool.h:64
CM_TOOL_NAME
@ CM_TOOL_NAME
tool name
Definition: zwapi_cm_tool.h:60
cvxCmToolSetAttr
evxErrors cvxCmToolSetAttr(int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
CM_TOOL_SUBTYPE_ENDNOSE
@ CM_TOOL_SUBTYPE_ENDNOSE
end
Definition: zwapi_cm_tool.h:51
cvxCmToolInsert
evxErrors cvxCmToolInsert(evxCmToolType tltype, evxCmToolSubType subtype, int *idx_tool)
svxCmAttrValue::cnt
int cnt
count of data
Definition: zwapi_util.h:2516
svxCmAttrValue::data
void * data
user is response to free this memory
Definition: zwapi_util.h:2517
svxCmAttrValue::type
evxCmAttrValueType type
cam data attribute type
Definition: zwapi_util.h:2515
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514

Returns ZW_API_NO_ERROR if it succeeds; the other value of evxErrors if function fails.

Parameters
[in] | idx_tool | index of the tool
[in] | attr | enumeration of tool attribute
[in] | value | the values needed
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Brep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Brep

Detailed Description

Modules

Brep Data
Edge API
Face API
Loop API
Preedge API
Shape API
Vertex API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Brep Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Brep Data
Brep

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Brep objects.

Entity

enum | evxEdgeType { VX_EDGE_UNKNOWN = -1 , VX_EDGE_STANDARD = 0 , VX_EDGE_SEAM = 1 , VX_EDGE_DEGEN = 2 }
type of edge More...
typedef enum evxEdgeType | evxEdgeType
type of edge

pre-edge Query Data

typedef struct svxPreEdge | svxPreEdge
pre-edge information
typedef struct svxMassProp | svxMassProp
mass attributes
typedef struct svxWeldAttr | svxWeldAttr
weldment attribute
typedef struct svxEvalSurf | svxEvalSurf
surface evaluate
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Edge API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Edge API
Brep

Detailed Description

THE MODULE FOR THE ZW3D Edge API

Edge Query

int | cvxPartInqEdgeOpen (int idEdge)
evxErrors | cvxPartInqEdgeType (int idEdge, evxEdgeType *EdgeType)
evxErrors | cvxPartInqEdgeFaces (int idEdge, int *Count, int **Faces)
evxErrors | cvxPartInqEdgePreEdges (int idEdge, int *Count, int **PreEdges)
evxErrors | cvxPartInqEdgeLoop (int idFace, int idEdge, int *idLoop)
evxErrors | cvxPartInqEdgeShape (int idEdge, int *idShape)
evxErrors | cvxPartInqEdgeCrv (int idEdge, int idFace, svxCurve *Crv)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeCrv()

evxErrors cvxPartInqEdgeCrv | ( | int | idEdge,
 |  | int | idFace,
 |  | svxCurve * | Crv
 | ) |  |

#include <zwapi_brep_edge.h>

Outputs the NURBS curve geometry of the specified edge in the active part.

If "idFace <= 0", the 3D definition of the edge is output.

If "idFace > 0", the UV definition of the edge corresponding to the specified face or loop is output.

The calling procedure is responsible for deallocating the memory assigned by this function to the "Crv" structure using cvxCurveFree().

The direction of UV curves output by this function follow the direction of their parent loops. 3D curves are not given a specific orientation.

Outer loops proceed counterclockwise relative to the natural normal of the parent surface. Inner loops are clockwise.

It is assumed the specified edge (idEdge) resides in the active part.

Note
cvxCurveFree() can use to free Crv.
Parameters
[in] | idEdge | edge id
[in] | idFace | optional face or loop id for retrieving UV geometry (else 0)
[out] | Crv | edge's curve geometry
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeFaces()

evxErrors cvxPartInqEdgeFaces | ( | int | idEdge,
 |  | int * | Count,
 |  | int ** | Faces
 | ) |  |

#include <zwapi_brep_edge.h>

Outputs a list of indices of the faces connected to an edge in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idEdge | edge id
[out] | Count | number of faces
[out] | Faces | list of face id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeLoop

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeLoop()

evxErrors cvxPartInqEdgeLoop | ( | int | idFace,
 |  | int | idEdge,
 |  | int * | idLoop
 | ) |  |

#include <zwapi_brep_edge.h>

Get the id of the parent loop of the specified edge on the specified face.

Parameters
[in] | idFace | face id
[in] | idEdge | edge id
[out] | idLoop | loop id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeOpen()

int cvxPartInqEdgeOpen ( int idEdge )

#include <zwapi_brep_edge.h>

Check if the specified edge is an open edge.

Parameters
[in] idEdge edge id (in active file)
Return values
return
  • 0: the specified edge is not an open edge
  • 1: the specified edge is an open edge
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgePreEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgePreEdges()

evxErrors cvxPartInqEdgePreEdges | ( | int | idEdge,
 |  | int * | Count,
 |  | int ** | PreEdges
 | ) |  |

#include <zwapi_brep_edge.h>

Gets a list of the pre-edges associated with the specified edge. Memory for the list is allocated by this function and must be freed by the calling procedure.

Parameters
[in] | idEdge | edge id
[out] | Count | number of pre-edges associated with the specified edge
[out] | PreEdges | list of pre-edges associated with the specified edge
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeShape()

evxErrors cvxPartInqEdgeShape | ( | int | idEdge,
 |  | int * | idShape
 | ) |  |

#include <zwapi_brep_edge.h>

Outputs the shape connected to an edge in the active file.

Parameters
[in] | idEdge | index of edge
[out] | idShape | index of shape
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEdgeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Edge API
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ cvxPartInqEdgeType()

evxErrors cvxPartInqEdgeType | ( | int | idEdge,
 |  | evxEdgeType * | EdgeType
 | ) |  |

#include <zwapi_brep_edge.h>

Gets the type of specified edge.

Parameters
[in] | idEdge | edge id (in active file)
[out] | EdgeType | edge type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Face API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Face API
Brep

Detailed Description

THE MODULE FOR THE ZW3D Face API

Face Attribute

evxErrors | cvxPartInqFaceAt (int idFace, svxFaceAt *At)
evxErrors | cvxPartInqFaceSh (int idFace, svxShaderAt *Sh)
evxErrors | cvxPartInqFaceTx (int idFace, svxTextureAt *Tx)
evxErrors | cvxFaceGetArea (const int faceId, const double tolerance, double *area)
evxErrors | cvxFaceGetMaxCurvature (const int faceId, const svxPoint2 uvPoint, svxPoint *point, svxPoint *normal, svxPoint *direction, double *minCurvature, double *maxCurvature, double *curvature, svxPoint *curvatureDirection, svxPoint *curvatureCenter)
evxErrors | cvxPartSetFaceAtInit (svxFaceAt *data)
evxErrors | cvxPartSetFaceAt (int Count, int *idFaces, const svxFaceAt *At)
evxErrors | cvxPartSetFaceTx (int idFace, const svxTextureAt *Tx)
evxErrors | cvxPartDelFaceTx (int Count, const int *idFaces)

Face Query

evxErrors | cvxPartInqFaceTxFile (int idFace, vxPath Path)
evxErrors | cvxPartInqFaceTxFileByLongPath (int idFace, char *Path, int sizePath)
evxErrors | cvxPartInqFaceBox (int idFace, svxBndBox *Box)
evxErrors | cvxPartInqFaceCrvs (int idFace, int *Count, svxCurve **TrimCurves)
evxErrors | cvxPartInqFaceEdges (int idFace, int *Count, int **Edges)
evxErrors | cvxPartInqFaceLoops (int idFace, int Inner, int *Count, int **Loops)
evxErrors | cvxPartInqFaceSrf (int idFace, svxSurface *Srf)
void | cvxSurfaceFree (svxSurface *Srf)
evxErrors | cvxPartInqFaceSrfPrim (int idFace, svxSrfPrim *SrfPrim)
void | cvxSrfPrimFree (svxSrfPrim *SrfPrim)
evxErrors | cvxPartInqFaceShape (int idFace, int *idShape)
evxErrors | cvxPartInqFaceGeom (int idFace, int *idGeom)
evxErrors | cvxPartInqFaceFillet (int idFace, int *isFilletFace)
evxErrors | cvxFaceRadius (int idFace, double *Radius)
evxErrors | cvxFaceInqBend (int idFace, int *bendFlag, double *bendRad, double *neutralRad, double *angle, double *thick, double *kFactor, double *flatTol)
int | cvxFaceIsConcave (int idFace)
int | cvxFaceIsPlanar (int idFace)
evxErrors | cvxFaceInqExtreme (int idFace, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)

Face Eval

evxErrors | cvxFaceEval (int idFace, double U, double V, svxPoint *Point, svxVector *Normal)
evxErrors | cvxFaceEval2 (int idFace, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
evxErrors | cvxFaceParam (int idFace, svxLimit *U, svxLimit *V)
evxErrors | cvxFacePntLoc (int idFace, double U, double V, evxPntLocation *Loc)
evxErrors | cvxFacePntProj (int idFace, svxPoint *Point, double *U, double *V)
evxErrors | cvxFaceRadialIntegrity (int idFace, double *URatio, double *VRatio)
evxErrors | cvxFaceEvalGeom (int idFace, double U, double V, int Level, svxEvalSurf *EvalSrf)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceEval()

evxErrors cvxFaceEval | ( | int | idFace,
 |  | double | U,
 |  | double | V,
 |  | svxPoint * | Point,
 |  | svxVector * | Normal
 | ) |  |

#include <zwapi_brep_face.h>

Evaluates the NURBS representation of the face entity specified by "idFace". Outputs the 3D point coordinates (Point) and normal direction (Normal) at the specified U,V location on the surface. Use cvxFaceParam() to get the face's parameter limits.

Note
The direction of "Normal" is set to reflect the outward normal of the face, where "outward" means the direction that points towards the outside of the shape that the face is associated with. This may be opposite the natural normal of the NURBS surface associated with the face.
If you want the natural normal of the NURBS surface associated with the face, call cvxPartInqFaceSrf() to get the "Srf", and if Srf->OutNormal= 0, call cvxVecReverse() to reverse the "Normal".
Parameters
[in] | idFace | face entity id
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[out] | Point | point on face (input NULL to ignore)
[out] | Normal | normal at point on face (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceEval2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceEval2()

evxErrors cvxFaceEval2 | ( | int | idFace,
 |  | double | U,
 |  | double | V,
 |  | svxPoint * | Point,
 |  | svxVector * | Normal,
 |  | svxVector * | Utan,
 |  | svxVector * | Vtan
 | ) |  |

#include <zwapi_brep_face.h>

Evaluates the NURBS representation of the face entity specified by "idFace". Outputs the 3D point coordinates (Point), normal direction (Normal) and UV tangent directions at the specified U,V location on the surface. Use cvxFaceParam() to get the face's parameter limits.

Note
The direction of "Normal" is set to reflect the outward normal of the face, where "outward" means the direction that points towards the outside of the shape that the face is associated with. This may be opposite the natural normal of the NURBS surface associated with the face.
If you want the natural normal of the NURBS surface associated with the face, call cvxPartInqFaceSrf() to get the "Srf", and if Srf->OutNormal= 0, call cvxVecReverse() to reverse the "Normal".
Parameters
[in] | idFace | face entity id
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[out] | Point | point on face (input NULL to ignore)
[out] | Normal | normal at point on face (input NULL to ignore)
[out] | Utan | U tangent direction (input NULL to ignore)
[out] | Vtan | V tangent direction (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceEvalGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceEvalGeom()

evxErrors cvxFaceEvalGeom | ( | int | idFace,
 |  | double | U,
 |  | double | V,
 |  | int | Level,
 |  | svxEvalSurf * | EvalSrf
 | ) |  |

#include <zwapi_brep_face.h>

Evaluates the NURBS representation of the face entity specified by "idFace". Use cvxFaceParam() to get the face's parameter limits.

"Level" specifies the level of evaluation. The higher the level, more data gets returned (at the expense of greater computation).

                      level
     |  0  |     1     |     2      |      3      |       4
     +-----+-----------+------------+-------------+-------------
     | pnt |  normal   | partial_uu | partial_uuu   partial_uuuu
             partial_u   partial_uv   partial_vuu   partial_vuuu
             partial_v   partial_vv   partial_uvv   partial_uuvv
                                      partial_vvv   partial_uvvv
                                                    partial_vvvv
Note
The direction of normal is set to reflect the outward normal of the face, where "outward" means the direction that points towards the outside of the shape that the face is associated with. This may be opposite the natural normal of the NURBS surface associated with the face.
Parameters
[in] | idFace | face entity id
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[in] | Level | level of evaluation(0 ~ 4). See description below
[out] | EvalSrf | Result
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceGetArea

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceGetArea()

evxErrors cvxFaceGetArea | ( | const int | faceId,
 |  | const double | tolerance,
 |  | double * | area
 | ) |  |

#include <zwapi_brep_face.h>

Get the face area of the face which id is "faceId" in the db.

Parameters
[in] | faceId | The face id in the db
[in] | tolerance | The tolerance
[out] | area | The area of the face to return
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceGetMaxCurvature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceGetMaxCurvature()

evxErrors cvxFaceGetMaxCurvature | ( | const int | faceId,
 |  | const svxPoint2 | uvPoint,
 |  | svxPoint * | point,
 |  | svxPoint * | normal,
 |  | svxPoint * | direction,
 |  | double * | minCurvature,
 |  | double * | maxCurvature,
 |  | double * | curvature,
 |  | svxPoint * | curvatureDirection,
 |  | svxPoint * | curvatureCenter
 | ) |  |

#include <zwapi_brep_face.h>

Evaluate curvature information on a surface at a specified uv location in the maximum curvature direction.

Parameters
[in] | faceId | face Id in the db
[in] | uvPoint | U,V coordinate to evaluate
[out] | point | 3D point on surface at the uv location (NULL to ignore)
[out] | normal | Surface normal at UV location (NULL to ignore)
[out] | direction | Surface direction(NULL to ignore)
[out] | minCurvature | minimum curvature at the uv location (NULL to ignore)
[out] | maxCurvature | maximum curvature at the uv location (NULL to ignore)
[out] | curvature | curvature (NULL to ignore)
[out] | curvatureDirection | curvature direction vector (NULL to ignore)
[out] | curvatureCenter | curvature center (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceInqBend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceInqBend()

evxErrors cvxFaceInqBend | ( | int | idFace,
 |  | int * | bendFlag,
 |  | double * | bendRad,
 |  | double * | neutralRad,
 |  | double * | angle,
 |  | double * | thick,
 |  | double * | kFactor,
 |  | double * | flatTol
 | ) |  |

#include <zwapi_brep_face.h>

Get bend information of specified face.

Parameters
[in] | idFace | index of face
[out] | bendFlag | whether the face is a bending surface (1 to yes; 0 to no)
[out] | bendRad | bend radius (NULL to ignore)
[out] | neutralRad | neutral radius (NULL to ignore)
[out] | angle | bend angle (NULL to ignore)
[out] | thick | thickness (NULL to ignore)
[out] | kFactor | K-factor (NULL to ignore)
[out] | flatTol | flat tolerance (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceInqExtreme

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceInqExtreme()

evxErrors cvxFaceInqExtreme | ( | int | idFace,
 |  | const svxVector * | Dir,
 |  | int * | Count,
 |  | int ** | idEnts,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_brep_face.h>

Gets the extreme point of face in the specified direction, if the farthest end of the specified direction are face or edges, the function also outputs the list of face or edges, in this case, the extreme point output is only any point on a face or edge.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFace | id of face in active part
[in] | Dir | direction
[out] | Count | number of face or edges (NULL to ignore)
[out] | idEnts | list of face or edges (NULL to ignore)
[out] | Point | extreme point (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceIsConcave

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceIsConcave()

int cvxFaceIsConcave ( int idFace )

#include <zwapi_brep_face.h>

Check if the specified face is a concave or convex face. the function is only applicable to a small subset of surfaces are universally convex or concave, such as surfaces approximating cylinders and cones and spheres.

Parameters
[in] idFace index of face
Return values
return
  • 0: the specified face is a convex face
  • 1: the specified face is a concave face
  • -1: the id is not a face or function fails
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceIsPlanar

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceIsPlanar()

int cvxFaceIsPlanar ( int idFace )

#include <zwapi_brep_face.h>

Check if the specified face is real planar face.

Note
The face of the VX_SRF_GEN type may also be a planar face.
Parameters
[in] idFace index of face
Return values
return
  • 0: the specified face is not planar or error occurs
  • 1: the specified face is planar
Warning
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceParam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceParam()

evxErrors cvxFaceParam | ( | int | idFace,
 |  | svxLimit * | U,
 |  | svxLimit * | V
 | ) |  |

#include <zwapi_brep_face.h>

Outputs the minimum and maximum parameter values of the NURBS representation of the specified face entity.

Parameters
[in] | idFace | face entity id
[out] | U | min/max U values
[out] | V | min/max V values
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFacePntLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFacePntLoc()

evxErrors cvxFacePntLoc | ( | int | idFace,
 |  | double | U,
 |  | double | V,
 |  | evxPntLocation * | Loc
 | ) |  |

#include <zwapi_brep_face.h>

Determines the location of the specified point on the specified face relative to the face's trim boundaries.

Parameters
[in] | idFace | face entity id
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[out] | Loc | point location relative to face boundaries
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFacePntProj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFacePntProj()

evxErrors cvxFacePntProj | ( | int | idFace,
 |  | svxPoint * | Point,
 |  | double * | U,
 |  | double * | V
 | ) |  |

#include <zwapi_brep_face.h>

Outputs the UV coordinates of the projection of the input XYX point onto the NURBS representation of the specified face. It is assumed that "Point" lies on or very close to the face.

Parameters
[in] | idFace | face entity id
[in] | Point | XYZ point on/near face
[out] | U | U coordinate of point-on-face
[out] | V | V coordinate of point-on-face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceRadialIntegrity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceRadialIntegrity()

evxErrors cvxFaceRadialIntegrity | ( | int | idFace,
 |  | double * | URatio,
 |  | double * | VRatio
 | ) |  |

#include <zwapi_brep_face.h>

Get radial integrity ratio value of specified surface. the ratio value is set to 0.0 when it is invalid, and then function is only applicable to cylinder, cone and torus.

Parameters
[in] | idFace | face entity id
[out] | URatio | radial integrity ratio value in U
[out] | VRatio | radial integrity ratio value in V
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxFaceRadius()

evxErrors cvxFaceRadius | ( | int | idFace,
 |  | double * | Radius
 | ) |  |

#include <zwapi_brep_face.h>

Get the radius of specified face, only revolved surfaces (cylinder and sphere) are valid.

Parameters
[in] | idFace | face entity id
[out] | Radius | radius
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDelFaceTx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartDelFaceTx()

evxErrors cvxPartDelFaceTx | ( | int | Count,
 |  | const int * | idFaces
 | ) |  |

#include <zwapi_brep_face.h>

Remove a texture or a texture map previously assigned to the specified shape or the specified face. it is assumed the specified face or shape (idFace) resides in the active part.

Parameters
[in] | Count | number of faces (or shapes)
[in] | idFaces | list of face or shape id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceAt()

evxErrors cvxPartInqFaceAt | ( | int | idFace,
 |  | svxFaceAt * | At
 | ) |  |

#include <zwapi_brep_face.h>

Outputs display attributes of the specified face or shape. Attributes for a shape are grabbed from the first face in the shape.

It is assumed the specified face or shape (idFace) resides in the active part.

Parameters
[in] | idFace | face or shape id
[out] | At | face/shape display attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceBox()

evxErrors cvxPartInqFaceBox | ( | int | idFace,
 |  | svxBndBox * | Box
 | ) |  |

#include <zwapi_brep_face.h>

Gets the bounding box of the specified face in the active file.

See also
cvxPartInqEntBox,cvxPartInqShapeBox,cvxEntBndBox. The three interfaces have similar functions.
Parameters
[in] | idFace | face id
[out] | Box | face bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceCrvs()

evxErrors cvxPartInqFaceCrvs | ( | int | idFace,
 |  | int * | Count,
 |  | svxCurve ** | TrimCurves
 | ) |  |

#include <zwapi_brep_face.h>

Outputs a list of the trim curves that bound a face in the active part. The calling application must sort these curves into inner and outer loops as desired. To get the them in sorted order, you must traverse the face and its loops using cvxPartInqFaceLoops(), cvxPartInqLoopEdges() and cvxPartInqEdgeCrv().

The calling procedure MUST deallocate the internal data in each element of the output list by calling cvxCurveFree(), after which the output list MUST be deallocated using cvxMemFree((void**)TrimCurves).

Parameters
[in] | idFace | face id
[out] | Count | number of trim curves
[out] | TrimCurves | list of trim curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceEdges()

evxErrors cvxPartInqFaceEdges | ( | int | idFace,
 |  | int * | Count,
 |  | int ** | Edges
 | ) |  |

#include <zwapi_brep_face.h>

Outputs a list of indices of the edges that bound a face in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFace | face id
[out] | Count | number of edges
[out] | Edges | list of edge id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceFillet()

evxErrors cvxPartInqFaceFillet | ( | int | idFace,
 |  | int * | isFilletFace
 | ) |  |

#include <zwapi_brep_face.h>

Get the flag indicating if the specified face is a fillet face.

Parameters
[in] | idFace | face id
[out] | isFilletFace | fillet flag (1 is fillet face, else is 0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceGeom()

evxErrors cvxPartInqFaceGeom | ( | int | idFace,
 |  | int * | idGeom
 | ) |  |

#include <zwapi_brep_face.h>

Outputs the face's geometry index.

Parameters
[in] | idFace | face id
[out] | idGeom | geometry index of the face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceLoops

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceLoops()

evxErrors cvxPartInqFaceLoops | ( | int | idFace,
 |  | int | Inner,
 |  | int * | Count,
 |  | int ** | Loops
 | ) |  |

#include <zwapi_brep_face.h>

Outputs a list of indices of the loops (outer and inner) that belong to a face in the active file.

Outer loops proceed counterclockwise relative to the natural normal of the parent surface. Inner loops are clockwise.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFace | face id
[in] | Inner | 1 to include inner loops; 0 for just the outer loops
[out] | Count | number of loops
[out] | Loops | list of loop id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceSh

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceSh()

evxErrors cvxPartInqFaceSh | ( | int | idFace,
 |  | svxShaderAt * | Sh
 | ) |  |

#include <zwapi_brep_face.h>

Outputs shader attributes of the specified face. "Sh->name[0]" is set to "0" (i.e. empty string) if no shader is defined for the face.

//Checkerboard Shader:
Sh->name = "Checker"
Sh->color[0] = first checkerboard square color
Sh->color[1] = second checkerboard square color
Sh->param[0] = scale factor for checkerboard squares
//Chrome Shader:
Sh->name = "Chrome"
Sh->image = optional image file reflected on chrome finish
Sh->param[0] = reflectance (0.0 - 1.0)
//Granite Shader:
Sh->name = "Granite"
Sh->param[0] = scale factor (0.0 - 2.0)
Sh->param[1] = noise (0.0 - 10.0)
//Marble Shader:
Sh->name = "Marble"
Sh->color[0] = marble base color
Sh->color[1] = marble vein color
Sh->param[0] = scale factor (0.0 - 200.0)
//Wood Shader:
Sh->name = "Wood"
Sh->color[0] = light wood color
Sh->color[1] = dark wood color
Sh->param[0] = frequency of wood rings (0.0 - 10.0)
Sh->param[1] = overall noisiness of wood grain (0.0 - 6.0)
Sh->param[2] = noise in X direction (0.0 - 1.0)
Sh->param[3] = noise in Y direction (0.0 - 1.0)
Sh->param[4] = noise in Z direction (0.0 - 1.0)
Sh->param[5] = scale factor (0.0 - 4.0)

It is assumed the specified face (idFace) resides in the active part.

Parameters
[in] | idFace | face id
[out] | Sh | face shader attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceShape()

evxErrors cvxPartInqFaceShape | ( | int | idFace,
 |  | int * | idShape
 | ) |  |

#include <zwapi_brep_face.h>

Gets the id of the specified face's parent shape (within the active file).

Parameters
[in] | idFace | face id
[out] | idShape | id face's parent shape
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceSrf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceSrf()

evxErrors cvxPartInqFaceSrf | ( | int | idFace,
 |  | svxSurface * | Srf
 | ) |  |

#include <zwapi_brep_face.h>

Outputs the untrimmed NURBS surface geometry of the specified face. The calling procedure is responsible for deallocating the memory assigned by this function to the "Srf" structure using cvxSurfaceFree().

It is assumed the specified face (idFace) resides in the active part.

Parameters
[in] | idFace | face id
[out] | Srf | face's untrimmed NURBS surface geometry
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceSrfPrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceSrfPrim()

evxErrors cvxPartInqFaceSrfPrim | ( | int | idFace,
 |  | svxSrfPrim * | SrfPrim
 | ) |  |

#include <zwapi_brep_face.h>

Gets surface geometry for the specified face entity. It is assumed the specified face (idFace) resides in the active part.

The calling procedure is responsible for deallocating the memory assigned by this function to the "SrfPrim" structure using cvxSurfaceFree(&SrfPrim->srfData.srf) when SrfPrim->srfType = VX_SF_PRIM_NURB.

Parameters
[in] | idFace | face id
[out] | SrfPrim | face's untrimmed NURBS surface geometry
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MODELIG_DATA_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceTx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceTx()

evxErrors cvxPartInqFaceTx | ( | int | idFace,
 |  | svxTextureAt * | Tx
 | ) |  |

#include <zwapi_brep_face.h>

Outputs texture attributes of the specified face.

If a texture image file is embedded in a Z3 file, it is automatically extracted to a "temp" sub-folder in the Z3 runtime folder. The path the temp file is output via "Tx->file".

It is assumed the specified face (idFace) resides in the active part.

See also
cvxPartInqFaceTxFile().
Parameters
[in] | idFace | face id
[out] | Tx | face texture attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceTxFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceTxFile()

evxErrors cvxPartInqFaceTxFile | ( | int | idFace,
 |  | vxPath | Path
 | ) |  |

#include <zwapi_brep_face.h>

Outputs path to the original image file if a texture map has been applied to a face. Unlike cvxPartInqFaceTx(), which may output the path to a copy of the original image file that ZW3D has put in its temp directory, this function outputs the path that was originally used to create the texture map. The file might no longer exist, although the image may still exist as an embedded object.

It is assumed the specified face (idFace) resides in the active part.

ZW3D's native texture map command (!CdTMap) does not save the path to the original image file when a texture map is applied to a face with the embed option selected. For faces that have been assigned a texture map using the texture map command rather than the cvxPartSetFaceTx() function, this function outputs the path that the texture map command saves with the face, which will be the path to a copy of the image file in ZW3D's temp directory.

See also
cvxPartInqFaceTx() for a function that outputs all texture map attributes.
Parameters
[in] | idFace | face id
[out] | Path | path to texture map's original image file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqFaceTxFileByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartInqFaceTxFileByLongPath()

evxErrors cvxPartInqFaceTxFileByLongPath | ( | int | idFace,
 |  | char * | Path,
 |  | int | sizePath
 | ) |  |

#include <zwapi_brep_face.h>

Outputs path to the original image file if a texture map has been
applied to a face. Unlike cvxPartInqFaceTx(), which may output the
path to a copy of the original image file that ZW3D has put in its
temp directory, this function outputs the path that was originally
used to create the texture map. The file might no longer exist,
although the image may still exist as an embedded object.

It is assumed the specified face (idFace) resides in the active part.

ZW3D's native texture map command (!CdTMap) does not save the path to
the original image file when a texture map is applied to a face with
the embed option selected. For faces that have been assigned a
texture map using the texture map command rather than the
cvxPartSetFaceTx() function, this function outputs the path that the
texture map command saves with the face, which will be the path to a
copy of the image file in ZW3D's temp directory.

A Path that is too long (longer than "sizePath") is truncated.

It is assumed that the input "Path" is no longer than 512 bytes.

See also
cvxPartInqFaceTx() for a function that outputs all texture map attributes.
cvxPartInqFaceTxFile()
Parameters
[in] | idFace | face id
[out] | Path | path to texture map's original image file
[in] | sizePath | max size of Path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSetFaceAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartSetFaceAt()

evxErrors cvxPartSetFaceAt | ( | int | Count,
 |  | int * | idFaces,
 |  | const svxFaceAt * | At
 | ) |  |

#include <zwapi_brep_face.h>

Changes display attributes of the specified faces or shapes. It is assumed the specified faces or shapes reside in the active part.

Note
Interface cvxPartSetFaceAtInit() can initialize variables of this function.
Parameters
[in] | Count | number of faces (or shapes)
[in] | idFaces | list of face or shape id's
[in] | At | face display attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSetFaceAtInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartSetFaceAtInit()

evxErrors cvxPartSetFaceAtInit ( svxFaceAt * data )

#include <zwapi_brep_face.h>

Initialize the parameters of the cvxPartSetFaceAt().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data face display attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSetFaceTx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxPartSetFaceTx()

evxErrors cvxPartSetFaceTx | ( | int | idFace,
 |  | const svxTextureAt * | Tx
 | ) |  |

#include <zwapi_brep_face.h>

Set texture attributes of the specified face.

It is assumed the specified face (idFace) resides in the active part. The 'opt' field of svxTextureAt structure is not supported now.

Parameters
[in] | idFace | face id
[in] | Tx | face texture attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfPrimFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxSrfPrimFree()

void cvxSrfPrimFree ( svxSrfPrim * SrfPrim )

#include <zwapi_brep_face.h>

Frees memory associated with the specified svxSrfPrim structure.

Parameters
[in] SrfPrim surface structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxSurfaceFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Face API
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ cvxSurfaceFree()

void cvxSurfaceFree ( svxSurface * Srf )

#include <zwapi_brep_face.h>

Frees memory associated with the specified surface structure.

Parameters
[in] Srf NURB surface structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Loop API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Loop API
Brep

Detailed Description

THE MODULE FOR THE ZW3D Loop API

Loop query

evxErrors | cvxPartInqLoopEdges (int idLoop, int *Count, int **Edges)
evxErrors | cvxPartInqLoopFace (int idLoop, int *idFace)
evxErrors | cvxPartInqLoopPreEdges (int idLoop, int *Count, int **PreEdges)
evxErrors | cvxPartInqLoopInner (int idLoop, int *isInner)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqLoopEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Loop API
cvxPartInqLoopEdges
cvxPartInqLoopFace
cvxPartInqLoopInner
cvxPartInqLoopPreEdges

◆ cvxPartInqLoopEdges()

evxErrors cvxPartInqLoopEdges | ( | int | idLoop,
 |  | int * | Count,
 |  | int ** | Edges
 | ) |  |

#include <zwapi_brep_loop.h>

Outputs a list of indices of the edges that belong to a loop on a face in the active file. Edges are output in the order they occur in the loop.

The calling procedure MUST deallocate the output list with cvxMemFree().

Outer loops proceed counterclockwise relative to the natural normal of the parent surface. Inner loops are clockwise relative to the natural surface normal.

Parameters
[in] | idLoop | loop id
[out] | Count | number of edges
[out] | Edges | list of edge id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqLoopFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Loop API
cvxPartInqLoopEdges
cvxPartInqLoopFace
cvxPartInqLoopInner
cvxPartInqLoopPreEdges

◆ cvxPartInqLoopFace()

evxErrors cvxPartInqLoopFace | ( | int | idLoop,
 |  | int * | idFace
 | ) |  |

#include <zwapi_brep_loop.h>

Outputs the id of the parent face of the specified loop within the active file.

Parameters
[in] | idLoop | loop id
[out] | idFace | id of loop's parent face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqLoopInner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Loop API
cvxPartInqLoopEdges
cvxPartInqLoopFace
cvxPartInqLoopInner
cvxPartInqLoopPreEdges

◆ cvxPartInqLoopInner()

evxErrors cvxPartInqLoopInner | ( | int | idLoop,
 |  | int * | isInner
 | ) |  |

#include <zwapi_brep_loop.h>

Determine whether a given loop is an outer or inner loop.

Parameters
[in] | idLoop | loop id
[out] | isInner | inner loop flag (1=inner, 0=outer)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqLoopPreEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Loop API
cvxPartInqLoopEdges
cvxPartInqLoopFace
cvxPartInqLoopInner
cvxPartInqLoopPreEdges

◆ cvxPartInqLoopPreEdges()

evxErrors cvxPartInqLoopPreEdges | ( | int | idLoop,
 |  | int * | Count,
 |  | int ** | PreEdges
 | ) |  |

#include <zwapi_brep_loop.h>

Outputs a list of indices of the PreEdges that belong to a loop on a face in the active file. PreEdges are output in the order they occur in the loop.

The calling procedure MUST deallocate the output list with cvxMemFree().

Outer loops proceed counterclockwise relative to the natural normal of the parent surface. Inner loops are clockwise relative to the natural surface normal.

Parameters
[in] | idLoop | loop id
[out] | Count | number of PreEdges
[out] | PreEdges | list of PreEdge id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Preedge API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Preedge API
Brep

Detailed Description

THE MODULE FOR THE ZW3D pre-edge API

pre-edge Query

evxErrors | cvxPartInqPreEdgeInfo (int idPreEdge, svxPreEdge *PreEdge)
evxErrors | cvxPartInqPreEdgeStartPnt (int idPreEdge, int *idEdge, svxPoint2 *StartPnt)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPreEdgeInfo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Preedge API
cvxPartInqPreEdgeInfo
cvxPartInqPreEdgeStartPnt

◆ cvxPartInqPreEdgeInfo()

evxErrors cvxPartInqPreEdgeInfo | ( | int | idPreEdge,
 |  | svxPreEdge * | PreEdge
 | ) |  |

#include <zwapi_brep_preedge.h>

Outputs information about the specified PreEdge (idPreEdge) to the structure referenced by the input pointer (PreEdge).

Parameters
[in] | idPreEdge | id of PreEdge within a loop on a face in the active part
[out] | PreEdge | information about the PreEdge
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqPreEdgeStartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Preedge API
cvxPartInqPreEdgeInfo
cvxPartInqPreEdgeStartPnt

◆ cvxPartInqPreEdgeStartPnt()

evxErrors cvxPartInqPreEdgeStartPnt | ( | int | idPreEdge,
 |  | int * | idEdge,
 |  | svxPoint2 * | StartPnt
 | ) |  |

#include <zwapi_brep_preedge.h>

Gets the coordinates of the specified PreEdge's start point relative to its parent loop direction. Also, outputs the id of the PreEdge's parent edge.

Parameters
[in] | idPreEdge | id of PreEdge within a loop on a face
[out] | idEdge | id of PreEdge's parent edge
[out] | StartPnt | coordinates of PreEdge start point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Shape API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Shape API
Brep

Detailed Description

THE MODULE FOR THE ZW3D Shape API

Shape Attribute

evxErrors | cvxShellAtGet (int idShape, svxPartAttribute *At)
evxErrors | cvxShellAtItemGet (int idShape, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxShellAtItemSet (int idShape, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartInqShapeOpen (int idShape, int *isOpen)
evxErrors | cvxPartInqShapeBox (int idShape, svxMatrix *Mat, svxBndBox *Box)
evxErrors | cvxPartInqShapeMass (int idShape, double Density, svxMassProp *Prop)
evxErrors | cvxPartShapeStructGet (int idShape, svxWeldAttr *at)

Shape Query

evxErrors | cvxPartInqShapes (const vxLongPath File, const vxRootName Part, int *Count, int **Shapes)
evxErrors | cvxPartInqShapeComp (int idShape, int *idComp)
evxErrors | cvxPartInqShapeEdges (int idShape, int *Count, int **Edges)
evxErrors | cvxPartInqShapeFaces (int idShape, int *Count, int **Faces)
evxErrors | cvxPartInqShapeFtrs (int idShape, int Option, int *Count, int **Features)
evxErrors | cvxPartInqShapeExtreme (int idShape, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)
evxErrors | cvxInstShpGetMatrix (int idShape, svxMatrix *Matrix)

Entity Query Shape

evxErrors cvxPartInqEntShape (int idEntity, int *idShape)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxInstShpGetMatrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxInstShpGetMatrix()

evxErrors cvxInstShpGetMatrix | ( | int | idShape,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs the transformation matrix associated with the specified shape, which was inserted from a part by command "CdInstPartAsShp". Now this function is just used for Misumi modify shape.

Parameters
[in] | idShape | shape id
[out] | Matrix | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqEntShape()

evxErrors cvxPartInqEntShape | ( | int | idEntity,
 |  | int * | idShape
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs the id of the shape that the specified face or edge (idEntity) belongs to. It is assumed the entity resides in the active object. If "idShape = 0" is output, the entity could not be located or didn't belong to a faceset.

Parameters
[in] | idEntity | entity id (in active file)
[out] | idShape | shape id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeBox()

evxErrors cvxPartInqShapeBox | ( | int | idShape,
 |  | svxMatrix * | Mat,
 |  | svxBndBox * | Box
 | ) |  |

#include <zwapi_brep_shape.h>

Gets the bounding box of the specified shape in the active file. If "*Mat = NULL" && the target object class isn't VX_ROOT_PART(evxRootType), the bounding box coordinates are given relative to the global frame of the parent part.

If the target object class is VX_ROOT_PART && "*Mat = NULL", initializes "Mat" to the identity matrix. The "idShape" must belong to the active part, a bounding box relative to the specified local coordinate frame is output.

See also
cvxPartInqEntBox,cvxPartInqFaceBox,cvxEntBndBox. The three interfaces have similar functions.
Parameters
[in] | idShape | shape or face id
[in] | Mat | optional local frame (or NULL)
[out] | Box | shape bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeComp()

evxErrors cvxPartInqShapeComp | ( | int | idShape,
 |  | int * | idComp
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs the id of the component from which the specified shape was merged. Outputs "idComp = 0" if the shape was not merged from a component.

Parameters
[in] | idShape | shape id (in active file)
[out] | idComp | shape's parent component (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeEdges()

evxErrors cvxPartInqShapeEdges | ( | int | idShape,
 |  | int * | Count,
 |  | int ** | Edges
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs a list of indices of the edges that belong to the specified shape in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idShape | shape id
[out] | Count | number of edges
[out] | Edges | list of edge id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeExtreme

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeExtreme()

evxErrors cvxPartInqShapeExtreme | ( | int | idShape,
 |  | const svxVector * | Dir,
 |  | int * | Count,
 |  | int ** | idEnts,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_brep_shape.h>

Gets the extreme point of shape in the specified direction, if the farthest end of the specified direction are faces or edges, the function also outputs the list of faces or edges, in this case, the extreme point output is only any point on a face or edge.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idShape | id of shape in active part
[in] | Dir | direction
[out] | Count | number of faces or edges (NULL to ignore)
[out] | idEnts | list of faces or edges (NULL to ignore)
[out] | Point | extreme point (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_output
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeFaces()

evxErrors cvxPartInqShapeFaces | ( | int | idShape,
 |  | int * | Count,
 |  | int ** | Faces
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs a list of indices of the faces that belong to the specified shape in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idShape | shape id
[out] | Count | number of faces
[out] | Faces | list of face id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeFtrs()

evxErrors cvxPartInqShapeFtrs | ( | int | idShape,
 |  | int | Option,
 |  | int * | Count,
 |  | int ** | Features
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs a list of indices of the features associated with the specified shape in the active part. By default (Option = 0), this includes features that generate the shape, features on which the generative features are dependent for their definition and features that modify attributes of the shape. If "Option=1", only features that generate shape geometry are output, insofar as that classification can be made.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idShape | shape id
[in] | Option | 0-get all dependencies; 1-get just shape generating features
[out] | Count | number of features
[out] | Features | list of feature id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeMass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeMass()

evxErrors cvxPartInqShapeMass | ( | int | idShape,
 |  | double | Density,
 |  | svxMassProp * | Prop
 | ) |  |

#include <zwapi_brep_shape.h>

Calculates mass properties for the specified shape in the active part. If Density = 0, the shape's default density is used.

Parameters
[in] | idShape | id of shape in active part
[in] | Density | density (kg/mm^3)
[out] | Prop | mass properties for specified shape
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapeOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapeOpen()

evxErrors cvxPartInqShapeOpen | ( | int | idShape,
 |  | int * | isOpen
 | ) |  |

#include <zwapi_brep_shape.h>

Get the flag indicating if shape is open.

Parameters
[in] | idShape | shape id (in active file)
[out] | isOpen | open flag for shape (1=open, 0=closed)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_wRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartInqShapes()

evxErrors cvxPartInqShapes | ( | const vxLongPath | File,
 |  | const vxRootName | Part,
 |  | int * | Count,
 |  | int ** | Shapes
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs a list of indices of the shapes that belong to the specified part. The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | File | part file name (File[0]=0 or NULL for active file)
[in] | Part | part name (Part[0]=0 or NULL for active part)
[out] | Count | number of shapes
[out] | Shapes | list of shape id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShapeStructGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxPartShapeStructGet()

evxErrors cvxPartShapeStructGet | ( | int | idShape,
 |  | svxWeldAttr * | at
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs the structural attributes of specified shape.

Parameters
[in] | idShape | entity id
[out] | at | structural attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxShellAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxShellAtGet()

evxErrors cvxShellAtGet | ( | int | idShape,
 |  | svxPartAttribute * | At
 | ) |  |

#include <zwapi_brep_shape.h>

Retrieves attribute data from the specified shell in the active file. If index is small than 1 or an inactive object, return 1.

Parameters
[in] | idShape | the shell index
[out] | At | shell attribute data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxShellAtItemGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxShellAtItemGet()

evxErrors cvxShellAtItemGet | ( | int | idShape,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_brep_shape.h>

Outputs the attribute of specified item for the specified shell.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must be assigned to At->label before calling this function. For all other itemId values, At->label can be an empty string (At->label[0]=0) when this function is called.

Parameters
[in] | idShape | the shell index
[in] | itemId | item id
[in,out] | At | attribute item data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxShellAtItemSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape API
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ cvxShellAtItemSet()

evxErrors cvxShellAtItemSet | ( | int | idShape,
 |  | evxAtItemId | itemId,
 |  | svxAttribute * | At
 | ) |  |

#include <zwapi_brep_shape.h>

Sets the attribute of specified item for the specified shell.

The itemId includes part items of evxAtItemId (VX_AT_USER~VX_AT_HEIGHT).

When itemId is VX_AT_USER, the name of the user-defined attribute must be assigned to At->label before calling this function. For all other itemId values, At->label can be an empty string (At->label[0]=0) when this function is called.

Parameters
[in] | idShape | the shell index
[in] | itemId | item id
[in] | At | attribute item data to set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Vertex API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Vertex API
Brep

Detailed Description

THE MODULE FOR THE ZW3D Vertex API

Vertex

evxErrors cvxPartInqVertexEdges (int idEdge, int EndPnt, int *Count, int **Edges)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqVertexEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vertex API
cvxPartInqVertexEdges

◆ cvxPartInqVertexEdges()

evxErrors cvxPartInqVertexEdges | ( | int | idEdge,
 |  | int | EndPnt,
 |  | int * | Count,
 |  | int ** | Edges
 | ) |  |

#include <zwapi_brep_vertex.h>

Gets all associated edges of the specified vertex of edge in the active file.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idEdge | the index of edge
[in] | EndPnt | 0 to use the starting vertex of the edge, 1 to use the end vertex of the edge
[out] | Count | the count of edges
[out] | Edges | the list of edges
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Math

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Math

Detailed Description

Modules

Math Common API
Bounding Box Math API
Math Data
Entities Intersection API
Matrix API
NURBS Curve
NURBS Surface
Point Math API
Vector API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Math Common API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Math Common API
Math

Detailed Description

THE MODULE FOR THE ZW3D Math API

Round Number

double cvxRoundNumber (double Num, double Step, double Tol, int Dir)

Parallel Check

evxErrors cvxCrvPlaneParallelChk (const svxPoint *plnPnt, const svxVector *plnNormal, const svxCurve *Crv, double tol, int *isParallel, double *Distance)

Distance Computes

evxErrors | cvxAxisDistance (const svxAxis *Axis1, const svxAxis *Axis2, svxPoint *PntOnAxis1, svxPoint *PntOnAxis2, int *Flag)
evxErrors | cvxPlaneDistance (const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, double *Distance)
evxErrors | cvxEntGetDistance (int ent1, int ent2, svxPoint *p1, svxPoint *p2, double *dist)
evxErrors | cvxEntGetDistanceByPath (svxEntPath *EntPath1, svxEntPath *EntPath2, svxPoint *Point1, svxPoint *Point2, double *MinDistance)
evxErrors | cvxAxisCrvDistance (const svxAxis *Axis, const svxCurve *Crv, svxPoint *pntOnAxis, svxPoint *pntOnCrv, double *Distance)

Entity Calculate

evxErrors | cvxEntGetAngle (int ent1, int ent2, double *angle)
evxErrors | cvxPartInqEntsAreaByPath (int cnt, svxEntPath *crvList, svxAreaProp *areaProp)
evxErrors | cvxPartInqEntsArea (int cnt, int *crvList, svxAreaProp *areaProp)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisCrvDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxAxisCrvDistance()

evxErrors cvxAxisCrvDistance | ( | const svxAxis * | Axis,
 |  | const svxCurve * | Crv,
 |  | svxPoint * | pntOnAxis,
 |  | svxPoint * | pntOnCrv,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math.h>

Gets the minimum distance from curve to an infinite line defined by point and direction.

Parameters
[in] | Axis | axis defined by a point and a direction
[in] | Crv | curve to measure distance to
[out] | pntOnAxis | the closest point on the axis (NULL to ignore)
[out] | pntOnCrv | the closest point on the curve (NULL to ignore)
[out] | Distance | the minimum distance (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxAxisDistance()

evxErrors cvxAxisDistance | ( | const svxAxis * | Axis1,
 |  | const svxAxis * | Axis2,
 |  | svxPoint * | PntOnAxis1,
 |  | svxPoint * | PntOnAxis2,
 |  | int * | Flag
 | ) |  |

#include <zwapi_math.h>

Computes the closest point between two 3D axes.

If the axes intersect (Flag is 0), ParamOnAxis1 & ParamOnAxis1 define parametric locations of intersection point on the two axes.

If the axes are parallel (Flag is 1), ParamOnAxis1 & ParamOnAxis1 are undefined.

If the axes are not co-planar and they do not intersect (Flag is 2), ParamOnAxis1 & ParamOnAxis1 define the parametric locations of the closest points.

Parameters
[in] | Axis1 | the first axis
[in] | Axis2 | the second axis
[out] | PntOnAxis1 | the parameter of the closet point on the first axis (NULL to ignore)
[out] | PntOnAxis2 | the parameter of the closet point on the second axis (NULL to ignore)
[out] Flag flag of the two axes position relationship (NULL to ignore)
0: axes intersect
1: axes are parallel
2: axes are not parallel(no intersection and not coplanar)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvPlaneParallelChk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxCrvPlaneParallelChk()

evxErrors cvxCrvPlaneParallelChk | ( | const svxPoint * | plnPnt,
 |  | const svxVector * | plnNormal,
 |  | const svxCurve * | Crv,
 |  | double | tol,
 |  | int * | isParallel,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math.h>

Check if curve lies on a plane parallel to the specified plane. if so output the distance between the curve and the plane.

Parameters
[in] | plnPnt | point on check plane
[in] | plnNormal | normal of check plane
[in] | Crv | curve to check for parallelism
[in] | tol | 3D proximity tolerance(mm) (0.0 for default)
[out] | isParallel | flag (1: parallel; 0: NOT parallel)
[out] Distance the distance between curve and plane, valid output only if parallel flag is true (NULL to ignore)
+: curve is on side of plane pointed to by normal
-: curve is on the opposite side of plane pointed to by normal
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntGetAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxEntGetAngle()

evxErrors cvxEntGetAngle | ( | int | ent1,
 |  | int | ent2,
 |  | double * | angle
 | ) |  |

#include <zwapi_math.h>

Get the angle between 2 entities.the entity type includes line, curve, edge, datum plane, planar face, sketch.

Note
ent1 and ent2 must are defined as "curve-curve" or "planar face-planar face". when entities are curve, the angle between the tangent direction of the starting point of the line is calculated.
Parameters
[in] | ent1 | index of entity 1
[in] | ent2 | index of entity 2
[out] | angle | angle (radians) between entities
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntGetDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxEntGetDistance()

evxErrors cvxEntGetDistance | ( | int | ent1,
 |  | int | ent2,
 |  | svxPoint * | p1,
 |  | svxPoint * | p2,
 |  | double * | dist
 | ) |  |

#include <zwapi_math.h>

Get the distance between 2 entities in part environment, the entity type includes face, curve, edge, datum plane, point.

Parameters
[in] | ent1 | index of entity 1
[in] | ent2 | index of entity 2
[out] | p1 | point on entity 1 (NULL to ignore)
[out] | p2 | point on entity 2 (NULL to ignore)
[out] | dist | distance of p1 and p2
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntGetDistanceByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxEntGetDistanceByPath()

evxErrors cvxEntGetDistanceByPath | ( | svxEntPath * | EntPath1,
 |  | svxEntPath * | EntPath2,
 |  | svxPoint * | Point1,
 |  | svxPoint * | Point2,
 |  | double * | MinDistance
 | ) |  |

#include <zwapi_math.h>

Get the minimum distance between 2 entities in part environment, the entity type includes shape and component.

Parameters
[in] | EntPath1 | the pick path of the first entity
[in] | EntPath2 | the pick path of the second entity
[out] | Point1 | Location on second entity at point of closest contact.(NULL to ignore)
[out] | Point2 | Location on second entity at point of closest contact.(NULL to ignore)
[out] | MinDistance | the minimum distance.(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqEntsAreaByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxPartInqEntsAreaByPath()

evxErrors cvxPartInqEntsAreaByPath | ( | int | cnt,
 |  | svxEntPath * | crvList,
 |  | svxAreaProp * | areaProp
 | ) |  |

#include <zwapi_math.h>

Inquires a planar area bounded by curves in 3d space.

The input boundaries may consist of 3d-curves, 2d-curves, edges, and all of them in the component.

The input just support one plane face.

Note
The calling procedure MUST deallocate the output(pAreaRef and pAreaCA) with cvxMemFree().
Use cvxPartInqEntsArea() to inquire the area of the entities of current part.
Parameters
[in] | cnt | count of curves/face (only one face)
[in] | crvList | entity path list of curves/face
[out] | areaProp | area property
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_MEMORY_ERROR
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlaneDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxPlaneDistance()

evxErrors cvxPlaneDistance | ( | const svxPoint * | PntOnPln1,
 |  | const svxVector * | NormalOfPln1,
 |  | const svxPoint * | PntOnPln2,
 |  | const svxVector * | NormalOfPln2,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math.h>

Gets the distance between two infinite planes and outputs 0.0 if the two planes intersect or coincide.

Parameters
[in] | PntOnPln1 | point on plane1
[in] | NormalOfPln1 | normal of plane1
[in] | PntOnPln2 | point on plane2
[in] | NormalOfPln2 | normal of plane2
[out] | Distance | the distance
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxRoundNumber

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Common API
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ cvxRoundNumber()

double cvxRoundNumber | ( | double | Num,
 |  | double | Step,
 |  | double | Tol,
 |  | int | Dir
 | ) |  |

#include <zwapi_math.h>

Return rounded number.
"Rounding" in this case means the number is adjusted to a value that is a whole-number multiple of the incremental step size Step.
For example, if Step is 0.25, this function returns values such as -0.5, -0.25, 0.0, 0.25, 0.5, 0.75, 1.0, and so on.
To round a number to the nearest integer value, set Step to 1.

If Step is effectively 0 or negative, the incremental step size is so small that no rounding occurs and the return value is Num.

If the rounding direction Dir is 0, Num is rounded to the nearest whole-number multiple of Step, which may be greater or less than Num.
For example, if Step is 1, an input value of 3.4 is rounded down to 3.0, and an input value of 3.6 is rounded up to 4.0.

If Dir is +1, the magnitude of Num is rounded up. For example, if Step is 1, an input value of 3.4 is rounded to 4.0, and an input value of -3.4 is rounded to -4.0.

If Dir is -1, the magnitude of Num is rounded down. For example, if Step is 1, an input value of 3.6 is rounded to 3.0, and an input value of -3.6 is rounded to -3.0.

The tolerance Tol helps to avoid unintended rounding.
If Num is within Tol of a whole-number multiple of Step, Num is rounded to the latter value regardless of the rounding direction specified by Dir.
For example, suppose Step is 1 and Dir is -1, but Num is 3.99999 when Tol is 0.01.
The result will be rounded up to 4.0 because Num is is effectively the same as 4.0 within the given tolerance, despite Dir indicating that Num should be rounded down.

The step size Step should be much larger than the tolerance Tol.

If Num is a value that represents a distance or an angle, all three inputs Num, Step and Tol should have the same units.

Parameters
[in] | Num | Number to round.
[in] | Step | Incremental step size, may be 0.
[in] | Tol | Tolerance for two values to be the same.
[in] | Dir | Rounding direction (0 nearest, -1 down, +1 up).
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Bounding Box Math API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Bounding Box Math API
Math

Detailed Description

THE MODULE FOR THE ZW3D Bounding Box API

Bounding Box

void | cvxBndBoxInit (svxBndBox *Box)
void | cvxBndBoxInit2 (svxBndBox *Box)
void | cvxBndBoxPnts (svxBndBox *Box, svxPoint *Pnts)
evxErrors | cvxBndBoxCenter (const svxBndBox *Box, svxPoint *CenterPnt)
evxErrors | cvxBndBoxPntLoc (const svxBndBox *Box, const svxPoint *Point, evxPntLocation *PntLoc)
void | cvxBndBoxAdd (svxBndBox *Box, svxPoint *Pnt)
void | cvxBndBoxMerge (const svxBndBox *Box1, svxBndBox *Box2)
double | cvxBndBoxSize (svxBndBox *Box)
double | cvxBndBoxVolume (const svxBndBox *Box)
int | cvxBndBoxContain (const svxBndBox *BaseBox, const svxBndBox *OtherBox)

Bounding Box Distance

evxErrors | cvxBndBoxPntDist (const svxBndBox *Box, const svxPoint *Point, double *DistMin, double *DistMax)
evxErrors | cvxBndBoxDist (const svxBndBox *Box1, const svxBndBox *Box2, double *DistMin, double *DistMax)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxAdd()

void cvxBndBoxAdd | ( | svxBndBox * | Box,
 |  | svxPoint * | Pnt
 | ) |  |

#include <zwapi_math_bndbox.h>

"Grows" the specified bounding box to envelop the specified point.

Parameters
[in,out] | Box | pointer to bounding box data
[in] | Pnt | point to add to bounding box
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxCenter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxCenter()

evxErrors cvxBndBoxCenter | ( | const svxBndBox * | Box,
 |  | svxPoint * | CenterPnt
 | ) |  |

#include <zwapi_math_bndbox.h>

Gets the center of the specified bounding box.

Parameters
[in] | Box | the bounding box
[out] | CenterPnt | the center point of bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxContain

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxContain()

int cvxBndBoxContain | ( | const svxBndBox * | BaseBox,
 |  | const svxBndBox * | OtherBox
 | ) |  |

#include <zwapi_math_bndbox.h>

Check whether the base bounding box is completely containing an other bounding box.

Parameters
[in] | BaseBox | the base bounding box
[in] | OtherBox | the other bounding box
Return values
succeeds
  • ZW_API_NO_ERROR - The base bounding box does not contain an other bounding box.
  • 1 - The base bounding box contains an other bounding box.
fail
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxDist()

evxErrors cvxBndBoxDist | ( | const svxBndBox * | Box1,
 |  | const svxBndBox * | Box2,
 |  | double * | DistMin,
 |  | double * | DistMax
 | ) |  |

#include <zwapi_math_bndbox.h>

Compute the maximum and minimum distance between a point and a 3D bounding boxes.

Parameters
[in] | Box1 | the first bounding box
[in] | Box2 | the second bounding box
[out] | DistMin | minimum distance between boxes, 0 if overlap (NULL to ignore)
[out] | DistMax | maximum distance between boxes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxInit()

void cvxBndBoxInit ( svxBndBox * Box )

#include <zwapi_math_bndbox.h>

Initializes the specified bounding box to all values set to zero.

Parameters
[in,out] Box pointer to bounding box data
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxInit2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxInit2()

void cvxBndBoxInit2 ( svxBndBox * Box )

#include <zwapi_math_bndbox.h>

Initializes the specified bounding box "min" values to "positive infinity" and "max" values to "negative infinity".

Parameters
[in,out] Box pointer to bounding box data
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxMerge()

void cvxBndBoxMerge | ( | const svxBndBox * | Box1,
 |  | svxBndBox * | Box2
 | ) |  |

#include <zwapi_math_bndbox.h>

Merge two bounding boxes and output results to the second bounding box.

Parameters
[in] | Box1 | the first bounding box
[in,out] | Box2 | the second bounding box
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxPntDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxPntDist()

evxErrors cvxBndBoxPntDist | ( | const svxBndBox * | Box,
 |  | const svxPoint * | Point,
 |  | double * | DistMin,
 |  | double * | DistMax
 | ) |  |

#include <zwapi_math_bndbox.h>

Compute the maximum and minimum distance between a point and a 3D bounding boxes.

Parameters
[in] | Box | the bounding box
[in] | Point | point to measure distance to
[out] | DistMin | minimum distance, 0 if overlap (NULL to ignore)
[out] | DistMax | maximum distance (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxPntLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxPntLoc()

evxErrors cvxBndBoxPntLoc | ( | const svxBndBox * | Box,
 |  | const svxPoint * | Point,
 |  | evxPntLocation * | PntLoc
 | ) |  |

#include <zwapi_math_bndbox.h>

Determine whether a given point lies inside, outside or on the specified bounding box.

Parameters
[in] | Box | the bounding box
[in] | Point | point to measure distance to
[out] | PntLoc | returned status of the point on the bounding box
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxPnts()

void cvxBndBoxPnts | ( | svxBndBox * | Box,
 |  | svxPoint * | Pnts
 | ) |  |

#include <zwapi_math_bndbox.h>

Outputs the corner points of the specified bounding box to the array referenced by "Pnts".
Memory for the array must be allocated by the calling procedure.
"Pnts" is a pointer to the start of the memory and must reference at least enough memory for 8 svxPoint structures.

The corners are assigned to "Pnts" as follows, where "min" and "max" refer to the bounding box's minimum and maximum limits in the specified coordinate direction:

Pnts[0] = Xmin,Ymin,Zmin
Pnts[1] = Xmax,Ymin,Zmin
Pnts[2] = Xmax,Ymax,Zmin
Pnts[3] = Xmin,Ymax,Zmin
Pnts[4] = Xmin,Ymin,Zmax
Pnts[5] = Xmax,Ymin,Zmax
Pnts[6] = Xmax,Ymax,Zmax
Pnts[7] = Xmin,Ymax,Zmax

Parameters
[in] | Box | pointer to bounding box data
[in,out] | Pnts | pointer to array of 8 point structures
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxSize()

double cvxBndBoxSize ( svxBndBox * Box )

#include <zwapi_math_bndbox.h>

Returns the "size" of the specified bounding box – that is, the length of its diagonal.

Parameters
[in] Box pointer to bounding box data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxVolume

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Bounding Box Math API
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ cvxBndBoxVolume()

double cvxBndBoxVolume ( const svxBndBox * Box )

#include <zwapi_math_bndbox.h>

Returns the volume of the specified bounding box. the volume will be set to 0.0 if there is an error in the function such as Box is NULL or something.

Parameters
[in] Box pointer to bounding box data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Math Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Math Data
Math

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the All Math functions.

Intersection of Curve/Face Data

enum | evxFaceTrim { VX_TRIM_NONE = 0 , VX_TRIM_ALL = 1 , VX_TRIM_OUTER = 2 }
face trim-curve option More...
typedef enum evxFaceTrim | evxFaceTrim
face trim-curve option

Surface Find Face/Edge Data

enum evxFaceFindType {
VX_FIND_BOSS , VX_FIND_POCKET , VX_FIND_HOLE , VX_FIND_FILLET ,
VX_FIND_CUSTOM , VX_FIND_FINDER
}
face search types More...
enum evxEdgeLoopType {
VX_EDGE_LOOP_INNER = 0 , VX_EDGE_LOOP_OUTER = 1 , VX_EDGE_LOOP_ALL = 2 , VX_EDGE_LOOP_SHARED = 3 ,
VX_EDGE_LOOP_BOUNDARY = 4
}
type of loop in which the edge is located More...
typedef enum evxFaceFindType | evxFaceFindType
face search types
typedef struct svxFaceFind | svxFaceFind
face search data
typedef enum evxEdgeLoopType | evxEdgeLoopType
type of loop in which the edge is located

Curve Evaluate Data

typedef struct svxEvalCurv svxEvalCurv
curve evaluate
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Entities Intersection API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Entities Intersection API
Math

Detailed Description

THE MODULE FOR THE ZW3D Intersection API

Curve And Curve/Face

evxErrors | cvxIsectCrvCrv (int idCurve1, int idCurve2, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectCrvFace (int idCurve, int idFace, int Trim, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectFaceFace (int idFace1, int idFace2, evxFaceTrim Trim, int TangentOk, int *Count, svxCurve **Curves)

Ray With Objects

evxErrors | cvxIsectRayCrv (svxAxis *Ray, int idCurve, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectRayFace (int idFace, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, svxPoint2 *UV)
evxErrors | cvxIsectRayFaceInfinite (int idFace, evxFaceTrim Trim, const svxAxis *Ray, int Infinite, int *Number, svxPoint **Pnts, svxPoint2 **UVs)
int | cvxIsectRayPlane (svxAxis *Ray, svxMatrix *Plane, svxPoint *Point)
evxErrors | cvxIsectRayShape (int idShape, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayShapes (int nShapes, int *idShapes, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, int **idFaces)
evxErrors | cvxIsectRayPart (evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayPartVis (evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayComp (int idComp, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point)
evxErrors | cvxIsectRayComps (int nComps, svxEntPath *CompPaths, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, svxEntPath **FacePaths)
evxErrors | cvxCompFind (evxFaceTrim Trim, svxAxis *Ray, double Dist, int SkipBlank, int *Count, int **Comps)
int | cvxIsectRayBndBox (const svxAxis *Ray, const svxBndBox *Box, svxPoint *IsectPnt)

Intersecting of Shapes

int | cvxPartIsectShpChk (int idBaseShape, int idOpShape)
int | cvxPartIsectShpChk2 (int idBaseShape, int idOpShape, int fClosedChk)
int | cvxCompIsectShpShp (const svxEntPath *basePath, const svxEntPath *opPath, evxFaceTrim trim, int *count, svxCurve **curves)

Intersecting of bounding box and plane

int | cvxIsectBndBoxBndBox (const svxBndBox *Box1, const svxBndBox *Box2)
int | cvxIsectBndBoxPlane (const svxBndBox *Box, const svxPoint *PntOnPln, const svxVector *NormalOfPln)
int | cvxIsectPlanePlane (const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, svxAxis *IsectLine)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxCompFind()

evxErrors cvxCompFind | ( | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | double | Dist,
 |  | int | SkipBlank,
 |  | int * | Count,
 |  | int ** | Comps
 | ) |  |

#include <zwapi_math_insect.h>

Outputs a list of indices of the components that belong the active part and are intersected by the specified ray.
Only intersections within "Dist" of the ray's start point (Ray->Pnt) are considered.

The "Trim" option is used to determine what portions of the component faces are checked against the ray.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[in] | Dist | distance from start of ray along direction of ray
[in] | SkipBlank | 1 to skip blanked components; else 0
[out] | Count | number of components
[out] | Comps | list of component id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsectShpShp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxCompIsectShpShp()

int cvxCompIsectShpShp | ( | const svxEntPath * | basePath,
 |  | const svxEntPath * | opPath,
 |  | evxFaceTrim | trim,
 |  | int * | count,
 |  | svxCurve ** | curves
 | ) |  |

#include <zwapi_math_insect.h>

Gets the intersecting curves of two shapes(comps).

Parameters
[in] | basePath | path of the first shape
[in] | opPath | path of the second shape
[in] | trim | face trim option
[out] | count | count of "curves"
[out] | curves | list of intersection curves
Return values
return
  • 2 - basePath is the same as opPath.
  • 3 - not intersect.
  • 0 - success,intersection exists.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectBndBoxBndBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectBndBoxBndBox()

int cvxIsectBndBoxBndBox | ( | const svxBndBox * | Box1,
 |  | const svxBndBox * | Box2
 | ) |  |

#include <zwapi_math_insect.h>

Check whether two bounding boxes intersect.

Parameters
[in] | Box1 | the first bounding box
[in] | Box2 | the second bounding box
Return values
succeeds
  • ZW_API_NO_ERROR - Boxes do NOT intersect.
  • 1 - Boxes do intersect.
fail
  • ZW_API_INVALID_INPUT
return
  • -1: Errors.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectBndBoxPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectBndBoxPlane()

int cvxIsectBndBoxPlane | ( | const svxBndBox * | Box,
 |  | const svxPoint * | PntOnPln,
 |  | const svxVector * | NormalOfPln
 | ) |  |

#include <zwapi_math_insect.h>

Check whether two bounding boxes intersect.

Parameters
[in] | Box | the bounding box
[in] | PntOnPln | point on plane
[in] | NormalOfPln | normal of plane
Return values
succeeds
  • ZW_API_NO_ERROR - Box and plane do NOT intersect.
  • 1 - Box and plane do intersect.
fail
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectCrvCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectCrvCrv()

evxErrors cvxIsectCrvCrv | ( | int | idCurve1,
 |  | int | idCurve2,
 |  | int | TangentOk,
 |  | int * | Count,
 |  | svxPoint ** | Points
 | ) |  |

#include <zwapi_math_insect.h>

Outputs a list of the points where the two input curves intersect. The calling procedure MUST deallocate the output list.

Parameters
[in] | idCurve1 | first curve
[in] | idCurve2 | second curve
[in] | TangentOk | 1 to include points of tangency; else 0
[out] | Count | number of intersection points
[out] | Points | list of intersection points
Return values
succeeds
  • ZW_API_NO_ERROR - one or more intersection points are found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection point is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectCrvFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectCrvFace()

evxErrors cvxIsectCrvFace | ( | int | idCurve,
 |  | int | idFace,
 |  | int | Trim,
 |  | int | TangentOk,
 |  | int * | Count,
 |  | svxPoint ** | Points
 | ) |  |

#include <zwapi_math_insect.h>

Outputs a list of the points where the input curve and face intersect.
The calling procedure MUST deallocate the output list.

Parameters
[in] | idCurve | id of curve entity in active file
[in] | idFace | id of face entity in active file
[in] | Trim | 1 to intersect trimmed face; 0 to intersect entire untrimmed surface
[in] | TangentOk | 1 to include points of tangency; else 0
[out] | Count | number of intersection points
[out] | Points | list of intersection points
Return values
succeeds
  • ZW_API_NO_ERROR - one or more intersection points are found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection point is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectFaceFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectFaceFace()

evxErrors cvxIsectFaceFace | ( | int | idFace1,
 |  | int | idFace2,
 |  | evxFaceTrim | Trim,
 |  | int | TangentOk,
 |  | int * | Count,
 |  | svxCurve ** | Curves
 | ) |  |

#include <zwapi_math_insect.h>

Outputs a list of curves where the two input faces intersect.
the output Curves data can be added to the active part with the cvxPartCurve() function.

The calling procedure MUST deallocate the internal data in each element of the output list by calling cvxCurveFree(), after which the output list MUST be deallocated using cvxMemFree((void**)Curves).

Parameters
[in] | idFace1 | id of the first face entity in active file
[in] | idFace2 | id of the second face entity in active file
[in] | Trim | face trim-curve option
[in] | TangentOk | 1 to include curves of tangency; else 0
[out] | Count | number of intersection curves
[out] | Curves | list of intersection curves
Return values
succeeds
  • ZW_API_NO_ERROR - one or more intersection curves are found
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection curves is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectPlanePlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectPlanePlane()

int cvxIsectPlanePlane | ( | const svxPoint * | PntOnPln1,
 |  | const svxVector * | NormalOfPln1,
 |  | const svxPoint * | PntOnPln2,
 |  | const svxVector * | NormalOfPln2,
 |  | svxAxis * | IsectLine
 | ) |  |

#include <zwapi_math_insect.h>

Gets the intersection line of two planes both defined by a point and normal.

Parameters
[in] | PntOnPln1 | the bounding box
[in] | NormalOfPln1 | point on plane
[in] | PntOnPln2 | normal of plane
[in] | NormalOfPln2 | normal of plane2
[out] | IsectLine | intersection line
Return values
succeeds
  • ZW_API_NO_ERROR - Valid intersection line found.
  • 1 - Planes are parallel and distinct.
  • 2 - Planes are identical.
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayBndBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayBndBox()

int cvxIsectRayBndBox | ( | const svxAxis * | Ray,
 |  | const svxBndBox * | Box,
 |  | svxPoint * | IsectPnt
 | ) |  |

#include <zwapi_math_insect.h>

Intersect an infinite line with a bounding box.
the intersection point given is the farthest point on the ray along the opposite direction of the ray.

Parameters
[in] | Ray | ray defined by a point and a direction
[in] | Box | the bounding box
[out] | IsectPnt | the intersection point (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - No intersection point found.
  • 1 - Intersection point found.
fail
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayComp()

evxErrors cvxIsectRayComp | ( | int | idComp,
 |  | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the specified component in the active part and outputs the point closest to the ray startpoint (Ray->Pnt).
The output point coordinates are given in the space of the active part.

Note
The ray only extends in the specified direction from the startpoint.
Intersections in the other direction are not considered.
The "Trim" option is used to determine what portions of the component's faces are checked against the ray.
Parameters
[in] | idComp | component id
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Point | closest intersection point (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayComps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayComps()

evxErrors cvxIsectRayComps | ( | int | nComps,
 |  | svxEntPath * | CompPaths,
 |  | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | int * | Number,
 |  | svxPoint ** | Points,
 |  | svxEntPath ** | FacePaths
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the input components and outputs the intersection points.

Note
The positive and negative directions of the ray will be involved in the calculation.
The "Trim" option is used to determine what portions of the shape's faces are checked against the ray.

This function allocates memory for the array output via "Points" and "FacePaths".
The calling procedure is responsible for deallocating the memory.

Parameters
[in] | nComps | number of components
[in] | CompPaths | pick path of components
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Number | number of intersection point
[out] | Points | list of intersection points (NULL to ignore)
[out] | FacePaths | list of face pick paths that intersection point lies (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayCrv()

evxErrors cvxIsectRayCrv | ( | svxAxis * | Ray,
 |  | int | idCurve,
 |  | int | TangentOk,
 |  | int * | Count,
 |  | svxPoint ** | Points
 | ) |  |

#include <zwapi_math_insect.h>

Outputs a list of the points where the input ray and curve intersect.
The calling procedure MUST deallocate the output list.

Parameters
[in] | Ray | ray defined by a point and a direction
[in] | idCurve | curve entity
[in] | TangentOk | 1 to include points of tangency; else 0
[out] | Count | number of intersection points
[out] | Points | list of intersection points
Return values
succeeds
  • ZW_API_NO_ERROR - one or more intersection points are found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection point is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayFace()

evxErrors cvxIsectRayFace | ( | int | idFace,
 |  | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | svxPoint * | Point,
 |  | svxPoint2 * | UV
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the input face and outputs the point closest to the ray startpoint (Ray->Pnt).

Note
The ray only extends in the specified direction from the startpoint. Intersections in the other direction are not considered.
The "Trim" option is used to determine what portions of the face are checked against the ray.
Parameters
[in] | idFace | id of face in active file
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Point | intersection point (NULL to ignore)
[out] | UV | U,V coordinates (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found
fail
  • ZW_API_GENERAL_ERROR - fails or no intersection is found
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayFaceInfinite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayFaceInfinite()

evxErrors cvxIsectRayFaceInfinite | ( | int | idFace,
 |  | evxFaceTrim | Trim,
 |  | const svxAxis * | Ray,
 |  | int | Infinite,
 |  | int * | Number,
 |  | svxPoint ** | Pnts,
 |  | svxPoint2 ** | UVs
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the input face and outputs all intersection points to the ray start point (Ray->Pnt).

The "Trim" option is used to determine what portions of the face are checked against the ray.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | idFace | id of shape in active part
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[in] | Infinite | 1 to check both directions of ray, 0 to check positive direction of ray only
[out] | Number | number of points
[out] | Pnts | list of intersection points (NULL to ignore)
[out] | UVs | list of U,V coordinates (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found
fail
  • ZW_API_GENERAL_ERROR - fails or no intersection is found
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayPart()

evxErrors cvxIsectRayPart | ( | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | svxPoint * | Point,
 |  | int * | idFace
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with all faces of the active part and outputs the point closest to the ray startpoint (Ray->Pnt).

Note
The ray only extends in the specified direction from the startpoint.
Intersections in the other direction are not considered.
If an intersection is found, the id of the intersected face is optionally output.
Use cvxPartInqFaceShape() to get the id of the face's parent shape.

The "Trim" option is used to determine what portions of the parts's faces are checked against the ray.

Parameters
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Point | closest intersection point (NULL to ignore)
[out] | idFace | id of face that intersection point lies on (input NULL to ignore this output)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayPartVis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayPartVis()

evxErrors cvxIsectRayPartVis | ( | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | svxPoint * | Point,
 |  | int * | idFace
 | ) |  |

#include <zwapi_math_insect.h>

This function is the same as cvxIsectRayPart(), except that it only considers visible faces.
That is, it ignores faces that belong to blanked shapes.

Parameters
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Point | closest intersection point (NULL to ignore)
[out] | idFace | id of face that intersection point lies on (input NULL to ignore this output)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayPlane()

int cvxIsectRayPlane | ( | svxAxis * | Ray,
 |  | svxMatrix * | Plane,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the XY plane of the specified transformation matrix and outputs the point of intersection.

Parameters
[in] | Ray | ray defined by a point and a direction
[in] | Plane | plane transformation matrix (XY plane)
[out] | Point | intersection point
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
  • 1 - if the ray is parallel to, and on the plane.
  • 2 - if the ray is parallel to, but off the plane.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayShape()

evxErrors cvxIsectRayShape | ( | int | idShape,
 |  | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | svxPoint * | Point,
 |  | int * | idFace
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the input shape and outputs the point closest to the ray start point (Ray->Pnt).

Note
The ray only extends in the specified direction from the start point. Intersections in the other direction are not considered.
If an intersection is found, the id of the intersected face is optionally output.
The "Trim" option is used to determine what portions of the shapes' faces are checked against the ray.
Parameters
[in] | idShape | id of shape in active part
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Point | closest intersection point (NULL to ignore)
[out] | idFace | id of face that intersection point lies on (input NULL to ignore this output)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxIsectRayShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxIsectRayShapes()

evxErrors cvxIsectRayShapes | ( | int | nShapes,
 |  | int * | idShapes,
 |  | evxFaceTrim | Trim,
 |  | svxAxis * | Ray,
 |  | int * | Number,
 |  | svxPoint ** | Points,
 |  | int ** | idFaces
 | ) |  |

#include <zwapi_math_insect.h>

Intersects the input ray with the input shapes and outputs the intersection points.

Note
The positive and negative directions of the ray will be involved in the calculation.
The "Trim" option is used to determine what portions of the shape's faces are checked against the ray.
This function allocates memory for the array output via "Points" and "FacePaths".
The calling procedure is responsible for deallocating the memory.
Parameters
[in] | nShapes | number of shapes
[in] | idShapes | index of shapes
[in] | Trim | face trim option
[in] | Ray | ray defined by a point and a direction
[out] | Number | number of intersection point
[out] | Points | list of intersection points (NULL to ignore)
[out] | idFaces | list of face ids that intersection point lies (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR - intersection point successfully found.
fail
  • ZW_API_GENERAL_ERROR - function fails or no intersection is found.
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsectShpChk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxPartIsectShpChk()

int cvxPartIsectShpChk | ( | int | idBaseShape,
 |  | int | idOpShape
 | ) |  |

#include <zwapi_math_insect.h>

Determine exist or not exist intersection between the input two shapes.

Parameters
[in] | idBaseShape | the need check intersection shape 1
[in] | idOpShape | the need check intersection shape 2
Return values
return
  • 1 - found shape isect
  • 0 - no shape isect or error occurs
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsectShpChk2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entities Intersection API
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ cvxPartIsectShpChk2()

int cvxPartIsectShpChk2 | ( | int | idBaseShape,
 |  | int | idOpShape,
 |  | int | fClosedChk
 | ) |  |

#include <zwapi_math_insect.h>

Determine exist or not exist intersection between the input two shapes.
If should check the two shapes are closed, it will return 0 if any shape of them is not closed.

Parameters
[in] | idBaseShape | the need check intersection shape 1
[in] | idOpShape | the need check intersection shape 2
[in] | fClosedChk | option to control whether check the open shell 1 is excluding the open shell. otherwise is 0
Return values
return
  • 1 - found shape isect
  • 0 - no shape isect or error occurs
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Matrix API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Matrix API
Math

Detailed Description

THE MODULE FOR THE ZW3D Matrix API

Transformation Matrix

evxErrors | cvxMatEigen (const double Mat3x3[3][3], double *Values, svxVector *Vectors)
void | cvxMatInit (svxMatrix *Mat)
void | cvxMatInvert (svxMatrix *Mat, svxMatrix *InvMat)
void | cvxMatMult (svxMatrix *Mat1, svxMatrix *Mat2, svxMatrix *Mat3)
void | cvxMatPntVec (svxPoint *Origin, svxVector *zAxis, svxMatrix *Mat)
evxErrors | cvxMatPntVecs (svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxMatrix *Mat)
evxErrors | cvxMatGetPntVecs (const svxMatrix *Mat, svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxVector *zAxis)
void | cvxMatRotate (svxMatrix *Mat, double Angle, svxAxis *Axis)
void | cvxMatScale (svxMatrix *Mat, svxPoint *Point, double sX, double sY, double sZ)
void | cvxMatSetIdentity (svxMatrix *Mat)
void | cvxMatTransform (svxMatrix *Mat, svxMatrix *Frame)
void | cvxMatTranslate (svxMatrix *Mat, double dX, double dY, double dZ)
void | cvxMatView (svxMatrix *Mat, evxViewStd Type)
evxErrors | cvxMatToEuler (evxEulerAngSeq Seq, svxMatrix *pMat, svxMatEuler *pzMatEuler)
evxErrors | cvxMatFromEuler (evxEulerAngSeq Seq, const svxMatEuler *pzMatEuler, svxMatrix *pMat)

Object Transformation

void | cvxPntTransform (svxMatrix *Mat, svxPoint *Point)
void | cvxPntTransformList (svxMatrix *Mat, int Count, svxPoint *Points)
void | cvxAxisTransform (svxMatrix *Mat, svxAxis *Axis)
void | cvxVecTransform (svxMatrix *Mat, svxVector *Vector)
void | cvxCrvTransform (svxMatrix *Mat, svxCurve *Crv)
void | cvxSrfTransform (svxMatrix *Mat, svxSurface *Srf)
void | cvxBndBoxTransform (svxMatrix *Mat, svxBndBox *Box)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxAxisTransform()

void cvxAxisTransform | ( | svxMatrix * | Mat,
 |  | svxAxis * | Axis
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Axis".

Parameters
[in] | Mat | transformation matrix
[in,out] | Axis | axis
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxBndBoxTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxBndBoxTransform()

void cvxBndBoxTransform | ( | svxMatrix * | Mat,
 |  | svxBndBox * | Box
 | ) |  |

#include <zwapi_math_matrix.h>

Apply the specified transform to the specified bounding box.

If the bounding box has not been modified since initialized, do nothing.

Parameters
[in] | Mat | transformation matrix
[in,out] | Box | bounding box
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxCrvTransform()

void cvxCrvTransform | ( | svxMatrix * | Mat,
 |  | svxCurve * | Crv
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Crv".
Assumes "Mat" is an affine transform.

Parameters
[in] | Mat | transformation matrix
[in,out] | Crv | curve
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatEigen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatEigen()

evxErrors cvxMatEigen | ( | const double | Mat3x3[3][3],
 |  | double * | Values,
 |  | svxVector * | Vectors
 | ) |  |

#include <zwapi_math_matrix.h>

Calculates the eigenvalues and eigenvectors of a 3x3 matrix.

Three real-valued eigenvalues are output in Values, which is an array that must be provided by the caller and must be dimensioned large enough to hold at least 3 double precision numbers.
The caller may pass NULL for the Values argument if the eigenvalues are not wanted.
This function always computes three eigenvalues, repeating values in the Values array if necessary.

The eigenvectors corresponding to the eigenvalues are output in Vectors, which is an array that must be provided by the caller and must be dimensioned large enough to hold at least 3 svxVector structures.
The caller may pass NULL for the Vectors argument if the eigenvectors are not wanted.

Vectors[i] is the eigenvector corresponding to the eigenvalue Values[i], but the eigenvalues are not sorted.
The largest or smallest eigenvalue may be in any element of the Values array.

Parameters
[in] | Mat3x3 | matrix
[out] | Values | three real-valued eigenvalues (or NULL)
[out] | Vectors | three eigenvectors for the eigenvalues (or NULL)

Returns: succeeds:

  • ZW_API_NO_ERROR fails:
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatFromEuler

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatFromEuler()

evxErrors cvxMatFromEuler | ( | evxEulerAngSeq | Seq,
 |  | const svxMatEuler * | pzMatEuler,
 |  | svxMatrix * | pMat
 | ) |  |

#include <zwapi_math_matrix.h>

Conversion from Euler Angles to Transform Matrix. Two categories of rotation sequence:

  1. Proper Euler Angle - when the first and third rotation are around the same axes.
    121: X-axis, Y-axis, X-axis
    131: X-axis, Z-axis, X-axis
    212: Y-axis, X-axis, Y-axis
    232: Y-axis, Z-axis, Y-axis
    313: Z-axis, X-axis, Z-axis
    323: Z-axis, Y-axis, Z-axis
  2. Tait-Bryan or Roll-Pitch-Yaw Angles - when three rotations are around different axes.
    123: X-axis (Roll), Y-axis (Pitch), Z-axis (Yaw)
    132: X-axis (Roll), Z-axis (Yaw), Y-axis (Pitch)
    213: Y-axis (Pitch), X-axis (Roll), Z-axis (Yaw)
    231: Y-axis (Pitch), Z-axis (Yaw), X-axis (Roll)
    312: Z-axis (Yaw), X-axis (Roll), Y-axis (Pitch)
    321: Z-axis (Yaw), Y-axis (Pitch), X-axis (Roll)
Parameters
[in] | Seq | rotation sequence type, see description
[in] | pzMatEuler | Euler angles and translate vector
[out] | pMat | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatGetPntVecs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatGetPntVecs()

evxErrors cvxMatGetPntVecs | ( | const svxMatrix * | Mat,
 |  | svxPoint * | Origin,
 |  | svxVector * | xAxis,
 |  | svxVector * | yAxis,
 |  | svxVector * | zAxis
 | ) |  |

#include <zwapi_math_matrix.h>

Gets the origin, x-direction, y-direction and z-direction of matrix.

Parameters
[in] | Mat | origin, optional
[out] | Origin | origin (NULL to ignore)
[out] | xAxis | x direction (NULL to ignore)
[out] | yAxis | y direction (NULL to ignore)
[out] | zAxis | z direction (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatInit()

void cvxMatInit ( svxMatrix * Mat )

#include <zwapi_math_matrix.h>

Initializes "Mat" to the identity matrix.

Parameters
[out] Mat transformation matrix
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\skCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatInvert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatInvert()

void cvxMatInvert | ( | svxMatrix * | Mat,
 |  | svxMatrix * | InvMat
 | ) |  |

#include <zwapi_math_matrix.h>

Output an inverted version of "Mat" via "InvMat".

Parameters
[in] | Mat | transformation matrix
[out] | InvMat | inverted transformation matrix
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatMult

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatMult()

void cvxMatMult | ( | svxMatrix * | Mat1,
 |  | svxMatrix * | Mat2,
 |  | svxMatrix * | Mat3
 | ) |  |

#include <zwapi_math_matrix.h>

Matrix multiply (Mat3 = Mat1 * Mat2).

Parameters
[in] | Mat1 | first transformation matrix
[in] | Mat2 | second transformation matrix
[out] | Mat3 | resulting matrix
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatPntVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatPntVec()

void cvxMatPntVec | ( | svxPoint * | Origin,
 |  | svxVector * | zAxis,
 |  | svxMatrix * | Mat
 | ) |  |

#include <zwapi_math_matrix.h>

Composes a transformation matrix that defines a reference frame whose origin coincides with "Origin", whose Z axis points in the direction of "zAxis", with arbitrary X and Y axis.

Parameters
[in] | Origin | origin
[in] | zAxis | direction of Z axis
[out] | Mat | transformation matrix
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatPntVecs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatPntVecs()

evxErrors cvxMatPntVecs | ( | svxPoint * | Origin,
 |  | svxVector * | xAxis,
 |  | svxVector * | yAxis,
 |  | svxMatrix * | Mat
 | ) |  |

#include <zwapi_math_matrix.h>

Compose a transformation matrix that defines a reference frame with an origin coinciding with "Origin" and X and Y axes being aligned to the directions given by "xAxis" and "yAxis", respectively.
The "xAxis" and "yAxis" inputs need not be unit vectors, and as long as they are not parallel, they do not have to be perpendicular.

Parameters
[in] | Origin | origin, optional
[in] | xAxis | direction of x axis
[in] | yAxis | direction of y axis
[out] | Mat | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatRotate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatRotate()

void cvxMatRotate | ( | svxMatrix * | Mat,
 |  | double | Angle,
 |  | svxAxis * | Axis
 | ) |  |

#include <zwapi_math_matrix.h>

Initializes a transformation matrix "Mat" to perform rotations by the specified angle about the specified axis.

Parameters
[in,out] | Mat | transformation matrix
[in] | Angle | rotation angle (deg)
[in] | Axis | axis of rotation
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatScale()

void cvxMatScale | ( | svxMatrix * | Mat,
 |  | svxPoint * | Point,
 |  | double | sX,
 |  | double | sY,
 |  | double | sZ
 | ) |  |

#include <zwapi_math_matrix.h>

Initializes "Mat" so that it will scale points by sX, sY, sZ relative to "Point".

Parameters
[in,out] | Mat | transformation matrix
[in] | Point | reference point
[in] | sX | X scale
[in] | sY | Y scale
[in] | sZ | Z scale
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatSetIdentity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatSetIdentity()

void cvxMatSetIdentity ( svxMatrix * Mat )

#include <zwapi_math_matrix.h>

Make sure "identity" flag associated with "Mat" is set correctly.

Parameters
[in,out] Mat transformation matrix
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatToEuler

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatToEuler()

evxErrors cvxMatToEuler | ( | evxEulerAngSeq | Seq,
 |  | svxMatrix * | pMat,
 |  | svxMatEuler * | pzMatEuler
 | ) |  |

#include <zwapi_math_matrix.h>

Conversion Transform Matrix to Euler Angles. Two categories of rotation sequence:

  1. Proper Euler Angle - when the first and third rotation are around the same axes.
    121: X-axis, Y-axis, X-axis
    131: X-axis, Z-axis, X-axis
    212: Y-axis, X-axis, Y-axis
    232: Y-axis, Z-axis, Y-axis
    313: Z-axis, X-axis, Z-axis
    323: Z-axis, Y-axis, Z-axis
  2. Tait-Bryan or Roll-Pitch-Yaw Angles - when three rotations are around different axes.
    123: X-axis (Roll), Y-axis (Pitch), Z-axis (Yaw)
    132: X-axis (Roll), Z-axis (Yaw), Y-axis (Pitch)
    213: Y-axis (Pitch), X-axis (Roll), Z-axis (Yaw)
    231: Y-axis (Pitch), Z-axis (Yaw), X-axis (Roll)
    312: Z-axis (Yaw), X-axis (Roll), Y-axis (Pitch)
    321: Z-axis (Yaw), Y-axis (Pitch), X-axis (Roll)
Parameters
[in] | Seq | rotation sequence type, see description
[in] | pMat | transformation matrix
[out] | pzMatEuler | Euler angles and translate vector
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatTransform()

void cvxMatTransform | ( | svxMatrix * | Mat,
 |  | svxMatrix * | Frame
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Frame".

Parameters
[in] | Mat | transformation matrix
[in,out] | Frame | coordinate frame (i.e. transform)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatTranslate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatTranslate()

void cvxMatTranslate | ( | svxMatrix * | Mat,
 |  | double | dX,
 |  | double | dY,
 |  | double | dZ
 | ) |  |

#include <zwapi_math_matrix.h>

Initializes "Mat" so that it will translate points by dX, dY, dZ.

Parameters
[in,out] | Mat | transformation matrix
[in] | dX | X distance
[in] | dY | Y distance
[in] | dZ | Z distance
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxMatView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxMatView()

void cvxMatView | ( | svxMatrix * | Mat,
 |  | evxViewStd | Type
 | ) |  |

#include <zwapi_math_matrix.h>

Initializes "Mat" to the specified standard view.

Parameters
[out] | Mat | transformation matrix
[in] | Type | standard view type
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxPntTransform()

void cvxPntTransform | ( | svxMatrix * | Mat,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Point".

Transform point from local to world space, if *Mat is a local matrix.
Transform point form world to local space. if *Mat is the inverse of a local matrix.

Parameters
[in] | Mat | transformation matrix
[in,out] | Point | point
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntTransformList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxPntTransformList()

void cvxPntTransformList | ( | svxMatrix * | Mat,
 |  | int | Count,
 |  | svxPoint * | Points
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Point".

Parameters
[in] | Mat | transformation matrix
[in] | Count | number of points to transform
[in] | Points | list of points to transform
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxSrfTransform()

void cvxSrfTransform | ( | svxMatrix * | Mat,
 |  | svxSurface * | Srf
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Srf".
Assumes "Mat" is an affine transform.

Parameters
[in] | Mat | transformation matrix
[in,out] | Srf | surface
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Matrix API
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ cvxVecTransform()

void cvxVecTransform | ( | svxMatrix * | Mat,
 |  | svxVector * | Vector
 | ) |  |

#include <zwapi_math_matrix.h>

Applies transformation matrix "Mat" to "Vector".

Parameters
[in] | Mat | transformation matrix
[in,out] | Vector | vector
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: NURBS Curve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
NURBS Curve
Math

Detailed Description

THE MODULE FOR THE ZW3D Nurbs Curve API

Curve Evaluate

evxErrors | cvxCrvEval (int idCurve, double T, svxPoint *Point, svxVector *Normal)
evxErrors | cvxCrvEval2 (const int idCurve, const double t, const int level, svxEvalCurv *eval)
evxErrors | cvxPreEdgeEval (const int idPreEdge, const double t, const int level, svxEvalCurv *eval)
evxErrors | cvxCrvEvalCrvtr (const int idCurve, const double t, svxPoint *point, svxPoint *normal, double *curvature)

Curve Query

int | cvxCrvIsLine (int idCurve)
evxErrors | cvxCrvParam (int idCurve, svxLimit *T)
evxErrors | cvxCrvMinMaxRad (int idCurve, double *minRad, double *maxRad, int *isFlat)
evxErrors | cvxCrvInqContinuity (int Count, int *Curves, int *Continuity)
evxErrors | cvxCrvContinuityTolListInit (svxCrvContinuityTolList *data)
evxErrors | cvxCrvInqMultiContinuity (int cnt, const int *curves, const svxCrvContinuityTolList *tols, int *cntContinuity, svxCrvContinuityData **data)
evxErrors | cvxPartCurveChainFind (int nSeeds, int *idSeeds, int type, int *Count, int **idCrvs)

Curve Point

evxErrors | cvxCrvGetPntAtLenFraction (int idCurve, double Fraction, svxPoint *Point)
evxErrors | cvxCrvPntProj (int idCurve, svxPoint *Pnt, double *T, svxPoint *ProjPnt)
evxErrors | cvxCrvGetPntAtDist (int idCurve, double StartT, double Length, double *T, svxPoint *Point)
evxErrors | cvxCrvGetInflections (int idCurve, int *Count, double **T, svxPoint **InfPnts)
evxErrors | cvxCrvInqExtreme (int idCurve, const svxVector *Dir, int *isPerp, svxPoint *Point)
evxErrors | cvxCrvExtremum (int idCurve, int *Count, svxPoint **Pnts, svxBndBox *BndBox)
evxErrors | cvxCrvGetCusps (int idCurve, int *Count, double **T, svxPoint **Cusps)

Curve Length

evxErrors | cvxCrvLen (int idCurve, double *Len)
evxErrors | cvxCrvLen2 (int idCurve, double T1, double T2, double *Length)

Edge Sew

evxErrors cvxPartSew (double Tol, int *OpenEdges, double *MaxGap)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvContinuityTolListInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvContinuityTolListInit()

evxErrors cvxCrvContinuityTolListInit ( svxCrvContinuityTolList * data )

#include <zwapi_math_nurbscurve.h>

Initialize the parameters of the cvxCrvInqMultiContinuity().

Note
Do not assign a value to variable "data" before calling this function.
The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvEval()

evxErrors cvxCrvEval | ( | int | idCurve,
 |  | double | T,
 |  | svxPoint * | Point,
 |  | svxVector * | Normal
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Evaluates the NURBS representation of the curve entity specified by "idCurve". Outputs the point coordinates (Point) and normal direction (Normal) at the specified "t" parameter value.
Use cvxCrvParam() to get the curve's parameter limits.
The "Normal" output is an arbitrary direction that is perpendicular to the curve at "t" and is not the same as the normal direction that is a function of curvature at "t".

See also
cvxCrvEvalCrvtr() if you need the normal that points toward the curve's center of curvature.
Parameters
[in] | idCurve | curve entity id
[in] | T | t parameter value on curve
[out] | Point | point on curve
[out] | Normal | normal at point on curve
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvEval2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvEval2()

evxErrors cvxCrvEval2 | ( | const int | idCurve,
 |  | const double | t,
 |  | const int | level,
 |  | svxEvalCurv * | eval
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Evaluates a curve at a specified parameter value.

"level" specifies the level of evaluation. The higher the level, more data gets returned (at the expense of greater computation).

                     level
      |  0  |     1     |     2      |    3
      +-----+-----------+------------+--------
      | pnt |  deriv_1  |  deriv_2   | deriv_3
Parameters
[in] | idCurve | curve entity id
[in] | t | t parameter value on curve
[in] | level | level of evaluation(0 ~ 3), See description below
[out] | eval | Result
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvEvalCrvtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvEvalCrvtr()

evxErrors cvxCrvEvalCrvtr | ( | const int | idCurve,
 |  | const double | t,
 |  | svxPoint * | point,
 |  | svxPoint * | normal,
 |  | double * | curvature
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Evaluates curvature, point and unit principal normal vector of a given curve at the specified parameter.Use cvxCrvParam() to get the curve's parameter limits.

Parameters
[in] | idCurve | curve entity id
[in] | t | parameter at which the curvature is evaluated
[out] | point | point at the specified parameter (input NULL to ignore).
[out] | normal | unit principal normal vector at the specified parameter (input NULL to ignore).
[out] | curvature | curvature at the specified parameter (input NULL to ignore).
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvExtremum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvExtremum()

evxErrors cvxCrvExtremum | ( | int | idCurve,
 |  | int * | Count,
 |  | svxPoint ** | Pnts,
 |  | svxBndBox * | BndBox
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Return the extremum points of specified curve and its bounding box.

The list of extremum points must be freed by caller.

Parameters
[in] | idCurve | id of curve entity
[out] | Count | extremum point count
[out] | Pnts | list of extremum points
[out] | BndBox | optional curve tight bounding box (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvGetCusps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvGetCusps()

evxErrors cvxCrvGetCusps | ( | int | idCurve,
 |  | int * | Count,
 |  | double ** | T,
 |  | svxPoint ** | Cusps
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Find cusps of the specified curve and outputs the list of
parameter value and coordinates of cusps.The calling
procedure MUST deallocate the output list.

Parameters
[in] | idCurve | id of curve in the active object
[out] | Count | number of cusps found
[out] | T | T parameter value of each cusps (NULL to ignore)
[out] | Cusps | the array of cusps found (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvGetInflections

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvGetInflections()

evxErrors cvxCrvGetInflections | ( | int | idCurve,
 |  | int * | Count,
 |  | double ** | T,
 |  | svxPoint ** | InfPnts
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Calculates inflection points of the specified curve and outputs the list of
parameter value and coordinates of inflection points found.The calling
procedure MUST deallocate the output list.

Parameters
[in] | idCurve | id of curve in the active object
[out] | Count | number of inflection points found
[out] | T | T parameter value of each inflection points (NULL to ignore)
[out] | InfPnts | the array of inflection points (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvGetPntAtDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvGetPntAtDist()

evxErrors cvxCrvGetPntAtDist | ( | int | idCurve,
 |  | double | StartT,
 |  | double | Length,
 |  | double * | T,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Get point on a curve at a specified distance from the specified start point of the curve.

Parameters
[in] | idCurve | curve entity id
[in] | StartT | T parameter value of starting point
[in] | Length | Length of interval
[out] | T | T parameter value of output point(NULL to ignore)
[out] | Point | output point on curve(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvGetPntAtLenFraction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvGetPntAtLenFraction()

evxErrors cvxCrvGetPntAtLenFraction | ( | int | idCurve,
 |  | double | Fraction,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Gets point on a curve at a specified fraction of the curve's length.
For example, to evaluate the curve at its minimum parameter value,
set frac to 0.0; to evaluate the curve at its maximum parameter value,
set frac to 1.0; and to evaluate the mid-point of the curve where the
length from each end is the same, set frac to 0.5.

Parameters
[in] | idCurve | curve entity id
[in] | Fraction | fraction of curve length (0.0 to 1.0)
[out] | Point | output point on curve
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvInqContinuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvInqContinuity()

evxErrors cvxCrvInqContinuity | ( | int | Count,
 |  | int * | Curves,
 |  | int * | Continuity
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Get the flag of continuity of curves.

Parameters
[in] | Count | number of curves
[in] | Curves | list of curves
[out] Continuity continuity flag (0 to discontinuous;
1 to position continuous;
2 to tangent continuous)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvInqExtreme

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvInqExtreme()

evxErrors cvxCrvInqExtreme | ( | int | idCurve,
 |  | const svxVector * | Dir,
 |  | int * | isPerp,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Gets the extreme point of curve in the specified direction. if the curve is
on a plane perpendicular to direction, the extreme point output is start point
of curve.

Parameters
[in] | idCurve | id of curve in active part
[in] | Dir | direction
[out] | isPerp | output 1 if the curve is on a plane perpendicular to direction, else 0
[out] | Point | extreme point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvInqMultiContinuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvInqMultiContinuity()

evxErrors cvxCrvInqMultiContinuity | ( | int | cnt,
 |  | const int * | curves,
 |  | const svxCrvContinuityTolList * | tols,
 |  | int * | cntContinuity,
 |  | svxCrvContinuityData ** | data
 | ) |  |

#include <zwapi_math_nurbscurve.h>

For all input lines, judge the continuity relationship between two lines.

cntContinuity is the number of intersections between every two line segments.

data is the continuity of the two line segments represented by the intersection.

Unlike the cvxCrvInqContinuity interface can only judge the overall continuity of all input line segments, and requires that the line segments are closed at last.

The cvxCrvInqMultiContinuity interface can judge the continuity between any two line segments, and there are no other use requirements.

Note
Interface cvxCrvContinuityTolListInit() can initialize variables of this function.
Parameters
[in] | cnt | count of curves
[in] | curves | list of curve id
[in] | tols | list of curve continuity tolerance
[out] | cntContinuity | count of data
[out] | data | list of continuity data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvIsLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvIsLine()

int cvxCrvIsLine ( int idCurve )

#include <zwapi_math_nurbscurve.h>

Check if the specified curve is a straight line.

Parameters
[in] idCurve index of curve
Return values
return
  • 0: the specified curve is not a straight line
  • 1: the specified curve is a straight line
  • -1: the id is not a curve or function fails
  • ZW_API_MODELING_DATA_ERROR
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvLen()

evxErrors cvxCrvLen | ( | int | idCurve,
 |  | double * | Len
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Calculates the length of the specified curve and outputs it via "Len".

Parameters
[in] | idCurve | id of curve in the active object
[out] | Len | curve length (mm)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvLen2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvLen2()

evxErrors cvxCrvLen2 | ( | int | idCurve,
 |  | double | T1,
 |  | double | T2,
 |  | double * | Length
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Calculates the curve length of a NURBS curve from the parameter T1 to T2.

Parameters
[in] | idCurve | curve entity id
[in] | T1 | T parameter value of start point
[in] | T2 | T parameter value of end point
[out] | Length | length of a NURBS curve from T1 to T2
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvMinMaxRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvMinMaxRad()

evxErrors cvxCrvMinMaxRad | ( | int | idCurve,
 |  | double * | minRad,
 |  | double * | maxRad,
 |  | int * | isFlat
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Get the maximum and minimum radius of the spline curve.
If curvature of curve = 0, Rad = -1 (the radius of curvature is infinite).

Parameters
[in] | idCurve | id of curve
[out] | minRad | minimum radius(NULL to ignore)
[out] | maxRad | maximum radius(NULL to ignore)
[out] | isFlat | 1 if the curve is flat, else 0(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvParam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvParam()

evxErrors cvxCrvParam | ( | int | idCurve,
 |  | svxLimit * | T
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Outputs the minimum and maximum t parameter values of the NURBS representation of the specified curve entity.

Parameters
[in] | idCurve | curve entity id
[out] | T | min/max T values
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCrvPntProj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxCrvPntProj()

evxErrors cvxCrvPntProj | ( | int | idCurve,
 |  | svxPoint * | Pnt,
 |  | double * | T,
 |  | svxPoint * | ProjPnt
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Outputs the T parameter value of the projection of the input XYZ
point onto the NURBS representation of the specified curve. It
is assumed that "Pnt" lies on or very close to the curve.

Parameters
[in] | idCurve | id of curve entity
[in] | Pnt | coordinates of point to project onto curve
[out] | T | T parameter value of point-on-curve
[out] | ProjPnt | XYZ coordinates of projected point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCurveChainFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxPartCurveChainFind()

evxErrors cvxPartCurveChainFind | ( | int | nSeeds,
 |  | int * | idSeeds,
 |  | int | type,
 |  | int * | Count,
 |  | int ** | idCrvs
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Use the function to find connected chain of curves or edges and output a list of indices of the edges or curves.

If the seed is a curve, the chain consists of curves that are connected end-to-end, but without any requirement for tangency between curve.

If the seed is an edge, the chain consists of edges that are tangent, i.e. smoothly
connected end-to-end. If type is 0, an edge may bound any number of faces. If type
is 1, only open edges are included in the chain, the requirement for tangency between
edges is suspended, so a chain of open edges may continue around sharp corners. If
type is 2, only manifold edges are included in the chain, i.e. edges that are shared
by exactly two faces, or edges that have seams with the same face on both sides.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | nSeeds | number of seed edges or curves
[in] | idSeeds | list of id of seed edges or curves
[in] type type of edges, only effects the find result of the seed edge
0: find continuously tangent edges that may be bound by any number of faces
1: find connected open edges
2: find continuously tangent manifold edges that are shared by exactly two
faces or are seams having the same face on both sides
[out] | Count | number of curves found
[out] | idCrvs | list of curves found
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxPartSew()

evxErrors cvxPartSew | ( | double | Tol,
 |  | int * | OpenEdges,
 |  | double * | MaxGap
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Matches and sews free edges in the active part using the input proximity
tolerance. If "Tol" is input as 0.0, the active part's default proximity
tolerance is used.

Input NULL for "OpenEdges" and/or "MaxGap" if you are not interested in
the information returned via those variables.

Parameters
[in] | Tol | 3D proximity tolerance (mm) (0.0 for default)
[out] | OpenEdges | number of unmatched/open edges after sew (or NULL)
[out] | MaxGap | maximum gap between all unmatched edges (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPreEdgeEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Curve
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ cvxPreEdgeEval()

evxErrors cvxPreEdgeEval | ( | const int | idPreEdge,
 |  | const double | t,
 |  | const int | level,
 |  | svxEvalCurv * | eval
 | ) |  |

#include <zwapi_math_nurbscurve.h>

Evaluates a pre-edge at a specified parameter value. the difference between the function
and cvxCrvEval2() is that cvxCrvEval2() simply evaluates point on a curve, the function computes
directional and point on the surface from the UV curve.

"level" specifies the level of evaluation. The higher the level, more data gets returned (at the expense of greater computation).

                     level
      |  0  |     1     |     2      |    3
      +-----+-----------+------------+--------
      | pnt |  deriv_1  |  deriv_2   | deriv_3
Parameters
[in] | idPreEdge | index of pre-edge
[in] | t | t parameter value on curve
[in] | level | level of evaluation(0 ~ 3). See description below
[out] | eval | Result
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: NURBS Surface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
NURBS Surface
Math

Detailed Description

THE MODULE FOR THE ZW3D Nurbs Surface API

Surface Edit

evxErrors | cvxPartFace (svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Code, int Sew, double Tol, int *idFace)
evxErrors | cvxPartFaceMod (int idFace, svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Sew, double Tol)

Surface Evaluate

evxErrors | cvxSrfEval (svxSurface *Srf, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
evxErrors | cvxSrfDiameterEval (svxSurface *Srf, double U, double V, double *Diameter)

Surface Find Face/Edge

evxErrors | cvxPartFaceFind (svxFaceFind *findData, int *Count, int **idFaces)
evxErrors | cvxPartFaceEdgesFind (int nSeeds, int *idSeeds, evxEdgeLoopType type, int *Count, int **idEdges)

Surface Query

evxErrors | cvxSrfAxis (svxSurface *Srf, svxPoint *startPnt, svxPoint *endPnt)
evxErrors | cvxSrfGetPole (svxSurface *srf, const svxPoint *dir, svxPoint *pnt)
int | cvxSrfFindPoles (svxSurface *srf, double tol, int poles[4])
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxPartFace()

evxErrors cvxPartFace | ( | svxSurface * | Srf,
 |  | int | NumCurves,
 |  | svxCurve * | TrimCurves,
 |  | int | Code,
 |  | int | Sew,
 |  | double | Tol,
 |  | int * | idFace
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Adds a face to the active part using the specified surface and trim curves.
The face is sewn to adjacent faces with matching edges.

It is assumed the trim curves are 2D NURBS curves defined in the UV space of
the specified surface. If no trim curves are input (NumCurves=0), trim
curves are automatically created around the "rectangular" surface boundary.

The input 3D proximity tolerance (Tol) is used to match the endpoints of
trim curves when they are sorted into loops, and to match edges of the
new face to edges to existing faces if the "Sew" option is enabled.

If "Tol" is input as 0.0, the active part's default proximity tolerance is used.

If "idFace" is not NULL, the database id of the new face entity is output.

This function copies data passed to it. The calling procedure is
responsible for deallocating memory referenced by the input data structures.

Note
Faces will not add successfully to the active part unless there
is an active feature (i.e. history operation) for them to link to. This is
accomplished by putting your code inside the callback function associated
with a command-template-defined custom history operation (see cvxTplInit()).
When the history is regenerated, ZW3D will expect the input parameters defined
by the command template to provide sufficient input to the callback function
to re-create (i.e. regenerate) the original geometry.

The other option is to start your code with cvxPartHistStart(), which
defines a "static" feature (i.e. history operation) for program-generated
geometry (e.g. faces) to attach to. When you are done adding geometry,
call cvxPartHistEnd(). This function will cause all existing part geometry
and history to be bundled into a single static "StartData" history operation.

Parameters
[in] | Srf | NURBS surface geometry
[in] | NumCurves | number of trim curves
[in] | TrimCurves | list of 2D NURBS UV trim curves
[in] | Code | non-zero integer code for labeling the face
[in] | Sew | 1 to sew face to adjacent faces, else 0
[in] | Tol | 3D proximity tolerance (mm) (0.0 for default)
[out] | idFace | database id of new face entity (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceEdgesFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxPartFaceEdgesFind()

evxErrors cvxPartFaceEdgesFind | ( | int | nSeeds,
 |  | int * | idSeeds,
 |  | evxEdgeLoopType | type,
 |  | int * | Count,
 |  | int ** | idEdges
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Use the function to find edges that bound one or more seed faces.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | nSeeds | number of seed faces
[in] | idSeeds | list of id of seed faces
[in] | type | type of boundary
[out] | Count | number of edges found
[out] | idEdges | list of edges found
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxPartFaceFind()

evxErrors cvxPartFaceFind | ( | svxFaceFind * | findData,
 |  | int * | Count,
 |  | int ** | idFaces
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Use the function to find connected groups of faces and output a list
of indices of the faces. the function provides several methods for
finding faces that form certain kinds of features, such as bosses,
pockets, holes and fillets. also support custom method, please refer
to the description of input variables for details.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | findData | face search data
[out] | Count | number of faces found
[out] | idFaces | list of faces found
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceMod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxPartFaceMod()

evxErrors cvxPartFaceMod | ( | int | idFace,
 |  | svxSurface * | Srf,
 |  | int | NumCurves,
 |  | svxCurve * | TrimCurves,
 |  | int | Sew,
 |  | double | Tol
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Modify a face to the active part using the specified surface and trim curves.
The face is sewn to adjacent faces with matching edges.

It is assumed the trim curves are 2D NURBS curves defined in the UV space of
the specified surface. If no trim curves are input (NumCurves=0), trim
curves are automatically created around the "rectangular" surface boundary.

The input 3D proximity tolerance (Tol) is used to match the endpoints of
trim curves when they are sorted into loops, and to match edges of the
new face to edges to existing faces if the "Sew" option is enabled.

If "Tol" is input as 0.0, the active part's default proximity tolerance is used.

This function copies data passed to it. The calling procedure is
responsible for deallocating memory referenced by the input data structures.

Note
Faces will not modify successfully to the active part unless there
is an active feature (i.e. history operation) for them to link to. This is
accomplished by putting your code inside the callback function associated
with a command-template-defined custom history operation. When the history
is regenerated, ZW3D will expect the input parameters defined by the command
template to provide sufficient input to the callback function to re-create
(i.e. regenerate) the original geometry.

The other option is to start your code with cvxPartHistStart(), which
defines a "static" feature (i.e. history operation) for program-generated
geometry (e.g. faces) to attach to. When you are done adding geometry,
call cvxPartHistEnd(). This function will cause all existing part geometry
and history to be bundled into a single static "StartData" history operation.

Parameters
[in] | idFace | index of face
[in] | Srf | NURBS surface geometry
[in] | NumCurves | number of trim curves
[in] | TrimCurves | list of 2D NURBS UV trim curves
[in] | Sew | 1 to sew face to adjacent faces, else 0
[in] | Tol | 3D proximity tolerance (mm) (0.0 for default)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxSrfAxis()

evxErrors cvxSrfAxis | ( | svxSurface * | Srf,
 |  | svxPoint * | startPnt,
 |  | svxPoint * | endPnt
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Get the axis of the specified surface. the surface type must be
one of the following: Cylinder, Torus and Cone.

Parameters
[in] | Srf | pointer to NURBS surface data structure
[out] | startPnt | start point of axis line
[out] | endPnt | end point of axis line
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfDiameterEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxSrfDiameterEval()

evxErrors cvxSrfDiameterEval | ( | svxSurface * | Srf,
 |  | double | U,
 |  | double | V,
 |  | double * | Diameter
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Get the surface diameter in the specified UV point. the surface type
must be one of the following:
1.Cylinder: the cylinder diameter.
2.Torus: the distance of the point specified from the axis.
3.Cone: the distance of the point specified from the axis.

Parameters
[in] | Srf | pointer to NURB surface data structure
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[out] | Diameter | diameter of specified point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxSrfEval()

evxErrors cvxSrfEval | ( | svxSurface * | Srf,
 |  | double | U,
 |  | double | V,
 |  | svxPoint * | Point,
 |  | svxVector * | Normal,
 |  | svxVector * | Utan,
 |  | svxVector * | Vtan
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Evaluates a point in the space of the specified NURBS surface. Outputs
the 3D point coordinates (Point), normal direction (Normal) and UV tangent
directions at the specified U,V location on the surface.

Note
The direction of "Normal" is set to reflect the outward
normal of the face, where "outward" means the direction that points
towards the outside of the shape that the face is associated with.
This may be opposite the natural normal of the NURBS surface associated
with the face.

If you want the natural normal of the NURBS surface associated with
the face, call cvxVecReverse() to reverse the "Normal" if Srf->OutNormal=0.

Parameters
[in] | Srf | pointer to NURBS surface data structure
[in] | U | U parameter value on face
[in] | V | V parameter value on face
[out] | Point | point on face (input NULL to ignore)
[out] | Normal | normal at point on face (input NULL to ignore)
[out] | Utan | U tangent direction (input NULL to ignore)
[out] | Vtan | V tangent direction (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfFindPoles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxSrfFindPoles()

int cvxSrfFindPoles | ( | svxSurface * | srf,
 |  | double | tol,
 |  | int | poles[4]
 | ) |  |

#include <zwapi_math_nurbssurface.h>

This routine determines which, if any, boundaries of srf are poles.
It sets the flags in the array poles appropriately.

Parameters
[in] | srf | pointer to NURBS surface data structure
[in] | tol | the tolerance
[out] poles[4] poles[i] = 0 means the i-th boundary is not a pole.
poles[i] = 1 means it is a pole.
The boundaries are numbered counterclockwise, starting at
the bottom (v=0).
fPoles[0] -> pole at loV
fPoles[1] -> pole at hiU
fPoles[2] -> pole at hiV
fPoles[3] -> pole at loU
Return values
return
  • 0 - No poles found or error occurs
  • 1 - At least one pole found
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSrfGetPole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • NURBS Surface
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ cvxSrfGetPole()

evxErrors cvxSrfGetPole | ( | svxSurface * | srf,
 |  | const svxPoint * | dir,
 |  | svxPoint * | pnt
 | ) |  |

#include <zwapi_math_nurbssurface.h>

Get the pole point of the specified surface in a specified direction.

Parameters
[in] | srf | pointer to NURBS surface data structure
[in] | dir | direction
[out] | pnt | pole point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Point Math API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Point Math API
Math

Detailed Description

THE MODULE FOR THE ZW3D Point Math API

Distance Computes

evxErrors cvxAxisCrvDistance (const svxAxis *Axis, const svxCurve *Crv, svxPoint *pntOnAxis, svxPoint *pntOnCrv, double *Distance)

Point On Entity

int | cvxPntIsCritical (svxPoint *pnt, int idCurve)
int | cvxPntIsOn (svxPoint *Pnt, int idEntity)
evxErrors | cvxPntOnCrv (int idCurve, double Fraction, svxPoint *Point)
evxErrors | cvxPntOnFace (int idComp, int idFace, double Param[2], svxPoint *Point)
evxErrors | cvxPntProject (svxPoint *Pnt, int idEntity, svxPoint *ProjPnt)
evxErrors | cvxPntEntLoc (svxPoint *Pnt, int idEntity, evxPntLocation *PntLoc)
evxErrors | cvxAxisPntProject (const svxAxis *Axis, const svxPoint *Pnt, svxPoint *ProjPnt)
int | cvxPlanePntProject (const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, const svxVector *ProjectDir, svxPoint *ProjPnt)

Point Distance

void | cvxPntTranslate (svxPoint *Point, svxVector *Vector, double Distance)
double | cvxPntDist (const svxPoint *Point1, const svxPoint *Point2)
evxErrors | cvxPntEntDist (const svxPoint *Point, int idEntity, svxPoint *TargetPnt, double *Distance)
evxErrors | cvxPntPreEdgeDist (const svxPoint *Point, int idPreEdge, double *T, svxPoint *TargetPnt, double *Distance)
evxErrors | cvxAxisPntDistance (const svxAxis *Axis, const svxPoint *Pnt, double *Distance)
evxErrors | cvxPlanePntDistance (const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, double *Distance, svxPoint *ProjPnt)

Point Evaluation

evxErrors | cvxAxisEvalPoint (const svxAxis *Axis, double Distance, svxPoint *Point)
evxErrors | cvxPlaneEvalPoint (const svxPoint *Origin, const svxVector *xAxis, const svxVector *yAxis, double xDist, double yDist, svxPoint *Point)

Plane/Polygon

int | cvxPlnThruPnts (int PntCount, svxPoint *PntList, svxVector *Normal, double *D)
evxErrors | cvxPolyToTri (int PntCount, svxPoint *PntList, int *VtxCount, int **VtxList)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisEvalPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxAxisEvalPoint()

evxErrors cvxAxisEvalPoint | ( | const svxAxis * | Axis,
 |  | double | Distance,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_point.h>

Get point on axis at a specified distance from origin of axis.

Parameters
[in] | Axis | axis defined by a point and a direction
[in] Distance distance
> 0: along direction of axis
< 0: the opppsite direction of axis
[out] | Point | point on the axis at specified distance
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisPntDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxAxisPntDistance()

evxErrors cvxAxisPntDistance | ( | const svxAxis * | Axis,
 |  | const svxPoint * | Pnt,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math_point.h>

Gets the minimum distance from a point to an infinite line defined by point and direction.

Parameters
[in] | Axis | axis defined by a point and a direction
[in] | Pnt | point to measure distance to
[out] | Distance | the minimum distance
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxAxisPntProject

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxAxisPntProject()

evxErrors cvxAxisPntProject | ( | const svxAxis * | Axis,
 |  | const svxPoint * | Pnt,
 |  | svxPoint * | ProjPnt
 | ) |  |

#include <zwapi_math_point.h>

Project point onto infinite line defined by point and direction.

Parameters
[in] | Axis | axis defined by a point and a direction
[in] | Pnt | point to project
[out] | ProjPnt | point projected on axis
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlaneEvalPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPlaneEvalPoint()

evxErrors cvxPlaneEvalPoint | ( | const svxPoint * | Origin,
 |  | const svxVector * | xAxis,
 |  | const svxVector * | yAxis,
 |  | double | xDist,
 |  | double | yDist,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_point.h>

Get point on plane that offset the origin by a specified distance in the x-direction and y-direction.

Parameters
[in] | Origin | origin of plane
[in] | xAxis | x-direction of plane
[in] | yAxis | y-direction of plane
[in] | xDist | distance of x-direction (> 0: in same direction; < 0: in opppsite direction)
[in] | yDist | distance of y-direction (> 0: in same direction; < 0: in opppsite direction)
[out] | Point | point on the axis at specified distance
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlanePntDistance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPlanePntDistance()

evxErrors cvxPlanePntDistance | ( | const svxPoint * | PlnPnt,
 |  | const svxVector * | PlnNormal,
 |  | const svxPoint * | Point,
 |  | double * | Distance,
 |  | svxPoint * | ProjPnt
 | ) |  |

#include <zwapi_math_point.h>

Get the minimum distance form a point to an infinite plane by point and direction.

Parameters
[in] | PlnPnt | point on plane
[in] | PlnNormal | normal of plane
[in] | Point | point to measure distance to
[out] | Distance | the minimum distance
[out] | ProjPnt | point projected on plane (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlanePntProject

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPlanePntProject()

int cvxPlanePntProject | ( | const svxPoint * | PlnPnt,
 |  | const svxVector * | PlnNormal,
 |  | const svxPoint * | Point,
 |  | const svxVector * | ProjectDir,
 |  | svxPoint * | ProjPnt
 | ) |  |

#include <zwapi_math_point.h>

Project point onto infinite plane by point and direction.

Parameters
[in] | PlnPnt | point on plane
[in] | PlnNormal | normal of plane
[in] | Point | point to project
[in] | ProjectDir | projection direction (NULL to use normal of plane)
[out] | ProjPnt | point projected on plane
Return values
succeeds
  • ZW_API_NO_ERROR
  • 1 - The projection direction is parallel to the plane normal and point is on the plane.
  • 2 - The projection direction is parallel to the plane normal and point is not in the plane.
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPlnThruPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPlnThruPnts()

int cvxPlnThruPnts | ( | int | PntCount,
 |  | svxPoint * | PntList,
 |  | svxVector * | Normal,
 |  | double * | D
 | ) |  |

#include <zwapi_math_point.h>

Given "PntCount" points, this function computes the least squares plane
fitted through these points. It then checks to see if the points are
contained within this plane such that for any point (X,Y,Z) in the plane,
the following equation holds true:

Normal.x * X + Normal.y * Y + Normal.z * Z + D = 0

Parameters
[in] | PntCount | number of points in point list
[in] | PntList | list of points
[out] | Normal | unit length vector normal to the plane
[out] | D | the last term in the plane equation (see description below)
Return values
succeeds
  • -2 : line or point in xy-plane (points do not define a plane).
  • -1 : line or point not in xy-plane (points do not define a plane).
  • 0 : points do not lie in a unique plane.
  • 1 : points lie in a unique plane (not the xy-plane).
  • 2 : points lie in the xy-plane.
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntDist()

double cvxPntDist | ( | const svxPoint * | Point1,
 |  | const svxPoint * | Point2
 | ) |  |

#include <zwapi_math_point.h>

Returns the distance between two points.

Parameters
[in] | Point1 | first point
[in] | Point2 | second point
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\datumCrtTest.cpp, and part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntEntDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntEntDist()

evxErrors cvxPntEntDist | ( | const svxPoint * | Point,
 |  | int | idEntity,
 |  | svxPoint * | TargetPnt,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math_point.h>

Acquire the minimum distance between the point and the target entity,
the target entity type includes shape, face, curve, edge, datum plane, point.

Parameters
[in] | Point | point coordinates of the inquiry
[in] | idEntity | index of target entity
[out] | TargetPnt | the closest point on target entity (NULL to ignore)
[out] | Distance | the minimum distance (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOR_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntEntLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntEntLoc()

evxErrors cvxPntEntLoc | ( | svxPoint * | Pnt,
 |  | int | idEntity,
 |  | evxPntLocation * | PntLoc
 | ) |  |

#include <zwapi_math_point.h>

Determine if a given point lies inside, outside or on the boundary of a given curve,
edge, face or shape.

Parameters
[in] | Pnt | point coordinates of the inquiry
[in] | idEntity | entity id (only curve, edge, face and shape are supported)
[out] | PntLoc | returned status of the point on the entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntIsCritical

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntIsCritical()

int cvxPntIsCritical | ( | svxPoint * | pnt,
 |  | int | idCurve
 | ) |  |

#include <zwapi_math_point.h>

This function is to determine whether the pnt is the critical point of
the 2D curve with index idCurve in Drawing Sheet.

Meaning of critical point is the point with start, end, middle or center position
of the curve.

Parameters
[in] | pnt | point
[in] | idCurve | index of 2D curve
Return values
return
  • 1 - it is a critical point
  • 0 - it is not a critical point or error
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntIsOn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntIsOn()

int cvxPntIsOn | ( | svxPoint * | Pnt,
 |  | int | idEntity
 | ) |  |

#include <zwapi_math_point.h>

Parameters
[in] | Pnt | point
[in] | idEntity | id of curve, edge, face or plane entity
Return values
return
  • 1 - the input point lies within the active proximity tolerance of the input entity
  • 0 - otherwise
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntOnCrv()

evxErrors cvxPntOnCrv | ( | int | idCurve,
 |  | double | Fraction,
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_point.h>

Calculates a 3D point on the specified curve entity
(in the active object) at the input fraction of the
curve's length from its startpoint.

Parameters
[in] | idCurve | id of curve in the active object
[in] | Fraction | fraction of curve length (0.0 to 1.0)
[out] | Point | point on curve
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntOnFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntOnFace()

evxErrors cvxPntOnFace | ( | int | idComp,
 |  | int | idFace,
 |  | double | Param[2],
 |  | svxPoint * | Point
 | ) |  |

#include <zwapi_math_point.h>

Calculates a point on the specified face at the midpoint of
the face's bounding box in UV parameter space. The 3D point
coordinates are output in the space of the active part, even
if the face belongs to a child component of the part (idComp > 0).
The corresponding U,V parameters are output as Param[0] and Param[1].

Parameters
[in] | idComp | id of component that contains face (0 if undefined)
[in] | idFace | id of face in active part or specified component
[out] | Param[2] | u,v parameter values
[out] | Point | point on face (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntPreEdgeDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntPreEdgeDist()

evxErrors cvxPntPreEdgeDist | ( | const svxPoint * | Point,
 |  | int | idPreEdge,
 |  | double * | T,
 |  | svxPoint * | TargetPnt,
 |  | double * | Distance
 | ) |  |

#include <zwapi_math_point.h>

Acquire the minimum distance between the point and the curve on face, the difference
from cvxPntEntDist() is that the function will be output the closest point on the UV line
of the face.

Parameters
[in] | Point | point coordinates of the inquiry
[in] | idPreEdge | index of pre-edge
[out] | T | parameter value at closest point (NULL to ignore)
[out] | TargetPnt | coordinates of closest point (NULL to ignore)
[out] | Distance | the minimum distance (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntProject

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntProject()

evxErrors cvxPntProject | ( | svxPoint * | Pnt,
 |  | int | idEntity,
 |  | svxPoint * | ProjPnt
 | ) |  |

#include <zwapi_math_point.h>

Projects "Pnt" onto the specified curve, edge, face or plane
and outputs the result as "ProjPnt".

Parameters
[in] | Pnt | point to project
[in] | idEntity | id of curve, edge, face or plane entity
[out] | ProjPnt | projected point on entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPntTranslate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPntTranslate()

void cvxPntTranslate | ( | svxPoint * | Point,
 |  | svxVector * | Vector,
 |  | double | Distance
 | ) |  |

#include <zwapi_math_point.h>

Translates "Point" along "Vector" by "Distance".
This function assumes that "Vector" is normalized.

Parameters
[in,out] | Point | point
[in] | Vector | direction vector
[in] | Distance | distance
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxPolyToTri

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Point Math API
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ cvxPolyToTri()

evxErrors cvxPolyToTri | ( | int | PntCount,
 |  | svxPoint * | PntList,
 |  | int * | VtxCount,
 |  | int ** | VtxList
 | ) |  |

#include <zwapi_math_point.h>

Given an array of points "PntList" defining the coordinates of a
polygon's vertices, this function decomposes the polygon into
triangles. The triangles are defined by an array of vertex indices
"VtxList", which is an int list of indices into the PntList array.
Every three elements in the output list define one triangle,
i.e. VtxList[0], VtxList[1] and VtxList[2] contain the PntList array
indices of the first triangle's vertices, VtxList[3], VtxList[4] and
VtxList[5] contain the PntList array indices of the second triangle,
and so on. The total number of triangle vertices is output in
VtxCount. The total number of triangles for the given polygon will be
(*VtxCount)/3.

The points in PntList are assumed to be in vertex order around the
perimeter of the polygon. The polygon may be concave.

This function allocates the output array VtxList. The caller is
responsible for freeing VtxList using cvxMemFree().

Parameters
[in] | PntCount | number of points in point list
[in] | PntList | point list of polygon vertex coordinates
[out] | VtxCount | number of triangle vertex indices in vertex list
[out] | VtxList | vertex list of triangle vertex indices (see description below)
Return values
succeeds
  • ZW_API_NO_ERROR - the polygon is successfully tessellated into triangles.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Vector API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Vector API
Math

Detailed Description

THE MODULE FOR THE ZW3D Vector API

Vector

void | cvxVecInit (svxPoint *Point1, svxPoint *Point2, svxVector *Vector)
void | cvxVecNormalize (svxVector *Vector)
void | cvxVecAngle (svxVector *V1, svxVector *V2, double *Angle)
void | cvxVecCross (svxVector *V1, svxVector *V2, svxVector *Cross)
void | cvxVecPerp (svxVector *Vector, svxVector *Perp)
void | cvxVecReverse (svxVector *Vector)
int | cvxVecParallelChk (int Orient, svxVector *V1, svxVector *V2, double CosTol)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecAngle()

void cvxVecAngle | ( | svxVector * | V1,
 |  | svxVector * | V2,
 |  | double * | Angle
 | ) |  |

#include <zwapi_math_vector.h>

Calculates the angle (radians) between the input vectors.

Parameters
[in] | V1 | first vector
[in] | V2 | second vector
[out] | Angle | angle (radians) between vectors
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecCross

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecCross()

void cvxVecCross | ( | svxVector * | V1,
 |  | svxVector * | V2,
 |  | svxVector * | Cross
 | ) |  |

#include <zwapi_math_vector.h>

Gets the cross product of two vectors.

Parameters
[in] | V1 | first vector
[in] | V2 | second vector
[out] | Cross | cross product of V1 and V2
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecInit()

void cvxVecInit | ( | svxPoint * | Point1,
 |  | svxPoint * | Point2,
 |  | svxVector * | Vector
 | ) |  |

#include <zwapi_math_vector.h>

Initializes a normalized "Vector" that points along
the direction from "Point1" to "Point2".

Parameters
[in] | Point1 | first point
[in] | Point2 | second point
[out] | Vector | direction vector
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecNormalize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecNormalize()

void cvxVecNormalize ( svxVector * Vector )

#include <zwapi_math_vector.h>

Normalizes a direction vector to unit magnitude (1.0).

Parameters
[in,out] Vector direction vector
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecParallelChk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecParallelChk()

int cvxVecParallelChk | ( | int | Orient,
 |  | svxVector * | V1,
 |  | svxVector * | V2,
 |  | double | CosTol
 | ) |  |

#include <zwapi_math_vector.h>

Determine whether two vectors are parallel within a specified angular tolerance.

The CosTol tolerance is the cosine of the maximum angle allowed between the
vectors for them to be considered parallel. The table below shows the maximum
angle allowed between the vectors (right) for several values of CosTol (left):

                     CosTol               degrees
                     0.9          -        25.84
                     0.9848       -          10
                     0.9962       -          5
                     0.9986       -          3
                     0.9994       -          2
                     0.99985      -          1
                     0.99996      -         0.5
                     0.999998     -         0.1
Parameters
[in] Orient 0 = parallel vectors can be in same or opposite direction
1 = Parallel vectors must point in same direction
2 = Parallel vectors must point in opposite directions
[in] | V1 | first vector
[in] | V2 | second vector
[in] | CosTol | cosine of maximum angle allowed for parallelism
Return values
return
  • 1: vectors are parallel; if Orient is 1, the vectors also point in the same direction; if Orient is 2, the vectors point in opposite directions.
  • 0: vectors are NOT parallel, or are not oriented with respect to each other as required by Orient, or at least one vector degenerates to zero length, or error occurs.
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecPerp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecPerp()

void cvxVecPerp | ( | svxVector * | Vector,
 |  | svxVector * | Perp
 | ) |  |

#include <zwapi_math_vector.h>

Creates a vector that is perpendicular to another vector.

Parameters
[in] | Vector | reference vector
[out] | Perp | vector perpendicular to input "Vector"
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxVecReverse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Vector API
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ cvxVecReverse()

void cvxVecReverse ( svxVector * Vector )

#include <zwapi_math_vector.h>

Reverses the direction of the input vector.

Parameters
[in,out] Vector vector
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: UI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
UI

Detailed Description

Modules

Combobox
UI Data
Form
Gui Set
List Widget
Popup Form
Ribbon
Slider
Table Widget
Tab Widget
Tree View
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Combobox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Combobox
UI

Detailed Description

THE MODULE FOR THE ZW3D Combobox API

Combobox

evxErrors | cvxComboCurrentItem (const char *sForm, int fldId, int *curIdx)
evxErrors | cvxComboSetCurrentItem (const char *sForm, int field, int item)
evxErrors | cvxComboCurrentText (const char *sForm, int idField, char *text, int sizeText)
evxErrors | cvxComboCurrentTextSet (const char *sForm, int idField, const char *text)
evxErrors | cvxComboItemCount (const char *sForm, int idField, int *count)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxComboCurrentItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Combobox
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ cvxComboCurrentItem()

evxErrors cvxComboCurrentItem | ( | const char * | sForm,
 |  | int | fldId,
 |  | int * | curIdx
 | ) |  |

#include <zwapi_ui_combobox.h>

Get the item index in the combobox widget of a form.

Parameters
[in] | sForm | form name
[in] | fldId | field id
[out] | curIdx | current index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxComboCurrentText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Combobox
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ cvxComboCurrentText()

evxErrors cvxComboCurrentText | ( | const char * | sForm,
 |  | int | idField,
 |  | char * | text,
 |  | int | sizeText
 | ) |  |

#include <zwapi_ui_combobox.h>

Get the item text in the combobox widget of a form.

Parameters
[in] | sForm | form name
[in] | idField | field id
[out] | text | current text
[in] | sizeText | sizeof test
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxComboCurrentTextSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Combobox
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ cvxComboCurrentTextSet()

evxErrors cvxComboCurrentTextSet | ( | const char * | sForm,
 |  | int | idField,
 |  | const char * | text
 | ) |  |

#include <zwapi_ui_combobox.h>

Set the item text in the combobox widget of a form.

Parameters
[in] | sForm | form name
[in] | idField | field id
[in] | text | current text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxComboItemCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Combobox
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ cvxComboItemCount()

evxErrors cvxComboItemCount | ( | const char * | sForm,
 |  | int | idField,
 |  | int * | count
 | ) |  |

#include <zwapi_ui_combobox.h>

Get the count of items in the combobox widget of a form.

Parameters
[in] | sForm | form name
[in] | idField | field id
[out] | count | count of items
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxComboSetCurrentItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Combobox
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ cvxComboSetCurrentItem()

evxErrors cvxComboSetCurrentItem | ( | const char * | sForm,
 |  | int | field,
 |  | int | item
 | ) |  |

#include <zwapi_ui_combobox.h>

Set the id of current selected item.

Parameters
[in] | sForm | form name
[in] | field | field number
[in] | item | index
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: UI Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
UI Data
UI

Detailed Description

THE MODULE FOR THE ZW3D Generic Data Types and Structures of the functions of UI Controls.

Form Add To Data

enum | evxFormAddTo { VX_FILE_BROWSER , VX_UI_MANAGER }
form type that the "Form" add to More...
typedef enum evxFormAddTo | evxFormAddTo
form type that the "Form" add to

Form Function Data

enum evxFormAction {
VX_FORM_INIT = -4 , VX_FORM_CANCEL = -3 , VX_FORM_RESET = -2 , VX_FORM_APPLY = -1 ,
VX_FORM_OKAY = 0 , VX_FORM_DEFAULT = 1
}
gui form action (see cvxFormFunc()) More...
typedef enum evxFormAction | evxFormAction
gui form action (see cvxFormFunc())
typedef struct svxFormInfo | svxFormInfo
form info that the "Form" add to. When user wants to add a form to UI manager or File browser by using dll,
he has to create svxFormInfo to store form information and Use cvxFormInsertTo() or cvxFormAddTO() to add.

Form Field Data

enum evxFormFldClass {
VX_FORM_FLD_NULL = -1 , VX_FORM_FLD_NUM = 0 , VX_FORM_FLD_SLIDER = 1 , VX_FORM_FLD_TXT_IN = 2 ,
VX_FORM_FLD_TXT_OUT = 3 , VX_FORM_FLD_TXT_BTN = 4 , VX_FORM_FLD_TXT_LBL = 5 , VX_FORM_FLD_DATA = 6 ,
VX_FORM_FLD_LIST = 7 , VX_FORM_FLD_OPT = 8 , VX_FORM_FLD_BTNS = 9 , VX_FORM_FLD_GROUP = 10 ,
VX_FORM_FLD_LABEL = 11 , VX_FORM_FLD_SEPARATOR = 12 , VX_FORM_FLD_COLOR = 13 , VX_FORM_FLD_TREE = 14 ,
VX_FORM_FLD_COMBO = 15 , VX_FORM_FLD_TAB = 16 , VX_FORM_FLD_PROGRESS = 17 , VX_FORM_FLD_TABLE = 18
}
gui form template field (i.e. widget) classes More...
enum evxCmdFldClass {
VX_CMD_FLD_NULL = 0 , VX_CMD_FLD_TEXT = 1 , VX_CMD_FLD_NUM = 2 , VX_CMD_FLD_DIST = 3 ,
VX_CMD_FLD_ANGLE = 4 , VX_CMD_FLD_POINT = 5 , VX_CMD_FLD_ENTITY = 6 , VX_CMD_FLD_OPTION = 7 ,
VX_CMD_FLD_CONT = 8 , VX_CMD_FLD_FORM = 9 , VX_CMD_FLD_WIN = 10 , VX_CMD_FLD_CMD = 11 ,
VX_CMD_FLD_PIN = 12 , VX_CMD_FLD_OPTGROUP = 13 , VX_CMD_FLD_NUMUNIT = 14 , VX_CMD_FLD_CUSTOMINPUT = 15 ,
VX_CMD_FLD_PICK = 16
}
command template field classes More...
typedef enum evxFormFldClass | evxFormFldClass
gui form template field (i.e. widget) classes
typedef enum evxCmdFldClass | evxCmdFldClass
command template field classes
typedef struct svxTplFld | svxTplFld
template field data

Cursor Management Data

enum evxCursorType {
VX_CURSOR_STD = 0 , VX_CURSOR_MOUSE = 1 , VX_CURSOR_BUSY = 2 , VX_CURSOR_WRENCH = 3 ,
VX_CURSOR_PLIERS = 4 , VX_CURSOR_SCREW_DRIVER = 5 , VX_CURSOR_HAMMER = 6 , VX_CURSOR_TOGGLE = 7 ,
VX_CURSOR_HAND = 8 , VX_CURSOR_WRENCH_PLUS = 9
}
cursor display type More...
typedef enum evxCursorType evxCursorType
cursor display type

List Widget Data

enum evxUiEvt {
VX_UIEVT_INVALID = -6 , VX_UIEVT_HELP = -5 , VX_UIEVT_CANCEL = -3 , VX_UIEVT_RESET = -2 ,
VX_UIEVT_APPLY = -1 , VX_UIEVT_OKAY = 0 , VX_UIEVT_DEF = 1 , VX_UIEVT_LBTNCLK ,
VX_UIEVT_LBTNUP = VX_UIEVT_LBTNCLK , VX_UIEVT_MBTNCLK , VX_UIEVT_RBTNCLK , VX_UIEVT_LBTNDCLK ,
VX_UIEVT_CHAR , VX_UIEVT_FOCUSKILL , VX_UIEVT_SCROLL , VX_UIEVT_HOTKEY ,
VX_UIEVT_CMDONOFF , VX_UIEVT_FOCUSSET , VX_UIEVT_STRING , VX_UIEVT_HOVER ,
VX_UIEVT_LBTNDOWN , VX_UIEVT_SORT , VX_UIEVT_DATACHANGE , VX_UIEVT_PREVIEW ,
VX_UIEVT_SELCHANGED = 19 , VX_UIEVT_STATECHANGED , VX_UIEVT_MOUSEMOVE , VX_UIEVT_DROP = 22 ,
VX_UIEVT_IGNORE
}
UI event type. More...
typedef enum evxUiEvt | evxUiEvt
UI event type.
typedef struct svxListCallBackParam | svxListCallBackParam
ListWidget event date.

Table Callback Data

enum evxTableEvent {
VX_LEFT_CLICK = 2 , VX_RIGHT_CLICK = 4 , VX_LEFT_DOUBLE_CLICK , VX_KEY_UP_DOWN ,
VX_HOT_KEY = 9 , VX_SORT = 15 , VX_DATA_CHANGED , VX_CELL_BUTTON_CLICKED ,
VX_MOUSE_MOVE = 21 , VX_CELL_CLOSE_EDITOR = 23
}
table widget event types More...
enum | evxTableAlignFlag { VX_TABLE_ALIGN_CENTER = 0 , VX_TABLE_ALIGN_LEFT = 1 , VX_TABLE_ALIGN_RIGHT = 2 }
table widget alignment mode More...
enum | evxTableResizeMode { VX_TABLE_RESIZE_MODE_INTERACTIVE = 0 , VX_TABLE_RESIZE_MODE_STRETCH = 1 , VX_TABLE_RESIZE_MODE_FIXED = 2 , VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS = 3 }
table widget resize mode More...
enum | evxDateType { VX_DATE_WITH_TIME , VX_DATE_ONLY }
data type More...
typedef enum evxTableEvent | evxTableEvent
table widget event types
typedef enum evxTableAlignFlag | evxTableAlignFlag
table widget alignment mode
typedef enum evxTableResizeMode | evxTableResizeMode
table widget resize mode
typedef struct svxKeyEvent | svxKeyEvent
keyboard event
typedef enum evxDateType | evxDateType
data type
typedef struct svxTableCellData | svxTableCellData
table cell data
typedef struct svxTableCallBackParam | svxTableCallBackParam
table widget callback function parameters

Tree Widget Header Data

enum | evxAlignFlag { VX_ALIGN_CENTER = 0 , VX_ALIGN_LEFT = 1 , VX_ALIGN_RIGHT = 2 }
ui alignment types More...
typedef enum evxAlignFlag | evxAlignFlag
ui alignment types

Table Cell Data

enum evxTableCellType {
VX_TABLECELL_TYPE_TEXT = 0 , VX_TABLECELL_TYPE_COMBOBOX = 1 , VX_TABLECELL_TYPE_CHECKBOX = 2 , VX_TABLECELL_TYPE_INDEX_COMBOBOX = 3 ,
VX_TABLECELL_TYPE_INPUT_COMBOBOX = 4 , VX_TABLECELL_TYPE_TEXT_BUTTON = 5 , VX_TABLECELL_TYPE_DATE = 6 , VX_TABLECELL_TYPE_COLOR = 7 ,
VX_TABLECELL_TYPE_NUMBER = 8
}
table cell types More...
typedef enum evxTableCellType evxTableCellType
table cell types

Tree Item Data

enum evxTreeItemFlag {
VX_TREE_NO_ITEM_FLAGS = 0x0000 , VX_TREE_IS_SELECTABLE = 0x0001 , VX_TREE_IS_EDITABLE = 0x0002 , VX_TREE_IS_DRAG_ENABLE = 0x0004 ,
VX_TREE_IS_DROP_ENABLE = 0x0008 , VX_TREE_IS_CHECKABLE = 0x0010 , VX_TREE_IS_ENABLE = 0x0020 , VX_TREE_IS_TRISTATE = 0x0040 ,
VX_TREE_ITEM_NEVER_HAS_CHILDREN = 0x0080 , VX_TREE_ITEM_IS_USER_TRISTATE = 0x0100 , VX_TREE_ITEM_IS_GRAY = 0x00010000
}
tree item data More...
enum | evxTreeItemType { VX_ITEM = 0 , VX_FINISHMARK = 1 }
tree widget item types More...
enum evxTreeEvent {
VX_EMPTY = 0 , VX_LEFT_DOWN , VX_LEFT_UP , VX_MIDDLE_DOWN ,
VX_MIDDLE_UP , VX_RIGHT_DOWN , VX_RIGHT_UP , VX_BOX_SELECTION_DONE ,
VX_LABEL_CHANGED , VX_EDITOR_CLOSED , VX_DBL_LEFT , VX_DROP ,
VX_KEY_PRESS , VX_HOVER , VX_HOVER_TIMEOUT , VX_ENTER ,
VX_LEAVE
}
tree widget event types More...
enum evxTreeHitPos {
VXTHP_BUTTON = 0x0001 , VXTHP_ICON = 0x0002 , VXTHP_LABEL = 0x0004 , VXTHP_ITEM = 0x0006 ,
VXTHP_SPACE = 0x0008 , VXTHP_CHECKBOX = 0x0010 , VXTHP_APD_ICON1 = 0x0020 , VXTHP_APD_ICON2 = 0x0040 ,
VXTHP_HEADER = 0x0080
}
tree widget element codes More...
typedef enum evxTreeItemFlag | evxTreeItemFlag
tree item data
typedef int | vxTreeItemId
integer tree widget item id More...
typedef enum evxTreeItemType | evxTreeItemType
tree widget item types
typedef enum evxTreeHitPos | evxTreeHitPos
tree widget element codes
typedef struct svxTreeCbParam | svxTreeCbParam
tree widget callback function parameters

Tree Item State Data

enum | evxTreeCheckState { VX_TREE_ITEM_UNCHECKED , VX_TREE_ITEM_BLACK_CHECKED = 4 }
check tree item state More...
typedef enum evxTreeCheckState | evxTreeCheckState
check tree item state

Table Attribute Data

typedef struct svxTableAt | svxTableAt
table attributes
typedef struct svxRectangle | svxRectangle
Rectangle data.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: vxTreeItemId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ vxTreeItemId

typedef int vxTreeItemId

#include <zwapi_ui_data.h>

integer tree widget item id

Definition at line 472 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: Form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Form
UI

Detailed Description

THE MODULE FOR THE ZW3D Form API

Form Creation

evxErrors | cvxFormCreate (char *Form, int Display)
void | cvxFormShow (char *Form)
void | cvxFormHide (char *Form)
void | cvxFormKill (char *Form)
void | cvxFormLogKill (char *Form)
void | cvxFormRefresh (char *Form)
int | cvxFormWait (char *Form)
void | cvxFormWaitExit (int ReturnValue)
evxErrors | cvxFormGetSize (const char *Form, int *Width, int *Height)
evxErrors | cvxFormResize (char *Form, int Width, int Height)
evxErrors | cvxFormAdjustSize (const char *Form)

Form Add To

void | cvxFormAddTo (const char *Form, evxFormAddTo addTo)
evxErrors | cvxFormInsertTo (const svxFormInfo *FormInfo, int Index, evxFormAddTo AddTo)
void | cvxFormRemoveFrom (const char *Form, evxFormAddTo removeFrom)

Form Set

void | cvxFormTitleGet (char *Form, int NumBytes, char *Title)
void | cvxFormTitleSet (char *Form, char *Title)
evxErrors | cvxFormDataGet (char *Form, char **Data)
evxErrors | cvxFormDataSet (char *Form, char *Data)

Form Function

void | cvxFormFunc (vxName Name, void *Function, double Code)
void | cvxFormCallback (vxName Name, void *Function)
evxErrors | cvxFormFieldGetCallback (const char *form, int field, void **callback)

Form State

void | cvxFormActiveField (int *idField)
int | cvxFormState (char *Form)
evxErrors | cvxFormVisibleSet (evxEnvironment Environment, const char *Form, int State, evxFormAddTo Type)
evxErrors | cvxFormFieldVisSet (const char *form, int field, int state)

Form Field

evxErrors | cvxFormInqFld (vxName Name, int *Count, svxTplFld **Fields)
evxErrors | cvxTplInqFields (const vxName Name, int *NumFld, int **idFields)
evxErrors | cvxTplInqFieldType (const vxName Name, int idField, evxCmdFldClass *Type)
evxErrors | cvxTplInqFieldOptions (const vxName Name, int idField, int NumBytes, char *Options)
void | cvxFormUpdate (int idField)
void | cvxFieldFocusSet (char *Form, int idField)
void | cvxFieldNumItems (char *Form, int idField, int *NumItems)
void | cvxFieldClear (char *Form, int idField)
void | cvxFieldDisable (char *Form, int idField)
void | cvxFieldEnable (char *Form, int idField)
int | cvxFieldEnableGet (char *Form, int idField)
void | cvxFilterItemApply (const char *panelName, const char *filterItem)
void | cvxFieldImageSet (char *Form, int idField, char *Image)
void | cvxFieldCaretSet (char *Form, int idField, int Position)
evxErrors | cvxFieldTipSet (const char *sForm, int idField, const char *tip)
evxErrors | cvxFieldInitFont (const char *Form, int idField, const char *Name, int hasZwFont)

Form Item

void | cvxItemAdd (char *Form, int idField, const char *Text)
void | cvxItemGet (char *Form, int idField, int idItem, char *Text)
void | cvxItemSet (char *Form, int idField, int idItem, char *Text)
void | cvxItemModify (const char *Form, int idField, int idItem, const char *Text)
void | cvxItemDel (char *Form, int idField, int idItem)
void | cvxItemFind (char *Form, int idField, char *Text, int *idItem)
void | cvxItemCbxSet (char *Form, int idField, int idItem, int isOn)
void | cvxItemSelect (char *Form, int idField, int idItem)
void | cvxItemSelectText (char *Form, int idField, char *Text)
void | cvxItemSelected (char *Form, int idField, int *idItem)
void | cvxItemStateGet (char *Form, int idField, int idItem, int *isOn)
void | cvxItemStateSet (char *Form, int idField, int idItem, int isOn)
evxErrors | cvxItemGetCheckState (char *Form, int idField, int idItem, int *checkState)
evxErrors | cvxItemVisibleSet (const char *Form, int idField, int idItem, int state)
evxErrors | cvxItemVisibleGet (const char *Form, int idField, int idItem, int *state)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldCaretSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldCaretSet()

void cvxFieldCaretSet | ( | char * | Form,
 |  | int | idField,
 |  | int | Position
 | ) |  |

#include <zwapi_ui_form.h>

Sets the position of the text caret (i.e. cursor) in the text string
associated with the specified GUI form field.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | Position | character position numbered from zero (-1 to set caret at end)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldClear()

void cvxFieldClear | ( | char * | Form,
 |  | int | idField
 | ) |  |

#include <zwapi_ui_form.h>

Deletes all text items contained in the specified "w_list", or "w_combo" field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldDisable()

void cvxFieldDisable | ( | char * | Form,
 |  | int | idField
 | ) |  |

#include <zwapi_ui_form.h>

Disable the specified GUI form field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldEnable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldEnable()

void cvxFieldEnable | ( | char * | Form,
 |  | int | idField
 | ) |  |

#include <zwapi_ui_form.h>

Enable the specified GUI form field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldEnableGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldEnableGet()

int cvxFieldEnableGet | ( | char * | Form,
 |  | int | idField
 | ) |  |

#include <zwapi_ui_form.h>

Get the enable state of the specified form field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
Return values
return
  • 1 - the field is enable
  • 0 - the field is not enable or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldFocusSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldFocusSet()

void cvxFieldFocusSet | ( | char * | Form,
 |  | int | idField
 | ) |  |

#include <zwapi_ui_form.h>

If possible, sets the focus for user input to the specified field of the specified form.

If this function does not work, especially for a command form displayed
in the ZW3D Manager area, try calling cvxCmdSend("@@idField"),
where "idField" is the actual integer value of the variable "idField".
For example, if "idField=3", call cvxCmdSend("@@3").

Parameters
[in] | Form | GUI form name
[in] | idField | field id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldImageSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldImageSet()

void cvxFieldImageSet | ( | char * | Form,
 |  | int | idField,
 |  | char * | Image
 | ) |  |

#include <zwapi_ui_form.h>

Assigns the specified image to the specified label field.
ZW3D looks in the default search paths for the image file.
See cvxPathFind().

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | label field id
[in] | Image | image file name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldInitFont

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldInitFont()

evxErrors cvxFieldInitFont | ( | const char * | Form,
 |  | int | idField,
 |  | const char * | Name,
 |  | int | hasZwFont
 | ) |  |

#include <zwapi_ui_form.h>

Initializes an input field for selecting a font. This function is
intended for use when initializing a form. It can be called during
initialization of a GUI form or from the "init_after" callback
function of an "Options" form.

It is assumed the form has an option (integer) field "idField" that
has a combo box widget. Any prior contents of the combo box list are
discarded, and the combo box list is filled with the names of fonts
currently available on the local computer. If "Name" is a non-empty
string that matches the name of one of those fonts, that font becomes
the default selection in the combo box.

To apply this function to an "Options" form, input "OptForm" as the
value of the "Form" argument.

It is recommended that the form's field "idField" should reference the
global variable "VgRdTxtFont" to hold the index of the selected item.
This will synchronize the default font selection with the font
selection fields in native ZW3D commands. This function updates
"VgRdTxtFont" if a match to "Name" is found. If "Name" does not match
any font name, the current value of "VgRdTxtFont" selects the default
item in the combo box list.

When working with an "Options" form, the usual practice for managing a
font input field is to use an option field having a combo box for the
font names, and to use a hidden text field in the form's data
container to hold the name of the selected font. In the form's
"init_after" callback, call this function with the contents of the
hidden field as the "Name" argument. In the form's "function"
callback, query the combo box for the text of the selected item, save
the text to the hidden field, and use the text wherever the font name
is needed. If the combo box cannot be queried because the "Options"
form is not active (such as during regeneration), use whatever text
was previously saved in the hidden field as the font name. For
example, an "init_after" callback might include this snippet of code
to initialize a font selection combo box in field 5, with a hidden
text field 4 that might contain the name of a previously selected font
(the data container is specified by "idData").

Note
The font name will be an empty string if field 4 does not exist:
svxData dataFontName;
cvxDataGet(idData, 4, &dataFontName);
cvxFieldInitFont("OptForm", 5, dataFontName.Text);
cvxDataGet
evxErrors cvxDataGet(int idData, int idField, svxData *Data)
cvxFieldInitFont
evxErrors cvxFieldInitFont(const char *Form, int idField, const char *Name, int hasZwFont)
svxData::Text
char Text[512]
text string (expression if "isNumber=1")
Definition: zwapi_util.h:1586
svxData
command input data item
Definition: zwapi_util.h:1555
The command's "function" callback might include this snippet to get the font name:
svxData dataFontIndex, dataFontName;
char font[sizeof(dataFontName.Text)];
// Get previously saved font name (will be an empty string if
// hidden field 4 does not exist) and index of selected font.
if (cvxDataGet(idData, 4, &dataFontName))
dataFontName.isText = 1;
if (cvxDataGet(idData, 5, &dataFontIndex)
return 1;
// Look up name of selected font.
cvxItemGet("OptForm", 5, (int)dataFontIndex.Num, font);
if (strlen(font) > 0)
strcpy(dataFontName.Text, font);
// Replace contents of hidden field with selected font name.
cvxDataDel(idData, 4);
cvxDataSet(idData, 4, dataFontName);
cvxDataToFeature(idData, 0, 1);
cvxDataToFeature
evxErrors cvxDataToFeature(int idData, int idFeature, int ExcludeRegen)
cvxDataDel
evxErrors cvxDataDel(int idData, int idField)
cvxDataSet
evxErrors cvxDataSet(int idData, int idField, svxData *Data)
cvxItemGet
void cvxItemGet(char *Form, int idField, int idItem, char *Text)
svxData::Num
double Num
numeric value
Definition: zwapi_util.h:1581
svxData::isText
char isText
1 if "Text" is defined, else 0
Definition: zwapi_util.h:1561
Parameters
[in] | Form | GUI form name
[in] | idField | id of form field for font combo box
[in] | Name | name of default font, may be NULL
[in] | hasZwFont | judge if fonts have ZW fonts.1:include ZW fonts,0:no ZW fonts
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldNumItems

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldNumItems()

void cvxFieldNumItems | ( | char * | Form,
 |  | int | idField,
 |  | int * | NumItems
 | ) |  |

#include <zwapi_ui_form.h>

Gets the number of items associated with a field. This is
primarily for querying the number of items associated with a
w_list, w_opt, w_btn, w_tree, w_combo, w_tab, or w_table widget.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[out] | NumItems | number of items associated with the field
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFieldTipSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFieldTipSet()

evxErrors cvxFieldTipSet | ( | const char * | sForm,
 |  | int | idField,
 |  | const char * | tip
 | ) |  |

#include <zwapi_ui_form.h>

Set tip to specified item of the form.

Parameters
[in] | sForm | form name
[in] | idField | field id
[in] | tip | tip for setting
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFilterItemApply

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFilterItemApply()

void cvxFilterItemApply | ( | const char * | panelName,
 |  | const char * | filterItem
 | ) |  |

#include <zwapi_ui_form.h>

Apply the specified filter item to the current command's field. Make sure
that "FilterItem" could be found.
If the specified panel is current pick panel, update the ui of pick tool.
Otherwise, just apply the filter item.

Parameters
[in] | panelName | entity pick filter panel
[in] | filterItem | Filter item name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormActiveField

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormActiveField()

void cvxFormActiveField ( int * idField )

#include <zwapi_ui_form.h>

Outputs the ID of the active field of the active template-driven GUI form.
Outputs "idField = 0" if the active field cannot be determined.

Parameters
[out] idField active field id
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormAddTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormAddTo()

void cvxFormAddTo | ( | const char * | Form,
 |  | evxFormAddTo | addTo
 | ) |  |

#include <zwapi_ui_form.h>

Add specified form to file browser.

Parameters
[in] | Form | form name
[in] | addTo | form type that the "Form" add to
Warning
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormAdjustSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormAdjustSize()

evxErrors cvxFormAdjustSize ( const char * Form )

#include <zwapi_ui_form.h>

Auto adjust the form size when its children are changed (hidden or modified).

Parameters
[in] Form form name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormCallback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormCallback()

void cvxFormCallback | ( | vxName | Name,
 |  | void * | Function
 | ) |  |

#include <zwapi_ui_form.h>

Registers a pointer to a callback function referenced by name
in the definition of a GUI form template field (e.g. "callback=MyCallback").

Function pointers should be registered in the "Init" function
called when your library is dynamically loaded by ZW3D at runtime.

The callback function should be of the following type:

int Callback(char *FormName, int idField, int idItem)

If developer wants to unload the DLL plug in file dynamically.
It is a MUST to run cvxCmdFuncUnload() in the exit function.

Parameters
[in] | Name | function name
[in] | Function | function pointer
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormCreate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormCreate()

evxErrors cvxFormCreate | ( | char * | Form,
 |  | int | Display
 | ) |  |

#include <zwapi_ui_form.h>

Creates the specified form in memory and displays it if requested.

Parameters
[in] | Form | GUI form name
[in] | Display | 1 to display form after it is created; else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_CREATE_FAIL
  • ZW_API_FORM_SHOW_FAIL
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormDataGet()

evxErrors cvxFormDataGet | ( | char * | Form,
 |  | char ** | Data
 | ) |  |

#include <zwapi_ui_form.h>

Encodes the data associated with the specified GUI form in a
null-terminated ascii string. Memory for the output string
is allocated by this function and should be deallocated by
the calling procedure. Only field items numbered 1 or more
are encoded.

The string has the following format:

Version,FormName,Field_Id,ItemCnt,IsOn,ItemData,IsOn,ItemData...,
Field_Id,ItemCnt,...

It is assumed no item exceeds 1024 bytes in its text-encoded form.

If a field is flagged with the "is_distance" option, the text string
associated with it is converted from user to database units if the
string contains a constant value.

Parameters
[in] | Form | GUI form name
[out] | Data | GUI data encoded in a null-terminated string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormDataSet()

evxErrors cvxFormDataSet | ( | char * | Form,
 |  | char * | Data
 | ) |  |

#include <zwapi_ui_form.h>

Uses the data encoded in "text" to initialize the specified GUI form.

See also
cvxFormDataGet().
Parameters
[in] | Form | GUI form name
[in] | Data | GUI data encoded in a null-terminated string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormFieldGetCallback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormFieldGetCallback()

evxErrors cvxFormFieldGetCallback | ( | const char * | form,
 |  | int | field,
 |  | void ** | callback
 | ) |  |

#include <zwapi_ui_form.h>

Get callback function of specified field.

Parameters
[in] | form | form name
[in] | field | field
[out] | callback | callback function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormFieldVisSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormFieldVisSet()

evxErrors cvxFormFieldVisSet | ( | const char * | form,
 |  | int | field,
 |  | int | state
 | ) |  |

#include <zwapi_ui_form.h>

Set the visibility of the specified field in the form.

Parameters
[in] | form | form name
[in] | field | field id
[in] | state | (1/0)visible or not
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormFunc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormFunc()

void cvxFormFunc | ( | vxName | Name,
 |  | void * | Function,
 |  | double | Code
 | ) |  |

#include <zwapi_ui_form.h>

Registers a function referenced by the "function=" field in
a GUI form template definition.

Callback functions should be registered in the "Init" function
called when your library is dynamically loaded by ZW3D at runtime.

The function should be the following type:

int FormFunction(int FormAction, int *UnusedInteger)

See evxFormAction for possible values of "int FormAction".

See the "Gui Forms" section of the API documentation for a
description of how to define a GUI form using a text-based
template.

If developer wants to unload the DLL plug in file dynamically.
It is a MUST to run cvxCmdFuncUnload() in the exit function.

Parameters
[in] | Name | function name
[in] | Function | function pointer
[in] | Code | ZW3D licensing code or 0.0
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormGetSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormGetSize()

evxErrors cvxFormGetSize | ( | const char * | Form,
 |  | int * | Width,
 |  | int * | Height
 | ) |  |

#include <zwapi_ui_form.h>

Get the size of specified GUI form.

Parameters
[in] | Form | form name
[out] | Width | width of the form
[out] | Height | height of the form
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormHide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormHide()

void cvxFormHide ( char * Form )

#include <zwapi_ui_form.h>

Hide the specified GUI form.

Parameters
[in] Form GUI form name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormInqFld

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormInqFld()

evxErrors cvxFormInqFld | ( | vxName | Name,
 |  | int * | Count,
 |  | svxTplFld ** | Fields
 | ) |  |

#include <zwapi_ui_form.h>

Gets abbreviated information about the fields associated
with a GUI form template. The calling procedure MUST
deallocate the output list.

Parameters
[in] | Name | template name
[out] | Count | number of template fields
[out] | Fields | list of template fields
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormInsertTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormInsertTo()

evxErrors cvxFormInsertTo | ( | const svxFormInfo * | FormInfo,
 |  | int | Index,
 |  | evxFormAddTo | AddTo
 | ) |  |

#include <zwapi_ui_form.h>

Add specified form to file browser or ui manager. We show in all environments as default.
If want to hide in some environment, please use cvxFormVisibleSet.

Parameters
[in] | FormInfo | form information that the "Form" add to
[in] | Index | position that the form insert to, only support VX_UI_MANAGER type
[in] | AddTo | form type that the "Form" add to
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormKill

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormKill()

void cvxFormKill ( char * Form )

#include <zwapi_ui_form.h>

Kills (i.e. cancel and undisplay) the specified GUI form.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] Form GUI form name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormLogKill

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormLogKill()

void cvxFormLogKill ( char * Form )

#include <zwapi_ui_form.h>

Log specified form, the form will be auto kill when root object exit.

Parameters
[in] Form form name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormRefresh

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormRefresh()

void cvxFormRefresh ( char * Form )

#include <zwapi_ui_form.h>

Refreshes display of the specified GUI form.
Input "OptForm" to apply this function to the active "Options" form.

Parameters
[in] Form GUI form name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormRemoveFrom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormRemoveFrom()

void cvxFormRemoveFrom | ( | const char * | Form,
 |  | evxFormAddTo | removeFrom
 | ) |  |

#include <zwapi_ui_form.h>

Remove specified form to file browser.

Parameters
[in] | Form | form name
[in] | removeFrom | form type that the "Form" add to
Warning
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormResize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormResize()

evxErrors cvxFormResize | ( | char * | Form,
 |  | int | Width,
 |  | int | Height
 | ) |  |

#include <zwapi_ui_form.h>

Set the size of specified form.

Parameters
[in] | Form | form name
[in] | Width | width of the form
[in] | Height | height of the form
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormShow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormShow()

void cvxFormShow ( char * Form )

#include <zwapi_ui_form.h>

Shows (i.e. display) the specified GUI form.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] Form GUI form name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormState()

int cvxFormState ( char * Form )

#include <zwapi_ui_form.h>

Determine form state.

Parameters
[in] Form GUI form name
Return values
return
  • 0 if the specified form has not been created in memory.
  • 1 if the form is created but not displayed.
  • 2 if the form is created and displayed.
Warning
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormTitleGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormTitleGet()

void cvxFormTitleGet | ( | char * | Form,
 |  | int | NumBytes,
 |  | char * | Title
 | ) |  |

#include <zwapi_ui_form.h>

Gets the specified form's caption title (if it has one) and stores it
as a null-terminated string in the memory referenced by "Title". If
the string is longer than "NumBytes", it is truncated.

Parameters
[in] | Form | GUI form name
[in] | NumBytes | number of bytes of memory referenced by "Title"
[out] | Title | form title (null-terminated text string)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormTitleSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormTitleSet()

void cvxFormTitleSet | ( | char * | Form,
 |  | char * | Title
 | ) |  |

#include <zwapi_ui_form.h>

Assigns the specified text to the specified form's title bar.

Parameters
[in] | Form | GUI form name
[in] | Title | form title (null-terminated text string)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormUpdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormUpdate()

void cvxFormUpdate ( int idField )

#include <zwapi_ui_form.h>

Updates the specified field of the active "Options" form to
display the numeric input associated with the corresponding
field of the form's data container (i.e. VDATA).

Parameters
[in] idField field id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormVisibleSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormVisibleSet()

evxErrors cvxFormVisibleSet | ( | evxEnvironment | Environment,
 |  | const char * | Form,
 |  | int | State,
 |  | evxFormAddTo | Type
 | ) |  |

#include <zwapi_ui_form.h>

edit the page config about whether to be show in particular environment. the function
currently only supports VX_UI_MANAGER;

ZW3D has entire 13 environments. the corresponding type can see evxEnvironment

Parameters
[in] | Environment | environments
[in] | Form | GUI form name
[in] | State | visibility of form (1: visible; 0: invisible)
[in] | Type | form type that the "Form" set visible
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormWait

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormWait()

int cvxFormWait ( char * Form )

#include <zwapi_ui_form.h>

This function displays the specified GUI form and waits for the
user to press the "Okay", "Apply" or "Cancel" button on the form.
It returns 0 if the user pressed "Cancel", 1 if the user pressed
"Okay" or 2 if the user pressed "Apply".

If you want to cause another widget on the form to cause cvxFormWait()
to return, attach a callback function that invokes cvxFormWaitExit() to
the widget. Whatever integer value is passed to cvxFormWaitExit() will
be returned by this function.

If "Okay" or "Cancel" are pressed, the GUI form is automatically
undisplayed. If this functions returns because the user pressed "Apply"
or because cvxFormWaitExit() was called, the GUI form remains displayed
until the calling application undisplays it using cvxFormKill().

Note
cvxFormKill() can be applied to a form that has already been
undisplayed without any bad consequences.
Parameters
[in] Form GUI form name (null-terminated ascii string)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxFormWaitExit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxFormWaitExit()

void cvxFormWaitExit ( int ReturnValue )

#include <zwapi_ui_form.h>

When a GUI form is displayed with cvxFormWait(), invoking this function
will cause cvxFormWait() to exit and return the integer value passed to
this function. Ordinarily, this function would be invoked from a callback
function associated with the form actively displayed by cvxFormWait().

Parameters
[in] ReturnValue integer value to pass to cvxFormWait ()
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemAdd()

void cvxItemAdd | ( | char * | Form,
 |  | int | idField,
 |  | const char * | Text
 | ) |  |

#include <zwapi_ui_form.h>

Adds a new item to the end of the list associated with the specified "w_list" or "w_combo" field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | Text | item text (NULL to Ignore)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemCbxSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemCbxSet()

void cvxItemCbxSet | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int | isOn
 | ) |  |

#include <zwapi_ui_form.h>

This function is similar to cvxItemSet(), the difference is, this function
is only for checkbox control.
If the field is list widget,add a checkbox for the item.

Note
For different controls,the processing methods are different when the item is -1.
Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[in] | isOn | is on or not
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemDel()

void cvxItemDel | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem
 | ) |  |

#include <zwapi_ui_form.h>

Deletes the specified item from the specified "w_list" or "w_combo" field.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemFind()

void cvxItemFind | ( | char * | Form,
 |  | int | idField,
 |  | char * | Text,
 |  | int * | idItem
 | ) |  |

#include <zwapi_ui_form.h>

Searches the specified "w_list" or "w_combo" field for
the specified text and outputs the corresponding item id.
"idItem" is set to zero if the specified text is not found.

For "Options" form, the id starts form 1, and 0 means it is not set. So item returns 0, indicating that it is not found.

For ListWidget and ComboCheck, the position of the item is transmitted through +1 processing. Therefore, the minimum transmitted position is 0 + 1 =1. Therefore, if the item is 0 ,it means that it is not found.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | Text | item text
[out] | idItem | item id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemGet()

void cvxItemGet | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | char * | Text
 | ) |  |

#include <zwapi_ui_form.h>

Gets the text string associated with the specified item of
the specified field. It is assumed that "Text" references
sufficient memory to hold the output string. See cvxItemSet()
for the meaning of "idItem" for each field type.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[in,out] | Text | item text
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemGetCheckState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemGetCheckState()

evxErrors cvxItemGetCheckState | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int * | checkState
 | ) |  |

#include <zwapi_ui_form.h>

Get item check state of list Widget or tree view.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[out] | checkState | 0:Unchecked, 1:PartiallyChecked, 2:Checked
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemModify

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemModify()

void cvxItemModify | ( | const char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | const char * | Text
 | ) |  |

#include <zwapi_ui_form.h>

Modifies the text associated with the specified item. See
cvxItemSet() for the meaning of "idItem" for each field type.

If the field is a w_list, this function changes the item's icon (if
Text is recognized as the path to an image file) or it changes the
item's text (if Text is not an image file path) without otherwise
re-initializing the item as cvxItemSet() would do. A typical use for
this function is to augment cvxItemAdd() or cvxItemSet() to create a
list item that has both text and an icon: specify the path to the icon
image file as the Text argument using one of the latter two functions,
then call this function to add text to the item.

For all other field types, this function is the same as cvxItemSet().

Input "OptForm" as the form name to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[in] | Text | item text
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemSelect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemSelect()

void cvxItemSelect | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem
 | ) |  |

#include <zwapi_ui_form.h>

Selects the specified item.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemSelected

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemSelected()

void cvxItemSelected | ( | char * | Form,
 |  | int | idField,
 |  | int * | idItem
 | ) |  |

#include <zwapi_ui_form.h>

Outputs the id of the item currently selected in the specified field.
Items are numbered from 1. Outputs 0 if there isn't a selected item.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[out] | idItem | item id
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemSelectText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemSelectText()

void cvxItemSelectText | ( | char * | Form,
 |  | int | idField,
 |  | char * | Text
 | ) |  |

#include <zwapi_ui_form.h>

Selects the specified item.

Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | Text | item text
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemSet()

void cvxItemSet | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | char * | Text
 | ) |  |

#include <zwapi_ui_form.h>

Set the text associated with the specified item.

Form: set Form to "OptForm" to use currently active form.
idField: use "$report" to get the value of the specific field.
idItem: the meaning of "idItem" for each field type is documented below.

1. idField with a label and an input(output) item, such as "ZsCc::Number":
   item = 0: label.
   item = 1: input(output) item.

2. idField with a label and multiple items in a list, such as "ZsCc::ComboBox":
   item = 0: label.
   item = N: insert "Text" into Nth(start from 1),
             and the following items move backward in turn.

3. idField with multiple radio buttons(one as well):
   item = N: Nth item label.
Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[in] | Text | item text (can be NULL)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemStateGet()

void cvxItemStateGet | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int * | isOn
 | ) |  |

#include <zwapi_ui_form.h>

Gets the ON/OFF status of a GUI item.
Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[out] | isOn | 1 if item is ON; 0 if it is OFF
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemStateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemStateSet()

void cvxItemStateSet | ( | char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int | isOn
 | ) |  |

#include <zwapi_ui_form.h>

Gets the ON/OFF status of a GUI item.
Input "OptForm" to apply this function to an "Options" form.

Parameters
[in] | Form | GUI form name
[in] | idField | field id
[in] | idItem | item id
[in] | isOn | 1 if item is ON; 0 if it is OFF
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemVisibleGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemVisibleGet()

evxErrors cvxItemVisibleGet | ( | const char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int * | state
 | ) |  |

#include <zwapi_ui_form.h>

Get the visibility of the field's specialized item.

Parameters
[in] | Form | form name
[in] | idField | field id
[in] | idItem | item number
[out] | state | 1 is visible ,0 is hide
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxItemVisibleSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxItemVisibleSet()

evxErrors cvxItemVisibleSet | ( | const char * | Form,
 |  | int | idField,
 |  | int | idItem,
 |  | int | state
 | ) |  |

#include <zwapi_ui_form.h>

Set the visibility of the field's specialized item.

Parameters
[in] | Form | form name
[in] | idField | field id
[in] | idItem | item number
[in] | state | 1 is visible ,0 is hide
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFieldOptions

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxTplInqFieldOptions()

evxErrors cvxTplInqFieldOptions | ( | const vxName | Name,
 |  | int | idField,
 |  | int | NumBytes,
 |  | char * | Options
 | ) |  |

#include <zwapi_ui_form.h>

Gets the string of the "options" of the specified field for the specified template.

Parameters
[in] | Name | template name
[in] | idField | index of field
[in] | NumBytes | no. bytes of option string
[out] | Options | option string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFields

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxTplInqFields()

evxErrors cvxTplInqFields | ( | const vxName | Name,
 |  | int * | NumFld,
 |  | int ** | idFields
 | ) |  |

#include <zwapi_ui_form.h>

Outputs a list of indices of the fields for the specified template.

The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | Name | template name
[out] | NumFld | number of fields
[out] | idFields | list of fields id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFieldType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Form
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ cvxTplInqFieldType()

evxErrors cvxTplInqFieldType | ( | const vxName | Name,
 |  | int | idField,
 |  | evxCmdFldClass * | Type
 | ) |  |

#include <zwapi_ui_form.h>

Gets the type of the specified field for the specified template.

Parameters
[in] | Name | template name
[in] | idField | index of field
[out] | Type | type of field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Gui Set

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Gui Set
UI

Detailed Description

THE MODULE FOR THE ZW3D UI Setting API

Role management

int | cvxUiSettingsCount (void)
evxErrors | cvxUiSettingsCreate (char *Name, char *Base)
evxErrors | cvxUiSettingsRename (char *Name, char *Dest)
evxErrors | cvxUiSettingsRemove (char *Name)
evxErrors | cvxUiSettingsImport (char *Path)
evxErrors | cvxUiSettingsExport (char *Name, char *Path)
evxErrors | cvxUiSettingsExists (char *Name)
evxErrors | cvxUiSettingsApply (char *Name)
evxErrors | cvxUiSettingsReset (char *Name)
evxErrors | cvxUiSettingsFetch (int i, char *Name)

Cursor Management

void | cvxCursorSet (evxCursorType Type)
void | cvxCursorRestore (void)
void | cvxProgress (int iprogress)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxCursorRestore

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxCursorRestore()

void cvxCursorRestore ( void )

#include <zwapi_ui_guiset.h>

Restores the cursor type that was active prior to the last call to cvxCursorSet.

Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxCursorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxCursorSet()

void cvxCursorSet ( evxCursorType Type )

#include <zwapi_ui_guiset.h>

Changes the active mouse cursor to the specified type.
A call to this function should always be paired with
a subsequent callto cvxCursorRestore().

Parameters
[in] Type cursor type
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxProgress

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxProgress()

void cvxProgress ( int iprogress )

#include <zwapi_ui_guiset.h>

Invoke GUI callback function to display percent progress
or to clear the progress meter if "iprogress < 0".

Parameters
[in] iprogress percent progress (0-100)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsApply

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsApply()

evxErrors cvxUiSettingsApply ( char * Name )

#include <zwapi_ui_guiset.h>

Apply the specified ui settings

Parameters
[in] Name the name of the Settings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsCount()

int cvxUiSettingsCount ( void )

#include <zwapi_ui_guiset.h>

Get the count of ui settings

Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsCreate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsCreate()

evxErrors cvxUiSettingsCreate | ( | char * | Name,
 |  | char * | Base
 | ) |  |

#include <zwapi_ui_guiset.h>

Create a new ui settings based on the given settings

Parameters
[in] | Name | the name of the Settings
[in] | Base | the name of the base Settings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsExists

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsExists()

evxErrors cvxUiSettingsExists ( char * Name )

#include <zwapi_ui_guiset.h>

Test the existence of ui setting by the given name

Parameters
[in] Name the name of the settings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsExport()

evxErrors cvxUiSettingsExport | ( | char * | Name,
 |  | char * | Path
 | ) |  |

#include <zwapi_ui_guiset.h>

Export the specified ui settings to a given path

Parameters
[in] | Name | the name of the settings to be exported
[in] | Path | the path of the settings file exported
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsFetch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsFetch()

evxErrors cvxUiSettingsFetch | ( | int | i,
 |  | char * | Name
 | ) |  |

#include <zwapi_ui_guiset.h>

Get the ui settings name by the given index.

Parameters
[in] | i | the index of the settings to be fetched
[out] | Name | the name of the settings to be fetched
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsImport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsImport()

evxErrors cvxUiSettingsImport ( char * Path )

#include <zwapi_ui_guiset.h>

Import the ui settings file

Parameters
[in] Path the path of the settings file to be imported
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsRemove()

evxErrors cvxUiSettingsRemove ( char * Name )

#include <zwapi_ui_guiset.h>

Remove the specified ui settings

Parameters
[in] Name the name of the Settings to be removed
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsRename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsRename()

evxErrors cvxUiSettingsRename | ( | char * | Name,
 |  | char * | Dest
 | ) |  |

#include <zwapi_ui_guiset.h>

Rename the specified ui settings to the given name

Parameters
[in] | Name | the name of the Settings to be renamed
[in] | Dest | the new name of the Settings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxUiSettingsReset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Gui Set
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ cvxUiSettingsReset()

evxErrors cvxUiSettingsReset ( char * Name )

#include <zwapi_ui_guiset.h>

Set the specified ui settings to its original state

Parameters
[in] Name the name of the settings
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: List Widget

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
List Widget
UI

Detailed Description

THE MODULE FOR THE ZW3D List Widget API

List Widget

evxErrors | cvxListCallbackParamGet (const char *form, int idField, svxListCallBackParam *param)
evxErrors | cvxListItemToolTipSet (const char *form, int field, int row, const char *toolTip)
evxErrors | cvxListItemToolTipGet (const char *form, int field, int row, char *toolTip, int size)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxListCallbackParamGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • List Widget
cvxListCallbackParamGet
cvxListItemToolTipGet
cvxListItemToolTipSet

◆ cvxListCallbackParamGet()

evxErrors cvxListCallbackParamGet | ( | const char * | form,
 |  | int | idField,
 |  | svxListCallBackParam * | param
 | ) |  |

#include <zwapi_ui_listwidget.h>

Get callback parameters for the list widget when the callback function being invoked,
the interface should be used in the callback function.

Note
To use the function, you should add a property of type string-list with the property
name "eventsEnabled" and add the property value "dbl_clk" to the list widget control
in UI file.
Parameters
[in] | form | form name
[in] | idField | field id
[out] | param | param
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxListItemToolTipGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • List Widget
cvxListCallbackParamGet
cvxListItemToolTipGet
cvxListItemToolTipSet

◆ cvxListItemToolTipGet()

evxErrors cvxListItemToolTipGet | ( | const char * | form,
 |  | int | field,
 |  | int | row,
 |  | char * | toolTip,
 |  | int | size
 | ) |  |

#include <zwapi_ui_listwidget.h>

Get the tooltip of specified row item for listWdiget.

Parameters
[in] | form | form name
[in] | field | field id
[in] | row | item row
[out] | toolTip | tooltip
[in] | size | max size of tooltip
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxListItemToolTipSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • List Widget
cvxListCallbackParamGet
cvxListItemToolTipGet
cvxListItemToolTipSet

◆ cvxListItemToolTipSet()

evxErrors cvxListItemToolTipSet | ( | const char * | form,
 |  | int | field,
 |  | int | row,
 |  | const char * | toolTip
 | ) |  |

#include <zwapi_ui_listwidget.h>

Set the tooltip for specified row item of listWdiget.

Parameters
[in] | form | form name
[in] | field | field id
[in] | row | item row
[in] | toolTip | tooltip
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Popup Form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Popup Form
UI

Detailed Description

THE MODULE FOR THE ZW3D Popup Form API

Popup Form

int | cvxPopupShow (const char *name)
evxErrors | cvxPopupDefine (const char *name)
evxErrors | cvxPopupUpdate (const char *Name)
evxErrors | cvxPopupSetVisible (const char *name, int visible)

Sub Menu

evxErrors | cvxPopupMenuCnt (const char *Name, int *cnt)
evxErrors | cvxPopupSubMenuCnt (const char *Name, const char *Sub, int *cnt)
evxErrors | cvxPopupSubMenuItemInsert (const char *Name, const char *Sub, int index, const char *ActName, const char *Label, const char *Script, const char *Icon)
evxErrors | cvxPopupSubMenuItemRemove (const char *name, const char *Sub, int index)
evxErrors | cvxPopupSubMenuActionsRemove (const char *Name, const char *Sub, int iFirst, int iLast)
evxErrors | cvxPopupSubMenuSeparatorInsert (const char *Name, const char *Sub)
evxErrors | cvxPopupSubMenuSetVisible (const char *name, const char *sub, int visible)

Popup Form Item

int | cvxPopupItemIsExist (const char *name, const char *action)
evxErrors | cvxPopupItemInsert (const char *name, int index, const char *Label, const char *Action)
evxErrors | cvxPopupItemRemove (const char *name, int index)
evxErrors | cvxPopupItemActionGet (const char *name, int item, char *Action, int nByte)
evxErrors | cvxPopupItemSetAction (const char *name, int index, const char *Action)
evxErrors | cvxPopupItemLabelGet (const char *name, int item, char *Label, int nByte)
evxErrors | cvxPopupItemCheckedGet (const char *name, int group, int item, int *Check)
evxErrors | cvxPopupItemVisibleGet (const char *name, int item, int *Visible)
evxErrors | cvxPopupItemSetVisibleByAction (const char *name, const char *action, int visible)
evxErrors | cvxPopupItemSetEnabledByAction (const char *name, const char *action, int enabled)
evxErrors | cvxPopupItemSetCheckedByAction (const char *name, const char *action, int checked)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupDefine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupDefine()

evxErrors cvxPopupDefine ( const char * name )

#include <zwapi_ui_popupform.h>

Determine if the specified pop up menu exists.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] name popup menu name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemActionGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemActionGet()

evxErrors cvxPopupItemActionGet | ( | const char * | name,
 |  | int | item,
 |  | char * | Action,
 |  | int | nByte
 | ) |  |

#include <zwapi_ui_popupform.h>

Get item action name by specified menu name and menu item.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | item | menu item
[out] | Action | action name
[in] | nByte | max size of Action
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemCheckedGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemCheckedGet()

evxErrors cvxPopupItemCheckedGet | ( | const char * | name,
 |  | int | group,
 |  | int | item,
 |  | int * | Check
 | ) |  |

#include <zwapi_ui_popupform.h>

Get the action's checked state.
Menu item must have the "GroupItem" attribute to call this interface.
Only one of the checked properties of all actions in a group can be true.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | group | menu group
[in] | item | menu item
[out] | Check | checked state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemInsert()

evxErrors cvxPopupItemInsert | ( | const char * | name,
 |  | int | index,
 |  | const char * | Label,
 |  | const char * | Action
 | ) |  |

#include <zwapi_ui_popupform.h>

Insert specified popup item.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).
If this menu is NULL, "index" = -1.
If this menu is not NULL, "index" >=0

Parameters
[in] | name | menu name
[in] | index | index in the menu
[in] | Label | label name
[in] | Action | action name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemIsExist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemIsExist()

int cvxPopupItemIsExist | ( | const char * | name,
 |  | const char * | action
 | ) |  |

#include <zwapi_ui_popupform.h>

Check if special menu item is exist.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | action | action name
Return values
succeeds
  • 1 - if exist
  • 0 - if not exist or function fails
warnings
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemLabelGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemLabelGet()

evxErrors cvxPopupItemLabelGet | ( | const char * | name,
 |  | int | item,
 |  | char * | Label,
 |  | int | nByte
 | ) |  |

#include <zwapi_ui_popupform.h>

Get the menu item label name.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | item | menu item
[out] | Label | Label name
[in] | nByte | max size of Label
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemRemove()

evxErrors cvxPopupItemRemove | ( | const char * | name,
 |  | int | index
 | ) |  |

#include <zwapi_ui_popupform.h>

Remove specified popup item.
If index = -1, remove all.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | index | index in the menu
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemSetAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemSetAction()

evxErrors cvxPopupItemSetAction | ( | const char * | name,
 |  | int | index,
 |  | const char * | Action
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the action of menu specified item
This interface cannot change the action label.
The "index" can't be less than 0.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | index | action index
[in] | Action | action script
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemSetCheckedByAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemSetCheckedByAction()

evxErrors cvxPopupItemSetCheckedByAction | ( | const char * | name,
 |  | const char * | action,
 |  | int | checked
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the action's checked state of quick bar, popup bar according to the specified
menu name and action name.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | action | action name
[in] | checked | action's checked state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemSetEnabledByAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemSetEnabledByAction()

evxErrors cvxPopupItemSetEnabledByAction | ( | const char * | name,
 |  | const char * | action,
 |  | int | enabled
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the action state of quick bar, popup bar according to the specified
menu name and action name.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | action | action name
[in] | enabled | action state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemSetVisibleByAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemSetVisibleByAction()

evxErrors cvxPopupItemSetVisibleByAction | ( | const char * | name,
 |  | const char * | action,
 |  | int | visible
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the action visibility of quick bar, popup bar according to the specified
menu name and action name.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | action | action name
[in] | visible | action visibility
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupItemVisibleGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupItemVisibleGet()

evxErrors cvxPopupItemVisibleGet | ( | const char * | name,
 |  | int | item,
 |  | int * | Visible
 | ) |  |

#include <zwapi_ui_popupform.h>

Get the action's visible state.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | item | menu item
[out] | Visible | visible state
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupMenuCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupMenuCnt()

evxErrors cvxPopupMenuCnt | ( | const char * | Name,
 |  | int * | cnt
 | ) |  |

#include <zwapi_ui_popupform.h>

Get count of menu actions.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | Name | menu name
[out] | cnt | count of actions
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSetVisible

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSetVisible()

evxErrors cvxPopupSetVisible | ( | const char * | name,
 |  | int | visible
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the visible state for the specified pop up menu.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | popup menu name
[in] | visible | visible or not
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupShow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupShow()

int cvxPopupShow ( const char * name )

#include <zwapi_ui_popupform.h>

Show the specified popup menu.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] name popup menu name
Return values
succeeds
  • 0 - success
fail
  • 1 - error
  • 2 - error and popupBar is not find.
  • ZW_API_INVALIS_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuActionsRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuActionsRemove()

evxErrors cvxPopupSubMenuActionsRemove | ( | const char * | Name,
 |  | const char * | Sub,
 |  | int | iFirst,
 |  | int | iLast
 | ) |  |

#include <zwapi_ui_popupform.h>

Remove action from specific sub-menu in menu.
If iLast = -1 and iFirst = 0, remove all.
If iLast = iFirst = -1, remove all.
The function of this interface is similar to cvxPopupSubMenuItemRemove().
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | Name | menu name
[in] | Sub | sub-menu name
[in] | iFirst | index in the sub-menu
[in] | iLast | index in the sub-menu
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuCnt()

evxErrors cvxPopupSubMenuCnt | ( | const char * | Name,
 |  | const char * | Sub,
 |  | int * | cnt
 | ) |  |

#include <zwapi_ui_popupform.h>

Get count of sub-menu actions.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | Name | menu name
[in] | Sub | sub-menu name
[out] | cnt | count of actions
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuItemInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuItemInsert()

evxErrors cvxPopupSubMenuItemInsert | ( | const char * | Name,
 |  | const char * | Sub,
 |  | int | index,
 |  | const char * | ActName,
 |  | const char * | Label,
 |  | const char * | Script,
 |  | const char * | Icon
 | ) |  |

#include <zwapi_ui_popupform.h>

Insert a item to specific sub-menu in menu.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).
If index = -1, it is inserted lase, otherwise it is inserted before index.

Parameters
[in] | Name | menu name
[in] | Sub | sub-menu name
[in] | index | index in the sub-menu
[in] | ActName | action name of item
[in] | Label | label of item
[in] | Script | action of the item
[in] | Icon | icon of item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuItemRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuItemRemove()

evxErrors cvxPopupSubMenuItemRemove | ( | const char * | name,
 |  | const char * | Sub,
 |  | int | index
 | ) |  |

#include <zwapi_ui_popupform.h>

Remove a item from specific sub-menu in menu.
The function of this interface is similar to cvxPopupSubMenuActionsRemove().
If index = -1, remove all.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | menu name
[in] | Sub | sub-menu name
[in] | index | index in the sub-menu
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuSeparatorInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuSeparatorInsert()

evxErrors cvxPopupSubMenuSeparatorInsert | ( | const char * | Name,
 |  | const char * | Sub
 | ) |  |

#include <zwapi_ui_popupform.h>

Insert a separator to specific sub-menu in menu.
This interface can only insert separator at the end of the sub-menu.
If there is no "action" after the separator, the separator is not displayed.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | Name | menu name
[in] | Sub | sub-menu name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupSubMenuSetVisible

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupSubMenuSetVisible()

evxErrors cvxPopupSubMenuSetVisible | ( | const char * | name,
 |  | const char * | sub,
 |  | int | visible
 | ) |  |

#include <zwapi_ui_popupform.h>

Set the visible state for the specified pop up sub-menu.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] | name | popup menu name
[in] | sub | popup sub-menu name
[in] | visible | visible or not
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxPopupUpdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Popup Form
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ cvxPopupUpdate()

evxErrors cvxPopupUpdate ( const char * Name )

#include <zwapi_ui_popupform.h>

Update the specified pop up menu.
Get the popup menu name through using "$report" or viewing the configuration file(ZW3D/Settings/).

Parameters
[in] Name menu name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Ribbon

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Ribbon
UI

Detailed Description

THE MODULE FOR THE ZW3D Ribbon API

Ribbon

void | cvxRibbonSetStatus (int enable)
void | cvxSetTitleAppend (const char *pStr)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxRibbonSetStatus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Ribbon
cvxRibbonSetStatus
cvxSetTitleAppend

◆ cvxRibbonSetStatus()

void cvxRibbonSetStatus ( int enable )

#include <zwapi_ui_ribbon.h>

Enable or disable the ribbon.

Parameters
[in] enable 1: enable the ribbon. 0: disable the ribbon
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxSetTitleAppend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Ribbon
cvxRibbonSetStatus
cvxSetTitleAppend

◆ cvxSetTitleAppend()

void cvxSetTitleAppend ( const char * pStr )

#include <zwapi_ui_ribbon.h>

Set the append string to display after the title area of the base GUI window.
pStr is NULL or a blank string to clear the append title string.

Parameters
[in] pStr Set/clear the string to display after the window title
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Slider

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Slider
UI

Detailed Description

THE MODULE FOR THE ZW3D Combobox API

Slider

evxErrors | cvxSliderLimitGet (const char *Form, int idfield, double *min, double *max)
evxErrors | cvxSliderLimitSet (const char *Form, int idfield, double min, double max)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxSliderLimitGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Slider
cvxSliderLimitGet
cvxSliderLimitSet

◆ cvxSliderLimitGet()

evxErrors cvxSliderLimitGet | ( | const char * | Form,
 |  | int | idfield,
 |  | double * | min,
 |  | double * | max
 | ) |  |

#include <zwapi_ui_slider.h>

Use this function to get slider's minimum and maximum.
Activate the form before calling this function.

See also
cvxSliderLimitSet().
Parameters
[in] | Form | form name
[in] | idfield | id of field
[out] | min | slider minimum
[out] | max | slider maximum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxSliderLimitSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Slider
cvxSliderLimitGet
cvxSliderLimitSet

◆ cvxSliderLimitSet()

evxErrors cvxSliderLimitSet | ( | const char * | Form,
 |  | int | idfield,
 |  | double | min,
 |  | double | max
 | ) |  |

#include <zwapi_ui_slider.h>

Use this function to set slider's minimum and maximum.
Activate the form before calling this function.

See also
cvxSliderLimitGet().
Parameters
[in] | Form | form name
[in] | idfield | id of field
[in] | min | slider minimum
[in] | max | slider maximum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Table Widget

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Table Widget
UI

Detailed Description

THE MODULE FOR THE ZW3D Table Widget API

Table Attribute

evxErrors | cvxTableAtSetInit (svxTableAt *data)
evxErrors | cvxTableAtSet (char *Form, int idTable, svxTableAt *At)
evxErrors | cvxTableSizeSet (char *Form, int idTable, int NumRow, int NumCol)
evxErrors | cvxTableSetSelRange (const char *Form, int idTable, svxRectangle *SelRange, int bSelect)
evxErrors | cvxTableGetSelRange (const char *Form, int idTable, int *RangeCnt, svxRectangle **SelRange)
evxErrors | cvxTableUnselectAll (const char *Form, int idTable)

Table Callback

evxErrors | cvxTableCallBackParamGet (const char *form, int idTable, svxTableCallBackParam *param)
void | cvxTableCallBackParamFree (svxTableCallBackParam *param)

Table Row/Column

int | cvxTableRowCnt (const char *Form, int idTable)
int | cvxTableColCnt (const char *Form, int idTable)
evxErrors | cvxTableRowInsert (const char *Form, int idTable, int Row)
evxErrors | cvxTableRowRemove (const char *Form, int idTable, int Row)
evxErrors | cvxTableColInsert (const char *Form, int idTable, int Col)
evxErrors | cvxTableColRemove (const char *Form, int idTable, int Col)

Table Combobox

evxErrors | cvxTableComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableComboGet (const char *Form, int idTable, int Row, int Col, int *Index, char *Text, int nBytes)
evxErrors | cvxTableIndexComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableInputComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableIndexComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableInputComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableComboSetOption (const char *Form, int idTable, int Row, int Col, int Index, char *IdxText)

Table Cell

evxErrors | cvxTableTypeGet (const char *Form, int idTable, int Row, int Col, evxTableCellType *Type)
void | cvxTableVisSet (char *Form, int idTable, int Row, int Col)
int | cvxTableIsCheck (const char *Form, int idTable, int Row, int Col)
evxErrors | cvxTableCheckSet (const char *Form, int idTable, int Row, int Col, int Check)
evxErrors | cvxTableCellTextGet (char *Form, int idTable, int Row, int Col, char *text, int nBytes)
void | cvxTableCellEnableSet (const char *Form, int idTable, int Row, int Col, int State)
void | cvxTableCellTipSet (const char *Form, int idTable, int Row, int Col, const char *tip)
evxErrors | cvxTableCellTipGet (const char *Form, int idTable, int Row, int Col, char *tip, int nBytes)
evxErrors | cvxTableCellTextSet (char *Form, int idTable, int Row, int Col, char *text)
evxErrors | cvxTableCellTextSet2 (const char *Form, int idTable, int Row, int Col, char *Text, char *Image)
evxErrors | cvxTableDateSet (const char *Form, int idTable, int Row, int Col, int Date, evxDateType DateType)
evxErrors | cvxTableDateGet (const char *Form, int idTable, int Row, int Col, int *Date, evxDateType *DateType)
evxErrors | cvxTableColorSet (const char *Form, int idTable, int Row, int Col, const svxColor *Color, int ClrIdx, unsigned char Type)
evxErrors | cvxTableColorGet (const char *Form, int idTable, int Row, int Col, svxColor *Color, int *ClrIdx, unsigned char *Type)
evxErrors | cvxTableNumSet (const char *Form, int idTable, int Row, int Col, const char *Num)
evxErrors | cvxTableNumGet (const char *Form, int idTable, int Row, int Col, char *Num, int Bytes)
evxErrors | cvxTableGetText (const char *Form, int idTable, int row, int col, char *text, int sizeText)

Table Header

evxErrors | cvxTableSetHorHeaderList (const char *Form, int idTable, int num, const char **pHeaderList)
evxErrors | cvxTableSetVerHeaderList (const char *Form, int idTable, int num, const char **pHeaderList)
evxErrors | cvxTableSetHeaderAlignment (const char *Form, int idTable, int isVertical, evxTableAlignFlag align)
evxErrors | cvxTableSetHeaderColResizeMode (const char *Form, int idTable, int col, evxTableResizeMode mode)
evxErrors | cvxTableSetHeaderSectionSize (const char *Form, int idTable, int size, int isMin)
evxErrors | cvxTableHeaderCellCheck (const char *Form, int idTable, int isVertical, int item, int check)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableAtSet()

evxErrors cvxTableAtSet | ( | char * | Form,
 |  | int | idTable,
 |  | svxTableAt * | At
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Applies the attributes specified in "At" to the GUI table identified
by "Form" and "idTable".

Note
Interface cvxTableAtSetInit() can initialize variables of this function.
Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | At | table attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableAtSetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableAtSetInit()

evxErrors cvxTableAtSetInit ( svxTableAt * data )

#include <zwapi_ui_tablewidget.h>

Initialize the parameters of the cvxTableAtSet().

Note
Do not assign a value to variable "data" before calling this function.
The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data table attributes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCallBackParamFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCallBackParamFree()

void cvxTableCallBackParamFree ( svxTableCallBackParam * param )

#include <zwapi_ui_tablewidget.h>

Frees memory for struct svxTableCallBackParam pointer.
Sets pointer to NULL if memory was freed successfully.

Parameters
[in] param address of pointer to be Free
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCallBackParamGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCallBackParamGet()

evxErrors cvxTableCallBackParamGet | ( | const char * | form,
 |  | int | idTable,
 |  | svxTableCallBackParam * | param
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get callback parameters for the table widget when the callback function being invoked.
For specific usage, please refer to the case TableSet in ApiExample.

The function will allocate memory to "param", please call cvxTableCallBackParamFree() function to free memory.

Parameters
[in] | form | form name
[in] | idTable | field id
[out] | param | assigned with table cell callback function parameter pointer
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellEnableSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellEnableSet()

void cvxTableCellEnableSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int | State
 | ) |  |

#include <zwapi_ui_tablewidget.h>

change a cell in table which was specified by VmUiItem2RC(item, iRow, iCol) to "selectable" .

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | State | 0 - disable, 1 - enable, 2 - enable & editable
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellTextGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellTextGet()

evxErrors cvxTableCellTextGet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | text,
 |  | int | nBytes
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the text of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | text | text to get
[in] | nBytes | string max size of text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellTextSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellTextSet()

evxErrors cvxTableCellTextSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | text
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the text of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | text | text to set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellTextSet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellTextSet2()

evxErrors cvxTableCellTextSet2 | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Text,
 |  | char * | Image
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the text and image of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Text | null-terminated, cell text, it will be ignored when it is NULL
[in] | Image | null-terminated, image, it will be ignored when it is NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellTipGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellTipGet()

evxErrors cvxTableCellTipGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | tip,
 |  | int | nBytes
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the tooltip of the table cell identified by "Row" and "Col".

Note
The row and column can not both be -1.
Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=-1)
[in] | Col | table column (>=-1)
[out] | tip | tooltip string
[in] | nBytes | max size of tooltip string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCellTipSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCellTipSet()

void cvxTableCellTipSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | const char * | tip
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the tooltip of the table cell identified by "Row" and "Col".

Note
The row and column can not both be -1.
Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=-1)
[in] | Col | table column (>=-1)
[in] | tip | tooltip string
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableCheckSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableCheckSet()

evxErrors cvxTableCheckSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int | Check
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a check box
specified by variable check.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Check | 1-check, 0-uncheck
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableColCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableColCnt()

int cvxTableColCnt | ( | const char * | Form,
 |  | int | idTable
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the column count of the specified table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
Return values
return
  • the column count of the specified table.
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableColInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableColInsert()

evxErrors cvxTableColInsert | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Col
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Insert a column to table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Col | Column id (>=0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableColorGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableColorGet()

evxErrors cvxTableColorGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | svxColor * | Color,
 |  | int * | ClrIdx,
 |  | unsigned char * | Type
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the color of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | Color | true color, such as RGB(255,0,0)
[out] | ClrIdx | index color (V_COLOR_NULL ~ V_COLOR_LAST)
[out] | Type | color type: 0-true color, 1-index color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableColorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableColorSet()

evxErrors cvxTableColorSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | const svxColor * | Color,
 |  | int | ClrIdx,
 |  | unsigned char | Type
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a color type editor.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Color | true color, such as RGB(255,0,0)
[in] | ClrIdx | index color (V_COLOR_NULL ~ V_COLOR_LAST)
[in] | Type | color type: 0-true color, 1-index color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableColRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableColRemove()

evxErrors cvxTableColRemove | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Col
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Remove a column from table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Col | Column id (>=0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableComboGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableComboGet()

evxErrors cvxTableComboGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int * | Index,
 |  | char * | Text,
 |  | int | nBytes
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the data for the specified table cell defined as combo box or indexed combo box or editable combo box.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | Index | Selected index
[out] | Text | Selected text
[in] | nBytes | string max size of text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableComboSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableComboSet()

evxErrors cvxTableComboSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a combo box of options
specified by the input list of comma-delimited text labels.

Options: each option is separated by ',' ("1,2,3").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableComboSet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableComboSet2()

evxErrors cvxTableComboSet2 | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options,
 |  | char * | Images
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a combo box of options
specified by the input list of comma-delimited text labels and images.

Options: each option is separated by ',' ("1,2,3").
Images: each image is separated by ',' ("A.png,B.png,C.png").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
[in] | Images | null-terminated, comma-delimited list of image, it will be ignored when it is NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableComboSetOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableComboSetOption()

evxErrors cvxTableComboSetOption | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int | Index,
 |  | char * | IdxText
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the option index for the specified table cell defined as combo box or indexed combo box or editable combo box.
If variable Index is not equal to -1, variable IdxText can be empty,
and when variable Index equals -1, set variable IdxText to the selected text.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Index | Option index
[in] | IdxText | null-terminated, Option text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableDateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableDateGet()

evxErrors cvxTableDateGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int * | Date,
 |  | evxDateType * | DateType
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the date of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | Date | Date to get (time in seconds elapsed since 00:00:00 Jan 1, 1970)
[out] | DateType | Date type to get
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableDateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableDateSet()

evxErrors cvxTableDateSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | int | Date,
 |  | evxDateType | DateType
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a date editor.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Date | Date to set (time in seconds elapsed since 00:00:00 Jan 1, 1970)
[in] | DateType | Date type to set
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableGetSelRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableGetSelRange()

evxErrors cvxTableGetSelRange | ( | const char * | Form,
 |  | int | idTable,
 |  | int * | RangeCnt,
 |  | svxRectangle ** | SelRange
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get selected range of the table, The calling procedure MUST deallocate
the output list with cvxMemFree().

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[out] | RangeCnt | number of ranges
[out] SelRange selected range
left: left column
right: right column
top: top row
bottom: bottom row
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableGetText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableGetText()

evxErrors cvxTableGetText | ( | const char * | Form,
 |  | int | idTable,
 |  | int | row,
 |  | int | col,
 |  | char * | text,
 |  | int | sizeText
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the text of the specified cell, the invoker should make sure that the For now we support 'ZeTextCell', 'ZeStrComboCell', 'ZeIndexComboCell', 'ZeInputComboCell' type cell.

Parameters
[in] | Form | form name
[in] | idTable | form field
[in] | row | row number
[in] | col | column number
[out] | text | text to store the output text
[in] | sizeText | text size
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_TABLE_GETDATA_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableHeaderCellCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableHeaderCellCheck()

evxErrors cvxTableHeaderCellCheck | ( | const char * | Form,
 |  | int | idTable,
 |  | int | isVertical,
 |  | int | item,
 |  | int | check
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set header item checked state in table Widget.

When isVertical = 1, set current vertical header item check state.

When isVertical = 0, set current horizontal header item check state.

Parameters
[in] | Form | form name
[in] | idTable | form field
[in] | isVertical | 1-vertical, 0-horizontal
[in] | item | item number
[in] | check | 1-check, 0-uncheck
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableIndexComboSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableIndexComboSet()

evxErrors cvxTableIndexComboSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a indexed combo box of options
specified by the input list of comma-delimited text labels.

Options: each option is separated by ',' ("1,2,3").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableIndexComboSet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableIndexComboSet2()

evxErrors cvxTableIndexComboSet2 | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options,
 |  | char * | Images
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a indexed combo box of options
specified by the input list of comma-delimited text labels and images.

Options: each option is separated by ',' ("1,2,3").

Images: each image is separated by ',' ("A.png,B.png,C.png").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
[in] | Images | null-terminated, comma-delimited list of image, it will be ignored when it is NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableInputComboSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableInputComboSet()

evxErrors cvxTableInputComboSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a editable combo box of options
specified by the input list of comma-delimited text labels.

Options: each option is separated by ',' ("1,2,3").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableInputComboSet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableInputComboSet2()

evxErrors cvxTableInputComboSet2 | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Options,
 |  | char * | Images
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a editable combo box of options
specified by the input list of comma-delimited text labels and images.

Options: each option is separated by ',' ("1,2,3").

Images: each image is separated by ',' ("A.png,B.png,C.png").

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Options | null-terminated, comma-delimited list of text labels
[in] | Images | null-terminated, comma-delimited list of image it will be ignored when it is NULL
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableIsCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableIsCheck()

int cvxTableIsCheck | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get check state of the table cell identified by "Row" and "Col" defined as check box.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
Return values
return
  • 1 - if checked
  • 0 - if not checked or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableNumGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableNumGet()

evxErrors cvxTableNumGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | char * | Num,
 |  | int | Bytes
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get number of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | Num | Number to get
[in] | nBytes | string max size of Num
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableNumSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableNumSet()

evxErrors cvxTableNumSet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | const char * | Num
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes the table cell identified by "Row" and "Col" a number editor.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[in] | Num | null-terminated, number value
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableRowCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableRowCnt()

int cvxTableRowCnt | ( | const char * | Form,
 |  | int | idTable
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the row count the specified table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
Return values
return
  • the row count the specified table
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableRowInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableRowInsert()

evxErrors cvxTableRowInsert | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Insert a row to table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | Row id (>=0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableRowRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableRowRemove()

evxErrors cvxTableRowRemove | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Remove a row from table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | Row id (>=0)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetHeaderAlignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetHeaderAlignment()

evxErrors cvxTableSetHeaderAlignment | ( | const char * | Form,
 |  | int | idTable,
 |  | int | isVertical,
 |  | evxTableAlignFlag | align
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set header text alignment direction: Center, Left, Right.

Parameters
[in] | Form | form name
[in] | idTable | field id
[in] | isVertical | Direction: 0-Horizontal, 1-Vertical
[in] | align | Alignment mode
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetHeaderColResizeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetHeaderColResizeMode()

evxErrors cvxTableSetHeaderColResizeMode | ( | const char * | Form,
 |  | int | idTable,
 |  | int | col,
 |  | evxTableResizeMode | mode
 | ) |  |

#include <zwapi_ui_tablewidget.h>

set header resize mode of col index,

0 for QHeaderView::Interactive,

1 for QHeaderView::Stretch,

2 for QHeaderView::Fixed,

3 for QHeaderView::ResizeToContents

Parameters
[in] | Form | form name
[in] | idTable | field id
[in] | col | column index(>=0)
[in] | mode | resize mode
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetHeaderSectionSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetHeaderSectionSize()

evxErrors cvxTableSetHeaderSectionSize | ( | const char * | Form,
 |  | int | idTable,
 |  | int | size,
 |  | int | isMin
 | ) |  |

#include <zwapi_ui_tablewidget.h>

set header column size limitation to affect the behavior of resizing and display for columns' width.

Parameters
[in] | Form | form name
[in] | idTable | field id
[in] | size | the header section limited size(>=-1)
[in] | isMin | if it is 1, means minimum limitation, else maximum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetHorHeaderList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetHorHeaderList()

evxErrors cvxTableSetHorHeaderList | ( | const char * | Form,
 |  | int | idTable,
 |  | int | num,
 |  | const char ** | pHeaderList
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the Horizontal header string list to table.

This interface means the header represented by the top row of the table.

Parameters
[in] | Form | form name
[in] | idTable | field id
[in] | num | number of header list
[in] | pHeaderList | header string list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetSelRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetSelRange()

evxErrors cvxTableSetSelRange | ( | const char * | Form,
 |  | int | idTable,
 |  | svxRectangle * | SelRange,
 |  | int | bSelect
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set selected range of the table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] SelRange select range
left: left column
right: right column
top: top row
bottom: bottom row
[in] | bSelect | select the range or not,1 for select
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSetVerHeaderList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSetVerHeaderList()

evxErrors cvxTableSetVerHeaderList | ( | const char * | Form,
 |  | int | idTable,
 |  | int | num,
 |  | const char ** | pHeaderList
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Set the Vertical header string list to table.

This interface means the header represented by the leftmost column of the table.

Parameters
[in] | Form | form name
[in] | idTable | field id
[in] | num | number of header list
[in] | pHeaderList | header string list
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_TABLE_SETDATA_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableSizeSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableSizeSet()

evxErrors cvxTableSizeSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | NumRow,
 |  | int | NumCol
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Sets the number of rows and columns in the specified table.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | NumRow | number of rows (0 to ignore)
[in] | NumCol | number of columns (0 to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableTypeGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableTypeGet()

evxErrors cvxTableTypeGet | ( | const char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col,
 |  | evxTableCellType * | Type
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Get the type of the table cell identified by "Row" and "Col".

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
[out] | Type | Table cell type
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableUnselectAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableUnselectAll()

evxErrors cvxTableUnselectAll | ( | const char * | Form,
 |  | int | idTable
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Unselect all items

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTableVisSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Table Widget
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ cvxTableVisSet()

void cvxTableVisSet | ( | char * | Form,
 |  | int | idTable,
 |  | int | Row,
 |  | int | Col
 | ) |  |

#include <zwapi_ui_tablewidget.h>

Makes sure the table cell identified by "Row" and "Col" is visible
within a table that may scroll vertically or horizontally beyond the
limits of the display area on its parent form.

Parameters
[in] | Form | GUI form name
[in] | idTable | table field id
[in] | Row | table row (>=0)
[in] | Col | table column (>=0)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Tab Widget

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Tab Widget
UI

Detailed Description

THE MODULE FOR THE ZW3D Tab Widget API

Tab Attribute

evxErrors cvxTabWidgetItemVisibleSet (const char *Form, int tabIdField, int tabIndex, char bVisible)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTabWidgetItemVisibleSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tab Widget
cvxTabWidgetItemVisibleSet

◆ cvxTabWidgetItemVisibleSet()

evxErrors cvxTabWidgetItemVisibleSet | ( | const char * | Form,
 |  | int | tabIdField,
 |  | int | tabIndex,
 |  | char | bVisible
 | ) |  |

#include <zwapi_ui_tabwidget.h>

Set the visibility of the specific(tab widget) field's specialized item. cvxItemVisibleSet has the similar function also.

Parameters
[in] | Form | form name
[in] | tabIdField | id of the tab widget
[in] | tabIndex | tab index ,start from 0
[in] | bVisible | true is visible ,false is hide
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Tree View

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Tree View
UI

Detailed Description

THE MODULE FOR THE ZW3D Tree View API

Tree Widget Header

void | cvxTreeSetHeaderIcon (const char *name, int field, int section, const char *icon)
void | cvxTreeSetHeaderText (const char *form, int field, int col, const char *text)
evxErrors | cvxTreeHeaderGetSize (const char *form, int field, int *width, int *height)
evxErrors | cvxTreeSetHeaderTextAlignment (const char *form, int field, int col, evxAlignFlag align)

Tree Widget Column

void | cvxTreeSetColumnCount (const char *form, int field, int count)
int | cvxTreeGetColumnCount (const char *form, int field)
void | cvxTreeSetColumnWidth (const char *form, int field, int col, int width)
int | cvxTreeGetColumnWidth (const char *form, int field, int col)
void | cvxTreeSetColumnHidden (const char *form, int field, int col, int hide)
int | cvxTreeIsColumnHidden (const char *form, int field, int col)
evxErrors | cvxTreeAutoResizeColumn (const char *form, int field, int col)

Tree Widget State

void | cvxTreeExpandAll (const char *form, int field)
void | cvxTreeCollapseAll (const char *form, int field)
evxErrors | cvxTreeUnselectAll (const char *form, int field)
evxErrors | cvxTreeSetSelectionMode (const char *form, int field, int mode)
evxErrors | cvxTreeSetSelectionBehavior (const char *form, int field, int behavior)

Tree Widget Callback

evxErrors cvxTreeGetCbParam (const char *form, int field, int itemId, svxTreeCbParam *cbp)

Tree Item

int | cvxTreeItemsCount (const char *form, int field)
evxErrors | cvxTreeAddItem (const char *form, int field, int parentId, int siblingId, const char *label, int imgIdx, int folderIdx, evxTreeItemType itemType, int dbIdx, int itemflag, int *outItemId, const char *cmdName)
evxErrors | cvxTreeSetItemFlag (const char *form, int field, int count, int *ids, int flag)
evxErrors | cvxTreeGetItemFlag (const char *form, int field, int id, int *flag)
evxErrors | cvxTreeSetItemIconNameByColumn (const char *form, int field, int id, int col, const char *iconName)
evxErrors | cvxTreeSetItemTextByColumn (const char *form, int field, int id, int col, const char *text)
void | cvxTreeGetItemTextByColumn (const char *form, int field, int id, int col, char *text, int size)
evxErrors | cvxTreeSetItemTextColor (const char *form, int field, int id, int col, svxColor *color)
evxErrors | cvxTreeGetDBIdByItem (const char *form, int field, int id, int *objectIndex)
evxErrors | cvxTreeDeleteItem (const char *form, int field, int id)
evxErrors | cvxTreeDeleteSubItem (const char *form, int field, int id)
evxErrors | cvxTreeEditItemByLineEdit (const char *form, int field, int id, int col, const char *defaultLabel)
evxErrors | cvxTreeEditItemByComboBox (const char *form, int field, int id, int col, const char *Options, const char *Images, int curIndex)
evxErrors | cvxTreeGetPrevSiblingItem (const char *form, int field, int id, int *prevId)
evxErrors | cvxTreeGetNextSiblingItem (const char *form, int field, int id, int *nextId)
evxErrors | cvxTreeGetChildItem (const char *form, int field, int id, int index, int *child_id)
evxErrors | cvxTreeGetChildrenCount (const char *form, int field, int id, int *count)
evxErrors | cvxTreeGetParentItem (const char *form, int field, int id, int *parent)
evxErrors | cvxTreeMoveItems (const char *form, int field, int numNodes, int *ids, int insParentId, int siblingId)
evxErrors | cvxTreeGetDescendants (const char *form, int field, int isAll, int parent, int *num, int **ids)
evxErrors | cvxTreeGetSelectedItems (const char *form, int field, int *count, int **ids)

Tree Item State

int | cvxTreeIsItemSelected (const char *form, int field, int id)
evxErrors | cvxTreeSelectItem (const char *form, int field, int id)
evxErrors | cvxTreeSetItemCheckable (const char *form, int field, int id, int checkable)
evxTreeCheckState | cvxTreeGetItemCheckState (const char *form, int field, int id)
void | cvxTreeSetItemCheckState (const char *form, int field, int id, evxTreeCheckState checkState, int extToChild)
int | cvxTreeItemIsExpand (const char *form, int field, int id)
evxErrors | cvxTreeExpandItem (const char *form, int field, int id, int option)
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeAddItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeAddItem()

evxErrors cvxTreeAddItem | ( | const char * | form,
 |  | int | field,
 |  | int | parentId,
 |  | int | siblingId,
 |  | const char * | label,
 |  | int | imgIdx,
 |  | int | folderIdx,
 |  | evxTreeItemType | itemType,
 |  | int | dbIdx,
 |  | int | itemflag,
 |  | int * | outItemId,
 |  | const char * | cmdName
 | ) |  |

#include <zwapi_ui_treeview.h>

Add a node with specified informations to the tree widget.

Parameters
[in] | form | form name
[in] | field | field number
[in] | parentId | Parent node id, if without parent, assign 0
[in] | siblingId | Prev sibling node id, if without previous node, assign VX_INSERT_LAST
[in] | label | Node label text
[in] | imgIdx | Index of the item's expanded image in the imagelist
[in] | folderIdx | Index of the item's collapsed image in the imagelist
[in] | itemType | Node type
[in] | dbIdx | Object index in database
[in] | itemflag | evxTreeItemFlag
[out] | outItemId | new added node's id
[in] | cmdName | icon name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeAutoResizeColumn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeAutoResizeColumn()

evxErrors cvxTreeAutoResizeColumn | ( | const char * | form,
 |  | int | field,
 |  | int | col
 | ) |  |

#include <zwapi_ui_treeview.h>

Resize the width of the special column to show their contents completely.

Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column (-1 to resize all columns)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeCollapseAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeCollapseAll()

void cvxTreeCollapseAll | ( | const char * | form,
 |  | int | field
 | ) |  |

#include <zwapi_ui_treeview.h>

Collapse all the nodes of the tree.

Parameters
[in] | form | form name
[in] | field | field number
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeDeleteItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeDeleteItem()

evxErrors cvxTreeDeleteItem | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

Delete specified tree node and its descendants. if id is VX_INVALID_ITEM, then delete all.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | node to be deleted (-1 to delete all nodes)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeDeleteSubItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeDeleteSubItem()

evxErrors cvxTreeDeleteSubItem | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

Delete specified node's descendants. if id is INVALID_TNODE_ID, return directly.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | node to be deleted
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeEditItemByComboBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeEditItemByComboBox()

evxErrors cvxTreeEditItemByComboBox | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | const char * | Options,
 |  | const char * | Images,
 |  | int | curIndex
 | ) |  |

#include <zwapi_ui_treeview.h>

Makes the cell identified by "id" and "col" a indexed combo box of options
specified by the input list of comma-delimited text labels and images.

Options: each option is separated by ',' ("1,2,3").

Images: each image is separated by ',' ("A.png,B.png,C.png").

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree item id
[in] | col | column
[in] | Options | null-terminated, comma-delimited list of text labels (NULL to ignore)
[in] | Images | null-terminated, comma-delimited list of image (NULL to ignore)
[in] | curIndex | the current index of combobox
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeEditItemByLineEdit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeEditItemByLineEdit()

evxErrors cvxTreeEditItemByLineEdit | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | const char * | defaultLabel
 | ) |  |

#include <zwapi_ui_treeview.h>

Activate the specified node to edit by a line edit.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[in] | col | column
[in] | defaultLabel | default text when editing
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeExpandAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeExpandAll()

void cvxTreeExpandAll | ( | const char * | form,
 |  | int | field
 | ) |  |

#include <zwapi_ui_treeview.h>

Expand all the nodes of the tree.

Parameters
[in] | form | form name
[in] | field | field number
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeExpandItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeExpandItem()

evxErrors cvxTreeExpandItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | option
 | ) |  |

#include <zwapi_ui_treeview.h>

Set expand status of specified tree node.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[in] | option | status (1 to expand, 2 to collapse, 3 to toggle)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetCbParam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetCbParam()

evxErrors cvxTreeGetCbParam | ( | const char * | form,
 |  | int | field,
 |  | int | itemId,
 |  | svxTreeCbParam * | cbp
 | ) |  |

#include <zwapi_ui_treeview.h>

Get callback parameters for the tree widget when the callback function being invoked.

Parameters
[in] | form | form name
[in] | field | filed id
[in] | itemId | item id
[out] | cbp | assigned with tree callback function parameter pointer
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetChildItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetChildItem()

evxErrors cvxTreeGetChildItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | index,
 |  | int * | child_id
 | ) |  |

#include <zwapi_ui_treeview.h>

Get the nth(index) child item of the specified node from the tree widget.
If the node has no child node or index is not valid, child_id will be VX_INVALID_ITEM.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | parent node id
[in] | index | index of node, 0 based
[out] | child_id | first child node id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetChildrenCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetChildrenCount()

evxErrors cvxTreeGetChildrenCount | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | count
 | ) |  |

#include <zwapi_ui_treeview.h>

Get the count of the child nodes for the specified node from the tree widget.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | parent node id
[out] | count | count of the child nodes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetColumnCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetColumnCount()

int cvxTreeGetColumnCount | ( | const char * | form,
 |  | int | field
 | ) |  |

#include <zwapi_ui_treeview.h>

This function get the number of columns displayed in the specified tree widget.

Parameters
[in] | form | form name
[in] | field | field id
Return values
return
  • the number of columns.
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetColumnWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetColumnWidth()

int cvxTreeGetColumnWidth | ( | const char * | form,
 |  | int | field,
 |  | int | col
 | ) |  |

#include <zwapi_ui_treeview.h>

Get the width of the given column.

Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column to get
Return values
return
  • the width of the given column.
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetDBIdByItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetDBIdByItem()

evxErrors cvxTreeGetDBIdByItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | objectIndex
 | ) |  |

#include <zwapi_ui_treeview.h>

Get object index in database which the specified node is associated to.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree node id
[out] | objectIndex | object index in database matched to node
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetDescendants

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetDescendants()

evxErrors cvxTreeGetDescendants | ( | const char * | form,
 |  | int | field,
 |  | int | isAll,
 |  | int | parent,
 |  | int * | num,
 |  | int ** | ids
 | ) |  |

#include <zwapi_ui_treeview.h>

Get all descendants or only children of the specified parent node. The calling
procedure MUST deallocate the output list.

Parameters
[in] | form | form name
[in] | field | form field id
[in] | isAll | 1-all descendants, 0-only children
[in] | parent | parent id
[out] | num | number of nodes
[out] | ids | node IDs
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetItemCheckState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetItemCheckState()

evxTreeCheckState cvxTreeGetItemCheckState | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

Get check state of the tree node identified by id defined as check box.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
Return values
return
  • evxTreeCheckState
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetItemFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetItemFlag()

evxErrors cvxTreeGetItemFlag | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | flag
 | ) |  |

#include <zwapi_ui_treeview.h>

Get flag of the specified node.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[out] | flag | tree node flag (evxTreeItemFlag)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetItemTextByColumn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetItemTextByColumn()

void cvxTreeGetItemTextByColumn | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | char * | text,
 |  | int | size
 | ) |  |

#include <zwapi_ui_treeview.h>

Get the cell item text of the specified column of the tree node.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree item id
[in] | col | column
[out] | text | column text
[in] | size | column text size
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetNextSiblingItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetNextSiblingItem()

evxErrors cvxTreeGetNextSiblingItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | nextId
 | ) |  |

#include <zwapi_ui_treeview.h>

Get next sibling node.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[out] | nextId | next sibling node id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetParentItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetParentItem()

evxErrors cvxTreeGetParentItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | parent
 | ) |  |

#include <zwapi_ui_treeview.h>

Get the parent node id for the specified tree node.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree node id
[out] | parent | parent node id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetPrevSiblingItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetPrevSiblingItem()

evxErrors cvxTreeGetPrevSiblingItem | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int * | prevId
 | ) |  |

#include <zwapi_ui_treeview.h>

Get previous sibling node.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[out] | prevId | previous sibling node id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeGetSelectedItems

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeGetSelectedItems()

evxErrors cvxTreeGetSelectedItems | ( | const char * | form,
 |  | int | field,
 |  | int * | count,
 |  | int ** | ids
 | ) |  |

#include <zwapi_ui_treeview.h>

Get all of the current selected nodes of the tree widget. The calling procedure
MUST deallocate the output list.

Parameters
[in] | form | form name
[in] | field | field number
[out] | count | number of nodes
[out] | ids | IDs of selected nodes
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeHeaderGetSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeHeaderGetSize()

evxErrors cvxTreeHeaderGetSize | ( | const char * | form,
 |  | int | field,
 |  | int * | width,
 |  | int * | height
 | ) |  |

#include <zwapi_ui_treeview.h>

This function gets the header size of the specified tree widget.

Parameters
[in] | form | form name
[in] | field | the item id
[out] | width | width of the item
[out] | height | height of the item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeIsColumnHidden

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeIsColumnHidden()

int cvxTreeIsColumnHidden | ( | const char * | form,
 |  | int | field,
 |  | int | col
 | ) |  |

#include <zwapi_ui_treeview.h>

Get visible state of the specified column.

Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column to query
Return values
return
  • 1 - the column is hidden
  • 0 - the column is not hidden or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeIsItemSelected

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeIsItemSelected()

int cvxTreeIsItemSelected | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

Judge whether the tree node is selected.

Parameters
[in] | form | form name
[in] | field | filed id
[in] | id | node to be checked
Return values
return
  • 1 - the node is selected
  • 0 - the node is not selected or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeItemIsExpand

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeItemIsExpand()

int cvxTreeItemIsExpand | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

Check whether the specified node is expanded.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
Return values
succeeds
  • 1 - the node is expanded
  • 0 - the node is not expanded or function fails
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeItemsCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeItemsCount()

int cvxTreeItemsCount | ( | const char * | form,
 |  | int | field
 | ) |  |

#include <zwapi_ui_treeview.h>

This function gets and return the total nodes of tree in the specified tree widget, including children nodes.

Parameters
[in] | form | form name
[in] | field | field id
Return values
return
  • number of tree items
Warning
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeMoveItems

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeMoveItems()

evxErrors cvxTreeMoveItems | ( | const char * | form,
 |  | int | field,
 |  | int | numNodes,
 |  | int * | ids,
 |  | int | insParentId,
 |  | int | siblingId
 | ) |  |

#include <zwapi_ui_treeview.h>

Move tree nodes to the specified position with all its descendants.

Parameters
[in] | form | form name
[in] | field | field number
[in] | numNodes | number of nodes moved
[in] | ids | list of nodes moved
[in] | insParentId | destination node's parent. If none, pass with 0
[in] siblingId destination node's prev sibling,
if insert as first child, pass with VX_INSERT_FIRST,
if insert as last child, pass with VX_INSERT_LAST
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSelectItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSelectItem()

evxErrors cvxTreeSelectItem | ( | const char * | form,
 |  | int | field,
 |  | int | id
 | ) |  |

#include <zwapi_ui_treeview.h>

This function is to select the specified node of the tree widget.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree node id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetColumnCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetColumnCount()

void cvxTreeSetColumnCount | ( | const char * | form,
 |  | int | field,
 |  | int | count
 | ) |  |

#include <zwapi_ui_treeview.h>

This function sets the number of columns displayed in the specified tree widget.

Parameters
[in] | form | form name
[in] | field | field id
[out] | count | count
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetColumnHidden

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetColumnHidden()

void cvxTreeSetColumnHidden | ( | const char * | form,
 |  | int | field,
 |  | int | col,
 |  | int | hide
 | ) |  |

#include <zwapi_ui_treeview.h>

Hide or show the specified column.

Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column to set
[in] | hide | whether to hide the column (1 to hide, 0 to show)
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetColumnWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetColumnWidth()

void cvxTreeSetColumnWidth | ( | const char * | form,
 |  | int | field,
 |  | int | col,
 |  | int | width
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the width of the given column to the width specified.

Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column to set
[in] | width | width
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetHeaderIcon

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetHeaderIcon()

void cvxTreeSetHeaderIcon | ( | const char * | name,
 |  | int | field,
 |  | int | section,
 |  | const char * | icon
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the icon of tree header according to specified section.
This interface is used for the widget TreeView.

Parameters
[in] | name | form name
[in] | field | field number
[in] | section | section of tree header
[in] | icon | tree header icon name
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetHeaderText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetHeaderText()

void cvxTreeSetHeaderText | ( | const char * | form,
 |  | int | field,
 |  | int | col,
 |  | const char * | text
 | ) |  |

#include <zwapi_ui_treeview.h>

This function sets the label for the header of the specified column of the tree widget.

Note
When the user does not use this interface to set the header information of the tree node,
user cannot do other processing on the header information.
For example, user cannot set the alignment of the header information.(cvxTreeSetHeaderTextAlignment).
Parameters
[in] | form | form name
[in] | field | field id
[in] | col | column
[in] | text | text
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetHeaderTextAlignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetHeaderTextAlignment()

evxErrors cvxTreeSetHeaderTextAlignment | ( | const char * | form,
 |  | int | field,
 |  | int | col,
 |  | evxAlignFlag | align
 | ) |  |

#include <zwapi_ui_treeview.h>

This function sets the tree view header text alignment by column index.

Note
When the user does not use the cvxTreeSetHeaderText() interface to set the header information of the tree control, calling this interface will have no effect.
Parameters
[in] | form | form name
[in] | field | field number
[in] | col | column to set
[in] | align | alignment flag
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemCheckable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemCheckable()

evxErrors cvxTreeSetItemCheckable | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | checkable
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the checkable state of the specified tree node.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[in] | checkable | checkable
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemCheckState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemCheckState()

void cvxTreeSetItemCheckState | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | evxTreeCheckState | checkState,
 |  | int | extToChild
 | ) |  |

#include <zwapi_ui_treeview.h>

Set check state of the tree node identified by id defined as check box.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[in] | checkState | check state
[in] | extToChild | flag to set children nodes check state
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemFlag()

evxErrors cvxTreeSetItemFlag | ( | const char * | form,
 |  | int | field,
 |  | int | count,
 |  | int * | ids,
 |  | int | flag
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the specified nodes' flags.

Parameters
[in] | form | form name
[in] | field | field number
[in] | count | number of nodes to set
[in] | ids | tree node ids
[in] | flag | tree node flag (evxTreeItemFlag)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemIconNameByColumn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemIconNameByColumn()

evxErrors cvxTreeSetItemIconNameByColumn | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | const char * | iconName
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the cell item (the specified column of the specified tree node) icon by name.

Parameters
[in] | form | form name
[in] | field | field number
[in] | id | tree node id
[in] | col | column to set
[in] | iconName | icon name without extension name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemTextByColumn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemTextByColumn()

evxErrors cvxTreeSetItemTextByColumn | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | const char * | text
 | ) |  |

#include <zwapi_ui_treeview.h>

Set the cell item text for the specified column of the specified tree node.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree item id
[in] | col | column
[in] | text | column text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetItemTextColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetItemTextColor()

evxErrors cvxTreeSetItemTextColor | ( | const char * | form,
 |  | int | field,
 |  | int | id,
 |  | int | col,
 |  | svxColor * | color
 | ) |  |

#include <zwapi_ui_treeview.h>

Set text's RGB color of specified cell.

Parameters
[in] | form | form name
[in] | field | field id
[in] | id | tree item id
[in] | col | column id (-1 to set whole row)
[in] | color | color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetSelectionBehavior

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetSelectionBehavior()

evxErrors cvxTreeSetSelectionBehavior | ( | const char * | form,
 |  | int | field,
 |  | int | behavior
 | ) |  |

#include <zwapi_ui_treeview.h>

This function sets the tree view control selection behavior.
behavior 0 for select items, 1 for select rows, and 2 for select columns.

Parameters
[in] | form | form name
[in] | field | field number
[in] | behavior | tree view control selection behavior
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeSetSelectionMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeSetSelectionMode()

evxErrors cvxTreeSetSelectionMode | ( | const char * | form,
 |  | int | field,
 |  | int | mode
 | ) |  |

#include <zwapi_ui_treeview.h>

This function sets the selection mode of a tree widget.

Parameters
[in] | form | form name
[in] | field | field number
[in] mode tree view control selection mode
0: No selection;
1: Single selection;
2: Multiple selection;
3: Extended selection;
4: Contiguous selection
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: cvxTreeUnselectAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Tree View
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ cvxTreeUnselectAll()

evxErrors cvxTreeUnselectAll | ( | const char * | form,
 |  | int | field
 | ) |  |

#include <zwapi_ui_treeview.h>

This function is to un-select all highlighted nodes of the tree widget.

Parameters
[in] | form | form name
[in] | field | field id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FORM_EXIST_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: Commands Creation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Commands Creation

Detailed Description

Modules

Command Definition
Part and Assembly Commands
Drawing Commands
Sketch Commands
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Command Definition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Command Definition
Commands Creation

Detailed Description

Modules

Command API
Command Data
Template Command
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Command API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Command API
Commands Creation » Command Definition

Detailed Description

THE MODULE FOR THE ZW3D Command Common API

Command Send

void | cvxNewCommand (void)
void | cvxCmdBuffer (const char *String, int Priority)
void | cvxCmdSend (char *CommandString)

Command Operation

evxErrors | cvxCmdChkLic (const vxName Name)
evxErrors | cvxCmdAction (evxCmdAction type, svxCmdActionParam *param)

Function Register/Un-register

evxErrors | cvxCmdFunc (const vxName Name, void *Function, double Code)
void | cvxCmdCallback (const vxName Name, void *Function)
evxErrors | cvxCmdFuncUnload (const vxName Name)
void | cvxCmdVariable (vxName Name, void *Variable)
evxErrors | cvxCmdVariableUnload (const vxName Name)
evxErrors | cvxCmdRegisterRcc (vxName File)
evxErrors | cvxCmdUnRegisterRcc (vxName File)

Macro

evxErrors | cvxCmdMacro (char *Input, char **Output)
evxErrors | cvxCmdMacro2 (char *path)
evxErrors | cvxMacroInqPath (vxPath path, vxPath file)
evxErrors | cvxMacroInqPathByLongPath (char *path, int sizepath, char *file, int filesize)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdAction()

evxErrors cvxCmdAction | ( | evxCmdAction | type,
 |  | svxCmdActionParam * | param
 | ) |  |

#include <zwapi_cmd.h>

Set a callback function. When processing the target command option, the callback function will be called.

If this function called many times with the same 'type', only the last will take effect.

If param or param->pfn is NULL, the original callback function, if there exists, will be removed.

If type is VX_CMD_START, param->pfn should return 0 if the specified command can be started, else return 1.

Note
If one call this function to register a callback in a dll module, he must call this function again, with argument param set as NULL, to unregister the callback for each action before the dll module exit. Usually we can do this in the exit function of the dll module.
Parameters
[in] | type | action type
[in] | param | callback function (NULL to remove the callback)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdBuffer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdBuffer()

void cvxCmdBuffer | ( | const char * | String,
 |  | int | Priority
 | ) |  |

#include <zwapi_cmd.h>

Buffers the input command string for execution after the current command and any previously-buffered command events are finished executing.

If "Priority" is input as 1, the input command string is given higher priority for execution than command strings buffered with "Priority = 0".

For example, if you register a pointer to a "void MyFunction(void)" callback function using cvxCmdFunc(), you can cause the function to be invoked after pending commands have executed using cvxCmdBuffer("~MyFunction").

Parameters
[in] | String | command string
[in] | Priority | priority of execution (0 or 1)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdCallback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdCallback()

void cvxCmdCallback | ( | const vxName | Name,
 |  | void * | Function
 | ) |  |

#include <zwapi_cmd.h>

Registers a pointer to an auxiliary callback function used by a command template. The function does not require a licensing code. The "init=", "exit=", "echo_obj=" and "callback=" fields reference auxiliary callback functions.

Function pointers should be registered in the "Init" function called when your library is dynamically loaded by ZW3D at runtime.

The callback function should be of the following type:

int Callback(char *TemplateName, int idField, int idData)

The echo_obj function should be of the following type: void Echo(int idData, void *ptr)

If developer wants to unload the DLL plug in file dynamically. It is a MUST to run cvxCmdFuncUnload() in the exit function.

Parameters
[in] | Name | function name
[in] | Function | function pointer
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_FUN_REGISTER_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdChkLic

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdChkLic()

evxErrors cvxCmdChkLic ( const vxName Name )

#include <zwapi_cmd.h>

Check whether license is valid.

Parameters
[in] Name Command name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdFunc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdFunc()

evxErrors cvxCmdFunc | ( | const vxName | Name,
 |  | void * | Function,
 |  | double | Code
 | ) |  |

#include <zwapi_cmd.h>

Registers a function referenced by the "function=" or "custom=" fields in a command template definition. The function is registered with a ZW3D licensing code. ZW3D ensures the user has the appropriate license before allowing access to the function.

Callback functions should be registered in the "Init" function called when your library is dynamically loaded by ZW3D at runtime.

For a standard command operation, the function should be the following type:

int StandardCommand(int idInputData, int *idOutputData)

For a custom command operation, the function should be the following type:

int CustomOperation(int idInputData)

For a callback function invoked by a command string that is the function name preceded by a "tilda" (e.g. ~MyFunction), the function should be one of the following types:

void MyFunction(void) or...

void MyFunction(char *string) invoked by sending the string "~MyFunction("text string")" using cvxCmdSend() or cvxCmdBuffer().

The API functions beginning with cvxData...() are used to compose and to query the data containers referenced by "idInputData" or "idOutputData".

For documentation on the the callback function registered in the header of a GUI template, see cvxFormFunc().

If developer wants to unload the DLL plug in file dynamically. It is a MUST to run cvxCmdFuncUnload() in the exit function.

In this case, the pre-existing symbol is kept and the input function is ignored.

Parameters
[in] | Name | function name
[in] | Function | function pointer
[in] | Code | ZW3D licensing code (e.g. VX_CODE_ADV_MODELING or VX_CODE_GENERAL)
Return values
succeeds
  • ZW_API_NO_ERROR : the input function was successfully registered
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_FUN_REGISTER_ERROR : a symbol with the same name as the input function already exists. In this case, the pre-existing symbol is kept and the input function is ignored.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdFuncUnload

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdFuncUnload()

evxErrors cvxCmdFuncUnload ( const vxName Name )

#include <zwapi_cmd.h>

Unload specified function registered via cvxCmdFunc()/cvxCmdCallback()/ cvxFormFunc()/cvxFormCallback() if developer wants to unload the DLL plug in file dynamically. The input name must be the same as the one used in cvxCmdFunc()/cvxCmdCallback()/cvxFormFunc()/cvxFormCallback().

Parameters
[in] Name function name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_FUN_UNLOAD_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdMacro

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdMacro()

evxErrors cvxCmdMacro | ( | char * | Input,
 |  | char ** | Output
 | ) |  |

#include <zwapi_cmd.h>

"Input" is interpreted as a string of one or more newline-delimted macro command strings – without the macro/endmacro keywords. A new macro is started, the encoded macro commands are executed and the macro is terminated.

The contents of variables created by the macro commands are output via "Output" as a single comma-delimited, null-terminated ascii string. The first item in the string is the total number of variables encoded in the string. This is followed by an encoding of each variable. Each variable is encoded with its name first, followed by the number of array elements in the variable, followed by the array values. Values are either ascii-encoded floating point numbers, or strings enclosed in double quotemarks. The following is an example:

   # variables
   Num = 25
   Strings = {"hello dolly", "hello world"}
   Array = {100,125,150}

   # ascii-encoded variable data
   3,Num,1,25,Strings,2,"hello dolly","hello world",Array,3,100,125,150

Memory for "Output" is allocated by this function. The memory must be deallocated by the calling procedure. If there is no output data, a NULL pointer is output.

Note
If user enter a new environment, user need to use the cvxDispSceneUpdate() interface to update the environment.
If this function errors out anywhere along the way, the string "ERROR" will be output via "Output" and this function will return 1. Otherwise, it will return 0.
Parameters
[in] | Input | null-terminated ascii string of macro commands
[out] | Output | pointer to of output data string (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdMacro2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdMacro2()

evxErrors cvxCmdMacro2 ( char * path )

#include <zwapi_cmd.h>

Runs a macro of specified path.

Note
If user enter a new environment, user need to use the cvxDispSceneUpdate() interface to update the environment.
Parameters
[in] path macro file path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdRegisterRcc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdRegisterRcc()

evxErrors cvxCmdRegisterRcc ( vxName File )

#include <zwapi_cmd.h>

Register a Qt resource file(rcc file).The rcc file contains the resources used in dll.If developer wants to unregister the rcc file in file dynamically. It is a MUST to run cvxCmdUnRegisterRcc() in the exit function.

Parameters
[in] File file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdSend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdSend()

void cvxCmdSend ( char * CommandString )

#include <zwapi_cmd.h>

Executes the input command string. If "String = NULL", the event queue is polled for buffered command strings, which are allowed to execute in the order they were buffered. When this function is called, any current thread of execution is suspended until pending command strings are processed, after which this function returns control to the calling procedure.

Parameters
[in] CommandString null-terminated ascii command string
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdUnRegisterRcc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdUnRegisterRcc()

evxErrors cvxCmdUnRegisterRcc ( vxName File )

#include <zwapi_cmd.h>

Unregister the Qt resource file(rcc file) registered via cvxCmdRegisterRcc(). If developer wants to unload the DLL plug in file dynamically. The input name must be the same as the one used in cvxCmdRegisterRcc().

Parameters
[in] File file name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdVariable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdVariable()

void cvxCmdVariable | ( | vxName | Name,
 |  | void * | Variable
 | ) |  |

#include <zwapi_cmd.h>

Registers a pointer to a global variable (i.e. the variable's address) referenced in a command template "options" string.

Global variables should be registered in the "Init" function called when your library is dynamically loaded by ZW3D at runtime.

If developer wants to unload the DLL plug in file dynamically. It is a MUST to run cvxCmdVariableUnload() in the exit function.

Parameters
[in] | Name | global variable name
[in] | Variable | pointer to global variable
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdVariableUnload

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxCmdVariableUnload()

evxErrors cvxCmdVariableUnload ( const vxName Name )

#include <zwapi_cmd.h>

Unload the variable registered via cvxCmdVariable() if developer wants to unload the DLL plug in file dynamically. The input name must be the same as the one used in cvxCmdVariable().

Parameters
[in] Name Variable name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxMacroInqPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxMacroInqPath()

evxErrors cvxMacroInqPath | ( | vxPath | path,
 |  | vxPath | file
 | ) |  |

#include <zwapi_cmd.h>

Gets the path and file name of the currently running macro. If no running macro, path[0] = 0 and file[0] = 0. The path and file cannot both be NULL.

Parameters
[out] | path | path of macro (NULL to ignore)
[out] | file | file name of macro (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxMacroInqPathByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxMacroInqPathByLongPath()

evxErrors cvxMacroInqPathByLongPath | ( | char * | path,
 |  | int | sizepath,
 |  | char * | file,
 |  | int | filesize
 | ) |  |

#include <zwapi_cmd.h>

Gets the path and file name of the currently running macro. If no running macro, path[0] = 0 and file[0] = 0. The path and file cannot both be NULL.

A path that is too long (longer than "sizepath") is truncated. A file that is too long (longer than "filesize") is truncated.

It is assumed that the input "name" and "file" are no longer than 512 bytes.

Parameters
[out] | path | path of macro (NULL to ignore)
[in] | sizepath | max size of path
[out] | file | file name of macro (NULL to ignore)
[in] | filesize | max size of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxNewCommand

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command API
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ cvxNewCommand()

void cvxNewCommand ( void )

#include <zwapi_cmd.h>

Displays buffered error messages and resets the GUI to prompt the user for a new command. Generally you would call this function at the end of your custom API code before returning control to ZW3D – unless your code is automatically called by a custom command template.

Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Command Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Command Data
Commands Creation » Command Definition

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Command Container and Command Parameter.

Command Operation Data

enum | evxCmdAction { VX_CMD_START = 0 , VX_CMD_FINISHED }
command action type More...
enum | evxCmdState { VX_CMD_ENABLE = 0 , VX_CMD_DISABLE = 1 }
command state type More...
enum evxCmdType {
VX_STANDARD_COMMAND = -1 , VX_HIST_GENERAL = 0 , VX_HIST_SOLID_CREATE = 11 , VX_HIST_SOLID_EDIT = 12 ,
VX_HIST_SURF_CREATE = 13 , VX_HIST_SURF_EDIT = 14 , VX_HIST_CRV_CREATE = 15 , VX_HIST_CRV_EDIT = 16 ,
VX_HIST_COMP = 17 , VX_HIST_SKETCH = 18 , VX_HIST_DATUM = 19 , VX_HIST_FILLET = 20 ,
VX_HIST_SHELL = 21 , VX_HIST_SHT_METAL = 22 , VX_HIST_HOLE = 23 , VX_HIST_CRV_LIST = 24 ,
VX_HIST_IMPORT = 25 , VX_HIST_REF_GEOM = 26 , VX_HIST_EQN = 27 , VX_HIST_HEAL = 28 ,
VX_HIST_ERASE = 29 , VX_HIST_BLANK = 30 , VX_HIST_ATTRIBUTE = 33 , VX_HIST_RENDER = 34 ,
VX_HIST_ANALYZE = 35 , VX_HIST_MOVE = 37 , VX_HIST_TEXT = 38 , VX_HIST_POINT = 39 ,
VX_HIST_DRAFT = 40 , VX_HIST_ASSEMBLY = 41 , VX_HIST_TAG = 42 , VX_HIST_MOLD = 43
}
command types More...
typedef enum evxCmdAction | evxCmdAction
command action type
typedef enum evxCmdState | evxCmdState
command state type
typedef struct svxCmdActionParam | svxCmdActionParam
command action parameter
typedef enum evxCmdType | evxCmdType
command types

Data Get Data

enum | evxFldNumType { VX_INP_DOUBLE = 0 , VX_INP_INTEGER = 1 , VX_INP_DISTANCE = 2 , VX_INP_ANGLE = 3 }
numeric input field type More...
enum evxFldType {
VX_FLD_NULL = 0 , VX_FLD_NUM = 1 , VX_FLD_DST = 2 , VX_FLD_ANG = 3 ,
VX_FLD_PNT = 4 , VX_FLD_ENT = 5 , VX_FLD_TXT = 6 , VX_FLD_DATA = 7
}
point input data types More...
typedef enum evxFldNumType | evxFldNumType
numeric input field type
typedef enum evxFldType | evxFldType
point input data types
typedef struct svxFldData | svxFldData
field data
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Template Command

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Template Command
Commands Creation » Command Definition

Detailed Description

Modules

Template Field API
Template API
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Template Field API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Template Field API
Commands Creation » Command Definition » Template Command

Detailed Description

THE MODULE FOR THE ZW3D Command Parameter API

Command Initialization

evxErrors cvxDataInit (const vxName Template, int *idData)

Data Set

void | cvxDataZero (svxData *Data)
evxErrors | cvxDataSet (int idData, int idField, svxData *Data)
evxErrors | cvxDataSetColor (int idData, int idField, svxColor *Color)
evxErrors | cvxDataSetPath (int idData, int idField, svxEntPath *Ent)
evxErrors | cvxDataSetPromote (int idData, int idField, int Promote)
evxErrors | cvxDataSetPntOnCrv (int idData, int idField, int idCrv, svxPoint *Pnt)
evxErrors | cvxDataSetPntOnFace (int idData, int idField, int idComp, int idFace)
evxErrors | cvxDataSetPntOnFace2 (int idData, int idField, int idFace, svxPoint *Pnt)
evxErrors | cvxDataSetPntByPath (int idData, int idField, svxEntPath *entPath, svxPoint *pnt)
evxErrors | cvxDataSetPntOnCrvPath (int idData, int idField, int critPnt, const svxEntPath *crvPath, const svxPoint *pnt)
evxErrors | cvxDataSetPntOnEnt (int idData, int idField, const svxPntOnEnt *pntData)
evxErrors | cvxDataSetPntOnEntPath (int idData, int idField, const svxPntOnEntPath *pntData)
evxErrors | cvxDataSetDirOnEntPath (int idData, int idField, const svxDirOnEntPath *dirData)
evxErrors | cvxDataSetMatrix (int idData, int idField, const svxMatrix *mat)
evxErrors | cvxDataToFeature (int idData, int idFeature, int ExcludeRegen)

Data Get

evxErrors | cvxDataGet (int idData, int idField, svxData *Data)
evxErrors | cvxDataGetColor (int idData, int idField, svxColor *Color)
evxErrors | cvxDataGetEnt (int idData, int idField, int *idEnt, int *idParent)
evxErrors | cvxDataGetEnts (int idData, int idField, int *Count, int **idEnts)
evxErrors | cvxDataGetList (int idData, int idField, int *Count, svxData **Data)
evxErrors | cvxDataGetNum (int idData, int idField, double *Number)
int | cvxDataGetOpt (int idData, int idField)
int | cvxDataGetPath (int idData, int idField, int *FirstEnt, svxEntPath *Ent)
evxErrors | cvxDataGetPaths (int idData, int idField, int *count, svxEntPath **paths)
evxErrors | cvxDataGetPnt (int idData, int idField, svxPoint *Pnt)
evxErrors | cvxDataGetPnts (int idData, int idField, int *Count, svxPoint **Pnts)
evxErrors | cvxDataGetPntOnEnt (int idData, int idField, svxPoint *pnt, svxEntPath *path)
evxErrors | cvxDataGetPntsOnEnts (int idData, int idField, int *count, svxPoint **pnts, svxEntPath **paths)
evxErrors | cvxDataGetPromote (int idData, int idField, int *Promote)
evxErrors | cvxDataGetText (int idData, int idField, int NumBytes, char *Text)
evxErrors | cvxDataGetMatrix (int idData, int idField, svxMatrix *Matrix)
evxErrors | cvxDataGetItemList (int idData, int idField, int *Count, int **idItems)
evxErrors | cvxDataGetItemData (int idItem, svxData *Data)
evxErrors | cvxDataGetAll (int idData, int *numFld, svxFldData **fldData)
void | cvxFldDataFree (int Count, svxFldData **fldData)

Data Clear

evxErrors | cvxDataClear (int idData, int idField)
evxErrors | cvxDataDel (int idData, int idField)
evxErrors | cvxDataDelItem (int idData, int idField, int iEnt)
evxErrors | cvxDataDelUnHi (int idData, int idField)
evxErrors | cvxDataFree (int idData)
evxErrors | cvxDataGrpRem (int idData, int idField, int idItem)

Data Query

evxErrors | cvxDataInqActive (int *idData)
evxErrors | cvxDataInqParent (int *idData)
char * | cvxDataName (int idData)

Aux Frame

void | cvxAuxFrameShow (int idData, int entField, int matField)
void | cvxAuxFrameSetOrigin (const svxPoint *Origin)
void | cvxAuxFrameSetAxisVec (evxAxisType AxisType, const svxVector *AxisDir)
void | cvxAuxFrameSetDirXYZOrgBuddy (int idData, int idXFld, int idYFld, int idZFld, int idOrgFld)
void | cvxMoveSetAuxFrameElem (int iElem)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxAuxFrameSetAxisVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxAuxFrameSetAxisVec()

void cvxAuxFrameSetAxisVec | ( | evxAxisType | AxisType,
 |  | const svxVector * | AxisDir
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Set direction of Aux Frame.

Parameters
[in] | AxisType | axis type
[in] | AxisDir | direction
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxAuxFrameSetDirXYZOrgBuddy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxAuxFrameSetDirXYZOrgBuddy()

void cvxAuxFrameSetDirXYZOrgBuddy | ( | int | idData,
 |  | int | idXFld,
 |  | int | idYFld,
 |  | int | idZFld,
 |  | int | idOrgFld
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Set buddy field of Aux Frame. the function must be called after cvxAuxFrameShow function.

Parameters
[in] | idData | VDATA
[in] | idXFld | x field
[in] | idYFld | y field
[in] | idZFld | z field
[in] | idOrgFld | origin field
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxAuxFrameSetOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxAuxFrameSetOrigin()

void cvxAuxFrameSetOrigin ( const svxPoint * Origin )

#include <zwapi_cmd_paramdefine_param.h>

Set origin position of Aux Frame.

Parameters
[in] Origin origin of aux frame
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxAuxFrameShow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxAuxFrameShow()

void cvxAuxFrameShow | ( | int | idData,
 |  | int | entField,
 |  | int | matField
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Show or hide Aux Frame by the input init values. Aux frame is displayed when idData equals to the id of data container. Aux frame is hidden when idData equals to -1.

Parameters
[in] | idData | id of data container
[in] | entField | id of entity field, to store selected entities
[in] | matField | id of matrix field, to store matrix data for aux frame
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataClear

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataClear()

evxErrors cvxDataClear | ( | int | idData,
 |  | int | idField
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Deletes data associated with the specified field (idField) of the specified data container (idData).

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataDel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataDel()

evxErrors cvxDataDel | ( | int | idData,
 |  | int | idField
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Delete the data associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataDelItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataDelItem()

evxErrors cvxDataDelItem | ( | int | idData,
 |  | int | idField,
 |  | int | iEnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Delete specified input data item associated with the specified field (data_id) of the specified VDATA object (idx_data) which is assumed to reside in PRJ_BIN.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | iEnt | entity to delete
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataDelUnHi

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataDelUnHi()

evxErrors cvxDataDelUnHi | ( | int | idData,
 |  | int | idField
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Delete the data associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataFree()

evxErrors cvxDataFree ( int idData )

#include <zwapi_cmd_paramdefine_param.h>

Deletes a data container created by cvxDataInit(), freeing the memory associated with it.

Parameters
[in] idData id of data container (i.e. VDATA)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGet()

evxErrors cvxDataGet | ( | int | idData,
 |  | int | idField,
 |  | svxData * | Data
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the first item of data associated with the specified field of the specified data container.

When the data come from a numeric input field in an option form, any expression entered by the user will be evaluated to determine a value for the number; the numeric value will be output in "Data->Num" and the expression will be output in "Data->Text".

When the data come from a text input field, the raw text is output in "Data->Text" without replacing expressions. If you wish to support variable reference expressions such as "[$VAR]" where VAR is the name of a variable in the active target, the output string from this function can be given to the cvxPartVarSubstitute() function to replace the "[$VAR]" expressions with the values of the variables. For example:

svxData Data;
if (!cvxDataGet(idData, idField, &Data) && Data.isText)
cvxPartVarSubstitute(Data.Text, sizeof(Data.Text), NULL);
cvxDataGet
evxErrors cvxDataGet(int idData, int idField, svxData *Data)
cvxPartVarSubstitute
evxErrors cvxPartVarSubstitute(char *Str, int nBytes, int *Truncated)
svxData::isText
char isText
1 if "Text" is defined, else 0
Definition: zwapi_util.h:1561
svxData::Text
char Text[512]
text string (expression if "isNumber=1")
Definition: zwapi_util.h:1586
svxData
command input data item
Definition: zwapi_util.h:1555
Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Data | first data item associated with "idField"
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetAll()

evxErrors cvxDataGetAll | ( | int | idData,
 |  | int * | numFld,
 |  | svxFldData ** | fldData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets data for all field in which valid data exists associated with the specified data container.

If using cvxPartInqFtrData() to get idData prior to calling this function, set cvxPartInqFtrData()'s iNoEval input argument to 0 to ensure idData will contain evaluated data.

The calling procedure is responsible for deallocating the memory assigned by this function to the "fldData" structure using cvxFldDataFree().

Parameters
[in] | idData | id of data container (i.e. VDATA)
[out] | numFld | number of fields in which valid data exists
[out] | fldData | list of field data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetColor()

evxErrors cvxDataGetColor | ( | int | idData,
 |  | int | idField,
 |  | svxColor * | Color
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the RGB color values in the specified VDATA field as an integer or one index value. Use cvxDataSetColor() to encode RGB color as an integer or one index value into VDATA field.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Color | rgb color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetEnt()

evxErrors cvxDataGetEnt | ( | int | idData,
 |  | int | idField,
 |  | int * | idEnt,
 |  | int * | idParent
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the entity id associated with the specified field of the specified data container. Input NULL for "idParent" if you are not interested in getting parent information.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | idEnt | id of entity associated with field (0 if undefined)
[out] | idParent | id of entity parent (0 if undefined; NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetEnts()

evxErrors cvxDataGetEnts | ( | int | idData,
 |  | int | idField,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the list of entity id's associated with the specified field of the specified data container. The list referenced by "**idEnts" is allocated by this function and must be deallocated by the calling procedure. A NULL pointer is output if no data is found.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Count | data item count
[out] | idEnts | list of entity id's associated with field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetItemData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetItemData()

evxErrors cvxDataGetItemData | ( | int | idItem,
 |  | svxData * | Data
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Get data of associated with specified data item.

Parameters
[in] | idItem | index of data item
[out] | Data | data of associated with specified data item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetItemList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetItemList()

evxErrors cvxDataGetItemList | ( | int | idData,
 |  | int | idField,
 |  | int * | Count,
 |  | int ** | idItems
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Get a list of data item indices associated with the specified field of the specified data container.

The list referenced by "**idItems" is allocated by this function and must be deallocated by the calling procedure. A NULL pointer is output if no data is found.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Count | data item count
[out] | idItems | list of data item indices associated with field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetList()

evxErrors cvxDataGetList | ( | int | idData,
 |  | int | idField,
 |  | int * | Count,
 |  | svxData ** | Data
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the list of data items associated with the specified field of the specified data container. The list referenced by "**Data" is allocated by this function and must be deallocated by the calling procedure. A NULL pointer is output if no data is found.

Note
For set list widget, idEntity to output the VDATA list associated with "idField"
Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Count | data item count
[out] | Data | list of data items associated with "idField"
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetMatrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetMatrix()

evxErrors cvxDataGetMatrix | ( | int | idData,
 |  | int | idField,
 |  | svxMatrix * | Matrix
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Get the transformation matrix associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Matrix | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetNum()

evxErrors cvxDataGetNum | ( | int | idData,
 |  | int | idField,
 |  | double * | Number
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the double precision number associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Number | double precision number associated with "idField"
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetOpt()

int cvxDataGetOpt | ( | int | idData,
 |  | int | idField
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Returns the integer option number associated with the specified field.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
Returns
  • the integer option number associated with the specified field
  • 0 - if no number is associated with the specified field or function fails
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPath()

int cvxDataGetPath | ( | int | idData,
 |  | int | idField,
 |  | int * | FirstEnt,
 |  | svxEntPath * | Ent
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Get the entity pick-path associated with "idField" of "idData".

This function does not activate the pick-path.

If "*FirstEnt=1", the first pick is retrieved, "*FirstEnt" is set to zero and static variables inside this function are set up to enable retrieval of the next pick when this function is called again with "*FirstEnt=0". If a pick is successfully retrieved, this function returns 0. If no pick was retrieved, it returns -1. If there was a fatal error, it returns 1.

If "FirstEnt=NULL", the first entity is retrieved without setting things up to get a "next" entity.

This function should not be called recursively, but no checking is done to insure it.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in,out] | FirstEnt | 1 for first entity; 0-subsequent entities
[out] | Ent | entity pick path
Return values
succeeds
  • 0 - no error and an entity was retrieved successfully
  • -1 - no error, but no entity was retrieved.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVAID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPaths()

evxErrors cvxDataGetPaths | ( | int | idData,
 |  | int | idField,
 |  | int * | count,
 |  | svxEntPath ** | paths
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Get the entity pick-paths associated with "idField" of "idData". "**paths" is allocated by this function and must be deallocated by the calling procedure.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | count | count of paths
[out] | paths | list of entity pick path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_aPI_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPnt()

evxErrors cvxDataGetPnt | ( | int | idData,
 |  | int | idField,
 |  | svxPoint * | Pnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the point coordinates associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Pnt | point associated with field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPntOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPntOnEnt()

evxErrors cvxDataGetPntOnEnt | ( | int | idData,
 |  | int | idField,
 |  | svxPoint * | pnt,
 |  | svxEntPath * | path
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the point coordinates and path of point on entity associated with the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | pnt | point associated with field
[out] | path | path of point on entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPnts()

evxErrors cvxDataGetPnts | ( | int | idData,
 |  | int | idField,
 |  | int * | Count,
 |  | svxPoint ** | Pnts
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the list of point coordinates associated with the specified field of the specified data container. The list referenced by "**Pnts" is allocated by this function and must be deallocated by the calling procedure. A NULL pointer is output if no data is found.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Count | data item count
[out] | Pnts | list of points associated with field
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_APPI_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPntsOnEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPntsOnEnts()

evxErrors cvxDataGetPntsOnEnts | ( | int | idData,
 |  | int | idField,
 |  | int * | count,
 |  | svxPoint ** | pnts,
 |  | svxEntPath ** | paths
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the list of point coordinates and list of paths associated with the specified field of the specified data container. The list referenced by "**paths" and "**pnts" are allocated by this function and must be deallocated by the calling procedure.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | count | data item count
[out] | pnts | list of points associated with field
[out] | paths | list of paths associated with points(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetPromote

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetPromote()

evxErrors cvxDataGetPromote | ( | int | idData,
 |  | int | idField,
 |  | int * | Promote
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Outputs "Promote=1", if the pick associated with the point-on-entity stored in the specified input field should be promoted to pick the parent of the entity instead of the entity itself. If not, "Promote=0" is output.

A common case is the promotion of a curve pick to its parent sketch or curve list.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[out] | Promote | 1 to promote entity to parent, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGetText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGetText()

evxErrors cvxDataGetText | ( | int | idData,
 |  | int | idField,
 |  | int | NumBytes,
 |  | char * | Text
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Gets the null-terminated ascii text string associated with the specified field of the specified data container.

If necessary, the string copied to the memory referenced by "Text" is truncated based on the value of "NumBytes".

The calling procedure is responsible for allocating and deallocating the memory referenced by "Text".

Note
This function outputs the raw text contained in the specified field.
Expressions embedded in the text to reference ZW3D variables are not automatically replaced by the variable values.
If you wish to support variable references of the form "[$VAR]" where VAR is the name of a variable in the active target, the output string from this function can be given to the cvxPartVarSubstitute() or cvxPartVarSubstituteResize() function to replace the "[$VAR]" expressions with the values of the variables.
Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | NumBytes | number of bytes of memory referenced by "Text"
[out] | Text | null-terminated ascii string
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataGrpRem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataGrpRem()

evxErrors cvxDataGrpRem | ( | int | idData,
 |  | int | idField,
 |  | int | idItem
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Remove the specified data item from specified field.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | idItem | index of data item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_DATA_ERROR
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataInit()

evxErrors cvxDataInit | ( | const vxName | Template,
 |  | int * | idData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Creates and initializes a data container for the specified command. The calling procedure is responsible for deleting the container and its contents using cvxDataFree().

Parameters
[in] | Template | command template name
[out] | idData | id of data container
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataInqActive()

evxErrors cvxDataInqActive ( int * idData )

#include <zwapi_cmd_paramdefine_param.h>

Get the index of the data container associated with the active form. If no form is activated, idData is set to -1.

Parameters
[out] idData id of data container
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataInqParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataInqParent()

evxErrors cvxDataInqParent ( int * idData )

#include <zwapi_cmd_paramdefine_param.h>

Get the index of the data container associated with the parent of an active form. if no form is activated or active form has no parent form, idData is set to -1.

Parameters
[out] idData id of data container
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataName()

char * cvxDataName ( int idData )

#include <zwapi_cmd_paramdefine_param.h>

Gets form name by VDATA.

Parameters
[in] idData id of data container (i.e. VDATA)
Returns
  • Form name;
  • NULL if function fails.
Warning
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSet()

evxErrors cvxDataSet | ( | int | idData,
 |  | int | idField,
 |  | svxData * | Data
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Assigns the specified item of data to the specified field of the specified data container. If "idField" is defined as a list in the command template used to initialize "idData", the new item of data is appended to items already associated with the field. If the field is not defined as a list, any existing item is replaced.

Note
For set list widget, it could be set idEntity to input the command VDATA that could be created by cvxDataInit().
Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | Data | data item
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetColor()

evxErrors cvxDataSetColor | ( | int | idData,
 |  | int | idField,
 |  | svxColor * | Color
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

If the corresponding color widget's type is index color, find the color index by input "Color" rgb value.
If the rgb value is not one of index color, it will return 1, otherwise set the index into specified VDATA field.
If type is true color, encodes the input RGB color values as an integer stored in VDATA field.
Use cvxDataGetColor() to retrieve RGB color from the field.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | Color | rgb color
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetDirOnEntPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetDirOnEntPath()

evxErrors cvxDataSetDirOnEntPath | ( | int | idData,
 |  | int | idField,
 |  | const svxDirOnEntPath * | dirData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Log the direction of point on the entity or direction to the specified field. The point can be on the curve or the surface, datum plane.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | dirData | direction data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetMatrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetMatrix()

evxErrors cvxDataSetMatrix | ( | int | idData,
 |  | int | idField,
 |  | const svxMatrix * | mat
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Logs a "mat" pick to the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | mat | entity matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPath()

evxErrors cvxDataSetPath | ( | int | idData,
 |  | int | idField,
 |  | svxEntPath * | Ent
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Append the specified entity to the specified field of the specified data container.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | Ent | entity pick path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntByPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntByPath()

evxErrors cvxDataSetPntByPath | ( | int | idData,
 |  | int | idField,
 |  | svxEntPath * | entPath,
 |  | svxPoint * | pnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Add the specified point (pnt) as the Nth element (N = idField) of the specified data object (VDATA).

If the Nth element is already defined (and it is a list), the point is appended to a list of points referenced by the Nth element.

If the NTh element is defined (and it is not a list), the point is overwritten.

Note
The id of path must start with -2 if you use "CdCnsCoin" command for a secondary development.
Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | entPath | the entity pick path
[in] | pnt | point on the entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnCrv()

evxErrors cvxDataSetPntOnCrv | ( | int | idData,
 |  | int | idField,
 |  | int | idCrv,
 |  | svxPoint * | Pnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Logs a "point on curve" pick to the specified field of the specified data container. Projects the specified point (Pnt) onto the specified curve. The point should lie on or near the curve.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | idCrv | id of curve in active root object
[in] | Pnt | point on or near the curve or key point of curve (NULL to use the start point of the curve )
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnCrvPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnCrvPath()

evxErrors cvxDataSetPntOnCrvPath | ( | int | idData,
 |  | int | idField,
 |  | int | critPnt,
 |  | const svxEntPath * | crvPath,
 |  | const svxPoint * | pnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Add the specified point on curve as the Nth element (N = idField) of the specified data object (VDATA).

If the Nth element is already defined (and it is a list), the point is appended to a list of points referenced by the Nth element.

If the NTh element is defined (and it is not a list), the point is overwritten.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | critPnt | whether to map point to critical point of curve
[in] | crvPath | pick path of curve
[in] | pnt | point on the curve
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_OBJ_TYPE_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnEnt()

evxErrors cvxDataSetPntOnEnt | ( | int | idData,
 |  | int | idField,
 |  | const svxPntOnEnt * | pntData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Log the point/direction on the entity or point/direction to the specified field.

If you want to log the critical point to the field, you should set useCritPnt to 1 and set one type to critTyp.

The point can be on the curve or the surface.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | pntData | point on entity data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnEntPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnEntPath()

evxErrors cvxDataSetPntOnEntPath | ( | int | idData,
 |  | int | idField,
 |  | const svxPntOnEntPath * | pntData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Log the point on the entity or point to the specified field. The point can be on the curve or the surface, datum plane.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | pntData | point on entity data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_OBJ_DATA_SET_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnFace()

evxErrors cvxDataSetPntOnFace | ( | int | idData,
 |  | int | idField,
 |  | int | idComp,
 |  | int | idFace
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Logs a "point on face" pick to the specified field of the specified data container. Uses a point on the specified face at the midpoint of the face's bounding box in UV parameter space.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | idComp | id of component in active part (0 to ignore)
[in] | idFace | id of face in active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPntOnFace2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPntOnFace2()

evxErrors cvxDataSetPntOnFace2 | ( | int | idData,
 |  | int | idField,
 |  | int | idFace,
 |  | svxPoint * | Pnt
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Logs a "point on face" pick to the specified field of the specified data container. Projects the specified point (Pnt) onto the face. The point should lie on or very near to the face in a location that can be projected onto the face along a face normal.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | idFace | id of face in active part
[in] | Pnt | point on or near the face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataSetPromote

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataSetPromote()

evxErrors cvxDataSetPromote | ( | int | idData,
 |  | int | idField,
 |  | int | Promote
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

If "Promote" is input as a non-zero value, the point-on-entity pick stored in the specified input field is flagged to tell ZW3D to promote the pick to the parent of the entity instead of the entity itself.

If "Promote" is input as zero, the point-on-entity pick is flagged to tell ZW3D not to promote the pick to its parent.

A common case is the promotion of a curve pick to its parent sketch or curve list.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idField | id of data field
[in] | Promote | 1 to promote entity pick to parent, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataToFeature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataToFeature()

evxErrors cvxDataToFeature | ( | int | idData,
 |  | int | idFeature,
 |  | int | ExcludeRegen
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

When a feature is logged to the history, a copy of its driving VDATA is converted to a persistent state and recorded with the feature.

After that, any modification you make to the original VDATA is not reflected into the VDATA recorded in the history.

This function is used to update the VDATA associated with the specified feature (idFeature) with the contents of the input VDATA (idData).

If "idFeature < 1", the VDATA of the feature created by the active feature operation (CustomOp) is updated.

If "ExcludeRegen != 0", this function does nothing if it is called during history regeneration.

Before the contents of "iData" are assigned to the specified feature, an attempt is made to make all entity picks/references in the "iData" persistent.

This requires finding the specified entities in the active part in order to lookup their persistent labels. If the entities cannot be found in the current part state, this function will fail.

Parameters
[in] | idData | id of data container (i.e. VDATA)
[in] | idFeature | id of feature in active part (0 for active feature operation)
[in] | ExcludeRegen | 1 to disable the action of this function during regen, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDataZero

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxDataZero()

void cvxDataZero ( svxData * Data )

#include <zwapi_cmd_paramdefine_param.h>

Set all bytes of the input "Data" structure to zero.

Parameters
[in,out] Data pointer to data structure
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxFldDataFree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxFldDataFree()

void cvxFldDataFree | ( | int | Count,
 |  | svxFldData ** | fldData
 | ) |  |

#include <zwapi_cmd_paramdefine_param.h>

Frees memory associated with the specified field data structure.

Parameters
[in] | Count | number of field data
[in] | fldData | list of field data
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxMoveSetAuxFrameElem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template Field API
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ cvxMoveSetAuxFrameElem()

void cvxMoveSetAuxFrameElem ( int iElem )

#include <zwapi_cmd_paramdefine_param.h>

Show element of AuxFrame. Set 0 to show all(except QuadrantArea). Otherwise add below for "iElem":

  • AUXFRAME_X_AXIS 0x1
  • AUXFRAME_Y_AXIS 0x2
  • AUXFRAME_Z_AXIS 0x4
  • AUXFRAME_XY_QUA 0x8
  • AUXFRAME_YZ_QUA 0x10
  • AUXFRAME_ZX_QUA 0x20
  • AUXFRAME_ORIGIN 0x40
  • AUXFRAME_XY_AREA 0x80
  • AUXFRAME_YZ_AREA 0x100
  • AUXFRAME_ZX_AREA 0x200
Parameters
[in] iElem Set which element to show in AuxFrame
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Template API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Template API
Commands Creation » Command Definition » Template Command

Detailed Description

THE MODULE FOR THE ZW3D Command Container API

Command Execute

int | cvxCmdEval (vxName Name, int idData)
int | cvxCmdExec (int idData)
evxErrors | cvxCmdExec2 (int idData)
evxErrors | cvxCmdExecWithOut (int idData, int *idOut)

Command Operation

evxErrors | cvxCmdInput (const vxName Name, int idDataIn, int *idDataOut)
evxErrors | cvxCmdInteract (const vxName Name)
void | cvxCmdInqActive (vxName Name)
void | cvxCmdMarker (const vxName Okay, const vxName Cancel)
evxErrors | cvxCmdStateGet (vxName CmdName, evxCmdState *State)
evxErrors | cvxCmdStateSet (vxName CmdName, evxCmdState State)

Template Register/Un-register

evxErrors | cvxCmdTemplate (const vxLongPath File)
evxErrors | cvxCmdTemplateUnload (const vxLongPath File)

Echo Function

void | cvxEchoColorGet (evxColor *Color)
void | cvxEchoColorSet (evxColor Color)
void | cvxEchoColorAtSet (svxWireAt *at)
void | cvxEchoColorAtGet (svxWireAt *at)
void | cvxEchoCustomStart ()
void | cvxEchoCustomEnd ()
void | cvxEchoDraw ()
void | cvxEchoStart ()
void | cvxEchoEnd ()
void | cvxEchoEscDisable ()
void | cvxEchoEscRestore ()

Template Query

evxErrors | cvxTplInqFnCust (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnEcho (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnInit (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnTerm (vxName Name, int NumBytes, char *FnName)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdEval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdEval()

int cvxCmdEval | ( | vxName | Name,
 |  | int | idData
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Passes "idData" to the evaluation function identified by "Name". It is assumed the function has been registered with ZW3D (see cvxCmdFunc()). The function should be of type "int function(int idData, int *idOutput)". Undo-redo transaction logging is managed by this command.

Use cvxDataInit() and cvxDataSet() to set up "idData". Unlike cvxCmdExec(), "idData" is not deleted by this function. The calling procedure is responsible for cleaning up "idData" using cvxDataFree().

When an echo has been initiated with cvxEchoStart(), this function will call the echo_obj function associated with idData and add the objects to the echo instead of adding them to the database.

When in echo mode (cvxEchoStart() called)

Parameters
[in] | Name | name of evaluation function
[in] | idData | id of command data container
Return values
succeeds
  • 0 : Success
fail
  • 1 : Internal error
  • 2 : There is no active command
  • 3 : The active command does not have an echo_obj function
  • 4 : There is no echo object associated with the active command
  • 5 : The template associated with "idData" could not be found in Forms.Z3
  • 6 : The template associated with "idData" does not have an echo_obj function
  • 7 : The echo_obj function associated with "idData" was not registered
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdExec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdExec()

int cvxCmdExec ( int idData )

#include <zwapi_cmd_paramdefine_tpl.h>

Executes the command defined by "idData". Use cvxDataInit() and cvxDataSet() to set up "idData". "idData" is always deleted by this function, even if it fails.

When an echo has been initiated with cvxEchoStart(), this function will call the echo_obj function associated with the command and add the objects to the echo instead of adding them to the database.

Automatic creation of feature-sets is disabled while this function is executing.

When in echo mode (cvxEchoStart() called)

Parameters
[in] idData id of command data container
Return values
succeeds
  • 0 : Success
fail
  • 1 : Internal error
  • 2 : There is no active command
  • 3 : The active command does not have an echo_obj function
  • 4 : There is no echo object associated with the active command
  • 5 : The template associated with "idData" could not be found in Forms.Z3
  • 6 : The template associated with "idData" does not have an echo_obj function
  • 7 : The echo_obj function associated with "idData" was not registered
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdExec2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdExec2()

evxErrors cvxCmdExec2 ( int idData )

#include <zwapi_cmd_paramdefine_tpl.h>

Same as cvxCmdExec(), except that the VDATA object was not deleted when the command outputs its input.

Parameters
[in] idData id of command data container
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdExecWithOut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdExecWithOut()

evxErrors cvxCmdExecWithOut | ( | int | idData,
 |  | int * | idOut
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Same as cvxCmdExec2(), except that the function output the index of output data object.

Parameters
[in] | idData | id of command data container
[out] | idOut | id of output data object (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdInput

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdInput()

evxErrors cvxCmdInput | ( | const vxName | Name,
 |  | int | idDataIn,
 |  | int * | idDataOut
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Uses the specified template to gather input data. Waits in this function until the data has been collected. Then outputs the id of the collected data via "idxDataOut".

Assigns the input data to a new data object if "idDataIn < 1". Otherwise, uses new input data to modify the data object defined by "idDataIn". It is assumed that "idDataIn" was created by cvxDataInit().

If "idDataOut" is output as 0, "idDataIn" is automatically deleted. This means the user tried to execute another command while this function was waiting for input.

Parameters
[in] | Name | command template name
[in] | idDataIn | optional data container id (0 if undefined)
[out] | idDataOut | output data container id (0 if undefined)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdInqActive()

void cvxCmdInqActive ( vxName Name )

#include <zwapi_cmd_paramdefine_tpl.h>

Outputs the name of the active command input form.

Parameters
[out] Name name of active command input form
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdInteract

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdInteract()

evxErrors cvxCmdInteract ( const vxName Name )

#include <zwapi_cmd_paramdefine_tpl.h>

Executes the specified command in interactive input mode (i.e. those commands that would preceded by an exclamation mark when executed from the command line). The user is prompted for the command's inputs, then the command is executed.

Parameters
[in] Name command template name
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdMarker

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdMarker()

void cvxCmdMarker | ( | const vxName | Okay,
 |  | const vxName | Cancel
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Log undo-redo markers for the active template-driven command.

If "Okay" defines a valid marker, ZW3D will automatically undo to the marker when input for the active command is accepted by the user.

This undo will happen BEFORE the evaluation function associated with the command is executed.

If the user cancels the active command while input is being gathered, ZW3D will automatically undo to the "Cancel" marker, if it is defined.

Input a blank string or NULL if a marker is not defined for either the "Okay" or "Cancel" case.

Undo-redo markers (see cvxUndoRedoMarker()) may be used with this function to manage automatic deletion of entities created during the user input gathering phase of a template-based command.

Parameters
[in] | Okay | undo to this marker on "Okay" (or input NULL)
[in] | Cancel | undo to this marker on "Cancel" (or input NULL)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdStateGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdStateGet()

evxErrors cvxCmdStateGet | ( | vxName | CmdName,
 |  | evxCmdState * | State
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Get the state of the command.

Parameters
[in] | CmdName | command name
[out] | State | state of the command
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdStateSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdStateSet()

evxErrors cvxCmdStateSet | ( | vxName | CmdName,
 |  | evxCmdState | State
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Set the state of the command.

Parameters
[in] | CmdName | command name
[in] | State | state of the command
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdTemplate()

evxErrors cvxCmdTemplate ( const vxLongPath File )

#include <zwapi_cmd_paramdefine_tpl.h>

Loads, compiles and registers the command template(s) defined in the specified file.

If "File" does not define a full path to the template file, ZW3D searches for the file in the runtime directory, the directories defined in "vxpaths", and the installation directories.

When ZW3D session management is enabled, dynamically-loaded templates are deleted when a session is cleared.
So that ZW3D can automatically reload the templates on-demand, register the directory that contains your template files using cvxPathAdd().
Each template file should have the same name (minus the .t extension) as the command defined inside of it. For example, if "TEMPLATE=MyCommand", the container file should be named "MyCommand.t".

A command template defines the input data required by a command and the name of the function the data is passed to for command execution.
The template also has information that tells the ZW3D Input Manager how to interactively prompt the user for the inputs required by the command.
These input fields may have callback functions associated with them.
All functions and variables referenced by a command template must be registered with cvxCmdFunc(), cvxCmdCallback() or cvxCmdVariable().
See the "Virtual Forms" online help topic for more information about the definition of command templates.

When a command template is used to define an "Options" form (i.e. opt_form), fields of the "opt_form" may be managed using some cvxFieldXXX() and cvxItemXXX() functions.
This is done by inputting "OptForm" for the "Form" argument of the form management functions.

Another way to dynamically define a template is to write it to a file in the ZW3D "temp" directory (see cvxPathTemp()) and then use this function to load/compile it.
When a session is cleared, ZW3D reloads command templates from the "temp" directory on-demand – as long as the template file name is the command name defined inside the file by "TEMPLATE=...".
Template files in the "temp" directory are automatically deleted when ZW3D exits.

If developer wants to unload the DLL plug in file dynamically. It is a MUST to run cvxCmdTemplateUnload() in the exit function.

Parameters
[in] File file that contains command template(s)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxCmdTemplateUnload

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxCmdTemplateUnload()

evxErrors cvxCmdTemplateUnload ( const vxLongPath File )

#include <zwapi_cmd_paramdefine_tpl.h>

Unload the command template(s) defined in the specified file and registered via cvxCmdTemplate() or cvxFormTemplate() if developer wants to unload the DLL plug in file dynamically. The input file path must be the same as the one used in cvxCmdTemplate().

Parameters
[in] File file that contains command template(s)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoColorAtGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoColorAtGet()

void cvxEchoColorAtGet ( svxWireAt * at )

#include <zwapi_cmd_paramdefine_tpl.h>

Return display attributes stored at echo.

Parameters
[out] at display attributes
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoColorAtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoColorAtSet()

void cvxEchoColorAtSet ( svxWireAt * at )

#include <zwapi_cmd_paramdefine_tpl.h>

Set display attributes echo.

Parameters
[in] at display attributes
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoColorGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoColorGet()

void cvxEchoColorGet ( evxColor * Color )

#include <zwapi_cmd_paramdefine_tpl.h>

Gets the active wireframe color of the dynamic echo.

Parameters
[out] Color active wireframe color for dynamic echo
Warning
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoColorSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoColorSet()

void cvxEchoColorSet ( evxColor Color )

#include <zwapi_cmd_paramdefine_tpl.h>

Sets the active color (wireframe and shaded) for dynamic echo.

Parameters
[in] Color active color for dynamic echo
Warning
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoCustomEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoCustomEnd()

void cvxEchoCustomEnd ( )

#include <zwapi_cmd_paramdefine_tpl.h>

cvxEchoEnd MUST be called at the end of the function that called cvxEchoCustomStart. Failure to do so could leave aspects of the GUI disabled (including error display) and could also mess up undo-redo.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoCustomStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoCustomStart()

void cvxEchoCustomStart ( )

#include <zwapi_cmd_paramdefine_tpl.h>

cvxEchoCustomStart() should only be called at the beginning of the "echo_obj" function associated with the currently executing command template.
It should ALWAYS be paired with a call to cvxEchoCustomEnd() at the end of the "echo_obj" function.

Calling this function at the beginning of an "echo_obj" function sets up the environment so that you can use other API functions to edit the target object inside the "echo_obj" function.
Those edits will persist until the next time the "echo_obj" function is called, at which time the edits will automatically be undone prior to the next round of edits to the target object.

The function prototype for a custom echo function looks like the following:

void MyCustomEcho(int idData, void *echo)

The "idData" passed to MyCustomEcho() is the id of the same container of command input data that is passed to the evaluation function associated with the currently executing command template.

The "void *echo" argument is currently not used but should be included in the echo function's argument list as shown.

Register a pointer to the custom echo function as follows:

cvxCmdFunc("MyCustomEcho",(void*)MyCustomEcho,0.0);

The custom echo function is registered in the custom command template as follows:

<property name="echo_obj">MyCustomEcho</property>

This function should not be used in conjunction with cvxEchoStart().

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoDraw

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoDraw()

void cvxEchoDraw ( )

#include <zwapi_cmd_paramdefine_tpl.h>

Draw the echo data of the active form.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoEnd()

void cvxEchoEnd ( )

#include <zwapi_cmd_paramdefine_tpl.h>

Instructs the API to stop sending entities to the echo and start sending them to the database again.

cvxEchoEnd() MUST be called at the end of the echo that called cvxEchoStart(). Failure to do so will cause most API functions to quit working.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoEscDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoEscDisable()

void cvxEchoEscDisable ( )

#include <zwapi_cmd_paramdefine_tpl.h>

Disable checking for certain escapes that ZW3D may issue while an echo function is executing. This function does not disable checking for escapes issued by the user.

Each call to this function must be paired with a call to cvxEchoEscRestore().

Use of this function is discouraged. It is intended for special situations in which a long-running echo function would otherwise trigger an automatic escape.
Usually such escapes should be allowed to occur to keep the user interface responsive during echo. An appropriate use of this function, for example, would be to disable escape checking to make an expensive calculation once in an echo function, after which the echo function might cache the results and restore escape checking so future calls to the echo function can execute quickly and respond normally to ZW3D's built-in automatic escapes.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoEscRestore

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoEscRestore()

void cvxEchoEscRestore ( )

#include <zwapi_cmd_paramdefine_tpl.h>

Restore escape checking previously disabled by a call to cvxEchoEscDisable().

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEchoStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxEchoStart()

void cvxEchoStart ( )

#include <zwapi_cmd_paramdefine_tpl.h>

Instructs the API to start sending entities to the echo rather than to the database. The function should always be paired with a call to cvxEchoEnd().

cvxEchoStart() should only be called from within the "echo_obj" function associated with the currently executing command template.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFnCust

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxTplInqFnCust()

evxErrors cvxTplInqFnCust | ( | vxName | Name,
 |  | int | NumBytes,
 |  | char * | FnName
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Gets the name of the custom function associated with the specified template.

Parameters
[in] | Name | template name
[in] | NumBytes | no. bytes of function name
[out] | FnName | name of custom function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFnEcho

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxTplInqFnEcho()

evxErrors cvxTplInqFnEcho | ( | vxName | Name,
 |  | int | NumBytes,
 |  | char * | FnName
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Gets the name of the "echo" function associated with the specified template.

Parameters
[in] | Name | template name
[in] | NumBytes | no. bytes of function name
[out] | FnName | name of echo function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFnInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxTplInqFnInit()

evxErrors cvxTplInqFnInit | ( | vxName | Name,
 |  | int | NumBytes,
 |  | char * | FnName
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Gets the name of the "init" function associated with the specified template.

Parameters
[in] | Name | template name
[in] | NumBytes | no. bytes of function name
[out] | FnName | name of initialization function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxTplInqFnTerm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Template API
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ cvxTplInqFnTerm()

evxErrors cvxTplInqFnTerm | ( | vxName | Name,
 |  | int | NumBytes,
 |  | char * | FnName
 | ) |  |

#include <zwapi_cmd_paramdefine_tpl.h>

Gets the name of the "term" function associated with the specified template.

Parameters
[in] | Name | template name
[in] | NumBytes | no. bytes of function name
[out] | FnName | name of termination function
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Part and Assembly Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Part and Assembly Commands
Commands Creation

Detailed Description

Modules

Assembly Commands
Assembly Commands Data
Data Exchange Commands
Data Exchange Commands Data
Datum Commands
Datum Commands Data
Direct Edit
Direct Edit Commands Data
ECAD Board Commands
ECAD Board Commands Data
Free Form Commands
Free Form Commands Data
PMI Commands
PMI Commands Data
Shape Commands
Shape Commands Data
Sheet Metal Commands
Sheet Metal Commands Data
Create Sketch Commands
Create Sketch Commands Data
Sub Commands
Sub Commands Data
UDF API
UDF Data
Wireframe Commands
Wireframe Commands Data
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Assembly Commands API

Component

int | cvxCompIns (svxCompData *Comp, int *idComp)
evxErrors | cvxCompInclude (const svxCompIncludeData *Comp, int *idComp)
evxErrors | cvxCompMerge (evxBoolType Combine, int idComp, int *idShape)
evxErrors | cvxCompMerge2 (evxBoolType Combine, int idComp, int MergeDim, int MergeWire, int *idShape)
evxErrors | cvxCompExtract (int idShape, svxMatrix *Frame, vxLongName Name, int NewFile, evxResponse Overwrite, int *idComp)
evxErrors | cvxPartGeomExport (svxGeomExport *Data)
evxErrors | cvxPartGeomExportII (svxGeomExport *Data)
evxErrors | cvxPartIns (svxPartInstData *Part, int *Count, int **ShapeList)

Common Constraint

evxErrors | cvxCompAddCoincidentCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddTangentCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddConcentricCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddParallelCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddPerpendicularCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddAngularCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddLockCons (svxEntPath *Comp1, svxEntPath *Comp2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddDistanceCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddMiddleCons (svxEntPath *BaseEnt1, svxEntPath *BaseEnt2, int nCenter, svxEntPath *CenterEnts, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddSymmetryCons (svxEntPath *Plane, svxEntPath *SymEnt1, svxEntPath *SymEnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddFrameCons (svxEntPath *Datum1, svxEntPath *Datum2, svxConsData *ConsData, int *idCons)

Mechanical Constraint

evxErrors | cvxCompAddGearCons (const svxEntPath *Gear1, const svxEntPath *Gear2, const svxGearConsData *ConsData, int *idCons)
evxErrors | cvxCompAddPathCons (const svxPntOnEntPath *Pnt, int nPaths, const svxEntPath *Paths, const svxPathConsData *ConsData, int *idCons)
evxErrors | cvxCompAddLinearCoupleCons (const svxEntPath *Comp1, const svxEntPath *Dir1, const svxEntPath *Comp2, const svxEntPath *Dir2, const svxLinearCpData *ConsData, int *idCons)
evxErrors | cvxCompAddRackPinionCons (const svxEntPath *Rack, const svxEntPath *Pinion, const svxRackPinionData *ConsData, int *idCons)
evxErrors | cvxCompAddScrewCons (const svxEntPath *ScrewEnt, const svxEntPath *LinearEnt, const svxScrewConsData *ConsData, int *idCons)
evxErrors | cvxCompAddSlotCons (const svxEntPath *Ent, int nSlots, const svxEntPath *Slots, const svxSlotConsData *ConsData, int *idCons)
evxErrors | cvxCompAddCamCons (const svxEntPath *Ent, int nCamFaces, const svxEntPath *CamFaces, int *idCons)
evxErrors | cvxCompAddUniJointCons (const svxEntPath *Shaft1, const svxPntOnEntPath *HingePnt1, const svxEntPath *Shaft2, const svxPntOnEntPath *HingePnt2, const svxUniJointData *ConsData, int *idCons)

Other Constraint

evxErrors | cvxPartAlign (svxAlign *Align)
evxErrors | cvxPartAnchor (int idEntity)

Basic Editing

evxErrors | cvxCompPtnInit (evxAsmPatternType type, svxAsmPtnData *data)
evxErrors | cvxCompPtn (const svxAsmPtnData *data, int *idPattern)
evxErrors | cvxCompMoveInit (evxAsmMoveType type, svxAsmMove *data)
evxErrors | cvxCompMove (const svxAsmMove *data)
evxErrors | cvxCompMirrorInit (evxAsmMirrorType type, svxAsmMirror *data)
evxErrors | cvxCompMirror (const svxAsmMirror *data, int *idMirror)
evxErrors | cvxAsmCutInit (svxAsmCut *data)
evxErrors | cvxAsmCut (const svxAsmCut *data, int *idCut)
evxErrors | cvxAsmFilletInit (evxChamFlltType type, svxAsmFllt *data)
evxErrors | cvxAsmFillet (const svxAsmFllt *data, int *idFllt)
evxErrors | cvxAsmChamferInit (evxAsmChmfType type, svxAsmChmf *data)
evxErrors | cvxAsmChamfer (const svxAsmChmf *data, int *idChmf)

Inquire

evxErrors | cvxCompIsectShpChk (svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int *fInterfer)
evxErrors | cvxCompIsectShpChk2 (svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int fClosedChk, int *fInterfer)
evxErrors | cvxCompIferCheck (svxEntPath *BaseComp, svxEntPath *ChkComp, int SubAsmAsWhole, int IgnoreHidden, int *IferCnt, svxIferChkResData **IferResults)
evxErrors | cvxCompClearCheck (int Count, svxEntPath *Comps, double Clear, int ChkCompShp, int IgnoreHidden, int ChkSubAsm, int *ClrCnt, svxClrChkData **ClrDatas)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmChamfer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmChamfer()

evxErrors cvxAsmChamfer | ( | const svxAsmChmf * | data,
 |  | int * | idChmf
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use this function to build assembly chamfer. Two different methods of chamfer are available, each method requires different types of input.

Note
Interface cvxAsmChamferInit() can initialize variables assembly chamfer of this function.
Parameters
[in] | data | assembly chamfer input data
[out] | idChmf | id of chamfer feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmChamferInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmChamferInit()

evxErrors cvxAsmChamferInit | ( | evxAsmChmfType | type,
 |  | svxAsmChmf * | data
 | ) |  |

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmChmf structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | assembly chamfer type
[out] | data | assembly chamfer data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmCut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmCut()

evxErrors cvxAsmCut | ( | const svxAsmCut * | data,
 |  | int * | idCut
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use this function to build assembly cut.

Note
Interface cvxAsmCutInit() can initialize variables assembly cut of this function.
Parameters
[in] | data | assembly mirror input data
[out] | idCut | id of cut feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmCutInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmCutInit()

evxErrors cvxAsmCutInit ( svxAsmCut * data )

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmCut structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data assembly cut data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmFillet()

evxErrors cvxAsmFillet | ( | const svxAsmFllt * | data,
 |  | int * | idFllt
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use this function to build assembly fillet. Three different methods of fillet are available, each method requires different types of input.

Note
Interface cvxAsmFilletInit() can initialize variables assembly fillet of this function.
Parameters
[in] | data | assembly fillet input data
[out] | idFllt | id of fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxAsmFilletInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxAsmFilletInit()

evxErrors cvxAsmFilletInit | ( | evxChamFlltType | type,
 |  | svxAsmFllt * | data
 | ) |  |

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmFllt structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | assembly fillet type
[out] | data | assembly fillet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddAngularCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddAngularCons()

evxErrors cvxCompAddAngularCons | ( | svxEntPath * | Ent1,
 |  | svxEntPath * | Ent2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a angular constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddCamCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddCamCons()

evxErrors cvxCompAddCamCons | ( | const svxEntPath * | Ent,
 |  | int | nCamFaces,
 |  | const svxEntPath * | CamFaces,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a Cam constraint.

Parameters
[in] | Ent | pick-path of the first entity (edge, curve, face, datum plane, point, datum axis)
[in] | nCamFaces | number of cam faces
[in] | CamFaces | pick-path list of cam faces
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddCoincidentCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddCoincidentCons()

evxErrors cvxCompAddCoincidentCons | ( | svxEntPath * | Ent1,
 |  | svxPoint * | Pnt1,
 |  | svxEntPath * | Ent2,
 |  | svxPoint * | Pnt2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a coincident constraint, the components will remain coincident.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt1 | coordinate of the coincidence point on the first entity (NULL to ignore)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt2 | coordinate of the coincidence point on the second entity (NULL to ignore)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddConcentricCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddConcentricCons()

evxErrors cvxCompAddConcentricCons | ( | svxEntPath * | Ent1,
 |  | svxPoint * | Pnt1,
 |  | svxEntPath * | Ent2,
 |  | svxPoint * | Pnt2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a concentric constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt1 | coordinate of the coincidence point on the first entity (NULL to ignore)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt2 | coordinate of the coincidence point on the second entity (NULL to ignore)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddDistanceCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddDistanceCons()

evxErrors cvxCompAddDistanceCons | ( | svxEntPath * | Ent1,
 |  | svxPoint * | Pnt1,
 |  | svxEntPath * | Ent2,
 |  | svxPoint * | Pnt2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a distance constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt1 | coordinate of the coincidence point on the first entity (NULL to ignore)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | Pnt2 | coordinate of the coincidence point on the second entity (NULL to ignore)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddFrameCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddFrameCons()

evxErrors cvxCompAddFrameCons | ( | svxEntPath * | Datum1,
 |  | svxEntPath * | Datum2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a frame constraint.

Parameters
[in] | Datum1 | pick-path of first datum (datum plane, datum CSYS)
[in] | Datum2 | pick-path of second datum (datum plane, datum CSYS)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddGearCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddGearCons()

evxErrors cvxCompAddGearCons | ( | const svxEntPath * | Gear1,
 |  | const svxEntPath * | Gear2,
 |  | const svxGearConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a gear constraint.

Parameters
[in] | Gear1 | pick-path of first entity (edge, curve, face, datum plane, point, datum axis)
[in] | Gear2 | pick-path of second entity (edge, curve, face, datum plane, point, datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddLinearCoupleCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddLinearCoupleCons()

evxErrors cvxCompAddLinearCoupleCons | ( | const svxEntPath * | Comp1,
 |  | const svxEntPath * | Dir1,
 |  | const svxEntPath * | Comp2,
 |  | const svxEntPath * | Dir2,
 |  | const svxLinearCpData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a linear couple constraint.

Parameters
[in] | Comp1 | pick-path of the first component
[in] | Dir1 | pick-path of the entity to specify the first component move direction (edge, curve, face, datum, point)
[in] | Comp2 | pick-path of the second component
[in] | Dir2 | pick-path of the entity to specify the second component move direction (edge, curve, face, datum, point)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddLockCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddLockCons()

evxErrors cvxCompAddLockCons | ( | svxEntPath * | Comp1,
 |  | svxEntPath * | Comp2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a lock constraint.

Parameters
[in] | Comp1 | pick-path of first component
[in] | Comp2 | pick-path of second component
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddMiddleCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddMiddleCons()

evxErrors cvxCompAddMiddleCons | ( | svxEntPath * | BaseEnt1,
 |  | svxEntPath * | BaseEnt2,
 |  | int | nCenter,
 |  | svxEntPath * | CenterEnts,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a middle constraint.

Parameters
[in] | BaseEnt1 | pick-path of first base entity (face,datum)
[in] | BaseEnt2 | pick-path of second base entity (face,datum)
[in] | nCenter | number of center entities (1 or 2)
[in] | CenterEnts | list of center entities (edge,curve,face,datum)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddParallelCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddParallelCons()

evxErrors cvxCompAddParallelCons | ( | svxEntPath * | Ent1,
 |  | svxEntPath * | Ent2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a parallel constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddPathCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddPathCons()

evxErrors cvxCompAddPathCons | ( | const svxPntOnEntPath * | Pnt,
 |  | int | nPaths,
 |  | const svxEntPath * | Paths,
 |  | const svxPathConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a path constraint. If multiple curves or edges are input as constraint paths, all curves or edges are required to come from the same component and G1 continuous between curves or edges.

Parameters
[in] | Pnt | point on component (edge, curve, face, datum plane, point)
[in] | nPaths | number of paths
[in] | Paths | pick-path list of paths to align to, the curves must be G1 continuous (edge, curve)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddPerpendicularCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddPerpendicularCons()

evxErrors cvxCompAddPerpendicularCons | ( | svxEntPath * | Ent1,
 |  | svxEntPath * | Ent2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a perpendicular constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddRackPinionCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddRackPinionCons()

evxErrors cvxCompAddRackPinionCons | ( | const svxEntPath * | Rack,
 |  | const svxEntPath * | Pinion,
 |  | const svxRackPinionData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a rack and pinion constraint.

Parameters
[in] | Rack | pick-path of first entity (edge, curve, face, datum plane, point, datum axis)
[in] | Pinion | pick-path of second entity (edge, curve, face, datum plane, point, datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddScrewCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddScrewCons()

evxErrors cvxCompAddScrewCons | ( | const svxEntPath * | ScrewEnt,
 |  | const svxEntPath * | LinearEnt,
 |  | const svxScrewConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a screw constraint.

Parameters
[in] | ScrewEnt | pick-path of screw entity (edge, curve, face, datum plane, point, datum axis)
[in] | LinearEnt | pick-path of linear entity (edge, curve, face, datum plane, point, datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddSlotCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddSlotCons()

evxErrors cvxCompAddSlotCons | ( | const svxEntPath * | Ent,
 |  | int | nSlots,
 |  | const svxEntPath * | Slots,
 |  | const svxSlotConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a slot constraint.

Parameters
[in] | Ent | pick-path of the first entity (edge, curve, face, datum plane, point, datum axis)
[in] | nSlots | number of slot faces
[in] | Slots | pick-path list of slot faces
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddSymmetryCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddSymmetryCons()

evxErrors cvxCompAddSymmetryCons | ( | svxEntPath * | Plane,
 |  | svxEntPath * | SymEnt1,
 |  | svxEntPath * | SymEnt2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a symmetry constraint.

Parameters
[in] | Plane | pick-path of plane (face,datum)
[in] | SymEnt1 | pick-path of first symmetric entity(edge,curve,face,datum,point,datum axis)
[in] | SymEnt2 | pick-path of second symmetric entity(edge,curve,face,datum,point,datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddTangentCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddTangentCons()

evxErrors cvxCompAddTangentCons | ( | svxEntPath * | Ent1,
 |  | svxEntPath * | Ent2,
 |  | svxConsData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a tangent constraint.

Parameters
[in] | Ent1 | pick-path of first entity (edge,curve,face,datum,point,datum axis)
[in] | Ent2 | pick-path of second entity (edge,curve,face,datum,point,datum axis)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompAddUniJointCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompAddUniJointCons()

evxErrors cvxCompAddUniJointCons | ( | const svxEntPath * | Shaft1,
 |  | const svxPntOnEntPath * | HingePnt1,
 |  | const svxEntPath * | Shaft2,
 |  | const svxPntOnEntPath * | HingePnt2,
 |  | const svxUniJointData * | ConsData,
 |  | int * | idCons
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use the function to create a universal joint constraint.

Parameters
[in] | Shaft1 | pick-path of first cross or propeller entity (edge, curve, face, datum axis)
[in] | HingePnt1 | the first hinge point on entity (edge, curve, face, datum, point) (NULL to ignore)
[in] | Shaft2 | pick-path of second cross or propeller entity (edge, curve, face, datum axis)
[in] | HingePnt2 | the second hinge point on entity (edge, curve, face, datum, point) (NULL to ignore)
[in] | ConsData | constraint custom data (NULL to use default value)
[out] | idCons | index of new constraint (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\asmConsTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompClearCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompClearCheck()

evxErrors cvxCompClearCheck | ( | int | Count,
 |  | svxEntPath * | Comps,
 |  | double | Clear,
 |  | int | ChkCompShp,
 |  | int | IgnoreHidden,
 |  | int | ChkSubAsm,
 |  | int * | ClrCnt,
 |  | svxClrChkData ** | ClrDatas
 | ) |  |

#include <zwapi_cmd_assembly.h>

Calculate the clearance between the input components and output the clearance result. all components in current assembly are checked when the input component paths are NULL.

The memory referenced by "ClrDatas" is allocated by this function. The calling procedure is responsible to free it (cvxMemFree((void**)ClrDatas)).

Parameters
[in] | Count | number of components or shapes (0 to check the whole assembly)
[in] | Comps | list of components or shapes (NULL to check the whole assembly)
[in] | Clear | clearance threshold, only results with clearance value less than the threshold are output
[in] | ChkCompShp | whether to check clearance between component and top shape (0 = no, 1 = yes)
[in] | IgnoreHidden | whether to ignore hidden components (0 = no, 1 = yes)
[in] | ChkSubAsm | whether to check sub-assembly internal parts clearance (0 = no, 1 = yes)
[out] | ClrCnt | number of clearance check results
[out] | ClrDatas | list of clearance check results
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompExtract

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompExtract()

evxErrors cvxCompExtract | ( | int | idShape,
 |  | svxMatrix * | Frame,
 |  | vxLongName | Name,
 |  | int | NewFile,
 |  | evxResponse | Overwrite,
 |  | int * | idComp
 | ) |  |

#include <zwapi_cmd_assembly.h>

Extracts a shape from the active part into a new part that is instanced back into the active part as a component (i.e. converts a shape into a component). If the shape was merged from a pre-existing component, "Frame" and "Name" are ignored and the shape is extracted to the original component using its local frame and name.

If "Frame" is input as NULL, the identity matrix is used.

If "Name" is input as NULL, a default name is assigned to the component.

If "idComp" is not NULL, the id of the new component is output.

Parameters
[in] | idShape | id of shape to extract
[in] | Frame | local coordinate frame to map shape into part space
[in] | Name | name of new part/component
[in] | NewFile | 1 to put new part in a new file; 0 for active file
[in] | Overwrite | response to "overwrite existing part?" query
[out] | idComp | id of new component (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CCMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIferCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompIferCheck()

evxErrors cvxCompIferCheck | ( | svxEntPath * | BaseComp,
 |  | svxEntPath * | ChkComp,
 |  | int | SubAsmAsWhole,
 |  | int | IgnoreHidden,
 |  | int * | IferCnt,
 |  | svxIferChkResData ** | IferResults
 | ) |  |

#include <zwapi_cmd_assembly.h>

Check if there is interference between the input components and output the interference result. all components in current assembly are checked when both of the input component paths are NULL.

The memory referenced by "IferResults" is allocated by this function. The calling procedure is responsible to free it (cvxMemFree((void**)IferResults)).

Parameters
[in] | BaseComp | pick path of the first Component, can be NULL
[in] | ChkComp | pick path of the second Component, can be NULL
[in] | SubAsmAsWhole | 1:sub-assembly as a whole, don't check interference inside sub-assembly 0:check interference inside sub-assembly
[in] | IgnoreHidden | whether to ignore the hidden components within the sub-assembly
[out] | IferCnt | number of interference
[out] | IferResults | pointer to list of interference result data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompInclude

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompInclude()

evxErrors cvxCompInclude | ( | const svxCompIncludeData * | Comp,
 |  | int * | idComp
 | ) |  |

#include <zwapi_cmd_assembly.h>

Include an unplaced component in the active part. If "idComp" is not NULL, the id of the new component is output.

Parameters
[in] | Comp | component data
[out] | idComp | id of new component (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_FILE_LOCATE_FAIL
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompIns()

int cvxCompIns | ( | svxCompData * | Comp,
 |  | int * | idComp
 | ) |  |

#include <zwapi_cmd_assembly.h>

Inserts a new component in the active part. If "idComp" is not NULL, the id of the new component is output.

If this function is called from a custom history operation, the component will be associated with the custom operation and will be deleted automatically when the custom operation is regenerated and re-inserts the component.

Note
When this function is called from within a custom history operation, if "idComp" is not NULL, "*idComp" must be a value greater than 0, and if this function is Cyclically called from within a custom history operation, "*idComp" CAN'T BE THE SAME in every calling, otherwise this function will return "ZW_API_INPUT_ERROR". value will be encoded in the component's persistent label to differentiate it from other components added by the custom operation. After the value of "idComp" is used to label the new component, the database id of the new component will be output via "idComp".
Parameters
[in] | Comp | component data
[in,out] | id | of new component,as input when this function is called from custom history operation
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
other
  • 2 - get new component fails
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsectShpChk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompIsectShpChk()

evxErrors cvxCompIsectShpChk | ( | svxEntPath * | BaseShpPath,
 |  | svxEntPath * | OpShpPath,
 |  | int * | fInterfer
 | ) |  |

#include <zwapi_cmd_assembly.h>

Determine exist or not exist intersection between the input two shapes which come from two components.

Parameters
[in] | BaseShpPath | the first shape in a component
[in] | OpShpPath | the second shape in other component
[out] | fInterfer | if found interference, output V_TRUE, otherwise output V_FALSE
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompIsectShpChk2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompIsectShpChk2()

evxErrors cvxCompIsectShpChk2 | ( | svxEntPath * | BaseShpPath,
 |  | svxEntPath * | OpShpPath,
 |  | int | fClosedChk,
 |  | int * | fInterfer
 | ) |  |

#include <zwapi_cmd_assembly.h>

Determine exist or not exist intersection between the input two shapes which come from two components.

Parameters
[in] | BaseShpPath | the first shape in a component
[in] | OpShpPath | the second shape in other component
[in] | fClosedChk | option to control whether check the open shell 1 is excluding the open shell. otherwise is 0
[out] | fInterfer | if found interference, output V_TRUE, otherwise output V_FALSE
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMerge()

evxErrors cvxCompMerge | ( | evxBoolType | Combine,
 |  | int | idComp,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_assembly.h>

Merges a component with the active part using the specified combination method. Only the component's top-level geometry is merged. Sub-components of the component are not merged.

Use cvxCompShift() to merge the component and its sub-components.

If "idShape" is not NULL, the id of the last shape created by merging the component is output. "isShape=0" is output if no shape was created by the merge.

Note
Merging a component could add multiple shapes, or other types of geometry, to the active part. If there is a possibility that the merge created more than a single shape, use cvxEntNewList() to retrieve the new entities created by the merge.
This function can be overloaded to force merging of component dimensions by inputting the component id with a negative sign.
Parameters
[in] | Combine | combination method
[in] | idComp | component id (0 for last feature)
[out] | idShape | shape id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMerge2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMerge2()

evxErrors cvxCompMerge2 | ( | evxBoolType | Combine,
 |  | int | idComp,
 |  | int | MergeDim,
 |  | int | MergeWire,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_assembly.h>

Merges a component with the active part using the specified combination method. Only the component's top-level geometry is merged. Sub-components of the component are not merged.

Use cvxCompShift() to merge the component and its sub-components.

If "idShape" is not NULL, the id of the last shape created by merging the component is output. "isShape=0" is output if no shape was created by the merge.

Note
Merging a component could add multiple shapes, or other types of geometry, to the active part. If there is a possibility that the merge created more than a single shape, use cvxEntNewList() to retrieve the new entities created by the merge.
Parameters
[in] | Combine | combination method
[in] | idComp | component id (0 for last feature)
[in] | MergeDim | 1 to merge component part dimensions into active part, else 0
[in] | MergeWire | 1 to merge component part wireframe geometry into active part, else 0
[out] | idShape | shape id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMirror

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMirror()

evxErrors cvxCompMirror | ( | const svxAsmMirror * | data,
 |  | int * | idMirror
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use this function to build assembly mirror. Two different methods of mirror are available, each method requires different types of input.

Note
Interface cvxCompMirrorInit() can initialize variables assembly mirror of this function.
Parameters
[in] | data | assembly mirror input data
[out] | idMirror | id of mirror feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMirrorInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMirrorInit()

evxErrors cvxCompMirrorInit | ( | evxAsmMirrorType | type,
 |  | svxAsmMirror * | data
 | ) |  |

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmMirror structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | assembly mirror type
[out] | data | assembly mirror data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMove()

evxErrors cvxCompMove ( const svxAsmMove * data )

#include <zwapi_cmd_assembly.h>

Use this function to build assembly move. Six different methods of pattern are available, each method requires different types of input.

Note
Interface cvxAsmMoveInit() can initialize variables assembly move of this function.
Parameters
[in] data assembly move input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompMoveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompMoveInit()

evxErrors cvxCompMoveInit | ( | evxAsmMoveType | type,
 |  | svxAsmMove * | data
 | ) |  |

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmMoveData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | assembly move type
[out] | data | assembly move data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompPtn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompPtn()

evxErrors cvxCompPtn | ( | const svxAsmPtnData * | data,
 |  | int * | idPattern
 | ) |  |

#include <zwapi_cmd_assembly.h>

Use this function to bulid assembly pattern.Six different methods of pattern are available, each method requires different types of input.

Note
Interface cvxAsmPtnInit() can initialize variables assembly pattern of this function.
Parameters
[in] | data | assembly pattern input data
[out] | idPattern | id of pattern feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxCompPtnInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxCompPtnInit()

evxErrors cvxCompPtnInit | ( | evxAsmPatternType | type,
 |  | svxAsmPtnData * | data
 | ) |  |

#include <zwapi_cmd_assembly.h>

Initialize the svxAsmPtnData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | assembly pattern type
[out] | data | assembly pattern data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxPartAlign()

evxErrors cvxPartAlign ( svxAlign * Align )

#include <zwapi_cmd_assembly.h>

Creates an alignment constraint between two shapes or components.

Parameters
[in] Align alignment constraint
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAnchor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxPartAnchor()

evxErrors cvxPartAnchor ( int idEntity )

#include <zwapi_cmd_assembly.h>

Anchors the specified component or shape so that it does not move when alignment constraints are created between it and another component/shape.

Parameters
[in] idEntity component or shape id in active part
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartGeomExport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxPartGeomExport()

evxErrors cvxPartGeomExport ( svxGeomExport * Data )

#include <zwapi_cmd_assembly.h>

Exports the specified geometry from the active target part to an external part. If the destination part does not exist, it is created. If the destination part already exists, the geometry is added to it.

Parameters
[in] Data data that defines geometry to be exported
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CCMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartGeomExportII

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxPartGeomExportII()

evxErrors cvxPartGeomExportII ( svxGeomExport * Data )

#include <zwapi_cmd_assembly.h>

Exports the specified geometry from the active target part to an external part. If the destination part does not exist, it is created. If the destination part already exists, the geometry is added to it.

Parameters
[in] Data data that defines geometry to be exported
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CCMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ cvxPartIns()

evxErrors cvxPartIns | ( | svxPartInstData * | Part,
 |  | int * | Count,
 |  | int ** | ShapeList
 | ) |  |

#include <zwapi_cmd_assembly.h>

Copy and insert the specified part at the specified location. Outputs a list of indices of the new shapes. The calling procedure MUST deallocate the output list with cvxMemFree().

Interface cvxMemZero() can initialize variables of this function.

Parameters
[in] | Part | component data
[out] | Count | number of shapes (NULL to ignore)
[out] | ShapeList | list of shape id's (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CCMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Assembly Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Assembly Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Assembly Command functions.

Component Insert Data

enum | evxResponse { VX_CANCEL = -1 , VX_NO = 0 , VX_YES = 1 , VX_YES_ALL = 2 }
response to user prompt More...
typedef struct svxCompData | svxCompData
component data
typedef struct svxCompIncludeData | svxCompIncludeData
include component data
typedef struct svxGeomExport | svxGeomExport
geometry export
typedef struct svxPartInstData | svxPartInstData
copy external part data
typedef enum evxResponse | evxResponse
response to user prompt

Assembly Constraint Data

enum evxAlignType {
VX_ALIGN_COINCIDENT = 0 , VX_ALIGN_TANGENT = 1 , VX_ALIGN_CONCENTRIC = 2 , VX_ALIGN_PARALLEL = 3 ,
VX_ALIGN_PERPENDICULAR = 4 , VX_ALIGN_ANGLE = 5
}
part component/shape alignment More...
enum | evxAlignInterference { VX_INTERFERENCE_NONE = 0 , VX_INTERFERENCE_HIGHLIGHT = 1 , VX_INTERFERENCE_STOP_AT = 2 , VX_INTERFERENCE_ADD_ALIGN = 3 }
interference type More...
enum evxConsType {
VX_NONE = 0x00000L , VX_CONCENTRIC = 0x00001L , VX_COINCIDENT = 0x00002L , VX_TANGENT = 0x00004L ,
VX_PARALLEL = 0x00008L , VX_PERPENDICULAR = 0x00010L , VX_AT_DISTANCE = 0x00040L , VX_AT_ANGLE_FULL = 0x00080L ,
VX_GEAR = 0x00100L , VX_SYMMETRIC = 0x00200L , VX_ADV_LOCKED = 0x00400L , VX_ADV_MIDDLE = 0x00800L ,
VX_ADV_FRAME = 0x01000L , VX_ADV_PATH = 0x02000L , VX_MC_LINEAR_COUPLER = 0x04000L , VX_MC_RACK_PINION = 0x08000L ,
VX_MC_SCREW = 0x10000L , VX_MC_SLOT = 0x2000000L , VX_MC_CAM = 0x4000000L , VX_MC_UNIV_JOINT = 0x00104L
}
assembly constraint type More...
enum | evxPathConsType { VX_PATH_CONS_FREE = 0 , VX_PATH_CONS_DISTANCE = 1 , VX_PATH_CONS_PERCENT = 2 }
path constraint type More...
enum | evxPitchYawType { VX_PITCH_YAW_FREE = 0 , VX_PITCH_YAW_FOLLOW_PATH = 1 }
pitch/yaw type More...
enum | evxRollCtrlType { VX_ROLL_CTRL_FREE = 0 , VX_ROLL_CTRL_UP_VEC = 1 }
roll control type More...
enum | evxSlotConsType { VX_SLOT_CONS_FREE = 0 , VX_SLOT_CONS_CENTER = 1 , VX_SLOT_CONS_DISTANCE = 2 , VX_SLOT_CONS_PERCENT = 3 }
slot constraint type More...
enum evxConsState {
VX_UNKNOWN , VX_UN_CONSTRAINED , VX_UNDER_CONSTRAINED , VX_WELL_CONSTRAINED ,
VX_FIXED , VX_OVER_CONSTRAINED
}
constraint state of component More...
typedef enum evxAlignType | evxAlignType
part component/shape alignment
typedef enum evxAlignInterference | evxAlignInterference
interference type
typedef struct svxAlign | svxAlign
Alignment constraint.
typedef enum evxConsType | evxConsType
assembly constraint type
typedef struct svxConsData | svxConsData
custom data for assembly common constraint
typedef struct svxGearConsData | svxGearConsData
custom data for assembly gear constraint
typedef enum evxPathConsType | evxPathConsType
path constraint type
typedef enum evxPitchYawType | evxPitchYawType
pitch/yaw type
typedef enum evxRollCtrlType | evxRollCtrlType
roll control type
typedef struct svxPathConsData | svxPathConsData
custom data for assembly path constraint
typedef struct svxLinearCpData | svxLinearCpData
custom data for assembly linear couple constraint
typedef struct svxRackPinionData | svxRackPinionData
custom data for assembly rack and pinion constraint
typedef struct svxScrewConsData | svxScrewConsData
custom data for assembly screw constraint
typedef enum evxSlotConsType | evxSlotConsType
slot constraint type
typedef struct svxSlotConsData | svxSlotConsData
custom data for assembly slot constraint
typedef struct svxUniJointData | svxUniJointData
custom data for assembly universal joint constraint
typedef enum evxConsState | evxConsState
constraint state of component

Basic Editing Data

enum evxAsmPatternType {
VX_ASM_PTN_LINEAR , VX_ASM_PTN_CIRCULAR , VX_ASM_PTN_POINT , VX_ASM_PTN_PATTERN ,
VX_ASM_PTN_CRV , VX_ASM_PTN_FACE
}
assembly pattern method More...
enum | evxAsmPtnStagger { VX_ASM_PTN_NO_STAGGER , VX_ASM_PTN_STAGGER }
assembly pattern stagger method More...
enum | evxAsmPtnDrv { VX_ASM_PTN_DRV_NONE , VX_ASM_PTN_DRV_SPACING , VX_ASM_PTN_DRV_NUM }
assembly pattern derive method More...
enum | evxAsmPtnAlg { VX_ASM_PTN_ALG_BASE , VX_ASM_PTN_ALG_PTN }
assembly pattern alignment method More...
enum | evxAsmPtnCrv { VX_ASM_PTN_CRV1 , VX_ASM_PTN_CRV2_TOG , VX_ASM_PTN_CRV2_ACROSS , VX_ASM_PTN_CRV3 }
assembly pattern curves method More...
enum | evxAsmPtnBnd { VX_ASM_PTN_BND_AUTO , VX_ASM_PTN_BND_PALCE , VX_ASM_PTN_BND_MOVE }
assembly pattern boundary method More...
enum evxAsmMoveType {
VX_ASM_MOVE_PNT = 1 , VX_ASM_MOVE_ALONG_DIR , VX_ASM_MOVE_ALIGN , VX_ASM_MOVE_SWEEP ,
VX_ASM_MOVE_AROUND_DIR , VX_ASM_MOVE_DYNAMIC
}
assembly move method More...
enum | evxAsmMoveFrame { VX_ASM_MOVE_FRAME_NTR , VX_ASM_MOVE_FRAME_PATH , VX_ASM_MOVE_FRAME_SLC }
assembly move frame method More...
enum | evxAsmMoveZSpine { VX_ASM_MOVE_Z_NTR , VX_ASM_MOVE_Z_SPINE , VX_ASM_MOVE_Z_PARALLEL }
assembly move z-spine method More...
enum | evxAsmMoveXOrnt { VX_ASM_MOVE_X_NTR , VX_ASM_MOVE_X_GUIDE , VX_ASM_MOVE_X_AXIS }
assembly move x-orient method More...
enum | evxAsmMirrorType { VX_ASM_MIRROR_COPY , VX_ASM_MIRROR_DUP }
assembly mirror method More...
enum evxAsmMirrorSymm {
VX_ASM_MIRROR_SYMM_XZ , VX_ASM_MIRROR_SYMM_YZ , VX_ASM_MIRROR_SYMM_XY , VX_ASM_MIRROR_SYMM_C ,
VX_ASM_MIRROR_SYMM_XCZC , VX_ASM_MIRROR_SYMM_YCZC , VX_ASM_MIRROR_SYMM_XCYC , VX_ASM_MIRROR_SYMM_NONE
}
assembly mirror self-symmetric method More...
enum | evxAsmMirrorCenter { VX_ASM_MIRROR_CTR_BOX , VX_ASM_MIRROR_CTR_MASS , VX_ASM_MIRROR_CTR_FRAME }
assembly mirror center method More...
enum | evxAsmMirrorCategory { VX_ASM_MIRROR_CAT_COPY , VX_ASM_MIRROR_CAT_DUP , VX_ASM_MIRROR_CAT_DEL }
assembly mirror category method More...
enum | evxAsmFlltArc { VX_ASM_FLLT_ARC_CIR , VX_ASM_FLLT_ARC_CONIC }
assembly fillet arc method More...
enum | evxAsmFlltBase { VX_ASM_FLLT_BASE_NO , VX_ASM_FLLT_BASE_DIV , VX_ASM_FLLT_BASE_TRIM , VX_ASM_FLLT_BASE_SEW }
assembly fillet base faces method More...
enum | evxAsmFlltFace { VX_ASM_FLLT_FACE_MAX , VX_ASM_FLLT_FACE_MIN , VX_ASM_FLLT_FACE_MATCH }
assembly fillet fillet face method More...
enum evxAsmFlltLoop {
VX_ASM_FLLT_LOOP_IN , VX_ASM_FLLT_LOOP_OUT , VX_ASM_FLLT_LOOP_SHARE , VX_ASM_FLLT_LOOP_BOUND ,
VX_ASM_FLLT_LOOP_ALL , VX_ASM_FLLT_LOOP_SELECT
}
assembly fillet loop method More...
enum | evxAsmChmfType { VX_ASM_CHMF_EDGE , VX_ASM_CHMF_VERTEX = 2 }
assembly chamfer method More...
enum | evxAsmChmfBase { VX_ASM_CHMF_BASE_NO , VX_ASM_CHMF_BASE_DIV , VX_ASM_CHMF_BASE_TRIM , VX_ASM_CHMF_BASE_SEW }
assembly chamfer base faces method More...
enum | evxAsmChmfFace { VX_ASM_CHMF_FACE_MAX , VX_ASM_CHMF_FACE_MIN , VX_ASM_CHMF_FACE_MATCH }
assembly chamfer fillet face method More...
typedef enum evxAsmPatternType | evxAsmPatternType
assembly pattern method
typedef enum evxAsmPtnStagger | evxAsmPtnStagger
assembly pattern stagger method
typedef enum evxAsmPtnDrv | evxAsmPtnDrv
assembly pattern derive method
typedef enum evxAsmPtnAlg | evxAsmPtnAlg
assembly pattern alignment method
typedef enum evxAsmPtnCrv | evxAsmPtnCrv
assembly pattern curves method
typedef enum evxAsmPtnBnd | evxAsmPtnBnd
assembly pattern boundary method
typedef enum evxAsmMoveType | evxAsmMoveType
assembly move method
typedef enum evxAsmMoveFrame | evxAsmMoveFrame
assembly move frame method
typedef enum evxAsmMoveZSpine | evxAsmMoveZSpine
assembly move z-spine method
typedef enum evxAsmMoveXOrnt | evxAsmMoveXOrnt
assembly move x-orient method
typedef enum evxAsmMirrorType | evxAsmMirrorType
assembly mirror method
typedef enum evxAsmMirrorSymm | evxAsmMirrorSymm
assembly mirror self-symmetric method More...
typedef enum evxAsmMirrorCenter | evxAsmMirrorCenter
assembly mirror center method
typedef enum evxAsmMirrorCategory | evxAsmMirrorCategory
assembly mirror category method
typedef enum evxAsmFlltArc | evxAsmFlltArc
assembly fillet arc method
typedef enum evxAsmFlltBase | evxAsmFlltBase
assembly fillet base faces method
typedef enum evxAsmFlltFace | evxAsmFlltFace
assembly fillet fillet face method
typedef enum evxAsmFlltLoop | evxAsmFlltLoop
assembly fillet loop method
typedef enum evxAsmChmfType | evxAsmChmfType
assembly chamfer method
typedef enum evxAsmChmfBase | evxAsmChmfBase
assembly chamfer base faces method
typedef enum evxAsmChmfFace | evxAsmChmfFace
assembly chamfer fillet face method
typedef struct svxAsmPtnData | svxAsmPtnData
assembly pattern data
typedef struct svxAsmMove | svxAsmMove
assembly move data
typedef struct svxAsmMirror | svxAsmMirror
assembly mirror data
typedef struct svxAsmCut | svxAsmCut
assembly cut data
typedef struct svxAsmFllt | svxAsmFllt
assembly fillet data
typedef struct svxAsmChmf | svxAsmChmf
assembly chamfer data

Inquire

typedef struct svxIferChkResData | svxIferChkResData
Interference check result data.
typedef struct svxClrChkData | svxClrChkData
clearance check result data
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMirrorSymm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMirrorSymm

typedef enum evxAsmMirrorSymm evxAsmMirrorSymm

#include <zwapi_cmd_assembly_data.h>

assembly mirror self-symmetric method

assembly mirror center method

Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Data Exchange Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Exchange Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Exchange Command API

Import

evxErrors | cvxPartRefGeom (svxEntPath *GeomPath, int AssociativeCopy, int *idGeom)
evxErrors | cvxPartPublishSet (const vxName Name, int Count, const int *idEnts, int *idPubSet)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPublishSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Data Exchange Commands
cvxPartPublishSet
cvxPartRefGeom

◆ cvxPartPublishSet()

evxErrors cvxPartPublishSet | ( | const vxName | Name,
 |  | int | Count,
 |  | const int * | idEnts,
 |  | int * | idPubSet
 | ) |  |

#include <zwapi_cmd_dataexchange.h>

Use the function to create a publication set to publish the specified entity.

See also
cvxPartInqPublishSets(): get a list of indices of the publication set.
cvxPartInqPublishSet(): query data of the specified publication set.
cvxPartPublishSetDel(): delete the specified publication sets.
Parameters
[in] | Name | name of publication set (NULL to use default name)
[in] | Count | number of entities to publish
[in] | idEnts | list of entity ids to publish (shape, face, edge, curve, point, sketch, datum plane, datum axis, datum CSYS)
[out] | idPubSet | id of new publication set (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRefGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Data Exchange Commands
cvxPartPublishSet
cvxPartRefGeom

◆ cvxPartRefGeom()

evxErrors cvxPartRefGeom | ( | svxEntPath * | GeomPath,
 |  | int | AssociativeCopy,
 |  | int * | idGeom
 | ) |  |

#include <zwapi_cmd_dataexchange.h>

Creates a copy of the specified external geometry (face, shape, curve or edge) in the active target part. The input pick-path must give the full traversal path to the external geometry relative to the top-level part of the parent assembly of the active target part. The id of the new geometry created in the active part is output via "idGeom".

Parameters
[in] | GeomPath | pick-path of external geometry relative to top-level parent file
[in] AssociativeCopy 0 for static copy;
1 for associative copy;
2 for time-stamped associative copy;
3 for time-stamped associative copy - assembly position independent.
[out] | idGeom | id of new geometry (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_ENT_PATH_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Data Exchange Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Exchange Commands Data
Commands Creation » Part and Assembly Commands

THE MODULE FOR THE ZW3D Data Types and Structures of the Data Exchange Command functions.

Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Datum Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Datum Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Datum/Axis/CSYS Commands API

Datum Axis

evxErrors cvxPartAxisNew (svxAxisData *Axis, int *idAxis)

Datum Plane

evxErrors | cvxPartDatum (svxMatrix *Frame, int *idDatum)
evxErrors | cvxPartDatum2 (svxMatrix *Frame, int iCode, int *idDatum)
evxErrors | cvxPartNewDatum (svxMatrix *Frame, int *idDatum)
evxErrors | cvxPartPlnCrv (int idCrv, svxPoint *Origin, svxPoint *Xaxis, int *idPln)
evxErrors | cvxPartPlnCrv2 (int idCrv, svxData *Origin, svxData *Xaxis, int Flip, int *idPln)
evxErrors | cvxPartPlnSrf (int idFace, svxPoint *Origin, int *idPln)
evxErrors | cvxPartPlnSrf2 (int idFace, svxPoint *Origin, svxPoint *XZ, int Flip, int *idPln)
evxErrors | cvxPartPlaneNew (svxPlaneData *Plane, int *idPlane)
evxErrors | cvxPartPlaneAddInit (evxNewPlaneMethods method, svxNewPlaneData *data)
evxErrors | cvxPartPlaneAdd (const svxNewPlaneData *plane, int *idPlane)

Datum CSYS

evxErrors | cvxPartCSYSNewInit (evxCSYSMethods method, svxCSYSData *data)
evxErrors | cvxPartCSYSNew (svxCSYSData *CSYS, int *idCSYS)

LCS

evxErrors cvxPartActiveAsLCS (int id)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartActiveAsLCS

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartActiveAsLCS()

evxErrors cvxPartActiveAsLCS ( int id )

#include <zwapi_cmd_datum.h>

Active the specified datum/CSYS as the LCS.

Parameters
[in] id id of datum/CSYS
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAxisNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartAxisNew()

evxErrors cvxPartAxisNew | ( | svxAxisData * | Axis,
 |  | int * | idAxis
 | ) |  |

#include <zwapi_cmd_datum.h>

This function add a new datum axis to the active part according to the *Axis. If "idAxis" is not NULL, the id of the new datum axis is output.

Note
Interface cvxMemZero() can initialize variables of this function.
Parameters
[in] | Axis | Axis data
[out] | idAxis | id of new datum Axis (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCSYSNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartCSYSNew()

evxErrors cvxPartCSYSNew | ( | svxCSYSData * | CSYS,
 |  | int * | idCSYS
 | ) |  |

#include <zwapi_cmd_datum.h>

This function add a new datum CSYS to the active part according to the Frame. If "idCSYS" is not NULL, the id of the new datum CSYS is output.

Note
Interface cvxPartCSYSNewInit() can initialize variables of this function.
Parameters
[in] | CSYS | CSYS data
[out] | idCSYS | id of new CSYS (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCSYSNewInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartCSYSNewInit()

evxErrors cvxPartCSYSNewInit | ( | evxCSYSMethods | method,
 |  | svxCSYSData * | data
 | ) |  |

#include <zwapi_cmd_datum.h>

Initialize the parameters of the cvxPartCSYSNew().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | csys method
[out] | data | csys data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartDatum()

evxErrors cvxPartDatum | ( | svxMatrix * | Frame,
 |  | int * | idDatum
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part, aligned with the specified local coordinate frame. If "idDatum" is not NULL, the id of the new datum is output.

If Frame is invalid, it will use the identity matrix.

Parameters
[in] | Frame | transformation matrix
[out] | idDatum | id of new datum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDatum2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartDatum2()

evxErrors cvxPartDatum2 | ( | svxMatrix * | Frame,
 |  | int | iCode,
 |  | int * | idDatum
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part, aligned with the specified local coordinate frame.
If "idDatum" is not NULL, the id of the new datum is output.In addition to need input position
code its function is same as cvxPartDatum(), 1 as the default in cvxPartDatum().

Parameters
[in] | Frame | transformation matrix
[in] | iCode | position code ,1 add label to entity, 0 don't
[out] | idDatum | id of new datum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartNewDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartNewDatum()

evxErrors cvxPartNewDatum | ( | svxMatrix * | Frame,
 |  | int * | idDatum
 | ) |  |

#include <zwapi_cmd_datum.h>

This function add a new datum plane to the active part according to the Frame.
It is different to cvxPartDatum(). If "idDatum" is not NULL, the id of the new datum is output.

Parameters
[in] | Frame | transformation matrix
[out] | idDatum | id of new datum
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlaneAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlaneAdd()

evxErrors cvxPartPlaneAdd | ( | const svxNewPlaneData * | plane,
 |  | int * | idPlane
 | ) |  |

#include <zwapi_cmd_datum.h>

This function add a new datum Plane to the active part according to the svxNewPlaneData. If "idPlane" is not NULL, the id of the new datum Plane is output.

This function is similar to cvxPartPlaneNew(). This interface uses a different command template than cvxPartPlaneNew().

Note
Interface cvxPartPlaneAddInit() can initialize variables of this function.
Parameters
[in] | plane | new plane data
[out] | idPlane | id of new plane (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlaneAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlaneAddInit()

evxErrors cvxPartPlaneAddInit | ( | evxNewPlaneMethods | method,
 |  | svxNewPlaneData * | data
 | ) |  |

#include <zwapi_cmd_datum.h>

Initialize the parameters of the cvxPartPlaneAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | New Plane Methods
[out] | data | New template command Plane input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlaneNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlaneNew()

evxErrors cvxPartPlaneNew | ( | svxPlaneData * | Plane,
 |  | int * | idPlane
 | ) |  |

#include <zwapi_cmd_datum.h>

This function add a new datum Plane to the active part according to the svxPlaneData. If "idPlane" is not NULL, the id of the new datum Plane is output.

Parameters
[in] | Plane | Plane data
[out] | idPlane | id of new Plane (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlnCrv()

evxErrors cvxPartPlnCrv | ( | int | idCrv,
 |  | svxPoint * | Origin,
 |  | svxPoint * | Xaxis,
 |  | int * | idPln
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part that is normal to the specified curve "idCrv", with its origin located at the point on "idCrv" that lies closest to the input "Origin" point.

If the reference point "Xaxis" is specified (i.e. not NULL), the new datum plane is oriented so that its X axis lies in the plane that contains "Xaxis" and the new datum's Z axis. That is, the point "Xaxis" specifies the XZ plane of the new datum.

Parameters
[in] | idCrv | id of curve entity
[in] | Origin | point at or near plane origin on curve
[in] | Xaxis | point lying on plane of new datum's X axis (or NULL)
[out] | idPln | id of new datum plane (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlnCrv2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlnCrv2()

evxErrors cvxPartPlnCrv2 | ( | int | idCrv,
 |  | svxData * | Origin,
 |  | svxData * | Xaxis,
 |  | int | Flip,
 |  | int * | idPln
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part that is normal to the specified curve "idCrv", with its origin located at the point on "idCrv" that lies closest to the input "Origin" point.

If the reference point "Xaxis" is specified (i.e. not NULL), the new datum plane is oriented so that its X axis lies in the plane that contains "Xaxis" and the new datum's Z axis. That is, the point "Xaxis" specifies the XZ plane of the new datum.

If "Flip" is non-zero, flip the datum plane 180 degrees about the specified axis.

Besides the "Flip" argument, the difference between this function and cvxPartPlnCrv() is that "Origin" and "Xaxis" can be defined more flexibly using the parameters available in "svxData". The calling procedure is responsible for defining "svxData" correctly.

Note
Make sure you zero the entire "svxData" structure before initializing specific parameters {svxData Origin; cvxMemZero(&Origin,sizeof(Origin);}.
Parameters
[in] | idCrv | id of curve entity
[in] | Origin | point at or near plane origin on curve
[in] | Xaxis | point lying on plane of new datum's X axis (or NULL)
[in] Flip 0-ignore this input;
1-flip plane 180 degrees about X axis;
2-flip plane about Y axis;
3-flip about Z axis
[out] | idPln | id of new datum plane (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlnSrf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlnSrf()

evxErrors cvxPartPlnSrf | ( | int | idFace,
 |  | svxPoint * | Origin,
 |  | int * | idPln
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part that is tangent to the surface of the specified face "idFace", with its origin located at the point on "idFace" that lies closest to the input "Origin" point.

Parameters
[in] | idFace | id of face entity
[in] | Origin | point at or near plane origin on face
[out] | idPln | id of new datum plane (or NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPlnSrf2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ cvxPartPlnSrf2()

evxErrors cvxPartPlnSrf2 | ( | int | idFace,
 |  | svxPoint * | Origin,
 |  | svxPoint * | XZ,
 |  | int | Flip,
 |  | int * | idPln
 | ) |  |

#include <zwapi_cmd_datum.h>

Adds a datum plane to the active part that is tangent to the surface of the specified face "idFace", with its origin located at the point on "idFace" that lies closest to the input "Origin" point and its Z axis pointing along the face's outward normal at "Origin".

If "XZ" is a non-NULL pointer to a 3D point, the point is used to control the plane's orientation by rotating the plane about its Z axis (face's outward normal) until its XZ plane intersects the point.

If "Flip" is non-zero, the plane is flipped 180 degrees about its X axis (Flip=1), Y axis (Flip=2) or Z axis (Flip=3).

Parameters
[in] | idFace | id of face entity
[in] | Origin | point at or near plane origin on face
[in] | XZ | point on XZ plane (NULL to ignore)
[in] | Flip | flip plane about an axis (see DESCRIPTION)
[out] | idPln | id of new datum plane (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Datum Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Datum Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Datum/ Axis/CSYS Command functions.

Datum Axis Data

enum evxAxisMethods {
VX_AXIS_GEOMETRY = 0 , VX_AXIS_FACE_CENTER = 1 , VX_AXIS_XX = 2 , VX_AXIS_YY = 3 ,
VX_AXIS_ZZ = 4 , VX_AXIS_TWO_PNT = 5 , VX_AXIS_PNT_DIR = 6 , VX_AXIS_INTERSECT_FACES = 7
}
Axis Methods. More...
typedef enum evxAxisMethods | evxAxisMethods
Axis Methods.
typedef struct svxAxisData | svxAxisData
template command Axis input data

Datum Plane

enum evxPlaneMethods {
VX_PLANE_GEOMETRY = 0 , VX_PLANE_THREE_POINTS = 1 , VX_PLANE_XY = 2 , VX_PLANE_XZ = 3 ,
VX_PLANE_YZ = 4 , VX_PLANE_VIEW_PLANE = 5 , VX_PLANE_TWO_ENTITIES = 6 , VX_PLANE_DYNAMIC = 7
}
Plane Methods. More...
enum | evxPlaneAlign { VX_PLANE_ALIGN_TO_XY = 1 , VX_PLANE_ALIGN_TO_XZ = 2 , VX_PLANE_ALIGN_TO_YZ = 3 }
Plane Orientation Align type. More...
enum evxNewPlaneMethods {
VX_NEW_PLANE_THREE_POINTS = 1 , VX_NEW_PLANE_VIEW_PLANE = 5 , VX_NEW_PLANE_DYNAMIC = 7 , VX_NEW_PLANE_GEOMETRY = 11 ,
VX_NEW_PLANE_OFFSET_PLANE = 12 , VX_NEW_PLANE_ANGLE_FACE = 13 , VX_NEW_PLANE_ON_CURVE = 14
}
New Plane Methods. More...
enum | evxOnCrvDirType { VX_ONCRV_TANGENT , VX_ONCRV_PERPENDICULAR , VX_ONCRV_PERPENDICULAR_TO_CURVE , VX_ONCRV_TANGENT_TO_CURVE }
Plane direction type. More...
typedef enum evxPlaneMethods | evxPlaneMethods
Plane Methods.
typedef enum evxPlaneAlign | evxPlaneAlign
Plane Orientation Align type.
typedef struct svxPlaneData | svxPlaneData
template command Plane input data
typedef enum evxNewPlaneMethods | evxNewPlaneMethods
New Plane Methods.
typedef enum evxOnCrvDirType | evxOnCrvDirType
Plane direction type.
typedef struct svxNewPlaneData | svxNewPlaneData
New template command Plane input data.

Datum CSYS

enum evxCSYSMethods {
VX_CSYS_THREE_POINTS = 1 , VX_CSYS_ONLY_MATRIX = 6 , VX_CSYS_DYNAMIC = 7 , VX_CSYS_THREE_FACES = 8 ,
VX_CSYS_PNT_AND_TWO_DIR = 9 , VX_CSYS_PLANE_PNT_AND_DIR = 10 , VX_CSYS_GEOMETRY = 11
}
CSYS Methods. More...
enum | evsResultsAxisMethod { VX_RESULTS_AXIS_X , VX_RESULTS_AXIS_Y , VX_RESULTS_AXIS_Z }
Results axis. More...
typedef enum evxCSYSMethods | evxCSYSMethods
CSYS Methods.
typedef enum evsResultsAxisMethod | evsResultsAxisMethod
Results axis.
typedef struct svxCSYSData | svxCSYSData
template command CSYS input data
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Direct Edit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Direct Edit
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Direct Edit Commands API

Modify

evxErrors | cvxPartDEMoveInit (evxDEMoveCopyType type, svxDEMove *data)
evxErrors | cvxPartDEMove (const svxDEMove *data, int *idMove)
evxErrors | cvxPartDEAlignMoveInit (evxDEAlignMoveType type, svxDEAlignMove *data)
evxErrors | cvxPartDEAlignMove (const svxDEAlignMove *data, int *idMove)
evxErrors | cvxPartDEDimMoveInit (evxDEDimMoveType type, svxDEDimMove *data)
evxErrors | cvxPartDEDimMove (const svxDEDimMove *data, int *idMove)
evxErrors | cvxPartDEOffsetInit (svxDEOffset *data)
evxErrors | cvxPartDEOffset (const svxDEOffset *data, int *idOffset)
evxErrors | cvxPartDEDraftInit (svxDEDraft *data)
evxErrors | cvxPartDEDraft (const svxDEDraft *data, int *idDraft)

Reuse

evxErrors | cvxPartDECopyInit (evxDEMoveCopyType type, svxDECopy *data)
evxErrors | cvxPartDECopy (const svxDECopy *data, int *idCopy)
evxErrors | cvxPartDEMirrorInit (svxDEMirror *data)
evxErrors | cvxPartDEMirror (const svxDEMirror *data, int *idMirror)
evxErrors | cvxPartDEPtnInit (evxDEPtnType type, svxDEPattern *data)
evxErrors | cvxPartDEPtn (const svxDEPattern *data, int *idPtn)

Resize

evxErrors | cvxPartDEFlltInit (svxDEFllt *data)
evxErrors | cvxPartDEFllt (const svxDEFllt *data, int *idFllt)
evxErrors | cvxPartDERadInit (svxDERad *data)
evxErrors | cvxPartDERad (const svxDERad *data, int *idRad)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEAlignMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEAlignMove()

evxErrors cvxPartDEAlignMove | ( | const svxDEAlignMove * | data,
 |  | int * | idMove
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Interface cvxPartDEAlignMoveInit() can initialize variables DE(Direct Edit) move of this function.

Parameters
[in] | data | DE(Direct Edit) align move input data
[out] | idMove | id of DE(Direct Edit) align move feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEAlignMoveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEAlignMoveInit()

evxErrors cvxPartDEAlignMoveInit | ( | evxDEAlignMoveType | type,
 |  | svxDEAlignMove * | data
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEAlignMove structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | DE(Direct Edit) align move type
[out] | data | DE(Direct Edit) align move data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDECopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDECopy()

evxErrors cvxPartDECopy | ( | const svxDECopy * | data,
 |  | int * | idCopy
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to DE(Direct Edit) copy faces. Six different methods of copy are available, each method requires different types of input.

Note
Interface cvxPartDECopyInit() can initialize variables DE(Direct Edit) copy of this function.
Parameters
[in] | data | part or assembly DE(Direct Edit) copy input data
[out] | idCopy | id of DE(Direct Edit) copy feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDECopyInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDECopyInit()

evxErrors cvxPartDECopyInit | ( | evxDEMoveCopyType | type,
 |  | svxDECopy * | data
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDECopy structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | part or assembly DE(Direct Edit) copy type
[out] | data | id of DE(Direct Edit) face draft feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEDimMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEDimMove()

evxErrors cvxPartDEDimMove | ( | const svxDEDimMove * | data,
 |  | int * | idMove
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to DE(Direct Edit) dim move faces. Two different methods of move are available, each method requires different types of input.

Note
Interface cvxPartDEDimMoveInit() can initialize variables DE(Direct Edit) move of this function.
Parameters
[in] | data | DE(Direct Edit) dim move input data
[out] | idMove | id of DE(Direct Edit) dim move feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEDimMoveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEDimMoveInit()

evxErrors cvxPartDEDimMoveInit | ( | evxDEDimMoveType | type,
 |  | svxDEDimMove * | data
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEDimMove structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | DE(Direct Edit) dim move type
[out] | data | DE(Direct Edit) dim move data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEDraft

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEDraft()

evxErrors cvxPartDEDraft | ( | const svxDEDraft * | data,
 |  | int * | idDraft
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEDraft structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | data | DE(Direct Edit) face draft input data
[out] | idDraft | id of DE(Direct Edit) face draft feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEDraftInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEDraftInit()

evxErrors cvxPartDEDraftInit ( svxDEDraft * data )

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEDraft structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data DE(Direct Edit) face draft data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEFllt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEFllt()

evxErrors cvxPartDEFllt | ( | const svxDEFllt * | data,
 |  | int * | idFllt
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to modify DE(Direct Edit) face fillet.

Note
Interface cvxPartDEMirrorInit() can initialize variables DE(Direct Edit) mirror of this function.
Parameters
[in] | data | DE(Direct Edit) fillet input data
[out] | idFllt | id of DE(Direct Edit) fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEFlltInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEFlltInit()

evxErrors cvxPartDEFlltInit ( svxDEFllt * data )

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEFllt structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data DE(Direct Edit) face fillet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEMirror

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEMirror()

evxErrors cvxPartDEMirror | ( | const svxDEMirror * | data,
 |  | int * | idMirror
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to create DE(Direct Edit) face mirror.

Note
Interface cvxPartDEMirrorInit() can initialize variables DE(Direct Edit) mirror of this function.
Parameters
[in] | data | DE(Direct Edit) mirror input data
[out] | idMirror | id of DE(Direct Edit) mirror feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEMirrorInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEMirrorInit()

evxErrors cvxPartDEMirrorInit ( svxDEMirror * data )

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEMirror structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data DE(Direct Edit) face mirror data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEMove()

evxErrors cvxPartDEMove | ( | const svxDEMove * | data,
 |  | int * | idMove
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to DE(Direct Edit) move faces. Six different methods of move are available, each method requires different types of input.

Note
Interface cvxPartDEMoveInit() can initialize variables DE(Direct Edit) move of this function.
Parameters
[in] | data | part or assembly DE(Direct Edit) move input data
[out] | idMove | id of DE(Direct Edit) move feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEMoveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEMoveInit()

evxErrors cvxPartDEMoveInit | ( | evxDEMoveCopyType | type,
 |  | svxDEMove * | data
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEMove structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | part or assembly DE(Direct Edit) move type
[out] | data | part or assembly DE(Direct Edit) move data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEOffset()

evxErrors cvxPartDEOffset | ( | const svxDEOffset * | data,
 |  | int * | idOffset
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to change DE(Direct Edit) face offset.

Note
Interface cvxPartDEOffsetInit() can initialize variables DE(Direct Edit) offset of this function.
Parameters
[in] | data | DE(Direct Edit) face offset input data
[out] | idOffset | id of DE(Direct Edit) face offset feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEOffsetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEOffsetInit()

evxErrors cvxPartDEOffsetInit ( svxDEOffset * data )

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEOffset structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEPtn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEPtn()

evxErrors cvxPartDEPtn | ( | const svxDEPattern * | data,
 |  | int * | idPtn
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to DE(Direct Edit) pattern faces. Six different methods of pattern are available, each method requires different types of input.

Note
Interface cvxPartDEMirrorInit() can initialize variables DE(Direct Edit) mirror of this function.
Parameters
[in] | data | part or assembly DE(Direct Edit) pattern input data
[out] | idPtn | id of DE(Direct Edit) pattern feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDEPtnInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDEPtnInit()

evxErrors cvxPartDEPtnInit | ( | evxDEPtnType | type,
 |  | svxDEPattern * | data
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDEPattern structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | part or assembly DE(Direct Edit) pattern type
[out] | data | part or assembly DE(Direct Edit) pattern data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDERad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDERad()

evxErrors cvxPartDERad | ( | const svxDERad * | data,
 |  | int * | idRad
 | ) |  |

#include <zwapi_cmd_direct_edit.h>

Use this function to modify DE(Direct Edit) face radius.

Note
Interface cvxPartDEMirrorInit() can initialize variables DE(Direct Edit) mirror of this function.
Parameters
[in] | data | DE(Direct Edit) radius input data
[out] | idRad | id of DE(Direct Edit) radius feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDERadInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ cvxPartDERadInit()

evxErrors cvxPartDERadInit ( svxDERad * data )

#include <zwapi_cmd_direct_edit.h>

Initialize the svxDERad structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data DE(Direct Edit) face radius data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Direct Edit Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Direct Edit Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Direct Edit Command functions.

Modify Data

enum evxDEMoveCopyType {
VX_DE_MOVE_PNT_TO_PNT = 1 , VX_DE_MOVE_ALONG_DIR = 2 , VX_DE_MOVE_FRAME = 3 , VX_DE_MOVE_PATH = 4 ,
VX_DE_MOVE_AROUND_DIR = 5 , VX_DE_MOVE_DYNAMIC = 6
}
part or assembly DE(Direct Edit) move or copy method More...
enum | evxDEFaceOverflow { VX_DE_OVERFLOW_AUTO , VX_DE_OVERFLOW_CHANGE , VX_DE_OVERFLOW_STATION , VX_DE_OVERFLOW_CAP }
part or assembly DE(Direct Edit) move overflow method More...
enum | evxDEMoveCopyFrame { VX_DE_MOVE_FRAME_NATURAL , VX_DE_MOVE_FRAME_PATH , VX_DE_MOVE_FRAME_SELECT }
part or assembly DE(Direct Edit) move or copy frame method More...
enum | evxDEMoveCopyZSpine { VX_DE_MOVE_Z_NATURAL , VX_DE_MOVE_Z_SPINE , VX_DE_MOVE_Z_PARALLEL }
part or assembly DE(Direct Edit) move or copy Z-spine method More...
enum | evxDEMoveCopyXOrient { VX_DE_MOVE_X_NATURAL , VX_DE_MOVE_X_PLANE , VX_DE_MOVE_X_CURVE }
part or assembly DE(Direct Edit) move or copy X-orient method More...
enum evxDEAlignMoveType {
VX_DE_ALIGN_MOVE_COPLANAR = 1 , VX_DE_ALIGN_MOVE_CONCENTRIC = 2 , VX_DE_ALIGN_MOVE_TANGENT = 3 , VX_DE_ALIGN_MOVE_PARALLEL = 4 ,
VX_DE_ALIGN_MOVE_PERPENDICULAR = 5 , VX_DE_ALIGN_MOVE_ANGLE = 6 , VX_DE_ALIGN_MOVE_SYMMETRY = 7
}
part or assembly DE(Direct Edit) align move method More...
enum | evxDEDimMoveType { VX_DE_DIM_LINEAR = 1 , VX_DE_DIM_ANGULAR = 2 }
part or assembly DE(Direct Edit) dim move method More...
enum | evxDESideFaceType { VX_DE_SIDE_FACE_NO_CREATE , VX_DE_SIDE_FACE_CREATE }
part or assembly DE(Direct Edit) side face method More...
enum | evxDEIsectType { VX_DE_ISECT_NO_REMOVE , VX_DE_ISECT_REMOVE }
part or assembly DE(Direct Edit) intersection method More...
enum | evxDEDraftSideType { VX_DE_DRAFT_SIDE_TOP , VX_DE_DRAFT_SIDE_BOTTOM , VX_DE_DRAFT_SIDE_SPILT , VX_DE_DRAFT_SIDE_NEUTRAL }
part or assembly DE(Direct Edit) draft about side method More...
typedef enum evxDEMoveCopyType | evxDEMoveCopyType
part or assembly DE(Direct Edit) move or copy method
typedef enum evxDEFaceOverflow | evxDEFaceOverflow
part or assembly DE(Direct Edit) move overflow method
typedef enum evxDEMoveCopyFrame | evxDEMoveCopyFrame
part or assembly DE(Direct Edit) move or copy frame method
typedef enum evxDEMoveCopyZSpine | evxDEMoveCopyZSpine
part or assembly DE(Direct Edit) move or copy Z-spine method
typedef enum evxDEMoveCopyXOrient | evxDEMoveCopyXOrient
part or assembly DE(Direct Edit) move or copy X-orient method
typedef struct svxDEMove | svxDEMove
part or assembly DE(Direct Edit) move data
typedef enum evxDEAlignMoveType | evxDEAlignMoveType
part or assembly DE(Direct Edit) align move method
typedef struct svxDEAlignMove | svxDEAlignMove
part or assembly DE(Direct Edit) align move data
typedef enum evxDEDimMoveType | evxDEDimMoveType
part or assembly DE(Direct Edit) dim move method
typedef struct svxDEDimMove | svxDEDimMove
part or assembly DE(Direct Edit) dim move data
typedef enum evxDESideFaceType | evxDESideFaceType
part or assembly DE(Direct Edit) side face method
typedef enum evxDEIsectType | evxDEIsectType
part or assembly DE(Direct Edit) intersection method
typedef struct svxDEOffset | svxDEOffset
part or assembly DE(Direct Edit) face offset data
typedef enum evxDEDraftSideType | evxDEDraftSideType
part or assembly DE(Direct Edit) draft about side method
typedef struct svxDEDraft | svxDEDraft
part or assembly DE(Direct Edit) draft data

Reuse Data

enum evxDEPtnType {
VX_DE_PTN_LINEAR , VX_DE_PTN_CIRCULAR , VX_DE_PTN_POINT , VX_DE_PTN_PATTERN ,
VX_DE_PTN_CURVE , VX_DE_PTN_FACE
}
part or assembly DE(Direct Edit) pattern method More...
enum | evxDEPtnDerive { VX_DE_PTN_DERIVE_NONE , VX_DE_PTN_DERIVE_SPACING , VX_DE_PTN_DERIVE_NUMBER }
part or assembly DE(Direct Edit) pattern derive method More...
enum | evxDEPtnCrv { VX_DE_PTN_CRV1 , VX_DE_PTN_CRV2_TGT , VX_DE_PTN_CRV2_ACR , VX_DE_PTN_CRV3 }
part or assembly DE(Direct Edit) pattern at curve method More...
enum | evxDEPtnBound { VX_DE_PTN_BOUND_AUTO , VX_DE_PTN_BOUND_PLACE , VX_DE_PTN_BOUND_MOVE }
part or assembly DE(Direct Edit) pattern boundary method More...
typedef struct svxDECopy | svxDECopy
part or assembly DE(Direct Edit) copy data
typedef struct svxDEMirror | svxDEMirror
part or assembly DE(Direct Edit) mirror data
typedef enum evxDEPtnType | evxDEPtnType
part or assembly DE(Direct Edit) pattern method
typedef enum evxDEPtnDerive | evxDEPtnDerive
part or assembly DE(Direct Edit) pattern derive method
typedef enum evxDEPtnCrv | evxDEPtnCrv
part or assembly DE(Direct Edit) pattern at curve method
typedef enum evxDEPtnBound | evxDEPtnBound
part or assembly DE(Direct Edit) pattern boundary method
typedef struct svxDEPattern | svxDEPattern
part or assembly DE(Direct Edit) pattern data

Resize Data

typedef struct svxDEFllt | svxDEFllt
part or assembly DE(Direct Edit) modify fillet data
typedef struct svxDERad | svxDERad
part or assembly DE(Direct Edit) modify radius data
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: ECAD Board Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
ECAD Board Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D ECAD Board API

Engineer Feature

evxErrors | cvxPartEcadRgnSetInit (svxEcadRgnSetData *data)
evxErrors | cvxPartEcadRgnSet (const svxEcadRgnSetData *pRgnSetData, int *idFtr)
evxErrors | cvxPartEcadRgnCut (int idSketch, int *idFtr)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEcadRgnCut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ECAD Board Commands
cvxPartEcadRgnCut
cvxPartEcadRgnSet
cvxPartEcadRgnSetInit

◆ cvxPartEcadRgnCut()

evxErrors cvxPartEcadRgnCut | ( | int | idSketch,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_ecadboard.h>

Use the input sketch to cut the sheet metal shape. It likes Extrude_Remove command and the extrude length is the thickness of the tab shape in current part.

Parameters
[in] | idSketch | id sketch to cut the tab shape
[out] | idFtr | id of feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEcadRgnSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ECAD Board Commands
cvxPartEcadRgnCut
cvxPartEcadRgnSet
cvxPartEcadRgnSetInit

◆ cvxPartEcadRgnSet()

evxErrors cvxPartEcadRgnSet | ( | const svxEcadRgnSetData * | pRgnSetData,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_ecadboard.h>

ECAD "Region Set" command. The sketch must be cosmetic.

Note
Interface cvxPartEcadRgnSetInit() can initialize variables of this function.
Parameters
[in] | pRgnSetData | region set data
[out] | idFtr | id of feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEcadRgnSetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ECAD Board Commands
cvxPartEcadRgnCut
cvxPartEcadRgnSet
cvxPartEcadRgnSetInit

◆ cvxPartEcadRgnSetInit()

evxErrors cvxPartEcadRgnSetInit ( svxEcadRgnSetData * data )

#include <zwapi_cmd_ecadboard.h>

Initialize the parameters of the cvxPartEcadRgnSet().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Region set data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: ECAD Board Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
ECAD Board Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the ECAD Board command functions.

Engineer Feature Data

enum evxEcadRgnSetType {
VX_ROUTING_RGN = 0 , VX_PLACEMENT_RGN = 1 , VX_VIA_RGN = 2 , VX_OTHER_RGN = 3 ,
VX_PLACEMENT_GRP_RGN = 4
}
region setting type More...
enum | evxEcadRgnOwner { VX_MCAD_RGN = 0 , VX_ECAD_RGN = 1 , VX_UNOWNED_RGN = 2 }
region owner More...
typedef enum evxEcadRgnSetType | evxEcadRgnSetType
region setting type
typedef enum evxEcadRgnOwner | evxEcadRgnOwner
region owner
typedef struct svxEcadRgnSetData | svxEcadRgnSetData
Region set data.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Free Form Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Free Form Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Free Form Commands API

Basic Face

evxErrors | cvxPartFilletBlendInit (svxFilletBlendData *data)
evxErrors | cvxPartFilletBlend (const svxFilletBlendData *FilletBlend, int *idFilletBlend)
evxErrors | cvxPartNSidedInit (svxNSidedData *data)
evxErrors | cvxPartNSided (const svxNSidedData *NSidedData, int *idShape)
evxErrors | cvxPartTrimmedPlaneInit (svxTrimPlnData *data)
evxErrors | cvxPartTrimmedPlane (svxTrimPlnData *data, int *newShp)
evxErrors | cvxPartRuledInit (svxRuledData *data)
evxErrors | cvxPartRuled (const svxRuledData *data, int *idFace)
evxErrors | cvxPartCircularBiRailInit (evxCircularBiRailMethod method, svxCircularBiRailData *data)
evxErrors | cvxPartCircularBiRail (const svxCircularBiRailData *data, int *idFace)
evxErrors | cvxPartConicBiRailInit (evxConicBiRailMethod method, svxConicBiRailData *data)
evxErrors | cvxPartConicBiRail (const svxConicBiRailData *data, int *idFace)

Edit Face

evxErrors | cvxPartFacesOffsetInit (svxFcsOffsetData *data)
evxErrors | cvxPartFacesOffset (const svxFcsOffsetData *data, int *idFtr)
evxErrors | cvxPartExtendFaceInit (svxExtendData *data)
evxErrors | cvxPartExtendFace (svxExtendData *data, int *newFtr)
evxErrors | cvxPartTrimToFacesInit (svxTrimToFacesData *data)
evxErrors | cvxPartTrimToFaces (const svxTrimToFacesData *data, int *idTrim)
evxErrors | cvxPartTrimToCrvs (const svxTrimToCurvesData *trimData, int *idTrim)
evxErrors | cvxPartSetFaceDir (int count, int *idFaces, const svxVector *dir)
evxErrors | cvxFaceReverse (int numFaces, int *idFaces)
evxErrors | cvxFaceReverseDir (int numFaces, int *idFaces)
evxErrors | cvxPartModifyIsolineNum (int count, int *idFaces, int Uisoline, int Visoline)
evxErrors | cvxPartExplodeInit (svxExplodeData *data)
evxErrors | cvxPartExplode (const svxExplodeData *ExplodeData, int *numShape, int **idShapes)
evxErrors | cvxPartFacesetSewInit (svxSewData *data)
evxErrors | cvxPartFacesetSew (int count, int *shapes, svxSewData *param, int *newFtr)
evxErrors | cvxPartSewForce (double Tol)
evxErrors | cvxPartEnlargeFaceInit (svxEnlargeFaceData *data)
evxErrors | cvxPartEnlargeFace (const svxEnlargeFaceData *data, int *idFace)
evxErrors | cvxPartExtendShapeInit (svxExtendShapeData *data)
evxErrors | cvxPartExtendShape (const svxExtendShapeData *data, int *idFtr)
evxErrors | cvxPartSplitWithCrvInit (svxSplitWithCrvData *data)
evxErrors | cvxPartSplitWithCrv (const svxSplitWithCrvData *data, int *idFtr)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceReverse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxFaceReverse()

evxErrors cvxFaceReverse | ( | int | numFaces,
 |  | int * | idFaces
 | ) |  |

#include <zwapi_cmd_freeform.h>

Reverses the direction of the natural normal of the input faces by swapping the U and V parameter directions of each face's surface.

Each face's normal direction also reverses to keep it consistently oriented with respect to the surface normal and ensure a closed shape's inside and outside remain unchanged.

This function also modifies each face's pre-edges to keep them properly located in the modified UV domain. This function ignores any face ID that is less than 1.

See also
cvxFaceReverseDir().
Parameters
[in] | numFaces | number of faces in input list
[in] | idFaces | pointer to array of integer face id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxFaceReverseDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxFaceReverseDir()

evxErrors cvxFaceReverseDir | ( | int | numFaces,
 |  | int * | idFaces
 | ) |  |

#include <zwapi_cmd_freeform.h>

Reverses the normal direction of each input face, without changing its surface or trim loops. If a face initially bounds a closed shape, this flips the inside and outside with respect to that shape.

Each ID in the idFaces array may refer to a face or a shape. When an ID refers to a shape, this function reverses all of the shape's faces.

See also
cvxFaceReverse().
Parameters
[in] | numFaces | number of faces in input list
[in] | idFaces | pointer to array of integer face id's
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_aPI_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCircularBiRail

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartCircularBiRail()

evxErrors cvxPartCircularBiRail | ( | const svxCircularBiRailData * | data,
 |  | int * | idFace
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to create a face of circular cross-section between two sets of path curves. The radii of the cross-sections are determined by the creation method and are used to define a circle that intersects both boundary curves.

Note
Interface cvxPartCircularBiRailInit() can initialize variables of this function.
Parameters
[in] | data | circular bi rail data to create a new circular face
[out] | idFace | id of new face (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCircularBiRailInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartCircularBiRailInit()

evxErrors cvxPartCircularBiRailInit | ( | evxCircularBiRailMethod | method,
 |  | svxCircularBiRailData * | data
 | ) |  |

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartCircularBiRail().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | circular bi rail method
[out] | data | circular bi rail data to create a new circular face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartConicBiRail

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartConicBiRail()

evxErrors cvxPartConicBiRail | ( | const svxConicBiRailData * | data,
 |  | int * | idFace
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to create a face with conic cross-sections between two path curves. The radii of the cross-sections are determined by the creation method. This radius defines a circle that intersects both boundary curves. Tangent lines to the circle at the intersection points, along with a conic ratio, define the conic cross-sections.

Note
Interface cvxPartConicBiRailInit() can initialize variables of this function.
Parameters
[in] | data | conic bi rail data to create a new conic face
[out] | idFace | id of new face (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartConicBiRailInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartConicBiRailInit()

evxErrors cvxPartConicBiRailInit | ( | evxConicBiRailMethod | method,
 |  | svxConicBiRailData * | data
 | ) |  |

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartConicBiRail().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | conic bi rail method
[out] | data | conic bi rail data to create a new conic face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEnlargeFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartEnlargeFace()

evxErrors cvxPartEnlargeFace | ( | const svxEnlargeFaceData * | data,
 |  | int * | idFace
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to remove all the loops from the selected face and enlarge the new face by extending each edge.

Note
Interface cvxPartEnlargeFaceInit() can initialize variables of this function.
Parameters
[in] | data | enlarge face data
[out] | idFace | id of new face (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEnlargeFaceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartEnlargeFaceInit()

evxErrors cvxPartEnlargeFaceInit ( svxEnlargeFaceData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartEnlargeFace().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data enlarge face data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExplode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExplode()

evxErrors cvxPartExplode | ( | const svxExplodeData * | ExplodeData,
 |  | int * | numShape,
 |  | int ** | idShapes
 | ) |  |

#include <zwapi_cmd_freeform.h>

Explode faces from the active topology table.

Note
Interface cvxPartExplodeInit() can initialize variables of this function.
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | ExplodeData | explode_data definition
[out] | numShape | number of resulting shapes (NULL to ignore)
[out] | idShapes | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExplodeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExplodeInit()

evxErrors cvxPartExplodeInit ( svxExplodeData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartExplode().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data data of explode command
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtendFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExtendFace()

evxErrors cvxPartExtendFace | ( | svxExtendData * | data,
 |  | int * | newFtr
 | ) |  |

#include <zwapi_cmd_freeform.h>

Extend the specified face.

Note
Interface cvxPartExtendFaceInit() can initialize variables of this function.
Parameters
[in] | data | extend face data
[out] | newFtr | index of new feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtendFaceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExtendFaceInit()

evxErrors cvxPartExtendFaceInit ( svxExtendData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartExtendFace().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Extend Face data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtendShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExtendShape()

evxErrors cvxPartExtendShape | ( | const svxExtendShapeData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to extend the face edges of an open shape or solid shape.

Note
Interface cvxPartExtendShapeInit() can initialize variables of this function.
Parameters
[in] | data | extend shape data
[out] | idFtr | id of new feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtendShapeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartExtendShapeInit()

evxErrors cvxPartExtendShapeInit ( svxExtendShapeData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartExtendShape().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data extend shape data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacesetSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFacesetSew()

evxErrors cvxPartFacesetSew | ( | int | count,
 |  | int * | shapes,
 |  | svxSewData * | param,
 |  | int * | newFtr
 | ) |  |

#include <zwapi_cmd_freeform.h>

Sew the specified shapes.

Note
Interface cvxPartFacesetSewInit() can initialize variables of this function.
See also
cvxPartSewForce() The difference between cvxPartFacesetSew and cvxPartSewForce is this function can input the specified shapes and set the svxSewData by themselves.
Parameters
[in] | count | count of shapes
[in] | shapes | id list of shapes
[in] | param | parameter value (NULL to use default)
[out] | newFtr | id of new feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacesetSewInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFacesetSewInit()

evxErrors cvxPartFacesetSewInit ( svxSewData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartFacesetSew().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data faces sew data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacesOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFacesOffset()

evxErrors cvxPartFacesOffset | ( | const svxFcsOffsetData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use this function to create a new face offset from a face at a specified distance. Multiple faces can be offset at the same time.

Note
Interface cvxPartFacesOffsetInit() can initialize variables of this function.
Parameters
[in] | data | face offset data
[out] | idFtr | feature id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFacesOffsetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFacesOffsetInit()

evxErrors cvxPartFacesOffsetInit ( svxFcsOffsetData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartFacesOffset().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data faces offset data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFilletBlend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFilletBlend()

evxErrors cvxPartFilletBlend | ( | const svxFilletBlendData * | FilletBlend,
 |  | int * | idFilletBlend
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use this function to create an intelligent blend face.

Note
Interface cvxPartFilletBlendInit() can initialize variables of this function.
Parameters
[in] | FilletBlend | filletBlend input data
[out] | idFilletBlend | id of FilletBlend feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFilletBlendInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartFilletBlendInit()

evxErrors cvxPartFilletBlendInit ( svxFilletBlendData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartFilletBlend().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data freeForm filletBlend data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartModifyIsolineNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartModifyIsolineNum()

evxErrors cvxPartModifyIsolineNum | ( | int | count,
 |  | int * | idFaces,
 |  | int | Uisoline,
 |  | int | Visoline
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to modify the number of iso-lines of the specified faces.

Parameters
[in] | count | number of faces
[in] | idFaces | list of face ids
[in] | Uisoline | number of iso-lines displayed in the U directions
[in] | Visoline | number of iso-lines displayed in the V directions
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartNSided

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartNSided()

evxErrors cvxPartNSided | ( | const svxNSidedData * | NSidedData,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_freeform.h>

This API is to do the N-sided function for entities. The id of entity newly created is output by idShape.

Note
Interface cvxPartNSidedInit() can initialize variables of this function.
Parameters
[in] | NSidedData | input boundary
[out] | idShape | id of new shape(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartNSidedInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartNSidedInit()

evxErrors cvxPartNSidedInit ( svxNSidedData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartNSided().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command N-sided data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRuled

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartRuled()

evxErrors cvxPartRuled | ( | const svxRuledData * | data,
 |  | int * | idFace
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to create a ruled face with linear cross-sections between two path curves.

Note
Interface cvxPartRuledInit() can initialize variables of this function.
Parameters
[in] | data | ruled data to create a new ruled face
[out] | idFace | index of new face (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRuledInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartRuledInit()

evxErrors cvxPartRuledInit ( svxRuledData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartRuled().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data ruled data to create a new ruled face
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSetFaceDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartSetFaceDir()

evxErrors cvxPartSetFaceDir | ( | int | count,
 |  | int * | idFaces,
 |  | const svxVector * | dir
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to orient the view direction of selected faces.

Parameters
[in] | count | count of faces (0 to orient all faces)
[in] | idFaces | list of face ids (NULL to orient all faces)
[in] | dir | direction of faces (NULL to use the positive z-axis)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSewForce

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartSewForce()

evxErrors cvxPartSewForce ( double Tol )

#include <zwapi_cmd_freeform.h>

Matches and sews free edges in the active part using the input proximity tolerance. If "Tol" is input as 0.0, the active part's default proximity tolerance is used. Unlike cvxPartSew(), this function attempts to "force" open edges to sew to adjacent edges that are "close" but not within tolerance.

See also
cvxPartFacesetSew() The difference between cvxPartSewForce and cvxPartFacesetSew is this function doesn't need to input the shapes and set "force object to sew into solid" to 1.
Parameters
[in] Tol 3D proximity tolerance (mm) (0.0 for default)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSplitWithCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartSplitWithCrv()

evxErrors cvxPartSplitWithCrv | ( | const svxSplitWithCrvData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use the function to split a face or shape at a curve or set of curves. If the curves intersect each other, the spurs are reflected in the resulting faces. If you split one face, a shape will be the result. Splitting one shape will result in the same shape having additional faces.

Note
Interface cvxPartSplitWithCrvInit() can initialize variables of this function.
Parameters
[in] | data | split faces with curves data
[out] | idFtr | id of new feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSplitWithCrvInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartSplitWithCrvInit()

evxErrors cvxPartSplitWithCrvInit ( svxSplitWithCrvData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartSplitWithCrv().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data split faces with curves data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimmedPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartTrimmedPlane()

evxErrors cvxPartTrimmedPlane | ( | svxTrimPlnData * | data,
 |  | int * | newShp
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use this command to create a planar face trimmed to a set of bounding curves. Required inputs include the boundary curves to trim to. Optional inputs include a datum plane or planar face to project to.

This function can output the new surface if data->sew is 0 and *newShp is not null.

Note
Interface cvxPartTrimmedPlaneInit() can initialize variables of this function.
Parameters
[in] | data | input data
[out] | newShp | id of new shape(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimmedPlaneInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartTrimmedPlaneInit()

evxErrors cvxPartTrimmedPlaneInit ( svxTrimPlnData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartTrimmedPlane().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Trimmed Plane data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimToCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartTrimToCrvs()

evxErrors cvxPartTrimToCrvs | ( | const svxTrimToCurvesData * | trimData,
 |  | int * | idTrim
 | ) |  |

#include <zwapi_cmd_freeform.h>

Use this function to trim a face or shape to a curve or set of curves.

Parameters
[in] | trimData | trim to curves data
[out] | idTrim | trim feature id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimToFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartTrimToFaces()

evxErrors cvxPartTrimToFaces | ( | const svxTrimToFacesData * | data,
 |  | int * | idTrim
 | ) |  |

#include <zwapi_cmd_freeform.h>

Trim away part of a face or shape where it intersects with Trimming.

Note
Interface cvxPartTrimToFacesInit() can initialize variables of this function.
Parameters
[in] | data | trimtofaces_data definition
[out] | idTrim | trim id (NULL to ignore )
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimToFacesInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ cvxPartTrimToFacesInit()

evxErrors cvxPartTrimToFacesInit ( svxTrimToFacesData * data )

#include <zwapi_cmd_freeform.h>

Initialize the parameters of the cvxPartTrimToFaces().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data data of trim to faces
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Free Form Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Free Form Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Free Form Command functions.

Basic Face

enum | evxSpineType { VX_SPINE_NATURAL = 0 , VX_SPINE_SPINE = 1 , VX_SPINE_PARALLEL = 2 }
spine type More...
enum | evxCroSecType { VX_CRO_SEC_CIRCULAR = 0 , VX_CRO_SEC_CONIC = 1 , VX_CRO_SEC_G2BLEND = 2 , VX_CRO_SEC_G3BLEND = 3 }
cross-section type More...
enum | evxSewingType { VX_SEWING_NOACTION = 0 , VX_SEWING_DIVIDE = 1 , VX_SEWING_TRIM = 2 , VX_SEWING_SEW = 3 }
sewing type More...
enum | evxCappingType { VX_CAPPING_MAXIMAL = 0 , VX_CAPPING_MINIMAL = 1 , VX_CAPPING_TANGENT = 2 }
capping type More...
enum | evxRefitOpt { VX_REFIT_NO = 0 , VX_REFIT_TANGENT = 1 , VX_REFIT_CURVATURE = 2 , VX_REFIT_DIRECT = 3 }
N-SIDED. More...
enum | evxCircularBiRailMethod { VX_CIRCULARBIRAIL_CONSTANT = 0 , VX_CIRCULARBIRAIL_VARIABLE , VX_CIRCULARBIRAIL_CENTER , VX_CIRCULARBIRAIL_MIDDLE }
circular bi rail method More...
enum evxConicBiRailMethod {
VX_CONICBIRAIL_CONSTANT = 0 , VX_CONICBIRAIL_VARIABLE , VX_CONICBIRAIL_HOLDER , VX_CONICBIRAIL_TANGENT ,
VX_CONICBIRAIL_INTERSECTION , VX_CONICBIRAIL_CENTER , VX_CONICBIRAIL_TANGENTEDGES
}
conic bi rail method More...
typedef enum evxSpineType | evxSpineType
spine type
typedef enum evxCroSecType | evxCroSecType
cross-section type
typedef enum evxSewingType | evxSewingType
sewing type
typedef enum evxCappingType | evxCappingType
capping type
typedef struct svxFilletBlendData | svxFilletBlendData
freeForm filletBlend data
typedef enum evxRefitOpt | evxRefitOpt
N-SIDED.
typedef struct svxNSidedData | svxNSidedData
template command N-sided data
typedef struct svxTrimPlnData | svxTrimPlnData
template command Trimmed Plane data
typedef struct svxRuledData | svxRuledData
ruled data
typedef enum evxCircularBiRailMethod | evxCircularBiRailMethod
circular bi rail method
typedef struct svxRadiusSetData | svxRadiusSetData
radius set data
typedef struct svxCircularBiRailData | svxCircularBiRailData
circular bi rail data
typedef enum evxConicBiRailMethod | evxConicBiRailMethod
conic bi rail method
typedef struct svxConicBiRailData | svxConicBiRailData
conic bi rail data

Edit Face

enum | evxTrimCrvsProjtype { VX_TRIMCRV_IN_PLACE , VX_TRIMCRV_FACE_NORMAL , VX_TRIMCRV_DIRECTED , VX_TRIMCRV_BI_DIRECTIONAL }
projection types of "trim to curves" More...
enum | evxFaceExtType { VX_FACE_EXT_LINEAR = 0 , VX_FACE_EXT_REFLECT , VX_FACE_EXT_CIRCULAR , VX_FACE_EXT_CURVATURE_DIMINISHING = 4 }
face extension type More...
enum | evxExtendShapeMethod { VX_EXTEND_OPEN_SHAPE = 0 , VX_EXTEND_GENERAL_SHAPE = 1 }
extend shape type More...
enum | evxEdgeExtensionType { VX_EDGE_EXTENSION_TANGENT = 0 , VX_EDGE_EXTENSION_ORTHOGONAL }
edge extension type More...
enum | evxExtendFaceMethod { VX_EXTEND_FACE_NONE = 0 , VX_EXTEND_FACE_CLOSE_ENTIRE_GAP , VX_EXTEND_FACE_DIRECT_EDIT }
extend face method More...
typedef struct svxFcsOffsetData | svxFcsOffsetData
faces offset data
typedef struct svxExtendData | svxExtendData
template command Extend Face data
typedef struct svxTrimToFacesData | svxTrimToFacesData
trim to faces
typedef enum evxTrimCrvsProjtype | evxTrimCrvsProjtype
projection types of "trim to curves"
typedef struct svxTrimToCurvesData | svxTrimToCurvesData
template command Trim to Curves input data
typedef struct svxExplodeData | svxExplodeData
data of explode command
typedef struct svxSewData | svxSewData
faces sew data
typedef enum evxFaceExtType | evxFaceExtType
face extension type
typedef struct svxEnlargeFaceData | svxEnlargeFaceData
enlarge face data
typedef enum evxExtendShapeMethod | evxExtendShapeMethod
extend shape type
typedef enum evxEdgeExtensionType | evxEdgeExtensionType
edge extension type
typedef enum evxExtendFaceMethod | evxExtendFaceMethod
extend face method
typedef struct svxExtendShapeData | svxExtendShapeData
extend shape data
typedef struct svxSplitWithCrvData | svxSplitWithCrvData
split with curve data
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: PMI Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
PMI Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D PMI Commands API

Dimension

evxErrors | cvxPartAddLineDim (int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddSymmetryDim (svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddAngleDim (int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddRadDim (int idEnt, int radType, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddChamferDim (int idEnt1, int idEnt2, const svxPoint *TextPos, int idPlane, int *idDim)
evxErrors | cvxPartAddArcDim (int idEnt, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)

Annotation

evxErrors | cvxPartAddCoorDim (svxPoint *LeaderPnt, int idParent, const svxPoint *TextPnt, int idDatum, int idPlane, int *idDim)
evxErrors | cvxPartAddLabelDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddDatumDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddDatumTargetDim (int idEnt, int radRype, double diameter, double width, double height, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddFcsDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddSymSrfDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, svxRoughTexts *textGrp, int idPlane, int *idDim)
evxErrors | cvxPartAddCenLinDim (int idEnt, int idPlane, int *idDim)
evxErrors | cvxPartAddCenMarkDim (int idEnt, int idPlane, int *idDim)

Text

evxErrors | cvxPartAddPMIText (svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddBalloon (svxPoint *TextPnt, char *text, int fImage, int idPlane, int *idDim)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddAngleDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddAngleDim()

evxErrors cvxPartAddAngleDim | ( | int | idEnt1,
 |  | int | idEnt2,
 |  | const svxPoint * | TextPnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI angle dimension between the specified two entities in part. Supported entities include two points, a point and a line,two parallel lines, two parallel faces.

Parameters
[in] | idEnt1 | id of the first entity
[in] | idEnt2 | id of the second entity
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddArcDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddArcDim()

evxErrors cvxPartAddArcDim | ( | int | idEnt,
 |  | const char * | text,
 |  | const svxPoint * | TextPnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI arc dimension between the specified entity in part. Supported entities include circle or face.

Parameters
[in] | idEnt | id of the first entity
[in] | text | input user text (NULL to ignore)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddBalloon

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddBalloon()

evxErrors cvxPartAddBalloon | ( | svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | fImage,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI balloon annotation in part.

Parameters
[in] | TextPnt | point coordinate of text placement point
[in] | text | balloon string
[in] | fImage | image flag: 1-image, 0-text
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddCenLinDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddCenLinDim()

evxErrors cvxPartAddCenLinDim | ( | int | idEnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI center line dimension of the specified entity in part. Supported entity is face.

Parameters
[in] | idEnt | id of the first entity
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddCenMarkDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddCenMarkDim()

evxErrors cvxPartAddCenMarkDim | ( | int | idEnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI center mark dimension of the specified entity in part. Supported entity is arc, circle, face.

Parameters
[in] | idEnt | id of the first entity
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddChamferDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddChamferDim()

evxErrors cvxPartAddChamferDim | ( | int | idEnt1,
 |  | int | idEnt2,
 |  | const svxPoint * | TextPos,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI chamfer dimension between the specified two entities in part. Supported entities include two points, a point and a line,two parallel lines, two parallel faces.

Parameters
[in] | idEnt1 | id of the first entity
[in] | idEnt2 | id of the second entity
[in] | TextPos | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddCoorDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddCoorDim()

evxErrors cvxPartAddCoorDim | ( | svxPoint * | LeaderPnt,
 |  | int | idParent,
 |  | const svxPoint * | TextPnt,
 |  | int | idDatum,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI coordinate dimension to specifies leader point.

Parameters
[in] | LeaderPnt | point coordinate of leader point, if idParent is a point, LeaderPnt set to NULL
[in] | idParent | id of the parent entity of the leader point, if no parent entity, idParent is equal to 0
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idDatum | Specifies a datum plane to define a local coordinate frame. 0 to use default datum
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use current view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddDatumDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddDatumDim()

evxErrors cvxPartAddDatumDim | ( | int | idEnt,
 |  | svxPoint * | leadPnt,
 |  | const svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI datum feature dimension for the specified entity in part. Supported entities include edge and face.

Parameters
[in] | idEnt | id of the first entity
[in] | leadPnt | point coordinate of text placement point (NULL to use critical point)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | text | datum label name
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddDatumTargetDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddDatumTargetDim()

evxErrors cvxPartAddDatumTargetDim | ( | int | idEnt,
 |  | int | radRype,
 |  | double | diameter,
 |  | double | width,
 |  | double | height,
 |  | svxPoint * | leadPnt,
 |  | const svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI datum target dimension for the specified entity in part. Supported entities include edge and face.

Parameters
[in] | idEnt | id of the first entity
[in] | radRype | type of DatumT dimension
[in] | diameter | diameter
[in] | width | width
[in] | height | height
[in] | leadPnt | point coordinate of text placement point (NULL to use critical point)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | text | datum label name
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddFcsDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddFcsDim()

evxErrors cvxPartAddFcsDim | ( | int | idEnt,
 |  | svxPoint * | leadPnt,
 |  | const svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI datum feature dimension for the specified entity in part. Supported entities include edge and face.

Parameters
[in] | idEnt | id of the first entity
[in] | leadPnt | point coordinate of text placement point (NULL to use critical point)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | text | datum label name
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddLabelDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddLabelDim()

evxErrors cvxPartAddLabelDim | ( | int | idEnt,
 |  | svxPoint * | leadPnt,
 |  | const svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI label dimension for the specified entity which includes edge, curve, face or datum plane. If leadPnt doesn't on entity, it will be projected into the entity. If leadPnt is null, it will be set to a point on entity. Set idEnt to -1 when there is no entity.

Parameters
[in] | idEnt | id of the entity where the leader point is located (0 to ignore)
[in] | leadPnt | leader point (NULL to use default point on entity or ignore)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | text | datum label name
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddLineDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddLineDim()

evxErrors cvxPartAddLineDim | ( | int | idEnt1,
 |  | int | idEnt2,
 |  | const svxPoint * | TextPnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI linear dimension between the specified two entities in part. Supported entities include two points, a point and a line,two parallel lines, two parallel faces.

Parameters
[in] | idEnt1 | id of the first entity
[in] | idEnt2 | id of the second entity
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddPMIText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddPMIText()

evxErrors cvxPartAddPMIText | ( | svxPoint * | TextPnt,
 |  | char * | text,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI text annotation in part.

Parameters
[in] | TextPnt | point coordinate of text placement point
[in] | text | datum label name
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddRadDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddRadDim()

evxErrors cvxPartAddRadDim | ( | int | idEnt,
 |  | int | radType,
 |  | const char * | text,
 |  | const svxPoint * | TextPnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI radius dimension between the specified entity in part. Supported entities include circle or face.

Parameters
[in] | idEnt | id of the first entity
[in] | radType | radial or diametric dim type, please refer to evxRadDimType
[in] | text | input user text (NULL to ignore)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddSymmetryDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddSymmetryDim()

evxErrors cvxPartAddSymmetryDim | ( | svxPntOnEnt | iEntId,
 |  | svxPntOnEnt | iCenterLineId,
 |  | svxPntOnEnt | TextPnt,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a symmetric annotation based on entity and a center line. Supported entities include two points, a point and a line,two parallel lines, two parallel faces.

Parameters
[in] | iEntId | id of the entity
[in] | iCenterLineId | id of the entity Center Line
[in] | TextPnt | point coordinate of text placement point
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartAddSymSrfDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • PMI Commands
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ cvxPartAddSymSrfDim()

evxErrors cvxPartAddSymSrfDim | ( | int | idEnt,
 |  | svxPoint * | leadPnt,
 |  | const svxPoint * | TextPnt,
 |  | svxRoughTexts * | textGrp,
 |  | int | idPlane,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_pmi.h>

Create a PMI surface finish dimension for the specified entity in part. Supported entities include edge and face.

Parameters
[in] | idEnt | id of the first entity
[in] | leadPnt | point coordinate of text placement point (NULL to use critical point)
[in] | TextPnt | point coordinate of text placement point (NULL to ignore, automatic calculation)
[in] | textGrp | Roughness PMI text define
[in] | idPlane | id of insertion plane (datum or planar face), 0 to use default view plane
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\pmiCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: PMI Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
PMI Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the PMI Command functions.

Annotation Data

typedef struct svxRoughTexts svxRoughTexts
Roughness PMI text define.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Shape Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Shape Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Shape Commands of Part API

Basic Shape

evxErrors | cvxPartBoxInit (svxBoxData *data)
evxErrors | cvxPartBox (svxBoxData *Box, int *idShape)
evxErrors | cvxPartCylInit (svxCylData *data)
evxErrors | cvxPartCyl (svxCylData *Cyl, int *idShape)
evxErrors | cvxPartConeInit (svxConeData *data)
evxErrors | cvxPartCone (svxConeData *Cone, int *idShape)
evxErrors | cvxPartSphereInit (svxSphereData *data)
evxErrors | cvxPartSphere (svxSphereData *Sphere, int *idShape)
evxErrors | cvxPartEllipsoidInit (svxEllsoData *data)
evxErrors | cvxPartEllipsoid (svxEllsoData *Ellso, int *idShape)
evxErrors | cvxPartExtrudeInit (svxExtrudeData *data)
evxErrors | cvxPartExtrude (svxExtrudeData *Ext, int *idShape)
evxErrors | cvxPartRevolveInit (svxRevolveData *data)
evxErrors | cvxPartRevolve (svxRevolveData *Rev, int *idShape)
evxErrors | cvxPartSweepInit (svxSweepData *data)
evxErrors | cvxPartSweep (svxSweepData *Swp, void *Options, int *idShape)
evxErrors | cvxPartSpiralSweepInit (svxSpiralSweepData *data)
evxErrors | cvxPartSpiralSweep (const svxSpiralSweepData *SpiralSwp, int *idShape)
evxErrors | cvxPartLoftInit (svxLoftData *data)
evxErrors | cvxPartLoft (svxLoftData *Loft, int *idShape)

Engineering Feature

evxErrors | cvxPartFillet (int Count, int *Edges, double Radius)
evxErrors | cvxPartFilletAllInit (svxChamFlltData *data)
evxErrors | cvxPartFilletAll (const svxChamFlltData *Fillet, int *idFillet)
evxErrors | cvxPartFaceFilletInit (svxFaceFlltData *data)
evxErrors | cvxPartFaceFillet (const svxFaceFlltData *data, int *idFillet)
evxErrors | cvxPartChamConst (int Count, int *Edges, double Setback)
evxErrors | cvxPartChamAng (int Count, int *Edges, int idFace, double Setback, double Angle)
evxErrors | cvxPartChamAsym (int Count, int *Edges, int idFace, double Setback1, double Setback2)
evxErrors | cvxChamFlltSetDataInit (svxChamFlltSetData *data)
evxErrors | cvxPartChamferAllInit (svxChamFlltData *data)
evxErrors | cvxPartChamferAll (const svxChamFlltData *Chamfer, int *idChamfer)
evxErrors | cvxPartDraftInit (evxDraftMethods method, svxDraftData *data)
evxErrors | cvxPartDraft (const svxDraftData *Draft, int *idDraft)
evxErrors | cvxPartHoleInit (evxHoleOpt HoleOpt, int type, svxHoleData *data)
evxErrors | cvxPartHole (svxHoleData *Data, int *idOp)
evxErrors | cvxPartModifyHoleInit (int idFace, svxHoleData *data)
evxErrors | cvxPartModifyHole (int cntFace, int *pFace, const svxHoleData *data, int *idFtr)
evxErrors | cvxPartFlagHolesInit (svxFlagHoleData *data)
evxErrors | cvxPartFlagHoles (const svxFlagHoleData *data, int *idFtr)
evxErrors | cvxPartRibInit (svxRibData *data)
evxErrors | cvxPartRib (svxRibData *Rib, int *idRib)
evxErrors | cvxPartFlagExtThreadInit (svxFlagExtThreadData *data)
evxErrors | cvxPartFlagExtThread (const svxFlagExtThreadData *data, int *idFtr)
evxErrors | cvxPartThreadAtInit (svxThreadData *data)
evxErrors | cvxPartThreadAt (int idFace, svxPoint *Pnt, svxThreadData *Thread)
evxErrors | cvxPartLipInit (svxLipData *data)
evxErrors | cvxPartLip (svxLipData *Lip, int *idLip)
evxErrors | cvxPartStockInit (svxStockData *data)
evxErrors | cvxPartStock (svxStockData *Stock, int *idShape)

Edit Shape

evxErrors | cvxPartFaceOffset (int idFace, double Dis, int Keep)
evxErrors | cvxPartShapeFaceOffsetInit (svxFaceOffData *data)
evxErrors | cvxPartShapeFaceOffset (svxFaceOffData *Offset, int *idOffset)
evxErrors | cvxPartShellInit (svxShellData *data)
evxErrors | cvxPartShell (const svxShellData *Shell, int *idShell)
evxErrors | cvxPartThickenInit (svxThickenData *data)
evxErrors | cvxPartThicken (svxThickenData *Thicken, int *idShape)
evxErrors | cvxPartBool (evxBoolType Type, int idBase, int Count, int *Shapes, int Keep)
evxErrors | cvxPartBool2 (evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int *ResultCount, int **ResultList)
evxErrors | cvxPartBool3 (evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int FaceCount, int *FaceList, int *ResultCount, int **ResultList)
evxErrors | cvxPartDivideInit (svxDivideData *data)
evxErrors | cvxPartDivide (svxDivideData *Divide, int *numShape, int **idShapes)
evxErrors | cvxPartTrimInit (svxTrimData *data)
evxErrors | cvxPartTrim (svxTrimData *Trim, int *numShape, int **idShapes)
evxErrors | cvxPartSimplify (int numEnts, int *idEnts, int *idSimplify)
evxErrors | cvxPartReplaceInit (svxReplaceData *data)
evxErrors | cvxPartReplace (const svxReplaceData *Replace, int *idReplace)
evxErrors | cvxPartInlayInit (svxInlayData *data)
evxErrors | cvxPartInlay (svxInlayData *Inlay, int *idInlay)
evxErrors | cvxPartSelfXInit (svxPartSelfX *data)
evxErrors | cvxPartSelfX (const svxPartSelfX *data, int *idShape)
evxErrors | cvxPartPunchInit (svxPunch *data)
evxErrors | cvxPartPunch (const svxPunch *data, int *idPunch)

Morph

evxErrors | cvxPartTwistInit (svxTwistData *data)
evxErrors | cvxPartTwist (const svxTwistData *Twist, int *idTwist)
evxErrors | cvxPartTaperInit (svxTaperData *data)
evxErrors | cvxPartTaper (const svxTaperData *Taper, int *idTaper)
evxErrors | cvxPartStretchInit (svxStretchData *data)
evxErrors | cvxPartStretch (const svxStretchData *Stretch, int *idStretch)
evxErrors | cvxPartMorphToCrvInit (svxMorphToCrvData *data)
evxErrors | cvxPartMorphToCrv (const svxMorphToCrvData *MorphToCrv, int *idMorphToCrv)

Basic Editing

evxErrors | cvxPtnDataInit (evxPatternType type, svxPtnData *data)
evxErrors | cvxPartPatternGeom (int Count, int *idEnts, const svxPtnGeom *Pattern, int *idPattern)
evxErrors | cvxPtnVarTblInit (int firstNum, int secondNum, const char *dimName, svxPtnVarTbl *ptnVarTbl)
evxErrors | cvxPartPatternFtr (int Count, int *idFtrs, const svxPtnFtr *Pattern, int *idPattern)
evxErrors | cvxPartMirrorGeominit (svxMirrorGeom *data)
evxErrors | cvxPartMirrorGeom (svxMirrorGeom *Mirror, int *NumNewEnts, int **idNewEnts)
evxErrors | cvxPartMirrorFtrInit (svxMirrorFtr *data)
evxErrors | cvxPartMirrorFtr (svxMirrorFtr *Mirror, int *idFtr)
evxErrors | cvxPartMovePntToPnt (int idEntity, svxAxis *Start, svxAxis *End)
evxErrors | cvxPartMoveTransform (int idEntity, const svxMatrix *Mat)
evxErrors | cvxPartMoveTransformList (int Count, const int *Entities, const svxMatrix *Mat)
evxErrors | cvxPartMove (const svxMoveData *Move, int *idMove)
evxErrors | cvxPartCopyDirDis (int idEntity, svxVector *Dir, double Dis, int *idCopy)
evxErrors | cvxPartCopyPntToPnt (int idEntity, svxAxis *Start, svxAxis *End, int *idCopy)
evxErrors | cvxPartCopyTransform (int idEntity, const svxMatrix *Mat, int *idCopy)
evxErrors | cvxPartCopyTransformList (const int Count, const int *Entities, const svxMatrix *Mat, int *EntCnt, int **idList)
evxErrors | cvxPartCopyInit (svxCopyData *data)
evxErrors | cvxPartCopy (const svxCopyData *Copy, int *idCopy)
evxErrors | cvxPartScale (int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum)
evxErrors | cvxPartScale2 (int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum, svxPoint *CentPnt)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxChamFlltSetDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxChamFlltSetDataInit()

evxErrors cvxChamFlltSetDataInit ( svxChamFlltSetData * data )

#include <zwapi_cmd_shape.h>

Initialize the svxChamFlltSetData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data set-list data for chamfer or fillet command
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartBool()

evxErrors cvxPartBool | ( | evxBoolType | Type,
 |  | int | idBase,
 |  | int | Count,
 |  | int * | Shapes,
 |  | int | Keep
 | ) |  |

#include <zwapi_cmd_shape.h>

Combines one or more shapes with a base shape using a boolean operation.

Parameters
[in] | Type | boolean combination method
[in] | idBase | id of base shape
[in] | Count | no. of shapes to combine with "idBase"
[in] | Shapes | list of id's of shapes to combine with "idBase"
[in] | Keep | 1 to keep "Shapes"; 0 to delete them
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBool2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartBool2()

evxErrors cvxPartBool2 | ( | evxBoolType | Type,
 |  | int | BaseCount,
 |  | int * | BaseList,
 |  | int | OpCount,
 |  | int * | OpList,
 |  | int * | ResultCount,
 |  | int ** | ResultList
 | ) |  |

#include <zwapi_cmd_shape.h>

Combines one or more operator shapes with one or more base shapes using the specified boolean combination method. The resulting shape(s) are output via "ResultList".

The memory referenced by "ResultList" is allocated by this function. The calling procedure is responsible to free the memory referenced by "ResultList" (cvxMemFree((void**)ResultList)).

If you do not need the list of output shapes, input NULL for "ResultCount" and "ResultList" and no list of results will be output by this function.

Parameters
[in] | Type | boolean combination method
[in] | BaseCount | number of base shapes
[in] | BaseList | list of base shape id's
[in] | OpCount | number of operator shapes
[in] | OpList | list of operator shape id's
[out] | ResultCount | number of resulting shapes (NULL to ignore)
[out] | ResultList | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OBJ_TYPE_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBool3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartBool3()

evxErrors cvxPartBool3 | ( | evxBoolType | Type,
 |  | int | BaseCount,
 |  | int * | BaseList,
 |  | int | OpCount,
 |  | int * | OpList,
 |  | int | FaceCount,
 |  | int * | FaceList,
 |  | int * | ResultCount,
 |  | int ** | ResultList
 | ) |  |

#include <zwapi_cmd_shape.h>

Combines one or more operator shapes with one or more base shapes using the specified boolean combination method. If bounding faces are defined (FaceCount and FaceList), an attempt is made to limit the resulting shapes to the regions between the bounding faces.

The resulting shape(s) are output via "ResultList". The memory referenced by "ResultList" is allocated by this function.

The calling procedure is responsible to free the memory referenced by "ResultList" (cvxMemFree((void**)ResultList)).

If you do not need the list of output shapes, input NULL for "ResultCount" and "ResultList" and no list of results will be output by this function.

Parameters
[in] | Type | boolean combination method
[in] | BaseCount | number of base shapes
[in] | BaseList | list of base shape id's
[in] | OpCount | number of operator shapes
[in] | OpList | list of operator shape id's
[in] | FaceCount | number of bounding faces (0 if undefined)
[in] | FaceList | list of bounding faces (NULL if undefined)
[out] | ResultCount | number of resulting shapes (NULL to ignore)
[out] | ResultList | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INVALID_OBJ
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartBox()

evxErrors cvxPartBox | ( | svxBoxData * | Box,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a box shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Box->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape".

Note
Interface cvxPartBoxInit() can initialize variables of this function.
This command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Box | box definition
[out] | idShape | id of new shape
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBoxInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartBoxInit()

evxErrors cvxPartBoxInit ( svxBoxData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartBox().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data box data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartChamAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartChamAng()

evxErrors cvxPartChamAng | ( | int | Count,
 |  | int * | Edges,
 |  | int | idFace,
 |  | double | Setback,
 |  | double | Angle
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds chamfers to the specified edges.

Parameters
[in] | Count | number of edges to chamfer
[in] | Edges | pointer to list of edge id's
[in] | idFace | id of face on first side of chamfer
[in] | Setback | setback (mm) on first side of chamfer
[in] | Angle | angle of chamfer (deg)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartChamAsym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartChamAsym()

evxErrors cvxPartChamAsym | ( | int | Count,
 |  | int * | Edges,
 |  | int | idFace,
 |  | double | Setback1,
 |  | double | Setback2
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds chamfers to the specified edges.

Parameters
[in] | Count | number of edges to chamfer
[in] | Edges | pointer to list of edge id's
[in] | idFace | id of face on first side of chamfer
[in] | Setback1 | setback (mm) on first side of chamfer
[in] | Setback2 | setback (mm) on second side of chamfer
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartChamConst

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartChamConst()

evxErrors cvxPartChamConst | ( | int | Count,
 |  | int * | Edges,
 |  | double | Setback
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds chamfers to the specified edges.

Parameters
[in] | Count | number of edges to chamfer
[in] | Edges | pointer to list of edge id's
[in] | Setback | setback (mm)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartChamferAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartChamferAll()

evxErrors cvxPartChamferAll | ( | const svxChamFlltData * | Chamfer,
 |  | int * | idChamfer
 | ) |  |

#include <zwapi_cmd_shape.h>

Use the function to create symmetric and asymmetric chamfers.

Note
Interface cvxPartChamferAllInit() can initialize variables of this function.
Parameters
[in] | Chamfer | chamfer data
[out] | idChamfer | index of new chamfer feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartChamferAllInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartChamferAllInit()

evxErrors cvxPartChamferAllInit ( svxChamFlltData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartChamferAll().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data chamfer data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCone

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCone()

evxErrors cvxPartCone | ( | svxConeData * | Cone,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a cone shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Cone->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape".

Note
Interface cvxPartConeInit() can initialize variables of this function.
This command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Cone | cone definition
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartConeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartConeInit()

evxErrors cvxPartConeInit ( svxConeData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartCone().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data cone data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopy()

evxErrors cvxPartCopy | ( | const svxCopyData * | Copy,
 |  | int * | idCopy
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds the specified Copy(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idCopy" if the output is not required.

Note
Interface cvxPartCopyInit() can initialize variables of this function.
Parameters
[in] | Copy | Copy data
[out] | idCopy | Copy feature id (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopyDirDis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopyDirDis()

evxErrors cvxPartCopyDirDis | ( | int | idEntity,
 |  | svxVector * | Dir,
 |  | double | Dis,
 |  | int * | idCopy
 | ) |  |

#include <zwapi_cmd_shape.h>

Copies the specified geometry within the active part along specified direction "Dir" with distance "Dis". If "idCopy" is not NULL, the id of the new copy is output.

Parameters
[in] | idEntity | id of geometry entity to copy
[in] | Dir | direction
[in] | Dis | distance
[out] | idCopy | id of copied entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopyInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopyInit()

evxErrors cvxPartCopyInit ( svxCopyData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartCopy().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Copy data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopyPntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopyPntToPnt()

evxErrors cvxPartCopyPntToPnt | ( | int | idEntity,
 |  | svxAxis * | Start,
 |  | svxAxis * | End,
 |  | int * | idCopy
 | ) |  |

#include <zwapi_cmd_shape.h>

Copies the specified geometry within the active part from one point "Start->Pnt" to another "End->Pnt". It also changes the orientation of the part based on "Start->Dir" and "End->Dir". If the directions are same, the orientation of the geometry is not changed – it is simply translated. If "idCopy" is not NULL, the id of the new copy is output.

Parameters
[in] | idEntity | id of geometry entity to copy
[in] | Start | start point and direction
[in] | End | end point and direction
[out] | idCopy | id of copied entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopyTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopyTransform()

evxErrors cvxPartCopyTransform | ( | int | idEntity,
 |  | const svxMatrix * | Mat,
 |  | int * | idCopy
 | ) |  |

#include <zwapi_cmd_shape.h>

Copies the specified geometry entity and applies the specified general transformation to the copy, moving the copy within the active part. If "idCopy" is not NULL, the id of the new copy is output.

If "Mat" includes scaling, the scale factors are ignored.

Parameters
[in] | idEntity | id of geometry entity to copy
[in] | Mat | transformation matrix
[out] | idCopy | id of new entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCopyTransformList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCopyTransformList()

evxErrors cvxPartCopyTransformList | ( | const int | Count,
 |  | const int * | Entities,
 |  | const svxMatrix * | Mat,
 |  | int * | EntCnt,
 |  | int ** | idList
 | ) |  |

#include <zwapi_cmd_shape.h>

Copies the specified geometry entities and applies the specified general transformation to the copy, moving the copy within the active part.The calling procedure MUST deallocate the output list with cvxMemFree().

If "Mat" includes scaling, the scale factors are ignored.

Parameters
[in] | Count | number of entities to transform
[in] | Entities | list of geometry entity ids
[in] | Mat | transformation matrix
[out] | EntCnt | number of new entities (NULL to ignore)
[out] | idList | id of new entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCyl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCyl()

evxErrors cvxPartCyl | ( | svxCylData * | Cyl,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a cylinder shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Cyl->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape".

Note
Interface cvxPartCylInit() can initialize variables of this function.
This command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Cyl | cylinder definition
[out] | idShape | id of new shape(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCylInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartCylInit()

evxErrors cvxPartCylInit ( svxCylData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartCyl().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data cylinder data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDivide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartDivide()

evxErrors cvxPartDivide | ( | svxDivideData * | Divide,
 |  | int * | numShape,
 |  | int ** | idShapes
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to divide a solid or open shape where it intersects with faces, shapes, or datum planes.
The result will be two distinct solids or shapes.
This function can also divide an open shape or result in one or more open shapes.

Note
Interface cvxPartDivideInit() can initialize variables of this function.
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | Divide | divide input data
[out] | numShape | number of resulting shapes (NULL to ignore)
[out] | idShapes | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDivideInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartDivideInit()

evxErrors cvxPartDivideInit ( svxDivideData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartDivide().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command divide data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDraft

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartDraft()

evxErrors cvxPartDraft | ( | const svxDraftData * | Draft,
 |  | int * | idDraft
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds the specified draft(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idDraft" if the output is not required.

Note
Interface cvxPartDraftInit() can initialize variables of this function.
Parameters
[in] | Draft | Draft Data
[out] | idDraft | id of feature operation that created Draft (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_OBJ
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartDraftInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartDraftInit()

evxErrors cvxPartDraftInit | ( | evxDraftMethods | method,
 |  | svxDraftData * | data
 | ) |  |

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartDraft().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | draft method
[out] | data | template command Draft data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEllipsoid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartEllipsoid()

evxErrors cvxPartEllipsoid | ( | svxEllsoData * | Ellso,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a ellipsoid shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Ellso->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape".

Note
Interface cvxPartEllipsoidInit() can initialize variables of this function.
This command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Ellso | ellipsoid definition
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEllipsoidInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartEllipsoidInit()

evxErrors cvxPartEllipsoidInit ( svxEllsoData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartEllipsoid().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data ellipsoid data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtrude

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartExtrude()

evxErrors cvxPartExtrude | ( | svxExtrudeData * | Ext,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates an extruded shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Ext->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape". If multiple shapes could be created, use cvxEntNewList() to get their id's.

Note
Interface cvxPartExtrudeInit() can initialize variables of this function.
cvxPartExtrude doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Ext | extrusion input data
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtrudeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartExtrudeInit()

evxErrors cvxPartExtrudeInit ( svxExtrudeData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartExtrude().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data extruded shape data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFaceFillet()

evxErrors cvxPartFaceFillet | ( | const svxFaceFlltData * | data,
 |  | int * | idFillet
 | ) |  |

#include <zwapi_cmd_shape.h>

Create fillet by the input faces and other variables.

Note
Interface cvxPartFaceFilletInit() can initialize variables of this function.
Parameters
[in] | data | face fillet data
[out] | idFillet | index of new fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceFilletInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFaceFilletInit()

evxErrors cvxPartFaceFilletInit ( svxFaceFlltData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartFaceFillet().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data face fillet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFaceOffset()

evxErrors cvxPartFaceOffset | ( | int | idFace,
 |  | double | Dis,
 |  | int | Keep
 | ) |  |

#include <zwapi_cmd_shape.h>

Offset a face with distance "Dis". Original surface will be deleted if "Keep=0".

Parameters
[in] | idFace | face id
[in] | Dis | offset distance
[in] | Keep | 1 to keep "Original surface"; 0 to delete it
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\freeFormFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFillet()

evxErrors cvxPartFillet | ( | int | Count,
 |  | int * | Edges,
 |  | double | Radius
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds fillets to the specified edges.

Use cvxPartPartialResults() to disable/enable the prompt to calculate/display partial results for failed fillets.

Parameters
[in] | Count | number of edges to fillet
[in] | Edges | pointer to list of edge id's
[in] | Radius | fillet radius
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFilletAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFilletAll()

evxErrors cvxPartFilletAll | ( | const svxChamFlltData * | Fillet,
 |  | int * | idFillet
 | ) |  |

#include <zwapi_cmd_shape.h>

Use the function to create symmetric and asymmetric fillets.

Note
Interface cvxPartFilletAllInit() can initialize variables of this function.
Parameters
[in] | Fillet | fillet data
[out] | idFillet | index of new fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFilletAllInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFilletAllInit()

evxErrors cvxPartFilletAllInit ( svxChamFlltData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartFilletAll().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data chamfer data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFlagExtThread

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFlagExtThread()

evxErrors cvxPartFlagExtThread | ( | const svxFlagExtThreadData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_shape.h>

Use the Flag Ext Thread command to assign hole attributes so drawing sheets will recognize these features as holes.but only visible in 3D.

Note
Interface cvxPartFlagExtThreadInit() can initialize variables of this function.
Parameters
[in] | data | flag ext thread data
[out] | idFtr | feature id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFlagExtThreadInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFlagExtThreadInit()

evxErrors cvxPartFlagExtThreadInit ( svxFlagExtThreadData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartFlagExtThread().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data flag ext thread data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFlagHoles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFlagHoles()

evxErrors cvxPartFlagHoles | ( | const svxFlagHoleData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_shape.h>

Use the Flag Hole command to assign hole attributes so drawing sheets will recognize these features as holes.

Note
Interface cvxPartFlagHolesInit() can initialize variables of this function.
Parameters
[in] | data | flag hole data
[out] | idFtr | feature id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFlagHolesInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartFlagHolesInit()

evxErrors cvxPartFlagHolesInit ( svxFlagHoleData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartFlagHoles().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data flag hole data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartHole()

evxErrors cvxPartHole | ( | svxHoleData * | Data,
 |  | int * | idOp
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds the specified hole(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idOp" if the output is not required.

Note
Interface cvxPartHoleInit() can initialize variables of this function.
Parameters
[in] | Data | hole data
[out] | idOp | id of feature operation that created hole
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartHoleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartHoleInit()

evxErrors cvxPartHoleInit | ( | evxHoleOpt | HoleOpt,
 |  | int | type,
 |  | svxHoleData * | data
 | ) |  |

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartHole().

HoleOpt = VX_CLEARANCE_HOLE,type use evxClearHoleType; else type use evxHoleType.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | HoleOpt | hole method
[in] | type | hole shape type(see description)
[out] | data | hole data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInlay

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartInlay()

evxErrors cvxPartInlay | ( | svxInlayData * | Inlay,
 |  | int * | idInlay
 | ) |  |

#include <zwapi_cmd_shape.h>

The function is used to embed a set of closed loops of curves, as it would be generated by an outline text font, into a face and then offset the new interior faces created by the desired distance, giving a raised or sunken text effect. it will create new faces, edges, vertices, etc., allowing for sharp transitions from the raised surfaces to the base surface.

Note
Interface cvxPartInlayInit() can initialize variables of this function.
Parameters
[in] | Inlay | inlay input data
[out] | idInlay | id of inlay feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInlayInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartInlayInit()

evxErrors cvxPartInlayInit ( svxInlayData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartInlay().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command inlay data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartLip()

evxErrors cvxPartLip | ( | svxLipData * | Lip,
 |  | int * | idLip
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to create a constant lip feature along selected edges based on two offset distances. The required inputs include the face edges to feature and the 1st and 2nd offsets.

Note
Interface cvxPartLipInit() can initialize variables of this function.
Parameters
[in] | Lip | lip input data
[out] | idLip | id of lip feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLipInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartLipInit()

evxErrors cvxPartLipInit ( svxLipData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartLip().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command lib data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLoft

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartLoft()

evxErrors cvxPartLoft | ( | svxLoftData * | Loft,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to create a loft feature.

Note
Interface cvxPartLoftInit() can initialize variables of this function.
cvxPartLoft doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Loft | loft input data
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLoftInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartLoftInit()

evxErrors cvxPartLoftInit ( svxLoftData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartLoft().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command loft data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMirrorFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMirrorFtr()

evxErrors cvxPartMirrorFtr | ( | svxMirrorFtr * | Mirror,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to mirror features.

Note
Interface cvxPartMirrorFtrInit() can initialize variables of this function.
Parameters
[in] | Mirror | mirror feature input data
[out] | idFtr | id of mirror feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMirrorFtrInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMirrorFtrInit()

evxErrors cvxPartMirrorFtrInit ( svxMirrorFtr * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartMirrorFtr().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data mirror feature data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMirrorGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMirrorGeom()

evxErrors cvxPartMirrorGeom | ( | svxMirrorGeom * | Mirror,
 |  | int * | NumNewEnts,
 |  | int ** | idNewEnts
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to mirror any combination of shapes, components, curves, points, sketches and datum planes.

The calling procedure MUST deallocate the output list with cvxMemFree().

Note
Interface cvxPartMirrorGeomInit() can initialize variables of this function.
Parameters
[in] | Mirror | mirror geometry input data
[out] | NumNewEnts | number of new entities (NULL to ignore)
[out] | idNewEnts | list of id's of new entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMirrorGeominit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMirrorGeominit()

evxErrors cvxPartMirrorGeominit ( svxMirrorGeom * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartMirrorGeom().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data mirror geometry data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartModifyHole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartModifyHole()

evxErrors cvxPartModifyHole | ( | int | cntFace,
 |  | int * | pFace,
 |  | const svxHoleData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_shape.h>

Modify the hole data of the input hole faces.

Note
Interface cvxPartModifyHoleInit() can initialize variables of this function.
Parameters
[in] | cntFace | count of the face to modify
[in] | pFace | face list
[in] | data | hole data
[out] | idFtr | index of the new feature(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartModifyHoleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartModifyHoleInit()

evxErrors cvxPartModifyHoleInit | ( | int | idFace,
 |  | svxHoleData * | data
 | ) |  |

#include <zwapi_cmd_shape.h>

Use the first input face to initialize the parameters of the cvxPartModifyHole(). It will get the hole data of the input face to initialize the data.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | idFace | id face of the specified hole
[out] | data | hole data to initialize
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMorphToCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMorphToCrv()

evxErrors cvxPartMorphToCrv | ( | const svxMorphToCrvData * | MorphToCrv,
 |  | int * | idMorphToCrv
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to transforms (morphs) shapes by warping face geometry.

Note
Interface cvxPartMorphToCrvInit() can initialize variables of this function.
Parameters
[in] | MorphToCrv | morph to curve input data
[out] | idMorphToCrv | id of morph to curve feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMorphToCrvInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMorphToCrvInit()

evxErrors cvxPartMorphToCrvInit ( svxMorphToCrvData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartMorphToCrv().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape morph to curve data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMove()

evxErrors cvxPartMove | ( | const svxMoveData * | Move,
 |  | int * | idMove
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds the specified Move(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idMove" if the output is not required.

Parameters
[in] | Move | Move data
[out] | idMove | Move feature id (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMovePntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMovePntToPnt()

evxErrors cvxPartMovePntToPnt | ( | int | idEntity,
 |  | svxAxis * | Start,
 |  | svxAxis * | End
 | ) |  |

#include <zwapi_cmd_shape.h>

Moves the specified geometry within the active part from one point "Start->Pnt" to another "End->Pnt".
It also changes the orientation of the part based on "Start->Dir" and "End->Dir".
If the directions are same, the orientation of the geometry is not changed – it is simply translated.

Parameters
[in] | idEntity | id of geometry entity to move
[in] | Start | start point and direction
[in] | End | end point and direction
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMoveTransform

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMoveTransform()

evxErrors cvxPartMoveTransform | ( | int | idEntity,
 |  | const svxMatrix * | Mat
 | ) |  |

#include <zwapi_cmd_shape.h>

Applies the specified general transformation to a geometry entity, moving the entity within the active part.

If "Mat" includes scaling, the scale factors are ignored.

Parameters
[in] | idEntity | id of geometry entity to move
[in] | Mat | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartMoveTransformList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartMoveTransformList()

evxErrors cvxPartMoveTransformList | ( | int | Count,
 |  | const int * | Entities,
 |  | const svxMatrix * | Mat
 | ) |  |

#include <zwapi_cmd_shape.h>

Applies the specified general transformation to a list of geometry entities, moving the entities within the active part.

"Entities" may be NULL only if "Count" is 0.

If "Mat" includes scaling, the scale factors are ignored.

It is not an error if "Count" is 0.

Parameters
[in] | Count | number of entities to transform
[in] | Entities | list of geometry entity ids
[in] | Mat | transformation matrix
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPatternFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartPatternFtr()

evxErrors cvxPartPatternFtr | ( | int | Count,
 |  | int * | idFtrs,
 |  | const svxPtnFtr * | Pattern,
 |  | int * | idPattern
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to pattern any combination of features. eight different methods of patterning are available, each method requires different types of input.

Note
Interface cvxPtnDataInit() can initialize variables(Pattern.inpData) of this function.
Interface cvxPtnVarTblInit() can initialize table variables(svxPtnVarTbl), cvxPtnDataInit() should be called before this Interface.
Parameters
[in] | Count | number of entities for pattern
[in] | idFtrs | list of id's of features
[in] | Pattern | pattern input data
[out] | idPattern | id of pattern feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPatternGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartPatternGeom()

evxErrors cvxPartPatternGeom | ( | int | Count,
 |  | int * | idEnts,
 |  | const svxPtnGeom * | Pattern,
 |  | int * | idPattern
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to pattern any combination of shapes, faces, curves, points, text, sketches, datum planes and patterns of patterns. eight different methods of patterning are available, each method requires different types of input.

Note
Interface cvxPtnDataInit() can initialize variables(Pattern.inpData) of this function.
Parameters
[in] | Count | number of entities for pattern
[in] | idEnts | list of id's of entities (supported entities include: shape,face,curve,point,sketch,datum plane,datum axis,datum CSYS)
[in] | Pattern | pattern input data
[out] | idPattern | id of pattern feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPunch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartPunch()

evxErrors cvxPartPunch | ( | const svxPunch * | data,
 |  | int * | idPunch
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to perform a punch operation between two shapes.

Note
Interface cvxPartPunchInit() can initialize variables resolve self intersection of this function.
Parameters
[in] | data
[out] | idPunch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPunchInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartPunchInit()

evxErrors cvxPartPunchInit ( svxPunch * data )

#include <zwapi_cmd_shape.h>

Initialize the svxPunch structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data part punch data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartReplace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartReplace()

evxErrors cvxPartReplace | ( | const svxReplaceData * | Replace,
 |  | int * | idReplace
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to replace one or more faces of a shape.

Note
Interface cvxPartReplaceInit() can initialize variables of this function.
Parameters
[in] | Replace | replace input data
[out] | idReplace | id of replace feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartReplaceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartReplaceInit()

evxErrors cvxPartReplaceInit ( svxReplaceData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartReplace().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape replace data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRevolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartRevolve()

evxErrors cvxPartRevolve | ( | svxRevolveData * | Rev,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a revolved shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Ext->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape". If multiple shapes could be created, use cvxEntNewList() to get their id's.

Note
Interface cvxPartRevolveInit() can initialize variables of this function.
cvxPartRevolve doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Rev | input data
[out] | idShape | id of new shape
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRevolveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartRevolveInit()

evxErrors cvxPartRevolveInit ( svxRevolveData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartRevolve().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data revolved shape data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRib

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartRib()

evxErrors cvxPartRib | ( | svxRibData * | Rib,
 |  | int * | idRib
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to create a rib feature using an open profile sketch, curve, edge or curve list. The required inputs include the profile, rib thickness, draft angle, boundary faces and the draft plane. The boundary faces can limit or expand the extent of the rib feature.

Note
Interface cvxPartRibInit() can initialize variables of this function.
Parameters
[in] | Rib | rib input data
[out] | idRib | id of rib feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRibInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartRibInit()

evxErrors cvxPartRibInit ( svxRibData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartRib().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command rib data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartScale()

evxErrors cvxPartScale | ( | int | Count,
 |  | int * | idEnts,
 |  | double | X_scale,
 |  | double | Y_scale,
 |  | double | Z_scale,
 |  | int | idDatum
 | ) |  |

#include <zwapi_cmd_shape.h>

Scales the specified entities in the active part by the input scale factors relative to the X, Y, Z axes and origin of the active part.

If "idDatum > 0", the entities(idEnts) are scaled relative to the origin and the X, Y, Z axes of the reference plane.

Parameters
[in] | Count | number of entities
[in] | idEnts | list of entity id's
[in] | X_scale | X scale factor
[in] | Y_scale | Y scale factor
[in] | Z_scale | Z scale factor
[in] | idDatum | optional datum plane entity (input 0 to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartScale2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartScale2()

evxErrors cvxPartScale2 | ( | int | Count,
 |  | int * | idEnts,
 |  | double | X_scale,
 |  | double | Y_scale,
 |  | double | Z_scale,
 |  | int | idDatum,
 |  | svxPoint * | CentPnt
 | ) |  |

#include <zwapi_cmd_shape.h>

Scales the specified entities in the active part by the input scale factors relative to the X, Y, Z axes and origin of the active part.

If "idDatum > 0", the entities(idEnts) are scaled relative to the origin and the X, Y, Z axes of the reference plane.

Parameters
[in] | Count | number of entities
[in] | idEnts | list of entity id's
[in] | X_scale | X scale factor
[in] | Y_scale | Y scale factor
[in] | Z_scale | Z scale factor
[in] | idDatum | optional datum plane entity (input 0 to ignore)
[in] | CentPnt | optional center point entity (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSelfX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSelfX()

evxErrors cvxPartSelfX | ( | const svxPartSelfX * | data,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

The corresponding function of this interface is Shape->Resolve SelfX.

Use this function to remove self intersections and inverted regions (including inverted inner loop cases) on selected faces as well as can be done.

Faces that intersect other faces in the shape will be split and the unnecessary faces will be removed. The shape will not be split.

Note
Interface cvxPartSelfXInit() can initialize variables resolve self intersection of this function.
Parameters
[in] | data | part resolve self intersection data
[out] | idShape | id of shape feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSelfXInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSelfXInit()

evxErrors cvxPartSelfXInit ( svxPartSelfX * data )

#include <zwapi_cmd_shape.h>

Initialize the svxPartSelfX structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data part resolve self intersection data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShapeFaceOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartShapeFaceOffset()

evxErrors cvxPartShapeFaceOffset | ( | svxFaceOffData * | Offset,
 |  | int * | idOffset
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to offset one or more faces of a shape.

Note
Interface cvxPartShapeFaceOffsetInit() can initialize variables of this function.
Parameters
[in] | Offset | face offset input data
[out] | idOffset | id of offset feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShapeFaceOffsetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartShapeFaceOffsetInit()

evxErrors cvxPartShapeFaceOffsetInit ( svxFaceOffData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartShapeFaceOffset().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape face offset data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShell

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartShell()

evxErrors cvxPartShell | ( | const svxShellData * | Shell,
 |  | int * | idShell
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds the specified shell(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idShell" if the output is not required.

Note
Interface cvxPartShellInit() can initialize variables of this function.
Parameters
[in] | Shell | Shell data
[out] | idShell | id of feature operation that created Shell (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_OBJ
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartShellInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartShellInit()

evxErrors cvxPartShellInit ( svxShellData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartShell().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Shell input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSimplify

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSimplify()

evxErrors cvxPartSimplify | ( | int | numEnts,
 |  | int * | idEnts,
 |  | int * | idSimplify
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to simplify a part by removing specified faces. The function will attempt to extend and reconnect faces to close the resulting gaps in the part.

Parameters
[in] | numEnts | number of face or feature to remove and gap edges to fill
[in] | idEnts | list of id's of face or feature to remove and gap edges to fill
[out] | idSimplify | id of simplify feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSphere

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSphere()

evxErrors cvxPartSphere | ( | svxSphereData * | Sphere,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a sphere shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Sphere->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape".

Note
Interface cvxPartSphereInit() can initialize variables of this function.
This command doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Sphere | sphere definition
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSphereInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSphereInit()

evxErrors cvxPartSphereInit ( svxSphereData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartSphere().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data sphere data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSpiralSweep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSpiralSweep()

evxErrors cvxPartSpiralSweep | ( | const svxSpiralSweepData * | SpiralSwp,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a spiral sweep shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Ext->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape". If multiple shapes could be created, use cvxEntNewList() to get their id's.

Note
Interface cvxPartSpiralSweepInit() can initialize variables of this function.
cvxPartSpiralSweep doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | SpiralSwp | sweep input data
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_GENERAL_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSpiralSweepInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSpiralSweepInit()

evxErrors cvxPartSpiralSweepInit ( svxSpiralSweepData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartSpiralSweep().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data spiral sweep shape data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartStock

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartStock()

evxErrors cvxPartStock | ( | svxStockData * | Stock,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to create an extruded stock feature that completely encloses faces, shapes or blocks.

Note
Interface cvxPartStockInit() can initialize variables of this function.
Parameters
[in] | Stock | stock input data
[out] | idShape | id of stock shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartStockInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartStockInit()

evxErrors cvxPartStockInit ( svxStockData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartStock().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command stock data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartStretch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartStretch()

evxErrors cvxPartStretch | ( | const svxStretchData * | Stretch,
 |  | int * | idStretch
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to stretch shape along X, Y and Z direction in specified range.

Note
Interface cvxPartStretchInit() can initialize variables of this function.
Parameters
[in] | Stretch | stretch input data
[out] | idStretch | id of Stretch feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartStretchInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartStretchInit()

evxErrors cvxPartStretchInit ( svxStretchData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartStretch().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape stretch data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSweep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSweep()

evxErrors cvxPartSweep | ( | svxSweepData * | Swp,
 |  | void * | Options,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Creates a swept shape and adds it to the active part using the specified combination method. If "idShape" is not NULL and "Ext->Combine = V_BOOL_NONE", the id of the shape created by this function is output via "idShape". If multiple shapes could be created, use cvxEntNewList() to get their id's.

Note
Interface cvxPartSweepInit() can initialize variables of this function.
cvxPartSweep doesn't support multi-base shape since R2024 when boolean type is VX_BOOL_ADD, and it will set the boolean type to VX_BOOL_NONE first, and then add a 'Add shape' feature to do the boolean add operation.
Parameters
[in] | Swp | sweep input data
[in] | Options | data pointer reserved for future use (input NULL)
[out] | idShape | id of new shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSweepInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartSweepInit()

evxErrors cvxPartSweepInit ( svxSweepData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartSweep().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data swept shape data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTaper

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTaper()

evxErrors cvxPartTaper | ( | const svxTaperData * | Taper,
 |  | int * | idTaper
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to taper shape and make it smaller in specified side.

Note
Interface cvxPartTaperInit() can initialize variables of this function.
Parameters
[in] | Taper | taper input data
[out] | idTaper | id of taper feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTaperInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTaperInit()

evxErrors cvxPartTaperInit ( svxTaperData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartTaper().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape taper data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartThicken

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartThicken()

evxErrors cvxPartThicken | ( | svxThickenData * | Thicken,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to create a thicken feature.

Note
Interface cvxPartThickenInit() can initialize variables of this function.
Parameters
[in] | Thicken | thicken input data
[out] | idShape | id of thicken shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartThickenInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartThickenInit()

evxErrors cvxPartThickenInit ( svxThickenData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartThicken().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command thicken data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartThreadAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartThreadAt()

evxErrors cvxPartThreadAt | ( | int | idFace,
 |  | svxPoint * | Pnt,
 |  | svxThreadData * | Thread
 | ) |  |

#include <zwapi_cmd_shape.h>

Adds thread attribute data (Thread) to the specified face (idFace) of the active part. The thread is placed on the end of the face nearest the input reference point (Pnt). A cosmetic representation of the thread displayed. Actual geometry representing the thread is not created.

Interface cvxPartThreadAtInit() can initialize variables of this function.

Note
cvxPartFlagExtThread() interface has the same function as this interface. Users can use the cvxPartFlagExtThread() interface to set more parameters.
Parameters
[in] | idFace | face id
[in] | Pnt | point on or near face identifying thread location
[in] | Thread | thread definition
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartThreadAtInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartThreadAtInit()

evxErrors cvxPartThreadAtInit ( svxThreadData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartThreadAt().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data thread definition data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTrim()

evxErrors cvxPartTrim | ( | svxTrimData * | Trim,
 |  | int * | numShape,
 |  | int ** | idShapes
 | ) |  |

#include <zwapi_cmd_shape.h>

Trim a shape by the input trimming data. The trimming face/faceset should extend outside the boundaries of the base face/faceset.

The calling procedure MUST deallocate the output list with cvxMemFree().

Note
Interface cvxPartTrimInit() can initialize variables of this function.
Parameters
[in] | Trim | trim input data
[out] | numShape | number of resulting shapes (NULL to ignore)
[out] | idShapes | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTrimInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTrimInit()

evxErrors cvxPartTrimInit ( svxTrimData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartTrim().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Trim data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTwist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTwist()

evxErrors cvxPartTwist | ( | const svxTwistData * | Twist,
 |  | int * | idTwist
 | ) |  |

#include <zwapi_cmd_shape.h>

Use this function to twist shapes along specified axis.

Note
Interface cvxPartTwistInit() can initialize variables of this function.
Parameters
[in] | Twist | twist input data
[out] | idTwist | id of Twist feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartTwistInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPartTwistInit()

evxErrors cvxPartTwistInit ( svxTwistData * data )

#include <zwapi_cmd_shape.h>

Initialize the parameters of the cvxPartTwist().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data shape twist data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPtnDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPtnDataInit()

evxErrors cvxPtnDataInit | ( | evxPatternType | type,
 |  | svxPtnData * | data
 | ) |  |

#include <zwapi_cmd_shape.h>

Initialize the svxPtnData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | pattern type
[out] | data | pattern data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPtnVarTblInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ cvxPtnVarTblInit()

evxErrors cvxPtnVarTblInit | ( | int | firstNum,
 |  | int | secondNum,
 |  | const char * | dimName,
 |  | svxPtnVarTbl * | ptnVarTbl
 | ) |  |

#include <zwapi_cmd_shape.h>

Initialize the svxPtnVarTbl structure.

pCell of ptnVarTbl will be initialized to the postion of the pattern instance, the position defined like this (such as: first direction x number is 3 and second direction y number is 2, B is the base feature):

-----------
y
^ * O O      if the '*' should be modified, pCell[i] = 1;
| B & O      if the '&' should be modified, pCell[i] = 10000;
|-------> x

normally pCell[i] = x*10000+y; and B(0,0) can't be modified.

pVal of ptnVarTbl will be initialized to the value of the dimension.

Note
Do not assign a value to variable "ptnVarTbl" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
The calling procedure MUST deallocate the output list pCell and pVal with cvxMemFree.
Parameters
[in] | firstNum | first direction patterned number
[in] | secondNum | second direction patterned number
[in] | dimName | the name of the dimension to be modified
[out] | ptnVarTbl | table pattern data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_MEMORY_ERROR
Examples
part\baseFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Shape Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Shape Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Shape Command functions of Part.

Basic Shape Data

enum | evxBoolType { VX_BOOL_NONE = 0 , VX_BOOL_ADD = 1 , VX_BOOL_REMOVE = 2 , VX_BOOL_INTERSECT = 3 }
boolean combination method More...
enum | evxOffsetType { VX_OFFSET_NONE = 0 , VX_OFFSET_SHRINK = 1 , VX_OFFSET_THICKEN = 2 , VX_OFFSET_THICKEN_SAME = 3 }
offset type More...
enum | evxLeadType { VX_LEAD_IN = 0 , VX_LEAD_OUT = 1 , VX_LEAD_NONE = 2 }
lead type More...
enum | evxCapType { VX_END_CAP_BOTH = 0 , VX_END_CAP_START = 1 , VX_END_CAP_END = 2 , VX_END_CAP_NONE = 3 }
End caps. More...
enum evxSweepOpt {
VX_SWP_NATURAL = 0 , VX_SWP_AT_PATH = 1 , VX_SWP_FRAME = 2 , VX_SWP_AT_PROFILE = 3 ,
VX_SWP_ALONG_PATH = 4
}
sweep option More...
enum | evxSweepXOpt { VX_SWP_X_MIN_TWIST = 0 , VX_SWP_X_FIXED_DIR = 1 , VX_SWP_X_XAXIS_CRV = 2 , VX_SWP_X_FACE_NORMAL = 3 }
sweep Xaxis option More...
enum | evxSweepZOpt { VX_SWP_Z_TANG_TO_PATH = 0 , VX_SWP_Z_TANG_TO_CRV = 1 , VX_SWP_Z_FIXED_DIR = 2 }
sweep Zaxis option More...
enum | evxLoftType { VX_LOFT_PROFS , VX_LOFT_START_PNT_PROFS , VX_LOFT_END_PNT_PROFS , VX_LOFT_BOTH_PNTS_PROFS }
loft method More...
typedef enum evxBoolType | evxBoolType
boolean combination method
typedef struct svxBoxData | svxBoxData
box data
typedef struct svxCylData | svxCylData
cylinder
typedef struct svxConeData | svxConeData
cone
typedef struct svxSphereData | svxSphereData
sphere
typedef struct svxEllsoData | svxEllsoData
ellipsoid
typedef enum evxOffsetType | evxOffsetType
offset type
typedef enum evxLeadType | evxLeadType
lead type
typedef enum evxCapType | evxCapType
End caps.
typedef struct svxExtrudeData | svxExtrudeData
extruded shape
typedef struct svxRevolveData | svxRevolveData
revolved shape
typedef enum evxSweepOpt | evxSweepOpt
sweep option
typedef enum evxSweepXOpt | evxSweepXOpt
sweep Xaxis option
typedef enum evxSweepZOpt | evxSweepZOpt
sweep Zaxis option
typedef struct svxSweepData | svxSweepData
swept shape
typedef struct svxSpiralSweepData | svxSpiralSweepData
spiral swept shape
typedef struct svxLoftProfile | svxLoftProfile
loft profile data
typedef enum evxLoftType | evxLoftType
loft method
typedef struct svxLoftData | svxLoftData
loft data

Engineering Feature Data

enum | evxChamFlltType { VX_CHAMFLLT_SYMMETRIC , VX_CHAMFLLT_ASYMMETRIC , VX_CHAMFLLT_SETBACK_ANGLE , VX_CHAMFLLT_VERTEX }
chamfer or fillet types More...
enum | evxDraftMethods { VX_EDGE_DRAFT = 1 , VX_FACE_DRAFT = 2 , VX_PRATING_EDGE_DRAFT = 3 }
draft methods More...
enum evxDraftType {
VX_DRAFT_TYPE_NONE = 0 , VX_SYM_EDGE_DRAFT = 1 , VX_ASYM_EDGE_DRAFT = 2 , VX_STATION_SYM_FACE_DRAFT = 3 ,
VX_STATION_ASYM_FACE_DRAFT = 4 , VX_STATION_PARTING_FACE_DRAFT = 5
}
draft type More...
enum | evxHoleOpt { VX_GENERAL_HOLE = 0 , VX_CLEARANCE_HOLE = 1 , VX_THREAD_HOLE = 2 , VX_PROFILE_HOLE = 3 }
hole option More...
enum evxHoleType {
VX_HOLE_SHAPE_ALL = -1 , VX_HOLE_SIMPLE = 0 , VX_HOLE_TAPERED = 1 , VX_HOLE_COUNTER_BORE = 2 ,
VX_HOLE_COUNTER_SUNK = 3 , VX_HOLE_SPOT_FACE = 4
}
hole types More...
enum evxClearHoleType {
VX_CLEAR_HOLE_SIMPLE = 0 , VX_CLEAR_HOLE_COUNT_BORE = 2 , VX_CLEAR_HOLE_COUNT_SINK = 3 , VX_CLEAR_HOLE_SLOT = 5 ,
VX_CLEAR_HOLE_COUNT_SINK_SLOT = 6 , VX_CLEAR_HOLE_COUNT_BORE_SLOT = 7
}
hole type of clearance hole More...
enum evxThreadType {
VX_THREAD_NONE = 1 , VX_THREAD_CUSTOM = 2 , VX_THREAD_M = 3 , VX_THREAD_UNC = 4 ,
VX_THREAD_UNF = 5 , VX_THREAD_ISO7 = 6 , VX_THREAD_ISO228 = 7 , VX_THREAD_NPT = 8 ,
VX_THREAD_NPSM = 9 , VX_THREAD_MC = 10 , VX_THREAD_MF = 11 , VX_THREAD_UN = 12 ,
VX_THREAD_UNEF = 13 , VX_THREAD_UNJ = 14 , VX_THREAD_UNJC = 15 , VX_THREAD_UNJF = 16 ,
VX_THREAD_UNJEF = 17 , VX_THREAD_ACME = 18 , VX_THREAD_BSP = 19 , VX_THREAD_BSTP = 20
}
hole thread types More...
enum | evxEndCondition { VX_BLIND = 0 , VX_UNTIL_FACE = 1 , VX_THROUGH_ALL = 2 }
hole end conditions More...
enum | evxThreadHoleClass { VX_THREAD_HOLE_UNDEFINED , VX_THREAD_HOLE_1B , VX_THREAD_HOLE_2B , VX_THREAD_HOLE_3B }
thread class for flag holes More...
enum evxFlagThreadDepthType {
VX_FLAG_THREAD_UNDEFINED , VX_FLAG_THREAD_DEPTH_DEFAULT , VX_FLAG_THREAD_DEPTH_1XDIAMETER , VX_FLAG_THREAD_DEPTH_15XDIAMETER ,
VX_FLAG_THREAD_DEPTH_2XDIAMETER , VX_FLAG_THREAD_DEPTH_25XDIAMETER , VX_FLAG_THREAD_DEPTH_3XDIAMETER , VX_FLAG_THREAD_DEPTH_FULL ,
VX_FLAG_THREAD_DEPTH_CUSTOM
}
flagged as thread hole depth type More...
enum | evxStockOpt { VX_STOCK_BLOCK = 1 , VX_STOCK_CYLINDER = 2 }
stock type More...
enum | evxFaceFlltType { VX_FACE_FFLT_FACE = 0 , VX_FACE_FFLT_RADIUS = 1 }
enum | evxFaceFlltBaseType { VX_FACE_FFLT_BASE_FACE_NONE = 0 , VX_FACE_FFLT_BASE_FACE_SEW = 3 }
typedef enum evxChamFlltType | evxChamFlltType
chamfer or fillet types
typedef struct svxChamFlltSetData | svxChamFlltSetData
set-list data for chamfer or fillet command
typedef struct svxChamFlltData | svxChamFlltData
chamfer or fillet data
typedef enum evxDraftMethods | evxDraftMethods
draft methods
typedef enum evxDraftType | evxDraftType
draft type
typedef struct svxDraftData | svxDraftData
template command Draft data
typedef enum evxHoleOpt | evxHoleOpt
hole option
typedef enum evxHoleType | evxHoleType
hole types
typedef enum evxClearHoleType | evxClearHoleType
hole type of clearance hole
typedef enum evxThreadType | evxThreadType
hole thread types
typedef struct svxHoleChams | svxHoleChams
Hole chamfer, added in 1900.
typedef enum evxEndCondition | evxEndCondition
hole end conditions
typedef struct svxHoleData | svxHoleData
hole data
typedef enum evxThreadHoleClass | evxThreadHoleClass
thread class for flag holes
typedef enum evxFlagThreadDepthType | evxFlagThreadDepthType
flagged as thread hole depth type
typedef struct svxFlagHoleData | svxFlagHoleData
flag hole data
typedef struct svxRibData | svxRibData
rib data
typedef struct svxFlagExtThreadData | svxFlagExtThreadData
flag ext thread data
typedef struct svxThreadData | svxThreadData
thread definition
typedef struct svxLipData | svxLipData
lip data
typedef enum evxStockOpt | evxStockOpt
stock type
typedef struct svxStockData | svxStockData
stock data
typedef enum evxFaceFlltType | evxFaceFlltType
typedef enum evxFaceFlltBaseType | evxFaceFlltBaseType
typedef struct svxFaceFlltData | svxFaceFlltData

Edit Shape Data

enum | evxOverflowType { VX_OF_AUTOMATIC = 0 , VX_OF_CHANGE = 1 , VX_OF_STATIONARY = 2 , VX_OF_CAP = 3 }
overflow types More...
typedef struct svxFaceOffData | svxFaceOffData
shape face offset data
typedef struct svxShellData | svxShellData
template command Shell input data
typedef struct svxThickenData | svxThickenData
thicken data
typedef struct svxDivideData | svxDivideData
divide data
typedef struct svxTrimData | svxTrimData
Trim data.
typedef enum evxOverflowType | evxOverflowType
overflow types
typedef struct svxReplaceData | svxReplaceData
shape replace data
typedef struct svxInlayData | svxInlayData
inlay data
typedef struct svxPartSelfX | svxPartSelfX
part resolveSelfX data
typedef struct svxPunch | svxPunch
part punch data

Basic Editing

enum evxPatternType {
VX_PATTERN_LINEAR , VX_PATTERN_CIRCULAR , VX_PATTERN_PNT_TO_PNT , VX_PATTERN_AT_PATTERN ,
VX_PATTERN_AT_CURVES , VX_PATTERN_AT_FACE , VX_PATTERN_POLYGON , VX_PATTERN_FILL_PATTERN ,
VX_PATTERN_BY_VAR
}
pattern method More...
enum evxMoveType {
VX_PNT_TO_PNT = 1 , VX_ALONG_DIR = 2 , VX_ASLIGN_FRAMES = 3 , VX_SWEEP_ALONG_PATH = 4 ,
VX_AROUND_DIR = 5 , VX_DYNAMIC_MOVE = 6
}
Move and Copy Methods. More...
typedef enum evxPatternType | evxPatternType
pattern method
typedef struct svxPtnData | svxPtnData
pattern data
typedef struct svxPtnGeom | svxPtnGeom
pattern geometry data
typedef struct svxPtnVarTbl | svxPtnVarTbl
table dimension information
typedef struct svxPtnFtr | svxPtnFtr
pattern feature data
typedef struct svxMirrorGeom | svxMirrorGeom
mirror geometry data
typedef struct svxMirrorFtr | svxMirrorFtr
mirror feature data
typedef enum evxMoveType | evxMoveType
Move and Copy Methods.
typedef struct svxDymMove | svxDymMove
dynamic copy/move entities
typedef struct svxMovePntToPnt | svxMovePntToPnt
copy/move entities form point to point
typedef struct svxAlongDir | svxAlongDir
copy/move entities along a direction
typedef struct svxAroundDir | svxAroundDir
rotate entities around a direction
typedef struct svxAlignFrame | svxAlignFrame
copy/move entities by aligning frames
typedef struct svxAlongPath | svxAlongPath
copy/move entities along path
typedef struct svxMoveData | svxMoveData
template command Move data
typedef struct svxCopyData | svxCopyData
template command Copy data

Morph Data

typedef struct svxTwistData | svxTwistData
shape twist data
typedef struct svxTaperData | svxTaperData
shape taper data
typedef struct svxStretchData | svxStretchData
shape stretch data
typedef struct svxMorphToCrvData | svxMorphToCrvData
shape morph to curve data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sheet Metal Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sheet Metal Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Sheet Metal Commands API

Base

evxErrors | cvxPartSmdExtrudeTabInit (svxSmdExtrudeTabData *data)
evxErrors | cvxPartSmdExtrudeTab (const svxSmdExtrudeTabData *data, int *idExtTab)
evxErrors | cvxPartSmdExtrudeFlangeinit (svxExtrudeFlangeData *data)
evxErrors | cvxPartSmdExtrudeFlange (const svxExtrudeFlangeData *data, int *idExtFlange)

Flange

evxErrors | cvxPartSmdReliefDataInit (svxSmdReliefData *data)
evxErrors | cvxPartSmdFullFlangeInit (svxSmdFullFlangeData *data)
evxErrors | cvxPartSmdFullFlange (const svxSmdFullFlangeData *data, int *idFull)
evxErrors | cvxPartSmdProfFlangeProfMatInit (int idEdge, double angle, svxMatrix *skMat)
evxErrors | cvxPartSmdProfFlangeInit (svxSmdFlangeProfData *data)
evxErrors | cvxPartSmdProfFlange (const svxSmdFlangeProfData *data, int *idFlange)
evxErrors | cvxPartSmdPartialFlangeInit (svxSmdPartialFlangeData *data)
evxErrors | cvxPartSmdPartialFlange (const svxSmdPartialFlangeData *data, int *idPartial)
evxErrors | cvxPartSmdHemFlangeInit (int hemType, svxSmdHemFlangeData *data)
evxErrors | cvxPartSmdHemFlange (const svxSmdHemFlangeData *data, int *idHem)
evxErrors | cvxPartSmdLftFlangeInit (evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData *data)
evxErrors | cvxPartSmdLftFlange (const svxSmdLoftedFlangeData *data, int *idLft)
evxErrors | cvxPartSmdSweptFlangeInit (evxSmdCornerRelief corType, svxSmdSweptFlangeData *data)
evxErrors | cvxPartSmdSweptFlange (const svxSmdSweptFlangeData *data, int *idSwept)
evxErrors | cvxPartSmdFoldByLineInit (svxSmdFoldByLineData *data)
evxErrors | cvxPartSmdFoldByLine (const svxSmdFoldByLineData *data, int *idFbl)
evxErrors | cvxPartSmdJogInit (svxSmdJogData *data)
evxErrors | cvxPartSmdJog (const svxSmdJogData *data, int *idJog)

Editing

evxErrors | cvxPartSmdExtendFlangeInit (evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData *data)
evxErrors | cvxPartSmdExtendFlange (const svxSmdExtendFlangeData *data, int *idFtr)
evxErrors | cvxPartSmdFlangeInit (svxSmdFlangeData *data)
evxErrors | cvxPartSmdFlange (const svxSmdFlangeData *data, int *idFlange)
evxErrors | cvxPartSmdBendTaperDefDataInit (int taperType, svxSmdBendTaperDefData *data)
evxErrors | cvxPartSmdBendTaperInit (evxSmdTaperSideMethod method, svxSmdBendTaperData *data)
evxErrors | cvxPartSmdBendTaper (const svxSmdBendTaperData *data, int *idFtr)
evxErrors | cvxPartSmdNormalCutinit (svxNormalCutData *data)
evxErrors | cvxPartSmdNormalCut (const svxNormalCutData *pData, int *numShape, int **idShapes)

Corner

evxErrors | cvxPartSmdCloseCornerInit (int type, svxCloseCornerData *data)
evxErrors | cvxPartSmdCloseCorner (const svxCloseCornerData *CornerData, int *idSmdCorner)

Form

evxErrors | cvxPartSmdDimpleInit (svxDimpleData *data)
evxErrors | cvxPartSmdDimple (svxDimpleData *Dimple, int *idDimple)
evxErrors | cvxPartSmdLouverInit (svxLouverData *data)
evxErrors | cvxPartSmdLouver (const svxLouverData *LouverData, int *idSmdLouver)
evxErrors | cvxPartSmdPunchInit (svxPunchData *data)
evxErrors | cvxPartSmdPunch (const svxPunchData *pData, int *idShape)

Bend

evxErrors | cvxPartSmdFold (const svxFoldData *Fold, int *idSmdFold)
evxErrors | cvxPartSmdUnfold (const svxUnfoldData *Unfold, int *idSmdUnfold)
evxErrors | cvxPartSmdFlattenInit (svxSmdFlattenData *data)
evxErrors | cvxPartSmdFlatten (const svxSmdFlattenData *data, int *idFtr)
evxErrors | cvxPartSmdLnUnfoldInit (svxSmdLinearUnfoldData *data)
evxErrors | cvxPartSmdLnUnfold (const svxSmdLinearUnfoldData *data, int *idFtr)
evxErrors | cvxPartSmdChangeBendInit (evxSmdChangeBendType type, svxSmdChangeBendData *data)
evxErrors | cvxPartSmdChangeBend (const svxSmdChangeBendData *data, int *idFtr)

Convert

evxErrors | cvxPartSmdRipInit (svxSmdRipData *data)
evxErrors | cvxPartSmdRip (const svxSmdRipData *data, int *idFtr)
evxErrors | cvxPartSmdMarkBendInit (svxSmdMarkBendData *data)
evxErrors | cvxPartSmdMarkBend (const svxSmdMarkBendData *data, int *idFtr)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdBendTaper

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdBendTaper()

evxErrors cvxPartSmdBendTaper | ( | const svxSmdBendTaperData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this command to miter the flange to change its profile and avoid the interference with other flanges, or make some gap, especially on the imported sheet metal which has no flange features. The system will specify the stationary face automatically, but you do have modify permission for designing the shape.

Note
Interface cvxPartSmdBendTaperInit() can initialize variables of this function.
Parameters
[in] | data | smd bend taper data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdBendTaperDefDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdBendTaperDefDataInit()

evxErrors cvxPartSmdBendTaperDefDataInit | ( | int | taperType,
 |  | svxSmdBendTaperDefData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdBendTaper().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | taperType | 0 is linear,Use an angle value or a distance value to taper the bend. 1 is tangent,Use a distance value to taper the bend. The edge of the bend is tangent to the web. default:0
[out] | data | smd bend taper definition side data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdBendTaperInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdBendTaperInit()

evxErrors cvxPartSmdBendTaperInit | ( | evxSmdTaperSideMethod | method,
 |  | svxSmdBendTaperData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdBendTaper().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Structure svxSmdBendTaperDefData can be initialized through interface cvxPartSmdBendTaperDefDataInit().
Parameters
[in] | method | Specify the side you want to taper
[out] | data | smd bend taper data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdChangeBend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdChangeBend()

evxErrors cvxPartSmdChangeBend | ( | const svxSmdChangeBendData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to modify the bending radius of the bend.

Note
Interface cvxPartSmdChangeBendInit() can initialize variables of this function.
Parameters
[in] | data | smd change bend data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdChangeBendInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdChangeBendInit()

evxErrors cvxPartSmdChangeBendInit | ( | evxSmdChangeBendType | type,
 |  | svxSmdChangeBendData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdChangeBend().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | change bend type
[out] | data | smd change bend data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdCloseCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdCloseCorner()

evxErrors cvxPartSmdCloseCorner | ( | const svxCloseCornerData * | CornerData,
 |  | int * | idSmdCorner
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Adds the specified close corner feature to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idSmdCorner" if the output is not required.

Note
Interface cvxPartSmdCloseCornerInit() can initialize variables of this function.
Parameters
[in] | CornerData | close corner data
[out] | idSmdCorner | index of close corner (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdCloseCornerInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdCloseCornerInit()

evxErrors cvxPartSmdCloseCornerInit | ( | int | type,
 |  | svxCloseCornerData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdCloseCorner().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | method, 0-close by edge, 1- close by bend(face)
[out] | data | template command Smd Close Corner data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdDimple

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdDimple()

evxErrors cvxPartSmdDimple | ( | svxDimpleData * | Dimple,
 |  | int * | idDimple
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create a raised dimple feature in a sheet metal part. The dimple(s) can be placed on any flat face including flanges and will be extended in the direction of the face.

Note
Interface cvxPartSmdDimpleInit() can initialize variables of this function.
Parameters
[in] | Dimple | dimple input data
[out] | idDimple | id of dimple feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdDimpleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdDimpleInit()

evxErrors cvxPartSmdDimpleInit ( svxDimpleData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdDimple().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data dimple data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtendFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtendFlange()

evxErrors cvxPartSmdExtendFlange | ( | const svxSmdExtendFlangeData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use function to stretch an existing tab or flange from its picked edges. It would be helpful if users don't want to redefine the flange or an Extrusion tab feature to change the size for replay efficiency, or you want to work on an imported/converted sheet metal part that doesn't have any redefine-able features.

Note
Interface cvxPartSmdExtendFlangeInit() can initialize variables of this function.
Parameters
[in] | data | smd extend flange data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtendFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtendFlangeInit()

evxErrors cvxPartSmdExtendFlangeInit | ( | evxSmdExtendFlangeMethod | type,
 |  | svxSmdExtendFlangeData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdExtendFlange().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | extend flange type
[out] | data | smd extend flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtrudeFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtrudeFlange()

evxErrors cvxPartSmdExtrudeFlange | ( | const svxExtrudeFlangeData * | data,
 |  | int * | idExtFlange
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create sheet metal flange feature, can create flange feature. Extrude a close or open profile to be a flange, it will offset the thick and add the bend.

Note
Interface cvxPartSmdExtrudeFlangeInit() can initialize variables of this function.
Parameters
[in] | data | smd extrude flange data
[out] | idExtFlange | id of smd extrude flange (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtrudeFlangeinit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtrudeFlangeinit()

evxErrors cvxPartSmdExtrudeFlangeinit ( svxExtrudeFlangeData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdExtrudeFlange().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Extrude Flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtrudeTab

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtrudeTab()

evxErrors cvxPartSmdExtrudeTab | ( | const svxSmdExtrudeTabData * | data,
 |  | int * | idExtTab
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create sheet metal flange feature, can create tab feature. Extrude a close profile to be a base tab.

Note
Interface cvxPartSmdExtrudeTabInit() can initialize variables of this function.
Parameters
[in] | data | Smd Extrude Tab data
[out] | idExtTab | id of tab (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdExtrudeTabInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdExtrudeTabInit()

evxErrors cvxPartSmdExtrudeTabInit ( svxSmdExtrudeTabData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdExtrudeTab().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Extrude Tab data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFlange()

evxErrors cvxPartSmdFlange | ( | const svxSmdFlangeData * | data,
 |  | int * | idFlange
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to add face flanges to the multi-edges of a sheet metal part.

Note
Interface cvxPartSmdFlangeInit() can initialize variables of this function.
Parameters
[in] | data | Smd Flange data
[out] | idFlange | id of flange ,NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFlangeInit()

evxErrors cvxPartSmdFlangeInit ( svxSmdFlangeData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdFlange().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.

Some parameters are gotten form interface cvxPartSmdAtGet();

Parameters
[out] data template command Smd Flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlatten

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFlatten()

evxErrors cvxPartSmdFlatten | ( | const svxSmdFlattenData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this command to generate flat entity and flat pattern. User can create multiple flatten commands in one file, which generate two sub-nodes of flat entity and flat pattern. Flat pattern applies to drawing sheet.

If there had crated flat patten in sheet metal module, when making drawing sheet, user can project flat pattern by "Standard".

Note
Interface cvxPartSmdExtendFlangeInit() can initialize variables of this function.
Parameters
[in] | data | smd flatten data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFlattenInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFlattenInit()

evxErrors cvxPartSmdFlattenInit ( svxSmdFlattenData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdFlatten().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd flatten data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFold()

evxErrors cvxPartSmdFold | ( | const svxFoldData * | Fold,
 |  | int * | idSmdFold
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Adds the specified fold(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idSmdFold" if the output is not required.

Parameters
[in] | Fold | Smdfold data
[out] | idSmdFold | Smdfold id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFoldByLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFoldByLine()

evxErrors cvxPartSmdFoldByLine | ( | const svxSmdFoldByLineData * | data,
 |  | int * | idFbl
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create bends along a line. This line can be a three-dimensional or two-dimensional line.

Note
Interface cvxPartSmdFoldByLineInit() can initialize variables of this function.
Parameters
[in] | data | smd Fold by Line data
[out] | idFbl | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFoldByLineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFoldByLineInit()

evxErrors cvxPartSmdFoldByLineInit ( svxSmdFoldByLineData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdFoldByLine().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd Fold by Line data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFullFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFullFlange()

evxErrors cvxPartSmdFullFlange | ( | const svxSmdFullFlangeData * | data,
 |  | int * | idFull
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to add full face flanges to the multi-edges of a sheet metal part.

Note
Interface cvxPartSmdFullFlangeInit() can initialize variables of this function.
Parameters
[in] | data | Smd Full Flange data
[out] | idFull | id of full flange ,NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdFullFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdFullFlangeInit()

evxErrors cvxPartSmdFullFlangeInit ( svxSmdFullFlangeData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdFullFlange().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Full Flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdHemFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdHemFlange()

evxErrors cvxPartSmdHemFlange | ( | const svxSmdHemFlangeData * | data,
 |  | int * | idHem
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to add various curly shape on edges of the sheet metal model, the thickness are same as the sheet metal model.

Note
Interface cvxPartSmdHemFlangeInit() can initialize variables of this function.
Parameters
[in] | data | Smd Hem Flange data
[out] | idHem | id of hem flange , NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdHemFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdHemFlangeInit()

evxErrors cvxPartSmdHemFlangeInit | ( | int | hemType,
 |  | svxSmdHemFlangeData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdHemFlange().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | hemType | 0 is Full hem, 1 is Partial hem.
[out] | data | template command Smd Hem Flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdJog

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdJog()

evxErrors cvxPartSmdJog | ( | const svxSmdJogData * | data,
 |  | int * | idJog
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this command to create two bends and two flange along a line, and lifting material between the to bends which are described in the notes below.

Note
Interface cvxPartSmdJogInit() can initialize variables of this function.
Parameters
[in] | data | smd jog data
[out] | idJog | feature id of jog(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdJogInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdJogInit()

evxErrors cvxPartSmdJogInit ( svxSmdJogData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdJog().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd jog data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLftFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLftFlange()

evxErrors cvxPartSmdLftFlange | ( | const svxSmdLoftedFlangeData * | data,
 |  | int * | idLft
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create lofted flange. It supports Fold/Unfold Sheet Metal Parts.

Note
Interface cvxPartSmdLftFlangeInit() can initialize variables of this function.
Parameters
[in] | data | smd lofted flange data
[out] | idLft | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLftFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLftFlangeInit()

evxErrors cvxPartSmdLftFlangeInit | ( | evxSmdLftFlangeMethod | method,
 |  | svxSmdLoftedFlangeData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdLftFlange().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | smd lofted flange method
[out] | data | smd jog data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLnUnfold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLnUnfold()

evxErrors cvxPartSmdLnUnfold | ( | const svxSmdLinearUnfoldData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this command to unfold or change the bend angle. The bend is limited to cylindrical face or modified cylindrical face.

Note
Interface cvxPartSmdLnUnfoldInit() can initialize variables of this function.
Parameters
[in] | data | smd linear unfold data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLnUnfoldInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLnUnfoldInit()

evxErrors cvxPartSmdLnUnfoldInit ( svxSmdLinearUnfoldData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdLnUnfold().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd linear unfold data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLouver

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLouver()

evxErrors cvxPartSmdLouver | ( | const svxLouverData * | LouverData,
 |  | int * | idSmdLouver
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Adds the specified louver feature to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idSmdLouver" if the output is not required.

Note
Interface cvxPartSmdLouverInit() can initialize variables of this function.
Parameters
[in] | LouverData | louver data
[out] | idSmdLouver | index of louver (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdLouverInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdLouverInit()

evxErrors cvxPartSmdLouverInit ( svxLouverData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdLouver().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Louver data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdMarkBend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdMarkBend()

evxErrors cvxPartSmdMarkBend | ( | const svxSmdMarkBendData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

A key characteristic of sheet metal parts are its bend faces. The Sheet Metal Tooltab contains commands to fold and unfold a sheet metal part. In order to perform these commands any bend radii (other than those created during the Create Full and Partial Sheet Metal Flange commands) need to be marked.

Note
Interface cvxPartSmdMarkBendInit() can initialize variables of this function.
Parameters
[in] | data | smd mark bend data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdMarkBendInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdMarkBendInit()

evxErrors cvxPartSmdMarkBendInit ( svxSmdMarkBendData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdMarkBend().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd mark bend data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdNormalCut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdNormalCut()

evxErrors cvxPartSmdNormalCut | ( | const svxNormalCutData * | pData,
 |  | int * | numShape,
 |  | int ** | idShapes
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create Normal Cut at shapes by Profile P. Pass in NULL for "idShapes" and "numShape" if the output is not require, or it will return the new shapes.

Note
Interface cvxPartSmdNormalCutInit() can initialize variables of this function.
Parameters
[in] | pData | NormalCut data
[out] | numShape | number of resulting shapes (NULL to ignore)
[out] | idShapes | list of id's of resulting shapes (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdNormalCutinit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdNormalCutinit()

evxErrors cvxPartSmdNormalCutinit ( svxNormalCutData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdNormalCut().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Normal Cut data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdPartialFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdPartialFlange()

evxErrors cvxPartSmdPartialFlange | ( | const svxSmdPartialFlangeData * | data,
 |  | int * | idPartial
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to add a partial flange to the edge of a sheet metal part.

Note
Interface cvxPartSmdPartialFlangeInit() can initialize variables of this function.
Parameters
[in] | data | Smd Partial Flange data
[out] | idPartial | id of Partial Flange, NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdPartialFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdPartialFlangeInit()

evxErrors cvxPartSmdPartialFlangeInit ( svxSmdPartialFlangeData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdPartialFlange().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Partial Flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdProfFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdProfFlange()

evxErrors cvxPartSmdProfFlange | ( | const svxSmdFlangeProfData * | data,
 |  | int * | idFlange
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to create a sheet metal profile flange. This function is similar to cvxPartSmdFullFlange(), but the shape of the bend and flanges is controlled by the profile.

Interface cvxPartSmdProfFlangeInit() can initialize variables of this function.

Note
You must call cvxPartSmdProfFlangeProfMatInit() to get the profile's matrix if you will create a profile for adding a flange.
Parameters
[in] | data | Smd Flange with profile data
[out] | idFlange | id of Flange with profile ,NULL to ignore
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdProfFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdProfFlangeInit()

evxErrors cvxPartSmdProfFlangeInit ( svxSmdFlangeProfData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdProfFlange().

Default values are used when some parameters are set to NULL. When users want to know what the default value is, they can use the interface cvxPartSmdAtGet() to get it.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Flange with Profile data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdProfFlangeProfMatInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdProfFlangeProfMatInit()

evxErrors cvxPartSmdProfFlangeProfMatInit | ( | int | idEdge,
 |  | double | angle,
 |  | svxMatrix * | skMat
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the matrix of the idProfile of svxSmdFlangeProfData.

Note
Call this interface first to get the matrix of the input profile if you will create a profile for adding a flange. You need use the output matrix as the profile's matrix.
Parameters
[in] | idEdge | id of edge to add flange with profile
[in] | angle | the bend angle
[out] | skMat | the matrix of the profile
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MODELING_DATA_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdPunch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdPunch()

evxErrors cvxPartSmdPunch | ( | const svxPunchData * | pData,
 |  | int * | idShape
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Use this function to act on the sheet metal, which can be completed punching forming. Pass in NULL for "idShape" if the output is not require, or it will return the new shape.

Note
Interface cvxPartSmdPunchInit() can initialize variables of this function.
Parameters
[in] | pData | Punch data
[out] | idShape | id's of resulting shape (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_PATH
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdPunchInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdPunchInit()

evxErrors cvxPartSmdPunchInit ( svxPunchData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdPunch().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data template command Smd Punch data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdReliefDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdReliefDataInit()

evxErrors cvxPartSmdReliefDataInit ( svxSmdReliefData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the relief parameter of svxSmdFullFlangeData/svxSmdFlangeProfData/ svxSmdPartialFlangeData/svxSmdHemFlangeData/svxSmdFlangeData.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Smd Relief data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdRip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdRip()

evxErrors cvxPartSmdRip | ( | const svxSmdRipData * | data,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Create a rip in a sheet metal part.

Note
Interface cvxPartSmdRipInit() can initialize variables of this function.
Parameters
[in] | data | smd rip data
[out] | idFtr | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdRipInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdRipInit()

evxErrors cvxPartSmdRipInit ( svxSmdRipData * data )

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdRip().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data smd rip data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdSweptFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdSweptFlange()

evxErrors cvxPartSmdSweptFlange | ( | const svxSmdSweptFlangeData * | data,
 |  | int * | idSwept
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Swept Flange is similar to Sweep, you need a profile and path to create the flange. To create a swept flange, you need an open profile sketch as the profile, and a series of existing sheet metal edges as the path.

Note
Interface cvxPartSmdSweptFlangeInit() can initialize variables of this function.
Parameters
[in] | data | smd swept flange data
[out] | idSwept | feature id(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdSweptFlangeInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdSweptFlangeInit()

evxErrors cvxPartSmdSweptFlangeInit | ( | evxSmdCornerRelief | corType,
 |  | svxSmdSweptFlangeData * | data
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Initialize the parameters of the cvxPartSmdSweptFlange().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | corType | smd relief type
[out] | data | smd Swept flange data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSmdUnfold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ cvxPartSmdUnfold()

evxErrors cvxPartSmdUnfold | ( | const svxUnfoldData * | Unfold,
 |  | int * | idSmdUnfold
 | ) |  |

#include <zwapi_cmd_sheetmetal.h>

Adds the specified unfold(s) to the active part and outputs the id of the corresponding history operation.

Pass in NULL for "idSmdUnfold" if the output is not required.

Parameters
[in] | Unfold | SmdUnfold data
[out] | idSmdUnfold | SmdUnfold id
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\smdFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sheet Metal Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sheet Metal Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Sheet Metal Command functions.

Sheet Metal Attribute Data

enum evxSmdPosition {
VX_POSITION_MATERIAL_INSIDE , VX_POSITION_MATERIAL_OUTSIDE , VX_POSITION_NATURAL , VX_POSITION_OFFSET ,
VX_POSITION_VIRTUAL_SHARP
}
Smd Flange Parameters Position. More...
enum | evxSmdBendLengthType { VX_BEND_STANDARD_LENGTH , VX_BEND_OUTER_HEIGHT , VX_BEND_INNER_HEIGHT , VX_BEND_EXTRAPOLATED_LENGTH }
Smd Bend Attributes Length type. More...
enum evxSmdKFactorType {
VX_SMD_KTYPE_CUSTOM , VX_SMD_KTYPE_FROM_MATERIAL , VX_SMD_KTYPE_BEND_TABLE , VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE ,
VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA , VX_SMD_KTYPE_BEND_DEDUCTION_TABLE , VX_SMD_KTYPE_BEND_DEDUCTIOIN , VX_SMD_KTYPE_BEND_ALLOWANCE
}
K-factor Definition type. More...
enum | evxSmdRelief { VX_RELIEF_RECTANGLE = 0 , VX_RELIEF_OBROUND = 1 , VX_RELIEF_NONE = 2 , VX_RELIEF_STRETCH = 3 }
Smd Relief type. More...
enum evxSmdCornerRelief {
VX_CORNER_RELIEF_CLOSED , VX_CORNER_RELIEF_CIRCULAR_CUTOUT , VX_CORNER_RELIEF_RECTANGULAR_CUTOUT , VX_CORNER_RELIEF_U_CUTOUT ,
VX_CORNER_RELIEF_V_CUTOUT
}
Smd Relief type of Corner Attributes. More...
enum evxSmdCalCustom {
VX_CUSTOM_RELIEF = 0x00000001 , VX_CUSTOM_ISWIDTHRATIO = 0x00000002 , VX_CUSTOM_RELIEFWIDTH = 0x00000004 , VX_CUSTOM_ISDEPTHRATIO = 0x00000008 ,
VX_CUSTOM_RELIEFDEPTH = 0x00000010
}
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom More...
enum | evxSmdReliefLengthType { VX_RELIEF_LENGTH_TYPE_TO_EDGE , VX_RELIEF_LENGTH_TYPE_THROUGH_ALL , VX_RELIEF_LENGTH_TYPE_VALUE }
Smd Relief Length Type of Flange. More...
typedef enum evxSmdPosition | evxSmdPosition
Smd Flange Parameters Position.
typedef enum evxSmdBendLengthType | evxSmdBendLengthType
Smd Bend Attributes Length type.
typedef enum evxSmdKFactorType | evxSmdKFactorType
K-factor Definition type.
typedef enum evxSmdRelief | evxSmdRelief
Smd Relief type.
typedef enum evxSmdCornerRelief | evxSmdCornerRelief
Smd Relief type of Corner Attributes.
typedef struct svxSmdAt | svxSmdAt
sheet metal attribute
typedef enum evxSmdCalCustom | evxSmdCalCustom
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom
typedef enum evxSmdReliefLengthType | evxSmdReliefLengthType
Smd Relief Length Type of Flange.
typedef struct svxSmdReliefData | svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.

Base Data

enum | evxExtFlangeType { VX_EXTFLANGE_1SIDE , VX_EXTFLANGE_2SIDES , VX_EXTFLANGE_SYMMETRICAL }
Smd extrude type. More...
enum evxSmdBendType {
VX_BEND_SIMPLE = 0 , VX_BEND_S_BEND = 1 , VX_BEND_CLOSED = 5 , VX_BEND_OPEN = 6 ,
VX_BEND_JOGGLE = 4 , VX_BEND_CURL = 2 , VX_BEND_Z_BEND = 7 , VX_BEND_CLOSED_LOOP = 8 ,
VX_BEND_OPEN_LOOP = 9 , VX_BEND_CENTERED_LOOP = 10 , VX_BEND_USER_DEFINED = 11
}
Smd Bend Type of Flange. More...
typedef enum evxExtFlangeType | evxExtFlangeType
Smd extrude type.
typedef struct svxSmdExtrudeTabData | svxSmdExtrudeTabData
template command Smd Extrude Tab data
typedef struct svxExtrudeFlangeData | svxExtrudeFlangeData
template command Smd Extrude Flange data
typedef enum evxSmdBendType | evxSmdBendType
Smd Bend Type of Flange.
typedef struct svxSmdFlangeData | svxSmdFlangeData
template command Smd Flange data

Flange Data

enum evxSmdHemBendType {
VX_SMD_HEM_BEND_CLOSED , VX_SMD_HEM_BEND_OPEN , VX_SMD_HEM_BEND_CLOSEDLOOP , VX_SMD_HEM_BEND_OPENLOOP ,
VX_SMD_HEM_BEND_CENTEREDLOOP , VX_SMD_HEM_BEND_SBEND , VX_SMD_HEM_BEND_CURL
}
Smd Bend Type of Hem Flange. More...
enum | evxSmdLftFlangeMethod { VX_SMD_GENERAL_LOFTING , VX_SMD_FLATTENABLE_LOFTING , VX_SMD_BENDING_LOFTING }
Lofted Flange method. More...
enum | evxSmdLftCutMethod { VX_SMD_LFG_MAX_ARC_HEIGHT , VX_SMD_LFG_NUMBER_BEND , VX_SMD_LFG_MAX_CHORD_LENGTH , VX_SMD_LFG_MAX_ARC_CHORD_ANGLE }
Lofted Flange Cutting Method. More...
enum evxSmdJogPosition {
VX_SMD_JOG_OUTER , VX_SMD_JOG_INNER , VX_SMD_JOG_MIDDLE , VX_SMD_JOG_MATERIAL_INSIDE ,
VX_SMD_JOG_MATERIAL_OUTSIDE
}
Smd Jog Parameters Position. More...
typedef struct svxSmdFullFlangeData | svxSmdFullFlangeData
template command Smd Full Flange data
typedef struct svxSmdFlangeProfData | svxSmdFlangeProfData
template command Smd Flange with Profile data
typedef struct svxSmdPartialFlangeData | svxSmdPartialFlangeData
template command Smd Partial Flange data
typedef enum evxSmdHemBendType | evxSmdHemBendType
Smd Bend Type of Hem Flange.
typedef struct svxSmdHemFlangeData | svxSmdHemFlangeData
template command Smd Hem Flange data
typedef enum evxSmdLftFlangeMethod | evxSmdLftFlangeMethod
Lofted Flange method.
typedef enum evxSmdLftCutMethod | evxSmdLftCutMethod
Lofted Flange Cutting Method.
typedef struct svxSmdLoftedFlangeData | svxSmdLoftedFlangeData
template command Smd Lofted Flange data
typedef struct svxSmdSweptFlangeData | svxSmdSweptFlangeData
template command Smd Swept Flange data
typedef enum evxSmdJogPosition | evxSmdJogPosition
Smd Jog Parameters Position.
typedef struct svxSmdFoldByLineData | svxSmdFoldByLineData
template command Smd Fold by Line data
typedef struct svxSmdJogData | svxSmdJogData
template command Smd Jog data

Editing Data

enum | evxSmdExtendFlangeMethod { VX_SMD_EXTEND_BY_VALUE , VX_SMD_EXTEND_THROUGH_UNTIL , VX_SMD_EXTEND_TO_SELECTED }
extend flange method More...
enum | evxSmdExtendSideMethod { VX_SMD_EXTEND_SIDE_NORMAL , VX_SMD_EXTEND_SIDE_ALONG }
extend flange side method More...
enum | evxSmdWebTaperType { VX_SMD_TAPER_WEB_NONE , VX_SMD_TAPER_WEB_FACE , VX_SMD_TAPER_WEB_FACE_CHAIN }
smd bend web taper type More...
enum | evxSmdTaperSideMethod { VX_SMD_TAPER_SIDES_BOTH , VX_SMD_TAPER_SIDES_SIDE1 , VX_SMD_TAPER_SIDES_SIDE2 , VX_SMD_TAPER_SIDES_SYMMETRY }
smd bend taper sides More...
enum | evxExtrudeType { VX_EXTRUDE_TYPE_ONESIDE = 0 , VX_EXTRUDE_TYPE_TWOSIDE = 1 , VX_EXTRUDE_TYPE_SYMMETRICAL }
extrude type More...
enum | evxNormCutTyp { VX_NORMCUT_BOTHSIDES = 0 , VX_NORMCUT_MIDDLE = 1 }
Normal Cut command. More...
typedef enum evxSmdExtendFlangeMethod | evxSmdExtendFlangeMethod
extend flange method
typedef enum evxSmdExtendSideMethod | evxSmdExtendSideMethod
extend flange side method
typedef struct svxSmdExtendFlangeData | svxSmdExtendFlangeData
template command Smd Extend Flange data
typedef enum evxSmdWebTaperType | evxSmdWebTaperType
smd bend web taper type
typedef struct svxSmdBendTaperDefData | svxSmdBendTaperDefData
smd bend taper definition side data
typedef enum evxSmdTaperSideMethod | evxSmdTaperSideMethod
smd bend taper sides
typedef struct svxSmdBendTaperData | svxSmdBendTaperData
template command Smd bend taper data
typedef enum evxExtrudeType | evxExtrudeType
extrude type
typedef enum evxNormCutTyp | evxNormCutTyp
Normal Cut command.
typedef struct svxNormalCutData | svxNormalCutData
template command Smd Normal Cut data

Corner Data

enum evxCornerReliefTyp {
VX_CORNER_CLOSED = 0 , VX_CORNER_CIRCL_CUTOUT , VX_CORNER_RECT_CUTOUT , VX_CORNER_U_CUTOUT ,
VX_CORNER_V_CUTOUT
}
corner relief type More...
enum | evxCornerOverlapTyp { VX_CORNER_UNDERLAP = 0 , VX_CORNER_OVERLAP , VX_CONER_NATURAL }
corner overlap type More...
typedef enum evxCornerReliefTyp | evxCornerReliefTyp
corner relief type
typedef enum evxCornerOverlapTyp | evxCornerOverlapTyp
corner overlap type
typedef struct svxCloseCornerData | svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default values)

Form Data

enum | evxPunchTyp { VX_PUNCH_SHAPE = 0 , VX_PUNCH_FILE = 1 }
Punch type. More...
enum | evxPunchLocType { VX_LOCATION_POINT = 0 , VX_LOCATION_CONSTRAINT = 1 }
location type of punch command More...
enum | evxDimplePostion { VX_MATERIAL_OUTSIDE = 0 , VX_MATERIAL_INSIDE , VX_BEND_OUTSIDE }
dimple position type More...
typedef enum evxPunchTyp | evxPunchTyp
Punch type.
typedef enum evxPunchLocType | evxPunchLocType
location type of punch command
typedef struct svxPunchCons | svxPunchCons
punch constraint
typedef struct svxPunchData | svxPunchData
Punch data.
typedef enum evxDimplePostion | evxDimplePostion
dimple position type
typedef struct svxDimpleData | svxDimpleData
dimple data
typedef struct svxLouverData | svxLouverData
template command Smd Louver data

Bend Data

enum | evxSmdChangeBendType { VX_SMD_CHANGE_BEND_DEFAULT , VX_SMD_CHANGE_BEND_FOLD_LENGTH , VX_SMD_CHANGE_BEND_UNFOLD_LENGTH }
change bend type More...
typedef struct svxFoldData | svxFoldData
template command Smd Fold data
typedef struct svxUnfoldData | svxUnfoldData
template command Smd Unfold data
typedef struct svxSmdFlattenData | svxSmdFlattenData
template command Smd flatten data
typedef struct svxSmdLinearUnfoldData | svxSmdLinearUnfoldData
template command Smd linear unfold data
typedef enum evxSmdChangeBendType | evxSmdChangeBendType
change bend type
typedef struct svxSmdChangeBendData | svxSmdChangeBendData
template command Smd change bend data

Convert Data

enum | evxSmdRipType { VX_SMD_RIP_BOTH_SIDES , VX_SMD_RIP_LEFT_SIDE , VX_SMD_RIP_RIGHT_SIDE }
smd rip type More...
typedef enum evxSmdRipType | evxSmdRipType
smd rip type
typedef struct svxSmdRipData | svxSmdRipData
template command Smd rip data
typedef struct svxSmdMarkBendData | svxSmdMarkBendData
template command Smd mark bend data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Create Sketch Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Create Sketch Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Sketch Creation Commands API

Sketch Creation

evxErrors | cvxPartSkIns (const vxLongPath File, const vxRootName Name, svxMatrix *Plane, int *idSketch)
evxErrors | cvxPartSkIns2 (const vxLongPath File, const vxRootName Name, int idPlane, int iAsso, int *idSketch)
evxErrors | cvxPartSkNew (svxMatrix *Plane, int *idSketch)
evxErrors | cvxPartSkPlane (svxSketchData *SkData, int *idSketch)
evxErrors | cvxHatchPtnDataInit (svxHatchPtnData *data)
evxErrors | cvxPartCosSkPlane (const svxSketchData *SkData, int isAddHatPtn, const svxHatchPtnData *PatData, int *idSketch)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxHatchPtnDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxHatchPtnDataInit()

evxErrors cvxHatchPtnDataInit ( svxHatchPtnData * data )

#include <zwapi_cmd_sk_create.h>

Initialize the svxHatchPtnData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data cosmetic sketch hatch pattern definition data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCosSkPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxPartCosSkPlane()

evxErrors cvxPartCosSkPlane | ( | const svxSketchData * | SkData,
 |  | int | isAddHatPtn,
 |  | const svxHatchPtnData * | PatData,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cmd_sk_create.h>

Adds a new cosmetic sketch to the active part, aligned with the specified insertion plane. The sketch is activated for editing.

Exit the sketch edit mode (back to editing the parent part) using cvxRootExit() or cvxSkActivate(0,0). If "idSketch" is not NULL, the id of the new sketch is output.

Note
Structure svxSketchData can be initialized through interface cvxMemZero().
Structure svxHatchPtnData can be initialized through interface cvxHatchPtnDataInit().
Parameters
[in] | SkData | sketch input data
[in] | isAddHatPtn | 1 if add hatch pattern ,else 0
[in] | PatData | hatch pattern input data (NULL to use default)
[out] | idSketch | id of new sketch (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSkIns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxPartSkIns()

evxErrors cvxPartSkIns | ( | const vxLongPath | File,
 |  | const vxRootName | Name,
 |  | svxMatrix * | Plane,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cmd_sk_create.h>

Inserts a copy of the specified sketch in the active part on the specified insertion plane. It is assumed that "File" resides in one of the default search directories. If "idSketch" is not NULL, the id of the new sketch is output.

Parameters
[in] | File | name of ZW3D file that contains the sketch as root object
[in] | Name | name of sketch root object
[in] | Plane | sketch insertion plane
[out] | idSketch | id of new sketch (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSkIns2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxPartSkIns2()

evxErrors cvxPartSkIns2 | ( | const vxLongPath | File,
 |  | const vxRootName | Name,
 |  | int | idPlane,
 |  | int | iAsso,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cmd_sk_create.h>

Inserts a copy of the specified sketch in the active part on the specified datum plane. The sketch location will be associatively linked to the datum plane – if the datum plane is moved (via history redefine/regen), the sketch will move with it.

It is assumed that "File" resides in one of the default search directories. If "idSketch" is not NULL, the id of the new sketch is output.

Parameters
[in] | File | name of ZW3D file that contains the sketch as root object
[in] | Name | name of sketch root object
[in] | idPlane | datum plane id
[in] | iAsso | option of associate copy
[out] | idSketch | id of new sketch (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSkNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxPartSkNew()

evxErrors cvxPartSkNew | ( | svxMatrix * | Plane,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cmd_sk_create.h>

Adds a new sketch to the active part, aligned with the specified insertion plane. The sketch is activated for editing.

Exit the sketch edit mode (back to editing the parent part) using cvxRootExit() or cvxSkActivate(0,0). If "idSketch" is not NULL, the id of the new sketch is output.

Parameters
[in] | Plane | sketch insertion plane
[out] | idSketch | id of new sketch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSkPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ cvxPartSkPlane()

evxErrors cvxPartSkPlane | ( | svxSketchData * | SkData,
 |  | int * | idSketch
 | ) |  |

#include <zwapi_cmd_sk_create.h>

Adds a new sketch to the active part, aligned with the specified insertion plane. The sketch is activated for editing.

Exit the sketch edit mode (back to editing the parent part) using cvxRootExit() or cvxSkActivate(0,0). If "idSketch" is not NULL, the id of the new sketch is output.

Parameters
[in] | SkData | sketch input data
[out] | idSketch | id of new sketch (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\skCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Create Sketch Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Create Sketch Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Sketch Creation Command functions.

Sketch Creation Data

enum evxHatchPtnType {
VX_HATCH_PATTERN_ANSI31 , VX_HATCH_PATTERN_ANSI32 , VX_HATCH_PATTERN_ANSI33 , VX_HATCH_PATTERN_ANSI34 ,
VX_HATCH_PATTERN_ANSI35 , VX_HATCH_PATTERN_ANSI36 , VX_HATCH_PATTERN_ANSI37 , VX_HATCH_PATTERN_ANSI38 ,
VX_HATCH_PATTERN_SHADOW_PLATE , VX_HATCH_PATTERN_BRICK , VX_HATCH_PATTERN_CORK , VX_HATCH_PATTERN_CROSS ,
VX_HATCH_PATTERN_DASH , VX_HATCH_PATTERN_LIMESTONE , VX_HATCH_PATTERN_DOTS , VX_HATCH_PATTERN_EARTH ,
VX_HATCH_PATTERN_EXPANSION , VX_HATCH_PATTERN_GRASS , VX_HATCH_PATTERN_GRATE , VX_HATCH_PATTERN_HEXAGON ,
VX_HATCH_PATTERN_HONEYCOMB , VX_HATCH_PATTERN_SQUARES , VX_HATCH_PATTERN_MOONYANG , VX_HATCH_PATTERN_BOX ,
VX_HATCH_PATTERN_BRASS , VX_HATCH_PATTERN_BRSTONE , VX_HATCH_PATTERN_CLAY , VX_HATCH_PATTERN_ESCHER ,
VX_HATCH_PATTERN_GRAVEL , VX_HATCH_PATTERN_HOUND , VX_HATCH_PATTERN_INSUL , VX_HATCH_PATTERN_ACAD_ISO02W100 ,
VX_HATCH_PATTERN_ACAD_ISO03W100 , VX_HATCH_PATTERN_ACAD_ISO04W100 , VX_HATCH_PATTERN_ACAD_ISO05W100 , VX_HATCH_PATTERN_ACAD_ISO06W100 ,
VX_HATCH_PATTERN_ACAD_ISO07W100 , VX_HATCH_PATTERN_ACAD_ISO08W100 , VX_HATCH_PATTERN_ACAD_ISO09W100 , VX_HATCH_PATTERN_ACAD_ISO10W100 ,
VX_HATCH_PATTERN_ACAD_ISO11W100 , VX_HATCH_PATTERN_ACAD_ISO12W100 , VX_HATCH_PATTERN_ACAD_ISO13W100 , VX_HATCH_PATTERN_ACAD_ISO14W100 ,
VX_HATCH_PATTERN_ACAD_ISO15W100 , VX_HATCH_PATTERN_JIS_LC_20 , VX_HATCH_PATTERN_JIS_LC_20A , VX_HATCH_PATTERN_JIS_LC_8A ,
VX_HATCH_PATTERN_JIS_LC_8 , VX_HATCH_PATTERN_JIS_RC_10 , VX_HATCH_PATTERN_JIS_RC_15 , VX_HATCH_PATTERN_JIS_RC_18 ,
VX_HATCH_PATTERN_JIS_RC_30 , VX_HATCH_PATTERN_JIS_STN_1E , VX_HATCH_PATTERN_JIS_STN_2_5 , VX_HATCH_PATTERN_JIS_WOOD ,
VX_HATCH_PATTERN_LINE , VX_HATCH_PATTERN_MUDST , VX_HATCH_PATTERN_NET , VX_HATCH_PATTERN_NET3 ,
VX_HATCH_PATTERN_PLAST , VX_HATCH_PATTERN_PLASTI , VX_HATCH_PATTERN_SACNCR , VX_HATCH_PATTERN_STARS ,
VX_HATCH_PATTERN_STEEL , VX_HATCH_PATTERN_SWAMP , VX_HATCH_PATTERN_TRANS , VX_HATCH_PATTERN_TRIANG ,
VX_HATCH_PATTERN_ZIGZAG , VX_HATCH_PATTERN_SOLID
}
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sketch or cross-hatch command to see. More...
typedef struct svxSketchData | svxSketchData
sketch definition data
typedef enum evxHatchPtnType | evxHatchPtnType
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sketch or cross-hatch command to see.
typedef struct svxHatchPtnData | svxHatchPtnData
cosmetic sketch hatch pattern definition data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sub Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sub Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Second Menu Commands API

Point

evxErrors | cvxPartPntByOffsetInit (svxPntByOffset *data, int useCirPnt)
evxErrors | cvxPartPntBy2LinesInit (svxPntBy2Lines *data, int useCirPnt)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPntBy2LinesInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sub Commands
cvxPartPntBy2LinesInit
cvxPartPntByOffsetInit

◆ cvxPartPntBy2LinesInit()

evxErrors cvxPartPntBy2LinesInit | ( | svxPntBy2Lines * | data,
 |  | int | useCirPnt
 | ) |  |

#include <zwapi_cmd_subcmd.h>

Initialize the parameters of the svxPntBy2Lines. It will set data->pntOnCrv1.critTyp and data->pntOnCrv2.critTyp to VX_START_POINT if useCirPnt = 1.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | point by two lines data
[in] | useCirPnt | 1- to use critical point, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPntByOffsetInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sub Commands
cvxPartPntBy2LinesInit
cvxPartPntByOffsetInit

◆ cvxPartPntByOffsetInit()

evxErrors cvxPartPntByOffsetInit | ( | svxPntByOffset * | data,
 |  | int | useCirPnt
 | ) |  |

#include <zwapi_cmd_subcmd.h>

Initialize the parameters of the svxPntByOffset. It will set data->pntOnEnt.critTyp to VX_START_POINT if useCirPnt = 1.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | point by offset data
[in] | useCirPnt | 1- to use critical point, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\datumCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sub Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sub Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Generic Data Types and Structures of Second Menu Command functions.

Sub-command(Point) Data

enum evxDistanceMethod {
VX_INPU_VALUE = 0 , VX_BY_THROUGH_ALL = 1 , VX_TO_POINT = 2 , VX_TO_FACES = 3 ,
VX_TO_EXTEND_FACE = 4 , VX_TO_FACE = 5
}
the distance method of the distance field, it can set the value by the specified sub-command More...
typedef struct svxPntByOffset | svxPntByOffset
the data to get the point by Offset command
typedef struct svxPntBy2Lines | svxPntBy2Lines
the data to get the point by From 2 Lines command
typedef enum evxDistanceMethod | evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
typedef struct svxLoftBndCons | svxLoftBndCons
loft boundary constraints
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: UDF API

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
UDF API
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D UDF API

UDF Creation

evxErrors | cvxPartUDFInit (const vxLongPath udfPath)
evxErrors | cvxPartUDFInqFlds (int *cnt, svxUDFParam **fldParams)
void | cvxPartUDFTerm ()
evxErrors | cvxPartUDFExplode (int idFtr)

UDF Query

evxErrors | cvxPartUDFInqPath (int idFtr, vxPath file)
evxErrors | cvxPartUDFInqLongPath (int idFtr, char *file, int sizefile)
evxErrors | cvxPartUDFInqSubFtrs (int idFtr, int *count, int **ftrList)
evxErrors | cvxPartFtrIsUDF (int idFtr, int *isUDF)
evxErrors | cvxPartUDFReplace (int idFtr, const vxLongPath file)

UDF Path

evxErrors | cvxPartUDFWizardPathSet (const vxLongPath path)
evxErrors | cvxPartUDFInsPathSet (const vxLongPath path)
evxErrors | cvxPartUDFWizardPathGet (vxPath Dir)
evxErrors | cvxPartUDFWizardPathGetByLongPath (char *Dir, int sizeDir)
evxErrors | cvxPartUDFInsPathGet (vxPath Dir)
evxErrors | cvxPartUDFInsPathGetByLongPath (char *Dir, int sizeDir)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFtrIsUDF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartFtrIsUDF()

evxErrors cvxPartFtrIsUDF | ( | int | idFtr,
 |  | int * | isUDF
 | ) |  |

#include <zwapi_cmd_udf.h>

Get the type of the feature: UDF or not.

Parameters
[in] | idFtr | index of feature
[out] | isUDF | 1 - is a UDF feature, 0 - is not a UDF feature, -1 - is not a feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFExplode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFExplode()

evxErrors cvxPartUDFExplode ( int idFtr )

#include <zwapi_cmd_udf.h>

Explode custom feature into the operations that define it.

Parameters
[in] idFtr index of UDF feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInit()

evxErrors cvxPartUDFInit ( const vxLongPath udfPath )

#include <zwapi_cmd_udf.h>

Initialize the specified UDF model, it will create a UDF command template.

If it successes, you can execute this command by follow steps:

  1. cvxDataCreate("CdUDFCmd", &idData);
  2. calls cvxPartUDFInqFlds() to get field parameters;
  3. calls cvxDataSet(idData, idFld, data) to set the data;
  4. calls ZwApiCmdExec(idData) to execute the UDF command;
  5. calls cvxPartUDFTerm to free the UDF template data.
Parameters
[in] udfPath path of UDF model
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInqFlds

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInqFlds()

evxErrors cvxPartUDFInqFlds | ( | int * | cnt,
 |  | svxUDFParam ** | fldParams
 | ) |  |

#include <zwapi_cmd_udf.h>

Get the field parameters of current UDF command.

Note
You must call the function cvxPartUDFInit() first.
Parameters
[out] | cnt | count of fields
[out] | fldParams | value of field parameters
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInqLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInqLongPath()

evxErrors cvxPartUDFInqLongPath | ( | int | idFtr,
 |  | char * | file,
 |  | int | sizefile
 | ) |  |

#include <zwapi_cmd_udf.h>

Get source file full path of specified UDF feature.

Parameters
[in] | idFtr | index of UDF feature
[out] | file | source file path of UDF feature
[in] | sizefile | max size of file
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInqPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInqPath()

evxErrors cvxPartUDFInqPath | ( | int | idFtr,
 |  | vxPath | file
 | ) |  |

#include <zwapi_cmd_udf.h>

Get source file full path of specified UDF feature.

Parameters
[in] | idFtr | index of UDF feature
[out] | file | source file path of UDF feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInqSubFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInqSubFtrs()

evxErrors cvxPartUDFInqSubFtrs | ( | int | idFtr,
 |  | int * | count,
 |  | int ** | ftrList
 | ) |  |

#include <zwapi_cmd_udf.h>

Get sub-feature list in specified UDF feature.

This function allocates memory for the array output via "ftrList". The calling procedure is responsible for deallocating the memory.

Parameters
[in] | idFtr | index of UDF feature
[out] | count | number of sub-feature in UDF feature
[out] | ftrList | list of sub-feature in UDF feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_ONJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInsPathGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInsPathGet()

evxErrors cvxPartUDFInsPathGet ( vxPath Dir )

#include <zwapi_cmd_udf.h>

Get the default open directory for the Insert UDF.

Parameters
[out] Dir full path of UDF
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • Zw_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInsPathGetByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInsPathGetByLongPath()

evxErrors cvxPartUDFInsPathGetByLongPath | ( | char * | Dir,
 |  | int | sizeDir
 | ) |  |

#include <zwapi_cmd_udf.h>

Get the default open directory for the Insert UDF. A Dir that is too long (longer than "sizeDir") is truncated. It is assumed that the input "Dir" is no longer than 512 bytes.

Parameters
[out] | Dir | full path of UDF
[in] | sizeDir | max size of Dir
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
  • Zw_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFInsPathSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFInsPathSet()

evxErrors cvxPartUDFInsPathSet ( const vxLongPath path )

#include <zwapi_cmd_udf.h>

Set the default open directory for the Insert UDF.

Parameters
[in] path full path of UDF
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFReplace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFReplace()

evxErrors cvxPartUDFReplace | ( | int | idFtr,
 |  | const vxLongPath | file
 | ) |  |

#include <zwapi_cmd_udf.h>

Replace the specified UDF to the new one by the path of UDF file. It requires that the new UDF has the same references as the old one, or it will fail.

Parameters
[in] | idFtr | index of UDF feature
[in] | file | the file path of UDF to replace
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFTerm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFTerm()

void cvxPartUDFTerm ( )

#include <zwapi_cmd_udf.h>

Destruct data after execute a user define feature command.

Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFWizardPathGet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFWizardPathGet()

evxErrors cvxPartUDFWizardPathGet ( vxPath Dir )

#include <zwapi_cmd_udf.h>

Get the default open directory for the wizard UDF.

Parameters
[out] Dir full path of UDF
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • Zw_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFWizardPathGetByLongPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFWizardPathGetByLongPath()

evxErrors cvxPartUDFWizardPathGetByLongPath | ( | char * | Dir,
 |  | int | sizeDir
 | ) |  |

#include <zwapi_cmd_udf.h>

Get the default open directory for the wizard UDF.

A Dir that is too long (longer than "sizeDir") is truncated.

It is assumed that the input "Dir" is no longer than 512 bytes.

Parameters
[out] | Dir | full path of UDF
[in] | sizeDir | max size of Dir
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • Zw_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartUDFWizardPathSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UDF API
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ cvxPartUDFWizardPathSet()

evxErrors cvxPartUDFWizardPathSet ( const vxLongPath path )

#include <zwapi_cmd_udf.h>

Set the default open directory for the wizard UDF.

Parameters
[in] path full path of UDF
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_PATH
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: UDF Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
UDF Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the UDF functions.

UDF Creation Data

typedef struct svxUDFParam svxUDFParam
field parameters of UDF command
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Wireframe Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Wireframe Commands
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Wireframe Commands API

Curve

evxErrors cvxSkCrvIntScaleInit (int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)

Drawing

evxErrors | cvxPartPnt (svxPoint *Point, int *idEnt)
evxErrors | cvxPartPntNew (int Count, const svxPntOnEntPath *PntData, int idAlignPln, int PrjToPln, int *idPntFtr)
evxErrors | cvxPartPnts (int Count, svxPoint *Points)
evxErrors | cvxPartPntsOnCrv (int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
evxErrors | cvxPartLine2pt (svxPoint *Start, svxPoint *End, int *idEnt)
evxErrors | cvxPartLineInit (svxLineData *lineData)
evxErrors | cvxPartLine (const svxLineData *lineData, int *idLine)
evxErrors | cvxPartPolylineInit (svxPolylineData *data)
evxErrors | cvxPartPolyLine (const svxPolylineData *polylinedata, int *Cnt, int **idEnt)
evxErrors | cvxPartArc3pt (svxPoint *Start, svxPoint *End, svxPoint *Mid, int *idEnt)
evxErrors | cvxPartArcRad (svxMatrix *Plane, double Radius, double Start, double End, int *idEnt)
evxErrors | cvxPartArcInit (svxArcData *arcData)
evxErrors | cvxPartArc (const svxArcData *arcData, int *idArc)
evxErrors | cvxPartCircleInit (svxCircleData *circleData)
evxErrors | cvxPartCircle (const svxCircleData *circleData, int *idCircle)
evxErrors | cvxPartRectangleInit (svxRectangleData *data)
evxErrors | cvxPartRectangle (svxRectangleData *rectData, int *iCnt, int **idEnt)
evxErrors | cvxPartCir3pt (svxPoint *P1, svxPoint *P2, svxPoint *P3, int *idEnt)
evxErrors | cvxPartCirRad (svxMatrix *Plane, double Radius, int *idEnt)
evxErrors | cvxPartEllipseInit (svxRectangleData *data)
evxErrors | cvxPartEllipse (svxRectangleData *ellipseData, int *idEnt)

Curve

evxErrors | cvxPartCrvIntInit (svxCrvIntData *data)
evxErrors | cvxPartCrvIntScaleInit (int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)
evxErrors | cvxPartCrvInt (svxCrvIntData *Crv, int *idEnt)
evxErrors | cvxPartSplineInit (svxSplineData *data, int count)
evxErrors | cvxSplinePntInit (svxSplinePnt *data)
evxErrors | cvxPartSpline (const svxSplineData *PntData, int *idEnt)
evxErrors | cvxPartCrvProjToFaceInit (svxCrvProjToFace *data)
evxErrors | cvxPartCrvProjToFace (const svxCrvProjToFace *data, int *cntEnts, int **pEnts)
evxErrors | cvxPartInterXCurveInit (svxInterCrvData *data)
evxErrors | cvxPartInterXCurve (const svxInterCrvData *pSurf, int *idFtr)
evxErrors | cvxPartCrvOnFaceThruPtsInit (svxCrvOnFaceThuPts *data)
evxErrors | cvxPartCrvOnFaceThruPts (const svxCrvOnFaceThuPts *data, int *idEnt)
evxErrors | cvxPartIsoCurveOnFaceInit (svxIsoCrvOnFaceData *data, evxCrvIsoType crvIsoType)
evxErrors | cvxPartIsoCurveOnFace (const svxIsoCrvOnFaceData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartIsoclineCurveInit (svxIsoclineCrvData *data, evxIsoclineCrvType type)
evxErrors | cvxPartIsoclineCurve (const svxIsoclineCrvData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartFaceCurve (const svxFaceCrvData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartCombinedProj (const svxCrvCombinedProjData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartExtractCenterlines (int cntFaces, int *idFaces, int extractAxis, int *cntEnts, int **idEnts)
evxErrors | cvxPartBlendCrvsConsInit (svxCrvBlendCons *consData, evxCrvBlendObjType objType)
evxErrors | cvxPartBlendCrvsInit (svxCrvBlendData *data)
evxErrors | cvxPartBlendCrvs (const svxCrvBlendData *data, int *idEnt)
evxErrors | cvxPartCurveOffset (int idCurve, double Dis, int *idOut)
evxErrors | cvxPartSpiralCurve (const svxSpiralCrvData *data, int *idEnt)
evxErrors | cvxPartCrvList (int Count, int *Curves, int *idEnt)
evxErrors | cvxPartCurve (svxCurve *Crv, int *idEnt)
evxErrors | cvxPartCurveSilh (int idCurve, svxPoint *dir, int *iCnt, int **idList)
evxErrors | cvxPartFittingCrv (int iCnt, svxPoint *pnts, double tol, double smth, int *idEnt)

Edit Curve

evxErrors | cvxPartCrvFilletInit (svxCrvFilletData *data)
evxErrors | cvxPartCrvFillet (const svxCrvFilletData *data, int *idFillet)
evxErrors | cvxPartCrvFilletChainInit (svxCrvFilletChainData *data)
evxErrors | cvxPartCrvFilletChain (const svxCrvFilletChainData *data, int *idFilletChain)
evxErrors | cvxPartCrvChamferInit (svxCrvChamferData *data)
evxErrors | cvxPartCrvChamfer (const svxCrvChamferData *data, int *idChamfer)
evxErrors | cvxPartCrvChamferChainInit (svxCrvChamferChainData *data)
evxErrors | cvxPartCrvChamferChain (const svxCrvChamferChainData *data, int *idChamfer)
evxErrors | cvxPartCrvTrimToFaces (const svxCrvTrimToFacesData *data, int *idTrim)
evxErrors | cvxPartCrvSplitAtPnts (int idCurve, int CountPnts, svxPoint *Points, int *CountCrvs, int **NewCrvs)
evxErrors | cvxPartInqReversedCurve (int idEnt, svxCurve *data)
evxErrors | cvxPartCrvTrimWithCrv (const svxTrimWithCrvData *data, int *CountCrvs, int **NewCrvs)
evxErrors | cvxPartConcentricArc (int refArc, double radius, int *idEnt)
evxErrors | cvxPartCrvConvertToArcsInit (svxCrvConvertTocData *data)
evxErrors | cvxPartCrvConvertToArcs (const svxCrvConvertTocData *data, int *cntArcs, int **idArcs)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartArc()

evxErrors cvxPartArc | ( | const svxArcData * | arcData,
 |  | int * | idArc
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D arc to the active part. If "idArc" is not NULL, the id of the new arc entity is output.

Parameters
[in] | arcData | 3D arc data
[out] | idArc | id of new 3D arc
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartArc3pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartArc3pt()

evxErrors cvxPartArc3pt | ( | svxPoint * | Start,
 |  | svxPoint * | End,
 |  | svxPoint * | Mid,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D arc to the active part. If "idEnt" is not NULL, the id of the new arc entity is output.

Parameters
[in] | Start | start point
[in] | End | end point
[in] | Mid | mid (i.e. through) point
[out] | idEnt | id of new 3D arc entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartArcInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartArcInit()

evxErrors cvxPartArcInit ( svxArcData * arcData )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartArc().

Note
Do not assign a value to variable "arcData" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] arcData 3D arc data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartArcRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartArcRad()

evxErrors cvxPartArcRad | ( | svxMatrix * | Plane,
 |  | double | Radius,
 |  | double | Start,
 |  | double | End,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D arc to the active part. The arc lies on the specified plane with its center at the plane's origin and its start/end angles measured CCW from the plane's X axis. If "idEnt" is not NULL, the id of the new entity is output.

Parameters
[in] | Plane | insertion plane
[in] | Radius | radius (mm)
[in] | Start | start angle (deg) - CCW from X axis
[in] | End | end angle (deg) - CCW from X axis
[out] | idEnt | id of new 2D circle entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBlendCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartBlendCrvs()

evxErrors cvxPartBlendCrvs | ( | const svxCrvBlendData * | data,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create a curve blend between two curves, lines, arcs, face edges or points. If "idEnt" is not NULL, the id of the shape created by this function is output via "idEnt".

Note
Interface cvxPartBlendCrvsInit() can initialize variables of this function.
Parameters
[in] | data | curve blend data
[out] | idEnt | id of blend curve (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBlendCrvsConsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartBlendCrvsConsInit()

evxErrors cvxPartBlendCrvsConsInit | ( | svxCrvBlendCons * | consData,
 |  | evxCrvBlendObjType | objType
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the svxCrvBlendCons for cvxPartBlendCrvs().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | consData | curve blend constraints data
[in] | objType | object type (curve or face)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartBlendCrvsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartBlendCrvsInit()

evxErrors cvxPartBlendCrvsInit ( svxCrvBlendData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartBlendCrvs().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data curve blend data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCir3pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCir3pt()

evxErrors cvxPartCir3pt | ( | svxPoint * | P1,
 |  | svxPoint * | P2,
 |  | svxPoint * | P3,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D circle to the active part. If "idEnt" is not NULL, the id of the new circle entity is output.

Parameters
[in] | P1 | first point on circle
[in] | P2 | second point on circle
[in] | P3 | third point on circle
[out] | idEnt | id of new 3D circle entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCircle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCircle()

evxErrors cvxPartCircle | ( | const svxCircleData * | circleData,
 |  | int * | idCircle
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D circle to the active part. If "idCircle" is not NULL, the id of the new arc entity is output.

Parameters
[in] | circleData | 3D circle data
[out] | idCircle | id of new 3D circle
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCircleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCircleInit()

evxErrors cvxPartCircleInit ( svxCircleData * circleData )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCircle().

Note
Do not assign a value to variable "circleData" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] circleData 3D circle data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCirRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCirRad()

evxErrors cvxPartCirRad | ( | svxMatrix * | Plane,
 |  | double | Radius,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D circle to the active part. The circle lies on the specified plane with its center at the plane's origin. If "idEnt" is not NULL, the id of the new entity is output.

Parameters
[in] | Plane | insertion plane
[in] | Radius | radius (mm)
[out] | idEnt | id of new 2D circle entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCombinedProj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCombinedProj()

evxErrors cvxPartCombinedProj | ( | const svxCrvCombinedProjData * | data,
 |  | int * | cntEnts,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create one or more new curves by project two curves. Please note that the projections of two curves must intersect, otherwise ZW3D will alarm this command failed.

Note
The calling procedure MUST deallocate the output list with cvxMemFree() if cntEnts and idEnts are not NULL.
Parameters
[in] | data | combined projection data
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | idEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartConcentricArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartConcentricArc()

evxErrors cvxPartConcentricArc | ( | int | refArc,
 |  | double | radius,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create an arc that share the same arc center.

Parameters
[in] | refArc | id of reference 3D arc entity (can be edge/curve)
[in] | radius | radius (mm)
[out] | idEnt | index of new 3D arc entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvChamfer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvChamfer()

evxErrors cvxPartCrvChamfer | ( | const svxCrvChamferData * | data,
 |  | int * | idChamfer
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use the function to create a chamfer between two boundary curves by specifying the setback(s) or setback value and angle. If a setback sets to "ZERO", the two curves are trimmed/extended to each other forming a corner.

Parameters
[in] | data | chamfer data
[out] | idChamfer | index of new chamfer feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvChamferChain

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvChamferChain()

evxErrors cvxPartCrvChamferChain | ( | const svxCrvChamferChainData * | data,
 |  | int * | idChamfer
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this function to create chamfers of equal setback around a chain of curves. There will be a chamfer between each adjacent curve in the chain.

Note
Interface cvxPartCrvChamferChainInit() can initialize variables of this function.
Parameters
[in] | data | chain chamfer data
[out] | idChamfer | index of new chamfer feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvChamferChainInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvChamferChainInit()

evxErrors cvxPartCrvChamferChainInit ( svxCrvChamferChainData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvChamferChain().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data chain chamfer data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvChamferInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvChamferInit()

evxErrors cvxPartCrvChamferInit ( svxCrvChamferData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvChamfer().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data chamfer data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvConvertToArcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvConvertToArcs()

evxErrors cvxPartCrvConvertToArcs | ( | const svxCrvConvertTocData * | data,
 |  | int * | cntArcs,
 |  | int ** | idArcs
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvConvertToArcs().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | data | curves convert to arc/line data
[out] | cntArcs | count of arcs/lines after conversion (NULL to ignore)
[out] | idArcs | id of arcs/lines after conversion (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvConvertToArcsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvConvertToArcsInit()

evxErrors cvxPartCrvConvertToArcsInit ( svxCrvConvertTocData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvConvertToArcs().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data curves convert to arc/line data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvFillet()

evxErrors cvxPartCrvFillet | ( | const svxCrvFilletData * | data,
 |  | int * | idFillet
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this function to create a fillet between two curves.

Parameters
[in] | data | fillet data
[out] | idFillet | index of new fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvFilletChain

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvFilletChain()

evxErrors cvxPartCrvFilletChain | ( | const svxCrvFilletChainData * | data,
 |  | int * | idFilletChain
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this function to create fillets of a specified radius between a chain of curves.

Parameters
[in] | data | chain fillet data
[out] | idFilletChain | index of new fillet feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvFilletChainInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvFilletChainInit()

evxErrors cvxPartCrvFilletChainInit ( svxCrvFilletChainData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvFilletChain().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data chain fillet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvFilletInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvFilletInit()

evxErrors cvxPartCrvFilletInit ( svxCrvFilletData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvFillet().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data fillet data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvInt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvInt()

evxErrors cvxPartCrvInt | ( | svxCrvIntData * | Crv,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D curve interpolated through through the input points with the specified degree to the active part. If "idEnt" is not NULL, the id of the new curve entity is output.

Note
Structure svxCrvIntData can be initialized through interface cvxPartCrvIntInit().
The StartScale and EndScale of svxCrvIntData can be initialized through interface cvxPartCrvIntScaleInit() by the interpolated points, or use the default value by cvxPartCrvIntInit(), or set them by yourselves .
Parameters
[in] | Crv | input data interpolated curve
[out] | idEnt | id of new 3D interpolated curve entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvIntInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvIntInit()

evxErrors cvxPartCrvIntInit ( svxCrvIntData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvInt().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data 3D interpolated curve data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvIntScaleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvIntScaleInit()

evxErrors cvxPartCrvIntScaleInit | ( | int | nPnt,
 |  | const svxPoint * | pPnts,
 |  | double * | startScale,
 |  | double * | endScale
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters StartScale and EndScale of svxCrvIntData by the interpolated points.

Parameters
[in] | nPnt | number of the points
[in] | pPnts | points list
[out] | startScale | start tangent scale factor(NULL to ignore)
[out] | endScale | end tangent scale factor(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvList()

evxErrors cvxPartCrvList | ( | int | Count,
 |  | int * | Curves,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D curve-list entity which groups the specified curves. Features like Sweep, Revolve and Extrude may be applied to 3D curve-lists as well as 2D sketches. If "idEnt" is not NULL, the id of the new entity is output.

Parameters
[in] | Count | number of curves in curve-list
[in] | Curves | pointer to list of 3D curve id's
[out] | idEnt | id of new curve-list entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvOnFaceThruPts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvOnFaceThruPts()

evxErrors cvxPartCrvOnFaceThruPts | ( | const svxCrvOnFaceThuPts * | data,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create a curve through a series of points on a face. Both the points and the curve lie on the face.

Note
Interface cvxPartCrvOnFaceThruPtsInit() can initialize variables of this function.
Parameters
[out] | data | curve on face through points data
[in] | idEnt | index of new curve entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvOnFaceThruPtsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvOnFaceThruPtsInit()

evxErrors cvxPartCrvOnFaceThruPtsInit ( svxCrvOnFaceThuPts * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvOnFaceThruPts().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data curve on face through points data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvProjToFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvProjToFace()

evxErrors cvxPartCrvProjToFace | ( | const svxCrvProjToFace * | data,
 |  | int * | cntEnts,
 |  | int ** | pEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to project curves or a sketch onto faces and/or datum planes. By default, the curve is projected normal to the faces or planes. Use the Direction option to select a different project direction.

You can also choose to limit the projected curve to the face's trim boundaries. If more than one curve is created, they become a single feature.

Note
Interface cvxPartCrvProjToFaceInit() can initialize variables of this function. The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | data | project to face data
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | pEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvProjToFaceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvProjToFaceInit()

evxErrors cvxPartCrvProjToFaceInit ( svxCrvProjToFace * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartCrvProjToFace().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data project to face data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvSplitAtPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvSplitAtPnts()

evxErrors cvxPartCrvSplitAtPnts | ( | int | idCurve,
 |  | int | CountPnts,
 |  | svxPoint * | Points,
 |  | int * | CountCrvs,
 |  | int ** | NewCrvs
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Split a curve at specified points. Outputs a list of indices of the new curves after split. The calling procedure MUST deallocate the internal memory of each element in the output list by calling cvxCurveFree(), after which the output list MUST be deallocated with cvxMemFree().

Parameters
[in] | idCurve | curve id
[in] | CountPnts | number of points to split at
[in] | Points | list of points to split at
[out] | CountCrvs | number of curves after split (NULL to ignore)
[out] | NewCrvs | list of curves after split (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvTrimToFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvTrimToFaces()

evxErrors cvxPartCrvTrimToFaces | ( | const svxCrvTrimToFacesData * | data,
 |  | int * | idTrim
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this function to trim curves or sketches to faces.

Parameters
[in] | data | trim to faces data
[out] | idTrim | index of new feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCrvTrimWithCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCrvTrimWithCrv()

evxErrors cvxPartCrvTrimWithCrv | ( | const svxTrimWithCrvData * | data,
 |  | int * | CountCrvs,
 |  | int ** | NewCrvs
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Trim or split curves to a set of boundary curves. First select the boundary Curves to split or trim to. Then select the curve Segments to delete, keep, or split. Curves can be split or trimmed by each curve in the set of boundary curves. At the part level you can trim 3D non-intersecting curves.

Note
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | data | trim with curve data
[out] | CountCrvs | count of new curve entities (NULL to ignore)
[out] | NewCrvs | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCurve()

evxErrors cvxPartCurve | ( | svxCurve * | Crv,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a curve to the active part. If "idEnt" is not NULL, the id of the new curve entity is output.

Parameters
[in] | Crv | curve data
[out] | idEnt | id of new curve entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCurveOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCurveOffset()

evxErrors cvxPartCurveOffset | ( | int | idCurve,
 |  | double | Dis,
 |  | int * | idOut
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Offset a curve with distance "Dis".

Parameters
[in] | idCurve | curve id
[in] | Dis | offset distance
[out] | idOut | id of curve after offset (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INTI_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartCurveSilh

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartCurveSilh()

evxErrors cvxPartCurveSilh | ( | int | idCurve,
 |  | svxPoint * | dir,
 |  | int * | iCnt,
 |  | int ** | idList
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Project a 2D curve along a direction, to find its silhouettes. This will split the curve on its self-intersections. Output new silhouette curves via "idList".

Parameters
[in] | idCurve | curve id
[in] | dir | project direction
[out] | iCnt | number of new curves (NULL to ignore)
[out] | idList | id of new curves (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEllipse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartEllipse()

evxErrors cvxPartEllipse | ( | svxRectangleData * | ellipseData,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Add a 3D ellipse to the active part. The ellipse lies on the specified plane with the specified center. If "idEnt" is not NULL, the id of the new entity is output.

Note
Structure svxRectangleData can be initialized through interface cvxPartEllipseInit().
Parameters
[in] | ellipseData | ellipse input data
[out] | idEnt | id of new 3D ellipse entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartEllipseInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartEllipseInit()

evxErrors cvxPartEllipseInit ( svxRectangleData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartEllipse().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Ellipse data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartExtractCenterlines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartExtractCenterlines()

evxErrors cvxPartExtractCenterlines | ( | int | cntFaces,
 |  | int * | idFaces,
 |  | int | extractAxis,
 |  | int * | cntEnts,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to extract centerlines from an existing face. Cylinder, Cone and Torus faces are recognized and the appropriate curve type is created.

Note
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | cntFaces | count of faces to create centerlines
[in] | idFaces | index of faces to create centerlines
[in] | extractAxis | 1 to display the axis, else 0
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | idEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFaceCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartFaceCurve()

evxErrors cvxPartFaceCurve | ( | const svxFaceCrvData * | data,
 |  | int * | cntEnts,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

This command is helpful when creating general face curves for which functionality provided by the parting line commands is not needed. Face curves can be created quickly around selected faces or from the projections of sketches and 3D curves onto those faces.

Note
The calling procedure MUST deallocate the output list with cvxMemFree().
Parameters
[in] | data | face curve data
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | idEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartFittingCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartFittingCrv()

evxErrors cvxPartFittingCrv | ( | int | iCnt,
 |  | svxPoint * | pnts,
 |  | double | tol,
 |  | double | smth,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Add a curve to the active part from fitting some points and smooth it. If "idEnt" is not NULL, the id of the new curve entity is output.

Parameters
[in] | iCnt | number of points
[in] | pnts | points
[in] | tol | tolerance value
[in] | smth | smooth value
[out] | idEnt | id of new curve entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInqReversedCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartInqReversedCurve()

evxErrors cvxPartInqReversedCurve | ( | int | idEnt,
 |  | svxCurve * | data
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Get the curve data of the idEnt and the reversed curve data will be output.

See also
cvxPartInqCurve().This interface can obtain curve data of curves, which is the opposite of this interface.
Parameters
[in] | idEnt | id of curvilinear entity
[out] | data | curve data.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInterXCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartInterXCurve()

evxErrors cvxPartInterXCurve | ( | const svxInterCrvData * | pSurf,
 |  | int * | idFtr
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this function to create a curve or curves at the intersection of two or more faces, open shapes, or solids.

Note
Interface cvxPartInterXCurveInit() can initialize variables of this function.
Parameters
[in] | pSurf | faces to intersect
[out] | idFtr | id of new curves list (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartInterXCurveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartInterXCurveInit()

evxErrors cvxPartInterXCurveInit ( svxInterCrvData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartInterXCurve().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data inter curve data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\shapeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsoclineCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartIsoclineCurve()

evxErrors cvxPartIsoclineCurve | ( | const svxIsoclineCrvData * | data,
 |  | int * | cntEnts,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create isocline curves on faces.

Note
Interface cvxPartIsoclineCurveInit() can initialize variables of this function.

The calling procedure MUST deallocate the output list with cvxMemFree() if cntEnts and idEnts are not NULL.

Parameters
[in] | data | isocline curve data
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | idEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsoclineCurveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartIsoclineCurveInit()

evxErrors cvxPartIsoclineCurveInit | ( | svxIsoclineCrvData * | data,
 |  | evxIsoclineCrvType | type
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the svxIsoclineCrvData for cvxPartIsoclineCurve().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | isocline curve data
[in] | type | create isocline curve's type (single angle or multiple angles)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsoCurveOnFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartIsoCurveOnFace()

evxErrors cvxPartIsoCurveOnFace | ( | const svxIsoCrvOnFaceData * | data,
 |  | int * | cntEnts,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create iso-curves on a face using a variety of methods. The curves are independent wireframe features that associated with the face. The methods in At Points, At U/V Parameter and Multiple.

The calling procedure MUST deallocate the output list with cvxMemFree() if cntEnts and idEnts are not NULL.

Note
Interface cvxPartIsoCurveOnFaceInit() can initialize variables of this function.
Parameters
[in] | data | iso-curve on face data
[out] | cntEnts | count of new curve entities (NULL to ignore)
[out] | idEnts | index of new curve entities (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartIsoCurveOnFaceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartIsoCurveOnFaceInit()

evxErrors cvxPartIsoCurveOnFaceInit | ( | svxIsoCrvOnFaceData * | data,
 |  | evxCrvIsoType | crvIsoType
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the svxIsoCrvOnFaceData for cvxPartIsoCurveOnFace().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | iso-curve on face data
[in] | crvIsoType | iso-curve on face methods
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartLine()

evxErrors cvxPartLine | ( | const svxLineData * | lineData,
 |  | int * | idLine
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D line to the active part. If "idLine" is not NULL, the id of the new line entity is output.

Parameters
[in] | lineData | 3D line data
[out] | idLine | id of new 3D line
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLine2pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartLine2pt()

evxErrors cvxPartLine2pt | ( | svxPoint * | Start,
 |  | svxPoint * | End,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D line to the active part. If "idEnt" is not NULL, the id of the new line entity is output.

Parameters
[in] | Start | start point
[in] | End | end point
[out] | idEnt | id of new 3D line entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartLineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartLineInit()

evxErrors cvxPartLineInit ( svxLineData * lineData )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartLine().

Note
Do not assign a value to variable "lineData" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] lineData 3D line data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPnt()

evxErrors cvxPartPnt | ( | svxPoint * | Point,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D point entity to the active part. If "idEnt" is not NULL, the id of the new point entity is output.

Parameters
[in] | Point | point coordinates
[out] | idEnt | id of new point entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPntNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPntNew()

evxErrors cvxPartPntNew | ( | int | Count,
 |  | const svxPntOnEntPath * | PntData,
 |  | int | idAlignPln,
 |  | int | PrjToPln,
 |  | int * | idPntFtr
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds 3D points entity to the active part.

If the id of the alignment plane "idAlignPln" is valid and "PrjToPln" is 1, the input point is projected onto the specified alignment plane.

If "idPntFtr" is not NULL, the id of the new point feature is output.

Parameters
[in] | Count | number of points
[in] | PntData | points data
[in] | idAlignPln | id of align plane
[in] | PrjToPln | whether to project point to alignment plane
[out] | idPntFtr | id of new point feature
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPnts()

evxErrors cvxPartPnts | ( | int | Count,
 |  | svxPoint * | Points
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a list 3D point entities to the active part.

Parameters
[in] | Count | number of points
[in] | Points | list of points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPntsOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPntsOnCrv()

evxErrors cvxPartPntsOnCrv | ( | int | idCrv,
 |  | svxPoint * | Pnt,
 |  | int | Num,
 |  | double | Dist,
 |  | evxExtendOpt | Opt,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Creates point entities spaced on and along a curve based on the specified input parameters.

Parameters
[in] | idCrv | id of curve entity in active object
[in] | Pnt | reference point that specifies which end of the curve to start from; this input is only necessary if "Dist" is defined (i.e. non-zero); if this argument is NULL, the geometric start point of the curve will be used if needed.
[in] Num the number of points to create along the curve; if "Dist" is zero, then the specified number of points will be created along the curve with equal spacing between them;
if "Dist" is "non-zero", then "Num" points will be created along the curve with "Dist" as the spacing between each point; in this case, "Pnt" should be input and an extension option should be defined in case the specified number of points at the specified distance exceeds the length of the curve;
if "Num" is input as zero, then "Dist" must be specified; in this case, points are created the specified distance apart, beginning at the end of the curve closest to "Pnt" and ending at/before the other end of the curve.
[in] | Dist | the distance (mm) between points (see description of "Num" argument)
[in] | Opt | extension option is "Dist" is non-zero
[out] | Count | if this argument is not NULL, output the number of points created
[out] idEnts if "Count" is not NULL, and this argument is not NULL, a list of the database id's of the point entities created by this function is output.
Memory for the list is allocated by this function. The calling procedure is responsible to free the memory.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPolyLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPolyLine()

evxErrors cvxPartPolyLine | ( | const svxPolylineData * | polylinedata,
 |  | int * | Cnt,
 |  | int ** | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Add a 3D Polyline to the active part by creating a separate line entity between each pair of input points. If "idEnt" is not NULL, this function outputs a list of the new line entity id's, and the number of new lines is assigned to "Cnt". The calling procedure MUST deallocate the output list with cvxMemFree().

Parameters
[in] | polylinedata | 3D polyline data
[out] | Cnt | number of lines to construct polyline
[out] | idEnt | id of new lines to construct polyline
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartPolylineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartPolylineInit()

evxErrors cvxPartPolylineInit ( svxPolylineData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartPolyline().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data 3D polyline data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRectangle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartRectangle()

evxErrors cvxPartRectangle | ( | svxRectangleData * | rectData,
 |  | int * | iCnt,
 |  | int ** | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Add a 3D rectangle to the active part. The rectangle lies on the specified plane with the specified center. Commonly, the output number "iCnt" should be 4. If "idEnt" is not NULL, the id of 4 lines of the rectangle is output.

Note
Structure svxRectangleData can be initialized through interface cvxPartRectangleInit().
Parameters
[in] | rectData | rectangle input data
[out] | iCnt | number of output entities
[out] | idEnt | id of new 3D rectangle entities
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartRectangleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartRectangleInit()

evxErrors cvxPartRectangleInit ( svxRectangleData * data )

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartRectangle().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Rectangle data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW-API_MEMORY_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSpiralCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartSpiralCurve()

evxErrors cvxPartSpiralCurve | ( | const svxSpiralCrvData * | data,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Use this command to create a spiral curve on a plane. User can define the revolve direction to clockwise or anti-clockwise.

Parameters
[in] | data | spiral curve data
[out] | idEnt | index of new curve entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSpline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartSpline()

evxErrors cvxPartSpline | ( | const svxSplineData * | PntData,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Adds a 3D curve interpolated through through the input points/control points with the specified data to the active part.

If "idEnt" is not NULL, the id of the new curve entity is output.

Note
Structure svxSplineData can be initialized through interface cvxPartSplineInit().
Parameters
[in] | PntData | spline data
[out] | idEnt | id of new 2D spline entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INTPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxPartSplineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxPartSplineInit()

evxErrors cvxPartSplineInit | ( | svxSplineData * | data,
 |  | int | count
 | ) |  |

#include <zwapi_cmd_wireframe.h>

Initialize the parameters of the cvxPartSpline(). If count > 0, this function allocates memory to data->Pnts based on the value of count and initializes the data->Pnts structure. Otherwise data->Pnts will be initialized to NULL.

cvxSplinePntInit() can initialize struct svxSplinePnt (data->Pnts).

If the user needs to clear "data" and count > 0, the cvxMemFree interface needs to be called to free "data->Pnts" memory.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | Spline data
[in] | count | count of points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCrvIntScaleInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxSkCrvIntScaleInit()

evxErrors cvxSkCrvIntScaleInit | ( | int | nPnt,
 |  | const svxPoint * | pPnts,
 |  | double * | startScale,
 |  | double * | endScale
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters StartScale and EndScale of svxCrvIntData by the interpolated points.

Parameters
[in] | nPnt | number of the points
[in] | pPnts | points list
[out] | startScale | start tangent scale factor(NULL to ignore)
[out] | endScale | end tangent scale factor(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSplinePntInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ cvxSplinePntInit()

evxErrors cvxSplinePntInit ( svxSplinePnt * data )

#include <zwapi_cmd_wireframe.h>

Initialize the svxSplinePnt structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Spline point data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
part\wireframeFtrCrtTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Wireframe Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Wireframe Commands Data
Commands Creation » Part and Assembly Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the Wireframe Command functions.

Wireframe Feature Data

enum evxLineType {
VX_LINE_2PT = 0 , VX_LINE_ALONG_DIR = 1 , VX_LINE_PARALLEL = 2 , VX_LINE_PERP = 3 ,
VX_LINE_ANGLE = 4 , VX_LINE_MIDDDLE = 5
}
3D line type More...
enum | evxArcType { VX_ARC_THROUGH = 0 , VX_ARC_RADIUS = 1 , VX_ARC_CENTER = 2 , VX_ARC_ANGLE = 3 }
3D arc type More...
enum evxCircleType {
VX_CIRCLE_BOUNDARY = 1 , VX_CIRCLE_RADIUS = 2 , VX_CIRCLE_THROUGH = 0 , VX_CIRCLE_2PT_RADIUS = 3 ,
VX_CIRCLE_2POINT = 4
}
3D circle type More...
enum | evxRectangleType { VX_RECT_2PT = 0 , VX_RECT_WIDTH_HEIGHT = 1 , VX_RECT_3PT = 2 }
3D ellipse & rectangle type More...
typedef enum evxLineType | evxLineType
3D line type
typedef struct svxLineData | svxLineData
3D line data
typedef enum evxArcType | evxArcType
3D arc type
typedef struct svxArcData | svxArcData
3D arc data
typedef enum evxCircleType | evxCircleType
3D circle type
typedef struct svxCircleData | svxCircleData
3D circle data
typedef struct svxPolylineData | svxPolylineData
3D polyline data
typedef enum evxRectangleType | evxRectangleType
3D ellipse & rectangle type
typedef struct svxRectangleData | svxRectangleData
3D ellipse & rectangle data

Curve Data

enum | evxCrvIsoType { VX_CRV_ISO_AT_POINT = 0 , VX_CRV_ISO_AT_UV = 1 , VX_CRV_ISO_MULTIPLE = 2 }
iso-curve type More...
enum | evxCrvIsoUVType { VX_CRV_ISO_UV_U = 0 , VX_CRV_ISO_UV_V = 1 , VX_CRV_ISO_UV_BOTH = 2 }
iso-curve U or V settings More...
enum | evxIsoclineCrvType { VX_CRV_ISOCLINE_SINGLE = 0 , VX_CRV_ISOCLINE_MULTIPLE = 1 }
create isocline curve with a single angle/multiple angles More...
enum | evxCrvBlendTrimType { VX_CURVE_BLEND_NO_TRIM = 0 , VX_CURVE_BLEND_TRIM_BOTH = 1 , VX_CURVE_BLEND_TRIM_FIRST = 2 , VX_CURVE_BLEND_TRIM_SECOND = 3 }
trim (or extend) curves type of curve blend More...
enum | evxCrvBlendPosType { VX_CURVE_BLEND_POS_ARC_LENGTH = 0 , VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH = 1 , VX_CURVE_BLEND_POS_THROUGH_POINT = 2 }
blend location type for curve to blend More...
enum | evxCrvBlendDirType { VX_CURVE_BLEND_DIR_SECTIONAL = 0 , VX_CURVE_BLEND_DIR_ISO_U = 1 , VX_CURVE_BLEND_DIR_ISO_V = 2 }
blend location type for face to blend More...
enum | evxCrvBlendObjType { VX_CURVE_BLEND_CURVE = 0 , VX_CURVE_BLEND_FACE = 1 }
select a curve or face as object to start/end blended More...
typedef struct svxCrvProjToFace | svxCrvProjToFace
project to face data
typedef struct svxInterCrvData | svxInterCrvData
inter curve
typedef struct svxCrvOnFaceThuPtsCons | svxCrvOnFaceThuPtsCons
curve on face through points constraint
typedef struct svxCrvOnFaceThuPts | svxCrvOnFaceThuPts
curve on face through points data
typedef enum evxCrvIsoType | evxCrvIsoType
iso-curve type
typedef enum evxCrvIsoUVType | evxCrvIsoUVType
iso-curve U or V settings
typedef struct svxIsoCrvOnFaceData | svxIsoCrvOnFaceData
iso-curve on face data
typedef enum evxIsoclineCrvType | evxIsoclineCrvType
create isocline curve with a single angle/multiple angles
typedef struct svxIsoclineCrvData | svxIsoclineCrvData
isocline curve data
typedef struct svxFaceCrvData | svxFaceCrvData
face curve data
typedef struct svxCrvCombinedProjData | svxCrvCombinedProjData
combined projection data
typedef enum evxCrvBlendTrimType | evxCrvBlendTrimType
trim (or extend) curves type of curve blend
typedef enum evxCrvBlendPosType | evxCrvBlendPosType
blend location type for curve to blend
typedef enum evxCrvBlendDirType | evxCrvBlendDirType
blend location type for face to blend
typedef struct svxCrvBlendCons | svxCrvBlendCons
curve blend constraints
typedef enum evxCrvBlendObjType | evxCrvBlendObjType
select a curve or face as object to start/end blended
typedef struct svxCrvBlendData | svxCrvBlendData
curve blend data
typedef struct svxSpiralCrvData | svxSpiralCrvData
spiral curve data

Edit Curve Data

enum | evxCrvTrimType { VX_CRV_TRIM_NONE = 0 , VX_CRV_TRIM_BOTH = 1 , VX_CRV_TRIM_FIRST = 2 , VX_CRV_TRIM_SECOND = 3 }
curve trim type More...
enum | evxCrvFilletMethods { VX_CRV_FILLET_RADIUS = 0 , VX_CRV_FILLET_BOUNDARY = 1 }
curve fillet method More...
enum | evxCrvChamferMethods { VX_CRV_CHAMFER_SETBACK = 0 , VX_CRV_CHAMFER_TWO_SETBACKS = 1 , VX_CRV_CHAMFER_SETBACK_AND_ANGLE = 2 }
curve chamfer method More...
enum | evxTrimWithCrvType { VX_TRIM_WITH_CRV_KEEP = 0 , VX_TRIM_WITH_CRV_DELETE = 1 , VX_TRIM_WITH_CRV_SPLIT = 2 }
trim with curve mode More...
typedef enum evxCrvTrimType | evxCrvTrimType
curve trim type
typedef enum evxCrvFilletMethods | evxCrvFilletMethods
curve fillet method
typedef struct svxCrvFilletData | svxCrvFilletData
curve fillet data
typedef struct svxCrvFilletChainData | svxCrvFilletChainData
curve fillet chain data
typedef enum evxCrvChamferMethods | evxCrvChamferMethods
curve chamfer method
typedef struct svxCrvChamferData | svxCrvChamferData
curve chamfer data
typedef struct svxCrvChamferChainData | svxCrvChamferChainData
chamfer chain data
typedef enum evxTrimWithCrvType | evxTrimWithCrvType
trim with curve mode
typedef struct svxTrimWithCrvData | svxTrimWithCrvData
trim with curve data
typedef struct svxCrvTrimToFacesData | svxCrvTrimToFacesData
trim to faces data
typedef struct svxCrvConvertTocData | svxCrvConvertTocData
create arc and line segments from existing curves data
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Drawing Commands
Commands Creation

Detailed Description

Modules

Drawing Commands Data
Drawing Dimension Commands
Drawing Commands
Layout Commands
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Commands Data
Commands Creation » Drawing Commands

Detailed Description

THE MODULE FOR THE ZW3D Data Types and Structures of the drawing command functions.

View Data

enum | evxViewLocationType { VX_LOCATION_AUTO , VX_LOCATION_CENTER , VX_LOCATION_CORNER }
drawing view location type More...
enum evxViewTypeEx {
VX_VU_NULL = 0 , VX_VU_TOP = 1 , VX_VU_FRONT = 2 , VX_VU_RIGHT = 3 ,
VX_VU_BACK = 4 , VX_VU_BOTTOM = 5 , VX_VU_LEFT = 6 , VX_VU_ISO_FRONT = 7 ,
VX_VU_AUX = 8 , VX_VU_NAME = 9 , VX_VU_3RD_UP = 10 , VX_VU_3RD_DN = 11 ,
VX_VU_3RD_RT = 12 , VX_VU_3RD_LT = 13 , VX_VU_1ST_UP = 14 , VX_VU_1ST_DN = 15 ,
VX_VU_1ST_RT = 16 , VX_VU_1ST_LT = 17 , VX_VU_3RD_PRJ_ANG = 18 , VX_VU_DETAIL = 19 ,
VX_VU_SECTION = 20 , VX_VU_DETAIL_DEF = 21 , VX_VU_SECTION_DEF = 22 , VX_VU_REV_SECT_DEF = 23 ,
VX_VU_ROTATE = 24 , VX_VU_ALIGN_SECT_DEF = 25 , VX_VU_PRJ_ANG_ARROWS = 26 , VX_VU_BEND_SECT_DEF = 27 ,
VX_VU_ISO_LFT = 28 , VX_VU_ISO_LBT = 29 , VX_VU_ISO_RBT = 30 , VX_VU_ISO_RFB = 31 ,
VX_VU_ISO_LFB = 32 , VX_VU_ISO_LBB = 33 , VX_VU_ISO_RBB = 34 , VX_VU_NAME_SECT_DEF = 35 ,
VX_VU_1ST_PRJ_ANG = 36 , VX_VU_BRKSECT = 37 , VX_VU_ISOSECT = 38 , VX_VU_DIMETRIC = 39 ,
VX_VU_SMD = 40
}
View type, more detailed than evxViewType. More...
enum | evxViewPrjAngType { VX_VIEW_PRJANG1ST = 1 , VX_VIEW_PRJANG3RD = 2 }
view projection type More...
enum | evxViewDimType { VX_VIEW_DIMTYPEPRJ = 0 , VX_VIEW_DIMTYPETRUE = 1 }
view dimension type More...
enum | evxSecMtdType { VX_METHOD_SECCURVE = 1 , VX_METHOD_TRIMPART = 2 , VX_METHOD_TRIMSURF = 3 }
section method type More...
enum | evxLocType { VX_LOC_HORIZONTAL = 1 , VX_LOC_VERTICAL = 2 , VX_LOC_ORTHOGONAL = 3 , VX_LOC_NONE = 4 }
section location More...
enum | evxLocAngType { VX_LOC_ANG_DEFAULT = 0 , VX_LOC_ANG_HORIZONTAL = 1 , VX_LOC_ANG_VERTICAL = 2 , VX_LOC_ANG_CUSTOM = 3 }
location angle More...
enum | evxDwgBndMethod { VX_RECTANGULAR_BOUNDARY = 1 , VX_CIRCULAR_BOUNDARY , VX_POLYLINE_BOUNDARY }
Drawing Broken Section Boundary Method. More...
enum | evxDwgDepthType { VX_DEPTH_POINT , VX_DEPTH_SECTION_PLANE , VX_DEPTH_3D_NAMED }
Drawing Broken Section Depth type. More...
enum | evxDwgDetailMethod { VX_RECTANGULAR_DETAIL = 1 , VX_CIRCULAR_DETAIL = 2 , VX_POLYLINE_DETAIL }
Drawing Detail Method. More...
enum | evxBrkLineType { VX_HOR_BRKLINE = 0 , VX_VER_BRKLINE , VX_SLANT_BRKLINE }
option of break line More...
typedef enum evxViewLocationType | evxViewLocationType
drawing view location type
typedef struct svxViewLocationData | svxViewLocationData
drawing view location data
typedef struct svxViewLayoutMethod | svxViewLayoutMethod
drawing view layout method
typedef struct svxViewAt | svxViewAt
View layout display attributes.
typedef struct svxViewLayoutData | svxViewLayoutData
drawing view layout data
typedef enum evxViewTypeEx | evxViewTypeEx
View type, more detailed than evxViewType.
typedef struct svxViewStandardData | svxViewStandardData
drawing view standard data
typedef enum evxViewPrjAngType | evxViewPrjAngType
view projection type
typedef enum evxViewDimType | evxViewDimType
view dimension type
typedef struct svxPrjSetting | svxPrjSetting
Projection or Auxiliary view's projection settings.
typedef struct svxViewArrow | svxViewArrow
view projection arrow
typedef struct svxAuxViewData | svxAuxViewData
Auxiliary view data.
typedef enum evxSecMtdType | evxSecMtdType
section method type
typedef enum evxLocType | evxLocType
section location
typedef enum evxLocAngType | evxLocAngType
location angle
typedef struct svxViewSecMtd | svxViewSecMtd
section method
typedef struct svxViewSecLine | svxViewSecLine
section line
typedef struct svxViewSecOp | svxViewSecOp
section option
typedef struct svxFulSecViewData | svxFulSecViewData
full section view data
typedef struct svxAlignSecViewData | svxAlignSecViewData
aligned section view data
typedef enum evxDwgBndMethod | evxDwgBndMethod
Drawing Broken Section Boundary Method.
typedef enum evxDwgDepthType | evxDwgDepthType
Drawing Broken Section Depth type.
typedef struct svxDwgBrokenSectionData | svxDwgBrokenSectionData
Drawing Broken Section input infos.
typedef enum evxDwgDetailMethod | evxDwgDetailMethod
Drawing Detail Method.
typedef struct svxDwgDetailData | svxDwgDetailData
Drawing Detail input infos.
typedef enum evxBrkLineType | evxBrkLineType
option of break line
typedef struct svxBrkLineData | svxBrkLineData
information we need when create break line

Table Data

enum | evxLevelSet { VX_TOP_LEVEL_ONLY = 0 , VX_PARTS_ONLY = 1 , VX_INDENTED = 3 , VX_BALLOON_ONLY = 4 }
level set More...
enum | evxIndentedType { VX_NO_NUM = 0 , VX_DETAILED_NUM = 1 , VX_FLAT_NUM = 2 }
indent type More...
enum | evxOrderType { VX_ORDER_BYNAME = 0 , VX_ORDER_REGEN_IDS = 1 , VX_ORDER_ASASM = 2 }
order type More...
enum evxBomset {
VX_BOM_INVALID = 0x0000 , VX_SET_DISP_CFG = 0x0001 , VX_DERIVED_PARTS = 0x0002 , VX_SYNC_BOM = 0x0004 ,
VX_KEEP_MISSING = 0x0008 , VX_STRIKE_THROUGH = 0x0010 , VX_BOM_VALID = 0xFFFF
}
BOM set. More...
enum evxOriginType {
VX_TOP_LEFT = 0 , VX_TOP_CENTER = 1 , VX_TOP_RIGHT = 2 , VX_MID_LEFT ,
VX_MID_CENTER , VX_MID_RIGHT , VX_BOTTOM_LEFT , VX_BOTTOM_CENTER ,
VX_BOTTOM_RIGHT
}
origin type More...
typedef enum evxLevelSet | evxLevelSet
level set
typedef enum evxIndentedType | evxIndentedType
indent type
typedef enum evxOrderType | evxOrderType
order type
typedef enum evxBomset | evxBomset
BOM set.
typedef struct svxDwgBom | svxDwgBom
BOM table data.
typedef enum evxOriginType | evxOriginType
origin type
typedef struct svxDwgTblInsert | svxDwgTblInsert
insert Table

Edit View Data

enum evxRotViewType {
VX_ROTVIEW_TOP = 1 , VX_ROTVIEW_FRONT = 2 , VX_ROTVIEW_RIGHT , VX_ROTVIEW_BACK ,
VX_ROTVIEW_BOTTOM , VX_ROTVIEW_LEFT , VX_ROTVIEW_ISOMETRIC , VX_ROTVIEW_ISOMETRIC_LFT ,
VX_ROTVIEW_ISOMETRIC_LBT , VX_ROTVIEW_ISOMETRIC_RBT , VX_ROTVIEW_ISOMETRIC_RFB , VX_ROTVIEW_ISOMETRIC_LFB ,
VX_ROTVIEW_ISOMETRIC_LBB , VX_ROTVIEW_ISOMETRIC_RBB
}
type of view More...
typedef enum evxRotViewType | evxRotViewType
type of view
typedef struct svxDwgRotView | svxDwgRotView
Rotate View.

Dimension Data

enum | evxAutoEntType { DIM_AUTO_ENT_ALL = 0 , DIM_AUTO_ENT_ARC_CIRCLE , DIM_AUTO_ENT_PICKED }
select geometry entity type More...
enum | evxAutoDimType { DIM_AUTO_BASELINE = 0 , DIM_AUTO_CONTINUOUS = 1 , DIM_AUTO_ORDINATE = 2 , DIM_AUTO_LABEL_COORDINATE = 3 }
auto dimension type More...
enum | evxAutoPlacement { DIM_VIEW_ABOVE_LEFT = 0 , DIM_VIEW_BELOW_RIGHT , DIM_VIEW_BOTH }
dimension position/placement More...
enum evxAutoInclude {
VX_AUTOINC_INVALID = 0x00000000 , VX_AUTOINC_ARC = 0x00000001 , VX_AUTOINC_CIRCLE = 0x00000002 , VX_AUTOINC_HOLE = 0x00000004 ,
VX_AUTOINC_LINE = 0x00000008 , VX_AUTOINC_HOLE_CALLOUT = 0x00000010 , VX_AUTOINC_CYLIND_DIM = 0x00000020 , VX_AUTOINC_MAXIMUM_DIM = 0x00000040 ,
VX_AUTOINC_VALID = 0xFFFFFFFF
}
auto dimension include More...
enum evxDimLineType {
VX_DIM_LINE_LH = 1 , VX_DIM_LINE_LV = 2 , VX_DIM_LINE_LA = 3 , VX_DIM_LINE_LR = 4 ,
VX_DIM_LINE_LP = 5 , VX_DIM_LINE_LO = 6
}
dimension Line type More...
enum | evxSymmetryDimType { VX_SYM_LINEAR = 1 , VX_SYM_ANGULAR = 2 }
symmetry dimension type More...
enum | evxDimLineOffset { VX_DIM_OFFSET_LOL = 1 , VX_DIM_OFFSET_LOP = 2 }
dimension off type More...
enum | evxDwgLnrChmDimType { VX_LEADER_CHAMFERDIM = 1 , VX_ALIGNED_CHAMFERDIM , VX_HORZORVERT_CHAMFERDIM }
type of linear chamfer dim in sheeting More...
enum | evxDwgLnrChmDimTexType { VX_TEXT_NOR_CHAMFERDIM = 0 , VX_TEXT_PERPENDICULAR_CHAMFERDIM , VX_TEXT_ALGMODLIN_CHAMFERDIM }
text style of leader linear chamfer dim in sheeting More...
enum evxAngDimType {
VX_ANG_TWOCURVES = 1 , VX_ANG_HORIZONTAL = 2 , VX_ANG_VERTICAL = 3 , VX_ANG_THREEPOINT = 4 ,
VX_ANG_ARC = 5
}
angular dimension type More...
enum evxRadDimType {
VX_RAD_RADIAL = 1 , VX_RAD_BROKEN = 2 , VX_RAD_LARGE = 3 , VX_RAD_LEADER = 4 ,
VX_RAD_DIAMETER = 5 , VX_RAD_LINEAR = 6
}
radial or diametric dim type More...
enum evxCalloutEmt {
VX_CALLOUTEMT_INVALID = 0x00000000 , VX_CALLOUTEMT_QUALITY = 0x00000001 , VX_CALLOUTEMT_DIAMETER = 0x00000002 , VX_CALLOUTEMT_DIAMETER_D2 = 0x00000004 ,
VX_CALLOUTEMT_DEPTH = 0x00000008 , VX_CALLOUTEMT_DEPTH_H2 = 0x00000010 , VX_CALLOUTEMT_THREAD_DIA = 0x00000020 , VX_CALLOUTEMT_THREAD_PITCH = 0x00000040 ,
VX_CALLOUTEMT_THREAD_DEPTH = 0x00000080 , VX_CALLOUTEMT_ANGLE = 0x00000100 , VX_CALLOUTEMT_CALLOUT_LABEL = 0x00000200 , VX_CALLOUTEMT_MULTIPLE_LINE = 0x00000400 ,
VX_CALLOUTEMT_SLOT_LENGTH = 0x00000800 , VX_CALLOUTEMT_VALID = 0xFFFFFFFF
}
Callout Elements. More...
typedef enum evxAutoEntType | evxAutoEntType
select geometry entity type
typedef enum evxAutoDimType | evxAutoDimType
auto dimension type
typedef enum evxAutoPlacement | evxAutoPlacement
dimension position/placement
typedef struct svxAutoSet | svxAutoSet
dimension position
typedef enum evxAutoInclude | evxAutoInclude
auto dimension include
typedef struct svxDimAuto | svxDimAuto
auto dimension
typedef enum evxDimLineType | evxDimLineType
dimension Line type
typedef struct svxDwgConsDim | svxDwgConsDim
data of constraint dimension
typedef struct svxDwgLineDim | svxDwgLineDim
Linear.
typedef struct svxDwgLineGrpDim | svxDwgLineGrpDim
Baseline, Continuous.
typedef struct svxDwgOrdinateDim | svxDwgOrdinateDim
Ordinate.
typedef enum evxSymmetryDimType | evxSymmetryDimType
symmetry dimension type
typedef enum evxDimLineOffset | evxDimLineOffset
dimension off type
typedef struct svxDwgLineOffsetDim | svxDwgLineOffsetDim
Linear Offset.
typedef struct svxDwgSymmetryDimData | svxDwgSymmetryDimData
Symmetry dimension data.
typedef enum evxDwgLnrChmDimType | evxDwgLnrChmDimType
type of linear chamfer dim in sheeting
typedef enum evxDwgLnrChmDimTexType | evxDwgLnrChmDimTexType
text style of leader linear chamfer dim in sheeting
typedef struct svxDwgLnrChmDimData | svxDwgLnrChmDimData
the info of the linear chamfer dim
typedef enum evxAngDimType | evxAngDimType
angular dimension type
typedef struct svxDwgAngDimData | svxDwgAngDimData
Angular dimension dim data.
typedef enum evxRadDimType | evxRadDimType
radial or diametric dim type
typedef struct svxRadDimData | svxRadDimData
radial or diametric dim data
typedef struct svxDwgArcDimData | svxDwgArcDimData
Arc dimension dim data.
typedef enum evxCalloutEmt | evxCalloutEmt
Callout Elements.
typedef struct svxDwgHoleCallOutDim | svxDwgHoleCallOutDim
Hole Callout.

Annotation Data

enum evxBalloonCon {
VX_BALLOON_CON_USERTEXT = 0 , VX_BALLOON_CON_ID = 1 , VX_BALLOON_CON_NAME = 2 , VX_BALLOON_CON_NUMBER = 3 ,
VX_BALLOON_CON_CLASS , VX_BALLOON_CON_DESIGNER , VX_BALLOON_CON_COST , VX_BALLOON_CON_SUPPLIER ,
VX_BALLOON_CON_MATERIAL , VX_BALLOON_CON_QUANTITY , VX_BALLOON_CON_MANAGER , VX_BALLOON_CON_REMARKS ,
VX_BALLOON_CON_DESCRIPTION , VX_BALLOON_CON_KEYWORDS , VX_BALLOON_CON_DERIVEDFROM , VX_BALLOON_CON_STARTDATE ,
VX_BALLOON_CON_ENDDATE , VX_BALLOON_CON_MASS , VX_BALLOON_CON_VOLUME , VX_BALLOON_CON_TOTALMASS ,
VX_BALLOON_CON_DENSITY , VX_BALLOON_CON_PARTCFG , VX_BALLOON_CON_FILEPATH , VX_BALLOON_CON_SIZE ,
VX_BALLOON_CON_LENGTH , VX_BALLOON_CON_WIDTH , VX_BALLOON_CON_HEIGHT , VX_BALLOON_CON_AREA ,
VX_BALLOON_CON_LEGEND , VX_BALLOON_CON_STOCKSIZE , VX_BALLOON_CON_VISIBLE
}
balloon text Condition More...
enum | evxDwgAtBlnInsTyp { VX_ATBLNINS_IGNMULINS = 0 , VX_ATBLNINS_MULLEAINS = 1 , VX_ATBLNINS_EACHINS = 2 }
Type of instances in auto balloon. More...
enum | evxDwgAtBlnPtnType { VX_ATBLNPAT_CONVEXHULL = 1 , VX_ATBLNPAT_SQUARE = 2 , VX_ATBLNPAT_CIRCULAR = 3 }
Pattern type of auto balloon. More...
enum | evxDwgAtBlnLeadAttach { VX_ATBLNLEAATT_EDAGES = 1 , VX_ATBLNLEAATT_FACES = 2 }
Leader attachment of auto balloon. More...
enum evxDwgAtBlnSkpSd {
VX_ATBLNSKPSD_NONE = 0 , VX_ATBLNSKPSD_LEFT = 1 , VX_ATBLNSKPSD_TOP = 2 , VX_ATBLNSKPSD_RIGHT = 4 ,
VX_ATBLNSKPSD_BOTTOM = 8
}
Skip sides of auto balloon. More...
enum | evxDwgAtBlnArrg { VX_ATBLNARR_NEAREST = 1 , VX_ATBLNARR_CW = 2 , VX_ATBLNARR_CCW = 3 }
Arrangement of auto balloon. More...
enum | evxDwgStkBlnPtn { VX_STKBLNPAT_HORRIGHT = 1 , VX_STKBLNPAT_HORLEFT , VX_STKBLNPAT_VERUP , VX_STKBLNPAT_VERDOWN }
pattern of stack balloons More...
enum | evxDatumDimType { VX_DATUM_NORMAL = 1 , VX_DATUM_ANSI = 2 }
datum dim type More...
enum | evxDatumTargDimType { VX_DATUMT_CIRCLE = 0 , VX_DATUMT_RECTANGLE = 1 , VX_DATUMT_LINE = 2 , VX_DATUMT_POINT = 3 }
datum target dim type More...
typedef struct svxLabelCoorDimData | svxLabelCoorDimData
label coordinate dim data
typedef enum evxBalloonCon | evxBalloonCon
balloon text Condition
typedef struct svxDimLabel | svxDimLabel
Label.
typedef struct svxDwgBalloonDim | svxDwgBalloonDim
Balloon.
typedef enum evxDwgAtBlnInsTyp | evxDwgAtBlnInsTyp
Type of instances in auto balloon.
typedef enum evxDwgAtBlnPtnType | evxDwgAtBlnPtnType
Pattern type of auto balloon.
typedef enum evxDwgAtBlnLeadAttach | evxDwgAtBlnLeadAttach
Leader attachment of auto balloon.
typedef enum evxDwgAtBlnSkpSd | evxDwgAtBlnSkpSd
Skip sides of auto balloon.
typedef enum evxDwgAtBlnArrg | evxDwgAtBlnArrg
Arrangement of auto balloon.
typedef struct svxDwgAtBlnData | svxDwgAtBlnData
Information of creating auto balloon.
typedef enum evxDwgStkBlnPtn | evxDwgStkBlnPtn
pattern of stack balloons
typedef struct svxDwgStkBlnData | svxDwgStkBlnData
information of creating stack balloons
typedef struct svxDwgFtrCtrl | svxDwgFtrCtrl
Datum Control.
typedef enum evxDatumDimType | evxDatumDimType
datum dim type
typedef struct svxDatumDimData | svxDatumDimData
datum dim data(drawing)
typedef enum evxDatumTargDimType | evxDatumTargDimType
datum target dim type
typedef struct svxDatumTargDimData | svxDatumTargDimData
datum target dim data

Symbol Data

enum | evxCentDimType { VX_DM_CENMARK = 1 , VX_DM_CENLINE , VX_DM_CENDLINE }
center mark type More...
enum | evxCenterLineType { VX_CL_BY_TWO_LINES = 1 , VX_CL_BY_TWO_POINTS }
centerline type More...
enum evxWeldFinishSym {
VX_WELD_FINISH_NONE = 1 , VX_WELD_FINISH_CHIPPING , VX_WELD_FINISH_GRINDING , VX_WELD_FINISH_HAMMERING ,
VX_WELD_FINISH_MACHINING , VX_WELD_FINISH_ROLLING , VX_WELD_FINISH_UNSPECIFIED
}
finish symbol of weld symbol More...
enum evxWeldContourSym {
VX_WELD_COUNTOUR_NONE = 1 , VX_WELD_COUNTOUR_FLAT , VX_WELD_COUNTOUR_CONVEX , VX_WELD_COUNTOUR_CONCAVE ,
VX_WELD_COUNTOUR_BLEND_TOES , VX_WELD_COUNTOUR_STRIP_PERMANENT , VX_WELD_COUNTOUR_STRIP_REMOVABLE
}
contour symbol of weld symbol More...
enum evxSymSurf {
VX_SYMSURF_BAS = 0 , VX_SYMSURF_MRR , VX_SYMSURF_MRP , VX_SYMSURF_JIS1 ,
VX_SYMSURF_JIS2 , VX_SYMSURF_JIS3 , VX_SYMSURF_JIS4 , VX_SYMSURF_JISNM
}
symbol type of surface roughness More...
enum evxSurfPtnSym {
VX_SURF_PTNSYM_NONE = 0 , VX_SURF_PTNSYM_RADIAL , VX_SURF_PTNSYM_PERPENDICULAR , VX_SURF_PTNSYM_ANGULAR ,
VX_SURF_PTNSYM_MULTI_DIR , VX_SURF_PTNSYM_CIRCULAR , VX_SURF_PTNSYM_PARALLEL , VX_SURF_PTNSYM_PARTICULATE
}
pattern symbol of surface roughness More...
enum | evxDwgHoleMarkType { VX_DWG_HOLE_MARK_AUTO , VX_DWG_HOLE_MARK_MANUAL }
drawing sheet hole mark method More...
enum evxDwgHoleMarkPtn {
VX_DWG_HOLE_MARK_UP_LEFT_4 , VX_DWG_HOLE_MARK_UP_RIGHT_4 , VX_DWG_HOLE_MARK_DOWN_LEFT_4 , VX_DWG_HOLE_MARK_DOWN_RIGHT_4 ,
VX_DWG_HOLE_MARK_LEFT_BEVEL_4 , VX_DWG_HOLE_MARK_RIGHT_BEVEL_4 , VX_DWG_HOLE_MARK_UP_LEFT_12 , VX_DWG_HOLE_MARK_UP_RIGHT_12 ,
VX_DWG_HOLE_MARK_DOWN_LEFT_12 , VX_DWG_HOLE_MARK_DOWN_RIGHT_12 , VX_DWG_HOLE_MARK_LEFT_BEVEL_12 , VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
}
drawing sheet hole mark pattern method More...
typedef struct svxCenterDim | svxCenterDim
Center Mark Settings.
typedef enum evxCentDimType | evxCentDimType
center mark type
typedef struct svxCenterMark | svxCenterMark
Center Mark.
typedef struct svxCenMarkCirDimData | svxCenMarkCirDimData
center mark circle dim data
typedef enum evxCenterLineType | evxCenterLineType
centerline type
typedef struct svxCenterLine | svxCenterLine
Center Line.
typedef enum evxWeldFinishSym | evxWeldFinishSym
finish symbol of weld symbol
typedef enum evxWeldContourSym | evxWeldContourSym
contour symbol of weld symbol
typedef struct svxSymWeld | svxSymWeld
Weld data.
typedef enum evxSymSurf | evxSymSurf
symbol type of surface roughness
typedef enum evxSurfPtnSym | evxSurfPtnSym
pattern symbol of surface roughness
typedef struct svxSymSurf | svxSymSurf
surface finish data
typedef struct svxSymImg | svxSymImg
image data
typedef struct svxDwgIsectSym | svxDwgIsectSym
drawing intersection symbol data
typedef enum evxDwgHoleMarkType | evxDwgHoleMarkType
drawing sheet hole mark method
typedef enum evxDwgHoleMarkPtn | evxDwgHoleMarkPtn
drawing sheet hole mark pattern method
typedef struct svxDwgHoleMark | svxDwgHoleMark
drawing sheet hole mark data

Drawing Data

enum evxHatchType {
VX_HATCH_CUSTOM = -1 , VX_HATCH_STANDARD , VX_HATCH_ANSI , VX_HATCH_ISO ,
VX_HATCH_DIN , VX_HATCH_JIS , VX_HATCH_GB
}
hatch type More...
typedef enum evxHatchType | evxHatchType
hatch type
typedef struct svxHatchAttr | svxHatchAttr
hatch attributes
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Dimension Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Dimension Commands
Commands Creation » Drawing Commands

Detailed Description

THE MODULE FOR THE ZW3D Dimension Command of Drawing API

Dimension

evxErrors | cvxDwgAutoDimAdd (const svxDimAuto *pDimData, int *idDim)
evxErrors | cvxDwgAutoDimAddInit (svxDimAuto *data)
evxErrors | cvxDwgLineDimAdd (const svxDwgLineDim *pData, int *idDim)
evxErrors | cvxDwgBaseLineDimAdd (const svxDwgLineGrpDim *pData, int *idDim)
evxErrors | cvxDwgContinuousDimAdd (const svxDwgLineGrpDim *pData, int *idDim)
evxErrors | cvxDwgOrdinateDimAdd (const svxDwgOrdinateDim *pData, int *idDim)
evxErrors | cvxDwgLineOffsetDimAdd (const svxDwgLineOffsetDim *pData, int *idDim)
evxErrors | cvxDwgSymmetryDimAdd (const svxDwgSymmetryDimData *symmetryDimData, int *idDim)
evxErrors | cvxDwgLnrChmDimAddInit (svxDwgLnrChmDimData *data)
evxErrors | cvxDwgLnrChmDimAdd (const svxDwgLnrChmDimData *DimData, int *idDim)
evxErrors | cvxDwgAngDimAdd (const svxDwgAngDimData *angDimData, int *idDim)
evxErrors | cvxDwgRadDimAdd (const svxRadDimData *radDimData, int *idDim)
evxErrors | cvxDwgArcDimAdd (const svxDwgArcDimData *arcDimData, int *idDim)
evxErrors | cvxDwgHoleCallOutDimAddinit (svxDwgHoleCallOutDim *data)
evxErrors | cvxDwgHoleCallOutDimAdd (const svxDwgHoleCallOutDim *pData, int *numDim, int **idDims)

Annotation

evxErrors | cvxDwgLabelCoorDimAdd (const svxLabelCoorDimData *coorDimData, int *idDim)
evxErrors | cvxDwgLabelDimAdd (const svxDimLabel *pLabel, int *idDim)
evxErrors | cvxDwgBalloonDimAdd (const svxDwgBalloonDim *pData, int *idDim)
evxErrors | cvxDwgAutoBlnAddInit (svxDwgAtBlnData *data)
evxErrors | cvxDwgAutoBlnAdd (const svxDwgAtBlnData *atBlnData, int *idDimCount, int **idDimList)
evxErrors | cvxDwgStkBlnAddInit (svxDwgStkBlnData *data)
evxErrors | cvxDwgStkBlnAdd (const svxDwgStkBlnData *stkBlnData, int *idDimCount, int **idDimList)
evxErrors | cvxDwgFtrCtrlDimAdd (const svxDwgFtrCtrl *pData, int *idDim)
evxErrors | cvxDwgDatumDimAdd (const svxDatumDimData *datumData, int *idDim)
evxErrors | cvxDwgDatumTargDimAddInit (svxDatumTargDimData *data)
evxErrors | cvxDwgDatumTargDimAdd (const svxDatumTargDimData *datumTData, int *idDim)

Symbol

evxErrors | cvxDwgCenterMarkDimAddInit (svxCenterMark *data)
evxErrors | cvxDwgCenterMarkDimAdd (const svxCenterMark *pzCenterMark, int *idDim)
evxErrors | cvxDwgCenMarkCirDimAddInit (svxCenMarkCirDimData *data)
evxErrors | cvxDwgCenMarkCirDimAdd (const svxCenMarkCirDimData *cmcDimData, int *idDim)
evxErrors | cvxDwgCenterLineDimAddInit (svxCenterLine *data)
evxErrors | cvxDwgCenterLineDimAdd (const svxCenterLine *pzCenterLine, int *idDim)
evxErrors | cvxDwgSymWeldNew (int idEnt, svxPoint2 *refPoint, const svxSymWeld *data, int *idSymWeld)
evxErrors | cvxDwgSymWeldNewInit (svxSymWeld *data)
evxErrors | cvxDwgSymSurfNewInit (svxSymSurf *data)
evxErrors | cvxDwgSymSurfNew (int idEnt, svxPoint2 *refPoint, const svxSymSurf *data, int *idSymSurf)
evxErrors | cvxDwgSymImgNew (svxSymImg *data, int embed, int locked, int *idSymImg)
evxErrors | cvxDwgSymImgNewInit (svxSymImg *data)
evxErrors | cvxDwgInsertSymbol (const vxLongPath fileName, const vxLongName symName, svxPoint2 *pnt, int *symId)
evxErrors | cvxDwgUserSymNew (int count, int *idEnt, svxPoint2 *BasePnt, const vxRootName Name, int *idBlock)
evxErrors | cvxDwgIsectSym (const svxDwgIsectSym *data, int *idSym)
evxErrors | cvxDwgHoleMarkInit (evxDwgHoleMarkType type, svxDwgHoleMark *data)
evxErrors | cvxDwgHoleMark (const svxDwgHoleMark *data)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAngDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgAngDimAdd()

evxErrors cvxDwgAngDimAdd | ( | const svxDwgAngDimData * | angDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create an angular dimension in a drawing sheet.

Parameters
[in] | angDimData | angular dimension input data
[out] | idDim | id of the angular dimension (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgArcDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgArcDimAdd()

evxErrors cvxDwgArcDimAdd | ( | const svxDwgArcDimData * | arcDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create an arc length dimension in a drawing sheet.

Parameters
[in] | arcDimData | arc dimension input data
[out] | idDim | id of the arc dimension (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAutoBlnAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgAutoBlnAdd()

evxErrors cvxDwgAutoBlnAdd | ( | const svxDwgAtBlnData * | atBlnData,
 |  | int * | idDimCount,
 |  | int ** | idDimList
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create auto balloon. all values of atBllnInfo need initialization.

Note
Interface cvxDwgAutoBlnAddInit() can initialize variables of this function.
Parameters
[in] | atBlnData | the information of Creating auto balloon
[out] | idDimCount | number of created balloon dim id (input NULL to ignore)
[out] | idDimList | list of created balloon dim id (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_TYPE_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAutoBlnAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgAutoBlnAddInit()

evxErrors cvxDwgAutoBlnAddInit ( svxDwgAtBlnData * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgAutoBlnAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Information of creating auto balloon
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAutoDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgAutoDimAdd()

evxErrors cvxDwgAutoDimAdd | ( | const svxDimAuto * | pDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Add auto dimension by special parameter.

Note
Interface cvxDwgAutoDimAddInit() can initialize variables of this function.
Parameters
[in] | pDimData | dimension parameters
[out] | idDim | id of Dim (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgAutoDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgAutoDimAddInit()

evxErrors cvxDwgAutoDimAddInit ( svxDimAuto * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgAutoDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data auto dimension data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgBalloonDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgBalloonDimAdd()

evxErrors cvxDwgBalloonDimAdd | ( | const svxDwgBalloonDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Balloon dimension between the specified points in drawing. pData->condition is set by evxBalloonCon

Parameters
[in] | pData | data of balloon dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgBaseLineDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgBaseLineDimAdd()

evxErrors cvxDwgBaseLineDimAdd | ( | const svxDwgLineGrpDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Baseline dimension between the specified object in drawing.

pData->sub.cons.type is set by evxDimLineType, as follows:
VX_DIM_LINE_LH – horizontal
VX_DIM_LINE_LV – vertical
VX_DIM_LINE_LA – aligned
VX_DIM_LINE_LR – rotated
VX_DIM_LINE_LP – projected

Parameters
[in] | pData | data of BaseLine dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenMarkCirDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenMarkCirDimAdd()

evxErrors cvxDwgCenMarkCirDimAdd | ( | const svxCenMarkCirDimData * | cmcDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a center mark circle dimension for the specified entities in drawing.

Note
Interface cvxDwgCenMarkCirDimAddInit() can initialize variables of this function.
Parameters
[in] | cmcDimData | center mark circle dimension input data
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_aPI_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenMarkCirDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenMarkCirDimAddInit()

evxErrors cvxDwgCenMarkCirDimAddInit ( svxCenMarkCirDimData * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgCenMarkCirDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data center mark circle dim data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenterLineDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenterLineDimAdd()

evxErrors cvxDwgCenterLineDimAdd | ( | const svxCenterLine * | pzCenterLine,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a center line dimension by two lines or two points.

By two lines: should be the same type, one is a straight line, the other must be a straight line; one is a arc or a circle, the other must be a arc or circle;

By two points: any point; default value: svxCenterDim cmSize : 4.254534 breakLen : 1.5 overRun : 3.06324 scaleFac : 1

Note
Interface cvxDwgCenterLineDimAddInit() can initialize variables of this function.
Parameters
[in] | pzCenterLine | info of two lines or two points
[out] | idDim | id of dim (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenterLineDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenterLineDimAddInit()

evxErrors cvxDwgCenterLineDimAddInit ( svxCenterLine * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgCenterLineDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Center Line data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenterMarkDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenterMarkDimAdd()

evxErrors cvxDwgCenterMarkDimAdd | ( | const svxCenterMark * | pzCenterMark,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Center dimension with specify coordinate.

default value:
   svxCenterDim
      cmSize   : 4.254534
      breakLen : 1.5
      overRun  : 3.06324
      scaleFac : 1
Note
Interface cvxDwgCenterMarkDimAddInit() can initialize variables of this function.
Parameters
[in] | pzCenterMark | id of the first entity
[out] | idDim | id of dim (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCenterMarkDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgCenterMarkDimAddInit()

evxErrors cvxDwgCenterMarkDimAddInit ( svxCenterMark * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgCenterMarkDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Center Mark data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgContinuousDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgContinuousDimAdd()

evxErrors cvxDwgContinuousDimAdd | ( | const svxDwgLineGrpDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Continuous dimension between the specified object in drawing.

pData->sub.cons.type is set by evxDimLineType, as follows:
VX_DIM_LINE_LH – horizontal
VX_DIM_LINE_LV – vertical
VX_DIM_LINE_LA – aligned
VX_DIM_LINE_LR – rotated
VX_DIM_LINE_LP – projected

Parameters
[in] | pData | data of Continuous dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgDatumDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgDatumDimAdd()

evxErrors cvxDwgDatumDimAdd | ( | const svxDatumDimData * | datumData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a datum dimension for the specified entity in drawing.

Parameters
[in] | datumData | datum input data
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgDatumTargDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgDatumTargDimAdd()

evxErrors cvxDwgDatumTargDimAdd | ( | const svxDatumTargDimData * | datumTData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a datum target dimension for the specified entity in drawing.

Note
Interface cvxDwgDatumTargDimAddInit() can initialize variables of this function.
Parameters
[in] | datumTData | datum target input data
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgDatumTargDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgDatumTargDimAddInit()

evxErrors cvxDwgDatumTargDimAddInit ( svxDatumTargDimData * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgDatumTargDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data datum target dim data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgFtrCtrlDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgFtrCtrlDimAdd()

evxErrors cvxDwgFtrCtrlDimAdd | ( | const svxDwgFtrCtrl * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a feature control dimension for the specified entity in drawing.

Parameters
[in] | pData | data of feature control dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHoleCallOutDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgHoleCallOutDimAdd()

evxErrors cvxDwgHoleCallOutDimAdd | ( | const svxDwgHoleCallOutDim * | pData,
 |  | int * | numDim,
 |  | int ** | idDims
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Hole Callout dimension between the specified holes in drawing. pData->iCalloutemt is set by evxCalloutEmt combined Memory for the idDims is allocated by this function. The calling procedure is responsible to free the memory

Note
Interface cvxDwgHoleCallOutDimAddInit() can initialize variables of this function.
Parameters
[in] | pData | data of hole callout dimension
[out] | numDim | number of resulting dimension (NULL to ignore)
[out] | idDims | id of list of id's of resulting dimension (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACt_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHoleCallOutDimAddinit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgHoleCallOutDimAddinit()

evxErrors cvxDwgHoleCallOutDimAddinit ( svxDwgHoleCallOutDim * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgHoleCallOutDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Hole Callout data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHoleMark

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgHoleMark()

evxErrors cvxDwgHoleMark ( const svxDwgHoleMark * data )

#include <zwapi_cmd_dwg_dimension.h>

Use this function to mark holes in drawing sheet.

Note
Interface cvxDwgHoleMarkInit() can initialize variables hole mark of this function.
Parameters
[in] data data of hole mark
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgHoleMarkInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgHoleMarkInit()

evxErrors cvxDwgHoleMarkInit | ( | evxDwgHoleMarkType | type,
 |  | svxDwgHoleMark * | data
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Initialize the svxDwgHoleMark structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | drawing sheet hole mark type
[out] | data | drawing sheet hole mark data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgInsertSymbol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgInsertSymbol()

evxErrors cvxDwgInsertSymbol | ( | const vxLongPath | fileName,
 |  | const vxLongName | symName,
 |  | svxPoint2 * | pnt,
 |  | int * | symId
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Insert the symbol of specified file to current file. Output the new symbol id if "symId" is not NULL.

The "symName" can be inquired by cvxRootInqSymbol().

Parameters
[in] | fileName | file name of specified symbol
[in] | symName | name of symbol
[in] | pnt | insert position
[out] | symId | symbol id (pass in NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgIsectSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgIsectSym()

evxErrors cvxDwgIsectSym | ( | const svxDwgIsectSym * | data,
 |  | int * | idSym
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Use this function to create drawing sheet intersection symbol.

Parameters
[in] | data | intersection symbol input data
[out] | idSym | id of drawing sheet intersection symbol feature (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLabelCoorDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLabelCoorDimAdd()

evxErrors cvxDwgLabelCoorDimAdd | ( | const svxLabelCoorDimData * | coorDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a label coordinate dimension for the specified entity in drawing.

Parameters
[in] | coorDimData | label coordinate dimension input data
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLabelDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLabelDimAdd()

evxErrors cvxDwgLabelDimAdd | ( | const svxDimLabel * | pLabel,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a label dimension.

Parameters
[in] | pLabel | information needed by creating dimension label
[out] | idDim | id of Dim (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLineDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLineDimAdd()

evxErrors cvxDwgLineDimAdd | ( | const svxDwgLineDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Linear dimension between the specified obj in drawing.

pData->cons.type is set by evxDimLineType, as follows:
VX_DIM_LINE_LH – horizontal
VX_DIM_LINE_LV – vertical
VX_DIM_LINE_LA – aligned
VX_DIM_LINE_LR – rotated
VX_DIM_LINE_LP – projected

Parameters
[in] | pData | data of line dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLineOffsetDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLineOffsetDimAdd()

evxErrors cvxDwgLineOffsetDimAdd | ( | const svxDwgLineOffsetDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Linear offset dimension between the specified two entities in drawing. Supported entities include two lines, a point and a line

type of pData is as follows by evxDimLineOffset:
VX_DIM_OFFSET_LOL offset dimension - line to line
VX_DIM_OFFSET_LOP offset dimension - line to point

Parameters
[in] | pData | data of LineOffset dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLnrChmDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLnrChmDimAdd()

evxErrors cvxDwgLnrChmDimAdd | ( | const svxDwgLnrChmDimData * | DimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a linear chamfer dimension in sheeting. dimInfo must initialize before use.

Note
Interface cvxDwgLnrChmDimAddInit() can initialize variables of this function.
Parameters
[in] | DimData | the information of linear chamfer dim which will create
[out] | idDim | id of the linear chamfer dim (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INPUT_TYPE_eRROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgLnrChmDimAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgLnrChmDimAddInit()

evxErrors cvxDwgLnrChmDimAddInit ( svxDwgLnrChmDimData * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgLnrChmDimAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data the info of the linear chamfer dim
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgOrdinateDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgOrdinateDimAdd()

evxErrors cvxDwgOrdinateDimAdd | ( | const svxDwgOrdinateDim * | pData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a Ordinate dimension between the specified object in drawing.

pData->sub.cons.type is set by evxDimLineType, as follows:
VX_DIM_LINE_LH – horizontal
VX_DIM_LINE_LV – vertical
VX_DIM_LINE_LA – aligned
VX_DIM_LINE_LR – rotated
VX_DIM_LINE_LP – projected
VX_DIM_LINE_LO – ordinate

Parameters
[in] | pData | data of Ordinate dimension
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgRadDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgRadDimAdd()

evxErrors cvxDwgRadDimAdd | ( | const svxRadDimData * | radDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a radial or diametric dimension for the specified entity in drawing.

Parameters
[in] | radDimData | radial or diametric input data
[out] | idDim | id of the dimension created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgStkBlnAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgStkBlnAdd()

evxErrors cvxDwgStkBlnAdd | ( | const svxDwgStkBlnData * | stkBlnData,
 |  | int * | idDimCount,
 |  | int ** | idDimList
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create stack balloons in sheeting.

Note
Interface cvxDwgStkBlnAddInit() can initialize variables of this function.
Parameters
[in] | stkBlnData | information of creating stack balloons
[out] | idDimCount | number of stacked balloon dim id (input NULL to ignore)
[out] | idDimList | list of stacked balloon dim id (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_aPI_INPUT_TYPE_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgStkBlnAddInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgStkBlnAddInit()

evxErrors cvxDwgStkBlnAddInit ( svxDwgStkBlnData * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgStkBlnAdd().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data information of creating stack balloons
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymImgNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymImgNew()

evxErrors cvxDwgSymImgNew | ( | svxSymImg * | data,
 |  | int | embed,
 |  | int | locked,
 |  | int * | idSymImg
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Creates a new image with the symbol image data.

If the "locked" of data is true, the width and the height's aspect ratio should be the same as the image. The width and the height can also be zero and it will be calculated based on the input points.

if idSymImg != NULL, output the id of new image.

Note
Interface cvxDwgSymImgNewInit() can initialize variables of this function.
Parameters
[in] | data | symbol image data
[in] | embed | 1-embed image file,0 not
[in] | locked | 1-lock aspect ratio,0 not
[out] | idSymImg | image id (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INVALID_PATH
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymImgNewInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymImgNewInit()

evxErrors cvxDwgSymImgNewInit ( svxSymImg * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgSymImgNew().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data image symbol data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymmetryDimAdd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymmetryDimAdd()

evxErrors cvxDwgSymmetryDimAdd | ( | const svxDwgSymmetryDimData * | symmetryDimData,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Create a symmetry dimension in a drawing sheet.

Parameters
[in] | symmetryDimData | symmetry dimension input data
[out] | idDim | id of the symmetry dimension (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_AIP_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgDimTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymSurfNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymSurfNew()

evxErrors cvxDwgSymSurfNew | ( | int | idEnt,
 |  | svxPoint2 * | refPoint,
 |  | const svxSymSurf * | data,
 |  | int * | idSymSurf
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Creates a surface finish symbol with specified data.

Note
Interface cvxDwgSymSurfNewInit() can initialize variables of this function.
Parameters
[in] | idEnt | id of the parent entity of the reference point (0 to ignore)
[in] | refPoint | coordinate of the reference point
[in] | data | surface finish symbol data
[out] | idSymSurf | index of new symbol (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymSurfNewInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymSurfNewInit()

evxErrors cvxDwgSymSurfNewInit ( svxSymSurf * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgSymSurfNew().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data surface finish symbol data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymWeldNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymWeldNew()

evxErrors cvxDwgSymWeldNew | ( | int | idEnt,
 |  | svxPoint2 * | refPoint,
 |  | const svxSymWeld * | data,
 |  | int * | idSymWeld
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Creates a standard weld symbol with specified data.

Note
Interface cvxDwgSymWeldNewInit() can initialize variables of this function.
Parameters
[in] | idEnt | id of the parent entity of the reference point (0 to ignore)
[in] | refPoint | coordinate of the reference point
[in] | data | weld symbol data
[out] | idSymWeld | index of new symbol (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgSymWeldNewInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgSymWeldNewInit()

evxErrors cvxDwgSymWeldNewInit ( svxSymWeld * data )

#include <zwapi_cmd_dwg_dimension.h>

Initialize the parameters of the cvxDwgSymWeldNew().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data weld symbol data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgUserSymNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Dimension Commands
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ cvxDwgUserSymNew()

evxErrors cvxDwgUserSymNew | ( | int | count,
 |  | int * | idEnt,
 |  | svxPoint2 * | BasePnt,
 |  | const vxRootName | Name,
 |  | int * | idBlock
 | ) |  |

#include <zwapi_cmd_dwg_dimension.h>

Use this function to save a group of entities to the active symbol library for later use. if BasePnt is NULL, the function will use the first critical point of the first entity to make up the user symbol as the reference point, see the function description of cvxEntPnt() for detail of the critical point.

All user symbol blocks can be inquired by cvxRootInqSymbol().

Parameters
[in] | count | number of entities that make up the user symbol
[in] | idEnt | list of index of entities that make up the user symbol
[in] | BasePnt | reference point (NULL to use the first critical point of the first entity)
[in] | Name | name of new user symbol to create
[out] | idBlock | index of new user symbol (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_NAME
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Drawing Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Drawing Commands
Commands Creation » Drawing Commands

Detailed Description

THE MODULE FOR THE ZW3D Drawing Command of Drawing API

Drawing

evxErrors | cvxDwgCrossHatchInit (svxHatchAttr *data)
evxErrors | cvxDwgCrossHatch (int countEnts, int *idEnts, int countPnts, svxPoint2 *insides, int isSplit, svxHatchAttr *hatch, int *idEnt)

Basic Editing

evxErrors | cvxDwgEntMovePntToPnt (int idEnt, svxPoint2 *Start, svxPoint2 *End, evxDrawingMoveDirType type, double angle, double scale)
evxErrors | cvxDwgEntMoveAlongDirection (int idEnt, svxVector2 *Direction, double Distance, svxPoint2 *BasePoint, double angle, double scale)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCrossHatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands
cvxDwgCrossHatch
cvxDwgCrossHatchInit
cvxDwgEntMoveAlongDirection
cvxDwgEntMovePntToPnt

◆ cvxDwgCrossHatch()

evxErrors cvxDwgCrossHatch | ( | int | countEnts,
 |  | int * | idEnts,
 |  | int | countPnts,
 |  | svxPoint2 * | insides,
 |  | int | isSplit,
 |  | svxHatchAttr * | hatch,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_dwg_drawing.h>

This function creates a hatch pattern within a boundary.

Note
Interface cvxDwgCrossHatchInit() initializes the svxHatchAttr structure.
Parameters
[in] | countEnts | count of "idEnts"
[in] | idEnts | list of entity id
[in] | countPnts | count of "insides"
[in] | insides | list of point
[in] | isSplit | 1 if split boundary ,else 0
[in] | hatch | hatch attributes (NULL to use default)
[out] | idEnt | id of hatch (NULL to ignore).idEnt=0 means that it was not created successfully.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgCrossHatchInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands
cvxDwgCrossHatch
cvxDwgCrossHatchInit
cvxDwgEntMoveAlongDirection
cvxDwgEntMovePntToPnt

◆ cvxDwgCrossHatchInit()

evxErrors cvxDwgCrossHatchInit ( svxHatchAttr * data )

#include <zwapi_cmd_dwg_drawing.h>

Initialize the parameters of the cvxDwgCrossHatch().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data hatch attributes(drawing)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgEntMoveAlongDirection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands
cvxDwgCrossHatch
cvxDwgCrossHatchInit
cvxDwgEntMoveAlongDirection
cvxDwgEntMovePntToPnt

◆ cvxDwgEntMoveAlongDirection()

evxErrors cvxDwgEntMoveAlongDirection | ( | int | idEnt,
 |  | svxVector2 * | Direction,
 |  | double | Distance,
 |  | svxPoint2 * | BasePoint,
 |  | double | angle,
 |  | double | scale
 | ) |  |

#include <zwapi_cmd_dwg_drawing.h>

The specified entity within the active drawing moves "Distance" distance in the direction of "Direction".

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | idEnt | id of entity to move
[in] | Direction | direction
[in] | Distance | distance
[in] | BasePoint | base point
[in] | angle | angle
[in] | scale | scale
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgEntMovePntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands
cvxDwgCrossHatch
cvxDwgCrossHatchInit
cvxDwgEntMoveAlongDirection
cvxDwgEntMovePntToPnt

◆ cvxDwgEntMovePntToPnt()

evxErrors cvxDwgEntMovePntToPnt | ( | int | idEnt,
 |  | svxPoint2 * | Start,
 |  | svxPoint2 * | End,
 |  | evxDrawingMoveDirType | type,
 |  | double | angle,
 |  | double | scale
 | ) |  |

#include <zwapi_cmd_dwg_drawing.h>

Moves the specified entity within the active drawing from one point "Start" to another "End".

Note
Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.
Parameters
[in] | idEnt | id of entity to move
[in] | Start | start point
[in] | End | end point
[in] | type | direction type
[in] | angle | angle
[in] | scale | scale
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Layout Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Layout Commands
Commands Creation » Drawing Commands

Detailed Description

THE MODULE FOR THE ZW3D Layout of Drawing API

View

evxErrors | cvxDwgViewLayoutInit (svxViewLayoutData *data)
evxErrors | cvxDwgViewLayout (svxViewLayoutData *data)
evxErrors | cvxDwgViewStandardInit (svxViewStandardData *data)
evxErrors | cvxDwgViewStandard (const svxViewStandardData *data, int *idView)
evxErrors | cvxDwgViewProjection (int idBaseView, svxPoint2 *location, int Projection, int DimType, svxViewAt *ViewAttr, int *idProjView)
evxErrors | cvxDwgViewAuxiliaryInit (svxAuxViewData *data)
evxErrors | cvxDwgViewAuxiliary (const svxAuxViewData *auxViewData, int *idView)
evxErrors | cvxDwgViewFullSectionInit (svxFulSecViewData *data)
evxErrors | cvxDwgViewFullSection (const svxFulSecViewData *fulSecViewData, int *idView)
evxErrors | cvxDwgViewAlignedSectionInit (svxAlignSecViewData *data)
evxErrors | cvxDwgViewAlignedSection (const svxAlignSecViewData *alignSecViewData, int *idView)
evxErrors | cvxDwgViewBrokenSectionInit (svxDwgBrokenSectionData *data)
evxErrors | cvxDwgViewBrokenSection (svxDwgBrokenSectionData *data, int *idView)
evxErrors | cvxDwgViewDetailInit (svxDwgDetailData *data)
evxErrors | cvxDwgViewDetail (const svxDwgDetailData *data, int *idView)
evxErrors | cvxDwgViewBrkLineInit (svxBrkLineData *data)
evxErrors | cvxDwgViewBrkLine (const svxBrkLineData *brkLineInfo, int *brkLnViewId)

Table

evxErrors | cvxDwgTableBomInit (svxDwgBom *data)
evxErrors | cvxDwgTableBom (const svxDwgBom *pData, int *idTbl)
evxErrors | cvxDwgTableInsert (const svxDwgTblInsert *pData)
evxErrors | cvxDwgUserTableCreate (const vxName name, int iRow, int iCol, svxPoint2 *pnt, int origin, int *idTable)
evxErrors | cvxDwgUserTableCreateByTemplate (const vxName name, const vxLongPath tplPath, svxPoint2 *pnt, int origin, int *idTable)

Edit View

evxErrors | cvxDwgRotateViewinit (svxDwgRotView *data)
evxErrors | cvxDwgRotateView (const svxDwgRotView *pData)
evxErrors | cvxDwgViewRotate (int idView, double angle)
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgRotateView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgRotateView()

evxErrors cvxDwgRotateView ( const svxDwgRotView * pData )

#include <zwapi_cmd_dwg_layout.h>

This function is used to Rotate View.

Note
Interface cvxDwgRotateViewInit() can initialize variables of this function.
Parameters
[in] pData data of Rotate View
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_OBJ_DATA_SET_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgRotateViewinit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgRotateViewinit()

evxErrors cvxDwgRotateViewinit ( svxDwgRotView * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgRotateView().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Rotate View data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableBom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgTableBom()

evxErrors cvxDwgTableBom | ( | const svxDwgBom * | pData,
 |  | int * | idTbl
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

This function is used to create BOM table

Note
Interface cvxDwgTableBomInit() can initialize variables of this function.
Parameters
[in] | pData | data of BOM
[out] | idTbl | id of BOM table (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableBomInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgTableBomInit()

evxErrors cvxDwgTableBomInit ( svxDwgBom * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgTableBom().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data BOM table data(drawing)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgTableInsert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgTableInsert()

evxErrors cvxDwgTableInsert ( const svxDwgTblInsert * pData )

#include <zwapi_cmd_dwg_layout.h>

This function is used to insert table

Parameters
[in] pData data of table
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OBJ
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgUserTableCreate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgUserTableCreate()

evxErrors cvxDwgUserTableCreate | ( | const vxName | name,
 |  | int | iRow,
 |  | int | iCol,
 |  | svxPoint2 * | pnt,
 |  | int | origin,
 |  | int * | idTable
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create a user table. Output the table id if idTable is not NULL.

Variable origin specifies where the table is inserted, valid values are as follows:

  • origin=0: Top-Left
  • origin=1: Top-Center
  • origin=2: Top-Right
  • origin=3: Mid-Left
  • origin=4: Mid-Center
  • origin=5: Mid-Right
  • origin=6: Bottom-Left
  • origin=7: Bottom-Center
  • origin=8: Bottom-Right
Parameters
[in] | name | table name
[in] | iRow | number of rows
[in] | iCol | number of columns
[in] | pnt | the coordinate of the origin of table
[in] | origin | indicate the insertion position(0-8)
[out] | idTable | id of new table(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgTableTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgUserTableCreateByTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgUserTableCreateByTemplate()

evxErrors cvxDwgUserTableCreateByTemplate | ( | const vxName | name,
 |  | const vxLongPath | tplPath,
 |  | svxPoint2 * | pnt,
 |  | int | origin,
 |  | int * | idTable
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create a user table through a template. Output the table id if idTable is not NULL.

Variable origin specifies where the table is inserted, valid values are as follows:

  • origin=0: Top-Left
  • origin=1: Top-Center
  • origin=2: Top-Right
  • origin=3: Mid-Left
  • origin=4: Mid-Center
  • origin=5: Mid-Right
  • origin=6: Bottom-Left
  • origin=7: Bottom-Center
  • origin=8: Bottom-Right
Parameters
[in] | name | table name
[in] | tplPath | template file full path
[in] | pnt | the coordinate of the origin of table
[in] | origin | indicate the insertion position(0-8)
[out] | idTable | id of new table(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_PATH
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_APPI_WRONG_ROOT_ENV
  • ZW_API_OUT_OF_RANGE
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAlignedSection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewAlignedSection()

evxErrors cvxDwgViewAlignedSection | ( | const svxAlignSecViewData * | alignSecViewData,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create a aligned section view for base view in drawing.

Note
Interface cvxDwgViewAlignedSectionInit() can initialize variables of this function.
Parameters
[in] | alignSecViewData | aligned section view data
[out] | idView | id of the view created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAlignedSectionInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewAlignedSectionInit()

evxErrors cvxDwgViewAlignedSectionInit ( svxAlignSecViewData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewAlignedSection().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data aligned section view data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAuxiliary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewAuxiliary()

evxErrors cvxDwgViewAuxiliary | ( | const svxAuxViewData * | auxViewData,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create an auxiliary view for base view in drawing.

Note
Interface cvxDwgViewAuxiliaryInit() can initialize variables of this function.
Parameters
[in] | auxViewData | auxiliary view data
[out] | idView | id of the view created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewAuxiliaryInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewAuxiliaryInit()

evxErrors cvxDwgViewAuxiliaryInit ( svxAuxViewData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewAuxiliary().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Auxiliary view data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewBrkLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewBrkLine()

evxErrors cvxDwgViewBrkLine | ( | const svxBrkLineData * | brkLineInfo,
 |  | int * | brkLnViewId
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create a break line.

Note
Interface cvxDwgViewBrkLineInit() can initialize variables of this function.
Parameters
[in] | brkLineInfo | information needed when create break line
[out] | brkLnViewId | id of break line that will create (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewBrkLineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewBrkLineInit()

evxErrors cvxDwgViewBrkLineInit ( svxBrkLineData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewBrkLine().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data information we need when create break line
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewBrokenSection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewBrokenSection()

evxErrors cvxDwgViewBrokenSection | ( | svxDwgBrokenSectionData * | data,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

This interface function is broken section. A broken section is a cut-away view of the interior of a part. It is a section view displayed inside a 2D boundary where an existing view of the part has been cut away.

Interface cvxDwgViewBrokenSectionInit() can initialize variables of this function.

Note
| type(evxDwgDepthType)  | The following variables must be defined                                            |
| VX_DEPTH_POINT         | method,idView,bPoints,countBPs,isShow,isDynamicHatch,dPoint,idCrv,dOffset          |
| VX_DEPTH_SECTION_PLANE | method,idView,bPoints,countBPs,isShow,isDynamicHatch,dPoint,dView,oPoints,countOPs |
| VX_DEPTH_3D_NAMED      | method,idView,bPoints,countBPs,isShow,isDynamicHatch,name                          |

| method(evxDwgBndMethod) | the range of values of "countBPs" |
| VX_RECTANGULAR_BOUNDARY |    countBPs == 2                  |
| VX_CIRCULAR_BOUNDARY    |    countBPs == 2                  |
| VX_POLYLINE_BOUNDARY    |    countBPs >= 3                  |
Parameters
[in] | data | broken section data
[out] | idView | id of section view (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewBrokenSectionInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewBrokenSectionInit()

evxErrors cvxDwgViewBrokenSectionInit ( svxDwgBrokenSectionData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewBrokenSection().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Drawing Broken Section input infos
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewDetail

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewDetail()

evxErrors cvxDwgViewDetail | ( | const svxDwgDetailData * | data,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

This function creates a local detail view.

Note
Interface cvxDwgViewDetailInit() can initialize variables of this function.
Parameters
[in] | data | detail data
[out] | idView | id of detail view (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewDetailInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewDetailInit()

evxErrors cvxDwgViewDetailInit ( svxDwgDetailData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewDetail().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Drawing Detail input infos
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewFullSection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewFullSection()

evxErrors cvxDwgViewFullSection | ( | const svxFulSecViewData * | fulSecViewData,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Create a full section view for base view in drawing.

Note
Interface cvxDwgViewFullSectionInit() can initialize variables of this function.
Parameters
[in] | fulSecViewData | full section view data
[out] | idView | id of the view created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
  • ZW_API_INVALID_NAME
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INVALID_OBJ
  • ZW_API_OBJ_DATA_GET_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewFullSectionInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewFullSectionInit()

evxErrors cvxDwgViewFullSectionInit ( svxFulSecViewData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewFullSection().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data full section view data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewLayout

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewLayout()

evxErrors cvxDwgViewLayout ( svxViewLayoutData * data )

#include <zwapi_cmd_dwg_layout.h>

Insert view layout. This function can create a 1 to 7 view layout of a 3D part. This interface is used in the engineering drawing environment.

Note
Interface cvxDwgViewLayoutInit() can initialize variables of this function.
Parameters
[in] data layout setting info
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_OUT_OF_RANGE
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewLayoutInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewLayoutInit()

evxErrors cvxDwgViewLayoutInit ( svxViewLayoutData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewLayout().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data drawing view layout data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewProjection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewProjection()

evxErrors cvxDwgViewProjection | ( | int | idBaseView,
 |  | svxPoint2 * | location,
 |  | int | Projection,
 |  | int | DimType,
 |  | svxViewAt * | ViewAttr,
 |  | int * | idProjView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Insert projection view. This function can create a view projected from another existing 3D layout view. This interface is used in the engineering drawing environment.

Note
The value of "ViewAttr" can be obtained through cvxDwgViewAtGet(). The default value of "ViewAttr" can be obtained through "cvxDwgViewAtGet(-1,ViewAttr)".
Parameters
[in] | idBaseView | id of base view
[in] | location | location of projection view
[in] | Projection | 1 if 1st angle, 2 if 3rd angle
[in] | DimType | 0 if projected, 1 if true
[in] | ViewAttr | view attribute(NULL to use default)
[out] | idProjView | id of projection view (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewRotate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewRotate()

evxErrors cvxDwgViewRotate | ( | int | idView,
 |  | double | angle
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Rotate the view with specify angle.

Parameters
[in] | idView | id of view
[in] | angle | degree angle
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INPUT_TYPE_ERROR
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewStandard

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewStandard()

evxErrors cvxDwgViewStandard | ( | const svxViewStandardData * | data,
 |  | int * | idView
 | ) |  |

#include <zwapi_cmd_dwg_layout.h>

Insert Standard View. Use this function to create a standard orthographic layout view from a 3D part. If the part has named views created using the View Manager, they can also be inserted as a standard view. This interface is used in the engineering drawing environment.

Note
Interface cvxDwgViewStandardInit() can initialize variables of this function.
Parameters
[in] | data | standard setting info
[out] | idView | id of standard view(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_eXEC_ERROR
  • ZW_API_OUT_OF_RANGE
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: cvxDwgViewStandardInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layout Commands
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ cvxDwgViewStandardInit()

evxErrors cvxDwgViewStandardInit ( svxViewStandardData * data )

#include <zwapi_cmd_dwg_layout.h>

Initialize the parameters of the cvxDwgViewStandard().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data drawing view standard data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
drawing\dwgViewTest.cpp.
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Sketch Commands
Commands Creation

Detailed Description

Modules

Sketch Apps
Sketch Commands Data
Sketch Commands
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Apps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Apps
Commands Creation » Sketch Commands

Detailed Description

THE MODULE FOR THE ZW3D Sketch App API It contains the interfaces of the third-party functions expected to be hung in the sketch environment. These interface need to be authorized to use.

Nesting

evxErrors | cvxSkNestingProfileDataInit (svxSkNestingProfileData *data)
evxErrors | cvxSkNestingBlankDataInit (svxSkNestingBlankData *data)
evxErrors | cvxSkNestingInit (svxSkNestingData *data)
evxErrors | cvxSkNesting (const svxSkNestingData *data)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNesting

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Apps
cvxSkNesting
cvxSkNestingBlankDataInit
cvxSkNestingInit
cvxSkNestingProfileDataInit

◆ cvxSkNesting()

evxErrors cvxSkNesting ( const svxSkNestingData * data )

#include <zwapi_cmd_sk_app.h>

Nesting can directly pick any loop enclosed geometries as Nesting Profiles and Blank to calculate nesting, the result include a sketch block and a report file in HTML format.

Users can use cvxSkNestingProfileDataInit() and cvxSkNestingBlankDataInit() to initialize the structures svxSkNestingProfileData and svxSkNestingBlankData respectively.

Then use cvxSkNestingInit() to initialize the structure svxSkNestingData.This interface will not allocate space for the points in the structure, so the users need toassign values to the sub structure pointers in the structure.

Note
Nesting command needs a specified dongle key inserted into user's PC to activate before starting.
Parameters
[in] data nesting data of sketch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_LICENSE_NESTING_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNestingBlankDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Apps
cvxSkNesting
cvxSkNestingBlankDataInit
cvxSkNestingInit
cvxSkNestingProfileDataInit

◆ cvxSkNestingBlankDataInit()

evxErrors cvxSkNestingBlankDataInit ( svxSkNestingBlankData * data )

#include <zwapi_cmd_sk_app.h>

Initialize the structure svxSkNestingBlankData.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data blank data of sketch nesting.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNestingInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Apps
cvxSkNesting
cvxSkNestingBlankDataInit
cvxSkNestingInit
cvxSkNestingProfileDataInit

◆ cvxSkNestingInit()

evxErrors cvxSkNestingInit ( svxSkNestingData * data )

#include <zwapi_cmd_sk_app.h>

Initialize the parameters of the cvxSkNesting().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data nesting data of sketch.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNestingProfileDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Apps
cvxSkNesting
cvxSkNestingBlankDataInit
cvxSkNestingInit
cvxSkNestingProfileDataInit

◆ cvxSkNestingProfileDataInit()

evxErrors cvxSkNestingProfileDataInit ( svxSkNestingProfileData * data )

#include <zwapi_cmd_sk_app.h>

Initialize the structure svxSkNestingProfileData.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data profile data of sketch nesting.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Commands Data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Commands Data
Commands Creation » Sketch Commands

Detailed Description

Interface data corresponding to the functions in the app module in the sketch.

THE MODULE FOR THE ZW3D Data Types and Structures of the All Commands of Sketch functions.

Drawing Data

enum evxSkAxisMethods {
VX_SK_AXIS_TWO_PNT = 0 , VX_SK_AXIS_PARAPT = 1 , VX_SK_AXIS_PERPENDICULAR = 2 , VX_SK_AXIS_ANGLE = 3 ,
VX_SK_AXIS_PARAOFF = 4 , VX_SK_AXIS_HORIZ = 5 , VX_SK_AXIS_VERT = 6
}
Create Sketch Axis Methods. More...
enum | evxReadyTextMethods { VX_ON_CRV = 1 , VX_BOX = 2 }
Create Sketch ready text Methods. More...
enum evxSkNgonsType {
VX_SK_NGONS_IN_R , VX_SK_NGONS_CIR_R , VX_SK_NGONS_SIDE_LEN , VX_SK_NGONS_IN_BOUND ,
VX_SK_NGONS_CIR_BOUND , VX_SK_NGONS_SIDE_BOUND
}
sketch polygon method More...
enum | evxSkRefMethod { VX_SK_REF_PROJECTION , VX_SK_REF_INTERSECTION }
sketch reference geometry method More...
enum | evxSkRefOption { VX_SK_REF_SINGLE , VX_SK_REF_CHAIN , VX_SK_REF_LOOPS , VX_SK_REF_POINT }
sketch reference type More...
enum | evxSkChainOption { VX_SK_CHAIN_PICK , VX_SK_CHAIN_BETWEEN_PICKS }
sketch reference chain option More...
enum evxSkLoopOption {
VX_SK_LOOP_ALL , VX_SK_LOOP_BOUNDARY , VX_SK_LOOP_SHARED , VX_SK_LOOP_INNER ,
VX_SK_LOOP_OUTER , VX_SK_LOOP_OPEN_BOUNDARY , VX_SK_LOOP_NON_SHARED_BOUNDARY , VX_SK_LOOP_SILHOUETTE
}
sketch reference loop option More...
typedef enum evxSkAxisMethods | evxSkAxisMethods
Create Sketch Axis Methods.
typedef struct svxSkAxisData | svxSkAxisData
data of sketch Axis
typedef struct svxEllipse | svxEllipse
data of ellipse
typedef enum evxReadyTextMethods | evxReadyTextMethods
Create Sketch ready text Methods.
typedef struct svxReadyText | svxReadyText
data of ready sketch text
typedef enum evxSkNgonsType | evxSkNgonsType
sketch polygon method
typedef struct svxSkNgons | svxSkNgons
sketch polygon data
typedef enum evxSkRefMethod | evxSkRefMethod
sketch reference geometry method
typedef enum evxSkRefOption | evxSkRefOption
sketch reference type
typedef enum evxSkChainOption | evxSkChainOption
sketch reference chain option
typedef enum evxSkLoopOption | evxSkLoopOption
sketch reference loop option
typedef struct svxSkRefData | svxSkRefData
sketch reference geometry data

Edit Curve Data

enum | evxConic3PntType { VX_CONIC_SHOULDER = 0 , VX_CONIC_TANGENT = 1 }
3 Point Conic type More...
enum | evxSkChamferOpt { VX_CHMOPT_SETBACK = 0 , VX_CHMOPT_TWOSETBACK , VX_CHMOPT_SETBACKANDDIS }
option of chamfer in sheeting or sketch More...
enum | evxSkChamferTrimOpt { VX_CHMTRIM_NO = 0 , VX_CHMTRIM_BOTH , VX_CHMTRIM_FIRST , VX_CHMTRIM_SECOND }
option of trim in chamfer/fillet of sheeting or sketch More...
enum | evxSkChamferExtenOpt { VX_CHMEXT_LINEAR = 1 , VX_CHMEXT_CIRCULAR , VX_CHMEXT_REFLECT }
control the path of extended curves in chamfer/fillet of sheeting or sketch More...
enum | evxTrimExtension { VX_EXT_LINEAR = 1 , VX_EXT_ARC , VX_EXT_REFLECT , VX_EXT_CRV_DIM }
trim/extend extension method More...
enum | evxTrimSplit { VX_SPLIT_KEEP , VX_SPLIT_DELETE , VX_SPLIT_BREAK }
trim/extend extension method More...
enum | evxTrimSplitCor { VX_SPLIT_COR_LINEAR , VX_SPLIT_COR_ARC , VX_SPLIT_COR_REFLECT }
trim/split to corner option method More...
typedef enum evxConic3PntType | evxConic3PntType
3 Point Conic type
typedef struct svxConic3ptData | svxConic3ptData
3 Point Conic command data
typedef enum evxSkChamferOpt | evxSkChamferOpt
option of chamfer in sheeting or sketch
typedef enum evxSkChamferTrimOpt | evxSkChamferTrimOpt
option of trim in chamfer/fillet of sheeting or sketch
typedef enum evxSkChamferExtenOpt | evxSkChamferExtenOpt
control the path of extended curves in chamfer/fillet of sheeting or sketch
typedef struct svxSkFilletData | svxSkFilletData
information of fillet in sheeting or sketch
typedef struct svxSkChamferData | svxSkChamferData
information of chamfer in sheeting or sketch
typedef enum evxTrimExtension | evxTrimExtension
trim/extend extension method
typedef enum evxTrimSplit | evxTrimSplit
trim/extend extension method
typedef enum evxTrimSplitCor | evxTrimSplitCor
trim/split to corner option method
typedef struct svxSkPowerTrim | svxSkPowerTrim
sketch power trim data
typedef struct svxSkTrimExt | svxSkTrimExt
sketch trim or extend data
typedef struct svxSkTrimSplit | svxSkTrimSplit
sketch trim or split data
typedef struct svxSkTrimSplitPnt | svxSkTrimSplitPnt
sketch trim or split at point data
typedef struct svxSkTrimSplitCor | svxSkTrimSplitCor
sketch trim or split to corner data
typedef struct svxSkSplitIsect | svxSkSplitIsect
sketch split at intersection data

Constraint Data

enum evxGeomConsSubType {
VX_SK_CONS_XY_COORDS_CONS = 0 , VX_SK_CONS_X_COORD_CONS , VX_SK_CONS_Y_COORD_CONS , VX_SK_PNT_TO_ARC_MIDPNT_CONS ,
VX_SK_PNTS_SYMMETRY_CONS
}
sub type of sketch geometry constraint More...
enum evxGeomConsType {
VX_SK_CONS_UNKNOWN , VX_SK_CONS_FIX , VX_SK_CONS_ALI_Y , VX_SK_CONS_ALI_X ,
VX_SK_CONS_MID , VX_SK_CONS_ON_CRV , VX_SK_CONS_ISECT , VX_SK_CONS_COIN ,
VX_SK_CONS_HOR , VX_SK_CONS_VER , VX_SK_CONS_SYM , VX_SK_CONS_PERP ,
VX_SK_CONS_PARA , VX_SK_CONS_COLINLN , VX_SK_CONS_TANG , VX_SK_CONS_EQL_LEN ,
VX_SK_CONS_EQL_CURVATURE , VX_SK_CONS_CONC , VX_SK_CONS_EQL_RAD , VX_SK_CONS_SYM_DST ,
VX_SK_CONS_SYM_ANG , VX_SK_CONS_PTN , VX_SK_CONS_OFFSET
}
type of sketch geometry constraint More...
typedef struct svxConsGeom | svxConsGeom
data of sketch geometry constraint object
typedef enum evxGeomConsSubType | evxGeomConsSubType
sub type of sketch geometry constraint
typedef enum evxGeomConsType | evxGeomConsType
type of sketch geometry constraint

Dimension Data

enum evxConsDimType {
VX_SK_CONSDIM_UNKNOW = -1 , VX_SK_CONSDIM_LINEAR , VX_SK_CONSDIM_LINEAR_OFFSET , VX_SK_CONSDIM_ANGULAR ,
VX_SK_CONSDIM_RADIAL , VX_SK_CONSDIM_ARC_LENGTH , VX_SK_CONSDIM_SYMMETRY , VX_SK_CONSDIM_PERIMETER
}
type of sketch constraint dimension More...
typedef enum evxConsDimType | evxConsDimType
type of sketch constraint dimension
typedef struct svxConsDim | svxConsDim
data of constraint dimension
typedef struct svxPerimeterDimData | svxPerimeterDimData
data of perimeter dimension

Basic Editing Data

enum | evxMoveType2D { VX_PNT_TO_PNT_2D , VX_ALONG_DIR_2D }
Move and Copy Methods(2D) More...
enum | evxDrawingMoveDirType { VX_DRAWING_TWOPOINTS , VX_DRAWING_HORIZONTAL , VX_DRAWING_VERTICAL }
Sketch/Drawing move direction type. More...
enum | evxRotateType { VX_ROTATE_ANGLE = 0 , VX_ROTATE_POINTS }
rotate type More...
enum | evxRotateSetting { VX_ROTATE_MOVE = 1 , VX_ROTATE_COPY }
rotate setting More...
enum | evxSkPatternType { VX_SKPATTERN_LINEAR , VX_SKPATTERN_CIRCULAR , VX_SKPATTERN_AT_CURVES }
sketch pattern method More...
enum | evxSkSpacingType { VX_NUMBER_PITCH , VX_NUMBER_SPAN , VX_PITCH_SPAN }
sketch pattern spacing method More...
enum | evxSkCopyType { VX_SK_COPY_PNT , VX_SK_COPY_DIR }
sketch copy method More...
enum | evxSkCopyDir { VX_SK_COPY_DIR_TWO , VX_SK_COPY_DIR_HORIZONTAL , VX_SK_COPY_DIR_VERTICAL }
sketch copy from point to point direction method More...
typedef enum evxMoveType2D | evxMoveType2D
Move and Copy Methods(2D)
typedef struct svxAlongDir2D | svxAlongDir2D
copy/move entities along a direction (2D)
typedef enum evxDrawingMoveDirType | evxDrawingMoveDirType
Sketch/Drawing move direction type.
typedef struct svxMovePntToPnt2D | svxMovePntToPnt2D
copy/move entities form point to point (2D)
typedef struct svxMoveData2D | svxMoveData2D
template command Move data(2D)
typedef enum evxRotateType | evxRotateType
rotate type
typedef enum evxRotateSetting | evxRotateSetting
rotate setting
typedef struct svxRotateData2D | svxRotateData2D
template command Rotate data
typedef struct svxMirrData2D | svxMirrData2D
template command Mirror data(2D)
typedef enum evxSkPatternType | evxSkPatternType
sketch pattern method
typedef enum evxSkSpacingType | evxSkSpacingType
sketch pattern spacing method
typedef struct svxSkPtnData | svxSkPtnData
sketch pattern data
typedef enum evxSkCopyType | evxSkCopyType
sketch copy method
typedef enum evxSkCopyDir | evxSkCopyDir
sketch copy from point to point direction method
typedef struct svxSkCopy | svxSkCopy
sketch copy data

Sketch App Data

typedef struct svxSkNestingProfileData | svxSkNestingProfileData
profile data of Sketch Nesting
typedef struct svxSkNestingBlankData | svxSkNestingBlankData
blank data of Sketch Nesting
typedef struct svxSkNestingData | svxSkNestingData
Nesting data of sketch.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Sketch Commands

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Sketch Commands
Commands Creation » Sketch Commands

Detailed Description

THE MODULE FOR THE ZW3D All Commands of Sketch API

Drawing

evxErrors | cvxSkLine2pt (svxPoint2 *Start, svxPoint2 *End, int *idEnt)
evxErrors | cvxSkAddPolyline (int cntPnt, svxPoint2 *pnts, int addCns)
evxErrors | cvxSkAxis (const svxSkAxisData *Axis, int *idAxis)
evxErrors | cvxSkCir3pt (svxPoint2 *P1, svxPoint2 *P2, svxPoint2 *P3, int *idEnt)
evxErrors | cvxSkCirRad (svxPoint2 *Center, double Radius, int *idEnt)
evxErrors | cvxSkArc3pt (svxPoint2 *Start, svxPoint2 *End, svxPoint2 *Mid, int *idEnt)
evxErrors | cvxSkArcRad (svxPoint2 *Center, double Radius, double Start, double End, int *idEnt)
evxErrors | cvxSkEllipseInit (svxEllipse *data)
evxErrors | cvxSkEllipse (svxEllipse *ellipse, int *idEnt)
evxErrors | cvxSkPnt (svxPoint2 *Point, int *idEnt)
evxErrors | cvxSkPntsOnCrv (int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
evxErrors | cvxSkReadyTextInit (evxReadyTextMethods method, svxReadyText *data)
evxErrors | cvxSkReadyText (const svxReadyText *RdText, int *idRdText)
evxErrors | cvxEntTextNew (char *String, int Type, svxPoint2 Pnt[2], int *idEnt)
evxErrors | cvxSkNgonsInit (evxSkNgonsType type, svxSkNgons *data)
evxErrors | cvxSkNgons (const svxSkNgons *Spl, int *cnt, int **idEnts)

Curve

evxErrors | cvxSkCrvIntInit (svxCrvIntData *data)
evxErrors | cvxSkCrvInt (svxCrvIntData *Crv, int *idEnt)
evxErrors | cvxSkSplineInit (svxSplineData *data, int count)
evxErrors | cvxSkSpline (const svxSplineData *PntData, int *idEnt)
evxErrors | cvxSkConic3pt (const svxConic3ptData *Data, int *idEnt)
evxErrors | cvxSkConic3ptInit (svxConic3ptData *Data)
evxErrors | cvxSkCrvIntScaleInit (int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)

Edit Curve

evxErrors | cvxSkFilletInit (svxSkFilletData *data)
evxErrors | cvxSkFillet (const svxSkFilletData *filletData, int *idFillet)
evxErrors | cvxSkChamferInit (svxSkChamferData *data)
evxErrors | cvxSkChamfer (const svxSkChamferData *chmData, int *idChamfer)
evxErrors | cvxSkPowerTrim (const svxSkPowerTrim *pwTrim)
evxErrors | cvxSkOneTouchTrim (const svxPntOnEnt *pnt)
evxErrors | cvxSkTrimExtInit (svxSkTrimExt *trimExt)
evxErrors | cvxSkTrimExt (const svxSkTrimExt *trimExt)
evxErrors | cvxSkTrimSplitInit (svxSkTrimSplit *trimSpl)
evxErrors | cvxSkTrimSplitCrv (const svxSkTrimSplit *trimSpl)
evxErrors | cvxSkTrimSplitPnt (const svxSkTrimSplitPnt *trimSpl)
evxErrors | cvxSkTrimSplitCorInit (svxSkTrimSplitCor *trimSpl)
evxErrors | cvxSkTrimSplitCor (const svxSkTrimSplitCor *trimSpl)
evxErrors | cvxSkDelBowties (const int numCrv, const int *idCrv)
evxErrors | cvxSkSplitIsectInit (svxSkSplitIsect *Spl)
evxErrors | cvxSkSplitIsect (const svxSkSplitIsect *Spl)

Constraint

evxErrors | cvxSkAutoCons (svxConsGeom *BasePnt, int Count, int *idEnts)
evxErrors | cvxSkAddGeomCons (evxGeomConsType type, int subType, int nGeoms, svxConsGeom *geoms, int *Count, int **idCons)
evxErrors | cvxSkAutoAddCoinCons (int idSketch)
evxErrors | cvxSkAutoAddCoinConsSkipRefGeom (int idSketch, int skipFlag, int solveFlag)

Dimension

evxErrors | cvxSkAddConsDim (evxConsDimType type, svxConsDim *pData)
evxErrors | cvxSkAddPerimeterDim (svxPerimeterDimData *data, int *idDim)

Reference

evxErrors | cvxSkReferenceInit (svxSkRefData *data)
evxErrors | cvxSkReference (const svxSkRefData *data, int *count, int **idRefEnts)

Basic Editing

evxErrors | cvxSkMoveInit (evxMoveType2D type, svxMoveData2D *data)
evxErrors | cvxSkMove (const svxMoveData2D *data)
evxErrors | cvxSkRotate (const svxRotateData2D *data, int *cnt, int **idEnts)
evxErrors | cvxSkRotateInit (svxRotateData2D *data)
evxErrors | cvxSkMirr (const svxMirrData2D *data, int *cnt, int **idEnts)
evxErrors | cvxSkMirrInit (svxMirrData2D *data)
evxErrors | cvxSkScale (int Count, int *idEnts, double X_scale, double Y_scale, svxPoint2 *Pnt)
evxErrors | cvxSkPtnDataInit (evxSkPatternType type, svxSkPtnData *data)
evxErrors | cvxSkPattern (const svxSkPtnData *Pattern, int *cnt, int **idEnts)
evxErrors | cvxSkCopyInit (evxSkCopyType type, svxSkCopy *data)
evxErrors | cvxSkCopy (const svxSkCopy *Spl, int *cnt, int **idEnts)
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntTextNew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxEntTextNew()

evxErrors cvxEntTextNew | ( | char * | String,
 |  | int | Type,
 |  | svxPoint2 | Pnt[2],
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Creates a new text with the given data. The target bin is sheet or sketch.
The Type include:
1-At point text, one point,
2-Aligned text, two points,
3-Box text, two points

Parameters
[in] | String | string of text
[in] | Type | type of input points
[in] | Pnt[2] | position of text
[out] | idEnt | text id (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAddConsDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAddConsDim()

evxErrors cvxSkAddConsDim | ( | evxConsDimType | type,
 |  | svxConsDim * | pData
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Add the specified constraint dimension with specified data and the type.

The "pData" defined by current command. If the "type" is VX_SK_CONSDIM_LINEAR or VX_SK_CONSDIM_LINEAR_OFFSET, all the data of "pData" should be defined.

If the "type" is VX_SK_CONSDIM_ANGULAR, the data of "pData" should be defined by the type of svxConsDim.

If the "type" is VX_SK_CONSDIM_RADIAL, the second point and second entity don't need to be defined.

If the "type" is VX_SK_CONSDIM_ARC_LENGTH, the second point, second entity and the type of svxConsDim don't need to be defined.

The function does not yet support the creation of type VX_SK_CONSDIM_SYMMETRY and type VX_SK_CONSDIM_PERIMETER dimension.

Parameters
[in] | type | type of constraint dimension
[in] | pData | data of constraint dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAddGeomCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAddGeomCons()

evxErrors cvxSkAddGeomCons | ( | evxGeomConsType | type,
 |  | int | subType,
 |  | int | nGeoms,
 |  | svxConsGeom * | geoms,
 |  | int * | Count,
 |  | int ** | idCons
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Add the specified geometry constraint with specified data and the type. the number of geometry required varies from constraint type, please specify the number and data of constraint geometry based on the specific constraint being created.

The number and order of geometry required for each constraint type is as follows:
VX_SK_CONS_FIX: one point or entity;
VX_SK_CONS_ALI_Y: one reference point and one alignment point;
VX_SK_CONS_ALI_X: one reference point and one alignment point;
VX_SK_CONS_MID: two endpoints and one midpoint;
VX_SK_CONS_ON_CRV: one curve and one alignment point;
VX_SK_CONS_ISECT: two curves and one alignment point;
VX_SK_CONS_COIN: two points;
VX_SK_CONS_HOR: one line;
VX_SK_CONS_VER: one line;
VX_SK_CONS_SYM: one symmetrical axis and two symmetrical points or entities;
VX_SK_CONS_PERP: one line and one curve;
VX_SK_CONS_PARA: two lines;
VX_SK_CONS_COLINLN: two lines;
VX_SK_CONS_TANG: one line and one curve;
VX_SK_CONS_EQL_LEN: two lines;
VX_SK_CONS_EQL_CURVATURE: two curves;
VX_SK_CONS_EQL_RAD: two arcs or circles;
VX_SK_CONS_CONC: one arc or circle and one alignment point;

The calling procedure MUST deallocate the output list.

Parameters
[in] | type | constraint type
[in] | subType | constraint type, only fix constraint, entity symmetrical constraint and point to midpoint constraint need to set the variable (evxGeomConsSubType): 0: both the X and Y coordinates are constrained, used to VX_SK_CONS_FIX 1: only the X coordinate is constrained, used to VX_SK_CONS_FIX 2: only the Y coordinate is constrained, used to VX_SK_CONS_FIX 3: point to arc midpoint constraint, used only VX_SK_CONS_MID 4: mark as points symmetry, used only VX_SK_CONS_SYM,
[in] | nGeoms | number of constraint geometries
[in] | geoms | array of constraint geometries data
[out] | Count | number of constraints generated (NULL to ignore)
[out] | idCons | id of constraints generated (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAddPerimeterDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAddPerimeterDim()

evxErrors cvxSkAddPerimeterDim | ( | svxPerimeterDimData * | data,
 |  | int * | idDim
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to create 2D perimeter dimensions at the sketch.

Parameters
[in] | data | perimeter dimension data
[out] | idDim | id of dimension
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAddPolyline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAddPolyline()

evxErrors cvxSkAddPolyline | ( | int | cntPnt,
 |  | svxPoint2 * | pnts,
 |  | int | addCns
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Create the polyline with the input points.

Parameters
[in] | cntPnt | count of 2D points
[in] | pnts | list of 2D points
[in] | addCns | 1-add constraint, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkArc3pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkArc3pt()

evxErrors cvxSkArc3pt | ( | svxPoint2 * | Start,
 |  | svxPoint2 * | End,
 |  | svxPoint2 * | Mid,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D arc to the active sketch or sheet. If "idEnt" is not NULL, the id of the new arc entity is output.

Parameters
[in] | Start | start point
[in] | End | end point
[in] | Mid | mid (i.e. through) point
[out] | idEnt | id of new 2D arc entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkArcRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkArcRad()

evxErrors cvxSkArcRad | ( | svxPoint2 * | Center,
 |  | double | Radius,
 |  | double | Start,
 |  | double | End,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D circle to the active sketch or sheet. If "idEnt" is not NULL, the id of the new entity is output.

Parameters
[in] | Center | center point (mm)
[in] | Radius | radius (mm)
[in] | Start | start angle (deg - CCW from X axis)
[in] | End | end angle (deg - CCW from X axis)
[out] | idEnt | id of new 2D circle entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAutoAddCoinCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAutoAddCoinCons()

evxErrors cvxSkAutoAddCoinCons ( int idSketch )

#include <zwapi_cmd_sk_cmds.h>

Create coincident constraints for the specified sketch/current active sketch. This function just add the constraints, not solve the constraints.

Parameters
[in] idSketch index of sketch (-1 to use the active sketch)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAutoAddCoinConsSkipRefGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAutoAddCoinConsSkipRefGeom()

evxErrors cvxSkAutoAddCoinConsSkipRefGeom | ( | int | idSketch,
 |  | int | skipFlag,
 |  | int | solveFlag
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Create coincident constraints for the specified sketch/current active sketch.

The difference between this function and cvxSkAutoAddCoinCons() is that this function can skip the reference geometries and solve the constraints.

Parameters
[in] | idSketch | index of sketch (-1 to use the active sketch)
[in] | skipFlag | 1-skip the reference geometries, else 0
[in] | solveFlag | 1-solve the constraints after adding them, else 0
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAutoCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAutoCons()

evxErrors cvxSkAutoCons | ( | svxConsGeom * | BasePnt,
 |  | int | Count,
 |  | int * | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use the function to analyze the current sketch geometry and add constraints and dimensions automatically.

Parameters
[in] | BasePnt | base point (NULL to use the default sketch origin)
[in] | Count | number of entities to add constraints and dimensions (0 for all entities)
[in] | idEnts | list of entities to add constraints and dimensions (NULL for all entities)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • Zw_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkAxis()

evxErrors cvxSkAxis | ( | const svxSkAxisData * | Axis,
 |  | int * | idAxis
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D Axis to the active sketch. If "idAxis" is not NULL, the id of the new entity is output.

Parameters
[in] | Axis | Axis data
[out] | idAxis | id of new 2D Axis entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkChamfer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkChamfer()

evxErrors cvxSkChamfer | ( | const svxSkChamferData * | chmData,
 |  | int * | idChamfer
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Create a chamfer in sheeting or sketch. chmInfo must be initialized before used.

Note
Interface cvxSkChamferInit() can initialize variables of this function.
Parameters
[in] | chmData | information of chamfer in sheeting
[out] | idChamfer | id of chamfer that created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkChamferInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkChamferInit()

evxErrors cvxSkChamferInit ( svxSkChamferData * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkChamfer().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data information of chamfer in sheeting or sketch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCir3pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCir3pt()

evxErrors cvxSkCir3pt | ( | svxPoint2 * | P1,
 |  | svxPoint2 * | P2,
 |  | svxPoint2 * | P3,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D circle to the active sketch or sheet. If "idEnt" is not NULL, the id of the new circle entity is output.

Parameters
[in] | P1 | first point on circle
[in] | P2 | second point on circle
[in] | P3 | third point on circle
[out] | idEnt | id of new 2D circle entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCirRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCirRad()

evxErrors cvxSkCirRad | ( | svxPoint2 * | Center,
 |  | double | Radius,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D circle to the active sketch or sheet. If "idEnt" is not NULL, the id of the new entity is output.

Parameters
[in] | Center | center point (mm)
[in] | Radius | radius (mm)
[out] | idEnt | id of new 2D circle entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_MEMORY_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkConic3pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkConic3pt()

evxErrors cvxSkConic3pt | ( | const svxConic3ptData * | Data,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Add a 3 Point Conic to the active sketch or Drawing.

If "idEnt" is not NULL, the id of the new curve entity is output.

Note
Structure svxConic3ptData can be initialized through interface cvxSkConic3ptInit().
Parameters
[in] | Data | 3 Point Conic data
[out] | idEnt | id of new curve
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkConic3ptInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkConic3ptInit()

evxErrors cvxSkConic3ptInit ( svxConic3ptData * Data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkConic3pt().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] Data 3 Point Conic data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCopy()

evxErrors cvxSkCopy | ( | const svxSkCopy * | Spl,
 |  | int * | cnt,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to create a copy by the input svxSkCopy data.

Note
Interface cvxSkCopyInit() can initialize variables data of this function. The calling procedure MUST deallocate the output list.
Parameters
[in] | Spl | sketch copy input data
[out] | cnt | count of idEnts(can be NULL)
[out] | idEnts | list of new entity id.(can be NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCopyInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCopyInit()

evxErrors cvxSkCopyInit | ( | evxSkCopyType | type,
 |  | svxSkCopy * | data
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkCopy structure.

Parameters
[in] | type | sketch copy type
[out] | data | sketch copy data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCrvInt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCrvInt()

evxErrors cvxSkCrvInt | ( | svxCrvIntData * | Crv,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D curve interpolated through through the input points with the specified degree to the active sketch or sheet. If "idEnt" is not NULL, the id of the new curve entity is output.

The StartScale and EndScale of svxCrvIntData can be initialized through interface cvxSkCrvIntScaleInit() by the interpolated points, or use the default value by cvxSkCrvIntInit(), or set them by yourselves.

Note
Structure svxCrvIntData can be initialized through interface svxCrvIntDataInit().
Parameters
[in] | Crv | input data interpolated curve
[out] | idEnt | id of new 2D interpolated curve entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_OUT_OF_RANGE
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkCrvIntInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkCrvIntInit()

evxErrors cvxSkCrvIntInit ( svxCrvIntData * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkCrvInt().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data 2D interpolated curve data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkDelBowties

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkDelBowties()

evxErrors cvxSkDelBowties | ( | const int | numCrv,
 |  | const int * | idCrv
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to delete the bowties of specific curves.

Parameters
[in] | numCrv | the number of curves
[in] | idCrv | the list id of curves
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkEllipse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkEllipse()

evxErrors cvxSkEllipse | ( | svxEllipse * | ellipse,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D ellipse to the active sketch or sheet. If "idEnt" is not NULL, the id of the new entity is output.

Note
Interface cvxSkEllipseInit() can initialize variables of this function.
Parameters
[in] | ellipse | ellipse data
[out] | idEnt | id of new 2D ellipse entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkEllipseInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkEllipseInit()

evxErrors cvxSkEllipseInit ( svxEllipse * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkEllipse().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data ellipse data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkFillet()

evxErrors cvxSkFillet | ( | const svxSkFilletData * | filletData,
 |  | int * | idFillet
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Create a fillet in sheeting or sketch. filletInfo must be initialized before used.

Note
Interface cvxSkFilletInit() can initialize variables of this function.
Parameters
[in] | filletData | information of fillet in sheeting
[out] | idFillet | id of fillet that created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkFilletInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkFilletInit()

evxErrors cvxSkFilletInit ( svxSkFilletData * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkFillet().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data information of fillet in sheeting or sketch
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkLine2pt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkLine2pt()

evxErrors cvxSkLine2pt | ( | svxPoint2 * | Start,
 |  | svxPoint2 * | End,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D line to the active sketch or sheet. If "idEnt" is not NULL, the id of the new line entity is output.

Parameters
[in] | Start | start point
[in] | End | end point
[out] | idEnt | id of new 2D line entity(NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkMirr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkMirr()

evxErrors cvxSkMirr | ( | const svxMirrData2D * | data,
 |  | int * | cnt,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Mirror the specified entity(entities) within the active 2D environment(drawing of sketch). If "idEnts" is not NULL, the ids of the mirrored entity is output.

Note
Interface cvxSkMirrInit() can initialize variables of this function.
Parameters
[in] | data | mirror data
[out] | cnt | number of Entity ids that created (input NULL to ignore)
[out] | idEnts | id of Entities that created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkMirrInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkMirrInit()

evxErrors cvxSkMirrInit ( svxMirrData2D * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkMirr().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data mirror data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkMove()

evxErrors cvxSkMove ( const svxMoveData2D * data )

#include <zwapi_cmd_sk_cmds.h>

Moves the specified entity(entities) within the active 2D environment(drawing of sketch).

Because this function has an internal call to the "cvxDispRedraw()" function, it must be called on the main thread.

Note
Interface cvxSkMoveInit() can initialize variables of this function.
Parameters
[in] data move data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkMoveInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkMoveInit()

evxErrors cvxSkMoveInit | ( | evxMoveType2D | type,
 |  | svxMoveData2D * | data
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkMove().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | move method
[out] | data | Region set data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNgons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkNgons()

evxErrors cvxSkNgons | ( | const svxSkNgons * | Spl,
 |  | int * | cnt,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to create a polygon by the input svxSkNgons data.

Note
Interface cvxSkNgonsInit() can initialize variables data of this function.
Parameters
[in] | Spl | sketch polygon input data
[out] | cnt | count of idEnts(can be NULL)
[out] | idEnts | list of new entity id.(can be NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkNgonsInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkNgonsInit()

evxErrors cvxSkNgonsInit | ( | evxSkNgonsType | type,
 |  | svxSkNgons * | data
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkNgons structure.

Parameters
[in] | type | sketch polygon type
[out] | data | sketch polygon data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkOneTouchTrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkOneTouchTrim()

evxErrors cvxSkOneTouchTrim ( const svxPntOnEnt * pnt )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim the sketch include the specific point.

Parameters
[in] pnt one touch trim input point
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkPattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkPattern()

evxErrors cvxSkPattern | ( | const svxSkPtnData * | Pattern,
 |  | int * | cnt,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to pattern of sketches patterns. Three different methods of patterning are available, each method requires different types of input.

Note
Interface cvxSkPtnDataInit() can initialize variables Pattern of this function.
Parameters
[in] | Pattern | pattern input data
[out] | cnt | count of idEnts(can be NULL)
[out] | idEnts | list of new entity id.(can be NULL)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
  • ZW_API_OBJ_DATA_GET_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkPnt()

evxErrors cvxSkPnt | ( | svxPoint2 * | Point,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D point entity to the active sketch or drawing.

Parameters
[in] | Point | point coordinate
[out] | idEnt | id of new 2D point entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkPntsOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkPntsOnCrv()

evxErrors cvxSkPntsOnCrv | ( | int | idCrv,
 |  | svxPoint * | Pnt,
 |  | int | Num,
 |  | double | Dist,
 |  | evxExtendOpt | Opt,
 |  | int * | Count,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Creates point entities spaced on and along a curve based on the specified input parameters.

Parameters
[in] | idCrv | id of curve entity in active object
[in] Pnt reference point that specifies which end of the curve to start from;
this input is only necessary if "Dist" is defined (i.e. non-zero);
if this argument is NULL, the geometric start point of the curve will be used if needed.
[in] Num the number of points to create along the curve; if "Dist" is zero, then the specified number of points will be created along the curve with equal spacing between them;
if "Dist" is "non-zero", then "Num" points will be created along the curve with "Dist" as the spacing between each point; in this case, "Pnt" should be input and an extension option should be defined in case the specified number of points at the specified distance exceeds the length of the curve;
if "Num" is input as zero, then "Dist" must be specified; in this case, points are created the specified distance apart, beginning at the end of the curve closest to "Pnt" and ending at/before the other end of the curve.
[in] | Dist | the distance (mm) between points (see description of "Num" argument)
[in] | Opt | extension option is "Dist" is non-zero
[out] | Count | if this argument is not NULL, output the number of points created
[out] idEnts if "Count" is not NULL, and this argument is not NULL, a list of the database id's of the point entities created by this function is output.
Memory for the list is allocated by this function. The calling procedure is responsible to free the memory.
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
  • ZW_API_OUT_OF_RANGE
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkPowerTrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkPowerTrim()

evxErrors cvxSkPowerTrim ( const svxSkPowerTrim * pwTrim )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim the sketch bewteen start point and end point.

Parameters
[in] pwTrim power trim input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkPtnDataInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkPtnDataInit()

evxErrors cvxSkPtnDataInit | ( | evxSkPatternType | type,
 |  | svxSkPtnData * | data
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkPtnData structure.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | type | pattern type
[out] | data | pattern data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReadyText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkReadyText()

evxErrors cvxSkReadyText | ( | const svxReadyText * | RdText,
 |  | int * | idRdText
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a ready sketch text to the active sketch.

Pass in NULL for "idRdText" if the output is not required.

Note
Interface cvxSkReadyTextInit() can initialize variables of this function.
Parameters
[in] | RdText | data of ready sketch text
[out] | idRdText | index of the ready sketch text (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_INVALID_NAME
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReadyTextInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkReadyTextInit()

evxErrors cvxSkReadyTextInit | ( | evxReadyTextMethods | method,
 |  | svxReadyText * | data
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkReadyText().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] | method | ready text method
[out] | data | data of ready sketch text
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_OUT_OF_RANGE
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkReference()

evxErrors cvxSkReference | ( | const svxSkRefData * | data,
 |  | int * | count,
 |  | int ** | idRefEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Use this function to project a curve, face, point or datum located in the active part/component to the sketch plane.

The calling procedure MUST deallocate the output list with cvxMemFree.

Parameters
[in] | data | reference geometry input data
[out] | count | number of reference geometries (NULL to ignore)
[out] | idRefEnts | list of reference geometry id's (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
  • ZW_API_MEMORY_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkReferenceInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkReferenceInit()

evxErrors cvxSkReferenceInit ( svxSkRefData * data )

#include <zwapi_cmd_sk_cmds.h>

Use this function to initialize the parameters of the cvxSkReference().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[in] data reference geometry input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkRotate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkRotate()

evxErrors cvxSkRotate | ( | const svxRotateData2D * | data,
 |  | int * | cnt,
 |  | int ** | idEnts
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Rotate the specified entity(entities) within the active 2D environment(drawing of sketch). If "idEnts" is not NULL and value of Setting is VX_ROTATE_COPY, the ids of the rotate entity is output.

Note
Interface cvxSkRotateInit() can initialize variables of this function.
Parameters
[in] | data | Rotate data
[out] | cnt | number of Entity ids that created (input NULL to ignore)
[out] | idEnts | id of Entities that created (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkRotateInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkRotateInit()

evxErrors cvxSkRotateInit ( svxRotateData2D * data )

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkRotate().

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] data Rotate data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkScale()

evxErrors cvxSkScale | ( | int | Count,
 |  | int * | idEnts,
 |  | double | X_scale,
 |  | double | Y_scale,
 |  | svxPoint2 * | Pnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Scales the specified entities in the active sketch or sheet by the input scale factors relative to the X, Y axes and origin of the active sketch If "Pnt" is not NULL, its coordinates are used as the center of scaling.

Parameters
[in] | Count | number of entities
[in] | idEnts | list of entity id's
[in] | X_scale | X scale factor
[in] | Y_scale | Y scale factor
[in] | Pnt | optional reference point (input NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\basicEditingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkSpline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkSpline()

evxErrors cvxSkSpline | ( | const svxSplineData * | PntData,
 |  | int * | idEnt
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Adds a 2D curve interpolated through through the input points/control points with the specified data to the active sketch or sheet.

If "idEnt" is not NULL, the id of the new curve entity is output.

Note
Structure svxSplineData can be initialized through interface cvxSkSplineInit().
Parameters
[in] | PntData | spline data
[out] | idEnt | id of new 2D spline entity (NULL to ignore)
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkSplineInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkSplineInit()

evxErrors cvxSkSplineInit | ( | svxSplineData * | data,
 |  | int | count
 | ) |  |

#include <zwapi_cmd_sk_cmds.h>

Initialize the parameters of the cvxSkSpline(). If count > 0, this function allocates memory to data->Pnts based on the value of count and initializes the data->Pnts structure. Otherwise data->Pnts will be initialized to NULL.

cvxSplinePntInit() can initialize struct svxSplinePnt (data->Pnts).

If the user needs to clear "data" and count > 0, the cvxMemFree() interface needs to be called to free "data->Pnts" memory.

Note
Do not assign a value to variable "data" before calling this function. The cvxMemZero() is called inside the interface to empty everything.
Parameters
[out] | data | Spline data
[in] | count | count of points
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
  • ZW_API_MEMORY_ERROR
Examples
sketch\skDrawingTest.cpp.
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkSplitIsect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkSplitIsect()

evxErrors cvxSkSplitIsect ( const svxSkSplitIsect * Spl )

#include <zwapi_cmd_sk_cmds.h>

Use this function to split the sketch at intersections by the input svxSkSplitIsect data.

Note
Interface cvxSkSplitIsectInit() can initialize variables Pattern of this function.
Parameters
[in] Spl split at intersections input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkSplitIsectInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkSplitIsectInit()

evxErrors cvxSkSplitIsectInit ( svxSkSplitIsect * Spl )

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkSplitIsect structure.

Parameters
[out] Spl split at intersections input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimExt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimExt()

evxErrors cvxSkTrimExt ( const svxSkTrimExt * trimExt )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim or extend the sketch by the input svxTrimExt data.

Note
Interface cvxSkTrimExtInit() can initialize variables Pattern of this function.
Parameters
[in] trimExt trim/extend input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimExtInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimExtInit()

evxErrors cvxSkTrimExtInit ( svxSkTrimExt * trimExt )

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkTrimExt structure.

Parameters
[out] trimExt trim/extend input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimSplitCor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimSplitCor()

evxErrors cvxSkTrimSplitCor ( const svxSkTrimSplitCor * trimSpl )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim or split the sketch to corner by the input svxSkTrimSplitCor data.

Note
Interface cvxSkTrimSplitCorInit() can initialize variables Pattern of this function.
Parameters
[in] trimSpl trim/split input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimSplitCorInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimSplitCorInit()

evxErrors cvxSkTrimSplitCorInit ( svxSkTrimSplitCor * trimSpl )

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkTrimSplitCor structure.

Parameters
[out] trimSpl trim/split input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimSplitCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimSplitCrv()

evxErrors cvxSkTrimSplitCrv ( const svxSkTrimSplit * trimSpl )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim or split the sketch by the input svxSkTrimSplit data.

Note
Interface cvxSkTrimSplitInit() can initialize variables Pattern of this function.
Parameters
[in] trimSpl trim/split input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimSplitInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimSplitInit()

evxErrors cvxSkTrimSplitInit ( svxSkTrimSplit * trimSpl )

#include <zwapi_cmd_sk_cmds.h>

Initialize the svxSkTrimSplit structure.

Parameters
[out] trimSpl trim/split input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: cvxSkTrimSplitPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ cvxSkTrimSplitPnt()

evxErrors cvxSkTrimSplitPnt ( const svxSkTrimSplitPnt * trimSpl )

#include <zwapi_cmd_sk_cmds.h>

Use this function to trim or split the sketch at point by the input svxSkTrimSplitPnt data.

Parameters
[in] trimSpl trim/split at point input data
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_WRONG_ROOT_ENV
  • ZW_API_CMMD_INIT_ERROR
  • ZW_API_INPUT_ERROR
  • ZW_API_CMMD_EXEC_ERROR
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: Tool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Modules
Tool

Detailed Description

Modules

Entity Path
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Entity Path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Entity Path
Tool

Detailed Description

Entity Path Basic Function

evxErrors | cvxEntPathInit (int idEntity, int idParent, svxEntPath *entPath)
evxErrors | cvxEntPathInqActive (svxEntPath *entPath)
evxErrors | cvxEntPathAppendEnt (svxEntPath *entPath, int idEntity)
evxErrors | cvxEntPathAppendPath (svxEntPath *dstPath, const svxEntPath *srcPath)
evxErrors | cvxEntPathToRoot (svxEntPath *EntPath)
int | cvxEntPathCmp (const svxEntPath *EntPath1, const svxEntPath *EntPath2)
int | cvxEntPathGetParentComp (const svxEntPath *entPath, svxEntPath *parentComp)
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathAppendEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathAppendEnt()

evxErrors cvxEntPathAppendEnt | ( | svxEntPath * | entPath,
 |  | int | idEntity
 | ) |  |

#include <zwapi_tool_entpath.h>

Appends an entity to the end of the specified entity path.

Parameters
[in,out] | entPath | entity path
[in] | idEntity | index of entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathAppendPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathAppendPath()

evxErrors cvxEntPathAppendPath | ( | svxEntPath * | dstPath,
 |  | const svxEntPath * | srcPath
 | ) |  |

#include <zwapi_tool_entpath.h>

Appends an entity path to the end of the specified entity path.

Parameters
[in,out] | dstPath | entity path that be appended
[in] | srcPath | the appended entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_INVALID_INPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathCmp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathCmp()

int cvxEntPathCmp | ( | const svxEntPath * | EntPath1,
 |  | const svxEntPath * | EntPath2
 | ) |  |

#include <zwapi_tool_entpath.h>

The subroutine is used for comparison two entity paths.

Parameters
[in] | EntPath1 | entity path
[in] | EntPath2 | entity path
Return values
return
  • 0 - the two entity paths are the same
  • 2 - entity path EntPath1 include entity path EntPath2
  • -2 - entity path EntPath2 include entity path EntPath1
  • 1 - otherwise
Warning
  • ZW_API_INVALID_ENT_PATH
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathGetParentComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathGetParentComp()

int cvxEntPathGetParentComp | ( | const svxEntPath * | entPath,
 |  | svxEntPath * | parentComp
 | ) |  |

#include <zwapi_tool_entpath.h>

Outputs the entity path of the parent component of the specified entity path.

Parameters
[in] | entPath | entity path
[out] | parentComp | entity path of parent component
Return values
succeeds
  • ZW_API_NO_ERROR - the entity path has no parent component.
  • 1 - the entity path has parent component.
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathInit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathInit()

evxErrors cvxEntPathInit | ( | int | idEntity,
 |  | int | idParent,
 |  | svxEntPath * | entPath
 | ) |  |

#include <zwapi_tool_entpath.h>

Outputs the entity path of the specified entity relative to the currently active root object, the entity must be an entity under the currently active root object.

Parameters
[in] | idEntity | index of entity
[in] | idParent | index of parent of entity (sketch, curve list, 0 to ignore)
[out] | entPath | entity path of entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_INPUT
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ROOT_OBJ_ACT_FAIL
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathInqActive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathInqActive()

evxErrors cvxEntPathInqActive ( svxEntPath * entPath )

#include <zwapi_tool_entpath.h>

Outputs current active entity path.

Parameters
[out] entPath entity path of entity
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_INVALID_OUTPUT
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: cvxEntPathToRoot

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Entity Path
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ cvxEntPathToRoot()

evxErrors cvxEntPathToRoot ( svxEntPath * EntPath )

#include <zwapi_tool_entpath.h>

Converts the input entity path from a path that is defined relative to the active target object to an "absolute" path that begins with the parent file of the target object. It is assumed that the entity path is an evaluated (i.e. non-persistent) entity path.
For example:
If the input EntPath's Id[0] = -1, such as Id = { -1, COMP, COMP, FACE};
the output EntPath's Id = { -2, PART, COMP, PART COMP, PART, FACE};

Parameters
[in,out] EntPath entity path
Return values
succeeds
  • ZW_API_NO_ERROR
fail
  • ZW_API_GENERAL_ERROR
  • ZW_API_INVALID_ENT_PATH
  • ZW_API_ENT_PATH_ERROR
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: File List

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
File List
Here is a list of all documented files with brief descriptions:
[detail level 123]
▼ api
► inc
zwapi_asm_comp.h
zwapi_asm_comp_attribute.h
zwapi_asm_constraint.h
zwapi_asm_data.h
zwapi_asm_opts.h
zwapi_asm_reuselibrary.h
zwapi_brep_data.h
zwapi_brep_edge.h
zwapi_brep_face.h
zwapi_brep_loop.h
zwapi_brep_preedge.h
zwapi_brep_shape.h
zwapi_brep_vertex.h
zwapi_cm_comp.h
zwapi_cm_folder.h
zwapi_cm_forms.h
zwapi_cm_frame.h
zwapi_cm_ftr.h
zwapi_cm_machine.h
zwapi_cm_op.h
zwapi_cm_query.h
zwapi_cm_tool.h
zwapi_cmd.h
zwapi_cmd_assembly.h
zwapi_cmd_assembly_data.h
zwapi_cmd_data.h
zwapi_cmd_dataexchange.h
zwapi_cmd_dataexchange_data.h
zwapi_cmd_datum.h
zwapi_cmd_datum_data.h
zwapi_cmd_direct_edit.h
zwapi_cmd_direct_edit_data.h
zwapi_cmd_dwg_data.h
zwapi_cmd_dwg_dimension.h
zwapi_cmd_dwg_drawing.h
zwapi_cmd_dwg_layout.h
zwapi_cmd_ecadboard.h
zwapi_cmd_ecadboard_data.h
zwapi_cmd_freeform.h
zwapi_cmd_freeform_data.h
zwapi_cmd_paramdefine_param.h
zwapi_cmd_paramdefine_tpl.h
zwapi_cmd_pmi.h
zwapi_cmd_pmi_data.h
zwapi_cmd_shape.h
zwapi_cmd_shape_data.h
zwapi_cmd_sheetmetal.h
zwapi_cmd_sheetmetal_data.h
zwapi_cmd_sk_app.h
zwapi_cmd_sk_app_data.h
zwapi_cmd_sk_cmds.h
zwapi_cmd_sk_cmds_data.h
zwapi_cmd_sk_create.h
zwapi_cmd_sk_create_data.h
zwapi_cmd_subcmd.h
zwapi_cmd_subcmd_data.h
zwapi_cmd_udf.h
zwapi_cmd_udf_data.h
zwapi_cmd_wireframe.h
zwapi_cmd_wireframe_data.h
zwapi_config.h
zwapi_dim.h
zwapi_display.h
zwapi_dwg_attribute.h
zwapi_dwg_data.h
zwapi_dwg_dim.h
zwapi_dwg_drawing.h
zwapi_dwg_geometry.h
zwapi_dwg_symbol.h
zwapi_dwg_table.h
zwapi_dwg_view.h
zwapi_file.h
zwapi_file_data.h
zwapi_file_path.h
zwapi_general_ent.h
zwapi_global_apply.h
zwapi_layer.h
zwapi_license.h
zwapi_math.h
zwapi_math_bndbox.h
zwapi_math_data.h
zwapi_math_insect.h
zwapi_math_matrix.h
zwapi_math_nurbscurve.h
zwapi_math_nurbssurface.h
zwapi_math_point.h
zwapi_math_vector.h
zwapi_memory.h
zwapi_message.h
zwapi_part_attribute.h
zwapi_part_config.h
zwapi_part_data.h
zwapi_part_datum_query.h
zwapi_part_dim.h
zwapi_part_facets.h
zwapi_part_history.h
zwapi_part_hole.h
zwapi_part_objs.h
zwapi_part_opts.h
zwapi_part_sheetmetal_attribute.h
zwapi_part_var.h
zwapi_part_view.h
zwapi_root.h
zwapi_sk_attribute.h
zwapi_sk_data.h
zwapi_sk_dim.h
zwapi_sk_objs.h
zwapi_sk_opts.h
zwapi_sk_var.h
zwapi_text.h
zwapi_tool_entpath.h
zwapi_ui_combobox.h
zwapi_ui_data.h
zwapi_ui_form.h
zwapi_ui_guiset.h
zwapi_ui_listwidget.h
zwapi_ui_popupform.h
zwapi_ui_ribbon.h
zwapi_ui_slider.h
zwapi_ui_tablewidget.h
zwapi_ui_tabwidget.h
zwapi_ui_treeview.h
zwapi_userinput.h
zwapi_util.h
zwapi_var.h
zwapi_view.h
zwapi_xn.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: api Directory Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
api Directory Reference

Directories

directory inc
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: inc Directory Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
inc Directory Reference

Files

file | zwapi_asm_comp.h [code]
file | zwapi_asm_comp_attribute.h [code]
file | zwapi_asm_constraint.h [code]
file | zwapi_asm_data.h [code]
file | zwapi_asm_opts.h [code]
file | zwapi_asm_reuselibrary.h [code]
file | zwapi_brep_data.h [code]
file | zwapi_brep_edge.h [code]
file | zwapi_brep_face.h [code]
file | zwapi_brep_loop.h [code]
file | zwapi_brep_preedge.h [code]
file | zwapi_brep_shape.h [code]
file | zwapi_brep_vertex.h [code]
file | zwapi_cm_comp.h [code]
file | zwapi_cm_folder.h [code]
file | zwapi_cm_forms.h [code]
file | zwapi_cm_frame.h [code]
file | zwapi_cm_ftr.h [code]
file | zwapi_cm_machine.h [code]
file | zwapi_cm_op.h [code]
file | zwapi_cm_query.h [code]
file | zwapi_cm_tool.h [code]
file | zwapi_cmd.h [code]
file | zwapi_cmd_assembly.h [code]
file | zwapi_cmd_assembly_data.h [code]
file | zwapi_cmd_data.h [code]
file | zwapi_cmd_dataexchange.h [code]
file | zwapi_cmd_dataexchange_data.h [code]
file | zwapi_cmd_datum.h [code]
file | zwapi_cmd_datum_data.h [code]
file | zwapi_cmd_direct_edit.h [code]
file | zwapi_cmd_direct_edit_data.h [code]
file | zwapi_cmd_dwg_data.h [code]
file | zwapi_cmd_dwg_dimension.h [code]
file | zwapi_cmd_dwg_drawing.h [code]
file | zwapi_cmd_dwg_layout.h [code]
file | zwapi_cmd_ecadboard.h [code]
file | zwapi_cmd_ecadboard_data.h [code]
file | zwapi_cmd_freeform.h [code]
file | zwapi_cmd_freeform_data.h [code]
file | zwapi_cmd_paramdefine_param.h [code]
file | zwapi_cmd_paramdefine_tpl.h [code]
file | zwapi_cmd_pmi.h [code]
file | zwapi_cmd_pmi_data.h [code]
file | zwapi_cmd_shape.h [code]
file | zwapi_cmd_shape_data.h [code]
file | zwapi_cmd_sheetmetal.h [code]
file | zwapi_cmd_sheetmetal_data.h [code]
file | zwapi_cmd_sk_app.h [code]
file | zwapi_cmd_sk_app_data.h [code]
file | zwapi_cmd_sk_cmds.h [code]
file | zwapi_cmd_sk_cmds_data.h [code]
file | zwapi_cmd_sk_create.h [code]
file | zwapi_cmd_sk_create_data.h [code]
file | zwapi_cmd_subcmd.h [code]
file | zwapi_cmd_subcmd_data.h [code]
file | zwapi_cmd_udf.h [code]
file | zwapi_cmd_udf_data.h [code]
file | zwapi_cmd_wireframe.h [code]
file | zwapi_cmd_wireframe_data.h [code]
file | zwapi_config.h [code]
file | zwapi_dim.h [code]
file | zwapi_display.h [code]
file | zwapi_dwg_attribute.h [code]
file | zwapi_dwg_data.h [code]
file | zwapi_dwg_dim.h [code]
file | zwapi_dwg_drawing.h [code]
file | zwapi_dwg_geometry.h [code]
file | zwapi_dwg_symbol.h [code]
file | zwapi_dwg_table.h [code]
file | zwapi_dwg_view.h [code]
file | zwapi_file.h [code]
file | zwapi_file_data.h [code]
file | zwapi_file_path.h [code]
file | zwapi_general_ent.h [code]
file | zwapi_global_apply.h [code]
file | zwapi_layer.h [code]
file | zwapi_license.h [code]
file | zwapi_math.h [code]
file | zwapi_math_bndbox.h [code]
file | zwapi_math_data.h [code]
file | zwapi_math_insect.h [code]
file | zwapi_math_matrix.h [code]
file | zwapi_math_nurbscurve.h [code]
file | zwapi_math_nurbssurface.h [code]
file | zwapi_math_point.h [code]
file | zwapi_math_vector.h [code]
file | zwapi_memory.h [code]
file | zwapi_message.h [code]
file | zwapi_part_attribute.h [code]
file | zwapi_part_config.h [code]
file | zwapi_part_data.h [code]
file | zwapi_part_datum_query.h [code]
file | zwapi_part_dim.h [code]
file | zwapi_part_facets.h [code]
file | zwapi_part_history.h [code]
file | zwapi_part_hole.h [code]
file | zwapi_part_objs.h [code]
file | zwapi_part_opts.h [code]
file | zwapi_part_sheetmetal_attribute.h [code]
file | zwapi_part_var.h [code]
file | zwapi_part_view.h [code]
file | zwapi_root.h [code]
file | zwapi_sk_attribute.h [code]
file | zwapi_sk_data.h [code]
file | zwapi_sk_dim.h [code]
file | zwapi_sk_objs.h [code]
file | zwapi_sk_opts.h [code]
file | zwapi_sk_var.h [code]
file | zwapi_text.h [code]
file | zwapi_tool_entpath.h [code]
file | zwapi_ui_combobox.h [code]
file | zwapi_ui_data.h [code]
file | zwapi_ui_form.h [code]
file | zwapi_ui_guiset.h [code]
file | zwapi_ui_listwidget.h [code]
file | zwapi_ui_popupform.h [code]
file | zwapi_ui_ribbon.h [code]
file | zwapi_ui_slider.h [code]
file | zwapi_ui_tablewidget.h [code]
file | zwapi_ui_tabwidget.h [code]
file | zwapi_ui_treeview.h [code]
file | zwapi_userinput.h [code]
file | zwapi_util.h [code]
file | zwapi_var.h [code]
file | zwapi_view.h [code]
file | zwapi_xn.h [code]
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_comp.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_comp.h File Reference
#include "zwapi_asm_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Component Query API Including query the components of the assembly, component's part/state and query the objects of the component etc..

Definition in file zwapi_asm_comp.h.

Assembly

evxErrors | cvxPartInqAsmFolders (const vxLongPath File, const vxRootName Part, int type, int *count, int **Folders)
evxErrors | cvxPartInqAsmFldChildEnts (const vxLongPath File, const vxRootName Part, int idFolder, int incSubFld, int *count, int **Ents)

Assembly Feature

evxErrors cvxPartInqAsmFtrList (const vxLongPath File, const vxRootName Part, int *Count, int **Features)

Query Components

evxErrors | cvxPartInqComps (const vxLongPath File, const vxRootName Part, int *Count, int **Comps)
evxErrors | cvxPartInqComps2 (const vxLongPath File, const vxRootName Part, int Option, int *Count, int **Comps)
evxErrors | cvxPartInqCompsInfo (const vxPath Path, const vxRootName Name, int *Count, vxPath **Paths, vxRootName **Names)
evxErrors | cvxPartInqCompsInfoByLongPath (const vxLongPath Path, const vxRootName Name, int *Count, vxLongPath **Paths, vxRootName **Names)
evxErrors | cvxCompInqPaths (svxEntPath *CompPath, int Depth, int IgnoreHidden, int *PathCnt, svxEntPath **lstPath)

Component's Part

evxErrors | cvxCompInqPart (int idComp, char *File, int nFileBytes, char *Part, int nPartBytes)
evxErrors | cvxCompInqPartByPath (const svxEntPath *CompPath, vxPath fileName, vxRootName partName)
evxErrors | cvxCompInqPartByPathByLongPath (const svxEntPath *CompPath, char *fileName, int sizeDir, vxRootName partName)
evxErrors | cvxCompGetRefPart (int *Count, vxPath **BinName, vxRootName **RootName)
evxErrors | cvxCompGetRefPartByLongPath (int *Count, vxLongPath **BinName, vxRootName **RootName)

Component's State

evxErrors | cvxPartInqAsmIsFlex (int idComp, int *isFlexible)
evxErrors | cvxPartInqAsmIsFlexByPath (svxEntPath AsmPath, int *isFlexible)
evxErrors | cvxCompSuppressGet (int idComp, int *suppress)
evxErrors | cvxCompSuppressGetByPath (svxEntPath *path, int *suppress)
evxErrors | cvxAssemCompVisAll (int *nSize, int **ppath_mode)
evxErrors | cvxCompVisGet (svxEntPath *CompPath, int *Vis)
void | cvxCompHighlight (svxEntPath *CompPath, svxColor *color)
void | cvxCompUnHighlight (svxEntPath *CompPath)
evxErrors | cvxCompMakeVirtual (svxEntPath *CompPath)
evxErrors | cvxCompIsVirtual (svxEntPath *CompPath, int *isVirtual)
evxErrors | cvxCompInqRenderMode (svxEntPath *CompPath, evxRenderMode *RenderMode)
evxErrors | cvxCompIsUnplaced (int idx_Comp, int *isUnplaced)
evxErrors | cvxCompIsUnplacedByPath (const svxEntPath *path, int *isUnplaced)
evxErrors | cvxCompIsFileLost (const svxEntPath *path, int *isFileLost)
evxErrors | cvxCompExpandStateGet (const svxEntPath *path, int *isExpand)
evxErrors | cvxCompExpandStateSet (const svxEntPath *path, int expand)
evxErrors | cvxCompSelectedStateGet (const svxEntPath *path, int *isSelected)
evxErrors | cvxCompSelectedStateSet (const svxEntPath *path, int selected)
evxErrors | cvxCompBomExcludedGet (svxEntPath EntPath, int *exclude)
evxErrors | cvxCompBomSettingGet (svx3DBomSettingsData *data)
evxErrors | cvxCompBomSettingSet (svx3DBomSettingsData *data)
evxErrors | cvxCompBomDispDataGet (svx3DBomData *data)
void | cvxBomDataFree (svx3DBomData *data)
evxErrors | cvxCompBomPathByPart (const vxLongName part, int *cnt, svxEntPath **paths)
evxErrors | cvxCompRegenSet (int idComp, int Regen)

Component Query

evxErrors | cvxPartInqFlexAsmMat (svxEntPath AsmPath, svxMatrix *AsmMat)
evxErrors | cvxCompInqOpenShapes (svxEntPath *CompPath, int IgnoreHide, int *numShps, svxEntPath **shpPaths)
evxErrors | cvxCompShapeInqOpenEdges (svxEntPath *ShpPath, int *numEdg, svxEntPath **edgPaths)
evxErrors | cvxCompCfgIdGet (const svxEntPath *path, int *idCfg)
evxErrors | cvxCompFolderIns (int cnt, const int *idCom, const vxLongName folderName, int *idFolder)
evxErrors | cvxCompFromAsmFtr (svxEntPath *path, int *isFromAsmFtr)

Assembly Reorder

evxErrors cvxAsmReorder (const vxLongPath fileName, const vxRootName rootName, int idEnt, evxReorderLoc reorderLoc, int idPreEnt)

sub-part

evxErrors cvxSubPartFlag (const vxLongPath File, const vxRootName Part, int isSubPart)
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_comp_attribute.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_comp_attribute.h File Reference
#include "zwapi_asm_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Component Attribute API Including query the user attribute and display attributes of the components.

Definition in file zwapi_asm_comp_attribute.h.

Component Attribute

evxErrors | cvxCompUserAtGet (svxEntPath *Comp, int *Count, svxAttribute **UserAt)
evxErrors | cvxCompUserAtSet (svxEntPath *Comp, int Count, svxAttribute *UserAt)
evxErrors | cvxCompUserAtDel (svxEntPath *Comp, int Count, svxAttribute *UserAt)
evxErrors | cvxCompFaceAtGet (const svxEntPath *CompPath, svxFaceAt *At)
evxErrors | cvxCompFaceAtSet (int Count, svxEntPath *CompPath, svxFaceAt *At)
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_constraint.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_constraint.h File Reference
#include "zwapi_asm_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Component Constraints Query API Including query the constraints of the components.

Definition in file zwapi_asm_constraint.h.

Assembly Constraint

evxErrors | cvxConsInqType (int idCons, evxConsType *consType)
evxErrors | cvxConsInqRefEnts (int idCons, int *count, svxEntPath **entPaths)
evxErrors | cvxConsInqConsData (int idCons, svxConsData *ConsData)
evxErrors | cvxCompInqConsState (int idComp, evxConsState *consState)
evxErrors | cvxCompInqConstraints (svxEntPath *CompPath, int *count, int **cons)
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_assembly_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the functions for the assembly's objects.

Definition in file zwapi_asm_data.h.

Assembly Component Data

enum | evxReorderLoc { VX_REORDER_FIRST = 0 , VX_REORDER_LAST = 1 , VX_REORDER_AFTER = 2 }
Reorder location. More...
enum evx3DBomLevelDispMode {
VX_3DBOM_TOP_LEVEL_ONLY = 1 , VX_3DBOM_PARTS_ONLY = 2 , VX_3DBOM_INDENTED = 3 , VX_3DBOM_SHAPE_ONLY = 4 ,
VX_3DBOM_ALLCOMPONENTS = 5
}
level display settings. More...
typedef enum evxReorderLoc | evxReorderLoc
Reorder location.
typedef enum evx3DBomLevelDispMode | evx3DBomLevelDispMode
level display settings. More...
typedef struct svx3DBomSettingsData | svx3DBomSettingsData
3D BOM display settings data
typedef struct svx3DBomData | svx3DBomData
3d BOM row data

Assembly operation Data

enum evxRenderMode {
VX_RENDER_NONE = 0 , VX_RENDER_WIRE = 1 , VX_RENDER_SHADE = 2 , VX_RENDER_HIDD_APPROX = 3 ,
VX_RENDER_ANALYZE = 4 , VX_RENDER_TRANSPARENT = 9
}
Render mode. More...
typedef struct svxAsmGrpCompData | svxAsmGrpCompData
group as sub-assembly data
typedef enum evxRenderMode | evxRenderMode
Render mode.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_opts.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_opts.h File Reference
#include "zwapi_asm_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Assembly Menu Commands API

Definition in file zwapi_asm_opts.h.

Assembly Operations

evxErrors | cvxAsmDissolve (const svxEntPath *path)
evxErrors | cvxAsmGrpComp (svxAsmGrpCompData *data)
evxErrors | cvxAsmAddToFavorites (svxEntPath *path)
evxErrors | cvxAsmRemoveFromFavorites (svxEntPath *path)
int | cvxAsmFavoritesEnable (svxEntPath *path)
evxErrors | cvxAsmUpdateCompRef (const char *OldRootName, const char *NewRootName)

Component Operations

evxErrors | cvxCompEditPart (int idComp)
evxErrors | cvxCompEditPartByPath (const svxEntPath *compPath)
evxErrors | cvxCompRegen (svxEntPath *Path, int flag)
evxErrors | cvxCompSetPart (int idComp, const vxLongPath File, const vxRootName Part)
evxErrors | cvxCompIsLightweightByPath (const svxEntPath *compPath, int *isLightweight)
evxErrors | cvxCompLightweightSetByPath (const svxEntPath *compPaths, int compCount, int load, int isRecursive)
evxErrors | cvxCompSetRenderMode (svxEntPath *CompPath, evxRenderMode RenderMode)
evxErrors | cvxCompShift (int idComp)
evxErrors | cvxCompSuppress (int idComp, int suppress)
evxErrors | cvxCompSuppressByPath (int Count, svxEntPath *CompPaths, int suppress)
evxErrors | cvxCompVisSet (svxEntPath *CompPath, int Vis)
evxErrors | cvxCompCfgIdSet (const svxEntPath *path, int idCfg)

Constraint Operations

evxErrors | cvxConsRedefine (int idCons)
evxErrors | cvxConsEnable (int count, int *idCons, int enable)
evxErrors | cvxConsDel (int count, int *idCons)

sub-part

evxErrors cvxSubPartIns (const vxRootName Name, int AutoRegen, int MergeDimen)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_reuselibrary.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_asm_reuselibrary.h File Reference
#include "zwapi_cmd_assembly_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Reuse Library API

Definition in file zwapi_asm_reuselibrary.h.

Reuse Library Insert

int | cvxLibPartIns (const svxCompData *Comp, const char *InstanceName, const char *ValStr, int fFileType, int fInsShape, int *idComp)
evxErrors | cvxInstPartAsShp (const svxCompData *Comp)
evxErrors | cvxLibPartAdjust (int idComp, const vxLongPath File, const vxRootName Part, const char *ValStr, const char *InstanceName)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Brep objects.

Definition in file zwapi_brep_data.h.

pre-edge Query Data

typedef struct svxPreEdge | svxPreEdge
pre-edge information
typedef struct svxMassProp | svxMassProp
mass attributes
typedef struct svxWeldAttr | svxWeldAttr
weldment attribute
typedef struct svxEvalSurf | svxEvalSurf
surface evaluate
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_edge.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_edge.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Edge API

Definition in file zwapi_brep_edge.h.

Edge Query

int | cvxPartInqEdgeOpen (int idEdge)
evxErrors | cvxPartInqEdgeType (int idEdge, evxEdgeType *EdgeType)
evxErrors | cvxPartInqEdgeFaces (int idEdge, int *Count, int **Faces)
evxErrors | cvxPartInqEdgePreEdges (int idEdge, int *Count, int **PreEdges)
evxErrors | cvxPartInqEdgeLoop (int idFace, int idEdge, int *idLoop)
evxErrors | cvxPartInqEdgeShape (int idEdge, int *idShape)
evxErrors | cvxPartInqEdgeCrv (int idEdge, int idFace, svxCurve *Crv)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_face.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_face.h File Reference
#include "zwapi_brep_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Face API

Definition in file zwapi_brep_face.h.

Face Attribute

evxErrors | cvxPartInqFaceAt (int idFace, svxFaceAt *At)
evxErrors | cvxPartInqFaceSh (int idFace, svxShaderAt *Sh)
evxErrors | cvxPartInqFaceTx (int idFace, svxTextureAt *Tx)
evxErrors | cvxFaceGetArea (const int faceId, const double tolerance, double *area)
evxErrors | cvxFaceGetMaxCurvature (const int faceId, const svxPoint2 uvPoint, svxPoint *point, svxPoint *normal, svxPoint *direction, double *minCurvature, double *maxCurvature, double *curvature, svxPoint *curvatureDirection, svxPoint *curvatureCenter)
evxErrors | cvxPartSetFaceAtInit (svxFaceAt *data)
evxErrors | cvxPartSetFaceAt (int Count, int *idFaces, const svxFaceAt *At)
evxErrors | cvxPartSetFaceTx (int idFace, const svxTextureAt *Tx)
evxErrors | cvxPartDelFaceTx (int Count, const int *idFaces)

Face Query

evxErrors | cvxPartInqFaceTxFile (int idFace, vxPath Path)
evxErrors | cvxPartInqFaceTxFileByLongPath (int idFace, char *Path, int sizePath)
evxErrors | cvxPartInqFaceBox (int idFace, svxBndBox *Box)
evxErrors | cvxPartInqFaceCrvs (int idFace, int *Count, svxCurve **TrimCurves)
evxErrors | cvxPartInqFaceEdges (int idFace, int *Count, int **Edges)
evxErrors | cvxPartInqFaceLoops (int idFace, int Inner, int *Count, int **Loops)
evxErrors | cvxPartInqFaceSrf (int idFace, svxSurface *Srf)
void | cvxSurfaceFree (svxSurface *Srf)
evxErrors | cvxPartInqFaceSrfPrim (int idFace, svxSrfPrim *SrfPrim)
void | cvxSrfPrimFree (svxSrfPrim *SrfPrim)
evxErrors | cvxPartInqFaceShape (int idFace, int *idShape)
evxErrors | cvxPartInqFaceGeom (int idFace, int *idGeom)
evxErrors | cvxPartInqFaceFillet (int idFace, int *isFilletFace)
evxErrors | cvxFaceRadius (int idFace, double *Radius)
evxErrors | cvxFaceInqBend (int idFace, int *bendFlag, double *bendRad, double *neutralRad, double *angle, double *thick, double *kFactor, double *flatTol)
int | cvxFaceIsConcave (int idFace)
int | cvxFaceIsPlanar (int idFace)
evxErrors | cvxFaceInqExtreme (int idFace, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)

Face Eval

evxErrors | cvxFaceEval (int idFace, double U, double V, svxPoint *Point, svxVector *Normal)
evxErrors | cvxFaceEval2 (int idFace, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
evxErrors | cvxFaceParam (int idFace, svxLimit *U, svxLimit *V)
evxErrors | cvxFacePntLoc (int idFace, double U, double V, evxPntLocation *Loc)
evxErrors | cvxFacePntProj (int idFace, svxPoint *Point, double *U, double *V)
evxErrors | cvxFaceRadialIntegrity (int idFace, double *URatio, double *VRatio)
evxErrors | cvxFaceEvalGeom (int idFace, double U, double V, int Level, svxEvalSurf *EvalSrf)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_loop.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_loop.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Loop API

Definition in file zwapi_brep_loop.h.

Loop query

evxErrors | cvxPartInqLoopEdges (int idLoop, int *Count, int **Edges)
evxErrors | cvxPartInqLoopFace (int idLoop, int *idFace)
evxErrors | cvxPartInqLoopPreEdges (int idLoop, int *Count, int **PreEdges)
evxErrors | cvxPartInqLoopInner (int idLoop, int *isInner)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_preedge.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_preedge.h File Reference
#include "zwapi_brep_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D pre-edge API

Definition in file zwapi_brep_preedge.h.

pre-edge Query

evxErrors | cvxPartInqPreEdgeInfo (int idPreEdge, svxPreEdge *PreEdge)
evxErrors | cvxPartInqPreEdgeStartPnt (int idPreEdge, int *idEdge, svxPoint2 *StartPnt)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_shape.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_shape.h File Reference
#include "zwapi_brep_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Shape API

Definition in file zwapi_brep_shape.h.

Shape Attribute

evxErrors | cvxShellAtGet (int idShape, svxPartAttribute *At)
evxErrors | cvxShellAtItemGet (int idShape, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxShellAtItemSet (int idShape, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartInqShapeOpen (int idShape, int *isOpen)
evxErrors | cvxPartInqShapeBox (int idShape, svxMatrix *Mat, svxBndBox *Box)
evxErrors | cvxPartInqShapeMass (int idShape, double Density, svxMassProp *Prop)
evxErrors | cvxPartShapeStructGet (int idShape, svxWeldAttr *at)

Shape Query

evxErrors | cvxPartInqShapes (const vxLongPath File, const vxRootName Part, int *Count, int **Shapes)
evxErrors | cvxPartInqShapeComp (int idShape, int *idComp)
evxErrors | cvxPartInqShapeEdges (int idShape, int *Count, int **Edges)
evxErrors | cvxPartInqShapeFaces (int idShape, int *Count, int **Faces)
evxErrors | cvxPartInqShapeFtrs (int idShape, int Option, int *Count, int **Features)
evxErrors | cvxPartInqShapeExtreme (int idShape, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)
evxErrors | cvxInstShpGetMatrix (int idShape, svxMatrix *Matrix)

Entity Query Shape

evxErrors cvxPartInqEntShape (int idEntity, int *idShape)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_vertex.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_brep_vertex.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Vertex API

Definition in file zwapi_brep_vertex.h.

Vertex

evxErrors cvxPartInqVertexEdges (int idEdge, int EndPnt, int *Count, int **Edges)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_comp.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_comp.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Components.

Definition in file zwapi_cm_comp.h.

Cam Component Data

enum evxCmCompClass {
ZW_CAM_COMP_CLASS_PART , ZW_CAM_COMP_CLASS_CLAMP , ZW_CAM_COMP_CLASS_STOCK , ZW_CAM_COMP_CLASS_TABLE ,
ZW_CAM_COMP_CLASS_TOOLHOLDER , ZW_CAM_COMP_CLASS_ATTACHMENT
}
cam component class More...
enum | evxCmCompAtrr { ZW_CAM_COMP_ATTR_FACES , ZW_CAM_COMP_ATTR_CLASS , ZW_CAM_COMP_ATTR_CDCOMP }
cam component attribute More...
typedef enum evxCmCompClass | evxCmCompClass
cam component class
typedef enum evxCmCompAtrr | evxCmCompAtrr
cam component attribute

Cam Component Fun

evxErrors | cvxCmCompInsert (char *fileName, char *shapeName, int *idx_CmComp)
evxErrors | cvxCmCompDelete (int idx_CmComp)
evxErrors | cvxCmCompGetAttr (int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue **pValue)
evxErrors | cvxCmCompSetAttr (int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue *value)
evxErrors | cvxCmCompInqInfo (int *compCnt, vxPath **compNames, vxPath **compPaths)
evxErrors | cvxCmCompInqInfoByLongPath (int *compCnt, vxLongPath **compNames, vxLongPath **compPaths)
evxErrors | cvxCmPlanSkNew (svxMatrix *Plane, int *idSketch)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_folder.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_folder.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Folder.

Definition in file zwapi_cm_folder.h.

Cam Folder Data

enum | evxCmFolderAttr { CM_FOLDER_NAME , CM_FOLDER_SUB }
cam folder attribute More...
typedef enum evxCmFolderAttr | evxCmFolderAttr
cam folder attribute

Cam Folder Fun

evxErrors | cvxCmFolderGetAttr (int idx_folder, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmFolderInqOps (const vxLongPath folder_name, int *op_cnt, int **op_list)
evxErrors | cvxCmOpInsFolder (int *idx_out)
evxErrors | cvxCmObjGetTreeId (int idx_in, int *tree_id, evxCmTreeType treeType)
evxErrors | cvxCmFldRename (int idx_fld, vxLongName fld_newName)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_forms.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_forms.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE API of the Cam Forms.

Definition in file zwapi_cm_forms.h.

Cam Forms Data

enum | evxCmOutFldType { CM_OUTFLD_FLD , CM_OUTFLD_NC }
cam output folder type More...
enum evxCmOutType {
CM_OUT_CL , CM_OUT_NC , CM_OUT_TOOL , CM_OUT_OP ,
CM_OUT_XML , CM_OUT_HTML
}
cam output type More...
typedef struct svxNcSetting | svxNcSetting
cam nc output setting
typedef enum evxCmOutFldType | evxCmOutFldType
cam output folder type
typedef enum evxCmOutType | evxCmOutType
cam output type

Cam Forms Fun

evxErrors | cvxCmSetClearance (double dClearZ, double dAppZ, double dRtZ, double dAutoClear, int iMiniClr)
evxErrors | cvxCmGetClearance (double *dClearZ, double *dAppZ, double *dRtZ, double *dAutoClear, int *iMiniClr)
evxErrors | cvxCmSetSAndF (double FeedRough, double FeedFinish, double SpeedRough, double SpeedFinish, char *pName)
evxErrors | cvxCmOutputManhours (int *idx_opedef, int cnt, double *manhours)
evxErrors | cvxCmOutputInsNC (int idx_fld, int *idx_out, evxCmOutFldType fldType)
evxErrors | cvxCmOutputDelNC (int idx_in, evxCmOutFldType fldType)
evxErrors | cvxCmGetOutputNCSet (int idx_nc, svxNcSetting *ncSet)
evxErrors | cvxCmSetOutputNCSet (int idx_nc, svxNcSetting *ncSet)
evxErrors | cvxCmOutputInsOps (int idx_nc, int cnt, int *idx_op)
evxErrors | cvxCmOutputDelOps (int idx_nc, int cnt, int *idx_op)
evxErrors | cvxCmOutputNC (int idx_nc, evxCmOutType outType)
evxErrors | cvxCmOpsOutputNc (int op_cnt, int *idx_opList, int *idx_nc)
evxErrors cvxCmMsgClear ()
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_frame.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_frame.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Frame.

Definition in file zwapi_cm_frame.h.

Cam Frame Data

enum | evxCmFrameAttr { CM_FRAME_NAME , CM_FRAME_CLEAR_Z , CM_FRAME_APPROACH_Z , CM_FRAME_RETRACT_Z }
cam frame attribute More...
typedef enum evxCmFrameAttr | evxCmFrameAttr
cam frame attribute

Cam Frame Fun

evxErrors | cvxCmFrameInsert (vxName frame_name, svxPoint origin_point, svxPoint x_point, svxPoint y_point, int *idx_frame)
evxErrors | cvxCmFrameDelete (int idx_frame)
evxErrors | cvxCmFrameGetAttr (int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmFrameSetAttr (int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmFrameInsert2 (const vxName frame_name, svxMatrix frame_mat, int *idx_frame)
evxErrors | cvxCmOpAddFrame (int idxOp, int idxFrame)
evxErrors | cvxCmFrameGetMatrix (int idxFrame, svxMatrix *frameMat)
evxErrors | cvxCmFrameGetActive (int *idx_actFrame)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_ftr.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_ftr.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Features.

Definition in file zwapi_cm_ftr.h.

Cam Features Data

enum evxCmFtrType {
ZW_CAM_FEATURE_SOLID = 1 , ZW_CAM_FEATURE_POCKET = 2 , ZW_CAM_FEATURE_HOLE = 3 , ZW_CAM_FEATURE_SLOT = 4 ,
ZW_CAM_FEATURE_PROFILE = 5 , ZW_CAM_FEATURE_STEP = 6 , ZW_CAM_FEATURE_SURFACE = 7 , ZW_CAM_FEATURE_CHAMFER = 8 ,
ZW_CAM_FEATURE_CRND = 9 , ZW_CAM_FEATURE_FACE = 10 , ZW_CAM_FEATURE_BOSS = 11 , ZW_CAM_FEATURE_FLAT = 12
}
cam feature type More...
enum | evxCmFtrAttr { CM_FEATURE_TYPE }
cam feature attribute More...
enum | evxCmFtrProfileType { PART , CONTAIN }
cam profile feature type More...
enum | evxCmProfileCuvAttr { V_CM_PRF_OFFSET = 0 , V_CM_PRF_DRAFT = 1 , V_CM_PRF_TOOLLOC = 2 }
cam profile feature curve attribute More...
enum | evxCmProfileTolLoc { V_CM_PRF_ON = 0 , V_CM_PRF_TAN = 1 , V_CM_PRF_PAST = 2 }
cam profile feature tool location type More...
typedef enum evxCmFtrType | evxCmFtrType
cam feature type
typedef enum evxCmFtrAttr | evxCmFtrAttr
cam feature attribute
typedef enum evxCmFtrProfileType | evxCmFtrProfileType
cam profile feature type
typedef enum evxCmProfileCuvAttr | evxCmProfileCuvAttr
cam profile feature curve attribute
typedef enum evxCmProfileTolLoc | evxCmProfileTolLoc
cam profile feature tool location type

Cam Features Fun

evxErrors | cvxCmFtrInsert (evxCmFtrType ftrType, int idx_CmComp, int cnt, int *geom, int *idx_FtrGrp)
evxErrors | cvxCmFtrInsertNew (evxCmFtrType ftrType, int cnt, int *geom, double *depths, int *idx_FtrGrp)
evxErrors | cvxCmFtrInsertWithoutHoles (evxCmFtrType ftrType, const vxName ftrName, int cnt, int *geom, int *idxFtrGrp)
evxErrors | cvxCmFtrInsertSK (evxCmFtrType ftrType, const vxName ftrName, int idxSk, int cnt, int *geom, int *idxFtrGrp)
evxErrors | cvxCmFtrGetComp (int *comp_cnt, int **idxComp)
evxErrors | cvxCmGetCrvId (int *numLine, int **lstLines)
evxErrors | cvxCmFtrInsertHole (const vxName ftrName, int cnt, int *geom, double *depths, int *idxFtrGrp)
evxErrors | cvxCmPlanDispSetMode (evxCmPlanDispMode iMode)
evxErrors | cvxCmFtrDelete (int idx_ftrgrp)
evxErrors | cvxCmFtrGetAttr (int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
evxErrors | cvxCmFtrSetAttr (int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
evxErrors | cvxCmFtrRename (int idx_ftr, vxLongName newFtrName)
evxErrors | cvxCmProfSetAttr (int prof_idx, int curve_idx, double newOffset, double newDraft, int tolloc)
evxErrors | cvxCmFtrInqType (int idx_Ftr, evxCmFtrType *ftrType)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_machine.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_machine.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Machine.

Definition in file zwapi_cm_machine.h.

Cam Machine Data

enum | evxCmMachClass { TWO_AXIS_MC , THREE_AXIS_MC }
cam machine class More...
enum | evxCmMachType { CM_MACH_TYPE_VERTICAL , CM_MACH_TYPE_HORIZNTAL }
cam machine type More...
enum | evxCmMachSubType { CM_MACH_SUBTYPE_ROTATING_HEAD , CM_MACH_SUBTYPE_ROTATING_TABLE }
cam machine sub type More...
enum | evxCmMachCutCompenation { CM_MACH_CUT_COMPENSATION_NONE , CM_MACH_CUT_COMPENSATION_LENGTH , CM_MACH_CUT_COMPENSATION_CENTER }
cam machine cut type More...
enum evxCmMachAttr {
CM_MACH_NAME , CM_MACH_CLASS , CM_MACH_TYPE , CM_MACH_SUBTYPE ,
CM_MACH_POST_CONFIGURATION , CM_MACH_CUT_COMPENSATION
}
cam machine attribute More...
typedef enum evxCmMachClass | evxCmMachClass
cam machine class
typedef enum evxCmMachType | evxCmMachType
cam machine type
typedef enum evxCmMachSubType | evxCmMachSubType
cam machine sub type
typedef enum evxCmMachCutCompenation | evxCmMachCutCompenation
cam machine cut type
typedef enum evxCmMachAttr | evxCmMachAttr
cam machine attribute

Cam Machine Fun

evxErrors | cvxCmMachineInsert (evxCmMachClass machine_class, evxCmMachType machine_type, evxCmMachSubType sub_type, int *idx_machine)
evxErrors | cvxCmMachineActive (int idx_machine)
evxErrors | cvxCmMachineDelete (int idx_machine)
evxErrors | cvxCmMachineGetAttr (int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmMachineSetAttr (int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmToolChangerInsert (int idx_toolchanger, int Location, int Diameter, int Height)
evxErrors | cvxCmToolChangerDelete (int idx_toolchanger)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_op.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_op.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Operation.

Definition in file zwapi_cm_op.h.

Cam Operation Data

enum evxCmOpType {
ZW_CAM_OPERATION_CENTER = 0 , ZW_CAM_OPERATION_DRILL , ZW_CAM_OPERATION_PECK , ZW_CAM_OPERATION_CHIP ,
ZW_CAM_OPERATION_REAM , ZW_CAM_OPERATION_BORE , ZW_CAM_OPERATION_FINEBORE , ZW_CAM_OPERATION_COUNTERBORE ,
ZW_CAM_OPERATION_COUNTERSINK , ZW_CAM_OPERATION_TAP , ZW_CAM_OPERATION_PROFILECUT = 20 , ZW_CAM_OPERATION_SPIRAL ,
ZW_CAM_OPERATION_ZIGZAG , ZW_CAM_OPERATION_BOX , ZW_CAM_OPERATION_CONTOUR , ZW_CAM_OPERATION_CHAMFER ,
ZW_CAM_OPERATION_COURNER_ROUND , ZW_CAM_OPERATION_HELICAL , ZW_CAM_OPERATION_RAMP , ZW_CAM_OPERATION_TOPFACE_CUT ,
ZW_CAM_OPERATION_NESTING , ZW_CAM_OPERATION_INTER_PATH_MOVE , ZW_CAM_OPERATION_THREADMILL , ZW_CAM_OPERATION_DRILL_TURNING = 35 ,
ZW_CAM_OPERATION_FACING , ZW_CAM_OPERATION_ROUGH , ZW_CAM_OPERATION_FINISH , ZW_CAM_OPERATION_GROOVE ,
ZW_CAM_OPERATION_THREADING , ZW_CAM_OPERATION_PARTOFF , ZW_CAM_OPERATION_SPIRAL_ROUGH = 50 , ZW_CAM_OPERATION_ZIGZAG_ROUGH ,
ZW_CAM_OPERATION_BOX_ROUGH , ZW_CAM_OPERATION_CONTOUR_ROUGH , ZW_CAM_OPERATION_SPIRAL_CAST = 55 , ZW_CAM_OPERATION_ZIGZAG_CAST ,
ZW_CAM_OPERATION_BOX_CAST , ZW_CAM_OPERATION_CONTOUR_CAST , ZW_CAM_OPERATION_SPIRAL_FINISH = 60 , ZW_CAM_OPERATION_ZIGZAG_FINISH ,
ZW_CAM_OPERATION_BOX_FINISH , ZW_CAM_OPERATION_CONTOUR_FINISH , ZW_CAM_OPERATION_PROFILE_FINISH , ZW_CAM_OPERATION_SIDE ,
ZW_CAM_OPERATION_PEELING , ZW_CAM_OPERATION_ISO , ZW_CAM_OPERATION_3XISO , ZW_CAM_OPERATION_MAP ,
ZW_CAM_OPERATION_REST , ZW_CAM_OPERATION_PENCIL_TRACE , ZW_CAM_OPERATION_SCALLOP_REMOVAL , ZW_CAM_OPERATION_SURFACE_ENGRAVING ,
ZW_CAM_OPERATION_SMOOTHFLOW = 80 , ZW_CAM_OPERATION_OFFSET2D , ZW_CAM_OPERATION_LACE_ROUGH , ZW_CAM_OPERATION_PLUNGE ,
ZW_CAM_OPERATION_PRE_DRILL , ZW_CAM_OPERATION_OFFSET3D , ZW_CAM_OPERATION_LACE_FINISH , ZW_CAM_OPERATION_ANGLE_LIMITING_FINISHING ,
ZW_CAM_OPERATION_DRIVE_CURVE , ZW_CAM_OPERATION_ZLEVEL , ZW_CAM_OPERATION_PENCIL , ZW_CAM_OPERATION_FLOW_3D ,
ZW_CAM_OPERATION_BULGE , ZW_CAM_OPERATION_ENGRAVE_2D , ZW_CAM_OPERATION_SMOOTHFLOW_HSM = 95 , ZW_CAM_OPERATION_OFFSET2D_HSM ,
ZW_CAM_OPERATION_LACE_HSM , ZW_CAM_OPERATION_FLOW_HSM , ZW_CAM_OPERATION_CORNERFINISH , ZW_CAM_OPERATION_FLATFINISH ,
ZW_CAM_OPERATION_PLANE = 110 , ZW_CAM_OPERATION_SWARF , ZW_CAM_OPERATION_DRIVECURVE_5X , ZW_CAM_OPERATION_INTERACTIVE ,
ZW_CAM_OPERATION_FLOW_5X , ZW_CAM_OPERATION_SIDE_5X , ZW_CAM_OPERATION_GUIDE_SURFACE_ISO
}
cam operation type More...
enum | evxCm2XOpAttr { ZW_CAM_2X_OPERATION_ATTR_NAME = 300 , ZW_CAM_2X_OPERATION_ATTR_FRAME , ZW_CAM_2X_OPERATION_ATTR_PATH_TOL }
cam mill2 operation attribute More...
enum evxCmQmOpAttr {
ZW_CAM_QM_OPERATION_ATTR_NAME = 400 , ZW_CAM_QM_OPERATION_ATTR_FRAME , ZW_CAM_QM_OPERATION_ATTR_PATH_TOL , ZW_CAM_QM_OPERATION_ATTR_SURF_THICK ,
ZW_CAM_QM_OPERATION_ATTR_Z_SURF_THICK , ZW_CAM_QM_OPERATION_ATTR_TOOL , ZW_CAM_QM_OPERATION_ATTR_MINTOOLHEIGHT , ZW_CAM_QM_OPERATION_ATTR_CLASS ,
ZW_CAM_QM_OPERATION_ATTR_LIMIT_TOPZ , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOMZ , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE , ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_ZDISPLACEMENT ,
ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_OFFSET
}
cam qm operation attribute More...
enum | evxCmOpClass { CM_OP_ROUGH = 0 , CM_OP_FINISH = 1 }
cam operation class: finish or rough More...
typedef enum evxCmOpType | evxCmOpType
cam operation type
typedef enum evxCm2XOpAttr | evxCm2XOpAttr
cam mill2 operation attribute
typedef enum evxCmQmOpAttr | evxCmQmOpAttr
cam qm operation attribute
typedef enum evxCmOpClass | evxCmOpClass
cam operation class: finish or rough

Cam Operation Fun

evxErrors | cvxCmOpInsert (evxCmOpType opType, int *idx_Op)
evxErrors | cvxCmOpDelete (int idx_Op)
evxErrors | cvxCmOpDuplicate (int idx_Op, int *cpyOp)
evxErrors | cvxCmOpAddComp (int idx_Op, int idx_CmComp)
evxErrors | cvxCmOpRemoveComp (int idx_Op, int idx_CmComp)
evxErrors | cvxCmOpAddFtr (int idx_Op, int idx_FtrGrp)
evxErrors | cvxCmOpRemoveFtr (int idx_Op, int idx_ftrgrp)
evxErrors | cvxCmOpCalTPath (int idx_Op)
evxErrors | cvxCmOpAddTool (int idx_Op, int idx_Tool)
evxErrors | cvxCmOpRemoveTool (int idx_Op)
evxErrors | cvxCmOpGetAttr (int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmOpSetAttr (int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
evxErrors | cvxCmOpSetAttrAsCfg (int idx_Op, const vxLongPath cfg_location)
evxErrors | cvxCmOpSetSpeed (int idx_op, vxName spdfdName)
evxErrors | cvxCmOpSetAttr2 (int idx_op, int field, int item, const char *value)
evxErrors | cvxCmOpGetAttr2 (int idx_op, int field, int item, int *is_on, char *value)
evxErrors | cvxCmOpGetIdxFromName (vxLongName op_name, int *op_index)
evxErrors | cvxCmSetOpPoint (int idx_op, svxPoint p0, int field)
evxErrors | cvxCmSetOpPoints (int idx_op, int num, svxPoint *pts, int field)
evxErrors | cvxCmOpRename (int idx_op, vxLongName op_newName)
evxErrors | cvxCmOpDrag (int drag_idx, evxCmTreeType drag_type, int drop_idx, evxCmTreeType drop_type, int iPos)
evxErrors | cvxCmOpSetBasicAttr (int idx_op, int field, int item, const char *value)
evxErrors | cvxCmOpInqClass (int idx_Op, evxCmOpClass *opClass)
evxErrors | cvxCmOpSetClass (int idx_Op, evxCmOpClass opClass)
evxErrors | cvxCmOpInqTypeS (int idx_Op, char *opType, int nByte)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_query.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_query.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D API of the Cam Query.

Definition in file zwapi_cm_query.h.

Cam Query Data

enum evxCmObjType {
CM_OPERATION , CM_OPFOLDER , CM_TOOL , CM_MACHINE ,
CM_CMCOMP , CM_FTR , CM_FRAME , CM_OUT
}
cam object type More...
typedef enum evxCmObjType evxCmObjType
cam object type

Cam Query Fun

evxErrors | cvxCmInqAl (evxCmObjType type, int *cnt, int **idx_obj)
evxErrors | cvxCmSolidVerify (int *gouge)
evxErrors | cvxCmClashDetect (int partIdx, int stockIdx, int cnt, int *idx_op)
evxErrors | cvxCmGougeDetect (int partIdx, int stockIdx, int cnt, int *idx_op)
evxErrors | cvxCmConfigFileGetString (const char *form, int field, int casesensitive, char *dbstring, char *guistring, int *ifound)
evxErrors | cvxCmInqOpName (int idx_op, vxLongName opName)
evxErrors | cvxCmInqIndexFromName (evxCmObjType objClass, vxLongName sName, int *index)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_tool.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cm_tool.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE API of the Cam Tool.

Definition in file zwapi_cm_tool.h.

Cam Tool Data

enum evxCmToolType {
CM_TOOL_TYPE_MILL , CM_TOOL_TYPE_FLAME , CM_TOOL_TYPE_DRILL , CM_TOOL_TYPE_TAP ,
CM_TOOL_TYPE_CENTER , CM_TOOL_TYPE_CHAMFER , CM_TOOL_TYPE_REAM , CM_TOOL_TYPE_BORE
}
cam tool type More...
enum | evxCmToolSubType { CM_TOOL_SUBTYPE_NULL = -1 , CM_TOOL_SUBTYPE_BALLNOSE , CM_TOOL_SUBTYPE_BULLNOSE , CM_TOOL_SUBTYPE_ENDNOSE }
cam tool sub type More...
enum evxCmToolAttr {
CM_TOOL_NAME = 400 , CM_TOOL_TYPE , CM_TOOL_SUBTYPE , CM_TOOL_ID ,
CM_TOOL_LEN , CM_TOOL_CUTTERDIAMETER , CM_TOOL_HOLDER , CM_TOOLCHANGER_LOCATION ,
CM_TOOLCHANGER_DIAMETER , CM_TOOLCHANGER_HEIGHT
}
cam tool attribute More...
typedef enum evxCmToolType | evxCmToolType
cam tool type
typedef enum evxCmToolSubType | evxCmToolSubType
cam tool sub type
typedef enum evxCmToolAttr | evxCmToolAttr
cam tool attribute

Cam Query Fun

evxErrors | cvxCmToolInsert (evxCmToolType tltype, evxCmToolSubType subtype, int *idx_tool)
evxErrors | cvxCmToolInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName tool_name, int *idx_tool)
evxErrors | cvxCmToolDelete (int idx_tool)
evxErrors | cvxCmToolGetAttr (int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmToolSetAttr (int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
evxErrors | cvxCmHolderInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName holder_name, int *idx_holder)
evxErrors | cvxCmSpeedInsertAsTemplate (const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName spdfd_name, int *idx_speed)
evxErrors | cvxCmToolGetData (int idx_tool, evxCmToolAttr attr, char *value)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd.h File Reference
#include "zwapi_cmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Command Common API

Definition in file zwapi_cmd.h.

Command Send

void | cvxNewCommand (void)
void | cvxCmdBuffer (const char *String, int Priority)
void | cvxCmdSend (char *CommandString)

Command Operation

evxErrors | cvxCmdChkLic (const vxName Name)
evxErrors | cvxCmdAction (evxCmdAction type, svxCmdActionParam *param)

Function Register/Un-register

evxErrors | cvxCmdFunc (const vxName Name, void *Function, double Code)
void | cvxCmdCallback (const vxName Name, void *Function)
evxErrors | cvxCmdFuncUnload (const vxName Name)
void | cvxCmdVariable (vxName Name, void *Variable)
evxErrors | cvxCmdVariableUnload (const vxName Name)
evxErrors | cvxCmdRegisterRcc (vxName File)
evxErrors | cvxCmdUnRegisterRcc (vxName File)

Macro

evxErrors | cvxCmdMacro (char *Input, char **Output)
evxErrors | cvxCmdMacro2 (char *path)
evxErrors | cvxMacroInqPath (vxPath path, vxPath file)
evxErrors | cvxMacroInqPathByLongPath (char *path, int sizepath, char *file, int filesize)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_assembly.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_assembly.h File Reference
#include "zwapi_cmd_assembly_data.h"
#include "zwapi_cmd_shape_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Assembly Commands API

Definition in file zwapi_cmd_assembly.h.

Component

int | cvxCompIns (svxCompData *Comp, int *idComp)
evxErrors | cvxCompInclude (const svxCompIncludeData *Comp, int *idComp)
evxErrors | cvxCompMerge (evxBoolType Combine, int idComp, int *idShape)
evxErrors | cvxCompMerge2 (evxBoolType Combine, int idComp, int MergeDim, int MergeWire, int *idShape)
evxErrors | cvxCompExtract (int idShape, svxMatrix *Frame, vxLongName Name, int NewFile, evxResponse Overwrite, int *idComp)
evxErrors | cvxPartGeomExport (svxGeomExport *Data)
evxErrors | cvxPartGeomExportII (svxGeomExport *Data)
evxErrors | cvxPartIns (svxPartInstData *Part, int *Count, int **ShapeList)

Common Constraint

evxErrors | cvxCompAddCoincidentCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddTangentCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddConcentricCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddParallelCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddPerpendicularCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddAngularCons (svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddLockCons (svxEntPath *Comp1, svxEntPath *Comp2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddDistanceCons (svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddMiddleCons (svxEntPath *BaseEnt1, svxEntPath *BaseEnt2, int nCenter, svxEntPath *CenterEnts, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddSymmetryCons (svxEntPath *Plane, svxEntPath *SymEnt1, svxEntPath *SymEnt2, svxConsData *ConsData, int *idCons)
evxErrors | cvxCompAddFrameCons (svxEntPath *Datum1, svxEntPath *Datum2, svxConsData *ConsData, int *idCons)

Mechanical Constraint

evxErrors | cvxCompAddGearCons (const svxEntPath *Gear1, const svxEntPath *Gear2, const svxGearConsData *ConsData, int *idCons)
evxErrors | cvxCompAddPathCons (const svxPntOnEntPath *Pnt, int nPaths, const svxEntPath *Paths, const svxPathConsData *ConsData, int *idCons)
evxErrors | cvxCompAddLinearCoupleCons (const svxEntPath *Comp1, const svxEntPath *Dir1, const svxEntPath *Comp2, const svxEntPath *Dir2, const svxLinearCpData *ConsData, int *idCons)
evxErrors | cvxCompAddRackPinionCons (const svxEntPath *Rack, const svxEntPath *Pinion, const svxRackPinionData *ConsData, int *idCons)
evxErrors | cvxCompAddScrewCons (const svxEntPath *ScrewEnt, const svxEntPath *LinearEnt, const svxScrewConsData *ConsData, int *idCons)
evxErrors | cvxCompAddSlotCons (const svxEntPath *Ent, int nSlots, const svxEntPath *Slots, const svxSlotConsData *ConsData, int *idCons)
evxErrors | cvxCompAddCamCons (const svxEntPath *Ent, int nCamFaces, const svxEntPath *CamFaces, int *idCons)
evxErrors | cvxCompAddUniJointCons (const svxEntPath *Shaft1, const svxPntOnEntPath *HingePnt1, const svxEntPath *Shaft2, const svxPntOnEntPath *HingePnt2, const svxUniJointData *ConsData, int *idCons)

Other Constraint

evxErrors | cvxPartAlign (svxAlign *Align)
evxErrors | cvxPartAnchor (int idEntity)

Basic Editing

evxErrors | cvxCompPtnInit (evxAsmPatternType type, svxAsmPtnData *data)
evxErrors | cvxCompPtn (const svxAsmPtnData *data, int *idPattern)
evxErrors | cvxCompMoveInit (evxAsmMoveType type, svxAsmMove *data)
evxErrors | cvxCompMove (const svxAsmMove *data)
evxErrors | cvxCompMirrorInit (evxAsmMirrorType type, svxAsmMirror *data)
evxErrors | cvxCompMirror (const svxAsmMirror *data, int *idMirror)
evxErrors | cvxAsmCutInit (svxAsmCut *data)
evxErrors | cvxAsmCut (const svxAsmCut *data, int *idCut)
evxErrors | cvxAsmFilletInit (evxChamFlltType type, svxAsmFllt *data)
evxErrors | cvxAsmFillet (const svxAsmFllt *data, int *idFllt)
evxErrors | cvxAsmChamferInit (evxAsmChmfType type, svxAsmChmf *data)
evxErrors | cvxAsmChamfer (const svxAsmChmf *data, int *idChmf)

Inquire

evxErrors | cvxCompIsectShpChk (svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int *fInterfer)
evxErrors | cvxCompIsectShpChk2 (svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int fClosedChk, int *fInterfer)
evxErrors | cvxCompIferCheck (svxEntPath *BaseComp, svxEntPath *ChkComp, int SubAsmAsWhole, int IgnoreHidden, int *IferCnt, svxIferChkResData **IferResults)
evxErrors | cvxCompClearCheck (int Count, svxEntPath *Comps, double Clear, int ChkCompShp, int IgnoreHidden, int ChkSubAsm, int *ClrCnt, svxClrChkData **ClrDatas)
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_assembly_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_assembly_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_shape_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Assembly Command functions.

Definition in file zwapi_cmd_assembly_data.h.

Component Insert Data

enum | evxResponse { VX_CANCEL = -1 , VX_NO = 0 , VX_YES = 1 , VX_YES_ALL = 2 }
response to user prompt More...
typedef struct svxCompData | svxCompData
component data
typedef struct svxCompIncludeData | svxCompIncludeData
include component data
typedef struct svxGeomExport | svxGeomExport
geometry export
typedef struct svxPartInstData | svxPartInstData
copy external part data
typedef enum evxResponse | evxResponse
response to user prompt

Assembly Constraint Data

enum evxAlignType {
VX_ALIGN_COINCIDENT = 0 , VX_ALIGN_TANGENT = 1 , VX_ALIGN_CONCENTRIC = 2 , VX_ALIGN_PARALLEL = 3 ,
VX_ALIGN_PERPENDICULAR = 4 , VX_ALIGN_ANGLE = 5
}
part component/shape alignment More...
enum | evxAlignInterference { VX_INTERFERENCE_NONE = 0 , VX_INTERFERENCE_HIGHLIGHT = 1 , VX_INTERFERENCE_STOP_AT = 2 , VX_INTERFERENCE_ADD_ALIGN = 3 }
interference type More...
enum evxConsType {
VX_NONE = 0x00000L , VX_CONCENTRIC = 0x00001L , VX_COINCIDENT = 0x00002L , VX_TANGENT = 0x00004L ,
VX_PARALLEL = 0x00008L , VX_PERPENDICULAR = 0x00010L , VX_AT_DISTANCE = 0x00040L , VX_AT_ANGLE_FULL = 0x00080L ,
VX_GEAR = 0x00100L , VX_SYMMETRIC = 0x00200L , VX_ADV_LOCKED = 0x00400L , VX_ADV_MIDDLE = 0x00800L ,
VX_ADV_FRAME = 0x01000L , VX_ADV_PATH = 0x02000L , VX_MC_LINEAR_COUPLER = 0x04000L , VX_MC_RACK_PINION = 0x08000L ,
VX_MC_SCREW = 0x10000L , VX_MC_SLOT = 0x2000000L , VX_MC_CAM = 0x4000000L , VX_MC_UNIV_JOINT = 0x00104L
}
assembly constraint type More...
enum | evxPathConsType { VX_PATH_CONS_FREE = 0 , VX_PATH_CONS_DISTANCE = 1 , VX_PATH_CONS_PERCENT = 2 }
path constraint type More...
enum | evxPitchYawType { VX_PITCH_YAW_FREE = 0 , VX_PITCH_YAW_FOLLOW_PATH = 1 }
pitch/yaw type More...
enum | evxRollCtrlType { VX_ROLL_CTRL_FREE = 0 , VX_ROLL_CTRL_UP_VEC = 1 }
roll control type More...
enum | evxSlotConsType { VX_SLOT_CONS_FREE = 0 , VX_SLOT_CONS_CENTER = 1 , VX_SLOT_CONS_DISTANCE = 2 , VX_SLOT_CONS_PERCENT = 3 }
slot constraint type More...
enum evxConsState {
VX_UNKNOWN , VX_UN_CONSTRAINED , VX_UNDER_CONSTRAINED , VX_WELL_CONSTRAINED ,
VX_FIXED , VX_OVER_CONSTRAINED
}
constraint state of component More...
typedef enum evxAlignType | evxAlignType
part component/shape alignment
typedef enum evxAlignInterference | evxAlignInterference
interference type
typedef struct svxAlign | svxAlign
Alignment constraint.
typedef enum evxConsType | evxConsType
assembly constraint type
typedef struct svxConsData | svxConsData
custom data for assembly common constraint
typedef struct svxGearConsData | svxGearConsData
custom data for assembly gear constraint
typedef enum evxPathConsType | evxPathConsType
path constraint type
typedef enum evxPitchYawType | evxPitchYawType
pitch/yaw type
typedef enum evxRollCtrlType | evxRollCtrlType
roll control type
typedef struct svxPathConsData | svxPathConsData
custom data for assembly path constraint
typedef struct svxLinearCpData | svxLinearCpData
custom data for assembly linear couple constraint
typedef struct svxRackPinionData | svxRackPinionData
custom data for assembly rack and pinion constraint
typedef struct svxScrewConsData | svxScrewConsData
custom data for assembly screw constraint
typedef enum evxSlotConsType | evxSlotConsType
slot constraint type
typedef struct svxSlotConsData | svxSlotConsData
custom data for assembly slot constraint
typedef struct svxUniJointData | svxUniJointData
custom data for assembly universal joint constraint
typedef enum evxConsState | evxConsState
constraint state of component

Basic Editing Data

enum evxAsmPatternType {
VX_ASM_PTN_LINEAR , VX_ASM_PTN_CIRCULAR , VX_ASM_PTN_POINT , VX_ASM_PTN_PATTERN ,
VX_ASM_PTN_CRV , VX_ASM_PTN_FACE
}
assembly pattern method More...
enum | evxAsmPtnStagger { VX_ASM_PTN_NO_STAGGER , VX_ASM_PTN_STAGGER }
assembly pattern stagger method More...
enum | evxAsmPtnDrv { VX_ASM_PTN_DRV_NONE , VX_ASM_PTN_DRV_SPACING , VX_ASM_PTN_DRV_NUM }
assembly pattern derive method More...
enum | evxAsmPtnAlg { VX_ASM_PTN_ALG_BASE , VX_ASM_PTN_ALG_PTN }
assembly pattern alignment method More...
enum | evxAsmPtnCrv { VX_ASM_PTN_CRV1 , VX_ASM_PTN_CRV2_TOG , VX_ASM_PTN_CRV2_ACROSS , VX_ASM_PTN_CRV3 }
assembly pattern curves method More...
enum | evxAsmPtnBnd { VX_ASM_PTN_BND_AUTO , VX_ASM_PTN_BND_PALCE , VX_ASM_PTN_BND_MOVE }
assembly pattern boundary method More...
enum evxAsmMoveType {
VX_ASM_MOVE_PNT = 1 , VX_ASM_MOVE_ALONG_DIR , VX_ASM_MOVE_ALIGN , VX_ASM_MOVE_SWEEP ,
VX_ASM_MOVE_AROUND_DIR , VX_ASM_MOVE_DYNAMIC
}
assembly move method More...
enum | evxAsmMoveFrame { VX_ASM_MOVE_FRAME_NTR , VX_ASM_MOVE_FRAME_PATH , VX_ASM_MOVE_FRAME_SLC }
assembly move frame method More...
enum | evxAsmMoveZSpine { VX_ASM_MOVE_Z_NTR , VX_ASM_MOVE_Z_SPINE , VX_ASM_MOVE_Z_PARALLEL }
assembly move z-spine method More...
enum | evxAsmMoveXOrnt { VX_ASM_MOVE_X_NTR , VX_ASM_MOVE_X_GUIDE , VX_ASM_MOVE_X_AXIS }
assembly move x-orient method More...
enum | evxAsmMirrorType { VX_ASM_MIRROR_COPY , VX_ASM_MIRROR_DUP }
assembly mirror method More...
enum evxAsmMirrorSymm {
VX_ASM_MIRROR_SYMM_XZ , VX_ASM_MIRROR_SYMM_YZ , VX_ASM_MIRROR_SYMM_XY , VX_ASM_MIRROR_SYMM_C ,
VX_ASM_MIRROR_SYMM_XCZC , VX_ASM_MIRROR_SYMM_YCZC , VX_ASM_MIRROR_SYMM_XCYC , VX_ASM_MIRROR_SYMM_NONE
}
assembly mirror self-symmetric method More...
enum | evxAsmMirrorCenter { VX_ASM_MIRROR_CTR_BOX , VX_ASM_MIRROR_CTR_MASS , VX_ASM_MIRROR_CTR_FRAME }
assembly mirror center method More...
enum | evxAsmMirrorCategory { VX_ASM_MIRROR_CAT_COPY , VX_ASM_MIRROR_CAT_DUP , VX_ASM_MIRROR_CAT_DEL }
assembly mirror category method More...
enum | evxAsmFlltArc { VX_ASM_FLLT_ARC_CIR , VX_ASM_FLLT_ARC_CONIC }
assembly fillet arc method More...
enum | evxAsmFlltBase { VX_ASM_FLLT_BASE_NO , VX_ASM_FLLT_BASE_DIV , VX_ASM_FLLT_BASE_TRIM , VX_ASM_FLLT_BASE_SEW }
assembly fillet base faces method More...
enum | evxAsmFlltFace { VX_ASM_FLLT_FACE_MAX , VX_ASM_FLLT_FACE_MIN , VX_ASM_FLLT_FACE_MATCH }
assembly fillet fillet face method More...
enum evxAsmFlltLoop {
VX_ASM_FLLT_LOOP_IN , VX_ASM_FLLT_LOOP_OUT , VX_ASM_FLLT_LOOP_SHARE , VX_ASM_FLLT_LOOP_BOUND ,
VX_ASM_FLLT_LOOP_ALL , VX_ASM_FLLT_LOOP_SELECT
}
assembly fillet loop method More...
enum | evxAsmChmfType { VX_ASM_CHMF_EDGE , VX_ASM_CHMF_VERTEX = 2 }
assembly chamfer method More...
enum | evxAsmChmfBase { VX_ASM_CHMF_BASE_NO , VX_ASM_CHMF_BASE_DIV , VX_ASM_CHMF_BASE_TRIM , VX_ASM_CHMF_BASE_SEW }
assembly chamfer base faces method More...
enum | evxAsmChmfFace { VX_ASM_CHMF_FACE_MAX , VX_ASM_CHMF_FACE_MIN , VX_ASM_CHMF_FACE_MATCH }
assembly chamfer fillet face method More...
typedef enum evxAsmPatternType | evxAsmPatternType
assembly pattern method
typedef enum evxAsmPtnStagger | evxAsmPtnStagger
assembly pattern stagger method
typedef enum evxAsmPtnDrv | evxAsmPtnDrv
assembly pattern derive method
typedef enum evxAsmPtnAlg | evxAsmPtnAlg
assembly pattern alignment method
typedef enum evxAsmPtnCrv | evxAsmPtnCrv
assembly pattern curves method
typedef enum evxAsmPtnBnd | evxAsmPtnBnd
assembly pattern boundary method
typedef enum evxAsmMoveType | evxAsmMoveType
assembly move method
typedef enum evxAsmMoveFrame | evxAsmMoveFrame
assembly move frame method
typedef enum evxAsmMoveZSpine | evxAsmMoveZSpine
assembly move z-spine method
typedef enum evxAsmMoveXOrnt | evxAsmMoveXOrnt
assembly move x-orient method
typedef enum evxAsmMirrorType | evxAsmMirrorType
assembly mirror method
typedef enum evxAsmMirrorSymm | evxAsmMirrorSymm
assembly mirror self-symmetric method More...
typedef enum evxAsmMirrorCenter | evxAsmMirrorCenter
assembly mirror center method
typedef enum evxAsmMirrorCategory | evxAsmMirrorCategory
assembly mirror category method
typedef enum evxAsmFlltArc | evxAsmFlltArc
assembly fillet arc method
typedef enum evxAsmFlltBase | evxAsmFlltBase
assembly fillet base faces method
typedef enum evxAsmFlltFace | evxAsmFlltFace
assembly fillet fillet face method
typedef enum evxAsmFlltLoop | evxAsmFlltLoop
assembly fillet loop method
typedef enum evxAsmChmfType | evxAsmChmfType
assembly chamfer method
typedef enum evxAsmChmfBase | evxAsmChmfBase
assembly chamfer base faces method
typedef enum evxAsmChmfFace | evxAsmChmfFace
assembly chamfer fillet face method
typedef struct svxAsmPtnData | svxAsmPtnData
assembly pattern data
typedef struct svxAsmMove | svxAsmMove
assembly move data
typedef struct svxAsmMirror | svxAsmMirror
assembly mirror data
typedef struct svxAsmCut | svxAsmCut
assembly cut data
typedef struct svxAsmFllt | svxAsmFllt
assembly fillet data
typedef struct svxAsmChmf | svxAsmChmf
assembly chamfer data

Inquire

typedef struct svxIferChkResData | svxIferChkResData
Interference check result data.
typedef struct svxClrChkData | svxClrChkData
clearance check result data
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Command Container and Command Parameter.

Definition in file zwapi_cmd_data.h.

Command Operation Data

#define | VX_CODE_GENERAL 0.0
#define | VX_CODE_ADV_RENDERING 1.0
#define | VX_CODE_ASSEMBLY 2.0
#define | VX_CODE_ADV_ASSEMBLY 17179869184.0
#define | VX_CODE_DRAFTING 4.0
#define | VX_CODE_WIREFRAME 8589934592.0
#define | VX_CODE_MODELING 512.0
#define | VX_CODE_ADV_MODELING 34359738368.0
#define | VX_CODE_ADV_SURF 256.0
#define | VX_CODE_MOLD_DESIGN 1024.0
#define | VX_CODE_HEALING 4294967296.0
#define | VX_CODE_POST 2199023255552.0
#define | VX_CODE_KEYSHOT 576460752303423488.0
#define | VX_CODE_ELECTRODE 1152921504606846976.0
#define | VX_CODE_PARTSOLUTIONS 32768.0
#define | VX_CODE_MISUMI VX_CODE_GENERAL
enum | evxCmdAction { VX_CMD_START = 0 , VX_CMD_FINISHED }
command action type More...
enum | evxCmdState { VX_CMD_ENABLE = 0 , VX_CMD_DISABLE = 1 }
command state type More...
enum evxCmdType {
VX_STANDARD_COMMAND = -1 , VX_HIST_GENERAL = 0 , VX_HIST_SOLID_CREATE = 11 , VX_HIST_SOLID_EDIT = 12 ,
VX_HIST_SURF_CREATE = 13 , VX_HIST_SURF_EDIT = 14 , VX_HIST_CRV_CREATE = 15 , VX_HIST_CRV_EDIT = 16 ,
VX_HIST_COMP = 17 , VX_HIST_SKETCH = 18 , VX_HIST_DATUM = 19 , VX_HIST_FILLET = 20 ,
VX_HIST_SHELL = 21 , VX_HIST_SHT_METAL = 22 , VX_HIST_HOLE = 23 , VX_HIST_CRV_LIST = 24 ,
VX_HIST_IMPORT = 25 , VX_HIST_REF_GEOM = 26 , VX_HIST_EQN = 27 , VX_HIST_HEAL = 28 ,
VX_HIST_ERASE = 29 , VX_HIST_BLANK = 30 , VX_HIST_ATTRIBUTE = 33 , VX_HIST_RENDER = 34 ,
VX_HIST_ANALYZE = 35 , VX_HIST_MOVE = 37 , VX_HIST_TEXT = 38 , VX_HIST_POINT = 39 ,
VX_HIST_DRAFT = 40 , VX_HIST_ASSEMBLY = 41 , VX_HIST_TAG = 42 , VX_HIST_MOLD = 43
}
command types More...
typedef enum evxCmdAction | evxCmdAction
command action type
typedef enum evxCmdState | evxCmdState
command state type
typedef struct svxCmdActionParam | svxCmdActionParam
command action parameter
typedef enum evxCmdType | evxCmdType
command types

Data Get Data

enum | evxFldNumType { VX_INP_DOUBLE = 0 , VX_INP_INTEGER = 1 , VX_INP_DISTANCE = 2 , VX_INP_ANGLE = 3 }
numeric input field type More...
enum evxFldType {
VX_FLD_NULL = 0 , VX_FLD_NUM = 1 , VX_FLD_DST = 2 , VX_FLD_ANG = 3 ,
VX_FLD_PNT = 4 , VX_FLD_ENT = 5 , VX_FLD_TXT = 6 , VX_FLD_DATA = 7
}
point input data types More...
typedef enum evxFldNumType | evxFldNumType
numeric input field type
typedef enum evxFldType | evxFldType
point input data types
typedef struct svxFldData | svxFldData
field data
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dataexchange.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dataexchange.h File Reference
#include "zwapi_cmd_dataexchange_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Exchange Command API

Definition in file zwapi_cmd_dataexchange.h.

Import

evxErrors | cvxPartRefGeom (svxEntPath *GeomPath, int AssociativeCopy, int *idGeom)
evxErrors | cvxPartPublishSet (const vxName Name, int Count, const int *idEnts, int *idPubSet)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dataexchange_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dataexchange_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Data Exchange Command functions.

Definition in file zwapi_cmd_dataexchange_data.h.

Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_datum.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_datum.h File Reference
#include "zwapi_cmd_datum_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Datum/Axis/CSYS Commands API

Definition in file zwapi_cmd_datum.h.

Datum Axis

evxErrors cvxPartAxisNew (svxAxisData *Axis, int *idAxis)

Datum Plane

evxErrors | cvxPartDatum (svxMatrix *Frame, int *idDatum)
evxErrors | cvxPartDatum2 (svxMatrix *Frame, int iCode, int *idDatum)
evxErrors | cvxPartNewDatum (svxMatrix *Frame, int *idDatum)
evxErrors | cvxPartPlnCrv (int idCrv, svxPoint *Origin, svxPoint *Xaxis, int *idPln)
evxErrors | cvxPartPlnCrv2 (int idCrv, svxData *Origin, svxData *Xaxis, int Flip, int *idPln)
evxErrors | cvxPartPlnSrf (int idFace, svxPoint *Origin, int *idPln)
evxErrors | cvxPartPlnSrf2 (int idFace, svxPoint *Origin, svxPoint *XZ, int Flip, int *idPln)
evxErrors | cvxPartPlaneNew (svxPlaneData *Plane, int *idPlane)
evxErrors | cvxPartPlaneAddInit (evxNewPlaneMethods method, svxNewPlaneData *data)
evxErrors | cvxPartPlaneAdd (const svxNewPlaneData *plane, int *idPlane)

Datum CSYS

evxErrors | cvxPartCSYSNewInit (evxCSYSMethods method, svxCSYSData *data)
evxErrors | cvxPartCSYSNew (svxCSYSData *CSYS, int *idCSYS)

LCS

evxErrors cvxPartActiveAsLCS (int id)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_datum_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_datum_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_subcmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Datum/ Axis/CSYS Command functions.

Definition in file zwapi_cmd_datum_data.h.

Datum Axis Data

enum evxAxisMethods {
VX_AXIS_GEOMETRY = 0 , VX_AXIS_FACE_CENTER = 1 , VX_AXIS_XX = 2 , VX_AXIS_YY = 3 ,
VX_AXIS_ZZ = 4 , VX_AXIS_TWO_PNT = 5 , VX_AXIS_PNT_DIR = 6 , VX_AXIS_INTERSECT_FACES = 7
}
Axis Methods. More...
typedef enum evxAxisMethods | evxAxisMethods
Axis Methods.
typedef struct svxAxisData | svxAxisData
template command Axis input data

Datum Plane

enum evxPlaneMethods {
VX_PLANE_GEOMETRY = 0 , VX_PLANE_THREE_POINTS = 1 , VX_PLANE_XY = 2 , VX_PLANE_XZ = 3 ,
VX_PLANE_YZ = 4 , VX_PLANE_VIEW_PLANE = 5 , VX_PLANE_TWO_ENTITIES = 6 , VX_PLANE_DYNAMIC = 7
}
Plane Methods. More...
enum | evxPlaneAlign { VX_PLANE_ALIGN_TO_XY = 1 , VX_PLANE_ALIGN_TO_XZ = 2 , VX_PLANE_ALIGN_TO_YZ = 3 }
Plane Orientation Align type. More...
enum evxNewPlaneMethods {
VX_NEW_PLANE_THREE_POINTS = 1 , VX_NEW_PLANE_VIEW_PLANE = 5 , VX_NEW_PLANE_DYNAMIC = 7 , VX_NEW_PLANE_GEOMETRY = 11 ,
VX_NEW_PLANE_OFFSET_PLANE = 12 , VX_NEW_PLANE_ANGLE_FACE = 13 , VX_NEW_PLANE_ON_CURVE = 14
}
New Plane Methods. More...
enum | evxOnCrvDirType { VX_ONCRV_TANGENT , VX_ONCRV_PERPENDICULAR , VX_ONCRV_PERPENDICULAR_TO_CURVE , VX_ONCRV_TANGENT_TO_CURVE }
Plane direction type. More...
typedef enum evxPlaneMethods | evxPlaneMethods
Plane Methods.
typedef enum evxPlaneAlign | evxPlaneAlign
Plane Orientation Align type.
typedef struct svxPlaneData | svxPlaneData
template command Plane input data
typedef enum evxNewPlaneMethods | evxNewPlaneMethods
New Plane Methods.
typedef enum evxOnCrvDirType | evxOnCrvDirType
Plane direction type.
typedef struct svxNewPlaneData | svxNewPlaneData
New template command Plane input data.

Datum CSYS

enum evxCSYSMethods {
VX_CSYS_THREE_POINTS = 1 , VX_CSYS_ONLY_MATRIX = 6 , VX_CSYS_DYNAMIC = 7 , VX_CSYS_THREE_FACES = 8 ,
VX_CSYS_PNT_AND_TWO_DIR = 9 , VX_CSYS_PLANE_PNT_AND_DIR = 10 , VX_CSYS_GEOMETRY = 11
}
CSYS Methods. More...
enum | evsResultsAxisMethod { VX_RESULTS_AXIS_X , VX_RESULTS_AXIS_Y , VX_RESULTS_AXIS_Z }
Results axis. More...
typedef enum evxCSYSMethods | evxCSYSMethods
CSYS Methods.
typedef enum evsResultsAxisMethod | evsResultsAxisMethod
Results axis.
typedef struct svxCSYSData | svxCSYSData
template command CSYS input data
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_direct_edit.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_direct_edit.h File Reference
#include "zwapi_cmd_direct_edit_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Direct Edit Commands API

Definition in file zwapi_cmd_direct_edit.h.

Modify

evxErrors | cvxPartDEMoveInit (evxDEMoveCopyType type, svxDEMove *data)
evxErrors | cvxPartDEMove (const svxDEMove *data, int *idMove)
evxErrors | cvxPartDEAlignMoveInit (evxDEAlignMoveType type, svxDEAlignMove *data)
evxErrors | cvxPartDEAlignMove (const svxDEAlignMove *data, int *idMove)
evxErrors | cvxPartDEDimMoveInit (evxDEDimMoveType type, svxDEDimMove *data)
evxErrors | cvxPartDEDimMove (const svxDEDimMove *data, int *idMove)
evxErrors | cvxPartDEOffsetInit (svxDEOffset *data)
evxErrors | cvxPartDEOffset (const svxDEOffset *data, int *idOffset)
evxErrors | cvxPartDEDraftInit (svxDEDraft *data)
evxErrors | cvxPartDEDraft (const svxDEDraft *data, int *idDraft)

Reuse

evxErrors | cvxPartDECopyInit (evxDEMoveCopyType type, svxDECopy *data)
evxErrors | cvxPartDECopy (const svxDECopy *data, int *idCopy)
evxErrors | cvxPartDEMirrorInit (svxDEMirror *data)
evxErrors | cvxPartDEMirror (const svxDEMirror *data, int *idMirror)
evxErrors | cvxPartDEPtnInit (evxDEPtnType type, svxDEPattern *data)
evxErrors | cvxPartDEPtn (const svxDEPattern *data, int *idPtn)

Resize

evxErrors | cvxPartDEFlltInit (svxDEFllt *data)
evxErrors | cvxPartDEFllt (const svxDEFllt *data, int *idFllt)
evxErrors | cvxPartDERadInit (svxDERad *data)
evxErrors | cvxPartDERad (const svxDERad *data, int *idRad)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_direct_edit_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_direct_edit_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Direct Edit Command functions.

Definition in file zwapi_cmd_direct_edit_data.h.

Modify Data

enum evxDEMoveCopyType {
VX_DE_MOVE_PNT_TO_PNT = 1 , VX_DE_MOVE_ALONG_DIR = 2 , VX_DE_MOVE_FRAME = 3 , VX_DE_MOVE_PATH = 4 ,
VX_DE_MOVE_AROUND_DIR = 5 , VX_DE_MOVE_DYNAMIC = 6
}
part or assembly DE(Direct Edit) move or copy method More...
enum | evxDEFaceOverflow { VX_DE_OVERFLOW_AUTO , VX_DE_OVERFLOW_CHANGE , VX_DE_OVERFLOW_STATION , VX_DE_OVERFLOW_CAP }
part or assembly DE(Direct Edit) move overflow method More...
enum | evxDEMoveCopyFrame { VX_DE_MOVE_FRAME_NATURAL , VX_DE_MOVE_FRAME_PATH , VX_DE_MOVE_FRAME_SELECT }
part or assembly DE(Direct Edit) move or copy frame method More...
enum | evxDEMoveCopyZSpine { VX_DE_MOVE_Z_NATURAL , VX_DE_MOVE_Z_SPINE , VX_DE_MOVE_Z_PARALLEL }
part or assembly DE(Direct Edit) move or copy Z-spine method More...
enum | evxDEMoveCopyXOrient { VX_DE_MOVE_X_NATURAL , VX_DE_MOVE_X_PLANE , VX_DE_MOVE_X_CURVE }
part or assembly DE(Direct Edit) move or copy X-orient method More...
enum evxDEAlignMoveType {
VX_DE_ALIGN_MOVE_COPLANAR = 1 , VX_DE_ALIGN_MOVE_CONCENTRIC = 2 , VX_DE_ALIGN_MOVE_TANGENT = 3 , VX_DE_ALIGN_MOVE_PARALLEL = 4 ,
VX_DE_ALIGN_MOVE_PERPENDICULAR = 5 , VX_DE_ALIGN_MOVE_ANGLE = 6 , VX_DE_ALIGN_MOVE_SYMMETRY = 7
}
part or assembly DE(Direct Edit) align move method More...
enum | evxDEDimMoveType { VX_DE_DIM_LINEAR = 1 , VX_DE_DIM_ANGULAR = 2 }
part or assembly DE(Direct Edit) dim move method More...
enum | evxDESideFaceType { VX_DE_SIDE_FACE_NO_CREATE , VX_DE_SIDE_FACE_CREATE }
part or assembly DE(Direct Edit) side face method More...
enum | evxDEIsectType { VX_DE_ISECT_NO_REMOVE , VX_DE_ISECT_REMOVE }
part or assembly DE(Direct Edit) intersection method More...
enum | evxDEDraftSideType { VX_DE_DRAFT_SIDE_TOP , VX_DE_DRAFT_SIDE_BOTTOM , VX_DE_DRAFT_SIDE_SPILT , VX_DE_DRAFT_SIDE_NEUTRAL }
part or assembly DE(Direct Edit) draft about side method More...
typedef enum evxDEMoveCopyType | evxDEMoveCopyType
part or assembly DE(Direct Edit) move or copy method
typedef enum evxDEFaceOverflow | evxDEFaceOverflow
part or assembly DE(Direct Edit) move overflow method
typedef enum evxDEMoveCopyFrame | evxDEMoveCopyFrame
part or assembly DE(Direct Edit) move or copy frame method
typedef enum evxDEMoveCopyZSpine | evxDEMoveCopyZSpine
part or assembly DE(Direct Edit) move or copy Z-spine method
typedef enum evxDEMoveCopyXOrient | evxDEMoveCopyXOrient
part or assembly DE(Direct Edit) move or copy X-orient method
typedef struct svxDEMove | svxDEMove
part or assembly DE(Direct Edit) move data
typedef enum evxDEAlignMoveType | evxDEAlignMoveType
part or assembly DE(Direct Edit) align move method
typedef struct svxDEAlignMove | svxDEAlignMove
part or assembly DE(Direct Edit) align move data
typedef enum evxDEDimMoveType | evxDEDimMoveType
part or assembly DE(Direct Edit) dim move method
typedef struct svxDEDimMove | svxDEDimMove
part or assembly DE(Direct Edit) dim move data
typedef enum evxDESideFaceType | evxDESideFaceType
part or assembly DE(Direct Edit) side face method
typedef enum evxDEIsectType | evxDEIsectType
part or assembly DE(Direct Edit) intersection method
typedef struct svxDEOffset | svxDEOffset
part or assembly DE(Direct Edit) face offset data
typedef enum evxDEDraftSideType | evxDEDraftSideType
part or assembly DE(Direct Edit) draft about side method
typedef struct svxDEDraft | svxDEDraft
part or assembly DE(Direct Edit) draft data

Reuse Data

enum evxDEPtnType {
VX_DE_PTN_LINEAR , VX_DE_PTN_CIRCULAR , VX_DE_PTN_POINT , VX_DE_PTN_PATTERN ,
VX_DE_PTN_CURVE , VX_DE_PTN_FACE
}
part or assembly DE(Direct Edit) pattern method More...
enum | evxDEPtnDerive { VX_DE_PTN_DERIVE_NONE , VX_DE_PTN_DERIVE_SPACING , VX_DE_PTN_DERIVE_NUMBER }
part or assembly DE(Direct Edit) pattern derive method More...
enum | evxDEPtnCrv { VX_DE_PTN_CRV1 , VX_DE_PTN_CRV2_TGT , VX_DE_PTN_CRV2_ACR , VX_DE_PTN_CRV3 }
part or assembly DE(Direct Edit) pattern at curve method More...
enum | evxDEPtnBound { VX_DE_PTN_BOUND_AUTO , VX_DE_PTN_BOUND_PLACE , VX_DE_PTN_BOUND_MOVE }
part or assembly DE(Direct Edit) pattern boundary method More...
typedef struct svxDECopy | svxDECopy
part or assembly DE(Direct Edit) copy data
typedef struct svxDEMirror | svxDEMirror
part or assembly DE(Direct Edit) mirror data
typedef enum evxDEPtnType | evxDEPtnType
part or assembly DE(Direct Edit) pattern method
typedef enum evxDEPtnDerive | evxDEPtnDerive
part or assembly DE(Direct Edit) pattern derive method
typedef enum evxDEPtnCrv | evxDEPtnCrv
part or assembly DE(Direct Edit) pattern at curve method
typedef enum evxDEPtnBound | evxDEPtnBound
part or assembly DE(Direct Edit) pattern boundary method
typedef struct svxDEPattern | svxDEPattern
part or assembly DE(Direct Edit) pattern data

Resize Data

typedef struct svxDEFllt | svxDEFllt
part or assembly DE(Direct Edit) modify fillet data
typedef struct svxDERad | svxDERad
part or assembly DE(Direct Edit) modify radius data
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dwg_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_sk_create_data.h"
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the drawing command functions.

Definition in file zwapi_cmd_dwg_data.h.

View Data

enum | evxViewLocationType { VX_LOCATION_AUTO , VX_LOCATION_CENTER , VX_LOCATION_CORNER }
drawing view location type More...
enum evxViewTypeEx {
VX_VU_NULL = 0 , VX_VU_TOP = 1 , VX_VU_FRONT = 2 , VX_VU_RIGHT = 3 ,
VX_VU_BACK = 4 , VX_VU_BOTTOM = 5 , VX_VU_LEFT = 6 , VX_VU_ISO_FRONT = 7 ,
VX_VU_AUX = 8 , VX_VU_NAME = 9 , VX_VU_3RD_UP = 10 , VX_VU_3RD_DN = 11 ,
VX_VU_3RD_RT = 12 , VX_VU_3RD_LT = 13 , VX_VU_1ST_UP = 14 , VX_VU_1ST_DN = 15 ,
VX_VU_1ST_RT = 16 , VX_VU_1ST_LT = 17 , VX_VU_3RD_PRJ_ANG = 18 , VX_VU_DETAIL = 19 ,
VX_VU_SECTION = 20 , VX_VU_DETAIL_DEF = 21 , VX_VU_SECTION_DEF = 22 , VX_VU_REV_SECT_DEF = 23 ,
VX_VU_ROTATE = 24 , VX_VU_ALIGN_SECT_DEF = 25 , VX_VU_PRJ_ANG_ARROWS = 26 , VX_VU_BEND_SECT_DEF = 27 ,
VX_VU_ISO_LFT = 28 , VX_VU_ISO_LBT = 29 , VX_VU_ISO_RBT = 30 , VX_VU_ISO_RFB = 31 ,
VX_VU_ISO_LFB = 32 , VX_VU_ISO_LBB = 33 , VX_VU_ISO_RBB = 34 , VX_VU_NAME_SECT_DEF = 35 ,
VX_VU_1ST_PRJ_ANG = 36 , VX_VU_BRKSECT = 37 , VX_VU_ISOSECT = 38 , VX_VU_DIMETRIC = 39 ,
VX_VU_SMD = 40
}
View type, more detailed than evxViewType. More...
enum | evxViewPrjAngType { VX_VIEW_PRJANG1ST = 1 , VX_VIEW_PRJANG3RD = 2 }
view projection type More...
enum | evxViewDimType { VX_VIEW_DIMTYPEPRJ = 0 , VX_VIEW_DIMTYPETRUE = 1 }
view dimension type More...
enum | evxSecMtdType { VX_METHOD_SECCURVE = 1 , VX_METHOD_TRIMPART = 2 , VX_METHOD_TRIMSURF = 3 }
section method type More...
enum | evxLocType { VX_LOC_HORIZONTAL = 1 , VX_LOC_VERTICAL = 2 , VX_LOC_ORTHOGONAL = 3 , VX_LOC_NONE = 4 }
section location More...
enum | evxLocAngType { VX_LOC_ANG_DEFAULT = 0 , VX_LOC_ANG_HORIZONTAL = 1 , VX_LOC_ANG_VERTICAL = 2 , VX_LOC_ANG_CUSTOM = 3 }
location angle More...
enum | evxDwgBndMethod { VX_RECTANGULAR_BOUNDARY = 1 , VX_CIRCULAR_BOUNDARY , VX_POLYLINE_BOUNDARY }
Drawing Broken Section Boundary Method. More...
enum | evxDwgDepthType { VX_DEPTH_POINT , VX_DEPTH_SECTION_PLANE , VX_DEPTH_3D_NAMED }
Drawing Broken Section Depth type. More...
enum | evxDwgDetailMethod { VX_RECTANGULAR_DETAIL = 1 , VX_CIRCULAR_DETAIL = 2 , VX_POLYLINE_DETAIL }
Drawing Detail Method. More...
enum | evxBrkLineType { VX_HOR_BRKLINE = 0 , VX_VER_BRKLINE , VX_SLANT_BRKLINE }
option of break line More...
typedef enum evxViewLocationType | evxViewLocationType
drawing view location type
typedef struct svxViewLocationData | svxViewLocationData
drawing view location data
typedef struct svxViewLayoutMethod | svxViewLayoutMethod
drawing view layout method
typedef struct svxViewAt | svxViewAt
View layout display attributes.
typedef struct svxViewLayoutData | svxViewLayoutData
drawing view layout data
typedef enum evxViewTypeEx | evxViewTypeEx
View type, more detailed than evxViewType.
typedef struct svxViewStandardData | svxViewStandardData
drawing view standard data
typedef enum evxViewPrjAngType | evxViewPrjAngType
view projection type
typedef enum evxViewDimType | evxViewDimType
view dimension type
typedef struct svxPrjSetting | svxPrjSetting
Projection or Auxiliary view's projection settings.
typedef struct svxViewArrow | svxViewArrow
view projection arrow
typedef struct svxAuxViewData | svxAuxViewData
Auxiliary view data.
typedef enum evxSecMtdType | evxSecMtdType
section method type
typedef enum evxLocType | evxLocType
section location
typedef enum evxLocAngType | evxLocAngType
location angle
typedef struct svxViewSecMtd | svxViewSecMtd
section method
typedef struct svxViewSecLine | svxViewSecLine
section line
typedef struct svxViewSecOp | svxViewSecOp
section option
typedef struct svxFulSecViewData | svxFulSecViewData
full section view data
typedef struct svxAlignSecViewData | svxAlignSecViewData
aligned section view data
typedef enum evxDwgBndMethod | evxDwgBndMethod
Drawing Broken Section Boundary Method.
typedef enum evxDwgDepthType | evxDwgDepthType
Drawing Broken Section Depth type.
typedef struct svxDwgBrokenSectionData | svxDwgBrokenSectionData
Drawing Broken Section input infos.
typedef enum evxDwgDetailMethod | evxDwgDetailMethod
Drawing Detail Method.
typedef struct svxDwgDetailData | svxDwgDetailData
Drawing Detail input infos.
typedef enum evxBrkLineType | evxBrkLineType
option of break line
typedef struct svxBrkLineData | svxBrkLineData
information we need when create break line

Table Data

enum | evxLevelSet { VX_TOP_LEVEL_ONLY = 0 , VX_PARTS_ONLY = 1 , VX_INDENTED = 3 , VX_BALLOON_ONLY = 4 }
level set More...
enum | evxIndentedType { VX_NO_NUM = 0 , VX_DETAILED_NUM = 1 , VX_FLAT_NUM = 2 }
indent type More...
enum | evxOrderType { VX_ORDER_BYNAME = 0 , VX_ORDER_REGEN_IDS = 1 , VX_ORDER_ASASM = 2 }
order type More...
enum evxBomset {
VX_BOM_INVALID = 0x0000 , VX_SET_DISP_CFG = 0x0001 , VX_DERIVED_PARTS = 0x0002 , VX_SYNC_BOM = 0x0004 ,
VX_KEEP_MISSING = 0x0008 , VX_STRIKE_THROUGH = 0x0010 , VX_BOM_VALID = 0xFFFF
}
BOM set. More...
enum evxOriginType {
VX_TOP_LEFT = 0 , VX_TOP_CENTER = 1 , VX_TOP_RIGHT = 2 , VX_MID_LEFT ,
VX_MID_CENTER , VX_MID_RIGHT , VX_BOTTOM_LEFT , VX_BOTTOM_CENTER ,
VX_BOTTOM_RIGHT
}
origin type More...
typedef enum evxLevelSet | evxLevelSet
level set
typedef enum evxIndentedType | evxIndentedType
indent type
typedef enum evxOrderType | evxOrderType
order type
typedef enum evxBomset | evxBomset
BOM set.
typedef struct svxDwgBom | svxDwgBom
BOM table data.
typedef enum evxOriginType | evxOriginType
origin type
typedef struct svxDwgTblInsert | svxDwgTblInsert
insert Table

Edit View Data

enum evxRotViewType {
VX_ROTVIEW_TOP = 1 , VX_ROTVIEW_FRONT = 2 , VX_ROTVIEW_RIGHT , VX_ROTVIEW_BACK ,
VX_ROTVIEW_BOTTOM , VX_ROTVIEW_LEFT , VX_ROTVIEW_ISOMETRIC , VX_ROTVIEW_ISOMETRIC_LFT ,
VX_ROTVIEW_ISOMETRIC_LBT , VX_ROTVIEW_ISOMETRIC_RBT , VX_ROTVIEW_ISOMETRIC_RFB , VX_ROTVIEW_ISOMETRIC_LFB ,
VX_ROTVIEW_ISOMETRIC_LBB , VX_ROTVIEW_ISOMETRIC_RBB
}
type of view More...
typedef enum evxRotViewType | evxRotViewType
type of view
typedef struct svxDwgRotView | svxDwgRotView
Rotate View.

Dimension Data

enum | evxAutoEntType { DIM_AUTO_ENT_ALL = 0 , DIM_AUTO_ENT_ARC_CIRCLE , DIM_AUTO_ENT_PICKED }
select geometry entity type More...
enum | evxAutoDimType { DIM_AUTO_BASELINE = 0 , DIM_AUTO_CONTINUOUS = 1 , DIM_AUTO_ORDINATE = 2 , DIM_AUTO_LABEL_COORDINATE = 3 }
auto dimension type More...
enum | evxAutoPlacement { DIM_VIEW_ABOVE_LEFT = 0 , DIM_VIEW_BELOW_RIGHT , DIM_VIEW_BOTH }
dimension position/placement More...
enum evxAutoInclude {
VX_AUTOINC_INVALID = 0x00000000 , VX_AUTOINC_ARC = 0x00000001 , VX_AUTOINC_CIRCLE = 0x00000002 , VX_AUTOINC_HOLE = 0x00000004 ,
VX_AUTOINC_LINE = 0x00000008 , VX_AUTOINC_HOLE_CALLOUT = 0x00000010 , VX_AUTOINC_CYLIND_DIM = 0x00000020 , VX_AUTOINC_MAXIMUM_DIM = 0x00000040 ,
VX_AUTOINC_VALID = 0xFFFFFFFF
}
auto dimension include More...
enum evxDimLineType {
VX_DIM_LINE_LH = 1 , VX_DIM_LINE_LV = 2 , VX_DIM_LINE_LA = 3 , VX_DIM_LINE_LR = 4 ,
VX_DIM_LINE_LP = 5 , VX_DIM_LINE_LO = 6
}
dimension Line type More...
enum | evxSymmetryDimType { VX_SYM_LINEAR = 1 , VX_SYM_ANGULAR = 2 }
symmetry dimension type More...
enum | evxDimLineOffset { VX_DIM_OFFSET_LOL = 1 , VX_DIM_OFFSET_LOP = 2 }
dimension off type More...
enum | evxDwgLnrChmDimType { VX_LEADER_CHAMFERDIM = 1 , VX_ALIGNED_CHAMFERDIM , VX_HORZORVERT_CHAMFERDIM }
type of linear chamfer dim in sheeting More...
enum | evxDwgLnrChmDimTexType { VX_TEXT_NOR_CHAMFERDIM = 0 , VX_TEXT_PERPENDICULAR_CHAMFERDIM , VX_TEXT_ALGMODLIN_CHAMFERDIM }
text style of leader linear chamfer dim in sheeting More...
enum evxAngDimType {
VX_ANG_TWOCURVES = 1 , VX_ANG_HORIZONTAL = 2 , VX_ANG_VERTICAL = 3 , VX_ANG_THREEPOINT = 4 ,
VX_ANG_ARC = 5
}
angular dimension type More...
enum evxRadDimType {
VX_RAD_RADIAL = 1 , VX_RAD_BROKEN = 2 , VX_RAD_LARGE = 3 , VX_RAD_LEADER = 4 ,
VX_RAD_DIAMETER = 5 , VX_RAD_LINEAR = 6
}
radial or diametric dim type More...
enum evxCalloutEmt {
VX_CALLOUTEMT_INVALID = 0x00000000 , VX_CALLOUTEMT_QUALITY = 0x00000001 , VX_CALLOUTEMT_DIAMETER = 0x00000002 , VX_CALLOUTEMT_DIAMETER_D2 = 0x00000004 ,
VX_CALLOUTEMT_DEPTH = 0x00000008 , VX_CALLOUTEMT_DEPTH_H2 = 0x00000010 , VX_CALLOUTEMT_THREAD_DIA = 0x00000020 , VX_CALLOUTEMT_THREAD_PITCH = 0x00000040 ,
VX_CALLOUTEMT_THREAD_DEPTH = 0x00000080 , VX_CALLOUTEMT_ANGLE = 0x00000100 , VX_CALLOUTEMT_CALLOUT_LABEL = 0x00000200 , VX_CALLOUTEMT_MULTIPLE_LINE = 0x00000400 ,
VX_CALLOUTEMT_SLOT_LENGTH = 0x00000800 , VX_CALLOUTEMT_VALID = 0xFFFFFFFF
}
Callout Elements. More...
typedef enum evxAutoEntType | evxAutoEntType
select geometry entity type
typedef enum evxAutoDimType | evxAutoDimType
auto dimension type
typedef enum evxAutoPlacement | evxAutoPlacement
dimension position/placement
typedef struct svxAutoSet | svxAutoSet
dimension position
typedef enum evxAutoInclude | evxAutoInclude
auto dimension include
typedef struct svxDimAuto | svxDimAuto
auto dimension
typedef enum evxDimLineType | evxDimLineType
dimension Line type
typedef struct svxDwgConsDim | svxDwgConsDim
data of constraint dimension
typedef struct svxDwgLineDim | svxDwgLineDim
Linear.
typedef struct svxDwgLineGrpDim | svxDwgLineGrpDim
Baseline, Continuous.
typedef struct svxDwgOrdinateDim | svxDwgOrdinateDim
Ordinate.
typedef enum evxSymmetryDimType | evxSymmetryDimType
symmetry dimension type
typedef enum evxDimLineOffset | evxDimLineOffset
dimension off type
typedef struct svxDwgLineOffsetDim | svxDwgLineOffsetDim
Linear Offset.
typedef struct svxDwgSymmetryDimData | svxDwgSymmetryDimData
Symmetry dimension data.
typedef enum evxDwgLnrChmDimType | evxDwgLnrChmDimType
type of linear chamfer dim in sheeting
typedef enum evxDwgLnrChmDimTexType | evxDwgLnrChmDimTexType
text style of leader linear chamfer dim in sheeting
typedef struct svxDwgLnrChmDimData | svxDwgLnrChmDimData
the info of the linear chamfer dim
typedef enum evxAngDimType | evxAngDimType
angular dimension type
typedef struct svxDwgAngDimData | svxDwgAngDimData
Angular dimension dim data.
typedef enum evxRadDimType | evxRadDimType
radial or diametric dim type
typedef struct svxRadDimData | svxRadDimData
radial or diametric dim data
typedef struct svxDwgArcDimData | svxDwgArcDimData
Arc dimension dim data.
typedef enum evxCalloutEmt | evxCalloutEmt
Callout Elements.
typedef struct svxDwgHoleCallOutDim | svxDwgHoleCallOutDim
Hole Callout.

Annotation Data

enum evxBalloonCon {
VX_BALLOON_CON_USERTEXT = 0 , VX_BALLOON_CON_ID = 1 , VX_BALLOON_CON_NAME = 2 , VX_BALLOON_CON_NUMBER = 3 ,
VX_BALLOON_CON_CLASS , VX_BALLOON_CON_DESIGNER , VX_BALLOON_CON_COST , VX_BALLOON_CON_SUPPLIER ,
VX_BALLOON_CON_MATERIAL , VX_BALLOON_CON_QUANTITY , VX_BALLOON_CON_MANAGER , VX_BALLOON_CON_REMARKS ,
VX_BALLOON_CON_DESCRIPTION , VX_BALLOON_CON_KEYWORDS , VX_BALLOON_CON_DERIVEDFROM , VX_BALLOON_CON_STARTDATE ,
VX_BALLOON_CON_ENDDATE , VX_BALLOON_CON_MASS , VX_BALLOON_CON_VOLUME , VX_BALLOON_CON_TOTALMASS ,
VX_BALLOON_CON_DENSITY , VX_BALLOON_CON_PARTCFG , VX_BALLOON_CON_FILEPATH , VX_BALLOON_CON_SIZE ,
VX_BALLOON_CON_LENGTH , VX_BALLOON_CON_WIDTH , VX_BALLOON_CON_HEIGHT , VX_BALLOON_CON_AREA ,
VX_BALLOON_CON_LEGEND , VX_BALLOON_CON_STOCKSIZE , VX_BALLOON_CON_VISIBLE
}
balloon text Condition More...
enum | evxDwgAtBlnInsTyp { VX_ATBLNINS_IGNMULINS = 0 , VX_ATBLNINS_MULLEAINS = 1 , VX_ATBLNINS_EACHINS = 2 }
Type of instances in auto balloon. More...
enum | evxDwgAtBlnPtnType { VX_ATBLNPAT_CONVEXHULL = 1 , VX_ATBLNPAT_SQUARE = 2 , VX_ATBLNPAT_CIRCULAR = 3 }
Pattern type of auto balloon. More...
enum | evxDwgAtBlnLeadAttach { VX_ATBLNLEAATT_EDAGES = 1 , VX_ATBLNLEAATT_FACES = 2 }
Leader attachment of auto balloon. More...
enum evxDwgAtBlnSkpSd {
VX_ATBLNSKPSD_NONE = 0 , VX_ATBLNSKPSD_LEFT = 1 , VX_ATBLNSKPSD_TOP = 2 , VX_ATBLNSKPSD_RIGHT = 4 ,
VX_ATBLNSKPSD_BOTTOM = 8
}
Skip sides of auto balloon. More...
enum | evxDwgAtBlnArrg { VX_ATBLNARR_NEAREST = 1 , VX_ATBLNARR_CW = 2 , VX_ATBLNARR_CCW = 3 }
Arrangement of auto balloon. More...
enum | evxDwgStkBlnPtn { VX_STKBLNPAT_HORRIGHT = 1 , VX_STKBLNPAT_HORLEFT , VX_STKBLNPAT_VERUP , VX_STKBLNPAT_VERDOWN }
pattern of stack balloons More...
enum | evxDatumDimType { VX_DATUM_NORMAL = 1 , VX_DATUM_ANSI = 2 }
datum dim type More...
enum | evxDatumTargDimType { VX_DATUMT_CIRCLE = 0 , VX_DATUMT_RECTANGLE = 1 , VX_DATUMT_LINE = 2 , VX_DATUMT_POINT = 3 }
datum target dim type More...
typedef struct svxLabelCoorDimData | svxLabelCoorDimData
label coordinate dim data
typedef enum evxBalloonCon | evxBalloonCon
balloon text Condition
typedef struct svxDimLabel | svxDimLabel
Label.
typedef struct svxDwgBalloonDim | svxDwgBalloonDim
Balloon.
typedef enum evxDwgAtBlnInsTyp | evxDwgAtBlnInsTyp
Type of instances in auto balloon.
typedef enum evxDwgAtBlnPtnType | evxDwgAtBlnPtnType
Pattern type of auto balloon.
typedef enum evxDwgAtBlnLeadAttach | evxDwgAtBlnLeadAttach
Leader attachment of auto balloon.
typedef enum evxDwgAtBlnSkpSd | evxDwgAtBlnSkpSd
Skip sides of auto balloon.
typedef enum evxDwgAtBlnArrg | evxDwgAtBlnArrg
Arrangement of auto balloon.
typedef struct svxDwgAtBlnData | svxDwgAtBlnData
Information of creating auto balloon.
typedef enum evxDwgStkBlnPtn | evxDwgStkBlnPtn
pattern of stack balloons
typedef struct svxDwgStkBlnData | svxDwgStkBlnData
information of creating stack balloons
typedef struct svxDwgFtrCtrl | svxDwgFtrCtrl
Datum Control.
typedef enum evxDatumDimType | evxDatumDimType
datum dim type
typedef struct svxDatumDimData | svxDatumDimData
datum dim data(drawing)
typedef enum evxDatumTargDimType | evxDatumTargDimType
datum target dim type
typedef struct svxDatumTargDimData | svxDatumTargDimData
datum target dim data

Symbol Data

enum | evxCentDimType { VX_DM_CENMARK = 1 , VX_DM_CENLINE , VX_DM_CENDLINE }
center mark type More...
enum | evxCenterLineType { VX_CL_BY_TWO_LINES = 1 , VX_CL_BY_TWO_POINTS }
centerline type More...
enum evxWeldFinishSym {
VX_WELD_FINISH_NONE = 1 , VX_WELD_FINISH_CHIPPING , VX_WELD_FINISH_GRINDING , VX_WELD_FINISH_HAMMERING ,
VX_WELD_FINISH_MACHINING , VX_WELD_FINISH_ROLLING , VX_WELD_FINISH_UNSPECIFIED
}
finish symbol of weld symbol More...
enum evxWeldContourSym {
VX_WELD_COUNTOUR_NONE = 1 , VX_WELD_COUNTOUR_FLAT , VX_WELD_COUNTOUR_CONVEX , VX_WELD_COUNTOUR_CONCAVE ,
VX_WELD_COUNTOUR_BLEND_TOES , VX_WELD_COUNTOUR_STRIP_PERMANENT , VX_WELD_COUNTOUR_STRIP_REMOVABLE
}
contour symbol of weld symbol More...
enum evxSymSurf {
VX_SYMSURF_BAS = 0 , VX_SYMSURF_MRR , VX_SYMSURF_MRP , VX_SYMSURF_JIS1 ,
VX_SYMSURF_JIS2 , VX_SYMSURF_JIS3 , VX_SYMSURF_JIS4 , VX_SYMSURF_JISNM
}
symbol type of surface roughness More...
enum evxSurfPtnSym {
VX_SURF_PTNSYM_NONE = 0 , VX_SURF_PTNSYM_RADIAL , VX_SURF_PTNSYM_PERPENDICULAR , VX_SURF_PTNSYM_ANGULAR ,
VX_SURF_PTNSYM_MULTI_DIR , VX_SURF_PTNSYM_CIRCULAR , VX_SURF_PTNSYM_PARALLEL , VX_SURF_PTNSYM_PARTICULATE
}
pattern symbol of surface roughness More...
enum | evxDwgHoleMarkType { VX_DWG_HOLE_MARK_AUTO , VX_DWG_HOLE_MARK_MANUAL }
drawing sheet hole mark method More...
enum evxDwgHoleMarkPtn {
VX_DWG_HOLE_MARK_UP_LEFT_4 , VX_DWG_HOLE_MARK_UP_RIGHT_4 , VX_DWG_HOLE_MARK_DOWN_LEFT_4 , VX_DWG_HOLE_MARK_DOWN_RIGHT_4 ,
VX_DWG_HOLE_MARK_LEFT_BEVEL_4 , VX_DWG_HOLE_MARK_RIGHT_BEVEL_4 , VX_DWG_HOLE_MARK_UP_LEFT_12 , VX_DWG_HOLE_MARK_UP_RIGHT_12 ,
VX_DWG_HOLE_MARK_DOWN_LEFT_12 , VX_DWG_HOLE_MARK_DOWN_RIGHT_12 , VX_DWG_HOLE_MARK_LEFT_BEVEL_12 , VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
}
drawing sheet hole mark pattern method More...
typedef struct svxCenterDim | svxCenterDim
Center Mark Settings.
typedef enum evxCentDimType | evxCentDimType
center mark type
typedef struct svxCenterMark | svxCenterMark
Center Mark.
typedef struct svxCenMarkCirDimData | svxCenMarkCirDimData
center mark circle dim data
typedef enum evxCenterLineType | evxCenterLineType
centerline type
typedef struct svxCenterLine | svxCenterLine
Center Line.
typedef enum evxWeldFinishSym | evxWeldFinishSym
finish symbol of weld symbol
typedef enum evxWeldContourSym | evxWeldContourSym
contour symbol of weld symbol
typedef struct svxSymWeld | svxSymWeld
Weld data.
typedef enum evxSymSurf | evxSymSurf
symbol type of surface roughness
typedef enum evxSurfPtnSym | evxSurfPtnSym
pattern symbol of surface roughness
typedef struct svxSymSurf | svxSymSurf
surface finish data
typedef struct svxSymImg | svxSymImg
image data
typedef struct svxDwgIsectSym | svxDwgIsectSym
drawing intersection symbol data
typedef enum evxDwgHoleMarkType | evxDwgHoleMarkType
drawing sheet hole mark method
typedef enum evxDwgHoleMarkPtn | evxDwgHoleMarkPtn
drawing sheet hole mark pattern method
typedef struct svxDwgHoleMark | svxDwgHoleMark
drawing sheet hole mark data

Drawing Data

enum evxHatchType {
VX_HATCH_CUSTOM = -1 , VX_HATCH_STANDARD , VX_HATCH_ANSI , VX_HATCH_ISO ,
VX_HATCH_DIN , VX_HATCH_JIS , VX_HATCH_GB
}
hatch type More...
typedef enum evxHatchType | evxHatchType
hatch type
typedef struct svxHatchAttr | svxHatchAttr
hatch attributes
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_dimension.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dwg_dimension.h File Reference
#include "zwapi_cmd_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Dimension Command of Drawing API

Definition in file zwapi_cmd_dwg_dimension.h.

Dimension

evxErrors | cvxDwgAutoDimAdd (const svxDimAuto *pDimData, int *idDim)
evxErrors | cvxDwgAutoDimAddInit (svxDimAuto *data)
evxErrors | cvxDwgLineDimAdd (const svxDwgLineDim *pData, int *idDim)
evxErrors | cvxDwgBaseLineDimAdd (const svxDwgLineGrpDim *pData, int *idDim)
evxErrors | cvxDwgContinuousDimAdd (const svxDwgLineGrpDim *pData, int *idDim)
evxErrors | cvxDwgOrdinateDimAdd (const svxDwgOrdinateDim *pData, int *idDim)
evxErrors | cvxDwgLineOffsetDimAdd (const svxDwgLineOffsetDim *pData, int *idDim)
evxErrors | cvxDwgSymmetryDimAdd (const svxDwgSymmetryDimData *symmetryDimData, int *idDim)
evxErrors | cvxDwgLnrChmDimAddInit (svxDwgLnrChmDimData *data)
evxErrors | cvxDwgLnrChmDimAdd (const svxDwgLnrChmDimData *DimData, int *idDim)
evxErrors | cvxDwgAngDimAdd (const svxDwgAngDimData *angDimData, int *idDim)
evxErrors | cvxDwgRadDimAdd (const svxRadDimData *radDimData, int *idDim)
evxErrors | cvxDwgArcDimAdd (const svxDwgArcDimData *arcDimData, int *idDim)
evxErrors | cvxDwgHoleCallOutDimAddinit (svxDwgHoleCallOutDim *data)
evxErrors | cvxDwgHoleCallOutDimAdd (const svxDwgHoleCallOutDim *pData, int *numDim, int **idDims)

Annotation

evxErrors | cvxDwgLabelCoorDimAdd (const svxLabelCoorDimData *coorDimData, int *idDim)
evxErrors | cvxDwgLabelDimAdd (const svxDimLabel *pLabel, int *idDim)
evxErrors | cvxDwgBalloonDimAdd (const svxDwgBalloonDim *pData, int *idDim)
evxErrors | cvxDwgAutoBlnAddInit (svxDwgAtBlnData *data)
evxErrors | cvxDwgAutoBlnAdd (const svxDwgAtBlnData *atBlnData, int *idDimCount, int **idDimList)
evxErrors | cvxDwgStkBlnAddInit (svxDwgStkBlnData *data)
evxErrors | cvxDwgStkBlnAdd (const svxDwgStkBlnData *stkBlnData, int *idDimCount, int **idDimList)
evxErrors | cvxDwgFtrCtrlDimAdd (const svxDwgFtrCtrl *pData, int *idDim)
evxErrors | cvxDwgDatumDimAdd (const svxDatumDimData *datumData, int *idDim)
evxErrors | cvxDwgDatumTargDimAddInit (svxDatumTargDimData *data)
evxErrors | cvxDwgDatumTargDimAdd (const svxDatumTargDimData *datumTData, int *idDim)

Symbol

evxErrors | cvxDwgCenterMarkDimAddInit (svxCenterMark *data)
evxErrors | cvxDwgCenterMarkDimAdd (const svxCenterMark *pzCenterMark, int *idDim)
evxErrors | cvxDwgCenMarkCirDimAddInit (svxCenMarkCirDimData *data)
evxErrors | cvxDwgCenMarkCirDimAdd (const svxCenMarkCirDimData *cmcDimData, int *idDim)
evxErrors | cvxDwgCenterLineDimAddInit (svxCenterLine *data)
evxErrors | cvxDwgCenterLineDimAdd (const svxCenterLine *pzCenterLine, int *idDim)
evxErrors | cvxDwgSymWeldNew (int idEnt, svxPoint2 *refPoint, const svxSymWeld *data, int *idSymWeld)
evxErrors | cvxDwgSymWeldNewInit (svxSymWeld *data)
evxErrors | cvxDwgSymSurfNewInit (svxSymSurf *data)
evxErrors | cvxDwgSymSurfNew (int idEnt, svxPoint2 *refPoint, const svxSymSurf *data, int *idSymSurf)
evxErrors | cvxDwgSymImgNew (svxSymImg *data, int embed, int locked, int *idSymImg)
evxErrors | cvxDwgSymImgNewInit (svxSymImg *data)
evxErrors | cvxDwgInsertSymbol (const vxLongPath fileName, const vxLongName symName, svxPoint2 *pnt, int *symId)
evxErrors | cvxDwgUserSymNew (int count, int *idEnt, svxPoint2 *BasePnt, const vxRootName Name, int *idBlock)
evxErrors | cvxDwgIsectSym (const svxDwgIsectSym *data, int *idSym)
evxErrors | cvxDwgHoleMarkInit (evxDwgHoleMarkType type, svxDwgHoleMark *data)
evxErrors | cvxDwgHoleMark (const svxDwgHoleMark *data)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_drawing.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dwg_drawing.h File Reference
#include "zwapi_cmd_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Command of Drawing API

Definition in file zwapi_cmd_dwg_drawing.h.

Drawing

evxErrors | cvxDwgCrossHatchInit (svxHatchAttr *data)
evxErrors | cvxDwgCrossHatch (int countEnts, int *idEnts, int countPnts, svxPoint2 *insides, int isSplit, svxHatchAttr *hatch, int *idEnt)

Basic Editing

evxErrors | cvxDwgEntMovePntToPnt (int idEnt, svxPoint2 *Start, svxPoint2 *End, evxDrawingMoveDirType type, double angle, double scale)
evxErrors | cvxDwgEntMoveAlongDirection (int idEnt, svxVector2 *Direction, double Distance, svxPoint2 *BasePoint, double angle, double scale)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_layout.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_dwg_layout.h File Reference
#include "zwapi_cmd_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Layout of Drawing API

Definition in file zwapi_cmd_dwg_layout.h.

View

evxErrors | cvxDwgViewLayoutInit (svxViewLayoutData *data)
evxErrors | cvxDwgViewLayout (svxViewLayoutData *data)
evxErrors | cvxDwgViewStandardInit (svxViewStandardData *data)
evxErrors | cvxDwgViewStandard (const svxViewStandardData *data, int *idView)
evxErrors | cvxDwgViewProjection (int idBaseView, svxPoint2 *location, int Projection, int DimType, svxViewAt *ViewAttr, int *idProjView)
evxErrors | cvxDwgViewAuxiliaryInit (svxAuxViewData *data)
evxErrors | cvxDwgViewAuxiliary (const svxAuxViewData *auxViewData, int *idView)
evxErrors | cvxDwgViewFullSectionInit (svxFulSecViewData *data)
evxErrors | cvxDwgViewFullSection (const svxFulSecViewData *fulSecViewData, int *idView)
evxErrors | cvxDwgViewAlignedSectionInit (svxAlignSecViewData *data)
evxErrors | cvxDwgViewAlignedSection (const svxAlignSecViewData *alignSecViewData, int *idView)
evxErrors | cvxDwgViewBrokenSectionInit (svxDwgBrokenSectionData *data)
evxErrors | cvxDwgViewBrokenSection (svxDwgBrokenSectionData *data, int *idView)
evxErrors | cvxDwgViewDetailInit (svxDwgDetailData *data)
evxErrors | cvxDwgViewDetail (const svxDwgDetailData *data, int *idView)
evxErrors | cvxDwgViewBrkLineInit (svxBrkLineData *data)
evxErrors | cvxDwgViewBrkLine (const svxBrkLineData *brkLineInfo, int *brkLnViewId)

Table

evxErrors | cvxDwgTableBomInit (svxDwgBom *data)
evxErrors | cvxDwgTableBom (const svxDwgBom *pData, int *idTbl)
evxErrors | cvxDwgTableInsert (const svxDwgTblInsert *pData)
evxErrors | cvxDwgUserTableCreate (const vxName name, int iRow, int iCol, svxPoint2 *pnt, int origin, int *idTable)
evxErrors | cvxDwgUserTableCreateByTemplate (const vxName name, const vxLongPath tplPath, svxPoint2 *pnt, int origin, int *idTable)

Edit View

evxErrors | cvxDwgRotateViewinit (svxDwgRotView *data)
evxErrors | cvxDwgRotateView (const svxDwgRotView *pData)
evxErrors | cvxDwgViewRotate (int idView, double angle)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_ecadboard.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_ecadboard.h File Reference
#include "zwapi_cmd_ecadboard_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D ECAD Board API

Definition in file zwapi_cmd_ecadboard.h.

Engineer Feature

evxErrors | cvxPartEcadRgnSetInit (svxEcadRgnSetData *data)
evxErrors | cvxPartEcadRgnSet (const svxEcadRgnSetData *pRgnSetData, int *idFtr)
evxErrors | cvxPartEcadRgnCut (int idSketch, int *idFtr)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_ecadboard_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_ecadboard_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the ECAD Board command functions.

Definition in file zwapi_cmd_ecadboard_data.h.

Engineer Feature Data

enum evxEcadRgnSetType {
VX_ROUTING_RGN = 0 , VX_PLACEMENT_RGN = 1 , VX_VIA_RGN = 2 , VX_OTHER_RGN = 3 ,
VX_PLACEMENT_GRP_RGN = 4
}
region setting type More...
enum | evxEcadRgnOwner { VX_MCAD_RGN = 0 , VX_ECAD_RGN = 1 , VX_UNOWNED_RGN = 2 }
region owner More...
typedef enum evxEcadRgnSetType | evxEcadRgnSetType
region setting type
typedef enum evxEcadRgnOwner | evxEcadRgnOwner
region owner
typedef struct svxEcadRgnSetData | svxEcadRgnSetData
Region set data.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_freeform.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_freeform.h File Reference
#include "zwapi_cmd_freeform_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Free Form Commands API

Definition in file zwapi_cmd_freeform.h.

Basic Face

evxErrors | cvxPartFilletBlendInit (svxFilletBlendData *data)
evxErrors | cvxPartFilletBlend (const svxFilletBlendData *FilletBlend, int *idFilletBlend)
evxErrors | cvxPartNSidedInit (svxNSidedData *data)
evxErrors | cvxPartNSided (const svxNSidedData *NSidedData, int *idShape)
evxErrors | cvxPartTrimmedPlaneInit (svxTrimPlnData *data)
evxErrors | cvxPartTrimmedPlane (svxTrimPlnData *data, int *newShp)
evxErrors | cvxPartRuledInit (svxRuledData *data)
evxErrors | cvxPartRuled (const svxRuledData *data, int *idFace)
evxErrors | cvxPartCircularBiRailInit (evxCircularBiRailMethod method, svxCircularBiRailData *data)
evxErrors | cvxPartCircularBiRail (const svxCircularBiRailData *data, int *idFace)
evxErrors | cvxPartConicBiRailInit (evxConicBiRailMethod method, svxConicBiRailData *data)
evxErrors | cvxPartConicBiRail (const svxConicBiRailData *data, int *idFace)

Edit Face

evxErrors | cvxPartFacesOffsetInit (svxFcsOffsetData *data)
evxErrors | cvxPartFacesOffset (const svxFcsOffsetData *data, int *idFtr)
evxErrors | cvxPartExtendFaceInit (svxExtendData *data)
evxErrors | cvxPartExtendFace (svxExtendData *data, int *newFtr)
evxErrors | cvxPartTrimToFacesInit (svxTrimToFacesData *data)
evxErrors | cvxPartTrimToFaces (const svxTrimToFacesData *data, int *idTrim)
evxErrors | cvxPartTrimToCrvs (const svxTrimToCurvesData *trimData, int *idTrim)
evxErrors | cvxPartSetFaceDir (int count, int *idFaces, const svxVector *dir)
evxErrors | cvxFaceReverse (int numFaces, int *idFaces)
evxErrors | cvxFaceReverseDir (int numFaces, int *idFaces)
evxErrors | cvxPartModifyIsolineNum (int count, int *idFaces, int Uisoline, int Visoline)
evxErrors | cvxPartExplodeInit (svxExplodeData *data)
evxErrors | cvxPartExplode (const svxExplodeData *ExplodeData, int *numShape, int **idShapes)
evxErrors | cvxPartFacesetSewInit (svxSewData *data)
evxErrors | cvxPartFacesetSew (int count, int *shapes, svxSewData *param, int *newFtr)
evxErrors | cvxPartSewForce (double Tol)
evxErrors | cvxPartEnlargeFaceInit (svxEnlargeFaceData *data)
evxErrors | cvxPartEnlargeFace (const svxEnlargeFaceData *data, int *idFace)
evxErrors | cvxPartExtendShapeInit (svxExtendShapeData *data)
evxErrors | cvxPartExtendShape (const svxExtendShapeData *data, int *idFtr)
evxErrors | cvxPartSplitWithCrvInit (svxSplitWithCrvData *data)
evxErrors | cvxPartSplitWithCrv (const svxSplitWithCrvData *data, int *idFtr)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_freeform_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_freeform_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Free Form Command functions.

Definition in file zwapi_cmd_freeform_data.h.

Basic Face

enum | evxSpineType { VX_SPINE_NATURAL = 0 , VX_SPINE_SPINE = 1 , VX_SPINE_PARALLEL = 2 }
spine type More...
enum | evxCroSecType { VX_CRO_SEC_CIRCULAR = 0 , VX_CRO_SEC_CONIC = 1 , VX_CRO_SEC_G2BLEND = 2 , VX_CRO_SEC_G3BLEND = 3 }
cross-section type More...
enum | evxSewingType { VX_SEWING_NOACTION = 0 , VX_SEWING_DIVIDE = 1 , VX_SEWING_TRIM = 2 , VX_SEWING_SEW = 3 }
sewing type More...
enum | evxCappingType { VX_CAPPING_MAXIMAL = 0 , VX_CAPPING_MINIMAL = 1 , VX_CAPPING_TANGENT = 2 }
capping type More...
enum | evxRefitOpt { VX_REFIT_NO = 0 , VX_REFIT_TANGENT = 1 , VX_REFIT_CURVATURE = 2 , VX_REFIT_DIRECT = 3 }
N-SIDED. More...
enum | evxCircularBiRailMethod { VX_CIRCULARBIRAIL_CONSTANT = 0 , VX_CIRCULARBIRAIL_VARIABLE , VX_CIRCULARBIRAIL_CENTER , VX_CIRCULARBIRAIL_MIDDLE }
circular bi rail method More...
enum evxConicBiRailMethod {
VX_CONICBIRAIL_CONSTANT = 0 , VX_CONICBIRAIL_VARIABLE , VX_CONICBIRAIL_HOLDER , VX_CONICBIRAIL_TANGENT ,
VX_CONICBIRAIL_INTERSECTION , VX_CONICBIRAIL_CENTER , VX_CONICBIRAIL_TANGENTEDGES
}
conic bi rail method More...
typedef enum evxSpineType | evxSpineType
spine type
typedef enum evxCroSecType | evxCroSecType
cross-section type
typedef enum evxSewingType | evxSewingType
sewing type
typedef enum evxCappingType | evxCappingType
capping type
typedef struct svxFilletBlendData | svxFilletBlendData
freeForm filletBlend data
typedef enum evxRefitOpt | evxRefitOpt
N-SIDED.
typedef struct svxNSidedData | svxNSidedData
template command N-sided data
typedef struct svxTrimPlnData | svxTrimPlnData
template command Trimmed Plane data
typedef struct svxRuledData | svxRuledData
ruled data
typedef enum evxCircularBiRailMethod | evxCircularBiRailMethod
circular bi rail method
typedef struct svxRadiusSetData | svxRadiusSetData
radius set data
typedef struct svxCircularBiRailData | svxCircularBiRailData
circular bi rail data
typedef enum evxConicBiRailMethod | evxConicBiRailMethod
conic bi rail method
typedef struct svxConicBiRailData | svxConicBiRailData
conic bi rail data

Edit Face

enum | evxTrimCrvsProjtype { VX_TRIMCRV_IN_PLACE , VX_TRIMCRV_FACE_NORMAL , VX_TRIMCRV_DIRECTED , VX_TRIMCRV_BI_DIRECTIONAL }
projection types of "trim to curves" More...
enum | evxFaceExtType { VX_FACE_EXT_LINEAR = 0 , VX_FACE_EXT_REFLECT , VX_FACE_EXT_CIRCULAR , VX_FACE_EXT_CURVATURE_DIMINISHING = 4 }
face extension type More...
enum | evxExtendShapeMethod { VX_EXTEND_OPEN_SHAPE = 0 , VX_EXTEND_GENERAL_SHAPE = 1 }
extend shape type More...
enum | evxEdgeExtensionType { VX_EDGE_EXTENSION_TANGENT = 0 , VX_EDGE_EXTENSION_ORTHOGONAL }
edge extension type More...
enum | evxExtendFaceMethod { VX_EXTEND_FACE_NONE = 0 , VX_EXTEND_FACE_CLOSE_ENTIRE_GAP , VX_EXTEND_FACE_DIRECT_EDIT }
extend face method More...
typedef struct svxFcsOffsetData | svxFcsOffsetData
faces offset data
typedef struct svxExtendData | svxExtendData
template command Extend Face data
typedef struct svxTrimToFacesData | svxTrimToFacesData
trim to faces
typedef enum evxTrimCrvsProjtype | evxTrimCrvsProjtype
projection types of "trim to curves"
typedef struct svxTrimToCurvesData | svxTrimToCurvesData
template command Trim to Curves input data
typedef struct svxExplodeData | svxExplodeData
data of explode command
typedef struct svxSewData | svxSewData
faces sew data
typedef enum evxFaceExtType | evxFaceExtType
face extension type
typedef struct svxEnlargeFaceData | svxEnlargeFaceData
enlarge face data
typedef enum evxExtendShapeMethod | evxExtendShapeMethod
extend shape type
typedef enum evxEdgeExtensionType | evxEdgeExtensionType
edge extension type
typedef enum evxExtendFaceMethod | evxExtendFaceMethod
extend face method
typedef struct svxExtendShapeData | svxExtendShapeData
extend shape data
typedef struct svxSplitWithCrvData | svxSplitWithCrvData
split with curve data
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_paramdefine_param.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_paramdefine_param.h File Reference
#include "zwapi_cmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Command Parameter API

Definition in file zwapi_cmd_paramdefine_param.h.

Command Initialization

evxErrors cvxDataInit (const vxName Template, int *idData)

Data Set

void | cvxDataZero (svxData *Data)
evxErrors | cvxDataSet (int idData, int idField, svxData *Data)
evxErrors | cvxDataSetColor (int idData, int idField, svxColor *Color)
evxErrors | cvxDataSetPath (int idData, int idField, svxEntPath *Ent)
evxErrors | cvxDataSetPromote (int idData, int idField, int Promote)
evxErrors | cvxDataSetPntOnCrv (int idData, int idField, int idCrv, svxPoint *Pnt)
evxErrors | cvxDataSetPntOnFace (int idData, int idField, int idComp, int idFace)
evxErrors | cvxDataSetPntOnFace2 (int idData, int idField, int idFace, svxPoint *Pnt)
evxErrors | cvxDataSetPntByPath (int idData, int idField, svxEntPath *entPath, svxPoint *pnt)
evxErrors | cvxDataSetPntOnCrvPath (int idData, int idField, int critPnt, const svxEntPath *crvPath, const svxPoint *pnt)
evxErrors | cvxDataSetPntOnEnt (int idData, int idField, const svxPntOnEnt *pntData)
evxErrors | cvxDataSetPntOnEntPath (int idData, int idField, const svxPntOnEntPath *pntData)
evxErrors | cvxDataSetDirOnEntPath (int idData, int idField, const svxDirOnEntPath *dirData)
evxErrors | cvxDataSetMatrix (int idData, int idField, const svxMatrix *mat)
evxErrors | cvxDataToFeature (int idData, int idFeature, int ExcludeRegen)

Data Get

evxErrors | cvxDataGet (int idData, int idField, svxData *Data)
evxErrors | cvxDataGetColor (int idData, int idField, svxColor *Color)
evxErrors | cvxDataGetEnt (int idData, int idField, int *idEnt, int *idParent)
evxErrors | cvxDataGetEnts (int idData, int idField, int *Count, int **idEnts)
evxErrors | cvxDataGetList (int idData, int idField, int *Count, svxData **Data)
evxErrors | cvxDataGetNum (int idData, int idField, double *Number)
int | cvxDataGetOpt (int idData, int idField)
int | cvxDataGetPath (int idData, int idField, int *FirstEnt, svxEntPath *Ent)
evxErrors | cvxDataGetPaths (int idData, int idField, int *count, svxEntPath **paths)
evxErrors | cvxDataGetPnt (int idData, int idField, svxPoint *Pnt)
evxErrors | cvxDataGetPnts (int idData, int idField, int *Count, svxPoint **Pnts)
evxErrors | cvxDataGetPntOnEnt (int idData, int idField, svxPoint *pnt, svxEntPath *path)
evxErrors | cvxDataGetPntsOnEnts (int idData, int idField, int *count, svxPoint **pnts, svxEntPath **paths)
evxErrors | cvxDataGetPromote (int idData, int idField, int *Promote)
evxErrors | cvxDataGetText (int idData, int idField, int NumBytes, char *Text)
evxErrors | cvxDataGetMatrix (int idData, int idField, svxMatrix *Matrix)
evxErrors | cvxDataGetItemList (int idData, int idField, int *Count, int **idItems)
evxErrors | cvxDataGetItemData (int idItem, svxData *Data)
evxErrors | cvxDataGetAll (int idData, int *numFld, svxFldData **fldData)
void | cvxFldDataFree (int Count, svxFldData **fldData)

Data Clear

evxErrors | cvxDataClear (int idData, int idField)
evxErrors | cvxDataDel (int idData, int idField)
evxErrors | cvxDataDelItem (int idData, int idField, int iEnt)
evxErrors | cvxDataDelUnHi (int idData, int idField)
evxErrors | cvxDataFree (int idData)
evxErrors | cvxDataGrpRem (int idData, int idField, int idItem)

Data Query

evxErrors | cvxDataInqActive (int *idData)
evxErrors | cvxDataInqParent (int *idData)
char * | cvxDataName (int idData)

Aux Frame

void | cvxAuxFrameShow (int idData, int entField, int matField)
void | cvxAuxFrameSetOrigin (const svxPoint *Origin)
void | cvxAuxFrameSetAxisVec (evxAxisType AxisType, const svxVector *AxisDir)
void | cvxAuxFrameSetDirXYZOrgBuddy (int idData, int idXFld, int idYFld, int idZFld, int idOrgFld)
void | cvxMoveSetAuxFrameElem (int iElem)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_paramdefine_tpl.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_paramdefine_tpl.h File Reference
#include "zwapi_cmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Command Container API

Definition in file zwapi_cmd_paramdefine_tpl.h.

Command Execute

int | cvxCmdEval (vxName Name, int idData)
int | cvxCmdExec (int idData)
evxErrors | cvxCmdExec2 (int idData)
evxErrors | cvxCmdExecWithOut (int idData, int *idOut)

Command Operation

evxErrors | cvxCmdInput (const vxName Name, int idDataIn, int *idDataOut)
evxErrors | cvxCmdInteract (const vxName Name)
void | cvxCmdInqActive (vxName Name)
void | cvxCmdMarker (const vxName Okay, const vxName Cancel)
evxErrors | cvxCmdStateGet (vxName CmdName, evxCmdState *State)
evxErrors | cvxCmdStateSet (vxName CmdName, evxCmdState State)

Template Register/Un-register

evxErrors | cvxCmdTemplate (const vxLongPath File)
evxErrors | cvxCmdTemplateUnload (const vxLongPath File)

Echo Function

void | cvxEchoColorGet (evxColor *Color)
void | cvxEchoColorSet (evxColor Color)
void | cvxEchoColorAtSet (svxWireAt *at)
void | cvxEchoColorAtGet (svxWireAt *at)
void | cvxEchoCustomStart ()
void | cvxEchoCustomEnd ()
void | cvxEchoDraw ()
void | cvxEchoStart ()
void | cvxEchoEnd ()
void | cvxEchoEscDisable ()
void | cvxEchoEscRestore ()

Template Query

evxErrors | cvxTplInqFnCust (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnEcho (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnInit (vxName Name, int NumBytes, char *FnName)
evxErrors | cvxTplInqFnTerm (vxName Name, int NumBytes, char *FnName)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_pmi.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_pmi.h File Reference
#include "zwapi_cmd_pmi_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D PMI Commands API

Definition in file zwapi_cmd_pmi.h.

Dimension

evxErrors | cvxPartAddLineDim (int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddSymmetryDim (svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddAngleDim (int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddRadDim (int idEnt, int radType, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
evxErrors | cvxPartAddChamferDim (int idEnt1, int idEnt2, const svxPoint *TextPos, int idPlane, int *idDim)
evxErrors | cvxPartAddArcDim (int idEnt, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)

Annotation

evxErrors | cvxPartAddCoorDim (svxPoint *LeaderPnt, int idParent, const svxPoint *TextPnt, int idDatum, int idPlane, int *idDim)
evxErrors | cvxPartAddLabelDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddDatumDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddDatumTargetDim (int idEnt, int radRype, double diameter, double width, double height, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddFcsDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddSymSrfDim (int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, svxRoughTexts *textGrp, int idPlane, int *idDim)
evxErrors | cvxPartAddCenLinDim (int idEnt, int idPlane, int *idDim)
evxErrors | cvxPartAddCenMarkDim (int idEnt, int idPlane, int *idDim)

Text

evxErrors | cvxPartAddPMIText (svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors | cvxPartAddBalloon (svxPoint *TextPnt, char *text, int fImage, int idPlane, int *idDim)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_pmi_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_pmi_data.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the PMI Command functions.

Definition in file zwapi_cmd_pmi_data.h.

Annotation Data

typedef struct svxRoughTexts svxRoughTexts
Roughness PMI text define.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_shape.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_shape.h File Reference
#include "zwapi_cmd_shape_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Shape Commands of Part API

Definition in file zwapi_cmd_shape.h.

Basic Shape

evxErrors | cvxPartBoxInit (svxBoxData *data)
evxErrors | cvxPartBox (svxBoxData *Box, int *idShape)
evxErrors | cvxPartCylInit (svxCylData *data)
evxErrors | cvxPartCyl (svxCylData *Cyl, int *idShape)
evxErrors | cvxPartConeInit (svxConeData *data)
evxErrors | cvxPartCone (svxConeData *Cone, int *idShape)
evxErrors | cvxPartSphereInit (svxSphereData *data)
evxErrors | cvxPartSphere (svxSphereData *Sphere, int *idShape)
evxErrors | cvxPartEllipsoidInit (svxEllsoData *data)
evxErrors | cvxPartEllipsoid (svxEllsoData *Ellso, int *idShape)
evxErrors | cvxPartExtrudeInit (svxExtrudeData *data)
evxErrors | cvxPartExtrude (svxExtrudeData *Ext, int *idShape)
evxErrors | cvxPartRevolveInit (svxRevolveData *data)
evxErrors | cvxPartRevolve (svxRevolveData *Rev, int *idShape)
evxErrors | cvxPartSweepInit (svxSweepData *data)
evxErrors | cvxPartSweep (svxSweepData *Swp, void *Options, int *idShape)
evxErrors | cvxPartSpiralSweepInit (svxSpiralSweepData *data)
evxErrors | cvxPartSpiralSweep (const svxSpiralSweepData *SpiralSwp, int *idShape)
evxErrors | cvxPartLoftInit (svxLoftData *data)
evxErrors | cvxPartLoft (svxLoftData *Loft, int *idShape)

Engineering Feature

evxErrors | cvxPartFillet (int Count, int *Edges, double Radius)
evxErrors | cvxPartFilletAllInit (svxChamFlltData *data)
evxErrors | cvxPartFilletAll (const svxChamFlltData *Fillet, int *idFillet)
evxErrors | cvxPartFaceFilletInit (svxFaceFlltData *data)
evxErrors | cvxPartFaceFillet (const svxFaceFlltData *data, int *idFillet)
evxErrors | cvxPartChamConst (int Count, int *Edges, double Setback)
evxErrors | cvxPartChamAng (int Count, int *Edges, int idFace, double Setback, double Angle)
evxErrors | cvxPartChamAsym (int Count, int *Edges, int idFace, double Setback1, double Setback2)
evxErrors | cvxChamFlltSetDataInit (svxChamFlltSetData *data)
evxErrors | cvxPartChamferAllInit (svxChamFlltData *data)
evxErrors | cvxPartChamferAll (const svxChamFlltData *Chamfer, int *idChamfer)
evxErrors | cvxPartDraftInit (evxDraftMethods method, svxDraftData *data)
evxErrors | cvxPartDraft (const svxDraftData *Draft, int *idDraft)
evxErrors | cvxPartHoleInit (evxHoleOpt HoleOpt, int type, svxHoleData *data)
evxErrors | cvxPartHole (svxHoleData *Data, int *idOp)
evxErrors | cvxPartModifyHoleInit (int idFace, svxHoleData *data)
evxErrors | cvxPartModifyHole (int cntFace, int *pFace, const svxHoleData *data, int *idFtr)
evxErrors | cvxPartFlagHolesInit (svxFlagHoleData *data)
evxErrors | cvxPartFlagHoles (const svxFlagHoleData *data, int *idFtr)
evxErrors | cvxPartRibInit (svxRibData *data)
evxErrors | cvxPartRib (svxRibData *Rib, int *idRib)
evxErrors | cvxPartFlagExtThreadInit (svxFlagExtThreadData *data)
evxErrors | cvxPartFlagExtThread (const svxFlagExtThreadData *data, int *idFtr)
evxErrors | cvxPartThreadAtInit (svxThreadData *data)
evxErrors | cvxPartThreadAt (int idFace, svxPoint *Pnt, svxThreadData *Thread)
evxErrors | cvxPartLipInit (svxLipData *data)
evxErrors | cvxPartLip (svxLipData *Lip, int *idLip)
evxErrors | cvxPartStockInit (svxStockData *data)
evxErrors | cvxPartStock (svxStockData *Stock, int *idShape)

Edit Shape

evxErrors | cvxPartFaceOffset (int idFace, double Dis, int Keep)
evxErrors | cvxPartShapeFaceOffsetInit (svxFaceOffData *data)
evxErrors | cvxPartShapeFaceOffset (svxFaceOffData *Offset, int *idOffset)
evxErrors | cvxPartShellInit (svxShellData *data)
evxErrors | cvxPartShell (const svxShellData *Shell, int *idShell)
evxErrors | cvxPartThickenInit (svxThickenData *data)
evxErrors | cvxPartThicken (svxThickenData *Thicken, int *idShape)
evxErrors | cvxPartBool (evxBoolType Type, int idBase, int Count, int *Shapes, int Keep)
evxErrors | cvxPartBool2 (evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int *ResultCount, int **ResultList)
evxErrors | cvxPartBool3 (evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int FaceCount, int *FaceList, int *ResultCount, int **ResultList)
evxErrors | cvxPartDivideInit (svxDivideData *data)
evxErrors | cvxPartDivide (svxDivideData *Divide, int *numShape, int **idShapes)
evxErrors | cvxPartTrimInit (svxTrimData *data)
evxErrors | cvxPartTrim (svxTrimData *Trim, int *numShape, int **idShapes)
evxErrors | cvxPartSimplify (int numEnts, int *idEnts, int *idSimplify)
evxErrors | cvxPartReplaceInit (svxReplaceData *data)
evxErrors | cvxPartReplace (const svxReplaceData *Replace, int *idReplace)
evxErrors | cvxPartInlayInit (svxInlayData *data)
evxErrors | cvxPartInlay (svxInlayData *Inlay, int *idInlay)
evxErrors | cvxPartSelfXInit (svxPartSelfX *data)
evxErrors | cvxPartSelfX (const svxPartSelfX *data, int *idShape)
evxErrors | cvxPartPunchInit (svxPunch *data)
evxErrors | cvxPartPunch (const svxPunch *data, int *idPunch)

Morph

evxErrors | cvxPartTwistInit (svxTwistData *data)
evxErrors | cvxPartTwist (const svxTwistData *Twist, int *idTwist)
evxErrors | cvxPartTaperInit (svxTaperData *data)
evxErrors | cvxPartTaper (const svxTaperData *Taper, int *idTaper)
evxErrors | cvxPartStretchInit (svxStretchData *data)
evxErrors | cvxPartStretch (const svxStretchData *Stretch, int *idStretch)
evxErrors | cvxPartMorphToCrvInit (svxMorphToCrvData *data)
evxErrors | cvxPartMorphToCrv (const svxMorphToCrvData *MorphToCrv, int *idMorphToCrv)

Basic Editing

evxErrors | cvxPtnDataInit (evxPatternType type, svxPtnData *data)
evxErrors | cvxPartPatternGeom (int Count, int *idEnts, const svxPtnGeom *Pattern, int *idPattern)
evxErrors | cvxPtnVarTblInit (int firstNum, int secondNum, const char *dimName, svxPtnVarTbl *ptnVarTbl)
evxErrors | cvxPartPatternFtr (int Count, int *idFtrs, const svxPtnFtr *Pattern, int *idPattern)
evxErrors | cvxPartMirrorGeominit (svxMirrorGeom *data)
evxErrors | cvxPartMirrorGeom (svxMirrorGeom *Mirror, int *NumNewEnts, int **idNewEnts)
evxErrors | cvxPartMirrorFtrInit (svxMirrorFtr *data)
evxErrors | cvxPartMirrorFtr (svxMirrorFtr *Mirror, int *idFtr)
evxErrors | cvxPartMovePntToPnt (int idEntity, svxAxis *Start, svxAxis *End)
evxErrors | cvxPartMoveTransform (int idEntity, const svxMatrix *Mat)
evxErrors | cvxPartMoveTransformList (int Count, const int *Entities, const svxMatrix *Mat)
evxErrors | cvxPartMove (const svxMoveData *Move, int *idMove)
evxErrors | cvxPartCopyDirDis (int idEntity, svxVector *Dir, double Dis, int *idCopy)
evxErrors | cvxPartCopyPntToPnt (int idEntity, svxAxis *Start, svxAxis *End, int *idCopy)
evxErrors | cvxPartCopyTransform (int idEntity, const svxMatrix *Mat, int *idCopy)
evxErrors | cvxPartCopyTransformList (const int Count, const int *Entities, const svxMatrix *Mat, int *EntCnt, int **idList)
evxErrors | cvxPartCopyInit (svxCopyData *data)
evxErrors | cvxPartCopy (const svxCopyData *Copy, int *idCopy)
evxErrors | cvxPartScale (int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum)
evxErrors | cvxPartScale2 (int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum, svxPoint *CentPnt)
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_shape_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_shape_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_subcmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Shape Command functions of Part.

Definition in file zwapi_cmd_shape_data.h.

Basic Shape Data

enum | evxBoolType { VX_BOOL_NONE = 0 , VX_BOOL_ADD = 1 , VX_BOOL_REMOVE = 2 , VX_BOOL_INTERSECT = 3 }
boolean combination method More...
enum | evxOffsetType { VX_OFFSET_NONE = 0 , VX_OFFSET_SHRINK = 1 , VX_OFFSET_THICKEN = 2 , VX_OFFSET_THICKEN_SAME = 3 }
offset type More...
enum | evxLeadType { VX_LEAD_IN = 0 , VX_LEAD_OUT = 1 , VX_LEAD_NONE = 2 }
lead type More...
enum | evxCapType { VX_END_CAP_BOTH = 0 , VX_END_CAP_START = 1 , VX_END_CAP_END = 2 , VX_END_CAP_NONE = 3 }
End caps. More...
enum evxSweepOpt {
VX_SWP_NATURAL = 0 , VX_SWP_AT_PATH = 1 , VX_SWP_FRAME = 2 , VX_SWP_AT_PROFILE = 3 ,
VX_SWP_ALONG_PATH = 4
}
sweep option More...
enum | evxSweepXOpt { VX_SWP_X_MIN_TWIST = 0 , VX_SWP_X_FIXED_DIR = 1 , VX_SWP_X_XAXIS_CRV = 2 , VX_SWP_X_FACE_NORMAL = 3 }
sweep Xaxis option More...
enum | evxSweepZOpt { VX_SWP_Z_TANG_TO_PATH = 0 , VX_SWP_Z_TANG_TO_CRV = 1 , VX_SWP_Z_FIXED_DIR = 2 }
sweep Zaxis option More...
enum | evxLoftType { VX_LOFT_PROFS , VX_LOFT_START_PNT_PROFS , VX_LOFT_END_PNT_PROFS , VX_LOFT_BOTH_PNTS_PROFS }
loft method More...
typedef enum evxBoolType | evxBoolType
boolean combination method
typedef struct svxBoxData | svxBoxData
box data
typedef struct svxCylData | svxCylData
cylinder
typedef struct svxConeData | svxConeData
cone
typedef struct svxSphereData | svxSphereData
sphere
typedef struct svxEllsoData | svxEllsoData
ellipsoid
typedef enum evxOffsetType | evxOffsetType
offset type
typedef enum evxLeadType | evxLeadType
lead type
typedef enum evxCapType | evxCapType
End caps.
typedef struct svxExtrudeData | svxExtrudeData
extruded shape
typedef struct svxRevolveData | svxRevolveData
revolved shape
typedef enum evxSweepOpt | evxSweepOpt
sweep option
typedef enum evxSweepXOpt | evxSweepXOpt
sweep Xaxis option
typedef enum evxSweepZOpt | evxSweepZOpt
sweep Zaxis option
typedef struct svxSweepData | svxSweepData
swept shape
typedef struct svxSpiralSweepData | svxSpiralSweepData
spiral swept shape
typedef struct svxLoftProfile | svxLoftProfile
loft profile data
typedef enum evxLoftType | evxLoftType
loft method
typedef struct svxLoftData | svxLoftData
loft data

Engineering Feature Data

enum | evxChamFlltType { VX_CHAMFLLT_SYMMETRIC , VX_CHAMFLLT_ASYMMETRIC , VX_CHAMFLLT_SETBACK_ANGLE , VX_CHAMFLLT_VERTEX }
chamfer or fillet types More...
enum | evxFaceFlltType { VX_FACE_FFLT_FACE = 0 , VX_FACE_FFLT_RADIUS = 1 }
enum | evxFaceFlltBaseType { VX_FACE_FFLT_BASE_FACE_NONE = 0 , VX_FACE_FFLT_BASE_FACE_SEW = 3 }
enum | evxDraftMethods { VX_EDGE_DRAFT = 1 , VX_FACE_DRAFT = 2 , VX_PRATING_EDGE_DRAFT = 3 }
draft methods More...
enum evxDraftType {
VX_DRAFT_TYPE_NONE = 0 , VX_SYM_EDGE_DRAFT = 1 , VX_ASYM_EDGE_DRAFT = 2 , VX_STATION_SYM_FACE_DRAFT = 3 ,
VX_STATION_ASYM_FACE_DRAFT = 4 , VX_STATION_PARTING_FACE_DRAFT = 5
}
draft type More...
enum | evxHoleOpt { VX_GENERAL_HOLE = 0 , VX_CLEARANCE_HOLE = 1 , VX_THREAD_HOLE = 2 , VX_PROFILE_HOLE = 3 }
hole option More...
enum evxHoleType {
VX_HOLE_SHAPE_ALL = -1 , VX_HOLE_SIMPLE = 0 , VX_HOLE_TAPERED = 1 , VX_HOLE_COUNTER_BORE = 2 ,
VX_HOLE_COUNTER_SUNK = 3 , VX_HOLE_SPOT_FACE = 4
}
hole types More...
enum evxClearHoleType {
VX_CLEAR_HOLE_SIMPLE = 0 , VX_CLEAR_HOLE_COUNT_BORE = 2 , VX_CLEAR_HOLE_COUNT_SINK = 3 , VX_CLEAR_HOLE_SLOT = 5 ,
VX_CLEAR_HOLE_COUNT_SINK_SLOT = 6 , VX_CLEAR_HOLE_COUNT_BORE_SLOT = 7
}
hole type of clearance hole More...
enum evxThreadType {
VX_THREAD_NONE = 1 , VX_THREAD_CUSTOM = 2 , VX_THREAD_M = 3 , VX_THREAD_UNC = 4 ,
VX_THREAD_UNF = 5 , VX_THREAD_ISO7 = 6 , VX_THREAD_ISO228 = 7 , VX_THREAD_NPT = 8 ,
VX_THREAD_NPSM = 9 , VX_THREAD_MC = 10 , VX_THREAD_MF = 11 , VX_THREAD_UN = 12 ,
VX_THREAD_UNEF = 13 , VX_THREAD_UNJ = 14 , VX_THREAD_UNJC = 15 , VX_THREAD_UNJF = 16 ,
VX_THREAD_UNJEF = 17 , VX_THREAD_ACME = 18 , VX_THREAD_BSP = 19 , VX_THREAD_BSTP = 20
}
hole thread types More...
enum | evxEndCondition { VX_BLIND = 0 , VX_UNTIL_FACE = 1 , VX_THROUGH_ALL = 2 }
hole end conditions More...
enum | evxThreadHoleClass { VX_THREAD_HOLE_UNDEFINED , VX_THREAD_HOLE_1B , VX_THREAD_HOLE_2B , VX_THREAD_HOLE_3B }
thread class for flag holes More...
enum evxFlagThreadDepthType {
VX_FLAG_THREAD_UNDEFINED , VX_FLAG_THREAD_DEPTH_DEFAULT , VX_FLAG_THREAD_DEPTH_1XDIAMETER , VX_FLAG_THREAD_DEPTH_15XDIAMETER ,
VX_FLAG_THREAD_DEPTH_2XDIAMETER , VX_FLAG_THREAD_DEPTH_25XDIAMETER , VX_FLAG_THREAD_DEPTH_3XDIAMETER , VX_FLAG_THREAD_DEPTH_FULL ,
VX_FLAG_THREAD_DEPTH_CUSTOM
}
flagged as thread hole depth type More...
enum | evxStockOpt { VX_STOCK_BLOCK = 1 , VX_STOCK_CYLINDER = 2 }
stock type More...
typedef enum evxChamFlltType | evxChamFlltType
chamfer or fillet types
typedef struct svxChamFlltSetData | svxChamFlltSetData
set-list data for chamfer or fillet command
typedef struct svxChamFlltData | svxChamFlltData
chamfer or fillet data
typedef enum evxFaceFlltType | evxFaceFlltType
typedef enum evxFaceFlltBaseType | evxFaceFlltBaseType
typedef struct svxFaceFlltData | svxFaceFlltData
typedef enum evxDraftMethods | evxDraftMethods
draft methods
typedef enum evxDraftType | evxDraftType
draft type
typedef struct svxDraftData | svxDraftData
template command Draft data
typedef enum evxHoleOpt | evxHoleOpt
hole option
typedef enum evxHoleType | evxHoleType
hole types
typedef enum evxClearHoleType | evxClearHoleType
hole type of clearance hole
typedef enum evxThreadType | evxThreadType
hole thread types
typedef struct svxHoleChams | svxHoleChams
Hole chamfer, added in 1900.
typedef enum evxEndCondition | evxEndCondition
hole end conditions
typedef struct svxHoleData | svxHoleData
hole data
typedef enum evxThreadHoleClass | evxThreadHoleClass
thread class for flag holes
typedef enum evxFlagThreadDepthType | evxFlagThreadDepthType
flagged as thread hole depth type
typedef struct svxFlagHoleData | svxFlagHoleData
flag hole data
typedef struct svxRibData | svxRibData
rib data
typedef struct svxFlagExtThreadData | svxFlagExtThreadData
flag ext thread data
typedef struct svxThreadData | svxThreadData
thread definition
typedef struct svxLipData | svxLipData
lip data
typedef enum evxStockOpt | evxStockOpt
stock type
typedef struct svxStockData | svxStockData
stock data

Edit Shape Data

enum | evxOverflowType { VX_OF_AUTOMATIC = 0 , VX_OF_CHANGE = 1 , VX_OF_STATIONARY = 2 , VX_OF_CAP = 3 }
overflow types More...
typedef struct svxFaceOffData | svxFaceOffData
shape face offset data
typedef struct svxShellData | svxShellData
template command Shell input data
typedef struct svxThickenData | svxThickenData
thicken data
typedef struct svxDivideData | svxDivideData
divide data
typedef struct svxTrimData | svxTrimData
Trim data.
typedef enum evxOverflowType | evxOverflowType
overflow types
typedef struct svxReplaceData | svxReplaceData
shape replace data
typedef struct svxInlayData | svxInlayData
inlay data
typedef struct svxPartSelfX | svxPartSelfX
part resolveSelfX data
typedef struct svxPunch | svxPunch
part punch data

Basic Editing

enum evxPatternType {
VX_PATTERN_LINEAR , VX_PATTERN_CIRCULAR , VX_PATTERN_PNT_TO_PNT , VX_PATTERN_AT_PATTERN ,
VX_PATTERN_AT_CURVES , VX_PATTERN_AT_FACE , VX_PATTERN_POLYGON , VX_PATTERN_FILL_PATTERN ,
VX_PATTERN_BY_VAR
}
pattern method More...
enum evxMoveType {
VX_PNT_TO_PNT = 1 , VX_ALONG_DIR = 2 , VX_ASLIGN_FRAMES = 3 , VX_SWEEP_ALONG_PATH = 4 ,
VX_AROUND_DIR = 5 , VX_DYNAMIC_MOVE = 6
}
Move and Copy Methods. More...
typedef enum evxPatternType | evxPatternType
pattern method
typedef struct svxPtnData | svxPtnData
pattern data
typedef struct svxPtnGeom | svxPtnGeom
pattern geometry data
typedef struct svxPtnVarTbl | svxPtnVarTbl
table dimension information
typedef struct svxPtnFtr | svxPtnFtr
pattern feature data
typedef struct svxMirrorGeom | svxMirrorGeom
mirror geometry data
typedef struct svxMirrorFtr | svxMirrorFtr
mirror feature data
typedef enum evxMoveType | evxMoveType
Move and Copy Methods.
typedef struct svxDymMove | svxDymMove
dynamic copy/move entities
typedef struct svxMovePntToPnt | svxMovePntToPnt
copy/move entities form point to point
typedef struct svxAlongDir | svxAlongDir
copy/move entities along a direction
typedef struct svxAroundDir | svxAroundDir
rotate entities around a direction
typedef struct svxAlignFrame | svxAlignFrame
copy/move entities by aligning frames
typedef struct svxAlongPath | svxAlongPath
copy/move entities along path
typedef struct svxMoveData | svxMoveData
template command Move data
typedef struct svxCopyData | svxCopyData
template command Copy data

Morph Data

typedef struct svxTwistData | svxTwistData
shape twist data
typedef struct svxTaperData | svxTaperData
shape taper data
typedef struct svxStretchData | svxStretchData
shape stretch data
typedef struct svxMorphToCrvData | svxMorphToCrvData
shape morph to curve data
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sheetmetal.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sheetmetal.h File Reference
#include "zwapi_cmd_sheetmetal_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sheet Metal Commands API

Definition in file zwapi_cmd_sheetmetal.h.

Base

evxErrors | cvxPartSmdExtrudeTabInit (svxSmdExtrudeTabData *data)
evxErrors | cvxPartSmdExtrudeTab (const svxSmdExtrudeTabData *data, int *idExtTab)
evxErrors | cvxPartSmdExtrudeFlangeinit (svxExtrudeFlangeData *data)
evxErrors | cvxPartSmdExtrudeFlange (const svxExtrudeFlangeData *data, int *idExtFlange)

Flange

evxErrors | cvxPartSmdReliefDataInit (svxSmdReliefData *data)
evxErrors | cvxPartSmdFullFlangeInit (svxSmdFullFlangeData *data)
evxErrors | cvxPartSmdFullFlange (const svxSmdFullFlangeData *data, int *idFull)
evxErrors | cvxPartSmdProfFlangeProfMatInit (int idEdge, double angle, svxMatrix *skMat)
evxErrors | cvxPartSmdProfFlangeInit (svxSmdFlangeProfData *data)
evxErrors | cvxPartSmdProfFlange (const svxSmdFlangeProfData *data, int *idFlange)
evxErrors | cvxPartSmdPartialFlangeInit (svxSmdPartialFlangeData *data)
evxErrors | cvxPartSmdPartialFlange (const svxSmdPartialFlangeData *data, int *idPartial)
evxErrors | cvxPartSmdHemFlangeInit (int hemType, svxSmdHemFlangeData *data)
evxErrors | cvxPartSmdHemFlange (const svxSmdHemFlangeData *data, int *idHem)
evxErrors | cvxPartSmdLftFlangeInit (evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData *data)
evxErrors | cvxPartSmdLftFlange (const svxSmdLoftedFlangeData *data, int *idLft)
evxErrors | cvxPartSmdSweptFlangeInit (evxSmdCornerRelief corType, svxSmdSweptFlangeData *data)
evxErrors | cvxPartSmdSweptFlange (const svxSmdSweptFlangeData *data, int *idSwept)
evxErrors | cvxPartSmdFoldByLineInit (svxSmdFoldByLineData *data)
evxErrors | cvxPartSmdFoldByLine (const svxSmdFoldByLineData *data, int *idFbl)
evxErrors | cvxPartSmdJogInit (svxSmdJogData *data)
evxErrors | cvxPartSmdJog (const svxSmdJogData *data, int *idJog)

Editing

evxErrors | cvxPartSmdExtendFlangeInit (evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData *data)
evxErrors | cvxPartSmdExtendFlange (const svxSmdExtendFlangeData *data, int *idFtr)
evxErrors | cvxPartSmdFlangeInit (svxSmdFlangeData *data)
evxErrors | cvxPartSmdFlange (const svxSmdFlangeData *data, int *idFlange)
evxErrors | cvxPartSmdBendTaperDefDataInit (int taperType, svxSmdBendTaperDefData *data)
evxErrors | cvxPartSmdBendTaperInit (evxSmdTaperSideMethod method, svxSmdBendTaperData *data)
evxErrors | cvxPartSmdBendTaper (const svxSmdBendTaperData *data, int *idFtr)
evxErrors | cvxPartSmdNormalCutinit (svxNormalCutData *data)
evxErrors | cvxPartSmdNormalCut (const svxNormalCutData *pData, int *numShape, int **idShapes)

Corner

evxErrors | cvxPartSmdCloseCornerInit (int type, svxCloseCornerData *data)
evxErrors | cvxPartSmdCloseCorner (const svxCloseCornerData *CornerData, int *idSmdCorner)

Form

evxErrors | cvxPartSmdDimpleInit (svxDimpleData *data)
evxErrors | cvxPartSmdDimple (svxDimpleData *Dimple, int *idDimple)
evxErrors | cvxPartSmdLouverInit (svxLouverData *data)
evxErrors | cvxPartSmdLouver (const svxLouverData *LouverData, int *idSmdLouver)
evxErrors | cvxPartSmdPunchInit (svxPunchData *data)
evxErrors | cvxPartSmdPunch (const svxPunchData *pData, int *idShape)

Bend

evxErrors | cvxPartSmdFold (const svxFoldData *Fold, int *idSmdFold)
evxErrors | cvxPartSmdUnfold (const svxUnfoldData *Unfold, int *idSmdUnfold)
evxErrors | cvxPartSmdFlattenInit (svxSmdFlattenData *data)
evxErrors | cvxPartSmdFlatten (const svxSmdFlattenData *data, int *idFtr)
evxErrors | cvxPartSmdLnUnfoldInit (svxSmdLinearUnfoldData *data)
evxErrors | cvxPartSmdLnUnfold (const svxSmdLinearUnfoldData *data, int *idFtr)
evxErrors | cvxPartSmdChangeBendInit (evxSmdChangeBendType type, svxSmdChangeBendData *data)
evxErrors | cvxPartSmdChangeBend (const svxSmdChangeBendData *data, int *idFtr)

Convert

evxErrors | cvxPartSmdRipInit (svxSmdRipData *data)
evxErrors | cvxPartSmdRip (const svxSmdRipData *data, int *idFtr)
evxErrors | cvxPartSmdMarkBendInit (svxSmdMarkBendData *data)
evxErrors | cvxPartSmdMarkBend (const svxSmdMarkBendData *data, int *idFtr)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sheetmetal_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sheetmetal_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Sheet Metal Command functions.

Definition in file zwapi_cmd_sheetmetal_data.h.

Sheet Metal Attribute Data

enum evxSmdPosition {
VX_POSITION_MATERIAL_INSIDE , VX_POSITION_MATERIAL_OUTSIDE , VX_POSITION_NATURAL , VX_POSITION_OFFSET ,
VX_POSITION_VIRTUAL_SHARP
}
Smd Flange Parameters Position. More...
enum | evxSmdBendLengthType { VX_BEND_STANDARD_LENGTH , VX_BEND_OUTER_HEIGHT , VX_BEND_INNER_HEIGHT , VX_BEND_EXTRAPOLATED_LENGTH }
Smd Bend Attributes Length type. More...
enum evxSmdKFactorType {
VX_SMD_KTYPE_CUSTOM , VX_SMD_KTYPE_FROM_MATERIAL , VX_SMD_KTYPE_BEND_TABLE , VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE ,
VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA , VX_SMD_KTYPE_BEND_DEDUCTION_TABLE , VX_SMD_KTYPE_BEND_DEDUCTIOIN , VX_SMD_KTYPE_BEND_ALLOWANCE
}
K-factor Definition type. More...
enum | evxSmdRelief { VX_RELIEF_RECTANGLE = 0 , VX_RELIEF_OBROUND = 1 , VX_RELIEF_NONE = 2 , VX_RELIEF_STRETCH = 3 }
Smd Relief type. More...
enum evxSmdCornerRelief {
VX_CORNER_RELIEF_CLOSED , VX_CORNER_RELIEF_CIRCULAR_CUTOUT , VX_CORNER_RELIEF_RECTANGULAR_CUTOUT , VX_CORNER_RELIEF_U_CUTOUT ,
VX_CORNER_RELIEF_V_CUTOUT
}
Smd Relief type of Corner Attributes. More...
enum evxSmdCalCustom {
VX_CUSTOM_RELIEF = 0x00000001 , VX_CUSTOM_ISWIDTHRATIO = 0x00000002 , VX_CUSTOM_RELIEFWIDTH = 0x00000004 , VX_CUSTOM_ISDEPTHRATIO = 0x00000008 ,
VX_CUSTOM_RELIEFDEPTH = 0x00000010
}
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom More...
enum | evxSmdReliefLengthType { VX_RELIEF_LENGTH_TYPE_TO_EDGE , VX_RELIEF_LENGTH_TYPE_THROUGH_ALL , VX_RELIEF_LENGTH_TYPE_VALUE }
Smd Relief Length Type of Flange. More...
typedef enum evxSmdPosition | evxSmdPosition
Smd Flange Parameters Position.
typedef enum evxSmdBendLengthType | evxSmdBendLengthType
Smd Bend Attributes Length type.
typedef enum evxSmdKFactorType | evxSmdKFactorType
K-factor Definition type.
typedef enum evxSmdRelief | evxSmdRelief
Smd Relief type.
typedef enum evxSmdCornerRelief | evxSmdCornerRelief
Smd Relief type of Corner Attributes.
typedef struct svxSmdAt | svxSmdAt
sheet metal attribute
typedef enum evxSmdCalCustom | evxSmdCalCustom
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom
typedef enum evxSmdReliefLengthType | evxSmdReliefLengthType
Smd Relief Length Type of Flange.
typedef struct svxSmdReliefData | svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.

Base Data

enum | evxExtFlangeType { VX_EXTFLANGE_1SIDE , VX_EXTFLANGE_2SIDES , VX_EXTFLANGE_SYMMETRICAL }
Smd extrude type. More...
enum evxSmdBendType {
VX_BEND_SIMPLE = 0 , VX_BEND_S_BEND = 1 , VX_BEND_CLOSED = 5 , VX_BEND_OPEN = 6 ,
VX_BEND_JOGGLE = 4 , VX_BEND_CURL = 2 , VX_BEND_Z_BEND = 7 , VX_BEND_CLOSED_LOOP = 8 ,
VX_BEND_OPEN_LOOP = 9 , VX_BEND_CENTERED_LOOP = 10 , VX_BEND_USER_DEFINED = 11
}
Smd Bend Type of Flange. More...
typedef enum evxExtFlangeType | evxExtFlangeType
Smd extrude type.
typedef struct svxSmdExtrudeTabData | svxSmdExtrudeTabData
template command Smd Extrude Tab data
typedef struct svxExtrudeFlangeData | svxExtrudeFlangeData
template command Smd Extrude Flange data
typedef enum evxSmdBendType | evxSmdBendType
Smd Bend Type of Flange.
typedef struct svxSmdFlangeData | svxSmdFlangeData
template command Smd Flange data

Flange Data

enum evxSmdHemBendType {
VX_SMD_HEM_BEND_CLOSED , VX_SMD_HEM_BEND_OPEN , VX_SMD_HEM_BEND_CLOSEDLOOP , VX_SMD_HEM_BEND_OPENLOOP ,
VX_SMD_HEM_BEND_CENTEREDLOOP , VX_SMD_HEM_BEND_SBEND , VX_SMD_HEM_BEND_CURL
}
Smd Bend Type of Hem Flange. More...
enum | evxSmdLftFlangeMethod { VX_SMD_GENERAL_LOFTING , VX_SMD_FLATTENABLE_LOFTING , VX_SMD_BENDING_LOFTING }
Lofted Flange method. More...
enum | evxSmdLftCutMethod { VX_SMD_LFG_MAX_ARC_HEIGHT , VX_SMD_LFG_NUMBER_BEND , VX_SMD_LFG_MAX_CHORD_LENGTH , VX_SMD_LFG_MAX_ARC_CHORD_ANGLE }
Lofted Flange Cutting Method. More...
enum evxSmdJogPosition {
VX_SMD_JOG_OUTER , VX_SMD_JOG_INNER , VX_SMD_JOG_MIDDLE , VX_SMD_JOG_MATERIAL_INSIDE ,
VX_SMD_JOG_MATERIAL_OUTSIDE
}
Smd Jog Parameters Position. More...
typedef struct svxSmdFullFlangeData | svxSmdFullFlangeData
template command Smd Full Flange data
typedef struct svxSmdFlangeProfData | svxSmdFlangeProfData
template command Smd Flange with Profile data
typedef struct svxSmdPartialFlangeData | svxSmdPartialFlangeData
template command Smd Partial Flange data
typedef enum evxSmdHemBendType | evxSmdHemBendType
Smd Bend Type of Hem Flange.
typedef struct svxSmdHemFlangeData | svxSmdHemFlangeData
template command Smd Hem Flange data
typedef enum evxSmdLftFlangeMethod | evxSmdLftFlangeMethod
Lofted Flange method.
typedef enum evxSmdLftCutMethod | evxSmdLftCutMethod
Lofted Flange Cutting Method.
typedef struct svxSmdLoftedFlangeData | svxSmdLoftedFlangeData
template command Smd Lofted Flange data
typedef struct svxSmdSweptFlangeData | svxSmdSweptFlangeData
template command Smd Swept Flange data
typedef enum evxSmdJogPosition | evxSmdJogPosition
Smd Jog Parameters Position.
typedef struct svxSmdFoldByLineData | svxSmdFoldByLineData
template command Smd Fold by Line data
typedef struct svxSmdJogData | svxSmdJogData
template command Smd Jog data

Editing Data

enum | evxSmdExtendFlangeMethod { VX_SMD_EXTEND_BY_VALUE , VX_SMD_EXTEND_THROUGH_UNTIL , VX_SMD_EXTEND_TO_SELECTED }
extend flange method More...
enum | evxSmdExtendSideMethod { VX_SMD_EXTEND_SIDE_NORMAL , VX_SMD_EXTEND_SIDE_ALONG }
extend flange side method More...
enum | evxSmdWebTaperType { VX_SMD_TAPER_WEB_NONE , VX_SMD_TAPER_WEB_FACE , VX_SMD_TAPER_WEB_FACE_CHAIN }
smd bend web taper type More...
enum | evxSmdTaperSideMethod { VX_SMD_TAPER_SIDES_BOTH , VX_SMD_TAPER_SIDES_SIDE1 , VX_SMD_TAPER_SIDES_SIDE2 , VX_SMD_TAPER_SIDES_SYMMETRY }
smd bend taper sides More...
enum | evxExtrudeType { VX_EXTRUDE_TYPE_ONESIDE = 0 , VX_EXTRUDE_TYPE_TWOSIDE = 1 , VX_EXTRUDE_TYPE_SYMMETRICAL }
extrude type More...
enum | evxNormCutTyp { VX_NORMCUT_BOTHSIDES = 0 , VX_NORMCUT_MIDDLE = 1 }
Normal Cut command. More...
typedef enum evxSmdExtendFlangeMethod | evxSmdExtendFlangeMethod
extend flange method
typedef enum evxSmdExtendSideMethod | evxSmdExtendSideMethod
extend flange side method
typedef struct svxSmdExtendFlangeData | svxSmdExtendFlangeData
template command Smd Extend Flange data
typedef enum evxSmdWebTaperType | evxSmdWebTaperType
smd bend web taper type
typedef struct svxSmdBendTaperDefData | svxSmdBendTaperDefData
smd bend taper definition side data
typedef enum evxSmdTaperSideMethod | evxSmdTaperSideMethod
smd bend taper sides
typedef struct svxSmdBendTaperData | svxSmdBendTaperData
template command Smd bend taper data
typedef enum evxExtrudeType | evxExtrudeType
extrude type
typedef enum evxNormCutTyp | evxNormCutTyp
Normal Cut command.
typedef struct svxNormalCutData | svxNormalCutData
template command Smd Normal Cut data

Corner Data

enum evxCornerReliefTyp {
VX_CORNER_CLOSED = 0 , VX_CORNER_CIRCL_CUTOUT , VX_CORNER_RECT_CUTOUT , VX_CORNER_U_CUTOUT ,
VX_CORNER_V_CUTOUT
}
corner relief type More...
enum | evxCornerOverlapTyp { VX_CORNER_UNDERLAP = 0 , VX_CORNER_OVERLAP , VX_CONER_NATURAL }
corner overlap type More...
typedef enum evxCornerReliefTyp | evxCornerReliefTyp
corner relief type
typedef enum evxCornerOverlapTyp | evxCornerOverlapTyp
corner overlap type
typedef struct svxCloseCornerData | svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default values)

Form Data

enum | evxPunchTyp { VX_PUNCH_SHAPE = 0 , VX_PUNCH_FILE = 1 }
Punch type. More...
enum | evxPunchLocType { VX_LOCATION_POINT = 0 , VX_LOCATION_CONSTRAINT = 1 }
location type of punch command More...
enum | evxDimplePostion { VX_MATERIAL_OUTSIDE = 0 , VX_MATERIAL_INSIDE , VX_BEND_OUTSIDE }
dimple position type More...
typedef enum evxPunchTyp | evxPunchTyp
Punch type.
typedef enum evxPunchLocType | evxPunchLocType
location type of punch command
typedef struct svxPunchCons | svxPunchCons
punch constraint
typedef struct svxPunchData | svxPunchData
Punch data.
typedef enum evxDimplePostion | evxDimplePostion
dimple position type
typedef struct svxDimpleData | svxDimpleData
dimple data
typedef struct svxLouverData | svxLouverData
template command Smd Louver data

Bend Data

enum | evxSmdChangeBendType { VX_SMD_CHANGE_BEND_DEFAULT , VX_SMD_CHANGE_BEND_FOLD_LENGTH , VX_SMD_CHANGE_BEND_UNFOLD_LENGTH }
change bend type More...
typedef struct svxFoldData | svxFoldData
template command Smd Fold data
typedef struct svxUnfoldData | svxUnfoldData
template command Smd Unfold data
typedef struct svxSmdFlattenData | svxSmdFlattenData
template command Smd flatten data
typedef struct svxSmdLinearUnfoldData | svxSmdLinearUnfoldData
template command Smd linear unfold data
typedef enum evxSmdChangeBendType | evxSmdChangeBendType
change bend type
typedef struct svxSmdChangeBendData | svxSmdChangeBendData
template command Smd change bend data

Convert Data

enum | evxSmdRipType { VX_SMD_RIP_BOTH_SIDES , VX_SMD_RIP_LEFT_SIDE , VX_SMD_RIP_RIGHT_SIDE }
smd rip type More...
typedef enum evxSmdRipType | evxSmdRipType
smd rip type
typedef struct svxSmdRipData | svxSmdRipData
template command Smd rip data
typedef struct svxSmdMarkBendData | svxSmdMarkBendData
template command Smd mark bend data
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_app.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_app.h File Reference
#include "zwapi_cmd_sk_app_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sketch App API It contains the interfaces of the third-party functions expected to be hung in the sketch environment. These interface need to be authorized to use.

Definition in file zwapi_cmd_sk_app.h.

Nesting

evxErrors | cvxSkNestingProfileDataInit (svxSkNestingProfileData *data)
evxErrors | cvxSkNestingBlankDataInit (svxSkNestingBlankData *data)
evxErrors | cvxSkNestingInit (svxSkNestingData *data)
evxErrors | cvxSkNesting (const svxSkNestingData *data)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_app_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_app_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the All Commands of Sketch functions.

Definition in file zwapi_cmd_sk_app_data.h.

Sketch App Data

typedef struct svxSkNestingProfileData | svxSkNestingProfileData
profile data of Sketch Nesting
typedef struct svxSkNestingBlankData | svxSkNestingBlankData
blank data of Sketch Nesting
typedef struct svxSkNestingData | svxSkNestingData
Nesting data of sketch.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_cmds.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_cmds.h File Reference
#include "zwapi_cmd_sk_cmds_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D All Commands of Sketch API

Definition in file zwapi_cmd_sk_cmds.h.

Drawing

evxErrors | cvxSkLine2pt (svxPoint2 *Start, svxPoint2 *End, int *idEnt)
evxErrors | cvxSkAddPolyline (int cntPnt, svxPoint2 *pnts, int addCns)
evxErrors | cvxSkAxis (const svxSkAxisData *Axis, int *idAxis)
evxErrors | cvxSkCir3pt (svxPoint2 *P1, svxPoint2 *P2, svxPoint2 *P3, int *idEnt)
evxErrors | cvxSkCirRad (svxPoint2 *Center, double Radius, int *idEnt)
evxErrors | cvxSkArc3pt (svxPoint2 *Start, svxPoint2 *End, svxPoint2 *Mid, int *idEnt)
evxErrors | cvxSkArcRad (svxPoint2 *Center, double Radius, double Start, double End, int *idEnt)
evxErrors | cvxSkEllipseInit (svxEllipse *data)
evxErrors | cvxSkEllipse (svxEllipse *ellipse, int *idEnt)
evxErrors | cvxSkPnt (svxPoint2 *Point, int *idEnt)
evxErrors | cvxSkPntsOnCrv (int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
evxErrors | cvxSkReadyTextInit (evxReadyTextMethods method, svxReadyText *data)
evxErrors | cvxSkReadyText (const svxReadyText *RdText, int *idRdText)
evxErrors | cvxEntTextNew (char *String, int Type, svxPoint2 Pnt[2], int *idEnt)
evxErrors | cvxSkNgonsInit (evxSkNgonsType type, svxSkNgons *data)
evxErrors | cvxSkNgons (const svxSkNgons *Spl, int *cnt, int **idEnts)

Curve

evxErrors | cvxSkCrvIntInit (svxCrvIntData *data)
evxErrors | cvxSkCrvIntScaleInit (int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)
evxErrors | cvxSkCrvInt (svxCrvIntData *Crv, int *idEnt)
evxErrors | cvxSkSplineInit (svxSplineData *data, int count)
evxErrors | cvxSkSpline (const svxSplineData *PntData, int *idEnt)
evxErrors | cvxSkConic3pt (const svxConic3ptData *Data, int *idEnt)
evxErrors | cvxSkConic3ptInit (svxConic3ptData *Data)

Edit Curve

evxErrors | cvxSkFilletInit (svxSkFilletData *data)
evxErrors | cvxSkFillet (const svxSkFilletData *filletData, int *idFillet)
evxErrors | cvxSkChamferInit (svxSkChamferData *data)
evxErrors | cvxSkChamfer (const svxSkChamferData *chmData, int *idChamfer)
evxErrors | cvxSkPowerTrim (const svxSkPowerTrim *pwTrim)
evxErrors | cvxSkOneTouchTrim (const svxPntOnEnt *pnt)
evxErrors | cvxSkTrimExtInit (svxSkTrimExt *trimExt)
evxErrors | cvxSkTrimExt (const svxSkTrimExt *trimExt)
evxErrors | cvxSkTrimSplitInit (svxSkTrimSplit *trimSpl)
evxErrors | cvxSkTrimSplitCrv (const svxSkTrimSplit *trimSpl)
evxErrors | cvxSkTrimSplitPnt (const svxSkTrimSplitPnt *trimSpl)
evxErrors | cvxSkTrimSplitCorInit (svxSkTrimSplitCor *trimSpl)
evxErrors | cvxSkTrimSplitCor (const svxSkTrimSplitCor *trimSpl)
evxErrors | cvxSkDelBowties (const int numCrv, const int *idCrv)
evxErrors | cvxSkSplitIsectInit (svxSkSplitIsect *Spl)
evxErrors | cvxSkSplitIsect (const svxSkSplitIsect *Spl)

Constraint

evxErrors | cvxSkAutoCons (svxConsGeom *BasePnt, int Count, int *idEnts)
evxErrors | cvxSkAddGeomCons (evxGeomConsType type, int subType, int nGeoms, svxConsGeom *geoms, int *Count, int **idCons)
evxErrors | cvxSkAutoAddCoinCons (int idSketch)
evxErrors | cvxSkAutoAddCoinConsSkipRefGeom (int idSketch, int skipFlag, int solveFlag)

Dimension

evxErrors | cvxSkAddConsDim (evxConsDimType type, svxConsDim *pData)
evxErrors | cvxSkAddPerimeterDim (svxPerimeterDimData *data, int *idDim)

Reference

evxErrors | cvxSkReferenceInit (svxSkRefData *data)
evxErrors | cvxSkReference (const svxSkRefData *data, int *count, int **idRefEnts)

Basic Editing

evxErrors | cvxSkMoveInit (evxMoveType2D type, svxMoveData2D *data)
evxErrors | cvxSkMove (const svxMoveData2D *data)
evxErrors | cvxSkRotate (const svxRotateData2D *data, int *cnt, int **idEnts)
evxErrors | cvxSkRotateInit (svxRotateData2D *data)
evxErrors | cvxSkMirr (const svxMirrData2D *data, int *cnt, int **idEnts)
evxErrors | cvxSkMirrInit (svxMirrData2D *data)
evxErrors | cvxSkScale (int Count, int *idEnts, double X_scale, double Y_scale, svxPoint2 *Pnt)
evxErrors | cvxSkPtnDataInit (evxSkPatternType type, svxSkPtnData *data)
evxErrors | cvxSkPattern (const svxSkPtnData *Pattern, int *cnt, int **idEnts)
evxErrors | cvxSkCopyInit (evxSkCopyType type, svxSkCopy *data)
evxErrors | cvxSkCopy (const svxSkCopy *Spl, int *cnt, int **idEnts)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_cmds_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_cmds_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the All Commands of Sketch functions.

Definition in file zwapi_cmd_sk_cmds_data.h.

Drawing Data

enum evxSkAxisMethods {
VX_SK_AXIS_TWO_PNT = 0 , VX_SK_AXIS_PARAPT = 1 , VX_SK_AXIS_PERPENDICULAR = 2 , VX_SK_AXIS_ANGLE = 3 ,
VX_SK_AXIS_PARAOFF = 4 , VX_SK_AXIS_HORIZ = 5 , VX_SK_AXIS_VERT = 6
}
Create Sketch Axis Methods. More...
enum | evxReadyTextMethods { VX_ON_CRV = 1 , VX_BOX = 2 }
Create Sketch ready text Methods. More...
enum evxSkNgonsType {
VX_SK_NGONS_IN_R , VX_SK_NGONS_CIR_R , VX_SK_NGONS_SIDE_LEN , VX_SK_NGONS_IN_BOUND ,
VX_SK_NGONS_CIR_BOUND , VX_SK_NGONS_SIDE_BOUND
}
sketch polygon method More...
enum | evxSkRefMethod { VX_SK_REF_PROJECTION , VX_SK_REF_INTERSECTION }
sketch reference geometry method More...
enum | evxSkRefOption { VX_SK_REF_SINGLE , VX_SK_REF_CHAIN , VX_SK_REF_LOOPS , VX_SK_REF_POINT }
sketch reference type More...
enum | evxSkChainOption { VX_SK_CHAIN_PICK , VX_SK_CHAIN_BETWEEN_PICKS }
sketch reference chain option More...
enum evxSkLoopOption {
VX_SK_LOOP_ALL , VX_SK_LOOP_BOUNDARY , VX_SK_LOOP_SHARED , VX_SK_LOOP_INNER ,
VX_SK_LOOP_OUTER , VX_SK_LOOP_OPEN_BOUNDARY , VX_SK_LOOP_NON_SHARED_BOUNDARY , VX_SK_LOOP_SILHOUETTE
}
sketch reference loop option More...
typedef enum evxSkAxisMethods | evxSkAxisMethods
Create Sketch Axis Methods.
typedef struct svxSkAxisData | svxSkAxisData
data of sketch Axis
typedef struct svxEllipse | svxEllipse
data of ellipse
typedef enum evxReadyTextMethods | evxReadyTextMethods
Create Sketch ready text Methods.
typedef struct svxReadyText | svxReadyText
data of ready sketch text
typedef enum evxSkNgonsType | evxSkNgonsType
sketch polygon method
typedef struct svxSkNgons | svxSkNgons
sketch polygon data
typedef enum evxSkRefMethod | evxSkRefMethod
sketch reference geometry method
typedef enum evxSkRefOption | evxSkRefOption
sketch reference type
typedef enum evxSkChainOption | evxSkChainOption
sketch reference chain option
typedef enum evxSkLoopOption | evxSkLoopOption
sketch reference loop option
typedef struct svxSkRefData | svxSkRefData
sketch reference geometry data

Edit Curve Data

enum | evxConic3PntType { VX_CONIC_SHOULDER = 0 , VX_CONIC_TANGENT = 1 }
3 Point Conic type More...
enum | evxSkChamferOpt { VX_CHMOPT_SETBACK = 0 , VX_CHMOPT_TWOSETBACK , VX_CHMOPT_SETBACKANDDIS }
option of chamfer in sheeting or sketch More...
enum | evxSkChamferTrimOpt { VX_CHMTRIM_NO = 0 , VX_CHMTRIM_BOTH , VX_CHMTRIM_FIRST , VX_CHMTRIM_SECOND }
option of trim in chamfer/fillet of sheeting or sketch More...
enum | evxSkChamferExtenOpt { VX_CHMEXT_LINEAR = 1 , VX_CHMEXT_CIRCULAR , VX_CHMEXT_REFLECT }
control the path of extended curves in chamfer/fillet of sheeting or sketch More...
enum | evxTrimExtension { VX_EXT_LINEAR = 1 , VX_EXT_ARC , VX_EXT_REFLECT , VX_EXT_CRV_DIM }
trim/extend extension method More...
enum | evxTrimSplit { VX_SPLIT_KEEP , VX_SPLIT_DELETE , VX_SPLIT_BREAK }
trim/extend extension method More...
enum | evxTrimSplitCor { VX_SPLIT_COR_LINEAR , VX_SPLIT_COR_ARC , VX_SPLIT_COR_REFLECT }
trim/split to corner option method More...
typedef enum evxConic3PntType | evxConic3PntType
3 Point Conic type
typedef struct svxConic3ptData | svxConic3ptData
3 Point Conic command data
typedef enum evxSkChamferOpt | evxSkChamferOpt
option of chamfer in sheeting or sketch
typedef enum evxSkChamferTrimOpt | evxSkChamferTrimOpt
option of trim in chamfer/fillet of sheeting or sketch
typedef enum evxSkChamferExtenOpt | evxSkChamferExtenOpt
control the path of extended curves in chamfer/fillet of sheeting or sketch
typedef struct svxSkFilletData | svxSkFilletData
information of fillet in sheeting or sketch
typedef struct svxSkChamferData | svxSkChamferData
information of chamfer in sheeting or sketch
typedef enum evxTrimExtension | evxTrimExtension
trim/extend extension method
typedef enum evxTrimSplit | evxTrimSplit
trim/extend extension method
typedef enum evxTrimSplitCor | evxTrimSplitCor
trim/split to corner option method
typedef struct svxSkPowerTrim | svxSkPowerTrim
sketch power trim data
typedef struct svxSkTrimExt | svxSkTrimExt
sketch trim or extend data
typedef struct svxSkTrimSplit | svxSkTrimSplit
sketch trim or split data
typedef struct svxSkTrimSplitPnt | svxSkTrimSplitPnt
sketch trim or split at point data
typedef struct svxSkTrimSplitCor | svxSkTrimSplitCor
sketch trim or split to corner data
typedef struct svxSkSplitIsect | svxSkSplitIsect
sketch split at intersection data

Constraint Data

enum evxGeomConsSubType {
VX_SK_CONS_XY_COORDS_CONS = 0 , VX_SK_CONS_X_COORD_CONS , VX_SK_CONS_Y_COORD_CONS , VX_SK_PNT_TO_ARC_MIDPNT_CONS ,
VX_SK_PNTS_SYMMETRY_CONS
}
sub type of sketch geometry constraint More...
enum evxGeomConsType {
VX_SK_CONS_UNKNOWN , VX_SK_CONS_FIX , VX_SK_CONS_ALI_Y , VX_SK_CONS_ALI_X ,
VX_SK_CONS_MID , VX_SK_CONS_ON_CRV , VX_SK_CONS_ISECT , VX_SK_CONS_COIN ,
VX_SK_CONS_HOR , VX_SK_CONS_VER , VX_SK_CONS_SYM , VX_SK_CONS_PERP ,
VX_SK_CONS_PARA , VX_SK_CONS_COLINLN , VX_SK_CONS_TANG , VX_SK_CONS_EQL_LEN ,
VX_SK_CONS_EQL_CURVATURE , VX_SK_CONS_CONC , VX_SK_CONS_EQL_RAD , VX_SK_CONS_SYM_DST ,
VX_SK_CONS_SYM_ANG , VX_SK_CONS_PTN , VX_SK_CONS_OFFSET
}
type of sketch geometry constraint More...
typedef struct svxConsGeom | svxConsGeom
data of sketch geometry constraint object
typedef enum evxGeomConsSubType | evxGeomConsSubType
sub type of sketch geometry constraint
typedef enum evxGeomConsType | evxGeomConsType
type of sketch geometry constraint

Dimension Data

enum evxConsDimType {
VX_SK_CONSDIM_UNKNOW = -1 , VX_SK_CONSDIM_LINEAR , VX_SK_CONSDIM_LINEAR_OFFSET , VX_SK_CONSDIM_ANGULAR ,
VX_SK_CONSDIM_RADIAL , VX_SK_CONSDIM_ARC_LENGTH , VX_SK_CONSDIM_SYMMETRY , VX_SK_CONSDIM_PERIMETER
}
type of sketch constraint dimension More...
typedef enum evxConsDimType | evxConsDimType
type of sketch constraint dimension
typedef struct svxConsDim | svxConsDim
data of constraint dimension
typedef struct svxPerimeterDimData | svxPerimeterDimData
data of perimeter dimension

Basic Editing Data

enum | evxMoveType2D { VX_PNT_TO_PNT_2D , VX_ALONG_DIR_2D }
Move and Copy Methods(2D) More...
enum | evxDrawingMoveDirType { VX_DRAWING_TWOPOINTS , VX_DRAWING_HORIZONTAL , VX_DRAWING_VERTICAL }
Sketch/Drawing move direction type. More...
enum | evxRotateType { VX_ROTATE_ANGLE = 0 , VX_ROTATE_POINTS }
rotate type More...
enum | evxRotateSetting { VX_ROTATE_MOVE = 1 , VX_ROTATE_COPY }
rotate setting More...
enum | evxSkPatternType { VX_SKPATTERN_LINEAR , VX_SKPATTERN_CIRCULAR , VX_SKPATTERN_AT_CURVES }
sketch pattern method More...
enum | evxSkSpacingType { VX_NUMBER_PITCH , VX_NUMBER_SPAN , VX_PITCH_SPAN }
sketch pattern spacing method More...
enum | evxSkCopyType { VX_SK_COPY_PNT , VX_SK_COPY_DIR }
sketch copy method More...
enum | evxSkCopyDir { VX_SK_COPY_DIR_TWO , VX_SK_COPY_DIR_HORIZONTAL , VX_SK_COPY_DIR_VERTICAL }
sketch copy from point to point direction method More...
typedef enum evxMoveType2D | evxMoveType2D
Move and Copy Methods(2D)
typedef struct svxAlongDir2D | svxAlongDir2D
copy/move entities along a direction (2D)
typedef enum evxDrawingMoveDirType | evxDrawingMoveDirType
Sketch/Drawing move direction type.
typedef struct svxMovePntToPnt2D | svxMovePntToPnt2D
copy/move entities form point to point (2D)
typedef struct svxMoveData2D | svxMoveData2D
template command Move data(2D)
typedef enum evxRotateType | evxRotateType
rotate type
typedef enum evxRotateSetting | evxRotateSetting
rotate setting
typedef struct svxRotateData2D | svxRotateData2D
template command Rotate data
typedef struct svxMirrData2D | svxMirrData2D
template command Mirror data(2D)
typedef enum evxSkPatternType | evxSkPatternType
sketch pattern method
typedef enum evxSkSpacingType | evxSkSpacingType
sketch pattern spacing method
typedef struct svxSkPtnData | svxSkPtnData
sketch pattern data
typedef enum evxSkCopyType | evxSkCopyType
sketch copy method
typedef enum evxSkCopyDir | evxSkCopyDir
sketch copy from point to point direction method
typedef struct svxSkCopy | svxSkCopy
sketch copy data
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_create.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_create.h File Reference
#include "zwapi_cmd_sk_create_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sketch Creation Commands API

Definition in file zwapi_cmd_sk_create.h.

Sketch Creation

evxErrors | cvxPartSkIns (const vxLongPath File, const vxRootName Name, svxMatrix *Plane, int *idSketch)
evxErrors | cvxPartSkIns2 (const vxLongPath File, const vxRootName Name, int idPlane, int iAsso, int *idSketch)
evxErrors | cvxPartSkNew (svxMatrix *Plane, int *idSketch)
evxErrors | cvxPartSkPlane (svxSketchData *SkData, int *idSketch)
evxErrors | cvxHatchPtnDataInit (svxHatchPtnData *data)
evxErrors | cvxPartCosSkPlane (const svxSketchData *SkData, int isAddHatPtn, const svxHatchPtnData *PatData, int *idSketch)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_create_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_sk_create_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Sketch Creation Command functions.

Definition in file zwapi_cmd_sk_create_data.h.

Sketch Creation Data

enum evxHatchPtnType {
VX_HATCH_PATTERN_ANSI31 , VX_HATCH_PATTERN_ANSI32 , VX_HATCH_PATTERN_ANSI33 , VX_HATCH_PATTERN_ANSI34 ,
VX_HATCH_PATTERN_ANSI35 , VX_HATCH_PATTERN_ANSI36 , VX_HATCH_PATTERN_ANSI37 , VX_HATCH_PATTERN_ANSI38 ,
VX_HATCH_PATTERN_SHADOW_PLATE , VX_HATCH_PATTERN_BRICK , VX_HATCH_PATTERN_CORK , VX_HATCH_PATTERN_CROSS ,
VX_HATCH_PATTERN_DASH , VX_HATCH_PATTERN_LIMESTONE , VX_HATCH_PATTERN_DOTS , VX_HATCH_PATTERN_EARTH ,
VX_HATCH_PATTERN_EXPANSION , VX_HATCH_PATTERN_GRASS , VX_HATCH_PATTERN_GRATE , VX_HATCH_PATTERN_HEXAGON ,
VX_HATCH_PATTERN_HONEYCOMB , VX_HATCH_PATTERN_SQUARES , VX_HATCH_PATTERN_MOONYANG , VX_HATCH_PATTERN_BOX ,
VX_HATCH_PATTERN_BRASS , VX_HATCH_PATTERN_BRSTONE , VX_HATCH_PATTERN_CLAY , VX_HATCH_PATTERN_ESCHER ,
VX_HATCH_PATTERN_GRAVEL , VX_HATCH_PATTERN_HOUND , VX_HATCH_PATTERN_INSUL , VX_HATCH_PATTERN_ACAD_ISO02W100 ,
VX_HATCH_PATTERN_ACAD_ISO03W100 , VX_HATCH_PATTERN_ACAD_ISO04W100 , VX_HATCH_PATTERN_ACAD_ISO05W100 , VX_HATCH_PATTERN_ACAD_ISO06W100 ,
VX_HATCH_PATTERN_ACAD_ISO07W100 , VX_HATCH_PATTERN_ACAD_ISO08W100 , VX_HATCH_PATTERN_ACAD_ISO09W100 , VX_HATCH_PATTERN_ACAD_ISO10W100 ,
VX_HATCH_PATTERN_ACAD_ISO11W100 , VX_HATCH_PATTERN_ACAD_ISO12W100 , VX_HATCH_PATTERN_ACAD_ISO13W100 , VX_HATCH_PATTERN_ACAD_ISO14W100 ,
VX_HATCH_PATTERN_ACAD_ISO15W100 , VX_HATCH_PATTERN_JIS_LC_20 , VX_HATCH_PATTERN_JIS_LC_20A , VX_HATCH_PATTERN_JIS_LC_8A ,
VX_HATCH_PATTERN_JIS_LC_8 , VX_HATCH_PATTERN_JIS_RC_10 , VX_HATCH_PATTERN_JIS_RC_15 , VX_HATCH_PATTERN_JIS_RC_18 ,
VX_HATCH_PATTERN_JIS_RC_30 , VX_HATCH_PATTERN_JIS_STN_1E , VX_HATCH_PATTERN_JIS_STN_2_5 , VX_HATCH_PATTERN_JIS_WOOD ,
VX_HATCH_PATTERN_LINE , VX_HATCH_PATTERN_MUDST , VX_HATCH_PATTERN_NET , VX_HATCH_PATTERN_NET3 ,
VX_HATCH_PATTERN_PLAST , VX_HATCH_PATTERN_PLASTI , VX_HATCH_PATTERN_SACNCR , VX_HATCH_PATTERN_STARS ,
VX_HATCH_PATTERN_STEEL , VX_HATCH_PATTERN_SWAMP , VX_HATCH_PATTERN_TRANS , VX_HATCH_PATTERN_TRIANG ,
VX_HATCH_PATTERN_ZIGZAG , VX_HATCH_PATTERN_SOLID
}
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sketch or cross-hatch command to see. More...
typedef struct svxSketchData | svxSketchData
sketch definition data
typedef enum evxHatchPtnType | evxHatchPtnType
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sketch or cross-hatch command to see.
typedef struct svxHatchPtnData | svxHatchPtnData
cosmetic sketch hatch pattern definition data
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_subcmd.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_subcmd.h File Reference
#include "zwapi_cmd_subcmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Second Menu Commands API

Definition in file zwapi_cmd_subcmd.h.

Point

evxErrors | cvxPartPntByOffsetInit (svxPntByOffset *data, int useCirPnt)
evxErrors | cvxPartPntBy2LinesInit (svxPntBy2Lines *data, int useCirPnt)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_subcmd_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_subcmd_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Generic Data Types and Structures of Second Menu Command functions.

Definition in file zwapi_cmd_subcmd_data.h.

Sub-command(Point) Data

enum evxDistanceMethod {
VX_INPU_VALUE = 0 , VX_BY_THROUGH_ALL = 1 , VX_TO_POINT = 2 , VX_TO_FACES = 3 ,
VX_TO_EXTEND_FACE = 4 , VX_TO_FACE = 5
}
the distance method of the distance field, it can set the value by the specified sub-command More...
typedef struct svxPntByOffset | svxPntByOffset
the data to get the point by Offset command
typedef struct svxPntBy2Lines | svxPntBy2Lines
the data to get the point by From 2 Lines command
typedef enum evxDistanceMethod | evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
typedef struct svxLoftBndCons | svxLoftBndCons
loft boundary constraints
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_udf.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_udf.h File Reference
#include "zwapi_cmd_udf_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D UDF API

Definition in file zwapi_cmd_udf.h.

UDF Creation

evxErrors | cvxPartUDFInit (const vxLongPath udfPath)
evxErrors | cvxPartUDFInqFlds (int *cnt, svxUDFParam **fldParams)
void | cvxPartUDFTerm ()
evxErrors | cvxPartUDFExplode (int idFtr)

UDF Query

evxErrors | cvxPartUDFInqPath (int idFtr, vxPath file)
evxErrors | cvxPartUDFInqLongPath (int idFtr, char *file, int sizefile)
evxErrors | cvxPartUDFInqSubFtrs (int idFtr, int *count, int **ftrList)
evxErrors | cvxPartFtrIsUDF (int idFtr, int *isUDF)
evxErrors | cvxPartUDFReplace (int idFtr, const vxLongPath file)

UDF Path

evxErrors | cvxPartUDFWizardPathSet (const vxLongPath path)
evxErrors | cvxPartUDFInsPathSet (const vxLongPath path)
evxErrors | cvxPartUDFWizardPathGet (vxPath Dir)
evxErrors | cvxPartUDFWizardPathGetByLongPath (char *Dir, int sizeDir)
evxErrors | cvxPartUDFInsPathGet (vxPath Dir)
evxErrors | cvxPartUDFInsPathGetByLongPath (char *Dir, int sizeDir)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_udf_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_udf_data.h File Reference
#include "zwapi_cmd_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the UDF functions.

Definition in file zwapi_cmd_udf_data.h.

UDF Creation Data

typedef struct svxUDFParam svxUDFParam
field parameters of UDF command
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_wireframe.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_wireframe.h File Reference
#include "zwapi_cmd_wireframe_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Wireframe Commands API

Definition in file zwapi_cmd_wireframe.h.

Drawing

evxErrors | cvxPartPnt (svxPoint *Point, int *idEnt)
evxErrors | cvxPartPntNew (int Count, const svxPntOnEntPath *PntData, int idAlignPln, int PrjToPln, int *idPntFtr)
evxErrors | cvxPartPnts (int Count, svxPoint *Points)
evxErrors | cvxPartPntsOnCrv (int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
evxErrors | cvxPartLine2pt (svxPoint *Start, svxPoint *End, int *idEnt)
evxErrors | cvxPartLineInit (svxLineData *lineData)
evxErrors | cvxPartLine (const svxLineData *lineData, int *idLine)
evxErrors | cvxPartPolylineInit (svxPolylineData *data)
evxErrors | cvxPartPolyLine (const svxPolylineData *polylinedata, int *Cnt, int **idEnt)
evxErrors | cvxPartArc3pt (svxPoint *Start, svxPoint *End, svxPoint *Mid, int *idEnt)
evxErrors | cvxPartArcRad (svxMatrix *Plane, double Radius, double Start, double End, int *idEnt)
evxErrors | cvxPartArcInit (svxArcData *arcData)
evxErrors | cvxPartArc (const svxArcData *arcData, int *idArc)
evxErrors | cvxPartCircleInit (svxCircleData *circleData)
evxErrors | cvxPartCircle (const svxCircleData *circleData, int *idCircle)
evxErrors | cvxPartRectangleInit (svxRectangleData *data)
evxErrors | cvxPartRectangle (svxRectangleData *rectData, int *iCnt, int **idEnt)
evxErrors | cvxPartCir3pt (svxPoint *P1, svxPoint *P2, svxPoint *P3, int *idEnt)
evxErrors | cvxPartCirRad (svxMatrix *Plane, double Radius, int *idEnt)
evxErrors | cvxPartEllipseInit (svxRectangleData *data)
evxErrors | cvxPartEllipse (svxRectangleData *ellipseData, int *idEnt)

Curve

evxErrors | cvxPartCrvIntInit (svxCrvIntData *data)
evxErrors | cvxPartCrvIntScaleInit (int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)
evxErrors | cvxPartCrvInt (svxCrvIntData *Crv, int *idEnt)
evxErrors | cvxPartSplineInit (svxSplineData *data, int count)
evxErrors | cvxSplinePntInit (svxSplinePnt *data)
evxErrors | cvxPartSpline (const svxSplineData *PntData, int *idEnt)
evxErrors | cvxPartCrvProjToFaceInit (svxCrvProjToFace *data)
evxErrors | cvxPartCrvProjToFace (const svxCrvProjToFace *data, int *cntEnts, int **pEnts)
evxErrors | cvxPartInterXCurveInit (svxInterCrvData *data)
evxErrors | cvxPartInterXCurve (const svxInterCrvData *pSurf, int *idFtr)
evxErrors | cvxPartCrvOnFaceThruPtsInit (svxCrvOnFaceThuPts *data)
evxErrors | cvxPartCrvOnFaceThruPts (const svxCrvOnFaceThuPts *data, int *idEnt)
evxErrors | cvxPartIsoCurveOnFaceInit (svxIsoCrvOnFaceData *data, evxCrvIsoType crvIsoType)
evxErrors | cvxPartIsoCurveOnFace (const svxIsoCrvOnFaceData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartIsoclineCurveInit (svxIsoclineCrvData *data, evxIsoclineCrvType type)
evxErrors | cvxPartIsoclineCurve (const svxIsoclineCrvData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartFaceCurve (const svxFaceCrvData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartCombinedProj (const svxCrvCombinedProjData *data, int *cntEnts, int **idEnts)
evxErrors | cvxPartExtractCenterlines (int cntFaces, int *idFaces, int extractAxis, int *cntEnts, int **idEnts)
evxErrors | cvxPartBlendCrvsConsInit (svxCrvBlendCons *consData, evxCrvBlendObjType objType)
evxErrors | cvxPartBlendCrvsInit (svxCrvBlendData *data)
evxErrors | cvxPartBlendCrvs (const svxCrvBlendData *data, int *idEnt)
evxErrors | cvxPartCurveOffset (int idCurve, double Dis, int *idOut)
evxErrors | cvxPartSpiralCurve (const svxSpiralCrvData *data, int *idEnt)
evxErrors | cvxPartCrvList (int Count, int *Curves, int *idEnt)
evxErrors | cvxPartCurve (svxCurve *Crv, int *idEnt)
evxErrors | cvxPartCurveSilh (int idCurve, svxPoint *dir, int *iCnt, int **idList)
evxErrors | cvxPartFittingCrv (int iCnt, svxPoint *pnts, double tol, double smth, int *idEnt)

Edit Curve

evxErrors | cvxPartCrvFilletInit (svxCrvFilletData *data)
evxErrors | cvxPartCrvFillet (const svxCrvFilletData *data, int *idFillet)
evxErrors | cvxPartCrvFilletChainInit (svxCrvFilletChainData *data)
evxErrors | cvxPartCrvFilletChain (const svxCrvFilletChainData *data, int *idFilletChain)
evxErrors | cvxPartCrvChamferInit (svxCrvChamferData *data)
evxErrors | cvxPartCrvChamfer (const svxCrvChamferData *data, int *idChamfer)
evxErrors | cvxPartCrvChamferChainInit (svxCrvChamferChainData *data)
evxErrors | cvxPartCrvChamferChain (const svxCrvChamferChainData *data, int *idChamfer)
evxErrors | cvxPartCrvTrimToFaces (const svxCrvTrimToFacesData *data, int *idTrim)
evxErrors | cvxPartCrvSplitAtPnts (int idCurve, int CountPnts, svxPoint *Points, int *CountCrvs, int **NewCrvs)
evxErrors | cvxPartInqReversedCurve (int idEnt, svxCurve *data)
evxErrors | cvxPartCrvTrimWithCrv (const svxTrimWithCrvData *data, int *CountCrvs, int **NewCrvs)
evxErrors | cvxPartConcentricArc (int refArc, double radius, int *idEnt)
evxErrors | cvxPartCrvConvertToArcsInit (svxCrvConvertTocData *data)
evxErrors | cvxPartCrvConvertToArcs (const svxCrvConvertTocData *data, int *cntArcs, int **idArcs)
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_wireframe_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_cmd_wireframe_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the Wireframe Command functions.

Definition in file zwapi_cmd_wireframe_data.h.

Wireframe Feature Data

enum evxLineType {
VX_LINE_2PT = 0 , VX_LINE_ALONG_DIR = 1 , VX_LINE_PARALLEL = 2 , VX_LINE_PERP = 3 ,
VX_LINE_ANGLE = 4 , VX_LINE_MIDDDLE = 5
}
3D line type More...
enum | evxArcType { VX_ARC_THROUGH = 0 , VX_ARC_RADIUS = 1 , VX_ARC_CENTER = 2 , VX_ARC_ANGLE = 3 }
3D arc type More...
enum evxCircleType {
VX_CIRCLE_BOUNDARY = 1 , VX_CIRCLE_RADIUS = 2 , VX_CIRCLE_THROUGH = 0 , VX_CIRCLE_2PT_RADIUS = 3 ,
VX_CIRCLE_2POINT = 4
}
3D circle type More...
enum | evxRectangleType { VX_RECT_2PT = 0 , VX_RECT_WIDTH_HEIGHT = 1 , VX_RECT_3PT = 2 }
3D ellipse & rectangle type More...
typedef enum evxLineType | evxLineType
3D line type
typedef struct svxLineData | svxLineData
3D line data
typedef enum evxArcType | evxArcType
3D arc type
typedef struct svxArcData | svxArcData
3D arc data
typedef enum evxCircleType | evxCircleType
3D circle type
typedef struct svxCircleData | svxCircleData
3D circle data
typedef struct svxPolylineData | svxPolylineData
3D polyline data
typedef enum evxRectangleType | evxRectangleType
3D ellipse & rectangle type
typedef struct svxRectangleData | svxRectangleData
3D ellipse & rectangle data

Curve Data

enum | evxCrvIsoType { VX_CRV_ISO_AT_POINT = 0 , VX_CRV_ISO_AT_UV = 1 , VX_CRV_ISO_MULTIPLE = 2 }
iso-curve type More...
enum | evxCrvIsoUVType { VX_CRV_ISO_UV_U = 0 , VX_CRV_ISO_UV_V = 1 , VX_CRV_ISO_UV_BOTH = 2 }
iso-curve U or V settings More...
enum | evxIsoclineCrvType { VX_CRV_ISOCLINE_SINGLE = 0 , VX_CRV_ISOCLINE_MULTIPLE = 1 }
create isocline curve with a single angle/multiple angles More...
enum | evxCrvBlendTrimType { VX_CURVE_BLEND_NO_TRIM = 0 , VX_CURVE_BLEND_TRIM_BOTH = 1 , VX_CURVE_BLEND_TRIM_FIRST = 2 , VX_CURVE_BLEND_TRIM_SECOND = 3 }
trim (or extend) curves type of curve blend More...
enum | evxCrvBlendPosType { VX_CURVE_BLEND_POS_ARC_LENGTH = 0 , VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH = 1 , VX_CURVE_BLEND_POS_THROUGH_POINT = 2 }
blend location type for curve to blend More...
enum | evxCrvBlendDirType { VX_CURVE_BLEND_DIR_SECTIONAL = 0 , VX_CURVE_BLEND_DIR_ISO_U = 1 , VX_CURVE_BLEND_DIR_ISO_V = 2 }
blend location type for face to blend More...
enum | evxCrvBlendObjType { VX_CURVE_BLEND_CURVE = 0 , VX_CURVE_BLEND_FACE = 1 }
select a curve or face as object to start/end blended More...
typedef struct svxCrvProjToFace | svxCrvProjToFace
project to face data
typedef struct svxInterCrvData | svxInterCrvData
inter curve
typedef struct svxCrvOnFaceThuPtsCons | svxCrvOnFaceThuPtsCons
curve on face through points constraint
typedef struct svxCrvOnFaceThuPts | svxCrvOnFaceThuPts
curve on face through points data
typedef enum evxCrvIsoType | evxCrvIsoType
iso-curve type
typedef enum evxCrvIsoUVType | evxCrvIsoUVType
iso-curve U or V settings
typedef struct svxIsoCrvOnFaceData | svxIsoCrvOnFaceData
iso-curve on face data
typedef enum evxIsoclineCrvType | evxIsoclineCrvType
create isocline curve with a single angle/multiple angles
typedef struct svxIsoclineCrvData | svxIsoclineCrvData
isocline curve data
typedef struct svxFaceCrvData | svxFaceCrvData
face curve data
typedef struct svxCrvCombinedProjData | svxCrvCombinedProjData
combined projection data
typedef enum evxCrvBlendTrimType | evxCrvBlendTrimType
trim (or extend) curves type of curve blend
typedef enum evxCrvBlendPosType | evxCrvBlendPosType
blend location type for curve to blend
typedef enum evxCrvBlendDirType | evxCrvBlendDirType
blend location type for face to blend
typedef struct svxCrvBlendCons | svxCrvBlendCons
curve blend constraints
typedef enum evxCrvBlendObjType | evxCrvBlendObjType
select a curve or face as object to start/end blended
typedef struct svxCrvBlendData | svxCrvBlendData
curve blend data
typedef struct svxSpiralCrvData | svxSpiralCrvData
spiral curve data

Edit Curve Data

enum | evxCrvTrimType { VX_CRV_TRIM_NONE = 0 , VX_CRV_TRIM_BOTH = 1 , VX_CRV_TRIM_FIRST = 2 , VX_CRV_TRIM_SECOND = 3 }
curve trim type More...
enum | evxCrvFilletMethods { VX_CRV_FILLET_RADIUS = 0 , VX_CRV_FILLET_BOUNDARY = 1 }
curve fillet method More...
enum | evxCrvChamferMethods { VX_CRV_CHAMFER_SETBACK = 0 , VX_CRV_CHAMFER_TWO_SETBACKS = 1 , VX_CRV_CHAMFER_SETBACK_AND_ANGLE = 2 }
curve chamfer method More...
enum | evxTrimWithCrvType { VX_TRIM_WITH_CRV_KEEP = 0 , VX_TRIM_WITH_CRV_DELETE = 1 , VX_TRIM_WITH_CRV_SPLIT = 2 }
trim with curve mode More...
typedef enum evxCrvTrimType | evxCrvTrimType
curve trim type
typedef enum evxCrvFilletMethods | evxCrvFilletMethods
curve fillet method
typedef struct svxCrvFilletData | svxCrvFilletData
curve fillet data
typedef struct svxCrvFilletChainData | svxCrvFilletChainData
curve fillet chain data
typedef enum evxCrvChamferMethods | evxCrvChamferMethods
curve chamfer method
typedef struct svxCrvChamferData | svxCrvChamferData
curve chamfer data
typedef struct svxCrvChamferChainData | svxCrvChamferChainData
chamfer chain data
typedef enum evxTrimWithCrvType | evxTrimWithCrvType
trim with curve mode
typedef struct svxTrimWithCrvData | svxTrimWithCrvData
trim with curve data
typedef struct svxCrvTrimToFacesData | svxCrvTrimToFacesData
trim to faces data
typedef struct svxCrvConvertTocData | svxCrvConvertTocData
create arc and line segments from existing curves data
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_config.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_config.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Global Config API, the input "Name" of the following functions defined in "zw3d installation dir\\supp\\config.xml".

Definition in file zwapi_config.h.

Config Get

void | cvxConfigGetColor (const char *Name, evxColor *Color)
evxErrors | cvxConfigGetInteger (const char *Name, int *Value)
evxErrors | cvxConfigGetNumber (const char *Name, double *Value)
int | cvxConfigGetOption (const char *Name, const char *Options)
evxErrors | cvxConfigGetRgb (const char *Name, svxColor *Rgb)
evxErrors | cvxConfigGetString (const char *Name, char *Str, int nBytes)
evxErrors | cvxConfigGetYesNo (const char *Name, int *YesNo)
evxErrors | cvxConfigPathGet (char *path, int sizepath)

Config Set

evxErrors | cvxConfigSetColor (const char *Name, evxColor Color)
evxErrors | cvxConfigSetInteger (const char *Name, int Value)
evxErrors | cvxConfigSetNumber (const char *Name, double Value)
evxErrors | cvxConfigSetOption (const char *Name, const char *Option)
evxErrors | cvxConfigSetRgb (const char *Name, svxColor *Rgb)
evxErrors | cvxConfigSetString (const char *Name, char *Str)
evxErrors | cvxConfigSetYesNo (const char *Name, int YesNo)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dim.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dim.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Dimension API
Note – The common functions of dimension are defined in this header file.
The function declarations of the dimension in the part are defined in "ZwApiPart.h"
The function declarations of the dimension in the sketch are defined in "ZwApiSkDim.h"
The function declarations of the dimension in the drawing are defined in "zwapi_dwg_dim.h"

Definition in file zwapi_dim.h.

Dimension Query

evxErrors | cvxDimInqType (int idDim, evxDimType *type)
evxErrors | cvxDimInqTypeEx (int idDim, evxDimTypeEx *typeEx)
evxErrors | cvxDimIsRadius (int idDim, int *isRadius)
evxErrors | cvxDimInqState (int idDim, evxDimState *state)
evxErrors | cvxDimInqDimBundles (int idDim, int *Count, int **idBundles)
evxErrors | cvxDimFCSDataGet (int idFCS, int *numOfFcs, svxFCSData **FcsData, vxLongName Note1, vxLongName Note2)

Dimension value

evxErrors | cvxDimInqVar (int idDim, svxVariable *Var)
evxErrors | cvxDimValMod (int idDim, char *exp)
evxErrors | cvxDimValModNoUpdate (int idDim, char *exp)

Dimension text

evxErrors | cvxDimInqText (int idDim, int subDim, char **pStr)
evxErrors | cvxDimModTxt (int idDim, int subDim, char *pStr)
evxErrors | cvxDimInqTextType (int idDim, int *Type)
evxErrors | cvxDimModTextType (int idDim, int Type, char *text)
evxErrors | cvxDimInqTxtPnt (int idDim, svxPoint *TextPnt)
evxErrors | cvxDimModTxtPnt (int idDim, int center, svxPoint *TextPnt)

Dimension Point

evxErrors | cvxDimInqPos (int idDim, svxPoint *pPos)
evxErrors | cvxDimInqDimPnts (int idDim, int *count, svxPoint **DimPnts)

Dimension Line

evxErrors | cvxDimInqDimLines (int idDim, int *count, svxCurve **DimCrvs)
evxErrors | cvxDimInqExtLines (int idDim, int *count, svxCurve **DimCrvs)

Dimension Attribute

evxErrors cvxDimAtGetBySub (int idDim, int subDim, svxDimAttr *dmAttr)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_display.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_display.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Display API and Generic Data Types and Structures of these functions

Definition in file zwapi_display.h.

Display Data

enum | evxDispAttrib { VX_DISP_POINT = 0 , VX_DISP_LINE = 1 , VX_DISP_FACE = 2 }
display attribute types More...
enum evxDispMode {
VX_DISP_WIRE = 1 , VX_DISP_SHADE = 2 , VX_DISP_HIDD_APPROX = 3 , VX_DISP_HIDD_EXACT = 4 ,
VX_DISP_EDGE = 5
}
display mode More...
enum | evxDispItem { VX_DISP_SCREEN = 0 , VX_DISP_PREVIEW = 1 , VX_DISP_FORMS = 2 , VX_DISP_ALL = 3 }
display (i.e. GUI) item More...
enum | evxVisualDispItem { VX_VISUAL_DISP_FRAME_TRIAD = 0 , VX_VISUAL_DISP_COMPASS_TRIAD = 1 , VX_VISUAL_DISP_TRIAD_TRANS = 2 }
visual display item More...
typedef int | vxDispState[10]
display state settings More...
typedef enum evxDispAttrib | evxDispAttrib
display attribute types
typedef enum evxDispMode | evxDispMode
display mode
typedef enum evxDispItem | evxDispItem
display (i.e. GUI) item
typedef enum evxVisualDispItem | evxVisualDispItem
visual display item

Lights Data

enum evxLightType {
V_LIGHT_NULL = 0 , V_LIGHT_AMB = 1 , V_LIGHT_DIR = 2 , V_LIGHT_POS = 3 ,
V_LIGHT_SPOT = 4 , V_LIGHT_EYE = 5
}
light source type More...
typedef enum evxLightType | evxLightType
light source type
typedef struct svxLight | svxLight
light source

Frame and Datum Data

enum evxDatumDispMode {
VX_DSP_PLN_XY = 0 , VX_DSP_PLN_RECT_XY = 1 , VX_DSP_PLN_RECT_XYZ = 2 , VX_DSP_PLN_RECT = 3 ,
VX_DSP_PLN_QURT = 4 , VX_DSP_PLN_RECT_XY_FIX = 5 , VX_DSP_PLN_RECT_XYZ_FIX = 6 , VX_DSP_PLN_RECT_FIX = 7 ,
VX_DSP_PLN_XYZ = 8
}
display mode of datum plane More...
enum | evxAxisDispMode { VX_DSP_AXIS_ARROW_LINE = 0 , VX_DSP_AXIS_DASH_LINE = 1 }
display mode of datum axis More...
typedef enum evxDatumDispMode | evxDatumDispMode
display mode of datum plane
typedef enum evxAxisDispMode | evxAxisDispMode
display mode of datum axis

Display

void | cvxDispRedraw (void)
void | cvxDispDataUpdate (void)
void | cvxDispModeGet (evxDispMode *Mode)
void | cvxDispModeSet (evxDispMode Mode)
void | cvxDispRgbGet (evxDispAttrib Type, svxColor *Rgb)
void | cvxDispRgbSet (evxDispAttrib Type, const svxColor *Rgb)
void | cvxDispColorGet (evxDispAttrib Type, evxColor *Color)
void | cvxDispColorSet (evxDispAttrib Type, evxColor Color)
void | cvxDispSwitch (evxDispItem Item, int isOn)
void | cvxDispSwitchGet (evxDispItem Item, int *isOn)
void | cvxDispState (int Option, vxDispState State)
void | cvxVisDispStatusGet (evxVisualDispItem Item, int *isOn)
evxErrors cvxDispSceneUpdate ()
evxErrors | cvxDispWindowRectGet (const int includeFrame, const int isGlobal, int *x, int *y, int *w, int *h)

Lights

evxErrors | cvxDispGetLights (int *Count, svxLight **Lights)
evxErrors | cvxDispSetLightsInit (svxLight *data)
evxErrors | cvxDispSetLights (int Count, svxLight *Lights)

Show-n_Tell

void | cvxShowOpen (const vxLongPath File)
void | cvxShowDisp (int SlideNumber)

Zoom

void | cvxDispZoomAll (int Redraw)
void | cvxDispZoomAllIncludeDim (int Redraw)
void | cvxDispZoomAt (const svxPoint point, const float factor)
evxErrors | cvxDispZoomLimits (void)
evxErrors | cvxDispZoomIn (int ZoomIn, const svxPoint2f StartPoint, const svxPoint2f EndPoint)

Frame and Datum

void | cvxDatumLocalVis (int iVisible)
void | cvxDatumDispModeSet (int idDatum, evxDatumDispMode DispMode)
evxErrors | cvxDatumDispModeGet (int idDatum, evxDatumDispMode *DispMode)
evxErrors | cvxDatumDispAttrGet (int idDatum, svxWireAt *DispAt)
evxErrors | cvxDatumDispAttrSet (int idDatum, const svxWireAt *DispAt)
evxErrors | cvxAxisDispModeGet (int idAxis, evxAxisDispMode *DspMode)
evxErrors | cvxAxisDispModeSet (int idAxis, evxAxisDispMode DspMode)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_attribute.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_attribute.h File Reference
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Attribute API

Definition in file zwapi_dwg_attribute.h.

Drawing Attribute

evxErrors | cvxDwgAtGet (int idDrawing, svxDrawingAt *drawingAt)
evxErrors | cvxDwgAtSet (int idDrawing, svxDrawingAt *drawingAt)
evxErrors | cvxDwgAtItemGet (evxAtItemId itemId, svxAttribute *At)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the functions for Drawing objects.

Definition in file zwapi_dwg_data.h.

View Query/Set Data

enum evxViewType {
VX_VIEW_ALL = 0 , VX_VIEW_BASE = 1 , VX_VIEW_PROJ = 2 , VX_VIEW_SECT = 3 ,
VX_VIEW_DET = 4 , VX_VIEW_DEFN = 5
}
view type More...
enum evxViewProjAngle {
VX_VIEW_PROJ_ANG_ALL = 0 , VX_VIEW_3RD_UP = 1 , VX_VIEW_3RD_DN = 2 , VX_VIEW_3RD_RT = 3 ,
VX_VIEW_3RD_LT = 4 , VX_VIEW_1ST_UP = 5 , VX_VIEW_1ST_DN = 6 , VX_VIEW_1ST_RT = 7 ,
VX_VIEW_1ST_LT = 8 , VX_VIEW_3RD_PRJ_ANG = 9 , VX_VIEW_1ST_PRJ_ANG = 10
}
drawing view projection angle More...
enum | evxBrkLineCutSty { VX_ZEROZIGZAG_BRKLINE = 0 , VX_ONEZIGZAG_BRKLINE , VX_TWOZIGZAG_BRKLINE , VX_CURVE_BRKLINE }
break Line style More...
typedef enum evxViewType | evxViewType
view type
typedef enum evxViewProjAngle | evxViewProjAngle
drawing view projection angle
typedef enum evxBrkLineCutSty | evxBrkLineCutSty
break Line style
typedef struct svxDwgBrkLineAt | svxDwgBrkLineAt
attribute of break line

Symbol Query Data

enum evxSymbolType {
VX_SYM_ALL = -1 , VX_SYM_USER = 0 , VX_SYM_SURF = 1 , VX_SYM_WELD = 2 ,
VX_SYM_IMAGE = 3 , VX_SYM_ORIGIN = 4 , VX_SYM_BEAD = 5 , VX_SYM_ENDTRT = 6 ,
VX_SYM_OPEN_LINK = 7 , VX_SYM_HOLE_MARK = 8
}
symbol object type More...
typedef enum evxSymbolType | evxSymbolType
symbol object type
typedef struct svxSymAttr | svxSymAttr
symbol attributes structure

Table Query/Set

enum evxTableType {
VX_TABLE_ALL = 0 , VX_TABLE_USER = 1 , VX_TABLE_BOM = 2 , VX_TABLE_HOLE = 3 ,
VX_TABLE_TRODE = 4 , VX_TABLE_WDSEG = 5 , VX_TABLE_WELD = 6 , VX_TABLE_PNT = 7 ,
VX_TABLE_DIM = 8 , VX_TABLE_REV = 9
}
table type More...
typedef enum evxTableType | evxTableType
table type
typedef struct svxDwgBundleDimData | svxDwgBundleDimData
data of dimension bundle

Style Manager Data

enum evxDwgStyleManagerMethod {
VX_STYLEMANAGER_TEXT , VX_STYLEMANAGER_ANNO_LEADER , VX_STYLEMANAGER_ANNO_BALLOON , VX_STYLEMANAGER_ANNO_DATUM_FEATURE ,
VX_STYLEMANAGER_ANNO_DATUM_TARGET , VX_STYLEMANAGER_ANNO_FEATURE_CONTROL , VX_STYLEMANAGER_DIM_LINEAR , VX_STYLEMANAGER_DIM_ANGULAR ,
VX_STYLEMANAGER_DIM_RADIAL , VX_STYLEMANAGER_DIM_ARC , VX_STYLEMANAGER_DIM_CHAMFER , VX_STYLEMANAGER_DIM_HOLECALLOUT ,
VX_STYLEMANAGER_DIM_ORDINATE , VX_STYLEMANAGER_SYM_WELD , VX_STYLEMANAGER_SYM_SRF_FINISH , VX_STYLEMANAGER_TABLE_USER ,
VX_STYLEMANAGER_TABLE_BOM , VX_STYLEMANAGER_TABLE_HOLE , VX_STYLEMANAGER_TABLE_EDM , VX_STYLEMANAGER_TABLE_STRUCTURAL ,
VX_STYLEMANAGER_TABLE_WELD , VX_STYLEMANAGER_TABLE_REVISION , VX_STYLEMANAGER_VIEW_BASE , VX_STYLEMANAGER_VIEW_PROJECTION ,
VX_STYLEMANAGER_VIEW_AUXILIARY , VX_STYLEMANAGER_VIEW_SECTION , VX_STYLEMANAGER_VIEW_DETAIL , VX_STYLEMANAGER_VIEW_ALTERNATE
}
style manager type More...
enum | evxTextFontType { VX_FONTTYPE_NORMAL , VX_FONTTYPE_PROPORTIONAL , VX_FONTTYPE_FIXED }
font type More...
enum | evxTextStroke { VX_STROKE_COARSE , VX_STROKE_MEDIUM , VX_STROKE_FINE }
text precision More...
enum | evxTextAlignWordWrap { VX_TEXTALIGN_NONE , VX_TEXTALIGN_WORDWRAP , VX_TEXTALIGN_AUTOSIZETEXT }
fit method More...
enum | evxHorizontalMethod { VX_HORIZONTAL_NORMAL , VX_HORIZONTAL_LEFT , VX_HORIZONTAL_CENTER , VX_HORIZONTAL_RIGHT }
horizontal method More...
enum evxVerticalMethod {
VX_VERTICAL_NORMAL , VX_VERTICAL_TOP , VX_VERTICAL_CAP , VX_VERTICAL_HALF ,
VX_VERTICAL_BASE , VX_VERTICAL_BOTTOM
}
vertical method More...
enum | evxTextAlignment { VX_ALIGNMENT_LEFT = 1 , VX_ALIGNMENT_CENTER , VX_ALIGNMENT_RIGHT }
justification More...
typedef enum evxDwgStyleManagerMethod | evxDwgStyleManagerMethod
style manager type
typedef enum evxTextFontType | evxTextFontType
font type
typedef enum evxTextStroke | evxTextStroke
text precision
typedef enum evxTextAlignWordWrap | evxTextAlignWordWrap
fit method
typedef enum evxHorizontalMethod | evxHorizontalMethod
horizontal method
typedef enum evxVerticalMethod | evxVerticalMethod
vertical method
typedef struct svxDwgStyleManagerText | svxDwgStyleManagerText
the text attribute of the text in the style manager.
typedef enum evxTextAlignment | evxTextAlignment
justification
typedef struct svxDwgStyleManagerAnnoDimText | svxDwgStyleManagerAnnoDimText
the text attribute of the annotation/dimension in the style manager.
typedef struct svxDwgStyleManagerTableText | svxDwgStyleManagerTableText
the text attribute of the table in the style manager.
typedef struct svxDwgStyleManagerSymText | svxDwgStyleManagerSymText
the text attribute of the weld(or surface finish) in the style manager.
typedef struct svxDwgStyleManagerViewText | svxDwgStyleManagerViewText
the text attribute of the view in the style manager.

Drawing Attribute Data

typedef struct svxDrawingAt svxDrawingAt
Sheet Format Attributes structure.

Drawing Geometry Query/Set Data

typedef struct svxRefEntData svxRefEntData
reference entity data. More...
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_dim.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_dim.h File Reference
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Dimension API

Definition in file zwapi_dwg_dim.h.

Drawing Dimension

evxErrors | cvxDwgInqDims (int idDrawing, evxDimType *dimTypeList, int dimTypeCount, int *count, int **dims)
evxErrors | cvxDwgInqDimEnts (int idDim, int *count, int **idEnts)
evxErrors | cvxDwgInqDimGripPnts (int idDim, int *Num, svxPoint **Pnts)
evxErrors | cvxDwgGetDimTextBox (int idDim, double *tbWid, double *tbHgt, double *chSlp, svxPoint2 *txtPt)
evxErrors | cvxDwgInqDimByView (int idView, int *count, int **idDims)
evxErrors | cvxDwgInqDimByDrawing (int idDrawing, int *count, int **idDims)
evxErrors | cvxDwgInqBundleDataByDim (int idDim, int *count, svxDwgBundleDimData **data)

Drawing Dimension Attribute

evxErrors | cvxDwgDimAtGet (int idDim, svxDimAttr *dmAttr)
evxErrors | cvxDwgDimAtSet (int idDim, svxDimAttr *dmAttr)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_drawing.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_drawing.h File Reference
#include "zwapi_dwg_data.h"
#include "zwapi_cmd_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing API

Definition in file zwapi_dwg_drawing.h.

Sheet Edit

evxErrors | cvxDwgSheetAdd (vxLongName Name, int *idSheet)
evxErrors | cvxDwgSheetDel (int count, int *idSheet)
evxErrors | cvxDwgSheetScaleGet (int idSheet, double *scale)
evxErrors | cvxDwgSheetScaleSet (int idSheet, double scale)

Drawing Query/Set

evxErrors | cvxDwgInqList (int idRoot, int *count, int **idDrawings)
evxErrors | cvxDwgInqName (int idDrawing, char *drawingName, int nBytes)
evxErrors | cvxDwgFind (const vxRootName rootName, const vxLongName drawingName, int *idDrawing)
evxErrors | cvxDwgInqBorderTitle (int idDrawing, int *idBorder, int *idBorderSkt, int *idTitle, int *idTitleSkt)
evxErrors | cvxDwgInqPart (char *rootName, int *iCount, svxCompName **partList)
evxErrors | cvxDwgSetRefPart (const char *File, const char *Root, int idxView, svxCompName *oldPart, svxCompName *newPart)
evxErrors | cvxDwgActivate (vxLongName drawingName)
evxErrors | cvxDwgInqActive (char *drawingName, int nBytes)
evxErrors | cvxDwgRegen (int count, int *idViews, int isRegenUnModifiedView, int isRegenTable, int isPrompt, int isRegenSketch)

Style Manager Data

evxErrors cvxDwgStyleManagerWithTextAtGet (evxDwgStyleManagerMethod type, void *data)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_geometry.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_geometry.h File Reference
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Geometry API

Definition in file zwapi_dwg_geometry.h.

Drawing Geometry Query/Set

evxErrors | cvxDwgInqGeom (int idDrawing, int *count, int **idEnts)
evxErrors | cvxDwgInqText (int idDrawing, int *count, int **idEnts)
evxErrors | cvxDwgInqHatchAttr (int idHatch, svxHatchAttr *HatchAttr)
evxErrors | cvxDwgHatchAttrSet (int idHatch, svxHatchAttr HatchAttr)
evxErrors | cvxDwgHatchAssoCrvsGet (int idHatch, int *count, int **AssocCrvs)
evxErrors | cvxDwgInqHatchIdByView (int idView, int *count, int **idHatchs)
evxErrors | cvxDwgInqHatchIdByDrawing (int idDrawing, int *count, int **idHatchs)
evxErrors | cvxDwgRefEntDataGet (int idRefEnt, svxRefEntData *data)
evxErrors | cvxDwgGeomGetView (int idGeom, int *idView)

View Geometry Query/Set

evxErrors | cvxDwgViewGeomInqList (int viewId, int option, int *count, int **indices)
evxErrors | cvxDwgViewGeomGetShapeId (int geomId, char *fileName, int fileNameBytes, char *partName, int partNameBytes, svxEntPath *pickPath, int *geom3DId, int *shapeId)
evxErrors | cvxDwgViewRefCompVisSet (int idView, const vxLongPath fileName, const vxRootName partName, int show)
evxErrors | cvxDwgViewInqRefEnts (int viewId, int *count, int **idRefEnts)
evxErrors | cvxDwgViewRefBlankGet (int idRefEnt, int *blank)
evxErrors | cvxDwgViewRefBlankSet (int idRefEnt, int blank)
evxErrors | cvxDwgViewRefEntAtGet (int idRefEnt, int *clrValid, int *typeValid, int *widthValid, svxLineAt *entAt)
evxErrors | cvxDwgViewRefEntAtSet (int idRefEnt, int clrValid, int typeValid, int widthValid, const svxLineAt *entAt)
evxErrors | cvxDwgViewPnt2DTo3D (int pnt2DId, svxPoint *pnt3D)
evxErrors | cvxDwgViewPnt3DTo2D (int viewId, svxPoint pnt3D, svxPoint2 *pnt2D)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_symbol.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_symbol.h File Reference
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Dimension API

Definition in file zwapi_dwg_symbol.h.

Symbol Query

evxErrors | cvxShtInqSymbol (evxSymbolType type, int *Count, int **idEnts)
evxErrors | cvxDwgInqSymObjList (int idSym, int *count, int **listId)
evxErrors | cvxDwgInqSymType (int idSym, evxSymbolType *type)
evxErrors | cvxDwgInqSymEnts (int idSym, int *Count, int **idEnts)

Symbol Attribute

evxErrors | cvxDwgSymAtGet (int idSym, svxSymAttr *symAttr)
evxErrors | cvxDwgSymAtSet (int idSym, svxSymAttr *symAttr)
evxErrors | cvxDwgSymImgAtGet (int idSymImg, svxSymImg *data)
evxErrors | cvxDwgSymImgAtSet (int idSymImg, const svxSymImg *data)

Symbol Data

evxErrors | cvxDwgSymSurfDataGet (int idSymSurf, svxSymSurf *data)
evxErrors | cvxDwgSymSurfDataSet (int idSymSurf, svxSymSurf *data)
evxErrors | cvxDwgSymWeldDataGet (const int idSymWeld, svxSymWeld *data)
evxErrors | cvxDwgSymWeldDataSet (const int idSymWeld, const svxSymWeld *data)
void | cvxSymWeldFree (svxSymWeld *WeldData)
evxErrors | cvxDwgUserSymObjGet (const int idSymUser, int *nObj, int **idObjs)
evxErrors | cvxDwgSymInsPointGet (int idSym, svxPoint2 *pnt)
evxErrors | cvxDwgSymInsPointSet (int idSym, svxPoint2 *pnt)
evxErrors | cvxDwgSymLinkGet (const int idSymLink, vxPath filePath)
evxErrors | cvxDwgSymLinkGetByLongPath (const int idSymLink, char *filePath, int sizePath)
evxErrors | cvxDwgSymLinkExport (const int idSymLink, vxPath filePath)
evxErrors | cvxDwgSymLinkExportByLongPath (const int idSymLink, char *filePath, int sizePath)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_table.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_table.h File Reference
#include "zwapi_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing Table API

Definition in file zwapi_dwg_table.h.

Table Query/Set

evxErrors | cvxDwgInqTables (int idDrawing, evxTableType type, int *count, int **tables)
evxErrors | cvxDwgInqTableType (int idTable, evxTableType *type)
evxErrors | cvxDwgGetTableSize (int iTblIdx, int *pRowNum, int *pColNum)
evxErrors | cvxDwgTableAdjustSize (int idTable)
evxErrors | cvxDwgTableInsPntSet (int idTable, svxPoint2 *pnt)
evxErrors | cvxDwgTableInsPntGet (int idTable, svxPoint2 *pnt)
evxErrors | cvxDwgTableExport (int idTable, const vxLongPath path)
evxErrors | cvxDwgTableLinkToExcel (int idTable, const vxLongPath path)

Table Row/column Set

evxErrors | cvxDwgTableRowHeightSet (int idTable, int Row, double Height)
evxErrors | cvxDwgTableRowInsert (int idTable, int Row)
evxErrors | cvxDwgTableRowDelete (int idTable, int Row)
evxErrors | cvxDwgTableColWidthSet (int idTable, int Col, double Width)
evxErrors | cvxDwgTableColInsert (int idTable, int Col)
evxErrors | cvxDwgTableColDelete (int idTable, int Col)

Table Cell Attribute

evxErrors | cvxDwgTableCellAtGet (int idTable, int Row, int Col, svxTextAt *TextAt)
evxErrors | cvxDwgTableCellAtSet (int idTable, int Row, int Col, svxTextAt *TextAt)

Table Cell Operation

evxErrors | cvxDwgTableCellSet (int idTable, int Row, int Col, char *Value)
evxErrors | cvxDwgTableCellGet (int idTable, int Row, int Col, char *Value, int nBytes)
void | cvxDwgTableCellsMerge (int idTable, int startRow, int endRow, int startCol, int endCol, int kFirstData)
void | cvxDwgTableCellsUnMerge (int idTable, int minRow, int maxRow, int minCol, int maxCol)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_view.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_dwg_view.h File Reference
#include "zwapi_dwg_data.h"
#include "zwapi_cmd_dwg_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Drawing View API

Definition in file zwapi_dwg_view.h.

View Query/Set

evxErrors | cvxDwgInqViews (int idDrawing, evxViewType type, int *count, int **views)
evxErrors | cvxDwgInqViewMod (int idDrawing, int *modified)
evxErrors | cvxDwgInqViewType (int idView, evxViewType *type)
evxErrors | cvxDwgInqViewTypeEx (int viewId, evxViewTypeEx *viewType)
evxErrors | cvxDwgViewAtGet (int idView, svxViewAt *viewAttr)
evxErrors | cvxDwgViewAtSet (int idView, svxViewAt *viewAttr)
evxErrors | cvxDwgViewLockSet (int idView, int lock)
evxErrors | cvxDwgViewLockGet (int idView, int *isLock)
evxErrors | cvxDwgViewDottedBorderGet (int idView, svxPoint2 *UpperLeft, svxPoint2 *UpperRight, svxPoint2 *BottomLeft, svxPoint2 *BottomRight)
evxErrors | cvxDwgViewInqPart (int idView, svxCompName *part)
evxErrors | cvxDwgViewInqPartConfig (int idView, vxName partCfg)
evxErrors | cvxDwgViewInqPartConfigByLongName (int idView, char *partCfg, int size)
evxErrors | cvxDwgViewInqChildView (int idView, int *count, int **idViews)
evxErrors | cvxDwgViewEntitiesAssociate (int idView, int count, int *idEnts)
evxErrors | cvxDwgViewInqProjection (int idView, evxViewProjAngle *projection)
evxErrors | cvxDwgViewLocationGet (int idView, svxPoint2 *point)
evxErrors | cvxDwgAlignmentGet (int idView, int *align)
evxErrors | cvxDwgViewInqOrgPnt (int idView, svxPoint2 *pnt, int *idEnt)
evxErrors | cvxDwgBrkLineAtSet (int brkLnViewId, const svxDwgBrkLineAt *brkLineAt)
evxErrors | cvxDwgBrkLineAtGet (int brkLnViewId, svxDwgBrkLineAt *brkLineAt)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_file.h File Reference
#include "zwapi_file_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D File API

Definition in file zwapi_file.h.

File New

int | cvxFileNameCheck (char *fileName, int nBytes)
evxErrors | cvxFileNew (const vxLongPath Name)
evxErrors | cvxFileNew2 (const vxLongPath Name, char *Description)
evxErrors | cvxFileNewSingle (const vxLongPath fileName, evxFileType fileType, evxFileSubtype fileSubtype, const char *templateName, char *fileDescription)

File Open

int | cvxFileKeep (int fKeepOpen)
evxErrors | cvxFileOpen (const vxLongPath File)
evxErrors | cvxFileReOpen (const vxLongPath Name)
evxErrors | cvxFileReplace (const vxLongPath filePath, const vxLongPath newData, int fDel)

File Save

evxErrors | cvxFileSave (int Close)
evxErrors | cvxFileSave2 (int Close)
evxErrors | cvxFileSave3 (int Close, int DisPrompt, int Related)
evxErrors | cvxFileSaveAll (void)
evxErrors | cvxFileSaveAs (const vxLongPath File)
evxErrors | cvxFilesSaveTo (int Count, const vxPath *FileList, const vxPath Path)
evxErrors | cvxFilesSaveToByLongPath (int Count, const vxLongPath *FileList, const vxLongPath Path)
evxErrors | cvxCompFileSaveAs (svxEntPath *CompPath, int UpdateFlag, const vxLongPath File)

File Close

void | cvxFileClose (void)
void | cvxFileClose2 (const vxLongPath Name, int Option)

Session

evxErrors | cvxSessionClear (void)
evxErrors | cvxFileSessionClear (const vxLongPath file)
evxErrors | cvxSessionSave (void)
evxErrors | cvxSessionRestore (void)

File Import/Export

evxErrors | cvxFileImportInit (svxImportData *data, evxImportType type, void *general)
evxErrors | cvxFileImport (svxImportData *importData)
evxErrors | cvxFileImportMulti (int Count, const vxPath *PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void *Setting)
evxErrors | cvxFileImportMultiByLongPath (int Count, const vxLongPath *PathList, int SubFolder, const vxLongPath SavePath, evxImportType Type, const void *Setting)
evxErrors | cvxFileImportStl (const char *path, int *idOut)
evxErrors | cvxFileExportInit (evxExportType type, int imgType, void *data)
evxErrors | cvxFileExport (evxExportType Type, const vxLongPath Path, void *Data)
evxErrors | cvxFileExportMulti (int Count, const vxPath *FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void *Data)
evxErrors | cvxFileExportMultiByLongPath (int Count, const vxLongPath *FileList, evxFileType Filter, evxExportType Type, const vxLongPath Path, void *Data)
evxErrors | cvxPartSmdFlatSolidExport (int idFlatten, evxExportType type, const vxLongPath filePath, void *data)
evxErrors | cvxPartSmdFlatPatternExport (int idFlatten, const vxLongPath filePath, const svxDWGData *data)

File Action

evxErrors cvxFileAction (evxDocAction type, svxDocActionParam *param)

File Query/Edit

evxErrors | cvxFileActivate (const vxLongPath Name)
void | cvxFileDirectory (vxPath Directory)
void | cvxFileDirectoryByLongPath (char *Directory, int sizeDire)
void | cvxFileInqActive (char *Name, int nBytes)
void | cvxFileTypeGet (int *MultiObject)
void | cvxFileTypeSet (int MultiObject)
evxErrors | cvxFileInqSubType (const vxLongPath fileName, evxFileSubtype *fileSubtype)
void | cvxFileInqOpen (char *Name, int nBytes)
void | cvxFileOpenList (int *count, vxPath **fileList)
void | cvxFileOpenListByLongPath (int *count, vxLongPath **fileList)
evxErrors | cvxFileLoadList (const int state, int *count, vxPath **fileList)
evxErrors | cvxFileLoadListByLongPath (int state, int *count, vxLongPath **fileList)
evxErrors | cvxFileVersionGet (const vxLongPath file, int *version)
evxErrors | cvxFileIsModified (const vxLongPath Name, int *Modified)
evxErrors | cvxFileInqAssociatedList (int *count, vxPath **fileList)
evxErrors | cvxFileInqAssociatedListByLongPath (int *count, vxLongPath **fileList)
evxErrors | cvxFileInqAssociatedListByName (const char *fileName, int nDepth, int *count, vxPath **fileList)
evxErrors | cvxFileInqAssociatedListByLongName (const char *fileName, int nDepth, int *count, vxLongPath **fileList)
evxErrors | cvxFilePreviewExtract (const vxLongPath SrcFile, const vxLongPath BmpFile)
evxErrors | cvxFileInqAsm (char *Name, int nBytes)
char | cvxFileInqAssemMode (void)

UDF File Query/Edit

evxErrors | cvxFileIsUDF (const vxLongPath path, const vxLongPath file, int *isUDF)
evxErrors | cvxUDFFileInqAssociatedList (const vxPath path, const vxPath file, int *count, vxPath **fileList)
evxErrors | cvxUDFFileInqAssociatedListByLongPath (const vxLongPath path, const vxLongPath file, int *count, vxLongPath **fileList)

File Attribute

void | cvxFileDescriptionSet (const vxLongPath Name, const char *Description)
evxErrors | cvxFileDescriptionGet (const vxLongPath Name, vxLongName Description)
evxErrors | cvxFileCustomDataSet (const vxLongPath file, const char *data, int dataLength)
evxErrors | cvxFileCustomDataGet (const vxLongPath file, char **data, int *dataLength)
evxErrors | cvxFileCustomDataDel (const vxLongPath file)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_file_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of File and Path functions.

Definition in file zwapi_file_data.h.

File New Data

enum evxFileType {
VX_FILE_ALL = 0 , VX_FILE_PART = 1 , VX_FILE_ASSEMBLY , VX_FILE_SHEET ,
VX_FILE_SKETCH , VX_FILE_CAMPLAN
}
file type More...
enum evxFileSubtype {
VX_SUBTYPE_NONE = 0 , VX_NORMAL_PART , VX_ECAD_BOARD_PART , VX_NORMAL_ASSEMBLY ,
VX_ECAD_ASSEMBLY , VX_ROUTING_ASSEMBLY , VX_SMD_PART , VX_HARNESS_ASSEMBLY ,
VX_HARNESS_PART , VX_MASTERLAYOUT_PART
}
file sub-type More...
typedef enum evxFileType | evxFileType
file type
typedef enum evxFileSubtype | evxFileSubtype
file sub-type

File Import/Export Data

enum evxImgColorMode {
VX_EXPORT_IMG_COLOR_MODE_24BITS = 0 , VX_EXPORT_IMG_COLOR_MODE_8BITS = 1 , VX_EXPORT_IMG_COLOR_MODE_COlORIZED = 0 , VX_EXPORT_IMG_COLOR_MODE_MONOCHROME = 2 ,
VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE = 3
}
export image color mode More...
enum | evxImgBkgndMode { VX_EXPORT_IMG_BKGND_MODE_CURRENT = 0 , VX_EXPORT_IMG_BKGND_MODE_CUSTOM }
export image background mode More...
enum | evxImgRangeMode { VX_EXPORT_IMG_RANGE_MODE_NORMAL = 0 , VX_EXPORT_IMG_RANGE_MODE_EXTENTS , VX_EXPORT_IMG_RANGE_MODE_CUSTOM }
export image range mode More...
enum evxImgType {
VX_EXPORT_IMG_TYPE_BMP = 1 , VX_EXPORT_IMG_TYPE_GIF , VX_EXPORT_IMG_TYPE_PNG , VX_EXPORT_IMG_TYPE_TIFF ,
VX_EXPORT_IMG_TYPE_JPEG
}
export image type More...
enum | evxPdfType { VX_EXPORT_PDF_TYPE_RASTER = 1 , VX_EXPORT_PDF_TYPE_VECTOR , VX_EXPORT_PDF_TYPE_OBJECT }
export pdf type More...
enum | evxPdfRangeMode { VX_EXPORT_PDF_RANGE_MODE_NORMAL = 0 , VX_EXPORT_PDF_RANGE_MODE_EXTENTS , VX_EXPORT_PDF_RANGE_MODE_CUSTOM }
export pdf range mode More...
enum evxDWGVer {
VX_DWG_VERSION_2018 = 1 , VX_DWG_VERSION_2013 = 2 , VX_DWG_VERSION_2010 = 3 , VX_DWG_VERSION_2007 ,
VX_DWG_VERSION_2004 , VX_DWG_VERSION_2000 , VX_DWG_VERSION_R14 , VX_DWG_VERSION_R13 ,
VX_DWG_VERSION_R11_R12
}
version of DWG More...
enum evxExportExcludeWidthStyle {
VX_EXCLUDE_WIDTH_STYLE_1 = 0x1 , VX_EXCLUDE_WIDTH_STYLE_2 = 0x2 , VX_EXCLUDE_WIDTH_STYLE_3 = 0x4 , VX_EXCLUDE_WIDTH_STYLE_4 = 0x8 ,
VX_EXCLUDE_WIDTH_STYLE_5 = 0x10
}
exclude attribute(no color) of *.dwg/*.dxf More...
enum evxExportExcludeColor {
VX_EXCLUDE_COLOR_GREEN = 0x1 , VX_EXCLUDE_COLOR_RED = 0x2 , VX_EXCLUDE_COLOR_BROWN = 0x4 , VX_EXCLUDE_COLOR_GOLDENROD = 0x8 ,
VX_EXCLUDE_COLOR_MED_BLUE = 0x10 , VX_EXCLUDE_COLOR_DARK_MAGENTA = 0x20 , VX_EXCLUDE_COLOR_DARK_GREY = 0x40 , VX_EXCLUDE_COLOR_DARK_BLUE = 0x80 ,
VX_EXCLUDE_COLOR_VIOLET = 0x100 , VX_EXCLUDE_COLOR_LIGHT_GREEN = 0x200 , VX_EXCLUDE_COLOR_LIGHT_BLUE = 0x400 , VX_EXCLUDE_COLOR_ROSE = 0x800 ,
VX_EXCLUDE_COLOR_LIGHT_MAGENTA = 0x1000 , VX_EXCLUDE_COLOR_LIGHT_GREY = 0x2000 , VX_EXCLUDE_COLOR_WHITE = 0x4000
}
exclude attribute(color) of *.dwg/*.dxf More...
enum | evxRemoveTextFontType { VX_TEXT_FONT_TYPE_NONE = 0 , VX_TEXT_FONT_TYPE_ALL = 1 , VX_TEXT_FONT_TYPE_EXCLUDE = 2 }
remove text font info type. More...
enum evxJTVer {
VX_JT_VER_6_4 , VX_JT_VER_7_0 , VX_JT_VER_8_0 , VX_JT_VER_8_1 ,
VX_JT_VER_8_2 , VX_JT_VER_8_3 , VX_JT_VER_9_0 , VX_JT_VER_9_1 ,
VX_JT_VER_9_2 , VX_JT_VER_9_3 , VX_JT_VER_9_4 , VX_JT_VER_9_5 ,
VX_JT_VER_10_0 , VX_JT_VER_10_1 , VX_JT_VER_10_2 , VX_JT_VER_10_3 ,
VX_JT_VER_10_4
}
version of JT More...
enum | evxDWGDXFConvertMeshTo { VX_DWGDXF_MESHTO_STL_BLOCKS = 1 , VX_DWGDXF_MESHTO_LINES = 2 , VX_DWGDXF_MESHTO_PLANAR_FACES = 3 }
dwg dxf file import of convert polygon mesh to More...
enum evxDWGDXFExcludeColor {
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED = 0x1 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN = 0x2 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE = 0x4 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW = 0x8 ,
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA = 0x10 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN = 0x20 , VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE = 0x40
}
import dwg dxf file, exclude color More...
enum evxImportType {
VX_IMPORT_TYPE_ALL = 0 , VX_IMPORT_TYPE_PARASOLID = 1 , VX_IMPORT_TYPE_DWG_DXF = 2 , VX_IMPORT_TYPE_STEP ,
VX_IMPORT_TYPE_SAT , VX_IMPORT_TYPE_IGES , VX_IMPORT_TYPE_CATIA4 , VX_IMPORT_TYPE_CATIA5 ,
VX_IMPORT_TYPE_INVENTOR , VX_IMPORT_TYPE_JT , VX_IMPORT_TYPE_PROE_CERO , VX_IMPORT_TYPE_SOLIDEDGE ,
VX_IMPORT_TYPE_SOLIDWORKS , VX_IMPORT_TYPE_UG , VX_IMPORT_TYPE_STL , VX_IMPORT_TYPE_GPH ,
VX_IMPORT_PTS_FROM_FILE
}
file import type More...
enum evxDWGDXFReadAsUnits {
VX_UNIT_DWGDXF_INCHES = 1 , VX_UNIT_DWGDXF_FEET = 2 , VX_UNIT_DWGDXF_MILES = 3 , VX_UNIT_DWGDXF_MILIMETERS = 4 ,
VX_UNIT_DWGDXF_CENTIMETERS = 5 , VX_UNIT_DWGDXF_METERS = 6 , VX_UNIT_DWGDXF_KILOMETERS = 7 , VX_UNIT_DWGDXF_MICROINCHES = 8 ,
VX_UNIT_DWGDXF_MILS = 9 , VX_UNIT_DWGDXF_YARDS = 10 , VX_UNIT_DWGDXF_ANGSTROMS = 11 , VX_UNIT_DWGDXF_NANOMETERS = 12 ,
VX_UNIT_DWGDXF_MICRONS = 13 , VX_UNIT_DWGDXF_DECIMETERS = 14 , VX_UNIT_DWGDXF_DEKAMETERS = 15 , VX_UNIT_DWGDXF_HECTOMETERS = 16 ,
VX_UNIT_DWGDXF_GIGAMETERS = 17 , VX_UNIT_DWGDXF_ASTRONOMICAL = 18 , VX_UNIT_DWGDXF_LIGHTYEARS = 19 , VX_UNIT_DWGDXF_PARSECS = 20
}
dwg dxf import options of read as units More...
enum | evxPTSHistoryType { VX_PTS_HISTORY_SUBPART = 0 , VX_PTS_HISTORY_BACKUP = 1 , VX_PTS_HISTORY_ENCAPSULATE = 2 , VX_PTS_HISTORY_NOBACKUP = 3 }
operation type stored in part's history More...
enum evxExportType {
VX_EXPORT_TYPE_IMG = 1 , VX_EXPORT_TYPE_PDF , VX_EXPORT_TYPE_GRP , VX_EXPORT_TYPE_DWG ,
VX_EXPORT_TYPE_IGES , VX_EXPORT_TYPE_STEP , VX_EXPORT_TYPE_JT , VX_EXPORT_TYPE_PARA_TEXT ,
VX_EXPORT_TYPE_PARA_BINARY , VX_EXPORT_TYPE_CAT5_PART , VX_EXPORT_TYPE_CAT5_ASM , VX_EXPORT_TYPE_HTML ,
VX_EXPORT_TYPE_STL , VX_EXPORT_TYPE_OBJ
}
export file type More...
enum evxExportExcludeGeom {
VX_EXCLUDE_CURVE = 0x1 , VX_EXCLUDE_SURFACE = 0x2 , VX_EXCLUDE_SOLID = 0x4 , VX_EXCLUDE_PLANE = 0x8 ,
VX_EXCLUDE_HATCH = 0x10 , VX_EXCLUDE_DIMEN = 0x20 , VX_EXCLUDE_TEXT = 0x40 , VX_EXCLUDE_BLANKED = 0x80
}
export exclude geometry More...
enum _evxDocAction {
VX_DOC_CREATED = 0 , VX_DOC_SAVING , VX_DOC_SAVED , VX_DOC_PRECHANGE ,
VX_DOC_CHANGED , VX_DOC_PREOPEN , VX_DOC_OPENED , VX_DOC_TITLEUPDATE
}
file action type More...
typedef enum evxImgColorMode | evxImgColorMode
export image color mode
typedef enum evxImgBkgndMode | evxImgBkgndMode
export image background mode
typedef enum evxImgRangeMode | evxImgRangeMode
export image range mode
typedef enum evxImgType | evxImgType
export image type
typedef enum evxPdfType | evxPdfType
export pdf type
typedef enum evxPdfRangeMode | evxPdfRangeMode
export pdf range mode
typedef struct svxImgData | svxImgData
data of export image file
typedef struct svxPdfData | svxPdfData
data of export pdf file
typedef struct svxSTLData | svxSTLData
data of export STL file
typedef enum evxDWGVer | evxDWGVer
version of DWG
typedef struct svxGRPData | svxGRPData
data of export GRP file
typedef enum evxExportExcludeWidthStyle | evxExportExcludeWidthStyle
exclude attribute(no color) of *.dwg/*.dxf
typedef enum evxExportExcludeColor | evxExportExcludeColor
exclude attribute(color) of *.dwg/*.dxf
typedef enum evxRemoveTextFontType | evxRemoveTextFontType
remove text font info type.
typedef struct svxDWGData | svxDWGData
data of export DWG file
typedef struct svxIGESData | svxIGESData
data of export IGEES file
typedef struct svxSTEPData | svxSTEPData
data of export STEP file
typedef enum evxJTVer | evxJTVer
version of JT
typedef struct svxJTData | svxJTData
data of export JT file
typedef struct svxPARAData | svxPARAData
data of export PARA file
typedef struct svxCAT5Data | svxCAT5Data
data of export CAT5 file
typedef struct svxHTMLData | svxHTMLData
data of export HTML file
typedef enum evxDWGDXFConvertMeshTo | evxDWGDXFConvertMeshTo
dwg dxf file import of convert polygon mesh to
typedef enum evxDWGDXFExcludeColor | evxDWGDXFExcludeColor
import dwg dxf file, exclude color
typedef enum evxImportType | evxImportType
file import type
typedef struct svxImportSTEPData | svxImportSTEPData
setting general properties if import stp/step file
typedef struct svxImportUGData | svxImportUGData
setting properties if import prt file
typedef enum evxDWGDXFReadAsUnits | evxDWGDXFReadAsUnits
dwg dxf import options of read as units
typedef struct svxImportDwgDxfData | svxImportDwgDxfData
setting properties if import dwg/dxf file
typedef struct svxImportSTLData | svxImportSTLData
setting properties if import stl file
typedef enum evxPTSHistoryType | evxPTSHistoryType
operation type stored in part's history
typedef struct svxImportPTSData | svxImportPTSData
setting properties if import points form ASCII file
typedef struct svxImportData | svxImportData
file import data
typedef struct svxOBJData | svxOBJData
data of export obj file
typedef enum evxExportType | evxExportType
export file type
typedef enum evxExportExcludeGeom | evxExportExcludeGeom
export exclude geometry
typedef enum _evxDocAction | evxDocAction
file action type
typedef struct svxDocActionParam | svxDocActionParam
file action parameters
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file_path.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_file_path.h File Reference
#include "zwapi_file_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Path API

Definition in file zwapi_file_path.h.

Path Add

evxErrors | cvxPathAdd (const vxLongPath SearchDirectory)
evxErrors | cvxPathSearchBeginAdd (const vxLongPath SearchDirectory)
evxErrors | cvxPathAddApiPath (vxName LibName, char *SubFolder)
evxErrors | cvxPathCompose (vxPath Path, const char *Name)
evxErrors | cvxPathComposeByLongPath (char *Path, int sizePath, const char *Name)
evxErrors | cvxPathCheck (const vxLongPath srcPath, char *desPath, int sizedes)

Path Set

evxErrors | cvxPathSet (const vxLongPath path)
void | cvxPathSearchFirst (const vxLongPath Directory)

Path Delete

void | cvxPathDel (const vxLongPath Path)
void | cvxPathDelAll (void)
void | cvxPathDelim (vxPath Path)
void | cvxPathDelimByLongPath (char *Path, int sizePath)

Path Query

int | cvxPathApiLib (vxName LibName, vxPath LibDirectory)
int | cvxPathApiLibByLongPath (const vxName LibName, char *LibDirectory, int sizeLib)
void | cvxPathDir (vxPath FullPath, vxPath Directory)
void | cvxPathDirByLongPath (const vxLongPath FullPath, char *Directory, int sizeDir)
void | cvxPathFile (vxPath FullPath, vxPath FileName)
void | cvxPathFileByLongPath (const vxLongPath FullPath, char *FileName, int sizeFile)
void | cvxPathFile2 (char *FullPath, int MaxNameLen, char *FileName)
int | cvxPathFind (const vxName FileName, vxPath FullPath)
int | cvxPathFindByLongPath (const vxName FileName, char *FullPath, int sizeFull)
int | cvxPathFindByFileName (const char *fileName, char *fullPath, int sizeFullPath)
void | cvxPathInstall (vxPath InstallDirectory)
void | cvxPathInstallByLongPath (char *InstallDirectory, int sizeIns)
void | cvxPathTemp (vxPath Directory)
void | cvxPathTempByLongPath (char *Directory, int sizeDir)
void | cvxPathUserFolder (vxPath Directory)
void | cvxPathUserFolderByLongPath (char *Directory, int sizeDir)
int | cvxPathIsDebug (const char *FolderName)

Path State Get/Set

void | cvxPathSearchSet (int Value)
int | cvxPathSearchGet ()
void | cvxPathCheckActiveOnlySet (int Value)
int | cvxPathCheckActiveOnlyGet ()
evxErrors | cvxFileNameLenIsOverrange (const char *file_name)
evxErrors | cvxFilePathLenIsOverrange (const char *file_path)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_general_ent.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_general_ent.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Object's(Entity) Common API

Definition in file zwapi_general_ent.h.

Entity Calculate Data

typedef struct svxAreaProp svxAreaProp
area properties

Entity New

int | cvxEntNew (int StartOp, evxEntType Type)
void | cvxEntNewList (int StartOp, evxEntType Type, int *Count, int **idEnts)
evxErrors | cvxEntNewAll (int startOp, evxEntType type, int *count, int **idEnts)

Name Tag Query

evxErrors cvxPartInqTagNames (int *Count, vxLongName **Names)

Entity State

evxErrors | cvxEntBlank (int Show, int Count, int *idEnts)
int | cvxEntIsBlanked (int idEntity)
void | cvxEntHighlight (int idEntity)
void | cvxEntUnHighlight (int idEntity)
void | cvxEntUnhighlightAll (void)
int | cvxEntExists (int idEntity, evxEntType EntType)
evxErrors | cvxEntInqSelected (int *Count, int **Ents)
evxErrors | cvxEntInqPicked (int *Count, int **Ents)
evxErrors | cvxEntInqPathSelected (int *Count, svxEntPath **Paths)
evxErrors | cvxEntInqPathPicked (int *Count, svxEntPath **Paths)
void | cvxEntUnPickAll ()
void | cvxEntUnPickLast ()
evxErrors | cvxEntUnPickByPath (const svxEntPath *path)
evxErrors | cvxEntAddPick (int idx_ent)
evxErrors | cvxEntPathAddPick (svxEntPath *entPath)
void | cvxPickDataClear ()

Entity Attribute

evxErrors | cvxEntUserAtGet (int idEnt, int *count, svxAttribute **At)
evxErrors | cvxEntUserAtSet (int idEnt, int count, svxAttribute *At)
evxErrors | cvxEntUserAtDel (int idEnt, int count, svxAttribute *At)
evxErrors | cvxEntColorGet (int idEntity, evxColor *Color)
evxErrors | cvxEntColorSet (evxColor Color, int Count, int *idEnts)
evxErrors | cvxEntRgbGet (int idEntity, svxColor *Color)
evxErrors | cvxEntRgbSet (svxColor Color, int Count, int *idEnts)
evxErrors | cvxEntRgbSetNoAt (svxColor Color, int Count, int *idEnts)
evxErrors | cvxEntTransSet (int iTrans, int Count, int *idEnts)
evxErrors | cvxEntLineAtGet (int idLine, svxLineAt *At)
evxErrors | cvxEntLineAtSet (svxLineAt *At, int Count, int *idEnts)

Entity Info Get/Set

evxErrors | cvxEntUidGet (int idEntity, svxUid *Uid)
evxErrors | cvxEntUidSet (int idEntity, const svxUid *Uid)
evxErrors | cvxPartInqEntLabel (int idEntity, int **Label)
evxErrors | cvxEntLabelGet (int idEntity, int **Label)
evxErrors | cvxEntLabelSet (int idEntity, int *Label)
evxErrors | cvxEntName (int idEntity, char *Name, int nBytes)
evxErrors | cvxEntNameSet (int idEntity, const char *Name)
evxErrors | cvxEntSetNameTag (int idx_ent, char *name)
evxErrors | cvxEntLayer (int idEntity, vxName Layer)
evxErrors | cvxEntLayerId (int idEntity, int *LayerId)
evxErrors | cvxEntMatrix (int idEntity, svxMatrix *Matrix)
evxErrors | cvxEntMatrix2 (svxEntPath Entity, svxMatrix *Matrix)
evxErrors | cvxEntMatrixSet (int idEntity, svxMatrix *Matrix)
evxErrors | cvxPartInqEntFtr (int idEntity, int *idFeature)
evxErrors | cvxEntBndBox (int idEntity, svxBndBox *Box)
evxErrors | cvxEntBndBoxByPath (svxEntPath *path, int fTartCord, svxBndBox *bndBox)
evxErrors | cvxPartInqEntBox (int idEnt, const svxMatrix *Mat, svxBndBox *Box)

Entity Find

evxErrors | cvxEntByLabel (int *Label, int Exact, int *idEntity)
evxErrors | cvxPartInqEntByLabel (int *Label, int flag, int *idEntity)
evxErrors | cvxEntByName (const char *Name, int *idEntity)
evxErrors | cvxEntByName2 (const vxLongPath File, const vxRootName Root, const vxName Name, int *idEntity)
evxErrors | cvxEntNameByPath (const svxEntPath *Path, vxLongName Name)
evxErrors | cvxEntByUid (const svxUid *Uid, int *idEntity)
evxErrors | cvxEntFind (evxEntFind EntType, svxPoint *RefPnt, int *idEntity, svxPoint *Pnt, double *Dist)
evxErrors | cvxEntFind2 (svxEntFind *Data)

Entity Type

void | cvxEntClassName (int ClassNumber, char *ClassName)
int | cvxEntClassNum (int idEntity)
int | cvxEntClassNumByPath (svxEntPath *entPath)
int | cvxEntIsCurve (int idEntity)
int | cvxEntIsElectrode (int idEntity)

Entity Query

evxErrors | cvxEntPnt (int idEntity, svxPoint *Pnt)
evxErrors | cvxEntEndPnt (int idEntity, svxPoint *Start, svxPoint *End)
void | cvxEntSketch (int idEntity, int *idSketch)
evxErrors | cvxEntParent (int idEntity, int *idParent)
evxErrors | cvxEntRefEnt (int idRefEnt, int *idEnt)
evxErrors | cvxEntGetInhSubIdx (int idx_ent, int klass, int sub_class, int *subIdx)
evxErrors | cvxEntComp (int idEntity, int *idComp, char *File, int nFileBytes, char *Parent, int nParentBytes)

Entity Edit

evxErrors cvxEntErase (svxEntPath *Ent)

Entity Pick Path Operation

int cvxEntActivate (svxEntPath *NewPath, int UpdateGUI, int *idEntity, svxEntPath *OldPath)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_global_apply.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_global_apply.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Global Tools API

Definition in file zwapi_global_apply.h.

Global Apply Data

enum evxGlobal {
VX_TOLERANCE = 1 , VX_AUTO_MERGE = 2 , VX_EXACT_MATCH = 3 , VX_LOCALCOORDIDX = 4 ,
VX_CONS_DELAY_SOLVE = 5 , VX_DIM_ATTR = 6
}
global settings More...
typedef struct svxPartDimAttr | svxPartDimAttr
part dimension attribute
typedef enum evxGlobal | evxGlobal
global settings

App Action Data

enum | _evxAppAction { VX_APP_PRECLOSE = 0 , VX_APP_STARTED }
application action type More...
typedef enum _evxAppAction | evxAppAction
application action type
typedef struct _svxAppActionParam | svxAppActionParam
application action parameter

Global Apply

evxErrors | cvxGlobalGet (evxGlobal Global, void *Data)
evxErrors | cvxGlobalSet (evxGlobal Global, void *Data)
evxErrors | cvxNoteGet (char **Note)
evxErrors | cvxNoteSet (char *Note)
void | cvxAutoRegenGet (int *Status)
void | cvxAutoRegenSet (int Status)
void | cvxLangGet (vxName Language)
void | cvxFontMap (const char *zw3dFont, vxLongName mapFont)

Unit

void | cvxUnitGet (evxUnitType *Type, vxName Name)
void | cvxUnitTypeGet (char *unit_str, char *sub_type, char *unit_type)
void | cvxUnitSet (evxUnitType Type)
void | cvxUnitToSys (double *Distance)
void | cvxUnitToUser (double *Distance)
evxErrors | cvxUnitMassGet (evxMassUnitType *type, vxName name)
evxErrors | cvxUnitMassSet (evxMassUnitType type)

Sketch Grid Spacing

evxErrors | cvxSkGridSpacingGet (double *spacing)
evxErrors | cvxSkGridSpacingSet (double spacing)

Color Utilities

void | cvxColorfToColor (const svxColorf *rgbf, svxColor *rgb)
void | cvxColorToColorf (const svxColor *rgb, svxColorf *rgbf)
evxErrors | cvxColorRGB (evxColor color, svxColor *rgb)
evxColor | cvxColorNear (const svxColor *rgb)

Escape Checking

int | cvxEscCheck (void)
void | cvxEscDisable (int *EscapeState)
void | cvxEscRestore (int EscapeState)
void | cvxEscStart (void)
void | cvxEscEnd (void)

Version

int | cvxVersion (char *vxStatus)
void | cvxVersionNum (vxLongName verNum)

Filter

void | cvxFilterListGet (int *count, vxName *filterList)
void | cvxColorFilter (int colorIdx)
evxErrors | cvxFilterActiveGet (vxName Filter)

Tools

int | cvxLabelMatch (int *Label1, int *Label2)
int | cvxNameIsOkay (char *name, int size, int option)
void | cvxHostId (double *idNetwork, double *idDongle)
void | cvxNotifyExit (int opt)
void | cvxSetMSMMoldInstalled (int IsInstalled)
void | cvxSetMSMPressInstalled (int IsInstalled)
evxErrors | cvxPluginRegPathGet (vxPath **pathList, int *pCnt, int is64)
evxErrors | cvxPluginRegPathGetByLongPath (vxLongPath **pathList, int *pCnt, int is64)
evxErrors | cvxHelpDocLoad (const vxLongPath filePath)

App Action

evxErrors cvxAppAction (evxAppAction type, svxAppActionParam *param)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_layer.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_layer.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Layer API

Definition in file zwapi_layer.h.

Layer Info Data

enum evxInfoLayerFlag {
VX_LAYER_INFOR_NAME = 0x00000001 , VX_LAYER_INFOR_DESC = 0x00000002 , VX_LAYER_INFOR_ID = 0x00000004 , VX_LAYER_INFOR_VISIBLE = 0x00000008 ,
VX_LAYER_INFOR_FREEZE = 0x000000010 , VX_LAYER_INFOR_DISABLE = 0x00000020 , VX_LAYER_INFOR_COLOR = 0x00000040 , VX_LAYER_INFOR_LINETYPE = 0x00000080 ,
VX_LAYER_INFOR_LINEWIDTH = 0x0000100 , VX_LAYER_INFOR_NUMOBJ = 0x0000200 , VX_LAYER_INFOR_FLTR = 0x0000400 , VX_LAYER_INFOR_ALL = 0xFFFFFFFF
}
layer mask information More...
typedef enum evxInfoLayerFlag | evxInfoLayerFlag
layer mask information
typedef struct svxLayerInfo | svxLayerInfo
layer information

Layer Operation

evxErrors | cvxLayerAdd (char *Name)
evxErrors | cvxLayerAdd2 (const svxLayerInfo *psLayerInfo, int *Number)
evxErrors | cvxLayerDel (vxName Name)
evxErrors | cvxLayerDel2 (int Number)
evxErrors | cvxLayerActivate (vxName Name)
evxErrors | cvxLayerSync (void)
evxErrors | cvxLayerShowAll (void)
evxErrors | cvxLayerIdModify (int srcNumber, int tarNumber)

Layer Query/Set

void | cvxLayerInqActive (vxName Name)
int | cvxLayerExists (vxName Name)
int | cvxLayerExists2 (int Number)
evxErrors | cvxLayerId (vxName name, int *id)
evxErrors | cvxLayerInqEnts (int Number, int *numEnt, svxEntPath **Paths)
evxErrors | cvxLayerAssign (char *Name, int numEnt, int *idEnts)
evxErrors | cvxLayerList (int *Count, vxName **Names)
evxErrors | cvxLayerName (int Number, vxName Name)
evxErrors | cvxLayerNum (vxName Name, int *Number)
evxErrors | cvxLayerGetAllCategory (int *numCate, vxLongName **categories)
evxErrors | cvxActiveLayerNumGet (int *Number)
evxErrors | cvxActiveLayerNumSet (int Number)
evxErrors | cvxLayerStateGet (vxName Name, int *isVisible, int *isFrozen)
evxErrors | cvxLayerStateSet (vxName Name, int isVisible, int isFrozen)

Layer Information

evxErrors | cvxLayerInfoGet (int Number, svxLayerInfo *pLayerInfo)
evxErrors | cvxLayerInfoSet (int Number, const svxLayerInfo *pLayerInfo)
evxErrors | cvxLayerInfoExport (const vxLongPath file)
evxErrors | cvxLayerInfoImport (const vxLongPath file, int overWrite)
void | cvxLayerRefresh ()
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_license.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_license.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D License API

Definition in file zwapi_license.h.

License

evxErrors | cvxLicModulesGet (char szModules[1024])
evxErrors | cvxLicIdentifierGet (char szIdentifier[36])
int | cvxLicEvaluationGet (char szEvaluation[36])
int | cvxLicStandaloneEvaluationGet ()
evxErrors | cvxLicActivate (const char *pzEntitlement)
evxErrors | cvxLicRemove (const char *pzEntitlement)
int | cvxLicTypeCheck ()
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Math API

Definition in file zwapi_math.h.

Round Number

double cvxRoundNumber (double Num, double Step, double Tol, int Dir)

Parallel Check

evxErrors cvxCrvPlaneParallelChk (const svxPoint *plnPnt, const svxVector *plnNormal, const svxCurve *Crv, double tol, int *isParallel, double *Distance)

Distance Computes

evxErrors | cvxAxisDistance (const svxAxis *Axis1, const svxAxis *Axis2, svxPoint *PntOnAxis1, svxPoint *PntOnAxis2, int *Flag)
evxErrors | cvxAxisCrvDistance (const svxAxis *Axis, const svxCurve *Crv, svxPoint *pntOnAxis, svxPoint *pntOnCrv, double *Distance)
evxErrors | cvxPlaneDistance (const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, double *Distance)
evxErrors | cvxEntGetDistance (int ent1, int ent2, svxPoint *p1, svxPoint *p2, double *dist)
evxErrors | cvxEntGetDistanceByPath (svxEntPath *EntPath1, svxEntPath *EntPath2, svxPoint *Point1, svxPoint *Point2, double *MinDistance)

Entity Calculate

evxErrors | cvxEntGetAngle (int ent1, int ent2, double *angle)
evxErrors | cvxPartInqEntsArea (int cnt, int *crvList, svxAreaProp *areaProp)
evxErrors | cvxPartInqEntsAreaByPath (int cnt, svxEntPath *crvList, svxAreaProp *areaProp)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_bndbox.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_bndbox.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Bounding Box API

Definition in file zwapi_math_bndbox.h.

Bounding Box

void | cvxBndBoxInit (svxBndBox *Box)
void | cvxBndBoxInit2 (svxBndBox *Box)
void | cvxBndBoxPnts (svxBndBox *Box, svxPoint *Pnts)
evxErrors | cvxBndBoxCenter (const svxBndBox *Box, svxPoint *CenterPnt)
evxErrors | cvxBndBoxPntLoc (const svxBndBox *Box, const svxPoint *Point, evxPntLocation *PntLoc)
void | cvxBndBoxAdd (svxBndBox *Box, svxPoint *Pnt)
void | cvxBndBoxMerge (const svxBndBox *Box1, svxBndBox *Box2)
double | cvxBndBoxSize (svxBndBox *Box)
double | cvxBndBoxVolume (const svxBndBox *Box)
int | cvxBndBoxContain (const svxBndBox *BaseBox, const svxBndBox *OtherBox)

Bounding Box Distance

evxErrors | cvxBndBoxPntDist (const svxBndBox *Box, const svxPoint *Point, double *DistMin, double *DistMax)
evxErrors | cvxBndBoxDist (const svxBndBox *Box1, const svxBndBox *Box2, double *DistMin, double *DistMax)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the All Math functions.

Definition in file zwapi_math_data.h.

Intersection of Curve/Face Data

enum | evxFaceTrim { VX_TRIM_NONE = 0 , VX_TRIM_ALL = 1 , VX_TRIM_OUTER = 2 }
face trim-curve option More...
typedef enum evxFaceTrim | evxFaceTrim
face trim-curve option

Surface Find Face/Edge Data

enum evxFaceFindType {
VX_FIND_BOSS , VX_FIND_POCKET , VX_FIND_HOLE , VX_FIND_FILLET ,
VX_FIND_CUSTOM , VX_FIND_FINDER
}
face search types More...
enum evxEdgeLoopType {
VX_EDGE_LOOP_INNER = 0 , VX_EDGE_LOOP_OUTER = 1 , VX_EDGE_LOOP_ALL = 2 , VX_EDGE_LOOP_SHARED = 3 ,
VX_EDGE_LOOP_BOUNDARY = 4
}
type of loop in which the edge is located More...
typedef enum evxFaceFindType | evxFaceFindType
face search types
typedef struct svxFaceFind | svxFaceFind
face search data
typedef enum evxEdgeLoopType | evxEdgeLoopType
type of loop in which the edge is located

Curve Evaluate Data

typedef struct svxEvalCurv svxEvalCurv
curve evaluate
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_insect.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_insect.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Intersection API

Definition in file zwapi_math_insect.h.

Curve And Curve/Face

evxErrors | cvxIsectCrvCrv (int idCurve1, int idCurve2, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectCrvFace (int idCurve, int idFace, int Trim, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectFaceFace (int idFace1, int idFace2, evxFaceTrim Trim, int TangentOk, int *Count, svxCurve **Curves)

Ray With Objects

evxErrors | cvxIsectRayCrv (svxAxis *Ray, int idCurve, int TangentOk, int *Count, svxPoint **Points)
evxErrors | cvxIsectRayFace (int idFace, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, svxPoint2 *UV)
evxErrors | cvxIsectRayFaceInfinite (int idFace, evxFaceTrim Trim, const svxAxis *Ray, int Infinite, int *Number, svxPoint **Pnts, svxPoint2 **UVs)
int | cvxIsectRayPlane (svxAxis *Ray, svxMatrix *Plane, svxPoint *Point)
evxErrors | cvxIsectRayShape (int idShape, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayShapes (int nShapes, int *idShapes, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, int **idFaces)
evxErrors | cvxIsectRayPart (evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayPartVis (evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
evxErrors | cvxIsectRayComp (int idComp, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point)
evxErrors | cvxIsectRayComps (int nComps, svxEntPath *CompPaths, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, svxEntPath **FacePaths)
evxErrors | cvxCompFind (evxFaceTrim Trim, svxAxis *Ray, double Dist, int SkipBlank, int *Count, int **Comps)
int | cvxIsectRayBndBox (const svxAxis *Ray, const svxBndBox *Box, svxPoint *IsectPnt)

Intersecting of Shapes

int | cvxPartIsectShpChk (int idBaseShape, int idOpShape)
int | cvxPartIsectShpChk2 (int idBaseShape, int idOpShape, int fClosedChk)
int | cvxCompIsectShpShp (const svxEntPath *basePath, const svxEntPath *opPath, evxFaceTrim trim, int *count, svxCurve **curves)

Intersecting of bounding box and plane

int | cvxIsectBndBoxBndBox (const svxBndBox *Box1, const svxBndBox *Box2)
int | cvxIsectBndBoxPlane (const svxBndBox *Box, const svxPoint *PntOnPln, const svxVector *NormalOfPln)
int | cvxIsectPlanePlane (const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, svxAxis *IsectLine)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_matrix.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_matrix.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Matrix API

Definition in file zwapi_math_matrix.h.

Transformation Matrix

evxErrors | cvxMatEigen (const double Mat3x3[3][3], double *Values, svxVector *Vectors)
void | cvxMatInit (svxMatrix *Mat)
void | cvxMatInvert (svxMatrix *Mat, svxMatrix *InvMat)
void | cvxMatMult (svxMatrix *Mat1, svxMatrix *Mat2, svxMatrix *Mat3)
void | cvxMatPntVec (svxPoint *Origin, svxVector *zAxis, svxMatrix *Mat)
evxErrors | cvxMatPntVecs (svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxMatrix *Mat)
evxErrors | cvxMatGetPntVecs (const svxMatrix *Mat, svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxVector *zAxis)
void | cvxMatRotate (svxMatrix *Mat, double Angle, svxAxis *Axis)
void | cvxMatScale (svxMatrix *Mat, svxPoint *Point, double sX, double sY, double sZ)
void | cvxMatSetIdentity (svxMatrix *Mat)
void | cvxMatTransform (svxMatrix *Mat, svxMatrix *Frame)
void | cvxMatTranslate (svxMatrix *Mat, double dX, double dY, double dZ)
void | cvxMatView (svxMatrix *Mat, evxViewStd Type)
evxErrors | cvxMatToEuler (evxEulerAngSeq Seq, svxMatrix *pMat, svxMatEuler *pzMatEuler)
evxErrors | cvxMatFromEuler (evxEulerAngSeq Seq, const svxMatEuler *pzMatEuler, svxMatrix *pMat)

Object Transformation

void | cvxPntTransform (svxMatrix *Mat, svxPoint *Point)
void | cvxPntTransformList (svxMatrix *Mat, int Count, svxPoint *Points)
void | cvxAxisTransform (svxMatrix *Mat, svxAxis *Axis)
void | cvxVecTransform (svxMatrix *Mat, svxVector *Vector)
void | cvxCrvTransform (svxMatrix *Mat, svxCurve *Crv)
void | cvxSrfTransform (svxMatrix *Mat, svxSurface *Srf)
void | cvxBndBoxTransform (svxMatrix *Mat, svxBndBox *Box)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_nurbscurve.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_nurbscurve.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Nurbs Curve API

Definition in file zwapi_math_nurbscurve.h.

Curve Evaluate

evxErrors | cvxCrvEval (int idCurve, double T, svxPoint *Point, svxVector *Normal)
evxErrors | cvxCrvEval2 (const int idCurve, const double t, const int level, svxEvalCurv *eval)
evxErrors | cvxPreEdgeEval (const int idPreEdge, const double t, const int level, svxEvalCurv *eval)
evxErrors | cvxCrvEvalCrvtr (const int idCurve, const double t, svxPoint *point, svxPoint *normal, double *curvature)

Curve Query

int | cvxCrvIsLine (int idCurve)
evxErrors | cvxCrvParam (int idCurve, svxLimit *T)
evxErrors | cvxCrvMinMaxRad (int idCurve, double *minRad, double *maxRad, int *isFlat)
evxErrors | cvxCrvInqContinuity (int Count, int *Curves, int *Continuity)
evxErrors | cvxCrvContinuityTolListInit (svxCrvContinuityTolList *data)
evxErrors | cvxCrvInqMultiContinuity (int cnt, const int *curves, const svxCrvContinuityTolList *tols, int *cntContinuity, svxCrvContinuityData **data)
evxErrors | cvxPartCurveChainFind (int nSeeds, int *idSeeds, int type, int *Count, int **idCrvs)

Curve Point

evxErrors | cvxCrvGetPntAtLenFraction (int idCurve, double Fraction, svxPoint *Point)
evxErrors | cvxCrvPntProj (int idCurve, svxPoint *Pnt, double *T, svxPoint *ProjPnt)
evxErrors | cvxCrvGetPntAtDist (int idCurve, double StartT, double Length, double *T, svxPoint *Point)
evxErrors | cvxCrvGetInflections (int idCurve, int *Count, double **T, svxPoint **InfPnts)
evxErrors | cvxCrvInqExtreme (int idCurve, const svxVector *Dir, int *isPerp, svxPoint *Point)
evxErrors | cvxCrvExtremum (int idCurve, int *Count, svxPoint **Pnts, svxBndBox *BndBox)
evxErrors | cvxCrvGetCusps (int idCurve, int *Count, double **T, svxPoint **Cusps)

Curve Length

evxErrors | cvxCrvLen (int idCurve, double *Len)
evxErrors | cvxCrvLen2 (int idCurve, double T1, double T2, double *Length)

Edge Sew

evxErrors cvxPartSew (double Tol, int *OpenEdges, double *MaxGap)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_nurbssurface.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_nurbssurface.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Nurbs Surface API

Definition in file zwapi_math_nurbssurface.h.

Surface Edit

evxErrors | cvxPartFace (svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Code, int Sew, double Tol, int *idFace)
evxErrors | cvxPartFaceMod (int idFace, svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Sew, double Tol)

Surface Evaluate

evxErrors | cvxSrfEval (svxSurface *Srf, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
evxErrors | cvxSrfDiameterEval (svxSurface *Srf, double U, double V, double *Diameter)

Surface Find Face/Edge

evxErrors | cvxPartFaceFind (svxFaceFind *findData, int *Count, int **idFaces)
evxErrors | cvxPartFaceEdgesFind (int nSeeds, int *idSeeds, evxEdgeLoopType type, int *Count, int **idEdges)

Surface Query

evxErrors | cvxSrfAxis (svxSurface *Srf, svxPoint *startPnt, svxPoint *endPnt)
evxErrors | cvxSrfGetPole (svxSurface *srf, const svxPoint *dir, svxPoint *pnt)
int | cvxSrfFindPoles (svxSurface *srf, double tol, int poles[4])
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_point.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_point.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Point Math API

Definition in file zwapi_math_point.h.

Point On Entity

int | cvxPntIsCritical (svxPoint *pnt, int idCurve)
int | cvxPntIsOn (svxPoint *Pnt, int idEntity)
evxErrors | cvxPntOnCrv (int idCurve, double Fraction, svxPoint *Point)
evxErrors | cvxPntOnFace (int idComp, int idFace, double Param[2], svxPoint *Point)
evxErrors | cvxPntProject (svxPoint *Pnt, int idEntity, svxPoint *ProjPnt)
evxErrors | cvxPntEntLoc (svxPoint *Pnt, int idEntity, evxPntLocation *PntLoc)
evxErrors | cvxAxisPntProject (const svxAxis *Axis, const svxPoint *Pnt, svxPoint *ProjPnt)
int | cvxPlanePntProject (const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, const svxVector *ProjectDir, svxPoint *ProjPnt)

Point Distance

void | cvxPntTranslate (svxPoint *Point, svxVector *Vector, double Distance)
double | cvxPntDist (const svxPoint *Point1, const svxPoint *Point2)
evxErrors | cvxPntEntDist (const svxPoint *Point, int idEntity, svxPoint *TargetPnt, double *Distance)
evxErrors | cvxPntPreEdgeDist (const svxPoint *Point, int idPreEdge, double *T, svxPoint *TargetPnt, double *Distance)
evxErrors | cvxAxisPntDistance (const svxAxis *Axis, const svxPoint *Pnt, double *Distance)
evxErrors | cvxPlanePntDistance (const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, double *Distance, svxPoint *ProjPnt)

Point Evaluation

evxErrors | cvxAxisEvalPoint (const svxAxis *Axis, double Distance, svxPoint *Point)
evxErrors | cvxPlaneEvalPoint (const svxPoint *Origin, const svxVector *xAxis, const svxVector *yAxis, double xDist, double yDist, svxPoint *Point)

Plane/Polygon

int | cvxPlnThruPnts (int PntCount, svxPoint *PntList, svxVector *Normal, double *D)
evxErrors | cvxPolyToTri (int PntCount, svxPoint *PntList, int *VtxCount, int **VtxList)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_vector.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_math_vector.h File Reference
#include "zwapi_math_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Vector API

Definition in file zwapi_math_vector.h.

Vector

void | cvxVecInit (svxPoint *Point1, svxPoint *Point2, svxVector *Vector)
void | cvxVecNormalize (svxVector *Vector)
void | cvxVecAngle (svxVector *V1, svxVector *V2, double *Angle)
void | cvxVecCross (svxVector *V1, svxVector *V2, svxVector *Cross)
void | cvxVecPerp (svxVector *Vector, svxVector *Perp)
void | cvxVecReverse (svxVector *Vector)
int | cvxVecParallelChk (int Orient, svxVector *V1, svxVector *V2, double CosTol)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_memory.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_memory.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Memory API

Definition in file zwapi_memory.h.

Memory Allocate

evxErrors | cvxMemAlloc (int NumBytes, void **MemPointer)
evxErrors | cvxMemResize (int NumBytes, void **MemPointer)

Memory Zero

void cvxMemZero (void *MemPointer, int NumBytes)

Memory Free

void cvxMemFree (void **MemPointer)
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_message.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_message.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Message API

Definition in file zwapi_message.h.

Message Disable Data

enum | evxDialogType { VX_DIALOG_SAVE_AS = 1 }
dialog form type of user prompt More...
typedef enum evxDialogType | evxDialogType
dialog form type of user prompt

Message Disable

void | cvxErrDisable (void)
void | cvxErrEnable (void)
void | cvxMsgDisable (void)
void | cvxMsgEnable (void)
void | cvxLastWarningMsgEnable (int enable)
void | cvxPromptDisable (void)
void | cvxPromptEnable (void)
void | cvxTranStatusDisable (void)
void | cvxTranStatusEnable (void)
void | cvxUserActionStatusGet (int *disableStatus)
void | cvxUserActionStatusSet (int disable)
void | cvxCrashPromptDisable ()
void | cvxCrashPromptEnable ()
int | cvxUserActionStatusSet2 (evxDialogType type, int value)

Message Area State

void | cvxMsgAreaClose (void)
void | cvxMsgAreaOpen (void)
void | cvxMsgAreaState (int)
evxErrors | cvxMsgAreaStateGet (int *action)

Message Display

evxErrors | cvxMsgFileLoad (const vxLongPath File, int *idFile)
char * | cvxMsgPtr (int idFile, int MessageNum)
void | cvxMsgDisp (char *Text)
void | cvxMsgDisp2 (char *Text, int level)
evxErrors | cvxMessageBox (int MsgType, int WndMode, const char *Title, const char *Message, const char *Btn1Str, const char *Btn2Str, int *Action)

Function Fail Message

evxErrors cvxLastErrGet ()
void | cvxLastErrSet (evxErrors error)
const char * | cvxErrMsgGet (evxErrors error)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_attribute.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_attribute.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Attribute API

Definition in file zwapi_part_attribute.h.

Part Physical Attribute

evxErrors | cvxPartMassProp (void)
evxErrors | cvxPartCalcAttrGet (int idPart, svxPartCalcAttrData *attr)
evxErrors | cvxPartPhyAttrCalc (vxRootName Name)
evxErrors | cvxPartVolumAndMassGet (vxRootName Name, double *dVolume, double *dMass)
evxErrors | cvxPartMaterialGet (const vxLongPath fileName, const vxRootName rootName, const vxLongName material, svxPartMaterial *data)
evxErrors | cvxPartMaterialSet (const vxLongPath fileName, const vxRootName rootName, const vxLongName material, const svxPartMaterial *data)
evxErrors | cvxPartMaterialDel (const vxLongPath fileName, const vxRootName rootName, const vxLongName material)

Part Attribute

evxErrors | cvxPartAtGet (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartAtMod (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartAtSet (vxRootName Name, svxPartAttribute *At)
evxErrors | cvxPartShowPartAt (const vxLongPath File, const vxRootName Root)
void | cvxPartClosePartAt ()
evxErrors | cvxPartAtItemGet (evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemSet (evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemGetInFile (const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemSetInFile (const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
evxErrors | cvxPartAtItemDel (evxAtItemId itemId, vxLongName label)
evxErrors | cvxPartAtItemDesGet (evxAtItemId itemId, char *AtLable, char *AtDes, int nBytes)
evxErrors | cvxPartAtItemDesSet (evxAtItemId itemId, char *AtLable, char *AtDes)
evxErrors | cvxPartAtItemLockGet (char *AtLable, evxAtItemLockStatus *AtLockState)
evxErrors | cvxPartAtItemLockSet (char *AtLable, evxAtItemLockStatus AtLockState)
evxErrors | cvxPartAtItemLockGetInFile (const vxLongPath File, const vxRootName Root, char *AtLable, evxAtItemLockStatus *AtLockState)
evxErrors | cvxPartAtItemLockSetInFile (const vxLongPath File, const vxRootName Root, const char *AtLable, evxAtItemLockStatus AtLockState)
evxErrors | cvxPartUserAtGet (const vxLongPath File, const vxRootName Root, int *Count, svxAttribute **UserAt)
evxErrors | cvxPartUserAtSet (const vxLongPath File, const vxRootName Root, int DelOrgAt, int Count, svxAttribute *UserAt)
evxErrors | cvxPartUserAtExport (const vxLongPath filePath)

Part Custom String

evxErrors | cvxPartSetCustomStr (int idEnt, const char *CustomString, int *idStr)
evxErrors | cvxPartGetCustomStr (int idEnt, int *idStr, char **CustomString)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_config.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_config.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Config API

Definition in file zwapi_part_config.h.

Part Config Activate

evxErrors | cvxPartCfgTblAdd (vxName cfgName, char *cfgDes, int *idCfg)
evxErrors | cvxPartCfgActivate (int idCfg)
evxErrors | cvxPartInqActiveCfg (int *idCfg)
evxErrors | cvxPartInqActiveCfgByName (const vxLongPath fileName, const vxRootName rootName, int *idCfg)

Part Config Query

evxErrors | cvxPartInqCfgList (int *Count, int **CfgList)
evxErrors | cvxPartInqCfgListByName (const vxLongPath fileName, const vxRootName rootName, int *count, int **cfgList)

Part Config Info

evxErrors | cvxCfgTblInfosSet (int idCfg, svxPartCfgInfo *info)
evxErrors | cvxPartInqCfgTblInfos (int idCfg, svxPartCfgInfo **partCfg)
evxErrors | cvxPartInqCfgTblInfosByName (const vxLongPath fileName, const vxRootName rootName, int idCfg, svxPartCfgInfo **partCfg)
void | cvxPartFreeCfgTbl (svxPartCfgInfo **cfginfo)
evxErrors | cvxPartCfgTblAttrSet (int markDel, int idCfg, int cnt, evxAtItemId *types, svxAttribute *attrs)
evxErrors | cvxPartCfgTblColorSet (int markDelClr, int idCfg, svxColor color)
evxErrors | cvxPartCfgTblInstNameSet (int markDelInstName, int idCfg, vxLongName instanceName)
evxErrors | cvxPartCfgTblVarsSet (int markDelVars, int idCfg, int cnt, svxVariable *vars)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Data Types and Structures of the functions of Part objects.

Definition in file zwapi_part_data.h.

Feature Query Data

enum evxFtrRegenStatus {
VX_FTR_REGEN_DEFAULT , VX_FTR_REGEN_LINK_LOST , VX_FTR_REGEN_PARTIAL_INP_LOST , VX_FTR_REGEN_VAR_LOST ,
VX_FTR_REGEN_ENT_LOST , VX_FTR_REGEN_OVER_CONSTRAINT , VX_FTR_REGEN_UNDER_CONSTRAINT
}
regen status of feature More...
typedef enum evxFtrRegenStatus evxFtrRegenStatus
regen status of feature

Part Physical Attribute Data

enum | evxAtItemLockStatus { VX_AT_ITEM_UNLOCKED = 0 , VX_AT_ITEM_LOCKED , VX_AT_ITEM_LIMITED }
Locking state of attribute item. More...
typedef struct svxPartCalcAttrData | svxPartCalcAttrData
part physical attributes data
typedef struct svxPartMaterial | svxPartMaterial
Part material physical attributes.
typedef enum evxAtItemLockStatus | evxAtItemLockStatus
Locking state of attribute item.

Block Data

enum | evxBlockType { VX_BLOCK_UNDEFINED = 0 , VX_BLOCK_FACETS = 1 , VX_BLOCK_POINTS = 2 }
3D Block Type More...
enum | evxRefineFacetsTolType { VX_FACETS_TOL_PIXEL , VX_FACETS_TOL_DISTANCE , VX_FACETS_TOL_ANGLE }
tolerance type of refine facets More...
typedef struct svxSTL | svxSTL
3D STL facets
typedef enum evxBlockType | evxBlockType
3D Block Type
typedef enum evxRefineFacetsTolType | evxRefineFacetsTolType
tolerance type of refine facets
typedef struct svxRefineFacets | svxRefineFacets
refine facets data

Part Config Info Data

enum evxCfgThreadCmd {
VX_NO_CMD = 0 , VX_FTHOLEMAIN = 1 , VX_FTTWKHOLE = 2 , VX_FTASSEMHOLE = 3 ,
VX_FTHOLEASGN = 4 , VX_CDHOLEPLUG = 5 , VX_CDTHRDADD = 6
}
Hole type. More...
enum evxCfgTblMethod {
VX_CFGTBL_MEHTOD_FTR , VX_CFGTBL_MEHTOD_FTRDIM , VX_CFGTBL_MEHTOD_FTRVDATA , VX_CFGTBL_MEHTOD_PROFDIM ,
VX_CFGTBL_MEHTOD_VAR , VX_CFGTBL_MEHTOD_ATTR , VX_CFGTBL_MEHTOD_PARTCOLOR , VX_CFGTBL_MEHTOD_THREAD ,
VX_CFGTBL_MEHTOD_THREADDEP , VX_CFGTBL_MEHTOD_COMPPARTCFG , VX_CFGTBL_MEHTOD_COMPSUPP , VX_CFGTBL_MEHTOD_COMPCOLOR ,
VX_CFGTBL_MEHTOD_ALIGNSUPP , VX_CFGTBL_MEHTOD_ALIGNVALUE
}
configuration item method More...
enum evxPMIEntType {
VX_PMI_ALL = 0x0000 , VX_PMI_DIM = 0x0001 , VX_PMI_NOTE = 0x0002 , VX_PMI_DTMF = 0x0004 ,
VX_PMI_DTMT = 0x0008 , VX_PMI_FCS = 0x0010 , VX_PMI_CLCM = 0x0020 , VX_PMI_SYMSRF = 0x0040 ,
VX_PMI_SYMWELD = 0x0080 , VX_PMI_TABLE = 0x0100 , VX_PMI_SYMBLK = 0x0200
}
PMI entity type. More...
typedef enum evxCfgThreadCmd | evxCfgThreadCmd
Hole type.
typedef struct svxCf | svxCf
conversion factor
typedef struct svxPartCfgInfo | svxPartCfgInfo
config table infos
typedef enum evxCfgTblMethod | evxCfgTblMethod
configuration item method
typedef enum evxPMIEntType | evxPMIEntType
PMI entity type.

Sheet Metal Attribute Data

enum evxSmdSurfaceType {
VX_SMD_SURF_NONE , VX_SMD_SURF_OTHER , VX_SMD_SURF_SIDE , VX_SMD_SURF_FLANGE_STAT ,
VX_SMD_SURF_FLANGE_STAT_PAIR
}
Sheet Metal surface type. More...
typedef enum evxSmdSurfaceType evxSmdSurfaceType
Sheet Metal surface type.

Datum Data

enum | evxPlaneType { VX_PLANE_TYPE_XY = 1 , VX_PLANE_TYPE_YZ = 2 , VX_PLANE_TYPE_XZ = 3 }
type of plane More...
typedef enum evxPlaneType | evxPlaneType
type of plane

Edge Display Data

typedef struct svxEdgeDispData svxEdgeDispData
edge display data
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_datum_query.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_datum_query.h File Reference
#include "zwapi_cmd_datum_data.h"
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Datum Query API

Definition in file zwapi_part_datum_query.h.

Axis Query

evxErrors | cvxPartInqAxis (int *Count, int **Axis)
evxErrors | cvxAxisInqDir (int idAxis, svxPoint *pPnt, svxPoint *pDir)
evxErrors | cvxAxisGetData (int idAxis, svxAxisData *Axis)
evxErrors | cvxAxisLengthGet (int idAxis, double *Length)
evxErrors | cvxAxisLengthSet (int idAxis, double Length)

Datum Query

evxErrors cvxPlaneGetData (int idPlane, svxPlaneData *Plane)

CSYS Query

evxErrors | cvxPartInqCsys (int *Count, int **Csys)
evxErrors | cvxPartInqDefaultCSYS (int *CSYS)
evxErrors | cvxPartInqCSYSAxis (int idCSYS, evxAxisType AxisType, int *idAxis)
evxErrors | cvxPartInqCSYSPlane (int idCSYS, evxPlaneType PlnType, int *idPlane)
evxErrors | cvxCSYSGetData (int idCSYS, svxCSYSData *CSYS)
void | cvxPartInqLCSMat (svxMatrix *mat)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_dim.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_dim.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Dimension API

Definition in file zwapi_part_dim.h.

Dimension

evxErrors | cvxPartInqDims (const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
evxErrors | cvxPartInqPMIDimEnts (int idDim, int *Count, svxEntPath **EntPaths)
evxErrors | cvxPartInqDimIdxs (const vxLongPath File, const vxRootName Part, int *Count, int **IdList)

PMI

evxErrors | cvxPartInqPMIs (evxPMIEntType type, int *count, int **idPMIs)
evxErrors | cvxPMIInqType (int idPMI, evxPMIEntType *type)
evxErrors | cvxPMIInqBaseEnt (int idPMI, int *idBaseObj)
evxErrors | cvxPMIInqAssoEnts (int idPMI, int *count, svxEntPath **entPaths)
evxErrors | cvxPMIInqValid (int idPMI, int *isValid)

Symbol

evxErrors | cvxSymInqRefPnt (int idSym, svxPoint *RefPnt)
evxErrors | cvxSymInqLeadLines (int idSym, int *count, svxCurve **LeadCrvs)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_facets.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_facets.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Facets/Part Block API

Definition in file zwapi_part_facets.h.

Block Creation

int | cvxPartPntBlock (vxLongName Name, int Count, svxPointf *Points, int *idEnt)
evxErrors | cvxPartFacets (vxLongName Name, svxFacets *Facets, int *idBlock)
evxErrors | cvxPartFacetsBySTL (const vxLongName name, const svxSTL *stl, int *idBlock)

Block Query

evxErrors | cvxPartInqBlocks (int *Count, int **Blocks)
evxErrors | cvxPartInqBlockPnts (int idBlock, int *Count, svxPointf **Points)
evxErrors | cvxPartInqBlockType (int idBlock, evxBlockType *Type)
evxErrors | cvxPartInqFacets (int idBlock, svxSTL *Stl)
evxErrors | cvxPartInqFacets2 (int idBlock, svxFacets *Facets)
evxErrors | cvxPartInqFacetsTxFile (int idBlock, vxPath Path)
evxErrors | cvxPartInqFacetsTxFileByLongPath (int idBlock, char *Path, int sizePath)

Facets Block Edit

evxErrors | cvxPartFacetsMod (int idBlock, svxFacets *Facets)
evxErrors | cvxPartFacetsSetAt (int idBlock, const svxFaceAt *At)
evxErrors | cvxPartFacetsSetTx (int idBlock, const svxTextureAt *Tx)
evxErrors | cvxPartProjStl (int idStl, int idPln, double tol, double smth, int *idCurve)

Face Facets

evxErrors | cvxPartInqFaceFacets (int idFace, int *Count, svxTriangle **Facets)
evxErrors | cvxPartInqFaceFacets2 (int idFace, svxFacets *Facets)
evxErrors | cvxPartInqFaceFacetsByChord (int idFace, double ChordHeight, int *Count, svxTriangle **Facets)
evxErrors | cvxPartRefineFacetsInit (svxRefineFacets *data)
evxErrors | cvxPartInqFaceFacets2ByTol (svxRefineFacets *RefineData, svxFacets *Facets)

svxFacets and svxSTL Convert

evxErrors | cvxPartFacetsConvertToSTL (const svxFacets *facets, svxSTL *stl)
evxErrors | cvxPartSTLConvertToFacets (const svxSTL *stl, svxFacets *facets)

Facets Free

void | cvxFacetsFree (svxFacets *Facets)
void | cvxStlFree (svxSTL *Stl)

Edge Display data

evxErrors | cvxPartEdgeDispData (int idEdge, svxEdgeDispData *data)
void | cvxPartEdgeDispDataFree (svxEdgeDispData *data)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_history.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_history.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part History Object API

Definition in file zwapi_part_history.h.

History Regeneration

int | cvxPartRegenIsActive (void)
int | cvxPartRedefineIsActive (void)
evxErrors | cvxPartRegenFacets (int Count, int *idFaces, int Assembly, int LOD, double Tol)
void | cvxPartPartialResults (int Disable)

History Query

evxErrors | cvxPartHistList (int Option, int *Cnts, int **HistList)
evxErrors | cvxPartInqFtrList (int *Count, int **Features)

Feature Query

int | cvxFtrIsSubPart (int idFtr)
int | cvxPartFtrIsMissRef (int idFeature, char *status)
int | cvxPartInqFtrAssoPart (int idFeature, vxPath file, vxRootName rootName)
int | cvxPartInqFtrAssoPartByLongPath (int idFeature, char *file, int sizeFile, char *rootName, int sizeRName)
int | cvxPartInqFtrData (int idFeature, int iNoEval, int *idData)
int | cvxPartFtrInqAuxFtrs (int idFtr, int *count, int **idAuxFtrs)
evxErrors | cvxPartInqFtrTemplate (int idFeature, vxName Template)
evxErrors | cvxPartInqFtrTol (int idFeature, double *Tolerance)
evxErrors | cvxPartInqFtrRegenStat (int idFeature, char *stat)
evxErrors | cvxPartInqFtrRegenStatus (int idFtr, evxFtrRegenStatus *status)
evxErrors | cvxPartInqFtrVersion (int idFeature, int *Version)
evxErrors | cvxPartInqFtrGroup (int idFeature, int *idGroup)

Group Features

evxErrors | cvxPartInqGroupFtrs (int idGroup, int *count, int **ftrList)
evxErrors | cvxPartInqGroupList (int *count, int **groups)

Feature's Parent/Child Features

evxErrors | cvxPartInqFtrParentFtrs (int idFeature, int getAll, int *cnt, int **list)
evxErrors | cvxPartInqFtrChildFtrs (int idFeature, int *cnt, int **list)

Feature's Entities

evxErrors | cvxPartFtrInqInpEnts (int idFeature, evxEntType type, int *cnt, int **list)
evxErrors | cvxPartInqFtrEnts (int idFeature, evxEntType EntType, int *Count, int **Ents)

Feature/Sketch Attribute

evxErrors | cvxPartFtrUserAtGet (int idFeature, int *Count, svxAttribute **UserAt)
evxErrors | cvxPartFtrUserAtSet (int idFeature, int Count, svxAttribute *UserAt)
evxErrors | cvxPartFtrUserAtDel (int idFeature, int Count, svxAttribute *UserAt)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_hole.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_hole.h File Reference
#include "zwapi_cmd_shape_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Hole Data API

Definition in file zwapi_part_hole.h.

Part Hole

evxErrors | cvxPartInqHoles (const vxLongPath File, const vxRootName Part, int *Count, svxHoleData **Holes)
void | cvxPartFreeHoles (int Count, svxHoleData **Holes)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_objs.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_objs.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Objects Query API

Definition in file zwapi_part_objs.h.

Curve

evxErrors | cvxPartInqCurves (int *Count, int **Curves)
evxErrors | cvxPartInqCrvLists (int *Count, int **CrvLists)
evxErrors | cvxPartInqCrvList (int idCrvList, int *Count, svxEntPick **Curves)
evxErrors | cvxPartInqCurve (int idEntity, int Nurb, svxCurve *Crv)
void | cvxCurveFree (svxCurve *Crv)

Point

evxErrors cvxPartInqPoints (int *count, int **pointIdx)

Text Query

evxErrors | cvxPartInqAnnoTexts (int *Count, int **Texts)
evxErrors | cvxPartInqTexts (int *count, int **idTexts)

Other Objects

evxErrors | cvxPartInqConstraints (const vxLongPath File, const vxRootName Part, int *count, int **cons)
evxErrors | cvxPartInqTempData (int idPart, int *count, int **datas)

Publish Set

evxErrors | cvxPartInqPublishSets (const vxLongPath File, const vxRootName Part, int *Count, int **idPubSets)
evxErrors | cvxPartInqPublishSet (const vxLongPath File, const vxRootName Part, int idPubSet, vxName Name, int *Count, int **idEnts)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_opts.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_opts.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Menu Commands API

Definition in file zwapi_part_opts.h.

Part Exit

void cvxPartExit (void)

Explicit Operation

evxErrors | cvxPartBackup (void)
evxErrors | cvxHistBackup (void)
evxErrors | cvxPartEncapsulate (int Option, int KeepDimen)
evxErrors | cvxPartHistStart (vxName Name)
evxErrors | cvxPartHistEnd (void)

History Operation

evxErrors | cvxHistRedefine (vxName Operation)
evxErrors | cvxHistSkipTo (char *Expression, vxName Operation, int *idOp)
evxErrors | cvxPartFtrPlayTo (int idxFtrPlayTo, int state)
evxErrors | cvxPartFtrSuppress (int count, int *idFeatures, char suppress)
evxErrors | cvxPartHistGroup (int idFirst, int idLast, const vxName Name, int Close)
evxErrors | cvxPartHistInqGroup (int idHistObj, int *idGroup)
evxErrors | cvxPartHistPaste (void)
evxErrors | cvxPartHistClip (int Cut, int Count, int *Operations)
evxErrors | cvxPartHistClipbyPath (int Cut, int Count, svxEntPath *paths)
evxErrors | cvxPartHistRename (int idOp, vxName Name, char *Descript)
evxErrors | cvxPartHistDel (int Count, int *Operations)
evxErrors | cvxPartHistDelUtil (int Count, int *Operations, int OpType)
evxErrors | cvxPartDelGrpFtr (int idFtr, int delFtrs)
evxErrors | cvxPartMkEntExternal (int idEnt, int external)
void | cvxHistDisable (void)
void | cvxHistEnable (void)

Feature Creation

evxErrors cvxPartHistAdd (const int idData, const vxName FtrName, const int Option, int *idFtr)

Entity Operations

evxErrors | cvxPartErase (int Count, int *idEnts)
evxErrors | cvxPartHistScrollTo (int idEnt)

Publish Set Operations

evxErrors cvxPartPublishSetDel (int Count, const int *idPubSets)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_sheetmetal_attribute.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_sheetmetal_attribute.h File Reference
#include "zwapi_cmd_sheetmetal_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sheet Metal Attributes API

Definition in file zwapi_part_sheetmetal_attribute.h.

Sheet Metal Attribute

evxErrors | cvxPartSmdAtGet (svxSmdAt *at)
evxErrors | cvxPartSmdAtSet (const svxSmdAt *at)

Flange Face

int | cvxPartInqSmdStatFcs (int idShape, int *countStat, int **statFcs, int *countPair, int **pairStatFcs)
evxErrors | cvxPartInqSmdStatFace (int idShape, int *idFace)
evxErrors | cvxPartInqSmdPairFaces (int idFace, int *count, int **faces)
evxErrors | cvxPartInqSmdSrfType (int idFace, evxSmdSurfaceType *type)
evxErrors | cvxPartInqShtMetalThick (int idShape, double *thick)
evxErrors | cvxPartSmdStatFaceSet (int idFace, int *idFtr)
evxErrors | cvxPartGetFlatSolids (int *cnts, int **solids)

Sheet Metal Flatten

evxErrors cvxPartInqFlattens (int *count, int **idFlattens, vxLongName **flattenNames)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_var.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_var.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Part Variables API

Definition in file zwapi_part_var.h.

Part Variable Query

evxErrors | cvxPartInqVars (const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
evxErrors | cvxPartInqEqnAllId (int *cntList, int **idList, int *cntSets, int **idSets)

Part Variable

evxErrors | cvxPartVarAdd (svxVariable *Variable)
evxErrors | cvxPartVarGet (svxVariable *Variable)
evxErrors | cvxPartVarGetById (int idEqn, svxVariable *Variable)
evxErrors | cvxPartVarSet (int Count, svxVariable *Variables, int Working)
evxErrors | cvxPartEqnMoveToEqnSet (int idEqnSet, int cnt, const int *idListEqn)
evxErrors | cvxPartVarAddToEqnSet (int idEqnSet, int cnt, const svxVariable *vars)
evxErrors | cvxPartEqnSet (int Count, svxVariable *Variables)
evxErrors | cvxPartEqnSetWithName (const vxLongName setName, int count, svxVariable *vars)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_view.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_part_view.h File Reference
#include "zwapi_part_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
MAIN HEADER FILE FOR THE ZW3D Part View API

Definition in file zwapi_part_view.h.

Part View

evxErrors | cvxPartInqView (int idView, svxView *View)
evxErrors | cvxPartInqViews (int *Count, int **Views)
evxErrors | cvxPartViewAddInit (svxView *data)
evxErrors | cvxPartViewAdd (svxView *View, int *idView)
evxErrors | cvxPartViewRecord (int idView, svxView *View)

Part Display

void | cvxPartShowAll (void)
void | cvxPartShowTarg (void)
evxErrors | cvxPartShowPreview (const vxLongPath fileName, const vxRootName rootName)
void | cvxPartClosePreview ()
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_root.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_root.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Root API

Definition in file zwapi_root.h.

Root Edit Data

enum evxRootType {
VX_ROOT_NULL = 0 , VX_ROOT_PART = 89 , VX_ROOT_PART_NEW = -VX_ROOT_PART , VX_ROOT_SHEET = 90 ,
VX_ROOT_DRAWING = 91 , VX_ROOT_SKETCH = 70 , VX_ROOT_EQUATION_SET = 121 , VX_ROOT_CAM_PLAN = 200
}
root object type More...
typedef enum evxRootType evxRootType
root object type

Root Query Data

enum | evxPreviewMode { VX_PREVIEW_OFF = 0 , VX_PREVIEW_GEOM = 1 , VX_PREVIEW_ATTRIB = 2 }
root object preview mode More...
typedef enum evxPreviewMode | evxPreviewMode
root object preview mode

root separate

typedef struct svxRootSepData | svxRootSepData
separate root to file
evxErrors | cvxRootSeparate (svxRootSepData *data)
evxErrors | cvxRootSeparateInit (svxRootSepData *data)

Root Activate

evxErrors | cvxRootActivate (vxRootName Name)
evxErrors | cvxRootActivate2 (const vxLongPath File, const vxRootName Name)
evxErrors | cvxRootActivateLoadAsmCtx (const vxLongPath File, const vxRootName Name, int isLoad)

Root Edit

evxErrors | cvxRootAdd (evxRootType Type, vxRootName Name, const char *Template)
evxErrors | cvxRootAdd2 (evxRootType, vxRootName Name, const char *Template, char *Description)
int | cvxRootAdd2Bg (evxRootType Type, vxRootName Name)
evxErrors | cvxRootCopy (const vxLongPath SourceFile, const vxRootName SourceName, const vxLongPath DestFile, vxRootName DestName, int Overwrite, int UpdateUid)
evxErrors | cvxRootDel (vxRootName Name)
void | cvxRootExit (void)

Root Query

evxErrors | cvxRootId (vxRootName Name, int *idRoot, evxRootType *Type)
void | cvxRootInqActive (char *Name, int nBytes)
evxErrors | cvxRootInqAsm (char *Name, int nBytes)
evxErrors | cvxRootInqMod (int *Mod)
evxErrors | cvxRootInqModByName (const vxLongPath fileName, const vxRootName rootName, int *mod)
evxErrors | cvxRootInqModSinceRegen (int *Mod)
evxErrors | cvxRootInqSymbol (const vxLongPath file, int *iCount, vxRootName **names)
evxErrors | cvxRootIsAsm (const vxLongPath File, const vxRootName Part, int *isAsm)
evxErrors | cvxRootList (const vxLongPath File, int *Count, vxRootName **Names)
evxPreviewMode | cvxRootPreviewGet (void)
void | cvxRootPreviewSet (evxPreviewMode Mode, const vxLongPath File, vxRootName Object)
void | cvxRootTemplateFile (const vxLongPath File)

File/Root Rename

evxErrors | cvxRootRename (vxRootName Name, vxRootName NewName, int Update)
evxErrors | cvxRootRename2 (vxRootName Name, vxRootName NewName, char *Descript, int Update)
evxErrors | cvxRootRenameMulti (int Count, const vxPath *FileName, const vxRootName *RootName, const vxPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)
evxErrors | cvxRootRenameMultiByLongPath (int Count, const vxLongPath *FileName, const vxRootName *RootName, const vxLongPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)

Root Variable

evxErrors | cvxRootVarGet (vxRootName Name, svxVariable *Variable)
evxErrors | cvxRootVarSet (vxRootName Name, int Count, svxVariable *Var, int Working)

Root Attribute

void | cvxRootVisibility (vxRootName Name, int Visible)
evxErrors | cvxRootInqSheetMetal (const vxLongPath file, const vxRootName part, int *shtMetal)
evxErrors | cvxRootAtItemGet (const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
evxErrors | cvxRootAtItemSet (const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
evxErrors | cvxRootCustomDataSet (const vxLongPath file, vxRootName objectName, char *data, int dataLength)
evxErrors | cvxRootCustomDataGet (const vxLongPath file, const vxRootName objectName, char **data, int *dataLength)
evxErrors | cvxRootCustomDataDel (const vxLongPath file, vxRootName objectName)
evxErrors | cvxRootCustomDataAdd (const vxLongPath file, const vxRootName root, const char *data, int *idCustomData)
evxErrors | cvxRootInqCustomData (const vxLongPath file, const vxRootName root, int *count, int **idCustomDatas)
evxErrors | cvxRootCustomDataGetAll (const vxLongPath file, const vxRootName root, int *count, char ***data)
evxErrors | cvxRootCustomDataGetById (const vxLongPath file, const vxRootName root, int idCustomData, char **data)
evxErrors | cvxRootCustomDataModById (const vxLongPath file, const vxRootName root, int idCustomData, const char *data)
evxErrors | cvxRootCustomDataDelById (const vxLongPath file, const vxRootName root, int count, const int *idCustomDatas)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_attribute.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_attribute.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note

Definition in file zwapi_sk_attribute.h.

Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_data.h File Reference
#include "zwapi_util.h"
#include "zwapi_cmd_sk_cmds_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Generic Data Types and Structures of the functions of Sketch objects.

Definition in file zwapi_sk_data.h.

Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_dim.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_dim.h File Reference
#include "zwapi_sk_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sketch Dimension API

Definition in file zwapi_sk_dim.h.

Sketch Dimension Query

evxErrors | cvxSkInqDim (int *Count, int **idEnts)
evxErrors | cvxSkInqDimType (int idDim, evxConsDimType *type)
evxErrors | cvxSkInqDimRefFlag (int idDim, int *refFlag)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_objs.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_objs.h File Reference
#include "zwapi_sk_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note

Definition in file zwapi_sk_objs.h.

Sketch Query/Edit

int | cvxSkInqPlane (int idSketch, svxEntPath *plnPath)
evxErrors | cvxSkInqPlanes (int idSketch, int *count, int **idFaces)
int | cvxSkIsCosmetic (int IdSketch)
int | cvxSkIsExternal (int IdSketch)
evxErrors | cvxSkInqExternalSk (int idSketch, vxPath fileName, vxRootName rootName, vxLongName skName)
evxErrors | cvxSkInqExternalSkByLongPath (int idSketch, char *fileName, int sizefile, vxRootName rootName, vxLongName skName)
int | cvxSkInqArea (int nCrv, int *idCrvs, svxPoint2 *innerPnt, svxPrfAreaProp *aboutCM, svxPrfAreaProp *aboutRf)
evxErrors | cvxSkActivate (int idSketch, int UpdateGUI)

Sketch Geometry Query

evxErrors | cvxSkInqAxis (int idSketch, int *xAxis, int *yAxis)
evxErrors | cvxSkInqAllAxis (int *Count, int **idEnts)
evxErrors | cvxSkInqAllAxisById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqAxisDir (int idAxis, svxPoint2 *pPnt, svxPoint2 *pDir)
evxErrors | cvxSkInqGeom (int *Count, int **idEnts)
evxErrors | cvxSkInqGeomById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqGeomX (int *Count, int **idEnts)
evxErrors | cvxSkInqGeomXById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqPnt (int *Count, int **idEnts)
evxErrors | cvxSkInqPntById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqRef (int *Count, int **idEnts)
evxErrors | cvxSkInqRefById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqText (int *Count, int **idEnts)
evxErrors | cvxSkInqTextById (int idSketch, int *count, int **idEnts)
evxErrors | cvxSkInqCns (int *Count, int **idEnts)
evxErrors | cvxSkInqCnsById (int idSketch, int *count, int **idEnts)

Sketch Curve Type

evxErrors | cvxSkInqCrvConnect (int iCount, int *idCrvs, int *iUnMatch, int *iOverMatch)
evxErrors | cvxSkEntWireType (int entId, int *type)
evxErrors | cvxSkSetWireType (int nEnt, int *idEnt, int type)

Sketch Ready Text

evxErrors | cvxSkInqReadyText (int idSketch, int *Count, int **idEnts)
evxErrors | cvxSkReadyTextInqCrvs (int idRdText, int *Count, int **idCrvs)
evxErrors | cvxSkReadyTextInqText (int idRdText, svxReadyText *RdText)
evxErrors | cvxSkReadyTextModText (int idRdText, svxReadyText *RdText)
void | cvxReadyTextFree (svxReadyText *RdText)

Sketch Block

evxErrors | cvxSkInqBlockReferences (int idSketch, int *Count, int **idEnts)
evxErrors | cvxSkInqSketchBlocks (int *Count, int **idEnts, vxRootName **Names)
evxErrors | cvxSkBlockActivate (int idBlock, int UpdateGUI)
evxErrors | cvxSkBlockGetSketch (int idBlock, int *idSketch)
evxErrors | cvxSkBlockRefGetDefinition (int idRef, int *idBlock)
evxErrors | cvxSkBlockInqGeom (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqPnt (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqDim (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqGeomX (const vxRootName blockName, int *Count, int **idEnts)
evxErrors | cvxSkBlockInqRefs (int idBlock, int *count, int **idEnts)

Sketch Constraint

evxErrors | cvxSkInqCnsType (int idCons, evxGeomConsType *type, int *subType)
evxErrors | cvxSkInqCnsGeoms (int idCons, int *Count, svxConsGeom **geoms)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_opts.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_opts.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Popup Menu Commands of Sketch API

Definition in file zwapi_sk_opts.h.

Sketch Operations

void cvxSkRegen ()
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_var.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_sk_var.h File Reference
#include "zwapi_sk_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Sketch Variable API

Definition in file zwapi_sk_var.h.

Sketch Variable

evxErrors | cvxSkVarAdd (svxVariable *Variable)
evxErrors | cvxSkVarGet (svxVariable *Variable)
evxErrors | cvxSkVarSet (int Count, svxVariable *Variables)
evxErrors | cvxSkInqVars (int *Count, svxVariable **Variables)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_text.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_text.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Text API

Definition in file zwapi_text.h.

Text Data

typedef struct svxTextLoc svxTextLoc
text location

Text

evxErrors | cvxEntTextInq (int idText, char **Text)
evxErrors | cvxEntTextMod (int idText, char *Text)
evxErrors | cvxEntTextAtGet (int idText, svxTextAt *At)
evxErrors | cvxEntTextAtSet (int idText, svxTextAt *At)
evxErrors | cvxEntTextLocGet (int idText, svxTextLoc *loc)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_tool_entpath.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_tool_entpath.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE API of the Entity Path.

Definition in file zwapi_tool_entpath.h.

Entity Path Basic Function

evxErrors | cvxEntPathInit (int idEntity, int idParent, svxEntPath *entPath)
evxErrors | cvxEntPathInqActive (svxEntPath *entPath)
evxErrors | cvxEntPathAppendEnt (svxEntPath *entPath, int idEntity)
evxErrors | cvxEntPathAppendPath (svxEntPath *dstPath, const svxEntPath *srcPath)
evxErrors | cvxEntPathToRoot (svxEntPath *EntPath)
int | cvxEntPathCmp (const svxEntPath *EntPath1, const svxEntPath *EntPath2)
int | cvxEntPathGetParentComp (const svxEntPath *entPath, svxEntPath *parentComp)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_combobox.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_combobox.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Combobox API

Definition in file zwapi_ui_combobox.h.

Combobox

evxErrors | cvxComboCurrentItem (const char *sForm, int fldId, int *curIdx)
evxErrors | cvxComboSetCurrentItem (const char *sForm, int field, int item)
evxErrors | cvxComboCurrentText (const char *sForm, int idField, char *text, int sizeText)
evxErrors | cvxComboCurrentTextSet (const char *sForm, int idField, const char *text)
evxErrors | cvxComboItemCount (const char *sForm, int idField, int *count)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_data.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_data.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Generic Data Types and Structures of the functions of UI Controls.

Definition in file zwapi_ui_data.h.

Tree Item Data

#define | VX_INVALID_ITEM ((vxTreeItemId)-1)
#define | VX_INVISIBLE_ROOT_ITEM ((vxTreeItemId)0)
#define | VX_INSERT_LAST ((vxTreeItemId)-1) /* Insert at last position */
#define | VX_INSERT_FIRST ((vxTreeItemId)0) /* Insert node at first position */
enum evxTreeItemFlag {
VX_TREE_NO_ITEM_FLAGS = 0x0000 , VX_TREE_IS_SELECTABLE = 0x0001 , VX_TREE_IS_EDITABLE = 0x0002 , VX_TREE_IS_DRAG_ENABLE = 0x0004 ,
VX_TREE_IS_DROP_ENABLE = 0x0008 , VX_TREE_IS_CHECKABLE = 0x0010 , VX_TREE_IS_ENABLE = 0x0020 , VX_TREE_IS_TRISTATE = 0x0040 ,
VX_TREE_ITEM_NEVER_HAS_CHILDREN = 0x0080 , VX_TREE_ITEM_IS_USER_TRISTATE = 0x0100 , VX_TREE_ITEM_IS_GRAY = 0x00010000
}
tree item data More...
enum | evxTreeItemType { VX_ITEM = 0 , VX_FINISHMARK = 1 }
tree widget item types More...
enum evxTreeEvent {
VX_EMPTY = 0 , VX_LEFT_DOWN , VX_LEFT_UP , VX_MIDDLE_DOWN ,
VX_MIDDLE_UP , VX_RIGHT_DOWN , VX_RIGHT_UP , VX_BOX_SELECTION_DONE ,
VX_LABEL_CHANGED , VX_EDITOR_CLOSED , VX_DBL_LEFT , VX_DROP ,
VX_KEY_PRESS , VX_HOVER , VX_HOVER_TIMEOUT , VX_ENTER ,
VX_LEAVE
}
tree widget event types More...
enum evxTreeHitPos {
VXTHP_BUTTON = 0x0001 , VXTHP_ICON = 0x0002 , VXTHP_LABEL = 0x0004 , VXTHP_ITEM = 0x0006 ,
VXTHP_SPACE = 0x0008 , VXTHP_CHECKBOX = 0x0010 , VXTHP_APD_ICON1 = 0x0020 , VXTHP_APD_ICON2 = 0x0040 ,
VXTHP_HEADER = 0x0080
}
tree widget element codes More...
typedef enum evxTreeItemFlag | evxTreeItemFlag
tree item data
typedef int | vxTreeItemId
integer tree widget item id More...
typedef enum evxTreeItemType | evxTreeItemType
tree widget item types
typedef enum evxTreeHitPos | evxTreeHitPos
tree widget element codes
typedef struct svxTreeCbParam | svxTreeCbParam
tree widget callback function parameters

Form Add To Data

enum | evxFormAddTo { VX_FILE_BROWSER , VX_UI_MANAGER }
form type that the "Form" add to More...
typedef enum evxFormAddTo | evxFormAddTo
form type that the "Form" add to

Form Function Data

enum evxFormAction {
VX_FORM_INIT = -4 , VX_FORM_CANCEL = -3 , VX_FORM_RESET = -2 , VX_FORM_APPLY = -1 ,
VX_FORM_OKAY = 0 , VX_FORM_DEFAULT = 1
}
gui form action (see cvxFormFunc()) More...
typedef enum evxFormAction | evxFormAction
gui form action (see cvxFormFunc())
typedef struct svxFormInfo | svxFormInfo
form info that the "Form" add to. When user wants to add a form to UI manager or File browser by using dll,
he has to create svxFormInfo to store form information and Use cvxFormInsertTo() or cvxFormAddTO() to add.

Form Field Data

enum evxFormFldClass {
VX_FORM_FLD_NULL = -1 , VX_FORM_FLD_NUM = 0 , VX_FORM_FLD_SLIDER = 1 , VX_FORM_FLD_TXT_IN = 2 ,
VX_FORM_FLD_TXT_OUT = 3 , VX_FORM_FLD_TXT_BTN = 4 , VX_FORM_FLD_TXT_LBL = 5 , VX_FORM_FLD_DATA = 6 ,
VX_FORM_FLD_LIST = 7 , VX_FORM_FLD_OPT = 8 , VX_FORM_FLD_BTNS = 9 , VX_FORM_FLD_GROUP = 10 ,
VX_FORM_FLD_LABEL = 11 , VX_FORM_FLD_SEPARATOR = 12 , VX_FORM_FLD_COLOR = 13 , VX_FORM_FLD_TREE = 14 ,
VX_FORM_FLD_COMBO = 15 , VX_FORM_FLD_TAB = 16 , VX_FORM_FLD_PROGRESS = 17 , VX_FORM_FLD_TABLE = 18
}
gui form template field (i.e. widget) classes More...
enum evxCmdFldClass {
VX_CMD_FLD_NULL = 0 , VX_CMD_FLD_TEXT = 1 , VX_CMD_FLD_NUM = 2 , VX_CMD_FLD_DIST = 3 ,
VX_CMD_FLD_ANGLE = 4 , VX_CMD_FLD_POINT = 5 , VX_CMD_FLD_ENTITY = 6 , VX_CMD_FLD_OPTION = 7 ,
VX_CMD_FLD_CONT = 8 , VX_CMD_FLD_FORM = 9 , VX_CMD_FLD_WIN = 10 , VX_CMD_FLD_CMD = 11 ,
VX_CMD_FLD_PIN = 12 , VX_CMD_FLD_OPTGROUP = 13 , VX_CMD_FLD_NUMUNIT = 14 , VX_CMD_FLD_CUSTOMINPUT = 15 ,
VX_CMD_FLD_PICK = 16
}
command template field classes More...
typedef enum evxFormFldClass | evxFormFldClass
gui form template field (i.e. widget) classes
typedef enum evxCmdFldClass | evxCmdFldClass
command template field classes
typedef struct svxTplFld | svxTplFld
template field data

Cursor Management Data

enum evxCursorType {
VX_CURSOR_STD = 0 , VX_CURSOR_MOUSE = 1 , VX_CURSOR_BUSY = 2 , VX_CURSOR_WRENCH = 3 ,
VX_CURSOR_PLIERS = 4 , VX_CURSOR_SCREW_DRIVER = 5 , VX_CURSOR_HAMMER = 6 , VX_CURSOR_TOGGLE = 7 ,
VX_CURSOR_HAND = 8 , VX_CURSOR_WRENCH_PLUS = 9
}
cursor display type More...
typedef enum evxCursorType evxCursorType
cursor display type

List Widget Data

enum evxUiEvt {
VX_UIEVT_INVALID = -6 , VX_UIEVT_HELP = -5 , VX_UIEVT_CANCEL = -3 , VX_UIEVT_RESET = -2 ,
VX_UIEVT_APPLY = -1 , VX_UIEVT_OKAY = 0 , VX_UIEVT_DEF = 1 , VX_UIEVT_LBTNCLK ,
VX_UIEVT_LBTNUP = VX_UIEVT_LBTNCLK , VX_UIEVT_MBTNCLK , VX_UIEVT_RBTNCLK , VX_UIEVT_LBTNDCLK ,
VX_UIEVT_CHAR , VX_UIEVT_FOCUSKILL , VX_UIEVT_SCROLL , VX_UIEVT_HOTKEY ,
VX_UIEVT_CMDONOFF , VX_UIEVT_FOCUSSET , VX_UIEVT_STRING , VX_UIEVT_HOVER ,
VX_UIEVT_LBTNDOWN , VX_UIEVT_SORT , VX_UIEVT_DATACHANGE , VX_UIEVT_PREVIEW ,
VX_UIEVT_SELCHANGED = 19 , VX_UIEVT_STATECHANGED , VX_UIEVT_MOUSEMOVE , VX_UIEVT_DROP = 22 ,
VX_UIEVT_IGNORE
}
UI event type. More...
typedef enum evxUiEvt | evxUiEvt
UI event type.
typedef struct svxListCallBackParam | svxListCallBackParam
ListWidget event date.

Table Callback Data

enum evxTableEvent {
VX_LEFT_CLICK = 2 , VX_RIGHT_CLICK = 4 , VX_LEFT_DOUBLE_CLICK , VX_KEY_UP_DOWN ,
VX_HOT_KEY = 9 , VX_SORT = 15 , VX_DATA_CHANGED , VX_CELL_BUTTON_CLICKED ,
VX_MOUSE_MOVE = 21 , VX_CELL_CLOSE_EDITOR = 23
}
table widget event types More...
enum | evxTableAlignFlag { VX_TABLE_ALIGN_CENTER = 0 , VX_TABLE_ALIGN_LEFT = 1 , VX_TABLE_ALIGN_RIGHT = 2 }
table widget alignment mode More...
enum | evxTableResizeMode { VX_TABLE_RESIZE_MODE_INTERACTIVE = 0 , VX_TABLE_RESIZE_MODE_STRETCH = 1 , VX_TABLE_RESIZE_MODE_FIXED = 2 , VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS = 3 }
table widget resize mode More...
enum | evxDateType { VX_DATE_WITH_TIME , VX_DATE_ONLY }
data type More...
typedef enum evxTableEvent | evxTableEvent
table widget event types
typedef enum evxTableAlignFlag | evxTableAlignFlag
table widget alignment mode
typedef enum evxTableResizeMode | evxTableResizeMode
table widget resize mode
typedef struct svxKeyEvent | svxKeyEvent
keyboard event
typedef enum evxDateType | evxDateType
data type
typedef struct svxTableCellData | svxTableCellData
table cell data
typedef struct svxTableCallBackParam | svxTableCallBackParam
table widget callback function parameters

Tree Widget Header Data

enum | evxAlignFlag { VX_ALIGN_CENTER = 0 , VX_ALIGN_LEFT = 1 , VX_ALIGN_RIGHT = 2 }
ui alignment types More...
typedef enum evxAlignFlag | evxAlignFlag
ui alignment types

Table Cell Data

enum evxTableCellType {
VX_TABLECELL_TYPE_TEXT = 0 , VX_TABLECELL_TYPE_COMBOBOX = 1 , VX_TABLECELL_TYPE_CHECKBOX = 2 , VX_TABLECELL_TYPE_INDEX_COMBOBOX = 3 ,
VX_TABLECELL_TYPE_INPUT_COMBOBOX = 4 , VX_TABLECELL_TYPE_TEXT_BUTTON = 5 , VX_TABLECELL_TYPE_DATE = 6 , VX_TABLECELL_TYPE_COLOR = 7 ,
VX_TABLECELL_TYPE_NUMBER = 8
}
table cell types More...
typedef enum evxTableCellType evxTableCellType
table cell types

Tree Item State Data

enum | evxTreeCheckState { VX_TREE_ITEM_UNCHECKED , VX_TREE_ITEM_BLACK_CHECKED = 4 }
check tree item state More...
typedef enum evxTreeCheckState | evxTreeCheckState
check tree item state

Table Attribute Data

typedef struct svxTableAt | svxTableAt
table attributes
typedef struct svxRectangle | svxRectangle
Rectangle data.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_form.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_form.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Form API

Definition in file zwapi_ui_form.h.

Form Creation

evxErrors | cvxFormCreate (char *Form, int Display)
void | cvxFormShow (char *Form)
void | cvxFormHide (char *Form)
void | cvxFormKill (char *Form)
void | cvxFormLogKill (char *Form)
void | cvxFormRefresh (char *Form)
int | cvxFormWait (char *Form)
void | cvxFormWaitExit (int ReturnValue)
evxErrors | cvxFormGetSize (const char *Form, int *Width, int *Height)
evxErrors | cvxFormResize (char *Form, int Width, int Height)
evxErrors | cvxFormAdjustSize (const char *Form)

Form Add To

void | cvxFormAddTo (const char *Form, evxFormAddTo addTo)
evxErrors | cvxFormInsertTo (const svxFormInfo *FormInfo, int Index, evxFormAddTo AddTo)
void | cvxFormRemoveFrom (const char *Form, evxFormAddTo removeFrom)

Form Set

void | cvxFormTitleGet (char *Form, int NumBytes, char *Title)
void | cvxFormTitleSet (char *Form, char *Title)
evxErrors | cvxFormDataGet (char *Form, char **Data)
evxErrors | cvxFormDataSet (char *Form, char *Data)

Form Function

void | cvxFormFunc (vxName Name, void *Function, double Code)
void | cvxFormCallback (vxName Name, void *Function)
evxErrors | cvxFormFieldGetCallback (const char *form, int field, void **callback)

Form State

void | cvxFormActiveField (int *idField)
int | cvxFormState (char *Form)
evxErrors | cvxFormVisibleSet (evxEnvironment Environment, const char *Form, int State, evxFormAddTo Type)
evxErrors | cvxFormFieldVisSet (const char *form, int field, int state)

Form Field

evxErrors | cvxFormInqFld (vxName Name, int *Count, svxTplFld **Fields)
evxErrors | cvxTplInqFields (const vxName Name, int *NumFld, int **idFields)
evxErrors | cvxTplInqFieldType (const vxName Name, int idField, evxCmdFldClass *Type)
evxErrors | cvxTplInqFieldOptions (const vxName Name, int idField, int NumBytes, char *Options)
void | cvxFormUpdate (int idField)
void | cvxFieldFocusSet (char *Form, int idField)
void | cvxFieldNumItems (char *Form, int idField, int *NumItems)
void | cvxFieldClear (char *Form, int idField)
void | cvxFieldDisable (char *Form, int idField)
void | cvxFieldEnable (char *Form, int idField)
int | cvxFieldEnableGet (char *Form, int idField)
void | cvxFilterItemApply (const char *panelName, const char *filterItem)
void | cvxFieldImageSet (char *Form, int idField, char *Image)
void | cvxFieldCaretSet (char *Form, int idField, int Position)
evxErrors | cvxFieldTipSet (const char *sForm, int idField, const char *tip)
evxErrors | cvxFieldInitFont (const char *Form, int idField, const char *Name, int hasZwFont)

Form Item

void | cvxItemAdd (char *Form, int idField, const char *Text)
void | cvxItemGet (char *Form, int idField, int idItem, char *Text)
void | cvxItemSet (char *Form, int idField, int idItem, char *Text)
void | cvxItemModify (const char *Form, int idField, int idItem, const char *Text)
void | cvxItemDel (char *Form, int idField, int idItem)
void | cvxItemFind (char *Form, int idField, char *Text, int *idItem)
void | cvxItemCbxSet (char *Form, int idField, int idItem, int isOn)
void | cvxItemSelect (char *Form, int idField, int idItem)
void | cvxItemSelectText (char *Form, int idField, char *Text)
void | cvxItemSelected (char *Form, int idField, int *idItem)
void | cvxItemStateGet (char *Form, int idField, int idItem, int *isOn)
void | cvxItemStateSet (char *Form, int idField, int idItem, int isOn)
evxErrors | cvxItemGetCheckState (char *Form, int idField, int idItem, int *checkState)
evxErrors | cvxItemVisibleSet (const char *Form, int idField, int idItem, int state)
evxErrors | cvxItemVisibleGet (const char *Form, int idField, int idItem, int *state)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_guiset.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_guiset.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D UI Setting API

Definition in file zwapi_ui_guiset.h.

Role management

int | cvxUiSettingsCount (void)
evxErrors | cvxUiSettingsCreate (char *Name, char *Base)
evxErrors | cvxUiSettingsRename (char *Name, char *Dest)
evxErrors | cvxUiSettingsRemove (char *Name)
evxErrors | cvxUiSettingsImport (char *Path)
evxErrors | cvxUiSettingsExport (char *Name, char *Path)
evxErrors | cvxUiSettingsExists (char *Name)
evxErrors | cvxUiSettingsApply (char *Name)
evxErrors | cvxUiSettingsReset (char *Name)
evxErrors | cvxUiSettingsFetch (int i, char *Name)

Cursor Management

void | cvxCursorSet (evxCursorType Type)
void | cvxCursorRestore (void)
void | cvxProgress (int iprogress)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_listwidget.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_listwidget.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D List Widget API

Definition in file zwapi_ui_listwidget.h.

List Widget

evxErrors | cvxListCallbackParamGet (const char *form, int idField, svxListCallBackParam *param)
evxErrors | cvxListItemToolTipSet (const char *form, int field, int row, const char *toolTip)
evxErrors | cvxListItemToolTipGet (const char *form, int field, int row, char *toolTip, int size)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_popupform.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_popupform.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Popup Form API

Definition in file zwapi_ui_popupform.h.

Popup Form

int | cvxPopupShow (const char *name)
evxErrors | cvxPopupDefine (const char *name)
evxErrors | cvxPopupUpdate (const char *Name)
evxErrors | cvxPopupSetVisible (const char *name, int visible)

Sub Menu

evxErrors | cvxPopupMenuCnt (const char *Name, int *cnt)
evxErrors | cvxPopupSubMenuCnt (const char *Name, const char *Sub, int *cnt)
evxErrors | cvxPopupSubMenuItemInsert (const char *Name, const char *Sub, int index, const char *ActName, const char *Label, const char *Script, const char *Icon)
evxErrors | cvxPopupSubMenuItemRemove (const char *name, const char *Sub, int index)
evxErrors | cvxPopupSubMenuActionsRemove (const char *Name, const char *Sub, int iFirst, int iLast)
evxErrors | cvxPopupSubMenuSeparatorInsert (const char *Name, const char *Sub)
evxErrors | cvxPopupSubMenuSetVisible (const char *name, const char *sub, int visible)

Popup Form Item

int | cvxPopupItemIsExist (const char *name, const char *action)
evxErrors | cvxPopupItemInsert (const char *name, int index, const char *Label, const char *Action)
evxErrors | cvxPopupItemRemove (const char *name, int index)
evxErrors | cvxPopupItemActionGet (const char *name, int item, char *Action, int nByte)
evxErrors | cvxPopupItemSetAction (const char *name, int index, const char *Action)
evxErrors | cvxPopupItemLabelGet (const char *name, int item, char *Label, int nByte)
evxErrors | cvxPopupItemCheckedGet (const char *name, int group, int item, int *Check)
evxErrors | cvxPopupItemVisibleGet (const char *name, int item, int *Visible)
evxErrors | cvxPopupItemSetVisibleByAction (const char *name, const char *action, int visible)
evxErrors | cvxPopupItemSetEnabledByAction (const char *name, const char *action, int enabled)
evxErrors | cvxPopupItemSetCheckedByAction (const char *name, const char *action, int checked)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_ribbon.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_ribbon.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Ribbon API

Definition in file zwapi_ui_ribbon.h.

Ribbon

void | cvxRibbonSetStatus (int enable)
void | cvxSetTitleAppend (const char *pStr)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_slider.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_slider.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Combobox API

Definition in file zwapi_ui_slider.h.

Slider

evxErrors | cvxSliderLimitGet (const char *Form, int idfield, double *min, double *max)
evxErrors | cvxSliderLimitSet (const char *Form, int idfield, double min, double max)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_tablewidget.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_tablewidget.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Table Widget API

Definition in file zwapi_ui_tablewidget.h.

Table Attribute

evxErrors | cvxTableAtSetInit (svxTableAt *data)
evxErrors | cvxTableAtSet (char *Form, int idTable, svxTableAt *At)
evxErrors | cvxTableSizeSet (char *Form, int idTable, int NumRow, int NumCol)
evxErrors | cvxTableSetSelRange (const char *Form, int idTable, svxRectangle *SelRange, int bSelect)
evxErrors | cvxTableGetSelRange (const char *Form, int idTable, int *RangeCnt, svxRectangle **SelRange)
evxErrors | cvxTableUnselectAll (const char *Form, int idTable)

Table Callback

evxErrors | cvxTableCallBackParamGet (const char *form, int idTable, svxTableCallBackParam *param)
void | cvxTableCallBackParamFree (svxTableCallBackParam *param)

Table Row/Column

int | cvxTableRowCnt (const char *Form, int idTable)
int | cvxTableColCnt (const char *Form, int idTable)
evxErrors | cvxTableRowInsert (const char *Form, int idTable, int Row)
evxErrors | cvxTableRowRemove (const char *Form, int idTable, int Row)
evxErrors | cvxTableColInsert (const char *Form, int idTable, int Col)
evxErrors | cvxTableColRemove (const char *Form, int idTable, int Col)

Table Combobox

evxErrors | cvxTableComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableComboGet (const char *Form, int idTable, int Row, int Col, int *Index, char *Text, int nBytes)
evxErrors | cvxTableIndexComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableInputComboSet (char *Form, int idTable, int Row, int Col, char *Options)
evxErrors | cvxTableIndexComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableInputComboSet2 (const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
evxErrors | cvxTableComboSetOption (const char *Form, int idTable, int Row, int Col, int Index, char *IdxText)

Table Cell

evxErrors | cvxTableTypeGet (const char *Form, int idTable, int Row, int Col, evxTableCellType *Type)
void | cvxTableVisSet (char *Form, int idTable, int Row, int Col)
int | cvxTableIsCheck (const char *Form, int idTable, int Row, int Col)
evxErrors | cvxTableCheckSet (const char *Form, int idTable, int Row, int Col, int Check)
evxErrors | cvxTableCellTextGet (char *Form, int idTable, int Row, int Col, char *text, int nBytes)
void | cvxTableCellEnableSet (const char *Form, int idTable, int Row, int Col, int State)
void | cvxTableCellTipSet (const char *Form, int idTable, int Row, int Col, const char *tip)
evxErrors | cvxTableCellTipGet (const char *Form, int idTable, int Row, int Col, char *tip, int nBytes)
evxErrors | cvxTableCellTextSet (char *Form, int idTable, int Row, int Col, char *text)
evxErrors | cvxTableCellTextSet2 (const char *Form, int idTable, int Row, int Col, char *Text, char *Image)
evxErrors | cvxTableDateSet (const char *Form, int idTable, int Row, int Col, int Date, evxDateType DateType)
evxErrors | cvxTableDateGet (const char *Form, int idTable, int Row, int Col, int *Date, evxDateType *DateType)
evxErrors | cvxTableColorSet (const char *Form, int idTable, int Row, int Col, const svxColor *Color, int ClrIdx, unsigned char Type)
evxErrors | cvxTableColorGet (const char *Form, int idTable, int Row, int Col, svxColor *Color, int *ClrIdx, unsigned char *Type)
evxErrors | cvxTableNumSet (const char *Form, int idTable, int Row, int Col, const char *Num)
evxErrors | cvxTableNumGet (const char *Form, int idTable, int Row, int Col, char *Num, int Bytes)
evxErrors | cvxTableGetText (const char *Form, int idTable, int row, int col, char *text, int sizeText)

Table Header

evxErrors | cvxTableSetHorHeaderList (const char *Form, int idTable, int num, const char **pHeaderList)
evxErrors | cvxTableSetVerHeaderList (const char *Form, int idTable, int num, const char **pHeaderList)
evxErrors | cvxTableSetHeaderAlignment (const char *Form, int idTable, int isVertical, evxTableAlignFlag align)
evxErrors | cvxTableSetHeaderColResizeMode (const char *Form, int idTable, int col, evxTableResizeMode mode)
evxErrors | cvxTableSetHeaderSectionSize (const char *Form, int idTable, int size, int isMin)
evxErrors | cvxTableHeaderCellCheck (const char *Form, int idTable, int isVertical, int item, int check)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_tabwidget.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_tabwidget.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Tab Widget API

Definition in file zwapi_ui_tabwidget.h.

Tab Attribute

evxErrors cvxTabWidgetItemVisibleSet (const char *Form, int tabIdField, int tabIndex, char bVisible)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_treeview.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_ui_treeview.h File Reference
#include "zwapi_ui_data.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Tree View API

Definition in file zwapi_ui_treeview.h.

Tree Widget Header

void | cvxTreeSetHeaderIcon (const char *name, int field, int section, const char *icon)
void | cvxTreeSetHeaderText (const char *form, int field, int col, const char *text)
evxErrors | cvxTreeHeaderGetSize (const char *form, int field, int *width, int *height)
evxErrors | cvxTreeSetHeaderTextAlignment (const char *form, int field, int col, evxAlignFlag align)

Tree Widget Column

void | cvxTreeSetColumnCount (const char *form, int field, int count)
int | cvxTreeGetColumnCount (const char *form, int field)
void | cvxTreeSetColumnWidth (const char *form, int field, int col, int width)
int | cvxTreeGetColumnWidth (const char *form, int field, int col)
void | cvxTreeSetColumnHidden (const char *form, int field, int col, int hide)
int | cvxTreeIsColumnHidden (const char *form, int field, int col)
evxErrors | cvxTreeAutoResizeColumn (const char *form, int field, int col)

Tree Widget State

void | cvxTreeExpandAll (const char *form, int field)
void | cvxTreeCollapseAll (const char *form, int field)
evxErrors | cvxTreeUnselectAll (const char *form, int field)
evxErrors | cvxTreeSetSelectionMode (const char *form, int field, int mode)
evxErrors | cvxTreeSetSelectionBehavior (const char *form, int field, int behavior)

Tree Widget Callback

evxErrors cvxTreeGetCbParam (const char *form, int field, int itemId, svxTreeCbParam *cbp)

Tree Item

int | cvxTreeItemsCount (const char *form, int field)
evxErrors | cvxTreeAddItem (const char *form, int field, int parentId, int siblingId, const char *label, int imgIdx, int folderIdx, evxTreeItemType itemType, int dbIdx, int itemflag, int *outItemId, const char *cmdName)
evxErrors | cvxTreeSetItemFlag (const char *form, int field, int count, int *ids, int flag)
evxErrors | cvxTreeGetItemFlag (const char *form, int field, int id, int *flag)
evxErrors | cvxTreeSetItemIconNameByColumn (const char *form, int field, int id, int col, const char *iconName)
evxErrors | cvxTreeSetItemTextByColumn (const char *form, int field, int id, int col, const char *text)
void | cvxTreeGetItemTextByColumn (const char *form, int field, int id, int col, char *text, int size)
evxErrors | cvxTreeSetItemTextColor (const char *form, int field, int id, int col, svxColor *color)
evxErrors | cvxTreeGetDBIdByItem (const char *form, int field, int id, int *objectIndex)
evxErrors | cvxTreeDeleteItem (const char *form, int field, int id)
evxErrors | cvxTreeDeleteSubItem (const char *form, int field, int id)
evxErrors | cvxTreeEditItemByLineEdit (const char *form, int field, int id, int col, const char *defaultLabel)
evxErrors | cvxTreeEditItemByComboBox (const char *form, int field, int id, int col, const char *Options, const char *Images, int curIndex)
evxErrors | cvxTreeGetPrevSiblingItem (const char *form, int field, int id, int *prevId)
evxErrors | cvxTreeGetNextSiblingItem (const char *form, int field, int id, int *nextId)
evxErrors | cvxTreeGetChildItem (const char *form, int field, int id, int index, int *child_id)
evxErrors | cvxTreeGetChildrenCount (const char *form, int field, int id, int *count)
evxErrors | cvxTreeGetParentItem (const char *form, int field, int id, int *parent)
evxErrors | cvxTreeMoveItems (const char *form, int field, int numNodes, int *ids, int insParentId, int siblingId)
evxErrors | cvxTreeGetDescendants (const char *form, int field, int isAll, int parent, int *num, int **ids)
evxErrors | cvxTreeGetSelectedItems (const char *form, int field, int *count, int **ids)

Tree Item State

int | cvxTreeIsItemSelected (const char *form, int field, int id)
evxErrors | cvxTreeSelectItem (const char *form, int field, int id)
evxErrors | cvxTreeSetItemCheckable (const char *form, int field, int id, int checkable)
evxTreeCheckState | cvxTreeGetItemCheckState (const char *form, int field, int id)
void | cvxTreeSetItemCheckState (const char *form, int field, int id, evxTreeCheckState checkState, int extToChild)
int | cvxTreeItemIsExpand (const char *form, int field, int id)
evxErrors | cvxTreeExpandItem (const char *form, int field, int id, int option)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_userinput.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_userinput.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D User Input API

Definition in file zwapi_userinput.h.

Get Entity Data

enum evxEntInpOpt {
VX_INP_UNDEFINED = 0 , VX_INP_GENERAL_3D = 1 , VX_INP_GENERAL_2D = 2 , VX_INP_SHAPE = 3 ,
VX_INP_FACE = 4 , VX_INP_SHAPE_OR_FACE = 5 , VX_INP_EDGE = 6 , VX_INP_CURVE = 7 ,
VX_INP_EDGE_OR_CURVE = 8 , VX_INP_CURVE_LIST = 9 , VX_INP_PARTING_CURVE = 10 , VX_INP_POINT = 11 ,
VX_INP_FEATURE = 12 , VX_INP_SKETCH = 13 , VX_INP_DATUM_PLANE = 14 , VX_INP_REF_PLANE = 15 ,
VX_INP_3D_BLOCK = 16 , VX_INP_LIGHT = 17 , VX_INP_LAYER = 18 , VX_INP_REF_GEOM = 19 ,
VX_INP_WIREFRAME = 20 , VX_INP_MOVE = 21 , VX_INP_BLANK = 22 , VX_INP_ERASE = 23 ,
VX_INP_INQUIRE = 24 , VX_INP_3D_GEOM = 25 , VX_INP_TEXT = 26 , VX_INP_PROF = 27 ,
VX_INP_COMP = 28 , VX_INP_ASM_SHAPE = 29 , VX_INP_FACE_ON_SHAPE = 30 , VX_INP_SUB_COMP = 31 ,
VX_INP_CSYS = 32 , VX_INP_AXIS_3D = 33 , VX_INP_AXIS_2D = 34
}
entity input options More...
typedef enum evxEntInpOpt evxEntInpOpt
entity input options

Get Point Data

enum evxPntInpOpt {
VX_INP_PNT_GENERAL = 0 , VX_INP_PNT_ON_ENTITY = 1 , VX_INP_PNT_ON_CURVE = 2 , VX_INP_PNT_ON_EDGE = 3 ,
VX_INP_PNT_ON_CURVE_OR_EDGE = 4 , VX_INP_PNT_ON_ANY_FACE = 5 , VX_INP_PNT_ON_FIELD_1_FACE = 6 , VX_INP_PNT_END = 7 ,
VX_INP_PNT_ASSEMBLY = 8 , VX_INP_PNT_DIRECTION = 9 , VX_INP_PNT_ON_CRV_OR_PROF = 10 , VX_INP_PNT_ASSEM_FACE = 11 ,
VX_INP_PNT_ASSEM_EDGE = 12 , VX_INP_PNT_ASSEM_CURVE = 13
}
point input options More...
typedef enum evxPntInpOpt evxPntInpOpt
point input options

Get Number

evxErrors | cvxGetAngle (const char *Prompt, double *Angle)
evxErrors | cvxGetDistance (const char *Prompt, double *Distance)
evxErrors | cvxGetNumber (const char *Prompt, double *Number)

Get Entity

evxErrors | cvxGetEnt (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
evxErrors | cvxGetEnts (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
evxErrors | cvxGetEntPath (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
evxErrors | cvxGetEntPaths (const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths)
evxErrors | cvxGetEntsMultiFilter (const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, int **idEnts)
evxErrors | cvxGetEntPathsMultiFilter (const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, svxEntPath **Paths)
evxErrors | cvxGetExternalPick (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, svxEntPath *EntPath, svxMatrix *Matrix)

Get Point

evxErrors | cvxGetPoint (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
evxErrors | cvxGetPoints (const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
evxErrors | cvxGetPointOnEnt (const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
evxErrors | cvxGetPointsOnEnts (const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)

Get File

void | cvxGetFile (int Open, const char *Prompt, const char *Default, const char *Filter, char *Path)
void | cvxGetFileByLongPath (int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
void | cvxGetFileActiveField (int Open, const char *Prompt, const char *Default, const char *Filter)
void | cvxGetFolder (const char *Prompt, char *Default, vxPath path)
void | cvxGetFolderByLongPath (const char *Prompt, char *Default, char *Path, int sizePath)
void | cvxGetFolderActiveField (const char *Prompt, const char *Default)

Get Message

int | cvxGetResponse (int Option, const char *Message)
int | cvxGetString (const char *Prompt, const char *Default, int NumBytes, char *String)
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_util.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_util.h File Reference

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Generic Data Types and Structures

Definition in file zwapi_util.h.

Entity Pick Path

#define | V_PP_LEN 400
maximum length of a non-persistent (i.e. evaluated) pick path More...
typedef struct svxEntPath | svxEntPath
entity pick path(sync with VsPickPath)

Function Return Error Type

enum evxErrors {
ZW_API_NO_ERROR = 0 , ZW_API_GENERAL_ERROR = -10000 , ZW_API_ROOT_OBJ_ACT_FAIL = -5 , ZW_API_WRONG_ROOT_ENV = -6 ,
ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR = -7 , ZW_API_ROOT_ERROR = -8 , ZW_API_INVALID_INPUT = -31 , ZW_API_INPUT_ERROR = -32 ,
ZW_API_INPUT_TYPE_ERROR = -33 , ZW_API_INVALID_OUTPUT = -34 , ZW_API_FILE_LOCATE_FAIL = -61 , ZW_API_FILE_ERROR = -62 ,
ZW_API_OBJ_TYPE_ERROR = -91 , ZW_API_OBJ_DATA_GET_ERROR = -92 , ZW_API_OBJ_DATA_SET_ERROR = -93 , ZW_API_INVALID_OBJ = -94 ,
ZW_API_ENT_PATH_ERROR = -121 , ZW_API_INVALID_ENT_PATH = -122 , ZW_API_CMMD_INIT_ERROR = -151 , ZW_API_CMMD_EXEC_ERROR = -152 ,
ZW_API_CMMD_DATA_ERROR = -153 , ZW_API_FUN_REGISTER_ERROR = -160 , ZW_API_FUN_UNLOAD_ERROR = -161 , ZW_API_MEMORY_ERROR = -181 ,
ZW_API_OUT_OF_RANGE = -182 , ZW_API_MODELING_DATA_ERROR = -211 , ZW_API_BOOLEAN_ADD_BASE_ERROR = -212 , ZW_API_INVALID_NAME = -241 ,
ZW_API_INVALID_PATH = -242 , ZW_API_INVALID_STRING = -243 , ZW_API_PATH_LEN_OVER_RANGE = -244 , ZW_API_NAME_LEN_OVER_RANGE = -245 ,
ZW_API_PATH_LEN_LESS_RANGE = -246 , ZW_API_NAME_LEN_LESS_RANGE = -247 , ZW_API_FORM_CREATE_FAIL = -271 , ZW_API_FORM_SHOW_FAIL = -272 ,
ZW_API_FORM_EXIST_ERROR = -273 , ZW_API_FORM_INIT_ERROR = -274 , ZW_API_TABLE_SETDATA_ERROR = -281 , ZW_API_TABLE_GETDATA_ERROR = -282 ,
ZW_API_LICENSE_NESTING_ERROR = -301 , ZW_API_FUNCTION_CB_GET_ERROR = -401 , ZW_API_FUCNTION_CB_EXIST_ERROR = -402 , ZW_API_FUCNTION_CB_EXECUTION_ERROR = -403 ,
ZW_API_CAM_OPTYPE_ERROR = -1001 , ZW_API_CAM_GETOPNAME_ERROR = -1002 , ZW_API_CAM_GETOPBYTAC_ERROR = -1003 , ZW_API_CAM_GETOPERATION_ERROR = -1004 ,
ZW_API_CAM_GETVDATA_ERROR = -1011 , ZW_API_CAM_SETVDATA_ERROR = -1012 , ZW_API_CAM_UPVADTA_ERROR = -1013 , ZW_API_CAM_GETTACNAME_ERROR = -1021 ,
ZW_API_CAM_GETTACTIC_ERROR = -1022 , ZW_API_CAM_GETFTRGRP_ERROR = -1031 , ZW_API_CAM_GETFTRDBNAME_ERROR = -1032 , ZW_API_CAM_GETFTR_ERROR = -1033 ,
ZW_API_CAM_GETSETUP_ERROR = -1041 , ZW_API_CAM_GETMACH_ERROR = -1051 , ZW_API_CAM_GETMACHNAME_ERROR = -1052 , ZW_API_CAM_GETFOLDER_ERROR = -1061 ,
ZW_API_CAM_GETFOLDERNAME_ERROR = -1062 , ZW_API_CAM_GETFOLDERSUB_ERROR = -1063 , ZW_API_CAM_GETTOOL_ERROR = -1072 , ZW_API_CAM_GETTOOLNAME_ERROR = -1073 ,
ZW_API_CAM_GETHOLDER_ERROR = -1073 , ZW_API_CAM_GETTOOLTYPE_ERROR = -1074 , ZW_API_CAM_GETTOOLSUBTYPE_ERROR = -1075 , ZW_API_CAM_GETTOOLID_ERROR = -1076 ,
ZW_API_CAM_GETTOOLLEN_ERROR = -1077 , ZW_API_CAM_GETTOOLDIA_ERROR = -1078 , ZW_API_CAM_GETCMCOMP_ERROR = -1081 , ZW_API_CAM_GETCOMPCLASS_ERROR = -1082 ,
ZW_API_CAM_GETCOMPINDEX_ERROR = -1083 , ZW_API_CAM_GETCOMPVDATA_ERROR = -1084 , ZW_API_CAM_GETFRAME_ERROR = -1091 , ZW_API_CAM_GETACTFRAME_ERROR = -1092 ,
ZW_API_CAM_GETOUT_ERROR = -1101 , ZW_API_CAM_OUTCL_ERROR = -1102 , ZW_API_CAM_OUTNC_ERROR = -1103 , ZW_API_CAM_OUTOPLIST_ERROR = -1104 ,
ZW_API_CAM_OUTOPHTML_ERROR = -1105 , ZW_API_CAM_OUTOPXML_ERROR = -1106 , ZW_API_CAM_OUTTOOL_ERROR = -1107 , ZW_API_CAM_GUITOTXT_ERROR = -1111 ,
ZW_API_CAM_GUIFROMTXT_ERROR = -1112 , ZW_API_CAM_GETFORMSTATE_ERROR = -1121 , ZW_API_CAM_FORMDEFINE_ERROR = -1122 , ZW_API_CAM_GETFORMITEM_ERROR = -1123 ,
ZW_API_CAM_SETFORMITEM_ERROR = -1124 , ZW_API_CAM_GETTPATH_ERROR = -1131 , ZW_API_CAM_GETTPATHINFO_ERROR = -1132 , ZW_API_CAM_GETSPDFD_ERROR = -1141
}
the return value of the API interfaces More...
typedef enum evxErrors evxErrors
the return value of the API interfaces

Point/Vector

enum | evxAxisType { VX_AXIS_X = 1 , VX_AXIS_Y = 2 , VX_AXIS_Z = 3 }
type of axis More...
typedef struct svxPoint2 | svxPoint2
2D point
typedef struct svxPoint2f | svxPoint2f
2D point(single precision floating point)
typedef struct svxPoint | svxPoint
3D point
typedef struct svxPointf | svxPointf
3D point (single precision floating point)
typedef struct svxVector2 | svxVector2
2D vector
typedef struct svxVector | svxVector
3D vector
typedef struct svxAxis | svxAxis
3D axis
typedef enum evxAxisType | evxAxisType
type of axis
typedef struct svxTriangle | svxTriangle
3D triangle

Unit

enum evxUnitType {
VX_UNIT_MICRON = 0 , VX_UNIT_MILLIMETER = 1 , VX_UNIT_CENTIMETER = 2 , VX_UNIT_METER = 3 ,
VX_UNIT_INCH = 4 , VX_UNIT_FOOT = 5 , VX_UNIT_YD = 6 , VX_UNIT_DM = 7 ,
VX_UNIT_MIL = 10
}
system of linear units More...
enum | evxMassUnitType { VX_UNIT_GM = 11 , VX_UNIT_KG = 12 , VX_UNIT_OZ = 13 , VX_UNIT_LB = 14 }
system of mass units More...
enum evxDensityUnitType {
VX_UNIT_DEN_KG_M3 = 0 , VX_UNIT_DEN_KG_MM3 = 1 , VX_UNIT_DEN_G_MM3 = 2 , VX_UNIT_DEN_G_CM3 = 3 ,
VX_UNIT_DEN_LB_IN3 = 4 , VX_UNIT_DEN_LB_FT3 = 5 , VX_UNIT_DEN_LB_YD3 = 6 , VX_UNIT_DEN_OZ_IN3 = 7 ,
VX_UNIT_DEN_OZ_FT3 = 8 , VX_UNIT_DEN_OZ_YD3 = 9 , VX_UNIT_DEN_KG_DM3 = 10 , VX_UNIT_DEN_G_DM3 = 11
}
system of density units More...
enum evxMassMomentUnitType {
VX_UNIT_MASSMOMENT_KGMM2 = 0 , VX_UNIT_MASSMOMENT_KGM2 = 1 , VX_UNIT_MASSMOMENT_GMM2 = 2 , VX_UNIT_MASSMOMENT_GCM2 = 3 ,
VX_UNIT_MASSMOMENT_LBIN2 = 4 , VX_UNIT_MASSMOMENT_LBFT2 = 5 , VX_UNIT_MASSMOMENT_LBYD2 = 6 , VX_UNIT_MASSMOMENT_OZIN2 = 7 ,
VX_UNIT_MASSMOMENT_OZFT2 = 8 , VX_UNIT_MASSMOMENT_OZYD2 = 9 , VX_UNIT_MASSMOMENT_KGDM2 = 10 , VX_UNIT_MASSMOMENT_GDM2 = 11
}
system of mass moment units More...
typedef enum evxUnitType | evxUnitType
system of linear units
typedef enum evxMassUnitType | evxMassUnitType
system of mass units
typedef enum evxDensityUnitType | evxDensityUnitType
system of density units
typedef enum evxMassMomentUnitType | evxMassMomentUnitType
system of mass moment units

Matrix

enum evxEulerAngSeq {
VX_XYX = 121 , VX_XZX = 131 , VX_YXY = 212 , VX_YZY = 232 ,
VX_ZXZ = 313 , VX_ZYZ = 323 , VX_RPY = 123 , VX_RYP = 132 ,
VX_PRY = 213 , VX_PYR = 231 , VX_YRP = 312 , VX_YPR = 321
}
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type. More...
typedef struct svxMatrix | svxMatrix
3D transformation matrix or coordinate frame (local to world)
typedef struct svxMatEuler | svxMatEuler
Euler angles and translate vector.
typedef enum evxEulerAngSeq | evxEulerAngSeq
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.

Point On Entity

enum evxGeomCritPnt {
VX_NO_POINT , VX_FREE_POINT = 0 , VX_START_POINT , VX_END_POINT ,
VX_CENTER_POINT , VX_SPLINE_DEFINING_POINT , VX_MIDDLE_POINT , VX_ORIGIN_POINT
}
type of sketch geometry critical point More...
enum | evxDirType { VX_START_DIR , VX_END_DIR , VX_PNT_DIR }
type of direction More...
enum | evxPntLocation { VX_PNT_OUT = -1 , VX_PNT_ON = 0 , VX_PNT_IN = 1 , VX_PNT_NULL = -2 }
point location More...
typedef enum evxGeomCritPnt | evxGeomCritPnt
type of sketch geometry critical point
typedef struct svxPntOnEnt | svxPntOnEnt
point on entity definition, also can use to set a dynamic point
typedef struct svxPntOnEntPath | svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
typedef enum evxDirType | evxDirType
type of direction
typedef struct svxDirOnEntPath | svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
typedef enum evxPntLocation | evxPntLocation
point location

Color

enum evxColor {
VX_COLOR_RGB = -1 , VX_COLOR_NULL = 0 , VX_COLOR_GREEN = 1 , VX_COLOR_RED = 2 ,
VX_COLOR_BROWN = 3 , VX_COLOR_GOLDENROD = 4 , VX_COLOR_MED_BLUE = 5 , VX_COLOR_DARK_MAGENTA = 6 ,
VX_COLOR_DARK_GREY = 7 , VX_COLOR_DARK_BLUE = 8 , VX_COLOR_VIOLET = 9 , VX_COLOR_LIGHT_GREEN = 10 ,
VX_COLOR_LIGHT_BLUE = 11 , VX_COLOR_ROSE = 12 , VX_COLOR_LIGHT_MAGENTA = 13 , VX_COLOR_LIGHT_GREY = 14 ,
VX_COLOR_WHITE = 15 , VX_COLOR_BLACK = 16 , VX_COLOR_YELLOW = 17 , VX_COLOR_MED_GREY = 18 ,
VX_COLOR_PURPLE = 19 , VX_COLOR_STANDARD_LAST = VX_COLOR_PURPLE , VX_COLOR_INDEX_BEGIN , VX_COLOR_INDEX20 = VX_COLOR_INDEX_BEGIN ,
VX_COLOR_INDEX21 , VX_COLOR_INDEX22 , VX_COLOR_INDEX23 , VX_COLOR_INDEX24 ,
VX_COLOR_INDEX25 , VX_COLOR_INDEX26 , VX_COLOR_INDEX27 , VX_COLOR_INDEX28 ,
VX_COLOR_INDEX29 , VX_COLOR_INDEX30 , VX_COLOR_INDEX31 , VX_COLOR_INDEX32 ,
VX_COLOR_INDEX33 , VX_COLOR_INDEX34 , VX_COLOR_INDEX35 , VX_COLOR_INDEX36 ,
VX_COLOR_INDEX37 , VX_COLOR_INDEX38 , VX_COLOR_INDEX39 , VX_COLOR_INDEX40 ,
VX_COLOR_INDEX41 , VX_COLOR_INDEX42 , VX_COLOR_INDEX43 , VX_COLOR_INDEX44 ,
VX_COLOR_INDEX45 , VX_COLOR_INDEX46 , VX_COLOR_INDEX47 , VX_COLOR_INDEX48 ,
VX_COLOR_INDEX49 , VX_COLOR_INDEX50 , VX_COLOR_INDEX51 , VX_COLOR_INDEX52 ,
VX_COLOR_INDEX53 , VX_COLOR_INDEX54 , VX_COLOR_INDEX55 , VX_COLOR_INDEX56 ,
VX_COLOR_INDEX57 , VX_COLOR_INDEX58 , VX_COLOR_INDEX59 , VX_COLOR_INDEX60 ,
VX_COLOR_INDEX61 , VX_COLOR_INDEX62 , VX_COLOR_INDEX63 , VX_COLOR_INDEX64 ,
VX_COLOR_INDEX65 , VX_COLOR_INDEX66 , VX_COLOR_INDEX67 , VX_COLOR_INDEX68 ,
VX_COLOR_INDEX69 , VX_COLOR_INDEX70 , VX_COLOR_INDEX71 , VX_COLOR_INDEX72 ,
VX_COLOR_INDEX73 , VX_COLOR_INDEX74 , VX_COLOR_INDEX75 , VX_COLOR_INDEX76 ,
VX_COLOR_INDEX77 , VX_COLOR_INDEX78 , VX_COLOR_INDEX79 , VX_COLOR_INDEX80 ,
VX_COLOR_INDEX81 , VX_COLOR_INDEX82 , VX_COLOR_INDEX83 , VX_COLOR_INDEX84 ,
VX_COLOR_INDEX85 , VX_COLOR_INDEX86 , VX_COLOR_INDEX87 , VX_COLOR_INDEX88 ,
VX_COLOR_INDEX89 , VX_COLOR_INDEX90 , VX_COLOR_INDEX91 , VX_COLOR_INDEX92 ,
VX_COLOR_INDEX93 , VX_COLOR_INDEX94 , VX_COLOR_INDEX95 , VX_COLOR_INDEX96 ,
VX_COLOR_INDEX97 , VX_COLOR_INDEX98 , VX_COLOR_INDEX99 , VX_COLOR_INDEX100 ,
VX_COLOR_INDEX101 , VX_COLOR_INDEX102 , VX_COLOR_INDEX103 , VX_COLOR_INDEX104 ,
VX_COLOR_INDEX105 , VX_COLOR_INDEX106 , VX_COLOR_INDEX107 , VX_COLOR_INDEX108 ,
VX_COLOR_INDEX109 , VX_COLOR_INDEX110 , VX_COLOR_INDEX111 , VX_COLOR_INDEX112 ,
VX_COLOR_INDEX113 , VX_COLOR_INDEX114 , VX_COLOR_INDEX115 , VX_COLOR_INDEX116 ,
VX_COLOR_INDEX117 , VX_COLOR_INDEX118 , VX_COLOR_INDEX119 , VX_COLOR_INDEX120 ,
VX_COLOR_INDEX121 , VX_COLOR_INDEX122 , VX_COLOR_INDEX123 , VX_COLOR_INDEX124 ,
VX_COLOR_INDEX125 , VX_COLOR_INDEX126 , VX_COLOR_INDEX127 , VX_COLOR_INDEX128 ,
VX_COLOR_INDEX129 , VX_COLOR_INDEX130 , VX_COLOR_INDEX131 , VX_COLOR_INDEX132 ,
VX_COLOR_INDEX133 , VX_COLOR_INDEX134 , VX_COLOR_INDEX135 , VX_COLOR_INDEX136 ,
VX_COLOR_INDEX137 , VX_COLOR_INDEX138 , VX_COLOR_INDEX139 , VX_COLOR_INDEX140 ,
VX_COLOR_INDEX141 , VX_COLOR_INDEX142 , VX_COLOR_INDEX143 , VX_COLOR_INDEX144 ,
VX_COLOR_INDEX145 , VX_COLOR_INDEX146 , VX_COLOR_INDEX147 , VX_COLOR_INDEX148 ,
VX_COLOR_INDEX149 , VX_COLOR_INDEX150 , VX_COLOR_INDEX151 , VX_COLOR_INDEX152 ,
VX_COLOR_INDEX153 , VX_COLOR_INDEX154 , VX_COLOR_INDEX155 , VX_COLOR_INDEX156 ,
VX_COLOR_INDEX157 , VX_COLOR_INDEX158 , VX_COLOR_INDEX159 , VX_COLOR_INDEX160 ,
VX_COLOR_INDEX161 , VX_COLOR_INDEX162 , VX_COLOR_INDEX163 , VX_COLOR_INDEX164 ,
VX_COLOR_INDEX165 , VX_COLOR_INDEX166 , VX_COLOR_INDEX167 , VX_COLOR_INDEX168 ,
VX_COLOR_INDEX169 , VX_COLOR_INDEX170 , VX_COLOR_INDEX171 , VX_COLOR_INDEX172 ,
VX_COLOR_INDEX173 , VX_COLOR_INDEX174 , VX_COLOR_INDEX175 , VX_COLOR_INDEX176 ,
VX_COLOR_INDEX177 , VX_COLOR_INDEX178 , VX_COLOR_INDEX179 , VX_COLOR_INDEX180 ,
VX_COLOR_INDEX181 , VX_COLOR_INDEX182 , VX_COLOR_INDEX183 , VX_COLOR_INDEX184 ,
VX_COLOR_INDEX185 , VX_COLOR_INDEX186 , VX_COLOR_INDEX187 , VX_COLOR_INDEX188 ,
VX_COLOR_INDEX189 , VX_COLOR_INDEX190 , VX_COLOR_INDEX191 , VX_COLOR_INDEX192 ,
VX_COLOR_INDEX193 , VX_COLOR_INDEX194 , VX_COLOR_INDEX195 , VX_COLOR_INDEX196 ,
VX_COLOR_INDEX197 , VX_COLOR_INDEX198 , VX_COLOR_INDEX199 , VX_COLOR_INDEX200 ,
VX_COLOR_INDEX201 , VX_COLOR_INDEX202 , VX_COLOR_INDEX203 , VX_COLOR_INDEX204 ,
VX_COLOR_INDEX205 , VX_COLOR_INDEX206 , VX_COLOR_INDEX207 , VX_COLOR_INDEX208 ,
VX_COLOR_INDEX209 , VX_COLOR_INDEX210 , VX_COLOR_INDEX211 , VX_COLOR_INDEX212 ,
VX_COLOR_INDEX213 , VX_COLOR_INDEX214 , VX_COLOR_INDEX215 , VX_COLOR_INDEX216 ,
VX_COLOR_INDEX217 , VX_COLOR_INDEX218 , VX_COLOR_INDEX219 , VX_COLOR_INDEX220 ,
VX_COLOR_INDEX221 , VX_COLOR_INDEX222 , VX_COLOR_INDEX223 , VX_COLOR_INDEX224 ,
VX_COLOR_INDEX225 , VX_COLOR_INDEX226 , VX_COLOR_INDEX227 , VX_COLOR_INDEX228 ,
VX_COLOR_INDEX229 , VX_COLOR_INDEX230 , VX_COLOR_INDEX231 , VX_COLOR_INDEX232 ,
VX_COLOR_INDEX233 , VX_COLOR_INDEX234 , VX_COLOR_INDEX235 , VX_COLOR_INDEX236 ,
VX_COLOR_INDEX237 , VX_COLOR_INDEX238 , VX_COLOR_INDEX239 , VX_COLOR_INDEX240 ,
VX_COLOR_INDEX241 , VX_COLOR_INDEX242 , VX_COLOR_INDEX243 , VX_COLOR_INDEX244 ,
VX_COLOR_INDEX_LAST = VX_COLOR_INDEX244 , VX_COLOR_LAST
}
standard colors + index colors (see cvxColorRGB() for RGB color components) More...
enum | evxColorAppFlag { VX_COLOR_BYLAYER = 253 }
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for the detail view More...
typedef struct svxColor | svxColor
RGB color (each component defined over 0 to 255)
typedef struct svxColorf | svxColorf
RGB color (floating point components defined over 0.0 to 1.0)
typedef enum evxColor | evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
typedef enum evxColorAppFlag | evxColorAppFlag
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for the detail view

Entity

enum evxEntType {
VX_ENT_BREP = -4 , VX_ENT_OP = -3 , VX_ENT_POINT = -2 , VX_ENT_WIRE = -1 ,
VX_ENT_ALL = 0 , VX_ENT_SHAPE = 42 , VX_ENT_FACE = 43 , VX_ENT_EDGE = 46 ,
VX_ENT_FTR = 48 , VX_ENT_NRB_CRV = 54 , VX_ENT_LINE3 = 56 , VX_ENT_LINE2 = 58 ,
VX_ENT_CIRCLE3 = 60 , VX_ENT_CIRCLE2 = 61 , VX_ENT_ARC3 = 62 , VX_ENT_ARC2 = 63 ,
VX_ENT_POINT3 = 64 , VX_ENT_POINT2 = 65 , VX_ENT_LAYER = 67 , VX_ENT_SKETCH = 70 ,
VX_ENT_REF_GEOM = 72 , VX_ENT_TEXT = 76 , VX_ENT_DIMEN = 77 , VX_ENT_ANNO = 83 ,
VX_ENT_BLOCK = 86 , VX_ENT_DWG_VIEW = 87 , VX_ENT_COMP = 88 , VX_ENT_PART = 89 ,
VX_ENT_SHEET = 90 , VX_ENT_PACKET = 91 , VX_ENT_DATUM = 95 , VX_ENT_CRV_LIST = 102 ,
VX_ENT_PART_LINE = 106 , VX_ENT_HATCH = 111 , VX_ENT_LIGHT = 118 , VX_ENT_INT_CRV = 119 ,
VX_ENT_VAR = 120 , VX_ENT_EQN_SET = 121 , VX_ENT_SYMBOL = 123 , VX_ENT_TRACE = 133 ,
VX_ENT_TABLE = 144 , VX_ENT_VBREAKLINE = 182 , VX_ENT_RDTXT = 185 , VX_ENT_BALLOON = 168 ,
VX_ENT_DRAWING = 169 , VX_ENT_PMIENT = 190 , VX_ENT_BLOCK2D = 197 , VX_ENT_BLKREF = 198 ,
VX_ENT_AXIS = 311 , VX_ENT_CSYS = 312 , VX_ENT_AXIS_2D = 313
}
entity types More...
enum | evxEdgeType { VX_EDGE_UNKNOWN = -1 , VX_EDGE_STANDARD = 0 , VX_EDGE_SEAM = 1 , VX_EDGE_DEGEN = 2 }
type of edge More...
enum evxEntFind {
VX_FIND_POINT = 1 , VX_FIND_CURVE = 2 , VX_FIND_EDGE = 3 , VX_FIND_WIRE = 4 ,
VX_FIND_FACE = 5 , VX_FIND_SKETCH = 6 , VX_FIND_CRV_LIST = 7 , VX_FIND_SKETCH_OR_CRV_LIST = 8 ,
VX_FIND_PROFILE = 9 , VX_FIND_EDGE_OR_CRV = 10 , VX_FIND_3D_BLOCK = 14 , VX_FIND_DIM = 15
}
entity search types More...
enum evxFindRule {
VX_STOP_FACE_FILLET = 0x00000001 , VX_STOP_EDGE_INNER_LOOP = 0x00000002 , VX_STOP_CONVEX_FLLT = 0x00000004 , VX_STOP_CONCAVE_FLLT = 0x00000008 ,
VX_STOP_CONVEX_EDGE = 0x00000010 , VX_STOP_CONCAVE_EDGE = 0x00000020 , VX_STOP_ADJACENCY_LEVEL = 0x00000040 , VX_STOP_BOUNDARY_FACE = 0x00000080 ,
VX_FIND_COAXIAL = 0x00000001 , VX_FIND_TANGENT = 0x00000002 , VX_FIND_COPLANAR = 0x00000004 , VX_FIND_COPL_AXES = 0x00000008 ,
VX_FIND_EQU_RAD = 0x00000010 , VX_FIND_SYMMETRIC = 0x00000020 , VX_FIND_OFFSET = 0x00000040
}
face search rules More...
typedef enum evxEntType | evxEntType
entity types
typedef struct svxEntPick | svxEntPick
entity pick (includes optional parent entity)
typedef struct svxUid | svxUid
entity unique identifier
typedef enum evxEdgeType | evxEdgeType
type of edge
typedef enum evxEntFind | evxEntFind
entity search types
typedef struct svxEntFind | svxEntFind
entity search data
typedef enum evxFindRule | evxFindRule
face search rules

Variable

enum | evxVarType { VX_VAR_NUM = 0 , VX_VAR_STR = 1 , VX_VAR_PNT = 2 , VX_VAR_VEC = 3 }
variable types More...
enum evxVarNumType {
VX_VAR_CONS = 0 , VX_VAR_DST = 1 , VX_VAR_ANG = 2 , VX_VAR_MASS = 3 ,
VX_VAR_DENSITY = 4 , VX_VAR_AREA = 5 , VX_VAR_VOLUME = 6 , VX_VAR_MASS_MOMENT = 7
}
sub types of numeric variable More...
typedef enum evxVarType | evxVarType
variable types
typedef enum evxVarNumType | evxVarNumType
sub types of numeric variable
typedef struct svxVariable | svxVariable
numeric variable

Wire Attribute

enum evxViewLineAttrIdx {
VX_VIS_LINE_ATTR = 0 , VX_HID_LINE_ATTR = 1 , VX_TAN_LINE_ATTR = 2 , VX_SECT_LINE_ATTR = 3 ,
VX_DET_LINE_ATTR = 4 , VX_CENT_LINE_ATTR = 5 , VX_THRD_LINE_ATTR = 6 , VX_VIEW_LINE_ATTR = 7 ,
VX_WIRE_LINE_ATTR = 8 , VX_TAN_HID_LINE_ATTR = 9 , VX_WIRE_HID_LINE_ATTR = 10 , VX_CENT_HID_LINE_ATTR = 11 ,
VX_THRD_HID_LINE_ATTR = 12 , VX_BEND_LINE_ATTR = 13 , VX_BEND_HID_LINE_ATTR = 14 , VX_THRD_END_LINE_ATTR = 15 ,
VX_THRD_END_HID_LINE_ATTR = 16 , VX_CROP_LINE_ATTR = 17
}
line type ids for view attribute line types More...
typedef enum evxViewLineAttrIdx | evxViewLineAttrIdx
line type ids for view attribute line types
typedef struct svxWireAt | svxWireAt
wire display attributes

Text Attribute

enum evxTextureOpt {
V_TEXTURE_NULL = 0 , V_TEXTURE_BLEND = 1 , V_TEXTURE_DECAL = 2 , V_TEXTURE_MODULATE = 3 ,
V_TEXTURE_REPLACE = 4
}
texture map option More...
enum evxTextureLoc {
V_TEXTURE_LOWER_LEFT = 0 , V_TEXTURE_UPPER_LEFT = 1 , V_TEXTURE_UPPER_RIGHT = 2 , V_TEXTURE_LOWER_RIGHT = 3 ,
V_TEXTURE_CENTER = 4
}
texture map origin point with respect to texture map rectangle More...
typedef enum evxTextureOpt | evxTextureOpt
texture map option
typedef enum evxTextureLoc | evxTextureLoc
texture map origin point with respect to texture map rectangle
typedef struct svxTextureAt | svxTextureAt
texture attribute
typedef struct svxTextAt | svxTextAt
text attribute

Part Attribute

enum evxAtItemId {
VX_AT_USER = 0 , VX_AT_NAME = 1 , VX_AT_NUMBER = 2 , VX_AT_CLASS ,
VX_AT_DESIGNER , VX_AT_COST , VX_AT_SUPPLIER , VX_AT_DESCRIPT ,
VX_AT_KEYWORD , VX_AT_MANAGER , VX_AT_MATERIAL , VX_AT_START ,
VX_AT_END , VX_AT_DERIVED , VX_AT_NO_SECTION , VX_AT_NO_HATCH ,
VX_AT_NO_BOM , VX_AT_NO_ROOTSHOW , VX_AT_DENSITY = 18 , VX_AT_FILEPATH = 20 ,
VX_AT_SHEETPATH = 21 , VX_AT_CAMPATH = 22 , VX_AT_SHEETCODE = 23 , VX_AT_AREA = 25 ,
VX_AT_VOLUME = 26 , VX_AT_MASS = 27 , VX_AT_LENGTH = 28 , VX_AT_WIDTH = 29 ,
VX_AT_HEIGHT = 30 , VX_AT_STOCK_SIZE = 43 , VX_AT_REVISION = 47 , VX_AT_SHEET_SCALE = 200 ,
VX_AT_SHEET_SEQUENCE = 201 , VX_AT_SHEET_AMOUNT , VX_AT_SHEET_SIZE , VX_AT_SHEET_PROJECTION ,
VX_AT_SHEET_FILEPATH
}
standard id of attribute item More...
enum evxAttributeType {
VX_ATTR_STRING = 0 , VX_ATTR_BOOL = 1 , VX_ATTR_INT = 2 , VX_ATTR_REAL = 3 ,
VX_ATTR_DATE = 4
}
attribute data type More...
enum evxDateFormat {
VX_DATE_FROMAT_SHORT = 0 , VX_DATE_FROMAT_LONG = 1 , VX_DATE_FROMAT1 = 2 , VX_DATE_FROMAT2 = 3 ,
VX_DATE_FROMAT3 = 4 , VX_DATE_FROMAT4 = 5 , VX_DATE_FROMAT5 = 6 , VX_DATE_FROMAT6 = 7
}
date attribute format More...
typedef enum evxAtItemId | evxAtItemId
standard id of attribute item
typedef enum evxAttributeType | evxAttributeType
attribute data type
typedef enum evxDateFormat | evxDateFormat
date attribute format
typedef struct svxAttribute | svxAttribute
standard attribute data
typedef struct svxPartAttribute | svxPartAttribute
part attribute structure

Line Attribute

enum evxLineWidth {
VX_WIDTH_UNDEFINED , VX_WIDTH_018 , VX_WIDTH_025 , VX_WIDTH_035 ,
VX_WIDTH_050 , VX_WIDTH_070 , VX_WIDTH_100 , VX_WIDTH_BYLAYER = 0xFF
}
line width More...
typedef struct svxLineAt | svxLineAt
Line attributes.
typedef enum evxLineWidth | evxLineWidth
line width

Command Input Data

enum evxNumType {
VX_NUM_UNDEFINED = -1 , VX_NUM_NULL = 0 , VX_NUM_TO_FACE = 1 , VX_NUM_FACE_BND = 2 ,
VX_NUM_TO_PNT = 3 , VX_NUM_THRU_PLUS = 4 , VX_NUM_THRU_MINUS = 5 , VX_NUM_CURVE_BND = 6 ,
VX_NUM_DATA = 7 , VX_UNDEF = 0 , VX_NUM = 1 , VX_DST = 2 ,
VX_ANG = 3 , VX_MASS = 4 , VX_DENSITY = 5 , VX_AREA = 6 ,
VX_VOLUME = 7 , VX_MASS_MOMENT = 8
}
numeric input data types More...
enum evxPntType {
VX_PNT3_ABS = 0 , VX_PNT3_ENT = 1 , VX_PNT3_ON = 2 , VX_PNT3_TO = 3 ,
VX_PNT3_MID = 4 , VX_PNT3_NUM = 5 , VX_PNT3_DST = 6 , VX_PNT3_ANG = 7 ,
VX_PNT3_TAN = 8 , VX_PNT3_FRAC = 9 , VX_PNT3_REL = 10 , VX_PNT3_DATA = 11 ,
VX_PNT3_ABS_COMP = 12
}
point input data types More...
enum | evxAngUnitType { VX_UNIT_DEG = 8 , VX_UNIT_RAD = 9 }
system of angle units More...
typedef enum evxNumType | evxNumType
numeric input data types
typedef enum evxPntType | evxPntType
point input data types
typedef enum evxAngUnitType | evxAngUnitType
system of angle units
typedef struct svxData | svxData
command input data item

Curve Data

enum evxCurveType {
VX_CRV_UNDEFINED = 0 , VX_CRV_LINE = 1 , VX_CRV_ARC = 2 , VX_CRV_CIRCLE = 3 ,
VX_CRV_NURB = 4
}
curve types More...
typedef enum evxCurveType | evxCurveType
curve types
typedef struct svxParameters | svxParameters
curve parameter space data
typedef struct svxControlPoints | svxControlPoints
curve control point data
typedef struct svxCrvContinuityData | svxCrvContinuityData
data of curve continuity.
typedef struct svxCrvContinuityTolList | svxCrvContinuityTolList
curve continuity tolerance list
typedef struct svxCurve | svxCurve
2D or 3D curvilinear geometry

Surface Data

enum evxSurfaceType {
VX_SRF_PLANE , VX_SRF_SPHERE , VX_SRF_CONE , VX_SRF_GRID ,
VX_SRF_CYLINDER , VX_SRF_EXTRUDE , VX_SRF_REVOLVE , VX_SRF_SWEEP_NOT_USED ,
VX_SRF_GEN , VX_SRF_OFFSET , VX_SRF_MESH , VX_SRF_RULED ,
VX_SRF_HEMIS , VX_SRF_FRUSTRUM , VX_SRF_DRAFT , VX_SRF_DRAFT_NPLN ,
VX_SRF_DRAFT_NUV , VX_SRF_ELLIPSOID , VX_SRF_3PT_PLANE , VX_SRF_BILIN_CNVX ,
VX_SRF_EXTRUDE_DRFT , VX_SRF_REVOLVE_PLN , VX_SRF_TORUS , VX_SRF_SMD_THCK_FC ,
VX_SRF_BEND_GEN , VX_SRF_PLANE_STAT_FC , VX_SRF_GEN_STAT_FC , VX_SRF_CIR_OFF ,
VX_SRF_VAR_OFF , VX_SRF_THRD_THDFC , VX_SRF_THRD_NTHDFC , VX_SRF_THRD_CONFC
}
surface types More...
enum evxSrfPrimType {
VX_SF_PRIM_PLN , VX_SF_PRIM_SPH , VX_SF_PRIM_CON , VX_SF_PRIM_CYL ,
VX_SF_PRIM_NURB , VX_SF_PRIM_ELLSO , VX_SF_PRIM_TORUS
}
3D NURB surface type More...
typedef enum evxSurfaceType | evxSurfaceType
surface types
typedef struct svxSurface | svxSurface
3D NURB surface (untrimmed)
typedef enum evxSrfPrimType | evxSrfPrimType
3D NURB surface type
typedef struct svxPlane | svxPlane
data of plane
typedef struct svxSphere | svxSphere
spherical surface data
typedef struct svxCone | svxCone
conical surface data
typedef struct svxCylinder | svxCylinder
cylindrical surface data
typedef struct svxTorus | svxTorus
circular surface data
typedef struct svxEllipsoid | svxEllipsoid
ellipsoid surface data
typedef struct svxSrfPrim | svxSrfPrim
3D NURB surface data

Dimension

enum evxDimType {
VX_DIM_LINEAR = 1 , VX_DIM_BASELINE = 2 , VX_DIM_CONTINUOUS = 3 , VX_DIM_ORDINATE = 4 ,
VX_DIM_LINEAR_OFFSET = 5 , VX_DIM_LINEAR_CHAMFER = 6 , VX_DIM_ANGULAR = 7 , VX_DIM_RADIAL_DIAMETRIC = 8 ,
VX_DIM_ARC_LENGTH = 9 , VX_DIM_SYMMETRY , VX_DIM_HLCALL , VX_DIM_LABEL ,
VX_DIM_BALLOON , VX_DIM_DATUMF , VX_DIM_DATUMT , VX_DIM_FCS ,
VX_DIM_CLCM , VX_DIM_INTERSYM , VX_DIM_LAST
}
dimension type More...
enum evxDimTypeEx {
VX_DIM_EX_FIRST = 0 , VX_DIM_EX_LH = 1 , VX_DIM_EX_LV = 5 , VX_DIM_EX_LA = 9 ,
VX_DIM_EX_LR = 13 , VX_DIM_EX_LP = 17 , VX_DIM_EX_LHB = 2 , VX_DIM_EX_LVB = 6 ,
VX_DIM_EX_LAB = 10 , VX_DIM_EX_LRB = 14 , VX_DIM_EX_LPB = 18 , VX_DIM_EX_LHC = 3 ,
VX_DIM_EX_LVC = 7 , VX_DIM_EX_LAC = 11 , VX_DIM_EX_LRC = 15 , VX_DIM_EX_LPC = 19 ,
VX_DIM_EX_LHO = 4 , VX_DIM_EX_LVO = 8 , VX_DIM_EX_LAO = 12 , VX_DIM_EX_LRO = 16 ,
VX_DIM_EX_LPO = 20 , VX_DIM_EX_LHVO = 88 , VX_DIM_EX_LO = 21 , VX_DIM_EX_LOS = 25 ,
VX_DIM_EX_LSY = 90 , VX_DIM_EX_ASY = 93 , VX_DIM_EX_LCHV = 26 , VX_DIM_EX_LCA = 29 ,
VX_DIM_EX_LCL = 30 , VX_DIM_EX_LCLP = 80 , VX_DIM_EX_LCLA = 83 , VX_DIM_EX_ANG = 48 ,
VX_DIM_EX_ANGH = 52 , VX_DIM_EX_ANGV = 56 , VX_DIM_EX_ANGA = 60 , VX_DIM_EX_ANG3PT = 74 ,
VX_DIM_EX_RAD = 31 , VX_DIM_EX_RADBG = 35 , VX_DIM_EX_RADBK = 39 , VX_DIM_EX_DIA = 44 ,
VX_DIM_EX_RADL = 76 , VX_DIM_EX_GDH = 70 , VX_DIM_EX_GDV = 71 , VX_DIM_EX_GDHS = 77 ,
VX_DIM_EX_GDVS = 78 , VX_DIM_EX_GDL = 81 , VX_DIM_EX_GDLS = 82 , VX_DIM_EX_GDTP = 72 ,
VX_DIM_EX_GDTC = 73 , VX_DIM_EX_GDTR = 84 , VX_DIM_EX_GDTL = 85 , VX_DIM_EX_LOB = 22 ,
VX_DIM_EX_LOC = 23 , VX_DIM_EX_LOO = 24 , VX_DIM_EX_LCH = 27 , VX_DIM_EX_LCV = 28 ,
VX_DIM_EX_RADB = 32 , VX_DIM_EX_RADC = 33 , VX_DIM_EX_RADO = 34 , VX_DIM_EX_RADBGB = 36 ,
VX_DIM_EX_RADBGC = 37 , VX_DIM_EX_RADBGO = 38 , VX_DIM_EX_RADBKB = 40 , VX_DIM_EX_RADBKC = 41 ,
VX_DIM_EX_RADBKO = 42 , VX_DIM_EX_RADS = 43 , VX_DIM_EX_DIAB = 45 , VX_DIM_EX_DIAC = 46 ,
VX_DIM_EX_DIAO = 47 , VX_DIM_EX_ANGB = 49 , VX_DIM_EX_ANGC = 50 , VX_DIM_EX_ANGO = 51 ,
VX_DIM_EX_ANGHB = 53 , VX_DIM_EX_ANGHC = 54 , VX_DIM_EX_ANGHO = 55 , VX_DIM_EX_ANGVB = 57 ,
VX_DIM_EX_ANGVC = 58 , VX_DIM_EX_ANGVO = 59 , VX_DIM_EX_ANGAB = 61 , VX_DIM_EX_ANGAC = 62 ,
VX_DIM_EX_ANGAO = 63 , VX_DIM_EX_LEAD = 64 , VX_DIM_EX_BALL = 65 , VX_DIM_EX_CM = 66 ,
VX_DIM_EX_GF = 67 , VX_DIM_EX_GFL = 68 , VX_DIM_EX_GFP = 69 , VX_DIM_EX_LCLS = 75 ,
VX_DIM_EX_CLC = 79 , VX_DIM_EX_CLBS = 86 , VX_DIM_EX_ARCL = 87 , VX_DIM_EX_INTSYM = 89 ,
VX_DIM_EX_LORD = 91 , VX_DIM_EX_DPLS = 92 , VX_DIM_EX_CRVL = 94 , VX_DIM_EX_RHO = 95 ,
VX_DIM_EX_CRVL3D = 96 , VX_DIM_EX_ELEV = 97 , VX_DIM_EX_AUTO_LSY = 98 , VX_DIM_EX_LAST = 99
}
dimension type, more detailed than evxDimType More...
enum | evxDimLineMode { VX_DIM_LINE_MODE_B = 2 , VX_DIM_LINE_MODE_C = 3 , VX_DIM_LINE_MODE_O = 4 }
dimension Line Mode More...
enum evxDimState {
VX_DM_REVISION = -4 , VX_DM_NOSCALE = -3 , VX_DM_MODIFIED = -2 , VX_DM_DANGLING = -1 ,
VX_DM_NORMAL = 0 , VX_DM_IN_OBJ = 1
}
dimension state More...
enum evxFCSSymbol {
VX_FCSSYM_NONE = 0 , VX_FCSSYM_STRAIGHTNESS , VX_FCSSYM_FLATNESS , VX_FCSSYM_CIRCULARITY ,
VX_FCSSYM_CYLINDRICITY , VX_FCSSYM_PARALLELISM , VX_FCSSYM_PERPENDICULARITY , VX_FCSSYM_ANGULARITY ,
VX_FCSSYM_POSITION , VX_FCSSYM_CONCENTRICITY , VX_FCSSYM_SYMMETRY , VX_FCSSYM_PROFILE_OF_LINE ,
VX_FCSSYM_PROFILE_OF_SURFACE , VX_FCSSYM_CIRCULAR_RUNOUT , VX_FCSSYM_TOTAL_RUNOUT
}
FCS MD&T symbol. More...
enum | evxFCSShapeSym { VX_SHP_NONE = 0 , VX_SHP_DIAMETER , VX_SHP_SPHERICAL_DIA , VX_SHP_SQUARE }
FCS area shape symbol. More...
enum | evxFCSLmsOption { VX_LMS_NONE = 0 , VX_LMS_MAX_MATERIAL , VX_LMS_MIN_MATERIAL , VX_LMS_FTR_SIZE_REGARDLESS }
FCS LMS option. More...
enum evxTermType {
VX_TERM_OFF = 0 , VX_TERM_ARROW_15 = 1 , VX_TERM_ARROW_30 , VX_TERM_ARROW_60 ,
VX_TERM_ARROW_H15 , VX_TERM_ARROW_H30 , VX_TERM_ARROW_H60 , VX_TERM_ARROW_HF15 ,
VX_TERM_ARROW_HF30 , VX_TERM_ARROW_HF60 , VX_TERM_TICK , VX_TERM_DOT ,
VX_TERM_DOTF
}
terminator types More...
enum evxHoleDimDataItem {
VX_HOLE_DIM_ITEM_ORG , VX_HOLE_DIM_ITEM_QTY , VX_HOLE_DIM_ITEM_DIA , VX_HOLE_DIM_ITEM_DIA2 ,
VX_HOLE_DIM_ITEM_LABEL , VX_HOLE_DIM_ITEM_DPTH , VX_HOLE_DIM_ITEM_DPTH2 , VX_HOLE_DIM_ITEM_ANG ,
VX_HOLE_DIM_ITEM_THRD_DIA , VX_HOLE_DIM_ITEM_THRD_DPTH , VX_HOLE_DIM_ITEM_PITCH , VX_HOLE_DIM_THRD_STD ,
VX_HOLE_DIM_THRD_SIZ
}
data sub-items of hole dimension More...
typedef enum evxDimType | evxDimType
dimension type
typedef enum evxDimTypeEx | evxDimTypeEx
dimension type, more detailed than evxDimType
typedef enum evxDimLineMode | evxDimLineMode
dimension Line Mode
typedef enum evxDimState | evxDimState
dimension state
typedef enum evxFCSSymbol | evxFCSSymbol
FCS MD&T symbol.
typedef enum evxFCSShapeSym | evxFCSShapeSym
FCS area shape symbol.
typedef enum evxFCSLmsOption | evxFCSLmsOption
FCS LMS option.
typedef struct svxFCSTol | svxFCSTol
FCS tolerance data.
typedef struct svxFCSDatum | svxFCSDatum
FCS datum data.
typedef struct svxFCSData | svxFCSData
FCS data.
typedef enum evxTermType | evxTermType
terminator types
typedef enum evxHoleDimDataItem | evxHoleDimDataItem
data sub-items of hole dimension
typedef struct svxDimAttr | svxDimAttr
Dimension attributes structure.

Curve/Surface Extension Options

enum | evxExtendOpt { VX_EXTEND_UNDEFINED = 0 , VX_EXTEND_LINEAR = 1 , VX_EXTEND_CIRCULAR = 2 , VX_EXTEND_REFLECT = 3 }
curve/surface extension options More...
typedef enum evxExtendOpt | evxExtendOpt
curve/surface extension options

2D/3D Curve Data

enum evxFairingType {
VX_FAIRING_NONE = 0 , VX_FAIRING_ENERGY = 1 , VX_FAIRING_VARIATION = 2 , VX_FAIRING_JERK = 3 ,
VX_FAIRING_BEND = 4 , VX_FAIRING_TENSION = 5
}
fairing modes More...
enum | evxContinuityTyp { VX_CONTIN_NONE = 0 , VX_CONTIN_G1 = 1 , VX_CONTIN_G2 = 2 , VX_CONTIN_G3 = 3 }
Continuity option. More...
enum evxPlacingType {
VX_PLACING_NONE = -1 , VX_PLACING_VIEW = 0 , VX_PLACING_VECTOR = 1 , VX_PLACING_WCS = 2 ,
VX_PLACING_PLANE = 3
}
placing adjustment type More...
typedef enum evxFairingType | evxFairingType
fairing modes
typedef struct svxCrvIntData | svxCrvIntData
2D/3D interpolated curve
typedef enum evxContinuityTyp | evxContinuityTyp
Continuity option.
typedef struct svxSplinePnt | svxSplinePnt
Spline point.
typedef enum evxPlacingType | evxPlacingType
placing adjustment type
typedef struct svxSplineData | svxSplineData
Spline command data.

View Data

enum evxViewStd {
VX_VIEW_FRONT = 0 , VX_VIEW_BACK = 1 , VX_VIEW_TOP = 2 , VX_VIEW_BOTTOM = 3 ,
VX_VIEW_RIGHT = 4 , VX_VIEW_LEFT = 5 , VX_VIEW_ISO = 6 , VX_VIEW_AUX = 7 ,
VX_VIEW_PLANE = 8
}
standard 3D view orientations More...
typedef struct svxView | svxView
view data(Z3PRT,Z3ASM)
typedef enum evxViewStd | evxViewStd
standard 3D view orientations

ZW3D environment

enum evxEnvironment {
VX_ENV_Z3FILE = 2 , VX_ENV_SKETCH , VX_ENV_SHEET , VX_ENV_PACKET ,
VX_ENV_CAM , VX_ENV_ANIMATION , VX_ENV_EXPLODEDVIEW , VX_ENV_3DSKETCH ,
VX_ENV_PART , VX_ENV_ECAD_PART , VX_ENV_ECAD_ASSEMBLY , VX_ENV_ASSEMBLY ,
VX_ENV_PIPING
}
zw3d environment More...
typedef enum evxEnvironment evxEnvironment
zw3d environment

Cam Data

enum | evxCmAttrValueType { ZW_CAM_ATTR_VALUE_TYPE_INVALID = -1 , ZW_CAM_ATTR_VALUE_TYPE_INTEGER = 0 , ZW_CAM_ATTR_VALUE_TYPE_DOUBLE , ZW_CAM_ATTR_VALUE_TYPE_STRING }
cam data attribute type More...
enum evxCmPlanDispMode {
CM_ACTIVE_LOCK = 0 , CM_ACTIVE_PART = 1 , CM_ACTIVE_PROCESS = 2 , CM_ACTIVE_SETUP = 3 ,
CM_ACTIVE_TOOLPATH = 4 , CM_ACTIVE_MACHINE = 5 , CM_ACTIVE_TOOL = 6 , CM_ACTIVE_TACTIC = 7 ,
CM_ACTIVE_SPDFD = 8 , CM_ACTIVE_CMCOMP = 9 , CM_ACTIVE_FTRGRP = 10 , CM_ACTIVE_FTRSET = 11 ,
CM_ACTIVE_NEST = 12 , CM_ACTIVE_WIZARD = 13 , CM_ACTIVE_PUNCH = 14 , CM_ACTIVE_HOLDER = 15
}
cam plan display mode More...
enum | evxCmTreeType { CM_TREE_OP = 0 , CM_TREE_COMP = 1 , CM_TREE_FLD = 2 , CM_TREE_FTR = 3 }
cam tree type More...
typedef enum evxCmAttrValueType | evxCmAttrValueType
cam data attribute type
typedef struct svxCmAttrValue | svxCmAttrValue
cam data attribute value
typedef enum evxCmPlanDispMode | evxCmPlanDispMode
cam plan display mode
typedef enum evxCmTreeType | evxCmTreeType
cam tree type

Basic String Types

typedef char | vxName[32]
object name (null-terminated text string) More...
typedef char | vxLongName[256]
long object name (null-terminated text string) More...
typedef char | vxPath[256]
file path or file name (null-terminated text string) More...
typedef char | vxRootName[256]
root object name (null-terminated text string) More...
typedef char | vxExp[256]
arithmetic expression (null-terminated text string) More...
typedef char | vxVarExp[1024]
variable expression (null-terminated text string) More...
typedef char | vxLongPath[512]
file path or file name (null-terminated text string) More...

Basic Integer Types

typedef unsigned int vxUint32
32 bit unsigned integer More...

Limits/3D Bounding Box

typedef struct svxLimit | svxLimit
limits
typedef struct svxBndBox | svxBndBox
3D bounding box

Face Attribute

typedef struct svxFaceAt svxFaceAt
face display attributes

Profile Attribute

typedef struct svxPrfAreaProp svxPrfAreaProp
profile area property

Facets

typedef struct svxShaderAt | svxShaderAt
shader attribute
typedef struct svxFacets | svxFacets
3D facets defined by triangle strips

Component Info

typedef struct svxCompName svxCompName
brief component info

Macros

#define | ZW_API_UTIL_H
#define | VX_API_VERSION 2800
API version number. More...
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_var.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_var.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Variable API Note – The common functions of variable are defined in this header file.

Definition in file zwapi_var.h.

Equations Edit Data

enum | evxEqnSetOpt { VX_EQN_MANUAL_SET_EQN = 0 , VX_EQN_AUTO_OVERWRITE_ALL_EQN = 1 , VX_EQN_AUTO_NEW_ALL_EQN = 2 , VX_EQN_AUTO_CANCEL_ALL_EQN = -1 }
equation set option More...
typedef enum evxEqnSetOpt | evxEqnSetOpt
equation set option

Equation Query

evxErrors | cvxPartInqEqnSetMembers (int idSet, int *count, int **idList)
evxErrors | cvxPartInqEqnAssociatedSet (int idEqn, int *idSet)
evxErrors | cvxEqGetExpByName (char *name, char *exp, int size)
evxErrors | cvxEqGetDescById (int idEqn, char *desc, int size)
evxErrors | cvxEqSetDescById (int idEqn, char *desc)

Equation Edit

evxErrors | cvxPartVarSubstitute (char *Str, int nBytes, int *Truncated)
evxErrors | cvxPartVarSubstituteResize (char **Str)
evxErrors | cvxEqLoadFile (const vxLongPath fullpath, evxEqnSetOpt option)
evxErrors | cvxEqRegen (int idEqn)
evxErrors | cvxPartEqnDelete (int idEqn)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_view.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_view.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D View API

Definition in file zwapi_view.h.

View Query

int | cvxViewIsSection (int idView)
int | cvxViewIsStandard (int idView)
evxErrors | cvxViewInqStandardType (int idView, evxViewStd *type)

View Operation

evxErrors | cvxViewActivate (int idView)
void | cvxViewExtent (double Extent)
void | cvxViewGet (svxMatrix *Frame, double *Extent)
void | cvxViewSet (svxMatrix *Frame, double Extent)
void | cvxViewOrigin (svxPoint *Origin)
void | cvxViewStd (evxViewStd Type, double NullExtent)
evxErrors | cvxViewSetBndBox (double Scale, const svxBndBox *BndBox)
evxErrors | cvxGetViewRect (int includeFrame, int isGlobal, int *tlX, int *tlY, int *brX, int *brY)

Custom View

evxErrors | cvxCustomViewAdd (char *Name, int LyrVis, int ObjVis, int *idView)
evxErrors | cvxCustomViewActivate (int idView)
evxErrors | cvxCustomViewDel (int idView)
evxErrors | cvxCustomViewId (vxName Name, int *idView)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_xn.h File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
Macros
zwapi_xn.h File Reference
#include "zwapi_util.h"

Go to the source code of this file.

Detailed Description

Copyright
(C) Copyright 2022, ZWSOFT CO., LTD. (Guangzhou) All Rights Reserved.
Note
THE HEADER FILE FOR THE ZW3D Transaction Operation API

Definition in file zwapi_xn.h.

Undo/Redo

int | cvxOpCount (void)
int | cvxXnUndoCount ()
evxErrors | cvxUndoRedoMarker (vxName Name)
evxErrors | cvxUndoRedo (int Undo)
evxErrors | cvxUndoRedoTo (int Undo, vxName Name)
evxErrors | cvxPartNameLastOp (vxName NewName)

Transaction Bundle

evxErrors | cvxXnBundle (int iCount, const char *xn_name)
void | cvxUndoBundleStart (int DisableManager, int Settings[])
void | cvxUndoBundleEnd (int RefreshDisplay, int Settings[], int isError)
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: Examples

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Examples
Here is a list of all examples:
  • drawing\dwgDimTest.cpp
  • drawing\dwgTableTest.cpp
  • drawing\dwgViewTest.cpp
  • part\asmConsTest.cpp
  • part\baseFtrCrtTest.cpp
  • part\datumCrtTest.cpp
  • part\freeFormFtrCrtTest.cpp
  • part\partUtils.cpp
  • part\pmiCrtTest.cpp
  • part\shapeFtrCrtTest.cpp
  • part\skCrtTest.cpp
  • part\smdFtrCrtTest.cpp
  • part\wireframeFtrCrtTest.cpp
  • sketch\skDrawingTest.cpp
  • sketch\basicEditingTest.cpp
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: drawing\dwgDimTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
drawing\dwgDimTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <vector>
ApiDefVoidFunc(zwTestDwgAutoDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgLineDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgBaseLineDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgContinuousDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgOrdinateDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgLineOffsetDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgAngDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgArcDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgHoleCallOutDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgRadDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgBalloonDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgFtrCtrlDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgCenterMarkDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgCenterLineDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgCenMarkCirDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgDatumTargDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgDatumDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgSymmetryDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgLabelCoorDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgLnrChmDimAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgAutoBlnAdd, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgStkBlnAdd, VX_CODE_GENERAL);
void zwTestDwgAutoDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgAutoDimAdd.
*/
{
/* initialize auto dimension data */
svxDimAuto autoDim;
if (cvxDwgAutoDimAddInit(&autoDim))
zwTestLogErrorMsg(5, "cvxDwgAutoDimAddInit: failed to initialize auto dimension data!");
cvxGetEnt("[View]Select one view to create auto dimension", VX_INP_GENERAL_2D, 0, &autoDim.idView);
if (cvxEntClassNum(autoDim.idView) != VX_ENT_DWG_VIEW) return;
double val = 0.0;
cvxGetNumber("[Entity Type]Enter number to select entity type(0: all; 1: all arc and circle; 2: picked)", &val);
switch (int(val + 0.5))
{
case 1: autoDim.entType = DIM_AUTO_ENT_ARC_CIRCLE; break;
case 2: autoDim.entType = DIM_AUTO_ENT_PICKED; break;
default: autoDim.entType = DIM_AUTO_ENT_ALL; break;
}
if (autoDim.entType == DIM_AUTO_ENT_PICKED)
cvxGetEnts("[Entities]Select specified entities, <middle-click> when done", VX_INP_GENERAL_2D, 0, &autoDim.cntEnt, &autoDim.pEntId);
cvxGetNumber("[Include Geometry]Enter number to switch incluing geometry(0: default; 1: picked; 2: all; 3: none)", &val);
switch (int(val+0.5))
{
case 1:
{
autoDim.incAuto = VX_AUTOINC_INVALID;
cvxGetNumber("[Include Arc]Whether to include arc(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_ARC;
cvxGetNumber("[Include Circle]Whether to include circle(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_CIRCLE;
cvxGetNumber("[Include Hole]Whether to include hole(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_HOLE;
cvxGetNumber("[Include Line]Whether to include line(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_LINE;
cvxGetNumber("[Include Hole Callout]Whether to include Hole callout(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_HOLE_CALLOUT;
cvxGetNumber("[Include Cylindrical Dimensions]Whether to include cylindrical dimensions(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_CYLIND_DIM;
cvxGetNumber("[Include Maximum Dimensions]Whether to include maximum dimensions(1: enable; 0: disable)", &val);
if (int(val + 0.5)) autoDim.incAuto |= VX_AUTOINC_MAXIMUM_DIM;
}
break;
case 2: autoDim.incAuto = (uint)VX_AUTOINC_VALID; break;
case 3: autoDim.incAuto = VX_AUTOINC_INVALID; break;
default: break;
}
cvxGetNumber("[Origin]Whether to use origin point(1: enable; 0: disable)", &val);
autoDim.checkOrg = ((int)(val + 0.5) == 1 ? 1 : 0);
if (autoDim.checkOrg == 1) zwUtilGetPntOrDirOnEnt(0, &autoDim.pntOrg);
for (int i = 0; i < 2; i++)
{
svxAutoSet* dim = (i == 0 ? &autoDim.horDim : &autoDim.verDim);
cvxGetNumber(i == 0 ? "Enable horizontal(1: enable; 0: disable)" : "Enable vertical(1: enable; 0: disable)", &val);
dim->enable = ((int)(val + 0.5) == 1 ? 1 : 0);
if (!dim->enable) continue;
cvxGetNumber("[Dimension Type]Enter number to select type(0: baseline; 1: continuous; 2: ordinate; 3: label ordinate)", &val);
switch (int(val + 0.5))
{
case 1: dim->type = DIM_AUTO_CONTINUOUS; break;
case 2: dim->type = DIM_AUTO_ORDINATE; break;
case 3: dim->type = DIM_AUTO_LABEL_COORDINATE; break;
default: dim->type = DIM_AUTO_BASELINE; break;
}
if (!autoDim.checkOrg)
zwUtilGetPntOrDirOnEnt(0, &dim->refPnt);
cvxGetNumber("[Placement]Enter number to select type(0: left or above of view; 1: right or below of view; 2: both of view)", &val);
switch (int(val + 0.5))
{
case 1: dim->viewType = DIM_VIEW_BELOW_RIGHT; break;
case 2: dim->viewType = DIM_VIEW_BOTH; break;
default: dim->viewType = DIM_VIEW_ABOVE_LEFT; break;
}
cvxGetNumber("[Dimension as group](1: enable; 0: disable)", &val);
dim->asgrp = ((int)(val + 0.5) == 1 ? 1 : 0);
}
/* auto dimension */
int idDim = 0;
if (cvxDwgAutoDimAdd(&autoDim, &idDim) || idDim < 1)
zwTestLogErrorMsg(5, "cvxDwgAutoDimAdd: failed to add auto dimension!");
/* free memory */
cvxMemFree((void**)&autoDim.pEntId);
}
void zwTestDwgLineDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgLineDimAdd.
*/
{
svxDwgLineDim lineDim = {};
/* set dimension type */
double val = 0.0;
cvxGetNumber("[Dimension Type]Enter number to select type(0: horizontal; 1: vertical; 2: aligned; 3: rotated; 4: projected)", &val);
switch (int(val + 0.5))
{
case 1: lineDim.cons.type = VX_DIM_LINE_LV; break;
case 2: lineDim.cons.type = VX_DIM_LINE_LA; break;
case 3: lineDim.cons.type = VX_DIM_LINE_LR; break;
case 4: lineDim.cons.type = VX_DIM_LINE_LP; break;
default: lineDim.cons.type = VX_DIM_LINE_LH; break;
}
cvxGetPoint("[1st Point]Specify first dimension point", VX_INP_PNT_END, 0, &lineDim.cons.firstPnt.pnt, &lineDim.cons.firstPnt.idEnt);
cvxGetPoint("[2nd Point]Specify second dimension point", VX_INP_PNT_END, 0, &lineDim.cons.secondPnt.pnt, &lineDim.cons.secondPnt.idEnt);
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &lineDim.cons.textPnt.pnt, &lineDim.cons.textPnt.idEnt);
if (lineDim.cons.type == VX_DIM_LINE_LR)
cvxGetNumber("[Angle]Specify angle of rotation", &lineDim.angle);
if (lineDim.cons.type == VX_DIM_LINE_LP)
{
cvxGetEnt("[Line]Specify line to project dimension to", VX_INP_PROF, 0, &lineDim.dirPnt.idEnt);
lineDim.dirPnt.useCritPnt = 1;
lineDim.dirPnt.critTyp = VX_START_POINT;
}
/* add linear dimension */
int idDim = 0;
if (cvxDwgLineDimAdd(&lineDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgLineDimAdd: failed to add a linear dimension!");
}
void zwTestDwgBaseLineDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgBaseLineDimAdd.
*/
{
svxDwgLineGrpDim lineGrpDim = {};
/* set dimension type */
double val = 0.0;
cvxGetNumber("[Dimension Type]Enter number to select type(0: horizontal; 1: vertical; 2: aligned; 3: rotated; 4: projected)", &val);
switch (int(val + 0.5))
{
case 1: lineGrpDim.sub.cons.type = VX_DIM_LINE_LV; break;
case 2: lineGrpDim.sub.cons.type = VX_DIM_LINE_LA; break;
case 3: lineGrpDim.sub.cons.type = VX_DIM_LINE_LR; break;
case 4: lineGrpDim.sub.cons.type = VX_DIM_LINE_LP; break;
default: lineGrpDim.sub.cons.type = VX_DIM_LINE_LH; break;
}
cvxGetPoint("[1st Point]Specify first dimension point", VX_INP_PNT_END, 0, &lineGrpDim.sub.cons.firstPnt.pnt, &lineGrpDim.sub.cons.firstPnt.idEnt);
cvxGetPoint("[2nd Point]Specify second dimension point", VX_INP_PNT_END, 0, &lineGrpDim.sub.cons.secondPnt.pnt, &lineGrpDim.sub.cons.secondPnt.idEnt);
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &lineGrpDim.sub.cons.textPnt.pnt, &lineGrpDim.sub.cons.textPnt.idEnt);
if (lineGrpDim.sub.cons.type == VX_DIM_LINE_LR)
cvxGetNumber("[Angle]Specify angle of rotation", &lineGrpDim.sub.angle);
if (lineGrpDim.sub.cons.type == VX_DIM_LINE_LP)
{
cvxGetEnt("[Line]Specify line to project dimension to", VX_INP_PROF, 0, &lineGrpDim.sub.dirPnt.idEnt);
lineGrpDim.sub.dirPnt.useCritPnt = 1;
lineGrpDim.sub.dirPnt.critTyp = VX_START_POINT;
}
std::vector<svxPntOnEnt> vPntOnEnt;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("[Points]Specify dimension point, <ESC> when done", VX_INP_PNT_END, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt) || pntOnEnt.idEnt < 1)
break;
vPntOnEnt.push_back(pntOnEnt);
}
lineGrpDim.cntCrv = (int)vPntOnEnt.size();
lineGrpDim.Points = vPntOnEnt.data();
/* add baseline dimension */
int idDim = 0;
if (cvxDwgBaseLineDimAdd(&lineGrpDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgBaseLineDimAdd: failed to add a baseline dimension!");
}
void zwTestDwgContinuousDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgContinuousDimAdd.
*/
{
svxDwgLineGrpDim contGrpDim = {};
/* set dimension type */
double val = 0.0;
cvxGetNumber("[Dimension Type]Enter number to select type(0: horizontal; 1: vertical; 2: aligned; 3: rotated; 4: projected)", &val);
switch (int(val + 0.5))
{
case 1: contGrpDim.sub.cons.type = VX_DIM_LINE_LV; break;
case 2: contGrpDim.sub.cons.type = VX_DIM_LINE_LA; break;
case 3: contGrpDim.sub.cons.type = VX_DIM_LINE_LR; break;
case 4: contGrpDim.sub.cons.type = VX_DIM_LINE_LP; break;
default: contGrpDim.sub.cons.type = VX_DIM_LINE_LH; break;
}
cvxGetPoint("[1st Point]Specify first dimension point", VX_INP_PNT_END, 0, &contGrpDim.sub.cons.firstPnt.pnt, &contGrpDim.sub.cons.firstPnt.idEnt);
cvxGetPoint("[2nd Point]Specify second dimension point", VX_INP_PNT_END, 0, &contGrpDim.sub.cons.secondPnt.pnt, &contGrpDim.sub.cons.secondPnt.idEnt);
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &contGrpDim.sub.cons.textPnt.pnt, &contGrpDim.sub.cons.textPnt.idEnt);
if (contGrpDim.sub.cons.type == VX_DIM_LINE_LR)
cvxGetNumber("[Angle]Specify angle of rotation", &contGrpDim.sub.angle);
if (contGrpDim.sub.cons.type == VX_DIM_LINE_LP)
{
cvxGetEnt("[Line]Specify line to project dimension to", VX_INP_PROF, 0, &contGrpDim.sub.dirPnt.idEnt);
contGrpDim.sub.dirPnt.useCritPnt = 1;
contGrpDim.sub.dirPnt.critTyp = VX_START_POINT;
}
std::vector<svxPntOnEnt> vPntOnEnt;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("[Points]Specify dimension point, <ESC> when done", VX_INP_PNT_END, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt) || pntOnEnt.idEnt < 1)
break;
vPntOnEnt.push_back(pntOnEnt);
}
contGrpDim.cntCrv = (int)vPntOnEnt.size();
contGrpDim.Points = vPntOnEnt.data();
/* add continuous dimension */
int idDim = 0;
if (cvxDwgContinuousDimAdd(&contGrpDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgContinuousDimAdd: failed to add a continuous dimension!");
}
void zwTestDwgOrdinateDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgOrdinateDimAdd.
*/
{
svxDwgOrdinateDim ordDim = {};
/* set dimension type */
double val = 0.0;
cvxGetNumber("[Dimension Type]Enter number to select type(0: horizontal; 1: vertical; 2: aligned; 3: rotated; 4: projected, 5: ordinate)", &val);
switch (int(val + 0.5))
{
case 1: ordDim.sub.cons.type = VX_DIM_LINE_LV; break;
case 2: ordDim.sub.cons.type = VX_DIM_LINE_LA; break;
case 3: ordDim.sub.cons.type = VX_DIM_LINE_LR; break;
case 4: ordDim.sub.cons.type = VX_DIM_LINE_LP; break;
case 5: ordDim.sub.cons.type = VX_DIM_LINE_LO; break;
default: ordDim.sub.cons.type = VX_DIM_LINE_LH; break;
}
cvxGetPoint("[1st Point]Specify first dimension point", VX_INP_PNT_END, 0, &ordDim.sub.cons.firstPnt.pnt, &ordDim.sub.cons.firstPnt.idEnt);
if (ordDim.sub.cons.type != VX_DIM_LINE_LO)
{
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &ordDim.sub.cons.textPnt.pnt, &ordDim.sub.cons.textPnt.idEnt);
}
else
{
cvxGetPoint("[Horizontal Text Point]Specify dimension horizontal text point", VX_INP_PNT_GENERAL, 0, &ordDim.textPnt[0].pnt, &ordDim.textPnt[0].idEnt);
cvxGetPoint("[Vertical Text Point]Specify dimension vertical text point", VX_INP_PNT_GENERAL, 0, &ordDim.textPnt[1].pnt, &ordDim.textPnt[1].idEnt);
}
if (ordDim.sub.cons.type == VX_DIM_LINE_LR)
cvxGetNumber("[Angle]Specify angle of rotation", &ordDim.sub.angle);
if (ordDim.sub.cons.type == VX_DIM_LINE_LP)
{
cvxGetEnt("[Line]Specify line to project dimension to", VX_INP_PROF, 0, &ordDim.sub.dirPnt.idEnt);
ordDim.sub.dirPnt.useCritPnt = 1;
ordDim.sub.dirPnt.critTyp = VX_START_POINT;
}
std::vector<svxPntOnEnt> vPntOnEnt;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("[Points]Specify dimension point, <ESC> when done", VX_INP_PNT_END, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt) || pntOnEnt.idEnt < 1)
break;
vPntOnEnt.push_back(pntOnEnt);
}
ordDim.cntCrv = (int)vPntOnEnt.size();
ordDim.Points = vPntOnEnt.data();
cvxGetNumber("[Reverse Axis 1](1: enable; 0: disable)", &val);
ordDim.reverseAxis1 = ((int)(val + 0.5) == 1 ? 1 : 0);
if (ordDim.sub.cons.type == VX_DIM_LINE_LO)
{
cvxGetNumber("[Reverse Axis 2](1: enable; 0: disable)", &val);
ordDim.reverseAxis2 = ((int)(val + 0.5) == 1 ? 1 : 0);
}
int idShareDim = 0;
cvxGetEnt("[Share origin]Select group dimension", VX_INP_GENERAL_2D, 1, &idShareDim);
if (cvxEntClassNum(idShareDim) == VX_ENT_DIMEN)
{
evxDimType dimType = VX_DIM_LAST;
cvxDimInqType(idShareDim, &dimType);
if (dimType == VX_DIM_BASELINE || dimType == VX_DIM_CONTINUOUS || dimType == VX_DIM_ORDINATE)
ordDim.idEnt = idShareDim;
}
/* add ordinate dimension */
int idDim = 0;
if (cvxDwgOrdinateDimAdd(&ordDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgOrdinateDimAdd: failed to add a ordinate dimension!");
}
void zwTestDwgLineOffsetDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgLineOffsetDimAdd.
*/
{
svxDwgLineOffsetDim lineOffDim = {};
/* set dimension type */
double val = 0.0;
cvxGetNumber("[Dimension Type]Enter number to select type(0: line to line; 1: point to line)", &val);
switch (int(val + 0.5))
{
case 1: lineOffDim.type = VX_DIM_OFFSET_LOP; break;
default: lineOffDim.type = VX_DIM_OFFSET_LOL; break;
}
cvxGetPoint("[1st Point]Specify first dimension point", VX_INP_PNT_END, 0, &lineOffDim.firstPnt.pnt, &lineOffDim.firstPnt.idEnt);
cvxGetPoint("[2nd Point]Specify second dimension point", VX_INP_PNT_END, 0, &lineOffDim.secondPnt.pnt, &lineOffDim.secondPnt.idEnt);
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &lineOffDim.textPnt.pnt, &lineOffDim.textPnt.idEnt);
/* add a linear offset dimension */
int idDim = 0;
if (cvxDwgLineOffsetDimAdd(&lineOffDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgLineOffsetDimAdd: failed to add a linear offset dimension!");
}
void zwTestDwgCenterMarkDimAdd(void)
/*
DESCRIPTION:
Test case for function cvxDwgCenterMarkDimAdd.
*/
{
/* initialize a center mark dimension */
svxCenterMark cenMarkDim;
if (cvxDwgCenterMarkDimAddInit(&cenMarkDim))
zwTestLogErrorMsg(5, "cvxDwgCenterMarkDimAddInit: failed to initialize a center mark dimension!");
cvxGetPoint("[Arc]Select arc to add mark", VX_INP_PNT_ON_ENTITY, 0, &cenMarkDim.zEntPnt, &cenMarkDim.idEntity);
if (!cvxGetPoint("[Arc]Select arc to add mark, <ESC> when done", VX_INP_PNT_GENERAL, 1, &cenMarkDim.zRotPnt.pnt, &cenMarkDim.zRotPnt.idEnt))
cenMarkDim.useRotPnt = 1;
double val = 0.0;
/* set mark type */
cvxGetNumber("[Mark Type]Enter number to select type(0: center mark; 1: center mark circle; 2: center line)", &val);
switch (int(val + 0.5))
{
case 1: cenMarkDim.cmType = VX_DM_CENLINE; break;
case 2: cenMarkDim.cmType = VX_DM_CENDLINE; break;
default: cenMarkDim.cmType = VX_DM_CENMARK; break;
}
cvxGetNumber("[Center Line/Mark Size]the default is 4.254534", &cenMarkDim.zCenterDim.cmSize);
cvxGetNumber("[Extension Lines Break Length]the default is 1.5", &cenMarkDim.zCenterDim.breakLen);
cvxGetNumber("[Extension Lines Overrun]the default is 3.06324", &cenMarkDim.zCenterDim.overRun);
cvxGetNumber("[Overall Scale Factor]the default is 1.0", &cenMarkDim.zCenterDim.scaleFac);
/* set slot type */
cvxGetNumber("[Mark Slot]Enter number to select type(0: slot centers; 1: slot ends)", &val);
cenMarkDim.slotType = (int(val + 0.5) == 1 ? 2 : 1);
/* add a center mark dimension */
int idDim = 0;
if (cvxDwgCenterMarkDimAdd(&cenMarkDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgCenterMarkDimAdd: failed to add a center mark dimension!");
}
void zwTestDwgCenterLineDimAdd(void)
/*
DESCRIPTION:
Test case for function cvxDwgCenterLineDimAdd.
*/
{
/* initialize a center line dimension */
svxCenterLine cenLineDim;
if (cvxDwgCenterLineDimAddInit(&cenLineDim))
zwTestLogErrorMsg(5, "cvxDwgCenterLineDimAddInit: failed to initialize a center line dimension!");
double val = 0.0;
cvxGetNumber("[Mark Type]Enter number to select type(0: draw by two lines; 1: draw by two points)", &val);
cenLineDim.iDimType = (int(val + 0.5) == 1 ? VX_CL_BY_TWO_POINTS : VX_CL_BY_TWO_LINES);
evxPntInpOpt type = VX_INP_PNT_ON_ENTITY;
if (cenLineDim.iDimType == VX_CL_BY_TWO_POINTS) type = VX_INP_PNT_GENERAL;
cvxGetPoint("[Start point]Select arc to add mark", type, 0, &cenLineDim.zPntStart.pnt, &cenLineDim.zPntStart.idEnt);
cvxGetPoint("[End point]Select arc to add mark", type, 0, &cenLineDim.zPntEnd.pnt, &cenLineDim.zPntEnd.idEnt);
cvxGetNumber("[Center Line/Mark Size]the default is 4.254534", &cenLineDim.zCenterDim.cmSize);
cvxGetNumber("[Extension Lines Break Length]the default is 1.5", &cenLineDim.zCenterDim.breakLen);
cvxGetNumber("[Extension Lines Overrun]the default is 3.06324", &cenLineDim.zCenterDim.overRun);
cvxGetNumber("[Overall Scale Factor]the default is 1.0", &cenLineDim.zCenterDim.scaleFac);
/* add a center line dimension */
int idDim = 0;
if (cvxDwgCenterLineDimAdd(&cenLineDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgCenterLineDimAdd: failed to add a center line dimension!");
}
void zwTestDwgCenMarkCirDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgCenMarkCirDimAdd.
*/
{
/* initialize a center mark circle dimension */
svxCenMarkCirDimData cenMarkCirDim;
if (cvxDwgCenMarkCirDimAddInit(&cenMarkCirDim))
zwTestLogErrorMsg(5, "cvxDwgCenMarkCirDimAddInit: failed to initialize a center mark circle dimension!");
svxPoint* points = nullptr;
svxEntPath* paths = nullptr;
cvxGetPointsOnEnts("select point for center mark", VX_INP_PNT_ON_ENTITY, 0, &cenMarkCirDim.iCntCens, &points, &paths);
cvxMemAlloc(cenMarkCirDim.iCntCens * sizeof(svxPntOnEnt), (void**)&cenMarkCirDim.pCens);
cvxMemZero(cenMarkCirDim.pCens, cenMarkCirDim.iCntCens * sizeof(svxPntOnEnt));
for (int i = 0; i < cenMarkCirDim.iCntCens; i++)
{
cenMarkCirDim.pCens[i].pnt = points[i];
cenMarkCirDim.pCens[i].idEnt = paths[i].Id[paths->Count - 1];
}
double val = 0;
cvxGetNumber("use arc or circle: 0 or 1, default 1", &val);
if (int(val + 0.5) == 0)
cenMarkCirDim.iflg = 0;
cvxGetNumber("whether use center: 0 or 1", &val);
if (int(val + 0.5))
{
cenMarkCirDim.flgCenter = 1;
cvxGetPoint(
"select center point", VX_INP_PNT_GENERAL, 0, &cenMarkCirDim.center.pnt, &cenMarkCirDim.center.idEnt);
}
/* add a center mark circle dimension */
int idDim = 0;
if (cvxDwgCenMarkCirDimAdd(&cenMarkCirDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgCenMarkCirDimAdd: failed to add a center mark circle dimension!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&paths);
cvxMemFree((void**)&cenMarkCirDim.pCens);
}
void zwTestDwgDatumTargDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgDatumTargDimAdd.
*/
{
/* initialize a datum target dimension */
svxDatumTargDimData datumTargDim;
if (cvxDwgDatumTargDimAddInit(&datumTargDim))
zwTestLogErrorMsg(5, "cvxDwgDatumTargDimAddInit: failed to initialize a datum target dimension!");
double val = 0;
cvxGetNumber("select datum target type: 0 - 3", &val); /* 3 as default */
if (int(val + 0.5) == 0)
datumTargDim.type = VX_DATUMT_CIRCLE;
else if (int(val + 0.5) == 1)
datumTargDim.type = VX_DATUMT_RECTANGLE;
else if (int(val + 0.5) == 2)
datumTargDim.type = VX_DATUMT_LINE;
cvxGetPoint("select target point", VX_INP_PNT_GENERAL, 0, &datumTargDim.pnt.pnt, &datumTargDim.pnt.idEnt);
if (datumTargDim.type == VX_DATUMT_LINE)
cvxGetPoint(
"select end point for line", VX_INP_PNT_GENERAL, 0, &datumTargDim.secPnt.pnt, &datumTargDim.secPnt.idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &datumTargDim.textPnt.pnt, &datumTargDim.textPnt.idEnt);
cvxGetNumber("use area text or user text: 0 or 1", &val);
if (int(val + 0.5))
datumTargDim.iAreaSizeText = 1;
datumTargDim.diameter = 10; /* for circle */
datumTargDim.height = 15; /* for rectangle */
datumTargDim.width = 20; /* for rectangle */
datumTargDim.text = "t1";
datumTargDim.text2 = "t2";
datumTargDim.text3 = "t3";
datumTargDim.userText = "user text"; /* for iAreaSizeText = 1 */
/* add a datum target dimension */
int idDim = 0;
if (cvxDwgDatumTargDimAdd(&datumTargDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgDatumTargDimAdd: failed to add a datum target dimension!");
}
void zwTestDwgDatumDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgDatumDimAdd.
*/
{
svxDatumDimData datumDim;
cvxMemZero(&datumDim, sizeof(svxDatumDimData));
double val = 0;
cvxGetNumber("select datum type: 1 or 2, 1 as default", &val);
if (int(val + 0.5) == 2)
datumDim.type = VX_DATUM_ANSI;
else
datumDim.type = VX_DATUM_NORMAL;
cvxGetPoint("select a point on curve", VX_INP_PNT_ON_CURVE, 0, &datumDim.leadPnt.pnt, &datumDim.leadPnt.idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &datumDim.txtPnt.pnt, &datumDim.txtPnt.idEnt);
datumDim.text = "text";
/* create a datum feature dimension */
int idDim = 0;
if (cvxDwgDatumDimAdd(&datumDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgDatumDimAdd: failed to add a datum feature dimension!");
}
void zwTestDwgSymmetryDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgSymmetryDimAdd.
*/
{
svxDwgSymmetryDimData symmetryDim;
cvxMemZero(&symmetryDim, sizeof(svxDwgSymmetryDimData));
double val = 0;
cvxGetNumber("select symmetry dimension type: 1 or 2", &val);
if (int(val + 0.5) == 1)
{
symmetryDim.type = VX_SYM_LINEAR;
cvxGetPoint("select a point on curve", VX_INP_PNT_ON_CURVE, 0, &symmetryDim.Pnt.pnt, &symmetryDim.Pnt.idEnt);
}
else
{
symmetryDim.type = VX_SYM_ANGULAR;
cvxGetPoint(
"select a point on line", VX_INP_PNT_ON_CURVE, 0, &symmetryDim.LinePnt.pnt, &symmetryDim.LinePnt.idEnt);
}
cvxGetPoint(
"pick a center line", VX_INP_PNT_ON_EDGE, 0, &symmetryDim.CenterLinePnt.pnt, &symmetryDim.CenterLinePnt.idEnt);
cvxGetPoint("pick a text point", VX_INP_PNT_GENERAL, 0, &symmetryDim.txtPnt.pnt, nullptr);
/* add a symmetry dimension */
int idDim = 0;
if (cvxDwgSymmetryDimAdd(&symmetryDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgSymmetryDimAdd: failed to add a symmetry dimension!");
}
void zwTestDwgAngDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgAngDimAdd.
*/
{
svxDwgAngDimData angDim;
cvxMemZero(&angDim, sizeof(svxDwgAngDimData));
double val = 0;
cvxGetNumber("select angular or diameter type: 1 - 5", &val);
switch (int(val + 0.5))
{
case 1:
angDim.type = VX_ANG_TWOCURVES;
cvxGetPoint("select first curve", VX_INP_PNT_ON_CURVE, 0, &angDim.Curve1.pnt, &angDim.Curve1.idEnt);
cvxGetPoint("select second curve", VX_INP_PNT_ON_CURVE, 0, &angDim.Curve2.pnt, &angDim.Curve2.idEnt);
cvxGetPoint("select quadrant point", VX_INP_PNT_GENERAL, 0, &angDim.QuadrantPnt.pnt, &angDim.QuadrantPnt.idEnt);
break;
case 2:
angDim.type = VX_ANG_HORIZONTAL;
cvxGetPoint("select first curve", VX_INP_PNT_ON_CURVE, 0, &angDim.Curve1.pnt, &angDim.Curve1.idEnt);
cvxGetPoint("select quadrant point", VX_INP_PNT_GENERAL, 0, &angDim.QuadrantPnt.pnt, &angDim.QuadrantPnt.idEnt);
break;
case 3:
angDim.type = VX_ANG_VERTICAL;
cvxGetPoint("select first curve", VX_INP_PNT_ON_CURVE, 0, &angDim.Curve1.pnt, &angDim.Curve1.idEnt);
cvxGetPoint("select quadrant point", VX_INP_PNT_GENERAL, 0, &angDim.QuadrantPnt.pnt, &angDim.QuadrantPnt.idEnt);
break;
case 4:
angDim.type = VX_ANG_THREEPOINT;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &angDim.StartPnt.pnt, &angDim.StartPnt.idEnt);
cvxGetPoint("select base point", VX_INP_PNT_GENERAL, 0, &angDim.BasePnt.pnt, &angDim.BasePnt.idEnt);
cvxGetPoint("select end point", VX_INP_PNT_GENERAL, 0, &angDim.EndPnt.pnt, &angDim.EndPnt.idEnt);
cvxGetPoint("select quadrant point", VX_INP_PNT_GENERAL, 0, &angDim.QuadrantPnt.pnt, &angDim.QuadrantPnt.idEnt);
break;
case 5:
angDim.type = VX_ANG_ARC;
cvxGetPoint("select an arc", VX_INP_PNT_ON_CURVE, 0, &angDim.ArcPnt.pnt, &angDim.ArcPnt.idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &angDim.txtPnt.pnt, &angDim.txtPnt.idEnt);
break;
default:
zwTestLogErrorMsg(5, "cvxDwgAngDimAdd: invalid option!");
break;
}
/* add a angular dimension */
int idDim = 0;
if (cvxDwgAngDimAdd(&angDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgAngDimAdd: failed to add a angular dimension!");
}
void zwTestDwgArcDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgArcDimAdd.
*/
{
svxDwgArcDimData arcDim = { 0 };
cvxGetPoint("select a point on an arc", VX_INP_PNT_ON_CURVE, 0, &arcDim.ArcEnt.pnt, &arcDim.ArcEnt.idEnt);
cvxGetPoint("select a text point", VX_INP_PNT_GENERAL, 0, &arcDim.txtPnt.pnt, &arcDim.txtPnt.idEnt);
/* add an arc dimension */
int idDim = 0;
if (cvxDwgArcDimAdd(&arcDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgArcDimAdd: failed to add an arc dimension!");
}
void zwTestDwgHoleCallOutDimAdd(void)
/*
DESCRIPTION:
Test case for function cvxDwgHoleCallOutDimAdd.
*/
{
/* initialize a hole callout dimension */
svxDwgHoleCallOutDim holeCallDim;
if (cvxDwgHoleCallOutDimAddinit(&holeCallDim))
zwTestLogErrorMsg(5, "cvxDwgHoleCallOutDimAddinit: failed to initialize a hole callout dimension!");
cvxGetEnt("[View]Select one view to add hole callout dimension", VX_INP_GENERAL_2D, 0, &holeCallDim.idView);
if (cvxEntClassNum(holeCallDim.idView) != VX_ENT_DWG_VIEW) return;
double val = 0.0;
cvxGetNumber("[Text Point]Whether to use default text point(1: yes; 0: no)", &val);
int useDefaultTxtPnt = ((int)(val+0.5) == 1 ? 1 : 0);
/* select dimension entities and text points */
std::vector<int> vCrvs;
std::vector<svxPoint2> vPnts;
while (true)
{
int idCrv = 0;
if (cvxGetEnt("[Holes]Select holes(along edge of arc) in the selected view fo callouts", VX_INP_GENERAL_2D, 1, &idCrv) || idCrv < 1)
break;
vCrvs.push_back(idCrv);
if (!useDefaultTxtPnt)
{
svxPoint pnt = {};
cvxGetPoint("[Text Point]Specify dimension text point", VX_INP_PNT_GENERAL, 0, &pnt, NULL);
svxPoint2 pnt2D = { pnt.x, pnt.y };
vPnts.push_back(pnt2D);
}
}
holeCallDim.cntCrv = (int)vCrvs.size();
holeCallDim.pCrvs = vCrvs.data();
holeCallDim.pnts = (useDefaultTxtPnt ? NULL : vPnts.data());
cvxGetNumber("[Ignore Duplicate Hole Callout]Whether to ignore duplicate hole callout(1: enable; 0: disable)", &val);
holeCallDim.ignoreDup = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Callout Elements]Enter number to specify incluing elements(0: all; 1: picked; 2: none)", &val);
switch (int(val + 0.5))
{
case 1:
{
holeCallDim.iCalloutemt = VX_CALLOUTEMT_INVALID;
cvxGetNumber("[Quality]Whether to include quality(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_QUALITY;
cvxGetNumber("[Diameter]Whether to include diameter(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_DIAMETER;
cvxGetNumber("[Diameter(D2)]Whether to include diameter(D2)(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_DIAMETER_D2;
cvxGetNumber("[Depth]Whether to include depth(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_DEPTH;
cvxGetNumber("[Depth(H2)]Whether to include depth(H2)(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_DEPTH_H2;
cvxGetNumber("[Thread Diameter]Whether to include thread diameter(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_THREAD_DIA;
cvxGetNumber("[Thread Pitch]Whether to include thread pitch(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_THREAD_PITCH;
cvxGetNumber("[Thread Depth]Whether to include thread depth(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_THREAD_DEPTH;
cvxGetNumber("[Angle]Whether to include angle(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_ANGLE;
cvxGetNumber("[Callout Label]Whether to include callout label(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_CALLOUT_LABEL;
cvxGetNumber("[Multiple Lines]Whether to include multiple lines(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_MULTIPLE_LINE;
cvxGetNumber("[Slot Length]Whether to include slot length(1: enable; 0: disable)", &val);
if (int(val + 0.5)) holeCallDim.iCalloutemt |= VX_CALLOUTEMT_SLOT_LENGTH;
}
break;
case 2: holeCallDim.iCalloutemt = VX_CALLOUTEMT_INVALID; break;
default: holeCallDim.iCalloutemt = (uint)VX_CALLOUTEMT_VALID; break;
}
/* add hole callout dimensions */
int nDims = 0, *idDims = NULL;
if (cvxDwgHoleCallOutDimAdd(&holeCallDim, &nDims, &idDims) || nDims < 1)
zwTestLogErrorMsg(5, "cvxDwgCenterLineDimAdd: failed to add hole callout dimensions!");
for (int i = 0; i < nDims; i++)
cvxEntAddPick(idDims[i]);
/* free memory */
cvxMemFree((void**)&idDims);
}
void zwTestDwgRadDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgRadDimAdd.
*/
{
svxRadDimData radDim;
cvxMemZero(&radDim, sizeof(svxRadDimData));
double val = 0;
cvxGetNumber("select radial or diameter type: 1 - 5", &val);
if (int(val + 0.5) == 1)
radDim.type = VX_RAD_RADIAL;
else if (int(val + 0.5) == 2)
radDim.type = VX_RAD_BROKEN;
else if (int(val + 0.5) == 3)
radDim.type = VX_RAD_LARGE;
else if (int(val + 0.5) == 4)
radDim.type = VX_RAD_LEADER;
else
radDim.type = VX_RAD_DIAMETER;
cvxGetPoint("select a point on an arc", VX_INP_PNT_ON_CURVE, 0, &radDim.arcPnt.pnt, &radDim.arcPnt.idEnt);
if (radDim.type == VX_RAD_BROKEN)
cvxGetPoint("select a broken point", VX_INP_PNT_GENERAL, 0, &radDim.brkPnt.pnt, &radDim.brkPnt.idEnt);
cvxGetPoint("select a text point", VX_INP_PNT_GENERAL, 0, &radDim.txtPnt.pnt, &radDim.txtPnt.idEnt);
/* add radial or diameter dimension */
int idDim = 0;
if (cvxDwgRadDimAdd(&radDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgRadDimAdd: failed to add a radial dimension!");
}
void zwTestDwgBalloonDimAdd(void)
/*
DESCRIPTION:
Test case for function cvxDwgBalloonDimAdd.
*/
{
svxDwgBalloonDim ballDim = {};
double val = 0.0;
cvxGetNumber("Enter number to select balloon text condition(0 ~ 30)", &val);
ballDim.condition = (evxBalloonCon)(int)val;
vxLongName text = "\0";
if (ballDim.condition == VX_BALLOON_CON_USERTEXT) cvxGetString("Input balloon text", "balloon text", sizeof(text), text);
ballDim.text = text;
/* set location points */
std::vector<svxPntOnEnt> vLocationPnts;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("Select location point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
break;
vLocationPnts.push_back(pntOnEnt);
}
ballDim.cntCrv = (int)vLocationPnts.size();
ballDim.Points = vLocationPnts.data();
/* set leader points */
std::vector<svxPntOnEnt> vLeadPnts;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("Select leader point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
break;
vLeadPnts.push_back(pntOnEnt);
}
ballDim.cntlead = (int)vLeadPnts.size();
ballDim.leadPoints = vLeadPnts.data();
/* add coordinate dimension */
int idDim = 0;
if (cvxDwgBalloonDimAdd(&ballDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgBalloonDimAdd: failed to add a balloon dimension!");
}
void zwTestDwgFtrCtrlDimAdd(void)
/*
DESCRIPTION:
Test case for function cvxDwgFtrCtrlDimAdd.
*/
{
svxDwgFtrCtrl fcsDim = {};
vxLongName text = "\0";
cvxGetString("Input balloon text", "note1\n<FCS_>[Box][VxX]h[VxX]x[VxX]c0.01[VxX]t[VxX]_[VxX]w[VxX]x<Tol2>S[VxX]c0.02[VxX]~[VxX]xdatum[VxX]u[VxX]_[Box]\nnote2", sizeof(text), text);
fcsDim.text = text;
/* set location points */
std::vector<svxPntOnEnt> vLocationPnts;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("Select location point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
break;
vLocationPnts.push_back(pntOnEnt);
}
fcsDim.cntCrv = (int)vLocationPnts.size();
fcsDim.Points = vLocationPnts.data();
/* set leader points */
std::vector<svxPntOnEnt> vLeadPnts;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("Select leader point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
break;
vLeadPnts.push_back(pntOnEnt);
}
fcsDim.cntlead = (int)vLeadPnts.size();
fcsDim.leadPoints = vLeadPnts.data();
/* set auxiliary location points */
std::vector<svxPntOnEnt> vAuxLocPnts;
while (true)
{
svxPntOnEnt pntOnEnt = {};
if (cvxGetPoint("Select auxiliary location point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
break;
vAuxLocPnts.push_back(pntOnEnt);
}
fcsDim.cntauxiLoc = (int)vAuxLocPnts.size();
fcsDim.auxiPoints = vAuxLocPnts.data();
/* add coordinate dimension */
int idDim = 0;
if (cvxDwgFtrCtrlDimAdd(&fcsDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgFtrCtrlDimAdd: failed to add feature control dimension!");
}
void zwTestDwgLabelCoorDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgLabelCoorDimAdd.
*/
{
svxLabelCoorDimData labelCoorDim = { 0 };
svxPoint* pnts = nullptr;
double val = 0;
cvxGetNumber("auto text placement or pick text placement: 1 or 2", &val);
if (int(val + 0.5) == 1)
{
labelCoorDim.type = 1; /* auto text placement */
cvxGetPoint("select an origin point", VX_INP_PNT_GENERAL, 0, &labelCoorDim.orgPnt.pnt, &labelCoorDim.orgPnt.idEnt);
cvxGetPoints("select coordinate point(s)", VX_INP_PNT_GENERAL, 0, &labelCoorDim.cntPnt, &pnts);
cvxMemAlloc(labelCoorDim.cntPnt * sizeof(svxPntOnEnt), (void**)&labelCoorDim.pPnts);
cvxMemZero(labelCoorDim.pPnts, labelCoorDim.cntPnt * sizeof(svxPntOnEnt));
for (int i = 0; i < labelCoorDim.cntPnt; i++)
labelCoorDim.pPnts[i].pnt = pnts[i];
}
else
{
labelCoorDim.type = 2; /* pick text placement */
cvxGetPoint("select an origin point", VX_INP_PNT_GENERAL, 0, &labelCoorDim.orgPnt.pnt, &labelCoorDim.orgPnt.idEnt);
cvxGetPoints("select coordinate point(s) and text point(s)", VX_INP_PNT_GENERAL, 0, &labelCoorDim.cntPnt, &pnts);
labelCoorDim.cntPnt /= 2;
cvxMemAlloc(labelCoorDim.cntPnt * sizeof(svxPntOnEnt), (void**)&labelCoorDim.pPnts);
cvxMemAlloc(labelCoorDim.cntPnt * sizeof(svxPntOnEnt), (void**)&labelCoorDim.pTxtPnts);
cvxMemZero(labelCoorDim.pPnts, labelCoorDim.cntPnt * sizeof(svxPntOnEnt));
cvxMemZero(labelCoorDim.pTxtPnts, labelCoorDim.cntPnt * sizeof(svxPntOnEnt));
for (int i = 0; i < labelCoorDim.cntPnt; i++)
{
labelCoorDim.pPnts[i].pnt = pnts[2 * i];
labelCoorDim.pTxtPnts[i].pnt = pnts[2 * i + 1];
}
}
//labelCoorDim.text = "X=<C_X>, Y=<C_Y>";
/* add coordinate dimension */
int idDim = 0;
if (cvxDwgLabelCoorDimAdd(&labelCoorDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgLabelCoorDimAdd: failed to add a coordinate dimension!");
/* free memory */
cvxMemFree((void**)&pnts);
cvxMemFree((void**)&labelCoorDim.pPnts);
cvxMemFree((void**)&labelCoorDim.pTxtPnts);
}
void zwTestDwgLnrChmDimAdd()
/*
DESCRIPTION:
Test case for function cvxDwgLnrChmDimAdd.
*/
{
/* initialize a linear chamfer dimension */
svxDwgLnrChmDimData lnrChmDim;
if (cvxDwgLnrChmDimAddInit(&lnrChmDim))
zwTestLogErrorMsg(5, "cvxDwgLnrChmDimAddInit: failed to initialize a linear chamfer dimension!");
double val = 0;
cvxGetNumber("select linear chamfer dimension type: 1 - 3", &val); /* 1 as default */
switch (int(val + 0.5))
{
case 1:
lnrChmDim.dimType = VX_LEADER_CHAMFERDIM;
cvxGetNumber("select text type: 0 - 2", &val); /* 0 as default */
if (int(val + 0.5) == 1)
lnrChmDim.dimTexType = VX_TEXT_PERPENDICULAR_CHAMFERDIM;
else if (int(val + 0.5) == 2)
lnrChmDim.dimTexType = VX_TEXT_ALGMODLIN_CHAMFERDIM;
break;
case 2:
lnrChmDim.dimType = VX_ALIGNED_CHAMFERDIM;
break;
case 3:
lnrChmDim.dimType = VX_HORZORVERT_CHAMFERDIM;
break;
default:
zwTestLogErrorMsg(5, "cvxDwgLnrChmDimAdd: invalid option!");
break;
}
cvxGetPoint("select a point on line", VX_INP_PNT_ON_CURVE, 0, &lnrChmDim.LineEnt.pnt, &lnrChmDim.LineEnt.idEnt);
if (lnrChmDim.dimType != VX_HORZORVERT_CHAMFERDIM)
cvxGetPoint("select a text point", VX_INP_PNT_GENERAL, 0, &lnrChmDim.textPnt.pnt, &lnrChmDim.textPnt.idEnt);
else
{
cvxGetPoint("select H origin", VX_INP_PNT_GENERAL, 0, &lnrChmDim.textPnt.pnt, &lnrChmDim.textPnt.idEnt);
cvxGetPoint("select V origin", VX_INP_PNT_GENERAL, 0, &lnrChmDim.verTextPnt.pnt, &lnrChmDim.verTextPnt.idEnt);
}
/* create a linear chamfer dimension */
int idDim = 0;
if (cvxDwgLnrChmDimAdd(&lnrChmDim, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxDwgLnrChmDimAdd: failed to add a linear chamfer dimension!");
}
void zwTestDwgAutoBlnAdd()
/*
DESCRIPTION:
Test case for function cvxDwgAutoBlnAdd.
*/
{
/* initialize auto balloons */
svxDwgAtBlnData atBln;
if (cvxDwgAutoBlnAddInit(&atBln))
zwTestLogErrorMsg(5, "cvxDwgAutoBlnAdd: failed to initialize auto balloons!");
cvxGetEnts("select views to create balloons, <middle-click> when done", VX_INP_GENERAL_2D, 0, &atBln.viewIdCnt, &atBln.viewIdList);
double val = 0;
cvxGetNumber("select instances type: 0 - 2", &val); /* 0 as default */
if (int(val + 0.5) == 1)
atBln.instOpt = VX_ATBLNINS_MULLEAINS;
else if (int(val + 0.5) == 2)
atBln.instOpt = VX_ATBLNINS_EACHINS;
cvxGetNumber("select pattern type: 1 - 3", &val); /* 1 as default */
if (int(val + 0.5) == 2)
atBln.ptnType = VX_ATBLNPAT_SQUARE;
else if (int(val + 0.5) == 3)
atBln.ptnType = VX_ATBLNPAT_CIRCULAR;
cvxGetNumber("select leader attachment type: 1 or 2", &val);
if (int(val + 0.5) == 1)
atBln.leadAttach = VX_ATBLNLEAATT_EDAGES;
else
atBln.leadAttach = VX_ATBLNLEAATT_FACES;
atBln.offSet = 15;
if (atBln.ptnType != VX_ATBLNPAT_CIRCULAR)
{
cvxGetNumber("select skip sides type: 0, 1, 2, 4, 8", &val); /* 0 as default */
if (int(val + 0.5) == 1)
atBln.skipSides = VX_ATBLNSKPSD_LEFT;
else if (int(val + 0.5) == 2)
atBln.skipSides = VX_ATBLNSKPSD_TOP;
else if (int(val + 0.5) == 4)
atBln.skipSides = VX_ATBLNSKPSD_RIGHT;
else if (int(val + 0.5) == 8)
atBln.skipSides = VX_ATBLNSKPSD_BOTTOM;
}
cvxGetNumber("select arrangement of auto balloon: 1 - 3", &val); /* a as default */
if (int(val + 0.5) == 2)
atBln.arrangement = VX_ATBLNARR_CW;
else if (int(val + 0.5) == 3)
atBln.arrangement = VX_ATBLNARR_CCW;
if (atBln.arrangement != VX_ATBLNARR_NEAREST)
{
cvxGetNumber("whether keep the item number: 0 or 1", &val);
if (int(val + 0.5) == 0)
cvxGetEnt("select kept curve", VX_INP_EDGE_OR_CURVE, 0, &atBln.ItemId);
}
cvxGetNumber("only label components in BOM: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5))
{
cvxGetNumber("only label components which are not labeled in other views: 0 or 1", &val);
if (int(val + 0.5))
atBln.OnlyWithoutBln = 0;
}
else
atBln.OnlyBom = 0;
/* create auto balloons */
int idDimCount = 0;
int* idDimList = nullptr;
if (cvxDwgAutoBlnAdd(&atBln, &idDimCount, &idDimList) || idDimList == nullptr)
zwTestLogErrorMsg(5, "cvxDwgAutoBlnAdd: failed to create auto balloons!");
/* free memory */
cvxMemFree((void**)&atBln.viewIdList);
cvxMemFree((void**)&idDimList);
}
void zwTestDwgStkBlnAdd()
/*
DESCRIPTION:
Test case for function cvxDwgStkBlnAdd.
*/
{
/* initialize a stack balloon */
svxDwgStkBlnData stkBln;
if (cvxDwgStkBlnAddInit(&stkBln))
zwTestLogErrorMsg(5, "cvxDwgStkBlnAddInit: failed to initialize a stake balloon!");
cvxGetEnt("select a main balloon", VX_INP_GENERAL_2D, 0, &stkBln.idBlnDim);
cvxGetEnts("select other balloons, <middle-click> when done", VX_INP_GENERAL_2D, 0, &stkBln.entCnt, &stkBln.pEntIdList);
double val = 0;
cvxGetNumber("select pattern type: 1 - 4", &val);
if (int(val + 0.5) == 2)
stkBln.stkBlnPtn = VX_STKBLNPAT_HORLEFT;
else if (int(val + 0.5) == 3)
stkBln.stkBlnPtn = VX_STKBLNPAT_VERUP;
else if (int(val + 0.5) == 4)
stkBln.stkBlnPtn = VX_STKBLNPAT_VERDOWN;
cvxGetNumber("whether auto sort: 0 or 1", &val);
if (int(val + 0.5))
stkBln.autoSort = 1;
/* create a stack balloon */
int idDimCount = 0;
int* idDimList = nullptr;
if (cvxDwgStkBlnAdd(&stkBln, nullptr, nullptr))
zwTestLogErrorMsg(5, "cvxDwgStkBlnAdd: failed to create a stack balloon!");
/* free memory */
cvxMemFree((void**)&stkBln.pEntIdList);
cvxMemFree((void**)&idDimList);
}
VX_RAD_DIAMETER
@ VX_RAD_DIAMETER
diametric dimension
Definition: zwapi_cmd_dwg_data.h:928
VX_RAD_LEADER
@ VX_RAD_LEADER
leader radial dimension
Definition: zwapi_cmd_dwg_data.h:927
VX_RAD_LARGE
@ VX_RAD_LARGE
large radial dimension
Definition: zwapi_cmd_dwg_data.h:926
VX_RAD_BROKEN
@ VX_RAD_BROKEN
broken radial dimension
Definition: zwapi_cmd_dwg_data.h:925
VX_RAD_RADIAL
@ VX_RAD_RADIAL
radial dimension
Definition: zwapi_cmd_dwg_data.h:924
DIM_VIEW_ABOVE_LEFT
@ DIM_VIEW_ABOVE_LEFT
left or above of view
Definition: zwapi_cmd_dwg_data.h:653
DIM_VIEW_BELOW_RIGHT
@ DIM_VIEW_BELOW_RIGHT
right or below of view
Definition: zwapi_cmd_dwg_data.h:654
DIM_VIEW_BOTH
@ DIM_VIEW_BOTH
both of view
Definition: zwapi_cmd_dwg_data.h:655
VX_ATBLNSKPSD_BOTTOM
@ VX_ATBLNSKPSD_BOTTOM
skip bottom
Definition: zwapi_cmd_dwg_data.h:1132
VX_ATBLNSKPSD_RIGHT
@ VX_ATBLNSKPSD_RIGHT
skip right
Definition: zwapi_cmd_dwg_data.h:1131
VX_ATBLNSKPSD_TOP
@ VX_ATBLNSKPSD_TOP
skip top
Definition: zwapi_cmd_dwg_data.h:1130
VX_ATBLNSKPSD_LEFT
@ VX_ATBLNSKPSD_LEFT
skip left
Definition: zwapi_cmd_dwg_data.h:1129
VX_DATUM_NORMAL
@ VX_DATUM_NORMAL
normal datum feature symbol
Definition: zwapi_cmd_dwg_data.h:1224
VX_DATUM_ANSI
@ VX_DATUM_ANSI
based on ANSI(per 1982)
Definition: zwapi_cmd_dwg_data.h:1225
VX_TEXT_PERPENDICULAR_CHAMFERDIM
@ VX_TEXT_PERPENDICULAR_CHAMFERDIM
always perpendicular
Definition: zwapi_cmd_dwg_data.h:846
VX_TEXT_ALGMODLIN_CHAMFERDIM
@ VX_TEXT_ALGMODLIN_CHAMFERDIM
along the model line
Definition: zwapi_cmd_dwg_data.h:847
VX_ATBLNPAT_SQUARE
@ VX_ATBLNPAT_SQUARE
square around the layout view
Definition: zwapi_cmd_dwg_data.h:1108
VX_ATBLNPAT_CIRCULAR
@ VX_ATBLNPAT_CIRCULAR
circular around the layout view
Definition: zwapi_cmd_dwg_data.h:1109
VX_DIM_LINE_LH
@ VX_DIM_LINE_LH
horizontal dimension
Definition: zwapi_cmd_dwg_data.h:717
VX_DIM_LINE_LA
@ VX_DIM_LINE_LA
aligned dimension
Definition: zwapi_cmd_dwg_data.h:719
VX_DIM_LINE_LR
@ VX_DIM_LINE_LR
rotated dimension
Definition: zwapi_cmd_dwg_data.h:720
VX_DIM_LINE_LV
@ VX_DIM_LINE_LV
vertical dimension
Definition: zwapi_cmd_dwg_data.h:718
VX_DIM_LINE_LO
@ VX_DIM_LINE_LO
ordinate dimension, only used in cvxDwgOrdinateDimAdd(): create a linear ordinate horizontal dimensio...
Definition: zwapi_cmd_dwg_data.h:722
VX_DIM_LINE_LP
@ VX_DIM_LINE_LP
projected dimension
Definition: zwapi_cmd_dwg_data.h:721
VX_DIM_OFFSET_LOP
@ VX_DIM_OFFSET_LOP
point to line (Projected Distance Method)
Definition: zwapi_cmd_dwg_data.h:798
VX_DIM_OFFSET_LOL
@ VX_DIM_OFFSET_LOL
line to line (Offset Method)
Definition: zwapi_cmd_dwg_data.h:797
VX_ATBLNARR_CCW
@ VX_ATBLNARR_CCW
arranged in counter - clockwise order
Definition: zwapi_cmd_dwg_data.h:1143
VX_ATBLNARR_NEAREST
@ VX_ATBLNARR_NEAREST
simply located nearest to the component being labeled
Definition: zwapi_cmd_dwg_data.h:1141
VX_ATBLNARR_CW
@ VX_ATBLNARR_CW
arranged in clockwise order
Definition: zwapi_cmd_dwg_data.h:1142
VX_ATBLNINS_MULLEAINS
@ VX_ATBLNINS_MULLEAINS
multi-leader for multiple instances
Definition: zwapi_cmd_dwg_data.h:1097
VX_ATBLNINS_EACHINS
@ VX_ATBLNINS_EACHINS
one for each instances
Definition: zwapi_cmd_dwg_data.h:1098
DIM_AUTO_LABEL_COORDINATE
@ DIM_AUTO_LABEL_COORDINATE
label ordinate dimension
Definition: zwapi_cmd_dwg_data.h:644
DIM_AUTO_BASELINE
@ DIM_AUTO_BASELINE
baseline
Definition: zwapi_cmd_dwg_data.h:641
DIM_AUTO_CONTINUOUS
@ DIM_AUTO_CONTINUOUS
continuous
Definition: zwapi_cmd_dwg_data.h:642
DIM_AUTO_ORDINATE
@ DIM_AUTO_ORDINATE
ordinate dimension
Definition: zwapi_cmd_dwg_data.h:643
VX_ATBLNLEAATT_FACES
@ VX_ATBLNLEAATT_FACES
attach to face
Definition: zwapi_cmd_dwg_data.h:1119
VX_ATBLNLEAATT_EDAGES
@ VX_ATBLNLEAATT_EDAGES
attach to edges
Definition: zwapi_cmd_dwg_data.h:1118
VX_ANG_HORIZONTAL
@ VX_ANG_HORIZONTAL
horizontal angular dimension
Definition: zwapi_cmd_dwg_data.h:875
VX_ANG_ARC
@ VX_ANG_ARC
arc angular dimension
Definition: zwapi_cmd_dwg_data.h:878
VX_ANG_VERTICAL
@ VX_ANG_VERTICAL
vertical angular dimension
Definition: zwapi_cmd_dwg_data.h:876
VX_ANG_THREEPOINT
@ VX_ANG_THREEPOINT
3 point angular dimension
Definition: zwapi_cmd_dwg_data.h:877
VX_ANG_TWOCURVES
@ VX_ANG_TWOCURVES
2 curves angular dimension
Definition: zwapi_cmd_dwg_data.h:874
VX_CALLOUTEMT_DIAMETER_D2
@ VX_CALLOUTEMT_DIAMETER_D2
Diameter(D2)
Definition: zwapi_cmd_dwg_data.h:970
VX_CALLOUTEMT_MULTIPLE_LINE
@ VX_CALLOUTEMT_MULTIPLE_LINE
Multiple Lines.
Definition: zwapi_cmd_dwg_data.h:978
VX_CALLOUTEMT_SLOT_LENGTH
@ VX_CALLOUTEMT_SLOT_LENGTH
Slot Length.
Definition: zwapi_cmd_dwg_data.h:979
VX_CALLOUTEMT_THREAD_DIA
@ VX_CALLOUTEMT_THREAD_DIA
Thread Diameter.
Definition: zwapi_cmd_dwg_data.h:973
VX_CALLOUTEMT_VALID
@ VX_CALLOUTEMT_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:980
VX_CALLOUTEMT_QUALITY
@ VX_CALLOUTEMT_QUALITY
Quality.
Definition: zwapi_cmd_dwg_data.h:968
VX_CALLOUTEMT_DIAMETER
@ VX_CALLOUTEMT_DIAMETER
Diameter.
Definition: zwapi_cmd_dwg_data.h:969
VX_CALLOUTEMT_DEPTH_H2
@ VX_CALLOUTEMT_DEPTH_H2
Depth(H2)
Definition: zwapi_cmd_dwg_data.h:972
VX_CALLOUTEMT_THREAD_PITCH
@ VX_CALLOUTEMT_THREAD_PITCH
Thread Pitch.
Definition: zwapi_cmd_dwg_data.h:974
VX_CALLOUTEMT_INVALID
@ VX_CALLOUTEMT_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:967
VX_CALLOUTEMT_DEPTH
@ VX_CALLOUTEMT_DEPTH
Depth.
Definition: zwapi_cmd_dwg_data.h:971
VX_CALLOUTEMT_THREAD_DEPTH
@ VX_CALLOUTEMT_THREAD_DEPTH
Thread Depth.
Definition: zwapi_cmd_dwg_data.h:975
VX_CALLOUTEMT_CALLOUT_LABEL
@ VX_CALLOUTEMT_CALLOUT_LABEL
Callout Label.
Definition: zwapi_cmd_dwg_data.h:977
VX_CALLOUTEMT_ANGLE
@ VX_CALLOUTEMT_ANGLE
Angle.
Definition: zwapi_cmd_dwg_data.h:976
VX_LEADER_CHAMFERDIM
@ VX_LEADER_CHAMFERDIM
leader linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:834
VX_HORZORVERT_CHAMFERDIM
@ VX_HORZORVERT_CHAMFERDIM
horizontal/vertical linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:836
VX_ALIGNED_CHAMFERDIM
@ VX_ALIGNED_CHAMFERDIM
aligned linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:835
DIM_AUTO_ENT_ARC_CIRCLE
@ DIM_AUTO_ENT_ARC_CIRCLE
entity type is all arc/circle
Definition: zwapi_cmd_dwg_data.h:631
DIM_AUTO_ENT_ALL
@ DIM_AUTO_ENT_ALL
entity type is all
Definition: zwapi_cmd_dwg_data.h:630
DIM_AUTO_ENT_PICKED
@ DIM_AUTO_ENT_PICKED
entity type is picked by user
Definition: zwapi_cmd_dwg_data.h:632
VX_AUTOINC_ARC
@ VX_AUTOINC_ARC
Include arc.
Definition: zwapi_cmd_dwg_data.h:678
VX_AUTOINC_HOLE_CALLOUT
@ VX_AUTOINC_HOLE_CALLOUT
Include Hole callout
Definition: zwapi_cmd_dwg_data.h:682
VX_AUTOINC_LINE
@ VX_AUTOINC_LINE
Include line.
Definition: zwapi_cmd_dwg_data.h:681
VX_AUTOINC_MAXIMUM_DIM
@ VX_AUTOINC_MAXIMUM_DIM
Include maximum dimensions.
Definition: zwapi_cmd_dwg_data.h:684
VX_AUTOINC_CYLIND_DIM
@ VX_AUTOINC_CYLIND_DIM
Include cylindrical dimensions.
Definition: zwapi_cmd_dwg_data.h:683
VX_AUTOINC_VALID
@ VX_AUTOINC_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:685
VX_AUTOINC_CIRCLE
@ VX_AUTOINC_CIRCLE
Include circle.
Definition: zwapi_cmd_dwg_data.h:679
VX_AUTOINC_INVALID
@ VX_AUTOINC_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:677
VX_AUTOINC_HOLE
@ VX_AUTOINC_HOLE
Include hole.
Definition: zwapi_cmd_dwg_data.h:680
VX_CL_BY_TWO_POINTS
@ VX_CL_BY_TWO_POINTS
draw by two points(Based on pick point)
Definition: zwapi_cmd_dwg_data.h:1354
VX_CL_BY_TWO_LINES
@ VX_CL_BY_TWO_LINES
draw by two lines(Based to curve)
Definition: zwapi_cmd_dwg_data.h:1353
VX_STKBLNPAT_VERUP
@ VX_STKBLNPAT_VERUP
vertical up
Definition: zwapi_cmd_dwg_data.h:1184
VX_STKBLNPAT_VERDOWN
@ VX_STKBLNPAT_VERDOWN
vertical down
Definition: zwapi_cmd_dwg_data.h:1185
VX_STKBLNPAT_HORLEFT
@ VX_STKBLNPAT_HORLEFT
horizontal left
Definition: zwapi_cmd_dwg_data.h:1183
evxBalloonCon
evxBalloonCon
balloon text Condition
Definition: zwapi_cmd_dwg_data.h:1029
VX_BALLOON_CON_USERTEXT
@ VX_BALLOON_CON_USERTEXT
user text
Definition: zwapi_cmd_dwg_data.h:1030
VX_DM_CENDLINE
@ VX_DM_CENDLINE
Center Line: create a centerline mark between lines, arcs or circle.
Definition: zwapi_cmd_dwg_data.h:1309
VX_DM_CENMARK
@ VX_DM_CENMARK
Center Mark: create a center mark at an arc or circle.
Definition: zwapi_cmd_dwg_data.h:1307
VX_DM_CENLINE
@ VX_DM_CENLINE
Center Mark Circle: place a centerline through a circular pattern such as bolt holes.
Definition: zwapi_cmd_dwg_data.h:1308
VX_DATUMT_CIRCLE
@ VX_DATUMT_CIRCLE
datum target - Circle
Definition: zwapi_cmd_dwg_data.h:1251
VX_DATUMT_LINE
@ VX_DATUMT_LINE
datum target - Line
Definition: zwapi_cmd_dwg_data.h:1253
VX_DATUMT_RECTANGLE
@ VX_DATUMT_RECTANGLE
datum target - Rectangle
Definition: zwapi_cmd_dwg_data.h:1252
VX_SYM_ANGULAR
@ VX_SYM_ANGULAR
angular dimension
Definition: zwapi_cmd_dwg_data.h:788
VX_SYM_LINEAR
@ VX_SYM_LINEAR
linear dimension
Definition: zwapi_cmd_dwg_data.h:787
cvxDwgCenterLineDimAddInit
evxErrors cvxDwgCenterLineDimAddInit(svxCenterLine *data)
cvxDwgCenMarkCirDimAddInit
evxErrors cvxDwgCenMarkCirDimAddInit(svxCenMarkCirDimData *data)
cvxDwgContinuousDimAdd
evxErrors cvxDwgContinuousDimAdd(const svxDwgLineGrpDim *pData, int *idDim)
cvxDwgHoleCallOutDimAddinit
evxErrors cvxDwgHoleCallOutDimAddinit(svxDwgHoleCallOutDim *data)
cvxDwgRadDimAdd
evxErrors cvxDwgRadDimAdd(const svxRadDimData *radDimData, int *idDim)
cvxDwgStkBlnAddInit
evxErrors cvxDwgStkBlnAddInit(svxDwgStkBlnData *data)
cvxDwgDatumDimAdd
evxErrors cvxDwgDatumDimAdd(const svxDatumDimData *datumData, int *idDim)
cvxDwgBalloonDimAdd
evxErrors cvxDwgBalloonDimAdd(const svxDwgBalloonDim *pData, int *idDim)
cvxDwgArcDimAdd
evxErrors cvxDwgArcDimAdd(const svxDwgArcDimData *arcDimData, int *idDim)
cvxDwgAutoDimAddInit
evxErrors cvxDwgAutoDimAddInit(svxDimAuto *data)
cvxDwgCenterLineDimAdd
evxErrors cvxDwgCenterLineDimAdd(const svxCenterLine *pzCenterLine, int *idDim)
cvxDwgAngDimAdd
evxErrors cvxDwgAngDimAdd(const svxDwgAngDimData *angDimData, int *idDim)
cvxDwgOrdinateDimAdd
evxErrors cvxDwgOrdinateDimAdd(const svxDwgOrdinateDim *pData, int *idDim)
cvxDwgLineDimAdd
evxErrors cvxDwgLineDimAdd(const svxDwgLineDim *pData, int *idDim)
cvxDwgAutoDimAdd
evxErrors cvxDwgAutoDimAdd(const svxDimAuto *pDimData, int *idDim)
cvxDwgHoleCallOutDimAdd
evxErrors cvxDwgHoleCallOutDimAdd(const svxDwgHoleCallOutDim *pData, int *numDim, int **idDims)
cvxDwgAutoBlnAddInit
evxErrors cvxDwgAutoBlnAddInit(svxDwgAtBlnData *data)
cvxDwgCenterMarkDimAdd
evxErrors cvxDwgCenterMarkDimAdd(const svxCenterMark *pzCenterMark, int *idDim)
cvxDwgDatumTargDimAdd
evxErrors cvxDwgDatumTargDimAdd(const svxDatumTargDimData *datumTData, int *idDim)
cvxDwgBaseLineDimAdd
evxErrors cvxDwgBaseLineDimAdd(const svxDwgLineGrpDim *pData, int *idDim)
cvxDwgLnrChmDimAdd
evxErrors cvxDwgLnrChmDimAdd(const svxDwgLnrChmDimData *DimData, int *idDim)
cvxDwgFtrCtrlDimAdd
evxErrors cvxDwgFtrCtrlDimAdd(const svxDwgFtrCtrl *pData, int *idDim)
cvxDwgSymmetryDimAdd
evxErrors cvxDwgSymmetryDimAdd(const svxDwgSymmetryDimData *symmetryDimData, int *idDim)
cvxDwgAutoBlnAdd
evxErrors cvxDwgAutoBlnAdd(const svxDwgAtBlnData *atBlnData, int *idDimCount, int **idDimList)
cvxDwgLineOffsetDimAdd
evxErrors cvxDwgLineOffsetDimAdd(const svxDwgLineOffsetDim *pData, int *idDim)
cvxDwgCenMarkCirDimAdd
evxErrors cvxDwgCenMarkCirDimAdd(const svxCenMarkCirDimData *cmcDimData, int *idDim)
cvxDwgStkBlnAdd
evxErrors cvxDwgStkBlnAdd(const svxDwgStkBlnData *stkBlnData, int *idDimCount, int **idDimList)
cvxDwgDatumTargDimAddInit
evxErrors cvxDwgDatumTargDimAddInit(svxDatumTargDimData *data)
cvxDwgCenterMarkDimAddInit
evxErrors cvxDwgCenterMarkDimAddInit(svxCenterMark *data)
cvxDwgLnrChmDimAddInit
evxErrors cvxDwgLnrChmDimAddInit(svxDwgLnrChmDimData *data)
cvxDwgLabelCoorDimAdd
evxErrors cvxDwgLabelCoorDimAdd(const svxLabelCoorDimData *coorDimData, int *idDim)
cvxDimInqType
evxErrors cvxDimInqType(int idDim, evxDimType *type)
cvxEntAddPick
evxErrors cvxEntAddPick(int idx_ent)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointsOnEnts
evxErrors cvxGetPointsOnEnts(const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
evxPntInpOpt
evxPntInpOpt
point input options
Definition: zwapi_userinput.h:77
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_END
@ VX_INP_PNT_END
point end
Definition: zwapi_userinput.h:85
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
cvxGetString
int cvxGetString(const char *Prompt, const char *Default, int NumBytes, char *String)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxDimType
evxDimType
dimension type
Definition: zwapi_util.h:1934
VX_DIM_ORDINATE
@ VX_DIM_ORDINATE
Ordinate dimension.
Definition: zwapi_util.h:1938
VX_DIM_BASELINE
@ VX_DIM_BASELINE
Baseline dimension.
Definition: zwapi_util.h:1936
VX_DIM_CONTINUOUS
@ VX_DIM_CONTINUOUS
Continuous dimension.
Definition: zwapi_util.h:1937
VX_ENT_DWG_VIEW
@ VX_ENT_DWG_VIEW
drawing view
Definition: zwapi_util.h:943
VX_ENT_DIMEN
@ VX_ENT_DIMEN
dimension
Definition: zwapi_util.h:940
VX_START_POINT
@ VX_START_POINT
start point of curve or line (if the input is face, get point of (u.min, v.min))
Definition: zwapi_util.h:537
svxAutoSet::type
evxAutoDimType type
select auto dimension type
Definition: zwapi_cmd_dwg_data.h:665
svxAutoSet::asgrp
int asgrp
1:auto dimensions are as group dimension* 0:not, default value:1
Definition: zwapi_cmd_dwg_data.h:668
svxAutoSet::viewType
evxAutoPlacement viewType
dimensions position / placement, default value:DIM_VIEW_BELOW_RIGHT
Definition: zwapi_cmd_dwg_data.h:667
svxAutoSet::refPnt
svxPntOnEnt refPnt
reference point, used when enable is 1
Definition: zwapi_cmd_dwg_data.h:666
svxAutoSet::enable
int enable
svxAutoSet enabled or not
Definition: zwapi_cmd_dwg_data.h:664
svxAutoSet
dimension position
Definition: zwapi_cmd_dwg_data.h:663
svxCenMarkCirDimData::pCens
svxPntOnEnt * pCens
point to the point for center marks(the length of list must equal to iCntCens)
Definition: zwapi_cmd_dwg_data.h:1336
svxCenMarkCirDimData::iflg
int iflg
optional open/close flag 0-Arc(open), 1-Circle(close) (note: 1 as default)
Definition: zwapi_cmd_dwg_data.h:1338
svxCenMarkCirDimData::flgCenter
char flgCenter
flag to use "center" (0 as default)
Definition: zwapi_cmd_dwg_data.h:1341
svxCenMarkCirDimData::center
svxPntOnEnt center
arc center or circle center(if flgCenter = 1, the value is valid) if iflg = 0, the center is the arc ...
Definition: zwapi_cmd_dwg_data.h:1342
svxCenMarkCirDimData::iCntCens
int iCntCens
the count of the center marks
Definition: zwapi_cmd_dwg_data.h:1335
svxCenMarkCirDimData
center mark circle dim data
Definition: zwapi_cmd_dwg_data.h:1334
svxCenterDim::scaleFac
double scaleFac
overall scale factor, default value:1
Definition: zwapi_cmd_dwg_data.h:1298
svxCenterDim::breakLen
double breakLen
extension lines break length (gap), default value:1.5
Definition: zwapi_cmd_dwg_data.h:1296
svxCenterDim::overRun
double overRun
extension lines overrun, default value:3.06324
Definition: zwapi_cmd_dwg_data.h:1297
svxCenterDim::cmSize
double cmSize
center line/mark size (short dash), default value:4.254534
Definition: zwapi_cmd_dwg_data.h:1295
svxCenterLine::zCenterDim
svxCenterDim zCenterDim
option param: center dimension attribute
Definition: zwapi_cmd_dwg_data.h:1370
svxCenterLine::iDimType
evxCenterLineType iDimType
start point. if type = VX_CL_BY_TWO_LINES, the start point is regarded as the entity line of the poin...
Definition: zwapi_cmd_dwg_data.h:1363
svxCenterLine::zPntStart
svxPntOnEnt zPntStart
end point. if type = VX_CL_BY_TWO_LINES, the end point is regarded as the entity line of the point,...
Definition: zwapi_cmd_dwg_data.h:1366
svxCenterLine::zPntEnd
svxPntOnEnt zPntEnd
end point
Definition: zwapi_cmd_dwg_data.h:1369
svxCenterLine
Center Line.
Definition: zwapi_cmd_dwg_data.h:1362
svxCenterMark::idEntity
int idEntity
entity id
Definition: zwapi_cmd_dwg_data.h:1318
svxCenterMark::zCenterDim
svxCenterDim zCenterDim
option param: center dimension attribute
Definition: zwapi_cmd_dwg_data.h:1323
svxCenterMark::zRotPnt
svxPntOnEnt zRotPnt
rotation point, just for cmType = VX_DM_CENMARK
Definition: zwapi_cmd_dwg_data.h:1321
svxCenterMark::zEntPnt
svxPoint zEntPnt
critical point of the entity
Definition: zwapi_cmd_dwg_data.h:1319
svxCenterMark::useRotPnt
char useRotPnt
whether to rotate the center line/mark toward a selected point.(0: no, 1: yes)
Definition: zwapi_cmd_dwg_data.h:1320
svxCenterMark::slotType
int slotType
Slot center mark type, valid when entity is a hole, default value:1.
Definition: zwapi_cmd_dwg_data.h:1324
svxCenterMark::cmType
evxCentDimType cmType
center mark type, default value:VX_DM_CENLINE
Definition: zwapi_cmd_dwg_data.h:1322
svxCenterMark
Center Mark.
Definition: zwapi_cmd_dwg_data.h:1317
svxDatumDimData::type
evxDatumDimType type
datum type. (note: VX_DATUM_NORMAL as default)
Definition: zwapi_cmd_dwg_data.h:1234
svxDatumDimData::txtPnt
svxPntOnEnt txtPnt
point coordinate of text placement point. if type = VX_DATUM_NORMAL, txtPnt can be given arbitrarily....
Definition: zwapi_cmd_dwg_data.h:1240
svxDatumDimData::text
char * text
datum label name
Definition: zwapi_cmd_dwg_data.h:1236
svxDatumDimData::leadPnt
svxPntOnEnt leadPnt
point coordinate of point on entity. if type = VX_DATUM_NORMAL, leadPnt is the txtPnt's projection on...
Definition: zwapi_cmd_dwg_data.h:1237
svxDatumDimData
datum dim data(drawing)
Definition: zwapi_cmd_dwg_data.h:1233
svxDatumTargDimData::userText
char * userText
user text (userText is valid when iAreaSizeText equals to 1): defines the text that is displayed inst...
Definition: zwapi_cmd_dwg_data.h:1282
svxDatumTargDimData::diameter
double diameter
diameter (just for type = VX_DATUMT_RECTANGLE, other type can be ignored). if type = VX_DATUMT_RECTAN...
Definition: zwapi_cmd_dwg_data.h:1271
svxDatumTargDimData::text2
char * text2
datum text2 (text2 is valid when text is not empty)
Definition: zwapi_cmd_dwg_data.h:1278
svxDatumTargDimData::text3
char * text3
datum text3 (text3 is valid when text2 is not empty)
Definition: zwapi_cmd_dwg_data.h:1279
svxDatumTargDimData::textPnt
svxPntOnEnt textPnt
text point
Definition: zwapi_cmd_dwg_data.h:1267
svxDatumTargDimData::text
char * text
datum text
Definition: zwapi_cmd_dwg_data.h:1277
svxDatumTargDimData::type
evxDatumTargDimType type
datum target type. (Note: VX_DATUMT_POINT as default)
Definition: zwapi_cmd_dwg_data.h:1263
svxDatumTargDimData::width
double width
width (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE,...
Definition: zwapi_cmd_dwg_data.h:1273
svxDatumTargDimData::height
double height
height (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE,...
Definition: zwapi_cmd_dwg_data.h:1275
svxDatumTargDimData::iAreaSizeText
int iAreaSizeText
Area size text (0-Area size, 1-User text, 0 as default): to determine how the upper text of the datum...
Definition: zwapi_cmd_dwg_data.h:1280
svxDatumTargDimData::pnt
svxPntOnEnt pnt
point coordinate of point on entity.
Definition: zwapi_cmd_dwg_data.h:1266
svxDatumTargDimData::secPnt
svxPntOnEnt secPnt
2nd point (if type = VX_DATUMT_POINT, secPnt is 2nd point of a line other type can be ignored)
Definition: zwapi_cmd_dwg_data.h:1268
svxDatumTargDimData
datum target dim data
Definition: zwapi_cmd_dwg_data.h:1262
svxDimAuto::cntEnt
int cntEnt
entity ID count. if type = DIM_AUTO_ENT_PICKED, number of entities need to be created dimension,...
Definition: zwapi_cmd_dwg_data.h:696
svxDimAuto::checkOrg
int checkOrg
origin check flag, default value:1
Definition: zwapi_cmd_dwg_data.h:705
svxDimAuto::horDim
svxAutoSet horDim
horizontal dimensions position/placement
Definition: zwapi_cmd_dwg_data.h:707
svxDimAuto::idView
int idView
index of View
Definition: zwapi_cmd_dwg_data.h:694
svxDimAuto::verDim
svxAutoSet verDim
vertical dimensions position/placement
Definition: zwapi_cmd_dwg_data.h:708
svxDimAuto::entType
evxAutoEntType entType
select entity type, default value:DIM_AUTO_ENT_ALL
Definition: zwapi_cmd_dwg_data.h:695
svxDimAuto::pntOrg
svxPntOnEnt pntOrg
origin reference point, member critPnt should be entity critical point
Definition: zwapi_cmd_dwg_data.h:706
svxDimAuto::incAuto
unsigned int incAuto
evxAutoInclude mask. whether to include arc, circle, hole, line, R/hole callout, cylindrical dimensio...
Definition: zwapi_cmd_dwg_data.h:702
svxDimAuto::pEntId
int * pEntId
entity ID list. if type = DIM_AUTO_ENT_PICKED, list id of entities need to be created dimension,...
Definition: zwapi_cmd_dwg_data.h:699
svxDimAuto
auto dimension
Definition: zwapi_cmd_dwg_data.h:693
svxDwgAngDimData::txtPnt
svxPntOnEnt txtPnt
text point. if type = VX_ANG_ARC, the point is position of text of angle. other type can be null
Definition: zwapi_cmd_dwg_data.h:913
svxDwgAngDimData::type
evxAngDimType type
Angular or diametric type.
Definition: zwapi_cmd_dwg_data.h:887
svxDwgAngDimData::StartPnt
svxPntOnEnt StartPnt
start point. if type = VX_ANG_THREEPOINT, the angle is between two line, 1st line through....
Definition: zwapi_cmd_dwg_data.h:897
svxDwgAngDimData::BasePnt
svxPntOnEnt BasePnt
base point. if type = VX_ANG_THREEPOINT, BasePnt is angle's vertex. other type can be null.
Definition: zwapi_cmd_dwg_data.h:901
svxDwgAngDimData::Curve1
svxPntOnEnt Curve1
get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and...
Definition: zwapi_cmd_dwg_data.h:889
svxDwgAngDimData::QuadrantPnt
svxPntOnEnt QuadrantPnt
quadrant point. if type != VX_ANG_ARC, the point is position of text of angle.
Definition: zwapi_cmd_dwg_data.h:911
svxDwgAngDimData::ArcPnt
svxPntOnEnt ArcPnt
arc point on arc. if type = VX_ANG_ARC, the angle is arc's angle. other type can be null
Definition: zwapi_cmd_dwg_data.h:908
svxDwgAngDimData::EndPnt
svxPntOnEnt EndPnt
end point. if type = VX_ANG_THREEPOINT, the angle is between two line, 2nd line through....
Definition: zwapi_cmd_dwg_data.h:904
svxDwgAngDimData::Curve2
svxPntOnEnt Curve2
get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2...
Definition: zwapi_cmd_dwg_data.h:894
svxDwgAngDimData
Angular dimension dim data.
Definition: zwapi_cmd_dwg_data.h:886
svxDwgArcDimData::txtPnt
svxPntOnEnt txtPnt
text point : specify the location of the dimension text.
Definition: zwapi_cmd_dwg_data.h:958
svxDwgArcDimData::ArcEnt
svxPntOnEnt ArcEnt
get arc one entity
Definition: zwapi_cmd_dwg_data.h:957
svxDwgArcDimData
Arc dimension dim data.
Definition: zwapi_cmd_dwg_data.h:956
svxDwgAtBlnData::viewIdCnt
int viewIdCnt
count of view id
Definition: zwapi_cmd_dwg_data.h:1152
svxDwgAtBlnData::ptnType
evxDwgAtBlnPtnType ptnType
pattern type (note: VX_ATBLNPAT_CONVEXHULL as default)
Definition: zwapi_cmd_dwg_data.h:1156
svxDwgAtBlnData::leadAttach
evxDwgAtBlnLeadAttach leadAttach
leader attachment (note: VX_ATBLNLEAATT_EDAGES as default)
Definition: zwapi_cmd_dwg_data.h:1158
svxDwgAtBlnData::viewIdList
int * viewIdList
list of view id
Definition: zwapi_cmd_dwg_data.h:1153
svxDwgAtBlnData::offSet
vxUint32 offSet
specify the offset
Definition: zwapi_cmd_dwg_data.h:1160
svxDwgAtBlnData::OnlyBom
int OnlyBom
Whether the excluded components from BOM should be labeled. Used when have bom in sheeting....
Definition: zwapi_cmd_dwg_data.h:1170
svxDwgAtBlnData::instOpt
evxDwgAtBlnInsTyp instOpt
instances type (note: VX_ATBLNINS_IGNMULINS as default)
Definition: zwapi_cmd_dwg_data.h:1154
svxDwgAtBlnData::skipSides
evxDwgAtBlnSkpSd skipSides
prevent placing balloon labels along one side of the view. Be unusable when ptnType is VX_ATBLNPAT_CI...
Definition: zwapi_cmd_dwg_data.h:1161
svxDwgAtBlnData::arrangement
evxDwgAtBlnArrg arrangement
how the balloon labels will be arranged around the layout view. Used when have bom in sheeting,...
Definition: zwapi_cmd_dwg_data.h:1164
svxDwgAtBlnData::ItemId
int ItemId
index of the kept curve,used when KepItem is not 0.
Definition: zwapi_cmd_dwg_data.h:1169
svxDwgAtBlnData::OnlyWithoutBln
int OnlyWithoutBln
Whether label the components which are not labeled in any other views to eliminate duplicate balloons...
Definition: zwapi_cmd_dwg_data.h:1172
svxDwgAtBlnData
Information of creating auto balloon.
Definition: zwapi_cmd_dwg_data.h:1151
svxDwgBalloonDim::cntCrv
int cntCrv
no. of Location data items
Definition: zwapi_cmd_dwg_data.h:1084
svxDwgBalloonDim::leadPoints
svxPntOnEnt * leadPoints
list of "cntlead" points
Definition: zwapi_cmd_dwg_data.h:1087
svxDwgBalloonDim::Points
svxPntOnEnt * Points
list of "cntCrv" points
Definition: zwapi_cmd_dwg_data.h:1085
svxDwgBalloonDim::text
char * text
text string
Definition: zwapi_cmd_dwg_data.h:1083
svxDwgBalloonDim::condition
evxBalloonCon condition
Text condition, default value:VX_BALLOON_CON_ID.
Definition: zwapi_cmd_dwg_data.h:1082
svxDwgBalloonDim::cntlead
int cntlead
no. of Lead pnts data items: to locate where additional leader arrows will point
Definition: zwapi_cmd_dwg_data.h:1086
svxDwgBalloonDim
Balloon.
Definition: zwapi_cmd_dwg_data.h:1081
svxDwgConsDim::type
evxDimLineType type
type of dimension default value:horizontal method
Definition: zwapi_cmd_dwg_data.h:733
svxDwgConsDim::firstPnt
svxPntOnEnt firstPnt
first point
Definition: zwapi_cmd_dwg_data.h:734
svxDwgConsDim::textPnt
svxPntOnEnt textPnt
text point: to locate the dimension text
Definition: zwapi_cmd_dwg_data.h:736
svxDwgConsDim::secondPnt
svxPntOnEnt secondPnt
second point
Definition: zwapi_cmd_dwg_data.h:735
svxDwgFtrCtrl::text
char * text
FCS text name.
Definition: zwapi_cmd_dwg_data.h:1209
svxDwgFtrCtrl::leadPoints
svxPntOnEnt * leadPoints
list of "cntlead" points
Definition: zwapi_cmd_dwg_data.h:1213
svxDwgFtrCtrl::Points
svxPntOnEnt * Points
list of "cntCrv" points
Definition: zwapi_cmd_dwg_data.h:1211
svxDwgFtrCtrl::cntauxiLoc
int cntauxiLoc
no. of Auxiliary location data items
Definition: zwapi_cmd_dwg_data.h:1214
svxDwgFtrCtrl::cntlead
int cntlead
no. of Lead pts data items
Definition: zwapi_cmd_dwg_data.h:1212
svxDwgFtrCtrl::auxiPoints
svxPntOnEnt * auxiPoints
list of "cntauxiLoc" points
Definition: zwapi_cmd_dwg_data.h:1215
svxDwgFtrCtrl::cntCrv
int cntCrv
no. of Location data items
Definition: zwapi_cmd_dwg_data.h:1210
svxDwgFtrCtrl
Datum Control.
Definition: zwapi_cmd_dwg_data.h:1208
svxDwgHoleCallOutDim::cntCrv
int cntCrv
number of pCrvs or Pnts. the layout view where the holes are displayed true to their diameters.
Definition: zwapi_cmd_dwg_data.h:990
svxDwgHoleCallOutDim::ignoreDup
int ignoreDup
Ignore duplicate hole callout, 1 is ignored,0 not, default value:0 1 - if you want to exclude the mar...
Definition: zwapi_cmd_dwg_data.h:996
svxDwgHoleCallOutDim::pnts
svxPoint2 * pnts
list of text point. NULL to use default value. (the new variable when the ZW_API_VERSION is 2730)
Definition: zwapi_cmd_dwg_data.h:994
svxDwgHoleCallOutDim::iCalloutemt
unsigned int iCalloutemt
Callout Elements by evxCalloutEmt combined, default value:VX_CALLOUTEMT_VALID.
Definition: zwapi_cmd_dwg_data.h:998
svxDwgHoleCallOutDim::pCrvs
int * pCrvs
list of Holes data. the holes anywhere on their perimeter diameter
Definition: zwapi_cmd_dwg_data.h:992
svxDwgHoleCallOutDim::idView
int idView
id of View
Definition: zwapi_cmd_dwg_data.h:989
svxDwgHoleCallOutDim
Hole Callout.
Definition: zwapi_cmd_dwg_data.h:988
svxDwgLineDim::dirPnt
svxPntOnEnt dirPnt
the point on the project line. if type = VX_DIM_LINE_LP, the point is on the project line,...
Definition: zwapi_cmd_dwg_data.h:749
svxDwgLineDim::angle
double angle
dimension angle. if type = VX_DIM_LINE_LR, it is the angle between target line and vertical line,...
Definition: zwapi_cmd_dwg_data.h:746
svxDwgLineDim::cons
svxDwgConsDim cons
constraint dimension, 5 type of line dimension
Definition: zwapi_cmd_dwg_data.h:745
svxDwgLineDim
Linear.
Definition: zwapi_cmd_dwg_data.h:744
svxDwgLineGrpDim::Points
svxPntOnEnt * Points
list of "cntCrv" Points
Definition: zwapi_cmd_dwg_data.h:762
svxDwgLineGrpDim::cntCrv
int cntCrv
no. of Points data items
Definition: zwapi_cmd_dwg_data.h:761
svxDwgLineGrpDim::sub
svxDwgLineDim sub
Linear constraint dimension.
Definition: zwapi_cmd_dwg_data.h:760
svxDwgLineGrpDim
Baseline, Continuous.
Definition: zwapi_cmd_dwg_data.h:759
svxDwgLineOffsetDim::type
evxDimLineOffset type
type of dimension default value:VX_DIM_OFFSET_LOL
Definition: zwapi_cmd_dwg_data.h:807
svxDwgLineOffsetDim::firstPnt
svxPntOnEnt firstPnt
VX_DIM_OFFSET_LOL: first line ; VX_DIM_OFFSET_LOP: first line.
Definition: zwapi_cmd_dwg_data.h:808
svxDwgLineOffsetDim::secondPnt
svxPntOnEnt secondPnt
VX_DIM_OFFSET_LOL: second line; VX_DIM_OFFSET_LOP: point.
Definition: zwapi_cmd_dwg_data.h:809
svxDwgLineOffsetDim::textPnt
svxPntOnEnt textPnt
text point: select a point to locate the dimension text
Definition: zwapi_cmd_dwg_data.h:810
svxDwgLineOffsetDim
Linear Offset.
Definition: zwapi_cmd_dwg_data.h:806
svxDwgLnrChmDimData::LineEnt
svxPntOnEnt LineEnt
ID and point data of line (the idEnt of "LineEnt" must be valid). if type = VX_LEADER_CHAMFERDIM,...
Definition: zwapi_cmd_dwg_data.h:856
svxDwgLnrChmDimData::textPnt
svxPntOnEnt textPnt
point coordinate of text placement point. When "dimType" is VX_HORZORVERT_CHAMFERDIM,...
Definition: zwapi_cmd_dwg_data.h:861
svxDwgLnrChmDimData::dimType
evxDwgLnrChmDimType dimType
type of line linear chamfer Dim
Definition: zwapi_cmd_dwg_data.h:859
svxDwgLnrChmDimData::verTextPnt
svxPntOnEnt verTextPnt
point coordinate of vertical text placement point, only required when "dimType" is VX_HORZORVERT_CHAM...
Definition: zwapi_cmd_dwg_data.h:864
svxDwgLnrChmDimData::dimTexType
evxDwgLnrChmDimTexType dimTexType
type of Text, only required when "dimType" is VX_LEADER_CHAMFERDIM
Definition: zwapi_cmd_dwg_data.h:860
svxDwgLnrChmDimData
the info of the linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:855
svxDwgOrdinateDim::reverseAxis2
int reverseAxis2
reverse direction, default value:0
Definition: zwapi_cmd_dwg_data.h:775
svxDwgOrdinateDim::textPnt
svxPntOnEnt textPnt[2]
Horizontal(textPnt[0]) and Vertical(textPnt[1]) text point, used only for sub.cons....
Definition: zwapi_cmd_dwg_data.h:777
svxDwgOrdinateDim::reverseAxis1
int reverseAxis1
reverse direction, default value:0
Definition: zwapi_cmd_dwg_data.h:774
svxDwgOrdinateDim::Points
svxPntOnEnt * Points
list of "cntCrv" Points
Definition: zwapi_cmd_dwg_data.h:773
svxDwgOrdinateDim::cntCrv
int cntCrv
no. of Points data items
Definition: zwapi_cmd_dwg_data.h:772
svxDwgOrdinateDim::idEnt
int idEnt
Share origin (Group dimension), 0 to ignore.
Definition: zwapi_cmd_dwg_data.h:776
svxDwgOrdinateDim::sub
svxDwgLineDim sub
Linear constraint dimension, 6 type of line dimension.
Definition: zwapi_cmd_dwg_data.h:771
svxDwgOrdinateDim
Ordinate.
Definition: zwapi_cmd_dwg_data.h:770
svxDwgStkBlnData::entCnt
int entCnt
count of input entity corresponding to pIndexEntityList
Definition: zwapi_cmd_dwg_data.h:1195
svxDwgStkBlnData::autoSort
char autoSort
flag of auto sort (0-no, else yes. Note:0 as default) if set to non-zero, the balloons can be stacked...
Definition: zwapi_cmd_dwg_data.h:1199
svxDwgStkBlnData::idBlnDim
int idBlnDim
index of main balloon. It must be index of V_DM_BALL(not stack balloon)
Definition: zwapi_cmd_dwg_data.h:1194
svxDwgStkBlnData::pEntIdList
int * pEntIdList
input entity index list. Index must be VV3REF/VNCURV/VICURV/ VLINE2/VCIRCLE2/VARC2/V_DM_BALL(not stac...
Definition: zwapi_cmd_dwg_data.h:1196
svxDwgStkBlnData::stkBlnPtn
evxDwgStkBlnPtn stkBlnPtn
pattern of stack balloons
Definition: zwapi_cmd_dwg_data.h:1198
svxDwgStkBlnData
information of creating stack balloons
Definition: zwapi_cmd_dwg_data.h:1193
svxDwgSymmetryDimData::Pnt
svxPntOnEnt Pnt
point coordinate of point on entity, just for type = 0
Definition: zwapi_cmd_dwg_data.h:820
svxDwgSymmetryDimData::type
evxSymmetryDimType type
Symmetry dimension type.
Definition: zwapi_cmd_dwg_data.h:819
svxDwgSymmetryDimData::LinePnt
svxPntOnEnt LinePnt
line point coordinates, just for type = 1
Definition: zwapi_cmd_dwg_data.h:821
svxDwgSymmetryDimData::txtPnt
svxPntOnEnt txtPnt
text point
Definition: zwapi_cmd_dwg_data.h:823
svxDwgSymmetryDimData::CenterLinePnt
svxPntOnEnt CenterLinePnt
Center Line point coordinates.
Definition: zwapi_cmd_dwg_data.h:822
svxDwgSymmetryDimData
Symmetry dimension data.
Definition: zwapi_cmd_dwg_data.h:818
svxEntPath::Count
int Count
number of id's in the path
Definition: zwapi_util.h:269
svxEntPath::Id
int Id[V_PP_LEN]
list of id's that define the path to an entity Id[0] = -1; path begins with top-level parent file/o...
Definition: zwapi_util.h:270
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxLabelCoorDimData::orgPnt
svxPntOnEnt orgPnt
origin point of label coordinate dimension
Definition: zwapi_cmd_dwg_data.h:1013
svxLabelCoorDimData::cntPnt
int cntPnt
count of the point need to give the coordinates
Definition: zwapi_cmd_dwg_data.h:1015
svxLabelCoorDimData::pPnts
svxPntOnEnt * pPnts
point to the coordinate point of dimension(length of list must equal to cntPnt)
Definition: zwapi_cmd_dwg_data.h:1016
svxLabelCoorDimData::type
char type
label coordinate type
Definition: zwapi_cmd_dwg_data.h:1010
svxLabelCoorDimData::pTxtPnts
svxPntOnEnt * pTxtPnts
point to the text point of dimension if needs customization, the length of list must equal to cntPnt,...
Definition: zwapi_cmd_dwg_data.h:1017
svxLabelCoorDimData
label coordinate dim data
Definition: zwapi_cmd_dwg_data.h:1009
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt::useCritPnt
int useCritPnt
1- use critTyp, else 0 (idEnt must be valid if useCritPnt is 1)
Definition: zwapi_util.h:553
svxPntOnEnt::critTyp
evxGeomCritPnt critTyp
type of critical point
Definition: zwapi_util.h:554
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxRadDimData::brkPnt
svxPntOnEnt brkPnt
break point. if type = VX_RAD_BROKEN, the line through arcPnt and the arc center will be cut at the i...
Definition: zwapi_cmd_dwg_data.h:943
svxRadDimData::type
evxRadDimType type
radial or diametric type
Definition: zwapi_cmd_dwg_data.h:938
svxRadDimData::txtPnt
svxPntOnEnt txtPnt
text point: specify the location the dimension text
Definition: zwapi_cmd_dwg_data.h:948
svxRadDimData::arcPnt
svxPntOnEnt arcPnt
point coordinate of point on entity (entPnt will be projected to the entity if entPnt is not on entit...
Definition: zwapi_cmd_dwg_data.h:940
svxRadDimData
radial or diametric dim data
Definition: zwapi_cmd_dwg_data.h:937
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: drawing\dwgTableTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
drawing\dwgTableTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <string.h>
#include <stdio.h>
ApiDefVoidFunc(zwTestDwgTableCreate, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgTableAdjustSize, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgTableMerge, VX_CODE_GENERAL);
void zwTestDwgTableCreate()
/*
DESCRIPTION:
Test case1 for function table functions in drawing.
*/
{
/* new a drawing table */
int idUserTable = 0;
int nRows = 2, nCols = 4;
svxPoint2 orgPntForUserTbl = { 50, 100 };
if (cvxDwgUserTableCreate("NewUserTable", nRows, nCols, &orgPntForUserTbl, 6, &idUserTable) || idUserTable < 1)
zwTestLogErrorMsg(5, "cvxDwgUserTableCreate: failed to created a user table in drawing!");
/* insert and delete row in table */
for (int i = 0; i < 3; i++)
{
if (cvxDwgTableRowInsert(idUserTable, 2))
zwTestLogErrorMsg(5, "cvxDwgTableRowInsert: failed to inset a row!");
else
nRows++;
}
if (cvxDwgTableRowDelete(idUserTable, 2))
zwTestLogErrorMsg(5, "cvxDwgTableRowDelete: failed to delete a row!");
else
nRows--;
/* insert and delete column in table */
for (int i = 0; i < 2; i++)
{
if (cvxDwgTableColInsert(idUserTable, 4))
zwTestLogErrorMsg(5, "cvxDwgTableColInsert: failed to inset a column!");
else
nCols++;
}
if (cvxDwgTableColDelete(idUserTable, 4))
zwTestLogErrorMsg(5, "cvxDwgTableRowDelete: failed to delete a column!");
else
nCols--;
for (int i = 1; i <= nRows; i++)
{
for (int j = 1; j <= nCols; j++)
{
vxLongName text = "\0";
sprintf_s(text, sizeof(text), "%d,%d", i, j);
if (cvxDwgTableCellSet(idUserTable, i, j, text))
zwTestLogErrorMsg(5, "cvxDwgTableCellSet: failed to set text to cell in table!");
vxLongName textGet = "\0";
if (cvxDwgTableCellGet(idUserTable, i, j, textGet, sizeof(textGet)))
zwTestLogErrorMsg(5, "cvxDwgTableCellGet: failed to get text to cell in table!");
if (strcmp(text, textGet))
zwTestLogErrorMsg(5, "cvxDwgTableCellGet: text obtained is incorrect!");
}
}
svxTextAt textAt = {};
if (cvxDwgTableCellAtGet(idUserTable, 1, 1, &textAt))
zwTestLogErrorMsg(5, "cvxDwgTableCellAtGet: failed to get text attribute!");
textAt.color = VX_COLOR_RED;
textAt.bold = 1;
textAt.underline = 1; /* underline flag */
textAt.italic = 1; /* italic flag 0-normal, 1-italic */
strcpy_s(textAt.fontName, sizeof(textAt.fontName), "ZW3D Gothic English");
textAt.char_height = 4.0;
textAt.char_aspect += (float)0.2;
if (cvxDwgTableCellAtSet(idUserTable, 1, 1, &textAt))
zwTestLogErrorMsg(5, "cvxDwgTableCellAtSet: failed to set text attribute!");
if (cvxDwgTableRowHeightSet(idUserTable, 1, 30))
zwTestLogErrorMsg(5, "cvxDwgTableRowHeightSet: failed to adjust height of row!");
if (cvxDwgTableColWidthSet(idUserTable, 1, 30))
zwTestLogErrorMsg(5, "cvxDwgTableColWidthSet: failed to adjust width of column!");
int nRowGet = 0, nColGet = 0;
if (cvxDwgGetTableSize(idUserTable, &nRowGet, &nColGet))
zwTestLogErrorMsg(5, "cvxDwgGetTableSize: failed to get size of table!");
if (nRowGet != nRows + 1 || nColGet != nCols + 1)
zwTestLogErrorMsg(5, "cvxDwgGetTableSize: size of table obtained is incorrect!");
}
void zwTestDwgTableAdjustSize()
/*
DESCRIPTION:
Test case2 for function table functions in drawing.
*/
{
/* inquire active drawing */
vxLongName dwgName = "\0";
cvxDwgInqActive(dwgName, sizeof(dwgName));
if (dwgName[0] == '\0') return;
/* inquire index of drawing */
int idDrawing = 0;
cvxDwgFind(NULL, dwgName, &idDrawing);
/* find user table */
int nTables = 0, * idTables = NULL;
if (cvxDwgInqTables(idDrawing, VX_TABLE_ALL, &nTables, &idTables))
zwTestLogErrorMsg(5, "cvxDwgInqTables: failed to inquire table of drawing!");
int idUserTable = 0;
for (int i = 0; i < nTables; i++)
{
evxTableType tblType = VX_TABLE_ALL;
if (cvxDwgInqTableType(idTables[i], &tblType))
zwTestLogErrorMsg(5, "cvxDwgInqTableType: failed to inquire table type!");
if (tblType == VX_TABLE_USER)
{
idUserTable = idTables[i];
break;
}
}
cvxMemFree((void**)&idTables);
if (idUserTable < 1) return;
if (cvxDwgTableAdjustSize(idUserTable))
zwTestLogErrorMsg(5, "cvxDwgTableColWidthSet: failed to adjust width of column!");
cvxDispRedraw();
}
void zwTestDwgTableMerge()
/*
DESCRIPTION:
Test case3 for function table functions in drawing.
*/
{
/* inquire active drawing */
vxLongName dwgName = "\0";
cvxDwgInqActive(dwgName, sizeof(dwgName));
if (dwgName[0] == '\0') return;
/* inquire index of drawing */
int idDrawing = 0;
cvxDwgFind(NULL, dwgName, &idDrawing);
/* find user table */
int nTables = 0, * idTables = NULL;
if (cvxDwgInqTables(idDrawing, VX_TABLE_USER, &nTables, &idTables))
zwTestLogErrorMsg(5, "cvxDwgInqTables: failed to inquire table of drawing!");
if (nTables < 1) return;
int idUserTable = idTables[0];
cvxMemFree((void**)&idTables);
int nRowGet = 0, nColGet = 0;
if (cvxDwgGetTableSize(idUserTable, &nRowGet, &nColGet))
zwTestLogErrorMsg(5, "cvxDwgGetTableSize: failed to get size of table!");
if (nRowGet < 3 || nColGet < 4) return;
cvxDwgTableCellsMerge(idUserTable, 1, 1, 2, 3, 1);
cvxDwgTableCellsMerge(idUserTable, 2, 3, 4, 4, 1);
cvxDwgTableCellsUnMerge(idUserTable, 2, 3, 4, 4);
}
cvxDwgUserTableCreate
evxErrors cvxDwgUserTableCreate(const vxName name, int iRow, int iCol, svxPoint2 *pnt, int origin, int *idTable)
cvxDispRedraw
void cvxDispRedraw(void)
evxTableType
evxTableType
table type
Definition: zwapi_dwg_data.h:204
VX_TABLE_ALL
@ VX_TABLE_ALL
any table type
Definition: zwapi_dwg_data.h:205
VX_TABLE_USER
@ VX_TABLE_USER
User table.
Definition: zwapi_dwg_data.h:206
cvxDwgInqActive
evxErrors cvxDwgInqActive(char *drawingName, int nBytes)
cvxDwgFind
evxErrors cvxDwgFind(const vxRootName rootName, const vxLongName drawingName, int *idDrawing)
cvxDwgInqTables
evxErrors cvxDwgInqTables(int idDrawing, evxTableType type, int *count, int **tables)
cvxDwgTableCellsUnMerge
void cvxDwgTableCellsUnMerge(int idTable, int minRow, int maxRow, int minCol, int maxCol)
cvxDwgTableCellGet
evxErrors cvxDwgTableCellGet(int idTable, int Row, int Col, char *Value, int nBytes)
cvxDwgTableCellAtGet
evxErrors cvxDwgTableCellAtGet(int idTable, int Row, int Col, svxTextAt *TextAt)
cvxDwgTableAdjustSize
evxErrors cvxDwgTableAdjustSize(int idTable)
cvxDwgGetTableSize
evxErrors cvxDwgGetTableSize(int iTblIdx, int *pRowNum, int *pColNum)
cvxDwgTableRowInsert
evxErrors cvxDwgTableRowInsert(int idTable, int Row)
cvxDwgTableRowHeightSet
evxErrors cvxDwgTableRowHeightSet(int idTable, int Row, double Height)
cvxDwgTableColInsert
evxErrors cvxDwgTableColInsert(int idTable, int Col)
cvxDwgTableCellSet
evxErrors cvxDwgTableCellSet(int idTable, int Row, int Col, char *Value)
cvxDwgTableColDelete
evxErrors cvxDwgTableColDelete(int idTable, int Col)
cvxDwgTableCellAtSet
evxErrors cvxDwgTableCellAtSet(int idTable, int Row, int Col, svxTextAt *TextAt)
cvxDwgTableCellsMerge
void cvxDwgTableCellsMerge(int idTable, int startRow, int endRow, int startCol, int endCol, int kFirstData)
cvxDwgTableColWidthSet
evxErrors cvxDwgTableColWidthSet(int idTable, int Col, double Width)
cvxDwgTableRowDelete
evxErrors cvxDwgTableRowDelete(int idTable, int Row)
cvxDwgInqTableType
evxErrors cvxDwgInqTableType(int idTable, evxTableType *type)
cvxMemFree
void cvxMemFree(void **MemPointer)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
VX_COLOR_RED
@ VX_COLOR_RED
R=255, G=0, B=0.
Definition: zwapi_util.h:645
svxPoint2
2D point
Definition: zwapi_util.h:286
svxTextAt::char_height
float char_height
text height
Definition: zwapi_util.h:1463
svxTextAt::bold
unsigned char bold
bold flag 0-normal, 1-bold
Definition: zwapi_util.h:1455
svxTextAt::italic
unsigned char italic
italic flag 0-normal, 1-italic
Definition: zwapi_util.h:1459
svxTextAt::underline
unsigned char underline
underline flag 0x01-ul, overline flag 0x02-ol, delete line flag 0x04-dl
Definition: zwapi_util.h:1456
svxTextAt::fontName
char fontName[36]
font name
Definition: zwapi_util.h:1461
svxTextAt::char_aspect
float char_aspect
width of text, char_aspect = width / height
Definition: zwapi_util.h:1464
svxTextAt
text attribute
Definition: zwapi_util.h:1454
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: drawing\dwgViewTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
drawing\dwgViewTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <cstring>
ApiDefVoidFunc(zwTestDwgViewLayout, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewProjection, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewAuxiliary, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewFullSection, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewBrokenSection, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewDetail, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewBrkLine, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestDwgViewStandard, VX_CODE_GENERAL);
void zwTestDwgViewLayout()
/*
DESCRIPTION:
Test case for function cvxDwgViewLayout.
*/
{
/* initialize view layout */
svxViewLayoutData viewLayout;
if (cvxDwgViewLayoutInit(&viewLayout))
zwTestLogErrorMsg(5, "cvxDwgViewLayoutInit: failed to initialize a view layout!");
double val = 0;
cvxGetNumber("Select file to create layout(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
cvxGetFileByLongPath(1, "Select the file for projection...", workDir, "Part(*.Z3PRT)|*.Z3PRT|Assembly(*.Z3ASM)|*.Z3ASM|", viewLayout.name, sizeof(viewLayout.name));
}
else
{
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
evxFileSubtype fileType = VX_SUBTYPE_NONE;
if (!cvxFileInqSubType(fileList[i], &fileType) && fileType != VX_SUBTYPE_NONE)
{
strcpy_s(viewLayout.name, sizeof(viewLayout.name), fileList[i]);
break;
}
}
cvxMemFree((void**)&fileList);
}
if (viewLayout.name[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestDwgViewLayout: projection file not specified!");
return;
}
cvxGetNumber("whether ignore location: 0 or 1", &val);
if (int(val + 0.5))
viewLayout.isIgnoreLoc = 1;
else
{
cvxGetNumber("select view location type: 0 - 2", &val); /* 0 as default */
svxPoint firstPoint = { 0 }, secondPoint = { 0 };
if (int(val + 0.5) == 0)
viewLayout.location.type = VX_LOCATION_AUTO;
else if (int(val + 0.5) == 1)
{
viewLayout.location.type = VX_LOCATION_CENTER;
cvxGetPoint("select center point", VX_INP_PNT_GENERAL, 0, &firstPoint, nullptr);
viewLayout.location.FirstPoint = { firstPoint.x, firstPoint.y };
}
else
{
viewLayout.location.type = VX_LOCATION_CORNER;
cvxGetPoint("select first point", VX_INP_PNT_GENERAL, 0, &firstPoint, nullptr);
cvxGetPoint("select second point", VX_INP_PNT_GENERAL, 0, &secondPoint, nullptr);
viewLayout.location.FirstPoint = { firstPoint.x, firstPoint.y };
viewLayout.location.SecondPoint = { secondPoint.x, secondPoint.y };
}
}
cvxGetNumber("whether ignore layout method: 0 or 1", &val);
if (int(val + 0.5))
viewLayout.isIgnoreMethod = 1;
else
{
cvxGetNumber("first perspective or third perspective: 1 or 2", &val); /* 2 as default */
if (int(val + 0.5) == 1)
viewLayout.method.projection = 1;
cvxGetNumber("select view count: 1 - 7", &val);
if (val < 1)
viewLayout.method.count = 1;
else if (val > 7)
viewLayout.method.count = 7;
else
viewLayout.method.count = int(val + 0.5);
for (int i = 0; i < 7; i++)
viewLayout.method.StdMethod[i] = (evxViewStd)i;
}
cvxGetNumber("whether use default attribute: 0 or 1", &val);
if (int(val + 0.5))
{
viewLayout.isIgnoreAttr = 1;
cvxDwgViewAtGet(0, &viewLayout.viewAttr);
}
else
{
viewLayout.isIgnoreAttr = 0;
int idView = 0;
cvxGetEnt("select a view", VX_INP_GENERAL_2D, 0, &idView);
cvxDwgViewAtGet(idView, &viewLayout.viewAttr);
}
cvxGetNumber("select coordinate type: 1-default, 2-active", &val);
if (int(val + 0.5) == 2)
viewLayout.coordinate = 2;
cvxGetNumber("whether use part config: 0 or 1", &val);
if (int(val + 0.5))
strcpy_s(viewLayout.PartConfig, "cfg1");
viewLayout.ExplodedView = 0;
viewLayout.state = -1;
cvxGetNumber("select dimension type: 0-projected, 1-true", &val);
if (int(val + 0.5))
viewLayout.DimensionType = 1;
cvxGetNumber("whether calculate part center: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
viewLayout.isCalculate = 0;
/* create a view layout */
if (cvxDwgViewLayout(&viewLayout))
zwTestLogErrorMsg(5, "cvxDwgViewLayout: failed to create a view layout!");
}
void zwTestDwgViewProjection()
/*
DESCRIPTION:
Test case for function cvxDwgViewProjection.
*/
{
int idBaseView = 0;
cvxGetEnt("select a view to project", VX_INP_GENERAL_2D, 0, &idBaseView);
svxPoint location = { 0 };
cvxGetPoint("select view location", VX_INP_PNT_GENERAL, 0, &location, nullptr);
svxPoint2 location2D = { location.x, location.y };
int projection = 1;
double val = 0;
cvxGetNumber("select projection type: 1-1st angle, 2-3rd angle", &val);
if (int(val + 0.5) == 2)
projection = 2;
int dimType = 0;
cvxGetNumber("select dimension type: 0-projected, 1-true", &val);
if (int(val + 0.5))
dimType = 1;
svxViewAt viewAttr = { 0 };
cvxGetNumber("whether use default attribute: 0 or 1", &val);
if (int(val + 0.5))
cvxDwgViewAtGet(0, &viewAttr);
else
{
int idView = 0;
cvxGetEnt("select a view", VX_INP_GENERAL_2D, 0, &idView);
cvxDwgViewAtGet(idView, &viewAttr);
}
/* create a projection view */
int idProjView = 0;
if (cvxDwgViewProjection(idBaseView, &location2D, projection, dimType, &viewAttr, &idProjView) || idProjView == 0)
zwTestLogErrorMsg(5, "cvxDwgViewProjection: failed to create a projection view!");
}
void zwTestDwgViewAuxiliary()
/*
DESCRIPTION:
Test case for function cvxDwgViewAuxiliary.
*/
{
/* initialize auxiliary view */
svxAuxViewData auxView;
if (cvxDwgViewAuxiliaryInit(&auxView))
zwTestLogErrorMsg(5, "cvxDwgViewAuxiliaryInit: failed to initialize an auxiliary view!");
cvxGetEnt("select a view to project", VX_INP_GENERAL_2D, 0, &auxView.idView);
cvxGetEnt("select a line", VX_INP_GENERAL_2D, 0, &auxView.idLine);
svxPoint point = { 0 };
cvxGetPoint("select view location", VX_INP_PNT_GENERAL, 0, &point, nullptr);
auxView.locPnt = { point.x, point.y };
double val = 0;
cvxGetNumber("select projection type: 1-1st angle, 2-3rd angle", &val); /* 2 as default */
if (int(val + 0.5) == 1)
auxView.settings.prjType = VX_VIEW_PRJANG1ST;
cvxGetNumber("select dimension type: 0-projected, 1-true", &val);
if (int(val + 0.5))
auxView.settings.dimType = VX_VIEW_DIMTYPETRUE;
cvxGetNumber("specify view line offset distance, 20 as default", &auxView.arrowInfo.offset);
cvxGetNumber("whether specify start point and end point", &val);
if (int(val + 0.5))
{
auxView.arrowInfo.iFlag = 1;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &point, nullptr);
auxView.arrowInfo.startPnt = { point.x, point.y };
cvxGetPoint("select end point", VX_INP_PNT_GENERAL, 0, &point, nullptr);
auxView.arrowInfo.endPnt = { point.x, point.y };
}
/* create an auxiliary view */
int idAuxView = 0;
if (cvxDwgViewAuxiliary(&auxView, &idAuxView) || idAuxView == 0)
zwTestLogErrorMsg(5, "cvxDwgViewAuxiliary: failed to create an auxiliary view!");
}
void zwTestDwgViewFullSection()
/*
DESCRIPTION:
Test case for function cvxDwgViewFullSection.
*/
{
/* initialize full section view */
svxFulSecViewData fulSecView;
if (cvxDwgViewFullSectionInit(&fulSecView))
zwTestLogErrorMsg(5, "cvxDwgViewFullSectionInit: failed to initialize a full section view!");
cvxGetEnt("select a view to section", VX_INP_GENERAL_2D, 0, &fulSecView.idView);
svxPoint* points = nullptr;
cvxGetPoints(
"select points to define section, <middle click> to finish", VX_INP_PNT_GENERAL, 0, &fulSecView.iCnt, &points);
cvxMemAlloc(fulSecView.iCnt * sizeof(svxPoint2), (void**)&fulSecView.pPnts);
for (int i = 0; i < fulSecView.iCnt; i++)
fulSecView.pPnts[i] = { points[i].x, points[i].y };
svxPoint point = {};
cvxGetPoint("select location for section view", VX_INP_PNT_GENERAL, 0, &point, nullptr);
fulSecView.locPnt = { point.x, point.y };
/* section method */
double val = 0;
cvxGetNumber("select section method: 1 - 3", &val); /* 2 as default */
if (int(val + 0.5) == 1)
fulSecView.secMtd.mtdType = VX_METHOD_SECCURVE;
else if (int(val + 0.5) == 3)
fulSecView.secMtd.mtdType = VX_METHOD_TRIMSURF;
cvxGetNumber("whether close open profile: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
fulSecView.secMtd.iCloseOpenProf = 0;
cvxGetNumber("whether dynamic hatch scaling and angle: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
fulSecView.secMtd.iDynScalAng = 0;
cvxGetNumber("whether inherit section from base view if base view is section view: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
fulSecView.secMtd.inheritSecBasView = 0;
cvxGetNumber("select location type: 1 - 4", &val); /* 3 as default */
if (int(val + 0.5) == 1)
fulSecView.secMtd.locType = VX_LOC_HORIZONTAL;
else if (int(val + 0.5) == 2)
fulSecView.secMtd.locType = VX_LOC_VERTICAL;
else if (int(val + 0.5) == 4)
fulSecView.secMtd.locType = VX_LOC_NONE;
cvxGetNumber("select dimension type: 0-projected, 1-true", &val);
if (int(val + 0.5))
fulSecView.secMtd.dimType = VX_VIEW_DIMTYPETRUE;
if (fulSecView.secMtd.mtdType != VX_METHOD_SECCURVE)
cvxGetNumber("specify the display depth for section view", &val);
/* section line */
char ch = '\0';
fulSecView.secLine.viewLabel = &ch;
cvxGetNumber("whether flip arrow: 0 or 1", &val);
if (int(val + 0.5))
fulSecView.secLine.iFlipArrow = 1;
cvxGetNumber("whether show step lines: 0 or 1", &val);
if (int(val + 0.5))
fulSecView.secLine.iShowStepLines = 1;
/* section option */
cvxGetNumber("whether set the component section state according to the part attributes: 0 or 1", &val);
if (int(val + 0.5))
fulSecView.secOp.iSecState = 1;
cvxGetNumber("whether set the component hatch state according to the part attributes: 0 or 1", &val);
if (int(val + 0.5))
fulSecView.secOp.iSecState = 1;
cvxGetNumber("whether set the component hatch color according to the part color: 0 or 1", &val);
if (int(val + 0.5))
fulSecView.secOp.iHatchClr = 1;
/* create a full section view */
int idFulSecView = 0;
if (cvxDwgViewFullSection(&fulSecView, &idFulSecView) || idFulSecView == 0)
zwTestLogErrorMsg(5, "cvxDwgViewFullSection: failed to create a full section view!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&fulSecView.pPnts);
}
void zwTestDwgViewBrokenSection()
/*
DESCRIPTION:
Test case for function cvxDwgViewBrokenSection.
*/
{
/* initialize a broken section view */
svxDwgBrokenSectionData brokenSection;
if (cvxDwgViewBrokenSectionInit(&brokenSection))
zwTestLogErrorMsg(5, "cvxDwgViewBrokenSectionInit: failed to initialize a broken section view!");
cvxGetEnt("select a view to section", VX_INP_GENERAL_2D, 0, &brokenSection.idView);
double val = 0;
cvxGetNumber("select boundary method: 1 - 3", &val); /* 1 as default */
int count = 0;
svxPoint* points = nullptr;
if (int(val + 0.5) == 1)
{
brokenSection.method = VX_RECTANGULAR_BOUNDARY;
cvxGetPoints("select corner points for rectangle boundary", VX_INP_PNT_GENERAL, 0, &count, &points);
brokenSection.countBPs = 2;
}
else if (int(val + 0.5) == 1)
{
brokenSection.method = VX_CIRCULAR_BOUNDARY;
cvxGetPoints("select center and radius points for circle boundary", VX_INP_PNT_GENERAL, 0, &count, &points);
brokenSection.countBPs = 2;
}
else
{
brokenSection.method = VX_POLYLINE_BOUNDARY;
cvxGetPoints("select points for polyline boundary", VX_INP_PNT_GENERAL, 0, &brokenSection.countBPs, &points);
}
cvxMemAlloc(brokenSection.countBPs * sizeof(svxPoint2), (void**)&brokenSection.bPoints);
for (int i = 0; i < brokenSection.countBPs; i++)
brokenSection.bPoints[i] = { points[i].x, points[i].y };
cvxGetNumber("select depth type: 0 - 2", &val);
if (int(val + 0.5) == 0)
{
brokenSection.type = VX_DEPTH_POINT;
svxPoint point = {};
cvxGetPoint("select point on curve to set section depth", VX_INP_PNT_ON_CURVE, 0, &point, &brokenSection.idCrv);
brokenSection.dPoint = { point.x, point.y };
cvxGetNumber("enter distance from depth point to section plane", &brokenSection.dOffset);
}
else if (int(val + 0.5) == 1)
{
brokenSection.type = VX_DEPTH_SECTION_PLANE;
cvxGetEnt("select a view in which to define section plane", VX_INP_GENERAL_2D, 0, &brokenSection.dView);
svxPoint point = {};
cvxGetPoint("select base point for section plane", VX_INP_PNT_GENERAL, 0, &point, nullptr);
brokenSection.dPoint = { point.x, point.y };
cvxMemFree((void**)&points);
cvxGetPoints(
"select points to define offset of section", VX_INP_PNT_GENERAL, 1, &brokenSection.countOPs, &points);
cvxMemAlloc(brokenSection.countOPs * sizeof(svxPoint2), (void**)&brokenSection.oPoints);
for (int i = 0; i < brokenSection.countOPs; i++)
brokenSection.oPoints[i] = { points[i].x, points[i].y };
}
else
{
brokenSection.type = VX_DEPTH_3D_NAMED;
strcpy_s(brokenSection.name, "3dNamed");
}
cvxGetNumber("whether show step lines: 0 or 1", &val);
if (int(val + 0.5))
brokenSection.isShow = 1;
cvxGetNumber("whether dynamic hatch scaling and angle: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
brokenSection.isDynamicHatch = 0;
/* create a broken section view */
int idBrokenSection = 0;
if (cvxDwgViewBrokenSection(&brokenSection, &idBrokenSection) || idBrokenSection == 0)
zwTestLogErrorMsg(5, "cvxDwgViewBrokenSection: failed to create a broken section view!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&brokenSection.bPoints);
cvxMemFree((void**)&brokenSection.oPoints);
}
void zwTestDwgViewDetail()
/*
DESCRIPTION:
Test case for function cvxDwgViewDetail.
*/
{
/* initialize a local detail view */
svxDwgDetailData detail;
if (cvxDwgViewDetailInit(&detail))
zwTestLogErrorMsg(5, "cvxDwgViewDetailInit: failed to initialize a local detail view!");
cvxGetEnt("select a view to create detail", VX_INP_GENERAL_2D, 0, &detail.idView);
double val = 0;
cvxGetNumber("select detail method: 1 - 3", &val);
int count = 0;
svxPoint* points = nullptr;
if (int(val + 0.5) == 1)
{
detail.method = VX_RECTANGULAR_DETAIL;
cvxGetPoints("specify detail from rectangle", VX_INP_PNT_GENERAL, 0, &count, &points);
detail.PntCount = 2;
}
else if (int(val + 0.5) == 2)
{
detail.method = VX_CIRCULAR_DETAIL;
cvxGetPoints("specify detail from center and radius points", VX_INP_PNT_GENERAL, 0, &count, &points);
detail.PntCount = 2;
}
else
{
detail.method = VX_POLYLINE_DETAIL;
cvxGetPoints("specify detail from polyline", VX_INP_PNT_GENERAL, 0, &detail.PntCount, &points);
}
cvxMemAlloc(detail.PntCount * sizeof(svxPntOnEnt), (void**)&detail.pPnts);
cvxMemZero((void*)detail.pPnts, detail.PntCount * sizeof(svxPntOnEnt));
for (int i = 0; i < detail.PntCount; i++)
detail.pPnts[i].pnt = points[i];
cvxGetPoint("indicate detail note location", VX_INP_PNT_GENERAL, 0, &detail.NotePnt.pnt, &detail.NotePnt.idEnt);
detail.iMultiplier = 3;
cvxGetPoint("indicate view location", VX_INP_PNT_GENERAL, 0, &detail.Location.pnt, &detail.Location.idEnt);
/* create a local detail view */
int idDetail = 0;
if (cvxDwgViewDetail(&detail, &idDetail) || idDetail == 0)
zwTestLogErrorMsg(5, "cvxDwgViewDetail: failed to create a local detail view!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&detail.pPnts);
}
void zwTestDwgViewBrkLine()
/*
DESCRIPTION:
Test case for function cvxDwgViewBrkLine.
*/
{
/* initialize a break line view */
svxBrkLineData brkLine;
if (cvxDwgViewBrkLineInit(&brkLine))
zwTestLogErrorMsg(5, "cvxDwgViewBrkLineInit: failed to initialize a break line view!");
cvxGetEnt("select a view to create break line", VX_INP_GENERAL_2D, 0, &brkLine.viewId);
double val = 0;
cvxGetNumber("select break line type: 0 - 2", &val);
if (int(val + 0.5) == 0)
{
brkLine.brkLnType = VX_HOR_BRKLINE;
for (int i = 0; i < 2; i++)
cvxGetPoint(
"select points to define gap point", VX_INP_PNT_GENERAL, 0, &brkLine.pts[i].pnt, &brkLine.pts[i].idEnt);
}
else if (int(val + 0.5) == 1)
{
brkLine.brkLnType = VX_VER_BRKLINE;
for (int i = 0; i < 2; i++)
cvxGetPoint(
"select points to define gap point", VX_INP_PNT_GENERAL, 0, &brkLine.pts[i].pnt, &brkLine.pts[i].idEnt);
}
else
{
brkLine.brkLnType = VX_SLANT_BRKLINE;
for (int i = 0; i < 3; i++)
cvxGetPoint(
"select points to define gap point", VX_INP_PNT_GENERAL, 0, &brkLine.pts[i].pnt, &brkLine.pts[i].idEnt);
int idEnt = 0;
cvxGetEnt("select direction", VX_INP_EDGE_OR_CURVE, 0, &idEnt);
svxPoint start = {}, end = {};
cvxEntEndPnt(idEnt, &start, &end);
brkLine.dir = { start.x - end.x, start.y - end.y };
}
cvxGetNumber("specify gap size", &brkLine.gap);
/* create a break line view */
int idBrkLine = 0;
if (cvxDwgViewBrkLine(&brkLine, &idBrkLine) || idBrkLine == 0)
zwTestLogErrorMsg(5, "cvxDwgViewBrkLine: failed to create a break line view!");
}
void zwTestDwgViewStandard()
/*
DESCRIPTION:
Test case for function cvxDwgViewStandard.
*/
{
/* initialize a standard view */
svxViewStandardData standard;
if (cvxDwgViewStandardInit(&standard))
zwTestLogErrorMsg(5, "cvxDwgViewStandardInit: failed to initialize a standard view!");
double val = 0;
cvxGetNumber("Select file to create layout(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
vxLongPath filePath = "\0";
cvxGetFileByLongPath(1, "Select the file for projection...", workDir, "Part(*.Z3PRT)|*.Z3PRT|Assembly(*.Z3ASM)|*.Z3ASM|", filePath, sizeof(filePath));
if (filePath[0] != '\0')
{
cvxPathDirByLongPath(filePath, standard.path,sizeof(standard.path));
cvxPathFileByLongPath(filePath, standard.fileName, sizeof(standard.fileName));
strcpy_s(standard.rootName, sizeof(standard.rootName), standard.fileName);
char* ch = strrchr(standard.rootName, '.');
if (ch) *ch = '\0';
}
}
else
{
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
evxFileSubtype fileType = VX_SUBTYPE_NONE;
if (!cvxFileInqSubType(fileList[i], &fileType) && fileType != VX_SUBTYPE_NONE)
{
strcpy_s(standard.fileName, sizeof(standard.fileName), fileList[i]);
strcpy_s(standard.rootName, sizeof(standard.rootName), fileList[i]);
char* ch = strrchr(standard.rootName, '.');
if (ch) *ch = '\0';
break;
}
}
cvxMemFree((void**)&fileList);
}
if (standard.fileName[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestDwgViewStandard: projection file not specified!");
return;
}
cvxGetNumber("select standard view type: 0 - 2", &val);
if (int(val + 0.5) == 0)
{
standard.type = 0;
cvxGetNumber("select view type: 1 - 7, 28 - 34, 39", &val);
standard.option.viewType = (evxViewTypeEx) int(val + 0.5);
}
else if (int(val + 0.5) == 1)
{
standard.type = 1;
strcpy_s(standard.option.viewName, "viewName");
}
else
{
standard.type = 2;
strcpy_s(standard.option.flatName, "Flatten1");
}
svxPoint point = {};
cvxGetPoint("indicate view location", VX_INP_PNT_GENERAL, 0, &point, nullptr);
standard.location = { point.x, point.y };
cvxGetNumber("whether use default attribute: 0 or 1", &val);
if (int(val + 0.5))
{
standard.isIgnoreAttr = 1;
cvxDwgViewAtGet(0, &standard.viewAttr);
}
else
{
standard.isIgnoreAttr = 0;
int idView = 0;
cvxGetEnt("select a view", VX_INP_GENERAL_2D, 0, &idView);
cvxDwgViewAtGet(idView, &standard.viewAttr);
}
cvxGetNumber("select origin: 1-default, 2-active", &val); /* 1 as default */
if (int(val + 0.5) == 2)
standard.origin = 2;
cvxGetNumber("select coordinate: 1-default, 2-active", &val); /* 1 as default */
if (int(val + 0.5) == 2)
standard.coordinate = 2;
cvxGetNumber("whether use part config: 0 or 1", &val);
if (val + 0.5)
strcpy_s(standard.partConfig, "configName");
standard.explodedView = 0;
standard.isDispTrails = 0;
standard.state = 1;
cvxGetNumber("select dimension type: 0-projected, 1-true", &val);
if (int(val + 0.5))
standard.dimensionType = 1;
cvxGetNumber("calculate part center: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
standard.isCalculate = 0;
cvxGetNumber("view orientation from parent: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
standard.isOrientation = 0;
/* create a standard view */
int idStandard = 0;
if (cvxDwgViewStandard(&standard, &idStandard) || idStandard == 0)
zwTestLogErrorMsg(5, "cvxDwgViewStandard: failed to create a standard view!");
}
VX_LOC_HORIZONTAL
@ VX_LOC_HORIZONTAL
Location : Horizontal.
Definition: zwapi_cmd_dwg_data.h:294
VX_LOC_VERTICAL
@ VX_LOC_VERTICAL
Location : Vertical.
Definition: zwapi_cmd_dwg_data.h:295
VX_LOC_NONE
@ VX_LOC_NONE
Location : None.
Definition: zwapi_cmd_dwg_data.h:297
VX_VER_BRKLINE
@ VX_VER_BRKLINE
Vertical break line.
Definition: zwapi_cmd_dwg_data.h:469
VX_SLANT_BRKLINE
@ VX_SLANT_BRKLINE
Slant break line.
Definition: zwapi_cmd_dwg_data.h:470
VX_HOR_BRKLINE
@ VX_HOR_BRKLINE
Horizontal break line.
Definition: zwapi_cmd_dwg_data.h:468
VX_VIEW_DIMTYPETRUE
@ VX_VIEW_DIMTYPETRUE
dimension type : True
Definition: zwapi_cmd_dwg_data.h:237
VX_DEPTH_POINT
@ VX_DEPTH_POINT
point
Definition: zwapi_cmd_dwg_data.h:408
VX_DEPTH_SECTION_PLANE
@ VX_DEPTH_SECTION_PLANE
section plane
Definition: zwapi_cmd_dwg_data.h:409
VX_DEPTH_3D_NAMED
@ VX_DEPTH_3D_NAMED
3d named
Definition: zwapi_cmd_dwg_data.h:410
evxViewTypeEx
evxViewTypeEx
View type, more detailed than evxViewType.
Definition: zwapi_cmd_dwg_data.h:140
VX_METHOD_SECCURVE
@ VX_METHOD_SECCURVE
Section Method : Sect Curves.
Definition: zwapi_cmd_dwg_data.h:283
VX_METHOD_TRIMSURF
@ VX_METHOD_TRIMSURF
Section Method : Trimmed Surface.
Definition: zwapi_cmd_dwg_data.h:285
VX_POLYLINE_DETAIL
@ VX_POLYLINE_DETAIL
polyline detail view
Definition: zwapi_cmd_dwg_data.h:444
VX_CIRCULAR_DETAIL
@ VX_CIRCULAR_DETAIL
circular detail view
Definition: zwapi_cmd_dwg_data.h:443
VX_RECTANGULAR_DETAIL
@ VX_RECTANGULAR_DETAIL
rectangular detail view
Definition: zwapi_cmd_dwg_data.h:442
VX_VIEW_PRJANG1ST
@ VX_VIEW_PRJANG1ST
1st angle
Definition: zwapi_cmd_dwg_data.h:226
VX_RECTANGULAR_BOUNDARY
@ VX_RECTANGULAR_BOUNDARY
Rectangular boundary.
Definition: zwapi_cmd_dwg_data.h:397
VX_CIRCULAR_BOUNDARY
@ VX_CIRCULAR_BOUNDARY
Circular boundary.
Definition: zwapi_cmd_dwg_data.h:398
VX_POLYLINE_BOUNDARY
@ VX_POLYLINE_BOUNDARY
Polyline boundary.
Definition: zwapi_cmd_dwg_data.h:399
VX_LOCATION_CENTER
@ VX_LOCATION_CENTER
set center point
Definition: zwapi_cmd_dwg_data.h:37
VX_LOCATION_AUTO
@ VX_LOCATION_AUTO
automatic set-up
Definition: zwapi_cmd_dwg_data.h:36
VX_LOCATION_CORNER
@ VX_LOCATION_CORNER
set corner points
Definition: zwapi_cmd_dwg_data.h:38
cvxDwgViewDetail
evxErrors cvxDwgViewDetail(const svxDwgDetailData *data, int *idView)
cvxDwgViewStandardInit
evxErrors cvxDwgViewStandardInit(svxViewStandardData *data)
cvxDwgViewBrkLine
evxErrors cvxDwgViewBrkLine(const svxBrkLineData *brkLineInfo, int *brkLnViewId)
cvxDwgViewAuxiliaryInit
evxErrors cvxDwgViewAuxiliaryInit(svxAuxViewData *data)
cvxDwgViewFullSection
evxErrors cvxDwgViewFullSection(const svxFulSecViewData *fulSecViewData, int *idView)
cvxDwgViewAuxiliary
evxErrors cvxDwgViewAuxiliary(const svxAuxViewData *auxViewData, int *idView)
cvxDwgViewBrokenSectionInit
evxErrors cvxDwgViewBrokenSectionInit(svxDwgBrokenSectionData *data)
cvxDwgViewFullSectionInit
evxErrors cvxDwgViewFullSectionInit(svxFulSecViewData *data)
cvxDwgViewStandard
evxErrors cvxDwgViewStandard(const svxViewStandardData *data, int *idView)
cvxDwgViewBrkLineInit
evxErrors cvxDwgViewBrkLineInit(svxBrkLineData *data)
cvxDwgViewBrokenSection
evxErrors cvxDwgViewBrokenSection(svxDwgBrokenSectionData *data, int *idView)
cvxDwgViewDetailInit
evxErrors cvxDwgViewDetailInit(svxDwgDetailData *data)
cvxDwgViewLayoutInit
evxErrors cvxDwgViewLayoutInit(svxViewLayoutData *data)
cvxDwgViewProjection
evxErrors cvxDwgViewProjection(int idBaseView, svxPoint2 *location, int Projection, int DimType, svxViewAt *ViewAttr, int *idProjView)
cvxDwgViewLayout
evxErrors cvxDwgViewLayout(svxViewLayoutData *data)
cvxConfigGetString
evxErrors cvxConfigGetString(const char *Name, char *Str, int nBytes)
cvxDwgViewAtGet
evxErrors cvxDwgViewAtGet(int idView, svxViewAt *viewAttr)
evxFileSubtype
evxFileSubtype
file sub-type
Definition: zwapi_file_data.h:46
VX_SUBTYPE_NONE
@ VX_SUBTYPE_NONE
no subtype
Definition: zwapi_file_data.h:47
cvxPathDirByLongPath
void cvxPathDirByLongPath(const vxLongPath FullPath, char *Directory, int sizeDir)
cvxPathFileByLongPath
void cvxPathFileByLongPath(const vxLongPath FullPath, char *FileName, int sizeFile)
cvxFileOpenListByLongPath
void cvxFileOpenListByLongPath(int *count, vxLongPath **fileList)
cvxFileInqSubType
evxErrors cvxFileInqSubType(const vxLongPath fileName, evxFileSubtype *fileSubtype)
cvxEntEndPnt
evxErrors cvxEntEndPnt(int idEntity, svxPoint *Start, svxPoint *End)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
cvxGetFileByLongPath
void cvxGetFileByLongPath(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
svxAuxViewData::arrowInfo
svxViewArrow arrowInfo
view arrow
Definition: zwapi_cmd_dwg_data.h:274
svxAuxViewData::idView
int idView
the id of base view
Definition: zwapi_cmd_dwg_data.h:270
svxAuxViewData::idLine
int idLine
line to define auxiliary view plane (this must be a line)
Definition: zwapi_cmd_dwg_data.h:271
svxAuxViewData::settings
svxPrjSetting settings
projection settings
Definition: zwapi_cmd_dwg_data.h:273
svxAuxViewData::locPnt
svxPoint2 locPnt
view location
Definition: zwapi_cmd_dwg_data.h:272
svxAuxViewData
Auxiliary view data.
Definition: zwapi_cmd_dwg_data.h:269
svxBrkLineData::pts
svxPntOnEnt pts[3]
3 input points depend on option of break line. only VX_SLANT_BRKLINE needs the third point,...
Definition: zwapi_cmd_dwg_data.h:481
svxBrkLineData::brkLnType
evxBrkLineType brkLnType
option of break line
Definition: zwapi_cmd_dwg_data.h:480
svxBrkLineData::viewId
int viewId
id of view
Definition: zwapi_cmd_dwg_data.h:479
svxBrkLineData::gap
double gap
gap size
Definition: zwapi_cmd_dwg_data.h:483
svxBrkLineData::dir
svxPoint2 dir
direction setting, only required when evxBrkLineType is VX_SLANT_BRKLINE
Definition: zwapi_cmd_dwg_data.h:484
svxBrkLineData
information we need when create break line
Definition: zwapi_cmd_dwg_data.h:478
svxDwgBrokenSectionData::type
evxDwgDepthType type
depth type
Definition: zwapi_cmd_dwg_data.h:423
svxDwgBrokenSectionData::idView
int idView
Base view.
Definition: zwapi_cmd_dwg_data.h:420
svxDwgBrokenSectionData::dPoint
svxPoint2 dPoint
depth point
Definition: zwapi_cmd_dwg_data.h:424
svxDwgBrokenSectionData::countBPs
int countBPs
count of "bPoints"
Definition: zwapi_cmd_dwg_data.h:422
svxDwgBrokenSectionData::method
evxDwgBndMethod method
Boundary Method.
Definition: zwapi_cmd_dwg_data.h:419
svxDwgBrokenSectionData::dView
int dView
depth view
Definition: zwapi_cmd_dwg_data.h:428
svxDwgBrokenSectionData::isDynamicHatch
int isDynamicHatch
dynamic hatch scaling and angle
Definition: zwapi_cmd_dwg_data.h:431
svxDwgBrokenSectionData::isShow
int isShow
show step lines
Definition: zwapi_cmd_dwg_data.h:430
svxDwgBrokenSectionData::countOPs
int countOPs
count of "oPoints"
Definition: zwapi_cmd_dwg_data.h:433
svxDwgBrokenSectionData::name
vxName name
3D name
Definition: zwapi_cmd_dwg_data.h:429
svxDwgBrokenSectionData::bPoints
svxPoint2 * bPoints
The boundary is made up of points.
Definition: zwapi_cmd_dwg_data.h:421
svxDwgBrokenSectionData::dOffset
double dOffset
depth offset
Definition: zwapi_cmd_dwg_data.h:427
svxDwgBrokenSectionData::oPoints
svxPoint2 * oPoints
offset points
Definition: zwapi_cmd_dwg_data.h:432
svxDwgBrokenSectionData::idCrv
int idCrv
curve id. if type == VX_DEPTH_POINT, point "dPoint" must be on the curve "idCrv"
Definition: zwapi_cmd_dwg_data.h:425
svxDwgBrokenSectionData
Drawing Broken Section input infos.
Definition: zwapi_cmd_dwg_data.h:418
svxDwgDetailData::pPnts
svxPntOnEnt * pPnts
pick points defining the detail boundary
Definition: zwapi_cmd_dwg_data.h:456
svxDwgDetailData::Location
svxPntOnEnt Location
local detail view position
Definition: zwapi_cmd_dwg_data.h:459
svxDwgDetailData::method
evxDwgDetailMethod method
Detail Method.
Definition: zwapi_cmd_dwg_data.h:453
svxDwgDetailData::PntCount
int PntCount
all points count
Definition: zwapi_cmd_dwg_data.h:455
svxDwgDetailData::idView
int idView
Base view.
Definition: zwapi_cmd_dwg_data.h:454
svxDwgDetailData::iMultiplier
int iMultiplier
local magnification
Definition: zwapi_cmd_dwg_data.h:458
svxDwgDetailData::NotePnt
svxPntOnEnt NotePnt
pick point for note
Definition: zwapi_cmd_dwg_data.h:457
svxDwgDetailData
Drawing Detail input infos.
Definition: zwapi_cmd_dwg_data.h:452
svxFulSecViewData::pPnts
svxPoint2 * pPnts
points to define section
Definition: zwapi_cmd_dwg_data.h:365
svxFulSecViewData::idView
int idView
the id of base view to section
Definition: zwapi_cmd_dwg_data.h:362
svxFulSecViewData::iCnt
int iCnt
the count of the points
Definition: zwapi_cmd_dwg_data.h:364
svxFulSecViewData::secMtd
svxViewSecMtd secMtd
section method
Definition: zwapi_cmd_dwg_data.h:368
svxFulSecViewData::secLine
svxViewSecLine secLine
section line
Definition: zwapi_cmd_dwg_data.h:369
svxFulSecViewData::locPnt
svxPoint2 locPnt
the location for section view
Definition: zwapi_cmd_dwg_data.h:367
svxFulSecViewData::secOp
svxViewSecOp secOp
section option
Definition: zwapi_cmd_dwg_data.h:370
svxFulSecViewData
full section view data
Definition: zwapi_cmd_dwg_data.h:361
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxPrjSetting::prjType
evxViewPrjAngType prjType
Projection or Auxiliary view's projection angle (VX_VIEW_PRJANG3RD as default)
Definition: zwapi_cmd_dwg_data.h:246
svxPrjSetting::dimType
evxViewDimType dimType
Projection or Auxiliary view's dimension type (VX_VIEW_DIMTYPEPRJ as default)
Definition: zwapi_cmd_dwg_data.h:247
svxViewArrow::endPnt
svxPoint2 endPnt
arrow end location
Definition: zwapi_cmd_dwg_data.h:261
svxViewArrow::startPnt
svxPoint2 startPnt
arrow start location
Definition: zwapi_cmd_dwg_data.h:260
svxViewArrow::offset
double offset
view line offset distance (20.0 as default)
Definition: zwapi_cmd_dwg_data.h:256
svxViewArrow::iFlag
int iFlag
iFlag = 0, startPnt and entPnt will use default value (user input is invalid) iFlag > 0,...
Definition: zwapi_cmd_dwg_data.h:258
svxViewAt
View layout display attributes.
Definition: zwapi_cmd_dwg_data.h:77
svxViewLayoutData::location
svxViewLocationData location
location of the views
Definition: zwapi_cmd_dwg_data.h:117
svxViewLayoutData::ExplodedView
int ExplodedView
exploded view ,default:0
Definition: zwapi_cmd_dwg_data.h:126
svxViewLayoutData::isIgnoreLoc
int isIgnoreLoc
1 if ignore location and use default,else 0
Definition: zwapi_cmd_dwg_data.h:118
svxViewLayoutData::DimensionType
int DimensionType
0 if projected, 1 if true. default:0.
Definition: zwapi_cmd_dwg_data.h:128
svxViewLayoutData::method
svxViewLayoutMethod method
layout method
Definition: zwapi_cmd_dwg_data.h:119
svxViewLayoutData::name
vxPath name
file name of the projected part or assembly (file that is unloaded must use the full path)
Definition: zwapi_cmd_dwg_data.h:115
svxViewLayoutData::isIgnoreAttr
int isIgnoreAttr
1 if ignore viewAttr and use default,else 0
Definition: zwapi_cmd_dwg_data.h:122
svxViewLayoutData::coordinate
int coordinate
projection coordinate system, default:1 to use the global coordinate system
Definition: zwapi_cmd_dwg_data.h:123
svxViewLayoutData::PartConfig
vxName PartConfig
part config name ,PartConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:124
svxViewLayoutData::isIgnoreMethod
int isIgnoreMethod
1 if ignore method and use default,else 0
Definition: zwapi_cmd_dwg_data.h:120
svxViewLayoutData::isCalculate
int isCalculate
1 if calculate part center ,else 0. default:1
Definition: zwapi_cmd_dwg_data.h:129
svxViewLayoutData::state
int state
index for the backup feature, default:-1
Definition: zwapi_cmd_dwg_data.h:127
svxViewLayoutData::viewAttr
svxViewAt viewAttr
view attribute
Definition: zwapi_cmd_dwg_data.h:121
svxViewLayoutData
drawing view layout data
Definition: zwapi_cmd_dwg_data.h:114
svxViewLayoutMethod::count
int count
The number of valid values for "StdMethod" "count" has a maximum of 7 and a minimum of 1....
Definition: zwapi_cmd_dwg_data.h:63
svxViewLayoutMethod::projection
int projection
1 if the first perspective, 2 if the third perspective default:2
Definition: zwapi_cmd_dwg_data.h:60
svxViewLayoutMethod::StdMethod
evxViewStd StdMethod[7]
StdMethod[0] is base view orientations, others are projection view orientations StdMethod[0] is in ...
Definition: zwapi_cmd_dwg_data.h:66
svxViewLocationData::FirstPoint
svxPoint2 FirstPoint
the first point (ignore this if type is VX_LOCATION_AUTO )
Definition: zwapi_cmd_dwg_data.h:48
svxViewLocationData::SecondPoint
svxPoint2 SecondPoint
the second point (ignore this if type is not VX_LOCATION_CORNER )
Definition: zwapi_cmd_dwg_data.h:50
svxViewLocationData::type
evxViewLocationType type
drawing view location type
Definition: zwapi_cmd_dwg_data.h:47
svxViewSecLine::viewLabel
char * viewLabel
view label (example: "A" becomes "A-A") the label doesn't duplicate the existing label null or "" to ...
Definition: zwapi_cmd_dwg_data.h:338
svxViewSecLine::iShowStepLines
int iShowStepLines
show step lines or not (0 as default)
Definition: zwapi_cmd_dwg_data.h:342
svxViewSecLine::iFlipArrow
int iFlipArrow
flip arrow or not (0 as default)
Definition: zwapi_cmd_dwg_data.h:341
svxViewSecMtd::iDynScalAng
int iDynScalAng
dynamic hatch scaling and angle or not (1 as default)
Definition: zwapi_cmd_dwg_data.h:320
svxViewSecMtd::inheritSecBasView
int inheritSecBasView
inherit section from base view or not if base view is not section view, this value can be ignored if ...
Definition: zwapi_cmd_dwg_data.h:321
svxViewSecMtd::mtdType
evxSecMtdType mtdType
section method (VX_METHOD_TRIMPART as default)
Definition: zwapi_cmd_dwg_data.h:318
svxViewSecMtd::dimType
evxViewDimType dimType
dimension type (VX_VIEW_DIMTYPEPRJ as default)
Definition: zwapi_cmd_dwg_data.h:325
svxViewSecMtd::iCloseOpenProf
int iCloseOpenProf
close open profiles or not (1 as default)
Definition: zwapi_cmd_dwg_data.h:319
svxViewSecMtd::locType
evxLocType locType
location type (VX_LOC_ORTHOGONAL as default)
Definition: zwapi_cmd_dwg_data.h:324
svxViewSecOp::iSecState
int iSecState
component section state from part
Definition: zwapi_cmd_dwg_data.h:351
svxViewSecOp::iHatchClr
int iHatchClr
hatch color from part
Definition: zwapi_cmd_dwg_data.h:353
svxViewStandardData::isDispTrails
int isDispTrails
1 if display exploded trails ,else 0.default:0
Definition: zwapi_cmd_dwg_data.h:210
svxViewStandardData::origin
int origin
Origin ,default:1.
Definition: zwapi_cmd_dwg_data.h:205
svxViewStandardData::fileName
vxLongPath fileName
file name (including the extension)
Definition: zwapi_cmd_dwg_data.h:191
svxViewStandardData::state
int state
index for the backup feature, default:1
Definition: zwapi_cmd_dwg_data.h:211
svxViewStandardData::rootName
vxRootName rootName
root name
Definition: zwapi_cmd_dwg_data.h:192
svxViewStandardData::coordinate
int coordinate
coordinate,default:1
Definition: zwapi_cmd_dwg_data.h:206
svxViewStandardData::location
svxPoint2 location
location
Definition: zwapi_cmd_dwg_data.h:202
svxViewStandardData::explodedView
int explodedView
exploded view ,default:0
Definition: zwapi_cmd_dwg_data.h:209
svxViewStandardData::type
int type
1 is use view manager custom view name(this manager in part environment), 2 is use flattening feature...
Definition: zwapi_cmd_dwg_data.h:193
svxViewStandardData::dimensionType
int dimensionType
0 if projected, 1 if true. default:0.
Definition: zwapi_cmd_dwg_data.h:212
svxViewStandardData::viewAttr
svxViewAt viewAttr
view attribute
Definition: zwapi_cmd_dwg_data.h:204
svxViewStandardData::isOrientation
int isOrientation
1 if view orientation from parent, else 0. default:1
Definition: zwapi_cmd_dwg_data.h:214
svxViewStandardData::path
vxLongPath path
file path
Definition: zwapi_cmd_dwg_data.h:190
svxViewStandardData::partConfig
vxName partConfig
part config name ,PartConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:207
svxViewStandardData::isIgnoreAttr
int isIgnoreAttr
1 if ignore viewAttr and use default,else 0
Definition: zwapi_cmd_dwg_data.h:203
svxViewStandardData::isCalculate
int isCalculate
1 if calculate part center ,else 0. default:1
Definition: zwapi_cmd_dwg_data.h:213
svxViewStandardData
drawing view standard data
Definition: zwapi_cmd_dwg_data.h:189
svxViewStandardData::uvxViewTypeData::viewName
vxName viewName
view Name. if type = 1,apply it.
Definition: zwapi_cmd_dwg_data.h:198
svxViewStandardData::uvxViewTypeData::flatName
vxName flatName
flatten Name. if type = 2, apply it.
Definition: zwapi_cmd_dwg_data.h:199
svxViewStandardData::uvxViewTypeData::viewType
evxViewTypeEx viewType
View type(1-7,28-34,39). if type = 0,apply it.
Definition: zwapi_cmd_dwg_data.h:200
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\asmConsTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\asmConsTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
ApiDefVoidFunc(zwTestCompAddCoincidentCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddTangentCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddConcentricCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddParallelCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddPerpendicularCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddAngularCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddLockCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddDistanceCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddMiddleCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddSymmetryCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddFrameCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddGearCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddPathCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddLinearCoupleCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddRackPinionCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddScrewCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddSlotCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddCamCons, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestCompAddUniJointCons, VX_CODE_GENERAL);
void zwTestCompAddCoincidentCons()
/*
DESCRIPTION:
Test case for function cvxCompAddCoincidentCons.
*/
{
double val = 0;
cvxGetNumber("Contraint entities or points(0: entities; 1 : points)", &val);
svxEntPath ent1 = {}, ent2 = {};
svxPoint* pntOnEnt1 = NULL, * pntOnEnt2 = NULL;
svxPoint pnt1 = {}, pnt2 = {};
if (int(val + 0.5))
{
/* select two edges, curves, faces, datums, points or datum axises */
svxMatrix mat1 = {}, mat2 = {};
cvxGetExternalPick("Select the first point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt1, &ent1, &mat1);
cvxGetExternalPick("Select the second point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt2, &ent2, &mat2);
pntOnEnt1 = &pnt1;
pntOnEnt2 = &pnt2;
}
else
{
/* select two edges, curves, faces, datums, points or datum axises */
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
}
/* custom data */
svxConsData consData = {};
cvxGetNumber("specify offset distance", &consData.value);
cvxGetNumber("whether to apply range(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
consData.useRange = 1;
cvxGetNumber("specify minimum value for offset", &consData.range.min);
cvxGetNumber("specify maximum value for offset", &consData.range.max);
}
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddCoincidentCons(&ent1, pntOnEnt1, &ent2, pntOnEnt2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddCoincidentCons: failed to add constraint!");
}
void zwTestCompAddTangentCons()
/*
DESCRIPTION:
Test case for function cvxCompAddTangentCons.
*/
{
/* select two edges, curves, faces, datums, points or datum axises */
svxEntPath ent1 = {}, ent2 = {};
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
/* custom data */
svxConsData consData = {};
cvxGetNumber("specify offset distance", &consData.value);
double val = 0;
cvxGetNumber("whether to apply range(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
consData.useRange = 1;
cvxGetNumber("specify minimum value for offset", &consData.range.min);
cvxGetNumber("specify maximum value for offset", &consData.range.max);
}
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddTangentCons(&ent1, &ent2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddTangentCons: failed to add constraint!");
}
void zwTestCompAddConcentricCons()
/*
DESCRIPTION:
Test case for function cvxCompAddConcentricCons.
*/
{
double val = 0;
cvxGetNumber("Contraint entities or points(0: entities; 1 : points)", &val);
svxEntPath ent1 = {}, ent2 = {};
svxPoint* pntOnEnt1 = NULL, * pntOnEnt2 = NULL;
svxPoint pnt1 = {}, pnt2 = {};
if (int(val + 0.5))
{
/* select two edges, curves, faces, datums, points or datum axises */
svxMatrix mat1 = {}, mat2 = {};
cvxGetExternalPick("Select the first point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt1, &ent1, &mat1);
cvxGetExternalPick("Select the second point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt2, &ent2, &mat2);
pntOnEnt1 = &pnt1;
pntOnEnt2 = &pnt2;
}
else
{
/* select two edges, curves, faces, datums, points or datum axises */
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
}
/* custom data */
svxConsData consData = {};
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("whether to lock rotation: 0 or 1", &val);
if (int(val + 0.5))
consData.lockRotation = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddConcentricCons(&ent1, pntOnEnt1, &ent2, pntOnEnt2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddConcentricCons: failed to add constraint!");
}
void zwTestCompAddParallelCons()
/*
DESCRIPTION:
Test case for function cvxCompAddParallelCons.
*/
{
/* select two edges, curves, faces, datums, points or datum axises */
svxEntPath ent1 = {}, ent2 = {};
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddParallelCons(&ent1, &ent2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddParallelCons: failed to add constraint!");
}
void zwTestCompAddPerpendicularCons()
/*
DESCRIPTION:
Test case for function cvxCompAddPerpendicularCons.
*/
{
/* select two edges, curves, faces, datums, points or datum axises */
svxEntPath ent1 = {}, ent2 = {};
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddPerpendicularCons(&ent1, &ent2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddPerpendicularCons: failed to add constraint!");
}
void zwTestCompAddAngularCons()
/*
DESCRIPTION:
Test case for function cvxCompAddAngularCons.
*/
{
/* select two edges, curves, faces, datums, points or datum axises */
svxEntPath ent1 = {}, ent2 = {};
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
/* custom data */
svxConsData consData = {};
cvxGetNumber("specify angle", &consData.value);
double val = 0;
cvxGetNumber("whether to apply range(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
consData.useRange = 1;
cvxGetNumber("specify minimum value for angle", &consData.range.min);
cvxGetNumber("specify maximum value for angle", &consData.range.max);
}
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddAngularCons(&ent1, &ent2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddAngularCons: failed to add constraint!");
}
void zwTestCompAddLockCons()
/*
DESCRIPTION:
Test case for function cvxCompAddLockCons.
*/
{
/* select two components */
svxEntPath comp1 = {}, comp2 = {};
cvxGetEntPath("select the first component", VX_INP_COMP, 0, &comp1);
cvxGetEntPath("select the second component", VX_INP_COMP, 0, &comp2);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddLockCons(&comp1, &comp2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddLockCons: failed to add constraint!");
}
void zwTestCompAddDistanceCons()
/*
DESCRIPTION:
Test case for function cvxCompAddDistanceCons.
*/
{
double val = 0;
cvxGetNumber("Contraint entities or points(0: entities; 1 : points)", &val);
svxEntPath ent1 = {}, ent2 = {};
svxPoint* pntOnEnt1 = NULL, * pntOnEnt2 = NULL;
svxPoint pnt1 = {}, pnt2 = {};
if (int(val + 0.5))
{
/* select two edges, curves, faces, datums, points or datum axises */
svxMatrix mat1 = {}, mat2 = {};
cvxGetExternalPick("Select the first point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt1, &ent1, &mat1);
cvxGetExternalPick("Select the second point on geometric element of the constraint", VX_INP_PNT_ON_ANY_FACE, 0, &pnt2, &ent2, &mat2);
pntOnEnt1 = &pnt1;
pntOnEnt2 = &pnt2;
}
else
{
/* select two edges, curves, faces, datums, points or datum axises */
cvxGetEntPath("select the first geometric element of the constraint", VX_INP_FACE, 0, &ent1);
cvxGetEntPath("select the second geometric element of the constraint", VX_INP_FACE, 0, &ent2);
}
/* custom data */
svxConsData consData = {};
cvxGetNumber("specify offset", &consData.value);
cvxGetNumber("whether to apply range(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
consData.useRange = 1;
cvxGetNumber("specify minimum value for angle", &consData.range.min);
cvxGetNumber("specify maximum value for angle", &consData.range.max);
}
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddDistanceCons(&ent1, pntOnEnt1, &ent2, pntOnEnt2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddDistanceCons: failed to add constraint!");
}
void zwTestCompAddMiddleCons()
/*
DESCRIPTION:
Test case for function cvxCompAddMiddleCons.
*/
{
/* select two faces or datums */
evxEntInpOpt pOptBase[2] = { VX_INP_FACE, VX_INP_DATUM_PLANE };
int count = 0;
svxEntPath* basePaths = nullptr;
cvxGetEntPathsMultiFilter("select two base planes, <middle click> to finish", pOptBase, 2, 0, &count, &basePaths);
/* select 1 or 2 edge(s), curve(s), face(s) or datum(s) */
evxEntInpOpt pOptCenter[3] = { VX_INP_EDGE_OR_CURVE, VX_INP_FACE, VX_INP_DATUM_PLANE };
svxEntPath* centerPaths = nullptr;
cvxGetEntPathsMultiFilter("select two planes or a cylinder or an axis, <middle click> to finish", pOptCenter, 3, 0, &count, &centerPaths);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddMiddleCons(&basePaths[0], &basePaths[1], count, centerPaths, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddMiddleCons: failed to add constraint!");
/* free memory */
cvxMemFree((void**)&basePaths);
cvxMemFree((void**)&centerPaths);
}
void zwTestCompAddSymmetryCons()
/*
DESCRIPTION:
Test case for function cvxCompAddSymmetryCons.
*/
{
/* select a face or datum */
evxEntInpOpt pOpt[2] = { VX_INP_FACE, VX_INP_DATUM_PLANE };
int count = 0;
svxEntPath* pln = nullptr;
cvxGetEntPathsMultiFilter("select a mirror plane, <middle click> to finish", pOpt, 2, 0, &count, &pln);
/* select two edges, curves, faces, datums, points or datum axises */
svxEntPath* ents = nullptr;
cvxGetEntPaths("select two symmetric entities, <middle click> to finish", VX_INP_FACE, 0, &count, &ents);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("same facing or opposite(0: opposite; 1: same)", &val);
if (int(val + 0.5))
consData.sameDir = 1;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddSymmetryCons(&pln[0], &ents[0], &ents[1], &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddSymmetryCons: failed to add constraint!");
/* free memory */
cvxMemFree((void**)&pln);
cvxMemFree((void**)&ents);
}
void zwTestCompAddFrameCons()
/*
DESCRIPTION:
Test case for function cvxCompAddFrameCons.
*/
{
/* select two datum planes or datum CSYS */
evxEntInpOpt pOpt[2] = { VX_INP_DATUM_PLANE, VX_INP_CSYS };
int count = 0;
svxEntPath* datums = nullptr;
cvxGetEntPathsMultiFilter("select two datums", pOpt, 2, 0, &count, &datums);
/* custom data */
svxConsData consData = {};
double val = 0;
cvxGetNumber("use for position only(0: add constraint; 1: don't add constraint)", &val);
if (int(val + 0.5))
consData.posOnly = 1;
/* add constraint */
int idCons = 0;
if (cvxCompAddFrameCons(&datums[0], &datums[1], &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddFrameCons: failed to add constraint!");
/* free memory */
cvxMemFree((void**)&datums);
}
void zwTestCompAddGearCons()
/*
DESCRIPTION:
Test case for function cvxCompAddGearCons.
*/
{
svxEntPath gearPath[2] = {};
/* select two edges, curves, faces, datum plane, point */
cvxGetEntPath("Select the first gear", VX_INP_FACE, 0, &gearPath[0]);
cvxGetEntPath("Select the second gear", VX_INP_FACE, 0, &gearPath[1]);
/* custom data */
double val = 0;
svxGearConsData consData = {};
cvxGetNumber("Enter constraint angle", &consData.angle);
cvxGetNumber("Specify ratio type(0: ratio; 1: teeth)", &val);
consData.ratioType = (int(val + 0.5) > 0 ? 1 : 0);
if (consData.ratioType == 0)
{
cvxGetNumber("Enter ratio value", &consData.ratio);
}
else
{
cvxGetNumber("Enter the first teeth value", &consData.teeth[0]);
cvxGetNumber("Enter the second teeth value", &consData.teeth[1]);
}
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
/* add constraint */
int idCons = 0;
if (cvxCompAddGearCons(&gearPath[0], &gearPath[1], &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddGearCons: failed to add gear mechanical constraint!");
}
void zwTestCompAddPathCons()
/*
DESCRIPTION:
Test case for function cvxCompAddPathCons.
*/
{
svxPntOnEntPath pntOnEnt = {};
svxMatrix mat = {};
/* select two edges, curves, faces, datum plane, point */
zwUtilGetPntOnEntPath(VX_INP_FACE, VX_INP_PNT_ON_ANY_FACE, &pntOnEnt);
int nPaths = 0;
svxEntPath* paths = NULL;
cvxGetEntPaths("Select the second geometric element of the constraint", VX_INP_EDGE_OR_CURVE, 0, &nPaths, &paths);
/* custom data */
double val = 0;
svxPathConsData consData = {};
cvxGetNumber("Specify path constraint type(0: free; 1: distance; 2: percent)", &val);
consData.pathConsType = (evxPathConsType)(val + 0.5);
if (consData.pathConsType != VX_PATH_CONS_FREE)
{
if (consData.pathConsType == VX_PATH_CONS_DISTANCE) cvxGetNumber("Specify constraint point distance from end point of path)", &consData.distance);
if (consData.pathConsType == VX_PATH_CONS_PERCENT) cvxGetNumber("Specify constraint point distance percent from end point of path(0 ~ 100)", &consData.percent);
cvxGetNumber("Whether to flip calculate direction(0: no; 1: yes)", &val);
consData.flipDim = (int(val + 0.5) > 0 ? 1 : 0);
}
cvxGetNumber("Specify pitch/yaw type(0: free; 1: follow path)", &val);
consData.pitchYawType = (evxPitchYawType)(val + 0.5);
if (consData.pitchYawType != VX_PITCH_YAW_FREE)
{
cvxGetNumber("Specify axis tangent to path(0: X axis; 1: Y axis; 2: Z axis)", &val);
consData.axisToTangent = (evxAxisType)(val + 1);
cvxGetNumber("Whether to flip tangent direction(0: no; 1: yes)", &val);
consData.flipTangentDir = (int(val + 0.5) > 0 ? 1 : 0);
}
cvxGetNumber("Specify roll control type(0: free; 1: up vector)", &val);
consData.rollCtrlType = (evxRollCtrlType)(val + 0.5);
if (consData.rollCtrlType != VX_ROLL_CTRL_FREE)
{
cvxGetEntPath("Select a linear curve or edge to specify up vector", VX_INP_EDGE_OR_CURVE, 0, &consData.upVector);
cvxGetNumber("Specify axis to align to the up vector(0: X axis; 1: Y axis; 2: Z axis)", &val);
consData.axisToAlign = (evxAxisType)(val + 1);
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flipAlignDir = (int(val + 0.5) > 0 ? 1 : 0);
}
/* add constraint */
int idCons = 0;
if (cvxCompAddPathCons(&pntOnEnt, nPaths, paths, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddPathCons: failed to add path mechanical constraint!");
/* free memory */
cvxMemFree((void**)&paths);
}
void zwTestCompAddLinearCoupleCons()
/*
DESCRIPTION:
Test case for function cvxCompAddLinearCoupleCons.
*/
{
svxEntPath compPath[2] = {};
cvxGetEntPath("Select the first component", VX_INP_SUB_COMP, 0, &compPath[0]);
cvxGetEntPath("Select the second component", VX_INP_SUB_COMP, 0, &compPath[1]);
svxEntPath dirPath[2] = {};
cvxGetEntPath("Select linear entity to specify move direction of the first component", VX_INP_EDGE_OR_CURVE, 0, &dirPath[0]);
cvxGetEntPath("Select linear entity to specify move direction of the second component", VX_INP_EDGE_OR_CURVE, 0, &dirPath[1]);
/* custom data */
double val = 0;
svxLinearCpData consData = {};
cvxGetNumber("Specify ratio type(0: ratio; 1: distance)", &val);
consData.ratioType = (int(val + 0.5) > 0 ? 1 : 0);
if (consData.ratioType == 0)
{
cvxGetNumber("Enter ratio value", &consData.ratio);
}
else
{
cvxGetNumber("Enter the first distance value", &consData.distance[0]);
cvxGetNumber("Enter the second distance value", &consData.distance[1]);
}
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
/* add constraint */
int idCons = 0;
if (cvxCompAddLinearCoupleCons(&compPath[0], &dirPath[0], &compPath[1], &dirPath[1], &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddLinearCoupleCons: failed to add linear couple mechanical constraint!");
}
void zwTestCompAddRackPinionCons()
/*
DESCRIPTION:
Test case for function cvxCompAddRackPinionCons.
*/
{
svxEntPath rackPath = {};
cvxGetEntPath("Select the rack", VX_INP_FACE, 0, &rackPath);
svxEntPath pinionPath = {};
cvxGetEntPath("Select the pinionPath", VX_INP_FACE, 0, &pinionPath);
/* custom data */
double val = 0;
svxRackPinionData consData = {};
cvxGetNumber("Specify translate type(0: revolutions/distance; 1: distance/revolutions)", &val);
consData.transType = (int(val + 0.5) > 0 ? 1 : 0);
cvxGetNumber("Enter translate value(1.0 - default)", &consData.value);
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
/* add constraint */
int idCons = 0;
if (cvxCompAddRackPinionCons(&rackPath, &pinionPath, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddRackPinionCons: failed to add rack pinion mechanical constraint!");
}
void zwTestCompAddScrewCons()
/*
DESCRIPTION:
Test case for function cvxCompAddScrewCons.
*/
{
svxEntPath screwPath = {};
/* select two edges, curves, faces, datum plane, point */
cvxGetEntPath("Select the first gear", VX_INP_FACE, 0, &screwPath);
svxEntPath linearPath = {};
cvxGetEntPath("Select linear entity to specify move direction", VX_INP_EDGE_OR_CURVE, 0, &linearPath);
/* custom data */
double val = 0;
svxScrewConsData consData = {};
cvxGetNumber("Specify translate type(0: revolutions/distance; 1: distance/revolutions)", &val);
consData.transType = (int(val + 0.5) > 0 ? 1 : 0);
cvxGetNumber("Enter translate value(1.0 - default)", &consData.value);
cvxGetNumber("Whether to flip alignment direction (0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
cvxGetNumber("Specify alignment direction of face (0: Opposite; 1: same facing)", &val);
consData.faceDir = (int(val + 0.5) > 0 ? 1 : 0);
/* add constraint */
int idCons = 0;
if (cvxCompAddScrewCons(&screwPath, &linearPath, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddScrewCons: failed to add screw mechanical constraint!");
}
void zwTestCompAddSlotCons()
/*
DESCRIPTION:
Test case for function cvxCompAddSlotCons.
*/
{
svxEntPath moveEntPath = {};
/* select two edges, curves, faces, datum plane, point */
cvxGetEntPath("Select the first gear", VX_INP_FACE, 0, &moveEntPath);
int nSlots = 0;
svxEntPath* slots = NULL;
cvxGetEntPaths("Select the slots", VX_INP_FACE, 0, &nSlots, &slots);
/* custom data */
double val = 0;
svxSlotConsData consData = {};
cvxGetNumber("Specify constraint type(0: free; 1: center; 2: distance; 3: percent)", &val);
consData.slotConsType = (evxSlotConsType)(val + 0.5);
if (consData.slotConsType == VX_SLOT_CONS_DISTANCE) cvxGetNumber("Specify constraint point distance from end point of slot)", &consData.distance);
if (consData.slotConsType == VX_SLOT_CONS_PERCENT) cvxGetNumber("Specify constraint point distance percent from end point of slot(0 ~ 100)", &consData.percent);
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
/* add constraint */
int idCons = 0;
if (cvxCompAddSlotCons(&moveEntPath, nSlots, slots, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddSlotCons: failed to add slot mechanical constraint!");
/* free memory */
cvxMemFree((void**)&slots);
}
void zwTestCompAddCamCons()
/*
DESCRIPTION:
Test case for function cvxCompAddCamCons.
*/
{
svxEntPath moveEntPath = {};
/* select two edges, curves, faces, datum plane, point */
cvxGetEntPath("Select the first gear", VX_INP_FACE, 0, &moveEntPath);
int nCamFaces = 0;
svxEntPath* camFaces = NULL;
cvxGetEntPaths("Select the slots", VX_INP_FACE, 0, &nCamFaces, &camFaces);
/* add constraint */
int idCons = 0;
if (cvxCompAddCamCons(&moveEntPath, nCamFaces, camFaces, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddCamCons: failed to add cam mechanical constraint!");
/* free memory */
cvxMemFree((void**)&camFaces);
}
void zwTestCompAddUniJointCons()
/*
DESCRIPTION:
Test case for function cvxCompAddUniJointCons.
*/
{
/* custom data */
double val = 0;
svxUniJointData consData = {};
cvxGetNumber("Specify constraint type(0: constant velocity; 1: variable velocity)", &val);
consData.jointConsType = (int(val + 0.5) > 0 ? 1 : 0);
svxEntPath shaftPath[2] = {};
/* select two edge, curve, face, datum axis */
cvxGetEntPath("Select the first cross\\propeller shaft", VX_INP_EDGE_OR_CURVE, 0, &shaftPath[0]);
cvxGetEntPath("Select the second cross\\propeller shaft", VX_INP_EDGE_OR_CURVE, 0, &shaftPath[1]);
svxPntOnEntPath* hingePnt1 = NULL, * hingePnt2 = NULL;
svxMatrix mat = {};
svxPntOnEntPath hingePnt[2] = {};
if (!cvxGetExternalPick("Select the first hinge point", VX_INP_PNT_ON_ENTITY, consData.jointConsType == 1 ? 0 : 1, &hingePnt[0].pnt, &hingePnt[0].entPath, &mat))
{
hingePnt1 = &hingePnt[0];
cvxPntTransform(&mat, &hingePnt1->pnt);
}
if (!cvxGetExternalPick("Select the second hinge point", VX_INP_PNT_ON_ENTITY, consData.jointConsType == 1 ? 0 : 1, &hingePnt[1].pnt, &hingePnt[1].entPath, &mat))
{
hingePnt2 = &hingePnt[1];
cvxPntTransform(&mat, &hingePnt2->pnt);
}
if (consData.jointConsType == 0)
{
cvxGetNumber("Whether to flip alignment direction(0: no; 1: yes)", &val);
consData.flip = (int(val + 0.5) > 0 ? 1 : 0);
}
/* add constraint */
int idCons = 0;
if (cvxCompAddUniJointCons(&shaftPath[0], hingePnt1, &shaftPath[1], hingePnt2, &consData, &idCons) || idCons == 0)
zwTestLogErrorMsg(5, "cvxCompAddUniJointCons: failed to add universal joint mechanical constraint!");
}
evxRollCtrlType
evxRollCtrlType
roll control type
Definition: zwapi_cmd_assembly_data.h:269
VX_ROLL_CTRL_FREE
@ VX_ROLL_CTRL_FREE
the roll of component is not constrained
Definition: zwapi_cmd_assembly_data.h:270
evxSlotConsType
evxSlotConsType
slot constraint type
Definition: zwapi_cmd_assembly_data.h:335
VX_SLOT_CONS_PERCENT
@ VX_SLOT_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of slot
Definition: zwapi_cmd_assembly_data.h:339
VX_SLOT_CONS_DISTANCE
@ VX_SLOT_CONS_DISTANCE
constraint component to a specified distance from the end of slot
Definition: zwapi_cmd_assembly_data.h:338
evxPathConsType
evxPathConsType
path constraint type
Definition: zwapi_cmd_assembly_data.h:248
VX_PATH_CONS_DISTANCE
@ VX_PATH_CONS_DISTANCE
constraint component to a specified distance from the end of the path
Definition: zwapi_cmd_assembly_data.h:250
VX_PATH_CONS_PERCENT
@ VX_PATH_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of the path
Definition: zwapi_cmd_assembly_data.h:251
VX_PATH_CONS_FREE
@ VX_PATH_CONS_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:249
evxPitchYawType
evxPitchYawType
pitch/yaw type
Definition: zwapi_cmd_assembly_data.h:259
VX_PITCH_YAW_FREE
@ VX_PITCH_YAW_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:260
cvxCompAddLockCons
evxErrors cvxCompAddLockCons(svxEntPath *Comp1, svxEntPath *Comp2, svxConsData *ConsData, int *idCons)
cvxCompAddGearCons
evxErrors cvxCompAddGearCons(const svxEntPath *Gear1, const svxEntPath *Gear2, const svxGearConsData *ConsData, int *idCons)
cvxCompAddUniJointCons
evxErrors cvxCompAddUniJointCons(const svxEntPath *Shaft1, const svxPntOnEntPath *HingePnt1, const svxEntPath *Shaft2, const svxPntOnEntPath *HingePnt2, const svxUniJointData *ConsData, int *idCons)
cvxCompAddMiddleCons
evxErrors cvxCompAddMiddleCons(svxEntPath *BaseEnt1, svxEntPath *BaseEnt2, int nCenter, svxEntPath *CenterEnts, svxConsData *ConsData, int *idCons)
cvxCompAddConcentricCons
evxErrors cvxCompAddConcentricCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxCompAddTangentCons
evxErrors cvxCompAddTangentCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompAddLinearCoupleCons
evxErrors cvxCompAddLinearCoupleCons(const svxEntPath *Comp1, const svxEntPath *Dir1, const svxEntPath *Comp2, const svxEntPath *Dir2, const svxLinearCpData *ConsData, int *idCons)
cvxCompAddPathCons
evxErrors cvxCompAddPathCons(const svxPntOnEntPath *Pnt, int nPaths, const svxEntPath *Paths, const svxPathConsData *ConsData, int *idCons)
cvxCompAddFrameCons
evxErrors cvxCompAddFrameCons(svxEntPath *Datum1, svxEntPath *Datum2, svxConsData *ConsData, int *idCons)
cvxCompAddDistanceCons
evxErrors cvxCompAddDistanceCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxCompAddCoincidentCons
evxErrors cvxCompAddCoincidentCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxCompAddScrewCons
evxErrors cvxCompAddScrewCons(const svxEntPath *ScrewEnt, const svxEntPath *LinearEnt, const svxScrewConsData *ConsData, int *idCons)
cvxCompAddSymmetryCons
evxErrors cvxCompAddSymmetryCons(svxEntPath *Plane, svxEntPath *SymEnt1, svxEntPath *SymEnt2, svxConsData *ConsData, int *idCons)
cvxCompAddRackPinionCons
evxErrors cvxCompAddRackPinionCons(const svxEntPath *Rack, const svxEntPath *Pinion, const svxRackPinionData *ConsData, int *idCons)
cvxCompAddAngularCons
evxErrors cvxCompAddAngularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompAddPerpendicularCons
evxErrors cvxCompAddPerpendicularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompAddCamCons
evxErrors cvxCompAddCamCons(const svxEntPath *Ent, int nCamFaces, const svxEntPath *CamFaces, int *idCons)
cvxCompAddParallelCons
evxErrors cvxCompAddParallelCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompAddSlotCons
evxErrors cvxCompAddSlotCons(const svxEntPath *Ent, int nSlots, const svxEntPath *Slots, const svxSlotConsData *ConsData, int *idCons)
cvxPntTransform
void cvxPntTransform(svxMatrix *Mat, svxPoint *Point)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEntPaths
evxErrors cvxGetEntPaths(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths)
cvxGetEntPathsMultiFilter
evxErrors cvxGetEntPathsMultiFilter(const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, svxEntPath **Paths)
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
cvxGetExternalPick
evxErrors cvxGetExternalPick(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, svxEntPath *EntPath, svxMatrix *Matrix)
evxEntInpOpt
evxEntInpOpt
entity input options
Definition: zwapi_userinput.h:31
VX_INP_SUB_COMP
@ VX_INP_SUB_COMP
pick sub-component in pick-path, instead of the top-level component
Definition: zwapi_userinput.h:63
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CSYS
@ VX_INP_CSYS
pick CSYS
Definition: zwapi_userinput.h:64
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_COMP
@ VX_INP_COMP
select the top-level component
Definition: zwapi_userinput.h:60
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
svxConsData::range
svxLimit range
constraint range: offset distance or constraint angle
Definition: zwapi_cmd_assembly_data.h:224
svxConsData::sameDir
int sameDir
same direction (0-default)
Definition: zwapi_cmd_assembly_data.h:225
svxConsData::useRange
int useRange
whether to apply constraint range (0-default)
Definition: zwapi_cmd_assembly_data.h:222
svxConsData::posOnly
int posOnly
only move position without creating constraint (0-default)
Definition: zwapi_cmd_assembly_data.h:226
svxConsData::value
double value
exact value: offset distance or constraint angle (0.0-default)
Definition: zwapi_cmd_assembly_data.h:223
svxConsData::lockRotation
int lockRotation
whether to lock rotation (0-default)
Definition: zwapi_cmd_assembly_data.h:227
svxConsData
custom data for assembly common constraint
Definition: zwapi_cmd_assembly_data.h:221
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxGearConsData::ratio
double ratio
ratio value, used when type is ratio (1.0-default)
Definition: zwapi_cmd_assembly_data.h:238
svxGearConsData::ratioType
int ratioType
ratio type (0: ratio; 1: teeth; 0-default)
Definition: zwapi_cmd_assembly_data.h:237
svxGearConsData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:240
svxGearConsData::teeth
double teeth[2]
teeth, used when type is teeth (0.0-default)
Definition: zwapi_cmd_assembly_data.h:239
svxGearConsData::angle
double angle
constraint angle (0.0-default)
Definition: zwapi_cmd_assembly_data.h:236
svxGearConsData
custom data for assembly gear constraint
Definition: zwapi_cmd_assembly_data.h:235
svxLimit::max
double max
minimum
Definition: zwapi_util.h:457
svxLimit::min
double min
maximum
Definition: zwapi_util.h:456
svxLinearCpData::distance
double distance[2]
distance, used when type is distance (0.0-default)
Definition: zwapi_cmd_assembly_data.h:303
svxLinearCpData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:304
svxLinearCpData::ratio
double ratio
ratio value, used when type is ratio (1.0-default)
Definition: zwapi_cmd_assembly_data.h:302
svxLinearCpData::ratioType
int ratioType
ratio type (0: ratio; 1: distance; 0-default)
Definition: zwapi_cmd_assembly_data.h:301
svxLinearCpData
custom data for assembly linear couple constraint
Definition: zwapi_cmd_assembly_data.h:300
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPathConsData::axisToTangent
evxAxisType axisToTangent
specify axis tangent to path (VX_AXIS_X-default)
Definition: zwapi_cmd_assembly_data.h:286
svxPathConsData::flipTangentDir
int flipTangentDir
whether to flip the tangential direction (0-default)
Definition: zwapi_cmd_assembly_data.h:287
svxPathConsData::axisToAlign
evxAxisType axisToAlign
specify axis to align to the up vector (VX_AXIS_X-default)
Definition: zwapi_cmd_assembly_data.h:291
svxPathConsData::distance
double distance
distance from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:281
svxPathConsData::upVector
svxEntPath upVector
entity to specify up vector (edge, curve, face, datum plane, point)
Definition: zwapi_cmd_assembly_data.h:290
svxPathConsData::pathConsType
evxPathConsType pathConsType
path constraint type (VX_PATH_CONS_FREE-default)
Definition: zwapi_cmd_assembly_data.h:280
svxPathConsData::flipAlignDir
int flipAlignDir
whether to flip the alignment direction (0-default)
Definition: zwapi_cmd_assembly_data.h:292
svxPathConsData::percent
double percent
distance percent from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:282
svxPathConsData::flipDim
int flipDim
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:283
svxPathConsData::rollCtrlType
evxRollCtrlType rollCtrlType
roll control type (VX_ROLL_CTRL_FREE-default)
Definition: zwapi_cmd_assembly_data.h:289
svxPathConsData::pitchYawType
evxPitchYawType pitchYawType
pitch/yaw type (VX_PITCH_YAW_FREE-default)
Definition: zwapi_cmd_assembly_data.h:285
svxPathConsData
custom data for assembly path constraint
Definition: zwapi_cmd_assembly_data.h:279
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxRackPinionData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:315
svxRackPinionData::transType
int transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)
Definition: zwapi_cmd_assembly_data.h:313
svxRackPinionData::value
double value
translate value (1.0-default)
Definition: zwapi_cmd_assembly_data.h:314
svxRackPinionData
custom data for assembly rack and pinion constraint
Definition: zwapi_cmd_assembly_data.h:312
svxScrewConsData::faceDir
int faceDir
face direction (0: opposite; 1: same facing; 0-default)
Definition: zwapi_cmd_assembly_data.h:327
svxScrewConsData::value
double value
translate value (1.0-default)
Definition: zwapi_cmd_assembly_data.h:325
svxScrewConsData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:326
svxScrewConsData::transType
int transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)
Definition: zwapi_cmd_assembly_data.h:324
svxScrewConsData
custom data for assembly screw constraint
Definition: zwapi_cmd_assembly_data.h:323
svxSlotConsData::slotConsType
evxSlotConsType slotConsType
slot constraint type (VX_SLOT_CONS_FREE-default)
Definition: zwapi_cmd_assembly_data.h:348
svxSlotConsData::distance
double distance
distance from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:349
svxSlotConsData::flip
int flip
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:351
svxSlotConsData::percent
double percent
distance percent from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:350
svxSlotConsData
custom data for assembly slot constraint
Definition: zwapi_cmd_assembly_data.h:347
svxUniJointData::jointConsType
int jointConsType
universal joint constraint type (0: constant velocity; 1: variable velocity; 1-default)
Definition: zwapi_cmd_assembly_data.h:360
svxUniJointData::flip
int flip
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:361
svxUniJointData
custom data for assembly universal joint constraint
Definition: zwapi_cmd_assembly_data.h:359
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\baseFtrCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\baseFtrCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include "string.h"
#include "math.h"
#include "vector"
ApiDefVoidFunc(zwTestPartMove, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCopy, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPattern, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartMovePntToPnt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartMoveTransform, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartMoveTransformList, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCopyDirDis, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCopyPntToPnt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCopyTransform, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCopyTransformList, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartErase, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartMirror, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartScale, VX_CODE_GENERAL);
void zwTestPartMove()
/*
DESCRIPTION:
Test case for function cvxPartMove.
*/
{
/* initialize move */
static svxMoveData move;
cvxMemZero(&move, sizeof(svxMoveData));
move.method = VX_PNT_TO_PNT;
svxPntOnEnt pntOnEnt = { 0 };
svxPoint origin = { 0 };
svxMatrix mat = { 0 };
double val = 0.0;
cvxGetNumber("[Move Method]Enter number to select move method(0: form point to point; 1: along a direction; 2: by "
"aligning frames; 3: along path; 4: around a direction; 5: dynamic move)",
&val);
switch (int(val + 0.5))
{
case 1:
move.method = VX_ALONG_DIR;
zwUtilGetPntOrDirOnEnt(1, &move.MethodUnion.AlongDir.Dir);
move.MethodUnion.AlongDir.Dist = 50;
cvxGetNumber("[Angle]Enter rotation angle about move direction", &move.MethodUnion.AlongDir.Ang);
if (fabs(move.MethodUnion.AlongDir.Ang) < V_ZERO)
move.MethodUnion.AlongDir.UnuseAng = 1;
break;
case 2:
move.method = VX_ASLIGN_FRAMES;
cvxGetEnt("[From Frame]Select frame", VX_INP_REF_PLANE, 0, &move.MethodUnion.AlignFrame.idFrom);
cvxGetEnt("[To Frame]Select frame", VX_INP_REF_PLANE, 0, &move.MethodUnion.AlignFrame.idTo);
break;
case 3:
move.method = VX_SWEEP_ALONG_PATH;
zwUtilGetPntOrDirOnEnt(0, &move.MethodUnion.Sweep.Path);
move.MethodUnion.Sweep.cntPnts = 1;
zwUtilGetPntOrDirOnEnt(0, &pntOnEnt);
move.MethodUnion.Sweep.ToPnts = &pntOnEnt;
break;
case 4:
move.method = VX_AROUND_DIR;
zwUtilGetPntOrDirOnEnt(1, &move.MethodUnion.AroundDir.Dir);
cvxGetNumber("[Angle]Enter rotation angle about move direction", &move.MethodUnion.AroundDir.Ang);
break;
case 5:
move.method = VX_DYNAMIC_MOVE;
cvxGetPoint(
"[Position]Select point for frame origin", VX_INP_PNT_GENERAL, 0, &move.MethodUnion.DymMove.Pos, NULL);
cvxGetPoint(
"[Z Axis]Select move direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&move.MethodUnion.DymMove.ZAxis, NULL);
cvxMatPntVec(&origin, &move.MethodUnion.DymMove.ZAxis, &mat);
move.MethodUnion.DymMove.XAxis = { mat.xx, mat.xy, mat.xz };
move.MethodUnion.DymMove.YAxis = { mat.yx, mat.yy, mat.yz };
break;
default:
zwUtilGetPntOrDirOnEnt(0, &move.MethodUnion.PntToPnt.FromPnt);
zwUtilGetPntOrDirOnEnt(0, &move.MethodUnion.PntToPnt.ToPnt);
zwUtilGetPntOrDirOnEnt(1, &move.MethodUnion.PntToPnt.FromVector);
zwUtilGetPntOrDirOnEnt(1, &move.MethodUnion.PntToPnt.ToVector);
break;
}
cvxGetEnts("[Entity]Select entities to move, <middle-click> when done", VX_INP_MOVE, 0, &move.cntEnt, &move.pEnts);
/* move shapes */
int idMove = 0;
if (cvxPartMove(&move, &idMove) || idMove == 0)
zwTestLogErrorMsg(5, "cvxPartMove: failed to move shades!");
/* free memory */
cvxMemFree((void**)&move.pEnts);
}
void zwTestPartCopy()
/*
DESCRIPTION:
Test case for function cvxPartCopy.
*/
{
/* initialize copy */
svxCopyData copy;
if (cvxPartCopyInit(&copy))
zwTestLogErrorMsg(5, "cvxPartCopyInit: failed to initialize copy!");
copy.method = VX_PNT_TO_PNT;
svxPntOnEnt pntOnEnt = { 0 };
svxPoint origin = { 0 };
svxMatrix mat = { 0 };
double val = 0.0;
cvxGetNumber("[Copy Method]Enter number to select copy method(0: form point to point; 1: along a direction; 2: by "
"aligning frames; 3: along path; 4: around a direction; 5: dynamic copy)",
&val);
switch (int(val + 0.5))
{
case 1:
copy.method = VX_ALONG_DIR;
zwUtilGetPntOrDirOnEnt(1, &copy.MethodUnion.AlongDir.Dir);
copy.MethodUnion.AlongDir.Dist = 50;
cvxGetNumber("[Angle]Enter rotation angle about copy direction", &copy.MethodUnion.AlongDir.Ang);
if (fabs(copy.MethodUnion.AlongDir.Ang) < V_ZERO)
copy.MethodUnion.AlongDir.UnuseAng = 1;
break;
case 2:
copy.method = VX_ASLIGN_FRAMES;
cvxGetEnt("[From Frame]Select frame", VX_INP_REF_PLANE, 0, &copy.MethodUnion.AlignFrame.idFrom);
cvxGetEnt("[To Frame]Select frame", VX_INP_REF_PLANE, 0, &copy.MethodUnion.AlignFrame.idTo);
break;
case 3:
copy.method = VX_SWEEP_ALONG_PATH;
zwUtilGetPntOrDirOnEnt(0, &copy.MethodUnion.Sweep.Path);
copy.MethodUnion.Sweep.cntPnts = 1;
zwUtilGetPntOrDirOnEnt(0, &pntOnEnt);
copy.MethodUnion.Sweep.ToPnts = &pntOnEnt;
break;
case 4:
copy.method = VX_AROUND_DIR;
zwUtilGetPntOrDirOnEnt(1, &copy.MethodUnion.AroundDir.Dir);
cvxGetNumber("[Angle]Enter rotation angle about copy direction", &copy.MethodUnion.AroundDir.Ang);
break;
case 5:
copy.method = VX_DYNAMIC_MOVE;
cvxGetPoint(
"[Position]Select point for frame origin", VX_INP_PNT_GENERAL, 0, &copy.MethodUnion.DymCopy.Pos, NULL);
cvxGetPoint(
"[Z Axis]Select copy direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&copy.MethodUnion.DymCopy.ZAxis, NULL);
cvxMatPntVec(&origin, &copy.MethodUnion.DymCopy.ZAxis, &mat);
copy.MethodUnion.DymCopy.XAxis = { mat.xx, mat.xy, mat.xz };
copy.MethodUnion.DymCopy.YAxis = { mat.yx, mat.yy, mat.yz };
break;
default:
zwUtilGetPntOrDirOnEnt(0, &copy.MethodUnion.PntToPnt.FromPnt);
zwUtilGetPntOrDirOnEnt(0, &copy.MethodUnion.PntToPnt.ToPnt);
zwUtilGetPntOrDirOnEnt(1, &copy.MethodUnion.PntToPnt.FromVector);
zwUtilGetPntOrDirOnEnt(1, &copy.MethodUnion.PntToPnt.ToVector);
break;
}
if (copy.method == VX_ALONG_DIR || copy.method == VX_AROUND_DIR)
{
cvxGetNumber("[Copy Number]Enter number of copies", &val);
copy.CpyNum = ((int)(val + 0.5) < 0 ? 1 : (int)(val + 0.5));
}
cvxGetNumber("[Associative Copy]the default is enable, enter 1 to disable", &val);
copy.isNonAssoCopy = ((int)(val + 0.5) == 1 ? 1 : 0);
if (copy.isNonAssoCopy)
{
cvxGetString("[Assign to layer]Enter layer name", "Active layer", sizeof(copy.layName), copy.layName);
if (copy.layName[0] == '\0')
cvxLayerInqActive(copy.layName);
}
cvxGetEnts("[Entity]Select entities to copy, <middle-click> when done", VX_INP_MOVE, 0, &copy.cntEnt, &copy.pEnts);
/* copy shades */
int idCopy = 0;
if (cvxPartCopy(&copy, &idCopy) || idCopy == 0)
zwTestLogErrorMsg(5, "cvxPartCopy: failed to copy shapes!");
/* free memory */
cvxMemFree((void**)&copy.pEnts);
}
void zwTestPartPattern()
/*
DESCRIPTION:
Test case for function cvxPartPatternGeom and cvxPartPatternFtr.
*/
{
/* select pattern type */
double val = 0.0;
evxPatternType ptnType = VX_PATTERN_LINEAR;
cvxGetNumber("[Pattern Type]Enter number to select pattern type(0: linear; 1: circular; 2: point to point;"
" 3: pattern; 4: along curves; 5: surface; 6: polygon; 7: fill pattern; 8: variant parameters)",
&val);
switch (int(val + 0.5))
{
case 1: ptnType = VX_PATTERN_CIRCULAR; break;
case 2: ptnType = VX_PATTERN_PNT_TO_PNT; break;
case 3: ptnType = VX_PATTERN_AT_PATTERN; break;
case 4: ptnType = VX_PATTERN_AT_CURVES; break;
case 5: ptnType = VX_PATTERN_AT_FACE; break;
case 6: ptnType = VX_PATTERN_POLYGON; break;
case 7: ptnType = VX_PATTERN_FILL_PATTERN; break;
case 8: ptnType = VX_PATTERN_BY_VAR; break;
default: break;
}
/* initialize pattern */
svxPtnData ptn;
if (cvxPtnDataInit(ptnType, &ptn))
zwTestLogErrorMsg(5, "cvxPtnDataInit: failed to initialize point data!");
std::vector<int> vGeoms;
std::vector<int> vFtrs;
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("[Base]Select base entities, including geometry and feature, <middle-click> when done",
VX_INP_GENERAL_3D,
0,
&nEnts,
&idEnts);
for (int i = 0; i < nEnts; i++)
{
int klass = cvxEntClassNum(idEnts[i]);
if (klass == VX_ENT_FTR || klass == VX_ENT_SKETCH)
vFtrs.push_back(idEnts[i]);
else
vGeoms.push_back(idEnts[i]);
}
cvxMemFree((void**)&idEnts);
if (ptn.type == VX_PATTERN_BY_VAR && vFtrs.size() < 1) return;
int useSecond = 0, ptnNum[2] = { 0 };
if (ptn.type == VX_PATTERN_LINEAR)
{
ptn.ptnData.linear.num[0] = ptnNum[0] = 5;
ptn.ptnData.linear.spacing[0] = 30;
cvxGetPoint("[Direction]Specify the first direction",
VX_INP_PNT_DIRECTION,
0,
(svxPoint*)&ptn.ptnData.linear.dir[0],
NULL);
cvxGetNumber("[Second Directio]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.linear.useSecondDir = ((int)(val + 0.5) == 1 ? 1 : 0);
if (ptn.ptnData.linear.useSecondDir)
{
useSecond = 1;
ptn.ptnData.linear.num[1] = ptnNum[1] = 3;
ptn.ptnData.linear.spacing[1] = 50;
cvxGetPoint("[Direction]Specify the second direction",
VX_INP_PNT_DIRECTION,
0,
(svxPoint*)&ptn.ptnData.linear.dir[1],
NULL);
}
}
if (ptn.type == VX_PATTERN_CIRCULAR)
{
cvxGetPoint("[Location]Specify the location of axis",
VX_INP_PNT_GENERAL,
0,
(svxPoint*)&ptn.ptnData.circular.axis.Pnt,
NULL);
cvxGetPoint("[Direction]Specify the direction of axis",
VX_INP_PNT_DIRECTION,
0,
(svxPoint*)&ptn.ptnData.circular.axis.Dir,
NULL);
ptn.ptnData.circular.diameter = 100;
ptn.ptnData.circular.num[0] = ptnNum[0] = 5;
ptn.ptnData.circular.angle = 60;
cvxGetNumber("[Second Direction]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.circular.useSecondDir = ((int)(val + 0.5) == 1 ? 1 : 0);
if (ptn.ptnData.circular.useSecondDir)
{
useSecond = 1;
ptn.ptnData.circular.num[1] = ptnNum[1] = 3;
ptn.ptnData.circular.spacing = 50;
}
}
if (ptn.type == VX_PATTERN_POLYGON)
{
cvxGetPoint("[Location]Specify the location of axis",
VX_INP_PNT_GENERAL,
0,
(svxPoint*)&ptn.ptnData.polygon.axis.Pnt,
NULL);
cvxGetPoint("[Direction]Specify the direction of axis",
VX_INP_PNT_DIRECTION,
0,
(svxPoint*)&ptn.ptnData.polygon.axis.Dir,
NULL);
ptn.ptnData.polygon.numSides = 5;
cvxGetNumber("[Spacing Type]the default is number per side, enter 1 to use pitch between instances", &val);
ptn.ptnData.polygon.spacingType = ((int)(val + 0.5) == 1 ? 1 : 0);
ptn.ptnData.polygon.number = ptnNum[0] = 3;
ptn.ptnData.polygon.pitch = 50;
cvxGetNumber("[Second Direction]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.polygon.useSecondDir = ((int)(val + 0.5) ? 1 : 0);
if (ptn.ptnData.polygon.useSecondDir)
{
useSecond = 1;
ptn.ptnData.polygon.numConcentric = ptnNum[1] = 3;
ptn.ptnData.polygon.spacing = 50;
}
}
int idParEnt[3] = { 0 };
svxPoint ptnPoint[3] = { 0 };
if (ptn.type == VX_PATTERN_PNT_TO_PNT)
{
for (size_t i = 0; i < 3; i++)
cvxGetPoint("[To points]Specify the to points", VX_INP_PNT_GENERAL, 0, &ptnPoint[i], &idParEnt[i]);
ptn.ptnData.PntToPnt.numPnts = ptnNum[0] = 3;
ptn.ptnData.PntToPnt.idParPnt = idParEnt;
ptn.ptnData.PntToPnt.pnt = ptnPoint;
}
if (ptn.type == VX_PATTERN_AT_PATTERN)
{
cvxGetEnt("Pick a feature", VX_INP_FEATURE, 1, &ptn.ptnData.pattern.idPtnFtr);
}
if (ptn.type == VX_PATTERN_AT_CURVES)
{
cvxGetEnts("[Boundary]Select boundaries, <middle-click> when done",
VX_INP_EDGE_OR_CURVE,
0,
&ptn.ptnData.ptnCrv.numCrvs,
&ptn.ptnData.ptnCrv.idCrvs);
if (ptn.ptnData.ptnCrv.numCrvs < 1) return;
ptn.ptnData.ptnCrv.curveType = 2;
if (ptn.ptnData.ptnCrv.numCrvs == 1)
ptn.ptnData.ptnCrv.curveType = 0;
if (ptn.ptnData.ptnCrv.numCrvs > 2)
ptn.ptnData.ptnCrv.curveType = 3;
if (ptn.ptnData.ptnCrv.numCrvs == 2)
{
svxPoint pnt[4] = { 0 };
cvxEntEndPnt(ptn.ptnData.ptnCrv.idCrvs[0], &pnt[0], &pnt[1]);
cvxEntEndPnt(ptn.ptnData.ptnCrv.idCrvs[1], &pnt[2], &pnt[3]);
if (zwUtilIsEqualPnt(&pnt[0], &pnt[2], V_FZERO) || zwUtilIsEqualPnt(&pnt[0], &pnt[3], V_FZERO) ||
zwUtilIsEqualPnt(&pnt[1], &pnt[2], V_FZERO) || zwUtilIsEqualPnt(&pnt[1], &pnt[3], V_FZERO))
ptn.ptnData.ptnCrv.curveType = 1;
}
ptn.ptnData.ptnCrv.num[0] = ptnNum[0] = 5;
ptn.ptnData.ptnCrv.spacing[0] = 30;
cvxGetNumber("[Second Direction]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.ptnCrv.useSecondDir = ((int)(val + 0.5) ? 1 : 0);
if (ptn.ptnData.ptnCrv.useSecondDir)
{
useSecond = 1;
ptn.ptnData.ptnCrv.num[1] = ptnNum[1] = 3;
ptn.ptnData.ptnCrv.spacing[1] = 50;
}
}
if (ptn.type == VX_PATTERN_AT_FACE)
{
cvxGetEnt("Pick a face", VX_INP_FACE, 0, &ptn.ptnData.ptnFace.idFace);
ptn.ptnData.ptnFace.num[0] = ptnNum[0] = 5;
ptn.ptnData.ptnFace.spacing[0] = 30;
cvxGetNumber("[Second Direction]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.ptnFace.useSecondDir = ((int)(val + 0.5) ? 1 : 0);
if (ptn.ptnData.ptnFace.useSecondDir)
{
useSecond = 1;
ptn.ptnData.ptnFace.num[1] = ptnNum[1] = 3;
ptn.ptnData.ptnFace.spacing[1] = 50;
}
}
if (ptn.type == VX_PATTERN_FILL_PATTERN)
{
cvxGetEnt("Pick a sketch", VX_INP_SKETCH, 0, &ptn.ptnData.ptnFill.idSketch);
cvxGetNumber("[Fill Type]Enter number to select fill type(0: square; 1: diamond; 2: hexagon; 3: concentric; 4: "
"spiral; 5: along sketch curves)", &val);
ptn.ptnData.ptnFill.type = (int)(val + 0.5);
if (ptn.ptnData.ptnFill.type < 0 || ptn.ptnData.ptnFill.type > 5)
ptn.ptnData.ptnFill.type = 0;
ptn.ptnData.ptnFill.spacing = 50;
ptn.ptnData.ptnFill.angle = 30;
ptn.ptnData.ptnFill.border = -10;
ptn.ptnData.ptnFill.radius = 50.5;
}
if (ptn.type == VX_PATTERN_BY_VAR && vFtrs.size() > 0)
{
ptn.ptnData.ptnVar.num[0] = ptnNum[0] = 5;
cvxGetNumber("[Second Direction]Whether to use the second direction(1: yes; 0: no)", &val);
ptn.ptnData.ptnVar.useSecondDir = ((int)(val + 0.5) ? 1 : 0);
if (ptn.ptnData.ptnVar.useSecondDir)
{
useSecond = 1;
ptn.ptnData.ptnVar.num[1] = ptnNum[1] = 3;
}
}
/* set base point */
cvxGetNumber("[Base Point]Whether to use base point(1: yes; 0: no)", &val);
ptn.useBasePnt = ((int)(val + 0.5) ? 1 : 0);
if (ptn.useBasePnt)
cvxGetPoint("[Base Point]Select a base point", VX_INP_PNT_GENERAL, 1, &ptn.basePnt, &ptn.idParent);
cvxGetNumber("[Relocate Base Object]Whether to relocate base object(1: yes; 0: no)", &val);
ptn.relocateBase = ((int)(val + 0.5) ? 1 : 0);
/* set derived pattern */
cvxGetNumber("[Derive Type]Enter number to select derive type(0: none; 1: spacing; 2: number)", &val);
ptn.deriveType = (int)(val + 0.5);
if (ptn.deriveType < 0 || ptn.deriveType > 2)
ptn.deriveType = 0;
cvxGetNumber("[Minimum]Enter percent of spacing to maintain", &ptn.minPer);
/* set skipped instances */
std::vector<int> firstTogglePos;
std::vector<int> secondTogglePos;
if (ptn.type != VX_PATTERN_AT_PATTERN && ptn.type != VX_PATTERN_BY_VAR)
{
while (true)
{
cvxGetNumber("[Toggle]Enter serial number in the first direction of the instance to be skipped, enter -1 "
"when done",
&val);
if (val < 0) break;
firstTogglePos.push_back(int(val + 0.5));
if (useSecond)
{
cvxGetNumber("[Toggle]Enter serial number in the second direction of the instance to be skipped", &val);
if (val < 0) val = 0.0;
secondTogglePos.push_back(int(val + 0.5));
}
}
ptn.cntSkip = (int)firstTogglePos.size();
ptn.firstTogglePos = firstTogglePos.data();
if (useSecond)
ptn.secondTogglePos = secondTogglePos.data();
}
if (vGeoms.size() > 0 && ptnType != VX_PATTERN_BY_VAR)
{
svxPtnGeom ptnGeom = { 0 };
ptnGeom.inpData = &ptn;
cvxGetNumber("[Associative Copy]The default is enable, enter 1 to disable", &val);
ptnGeom.nonAssoCopy = ((int)(val + 0.5) ? 1 : 0);
/* create pattern */
int idPattern = 0;
if (cvxPartPatternGeom((int)vGeoms.size(), vGeoms.data(), &ptnGeom, &idPattern) || idPattern == 0)
zwTestLogErrorMsg(5, "cvxPartPatternGeom: failed to pattern shapes!");
}
if (vFtrs.size() > 0)
{
svxPtnFtr ptnFtr = { 0 };
ptnFtr.inpData = &ptn;
std::vector<svxPtnVarTbl> vVarTbl;
if (ptn.type != VX_PATTERN_PNT_TO_PNT && ptn.type != VX_PATTERN_AT_PATTERN && ptn.type != VX_PATTERN_FILL_PATTERN)
{
int nDims = 0, * idDims = NULL;
cvxPartInqDimIdxs(NULL, NULL, &nDims, &idDims);
cvxEntBlank(1, nDims, idDims);
cvxMemFree((void**)&idDims);
/* set variable pattern */
cvxGetNumber("[Increment]The default is use value, enter 1 to use increment", &val);
ptnFtr.inc = ((int)(val + 0.5) == 1 ? 1 : 0);
while (true)
{
int idDim = 0;
cvxGetEnt("[Dimension]Select a dimension to modify", VX_INP_GENERAL_3D, 1, &idDim);
if (idDim < 1)
break;
if (cvxEntClassNum(idDim) != VX_ENT_DIMEN)
continue;
svxPtnVarTbl varTbl = { 0 };
vxName dimName = {};
cvxEntName(idDim, dimName, sizeof(vxName));
if (!ptnFtr.inc) // set value
{
// get the values
if (cvxPtnVarTblInit(ptnNum[0], ptnNum[1], dimName, &varTbl))
zwTestLogErrorMsg(5, "cvxPtnVarTblInit: failed to initialize the table values !");
// set the specify cell value
while (true)
{
/* see the document how to set the idCell */
cvxGetNumber("[Cell]Enter index of cell, enter -1 when done", &val);
if (val < -V_ZERO)
break;
int idCell = (int)(val + 0.5);
cvxGetNumber("[Value]Enter value", &val);
for (int i = 0; i < varTbl.cntCell; i++)
{
if (idCell == varTbl.pCell[i])
{
varTbl.pVal[i] = val;
}
}
}
}
else
{
strcpy_s(varTbl.dimName, sizeof(vxName), dimName);
std::vector<int> vCells;
std::vector<double> vVars;
while (true)
{
/* see the document how to set the idCell */
cvxGetNumber("[Cell]Enter index of cell, enter -1 when done", &val);
if (val < -V_ZERO)
break;
int idCell = (int)(val + 0.5);
vCells.push_back(idCell);
cvxGetNumber("[Value]Enter value", &val);
vVars.push_back(val);
}
/* just set specify cell's value */
if (vCells.size() > 0)
{
varTbl.cntCell = (int)vCells.size();
cvxMemAlloc(varTbl.cntCell * sizeof(int), (void**)&varTbl.pCell);
memcpy_s(varTbl.pCell, varTbl.cntCell * sizeof(int), vCells.data(), varTbl.cntCell * sizeof(int));
cvxMemAlloc(varTbl.cntCell * sizeof(double), (void**)&varTbl.pVal);
memcpy_s(
varTbl.pVal, varTbl.cntCell * sizeof(double), vVars.data(), varTbl.cntCell * sizeof(double));
}
/* set all cells' value */
else
{
int cntVal = ptnNum[0] * (ptnNum[1] == 0 ? 1 : ptnNum[1]) - 1;
cvxMemAlloc(sizeof(double) * cntVal, (void**)&varTbl.pVal);
for (int i = 0; i < cntVal; i++)
{
svxVariable var = { 0 };
cvxDimInqVar(idDim, &var);
char prompt[256] = "\0";
sprintf_s(prompt, sizeof(prompt), "[Value]Enter value, the original value is %f", var.Value);
cvxGetNumber("[Value]Enter value", &varTbl.pVal[i]);
}
}
}
vVarTbl.push_back(varTbl);
}
ptnFtr.cntDim = (int)vVarTbl.size();
ptnFtr.pTableVal = vVarTbl.data();
}
/* create pattern */
int idPattern = 0;
if (cvxPartPatternFtr((int)vFtrs.size(), vFtrs.data(), &ptnFtr, &idPattern) || idPattern == 0)
zwTestLogErrorMsg(5, "cvxPartPatternFtr: failed to pattern features!");
for (auto varTbl : vVarTbl)
{
cvxMemFree((void**)&varTbl.pCell);
cvxMemFree((void**)&varTbl.pVal);
}
}
if (ptn.type == VX_PATTERN_AT_CURVES)
cvxMemFree((void**)&ptn.ptnData.ptnCrv.idCrvs);
}
void zwTestPartMovePntToPnt()
/*
DESCRIPTION:
Test case for function cvxPartMovePntToPnt.
*/
{
int idEnt = 0;
cvxGetEnt("Select a entity to move", VX_INP_GENERAL_3D, 0, &idEnt);
svxAxis axis[2] = { 0 };
for (int i = 0; i < 2; i++)
{
cvxGetPoint("[Location]Specify the location of axis", VX_INP_PNT_GENERAL, 0, (svxPoint*)&axis[i].Pnt, NULL);
cvxGetPoint("[Direction]Specify the direction of axis", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&axis[i].Dir, NULL);
}
/* move entity */
if (cvxPartMovePntToPnt(idEnt, &axis[0], &axis[1]))
zwTestLogErrorMsg(5, "cvxPartMovePntToPnt: failed to move entity!");
}
void zwTestPartMoveTransform()
/*
DESCRIPTION:
Test case for function cvxPartMoveTransform.
*/
{
svxMatrix mat = { 0 };
int idCsys = 0;
cvxGetEnt("Select a CSYS", VX_INP_CSYS, 0, &idCsys);
cvxEntMatrix(idCsys, &mat);
int idEnt = 0;
cvxGetEnt("Select a entity to move", VX_INP_GENERAL_3D, 0, &idEnt);
/* move entity */
if (cvxPartMoveTransform(idEnt, &mat))
zwTestLogErrorMsg(5, "cvxPartMoveTransform: failed to move entity!");
}
void zwTestPartMoveTransformList()
/*
DESCRIPTION:
Test case for function cvxPartMoveTransformList.
*/
{
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("Select entities to move, <middle-click> when done", VX_INP_GENERAL_3D, 0, &nEnts, &idEnts);
svxMatrix mat = { 0 };
int idCsys = 0;
cvxGetEnt("Select a CSYS", VX_INP_CSYS, 0, &idCsys);
cvxEntMatrix(idCsys, &mat);
/* move entity */
if (cvxPartMoveTransformList(nEnts, idEnts, &mat))
zwTestLogErrorMsg(5, "cvxPartMoveTransformList: failed to move entities!");
/* free memory */
cvxMemFree((void**)&idEnts);
}
void zwTestPartCopyDirDis()
/*
DESCRIPTION:
Test case for function cvxPartCopyDirDis.
*/
{
int idEnt = 0;
cvxGetEnt("Select a entity to copy", VX_INP_GENERAL_3D, 0, &idEnt);
svxVector dir = {};
cvxGetPoint("[Direction]Specify the direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&dir, NULL);
/* copy entity */
int idCpyEnt = 0;
if (cvxPartCopyDirDis(idEnt, &dir, 100, &idCpyEnt) || idCpyEnt < 1)
zwTestLogErrorMsg(5, "cvxPartCopyDirDis: failed to copy entity!");
}
void zwTestPartCopyPntToPnt()
/*
DESCRIPTION:
Test case for function cvxPartCopyPntToPnt.
*/
{
int idEnt = 0;
cvxGetEnt("Select a entity to copy", VX_INP_GENERAL_3D, 0, &idEnt);
svxAxis axis[2] = { 0 };
for (int i = 0; i < 2; i++)
{
cvxGetPoint("[Location]Specify the location of axis", VX_INP_PNT_GENERAL, 0, (svxPoint*)&axis[i].Pnt, NULL);
cvxGetPoint("[Direction]Specify the direction of axis", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&axis[i].Dir, NULL);
}
/* copy entity */
int idCpyEnt = 0;
if (cvxPartCopyPntToPnt(idEnt, &axis[0], &axis[1], &idCpyEnt) || idCpyEnt < 1)
zwTestLogErrorMsg(5, "cvxPartCopyPntToPnt: failed to copy entity!");
}
void zwTestPartCopyTransform()
/*
DESCRIPTION:
Test case for function cvxPartCopyTransform.
*/
{
svxMatrix mat = { 0 };
int idCsys = 0;
cvxGetEnt("Select a CSYS", VX_INP_CSYS, 0, &idCsys);
cvxEntMatrix(idCsys, &mat);
int idEnt = 0;
cvxGetEnt("Select a entity to copy", VX_INP_GENERAL_3D, 0, &idEnt);
/* copy entity */
int idCpyEnt = 0;
if (cvxPartCopyTransform(idEnt, &mat, &idCpyEnt) || idCpyEnt < 1)
zwTestLogErrorMsg(5, "cvxPartCopyTransform: failed to copy entity!");
}
void zwTestPartCopyTransformList()
/*
DESCRIPTION:
Test case for function cvxPartCopyTransformList.
*/
{
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("Select entities to copy, <middle-click> when done", VX_INP_GENERAL_3D, 0, &nEnts, &idEnts);
svxMatrix mat = { 0 };
int idCsys = 0;
cvxGetEnt("Select a CSYS", VX_INP_CSYS, 0, &idCsys);
cvxEntMatrix(idCsys, &mat);
/* copy entity */
int nCypEnts = 0, * idCypEnts = NULL;
if (cvxPartCopyTransformList(nEnts, idEnts, &mat, &nCypEnts, &idCypEnts) || nCypEnts < 1 || !idCypEnts)
zwTestLogErrorMsg(5, "cvxPartCopyTransformList: failed to copy entities!");
/* free memory */
cvxMemFree((void**)&idEnts);
cvxMemFree((void**)&idCypEnts);
}
void zwTestPartErase()
/*
DESCRIPTION:
Test case for function cvxPartErase.
*/
{
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("Select entities to erase, <middle-click> when done", VX_INP_GENERAL_3D, 0, &nEnts, &idEnts);
/* erase entities */
if (cvxPartErase(nEnts, idEnts))
zwTestLogErrorMsg(5, "cvxPartErase: failed to erase entities!");
/* free memory */
cvxMemFree((void**)&idEnts);
}
void zwTestPartMirror()
/*
DESCRIPTION:
Test case for function cvxPartMirrorGeom and cvxPartMirrorFtr.
*/
{
/* select mirror entities */
std::vector<int> vGeoms;
std::vector<int> vFtrs;
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("[Base]Select base entities, including geometry and feature, <middle-click> when done",
VX_INP_GENERAL_3D,
0,
&nEnts,
&idEnts);
for (int i = 0; i < nEnts; i++)
{
int klass = cvxEntClassNum(idEnts[i]);
if (klass == VX_ENT_FTR || klass == VX_ENT_SKETCH)
vFtrs.push_back(idEnts[i]);
else
vGeoms.push_back(idEnts[i]);
}
cvxMemFree((void**)&idEnts);
/* set mirror plane and boolean type */
int idPlane = 0;
cvxGetEnt("[Plane]Select mirror plane", VX_INP_REF_PLANE, 0, &idPlane);
double val = 0.0;
evxBoolType boolType = VX_BOOL_NONE;
cvxGetNumber("[Bool Type]Enter number to select boolean type(0: base; 1: add; 2: remove; 3: intersect)", &val);
switch (int(val + 0.5))
{
case 1: boolType = VX_BOOL_ADD; break;
case 2: boolType = VX_BOOL_REMOVE; break;
case 3: boolType = VX_BOOL_INTERSECT; break;
default: break;
}
/* set boolean shapes */
int nBoolShps = 0, * idBoolShps = NULL;
cvxGetEnts(
"[Boolean Shapes]Select shapes to boolean, <middle-click> when done", VX_INP_SHAPE, 1, &nBoolShps, &idBoolShps);
cvxGetNumber("[Keep]Whether to keep the original entities(1: yes; 0: no)", &val);
int keep = ((int)(val + 0.5) ? 1 : 0);
if (vGeoms.size() > 0)
{
/* initialize mirror geometry */
svxMirrorGeom mirrorGeom;
if (cvxPartMirrorGeominit(&mirrorGeom))
zwTestLogErrorMsg(5, "cvxPartMirrorGeominit: failed to initialize mirror geometry!");
/* set mirror base geometry */
mirrorGeom.numEnts = (int)vGeoms.size();
mirrorGeom.idEnts = vGeoms.data();
mirrorGeom.idPlane = idPlane;
mirrorGeom.combine = boolType;
mirrorGeom.numShapes = nBoolShps;
mirrorGeom.idShapes = idBoolShps;
mirrorGeom.keep = keep;
cvxGetNumber("[Associative Copy]Whether to keep associated with the original entities(1: yes; 0: no)", &val);
mirrorGeom.assoCopy = ((int)(val + 0.5) ? 1 : 0);
/* mirror geometries */
int nMirrorEnts = 0, * idMirrorEnts = NULL;
if (cvxPartMirrorGeom(&mirrorGeom, &nMirrorEnts, &idMirrorEnts))
zwTestLogErrorMsg(5, "cvxPartMirrorGeom: failed to mirror geometries!");
/* free memory */
cvxMemFree((void**)&idMirrorEnts);
}
if (vFtrs.size() > 0)
{
/* initialize mirror feature */
svxMirrorFtr mirrorFtr;
if (cvxPartMirrorFtrInit(&mirrorFtr))
zwTestLogErrorMsg(5, "cvxPartMirrorFtrInit: failed to initialize mirror features!");
/* set mirror base feature */
mirrorFtr.numFtrs = (int)vFtrs.size();
mirrorFtr.idFtrs = vFtrs.data();
mirrorFtr.idPlane = idPlane;
mirrorFtr.combine = boolType;
mirrorFtr.numShapes = nBoolShps;
mirrorFtr.idShapes = idBoolShps;
mirrorFtr.keep = keep;
/* mirror features */
int idFtr = 0;
if (cvxPartMirrorFtr(&mirrorFtr, &idFtr) || idFtr < 1)
zwTestLogErrorMsg(5, "cvxPartMirrorFtr: failed to mirror features!");
}
/* free memory */
cvxMemFree((void**)&idBoolShps);
}
void zwTestPartScale()
/*
DESCRIPTION:
Test case for function cvxPartScale2.
*/
{
/* set scale factor */
double xScale = 0.0, yScale = 0.0, zScale = 0.0;
cvxGetNumber("Enter X scale factor", &xScale);
cvxGetNumber("Enter Y scale factor", &yScale);
cvxGetNumber("Enter Z scale factor", &zScale);
/* set reference plane */
int idPlane = 0;
cvxGetEnt("Select reference plane, <middle-click> to skip", VX_INP_REF_PLANE, 1, &idPlane);
/* set center of scaling */
svxPoint ctrPnt = {};
cvxGetPoint("Select center of scaling, <middle-click> to skip", VX_INP_PNT_GENERAL, 1, &ctrPnt, NULL);
/* select entities to scale */
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("[Entity]Select entities to scale, <middle-click> when done", VX_INP_GENERAL_3D, 0, &nEnts, &idEnts);
/* scale entities */
if (cvxPartScale2(nEnts, idEnts, xScale, yScale, zScale, idPlane, &ctrPnt))
zwTestLogErrorMsg(5, "cvxPartScale2: failed to scale entity!");
/* free memory */
cvxMemFree((void**)&idEnts);
}
VX_DYNAMIC_MOVE
@ VX_DYNAMIC_MOVE
dynamic copy/move entities
Definition: zwapi_cmd_shape_data.h:1492
VX_SWEEP_ALONG_PATH
@ VX_SWEEP_ALONG_PATH
copy/move entities along path
Definition: zwapi_cmd_shape_data.h:1490
VX_ASLIGN_FRAMES
@ VX_ASLIGN_FRAMES
copy/move entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1489
VX_PNT_TO_PNT
@ VX_PNT_TO_PNT
copy/move entities form point to point
Definition: zwapi_cmd_shape_data.h:1487
VX_AROUND_DIR
@ VX_AROUND_DIR
rotate entities around a direction
Definition: zwapi_cmd_shape_data.h:1491
VX_ALONG_DIR
@ VX_ALONG_DIR
copy/move entities along a direction
Definition: zwapi_cmd_shape_data.h:1488
evxPatternType
evxPatternType
pattern method
Definition: zwapi_cmd_shape_data.h:1276
VX_PATTERN_PNT_TO_PNT
@ VX_PATTERN_PNT_TO_PNT
irregular pattern of objects from point to point
Definition: zwapi_cmd_shape_data.h:1279
VX_PATTERN_CIRCULAR
@ VX_PATTERN_CIRCULAR
circular pattern
Definition: zwapi_cmd_shape_data.h:1278
VX_PATTERN_POLYGON
@ VX_PATTERN_POLYGON
polygon pattern
Definition: zwapi_cmd_shape_data.h:1283
VX_PATTERN_FILL_PATTERN
@ VX_PATTERN_FILL_PATTERN
fill pattern
Definition: zwapi_cmd_shape_data.h:1284
VX_PATTERN_AT_FACE
@ VX_PATTERN_AT_FACE
pattern in space using an existing surface
Definition: zwapi_cmd_shape_data.h:1282
VX_PATTERN_AT_PATTERN
@ VX_PATTERN_AT_PATTERN
pattern of objects at locations defined by a previous pattern
Definition: zwapi_cmd_shape_data.h:1280
VX_PATTERN_AT_CURVES
@ VX_PATTERN_AT_CURVES
pattern in space using one or more input curves
Definition: zwapi_cmd_shape_data.h:1281
VX_PATTERN_LINEAR
@ VX_PATTERN_LINEAR
linear pattern
Definition: zwapi_cmd_shape_data.h:1277
VX_PATTERN_BY_VAR
@ VX_PATTERN_BY_VAR
feature pattern by variant parameters(just use pattern feature command)
Definition: zwapi_cmd_shape_data.h:1285
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
VX_BOOL_REMOVE
@ VX_BOOL_REMOVE
remove
Definition: zwapi_cmd_shape_data.h:37
VX_BOOL_INTERSECT
@ VX_BOOL_INTERSECT
intersect
Definition: zwapi_cmd_shape_data.h:38
VX_BOOL_ADD
@ VX_BOOL_ADD
add
Definition: zwapi_cmd_shape_data.h:36
VX_BOOL_NONE
@ VX_BOOL_NONE
base
Definition: zwapi_cmd_shape_data.h:35
cvxPartPatternGeom
evxErrors cvxPartPatternGeom(int Count, int *idEnts, const svxPtnGeom *Pattern, int *idPattern)
cvxPartCopy
evxErrors cvxPartCopy(const svxCopyData *Copy, int *idCopy)
cvxPartMoveTransform
evxErrors cvxPartMoveTransform(int idEntity, const svxMatrix *Mat)
cvxPartCopyInit
evxErrors cvxPartCopyInit(svxCopyData *data)
cvxPartMoveTransformList
evxErrors cvxPartMoveTransformList(int Count, const int *Entities, const svxMatrix *Mat)
cvxPartPatternFtr
evxErrors cvxPartPatternFtr(int Count, int *idFtrs, const svxPtnFtr *Pattern, int *idPattern)
cvxPartMovePntToPnt
evxErrors cvxPartMovePntToPnt(int idEntity, svxAxis *Start, svxAxis *End)
cvxPartCopyTransform
evxErrors cvxPartCopyTransform(int idEntity, const svxMatrix *Mat, int *idCopy)
cvxPartMirrorGeominit
evxErrors cvxPartMirrorGeominit(svxMirrorGeom *data)
cvxPartMirrorGeom
evxErrors cvxPartMirrorGeom(svxMirrorGeom *Mirror, int *NumNewEnts, int **idNewEnts)
cvxPartCopyPntToPnt
evxErrors cvxPartCopyPntToPnt(int idEntity, svxAxis *Start, svxAxis *End, int *idCopy)
cvxPartCopyTransformList
evxErrors cvxPartCopyTransformList(const int Count, const int *Entities, const svxMatrix *Mat, int *EntCnt, int **idList)
cvxPartMirrorFtrInit
evxErrors cvxPartMirrorFtrInit(svxMirrorFtr *data)
cvxPtnDataInit
evxErrors cvxPtnDataInit(evxPatternType type, svxPtnData *data)
cvxPartScale2
evxErrors cvxPartScale2(int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum, svxPoint *CentPnt)
cvxPtnVarTblInit
evxErrors cvxPtnVarTblInit(int firstNum, int secondNum, const char *dimName, svxPtnVarTbl *ptnVarTbl)
cvxPartCopyDirDis
evxErrors cvxPartCopyDirDis(int idEntity, svxVector *Dir, double Dis, int *idCopy)
cvxPartMove
evxErrors cvxPartMove(const svxMoveData *Move, int *idMove)
cvxPartMirrorFtr
evxErrors cvxPartMirrorFtr(svxMirrorFtr *Mirror, int *idFtr)
cvxDimInqVar
evxErrors cvxDimInqVar(int idDim, svxVariable *Var)
cvxEntEndPnt
evxErrors cvxEntEndPnt(int idEntity, svxPoint *Start, svxPoint *End)
cvxEntBlank
evxErrors cvxEntBlank(int Show, int Count, int *idEnts)
cvxEntMatrix
evxErrors cvxEntMatrix(int idEntity, svxMatrix *Matrix)
cvxEntName
evxErrors cvxEntName(int idEntity, char *Name, int nBytes)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxLayerInqActive
void cvxLayerInqActive(vxName Name)
cvxMatPntVec
void cvxMatPntVec(svxPoint *Origin, svxVector *zAxis, svxMatrix *Mat)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxPartInqDimIdxs
evxErrors cvxPartInqDimIdxs(const vxLongPath File, const vxRootName Part, int *Count, int **IdList)
cvxPartErase
evxErrors cvxPartErase(int Count, int *idEnts)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CSYS
@ VX_INP_CSYS
pick CSYS
Definition: zwapi_userinput.h:64
VX_INP_MOVE
@ VX_INP_MOVE
pick move
Definition: zwapi_userinput.h:53
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
VX_INP_FEATURE
@ VX_INP_FEATURE
pick feature
Definition: zwapi_userinput.h:44
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
cvxGetString
int cvxGetString(const char *Prompt, const char *Default, int NumBytes, char *String)
VX_ENT_SKETCH
@ VX_ENT_SKETCH
sketch
Definition: zwapi_util.h:937
VX_ENT_FTR
@ VX_ENT_FTR
feature operation
Definition: zwapi_util.h:926
VX_ENT_DIMEN
@ VX_ENT_DIMEN
dimension
Definition: zwapi_util.h:940
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAlignFrame::idFrom
int idFrom
from frame
Definition: zwapi_cmd_shape_data.h:1549
svxAlignFrame::idTo
int idTo
to frames
Definition: zwapi_cmd_shape_data.h:1550
svxAlongDir::Dist
double Dist
distance value
Definition: zwapi_cmd_shape_data.h:1528
svxAlongDir::UnuseAng
int UnuseAng
angle enable (default 0)
Definition: zwapi_cmd_shape_data.h:1529
svxAlongDir::Ang
double Ang
angle value
Definition: zwapi_cmd_shape_data.h:1530
svxAlongDir::Dir
svxPntOnEnt Dir
direction
Definition: zwapi_cmd_shape_data.h:1527
svxAlongPath::ToPnts
svxPntOnEnt * ToPnts
to points
Definition: zwapi_cmd_shape_data.h:1561
svxAlongPath::Path
svxPntOnEnt Path
path
Definition: zwapi_cmd_shape_data.h:1559
svxAlongPath::cntPnts
int cntPnts
count of points
Definition: zwapi_cmd_shape_data.h:1560
svxAroundDir::Ang
double Ang
angle value
Definition: zwapi_cmd_shape_data.h:1540
svxAroundDir::Dir
svxPntOnEnt Dir
direction
Definition: zwapi_cmd_shape_data.h:1539
svxAxis::Dir
svxVector Dir
direction
Definition: zwapi_util.h:351
svxAxis::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:350
svxAxis
3D axis
Definition: zwapi_util.h:349
svxCopyData::layName
vxName layName
layer to copy if isNonAssoCopy is 1
Definition: zwapi_cmd_shape_data.h:1615
svxCopyData::CpyNum
int CpyNum
copy number (just method = VX_ALONG_DIR or VX_AROUND_DIR, and must initialize to 1)
Definition: zwapi_cmd_shape_data.h:1611
svxCopyData::pEnts
int * pEnts
entities ID
Definition: zwapi_cmd_shape_data.h:1601
svxCopyData::cntEnt
int cntEnt
entity count
Definition: zwapi_cmd_shape_data.h:1600
svxCopyData::isNonAssoCopy
int isNonAssoCopy
0-associative copy, 1-non associative copy(default 0) if set to 0, the duplicate will be associative ...
Definition: zwapi_cmd_shape_data.h:1612
svxCopyData::method
evxMoveType method
copy methods
Definition: zwapi_cmd_shape_data.h:1599
svxCopyData
template command Copy data
Definition: zwapi_cmd_shape_data.h:1598
svxDymMove::YAxis
svxVector YAxis
Y Axis.
Definition: zwapi_cmd_shape_data.h:1504
svxDymMove::XAxis
svxVector XAxis
X Axis.
Definition: zwapi_cmd_shape_data.h:1503
svxDymMove::ZAxis
svxVector ZAxis
Z Axis.
Definition: zwapi_cmd_shape_data.h:1505
svxDymMove::Pos
svxPoint Pos
Position.
Definition: zwapi_cmd_shape_data.h:1502
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxMirrorFtr::idPlane
int idPlane
id of mirror plane (datum plane, planar face or sketch)
Definition: zwapi_cmd_shape_data.h:1471
svxMirrorFtr::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:1473
svxMirrorFtr::idShapes
int * idShapes
list of id's of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1475
svxMirrorFtr::numShapes
int numShapes
number of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1474
svxMirrorFtr::numFtrs
int numFtrs
number of features to mirror
Definition: zwapi_cmd_shape_data.h:1469
svxMirrorFtr::idFtrs
int * idFtrs
list of features ids
Definition: zwapi_cmd_shape_data.h:1470
svxMirrorFtr::keep
int keep
whether to keep the original features (0 = no keep, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1477
svxMirrorFtr
mirror feature data
Definition: zwapi_cmd_shape_data.h:1468
svxMirrorGeom::idPlane
int idPlane
id of mirror plane (datum plane, planar face or sketch)
Definition: zwapi_cmd_shape_data.h:1451
svxMirrorGeom::assoCopy
int assoCopy
whether to keep associated with the original entities (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1458
svxMirrorGeom::numShapes
int numShapes
number of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1454
svxMirrorGeom::numEnts
int numEnts
number of entities to mirror
Definition: zwapi_cmd_shape_data.h:1449
svxMirrorGeom::keep
int keep
whether to keep the original entities (0 = no keep, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1457
svxMirrorGeom::idShapes
int * idShapes
list of id's of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1455
svxMirrorGeom::idEnts
int * idEnts
list of geometry entity ids
Definition: zwapi_cmd_shape_data.h:1450
svxMirrorGeom::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:1453
svxMirrorGeom
mirror geometry data
Definition: zwapi_cmd_shape_data.h:1448
svxMoveData::method
evxMoveType method
move methods
Definition: zwapi_cmd_shape_data.h:1579
svxMoveData::pEnts
int * pEnts
entities ID
Definition: zwapi_cmd_shape_data.h:1581
svxMoveData::cntEnt
int cntEnt
entity count
Definition: zwapi_cmd_shape_data.h:1580
svxMoveData
template command Move data
Definition: zwapi_cmd_shape_data.h:1578
svxMovePntToPnt::ToVector
svxPntOnEnt ToVector
to vector
Definition: zwapi_cmd_shape_data.h:1518
svxMovePntToPnt::FromVector
svxPntOnEnt FromVector
from vector
Definition: zwapi_cmd_shape_data.h:1517
svxMovePntToPnt::ToPnt
svxPntOnEnt ToPnt
to point
Definition: zwapi_cmd_shape_data.h:1515
svxMovePntToPnt::FromPnt
svxPntOnEnt FromPnt
from point
Definition: zwapi_cmd_shape_data.h:1514
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxPtnData::PtnData::svxCircular::spacing
double spacing
pattern spacing in second direction, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1313
svxPtnData::PtnData::svxCircular::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1311
svxPtnData::PtnData::svxCircular::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1310
svxPtnData::PtnData::svxCircular::angle
double angle
spacing between the instances measured in degrees
Definition: zwapi_cmd_shape_data.h:1312
svxPtnData::PtnData::svxCircular::diameter
double diameter
rotation diameter for the pattern
Definition: zwapi_cmd_shape_data.h:1309
svxPtnData::PtnData::svxCircular::axis
svxAxis axis
rotation axis for the pattern
Definition: zwapi_cmd_shape_data.h:1308
svxPtnData::PtnData::svxLinear::dir
svxVector dir[2]
first and second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1302
svxPtnData::PtnData::svxLinear::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1303
svxPtnData::PtnData::svxLinear::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1301
svxPtnData::PtnData::svxLinear::spacing
double spacing[2]
pattern spacing in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1304
svxPtnData::PtnData::svxPattern::idPtnFtr
int idPtnFtr
id of pattern feature
Definition: zwapi_cmd_shape_data.h:1336
svxPtnData::PtnData::svxPntFill::spacing
double spacing
pattern spacing
Definition: zwapi_cmd_shape_data.h:1359
svxPtnData::PtnData::svxPntFill::angle
double angle
rotation angle, the value is ignored when type = 5
Definition: zwapi_cmd_shape_data.h:1360
svxPtnData::PtnData::svxPntFill::radius
double radius
rotation radius, used only when type is 3 or 4
Definition: zwapi_cmd_shape_data.h:1362
svxPtnData::PtnData::svxPntFill::border
double border
border, the value is ignored when type = 5
Definition: zwapi_cmd_shape_data.h:1361
svxPtnData::PtnData::svxPntFill::idSketch
int idSketch
id of sketch
Definition: zwapi_cmd_shape_data.h:1358
svxPtnData::PtnData::svxPntFill::type
int type
type (0 = square, 1 = diamond, 2 = hexagon, 3 = concentric, 4 = spiral, 5 = along sketch curves)
Definition: zwapi_cmd_shape_data.h:1357
svxPtnData::PtnData::svxPntToPnt::pnt
svxPoint * pnt
list of point coordinates
Definition: zwapi_cmd_shape_data.h:1332
svxPtnData::PtnData::svxPntToPnt::idParPnt
int * idParPnt
list of id's of the parent of point, set id to 0 when no parent object exists
Definition: zwapi_cmd_shape_data.h:1331
svxPtnData::PtnData::svxPntToPnt::numPnts
int numPnts
number of point, parent and point value should be set in pairs
Definition: zwapi_cmd_shape_data.h:1330
svxPtnData::PtnData::svxPntVar::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1367
svxPtnData::PtnData::svxPntVar::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1366
svxPtnData::PtnData::svxPolygon::spacing
double spacing
spacing of between rings radiating outward, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1326
svxPtnData::PtnData::svxPolygon::spacingType
int spacingType
pattern ways (0 = number per side, 1 = pitch between instances)
Definition: zwapi_cmd_shape_data.h:1320
svxPtnData::PtnData::svxPolygon::pitch
double pitch
pitch between instances, used only when spacingType = 1
Definition: zwapi_cmd_shape_data.h:1322
svxPtnData::PtnData::svxPolygon::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1324
svxPtnData::PtnData::svxPolygon::number
int number
number of per side, used only when spacingType = 0
Definition: zwapi_cmd_shape_data.h:1321
svxPtnData::PtnData::svxPolygon::axis
svxAxis axis
central axis for the pattern
Definition: zwapi_cmd_shape_data.h:1317
svxPtnData::PtnData::svxPolygon::numSides
int numSides
number of sides, it has to be greater than 2
Definition: zwapi_cmd_shape_data.h:1318
svxPtnData::PtnData::svxPolygon::numConcentric
int numConcentric
number of concentric polygons, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1325
svxPtnData::PtnData::svxPtnCrv::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1345
svxPtnData::PtnData::svxPtnCrv::curveType
int curveType
curve method (0 = 1 curve, 1 = 2 curves together, 2 = 2 curves across, 3 = 3~4 curves)
Definition: zwapi_cmd_shape_data.h:1340
svxPtnData::PtnData::svxPtnCrv::spacing
double spacing[2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1346
svxPtnData::PtnData::svxPtnCrv::idCrvs
int * idCrvs
list of id's of curves
Definition: zwapi_cmd_shape_data.h:1342
svxPtnData::PtnData::svxPtnCrv::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1344
svxPtnData::PtnData::svxPtnCrv::numCrvs
int numCrvs
number of curves, can't go beyond 4 curves
Definition: zwapi_cmd_shape_data.h:1341
svxPtnData::PtnData::svxPtnFace::spacing
double spacing[2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1353
svxPtnData::PtnData::svxPtnFace::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1351
svxPtnData::PtnData::svxPtnFace::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1352
svxPtnData::PtnData::svxPtnFace::idFace
int idFace
id of face
Definition: zwapi_cmd_shape_data.h:1350
svxPtnData::idParent
int idParent
id of the parent entity of point, set id to 0 when no parent object exists
Definition: zwapi_cmd_shape_data.h:1372
svxPtnData::cntSkip
int cntSkip
number of the instances to be skipped
Definition: zwapi_cmd_shape_data.h:1382
svxPtnData::firstTogglePos
int * firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in t...
Definition: zwapi_cmd_shape_data.h:1387
svxPtnData::basePnt
svxPoint basePnt
base point, the value is ignored if useBasePnt = 0
Definition: zwapi_cmd_shape_data.h:1373
svxPtnData::type
evxPatternType type
pattern method
Definition: zwapi_cmd_shape_data.h:1295
svxPtnData::minPer
double minPer
percentage of the minimum spacing, instances less than this will be deleted
Definition: zwapi_cmd_shape_data.h:1379
svxPtnData::useBasePnt
int useBasePnt
whether to use base point (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1371
svxPtnData::deriveType
int deriveType
derive method (0 = by spacing and number, 1 = by number, 2 = by spacing)
Definition: zwapi_cmd_shape_data.h:1378
svxPtnData::relocateBase
int relocateBase
whether to relocate base object (0 = no, 1 = yes) 1 - ensure that the array base point is at the desi...
Definition: zwapi_cmd_shape_data.h:1374
svxPtnData::secondTogglePos
int * secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in ...
Definition: zwapi_cmd_shape_data.h:1388
svxPtnData
pattern data
Definition: zwapi_cmd_shape_data.h:1293
svxPtnFtr::pTableVal
svxPtnVarTbl * pTableVal
the table dimension information,
Definition: zwapi_cmd_shape_data.h:1440
svxPtnFtr::cntDim
int cntDim
count dimension to change the value
Definition: zwapi_cmd_shape_data.h:1439
svxPtnFtr::inc
int inc
0-the value to be set, 1- the value to be increased
Definition: zwapi_cmd_shape_data.h:1438
svxPtnFtr::inpData
svxPtnData * inpData
base input data of pattern feature command
Definition: zwapi_cmd_shape_data.h:1437
svxPtnFtr
pattern feature data
Definition: zwapi_cmd_shape_data.h:1436
svxPtnGeom::inpData
svxPtnData * inpData
base input data of pattern geometry command
Definition: zwapi_cmd_shape_data.h:1404
svxPtnGeom::nonAssoCopy
int nonAssoCopy
non-associative copy (0 = no, 1 = yes), used only for geometry pattern if set to 0,...
Definition: zwapi_cmd_shape_data.h:1405
svxPtnGeom
pattern geometry data
Definition: zwapi_cmd_shape_data.h:1403
svxPtnVarTbl::pCell
int * pCell
Definition: zwapi_cmd_shape_data.h:1418
svxPtnVarTbl::dimName
vxName dimName
the name of the dimension to change the value
Definition: zwapi_cmd_shape_data.h:1416
svxPtnVarTbl::cntCell
int cntCell
count of cells to be set
Definition: zwapi_cmd_shape_data.h:1417
svxPtnVarTbl::pVal
double * pVal
the dimension value to be set.
Definition: zwapi_cmd_shape_data.h:1428
svxPtnVarTbl
table dimension information
Definition: zwapi_cmd_shape_data.h:1415
svxVariable::Value
double Value
value is not required if Expression is defined
Definition: zwapi_util.h:1124
svxVariable
numeric variable
Definition: zwapi_util.h:1122
svxVector
3D vector
Definition: zwapi_util.h:338
svxCopyData::evxMethodUnion::AroundDir
svxAroundDir AroundDir
around direction data
Definition: zwapi_cmd_shape_data.h:1607
svxCopyData::evxMethodUnion::AlongDir
svxAlongDir AlongDir
along direction data
Definition: zwapi_cmd_shape_data.h:1606
svxCopyData::evxMethodUnion::Sweep
svxAlongPath Sweep
sweep along path
Definition: zwapi_cmd_shape_data.h:1609
svxCopyData::evxMethodUnion::AlignFrame
svxAlignFrame AlignFrame
copy entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1608
svxCopyData::evxMethodUnion::DymCopy
svxDymMove DymCopy
dynamic copy
Definition: zwapi_cmd_shape_data.h:1604
svxCopyData::evxMethodUnion::PntToPnt
svxMovePntToPnt PntToPnt
point to point
Definition: zwapi_cmd_shape_data.h:1605
svxMoveData::evxMethodsUnion::AlongDir
svxAlongDir AlongDir
along direction data
Definition: zwapi_cmd_shape_data.h:1586
svxMoveData::evxMethodsUnion::AlignFrame
svxAlignFrame AlignFrame
copy entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1588
svxMoveData::evxMethodsUnion::Sweep
svxAlongPath Sweep
sweep along path
Definition: zwapi_cmd_shape_data.h:1589
svxMoveData::evxMethodsUnion::DymMove
svxDymMove DymMove
dynamic move
Definition: zwapi_cmd_shape_data.h:1584
svxMoveData::evxMethodsUnion::AroundDir
svxAroundDir AroundDir
around direction data
Definition: zwapi_cmd_shape_data.h:1587
svxMoveData::evxMethodsUnion::PntToPnt
svxMovePntToPnt PntToPnt
point to point
Definition: zwapi_cmd_shape_data.h:1585
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\datumCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\datumCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
ApiDefVoidFunc(zwTestPartDatum, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartDatum2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartNewDatum, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlnCrv, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlnCrv2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlnSrf, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlnSrf2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAxisNew, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew1, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew3, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew4, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew5, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew6, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCSYSNew7, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlaneNew, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlaneAdd1, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlaneAdd2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlaneAdd3, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPlaneAdd4, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartActiveAsLCS, VX_CODE_GENERAL);
void zwTestPartDatum()
/*
DESCRIPTION:
Test case for function cvxPartDatum.
*/
{
/* add a datum plane */
svxMatrix frame = { 0 };
frame.xx = frame.yy = frame.zz = 1;
svxPoint point = { 0 };
cvxGetPoint("select a point to add a datum plane", VX_INP_PNT_GENERAL, 0, &point, nullptr);
frame.xt = point.x;
frame.yt = point.y;
frame.zt = point.z;
int idDatum = 0;
if (cvxPartDatum(&frame, &idDatum) || idDatum == 0)
zwTestLogErrorMsg(5, "cvxPartDatum: failed to add a datum plane!");
}
void zwTestPartDatum2()
/*
DESCRIPTION:
Test case for function cvxPartDatum2.
*/
{
/* add a datum plane */
svxMatrix frame = { 0 };
frame.xx = frame.yy = frame.zz = 1;
svxPoint point = { 0 };
cvxGetPoint("select a point to add a datum plane", VX_INP_PNT_GENERAL, 0, &point, nullptr);
frame.xt = point.x;
frame.yt = point.y;
frame.zt = point.z;
int code = 0;
double val = 0;
cvxGetNumber("whether add label to entity: 0 or 1", &val);
if (int(val + 0.5))
code = 1;
int idDatum = 0;
if (cvxPartDatum2(&frame, code, &idDatum) || idDatum == 0)
zwTestLogErrorMsg(5, "cvxPartDatum2: failed to create a datum plane!");
}
void zwTestPartNewDatum()
/*
DESCRIPTION:
Test case for function cvxPartNewDatum.
*/
{
/* create a datum plane */
svxPoint point = { 0 };
cvxGetPoint("select a point to add a datum plane", VX_INP_PNT_GENERAL, 0, &point, nullptr);
svxMatrix frame = { 0 };
cvxMatTranslate(&frame, point.x, point.y, point.z);
int idDatum = 0;
if (cvxPartNewDatum(&frame, &idDatum) || idDatum == 0)
zwTestLogErrorMsg(5, "cvxPartNewDatum: failed to create a datum plane!");
}
void zwTestPartPlnCrv()
/*
DESCRIPTION:
Test case for function cvxPartPlnCrv.
*/
{
/* select a curve */
int idCrv;
svxPoint origin = { 0 };
cvxGetPoint("select origin point of a curve", VX_INP_PNT_ON_CRV_OR_PROF, 0, &origin, &idCrv);
/* select direction */
double val = 0;
svxPoint* pAxis = nullptr;
svxPoint direction = { 0 };
cvxGetNumber("whether specify X-axis", &val);
if (int(val + 0.5))
{
cvxGetPoint("specify direction of X-axis, <middle-click> to ignore", VX_INP_PNT_GENERAL, 1, &direction, nullptr);
pAxis = &direction;
}
/* create a datum plane normal to the curve */
int idPlane = 0;
if (cvxPartPlnCrv(idCrv, &origin, pAxis, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlnCrv: failed to create a datum plane!");
}
void zwTestPartPlnCrv2()
/*
DESCRIPTION:
Test case for function cvxPartPlnCrv2.
*/
{
/* select a curve */
int idCrv;
svxData origin = { 0 };
origin.isPoint = 1;
cvxGetPoint("select origin point of a curve", VX_INP_PNT_ON_CRV_OR_PROF, 0, &origin.Pnt, &idCrv);
/* select direction */
svxData* pAxis = nullptr;
svxData direction = { 0 };
direction.isPoint = 1;
double val = 0;
cvxGetNumber("whether specify X-axis", &val);
if (int(val + 0.5))
{
cvxGetPoint("specify direction of X-axis, <middle-click> to ignore", VX_INP_PNT_GENERAL, 1, &direction.Pnt, nullptr);
pAxis = &direction;
}
/* flip option */
int flipPln = 0;
cvxGetNumber("select flip method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
case 3:
flipPln = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlnCrv2: invalid option!");
break;
}
/* create datum plane */
int idPlane = 0;
if (cvxPartPlnCrv2(idCrv, &origin, pAxis, flipPln, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlnCrv2: failed to create a datum plane!");
}
void zwTestPartPlnSrf()
/*
DESCRIPTION:
Test case for function cvxPartPlnSrf.
*/
{
/* select a surface */
int idFace = 0;
svxPoint point = { 0 };
cvxGetPoint("select a point on face", VX_INP_PNT_ON_ANY_FACE, 0, &point, &idFace);
/* create a datum plane */
int idPln = 0;
if (cvxPartPlnSrf(idFace, &point, &idPln) || idPln == 0)
zwTestLogErrorMsg(5, "cvxPartPlnSrf: failed to create a datum plane!");
}
void zwTestPartPlnSrf2()
/*
DESCRIPTION:
Test case for function cvxPartPlnSrf2.
*/
{
/* select a surface */
int idFace = 0;
svxPoint point = { 0 };
cvxGetPoint("select a point on face", VX_INP_PNT_ON_ANY_FACE, 0, &point, &idFace);
/* select XZ plane */
double val = 0;
svxPoint* XZPln = nullptr;
svxPoint XZPnt = { 0 };
cvxGetNumber("whether specify XZ plane: 0 or 1", &val);
if (int(val + 0.5))
{
cvxGetPoint("select a point on XZ plane", VX_INP_PNT_GENERAL, 0, &XZPnt, nullptr);
XZPln = &XZPnt;
}
/* flip option */
int flipPln = 0;
cvxGetNumber("select flip method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
case 3:
flipPln = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlnCrv2: invalid option!");
break;
}
/* create a datum plane */
int idPln = 0;
if (cvxPartPlnSrf2(idFace, &point, XZPln, flipPln, &idPln) || idPln == 0)
zwTestLogErrorMsg(5, "cvxPartPlnSrf2: failed to create a datum plane!");
}
void zwTestPartAxisNew()
/*
DESCRIPTION:
Test case for function cvxPartAxisNew.
*/
{
/*initialize a datum axis*/
svxAxisData axis = { 0 };
double val = 0;
cvxGetNumber("select a axis method: 0 - 7", &val);
switch (int(val + 0.5))
{
case 0:
axis.method = VX_AXIS_GEOMETRY;
cvxGetPointOnEnt(
"select a point on entity", VX_INP_PNT_ON_ENTITY, 0, &axis.inpUnion.geomPnt.Pnt, &axis.inpUnion.geomPnt.Path);
break;
case 1:
axis.method = VX_AXIS_FACE_CENTER;
cvxGetEntPath("select a face", VX_INP_FACE, 0, &axis.inpUnion.facCenter.Face);
break;
case 2:
axis.method = VX_AXIS_XX;
break;
case 3:
axis.method = VX_AXIS_YY;
break;
case 4:
axis.method = VX_AXIS_ZZ;
break;
case 5:
axis.method = VX_AXIS_TWO_PNT;
cvxGetPoint("select the first point", VX_INP_PNT_GENERAL, 0, &axis.inpUnion.twoPnts.Pnt1, &axis.inpUnion.twoPnts.idPnt1);
cvxGetPoint("select the second point", VX_INP_PNT_GENERAL, 0, &axis.inpUnion.twoPnts.Pnt2, &axis.inpUnion.twoPnts.idPnt2);
axis.length = cvxPntDist(&axis.inpUnion.twoPnts.Pnt1, &axis.inpUnion.twoPnts.Pnt2);
break;
case 6:
axis.method = VX_AXIS_PNT_DIR;
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &axis.inpUnion.pntDir.OrgPnt, &axis.inpUnion.pntDir.idOrgPnt);
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&axis.inpUnion.pntDir.Dir, nullptr);
break;
case 7:
axis.method = VX_AXIS_INTERSECT_FACES;
cvxGetEntPath("select first face", VX_INP_FACE, 0, &axis.inpUnion.interFaces.Face1);
cvxGetEntPath("select second face", VX_INP_FACE, 0, &axis.inpUnion.interFaces.Face2);
break;
default:
zwTestLogErrorMsg(5, "cvxPartAxisNew: invalid option!");
break;
}
if (axis.method != VX_AXIS_TWO_PNT)
cvxGetNumber("specify length of axis", &axis.length);
cvxGetNumber("whether flip direction: 0 or 1", &val);
if (int(val + 0.5))
axis.FlipDir = 1;
/* create a datum axis */
int idAxis = 0;
if (cvxPartAxisNew(&axis, &idAxis) || idAxis == 0)
zwTestLogErrorMsg(5, "cvxPartAxisNew: failed to create a datum axis!");
}
void zwTestPartCSYSNew1()
/*
DESCRIPTION:
Test case1 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_THREE_POINTS */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_THREE_POINTS, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
svxPntByOffset orgByOffset = { 0 }, pnt1ByOffset = { 0 }, pnt2ByOffset = { 0 };
cvxPartPntByOffsetInit(&orgByOffset, 0);
cvxPartPntByOffsetInit(&pnt1ByOffset, 0);
cvxPartPntByOffsetInit(&pnt2ByOffset, 0);
svxPntBy2Lines orgBy2Lines = { 0 }, pnt1By2Lines = { 0 }, pnt2By2Lines = { 0 };
cvxPartPntBy2LinesInit(&orgBy2Lines, 1);
cvxPartPntBy2LinesInit(&pnt1By2Lines, 1);
cvxPartPntBy2LinesInit(&pnt2By2Lines, 1);
/* set origin point */
double val = 0;
cvxGetNumber("select method for origin point: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select origin point.",
VX_INP_PNT_GENERAL,
0,
&CSYS.inpUnion.threePnts.OrgPnt,
&CSYS.inpUnion.threePnts.idOrgPnt);
break;
case 1:
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &orgByOffset.pntOnEnt.pnt, &orgByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &orgByOffset.xOffset);
cvxGetNumber("specify Y offset", &orgByOffset.yOffset);
cvxGetNumber("specify Z offset", &orgByOffset.zOffset);
CSYS.inpUnion.threePnts.OrgPntByOffset = &orgByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &orgBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &orgBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &orgBy2Lines.dDst1);
cvxGetNumber("specify second distance", &orgBy2Lines.dDst2);
CSYS.inpUnion.threePnts.OrgPntBy2Lines = &orgBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid option!");
break;
}
/* set point1 */
cvxGetNumber("select point1 type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint(
"select point1.", VX_INP_PNT_GENERAL, 0, &CSYS.inpUnion.threePnts.Pnt1, &CSYS.inpUnion.threePnts.idPnt1);
break;
case 1:
cvxGetPoint(
"select point1", VX_INP_PNT_GENERAL, 0, &pnt1ByOffset.pntOnEnt.pnt, &pnt1ByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &pnt1ByOffset.xOffset);
cvxGetNumber("specify Y offset", &pnt1ByOffset.yOffset);
cvxGetNumber("specify Z offset", &pnt1ByOffset.zOffset);
CSYS.inpUnion.threePnts.Pnt1ByOffset = &pnt1ByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &pnt1By2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &pnt1By2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &pnt1By2Lines.dDst1);
cvxGetNumber("specify second distance", &pnt1By2Lines.dDst2);
CSYS.inpUnion.threePnts.Pnt1By2Lines = &pnt1By2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid option!");
break;
}
cvxGetNumber("select first axis type: 0 - 2, 0 as default", &val);
if (int(val + 0.5) == 1)
CSYS.inpUnion.threePnts.firstAxis = VX_RESULTS_AXIS_Y;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.threePnts.firstAxis = VX_RESULTS_AXIS_Z;
cvxGetNumber("whether flip first axis: 0 or 1", &val);
if (int(val + 0.5))
CSYS.inpUnion.threePnts.isFlip1 = 1;
/* set point2 */
cvxGetNumber("select point2 type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint(
"select point2.", VX_INP_PNT_GENERAL, 0, &CSYS.inpUnion.threePnts.Pnt2, &CSYS.inpUnion.threePnts.idPnt2);
break;
case 1:
cvxGetPoint(
"select point2", VX_INP_PNT_GENERAL, 0, &pnt2ByOffset.pntOnEnt.pnt, &pnt2ByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &pnt2ByOffset.xOffset);
cvxGetNumber("specify Y offset", &pnt2ByOffset.yOffset);
cvxGetNumber("specify Z offset", &pnt2ByOffset.zOffset);
CSYS.inpUnion.threePnts.Pnt2ByOffset = &pnt2ByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &pnt2By2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &pnt2By2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &pnt2By2Lines.dDst1);
cvxGetNumber("specify second distance", &pnt2By2Lines.dDst2);
CSYS.inpUnion.threePnts.OrgPntBy2Lines = &pnt2By2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid option!");
break;
}
cvxGetNumber("select second axis type: 0 - 2, 1 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.threePnts.secondAxis = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.threePnts.secondAxis = VX_RESULTS_AXIS_Z;
cvxGetNumber("whether flip second axis: 0 or 1", &val);
if (int(val + 0.5))
CSYS.inpUnion.threePnts.isFlip2 = 1;
cvxGetNumber("specify Z offset", &CSYS.dOffset);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &CSYS.XPnt, &CSYS.idXPnt);
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew2()
/*
DESCRIPTION:
Test case2 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_ONLY_MATRIX */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_ONLY_MATRIX, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
svxPoint origin = { 0 };
cvxGetPoint("select origin point", VX_INP_PNT_GENERAL, 0, &origin, nullptr);
CSYS.Frame.xt = origin.x;
CSYS.Frame.yt = origin.y;
CSYS.Frame.zt = origin.z;
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew3()
/*
DESCRIPTION:
Test case3 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_DYNAMIC */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_DYNAMIC, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
svxPntByOffset posByOffset = { 0 };
cvxPartPntByOffsetInit(&posByOffset, 0);
svxPntBy2Lines posBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&posBy2Lines, 1);
double val = 0;
cvxGetNumber("select position point method: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select position point",
VX_INP_PNT_GENERAL,
0,
&CSYS.inpUnion.dynamic.PosPnt,
&CSYS.inpUnion.dynamic.idPosPnt);
break;
case 1:
cvxGetPoint(
"select position point", VX_INP_PNT_GENERAL, 0, &posByOffset.pntOnEnt.pnt, &posByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &posByOffset.xOffset);
cvxGetNumber("specify Y offset", &posByOffset.yOffset);
cvxGetNumber("specify Z offset", &posByOffset.zOffset);
CSYS.inpUnion.dynamic.PosPntByOffset = &posByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &posBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &posBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &posBy2Lines.dDst1);
cvxGetNumber("specify second distance", &posBy2Lines.dDst2);
CSYS.inpUnion.dynamic.PosPntBy2Lines = &posBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid method!");
break;
}
cvxGetPoint("select X-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&CSYS.inpUnion.dynamic.Xaxis, nullptr);
cvxGetPoint("select Y-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&CSYS.inpUnion.dynamic.Yaxis, nullptr);
cvxGetPoint("select Z-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&CSYS.inpUnion.dynamic.Zaxis, nullptr);
cvxGetNumber("whether use auto orientation: 0 or 1, 1 as default", &val); /* default 1 */
if (int(val + 0.5) == 0)
CSYS.inpUnion.dynamic.isAutoOrint = 0;
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew4()
/*
DESCRIPTION:
Test case4 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_THREE_FACES */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_THREE_FACES, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
cvxGetEntPath("select face1", VX_INP_FACE, 0, &CSYS.inpUnion.threeFaces.Face1);
cvxGetEntPath("select face2", VX_INP_FACE, 0, &CSYS.inpUnion.threeFaces.Face2);
cvxGetEntPath("select face3", VX_INP_FACE, 0, &CSYS.inpUnion.threeFaces.Face3);
double val = 0;
cvxGetNumber("select axis1 type: 0 - 2, 0 as default", &val);
if (int(val + 0.5) == 1)
CSYS.inpUnion.threeFaces.axis1 = VX_RESULTS_AXIS_Y;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.threeFaces.axis1 = VX_RESULTS_AXIS_Z;
cvxGetNumber("whether flip axis1: 0 or 1", &val);
if (int(val + 0.5))
CSYS.inpUnion.threeFaces.isFlip1 = 1;
cvxGetNumber("select axis2 type: 0 - 2, 1 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.threeFaces.axis2 = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.threeFaces.axis2 = VX_RESULTS_AXIS_Z;
cvxGetNumber("whether flip axis2: 0 or 1", &val);
if (int(val + 0.5))
CSYS.inpUnion.threeFaces.isFlip2 = 1;
cvxGetNumber("select axis3 type: 0 - 2, 2 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.threeFaces.axis3 = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 1)
CSYS.inpUnion.threeFaces.axis3 = VX_RESULTS_AXIS_Y;
cvxGetNumber("specify Z offset", &CSYS.dOffset);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &CSYS.XPnt, &CSYS.idXPnt);
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew5()
/*
DESCRIPTION:
Test case5 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_PNT_AND_TWO_DIR */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_PNT_AND_TWO_DIR, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
svxPntByOffset orgByOffset = { 0 };
cvxPartPntByOffsetInit(&orgByOffset, 0);
svxPntBy2Lines orgBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&orgBy2Lines, 1);
double val = 0;
cvxGetNumber("select origin point method: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select origin point",
VX_INP_PNT_GENERAL,
0,
&CSYS.inpUnion.pntAnd2Dir.OrgPnt,
&CSYS.inpUnion.pntAnd2Dir.idOrgPnt);
break;
case 1:
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &orgByOffset.pntOnEnt.pnt, &orgByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &orgByOffset.xOffset);
cvxGetNumber("specify Y offset", &orgByOffset.yOffset);
cvxGetNumber("specify Z offset", &orgByOffset.zOffset);
CSYS.inpUnion.pntAnd2Dir.OrgPntByOffset = &orgByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &orgBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &orgBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &orgBy2Lines.dDst1);
cvxGetNumber("specify second distance", &orgBy2Lines.dDst2);
CSYS.inpUnion.pntAnd2Dir.OrgPntBy2Lines = &orgBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid option!");
break;
}
cvxGetPoint("select first direction",
VX_INP_PNT_ON_CURVE_OR_EDGE,
0,
&CSYS.inpUnion.pntAnd2Dir.DirOnEnt1.pnt,
&CSYS.inpUnion.pntAnd2Dir.DirOnEnt1.idEnt);
cvxGetPoint("select second direction",
VX_INP_PNT_ON_CURVE_OR_EDGE,
0,
&CSYS.inpUnion.pntAnd2Dir.DirOnEnt2.pnt,
&CSYS.inpUnion.pntAnd2Dir.DirOnEnt2.idEnt);
cvxGetNumber("select axis1 type: 0 - 2, 0 as default", &val);
if (int(val + 0.5) == 1)
CSYS.inpUnion.pntAnd2Dir.axis1 = VX_RESULTS_AXIS_Y;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.pntAnd2Dir.axis1 = VX_RESULTS_AXIS_Z;
cvxGetNumber("select axis2 type: 0 - 2, 1 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.pntAnd2Dir.axis2 = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.pntAnd2Dir.axis2 = VX_RESULTS_AXIS_Z;
cvxGetNumber("specify Z offset", &CSYS.dOffset);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &CSYS.XPnt, &CSYS.idXPnt);
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew6()
/*
DESCRIPTION:
Test case6 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_PLANE_PNT_AND_DIR */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_PLANE_PNT_AND_DIR, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
cvxGetEntPath("select a face", VX_INP_FACE, 0, &CSYS.inpUnion.PlanAndDir.Face);
double val = 0;
cvxGetNumber("select axis type: 0 - 2, 2 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.PlanAndDir.axisFc = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 1)
CSYS.inpUnion.PlanAndDir.axisFc = VX_RESULTS_AXIS_Y;
cvxGetNumber("whether flip face: 0 or 1", &val);
if (int(val + 0.5))
CSYS.inpUnion.PlanAndDir.isFlipFc = 1;
svxPntByOffset pntByOffset = { 0 };
cvxPartPntByOffsetInit(&pntByOffset, 0);
svxPntBy2Lines pntBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&pntBy2Lines, 1);
cvxGetNumber("select point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint(
"select a point", VX_INP_PNT_GENERAL, 0, &CSYS.inpUnion.PlanAndDir.Pnt, &CSYS.inpUnion.PlanAndDir.idPnt);
break;
case 1:
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &pntByOffset.pntOnEnt.pnt, &pntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &pntByOffset.xOffset);
cvxGetNumber("specify Y offset", &pntByOffset.yOffset);
cvxGetNumber("specify Z offset", &pntByOffset.zOffset);
CSYS.inpUnion.PlanAndDir.PntByOffset = &pntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &pntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &pntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first direction", &pntBy2Lines.dDst1);
cvxGetNumber("specify second direction", &pntBy2Lines.dDst2);
CSYS.inpUnion.PlanAndDir.PntBy2Lines = &pntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCSYSNew: invalid option!");
break;
}
cvxGetEnt("select a direction", VX_INP_EDGE_OR_CURVE, 0, &CSYS.inpUnion.PlanAndDir.DirOnEnt.idEnt);
cvxGetNumber("select axis type: 0 - 2, 0 as default", &val);
if (int(val + 0.5) == 1)
CSYS.inpUnion.PlanAndDir.axisDir = VX_RESULTS_AXIS_Y;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.PlanAndDir.axisDir = VX_RESULTS_AXIS_Z;
cvxGetNumber("specify Z offset", &CSYS.dOffset);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &CSYS.XPnt, &CSYS.idXPnt);
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
}
void zwTestPartCSYSNew7()
/*
DESCRIPTION:
Test case7 for function cvxPartCSYSNew.
*/
{
/* svxCSYSData.method = VX_CSYS_GEOMETRY */
svxCSYSData CSYS = { 0 };
if (cvxPartCSYSNewInit(VX_CSYS_GEOMETRY, &CSYS))
zwTestLogErrorMsg(5, "cvxPartCSYSNewInit: failed to initialize a datum CSYS!");
double val = 0;
cvxGetNumber("select a method: 0-CSYS, 1-other geometry", &val);
if (int(val + 0.5) == 0)
{
CSYS.inpUnion.byGeom.cnt = 1;
cvxMemAlloc(sizeof(svxPoint), (void**)&CSYS.inpUnion.byGeom.OrgPnts);
cvxMemAlloc(sizeof(svxEntPath), (void**)&CSYS.inpUnion.byGeom.Paths);
CSYS.inpUnion.byGeom.cnt = 1;
CSYS.inpUnion.byGeom.Paths->Count = 2;
CSYS.inpUnion.byGeom.Paths->Id[0] = -1;
cvxGetEnt("select a CSYS", VX_INP_CSYS, 0, &CSYS.inpUnion.byGeom.Paths->Id[1]);
cvxEntPnt(CSYS.inpUnion.byGeom.Paths->Id[1], &CSYS.inpUnion.byGeom.OrgPnts[0]);
cvxGetNumber("0-offset first, 1-rotate first", &val);
if (int(val + 0.5))
CSYS.inpUnion.byGeom.offsetFirst = 1;
cvxGetNumber("specify X offset", &CSYS.inpUnion.byGeom.xOffset);
cvxGetNumber("specify Y offset", &CSYS.inpUnion.byGeom.yOffset);
cvxGetNumber("specify Z offset", &CSYS.inpUnion.byGeom.zOffset);
}
else
{
cvxGetPointsOnEnts("select some geometry",
VX_INP_PNT_ON_ENTITY,
0,
&CSYS.inpUnion.byGeom.cnt,
&CSYS.inpUnion.byGeom.OrgPnts,
&CSYS.inpUnion.byGeom.Paths);
cvxGetNumber("select axis1 type: 0 - 2, 0 as default", &val);
if (int(val + 0.5) == 1)
CSYS.inpUnion.byGeom.firstAxis = VX_RESULTS_AXIS_Y;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.byGeom.firstAxis = VX_RESULTS_AXIS_Z;
cvxGetNumber("select axis2 type: 0 - 2, 1 as default", &val);
if (int(val + 0.5) == 0)
CSYS.inpUnion.byGeom.secondAxis = VX_RESULTS_AXIS_X;
else if (int(val + 0.5) == 2)
CSYS.inpUnion.byGeom.secondAxis = VX_RESULTS_AXIS_Z;
cvxGetNumber("specify Z offset", &CSYS.dOffset);
cvxGetPoint("specify origin point", VX_INP_PNT_GENERAL, 0, &CSYS.OrgPnt, &CSYS.idOrgPnt);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &CSYS.XPnt, &CSYS.idXPnt);
}
cvxGetNumber("specify X angle", &CSYS.XAng);
cvxGetNumber("specify Y angle", &CSYS.YAng);
cvxGetNumber("specify Z angle", &CSYS.ZAng);
/* create a datum CSYS */
int idCSYS = 0;
if (cvxPartCSYSNew(&CSYS, &idCSYS) || idCSYS == 0)
zwTestLogErrorMsg(5, "cvxPartCSYSNew: failed to create a datum CSYS!");
/* free memory */
cvxMemFree((void**)&CSYS.inpUnion.byGeom.OrgPnts);
cvxMemFree((void**)&CSYS.inpUnion.byGeom.Paths);
}
void zwTestPartPlaneNew()
/*
DESCRIPTION:
Test case for function cvxPartPlaneNew.
*/
{
/* initialize a datum plane */
svxPlaneData plane;
cvxMemZero((void*)&plane, sizeof(svxPlaneData));
double val = 0;
cvxGetNumber("select a plane method: 0 - 7", &val);
switch (int(val + 0.5))
{
case 0:
plane.method = VX_PLANE_GEOMETRY;
cvxGetPointOnEnt(
"select a geometry", VX_INP_PNT_ON_ENTITY, 0, &plane.inpUnion.geomPnt.Pnt, &plane.inpUnion.geomPnt.Path);
cvxGetNumber("select plane orientation align type: 1 - 3", &val);
if (int(val + 0.5) == 2)
plane.AlignType = VX_PLANE_ALIGN_TO_XZ;
else if (int(val + 0.5) == 3)
plane.AlignType = VX_PLANE_ALIGN_TO_YZ;
else
plane.AlignType = VX_PLANE_ALIGN_TO_XY;
cvxGetNumber("specify offset", &plane.dOffset);
break;
case 1:
plane.method = VX_PLANE_THREE_POINTS;
/*pick three points*/
cvxGetPoint("pick origin point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.OrgPnt, nullptr);
cvxGetPoint("pick x point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.XPnt, nullptr);
cvxGetPoint("pick y point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.YPnt, nullptr);
cvxGetNumber("select plane orientation align type: 1 - 3", &val);
if (int(val + 0.5) == 2)
plane.AlignType = VX_PLANE_ALIGN_TO_XZ;
else if (int(val + 0.5) == 3)
plane.AlignType = VX_PLANE_ALIGN_TO_YZ;
else
plane.AlignType = VX_PLANE_ALIGN_TO_XY;
cvxGetNumber("specify offset", &plane.dOffset);
break;
case 2:
plane.method = VX_PLANE_XY;
cvxGetNumber("specify offset", &plane.inpUnion.xyz.Offset);
break;
case 3:
plane.method = VX_PLANE_XZ;
cvxGetNumber("specify offset", &plane.inpUnion.xyz.Offset);
break;
case 4:
plane.method = VX_PLANE_YZ;
cvxGetNumber("specify offset", &plane.inpUnion.xyz.Offset);
break;
case 5:
plane.method = VX_PLANE_VIEW_PLANE;
cvxGetPoint("select origin point", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.viewPln.OrgPnt, nullptr);
break;
case 6:
plane.method = VX_PLANE_TWO_ENTITIES;
cvxGetPoint("select the first entity",
VX_INP_PNT_ON_ENTITY,
0,
&plane.inpUnion.twoEnts.Ent1Pnt,
&plane.inpUnion.twoEnts.idEnt1);
cvxGetPoint("select the second entity",
VX_INP_PNT_ON_ENTITY,
0,
&plane.inpUnion.twoEnts.Ent2Pnt,
&plane.inpUnion.twoEnts.idEnt2);
cvxGetNumber("select plane orientation align type: 1 - 3", &val);
if (int(val + 0.5) == 2)
plane.AlignType = VX_PLANE_ALIGN_TO_XZ;
else if (int(val + 0.5) == 3)
plane.AlignType = VX_PLANE_ALIGN_TO_YZ;
else
plane.AlignType = VX_PLANE_ALIGN_TO_XY;
cvxGetNumber("specify offset", &plane.dOffset);
break;
case 7:
plane.method = VX_PLANE_DYNAMIC;
cvxGetPoint("select position point",
VX_INP_PNT_GENERAL,
0,
&plane.inpUnion.dynamic.PosPnt,
&plane.inpUnion.dynamic.idPosPnt);
cvxGetPoint(
"select X-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.XAxis, nullptr);
cvxGetPoint(
"select Y-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.YAxis, nullptr);
cvxGetPoint(
"select Z-axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.ZAxis, nullptr);
break;
default:
break;
}
/* orientation option */
if (plane.method != VX_PLANE_DYNAMIC)
{
if (plane.method != VX_PLANE_THREE_POINTS && plane.method != VX_PLANE_VIEW_PLANE)
cvxGetPoint("select origin point", VX_INP_PNT_GENERAL, 0, &plane.OrgPnt, &plane.idOrgPnt);
if (plane.method != VX_PLANE_VIEW_PLANE)
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &plane.XPnt, &plane.idXPnt);
cvxGetNumber("specify X angle", &plane.XAng);
cvxGetNumber("specify Y angle", &plane.YAng);
cvxGetNumber("specify Z angle", &plane.ZAng);
}
/* create a datum plane */
int idPlane = 0;
if (cvxPartPlaneNew(&plane, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlaneNew: failed to create a datum plane!");
}
void zwTestPartPlaneAdd1()
/*
DESCRIPTION:
Test case1 for function cvxPartPlaneAdd.
*/
{
/* evxNewPlaneMethods = VX_NEW_PLANE_THREE_POINTS */
svxNewPlaneData plane;
if (cvxPartPlaneAddInit(VX_NEW_PLANE_THREE_POINTS, &plane))
zwTestLogErrorMsg(5, "cvxPartPlaneAddInit: failed to initialize a datum plane!");
svxPntByOffset orgPntByOffset = { 0 }, xPntByOffset = { 0 }, yPntByOffset = { 0 };
cvxPartPntByOffsetInit(&orgPntByOffset, 0);
cvxPartPntByOffsetInit(&xPntByOffset, 0);
cvxPartPntByOffsetInit(&yPntByOffset, 0);
svxPntBy2Lines orgPntBy2Lines = { 0 }, xPntBy2Lines = { 0 }, yPntBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&orgPntBy2Lines, 1);
cvxPartPntBy2LinesInit(&xPntBy2Lines, 1);
cvxPartPntBy2LinesInit(&yPntBy2Lines, 1);
/* origin point */
double val = 0;
cvxGetNumber("select origin point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select origin point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.orgPnt, nullptr);
break;
case 1:
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &orgPntByOffset.pntOnEnt.pnt, &orgPntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &orgPntByOffset.xOffset);
cvxGetNumber("specify Y offset", &orgPntByOffset.yOffset);
cvxGetNumber("specify Z offset", &orgPntByOffset.zOffset);
plane.inpUnion.threePnts.orgPntByOffset = &orgPntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &orgPntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &orgPntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &orgPntBy2Lines.dDst1);
cvxGetNumber("specify second distance", &orgPntBy2Lines.dDst2);
plane.inpUnion.threePnts.orgPntBy2Lines = &orgPntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
/* x point */
cvxGetNumber("select X point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select X point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.xPnt, nullptr);
break;
case 1:
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &xPntByOffset.pntOnEnt.pnt, &xPntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &xPntByOffset.xOffset);
cvxGetNumber("specify Y offset", &xPntByOffset.yOffset);
cvxGetNumber("specify Z offset", &xPntByOffset.zOffset);
plane.inpUnion.threePnts.xPntByOffset = &xPntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &xPntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &xPntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &xPntBy2Lines.dDst1);
cvxGetNumber("specify second distance", &xPntBy2Lines.dDst2);
plane.inpUnion.threePnts.xPntBy2Lines = &xPntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
/* y point */
cvxGetNumber("select Y point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select Y point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.yPnt, nullptr);
break;
case 1:
cvxGetPoint("select Y point", VX_INP_PNT_GENERAL, 0, &yPntByOffset.pntOnEnt.pnt, &yPntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &yPntByOffset.xOffset);
cvxGetNumber("specify Y offset", &yPntByOffset.yOffset);
cvxGetNumber("specify Z offset", &yPntByOffset.zOffset);
plane.inpUnion.threePnts.yPntByOffset = &yPntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &yPntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &yPntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &yPntBy2Lines.dDst1);
cvxGetNumber("specify second distance", &yPntBy2Lines.dDst2);
plane.inpUnion.threePnts.yPntBy2Lines = &yPntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
cvxGetNumber("whether flip direction: 0 or 1", &val);
if (int(val + 0.5))
plane.isFlipDir = 1;
/* orientation option */
cvxGetNumber("specify offset", &plane.dOffset);
svxPoint xPoint = { 0 };
plane.xPoint = &xPoint;
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &xPoint, nullptr);
cvxGetNumber("specify X angle", &plane.xAng);
cvxGetNumber("specify Y angle", &plane.yAng);
cvxGetNumber("specify Z angle", &plane.zAng);
/* create a datum plane */
int idPlane = 0;
if (cvxPartPlaneAdd(&plane, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: failed to create a datum plane!");
}
void zwTestPartPlaneAdd2()
/*
DESCRIPTION:
Test case2 for function cvxPartPlaneAdd.
*/
{
/* evxNewPlaneMethods = VX_NEW_PLANE_VIEW_PLANE */
svxNewPlaneData plane;
if (cvxPartPlaneAddInit(VX_NEW_PLANE_VIEW_PLANE, &plane))
zwTestLogErrorMsg(5, "cvxPartPlaneAddInit: failed to initialize a datum plane!");
svxPntByOffset orgPntByOffset = { 0 };
cvxPartPntByOffsetInit(&orgPntByOffset, 0);
svxPntBy2Lines orgPntBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&orgPntBy2Lines, 1);
/* origin point */
double val = 0;
cvxGetNumber("select origin point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select origin point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.threePnts.orgPnt, nullptr);
break;
case 1:
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &orgPntByOffset.pntOnEnt.pnt, &orgPntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &orgPntByOffset.xOffset);
cvxGetNumber("specify Y offset", &orgPntByOffset.yOffset);
cvxGetNumber("specify Z offset", &orgPntByOffset.zOffset);
plane.inpUnion.view.orgPntByOffset = &orgPntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &orgPntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &orgPntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &orgPntBy2Lines.dDst1);
cvxGetNumber("specify second distance", &orgPntBy2Lines.dDst2);
plane.inpUnion.view.orgPntBy2Lines = &orgPntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
cvxGetNumber("whether flip direction: 0 or 1", &val);
if (int(val + 0.5))
plane.isFlipDir = 1;
/* orientation option */
cvxGetNumber("specify X angle", &plane.xAng);
cvxGetNumber("specify Y angle", &plane.yAng);
cvxGetNumber("specify Z angle", &plane.zAng);
/* create a datum plane */
int idPlane = 0;
if (cvxPartPlaneAdd(&plane, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: failed to create a datum plane!");
}
void zwTestPartPlaneAdd3()
/*
DESCRIPTION:
Test case3 for function cvxPartPlaneAdd.
*/
{
/* evxNewPlaneMethods = VX_NEW_PLANE_DYNAMIC */
svxNewPlaneData plane;
if (cvxPartPlaneAddInit(VX_NEW_PLANE_DYNAMIC, &plane))
zwTestLogErrorMsg(5, "cvxPartPlaneAddInit: failed to initialize a datum plane!");
svxPntByOffset posPntByOffset = { 0 };
cvxPartPntByOffsetInit(&posPntByOffset, 0);
svxPntBy2Lines posPntBy2Lines = { 0 };
cvxPartPntBy2LinesInit(&posPntBy2Lines, 1);
/* position point */
double val = 0;
cvxGetNumber("select position point type: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
cvxGetPoint("select position point.", VX_INP_PNT_GENERAL, 0, &plane.inpUnion.dynamic.posPnt, nullptr);
break;
case 1:
cvxGetPoint(
"select origin point", VX_INP_PNT_GENERAL, 0, &posPntByOffset.pntOnEnt.pnt, &posPntByOffset.pntOnEnt.idEnt);
cvxGetNumber("specify X offset", &posPntByOffset.xOffset);
cvxGetNumber("specify Y offset", &posPntByOffset.yOffset);
cvxGetNumber("specify Z offset", &posPntByOffset.zOffset);
plane.inpUnion.dynamic.posPntByOffset = &posPntByOffset;
break;
case 2:
cvxGetEnt("select first line", VX_INP_EDGE_OR_CURVE, 0, &posPntBy2Lines.pntOnCrv1.idEnt);
cvxGetEnt("select second line", VX_INP_EDGE_OR_CURVE, 0, &posPntBy2Lines.pntOnCrv2.idEnt);
cvxGetNumber("specify first distance", &posPntBy2Lines.dDst1);
cvxGetNumber("specify second distance", &posPntBy2Lines.dDst2);
plane.inpUnion.dynamic.posPntBy2Lines = &posPntBy2Lines;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
cvxGetPoint("select X axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.xAxis, nullptr);
cvxGetPoint("select Y axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.yAxis, nullptr);
cvxGetPoint("select Z axis direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&plane.inpUnion.dynamic.zAxis, nullptr);
cvxGetNumber("whether use auto orientation: 0 or 1, 1 as default", &val); /* 1 as default */
if (int(val + 0.5) == 0)
plane.inpUnion.dynamic.autoOrient = 0;
/* create a datum plane */
int idPlane = 0;
if (cvxPartPlaneAdd(&plane, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: failed to create a datum plane!");
}
void zwTestPartPlaneAdd4()
/*
DESCRIPTION:
Test case4 for function cvxPartPlaneAdd.
*/
{
/* evxNewPlaneMethods = VX_NEW_PLANE_GEOMETRY, VX_NEW_PLANE_OFFSET_PLANE,
VX_NEW_PLANE_ANGLE_FACE or VX_NEW_PLANE_ON_CURVE */
evxNewPlaneMethods method;
double val = 0;
cvxGetNumber("select a plane method: 11 - 14", &val);
if (int(val + 0.5) == 11)
method = VX_NEW_PLANE_GEOMETRY;
else if (int(val + 0.5) == 12)
method = VX_NEW_PLANE_OFFSET_PLANE;
else if (int(val + 0.5) == 13)
method = VX_NEW_PLANE_ANGLE_FACE;
else
method = VX_NEW_PLANE_ON_CURVE;
svxNewPlaneData plane;
if (cvxPartPlaneAddInit(method, &plane))
zwTestLogErrorMsg(5, "cvxPartPlaneAddInit: failed to initialize a datum plane!");
switch (method)
{
case VX_NEW_PLANE_GEOMETRY:
cvxGetPointsOnEnts("select some geometry",
VX_INP_PNT_ON_ENTITY,
0,
&plane.inpUnion.geom.cnt,
&plane.inpUnion.geom.pnts,
&plane.inpUnion.geom.paths);
cvxGetNumber("specify angle, 45 as default", &plane.inpUnion.geom.angle);
cvxGetNumber("whether flip direction: 0 or 1", &val);
if (int(val + 0.5))
plane.isFlipDir = 1;
if (plane.inpUnion.geom.cnt == 1)
cvxGetNumber("specify offset", &plane.inpUnion.geom.offset);
break;
case VX_NEW_PLANE_OFFSET_PLANE:
cvxGetPointOnEnt(
"select a plane", VX_INP_PNT_ON_ANY_FACE, 0, &plane.inpUnion.pOffset.orgPnt, &plane.inpUnion.pOffset.path);
cvxGetNumber("specify offset", &plane.inpUnion.pOffset.offset);
break;
case VX_NEW_PLANE_ANGLE_FACE:
cvxGetPointOnEnt(
"select a face", VX_INP_PNT_ON_ANY_FACE, 0, &plane.inpUnion.angToFc.orgPnt, &plane.inpUnion.angToFc.path);
cvxGetPointOnEnt("select an axis",
VX_INP_PNT_ON_CURVE_OR_EDGE,
0,
&plane.inpUnion.angToFc.axis,
&plane.inpUnion.angToFc.linePath);
cvxGetNumber("specify angle, 45 as default", &plane.inpUnion.angToFc.angle);
break;
case VX_NEW_PLANE_ON_CURVE:
cvxGetEntPath("select a curve", VX_INP_EDGE_OR_CURVE, 0, &plane.inpUnion.onCrv.path);
cvxGetNumber("1-use percent, 2-use distance", &val); /* 1 as default */
if (int(val + 0.5) == 2)
plane.inpUnion.onCrv.isPercent = 2;
cvxGetNumber("specify percentage or distance", &plane.inpUnion.onCrv.num);
cvxGetNumber("select direction type: 0 - 3", &val); /* VX_ONCRV_PERPENDICULAR as default */
if (int(val + 0.5) == 0)
plane.inpUnion.onCrv.dirType = VX_ONCRV_TANGENT;
else if (int(val + 0.5) == 2)
plane.inpUnion.onCrv.dirType = VX_ONCRV_PERPENDICULAR_TO_CURVE;
else if (int(val + 0.5) == 3)
plane.inpUnion.onCrv.dirType = VX_ONCRV_TANGENT_TO_CURVE;
if (plane.inpUnion.onCrv.dirType == VX_ONCRV_PERPENDICULAR_TO_CURVE ||
plane.inpUnion.onCrv.dirType == VX_ONCRV_TANGENT_TO_CURVE)
cvxGetEntPath("select a curve", VX_INP_EDGE_OR_CURVE, 0, &plane.inpUnion.onCrv.CrvPath);
cvxGetNumber("whether flip direction: 0 or 1", &val);
if (int(val + 0.5))
plane.isFlipDir = 1;
break;
default:
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: invalid option!");
break;
}
/* orientation option */
if (plane.inpUnion.geom.cnt > 1 || plane.method == VX_NEW_PLANE_ANGLE_FACE || plane.method == VX_NEW_PLANE_ON_CURVE)
cvxGetNumber("specify offset", &plane.dOffset);
svxPoint orgPnt = { 0 }, xPoint = { 0 };
plane.orgPnt = &orgPnt;
plane.xPoint = &xPoint;
cvxGetPoint("select origin point", VX_INP_PNT_GENERAL, 0, &orgPnt, nullptr);
cvxGetPoint("select X point", VX_INP_PNT_GENERAL, 0, &xPoint, nullptr);
if (plane.method != VX_NEW_PLANE_OFFSET_PLANE)
cvxGetNumber("specify X angle", &plane.xAng);
cvxGetNumber("specify Y angle", &plane.yAng);
cvxGetNumber("specify Z angle", &plane.zAng);
/* create a datum plane */
int idPlane = 0;
if (cvxPartPlaneAdd(&plane, &idPlane) || idPlane == 0)
zwTestLogErrorMsg(5, "cvxPartPlaneAdd: failed to create a datum plane!");
/* free memory */
if (plane.method == VX_NEW_PLANE_GEOMETRY)
{
cvxMemFree((void**)&plane.inpUnion.geom.pnts);
cvxMemFree((void**)&plane.inpUnion.geom.paths);
}
}
void zwTestPartActiveAsLCS()
/*
DESCRIPTION:
Test case for function cvxPartActiveAsLCS.
*/
{
/* select a CSYS as LCS */
int idEnt = 0;
cvxGetEnt("pick a CSYS as LCS", VX_INP_CSYS, 0, &idEnt);
/* activate it as LCS */
if (cvxPartActiveAsLCS(idEnt))
zwTestLogErrorMsg(5, "cvxPartActiveAsLCS: fail to active a datum/CSYS!");
}
evxNewPlaneMethods
evxNewPlaneMethods
New Plane Methods.
Definition: zwapi_cmd_datum_data.h:182
VX_NEW_PLANE_VIEW_PLANE
@ VX_NEW_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:184
VX_NEW_PLANE_GEOMETRY
@ VX_NEW_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:186
VX_NEW_PLANE_ON_CURVE
@ VX_NEW_PLANE_ON_CURVE
on curve
Definition: zwapi_cmd_datum_data.h:189
VX_NEW_PLANE_ANGLE_FACE
@ VX_NEW_PLANE_ANGLE_FACE
angle to face
Definition: zwapi_cmd_datum_data.h:188
VX_NEW_PLANE_THREE_POINTS
@ VX_NEW_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:183
VX_NEW_PLANE_OFFSET_PLANE
@ VX_NEW_PLANE_OFFSET_PLANE
offset plane
Definition: zwapi_cmd_datum_data.h:187
VX_NEW_PLANE_DYNAMIC
@ VX_NEW_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:185
VX_RESULTS_AXIS_Y
@ VX_RESULTS_AXIS_Y
Y direction.
Definition: zwapi_cmd_datum_data.h:339
VX_RESULTS_AXIS_X
@ VX_RESULTS_AXIS_X
X direction.
Definition: zwapi_cmd_datum_data.h:338
VX_RESULTS_AXIS_Z
@ VX_RESULTS_AXIS_Z
Z direction.
Definition: zwapi_cmd_datum_data.h:340
VX_PLANE_ALIGN_TO_XZ
@ VX_PLANE_ALIGN_TO_XZ
align to XZ of geometry frame
Definition: zwapi_cmd_datum_data.h:112
VX_PLANE_ALIGN_TO_YZ
@ VX_PLANE_ALIGN_TO_YZ
align to YZ of geometry frame
Definition: zwapi_cmd_datum_data.h:113
VX_PLANE_ALIGN_TO_XY
@ VX_PLANE_ALIGN_TO_XY
align to XY of geometry frame
Definition: zwapi_cmd_datum_data.h:111
VX_PLANE_DYNAMIC
@ VX_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:102
VX_PLANE_XY
@ VX_PLANE_XY
XY Plane.
Definition: zwapi_cmd_datum_data.h:97
VX_PLANE_VIEW_PLANE
@ VX_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:100
VX_PLANE_GEOMETRY
@ VX_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:95
VX_PLANE_YZ
@ VX_PLANE_YZ
YZ Plane.
Definition: zwapi_cmd_datum_data.h:99
VX_PLANE_XZ
@ VX_PLANE_XZ
XZ Plane.
Definition: zwapi_cmd_datum_data.h:98
VX_PLANE_TWO_ENTITIES
@ VX_PLANE_TWO_ENTITIES
two entities
Definition: zwapi_cmd_datum_data.h:101
VX_PLANE_THREE_POINTS
@ VX_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:96
VX_ONCRV_TANGENT_TO_CURVE
@ VX_ONCRV_TANGENT_TO_CURVE
tangent to curve
Definition: zwapi_cmd_datum_data.h:201
VX_ONCRV_PERPENDICULAR_TO_CURVE
@ VX_ONCRV_PERPENDICULAR_TO_CURVE
perpendicular to curve
Definition: zwapi_cmd_datum_data.h:200
VX_ONCRV_TANGENT
@ VX_ONCRV_TANGENT
tangent
Definition: zwapi_cmd_datum_data.h:198
VX_CSYS_THREE_FACES
@ VX_CSYS_THREE_FACES
three faces
Definition: zwapi_cmd_datum_data.h:326
VX_CSYS_GEOMETRY
@ VX_CSYS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:329
VX_CSYS_DYNAMIC
@ VX_CSYS_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:325
VX_CSYS_PLANE_PNT_AND_DIR
@ VX_CSYS_PLANE_PNT_AND_DIR
plane point and direction
Definition: zwapi_cmd_datum_data.h:328
VX_CSYS_ONLY_MATRIX
@ VX_CSYS_ONLY_MATRIX
only input CSYS matrix
Definition: zwapi_cmd_datum_data.h:324
VX_CSYS_PNT_AND_TWO_DIR
@ VX_CSYS_PNT_AND_TWO_DIR
point and two directions
Definition: zwapi_cmd_datum_data.h:327
VX_CSYS_THREE_POINTS
@ VX_CSYS_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:323
VX_AXIS_GEOMETRY
@ VX_AXIS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:35
VX_AXIS_INTERSECT_FACES
@ VX_AXIS_INTERSECT_FACES
intersect faces
Definition: zwapi_cmd_datum_data.h:42
VX_AXIS_TWO_PNT
@ VX_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_datum_data.h:40
VX_AXIS_FACE_CENTER
@ VX_AXIS_FACE_CENTER
face center axis
Definition: zwapi_cmd_datum_data.h:36
VX_AXIS_YY
@ VX_AXIS_YY
Y Axis.
Definition: zwapi_cmd_datum_data.h:38
VX_AXIS_PNT_DIR
@ VX_AXIS_PNT_DIR
point and Direction
Definition: zwapi_cmd_datum_data.h:41
VX_AXIS_XX
@ VX_AXIS_XX
X Axis.
Definition: zwapi_cmd_datum_data.h:37
VX_AXIS_ZZ
@ VX_AXIS_ZZ
Z Axis.
Definition: zwapi_cmd_datum_data.h:39
cvxPartPlaneNew
evxErrors cvxPartPlaneNew(svxPlaneData *Plane, int *idPlane)
cvxPartPlnCrv
evxErrors cvxPartPlnCrv(int idCrv, svxPoint *Origin, svxPoint *Xaxis, int *idPln)
cvxPartNewDatum
evxErrors cvxPartNewDatum(svxMatrix *Frame, int *idDatum)
cvxPartPlnSrf2
evxErrors cvxPartPlnSrf2(int idFace, svxPoint *Origin, svxPoint *XZ, int Flip, int *idPln)
cvxPartCSYSNew
evxErrors cvxPartCSYSNew(svxCSYSData *CSYS, int *idCSYS)
cvxPartPlnSrf
evxErrors cvxPartPlnSrf(int idFace, svxPoint *Origin, int *idPln)
cvxPartCSYSNewInit
evxErrors cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData *data)
cvxPartDatum
evxErrors cvxPartDatum(svxMatrix *Frame, int *idDatum)
cvxPartDatum2
evxErrors cvxPartDatum2(svxMatrix *Frame, int iCode, int *idDatum)
cvxPartActiveAsLCS
evxErrors cvxPartActiveAsLCS(int id)
cvxPartPlnCrv2
evxErrors cvxPartPlnCrv2(int idCrv, svxData *Origin, svxData *Xaxis, int Flip, int *idPln)
cvxPartAxisNew
evxErrors cvxPartAxisNew(svxAxisData *Axis, int *idAxis)
cvxPartPlaneAdd
evxErrors cvxPartPlaneAdd(const svxNewPlaneData *plane, int *idPlane)
cvxPartPlaneAddInit
evxErrors cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData *data)
cvxPartPntByOffsetInit
evxErrors cvxPartPntByOffsetInit(svxPntByOffset *data, int useCirPnt)
cvxPartPntBy2LinesInit
evxErrors cvxPartPntBy2LinesInit(svxPntBy2Lines *data, int useCirPnt)
cvxEntPnt
evxErrors cvxEntPnt(int idEntity, svxPoint *Pnt)
cvxMatTranslate
void cvxMatTranslate(svxMatrix *Mat, double dX, double dY, double dZ)
cvxPntDist
double cvxPntDist(const svxPoint *Point1, const svxPoint *Point2)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetPointsOnEnts
evxErrors cvxGetPointsOnEnts(const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CRV_OR_PROF
@ VX_INP_PNT_ON_CRV_OR_PROF
point on curve or profile
Definition: zwapi_userinput.h:88
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CSYS
@ VX_INP_CSYS
pick CSYS
Definition: zwapi_userinput.h:64
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
svxAxisData::evxAxisInpUnion::AxisFaceCenter::Face
svxEntPath Face
face
Definition: zwapi_cmd_datum_data.h:68
svxAxisData::evxAxisInpUnion::AxisGeomPnt::Path
svxEntPath Path
entity/object pick path
Definition: zwapi_cmd_datum_data.h:64
svxAxisData::evxAxisInpUnion::AxisGeomPnt::Pnt
svxPoint Pnt
picked Point
Definition: zwapi_cmd_datum_data.h:63
svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face2
svxEntPath Face2
2nd face
Definition: zwapi_cmd_datum_data.h:73
svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face1
svxEntPath Face1
1st face
Definition: zwapi_cmd_datum_data.h:72
svxAxisData::evxAxisInpUnion::AxisPntAndDir::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:58
svxAxisData::evxAxisInpUnion::AxisPntAndDir::Dir
svxVector Dir
direction
Definition: zwapi_cmd_datum_data.h:59
svxAxisData::evxAxisInpUnion::AxisPntAndDir::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:57
svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt2
svxPoint Pnt2
2nd point
Definition: zwapi_cmd_datum_data.h:80
svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt2
int idPnt2
id of the point2 parent entity
Definition: zwapi_cmd_datum_data.h:79
svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt1
int idPnt1
id of the point1 parent entity
Definition: zwapi_cmd_datum_data.h:77
svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt1
svxPoint Pnt1
1st point
Definition: zwapi_cmd_datum_data.h:78
svxAxisData::length
double length
axis length
Definition: zwapi_cmd_datum_data.h:51
svxAxisData::FlipDir
int FlipDir
flip direction
Definition: zwapi_cmd_datum_data.h:83
svxAxisData::method
evxAxisMethods method
axis methods
Definition: zwapi_cmd_datum_data.h:52
svxAxisData
template command Axis input data
Definition: zwapi_cmd_datum_data.h:50
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::cnt
int cnt
count of OrgPnts and Paths.
Definition: zwapi_cmd_datum_data.h:361
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::zOffset
double zOffset
z offset
Definition: zwapi_cmd_datum_data.h:369
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnts
svxPoint * OrgPnts
origin points
Definition: zwapi_cmd_datum_data.h:362
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::offsetFirst
int offsetFirst
0 is offset first,else 1.default:0
Definition: zwapi_cmd_datum_data.h:366
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::yOffset
double yOffset
y offset
Definition: zwapi_cmd_datum_data.h:368
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Paths
svxEntPath * Paths
entity/object pick paths
Definition: zwapi_cmd_datum_data.h:363
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::xOffset
double xOffset
x offset
Definition: zwapi_cmd_datum_data.h:367
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::firstAxis
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:372
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::secondAxis
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:373
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Xaxis
svxVector Xaxis
A axis.
Definition: zwapi_cmd_datum_data.h:464
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Zaxis
svxVector Zaxis
Z axis.
Definition: zwapi_cmd_datum_data.h:466
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::idPosPnt
int idPosPnt
id of the position parent entity
Definition: zwapi_cmd_datum_data.h:457
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::isAutoOrint
int isAutoOrint
1 is auto orientation,else 0.default:1
Definition: zwapi_cmd_datum_data.h:467
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntBy2Lines
svxPntBy2Lines * PosPntBy2Lines
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntByOffset) c...
Definition: zwapi_cmd_datum_data.h:462
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntByOffset
svxPntByOffset * PosPntByOffset
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntBy2Lines) c...
Definition: zwapi_cmd_datum_data.h:459
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Yaxis
svxVector Yaxis
Y axis.
Definition: zwapi_cmd_datum_data.h:465
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPnt
svxPoint PosPnt
position point
Definition: zwapi_cmd_datum_data.h:458
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Face
svxEntPath Face
face
Definition: zwapi_cmd_datum_data.h:441
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::DirOnEnt
svxPntOnEnt DirOnEnt
direction."DirOnEnt.useDir" has to be equal to 1."DirOnEnt.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:452
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntByOffset
svxPntByOffset * PntByOffset
set the point by the offset sub-command (NULL to use (idPnt, Pnt) or PntBy2Lines) cvxPartPntByOffsetI...
Definition: zwapi_cmd_datum_data.h:446
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Pnt
svxPoint Pnt
point
Definition: zwapi_cmd_datum_data.h:445
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::idPnt
int idPnt
id of the point parent entity
Definition: zwapi_cmd_datum_data.h:444
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::isFlipFc
int isFlipFc
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:443
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisFc
evsResultsAxisMethod axisFc
axis(default:VX_RESULTS_AXIS_Z)
Definition: zwapi_cmd_datum_data.h:442
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntBy2Lines
svxPntBy2Lines * PntBy2Lines
set the point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or PntByOffset) cvxPartPntBy2...
Definition: zwapi_cmd_datum_data.h:449
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisDir
evsResultsAxisMethod axisDir
axis(default:VX_RESULTS_AXIS_X).The two axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:453
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis2
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y).The two axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:437
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:421
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt2
svxPntOnEnt DirOnEnt2
direction2."DirOnEnt2.useDir" has to be equal to 1."DirOnEnt2.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:436
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis1
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:432
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt1
svxPntOnEnt DirOnEnt1
direction1."DirOnEnt1.useDir" has to be equal to 1."DirOnEnt1.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:431
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntByOffset
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cv...
Definition: zwapi_cmd_datum_data.h:424
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntBy2Lines
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffse...
Definition: zwapi_cmd_datum_data.h:427
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:422
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face3
svxEntPath Face3
face3
Definition: zwapi_cmd_datum_data.h:415
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face1
svxEntPath Face1
face1
Definition: zwapi_cmd_datum_data.h:407
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face2
svxEntPath Face2
face2
Definition: zwapi_cmd_datum_data.h:411
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis3
evsResultsAxisMethod axis3
axis3(default:VX_RESULTS_AXIS_Z).The three axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:416
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis2
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y)
Definition: zwapi_cmd_datum_data.h:412
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis1
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:408
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip1
int isFlip1
1 is flip,else 0. default:0.
Definition: zwapi_cmd_datum_data.h:409
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip2
int isFlip2
1 is flip,else 0. default:0.
Definition: zwapi_cmd_datum_data.h:413
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:377
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntByOffset
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cv...
Definition: zwapi_cmd_datum_data.h:379
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1ByOffset
svxPntByOffset * Pnt1ByOffset
set the point1 by the offset sub-command (NULL to use (idPnt1, Pnt1) or Pnt1By2Lines) cvxPartPntByOff...
Definition: zwapi_cmd_datum_data.h:387
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntBy2Lines
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffse...
Definition: zwapi_cmd_datum_data.h:382
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2ByOffset
svxPntByOffset * Pnt2ByOffset
set the origin point by the offset sub-command (NULL to use (idPnt2, Pnt2) or Pnt2By2Lines) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:397
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:378
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt1
int idPnt1
id of the point1 parent entity
Definition: zwapi_cmd_datum_data.h:385
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip1
int isFlip1
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:393
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2
svxPoint Pnt2
Point2.
Definition: zwapi_cmd_datum_data.h:396
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::firstAxis
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:392
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1By2Lines
svxPntBy2Lines * Pnt1By2Lines
set the point2 by the from 2 lines sub-command (NULL to use (idPnt1, Pnt1) or Pnt1ByOffset) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:390
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1
svxPoint Pnt1
point1
Definition: zwapi_cmd_datum_data.h:386
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip2
int isFlip2
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:403
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::secondAxis
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:402
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt2
int idPnt2
id of the point2 parent entity
Definition: zwapi_cmd_datum_data.h:395
svxCSYSData::XAng
double XAng
angle value X direction
Definition: zwapi_cmd_datum_data.h:477
svxCSYSData::dOffset
double dOffset
offset value
Definition: zwapi_cmd_datum_data.h:472
svxCSYSData::XPnt
svxPoint XPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:476
svxCSYSData::ZAng
double ZAng
angle value Z direction
Definition: zwapi_cmd_datum_data.h:479
svxCSYSData::idXPnt
int idXPnt
id of the XPoint parent entity
Definition: zwapi_cmd_datum_data.h:475
svxCSYSData::Frame
svxMatrix Frame
transformation matrix
Definition: zwapi_cmd_datum_data.h:349
svxCSYSData::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:473
svxCSYSData::OrgPnt
svxPoint OrgPnt
origin
Definition: zwapi_cmd_datum_data.h:474
svxCSYSData::YAng
double YAng
angle value Y direction
Definition: zwapi_cmd_datum_data.h:478
svxCSYSData
template command CSYS input data
Definition: zwapi_cmd_datum_data.h:348
svxData::Pnt
svxPoint Pnt
point coordinates
Definition: zwapi_util.h:1583
svxData::isPoint
char isPoint
1 if "Pnt" is defined, else 0
Definition: zwapi_util.h:1557
svxData
command input data item
Definition: zwapi_util.h:1555
svxEntPath::Count
int Count
number of id's in the path
Definition: zwapi_util.h:269
svxEntPath::Id
int Id[V_PP_LEN]
list of id's that define the path to an entity Id[0] = -1; path begins with top-level parent file/o...
Definition: zwapi_util.h:270
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMatrix::xt
double xt
cosines of X axis and origin X (xt)
Definition: zwapi_util.h:481
svxMatrix::zt
double zt
cosines of Z axis and origin Z (zt)
Definition: zwapi_util.h:483
svxMatrix::yt
double yt
cosines of Y axis and origin Y (yt)
Definition: zwapi_util.h:482
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::angle
double angle
angle (default: 45)
Definition: zwapi_cmd_datum_data.h:286
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::linePath
svxEntPath linePath
line or edge path
Definition: zwapi_cmd_datum_data.h:285
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::orgPnt
svxPoint orgPnt
origin on "path"
Definition: zwapi_cmd_datum_data.h:282
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::path
svxEntPath path
face path
Definition: zwapi_cmd_datum_data.h:283
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::axis
svxPoint axis
point on line(or edge)
Definition: zwapi_cmd_datum_data.h:284
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::yAxis
svxVector yAxis
Y Axis.
Definition: zwapi_cmd_datum_data.h:270
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::xAxis
svxVector xAxis
X Axis.
Definition: zwapi_cmd_datum_data.h:269
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPnt
svxPoint posPnt
position
Definition: zwapi_cmd_datum_data.h:263
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntBy2Lines
svxPntBy2Lines * posPntBy2Lines
set the position point by the from 2 lines sub-command (NULL to use posPnt or PosPntByOffset) cvxPart...
Definition: zwapi_cmd_datum_data.h:267
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::autoOrient
int autoOrient
1 if auto orientation, else 0
Definition: zwapi_cmd_datum_data.h:272
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::zAxis
svxVector zAxis
Z Axis.
Definition: zwapi_cmd_datum_data.h:271
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntByOffset
svxPntByOffset * posPntByOffset
set the position point by the offset sub-command (NULL to use posPnt or PosPntBy2Lines) cvxPartPntByO...
Definition: zwapi_cmd_datum_data.h:264
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::cnt
int cnt
count of pnts and paths
Definition: zwapi_cmd_datum_data.h:221
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::paths
svxEntPath * paths
entity/object pick paths
Definition: zwapi_cmd_datum_data.h:223
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::offset
double offset
offset the new datum from the target geometry
Definition: zwapi_cmd_datum_data.h:226
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::angle
double angle
angle (default: 45)
Definition: zwapi_cmd_datum_data.h:227
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnts
svxPoint * pnts
picked points
Definition: zwapi_cmd_datum_data.h:222
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::orgPnt
svxPoint orgPnt
origin on "path"
Definition: zwapi_cmd_datum_data.h:276
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::offset
double offset
offset
Definition: zwapi_cmd_datum_data.h:278
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::path
svxEntPath path
face path
Definition: zwapi_cmd_datum_data.h:277
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::dirType
evxOnCrvDirType dirType
direction type
Definition: zwapi_cmd_datum_data.h:294
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::isPercent
int isPercent
1 if use percent, 2 if use distance
Definition: zwapi_cmd_datum_data.h:292
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::path
svxEntPath path
Curve C path.
Definition: zwapi_cmd_datum_data.h:291
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::num
double num
if isPercent = 1, num is Percent; if isPercent = 2, num is distance.
Definition: zwapi_cmd_datum_data.h:293
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::CrvPath
svxEntPath CrvPath
Curve path.
Definition: zwapi_cmd_datum_data.h:295
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPnt
svxPoint xPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:238
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPnt
svxPoint orgPnt
origin
Definition: zwapi_cmd_datum_data.h:231
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntByOffset
svxPntByOffset * xPntByOffset
set the XPoint by the offset sub-command (NULL to use xPnt or xPntBy2Lines) cvxPartPntByOffsetInit() ...
Definition: zwapi_cmd_datum_data.h:239
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntBy2Lines
svxPntBy2Lines * xPntBy2Lines
set the XPoint by the from 2 lines sub-command (NULL to use xPnt or xPntByOffset) cvxPartPntBy2LinesI...
Definition: zwapi_cmd_datum_data.h:242
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPnt
svxPoint yPnt
YPoint.
Definition: zwapi_cmd_datum_data.h:245
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntBy2Lines
svxPntBy2Lines * yPntBy2Lines
set the YPoint by the from 2 lines sub-command (NULL to use yPnt or yPntByOffset) cvxPartPntBy2LinesI...
Definition: zwapi_cmd_datum_data.h:249
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntBy2Lines
svxPntBy2Lines * orgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:235
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntByOffset
svxPntByOffset * orgPntByOffset
set the origin point by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOff...
Definition: zwapi_cmd_datum_data.h:232
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntByOffset
svxPntByOffset * yPntByOffset
set the YPoint by the offset sub-command (NULL to use yPnt or yPntBy2Lines) cvxPartPntByOffsetInit() ...
Definition: zwapi_cmd_datum_data.h:246
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntByOffset
svxPntByOffset * orgPntByOffset
set the origin by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetIni...
Definition: zwapi_cmd_datum_data.h:255
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntBy2Lines
svxPntBy2Lines * orgPntBy2Lines
set the origin by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2Li...
Definition: zwapi_cmd_datum_data.h:258
svxNewPlaneData::yAng
double yAng
angle value Y direction
Definition: zwapi_cmd_datum_data.h:310
svxNewPlaneData::xPoint
svxPoint * xPoint
X point (NULL to ignore)
Definition: zwapi_cmd_datum_data.h:308
svxNewPlaneData::isFlipDir
int isFlipDir
1 if flip direction, else 0 method = VX_NEW_PLANE_GEOMETRY, VX_NEW_PLANE_THREE_POINTS,...
Definition: zwapi_cmd_datum_data.h:300
svxNewPlaneData::zAng
double zAng
angle value Z direction
Definition: zwapi_cmd_datum_data.h:311
svxNewPlaneData::xAng
double xAng
angle value X direction
Definition: zwapi_cmd_datum_data.h:309
svxNewPlaneData::orgPnt
svxPoint * orgPnt
origin (NULL to ignore)
Definition: zwapi_cmd_datum_data.h:307
svxNewPlaneData::dOffset
double dOffset
offset
Definition: zwapi_cmd_datum_data.h:306
svxNewPlaneData::method
evxNewPlaneMethods method
methods
Definition: zwapi_cmd_datum_data.h:210
svxNewPlaneData
New template command Plane input data.
Definition: zwapi_cmd_datum_data.h:209
svxPlaneData
template command Plane input data
Definition: zwapi_cmd_datum_data.h:121
svxPntBy2Lines::dDst1
double dDst1
distance from the first edge/line
Definition: zwapi_cmd_subcmd_data.h:48
svxPntBy2Lines::pntOnCrv1
svxPntOnEnt pntOnCrv1
point on first edge/line
Definition: zwapi_cmd_subcmd_data.h:46
svxPntBy2Lines::dDst2
double dDst2
distance from the second edge/line
Definition: zwapi_cmd_subcmd_data.h:49
svxPntBy2Lines::pntOnCrv2
svxPntOnEnt pntOnCrv2
point on second edge/line
Definition: zwapi_cmd_subcmd_data.h:47
svxPntBy2Lines
the data to get the point by From 2 Lines command
Definition: zwapi_cmd_subcmd_data.h:45
svxPntByOffset::yOffset
double yOffset
y offset value
Definition: zwapi_cmd_subcmd_data.h:36
svxPntByOffset::zOffset
double zOffset
z offset value
Definition: zwapi_cmd_subcmd_data.h:37
svxPntByOffset::pntOnEnt
svxPntOnEnt pntOnEnt
point on entity
Definition: zwapi_cmd_subcmd_data.h:34
svxPntByOffset::xOffset
double xOffset
x offset value
Definition: zwapi_cmd_subcmd_data.h:35
svxPntByOffset
the data to get the point by Offset command
Definition: zwapi_cmd_subcmd_data.h:33
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPoint
3D point
Definition: zwapi_util.h:306
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\freeFormFtrCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\freeFormFtrCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include "string.h"
ApiDefVoidFunc(zwTestPartFaceOffset, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFacesOffset, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFacesetSew, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartTrimToCrvs, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartTrimToFaces, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartTrimmedPlane, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartExtendFace, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartNSided, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartExplode, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartRuled, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCircularBiRail, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartConicBiRail, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartEnlargeFace, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartExtendShape, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSplitWithCrv, VX_CODE_GENERAL);
void zwTestPartFaceOffset()
/*
DESCRIPTION:
Test case for function cvxPartFaceOffset.
*/
{
/* offset a surface */
int idFace = 0;
cvxGetEnt("[Face]Select a surface to offset", VX_INP_FACE, 0, &idFace);
double distance = 10;
double val = 0.0;
cvxGetNumber("[Keep original surface]Whether to keep original surface(1: yes; 0: no)", &val);
int keepSrf = 0;
if (int(val + 0.5))
keepSrf = 1;
if (cvxPartFaceOffset(idFace, distance, keepSrf))
zwTestLogErrorMsg(5, "cvxPartFaceOffset: failed to offset the surface!");
}
void zwTestPartFacesOffset()
/*
DESCRIPTION:
Test case for function cvxPartFacesOffset.
*/
{
/* initialize surface offset */
svxFcsOffsetData surfacesOffset;
if (cvxPartFacesOffsetInit(&surfacesOffset))
zwTestLogErrorMsg(5, "cvxPartFacesOffsetInit: failed to initialize surfaces offset!");
/* set offset faces and offset value */
cvxGetEnts("[Faces]Select some surfaces to offset, then click the middle button to end the selection",
VX_INP_FACE,
0,
&surfacesOffset.count,
&surfacesOffset.faces);
surfacesOffset.offset = 10;
/* whether to keep original surface */
double val = 0.0;
cvxGetNumber("[Keep original surface]Whether to keep original surface(1: yes; 0: no)", &val);
if (int(val + 0.5) == 0)
surfacesOffset.keepSurface = 0;
/* whether to keep edge connectivity */
cvxGetNumber("[Keep edge connectivity]Whether to keep edge connectivity(1: yes; 0: no)", &val);
if (int(val + 0.5) == 0)
surfacesOffset.keepEdge = 0;
/* add variable offset */
svxFcsOffsetData::svxVarOffset varPnt = { 0 };
cvxGetPoint("[Variable Offset]Select a point on selected faces to add variable offset, skip the selection by "
"clicking the middle button",
VX_INP_PNT_ON_ANY_FACE,
1,
&varPnt.pntOnEnt.pnt,
&varPnt.pntOnEnt.idEnt);
if (varPnt.pntOnEnt.idEnt > 0)
{
varPnt.pntOffset = 15;
surfacesOffset.cnt = 1;
surfacesOffset.list = &varPnt;
}
int idFtr = 0;
if (cvxPartFacesOffset(&surfacesOffset, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartFacesOffset: failed to add surfaces offset!");
/* free memory */
cvxMemFree((void**)&surfacesOffset.faces);
}
void zwTestPartFacesetSew()
/*
DESCRIPTION:
Test case for function cvxPartFacesetSew.
*/
{
/* initialize sew */
svxSewData sew;
if (cvxPartFacesetSewInit(&sew))
zwTestLogErrorMsg(5, "cvxPartFacesetSewInit: failed to initialize!");
int countShapes = 0;
int* idShapes = nullptr;
cvxGetEnts("[Shapes]Select some shapes to sew, then click the middle button to end the selection",
VX_INP_SHAPE,
0,
&countShapes,
&idShapes);
/* enable multiple edge matching */
double val = 0.0;
cvxGetNumber("[Enable multiple edge matching]the default is enable, enter number 1 to disable", &val);
if (int(val + 0.5))
sew.multEdg = 0;
/* whether to force object to sew into solid */
cvxGetNumber("[Force object to sew into solid]the default is disable, enter number 1 to enable", &val);
if (int(val + 0.5))
sew.forceClose = 1;
/* sew shapes */
int idFtr = 0;
if (cvxPartFacesetSew(countShapes, idShapes, &sew, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartFacesetSew: failed to sew shapes!");
/* free memory */
cvxMemFree((void**)&idShapes);
}
void zwTestPartTrimToCrvs()
/*
DESCRIPTION:
Test case for function cvxPartTrimToCrvs.
*/
{
svxTrimToCurvesData trim = {};
/* select face to trim and trim curves */
cvxGetEnts("[Faces]Select faces or shapes to be trimmed, <middle-click> when done",
VX_INP_FACE,
0,
&trim.cntFcs,
&trim.idFaces);
cvxGetEnts("[Curves]Select trimming curves on faces, <middle-click> when done",
VX_INP_CURVE,
0,
&trim.cntCrvs,
&trim.idCurves);
double val = 0.0;
cvxGetNumber("[Faces to remove]Whether to remove trimmed regions(1: remove; 0: keep)", &val);
trim.toKeep = (int(val + 0.5) == 1 ? 1 : 0);
svxPntOnEnt pntOnEnt = {};
zwUtilGetPntOrDirOnEnt(0, &pntOnEnt);
trim.cntPnts = 1;
trim.sides = &pntOnEnt;
cvxGetNumber("[Projection]Select project method(0: in place; 1: face normal; 2: directed; 3: bi-directional)", &val);
switch (int(val + 0.5))
{
case 1: trim.projection = VX_TRIMCRV_FACE_NORMAL; break;
case 2: trim.projection = VX_TRIMCRV_DIRECTED; break;
case 3: trim.projection = VX_TRIMCRV_BI_DIRECTIONAL; break;
default: trim.projection = VX_TRIMCRV_IN_PLACE; break;
}
svxPoint prjDir = {};
if (trim.projection == VX_TRIMCRV_DIRECTED || trim.projection == VX_TRIMCRV_BI_DIRECTIONAL)
{
cvxGetPoint("[Direction]Select projection direction", VX_INP_PNT_DIRECTION, 0, &prjDir, NULL);
trim.dirction = (svxVector*)&prjDir;
}
cvxGetNumber("[Trim to Checkerboard]Whether to trim to checkerboard(1: enable; 0: disable)", &val);
trim.isCheckerboard = (int(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Extend Curves to Boundary]Whether to extend curves to boundary(1: enable; 0: disable)", &val);
trim.isExtend = (int(val + 0.5) == 1 ? 1 : 0);
/* trim face */
int idFtr = 0;
if (cvxPartTrimToCrvs(&trim, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartTrimToCrvs: failed to trim face!");
/* free memory */
cvxMemFree((void**)&trim.idFaces);
cvxMemFree((void**)&trim.idCurves);
}
void zwTestPartTrimToFaces()
/*
DESCRIPTION:
Test case for function cvxPartTrimToFaces.
*/
{
svxTrimToFacesData trim = {};
if (cvxPartTrimToFacesInit(&trim))
zwTestLogErrorMsg(5, "cvxPartTrimToFacesInit: failed to initialize!");
/* select face to trim and trim faces */
cvxGetEnts("[Faces]Select faces or shapes to be trimmed, <middle-click> when done",
VX_INP_FACE,
0,
&trim.numFace,
&trim.pFace);
cvxGetEnts("[Curves]Select trimming curves on faces, <middle-click> when done",
VX_INP_FACE,
0,
&trim.numTrimming,
&trim.pTrimming);
double val = 0.0;
cvxGetNumber("[Flip side to keep]Whether llip side to keep(1: enable; 0: disable)", &val);
trim.FlipSide = (int(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Trim with all simultaneously]Whether to trim with all simultaneously(1: enable; 0: disable)", &val);
trim.TrimWith = (int(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Extend trimming faces]Whether to extend trimming faces(1: enable; 0: disable)", &val);
trim.ExtendTrimming = (int(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Keep trimming faces]Whether to keep trimming faces(1: enable; 0: disable)", &val);
trim.KeepTrimming = (int(val + 0.5) == 1 ? 1 : 0);
/* trim face */
int idFtr = 0;
if (cvxPartTrimToFaces(&trim, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartTrimToFaces: failed to trim face!");
/* free memory */
cvxMemFree((void**)&trim.pFace);
cvxMemFree((void**)&trim.pTrimming);
}
void zwTestPartTrimmedPlane()
/*
DESCRIPTION:
Test case for function cvxPartTrimmedPlane.
*/
{
/* initialize a trimmed plane and pick boundary curve(s) */
svxTrimPlnData trimPln;
if (cvxPartTrimmedPlaneInit(&trimPln))
zwTestLogErrorMsg(5, "cvxPartTrimmedPlaneInit: failed to initialize a planar face!");
cvxGetEnts("select boundary curve(s), <middle-click> when done", VX_INP_PROF, 0, &trimPln.cntCrv, &trimPln.pCrvList);
double val = 0;
cvxGetNumber("whether sew shapes: 0 or 1", &val); /* 1 as default*/
if (int(val + 0.5))
cvxGetEnts("select shape(s) to sew, <middle-click> when done", VX_INP_SHAPE, 0, &trimPln.cntBool, &trimPln.pBooolList);
else
trimPln.sew = 0;
cvxGetEnt("select projection face, <middle click> for default", VX_INP_FACE, 1, &trimPln.idPlane);
/* create a trimmed plane */
int newShape = 0;
if (cvxPartTrimmedPlane(&trimPln, &newShape) || trimPln.sew == 0 && newShape == 0)
zwTestLogErrorMsg(5, "cvxPartTrimmedPlane: failed to create a planar face!");
/* free memory */
cvxMemFree((void**)&trimPln.pCrvList);
cvxMemFree((void**)&trimPln.pBooolList);
}
void zwTestPartExtendFace()
/*
DESCRIPTION:
Test case for function cvxPartExtendFace.
*/
{
/* initialize data */
svxExtendData extend;
if (cvxPartExtendFaceInit(&extend))
zwTestLogErrorMsg(5, "cvxPartExtendFaceInit: failed to extend a face!");
cvxGetEnt("select a face to extend", VX_INP_FACE, 0, &extend.idFace);
cvxGetEnts("select edge(s) on face to extend, <middle-click> when done", VX_INP_EDGE, 0, &extend.cntEdge, &extend.pEdgList);
cvxMemAlloc(extend.cntEdge * sizeof(double), (void**)&extend.pDistList);
for (int i = 0; i < extend.cntEdge; i++)
cvxGetNumber("specify extend distance", &extend.pDistList[i]);
double val = 0;
cvxGetNumber("whether merge extended face: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5))
{
cvxGetNumber("whether keep original face: 0 or 1", &val);
if (int(val + 0.5))
extend.iKeepFace = 1;
}
else
extend.iMerge = 0;
cvxGetNumber("select a extend method: 0, 1, 2 or 4", &val);
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
case 4:
extend.iExtension = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtendFace: invalid option!");
break;
}
/* extend the picked surface */
int newFtr = 0;
if (cvxPartExtendFace(&extend, &newFtr) || newFtr == 0)
zwTestLogErrorMsg(5, "cvxPartExtendFace: failed to extend a face!");
/* free the memory */
cvxMemFree((void**)&extend.pEdgList);
cvxMemFree((void**)&extend.pDistList);
}
void zwTestPartNSided()
/*
DESCRIPTION:
Test case for function cvxPartNSided.
*/
{
/* initialize data */
svxNSidedData NSided;
if (cvxPartNSidedInit(&NSided))
zwTestLogErrorMsg(5, "cvxPartNSidedInit: failed to initialize an entity!");
cvxGetEnts("select boundary edges/curves, <middle-click> when done", VX_INP_PROF, 0, &NSided.numCrv, &NSided.pCrv);
double val = 0;
cvxGetNumber("whether sew shades: 0 or 1", &val); /* 1 as default, since R2024, it doesn't sew the new shapes and if user set it to 1, it will create a 'Sew' feature to sew the shapes */
if (int(val + 0.5))
cvxGetEnts("select shade(s) to sew, <middle-click> when done", VX_INP_SHAPE, 0, &NSided.numShape, &NSided.pShape);
else
NSided.sewShape = 0;
cvxGetNumber("whether tangent at boundary: 0 or 1", &val);
if (int(val + 0.5))
NSided.tangent = 1;
cvxGetNumber("select refit option: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
NSided.refit = VX_REFIT_NO;
break;
case 1:
NSided.refit = VX_REFIT_TANGENT;
break;
case 2:
NSided.refit = VX_REFIT_CURVATURE;
break;
case 3:
NSided.refit = VX_REFIT_DIRECT;
break;
default:
break;
}
cvxGetNumber("specify tolerance: 0.01 as default", &NSided.dTol);
/* create an entity */
int idEnt = 0;
if (cvxPartNSided(&NSided, &idEnt) || NSided.sewShape == 0 && idEnt == 0)
zwTestLogErrorMsg(5, "cvxPartNSided: failed to create an entity!");
/* free memory */
cvxMemFree((void**)&NSided.pCrv);
cvxMemFree((void**)&NSided.pShape);
}
void zwTestPartExplode()
/*
DESCRIPTION:
Test case for function cvxPartExplode.
*/
{
/* initialize explode */
svxExplodeData explode = { 0 };
if (cvxPartExplodeInit(&explode))
zwTestLogErrorMsg(5, "cvxPartExplodeInit: failed to initialize an explode!");
cvxGetEnts("select some surfaces to explode, <middle-click> when done", VX_INP_FACE, 0, &explode.numFace, &explode.pFace);
double val = 0;
cvxGetNumber("whether group connected faces: 0 or 1", &val);
if (int(val + 0.5))
explode.ConnectFc = 1;
cvxGetNumber("whether rebuild edges along boundary: 0 or 1", &val); /* 1 as default */
if (int(val + 0.5) == 0)
explode.RebudEdge = 0;
/* explode surfaces */
int numShapes = 0;
int* idShapes = nullptr;
if (cvxPartExplode(&explode, &numShapes, &idShapes) || idShapes == nullptr)
zwTestLogErrorMsg(5, "cvxPartExplode: failed to explode surfaces!");
/* free memory */
cvxMemFree((void**)&explode.pFace);
cvxMemFree((void**)&idShapes);
}
void zwTestPartRuled()
/*
DESCRIPTION:
Test case for function cvxPartRuled.
*/
{
/* initialize data */
svxRuledData data = {};
if (cvxPartRuledInit(&data))
zwTestLogErrorMsg(5, "cvxPartRuledInit: failed to initialize data!");
cvxGetPointOnEnt("select the first curve", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.firstCrv.pnt, &data.firstCrv.entPath);
cvxGetPointOnEnt("select the second curve", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.secondCrv.pnt, &data.secondCrv.entPath);
cvxGetPointOnEnt("select spine, <middle-click> to ignore", VX_INP_PNT_ON_CURVE_OR_EDGE, 1, &data.spineCrv.pnt, &data.spineCrv.entPath);
double val = 0.0;
cvxGetNumber("whether to attempt trimmed plane: 0 or 1", &val);
data.trimPlane = int(val + 0.5);
int idFace = 0;
if (cvxPartRuled(&data,&idFace) || idFace == 0)
zwTestLogErrorMsg(5, "cvxPartRuled: failed to create a ruled surface!");
}
void zwTestPartCircularBiRail()
/*
DESCRIPTION:
Test case for function cvxPartCircularBiRail.
*/
{
double val = 0;
cvxGetNumber("select create method(0: constant, 1: variable, 2: center, 3: middle", &val);
evxCircularBiRailMethod method = VX_CIRCULARBIRAIL_CONSTANT;
switch (int(val))
{
case 1: method = VX_CIRCULARBIRAIL_VARIABLE; break;
case 2: method = VX_CIRCULARBIRAIL_CENTER; break;
case 3: method = VX_CIRCULARBIRAIL_MIDDLE; break;
default: break;
}
/* initialize data */
svxCircularBiRailData data = {};
if (cvxPartCircularBiRailInit(method, &data))
zwTestLogErrorMsg(5, "cvxPartCircularBiRailInit: failed to initialize data!");
/* Select curves */
cvxGetPointOnEnt("select point1", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.firstCrv.pnt, &data.firstCrv.entPath);
cvxGetPointOnEnt("select point2", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.secondCrv.pnt, &data.secondCrv.entPath);
cvxGetPointOnEnt("select spine, <middle-click> to ignore", VX_INP_PNT_ON_CURVE_OR_EDGE, 1, &data.spineCrv.pnt, &data.spineCrv.entPath);
svxRadiusSetData setdata = {};
switch (data.method)
{
case VX_CIRCULARBIRAIL_CONSTANT:
{
cvxGetDistance("input radius", &data.inpUnion.constant.radius);
cvxGetNumber("select solution (1 ~ 4)", &val);
data.inpUnion.constant.solution = int(val + 0.5);
break;
}
case VX_CIRCULARBIRAIL_VARIABLE:
{
cvxGetEnt("select a curve", VX_INP_EDGE_OR_CURVE, 0, &setdata.idCurve);
cvxGetPointOnEnt("select a point", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &setdata.pnt.pnt, &setdata.pnt.entPath);
cvxGetDistance("input radius", &setdata.radius);
cvxGetNumber("whether to radius locally flat: 0 or 1", &val);
setdata.radiusFlat = int(val + 0.5);
data.inpUnion.variable.pRadSet = &setdata;
data.inpUnion.variable.nRadSet = 1;
cvxGetNumber("select solution (1 ~ 4)", &val);
data.inpUnion.variable.solution = int(val + 0.5);
break;
}
case VX_CIRCULARBIRAIL_CENTER:
{
cvxGetPointOnEnt("select center", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.center.center.pnt, &data.inpUnion.center.center.entPath);
cvxGetNumber("select solution (1 ~ 4)", &val);
data.inpUnion.center.solution = int(val + 0.5);
break;
}
case VX_CIRCULARBIRAIL_MIDDLE:
{
cvxGetPointOnEnt("select middle", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.middle.middle.pnt, &data.inpUnion.middle.middle.entPath);
break;
}
default:
break;
}
int idFace = 0;
if (cvxPartCircularBiRail(&data, &idFace) || idFace == 0)
zwTestLogErrorMsg(5, "cvxPartCircularBiRail: failed to create a ruled surface!");
}
void zwTestPartConicBiRail()
/*
DESCRIPTION:
Test case for function cvxPartConicBiRail.
*/
{
double val = 0;
cvxGetNumber("select create method(0: constant, 1: variable, 2: holder, 3: tangent, 4: intersection, 5: center, 6: tangent edges", &val);
evxConicBiRailMethod method = VX_CONICBIRAIL_CONSTANT;
switch (int(val))
{
case 1: method = VX_CONICBIRAIL_VARIABLE; break;
case 2: method = VX_CONICBIRAIL_HOLDER; break;
case 3: method = VX_CONICBIRAIL_TANGENT; break;
case 4: method = VX_CONICBIRAIL_INTERSECTION; break;
case 5: method = VX_CONICBIRAIL_CENTER; break;
case 6: method = VX_CONICBIRAIL_TANGENTEDGES; break;
default: break;
}
/* initialize data */
svxConicBiRailData data = {};
if (cvxPartConicBiRailInit(method, &data))
zwTestLogErrorMsg(5, "cvxPartConicBiRailInit: failed to initialize data!");
cvxGetPointOnEnt("select point1", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.firstCrv.pnt, &data.firstCrv.entPath);
cvxGetPointOnEnt("select point2", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.secondCrv.pnt, &data.secondCrv.entPath);
cvxGetPointOnEnt("select spine, <middle-click> to ignore", VX_INP_PNT_ON_CURVE_OR_EDGE, 1, &data.spineCrv.pnt, &data.spineCrv.entPath);
svxRadiusSetData setdata = {};
switch (data.method)
{
case VX_CONICBIRAIL_CONSTANT:
{
cvxGetDistance("input radius", &data.inpUnion.constant.radius);
cvxGetNumber("select solution (1 ~ 4)", &val);
data.inpUnion.constant.solution = int(val + 0.5);
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.constant.ratio);
break;
}
case VX_CONICBIRAIL_VARIABLE:
{
cvxGetEnt("select a curve", VX_INP_EDGE_OR_CURVE, 0, &setdata.idCurve);
cvxGetPointOnEnt("select a point", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &setdata.pnt.pnt, &setdata.pnt.entPath);
cvxGetDistance("input radius", &setdata.radius);
cvxGetNumber("whether to radius locally flat: 0 or 1", &val);
setdata.radiusFlat = int(val + 0.5);
data.inpUnion.variable.pRadSet = &setdata;
data.inpUnion.variable.nRadSet = 1;
cvxGetNumber("select solution (1 ~ 4)", &val);
data.inpUnion.variable.solution = int(val + 0.5);
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.variable.ratio);
break;
}
case VX_CONICBIRAIL_HOLDER:
{
cvxGetPointOnEnt("select holder", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.holder.holder.pnt, &data.inpUnion.holder.holder.entPath);
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.holder.ratio);
break;
}
case VX_CONICBIRAIL_TANGENT:
{
cvxGetPointOnEnt("select tangent", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.tangent.tangent.pnt, &data.inpUnion.tangent.tangent.entPath);
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.tangent.ratio);
break;
}
case VX_CONICBIRAIL_INTERSECTION:
{
cvxGetPointOnEnt("select holder", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.intersection.holder.pnt, &data.inpUnion.intersection.holder.entPath);
cvxGetPointOnEnt("select tangent", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.intersection.tangent.pnt, &data.inpUnion.intersection.tangent.entPath);
break;
}
case VX_CONICBIRAIL_CENTER:
{
cvxGetPointOnEnt("select center", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.center.center.pnt, &data.inpUnion.center.center.entPath);
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.center.ratio);
break;
}
case VX_CONICBIRAIL_TANGENTEDGES:
{
cvxGetDistance("input ratio (0.0 ~ 1.0)", &data.inpUnion.tangentEdges.ratio);
break;
}
default:
break;
}
int idFace = 0;
if (cvxPartConicBiRail(&data, &idFace) || idFace == 0)
zwTestLogErrorMsg(5, "cvxPartConicBiRail: failed to create a ruled surface!");
}
void zwTestPartEnlargeFace()
/*
DESCRIPTION:
Test case for function cvxPartEnlargeFace.
*/
{
/* initialize data */
svxEnlargeFaceData data = {};
if (cvxPartEnlargeFaceInit(&data))
zwTestLogErrorMsg(5, "cvxPartEnlargeFaceInit: failed to initialize data!");
cvxGetEnt("select a face", VX_INP_FACE, 0, &data.idFace);
double val = 0;
cvxGetNumber("whether to apply to all: 0 or 1", &val);
if (int(val + 0.5))
{
data.applyAll = 1;
cvxGetDistance("input distance", &data.distance);
}
else
{
data.applyAll = 0;
cvxGetDistance("input u0", &data.u0);
cvxGetDistance("input u1", &data.u1);
cvxGetDistance("input v0", &data.v0);
cvxGetDistance("input v1", &data.v1);
}
cvxGetNumber("whether to keep original face: 0 or 1", &val);
data.keepOriginal = int(val + 0.5);
cvxGetNumber("select extension method(0: linear, 1: reflect, 2: circular, 4: Curvature diminishing", &val);
data.extension = evxFaceExtType(val + 0.5);
int idFace = 0;
if (cvxPartEnlargeFace(&data, &idFace) || idFace == 0)
zwTestLogErrorMsg(5, "cvxPartEnlargeFace: failed to enlarge a surface!");
}
void zwTestPartExtendShape()
/*
DESCRIPTION:
Test case for function cvxPartExtendShape.
*/
{
/* initialize data */
svxExtendShapeData data = {};
if (cvxPartExtendShapeInit(&data))
zwTestLogErrorMsg(5, "cvxPartExtendShapeInit: failed to initialize data!");
double val;
cvxGetNumber("select a method to extend(0: open shape, 1: general shape", &val);
data.method = (evxExtendShapeMethod)(val + 0.5);
cvxGetDistance("input distance", &data.distance);
cvxGetNumber("select edge extension(0: tangent, 1: Orthogonal", &val);
data.edgeExtension = (evxEdgeExtensionType)(val + 0.5);
if (data.method == VX_EXTEND_OPEN_SHAPE)
{
cvxGetEnts("select edges", VX_INP_EDGE, 0, &data.inpUnion.open.nEdges, &data.inpUnion.open.idEdges);
cvxGetNumber("whether to loft with new face", &val);
data.inpUnion.open.loftFaces = (int)(val + 0.5);
if (!data.inpUnion.open.loftFaces)
{
cvxGetNumber("whether to create a new face", &val);
data.inpUnion.open.createFaces = (int)(val + 0.5);
cvxGetNumber("select face extension(0: linear, 1: reflect, 2: circular, 4: Curvature diminishing", &val);
data.faceExtension = (evxFaceExtType)(val + 0.5);
}
cvxGetNumber("select option (0: none, 1: close entire gap, 2: direct edit", &val);
data.inpUnion.open.option = (evxExtendFaceMethod)(val + 0.5);
if (data.inpUnion.open.option == VX_EXTEND_FACE_DIRECT_EDIT)
cvxGetEnts("select to faces, <middle-click> when done", VX_INP_FACE, 1, &data.inpUnion.open.nFaces, &data.inpUnion.open.idFaces);
}
else
{
cvxGetNumber("select face extension(0: linear, 1: reflect, 2: circular, 4: Curvature diminishing", &val);
data.faceExtension = (evxFaceExtType)(val + 0.5);
cvxGetEnts("select faces", VX_INP_FACE, 0, &data.inpUnion.general.nFaces, &data.inpUnion.general.idFaces);
cvxGetEnts("select edges", VX_INP_EDGE, 0, &data.inpUnion.general.nEdges, &data.inpUnion.general.idEdges);
}
int idFtr = 0;
if (cvxPartExtendShape(&data, &idFtr) || idFtr < 1)
zwTestLogErrorMsg(5, "cvxPartExtendShape: failed to extend shape!");
if (data.method == VX_EXTEND_OPEN_SHAPE)
{
cvxMemFree((void**)&data.inpUnion.open.idEdges);
cvxMemFree((void**)&data.inpUnion.open.idFaces);
}
else
{
cvxMemFree((void**)&data.inpUnion.general.idFaces);
cvxMemFree((void**)&data.inpUnion.general.idEdges);
}
}
void zwTestPartSplitWithCrv()
/*
DESCRIPTION:
Test case for function cvxPartSplitWithCrv.
*/
{
/* initialize data */
svxSplitWithCrvData data = {};
if (cvxPartSplitWithCrvInit(&data))
zwTestLogErrorMsg(5, "cvxPartSplitWithCrvInit: failed to initialize data!");
cvxGetEnts("select faces", VX_INP_FACE, 0, &data.nFaces, &data.idFaces);
cvxGetEnts("select curves", VX_INP_CURVE, 0, &data.nCrvs, &data.idCrvs);
double val = 0.0;
cvxGetNumber("input option(0: in place, 1: face normal, 2: directed, 3: bi-directional)", &val);
data.prjMethod = (evxTrimCrvsProjtype)(val + 0.5);
if (data.prjMethod == VX_TRIMCRV_DIRECTED || data.prjMethod == VX_TRIMCRV_BI_DIRECTIONAL)
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&data.direction, NULL);
cvxGetNumber("whether to explode : 0 or 1", &val);
data.explodeEdges = (int)(val + 0.5);
cvxGetNumber("whether to extend : 0 or 1", &val);
data.extendCrvs = (int)(val + 0.5);
cvxGetNumber("whether to remove : 0 or 1", &val);
data.removeSpurs = (int)(val + 0.5);
int idFtr = 0;
if (cvxPartSplitWithCrv(&data, &idFtr) || idFtr < 1)
zwTestLogErrorMsg(5, "cvxPartSplitWithCrv: failed to split with curves!");
cvxMemFree((void**)&data.idFaces);
cvxMemFree((void**)&data.idCrvs);
}
evxEdgeExtensionType
evxEdgeExtensionType
edge extension type
Definition: zwapi_cmd_freeform_data.h:448
evxCircularBiRailMethod
evxCircularBiRailMethod
circular bi rail method
Definition: zwapi_cmd_freeform_data.h:168
VX_CIRCULARBIRAIL_MIDDLE
@ VX_CIRCULARBIRAIL_MIDDLE
radius is defined implicitly by a middle curve
Definition: zwapi_cmd_freeform_data.h:172
VX_CIRCULARBIRAIL_CENTER
@ VX_CIRCULARBIRAIL_CENTER
radius is defined implicitly by a center curve
Definition: zwapi_cmd_freeform_data.h:171
VX_CIRCULARBIRAIL_VARIABLE
@ VX_CIRCULARBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:170
VX_CIRCULARBIRAIL_CONSTANT
@ VX_CIRCULARBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:169
evxExtendFaceMethod
evxExtendFaceMethod
extend face method
Definition: zwapi_cmd_freeform_data.h:458
VX_EXTEND_FACE_DIRECT_EDIT
@ VX_EXTEND_FACE_DIRECT_EDIT
direct edit
Definition: zwapi_cmd_freeform_data.h:461
VX_REFIT_CURVATURE
@ VX_REFIT_CURVATURE
curvature
Definition: zwapi_cmd_freeform_data.h:113
VX_REFIT_NO
@ VX_REFIT_NO
none
Definition: zwapi_cmd_freeform_data.h:111
VX_REFIT_TANGENT
@ VX_REFIT_TANGENT
tangent
Definition: zwapi_cmd_freeform_data.h:112
VX_REFIT_DIRECT
@ VX_REFIT_DIRECT
direct
Definition: zwapi_cmd_freeform_data.h:114
evxConicBiRailMethod
evxConicBiRailMethod
conic bi rail method
Definition: zwapi_cmd_freeform_data.h:227
VX_CONICBIRAIL_INTERSECTION
@ VX_CONICBIRAIL_INTERSECTION
using a tangent curve and a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:232
VX_CONICBIRAIL_CONSTANT
@ VX_CONICBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:228
VX_CONICBIRAIL_CENTER
@ VX_CONICBIRAIL_CENTER
using a center curve
Definition: zwapi_cmd_freeform_data.h:233
VX_CONICBIRAIL_TANGENT
@ VX_CONICBIRAIL_TANGENT
using a tangent curve.
Definition: zwapi_cmd_freeform_data.h:231
VX_CONICBIRAIL_VARIABLE
@ VX_CONICBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:229
VX_CONICBIRAIL_TANGENTEDGES
@ VX_CONICBIRAIL_TANGENTEDGES
tangent to two existing face edges.
Definition: zwapi_cmd_freeform_data.h:234
VX_CONICBIRAIL_HOLDER
@ VX_CONICBIRAIL_HOLDER
using a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:230
evxTrimCrvsProjtype
evxTrimCrvsProjtype
projection types of "trim to curves"
Definition: zwapi_cmd_freeform_data.h:352
VX_TRIMCRV_FACE_NORMAL
@ VX_TRIMCRV_FACE_NORMAL
face normal
Definition: zwapi_cmd_freeform_data.h:354
VX_TRIMCRV_IN_PLACE
@ VX_TRIMCRV_IN_PLACE
in place(none)
Definition: zwapi_cmd_freeform_data.h:353
VX_TRIMCRV_DIRECTED
@ VX_TRIMCRV_DIRECTED
directed
Definition: zwapi_cmd_freeform_data.h:355
VX_TRIMCRV_BI_DIRECTIONAL
@ VX_TRIMCRV_BI_DIRECTIONAL
bi-directional
Definition: zwapi_cmd_freeform_data.h:356
evxExtendShapeMethod
evxExtendShapeMethod
extend shape type
Definition: zwapi_cmd_freeform_data.h:438
VX_EXTEND_OPEN_SHAPE
@ VX_EXTEND_OPEN_SHAPE
extend open shape
Definition: zwapi_cmd_freeform_data.h:439
evxFaceExtType
evxFaceExtType
face extension type
Definition: zwapi_cmd_freeform_data.h:409
cvxPartExplodeInit
evxErrors cvxPartExplodeInit(svxExplodeData *data)
cvxPartCircularBiRailInit
evxErrors cvxPartCircularBiRailInit(evxCircularBiRailMethod method, svxCircularBiRailData *data)
cvxPartExtendFace
evxErrors cvxPartExtendFace(svxExtendData *data, int *newFtr)
cvxPartEnlargeFaceInit
evxErrors cvxPartEnlargeFaceInit(svxEnlargeFaceData *data)
cvxPartEnlargeFace
evxErrors cvxPartEnlargeFace(const svxEnlargeFaceData *data, int *idFace)
cvxPartTrimToFacesInit
evxErrors cvxPartTrimToFacesInit(svxTrimToFacesData *data)
cvxPartRuledInit
evxErrors cvxPartRuledInit(svxRuledData *data)
cvxPartCircularBiRail
evxErrors cvxPartCircularBiRail(const svxCircularBiRailData *data, int *idFace)
cvxPartSplitWithCrv
evxErrors cvxPartSplitWithCrv(const svxSplitWithCrvData *data, int *idFtr)
cvxPartExplode
evxErrors cvxPartExplode(const svxExplodeData *ExplodeData, int *numShape, int **idShapes)
cvxPartNSidedInit
evxErrors cvxPartNSidedInit(svxNSidedData *data)
cvxPartConicBiRailInit
evxErrors cvxPartConicBiRailInit(evxConicBiRailMethod method, svxConicBiRailData *data)
cvxPartFacesOffsetInit
evxErrors cvxPartFacesOffsetInit(svxFcsOffsetData *data)
cvxPartFacesetSew
evxErrors cvxPartFacesetSew(int count, int *shapes, svxSewData *param, int *newFtr)
cvxPartNSided
evxErrors cvxPartNSided(const svxNSidedData *NSidedData, int *idShape)
cvxPartConicBiRail
evxErrors cvxPartConicBiRail(const svxConicBiRailData *data, int *idFace)
cvxPartTrimToFaces
evxErrors cvxPartTrimToFaces(const svxTrimToFacesData *data, int *idTrim)
cvxPartExtendFaceInit
evxErrors cvxPartExtendFaceInit(svxExtendData *data)
cvxPartSplitWithCrvInit
evxErrors cvxPartSplitWithCrvInit(svxSplitWithCrvData *data)
cvxPartTrimmedPlaneInit
evxErrors cvxPartTrimmedPlaneInit(svxTrimPlnData *data)
cvxPartTrimToCrvs
evxErrors cvxPartTrimToCrvs(const svxTrimToCurvesData *trimData, int *idTrim)
cvxPartExtendShape
evxErrors cvxPartExtendShape(const svxExtendShapeData *data, int *idFtr)
cvxPartFacesetSewInit
evxErrors cvxPartFacesetSewInit(svxSewData *data)
cvxPartExtendShapeInit
evxErrors cvxPartExtendShapeInit(svxExtendShapeData *data)
cvxPartRuled
evxErrors cvxPartRuled(const svxRuledData *data, int *idFace)
cvxPartTrimmedPlane
evxErrors cvxPartTrimmedPlane(svxTrimPlnData *data, int *newShp)
cvxPartFacesOffset
evxErrors cvxPartFacesOffset(const svxFcsOffsetData *data, int *idFtr)
cvxPartFaceOffset
evxErrors cvxPartFaceOffset(int idFace, double Dis, int Keep)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
cvxGetDistance
evxErrors cvxGetDistance(const char *Prompt, double *Distance)
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::center
svxPntOnEntPath center
select the center curve
Definition: zwapi_cmd_freeform_data.h:212
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:213
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::radius
double radius
constant radius
Definition: zwapi_cmd_freeform_data.h:201
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:202
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle::middle
svxPntOnEntPath middle
select the middle curve
Definition: zwapi_cmd_freeform_data.h:217
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:206
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::pRadSet
svxRadiusSetData * pRadSet
store spines list with different radius
Definition: zwapi_cmd_freeform_data.h:208
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::nRadSet
int nRadSet
the count of list
Definition: zwapi_cmd_freeform_data.h:207
svxCircularBiRailData::firstCrv
svxPntOnEntPath firstCrv
select the first path curve
Definition: zwapi_cmd_freeform_data.h:194
svxCircularBiRailData::method
evxCircularBiRailMethod method
method to create a new circular face (VX_CIRCULARBIRAIL_CONSTANT as default)
Definition: zwapi_cmd_freeform_data.h:193
svxCircularBiRailData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:196
svxCircularBiRailData::secondCrv
svxPntOnEntPath secondCrv
select the second path curve
Definition: zwapi_cmd_freeform_data.h:195
svxCircularBiRailData
circular bi rail data
Definition: zwapi_cmd_freeform_data.h:192
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:280
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::center
svxPntOnEntPath center
select the center curve
Definition: zwapi_cmd_freeform_data.h:279
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:252
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:253
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::radius
double radius
constant radius
Definition: zwapi_cmd_freeform_data.h:251
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::holder
svxPntOnEntPath holder
select the shoulder curve
Definition: zwapi_cmd_freeform_data.h:264
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:265
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::holder
svxPntOnEntPath holder
select the shoulder curve
Definition: zwapi_cmd_freeform_data.h:274
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::tangent
svxPntOnEntPath tangent
select the tangent curve
Definition: zwapi_cmd_freeform_data.h:275
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::tangent
svxPntOnEntPath tangent
select the tangent curve
Definition: zwapi_cmd_freeform_data.h:269
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:270
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:284
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::nRadSet
int nRadSet
the count of list
Definition: zwapi_cmd_freeform_data.h:257
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:260
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::pRadSet
svxRadiusSetData * pRadSet
store spines list with different radius
Definition: zwapi_cmd_freeform_data.h:258
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:259
svxConicBiRailData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:246
svxConicBiRailData::method
evxConicBiRailMethod method
method to create a new conic face (VX_CONICBIRAIL_CONSTANT as default)
Definition: zwapi_cmd_freeform_data.h:243
svxConicBiRailData::secondCrv
svxPntOnEntPath secondCrv
select the second path curve
Definition: zwapi_cmd_freeform_data.h:245
svxConicBiRailData::firstCrv
svxPntOnEntPath firstCrv
select the first path curve
Definition: zwapi_cmd_freeform_data.h:244
svxConicBiRailData
conic bi rail data
Definition: zwapi_cmd_freeform_data.h:242
svxEnlargeFaceData::applyAll
int applyAll
whether all the edges will be extended the same distance (0 as default)
Definition: zwapi_cmd_freeform_data.h:423
svxEnlargeFaceData::keepOriginal
int keepOriginal
whether to keep original face (1 as default)
Definition: zwapi_cmd_freeform_data.h:429
svxEnlargeFaceData::v0
double v0
set v0 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:427
svxEnlargeFaceData::distance
double distance
the distance to enlarge, used only when applyAll is 1
Definition: zwapi_cmd_freeform_data.h:424
svxEnlargeFaceData::idFace
int idFace
index of face to enlarge
Definition: zwapi_cmd_freeform_data.h:422
svxEnlargeFaceData::u1
double u1
set u1 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:426
svxEnlargeFaceData::extension
evxFaceExtType extension
extension type (VX_FACE_EXTENSION_LINEAR as default)
Definition: zwapi_cmd_freeform_data.h:430
svxEnlargeFaceData::v1
double v1
set v1 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:428
svxEnlargeFaceData::u0
double u0
set u0 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:425
svxEnlargeFaceData
enlarge face data
Definition: zwapi_cmd_freeform_data.h:421
svxExplodeData::RebudEdge
int RebudEdge
flag to use Rebuild edges along boundary, 1 default
Definition: zwapi_cmd_freeform_data.h:390
svxExplodeData::pFace
int * pFace
Id list of faces to explode.
Definition: zwapi_cmd_freeform_data.h:387
svxExplodeData::ConnectFc
int ConnectFc
flag to use Group connected faces, 0 default
Definition: zwapi_cmd_freeform_data.h:389
svxExplodeData::numFace
int numFace
Number of selected faces.
Definition: zwapi_cmd_freeform_data.h:386
svxExplodeData
data of explode command
Definition: zwapi_cmd_freeform_data.h:385
svxExtendData::cntEdge
int cntEdge
count of the extend edges(0-extend all the edges of the face and the idFace must be valid
Definition: zwapi_cmd_freeform_data.h:321
svxExtendData::iExtension
int iExtension
extend method(0-liner, 1-reflect, 2-circular, 4-curvature diminishing, 0-default value)
Definition: zwapi_cmd_freeform_data.h:327
svxExtendData::pDistList
double * pDistList
the extend distance list, every edge can be extended with a different value (NULL to use fDist)
Definition: zwapi_cmd_freeform_data.h:323
svxExtendData::pEdgList
int * pEdgList
the edges that belonging to the face(NUll to use idFace get all the edges)
Definition: zwapi_cmd_freeform_data.h:322
svxExtendData::idFace
int idFace
id face (if idFace is 0/-1, it will get from the first edge )
Definition: zwapi_cmd_freeform_data.h:320
svxExtendData::iMerge
int iMerge
merge extended face(1-merge, 0-no, initialize 1 as the default)
Definition: zwapi_cmd_freeform_data.h:325
svxExtendData::iKeepFace
int iKeepFace
keep the original face(1-keep, 0-no, initialize 0 as the default)
Definition: zwapi_cmd_freeform_data.h:326
svxExtendData
template command Extend Face data
Definition: zwapi_cmd_freeform_data.h:319
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idEdges
int * idEdges
list of edges to extend, the edges should be the edges of the extended faces
Definition: zwapi_cmd_freeform_data.h:490
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nEdges
int nEdges
count of edges to extend
Definition: zwapi_cmd_freeform_data.h:489
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nFaces
int nFaces
count of faces to extend
Definition: zwapi_cmd_freeform_data.h:487
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idFaces
int * idFaces
list of faces to extend
Definition: zwapi_cmd_freeform_data.h:488
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nEdges
int nEdges
count of edges to extend
Definition: zwapi_cmd_freeform_data.h:477
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::option
evxExtendFaceMethod option
extension open face option (VX_EXTEND_FACE_NONE as default)
Definition: zwapi_cmd_freeform_data.h:479
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idEdges
int * idEdges
list of edges to extend
Definition: zwapi_cmd_freeform_data.h:478
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nFaces
int nFaces
count of faces to extend to (0 to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT
Definition: zwapi_cmd_freeform_data.h:480
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idFaces
int * idFaces
list of faces to extend to (NULL to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT
Definition: zwapi_cmd_freeform_data.h:481
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::loftFaces
int loftFaces
whether to create new loft extension faces
Definition: zwapi_cmd_freeform_data.h:483
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::createFaces
int createFaces
whether to create new linear extension faces
Definition: zwapi_cmd_freeform_data.h:482
svxExtendShapeData::faceExtension
evxFaceExtType faceExtension
face extension type (VX_FACE_EXT_LINEAR as default)
Definition: zwapi_cmd_freeform_data.h:494
svxExtendShapeData::distance
double distance
specify the distance to extend.
Definition: zwapi_cmd_freeform_data.h:471
svxExtendShapeData::method
evxExtendShapeMethod method
method to extend shape (VX_EXTEND_OPEN_SHAPE as default)
Definition: zwapi_cmd_freeform_data.h:470
svxExtendShapeData::edgeExtension
evxEdgeExtensionType edgeExtension
edge extension type (VX_EDGE_EXTENSION_TANGENT as default)
Definition: zwapi_cmd_freeform_data.h:495
svxExtendShapeData
extend shape data
Definition: zwapi_cmd_freeform_data.h:469
svxFcsOffsetData::svxVarOffset::pntOffset
double pntOffset
offset
Definition: zwapi_cmd_freeform_data.h:310
svxFcsOffsetData::svxVarOffset::pntOnEnt
svxPntOnEnt pntOnEnt
set point on face(or edge)
Definition: zwapi_cmd_freeform_data.h:309
svxFcsOffsetData::svxVarOffset
faces offset variable data
Definition: zwapi_cmd_freeform_data.h:308
svxFcsOffsetData::offset
double offset
offset
Definition: zwapi_cmd_freeform_data.h:300
svxFcsOffsetData::cnt
int cnt
count of "list", cnt=0 to ignore
Definition: zwapi_cmd_freeform_data.h:306
svxFcsOffsetData::keepEdge
int keepEdge
1 is keep edge connectivity, else 0
Definition: zwapi_cmd_freeform_data.h:303
svxFcsOffsetData::keepSurface
int keepSurface
1 is keep original surface, else 0
Definition: zwapi_cmd_freeform_data.h:302
svxFcsOffsetData::faces
int * faces
list of face id
Definition: zwapi_cmd_freeform_data.h:299
svxFcsOffsetData::count
int count
count of "faces"
Definition: zwapi_cmd_freeform_data.h:298
svxFcsOffsetData
faces offset data
Definition: zwapi_cmd_freeform_data.h:297
svxFcsOffsetData::list
struct svxFcsOffsetData::svxVarOffset * list
NULL to ignore.
svxNSidedData::pShape
int * pShape
index of the shapes, valid if sewShape set to 1, can be ignored
Definition: zwapi_cmd_freeform_data.h:129
svxNSidedData::pCrv
int * pCrv
id of curves
Definition: zwapi_cmd_freeform_data.h:124
svxNSidedData::refit
evxRefitOpt refit
enum for Refit options, 0 = no, 1 = tangent , 2 = curvature, 3 = direct (default)
Definition: zwapi_cmd_freeform_data.h:131
svxNSidedData::sewShape
int sewShape
flag to sew shapes or not. 1 = to sew , (default) since R2024, it doesn't sew the new shapes and if u...
Definition: zwapi_cmd_freeform_data.h:126
svxNSidedData::tangent
int tangent
tangent at boundary , 0 = no (default), 1 = tangent
Definition: zwapi_cmd_freeform_data.h:130
svxNSidedData::numShape
int numShape
count of the shapes, valid if sewShape set to 1, can be ignored
Definition: zwapi_cmd_freeform_data.h:128
svxNSidedData::numCrv
int numCrv
count of the paths
Definition: zwapi_cmd_freeform_data.h:123
svxNSidedData::dTol
double dTol
Tolerance, 0.01 (default)
Definition: zwapi_cmd_freeform_data.h:132
svxNSidedData
template command N-sided data
Definition: zwapi_cmd_freeform_data.h:122
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath::entPath
svxEntPath entPath
entity path that the point on
Definition: zwapi_util.h:570
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPoint
3D point
Definition: zwapi_util.h:306
svxRadiusSetData::idCurve
int idCurve
set the curve
Definition: zwapi_cmd_freeform_data.h:181
svxRadiusSetData::radius
double radius
set the radius
Definition: zwapi_cmd_freeform_data.h:183
svxRadiusSetData::radiusFlat
int radiusFlat
whether to mark the radius as flat
Definition: zwapi_cmd_freeform_data.h:184
svxRadiusSetData::pnt
svxPntOnEntPath pnt
set the point
Definition: zwapi_cmd_freeform_data.h:182
svxRadiusSetData
radius set data
Definition: zwapi_cmd_freeform_data.h:180
svxRuledData::secondCrv
svxPntOnEntPath secondCrv
select the second curve
Definition: zwapi_cmd_freeform_data.h:158
svxRuledData::firstCrv
svxPntOnEntPath firstCrv
select the first curve
Definition: zwapi_cmd_freeform_data.h:157
svxRuledData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:159
svxRuledData::trimPlane
int trimPlane
whether to attempt trimmed plane (1 as default)
Definition: zwapi_cmd_freeform_data.h:160
svxRuledData
ruled data
Definition: zwapi_cmd_freeform_data.h:156
svxSewData::forceClose
char forceClose
force object to sew into solid
Definition: zwapi_cmd_freeform_data.h:401
svxSewData::multEdg
char multEdg
enable multiple edge matching or not
Definition: zwapi_cmd_freeform_data.h:400
svxSewData
faces sew data
Definition: zwapi_cmd_freeform_data.h:398
svxSplitWithCrvData::explodeEdges
int explodeEdges
whether all new edges will be unsewn from the shape (0 as default)
Definition: zwapi_cmd_freeform_data.h:510
svxSplitWithCrvData::direction
svxVector direction
projection direction, used when prjMethod is VX_TRIMCRV_DIRECTED or VX_TRIMCRV_BI_DIRECTIONAL
Definition: zwapi_cmd_freeform_data.h:509
svxSplitWithCrvData::removeSpurs
int removeSpurs
whether to remove the excess spurs and face edges (1 as default)
Definition: zwapi_cmd_freeform_data.h:512
svxSplitWithCrvData::nCrvs
int nCrvs
count of split curves (0 to use intersecting curves to split faces)
Definition: zwapi_cmd_freeform_data.h:506
svxSplitWithCrvData::idCrvs
int * idCrvs
list of split curves (NULL to use intersecting curves to split faces)
Definition: zwapi_cmd_freeform_data.h:507
svxSplitWithCrvData::nFaces
int nFaces
count of faces or shapes to split
Definition: zwapi_cmd_freeform_data.h:504
svxSplitWithCrvData::prjMethod
evxTrimCrvsProjtype prjMethod
method to project the trimming curves onto the subject faces (VX_TRIMCRV_IN_PLACE as default)
Definition: zwapi_cmd_freeform_data.h:508
svxSplitWithCrvData::idFaces
int * idFaces
list of faces or shapes to split
Definition: zwapi_cmd_freeform_data.h:505
svxSplitWithCrvData::extendCrvs
int extendCrvs
whether to automatically extend trim curves to boundary (0 as default)
Definition: zwapi_cmd_freeform_data.h:511
svxSplitWithCrvData
split with curve data
Definition: zwapi_cmd_freeform_data.h:503
svxTrimPlnData::idPlane
int idPlane
id of reference plane(-1/0 to ignore)
Definition: zwapi_cmd_freeform_data.h:147
svxTrimPlnData::pBooolList
int * pBooolList
list boolean shapes(null to ignore)
Definition: zwapi_cmd_freeform_data.h:146
svxTrimPlnData::cntBool
int cntBool
count of boolean shapes(0 to ignore)
Definition: zwapi_cmd_freeform_data.h:145
svxTrimPlnData::pCrvList
int * pCrvList
input curve id list(required)
Definition: zwapi_cmd_freeform_data.h:142
svxTrimPlnData::sew
char sew
flag of sew or not(1-sew, else 0)
Definition: zwapi_cmd_freeform_data.h:144
svxTrimPlnData::cntCrv
int cntCrv
count of input curve(required)
Definition: zwapi_cmd_freeform_data.h:141
svxTrimPlnData
template command Trimmed Plane data
Definition: zwapi_cmd_freeform_data.h:140
svxTrimToCurvesData::cntPnts
int cntPnts
count of sides
Definition: zwapi_cmd_freeform_data.h:370
svxTrimToCurvesData::toKeep
int toKeep
0 is faces to keep, 1 is faces to remove
Definition: zwapi_cmd_freeform_data.h:369
svxTrimToCurvesData::projection
evxTrimCrvsProjtype projection
projection
Definition: zwapi_cmd_freeform_data.h:374
svxTrimToCurvesData::idFaces
int * idFaces
list of id face
Definition: zwapi_cmd_freeform_data.h:366
svxTrimToCurvesData::isExtend
int isExtend
1 is extend curves to boundary, else 0
Definition: zwapi_cmd_freeform_data.h:377
svxTrimToCurvesData::isCheckerboard
int isCheckerboard
1 is trim to checkerboard, else 0
Definition: zwapi_cmd_freeform_data.h:376
svxTrimToCurvesData::cntCrvs
int cntCrvs
count of idCurves
Definition: zwapi_cmd_freeform_data.h:367
svxTrimToCurvesData::dirction
svxVector * dirction
direction, NULL to ignore
Definition: zwapi_cmd_freeform_data.h:375
svxTrimToCurvesData::sides
svxPntOnEnt * sides
point on ent
Definition: zwapi_cmd_freeform_data.h:371
svxTrimToCurvesData::cntFcs
int cntFcs
count of idFaces
Definition: zwapi_cmd_freeform_data.h:365
svxTrimToCurvesData::idCurves
int * idCurves
list of id curve
Definition: zwapi_cmd_freeform_data.h:368
svxTrimToCurvesData
template command Trim to Curves input data
Definition: zwapi_cmd_freeform_data.h:364
svxTrimToFacesData::pFace
int * pFace
Id list of faces to Trim.
Definition: zwapi_cmd_freeform_data.h:337
svxTrimToFacesData::pTrimming
int * pTrimming
Id list of trimming entities.
Definition: zwapi_cmd_freeform_data.h:339
svxTrimToFacesData::TrimWith
int TrimWith
flag to use "Trim with all simultaneously", 0 default
Definition: zwapi_cmd_freeform_data.h:342
svxTrimToFacesData::numTrimming
int numTrimming
Number of trimming entities.
Definition: zwapi_cmd_freeform_data.h:338
svxTrimToFacesData::numFace
int numFace
Number of faces to Trim.
Definition: zwapi_cmd_freeform_data.h:336
svxTrimToFacesData::FlipSide
int FlipSide
flag to use "Flip side to keep", 0 default
Definition: zwapi_cmd_freeform_data.h:341
svxTrimToFacesData::ExtendTrimming
int ExtendTrimming
flag to use "Extend trimming faces", 0 default
Definition: zwapi_cmd_freeform_data.h:343
svxTrimToFacesData::KeepTrimming
int KeepTrimming
flag to use "Keep trimming faces", 1 default
Definition: zwapi_cmd_freeform_data.h:344
svxTrimToFacesData
trim to faces
Definition: zwapi_cmd_freeform_data.h:335
svxVector
3D vector
Definition: zwapi_util.h:338
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\partUtils.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\partUtils.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <string.h>
void zwUtilGetPntOrDirOnEnt
(
int isDir, /* I: 1 to get direction; 0 to get point */
svxPntOnEnt* pntOnEnt /* O: data */
)
/*
DESCRIPTION:
Get point or direction on entity.
*/
{
*pntOnEnt = { 0 };
double val = 0.0;
cvxGetNumber("Whether to use critical point(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
pntOnEnt->useCritPnt = 1;
cvxGetEnt("Select the entity where the critical point is located", VX_INP_MOVE, 0, &pntOnEnt->idEnt);
cvxGetNumber("Enter number to select critical point(0: start point; 1: end point; 2: center pint; 3: control point)", &val);
switch (int(val + 0.5))
{
case 1: pntOnEnt->critTyp = VX_END_POINT; break;
case 2: pntOnEnt->critTyp = VX_CENTER_POINT; break;
case 3: pntOnEnt->critTyp = VX_SPLINE_DEFINING_POINT; break;
default: pntOnEnt->critTyp = VX_START_POINT; break;
}
if (pntOnEnt->critTyp == VX_SPLINE_DEFINING_POINT)
{
cvxGetNumber("Enter the serial number of control point, starting from 0", &val);
pntOnEnt->idControlPnt = (int)(val + 0.5);
}
}
else
{
cvxGetPoint("Select a point, <middle-click> to ignore", VX_INP_PNT_GENERAL, 1, &pntOnEnt->pnt, &pntOnEnt->idEnt);
}
if (pntOnEnt->idEnt > 0)
{
if (cvxEntIsCurve(pntOnEnt->idEnt) && VX_ENT_EDGE != cvxEntClassNum(pntOnEnt->idEnt))
{
vxLongName rootName = "\0";
cvxRootInqActive(rootName, sizeof(rootName));
int idRoot = 0;
evxRootType rootType = VX_ROOT_NULL;
cvxRootId(rootName, &idRoot, &rootType);
int idParent = 0;
if (rootType == VX_ROOT_SHEET)
{
}
else
{
cvxEntSketch(pntOnEnt->idEnt, &idParent);
if (idParent < 1)
{
int nCrvList = 0, * idCrvList = NULL;
cvxPartInqCrvLists(&nCrvList, &idCrvList);
for (int i = 0; i < nCrvList; i++)
{
int nCrv = 0;
svxEntPick* crvPick = NULL;
cvxPartInqCrvList(idCrvList[i], &nCrv, &crvPick);
for (int k = 0; k < nCrv; k++)
{
if (crvPick[k].idEntity == pntOnEnt->idEnt)
idParent = idCrvList[i];
if (idParent > 0)
break;
}
cvxMemFree((void**)&crvPick);
if (idParent > 0)
break;
}
cvxMemFree((void**)&idCrvList);
}
}
if (idParent > 0)
pntOnEnt->idEnt = idParent;
}
}
if (isDir)
{
pntOnEnt->useDir = 1;
int GetDir = 1;
if (pntOnEnt->idEnt > 0)
{
cvxGetNumber("Use the direction at the point on the geometry(1: yes; 0: no)", &val);
if (int(val + 0.5))
GetDir = 0;
}
if (GetDir)
cvxGetPoint("Select direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&pntOnEnt->dir, &pntOnEnt->idEnt);
cvxGetNumber("Whether to flip direction(1: yes; 0: no)", &val);
if (int(val + 0.5))
pntOnEnt->flipDir = 1;
}
}
void zwUtilGetPntOnEntPath
(
evxEntInpOpt entType, /* I: entity type */
evxPntInpOpt pntType, /* I: point type */
svxPntOnEntPath* pntOnEnt /* O: point data */
)
/*
DESCRIPTION:
Get point on entity.
*/
{
*pntOnEnt = {};
double val = 0.0;
cvxGetNumber("Enter number to select critical point(0: free point; 1: start point; 2: end point; 3: center; 4: control point; 5: middle; 6: orgin)", &val);
switch (int(val + 0.5))
{
case 1: pntOnEnt->pntType = VX_START_POINT; break;
case 2: pntOnEnt->pntType = VX_END_POINT; break;
case 3: pntOnEnt->pntType = VX_CENTER_POINT; break;
case 4: pntOnEnt->pntType = VX_SPLINE_DEFINING_POINT; break;
case 5: pntOnEnt->pntType = VX_MIDDLE_POINT; break;
case 6: pntOnEnt->pntType = VX_ORIGIN_POINT; break;
default: pntOnEnt->pntType = VX_FREE_POINT; break;
}
if (pntOnEnt->pntType == VX_SPLINE_DEFINING_POINT)
{
cvxGetNumber("Enter the serial number of control point, starting from 0", &val);
pntOnEnt->idControlPnt = (int)(val + 0.5);
}
if (pntOnEnt->pntType == VX_FREE_POINT)
cvxGetPointOnEnt("Select a point", pntType, 0, &pntOnEnt->pnt, &pntOnEnt->entPath);
else
cvxGetEntPath("Select a entity", entType, 0, &pntOnEnt->entPath);
}
void zwUtilGetDirOnEntPath
(
evxEntInpOpt entType, /* I: entity type */
svxDirOnEntPath* dirOnEnt /* O: direction data */
)
/*
DESCRIPTION:
Get direction on entity.
*/
{
*dirOnEnt = {};
double val = 0.0;
cvxGetEntPath("Select a entity to specify direction, <middle-clicl> to use free direction", entType, 1, &dirOnEnt->entPath);
if (dirOnEnt->entPath.Count > 1)
{
int klass = cvxEntClassNumByPath(&dirOnEnt->entPath);
if (klass != VX_ENT_CIRCLE2 && klass != VX_ENT_CIRCLE3 && klass != VX_ENT_DATUM && klass != VX_ENT_AXIS && klass != VX_ENT_AXIS_2D)
{
cvxGetNumber("Enter number to select direction(0: start direction of curve; 1: end direction of curve; 2: tangent direction of point on face)", &val);
switch (int(val + 0.5))
{
case 1: dirOnEnt->dirType = VX_END_DIR; break;
case 2: dirOnEnt->dirType = VX_PNT_DIR; break;
default: dirOnEnt->dirType = VX_START_DIR; break;
}
}
cvxGetNumber("Whether to flip direction(1: yes; 0: no)", &val);
if (int(val + 0.5)) dirOnEnt->flipDir = 1;
}
else
{
cvxGetPointOnEnt("Select a point", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&dirOnEnt->dir, NULL);
}
}
cvxEntIsCurve
int cvxEntIsCurve(int idEntity)
cvxEntSketch
void cvxEntSketch(int idEntity, int *idSketch)
cvxEntClassNumByPath
int cvxEntClassNumByPath(svxEntPath *entPath)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxPartInqCrvLists
evxErrors cvxPartInqCrvLists(int *Count, int **CrvLists)
cvxPartInqCrvList
evxErrors cvxPartInqCrvList(int idCrvList, int *Count, svxEntPick **Curves)
cvxRootId
evxErrors cvxRootId(vxRootName Name, int *idRoot, evxRootType *Type)
evxRootType
evxRootType
root object type
Definition: zwapi_root.h:31
VX_ROOT_SHEET
@ VX_ROOT_SHEET
sheet
Definition: zwapi_root.h:35
cvxRootInqActive
void cvxRootInqActive(char *Name, int nBytes)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
evxPntInpOpt
evxPntInpOpt
point input options
Definition: zwapi_userinput.h:77
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
evxEntInpOpt
evxEntInpOpt
entity input options
Definition: zwapi_userinput.h:31
VX_INP_MOVE
@ VX_INP_MOVE
pick move
Definition: zwapi_userinput.h:53
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
VX_END_DIR
@ VX_END_DIR
end direction of curve, (if the input is face, get tangent direction of (u.max, v....
Definition: zwapi_util.h:581
VX_PNT_DIR
@ VX_PNT_DIR
tangent direction of point on face
Definition: zwapi_util.h:582
VX_START_DIR
@ VX_START_DIR
start direction of curve, (if the input is face, get tangent direction of (u.min, v....
Definition: zwapi_util.h:580
VX_ENT_AXIS
@ VX_ENT_AXIS
Datum axis.
Definition: zwapi_util.h:966
VX_ENT_AXIS_2D
@ VX_ENT_AXIS_2D
2D datum axis
Definition: zwapi_util.h:968
VX_ENT_CIRCLE3
@ VX_ENT_CIRCLE3
3D circle
Definition: zwapi_util.h:930
VX_ENT_DATUM
@ VX_ENT_DATUM
datum plane
Definition: zwapi_util.h:948
VX_ENT_CIRCLE2
@ VX_ENT_CIRCLE2
2D circle
Definition: zwapi_util.h:931
VX_ENT_EDGE
@ VX_ENT_EDGE
b-rep edge
Definition: zwapi_util.h:925
VX_END_POINT
@ VX_END_POINT
end point of curve or line (if the input is face, get point of (u.max, v.max))
Definition: zwapi_util.h:538
VX_MIDDLE_POINT
@ VX_MIDDLE_POINT
middle point of curve or line
Definition: zwapi_util.h:541
VX_CENTER_POINT
@ VX_CENTER_POINT
center point, used only for arc or circle (if the input is face, get point of ((u....
Definition: zwapi_util.h:539
VX_FREE_POINT
@ VX_FREE_POINT
free point, non-critical point
Definition: zwapi_util.h:536
VX_ORIGIN_POINT
@ VX_ORIGIN_POINT
origin of datum plane and datum CSYS
Definition: zwapi_util.h:542
VX_START_POINT
@ VX_START_POINT
start point of curve or line (if the input is face, get point of (u.min, v.min))
Definition: zwapi_util.h:537
VX_SPLINE_DEFINING_POINT
@ VX_SPLINE_DEFINING_POINT
control point, used only for splines
Definition: zwapi_util.h:540
svxDirOnEntPath::flipDir
int flipDir
whether to flip direction (1 to flip, else 0). enable when the direction control support flip the dir...
Definition: zwapi_util.h:595
svxDirOnEntPath::entPath
svxEntPath entPath
entity path that defines the direction
Definition: zwapi_util.h:591
svxDirOnEntPath::dirType
evxDirType dirType
direction type, only used when entPath is a curve and not a circle or face
Definition: zwapi_util.h:592
svxDirOnEntPath::dir
svxVector dir
direction, only used when entPath is a invalid path (svxEntPath.Count < 2)
Definition: zwapi_util.h:594
svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
Definition: zwapi_util.h:590
svxEntPath::Count
int Count
number of id's in the path
Definition: zwapi_util.h:269
svxEntPick
entity pick (includes optional parent entity)
Definition: zwapi_util.h:976
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idControlPnt
int idControlPnt
id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING...
Definition: zwapi_util.h:555
svxPntOnEnt::useDir
int useDir
1-use as a direction, else 0
Definition: zwapi_util.h:558
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt::dir
svxVector dir
direction of the input point
Definition: zwapi_util.h:557
svxPntOnEnt::flipDir
int flipDir
1-flip direction, else 0. enable when the direction control support flip the direction
Definition: zwapi_util.h:559
svxPntOnEnt::useCritPnt
int useCritPnt
1- use critTyp, else 0 (idEnt must be valid if useCritPnt is 1)
Definition: zwapi_util.h:553
svxPntOnEnt::critTyp
evxGeomCritPnt critTyp
type of critical point
Definition: zwapi_util.h:554
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath::entPath
svxEntPath entPath
entity path that the point on
Definition: zwapi_util.h:570
svxPntOnEntPath::pntType
evxGeomCritPnt pntType
point type
Definition: zwapi_util.h:568
svxPntOnEntPath::idControlPnt
int idControlPnt
id of the control point of the spline (starting from 0), only used when pntType is VX_SPLINE_DEFINING...
Definition: zwapi_util.h:569
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\pmiCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\pmiCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
ApiDefVoidFunc(zwTestPartAddLineDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddSymmetryDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddAngleDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddChamferDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddRadDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddArcDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddCoorDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddDatumDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddDatumTargetDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddFcsDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddSymSrfDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddLabelDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddCenLinDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddCenMarkDim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddPMIText, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartAddBalloon, VX_CODE_GENERAL);
void zwTestPartAddLineDim()
/*
DESCRIPTION:
Test case for function cvxPartAddLineDim.
*/
{
int idEnt1 = 0, idEnt2 = 0, idPlane = 0;
svxPoint textPoint = { 0 };
cvxGetEnt("select a point, line or face", VX_INP_GENERAL_3D, 0, &idEnt1);
cvxGetEnt("select another point, line or face", VX_INP_GENERAL_3D, 0, &idEnt2);
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPoint, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a linear dimension */
int idDim = 0;
if (cvxPartAddLineDim(idEnt1, idEnt2, &textPoint, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddLineDim: failed to add a linear dimension!");
}
void zwTestPartAddSymmetryDim()
/*
DESCRIPTION:
Test case for function cvxPartAddSymmetryDim.
*/
{
svxPntOnEnt ent = { 0 }, centerLine = { 0 }, textPnt = { 0 };
int idPlane = 0;
cvxGetPoint("select first entity", VX_INP_PNT_ON_ENTITY, 0, &ent.pnt, &ent.idEnt);
cvxGetPoint("select center line", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &centerLine.pnt, &centerLine.idEnt);
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPnt.pnt, &textPnt.idEnt);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a symmetric dimension */
int idDim = 0;
if (cvxPartAddSymmetryDim(ent, centerLine, textPnt, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddSymmetryDim: failed to add a symmetric dimension!");
}
void zwTestPartAddAngleDim()
/*
DESCRIPTION:
Test case for function cvxPartAddAngleDim.
*/
{
int idEnt1 = 0, idEnt2 = 0, idPlane = 0;
svxPoint textPoint = { 0 };
cvxGetEnt("select first entity", VX_INP_GENERAL_3D, 0, &idEnt1);
cvxGetEnt("select second entity", VX_INP_GENERAL_3D, 0, &idEnt2);
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPoint, nullptr);
cvxGetEnt("select insertion plane, <middle click to ignore>", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a angle dimension */
int idDim = 0;
if (cvxPartAddAngleDim(idEnt1, idEnt2, &textPoint, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddAngleDim: failed to add a angle dimension!");
}
void zwTestPartAddChamferDim()
/*
DESCRIPTION:
Test case for function cvxPartAddChamferDim.
*/
{
int idEnt1 = 0, idEnt2 = 0, idPlane = 0;
svxPoint textPoint = { 0 };
cvxGetEnt("select a chamfer face dimension", VX_INP_FACE, 0, &idEnt1);
cvxGetEnt("select a 45 degrees reference face", VX_INP_FACE, 0, &idEnt2);
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPoint, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a chamfer dimension */
int idDim = 0;
if (cvxPartAddChamferDim(idEnt1, idEnt2, &textPoint, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddChamferDim: failed to add a chamfer dimension!");
}
void zwTestPartAddRadDim()
/*
DESCRIPTION:
Test case for function cvxPartAddRadDim.
*/
{
int idEnt = 0, idPlane = 0;
svxPoint textPoint = { 0 };
cvxGetEnt("select an arc", VX_INP_EDGE_OR_CURVE, 0, &idEnt);
double val = 0;
cvxGetNumber("select dimension type: 1 - 6", &val); /* type 2 need break point */
char* text = "user text";
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPoint, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a rad dimension */
int idDim = 0;
if (cvxPartAddRadDim(idEnt, int(val + 0.5), text, &textPoint, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddRadDim: failed to add a rad dimension!");
}
void zwTestPartAddArcDim()
/*
DESCRIPTION:
Test case for function cvxPartAddArcDim.
*/
{
int idEnt = 0, idPlane = 0;
svxPoint textPoint = { 0 };
cvxGetEnt("select an arc", VX_INP_EDGE_OR_CURVE, 0, &idEnt);
cvxGetPoint("select text position", VX_INP_PNT_GENERAL, 0, &textPoint, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
char* text = "user text";
char* pText = nullptr;
double val = 0;
cvxGetNumber("whether use user text: 0 or 1", &val);
if (int(val + 0.5))
pText = text;
/* add a rad dimension */
int idDim = 0;
if (cvxPartAddArcDim(idEnt, pText, &textPoint, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddArcDim: failed to add an arc dimension!");
}
void zwTestPartAddCoorDim()
/*
DESCRIPTION:
Test case for function cvxPartAddCoorDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idParent = 0, idDatum = 0, idPlane = 0;
cvxGetPoint("select leader point", VX_INP_PNT_GENERAL, 0, &leaderPnt, &idParent);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select coordinate frame, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idDatum);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a coordinate dimension */
int idDim = 0;
if (cvxPartAddCoorDim(&leaderPnt, idParent, &textPnt, idDatum, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddCoorDim: failed to add a coordinate dimension!");
}
void zwTestPartAddDatumDim()
/*
DESCRIPTION:
Test case for function cvxPartAddDatumDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idEnt = 0, idPlane = 0;
char* text = "user text";
cvxGetPoint("select leader point", VX_INP_PNT_ON_ENTITY, 0, &leaderPnt, &idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a datum feature dimension */
int idDim = 0;
if (cvxPartAddDatumDim(idEnt, &leaderPnt, &textPnt, text, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddDatumDim: failed to add a datum feature dimension!");
}
void zwTestPartAddDatumTargetDim()
/*
DESCRIPTION:
Test case for function cvxPartAddDatumTargetDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idEnt = 0, idPlane = 0;
char* text = "user text";
cvxGetPoint("select leader point", VX_INP_PNT_ON_ENTITY, 0, &leaderPnt, &idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
int diameter = 10, width = 15, height = 20;
double val = 0;
cvxGetNumber("select datum target type: 0 - 3", &val); /* type 2 need another point */
/* add a datum target dimension */
int idDim = 0;
if (cvxPartAddDatumTargetDim(idEnt, int(val + 0.5), diameter, width, height, &leaderPnt, &textPnt, text, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddDatumTargetDim: failed to add a datum target dimension!");
}
void zwTestPartAddFcsDim()
/*
DESCRIPTION:
Test case for function cvxPartAddFcsDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idEnt = 0, idPlane = 0;
char* text = "user text";
cvxGetPoint("select leader point", VX_INP_PNT_ON_ENTITY, 0, &leaderPnt, &idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a feature control system dimension */
int idDim = 0;
if (cvxPartAddFcsDim(idEnt, &leaderPnt, &textPnt, text, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddFcsDim: failed to add a feature control system dimension!");
}
void zwTestPartAddSymSrfDim()
/*
DESCRIPTION:
Test case for function cvxPartAddSymSrfDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idEnt = 0, idPlane = 0;
svxRoughTexts text = { "a1", "a2", "b", "c", "e", "f1", "f2", "" };
cvxGetPoint("select leader point", VX_INP_PNT_ON_ENTITY, 0, &leaderPnt, &idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a surface finish label */
int idDim = 0;
if (cvxPartAddSymSrfDim(idEnt, &leaderPnt, &textPnt, &text, idPlane, &idDim) || idDim < 1)
zwTestLogErrorMsg(5, "cvxPartAddSymSrfDim: failed to add a surface finish label!");
}
void zwTestPartAddLabelDim()
/*
DESCRIPTION:
Test case for function cvxPartAddLabelDim.
*/
{
svxPoint leaderPnt = { 0 }, textPnt = { 0 };
int idEnt = 0, idPlane = 0;
char* text = "user text";
cvxGetPoint("select leader point", VX_INP_PNT_ON_ENTITY, 0, &leaderPnt, &idEnt);
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add a label dimension */
int idDim = 0;
if (cvxPartAddLabelDim(idEnt, &leaderPnt, &textPnt, text, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddLabelDim: failed to add a label dimension!");
}
void zwTestPartAddCenLinDim()
/*
DESCRIPTION:
Test case for function cvxPartAddCenLinDim.
*/
{
int idEnt = 0;
cvxGetEnt("select a cylindrical face", VX_INP_FACE, 0, &idEnt);
/* add a center line dimension */
int idDim = 0;
if (cvxPartAddCenLinDim(idEnt, 0, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddCenLinDim: failed to add a center line dimension!");
}
void zwTestPartAddCenMarkDim()
/*
DESCRIPTION:
Test case for function cvxPartAddCenMarkDim.
*/
{
int idEnt = 0;
cvxGetEnt("select an arc or a cylindrical face", VX_INP_GENERAL_3D, 0, &idEnt);
/* add a center mark dimension */
int idDim = 0;
if (cvxPartAddCenMarkDim(idEnt, 0, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddCenMarkDim: failed to add a center mark dimension!");
}
void zwTestPartAddPMIText()
/*
DESCRIPTION:
Test case for function cvxPartAddPMIText.
*/
{
svxPoint textPnt = { 0 };
int idPlane = 0;
char* text = "annotation text";
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
cvxGetEnt("select insertion plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &idPlane);
/* add annotation text */
int idDim = 0;
if (cvxPartAddPMIText(&textPnt, text, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddPMIText: failed to add annotation text!");
}
void zwTestPartAddBalloon()
/*
DESCRIPTION:
Test case for function cvxPartAddBalloon.
*/
{
svxPoint textPnt = { 0 };
int idPlane = 0, fImage = 0;
char* text = "annotation text";
cvxGetPoint("select text point", VX_INP_PNT_GENERAL, 0, &textPnt, nullptr);
/* add text in a balloon */
int idDim = 0;
if (cvxPartAddBalloon(&textPnt, text, fImage, idPlane, &idDim) || idDim == 0)
zwTestLogErrorMsg(5, "cvxPartAddBalloon: failed to add text in a balloon!");
}
cvxPartAddRadDim
evxErrors cvxPartAddRadDim(int idEnt, int radType, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddArcDim
evxErrors cvxPartAddArcDim(int idEnt, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddBalloon
evxErrors cvxPartAddBalloon(svxPoint *TextPnt, char *text, int fImage, int idPlane, int *idDim)
cvxPartAddSymSrfDim
evxErrors cvxPartAddSymSrfDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, svxRoughTexts *textGrp, int idPlane, int *idDim)
cvxPartAddSymmetryDim
evxErrors cvxPartAddSymmetryDim(svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int *idDim)
cvxPartAddFcsDim
evxErrors cvxPartAddFcsDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddCoorDim
evxErrors cvxPartAddCoorDim(svxPoint *LeaderPnt, int idParent, const svxPoint *TextPnt, int idDatum, int idPlane, int *idDim)
cvxPartAddPMIText
evxErrors cvxPartAddPMIText(svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddLabelDim
evxErrors cvxPartAddLabelDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddCenLinDim
evxErrors cvxPartAddCenLinDim(int idEnt, int idPlane, int *idDim)
cvxPartAddCenMarkDim
evxErrors cvxPartAddCenMarkDim(int idEnt, int idPlane, int *idDim)
cvxPartAddDatumTargetDim
evxErrors cvxPartAddDatumTargetDim(int idEnt, int radRype, double diameter, double width, double height, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddAngleDim
evxErrors cvxPartAddAngleDim(int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddLineDim
evxErrors cvxPartAddLineDim(int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddChamferDim
evxErrors cvxPartAddChamferDim(int idEnt1, int idEnt2, const svxPoint *TextPos, int idPlane, int *idDim)
cvxPartAddDatumDim
evxErrors cvxPartAddDatumDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxRoughTexts
Roughness PMI text define.
Definition: zwapi_cmd_pmi_data.h:31
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\shapeFtrCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\shapeFtrCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <string.h>
#include <math.h>
#include <vector>
ApiDefVoidFunc(zwTestPartBox, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartInterXCurve, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCyl, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCone, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSphere, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartEllipsoid, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartExtrude, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFace, VX_CODE_GENERAL); // no macro
ApiDefVoidFunc(zwTestPartRefGeom, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartRevolve, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSweep, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartIns, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartChamConst, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartChamAng, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartChamAsym, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartChamferAll, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFillet, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFilletAll, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartHole, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartThreadAt, VX_CODE_GENERAL); // no macro
ApiDefVoidFunc(zwTestPartShell, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartDraft, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartRib, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartLip, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartStock, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartThicken, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartDivide, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartTrim, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSimplify, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartInlay, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartLoft, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartShapeFaceOffset, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFlagHoles, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFlagExtThread, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartBool, VX_CODE_GENERAL);
void zwTestPartBox()
/*
DESCRIPTION:
Test case for function cvxPartBox.
*/
{
/* initialize a box */
svxBoxData box;
if (cvxPartBoxInit(&box))
zwTestLogErrorMsg(5, "cvxPartBoxInit: failed to initialize a box!");
double val = 0;
cvxGetNumber("select combination method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
box.Combine = VX_BOOL_NONE;
break;
case 1:
box.Combine = VX_BOOL_ADD;
break;
case 2:
box.Combine = VX_BOOL_REMOVE;
break;
case 3:
box.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "cvxPartBox: invalid option!");
break;
}
cvxGetEnt("select a plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &box.idPlane);
if (box.idPlane == 0)
{
cvxGetNumber("whether use axis: 0 or 1", &val);
if (int(val + 0.5))
{
box.useAxis = 1;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &box.axis.Pnt, nullptr);
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&box.axis.Dir, nullptr);
}
}
cvxGetPoint("select center point", VX_INP_PNT_GENERAL, 0, &box.Center, nullptr);
cvxGetNumber("specify x", &box.X);
cvxGetNumber("specify y", &box.Y);
cvxGetNumber("specify z", &box.Z);
strcpy_s(box.ftrName, sizeof(box.ftrName), "boxName");
/* create a box */
int idShape = 0;
if (cvxPartBox(&box, &idShape) || (box.Combine == VX_BOOL_NONE && idShape == 0))
zwTestLogErrorMsg(5, "cvxPartBox: failed to create a box!");
}
void zwTestPartInterXCurve()
/*
DESCRIPTION:
Test case for function cvxPartInterXCurve.
*/
{
/* initialize data */
svxInterCrvData interCrv;
if (cvxPartInterXCurveInit(&interCrv))
zwTestLogErrorMsg(5, "cvxPartInterXCurveInit: failed to initialize data!");
cvxGetEnts("select the first field of intersected surfaces, <middle-click> when done", VX_INP_SHAPE_OR_FACE, 0, &interCrv.iEntCout1, &interCrv.idEnt1);
cvxGetEnts("select the second field of intersected surfaces, <middle-click> when done", VX_INP_SHAPE_OR_FACE, 0, &interCrv.iEntCout2, &interCrv.idEnt2);
double val = 0;
cvxGetNumber("whether trim curves", &val);
if (int(val + 0.5) == 0) /* default 1 */
interCrv.trim = 0;
/* create curves at the intersection of two fields of surfaces */
int idFtr = 0;
if (cvxPartInterXCurve(&interCrv, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartInterXCurve: failed to create curves!");
/* free memory */
cvxMemFree((void**)&interCrv.idEnt1);
cvxMemFree((void**)&interCrv.idEnt2);
}
void zwTestPartCyl()
/*
DESCRIPTION:
Test case for function cvxPartCyl.
*/
{
/* initialize a cylinder */
svxCylData cylinder;
if (cvxPartCylInit(&cylinder))
zwTestLogErrorMsg(5, "cvxPartCylInit: failed to initialize a cylinder!");
double val = 0;
cvxGetNumber("select combination method", &val);
switch (int(val + 0.5))
{
case 0:
cylinder.Combine = VX_BOOL_NONE;
break;
case 1:
cylinder.Combine = VX_BOOL_ADD;
break;
case 2:
cylinder.Combine = VX_BOOL_REMOVE;
break;
case 3:
cylinder.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "zwTestPartCyl: invalid option!");
break;
}
cvxGetEnt("select a plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &cylinder.idPlane);
if (cylinder.idPlane == 0)
{
cvxGetNumber("whether use axis: 0 or 1", &val);
if (int(val + 0.5))
{
cylinder.useAxis = 1;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &cylinder.axis.Pnt, nullptr);
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&cylinder.axis.Dir, nullptr);
}
}
cvxGetPoint("pick the center point of bottom face.", VX_INP_PNT_GENERAL, 0, &cylinder.Center, nullptr);
cvxGetNumber("specify radius", &cylinder.Radius);
cvxGetNumber("specify length", &cylinder.Length);
strcpy_s(cylinder.ftrName, sizeof(cylinder.ftrName), "cylinderName");
/* create a cylinder */
int idShape = 0;
if (cvxPartCyl(&cylinder, &idShape) || (cylinder.Combine == VX_BOOL_NONE && idShape == 0))
zwTestLogErrorMsg(5, "cvxPartCyl: failed to create a cylinder!");
}
void zwTestPartCone()
/*
DESCRIPTION:
Test case for function cvxPartCone.
*/
{
/* initialize a cone */
svxConeData cone;
if (cvxPartConeInit(&cone))
zwTestLogErrorMsg(5, "cvxPartConeInit: failed to initialize a cone!");
double val = 0;
cvxGetNumber("select combination method", &val);
switch (int(val + 0.5))
{
case 0:
cone.Combine = VX_BOOL_NONE;
break;
case 1:
cone.Combine = VX_BOOL_ADD;
break;
case 2:
cone.Combine = VX_BOOL_REMOVE;
break;
case 3:
cone.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "zwTestPartCone: invalid option!");
break;
}
cvxGetEnt("select a plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &cone.idPlane);
if (cone.idPlane == 0)
{
cvxGetNumber("whether use axis: 0 or 1", &val);
if (int(val + 0.5))
{
cone.useAxis = 1;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &cone.axis.Pnt, nullptr);
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&cone.axis.Dir, nullptr);
}
}
cvxGetPoint("pick the center point of bottom face.", VX_INP_PNT_GENERAL, 0, &cone.Center, nullptr);
cvxGetNumber("specify first radius", &cone.Radius1);
cvxGetNumber("specify second radius", &cone.Radius2);
cvxGetNumber("specify length", &cone.Length);
strcpy_s(cone.ftrName, sizeof(cone.ftrName), "coneName");
/* create a cone */
int idShape = 0;
if (cvxPartCone(&cone, &idShape) || (cone.Combine == VX_BOOL_NONE && idShape == 0))
zwTestLogErrorMsg(5, "cvxPartCone: failed to create a cone!");
}
void zwTestPartSphere()
/*
DESCRIPTION:
Test case for function cvxPartSphere.
*/
{
/* initialize a sphere */
svxSphereData sphere;
if (cvxPartSphereInit(&sphere))
zwTestLogErrorMsg(5, "cvxPartSphereInit: failed to initialize a sphere!");
double val = 0;
cvxGetNumber("select combination method", &val);
switch (int(val + 0.5))
{
case 0:
sphere.Combine = VX_BOOL_NONE;
break;
case 1:
sphere.Combine = VX_BOOL_ADD;
break;
case 2:
sphere.Combine = VX_BOOL_REMOVE;
break;
case 3:
sphere.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "zwTestPartSphere: invalid option!");
break;
}
cvxGetPoint("pick the center point.", VX_INP_PNT_GENERAL, 0, &sphere.Center, nullptr);
cvxGetNumber("specify radius", &sphere.Radius);
strcpy_s(sphere.ftrName, sizeof(sphere.ftrName), "sphereName");
/* create a sphere */
int idShape = 0;
if (cvxPartSphere(&sphere, &idShape) || (sphere.Combine == VX_BOOL_NONE && idShape == 0))
zwTestLogErrorMsg(5, "cvxPartSphere: failed to create a sphere!");
}
void zwTestPartEllipsoid()
/*
DESCRIPTION:
Test case for function cvxPartEllipsoid.
*/
{
/* initialize an ellipsoid */
svxEllsoData ellipsoid;
if (cvxPartEllipsoidInit(&ellipsoid))
zwTestLogErrorMsg(5, "cvxPartEllipsoidInit: failed to initialize an ellipsoid!");
double val = 0;
cvxGetNumber("select combination method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
ellipsoid.Combine = VX_BOOL_NONE;
break;
case 1:
ellipsoid.Combine = VX_BOOL_ADD;
break;
case 2:
ellipsoid.Combine = VX_BOOL_REMOVE;
break;
case 3:
ellipsoid.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "zwTestPartEllipsoid: invalid option!");
break;
}
cvxGetEnt("select a plane, <middle click> to ignore", VX_INP_DATUM_PLANE, 1, &ellipsoid.idPlane);
if (ellipsoid.idPlane == 0)
{
cvxGetNumber("whether use axis: 0 or 1", &val);
if (int(val + 0.5))
{
ellipsoid.useAxis = 1;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &ellipsoid.axis.Pnt, nullptr);
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&ellipsoid.axis.Dir, nullptr);
}
}
cvxGetPoint("select center point", VX_INP_PNT_GENERAL, 0, &ellipsoid.Center, nullptr);
cvxGetNumber("specify x", &ellipsoid.xLen);
cvxGetNumber("specify y", &ellipsoid.yLen);
cvxGetNumber("specify z", &ellipsoid.zLen);
strcpy_s(ellipsoid.ftrName, sizeof(ellipsoid.ftrName), "ellipsoidName");
/* create an ellipsoid */
int idShape = 0;
if (cvxPartEllipsoid(&ellipsoid, &idShape) || (ellipsoid.Combine == VX_BOOL_NONE && idShape == 0))
zwTestLogErrorMsg(5, "cvxPartEllipsoid: failed to create an ellipsoid!");
}
void zwTestPartExtrude()
/*
DESCRIPTION:
Test case for function cvxPartExtrude.
*/
{
/* initialize an extrusion */
svxExtrudeData extrude;
if (cvxPartExtrudeInit(&extrude))
zwTestLogErrorMsg(5, "cvxPartExtrudeInit: failed to initialize an extrusion!");
cvxGetEnt("select a profile", VX_INP_PROF, 0, &extrude.idProfile);
svxPoint profStart = { 0 }, profEnd = { 0 };
cvxEntEndPnt(extrude.idProfile, &profStart, &profEnd);
bool isOpen = (cvxPntDist(&profStart, &profEnd) > 1e-12);
/* boolean option */
double val = 0;
cvxGetNumber("select combination method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
extrude.Combine = VX_BOOL_NONE;
break;
case 1:
extrude.Combine = VX_BOOL_ADD;
break;
case 2:
extrude.Combine = VX_BOOL_REMOVE;
break;
case 3:
extrude.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "zwTestPartExtrude: invalid option!");
break;
}
if (extrude.Combine != VX_BOOL_NONE)
cvxGetEnts("select some shapes to boolean, <middle-click> when done", VX_INP_SHAPE, 0, &extrude.numBooleanEnts, &extrude.BooleanEnts);
/* set start and end */
double boundZ = 0;
int idFace = 0;
svxPoint start = { 0 }, end = { 0 }, * points = nullptr;
svxBndBox bound = { 0 };
cvxGetNumber("select start type:0-input value, 1-through all, 2-to point, 3-to faces, 4-extend face", &val);
switch (int(val + 0.5))
{
case 0:
extrude.StartType = VX_INPU_VALUE;
cvxGetNumber("specify start distance", &extrude.Start);
break;
case 1:
if (extrude.Combine == VX_BOOL_REMOVE)
extrude.StartType = VX_BY_THROUGH_ALL;
else
zwTestLogErrorMsg(5, "cvxPartExtrude: \"through all\" is only available in \"remove\"!");
break;
case 2:
extrude.StartType = VX_TO_POINT;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &start, &extrude.idStartEnt);
extrude.StartToPnt = &start;
break;
case 3:
extrude.StartType = VX_TO_FACES;
/* find max Z bound of faces */
while (true)
{
cvxGetPoint("select some faces, <middle click> to finish", VX_INP_PNT_ON_ANY_FACE, 1, &start, &idFace);
if (idFace == 0)
break;
cvxEntBndBox(idFace, &bound);
if (extrude.idStartEnt == 0)
{
extrude.StartToPnt = &start;
extrude.idStartEnt = idFace;
}
else
{
boundZ = bound.Z.max;
cvxEntBndBox(extrude.idStartEnt, &bound);
if (boundZ > bound.Z.max)
{
extrude.StartToPnt = &start;
extrude.idStartEnt = idFace;
}
}
};
cvxGetNumber("specify start offset", &extrude.StartOffset);
break;
case 4:
extrude.StartType = VX_TO_EXTEND_FACE;
cvxGetPoint("select an extend face", VX_INP_PNT_ON_ANY_FACE, 0, &start, &extrude.idStartEnt);
extrude.StartToPnt = &start;
cvxGetNumber("specify start offset", &extrude.StartOffset);
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtrude: invalid option!");
break;
}
cvxGetNumber("select end type:0-input value, 1-through all, 2-to point, 3-to faces, 4-extend face", &val);
switch (int(val + 0.5))
{
case 0:
extrude.EndType = VX_INPU_VALUE;
cvxGetNumber("specify end distance", &extrude.End);
break;
case 1:
if (extrude.Combine == VX_BOOL_REMOVE)
extrude.EndType = VX_BY_THROUGH_ALL;
else
zwTestLogErrorMsg(5, "cvxPartExtrude: \"through all\" is only available in \"remove\"!");
break;
case 2:
extrude.EndType = VX_TO_POINT;
cvxGetPoint("select end point", VX_INP_PNT_GENERAL, 0, &end, &extrude.idEndEnt);
extrude.EndToPnt = &end;
break;
case 3:
extrude.EndType = VX_TO_FACES;
/* find min Z bound of faces */
while (true) {
cvxGetPoint("select some faces, <middle-click> to ignore", VX_INP_PNT_ON_ANY_FACE, 1, &end, &idFace);
if (idFace == 0)
break;
cvxEntBndBox(idFace, &bound);
if (extrude.idEndEnt == 0)
{
extrude.EndToPnt = &end;
extrude.idEndEnt = idFace;
}
else
{
boundZ = bound.Z.min;
cvxEntBndBox(extrude.idEndEnt, &bound);
if (boundZ < bound.Z.min)
{
extrude.EndToPnt = &end;
extrude.idEndEnt = idFace;
}
}
};
cvxGetNumber("specify end offset", &extrude.EndOffset);
break;
case 4:
extrude.EndType = VX_TO_EXTEND_FACE;
cvxGetPoint("select an extend face", VX_INP_PNT_ON_ANY_FACE, 0, &end, &extrude.idEndEnt);
extrude.EndToPnt = &end;
cvxGetNumber("specify end offset", &extrude.EndOffset);
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtrude: invalid option!");
break;
}
cvxGetNumber("whether use direction: 0 or 1", &val);
if (int(val + 0.5))
{
extrude.UseDirection = 1;
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&extrude.Direction, nullptr);
}
/* draft option */
cvxGetNumber("specify draft angle", &extrude.Draft);
if (extrude.Draft)
{
cvxGetNumber("select blend method: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
extrude.Blend = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtrude: invalid option!");
break;
}
cvxGetNumber("whether use extrude direction: 0 or 1", &val);
if (int(val + 0.5))
{
extrude.UseDirection = 1;
cvxGetPoint("select a direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&extrude.Direction, nullptr);
}
}
/* offset option */
cvxGetNumber("select offset type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
extrude.OffsetTyp = VX_OFFSET_NONE;
break;
case 1:
extrude.OffsetTyp = VX_OFFSET_SHRINK;
cvxGetNumber("specify profile offset", &extrude.Offset);
break;
case 2:
extrude.OffsetTyp = VX_OFFSET_THICKEN;
cvxGetNumber("specify profile offset", &extrude.Offset);
cvxGetNumber("specify wall thickness", &extrude.Thickness);
break;
case 3:
extrude.OffsetTyp = VX_OFFSET_THICKEN_SAME;
cvxGetNumber("specify profile offset", &extrude.Offset);
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtrude: invalid option!");
break;
}
strcpy_s(extrude.ftrName, sizeof(extrude.ftrName), "extrudeName");
/* twist option */
cvxGetNumber("specify twist angle", &extrude.Twist);
if (extrude.Twist)
cvxGetPoint("select a pivot point", VX_INP_PNT_GENERAL, 0, &extrude.Pivot, nullptr);
/* profile cap option */
if (extrude.Combine == VX_BOOL_ADD || extrude.Combine == VX_BOOL_REMOVE && isOpen)
{
cvxGetNumber("whether use profile cap option: 0 or 1", &val);
if (int(val + 0.5))
{
cvxGetNumber("select end cap type", &val);
switch (int(val + 0.5))
{
case 0:
extrude.CapType = VX_END_CAP_BOTH;
break;
case 1:
extrude.CapType = VX_END_CAP_START;
break;
case 2:
extrude.CapType = VX_END_CAP_END;
break;
case 3:
extrude.CapType = VX_END_CAP_NONE;
break;
default:
zwTestLogErrorMsg(5, "cvxPartExtrude: invalid option!");
break;
}
cvxGetEnts("select some faces, <middle-click> when done", VX_INP_FACE, 0, &extrude.cntCap, &extrude.CapFace);
}
}
if (isOpen || extrude.CapType == VX_END_CAP_END)
{
cvxGetNumber("whether flip face direction", &val);
if (int(val + 0.5))
extrude.FlipFaceDir = 1;
}
/* create an extrusion */
int idExtrude = 0;
if (cvxPartExtrude(&extrude, &idExtrude) || extrude.Combine == VX_BOOL_NONE && idExtrude == 0)
zwTestLogErrorMsg(5, "cvxPartExtrude: failed to extrude!");
/* free memory */
cvxMemFree((void**)&extrude.BooleanEnts);
cvxMemFree((void**)&points);
cvxMemFree((void**)&extrude.CapFace);
}
void zwTestPartFace()
/*
DESCRIPTION:
Test case for function cvxPartFace.
*/
{
/* not finished yet */
/* select a surface and initialize data */
int idSurface = 0;
cvxGetEnt("select a surface", VX_INP_FACE, 0, &idSurface);
svxSurface surface;
cvxPartInqFaceSrf(idSurface, &surface);
/* select some trim curves */
int numCurces = 0, * idCurves = nullptr;
cvxGetEnts("select some curves, <middle click> to ignore", VX_INP_EDGE_OR_CURVE, 1, &numCurces, &idCurves);
svxCurve* curves = nullptr;
cvxMemAlloc(numCurces * sizeof(svxCurve), (void**)&curves);
for (int i = 0; i < numCurces; i++)
cvxPartInqCurve(idCurves[i], 1, &curves[i]);
int sew = 0;
double val = 0;
cvxGetNumber("whether sew face to adjacent face: 0 or 1", &val);
if (int(val + 0.5))
sew = 1;
double tolerance = 0;
cvxGetNumber("specify tolerance: 0.01 as default", &tolerance);
/* create a new surface */
int idNewFace = 0;
if (cvxPartFace(&surface, numCurces, curves, 1, sew, tolerance, &idNewFace) || idNewFace == 0)
zwTestLogErrorMsg(5, "cvxPartFace: failed to create a surface!");
/* free memory */
cvxSurfaceFree(&surface);
cvxMemFree((void**)&idCurves);
for (int i = 0; i < numCurces; i++)
cvxCurveFree(&curves[i]);
cvxMemFree((void**)&curves);
}
void zwTestPartRefGeom()
/*
DESCRIPTION:
Test case for function cvxPartRefGeom.
*/
{
/* select a geometry */
svxEntPath path;
cvxGetEntPath("select a geometry", VX_INP_3D_GEOM, 0, &path);
double val = 0;
cvxGetNumber("select a copy method: 0 - 3", &val);
int copy = 0;
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
case 3:
copy = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartRefGeom: invalid option!");
break;
}
/* create reference geometry */
int idGeometry = 0;
if (cvxPartRefGeom(&path, 0, &idGeometry) || idGeometry == 0)
zwTestLogErrorMsg(5, "cvxPartRefGeom: failed to create reference geometry!");
}
void zwTestPartRevolve()
/*
DESCRIPTION:
Test case for function cvxPartRevolve.
*/
{
/* initialize revolve */
svxRevolveData revolve;
if (cvxPartRevolveInit(&revolve))
zwTestLogErrorMsg(5, "cvxPartRevolveInit: failed to initialize!");
cvxGetEnt("select a profile to revolve", VX_INP_PROF, 0, &revolve.idProfile);
cvxGetPoint("specify origin of axis", VX_INP_PNT_GENERAL, 0, &revolve.Axis.Pnt, nullptr);
cvxGetPoint("specify direction of axis", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&revolve.Axis.Dir, nullptr);
/* boolean option */
double val = 0;
cvxGetNumber("select combination method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
revolve.Combine = VX_BOOL_NONE;
break;
case 1:
revolve.Combine = VX_BOOL_ADD;
break;
case 2:
revolve.Combine = VX_BOOL_REMOVE;
break;
case 3:
revolve.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "cvxPartRevolve: invalid option!");
break;
}
/* set start and end */
svxPoint start = { 0 }, end = { 0 };
cvxGetNumber("select start type: 0, 1, 2, 4 or 5", &val);
switch (int(val + 0.5))
{
case 0:
revolve.StartType = VX_INPU_VALUE;
cvxGetNumber("specify start angle", &revolve.Start);
break;
case 1:
if (revolve.Combine == VX_BOOL_REMOVE)
revolve.StartType = VX_BY_THROUGH_ALL;
else
zwTestLogErrorMsg(5, "cvxPartRevolve: \"through all\" is only available in \"remove\"!");
break;
case 2:
revolve.StartType = VX_TO_POINT;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &start, &revolve.idStartEnt);
revolve.StartPnt = &start;
break;
case 4:
revolve.StartType = VX_TO_EXTEND_FACE;
cvxGetPoint("select a face", VX_INP_PNT_ON_ANY_FACE, 0, &start, &revolve.idStartEnt);
revolve.StartPnt = &start;
break;
case 5:
revolve.StartType = VX_TO_FACE;
cvxGetPoint("select a face", VX_INP_PNT_ON_ANY_FACE, 0, &start, &revolve.idStartEnt);
revolve.StartPnt = &start;
break;
default:
break;
}
cvxGetNumber("select end type: 0, 1, 2, 4 or 5", &val);
switch (int(val + 0.5))
{
case 0:
revolve.EndType = VX_INPU_VALUE;
cvxGetNumber("specify end angle", &revolve.End);
break;
case 1:
if (revolve.Combine == VX_BOOL_REMOVE)
revolve.EndType = VX_BY_THROUGH_ALL;
else
zwTestLogErrorMsg(5, "cvxPartRevolve: \"through all\" is only available in \"remove\"!");
break;
case 2:
revolve.EndType = VX_TO_POINT;
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &end, &revolve.idEndEnt);
revolve.EndPnt = &end;
break;
case 4:
revolve.EndType = VX_TO_EXTEND_FACE;
cvxGetPoint("select a face", VX_INP_PNT_ON_ANY_FACE, 0, &end, &revolve.idEndEnt);
revolve.EndPnt = &end;
break;
case 5:
revolve.EndType = VX_TO_FACE;
cvxGetPoint("select a face", VX_INP_PNT_ON_ANY_FACE, 0, &end, &revolve.idEndEnt);
revolve.EndPnt = &end;
break;
default:
break;
}
/* offset option */
cvxGetNumber("specify offset type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
revolve.OffsetTyp = VX_OFFSET_NONE;
break;
case 1:
revolve.OffsetTyp = VX_OFFSET_SHRINK;
cvxGetNumber("specify profile offset", &revolve.Offset);
break;
case 2:
revolve.OffsetTyp = VX_OFFSET_THICKEN;
cvxGetNumber("specify profile offset", &revolve.Offset);
cvxGetNumber("specify wall thickness", &revolve.Thickness);
break;
case 3:
revolve.OffsetTyp = VX_OFFSET_THICKEN_SAME;
cvxGetNumber("specify profile offset", &revolve.Offset);
break;
default:
zwTestLogErrorMsg(5, "cvxPartRevolve: invalid option!");
break;
}
/* profile cap option */
svxPoint profStart = { 0 }, profEnd = { 0 };
cvxEntEndPnt(revolve.idProfile, &profStart, &profEnd);
bool isClose = (cvxPntDist(&profStart, &profEnd) < 1e-12);
if (isClose)
{
cvxGetNumber("select cap type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
revolve.CapType = VX_END_CAP_BOTH;
break;
case 1:
revolve.CapType = VX_END_CAP_START;
break;
case 2:
revolve.CapType = VX_END_CAP_END;
break;
case 3:
revolve.CapType = VX_END_CAP_NONE;
break;
default:
zwTestLogErrorMsg(5, "cvxPartRevolve: invalid option!");
break;
}
if (revolve.CapType == VX_END_CAP_NONE)
{
cvxGetNumber("whether flip face direction: 0 or 1", &val);
if (val + 0.5)
revolve.Flip = 1;
}
}
/* revolve profile */
int idShape = 0;
if (cvxPartRevolve(&revolve, &idShape) || revolve.Combine == VX_BOOL_NONE && idShape == 0)
zwTestLogErrorMsg(5, "cvxPartRevolve: failed to revolve!");
}
void zwTestPartSweep()
/*
DESCRIPTION:
Test case for function cvxPartSweep.
*/
{
/* initialize sweep */
svxSweepData sweep;
if (cvxPartSweepInit(&sweep))
zwTestLogErrorMsg(5, "cvxPartSweepInit: failed to initialize!");
cvxGetEnt("select a profile to sweep", VX_INP_PROF, 0, &sweep.idProfile);
cvxGetEnt("select a sweep path", VX_INP_PROF, 0, &sweep.idPath);
double val = 0;
cvxGetNumber("whether identify the start point of sweep path: 0 or 1", &val);
if (int(val + 0.5))
{
sweep.useStartPnt = 1;
cvxGetPoint("select the start point of sweep curve", VX_INP_PNT_ON_CRV_OR_PROF, 0, &sweep.StartPnt, nullptr);
}
/* boolean option */
cvxGetNumber("select combination method: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
sweep.Combine = VX_BOOL_NONE;
break;
case 1:
sweep.Combine = VX_BOOL_ADD;
break;
case 2:
sweep.Combine = VX_BOOL_REMOVE;
break;
case 3:
sweep.Combine = VX_BOOL_INTERSECT;
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
/* orientation option */
cvxGetNumber("select sweep option: 0 - 4", &val);
switch (int(val + 0.5))
{
case 0:
sweep.Option = VX_SWP_NATURAL;
break;
case 1:
sweep.Option = VX_SWP_AT_PATH;
break;
case 2:
sweep.Option = VX_SWP_FRAME;
cvxGetEnt("select a frame", VX_INP_DATUM_PLANE, 0, &sweep.idFrame);
break;
case 3:
sweep.Option = VX_SWP_AT_PROFILE;
break;
case 4:
sweep.Option = VX_SWP_ALONG_PATH;
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
cvxGetNumber("select the type of Z-axis: 0 - 2", &val);
svxPntOnEnt entZ = { 0 };
sweep.zEnt = &entZ;
switch (int(val + 0.5))
{
case 0:
sweep.zOpt = VX_SWP_Z_TANG_TO_PATH;
break;
case 1:
sweep.zOpt = VX_SWP_Z_TANG_TO_CRV;
cvxGetPoint("select a tangent curve", VX_INP_PNT_ON_CRV_OR_PROF, 0, &entZ.pnt, &entZ.idEnt);
break;
case 2:
sweep.zOpt = VX_SWP_Z_FIXED_DIR;
entZ.useDir = 1;
cvxGetPoint("select a fixed direction", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &entZ.pnt, &entZ.idEnt);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
cvxGetNumber("select the type of X-axis: 0 - 3", &val);
svxPntOnEnt entX = { 0 };
sweep.xEnt = &entX;
switch (int(val + 0.5))
{
case 0:
sweep.xOpt = VX_SWP_X_MIN_TWIST;
break;
case 1:
sweep.xOpt = VX_SWP_X_FIXED_DIR;
entX.useDir = 1;
cvxGetPoint("select a fixed direction", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &entX.pnt, &entX.idEnt);
break;
case 2:
sweep.xOpt = VX_SWP_X_XAXIS_CRV;
cvxGetPoint("select X-axis curve", VX_INP_PNT_ON_CRV_OR_PROF, 0, &entX.pnt, &entX.idEnt);
break;
case 3:
sweep.xOpt = VX_SWP_X_FACE_NORMAL;
cvxGetPoint("select a face", VX_INP_PNT_ON_ANY_FACE, 0, &entX.pnt, &entX.idEnt);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
/* offset option */
cvxGetNumber("specify offset type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
sweep.OffsetTyp = VX_OFFSET_NONE;
break;
case 1:
sweep.OffsetTyp = VX_OFFSET_SHRINK;
cvxGetNumber("specify profile offset", &sweep.Offset);
break;
case 2:
sweep.OffsetTyp = VX_OFFSET_THICKEN;
cvxGetNumber("specify profile offset", &sweep.Offset);
cvxGetNumber("specify wall thickness", &sweep.Thickness);
break;
case 3:
sweep.OffsetTyp = VX_OFFSET_THICKEN_SAME;
cvxGetNumber("specify profile offset", &sweep.Offset);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
/* profile cap option */
svxPoint profStart = { 0 }, profEnd = { 0 };
cvxEntEndPnt(sweep.idProfile, &profStart, &profEnd);
bool isClose = (cvxPntDist(&profStart, &profEnd) < 1e-12);
if (isClose)
{
cvxGetNumber("select end cap type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
sweep.CapType = VX_END_CAP_BOTH;
break;
case 1:
sweep.CapType = VX_END_CAP_START;
break;
case 2:
sweep.CapType = VX_END_CAP_END;
break;
case 3:
sweep.CapType = VX_END_CAP_NONE;
break;
default:
zwTestLogErrorMsg(5, "cvxPartSweep: invalid option!");
break;
}
}
if (sweep.Combine == VX_BOOL_ADD || sweep.Combine == VX_BOOL_REMOVE && !isClose)
cvxGetEnts("pick cap faces, <middle click> to ignore", VX_INP_FACE, 1, &sweep.cntCap, &sweep.CapFace);
cvxGetNumber("whether merge tangent faces: 0 or 1", &val);
if (int(val + 0.5))
sweep.MergeFc = 1;
/* sweep profile */
int idShape = 0;
if (cvxPartSweep(&sweep, nullptr, &idShape) || sweep.Combine == VX_BOOL_NONE && idShape == 0)
zwTestLogErrorMsg(5, "cvxPartSweep: failed to sweep!");
/* free memory */
cvxMemFree((void**)&sweep.CapFace);
}
void zwTestPartIns()
/*
DESCRIPTION:
Test case for function cvxPartIns.
*/
{
/* insert a .Z3PRT file */
svxPartInstData partInsertion = {};
double val = 0;
cvxGetNumber("Select file to insert(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
vxLongPath filePath = "\0";
cvxGetFileByLongPath(1, "Select the file for insertion...", workDir, "Part(*.Z3PRT)|*.Z3PRT|", filePath, sizeof(filePath));
if (filePath[0] != '\0')
{
cvxPathDirByLongPath(filePath, partInsertion.Dir, sizeof(partInsertion.Dir));
cvxPathFileByLongPath(filePath, partInsertion.File, sizeof(partInsertion.File));
strcpy_s(partInsertion.Part, sizeof(partInsertion.Part), partInsertion.File);
char* ch = strrchr(partInsertion.Part, '.');
if (ch) *ch = '\0';
}
}
else
{
vxLongName actFile = "\0";
cvxFileInqActive(actFile, sizeof(actFile));
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
char* ch = strrchr(fileList[i], '.');
if (_strcmpi(actFile, fileList[i]) && !_strcmpi(ch + 1, "Z3PRT"))
{
strcpy_s(partInsertion.File, sizeof(partInsertion.File), fileList[i]);
strcpy_s(partInsertion.Part, sizeof(partInsertion.Part), fileList[i]);
char* ch = strrchr(partInsertion.Part, '.');
if (ch) *ch = '\0';
break;
}
}
cvxMemFree((void**)&fileList);
}
if (partInsertion.File[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestPartIns: insertion file not specified!");
return;
}
cvxGetNumber("select copy option: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
case 1:
case 2:
case 3:
partInsertion.Option = int(val + 0.5);
break;
default:
zwTestLogErrorMsg(5, "cvxPartIns: invalid option!");
break;
}
if (partInsertion.Option != 2)
{
svxPoint location = { 0 };
cvxGetPoint("select insertion location", VX_INP_PNT_GENERAL, 0, &location, nullptr);
partInsertion.Frame.xx = partInsertion.Frame.yy = partInsertion.Frame.zz = 1;
partInsertion.Frame.xt = location.x;
partInsertion.Frame.yt = location.y;
partInsertion.Frame.zt = location.z;
cvxGetNumber("whether copy wireframe: 0 or 1", &val);
if (int(val + 0.5))
partInsertion.CopyWire = 1;
cvxGetNumber("whether copy dimension: 0 or 1", &val);
if (int(val + 0.5))
partInsertion.CopyDim = 1;
}
/* copy and insert the specified part */
int count = 0;
int* idShapeList = nullptr;
if (cvxPartIns(&partInsertion, &count, &idShapeList))
zwTestLogErrorMsg(5, "cvxPartIns: failed to copy and insert the specified part!");
/* free memory */
if (count > 0 && idShapeList)
cvxMemFree((void**)&idShapeList);
}
void zwTestPartChamConst()
/*
DESCRIPTION:
Test case for function cvxPartChamConst.
*/
{
/* select edge(s) to chamfer */
int numEdges = 0, * idEdges = nullptr;
cvxGetEnts("[Chamfer Edge]Select chamfer edge(s), <middle-click> when done", VX_INP_EDGE, 0, &numEdges, &idEdges);
/* chamfer edge(s) */
double setback = 5;
cvxGetNumber("[Chamfer Setback]Specify setback", &setback);
if (cvxPartChamConst(numEdges, idEdges, setback))
zwTestLogErrorMsg(5, "cvxPartChamConst: failed to chamfer!");
/* free memory */
cvxMemFree((void**)&idEdges);
}
void zwTestPartChamAng()
/*
DESCRIPTION:
Test case for function cvxPartChamAng.
*/
{
/* select edge(s) to chamfer and select the first side */
int countEdges = 0, * idEdges = nullptr;
cvxGetEnts("[Chamfer Edge]Select chamfer edge(s), <middle-click> when done", VX_INP_EDGE, 0, &countEdges, &idEdges);
int idFace = 0;
cvxGetEnt("[Chamfer Face]Select the face on the first side", VX_INP_FACE, 0, &idFace);
/* chamfer edge(s) */
double setback = 5, angle = 30;
cvxGetNumber("[Chamfer Setback]Specify setback", &setback);
cvxGetNumber("[Chamfer Angle]Specify angle", &angle);
if (cvxPartChamAng(countEdges, idEdges, idFace, setback, angle))
zwTestLogErrorMsg(5, "cvxPartChamAng: failed to chamfer!");
/* free memory */
cvxMemFree((void**)&idEdges);
}
void zwTestPartChamAsym()
/*
DESCRIPTION:
Test case for function cvxPartChamAsym.
*/
{
/* select edge(s) to chamfer and select the first side */
int countEdges = 0, * idEdges = nullptr;
cvxGetEnts("[Chamfer Edge]Select chamfer edge(s), <middle-click> when done", VX_INP_EDGE, 0, &countEdges, &idEdges);
int idFace = 0;
cvxGetEnt("[Chamfer Face]Select the face on the first side", VX_INP_FACE, 0, &idFace);
/* chamfer edges */
double setback1 = 5, setback2 = 10;
cvxGetNumber("[Chamfer Setback1]Specify first setback", &setback1);
cvxGetNumber("[Chamfer Setback2]Specify second setback", &setback2);
if (cvxPartChamAsym(countEdges, idEdges, idFace, setback1, setback2))
zwTestLogErrorMsg(5, "cvxPartChamAsym: failed to chamfer!");
/* free memory */
cvxMemFree((void**)&idEdges);
}
void zwTestPartChamferAll()
/*
DESCRIPTION:
Test case for function cvxPartChamferAll.
*/
{
/* chamfer data */
svxChamFlltData cham;
if (cvxPartChamferAllInit(&cham))
zwTestLogErrorMsg(5, "cvxPartChamferAllInit: failed to initialize chamfer!");
/* set chamfer type */
double val = 0;
char prompt[256] = "\0";
strcpy_s(prompt,
sizeof(prompt),
"[Chamfer Type]The default type is Symmetrical chamfering, enter number to switch type(1: double "
"offset chamfer; 2: offset and angle chamfer; 3: vertex chamfer)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: cham.type = VX_CHAMFLLT_ASYMMETRIC; break;
case 2: cham.type = VX_CHAMFLLT_SETBACK_ANGLE; break;
case 3: cham.type = VX_CHAMFLLT_VERTEX; break;
default: cham.type = VX_CHAMFLLT_SYMMETRIC; break;
}
/* set offset method */
if (cham.type == VX_CHAMFLLT_SYMMETRIC || cham.type == VX_CHAMFLLT_ASYMMETRIC)
{
strcpy_s(prompt,
sizeof(prompt),
"[Offset Method]The default method is offset distance, enter number to switch method(1: offset surface)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.offsetType = 1;
}
/* initialize set-list data */
svxChamFlltSetData chamSet = { 0 };
if (cvxChamFlltSetDataInit(&chamSet))
zwTestLogErrorMsg(5, "cvxChamFlltSetDataInit: failed to initialize set-list!");
cham.cntList = 1;
cham.pChamFlltDataList = &chamSet;
/* select chamfer edge(s) or vertex */
int idEdge = 0, vertex = 0;
if (cham.type != VX_CHAMFLLT_VERTEX)
{
strcpy_s(prompt,
sizeof(prompt),
"[Chamfer Edge]Select chamfer edge(s), <middle-click> when done");
cvxGetEnts(prompt, VX_INP_EDGE, 0, &chamSet.nEdges, &chamSet.idEdge);
}
else
{
svxPoint point = { 0 }, stPnt = { 0 }, endPnt = { 0 };
strcpy_s(prompt, sizeof(prompt), "[Chamfer Vertex]Select a point on an edge to identify the chamfering vertex");
cvxGetPoint(prompt, VX_INP_PNT_ON_EDGE, 0, &point, &idEdge);
cvxEntEndPnt(idEdge, &stPnt, &endPnt);
if (cvxPntDist(&point, &stPnt) > cvxPntDist(&point, &endPnt)) vertex = 1;
chamSet.nEdges = 1;
chamSet.idEdge = &idEdge;
chamSet.vertex = &vertex;
cham.vertex = &vertex;
}
/* set chamfer value */
svxPntOnEnt pntOnEnt[2] = { 0 };
for (int i = 0; i < 2; i++)
{
if (cham.type == VX_CHAMFLLT_SETBACK_ANGLE && i == 1)
{
chamSet.angle = 30; break;
}
strcpy_s(prompt,
sizeof(prompt),
"[Chamfer Setback]Defaults to the specified value, enter number to switch mode(1: to point)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1:
cvxGetPoint("select a point on face", VX_INP_PNT_ON_ANY_FACE, 0, &pntOnEnt[i].pnt, &pntOnEnt[i].idEnt);
if (i == 0) chamSet.setback1Pnt = &pntOnEnt[i];
if (i == 1) chamSet.setback2Pnt = &pntOnEnt[i];
break;
default:
if (i == 0) chamSet.setback1 = 3;
if (i == 1) chamSet.setback2 = 6;
break;
}
if (cham.type != VX_CHAMFLLT_SETBACK_ANGLE && cham.type != VX_CHAMFLLT_ASYMMETRIC)
break;
}
/* set base face processing method */
strcpy_s(prompt,
sizeof(prompt),
"[Base face processing method]The default is sew, enter number to switch method(1: trim; 2: divide; 3: no action)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: cham.baseFaces = 1; break;
case 2: cham.baseFaces = 2; break;
case 3: cham.baseFaces = 3; break;
default: cham.baseFaces = 0; break;
}
/* other settings */
if (cham.type != VX_CHAMFLLT_VERTEX)
{
strcpy_s(prompt, sizeof(prompt), "[Hold chamfer to edge]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.filletToEdge = 1;
strcpy_s(prompt, sizeof(prompt), "[Use patch for tight corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.usePatch = 1;
strcpy_s(prompt, sizeof(prompt), "[Search for undercuts]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.undercuts = 1;
strcpy_s(prompt, sizeof(prompt), "[Force local corner]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.localCorner = 1;
strcpy_s(prompt, sizeof(prompt), "[Mitred corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.mitred = 1;
strcpy_s(prompt, sizeof(prompt), "[Trace corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) cham.traceCorners = 1;
strcpy_s(prompt, sizeof(prompt), "[Blend corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1)
{
cham.blendCorners = 1;
cham.desity = 20;
}
strcpy_s(prompt,
sizeof(prompt),
"[Chamfer face match method]The default is tangent match, enter number to switch method(1: minimal; 2: "
"maximal)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: cham.filletFace = 1; break;
case 2: cham.filletFace = 2; break;
default: cham.filletFace = 0; break;
}
}
/* chamfer edge(s) */
int idChamfer = 0;
if (cvxPartChamferAll(&cham, &idChamfer) || idChamfer == 0)
zwTestLogErrorMsg(5, "cvxPartChamferAll: failed to chamfer!");
/* free memory */
if (cham.type != VX_CHAMFLLT_VERTEX)
cvxMemFree((void**)&chamSet.idEdge);
}
void zwTestPartFillet()
/*
DESCRIPTION:
Test case for function cvxPartFillet.
*/
{
/* select edge(s) to fillet */
int countEdges = 0, * idEdges = nullptr;
cvxGetEnts("[Fillet Edge]Select fillet edge(s), <middle-click> when done ", VX_INP_EDGE, 0, &countEdges, &idEdges);
double radius = 5;
cvxGetNumber("[Fillet Radius]Specify radius", &radius);
/* fillet edges */
if (cvxPartFillet(countEdges, idEdges, radius))
zwTestLogErrorMsg(5, "cvxPartFillet: failed to fillet!");
/* free memory */
cvxMemFree((void**)&idEdges);
}
void zwTestPartFilletAll()
/*
DESCRIPTION:
Test case for function cvxPartFilletAll.
*/
{
/* initialize fillet data */
svxChamFlltData fllt;
if (cvxPartFilletAllInit(&fllt))
zwTestLogErrorMsg(5, "cvxPartFilletAllInit: failed to initialize fillet!");
double val = 0;
char prompt[256] = "\0";
/* set fillet type */
strcpy_s(prompt,
sizeof(prompt),
"[Fillet Type]The default type is Symmetrical Fillet, enter number to switch type(1: double "
"offset Fillet; 2: offset and angle Fillet; 3: vertex Fillet)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: fllt.type = VX_CHAMFLLT_ASYMMETRIC; break;
case 2: fllt.type = VX_CHAMFLLT_SETBACK_ANGLE; break;
case 3: fllt.type = VX_CHAMFLLT_VERTEX; break;
default: fllt.type = VX_CHAMFLLT_SYMMETRIC; break;
}
/* initialize set-list data */
svxChamFlltSetData flltSet;
if (cvxChamFlltSetDataInit(&flltSet))
zwTestLogErrorMsg(5, "cvxChamFlltSetDataInit: failed to initialize set-list!");
fllt.cntList = 1;
fllt.pChamFlltDataList = &flltSet;
/* select fillet edge(s) or vertex */
int idEdge = 0, vertex = 0;
if (fllt.type != VX_CHAMFLLT_VERTEX)
{
strcpy_s(prompt,
sizeof(prompt),
"[Fillet Edge]Select fillet edge(s), <middle-click> when done");
cvxGetEnts(prompt, VX_INP_EDGE, 0, &flltSet.nEdges, &flltSet.idEdge);
}
else
{
svxPoint point = { 0 }, stPnt = { 0 }, endPnt = { 0 };
strcpy_s(prompt, sizeof(prompt), "[Fillet Vertex]Select a point on an edge to identify the fillet vertex");
cvxGetPoint(prompt, VX_INP_PNT_ON_EDGE, 0, &point, &idEdge);
cvxEntEndPnt(idEdge, &stPnt, &endPnt);
if (cvxPntDist(&point, &stPnt) > cvxPntDist(&point, &endPnt)) vertex = 1;
flltSet.nEdges = 1;
flltSet.idEdge = &idEdge;
flltSet.vertex = &vertex;
fllt.vertex = &vertex;
}
/* set fillet setback */
svxPntOnEnt pntOnEnt[2] = { 0 };
for (int i = 0; i < 2; i++)
{
if (fllt.type == VX_CHAMFLLT_SETBACK_ANGLE && i == 1)
{
fllt.angle = 30; break;
}
strcpy_s(prompt,
sizeof(prompt),
"[Fillet Setback]Defaults to the specified value, enter number to switch mode(1: to point)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1:
cvxGetPoint("select a point on face", VX_INP_PNT_ON_ANY_FACE, 0, &pntOnEnt[i].pnt, &pntOnEnt[i].idEnt);
if (i == 0) flltSet.setback1Pnt = &pntOnEnt[i];
if (i == 1) flltSet.setback2Pnt = &pntOnEnt[i];
break;
default:
if (i == 0) flltSet.setback1 = 3;
if (i == 1) flltSet.setback2 = 6;
break;
}
if (fllt.type != VX_CHAMFLLT_SETBACK_ANGLE && fllt.type != VX_CHAMFLLT_ASYMMETRIC)
break;
}
/* set base face processing method */
strcpy_s(prompt,
sizeof(prompt),
"[Base face processing method]The default is sew, enter number to switch method(1: trim; 2: divide; 3: no "
"action)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: fllt.baseFaces = 1; break;
case 2: fllt.baseFaces = 2; break;
case 3: fllt.baseFaces = 3; break;
default: fllt.baseFaces = 0; break;
}
/* other settings */
if (fllt.type != VX_CHAMFLLT_VERTEX)
{
/* set shape of fillet */
if (fllt.type == VX_CHAMFLLT_SYMMETRIC)
{
strcpy_s(prompt, sizeof(prompt), "[Relief]The default value is 0.0, enter number to modify it");
cvxGetNumber(prompt, &fllt.relief);
strcpy_s(prompt,
sizeof(prompt),
"[Arc Type]The default type is circular, enter number to switch type(1-conic arc, 2-G2 blend)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: fllt.arcType = 1; break;
case 2: fllt.arcType = 2; break;
default: fllt.arcType = 0; break;
}
}
if (fllt.type == VX_CHAMFLLT_ASYMMETRIC || fllt.type == VX_CHAMFLLT_SETBACK_ANGLE)
{
strcpy_s(prompt,
sizeof(prompt),
"[Arc Type]The default type is conic arc, enter number to switch type(2-G2 blend)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 2: fllt.arcType = 2; break;
default: fllt.arcType = 1; break;
}
}
if (fllt.arcType == 1)
{
strcpy_s(
prompt, sizeof(prompt), "[Conic Ratio]The default value is 0.5, enter number to modify it(0~0.999999)");
cvxGetNumber(prompt, &fllt.conicRatio);
}
if (fllt.arcType == 2)
{
strcpy_s(
prompt, sizeof(prompt), "[Start Weight]The default value is 0.1, enter number to modify it(0.1~5.0)");
cvxGetNumber(prompt, &fllt.weight[0]);
strcpy_s(prompt, sizeof(prompt), "[End Weight]The default value is 0.1, enter number to modify it(0.1~5.0)");
cvxGetNumber(prompt, &fllt.weight[1]);
}
strcpy_s(prompt,
sizeof(prompt),
"[Hold fillet to edge]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.filletToEdge = 1;
strcpy_s(prompt,
sizeof(prompt),
"[Use patch for tight corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.usePatch = 1;
strcpy_s(prompt,
sizeof(prompt),
"[Force local corner]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.localCorner = 1;
strcpy_s(
prompt, sizeof(prompt), "[Mitred corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.mitred = 1;
strcpy_s(
prompt, sizeof(prompt), "[Trace corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.traceCorners = 1;
strcpy_s(prompt,
sizeof(prompt),
"[Fillet face match method]The default is tangent match, enter number to switch method(1: minimal; "
"2: maximal)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: fllt.filletFace = 1; break;
case 2: fllt.filletFace = 2; break;
default: fllt.filletFace = 0; break;
}
}
strcpy_s(
prompt, sizeof(prompt), "[Search for undercuts]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1) fllt.undercuts = 1;
strcpy_s(prompt, sizeof(prompt), "[Blend corners]The default value is no, enter number to switch to yes(1: yes)");
cvxGetNumber(prompt, &val);
if (int(val + 0.5) == 1)
{
fllt.blendCorners = 1;
fllt.desity = 20;
}
/* fillet edges */
int idFillet = 0;
if (cvxPartFilletAll(&fllt, &idFillet) || idFillet == 0)
zwTestLogErrorMsg(5, "cvxPartFilletAll: failed to fillet!");
/* free memory */
if (fllt.type != VX_CHAMFLLT_VERTEX)
cvxMemFree((void**)&flltSet.idEdge);
}
void zwTestPartHole()
/*
DESCRIPTION:
Test case for function cvxPartHole.
*/
{
/* initialize holes */
svxHoleData hole;
double val = 0;
char prompt[256] = "\0";
/* set hole type */
strcpy_s(prompt,
sizeof(prompt),
"[Hole Type]The default type is general hole, enter number to switch type(1: clearance hole; 2: thread "
"hole; 3: profile hole)");
cvxGetNumber(prompt, &val);
evxHoleOpt holeType = VX_GENERAL_HOLE;
switch (int(val + 0.5))
{
case 1: holeType = VX_CLEARANCE_HOLE; break;
case 2: holeType = VX_THREAD_HOLE; break;
case 3: holeType = VX_PROFILE_HOLE; break;
default: break;
}
/* set shape type */
int shapeType = 0;
if (holeType != VX_CLEARANCE_HOLE)
{
strcpy_s(prompt, sizeof(prompt),
"[Shape Type]The default type is simple, enter number to switch type(1: tapered; 2: counter_bore; 3: "
"counter_sunk; 4: spot_face)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: case 2: case 3: case 4: shapeType = int(val + 0.5); break;
default: break;
}
}
else
{
strcpy_s(prompt, sizeof(prompt),
"[Shape Type]The default type is simple, enter number to switch type(2: counter-Bore; 3: counter-sink; 5: "
"slot; 6: countersink slot; 7: counterbore slot)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 2: case 3: case 5: case 6: case 7: shapeType = int(val + 0.5); break;
default: break;
}
}
/* initialize hole data */
if (cvxPartHoleInit(holeType, shapeType, &hole))
zwTestLogErrorMsg(5, "cvxPartHoleInit: failed to initialize holes!");
/* set hole location */
cvxGetPoints("select point(s) to add holes", VX_INP_PNT_ON_ANY_FACE, 0, &hole.Count, &hole.Points);
if (hole.HoleOpt == VX_PROFILE_HOLE)
cvxGetEnt("[Sketch]Select a sketch", VX_INP_SKETCH, 0, &hole.idSketch);
/* set hole plane */
cvxGetEnt("[Insertion Face]Select a insertion face, <middle-click> to skip",
VX_INP_FACE,
1,
&hole.idInsFace);
if (hole.idInsFace)
{
cvxGetNumber("[Project location point]The default type is yes, enter number 1 to switch no", &val);
hole.NoProjPntLoc = (int)(val + 0.5);
}
/* set hole direction */
hole.Direction = { 1, 1, -1 };
hole.UseDirection = 0;
cvxGetNumber("[Hole Direction]The default value is 0, input 1 to use specified direction)", &val);
if (int(val + 0.5) == 1) hole.UseDirection = 1;
/* set boolean shapes */
cvxGetEnts("[Boolean Shapes]Select boolean shapes, <middle-click> to skip",
VX_INP_SHAPE,
1,
&hole.cntShps,
&hole.idShapes);
if (hole.HoleOpt != VX_PROFILE_HOLE)
{
/* set hole end */
cvxGetNumber("[End Type]The default type is blind, enter number to switch type(1: until face; 2: thru-all)", &val);
switch (int(val + 0.5))
{
case 1:
hole.End = VX_UNTIL_FACE;
cvxGetEnt("[End Face]Select a face where the hole should end", VX_INP_FACE, 0, &hole.idUntilFace);
break;
case 2:hole.End = VX_THROUGH_ALL; break;
default:hole.End = VX_BLIND; break;
}
/* add chamfer */
strcpy_s(prompt,
sizeof(prompt),
"[Add Chamfer]The default isn't to add chamfering, enter number to add chamfer, the added number to "
"add multiple chamfers(1: start chamfer; 2: middle chamfer; 4: end chamfer)");
cvxGetNumber(prompt, &val);
int cham = (int)(val + 0.5);
if (cham & 0x01) hole.sCham.fCham = 1;
if (cham & 0x02) hole.mCham.fCham = 1;
if (cham & 0x04) hole.eCham.fCham = 1;
}
if (hole.HoleOpt == VX_CLEARANCE_HOLE)
{
cvxGetString("[Standard]Input standard", "GB", sizeof(hole.Standard), hole.Standard);
cvxGetString("[Screw type]Input screw type", "General Screw Clearance", sizeof(hole.Screw), hole.Screw);
cvxGetString("[Size]Input size", "M4", sizeof(hole.Size), hole.Size);
cvxGetString("[Fit]Input fit", "Normal", sizeof(hole.Fit), hole.Fit);
hole.slotLength = 13.4;
hole.slotAngle = 90;
}
if (hole.HoleOpt == VX_THREAD_HOLE)
{
/* set thread type */
strcpy_s(prompt,
sizeof(prompt),
"[Thread Type]The default is custom, enter number to switch type(1: M; 2: MC; 3: MF; 4: ISO228-1)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: hole.ThreadType = VX_THREAD_M; break;
case 2: hole.ThreadType = VX_THREAD_MC; break;
case 3: hole.ThreadType = VX_THREAD_MF; break;
case 4: hole.ThreadType = VX_THREAD_ISO228; break;
default: hole.ThreadType = VX_THREAD_CUSTOM; break;
}
if (hole.ThreadType != VX_THREAD_CUSTOM)
cvxGetString("[Thread Size]Input thread size", "M1.0 x 0.20", sizeof(hole.ThreadSize), hole.ThreadSize);
}
/* add holes */
int idHole = 0;
if (cvxPartHole(&hole, &idHole) || idHole == 0)
zwTestLogErrorMsg(5, "cvxPartHole: failed to add holes!");
/* free memory */
cvxMemFree((void**)&hole.Points);
cvxMemFree((void**)&hole.idShapes);
}
void zwTestPartThreadAt()
/*
DESCRIPTION:
Test case for function cvxPartThreadAt.
*/
{
int idFace = 0;
svxPoint location = { 0 };
cvxGetPoint("[Faces]Select a point on the cylinder", VX_INP_PNT_ON_ANY_FACE, 0, &location, &idFace);
double val = 0;
char prompt[256] = "\0";
/* initialize thread data */
svxThreadData thread;
if (cvxPartThreadAtInit(&thread))
zwTestLogErrorMsg(5, "cvxPartThreadAtInit: failed to initialize thread!");
strcpy_s(prompt,
sizeof(prompt),
"[Thread Type]The default is custom, enter number to switch type(1: M; 2: MC; 3: MF; 4: ISO7; 5: "
"ISO228-1)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: thread.Type = VX_THREAD_M; break;
case 2: thread.Type = VX_THREAD_MC; break;
case 3: thread.Type = VX_THREAD_MF; break;
case 4: thread.Type = VX_THREAD_ISO7; break;
case 5: thread.Type = VX_THREAD_ISO228; break;
default: break;
}
svxSrfPrim prim;
cvxMemZero(&prim, sizeof(prim));
if (cvxPartInqFaceSrfPrim(idFace, &prim))
zwTestLogErrorMsg(5, "cvxPartInqFaceSrfPrim: failed to get face data!");
if (prim.srfType == VX_SF_PRIM_CYL)
thread.Diameter = prim.srfData.cyl.radius * 2;
thread.EndChamfer = 1;
/* add thread */
if (cvxPartThreadAt(idFace, &location, &thread))
zwTestLogErrorMsg(5, "cvxPartThreadAt: failed to add thread!");
}
void zwTestPartShell()
/*
DESCRIPTION:
Test case for function cvxPartShell.
*/
{
/* initialize shell */
svxShellData shell;
if (cvxPartShellInit(&shell))
zwTestLogErrorMsg(5, "cvxPartShellInit: failed to initialize shell!");
/* set shell shape and open face */
cvxGetEnt("[Shape]Select a shape to shell", VX_INP_SHAPE, 0, &shell.idShape);
cvxGetEnts("[Open]Select face(s) for openings, <middle-click> when done",
VX_INP_FACE,
1,
&shell.cntOpenFace,
&shell.pIdOpenFace);
shell.dThick = -2;
/* set the offset value to specified face */
int nFaces = 0;
int idFace[5] = { 0 };
double offset[5] = { 0 };
while (nFaces < 5)
{
cvxGetEnt("[Face]Select a face to offset, <middle-click> to skip",
VX_INP_FACE,
1,
&idFace[nFaces]);
if (idFace[nFaces] < 1) break;
cvxGetNumber("[Offset]Enter offset value", &offset[nFaces]);
nFaces++;
}
shell.cntList = nFaces;
shell.pIdFace = idFace;
shell.pOffSet = offset;
double val = 0.0;
cvxGetNumber("[Create side faces]The default value is enable, input 1 to disable)", &val);
if (int(val + 0.5) == 1) shell.sideFaces = 0;
cvxGetNumber("[Keep primitive faces]The default value is enable, input 1 to disable)", &val);
if (int(val + 0.5) == 1) shell.KeepPrimFace = 0;
cvxGetNumber("[Intersecting Options]The default option is [remove fast], enter number to switch option(1: don't "
"remove; 2: remove all)",
&val);
switch (int(val + 0.5))
{
case 1: shell.Intersect = 1; break;
case 2: shell.Intersect = 3; break;
default: break;
}
/* create shell */
int idShell = 0;
if (cvxPartShell(&shell, &idShell) || idShell == 0)
zwTestLogErrorMsg(5, "cvxPartShell: failed to add shell!");
/* free memory */
cvxMemFree((void**)&shell.pIdOpenFace);
}
void zwTestPartDraft()
/*
DESCRIPTION:
Test case for function cvxPartDraft.
*/
{
double val = 0;
char prompt[256] = "\0";
/* set draft method */
strcpy_s(prompt,
sizeof(prompt),
"[Draft Method]The default is edge, enter number to switch method(1: face draft; 2: parting edge draft)");
cvxGetNumber(prompt, &val);
evxDraftMethods method = VX_EDGE_DRAFT;
switch (int(val + 0.5))
{
case 1: method = VX_FACE_DRAFT; break;
case 2: method = VX_PRATING_EDGE_DRAFT; break;
default: break;
}
/* initialize draft */
svxDraftData draft;
if (cvxPartDraftInit(method, &draft))
zwTestLogErrorMsg(5, "cvxPartDraftInit: failed to initialize a draft!");
draft.AngleA1 = 10;
draft.AngleA2 = 20;
if (draft.Methods == VX_EDGE_DRAFT)
{
cvxGetNumber("[Draft Type]The default is symmetric, enter number 1 to switch to asymmetric draft", &val);
if (int(val + 0.5) == 1) draft.Type = VX_ASYM_EDGE_DRAFT;
cvxGetEnts("[Edges]Select edge(s) or curve(s) to draft, <middle-click> when done",
VX_INP_EDGE_OR_CURVE,
0,
&draft.iCntDataList,
&draft.idEnt);
}
if (draft.Methods == VX_FACE_DRAFT)
{
cvxGetNumber("[Draft Type]The default is stationary symmetric, enter number to switch type(1: stationary "
"asymmetric; 2: stationary and parting)",
&val);
if (int(val + 0.5) == 1) draft.Type = VX_STATION_ASYM_FACE_DRAFT;
if (int(val + 0.5) == 2) draft.Type = VX_STATION_PARTING_FACE_DRAFT;
if (draft.Type != VX_STATION_PARTING_FACE_DRAFT)
{
cvxGetEnts("[Stationary Faces]Select stationary faces, <middle-click> when done",
VX_INP_REF_PLANE,
0,
&draft.StationEnt.stationaryFaces.cnt,
&draft.StationEnt.stationaryFaces.idEnt);
}
else
{
cvxGetEnts("[Stationary Face]Select stationary faces, <middle-click> when done",
VX_INP_FACE,
0,
&draft.StationEnt.staAndPrtFace.cntStaFaces2,
&draft.StationEnt.staAndPrtFace.StationaryFaces2);
cvxGetEnts("[Parting Face]Select parting faces, <middle-click> when done",
VX_INP_FACE,
0,
&draft.StationEnt.staAndPrtFace.cntPrtFaces,
&draft.StationEnt.staAndPrtFace.PartingFaces);
}
cvxGetEnts("[Draft Faces]Select face(s) to draft, <middle-click> when done",
VX_INP_FACE,
0,
&draft.iCntDataList,
&draft.idEnt);
}
if (draft.Methods == VX_PRATING_EDGE_DRAFT)
{
cvxGetEnts("[Stationary Planes]Select stationary planes, <middle-click> when done",
VX_INP_REF_PLANE,
0,
&draft.StationEnt.stationaryPlane.cnt,
&draft.StationEnt.stationaryPlane.idEnt);
cvxGetEnts("[Edges]Select edge(s) to draft, <middle-click> when done",
VX_INP_EDGE,
0,
&draft.iCntDataList,
&draft.idEnt);
svxMatrix mat = { 0 };
if (draft.StationEnt.stationaryPlane.cnt > 0)
{
cvxEntMatrix(draft.StationEnt.stationaryPlane.idEnt[0], &mat);
draft.DirP = { mat.zx, mat.zy, mat.zz };
}
}
cvxGetNumber(
"[Draft Side]The default option is split, enter number to switch option(1: top; 2: bottom; 3: neutral)", &val);
switch (int(val + 0.5))
{
case 1: draft.DraftSideS = 1; break;
case 2: draft.DraftSideS = 2; break;
case 3: draft.DraftSideS = 3; break;
default: break;
}
cvxGetNumber("[Extension]The default option is linear, enter number to switch option(1: circular; 2: reflect; 3: "
"curvature diminishing)",
&val);
switch (int(val + 0.5))
{
case 1: draft.Extention = 1; break;
case 2: draft.Extention = 2; break;
case 3: draft.Extention = 3; break;
default: break;
}
cvxGetNumber("[Recompute fillets]The default is disable, enter 1 to enable)", &val);
if (int(val + 0.5) == 1) draft.iIsrecomputeflt = 1;
cvxGetNumber("[Intersections]The default don't remove, enter 1 to remove all)", &val);
if (int(val + 0.5) == 1) draft.iIntersections = 1;
cvxGetNumber("[Remove inverted regions]The default is enable, enter 1 to disable)", &val);
if (int(val + 0.5) == 1) draft.iIsRemivtrgns = 0;
/* create a draft */
int idDraft = 0;
if (cvxPartDraft(&draft, &idDraft) || idDraft == 0)
zwTestLogErrorMsg(5, "cvxPartDraft: failed to add a draft!");
/* free memory */
cvxMemFree((void**)&draft.idEnt);
if (draft.Methods == VX_FACE_DRAFT)
{
if (draft.Type != VX_STATION_PARTING_FACE_DRAFT)
{
cvxMemFree((void**)&draft.StationEnt.stationaryFaces.idEnt);
}
else
{
cvxMemFree((void**)&draft.StationEnt.staAndPrtFace.StationaryFaces2);
cvxMemFree((void**)&draft.StationEnt.staAndPrtFace.PartingFaces);
}
}
if (draft.Methods == VX_PRATING_EDGE_DRAFT)
cvxMemFree((void**)&draft.StationEnt.stationaryPlane.idEnt);
}
void zwTestPartRib()
/*
DESCRIPTION:
Test case for function cvxPartRib.
*/
{
/* initialize rib */
svxRibData rib;
if (cvxPartRibInit(&rib))
zwTestLogErrorMsg(5, "cvxPartRibInit: failed to initialize rib!");
double val = 0;
cvxGetNumber("[Direction]The default is Parallel, enter 1 to switch vertical", &val);
if (int(val + 0.5) == 1) rib.direction = 1;
cvxGetNumber("[Width Type]The default is both, enter number to switch type(1: 1st side; 2: 2nd side)", &val);
if (int(val + 0.5) == 1) rib.widthType = 0;
if (int(val + 0.5) == 2) rib.widthType = 2;
cvxGetNumber("[Width W]Enter rib thickness", &rib.width);
cvxGetNumber("[Angle A]Enter draft angle", &rib.angle);
if (fabs(rib.angle) > V_ZERO)
cvxGetEnt("[Plane P2]Select draft plane", VX_INP_REF_PLANE, 0, &rib.idPlane);
cvxGetEnts("[Bounds B]Select rib boundary face(s), <middle-click> when done",
VX_INP_FACE,
1,
&rib.numBndFaces,
&rib.idBndFaces);
cvxGetNumber("[Flip the material direction]The default is disable, enter 1 to enable", &val);
if (int(val + 0.5) == 1) rib.flipDir = 1;
cvxGetEnt("[Profile P1]Select profile", VX_INP_PROF, 0, &rib.idProfile);
if (cvxEntIsCurve(rib.idProfile) && VX_ENT_EDGE != cvxEntClassNum(rib.idProfile))
{
int idParent = 0;
cvxEntSketch(rib.idProfile, &idParent);
if (idParent < 1)
{
int nCrvList = 0, * idCrvList = NULL;
cvxPartInqCrvLists(&nCrvList, &idCrvList);
for (int i = 0; i < nCrvList; i++)
{
int nCrv = 0;
svxEntPick* crvPick = NULL;
cvxPartInqCrvList(idCrvList[i], &nCrv, &crvPick);
for (int k = 0; k < nCrv; k++)
{
if (crvPick[k].idEntity == rib.idProfile)
idParent = idCrvList[i];
if (idParent > 0)
break;
}
cvxMemFree((void**)&crvPick);
if (idParent > 0)
break;
}
cvxMemFree((void**)&idCrvList);
}
if (idParent > 0)
rib.idParent = idParent;
}
/* create a rib */
int idRib = 0;
if (cvxPartRib(&rib, &idRib) || idRib == 0)
zwTestLogErrorMsg(5, "cvxPartRib: failed to create a rib!");
/* free memory */
cvxMemFree((void**)&rib.idBndFaces);
}
void zwTestPartLip()
/*
DESCRIPTION:
Test case for function cvxPartLip.
*/
{
/* initialize lip */
svxLipData lip;
if (cvxPartLipInit(&lip))
zwTestLogErrorMsg(5, "cvxPartLipInit: failed to initialize a lip!");
/* set the lip edge and 1st offset face */
int nEdges = 0;
int idEdge[5] = { 0 }, idFace[5] = { 0 };
while (nEdges < 5)
{
cvxGetEnt("[Edge E]Select edge to apply lip", VX_INP_EDGE, 1, &idEdge[nEdges]);
if (idEdge[nEdges] < 1) break;
cvxGetEnt("[Face F]Select first offset face", VX_INP_FACE, 0, &idFace[nEdges]);
nEdges++;
}
lip.numEdges = nEdges;
lip.idEdge = idEdge;
lip.idFace = idFace;
cvxGetNumber("[Offset 1]Enter first offset", &lip.offset1);
cvxGetNumber("[Offset 2]Enter second offset", &lip.offset2);
/* create a lip */
int idLip = 0;
if (cvxPartLip(&lip, &idLip) || idLip == 0)
zwTestLogErrorMsg(5, "cvxPartLip: failed to create a lip!");
}
void zwTestPartStock()
/*
DESCRIPTION:
Test case for function cvxPartStock.
*/
{
/* initialize stock */
svxStockData stock;
if (cvxPartStockInit(&stock))
zwTestLogErrorMsg(5, "cvxPartStockInit: failed to initialize a stock!");
/* set stock option */
double val = 0;
cvxGetNumber("[Stock Option]The default is block, enter 1 to switch cylinder", &val);
if (int(val + 0.5) == 1) stock.option = VX_STOCK_CYLINDER;
/* set stock shapes */
cvxGetEnts("[Stock Shape]Select shape(s) to enclose, <middle-click> when done", VX_INP_SHAPE, 0, &stock.numEnts, &stock.idEnts);
cvxGetNumber("[Adjust Type]The default is by side, enter 1 to switch to by total", &val);
if (int(val + 0.5) == 1) stock.adjustType = 1;
cvxGetNumber("[Decimal]Set decimal to control the accuracy of stock", &val);
stock.decimal = (int)(val + 0.5);
if (stock.option == VX_STOCK_BLOCK)
{
cvxGetEnt("[Plane]Select reference plane", VX_INP_REF_PLANE, 1, &stock.idPlane);
stock.length[0] = 5.555;
stock.length[1] = 2.555;
}
else
{
svxAxis axis = { 0 };
cvxGetPoint("[Axis]Select cylinder axis, <middle-click> to ignore", VX_INP_PNT_DIRECTION, 1, (svxPoint*)&stock.axis.Dir, NULL);
cvxGetNumber("[Axis Position]The default is on the setting axis, enter 1 to switch to central of the shape", &val);
if (int(val + 0.5) == 1) stock.axisPos = 1;
}
/* create a stock */
int idStock = 0;
if (cvxPartStock(&stock, &idStock) || idStock == 0)
zwTestLogErrorMsg(5, "cvxPartStock: failed to create a stock!");
/* free memory */
cvxMemFree((void**)&stock.idEnts);
}
void zwTestPartThicken()
/*
DESCRIPTION:
Test case for function cvxPartThicken.
*/
{
/* initialize thicken feature */
svxThickenData thicken;
if (cvxPartThickenInit(&thicken))
zwTestLogErrorMsg(5, "cvxPartThickenInit: failed to initialize thicken feature!");
/* set thicken type */
double val = 0;
cvxGetNumber("[Thicken Type]The default is sheet, enter 1 to switch face", &val);
if (int(val + 0.5) == 1) thicken.type = 1;
if (thicken.type == 0)
{
cvxGetEnt("[Sheet]Select a shape to thicken", VX_INP_SHAPE, 0, &thicken.idShape);
cvxGetNumber("[Keep original sheet]The default is disable, enter 1 to switch to enable", &val);
if (int(val + 0.5) == 1) thicken.keep = 1;
}
else
{
cvxGetEnts("[Faces]Select faces to thicken, <middle-click> when done",
VX_INP_FACE,
0,
&thicken.numFaces,
&thicken.idFaces);
}
std::vector<int> vFace;
std::vector<double> vOffset;
while (true)
{
int idFace = 0;
cvxGetEnt("[Face]Select face to offset", VX_INP_FACE, 1, &idFace);
if (idFace < 1) break;
vFace.push_back(idFace);
cvxGetNumber("[Thick T]Enter offset value", &val);
vOffset.push_back(val);
}
thicken.numOffset = (int)vFace.size();
thicken.idOffFaces = vFace.data();
thicken.thickT = vOffset.data();
/* create thicken feature */
int idThicken = 0;
if (cvxPartThicken(&thicken, &idThicken) || idThicken == 0)
zwTestLogErrorMsg(5, "cvxPartThicken: failed to create thicken feature!");
/* free memory */
cvxMemFree((void**)&thicken.idFaces);
}
void zwTestPartDivide()
/*
DESCRIPTION:
Test case for function cvxPartDivide.
*/
{
/* initialize divide feature */
svxDivideData divide;
if (cvxPartDivideInit(&divide))
zwTestLogErrorMsg(5, "cvxPartDivideInit: failed to initialize divide feature!");
/* set base and cutter */
cvxGetEnts("[Base B]Select shape(s) to be divided, <middle-click> when done",
VX_INP_SHAPE,
0,
&divide.numBase,
&divide.idBase);
cvxGetEnts("[Cutting C]Selects dividing shapes or planes, <middle-click> when done",
VX_INP_SHAPE_OR_FACE,
0,
&divide.numCutter,
&divide.idCutters);
double val = 0;
cvxGetNumber("[Cutter C]The default is delete, enter number to switch(1: keep; 2: divide)", &val);
switch (int(val + 0.5))
{
case 1: divide.keepCutter = 1; break;
case 2: divide.keepCutter = 2; break;
default: divide.keepCutter = 0; break;
}
cvxGetNumber("[Cap Trimmed Region]The default is enable, enter 1 to disable", &val);
divide.trimCap = ((int)(val + 0.5) == 1 ? 0 : 1);
cvxGetNumber("[Extension]The default is no extend, enter number to switch(1: linear; 2: circular)", &val);
switch (int(val + 0.5))
{
case 1: divide.extend = 0; break;
case 2: divide.extend = 2; break;
default: divide.extend = 1; break;
}
/* create divide feature */
int numShapes = 0;
int* idShapses = nullptr;
if (cvxPartDivide(&divide, &numShapes, &idShapses) || idShapses == nullptr)
zwTestLogErrorMsg(5, "cvxPartDivide: failed to create divide feature!");
/* free memory */
cvxMemFree((void**)&divide.idBase);
cvxMemFree((void**)&divide.idCutters);
cvxMemFree((void**)&idShapses);
}
void zwTestPartTrim()
/*
DESCRIPTION:
Test case for function cvxPartTrim.
*/
{
/* initialize trim feature */
svxTrimData trim;
if (cvxPartTrimInit(&trim))
zwTestLogErrorMsg(5, "cvxPartTrimInit: failed to initialize trim feature!");
cvxGetEnts(
"[Base B]Select shape(s) to be divided, <middle-click> when done", VX_INP_SHAPE, 0, &trim.numBase, &trim.idBase);
cvxGetEnts("[Trimming C]Selects dividing shapes or planes, <middle-click> when done",
VX_INP_SHAPE_OR_FACE,
0,
&trim.numTrimm,
&trim.idTrimmer);
double val = 0.0;
cvxGetNumber("[Flip side to keep]The default is disable, enter 1 to enable", &val);
trim.flip = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Trim with all simultaneously]The default is enable, enter 1 to disable", &val);
trim.trimType = ((int)(val + 0.5) == 1 ? 0 : 1);
cvxGetNumber("[Cap Trimmed Region]The default is enable, enter 1 to disable", &val);
trim.trimCap = ((int)(val + 0.5) == 1 ? 0 : 1);
cvxGetNumber("[Keep trimming shapes]The default is keep, enter 1 to delete", &val);
trim.keepTrimm = ((int)(val + 0.5) == 1 ? 0 : 1);
cvxGetNumber("[Extension]The default is no extend, enter number to switch(1: linear; 2: circular)", &val);
switch (int(val + 0.5))
{
case 1: trim.extend = 0; break;
case 2: trim.extend = 2; break;
default: trim.extend = 1; break;
}
/* create trim feature */
int numShapes = 0;
int* idShapses = nullptr;
if (cvxPartTrim(&trim, &numShapes, &idShapses) || idShapses == nullptr)
zwTestLogErrorMsg(5, "cvxPartTrim: failed to create trim feature!");
/* free memory */
cvxMemFree((void**)&trim.idBase);
cvxMemFree((void**)&trim.idTrimmer);
cvxMemFree((void**)&idShapses);
}
void zwTestPartSimplify()
/*
DESCRIPTION:
Test case for function cvxPartSimplify.
*/
{
/* simplify some faces */
int numFaces = 0;
int* idFaces = nullptr;
cvxGetEnts("[Entities]Select some faces to simplify, <middle-click> when done", VX_INP_FACE, 0, &numFaces, &idFaces);
int idSimplify = 0;
if (cvxPartSimplify(numFaces, idFaces, &idSimplify) || idSimplify == 0)
zwTestLogErrorMsg(5, "cvxPartSimplify: failed to simplify faces!");
/* free memory */
cvxMemFree((void**)&idFaces);
}
void zwTestPartInlay()
/*
DESCRIPTION:
Test case for function cvxPartInlay.
*/
{
/* initialize inlay */
svxInlayData inlay;
if (cvxPartInlayInit(&inlay))
zwTestLogErrorMsg(5, "cvxPartInlayInit: failed to initialize inlay!");
cvxGetEnts("[Faces]Select faces to inlay, <middle-click> when done", VX_INP_FACE, 0, &inlay.numFaces, &inlay.idFaces);
cvxGetEnts("[Faces]Select closed curves, <middle-click> when done", VX_INP_CURVE, 0, &inlay.numCrvs, &inlay.idCrvs);
inlay.offset = 2.0;
double val = 0.0;
cvxGetNumber("[Projection method]The default is in place(none), enter number to switch(1: face normal; 2: "
"directed; 3: bi-directional)",
&val);
switch (int(val + 0.5))
{
case 1: case 2: case 3: inlay.projType = (int)(val + 0.5); break;
default: inlay.projType = 0; break;
}
svxMatrix mat = { 0 };
if (inlay.projType > 1)
cvxGetPoint("[Project Direction]Specify project direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&inlay.projDir, NULL);
cvxGetPoint("[Inlay Direction]Specify inlay direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&inlay.inlayDir, NULL);
cvxGetNumber("[Draft about]The default is base, enter number to switch(1: offset; 2: middle)", &val);
switch (int(val + 0.5))
{
case 1: case 2: inlay.draftAbout = (int)(val + 0.5); break;
default: inlay.draftAbout = 0; break;
}
inlay.draftAngle = 1;
cvxGetNumber("[Fillet Type]The default is circular, enter 1 to switch chamfer", &val);
inlay.filletType = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Fillet about]The default is both, enter number to switch(1: base; 2: offset)", &val);
switch (int(val + 0.5))
{
case 1: case 2: inlay.filletAbout = (int)(val + 0.5); break;
default: inlay.filletAbout = 0; break;
}
inlay.filletRad = 0.2;
/* create inlay */
int idInlay = 0;
if (cvxPartInlay(&inlay, &idInlay) || idInlay == 0)
zwTestLogErrorMsg(5, "cvxPartInlay: failed to create inlay!");
/* free memory */
cvxMemFree((void**)&inlay.idFaces);
cvxMemFree((void**)&inlay.idCrvs);
}
void zwTestPartLoft()
/*
DESCRIPTION:
Test case for function cvxPartLoft.
*/
{
/* initialize loft */
svxLoftData loft;
if (cvxPartLoftInit(&loft))
zwTestLogErrorMsg(5, "cvxPartLoftInit: failed to initialize loft!");
/* set boolean type */
double val = 0.0;
cvxGetNumber("[Boolean]The default is base, enter number to switch(1: add; 2: remove; 3: intersect)", &val);
switch (int(val + 0.5))
{
case 1: loft.combine = VX_BOOL_ADD; break;
case 2: loft.combine = VX_BOOL_REMOVE; break;
case 3: loft.combine = VX_BOOL_INTERSECT; break;
default: loft.combine = VX_BOOL_NONE; break;
}
/* set loft type */
cvxGetNumber("[Loft Type]The default is profiles, enter number to switch(1: start point and profiles; 2: "
"end point and profiles; 3: both end points and profiles)",
&val);
switch (int(val + 0.5))
{
case 1: loft.type = VX_LOFT_START_PNT_PROFS; break;
case 2: loft.type = VX_LOFT_END_PNT_PROFS; break;
case 3: loft.type = VX_LOFT_BOTH_PNTS_PROFS; break;
default: loft.type = VX_LOFT_PROFS; break;
}
typedef enum eBndType
{
BND_NONE,
BND_PNT,
BND_EDGE,
} eBndType;
eBndType BndType[2];
cvxMemZero(BndType, sizeof(eBndType) * 2);
/* set start point */
if (loft.type == VX_LOFT_START_PNT_PROFS || loft.type == VX_LOFT_BOTH_PNTS_PROFS)
{
cvxGetPoint(
"[Start Point]Select the start point for loft", VX_INP_PNT_END, 0, &loft.startPnt, &loft.idStartParent);
BndType[0] = BND_PNT;
}
/* set profiles */
svxPoint preDir = { 0 };
std::vector<svxLoftProfile> vProfs;
while (true)
{
svxLoftProfile prof = { 0 };
svxPoint pnt = { 0 };
cvxGetPoint("[Profile]Select profile, <middle-click> to exit", VX_INP_PNT_ON_CRV_OR_PROF, 1, &pnt, &prof.idProfile);
if (prof.idProfile < 1) break;
/* set parent entity */
if (cvxEntIsCurve(prof.idProfile) && VX_ENT_EDGE != cvxEntClassNum(prof.idProfile))
{
int idParent = 0;
cvxEntSketch(prof.idProfile, &idParent);
if (idParent < 1)
{
int nCrvList = 0, * idCrvList = NULL;
cvxPartInqCrvLists(&nCrvList, &idCrvList);
for (int i = 0; i < nCrvList; i++)
{
int nCrv = 0;
svxEntPick* crvPick = NULL;
cvxPartInqCrvList(idCrvList[i], &nCrv, &crvPick);
for (int k = 0; k < nCrv; k++)
{
if (crvPick[k].idEntity == prof.idProfile) idParent = idCrvList[i];
if (idParent > 0) break;
}
cvxMemFree((void**)&crvPick);
if (idParent > 0)
break;
}
cvxMemFree((void**)&idCrvList);
}
if (idParent > 0) prof.idParent = idParent;
}
/* set profile direction */
svxLimit t = { 0 };
cvxCrvParam(prof.idProfile, &t);
svxEvalCurv eval = { 0 };
cvxCrvEval2(prof.idProfile, t.min, 1, &eval);
if (vProfs.size() > 0)
{
if (!cvxVecParallelChk(1, (svxVector*)&preDir, (svxVector*)&eval.deriv_1, cos(90.0 * V_PI) / 180.0))
prof.profDir = 1;
}
preDir = eval.deriv_1;
/* set start point */
int idEnt = 0;
cvxGetPoint("[Start Point]Select a point on profile as starting point",
VX_INP_PNT_ON_CURVE_OR_EDGE,
1,
&prof.startPnt,
&idEnt);
if (idEnt == prof.idProfile) prof.useStartPnt = 1;
vProfs.push_back(prof);
}
if (vProfs.size() < 1 || (loft.type == VX_LOFT_PROFS && vProfs.size() < 2))
{
zwTestLogErrorMsg(5, "cvxPartLoft: insufficient profiles!");
return;
}
loft.numProfs = (int)vProfs.size();
loft.profs = vProfs.data();
/* set end point */
if (loft.type == VX_LOFT_END_PNT_PROFS || loft.type == VX_LOFT_BOTH_PNTS_PROFS)
{
cvxGetPoint("[End Point]Select the end point for loft", VX_INP_PNT_END, 0, &loft.endPnt, &loft.idEndParent);
BndType[1] = BND_PNT;
}
if (BndType[0] == BND_NONE && VX_ENT_EDGE == cvxEntClassNum(loft.profs[0].idProfile))
BndType[0] = BND_EDGE;
if (BndType[1] == BND_NONE && VX_ENT_EDGE == cvxEntClassNum(loft.profs[loft.numProfs - 1].idProfile))
BndType[1] = BND_EDGE;
/* set boundary constraints */
for (int i = 0; i < 2; i++)
{
if (BndType[i] == BND_NONE) continue;
/* continuity */
cvxGetNumber("[Continuity]The default is tangent, enter number to switch(1: none; 2: curvature; 3: flow)", &val);
switch (int(val + 0.5))
{
case 1: loft.bndCons[i].continuity = 0; break;
case 2: loft.bndCons[i].continuity = 2; break;
case 3: loft.bndCons[i].continuity = 3; break;
default: loft.bndCons[i].continuity = 1; break;
}
loft.bndCons[i].weight = 0.1;
if (BndType[i] == BND_EDGE)
{
cvxGetNumber("[Direction]The default is perpendicular, enter 1 to along edges", &val);
loft.bndCons[i].direction = ((int)(val + 0.5) == 1 ? 1 : 0);
int nFace = 0, * idFace = NULL;
cvxPartInqEdgeFaces(
i == 0 ? loft.profs[0].idProfile : loft.profs[loft.numProfs - 1].idProfile, &nFace, &idFace);
if (loft.bndCons[i].continuity > 0 && nFace > 1)
{
cvxGetNumber("[Toggle Face]enter 1 to toggle face", &val);
if (int(val + 0.5)) loft.bndCons[i].idFace = idFace[1];
}
cvxMemFree((void**)&idFace);
}
}
/* other setting */
cvxGetNumber("[Cap]The default is both, enter number to switch(1: start; 2: end; 3: none)", &val);
switch (int(val + 0.5))
{
case 1: case 2: case 3: loft.endCap = (int)(val + 0.5); break;
default: loft.endCap = 0; break;
}
cvxGetNumber("[Connect first profile to last]The default is disable, enter 1 to enable", &val);
loft.close = ((int)(val + 0.5) == 1 ? 1 : 0);
/* create loft */
int idLoft = 0;
if (cvxPartLoft(&loft, &idLoft))
zwTestLogErrorMsg(5, "cvxPartLoft: failed to create loft!");
}
void zwTestPartShapeFaceOffset()
/*
DESCRIPTION:
Test case for function cvxPartShapeFaceOffset.
*/
{
/* initialize offset */
svxFaceOffData faceOffset;
if (cvxPartShapeFaceOffsetInit(&faceOffset))
zwTestLogErrorMsg(5, "cvxPartShapeFaceOffsetInit: failed to initialize offset!");
double val = 0.0;
cvxGetNumber("[Offset Type]The default is constant, enter 1 switch variable", &val);
faceOffset.type = ((int)(val + 0.5) == 1 ? 1 : 0);
std::vector<int> vFace;
std::vector<double> vOffset;
if (faceOffset.type)
{
while (true)
{
int idFace = 0;
cvxGetEnt("[Face]Select face to offset", VX_INP_FACE, 1, &idFace);
if (idFace < 1) break;
vFace.push_back(idFace);
cvxGetNumber("[Offset]Enter offset value", &val);
vOffset.push_back(val);
}
faceOffset.numOffsetSet = (int)vFace.size();
faceOffset.idFaceSet = vFace.data();
faceOffset.offsetSet = vOffset.data();
}
else
{
cvxGetEnts("[Face]Select face to offset", VX_INP_FACE, 0, &faceOffset.numFaces, &faceOffset.idFaces);
cvxGetNumber("[Offset]Enter offset value", &faceOffset.offset);
}
cvxGetNumber("[Side Face]The default is to create, enter number to switch(1: do not create; 2: force)", &val);
switch (int(val + 0.5))
{
case 1: faceOffset.sideFaces = 0; break;
case 2: faceOffset.sideFaces = 2; break;
default: faceOffset.sideFaces = 1; break;
}
cvxGetNumber("[Extension]The default is linear, enter number to switch(1: circular; 2: reflect; 3: curvature diminishing)", &val);
switch (int(val + 0.5))
{
case 1: case 2: case 3: faceOffset.extension = (int)(val + 0.5); break;
default: faceOffset.extension = 0; break;
}
cvxGetNumber("[Intersects]The default do not remove, enter 1 to remove all", &val);
faceOffset.intersect = ((int)(val + 0.5) == 1 ? 1 : 0);
/* offset faces */
int idOffset = 0;
if (cvxPartShapeFaceOffset(&faceOffset, &idOffset))
zwTestLogErrorMsg(5, "cvxPartShapeFaceOffset: failed to offset!");
/* free memory */
cvxMemFree((void**)&faceOffset.idFaces);
}
void zwTestPartFlagHoles()
/*
DESCRIPTION:
Test case for function cvxPartFlagHoles.
*/
{
/* initialize feature */
svxFlagHoleData flagHoles;
if (cvxPartFlagHolesInit(&flagHoles))
zwTestLogErrorMsg(5, "cvxPartFlagHolesInit: failed to initialize feature!");
cvxGetEnt("[Face]Select base face for holes", VX_INP_FACE, 0, &flagHoles.FaceId);
cvxGetEnts("[Hole]Select cylindrical face(s), <middle-click> when done", VX_INP_FACE, 0, &flagHoles.count, &flagHoles.HolesId);
double val = 0.0;
cvxGetNumber("[Use Hole Filter]The default is disable, enter 1 to enable", &val);
flagHoles.isUseFilter = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Flagged as thread hole]The default is disable, enter 1 to enable", &val);
flagHoles.isUseFlaggedThread = ((int)(val + 0.5) == 1 ? 1 : 0);
if (flagHoles.isUseFlaggedThread)
{
cvxGetString("[Thread Type]Input type name", "MF", sizeof(flagHoles.type), flagHoles.type);
cvxGetString("[Thread Size]Input size name", "M20 x 1.5", sizeof(flagHoles.size), flagHoles.size);
if (!flagHoles.type[0])
{
flagHoles.custom.diamter = 15;
flagHoles.custom.isPitch = 1;
flagHoles.custom.value = 2.5;
}
}
cvxGetNumber("[Depth Type]The default type is default, enter number to switch type(1: 1.0xD; 2: 1.5xD; 3: 2.0xD; "
"4: 2.5xD; 5: 3.0xD; 6: Full; 7: Custom)",
&val);
switch (int(val + 0.5))
{
case 1: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_1XDIAMETER; break;
case 2: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_15XDIAMETER; break;
case 3: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_2XDIAMETER; break;
case 4: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_25XDIAMETER; break;
case 5: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_3XDIAMETER; break;
case 6: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_FULL; break;
case 7: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_CUSTOM; break;
default: flagHoles.DepthType = VX_FLAG_THREAD_DEPTH_DEFAULT; break;
}
if (flagHoles.DepthType == VX_FLAG_THREAD_DEPTH_CUSTOM) flagHoles.depth = 25;
/* assign hole attributes */
int idFtr = 0;
if (cvxPartFlagHoles(&flagHoles, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartFlagHoles: failed to flag holes!");
/* free memory */
cvxMemFree((void**)&flagHoles.HolesId);
}
void zwTestPartFlagExtThread()
/*
DESCRIPTION:
Test case for function cvxPartFlagExtThread.
*/
{
/* initialize feature */
svxFlagExtThreadData flagExtThread;
if (cvxPartFlagExtThreadInit(&flagExtThread))
zwTestLogErrorMsg(5, "cvxPartFlagExtThreadInit: failed to initialize feature!");
svxPoint point = { 0 };
int idFace = 0;
cvxGetPoint("[Faces]Select a point on the cylinder", VX_INP_PNT_ON_ANY_FACE, 0, &point, &idFace);
flagExtThread.count = 1;
flagExtThread.Faces = &point;
flagExtThread.IdFaces = &idFace;
cvxGetString("[Thread Type]Input type name", "MF", sizeof(flagExtThread.type), flagExtThread.type);
cvxGetString("[Thread Size]Input size name", "M20 x 1.5", sizeof(flagExtThread.size), flagExtThread.size);
if (!flagExtThread.type[0])
{
flagExtThread.custom.useDiam = 1;
flagExtThread.custom.diamter = 15;
flagExtThread.custom.isThread = 1;
flagExtThread.custom.value = 2.5;
}
double val = 0.0;
char prompt[256] = "\0";
strcpy_s(prompt,
sizeof(prompt),
"[Lenght Type]The default type is default, enter number to switch type(1: 1.0xD; 2: 1.5xD; 3: 2.0xD; 4: "
"2.5xD; 5: 3.0xD; 6: Full; 7: Custom)");
cvxGetNumber(prompt, &val);
switch (int(val + 0.5))
{
case 1: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_1XDIAMETER; break;
case 2: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_15XDIAMETER; break;
case 3: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_2XDIAMETER; break;
case 4: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_25XDIAMETER; break;
case 5: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_3XDIAMETER; break;
case 6: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_FULL; break;
case 7: flagExtThread.LengthType = VX_FLAG_THREAD_DEPTH_CUSTOM; break;
default: break;
}
if (flagExtThread.LengthType == VX_FLAG_THREAD_DEPTH_CUSTOM) flagExtThread.length = 25;
strcpy_s(prompt, sizeof(prompt), "[End Chamfer]The default don't add end chamfer, enter number 1 to add");
cvxGetNumber(prompt, &val);
flagExtThread.isChamfer = (int)(val + 0.5);
flagExtThread.SetBack = 1;
flagExtThread.angle = 45;
/* assign external thread attributes */
int idFtr = 0;
if (cvxPartFlagExtThread(&flagExtThread, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartFlagExtThread: failed to assign external thread(s) data!");
}
void zwTestPartBool()
/*
DESCRIPTION:
Test case for function cvxPartBool, cvxPartBool2 and cvxPartBool3.
*/
{
double val = 0.0;
evxBoolType boolType = VX_BOOL_ADD;
cvxGetNumber("[Bool Type]Enter number to select boolean type(0: add; 1: remove; 2: intersect)", &val);
switch (int(val + 0.5))
{
case 1: boolType = VX_BOOL_REMOVE; break;
case 2: boolType = VX_BOOL_INTERSECT; break;
default: break;
}
/* select base shapes and operator shapes */
int nBases = 0, * idBases = NULL;
cvxGetEnts("Select base shapes, <middle-click> when done", VX_INP_SHAPE, 0, &nBases, &idBases);
int nOps = 0, * idOps = NULL;
cvxGetEnts("Select operator shapes, <middle-click> when done", VX_INP_SHAPE, 0, &nOps, &idOps);
int nBnds = 0, * idBnds = NULL;
cvxGetEnts("Select boundary faces, <middle-click> when done", VX_INP_FACE, 1, &nBnds, &idBnds);
if (nBases < 1 || nOps < 1) return;
int nBoolShps = 0, * idBoolShps = NULL;
if (nBnds < 1)
{
if (nBases == 1 && cvxPartBool(boolType, idBases[0], nOps, idOps, 1))
zwTestLogErrorMsg(5, "cvxPartBool: failed to bool shapes!");
if (nBases > 1 && cvxPartBool2(boolType, nBases, idBases, nOps, idOps, &nBoolShps, &idBoolShps))
zwTestLogErrorMsg(5, "cvxPartBool2: failed to bool shapes!");
}
else
{
if (cvxPartBool3(boolType, nBases, idBases, nOps, idOps, nBnds, idBnds, &nBoolShps, &idBoolShps))
zwTestLogErrorMsg(5, "cvxPartBool3: failed to bool shapes!");
}
/* free memory */
cvxMemFree((void**)&idBases);
cvxMemFree((void**)&idOps);
cvxMemFree((void**)&idBnds);
cvxMemFree((void**)&idBoolShps);
}
cvxPartInqEdgeFaces
evxErrors cvxPartInqEdgeFaces(int idEdge, int *Count, int **Faces)
cvxPartInqFaceSrf
evxErrors cvxPartInqFaceSrf(int idFace, svxSurface *Srf)
cvxSurfaceFree
void cvxSurfaceFree(svxSurface *Srf)
cvxPartInqFaceSrfPrim
evxErrors cvxPartInqFaceSrfPrim(int idFace, svxSrfPrim *SrfPrim)
cvxPartIns
evxErrors cvxPartIns(svxPartInstData *Part, int *Count, int **ShapeList)
cvxPartRefGeom
evxErrors cvxPartRefGeom(svxEntPath *GeomPath, int AssociativeCopy, int *idGeom)
VX_SWP_Z_FIXED_DIR
@ VX_SWP_Z_FIXED_DIR
parallel with the fixed direction
Definition: zwapi_cmd_shape_data.h:274
VX_SWP_Z_TANG_TO_PATH
@ VX_SWP_Z_TANG_TO_PATH
tangent to path (default)
Definition: zwapi_cmd_shape_data.h:272
VX_SWP_Z_TANG_TO_CRV
@ VX_SWP_Z_TANG_TO_CRV
tangent to curve
Definition: zwapi_cmd_shape_data.h:273
VX_THROUGH_ALL
@ VX_THROUGH_ALL
through all
Definition: zwapi_cmd_shape_data.h:689
VX_UNTIL_FACE
@ VX_UNTIL_FACE
until face
Definition: zwapi_cmd_shape_data.h:688
VX_BLIND
@ VX_BLIND
blind
Definition: zwapi_cmd_shape_data.h:687
VX_OFFSET_THICKEN_SAME
@ VX_OFFSET_THICKEN_SAME
Thicken same.
Definition: zwapi_cmd_shape_data.h:134
VX_OFFSET_NONE
@ VX_OFFSET_NONE
none
Definition: zwapi_cmd_shape_data.h:131
VX_OFFSET_THICKEN
@ VX_OFFSET_THICKEN
Thicken.
Definition: zwapi_cmd_shape_data.h:133
VX_OFFSET_SHRINK
@ VX_OFFSET_SHRINK
Shrink / Expand.
Definition: zwapi_cmd_shape_data.h:132
VX_STATION_ASYM_FACE_DRAFT
@ VX_STATION_ASYM_FACE_DRAFT
Stationary Asymmetric.
Definition: zwapi_cmd_shape_data.h:553
VX_STATION_PARTING_FACE_DRAFT
@ VX_STATION_PARTING_FACE_DRAFT
Stationary and parting.
Definition: zwapi_cmd_shape_data.h:554
VX_ASYM_EDGE_DRAFT
@ VX_ASYM_EDGE_DRAFT
Asymmetric draft.
Definition: zwapi_cmd_shape_data.h:549
VX_SWP_NATURAL
@ VX_SWP_NATURAL
Default frame.
Definition: zwapi_cmd_shape_data.h:247
VX_SWP_AT_PROFILE
@ VX_SWP_AT_PROFILE
At intersection.
Definition: zwapi_cmd_shape_data.h:250
VX_SWP_FRAME
@ VX_SWP_FRAME
Selected.
Definition: zwapi_cmd_shape_data.h:249
VX_SWP_ALONG_PATH
@ VX_SWP_ALONG_PATH
Along Path.
Definition: zwapi_cmd_shape_data.h:251
VX_SWP_AT_PATH
@ VX_SWP_AT_PATH
At Path.
Definition: zwapi_cmd_shape_data.h:248
evxDraftMethods
evxDraftMethods
draft methods
Definition: zwapi_cmd_shape_data.h:534
VX_FACE_DRAFT
@ VX_FACE_DRAFT
Face Draft.
Definition: zwapi_cmd_shape_data.h:536
VX_EDGE_DRAFT
@ VX_EDGE_DRAFT
Edge Draft.
Definition: zwapi_cmd_shape_data.h:535
VX_PRATING_EDGE_DRAFT
@ VX_PRATING_EDGE_DRAFT
Parting Edge Draft.
Definition: zwapi_cmd_shape_data.h:537
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
VX_BOOL_REMOVE
@ VX_BOOL_REMOVE
remove
Definition: zwapi_cmd_shape_data.h:37
VX_BOOL_INTERSECT
@ VX_BOOL_INTERSECT
intersect
Definition: zwapi_cmd_shape_data.h:38
VX_BOOL_ADD
@ VX_BOOL_ADD
add
Definition: zwapi_cmd_shape_data.h:36
VX_BOOL_NONE
@ VX_BOOL_NONE
base
Definition: zwapi_cmd_shape_data.h:35
VX_SWP_X_FACE_NORMAL
@ VX_SWP_X_FACE_NORMAL
face normal
Definition: zwapi_cmd_shape_data.h:263
VX_SWP_X_MIN_TWIST
@ VX_SWP_X_MIN_TWIST
minimum twist (default)
Definition: zwapi_cmd_shape_data.h:260
VX_SWP_X_FIXED_DIR
@ VX_SWP_X_FIXED_DIR
fixed direction
Definition: zwapi_cmd_shape_data.h:261
VX_SWP_X_XAXIS_CRV
@ VX_SWP_X_XAXIS_CRV
X-axis curve.
Definition: zwapi_cmd_shape_data.h:262
VX_STOCK_BLOCK
@ VX_STOCK_BLOCK
block type
Definition: zwapi_cmd_shape_data.h:941
VX_STOCK_CYLINDER
@ VX_STOCK_CYLINDER
cylinder type
Definition: zwapi_cmd_shape_data.h:942
VX_FLAG_THREAD_DEPTH_1XDIAMETER
@ VX_FLAG_THREAD_DEPTH_1XDIAMETER
1.0 x diameter
Definition: zwapi_cmd_shape_data.h:788
VX_FLAG_THREAD_DEPTH_CUSTOM
@ VX_FLAG_THREAD_DEPTH_CUSTOM
custom
Definition: zwapi_cmd_shape_data.h:794
VX_FLAG_THREAD_DEPTH_15XDIAMETER
@ VX_FLAG_THREAD_DEPTH_15XDIAMETER
1.5 x diameter
Definition: zwapi_cmd_shape_data.h:789
VX_FLAG_THREAD_DEPTH_FULL
@ VX_FLAG_THREAD_DEPTH_FULL
full
Definition: zwapi_cmd_shape_data.h:793
VX_FLAG_THREAD_DEPTH_25XDIAMETER
@ VX_FLAG_THREAD_DEPTH_25XDIAMETER
2.5 x diameter
Definition: zwapi_cmd_shape_data.h:791
VX_FLAG_THREAD_DEPTH_DEFAULT
@ VX_FLAG_THREAD_DEPTH_DEFAULT
default
Definition: zwapi_cmd_shape_data.h:787
VX_FLAG_THREAD_DEPTH_2XDIAMETER
@ VX_FLAG_THREAD_DEPTH_2XDIAMETER
2.0 x diameter
Definition: zwapi_cmd_shape_data.h:790
VX_FLAG_THREAD_DEPTH_3XDIAMETER
@ VX_FLAG_THREAD_DEPTH_3XDIAMETER
3.0 x diameter
Definition: zwapi_cmd_shape_data.h:792
VX_CHAMFLLT_ASYMMETRIC
@ VX_CHAMFLLT_ASYMMETRIC
asymmetric chamfer or fillet: double offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:415
VX_CHAMFLLT_SETBACK_ANGLE
@ VX_CHAMFLLT_SETBACK_ANGLE
asymmetric chamfer or fillet: offset and angle chamfer at edge
Definition: zwapi_cmd_shape_data.h:416
VX_CHAMFLLT_VERTEX
@ VX_CHAMFLLT_VERTEX
vertex chamfer or fillet: single offset chamfer at vertex
Definition: zwapi_cmd_shape_data.h:417
VX_CHAMFLLT_SYMMETRIC
@ VX_CHAMFLLT_SYMMETRIC
symmetric chamfer or fillet: single offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:414
VX_LOFT_END_PNT_PROFS
@ VX_LOFT_END_PNT_PROFS
loft based on ending point and profiles
Definition: zwapi_cmd_shape_data.h:379
VX_LOFT_BOTH_PNTS_PROFS
@ VX_LOFT_BOTH_PNTS_PROFS
loft based on both end points and profiles
Definition: zwapi_cmd_shape_data.h:380
VX_LOFT_PROFS
@ VX_LOFT_PROFS
loft profiles in the order of profiles selection
Definition: zwapi_cmd_shape_data.h:377
VX_LOFT_START_PNT_PROFS
@ VX_LOFT_START_PNT_PROFS
loft based on starting point and profiles
Definition: zwapi_cmd_shape_data.h:378
evxHoleOpt
evxHoleOpt
hole option
Definition: zwapi_cmd_shape_data.h:606
VX_GENERAL_HOLE
@ VX_GENERAL_HOLE
general hole
Definition: zwapi_cmd_shape_data.h:607
VX_CLEARANCE_HOLE
@ VX_CLEARANCE_HOLE
clearance hole
Definition: zwapi_cmd_shape_data.h:608
VX_THREAD_HOLE
@ VX_THREAD_HOLE
thread hole
Definition: zwapi_cmd_shape_data.h:609
VX_PROFILE_HOLE
@ VX_PROFILE_HOLE
profile hole
Definition: zwapi_cmd_shape_data.h:610
VX_END_CAP_BOTH
@ VX_END_CAP_BOTH
both
Definition: zwapi_cmd_shape_data.h:154
VX_END_CAP_NONE
@ VX_END_CAP_NONE
none
Definition: zwapi_cmd_shape_data.h:157
VX_END_CAP_END
@ VX_END_CAP_END
end
Definition: zwapi_cmd_shape_data.h:156
VX_END_CAP_START
@ VX_END_CAP_START
start
Definition: zwapi_cmd_shape_data.h:155
cvxPartDivide
evxErrors cvxPartDivide(svxDivideData *Divide, int *numShape, int **idShapes)
cvxPartChamAsym
evxErrors cvxPartChamAsym(int Count, int *Edges, int idFace, double Setback1, double Setback2)
cvxPartDraft
evxErrors cvxPartDraft(const svxDraftData *Draft, int *idDraft)
cvxPartFilletAllInit
evxErrors cvxPartFilletAllInit(svxChamFlltData *data)
cvxPartBool2
evxErrors cvxPartBool2(evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int *ResultCount, int **ResultList)
cvxPartDraftInit
evxErrors cvxPartDraftInit(evxDraftMethods method, svxDraftData *data)
cvxPartChamAng
evxErrors cvxPartChamAng(int Count, int *Edges, int idFace, double Setback, double Angle)
cvxPartEllipsoidInit
evxErrors cvxPartEllipsoidInit(svxEllsoData *data)
cvxPartCone
evxErrors cvxPartCone(svxConeData *Cone, int *idShape)
cvxPartLipInit
evxErrors cvxPartLipInit(svxLipData *data)
cvxPartRib
evxErrors cvxPartRib(svxRibData *Rib, int *idRib)
cvxPartConeInit
evxErrors cvxPartConeInit(svxConeData *data)
cvxPartLip
evxErrors cvxPartLip(svxLipData *Lip, int *idLip)
cvxPartFlagExtThreadInit
evxErrors cvxPartFlagExtThreadInit(svxFlagExtThreadData *data)
cvxPartShell
evxErrors cvxPartShell(const svxShellData *Shell, int *idShell)
cvxPartFlagHoles
evxErrors cvxPartFlagHoles(const svxFlagHoleData *data, int *idFtr)
cvxPartStock
evxErrors cvxPartStock(svxStockData *Stock, int *idShape)
cvxPartSphereInit
evxErrors cvxPartSphereInit(svxSphereData *data)
cvxPartShellInit
evxErrors cvxPartShellInit(svxShellData *data)
cvxPartSphere
evxErrors cvxPartSphere(svxSphereData *Sphere, int *idShape)
cvxPartEllipsoid
evxErrors cvxPartEllipsoid(svxEllsoData *Ellso, int *idShape)
cvxPartCylInit
evxErrors cvxPartCylInit(svxCylData *data)
cvxPartRevolveInit
evxErrors cvxPartRevolveInit(svxRevolveData *data)
cvxPartInlayInit
evxErrors cvxPartInlayInit(svxInlayData *data)
cvxPartRibInit
evxErrors cvxPartRibInit(svxRibData *data)
cvxPartTrim
evxErrors cvxPartTrim(svxTrimData *Trim, int *numShape, int **idShapes)
cvxPartStockInit
evxErrors cvxPartStockInit(svxStockData *data)
cvxPartDivideInit
evxErrors cvxPartDivideInit(svxDivideData *data)
cvxPartBoxInit
evxErrors cvxPartBoxInit(svxBoxData *data)
cvxPartThickenInit
evxErrors cvxPartThickenInit(svxThickenData *data)
cvxPartBox
evxErrors cvxPartBox(svxBoxData *Box, int *idShape)
cvxPartSimplify
evxErrors cvxPartSimplify(int numEnts, int *idEnts, int *idSimplify)
cvxPartShapeFaceOffset
evxErrors cvxPartShapeFaceOffset(svxFaceOffData *Offset, int *idOffset)
cvxPartFlagHolesInit
evxErrors cvxPartFlagHolesInit(svxFlagHoleData *data)
cvxPartFlagExtThread
evxErrors cvxPartFlagExtThread(const svxFlagExtThreadData *data, int *idFtr)
cvxPartChamferAll
evxErrors cvxPartChamferAll(const svxChamFlltData *Chamfer, int *idChamfer)
cvxPartHoleInit
evxErrors cvxPartHoleInit(evxHoleOpt HoleOpt, int type, svxHoleData *data)
cvxPartRevolve
evxErrors cvxPartRevolve(svxRevolveData *Rev, int *idShape)
cvxPartInlay
evxErrors cvxPartInlay(svxInlayData *Inlay, int *idInlay)
cvxPartThreadAt
evxErrors cvxPartThreadAt(int idFace, svxPoint *Pnt, svxThreadData *Thread)
cvxPartHole
evxErrors cvxPartHole(svxHoleData *Data, int *idOp)
cvxPartSweep
evxErrors cvxPartSweep(svxSweepData *Swp, void *Options, int *idShape)
cvxPartExtrude
evxErrors cvxPartExtrude(svxExtrudeData *Ext, int *idShape)
cvxChamFlltSetDataInit
evxErrors cvxChamFlltSetDataInit(svxChamFlltSetData *data)
cvxPartBool3
evxErrors cvxPartBool3(evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int FaceCount, int *FaceList, int *ResultCount, int **ResultList)
cvxPartChamferAllInit
evxErrors cvxPartChamferAllInit(svxChamFlltData *data)
cvxPartLoftInit
evxErrors cvxPartLoftInit(svxLoftData *data)
cvxPartThicken
evxErrors cvxPartThicken(svxThickenData *Thicken, int *idShape)
cvxPartLoft
evxErrors cvxPartLoft(svxLoftData *Loft, int *idShape)
cvxPartThreadAtInit
evxErrors cvxPartThreadAtInit(svxThreadData *data)
cvxPartChamConst
evxErrors cvxPartChamConst(int Count, int *Edges, double Setback)
cvxPartCyl
evxErrors cvxPartCyl(svxCylData *Cyl, int *idShape)
cvxPartBool
evxErrors cvxPartBool(evxBoolType Type, int idBase, int Count, int *Shapes, int Keep)
cvxPartFilletAll
evxErrors cvxPartFilletAll(const svxChamFlltData *Fillet, int *idFillet)
cvxPartShapeFaceOffsetInit
evxErrors cvxPartShapeFaceOffsetInit(svxFaceOffData *data)
cvxPartTrimInit
evxErrors cvxPartTrimInit(svxTrimData *data)
cvxPartSweepInit
evxErrors cvxPartSweepInit(svxSweepData *data)
cvxPartExtrudeInit
evxErrors cvxPartExtrudeInit(svxExtrudeData *data)
cvxPartFillet
evxErrors cvxPartFillet(int Count, int *Edges, double Radius)
VX_TO_POINT
@ VX_TO_POINT
the start/end field by the to point method
Definition: zwapi_cmd_subcmd_data.h:60
VX_TO_FACES
@ VX_TO_FACES
the start/end field by the to faces method
Definition: zwapi_cmd_subcmd_data.h:61
VX_INPU_VALUE
@ VX_INPU_VALUE
the start/end field by the input number
Definition: zwapi_cmd_subcmd_data.h:58
VX_TO_EXTEND_FACE
@ VX_TO_EXTEND_FACE
the start/end field by the to extend face method(extrude)
Definition: zwapi_cmd_subcmd_data.h:62
VX_BY_THROUGH_ALL
@ VX_BY_THROUGH_ALL
the start/end field by the through all method
Definition: zwapi_cmd_subcmd_data.h:59
VX_TO_FACE
@ VX_TO_FACE
the start/end field by the to extend face method (normal cut)
Definition: zwapi_cmd_subcmd_data.h:63
cvxPartInterXCurveInit
evxErrors cvxPartInterXCurveInit(svxInterCrvData *data)
cvxPartInterXCurve
evxErrors cvxPartInterXCurve(const svxInterCrvData *pSurf, int *idFtr)
cvxConfigGetString
evxErrors cvxConfigGetString(const char *Name, char *Str, int nBytes)
cvxPathDirByLongPath
void cvxPathDirByLongPath(const vxLongPath FullPath, char *Directory, int sizeDir)
cvxPathFileByLongPath
void cvxPathFileByLongPath(const vxLongPath FullPath, char *FileName, int sizeFile)
cvxFileOpenListByLongPath
void cvxFileOpenListByLongPath(int *count, vxLongPath **fileList)
cvxFileInqActive
void cvxFileInqActive(char *Name, int nBytes)
cvxEntEndPnt
evxErrors cvxEntEndPnt(int idEntity, svxPoint *Start, svxPoint *End)
cvxEntMatrix
evxErrors cvxEntMatrix(int idEntity, svxMatrix *Matrix)
cvxEntIsCurve
int cvxEntIsCurve(int idEntity)
cvxEntBndBox
evxErrors cvxEntBndBox(int idEntity, svxBndBox *Box)
cvxEntSketch
void cvxEntSketch(int idEntity, int *idSketch)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxCrvEval2
evxErrors cvxCrvEval2(const int idCurve, const double t, const int level, svxEvalCurv *eval)
cvxCrvParam
evxErrors cvxCrvParam(int idCurve, svxLimit *T)
cvxPartFace
evxErrors cvxPartFace(svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Code, int Sew, double Tol, int *idFace)
cvxPntDist
double cvxPntDist(const svxPoint *Point1, const svxPoint *Point2)
cvxVecParallelChk
int cvxVecParallelChk(int Orient, svxVector *V1, svxVector *V2, double CosTol)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxPartInqCurve
evxErrors cvxPartInqCurve(int idEntity, int Nurb, svxCurve *Crv)
cvxPartInqCrvLists
evxErrors cvxPartInqCrvLists(int *Count, int **CrvLists)
cvxPartInqCrvList
evxErrors cvxPartInqCrvList(int idCrvList, int *Count, svxEntPick **Curves)
cvxCurveFree
void cvxCurveFree(svxCurve *Crv)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CRV_OR_PROF
@ VX_INP_PNT_ON_CRV_OR_PROF
point on curve or profile
Definition: zwapi_userinput.h:88
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_END
@ VX_INP_PNT_END
point end
Definition: zwapi_userinput.h:85
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
VX_INP_SHAPE_OR_FACE
@ VX_INP_SHAPE_OR_FACE
pick shape or face
Definition: zwapi_userinput.h:37
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_3D_GEOM
@ VX_INP_3D_GEOM
pick 3d geometry
Definition: zwapi_userinput.h:57
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
cvxGetFileByLongPath
void cvxGetFileByLongPath(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
cvxGetString
int cvxGetString(const char *Prompt, const char *Default, int NumBytes, char *String)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
VX_SF_PRIM_CYL
@ VX_SF_PRIM_CYL
cylinder
Definition: zwapi_util.h:1759
VX_ENT_EDGE
@ VX_ENT_EDGE
b-rep edge
Definition: zwapi_util.h:925
svxAxis::Dir
svxVector Dir
direction
Definition: zwapi_util.h:351
svxAxis::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:350
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBndBox::Z
svxLimit Z
the maximum and minimum values in the z direction of the boundle box
Definition: zwapi_util.h:468
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxBoxData::idPlane
int idPlane
optional datum plane, or 0
Definition: zwapi_cmd_shape_data.h:48
svxBoxData::Center
svxPoint Center
center of box volume
Definition: zwapi_cmd_shape_data.h:51
svxBoxData::useAxis
int useAxis
flag to use axis, 0 default
Definition: zwapi_cmd_shape_data.h:49
svxBoxData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:47
svxBoxData::X
double X
length along X
Definition: zwapi_cmd_shape_data.h:52
svxBoxData::Y
double Y
length along Y
Definition: zwapi_cmd_shape_data.h:53
svxBoxData::ftrName
vxName ftrName
feature name for "FtAllBox", 0 default
Definition: zwapi_cmd_shape_data.h:55
svxBoxData::Z
double Z
length along Z
Definition: zwapi_cmd_shape_data.h:54
svxBoxData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:50
svxBoxData
box data
Definition: zwapi_cmd_shape_data.h:46
svxChamFlltData::baseFaces
int baseFaces
base face processing method (0-sew, 1-trim, 2-divide, 3-no action)
Definition: zwapi_cmd_shape_data.h:488
svxChamFlltData::cntList
int cntList
count of set list, 0-to ignore
Definition: zwapi_cmd_shape_data.h:499
svxChamFlltData::weight
double weight[2]
endpoint weights for G2 blend arc type (0.1~5.0, 1.0-default)
Definition: zwapi_cmd_shape_data.h:466
svxChamFlltData::traceCorners
int traceCorners
if set to 1, the rails of the chamfer/fillet and corner patch faces are traced onto the support faces...
Definition: zwapi_cmd_shape_data.h:480
svxChamFlltData::vertex
int * vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in thi...
Definition: zwapi_cmd_shape_data.h:452
svxChamFlltData::angle
double angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type
Definition: zwapi_cmd_shape_data.h:458
svxChamFlltData::localCorner
int localCorner
if set to 1, keep chamfering/filleting only to the edge, else the chamfer/fillet will extend to the s...
Definition: zwapi_cmd_shape_data.h:475
svxChamFlltData::mitred
int mitred
if set to 1, the chamfer/fillet engine will provide a mitred solution at corners of uniform convexity...
Definition: zwapi_cmd_shape_data.h:477
svxChamFlltData::offsetType
int offsetType
method of offset, 0- offset distance, 1- offset surface(default:0, only used for Charmer feature)
Definition: zwapi_cmd_shape_data.h:492
svxChamFlltData::relief
double relief
specify the amount of smoothing at a corner patch. When set to zero (0.0-default),...
Definition: zwapi_cmd_shape_data.h:461
svxChamFlltData::pChamFlltDataList
svxChamFlltSetData * pChamFlltDataList
data of each list, NULL to ignore
Definition: zwapi_cmd_shape_data.h:500
svxChamFlltData::filletFace
int filletFace
the tangency of the new chamfer/fillet faces (0-tangent match, 1-minimal, 2-maximal)
Definition: zwapi_cmd_shape_data.h:489
svxChamFlltData::arcType
int arcType
specify the fillet arc type (0-circular arc, 1-conic arc, 2-G2 blend)
Definition: zwapi_cmd_shape_data.h:464
svxChamFlltData::usePatch
int usePatch
whether to use patches in tight corners (0-default)
Definition: zwapi_cmd_shape_data.h:470
svxChamFlltData::undercuts
int undercuts
if set to 1, the chamfer/fillet engine will look for cases where the new chamfer/fillet are completel...
Definition: zwapi_cmd_shape_data.h:471
svxChamFlltData::desity
int desity
the average number of sampling points along the edges of the blended corners (2~200)
Definition: zwapi_cmd_shape_data.h:486
svxChamFlltData::type
evxChamFlltType type
chamfer or fillet type
Definition: zwapi_cmd_shape_data.h:448
svxChamFlltData::filletToEdge
int filletToEdge
if set to 1, fillet held to nearby edges (0-default)
Definition: zwapi_cmd_shape_data.h:469
svxChamFlltData::blendCorners
int blendCorners
if set to 1, create a single smooth trimmed planar face for each corner via the FEM-based surface fit...
Definition: zwapi_cmd_shape_data.h:482
svxChamFlltData::conicRatio
double conicRatio
conic ratio for conic arc type (0~0.999999, 0.5-default)
Definition: zwapi_cmd_shape_data.h:465
svxChamFlltData
chamfer or fillet data
Definition: zwapi_cmd_shape_data.h:447
svxChamFlltSetData::idEdge
int * idEdge
list of index of edges to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:427
svxChamFlltSetData::angle
double angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type
Definition: zwapi_cmd_shape_data.h:434
svxChamFlltSetData::setback1
double setback1
the first setback distance or radius
Definition: zwapi_cmd_shape_data.h:432
svxChamFlltSetData::setback1Pnt
svxPntOnEnt * setback1Pnt
setback1 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:438
svxChamFlltSetData::setback2
double setback2
the second setback distance for VX_CHAMFILT_ASYMMETRIC type
Definition: zwapi_cmd_shape_data.h:433
svxChamFlltSetData::nEdges
int nEdges
number of edges or vertexes to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:426
svxChamFlltSetData::vertex
int * vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in thi...
Definition: zwapi_cmd_shape_data.h:428
svxChamFlltSetData::setback2Pnt
svxPntOnEnt * setback2Pnt
setback2 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:439
svxChamFlltSetData
set-list data for chamfer or fillet command
Definition: zwapi_cmd_shape_data.h:425
svxConeData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:80
svxConeData::Center
svxPoint Center
center of bottom face
Definition: zwapi_cmd_shape_data.h:81
svxConeData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:87
svxConeData::Length
double Length
length (mm) along Z
Definition: zwapi_cmd_shape_data.h:83
svxConeData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:88
svxConeData::useAxis
int useAxis
flag to use axis (0 to use plane, 1 to use axis)
Definition: zwapi_cmd_shape_data.h:86
svxConeData::Radius2
double Radius2
the second radius (mm), 0 default
Definition: zwapi_cmd_shape_data.h:84
svxConeData::Radius1
double Radius1
the first radius (mm) in bottom face
Definition: zwapi_cmd_shape_data.h:82
svxConeData::ftrName
vxName ftrName
feature name for "FtAllCone", 0 default
Definition: zwapi_cmd_shape_data.h:90
svxConeData
cone
Definition: zwapi_cmd_shape_data.h:79
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxCylData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:64
svxCylData::ftrName
vxName ftrName
feature name for "FtAllCyl", 0 default
Definition: zwapi_cmd_shape_data.h:71
svxCylData::Radius
double Radius
radius (mm) in XY plane
Definition: zwapi_cmd_shape_data.h:69
svxCylData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:65
svxCylData::Length
double Length
length (mm) along Z
Definition: zwapi_cmd_shape_data.h:70
svxCylData::Center
svxPoint Center
center of bottom face
Definition: zwapi_cmd_shape_data.h:68
svxCylData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:67
svxCylData::useAxis
int useAxis
flag to use axis, 0 default
Definition: zwapi_cmd_shape_data.h:66
svxCylData
cylinder
Definition: zwapi_cmd_shape_data.h:63
svxCylinder::radius
double radius
radius
Definition: zwapi_util.h:1811
svxDivideData::trimCap
int trimCap
whether to cap shape at the trimmed edges (1 = cap, 0 = uncap)
Definition: zwapi_cmd_shape_data.h:1076
svxDivideData::extend
int extend
extend method (1 = no extend, 0 = linear, 2 = circular)
Definition: zwapi_cmd_shape_data.h:1077
svxDivideData::numCutter
int numCutter
number of dividing entities
Definition: zwapi_cmd_shape_data.h:1071
svxDivideData::idCutters
int * idCutters
list of dividing entities (shape, face, datum plane)
Definition: zwapi_cmd_shape_data.h:1072
svxDivideData::keepCutter
int keepCutter
whether to keep dividing entities (0 = delete, 1 = keep, 2 = divide)
Definition: zwapi_cmd_shape_data.h:1075
svxDivideData::idBase
int * idBase
id list of shape to divide
Definition: zwapi_cmd_shape_data.h:1070
svxDivideData::numBase
int numBase
number of shapes to divide
Definition: zwapi_cmd_shape_data.h:1069
svxDivideData
divide data
Definition: zwapi_cmd_shape_data.h:1068
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntStaFaces2
int cntStaFaces2
Stationary faces cnt.
Definition: zwapi_cmd_shape_data.h:581
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntPrtFaces
int cntPrtFaces
Parting faces cnt.
Definition: zwapi_cmd_shape_data.h:583
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::StationaryFaces2
int * StationaryFaces2
List of stationary faces in STATION_PARTING_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:580
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::PartingFaces
int * PartingFaces
List of parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:582
svxDraftData::svxDraftStationaryEnt::StationaryFaces::cnt
int cnt
Stationary Faces count.
Definition: zwapi_cmd_shape_data.h:574
svxDraftData::svxDraftStationaryEnt::StationaryFaces::idEnt
int * idEnt
List of stationary Faces id.
Definition: zwapi_cmd_shape_data.h:575
svxDraftData::svxDraftStationaryEnt::StationaryPlane::idEnt
int * idEnt
List of stationary Plane id.
Definition: zwapi_cmd_shape_data.h:589
svxDraftData::svxDraftStationaryEnt::StationaryPlane::cnt
int cnt
Stationary Plane count.
Definition: zwapi_cmd_shape_data.h:588
svxDraftData::Methods
evxDraftMethods Methods
Draft Methods.
Definition: zwapi_cmd_shape_data.h:563
svxDraftData::iIsRemivtrgns
int iIsRemivtrgns
Whether to remove inverted regions (0 = no, 1 = yes, 1 for default)
Definition: zwapi_cmd_shape_data.h:598
svxDraftData::idEnt
int * idEnt
List of picked Entity id.
Definition: zwapi_cmd_shape_data.h:566
svxDraftData::AngleA1
double AngleA1
Angle A1, if only one angle it is also Angle A.
Definition: zwapi_cmd_shape_data.h:567
svxDraftData::Type
evxDraftType Type
Draft Type in options can be picked.
Definition: zwapi_cmd_shape_data.h:564
svxDraftData::iCntDataList
int iCntDataList
Picked Entity count will be filled in list.
Definition: zwapi_cmd_shape_data.h:565
svxDraftData::AngleA2
double AngleA2
Angle A2.
Definition: zwapi_cmd_shape_data.h:568
svxDraftData::DraftSideS
int DraftSideS
Draft Side S (0 = split, 1 = top, 2 = bottom, 3 = neutral, 0 for default)
Definition: zwapi_cmd_shape_data.h:594
svxDraftData::DirP
svxVector DirP
Direction P.
Definition: zwapi_cmd_shape_data.h:593
svxDraftData::iIntersections
int iIntersections
Whether to remove intersections (0 = do not remove, 1 = remove all, 0 for default)
Definition: zwapi_cmd_shape_data.h:597
svxDraftData::iIsrecomputeflt
int iIsrecomputeflt
Whether to recompute fillets (0 = no, 1 = yes, 0 for default)
Definition: zwapi_cmd_shape_data.h:596
svxDraftData::Extention
int Extention
Extention type (0 = linear, 1 = circular, 2 = Reflect, 3 = curvature diminishing, 0 for default)
Definition: zwapi_cmd_shape_data.h:595
svxDraftData
template command Draft data
Definition: zwapi_cmd_shape_data.h:562
svxEllsoData::zLen
double zLen
length of the ellipsoid along the z (mm)
Definition: zwapi_cmd_shape_data.h:116
svxEllsoData::yLen
double yLen
length of the ellipsoid along the y (mm)
Definition: zwapi_cmd_shape_data.h:115
svxEllsoData::ftrName
vxName ftrName
feature name for "FtAllEllso", 0 default
Definition: zwapi_cmd_shape_data.h:122
svxEllsoData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:119
svxEllsoData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:112
svxEllsoData::useAxis
int useAxis
flag to use axis (0 to use plane, 1 to use axis)
Definition: zwapi_cmd_shape_data.h:118
svxEllsoData::Center
svxPoint Center
sphere center point
Definition: zwapi_cmd_shape_data.h:113
svxEllsoData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:120
svxEllsoData::xLen
double xLen
length of the ellipsoid along the x (mm)
Definition: zwapi_cmd_shape_data.h:114
svxEllsoData
ellipsoid
Definition: zwapi_cmd_shape_data.h:111
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxEntPick
entity pick (includes optional parent entity)
Definition: zwapi_util.h:976
svxEvalCurv::deriv_1
svxPoint deriv_1
level 1 - x',y' (or u',v')
Definition: zwapi_math_data.h:50
svxEvalCurv
curve evaluate
Definition: zwapi_math_data.h:47
svxExtrudeData::StartToPnt
svxPoint * StartToPnt
set the point if StartType > 1 , (NULL to ignore, it will use the start point of idStartEnt)
Definition: zwapi_cmd_shape_data.h:199
svxExtrudeData::EndType
evxDistanceMethod EndType
end type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)
Definition: zwapi_cmd_shape_data.h:194
svxExtrudeData::UseDirection
int UseDirection
1 to use optional extrusion direction, else 0
Definition: zwapi_cmd_shape_data.h:175
svxExtrudeData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:202
svxExtrudeData::idStartEnt
int idStartEnt
the entity id of start field if StartType > 1
Definition: zwapi_cmd_shape_data.h:195
svxExtrudeData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:203
svxExtrudeData::CapFace
int * CapFace
cap face id list (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:207
svxExtrudeData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:166
svxExtrudeData::ftrName
vxName ftrName
feature name for "FtAllExt", 0 default
Definition: zwapi_cmd_shape_data.h:189
svxExtrudeData::cntCap
int cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is o...
Definition: zwapi_cmd_shape_data.h:204
svxExtrudeData::EndToPnt
svxPoint * EndToPnt
set the point if EndType > 1 , (NULL to ignore, it will use the start point of idEndEnt)
Definition: zwapi_cmd_shape_data.h:200
svxExtrudeData::BooleanEnts
int * BooleanEnts
id list of shapes to combine with extrusion, use NULL if Combine is VX_BOOL_NONE or to combine extrus...
Definition: zwapi_cmd_shape_data.h:187
svxExtrudeData::idEndEnt
int idEndEnt
the entity id of end field if EndType > 1
Definition: zwapi_cmd_shape_data.h:196
svxExtrudeData::Direction
svxVector Direction
optional extrusion direction
Definition: zwapi_cmd_shape_data.h:176
svxExtrudeData::EndOffset
double EndOffset
end offset value if EndType >= 3
Definition: zwapi_cmd_shape_data.h:198
svxExtrudeData::Draft
double Draft
draft angle (deg)
Definition: zwapi_cmd_shape_data.h:171
svxExtrudeData::Start
double Start
start distance (mm)
Definition: zwapi_cmd_shape_data.h:168
svxExtrudeData::idProfile
int idProfile
profile (sketch or curvelist)
Definition: zwapi_cmd_shape_data.h:167
svxExtrudeData::End
double End
end distance (mm)
Definition: zwapi_cmd_shape_data.h:169
svxExtrudeData::numBooleanEnts
int numBooleanEnts
count of shapes in BooleanEnts array, use 0 if BooleanEnts is NULL
Definition: zwapi_cmd_shape_data.h:186
svxExtrudeData::FlipFaceDir
int FlipFaceDir
1-flip face direction, else 0 (0:default value, valid when the idProfile is open or CapType == VX_END...
Definition: zwapi_cmd_shape_data.h:191
svxExtrudeData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:181
svxExtrudeData::Twist
double Twist
twist angle (deg)
Definition: zwapi_cmd_shape_data.h:178
svxExtrudeData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:182
svxExtrudeData::StartOffset
double StartOffset
start offset value if StartType >= 3
Definition: zwapi_cmd_shape_data.h:197
svxExtrudeData::Pivot
svxPoint Pivot
pivot point if twist is non-zero
Definition: zwapi_cmd_shape_data.h:179
svxExtrudeData::StartType
evxDistanceMethod StartType
start type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)
Definition: zwapi_cmd_shape_data.h:193
svxExtrudeData::Blend
int Blend
corner blend option
Definition: zwapi_cmd_shape_data.h:172
svxExtrudeData
extruded shape
Definition: zwapi_cmd_shape_data.h:165
svxFaceOffData::numOffsetSet
int numOffsetSet
number of face offset set
Definition: zwapi_cmd_shape_data.h:995
svxFaceOffData::sideFaces
int sideFaces
whether to create side faces (0 = do not create, 1 = create, 2 = force)
Definition: zwapi_cmd_shape_data.h:999
svxFaceOffData::idFaceSet
int * idFaceSet
list of id's of faces in offset set
Definition: zwapi_cmd_shape_data.h:996
svxFaceOffData::numFaces
int numFaces
number of faces for offset
Definition: zwapi_cmd_shape_data.h:990
svxFaceOffData::type
int type
face offset type (0 = constant, 1 = variable)
Definition: zwapi_cmd_shape_data.h:987
svxFaceOffData::extension
int extension
extension type of offset face (0 = linear, 1 = circular, 2 = reflect, 3 = curvature diminishing)
Definition: zwapi_cmd_shape_data.h:1000
svxFaceOffData::offset
double offset
offset value
Definition: zwapi_cmd_shape_data.h:992
svxFaceOffData::intersect
int intersect
whether to remove self intersecting faces (0 = do not remove, 1 = remove all)
Definition: zwapi_cmd_shape_data.h:1001
svxFaceOffData::idFaces
int * idFaces
list of id's of faces for offset
Definition: zwapi_cmd_shape_data.h:991
svxFaceOffData::offsetSet
double * offsetSet
list of offset value in offset set
Definition: zwapi_cmd_shape_data.h:997
svxFaceOffData
shape face offset data
Definition: zwapi_cmd_shape_data.h:986
svxFlagExtThreadData::svxCustomInfo::value
double value
isThread is 0, value is pitch value,else Thread/Unit value
Definition: zwapi_cmd_shape_data.h:889
svxFlagExtThreadData::svxCustomInfo::isThread
int isThread
1 if thread/unit ,else pitch
Definition: zwapi_cmd_shape_data.h:888
svxFlagExtThreadData::svxCustomInfo::diamter
double diamter
diameter
Definition: zwapi_cmd_shape_data.h:887
svxFlagExtThreadData::svxCustomInfo::useDiam
int useDiam
1-use diameter, 0 use the diameter of the first input face (default: 0)
Definition: zwapi_cmd_shape_data.h:890
svxFlagExtThreadData::type
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:879
svxFlagExtThreadData::LengthType
evxFlagThreadDepthType LengthType
length type
Definition: zwapi_cmd_shape_data.h:892
svxFlagExtThreadData::count
int count
count of "Faces"
Definition: zwapi_cmd_shape_data.h:876
svxFlagExtThreadData::SetBack
double SetBack
SetBack.
Definition: zwapi_cmd_shape_data.h:898
svxFlagExtThreadData::isChamfer
int isChamfer
1 if end chamfer ,else 0
Definition: zwapi_cmd_shape_data.h:896
svxFlagExtThreadData::IdFaces
int * IdFaces
id(IdFaces[0]) of face(Faces[0])
Definition: zwapi_cmd_shape_data.h:878
svxFlagExtThreadData::angle
double angle
angle
Definition: zwapi_cmd_shape_data.h:899
svxFlagExtThreadData::Faces
svxPoint * Faces
faces
Definition: zwapi_cmd_shape_data.h:877
svxFlagExtThreadData::size
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:882
svxFlagExtThreadData::length
double length
length
Definition: zwapi_cmd_shape_data.h:895
svxFlagExtThreadData
flag ext thread data
Definition: zwapi_cmd_shape_data.h:875
svxFlagHoleData::svxCustomData::isPitch
int isPitch
1 if pitch ,else thread/unit
Definition: zwapi_cmd_shape_data.h:830
svxFlagHoleData::svxCustomData::value
double value
isPitch is 1,value is pitch value,else Thread/Unit value
Definition: zwapi_cmd_shape_data.h:831
svxFlagHoleData::svxCustomData::diamter
double diamter
diameter
Definition: zwapi_cmd_shape_data.h:829
svxFlagHoleData::DepthType
evxFlagThreadDepthType DepthType
depth type if DepthType = VX_FLAG_THREAD_DEPTH_FULL, the thread depth is the hole depth.
Definition: zwapi_cmd_shape_data.h:833
svxFlagHoleData::isUseFlaggedThread
int isUseFlaggedThread
1 if use flagged as thread hole,else 0
Definition: zwapi_cmd_shape_data.h:820
svxFlagHoleData::HolesId
int * HolesId
list of hole id
Definition: zwapi_cmd_shape_data.h:805
svxFlagHoleData::depth
double depth
depth : if DepthType = VX_FLAG_THREAD_DEPTH_CUSTOM, users can specify the thread depth into the hole ...
Definition: zwapi_cmd_shape_data.h:835
svxFlagHoleData::isUseFilter
int isUseFilter
1 if use hole filter,else 0
Definition: zwapi_cmd_shape_data.h:807
svxFlagHoleData::FaceId
int FaceId
face id
Definition: zwapi_cmd_shape_data.h:803
svxFlagHoleData::type
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:821
svxFlagHoleData::count
int count
count of "HolesId"
Definition: zwapi_cmd_shape_data.h:804
svxFlagHoleData::size
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:824
svxFlagHoleData
flag hole data
Definition: zwapi_cmd_shape_data.h:802
svxHoleChams::fCham
int fCham
Flag if chamfer.
Definition: zwapi_cmd_shape_data.h:675
svxHoleData::NoProjPntLoc
int NoProjPntLoc
1 not to project location point, 0 to project
Definition: zwapi_cmd_shape_data.h:720
svxHoleData::idShapes
int * idShapes
list of shape id. if OpNoRemove = 0 and cntShps > 0,apply it.
Definition: zwapi_cmd_shape_data.h:719
svxHoleData::idSketch
int idSketch
use sketch to create the hole (HoleOpt = VX_PROFILE_HOLE, 0 to ignore)
Definition: zwapi_cmd_shape_data.h:762
svxHoleData::slotAngle
double slotAngle
slot angle (deg)
Definition: zwapi_cmd_shape_data.h:722
svxHoleData::idInsFace
int idInsFace
id of insertion face. 0 to ignore
Definition: zwapi_cmd_shape_data.h:700
svxHoleData::Standard
vxLongName Standard
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:758
svxHoleData::idUntilFace
int idUntilFace
id of "until" face (0 if not required)
Definition: zwapi_cmd_shape_data.h:711
svxHoleData::End
evxEndCondition End
hole end condition
Definition: zwapi_cmd_shape_data.h:710
svxHoleData::HoleOpt
evxHoleOpt HoleOpt
different hole to create
Definition: zwapi_cmd_shape_data.h:756
svxHoleData::Fit
vxLongName Fit
"Close","Normal","Loose","Custom"
Definition: zwapi_cmd_shape_data.h:761
svxHoleData::cntShps
int cntShps
count of shapes. if OpNoRemove = 0,apply it. if OpNoRemove=0 and cngShps=0, remove default.
Definition: zwapi_cmd_shape_data.h:716
svxHoleData::UseDirection
int UseDirection
1 to use "Direction" input ; 0 for default (the hole feature(s) will be perpendicular to the face)
Definition: zwapi_cmd_shape_data.h:712
svxHoleData::Screw
vxLongName Screw
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:759
svxHoleData::sCham
svxHoleChams sCham
Start chamfer.
Definition: zwapi_cmd_shape_data.h:737
svxHoleData::slotLength
double slotLength
slot length (mm)
Definition: zwapi_cmd_shape_data.h:721
svxHoleData::Count
int Count
number of holes
Definition: zwapi_cmd_shape_data.h:701
svxHoleData::mCham
svxHoleChams mCham
Middle chamfer for counter bore or spot face bore.
Definition: zwapi_cmd_shape_data.h:738
svxHoleData::eCham
svxHoleChams eCham
End chamfer.
Definition: zwapi_cmd_shape_data.h:739
svxHoleData::ThreadSize
vxLongName ThreadSize
thread size. The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:726
svxHoleData::Size
vxLongName Size
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:760
svxHoleData::Direction
svxVector Direction
optional direction for hole centerline
Definition: zwapi_cmd_shape_data.h:714
svxHoleData::ThreadType
evxThreadType ThreadType
thread type
Definition: zwapi_cmd_shape_data.h:725
svxHoleData::Points
svxPoint * Points
list of "Count" hole insertion points (calling procedure must allocate/deallocate)
Definition: zwapi_cmd_shape_data.h:702
svxHoleData
hole data
Definition: zwapi_cmd_shape_data.h:697
svxInlayData::numCrvs
int numCrvs
number of curves that defines a inlay boundary
Definition: zwapi_cmd_shape_data.h:1136
svxInlayData::draftAbout
int draftAbout
specify which plane to draft about ( 0 = base, 1 = offset, 2 = middle)
Definition: zwapi_cmd_shape_data.h:1143
svxInlayData::filletAbout
int filletAbout
specify which edges to fillet ( 0 = both, 1 = base, 2 = offset)
Definition: zwapi_cmd_shape_data.h:1146
svxInlayData::inlayDir
svxVector inlayDir
inlay direction of curves
Definition: zwapi_cmd_shape_data.h:1142
svxInlayData::idCrvs
int * idCrvs
list of curves that defines a inlay boundary (sketch, curve, curve list, sketch block)
Definition: zwapi_cmd_shape_data.h:1137
svxInlayData::projType
int projType
projection method (0 = in place(none), 1 = face normal, 2 = directed, 3 = bi-directional)
Definition: zwapi_cmd_shape_data.h:1140
svxInlayData::numFaces
int numFaces
number of faces to receive the inlay
Definition: zwapi_cmd_shape_data.h:1134
svxInlayData::offset
double offset
offset distance, positive raises the faces while negative sinks the faces
Definition: zwapi_cmd_shape_data.h:1138
svxInlayData::idFaces
int * idFaces
list of id's of faces to receive the inlay
Definition: zwapi_cmd_shape_data.h:1135
svxInlayData::projDir
svxVector projDir
projection direction, only used when projType = 2
Definition: zwapi_cmd_shape_data.h:1141
svxInlayData::draftAngle
double draftAngle
draft angle for the side faces
Definition: zwapi_cmd_shape_data.h:1144
svxInlayData::filletRad
double filletRad
fillet radius
Definition: zwapi_cmd_shape_data.h:1147
svxInlayData::filletType
int filletType
fillet type ( 0 = circular, 1 = chamfer)
Definition: zwapi_cmd_shape_data.h:1145
svxInlayData
inlay data
Definition: zwapi_cmd_shape_data.h:1133
svxInterCrvData::iEntCout2
int iEntCout2
The number of faces selected for the second field.
Definition: zwapi_cmd_wireframe_data.h:196
svxInterCrvData::idEnt2
int * idEnt2
Select all face ids for the second field.
Definition: zwapi_cmd_wireframe_data.h:198
svxInterCrvData::idEnt1
int * idEnt1
Select all face ids for the first field.
Definition: zwapi_cmd_wireframe_data.h:197
svxInterCrvData::trim
int trim
1 to trim intersection curves to face boundaries; 0 does not not trim the curve, 1 default
Definition: zwapi_cmd_wireframe_data.h:199
svxInterCrvData::iEntCout1
int iEntCout1
The number of faces selected for the first field.
Definition: zwapi_cmd_wireframe_data.h:195
svxInterCrvData
inter curve
Definition: zwapi_cmd_wireframe_data.h:194
svxLimit::max
double max
minimum
Definition: zwapi_util.h:457
svxLimit::min
double min
maximum
Definition: zwapi_util.h:456
svxLimit
limits
Definition: zwapi_util.h:455
svxLipData::idEdge
int * idEdge
list of edges to apply lip
Definition: zwapi_cmd_shape_data.h:926
svxLipData::idFace
int * idFace
list of faces on first side, the face must be associated with lip edge
Definition: zwapi_cmd_shape_data.h:927
svxLipData::numEdges
int numEdges
number of edges to apply lip
Definition: zwapi_cmd_shape_data.h:925
svxLipData::offset2
double offset2
the second offset distance
Definition: zwapi_cmd_shape_data.h:931
svxLipData::offset1
double offset1
the first offset distance. Lip setback distances are +/- relative to the face normal....
Definition: zwapi_cmd_shape_data.h:929
svxLipData
lip data
Definition: zwapi_cmd_shape_data.h:923
svxLoftBndCons::idFace
int idFace
id of tangency, it's ignored when a single face on the edges or continuity = 0, 0 to use default face
Definition: zwapi_cmd_subcmd_data.h:75
svxLoftBndCons::continuity
int continuity
specify the continuity level at end of loft (0 = None, 1 = tangent, 2 = curvature,...
Definition: zwapi_cmd_subcmd_data.h:72
svxLoftBndCons::weight
double weight
specify the amount of the loft affected by the enforcement of tangency
Definition: zwapi_cmd_subcmd_data.h:74
svxLoftBndCons::direction
int direction
specify direction of loft at start and end profiles (0 = perpendicular, 1 = along edges)
Definition: zwapi_cmd_subcmd_data.h:73
svxLoftData::numProfs
int numProfs
number of profiles for loft
Definition: zwapi_cmd_shape_data.h:393
svxLoftData::bndCons
svxLoftBndCons bndCons[2]
boundary constraints data of start and end profiles
Definition: zwapi_cmd_shape_data.h:398
svxLoftData::endPnt
svxPoint endPnt
ending point coordinate
Definition: zwapi_cmd_shape_data.h:396
svxLoftData::endCap
int endCap
end cap option (0-both, 1-start, 2-end, 3-none)
Definition: zwapi_cmd_shape_data.h:399
svxLoftData::idEndParent
int idEndParent
id of the parent entity where the ending point is located
Definition: zwapi_cmd_shape_data.h:395
svxLoftData::startPnt
svxPoint startPnt
starting point coordinate
Definition: zwapi_cmd_shape_data.h:392
svxLoftData::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:389
svxLoftData::profs
svxLoftProfile * profs
list of profiles data
Definition: zwapi_cmd_shape_data.h:394
svxLoftData::close
int close
whether to generate a closed loft (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:400
svxLoftData::type
evxLoftType type
loft method
Definition: zwapi_cmd_shape_data.h:390
svxLoftData::idStartParent
int idStartParent
id of the parent entity where the starting point is located
Definition: zwapi_cmd_shape_data.h:391
svxLoftData
loft data
Definition: zwapi_cmd_shape_data.h:388
svxLoftProfile::idParent
int idParent
id of profile curve's parent sketch or curve list
Definition: zwapi_cmd_shape_data.h:364
svxLoftProfile::startPnt
svxPoint startPnt
starting point coordinate, only setting when useStartPnt = 1
Definition: zwapi_cmd_shape_data.h:368
svxLoftProfile::useStartPnt
int useStartPnt
1 = use the specified starting point, 0 = use the default starting point
Definition: zwapi_cmd_shape_data.h:367
svxLoftProfile::profDir
int profDir
specify the orientation of the profile (0 = from start point to end point, otherwise 1)
Definition: zwapi_cmd_shape_data.h:366
svxLoftProfile::idProfile
int idProfile
id of profile curve for loft (curve, edge, parting line)
Definition: zwapi_cmd_shape_data.h:365
svxLoftProfile
loft profile data
Definition: zwapi_cmd_shape_data.h:363
svxMatrix::xt
double xt
cosines of X axis and origin X (xt)
Definition: zwapi_util.h:481
svxMatrix::zt
double zt
cosines of Z axis and origin Z (zt)
Definition: zwapi_util.h:483
svxMatrix::yt
double yt
cosines of Y axis and origin Y (yt)
Definition: zwapi_util.h:482
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPartInstData::CopyWire
int CopyWire
1 to copy wireframe, or 0
Definition: zwapi_cmd_assembly_data.h:116
svxPartInstData::File
vxLongPath File
name of ZW3D file that contains "Part"
Definition: zwapi_cmd_assembly_data.h:111
svxPartInstData::Option
int Option
0 - sub-part with associative copy. 1 - sub-part with history. 2 - history copied into this part....
Definition: zwapi_cmd_assembly_data.h:118
svxPartInstData::Dir
vxLongPath Dir
pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames
Definition: zwapi_cmd_assembly_data.h:108
svxPartInstData::Part
vxRootName Part
name of part that to be copied
Definition: zwapi_cmd_assembly_data.h:112
svxPartInstData::Frame
svxMatrix Frame
insertion frame for sub-part,the insert point is the original point of frame
Definition: zwapi_cmd_assembly_data.h:113
svxPartInstData::CopyDim
int CopyDim
1 to copy dimension, or 0
Definition: zwapi_cmd_assembly_data.h:117
svxPartInstData
copy external part data
Definition: zwapi_cmd_assembly_data.h:107
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::useDir
int useDir
1-use as a direction, else 0
Definition: zwapi_util.h:558
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxRevolveData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:223
svxRevolveData::StartPnt
svxPoint * StartPnt
start point (NULL to ignore, it will get the point (umin,vmin) of the idStartEnt if StartType = VX_EX...
Definition: zwapi_cmd_shape_data.h:235
svxRevolveData::Flip
int Flip
flip face direction (0 as default, CapType=VX_END_CAP_NONE)
Definition: zwapi_cmd_shape_data.h:238
svxRevolveData::Start
double Start
start angle (deg)
Definition: zwapi_cmd_shape_data.h:218
svxRevolveData::EndPnt
svxPoint * EndPnt
end point (NULL to ignore, it will get the point (umin,vmin) of the idEndEnt if EndType = VX_EXT_TO_F...
Definition: zwapi_cmd_shape_data.h:236
svxRevolveData::idEndEnt
int idEndEnt
entity id if EndType != VX_INPU_VALUE (-1 to ignore)
Definition: zwapi_cmd_shape_data.h:234
svxRevolveData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:228
svxRevolveData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:222
svxRevolveData::End
double End
end angle (deg)
Definition: zwapi_cmd_shape_data.h:219
svxRevolveData::EndType
evxDistanceMethod EndType
end type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE,...
Definition: zwapi_cmd_shape_data.h:232
svxRevolveData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:237
svxRevolveData::StartType
evxDistanceMethod StartType
start type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE,...
Definition: zwapi_cmd_shape_data.h:231
svxRevolveData::idStartEnt
int idStartEnt
entity id if StartType != VX_INPU_VALUE (-1 to ignore)
Definition: zwapi_cmd_shape_data.h:233
svxRevolveData::idProfile
int idProfile
profile (sketch or curvelist)
Definition: zwapi_cmd_shape_data.h:217
svxRevolveData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:216
svxRevolveData::Axis
svxAxis Axis
axis of revolution
Definition: zwapi_cmd_shape_data.h:220
svxRevolveData
revolved shape
Definition: zwapi_cmd_shape_data.h:215
svxRibData::numBndFaces
int numBndFaces
number of rib boundary faces.
Definition: zwapi_cmd_shape_data.h:864
svxRibData::width
double width
rib thickness (mm) (default:10)
Definition: zwapi_cmd_shape_data.h:861
svxRibData::idBndFaces
int * idBndFaces
list of rib boundary faces
Definition: zwapi_cmd_shape_data.h:865
svxRibData::idParent
int idParent
id of profile curve's parent sketch or curvelist
Definition: zwapi_cmd_shape_data.h:857
svxRibData::flipDir
int flipDir
flip the material direction (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:866
svxRibData::idProfile
int idProfile
index of profile curve
Definition: zwapi_cmd_shape_data.h:858
svxRibData::idPlane
int idPlane
draft plane, set when angle > 0.0
Definition: zwapi_cmd_shape_data.h:863
svxRibData::angle
double angle
draft angle (default:0)
Definition: zwapi_cmd_shape_data.h:862
svxRibData::direction
int direction
extrude direction (0 = Parallel to sketch(default), 1 = Vertical to sketch)
Definition: zwapi_cmd_shape_data.h:859
svxRibData::widthType
int widthType
thickness type (0 = Fist side, 1 = Two sides(default), 2 = Second side)
Definition: zwapi_cmd_shape_data.h:860
svxRibData
rib data
Definition: zwapi_cmd_shape_data.h:854
svxShellData::cntList
int cntList
the count of the sub_data will be filled in List
Definition: zwapi_cmd_shape_data.h:1019
svxShellData::sideFaces
int sideFaces
create side faces 0 to no 1 to yes (Generally 1) :create any required side faces during the offset ...
Definition: zwapi_cmd_shape_data.h:1024
svxShellData::Intersect
int Intersect
intersections 1 to do not remove. Ignore self intersecting faces. 2 to remove fast....
Definition: zwapi_cmd_shape_data.h:1030
svxShellData::idShape
int idShape
shape S id
Definition: zwapi_cmd_shape_data.h:1012
svxShellData::pIdOpenFace
int * pIdOpenFace
open faces' id
Definition: zwapi_cmd_shape_data.h:1016
svxShellData::dThick
double dThick
thick T
Definition: zwapi_cmd_shape_data.h:1013
svxShellData::cntOpenFace
int cntOpenFace
open faces' count
Definition: zwapi_cmd_shape_data.h:1015
svxShellData::KeepPrimFace
int KeepPrimFace
Keep primitive faces 0 to no (Generally 1) 1 to yes : primitive faces remaining as primitive after ...
Definition: zwapi_cmd_shape_data.h:1027
svxShellData::pOffSet
double * pOffSet
offset T array ,it must be correspond to pIdFaces one by one
Definition: zwapi_cmd_shape_data.h:1021
svxShellData::pIdFace
int * pIdFace
face F ids
Definition: zwapi_cmd_shape_data.h:1020
svxShellData
template command Shell input data
Definition: zwapi_cmd_shape_data.h:1011
svxSphereData::Radius
double Radius
sphere radius (mm)
Definition: zwapi_cmd_shape_data.h:101
svxSphereData::ftrName
vxName ftrName
feature name for "FtAllSph", 0 default
Definition: zwapi_cmd_shape_data.h:103
svxSphereData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:99
svxSphereData::Center
svxPoint Center
sphere center point
Definition: zwapi_cmd_shape_data.h:100
svxSphereData
sphere
Definition: zwapi_cmd_shape_data.h:98
svxSrfPrim::cyl
svxCylinder cyl
cylindrical surface data
Definition: zwapi_util.h:1865
svxSrfPrim::srfType
evxSrfPrimType srfType
surface type
Definition: zwapi_util.h:1859
svxSrfPrim
3D NURB surface data
Definition: zwapi_util.h:1858
svxStockData::length
double length[2]
when adjustType = 0, increment of length in the positive and negative directions when adjustType = 1,...
Definition: zwapi_cmd_shape_data.h:961
svxStockData::axisPos
int axisPos
specify the center axis position of the cylinder (0 = on the setting axis, 1 = on the center of the s...
Definition: zwapi_cmd_shape_data.h:970
svxStockData::numEnts
int numEnts
number of entities to enclose
Definition: zwapi_cmd_shape_data.h:952
svxStockData::axis
svxAxis axis
spiral axis to specify the rotational center of the cylinder
Definition: zwapi_cmd_shape_data.h:969
svxStockData::adjustType
int adjustType
Type of adjust value (0 = By side, 1 = By total)
Definition: zwapi_cmd_shape_data.h:954
svxStockData::idPlane
int idPlane
id of reference plane to orient the stock, 0 to use default plane paralleled to XY datum (datum,...
Definition: zwapi_cmd_shape_data.h:959
svxStockData::option
evxStockOpt option
stock type(1:Block, 2:Cylinder)
Definition: zwapi_cmd_shape_data.h:951
svxStockData::decimal
int decimal
number of decimal place
Definition: zwapi_cmd_shape_data.h:955
svxStockData::idEnts
int * idEnts
list of entities to enclose (shape, face, block)
Definition: zwapi_cmd_shape_data.h:953
svxStockData
stock data
Definition: zwapi_cmd_shape_data.h:950
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
svxSweepData::xOpt
evxSweepXOpt xOpt
type of X-axis
Definition: zwapi_cmd_shape_data.h:305
svxSweepData::useStartPnt
int useStartPnt
1- user "StartPnt", else 0 it will get the start point of the "idPath"
Definition: zwapi_cmd_shape_data.h:303
svxSweepData::xEnt
svxPntOnEnt * xEnt
entity data of x-axis (NULL to ignore or use idZaxis or xOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR...
Definition: zwapi_cmd_shape_data.h:307
svxSweepData::StartPnt
svxPoint StartPnt
point that identifies start of path curve
Definition: zwapi_cmd_shape_data.h:286
svxSweepData::cntCap
int cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is o...
Definition: zwapi_cmd_shape_data.h:319
svxSweepData::idPath
int idPath
id of curve that identifies the sweep path
Definition: zwapi_cmd_shape_data.h:285
svxSweepData::CapFace
int * CapFace
cap face id list (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:322
svxSweepData::zEnt
svxPntOnEnt * zEnt
entity data of z-axis (NULL to ignore or use idZaxis or zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_T...
Definition: zwapi_cmd_shape_data.h:312
svxSweepData::idProfile
int idProfile
profile (sketch, curve, edge, curvelist)
Definition: zwapi_cmd_shape_data.h:284
svxSweepData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:318
svxSweepData::Option
evxSweepOpt Option
sweep option(VX_SWP_AT_PROFILE as default)
Definition: zwapi_cmd_shape_data.h:292
svxSweepData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:300
svxSweepData::idFrame
int idFrame
id of sweep frame if Option=VX_SWP_FRAME, else 0
Definition: zwapi_cmd_shape_data.h:294
svxSweepData::MergeFc
int MergeFc
merge tangent faces (0 as default)
Definition: zwapi_cmd_shape_data.h:323
svxSweepData::zOpt
evxSweepZOpt zOpt
type of Y-axis
Definition: zwapi_cmd_shape_data.h:306
svxSweepData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:301
svxSweepData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:283
svxSweepData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:316
svxSweepData
swept shape
Definition: zwapi_cmd_shape_data.h:282
svxThickenData::idShape
int idShape
id of shape to thicken
Definition: zwapi_cmd_shape_data.h:1050
svxThickenData::numFaces
int numFaces
number of faces to thicken
Definition: zwapi_cmd_shape_data.h:1054
svxThickenData::idFaces
int * idFaces
list of faces to thicken
Definition: zwapi_cmd_shape_data.h:1055
svxThickenData::type
int type
specify the selection of object (0 = sheet, 1 = Faces)
Definition: zwapi_cmd_shape_data.h:1044
svxThickenData::idOffFaces
int * idOffFaces
list of additional offset faces
Definition: zwapi_cmd_shape_data.h:1059
svxThickenData::numOffset
int numOffset
number of additional offset
Definition: zwapi_cmd_shape_data.h:1058
svxThickenData::keep
int keep
whether to keep the original sheet (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:1051
svxThickenData::thickT
double * thickT
list of additional offset value
Definition: zwapi_cmd_shape_data.h:1060
svxThickenData
thicken data
Definition: zwapi_cmd_shape_data.h:1043
svxThreadData::Diameter
double Diameter
thread diameter (mm)
Definition: zwapi_cmd_shape_data.h:909
svxThreadData::EndChamfer
int EndChamfer
1=Yes; 0=No Input the setback and the angle to create chamfer on the end of the face nearest the sele...
Definition: zwapi_cmd_shape_data.h:913
svxThreadData::Type
evxThreadType Type
thread type
Definition: zwapi_cmd_shape_data.h:908
svxThreadData
thread definition
Definition: zwapi_cmd_shape_data.h:907
svxTrimData::idTrimmer
int * idTrimmer
list of trimming entities (shape, face, datum plane)
Definition: zwapi_cmd_shape_data.h:1091
svxTrimData::flip
int flip
1-flip side to keep, else 0
Definition: zwapi_cmd_shape_data.h:1093
svxTrimData::trimCap
int trimCap
whether to cap shape at the trimming edges (0 = uncap, 1 = cap)
Definition: zwapi_cmd_shape_data.h:1095
svxTrimData::keepTrimm
int keepTrimm
whether to keep trimming shapes (0 = delete, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1096
svxTrimData::trimType
int trimType
1-trim with all simultaneously, else 0
Definition: zwapi_cmd_shape_data.h:1094
svxTrimData::extend
int extend
extend method (1 = no extend, 0 = linear, 2 = circular)
Definition: zwapi_cmd_shape_data.h:1097
svxTrimData::numTrimm
int numTrimm
number of trimming entities
Definition: zwapi_cmd_shape_data.h:1090
svxTrimData::numBase
int numBase
number of shapes to trimming
Definition: zwapi_cmd_shape_data.h:1088
svxTrimData::idBase
int * idBase
id list of shape to trimming
Definition: zwapi_cmd_shape_data.h:1089
svxTrimData
Trim data.
Definition: zwapi_cmd_shape_data.h:1087
svxVector
3D vector
Definition: zwapi_util.h:338
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\skCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\skCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <cmath>
#include <cstring>
ApiDefVoidFunc(zwTestPartSkIns, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSkIns2, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSkNew, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSkPlane, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCosSkPlane, VX_CODE_GENERAL);
void zwTestPartSkIns()
/*
DESCRIPTION:
Test case for function cvxPartSkIns.
*/
{
vxLongPath fileName = "\0", rootName = "\0";
double val = 0;
cvxGetNumber("Select file to insert(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
cvxGetFileByLongPath(1, "Select the file contains the sketch root abject...", workDir, "Sketch(*.Z3SKH)|*.Z3SKH|", fileName, sizeof(fileName));
cvxPathFileByLongPath(fileName, rootName, sizeof(rootName));
char* ch = strrchr(rootName, '.');
if (ch) *ch = '\0';
}
else
{
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
char* ch = strrchr(fileList[i], '.');
if (_strcmpi(ch + 1, "Z3SKH") == 0)
{
strcpy_s(fileName, sizeof(fileName), fileList[i]);
strcpy_s(rootName, sizeof(rootName), fileList[i]);
char* ch = strrchr(rootName, '.');
if (ch) *ch = '\0';
break;
}
}
cvxMemFree((void**)&fileList);
}
if (fileName[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestPartSkIns: sketch file not specified!");
return;
}
int idPlanar = 0;
cvxGetEnt("Specify planar face to insert sketch", VX_INP_REF_PLANE, 0, &idPlanar);
svxMatrix plane = { 0 };
cvxEntMatrix(idPlanar, &plane);
plane.xt = plane.yt = plane.zt = 10;
/* insert a sketch in part */
int idSketch = 0;
if (cvxPartSkIns(fileName, rootName, &plane, &idSketch) || idSketch == 0)
zwTestLogErrorMsg(5, "cvxPartSkIns: failed to insert a sketch in part!");
}
void zwTestPartSkIns2()
/*
DESCRIPTION:
Test case for function cvxPartSkIns2.
*/
{
vxLongPath fileName = "\0", rootName = "\0";
double val = 0;
cvxGetNumber("Select file to insert(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
cvxGetFileByLongPath(1, "Select the file contains the sketch root abject...", workDir, "Sketch(*.Z3SKH)|*.Z3SKH|", fileName, sizeof(fileName));
cvxPathFileByLongPath(fileName, rootName, sizeof(rootName));
char* ch = strrchr(rootName, '.');
if (ch) *ch = '\0';
}
else
{
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
char* ch = strrchr(fileList[i], '.');
if (_strcmpi(ch + 1, "Z3SKH") == 0)
{
strcpy_s(fileName, sizeof(fileName), fileList[i]);
strcpy_s(rootName, sizeof(rootName), fileList[i]);
char* ch = strrchr(rootName, '.');
if (ch) *ch = '\0';
break;
}
}
cvxMemFree((void**)&fileList);
}
if (fileName[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestPartSkIns2: sketch file not specified!");
return;
}
int idPlane = 0;
cvxGetEnt("select a datum plane", VX_INP_REF_PLANE, 0, &idPlane);
int asso = 0;
cvxGetNumber("whether use associate copy", &val);
if (int(val + 0.5))
asso = 1;
/* insert a sketch in part */
int idSketch = 0;
if (cvxPartSkIns2(fileName, rootName, idPlane, asso, &idSketch) || idSketch == 0)
zwTestLogErrorMsg(5, "cvxPartSkIns2: failed to insert a sketch in part!");
}
void zwTestPartSkNew()
/*
DESCRIPTION:
Test case for function cvxPartSkNew.
*/
{
/* add a sketch to part */
svxMatrix plane = { 0 };
cvxMatInit(&plane);
int idSketch = 0;
if (cvxPartSkNew(&plane, &idSketch) || idSketch == 0)
zwTestLogErrorMsg(5, "cvxPartSkNew: failed to add a sketch to part!");
}
void zwTestPartSkPlane()
/*
DESCRIPTION:
Test case for function cvxPartSkPlane.
*/
{
svxSketchData sketch = { 0 };
cvxGetEntPath("pick a datum plane", VX_INP_DATUM_PLANE, 0, &sketch.Plane);
/* define Y-axis */
double val = 0;
cvxGetNumber("whether define Y-axis: 0 or 1", &val);
if (int(val + 0.5))
{
sketch.RedefOrigin = 1;
cvxGetEnt("select an entity to define Y-axis, <middle click> to ignore", VX_INP_EDGE, 1, &sketch.idUpEnt);
if (sketch.idUpEnt > 0)
{
cvxGetNumber("select direction of Y-axis: 0 or 1", &val);
if (int(val + 0.5))
sketch.idUpParam = 1;
}
else
cvxGetPoint("specify the direction of Y-axis", VX_INP_PNT_ON_EDGE, 0, (svxPoint*)&sketch.UpDir, nullptr);
}
/* define XY origin */
cvxGetNumber("select the method to define XY origin: 0 - 2", &val);
if (int(val + 0.5))
{
if (int(val + 0.5) == 1)
sketch.RedefOrigin = 1;
else
{
sketch.RedefOrigin = 2;
cvxGetPoint("select XY origin", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &sketch.Origin, &sketch.idOrgEnt);
}
}
cvxGetNumber("whether reverse X-axis direction: 0 or 1", &val);
if (int(val + 1))
sketch.xDirRev = 1;
/* add a sketch to part */
int idSketch = 0;
if (cvxPartSkPlane(&sketch, &idSketch) || idSketch == 0)
zwTestLogErrorMsg(5, "cvxPartSkPlane: failed to add a sketch to part!");
}
void zwTestPartCosSkPlane()
/*
DESCRIPTION:
Test case for function cvxPartCosSkPlane.
*/
{
/* hatch pattern data */
svxHatchPtnData hatchPattern;
if (cvxHatchPtnDataInit(&hatchPattern))
zwTestLogErrorMsg(5, "cvxHatchPtnDataInit: failed to initialize hatch pattern!");
cvxGetNumber("specify angle, 0.0 as default", &hatchPattern.angle);
cvxGetNumber("specify space, 3.175 as default", &hatchPattern.space);
/* sketch data */
svxSketchData sketch = { 0 };
cvxGetEntPath("pick a datum plane", VX_INP_DATUM_PLANE, 0, &sketch.Plane);
/* define Y-axis */
double val = 0;
cvxGetNumber("whether define Y-axis: 0 or 1", &val);
if (int(val + 0.5))
{
sketch.RedefOrigin = 1;
cvxGetEnt("select an entity to define Y-axis, <middle click> to ignore", VX_INP_EDGE, 1, &sketch.idUpEnt);
if (sketch.idUpEnt > 0)
{
cvxGetNumber("select direction of Y-axis: 0 or 1", &val);
if (int(val + 0.5))
sketch.idUpParam = 1;
}
else
cvxGetPoint("specify the direction of Y-axis", VX_INP_PNT_ON_EDGE, 0, (svxPoint*)&sketch.UpDir, nullptr);
}
/* define XY origin */
cvxGetNumber("select the method to define XY origin: 0 - 2", &val);
if (int(val + 0.5))
{
if (int(val + 0.5) == 1)
sketch.RedefOrigin = 1;
else
{
sketch.RedefOrigin = 2;
cvxGetPoint("select XY origin", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &sketch.Origin, &sketch.idOrgEnt);
}
}
cvxGetNumber("whether reverse X-axis direction: 0 or 1", &val);
if (int(val + 1))
sketch.xDirRev = 1;
/* add a cosmetic sketch to part */
int idSketch = 0;
if (cvxPartCosSkPlane(&sketch, 1, &hatchPattern, &idSketch) || idSketch == 0)
zwTestLogErrorMsg(5, "cvxPartCosSkPlane: failed to add a sketch!");
}
cvxPartSkPlane
evxErrors cvxPartSkPlane(svxSketchData *SkData, int *idSketch)
cvxPartCosSkPlane
evxErrors cvxPartCosSkPlane(const svxSketchData *SkData, int isAddHatPtn, const svxHatchPtnData *PatData, int *idSketch)
cvxPartSkNew
evxErrors cvxPartSkNew(svxMatrix *Plane, int *idSketch)
cvxHatchPtnDataInit
evxErrors cvxHatchPtnDataInit(svxHatchPtnData *data)
cvxPartSkIns
evxErrors cvxPartSkIns(const vxLongPath File, const vxRootName Name, svxMatrix *Plane, int *idSketch)
cvxPartSkIns2
evxErrors cvxPartSkIns2(const vxLongPath File, const vxRootName Name, int idPlane, int iAsso, int *idSketch)
cvxConfigGetString
evxErrors cvxConfigGetString(const char *Name, char *Str, int nBytes)
cvxPathFileByLongPath
void cvxPathFileByLongPath(const vxLongPath FullPath, char *FileName, int sizeFile)
cvxFileOpenListByLongPath
void cvxFileOpenListByLongPath(int *count, vxLongPath **fileList)
cvxEntMatrix
evxErrors cvxEntMatrix(int idEntity, svxMatrix *Matrix)
cvxMatInit
void cvxMatInit(svxMatrix *Mat)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
cvxGetFileByLongPath
void cvxGetFileByLongPath(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
svxHatchPtnData::space
double space
spacing attribute default: 3.175
Definition: zwapi_cmd_sk_create_data.h:147
svxHatchPtnData::angle
double angle
angle attribute default: 0.0
Definition: zwapi_cmd_sk_create_data.h:145
svxHatchPtnData
cosmetic sketch hatch pattern definition data
Definition: zwapi_cmd_sk_create_data.h:142
svxMatrix::xt
double xt
cosines of X axis and origin X (xt)
Definition: zwapi_util.h:481
svxMatrix::zt
double zt
cosines of Z axis and origin Z (zt)
Definition: zwapi_util.h:483
svxMatrix::yt
double yt
cosines of Y axis and origin Y (yt)
Definition: zwapi_util.h:482
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
svxSketchData::xDirRev
int xDirRev
whether to reverse X-axis direction
Definition: zwapi_cmd_sk_create_data.h:56
svxSketchData::Plane
svxEntPath Plane
pick path of insertion to locate the sketch (datum plane,planar face,sketch)
Definition: zwapi_cmd_sk_create_data.h:34
svxSketchData::idUpEnt
int idUpEnt
specify the entity used to define the Y-axis, 0 to ignore (edge,curve,axis,datum plane)
Definition: zwapi_cmd_sk_create_data.h:40
svxSketchData::idUpParam
int idUpParam
specify direction of Y-axis (0: use the positive direction of the edge or curve, or X-axis of datum p...
Definition: zwapi_cmd_sk_create_data.h:41
svxSketchData::Origin
svxPoint Origin
origin of sketch, can be ignored if idOrgEnt > 0 and use the critical point of entity
Definition: zwapi_cmd_sk_create_data.h:54
svxSketchData::RedefOrigin
int RedefOrigin
whether to redefine origin of sketch (0: use the default origin of the insertion plane 1: use centroi...
Definition: zwapi_cmd_sk_create_data.h:47
svxSketchData::idOrgEnt
int idOrgEnt
specify the parent entity where the origin locate, 0 to ignore (edge,curve,face,datum plane,...
Definition: zwapi_cmd_sk_create_data.h:51
svxSketchData::UpDir
svxVector UpDir
direction of Y-axis, can be ignored if idUpEnt > 0
Definition: zwapi_cmd_sk_create_data.h:44
svxSketchData
sketch definition data
Definition: zwapi_cmd_sk_create_data.h:33
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\smdFtrCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\smdFtrCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <cstring>
ApiDefVoidFunc(zwTestPartSmdUnfold, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdFold, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdDimple, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdCloseCorner, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdLouver, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdNormalCut, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdPunch, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdExtrudeTab, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdExtrudeFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdFullFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdProfFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdPartialFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdHemFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdStatFaceSet, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdJog, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdLftFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdFoldByLine, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdSweptFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdExtendFlange, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdBendTaper, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdFlatten, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdLnUnfold, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdChangeBend, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdRip, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSmdMarkBend, VX_CODE_GENERAL);
void zwTestPartSmdUnfold()
/*
DESCRIPTION:
Test case for function cvxPartSmdUnfold.
*/
{
/* initialize unfold data */
svxUnfoldData unfold = {};
/* select a shape to unfold */
cvxGetEnt("[shape]Select a shape to unfold", VX_INP_SHAPE, 0, &unfold.idShape);
/* optional input */
cvxGetEnt("[face]Select a stationary face, <middle click> to ignore", VX_INP_FACE, 1, &unfold.idStationary);
cvxGetEnts("[faces]Select bend faces, <middle click> when done", VX_INP_FACE, 1, &unfold.BendFaceCnts, &unfold.idBendFace);
cvxGetEnts("[curves]Select curves on sheet metal, <middle click> when done", VX_INP_CURVE, 1, &unfold.CrvCnts, &unfold.idCrv);
/* unfold shape */
int idSmd = 0;
if (cvxPartSmdUnfold(&unfold, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdUnfold: failed to unfold shape!");
/* free memory */
cvxMemFree((void**)&unfold.idBendFace);
cvxMemFree((void**)&unfold.idCrv);
}
void zwTestPartSmdFold()
/*
DESCRIPTION:
Test case for function cvxPartSmdFold.
*/
{
/* initialize fold data */
svxFoldData fold = {};
/* select a shape to unfold */
cvxGetEnt("[shape]Select a shape to fold", VX_INP_SHAPE, 0, &fold.idShape);
/* optional input */
cvxGetEnt("[face]Select a stationary face, <middle click> to ignore", VX_INP_FACE, 1, &fold.idStationary);
cvxGetEnts("[faces]Select bend faces, <middle click> when done", VX_INP_FACE, 1, &fold.BendFaceCnts, &fold.idBendFace);
cvxGetEnts("[curves]Select curves on sheet metal, <middle click> when done", VX_INP_CURVE, 1, &fold.CrvCnts, &fold.idCrv);
/* fold shape */
int idSmd = 0;
if (cvxPartSmdFold(&fold, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdFold: failed to fold shape!");
/* free memory */
cvxMemFree((void**)&fold.idBendFace);
cvxMemFree((void**)&fold.idCrv);
}
void zwTestPartSmdDimple()
/*
DESCRIPTION:
Test case for function cvxPartSmdDimpleInit and cvxPartSmdDimple.
*/
{
/* initialize data */
svxDimpleData dimple = {};
if (cvxPartSmdDimpleInit(&dimple))
zwTestLogErrorMsg(5, "cvxPartSmdDimpleInit: failed to initialize dimple data!");
double val = 0.0;
cvxGetNumber("[dimple type]Select dimple type (0-Plain Dimple, 1-Flared Hole)", &val);
dimple.dimpleType = int(val + 0.5);
cvxGetEnt("[plane]Select planar face for dimple placement", VX_INP_FACE, 0, &dimple.idPlane);
cvxGetEnt("[sketch]Select a sketch", VX_INP_SKETCH, 0, &dimple.idProfile);
/* optional input */
cvxGetEnts("[shapes]Select shapes to sew, <middle click> when done", VX_INP_SHAPE, 1, &dimple.numShapes, &dimple.idShapes);
cvxGetNumber("[H]specify height measured from the selected face to the outside face of the dimple (6 as default)", &dimple.height);
cvxGetNumber("[A]specify the side angle measured from the selected face (90 as default)", &dimple.angle);
cvxGetNumber("[R1]specify inner radius around the perimeter height of the dimple (1 as default)", &dimple.radius1);
cvxGetNumber("[R2]specify outer radius around the perimeter of the dimple and tangent to the selected face (1 as default)", &dimple.radius2);
if (dimple.dimpleType == 0)
cvxGetNumber("[R3]specify the outer fillet radius of the outside wall (default:1.0, 0.0-disable)", &dimple.radius3);
cvxGetNumber("[Flip the flanges]whether to flip the normal direction of the plane where the dimple is placed (1-yes, 0-no)", &val);
dimple.flipFlange = int(val + 0.5);
cvxGetNumber("[Profile on dimple top]1-the top of the dimple is the size of the outline, 0-the bottom of the dimple is the size of the contour", &val);
dimple.prfOnDimpleTop = int(val + 0.5);
if (dimple.dimpleType == 0)
cvxGetNumber("[Position]select position type (0-material outside, 1-material inside, 2-bend outside)", &val);
else
cvxGetNumber("[Position]select position type (0-material outside, 1-material inside)", &val);
dimple.postion = (evxDimplePostion)(int)(val + 0.5);
strcpy_s(dimple.ftrName, "dimpleName");
/* dimple shape */
int idSmd = 0;
if (cvxPartSmdDimple(&dimple, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdDimple: failed to dimple shape!");
/* free memory */
cvxMemFree((void**)&dimple.idShapes);
}
void zwTestPartSmdCloseCorner()
/*
DESCRIPTION:
Test case for function cvxPartSmdCloseCorner.
*/
{
/* select close corner type */
svxCloseCornerData corner = {};
double val = 0.0;
cvxGetNumber("select close corner type (0-close by edge, 1-close by bend face)", &val);
corner.type = int(val + 0.5);
/* initialize data */
if (cvxPartSmdCloseCornerInit(corner.type, &corner))
zwTestLogErrorMsg(5, "cvxPartSmdCloseCornerInit: failed to initialize dimple data!");
if (corner.type == 0)
{
cvxGetPoint("[edge]Select first face edge", VX_INP_PNT_ON_EDGE, 0,
&corner.cornerData.byEdge.Edg1Pnt.pnt, &corner.cornerData.byEdge.Edg1Pnt.idEnt);
cvxGetPoint("[edge]Select second face edge", VX_INP_PNT_ON_EDGE, 0,
&corner.cornerData.byEdge.Edg2Pnt.pnt, &corner.cornerData.byEdge.Edg2Pnt.idEnt);
}
else
{
cvxGetEnt("[face]Select first bend face", VX_INP_FACE, 0, &corner.cornerData.byFace.idBend1);
cvxGetEnt("[face]Select second bend face", VX_INP_FACE, 0, &corner.cornerData.byFace.idBend2);
cvxGetNumber("[Close the whole flange]Whether to close the whole flange (1-yes, 0-no)", &val); /* 1 as default */
corner.cornerData.byFace.CloseFlange = int(val + 0.5);
cvxGetNumber("[Miter corner]Whether to miter corner (1-yes, 0-no)", &val); /* 1 as default */
corner.cornerData.byFace.Miter = int(val + 0.5);
cvxGetNumber("[Relief]Select corner relief type (0-closed, 1-circular cutout, 2-rectangular cutout, 3-U cutout, 4-V cutout)", &val);
corner.cornerData.byFace.Relief = (evxCornerReliefTyp)int(val + 0.5);
switch (corner.cornerData.byFace.Relief)
{
case VX_CORNER_CIRCL_CUTOUT:
corner.cornerData.byFace.OrgType = 1;
corner.cornerData.byFace.dOffset = 0;
corner.cornerData.byFace.dDiam = 4;
break;
case VX_CORNER_RECT_CUTOUT:
corner.cornerData.byFace.OrgType = 1;
corner.cornerData.byFace.dOffset = 0;
corner.cornerData.byFace.dLength = 4;
corner.cornerData.byFace.dWidth = 4;
break;
case VX_CORNER_U_CUTOUT:
corner.cornerData.byFace.OrgType = 1;
corner.cornerData.byFace.dOffset = 0;
corner.cornerData.byFace.dDiam = 4;
break;
case VX_CORNER_V_CUTOUT:
corner.cornerData.byFace.OrgType = 1;
corner.cornerData.byFace.dOffset = 0;
corner.cornerData.byFace.dDiam = 4;
corner.cornerData.byFace.dAng1 = 30;
corner.cornerData.byFace.dAng2 = 30;
break;
default:
break;
}
}
cvxGetNumber("[Overlap]Select overlap type (0-underlap, 1-overlap, 2-natural)", &val);
corner.Overlp = (evxCornerOverlapTyp)int(val + 0.5);
cvxGetNumber("[Gap]Specify gap for close corner (0.1 as default)", &corner.dGap);
/* close corner */
int idSmd = 0;
if (cvxPartSmdCloseCorner(&corner, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdCloseCorner: failed to close corner!");
}
void zwTestPartSmdLouver()
/*
DESCRIPTION:
Test case for function cvxPartSmdLouver.
*/
{
/* initialize data */
svxLouverData louver = {};
if (cvxPartSmdLouverInit(&louver))
zwTestLogErrorMsg(5, "cvxPartSmdLouverInit: failed to initialize louver data!");
cvxGetEnt("[plane]Select planar face for louver placement", VX_INP_FACE, 0, &louver.idPlane);
cvxGetEnt("[sketch]Select a sketch", VX_INP_SKETCH, 0, &louver.idProf);
cvxGetEnts("[shapes]Select shapes to sew, <middle click> when done", VX_INP_SHAPE, 1, &louver.cntSew, &louver.pSewShape);
cvxGetNumber("[H]Specify louver height (3.0mm as default)", &louver.dHeight);
cvxGetNumber("[A]Specify louver angle (45deg as default)", &louver.dAng);
cvxGetNumber("[R1]Specify 1st louver radius (1.0mm as default)", &louver.dR1);
cvxGetNumber("[R2]Specify 2nd louver radius (1.0mm as default)", &louver.dR2);
cvxGetNumber("[W]Specify louver width (6.0mm as default)", &louver.dWidth);
double val = 0.0;
cvxGetNumber("[Flip louver 180 degrees]Whether to flip the louver 180 degrees about the sketch line(0-no, 1-yes)", &val);
louver.Flip = int(val + 0.5);
/* add louver */
int idSmd = 0;
if (cvxPartSmdLouver(&louver, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdLouver: failed to add louver!");
/* free memory */
cvxMemFree((void**)&louver.pSewShape);
}
void zwTestPartSmdNormalCut()
/*
DESCRIPTION:
Test case for function cvxPartSmdNormalCut.
*/
{
/* initialize data */
svxNormalCutData normalCut = {};
if (cvxPartSmdNormalCutinit(&normalCut))
zwTestLogErrorMsg(5, "cvxPartSmdNormalCutinit: failed to initialize normal cut data!");
double val = 0.0;
cvxGetNumber("select normal cut option (0-normal to both sides, 1-normal to middle)", &val);
normalCut.cutType = (evxNormCutTyp)int(val + 0.5);
cvxGetEnt("[Profile]Select a profile to project", VX_INP_PROF, 0, &normalCut.idProfile);
cvxGetEnts("[Shapes]Select sheet metal models to be created the normal cutout, <middle click> to finish", VX_INP_SHAPE, 0, &normalCut.cntShape, &normalCut.shapeList);
cvxGetNumber("[Extrude type]Specify the extrude type (0-one side, 1-two side, 2-symmetrical)", &val);
normalCut.extType = (evxExtrudeType)int(val + 0.5);
svxPoint startPnt = {}, endPnt = {};
switch (normalCut.extType)
{
case VX_EXTRUDE_TYPE_TWOSIDE:
cvxGetNumber("[Start S]Select start type (0-input value, 1-through all, 2-to point, 5-to face)", &val);
normalCut.startType = (evxDistanceMethod)int(val + 0.5);
switch (normalCut.startType)
{
case VX_INPU_VALUE:
cvxGetNumber("[Start S]Specify start distance", &normalCut.dStart);
break;
case VX_BY_THROUGH_ALL:
break;
case VX_TO_POINT:
cvxGetPoint("[Start S]Select start point", VX_INP_PNT_GENERAL, 0, &startPnt, &normalCut.idStartEnt);
normalCut.startToPnt = &startPnt;
break;
case VX_TO_FACE:
cvxGetEnt("[Start S]Select bounding face", VX_INP_FACE, 0, &normalCut.idStartEnt);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdNormalCut: invalid option!");
break;
}
case VX_EXTRUDE_TYPE_ONESIDE:
case VX_EXTRUDE_TYPE_SYMMETRICAL:
cvxGetNumber("[End E]Select end type (0-input value, 1-through all, 2-to point, 5-to face)", &val);
normalCut.endType = (evxDistanceMethod)int(val + 0.5);
switch (normalCut.endType)
{
case VX_INPU_VALUE:
cvxGetNumber("[End E]Specify end distance", &normalCut.dEnd);
break;
case VX_BY_THROUGH_ALL:
break;
case VX_TO_POINT:
cvxGetPoint("[End E]Select end point", VX_INP_PNT_GENERAL, 0, &endPnt, &normalCut.idEndEnt);
normalCut.endToPnt = &endPnt;
break;
case VX_TO_FACE:
cvxGetEnt("[End E]Select bounding face", VX_INP_FACE, 0, &normalCut.idEndEnt);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdNormalCut: invalid option!");
break;
}
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdNormalCut: invalid option!");
break;
}
svxVector direction = {};
cvxGetPoint("[Direction]select direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&direction, nullptr);
normalCut.Dir = &direction;
cvxGetNumber("[Flip]Whether to cut the opposite side of the sheet metal model (1-yes, 0-no)", &val);
normalCut.Flip = int(val + 0.5);
/* create normal cut */
int numShapes = 0, *idShapes = nullptr;
if (cvxPartSmdNormalCut(&normalCut, &numShapes, &idShapes) || numShapes == 0)
zwTestLogErrorMsg(5, "cvxPartSmdNormalCut: failed to create normal cut!");
/* free memory */
cvxMemFree((void**)&normalCut.shapeList);
cvxMemFree((void**)&idShapes);
}
void zwTestPartSmdPunch()
/*
DESCRIPTION:
Test case for function cvxPartSmdPunch.
*/
{
/* initialize data */
svxPunchData punch = {};
if (cvxPartSmdPunchInit(&punch))
zwTestLogErrorMsg(5, "cvxPartSmdPunchInit: failed to initialize punch data!");
double val = 0.0;
cvxGetNumber("Select punch type (0-punch from shape, 1-punch from file)", &val);
punch.punchTyp = (evxPunchTyp)int(val + 0.5);
cvxGetEnt("[Base]Select boundary face on base", VX_INP_FACE, 0, &punch.idBase);
if (punch.punchTyp == VX_PUNCH_SHAPE)
{
cvxGetEnt("[Punch P]Select a punch shape", VX_INP_SHAPE, 0, &punch.idPunch);
cvxGetEnts("[Open O]Select open faces from punch shape, <middle click> to finish", VX_INP_FACE, 1, &punch.cntOpen, &punch.pOpenList);
}
else
{
cvxGetNumber("Select file to insert(1: yes; 0: no)", &val);
if (int(val + 0.5))
{
vxLongPath workDir = "\0";
cvxConfigGetString("Z3.Archive", workDir, sizeof(workDir));
cvxGetFileByLongPath(1, "Select the file for punch...", workDir, "Part(*.Z3PRT)|*.Z3PRT|", punch.pathPunch, sizeof(punch.pathPunch));
}
else
{
vxLongName actFile = "\0";
cvxFileInqActive(actFile, sizeof(actFile));
int nFiles = 0;
vxLongPath* fileList = NULL;
cvxFileOpenListByLongPath(&nFiles, &fileList);
for (int i = 0; i < nFiles; i++)
{
char* ch = strrchr(fileList[i], '.');
if (_strcmpi(actFile, fileList[i]) && !_strcmpi(ch + 1, "Z3PRT"))
{
strcpy_s(punch.pathPunch, sizeof(punch.pathPunch), fileList[i]);
break;
}
}
cvxMemFree((void**)&fileList);
}
if (punch.pathPunch[0] == '\0')
{
zwTestLogErrorMsg(5, "zwTestPartSmdPunch: punch file not specified!");
return;
}
cvxGetNumber("[Location type]Select location type (0-point, 1-constraint)", &val);
cvxGetPoint("Specify punch point, <middle-click> to ignore", VX_INP_PNT_GENERAL, 1, &punch.localPnt, nullptr);
punch.locTyp = (evxPunchLocType)int(val + 0.5);
if (punch.locTyp == VX_LOCATION_POINT)
{
cvxGetEnt("Specify insertion plane", VX_INP_DATUM_PLANE, 1, &punch.locData.byPnt.idFrame);
}
else
{
punch.locData.byCons.cntCons = 1;
cvxMemAlloc(sizeof(svxPunchCons), (void**)&punch.locData.byCons.punchCons);
cvxMemZero((void*)punch.locData.byCons.punchCons, sizeof(svxPunchCons));
punch.locData.byCons.punchCons->alignTyp = VX_COINCIDENT;
/* existing entity */
punch.locData.byCons.punchCons->pathEnt1 = { 2, -1 };
cvxGetEnt("[1st entity]Select a face", VX_INP_FACE, 0, &punch.locData.byCons.punchCons->pathEnt1.Id[1]);
punch.locData.byCons.punchCons->ent1FormFile = 0;
/* entity from file */
punch.locData.byCons.punchCons->pathEnt2 = { 2, -1, 234 };
punch.locData.byCons.punchCons->ent2FormFile = 1;
punch.locData.byCons.punchCons->dOffset = 0;
punch.locData.byCons.punchCons->Flip = 0;
}
punch.cntOpen = 1;
cvxMemAlloc(sizeof(int), (void**)&punch.pOpenList);
punch.pOpenList[0] = 238;
cvxGetNumber("[Related with source]Whether the punch result changes as the punch in source changes (1-yes, 0-no)", &val); /* 1 as default */
punch.relation = int(val + 0.5);
}
cvxGetNumber("[Fillet placement edges]Whether to fillet placement edges (1-yes, 0-no)", &val);
punch.addFillet = int(val + 0.5);
if (punch.addFillet)
cvxGetNumber("[Radius]Specify radius (5 as default)", &punch.dRadius);
cvxGetNumber("[Fillet non-placement edges]Whether to fillet non-placement edges (1-yes, 0-no)", &val);
punch.addFillet2 = int(val + 0.5);
if (punch.addFillet2)
cvxGetNumber("[Radius]Specify radius (5 as default)", &punch.dRadius2);
/* perform punch */
int idShape = 0;
if (cvxPartSmdPunch(&punch, &idShape) || idShape == 0)
zwTestLogErrorMsg(5, "cvxPartSmdPunch: failed to perform punch!");
/* free memory */
if (punch.punchTyp == VX_PUNCH_FILE)
cvxMemFree((void**)&punch.pOpenList);
if (punch.locTyp == VX_LOCATION_CONSTRAINT)
cvxMemFree((void**)&punch.locData.byCons.punchCons);
cvxMemFree((void**)&punch.pOpenList);
}
void zwTestPartSmdExtrudeTab()
/*
DESCRIPTION:
Test case for function cvxPartSmdExtrudeTab.
*/
{
/* initialize data */
svxSmdExtrudeTabData extrudeTab = {};
if (cvxPartSmdExtrudeTabInit(&extrudeTab))
zwTestLogErrorMsg(5, "cvxPartSmdExtrudeTabInit: failed to initialize extrude tab data!");
cvxGetEnt("[Profile]Select a profile to make extrude flange", VX_INP_PROF, 0, &extrudeTab.idProfile);
double thickmess = 0.0;
cvxGetNumber("[Thickness]Specify thickness", &thickmess);
extrudeTab.Thickness = &thickmess;
double val = 0.0;
cvxGetNumber("[Merge with base]Whether to merge with base (1-yes, 0-no)", &val);
extrudeTab.isMerge = int(val + 0.5);
if (extrudeTab.isMerge)
cvxGetEnt("[Merge with base]Select a shape to merge", VX_INP_SHAPE, 0, &extrudeTab.idMergeShape);
cvxGetNumber("[Opposite]Whether to opposite the direction of tab (1-yes, 0-no)", &val);
extrudeTab.isOpposite = int(val + 0.5);
/* extrude base tab */
int idSmd = 0;
if (cvxPartSmdExtrudeTab(&extrudeTab, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdExtrudeTab: failed to extrude base tab!");
}
void zwTestPartSmdExtrudeFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdExtrudeFlange.
*/
{
/* initialize data */
svxExtrudeFlangeData extrudeFlange = {};
if (cvxPartSmdExtrudeFlangeinit(&extrudeFlange))
zwTestLogErrorMsg(5, "cvxPartSmdExtrudeFlangeinit: failed to initialize extrude flange data!");
cvxGetEnt("[Profile]Select a profile to make extrude flange", VX_INP_PROF, 0, &extrudeFlange.idProfile);
double val = 0.0;
cvxGetNumber("[Extrude type]Select extrude type (0-one side, 1-two sides, 2-symmetrical)", &val);
extrudeFlange.extType = (evxExtFlangeType)int(val + 0.5);
switch (extrudeFlange.extType)
{
case VX_EXTFLANGE_2SIDES:
cvxGetNumber("[Start]Specify start distance", &extrudeFlange.start);
case VX_EXTFLANGE_1SIDE:
case VX_EXTFLANGE_SYMMETRICAL:
cvxGetNumber("[End]Specify end distance", &extrudeFlange.end);
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdExtrudeFlange: invalid option!");
break;
}
double thickness = 0.0;
cvxGetNumber("[Thickness]specify thickness", &thickness);
extrudeFlange.thickness = &thickness;
cvxGetNumber("[Opposite]Whether opposite the direction of flange (1-yes, 0-no)", &val);
extrudeFlange.isOpposite = int(val + 0.5);
double radius = 0.0;
cvxGetNumber("[Radius]Specify radius", &radius);
extrudeFlange.radius = &radius;
evxSmdKFactorType kType = VX_SMD_KTYPE_CUSTOM;
double kValue = 0.41;
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
if (int(val + 0.5) == 0)
{
extrudeFlange.kType = &kType;
extrudeFlange.kValue = &kValue;
}
svxPntOnEnt pntOnCrv = {};
cvxGetNumber("Whether to set rip (1-yes, 0-no)", &val);
if (int(val + 0.5))
{
cvxGetPoint("[Point]Select a point to set rip", VX_INP_PNT_ON_CURVE, 0, &pntOnCrv.pnt, &pntOnCrv.idEnt);
extrudeFlange.PntOnCrv = &pntOnCrv;
cvxGetNumber("[Rip size]Specify rip size", &extrudeFlange.RipSize);
double tol = 0.0;
cvxGlobalGet(VX_TOLERANCE, &tol);
if (extrudeFlange.RipSize < 2 * tol)
extrudeFlange.RipSize = 2 * tol;
}
/* create flange */
int idSmd = 0;
if (cvxPartSmdExtrudeFlange(&extrudeFlange, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdExtrudeFlange: failed to create flange!");
}
void zwTestPartSmdFullFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdFullFlange.
*/
{
/* initialize data */
svxSmdFullFlangeData fullFlange = {};
if (cvxPartSmdFullFlangeInit(&fullFlange))
zwTestLogErrorMsg(5, "cvxPartSmdFullFlangeInit: failed to initialize full flange data!");
cvxGetEnts("[Edges]Select inner edges, <middle click to finish>", VX_INP_EDGE, 0, &fullFlange.count, &fullFlange.idEdges);
double val = 0.0;
cvxGetNumber("[Flip the flanges]Whether to flip the flanges (1-yes, 0-no)", &val);
fullFlange.isFlip = int(val + 0.5);
/* Flange Parameters */
cvxGetNumber("[Position]Enter number to switch position(0-Material inside, 1-Material outside, 2-Natural, 3-Offset, 4-Virtual sharp)", &val);
evxSmdPosition position = (evxSmdPosition)int(val + 0.5);
fullFlange.position = &position;
double offset = 0;
if (*fullFlange.position == VX_POSITION_OFFSET)
{
cvxGetNumber("[Offset]Specify offset", &offset);
fullFlange.offset = &offset;
}
/* K-factor definition */
evxSmdKFactorType kType = VX_SMD_KTYPE_CUSTOM;
double kValue = 0.41;
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
if (int(val + 0.5) == 0)
{
fullFlange.kType = &kType;
fullFlange.kValue = &kValue;
}
/* Settings */
double tol = 0.0;
cvxGlobalGet(VX_TOLERANCE, &tol);
fullFlange.tol = &tol;
cvxGetNumber("[Resolve flange interference]Whether to resolve flange interference (1-yes, 0-no)", &val);
fullFlange.isResolve = int(val + 0.5);
if (fullFlange.isResolve)
cvxGetNumber("[Gap]Specify gap distance (0.5 as default)", &fullFlange.gap);
/* Bend Attributes */
cvxGetNumber("[Bend]Select bend type (0-Simple, 1-S bend)", &val);
fullFlange.bend = int(val + 0.5);
double radius1 = 5.0, radius2 = 5.0, length = 0.0;
cvxGetNumber("[Radius R1]Specify radius R1", &radius1);
fullFlange.radius1 = &radius1;
if (fullFlange.bend == 1)
{
cvxGetNumber("[Radius R2]Specify radius R2", &radius2);
fullFlange.radius2 = &radius2;
}
cvxGetNumber("[Angle]Specify angle (90 as default)", &fullFlange.angle);
if (fullFlange.bend == 0)
cvxGetNumber("[Length type]Select length type (0-Standard length, 1-Outer height, 2-Inner height, 3-extrapolated length)", &val);
else
cvxGetNumber("[Length type]Select length type (0-Standard length, 3-extrapolated length)", &val);
evxSmdBendLengthType bendLengthType = (evxSmdBendLengthType)int(val + 0.5);
fullFlange.lengthType = &bendLengthType;
cvxGetNumber("[Length]Specify flange length", &length);
fullFlange.length = &length;
if (fullFlange.bend == 1)
{
cvxGetNumber("[S bend size]Select S bend size (0-Height, 1-Length)", &val);
fullFlange.sBendSize = int(val + 0.5);
if (fullFlange.sBendSize == 0)
cvxGetNumber("[Height]Specify the height of S bend type (12 as default)", &fullFlange.Size);
else
cvxGetNumber("[Length]Specify the length of S bend type (12 as default)", &fullFlange.Size);
}
/* Relief */
cvxGetNumber("[Define each side separately]Whether to define each side separately (1-yes, 0-no)", &val);
fullFlange.isDefSepa = int(val + 0.5);
svxSmdReliefData startRelief = {}, endRelief = {};
cvxPartSmdReliefDataInit(&startRelief);
cvxPartSmdReliefDataInit(&endRelief);
/* relief of start */
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
startRelief.relief = (evxSmdRelief)int(val + 0.5);
if (startRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
startRelief.isWidthRatio = int(val + 0.5);
if (startRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &startRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &startRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
startRelief.isDepthRatio = int(val + 0.5);
if (startRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &startRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &startRelief.ReliefDepth);
}
fullFlange.startRelief = &startRelief;
/* relief of end */
if (fullFlange.isDefSepa == 1)
{
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
endRelief.relief = (evxSmdRelief)int(val + 0.5);
if (endRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
endRelief.isWidthRatio = int(val + 0.5);
if (endRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &endRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &endRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
endRelief.isDepthRatio = int(val + 0.5);
if (endRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &endRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &endRelief.ReliefDepth);
}
fullFlange.endRelief = &endRelief;
}
/* corner contributes */
int isCorner = 0, isMiter = 0, corOrigin = 0;
double corGap = 0.0, corOffset = 0.0, corLength = 0.0, corWidth = 0.0, corDiameter = 0.0, corAngle1 = 0.0, corAngle2 = 0.0;
evxSmdCornerRelief cornerRelief = VX_CORNER_RELIEF_CLOSED;
cvxGetNumber("[Close corner]Whether to close corner (1-yes, 0-no)", &val);
isCorner = int(val + 0.5);
fullFlange.isCorner = &isCorner;
if (*fullFlange.isCorner == 1)
{
cvxGetNumber("[Miter corner]Whether to miter corner (1-yes, 0-no)", &val);
isMiter = int(val + 0.5);
fullFlange.isMiter = &isMiter;
cvxGetNumber("[Relief]Select corner relief type (0-closed, 1-circular cutout, 2-rectangular cutout, 3-U cutout, 4-V-cutout)", &val);
cornerRelief = (evxSmdCornerRelief)int(val + 0.5);
fullFlange.corRelief = &cornerRelief;
cvxGetNumber("[Gap]Specify gap for close corner", &corGap);
fullFlange.corGap = &corGap;
switch (*fullFlange.corRelief)
{
case VX_CORNER_RELIEF_CLOSED:
break;
case VX_CORNER_RELIEF_CIRCULAR_CUTOUT:
case VX_CORNER_RELIEF_U_CUTOUT:
cvxGetNumber("[Origin]0-bend center, 1-corner point", &val);
corOrigin = int(val + 0.5);
fullFlange.corOrigin = &corOrigin;
cvxGetNumber("[Offset]Specify offset distance for origin", &corOffset);
fullFlange.corOffset = &corOffset;
cvxGetNumber("[Diameter]Specify diameter", &corDiameter);
fullFlange.corDiameter = &corDiameter;
break;
case VX_CORNER_RELIEF_RECTANGULAR_CUTOUT:
cvxGetNumber("[Origin]0-bend center, 1-corner point", &val);
corOrigin = int(val + 0.5);
fullFlange.corOrigin = &corOrigin;
cvxGetNumber("[Offset]Specify offset distance for origin", &corOffset);
fullFlange.corOffset = &corOffset;
cvxGetNumber("[Length]Specify length for rectangular cut", &corLength);
fullFlange.corLength = &corLength;
cvxGetNumber("[Width]Specify width for rectangular cut", &corWidth);
fullFlange.corWidth = &corWidth;
break;
case VX_CORNER_RELIEF_V_CUTOUT:
cvxGetNumber("[Origin]0-bend center, 1-corner point", &val);
corOrigin = int(val + 0.5);
fullFlange.corOrigin = &corOrigin;
cvxGetNumber("[Offset]Specify offset distance for origin", &corOffset);
fullFlange.corOffset = &corOffset;
cvxGetNumber("[Diameter]Specify diameter", &corDiameter);
fullFlange.corDiameter = &corDiameter;
cvxGetNumber("[Angle 1]Specify first angle for V cut", &corAngle1);
fullFlange.corAngle1 = &corAngle1;
cvxGetNumber("[Angle 2]Specify second angle for V cut", &corAngle2);
fullFlange.corAngle2 = &corAngle2;
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdFullFlange: invalid option!");
break;
}
}
/* create full flange */
int idSmd = 0;
if (cvxPartSmdFullFlange(&fullFlange, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdFullFlange: failed to create full flange!");
/* free memory */
cvxMemFree((void**)&fullFlange.idEdges);
}
void zwTestPartSmdProfFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdProfFlange.
*/
{
/* initialize data */
svxSmdFlangeProfData flangeProf = {};
if (cvxPartSmdProfFlangeInit(&flangeProf))
zwTestLogErrorMsg(5, "cvxPartSmdProfFlangeInit: failed to initialize flange with profile data!");
cvxGetEnt("[Edge]Select inner edge", VX_INP_EDGE, 0, &flangeProf.idEdge);
int idProf = 0;
cvxGetEnt("Select a profile, <middle click> to ignore", VX_INP_SKETCH, 1, &idProf);
if (idProf > 0)
flangeProf.idProfile = &idProf;
/* Flange Parameters */
double val = 0.0;
cvxGetNumber("[Position]Enter number to switch position(0-Material inside, 1-Material outside, 2-Natural, 3-Offset, 4-Virtual sharp)", &val);
evxSmdPosition position = (evxSmdPosition)int(val + 0.5);
flangeProf.position = &position;
double offset = 0;
if (*flangeProf.position == VX_POSITION_OFFSET)
{
cvxGetNumber("[Offset]Specify offset", &offset);
flangeProf.offset = &offset;
}
/* Bend Attributes */
double radius = 0.0, length = 0.0;
cvxGetNumber("[Radius]Specify radius", &radius);
flangeProf.radius = &radius;
cvxGetNumber("[Angle]Specify angle (90 as default)", &flangeProf.angle);
cvxGetNumber("[Length type]Select length type (0-Standard length, 1-Outer height, 2-Inner height, 3-extrapolated length)", &val);
evxSmdBendLengthType bendLengthType = (evxSmdBendLengthType)int(val + 0.5);
flangeProf.lengthType = &bendLengthType;
cvxGetNumber("[Length]Specify flange length", &length);
flangeProf.length = &length;
/* K-factor definition */
evxSmdKFactorType kType = VX_SMD_KTYPE_CUSTOM;
double kValue = 0.41;
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
if (int(val + 0.5) == 0)
{
flangeProf.kType = &kType;
flangeProf.kValue = &kValue;
}
/* Relief */
cvxGetNumber("[Relief for insufficient length]Whether to create relief for insufficient length (1-yes, 0-no)", &val);
flangeProf.isRelief = int(val + 0.5);
cvxGetNumber("[Define each side separately]Whether to define each side separately (1-yes, 0-no)", &val);
flangeProf.isDefSepa = int(val + 0.5);
svxSmdReliefData startRelief = {}, endRelief = {};
cvxPartSmdReliefDataInit(&startRelief);
cvxPartSmdReliefDataInit(&endRelief);
/* relief of start */
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
startRelief.relief = (evxSmdRelief)int(val + 0.5);
if (startRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
startRelief.isWidthRatio = int(val + 0.5);
if (startRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &startRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &startRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
startRelief.isDepthRatio = int(val + 0.5);
if (startRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &startRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &startRelief.ReliefDepth);
}
flangeProf.startRelief = &startRelief;
/* relief of end */
if (flangeProf.isDefSepa == 1)
{
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
endRelief.relief = (evxSmdRelief)int(val + 0.5);
if (endRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
endRelief.isWidthRatio = int(val + 0.5);
if (endRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &endRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &endRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
endRelief.isDepthRatio = int(val + 0.5);
if (endRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &endRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &endRelief.ReliefDepth);
}
flangeProf.endRelief = &endRelief;
}
/* Settings */
double tol = 0.0;
cvxGlobalGet(VX_TOLERANCE, &tol);
flangeProf.tol = &tol;
/* create flange with profile */
int idSmd = 0;
if (cvxPartSmdProfFlange(&flangeProf, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdProfFlange: failed to create flange with profile!");
}
void zwTestPartSmdPartialFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdPartialFlange.
*/
{
/* initialize data */
svxSmdPartialFlangeData partialFlange = {};
if (cvxPartSmdPartialFlangeInit(&partialFlange))
zwTestLogErrorMsg(5, "cvxPartSmdPartialFlangeInit: failed to initialize partial flange data!");
cvxGetEnt("[Edge]Select end points on inner edge", VX_INP_EDGE, 0, &partialFlange.idEdge);
double val = 0.0;
cvxGetNumber("Whether to switch start point (1-yes, 0-no)", &val);
partialFlange.isRevert = int(val + 0.5);
cvxGetNumber("[Flip the flange]Whether to flip the flange (1-yes, 0-no)", &val);
partialFlange.isFlip = int(val + 0.5);
cvxGetNumber("[Width type]Select width type (0=Start-Width, 1=Start-End)", &val);
partialFlange.widthType = int(val + 0.5);
cvxGetNumber("[Start]Set the distance away from the start point of the edge (5 as default)", &partialFlange.start);
if (partialFlange.widthType == 0)
cvxGetNumber("[Width]Set the width of flange (5 as default)", &partialFlange.width);
else
cvxGetNumber("[End]Set the distance away from the end point of the edge (20 as default)", &partialFlange.end);
/* Flange Parameters */
cvxGetNumber("[Position]Enter number to switch position(0-Material inside, 1-Material outside, 2-Natural, 3-Offset, 4-Virtual sharp)", &val);
evxSmdPosition position = (evxSmdPosition)int(val + 0.5);
partialFlange.position = &position;
double offset = 0;
if (*partialFlange.position == VX_POSITION_OFFSET)
{
cvxGetNumber("[Offset]Specify offset", &offset);
partialFlange.offset = &offset;
}
/* Bend Attributes */
cvxGetNumber("[Bend]Select bend type (0-Simple, 1-S bend)", &val);
partialFlange.bend = int(val + 0.5);
double radius1 = 5.0, radius2 = 5.0, length = 0.0;
cvxGetNumber("[Radius R1]Specify radius R1", &radius1);
partialFlange.radius1 = &radius1;
if (partialFlange.bend == 1)
{
cvxGetNumber("[Radius R2]Specify radius R2", &radius2);
partialFlange.radius2 = &radius2;
}
cvxGetNumber("[Angle]Specify angle (90 as default)", &partialFlange.angle);
if (partialFlange.bend == 0)
cvxGetNumber("[Length type]Select length type (0-Standard length, 1-Outer height, 2-Inner height, 3-extrapolated length)", &val);
else
cvxGetNumber("[Length type]Select length type (0-Standard length, 3-extrapolated length)", &val);
evxSmdBendLengthType bendLengthType = (evxSmdBendLengthType)int(val + 0.5);
partialFlange.lengthType = &bendLengthType;
cvxGetNumber("[Length]Specify flange length", &length);
partialFlange.length = &length;
if (partialFlange.bend == 1)
{
cvxGetNumber("[S bend size]Select S bend size (0-Height, 1-Length)", &val);
partialFlange.sBendSize = int(val + 0.5);
if (partialFlange.sBendSize == 0)
cvxGetNumber("[Height]Specify the height of S bend type (12 as default)", &partialFlange.Size);
else
cvxGetNumber("[Length]Specify the length of S bend type (12 as default)", &partialFlange.Size);
}
/* K-factor definition */
evxSmdKFactorType kType = VX_SMD_KTYPE_CUSTOM;
double kValue = 0.41;
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
if (int(val + 0.5) == 0)
{
partialFlange.kType = &kType;
partialFlange.kValue = &kValue;
}
/* Relief */
cvxGetNumber("[Relief for insufficient length]Whether to create relief for insufficient length (1-yes, 0-no)", &val);
partialFlange.isRelief = int(val + 0.5);
cvxGetNumber("[Define each side separately]Whether to define each side separately (1-yes, 0-no)", &val);
partialFlange.isDefSepa = int(val + 0.5);
svxSmdReliefData startRelief = {}, endRelief = {};
cvxPartSmdReliefDataInit(&startRelief);
cvxPartSmdReliefDataInit(&endRelief);
/* relief of start */
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
startRelief.relief = (evxSmdRelief)int(val + 0.5);
if (startRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
startRelief.isWidthRatio = int(val + 0.5);
if (startRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &startRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &startRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
startRelief.isDepthRatio = int(val + 0.5);
if (startRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &startRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &startRelief.ReliefDepth);
}
partialFlange.startRelief = &startRelief;
/* relief of end */
if (partialFlange.isDefSepa == 1)
{
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
endRelief.relief = (evxSmdRelief)int(val + 0.5);
if (endRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
endRelief.isWidthRatio = int(val + 0.5);
if (endRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &endRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &endRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
endRelief.isDepthRatio = int(val + 0.5);
if (endRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &endRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &endRelief.ReliefDepth);
}
partialFlange.endRelief = &endRelief;
}
/* Settings */
double tol = 0.0;
cvxGlobalGet(VX_TOLERANCE, &tol);
partialFlange.tol = &tol;
/* create partial flange */
int idSmd = 0;
if (cvxPartSmdPartialFlange(&partialFlange, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdPartialFlange: failed to create partial flange!");
}
void zwTestPartSmdHemFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdHemFlange.
*/
{
/* initialize data */
svxSmdHemFlangeData hemFlange = {};
double val = 0.0;
cvxGetNumber("Select hem type (0-full hem, 1-partial hem)", &val);
hemFlange.hemType = int(val + 0.5);
if (cvxPartSmdHemFlangeInit(hemFlange.hemType, &hemFlange))
zwTestLogErrorMsg(5, "cvxPartSmdHemFlangeInit: failed to initialize hem flange data!");
svxPntOnEnt startPnt = {}, endPnt = {}, widthPnt = {};
if (hemFlange.hemType == 0) /* full hem */
{
cvxGetEnts("[Edges]Select inner edges, <midlle click> to finish", VX_INP_EDGE, 0, &hemFlange.hemData.full.count, &hemFlange.hemData.full.idEdges);
cvxGetNumber("[Miter hem]Whether to miter hem (1-yes, 0-no)", &val);
hemFlange.hemData.full.isMiterHem = int(val + 0.5);
if (hemFlange.hemData.full.isMiterHem)
cvxGetNumber("[Miter gap size]Specify miter gap size (0.1 as default)", &hemFlange.hemData.full.gapSize);
}
else /* partial hem */
{
cvxGetEnt("[Edge]Select inner edge", VX_INP_EDGE, 0, &hemFlange.hemData.partial.idEdge);
cvxGetNumber("[Width type]Select width type (0=Start-Width, 1=Start-End)", &val);
hemFlange.hemData.partial.widthType = int(val + 0.5);
cvxGetNumber("0-use \"Dynamic Input\", 1-use \"To Point\"", &val);
if (int(val + 0.5) == 0) /* Dynamic Input */
{
if (hemFlange.hemData.partial.widthType == 0)
{
cvxGetNumber("[Start]Set the distance away from the start point of the edge (5 as default)", &hemFlange.hemData.partial.start);
cvxGetNumber("[Width]Set the width of flange (5 as default)", &hemFlange.hemData.partial.width);
}
else
{
cvxGetNumber("[Start]Set the distance away from the start point of the edge (5 as default)", &hemFlange.hemData.partial.start);
cvxGetNumber("[End]Set the distance away from the end point of the edge (20 as default)", &hemFlange.hemData.partial.end);
}
}
else /* To Point */
{
if (hemFlange.hemData.partial.widthType == 0)
{
cvxGetPoint("[Start]Select a point", VX_INP_PNT_GENERAL, 0, &startPnt.pnt, &startPnt.idEnt);
cvxGetPoint("[Width]Select a point", VX_INP_PNT_GENERAL, 0, &widthPnt.pnt, &widthPnt.idEnt);
hemFlange.hemData.partial.startPnt = &startPnt;
hemFlange.hemData.partial.widthPnt = &widthPnt;
}
else
{
cvxGetPoint("[Start]Select a point", VX_INP_PNT_GENERAL, 0, &startPnt.pnt, &startPnt.idEnt);
cvxGetPoint("[End]Select a point", VX_INP_PNT_GENERAL, 0, &endPnt.pnt, &endPnt.idEnt);
hemFlange.hemData.partial.startPnt = &startPnt;
hemFlange.hemData.partial.endPnt = &endPnt;
}
}
}
cvxGetNumber("[Flip the hems]Whether to flip the hems (1-yes, 0-no)", &val);
hemFlange.isFlip = int(val + 0.5);
/* Flange Parameters */
cvxGetNumber("[Position]Enter number to switch position(0-Material inside, 1-Material outside, 2-Natural, 3-Offset, 4-Virtual sharp)", &val);
evxSmdPosition position = (evxSmdPosition)int(val + 0.5);
hemFlange.position = &position;
double offset = 0;
if (*hemFlange.position == VX_POSITION_OFFSET)
{
cvxGetNumber("[Offset]Specify offset", &offset);
hemFlange.offset = &offset;
}
/* Bend Attributes */
cvxGetNumber("[Type]Select bend type (0-Closed, 1-Open, 2-Close loop, 3-Open loop, 4-Centered loop, 5-S bend, 6-Curl)", &val);
hemFlange.bendType = (evxSmdHemBendType)int(val + 0.5);
double radius1 = 5.0, radius2 = 5.0;
switch (hemFlange.bendType)
{
case VX_SMD_HEM_BEND_CLOSED:
cvxGetNumber("[Length L1]Specify hem length L1", &hemFlange.length1);
break;
case VX_SMD_HEM_BEND_OPEN:
case VX_SMD_HEM_BEND_CLOSEDLOOP:
cvxGetNumber("[Length L1]Specify hem length L1", &hemFlange.length1);
cvxGetNumber("[Radius R1]Specify inner bend face radius R1", &radius1);
hemFlange.radius1 = &radius1;
break;
case VX_SMD_HEM_BEND_OPENLOOP:
cvxGetNumber("[Radius R1]Specify inner bend face radius R1", &radius1);
hemFlange.radius1 = &radius1;
cvxGetNumber("[Angle A]Specify bend angle", &hemFlange.angle);
break;
case VX_SMD_HEM_BEND_CENTEREDLOOP:
cvxGetNumber("[Equal radii]1-yes, 0-no", &val);
hemFlange.isEqual = int(val + 0.5);
cvxGetNumber("[Radius R1]Specify inner bend face radius R1", &radius1);
hemFlange.radius1 = &radius1;
if (hemFlange.isEqual == 0)
{
cvxGetNumber("[Radius R2]Specify inner bend face radius R2", &radius2);
hemFlange.radius2 = &radius2;
}
cvxGetNumber("[Angle A]Specify bend angle", &hemFlange.angle);
break;
case VX_SMD_HEM_BEND_SBEND:
cvxGetNumber("[Equal radii]1-yes, 0-no", &val);
hemFlange.isEqual = int(val + 0.5);
cvxGetNumber("[Length L1]Specify hem length L1", &hemFlange.length1);
cvxGetNumber("[Length L2]Specify hem length L2", &hemFlange.length2);
cvxGetNumber("[Radius R1]Specify inner bend face radius R1", &radius1);
hemFlange.radius1 = &radius1;
if (hemFlange.isEqual == 0)
{
cvxGetNumber("[Radius R2]Specify inner bend face radius R2", &radius2);
hemFlange.radius2 = &radius2;
}
break;
case VX_SMD_HEM_BEND_CURL:
cvxGetNumber("[Length L1]Specify hem length L1", &hemFlange.length1);
cvxGetNumber("[Length L2]Specify hem length L2", &hemFlange.length2);
cvxGetNumber("[Radius R1]Specify inner bend face radius R1", &radius1);
hemFlange.radius1 = &radius1;
cvxGetNumber("[Radius R2]Specify inner bend face radius R2", &radius2);
hemFlange.radius2 = &radius2;
break;
default:
break;
}
/* K-factor definition */
evxSmdKFactorType kType = VX_SMD_KTYPE_CUSTOM;
double kValue = 0.41;
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
if (int(val + 0.5) == 0)
{
hemFlange.kType = &kType;
hemFlange.kValue = &kValue;
}
/* Relief */
if (hemFlange.hemType == 1)
{
cvxGetNumber("[Relief for insufficient length]Whether to create relief for insufficient length (1-yes, 0-no)", &val);
hemFlange.hemData.partial.isRelief = int(val + 0.5);
}
cvxGetNumber("[Define each side separately]Whether to define each side separately (1-yes, 0-no)", &val);
hemFlange.isDefSepa = int(val + 0.5);
svxSmdReliefData startRelief = {}, endRelief = {};
cvxPartSmdReliefDataInit(&startRelief);
cvxPartSmdReliefDataInit(&endRelief);
/* relief of start */
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
startRelief.relief = (evxSmdRelief)int(val + 0.5);
if (startRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
startRelief.isWidthRatio = int(val + 0.5);
if (startRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &startRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &startRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
startRelief.isDepthRatio = int(val + 0.5);
if (startRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &startRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &startRelief.ReliefDepth);
}
hemFlange.startRelief = &startRelief;
/* relief of end */
if (hemFlange.isDefSepa == 1)
{
cvxGetNumber("[Relief]Select relief type (0-Rectangle, 1-Obround, 2-None)", &val);
endRelief.relief = (evxSmdRelief)int(val + 0.5);
if (endRelief.relief != VX_RELIEF_NONE)
{
cvxGetNumber("[Relief width]1-relief width ratio, 2-relief width value", &val); /* 1 as default */
endRelief.isWidthRatio = int(val + 0.5);
if (endRelief.isWidthRatio == 1)
cvxGetNumber("[Ratio]Specify relief width ratio", &endRelief.ReliefWidth);
else
cvxGetNumber("[Value]Specify relief width value", &endRelief.ReliefWidth);
cvxGetNumber("[Relief depth]1-relief depth ratio, 2-relief depth value", &val);
endRelief.isDepthRatio = int(val + 0.5);
if (endRelief.isDepthRatio == 1)
cvxGetNumber("[Ratio]Specify relief depth ratio", &endRelief.ReliefDepth);
else
cvxGetNumber("[Value]Specify relief depth value", &endRelief.ReliefDepth);
}
hemFlange.endRelief = &endRelief;
}
/* create partial flange */
int idSmd = 0;
if (cvxPartSmdHemFlange(&hemFlange, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdHemFlange: failed to create hem flange!");
/* free memory */
if (hemFlange.hemType == 0)
cvxMemFree((void**)&hemFlange.hemData.full.idEdges);
}
void zwTestPartSmdStatFaceSet()
/*
DESCRIPTION:
Test case for function cvxPartSmdStatFaceSet.
*/
{
/* select a face */
int idFace = 0;
cvxGetEnt("[Face]Select a stationary face", VX_INP_FACE, 0, &idFace);
/* set the stationary face of a sheet metal part */
int idFtr = 0;
if (cvxPartSmdStatFaceSet(idFace, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartSmdStatFaceSet: failed to set the stationary face of a sheet metal part!");
}
void zwTestPartSmdJog()
/*
DESCRIPTION:
Test case for function cvxPartSmdJog.
*/
{
/* initialize data */
svxSmdJogData jog = {};
if (cvxPartSmdJogInit(&jog))
zwTestLogErrorMsg(5, "cvxPartSmdJogInit: failed to initialize jog data!");
cvxGetEnt("[Line]Select fold line", VX_INP_CURVE, 0, &jog.idLine);
cvxGetEnt("[Face]Select face to fold", VX_INP_FACE, 0, &jog.idFace);
double val = 0.0;
cvxGetNumber("[Reverse stationary side]Whether to reverse stationary side (1-yes, 0-no)", &val);
jog.reverseSide = int(val + 0.5);
/* Flange Parameters */
cvxGetNumber("[Height type]Select height type (0-Inside, 1-Outside)", &val);
jog.heightType = int(val + 0.5);
cvxGetNumber("[Height]Specify jog height", &jog.height);
cvxGetNumber("[Keep project length]Whether to keep project length (1-yes, 0-no)", &val); /* 1 as default */
jog.keepProjLen = int(val + 0.5);
/* Bend Parameters */
cvxGetNumber("[Position]Specify the position relationship between bend and line (0-Fold line outside, 1-Fold line inside, 2-Fold line middle, 3-Material inside, 4-Material outside)", &val);
jog.position = (evxSmdJogPosition)int(val + 0.5);
cvxGetNumber("[Radius]Specify inner bend face radius", &jog.radius);
/* K-factor definition */
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
jog.isUseGlobal = int(val + 0.5);
if (jog.isUseGlobal == 0)
{
jog.kType = VX_SMD_KTYPE_CUSTOM;
jog.kValue = 0.41;
}
/* jog sheet metal */
int idSmd = 0;
if (cvxPartSmdJog(&jog, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdJog: failed to jog sheet metal!");
}
void zwTestPartSmdLftFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdLftFlange.
*/
{
/* initialize data */
svxSmdLoftedFlangeData loftedFlange = {};
double val = 0.0;
cvxGetNumber("Select lofted flange data (0-General lofting, 1-flattenable lofting, 2-bending lofting)", &val);
loftedFlange.method = (evxSmdLftFlangeMethod)int(val + 0.5);
if (cvxPartSmdLftFlangeInit(loftedFlange.method, &loftedFlange))
zwTestLogErrorMsg(5, "cvxPartSmdLftFlangeInit: failed to initialize lofted flange data!");
cvxGetNumber("[Thickness T]Specify flange thickness (1 as default)", &loftedFlange.thickness);
cvxGetNumber("[Opposite]Whether to flip the direction of lofted flange (1-yes, 0-no)", &val);
loftedFlange.isOpposite = int(val + 0.5);
cvxGetNumber("[Radius]Specify inner bend face radius (5 as default)", &loftedFlange.radius);
switch (loftedFlange.method)
{
case VX_SMD_GENERAL_LOFTING:
cvxGetEnts("[Profile P1]Select the first profile, <midlle click> when done", VX_INP_PROF, 0,
&loftedFlange.inpUnion.general.count1, &loftedFlange.inpUnion.general.listLines1);
cvxGetEnts("[Profile P2]Select the second profile, <middle click> when done", VX_INP_PROF, 0,
&loftedFlange.inpUnion.general.count2, &loftedFlange.inpUnion.general.listLines2);
cvxGetEnts("[Boolean shapes]Select shapes to boolean, <middle click> when done", VX_INP_SHAPE, 0,
&loftedFlange.inpUnion.general.cntShps, &loftedFlange.inpUnion.general.boolShps);
cvxGetNumber("whether to flip Profile P1 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.general.flip1 = int(val + 0.5);
cvxGetNumber("Whether to flip Profile P2 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.general.flip2 = int(val + 0.5);
/* Boundary Constraints */
cvxGetNumber("[Continuity]Specify the continuity level at start (0-None, 1-Tangent, 2-Curvature, 3-Flow)", &val);
loftedFlange.inpUnion.general.bndCons[0].continuity = int(val + 0.5);
cvxGetNumber("[Direction]Specify direction of loft at start (0-Perpendicular, 1-Along edges)", &val);
loftedFlange.inpUnion.general.bndCons[0].direction = int(val + 0.5);
if (loftedFlange.inpUnion.general.bndCons[0].continuity > 0)
loftedFlange.inpUnion.general.bndCons[0].weight = 0.5;
cvxGetNumber("[Continuity]Specify the continuity level at end (0-None, 1-Tangent, 2-Curvature, 3-Flow)", &val);
loftedFlange.inpUnion.general.bndCons[1].continuity = int(val + 0.5);
cvxGetNumber("[Direction]Specify direction of loft at end (0-Perpendicular, 1-Along edges)", &val);
loftedFlange.inpUnion.general.bndCons[1].direction = int(val + 0.5);
if (loftedFlange.inpUnion.general.bndCons[1].continuity > 0)
loftedFlange.inpUnion.general.bndCons[0].weight = 0.5;
cvxGetNumber("[Scale]Specify additional scale factor that is applied to the weight slide bar (1 as default)", &val);
loftedFlange.inpUnion.general.scale = int(val + 0.5);
break;
case VX_SMD_FLATTENABLE_LOFTING:
cvxGetEnt("[Profile P1]Select the first profile", VX_INP_PROF, 0, &loftedFlange.inpUnion.flattenable.idProf1);
cvxGetNumber("Whether to flip Profile P1 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.flattenable.flip1 = int(val + 0.5);
cvxGetEnt("[Profile P2]Select the second profile", VX_INP_PROF, 0, &loftedFlange.inpUnion.flattenable.idProf2);
cvxGetNumber("Whether to flip Profile P2 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.flattenable.flip2 = int(val + 0.5);
/* Cut */
cvxGetPoint("[First cut point]Select the cut point to cut first profile", VX_INP_PNT_ON_ENTITY, 0,
&loftedFlange.inpUnion.flattenable.cutPnt1.pnt, &loftedFlange.inpUnion.flattenable.cutPnt1.idEnt);
cvxGetPoint("[Second cut point]Select the cut point to cut second profile", VX_INP_PNT_ON_ENTITY, 0,
&loftedFlange.inpUnion.flattenable.cutPnt2.pnt, &loftedFlange.inpUnion.flattenable.cutPnt2.idEnt);
cvxGetNumber("[Cut length]Select the cut length (1 as default)", &loftedFlange.inpUnion.flattenable.cutLength);
/* K-factor definition */
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
loftedFlange.inpUnion.flattenable.isUseGlobal = int(val + 0.5);
if (loftedFlange.inpUnion.flattenable.isUseGlobal == 0)
{
loftedFlange.inpUnion.flattenable.kType = VX_SMD_KTYPE_CUSTOM;
loftedFlange.inpUnion.flattenable.kValue = 0.41;
}
break;
case VX_SMD_BENDING_LOFTING:
cvxGetEnt("[Profile P1]Select the first profile", VX_INP_PROF, 0, &loftedFlange.inpUnion.bending.idProf1);
cvxGetNumber("Whether to flip Profile P1 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.bending.flip1 = int(val + 0.5);
cvxGetEnt("[Profile P2]Select the second profile", VX_INP_PROF, 0, &loftedFlange.inpUnion.bending.idProf2);
cvxGetNumber("Whether to flip Profile P2 (1-yes, 0-no)", &val);
loftedFlange.inpUnion.bending.flip2 = int(val + 0.5);
/* Cut */
cvxGetPoint("[First cut point]Select the cut point to cut first profile", VX_INP_PNT_ON_ENTITY, 0,
&loftedFlange.inpUnion.bending.cutPnt1.pnt, &loftedFlange.inpUnion.bending.cutPnt1.idEnt);
cvxGetPoint("[Second cut point]Select the cut point to cut second profile", VX_INP_PNT_ON_ENTITY, 0,
&loftedFlange.inpUnion.bending.cutPnt2.pnt, &loftedFlange.inpUnion.bending.cutPnt2.idEnt);
cvxGetNumber("[Cut length]Select the cut length (1 as default)", &loftedFlange.inpUnion.bending.cutLength);
/* Cutting Method */
cvxGetNumber("Select cut method (0-Maximum arc height, 1-Number of bend, 2-maximum chord length, 3-Maximum arc chord angle)", &val);
loftedFlange.inpUnion.bending.cutMethod = (evxSmdLftCutMethod)int(val + 0.5);
switch (loftedFlange.inpUnion.bending.cutMethod)
{
case VX_SMD_LFG_MAX_ARC_HEIGHT:
loftedFlange.inpUnion.bending.cutValue = 1;
break;
case VX_SMD_LFG_NUMBER_BEND:
loftedFlange.inpUnion.bending.cutValue = 2;
break;
case VX_SMD_LFG_MAX_CHORD_LENGTH:
loftedFlange.inpUnion.bending.cutValue = 10;
break;
case VX_SMD_LFG_MAX_ARC_CHORD_ANGLE:
loftedFlange.inpUnion.bending.cutValue = 30;
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdLftFlange: invalid option!");
break;
}
/* K-factor definition */
cvxGetNumber("[Global setting]Whether to use default K-factor Definition (1-yes, 0-no)", &val);
loftedFlange.inpUnion.bending.isUseGlobal = int(val + 0.5);
if (loftedFlange.inpUnion.bending.isUseGlobal == 0)
{
loftedFlange.inpUnion.bending.kType = VX_SMD_KTYPE_CUSTOM;
loftedFlange.inpUnion.bending.kValue = 0.41;
}
break;
default:
zwTestLogErrorMsg(5, "cvxPartSmdLftFlange: invalid option!");
break;
}
/* create lofted flange */
int idSmd = 0;
if (cvxPartSmdLftFlange(&loftedFlange, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdLftFlange: failed to create lofted flange!");
if (loftedFlange.method == VX_SMD_GENERAL_LOFTING)
{
cvxMemFree((void**)&loftedFlange.inpUnion.general.listLines1);
cvxMemFree((void**)&loftedFlange.inpUnion.general.listLines2);
cvxMemFree((void**)&loftedFlange.inpUnion.general.boolShps);
}
}
void zwTestPartSmdFoldByLine()
/*
DESCRIPTION:
Test case for function cvxPartSmdFoldByLine.
*/
{
/* initialize data */
svxSmdFoldByLineData foldByLine = {};
if (cvxPartSmdFoldByLineInit(&foldByLine))
zwTestLogErrorMsg(5, "cvxPartSmdFoldByLineInit: failed to initialize data!");
cvxGetEnt("[Line]Select fold line", VX_INP_PROF, 0, &foldByLine.idLine);
if (cvxEntClassNum(foldByLine.idLine) == VX_ENT_LINE2)
cvxEntSketch(foldByLine.idLine, &foldByLine.idProfile);
cvxGetEnt("[Face]Select face to fold", VX_INP_FACE, 0, &foldByLine.idFace);
double val = 0.0;
cvxGetNumber("[Flip Side To Keep]Whether to flip side to keep(1: enable; 0: disable)", &val);
foldByLine.flipSide = ((int)(val + 0.5) == 1 ? 1 : 0);
/* flange parameters */
cvxGetNumber("[Position]Specify the position relationship between bend and line (0-Fold line outside, 1-Fold line inside, 2-Fold line middle, 3-Material inside, 4-Material outside)", &val);
foldByLine.position = (evxSmdJogPosition)int(val + 0.5);
cvxGetNumber("[Angle]Specify bend angle", &foldByLine.angle);
/* blend radius */
cvxGetNumber("[Radius]Specify bend radius", &foldByLine.radius);
/* K-factor definition */
cvxGetNumber("[Global setting]Whether to use global setting(1: enable; 0: disable)", &val);
foldByLine.isUseGlobal = ((int)(val + 0.5) == 1 ? 1 : 0);
if (foldByLine.isUseGlobal == 0)
{
cvxGetNumber("[Factor Type]Enter number to switch factor type(0: custom; 1: from material; 2: bend table; "
"3: bend allowance table; 4: bend allowance formula; 5: bend deduction table; 6: bend deduction; 7: bend allowance)", &val);
foldByLine.kType = (evxSmdKFactorType)(int)(val + 0.5);
if (foldByLine.kType == VX_SMD_KTYPE_CUSTOM)
cvxGetNumber("[K-Factor]The default value is 0.41", &foldByLine.kValue);
}
/* create fold feature */
int idSmd = 0;
if (cvxPartSmdFoldByLine(&foldByLine, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdLftFlange: failed to create fold feature!");
}
void zwTestPartSmdSweptFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdSweptFlange.
*/
{
/* initialize data */
double val = 0.0;
cvxGetNumber("[Relief]Enter number to switch type(0: closed; 1: circular cutout; 2: rectangular cutout; 3: U cutout; 4: V cutout)", &val);
evxSmdCornerRelief corType = (evxSmdCornerRelief)(int)(val + 0.5);
svxSmdSweptFlangeData swept = {};
if (cvxPartSmdSweptFlangeInit(corType, &swept))
zwTestLogErrorMsg(5, "cvxPartSmdSweptFlangeInit: failed to initialize data!");
cvxGetEnt("[Stationary]Select stationary face", VX_INP_FACE, 0, &swept.idFace);
cvxGetEnt("[Profile]Select profile", VX_INP_SKETCH, 0, &swept.idProfile);
cvxGetEnts("[Path]Select sweep path", VX_INP_EDGE, 0, &swept.count, &swept.sweptPath);
/* flange parameters */
cvxGetNumber("[Position]Enter number to switch position(0-Material inside, 1-Material outside, 2-Natural, 3-Offset)", &val);
swept.position = (evxSmdPosition)int(val + 0.5);
cvxGetNumber("[Radius]Specify inner bend face radius", &swept.radius);
if (swept.position == VX_POSITION_OFFSET)
cvxGetNumber("[Offset]Specify flange offset", &swept.offset);
cvxGetNumber("[Keep merged edges]Whether to keep merged edges(1: enable; 0: disable)", &val);
swept.keepMerged = ((int)(val + 0.5) == 1 ? 1 : 0);
/* K-factor definition */
cvxGetNumber("[Global setting]Whether to use global setting(1: enable; 0: disable)", &val);
swept.isUseGlobal = ((int)(val + 0.5) == 1 ? 1 : 0);
if (swept.isUseGlobal == 0)
{
cvxGetNumber("[Factor Type]Enter number to switch factor type(0: custom; 1: from material; 2: bend table; "
"3: bend allowance table; 4: bend allowance formula; 5: bend deduction table; 6: bend deduction; 7: bend allowance)", &val);
swept.kType = (evxSmdKFactorType)(int)(val + 0.5);
if (swept.kType == VX_SMD_KTYPE_CUSTOM)
cvxGetNumber("[K-Factor]The default value is 0.41", &swept.kValue);
}
/* corner attributes */
switch (swept.relief)
{
case VX_CORNER_RELIEF_CLOSED:
cvxGetNumber("[Gap]Specify gap for close corner", &swept.inpUnion.closed.gap);
break;
case VX_CORNER_RELIEF_CIRCULAR_CUTOUT:
cvxGetNumber("[Gap]Specify gap for close corner", &swept.inpUnion.circular.gap);
cvxGetNumber("[Origin]Specify origin(0: bend center; 1: corner point)", &val);
swept.inpUnion.circular.origin = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Offset]Specify offset distance from the origin of the Cutout", &swept.inpUnion.circular.offset);
cvxGetNumber("[Diameter]Specify diameter", &swept.inpUnion.circular.diameter);
break;
case VX_CORNER_RELIEF_RECTANGULAR_CUTOUT:
cvxGetNumber("[Gap]Specify gap for close corner", &swept.inpUnion.rectangular.gap);
cvxGetNumber("[Origin]Specify origin(0: bend center; 1: corner point)", &val);
swept.inpUnion.rectangular.origin = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Offset]Specify offset distance from the origin of the Cutout", &swept.inpUnion.rectangular.offset);
cvxGetNumber("[Length]Specify length for rectangular cut", &swept.inpUnion.rectangular.length);
cvxGetNumber("[Width]Specify width for rectangular cut", &swept.inpUnion.rectangular.width);
break;
case VX_CORNER_RELIEF_U_CUTOUT:
cvxGetNumber("[Gap]Specify gap for close corner", &swept.inpUnion.uCutout.gap);
cvxGetNumber("[Origin]Specify origin(0: bend center; 1: corner point)", &val);
swept.inpUnion.uCutout.origin = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Offset]Specify offset distance from the origin of the Cutout", &swept.inpUnion.uCutout.offset);
cvxGetNumber("[Diameter]Specify diameter", &swept.inpUnion.uCutout.diameter);
break;
case VX_CORNER_RELIEF_V_CUTOUT:
cvxGetNumber("[Gap]Specify gap for close corner", &swept.inpUnion.vCutout.gap);
cvxGetNumber("[Origin]Specify origin(0: bend center; 1: corner point)", &val);
swept.inpUnion.vCutout.origin = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Offset]Specify offset distance from the origin of the Cutout", &swept.inpUnion.vCutout.offset);
cvxGetNumber("[Diameter]Specify diameter", &swept.inpUnion.vCutout.diameter);
cvxGetNumber("[Angle1]Specify first angle for V cut", &swept.inpUnion.vCutout.angle1);
cvxGetNumber("[Angle2]Specify second angle for V cut", &swept.inpUnion.vCutout.angle2);
break;
default:
break;
}
cvxGetNumber("[Miter corner]Whether to use miter corner(1: enable; 0: disable)", &val);
swept.miterCorner = ((int)(val + 0.5) == 1 ? 1 : 0);
/* create swept flange */
int idSmd = 0;
if (cvxPartSmdSweptFlange(&swept, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdSweptFlange: failed to create swept flange!");
/* free memory */
cvxMemFree((void**)&swept.sweptPath);
}
void zwTestPartSmdExtendFlange()
/*
DESCRIPTION:
Test case for function cvxPartSmdExtendFlange.
*/
{
/* initialize data */
double val = 0.0;
cvxGetNumber("[Extend Type]Enter number to switch type(0: specfied value; 1: extends to intersect the plane; 2: extends up to the plane)", &val);
evxSmdExtendFlangeMethod extType = (evxSmdExtendFlangeMethod)(int)(val + 0.5);
svxSmdExtendFlangeData extendFlg = {};
if (cvxPartSmdExtendFlangeInit(extType, &extendFlg))
zwTestLogErrorMsg(5, "cvxPartSmdExtendFlangeInit: failed to initialize data!");
cvxGetEnt("[Edge]Select one edge on the flange", VX_INP_EDGE, 0, &extendFlg.idEdge);
if (extendFlg.type == VX_SMD_EXTEND_BY_VALUE)
{
cvxGetNumber("[Distance]Specify extend distance", &extendFlg.inpUnion.distance);
}
else
{
cvxGetEnt("[Plane]Select the reference plane", VX_INP_DATUM_PLANE, 0, &extendFlg.inpUnion.nonByValue.idPlane);
cvxGetNumber("[Offset]Specify offset distance", &extendFlg.inpUnion.nonByValue.offset);
}
/* extension */
for (int i = 0; i < 2; i++)
{
evxSmdExtendSideMethod* sideType = (i == 0 ? &extendFlg.sideType1 : &extendFlg.sideType2);
cvxGetNumber("[Method]Select method(0: Extend the flange normal to the edge; 1: Extend along the edge)", &val);
*sideType = (evxSmdExtendSideMethod)((int)(val + 0.5) == 1 ? 1 : 0);
if (*sideType == VX_SMD_EXTEND_SIDE_ALONG)
{
int* extendToEdge = (i == 0 ? &extendFlg.extendSrfToEdge1 : &extendFlg.extendSrfToEdge2);
cvxGetNumber("[Extend surface adjacent to edge]Select method(1: enable; 1: disable)", &val);
*extendToEdge = ((int)(val + 0.5) == 1 ? 1 : 0);
}
}
/* create swept flange */
int idSmd = 0;
if (cvxPartSmdExtendFlange(&extendFlg, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdExtendFlange: failed to create extend flange!");
}
void zwTestPartSmdBendTaper()
/*
DESCRIPTION:
Test case for function cvxPartSmdBendTaper.
*/
{
/* initialize data */
double val = 0.0;
cvxGetNumber("[Taper Side]Enter number to switch type(0: both; 1: side 1; 2: side 2; 3: symmetry)", &val);
evxSmdTaperSideMethod taperSide = (evxSmdTaperSideMethod)(int)(val + 0.5);
svxSmdBendTaperData bendTaper = {};
if (cvxPartSmdBendTaperInit(taperSide, &bendTaper))
zwTestLogErrorMsg(5, "cvxPartSmdBendTaperInit: failed to initialize data!");
cvxGetEnt("[Bend]Select bend face", VX_INP_FACE, 0, &bendTaper.idBend);
cvxGetNumber("[Opposite](1: enable; 0: disable)", &val);
bendTaper.opposite = ((int)(val + 0.5) == 1 ? 1 : 0);
/* initialize data */
int nSides = (taperSide == VX_SMD_TAPER_SIDES_BOTH ? 2 : 1);
for (int i = 0; i < nSides; i++)
{
cvxGetNumber("[Bend Taper]Enter number to switch type(0: linear; 1: tangent)", &val);
int taperType = ((int)(val + 0.5) == 1 ? 1 : 0);
svxSmdBendTaperDefData *bendTaperDef = (i == 0 ? &bendTaper.defData : &bendTaper.defData2);
if (cvxPartSmdBendTaperDefDataInit(taperType, bendTaperDef))
zwTestLogErrorMsg(5, "cvxPartSmdBendTaperDefDataInit: failed to initialize data!");
if (bendTaperDef->taperType == 0)
{
cvxGetNumber("[Input method]Enter number to switch type(0: setback; 1: angle)", &val);
bendTaperDef->inpUnion.linear.method = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Setback or angle]Enter Setback or angle", &bendTaperDef->inpUnion.linear.value);
}
else
{
cvxGetNumber("[Setback]Enter Setback", &bendTaperDef->inpUnion.tangent.setback);
cvxGetNumber("[Auto computer radius]Whether to auto computer radius(1: enable; 0: disable)", &val);
bendTaperDef->inpUnion.tangent.isAutoCompute = ((int)(val + 0.5) == 1 ? 1 : 0);
if (bendTaperDef->inpUnion.tangent.isAutoCompute == 0)
{
cvxGetNumber("[Start radius]Enter start radius", &bendTaperDef->inpUnion.tangent.sRadius);
cvxGetNumber("[End radius]Enter end radius", &bendTaperDef->inpUnion.tangent.eRadius);
}
}
cvxGetNumber("[Web Taper]Enter number to switch type(0: none; 1: face 1; 2: face chain)", &val);
bendTaperDef->webTaperType = (evxSmdWebTaperType)(int)(val + 0.5);
if (bendTaperDef->webTaperType != VX_SMD_TAPER_WEB_NONE)
cvxGetNumber("[Angle]Enter angle", &bendTaperDef->angle);
}
/* create bend taper */
int idSmd = 0;
if (cvxPartSmdBendTaper(&bendTaper, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdBendTaper: failed to create bend taper!");
}
void zwTestPartSmdFlatten()
/*
DESCRIPTION:
Test case for function cvxPartSmdFlatten.
*/
{
/* initialize data */
svxSmdFlattenData flatten = {};
if (cvxPartSmdFlattenInit(&flatten))
zwTestLogErrorMsg(5, "cvxPartSmdFlattenInit: failed to initialize data!");
cvxGetEnt("[Shape]Select shape to flatten", VX_INP_SHAPE, 0, &flatten.idShape);
/* setting */
double val = 0.0;
cvxGetEnt("[Stationary]Select stationary face, <middle-click> to ignore", VX_INP_FACE, 1, &flatten.idFace);
cvxGetNumber("[Offset]Input offset value", &flatten.offset);
if (!cvxGetPoint("[Direction]Select offset direction, <middle-click> to ignore", VX_INP_PNT_DIRECTION, 1, (svxPoint*)&flatten.direction, NULL))
{
svxPoint orgPnt = {};
if (!zwUtilIsEqualPnt((svxPoint*)&flatten.direction, &orgPnt, V_FZERO))
flatten.useDir = 1;
}
cvxGetNumber("[Include flat pattern]Whether to include flat pattern(1: enable; 0: disable)", &val);
flatten.includePattern = ((int)(val + 0.5) == 1 ? 1 : 0);
if (flatten.includePattern == 1)
{
cvxGetNumber("[Ingore tangent edges]Whether to ingore tangent edges(1: enable; 0: disable)", &val);
flatten.ignoreTangent = ((int)(val + 0.5) == 1 ? 1 : 0);
if (!cvxGetPoint("[PMI Direction]Select PMI direction, <middle-click> to ignore", VX_INP_PNT_DIRECTION, 1, (svxPoint*)&flatten.dirPMI, NULL))
{
svxPoint orgPnt = {};
if (!zwUtilIsEqualPnt((svxPoint*)&flatten.dirPMI, &orgPnt, V_FZERO))
flatten.useDirPMI = 1;
}
}
/* create flatten feature */
int idSmd = 0;
if (cvxPartSmdFlatten(&flatten, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdFlatten: failed to create flatten feature!");
}
void zwTestPartSmdLnUnfold()
/*
DESCRIPTION:
Test case for function cvxPartSmdLnUnfold.
*/
{
/* initialize data */
svxSmdLinearUnfoldData lineUnfold = {};
if (cvxPartSmdLnUnfoldInit(&lineUnfold))
zwTestLogErrorMsg(5, "cvxPartSmdLnUnfoldInit: failed to initialize data!");
cvxGetEnt("[Stationary]Select stationary face, <middle-click> to ignore", VX_INP_FACE, 1, &lineUnfold.idFace);
cvxGetEnts("[Bends]Select bend faces, <middle-click> when done", VX_INP_FACE, 0, &lineUnfold.cnt, &lineUnfold.bendFcs);
cvxGetNumber("[Angle]Specify bend angle", &lineUnfold.angle);
/* K-factor definition */
double val = 0.0;
cvxGetNumber("[Global setting]Whether to use global setting(1: enable; 0: disable)", &val);
lineUnfold.isUseGlobal = ((int)(val + 0.5) == 1 ? 1 : 0);
if (lineUnfold.isUseGlobal == 0)
{
cvxGetNumber("[Factor Type]Enter number to switch factor type(0: custom; 1: from material; 2: bend table; "
"3: bend allowance table; 4: bend allowance formula; 5: bend deduction table; 6: bend deduction; 7: bend allowance)", &val);
lineUnfold.kType = (evxSmdKFactorType)(int)(val + 0.5);
if (lineUnfold.kType == VX_SMD_KTYPE_CUSTOM)
cvxGetNumber("[K-Factor]The default value is 0.41", &lineUnfold.kValue);
}
cvxGetNumber("[Add a new forming status]Whether to add a new forming status(1: enable; 0: disable)", &val);
lineUnfold.addStatus = ((int)(val + 0.5) == 1 ? 1 : 0);
if (lineUnfold.addStatus)
{
cvxGetPoint("[Direction]Select linear unfold direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&lineUnfold.dir, NULL);
cvxGetNumber("[Distance]Enter distance along linear unfold direction", &lineUnfold.distance);
}
/* create linear unfold */
int idSmd = 0;
if (cvxPartSmdLnUnfold(&lineUnfold, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdLnUnfold: failed to create linear unfold!");
/* free memory */
cvxMemFree((void**)&lineUnfold.bendFcs);
}
void zwTestPartSmdChangeBend()
/*
DESCRIPTION:
Test case for function cvxPartSmdChangeBend.
*/
{
double val = 0.0;
/* initialize data */
evxSmdChangeBendType type = VX_SMD_CHANGE_BEND_DEFAULT;
cvxGetNumber("[Type]Enter number to switch factor type(0: default; 1: fixed fold length; 2: fixed unfold length)", &val);
type = (evxSmdChangeBendType)(int)(val + 0.5);
svxSmdChangeBendData changeBend = {};
if (cvxPartSmdChangeBendInit(type, &changeBend))
zwTestLogErrorMsg(5, "cvxPartSmdChangeBendInit: failed to initialize data!");
cvxGetEnts("[Bends]Select bend faces, <middle-click> when done", VX_INP_FACE, 0, &changeBend.cnt, &changeBend.bendFcs);
/* bend parameter */
cvxGetNumber("[Radius]Specify bend radius", &changeBend.radius);
if (changeBend.type == VX_SMD_CHANGE_BEND_DEFAULT)
cvxGetNumber("[Angle]Specify bend angle", &changeBend.inpUnion.defaultInfo.angle);
if (changeBend.type == VX_SMD_CHANGE_BEND_UNFOLD_LENGTH)
{
cvxGetEnt("[Stationary]Select stationary face", VX_INP_FACE, 0, &changeBend.inpUnion.unfold.stationary);
cvxGetNumber("[Angle]Specify bend angle", &changeBend.inpUnion.unfold.angle);
}
if (changeBend.type == VX_SMD_CHANGE_BEND_DEFAULT || changeBend.type == VX_SMD_CHANGE_BEND_FOLD_LENGTH)
{
int* useGlobal = (changeBend.type == VX_SMD_CHANGE_BEND_DEFAULT ? &changeBend.inpUnion.defaultInfo.isUseGlobal : &changeBend.inpUnion.fold.isUseGlobal);
cvxGetNumber("[Global setting]Whether to use global setting(1: enable; 0: disable)", &val);
*useGlobal = ((int)(val + 0.5) == 1 ? 1 : 0);
if (*useGlobal == 0)
{
evxSmdKFactorType* kType = (changeBend.type == VX_SMD_CHANGE_BEND_DEFAULT ? &changeBend.inpUnion.defaultInfo.kType : &changeBend.inpUnion.fold.kType);
cvxGetNumber("[Factor Type]Enter number to switch factor type(0: custom; 1: from material; 2: bend table; "
"3: bend allowance table; 4: bend allowance formula; 5: bend deduction table; 6: bend deduction; 7: bend allowance)", &val);
*kType = (evxSmdKFactorType)(int)(val + 0.5);
if (*kType == VX_SMD_KTYPE_CUSTOM)
{
double* kValue = (changeBend.type == VX_SMD_CHANGE_BEND_DEFAULT ? &changeBend.inpUnion.defaultInfo.kValue : &changeBend.inpUnion.fold.kValue);
cvxGetNumber("[K-Factor]The default value is 0.41", kValue);
}
}
}
/* create change bend */
int idSmd = 0;
if (cvxPartSmdChangeBend(&changeBend, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdChangeBend: failed to create change bend!");
/* free memory */
cvxMemFree((void**)&changeBend.bendFcs);
}
void zwTestPartSmdRip()
/*
DESCRIPTION:
Test case for function cvxPartSmdRip.
*/
{
/* initialize data */
svxSmdRipData rip = {};
if (cvxPartSmdRipInit(&rip))
zwTestLogErrorMsg(5, "cvxPartSmdRipInit: failed to initialize data!");
double val = 0.0;
cvxGetNumber("[Rip Type]Enter number to switch rip type(0: two sides; 1: left side; 2: right side", &val);
switch (int(val+0.5))
{
case 1: rip.type = VX_SMD_RIP_LEFT_SIDE; break;
case 2: rip.type = VX_SMD_RIP_RIGHT_SIDE; break;
default: rip.type = VX_SMD_RIP_BOTH_SIDES; break;
}
cvxGetEnts("[Edges]Select splitting line or linear edges, <middle-click> when done", VX_INP_EDGE, 0, &rip.cnt, &rip.ids);
cvxGetNumber("[Gap]The default value is 0.10", &rip.gap);
/* create rib feature */
int idSmd = 0;
if (cvxPartSmdRip(&rip, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdRip: failed to create rib feature!");
/* free memory */
cvxMemFree((void**)&rip.ids);
}
void zwTestPartSmdMarkBend()
/*
DESCRIPTION:
Test case for function cvxPartSmdMarkBend.
*/
{
/* initialize data */
svxSmdMarkBendData markBend = {};
if (cvxPartSmdMarkBendInit(&markBend))
zwTestLogErrorMsg(5, "cvxPartSmdMarkBendInit: failed to initialize data!");
cvxGetEnt("[Stationary]Select stationary face", VX_INP_FACE, 0, &markBend.idFace);
cvxGetEnts("[Bend Faces]Select faces of bends, <middle-click> when done", VX_INP_FACE, 0, &markBend.cnt, &markBend.bendFcs);
double val = 0.0;
cvxGetNumber("[Global setting]Whether to use global setting(1: enable; 0: disable)", &val);
markBend.isUseGlobal = ((int)(val + 0.5) == 1 ? 1 : 0);
if (markBend.isUseGlobal == 0)
{
/* K-factor definition */
cvxGetNumber("[Factor Type]Enter number to switch factor type(0: custom; 1: from material; 2: bend table; "
"3: bend allowance table; 4: bend allowance formula; 5: bend deduction table; 6: bend deduction; 7: bend allowance)", &val);
markBend.kType = (evxSmdKFactorType)(int)(val + 0.5);
if (markBend.kType == VX_SMD_KTYPE_CUSTOM)
cvxGetNumber("[K-Factor]The default value is 0.41", &markBend.kValue);
cvxGetNumber("[Thickness]The default value is 1.0", &markBend.thickness);
}
cvxGetNumber("[Tolerance]The default value is 0.1", &markBend.flatTol);
/* create mark bend */
int idSmd = 0;
if (cvxPartSmdMarkBend(&markBend, &idSmd) || idSmd == 0)
zwTestLogErrorMsg(5, "cvxPartSmdMarkBend: failed to create mark bend!");
/* free memory */
cvxMemFree((void**)&markBend.bendFcs);
}
VX_COINCIDENT
@ VX_COINCIDENT
Coincident constraint.
Definition: zwapi_cmd_assembly_data.h:196
evxSmdTaperSideMethod
evxSmdTaperSideMethod
smd bend taper sides
Definition: zwapi_cmd_sheetmetal_data.h:892
VX_SMD_TAPER_SIDES_BOTH
@ VX_SMD_TAPER_SIDES_BOTH
Tapers both sides of the flange. You can set different values for each side.
Definition: zwapi_cmd_sheetmetal_data.h:893
evxNormCutTyp
evxNormCutTyp
Normal Cut command.
Definition: zwapi_cmd_sheetmetal_data.h:929
evxDimplePostion
evxDimplePostion
dimple position type
Definition: zwapi_cmd_sheetmetal_data.h:1113
evxSmdHemBendType
evxSmdHemBendType
Smd Bend Type of Hem Flange.
Definition: zwapi_cmd_sheetmetal_data.h:487
VX_SMD_HEM_BEND_CENTEREDLOOP
@ VX_SMD_HEM_BEND_CENTEREDLOOP
Centered loop.
Definition: zwapi_cmd_sheetmetal_data.h:492
VX_SMD_HEM_BEND_CLOSED
@ VX_SMD_HEM_BEND_CLOSED
Close.
Definition: zwapi_cmd_sheetmetal_data.h:488
VX_SMD_HEM_BEND_CLOSEDLOOP
@ VX_SMD_HEM_BEND_CLOSEDLOOP
Closed loop.
Definition: zwapi_cmd_sheetmetal_data.h:490
VX_SMD_HEM_BEND_OPENLOOP
@ VX_SMD_HEM_BEND_OPENLOOP
Open loop.
Definition: zwapi_cmd_sheetmetal_data.h:491
VX_SMD_HEM_BEND_SBEND
@ VX_SMD_HEM_BEND_SBEND
S bend.
Definition: zwapi_cmd_sheetmetal_data.h:493
VX_SMD_HEM_BEND_OPEN
@ VX_SMD_HEM_BEND_OPEN
Open.
Definition: zwapi_cmd_sheetmetal_data.h:489
VX_SMD_HEM_BEND_CURL
@ VX_SMD_HEM_BEND_CURL
Curl.
Definition: zwapi_cmd_sheetmetal_data.h:494
evxExtrudeType
evxExtrudeType
extrude type
Definition: zwapi_cmd_sheetmetal_data.h:918
VX_EXTRUDE_TYPE_ONESIDE
@ VX_EXTRUDE_TYPE_ONESIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:919
VX_EXTRUDE_TYPE_SYMMETRICAL
@ VX_EXTRUDE_TYPE_SYMMETRICAL
Symmetrical.
Definition: zwapi_cmd_sheetmetal_data.h:921
VX_EXTRUDE_TYPE_TWOSIDE
@ VX_EXTRUDE_TYPE_TWOSIDE
2 side
Definition: zwapi_cmd_sheetmetal_data.h:920
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
Lofted Flange method.
Definition: zwapi_cmd_sheetmetal_data.h:568
VX_SMD_FLATTENABLE_LOFTING
@ VX_SMD_FLATTENABLE_LOFTING
Open - loop contour and bending lofting.
Definition: zwapi_cmd_sheetmetal_data.h:570
VX_SMD_BENDING_LOFTING
@ VX_SMD_BENDING_LOFTING
The number of segments of the arc is controlled according to the maximum arc height,...
Definition: zwapi_cmd_sheetmetal_data.h:571
VX_SMD_GENERAL_LOFTING
@ VX_SMD_GENERAL_LOFTING
The surfaces generated are the same as those generated by solid lofting.
Definition: zwapi_cmd_sheetmetal_data.h:569
evxSmdCornerRelief
evxSmdCornerRelief
Smd Relief type of Corner Attributes.
Definition: zwapi_cmd_sheetmetal_data.h:86
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
@ VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:89
VX_CORNER_RELIEF_V_CUTOUT
@ VX_CORNER_RELIEF_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:91
VX_CORNER_RELIEF_U_CUTOUT
@ VX_CORNER_RELIEF_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:90
VX_CORNER_RELIEF_CIRCULAR_CUTOUT
@ VX_CORNER_RELIEF_CIRCULAR_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:88
VX_CORNER_RELIEF_CLOSED
@ VX_CORNER_RELIEF_CLOSED
closed
Definition: zwapi_cmd_sheetmetal_data.h:87
evxSmdRelief
evxSmdRelief
Smd Relief type.
Definition: zwapi_cmd_sheetmetal_data.h:74
VX_RELIEF_NONE
@ VX_RELIEF_NONE
None.
Definition: zwapi_cmd_sheetmetal_data.h:77
evxCornerReliefTyp
evxCornerReliefTyp
corner relief type
Definition: zwapi_cmd_sheetmetal_data.h:966
VX_CORNER_V_CUTOUT
@ VX_CORNER_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:971
VX_CORNER_U_CUTOUT
@ VX_CORNER_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:970
VX_CORNER_RECT_CUTOUT
@ VX_CORNER_RECT_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:969
VX_CORNER_CIRCL_CUTOUT
@ VX_CORNER_CIRCL_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:968
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
extend flange method
Definition: zwapi_cmd_sheetmetal_data.h:796
VX_SMD_EXTEND_BY_VALUE
@ VX_SMD_EXTEND_BY_VALUE
Extends by a specfied value.
Definition: zwapi_cmd_sheetmetal_data.h:797
VX_SMD_RIP_RIGHT_SIDE
@ VX_SMD_RIP_RIGHT_SIDE
right side
Definition: zwapi_cmd_sheetmetal_data.h:1303
VX_SMD_RIP_LEFT_SIDE
@ VX_SMD_RIP_LEFT_SIDE
left side
Definition: zwapi_cmd_sheetmetal_data.h:1302
VX_SMD_RIP_BOTH_SIDES
@ VX_SMD_RIP_BOTH_SIDES
two sides
Definition: zwapi_cmd_sheetmetal_data.h:1301
evxPunchLocType
evxPunchLocType
location type of punch command
Definition: zwapi_cmd_sheetmetal_data.h:1043
VX_LOCATION_CONSTRAINT
@ VX_LOCATION_CONSTRAINT
Constraint.
Definition: zwapi_cmd_sheetmetal_data.h:1045
VX_LOCATION_POINT
@ VX_LOCATION_POINT
Point.
Definition: zwapi_cmd_sheetmetal_data.h:1044
evxSmdJogPosition
evxSmdJogPosition
Smd Jog Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:739
evxSmdChangeBendType
evxSmdChangeBendType
change bend type
Definition: zwapi_cmd_sheetmetal_data.h:1251
VX_SMD_CHANGE_BEND_FOLD_LENGTH
@ VX_SMD_CHANGE_BEND_FOLD_LENGTH
Only bend radius of picked bends and geometries nearby will be changed keeping other dimensions of th...
Definition: zwapi_cmd_sheetmetal_data.h:1253
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
@ VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
Both bend radius and angle can be changed keep the over all unfold length of the shape unchanged.
Definition: zwapi_cmd_sheetmetal_data.h:1256
VX_SMD_CHANGE_BEND_DEFAULT
@ VX_SMD_CHANGE_BEND_DEFAULT
Both bend radius and angle can be changed.
Definition: zwapi_cmd_sheetmetal_data.h:1252
evxSmdLftCutMethod
evxSmdLftCutMethod
Lofted Flange Cutting Method.
Definition: zwapi_cmd_sheetmetal_data.h:581
VX_SMD_LFG_MAX_CHORD_LENGTH
@ VX_SMD_LFG_MAX_CHORD_LENGTH
This method requires that the chord length of each arc/ellipse arc is equal (the chord length of diff...
Definition: zwapi_cmd_sheetmetal_data.h:587
VX_SMD_LFG_MAX_ARC_HEIGHT
@ VX_SMD_LFG_MAX_ARC_HEIGHT
This method requires that the arc/ellipse corresponding to each segment line of the graph arc have th...
Definition: zwapi_cmd_sheetmetal_data.h:582
VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
@ VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
This method requires that the maximum Angle between the tangent vector of the two ends of the arc and...
Definition: zwapi_cmd_sheetmetal_data.h:590
VX_SMD_LFG_NUMBER_BEND
@ VX_SMD_LFG_NUMBER_BEND
The control value is the number of line segments in each arc/ellipse. It has no unit and is an intege...
Definition: zwapi_cmd_sheetmetal_data.h:585
evxSmdPosition
evxSmdPosition
Smd Flange Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:33
VX_POSITION_OFFSET
@ VX_POSITION_OFFSET
Offset.
Definition: zwapi_cmd_sheetmetal_data.h:37
evxCornerOverlapTyp
evxCornerOverlapTyp
corner overlap type
Definition: zwapi_cmd_sheetmetal_data.h:979
evxSmdBendLengthType
evxSmdBendLengthType
Smd Bend Attributes Length type.
Definition: zwapi_cmd_sheetmetal_data.h:46
evxSmdWebTaperType
evxSmdWebTaperType
smd bend web taper type
Definition: zwapi_cmd_sheetmetal_data.h:847
VX_SMD_TAPER_WEB_NONE
@ VX_SMD_TAPER_WEB_NONE
Tapers only the bend.
Definition: zwapi_cmd_sheetmetal_data.h:848
evxSmdKFactorType
evxSmdKFactorType
K-factor Definition type.
Definition: zwapi_cmd_sheetmetal_data.h:58
VX_SMD_KTYPE_CUSTOM
@ VX_SMD_KTYPE_CUSTOM
custom
Definition: zwapi_cmd_sheetmetal_data.h:59
evxPunchTyp
evxPunchTyp
Punch type.
Definition: zwapi_cmd_sheetmetal_data.h:1033
VX_PUNCH_SHAPE
@ VX_PUNCH_SHAPE
Punch from Shape.
Definition: zwapi_cmd_sheetmetal_data.h:1034
VX_PUNCH_FILE
@ VX_PUNCH_FILE
Punch from File.
Definition: zwapi_cmd_sheetmetal_data.h:1035
evxExtFlangeType
evxExtFlangeType
Smd extrude type.
Definition: zwapi_cmd_sheetmetal_data.h:191
VX_EXTFLANGE_1SIDE
@ VX_EXTFLANGE_1SIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:192
VX_EXTFLANGE_2SIDES
@ VX_EXTFLANGE_2SIDES
2 sides
Definition: zwapi_cmd_sheetmetal_data.h:193
VX_EXTFLANGE_SYMMETRICAL
@ VX_EXTFLANGE_SYMMETRICAL
symmetrical
Definition: zwapi_cmd_sheetmetal_data.h:194
evxSmdExtendSideMethod
evxSmdExtendSideMethod
extend flange side method
Definition: zwapi_cmd_sheetmetal_data.h:807
VX_SMD_EXTEND_SIDE_ALONG
@ VX_SMD_EXTEND_SIDE_ALONG
Extend along the edge.
Definition: zwapi_cmd_sheetmetal_data.h:809
cvxPartSmdHemFlange
evxErrors cvxPartSmdHemFlange(const svxSmdHemFlangeData *data, int *idHem)
cvxPartSmdPartialFlange
evxErrors cvxPartSmdPartialFlange(const svxSmdPartialFlangeData *data, int *idPartial)
cvxPartSmdFlattenInit
evxErrors cvxPartSmdFlattenInit(svxSmdFlattenData *data)
cvxPartSmdExtrudeTab
evxErrors cvxPartSmdExtrudeTab(const svxSmdExtrudeTabData *data, int *idExtTab)
cvxPartSmdLftFlange
evxErrors cvxPartSmdLftFlange(const svxSmdLoftedFlangeData *data, int *idLft)
cvxPartSmdLnUnfold
evxErrors cvxPartSmdLnUnfold(const svxSmdLinearUnfoldData *data, int *idFtr)
cvxPartSmdLnUnfoldInit
evxErrors cvxPartSmdLnUnfoldInit(svxSmdLinearUnfoldData *data)
cvxPartSmdBendTaper
evxErrors cvxPartSmdBendTaper(const svxSmdBendTaperData *data, int *idFtr)
cvxPartSmdExtendFlange
evxErrors cvxPartSmdExtendFlange(const svxSmdExtendFlangeData *data, int *idFtr)
cvxPartSmdFoldByLine
evxErrors cvxPartSmdFoldByLine(const svxSmdFoldByLineData *data, int *idFbl)
cvxPartSmdDimpleInit
evxErrors cvxPartSmdDimpleInit(svxDimpleData *data)
cvxPartSmdMarkBend
evxErrors cvxPartSmdMarkBend(const svxSmdMarkBendData *data, int *idFtr)
cvxPartSmdSweptFlange
evxErrors cvxPartSmdSweptFlange(const svxSmdSweptFlangeData *data, int *idSwept)
cvxPartSmdFullFlangeInit
evxErrors cvxPartSmdFullFlangeInit(svxSmdFullFlangeData *data)
cvxPartSmdExtrudeFlangeinit
evxErrors cvxPartSmdExtrudeFlangeinit(svxExtrudeFlangeData *data)
cvxPartSmdExtendFlangeInit
evxErrors cvxPartSmdExtendFlangeInit(evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData *data)
cvxPartSmdChangeBend
evxErrors cvxPartSmdChangeBend(const svxSmdChangeBendData *data, int *idFtr)
cvxPartSmdFullFlange
evxErrors cvxPartSmdFullFlange(const svxSmdFullFlangeData *data, int *idFull)
cvxPartSmdProfFlange
evxErrors cvxPartSmdProfFlange(const svxSmdFlangeProfData *data, int *idFlange)
cvxPartSmdFlatten
evxErrors cvxPartSmdFlatten(const svxSmdFlattenData *data, int *idFtr)
cvxPartSmdPunchInit
evxErrors cvxPartSmdPunchInit(svxPunchData *data)
cvxPartSmdProfFlangeInit
evxErrors cvxPartSmdProfFlangeInit(svxSmdFlangeProfData *data)
cvxPartSmdBendTaperDefDataInit
evxErrors cvxPartSmdBendTaperDefDataInit(int taperType, svxSmdBendTaperDefData *data)
cvxPartSmdFoldByLineInit
evxErrors cvxPartSmdFoldByLineInit(svxSmdFoldByLineData *data)
cvxPartSmdLouver
evxErrors cvxPartSmdLouver(const svxLouverData *LouverData, int *idSmdLouver)
cvxPartSmdHemFlangeInit
evxErrors cvxPartSmdHemFlangeInit(int hemType, svxSmdHemFlangeData *data)
cvxPartSmdDimple
evxErrors cvxPartSmdDimple(svxDimpleData *Dimple, int *idDimple)
cvxPartSmdExtrudeTabInit
evxErrors cvxPartSmdExtrudeTabInit(svxSmdExtrudeTabData *data)
cvxPartSmdChangeBendInit
evxErrors cvxPartSmdChangeBendInit(evxSmdChangeBendType type, svxSmdChangeBendData *data)
cvxPartSmdPunch
evxErrors cvxPartSmdPunch(const svxPunchData *pData, int *idShape)
cvxPartSmdLouverInit
evxErrors cvxPartSmdLouverInit(svxLouverData *data)
cvxPartSmdCloseCornerInit
evxErrors cvxPartSmdCloseCornerInit(int type, svxCloseCornerData *data)
cvxPartSmdUnfold
evxErrors cvxPartSmdUnfold(const svxUnfoldData *Unfold, int *idSmdUnfold)
cvxPartSmdSweptFlangeInit
evxErrors cvxPartSmdSweptFlangeInit(evxSmdCornerRelief corType, svxSmdSweptFlangeData *data)
cvxPartSmdJog
evxErrors cvxPartSmdJog(const svxSmdJogData *data, int *idJog)
cvxPartSmdNormalCut
evxErrors cvxPartSmdNormalCut(const svxNormalCutData *pData, int *numShape, int **idShapes)
cvxPartSmdMarkBendInit
evxErrors cvxPartSmdMarkBendInit(svxSmdMarkBendData *data)
cvxPartSmdNormalCutinit
evxErrors cvxPartSmdNormalCutinit(svxNormalCutData *data)
cvxPartSmdExtrudeFlange
evxErrors cvxPartSmdExtrudeFlange(const svxExtrudeFlangeData *data, int *idExtFlange)
cvxPartSmdLftFlangeInit
evxErrors cvxPartSmdLftFlangeInit(evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData *data)
cvxPartSmdReliefDataInit
evxErrors cvxPartSmdReliefDataInit(svxSmdReliefData *data)
cvxPartSmdBendTaperInit
evxErrors cvxPartSmdBendTaperInit(evxSmdTaperSideMethod method, svxSmdBendTaperData *data)
cvxPartSmdCloseCorner
evxErrors cvxPartSmdCloseCorner(const svxCloseCornerData *CornerData, int *idSmdCorner)
cvxPartSmdRipInit
evxErrors cvxPartSmdRipInit(svxSmdRipData *data)
cvxPartSmdPartialFlangeInit
evxErrors cvxPartSmdPartialFlangeInit(svxSmdPartialFlangeData *data)
cvxPartSmdFold
evxErrors cvxPartSmdFold(const svxFoldData *Fold, int *idSmdFold)
cvxPartSmdJogInit
evxErrors cvxPartSmdJogInit(svxSmdJogData *data)
cvxPartSmdRip
evxErrors cvxPartSmdRip(const svxSmdRipData *data, int *idFtr)
evxDistanceMethod
evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
Definition: zwapi_cmd_subcmd_data.h:57
VX_TO_POINT
@ VX_TO_POINT
the start/end field by the to point method
Definition: zwapi_cmd_subcmd_data.h:60
VX_INPU_VALUE
@ VX_INPU_VALUE
the start/end field by the input number
Definition: zwapi_cmd_subcmd_data.h:58
VX_BY_THROUGH_ALL
@ VX_BY_THROUGH_ALL
the start/end field by the through all method
Definition: zwapi_cmd_subcmd_data.h:59
VX_TO_FACE
@ VX_TO_FACE
the start/end field by the to extend face method (normal cut)
Definition: zwapi_cmd_subcmd_data.h:63
cvxConfigGetString
evxErrors cvxConfigGetString(const char *Name, char *Str, int nBytes)
cvxFileOpenListByLongPath
void cvxFileOpenListByLongPath(int *count, vxLongPath **fileList)
cvxFileInqActive
void cvxFileInqActive(char *Name, int nBytes)
cvxEntSketch
void cvxEntSketch(int idEntity, int *idSketch)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxGlobalGet
evxErrors cvxGlobalGet(evxGlobal Global, void *Data)
VX_TOLERANCE
@ VX_TOLERANCE
proximity tolerance (double)
Definition: zwapi_global_apply.h:42
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxPartSmdStatFaceSet
evxErrors cvxPartSmdStatFaceSet(int idFace, int *idFtr)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
cvxGetFileByLongPath
void cvxGetFileByLongPath(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
VX_ENT_LINE2
@ VX_ENT_LINE2
2D line
Definition: zwapi_util.h:929
svxCloseCornerData::CornerData::svxByEdge::Edg2Pnt
svxPntOnEnt Edg2Pnt
second face edge
Definition: zwapi_cmd_sheetmetal_data.h:997
svxCloseCornerData::CornerData::svxByEdge::Edg1Pnt
svxPntOnEnt Edg1Pnt
first face edge
Definition: zwapi_cmd_sheetmetal_data.h:996
svxCloseCornerData::CornerData::svxByFace::idBend2
int idBend2
second bend face
Definition: zwapi_cmd_sheetmetal_data.h:1003
svxCloseCornerData::CornerData::svxByFace::dWidth
double dWidth
specify width for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1015
svxCloseCornerData::CornerData::svxByFace::dLength
double dLength
specify length for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1014
svxCloseCornerData::CornerData::svxByFace::dDiam
double dDiam
diameter(4.0 as default, use it when Relief!=VX_CORNER_CLOSED && Relief!=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1013
svxCloseCornerData::CornerData::svxByFace::idBend1
int idBend1
first bend face
Definition: zwapi_cmd_sheetmetal_data.h:1002
svxCloseCornerData::CornerData::svxByFace::OrgType
int OrgType
0-bend center, 1-corner point(1 as default, and it works when Relief != VX_CORNER_CLOSED)
Definition: zwapi_cmd_sheetmetal_data.h:1011
svxCloseCornerData::CornerData::svxByFace::CloseFlange
int CloseFlange
close the whole flange or not(1 as default) if set to 1, it closes all sub corners with the basic one...
Definition: zwapi_cmd_sheetmetal_data.h:1004
svxCloseCornerData::CornerData::svxByFace::dAng1
double dAng1
specify first angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1016
svxCloseCornerData::CornerData::svxByFace::dAng2
double dAng2
specify second angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1017
svxCloseCornerData::CornerData::svxByFace::Relief
evxCornerReliefTyp Relief
to trim the adjoining flanges (VX_CORNER_CLOSED as default)
Definition: zwapi_cmd_sheetmetal_data.h:1010
svxCloseCornerData::CornerData::svxByFace::Miter
int Miter
miter corner or not (1 as default) if set to 0, use straight lines to form the outline of the cuter w...
Definition: zwapi_cmd_sheetmetal_data.h:1007
svxCloseCornerData::CornerData::svxByFace::dOffset
double dOffset
specify offset distance for origin (0.0 as default, use it when Relief!=VX_CORNER_CLOSED)
Definition: zwapi_cmd_sheetmetal_data.h:1012
svxCloseCornerData::dGap
double dGap
(0.1mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1022
svxCloseCornerData::Overlp
evxCornerOverlapTyp Overlp
(VX_CONER_NATURAL as default)
Definition: zwapi_cmd_sheetmetal_data.h:1021
svxCloseCornerData::type
int type
method, 0-close by edge, 1- close by bend(face)(0 as default)
Definition: zwapi_cmd_sheetmetal_data.h:991
svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default ...
Definition: zwapi_cmd_sheetmetal_data.h:990
svxDimpleData::prfOnDimpleTop
int prfOnDimpleTop
1-the top of the dimple is the size of the outline, and the bottom changes with the angle; 0-the bott...
Definition: zwapi_cmd_sheetmetal_data.h:1143
svxDimpleData::ftrName
vxName ftrName
feature name for "SmdDimple", 0 default
Definition: zwapi_cmd_sheetmetal_data.h:1149
svxDimpleData::radius1
double radius1
inner radius around the perimeter height of the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1137
svxDimpleData::radius3
double radius3
the outer fillet radius of the outside wall (default:1.0, 0.0-disable) doesn't use if dimpleType = 1
Definition: zwapi_cmd_sheetmetal_data.h:1139
svxDimpleData::dimpleType
int dimpleType
dimple type (0 = Plain Dimple, 1 = Flared Hole)
Definition: zwapi_cmd_sheetmetal_data.h:1125
svxDimpleData::numShapes
int numShapes
number of shapes to sew
Definition: zwapi_cmd_sheetmetal_data.h:1132
svxDimpleData::height
double height
height measured from the selected face to the outside face of the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1135
svxDimpleData::flipFlange
int flipFlange
1-flip the normal direction of the plane where the dimple is placed, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:1142
svxDimpleData::postion
evxDimplePostion postion
postion type (default: VX_MATERIAL_OUTSIDE) dimpleType = 1, VX_BEND_OUTSIDE does not contain
Definition: zwapi_cmd_sheetmetal_data.h:1146
svxDimpleData::idProfile
int idProfile
id of sketch defining the dimple perimeter, the sketch must be a closed sketch with one or more tange...
Definition: zwapi_cmd_sheetmetal_data.h:1127
svxDimpleData::angle
double angle
the side angle measured from the selected face
Definition: zwapi_cmd_sheetmetal_data.h:1136
svxDimpleData::idPlane
int idPlane
id of planar face to place the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1126
svxDimpleData::idShapes
int * idShapes
list of id's of shapes to sew
Definition: zwapi_cmd_sheetmetal_data.h:1133
svxDimpleData::radius2
double radius2
outer radius around the perimeter of the dimple and tangent to the selected face
Definition: zwapi_cmd_sheetmetal_data.h:1138
svxDimpleData
dimple data
Definition: zwapi_cmd_sheetmetal_data.h:1124
svxEntPath::Id
int Id[V_PP_LEN]
list of id's that define the path to an entity Id[0] = -1; path begins with top-level parent file/o...
Definition: zwapi_util.h:270
svxExtrudeFlangeData::end
double end
end distance
Definition: zwapi_cmd_sheetmetal_data.h:221
svxExtrudeFlangeData::kValue
double * kValue
k_factor. NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:228
svxExtrudeFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use default K-Factor indicates the location of the neutral axis wit...
Definition: zwapi_cmd_sheetmetal_data.h:225
svxExtrudeFlangeData::PntOnCrv
svxPntOnEnt * PntOnCrv
rip point, point on curve, (NULL to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:229
svxExtrudeFlangeData::radius
double * radius
radius NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:224
svxExtrudeFlangeData::thickness
double * thickness
thickness. NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:222
svxExtrudeFlangeData::isOpposite
int isOpposite
1 if opposite the direction of the flange, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:223
svxExtrudeFlangeData::extType
evxExtFlangeType extType
extrude type
Definition: zwapi_cmd_sheetmetal_data.h:219
svxExtrudeFlangeData::start
double start
start distance
Definition: zwapi_cmd_sheetmetal_data.h:220
svxExtrudeFlangeData::idProfile
int idProfile
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:218
svxExtrudeFlangeData::RipSize
double RipSize
rip size. the minimum value of "RipSize" is twice the tolerance
Definition: zwapi_cmd_sheetmetal_data.h:230
svxExtrudeFlangeData
template command Smd Extrude Flange data
Definition: zwapi_cmd_sheetmetal_data.h:217
svxFoldData::idCrv
int * idCrv
curve list on the sheet metal(NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1186
svxFoldData::idBendFace
int * idBendFace
Bend faces id (NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1184
svxFoldData::CrvCnts
int CrvCnts
Curve list counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1185
svxFoldData::BendFaceCnts
int BendFaceCnts
Bend face counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1183
svxFoldData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1181
svxFoldData::idStationary
int idStationary
Stationary face id (0/-1 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1182
svxFoldData
template command Smd Fold data
Definition: zwapi_cmd_sheetmetal_data.h:1180
svxLoftBndCons::continuity
int continuity
specify the continuity level at end of loft (0 = None, 1 = tangent, 2 = curvature,...
Definition: zwapi_cmd_subcmd_data.h:72
svxLoftBndCons::weight
double weight
specify the amount of the loft affected by the enforcement of tangency
Definition: zwapi_cmd_subcmd_data.h:74
svxLoftBndCons::direction
int direction
specify direction of loft at start and end profiles (0 = perpendicular, 1 = along edges)
Definition: zwapi_cmd_subcmd_data.h:73
svxLouverData::dAng
double dAng
louver angle (45deg as default)
Definition: zwapi_cmd_sheetmetal_data.h:1161
svxLouverData::idProf
int idProf
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:1159
svxLouverData::Flip
int Flip
whether to flip the louver 180 degrees about the sketch line(0-no as default, 1-yes)
Definition: zwapi_cmd_sheetmetal_data.h:1165
svxLouverData::idPlane
int idPlane
id of planar face for louver placement
Definition: zwapi_cmd_sheetmetal_data.h:1158
svxLouverData::dHeight
double dHeight
louver height (3.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1160
svxLouverData::cntSew
int cntSew
count of sew shapes
Definition: zwapi_cmd_sheetmetal_data.h:1168
svxLouverData::dR2
double dR2
2nd louver radius (1.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1163
svxLouverData::dWidth
double dWidth
louver width (6.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1164
svxLouverData::pSewShape
int * pSewShape
id list of sew shapes (NULL to sew with all shapes)
Definition: zwapi_cmd_sheetmetal_data.h:1169
svxLouverData::dR1
double dR1
1st louver radius (1.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1162
svxLouverData
template command Smd Louver data
Definition: zwapi_cmd_sheetmetal_data.h:1157
svxNormalCutData::cntShape
int cntShape
Cut Shapes count.
Definition: zwapi_cmd_sheetmetal_data.h:942
svxNormalCutData::idProfile
int idProfile
Profile P.
Definition: zwapi_cmd_sheetmetal_data.h:941
svxNormalCutData::endType
evxDistanceMethod endType
end type (0 = input value, 1 = through all, 2= to point, 5 = to face)
Definition: zwapi_cmd_sheetmetal_data.h:951
svxNormalCutData::Flip
int Flip
Flip side to cut, default value:0.
Definition: zwapi_cmd_sheetmetal_data.h:948
svxNormalCutData::idStartEnt
int idStartEnt
the entity id of start field if startType > 1
Definition: zwapi_cmd_sheetmetal_data.h:952
svxNormalCutData::dStart
double dStart
Start S, default value:10.0.
Definition: zwapi_cmd_sheetmetal_data.h:945
svxNormalCutData::cutType
evxNormCutTyp cutType
normal cut option, default value:VX_NORMCUT_BOTHSIDES
Definition: zwapi_cmd_sheetmetal_data.h:940
svxNormalCutData::dEnd
double dEnd
End E, default value:-10.0.
Definition: zwapi_cmd_sheetmetal_data.h:946
svxNormalCutData::Dir
svxVector * Dir
Direction (NULL can be ignored)
Definition: zwapi_cmd_sheetmetal_data.h:947
svxNormalCutData::idEndEnt
int idEndEnt
the entity id of end field if endType > 1
Definition: zwapi_cmd_sheetmetal_data.h:953
svxNormalCutData::startType
evxDistanceMethod startType
start type (0 = input value, 1 = through all, 2= to point, 5 = to face)
Definition: zwapi_cmd_sheetmetal_data.h:950
svxNormalCutData::startToPnt
svxPoint * startToPnt
if startType = 2, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:954
svxNormalCutData::shapeList
int * shapeList
Cut Shapes List.
Definition: zwapi_cmd_sheetmetal_data.h:943
svxNormalCutData::endToPnt
svxPoint * endToPnt
if endType = 2, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:955
svxNormalCutData::extType
evxExtrudeType extType
extrude type, default value:VX_EXTRUDE_TYPE_ONESIDE
Definition: zwapi_cmd_sheetmetal_data.h:944
svxNormalCutData
template command Smd Normal Cut data
Definition: zwapi_cmd_sheetmetal_data.h:939
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxPunchCons::Flip
int Flip
1-flip the alignment direction, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1065
svxPunchCons::pathEnt1
svxEntPath pathEnt1
first entity path (initialize as(2,-1,idEnt))
Definition: zwapi_cmd_sheetmetal_data.h:1056
svxPunchCons::alignTyp
evxConsType alignTyp
alignment type (default value: VX_CONCENTRIC)
Definition: zwapi_cmd_sheetmetal_data.h:1054
svxPunchCons::ent1FormFile
int ent1FormFile
1 if the first entity from the punch file, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1057
svxPunchCons::pathEnt2
svxEntPath pathEnt2
second entity path (initialize as(2,-1,idEnt))
Definition: zwapi_cmd_sheetmetal_data.h:1058
svxPunchCons::dOffset
double dOffset
offset value (default value: 0)
Definition: zwapi_cmd_sheetmetal_data.h:1061
svxPunchCons::ent2FormFile
int ent2FormFile
1 if the second entity from the punch file, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1059
svxPunchCons
punch constraint
Definition: zwapi_cmd_sheetmetal_data.h:1053
svxPunchData::LocData::ByCons::cntCons
int cntCons
count of constraint data (0 to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1102
svxPunchData::LocData::ByCons::punchCons
svxPunchCons * punchCons
constraint data list(NUll to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1103
svxPunchData::LocData::ByPnt::idFrame
int idFrame
Frame, used option in VX_PUNCH_FILE (-1/0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1097
svxPunchData::punchTyp
evxPunchTyp punchTyp
Punch option, default value:VX_PUNCH_SHAPE.
Definition: zwapi_cmd_sheetmetal_data.h:1074
svxPunchData::addFillet2
int addFillet2
fillet non placement edges,default value:0
Definition: zwapi_cmd_sheetmetal_data.h:1082
svxPunchData::locTyp
evxPunchLocType locTyp
location Type, default value:VX_LOCATION_POINT
Definition: zwapi_cmd_sheetmetal_data.h:1088
svxPunchData::dRadius
double dRadius
radius for dRadius, default value:5
Definition: zwapi_cmd_sheetmetal_data.h:1081
svxPunchData::localPnt
svxPoint localPnt
punch point, used option in VX_PUNCH_FILE(default:(0,0,0))
Definition: zwapi_cmd_sheetmetal_data.h:1089
svxPunchData::cntOpen
int cntOpen
count of open faces (0 to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1076
svxPunchData::addFillet
int addFillet
fillet placement edges,default value:0 if set to 1, user can set the fillet radius of intersected edg...
Definition: zwapi_cmd_sheetmetal_data.h:1079
svxPunchData::relation
int relation
Related with source, default value:1, used option in VX_PUNCH_FILE if set to 1, the punch result chan...
Definition: zwapi_cmd_sheetmetal_data.h:1090
svxPunchData::idBase
int idBase
boundary face on base (face id)
Definition: zwapi_cmd_sheetmetal_data.h:1075
svxPunchData::pathPunch
vxLongPath pathPunch
punch file path, used option in VX_PUNCH_FILE
Definition: zwapi_cmd_sheetmetal_data.h:1087
svxPunchData::pOpenList
int * pOpenList
open faces from punch shape (NULL to ignore) if punchTyp = VX_PUNCH_FILE, pOpenList must from the pun...
Definition: zwapi_cmd_sheetmetal_data.h:1077
svxPunchData::idPunch
int idPunch
a punch shape (shape id)
Definition: zwapi_cmd_sheetmetal_data.h:1085
svxPunchData::dRadius2
double dRadius2
radius for addFillet2, default value:5
Definition: zwapi_cmd_sheetmetal_data.h:1083
svxPunchData
Punch data.
Definition: zwapi_cmd_sheetmetal_data.h:1073
svxSmdBendTaperData::opposite
int opposite
Check(opposite=1) this box to flip the arrows, and system will reset the stationary face....
Definition: zwapi_cmd_sheetmetal_data.h:907
svxSmdBendTaperData::defData2
svxSmdBendTaperDefData defData2
apply it if method = VX_SMD_TAPER_SIDES_BOTH,else ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:910
svxSmdBendTaperData::defData
svxSmdBendTaperDefData defData
bend taper definition side data
Definition: zwapi_cmd_sheetmetal_data.h:909
svxSmdBendTaperData::idBend
int idBend
Select a bend face to taper one or both sides of the flange. The edges of the flange are tapered in t...
Definition: zwapi_cmd_sheetmetal_data.h:905
svxSmdBendTaperData
template command Smd bend taper data
Definition: zwapi_cmd_sheetmetal_data.h:904
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::method
int method
0 is setback,Specify a distance value to taper the bend. 1 is end radius,Specify an angle value to ...
Definition: zwapi_cmd_sheetmetal_data.h:869
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::value
double value
Angle or setback.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:872
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::isAutoCompute
int isAutoCompute
1 is auto compute radius,else 0. default:1
Definition: zwapi_cmd_sheetmetal_data.h:877
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::eRadius
double eRadius
end radius. apply it if isAutoCompute=0. default:2
Definition: zwapi_cmd_sheetmetal_data.h:879
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::sRadius
double sRadius
start radius. apply it if isAutoCompute=0. default:2
Definition: zwapi_cmd_sheetmetal_data.h:878
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::setback
double setback
Specify the distance value to taper.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:876
svxSmdBendTaperDefData::angle
double angle
apply it if webTaperType != VX_SMD_TAPER_WEB_NONE, else ignore it.default:5
Definition: zwapi_cmd_sheetmetal_data.h:884
svxSmdBendTaperDefData::webTaperType
evxSmdWebTaperType webTaperType
Creates tapers that start from the web.default:VX_SMD_TAPER_WEB_NONE.
Definition: zwapi_cmd_sheetmetal_data.h:883
svxSmdBendTaperDefData::taperType
int taperType
0 is linear,Use an angle value or a distance value to taper the bend. 1 is tangent,...
Definition: zwapi_cmd_sheetmetal_data.h:862
svxSmdBendTaperDefData
smd bend taper definition side data
Definition: zwapi_cmd_sheetmetal_data.h:861
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1274
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::angle
double angle
Set the angle of bends.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1273
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1276
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1275
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1282
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1280
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1281
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::stationary
int stationary
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:1286
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::angle
double angle
Set the angle of bends.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1287
svxSmdChangeBendData::bendFcs
int * bendFcs
Select the bend faces to change.
Definition: zwapi_cmd_sheetmetal_data.h:1267
svxSmdChangeBendData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1266
svxSmdChangeBendData::type
evxSmdChangeBendType type
Specify change bend type from the following.default:VX_SMD_CHANGE_BEND_DEFAULT.
Definition: zwapi_cmd_sheetmetal_data.h:1265
svxSmdChangeBendData::radius
double radius
Set the radius of bends.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:1268
svxSmdChangeBendData
template command Smd change bend data
Definition: zwapi_cmd_sheetmetal_data.h:1264
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::idPlane
int idPlane
Specify a plane or datum as reference object.
Definition: zwapi_cmd_sheetmetal_data.h:828
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::offset
double offset
Specify the distance between the plane and the edge.default:0 The flange will extend beyond the plane...
Definition: zwapi_cmd_sheetmetal_data.h:829
svxSmdExtendFlangeData::idEdge
int idEdge
Select a edge to extend.
Definition: zwapi_cmd_sheetmetal_data.h:819
svxSmdExtendFlangeData::extendSrfToEdge2
int extendSrfToEdge2
Check this box to extend the bend adjacent to the edge together.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:839
svxSmdExtendFlangeData::sideType2
evxSmdExtendSideMethod sideType2
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_S...
Definition: zwapi_cmd_sheetmetal_data.h:837
svxSmdExtendFlangeData::type
evxSmdExtendFlangeMethod type
extend type.default:VX_SMD_EXTEND_BY_VALUE
Definition: zwapi_cmd_sheetmetal_data.h:818
svxSmdExtendFlangeData::sideType1
evxSmdExtendSideMethod sideType1
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_S...
Definition: zwapi_cmd_sheetmetal_data.h:834
svxSmdExtendFlangeData::extendSrfToEdge1
int extendSrfToEdge1
Check this box to extend the bend adjacent to the edge together.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:836
svxSmdExtendFlangeData
template command Smd Extend Flange data
Definition: zwapi_cmd_sheetmetal_data.h:817
svxSmdExtrudeTabData::isMerge
int isMerge
1 if merge, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:205
svxSmdExtrudeTabData::isOpposite
int isOpposite
1 if opposite the direction of the tab, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:206
svxSmdExtrudeTabData::Thickness
double * Thickness
thickness. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:204
svxSmdExtrudeTabData::idProfile
int idProfile
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:203
svxSmdExtrudeTabData::idMergeShape
int idMergeShape
id of the shape to be merged. Note:since 2700, this parameter must be set, if you don't set this para...
Definition: zwapi_cmd_sheetmetal_data.h:207
svxSmdExtrudeTabData
template command Smd Extrude Tab data
Definition: zwapi_cmd_sheetmetal_data.h:202
svxSmdFlangeProfData::isRelief
int isRelief
1 if relief for insufficient length , else 0 as default if set to 1, user can create relief for parti...
Definition: zwapi_cmd_sheetmetal_data.h:434
svxSmdFlangeProfData::tol
double * tol
Flat Tolerance. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:441
svxSmdFlangeProfData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:437
svxSmdFlangeProfData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:418
svxSmdFlangeProfData::radius
double * radius
radius. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:424
svxSmdFlangeProfData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:426
svxSmdFlangeProfData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:427
svxSmdFlangeProfData::idProfile
int * idProfile
id of profile, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:419
svxSmdFlangeProfData::offset
double * offset
offset, specify the offset value of the flange. if *position = VX_POSITION_OFFSET,...
Definition: zwapi_cmd_sheetmetal_data.h:421
svxSmdFlangeProfData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:420
svxSmdFlangeProfData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:438
svxSmdFlangeProfData::angle
double angle
angle (0-180). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:425
svxSmdFlangeProfData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:439
svxSmdFlangeProfData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:432
svxSmdFlangeProfData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:429
svxSmdFlangeProfData
template command Smd Flange with Profile data
Definition: zwapi_cmd_sheetmetal_data.h:417
svxSmdFlattenData::dirPMI
svxVector dirPMI
linear PMI direction.
Definition: zwapi_cmd_sheetmetal_data.h:1223
svxSmdFlattenData::ignoreTangent
int ignoreTangent
Check(=1) this option if user wants to adjsut the tangent edges from flat pattern that can be shown o...
Definition: zwapi_cmd_sheetmetal_data.h:1218
svxSmdFlattenData::idFace
int idFace
Select the bend faces to flatten.0/-1 to ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:1210
svxSmdFlattenData::includePattern
int includePattern
Check(=1) this option if user wants to quickly project to the generated flat view of sheet metal mode...
Definition: zwapi_cmd_sheetmetal_data.h:1214
svxSmdFlattenData::offset
double offset
Set the offset distance between the flatten entity and the flatten pattern.default:20.
Definition: zwapi_cmd_sheetmetal_data.h:1211
svxSmdFlattenData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1209
svxSmdFlattenData::direction
svxVector direction
Select the direction for offset.
Definition: zwapi_cmd_sheetmetal_data.h:1213
svxSmdFlattenData::useDirPMI
int useDirPMI
1 is use PMI direction, else 0. default:0
Definition: zwapi_cmd_sheetmetal_data.h:1222
svxSmdFlattenData::useDir
int useDir
1 is use direction, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:1212
svxSmdFlattenData
template command Smd flatten data
Definition: zwapi_cmd_sheetmetal_data.h:1208
svxSmdFoldByLineData::position
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.
Definition: zwapi_cmd_sheetmetal_data.h:757
svxSmdFoldByLineData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:760
svxSmdFoldByLineData::radius
double radius
Specify the inner radius value of bend.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:759
svxSmdFoldByLineData::angle
double angle
Specify the bend angle.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:758
svxSmdFoldByLineData::idProfile
int idProfile
id of sketch, if idLine is one curve of the sketch (-1/0 if idLine is a line or a sketch)
Definition: zwapi_cmd_sheetmetal_data.h:754
svxSmdFoldByLineData::flipSide
int flipSide
bend direction, 1- flip side to keep, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:756
svxSmdFoldByLineData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:762
svxSmdFoldByLineData::idLine
int idLine
Select a line. It can be a 3 dimensional line or a sketch line.
Definition: zwapi_cmd_sheetmetal_data.h:753
svxSmdFoldByLineData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:761
svxSmdFoldByLineData::idFace
int idFace
Specify the plane face where inner bends are created.
Definition: zwapi_cmd_sheetmetal_data.h:755
svxSmdFoldByLineData
template command Smd Fold by Line data
Definition: zwapi_cmd_sheetmetal_data.h:752
svxSmdFullFlangeData::radius2
double * radius2
radius r2, if bend = 0, ignore this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:375
svxSmdFullFlangeData::isDefSepa
int isDefSepa
1 if define each side separately, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:379
svxSmdFullFlangeData::corOffset
double * corOffset
offset. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:404
svxSmdFullFlangeData::gap
double gap
Gap. 0.5 is default.
Definition: zwapi_cmd_sheetmetal_data.h:368
svxSmdFullFlangeData::isResolve
int isResolve
1 if resolve flange interference ,else 0 as default 1-to make the flanges not intersect when the crea...
Definition: zwapi_cmd_sheetmetal_data.h:366
svxSmdFullFlangeData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:373
svxSmdFullFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:360
svxSmdFullFlangeData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:374
svxSmdFullFlangeData::corAngle1
double * corAngle1
angle 1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:408
svxSmdFullFlangeData::isMiter
int * isMiter
1 if miter corner, else 0. NULL to use global default if set to 0, use straight lines to form the o...
Definition: zwapi_cmd_sheetmetal_data.h:399
svxSmdFullFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:363
svxSmdFullFlangeData::idEdges
int * idEdges
list of idEdge
Definition: zwapi_cmd_sheetmetal_data.h:356
svxSmdFullFlangeData::corRelief
evxSmdCornerRelief * corRelief
corner relief type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:395
svxSmdFullFlangeData::corGap
double * corGap
corner Gap. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:402
svxSmdFullFlangeData::isCorner
int * isCorner
1 if close corner, else 0. NULL to use global default if isCorner = 0, ignore the following varia...
Definition: zwapi_cmd_sheetmetal_data.h:396
svxSmdFullFlangeData::corOrigin
int * corOrigin
0 is bend center, 1 is corner point. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:403
svxSmdFullFlangeData::sBendSize
int sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this.
Definition: zwapi_cmd_sheetmetal_data.h:376
svxSmdFullFlangeData::corWidth
double * corWidth
width. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:406
svxSmdFullFlangeData::radius1
double * radius1
radius r1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:371
svxSmdFullFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:380
svxSmdFullFlangeData::position
evxSmdPosition * position
flange parameters position. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:358
svxSmdFullFlangeData::corDiameter
double * corDiameter
diameter. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:407
svxSmdFullFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:381
svxSmdFullFlangeData::count
int count
count of "idEdges"
Definition: zwapi_cmd_sheetmetal_data.h:355
svxSmdFullFlangeData::tol
double * tol
Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state....
Definition: zwapi_cmd_sheetmetal_data.h:364
svxSmdFullFlangeData::isFlip
int isFlip
indicate flange direction: 1 if flip the flanges, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:357
svxSmdFullFlangeData::offset
double * offset
offset, if position = VX_POSITION_OFFSET,apply it. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:359
svxSmdFullFlangeData::angle
double angle
angle (> 0). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:372
svxSmdFullFlangeData::corLength
double * corLength
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:405
svxSmdFullFlangeData::Size
double Size
size (height or length), if bend = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:377
svxSmdFullFlangeData::corAngle2
double * corAngle2
angle 2. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:409
svxSmdFullFlangeData::bend
int bend
bend, 0 if simple, 1 if S bend. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:370
svxSmdFullFlangeData
template command Smd Full Flange data
Definition: zwapi_cmd_sheetmetal_data.h:354
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::idEdges
int * idEdges
list of idEdge.
Definition: zwapi_cmd_sheetmetal_data.h:510
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::count
int count
count of idEdges
Definition: zwapi_cmd_sheetmetal_data.h:509
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::gapSize
double gapSize
miter gap size. if isMiterHem = 1, apply it. default is 0.1
Definition: zwapi_cmd_sheetmetal_data.h:513
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::isMiterHem
int isMiterHem
1 if miter hem, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:512
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:517
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthType
int widthType
0 is Start-Width, 1 is Start-End. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:518
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::isRelief
int isRelief
1 if relief for insufficient length, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:522
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::start
double start
start(>=0)
Definition: zwapi_cmd_sheetmetal_data.h:519
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthPnt
svxPntOnEnt * widthPnt
use "To Point" to get the value of "width" (NULL to use width)
Definition: zwapi_cmd_sheetmetal_data.h:526
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::end
double end
end(>=start). if widthType = 1, using this
Definition: zwapi_cmd_sheetmetal_data.h:520
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::endPnt
svxPntOnEnt * endPnt
use "To Point" to get the value of "end" (NULL to use end)
Definition: zwapi_cmd_sheetmetal_data.h:525
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::width
double width
width(>=start). if widthType = 0 ,using this
Definition: zwapi_cmd_sheetmetal_data.h:521
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::startPnt
svxPntOnEnt * startPnt
use "To Point" to get the value of "start" (NULL to use start)
Definition: zwapi_cmd_sheetmetal_data.h:524
svxSmdHemFlangeData::hemType
int hemType
0 is Full hem, 1 is Partial hem. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:503
svxSmdHemFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:553
svxSmdHemFlangeData::offset
double * offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:531
svxSmdHemFlangeData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:558
svxSmdHemFlangeData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:530
svxSmdHemFlangeData::isEqual
int isEqual
1 if equal radii ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:546
svxSmdHemFlangeData::radius1
double * radius1
Radius R1. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:549
svxSmdHemFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:556
svxSmdHemFlangeData::bendType
evxSmdHemBendType bendType
bend type. default is VX_SMD_HEM_BEND_CLOSED
Definition: zwapi_cmd_sheetmetal_data.h:545
svxSmdHemFlangeData::length1
double length1
Length L1.
Definition: zwapi_cmd_sheetmetal_data.h:547
svxSmdHemFlangeData::isFlip
int isFlip
1 if flip the hems, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:504
svxSmdHemFlangeData::angle
double angle
angle( >1). 270 as default
Definition: zwapi_cmd_sheetmetal_data.h:551
svxSmdHemFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:559
svxSmdHemFlangeData::length2
double length2
Length L2.
Definition: zwapi_cmd_sheetmetal_data.h:548
svxSmdHemFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:560
svxSmdHemFlangeData::radius2
double * radius2
Radius R2. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:550
svxSmdHemFlangeData
template command Smd Hem Flange data
Definition: zwapi_cmd_sheetmetal_data.h:502
svxSmdJogData::keepProjLen
int keepProjLen
1 is keep the projection length, else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:780
svxSmdJogData::reverseSide
int reverseSide
1 is reverse the stationary side, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:773
svxSmdJogData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:783
svxSmdJogData::position
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.
Definition: zwapi_cmd_sheetmetal_data.h:781
svxSmdJogData::idFace
int idFace
id face.Specify the plane face where inner bends are created.
Definition: zwapi_cmd_sheetmetal_data.h:772
svxSmdJogData::idLine
int idLine
id line. Make sure it is a straight line.
Definition: zwapi_cmd_sheetmetal_data.h:771
svxSmdJogData::heightType
int heightType
0 is inner: Measure the height from the sketch plane of the fold line, extend to the total height....
Definition: zwapi_cmd_sheetmetal_data.h:774
svxSmdJogData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:785
svxSmdJogData::height
double height
input a value to define the height of the jog.default:40
Definition: zwapi_cmd_sheetmetal_data.h:779
svxSmdJogData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:784
svxSmdJogData::radius
double radius
Specify the inner radius value of bend.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:782
svxSmdJogData
template command Smd Jog data
Definition: zwapi_cmd_sheetmetal_data.h:770
svxSmdLinearUnfoldData::bendFcs
int * bendFcs
Specify bend faces to lay out.
Definition: zwapi_cmd_sheetmetal_data.h:1234
svxSmdLinearUnfoldData::angle
double angle
Specify the angle to unfold.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1235
svxSmdLinearUnfoldData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1237
svxSmdLinearUnfoldData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1238
svxSmdLinearUnfoldData::idFace
int idFace
Specify the face to fix.0/-1 to ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:1232
svxSmdLinearUnfoldData::dir
svxVector dir
Select linear unfold direction.default:{1,0,0}.
Definition: zwapi_cmd_sheetmetal_data.h:1242
svxSmdLinearUnfoldData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1233
svxSmdLinearUnfoldData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1239
svxSmdLinearUnfoldData::addStatus
int addStatus
Check(=1) this option to create a newly copied part which is associative with the original one....
Definition: zwapi_cmd_sheetmetal_data.h:1241
svxSmdLinearUnfoldData::distance
double distance
Enter distance along linear unfold direction.default:0.1.
Definition: zwapi_cmd_sheetmetal_data.h:1243
svxSmdLinearUnfoldData
template command Smd linear unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1231
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:657
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutValue
double cutValue
cutting value.default:1
Definition: zwapi_cmd_sheetmetal_data.h:656
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf1
int idProf1
id of profile1
Definition: zwapi_cmd_sheetmetal_data.h:644
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutLength
double cutLength
Specify the cut length.default:1.
Definition: zwapi_cmd_sheetmetal_data.h:654
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt1
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:646
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutMethod
evxSmdLftCutMethod cutMethod
Pick the position to place the cut point.default:VX_SMD_LFG_MAX_ARC_HEIGHT.
Definition: zwapi_cmd_sheetmetal_data.h:655
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf2
int idProf2
id of profile2
Definition: zwapi_cmd_sheetmetal_data.h:649
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt2
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:651
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:659
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip2
int flip2
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:650
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip1
int flip1
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:645
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:658
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip1
int flip1
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:628
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt1
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:629
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutLength
double cutLength
Specify the cut length.default:1.
Definition: zwapi_cmd_sheetmetal_data.h:637
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf2
int idProf2
id of profile2
Definition: zwapi_cmd_sheetmetal_data.h:632
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf1
int idProf1
id of profile1
Definition: zwapi_cmd_sheetmetal_data.h:627
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:640
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:638
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt2
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:634
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:639
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip2
int flip2
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:633
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip2
int flip2
1 is flip, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:616
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines1
int * listLines1
list of line(edge/curve) id
Definition: zwapi_cmd_sheetmetal_data.h:611
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip1
int flip1
1 is flip, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:612
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::cntShps
int cntShps
count of boolShps,cntShps=0 to use default.
Definition: zwapi_cmd_sheetmetal_data.h:618
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::bndCons
svxLoftBndCons bndCons[2]
boundary constraints
Definition: zwapi_cmd_sheetmetal_data.h:620
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::boolShps
int * boolShps
Specify the boolean operation and the boolean shapes.
Definition: zwapi_cmd_sheetmetal_data.h:619
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count1
int count1
count of listLines1
Definition: zwapi_cmd_sheetmetal_data.h:610
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count2
int count2
count of listLines2
Definition: zwapi_cmd_sheetmetal_data.h:614
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines2
int * listLines2
list of line(edge/curve) id
Definition: zwapi_cmd_sheetmetal_data.h:615
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::scale
int scale
An additional scale factor that is applied to the Weight slider bar. This is only needed when the ext...
Definition: zwapi_cmd_sheetmetal_data.h:621
svxSmdLoftedFlangeData::method
evxSmdLftFlangeMethod method
Lofted Flange method.default:VX_SMD_FLATTENABLE_LOFTING.
Definition: zwapi_cmd_sheetmetal_data.h:601
svxSmdLoftedFlangeData::thickness
double thickness
Specifies the thickness for the profile.default:1. Recommended minimum value is not less than two tim...
Definition: zwapi_cmd_sheetmetal_data.h:602
svxSmdLoftedFlangeData::isOpposite
int isOpposite
1 is Flip the direction of lofted flange, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:604
svxSmdLoftedFlangeData::radius
double radius
Specifies the bend radius of profile.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:605
svxSmdLoftedFlangeData
template command Smd Lofted Flange data
Definition: zwapi_cmd_sheetmetal_data.h:600
svxSmdMarkBendData::thickness
double thickness
sheet metal thickness.default:1.0
Definition: zwapi_cmd_sheetmetal_data.h:1331
svxSmdMarkBendData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1330
svxSmdMarkBendData::bendFcs
int * bendFcs
Select the inner or outer bend faces. Bend faces can be marked while the sheet metal part is in its u...
Definition: zwapi_cmd_sheetmetal_data.h:1326
svxSmdMarkBendData::idFace
int idFace
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:1324
svxSmdMarkBendData::flatTol
double flatTol
Refers to the flat tolerance allowed for sheet metal parts in their unfolded state....
Definition: zwapi_cmd_sheetmetal_data.h:1332
svxSmdMarkBendData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1329
svxSmdMarkBendData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1328
svxSmdMarkBendData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1325
svxSmdMarkBendData
template command Smd mark bend data
Definition: zwapi_cmd_sheetmetal_data.h:1323
svxSmdPartialFlangeData::isRelief
int isRelief
1 if relief for insufficient length , else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:474
svxSmdPartialFlangeData::Size
double Size
size (height or length), if bend = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:467
svxSmdPartialFlangeData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:450
svxSmdPartialFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:472
svxSmdPartialFlangeData::angle
double angle
angle (>0). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:462
svxSmdPartialFlangeData::sBendSize
int sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this.
Definition: zwapi_cmd_sheetmetal_data.h:466
svxSmdPartialFlangeData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:475
svxSmdPartialFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:469
svxSmdPartialFlangeData::radius1
double * radius1
radius r1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:461
svxSmdPartialFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:476
svxSmdPartialFlangeData::radius2
double * radius2
radius r2, if bend = 0, ignore this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:465
svxSmdPartialFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:477
svxSmdPartialFlangeData::offset
double * offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:458
svxSmdPartialFlangeData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:464
svxSmdPartialFlangeData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:457
svxSmdPartialFlangeData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:463
svxSmdPartialFlangeData::end
double end
end(!=start). if widthType = 1, using this
Definition: zwapi_cmd_sheetmetal_data.h:455
svxSmdPartialFlangeData::width
double width
width(>=start). if widthType = 0, using this
Definition: zwapi_cmd_sheetmetal_data.h:456
svxSmdPartialFlangeData::start
double start
start(>=0)
Definition: zwapi_cmd_sheetmetal_data.h:454
svxSmdPartialFlangeData::bend
int bend
bend, 0 if simple, 1 if S bend. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:460
svxSmdPartialFlangeData::tol
double * tol
Flat Tolerance. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:479
svxSmdPartialFlangeData::isFlip
int isFlip
1 if flip the flange, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:452
svxSmdPartialFlangeData::widthType
int widthType
0 is Start-Width, 1 is Start-End. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:453
svxSmdPartialFlangeData::isRevert
int isRevert
1 if switch start point, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:451
svxSmdPartialFlangeData
template command Smd Partial Flange data
Definition: zwapi_cmd_sheetmetal_data.h:449
svxSmdReliefData::isDepthRatio
int isDepthRatio
1 if relief depth ratio, else 2 is value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:179
svxSmdReliefData::relief
evxSmdRelief relief
relief type. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:170
svxSmdReliefData::isWidthRatio
int isWidthRatio
1 if relief width ratio, else 2 is value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:176
svxSmdReliefData::ReliefDepth
double ReliefDepth
ratio or value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:180
svxSmdReliefData::ReliefWidth
double ReliefWidth
ratio or value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:177
svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.
Definition: zwapi_cmd_sheetmetal_data.h:164
svxSmdRipData::cnt
int cnt
count of ids
Definition: zwapi_cmd_sheetmetal_data.h:1313
svxSmdRipData::ids
int * ids
Choose edges/lines to create a rip.
Definition: zwapi_cmd_sheetmetal_data.h:1314
svxSmdRipData::gap
double gap
Set the gap size.default:0.1.
Definition: zwapi_cmd_sheetmetal_data.h:1315
svxSmdRipData::type
evxSmdRipType type
rip type.default:VX_SMD_RIP_BOTH_SIDES
Definition: zwapi_cmd_sheetmetal_data.h:1312
svxSmdRipData
template command Smd rip data
Definition: zwapi_cmd_sheetmetal_data.h:1311
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:702
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:699
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:700
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:701
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:694
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::length
double length
Specify the length of the Rectangular Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:710
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:709
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::width
double width
Specify the width of the Rectangular Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:711
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:707
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:708
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:716
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:717
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:718
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:719
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle1
double angle1
Specify the angle of the V Cutout.default:30.
Definition: zwapi_cmd_sheetmetal_data.h:728
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:726
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:724
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:725
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle2
double angle2
Specify the angle of the V Cutout.default:30.
Definition: zwapi_cmd_sheetmetal_data.h:729
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:727
svxSmdSweptFlangeData::idFace
int idFace
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:670
svxSmdSweptFlangeData::miterCorner
int miterCorner
1 is miter corner, else 0. default:1.
Definition: zwapi_cmd_sheetmetal_data.h:689
svxSmdSweptFlangeData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:686
svxSmdSweptFlangeData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:684
svxSmdSweptFlangeData::offset
double offset
specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore....
Definition: zwapi_cmd_sheetmetal_data.h:680
svxSmdSweptFlangeData::position
evxSmdPosition position
Use this option to specify the position of the added sheet metal flange. The position of the flange i...
Definition: zwapi_cmd_sheetmetal_data.h:677
svxSmdSweptFlangeData::keepMerged
int keepMerged
1 is keep merged edges, else 0. default:0
Definition: zwapi_cmd_sheetmetal_data.h:682
svxSmdSweptFlangeData::idProfile
int idProfile
Set the open, non-intersecting profile sketch used to create the sweep.
Definition: zwapi_cmd_sheetmetal_data.h:671
svxSmdSweptFlangeData::count
int count
count of sweptPath
Definition: zwapi_cmd_sheetmetal_data.h:672
svxSmdSweptFlangeData::sweptPath
int * sweptPath
Set the path along which the profile sweeps. You can select a series of existing sheet metal edges fo...
Definition: zwapi_cmd_sheetmetal_data.h:673
svxSmdSweptFlangeData::relief
evxSmdCornerRelief relief
Use this option to trim the adjoining flanges.
Definition: zwapi_cmd_sheetmetal_data.h:688
svxSmdSweptFlangeData::radius
double radius
Specifies the inner bend radius applied to flange features.
Definition: zwapi_cmd_sheetmetal_data.h:681
svxSmdSweptFlangeData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:685
svxSmdSweptFlangeData
template command Smd Swept Flange data
Definition: zwapi_cmd_sheetmetal_data.h:669
svxUnfoldData::idStationary
int idStationary
Stationary face id.
Definition: zwapi_cmd_sheetmetal_data.h:1196
svxUnfoldData::CrvCnts
int CrvCnts
Curve list counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1199
svxUnfoldData::BendFaceCnts
int BendFaceCnts
Bend face counts.
Definition: zwapi_cmd_sheetmetal_data.h:1197
svxUnfoldData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1195
svxUnfoldData::idBendFace
int * idBendFace
Bend faces id.
Definition: zwapi_cmd_sheetmetal_data.h:1198
svxUnfoldData::idCrv
int * idCrv
curve list on the sheet metal(NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1200
svxUnfoldData
template command Smd Unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1194
svxVector
3D vector
Definition: zwapi_util.h:338
svxSmdExtendFlangeData::uvxExtFlangeData::distance
double distance
Specify a value to extend.default:0.1 The flange will stretch out when you enter a positive number,...
Definition: zwapi_cmd_sheetmetal_data.h:822
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: part\wireframeFtrCrtTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
part\wireframeFtrCrtTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <stdio.h>
#include <math.h>
#include <vector>
ApiDefVoidFunc(zwTestPartLine, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartArc3pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartArcRad, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartArc, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCir3pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCirRad, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCircle, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvInt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvList, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCurve, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartLine2pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPnt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPntBlock, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPnts, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPntsOnCrv, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartEllipse, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartRectangle, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartProjStl, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCurveSilh, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFittingCrv, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartSpline, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCurveOffset, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvProjToFace, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvOnFaceThruPts, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartFaceCurve, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartExtractCenterlines, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartPolyLine, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvSplitAtPnts, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvFillet, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvChamfer, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartCrvFilletChain, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestPartBlendCrvs, VX_CODE_GENERAL);
void zwTestPartLine()
/*
DESCRIPTION:
Test case for function cvxPartLine.
*/
{
/* initialize line data */
svxLineData line = {};
if (cvxPartLineInit(&line))
zwTestLogErrorMsg(5, "cvxPartLineInit: failed to initialize data!");
double val = 0;
cvxGetNumber("Select a method to create line(0: 2pt; 1: along direction; 2: parallel line; 3: perpendicular line; 4: angled line; 5: middle point)", &val);
switch (int(val + 0.5))
{
case 0:
line.lineType = VX_LINE_2PT;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point2);
break;
case 1:
line.lineType = VX_LINE_ALONG_DIR;
zwUtilGetDirOnEntPath(VX_INP_EDGE_OR_CURVE, &line.refDir);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
cvxGetNumber("Enter length of line", &line.length);
break;
case 2:
line.lineType = VX_LINE_PARALLEL;
zwUtilGetDirOnEntPath(VX_INP_EDGE_OR_CURVE, &line.refDir);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
cvxGetNumber("Enter length of line", &line.length);
cvxGetNumber("Enter offset distance form reference direction", &line.offset);
break;
case 3:
line.lineType = VX_LINE_PERP;
zwUtilGetDirOnEntPath(VX_INP_EDGE_OR_CURVE,&line.refDir);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point2);
break;
case 4:
line.lineType = VX_LINE_ANGLE;
zwUtilGetDirOnEntPath(VX_INP_EDGE_OR_CURVE,&line.refDir);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
cvxGetNumber("Enter angle form reference direction", &line.angle);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point2);
break;
case 5:
line.lineType = VX_LINE_MIDDDLE;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point1);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &line.point2);
break;
default:
zwTestLogErrorMsg(5, "cvxPartLine: invalid option!");
break;
}
if (line.lineType == VX_LINE_2PT || line.lineType == VX_LINE_MIDDDLE)
{
cvxGetEnt("Select reference frame, <middle-click> to ignore", VX_INP_REF_PLANE, 1, &line.idAlignPln);
if (line.idAlignPln > 0)
{
cvxGetNumber("whether to project line to alignment plane", &val);
line.prjToPln = (int(val + 0.5) > 0 ? 1 : 0);
}
}
/* create a 3D line */
int idLine = -1;
if (cvxPartLine(&line, &idLine) || idLine < 1)
zwTestLogErrorMsg(5, "cvxPartLine: failed to create a 3D line!");
}
void zwTestPartArc()
/*
DESCRIPTION:
Test case for function cvxPartArc.
*/
{
/* initialize arc data */
svxArcData arc = {};
if (cvxPartArcInit(&arc))
zwTestLogErrorMsg(5, "cvxPartArcInit: failed to initialize data!");
double val = 0;
cvxGetNumber("Select a method to create arc(0: through; 1: radius; 2: center; 3: angle)", &val);
switch (int(val + 0.5))
{
case 0:
arc.arcType = VX_ARC_THROUGH;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.startPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.endPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.centerPnt);
break;
case 1:
arc.arcType = VX_ARC_RADIUS;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.startPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.endPnt);
cvxGetNumber("Enter radius of arc", &arc.radius);
break;
case 2:
arc.arcType = VX_ARC_CENTER;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.startPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.endPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.centerPnt);
break;
case 3:
arc.arcType = VX_ARC_ANGLE;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &arc.centerPnt);
cvxGetNumber("Enter radius of arc", &arc.radius);
cvxGetNumber("Enter start angle of arc", &arc.startAngle);
cvxGetNumber("Enter angle of arc", &arc.arcAngle);
break;
default:
zwTestLogErrorMsg(5, "cvxPartArc: invalid option!");
break;
}
cvxGetEnt("Select reference frame, <middle-click> to ignore", VX_INP_REF_PLANE, 1, &arc.idAlignPln);
if (arc.idAlignPln > 0)
{
cvxGetNumber("whether to project arc to alignment plane", &val);
arc.prjToPln = (int(val + 0.5) > 0 ? 1 : 0);
}
svxPntOnEntPath location = {};
if (arc.arcType == VX_ARC_RADIUS)
{
cvxGetNumber("Whether to select a location point(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &location);
arc.location = &location;
}
}
if (arc.arcType == VX_ARC_CENTER || arc.arcType == VX_ARC_ANGLE)
{
cvxGetNumber("Indicate the direction for angular input (0: counter; 1: clockwise)", &val);
arc.arcDir = (int(val + 0.5) > 0 ? 1 : 0);
}
/* create a 3D arc */
int idArc = -1;
if (cvxPartArc(&arc, &idArc) || idArc < 1)
zwTestLogErrorMsg(5, "cvxPartArc: failed to create a 3D arc!");
}
void zwTestPartArc3pt()
/*
DESCRIPTION:
Test case for function cvxPartArc3pt.
*/
{
/* select three points to create an arc */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select three points.", VX_INP_PNT_GENERAL, 0, &count, &points);
if (count < 3)
{
zwTestLogErrorMsg(5, "cvxPartArc3pt: too few points!");
cvxMemFree((void**)&points);
return;
}
/* create an arc */
int idArc = 0;
if (cvxPartArc3pt(&points[0], &points[1], &points[2], &idArc) || idArc == 0)
zwTestLogErrorMsg(5, "cvxPartArc3pt: failed to create an arc!");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestPartArcRad()
/*
DESCRIPTION:
Test case for function cvxPartArcRad.
*/
{
/* select a plane and set parameters*/
svxMatrix frame = { 0 };
cvxMatInit(&frame);
double radius = 50, start = 45, end = 135;
cvxGetNumber("Specify radius", &radius);
cvxGetNumber("Specify start angle", &start);
cvxGetNumber("Specify end angle", &end);
/* create an arc */
int idArc = 0;
if (cvxPartArcRad(&frame, radius, start, end, &idArc) || idArc == 0)
zwTestLogErrorMsg(5, "cvxPartArcRad: failed to create an arc!");
}
void zwTestPartCir3pt()
/*
DESCRIPTION:
Test case for function cvxPartCir3pt.
*/
{
/* select three points to create a circle */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("Select three points to create a circle.", VX_INP_PNT_GENERAL, 0, &count, &points);
if (count < 3)
{
zwTestLogErrorMsg(5, "cvxPartCir3pt: too few points!");
cvxMemFree((void**)&points);
return;
}
/* use three points to create a circle */
int idCir = 0;
if (cvxPartCir3pt(&points[0], &points[1], &points[2], &idCir) || idCir == 0)
zwTestLogErrorMsg(5, "cvxPartCir3pt: failed to create a circle!");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestPartCirRad()
/*
DESCRIPTION:
Test case for function cvxPartCirRad.
*/
{
/* select a plane and specify radius */
svxMatrix frame = { 0 };
cvxMatInit(&frame);
double radius = 20;
cvxGetNumber("Specify radius", &radius);
/* create a circle */
int idCir = 0;
if (cvxPartCirRad(&frame, radius, &idCir) || idCir == 0)
zwTestLogErrorMsg(5, "cvxPartCirRad: failed to create a circle!");
}
void zwTestPartCircle()
/*
DESCRIPTION:
Test case for function cvxPartCircle.
*/
{
/* initialize circle data */
svxCircleData circle = {};
if (cvxPartCircleInit(&circle))
zwTestLogErrorMsg(5, "cvxPartCircleInit: failed to initialize data!");
double val = 0;
cvxGetNumber("Select a method to create circle(0: boundary; 1: radius; 2: through; 3: 2pt radius; 4: 2 points)", &val);
switch (int(val + 0.5))
{
case 0:
circle.type = VX_CIRCLE_BOUNDARY;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.centerPnt);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[0]);
break;
case 1:
circle.type = VX_CIRCLE_RADIUS;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.centerPnt);
cvxGetNumber("Indicate radius or diameter(0: radius; 1: diameter)", &val);
circle.useDiameter = (int(val + 0.5) > 0 ? 1 : 0);
cvxGetNumber("Enter radius or diameter value of circle", &circle.radOrDia);
break;
case 2:
circle.type = VX_CIRCLE_THROUGH;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[0]);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[1]);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[2]);
break;
case 3:
circle.type = VX_CIRCLE_2PT_RADIUS;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[0]);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[1]);
cvxGetNumber("Enter radius value of circle", &circle.radOrDia);
break;
case 4:
circle.type = VX_CIRCLE_2POINT;
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[0]);
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &circle.bndPnts[1]);
break;
default:
zwTestLogErrorMsg(5, "cvxPartCircle: invalid option!");
break;
}
cvxGetEnt("Select reference frame, <middle-click> to ignore", VX_INP_REF_PLANE, 1, &circle.idAlignPln);
if (circle.idAlignPln > 0)
{
cvxGetNumber("whether to project circle to alignment plane", &val);
circle.prjToPln = (int(val + 0.5) > 0 ? 1 : 0);
}
svxPntOnEntPath location = {};
if (circle.type == VX_CIRCLE_2PT_RADIUS)
{
cvxGetNumber("Whether to select a location point(0: no; 1: yes)", &val);
if (int(val + 0.5))
{
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &location);
circle.location = &location;
}
}
/* create a 3D circle */
int idCircle = -1;
if (cvxPartCircle(&circle, &idCircle) || idCircle < 1)
zwTestLogErrorMsg(5, "cvxPartCircle: failed to create a 3D circle!");
}
void zwTestPartCrvInt()
/*
DESCRIPTION:
Test case for function cvxPartCrvInt.
*/
{
/* select some points to create a curve */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select some points to create a curve.", VX_INP_PNT_GENERAL, 0, &count, &points);
/* initialize a curve */
svxCrvIntData crv;
if (cvxPartCrvIntInit(&crv))
zwTestLogErrorMsg(5, "cvxPartCrvIntInit: failed to initialize a curve!");
double val = 0;
cvxGetNumber("whether closed: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 0 */
crv.isClosed = 0;
else
crv.isClosed = 1;
cvxGetNumber("specify degree: 2 - 6", &val);
crv.Degree = int(val + 0.5);
crv.Count = count;
crv.Points = points;
cvxGetNumber("whether use start tangent direction: 0 or 1", &val);
if (int(val + 0.5))
{
crv.UseStartTan = 1;
cvxGetNumber("specify start tangent degree phi", &val);
crv.StartTan.x = cos(val * V_DEG_TO_RAD);
crv.StartTan.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify start tangent degree theta", &val);
crv.StartTan.z = cos(val * V_DEG_TO_RAD);
crv.StartTan.x *= sin(val * V_DEG_TO_RAD);
crv.StartTan.y *= sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify start tangent scale: 0.1 - 10.0", &crv.StartScale); // or use cvxPartCrvIntScaleInit to initialize crv.StartScale
}
cvxGetNumber("whether use end tangent direction: 0 or 1", &val);
if (int(val + 0.5))
{
crv.UseEndTan = 1;
cvxGetNumber("specify end tangent degree phi", &val);
crv.EndTan.x = cos(val * V_DEG_TO_RAD);
crv.EndTan.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify end tangent degree theta", &val);
crv.EndTan.z = cos(val * V_DEG_TO_RAD);
crv.EndTan.x *= sin(val * V_DEG_TO_RAD);
crv.EndTan.y *= sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify end tangent scale: 0.1 - 10.0", &crv.EndScale); // or use cvxPartCrvIntScaleInit to initialize crv.EndScale
}
cvxGetNumber("select fairing method: 0 - 5", &val);
crv.Fairing = int(val + 0.5);
/* create a curve */
int idCrv = 0;
if (cvxPartCrvInt(&crv, &idCrv) || idCrv == 0)
zwTestLogErrorMsg(5, "cvxPartCrvInt: failed to create a curve");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestPartCrvList()
/*
DESCRIPTION:
Test case for function cvxPartCrvList.
*/
{
/* select curve(s) to create a curve list */
int* idCrvList = nullptr;
int countCrv = 0;
cvxGetEnts("select curve(s) to create a curve list, <middle-click> when done", VX_INP_EDGE_OR_CURVE, 0, &countCrv, &idCrvList);
/* create a curve list */
int idList = 0;
if (cvxPartCrvList(countCrv, idCrvList, &idList) || idList == 0)
zwTestLogErrorMsg(5, "cvxPartCrvList: failed to create a curve list!");
/* free memory */
cvxMemFree((void**)&idCrvList);
}
void zwTestPartCurve()
/*
DESCRIPTION:
Test case for function cvxPartCurve.
*/
{
/* initialize a curve */
svxCurve curve;
cvxMemZero(&curve, sizeof(svxCurve));
curve.Frame.identity = 1;
int idOld = 0;
double val = 0;
cvxGetNumber("select a method for curve: 1 - 4", &val);
switch (int(val + 0.5))
{
case 1:
curve.Type = VX_CRV_LINE;
cvxGetPoint("select start point of line", VX_INP_PNT_GENERAL, 0, &curve.P1, nullptr);
cvxGetPoint("select end point of line", VX_INP_PNT_GENERAL, 0, &curve.P2, nullptr);
break;
case 2:
curve.Type = VX_CRV_ARC;
cvxGetNumber("specify start degree of arc", &curve.A1);
cvxGetNumber("specify end degree of arc", &curve.A2);
cvxGetNumber("specify radius of arc", &curve.R);
break;
case 3:
curve.Type = VX_CRV_CIRCLE;
cvxGetNumber("specify radius of circle", &curve.R);
break;
case 4:
curve.Type = VX_CRV_NURB;
cvxGetEnt("pick a curve", VX_INP_EDGE_OR_CURVE, 0, &idOld);
cvxPartInqCurve(idOld, 1, &curve);
curve.P1.x += 10;
curve.P2.x += 10;
curve.Frame.xt += 10;
break;
default:
zwTestLogErrorMsg(5, "cvxPartCurve: invalid option!");
break;
}
/* create a line */
int idCurve = 0;
if (cvxPartCurve(&curve, &idCurve) || idCurve == 0)
zwTestLogErrorMsg(5, "cvxPartCurve: failed to create a curve!");
/* free memory */
cvxCurveFree(&curve);
}
void zwTestPartLine2pt()
/*
DESCRIPTION:
Test case for function cvxPartLine2pt.
*/
{
/* select two points */
svxPoint start = { 0 }, end = { 0 };
cvxGetPoint("select start point.", VX_INP_PNT_GENERAL, 0, &start, nullptr);
cvxGetPoint("select end point.", VX_INP_PNT_GENERAL, 0, &end, nullptr);
/* create a line */
int idLine = 0;
if (cvxPartLine2pt(&start, &end, &idLine) || idLine == 0)
zwTestLogErrorMsg(5, "cvxPartLine2pt: failed to create a line!");
}
void zwTestPartPnt()
/*
DESCRIPTION:
Test case for function cvxPartPnt & cvxPartPntNew.
*/
{
/* create a point */
svxPoint point = { 0 };
cvxGetPoint("select a point", VX_INP_PNT_GENERAL, 0, &point, nullptr);
int idPoint = 0;
if (cvxPartPnt(&point, &idPoint) || idPoint == 0)
zwTestLogErrorMsg(5, "cvxPartPnt: failed to create a point!");
svxPoint inqPoint = { 0 };
cvxEntPnt(idPoint, &inqPoint);
if (!zwUtilIsEqualPnt(&point, &inqPoint, V_FZERO))
zwTestLogErrorMsg(5, "cvxPartPnt: failed to determine point coordinate!");
svxPntOnEntPath pntOnEnt = {};
zwUtilGetPntOnEntPath(VX_INP_MOVE, VX_INP_PNT_GENERAL, &pntOnEnt);
int idAlignPln = 0, prjToPln = 0;
cvxGetEnt("Select reference frame, <middle-click> to ignore", VX_INP_REF_PLANE, 1, &idAlignPln);
if (idAlignPln > 0)
{
double val = 0.0;
cvxGetNumber("whether to project pnt to alignment plane", &val);
prjToPln = (int(val + 0.5) > 0 ? 1 : 0);
}
if (cvxPartPntNew(1, &pntOnEnt, idAlignPln, prjToPln, &idPoint) || idPoint == 0)
zwTestLogErrorMsg(5, "cvxPartPntNew: failed to create a point!");
return;
}
void zwTestPartPntBlock()
/*
DESCRIPTION:
Test case for function cvxPartPntBlock.
*/
{
/* select point(s) */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select point(s) to create point block.", VX_INP_PNT_GENERAL, 0, &count, &points);
svxPointf* pointfs = nullptr;
cvxMemAlloc(count * sizeof(svxPointf), (void**)&pointfs);
for (int i = 0; i < count; i++)
pointfs[i] = { (float)points[i].x, (float)points[i].y, (float)points[i].z };
/* create a point block */
vxLongName name = "pointBlockName";
int idEnt = 0;
if (cvxPartPntBlock(name, count, pointfs, &idEnt) || idEnt == 0)
zwTestLogErrorMsg(5, "cvxPartPntBlock: failed to create a point block!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&pointfs);
}
void zwTestPartPnts()
/*
DESCRIPTION:
Test case for function cvxPartPnts.
*/
{
/* select point(s) */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select point(s).", VX_INP_PNT_GENERAL, 0, &count, &points);
/* create some points */
if (cvxPartPnts(count, points))
zwTestLogErrorMsg(5, "cvxPartPnts: failed to create some points!");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestPartPntsOnCrv()
/*
DESCRIPTION:
Test case for function cvxPartPntsOnCrv.
*/
{
/* initialize points on curve */
svxPoint* pnt = nullptr;
svxPoint start = { 0 };
int num = 0;
double dist = 0;
evxExtendOpt opt = VX_EXTEND_UNDEFINED;
double val = 0;
cvxGetNumber("select a method: 0, 1, 2, 3 or 4", &val);
int idCrv = 0;
cvxGetEnt("select a curve", VX_INP_EDGE_OR_CURVE, 0, &idCrv);
switch (int(val + 0.5))
{
case 0:
opt = VX_EXTEND_UNDEFINED;
cvxGetNumber("specify number of points", &val);
num = int(val + 0.5);
break;
case 1:
opt = VX_EXTEND_UNDEFINED;
cvxGetPoint("select the start point of the curve", VX_INP_PNT_ON_CURVE, 0, &start, nullptr);
pnt = &start;
cvxGetNumber("specify distance", &dist);
break;
case 2:
case 3:
case 4:
if (int(val + 0.5) == 2)
opt = VX_EXTEND_LINEAR;
else if (int(val + 0.5) == 3)
opt = VX_EXTEND_CIRCULAR;
else
opt = VX_EXTEND_REFLECT;
cvxGetPoint("select the start point of the curve", VX_INP_PNT_ON_CURVE, 0, &start, nullptr);
pnt = &start;
cvxGetNumber("specify number of points", &val);
num = int(val + 0.5);
cvxGetNumber("specify distance", &dist);
break;
default:
zwTestLogErrorMsg(5, "cvxPartPntsOnCrv: invalid option!");
break;
}
/* create points on the curve */
int count = 0;
int* idEnts = nullptr;
if (cvxPartPntsOnCrv(idCrv, pnt, num, dist, opt, &count, &idEnts) || idEnts == nullptr)
zwTestLogErrorMsg(5, "cvxPartPntsOnCrv: failed to create points on a curve!");
/* free memory */
cvxMemFree((void**)&idEnts);
}
void zwTestPartEllipse()
/*
DESCRIPTION:
Test case for function cvxPartEllipse.
*/
{
/* initialize an ellipse */
svxRectangleData ellipseData;
if (cvxPartEllipseInit(&ellipseData))
zwTestLogErrorMsg(5, "cvxPartEllipseInit: failed to initialize an ellipse!");
double val = 0;
cvxGetNumber("select ellipse method: 0, 1 or 2", &val);
switch (int(val + 0.5))
{
case 0:
ellipseData.type = VX_RECT_2PT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
ellipseData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[0], nullptr);
cvxGetPoint("select the second point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[1], nullptr);
cvxGetNumber("specify rotation angle", &ellipseData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 0, &ellipseData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
ellipseData.prjFirstPt = 0;
break;
case 1:
ellipseData.type = VX_RECT_WIDTH_HEIGHT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
ellipseData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[0], nullptr);
cvxGetNumber("specify width", &ellipseData.width);
cvxGetNumber("specify height", &ellipseData.height);
cvxGetNumber("specify rotation angle", &ellipseData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 0, &ellipseData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
ellipseData.prjFirstPt = 0;
break;
case 2:
ellipseData.type = VX_RECT_3PT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
ellipseData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[0], nullptr);
cvxGetPoint("select the second point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[1], nullptr);
cvxGetPoint("select the third point.", VX_INP_PNT_GENERAL, 0, &ellipseData.pts[2], nullptr);
cvxGetNumber("specify rotation angle", &ellipseData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 1, &ellipseData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
ellipseData.prjFirstPt = 0;
break;
default:
zwTestLogErrorMsg(5, "cvxPartEllipse: invalid option!");
break;
}
/* create an ellipse */
int idEllipse = 0;
if (cvxPartEllipse(&ellipseData, &idEllipse) || idEllipse == 0)
zwTestLogErrorMsg(5, "cvxPartEllipseInit: failed to create an ellipse!");
}
void zwTestPartRectangle()
/*
DESCRIPTION:
Test case for function cvxPartRectangle.
*/
{
/* initialize a rectangle */
svxRectangleData rectangleData;
if (cvxPartRectangleInit(&rectangleData))
zwTestLogErrorMsg(5, "cvxPartRectangleInit: failed to initialize a rectangle!");
double val = 0;
cvxGetNumber("select rectangle method: 0, 1 or 2", &val);
switch (int(val + 0.5))
{
case 0:
rectangleData.type = VX_RECT_2PT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
rectangleData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[0], nullptr);
cvxGetPoint("select the second point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[1], nullptr);
cvxGetNumber("specify rotation angle", &rectangleData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 0, &rectangleData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
rectangleData.prjFirstPt = 0;
break;
case 1:
rectangleData.type = VX_RECT_WIDTH_HEIGHT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
rectangleData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[0], nullptr);
cvxGetNumber("specify width", &rectangleData.width);
cvxGetNumber("specify height", &rectangleData.height);
cvxGetNumber("specify rotation angle", &rectangleData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 0, &rectangleData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
rectangleData.prjFirstPt = 0;
break;
case 2:
rectangleData.type = VX_RECT_3PT;
cvxGetNumber("select first point type: 0 or 1", &val);
if (int(val + 0.5))
rectangleData.firstPtType = 1;
cvxGetPoint("select the first point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[0], nullptr);
cvxGetPoint("select the second point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[1], nullptr);
cvxGetPoint("select the third point.", VX_INP_PNT_GENERAL, 0, &rectangleData.pts[2], nullptr);
cvxGetNumber("rectangle or parallelogram: 0 or 1", &val);
if (int(val + 0.5))
rectangleData.parallelogram = 1;
cvxGetNumber("specify rotation angle", &rectangleData.angle);
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 1, &rectangleData.idPlane);
cvxGetNumber("whether project first point to plane: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 1 */
rectangleData.prjFirstPt = 0;
break;
default:
zwTestLogErrorMsg(5, "cvxPartRectangle: invalid option!");
break;
}
/* create a rectangle */
int numEdges = 0;
int* idEdges = 0;
if (cvxPartRectangle(&rectangleData, &numEdges, &idEdges) || idEdges == 0)
zwTestLogErrorMsg(5, "cvxPartRectangle: failed to create a rectangle!");
/* free memory */
cvxMemFree((void**)&idEdges);
}
void zwTestPartProjStl()
/*
DESCRIPTION:
Test case for function cvxPartProjStl.
*/
{
/* select a STL and a plane*/
int idStl = 0;
cvxGetEnt("select a STL", VX_INP_GENERAL_3D, 0, &idStl);
int idPlane = 0;
cvxGetEnt("select a plane", VX_INP_DATUM_PLANE, 0, &idPlane);
double tolerance = 0, smooth = 0;
cvxGetNumber("specify tolerance: 0.005 as default", &tolerance);
cvxGetNumber("specify smooth: 0.01 as default", &smooth);
/* project a STL */
int idCurve = 0;
if (cvxPartProjStl(idStl, idPlane, tolerance, smooth, &idCurve) || idCurve == 0)
zwTestLogErrorMsg(5, "cvxPartProjStl: failed to project a STL!");
}
void zwTestPartCurveSilh()
/*
DESCRIPTION:
Test case for function cvxPartCurveSilh.
*/
{
/* select a curve */
int idCrv = 0;
cvxGetEnt("select a curve", VX_INP_CURVE, 0, &idCrv);
/* specify project direction */
svxPoint dir = { 0 };
double val = 0;
cvxGetNumber("specify project angle phi", &val);
dir.x = cos(val * V_DEG_TO_RAD);
dir.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify project angle theta", &val);
dir.z = cos(val * V_DEG_TO_RAD);
dir.x *= sin(val * V_DEG_TO_RAD);
dir.y *= sin(val * V_DEG_TO_RAD);
/* project the curve */
int numEnt = 0;
int* idList = nullptr;
if (cvxPartCurveSilh(idCrv, &dir, &numEnt, &idList) || idList == nullptr)
zwTestLogErrorMsg(5, "cvxPartCurveSilh: failed to project a curve!");
/* free memory */
cvxMemFree((void**)&idList);
}
void zwTestPartFittingCrv()
/*
DESCRIPTION:
Test case for function cvxPartFittingCrv.
*/
{
/* select some points to create a curve */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select some points.", VX_INP_PNT_GENERAL, 0, &count, &points);
double tolerance = 0, smooth = 0;
cvxGetNumber("specify tolerance: 0.005 as default", &tolerance);
cvxGetNumber("specify smooth: 0.01 as default", &smooth);
/* create a curve */
int idCrv = 0;
if (cvxPartFittingCrv(count, points, tolerance, smooth, &idCrv) || idCrv == 0)
zwTestLogErrorMsg(5, "cvxPartFittingCrv: failed to create a curve");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestPartSpline()
/*
DESCRIPTION:
Test case for function cvxPartSpline.
*/
{
/* select some points */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select some points.", VX_INP_PNT_GENERAL, 0, &count, &points);
/* initialize the spline */
svxSplineData spline;
if (cvxPartSplineInit(&spline, count))
zwTestLogErrorMsg(5, "cvxPartSplineInit: failed to initialize the spline!");
if (cvxSplinePntInit(spline.Pnts))
zwTestLogErrorMsg(5, "cvxSplinePntInit: failed to initialize the spline!");
double val = 0;
for (int i = 0; i < count; i++)
{
spline.Pnts[i].Pnt = points[i];
char msg[100];
sprintf_s(msg, 100, "whether use constraint for point %d: 0 or 1", i + 1);
cvxGetNumber(msg, &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseCons = 1;
cvxGetNumber("select continuity type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_NONE;
break;
case 1:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G1;
break;
case 2:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G2;
break;
case 3:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G3;
break;
default:
zwTestLogErrorMsg(5, "cvxSkSpline: invalid option!");
break;
}
if (spline.Pnts[i].ContinuityTyp != VX_CONTIN_NONE)
{
cvxGetNumber("specify tangent angle phi", &val);
spline.Pnts[i].TangDir.x = cos(val * V_DEG_TO_RAD);
spline.Pnts[i].TangDir.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify tangent angle theta", &val);
spline.Pnts[i].TangDir.z = cos(val * V_DEG_TO_RAD);
spline.Pnts[i].TangDir.x *= sin(val * V_DEG_TO_RAD);
spline.Pnts[i].TangDir.y *= sin(val * V_DEG_TO_RAD);
}
cvxGetNumber("whether use G1 magnitude: 0 or 1", &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseG1Manitude = 1;
cvxGetNumber("specify G1 magnitude", &spline.Pnts[i].dG1Manitude);
}
cvxGetNumber("whether use G2 radius: 0 or 1", &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseG2Radius = 1;
cvxGetNumber("specify G2 radius", &spline.Pnts[i].dG2Radius);
}
cvxGetNumber("whether flip the tangent direction: 0 or 1", &val);
if (int(val + 0.5))
spline.Pnts[i].FlipDir = 1;
}
}
cvxGetNumber("select spline type: 0 or 1", &val);
if (int(val + 0.5))
{
spline.SplineTyp = 1;
cvxGetNumber("whether use single segment: 0 or 1", &val);
if (int(val + 0.5))
spline.SingleSeg = 1;
}
cvxGetNumber("specify degree", &val);
spline.Degree = int(val + 0.5);
/* note: default 1 */
cvxGetNumber("whether create curve open: 0 or 1", &val);
if (int(val + 0.5) == 0)
spline.CreateCrvOpen = 0;
cvxGetNumber("select fairing type: 0 - 5", &val);
spline.Fairing = int(val + 0.5);
cvxGetNumber("select placing adjustment type: -1 - 3", &val);
switch (int(val + 0.5))
{
case -1:
spline.PlacingTyp = VX_PLACING_NONE;
break;
case 0:
spline.PlacingTyp = VX_PLACING_VIEW;
break;
case 1:
spline.PlacingTyp = VX_PLACING_VECTOR;
cvxGetNumber("specify placing adjustment angle phi", &val);
spline.PlacingDir.x = cos(val * V_DEG_TO_RAD);
spline.PlacingDir.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify placing adjustment angle theta", &val);
spline.PlacingDir.z = cos(val * V_DEG_TO_RAD);
spline.PlacingDir.x *= sin(val * V_DEG_TO_RAD);
spline.PlacingDir.y *= sin(val * V_DEG_TO_RAD);
break;
case 2:
spline.PlacingTyp = VX_PLACING_WCS;
break;
case 3:
spline.PlacingTyp = VX_PLACING_PLANE;
break;
default:
zwTestLogErrorMsg(5, "cvxSkSpline: invalid option!");
break;
}
/* create a spline */
int idSpline = 0;
if (cvxPartSpline(&spline, &idSpline))
zwTestLogErrorMsg(5, "cvxPartSpline: failed to create a spline!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&spline.Pnts);
}
void zwTestPartCurveOffset()
/*
DESCRIPTION:
Test case for function cvxPartCurveOffset.
*/
{
/* offset a curve */
int idCurve = 0;
cvxGetEnt("[Curve]Select a curve to offset", VX_INP_CURVE, 0, &idCurve);
double distance = 10;
int idFtr = 0;
if (cvxPartCurveOffset(idCurve, distance, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartCurveOffset: failed to offset a curve!");
}
void zwTestPartCrvProjToFace()
/*
DESCRIPTION:
Test case for function cvxPartCrvProjToFaceInit and cvxPartCrvProjToFace.
*/
{
svxCrvProjToFace data = {};
if (cvxPartCrvProjToFaceInit(&data))
zwTestLogErrorMsg(5, "cvxPartCrvProjToFaceInit: failed to initialize the project to face data!");
cvxGetEnts("[Curves]Select some curves to project, <middle click> when done", VX_INP_WIREFRAME, 0, &data.cntCrvs, &data.pCrvs);
cvxGetEnts("[Faces]Select some faces to project onto, <middle click> when done", VX_INP_FACE, 0, &data.cntFaces, &data.pFaces);
double val = 0.0;
svxVector dir = {};
cvxGetNumber("Whether to specify direction: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
data.pDir = &dir;
cvxGetPoint("[Direction]Specify project direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&dir, nullptr);
}
cvxGetNumber("[Bi-directional projection]1-yes, 0-no", &val);
data.biDir = int(val + 0.5);
cvxGetNumber("[Trim to face boundaries]1-yes, 0-no", &val);
data.trim = int(val + 0.5);
/* project curves to faces */
int cntEnts = 0, * idEnts = nullptr;
if (cvxPartCrvProjToFace(&data, &cntEnts, &idEnts) || cntEnts == 0)
zwTestLogErrorMsg(5, "cvxPartCrvProjToFace: failed to project to face!");
/* free memory */
cvxMemFree((void**)&data.pCrvs);
cvxMemFree((void**)&data.pFaces);
cvxMemFree((void**)&idEnts);
}
void zwTestPartCrvOnFaceThruPts()
/*
DESCRIPTION:
Test case for function cvxPartCrvOnFaceThruPtsInit and cvxPartCrvOnFaceThruPts.
*/
{
svxCrvOnFaceThuPts crv;
if (cvxPartCrvOnFaceThruPtsInit(&crv))
zwTestLogErrorMsg(5, "cvxPartCrvOnFaceThruPtsInit: failed to initialize curve on face through face data!");
cvxGetEnt("[Face]Select a face", VX_INP_FACE, 0, &crv.face);
cvxGetPoints("[Points]Select some points on the face, <middle click> when done", VX_INP_PNT_ON_ANY_FACE, 0, &crv.cntPts, &crv.pts);
double val = 0.0;
cvxGetNumber("[Create curve open]1-yes, 0-no (1 as default)", &val);
crv.isOpen = int(val + 0.5);
cvxGetNumber("[Fairing]Select fairing type: 0 - 5", &val);
crv.fairing = evxFairingType(int(val + 0.5));
svxCrvOnFaceThuPtsCons cons[2] = {};
cvxGetNumber("Whether to use start constraint: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
crv.startCons = &cons[0];
cvxGetNumber("[start continuity]Select start continuity: 0-connect, 1-tangent, 2-curvature", &val);
cons[0].continuity = evxContinuityTyp(int(val + 0.5));
cvxGetPoint("[start tan]Select start tangent direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&cons[0].tan, nullptr);
cvxGetNumber("[reverse start direction on curve]1-yes, 0-no", &val);
cons[0].flip = int(val + 0.5);
cvxGetNumber("[start weight]Specify start weight (between 0.1 and 10)", &cons[0].weight);
}
cvxGetNumber("Whether to use end constraint: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
crv.endCons = &cons[1];
cvxGetNumber("[end continuity]Select end continuity: 0-connect, 1-tangent, 2-curvature", &val);
cons[1].continuity = evxContinuityTyp(int(val + 0.5));
cvxGetPoint("[end tan]Select end tangent direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&cons[1].tan, nullptr);
cvxGetNumber("[reverse end direction on curve]1-yes, 0-no", &val);
cons[1].flip = int(val + 0.5);
cvxGetNumber("[end weight]Specify end weight (between 0.1 and 10)", &cons[1].weight);
}
int idEnt = 0;
if (cvxPartCrvOnFaceThruPts(&crv, &idEnt) || idEnt == 0)
zwTestLogErrorMsg(5, "cvxPartCrvOnFaceThruPts: failed to create curve on face through points!");
/* free memory */
cvxMemFree((void**)&crv.pts);
}
void zwTestPartFaceCurve()
/*
DESCRIPTION:
Test case for function cvxPartFaceCurve.
*/
{
svxFaceCrvData data = {};
svxVector direction = {};
double val = 0;
cvxGetNumber("Select face curve method: 0-from edges, 1-from projected curves", &val);
data.method = int(val + 0.5);
cvxGetEnts("[Faces]Select some faces to create curves, <middle click> when done", VX_INP_FACE, 0, &data.cntFaces, &data.pFaces);
cvxGetNumber("[Add as parting lines]1-yes, 0-no", &val);
data.partingLine = int(val + 0.5);
if (data.method == 0)
{
cvxGetEnts("[Edges]Select some edges on selected faces, <middle click> when done", VX_INP_EDGE, 0,
&data.inpUion.fromEdge.cntEdge, &data.inpUion.fromEdge.pEdge);
cvxGetNumber("[Allow seam edges]1-yes, 0-no", &val);
data.inpUion.fromEdge.seam = int(val + 0.5);
}
else if (data.method == 1)
{
cvxGetEnts("[Curves]Select some curves to project, <middle click> when done", VX_INP_WIREFRAME, 0,
&data.inpUion.fromProjCrv.cntCrv, &data.inpUion.fromProjCrv.pCrv);
cvxGetNumber("[direction]1-specify custom direction, 0-use default direction", &val);
if (int(val + 0.5))
{
data.inpUion.fromProjCrv.dir = &direction;
cvxGetPoint("[Direction]Specify projection direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&direction, nullptr);
}
}
/* create face curves */
int cntEnts = 0;
int* idEnts = nullptr;
if (cvxPartFaceCurve(&data, &cntEnts, &idEnts) || cntEnts == 0)
zwTestLogErrorMsg(5, "cvxPartFaceCurve: failed to create face curve!");
/* free memory */
cvxMemFree((void**)&data.pFaces);
cvxMemFree((void**)&idEnts);
if (data.method == 0)
cvxMemFree((void**)&data.inpUion.fromEdge.pEdge);
else if (data.method == 1)
cvxMemFree((void**)&data.inpUion.fromProjCrv.pCrv);
}
void zwTestPartExtractCenterlines()
/*
DESCRIPTION:
Test case for function cvxPartExtractCenterlines.
*/
{
int cntFaces = 0;
int* idFaces = nullptr;
cvxGetEnts("[Faces]Select some faces to extract centerlines, <middle click> when done", VX_INP_FACE, 0, &cntFaces, &idFaces);
double extractAxis = 0;
cvxGetNumber("[Extract axis]1-yes, 0-no", &extractAxis);
/* extract centerlines */
int cntEnts = 0;
int* idEnts = nullptr;
if (cvxPartExtractCenterlines(cntFaces, idFaces, int(extractAxis + 0.5), &cntEnts, &idEnts) || cntEnts == 0)
zwTestLogErrorMsg(5, "cvxPartExtractCenterlines: failed to extract centerlines!");
/* free memory */
cvxMemFree((void**)&idFaces);
cvxMemFree((void**)&idEnts);
}
void zwTestPartCrvSpiral()
/*
DESCRIPTION:
Test case for function cvxPartSpiralCurve.
*/
{
svxSpiralCrvData data = {};
cvxGetPoint("[Start Point]Select a start point", VX_INP_PNT_GENERAL, 0, &data.startPnt, nullptr);
cvxGetPoint("[Axis]Select axis", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&data.axis, nullptr);
cvxGetNumber("[Turns]Specify number of turns", &data.turns);
cvxGetNumber("[Offset]Specify offset between each turn", &data.offset);
double val = 0.0;
cvxGetNumber("[Revolve clockwise]1-yes, 0-no", &val);
data.revolve = int(val + 0.5);
svxVector refDir = {};
cvxGetNumber("Whether to specify reference direction: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
data.pRefDir = &refDir;
cvxGetPoint("[Reference Direction]Select reference direction", VX_INP_PNT_DIRECTION, 0, (svxPoint*)&refDir, nullptr);
}
cvxGetNumber("[Angle]Specify angle", &data.ang);
/* create spiral curves */
int idEnt = 0;
if (cvxPartSpiralCurve(&data, &idEnt) || idEnt == 0)
zwTestLogErrorMsg(5, "cvxPartSpiralCurve: failed to create a spiral curve!");
}
void zwTestPartCrvTrimToFaces()
/*
DESCRIPTION:
Test case for function cvxPartCrvTrimToFaces.
*/
{
svxCrvTrimToFacesData data = {};
cvxGetEnts("[Curves]Select curves to trim", VX_INP_CURVE, 0, &data.cntCrvs, &data.pCrvs);
cvxGetEnts("[Faces]Select trimming faces", VX_INP_FACE, 0, &data.cntFaces, &data.pFaces);
double val = 0.0;
cvxGetNumber("[Flip side to keep]1-yes, 0-no", &val);
data.flip = int(val + 0.5);
/* trim curves to faces */
int idFtr = 0;
if (cvxPartCrvTrimToFaces(&data, &idFtr) || idFtr == 0)
zwTestLogErrorMsg(5, "cvxPartCrvSpiral: failed to trim curves to faces!");
/* free memory */
cvxMemFree((void**)&data.pCrvs);
cvxMemFree((void**)&data.pFaces);
}
void zwTestPartCrvTrimWithCrv()
/*
DESCRIPTION:
Test case for function cvxPartCrvTrimWithCrv.
*/
{
svxTrimWithCrvData data = {};
cvxGetEnts("[curves]Select boundary curves, <middle click> when done", VX_INP_EDGE_OR_CURVE, 0, &data.cntCrvs, &data.pCrvs);
svxPoint* pnts = NULL;
svxEntPath* paths = NULL;
cvxGetPointsOnEnts("[delete]Select curve segment to delete, <middle click> when done", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.cntDelSeg, &pnts, &paths);
cvxMemAlloc(data.cntDelSeg * sizeof(svxPntOnEntPath), (void**)&data.pDelSeg);
cvxMemZero(data.pDelSeg, data.cntDelSeg * sizeof(svxPntOnEntPath));
for (int i = 0; i < data.cntDelSeg; i++)
{
data.pDelSeg[i].entPath = paths[i];
data.pDelSeg[i].pnt = pnts[i];
}
double val = 0.0;
cvxGetNumber("[trim]Select trim mode: 0-keep, 1-delete, 2-split", &val);
data.trimMode = evxTrimWithCrvType(int(val + 0.5));
svxPntOnEntPath Pln = {};
cvxGetNumber("Whether to use projection plane: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
cvxGetPointOnEnt("[plane]Select a plane", VX_INP_PNT_ON_ANY_FACE, 0, &Pln.pnt, &Pln.entPath);
data.pPln = &Pln;
}
int cntEnts = 0, * idEnts = nullptr;
if (cvxPartCrvTrimWithCrv(&data, &cntEnts, &idEnts) || data.trimMode == VX_TRIM_WITH_CRV_SPLIT && cntEnts == 0)
zwTestLogErrorMsg(5, "cvxPartCrvTrimWithCrv: failed to trim with curves!");
/* free memory */
cvxMemFree((void**)&data.pCrvs);
cvxMemFree((void**)&data.pDelSeg);
cvxMemFree((void**)&idEnts);
cvxMemFree((void**)&pnts);
cvxMemFree((void**)&paths);
}
void zwTestPartPolyLine()
/*
DESCRIPTION:
Test case for function cvxPartPolyLine.
*/
{
/* initialize a curve */
svxPolylineData poly = {};
if (cvxPartPolylineInit(&poly))
zwTestLogErrorMsg(5, "cvxPartPolylineInit: failed to initialize data!");
std::vector<svxPntOnEnt> vPnts;
svxPntOnEnt pntOnEnt = {};
while (!cvxGetPoint("[Points]Select a point, <ESC> when done", VX_INP_PNT_GENERAL, 1, &pntOnEnt.pnt, &pntOnEnt.idEnt))
{
vPnts.push_back(pntOnEnt);
}
poly.numPoint = (int)vPnts.size();
poly.pPoints = vPnts.data();
int idPlane = -1;
cvxGetEnt("[Align plane]Select reference frame, <middle-click> to ignore done", VX_INP_REF_PLANE, 1, &idPlane);
if (idPlane > 0)
{
poly.idAligPln = idPlane;
double val = 0.0;
cvxGetNumber("[Project to plane]Whether to project to plane(1: enable; 0: disable)", &val);
poly.projectToPln = (int(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Points on align plane]Select points on align plane(1: enable; 0: disable)", &val);
poly.pntOnPln = (int(val + 0.5) == 1 ? 1 : 0);
}
int nLines = 0;
int* idLines = NULL;
if (cvxPartPolyLine(&poly, &nLines, &idLines) || nLines < 1)
zwTestLogErrorMsg(5, "cvxPartCurveOffset: failed to create a poly line!");
/* free memory */
cvxMemFree((void**)&idLines);
}
void zwTestPartCrvSplitAtPnts()
/*
DESCRIPTION:
Test case for function cvxPartCrvSplitAtPnts.
*/
{
int idCrv = 0;
cvxGetEnt("[Curve]Select curve", VX_INP_CURVE, 0, &idCrv);
std::vector<svxPoint> vPnts;
int idParent = 0;
svxPoint pnt = {};
while (!cvxGetPoint("[Point]Select split points, <ESC> when done", VX_INP_PNT_ON_CURVE, 1, &pnt, &idParent))
{
if (idParent == idCrv)
vPnts.push_back(pnt);
}
int nCrvs = 0;
int* idCrvs = NULL;
if (cvxPartCrvSplitAtPnts(idCrv, (int)vPnts.size(), vPnts.data(), &nCrvs, &idCrvs) || nCrvs < 1)
zwTestLogErrorMsg(5, "cvxPartCrvSplitAtPnts: failed to split curve!");
/* free memory */
cvxMemFree((void**)&idCrvs);
}
void zwTestPartCrvFillet()
/*
DESCRIPTION:
Test case for function cvxPartCrvFillet.
*/
{
svxCrvFilletData data = {};
if (cvxPartCrvFilletInit(&data))
zwTestLogErrorMsg(5, "cvxPartCrvFilletInit: failed to initialize data!");
cvxGetPointOnEnt("Select point1", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.firstPnt.pnt, &data.firstPnt.entPath);
cvxGetPointOnEnt("Select point2", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.secondPnt.pnt, &data.secondPnt.entPath);
double val = 0.0;
svxPntOnEnt settingPnt = {};
cvxGetNumber("select fillet method(0: radius, 1: boundary)", &val);
switch (int(val+0.5))
{
case 0:
data.method = VX_CRV_FILLET_RADIUS;
cvxGetNumber("Enter radius", &val);
data.inpUnion.radius = val;
break;
case 1:
data.method = VX_CRV_FILLET_BOUNDARY;
cvxGetPointOnEnt("Select setting point", VX_INP_PNT_GENERAL, 0, &data.inpUnion.settingPnt.pnt, &data.inpUnion.settingPnt.entPath);
break;
default:
break;
}
cvxGetNumber("Select trim method(0: none; 1: both; 2: first; 3: second)", &val);
switch (int(val + 0.5))
{
case 0: data.trimType = VX_CRV_TRIM_NONE; break;
case 1: data.trimType = VX_CRV_TRIM_BOTH; break;
case 2: data.trimType = VX_CRV_TRIM_FIRST; break;
case 3: data.trimType = VX_CRV_TRIM_SECOND; break;
default: zwTestLogErrorMsg(5, "zwTestPartCrvFillet: invalid option!");
break;
};
cvxGetNumber("Select extend method(1: linear; 2: circular; 3: reflect)", &val);
switch (int(val + 0.5))
{
case 1: data.extensionType = VX_EXTEND_LINEAR; break;
case 2: data.extensionType = VX_EXTEND_CIRCULAR; break;
case 3: data.extensionType = VX_EXTEND_REFLECT; break;
default: zwTestLogErrorMsg(5, "zwTestPartCrvFillet: invalid option!");
break;
};
cvxGetNumber("whether to use designer arc: 0 or 1", &val);
data.designerArc = (int)(val + 0.5);
/* create a fillet */
int idFillet = 0;
if (cvxPartCrvFillet(&data, &idFillet) || idFillet == 0)
zwTestLogErrorMsg(5, "cvxPartCrvFillet: failed to create a fillet!");
}
void zwTestPartCrvChamfer()
/*
DESCRIPTION:
Test case for function cvxPartCrvChamfer.
*/
{
svxCrvChamferData data;
if (cvxPartCrvChamferInit(&data))
zwTestLogErrorMsg(5, "cvxPartCrvChamferInit: failed to initialize data!");
cvxGetPointOnEnt("Select point1", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.firstPnt.pnt, &data.firstPnt.entPath);
cvxGetPointOnEnt("Select point2", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.secondPnt.pnt, &data.secondPnt.entPath);
double val = 0.0;
svxPntOnEnt settingPnt = {};
cvxGetNumber("select chamfer method: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
data.method = VX_CRV_CHAMFER_SETBACK;
cvxGetNumber("set setback", &data.inpUnion.setback);
break;
case 1:
data.method = VX_CRV_CHAMFER_TWO_SETBACKS;
cvxGetNumber("set setback1", &data.inpUnion.twoSetbacks.firstSetback);
cvxGetNumber("set setback2", &data.inpUnion.twoSetbacks.secondSetback);
break;
case 2:
data.method = VX_CRV_CHAMFER_SETBACK_AND_ANGLE;
cvxGetNumber("set setback1", &data.inpUnion.setbackAndAngle.setback);
cvxGetNumber("set angle", &data.inpUnion.setbackAndAngle.angle);
break;
default:
zwTestLogErrorMsg(5, "zwTestPartCrvChamfer: invalid option!");
break;
}
cvxGetNumber("Select trim method(0: none; 1: both; 2: first; 3: second)", &val);
switch (int(val + 0.5))
{
case 0: data.trimType = VX_CRV_TRIM_NONE; break;
case 1: data.trimType = VX_CRV_TRIM_BOTH; break;
case 2: data.trimType = VX_CRV_TRIM_FIRST; break;
case 3: data.trimType = VX_CRV_TRIM_SECOND; break;
default: zwTestLogErrorMsg(5, "zwTestPartCrvChamfer: invalid option!");
break;
};
cvxGetNumber("Select extend method(1: linear; 2: circular; 3: reflect)", &val);
switch (int(val + 0.5))
{
case 1: data.extensionType = VX_EXTEND_LINEAR; break;
case 2: data.extensionType = VX_EXTEND_CIRCULAR; break;
case 3: data.extensionType = VX_EXTEND_REFLECT; break;
default: zwTestLogErrorMsg(5, "zwTestPartCrvChamfer: invalid option!");
break;
};
/* create a chamfer */
int idChamfer = 0;
if (cvxPartCrvChamfer(&data, &idChamfer) || idChamfer == 0)
zwTestLogErrorMsg(5, "cvxPartCrvChamfer: failed to create a chamfer!");
}
void zwTestPartCrvFilletChain()
/*
DESCRIPTION:
Test case for function cvxPartCrvFilletChain.
*/
{
svxCrvFilletChainData data;
if (cvxPartCrvFilletChainInit(&data))
zwTestLogErrorMsg(5, "cvxPartFilletChainInit: failed to initialize data!");
cvxGetEnts("[Edges]Select edge(s) to fillet, <middle-click> when done",
VX_INP_EDGE_OR_CURVE,
0,
&data.count,
&data.curves);
double val;
cvxGetNumber("set radius", &val);
data.radius = val;
cvxGetNumber("whether to use designer arc: 0 or 1", &val);
data.designerArc = (int)(val + 0.5);
cvxGetNumber("whether to trim original curves: 0 or 1", &val);
data.trimOriginal = (int)(val + 0.5);
/* create a fillet */
int idFilletChain = 0;
if (cvxPartCrvFilletChain(&data, &idFilletChain) || idFilletChain == 0)
zwTestLogErrorMsg(5, "cvxPartCrvFilletChain: failed to create a fillet!");
cvxMemFree((void**)&data.curves);
}
void zwTestPartBlendCrvs()
/*
DESCRIPTION:
Test case for function cvxPartBlendCrvsInit and cvxPartBlendCrvs.
*/
{
/* initialize curve blend data */
svxCrvBlendData data;
if (cvxPartBlendCrvsInit(&data))
zwTestLogErrorMsg(5, "cvxPartCrvBlendInit: failed to initialize curve blend data!");
/* start object */
double val = 0.0;
cvxGetNumber("[Start Object]Select start object type: 0-curve, 1-face", &val);
data.startObjType = (int(val) == 1 ? VX_CURVE_BLEND_FACE : VX_CURVE_BLEND_CURVE);
if (data.startObjType == VX_CURVE_BLEND_CURVE)
{
cvxGetPointOnEnt("[Curve 1]Select start object", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.startObj.pnt, &data.startObj.entPath);
cvxGetNumber("Whether to flip start object: 0-no, 1-yes", &val);
data.startObjFlip = int(val + 0.5);
}
else
{
cvxGetPointOnEnt("[Face 1]Select start object", VX_INP_PNT_ON_ANY_FACE, 0, &data.startObj.pnt, &data.startObj.entPath);
}
/* end object */
cvxGetNumber("[End object]Select end object type: 0-curve, 1-face", &val);
data.endObjType = (int(val) == 1 ? VX_CURVE_BLEND_FACE : VX_CURVE_BLEND_CURVE);
if (data.endObjType == VX_CURVE_BLEND_CURVE)
{
cvxGetPointOnEnt("[Curve 2]Select end object", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.endObj.pnt, &data.endObj.entPath);
cvxGetNumber("Whether to flip end object: 0-no, 1-yes", &val);
data.endObjFlip = int(val + 0.5);
}
else
{
cvxGetPointOnEnt("[Face 2]Select end object", VX_INP_PNT_ON_ANY_FACE, 0, &data.endObj.pnt, &data.endObj.entPath);
}
cvxGetNumber("[Trim]Select trim type: 0-no trim, 1-trim both, 2-trim first, 3-trim second", &val);
data.trim = evxCrvBlendTrimType(int(val + 0.5));
cvxGetNumber("[Display curvature]Whether to display curvature: 1-yes, 0-no", &val);
data.curvature = int(val + 0.5);
cvxGetNumber("[Pick end point by default]0-no, 1-yes", &val);
data.endpointPick = int(val + 0.5);
/* start constraints */
svxCrvBlendCons cons[2] = {};
if (cvxPartBlendCrvsConsInit(&cons[0], data.startObjType))
zwTestLogErrorMsg(5, "cvxPartBlendCrvsConsInit: failed to initialize constraint data!");
cvxGetNumber("Whether to start constraints: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
data.startCons = &cons[0];
cvxGetNumber("[Continuity]Select start constraints continuity: 0-none, 1-tangent, 2-curvature, 3-flow", &val);
cons[0].continuity = evxContinuityTyp(int(val + 0.5));
cvxGetNumber("Whether to flip start constraints tangent direction: 0-no, 1-yes", &val);
cons[0].tangentDirFlip = int(val + 0.5);
cvxGetNumber("[Weight]Specify start constraints weight, 1.0 as default", &cons[0].weight);
if (data.startObjType == 0)
{
cvxGetNumber("[Position]Select position type: 0-arc length, 1-%arc length, 2-through point", &val);
cons[0].inpUion.crv.pos = evxCrvBlendPosType(int(val + 0.5));
if (cons[0].inpUion.crv.pos == VX_CURVE_BLEND_POS_ARC_LENGTH)
cvxGetNumber("[Value]Specify arc length", &cons[0].inpUion.crv.value);
else if (cons[0].inpUion.crv.pos == VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH)
cvxGetNumber("[Value]Specify percentage of arc length", &cons[0].inpUion.crv.value);
else if (cons[0].inpUion.crv.pos == VX_CURVE_BLEND_POS_THROUGH_POINT)
cvxGetPointOnEnt("[Point]Select a point on curve", VX_INP_PNT_ON_CURVE, 0, &cons[0].inpUion.crv.throughPnt.pnt,
&cons[0].inpUion.crv.throughPnt.entPath);
cvxGetNumber("[Keep Side]0-long, 1-short", &val);
cons[0].inpUion.crv.keepside = int(val + 0.5);
}
else if (data.startObjType == 1)
{
cvxGetNumber("[Blend Direction]0-sectional, 1-Iso u, 2-Iso v", &val);
cons[0].inpUion.face.blendDir = evxCrvBlendDirType(int(val + 0.5));
if (cons[0].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_SECTIONAL)
cvxGetNumber("[Angle]Specify angle", &cons[0].inpUion.face.value);
else if (cons[0].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_ISO_U)
cvxGetNumber("[Iso U]Specify percentage", &cons[0].inpUion.face.value);
else if (cons[0].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_ISO_V)
cvxGetNumber("[Iso V]Specify percentage", &cons[0].inpUion.face.value);
}
}
/* end constraints */
if (cvxPartBlendCrvsConsInit(&cons[1], data.endObjType))
zwTestLogErrorMsg(5, "cvxPartBlendCrvsConsInit: failed to initialize constraint data!");
cvxGetNumber("Whether to start constraints: 1-yes, 0-no", &val);
if (int(val + 0.5))
{
data.endCons = &cons[1];
cvxGetNumber("[Continuity]Select end constraints continuity: 0-none, 1-tangent, 2-curvature, 3-flow", &val);
cons[1].continuity = evxContinuityTyp(int(val + 0.5));
cvxGetNumber("Whether to flip end constraints tangent direction: 0-no, 1-yes", &val);
cons[1].tangentDirFlip = int(val + 0.5);
cvxGetNumber("[Weight]Specify end constraints weight, 1.0 as default", &cons[1].weight);
if (data.endObjType == 0)
{
cvxGetNumber("[Position]Select end constraints position type: 0-arc length, 1-%arc length, 2-through point", &val);
cons[1].inpUion.crv.pos = evxCrvBlendPosType(int(val + 0.5));
if (cons[1].inpUion.crv.pos == VX_CURVE_BLEND_POS_ARC_LENGTH)
cvxGetNumber("[Value]Specify arc length", &cons[1].inpUion.crv.value);
else if (cons[1].inpUion.crv.pos == VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH)
cvxGetNumber("[Value]Specify percentage of arc length", &cons[1].inpUion.crv.value);
else if (cons[1].inpUion.crv.pos == VX_CURVE_BLEND_POS_THROUGH_POINT)
cvxGetPointOnEnt("[Point]Select a point on curve", VX_INP_PNT_ON_CURVE, 0, &cons[1].inpUion.crv.throughPnt.pnt,
&cons[1].inpUion.crv.throughPnt.entPath);
cvxGetNumber("[Keep Side]0-long, 1-short", &val);
cons[1].inpUion.crv.keepside = int(val + 0.5);
}
else if (data.endObjType == 1)
{
cvxGetNumber("[Blend Direction]0-sectional, 1-Iso u, 2-Iso v", &val);
cons[1].inpUion.face.blendDir = evxCrvBlendDirType(int(val + 0.5));
if (cons[1].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_SECTIONAL)
cvxGetNumber("[Angle]Specify angle", &cons[1].inpUion.face.value);
else if (cons[1].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_ISO_U)
cvxGetNumber("[Iso U]Specify percentage", &cons[1].inpUion.face.value);
else if (cons[1].inpUion.face.blendDir == VX_CURVE_BLEND_DIR_ISO_V)
cvxGetNumber("[Iso V]Specify percentage", &cons[1].inpUion.face.value);
}
}
/* create curve blend */
int idEnt = 0;
if (cvxPartBlendCrvs(&data, &idEnt))
zwTestLogErrorMsg(5, "cvxPartCrvBlend: failed to create curve blend!");
}
evxCrvBlendDirType
evxCrvBlendDirType
blend location type for face to blend
Definition: zwapi_cmd_wireframe_data.h:390
VX_CURVE_BLEND_DIR_ISO_V
@ VX_CURVE_BLEND_DIR_ISO_V
ISO V works as the blend direction and a % of iso v can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:393
VX_CURVE_BLEND_DIR_SECTIONAL
@ VX_CURVE_BLEND_DIR_SECTIONAL
An angle relative to ISO U is defined to set up blend direction.
Definition: zwapi_cmd_wireframe_data.h:391
VX_CURVE_BLEND_DIR_ISO_U
@ VX_CURVE_BLEND_DIR_ISO_U
ISO U works as the blend direction and a % of iso u can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:392
VX_CRV_TRIM_NONE
@ VX_CRV_TRIM_NONE
no trim
Definition: zwapi_cmd_wireframe_data.h:481
VX_CRV_TRIM_SECOND
@ VX_CRV_TRIM_SECOND
trim only the second curves
Definition: zwapi_cmd_wireframe_data.h:484
VX_CRV_TRIM_BOTH
@ VX_CRV_TRIM_BOTH
trim both curves
Definition: zwapi_cmd_wireframe_data.h:482
VX_CRV_TRIM_FIRST
@ VX_CRV_TRIM_FIRST
trim only the first curves
Definition: zwapi_cmd_wireframe_data.h:483
VX_RECT_3PT
@ VX_RECT_3PT
three points
Definition: zwapi_cmd_wireframe_data.h:143
VX_RECT_2PT
@ VX_RECT_2PT
two points
Definition: zwapi_cmd_wireframe_data.h:141
VX_RECT_WIDTH_HEIGHT
@ VX_RECT_WIDTH_HEIGHT
width and height
Definition: zwapi_cmd_wireframe_data.h:142
VX_ARC_ANGLE
@ VX_ARC_ANGLE
create an arc by defining its center, radius, start angle and arc angle
Definition: zwapi_cmd_wireframe_data.h:69
VX_ARC_THROUGH
@ VX_ARC_THROUGH
create an arc by defining its two endpoints and a third point that arc passes through
Definition: zwapi_cmd_wireframe_data.h:66
VX_ARC_RADIUS
@ VX_ARC_RADIUS
create an arc by defining its two endpoints and radius
Definition: zwapi_cmd_wireframe_data.h:67
VX_ARC_CENTER
@ VX_ARC_CENTER
create an arc by defining its center and two endpoints
Definition: zwapi_cmd_wireframe_data.h:68
VX_CRV_CHAMFER_SETBACK
@ VX_CRV_CHAMFER_SETBACK
setback
Definition: zwapi_cmd_wireframe_data.h:535
VX_CRV_CHAMFER_SETBACK_AND_ANGLE
@ VX_CRV_CHAMFER_SETBACK_AND_ANGLE
setback and angle
Definition: zwapi_cmd_wireframe_data.h:537
VX_CRV_CHAMFER_TWO_SETBACKS
@ VX_CRV_CHAMFER_TWO_SETBACKS
two setbacks
Definition: zwapi_cmd_wireframe_data.h:536
VX_CRV_FILLET_RADIUS
@ VX_CRV_FILLET_RADIUS
radius
Definition: zwapi_cmd_wireframe_data.h:493
VX_CRV_FILLET_BOUNDARY
@ VX_CRV_FILLET_BOUNDARY
boundary
Definition: zwapi_cmd_wireframe_data.h:494
VX_CIRCLE_RADIUS
@ VX_CIRCLE_RADIUS
create a circle by defining its center and radius or diameter
Definition: zwapi_cmd_wireframe_data.h:99
VX_CIRCLE_THROUGH
@ VX_CIRCLE_THROUGH
create a circle by defining 3 boundary points
Definition: zwapi_cmd_wireframe_data.h:100
VX_CIRCLE_2POINT
@ VX_CIRCLE_2POINT
create a circle by defining 2 boundary points
Definition: zwapi_cmd_wireframe_data.h:102
VX_CIRCLE_2PT_RADIUS
@ VX_CIRCLE_2PT_RADIUS
create a circle by defining 2 boundary points and radius
Definition: zwapi_cmd_wireframe_data.h:101
VX_CIRCLE_BOUNDARY
@ VX_CIRCLE_BOUNDARY
create a circle by defining its center and a boundary point
Definition: zwapi_cmd_wireframe_data.h:98
evxCrvBlendPosType
evxCrvBlendPosType
blend location type for curve to blend
Definition: zwapi_cmd_wireframe_data.h:379
VX_CURVE_BLEND_POS_THROUGH_POINT
@ VX_CURVE_BLEND_POS_THROUGH_POINT
Picking a pick on curve as the blend location.
Definition: zwapi_cmd_wireframe_data.h:382
VX_CURVE_BLEND_POS_ARC_LENGTH
@ VX_CURVE_BLEND_POS_ARC_LENGTH
location to blend is defined by arc length
Definition: zwapi_cmd_wireframe_data.h:380
VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
@ VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
location to blend is defined by % of arc length
Definition: zwapi_cmd_wireframe_data.h:381
VX_LINE_ANGLE
@ VX_LINE_ANGLE
create a line between two points and at an angle to the reference direction
Definition: zwapi_cmd_wireframe_data.h:38
VX_LINE_ALONG_DIR
@ VX_LINE_ALONG_DIR
create a line in the same direction as the reference by start point and length
Definition: zwapi_cmd_wireframe_data.h:35
VX_LINE_PERP
@ VX_LINE_PERP
create a line between two points and perpendicular to the reference direction
Definition: zwapi_cmd_wireframe_data.h:37
VX_LINE_PARALLEL
@ VX_LINE_PARALLEL
create a line parallel to the reference direction by point and length
Definition: zwapi_cmd_wireframe_data.h:36
VX_LINE_2PT
@ VX_LINE_2PT
create a line between two points
Definition: zwapi_cmd_wireframe_data.h:34
VX_LINE_MIDDDLE
@ VX_LINE_MIDDDLE
create a line by conforming the middle point and a end point
Definition: zwapi_cmd_wireframe_data.h:39
evxCrvBlendTrimType
evxCrvBlendTrimType
trim (or extend) curves type of curve blend
Definition: zwapi_cmd_wireframe_data.h:367
VX_CURVE_BLEND_FACE
@ VX_CURVE_BLEND_FACE
face
Definition: zwapi_cmd_wireframe_data.h:430
VX_CURVE_BLEND_CURVE
@ VX_CURVE_BLEND_CURVE
curve
Definition: zwapi_cmd_wireframe_data.h:429
evxTrimWithCrvType
evxTrimWithCrvType
trim with curve mode
Definition: zwapi_cmd_wireframe_data.h:586
VX_TRIM_WITH_CRV_SPLIT
@ VX_TRIM_WITH_CRV_SPLIT
The trimmed curves will be split at the boundary curves (or point).
Definition: zwapi_cmd_wireframe_data.h:589
cvxPartPntsOnCrv
evxErrors cvxPartPntsOnCrv(int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
cvxPartFittingCrv
evxErrors cvxPartFittingCrv(int iCnt, svxPoint *pnts, double tol, double smth, int *idEnt)
cvxPartBlendCrvsInit
evxErrors cvxPartBlendCrvsInit(svxCrvBlendData *data)
cvxPartCrvInt
evxErrors cvxPartCrvInt(svxCrvIntData *Crv, int *idEnt)
cvxPartFaceCurve
evxErrors cvxPartFaceCurve(const svxFaceCrvData *data, int *cntEnts, int **idEnts)
cvxPartRectangleInit
evxErrors cvxPartRectangleInit(svxRectangleData *data)
cvxPartSpiralCurve
evxErrors cvxPartSpiralCurve(const svxSpiralCrvData *data, int *idEnt)
cvxPartPolyLine
evxErrors cvxPartPolyLine(const svxPolylineData *polylinedata, int *Cnt, int **idEnt)
cvxPartCrvOnFaceThruPtsInit
evxErrors cvxPartCrvOnFaceThruPtsInit(svxCrvOnFaceThuPts *data)
cvxPartCrvChamfer
evxErrors cvxPartCrvChamfer(const svxCrvChamferData *data, int *idChamfer)
cvxPartPnts
evxErrors cvxPartPnts(int Count, svxPoint *Points)
cvxPartCrvTrimToFaces
evxErrors cvxPartCrvTrimToFaces(const svxCrvTrimToFacesData *data, int *idTrim)
cvxPartLineInit
evxErrors cvxPartLineInit(svxLineData *lineData)
cvxPartBlendCrvsConsInit
evxErrors cvxPartBlendCrvsConsInit(svxCrvBlendCons *consData, evxCrvBlendObjType objType)
cvxPartCrvFilletChain
evxErrors cvxPartCrvFilletChain(const svxCrvFilletChainData *data, int *idFilletChain)
cvxPartCircle
evxErrors cvxPartCircle(const svxCircleData *circleData, int *idCircle)
cvxPartLine
evxErrors cvxPartLine(const svxLineData *lineData, int *idLine)
cvxSplinePntInit
evxErrors cvxSplinePntInit(svxSplinePnt *data)
cvxPartArcInit
evxErrors cvxPartArcInit(svxArcData *arcData)
cvxPartPntNew
evxErrors cvxPartPntNew(int Count, const svxPntOnEntPath *PntData, int idAlignPln, int PrjToPln, int *idPntFtr)
cvxPartCrvProjToFace
evxErrors cvxPartCrvProjToFace(const svxCrvProjToFace *data, int *cntEnts, int **pEnts)
cvxPartCircleInit
evxErrors cvxPartCircleInit(svxCircleData *circleData)
cvxPartEllipse
evxErrors cvxPartEllipse(svxRectangleData *ellipseData, int *idEnt)
cvxPartEllipseInit
evxErrors cvxPartEllipseInit(svxRectangleData *data)
cvxPartPolylineInit
evxErrors cvxPartPolylineInit(svxPolylineData *data)
cvxPartCurveOffset
evxErrors cvxPartCurveOffset(int idCurve, double Dis, int *idOut)
cvxPartCrvFillet
evxErrors cvxPartCrvFillet(const svxCrvFilletData *data, int *idFillet)
cvxPartCrvIntInit
evxErrors cvxPartCrvIntInit(svxCrvIntData *data)
cvxPartRectangle
evxErrors cvxPartRectangle(svxRectangleData *rectData, int *iCnt, int **idEnt)
cvxPartSplineInit
evxErrors cvxPartSplineInit(svxSplineData *data, int count)
cvxPartCrvFilletChainInit
evxErrors cvxPartCrvFilletChainInit(svxCrvFilletChainData *data)
cvxPartCurveSilh
evxErrors cvxPartCurveSilh(int idCurve, svxPoint *dir, int *iCnt, int **idList)
cvxPartCrvProjToFaceInit
evxErrors cvxPartCrvProjToFaceInit(svxCrvProjToFace *data)
cvxPartCir3pt
evxErrors cvxPartCir3pt(svxPoint *P1, svxPoint *P2, svxPoint *P3, int *idEnt)
cvxPartPnt
evxErrors cvxPartPnt(svxPoint *Point, int *idEnt)
cvxPartBlendCrvs
evxErrors cvxPartBlendCrvs(const svxCrvBlendData *data, int *idEnt)
cvxPartCrvTrimWithCrv
evxErrors cvxPartCrvTrimWithCrv(const svxTrimWithCrvData *data, int *CountCrvs, int **NewCrvs)
cvxPartArc3pt
evxErrors cvxPartArc3pt(svxPoint *Start, svxPoint *End, svxPoint *Mid, int *idEnt)
cvxPartCirRad
evxErrors cvxPartCirRad(svxMatrix *Plane, double Radius, int *idEnt)
cvxPartCrvChamferInit
evxErrors cvxPartCrvChamferInit(svxCrvChamferData *data)
cvxPartExtractCenterlines
evxErrors cvxPartExtractCenterlines(int cntFaces, int *idFaces, int extractAxis, int *cntEnts, int **idEnts)
cvxPartCurve
evxErrors cvxPartCurve(svxCurve *Crv, int *idEnt)
cvxPartArc
evxErrors cvxPartArc(const svxArcData *arcData, int *idArc)
cvxPartSpline
evxErrors cvxPartSpline(const svxSplineData *PntData, int *idEnt)
cvxPartCrvList
evxErrors cvxPartCrvList(int Count, int *Curves, int *idEnt)
cvxPartCrvSplitAtPnts
evxErrors cvxPartCrvSplitAtPnts(int idCurve, int CountPnts, svxPoint *Points, int *CountCrvs, int **NewCrvs)
cvxPartArcRad
evxErrors cvxPartArcRad(svxMatrix *Plane, double Radius, double Start, double End, int *idEnt)
cvxPartLine2pt
evxErrors cvxPartLine2pt(svxPoint *Start, svxPoint *End, int *idEnt)
cvxPartCrvOnFaceThruPts
evxErrors cvxPartCrvOnFaceThruPts(const svxCrvOnFaceThuPts *data, int *idEnt)
cvxPartCrvFilletInit
evxErrors cvxPartCrvFilletInit(svxCrvFilletData *data)
cvxEntPnt
evxErrors cvxEntPnt(int idEntity, svxPoint *Pnt)
cvxMatInit
void cvxMatInit(svxMatrix *Mat)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxPartPntBlock
int cvxPartPntBlock(vxLongName Name, int Count, svxPointf *Points, int *idEnt)
cvxPartProjStl
evxErrors cvxPartProjStl(int idStl, int idPln, double tol, double smth, int *idCurve)
cvxPartInqCurve
evxErrors cvxPartInqCurve(int idEntity, int Nurb, svxCurve *Crv)
cvxCurveFree
void cvxCurveFree(svxCurve *Crv)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetPointsOnEnts
evxErrors cvxGetPointsOnEnts(const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_WIREFRAME
@ VX_INP_WIREFRAME
pick wireframe
Definition: zwapi_userinput.h:52
VX_INP_MOVE
@ VX_INP_MOVE
pick move
Definition: zwapi_userinput.h:53
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
VX_PLACING_WCS
@ VX_PLACING_WCS
WCS.
Definition: zwapi_util.h:2389
VX_PLACING_PLANE
@ VX_PLACING_PLANE
PLANE.
Definition: zwapi_util.h:2390
VX_PLACING_VECTOR
@ VX_PLACING_VECTOR
vector
Definition: zwapi_util.h:2388
VX_PLACING_VIEW
@ VX_PLACING_VIEW
view , 3d spline default value
Definition: zwapi_util.h:2387
VX_PLACING_NONE
@ VX_PLACING_NONE
none , 2d spline default value
Definition: zwapi_util.h:2386
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxFairingType
evxFairingType
fairing modes
Definition: zwapi_util.h:2315
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
VX_EXTEND_UNDEFINED
@ VX_EXTEND_UNDEFINED
linear extend is the default when extension is undefined
Definition: zwapi_util.h:2301
evxContinuityTyp
evxContinuityTyp
Continuity option.
Definition: zwapi_util.h:2355
VX_CONTIN_G1
@ VX_CONTIN_G1
tangent
Definition: zwapi_util.h:2357
VX_CONTIN_NONE
@ VX_CONTIN_NONE
none
Definition: zwapi_util.h:2356
VX_CONTIN_G3
@ VX_CONTIN_G3
flow
Definition: zwapi_util.h:2359
VX_CONTIN_G2
@ VX_CONTIN_G2
curvature
Definition: zwapi_util.h:2358
svxArcData::arcDir
int arcDir
indicate the direction for angular input (0: counter; 1: clockwise), used when type is VX_ARC_CENTER ...
Definition: zwapi_cmd_wireframe_data.h:88
svxArcData::arcAngle
double arcAngle
angle of arc (deg), used when type is VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:84
svxArcData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore)
Definition: zwapi_cmd_wireframe_data.h:86
svxArcData::startAngle
double startAngle
start angle of arc (deg), used when type is VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:83
svxArcData::radius
double radius
radius of arc, used when type is VX_ARC_RADIUS
Definition: zwapi_cmd_wireframe_data.h:82
svxArcData::startPnt
svxPntOnEntPath startPnt
start point of arc, used when type isn't VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:79
svxArcData::endPnt
svxPntOnEntPath endPnt
end point of arc, used when type isn't VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:80
svxArcData::centerPnt
svxPntOnEntPath centerPnt
through point or center point of arc, used when type is VX_ARC_THROUGH or VX_ARC_CENTER
Definition: zwapi_cmd_wireframe_data.h:81
svxArcData::prjToPln
int prjToPln
whether to project arc to alignment plane
Definition: zwapi_cmd_wireframe_data.h:87
svxArcData::location
svxPntOnEntPath * location
indicate arc, used when type is VX_ARC_RADIUS
Definition: zwapi_cmd_wireframe_data.h:89
svxArcData::arcType
evxArcType arcType
type to create an arc
Definition: zwapi_cmd_wireframe_data.h:78
svxArcData
3D arc data
Definition: zwapi_cmd_wireframe_data.h:77
svxCircleData::useDiameter
int useDiameter
indicate radius or diameter (0: radius; 1: diameter), used when type is VX_CIRCLE_RADIUS
Definition: zwapi_cmd_wireframe_data.h:114
svxCircleData::centerPnt
svxPntOnEntPath centerPnt
center point of circle, used when type is VX_CIRCLE_BOUNDARY or VX_CIRCLE_RADIUS
Definition: zwapi_cmd_wireframe_data.h:112
svxCircleData::location
svxPntOnEntPath * location
indicate circle, used when type is VX_CIRCLE_2PT_RADIUS
Definition: zwapi_cmd_wireframe_data.h:119
svxCircleData::prjToPln
int prjToPln
whether to project circle to alignment plane
Definition: zwapi_cmd_wireframe_data.h:118
svxCircleData::bndPnts
svxPntOnEntPath bndPnts[3]
boundary points of circle, fill the array with the number of bounding points required by type
Definition: zwapi_cmd_wireframe_data.h:113
svxCircleData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore)
Definition: zwapi_cmd_wireframe_data.h:117
svxCircleData::radOrDia
double radOrDia
radius or diameter of circle, used when type is VX_CIRCLE_RADIUS or VX_CIRCLE_2PT_RADIUS
Definition: zwapi_cmd_wireframe_data.h:115
svxCircleData::type
evxCircleType type
type to create a circle
Definition: zwapi_cmd_wireframe_data.h:111
svxCircleData
3D circle data
Definition: zwapi_cmd_wireframe_data.h:110
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::keepside
int keepside
0-long, 1-short
Definition: zwapi_cmd_wireframe_data.h:410
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::pos
evxCrvBlendPosType pos
define specific location to blend, VX_CURVE_BLEND_POS_THROUGH_POINT as default
Definition: zwapi_cmd_wireframe_data.h:409
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::blendDir
evxCrvBlendDirType blendDir
define specific location to blend. VX_CURVE_BLEND_DIR_ISO_U as default
Definition: zwapi_cmd_wireframe_data.h:417
svxCrvBlendCons::tangentDirFlip
int tangentDirFlip
1 to flip tangent direction, else 0
Definition: zwapi_cmd_wireframe_data.h:403
svxCrvBlendCons::continuity
evxContinuityTyp continuity
continuity method used for refitting and blending the curves, VX_CONTIN_G1 as default
Definition: zwapi_cmd_wireframe_data.h:402
svxCrvBlendCons
curve blend constraints
Definition: zwapi_cmd_wireframe_data.h:401
svxCrvBlendData::endObjFlip
int endObjFlip
1 to flip end object position, else 0
Definition: zwapi_cmd_wireframe_data.h:444
svxCrvBlendData::curvature
int curvature
1 to display curvature, else 0
Definition: zwapi_cmd_wireframe_data.h:447
svxCrvBlendData::endObjType
evxCrvBlendObjType endObjType
end object type, VX_CURVE_BLEND_CURVE as default
Definition: zwapi_cmd_wireframe_data.h:442
svxCrvBlendData::trim
evxCrvBlendTrimType trim
trim type, VX_CURVE_BLEND_TRIM_BOTH as default
Definition: zwapi_cmd_wireframe_data.h:446
svxCrvBlendData::endObj
svxPntOnEntPath endObj
end object
Definition: zwapi_cmd_wireframe_data.h:443
svxCrvBlendData::endpointPick
int endpointPick
1 to pick endpoint by default, else 0. 1 as default
Definition: zwapi_cmd_wireframe_data.h:448
svxCrvBlendData::startObj
svxPntOnEntPath startObj
start object
Definition: zwapi_cmd_wireframe_data.h:440
svxCrvBlendData::endCons
svxCrvBlendCons * endCons
end constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:451
svxCrvBlendData::startObjFlip
int startObjFlip
1 to flip start object position, else 0
Definition: zwapi_cmd_wireframe_data.h:441
svxCrvBlendData::startObjType
evxCrvBlendObjType startObjType
start object type, VX_CURVE_BLEND_CURVE as default
Definition: zwapi_cmd_wireframe_data.h:439
svxCrvBlendData::startCons
svxCrvBlendCons * startCons
start constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:450
svxCrvBlendData
curve blend data
Definition: zwapi_cmd_wireframe_data.h:438
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::angle
double angle
angle of the first curve
Definition: zwapi_cmd_wireframe_data.h:562
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::setback
double setback
the first setback
Definition: zwapi_cmd_wireframe_data.h:561
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::secondSetback
double secondSetback
the second setback
Definition: zwapi_cmd_wireframe_data.h:556
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::firstSetback
double firstSetback
the first setback
Definition: zwapi_cmd_wireframe_data.h:555
svxCrvChamferData::trimType
evxCrvTrimType trimType
trim type (VX_CRV_TRIM_BOTH as default)
Definition: zwapi_cmd_wireframe_data.h:565
svxCrvChamferData::method
evxCrvChamferMethods method
method to create a chamfer (VX_CRV_CHAMFER_SETBACK as default)
Definition: zwapi_cmd_wireframe_data.h:546
svxCrvChamferData::extensionType
evxExtendOpt extensionType
extension type (VX_EXTEND_CIRCULAR as default)
Definition: zwapi_cmd_wireframe_data.h:566
svxCrvChamferData::firstPnt
svxPntOnEntPath firstPnt
the first curve to chamfer
Definition: zwapi_cmd_wireframe_data.h:547
svxCrvChamferData::secondPnt
svxPntOnEntPath secondPnt
the second curve to chamfer
Definition: zwapi_cmd_wireframe_data.h:548
svxCrvChamferData
curve chamfer data
Definition: zwapi_cmd_wireframe_data.h:545
svxCrvFilletChainData::trimOriginal
int trimOriginal
whether to trim original curves (1 as default)
Definition: zwapi_cmd_wireframe_data.h:526
svxCrvFilletChainData::count
int count
count of curves
Definition: zwapi_cmd_wireframe_data.h:522
svxCrvFilletChainData::designerArc
int designerArc
whether to use designer arc (0 as default)
Definition: zwapi_cmd_wireframe_data.h:525
svxCrvFilletChainData::curves
int * curves
list ids of curves
Definition: zwapi_cmd_wireframe_data.h:523
svxCrvFilletChainData::radius
double radius
radius to fillet
Definition: zwapi_cmd_wireframe_data.h:524
svxCrvFilletChainData
curve fillet chain data
Definition: zwapi_cmd_wireframe_data.h:521
svxCrvFilletData::firstPnt
svxPntOnEntPath firstPnt
the first curve to fillet
Definition: zwapi_cmd_wireframe_data.h:504
svxCrvFilletData::designerArc
int designerArc
whether to use designer arc (0 as default)
Definition: zwapi_cmd_wireframe_data.h:513
svxCrvFilletData::method
evxCrvFilletMethods method
method to create a fillet (VX_CRV_FILLET_RADIUS as default)
Definition: zwapi_cmd_wireframe_data.h:503
svxCrvFilletData::extensionType
evxExtendOpt extensionType
extension type (VX_EXTEND_LINEAR as default)
Definition: zwapi_cmd_wireframe_data.h:512
svxCrvFilletData::secondPnt
svxPntOnEntPath secondPnt
the second curve to fillet
Definition: zwapi_cmd_wireframe_data.h:505
svxCrvFilletData::trimType
evxCrvTrimType trimType
curve trim type (VX_CRV_TRIM_BOTH as default)
Definition: zwapi_cmd_wireframe_data.h:511
svxCrvFilletData
curve fillet data
Definition: zwapi_cmd_wireframe_data.h:502
svxCrvIntData::UseEndTan
int UseEndTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2342
svxCrvIntData::Count
int Count
number of points to interpolate
Definition: zwapi_util.h:2333
svxCrvIntData::StartTan
svxVector StartTan
normalized start tangent direction vector
Definition: zwapi_util.h:2339
svxCrvIntData::EndScale
double EndScale
end tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2344
svxCrvIntData::UseStartTan
int UseStartTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2338
svxCrvIntData::Degree
int Degree
curve degree (2 - 6)
Definition: zwapi_util.h:2332
svxCrvIntData::Points
svxPoint * Points
pointer to list of points to interpolate
Definition: zwapi_util.h:2334
svxCrvIntData::isClosed
int isClosed
1 if curve is closed, 0 if open
Definition: zwapi_util.h:2331
svxCrvIntData::StartScale
double StartScale
start tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2340
svxCrvIntData::EndTan
svxVector EndTan
normalized end tangent direction vector
Definition: zwapi_util.h:2343
svxCrvIntData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2346
svxCrvIntData
2D/3D interpolated curve
Definition: zwapi_util.h:2329
svxCrvOnFaceThuPts::face
int face
face to create the curve on
Definition: zwapi_cmd_wireframe_data.h:222
svxCrvOnFaceThuPts::endCons
svxCrvOnFaceThuPtsCons * endCons
end constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:228
svxCrvOnFaceThuPts::fairing
evxFairingType fairing
fairing mode, VX_FAIRING_NONE as default
Definition: zwapi_cmd_wireframe_data.h:226
svxCrvOnFaceThuPts::pts
svxPoint * pts
points on the face for the curve to pass through
Definition: zwapi_cmd_wireframe_data.h:224
svxCrvOnFaceThuPts::cntPts
int cntPts
number of points
Definition: zwapi_cmd_wireframe_data.h:223
svxCrvOnFaceThuPts::startCons
svxCrvOnFaceThuPtsCons * startCons
start constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:227
svxCrvOnFaceThuPts::isOpen
int isOpen
whether to create open curve, 1 as default
Definition: zwapi_cmd_wireframe_data.h:225
svxCrvOnFaceThuPtsCons::continuity
evxContinuityTyp continuity
continuity method used for creating curves, between VX_CONTIN_NONE and VX_CONTIN_G2 (VX_CONTIN_NONE a...
Definition: zwapi_cmd_wireframe_data.h:209
svxCrvOnFaceThuPtsCons::flip
int flip
whether to reverse the tangent direction
Definition: zwapi_cmd_wireframe_data.h:212
svxCrvOnFaceThuPtsCons
curve on face through points constraint
Definition: zwapi_cmd_wireframe_data.h:208
svxCrvOnFaceThuPts
curve on face through points data
Definition: zwapi_cmd_wireframe_data.h:221
svxCrvProjToFace::biDir
int biDir
Use this option to project the curves in both the positive and the negative directions relative to th...
Definition: zwapi_cmd_wireframe_data.h:182
svxCrvProjToFace::trim
int trim
Use this option to project only to the trim boundaries of a face. If you are projecting onto a trimme...
Definition: zwapi_cmd_wireframe_data.h:184
svxCrvProjToFace::pCrvs
int * pCrvs
a sketch or curves
Definition: zwapi_cmd_wireframe_data.h:176
svxCrvProjToFace::pFaces
int * pFaces
faces or datum planes to project curves onto
Definition: zwapi_cmd_wireframe_data.h:178
svxCrvProjToFace::pDir
svxVector * pDir
By default, the projection direction is normal to the surface. Use this option to define a different ...
Definition: zwapi_cmd_wireframe_data.h:179
svxCrvProjToFace::cntFaces
int cntFaces
count of faces
Definition: zwapi_cmd_wireframe_data.h:177
svxCrvProjToFace::cntCrvs
int cntCrvs
count of curves
Definition: zwapi_cmd_wireframe_data.h:175
svxCrvProjToFace
project to face data
Definition: zwapi_cmd_wireframe_data.h:174
svxCrvTrimToFacesData::cntFaces
int cntFaces
count of the trimming faces or shapes
Definition: zwapi_cmd_wireframe_data.h:619
svxCrvTrimToFacesData::pFaces
int * pFaces
index of the trimming faces or shapes
Definition: zwapi_cmd_wireframe_data.h:620
svxCrvTrimToFacesData::cntCrvs
int cntCrvs
count of curves or sketches to trim
Definition: zwapi_cmd_wireframe_data.h:617
svxCrvTrimToFacesData::pCrvs
int * pCrvs
index of curves or sketches to trim
Definition: zwapi_cmd_wireframe_data.h:618
svxCrvTrimToFacesData::flip
int flip
1 to flip the arrows to keep the opposite side, else 0
Definition: zwapi_cmd_wireframe_data.h:621
svxCrvTrimToFacesData
trim to faces data
Definition: zwapi_cmd_wireframe_data.h:616
svxCurve::Type
evxCurveType Type
curve type
Definition: zwapi_util.h:1680
svxCurve::A2
double A2
arc start/end angles (degrees)
Definition: zwapi_util.h:1684
svxCurve::P2
svxPoint P2
line start/end points or center of 2D circle/arc
Definition: zwapi_util.h:1683
svxCurve::R
double R
circle/arc radius
Definition: zwapi_util.h:1685
svxCurve::Frame
svxMatrix Frame
local frame (origin is center of 3D circle/arc)
Definition: zwapi_util.h:1681
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::seam
int seam
1 to create face curves along seam edges, 0 to ignore
Definition: zwapi_cmd_wireframe_data.h:339
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::pEdge
int * pEdge
If this field is empty, face curves are created surrounding the region formed by the selected faces....
Definition: zwapi_cmd_wireframe_data.h:334
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::cntEdge
int cntEdge
count of edges
Definition: zwapi_cmd_wireframe_data.h:333
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::cntCrv
int cntCrv
count of curves
Definition: zwapi_cmd_wireframe_data.h:343
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::dir
svxVector * dir
direction curves are projected onto (NULL to projected in the direction of minimum distance from the ...
Definition: zwapi_cmd_wireframe_data.h:345
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::pCrv
int * pCrv
curves, sketches, curve lists and edges to project onto the selected faces
Definition: zwapi_cmd_wireframe_data.h:344
svxFaceCrvData::method
int method
create face curves method (0-from edges, 1-from projected curves)
Definition: zwapi_cmd_wireframe_data.h:325
svxFaceCrvData::cntFaces
int cntFaces
count of faces on which to create the face curves
Definition: zwapi_cmd_wireframe_data.h:326
svxFaceCrvData::pFaces
int * pFaces
index of faces on which to create the face curves
Definition: zwapi_cmd_wireframe_data.h:327
svxFaceCrvData::partingLine
int partingLine
1 to add the selected Edges as parting line, else 0
Definition: zwapi_cmd_wireframe_data.h:328
svxFaceCrvData
face curve data
Definition: zwapi_cmd_wireframe_data.h:324
svxLineData::refDir
svxDirOnEntPath refDir
reference direction, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL, VX_LINE_PERP,...
Definition: zwapi_cmd_wireframe_data.h:49
svxLineData::length
double length
length of line, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL
Definition: zwapi_cmd_wireframe_data.h:52
svxLineData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore), used when type is VX_LINE_2PT,...
Definition: zwapi_cmd_wireframe_data.h:56
svxLineData::point2
svxPntOnEntPath point2
the end point, used when type is VX_LINE_2PT, VX_LINE_PERP, VX_LINE_ANGLE, VX_LINE_MIDDDLE
Definition: zwapi_cmd_wireframe_data.h:51
svxLineData::prjToPln
int prjToPln
whether to project line to alignment plane, used when type is VX_LINE_2PT, VX_LINE_MIDDDLE
Definition: zwapi_cmd_wireframe_data.h:57
svxLineData::angle
double angle
angle from the reference direction, used when type is VX_LINE_ANGLE
Definition: zwapi_cmd_wireframe_data.h:54
svxLineData::offset
double offset
offset distance from the reference direction, used when type is VX_LINE_PARALLEL
Definition: zwapi_cmd_wireframe_data.h:53
svxLineData::point1
svxPntOnEntPath point1
start point or middle point
Definition: zwapi_cmd_wireframe_data.h:50
svxLineData::lineType
evxLineType lineType
type to create line
Definition: zwapi_cmd_wireframe_data.h:48
svxLineData
3D line data
Definition: zwapi_cmd_wireframe_data.h:47
svxMatrix::xt
double xt
cosines of X axis and origin X (xt)
Definition: zwapi_util.h:481
svxMatrix::identity
char identity
1 if identity matrix, else 0
Definition: zwapi_util.h:480
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath::entPath
svxEntPath entPath
entity path that the point on
Definition: zwapi_util.h:570
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxPointf
3D point (single precision floating point)
Definition: zwapi_util.h:317
svxPolylineData::numPoint
int numPoint
number of points to construct polyline
Definition: zwapi_cmd_wireframe_data.h:128
svxPolylineData::projectToPln
int projectToPln
1-project to the align plane, else 0 (1 as default)
Definition: zwapi_cmd_wireframe_data.h:131
svxPolylineData::pPoints
svxPntOnEnt * pPoints
pointer to list of points to construct polyline
Definition: zwapi_cmd_wireframe_data.h:129
svxPolylineData::pntOnPln
int pntOnPln
1-points on align plane, else 0 (0 as default)
Definition: zwapi_cmd_wireframe_data.h:132
svxPolylineData::idAligPln
int idAligPln
id of Align plane, -1 as default
Definition: zwapi_cmd_wireframe_data.h:130
svxPolylineData
3D polyline data
Definition: zwapi_cmd_wireframe_data.h:127
svxRectangleData::pts
svxPoint pts[3]
3 input points depend on "type"
Definition: zwapi_cmd_wireframe_data.h:156
svxRectangleData::angle
double angle
rotation angle
Definition: zwapi_cmd_wireframe_data.h:161
svxRectangleData::parallelogram
int parallelogram
0 rectangle, 1 parallelogram
Definition: zwapi_cmd_wireframe_data.h:163
svxRectangleData::firstPtType
int firstPtType
type of 1st input point (0 corner, 1 center)
Definition: zwapi_cmd_wireframe_data.h:155
svxRectangleData::width
double width
width if "type" is VX_RECT_WIDTH_HEIGHT
Definition: zwapi_cmd_wireframe_data.h:157
svxRectangleData::height
double height
height if "type" is VX_RECT_WIDTH_HEIGHT
Definition: zwapi_cmd_wireframe_data.h:158
svxRectangleData::type
evxRectangleType type
type to make rectangle
Definition: zwapi_cmd_wireframe_data.h:153
svxRectangleData::idPlane
int idPlane
not required if "type" is VX_RECT_3PT
Definition: zwapi_cmd_wireframe_data.h:154
svxRectangleData::prjFirstPt
int prjFirstPt
1 to project first point to plane, 0 not
Definition: zwapi_cmd_wireframe_data.h:162
svxRectangleData
3D ellipse & rectangle data
Definition: zwapi_cmd_wireframe_data.h:151
svxSpiralCrvData::offset
double offset
the value the turn offset, that is the distance between two turns. A positive value indicates an exte...
Definition: zwapi_cmd_wireframe_data.h:463
svxSpiralCrvData::axis
svxVector axis
the spiral axis, it can be the coordinate axis, line or point
Definition: zwapi_cmd_wireframe_data.h:461
svxSpiralCrvData::pRefDir
svxVector * pRefDir
the reference direction for spiral curve (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:467
svxSpiralCrvData::turns
double turns
the number of turns
Definition: zwapi_cmd_wireframe_data.h:462
svxSpiralCrvData::ang
double ang
the angle of spiral curve
Definition: zwapi_cmd_wireframe_data.h:468
svxSpiralCrvData::revolve
int revolve
1 to revolve the curve clockwise about the specified axis, else revolve the curve anti-clockwise.
Definition: zwapi_cmd_wireframe_data.h:465
svxSpiralCrvData::startPnt
svxPoint startPnt
the start point
Definition: zwapi_cmd_wireframe_data.h:460
svxSpiralCrvData
spiral curve data
Definition: zwapi_cmd_wireframe_data.h:459
svxSplineData::SingleSeg
int SingleSeg
single segment (0 as default)
Definition: zwapi_util.h:2409
svxSplineData::PlacingDir
svxVector PlacingDir
Placing adjustment director (PlacingTyp = VX_PLACING_VECTOR)
Definition: zwapi_util.h:2413
svxSplineData::SplineTyp
int SplineTyp
0- through point, 1- control point (0 as default))
Definition: zwapi_util.h:2400
svxSplineData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2407
svxSplineData::CreateCrvOpen
int CreateCrvOpen
1-create curve open, 0-create close curve(1 as default)
Definition: zwapi_util.h:2406
svxSplineData::Degree
int Degree
degree (3 as default)
Definition: zwapi_util.h:2403
svxSplineData::PlacingTyp
evxPlacingType PlacingTyp
placing adjustment type
Definition: zwapi_util.h:2412
svxSplineData::Pnts
svxSplinePnt * Pnts
point list
Definition: zwapi_util.h:2402
svxSplineData
Spline command data.
Definition: zwapi_util.h:2398
svxSplinePnt::ContinuityTyp
evxContinuityTyp ContinuityTyp
continuity type (VX_NONE as default)
Definition: zwapi_util.h:2371
svxSplinePnt::FlipDir
int FlipDir
1-flip the TangDir, else 0 (0 as default)
Definition: zwapi_util.h:2377
svxSplinePnt::dG2Radius
double dG2Radius
G2 radius(use this when UseG2Radius != 0)
Definition: zwapi_util.h:2376
svxSplinePnt::UseG1Manitude
int UseG1Manitude
1-use G1 magnitude, else 0 (0 as default)
Definition: zwapi_util.h:2373
svxSplinePnt::UseG2Radius
int UseG2Radius
1-use G2 radius, else 0 (0 as default)
Definition: zwapi_util.h:2375
svxSplinePnt::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:2368
svxSplinePnt::TangDir
svxVector TangDir
tangent direction at this point (ContinuityTyp != VX_CONTIN_NONE)
Definition: zwapi_util.h:2372
svxSplinePnt::UseCons
int UseCons
1-use the constraints data ,else 0 (0 as default)
Definition: zwapi_util.h:2369
svxSplinePnt::dG1Manitude
double dG1Manitude
G1 magnitude (use this when UseG1Manitude != 0 )
Definition: zwapi_util.h:2374
svxTrimWithCrvData::trimMode
evxTrimWithCrvType trimMode
trim mode
Definition: zwapi_cmd_wireframe_data.h:602
svxTrimWithCrvData::cntDelSeg
int cntDelSeg
number of curve segments
Definition: zwapi_cmd_wireframe_data.h:600
svxTrimWithCrvData::pDelSeg
svxPntOnEntPath * pDelSeg
curve segments where you want them to be trimmed away
Definition: zwapi_cmd_wireframe_data.h:601
svxTrimWithCrvData::pPln
svxPntOnEntPath * pPln
Use this option to trim non-intersection 3D curves. You can project the curves onto a plane and deter...
Definition: zwapi_cmd_wireframe_data.h:603
svxTrimWithCrvData::cntCrvs
int cntCrvs
number of curves
Definition: zwapi_cmd_wireframe_data.h:598
svxTrimWithCrvData::pCrvs
int * pCrvs
curves to use as boundaries
Definition: zwapi_cmd_wireframe_data.h:599
svxTrimWithCrvData
trim with curve data
Definition: zwapi_cmd_wireframe_data.h:597
svxVector
3D vector
Definition: zwapi_util.h:338
svxCrvChamferData::evxCrvChamferInpUnion::setback
double setback
setback is a straight line distance between the vertex and the new setback point
Definition: zwapi_cmd_wireframe_data.h:551
svxCrvFilletData::evxCrvFilletInpUnion::settingPnt
svxPntOnEntPath settingPnt
point between the two picked curves to create a full fillet if method is VX_CRV_FILLET_BOUNDARY
Definition: zwapi_cmd_wireframe_data.h:509
svxCrvFilletData::evxCrvFilletInpUnion::radius
double radius
radius to fillet if method is VX_CRV_FILLET_RADIUS
Definition: zwapi_cmd_wireframe_data.h:508
svxFaceCrvData::uvxFaceCrvData::fromEdge
struct svxFaceCrvData::uvxFaceCrvData::uvxFromEdges fromEdge
create face curves from edges data
svxFaceCrvData::uvxFaceCrvData::fromProjCrv
struct svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv fromProjCrv
create face curves from projected curves data
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: sketch\skDrawingTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
sketch\skDrawingTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <cmath>
#include <cstdio>
ApiDefVoidFunc(zwTestSkArc3pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkArcRad, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkEllipse, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkAxis, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkPntsOnCrv, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkCir3pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkCirRad, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkCrvInt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkPnt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkLine2pt, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkAddPolyline, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkChamfer, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkFillet, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkSpline, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkReadyText, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkReference, VX_CODE_GENERAL);
void zwTestSkArc3pt()
/*
DESCRIPTION:
Test case for function cvxSkArc3pt.
*/
{
/* select three points to create an arc */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select three points to create an arc.", VX_INP_PNT_GENERAL, 0, &count, &points);
if (count < 3)
{
zwTestLogErrorMsg(5, "cvxSkArc3pt: too few points!");
cvxMemFree((void**)&points);
return;
}
/* create an arc */
svxPoint2 points2D[3];
for (int i = 0; i < 3; i++)
points2D[i] = { points[i].x, points[i].y };
int idArc = 0;
if (cvxSkArc3pt(&points2D[0], &points2D[1], &points2D[2], &idArc) || idArc == 0)
zwTestLogErrorMsg(5, "cvxSkArc3pt: failed to create an arc!");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestSkArcRad()
/*
DESCRIPTION:
Test case for function cvxSkArcRad.
*/
{
/* select the center point and set parameters */
svxPoint center = { 0 };
cvxGetPoint("select the center point of an arc.", VX_INP_PNT_GENERAL, 0, &center, NULL);
double radius = 50, start = 45, end = 135;
cvxGetNumber("specify radius", &radius);
cvxGetNumber("specify start angle", &start);
cvxGetNumber("specify end angle", &end);
/* create an arc */
svxPoint2 center2D = { center.x, center.y };
int idArc = 0;
if (cvxSkArcRad(&center2D, radius, start, end, &idArc) || idArc == 0)
zwTestLogErrorMsg(5, "cvxSkArcRad: failed to create a 2D arc!");
}
void zwTestSkEllipse()
/*
DESCRIPTION:
Test case for function cvxSkEllipse.
*/
{
/* initialize an ellipse */
svxEllipse ellipse = { };
if (cvxSkEllipseInit(&ellipse))
zwTestLogErrorMsg(5, "cvxSkEllipseInit: failed to initialize an ellipse!");
/* select two points */
svxPoint point = { 0 };
cvxGetPoint("select centroid point", VX_INP_PNT_GENERAL, 0, &ellipse.centroid, nullptr);
cvxGetPoint("select another point", VX_INP_PNT_GENERAL, 0, &point, nullptr);
/* create an ellipse */
ellipse.width = 2 * abs(point.x - ellipse.centroid.x);
ellipse.height = 2 * abs(point.y - ellipse.centroid.y);
int idEllipse = 0;
if (cvxSkEllipse(&ellipse, &idEllipse) || idEllipse == 0)
zwTestLogErrorMsg(5, "cvxSkEllipse: failed to create an ellipse!");
}
void zwTestSkAxis()
/*
DESCRIPTION:
Test case for function cvxSkAxis.
*/
{
/* initialize axis */
svxSkAxisData axis = {};
svxPoint pnt13D = { 0 }, refPnt3D = { 0 }, pnt23D = { 0 };
double val = 0;
/* select a method */
cvxGetNumber("select a method: 0, 1, 2, 3, 4, 5 or 6", &val);
switch (int(val + 0.5))
{
case 0:
axis.Method = VX_SK_AXIS_TWO_PNT;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
cvxGetPoint("select end point", VX_INP_PNT_GENERAL, 0, &pnt23D, &axis.inpUnion.axis2pnt.idEnt2);
axis.inpUnion.axis2pnt.Pnt2.x = pnt23D.x;
axis.inpUnion.axis2pnt.Pnt2.y = pnt23D.y;
break;
case 1:
axis.Method = VX_SK_AXIS_PARAPT;
cvxGetEnt("select a reference line", VX_INP_GENERAL_2D, 0, &axis.idRefEnt);
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
break;
case 2:
axis.Method = VX_SK_AXIS_PERPENDICULAR;
cvxGetEnt("select a reference line", VX_INP_GENERAL_2D, 0, &axis.idRefEnt);
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
break;
case 3:
axis.Method = VX_SK_AXIS_ANGLE;
cvxGetEnt("select a reference line", VX_INP_GENERAL_2D, 0, &axis.idRefEnt);
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
cvxGetNumber("specify angle", &axis.inpUnion.axisAng.Angle);
break;
case 4:
axis.Method = VX_SK_AXIS_PARAOFF;
cvxGetEnt("select a reference line", VX_INP_GENERAL_2D, 0, &axis.idRefEnt);
cvxGetNumber("specify offset", &axis.inpUnion.axisParaOff.Offset);
break;
case 5:
axis.Method = VX_SK_AXIS_HORIZ;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
break;
case 6:
axis.Method = VX_SK_AXIS_VERT;
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &pnt13D, &axis.idEnt1);
break;
default:
zwTestLogErrorMsg(5, "cvxSkAxis: invalid option!");
break;
}
axis.Pnt1 = { pnt13D.x, pnt13D.y };
axis.RefPnt = { refPnt3D.x, refPnt3D.y };
cvxGetNumber("whether construct geometry: 0 or 1", &val);
if (int(val + 0.5))
axis.ConstGeom = 1;
/* create axis */
int idAxis = 0;
if (cvxSkAxis(&axis, &idAxis) || idAxis == 0)
zwTestLogErrorMsg(5, "cvxSkAxis: failed to create an axis!");
}
void zwTestSkPntsOnCrv()
/*
DESCRIPTION:
Test case for function cvxSkPntsOnCrv.
*/
{
/* initialize points on curve */
svxPoint* pnt = nullptr;
svxPoint start = { 0 };
int num = 0;
double dist = 0;
evxExtendOpt opt = VX_EXTEND_UNDEFINED;
double val = 0;
cvxGetNumber("select a method: 0, 1, 2, 3 or 4", &val);
int idCrv = 0;
cvxGetEnt("select a curve", VX_INP_GENERAL_2D, 0, &idCrv);
switch (int(val + 0.5))
{
case 0:
opt = VX_EXTEND_UNDEFINED;
cvxGetNumber("specify number of points", &val);
num = int(val + 0.5);
break;
case 1:
opt = VX_EXTEND_UNDEFINED;
cvxGetPoint("select the start point of the curve", VX_INP_PNT_ON_CURVE, 0, &start, nullptr);
pnt = &start;
cvxGetNumber("specify distance", &dist);
break;
case 2:
case 3:
case 4:
if (int(val + 0.5) == 2)
opt = VX_EXTEND_LINEAR;
else if (int(val + 0.5) == 3)
opt = VX_EXTEND_CIRCULAR;
else
opt = VX_EXTEND_REFLECT;
cvxGetPoint("select the start point of the curve", VX_INP_PNT_ON_CURVE, 0, &start, nullptr);
pnt = &start;
cvxGetNumber("specify number of points", &val);
num = int(val + 0.5);
cvxGetNumber("specify distance", &dist);
break;
default:
zwTestLogErrorMsg(5, "cvxSkPntsOnCrv: invalid option!");
break;
}
/* create points on the curve */
int count = 0;
int* idEnts = nullptr;
if (cvxSkPntsOnCrv(idCrv, pnt, num, dist, opt, &count, &idEnts) || idEnts == nullptr)
zwTestLogErrorMsg(5, "cvxSkPntsOnCrv: failed to create points on a curve!");
/* free memory */
cvxMemFree((void**)&idEnts);
}
void zwTestSkCir3pt()
/*
DESCRIPTION:
Test case for function cvxSkCir3pt.
*/
{
/* specify three points to create a circle */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("specify three points to create a circle.", VX_INP_PNT_GENERAL, 0, &count, &points);
if (count < 3)
{
zwTestLogErrorMsg(5, "cvxSkCir3pt: too few points!");
cvxMemFree((void**)&points);
return;
}
/* use three points to create a circle */
svxPoint2 points2D[3] = { 0 };
for (int i = 0; i < 3; i++)
points2D[i] = { points[i].x, points[i].y };
int idCir = 0;
if (cvxSkCir3pt(&points2D[0], &points2D[1], &points2D[2], &idCir) || idCir == 0)
zwTestLogErrorMsg(5, "cvxSkCir3pt: failed to create a circle!");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestSkCirRad()
/*
DESCRIPTION:
Test case for function cvxSkCirRad.
*/
{
/* use center point and radius to create a circle */
svxPoint center = { 0 };
cvxGetPoint("specify center point", VX_INP_PNT_GENERAL, 0, &center, nullptr);
svxPoint2 center2D = { center.x, center.y };
double radius = 10;
cvxGetNumber("specify radius", &radius);
int idCir = 0;
if (cvxSkCirRad(&center2D, radius, &idCir) || idCir == 0)
zwTestLogErrorMsg(5, "cvxSkCirRad: failed to create a circle!");
}
void zwTestSkCrvInt()
/*
DESCRIPTION:
Test case for function cvxSkCrvInt.
*/
{
/* select some points to create a curve */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select some points to create a curve.", VX_INP_PNT_GENERAL, 0, &count, &points);
/* initialize a curve */
svxCrvIntData crv = {};
if (cvxSkCrvIntInit(&crv))
zwTestLogErrorMsg(5, "cvxSkCrvIntInit: failed to initialize a curve!");
double val = 0;
cvxGetNumber("whether closed: 0 or 1", &val);
if (int(val + 0.5) == 0) /* default 0 */
crv.isClosed = 0;
else
crv.isClosed = 1;
cvxGetNumber("specify degree: 2 - 6", &val);
crv.Degree = int(val + 0.5);
crv.Count = count;
crv.Points = points;
cvxGetNumber("whether use start tangent direction: 0 or 1", &val);
if (int(val + 0.5))
{
crv.UseStartTan = 1;
cvxGetNumber("specify start tangent degree", &val);
crv.StartTan.x = cos(val * V_DEG_TO_RAD);
crv.StartTan.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify start tangent scale: 0.1 - 10.0", &crv.StartScale); // or use cvxSkCrvIntScaleInit to initialize crv.StartScale
}
cvxGetNumber("whether use end tangent direction: 0 or 1", &val);
if (int(val + 0.5))
{
crv.UseEndTan = 1;
cvxGetNumber("specify end tangent degree", &val);
crv.EndTan.x = cos(val * V_DEG_TO_RAD);
crv.EndTan.y = sin(val * V_DEG_TO_RAD);
cvxGetNumber("specify end tangent scale: 0.1 - 10.0", &crv.EndScale); // or use cvxSkCrvIntScaleInit to initialize crv.EndScale
}
cvxGetNumber("select fairing method: 0 - 5", &val);
crv.Fairing = int(val + 0.5);
/* create a curve */
int idCrv = 0;
if (cvxSkCrvInt(&crv, &idCrv) || idCrv == 0)
zwTestLogErrorMsg(5, "cvxSkCrvInt: failed to create a curve");
/* free memory */
cvxMemFree((void**)&points);
}
void zwTestSkPnt()
/*
DESCRIPTION:
Test case for function cvxSkPnt.
*/
{
svxPoint point = { 0 };
cvxGetPoint("select a point to create 2D point", VX_INP_PNT_GENERAL, 0, &point, nullptr);
svxPoint2 point2D = { point.x, point.y };
int idPoint = 0;
if (cvxSkPnt(&point2D, &idPoint) || idPoint == 0)
zwTestLogErrorMsg(5, "cvxSkPnt: failed to create a 2D point!");
svxPoint inqPoint = { 0 };
cvxEntPnt(idPoint, &inqPoint);
if (!zwUtilIsEqualPnt(&point, &inqPoint, V_FZERO))
zwTestLogErrorMsg(5, "cvxSkPnt: failed to determine point coordinate!");
return;
}
void zwTestSkLine2pt()
/*
DESCRIPTION:
Test case for function cvxSkLine2pt.
*/
{
/* select two points */
svxPoint start = { 0 }, end = { 0 };
cvxGetPoint("select start point", VX_INP_PNT_GENERAL, 0, &start, nullptr);
cvxGetPoint("select end point", VX_INP_PNT_GENERAL, 0, &end, nullptr);
svxPoint2 start2D = { start.x, start.y }, end2D = { end.x, end.y };
/* use two points to create a line */
int idLine = 0;
if (cvxSkLine2pt(&start2D, &end2D, &idLine) || idLine == 0)
zwTestLogErrorMsg(5, "cvxSkLine2pt: failed to create a line!");
}
void zwTestSkAddPolyline()
/*
DESCRIPTION:
Test case for function cvxSkAddPolyline.
*/
{
/* select some points to create a polyline */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select two or more points.", VX_INP_PNT_GENERAL, 0, &count, &points);
if (count < 2)
{
zwTestLogErrorMsg(5, "cvxSkAddPolyline: too few points!");
cvxMemFree((void**)&points);
return;
}
/* create a polyline */
svxPoint2* points2D = nullptr;
cvxMemAlloc(count * sizeof(svxPoint2), (void**)&points2D);
for (int i = 0; i < count; i++)
points2D[i] = { points[i].x, points[i].y };
if (cvxSkAddPolyline(count, points2D, 0))
zwTestLogErrorMsg(5, "cvxSkAddPolyline: failed to create a 2D polyline!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&points2D);
}
void zwTestSkChamfer()
/*
DESCRIPTION:
Test case for function cvxSkChamfer.
*/
{
/* initialize chamfer */
svxSkChamferData chamfer = {};
if (cvxSkChamferInit(&chamfer))
zwTestLogErrorMsg(5, "cvxSkChamferInit: failed to initialize the chamfer!");
/* select two curves */
svxPoint firPnt = { 0 }, secPnt = { 0 };
cvxGetPoint("select first curve", VX_INP_PNT_ON_CURVE, 0, &firPnt, &chamfer.idFirCurve);
cvxGetPoint("select second curve", VX_INP_PNT_ON_CURVE, 0, &secPnt, &chamfer.idSecCurve);
chamfer.firPnt = { firPnt.x, firPnt.y };
chamfer.secPnt = { secPnt.x, secPnt.y };
double val = 0;
cvxGetNumber("select chamfer option: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
chamfer.chamferOpt = VX_CHMOPT_SETBACK;
cvxGetNumber("specify setback", &chamfer.firSetBack);
break;
case 1:
chamfer.chamferOpt = VX_CHMOPT_TWOSETBACK;
cvxGetNumber("specify first setback", &chamfer.firSetBack);
cvxGetNumber("specify second setback", &chamfer.secSetBack);
break;
case 2:
chamfer.chamferOpt = VX_CHMOPT_SETBACKANDDIS;
cvxGetNumber("specify setback", &chamfer.firSetBack);
cvxGetNumber("specify angle", &chamfer.angValue);
break;
default:
zwTestLogErrorMsg(5, "cvxSkChamfer: invalid option!");
break;
}
cvxGetNumber("select trim option: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
chamfer.chmTrimOpt = VX_CHMTRIM_NO;
break;
case 1:
chamfer.chmTrimOpt = VX_CHMTRIM_BOTH;
break;
case 2:
chamfer.chmTrimOpt = VX_CHMTRIM_FIRST;
break;
case 3:
chamfer.chmTrimOpt = VX_CHMTRIM_SECOND;
break;
default:
zwTestLogErrorMsg(5, "cvxSkChamfer: invalid option!");
break;
}
cvxGetNumber("select extend option: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
chamfer.chmExtOpt = VX_CHMEXT_LINEAR;
break;
case 1:
chamfer.chmExtOpt = VX_CHMEXT_CIRCULAR;
break;
case 2:
chamfer.chmExtOpt = VX_CHMEXT_REFLECT;
break;
default:
zwTestLogErrorMsg(5, "cvxSkChamfer: invalid option!");
break;
}
/* create chamfer */
int idChamfer = 0;
if (cvxSkChamfer(&chamfer, &idChamfer) || idChamfer == 0)
zwTestLogErrorMsg(5, "cvxSkChamfer: failed to create a chamfer!");
}
void zwTestSkFillet()
/*
DESCRIPTION:
Test case for function cvxSkFillet.
*/
{
/* initialize a fillet */
svxSkFilletData fillet = {};
if (cvxSkFilletInit(&fillet))
zwTestLogErrorMsg(5, "cvxSkFilletInit: failed to initialize a fillet!");
/* pick two curves */
svxPoint firPnt = { 0 }, secPnt = { 0 };
cvxGetPoint("select first curve", VX_INP_PNT_ON_CURVE, 0, &firPnt, &fillet.idFirCurve);
cvxGetPoint("select second curve", VX_INP_PNT_ON_CURVE, 0, &secPnt, &fillet.idSecCurve);
fillet.firPnt = { firPnt.x, firPnt.y };
fillet.secPnt = { secPnt.x, secPnt.y };
cvxGetNumber("specify radius", &fillet.radius);
double val = 0;
cvxGetNumber("whether use design arc: 0 or 1", &val);
if (int(val + 0.5))
fillet.designArc = 1;
cvxGetNumber("select trim option: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
fillet.fltTrimOpt = VX_CHMTRIM_NO;
break;
case 1:
fillet.fltTrimOpt = VX_CHMTRIM_BOTH;
break;
case 2:
fillet.fltTrimOpt = VX_CHMTRIM_FIRST;
break;
case 3:
fillet.fltTrimOpt = VX_CHMTRIM_SECOND;
break;
default:
zwTestLogErrorMsg(5, "cvxSkFillet: invalid option!");
break;
}
cvxGetNumber("select extend option: 0 - 2", &val);
switch (int(val + 0.5))
{
case 0:
fillet.fltExtOpt = VX_CHMEXT_LINEAR;
break;
case 1:
fillet.fltExtOpt = VX_CHMEXT_CIRCULAR;
break;
case 2:
fillet.fltExtOpt = VX_CHMEXT_REFLECT;
break;
default:
zwTestLogErrorMsg(5, "cvxSkFillet: invalid option!");
break;
}
/* create a fillet */
int idFillet = 0;
if (cvxSkFillet(&fillet, &idFillet) || idFillet == 0)
zwTestLogErrorMsg(5, "cvxSkFillet: failed to create a fillet!");
}
void zwTestSkSpline()
/*
DESCRIPTION:
Test case for function cvxSkSpline.
*/
{
/* select some points */
svxPoint* points = nullptr;
int count = 0;
cvxGetPoints("select some points.", VX_INP_PNT_GENERAL, 0, &count, &points);
/* initialize the spline */
svxSplineData spline = {};
if (cvxSkSplineInit(&spline, count))
zwTestLogErrorMsg(5, "cvxSkSplineInit: failed to initialize the spline!");
double val = 0;
for (int i = 0; i < count; i++)
{
spline.Pnts[i].Pnt = points[i];
char msg[100];
sprintf_s(msg, 100, "whether use constraint for point %d: 0 or 1", i + 1);
cvxGetNumber(msg, &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseCons = 1;
cvxGetNumber("select continuity type: 0 - 3", &val);
switch (int(val + 0.5))
{
case 0:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_NONE;
break;
case 1:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G1;
break;
case 2:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G2;
break;
case 3:
spline.Pnts[i].ContinuityTyp = VX_CONTIN_G3;
break;
default:
zwTestLogErrorMsg(5, "cvxSkSpline: invalid option!");
break;
}
if (spline.Pnts[i].ContinuityTyp != VX_CONTIN_NONE)
{
cvxGetNumber("specify tangent direction", &val);
spline.Pnts[i].TangDir.x = cos(val * V_DEG_TO_RAD);
spline.Pnts[i].TangDir.y = sin(val * V_DEG_TO_RAD);
}
cvxGetNumber("whether use G1 magnitude: 0 or 1", &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseG1Manitude = 1;
cvxGetNumber("specify G1 magnitude", &spline.Pnts[i].dG1Manitude);
}
cvxGetNumber("whether use G2 radius: 0 or 1", &val);
if (int(val + 0.5))
{
spline.Pnts[i].UseG2Radius = 1;
cvxGetNumber("specify G2 radius", &spline.Pnts[i].dG2Radius);
}
cvxGetNumber("whether flip the tangent direction: 0 or 1", &val);
if (int(val + 0.5))
spline.Pnts[i].FlipDir = 1;
}
}
cvxGetNumber("select spline type: 0 or 1", &val);
if (int(val + 0.5))
{
spline.SplineTyp = 1;
cvxGetNumber("whether use single segment: 0 or 1", &val);
if (int(val + 0.5))
spline.SingleSeg = 1;
}
cvxGetNumber("specify degree", &val);
spline.Degree = int(val + 0.5);
/* note: default 1 */
cvxGetNumber("whether create curve open: 0 or 1", &val);
if (int(val + 0.5) == 0)
spline.CreateCrvOpen = 0;
cvxGetNumber("select fairing type: 0 - 5", &val);
spline.Fairing = int(val + 0.5);
cvxGetNumber("select placing adjustment type: -1 - 3", &val);
switch (int(val + 0.5))
{
case -1:
spline.PlacingTyp = VX_PLACING_NONE;
break;
case 0:
spline.PlacingTyp = VX_PLACING_VIEW;
break;
case 1:
spline.PlacingTyp = VX_PLACING_VECTOR;
cvxGetNumber("specify placing adjustment direction", &val);
spline.PlacingDir.x = cos(val * V_DEG_TO_RAD);
spline.PlacingDir.y = sin(val * V_DEG_TO_RAD);
break;
case 2:
spline.PlacingTyp = VX_PLACING_WCS;
break;
case 3:
spline.PlacingTyp = VX_PLACING_PLANE;
break;
default:
zwTestLogErrorMsg(5, "cvxSkSpline: invalid option!");
break;
}
/* create a spline */
int idSpline = 0;
if (cvxSkSpline(&spline, &idSpline))
zwTestLogErrorMsg(5, "cvxSkSpline: failed to create a spline!");
/* free memory */
cvxMemFree((void**)&points);
cvxMemFree((void**)&spline.Pnts);
}
void zwTestSkReadyText()
/*
DESCRIPTION:
Test case for function cvxSkReadyText.
*/
{
double val = 0.0;
evxReadyTextMethods method = VX_ON_CRV;
cvxGetNumber("[Method]The default is on curve text, enter 1 to switch to box text", &val);
if (int(val + 0.5) == 1) method = VX_BOX;
/* initialize readytext data */
svxReadyText readyText = {};
if (cvxSkReadyTextInit(method, &readyText))
zwTestLogErrorMsg(5, "cvxSkReadyTextInit: failed to initialize data!");
vxLongName text = "\0";
cvxGetString("[Text]Input text", "Test ready text", sizeof(text), text);
readyText.text = text;
cvxGetNumber("[Height]The default is 10.0", &readyText.size);
cvxGetNumber("[Text Style]The default is Regular, enter number to switch(1:Italic; 2:Bold; 3.Bold Italic)", &val);
switch (int(val + 0.5))
{
case 1: case 2: case 3: readyText.style = (int)(val + 0.5) + 1; break;
default: readyText.style = 1; break;
}
cvxGetNumber("[Spacing]Enter spacing", &readyText.spacing);
cvxGetNumber("[Text width]Enter text width", &readyText.WidthText);
cvxGetNumber("[Vertical Spacing]Enter vertical spacing", &readyText.VerticalSpacing);
cvxGetPoint("[Origin]Select base point", VX_INP_PNT_GENERAL, 0, &readyText.origin, NULL);
cvxGetNumber("[Flip]Whether to flip(1: enable; 0: disable)", &val);
readyText.flipY = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Mirror]Whether to mirror(1: enable; 0: disable)", &val);
readyText.mirror = ((int)(val + 0.5) == 1 ? 1 : 0);
if (readyText.methods == VX_ON_CRV)
{
cvxGetNumber("[Reverse curve]Whether to reverse curve(1: enable; 0: disable)", &val);
readyText.methodsUnion.oncrvtext.reverseCurve = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Place text at origin]Whether to place text at origin(1: enable; 0: disable)", &val);
readyText.methodsUnion.oncrvtext.placeTextAtOrg = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Reduce text data]Whether to reduce text data(1: enable; 0: disable)", &val);
readyText.methodsUnion.oncrvtext.reduceTxtDat = ((int)(val + 0.5) == 1 ? 1 : 0);
cvxGetNumber("[Keep Text Shape]Whether to keep text shape(1: enable; 0: disable)", &val);
readyText.methodsUnion.oncrvtext.KeepTextShape = ((int)(val + 0.5) == 1 ? 1 : 0);
int idCrv = 0;
cvxGetEnt("[Curve]Select curve to follow", VX_INP_GENERAL_2D, 1, &idCrv);
if (cvxEntIsCurve(idCrv)) readyText.methodsUnion.oncrvtext.idxCurve = idCrv;
}
else
{
if (cvxGetPoint("[Align Point]Select text alignment point, <middle-click> to ignore", VX_INP_PNT_GENERAL, 1, &readyText.methodsUnion.boxtext.AlignPoint, NULL))
{
cvxGetNumber("[Width]Enter width", &readyText.methodsUnion.boxtext.WidthSetting);
cvxGetNumber("[Height]Enter height", &readyText.methodsUnion.boxtext.HeightSetting);
}
}
/* create a spline */
int idRdText = 0;
if (cvxSkReadyText(&readyText, &idRdText) || idRdText < 1)
zwTestLogErrorMsg(5, "cvxSkReadyText: failed to create a ready sketch text!");
}
void zwTestSkReference()
/*
DESCRIPTION:
Test case for function cvxSkReference.
*/
{
svxSkRefData data = {};
cvxSkReferenceInit(&data);
double val;
cvxGetNumber("select a method to reference geometry(0: projection, 1: intersection", &val);
data.method = (evxSkRefMethod)(val + 0.5);
if (data.method == VX_SK_REF_PROJECTION)
{
cvxGetNumber("select a option(0: single, 1: chain, 2: loops, 3: point)", &val);
data.option = (evxSkRefOption)(val + 0.5);
}
else
{
cvxGetNumber("select a option(0: single, 1: chain)", &val);
data.option = (evxSkRefOption)(val + 0.5);
}
switch (data.option)
{
case VX_SK_REF_SINGLE:
{
cvxGetEntPaths("select entities", VX_INP_GENERAL_3D, 0, &data.inpUnion.single.numEnt, &data.inpUnion.single.entPaths);
break;
}
case VX_SK_REF_CHAIN:
{
cvxGetNumber("select a chain option(0: chain pick, 1: chain between picks)", &val);
data.inpUnion.chain.option = (evxSkChainOption)(val + 0.5);
cvxGetEntPaths("select entities", VX_INP_GENERAL_3D, 0, &data.inpUnion.chain.numEnt, &data.inpUnion.chain.entPaths);
break;
}
case VX_SK_REF_LOOPS:
{
cvxGetNumber("select a loop option(0: all, 1: boundary, 2: shared, 3: inner, 4: outer, 5: open boundary, 6: non-shared boundary 7: Silhouette )", &val);
data.inpUnion.loop.option = (evxSkLoopOption)(val + 0.5);
cvxGetEntPaths("select entities", VX_INP_GENERAL_3D, 0, &data.inpUnion.loop.numEnt, &data.inpUnion.loop.entPaths);
break;
}
case VX_SK_REF_POINT:
{
cvxGetNumber("select point type(0: free point; 1: start point; 2: end point; 3: center; 4: control point; 5: middle; 6: origin)", &val);
data.inpUnion.point.pnt.pntType = (evxGeomCritPnt)(int)val;
if (data.inpUnion.point.pnt.pntType == VX_FREE_POINT)
cvxGetPointOnEnt("select a point", VX_INP_PNT_ON_CURVE_OR_EDGE, 0, &data.inpUnion.point.pnt.pnt, &data.inpUnion.point.pnt.entPath);
else
cvxGetEntPath("select entity that point is on", VX_INP_GENERAL_3D, 0, &data.inpUnion.point.pnt.entPath);
if (data.inpUnion.point.pnt.pntType == VX_SPLINE_DEFINING_POINT)
{
cvxGetNumber("enter number of control point (start from 0)", &val);
data.inpUnion.point.pnt.idControlPnt = (int)val;
}
break;
}
default:
break;
}
cvxGetNumber("whether to create construction geometry: 0 or 1 )", &val);
data.constructGeom = (int)(val + 0.5);
cvxGetNumber("whether to record: 0 or 1 )", &val);
data.recordState = (int)(val + 0.5);
int idSketch = 0;
cvxGetEnt("select a sketch", VX_INP_SKETCH, 0, &idSketch);
cvxSkActivate(idSketch, 1);
int nRefEnts = 0;
int *idRefEnts = NULL;
if (cvxSkReference(&data, &nRefEnts, &idRefEnts) || nRefEnts < 1)
{
zwTestLogErrorMsg(5, "cvxSkReference: failed to reference geometry!");
}
else
{
zwTestLogErrorMsg(1, "cvxSkReference: number of reference geometries is %d!", nRefEnts);
for (int i = 0; i < nRefEnts; i++)
cvxEntAddPick(idRefEnts[i]);
}
if (data.option == VX_SK_REF_SINGLE) cvxMemFree((void**)&data.inpUnion.single.entPaths);
if (data.option == VX_SK_REF_CHAIN) cvxMemFree((void**)&data.inpUnion.chain.entPaths);
if (data.option == VX_SK_REF_LOOPS) cvxMemFree((void**)&data.inpUnion.loop.entPaths);
cvxMemFree((void**)&idRefEnts);
}
evxSkRefMethod
evxSkRefMethod
sketch reference geometry method
Definition: zwapi_cmd_sk_cmds_data.h:201
VX_SK_REF_PROJECTION
@ VX_SK_REF_PROJECTION
projection method
Definition: zwapi_cmd_sk_cmds_data.h:202
evxSkRefOption
evxSkRefOption
sketch reference type
Definition: zwapi_cmd_sk_cmds_data.h:211
VX_SK_REF_CHAIN
@ VX_SK_REF_CHAIN
chain
Definition: zwapi_cmd_sk_cmds_data.h:213
VX_SK_REF_POINT
@ VX_SK_REF_POINT
point
Definition: zwapi_cmd_sk_cmds_data.h:215
VX_SK_REF_SINGLE
@ VX_SK_REF_SINGLE
single
Definition: zwapi_cmd_sk_cmds_data.h:212
VX_SK_REF_LOOPS
@ VX_SK_REF_LOOPS
loops
Definition: zwapi_cmd_sk_cmds_data.h:214
VX_CHMEXT_REFLECT
@ VX_CHMEXT_REFLECT
The extension follows a reflective path opposite the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:347
VX_CHMEXT_CIRCULAR
@ VX_CHMEXT_CIRCULAR
The extension follows an arc path in the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:346
VX_CHMEXT_LINEAR
@ VX_CHMEXT_LINEAR
The extension follows a linear path.
Definition: zwapi_cmd_sk_cmds_data.h:345
evxReadyTextMethods
evxReadyTextMethods
Create Sketch ready text Methods.
Definition: zwapi_cmd_sk_cmds_data.h:111
VX_BOX
@ VX_BOX
box text
Definition: zwapi_cmd_sk_cmds_data.h:113
VX_ON_CRV
@ VX_ON_CRV
on curve text
Definition: zwapi_cmd_sk_cmds_data.h:112
evxSkChainOption
evxSkChainOption
sketch reference chain option
Definition: zwapi_cmd_sk_cmds_data.h:223
evxSkLoopOption
evxSkLoopOption
sketch reference loop option
Definition: zwapi_cmd_sk_cmds_data.h:233
VX_SK_AXIS_PARAOFF
@ VX_SK_AXIS_PARAOFF
Parallel and Offset.
Definition: zwapi_cmd_sk_cmds_data.h:38
VX_SK_AXIS_PARAPT
@ VX_SK_AXIS_PARAPT
Parallel and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:35
VX_SK_AXIS_TWO_PNT
@ VX_SK_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_sk_cmds_data.h:34
VX_SK_AXIS_VERT
@ VX_SK_AXIS_VERT
Vertical.
Definition: zwapi_cmd_sk_cmds_data.h:40
VX_SK_AXIS_ANGLE
@ VX_SK_AXIS_ANGLE
Angle.
Definition: zwapi_cmd_sk_cmds_data.h:37
VX_SK_AXIS_HORIZ
@ VX_SK_AXIS_HORIZ
Horizontal.
Definition: zwapi_cmd_sk_cmds_data.h:39
VX_SK_AXIS_PERPENDICULAR
@ VX_SK_AXIS_PERPENDICULAR
Perpendicular and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:36
VX_CHMTRIM_FIRST
@ VX_CHMTRIM_FIRST
Trim/Extend only the first selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:335
VX_CHMTRIM_BOTH
@ VX_CHMTRIM_BOTH
Trim/Extend both curves.
Definition: zwapi_cmd_sk_cmds_data.h:334
VX_CHMTRIM_SECOND
@ VX_CHMTRIM_SECOND
Trim/extend only the second selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:336
VX_CHMTRIM_NO
@ VX_CHMTRIM_NO
No trim/extend is performed.
Definition: zwapi_cmd_sk_cmds_data.h:333
VX_CHMOPT_SETBACKANDDIS
@ VX_CHMOPT_SETBACKANDDIS
a chamfer by specifying the setback and an angle
Definition: zwapi_cmd_sk_cmds_data.h:324
VX_CHMOPT_TWOSETBACK
@ VX_CHMOPT_TWOSETBACK
a chamfer with different setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:323
VX_CHMOPT_SETBACK
@ VX_CHMOPT_SETBACK
a chamfer of equal setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:322
cvxSkArc3pt
evxErrors cvxSkArc3pt(svxPoint2 *Start, svxPoint2 *End, svxPoint2 *Mid, int *idEnt)
cvxSkCrvIntInit
evxErrors cvxSkCrvIntInit(svxCrvIntData *data)
cvxSkReadyText
evxErrors cvxSkReadyText(const svxReadyText *RdText, int *idRdText)
cvxSkChamfer
evxErrors cvxSkChamfer(const svxSkChamferData *chmData, int *idChamfer)
cvxSkChamferInit
evxErrors cvxSkChamferInit(svxSkChamferData *data)
cvxSkPnt
evxErrors cvxSkPnt(svxPoint2 *Point, int *idEnt)
cvxSkSplineInit
evxErrors cvxSkSplineInit(svxSplineData *data, int count)
cvxSkArcRad
evxErrors cvxSkArcRad(svxPoint2 *Center, double Radius, double Start, double End, int *idEnt)
cvxSkAddPolyline
evxErrors cvxSkAddPolyline(int cntPnt, svxPoint2 *pnts, int addCns)
cvxSkCirRad
evxErrors cvxSkCirRad(svxPoint2 *Center, double Radius, int *idEnt)
cvxSkLine2pt
evxErrors cvxSkLine2pt(svxPoint2 *Start, svxPoint2 *End, int *idEnt)
cvxSkFilletInit
evxErrors cvxSkFilletInit(svxSkFilletData *data)
cvxSkReadyTextInit
evxErrors cvxSkReadyTextInit(evxReadyTextMethods method, svxReadyText *data)
cvxSkReference
evxErrors cvxSkReference(const svxSkRefData *data, int *count, int **idRefEnts)
cvxSkReferenceInit
evxErrors cvxSkReferenceInit(svxSkRefData *data)
cvxSkPntsOnCrv
evxErrors cvxSkPntsOnCrv(int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
cvxSkCir3pt
evxErrors cvxSkCir3pt(svxPoint2 *P1, svxPoint2 *P2, svxPoint2 *P3, int *idEnt)
cvxSkSpline
evxErrors cvxSkSpline(const svxSplineData *PntData, int *idEnt)
cvxSkAxis
evxErrors cvxSkAxis(const svxSkAxisData *Axis, int *idAxis)
cvxSkEllipse
evxErrors cvxSkEllipse(svxEllipse *ellipse, int *idEnt)
cvxSkCrvInt
evxErrors cvxSkCrvInt(svxCrvIntData *Crv, int *idEnt)
cvxSkEllipseInit
evxErrors cvxSkEllipseInit(svxEllipse *data)
cvxSkFillet
evxErrors cvxSkFillet(const svxSkFilletData *filletData, int *idFillet)
cvxEntIsCurve
int cvxEntIsCurve(int idEntity)
cvxEntAddPick
evxErrors cvxEntAddPick(int idx_ent)
cvxEntPnt
evxErrors cvxEntPnt(int idEntity, svxPoint *Pnt)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxSkActivate
evxErrors cvxSkActivate(int idSketch, int UpdateGUI)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetEntPaths
evxErrors cvxGetEntPaths(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
cvxGetString
int cvxGetString(const char *Prompt, const char *Default, int NumBytes, char *String)
VX_PLACING_WCS
@ VX_PLACING_WCS
WCS.
Definition: zwapi_util.h:2389
VX_PLACING_PLANE
@ VX_PLACING_PLANE
PLANE.
Definition: zwapi_util.h:2390
VX_PLACING_VECTOR
@ VX_PLACING_VECTOR
vector
Definition: zwapi_util.h:2388
VX_PLACING_VIEW
@ VX_PLACING_VIEW
view , 3d spline default value
Definition: zwapi_util.h:2387
VX_PLACING_NONE
@ VX_PLACING_NONE
none , 2d spline default value
Definition: zwapi_util.h:2386
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
VX_EXTEND_UNDEFINED
@ VX_EXTEND_UNDEFINED
linear extend is the default when extension is undefined
Definition: zwapi_util.h:2301
VX_CONTIN_G1
@ VX_CONTIN_G1
tangent
Definition: zwapi_util.h:2357
VX_CONTIN_NONE
@ VX_CONTIN_NONE
none
Definition: zwapi_util.h:2356
VX_CONTIN_G3
@ VX_CONTIN_G3
flow
Definition: zwapi_util.h:2359
VX_CONTIN_G2
@ VX_CONTIN_G2
curvature
Definition: zwapi_util.h:2358
evxGeomCritPnt
evxGeomCritPnt
type of sketch geometry critical point
Definition: zwapi_util.h:534
VX_FREE_POINT
@ VX_FREE_POINT
free point, non-critical point
Definition: zwapi_util.h:536
VX_SPLINE_DEFINING_POINT
@ VX_SPLINE_DEFINING_POINT
control point, used only for splines
Definition: zwapi_util.h:540
svxCrvIntData::UseEndTan
int UseEndTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2342
svxCrvIntData::Count
int Count
number of points to interpolate
Definition: zwapi_util.h:2333
svxCrvIntData::StartTan
svxVector StartTan
normalized start tangent direction vector
Definition: zwapi_util.h:2339
svxCrvIntData::EndScale
double EndScale
end tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2344
svxCrvIntData::UseStartTan
int UseStartTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2338
svxCrvIntData::Degree
int Degree
curve degree (2 - 6)
Definition: zwapi_util.h:2332
svxCrvIntData::Points
svxPoint * Points
pointer to list of points to interpolate
Definition: zwapi_util.h:2334
svxCrvIntData::isClosed
int isClosed
1 if curve is closed, 0 if open
Definition: zwapi_util.h:2331
svxCrvIntData::StartScale
double StartScale
start tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2340
svxCrvIntData::EndTan
svxVector EndTan
normalized end tangent direction vector
Definition: zwapi_util.h:2343
svxCrvIntData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2346
svxCrvIntData
2D/3D interpolated curve
Definition: zwapi_util.h:2329
svxEllipse::width
double width
width of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:98
svxEllipse::centroid
svxPoint centroid
centroid of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:97
svxEllipse::height
double height
height of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:99
svxEllipse
data of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:96
svxPntOnEntPath::entPath
svxEntPath entPath
entity path that the point on
Definition: zwapi_util.h:570
svxPntOnEntPath::pntType
evxGeomCritPnt pntType
point type
Definition: zwapi_util.h:568
svxPntOnEntPath::idControlPnt
int idControlPnt
id of the control point of the spline (starting from 0), only used when pntType is VX_SPLINE_DEFINING...
Definition: zwapi_util.h:569
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxReadyText::evxSkTextMethodsUnion::BoxText::AlignPoint
svxPoint AlignPoint
Align Point.
Definition: zwapi_cmd_sk_cmds_data.h:149
svxReadyText::evxSkTextMethodsUnion::BoxText::HeightSetting
double HeightSetting
Setting Height.
Definition: zwapi_cmd_sk_cmds_data.h:151
svxReadyText::evxSkTextMethodsUnion::BoxText::WidthSetting
double WidthSetting
Setting Width.
Definition: zwapi_cmd_sk_cmds_data.h:150
svxReadyText::evxSkTextMethodsUnion::OnCrvText::placeTextAtOrg
int placeTextAtOrg
Place text at origin.
Definition: zwapi_cmd_sk_cmds_data.h:142
svxReadyText::evxSkTextMethodsUnion::OnCrvText::idxCurve
int idxCurve
curve index
Definition: zwapi_cmd_sk_cmds_data.h:145
svxReadyText::evxSkTextMethodsUnion::OnCrvText::reduceTxtDat
int reduceTxtDat
Reduce text data.
Definition: zwapi_cmd_sk_cmds_data.h:143
svxReadyText::evxSkTextMethodsUnion::OnCrvText::reverseCurve
int reverseCurve
Reverse curve.
Definition: zwapi_cmd_sk_cmds_data.h:141
svxReadyText::evxSkTextMethodsUnion::OnCrvText::KeepTextShape
int KeepTextShape
Keep Text Shape.
Definition: zwapi_cmd_sk_cmds_data.h:144
svxReadyText::methods
evxReadyTextMethods methods
ready text methods
Definition: zwapi_cmd_sk_cmds_data.h:132
svxReadyText::flipY
int flipY
Horizontal flip.
Definition: zwapi_cmd_sk_cmds_data.h:129
svxReadyText::mirror
int mirror
Mirror.
Definition: zwapi_cmd_sk_cmds_data.h:130
svxReadyText::style
int style
text style(1:Regular; 2:Italic; 3:Bold; 4.Bold Italic)
Definition: zwapi_cmd_sk_cmds_data.h:125
svxReadyText::origin
svxPoint origin
text position
Definition: zwapi_cmd_sk_cmds_data.h:128
svxReadyText::spacing
double spacing
character space
Definition: zwapi_cmd_sk_cmds_data.h:126
svxReadyText::VerticalSpacing
double VerticalSpacing
Vertical Spacing.
Definition: zwapi_cmd_sk_cmds_data.h:135
svxReadyText::text
char * text
text string
Definition: zwapi_cmd_sk_cmds_data.h:122
svxReadyText::size
double size
text height
Definition: zwapi_cmd_sk_cmds_data.h:124
svxReadyText::WidthText
double WidthText
Text width.
Definition: zwapi_cmd_sk_cmds_data.h:134
svxReadyText
data of ready sketch text
Definition: zwapi_cmd_sk_cmds_data.h:121
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::Pnt2
svxPoint2 Pnt2
second point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. other type can be null
Definition: zwapi_cmd_sk_cmds_data.h:70
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::idEnt2
int idEnt2
id of the Second Parent entity (0 to ignore)
Definition: zwapi_cmd_sk_cmds_data.h:69
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle::Angle
double Angle
Angle. if type = VX_SK_AXIS_ANGLE, it is the angle between axis and reference line....
Definition: zwapi_cmd_sk_cmds_data.h:83
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff::Offset
double Offset
Offset. if type = VX_SK_AXIS_PARAOFF, the axis is parallel to reference line, and the distance betwee...
Definition: zwapi_cmd_sk_cmds_data.h:76
svxSkAxisData::idEnt1
int idEnt1
id of the First Point parent entity(0 to ignore)
Definition: zwapi_cmd_sk_cmds_data.h:50
svxSkAxisData::Method
evxSkAxisMethods Method
Sketch Axis Methods.
Definition: zwapi_cmd_sk_cmds_data.h:49
svxSkAxisData::idRefEnt
int idRefEnt
id of the RefLine parent entity. if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to refere...
Definition: zwapi_cmd_sk_cmds_data.h:59
svxSkAxisData::Pnt1
svxPoint2 Pnt1
first Point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. if type = VX_SK_AXI...
Definition: zwapi_cmd_sk_cmds_data.h:51
svxSkAxisData::RefPnt
svxPoint2 RefPnt
Ref Line point.
Definition: zwapi_cmd_sk_cmds_data.h:64
svxSkAxisData::ConstGeom
int ConstGeom
1-Construction Geometry, else 0 (1 as default)
Definition: zwapi_cmd_sk_cmds_data.h:88
svxSkAxisData
data of sketch Axis
Definition: zwapi_cmd_sk_cmds_data.h:48
svxSkChamferData::idFirCurve
int idFirCurve
first setback value. if type = VX_CHMOPT_SETBACK, it is setback value for 2 curves....
Definition: zwapi_cmd_sk_cmds_data.h:373
svxSkChamferData::secPnt
svxPoint2 secPnt
a point on the second curve
Definition: zwapi_cmd_sk_cmds_data.h:380
svxSkChamferData::angValue
double angValue
specifying the angle of the first curve, if type = VX_CHMOPT_SETBACKANDDIS, the setback value for 2nd...
Definition: zwapi_cmd_sk_cmds_data.h:383
svxSkChamferData::firPnt
svxPoint2 firPnt
a point on the first curve
Definition: zwapi_cmd_sk_cmds_data.h:376
svxSkChamferData::secSetBack
double secSetBack
second setback value, only needed when chamferOpt is VX_CHMOPT_TWOSETBACK
Definition: zwapi_cmd_sk_cmds_data.h:382
svxSkChamferData::chamferOpt
evxSkChamferOpt chamferOpt
option of chamfer
Definition: zwapi_cmd_sk_cmds_data.h:372
svxSkChamferData::idSecCurve
int idSecCurve
second setback value. if type = VX_CHMOPT_TWOSETBACK,it is setback value for 2nd curve....
Definition: zwapi_cmd_sk_cmds_data.h:377
svxSkChamferData::chmExtOpt
evxSkChamferExtenOpt chmExtOpt
control the path of extended curves
Definition: zwapi_cmd_sk_cmds_data.h:388
svxSkChamferData::firSetBack
double firSetBack
first setback value, when chamferOpt is VX_CHMOPT_SETBACK it represents setback value
Definition: zwapi_cmd_sk_cmds_data.h:381
svxSkChamferData::chmTrimOpt
evxSkChamferTrimOpt chmTrimOpt
trim (or extend) curves
Definition: zwapi_cmd_sk_cmds_data.h:387
svxSkChamferData
information of chamfer in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:371
svxSkFilletData::fltTrimOpt
evxSkChamferTrimOpt fltTrimOpt
trim (or extend) curves
Definition: zwapi_cmd_sk_cmds_data.h:362
svxSkFilletData::fltExtOpt
evxSkChamferExtenOpt fltExtOpt
control the path of extended curves
Definition: zwapi_cmd_sk_cmds_data.h:363
svxSkFilletData::secPnt
svxPoint2 secPnt
a point on the second curve
Definition: zwapi_cmd_sk_cmds_data.h:359
svxSkFilletData::idSecCurve
int idSecCurve
second specified curve
Definition: zwapi_cmd_sk_cmds_data.h:358
svxSkFilletData::radius
double radius
radius of fillet
Definition: zwapi_cmd_sk_cmds_data.h:360
svxSkFilletData::firPnt
svxPoint2 firPnt
a point on the first curve
Definition: zwapi_cmd_sk_cmds_data.h:357
svxSkFilletData::designArc
int designArc
flag to use design arc, 0 no else yes
Definition: zwapi_cmd_sk_cmds_data.h:361
svxSkFilletData::idFirCurve
int idFirCurve
first specified curve
Definition: zwapi_cmd_sk_cmds_data.h:356
svxSkFilletData
information of fillet in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:355
svxSkRefData::evxSkRefInpUnion::ReferenceChain::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:263
svxSkRefData::evxSkRefInpUnion::ReferenceChain::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:264
svxSkRefData::evxSkRefInpUnion::ReferenceChain::option
evxSkChainOption option
chain option (VX_SK_CHAIN_PICK as default)
Definition: zwapi_cmd_sk_cmds_data.h:262
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::option
evxSkLoopOption option
loop option (VX_SK_LOOP_ALL as default)
Definition: zwapi_cmd_sk_cmds_data.h:268
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:269
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:270
svxSkRefData::evxSkRefInpUnion::ReferencePoint::pnt
svxPntOnEntPath pnt
reference point
Definition: zwapi_cmd_sk_cmds_data.h:274
svxSkRefData::evxSkRefInpUnion::ReferenceSingle::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:257
svxSkRefData::evxSkRefInpUnion::ReferenceSingle::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:258
svxSkRefData::method
evxSkRefMethod method
reference method (VX_SK_REF_PROJECTION as default)
Definition: zwapi_cmd_sk_cmds_data.h:250
svxSkRefData::constructGeom
int constructGeom
whether to create construction geometry (1 or 0, 1 as default)
Definition: zwapi_cmd_sk_cmds_data.h:278
svxSkRefData::recordState
int recordState
whether to record the state of the history of the part from which the reference geometry is extracted...
Definition: zwapi_cmd_sk_cmds_data.h:279
svxSkRefData::option
evxSkRefOption option
reference option (VX_SK_REF_SINGLE as default)
Definition: zwapi_cmd_sk_cmds_data.h:251
svxSkRefData
sketch reference geometry data
Definition: zwapi_cmd_sk_cmds_data.h:249
svxSplineData::SingleSeg
int SingleSeg
single segment (0 as default)
Definition: zwapi_util.h:2409
svxSplineData::PlacingDir
svxVector PlacingDir
Placing adjustment director (PlacingTyp = VX_PLACING_VECTOR)
Definition: zwapi_util.h:2413
svxSplineData::SplineTyp
int SplineTyp
0- through point, 1- control point (0 as default))
Definition: zwapi_util.h:2400
svxSplineData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2407
svxSplineData::CreateCrvOpen
int CreateCrvOpen
1-create curve open, 0-create close curve(1 as default)
Definition: zwapi_util.h:2406
svxSplineData::Degree
int Degree
degree (3 as default)
Definition: zwapi_util.h:2403
svxSplineData::PlacingTyp
evxPlacingType PlacingTyp
placing adjustment type
Definition: zwapi_util.h:2412
svxSplineData::Pnts
svxSplinePnt * Pnts
point list
Definition: zwapi_util.h:2402
svxSplineData
Spline command data.
Definition: zwapi_util.h:2398
svxSplinePnt::ContinuityTyp
evxContinuityTyp ContinuityTyp
continuity type (VX_NONE as default)
Definition: zwapi_util.h:2371
svxSplinePnt::FlipDir
int FlipDir
1-flip the TangDir, else 0 (0 as default)
Definition: zwapi_util.h:2377
svxSplinePnt::dG2Radius
double dG2Radius
G2 radius(use this when UseG2Radius != 0)
Definition: zwapi_util.h:2376
svxSplinePnt::UseG1Manitude
int UseG1Manitude
1-use G1 magnitude, else 0 (0 as default)
Definition: zwapi_util.h:2373
svxSplinePnt::UseG2Radius
int UseG2Radius
1-use G2 radius, else 0 (0 as default)
Definition: zwapi_util.h:2375
svxSplinePnt::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:2368
svxSplinePnt::TangDir
svxVector TangDir
tangent direction at this point (ContinuityTyp != VX_CONTIN_NONE)
Definition: zwapi_util.h:2372
svxSplinePnt::UseCons
int UseCons
1-use the constraints data ,else 0 (0 as default)
Definition: zwapi_util.h:2369
svxSplinePnt::dG1Manitude
double dG1Manitude
G1 magnitude (use this when UseG1Manitude != 0 )
Definition: zwapi_util.h:2374
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: sketch\basicEditingTest.cpp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
sketch\basicEditingTest.cpp
/*
** (C) Copyright 2022, ZWSOFT Co., LTD. (Guangzhou) All Rights Reserved.
*/
#include "apiQaUtils.h"
#include <stdio.h>
#include <string.h>
#include <vector>
ApiDefVoidFunc(zwTestSkScale, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkMove, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkMirr, VX_CODE_GENERAL);
ApiDefVoidFunc(zwTestSkRotate, VX_CODE_GENERAL);
void zwTestSkScale()
/*
DESCRIPTION:
Test case for function cvxSkScale.
*/
{
/* set scale factor */
double xScale = 0.0, yScale = 0.0;
cvxGetNumber("Enter X scale factor", &xScale);
cvxGetNumber("Enter Y scale factor", &yScale);
/* set center of scaling */
svxPoint ctrPnt = {};
cvxGetPoint("Select center of scaling, <middle-click> to skip", VX_INP_PNT_GENERAL, 1, &ctrPnt, NULL);
/* select entities to scale */
std::vector<int> scaleEnt;
int nEnts = 0, * idEnts = NULL;
cvxGetEnts("[Entity]Select entities to scale, <middle-click> when done", VX_INP_GENERAL_2D, 0, &nEnts, &idEnts);
for (int i = 0; i < nEnts; i++)
{
if (cvxEntIsCurve(idEnts[i]) || cvxEntClassNum(idEnts[i]) == VX_ENT_RDTXT)
scaleEnt.push_back(idEnts[i]);
}
cvxMemFree((void**)&idEnts);
/* scale entities */
if (cvxSkScale((int)scaleEnt.size(), scaleEnt.data(), xScale, yScale, (svxPoint2*)&ctrPnt))
zwTestLogErrorMsg(5, "cvxPartScale2: failed to scale entity!");
}
void zwTestSkMove()
/*
DESCRIPTION:
Test case for function cvxSkMove.
*/
{
evxMoveType2D type = VX_PNT_TO_PNT_2D;
double val = 0.0;
cvxGetNumber("[Move Type]The default type is point to point, enter 1 to switch to move along a direction", &val);
if (int(val + 0.5) == 1) type = VX_ALONG_DIR_2D;
/* initialize move feature */
svxMoveData2D move;
if (cvxSkMoveInit(type, &move))
zwTestLogErrorMsg(5, "cvxSkMoveInit: failed to initialize move features!");
/* select entities to move */
cvxGetEnts("[Entity]Select entities to move, <middle-click> when done", VX_INP_GENERAL_2D, 0, &move.cntEnt, &move.pEnts);
/* set move parameter */
if (move.methods == VX_PNT_TO_PNT_2D)
{
svxPoint pnt = {};
cvxGetPoint("[From Point]Specify a reference point", VX_INP_PNT_GENERAL, 0, &pnt, NULL);
move.MethodUnion2D.PntToPnt2D.FromPoint = { pnt.x, pnt.y };
cvxGetPoint("[To Point]Specify a destination point", VX_INP_PNT_GENERAL, 0, &pnt, NULL);
move.MethodUnion2D.PntToPnt2D.ToPoint = { pnt.x, pnt.y };
double val = 0.0;
cvxGetNumber("[Direction]Enter number to select direction(0: two points; 1: horizontal; 2: vertical)", &val);
switch (int(val + 0.5))
{
case 1: move.MethodUnion2D.PntToPnt2D.type = VX_DRAWING_HORIZONTAL; break;
case 2: move.MethodUnion2D.PntToPnt2D.type = VX_DRAWING_VERTICAL; break;
default: move.MethodUnion2D.PntToPnt2D.type = VX_DRAWING_TWOPOINTS; break;
}
cvxGetNumber("[Angle]Specify rotation angle", &move.MethodUnion2D.PntToPnt2D.angle);
cvxGetNumber("[Scale]Specify scale factor", &move.MethodUnion2D.PntToPnt2D.scale);
}
else
{
svxPoint pnt = {};
cvxGetPoint("[Direction]Specify move direction", VX_INP_PNT_DIRECTION, 0, &pnt, NULL);
move.MethodUnion2D.AlongDir2D.dir = { pnt.x, pnt.y };
cvxGetPoint("[Base Point]Specify base point", VX_INP_PNT_GENERAL, 0, &pnt, NULL);
move.MethodUnion2D.AlongDir2D.BasePoint = { pnt.x, pnt.y };
cvxGetNumber("[Distance]Specify move distance", &move.MethodUnion2D.AlongDir2D.distance);
cvxGetNumber("[Angle]Specify rotation angle", &move.MethodUnion2D.AlongDir2D.angle);
cvxGetNumber("[Scale]Specify scale factor", &move.MethodUnion2D.AlongDir2D.scale);
}
/* mirror features */
int idFtr = 0;
if (cvxSkMove(&move))
zwTestLogErrorMsg(5, "cvxSkMove: failed to move entities!");
/* free memory */
cvxMemFree((void**)&move.pEnts);
}
void zwTestSkMirr()
/*
DESCRIPTION:
Test case for function cvxSkMirr.
*/
{
/* initialize move feature */
svxMirrData2D mirror;
if (cvxSkMirrInit(&mirror))
zwTestLogErrorMsg(5, "cvxSkMirrInit: failed to initialize mirror features!");
/* select mirror entities */
cvxGetEnts("[Entities]Select entities to mirrored, <middle-click> when done",
VX_INP_GENERAL_2D,
0,
&mirror.cntEnt,
&mirror.pEnts);
/* select mirror axis */
cvxGetEnt("[Line]Specify the symmetry line", VX_INP_GENERAL_2D, 0, &mirror.Line);
if (!cvxEntIsCurve(mirror.Line) || !cvxCrvIsLine(mirror.Line)) return;
double val = 0.0;
cvxGetNumber("[Keep Original Entities]Whether to keep the original entities(1: yes; 0: no)", &val);
mirror.KeepOrigEnt = ((int)(val + 0.5) ? 1 : 0);
/* mirror geometries */
int nMirrorEnts = 0, * idMirrorEnts = NULL;
if (cvxSkMirr(&mirror, &nMirrorEnts, &idMirrorEnts) || nMirrorEnts < 1)
zwTestLogErrorMsg(5, "cvxSkMirr: failed to mirror geometries!");
/* free memory */
cvxMemFree((void**)&mirror.pEnts);
cvxMemFree((void**)&idMirrorEnts);
}
void zwTestSkRotate()
/*
DESCRIPTION:
Test case for function cvxSkRotate.
*/
{
/* initialize move feature */
svxRotateData2D rotate;
if (cvxSkRotateInit(&rotate))
zwTestLogErrorMsg(5, "cvxSkRotateInit: failed to initialize rotate features!");
zwUtilGetPntOrDirOnEnt(0, &rotate.Pnt);
/* select mirror entities */
cvxGetEnts("[Entities]Select entities to rotated, <middle-click> when done",
VX_INP_GENERAL_2D,
0,
&rotate.cntEnt,
&rotate.pEnts);
/* select mirror axis */
double val = 0.0;
cvxGetNumber("[Type]The default is angle, enter 1 to use point", &val);
rotate.Type = ((int)(val + 0.5) == 1 ? VX_ROTATE_POINTS : VX_ROTATE_ANGLE);
if (rotate.Type == VX_ROTATE_ANGLE)
{
cvxGetNumber("[Angle]Specify rotation angle", &rotate.Angle);
}
else
{
zwUtilGetPntOrDirOnEnt(0, &rotate.Start);
zwUtilGetPntOrDirOnEnt(0, &rotate.End);
}
cvxGetNumber("[Move or Copy]The default is to move, enter 1 to copy", &val);
rotate.Setting = ((int)(val + 0.5) == 1 ? VX_ROTATE_COPY : VX_ROTATE_MOVE);
if (rotate.Setting == VX_ROTATE_COPY)
{
cvxGetNumber("[Copies]Specify the number of copies", &val);
rotate.cntCopy = (int)val;
}
/* mirror geometries */
int nRotateEnts = 0, * idRotateEnts = NULL;
if (cvxSkRotate(&rotate, &nRotateEnts, &idRotateEnts))
zwTestLogErrorMsg(5, "cvxSkRotate: failed to rotate geometries!");
/* free memory */
cvxMemFree((void**)&rotate.pEnts);
cvxMemFree((void**)&idRotateEnts);
}
VX_ROTATE_MOVE
@ VX_ROTATE_MOVE
Move, default value.
Definition: zwapi_cmd_sk_cmds_data.h:695
VX_ROTATE_COPY
@ VX_ROTATE_COPY
Copy.
Definition: zwapi_cmd_sk_cmds_data.h:696
VX_ROTATE_ANGLE
@ VX_ROTATE_ANGLE
Angle, default value.
Definition: zwapi_cmd_sk_cmds_data.h:685
VX_ROTATE_POINTS
@ VX_ROTATE_POINTS
Points.
Definition: zwapi_cmd_sk_cmds_data.h:686
VX_DRAWING_TWOPOINTS
@ VX_DRAWING_TWOPOINTS
two points
Definition: zwapi_cmd_sk_cmds_data.h:645
VX_DRAWING_VERTICAL
@ VX_DRAWING_VERTICAL
vertical
Definition: zwapi_cmd_sk_cmds_data.h:647
VX_DRAWING_HORIZONTAL
@ VX_DRAWING_HORIZONTAL
horizontal
Definition: zwapi_cmd_sk_cmds_data.h:646
evxMoveType2D
evxMoveType2D
Move and Copy Methods(2D)
Definition: zwapi_cmd_sk_cmds_data.h:621
VX_PNT_TO_PNT_2D
@ VX_PNT_TO_PNT_2D
copy/move entities along a direction (2D)
Definition: zwapi_cmd_sk_cmds_data.h:622
VX_ALONG_DIR_2D
@ VX_ALONG_DIR_2D
copy/move entities form point to point (2D)
Definition: zwapi_cmd_sk_cmds_data.h:623
cvxSkRotate
evxErrors cvxSkRotate(const svxRotateData2D *data, int *cnt, int **idEnts)
cvxSkMove
evxErrors cvxSkMove(const svxMoveData2D *data)
cvxSkMirr
evxErrors cvxSkMirr(const svxMirrData2D *data, int *cnt, int **idEnts)
cvxSkRotateInit
evxErrors cvxSkRotateInit(svxRotateData2D *data)
cvxSkScale
evxErrors cvxSkScale(int Count, int *idEnts, double X_scale, double Y_scale, svxPoint2 *Pnt)
cvxSkMirrInit
evxErrors cvxSkMirrInit(svxMirrData2D *data)
cvxSkMoveInit
evxErrors cvxSkMoveInit(evxMoveType2D type, svxMoveData2D *data)
cvxEntIsCurve
int cvxEntIsCurve(int idEntity)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxCrvIsLine
int cvxCrvIsLine(int idCurve)
cvxMemFree
void cvxMemFree(void **MemPointer)
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
VX_ENT_RDTXT
@ VX_ENT_RDTXT
Ready sketch text.
Definition: zwapi_util.h:960
svxAlongDir2D::BasePoint
svxPoint2 BasePoint
base point
Definition: zwapi_cmd_sk_cmds_data.h:634
svxAlongDir2D::scale
double scale
scale
Definition: zwapi_cmd_sk_cmds_data.h:636
svxAlongDir2D::distance
double distance
distance
Definition: zwapi_cmd_sk_cmds_data.h:633
svxAlongDir2D::dir
svxVector2 dir
move direction
Definition: zwapi_cmd_sk_cmds_data.h:632
svxAlongDir2D::angle
double angle
angle
Definition: zwapi_cmd_sk_cmds_data.h:635
svxMirrData2D::KeepOrigEnt
int KeepOrigEnt
Flag to use "Keep original entities" ,1 is default
Definition: zwapi_cmd_sk_cmds_data.h:725
svxMirrData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:722
svxMirrData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:723
svxMirrData2D::Line
int Line
Line(Symmetry axis) ID.
Definition: zwapi_cmd_sk_cmds_data.h:724
svxMirrData2D
template command Mirror data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:721
svxMoveData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:671
svxMoveData2D::methods
evxMoveType2D methods
Move Methods.
Definition: zwapi_cmd_sk_cmds_data.h:669
svxMoveData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:670
svxMoveData2D
template command Move data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:668
svxMovePntToPnt2D::type
evxDrawingMoveDirType type
direction type
Definition: zwapi_cmd_sk_cmds_data.h:658
svxMovePntToPnt2D::FromPoint
svxPoint2 FromPoint
from point
Definition: zwapi_cmd_sk_cmds_data.h:656
svxMovePntToPnt2D::angle
double angle
angle
Definition: zwapi_cmd_sk_cmds_data.h:659
svxMovePntToPnt2D::ToPoint
svxPoint2 ToPoint
to point
Definition: zwapi_cmd_sk_cmds_data.h:657
svxMovePntToPnt2D::scale
double scale
scale
Definition: zwapi_cmd_sk_cmds_data.h:660
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxRotateData2D::End
svxPntOnEnt End
End point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.
Definition: zwapi_cmd_sk_cmds_data.h:711
svxRotateData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:706
svxRotateData2D::Angle
double Angle
Rotate angle, 0 if Type is VX_POTATE_POINTS.
Definition: zwapi_cmd_sk_cmds_data.h:709
svxRotateData2D::cntCopy
int cntCopy
Copy count, 0 if Setting is VX_ROTATE_MOVE.
Definition: zwapi_cmd_sk_cmds_data.h:713
svxRotateData2D::Pnt
svxPntOnEnt Pnt
Base point.
Definition: zwapi_cmd_sk_cmds_data.h:707
svxRotateData2D::Start
svxPntOnEnt Start
Start point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.
Definition: zwapi_cmd_sk_cmds_data.h:710
svxRotateData2D::Setting
evxRotateSetting Setting
Rotate settings, VX_ROTATE_MOVE is default.
Definition: zwapi_cmd_sk_cmds_data.h:712
svxRotateData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:705
svxRotateData2D::Type
evxRotateType Type
Option to set rotate type, VX_ROTATE_ANGLE is default.
Definition: zwapi_cmd_sk_cmds_data.h:708
svxRotateData2D
template command Rotate data
Definition: zwapi_cmd_sk_cmds_data.h:704
svxMoveData2D::evxMethodsUnion2D::PntToPnt2D
svxMovePntToPnt2D PntToPnt2D
point to point(2D)
Definition: zwapi_cmd_sk_cmds_data.h:675
svxMoveData2D::evxMethodsUnion2D::AlongDir2D
svxAlongDir2D AlongDir2D
along direction data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:674
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZwApiFAQ.txt File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
ZwApiFAQ.txt File Reference
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: ZwApiIntroduction.txt File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
ZwApiIntroduction.txt File Reference
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: ZwApiMainPage.txt File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
ZwApiMainPage.txt File Reference
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: ZwApiRemote.txt File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
ZwApiRemote.txt File Reference
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: ZwApiStructure.txt File Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
ZwApiStructure.txt File Reference
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evx3DBomLevelDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Data
evx3DBomLevelDispMode
evx3DBomLevelDispMode
evxReorderLoc
evxReorderLoc
svx3DBomData
svx3DBomSettingsData

◆ evx3DBomLevelDispMode

enum evx3DBomLevelDispMode

#include <zwapi_asm_data.h>

level display settings.

Note
In the part environment, 3D BOM supports only managing shape attributes.
Enumerator
VX_3DBOM_TOP_LEVEL_ONLY | Select this item to display only the top-level components.
VX_3DBOM_PARTS_ONLY | Select this item to display only parts.
VX_3DBOM_INDENTED | Select this item and indent it by assembly level.
VX_3DBOM_SHAPE_ONLY | Select this item to display only the shapes.
VX_3DBOM_ALLCOMPONENTS | Select this item to display all components that belong to the same level.

Definition at line 45 of file zwapi_asm_data.h.

46 {
47 VX_3DBOM_TOP_LEVEL_ONLY = 1,
48 VX_3DBOM_PARTS_ONLY = 2,
49 VX_3DBOM_INDENTED = 3,
50 VX_3DBOM_SHAPE_ONLY = 4,
51 VX_3DBOM_ALLCOMPONENTS = 5,
52 } evx3DBomLevelDispMode;
evx3DBomLevelDispMode
evx3DBomLevelDispMode
level display settings.
Definition: zwapi_asm_data.h:46
VX_3DBOM_TOP_LEVEL_ONLY
@ VX_3DBOM_TOP_LEVEL_ONLY
Select this item to display only the top-level components.
Definition: zwapi_asm_data.h:47
VX_3DBOM_PARTS_ONLY
@ VX_3DBOM_PARTS_ONLY
Select this item to display only parts.
Definition: zwapi_asm_data.h:48
VX_3DBOM_INDENTED
@ VX_3DBOM_INDENTED
Select this item and indent it by assembly level.
Definition: zwapi_asm_data.h:49
VX_3DBOM_SHAPE_ONLY
@ VX_3DBOM_SHAPE_ONLY
Select this item to display only the shapes.
Definition: zwapi_asm_data.h:50
VX_3DBOM_ALLCOMPONENTS
@ VX_3DBOM_ALLCOMPONENTS
Select this item to display all components that belong to the same level.
Definition: zwapi_asm_data.h:51
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxReorderLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Data
evx3DBomLevelDispMode
evx3DBomLevelDispMode
evxReorderLoc
evxReorderLoc
svx3DBomData
svx3DBomSettingsData

◆ evxReorderLoc

enum evxReorderLoc

#include <zwapi_asm_data.h>

Reorder location.

Enumerator
VX_REORDER_FIRST | insert the object as the first object
VX_REORDER_LAST | insert the object as the last object
VX_REORDER_AFTER | insert the object after the specified object

Definition at line 33 of file zwapi_asm_data.h.

34 {
35 VX_REORDER_FIRST = 0,
36 VX_REORDER_LAST = 1,
37 VX_REORDER_AFTER = 2,
38 } evxReorderLoc;
evxReorderLoc
evxReorderLoc
Reorder location.
Definition: zwapi_asm_data.h:34
VX_REORDER_LAST
@ VX_REORDER_LAST
insert the object as the last object
Definition: zwapi_asm_data.h:36
VX_REORDER_AFTER
@ VX_REORDER_AFTER
insert the object after the specified object
Definition: zwapi_asm_data.h:37
VX_REORDER_FIRST
@ VX_REORDER_FIRST
insert the object as the first object
Definition: zwapi_asm_data.h:35
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmCompClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ evxCmCompClass

enum evxCmCompClass

#include <zwapi_cm_comp.h>

cam component class

Definition at line 30 of file zwapi_cm_comp.h.

31 {
32 ZW_CAM_COMP_CLASS_PART,
33 ZW_CAM_COMP_CLASS_CLAMP,
34 ZW_CAM_COMP_CLASS_STOCK,
35 ZW_CAM_COMP_CLASS_TABLE,
36 ZW_CAM_COMP_CLASS_TOOLHOLDER,
37 ZW_CAM_COMP_CLASS_ATTACHMENT
38 }evxCmCompClass;
evxCmCompClass
evxCmCompClass
cam component class
Definition: zwapi_cm_comp.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmCompAtrr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Component API
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ evxCmCompAtrr

enum evxCmCompAtrr

#include <zwapi_cm_comp.h>

cam component attribute

Definition at line 44 of file zwapi_cm_comp.h.

45 {
46 ZW_CAM_COMP_ATTR_FACES,
47 ZW_CAM_COMP_ATTR_CLASS,
48 ZW_CAM_COMP_ATTR_CDCOMP
49 }evxCmCompAtrr;
evxCmCompAtrr
evxCmCompAtrr
cam component attribute
Definition: zwapi_cm_comp.h:45
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmFolderAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Folder API
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ evxCmFolderAttr

enum evxCmFolderAttr

#include <zwapi_cm_folder.h>

cam folder attribute

Definition at line 30 of file zwapi_cm_folder.h.

31 {
32 CM_FOLDER_NAME,
33 CM_FOLDER_SUB
34 }evxCmFolderAttr;
evxCmFolderAttr
evxCmFolderAttr
cam folder attribute
Definition: zwapi_cm_folder.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmOutFldType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ evxCmOutFldType

enum evxCmOutFldType

#include <zwapi_cm_forms.h>

cam output folder type

Definition at line 48 of file zwapi_cm_forms.h.

49 {
50 CM_OUTFLD_FLD,
51 CM_OUTFLD_NC
52 }evxCmOutFldType;
evxCmOutFldType
evxCmOutFldType
cam output folder type
Definition: zwapi_cm_forms.h:49
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmOutType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Forms API
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ evxCmOutType

enum evxCmOutType

#include <zwapi_cm_forms.h>

cam output type

Definition at line 58 of file zwapi_cm_forms.h.

59 {
60 CM_OUT_CL,
61 CM_OUT_NC,
62 CM_OUT_TOOL,
63 CM_OUT_OP,
64 CM_OUT_XML,
65 CM_OUT_HTML
66 }evxCmOutType;
evxCmOutType
evxCmOutType
cam output type
Definition: zwapi_cm_forms.h:59
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmFrameAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Frame API
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ evxCmFrameAttr

enum evxCmFrameAttr

#include <zwapi_cm_frame.h>

cam frame attribute

Definition at line 30 of file zwapi_cm_frame.h.

31 {
32 /* Definition Form */
33 CM_FRAME_NAME,
34 CM_FRAME_CLEAR_Z,
35 CM_FRAME_APPROACH_Z,
36 CM_FRAME_RETRACT_Z
37 }evxCmFrameAttr;
evxCmFrameAttr
evxCmFrameAttr
cam frame attribute
Definition: zwapi_cm_frame.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmFtrAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ evxCmFtrAttr

enum evxCmFtrAttr

#include <zwapi_cm_ftr.h>

cam feature attribute

Definition at line 50 of file zwapi_cm_ftr.h.

51 {
52 CM_FEATURE_TYPE
53 }evxCmFtrAttr;
evxCmFtrAttr
evxCmFtrAttr
cam feature attribute
Definition: zwapi_cm_ftr.h:51
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmProfileCuvAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ evxCmProfileCuvAttr

enum evxCmProfileCuvAttr

#include <zwapi_cm_ftr.h>

cam profile feature curve attribute

Enumerator
V_CM_PRF_OFFSET | curve's offset
V_CM_PRF_DRAFT | curve's draft
V_CM_PRF_TOOLLOC | curve's tool location

Definition at line 69 of file zwapi_cm_ftr.h.

70 {
71 V_CM_PRF_OFFSET = 0,
72 V_CM_PRF_DRAFT = 1,
73 V_CM_PRF_TOOLLOC = 2,
74 }evxCmProfileCuvAttr;
evxCmProfileCuvAttr
evxCmProfileCuvAttr
cam profile feature curve attribute
Definition: zwapi_cm_ftr.h:70
V_CM_PRF_OFFSET
@ V_CM_PRF_OFFSET
curve's offset
Definition: zwapi_cm_ftr.h:71
V_CM_PRF_TOOLLOC
@ V_CM_PRF_TOOLLOC
curve's tool location
Definition: zwapi_cm_ftr.h:73
V_CM_PRF_DRAFT
@ V_CM_PRF_DRAFT
curve's draft
Definition: zwapi_cm_ftr.h:72
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmFtrType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ evxCmFtrType

enum evxCmFtrType

#include <zwapi_cm_ftr.h>

cam feature type

Enumerator
ZW_CAM_FEATURE_SOLID | solid feature
ZW_CAM_FEATURE_POCKET | pocket feature
ZW_CAM_FEATURE_HOLE | hole feature
ZW_CAM_FEATURE_SLOT | slot feature
ZW_CAM_FEATURE_PROFILE | profile feature
ZW_CAM_FEATURE_STEP | step feature
ZW_CAM_FEATURE_SURFACE | surface feature
ZW_CAM_FEATURE_CHAMFER | chamfer feature
ZW_CAM_FEATURE_CRND | cround feature
ZW_CAM_FEATURE_FACE | face feature
ZW_CAM_FEATURE_BOSS | boss feature
ZW_CAM_FEATURE_FLAT | flat region feature

Definition at line 30 of file zwapi_cm_ftr.h.

31 {
32 ZW_CAM_FEATURE_SOLID = 1,
33 ZW_CAM_FEATURE_POCKET = 2,
34 ZW_CAM_FEATURE_HOLE = 3,
35 ZW_CAM_FEATURE_SLOT = 4,
36 ZW_CAM_FEATURE_PROFILE = 5,
37 ZW_CAM_FEATURE_STEP = 6,
38 ZW_CAM_FEATURE_SURFACE = 7,
39 ZW_CAM_FEATURE_CHAMFER = 8,
40 ZW_CAM_FEATURE_CRND = 9,
41 ZW_CAM_FEATURE_FACE = 10,
42 ZW_CAM_FEATURE_BOSS = 11,
43 ZW_CAM_FEATURE_FLAT = 12
44 }evxCmFtrType;
evxCmFtrType
evxCmFtrType
cam feature type
Definition: zwapi_cm_ftr.h:31
ZW_CAM_FEATURE_PROFILE
@ ZW_CAM_FEATURE_PROFILE
profile feature
Definition: zwapi_cm_ftr.h:36
ZW_CAM_FEATURE_POCKET
@ ZW_CAM_FEATURE_POCKET
pocket feature
Definition: zwapi_cm_ftr.h:33
ZW_CAM_FEATURE_CHAMFER
@ ZW_CAM_FEATURE_CHAMFER
chamfer feature
Definition: zwapi_cm_ftr.h:39
ZW_CAM_FEATURE_FACE
@ ZW_CAM_FEATURE_FACE
face feature
Definition: zwapi_cm_ftr.h:41
ZW_CAM_FEATURE_HOLE
@ ZW_CAM_FEATURE_HOLE
hole feature
Definition: zwapi_cm_ftr.h:34
ZW_CAM_FEATURE_FLAT
@ ZW_CAM_FEATURE_FLAT
flat region feature
Definition: zwapi_cm_ftr.h:43
ZW_CAM_FEATURE_STEP
@ ZW_CAM_FEATURE_STEP
step feature
Definition: zwapi_cm_ftr.h:37
ZW_CAM_FEATURE_SLOT
@ ZW_CAM_FEATURE_SLOT
slot feature
Definition: zwapi_cm_ftr.h:35
ZW_CAM_FEATURE_CRND
@ ZW_CAM_FEATURE_CRND
cround feature
Definition: zwapi_cm_ftr.h:40
ZW_CAM_FEATURE_BOSS
@ ZW_CAM_FEATURE_BOSS
boss feature
Definition: zwapi_cm_ftr.h:42
ZW_CAM_FEATURE_SURFACE
@ ZW_CAM_FEATURE_SURFACE
surface feature
Definition: zwapi_cm_ftr.h:38
ZW_CAM_FEATURE_SOLID
@ ZW_CAM_FEATURE_SOLID
solid feature
Definition: zwapi_cm_ftr.h:32
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmProfileTolLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ evxCmProfileTolLoc

enum evxCmProfileTolLoc

#include <zwapi_cm_ftr.h>

cam profile feature tool location type

Enumerator
V_CM_PRF_ON | tool is on curve
V_CM_PRF_TAN | tool is tangent curve
V_CM_PRF_PAST | tool is past curve

Definition at line 80 of file zwapi_cm_ftr.h.

81 {
82 V_CM_PRF_ON = 0,
83 V_CM_PRF_TAN = 1,
84 V_CM_PRF_PAST = 2,
85 }evxCmProfileTolLoc;
evxCmProfileTolLoc
evxCmProfileTolLoc
cam profile feature tool location type
Definition: zwapi_cm_ftr.h:81
V_CM_PRF_ON
@ V_CM_PRF_ON
tool is on curve
Definition: zwapi_cm_ftr.h:82
V_CM_PRF_TAN
@ V_CM_PRF_TAN
tool is tangent curve
Definition: zwapi_cm_ftr.h:83
V_CM_PRF_PAST
@ V_CM_PRF_PAST
tool is past curve
Definition: zwapi_cm_ftr.h:84
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmFtrProfileType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Feature API
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ evxCmFtrProfileType

enum evxCmFtrProfileType

#include <zwapi_cm_ftr.h>

cam profile feature type

Definition at line 59 of file zwapi_cm_ftr.h.

60 {
61 PART,
62 CONTAIN
63 }evxCmFtrProfileType;
evxCmFtrProfileType
evxCmFtrProfileType
cam profile feature type
Definition: zwapi_cm_ftr.h:60
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmMachSubType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ evxCmMachSubType

enum evxCmMachSubType

#include <zwapi_cm_machine.h>

cam machine sub type

Definition at line 50 of file zwapi_cm_machine.h.

51 {
52 CM_MACH_SUBTYPE_ROTATING_HEAD,
53 CM_MACH_SUBTYPE_ROTATING_TABLE
54 }evxCmMachSubType;
evxCmMachSubType
evxCmMachSubType
cam machine sub type
Definition: zwapi_cm_machine.h:51
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmMachAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ evxCmMachAttr

enum evxCmMachAttr

#include <zwapi_cm_machine.h>

cam machine attribute

Definition at line 71 of file zwapi_cm_machine.h.

72 {
73 /* Definition Form */
74 CM_MACH_NAME,
75 CM_MACH_CLASS,
76 CM_MACH_TYPE,
77 CM_MACH_SUBTYPE,
78 CM_MACH_POST_CONFIGURATION,
79 CM_MACH_CUT_COMPENSATION,
80 /* Others */
81 }evxCmMachAttr;
evxCmMachAttr
evxCmMachAttr
cam machine attribute
Definition: zwapi_cm_machine.h:72
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmMachClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ evxCmMachClass

enum evxCmMachClass

#include <zwapi_cm_machine.h>

cam machine class

Definition at line 30 of file zwapi_cm_machine.h.

31 {
32 TWO_AXIS_MC,
33 THREE_AXIS_MC
34 }evxCmMachClass;
evxCmMachClass
evxCmMachClass
cam machine class
Definition: zwapi_cm_machine.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmMachType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ evxCmMachType

enum evxCmMachType

#include <zwapi_cm_machine.h>

cam machine type

Definition at line 40 of file zwapi_cm_machine.h.

41 {
42 CM_MACH_TYPE_VERTICAL,
43 CM_MACH_TYPE_HORIZNTAL
44 }evxCmMachType;
evxCmMachType
evxCmMachType
cam machine type
Definition: zwapi_cm_machine.h:41
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmMachCutCompenation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Machine
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ evxCmMachCutCompenation

enum evxCmMachCutCompenation

#include <zwapi_cm_machine.h>

cam machine cut type

Definition at line 60 of file zwapi_cm_machine.h.

61 {
62 CM_MACH_CUT_COMPENSATION_NONE,
63 CM_MACH_CUT_COMPENSATION_LENGTH,
64 CM_MACH_CUT_COMPENSATION_CENTER
65 }evxCmMachCutCompenation;
evxCmMachCutCompenation
evxCmMachCutCompenation
cam machine cut type
Definition: zwapi_cm_machine.h:61
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmOpType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ evxCmOpType

enum evxCmOpType

#include <zwapi_cm_op.h>

cam operation type

Definition at line 30 of file zwapi_cm_op.h.

31 {
32 /* Drill:0-19*/
33 ZW_CAM_OPERATION_CENTER = 0,
34 ZW_CAM_OPERATION_DRILL,
35 ZW_CAM_OPERATION_PECK,
36 ZW_CAM_OPERATION_CHIP,
37 ZW_CAM_OPERATION_REAM,
38 ZW_CAM_OPERATION_BORE,
39 ZW_CAM_OPERATION_FINEBORE,
40 ZW_CAM_OPERATION_COUNTERBORE,
41 ZW_CAM_OPERATION_COUNTERSINK,
42 ZW_CAM_OPERATION_TAP,
43 /* 2X:20-34*/
44 ZW_CAM_OPERATION_PROFILECUT = 20,
45 ZW_CAM_OPERATION_SPIRAL,
46 ZW_CAM_OPERATION_ZIGZAG,
47 ZW_CAM_OPERATION_BOX,
48 ZW_CAM_OPERATION_CONTOUR,
49 ZW_CAM_OPERATION_CHAMFER,
50 ZW_CAM_OPERATION_COURNER_ROUND,
51 ZW_CAM_OPERATION_HELICAL,
52 ZW_CAM_OPERATION_RAMP,
53 ZW_CAM_OPERATION_TOPFACE_CUT,
54 ZW_CAM_OPERATION_NESTING,
55 ZW_CAM_OPERATION_INTER_PATH_MOVE,
56 ZW_CAM_OPERATION_THREADMILL,
57 /* Turning:35-49*/
58 ZW_CAM_OPERATION_DRILL_TURNING = 35,
59 ZW_CAM_OPERATION_FACING,
60 ZW_CAM_OPERATION_ROUGH,
61 ZW_CAM_OPERATION_FINISH,
62 ZW_CAM_OPERATION_GROOVE,
63 ZW_CAM_OPERATION_THREADING,
64 ZW_CAM_OPERATION_PARTOFF,
65 /* 3X:50-79*/
66 ZW_CAM_OPERATION_SPIRAL_ROUGH = 50,
67 ZW_CAM_OPERATION_ZIGZAG_ROUGH,
68 ZW_CAM_OPERATION_BOX_ROUGH,
69 ZW_CAM_OPERATION_CONTOUR_ROUGH,
70 ZW_CAM_OPERATION_SPIRAL_CAST = 55,
71 ZW_CAM_OPERATION_ZIGZAG_CAST,
72 ZW_CAM_OPERATION_BOX_CAST,
73 ZW_CAM_OPERATION_CONTOUR_CAST,
74 ZW_CAM_OPERATION_SPIRAL_FINISH = 60,
75 ZW_CAM_OPERATION_ZIGZAG_FINISH,
76 ZW_CAM_OPERATION_BOX_FINISH,
77 ZW_CAM_OPERATION_CONTOUR_FINISH,
78 ZW_CAM_OPERATION_PROFILE_FINISH,
79 ZW_CAM_OPERATION_SIDE,
80 ZW_CAM_OPERATION_PEELING,
81 ZW_CAM_OPERATION_ISO,
82 ZW_CAM_OPERATION_3XISO,
83 ZW_CAM_OPERATION_MAP,
84 ZW_CAM_OPERATION_REST,
85 ZW_CAM_OPERATION_PENCIL_TRACE,
86 ZW_CAM_OPERATION_SCALLOP_REMOVAL,
87 ZW_CAM_OPERATION_SURFACE_ENGRAVING,
88 /* QM:80-109*/
89 ZW_CAM_OPERATION_SMOOTHFLOW = 80,
90 ZW_CAM_OPERATION_OFFSET2D,
91 ZW_CAM_OPERATION_LACE_ROUGH,
92 ZW_CAM_OPERATION_PLUNGE,
93 ZW_CAM_OPERATION_PRE_DRILL,
94 ZW_CAM_OPERATION_OFFSET3D,
95 ZW_CAM_OPERATION_LACE_FINISH,
96 ZW_CAM_OPERATION_ANGLE_LIMITING_FINISHING,
97 ZW_CAM_OPERATION_DRIVE_CURVE,
98 ZW_CAM_OPERATION_ZLEVEL,
99 ZW_CAM_OPERATION_PENCIL,
100 ZW_CAM_OPERATION_FLOW_3D,
101 ZW_CAM_OPERATION_BULGE,
102 ZW_CAM_OPERATION_ENGRAVE_2D,
103 ZW_CAM_OPERATION_SMOOTHFLOW_HSM = 95,
104 ZW_CAM_OPERATION_OFFSET2D_HSM,
105 ZW_CAM_OPERATION_LACE_HSM,
106 ZW_CAM_OPERATION_FLOW_HSM,
107 ZW_CAM_OPERATION_CORNERFINISH,
108 ZW_CAM_OPERATION_FLATFINISH,
109 /* 5X:110-129*/
110 ZW_CAM_OPERATION_PLANE = 110,
111 ZW_CAM_OPERATION_SWARF,
112 ZW_CAM_OPERATION_DRIVECURVE_5X,
113 ZW_CAM_OPERATION_INTERACTIVE,
114 ZW_CAM_OPERATION_FLOW_5X,
115 ZW_CAM_OPERATION_SIDE_5X,
116 ZW_CAM_OPERATION_GUIDE_SURFACE_ISO
117 }evxCmOpType;
evxCmOpType
evxCmOpType
cam operation type
Definition: zwapi_cm_op.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmQmOpAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ evxCmQmOpAttr

enum evxCmQmOpAttr

#include <zwapi_cm_op.h>

cam qm operation attribute

Definition at line 134 of file zwapi_cm_op.h.

135 {
136 ZW_CAM_QM_OPERATION_ATTR_NAME = 400,
137 ZW_CAM_QM_OPERATION_ATTR_FRAME,
138 ZW_CAM_QM_OPERATION_ATTR_PATH_TOL,
139 ZW_CAM_QM_OPERATION_ATTR_SURF_THICK,
140 ZW_CAM_QM_OPERATION_ATTR_Z_SURF_THICK,
141 ZW_CAM_QM_OPERATION_ATTR_TOOL,
142 ZW_CAM_QM_OPERATION_ATTR_MINTOOLHEIGHT,
143 ZW_CAM_QM_OPERATION_ATTR_CLASS,
144 ZW_CAM_QM_OPERATION_ATTR_LIMIT_TOPZ,
145 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOMZ,
146 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE,
147 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_ZDISPLACEMENT,
148 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_OFFSET
149 }evxCmQmOpAttr;
evxCmQmOpAttr
evxCmQmOpAttr
cam qm operation attribute
Definition: zwapi_cm_op.h:135
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCm2XOpAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ evxCm2XOpAttr

enum evxCm2XOpAttr

#include <zwapi_cm_op.h>

cam mill2 operation attribute

Definition at line 123 of file zwapi_cm_op.h.

124 {
125 ZW_CAM_2X_OPERATION_ATTR_NAME = 300,
126 ZW_CAM_2X_OPERATION_ATTR_FRAME,
127 ZW_CAM_2X_OPERATION_ATTR_PATH_TOL,
128 }evxCm2XOpAttr;
evxCm2XOpAttr
evxCm2XOpAttr
cam mill2 operation attribute
Definition: zwapi_cm_op.h:124
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmOpClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Operation
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ evxCmOpClass

enum evxCmOpClass

#include <zwapi_cm_op.h>

cam operation class: finish or rough

Enumerator
CM_OP_ROUGH | rough operation
CM_OP_FINISH | finish operation

Definition at line 155 of file zwapi_cm_op.h.

156 {
157 CM_OP_ROUGH = 0,
158 CM_OP_FINISH = 1,
159 }evxCmOpClass;
evxCmOpClass
evxCmOpClass
cam operation class: finish or rough
Definition: zwapi_cm_op.h:156
CM_OP_FINISH
@ CM_OP_FINISH
finish operation
Definition: zwapi_cm_op.h:158
CM_OP_ROUGH
@ CM_OP_ROUGH
rough operation
Definition: zwapi_cm_op.h:157
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmObjType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Query
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ evxCmObjType

enum evxCmObjType

#include <zwapi_cm_query.h>

cam object type

Definition at line 30 of file zwapi_cm_query.h.

31 {
32 CM_OPERATION,
33 CM_OPFOLDER,
34 CM_TOOL,
35 CM_MACHINE,
36 CM_CMCOMP,
37 CM_FTR,
38 CM_FRAME,
39 CM_OUT
40 }evxCmObjType;
evxCmObjType
evxCmObjType
cam object type
Definition: zwapi_cm_query.h:31
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmToolType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ evxCmToolType

enum evxCmToolType

#include <zwapi_cm_tool.h>

cam tool type

Enumerator
CM_TOOL_TYPE_MILL | mill
CM_TOOL_TYPE_FLAME | flame
CM_TOOL_TYPE_DRILL | drill
CM_TOOL_TYPE_TAP | tap
CM_TOOL_TYPE_CENTER | center
CM_TOOL_TYPE_CHAMFER | chamfer
CM_TOOL_TYPE_REAM | ream
CM_TOOL_TYPE_BORE | bore

Definition at line 30 of file zwapi_cm_tool.h.

31 {
32 CM_TOOL_TYPE_MILL,
33 CM_TOOL_TYPE_FLAME,
34 CM_TOOL_TYPE_DRILL,
35 CM_TOOL_TYPE_TAP,
36 CM_TOOL_TYPE_CENTER,
37 CM_TOOL_TYPE_CHAMFER,
38 CM_TOOL_TYPE_REAM,
39 CM_TOOL_TYPE_BORE
40 }evxCmToolType;
evxCmToolType
evxCmToolType
cam tool type
Definition: zwapi_cm_tool.h:31
CM_TOOL_TYPE_CHAMFER
@ CM_TOOL_TYPE_CHAMFER
chamfer
Definition: zwapi_cm_tool.h:37
CM_TOOL_TYPE_REAM
@ CM_TOOL_TYPE_REAM
ream
Definition: zwapi_cm_tool.h:38
CM_TOOL_TYPE_FLAME
@ CM_TOOL_TYPE_FLAME
flame
Definition: zwapi_cm_tool.h:33
CM_TOOL_TYPE_TAP
@ CM_TOOL_TYPE_TAP
tap
Definition: zwapi_cm_tool.h:35
CM_TOOL_TYPE_MILL
@ CM_TOOL_TYPE_MILL
mill
Definition: zwapi_cm_tool.h:32
CM_TOOL_TYPE_CENTER
@ CM_TOOL_TYPE_CENTER
center
Definition: zwapi_cm_tool.h:36
CM_TOOL_TYPE_BORE
@ CM_TOOL_TYPE_BORE
bore
Definition: zwapi_cm_tool.h:39
CM_TOOL_TYPE_DRILL
@ CM_TOOL_TYPE_DRILL
drill
Definition: zwapi_cm_tool.h:34
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmToolAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ evxCmToolAttr

enum evxCmToolAttr

#include <zwapi_cm_tool.h>

cam tool attribute

Enumerator
CM_TOOL_NAME | tool name
CM_TOOL_TYPE | tool type
CM_TOOL_SUBTYPE | tool subtype
CM_TOOL_ID | tool id
CM_TOOL_LEN | tool_length
CM_TOOL_CUTTERDIAMETER | tool diameter
CM_TOOL_HOLDER | tool holder name

Definition at line 58 of file zwapi_cm_tool.h.

59 {
60 CM_TOOL_NAME = 400,
61 CM_TOOL_TYPE,
62 CM_TOOL_SUBTYPE,
63 CM_TOOL_ID,
64 CM_TOOL_LEN,
65 CM_TOOL_CUTTERDIAMETER,
66 CM_TOOL_HOLDER,
67 /* tool register data in active machine */
68 CM_TOOLCHANGER_LOCATION,
69 CM_TOOLCHANGER_DIAMETER,
70 CM_TOOLCHANGER_HEIGHT
71 }evxCmToolAttr;
evxCmToolAttr
evxCmToolAttr
cam tool attribute
Definition: zwapi_cm_tool.h:59
CM_TOOL_TYPE
@ CM_TOOL_TYPE
tool type
Definition: zwapi_cm_tool.h:61
CM_TOOL_LEN
@ CM_TOOL_LEN
tool_length
Definition: zwapi_cm_tool.h:64
CM_TOOL_NAME
@ CM_TOOL_NAME
tool name
Definition: zwapi_cm_tool.h:60
CM_TOOL_ID
@ CM_TOOL_ID
tool id
Definition: zwapi_cm_tool.h:63
CM_TOOL_CUTTERDIAMETER
@ CM_TOOL_CUTTERDIAMETER
tool diameter
Definition: zwapi_cm_tool.h:65
CM_TOOL_HOLDER
@ CM_TOOL_HOLDER
tool holder name
Definition: zwapi_cm_tool.h:66
CM_TOOL_SUBTYPE
@ CM_TOOL_SUBTYPE
tool subtype
Definition: zwapi_cm_tool.h:62
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmToolSubType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Cam Tool
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ evxCmToolSubType

enum evxCmToolSubType

#include <zwapi_cm_tool.h>

cam tool sub type

Enumerator
CM_TOOL_SUBTYPE_NULL | NULL.
CM_TOOL_SUBTYPE_BALLNOSE | taperball
CM_TOOL_SUBTYPE_BULLNOSE | taperbull
CM_TOOL_SUBTYPE_ENDNOSE | end

Definition at line 46 of file zwapi_cm_tool.h.

47 {
48 CM_TOOL_SUBTYPE_NULL = -1,
49 CM_TOOL_SUBTYPE_BALLNOSE,
50 CM_TOOL_SUBTYPE_BULLNOSE,
51 CM_TOOL_SUBTYPE_ENDNOSE
52 }evxCmToolSubType;
evxCmToolSubType
evxCmToolSubType
cam tool sub type
Definition: zwapi_cm_tool.h:47
CM_TOOL_SUBTYPE_NULL
@ CM_TOOL_SUBTYPE_NULL
NULL.
Definition: zwapi_cm_tool.h:48
CM_TOOL_SUBTYPE_BALLNOSE
@ CM_TOOL_SUBTYPE_BALLNOSE
taperball
Definition: zwapi_cm_tool.h:49
CM_TOOL_SUBTYPE_ENDNOSE
@ CM_TOOL_SUBTYPE_ENDNOSE
end
Definition: zwapi_cm_tool.h:51
CM_TOOL_SUBTYPE_BULLNOSE
@ CM_TOOL_SUBTYPE_BULLNOSE
taperbull
Definition: zwapi_cm_tool.h:50
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmFlltArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmFlltArc

enum evxAsmFlltArc

#include <zwapi_cmd_assembly_data.h>

assembly fillet arc method

Enumerator
VX_ASM_FLLT_ARC_CIR | circular arc type
VX_ASM_FLLT_ARC_CONIC | conic arc type

Definition at line 550 of file zwapi_cmd_assembly_data.h.

551 {
552 VX_ASM_FLLT_ARC_CIR,
553 VX_ASM_FLLT_ARC_CONIC,
554 } evxAsmFlltArc;
evxAsmFlltArc
evxAsmFlltArc
assembly fillet arc method
Definition: zwapi_cmd_assembly_data.h:551
VX_ASM_FLLT_ARC_CONIC
@ VX_ASM_FLLT_ARC_CONIC
conic arc type
Definition: zwapi_cmd_assembly_data.h:553
VX_ASM_FLLT_ARC_CIR
@ VX_ASM_FLLT_ARC_CIR
circular arc type
Definition: zwapi_cmd_assembly_data.h:552
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPtnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPtnCrv

enum evxAsmPtnCrv

#include <zwapi_cmd_assembly_data.h>

assembly pattern curves method

Enumerator
VX_ASM_PTN_CRV1 | 1 curve option
VX_ASM_PTN_CRV2_TOG | 2 cruves together option
VX_ASM_PTN_CRV2_ACROSS | 2 cruves across option
VX_ASM_PTN_CRV3 | 3-4 curves option

Definition at line 431 of file zwapi_cmd_assembly_data.h.

432 {
433 VX_ASM_PTN_CRV1,
434 VX_ASM_PTN_CRV2_TOG,
435 VX_ASM_PTN_CRV2_ACROSS,
436 VX_ASM_PTN_CRV3,
437 } evxAsmPtnCrv;
evxAsmPtnCrv
evxAsmPtnCrv
assembly pattern curves method
Definition: zwapi_cmd_assembly_data.h:432
VX_ASM_PTN_CRV1
@ VX_ASM_PTN_CRV1
1 curve option
Definition: zwapi_cmd_assembly_data.h:433
VX_ASM_PTN_CRV2_ACROSS
@ VX_ASM_PTN_CRV2_ACROSS
2 cruves across option
Definition: zwapi_cmd_assembly_data.h:435
VX_ASM_PTN_CRV2_TOG
@ VX_ASM_PTN_CRV2_TOG
2 cruves together option
Definition: zwapi_cmd_assembly_data.h:434
VX_ASM_PTN_CRV3
@ VX_ASM_PTN_CRV3
3-4 curves option
Definition: zwapi_cmd_assembly_data.h:436
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAlignType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAlignType

enum evxAlignType

#include <zwapi_cmd_assembly_data.h>

part component/shape alignment

Enumerator
VX_ALIGN_COINCIDENT | coincident
VX_ALIGN_TANGENT | tangent
VX_ALIGN_CONCENTRIC | concentric
VX_ALIGN_PARALLEL | parallel
VX_ALIGN_PERPENDICULAR | perpendicular
VX_ALIGN_ANGLE | angle

Definition at line 143 of file zwapi_cmd_assembly_data.h.

144 {
145 VX_ALIGN_COINCIDENT = 0,
146 VX_ALIGN_TANGENT = 1,
147 VX_ALIGN_CONCENTRIC = 2,
148 VX_ALIGN_PARALLEL = 3,
149 VX_ALIGN_PERPENDICULAR = 4,
150 VX_ALIGN_ANGLE = 5
151 } evxAlignType;
evxAlignType
evxAlignType
part component/shape alignment
Definition: zwapi_cmd_assembly_data.h:144
VX_ALIGN_PERPENDICULAR
@ VX_ALIGN_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_assembly_data.h:149
VX_ALIGN_ANGLE
@ VX_ALIGN_ANGLE
angle
Definition: zwapi_cmd_assembly_data.h:150
VX_ALIGN_CONCENTRIC
@ VX_ALIGN_CONCENTRIC
concentric
Definition: zwapi_cmd_assembly_data.h:147
VX_ALIGN_PARALLEL
@ VX_ALIGN_PARALLEL
parallel
Definition: zwapi_cmd_assembly_data.h:148
VX_ALIGN_COINCIDENT
@ VX_ALIGN_COINCIDENT
coincident
Definition: zwapi_cmd_assembly_data.h:145
VX_ALIGN_TANGENT
@ VX_ALIGN_TANGENT
tangent
Definition: zwapi_cmd_assembly_data.h:146
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMirrorSymm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMirrorSymm

enum evxAsmMirrorSymm

#include <zwapi_cmd_assembly_data.h>

assembly mirror self-symmetric method

Enumerator
VX_ASM_MIRROR_SYMM_XZ | XZ option.
VX_ASM_MIRROR_SYMM_YZ | YZ option.
VX_ASM_MIRROR_SYMM_XY | XY option.
VX_ASM_MIRROR_SYMM_C | C option.
VX_ASM_MIRROR_SYMM_XCZC | XcZc option.
VX_ASM_MIRROR_SYMM_YCZC | YcZc option.
VX_ASM_MIRROR_SYMM_XCYC | XcYc option.
VX_ASM_MIRROR_SYMM_NONE | none option

Definition at line 511 of file zwapi_cmd_assembly_data.h.

512 {
513 VX_ASM_MIRROR_SYMM_XZ,
514 VX_ASM_MIRROR_SYMM_YZ,
515 VX_ASM_MIRROR_SYMM_XY,
516 VX_ASM_MIRROR_SYMM_C,
517 VX_ASM_MIRROR_SYMM_XCZC,
518 VX_ASM_MIRROR_SYMM_YCZC,
519 VX_ASM_MIRROR_SYMM_XCYC,
520 VX_ASM_MIRROR_SYMM_NONE,
521 } evxAsmMirrorSymm;
evxAsmMirrorSymm
evxAsmMirrorSymm
assembly mirror self-symmetric method
Definition: zwapi_cmd_assembly_data.h:512
VX_ASM_MIRROR_SYMM_YZ
@ VX_ASM_MIRROR_SYMM_YZ
YZ option.
Definition: zwapi_cmd_assembly_data.h:514
VX_ASM_MIRROR_SYMM_YCZC
@ VX_ASM_MIRROR_SYMM_YCZC
YcZc option.
Definition: zwapi_cmd_assembly_data.h:518
VX_ASM_MIRROR_SYMM_C
@ VX_ASM_MIRROR_SYMM_C
C option.
Definition: zwapi_cmd_assembly_data.h:516
VX_ASM_MIRROR_SYMM_XZ
@ VX_ASM_MIRROR_SYMM_XZ
XZ option.
Definition: zwapi_cmd_assembly_data.h:513
VX_ASM_MIRROR_SYMM_XCZC
@ VX_ASM_MIRROR_SYMM_XCZC
XcZc option.
Definition: zwapi_cmd_assembly_data.h:517
VX_ASM_MIRROR_SYMM_NONE
@ VX_ASM_MIRROR_SYMM_NONE
none option
Definition: zwapi_cmd_assembly_data.h:520
VX_ASM_MIRROR_SYMM_XY
@ VX_ASM_MIRROR_SYMM_XY
XY option.
Definition: zwapi_cmd_assembly_data.h:515
VX_ASM_MIRROR_SYMM_XCYC
@ VX_ASM_MIRROR_SYMM_XCYC
XcYc option.
Definition: zwapi_cmd_assembly_data.h:519
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxSlotConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxSlotConsType

enum evxSlotConsType

#include <zwapi_cmd_assembly_data.h>

slot constraint type

Enumerator
VX_SLOT_CONS_FREE | component can move along the slot
VX_SLOT_CONS_CENTER | constraint component in the center of slot
VX_SLOT_CONS_DISTANCE | constraint component to a specified distance from the end of slot
VX_SLOT_CONS_PERCENT | constraint component to a distance specified by a percentage from the end of slot
Examples
part\asmConsTest.cpp.

Definition at line 334 of file zwapi_cmd_assembly_data.h.

335 {
336 VX_SLOT_CONS_FREE = 0,
337 VX_SLOT_CONS_CENTER = 1,
338 VX_SLOT_CONS_DISTANCE = 2,
339 VX_SLOT_CONS_PERCENT = 3,
340 } evxSlotConsType;
evxSlotConsType
evxSlotConsType
slot constraint type
Definition: zwapi_cmd_assembly_data.h:335
VX_SLOT_CONS_PERCENT
@ VX_SLOT_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of slot
Definition: zwapi_cmd_assembly_data.h:339
VX_SLOT_CONS_DISTANCE
@ VX_SLOT_CONS_DISTANCE
constraint component to a specified distance from the end of slot
Definition: zwapi_cmd_assembly_data.h:338
VX_SLOT_CONS_CENTER
@ VX_SLOT_CONS_CENTER
constraint component in the center of slot
Definition: zwapi_cmd_assembly_data.h:337
VX_SLOT_CONS_FREE
@ VX_SLOT_CONS_FREE
component can move along the slot
Definition: zwapi_cmd_assembly_data.h:336
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmChmfFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmChmfFace

enum evxAsmChmfFace

#include <zwapi_cmd_assembly_data.h>

assembly chamfer fillet face method

Enumerator
VX_ASM_CHMF_FACE_MAX | maximal option
VX_ASM_CHMF_FACE_MIN | minimal option
VX_ASM_CHMF_FACE_MATCH | tangent match option

Definition at line 619 of file zwapi_cmd_assembly_data.h.

620 {
621 VX_ASM_CHMF_FACE_MAX,
622 VX_ASM_CHMF_FACE_MIN,
623 VX_ASM_CHMF_FACE_MATCH,
624 } evxAsmChmfFace;
evxAsmChmfFace
evxAsmChmfFace
assembly chamfer fillet face method
Definition: zwapi_cmd_assembly_data.h:620
VX_ASM_CHMF_FACE_MATCH
@ VX_ASM_CHMF_FACE_MATCH
tangent match option
Definition: zwapi_cmd_assembly_data.h:623
VX_ASM_CHMF_FACE_MAX
@ VX_ASM_CHMF_FACE_MAX
maximal option
Definition: zwapi_cmd_assembly_data.h:621
VX_ASM_CHMF_FACE_MIN
@ VX_ASM_CHMF_FACE_MIN
minimal option
Definition: zwapi_cmd_assembly_data.h:622
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMoveXOrnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMoveXOrnt

enum evxAsmMoveXOrnt

#include <zwapi_cmd_assembly_data.h>

assembly move x-orient method

Enumerator
VX_ASM_MOVE_X_NTR | natural option
VX_ASM_MOVE_X_GUIDE | guide plane option
VX_ASM_MOVE_X_AXIS | x-axis curve option

Definition at line 490 of file zwapi_cmd_assembly_data.h.

491 {
492 VX_ASM_MOVE_X_NTR,
493 VX_ASM_MOVE_X_GUIDE,
494 VX_ASM_MOVE_X_AXIS,
495 } evxAsmMoveXOrnt;
evxAsmMoveXOrnt
evxAsmMoveXOrnt
assembly move x-orient method
Definition: zwapi_cmd_assembly_data.h:491
VX_ASM_MOVE_X_NTR
@ VX_ASM_MOVE_X_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:492
VX_ASM_MOVE_X_AXIS
@ VX_ASM_MOVE_X_AXIS
x-axis curve option
Definition: zwapi_cmd_assembly_data.h:494
VX_ASM_MOVE_X_GUIDE
@ VX_ASM_MOVE_X_GUIDE
guide plane option
Definition: zwapi_cmd_assembly_data.h:493
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxResponse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxResponse

enum evxResponse

#include <zwapi_cmd_assembly_data.h>

response to user prompt

Enumerator
VX_CANCEL | cancel
VX_NO | no
VX_YES | yes
VX_YES_ALL | yes all

Definition at line 128 of file zwapi_cmd_assembly_data.h.

129 {
130 VX_CANCEL = -1,
131 VX_NO = 0,
132 VX_YES = 1,
133 VX_YES_ALL = 2
134 } evxResponse;
evxResponse
evxResponse
response to user prompt
Definition: zwapi_cmd_assembly_data.h:129
VX_CANCEL
@ VX_CANCEL
cancel
Definition: zwapi_cmd_assembly_data.h:130
VX_YES
@ VX_YES
yes
Definition: zwapi_cmd_assembly_data.h:132
VX_YES_ALL
@ VX_YES_ALL
yes all
Definition: zwapi_cmd_assembly_data.h:133
VX_NO
@ VX_NO
no
Definition: zwapi_cmd_assembly_data.h:131
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPtnDrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPtnDrv

enum evxAsmPtnDrv

#include <zwapi_cmd_assembly_data.h>

assembly pattern derive method

Enumerator
VX_ASM_PTN_DRV_NONE | none option
VX_ASM_PTN_DRV_SPACING | spacing option
VX_ASM_PTN_DRV_NUM | number option

Definition at line 410 of file zwapi_cmd_assembly_data.h.

411 {
412 VX_ASM_PTN_DRV_NONE,
413 VX_ASM_PTN_DRV_SPACING,
414 VX_ASM_PTN_DRV_NUM,
415 } evxAsmPtnDrv;
evxAsmPtnDrv
evxAsmPtnDrv
assembly pattern derive method
Definition: zwapi_cmd_assembly_data.h:411
VX_ASM_PTN_DRV_SPACING
@ VX_ASM_PTN_DRV_SPACING
spacing option
Definition: zwapi_cmd_assembly_data.h:413
VX_ASM_PTN_DRV_NONE
@ VX_ASM_PTN_DRV_NONE
none option
Definition: zwapi_cmd_assembly_data.h:412
VX_ASM_PTN_DRV_NUM
@ VX_ASM_PTN_DRV_NUM
number option
Definition: zwapi_cmd_assembly_data.h:414
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAlignInterference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAlignInterference

enum evxAlignInterference

#include <zwapi_cmd_assembly_data.h>

interference type

Enumerator
VX_INTERFERENCE_NONE | do not check for interference when dragging a component
VX_INTERFERENCE_HIGHLIGHT | when you drag a component, it will pause when interference is detected and the intersecting faces will highlight
VX_INTERFERENCE_STOP_AT | this is similar to the VX_INTERFERENCE_HIGHLIGHT option but the component is stopped at the point of intersection
VX_INTERFERENCE_ADD_ALIGN | add constraint

Definition at line 157 of file zwapi_cmd_assembly_data.h.

158 {
159 VX_INTERFERENCE_NONE = 0,
160 VX_INTERFERENCE_HIGHLIGHT = 1,
163 VX_INTERFERENCE_STOP_AT = 2,
166 VX_INTERFERENCE_ADD_ALIGN = 3
167 } evxAlignInterference;
evxAlignInterference
evxAlignInterference
interference type
Definition: zwapi_cmd_assembly_data.h:158
VX_INTERFERENCE_HIGHLIGHT
@ VX_INTERFERENCE_HIGHLIGHT
when you drag a component, it will pause when interference is detected and the intersecting faces wil...
Definition: zwapi_cmd_assembly_data.h:160
VX_INTERFERENCE_STOP_AT
@ VX_INTERFERENCE_STOP_AT
this is similar to the VX_INTERFERENCE_HIGHLIGHT option but the component is stopped at the point of ...
Definition: zwapi_cmd_assembly_data.h:163
VX_INTERFERENCE_ADD_ALIGN
@ VX_INTERFERENCE_ADD_ALIGN
add constraint
Definition: zwapi_cmd_assembly_data.h:166
VX_INTERFERENCE_NONE
@ VX_INTERFERENCE_NONE
do not check for interference when dragging a component
Definition: zwapi_cmd_assembly_data.h:159
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPtnStagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPtnStagger

enum evxAsmPtnStagger

#include <zwapi_cmd_assembly_data.h>

assembly pattern stagger method

Enumerator
VX_ASM_PTN_NO_STAGGER | no stagger option
VX_ASM_PTN_STAGGER | stagger pattern option

Definition at line 400 of file zwapi_cmd_assembly_data.h.

401 {
402 VX_ASM_PTN_NO_STAGGER,
403 VX_ASM_PTN_STAGGER,
404 } evxAsmPtnStagger;
evxAsmPtnStagger
evxAsmPtnStagger
assembly pattern stagger method
Definition: zwapi_cmd_assembly_data.h:401
VX_ASM_PTN_NO_STAGGER
@ VX_ASM_PTN_NO_STAGGER
no stagger option
Definition: zwapi_cmd_assembly_data.h:402
VX_ASM_PTN_STAGGER
@ VX_ASM_PTN_STAGGER
stagger pattern option
Definition: zwapi_cmd_assembly_data.h:403
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxRollCtrlType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxRollCtrlType

enum evxRollCtrlType

#include <zwapi_cmd_assembly_data.h>

roll control type

Enumerator
VX_ROLL_CTRL_FREE | the roll of component is not constrained
VX_ROLL_CTRL_UP_VEC | constraint an axis of component to align with the specified vector
Examples
part\asmConsTest.cpp.

Definition at line 268 of file zwapi_cmd_assembly_data.h.

269 {
270 VX_ROLL_CTRL_FREE = 0,
271 VX_ROLL_CTRL_UP_VEC = 1,
272 } evxRollCtrlType;
evxRollCtrlType
evxRollCtrlType
roll control type
Definition: zwapi_cmd_assembly_data.h:269
VX_ROLL_CTRL_FREE
@ VX_ROLL_CTRL_FREE
the roll of component is not constrained
Definition: zwapi_cmd_assembly_data.h:270
VX_ROLL_CTRL_UP_VEC
@ VX_ROLL_CTRL_UP_VEC
constraint an axis of component to align with the specified vector
Definition: zwapi_cmd_assembly_data.h:271
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMoveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMoveType

enum evxAsmMoveType

#include <zwapi_cmd_assembly_data.h>

assembly move method

Enumerator
VX_ASM_MOVE_PNT | point to point option
VX_ASM_MOVE_ALONG_DIR | along direction option
VX_ASM_MOVE_ALIGN | align frames option
VX_ASM_MOVE_SWEEP | sweep option
VX_ASM_MOVE_AROUND_DIR | around direction option
VX_ASM_MOVE_DYNAMIC | dynamic move option

Definition at line 454 of file zwapi_cmd_assembly_data.h.

455 {
456 VX_ASM_MOVE_PNT = 1,
457 VX_ASM_MOVE_ALONG_DIR,
458 VX_ASM_MOVE_ALIGN,
459 VX_ASM_MOVE_SWEEP,
460 VX_ASM_MOVE_AROUND_DIR,
461 VX_ASM_MOVE_DYNAMIC,
462 } evxAsmMoveType;
evxAsmMoveType
evxAsmMoveType
assembly move method
Definition: zwapi_cmd_assembly_data.h:455
VX_ASM_MOVE_SWEEP
@ VX_ASM_MOVE_SWEEP
sweep option
Definition: zwapi_cmd_assembly_data.h:459
VX_ASM_MOVE_DYNAMIC
@ VX_ASM_MOVE_DYNAMIC
dynamic move option
Definition: zwapi_cmd_assembly_data.h:461
VX_ASM_MOVE_PNT
@ VX_ASM_MOVE_PNT
point to point option
Definition: zwapi_cmd_assembly_data.h:456
VX_ASM_MOVE_ALIGN
@ VX_ASM_MOVE_ALIGN
align frames option
Definition: zwapi_cmd_assembly_data.h:458
VX_ASM_MOVE_AROUND_DIR
@ VX_ASM_MOVE_AROUND_DIR
around direction option
Definition: zwapi_cmd_assembly_data.h:460
VX_ASM_MOVE_ALONG_DIR
@ VX_ASM_MOVE_ALONG_DIR
along direction option
Definition: zwapi_cmd_assembly_data.h:457
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPtnBnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPtnBnd

enum evxAsmPtnBnd

#include <zwapi_cmd_assembly_data.h>

assembly pattern boundary method

Enumerator
VX_ASM_PTN_BND_AUTO | move option
VX_ASM_PTN_BND_PALCE | in palce option
VX_ASM_PTN_BND_MOVE | move option

Definition at line 443 of file zwapi_cmd_assembly_data.h.

444 {
445 VX_ASM_PTN_BND_AUTO,
446 VX_ASM_PTN_BND_PALCE,
447 VX_ASM_PTN_BND_MOVE,
448 } evxAsmPtnBnd;
evxAsmPtnBnd
evxAsmPtnBnd
assembly pattern boundary method
Definition: zwapi_cmd_assembly_data.h:444
VX_ASM_PTN_BND_PALCE
@ VX_ASM_PTN_BND_PALCE
in palce option
Definition: zwapi_cmd_assembly_data.h:446
VX_ASM_PTN_BND_AUTO
@ VX_ASM_PTN_BND_AUTO
move option
Definition: zwapi_cmd_assembly_data.h:445
VX_ASM_PTN_BND_MOVE
@ VX_ASM_PTN_BND_MOVE
move option
Definition: zwapi_cmd_assembly_data.h:447
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmFlltFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmFlltFace

enum evxAsmFlltFace

#include <zwapi_cmd_assembly_data.h>

assembly fillet fillet face method

Enumerator
VX_ASM_FLLT_FACE_MAX | maximal option
VX_ASM_FLLT_FACE_MIN | minimal option
VX_ASM_FLLT_FACE_MATCH | tangent match option

Definition at line 572 of file zwapi_cmd_assembly_data.h.

573 {
574 VX_ASM_FLLT_FACE_MAX,
575 VX_ASM_FLLT_FACE_MIN,
576 VX_ASM_FLLT_FACE_MATCH,
577 } evxAsmFlltFace;
evxAsmFlltFace
evxAsmFlltFace
assembly fillet fillet face method
Definition: zwapi_cmd_assembly_data.h:573
VX_ASM_FLLT_FACE_MIN
@ VX_ASM_FLLT_FACE_MIN
minimal option
Definition: zwapi_cmd_assembly_data.h:575
VX_ASM_FLLT_FACE_MAX
@ VX_ASM_FLLT_FACE_MAX
maximal option
Definition: zwapi_cmd_assembly_data.h:574
VX_ASM_FLLT_FACE_MATCH
@ VX_ASM_FLLT_FACE_MATCH
tangent match option
Definition: zwapi_cmd_assembly_data.h:576
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmFlltLoop

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmFlltLoop

enum evxAsmFlltLoop

#include <zwapi_cmd_assembly_data.h>

assembly fillet loop method

Enumerator
VX_ASM_FLLT_LOOP_IN | inner option
VX_ASM_FLLT_LOOP_OUT | outer option
VX_ASM_FLLT_LOOP_SHARE | shared option
VX_ASM_FLLT_LOOP_BOUND | boundary option
VX_ASM_FLLT_LOOP_ALL | all option
VX_ASM_FLLT_LOOP_SELECT | selected option

Definition at line 583 of file zwapi_cmd_assembly_data.h.

584 {
585 VX_ASM_FLLT_LOOP_IN,
586 VX_ASM_FLLT_LOOP_OUT,
587 VX_ASM_FLLT_LOOP_SHARE,
588 VX_ASM_FLLT_LOOP_BOUND,
589 VX_ASM_FLLT_LOOP_ALL,
590 VX_ASM_FLLT_LOOP_SELECT,
591 } evxAsmFlltLoop;
evxAsmFlltLoop
evxAsmFlltLoop
assembly fillet loop method
Definition: zwapi_cmd_assembly_data.h:584
VX_ASM_FLLT_LOOP_IN
@ VX_ASM_FLLT_LOOP_IN
inner option
Definition: zwapi_cmd_assembly_data.h:585
VX_ASM_FLLT_LOOP_SELECT
@ VX_ASM_FLLT_LOOP_SELECT
selected option
Definition: zwapi_cmd_assembly_data.h:590
VX_ASM_FLLT_LOOP_BOUND
@ VX_ASM_FLLT_LOOP_BOUND
boundary option
Definition: zwapi_cmd_assembly_data.h:588
VX_ASM_FLLT_LOOP_ALL
@ VX_ASM_FLLT_LOOP_ALL
all option
Definition: zwapi_cmd_assembly_data.h:589
VX_ASM_FLLT_LOOP_SHARE
@ VX_ASM_FLLT_LOOP_SHARE
shared option
Definition: zwapi_cmd_assembly_data.h:587
VX_ASM_FLLT_LOOP_OUT
@ VX_ASM_FLLT_LOOP_OUT
outer option
Definition: zwapi_cmd_assembly_data.h:586
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMirrorCategory

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMirrorCategory

enum evxAsmMirrorCategory

#include <zwapi_cmd_assembly_data.h>

assembly mirror category method

Enumerator
VX_ASM_MIRROR_CAT_COPY | copy option
VX_ASM_MIRROR_CAT_DUP | duplicate option
VX_ASM_MIRROR_CAT_DEL | delete option

Definition at line 539 of file zwapi_cmd_assembly_data.h.

540 {
541 VX_ASM_MIRROR_CAT_COPY,
542 VX_ASM_MIRROR_CAT_DUP,
543 VX_ASM_MIRROR_CAT_DEL,
544 } evxAsmMirrorCategory;
evxAsmMirrorCategory
evxAsmMirrorCategory
assembly mirror category method
Definition: zwapi_cmd_assembly_data.h:540
VX_ASM_MIRROR_CAT_DUP
@ VX_ASM_MIRROR_CAT_DUP
duplicate option
Definition: zwapi_cmd_assembly_data.h:542
VX_ASM_MIRROR_CAT_DEL
@ VX_ASM_MIRROR_CAT_DEL
delete option
Definition: zwapi_cmd_assembly_data.h:543
VX_ASM_MIRROR_CAT_COPY
@ VX_ASM_MIRROR_CAT_COPY
copy option
Definition: zwapi_cmd_assembly_data.h:541
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPatternType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPatternType

enum evxAsmPatternType

#include <zwapi_cmd_assembly_data.h>

assembly pattern method

Enumerator
VX_ASM_PTN_LINEAR | linear option
VX_ASM_PTN_CIRCULAR | circular option
VX_ASM_PTN_POINT | piont to point option
VX_ASM_PTN_PATTERN | at pattern option
VX_ASM_PTN_CRV | at curves option
VX_ASM_PTN_FACE | at face option

Definition at line 386 of file zwapi_cmd_assembly_data.h.

387 {
388 VX_ASM_PTN_LINEAR,
389 VX_ASM_PTN_CIRCULAR,
390 VX_ASM_PTN_POINT,
391 VX_ASM_PTN_PATTERN,
392 VX_ASM_PTN_CRV,
393 VX_ASM_PTN_FACE,
394 } evxAsmPatternType;
evxAsmPatternType
evxAsmPatternType
assembly pattern method
Definition: zwapi_cmd_assembly_data.h:387
VX_ASM_PTN_PATTERN
@ VX_ASM_PTN_PATTERN
at pattern option
Definition: zwapi_cmd_assembly_data.h:391
VX_ASM_PTN_CIRCULAR
@ VX_ASM_PTN_CIRCULAR
circular option
Definition: zwapi_cmd_assembly_data.h:389
VX_ASM_PTN_LINEAR
@ VX_ASM_PTN_LINEAR
linear option
Definition: zwapi_cmd_assembly_data.h:388
VX_ASM_PTN_POINT
@ VX_ASM_PTN_POINT
piont to point option
Definition: zwapi_cmd_assembly_data.h:390
VX_ASM_PTN_CRV
@ VX_ASM_PTN_CRV
at curves option
Definition: zwapi_cmd_assembly_data.h:392
VX_ASM_PTN_FACE
@ VX_ASM_PTN_FACE
at face option
Definition: zwapi_cmd_assembly_data.h:393
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmChmfType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmChmfType

enum evxAsmChmfType

#include <zwapi_cmd_assembly_data.h>

assembly chamfer method

Enumerator
VX_ASM_CHMF_EDGE | edge chamfer type
VX_ASM_CHMF_VERTEX | vertex chamfer type

Definition at line 597 of file zwapi_cmd_assembly_data.h.

598 {
599 VX_ASM_CHMF_EDGE,
600 VX_ASM_CHMF_VERTEX = 2,
601 } evxAsmChmfType;
evxAsmChmfType
evxAsmChmfType
assembly chamfer method
Definition: zwapi_cmd_assembly_data.h:598
VX_ASM_CHMF_VERTEX
@ VX_ASM_CHMF_VERTEX
vertex chamfer type
Definition: zwapi_cmd_assembly_data.h:600
VX_ASM_CHMF_EDGE
@ VX_ASM_CHMF_EDGE
edge chamfer type
Definition: zwapi_cmd_assembly_data.h:599
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxConsType

enum evxConsType

#include <zwapi_cmd_assembly_data.h>

assembly constraint type

Enumerator
VX_CONCENTRIC | Concentric constraint.
VX_COINCIDENT | Coincident constraint.
VX_TANGENT | Tangent constraint.
VX_PARALLEL | Parallel constraint.
VX_PERPENDICULAR | Perpendicular constraint.
VX_AT_DISTANCE | Distance constraint.
VX_AT_ANGLE_FULL | At angle constraint.
VX_GEAR | Gear constraint.
VX_SYMMETRIC | Symmetry constraint.
VX_ADV_LOCKED | Lock constraint.
VX_ADV_MIDDLE | Middle constraint.
VX_ADV_FRAME | Frame constraint.
VX_ADV_PATH | Path constraint.
VX_MC_LINEAR_COUPLER | Linear couple constraint.
VX_MC_RACK_PINION | Rack and pinion constraint.
VX_MC_SCREW | Screw constraint.
VX_MC_SLOT | Slot constraint.
VX_MC_CAM | Cam constraint.
VX_MC_UNIV_JOINT | universal joint constraint

Definition at line 192 of file zwapi_cmd_assembly_data.h.

193 {
194 VX_NONE = 0x00000L,
195 VX_CONCENTRIC = 0x00001L,
196 VX_COINCIDENT = 0x00002L,
197 VX_TANGENT = 0x00004L,
198 VX_PARALLEL = 0x00008L,
199 VX_PERPENDICULAR = 0x00010L,
200 VX_AT_DISTANCE = 0x00040L,
201 VX_AT_ANGLE_FULL = 0x00080L,
202 VX_GEAR = 0x00100L,
203 VX_SYMMETRIC = 0x00200L,
204 VX_ADV_LOCKED = 0x00400L,
205 VX_ADV_MIDDLE = 0x00800L,
206 VX_ADV_FRAME = 0x01000L,
207 VX_ADV_PATH = 0x02000L,
208 VX_MC_LINEAR_COUPLER = 0x04000L,
209 VX_MC_RACK_PINION = 0x08000L,
210 VX_MC_SCREW = 0x10000L,
211 VX_MC_SLOT = 0x2000000L,
212 VX_MC_CAM = 0x4000000L,
213 VX_MC_UNIV_JOINT = 0x00104L,
214 } evxConsType;
evxConsType
evxConsType
assembly constraint type
Definition: zwapi_cmd_assembly_data.h:193
VX_PARALLEL
@ VX_PARALLEL
Parallel constraint.
Definition: zwapi_cmd_assembly_data.h:198
VX_MC_SLOT
@ VX_MC_SLOT
Slot constraint.
Definition: zwapi_cmd_assembly_data.h:211
VX_COINCIDENT
@ VX_COINCIDENT
Coincident constraint.
Definition: zwapi_cmd_assembly_data.h:196
VX_MC_CAM
@ VX_MC_CAM
Cam constraint.
Definition: zwapi_cmd_assembly_data.h:212
VX_TANGENT
@ VX_TANGENT
Tangent constraint.
Definition: zwapi_cmd_assembly_data.h:197
VX_CONCENTRIC
@ VX_CONCENTRIC
Concentric constraint.
Definition: zwapi_cmd_assembly_data.h:195
VX_AT_DISTANCE
@ VX_AT_DISTANCE
Distance constraint.
Definition: zwapi_cmd_assembly_data.h:200
VX_MC_UNIV_JOINT
@ VX_MC_UNIV_JOINT
universal joint constraint
Definition: zwapi_cmd_assembly_data.h:213
VX_ADV_LOCKED
@ VX_ADV_LOCKED
Lock constraint.
Definition: zwapi_cmd_assembly_data.h:204
VX_AT_ANGLE_FULL
@ VX_AT_ANGLE_FULL
At angle constraint.
Definition: zwapi_cmd_assembly_data.h:201
VX_SYMMETRIC
@ VX_SYMMETRIC
Symmetry constraint.
Definition: zwapi_cmd_assembly_data.h:203
VX_GEAR
@ VX_GEAR
Gear constraint.
Definition: zwapi_cmd_assembly_data.h:202
VX_ADV_MIDDLE
@ VX_ADV_MIDDLE
Middle constraint.
Definition: zwapi_cmd_assembly_data.h:205
VX_MC_RACK_PINION
@ VX_MC_RACK_PINION
Rack and pinion constraint.
Definition: zwapi_cmd_assembly_data.h:209
VX_MC_LINEAR_COUPLER
@ VX_MC_LINEAR_COUPLER
Linear couple constraint.
Definition: zwapi_cmd_assembly_data.h:208
VX_PERPENDICULAR
@ VX_PERPENDICULAR
Perpendicular constraint.
Definition: zwapi_cmd_assembly_data.h:199
VX_ADV_FRAME
@ VX_ADV_FRAME
Frame constraint.
Definition: zwapi_cmd_assembly_data.h:206
VX_MC_SCREW
@ VX_MC_SCREW
Screw constraint.
Definition: zwapi_cmd_assembly_data.h:210
VX_ADV_PATH
@ VX_ADV_PATH
Path constraint.
Definition: zwapi_cmd_assembly_data.h:207
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMirrorType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMirrorType

enum evxAsmMirrorType

#include <zwapi_cmd_assembly_data.h>

assembly mirror method

Enumerator
VX_ASM_MIRROR_COPY | copy option
VX_ASM_MIRROR_DUP | duplicate option

Definition at line 501 of file zwapi_cmd_assembly_data.h.

502 {
503 VX_ASM_MIRROR_COPY,
504 VX_ASM_MIRROR_DUP,
505 } evxAsmMirrorType;
evxAsmMirrorType
evxAsmMirrorType
assembly mirror method
Definition: zwapi_cmd_assembly_data.h:502
VX_ASM_MIRROR_COPY
@ VX_ASM_MIRROR_COPY
copy option
Definition: zwapi_cmd_assembly_data.h:503
VX_ASM_MIRROR_DUP
@ VX_ASM_MIRROR_DUP
duplicate option
Definition: zwapi_cmd_assembly_data.h:504
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxPathConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxPathConsType

enum evxPathConsType

#include <zwapi_cmd_assembly_data.h>

path constraint type

Enumerator
VX_PATH_CONS_FREE | component can move along the path
VX_PATH_CONS_DISTANCE | constraint component to a specified distance from the end of the path
VX_PATH_CONS_PERCENT | constraint component to a distance specified by a percentage from the end of the path
Examples
part\asmConsTest.cpp.

Definition at line 247 of file zwapi_cmd_assembly_data.h.

248 {
249 VX_PATH_CONS_FREE = 0,
250 VX_PATH_CONS_DISTANCE = 1,
251 VX_PATH_CONS_PERCENT = 2,
252 } evxPathConsType;
evxPathConsType
evxPathConsType
path constraint type
Definition: zwapi_cmd_assembly_data.h:248
VX_PATH_CONS_DISTANCE
@ VX_PATH_CONS_DISTANCE
constraint component to a specified distance from the end of the path
Definition: zwapi_cmd_assembly_data.h:250
VX_PATH_CONS_PERCENT
@ VX_PATH_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of the path
Definition: zwapi_cmd_assembly_data.h:251
VX_PATH_CONS_FREE
@ VX_PATH_CONS_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:249
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMoveFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMoveFrame

enum evxAsmMoveFrame

#include <zwapi_cmd_assembly_data.h>

assembly move frame method

Enumerator
VX_ASM_MOVE_FRAME_NTR | natural option
VX_ASM_MOVE_FRAME_PATH | at path option
VX_ASM_MOVE_FRAME_SLC | selected option

Definition at line 468 of file zwapi_cmd_assembly_data.h.

469 {
470 VX_ASM_MOVE_FRAME_NTR,
471 VX_ASM_MOVE_FRAME_PATH,
472 VX_ASM_MOVE_FRAME_SLC,
473 } evxAsmMoveFrame;
evxAsmMoveFrame
evxAsmMoveFrame
assembly move frame method
Definition: zwapi_cmd_assembly_data.h:469
VX_ASM_MOVE_FRAME_PATH
@ VX_ASM_MOVE_FRAME_PATH
at path option
Definition: zwapi_cmd_assembly_data.h:471
VX_ASM_MOVE_FRAME_NTR
@ VX_ASM_MOVE_FRAME_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:470
VX_ASM_MOVE_FRAME_SLC
@ VX_ASM_MOVE_FRAME_SLC
selected option
Definition: zwapi_cmd_assembly_data.h:472
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxConsState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxConsState

enum evxConsState

#include <zwapi_cmd_assembly_data.h>

constraint state of component

Enumerator
VX_UNKNOWN | unknown
VX_UN_CONSTRAINED | the component is not constrained
VX_UNDER_CONSTRAINED | the component can still move
VX_WELL_CONSTRAINED | the component is completely and correctly constrained
VX_FIXED | the component is fixed and will not move
VX_OVER_CONSTRAINED | the component has conflicting or redundant constraints

Definition at line 368 of file zwapi_cmd_assembly_data.h.

369 {
370 VX_UNKNOWN,
371 VX_UN_CONSTRAINED,
372 VX_UNDER_CONSTRAINED,
373 VX_WELL_CONSTRAINED,
374 VX_FIXED,
375 VX_OVER_CONSTRAINED,
376 } evxConsState;
evxConsState
evxConsState
constraint state of component
Definition: zwapi_cmd_assembly_data.h:369
VX_UN_CONSTRAINED
@ VX_UN_CONSTRAINED
the component is not constrained
Definition: zwapi_cmd_assembly_data.h:371
VX_UNDER_CONSTRAINED
@ VX_UNDER_CONSTRAINED
the component can still move
Definition: zwapi_cmd_assembly_data.h:372
VX_OVER_CONSTRAINED
@ VX_OVER_CONSTRAINED
the component has conflicting or redundant constraints
Definition: zwapi_cmd_assembly_data.h:375
VX_FIXED
@ VX_FIXED
the component is fixed and will not move
Definition: zwapi_cmd_assembly_data.h:374
VX_UNKNOWN
@ VX_UNKNOWN
unknown
Definition: zwapi_cmd_assembly_data.h:370
VX_WELL_CONSTRAINED
@ VX_WELL_CONSTRAINED
the component is completely and correctly constrained
Definition: zwapi_cmd_assembly_data.h:373
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmFlltBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmFlltBase

enum evxAsmFlltBase

#include <zwapi_cmd_assembly_data.h>

assembly fillet base faces method

Enumerator
VX_ASM_FLLT_BASE_NO | no action option
VX_ASM_FLLT_BASE_DIV | divide option
VX_ASM_FLLT_BASE_TRIM | trim option
VX_ASM_FLLT_BASE_SEW | sew option

Definition at line 560 of file zwapi_cmd_assembly_data.h.

561 {
562 VX_ASM_FLLT_BASE_NO,
563 VX_ASM_FLLT_BASE_DIV,
564 VX_ASM_FLLT_BASE_TRIM,
565 VX_ASM_FLLT_BASE_SEW,
566 } evxAsmFlltBase;
evxAsmFlltBase
evxAsmFlltBase
assembly fillet base faces method
Definition: zwapi_cmd_assembly_data.h:561
VX_ASM_FLLT_BASE_DIV
@ VX_ASM_FLLT_BASE_DIV
divide option
Definition: zwapi_cmd_assembly_data.h:563
VX_ASM_FLLT_BASE_TRIM
@ VX_ASM_FLLT_BASE_TRIM
trim option
Definition: zwapi_cmd_assembly_data.h:564
VX_ASM_FLLT_BASE_NO
@ VX_ASM_FLLT_BASE_NO
no action option
Definition: zwapi_cmd_assembly_data.h:562
VX_ASM_FLLT_BASE_SEW
@ VX_ASM_FLLT_BASE_SEW
sew option
Definition: zwapi_cmd_assembly_data.h:565
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMoveZSpine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMoveZSpine

enum evxAsmMoveZSpine

#include <zwapi_cmd_assembly_data.h>

assembly move z-spine method

Enumerator
VX_ASM_MOVE_Z_NTR | natural option
VX_ASM_MOVE_Z_SPINE | spine option
VX_ASM_MOVE_Z_PARALLEL | paallel option

Definition at line 479 of file zwapi_cmd_assembly_data.h.

480 {
481 VX_ASM_MOVE_Z_NTR,
482 VX_ASM_MOVE_Z_SPINE,
483 VX_ASM_MOVE_Z_PARALLEL,
484 } evxAsmMoveZSpine;
evxAsmMoveZSpine
evxAsmMoveZSpine
assembly move z-spine method
Definition: zwapi_cmd_assembly_data.h:480
VX_ASM_MOVE_Z_PARALLEL
@ VX_ASM_MOVE_Z_PARALLEL
paallel option
Definition: zwapi_cmd_assembly_data.h:483
VX_ASM_MOVE_Z_NTR
@ VX_ASM_MOVE_Z_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:481
VX_ASM_MOVE_Z_SPINE
@ VX_ASM_MOVE_Z_SPINE
spine option
Definition: zwapi_cmd_assembly_data.h:482
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmPtnAlg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmPtnAlg

enum evxAsmPtnAlg

#include <zwapi_cmd_assembly_data.h>

assembly pattern alignment method

Enumerator
VX_ASM_PTN_ALG_BASE | align with base option
VX_ASM_PTN_ALG_PTN | align with pattern option

Definition at line 421 of file zwapi_cmd_assembly_data.h.

422 {
423 VX_ASM_PTN_ALG_BASE,
424 VX_ASM_PTN_ALG_PTN,
425 } evxAsmPtnAlg;
evxAsmPtnAlg
evxAsmPtnAlg
assembly pattern alignment method
Definition: zwapi_cmd_assembly_data.h:422
VX_ASM_PTN_ALG_BASE
@ VX_ASM_PTN_ALG_BASE
align with base option
Definition: zwapi_cmd_assembly_data.h:423
VX_ASM_PTN_ALG_PTN
@ VX_ASM_PTN_ALG_PTN
align with pattern option
Definition: zwapi_cmd_assembly_data.h:424
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxPitchYawType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxPitchYawType

enum evxPitchYawType

#include <zwapi_cmd_assembly_data.h>

pitch/yaw type

Enumerator
VX_PITCH_YAW_FREE | component can move along the path
VX_PITCH_YAW_FOLLOW_PATH | constraint an axis of component to be tangent to the path
Examples
part\asmConsTest.cpp.

Definition at line 258 of file zwapi_cmd_assembly_data.h.

259 {
260 VX_PITCH_YAW_FREE = 0,
261 VX_PITCH_YAW_FOLLOW_PATH = 1,
262 } evxPitchYawType;
evxPitchYawType
evxPitchYawType
pitch/yaw type
Definition: zwapi_cmd_assembly_data.h:259
VX_PITCH_YAW_FOLLOW_PATH
@ VX_PITCH_YAW_FOLLOW_PATH
constraint an axis of component to be tangent to the path
Definition: zwapi_cmd_assembly_data.h:261
VX_PITCH_YAW_FREE
@ VX_PITCH_YAW_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:260
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmChmfBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmChmfBase

enum evxAsmChmfBase

#include <zwapi_cmd_assembly_data.h>

assembly chamfer base faces method

Enumerator
VX_ASM_CHMF_BASE_NO | no action option
VX_ASM_CHMF_BASE_DIV | divide option
VX_ASM_CHMF_BASE_TRIM | trim option
VX_ASM_CHMF_BASE_SEW | sew option

Definition at line 607 of file zwapi_cmd_assembly_data.h.

608 {
609 VX_ASM_CHMF_BASE_NO,
610 VX_ASM_CHMF_BASE_DIV,
611 VX_ASM_CHMF_BASE_TRIM,
612 VX_ASM_CHMF_BASE_SEW,
613 } evxAsmChmfBase;
evxAsmChmfBase
evxAsmChmfBase
assembly chamfer base faces method
Definition: zwapi_cmd_assembly_data.h:608
VX_ASM_CHMF_BASE_NO
@ VX_ASM_CHMF_BASE_NO
no action option
Definition: zwapi_cmd_assembly_data.h:609
VX_ASM_CHMF_BASE_SEW
@ VX_ASM_CHMF_BASE_SEW
sew option
Definition: zwapi_cmd_assembly_data.h:612
VX_ASM_CHMF_BASE_DIV
@ VX_ASM_CHMF_BASE_DIV
divide option
Definition: zwapi_cmd_assembly_data.h:610
VX_ASM_CHMF_BASE_TRIM
@ VX_ASM_CHMF_BASE_TRIM
trim option
Definition: zwapi_cmd_assembly_data.h:611
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAsmMirrorCenter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Assembly Commands Data
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ evxAsmMirrorCenter

enum evxAsmMirrorCenter

#include <zwapi_cmd_assembly_data.h>

assembly mirror center method

Enumerator
VX_ASM_MIRROR_CTR_BOX | bounding box option
VX_ASM_MIRROR_CTR_MASS | mass option
VX_ASM_MIRROR_CTR_FRAME | frame option

Definition at line 528 of file zwapi_cmd_assembly_data.h.

529 {
530 VX_ASM_MIRROR_CTR_BOX,
531 VX_ASM_MIRROR_CTR_MASS,
532 VX_ASM_MIRROR_CTR_FRAME,
533 } evxAsmMirrorCenter;
evxAsmMirrorCenter
evxAsmMirrorCenter
assembly mirror center method
Definition: zwapi_cmd_assembly_data.h:529
VX_ASM_MIRROR_CTR_MASS
@ VX_ASM_MIRROR_CTR_MASS
mass option
Definition: zwapi_cmd_assembly_data.h:531
VX_ASM_MIRROR_CTR_BOX
@ VX_ASM_MIRROR_CTR_BOX
bounding box option
Definition: zwapi_cmd_assembly_data.h:530
VX_ASM_MIRROR_CTR_FRAME
@ VX_ASM_MIRROR_CTR_FRAME
frame option
Definition: zwapi_cmd_assembly_data.h:532
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxFldType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command Data
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ evxFldType

enum evxFldType

#include <zwapi_cmd_data.h>

point input data types

Enumerator
VX_FLD_NULL | NULL if error.
VX_FLD_NUM | dimensionless number
VX_FLD_DST | distance (mm)
VX_FLD_ANG | angle (radians)
VX_FLD_PNT | 3D point
VX_FLD_ENT | entity pick
VX_FLD_TXT | text
VX_FLD_DATA | data container (i.e. VDATA)

Definition at line 135 of file zwapi_cmd_data.h.

136 {
137 VX_FLD_NULL = 0,
138 VX_FLD_NUM = 1,
139 VX_FLD_DST = 2,
140 VX_FLD_ANG = 3,
141 VX_FLD_PNT = 4,
142 VX_FLD_ENT = 5,
143 VX_FLD_TXT = 6,
144 VX_FLD_DATA = 7,
145 }evxFldType;
evxFldType
evxFldType
point input data types
Definition: zwapi_cmd_data.h:136
VX_FLD_NULL
@ VX_FLD_NULL
NULL if error.
Definition: zwapi_cmd_data.h:137
VX_FLD_ENT
@ VX_FLD_ENT
entity pick
Definition: zwapi_cmd_data.h:142
VX_FLD_DATA
@ VX_FLD_DATA
data container (i.e. VDATA)
Definition: zwapi_cmd_data.h:144
VX_FLD_TXT
@ VX_FLD_TXT
text
Definition: zwapi_cmd_data.h:143
VX_FLD_ANG
@ VX_FLD_ANG
angle (radians)
Definition: zwapi_cmd_data.h:140
VX_FLD_NUM
@ VX_FLD_NUM
dimensionless number
Definition: zwapi_cmd_data.h:138
VX_FLD_DST
@ VX_FLD_DST
distance (mm)
Definition: zwapi_cmd_data.h:139
VX_FLD_PNT
@ VX_FLD_PNT
3D point
Definition: zwapi_cmd_data.h:141
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmdState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command Data
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ evxCmdState

enum evxCmdState

#include <zwapi_cmd_data.h>

command state type

Enumerator
VX_CMD_ENABLE | command state type: enable
VX_CMD_DISABLE | command state type: disable

Definition at line 60 of file zwapi_cmd_data.h.

61 {
62 VX_CMD_ENABLE = 0,
63 VX_CMD_DISABLE = 1,
64 } evxCmdState;
evxCmdState
evxCmdState
command state type
Definition: zwapi_cmd_data.h:61
VX_CMD_DISABLE
@ VX_CMD_DISABLE
command state type: disable
Definition: zwapi_cmd_data.h:63
VX_CMD_ENABLE
@ VX_CMD_ENABLE
command state type: enable
Definition: zwapi_cmd_data.h:62
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxFldNumType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command Data
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ evxFldNumType

enum evxFldNumType

#include <zwapi_cmd_data.h>

numeric input field type

Enumerator
VX_INP_DOUBLE | double
VX_INP_INTEGER | int
VX_INP_DISTANCE | distance
VX_INP_ANGLE | angle

Definition at line 123 of file zwapi_cmd_data.h.

124 {
125 VX_INP_DOUBLE = 0,
126 VX_INP_INTEGER = 1,
127 VX_INP_DISTANCE = 2,
128 VX_INP_ANGLE = 3
129 } evxFldNumType;
evxFldNumType
evxFldNumType
numeric input field type
Definition: zwapi_cmd_data.h:124
VX_INP_ANGLE
@ VX_INP_ANGLE
angle
Definition: zwapi_cmd_data.h:128
VX_INP_DISTANCE
@ VX_INP_DISTANCE
distance
Definition: zwapi_cmd_data.h:127
VX_INP_DOUBLE
@ VX_INP_DOUBLE
double
Definition: zwapi_cmd_data.h:125
VX_INP_INTEGER
@ VX_INP_INTEGER
int
Definition: zwapi_cmd_data.h:126
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmdType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command Data
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ evxCmdType

enum evxCmdType

#include <zwapi_cmd_data.h>

command types

Enumerator
VX_STANDARD_COMMAND | non-history command
VX_HIST_GENERAL | general-purpose history operation
VX_HIST_SOLID_CREATE | "solid create" history operation
VX_HIST_SOLID_EDIT | "solid edit" history operation
VX_HIST_SURF_CREATE | "surface create" history operation
VX_HIST_SURF_EDIT | "surface edit" history operation
VX_HIST_CRV_CREATE | "curve create" history operation
VX_HIST_CRV_EDIT | "curve edit" history operation
VX_HIST_COMP | "component" history operation
VX_HIST_SKETCH | "sketch" history operation
VX_HIST_DATUM | "datum" history operation
VX_HIST_FILLET | "fillet/chamfer" history operation
VX_HIST_SHELL | "shell" history operation
VX_HIST_SHT_METAL | "sheet metal" history operation
VX_HIST_HOLE | "hole" history operation
VX_HIST_CRV_LIST | "curve list" history operation
VX_HIST_IMPORT | "import" history operation
VX_HIST_REF_GEOM | "reference geometry" history operation
VX_HIST_EQN | "equation" history operation
VX_HIST_HEAL | "heal" history operation
VX_HIST_ERASE | "erase" history operation
VX_HIST_BLANK | "blank/unblank" history operation
VX_HIST_ATTRIBUTE | "attributes" history operation
VX_HIST_RENDER | "rendering" history operation
VX_HIST_ANALYZE | "analyze" history operation
VX_HIST_MOVE | "copy/move/pattern" history operation
VX_HIST_TEXT | "text" history operation
VX_HIST_POINT | "point" history operation
VX_HIST_DRAFT | "draft" history operation
VX_HIST_ASSEMBLY | "assembly" history operation
VX_HIST_TAG | "tag" history operation
VX_HIST_MOLD | "mold design" history operation

Definition at line 80 of file zwapi_cmd_data.h.

81 {
82 VX_STANDARD_COMMAND = -1,
83 VX_HIST_GENERAL = 0,
84 VX_HIST_SOLID_CREATE = 11,
85 VX_HIST_SOLID_EDIT = 12,
86 VX_HIST_SURF_CREATE = 13,
87 VX_HIST_SURF_EDIT = 14,
88 VX_HIST_CRV_CREATE = 15,
89 VX_HIST_CRV_EDIT = 16,
90 VX_HIST_COMP = 17,
91 VX_HIST_SKETCH = 18,
92 VX_HIST_DATUM = 19,
93 VX_HIST_FILLET = 20,
94 VX_HIST_SHELL = 21,
95 VX_HIST_SHT_METAL = 22,
96 VX_HIST_HOLE = 23,
97 VX_HIST_CRV_LIST = 24,
98 VX_HIST_IMPORT = 25,
99 VX_HIST_REF_GEOM = 26,
100 VX_HIST_EQN = 27,
101 VX_HIST_HEAL = 28,
102 VX_HIST_ERASE = 29,
103 VX_HIST_BLANK = 30,
104 VX_HIST_ATTRIBUTE = 33,
105 VX_HIST_RENDER = 34,
106 VX_HIST_ANALYZE = 35,
107 VX_HIST_MOVE = 37,
108 VX_HIST_TEXT = 38,
109 VX_HIST_POINT = 39,
110 VX_HIST_DRAFT = 40,
111 VX_HIST_ASSEMBLY = 41,
112 VX_HIST_TAG = 42,
113 VX_HIST_MOLD = 43
114 } evxCmdType;
evxCmdType
evxCmdType
command types
Definition: zwapi_cmd_data.h:81
VX_HIST_ASSEMBLY
@ VX_HIST_ASSEMBLY
"assembly" history operation
Definition: zwapi_cmd_data.h:111
VX_HIST_REF_GEOM
@ VX_HIST_REF_GEOM
"reference geometry" history operation
Definition: zwapi_cmd_data.h:99
VX_HIST_HOLE
@ VX_HIST_HOLE
"hole" history operation
Definition: zwapi_cmd_data.h:96
VX_HIST_SURF_CREATE
@ VX_HIST_SURF_CREATE
"surface create" history operation
Definition: zwapi_cmd_data.h:86
VX_HIST_MOLD
@ VX_HIST_MOLD
"mold design" history operation
Definition: zwapi_cmd_data.h:113
VX_HIST_CRV_EDIT
@ VX_HIST_CRV_EDIT
"curve edit" history operation
Definition: zwapi_cmd_data.h:89
VX_HIST_DATUM
@ VX_HIST_DATUM
"datum" history operation
Definition: zwapi_cmd_data.h:92
VX_HIST_SKETCH
@ VX_HIST_SKETCH
"sketch" history operation
Definition: zwapi_cmd_data.h:91
VX_HIST_SOLID_CREATE
@ VX_HIST_SOLID_CREATE
"solid create" history operation
Definition: zwapi_cmd_data.h:84
VX_HIST_TAG
@ VX_HIST_TAG
"tag" history operation
Definition: zwapi_cmd_data.h:112
VX_HIST_POINT
@ VX_HIST_POINT
"point" history operation
Definition: zwapi_cmd_data.h:109
VX_HIST_RENDER
@ VX_HIST_RENDER
"rendering" history operation
Definition: zwapi_cmd_data.h:105
VX_HIST_SURF_EDIT
@ VX_HIST_SURF_EDIT
"surface edit" history operation
Definition: zwapi_cmd_data.h:87
VX_HIST_SOLID_EDIT
@ VX_HIST_SOLID_EDIT
"solid edit" history operation
Definition: zwapi_cmd_data.h:85
VX_HIST_EQN
@ VX_HIST_EQN
"equation" history operation
Definition: zwapi_cmd_data.h:100
VX_HIST_DRAFT
@ VX_HIST_DRAFT
"draft" history operation
Definition: zwapi_cmd_data.h:110
VX_HIST_TEXT
@ VX_HIST_TEXT
"text" history operation
Definition: zwapi_cmd_data.h:108
VX_HIST_ANALYZE
@ VX_HIST_ANALYZE
"analyze" history operation
Definition: zwapi_cmd_data.h:106
VX_HIST_ERASE
@ VX_HIST_ERASE
"erase" history operation
Definition: zwapi_cmd_data.h:102
VX_HIST_COMP
@ VX_HIST_COMP
"component" history operation
Definition: zwapi_cmd_data.h:90
VX_STANDARD_COMMAND
@ VX_STANDARD_COMMAND
non-history command
Definition: zwapi_cmd_data.h:82
VX_HIST_CRV_LIST
@ VX_HIST_CRV_LIST
"curve list" history operation
Definition: zwapi_cmd_data.h:97
VX_HIST_FILLET
@ VX_HIST_FILLET
"fillet/chamfer" history operation
Definition: zwapi_cmd_data.h:93
VX_HIST_MOVE
@ VX_HIST_MOVE
"copy/move/pattern" history operation
Definition: zwapi_cmd_data.h:107
VX_HIST_HEAL
@ VX_HIST_HEAL
"heal" history operation
Definition: zwapi_cmd_data.h:101
VX_HIST_BLANK
@ VX_HIST_BLANK
"blank/unblank" history operation
Definition: zwapi_cmd_data.h:103
VX_HIST_IMPORT
@ VX_HIST_IMPORT
"import" history operation
Definition: zwapi_cmd_data.h:98
VX_HIST_GENERAL
@ VX_HIST_GENERAL
general-purpose history operation
Definition: zwapi_cmd_data.h:83
VX_HIST_SHT_METAL
@ VX_HIST_SHT_METAL
"sheet metal" history operation
Definition: zwapi_cmd_data.h:95
VX_HIST_SHELL
@ VX_HIST_SHELL
"shell" history operation
Definition: zwapi_cmd_data.h:94
VX_HIST_ATTRIBUTE
@ VX_HIST_ATTRIBUTE
"attributes" history operation
Definition: zwapi_cmd_data.h:104
VX_HIST_CRV_CREATE
@ VX_HIST_CRV_CREATE
"curve create" history operation
Definition: zwapi_cmd_data.h:88
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCmdAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Command Data
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ evxCmdAction

enum evxCmdAction

#include <zwapi_cmd_data.h>

command action type

Enumerator
VX_CMD_START | called before command start
VX_CMD_FINISHED | called after command finished

Definition at line 50 of file zwapi_cmd_data.h.

51 {
52 VX_CMD_START = 0,
53 VX_CMD_FINISHED,
54 }evxCmdAction;
evxCmdAction
evxCmdAction
command action type
Definition: zwapi_cmd_data.h:51
VX_CMD_FINISHED
@ VX_CMD_FINISHED
called after command finished
Definition: zwapi_cmd_data.h:53
VX_CMD_START
@ VX_CMD_START
called before command start
Definition: zwapi_cmd_data.h:52
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evsResultsAxisMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evsResultsAxisMethod

enum evsResultsAxisMethod

#include <zwapi_cmd_datum_data.h>

Results axis.

Enumerator
VX_RESULTS_AXIS_X | X direction.
VX_RESULTS_AXIS_Y | Y direction.
VX_RESULTS_AXIS_Z | Z direction.

Definition at line 336 of file zwapi_cmd_datum_data.h.

337 {
338 VX_RESULTS_AXIS_X,
339 VX_RESULTS_AXIS_Y,
340 VX_RESULTS_AXIS_Z,
341 } evsResultsAxisMethod;
evsResultsAxisMethod
evsResultsAxisMethod
Results axis.
Definition: zwapi_cmd_datum_data.h:337
VX_RESULTS_AXIS_Y
@ VX_RESULTS_AXIS_Y
Y direction.
Definition: zwapi_cmd_datum_data.h:339
VX_RESULTS_AXIS_X
@ VX_RESULTS_AXIS_X
X direction.
Definition: zwapi_cmd_datum_data.h:338
VX_RESULTS_AXIS_Z
@ VX_RESULTS_AXIS_Z
Z direction.
Definition: zwapi_cmd_datum_data.h:340
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxNewPlaneMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxNewPlaneMethods

enum evxNewPlaneMethods

#include <zwapi_cmd_datum_data.h>

New Plane Methods.

Enumerator
VX_NEW_PLANE_THREE_POINTS | three points
VX_NEW_PLANE_VIEW_PLANE | view plane
VX_NEW_PLANE_DYNAMIC | dynamic
VX_NEW_PLANE_GEOMETRY | geometry
VX_NEW_PLANE_OFFSET_PLANE | offset plane
VX_NEW_PLANE_ANGLE_FACE | angle to face
VX_NEW_PLANE_ON_CURVE | on curve

Definition at line 181 of file zwapi_cmd_datum_data.h.

182 {
183 VX_NEW_PLANE_THREE_POINTS = 1,
184 VX_NEW_PLANE_VIEW_PLANE = 5,
185 VX_NEW_PLANE_DYNAMIC = 7,
186 VX_NEW_PLANE_GEOMETRY = 11,
187 VX_NEW_PLANE_OFFSET_PLANE = 12,
188 VX_NEW_PLANE_ANGLE_FACE = 13,
189 VX_NEW_PLANE_ON_CURVE = 14,
190 }evxNewPlaneMethods;
evxNewPlaneMethods
evxNewPlaneMethods
New Plane Methods.
Definition: zwapi_cmd_datum_data.h:182
VX_NEW_PLANE_VIEW_PLANE
@ VX_NEW_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:184
VX_NEW_PLANE_GEOMETRY
@ VX_NEW_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:186
VX_NEW_PLANE_ON_CURVE
@ VX_NEW_PLANE_ON_CURVE
on curve
Definition: zwapi_cmd_datum_data.h:189
VX_NEW_PLANE_ANGLE_FACE
@ VX_NEW_PLANE_ANGLE_FACE
angle to face
Definition: zwapi_cmd_datum_data.h:188
VX_NEW_PLANE_THREE_POINTS
@ VX_NEW_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:183
VX_NEW_PLANE_OFFSET_PLANE
@ VX_NEW_PLANE_OFFSET_PLANE
offset plane
Definition: zwapi_cmd_datum_data.h:187
VX_NEW_PLANE_DYNAMIC
@ VX_NEW_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:185
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxPlaneAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxPlaneAlign

enum evxPlaneAlign

#include <zwapi_cmd_datum_data.h>

Plane Orientation Align type.

Enumerator
VX_PLANE_ALIGN_TO_XY | align to XY of geometry frame
VX_PLANE_ALIGN_TO_XZ | align to XZ of geometry frame
VX_PLANE_ALIGN_TO_YZ | align to YZ of geometry frame

Definition at line 109 of file zwapi_cmd_datum_data.h.

110 {
111 VX_PLANE_ALIGN_TO_XY = 1,
112 VX_PLANE_ALIGN_TO_XZ = 2,
113 VX_PLANE_ALIGN_TO_YZ = 3,
114 } evxPlaneAlign;
evxPlaneAlign
evxPlaneAlign
Plane Orientation Align type.
Definition: zwapi_cmd_datum_data.h:110
VX_PLANE_ALIGN_TO_XZ
@ VX_PLANE_ALIGN_TO_XZ
align to XZ of geometry frame
Definition: zwapi_cmd_datum_data.h:112
VX_PLANE_ALIGN_TO_YZ
@ VX_PLANE_ALIGN_TO_YZ
align to YZ of geometry frame
Definition: zwapi_cmd_datum_data.h:113
VX_PLANE_ALIGN_TO_XY
@ VX_PLANE_ALIGN_TO_XY
align to XY of geometry frame
Definition: zwapi_cmd_datum_data.h:111
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxPlaneMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxPlaneMethods

enum evxPlaneMethods

#include <zwapi_cmd_datum_data.h>

Plane Methods.

Enumerator
VX_PLANE_GEOMETRY | geometry
VX_PLANE_THREE_POINTS | three points
VX_PLANE_XY | XY Plane.
VX_PLANE_XZ | XZ Plane.
VX_PLANE_YZ | YZ Plane.
VX_PLANE_VIEW_PLANE | view plane
VX_PLANE_TWO_ENTITIES | two entities
VX_PLANE_DYNAMIC | dynamic

Definition at line 93 of file zwapi_cmd_datum_data.h.

94 {
95 VX_PLANE_GEOMETRY = 0,
96 VX_PLANE_THREE_POINTS = 1,
97 VX_PLANE_XY = 2,
98 VX_PLANE_XZ = 3,
99 VX_PLANE_YZ = 4,
100 VX_PLANE_VIEW_PLANE = 5,
101 VX_PLANE_TWO_ENTITIES = 6,
102 VX_PLANE_DYNAMIC = 7,
103 } evxPlaneMethods;
evxPlaneMethods
evxPlaneMethods
Plane Methods.
Definition: zwapi_cmd_datum_data.h:94
VX_PLANE_DYNAMIC
@ VX_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:102
VX_PLANE_XY
@ VX_PLANE_XY
XY Plane.
Definition: zwapi_cmd_datum_data.h:97
VX_PLANE_VIEW_PLANE
@ VX_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:100
VX_PLANE_GEOMETRY
@ VX_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:95
VX_PLANE_YZ
@ VX_PLANE_YZ
YZ Plane.
Definition: zwapi_cmd_datum_data.h:99
VX_PLANE_XZ
@ VX_PLANE_XZ
XZ Plane.
Definition: zwapi_cmd_datum_data.h:98
VX_PLANE_TWO_ENTITIES
@ VX_PLANE_TWO_ENTITIES
two entities
Definition: zwapi_cmd_datum_data.h:101
VX_PLANE_THREE_POINTS
@ VX_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:96
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxOnCrvDirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxOnCrvDirType

enum evxOnCrvDirType

#include <zwapi_cmd_datum_data.h>

Plane direction type.

Enumerator
VX_ONCRV_TANGENT | tangent
VX_ONCRV_PERPENDICULAR | perpendicular
VX_ONCRV_PERPENDICULAR_TO_CURVE | perpendicular to curve
VX_ONCRV_TANGENT_TO_CURVE | tangent to curve

Definition at line 196 of file zwapi_cmd_datum_data.h.

197 {
198 VX_ONCRV_TANGENT,
199 VX_ONCRV_PERPENDICULAR,
200 VX_ONCRV_PERPENDICULAR_TO_CURVE,
201 VX_ONCRV_TANGENT_TO_CURVE,
202 } evxOnCrvDirType;
evxOnCrvDirType
evxOnCrvDirType
Plane direction type.
Definition: zwapi_cmd_datum_data.h:197
VX_ONCRV_TANGENT_TO_CURVE
@ VX_ONCRV_TANGENT_TO_CURVE
tangent to curve
Definition: zwapi_cmd_datum_data.h:201
VX_ONCRV_PERPENDICULAR_TO_CURVE
@ VX_ONCRV_PERPENDICULAR_TO_CURVE
perpendicular to curve
Definition: zwapi_cmd_datum_data.h:200
VX_ONCRV_TANGENT
@ VX_ONCRV_TANGENT
tangent
Definition: zwapi_cmd_datum_data.h:198
VX_ONCRV_PERPENDICULAR
@ VX_ONCRV_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_datum_data.h:199
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxCSYSMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxCSYSMethods

enum evxCSYSMethods

#include <zwapi_cmd_datum_data.h>

CSYS Methods.

Enumerator
VX_CSYS_THREE_POINTS | three points
VX_CSYS_ONLY_MATRIX | only input CSYS matrix
VX_CSYS_DYNAMIC | dynamic
VX_CSYS_THREE_FACES | three faces
VX_CSYS_PNT_AND_TWO_DIR | point and two directions
VX_CSYS_PLANE_PNT_AND_DIR | plane point and direction
VX_CSYS_GEOMETRY | geometry

Definition at line 321 of file zwapi_cmd_datum_data.h.

322 {
323 VX_CSYS_THREE_POINTS = 1,
324 VX_CSYS_ONLY_MATRIX = 6,
325 VX_CSYS_DYNAMIC = 7,
326 VX_CSYS_THREE_FACES = 8,
327 VX_CSYS_PNT_AND_TWO_DIR = 9,
328 VX_CSYS_PLANE_PNT_AND_DIR = 10,
329 VX_CSYS_GEOMETRY = 11,
330 } evxCSYSMethods;
evxCSYSMethods
evxCSYSMethods
CSYS Methods.
Definition: zwapi_cmd_datum_data.h:322
VX_CSYS_THREE_FACES
@ VX_CSYS_THREE_FACES
three faces
Definition: zwapi_cmd_datum_data.h:326
VX_CSYS_GEOMETRY
@ VX_CSYS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:329
VX_CSYS_DYNAMIC
@ VX_CSYS_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:325
VX_CSYS_PLANE_PNT_AND_DIR
@ VX_CSYS_PLANE_PNT_AND_DIR
plane point and direction
Definition: zwapi_cmd_datum_data.h:328
VX_CSYS_ONLY_MATRIX
@ VX_CSYS_ONLY_MATRIX
only input CSYS matrix
Definition: zwapi_cmd_datum_data.h:324
VX_CSYS_PNT_AND_TWO_DIR
@ VX_CSYS_PNT_AND_TWO_DIR
point and two directions
Definition: zwapi_cmd_datum_data.h:327
VX_CSYS_THREE_POINTS
@ VX_CSYS_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:323
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxAxisMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Datum Commands Data
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ evxAxisMethods

enum evxAxisMethods

#include <zwapi_cmd_datum_data.h>

Axis Methods.

Enumerator
VX_AXIS_GEOMETRY | geometry
VX_AXIS_FACE_CENTER | face center axis
VX_AXIS_XX | X Axis.
VX_AXIS_YY | Y Axis.
VX_AXIS_ZZ | Z Axis.
VX_AXIS_TWO_PNT | Two Point.
VX_AXIS_PNT_DIR | point and Direction
VX_AXIS_INTERSECT_FACES | intersect faces

Definition at line 33 of file zwapi_cmd_datum_data.h.

34 {
35 VX_AXIS_GEOMETRY = 0,
36 VX_AXIS_FACE_CENTER = 1,
37 VX_AXIS_XX = 2,
38 VX_AXIS_YY = 3,
39 VX_AXIS_ZZ = 4,
40 VX_AXIS_TWO_PNT = 5,
41 VX_AXIS_PNT_DIR = 6,
42 VX_AXIS_INTERSECT_FACES = 7,
43 } evxAxisMethods;
evxAxisMethods
evxAxisMethods
Axis Methods.
Definition: zwapi_cmd_datum_data.h:34
VX_AXIS_GEOMETRY
@ VX_AXIS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:35
VX_AXIS_INTERSECT_FACES
@ VX_AXIS_INTERSECT_FACES
intersect faces
Definition: zwapi_cmd_datum_data.h:42
VX_AXIS_TWO_PNT
@ VX_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_datum_data.h:40
VX_AXIS_FACE_CENTER
@ VX_AXIS_FACE_CENTER
face center axis
Definition: zwapi_cmd_datum_data.h:36
VX_AXIS_YY
@ VX_AXIS_YY
Y Axis.
Definition: zwapi_cmd_datum_data.h:38
VX_AXIS_PNT_DIR
@ VX_AXIS_PNT_DIR
point and Direction
Definition: zwapi_cmd_datum_data.h:41
VX_AXIS_XX
@ VX_AXIS_XX
X Axis.
Definition: zwapi_cmd_datum_data.h:37
VX_AXIS_ZZ
@ VX_AXIS_ZZ
Z Axis.
Definition: zwapi_cmd_datum_data.h:39
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEPtnBound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEPtnBound

enum evxDEPtnBound

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) pattern boundary method

Enumerator
VX_DE_PTN_BOUND_AUTO | auto
VX_DE_PTN_BOUND_PLACE | in place
VX_DE_PTN_BOUND_MOVE | move

Definition at line 466 of file zwapi_cmd_direct_edit_data.h.

467 {
468 VX_DE_PTN_BOUND_AUTO,
469 VX_DE_PTN_BOUND_PLACE,
470 VX_DE_PTN_BOUND_MOVE,
471 } evxDEPtnBound;
evxDEPtnBound
evxDEPtnBound
part or assembly DE(Direct Edit) pattern boundary method
Definition: zwapi_cmd_direct_edit_data.h:467
VX_DE_PTN_BOUND_PLACE
@ VX_DE_PTN_BOUND_PLACE
in place
Definition: zwapi_cmd_direct_edit_data.h:469
VX_DE_PTN_BOUND_AUTO
@ VX_DE_PTN_BOUND_AUTO
auto
Definition: zwapi_cmd_direct_edit_data.h:468
VX_DE_PTN_BOUND_MOVE
@ VX_DE_PTN_BOUND_MOVE
move
Definition: zwapi_cmd_direct_edit_data.h:470
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEMoveCopyType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEMoveCopyType

enum evxDEMoveCopyType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) move or copy method

Enumerator
VX_DE_MOVE_PNT_TO_PNT | move or copy entities point to point
VX_DE_MOVE_ALONG_DIR | move or copy entities along a dirction
VX_DE_MOVE_FRAME | move or copy entities by aligning frame
VX_DE_MOVE_PATH | move or copy entities along path
VX_DE_MOVE_AROUND_DIR | rotate entities around a dirction
VX_DE_MOVE_DYNAMIC | dynamic move or copy

Definition at line 31 of file zwapi_cmd_direct_edit_data.h.

32 {
33 VX_DE_MOVE_PNT_TO_PNT = 1,
34 VX_DE_MOVE_ALONG_DIR = 2,
35 VX_DE_MOVE_FRAME = 3,
36 VX_DE_MOVE_PATH = 4,
37 VX_DE_MOVE_AROUND_DIR = 5,
38 VX_DE_MOVE_DYNAMIC = 6,
39 } evxDEMoveCopyType;
evxDEMoveCopyType
evxDEMoveCopyType
part or assembly DE(Direct Edit) move or copy method
Definition: zwapi_cmd_direct_edit_data.h:32
VX_DE_MOVE_DYNAMIC
@ VX_DE_MOVE_DYNAMIC
dynamic move or copy
Definition: zwapi_cmd_direct_edit_data.h:38
VX_DE_MOVE_PNT_TO_PNT
@ VX_DE_MOVE_PNT_TO_PNT
move or copy entities point to point
Definition: zwapi_cmd_direct_edit_data.h:33
VX_DE_MOVE_ALONG_DIR
@ VX_DE_MOVE_ALONG_DIR
move or copy entities along a dirction
Definition: zwapi_cmd_direct_edit_data.h:34
VX_DE_MOVE_PATH
@ VX_DE_MOVE_PATH
move or copy entities along path
Definition: zwapi_cmd_direct_edit_data.h:36
VX_DE_MOVE_AROUND_DIR
@ VX_DE_MOVE_AROUND_DIR
rotate entities around a dirction
Definition: zwapi_cmd_direct_edit_data.h:37
VX_DE_MOVE_FRAME
@ VX_DE_MOVE_FRAME
move or copy entities by aligning frame
Definition: zwapi_cmd_direct_edit_data.h:35
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEPtnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEPtnType

enum evxDEPtnType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) pattern method

Enumerator
VX_DE_PTN_LINEAR | linear
VX_DE_PTN_CIRCULAR | circular
VX_DE_PTN_POINT | point to point
VX_DE_PTN_PATTERN | at pattern
VX_DE_PTN_CURVE | at curve
VX_DE_PTN_FACE | at face

Definition at line 429 of file zwapi_cmd_direct_edit_data.h.

430 {
431 VX_DE_PTN_LINEAR,
432 VX_DE_PTN_CIRCULAR,
433 VX_DE_PTN_POINT,
434 VX_DE_PTN_PATTERN,
435 VX_DE_PTN_CURVE,
436 VX_DE_PTN_FACE,
437 } evxDEPtnType;
evxDEPtnType
evxDEPtnType
part or assembly DE(Direct Edit) pattern method
Definition: zwapi_cmd_direct_edit_data.h:430
VX_DE_PTN_CURVE
@ VX_DE_PTN_CURVE
at curve
Definition: zwapi_cmd_direct_edit_data.h:435
VX_DE_PTN_FACE
@ VX_DE_PTN_FACE
at face
Definition: zwapi_cmd_direct_edit_data.h:436
VX_DE_PTN_PATTERN
@ VX_DE_PTN_PATTERN
at pattern
Definition: zwapi_cmd_direct_edit_data.h:434
VX_DE_PTN_LINEAR
@ VX_DE_PTN_LINEAR
linear
Definition: zwapi_cmd_direct_edit_data.h:431
VX_DE_PTN_POINT
@ VX_DE_PTN_POINT
point to point
Definition: zwapi_cmd_direct_edit_data.h:433
VX_DE_PTN_CIRCULAR
@ VX_DE_PTN_CIRCULAR
circular
Definition: zwapi_cmd_direct_edit_data.h:432
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEFaceOverflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEFaceOverflow

enum evxDEFaceOverflow

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) move overflow method

Enumerator
VX_DE_OVERFLOW_AUTO | automatic
VX_DE_OVERFLOW_CHANGE | extend change face
VX_DE_OVERFLOW_STATION | extend stationary face
VX_DE_OVERFLOW_CAP | extend cap face

Definition at line 45 of file zwapi_cmd_direct_edit_data.h.

46 {
47 VX_DE_OVERFLOW_AUTO,
48 VX_DE_OVERFLOW_CHANGE,
49 VX_DE_OVERFLOW_STATION,
50 VX_DE_OVERFLOW_CAP,
51 } evxDEFaceOverflow;
evxDEFaceOverflow
evxDEFaceOverflow
part or assembly DE(Direct Edit) move overflow method
Definition: zwapi_cmd_direct_edit_data.h:46
VX_DE_OVERFLOW_CAP
@ VX_DE_OVERFLOW_CAP
extend cap face
Definition: zwapi_cmd_direct_edit_data.h:50
VX_DE_OVERFLOW_AUTO
@ VX_DE_OVERFLOW_AUTO
automatic
Definition: zwapi_cmd_direct_edit_data.h:47
VX_DE_OVERFLOW_STATION
@ VX_DE_OVERFLOW_STATION
extend stationary face
Definition: zwapi_cmd_direct_edit_data.h:49
VX_DE_OVERFLOW_CHANGE
@ VX_DE_OVERFLOW_CHANGE
extend change face
Definition: zwapi_cmd_direct_edit_data.h:48
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDESideFaceType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDESideFaceType

enum evxDESideFaceType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) side face method

Enumerator
VX_DE_SIDE_FACE_NO_CREATE | do not create
VX_DE_SIDE_FACE_CREATE | create

Definition at line 258 of file zwapi_cmd_direct_edit_data.h.

259 {
260 VX_DE_SIDE_FACE_NO_CREATE,
261 VX_DE_SIDE_FACE_CREATE,
262 } evxDESideFaceType;
evxDESideFaceType
evxDESideFaceType
part or assembly DE(Direct Edit) side face method
Definition: zwapi_cmd_direct_edit_data.h:259
VX_DE_SIDE_FACE_NO_CREATE
@ VX_DE_SIDE_FACE_NO_CREATE
do not create
Definition: zwapi_cmd_direct_edit_data.h:260
VX_DE_SIDE_FACE_CREATE
@ VX_DE_SIDE_FACE_CREATE
create
Definition: zwapi_cmd_direct_edit_data.h:261
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEIsectType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEIsectType

enum evxDEIsectType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) intersection method

Enumerator
VX_DE_ISECT_NO_REMOVE | do not remove
VX_DE_ISECT_REMOVE | remove

Definition at line 268 of file zwapi_cmd_direct_edit_data.h.

269 {
270 VX_DE_ISECT_NO_REMOVE,
271 VX_DE_ISECT_REMOVE,
272 } evxDEIsectType;
evxDEIsectType
evxDEIsectType
part or assembly DE(Direct Edit) intersection method
Definition: zwapi_cmd_direct_edit_data.h:269
VX_DE_ISECT_REMOVE
@ VX_DE_ISECT_REMOVE
remove
Definition: zwapi_cmd_direct_edit_data.h:271
VX_DE_ISECT_NO_REMOVE
@ VX_DE_ISECT_NO_REMOVE
do not remove
Definition: zwapi_cmd_direct_edit_data.h:270
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEMoveCopyFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEMoveCopyFrame

enum evxDEMoveCopyFrame

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) move or copy frame method

Enumerator
VX_DE_MOVE_FRAME_NATURAL | natural
VX_DE_MOVE_FRAME_PATH | at path
VX_DE_MOVE_FRAME_SELECT | selected

Definition at line 57 of file zwapi_cmd_direct_edit_data.h.

58 {
59 VX_DE_MOVE_FRAME_NATURAL,
60 VX_DE_MOVE_FRAME_PATH,
61 VX_DE_MOVE_FRAME_SELECT,
62 } evxDEMoveCopyFrame;
evxDEMoveCopyFrame
evxDEMoveCopyFrame
part or assembly DE(Direct Edit) move or copy frame method
Definition: zwapi_cmd_direct_edit_data.h:58
VX_DE_MOVE_FRAME_PATH
@ VX_DE_MOVE_FRAME_PATH
at path
Definition: zwapi_cmd_direct_edit_data.h:60
VX_DE_MOVE_FRAME_SELECT
@ VX_DE_MOVE_FRAME_SELECT
selected
Definition: zwapi_cmd_direct_edit_data.h:61
VX_DE_MOVE_FRAME_NATURAL
@ VX_DE_MOVE_FRAME_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:59
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEPtnDerive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEPtnDerive

enum evxDEPtnDerive

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) pattern derive method

Enumerator
VX_DE_PTN_DERIVE_NONE | none
VX_DE_PTN_DERIVE_SPACING | spacing
VX_DE_PTN_DERIVE_NUMBER | number

Definition at line 443 of file zwapi_cmd_direct_edit_data.h.

444 {
445 VX_DE_PTN_DERIVE_NONE,
446 VX_DE_PTN_DERIVE_SPACING,
447 VX_DE_PTN_DERIVE_NUMBER,
448 } evxDEPtnDerive;
evxDEPtnDerive
evxDEPtnDerive
part or assembly DE(Direct Edit) pattern derive method
Definition: zwapi_cmd_direct_edit_data.h:444
VX_DE_PTN_DERIVE_SPACING
@ VX_DE_PTN_DERIVE_SPACING
spacing
Definition: zwapi_cmd_direct_edit_data.h:446
VX_DE_PTN_DERIVE_NUMBER
@ VX_DE_PTN_DERIVE_NUMBER
number
Definition: zwapi_cmd_direct_edit_data.h:447
VX_DE_PTN_DERIVE_NONE
@ VX_DE_PTN_DERIVE_NONE
none
Definition: zwapi_cmd_direct_edit_data.h:445
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEPtnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEPtnCrv

enum evxDEPtnCrv

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) pattern at curve method

Enumerator
VX_DE_PTN_CRV1 | one curve
VX_DE_PTN_CRV2_TGT | two curves together
VX_DE_PTN_CRV2_ACR | two curves across
VX_DE_PTN_CRV3 | three or four curves

Definition at line 454 of file zwapi_cmd_direct_edit_data.h.

455 {
456 VX_DE_PTN_CRV1,
457 VX_DE_PTN_CRV2_TGT,
458 VX_DE_PTN_CRV2_ACR,
459 VX_DE_PTN_CRV3,
460 } evxDEPtnCrv;
evxDEPtnCrv
evxDEPtnCrv
part or assembly DE(Direct Edit) pattern at curve method
Definition: zwapi_cmd_direct_edit_data.h:455
VX_DE_PTN_CRV2_ACR
@ VX_DE_PTN_CRV2_ACR
two curves across
Definition: zwapi_cmd_direct_edit_data.h:458
VX_DE_PTN_CRV2_TGT
@ VX_DE_PTN_CRV2_TGT
two curves together
Definition: zwapi_cmd_direct_edit_data.h:457
VX_DE_PTN_CRV3
@ VX_DE_PTN_CRV3
three or four curves
Definition: zwapi_cmd_direct_edit_data.h:459
VX_DE_PTN_CRV1
@ VX_DE_PTN_CRV1
one curve
Definition: zwapi_cmd_direct_edit_data.h:456
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEAlignMoveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEAlignMoveType

enum evxDEAlignMoveType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) align move method

Enumerator
VX_DE_ALIGN_MOVE_COPLANAR | coplanar
VX_DE_ALIGN_MOVE_CONCENTRIC | concentric
VX_DE_ALIGN_MOVE_TANGENT | tangent
VX_DE_ALIGN_MOVE_PARALLEL | parallel
VX_DE_ALIGN_MOVE_PERPENDICULAR | perpendicular
VX_DE_ALIGN_MOVE_ANGLE | at angle
VX_DE_ALIGN_MOVE_SYMMETRY | symmetric

Definition at line 174 of file zwapi_cmd_direct_edit_data.h.

175 {
176 VX_DE_ALIGN_MOVE_COPLANAR = 1,
177 VX_DE_ALIGN_MOVE_CONCENTRIC = 2,
178 VX_DE_ALIGN_MOVE_TANGENT = 3,
179 VX_DE_ALIGN_MOVE_PARALLEL = 4,
180 VX_DE_ALIGN_MOVE_PERPENDICULAR = 5,
181 VX_DE_ALIGN_MOVE_ANGLE = 6,
182 VX_DE_ALIGN_MOVE_SYMMETRY = 7,
183 } evxDEAlignMoveType;
evxDEAlignMoveType
evxDEAlignMoveType
part or assembly DE(Direct Edit) align move method
Definition: zwapi_cmd_direct_edit_data.h:175
VX_DE_ALIGN_MOVE_TANGENT
@ VX_DE_ALIGN_MOVE_TANGENT
tangent
Definition: zwapi_cmd_direct_edit_data.h:178
VX_DE_ALIGN_MOVE_SYMMETRY
@ VX_DE_ALIGN_MOVE_SYMMETRY
symmetric
Definition: zwapi_cmd_direct_edit_data.h:182
VX_DE_ALIGN_MOVE_CONCENTRIC
@ VX_DE_ALIGN_MOVE_CONCENTRIC
concentric
Definition: zwapi_cmd_direct_edit_data.h:177
VX_DE_ALIGN_MOVE_ANGLE
@ VX_DE_ALIGN_MOVE_ANGLE
at angle
Definition: zwapi_cmd_direct_edit_data.h:181
VX_DE_ALIGN_MOVE_PARALLEL
@ VX_DE_ALIGN_MOVE_PARALLEL
parallel
Definition: zwapi_cmd_direct_edit_data.h:179
VX_DE_ALIGN_MOVE_PERPENDICULAR
@ VX_DE_ALIGN_MOVE_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_direct_edit_data.h:180
VX_DE_ALIGN_MOVE_COPLANAR
@ VX_DE_ALIGN_MOVE_COPLANAR
coplanar
Definition: zwapi_cmd_direct_edit_data.h:176
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEMoveCopyXOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEMoveCopyXOrient

enum evxDEMoveCopyXOrient

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) move or copy X-orient method

Enumerator
VX_DE_MOVE_X_NATURAL | natural
VX_DE_MOVE_X_PLANE | guide plane
VX_DE_MOVE_X_CURVE | x-axis curve

Definition at line 79 of file zwapi_cmd_direct_edit_data.h.

80 {
81 VX_DE_MOVE_X_NATURAL,
82 VX_DE_MOVE_X_PLANE,
83 VX_DE_MOVE_X_CURVE,
84 } evxDEMoveCopyXOrient;
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
part or assembly DE(Direct Edit) move or copy X-orient method
Definition: zwapi_cmd_direct_edit_data.h:80
VX_DE_MOVE_X_CURVE
@ VX_DE_MOVE_X_CURVE
x-axis curve
Definition: zwapi_cmd_direct_edit_data.h:83
VX_DE_MOVE_X_PLANE
@ VX_DE_MOVE_X_PLANE
guide plane
Definition: zwapi_cmd_direct_edit_data.h:82
VX_DE_MOVE_X_NATURAL
@ VX_DE_MOVE_X_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:81
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEMoveCopyZSpine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEMoveCopyZSpine

enum evxDEMoveCopyZSpine

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) move or copy Z-spine method

Enumerator
VX_DE_MOVE_Z_NATURAL | natural
VX_DE_MOVE_Z_SPINE | spine
VX_DE_MOVE_Z_PARALLEL | parallel

Definition at line 68 of file zwapi_cmd_direct_edit_data.h.

69 {
70 VX_DE_MOVE_Z_NATURAL,
71 VX_DE_MOVE_Z_SPINE,
72 VX_DE_MOVE_Z_PARALLEL,
73 } evxDEMoveCopyZSpine;
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
part or assembly DE(Direct Edit) move or copy Z-spine method
Definition: zwapi_cmd_direct_edit_data.h:69
VX_DE_MOVE_Z_NATURAL
@ VX_DE_MOVE_Z_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:70
VX_DE_MOVE_Z_SPINE
@ VX_DE_MOVE_Z_SPINE
spine
Definition: zwapi_cmd_direct_edit_data.h:71
VX_DE_MOVE_Z_PARALLEL
@ VX_DE_MOVE_Z_PARALLEL
parallel
Definition: zwapi_cmd_direct_edit_data.h:72
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEDraftSideType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEDraftSideType

enum evxDEDraftSideType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) draft about side method

Enumerator
VX_DE_DRAFT_SIDE_TOP | top
VX_DE_DRAFT_SIDE_BOTTOM | bottom
VX_DE_DRAFT_SIDE_SPILT | split
VX_DE_DRAFT_SIDE_NEUTRAL | neutral

Definition at line 292 of file zwapi_cmd_direct_edit_data.h.

293 {
294 VX_DE_DRAFT_SIDE_TOP,
295 VX_DE_DRAFT_SIDE_BOTTOM,
296 VX_DE_DRAFT_SIDE_SPILT,
297 VX_DE_DRAFT_SIDE_NEUTRAL,
298 } evxDEDraftSideType;
evxDEDraftSideType
evxDEDraftSideType
part or assembly DE(Direct Edit) draft about side method
Definition: zwapi_cmd_direct_edit_data.h:293
VX_DE_DRAFT_SIDE_TOP
@ VX_DE_DRAFT_SIDE_TOP
top
Definition: zwapi_cmd_direct_edit_data.h:294
VX_DE_DRAFT_SIDE_BOTTOM
@ VX_DE_DRAFT_SIDE_BOTTOM
bottom
Definition: zwapi_cmd_direct_edit_data.h:295
VX_DE_DRAFT_SIDE_SPILT
@ VX_DE_DRAFT_SIDE_SPILT
split
Definition: zwapi_cmd_direct_edit_data.h:296
VX_DE_DRAFT_SIDE_NEUTRAL
@ VX_DE_DRAFT_SIDE_NEUTRAL
neutral
Definition: zwapi_cmd_direct_edit_data.h:297
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxDEDimMoveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Direct Edit Commands Data
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ evxDEDimMoveType

enum evxDEDimMoveType

#include <zwapi_cmd_direct_edit_data.h>

part or assembly DE(Direct Edit) dim move method

Enumerator
VX_DE_DIM_LINEAR | linear
VX_DE_DIM_ANGULAR | angular

Definition at line 220 of file zwapi_cmd_direct_edit_data.h.

221 {
222 VX_DE_DIM_LINEAR = 1,
223 VX_DE_DIM_ANGULAR = 2,
224 } evxDEDimMoveType;
evxDEDimMoveType
evxDEDimMoveType
part or assembly DE(Direct Edit) dim move method
Definition: zwapi_cmd_direct_edit_data.h:221
VX_DE_DIM_LINEAR
@ VX_DE_DIM_LINEAR
linear
Definition: zwapi_cmd_direct_edit_data.h:222
VX_DE_DIM_ANGULAR
@ VX_DE_DIM_ANGULAR
angular
Definition: zwapi_cmd_direct_edit_data.h:223
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: evxLocType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxLocType

enum evxLocType

#include <zwapi_cmd_dwg_data.h>

section location

Enumerator
VX_LOC_HORIZONTAL | Location : Horizontal.
VX_LOC_VERTICAL | Location : Vertical.
VX_LOC_ORTHOGONAL | Location : Orthogonal.
VX_LOC_NONE | Location : None.

Definition at line 292 of file zwapi_cmd_dwg_data.h.

293 {
294 VX_LOC_HORIZONTAL = 1,
295 VX_LOC_VERTICAL = 2,
296 VX_LOC_ORTHOGONAL = 3,
297 VX_LOC_NONE = 4,
298 } evxLocType;
evxLocType
evxLocType
section location
Definition: zwapi_cmd_dwg_data.h:293
VX_LOC_HORIZONTAL
@ VX_LOC_HORIZONTAL
Location : Horizontal.
Definition: zwapi_cmd_dwg_data.h:294
VX_LOC_ORTHOGONAL
@ VX_LOC_ORTHOGONAL
Location : Orthogonal.
Definition: zwapi_cmd_dwg_data.h:296
VX_LOC_VERTICAL
@ VX_LOC_VERTICAL
Location : Vertical.
Definition: zwapi_cmd_dwg_data.h:295
VX_LOC_NONE
@ VX_LOC_NONE
Location : None.
Definition: zwapi_cmd_dwg_data.h:297
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgLnrChmDimTexType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgLnrChmDimTexType

enum evxDwgLnrChmDimTexType

#include <zwapi_cmd_dwg_data.h>

text style of leader linear chamfer dim in sheeting

Enumerator
VX_TEXT_NOR_CHAMFERDIM | normal
VX_TEXT_PERPENDICULAR_CHAMFERDIM | always perpendicular
VX_TEXT_ALGMODLIN_CHAMFERDIM | along the model line

Definition at line 843 of file zwapi_cmd_dwg_data.h.

844 {
845 VX_TEXT_NOR_CHAMFERDIM = 0,
846 VX_TEXT_PERPENDICULAR_CHAMFERDIM,
847 VX_TEXT_ALGMODLIN_CHAMFERDIM
848 } evxDwgLnrChmDimTexType;
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
text style of leader linear chamfer dim in sheeting
Definition: zwapi_cmd_dwg_data.h:844
VX_TEXT_PERPENDICULAR_CHAMFERDIM
@ VX_TEXT_PERPENDICULAR_CHAMFERDIM
always perpendicular
Definition: zwapi_cmd_dwg_data.h:846
VX_TEXT_ALGMODLIN_CHAMFERDIM
@ VX_TEXT_ALGMODLIN_CHAMFERDIM
along the model line
Definition: zwapi_cmd_dwg_data.h:847
VX_TEXT_NOR_CHAMFERDIM
@ VX_TEXT_NOR_CHAMFERDIM
normal
Definition: zwapi_cmd_dwg_data.h:845
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgAtBlnPtnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgAtBlnPtnType

enum evxDwgAtBlnPtnType

#include <zwapi_cmd_dwg_data.h>

Pattern type of auto balloon.

Enumerator
VX_ATBLNPAT_CONVEXHULL | convex hull around the layout view
VX_ATBLNPAT_SQUARE | square around the layout view
VX_ATBLNPAT_CIRCULAR | circular around the layout view

Definition at line 1105 of file zwapi_cmd_dwg_data.h.

1106 {
1107 VX_ATBLNPAT_CONVEXHULL = 1,
1108 VX_ATBLNPAT_SQUARE = 2,
1109 VX_ATBLNPAT_CIRCULAR = 3
1110 } evxDwgAtBlnPtnType;
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
Pattern type of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1106
VX_ATBLNPAT_SQUARE
@ VX_ATBLNPAT_SQUARE
square around the layout view
Definition: zwapi_cmd_dwg_data.h:1108
VX_ATBLNPAT_CIRCULAR
@ VX_ATBLNPAT_CIRCULAR
circular around the layout view
Definition: zwapi_cmd_dwg_data.h:1109
VX_ATBLNPAT_CONVEXHULL
@ VX_ATBLNPAT_CONVEXHULL
convex hull around the layout view
Definition: zwapi_cmd_dwg_data.h:1107
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDimLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDimLineType

enum evxDimLineType

#include <zwapi_cmd_dwg_data.h>

dimension Line type

Enumerator
VX_DIM_LINE_LH | horizontal dimension
VX_DIM_LINE_LV | vertical dimension
VX_DIM_LINE_LA | aligned dimension
VX_DIM_LINE_LR | rotated dimension
VX_DIM_LINE_LP | projected dimension
VX_DIM_LINE_LO | ordinate dimension, only used in cvxDwgOrdinateDimAdd(): create a linear ordinate horizontal dimension groups and the linear ordinate vertical dimension groups.

Definition at line 715 of file zwapi_cmd_dwg_data.h.

716 {
717 VX_DIM_LINE_LH = 1,
718 VX_DIM_LINE_LV = 2,
719 VX_DIM_LINE_LA = 3,
720 VX_DIM_LINE_LR = 4,
721 VX_DIM_LINE_LP = 5,
722 VX_DIM_LINE_LO = 6,
725 } evxDimLineType;
evxDimLineType
evxDimLineType
dimension Line type
Definition: zwapi_cmd_dwg_data.h:716
VX_DIM_LINE_LH
@ VX_DIM_LINE_LH
horizontal dimension
Definition: zwapi_cmd_dwg_data.h:717
VX_DIM_LINE_LA
@ VX_DIM_LINE_LA
aligned dimension
Definition: zwapi_cmd_dwg_data.h:719
VX_DIM_LINE_LR
@ VX_DIM_LINE_LR
rotated dimension
Definition: zwapi_cmd_dwg_data.h:720
VX_DIM_LINE_LV
@ VX_DIM_LINE_LV
vertical dimension
Definition: zwapi_cmd_dwg_data.h:718
VX_DIM_LINE_LO
@ VX_DIM_LINE_LO
ordinate dimension, only used in cvxDwgOrdinateDimAdd(): create a linear ordinate horizontal dimensio...
Definition: zwapi_cmd_dwg_data.h:722
VX_DIM_LINE_LP
@ VX_DIM_LINE_LP
projected dimension
Definition: zwapi_cmd_dwg_data.h:721
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDimLineOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDimLineOffset

enum evxDimLineOffset

#include <zwapi_cmd_dwg_data.h>

dimension off type

Enumerator
VX_DIM_OFFSET_LOL | line to line (Offset Method)
VX_DIM_OFFSET_LOP | point to line (Projected Distance Method)

Definition at line 795 of file zwapi_cmd_dwg_data.h.

796 {
797 VX_DIM_OFFSET_LOL = 1,
798 VX_DIM_OFFSET_LOP = 2,
799 } evxDimLineOffset;
evxDimLineOffset
evxDimLineOffset
dimension off type
Definition: zwapi_cmd_dwg_data.h:796
VX_DIM_OFFSET_LOP
@ VX_DIM_OFFSET_LOP
point to line (Projected Distance Method)
Definition: zwapi_cmd_dwg_data.h:798
VX_DIM_OFFSET_LOL
@ VX_DIM_OFFSET_LOL
line to line (Offset Method)
Definition: zwapi_cmd_dwg_data.h:797
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgAtBlnArrg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgAtBlnArrg

enum evxDwgAtBlnArrg

#include <zwapi_cmd_dwg_data.h>

Arrangement of auto balloon.

Enumerator
VX_ATBLNARR_NEAREST | simply located nearest to the component being labeled
VX_ATBLNARR_CW | arranged in clockwise order
VX_ATBLNARR_CCW | arranged in counter - clockwise order

Definition at line 1139 of file zwapi_cmd_dwg_data.h.

1140 {
1141 VX_ATBLNARR_NEAREST = 1,
1142 VX_ATBLNARR_CW = 2,
1143 VX_ATBLNARR_CCW = 3
1144 } evxDwgAtBlnArrg;
evxDwgAtBlnArrg
evxDwgAtBlnArrg
Arrangement of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1140
VX_ATBLNARR_CCW
@ VX_ATBLNARR_CCW
arranged in counter - clockwise order
Definition: zwapi_cmd_dwg_data.h:1143
VX_ATBLNARR_NEAREST
@ VX_ATBLNARR_NEAREST
simply located nearest to the component being labeled
Definition: zwapi_cmd_dwg_data.h:1141
VX_ATBLNARR_CW
@ VX_ATBLNARR_CW
arranged in clockwise order
Definition: zwapi_cmd_dwg_data.h:1142
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgAtBlnInsTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgAtBlnInsTyp

enum evxDwgAtBlnInsTyp

#include <zwapi_cmd_dwg_data.h>

Type of instances in auto balloon.

Enumerator
VX_ATBLNINS_IGNMULINS | ignore multiple instances
VX_ATBLNINS_MULLEAINS | multi-leader for multiple instances
VX_ATBLNINS_EACHINS | one for each instances

Definition at line 1094 of file zwapi_cmd_dwg_data.h.

1095 {
1096 VX_ATBLNINS_IGNMULINS = 0,
1097 VX_ATBLNINS_MULLEAINS = 1,
1098 VX_ATBLNINS_EACHINS = 2
1099 } evxDwgAtBlnInsTyp;
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
Type of instances in auto balloon.
Definition: zwapi_cmd_dwg_data.h:1095
VX_ATBLNINS_MULLEAINS
@ VX_ATBLNINS_MULLEAINS
multi-leader for multiple instances
Definition: zwapi_cmd_dwg_data.h:1097
VX_ATBLNINS_EACHINS
@ VX_ATBLNINS_EACHINS
one for each instances
Definition: zwapi_cmd_dwg_data.h:1098
VX_ATBLNINS_IGNMULINS
@ VX_ATBLNINS_IGNMULINS
ignore multiple instances
Definition: zwapi_cmd_dwg_data.h:1096
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxAutoDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxAutoDimType

enum evxAutoDimType

#include <zwapi_cmd_dwg_data.h>

auto dimension type

Enumerator
DIM_AUTO_BASELINE | baseline
DIM_AUTO_CONTINUOUS | continuous
DIM_AUTO_ORDINATE | ordinate dimension
DIM_AUTO_LABEL_COORDINATE | label ordinate dimension

Definition at line 639 of file zwapi_cmd_dwg_data.h.

640 {
641 DIM_AUTO_BASELINE = 0,
642 DIM_AUTO_CONTINUOUS = 1,
643 DIM_AUTO_ORDINATE = 2,
644 DIM_AUTO_LABEL_COORDINATE = 3,
645 }evxAutoDimType;
evxAutoDimType
evxAutoDimType
auto dimension type
Definition: zwapi_cmd_dwg_data.h:640
DIM_AUTO_LABEL_COORDINATE
@ DIM_AUTO_LABEL_COORDINATE
label ordinate dimension
Definition: zwapi_cmd_dwg_data.h:644
DIM_AUTO_BASELINE
@ DIM_AUTO_BASELINE
baseline
Definition: zwapi_cmd_dwg_data.h:641
DIM_AUTO_CONTINUOUS
@ DIM_AUTO_CONTINUOUS
continuous
Definition: zwapi_cmd_dwg_data.h:642
DIM_AUTO_ORDINATE
@ DIM_AUTO_ORDINATE
ordinate dimension
Definition: zwapi_cmd_dwg_data.h:643
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgAtBlnLeadAttach

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgAtBlnLeadAttach

enum evxDwgAtBlnLeadAttach

#include <zwapi_cmd_dwg_data.h>

Leader attachment of auto balloon.

Enumerator
VX_ATBLNLEAATT_EDAGES | attach to edges
VX_ATBLNLEAATT_FACES | attach to face

Definition at line 1116 of file zwapi_cmd_dwg_data.h.

1117 {
1118 VX_ATBLNLEAATT_EDAGES = 1,
1119 VX_ATBLNLEAATT_FACES = 2
1120 } evxDwgAtBlnLeadAttach;
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
Leader attachment of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1117
VX_ATBLNLEAATT_FACES
@ VX_ATBLNLEAATT_FACES
attach to face
Definition: zwapi_cmd_dwg_data.h:1119
VX_ATBLNLEAATT_EDAGES
@ VX_ATBLNLEAATT_EDAGES
attach to edges
Definition: zwapi_cmd_dwg_data.h:1118
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxWeldFinishSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxWeldFinishSym

enum evxWeldFinishSym

#include <zwapi_cmd_dwg_data.h>

finish symbol of weld symbol

Enumerator
VX_WELD_FINISH_NONE | none
VX_WELD_FINISH_CHIPPING | chipping
VX_WELD_FINISH_GRINDING | grinding
VX_WELD_FINISH_HAMMERING | hammering
VX_WELD_FINISH_MACHINING | machining
VX_WELD_FINISH_ROLLING | rolling
VX_WELD_FINISH_UNSPECIFIED | unspecified

Definition at line 1377 of file zwapi_cmd_dwg_data.h.

1378 {
1379 VX_WELD_FINISH_NONE = 1,
1380 VX_WELD_FINISH_CHIPPING,
1381 VX_WELD_FINISH_GRINDING,
1382 VX_WELD_FINISH_HAMMERING,
1383 VX_WELD_FINISH_MACHINING,
1384 VX_WELD_FINISH_ROLLING,
1385 VX_WELD_FINISH_UNSPECIFIED,
1386 } evxWeldFinishSym;
evxWeldFinishSym
evxWeldFinishSym
finish symbol of weld symbol
Definition: zwapi_cmd_dwg_data.h:1378
VX_WELD_FINISH_CHIPPING
@ VX_WELD_FINISH_CHIPPING
chipping
Definition: zwapi_cmd_dwg_data.h:1380
VX_WELD_FINISH_UNSPECIFIED
@ VX_WELD_FINISH_UNSPECIFIED
unspecified
Definition: zwapi_cmd_dwg_data.h:1385
VX_WELD_FINISH_HAMMERING
@ VX_WELD_FINISH_HAMMERING
hammering
Definition: zwapi_cmd_dwg_data.h:1382
VX_WELD_FINISH_NONE
@ VX_WELD_FINISH_NONE
none
Definition: zwapi_cmd_dwg_data.h:1379
VX_WELD_FINISH_MACHINING
@ VX_WELD_FINISH_MACHINING
machining
Definition: zwapi_cmd_dwg_data.h:1383
VX_WELD_FINISH_GRINDING
@ VX_WELD_FINISH_GRINDING
grinding
Definition: zwapi_cmd_dwg_data.h:1381
VX_WELD_FINISH_ROLLING
@ VX_WELD_FINISH_ROLLING
rolling
Definition: zwapi_cmd_dwg_data.h:1384
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgHoleMarkPtn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgHoleMarkPtn

enum evxDwgHoleMarkPtn

#include <zwapi_cmd_dwg_data.h>

drawing sheet hole mark pattern method

Enumerator
VX_DWG_HOLE_MARK_UP_LEFT_4 | up-left 1/4
VX_DWG_HOLE_MARK_UP_RIGHT_4 | up-right 1/4
VX_DWG_HOLE_MARK_DOWN_LEFT_4 | down-left 1/4
VX_DWG_HOLE_MARK_DOWN_RIGHT_4 | down-right 1/4
VX_DWG_HOLE_MARK_LEFT_BEVEL_4 | left-bevel 1/4
VX_DWG_HOLE_MARK_RIGHT_BEVEL_4 | right-bevel 1/4
VX_DWG_HOLE_MARK_UP_LEFT_12 | up-left 1/12
VX_DWG_HOLE_MARK_UP_RIGHT_12 | up-right 1/12
VX_DWG_HOLE_MARK_DOWN_LEFT_12 | down-left 1/12
VX_DWG_HOLE_MARK_DOWN_RIGHT_12 | down-right 1/12
VX_DWG_HOLE_MARK_LEFT_BEVEL_12 | left-bevel 1/12
VX_DWG_HOLE_MARK_RIGHT_BEVEL_12 | right-bevel 1/12

Definition at line 1546 of file zwapi_cmd_dwg_data.h.

1547 {
1548 VX_DWG_HOLE_MARK_UP_LEFT_4,
1549 VX_DWG_HOLE_MARK_UP_RIGHT_4,
1550 VX_DWG_HOLE_MARK_DOWN_LEFT_4,
1551 VX_DWG_HOLE_MARK_DOWN_RIGHT_4,
1552 VX_DWG_HOLE_MARK_LEFT_BEVEL_4,
1553 VX_DWG_HOLE_MARK_RIGHT_BEVEL_4,
1554 VX_DWG_HOLE_MARK_UP_LEFT_12,
1555 VX_DWG_HOLE_MARK_UP_RIGHT_12,
1556 VX_DWG_HOLE_MARK_DOWN_LEFT_12,
1557 VX_DWG_HOLE_MARK_DOWN_RIGHT_12,
1558 VX_DWG_HOLE_MARK_LEFT_BEVEL_12,
1559 VX_DWG_HOLE_MARK_RIGHT_BEVEL_12,
1560 } evxDwgHoleMarkPtn;
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
drawing sheet hole mark pattern method
Definition: zwapi_cmd_dwg_data.h:1547
VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
@ VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
right-bevel 1/12
Definition: zwapi_cmd_dwg_data.h:1559
VX_DWG_HOLE_MARK_UP_LEFT_4
@ VX_DWG_HOLE_MARK_UP_LEFT_4
up-left 1/4
Definition: zwapi_cmd_dwg_data.h:1548
VX_DWG_HOLE_MARK_DOWN_RIGHT_4
@ VX_DWG_HOLE_MARK_DOWN_RIGHT_4
down-right 1/4
Definition: zwapi_cmd_dwg_data.h:1551
VX_DWG_HOLE_MARK_UP_LEFT_12
@ VX_DWG_HOLE_MARK_UP_LEFT_12
up-left 1/12
Definition: zwapi_cmd_dwg_data.h:1554
VX_DWG_HOLE_MARK_UP_RIGHT_12
@ VX_DWG_HOLE_MARK_UP_RIGHT_12
up-right 1/12
Definition: zwapi_cmd_dwg_data.h:1555
VX_DWG_HOLE_MARK_DOWN_LEFT_4
@ VX_DWG_HOLE_MARK_DOWN_LEFT_4
down-left 1/4
Definition: zwapi_cmd_dwg_data.h:1550
VX_DWG_HOLE_MARK_LEFT_BEVEL_12
@ VX_DWG_HOLE_MARK_LEFT_BEVEL_12
left-bevel 1/12
Definition: zwapi_cmd_dwg_data.h:1558
VX_DWG_HOLE_MARK_UP_RIGHT_4
@ VX_DWG_HOLE_MARK_UP_RIGHT_4
up-right 1/4
Definition: zwapi_cmd_dwg_data.h:1549
VX_DWG_HOLE_MARK_LEFT_BEVEL_4
@ VX_DWG_HOLE_MARK_LEFT_BEVEL_4
left-bevel 1/4
Definition: zwapi_cmd_dwg_data.h:1552
VX_DWG_HOLE_MARK_DOWN_RIGHT_12
@ VX_DWG_HOLE_MARK_DOWN_RIGHT_12
down-right 1/12
Definition: zwapi_cmd_dwg_data.h:1557
VX_DWG_HOLE_MARK_RIGHT_BEVEL_4
@ VX_DWG_HOLE_MARK_RIGHT_BEVEL_4
right-bevel 1/4
Definition: zwapi_cmd_dwg_data.h:1553
VX_DWG_HOLE_MARK_DOWN_LEFT_12
@ VX_DWG_HOLE_MARK_DOWN_LEFT_12
down-left 1/12
Definition: zwapi_cmd_dwg_data.h:1556
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxViewTypeEx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxViewTypeEx

enum evxViewTypeEx

#include <zwapi_cmd_dwg_data.h>

View type, more detailed than evxViewType.

Enumerator
VX_VU_NULL | undefined
VX_VU_TOP | top view
VX_VU_FRONT | front view
VX_VU_RIGHT | right view
VX_VU_BACK | back view
VX_VU_BOTTOM | bottom view
VX_VU_LEFT | left view
VX_VU_ISO_FRONT | front isometric view
VX_VU_AUX | "auxiliary" view
VX_VU_NAME | named view
VX_VU_3RD_UP | view projected 3rd angle from above
VX_VU_3RD_DN | view projected 3rd angle from below
VX_VU_3RD_RT | view projected 3rd angle from right
VX_VU_3RD_LT | view projected 3rd angle from left
VX_VU_1ST_UP | view projected 1st angle from above
VX_VU_1ST_DN | view projected 1st angle from below
VX_VU_1ST_RT | view projected 1st angle from right
VX_VU_1ST_LT | view projected 1st angle from left
VX_VU_3RD_PRJ_ANG | view projected at angle, 3rd angle projection
VX_VU_DETAIL | detail view
VX_VU_SECTION | section view
VX_VU_DETAIL_DEF | detail definition
VX_VU_SECTION_DEF | section definition
VX_VU_REV_SECT_DEF | revolved section definition
VX_VU_ROTATE | rotated view
VX_VU_ALIGN_SECT_DEF | aligned section definition
VX_VU_PRJ_ANG_ARROWS | aux view arrows
VX_VU_BEND_SECT_DEF | bend section definition
VX_VU_ISO_LFT | left-front-top side isometric view
VX_VU_ISO_LBT | left-back-top side isometric view
VX_VU_ISO_RBT | right-back-top side isometric view
VX_VU_ISO_RFB | right-front-bottom side isometric view
VX_VU_ISO_LFB | left-front-bottom side isometric view
VX_VU_ISO_LBB | left-back-bottom side isometric view
VX_VU_ISO_RBB | right-back-bottom side isometric view
VX_VU_NAME_SECT_DEF | 3D named sect def'n
VX_VU_1ST_PRJ_ANG | view projected at angle, 1st angle projection
VX_VU_BRKSECT | broken section
VX_VU_ISOSECT | 3D isometric section view
VX_VU_DIMETRIC | dimetric view
VX_VU_SMD | selected sheet metal flat item view
Examples
drawing\dwgViewTest.cpp.

Definition at line 139 of file zwapi_cmd_dwg_data.h.

140 {
141 VX_VU_NULL = 0,
142 VX_VU_TOP = 1,
143 VX_VU_FRONT = 2,
144 VX_VU_RIGHT = 3,
145 VX_VU_BACK = 4,
146 VX_VU_BOTTOM = 5,
147 VX_VU_LEFT = 6,
148 VX_VU_ISO_FRONT = 7,
149 VX_VU_AUX = 8,
150 VX_VU_NAME = 9,
151 VX_VU_3RD_UP = 10,
152 VX_VU_3RD_DN = 11,
153 VX_VU_3RD_RT = 12,
154 VX_VU_3RD_LT = 13,
155 VX_VU_1ST_UP = 14,
156 VX_VU_1ST_DN = 15,
157 VX_VU_1ST_RT = 16,
158 VX_VU_1ST_LT = 17,
159 VX_VU_3RD_PRJ_ANG = 18,
160 VX_VU_DETAIL = 19,
161 VX_VU_SECTION = 20,
162 VX_VU_DETAIL_DEF = 21,
163 VX_VU_SECTION_DEF = 22,
164 VX_VU_REV_SECT_DEF = 23,
165 VX_VU_ROTATE = 24,
166 VX_VU_ALIGN_SECT_DEF = 25,
167 VX_VU_PRJ_ANG_ARROWS = 26,
168 VX_VU_BEND_SECT_DEF = 27,
169 VX_VU_ISO_LFT = 28,
170 VX_VU_ISO_LBT = 29,
171 VX_VU_ISO_RBT = 30,
172 VX_VU_ISO_RFB = 31,
173 VX_VU_ISO_LFB = 32,
174 VX_VU_ISO_LBB = 33,
175 VX_VU_ISO_RBB = 34,
176 VX_VU_NAME_SECT_DEF = 35,
177 VX_VU_1ST_PRJ_ANG = 36,
178 VX_VU_BRKSECT = 37,
179 VX_VU_ISOSECT = 38,
180 VX_VU_DIMETRIC = 39,
181 VX_VU_SMD = 40
182 } evxViewTypeEx;
evxViewTypeEx
evxViewTypeEx
View type, more detailed than evxViewType.
Definition: zwapi_cmd_dwg_data.h:140
VX_VU_1ST_UP
@ VX_VU_1ST_UP
view projected 1st angle from above
Definition: zwapi_cmd_dwg_data.h:155
VX_VU_DIMETRIC
@ VX_VU_DIMETRIC
dimetric view
Definition: zwapi_cmd_dwg_data.h:180
VX_VU_ISO_RFB
@ VX_VU_ISO_RFB
right-front-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:172
VX_VU_NAME_SECT_DEF
@ VX_VU_NAME_SECT_DEF
3D named sect def'n
Definition: zwapi_cmd_dwg_data.h:176
VX_VU_ISO_LBT
@ VX_VU_ISO_LBT
left-back-top side isometric view
Definition: zwapi_cmd_dwg_data.h:170
VX_VU_3RD_RT
@ VX_VU_3RD_RT
view projected 3rd angle from right
Definition: zwapi_cmd_dwg_data.h:153
VX_VU_REV_SECT_DEF
@ VX_VU_REV_SECT_DEF
revolved section definition
Definition: zwapi_cmd_dwg_data.h:164
VX_VU_BOTTOM
@ VX_VU_BOTTOM
bottom view
Definition: zwapi_cmd_dwg_data.h:146
VX_VU_PRJ_ANG_ARROWS
@ VX_VU_PRJ_ANG_ARROWS
aux view arrows
Definition: zwapi_cmd_dwg_data.h:167
VX_VU_DETAIL
@ VX_VU_DETAIL
detail view
Definition: zwapi_cmd_dwg_data.h:160
VX_VU_3RD_PRJ_ANG
@ VX_VU_3RD_PRJ_ANG
view projected at angle, 3rd angle projection
Definition: zwapi_cmd_dwg_data.h:159
VX_VU_NAME
@ VX_VU_NAME
named view
Definition: zwapi_cmd_dwg_data.h:150
VX_VU_3RD_LT
@ VX_VU_3RD_LT
view projected 3rd angle from left
Definition: zwapi_cmd_dwg_data.h:154
VX_VU_BEND_SECT_DEF
@ VX_VU_BEND_SECT_DEF
bend section definition
Definition: zwapi_cmd_dwg_data.h:168
VX_VU_DETAIL_DEF
@ VX_VU_DETAIL_DEF
detail definition
Definition: zwapi_cmd_dwg_data.h:162
VX_VU_ISOSECT
@ VX_VU_ISOSECT
3D isometric section view
Definition: zwapi_cmd_dwg_data.h:179
VX_VU_1ST_PRJ_ANG
@ VX_VU_1ST_PRJ_ANG
view projected at angle, 1st angle projection
Definition: zwapi_cmd_dwg_data.h:177
VX_VU_SECTION
@ VX_VU_SECTION
section view
Definition: zwapi_cmd_dwg_data.h:161
VX_VU_ISO_RBT
@ VX_VU_ISO_RBT
right-back-top side isometric view
Definition: zwapi_cmd_dwg_data.h:171
VX_VU_ISO_LFB
@ VX_VU_ISO_LFB
left-front-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:173
VX_VU_ISO_LFT
@ VX_VU_ISO_LFT
left-front-top side isometric view
Definition: zwapi_cmd_dwg_data.h:169
VX_VU_SMD
@ VX_VU_SMD
selected sheet metal flat item view
Definition: zwapi_cmd_dwg_data.h:181
VX_VU_FRONT
@ VX_VU_FRONT
front view
Definition: zwapi_cmd_dwg_data.h:143
VX_VU_3RD_DN
@ VX_VU_3RD_DN
view projected 3rd angle from below
Definition: zwapi_cmd_dwg_data.h:152
VX_VU_RIGHT
@ VX_VU_RIGHT
right view
Definition: zwapi_cmd_dwg_data.h:144
VX_VU_AUX
@ VX_VU_AUX
"auxiliary" view
Definition: zwapi_cmd_dwg_data.h:149
VX_VU_ISO_LBB
@ VX_VU_ISO_LBB
left-back-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:174
VX_VU_ALIGN_SECT_DEF
@ VX_VU_ALIGN_SECT_DEF
aligned section definition
Definition: zwapi_cmd_dwg_data.h:166
VX_VU_1ST_DN
@ VX_VU_1ST_DN
view projected 1st angle from below
Definition: zwapi_cmd_dwg_data.h:156
VX_VU_ISO_FRONT
@ VX_VU_ISO_FRONT
front isometric view
Definition: zwapi_cmd_dwg_data.h:148
VX_VU_NULL
@ VX_VU_NULL
undefined
Definition: zwapi_cmd_dwg_data.h:141
VX_VU_ISO_RBB
@ VX_VU_ISO_RBB
right-back-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:175
VX_VU_LEFT
@ VX_VU_LEFT
left view
Definition: zwapi_cmd_dwg_data.h:147
VX_VU_1ST_RT
@ VX_VU_1ST_RT
view projected 1st angle from right
Definition: zwapi_cmd_dwg_data.h:157
VX_VU_1ST_LT
@ VX_VU_1ST_LT
view projected 1st angle from left
Definition: zwapi_cmd_dwg_data.h:158
VX_VU_SECTION_DEF
@ VX_VU_SECTION_DEF
section definition
Definition: zwapi_cmd_dwg_data.h:163
VX_VU_BACK
@ VX_VU_BACK
back view
Definition: zwapi_cmd_dwg_data.h:145
VX_VU_3RD_UP
@ VX_VU_3RD_UP
view projected 3rd angle from above
Definition: zwapi_cmd_dwg_data.h:151
VX_VU_TOP
@ VX_VU_TOP
top view
Definition: zwapi_cmd_dwg_data.h:142
VX_VU_ROTATE
@ VX_VU_ROTATE
rotated view
Definition: zwapi_cmd_dwg_data.h:165
VX_VU_BRKSECT
@ VX_VU_BRKSECT
broken section
Definition: zwapi_cmd_dwg_data.h:178
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSymSurf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxSymSurf

enum evxSymSurf

#include <zwapi_cmd_dwg_data.h>

symbol type of surface roughness

Enumerator
VX_SYMSURF_BAS | basic
VX_SYMSURF_MRR | material removal required
VX_SYMSURF_MRP | material removal prohibited
VX_SYMSURF_JIS1 | JIS surface texture 1.
VX_SYMSURF_JIS2 | JIS surface texture 2.
VX_SYMSURF_JIS3 | JIS surface texture 3.
VX_SYMSURF_JIS4 | JIS surface texture 4.
VX_SYMSURF_JISNM | JIS no machining.

Definition at line 1451 of file zwapi_cmd_dwg_data.h.

1452 {
1453 VX_SYMSURF_BAS = 0,
1454 VX_SYMSURF_MRR,
1455 VX_SYMSURF_MRP,
1456 VX_SYMSURF_JIS1,
1457 VX_SYMSURF_JIS2,
1458 VX_SYMSURF_JIS3,
1459 VX_SYMSURF_JIS4,
1460 VX_SYMSURF_JISNM
1461 } evxSymSurf;
evxSymSurf
evxSymSurf
symbol type of surface roughness
Definition: zwapi_cmd_dwg_data.h:1452
VX_SYMSURF_JISNM
@ VX_SYMSURF_JISNM
JIS no machining.
Definition: zwapi_cmd_dwg_data.h:1460
VX_SYMSURF_MRR
@ VX_SYMSURF_MRR
material removal required
Definition: zwapi_cmd_dwg_data.h:1454
VX_SYMSURF_JIS1
@ VX_SYMSURF_JIS1
JIS surface texture 1.
Definition: zwapi_cmd_dwg_data.h:1456
VX_SYMSURF_BAS
@ VX_SYMSURF_BAS
basic
Definition: zwapi_cmd_dwg_data.h:1453
VX_SYMSURF_JIS4
@ VX_SYMSURF_JIS4
JIS surface texture 4.
Definition: zwapi_cmd_dwg_data.h:1459
VX_SYMSURF_JIS2
@ VX_SYMSURF_JIS2
JIS surface texture 2.
Definition: zwapi_cmd_dwg_data.h:1457
VX_SYMSURF_JIS3
@ VX_SYMSURF_JIS3
JIS surface texture 3.
Definition: zwapi_cmd_dwg_data.h:1458
VX_SYMSURF_MRP
@ VX_SYMSURF_MRP
material removal prohibited
Definition: zwapi_cmd_dwg_data.h:1455
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxIndentedType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxIndentedType

enum evxIndentedType

#include <zwapi_cmd_dwg_data.h>

indent type

Enumerator
VX_NO_NUM | No numbering.
VX_DETAILED_NUM | Detailed numbering.
VX_FLAT_NUM | Flat numbering.

Definition at line 506 of file zwapi_cmd_dwg_data.h.

507 {
508 VX_NO_NUM = 0,
509 VX_DETAILED_NUM = 1,
510 VX_FLAT_NUM = 2,
511 } evxIndentedType;
evxIndentedType
evxIndentedType
indent type
Definition: zwapi_cmd_dwg_data.h:507
VX_DETAILED_NUM
@ VX_DETAILED_NUM
Detailed numbering.
Definition: zwapi_cmd_dwg_data.h:509
VX_NO_NUM
@ VX_NO_NUM
No numbering.
Definition: zwapi_cmd_dwg_data.h:508
VX_FLAT_NUM
@ VX_FLAT_NUM
Flat numbering.
Definition: zwapi_cmd_dwg_data.h:510
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxRadDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxRadDimType

enum evxRadDimType

#include <zwapi_cmd_dwg_data.h>

radial or diametric dim type

Enumerator
VX_RAD_RADIAL | radial dimension
VX_RAD_BROKEN | broken radial dimension
VX_RAD_LARGE | large radial dimension
VX_RAD_LEADER | leader radial dimension
VX_RAD_DIAMETER | diametric dimension
VX_RAD_LINEAR | linear diameter

Definition at line 922 of file zwapi_cmd_dwg_data.h.

923 {
924 VX_RAD_RADIAL = 1,
925 VX_RAD_BROKEN = 2,
926 VX_RAD_LARGE = 3,
927 VX_RAD_LEADER = 4,
928 VX_RAD_DIAMETER = 5,
929 VX_RAD_LINEAR = 6
930 } evxRadDimType;
evxRadDimType
evxRadDimType
radial or diametric dim type
Definition: zwapi_cmd_dwg_data.h:923
VX_RAD_DIAMETER
@ VX_RAD_DIAMETER
diametric dimension
Definition: zwapi_cmd_dwg_data.h:928
VX_RAD_LEADER
@ VX_RAD_LEADER
leader radial dimension
Definition: zwapi_cmd_dwg_data.h:927
VX_RAD_LARGE
@ VX_RAD_LARGE
large radial dimension
Definition: zwapi_cmd_dwg_data.h:926
VX_RAD_BROKEN
@ VX_RAD_BROKEN
broken radial dimension
Definition: zwapi_cmd_dwg_data.h:925
VX_RAD_RADIAL
@ VX_RAD_RADIAL
radial dimension
Definition: zwapi_cmd_dwg_data.h:924
VX_RAD_LINEAR
@ VX_RAD_LINEAR
linear diameter
Definition: zwapi_cmd_dwg_data.h:929
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDatumDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDatumDimType

enum evxDatumDimType

#include <zwapi_cmd_dwg_data.h>

datum dim type

Enumerator
VX_DATUM_NORMAL | normal datum feature symbol
VX_DATUM_ANSI | based on ANSI(per 1982)

Definition at line 1222 of file zwapi_cmd_dwg_data.h.

1223 {
1224 VX_DATUM_NORMAL = 1,
1225 VX_DATUM_ANSI = 2,
1226 } evxDatumDimType;
evxDatumDimType
evxDatumDimType
datum dim type
Definition: zwapi_cmd_dwg_data.h:1223
VX_DATUM_NORMAL
@ VX_DATUM_NORMAL
normal datum feature symbol
Definition: zwapi_cmd_dwg_data.h:1224
VX_DATUM_ANSI
@ VX_DATUM_ANSI
based on ANSI(per 1982)
Definition: zwapi_cmd_dwg_data.h:1225
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxRotViewType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxRotViewType

enum evxRotViewType

#include <zwapi_cmd_dwg_data.h>

type of view

Enumerator
VX_ROTVIEW_TOP | top
VX_ROTVIEW_FRONT | front
VX_ROTVIEW_RIGHT | right
VX_ROTVIEW_BACK | back
VX_ROTVIEW_BOTTOM | bottom
VX_ROTVIEW_LEFT | left
VX_ROTVIEW_ISOMETRIC | isometric
VX_ROTVIEW_ISOMETRIC_LFT | isometric_left-front-top
VX_ROTVIEW_ISOMETRIC_LBT | isometric_left-back-top
VX_ROTVIEW_ISOMETRIC_RBT | isometric_right-back-top
VX_ROTVIEW_ISOMETRIC_RFB | isometric_right-front-bottom
VX_ROTVIEW_ISOMETRIC_LFB | isometric_left-front-bottom
VX_ROTVIEW_ISOMETRIC_LBB | isometric_left-back-bottom
VX_ROTVIEW_ISOMETRIC_RBB | isometric_right-back-bottom

Definition at line 591 of file zwapi_cmd_dwg_data.h.

592 {
593 VX_ROTVIEW_TOP = 1,
594 VX_ROTVIEW_FRONT = 2,
595 VX_ROTVIEW_RIGHT,
596 VX_ROTVIEW_BACK,
597 VX_ROTVIEW_BOTTOM,
598 VX_ROTVIEW_LEFT,
599 VX_ROTVIEW_ISOMETRIC,
600 VX_ROTVIEW_ISOMETRIC_LFT,
601 VX_ROTVIEW_ISOMETRIC_LBT,
602 VX_ROTVIEW_ISOMETRIC_RBT,
603 VX_ROTVIEW_ISOMETRIC_RFB,
604 VX_ROTVIEW_ISOMETRIC_LFB,
605 VX_ROTVIEW_ISOMETRIC_LBB,
606 VX_ROTVIEW_ISOMETRIC_RBB,
607 } evxRotViewType;
evxRotViewType
evxRotViewType
type of view
Definition: zwapi_cmd_dwg_data.h:592
VX_ROTVIEW_BOTTOM
@ VX_ROTVIEW_BOTTOM
bottom
Definition: zwapi_cmd_dwg_data.h:597
VX_ROTVIEW_ISOMETRIC
@ VX_ROTVIEW_ISOMETRIC
isometric
Definition: zwapi_cmd_dwg_data.h:599
VX_ROTVIEW_FRONT
@ VX_ROTVIEW_FRONT
front
Definition: zwapi_cmd_dwg_data.h:594
VX_ROTVIEW_ISOMETRIC_LBT
@ VX_ROTVIEW_ISOMETRIC_LBT
isometric_left-back-top
Definition: zwapi_cmd_dwg_data.h:601
VX_ROTVIEW_BACK
@ VX_ROTVIEW_BACK
back
Definition: zwapi_cmd_dwg_data.h:596
VX_ROTVIEW_TOP
@ VX_ROTVIEW_TOP
top
Definition: zwapi_cmd_dwg_data.h:593
VX_ROTVIEW_ISOMETRIC_RBT
@ VX_ROTVIEW_ISOMETRIC_RBT
isometric_right-back-top
Definition: zwapi_cmd_dwg_data.h:602
VX_ROTVIEW_ISOMETRIC_LBB
@ VX_ROTVIEW_ISOMETRIC_LBB
isometric_left-back-bottom
Definition: zwapi_cmd_dwg_data.h:605
VX_ROTVIEW_ISOMETRIC_RFB
@ VX_ROTVIEW_ISOMETRIC_RFB
isometric_right-front-bottom
Definition: zwapi_cmd_dwg_data.h:603
VX_ROTVIEW_ISOMETRIC_LFT
@ VX_ROTVIEW_ISOMETRIC_LFT
isometric_left-front-top
Definition: zwapi_cmd_dwg_data.h:600
VX_ROTVIEW_ISOMETRIC_RBB
@ VX_ROTVIEW_ISOMETRIC_RBB
isometric_right-back-bottom
Definition: zwapi_cmd_dwg_data.h:606
VX_ROTVIEW_LEFT
@ VX_ROTVIEW_LEFT
left
Definition: zwapi_cmd_dwg_data.h:598
VX_ROTVIEW_RIGHT
@ VX_ROTVIEW_RIGHT
right
Definition: zwapi_cmd_dwg_data.h:595
VX_ROTVIEW_ISOMETRIC_LFB
@ VX_ROTVIEW_ISOMETRIC_LFB
isometric_left-front-bottom
Definition: zwapi_cmd_dwg_data.h:604
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCalloutEmt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxCalloutEmt

enum evxCalloutEmt

#include <zwapi_cmd_dwg_data.h>

Callout Elements.

Enumerator
VX_CALLOUTEMT_INVALID | all is not valid
VX_CALLOUTEMT_QUALITY | Quality.
VX_CALLOUTEMT_DIAMETER | Diameter.
VX_CALLOUTEMT_DIAMETER_D2 | Diameter(D2)
VX_CALLOUTEMT_DEPTH | Depth.
VX_CALLOUTEMT_DEPTH_H2 | Depth(H2)
VX_CALLOUTEMT_THREAD_DIA | Thread Diameter.
VX_CALLOUTEMT_THREAD_PITCH | Thread Pitch.
VX_CALLOUTEMT_THREAD_DEPTH | Thread Depth.
VX_CALLOUTEMT_ANGLE | Angle.
VX_CALLOUTEMT_CALLOUT_LABEL | Callout Label.
VX_CALLOUTEMT_MULTIPLE_LINE | Multiple Lines.
VX_CALLOUTEMT_SLOT_LENGTH | Slot Length.
VX_CALLOUTEMT_VALID | all is valid

Definition at line 965 of file zwapi_cmd_dwg_data.h.

966 {
967 VX_CALLOUTEMT_INVALID = 0x00000000,
968 VX_CALLOUTEMT_QUALITY = 0x00000001,
969 VX_CALLOUTEMT_DIAMETER = 0x00000002,
970 VX_CALLOUTEMT_DIAMETER_D2 = 0x00000004,
971 VX_CALLOUTEMT_DEPTH = 0x00000008,
972 VX_CALLOUTEMT_DEPTH_H2 = 0x00000010,
973 VX_CALLOUTEMT_THREAD_DIA = 0x00000020,
974 VX_CALLOUTEMT_THREAD_PITCH = 0x00000040,
975 VX_CALLOUTEMT_THREAD_DEPTH = 0x00000080,
976 VX_CALLOUTEMT_ANGLE = 0x00000100,
977 VX_CALLOUTEMT_CALLOUT_LABEL = 0x00000200,
978 VX_CALLOUTEMT_MULTIPLE_LINE = 0x00000400,
979 VX_CALLOUTEMT_SLOT_LENGTH = 0x00000800,
980 VX_CALLOUTEMT_VALID = 0xFFFFFFFF
981 } evxCalloutEmt;
evxCalloutEmt
evxCalloutEmt
Callout Elements.
Definition: zwapi_cmd_dwg_data.h:966
VX_CALLOUTEMT_DIAMETER_D2
@ VX_CALLOUTEMT_DIAMETER_D2
Diameter(D2)
Definition: zwapi_cmd_dwg_data.h:970
VX_CALLOUTEMT_MULTIPLE_LINE
@ VX_CALLOUTEMT_MULTIPLE_LINE
Multiple Lines.
Definition: zwapi_cmd_dwg_data.h:978
VX_CALLOUTEMT_SLOT_LENGTH
@ VX_CALLOUTEMT_SLOT_LENGTH
Slot Length.
Definition: zwapi_cmd_dwg_data.h:979
VX_CALLOUTEMT_THREAD_DIA
@ VX_CALLOUTEMT_THREAD_DIA
Thread Diameter.
Definition: zwapi_cmd_dwg_data.h:973
VX_CALLOUTEMT_VALID
@ VX_CALLOUTEMT_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:980
VX_CALLOUTEMT_QUALITY
@ VX_CALLOUTEMT_QUALITY
Quality.
Definition: zwapi_cmd_dwg_data.h:968
VX_CALLOUTEMT_DIAMETER
@ VX_CALLOUTEMT_DIAMETER
Diameter.
Definition: zwapi_cmd_dwg_data.h:969
VX_CALLOUTEMT_DEPTH_H2
@ VX_CALLOUTEMT_DEPTH_H2
Depth(H2)
Definition: zwapi_cmd_dwg_data.h:972
VX_CALLOUTEMT_THREAD_PITCH
@ VX_CALLOUTEMT_THREAD_PITCH
Thread Pitch.
Definition: zwapi_cmd_dwg_data.h:974
VX_CALLOUTEMT_INVALID
@ VX_CALLOUTEMT_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:967
VX_CALLOUTEMT_DEPTH
@ VX_CALLOUTEMT_DEPTH
Depth.
Definition: zwapi_cmd_dwg_data.h:971
VX_CALLOUTEMT_THREAD_DEPTH
@ VX_CALLOUTEMT_THREAD_DEPTH
Thread Depth.
Definition: zwapi_cmd_dwg_data.h:975
VX_CALLOUTEMT_CALLOUT_LABEL
@ VX_CALLOUTEMT_CALLOUT_LABEL
Callout Label.
Definition: zwapi_cmd_dwg_data.h:977
VX_CALLOUTEMT_ANGLE
@ VX_CALLOUTEMT_ANGLE
Angle.
Definition: zwapi_cmd_dwg_data.h:976
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgAtBlnSkpSd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgAtBlnSkpSd

enum evxDwgAtBlnSkpSd

#include <zwapi_cmd_dwg_data.h>

Skip sides of auto balloon.

Enumerator
VX_ATBLNSKPSD_NONE | skip none
VX_ATBLNSKPSD_LEFT | skip left
VX_ATBLNSKPSD_TOP | skip top
VX_ATBLNSKPSD_RIGHT | skip right
VX_ATBLNSKPSD_BOTTOM | skip bottom

Definition at line 1126 of file zwapi_cmd_dwg_data.h.

1127 {
1128 VX_ATBLNSKPSD_NONE = 0,
1129 VX_ATBLNSKPSD_LEFT = 1,
1130 VX_ATBLNSKPSD_TOP = 2,
1131 VX_ATBLNSKPSD_RIGHT = 4,
1132 VX_ATBLNSKPSD_BOTTOM = 8
1133 } evxDwgAtBlnSkpSd;
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
Skip sides of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1127
VX_ATBLNSKPSD_BOTTOM
@ VX_ATBLNSKPSD_BOTTOM
skip bottom
Definition: zwapi_cmd_dwg_data.h:1132
VX_ATBLNSKPSD_RIGHT
@ VX_ATBLNSKPSD_RIGHT
skip right
Definition: zwapi_cmd_dwg_data.h:1131
VX_ATBLNSKPSD_TOP
@ VX_ATBLNSKPSD_TOP
skip top
Definition: zwapi_cmd_dwg_data.h:1130
VX_ATBLNSKPSD_LEFT
@ VX_ATBLNSKPSD_LEFT
skip left
Definition: zwapi_cmd_dwg_data.h:1129
VX_ATBLNSKPSD_NONE
@ VX_ATBLNSKPSD_NONE
skip none
Definition: zwapi_cmd_dwg_data.h:1128
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxOrderType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxOrderType

enum evxOrderType

#include <zwapi_cmd_dwg_data.h>

order type

Enumerator
VX_ORDER_BYNAME | Order by name.
VX_ORDER_REGEN_IDS | Regenerate IDs after sort.
VX_ORDER_ASASM | Order as assembly.

Definition at line 517 of file zwapi_cmd_dwg_data.h.

518 {
519 VX_ORDER_BYNAME = 0,
520 VX_ORDER_REGEN_IDS = 1,
521 VX_ORDER_ASASM = 2,
522 } evxOrderType;
evxOrderType
evxOrderType
order type
Definition: zwapi_cmd_dwg_data.h:518
VX_ORDER_ASASM
@ VX_ORDER_ASASM
Order as assembly.
Definition: zwapi_cmd_dwg_data.h:521
VX_ORDER_BYNAME
@ VX_ORDER_BYNAME
Order by name.
Definition: zwapi_cmd_dwg_data.h:519
VX_ORDER_REGEN_IDS
@ VX_ORDER_REGEN_IDS
Regenerate IDs after sort.
Definition: zwapi_cmd_dwg_data.h:520
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgDepthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgDepthType

enum evxDwgDepthType

#include <zwapi_cmd_dwg_data.h>

Drawing Broken Section Depth type.

Enumerator
VX_DEPTH_POINT | point
VX_DEPTH_SECTION_PLANE | section plane
VX_DEPTH_3D_NAMED | 3d named

Definition at line 406 of file zwapi_cmd_dwg_data.h.

407 {
408 VX_DEPTH_POINT,
409 VX_DEPTH_SECTION_PLANE,
410 VX_DEPTH_3D_NAMED,
411 } evxDwgDepthType;
evxDwgDepthType
evxDwgDepthType
Drawing Broken Section Depth type.
Definition: zwapi_cmd_dwg_data.h:407
VX_DEPTH_POINT
@ VX_DEPTH_POINT
point
Definition: zwapi_cmd_dwg_data.h:408
VX_DEPTH_SECTION_PLANE
@ VX_DEPTH_SECTION_PLANE
section plane
Definition: zwapi_cmd_dwg_data.h:409
VX_DEPTH_3D_NAMED
@ VX_DEPTH_3D_NAMED
3d named
Definition: zwapi_cmd_dwg_data.h:410
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgLnrChmDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgLnrChmDimType

enum evxDwgLnrChmDimType

#include <zwapi_cmd_dwg_data.h>

type of linear chamfer dim in sheeting

Enumerator
VX_LEADER_CHAMFERDIM | leader linear chamfer dim
VX_ALIGNED_CHAMFERDIM | aligned linear chamfer dim
VX_HORZORVERT_CHAMFERDIM | horizontal/vertical linear chamfer dim

Definition at line 832 of file zwapi_cmd_dwg_data.h.

833 {
834 VX_LEADER_CHAMFERDIM = 1,
835 VX_ALIGNED_CHAMFERDIM,
836 VX_HORZORVERT_CHAMFERDIM
837 } evxDwgLnrChmDimType;
evxDwgLnrChmDimType
evxDwgLnrChmDimType
type of linear chamfer dim in sheeting
Definition: zwapi_cmd_dwg_data.h:833
VX_LEADER_CHAMFERDIM
@ VX_LEADER_CHAMFERDIM
leader linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:834
VX_HORZORVERT_CHAMFERDIM
@ VX_HORZORVERT_CHAMFERDIM
horizontal/vertical linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:836
VX_ALIGNED_CHAMFERDIM
@ VX_ALIGNED_CHAMFERDIM
aligned linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:835
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxBrkLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxBrkLineType

enum evxBrkLineType

#include <zwapi_cmd_dwg_data.h>

option of break line

Enumerator
VX_HOR_BRKLINE | Horizontal break line.
VX_VER_BRKLINE | Vertical break line.
VX_SLANT_BRKLINE | Slant break line.

Definition at line 466 of file zwapi_cmd_dwg_data.h.

467 {
468 VX_HOR_BRKLINE = 0,
469 VX_VER_BRKLINE,
470 VX_SLANT_BRKLINE
471 } evxBrkLineType;
evxBrkLineType
evxBrkLineType
option of break line
Definition: zwapi_cmd_dwg_data.h:467
VX_VER_BRKLINE
@ VX_VER_BRKLINE
Vertical break line.
Definition: zwapi_cmd_dwg_data.h:469
VX_SLANT_BRKLINE
@ VX_SLANT_BRKLINE
Slant break line.
Definition: zwapi_cmd_dwg_data.h:470
VX_HOR_BRKLINE
@ VX_HOR_BRKLINE
Horizontal break line.
Definition: zwapi_cmd_dwg_data.h:468
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxHatchType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxHatchType

enum evxHatchType

#include <zwapi_cmd_dwg_data.h>

hatch type

Enumerator
VX_HATCH_CUSTOM | custom hatch style
VX_HATCH_STANDARD | from standard
VX_HATCH_ANSI | hatch style (ANSI)
VX_HATCH_ISO | hatch style (ISO)
VX_HATCH_DIN | hatch style (DIN)
VX_HATCH_JIS | hatch style (JIS)
VX_HATCH_GB | hatch style (GB)

Definition at line 1595 of file zwapi_cmd_dwg_data.h.

1596 {
1597 VX_HATCH_CUSTOM = -1,
1598 VX_HATCH_STANDARD,
1599 VX_HATCH_ANSI,
1600 VX_HATCH_ISO,
1601 VX_HATCH_DIN,
1602 VX_HATCH_JIS,
1603 VX_HATCH_GB,
1604 } evxHatchType;
evxHatchType
evxHatchType
hatch type
Definition: zwapi_cmd_dwg_data.h:1596
VX_HATCH_ANSI
@ VX_HATCH_ANSI
hatch style (ANSI)
Definition: zwapi_cmd_dwg_data.h:1599
VX_HATCH_DIN
@ VX_HATCH_DIN
hatch style (DIN)
Definition: zwapi_cmd_dwg_data.h:1601
VX_HATCH_CUSTOM
@ VX_HATCH_CUSTOM
custom hatch style
Definition: zwapi_cmd_dwg_data.h:1597
VX_HATCH_STANDARD
@ VX_HATCH_STANDARD
from standard
Definition: zwapi_cmd_dwg_data.h:1598
VX_HATCH_ISO
@ VX_HATCH_ISO
hatch style (ISO)
Definition: zwapi_cmd_dwg_data.h:1600
VX_HATCH_JIS
@ VX_HATCH_JIS
hatch style (JIS)
Definition: zwapi_cmd_dwg_data.h:1602
VX_HATCH_GB
@ VX_HATCH_GB
hatch style (GB)
Definition: zwapi_cmd_dwg_data.h:1603
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxAutoPlacement

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxAutoPlacement

enum evxAutoPlacement

#include <zwapi_cmd_dwg_data.h>

dimension position/placement

Enumerator
DIM_VIEW_ABOVE_LEFT | left or above of view
DIM_VIEW_BELOW_RIGHT | right or below of view
DIM_VIEW_BOTH | both of view

Definition at line 651 of file zwapi_cmd_dwg_data.h.

652 {
653 DIM_VIEW_ABOVE_LEFT = 0,
654 DIM_VIEW_BELOW_RIGHT,
655 DIM_VIEW_BOTH,
656 }evxAutoPlacement;
evxAutoPlacement
evxAutoPlacement
dimension position/placement
Definition: zwapi_cmd_dwg_data.h:652
DIM_VIEW_ABOVE_LEFT
@ DIM_VIEW_ABOVE_LEFT
left or above of view
Definition: zwapi_cmd_dwg_data.h:653
DIM_VIEW_BELOW_RIGHT
@ DIM_VIEW_BELOW_RIGHT
right or below of view
Definition: zwapi_cmd_dwg_data.h:654
DIM_VIEW_BOTH
@ DIM_VIEW_BOTH
both of view
Definition: zwapi_cmd_dwg_data.h:655
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxLevelSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxLevelSet

enum evxLevelSet

#include <zwapi_cmd_dwg_data.h>

level set

Enumerator
VX_TOP_LEVEL_ONLY | Top-level only.
VX_PARTS_ONLY | Parts only.
VX_INDENTED | Indented.
VX_BALLOON_ONLY | by balloon only

Definition at line 494 of file zwapi_cmd_dwg_data.h.

495 {
496 VX_TOP_LEVEL_ONLY = 0,
497 VX_PARTS_ONLY = 1,
498 VX_INDENTED = 3,
499 VX_BALLOON_ONLY = 4,
500 } evxLevelSet;
evxLevelSet
evxLevelSet
level set
Definition: zwapi_cmd_dwg_data.h:495
VX_INDENTED
@ VX_INDENTED
Indented.
Definition: zwapi_cmd_dwg_data.h:498
VX_BALLOON_ONLY
@ VX_BALLOON_ONLY
by balloon only
Definition: zwapi_cmd_dwg_data.h:499
VX_PARTS_ONLY
@ VX_PARTS_ONLY
Parts only.
Definition: zwapi_cmd_dwg_data.h:497
VX_TOP_LEVEL_ONLY
@ VX_TOP_LEVEL_ONLY
Top-level only.
Definition: zwapi_cmd_dwg_data.h:496
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxOriginType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxOriginType

enum evxOriginType

#include <zwapi_cmd_dwg_data.h>

origin type

Enumerator
VX_TOP_LEFT | Top-Left.
VX_TOP_CENTER | Top-Center.
VX_TOP_RIGHT | Top-Right.
VX_MID_LEFT | Mid-Left.
VX_MID_CENTER | Mid-Center.
VX_MID_RIGHT | Mid-Right.
VX_BOTTOM_LEFT | Bottom-Left.
VX_BOTTOM_CENTER | Bottom-Center.
VX_BOTTOM_RIGHT | Bottom-Right.

Definition at line 560 of file zwapi_cmd_dwg_data.h.

561 {
562 VX_TOP_LEFT = 0,
563 VX_TOP_CENTER = 1,
564 VX_TOP_RIGHT = 2,
565 VX_MID_LEFT,
566 VX_MID_CENTER,
567 VX_MID_RIGHT,
568 VX_BOTTOM_LEFT,
569 VX_BOTTOM_CENTER,
570 VX_BOTTOM_RIGHT,
571 } evxOriginType;
evxOriginType
evxOriginType
origin type
Definition: zwapi_cmd_dwg_data.h:561
VX_MID_RIGHT
@ VX_MID_RIGHT
Mid-Right.
Definition: zwapi_cmd_dwg_data.h:567
VX_BOTTOM_LEFT
@ VX_BOTTOM_LEFT
Bottom-Left.
Definition: zwapi_cmd_dwg_data.h:568
VX_MID_LEFT
@ VX_MID_LEFT
Mid-Left.
Definition: zwapi_cmd_dwg_data.h:565
VX_MID_CENTER
@ VX_MID_CENTER
Mid-Center.
Definition: zwapi_cmd_dwg_data.h:566
VX_TOP_CENTER
@ VX_TOP_CENTER
Top-Center.
Definition: zwapi_cmd_dwg_data.h:563
VX_BOTTOM_CENTER
@ VX_BOTTOM_CENTER
Bottom-Center.
Definition: zwapi_cmd_dwg_data.h:569
VX_TOP_RIGHT
@ VX_TOP_RIGHT
Top-Right.
Definition: zwapi_cmd_dwg_data.h:564
VX_TOP_LEFT
@ VX_TOP_LEFT
Top-Left.
Definition: zwapi_cmd_dwg_data.h:562
VX_BOTTOM_RIGHT
@ VX_BOTTOM_RIGHT
Bottom-Right.
Definition: zwapi_cmd_dwg_data.h:570
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxViewDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxViewDimType

enum evxViewDimType

#include <zwapi_cmd_dwg_data.h>

view dimension type

Enumerator
VX_VIEW_DIMTYPEPRJ | dimension type : Projected
VX_VIEW_DIMTYPETRUE | dimension type : True

Definition at line 234 of file zwapi_cmd_dwg_data.h.

235 {
236 VX_VIEW_DIMTYPEPRJ = 0,
237 VX_VIEW_DIMTYPETRUE = 1,
238 } evxViewDimType;
evxViewDimType
evxViewDimType
view dimension type
Definition: zwapi_cmd_dwg_data.h:235
VX_VIEW_DIMTYPEPRJ
@ VX_VIEW_DIMTYPEPRJ
dimension type : Projected
Definition: zwapi_cmd_dwg_data.h:236
VX_VIEW_DIMTYPETRUE
@ VX_VIEW_DIMTYPETRUE
dimension type : True
Definition: zwapi_cmd_dwg_data.h:237
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxAngDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxAngDimType

enum evxAngDimType

#include <zwapi_cmd_dwg_data.h>

angular dimension type

Enumerator
VX_ANG_TWOCURVES | 2 curves angular dimension
VX_ANG_HORIZONTAL | horizontal angular dimension
VX_ANG_VERTICAL | vertical angular dimension
VX_ANG_THREEPOINT | 3 point angular dimension
VX_ANG_ARC | arc angular dimension

Definition at line 872 of file zwapi_cmd_dwg_data.h.

873 {
874 VX_ANG_TWOCURVES = 1,
875 VX_ANG_HORIZONTAL = 2,
876 VX_ANG_VERTICAL = 3,
877 VX_ANG_THREEPOINT = 4,
878 VX_ANG_ARC = 5,
879 }evxAngDimType;
evxAngDimType
evxAngDimType
angular dimension type
Definition: zwapi_cmd_dwg_data.h:873
VX_ANG_HORIZONTAL
@ VX_ANG_HORIZONTAL
horizontal angular dimension
Definition: zwapi_cmd_dwg_data.h:875
VX_ANG_ARC
@ VX_ANG_ARC
arc angular dimension
Definition: zwapi_cmd_dwg_data.h:878
VX_ANG_VERTICAL
@ VX_ANG_VERTICAL
vertical angular dimension
Definition: zwapi_cmd_dwg_data.h:876
VX_ANG_THREEPOINT
@ VX_ANG_THREEPOINT
3 point angular dimension
Definition: zwapi_cmd_dwg_data.h:877
VX_ANG_TWOCURVES
@ VX_ANG_TWOCURVES
2 curves angular dimension
Definition: zwapi_cmd_dwg_data.h:874
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSecMtdType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxSecMtdType

enum evxSecMtdType

#include <zwapi_cmd_dwg_data.h>

section method type

Enumerator
VX_METHOD_SECCURVE | Section Method : Sect Curves.
VX_METHOD_TRIMPART | Section Method : Trimmed Part.
VX_METHOD_TRIMSURF | Section Method : Trimmed Surface.

Definition at line 281 of file zwapi_cmd_dwg_data.h.

282 {
283 VX_METHOD_SECCURVE = 1,
284 VX_METHOD_TRIMPART = 2,
285 VX_METHOD_TRIMSURF = 3,
286 } evxSecMtdType;
evxSecMtdType
evxSecMtdType
section method type
Definition: zwapi_cmd_dwg_data.h:282
VX_METHOD_SECCURVE
@ VX_METHOD_SECCURVE
Section Method : Sect Curves.
Definition: zwapi_cmd_dwg_data.h:283
VX_METHOD_TRIMPART
@ VX_METHOD_TRIMPART
Section Method : Trimmed Part.
Definition: zwapi_cmd_dwg_data.h:284
VX_METHOD_TRIMSURF
@ VX_METHOD_TRIMSURF
Section Method : Trimmed Surface.
Definition: zwapi_cmd_dwg_data.h:285
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgDetailMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgDetailMethod

enum evxDwgDetailMethod

#include <zwapi_cmd_dwg_data.h>

Drawing Detail Method.

Enumerator
VX_RECTANGULAR_DETAIL | rectangular detail view
VX_CIRCULAR_DETAIL | circular detail view
VX_POLYLINE_DETAIL | polyline detail view

Definition at line 440 of file zwapi_cmd_dwg_data.h.

441 {
442 VX_RECTANGULAR_DETAIL = 1,
443 VX_CIRCULAR_DETAIL = 2,
444 VX_POLYLINE_DETAIL,
445 } evxDwgDetailMethod;
evxDwgDetailMethod
evxDwgDetailMethod
Drawing Detail Method.
Definition: zwapi_cmd_dwg_data.h:441
VX_POLYLINE_DETAIL
@ VX_POLYLINE_DETAIL
polyline detail view
Definition: zwapi_cmd_dwg_data.h:444
VX_CIRCULAR_DETAIL
@ VX_CIRCULAR_DETAIL
circular detail view
Definition: zwapi_cmd_dwg_data.h:443
VX_RECTANGULAR_DETAIL
@ VX_RECTANGULAR_DETAIL
rectangular detail view
Definition: zwapi_cmd_dwg_data.h:442
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxBomset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxBomset

enum evxBomset

#include <zwapi_cmd_dwg_data.h>

BOM set.

Enumerator
VX_BOM_INVALID | all is not valid
VX_SET_DISP_CFG | Display configurations of the same as one item.
VX_DERIVED_PARTS | Derived parts as instances of source part.
VX_SYNC_BOM | Sync BOM table with part attributes.
VX_KEEP_MISSING | Keep missing item.
VX_STRIKE_THROUGH | Strike through.
VX_BOM_VALID | all is valid

Definition at line 528 of file zwapi_cmd_dwg_data.h.

529 {
530 VX_BOM_INVALID = 0x0000,
531 VX_SET_DISP_CFG = 0x0001,
532 VX_DERIVED_PARTS = 0x0002,
533 VX_SYNC_BOM = 0x0004,
534 VX_KEEP_MISSING = 0x0008,
535 VX_STRIKE_THROUGH = 0x0010,
536 VX_BOM_VALID = 0xFFFF
537 } evxBomset;
evxBomset
evxBomset
BOM set.
Definition: zwapi_cmd_dwg_data.h:529
VX_BOM_VALID
@ VX_BOM_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:536
VX_SET_DISP_CFG
@ VX_SET_DISP_CFG
Display configurations of the same as one item.
Definition: zwapi_cmd_dwg_data.h:531
VX_BOM_INVALID
@ VX_BOM_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:530
VX_KEEP_MISSING
@ VX_KEEP_MISSING
Keep missing item.
Definition: zwapi_cmd_dwg_data.h:534
VX_STRIKE_THROUGH
@ VX_STRIKE_THROUGH
Strike through.
Definition: zwapi_cmd_dwg_data.h:535
VX_SYNC_BOM
@ VX_SYNC_BOM
Sync BOM table with part attributes.
Definition: zwapi_cmd_dwg_data.h:533
VX_DERIVED_PARTS
@ VX_DERIVED_PARTS
Derived parts as instances of source part.
Definition: zwapi_cmd_dwg_data.h:532
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxAutoEntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxAutoEntType

enum evxAutoEntType

#include <zwapi_cmd_dwg_data.h>

select geometry entity type

Enumerator
DIM_AUTO_ENT_ALL | entity type is all
DIM_AUTO_ENT_ARC_CIRCLE | entity type is all arc/circle
DIM_AUTO_ENT_PICKED | entity type is picked by user

Definition at line 628 of file zwapi_cmd_dwg_data.h.

629 {
630 DIM_AUTO_ENT_ALL = 0,
631 DIM_AUTO_ENT_ARC_CIRCLE,
632 DIM_AUTO_ENT_PICKED
633 }evxAutoEntType;
evxAutoEntType
evxAutoEntType
select geometry entity type
Definition: zwapi_cmd_dwg_data.h:629
DIM_AUTO_ENT_ARC_CIRCLE
@ DIM_AUTO_ENT_ARC_CIRCLE
entity type is all arc/circle
Definition: zwapi_cmd_dwg_data.h:631
DIM_AUTO_ENT_ALL
@ DIM_AUTO_ENT_ALL
entity type is all
Definition: zwapi_cmd_dwg_data.h:630
DIM_AUTO_ENT_PICKED
@ DIM_AUTO_ENT_PICKED
entity type is picked by user
Definition: zwapi_cmd_dwg_data.h:632
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxAutoInclude

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxAutoInclude

enum evxAutoInclude

#include <zwapi_cmd_dwg_data.h>

auto dimension include

Enumerator
VX_AUTOINC_INVALID | all is not valid
VX_AUTOINC_ARC | Include arc.
VX_AUTOINC_CIRCLE | Include circle.
VX_AUTOINC_HOLE | Include hole.
VX_AUTOINC_LINE | Include line.
VX_AUTOINC_HOLE_CALLOUT | Include Hole callout
VX_AUTOINC_CYLIND_DIM | Include cylindrical dimensions.
VX_AUTOINC_MAXIMUM_DIM | Include maximum dimensions.
VX_AUTOINC_VALID | all is valid

Definition at line 675 of file zwapi_cmd_dwg_data.h.

676 {
677 VX_AUTOINC_INVALID = 0x00000000,
678 VX_AUTOINC_ARC = 0x00000001,
679 VX_AUTOINC_CIRCLE = 0x00000002,
680 VX_AUTOINC_HOLE = 0x00000004,
681 VX_AUTOINC_LINE = 0x00000008,
682 VX_AUTOINC_HOLE_CALLOUT = 0x00000010,
683 VX_AUTOINC_CYLIND_DIM = 0x00000020,
684 VX_AUTOINC_MAXIMUM_DIM = 0x00000040,
685 VX_AUTOINC_VALID = 0xFFFFFFFF
686 } evxAutoInclude;
evxAutoInclude
evxAutoInclude
auto dimension include
Definition: zwapi_cmd_dwg_data.h:676
VX_AUTOINC_ARC
@ VX_AUTOINC_ARC
Include arc.
Definition: zwapi_cmd_dwg_data.h:678
VX_AUTOINC_HOLE_CALLOUT
@ VX_AUTOINC_HOLE_CALLOUT
Include Hole callout
Definition: zwapi_cmd_dwg_data.h:682
VX_AUTOINC_LINE
@ VX_AUTOINC_LINE
Include line.
Definition: zwapi_cmd_dwg_data.h:681
VX_AUTOINC_MAXIMUM_DIM
@ VX_AUTOINC_MAXIMUM_DIM
Include maximum dimensions.
Definition: zwapi_cmd_dwg_data.h:684
VX_AUTOINC_CYLIND_DIM
@ VX_AUTOINC_CYLIND_DIM
Include cylindrical dimensions.
Definition: zwapi_cmd_dwg_data.h:683
VX_AUTOINC_VALID
@ VX_AUTOINC_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:685
VX_AUTOINC_CIRCLE
@ VX_AUTOINC_CIRCLE
Include circle.
Definition: zwapi_cmd_dwg_data.h:679
VX_AUTOINC_INVALID
@ VX_AUTOINC_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:677
VX_AUTOINC_HOLE
@ VX_AUTOINC_HOLE
Include hole.
Definition: zwapi_cmd_dwg_data.h:680
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCenterLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxCenterLineType

enum evxCenterLineType

#include <zwapi_cmd_dwg_data.h>

centerline type

Enumerator
VX_CL_BY_TWO_LINES | draw by two lines(Based to curve)
VX_CL_BY_TWO_POINTS | draw by two points(Based on pick point)

Definition at line 1351 of file zwapi_cmd_dwg_data.h.

1352 {
1353 VX_CL_BY_TWO_LINES = 1,
1354 VX_CL_BY_TWO_POINTS,
1355 }evxCenterLineType;
evxCenterLineType
evxCenterLineType
centerline type
Definition: zwapi_cmd_dwg_data.h:1352
VX_CL_BY_TWO_POINTS
@ VX_CL_BY_TWO_POINTS
draw by two points(Based on pick point)
Definition: zwapi_cmd_dwg_data.h:1354
VX_CL_BY_TWO_LINES
@ VX_CL_BY_TWO_LINES
draw by two lines(Based to curve)
Definition: zwapi_cmd_dwg_data.h:1353
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgStkBlnPtn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgStkBlnPtn

enum evxDwgStkBlnPtn

#include <zwapi_cmd_dwg_data.h>

pattern of stack balloons

Enumerator
VX_STKBLNPAT_HORRIGHT | horizontal right
VX_STKBLNPAT_HORLEFT | horizontal left
VX_STKBLNPAT_VERUP | vertical up
VX_STKBLNPAT_VERDOWN | vertical down

Definition at line 1180 of file zwapi_cmd_dwg_data.h.

1181 {
1182 VX_STKBLNPAT_HORRIGHT = 1,
1183 VX_STKBLNPAT_HORLEFT,
1184 VX_STKBLNPAT_VERUP,
1185 VX_STKBLNPAT_VERDOWN
1186 } evxDwgStkBlnPtn;
evxDwgStkBlnPtn
evxDwgStkBlnPtn
pattern of stack balloons
Definition: zwapi_cmd_dwg_data.h:1181
VX_STKBLNPAT_HORRIGHT
@ VX_STKBLNPAT_HORRIGHT
horizontal right
Definition: zwapi_cmd_dwg_data.h:1182
VX_STKBLNPAT_VERUP
@ VX_STKBLNPAT_VERUP
vertical up
Definition: zwapi_cmd_dwg_data.h:1184
VX_STKBLNPAT_VERDOWN
@ VX_STKBLNPAT_VERDOWN
vertical down
Definition: zwapi_cmd_dwg_data.h:1185
VX_STKBLNPAT_HORLEFT
@ VX_STKBLNPAT_HORLEFT
horizontal left
Definition: zwapi_cmd_dwg_data.h:1183
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxWeldContourSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxWeldContourSym

enum evxWeldContourSym

#include <zwapi_cmd_dwg_data.h>

contour symbol of weld symbol

Enumerator
VX_WELD_COUNTOUR_NONE | none
VX_WELD_COUNTOUR_FLAT | flat
VX_WELD_COUNTOUR_CONVEX | convex
VX_WELD_COUNTOUR_CONCAVE | concave
VX_WELD_COUNTOUR_BLEND_TOES | blended toes
VX_WELD_COUNTOUR_STRIP_PERMANENT | backing strip permanent
VX_WELD_COUNTOUR_STRIP_REMOVABLE | backing strip removable

Definition at line 1392 of file zwapi_cmd_dwg_data.h.

1393 {
1394 VX_WELD_COUNTOUR_NONE = 1,
1395 VX_WELD_COUNTOUR_FLAT,
1396 VX_WELD_COUNTOUR_CONVEX,
1397 VX_WELD_COUNTOUR_CONCAVE,
1398 VX_WELD_COUNTOUR_BLEND_TOES,
1399 VX_WELD_COUNTOUR_STRIP_PERMANENT,
1400 VX_WELD_COUNTOUR_STRIP_REMOVABLE,
1401 } evxWeldContourSym;
evxWeldContourSym
evxWeldContourSym
contour symbol of weld symbol
Definition: zwapi_cmd_dwg_data.h:1393
VX_WELD_COUNTOUR_FLAT
@ VX_WELD_COUNTOUR_FLAT
flat
Definition: zwapi_cmd_dwg_data.h:1395
VX_WELD_COUNTOUR_CONCAVE
@ VX_WELD_COUNTOUR_CONCAVE
concave
Definition: zwapi_cmd_dwg_data.h:1397
VX_WELD_COUNTOUR_BLEND_TOES
@ VX_WELD_COUNTOUR_BLEND_TOES
blended toes
Definition: zwapi_cmd_dwg_data.h:1398
VX_WELD_COUNTOUR_NONE
@ VX_WELD_COUNTOUR_NONE
none
Definition: zwapi_cmd_dwg_data.h:1394
VX_WELD_COUNTOUR_STRIP_REMOVABLE
@ VX_WELD_COUNTOUR_STRIP_REMOVABLE
backing strip removable
Definition: zwapi_cmd_dwg_data.h:1400
VX_WELD_COUNTOUR_CONVEX
@ VX_WELD_COUNTOUR_CONVEX
convex
Definition: zwapi_cmd_dwg_data.h:1396
VX_WELD_COUNTOUR_STRIP_PERMANENT
@ VX_WELD_COUNTOUR_STRIP_PERMANENT
backing strip permanent
Definition: zwapi_cmd_dwg_data.h:1399
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCentDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxCentDimType

enum evxCentDimType

#include <zwapi_cmd_dwg_data.h>

center mark type

Enumerator
VX_DM_CENMARK | Center Mark: create a center mark at an arc or circle.
VX_DM_CENLINE | Center Mark Circle: place a centerline through a circular pattern such as bolt holes.
VX_DM_CENDLINE | Center Line: create a centerline mark between lines, arcs or circle.

Definition at line 1305 of file zwapi_cmd_dwg_data.h.

1306 {
1307 VX_DM_CENMARK = 1,
1308 VX_DM_CENLINE,
1309 VX_DM_CENDLINE
1310 }evxCentDimType;
evxCentDimType
evxCentDimType
center mark type
Definition: zwapi_cmd_dwg_data.h:1306
VX_DM_CENDLINE
@ VX_DM_CENDLINE
Center Line: create a centerline mark between lines, arcs or circle.
Definition: zwapi_cmd_dwg_data.h:1309
VX_DM_CENMARK
@ VX_DM_CENMARK
Center Mark: create a center mark at an arc or circle.
Definition: zwapi_cmd_dwg_data.h:1307
VX_DM_CENLINE
@ VX_DM_CENLINE
Center Mark Circle: place a centerline through a circular pattern such as bolt holes.
Definition: zwapi_cmd_dwg_data.h:1308
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxBalloonCon

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxBalloonCon

enum evxBalloonCon

#include <zwapi_cmd_dwg_data.h>

balloon text Condition

Enumerator
VX_BALLOON_CON_USERTEXT | user text
VX_BALLOON_CON_ID | id
VX_BALLOON_CON_NAME | name
VX_BALLOON_CON_NUMBER | number
VX_BALLOON_CON_CLASS | class
VX_BALLOON_CON_DESIGNER | designer
VX_BALLOON_CON_COST | cost
VX_BALLOON_CON_SUPPLIER | supplier
VX_BALLOON_CON_MATERIAL | material
VX_BALLOON_CON_QUANTITY | quantity
VX_BALLOON_CON_MANAGER | manager
VX_BALLOON_CON_REMARKS | remarks
VX_BALLOON_CON_DESCRIPTION | description
VX_BALLOON_CON_KEYWORDS | keywords
VX_BALLOON_CON_DERIVEDFROM | derived from
VX_BALLOON_CON_STARTDATE | start date
VX_BALLOON_CON_ENDDATE | end date
VX_BALLOON_CON_MASS | mass
VX_BALLOON_CON_VOLUME | volume
VX_BALLOON_CON_TOTALMASS | total mass
VX_BALLOON_CON_DENSITY | density
VX_BALLOON_CON_PARTCFG | part config
VX_BALLOON_CON_FILEPATH | source file path
VX_BALLOON_CON_SIZE | size
VX_BALLOON_CON_LENGTH | length
VX_BALLOON_CON_WIDTH | width
VX_BALLOON_CON_HEIGHT | height
VX_BALLOON_CON_AREA | area
VX_BALLOON_CON_LEGEND | legend
VX_BALLOON_CON_STOCKSIZE | stock size
VX_BALLOON_CON_VISIBLE | visible
Examples
drawing\dwgDimTest.cpp.

Definition at line 1028 of file zwapi_cmd_dwg_data.h.

1029 {
1030 VX_BALLOON_CON_USERTEXT = 0,
1031 VX_BALLOON_CON_ID = 1,
1032 VX_BALLOON_CON_NAME = 2,
1033 VX_BALLOON_CON_NUMBER = 3,
1034 VX_BALLOON_CON_CLASS,
1035 VX_BALLOON_CON_DESIGNER,
1036 VX_BALLOON_CON_COST,
1037 VX_BALLOON_CON_SUPPLIER,
1038 VX_BALLOON_CON_MATERIAL,
1039 VX_BALLOON_CON_QUANTITY,
1040 VX_BALLOON_CON_MANAGER,
1041 VX_BALLOON_CON_REMARKS,
1042 VX_BALLOON_CON_DESCRIPTION,
1043 VX_BALLOON_CON_KEYWORDS,
1044 VX_BALLOON_CON_DERIVEDFROM,
1045 VX_BALLOON_CON_STARTDATE,
1046 VX_BALLOON_CON_ENDDATE,
1047 VX_BALLOON_CON_MASS,
1048 VX_BALLOON_CON_VOLUME,
1049 VX_BALLOON_CON_TOTALMASS,
1050 VX_BALLOON_CON_DENSITY,
1051 VX_BALLOON_CON_PARTCFG,
1052 VX_BALLOON_CON_FILEPATH,
1053 VX_BALLOON_CON_SIZE,
1054 VX_BALLOON_CON_LENGTH,
1055 VX_BALLOON_CON_WIDTH,
1056 VX_BALLOON_CON_HEIGHT,
1057 VX_BALLOON_CON_AREA,
1058 VX_BALLOON_CON_LEGEND,
1059 VX_BALLOON_CON_STOCKSIZE,
1060 VX_BALLOON_CON_VISIBLE,
1061 } evxBalloonCon;
evxBalloonCon
evxBalloonCon
balloon text Condition
Definition: zwapi_cmd_dwg_data.h:1029
VX_BALLOON_CON_CLASS
@ VX_BALLOON_CON_CLASS
class
Definition: zwapi_cmd_dwg_data.h:1034
VX_BALLOON_CON_HEIGHT
@ VX_BALLOON_CON_HEIGHT
height
Definition: zwapi_cmd_dwg_data.h:1056
VX_BALLOON_CON_DENSITY
@ VX_BALLOON_CON_DENSITY
density
Definition: zwapi_cmd_dwg_data.h:1050
VX_BALLOON_CON_STARTDATE
@ VX_BALLOON_CON_STARTDATE
start date
Definition: zwapi_cmd_dwg_data.h:1045
VX_BALLOON_CON_MASS
@ VX_BALLOON_CON_MASS
mass
Definition: zwapi_cmd_dwg_data.h:1047
VX_BALLOON_CON_ENDDATE
@ VX_BALLOON_CON_ENDDATE
end date
Definition: zwapi_cmd_dwg_data.h:1046
VX_BALLOON_CON_PARTCFG
@ VX_BALLOON_CON_PARTCFG
part config
Definition: zwapi_cmd_dwg_data.h:1051
VX_BALLOON_CON_USERTEXT
@ VX_BALLOON_CON_USERTEXT
user text
Definition: zwapi_cmd_dwg_data.h:1030
VX_BALLOON_CON_MANAGER
@ VX_BALLOON_CON_MANAGER
manager
Definition: zwapi_cmd_dwg_data.h:1040
VX_BALLOON_CON_DESCRIPTION
@ VX_BALLOON_CON_DESCRIPTION
description
Definition: zwapi_cmd_dwg_data.h:1042
VX_BALLOON_CON_TOTALMASS
@ VX_BALLOON_CON_TOTALMASS
total mass
Definition: zwapi_cmd_dwg_data.h:1049
VX_BALLOON_CON_DESIGNER
@ VX_BALLOON_CON_DESIGNER
designer
Definition: zwapi_cmd_dwg_data.h:1035
VX_BALLOON_CON_MATERIAL
@ VX_BALLOON_CON_MATERIAL
material
Definition: zwapi_cmd_dwg_data.h:1038
VX_BALLOON_CON_LENGTH
@ VX_BALLOON_CON_LENGTH
length
Definition: zwapi_cmd_dwg_data.h:1054
VX_BALLOON_CON_STOCKSIZE
@ VX_BALLOON_CON_STOCKSIZE
stock size
Definition: zwapi_cmd_dwg_data.h:1059
VX_BALLOON_CON_DERIVEDFROM
@ VX_BALLOON_CON_DERIVEDFROM
derived from
Definition: zwapi_cmd_dwg_data.h:1044
VX_BALLOON_CON_VOLUME
@ VX_BALLOON_CON_VOLUME
volume
Definition: zwapi_cmd_dwg_data.h:1048
VX_BALLOON_CON_FILEPATH
@ VX_BALLOON_CON_FILEPATH
source file path
Definition: zwapi_cmd_dwg_data.h:1052
VX_BALLOON_CON_VISIBLE
@ VX_BALLOON_CON_VISIBLE
visible
Definition: zwapi_cmd_dwg_data.h:1060
VX_BALLOON_CON_QUANTITY
@ VX_BALLOON_CON_QUANTITY
quantity
Definition: zwapi_cmd_dwg_data.h:1039
VX_BALLOON_CON_COST
@ VX_BALLOON_CON_COST
cost
Definition: zwapi_cmd_dwg_data.h:1036
VX_BALLOON_CON_ID
@ VX_BALLOON_CON_ID
id
Definition: zwapi_cmd_dwg_data.h:1031
VX_BALLOON_CON_WIDTH
@ VX_BALLOON_CON_WIDTH
width
Definition: zwapi_cmd_dwg_data.h:1055
VX_BALLOON_CON_NAME
@ VX_BALLOON_CON_NAME
name
Definition: zwapi_cmd_dwg_data.h:1032
VX_BALLOON_CON_AREA
@ VX_BALLOON_CON_AREA
area
Definition: zwapi_cmd_dwg_data.h:1057
VX_BALLOON_CON_SIZE
@ VX_BALLOON_CON_SIZE
size
Definition: zwapi_cmd_dwg_data.h:1053
VX_BALLOON_CON_LEGEND
@ VX_BALLOON_CON_LEGEND
legend
Definition: zwapi_cmd_dwg_data.h:1058
VX_BALLOON_CON_SUPPLIER
@ VX_BALLOON_CON_SUPPLIER
supplier
Definition: zwapi_cmd_dwg_data.h:1037
VX_BALLOON_CON_KEYWORDS
@ VX_BALLOON_CON_KEYWORDS
keywords
Definition: zwapi_cmd_dwg_data.h:1043
VX_BALLOON_CON_NUMBER
@ VX_BALLOON_CON_NUMBER
number
Definition: zwapi_cmd_dwg_data.h:1033
VX_BALLOON_CON_REMARKS
@ VX_BALLOON_CON_REMARKS
remarks
Definition: zwapi_cmd_dwg_data.h:1041
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxViewPrjAngType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxViewPrjAngType

enum evxViewPrjAngType

#include <zwapi_cmd_dwg_data.h>

view projection type

Enumerator
VX_VIEW_PRJANG1ST | 1st angle
VX_VIEW_PRJANG3RD | 3rd angle

Definition at line 224 of file zwapi_cmd_dwg_data.h.

225 {
226 VX_VIEW_PRJANG1ST = 1,
227 VX_VIEW_PRJANG3RD = 2,
228 } evxViewPrjAngType;
evxViewPrjAngType
evxViewPrjAngType
view projection type
Definition: zwapi_cmd_dwg_data.h:225
VX_VIEW_PRJANG3RD
@ VX_VIEW_PRJANG3RD
3rd angle
Definition: zwapi_cmd_dwg_data.h:227
VX_VIEW_PRJANG1ST
@ VX_VIEW_PRJANG1ST
1st angle
Definition: zwapi_cmd_dwg_data.h:226
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgBndMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgBndMethod

enum evxDwgBndMethod

#include <zwapi_cmd_dwg_data.h>

Drawing Broken Section Boundary Method.

Enumerator
VX_RECTANGULAR_BOUNDARY | Rectangular boundary.
VX_CIRCULAR_BOUNDARY | Circular boundary.
VX_POLYLINE_BOUNDARY | Polyline boundary.

Definition at line 395 of file zwapi_cmd_dwg_data.h.

396 {
397 VX_RECTANGULAR_BOUNDARY = 1,
398 VX_CIRCULAR_BOUNDARY,
399 VX_POLYLINE_BOUNDARY,
400 } evxDwgBndMethod;
evxDwgBndMethod
evxDwgBndMethod
Drawing Broken Section Boundary Method.
Definition: zwapi_cmd_dwg_data.h:396
VX_RECTANGULAR_BOUNDARY
@ VX_RECTANGULAR_BOUNDARY
Rectangular boundary.
Definition: zwapi_cmd_dwg_data.h:397
VX_CIRCULAR_BOUNDARY
@ VX_CIRCULAR_BOUNDARY
Circular boundary.
Definition: zwapi_cmd_dwg_data.h:398
VX_POLYLINE_BOUNDARY
@ VX_POLYLINE_BOUNDARY
Polyline boundary.
Definition: zwapi_cmd_dwg_data.h:399
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSurfPtnSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxSurfPtnSym

enum evxSurfPtnSym

#include <zwapi_cmd_dwg_data.h>

pattern symbol of surface roughness

Enumerator
VX_SURF_PTNSYM_NONE | none
VX_SURF_PTNSYM_RADIAL | radial
VX_SURF_PTNSYM_PERPENDICULAR | perpendicular
VX_SURF_PTNSYM_ANGULAR | angular
VX_SURF_PTNSYM_MULTI_DIR | multi-directional
VX_SURF_PTNSYM_CIRCULAR | circular
VX_SURF_PTNSYM_PARALLEL | parallel
VX_SURF_PTNSYM_PARTICULATE | particulate

Definition at line 1468 of file zwapi_cmd_dwg_data.h.

1469 {
1470 VX_SURF_PTNSYM_NONE = 0,
1471 VX_SURF_PTNSYM_RADIAL,
1472 VX_SURF_PTNSYM_PERPENDICULAR,
1473 VX_SURF_PTNSYM_ANGULAR,
1474 VX_SURF_PTNSYM_MULTI_DIR,
1475 VX_SURF_PTNSYM_CIRCULAR,
1476 VX_SURF_PTNSYM_PARALLEL,
1477 VX_SURF_PTNSYM_PARTICULATE
1478 } evxSurfPtnSym;
evxSurfPtnSym
evxSurfPtnSym
pattern symbol of surface roughness
Definition: zwapi_cmd_dwg_data.h:1469
VX_SURF_PTNSYM_PARTICULATE
@ VX_SURF_PTNSYM_PARTICULATE
particulate
Definition: zwapi_cmd_dwg_data.h:1477
VX_SURF_PTNSYM_MULTI_DIR
@ VX_SURF_PTNSYM_MULTI_DIR
multi-directional
Definition: zwapi_cmd_dwg_data.h:1474
VX_SURF_PTNSYM_RADIAL
@ VX_SURF_PTNSYM_RADIAL
radial
Definition: zwapi_cmd_dwg_data.h:1471
VX_SURF_PTNSYM_PERPENDICULAR
@ VX_SURF_PTNSYM_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_dwg_data.h:1472
VX_SURF_PTNSYM_PARALLEL
@ VX_SURF_PTNSYM_PARALLEL
parallel
Definition: zwapi_cmd_dwg_data.h:1476
VX_SURF_PTNSYM_ANGULAR
@ VX_SURF_PTNSYM_ANGULAR
angular
Definition: zwapi_cmd_dwg_data.h:1473
VX_SURF_PTNSYM_CIRCULAR
@ VX_SURF_PTNSYM_CIRCULAR
circular
Definition: zwapi_cmd_dwg_data.h:1475
VX_SURF_PTNSYM_NONE
@ VX_SURF_PTNSYM_NONE
none
Definition: zwapi_cmd_dwg_data.h:1470
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxViewLocationType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxViewLocationType

enum evxViewLocationType

#include <zwapi_cmd_dwg_data.h>

drawing view location type

Enumerator
VX_LOCATION_AUTO | automatic set-up
VX_LOCATION_CENTER | set center point
VX_LOCATION_CORNER | set corner points

Definition at line 34 of file zwapi_cmd_dwg_data.h.

35 {
36 VX_LOCATION_AUTO,
37 VX_LOCATION_CENTER,
38 VX_LOCATION_CORNER,
39 } evxViewLocationType;
evxViewLocationType
evxViewLocationType
drawing view location type
Definition: zwapi_cmd_dwg_data.h:35
VX_LOCATION_CENTER
@ VX_LOCATION_CENTER
set center point
Definition: zwapi_cmd_dwg_data.h:37
VX_LOCATION_AUTO
@ VX_LOCATION_AUTO
automatic set-up
Definition: zwapi_cmd_dwg_data.h:36
VX_LOCATION_CORNER
@ VX_LOCATION_CORNER
set corner points
Definition: zwapi_cmd_dwg_data.h:38
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDatumTargDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDatumTargDimType

enum evxDatumTargDimType

#include <zwapi_cmd_dwg_data.h>

datum target dim type

Enumerator
VX_DATUMT_CIRCLE | datum target - Circle
VX_DATUMT_RECTANGLE | datum target - Rectangle
VX_DATUMT_LINE | datum target - Line
VX_DATUMT_POINT | datum target - Point

Definition at line 1249 of file zwapi_cmd_dwg_data.h.

1250 {
1251 VX_DATUMT_CIRCLE = 0,
1252 VX_DATUMT_RECTANGLE = 1,
1253 VX_DATUMT_LINE = 2,
1254 VX_DATUMT_POINT = 3,
1255 } evxDatumTargDimType;
evxDatumTargDimType
evxDatumTargDimType
datum target dim type
Definition: zwapi_cmd_dwg_data.h:1250
VX_DATUMT_POINT
@ VX_DATUMT_POINT
datum target - Point
Definition: zwapi_cmd_dwg_data.h:1254
VX_DATUMT_CIRCLE
@ VX_DATUMT_CIRCLE
datum target - Circle
Definition: zwapi_cmd_dwg_data.h:1251
VX_DATUMT_LINE
@ VX_DATUMT_LINE
datum target - Line
Definition: zwapi_cmd_dwg_data.h:1253
VX_DATUMT_RECTANGLE
@ VX_DATUMT_RECTANGLE
datum target - Rectangle
Definition: zwapi_cmd_dwg_data.h:1252
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxLocAngType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxLocAngType

enum evxLocAngType

#include <zwapi_cmd_dwg_data.h>

location angle

Enumerator
VX_LOC_ANG_DEFAULT | default
VX_LOC_ANG_HORIZONTAL | horizontal
VX_LOC_ANG_VERTICAL | vertical
VX_LOC_ANG_CUSTOM | custom

Definition at line 304 of file zwapi_cmd_dwg_data.h.

305 {
306 VX_LOC_ANG_DEFAULT = 0,
307 VX_LOC_ANG_HORIZONTAL = 1,
308 VX_LOC_ANG_VERTICAL = 2,
309 VX_LOC_ANG_CUSTOM = 3,
310 } evxLocAngType;
evxLocAngType
evxLocAngType
location angle
Definition: zwapi_cmd_dwg_data.h:305
VX_LOC_ANG_DEFAULT
@ VX_LOC_ANG_DEFAULT
default
Definition: zwapi_cmd_dwg_data.h:306
VX_LOC_ANG_CUSTOM
@ VX_LOC_ANG_CUSTOM
custom
Definition: zwapi_cmd_dwg_data.h:309
VX_LOC_ANG_HORIZONTAL
@ VX_LOC_ANG_HORIZONTAL
horizontal
Definition: zwapi_cmd_dwg_data.h:307
VX_LOC_ANG_VERTICAL
@ VX_LOC_ANG_VERTICAL
vertical
Definition: zwapi_cmd_dwg_data.h:308
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSymmetryDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxSymmetryDimType

enum evxSymmetryDimType

#include <zwapi_cmd_dwg_data.h>

symmetry dimension type

Enumerator
VX_SYM_LINEAR | linear dimension
VX_SYM_ANGULAR | angular dimension

Definition at line 785 of file zwapi_cmd_dwg_data.h.

786 {
787 VX_SYM_LINEAR = 1,
788 VX_SYM_ANGULAR = 2,
789 } evxSymmetryDimType;
evxSymmetryDimType
evxSymmetryDimType
symmetry dimension type
Definition: zwapi_cmd_dwg_data.h:786
VX_SYM_ANGULAR
@ VX_SYM_ANGULAR
angular dimension
Definition: zwapi_cmd_dwg_data.h:788
VX_SYM_LINEAR
@ VX_SYM_LINEAR
linear dimension
Definition: zwapi_cmd_dwg_data.h:787
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgHoleMarkType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Commands Data
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ evxDwgHoleMarkType

enum evxDwgHoleMarkType

#include <zwapi_cmd_dwg_data.h>

drawing sheet hole mark method

Enumerator
VX_DWG_HOLE_MARK_AUTO | auto pick
VX_DWG_HOLE_MARK_MANUAL | manual pick

Definition at line 1536 of file zwapi_cmd_dwg_data.h.

1537 {
1538 VX_DWG_HOLE_MARK_AUTO,
1539 VX_DWG_HOLE_MARK_MANUAL,
1540 } evxDwgHoleMarkType;
evxDwgHoleMarkType
evxDwgHoleMarkType
drawing sheet hole mark method
Definition: zwapi_cmd_dwg_data.h:1537
VX_DWG_HOLE_MARK_AUTO
@ VX_DWG_HOLE_MARK_AUTO
auto pick
Definition: zwapi_cmd_dwg_data.h:1538
VX_DWG_HOLE_MARK_MANUAL
@ VX_DWG_HOLE_MARK_MANUAL
manual pick
Definition: zwapi_cmd_dwg_data.h:1539
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxEcadRgnOwner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ECAD Board Commands Data
evxEcadRgnOwner
evxEcadRgnOwner
evxEcadRgnSetType
evxEcadRgnSetType
svxEcadRgnSetData

◆ evxEcadRgnOwner

enum evxEcadRgnOwner

#include <zwapi_cmd_ecadboard_data.h>

region owner

Enumerator
VX_MCAD_RGN | MCAD region.
VX_ECAD_RGN | ECAD region.
VX_UNOWNED_RGN | unowned region

Definition at line 45 of file zwapi_cmd_ecadboard_data.h.

46 {
47 VX_MCAD_RGN = 0,
48 VX_ECAD_RGN = 1,
49 VX_UNOWNED_RGN = 2,
50 }evxEcadRgnOwner;
evxEcadRgnOwner
evxEcadRgnOwner
region owner
Definition: zwapi_cmd_ecadboard_data.h:46
VX_MCAD_RGN
@ VX_MCAD_RGN
MCAD region.
Definition: zwapi_cmd_ecadboard_data.h:47
VX_UNOWNED_RGN
@ VX_UNOWNED_RGN
unowned region
Definition: zwapi_cmd_ecadboard_data.h:49
VX_ECAD_RGN
@ VX_ECAD_RGN
ECAD region.
Definition: zwapi_cmd_ecadboard_data.h:48
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxEcadRgnSetType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • ECAD Board Commands Data
evxEcadRgnOwner
evxEcadRgnOwner
evxEcadRgnSetType
evxEcadRgnSetType
svxEcadRgnSetData

◆ evxEcadRgnSetType

enum evxEcadRgnSetType

#include <zwapi_cmd_ecadboard_data.h>

region setting type

Enumerator
VX_ROUTING_RGN | routing region
VX_PLACEMENT_RGN | placement region
VX_VIA_RGN | via region
VX_OTHER_RGN | other region
VX_PLACEMENT_GRP_RGN | placement group region

Definition at line 32 of file zwapi_cmd_ecadboard_data.h.

33 {
34 VX_ROUTING_RGN = 0,
35 VX_PLACEMENT_RGN = 1,
36 VX_VIA_RGN = 2,
37 VX_OTHER_RGN = 3,
38 VX_PLACEMENT_GRP_RGN = 4,
39 }evxEcadRgnSetType;
evxEcadRgnSetType
evxEcadRgnSetType
region setting type
Definition: zwapi_cmd_ecadboard_data.h:33
VX_OTHER_RGN
@ VX_OTHER_RGN
other region
Definition: zwapi_cmd_ecadboard_data.h:37
VX_PLACEMENT_GRP_RGN
@ VX_PLACEMENT_GRP_RGN
placement group region
Definition: zwapi_cmd_ecadboard_data.h:38
VX_VIA_RGN
@ VX_VIA_RGN
via region
Definition: zwapi_cmd_ecadboard_data.h:36
VX_PLACEMENT_RGN
@ VX_PLACEMENT_RGN
placement region
Definition: zwapi_cmd_ecadboard_data.h:35
VX_ROUTING_RGN
@ VX_ROUTING_RGN
routing region
Definition: zwapi_cmd_ecadboard_data.h:34
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxEdgeExtensionType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxEdgeExtensionType

enum evxEdgeExtensionType

#include <zwapi_cmd_freeform_data.h>

edge extension type

Enumerator
VX_EDGE_EXTENSION_TANGENT | tangent
VX_EDGE_EXTENSION_ORTHOGONAL | orthogonal
Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 447 of file zwapi_cmd_freeform_data.h.

448 {
449 VX_EDGE_EXTENSION_TANGENT = 0,
450 VX_EDGE_EXTENSION_ORTHOGONAL,
451 }evxEdgeExtensionType;
evxEdgeExtensionType
evxEdgeExtensionType
edge extension type
Definition: zwapi_cmd_freeform_data.h:448
VX_EDGE_EXTENSION_TANGENT
@ VX_EDGE_EXTENSION_TANGENT
tangent
Definition: zwapi_cmd_freeform_data.h:449
VX_EDGE_EXTENSION_ORTHOGONAL
@ VX_EDGE_EXTENSION_ORTHOGONAL
orthogonal
Definition: zwapi_cmd_freeform_data.h:450
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCircularBiRailMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxCircularBiRailMethod

enum evxCircularBiRailMethod

#include <zwapi_cmd_freeform_data.h>

circular bi rail method

Enumerator
VX_CIRCULARBIRAIL_CONSTANT | with constant radius between the two path curves
VX_CIRCULARBIRAIL_VARIABLE | with variable radius between the two path curves
VX_CIRCULARBIRAIL_CENTER | radius is defined implicitly by a center curve
VX_CIRCULARBIRAIL_MIDDLE | radius is defined implicitly by a middle curve

Definition at line 167 of file zwapi_cmd_freeform_data.h.

168 {
169 VX_CIRCULARBIRAIL_CONSTANT = 0,
170 VX_CIRCULARBIRAIL_VARIABLE,
171 VX_CIRCULARBIRAIL_CENTER,
172 VX_CIRCULARBIRAIL_MIDDLE,
173 }evxCircularBiRailMethod;
evxCircularBiRailMethod
evxCircularBiRailMethod
circular bi rail method
Definition: zwapi_cmd_freeform_data.h:168
VX_CIRCULARBIRAIL_MIDDLE
@ VX_CIRCULARBIRAIL_MIDDLE
radius is defined implicitly by a middle curve
Definition: zwapi_cmd_freeform_data.h:172
VX_CIRCULARBIRAIL_CENTER
@ VX_CIRCULARBIRAIL_CENTER
radius is defined implicitly by a center curve
Definition: zwapi_cmd_freeform_data.h:171
VX_CIRCULARBIRAIL_VARIABLE
@ VX_CIRCULARBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:170
VX_CIRCULARBIRAIL_CONSTANT
@ VX_CIRCULARBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:169
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSewingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxSewingType

enum evxSewingType

#include <zwapi_cmd_freeform_data.h>

sewing type

Enumerator
VX_SEWING_NOACTION | leave the base faces as is
VX_SEWING_DIVIDE | divide the base faces at the fillet tangents
VX_SEWING_TRIM | divide and trim away the base faces at the fillet tangents
VX_SEWING_SEW | divide, trim and sew the base faces with the fillet faces

Definition at line 55 of file zwapi_cmd_freeform_data.h.

56 {
57 VX_SEWING_NOACTION = 0,
58 VX_SEWING_DIVIDE = 1,
59 VX_SEWING_TRIM = 2,
60 VX_SEWING_SEW = 3,
61 } evxSewingType;
evxSewingType
evxSewingType
sewing type
Definition: zwapi_cmd_freeform_data.h:56
VX_SEWING_SEW
@ VX_SEWING_SEW
divide, trim and sew the base faces with the fillet faces
Definition: zwapi_cmd_freeform_data.h:60
VX_SEWING_DIVIDE
@ VX_SEWING_DIVIDE
divide the base faces at the fillet tangents
Definition: zwapi_cmd_freeform_data.h:58
VX_SEWING_TRIM
@ VX_SEWING_TRIM
divide and trim away the base faces at the fillet tangents
Definition: zwapi_cmd_freeform_data.h:59
VX_SEWING_NOACTION
@ VX_SEWING_NOACTION
leave the base faces as is
Definition: zwapi_cmd_freeform_data.h:57
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxConicBiRailMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxConicBiRailMethod

enum evxConicBiRailMethod

#include <zwapi_cmd_freeform_data.h>

conic bi rail method

Enumerator
VX_CONICBIRAIL_CONSTANT | with constant radius between the two path curves
VX_CONICBIRAIL_VARIABLE | with variable radius between the two path curves
VX_CONICBIRAIL_HOLDER | using a shoulder curve.
VX_CONICBIRAIL_TANGENT | using a tangent curve.
VX_CONICBIRAIL_INTERSECTION | using a tangent curve and a shoulder curve.
VX_CONICBIRAIL_CENTER | using a center curve
VX_CONICBIRAIL_TANGENTEDGES | tangent to two existing face edges.

Definition at line 226 of file zwapi_cmd_freeform_data.h.

227 {
228 VX_CONICBIRAIL_CONSTANT = 0,
229 VX_CONICBIRAIL_VARIABLE,
230 VX_CONICBIRAIL_HOLDER,
231 VX_CONICBIRAIL_TANGENT,
232 VX_CONICBIRAIL_INTERSECTION,
233 VX_CONICBIRAIL_CENTER,
234 VX_CONICBIRAIL_TANGENTEDGES,
235 }evxConicBiRailMethod;
evxConicBiRailMethod
evxConicBiRailMethod
conic bi rail method
Definition: zwapi_cmd_freeform_data.h:227
VX_CONICBIRAIL_INTERSECTION
@ VX_CONICBIRAIL_INTERSECTION
using a tangent curve and a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:232
VX_CONICBIRAIL_CONSTANT
@ VX_CONICBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:228
VX_CONICBIRAIL_CENTER
@ VX_CONICBIRAIL_CENTER
using a center curve
Definition: zwapi_cmd_freeform_data.h:233
VX_CONICBIRAIL_TANGENT
@ VX_CONICBIRAIL_TANGENT
using a tangent curve.
Definition: zwapi_cmd_freeform_data.h:231
VX_CONICBIRAIL_VARIABLE
@ VX_CONICBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:229
VX_CONICBIRAIL_TANGENTEDGES
@ VX_CONICBIRAIL_TANGENTEDGES
tangent to two existing face edges.
Definition: zwapi_cmd_freeform_data.h:234
VX_CONICBIRAIL_HOLDER
@ VX_CONICBIRAIL_HOLDER
using a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:230
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSpineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxSpineType

enum evxSpineType

#include <zwapi_cmd_freeform_data.h>

spine type

Enumerator
VX_SPINE_NATURAL | no drive curve is used
VX_SPINE_SPINE | a spine curve will be used as the drive curve
VX_SPINE_PARALLEL | the face is created by moving an infinite plane containing cross-sections of the face parallel to a plane

Definition at line 32 of file zwapi_cmd_freeform_data.h.

33 {
34 VX_SPINE_NATURAL = 0,
35 VX_SPINE_SPINE = 1,
36 VX_SPINE_PARALLEL = 2,
37 } evxSpineType;
evxSpineType
evxSpineType
spine type
Definition: zwapi_cmd_freeform_data.h:33
VX_SPINE_NATURAL
@ VX_SPINE_NATURAL
no drive curve is used
Definition: zwapi_cmd_freeform_data.h:34
VX_SPINE_PARALLEL
@ VX_SPINE_PARALLEL
the face is created by moving an infinite plane containing cross-sections of the face parallel to a p...
Definition: zwapi_cmd_freeform_data.h:36
VX_SPINE_SPINE
@ VX_SPINE_SPINE
a spine curve will be used as the drive curve
Definition: zwapi_cmd_freeform_data.h:35
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCappingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxCappingType

enum evxCappingType

#include <zwapi_cmd_freeform_data.h>

capping type

Enumerator
VX_CAPPING_MAXIMAL | trim the fillet to the wider pair of face boundaries
VX_CAPPING_MINIMAL | trim the fillet to the narrower pair of face boundaries
VX_CAPPING_TANGENT | create a blended curve matching the tangency of the boundaries of the two supporting faces

Definition at line 67 of file zwapi_cmd_freeform_data.h.

68 {
69 VX_CAPPING_MAXIMAL = 0,
70 VX_CAPPING_MINIMAL = 1,
71 VX_CAPPING_TANGENT = 2,
72 } evxCappingType;
evxCappingType
evxCappingType
capping type
Definition: zwapi_cmd_freeform_data.h:68
VX_CAPPING_MAXIMAL
@ VX_CAPPING_MAXIMAL
trim the fillet to the wider pair of face boundaries
Definition: zwapi_cmd_freeform_data.h:69
VX_CAPPING_TANGENT
@ VX_CAPPING_TANGENT
create a blended curve matching the tangency of the boundaries of the two supporting faces
Definition: zwapi_cmd_freeform_data.h:71
VX_CAPPING_MINIMAL
@ VX_CAPPING_MINIMAL
trim the fillet to the narrower pair of face boundaries
Definition: zwapi_cmd_freeform_data.h:70
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxRefitOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxRefitOpt

enum evxRefitOpt

#include <zwapi_cmd_freeform_data.h>

N-SIDED.

Enumerator
VX_REFIT_NO | none
VX_REFIT_TANGENT | tangent
VX_REFIT_CURVATURE | curvature
VX_REFIT_DIRECT | direct

Definition at line 109 of file zwapi_cmd_freeform_data.h.

110 {
111 VX_REFIT_NO = 0,
112 VX_REFIT_TANGENT = 1,
113 VX_REFIT_CURVATURE = 2,
114 VX_REFIT_DIRECT = 3,
115 } evxRefitOpt;
evxRefitOpt
evxRefitOpt
N-SIDED.
Definition: zwapi_cmd_freeform_data.h:110
VX_REFIT_CURVATURE
@ VX_REFIT_CURVATURE
curvature
Definition: zwapi_cmd_freeform_data.h:113
VX_REFIT_NO
@ VX_REFIT_NO
none
Definition: zwapi_cmd_freeform_data.h:111
VX_REFIT_TANGENT
@ VX_REFIT_TANGENT
tangent
Definition: zwapi_cmd_freeform_data.h:112
VX_REFIT_DIRECT
@ VX_REFIT_DIRECT
direct
Definition: zwapi_cmd_freeform_data.h:114
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxExtendFaceMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxExtendFaceMethod

enum evxExtendFaceMethod

#include <zwapi_cmd_freeform_data.h>

extend face method

Enumerator
VX_EXTEND_FACE_NONE | none
VX_EXTEND_FACE_CLOSE_ENTIRE_GAP | close entire gap
VX_EXTEND_FACE_DIRECT_EDIT | direct edit
Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 457 of file zwapi_cmd_freeform_data.h.

458 {
459 VX_EXTEND_FACE_NONE = 0,
460 VX_EXTEND_FACE_CLOSE_ENTIRE_GAP,
461 VX_EXTEND_FACE_DIRECT_EDIT,
462 }evxExtendFaceMethod;
evxExtendFaceMethod
evxExtendFaceMethod
extend face method
Definition: zwapi_cmd_freeform_data.h:458
VX_EXTEND_FACE_CLOSE_ENTIRE_GAP
@ VX_EXTEND_FACE_CLOSE_ENTIRE_GAP
close entire gap
Definition: zwapi_cmd_freeform_data.h:460
VX_EXTEND_FACE_NONE
@ VX_EXTEND_FACE_NONE
none
Definition: zwapi_cmd_freeform_data.h:459
VX_EXTEND_FACE_DIRECT_EDIT
@ VX_EXTEND_FACE_DIRECT_EDIT
direct edit
Definition: zwapi_cmd_freeform_data.h:461
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxTrimCrvsProjtype

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxTrimCrvsProjtype

enum evxTrimCrvsProjtype

#include <zwapi_cmd_freeform_data.h>

projection types of "trim to curves"

Enumerator
VX_TRIMCRV_IN_PLACE | in place(none)
VX_TRIMCRV_FACE_NORMAL | face normal
VX_TRIMCRV_DIRECTED | directed
VX_TRIMCRV_BI_DIRECTIONAL | bi-directional
Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 351 of file zwapi_cmd_freeform_data.h.

352 {
353 VX_TRIMCRV_IN_PLACE,
354 VX_TRIMCRV_FACE_NORMAL,
355 VX_TRIMCRV_DIRECTED,
356 VX_TRIMCRV_BI_DIRECTIONAL,
357 } evxTrimCrvsProjtype;
evxTrimCrvsProjtype
evxTrimCrvsProjtype
projection types of "trim to curves"
Definition: zwapi_cmd_freeform_data.h:352
VX_TRIMCRV_FACE_NORMAL
@ VX_TRIMCRV_FACE_NORMAL
face normal
Definition: zwapi_cmd_freeform_data.h:354
VX_TRIMCRV_IN_PLACE
@ VX_TRIMCRV_IN_PLACE
in place(none)
Definition: zwapi_cmd_freeform_data.h:353
VX_TRIMCRV_DIRECTED
@ VX_TRIMCRV_DIRECTED
directed
Definition: zwapi_cmd_freeform_data.h:355
VX_TRIMCRV_BI_DIRECTIONAL
@ VX_TRIMCRV_BI_DIRECTIONAL
bi-directional
Definition: zwapi_cmd_freeform_data.h:356
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxExtendShapeMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxExtendShapeMethod

enum evxExtendShapeMethod

#include <zwapi_cmd_freeform_data.h>

extend shape type

Enumerator
VX_EXTEND_OPEN_SHAPE | extend open shape
VX_EXTEND_GENERAL_SHAPE | extend general shape
Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 437 of file zwapi_cmd_freeform_data.h.

438 {
439 VX_EXTEND_OPEN_SHAPE = 0,
440 VX_EXTEND_GENERAL_SHAPE = 1,
441 }evxExtendShapeMethod;
evxExtendShapeMethod
evxExtendShapeMethod
extend shape type
Definition: zwapi_cmd_freeform_data.h:438
VX_EXTEND_GENERAL_SHAPE
@ VX_EXTEND_GENERAL_SHAPE
extend general shape
Definition: zwapi_cmd_freeform_data.h:440
VX_EXTEND_OPEN_SHAPE
@ VX_EXTEND_OPEN_SHAPE
extend open shape
Definition: zwapi_cmd_freeform_data.h:439
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxFaceExtType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxFaceExtType

enum evxFaceExtType

#include <zwapi_cmd_freeform_data.h>

face extension type

Enumerator
VX_FACE_EXT_LINEAR | linear
VX_FACE_EXT_REFLECT | reflect
VX_FACE_EXT_CIRCULAR | circular
VX_FACE_EXT_CURVATURE_DIMINISHING | curvature diminishing
Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 408 of file zwapi_cmd_freeform_data.h.

409 {
410 VX_FACE_EXT_LINEAR = 0,
411 VX_FACE_EXT_REFLECT,
412 VX_FACE_EXT_CIRCULAR,
413 VX_FACE_EXT_CURVATURE_DIMINISHING = 4,
414 }evxFaceExtType;
evxFaceExtType
evxFaceExtType
face extension type
Definition: zwapi_cmd_freeform_data.h:409
VX_FACE_EXT_CIRCULAR
@ VX_FACE_EXT_CIRCULAR
circular
Definition: zwapi_cmd_freeform_data.h:412
VX_FACE_EXT_REFLECT
@ VX_FACE_EXT_REFLECT
reflect
Definition: zwapi_cmd_freeform_data.h:411
VX_FACE_EXT_LINEAR
@ VX_FACE_EXT_LINEAR
linear
Definition: zwapi_cmd_freeform_data.h:410
VX_FACE_EXT_CURVATURE_DIMINISHING
@ VX_FACE_EXT_CURVATURE_DIMINISHING
curvature diminishing
Definition: zwapi_cmd_freeform_data.h:413
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxCroSecType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Free Form Commands Data
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ evxCroSecType

enum evxCroSecType

#include <zwapi_cmd_freeform_data.h>

cross-section type

Enumerator
VX_CRO_SEC_CIRCULAR | create the face using circular arc cross-sections
VX_CRO_SEC_CONIC | create the face using conic arc cross-sections
VX_CRO_SEC_G2BLEND | create the face using G2 Blend cross-sections
VX_CRO_SEC_G3BLEND | create the face using G3 Blend cross-sections

Definition at line 43 of file zwapi_cmd_freeform_data.h.

44 {
45 VX_CRO_SEC_CIRCULAR = 0,
46 VX_CRO_SEC_CONIC = 1,
47 VX_CRO_SEC_G2BLEND = 2,
48 VX_CRO_SEC_G3BLEND = 3,
49 } evxCroSecType;
evxCroSecType
evxCroSecType
cross-section type
Definition: zwapi_cmd_freeform_data.h:44
VX_CRO_SEC_G2BLEND
@ VX_CRO_SEC_G2BLEND
create the face using G2 Blend cross-sections
Definition: zwapi_cmd_freeform_data.h:47
VX_CRO_SEC_G3BLEND
@ VX_CRO_SEC_G3BLEND
create the face using G3 Blend cross-sections
Definition: zwapi_cmd_freeform_data.h:48
VX_CRO_SEC_CIRCULAR
@ VX_CRO_SEC_CIRCULAR
create the face using circular arc cross-sections
Definition: zwapi_cmd_freeform_data.h:45
VX_CRO_SEC_CONIC
@ VX_CRO_SEC_CONIC
create the face using conic arc cross-sections
Definition: zwapi_cmd_freeform_data.h:46
Generated at Sun Apr 23 2023 16:41:42 for the ZWAPIOPEN


ZWAPIOPEN: evxSweepZOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxSweepZOpt

enum evxSweepZOpt

#include <zwapi_cmd_shape_data.h>

sweep Zaxis option

Enumerator
VX_SWP_Z_TANG_TO_PATH | tangent to path (default)
VX_SWP_Z_TANG_TO_CRV | tangent to curve
VX_SWP_Z_FIXED_DIR | parallel with the fixed direction

Definition at line 270 of file zwapi_cmd_shape_data.h.

271 {
272 VX_SWP_Z_TANG_TO_PATH = 0,
273 VX_SWP_Z_TANG_TO_CRV = 1,
274 VX_SWP_Z_FIXED_DIR = 2,
275 } evxSweepZOpt;
evxSweepZOpt
evxSweepZOpt
sweep Zaxis option
Definition: zwapi_cmd_shape_data.h:271
VX_SWP_Z_FIXED_DIR
@ VX_SWP_Z_FIXED_DIR
parallel with the fixed direction
Definition: zwapi_cmd_shape_data.h:274
VX_SWP_Z_TANG_TO_PATH
@ VX_SWP_Z_TANG_TO_PATH
tangent to path (default)
Definition: zwapi_cmd_shape_data.h:272
VX_SWP_Z_TANG_TO_CRV
@ VX_SWP_Z_TANG_TO_CRV
tangent to curve
Definition: zwapi_cmd_shape_data.h:273
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxThreadHoleClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxThreadHoleClass

enum evxThreadHoleClass

#include <zwapi_cmd_shape_data.h>

thread class for flag holes

Enumerator
VX_THREAD_HOLE_UNDEFINED | undefined
VX_THREAD_HOLE_1B | 1B
VX_THREAD_HOLE_2B | 2B
VX_THREAD_HOLE_3B | 3B

Definition at line 772 of file zwapi_cmd_shape_data.h.

773 {
774 VX_THREAD_HOLE_UNDEFINED,
775 VX_THREAD_HOLE_1B,
776 VX_THREAD_HOLE_2B,
777 VX_THREAD_HOLE_3B,
778 } evxThreadHoleClass;
evxThreadHoleClass
evxThreadHoleClass
thread class for flag holes
Definition: zwapi_cmd_shape_data.h:773
VX_THREAD_HOLE_1B
@ VX_THREAD_HOLE_1B
1B
Definition: zwapi_cmd_shape_data.h:775
VX_THREAD_HOLE_UNDEFINED
@ VX_THREAD_HOLE_UNDEFINED
undefined
Definition: zwapi_cmd_shape_data.h:774
VX_THREAD_HOLE_3B
@ VX_THREAD_HOLE_3B
3B
Definition: zwapi_cmd_shape_data.h:777
VX_THREAD_HOLE_2B
@ VX_THREAD_HOLE_2B
2B
Definition: zwapi_cmd_shape_data.h:776
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxOverflowType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxOverflowType

enum evxOverflowType

#include <zwapi_cmd_shape_data.h>

overflow types

Enumerator
VX_OF_AUTOMATIC | automatically choose the faces to extend
VX_OF_CHANGE | extend change face
VX_OF_STATIONARY | extend stationary face
VX_OF_CAP | extend cap face

Definition at line 1106 of file zwapi_cmd_shape_data.h.

1107 {
1108 VX_OF_AUTOMATIC = 0,
1109 VX_OF_CHANGE = 1,
1110 VX_OF_STATIONARY = 2,
1111 VX_OF_CAP = 3,
1112 } evxOverflowType;
evxOverflowType
evxOverflowType
overflow types
Definition: zwapi_cmd_shape_data.h:1107
VX_OF_AUTOMATIC
@ VX_OF_AUTOMATIC
automatically choose the faces to extend
Definition: zwapi_cmd_shape_data.h:1108
VX_OF_CAP
@ VX_OF_CAP
extend cap face
Definition: zwapi_cmd_shape_data.h:1111
VX_OF_STATIONARY
@ VX_OF_STATIONARY
extend stationary face
Definition: zwapi_cmd_shape_data.h:1110
VX_OF_CHANGE
@ VX_OF_CHANGE
extend change face
Definition: zwapi_cmd_shape_data.h:1109
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxOffsetType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxOffsetType

enum evxOffsetType

#include <zwapi_cmd_shape_data.h>

offset type

Enumerator
VX_OFFSET_NONE | none
VX_OFFSET_SHRINK | Shrink / Expand.
VX_OFFSET_THICKEN | Thicken.
VX_OFFSET_THICKEN_SAME | Thicken same.

Definition at line 129 of file zwapi_cmd_shape_data.h.

130 {
131 VX_OFFSET_NONE = 0,
132 VX_OFFSET_SHRINK = 1,
133 VX_OFFSET_THICKEN = 2,
134 VX_OFFSET_THICKEN_SAME = 3,
135 } evxOffsetType;
evxOffsetType
evxOffsetType
offset type
Definition: zwapi_cmd_shape_data.h:130
VX_OFFSET_THICKEN_SAME
@ VX_OFFSET_THICKEN_SAME
Thicken same.
Definition: zwapi_cmd_shape_data.h:134
VX_OFFSET_NONE
@ VX_OFFSET_NONE
none
Definition: zwapi_cmd_shape_data.h:131
VX_OFFSET_THICKEN
@ VX_OFFSET_THICKEN
Thicken.
Definition: zwapi_cmd_shape_data.h:133
VX_OFFSET_SHRINK
@ VX_OFFSET_SHRINK
Shrink / Expand.
Definition: zwapi_cmd_shape_data.h:132
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxClearHoleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxClearHoleType

enum evxClearHoleType

#include <zwapi_cmd_shape_data.h>

hole type of clearance hole

Enumerator
VX_CLEAR_HOLE_SIMPLE | simple
VX_CLEAR_HOLE_COUNT_BORE | counter-Bore
VX_CLEAR_HOLE_COUNT_SINK | counter-sink
VX_CLEAR_HOLE_SLOT | slot
VX_CLEAR_HOLE_COUNT_SINK_SLOT | countersink slot
VX_CLEAR_HOLE_COUNT_BORE_SLOT | counterbore slot

Definition at line 631 of file zwapi_cmd_shape_data.h.

632 {
633 VX_CLEAR_HOLE_SIMPLE = 0,
634 VX_CLEAR_HOLE_COUNT_BORE = 2,
635 VX_CLEAR_HOLE_COUNT_SINK = 3,
636 VX_CLEAR_HOLE_SLOT = 5,
637 VX_CLEAR_HOLE_COUNT_SINK_SLOT = 6,
638 VX_CLEAR_HOLE_COUNT_BORE_SLOT = 7,
639 }evxClearHoleType;
evxClearHoleType
evxClearHoleType
hole type of clearance hole
Definition: zwapi_cmd_shape_data.h:632
VX_CLEAR_HOLE_COUNT_SINK_SLOT
@ VX_CLEAR_HOLE_COUNT_SINK_SLOT
countersink slot
Definition: zwapi_cmd_shape_data.h:637
VX_CLEAR_HOLE_SIMPLE
@ VX_CLEAR_HOLE_SIMPLE
simple
Definition: zwapi_cmd_shape_data.h:633
VX_CLEAR_HOLE_COUNT_BORE_SLOT
@ VX_CLEAR_HOLE_COUNT_BORE_SLOT
counterbore slot
Definition: zwapi_cmd_shape_data.h:638
VX_CLEAR_HOLE_COUNT_SINK
@ VX_CLEAR_HOLE_COUNT_SINK
counter-sink
Definition: zwapi_cmd_shape_data.h:635
VX_CLEAR_HOLE_SLOT
@ VX_CLEAR_HOLE_SLOT
slot
Definition: zwapi_cmd_shape_data.h:636
VX_CLEAR_HOLE_COUNT_BORE
@ VX_CLEAR_HOLE_COUNT_BORE
counter-Bore
Definition: zwapi_cmd_shape_data.h:634
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDraftType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxDraftType

enum evxDraftType

#include <zwapi_cmd_shape_data.h>

draft type

Enumerator
VX_DRAFT_TYPE_NONE | no draft type
VX_SYM_EDGE_DRAFT | Symmetric draft.
VX_ASYM_EDGE_DRAFT | Asymmetric draft.
VX_STATION_SYM_FACE_DRAFT | Stationary symmetric.
VX_STATION_ASYM_FACE_DRAFT | Stationary Asymmetric.
VX_STATION_PARTING_FACE_DRAFT | Stationary and parting.

Definition at line 544 of file zwapi_cmd_shape_data.h.

545 {
546 VX_DRAFT_TYPE_NONE = 0,
547 /* Edge Draft */
548 VX_SYM_EDGE_DRAFT = 1,
549 VX_ASYM_EDGE_DRAFT = 2,
551 /* Face Draft */
552 VX_STATION_SYM_FACE_DRAFT = 3,
553 VX_STATION_ASYM_FACE_DRAFT = 4,
554 VX_STATION_PARTING_FACE_DRAFT = 5,
555 } evxDraftType;
evxDraftType
evxDraftType
draft type
Definition: zwapi_cmd_shape_data.h:545
VX_STATION_ASYM_FACE_DRAFT
@ VX_STATION_ASYM_FACE_DRAFT
Stationary Asymmetric.
Definition: zwapi_cmd_shape_data.h:553
VX_STATION_PARTING_FACE_DRAFT
@ VX_STATION_PARTING_FACE_DRAFT
Stationary and parting.
Definition: zwapi_cmd_shape_data.h:554
VX_ASYM_EDGE_DRAFT
@ VX_ASYM_EDGE_DRAFT
Asymmetric draft.
Definition: zwapi_cmd_shape_data.h:549
VX_DRAFT_TYPE_NONE
@ VX_DRAFT_TYPE_NONE
no draft type
Definition: zwapi_cmd_shape_data.h:546
VX_STATION_SYM_FACE_DRAFT
@ VX_STATION_SYM_FACE_DRAFT
Stationary symmetric.
Definition: zwapi_cmd_shape_data.h:552
VX_SYM_EDGE_DRAFT
@ VX_SYM_EDGE_DRAFT
Symmetric draft.
Definition: zwapi_cmd_shape_data.h:548
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPatternType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxPatternType

enum evxPatternType

#include <zwapi_cmd_shape_data.h>

pattern method

Enumerator
VX_PATTERN_LINEAR | linear pattern
VX_PATTERN_CIRCULAR | circular pattern
VX_PATTERN_PNT_TO_PNT | irregular pattern of objects from point to point
VX_PATTERN_AT_PATTERN | pattern of objects at locations defined by a previous pattern
VX_PATTERN_AT_CURVES | pattern in space using one or more input curves
VX_PATTERN_AT_FACE | pattern in space using an existing surface
VX_PATTERN_POLYGON | polygon pattern
VX_PATTERN_FILL_PATTERN | fill pattern
VX_PATTERN_BY_VAR | feature pattern by variant parameters(just use pattern feature command)

Definition at line 1275 of file zwapi_cmd_shape_data.h.

1276 {
1277 VX_PATTERN_LINEAR,
1278 VX_PATTERN_CIRCULAR,
1279 VX_PATTERN_PNT_TO_PNT,
1280 VX_PATTERN_AT_PATTERN,
1281 VX_PATTERN_AT_CURVES,
1282 VX_PATTERN_AT_FACE,
1283 VX_PATTERN_POLYGON,
1284 VX_PATTERN_FILL_PATTERN,
1285 VX_PATTERN_BY_VAR,
1286 } evxPatternType;
evxPatternType
evxPatternType
pattern method
Definition: zwapi_cmd_shape_data.h:1276
VX_PATTERN_PNT_TO_PNT
@ VX_PATTERN_PNT_TO_PNT
irregular pattern of objects from point to point
Definition: zwapi_cmd_shape_data.h:1279
VX_PATTERN_CIRCULAR
@ VX_PATTERN_CIRCULAR
circular pattern
Definition: zwapi_cmd_shape_data.h:1278
VX_PATTERN_POLYGON
@ VX_PATTERN_POLYGON
polygon pattern
Definition: zwapi_cmd_shape_data.h:1283
VX_PATTERN_FILL_PATTERN
@ VX_PATTERN_FILL_PATTERN
fill pattern
Definition: zwapi_cmd_shape_data.h:1284
VX_PATTERN_AT_FACE
@ VX_PATTERN_AT_FACE
pattern in space using an existing surface
Definition: zwapi_cmd_shape_data.h:1282
VX_PATTERN_AT_PATTERN
@ VX_PATTERN_AT_PATTERN
pattern of objects at locations defined by a previous pattern
Definition: zwapi_cmd_shape_data.h:1280
VX_PATTERN_AT_CURVES
@ VX_PATTERN_AT_CURVES
pattern in space using one or more input curves
Definition: zwapi_cmd_shape_data.h:1281
VX_PATTERN_LINEAR
@ VX_PATTERN_LINEAR
linear pattern
Definition: zwapi_cmd_shape_data.h:1277
VX_PATTERN_BY_VAR
@ VX_PATTERN_BY_VAR
feature pattern by variant parameters(just use pattern feature command)
Definition: zwapi_cmd_shape_data.h:1285
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSweepOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxSweepOpt

enum evxSweepOpt

#include <zwapi_cmd_shape_data.h>

sweep option

Enumerator
VX_SWP_NATURAL | Default frame.
VX_SWP_AT_PATH | At Path.
VX_SWP_FRAME | Selected.
VX_SWP_AT_PROFILE | At intersection.
VX_SWP_ALONG_PATH | Along Path.

Definition at line 245 of file zwapi_cmd_shape_data.h.

246 {
247 VX_SWP_NATURAL = 0,
248 VX_SWP_AT_PATH = 1,
249 VX_SWP_FRAME = 2,
250 VX_SWP_AT_PROFILE = 3,
251 VX_SWP_ALONG_PATH = 4
252 } evxSweepOpt;
evxSweepOpt
evxSweepOpt
sweep option
Definition: zwapi_cmd_shape_data.h:246
VX_SWP_NATURAL
@ VX_SWP_NATURAL
Default frame.
Definition: zwapi_cmd_shape_data.h:247
VX_SWP_AT_PROFILE
@ VX_SWP_AT_PROFILE
At intersection.
Definition: zwapi_cmd_shape_data.h:250
VX_SWP_FRAME
@ VX_SWP_FRAME
Selected.
Definition: zwapi_cmd_shape_data.h:249
VX_SWP_ALONG_PATH
@ VX_SWP_ALONG_PATH
Along Path.
Definition: zwapi_cmd_shape_data.h:251
VX_SWP_AT_PATH
@ VX_SWP_AT_PATH
At Path.
Definition: zwapi_cmd_shape_data.h:248
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFaceFlltType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxFaceFlltType

enum evxFaceFlltType

#include <zwapi_cmd_shape_data.h>

Definition at line 504 of file zwapi_cmd_shape_data.h.

505 {
506 VX_FACE_FFLT_FACE = 0, /* tangent face */
507 VX_FACE_FFLT_RADIUS = 1, /* by radius */
508 }evxFaceFlltType;
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxBoolType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxBoolType

enum evxBoolType

#include <zwapi_cmd_shape_data.h>

boolean combination method

Enumerator
VX_BOOL_NONE | base
VX_BOOL_ADD | add
VX_BOOL_REMOVE | remove
VX_BOOL_INTERSECT | intersect

Definition at line 33 of file zwapi_cmd_shape_data.h.

34 {
35 VX_BOOL_NONE = 0,
36 VX_BOOL_ADD = 1,
37 VX_BOOL_REMOVE = 2,
38 VX_BOOL_INTERSECT = 3
39 } evxBoolType;
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
VX_BOOL_REMOVE
@ VX_BOOL_REMOVE
remove
Definition: zwapi_cmd_shape_data.h:37
VX_BOOL_INTERSECT
@ VX_BOOL_INTERSECT
intersect
Definition: zwapi_cmd_shape_data.h:38
VX_BOOL_ADD
@ VX_BOOL_ADD
add
Definition: zwapi_cmd_shape_data.h:36
VX_BOOL_NONE
@ VX_BOOL_NONE
base
Definition: zwapi_cmd_shape_data.h:35
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxEndCondition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxEndCondition

enum evxEndCondition

#include <zwapi_cmd_shape_data.h>

hole end conditions

Enumerator
VX_BLIND | blind
VX_UNTIL_FACE | until face
VX_THROUGH_ALL | through all

Definition at line 685 of file zwapi_cmd_shape_data.h.

686 {
687 VX_BLIND = 0,
688 VX_UNTIL_FACE = 1,
689 VX_THROUGH_ALL = 2
690 } evxEndCondition;
evxEndCondition
evxEndCondition
hole end conditions
Definition: zwapi_cmd_shape_data.h:686
VX_THROUGH_ALL
@ VX_THROUGH_ALL
through all
Definition: zwapi_cmd_shape_data.h:689
VX_UNTIL_FACE
@ VX_UNTIL_FACE
until face
Definition: zwapi_cmd_shape_data.h:688
VX_BLIND
@ VX_BLIND
blind
Definition: zwapi_cmd_shape_data.h:687
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFaceFlltBaseType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxFaceFlltBaseType

enum evxFaceFlltBaseType

#include <zwapi_cmd_shape_data.h>

Definition at line 511 of file zwapi_cmd_shape_data.h.

512 {
513 VX_FACE_FFLT_BASE_FACE_NONE = 0, /* none */
514 VX_FACE_FFLT_BASE_FACE_SEW = 3, /* sew */
515 }evxFaceFlltBaseType;
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxLeadType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxLeadType

enum evxLeadType

#include <zwapi_cmd_shape_data.h>

lead type

Enumerator
VX_LEAD_IN | transitions the spiral in toward the center of the axis for spiral solids and threaded bosses
VX_LEAD_OUT | transitions the spiral out away from the center of the axis for threaded cuts
VX_LEAD_NONE | no lead in/out applied

Definition at line 141 of file zwapi_cmd_shape_data.h.

142 {
143 VX_LEAD_IN = 0,
144 VX_LEAD_OUT = 1,
145 VX_LEAD_NONE = 2,
146 } evxLeadType;
evxLeadType
evxLeadType
lead type
Definition: zwapi_cmd_shape_data.h:142
VX_LEAD_OUT
@ VX_LEAD_OUT
transitions the spiral out away from the center of the axis for threaded cuts
Definition: zwapi_cmd_shape_data.h:144
VX_LEAD_IN
@ VX_LEAD_IN
transitions the spiral in toward the center of the axis for spiral solids and threaded bosses
Definition: zwapi_cmd_shape_data.h:143
VX_LEAD_NONE
@ VX_LEAD_NONE
no lead in/out applied
Definition: zwapi_cmd_shape_data.h:145
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxHoleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxHoleType

enum evxHoleType

#include <zwapi_cmd_shape_data.h>

hole types

Enumerator
VX_HOLE_SHAPE_ALL | all,used in "flag holes"
VX_HOLE_SIMPLE | simple
VX_HOLE_TAPERED | tapered
VX_HOLE_COUNTER_BORE | counter_bore
VX_HOLE_COUNTER_SUNK | counter_sunk
VX_HOLE_SPOT_FACE | spot_face

Definition at line 617 of file zwapi_cmd_shape_data.h.

618 {
619 VX_HOLE_SHAPE_ALL = -1,
620 VX_HOLE_SIMPLE = 0,
621 VX_HOLE_TAPERED = 1,
622 VX_HOLE_COUNTER_BORE = 2,
623 VX_HOLE_COUNTER_SUNK = 3,
624 VX_HOLE_SPOT_FACE = 4
625 } evxHoleType;
evxHoleType
evxHoleType
hole types
Definition: zwapi_cmd_shape_data.h:618
VX_HOLE_SIMPLE
@ VX_HOLE_SIMPLE
simple
Definition: zwapi_cmd_shape_data.h:620
VX_HOLE_TAPERED
@ VX_HOLE_TAPERED
tapered
Definition: zwapi_cmd_shape_data.h:621
VX_HOLE_SPOT_FACE
@ VX_HOLE_SPOT_FACE
spot_face
Definition: zwapi_cmd_shape_data.h:624
VX_HOLE_COUNTER_SUNK
@ VX_HOLE_COUNTER_SUNK
counter_sunk
Definition: zwapi_cmd_shape_data.h:623
VX_HOLE_SHAPE_ALL
@ VX_HOLE_SHAPE_ALL
all,used in "flag holes"
Definition: zwapi_cmd_shape_data.h:619
VX_HOLE_COUNTER_BORE
@ VX_HOLE_COUNTER_BORE
counter_bore
Definition: zwapi_cmd_shape_data.h:622
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDraftMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxDraftMethods

enum evxDraftMethods

#include <zwapi_cmd_shape_data.h>

draft methods

Enumerator
VX_EDGE_DRAFT | Edge Draft.
VX_FACE_DRAFT | Face Draft.
VX_PRATING_EDGE_DRAFT | Parting Edge Draft.

Definition at line 533 of file zwapi_cmd_shape_data.h.

534 {
535 VX_EDGE_DRAFT = 1,
536 VX_FACE_DRAFT = 2,
537 VX_PRATING_EDGE_DRAFT = 3
538 } evxDraftMethods;
evxDraftMethods
evxDraftMethods
draft methods
Definition: zwapi_cmd_shape_data.h:534
VX_FACE_DRAFT
@ VX_FACE_DRAFT
Face Draft.
Definition: zwapi_cmd_shape_data.h:536
VX_EDGE_DRAFT
@ VX_EDGE_DRAFT
Edge Draft.
Definition: zwapi_cmd_shape_data.h:535
VX_PRATING_EDGE_DRAFT
@ VX_PRATING_EDGE_DRAFT
Parting Edge Draft.
Definition: zwapi_cmd_shape_data.h:537
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxMoveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxMoveType

enum evxMoveType

#include <zwapi_cmd_shape_data.h>

Move and Copy Methods.

Enumerator
VX_PNT_TO_PNT | copy/move entities form point to point
VX_ALONG_DIR | copy/move entities along a direction
VX_ASLIGN_FRAMES | copy/move entities by aligning frames
VX_SWEEP_ALONG_PATH | copy/move entities along path
VX_AROUND_DIR | rotate entities around a direction
VX_DYNAMIC_MOVE | dynamic copy/move entities

Definition at line 1485 of file zwapi_cmd_shape_data.h.

1486 {
1487 VX_PNT_TO_PNT = 1,
1488 VX_ALONG_DIR = 2,
1489 VX_ASLIGN_FRAMES = 3,
1490 VX_SWEEP_ALONG_PATH = 4,
1491 VX_AROUND_DIR = 5,
1492 VX_DYNAMIC_MOVE = 6,
1493 } evxMoveType;
evxMoveType
evxMoveType
Move and Copy Methods.
Definition: zwapi_cmd_shape_data.h:1486
VX_DYNAMIC_MOVE
@ VX_DYNAMIC_MOVE
dynamic copy/move entities
Definition: zwapi_cmd_shape_data.h:1492
VX_SWEEP_ALONG_PATH
@ VX_SWEEP_ALONG_PATH
copy/move entities along path
Definition: zwapi_cmd_shape_data.h:1490
VX_ASLIGN_FRAMES
@ VX_ASLIGN_FRAMES
copy/move entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1489
VX_PNT_TO_PNT
@ VX_PNT_TO_PNT
copy/move entities form point to point
Definition: zwapi_cmd_shape_data.h:1487
VX_AROUND_DIR
@ VX_AROUND_DIR
rotate entities around a direction
Definition: zwapi_cmd_shape_data.h:1491
VX_ALONG_DIR
@ VX_ALONG_DIR
copy/move entities along a direction
Definition: zwapi_cmd_shape_data.h:1488
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSweepXOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxSweepXOpt

enum evxSweepXOpt

#include <zwapi_cmd_shape_data.h>

sweep Xaxis option

Enumerator
VX_SWP_X_MIN_TWIST | minimum twist (default)
VX_SWP_X_FIXED_DIR | fixed direction
VX_SWP_X_XAXIS_CRV | X-axis curve.
VX_SWP_X_FACE_NORMAL | face normal

Definition at line 258 of file zwapi_cmd_shape_data.h.

259 {
260 VX_SWP_X_MIN_TWIST = 0,
261 VX_SWP_X_FIXED_DIR = 1,
262 VX_SWP_X_XAXIS_CRV = 2,
263 VX_SWP_X_FACE_NORMAL = 3,
264 } evxSweepXOpt;
evxSweepXOpt
evxSweepXOpt
sweep Xaxis option
Definition: zwapi_cmd_shape_data.h:259
VX_SWP_X_FACE_NORMAL
@ VX_SWP_X_FACE_NORMAL
face normal
Definition: zwapi_cmd_shape_data.h:263
VX_SWP_X_MIN_TWIST
@ VX_SWP_X_MIN_TWIST
minimum twist (default)
Definition: zwapi_cmd_shape_data.h:260
VX_SWP_X_FIXED_DIR
@ VX_SWP_X_FIXED_DIR
fixed direction
Definition: zwapi_cmd_shape_data.h:261
VX_SWP_X_XAXIS_CRV
@ VX_SWP_X_XAXIS_CRV
X-axis curve.
Definition: zwapi_cmd_shape_data.h:262
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxStockOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxStockOpt

enum evxStockOpt

#include <zwapi_cmd_shape_data.h>

stock type

Enumerator
VX_STOCK_BLOCK | block type
VX_STOCK_CYLINDER | cylinder type

Definition at line 939 of file zwapi_cmd_shape_data.h.

940 {
941 VX_STOCK_BLOCK = 1,
942 VX_STOCK_CYLINDER = 2,
943 } evxStockOpt;
evxStockOpt
evxStockOpt
stock type
Definition: zwapi_cmd_shape_data.h:940
VX_STOCK_BLOCK
@ VX_STOCK_BLOCK
block type
Definition: zwapi_cmd_shape_data.h:941
VX_STOCK_CYLINDER
@ VX_STOCK_CYLINDER
cylinder type
Definition: zwapi_cmd_shape_data.h:942
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFlagThreadDepthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxFlagThreadDepthType

enum evxFlagThreadDepthType

#include <zwapi_cmd_shape_data.h>

flagged as thread hole depth type

Enumerator
VX_FLAG_THREAD_UNDEFINED | undefined
VX_FLAG_THREAD_DEPTH_DEFAULT | default
VX_FLAG_THREAD_DEPTH_1XDIAMETER | 1.0 x diameter
VX_FLAG_THREAD_DEPTH_15XDIAMETER | 1.5 x diameter
VX_FLAG_THREAD_DEPTH_2XDIAMETER | 2.0 x diameter
VX_FLAG_THREAD_DEPTH_25XDIAMETER | 2.5 x diameter
VX_FLAG_THREAD_DEPTH_3XDIAMETER | 3.0 x diameter
VX_FLAG_THREAD_DEPTH_FULL | full
VX_FLAG_THREAD_DEPTH_CUSTOM | custom

Definition at line 784 of file zwapi_cmd_shape_data.h.

785 {
786 VX_FLAG_THREAD_UNDEFINED,
787 VX_FLAG_THREAD_DEPTH_DEFAULT,
788 VX_FLAG_THREAD_DEPTH_1XDIAMETER,
789 VX_FLAG_THREAD_DEPTH_15XDIAMETER,
790 VX_FLAG_THREAD_DEPTH_2XDIAMETER,
791 VX_FLAG_THREAD_DEPTH_25XDIAMETER,
792 VX_FLAG_THREAD_DEPTH_3XDIAMETER,
793 VX_FLAG_THREAD_DEPTH_FULL,
794 VX_FLAG_THREAD_DEPTH_CUSTOM,
795 } evxFlagThreadDepthType;
evxFlagThreadDepthType
evxFlagThreadDepthType
flagged as thread hole depth type
Definition: zwapi_cmd_shape_data.h:785
VX_FLAG_THREAD_UNDEFINED
@ VX_FLAG_THREAD_UNDEFINED
undefined
Definition: zwapi_cmd_shape_data.h:786
VX_FLAG_THREAD_DEPTH_1XDIAMETER
@ VX_FLAG_THREAD_DEPTH_1XDIAMETER
1.0 x diameter
Definition: zwapi_cmd_shape_data.h:788
VX_FLAG_THREAD_DEPTH_CUSTOM
@ VX_FLAG_THREAD_DEPTH_CUSTOM
custom
Definition: zwapi_cmd_shape_data.h:794
VX_FLAG_THREAD_DEPTH_15XDIAMETER
@ VX_FLAG_THREAD_DEPTH_15XDIAMETER
1.5 x diameter
Definition: zwapi_cmd_shape_data.h:789
VX_FLAG_THREAD_DEPTH_FULL
@ VX_FLAG_THREAD_DEPTH_FULL
full
Definition: zwapi_cmd_shape_data.h:793
VX_FLAG_THREAD_DEPTH_25XDIAMETER
@ VX_FLAG_THREAD_DEPTH_25XDIAMETER
2.5 x diameter
Definition: zwapi_cmd_shape_data.h:791
VX_FLAG_THREAD_DEPTH_DEFAULT
@ VX_FLAG_THREAD_DEPTH_DEFAULT
default
Definition: zwapi_cmd_shape_data.h:787
VX_FLAG_THREAD_DEPTH_2XDIAMETER
@ VX_FLAG_THREAD_DEPTH_2XDIAMETER
2.0 x diameter
Definition: zwapi_cmd_shape_data.h:790
VX_FLAG_THREAD_DEPTH_3XDIAMETER
@ VX_FLAG_THREAD_DEPTH_3XDIAMETER
3.0 x diameter
Definition: zwapi_cmd_shape_data.h:792
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxChamFlltType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxChamFlltType

enum evxChamFlltType

#include <zwapi_cmd_shape_data.h>

chamfer or fillet types

Enumerator
VX_CHAMFLLT_SYMMETRIC | symmetric chamfer or fillet: single offset chamfer at edge
VX_CHAMFLLT_ASYMMETRIC | asymmetric chamfer or fillet: double offset chamfer at edge
VX_CHAMFLLT_SETBACK_ANGLE | asymmetric chamfer or fillet: offset and angle chamfer at edge
VX_CHAMFLLT_VERTEX | vertex chamfer or fillet: single offset chamfer at vertex

Definition at line 412 of file zwapi_cmd_shape_data.h.

413 {
414 VX_CHAMFLLT_SYMMETRIC,
415 VX_CHAMFLLT_ASYMMETRIC,
416 VX_CHAMFLLT_SETBACK_ANGLE,
417 VX_CHAMFLLT_VERTEX
418 } evxChamFlltType;
evxChamFlltType
evxChamFlltType
chamfer or fillet types
Definition: zwapi_cmd_shape_data.h:413
VX_CHAMFLLT_ASYMMETRIC
@ VX_CHAMFLLT_ASYMMETRIC
asymmetric chamfer or fillet: double offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:415
VX_CHAMFLLT_SETBACK_ANGLE
@ VX_CHAMFLLT_SETBACK_ANGLE
asymmetric chamfer or fillet: offset and angle chamfer at edge
Definition: zwapi_cmd_shape_data.h:416
VX_CHAMFLLT_VERTEX
@ VX_CHAMFLLT_VERTEX
vertex chamfer or fillet: single offset chamfer at vertex
Definition: zwapi_cmd_shape_data.h:417
VX_CHAMFLLT_SYMMETRIC
@ VX_CHAMFLLT_SYMMETRIC
symmetric chamfer or fillet: single offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:414
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxLoftType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxLoftType

enum evxLoftType

#include <zwapi_cmd_shape_data.h>

loft method

Enumerator
VX_LOFT_PROFS | loft profiles in the order of profiles selection
VX_LOFT_START_PNT_PROFS | loft based on starting point and profiles
VX_LOFT_END_PNT_PROFS | loft based on ending point and profiles
VX_LOFT_BOTH_PNTS_PROFS | loft based on both end points and profiles

Definition at line 375 of file zwapi_cmd_shape_data.h.

376 {
377 VX_LOFT_PROFS,
378 VX_LOFT_START_PNT_PROFS,
379 VX_LOFT_END_PNT_PROFS,
380 VX_LOFT_BOTH_PNTS_PROFS
381 } evxLoftType;
evxLoftType
evxLoftType
loft method
Definition: zwapi_cmd_shape_data.h:376
VX_LOFT_END_PNT_PROFS
@ VX_LOFT_END_PNT_PROFS
loft based on ending point and profiles
Definition: zwapi_cmd_shape_data.h:379
VX_LOFT_BOTH_PNTS_PROFS
@ VX_LOFT_BOTH_PNTS_PROFS
loft based on both end points and profiles
Definition: zwapi_cmd_shape_data.h:380
VX_LOFT_PROFS
@ VX_LOFT_PROFS
loft profiles in the order of profiles selection
Definition: zwapi_cmd_shape_data.h:377
VX_LOFT_START_PNT_PROFS
@ VX_LOFT_START_PNT_PROFS
loft based on starting point and profiles
Definition: zwapi_cmd_shape_data.h:378
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxHoleOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxHoleOpt

enum evxHoleOpt

#include <zwapi_cmd_shape_data.h>

hole option

Enumerator
VX_GENERAL_HOLE | general hole
VX_CLEARANCE_HOLE | clearance hole
VX_THREAD_HOLE | thread hole
VX_PROFILE_HOLE | profile hole

Definition at line 605 of file zwapi_cmd_shape_data.h.

606 {
607 VX_GENERAL_HOLE = 0,
608 VX_CLEARANCE_HOLE = 1,
609 VX_THREAD_HOLE = 2,
610 VX_PROFILE_HOLE = 3,
611 }evxHoleOpt;
evxHoleOpt
evxHoleOpt
hole option
Definition: zwapi_cmd_shape_data.h:606
VX_GENERAL_HOLE
@ VX_GENERAL_HOLE
general hole
Definition: zwapi_cmd_shape_data.h:607
VX_CLEARANCE_HOLE
@ VX_CLEARANCE_HOLE
clearance hole
Definition: zwapi_cmd_shape_data.h:608
VX_THREAD_HOLE
@ VX_THREAD_HOLE
thread hole
Definition: zwapi_cmd_shape_data.h:609
VX_PROFILE_HOLE
@ VX_PROFILE_HOLE
profile hole
Definition: zwapi_cmd_shape_data.h:610
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxThreadType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxThreadType

enum evxThreadType

#include <zwapi_cmd_shape_data.h>

hole thread types

Definition at line 645 of file zwapi_cmd_shape_data.h.

646 {
647 VX_THREAD_NONE = 1,
648 VX_THREAD_CUSTOM = 2,
649 VX_THREAD_M = 3,
650 VX_THREAD_UNC = 4,
651 VX_THREAD_UNF = 5,
652 VX_THREAD_ISO7 = 6,
653 VX_THREAD_ISO228 = 7,
654 VX_THREAD_NPT = 8,
655 VX_THREAD_NPSM = 9,
656 VX_THREAD_MC = 10,
657 VX_THREAD_MF = 11,
658 VX_THREAD_UN = 12,
659 VX_THREAD_UNEF = 13,
660 VX_THREAD_UNJ = 14,
661 VX_THREAD_UNJC = 15,
662 VX_THREAD_UNJF = 16,
663 VX_THREAD_UNJEF = 17,
664 VX_THREAD_ACME = 18,
665 VX_THREAD_BSP = 19,
666 VX_THREAD_BSTP = 20
667 } evxThreadType;
evxThreadType
evxThreadType
hole thread types
Definition: zwapi_cmd_shape_data.h:646
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCapType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Shape Commands Data
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ evxCapType

enum evxCapType

#include <zwapi_cmd_shape_data.h>

End caps.

Enumerator
VX_END_CAP_BOTH | both
VX_END_CAP_START | start
VX_END_CAP_END | end
VX_END_CAP_NONE | none

Definition at line 152 of file zwapi_cmd_shape_data.h.

153 {
154 VX_END_CAP_BOTH = 0,
155 VX_END_CAP_START = 1,
156 VX_END_CAP_END = 2,
157 VX_END_CAP_NONE = 3,
158 }evxCapType;
evxCapType
evxCapType
End caps.
Definition: zwapi_cmd_shape_data.h:153
VX_END_CAP_BOTH
@ VX_END_CAP_BOTH
both
Definition: zwapi_cmd_shape_data.h:154
VX_END_CAP_NONE
@ VX_END_CAP_NONE
none
Definition: zwapi_cmd_shape_data.h:157
VX_END_CAP_END
@ VX_END_CAP_END
end
Definition: zwapi_cmd_shape_data.h:156
VX_END_CAP_START
@ VX_END_CAP_START
start
Definition: zwapi_cmd_shape_data.h:155
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdTaperSideMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdTaperSideMethod

enum evxSmdTaperSideMethod

#include <zwapi_cmd_sheetmetal_data.h>

smd bend taper sides

Enumerator
VX_SMD_TAPER_SIDES_BOTH | Tapers both sides of the flange. You can set different values for each side.
VX_SMD_TAPER_SIDES_SIDE1 | Tapers the first side of the flange. You can see a preview of the result.
VX_SMD_TAPER_SIDES_SIDE2 | Tapers the second side of the flange. You can see a preview of the result.
VX_SMD_TAPER_SIDES_SYMMETRY | Tapers both sides equally of the flange.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 891 of file zwapi_cmd_sheetmetal_data.h.

892 {
893 VX_SMD_TAPER_SIDES_BOTH,
894 VX_SMD_TAPER_SIDES_SIDE1,
895 VX_SMD_TAPER_SIDES_SIDE2,
896 VX_SMD_TAPER_SIDES_SYMMETRY,
897 } evxSmdTaperSideMethod;
evxSmdTaperSideMethod
evxSmdTaperSideMethod
smd bend taper sides
Definition: zwapi_cmd_sheetmetal_data.h:892
VX_SMD_TAPER_SIDES_SIDE2
@ VX_SMD_TAPER_SIDES_SIDE2
Tapers the second side of the flange. You can see a preview of the result.
Definition: zwapi_cmd_sheetmetal_data.h:895
VX_SMD_TAPER_SIDES_SYMMETRY
@ VX_SMD_TAPER_SIDES_SYMMETRY
Tapers both sides equally of the flange.
Definition: zwapi_cmd_sheetmetal_data.h:896
VX_SMD_TAPER_SIDES_SIDE1
@ VX_SMD_TAPER_SIDES_SIDE1
Tapers the first side of the flange. You can see a preview of the result.
Definition: zwapi_cmd_sheetmetal_data.h:894
VX_SMD_TAPER_SIDES_BOTH
@ VX_SMD_TAPER_SIDES_BOTH
Tapers both sides of the flange. You can set different values for each side.
Definition: zwapi_cmd_sheetmetal_data.h:893
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDimplePostion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxDimplePostion

enum evxDimplePostion

#include <zwapi_cmd_sheetmetal_data.h>

dimple position type

Enumerator
VX_MATERIAL_OUTSIDE | material outside: set the dimple outside the sketch
VX_MATERIAL_INSIDE | material inside: set the dimple inside the sketch
VX_BEND_OUTSIDE | bend outside: set the dimple outside the sketch
Examples
part\smdFtrCrtTest.cpp.

Definition at line 1112 of file zwapi_cmd_sheetmetal_data.h.

1113 {
1114 VX_MATERIAL_OUTSIDE = 0,
1115 VX_MATERIAL_INSIDE,
1116 VX_BEND_OUTSIDE,
1117 } evxDimplePostion;
evxDimplePostion
evxDimplePostion
dimple position type
Definition: zwapi_cmd_sheetmetal_data.h:1113
VX_MATERIAL_OUTSIDE
@ VX_MATERIAL_OUTSIDE
material outside: set the dimple outside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1114
VX_BEND_OUTSIDE
@ VX_BEND_OUTSIDE
bend outside: set the dimple outside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1116
VX_MATERIAL_INSIDE
@ VX_MATERIAL_INSIDE
material inside: set the dimple inside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1115
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxNormCutTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxNormCutTyp

enum evxNormCutTyp

#include <zwapi_cmd_sheetmetal_data.h>

Normal Cut command.

Enumerator
VX_NORMCUT_BOTHSIDES | Normal to Both Sides.
VX_NORMCUT_MIDDLE | Normal to Middle.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 928 of file zwapi_cmd_sheetmetal_data.h.

929 {
930 VX_NORMCUT_BOTHSIDES = 0,
931 VX_NORMCUT_MIDDLE = 1,
932 }evxNormCutTyp;
evxNormCutTyp
evxNormCutTyp
Normal Cut command.
Definition: zwapi_cmd_sheetmetal_data.h:929
VX_NORMCUT_MIDDLE
@ VX_NORMCUT_MIDDLE
Normal to Middle.
Definition: zwapi_cmd_sheetmetal_data.h:931
VX_NORMCUT_BOTHSIDES
@ VX_NORMCUT_BOTHSIDES
Normal to Both Sides.
Definition: zwapi_cmd_sheetmetal_data.h:930
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdBendType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdBendType

enum evxSmdBendType

#include <zwapi_cmd_sheetmetal_data.h>

Smd Bend Type of Flange.

Enumerator
VX_BEND_SIMPLE | Simple.
VX_BEND_S_BEND | S bend.
VX_BEND_CLOSED | Closed.
VX_BEND_OPEN | Open.
VX_BEND_JOGGLE | Joggle.
VX_BEND_CURL | Curl.
VX_BEND_Z_BEND | Z bend.
VX_BEND_CLOSED_LOOP | Closed loop.
VX_BEND_OPEN_LOOP | Open loop.
VX_BEND_CENTERED_LOOP | Centered loop.
VX_BEND_USER_DEFINED | user defined

Definition at line 237 of file zwapi_cmd_sheetmetal_data.h.

238 {
239 VX_BEND_SIMPLE = 0,
240 VX_BEND_S_BEND = 1,
241 VX_BEND_CLOSED = 5,
242 VX_BEND_OPEN = 6,
243 VX_BEND_JOGGLE = 4,
244 VX_BEND_CURL = 2,
245 VX_BEND_Z_BEND = 7,
246 VX_BEND_CLOSED_LOOP = 8,
247 VX_BEND_OPEN_LOOP = 9,
248 VX_BEND_CENTERED_LOOP = 10,
249 VX_BEND_USER_DEFINED = 11
250 } evxSmdBendType;
evxSmdBendType
evxSmdBendType
Smd Bend Type of Flange.
Definition: zwapi_cmd_sheetmetal_data.h:238
VX_BEND_Z_BEND
@ VX_BEND_Z_BEND
Z bend.
Definition: zwapi_cmd_sheetmetal_data.h:245
VX_BEND_CLOSED_LOOP
@ VX_BEND_CLOSED_LOOP
Closed loop.
Definition: zwapi_cmd_sheetmetal_data.h:246
VX_BEND_S_BEND
@ VX_BEND_S_BEND
S bend.
Definition: zwapi_cmd_sheetmetal_data.h:240
VX_BEND_CLOSED
@ VX_BEND_CLOSED
Closed.
Definition: zwapi_cmd_sheetmetal_data.h:241
VX_BEND_SIMPLE
@ VX_BEND_SIMPLE
Simple.
Definition: zwapi_cmd_sheetmetal_data.h:239
VX_BEND_JOGGLE
@ VX_BEND_JOGGLE
Joggle.
Definition: zwapi_cmd_sheetmetal_data.h:243
VX_BEND_OPEN_LOOP
@ VX_BEND_OPEN_LOOP
Open loop.
Definition: zwapi_cmd_sheetmetal_data.h:247
VX_BEND_OPEN
@ VX_BEND_OPEN
Open.
Definition: zwapi_cmd_sheetmetal_data.h:242
VX_BEND_CENTERED_LOOP
@ VX_BEND_CENTERED_LOOP
Centered loop.
Definition: zwapi_cmd_sheetmetal_data.h:248
VX_BEND_USER_DEFINED
@ VX_BEND_USER_DEFINED
user defined
Definition: zwapi_cmd_sheetmetal_data.h:249
VX_BEND_CURL
@ VX_BEND_CURL
Curl.
Definition: zwapi_cmd_sheetmetal_data.h:244
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdExtendFlangeMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdExtendFlangeMethod

enum evxSmdExtendFlangeMethod

#include <zwapi_cmd_sheetmetal_data.h>

extend flange method

Enumerator
VX_SMD_EXTEND_BY_VALUE | Extends by a specfied value.
VX_SMD_EXTEND_THROUGH_UNTIL | Extends to intersect the plane.
VX_SMD_EXTEND_TO_SELECTED | Extends up to the plane.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 795 of file zwapi_cmd_sheetmetal_data.h.

796 {
797 VX_SMD_EXTEND_BY_VALUE,
798 VX_SMD_EXTEND_THROUGH_UNTIL,
799 VX_SMD_EXTEND_TO_SELECTED,
800 } evxSmdExtendFlangeMethod;
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
extend flange method
Definition: zwapi_cmd_sheetmetal_data.h:796
VX_SMD_EXTEND_TO_SELECTED
@ VX_SMD_EXTEND_TO_SELECTED
Extends up to the plane.
Definition: zwapi_cmd_sheetmetal_data.h:799
VX_SMD_EXTEND_THROUGH_UNTIL
@ VX_SMD_EXTEND_THROUGH_UNTIL
Extends to intersect the plane.
Definition: zwapi_cmd_sheetmetal_data.h:798
VX_SMD_EXTEND_BY_VALUE
@ VX_SMD_EXTEND_BY_VALUE
Extends by a specfied value.
Definition: zwapi_cmd_sheetmetal_data.h:797
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPunchLocType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxPunchLocType

enum evxPunchLocType

#include <zwapi_cmd_sheetmetal_data.h>

location type of punch command

Enumerator
VX_LOCATION_POINT | Point.
VX_LOCATION_CONSTRAINT | Constraint.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 1042 of file zwapi_cmd_sheetmetal_data.h.

1043 {
1044 VX_LOCATION_POINT = 0,
1045 VX_LOCATION_CONSTRAINT = 1,
1046 }evxPunchLocType;
evxPunchLocType
evxPunchLocType
location type of punch command
Definition: zwapi_cmd_sheetmetal_data.h:1043
VX_LOCATION_CONSTRAINT
@ VX_LOCATION_CONSTRAINT
Constraint.
Definition: zwapi_cmd_sheetmetal_data.h:1045
VX_LOCATION_POINT
@ VX_LOCATION_POINT
Point.
Definition: zwapi_cmd_sheetmetal_data.h:1044
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdCalCustom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdCalCustom

enum evxSmdCalCustom

#include <zwapi_cmd_sheetmetal_data.h>

the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom

Enumerator
VX_CUSTOM_RELIEF | "relief" is a custom value
VX_CUSTOM_ISWIDTHRATIO | "isWidthRatio" is a custom value
VX_CUSTOM_RELIEFWIDTH | "ReliefWidth" is a custom value
VX_CUSTOM_ISDEPTHRATIO | "isDepthRatio" is a custom value
VX_CUSTOM_RELIEFDEPTH | "ReliefDepth" is a custom value

Definition at line 139 of file zwapi_cmd_sheetmetal_data.h.

140 {
141 VX_CUSTOM_RELIEF = 0x00000001,
142 VX_CUSTOM_ISWIDTHRATIO = 0x00000002,
143 VX_CUSTOM_RELIEFWIDTH = 0x00000004,
144 VX_CUSTOM_ISDEPTHRATIO = 0x00000008,
145 VX_CUSTOM_RELIEFDEPTH = 0x00000010,
146 } evxSmdCalCustom;
evxSmdCalCustom
evxSmdCalCustom
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom
Definition: zwapi_cmd_sheetmetal_data.h:140
VX_CUSTOM_ISWIDTHRATIO
@ VX_CUSTOM_ISWIDTHRATIO
"isWidthRatio" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:142
VX_CUSTOM_RELIEFDEPTH
@ VX_CUSTOM_RELIEFDEPTH
"ReliefDepth" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:145
VX_CUSTOM_RELIEFWIDTH
@ VX_CUSTOM_RELIEFWIDTH
"ReliefWidth" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:143
VX_CUSTOM_ISDEPTHRATIO
@ VX_CUSTOM_ISDEPTHRATIO
"isDepthRatio" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:144
VX_CUSTOM_RELIEF
@ VX_CUSTOM_RELIEF
"relief" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:141
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExtrudeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxExtrudeType

enum evxExtrudeType

#include <zwapi_cmd_sheetmetal_data.h>

extrude type

Enumerator
VX_EXTRUDE_TYPE_ONESIDE | 1 side
VX_EXTRUDE_TYPE_TWOSIDE | 2 side
VX_EXTRUDE_TYPE_SYMMETRICAL | Symmetrical.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 917 of file zwapi_cmd_sheetmetal_data.h.

918 {
919 VX_EXTRUDE_TYPE_ONESIDE = 0,
920 VX_EXTRUDE_TYPE_TWOSIDE = 1,
921 VX_EXTRUDE_TYPE_SYMMETRICAL,
922 }evxExtrudeType;
evxExtrudeType
evxExtrudeType
extrude type
Definition: zwapi_cmd_sheetmetal_data.h:918
VX_EXTRUDE_TYPE_ONESIDE
@ VX_EXTRUDE_TYPE_ONESIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:919
VX_EXTRUDE_TYPE_SYMMETRICAL
@ VX_EXTRUDE_TYPE_SYMMETRICAL
Symmetrical.
Definition: zwapi_cmd_sheetmetal_data.h:921
VX_EXTRUDE_TYPE_TWOSIDE
@ VX_EXTRUDE_TYPE_TWOSIDE
2 side
Definition: zwapi_cmd_sheetmetal_data.h:920
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdCornerRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdCornerRelief

enum evxSmdCornerRelief

#include <zwapi_cmd_sheetmetal_data.h>

Smd Relief type of Corner Attributes.

Enumerator
VX_CORNER_RELIEF_CLOSED | closed
VX_CORNER_RELIEF_CIRCULAR_CUTOUT | circular cutout
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT | rectangular cutout
VX_CORNER_RELIEF_U_CUTOUT | U cutout.
VX_CORNER_RELIEF_V_CUTOUT | V cutout.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 85 of file zwapi_cmd_sheetmetal_data.h.

86 {
87 VX_CORNER_RELIEF_CLOSED,
88 VX_CORNER_RELIEF_CIRCULAR_CUTOUT,
89 VX_CORNER_RELIEF_RECTANGULAR_CUTOUT,
90 VX_CORNER_RELIEF_U_CUTOUT,
91 VX_CORNER_RELIEF_V_CUTOUT,
92 } evxSmdCornerRelief;
evxSmdCornerRelief
evxSmdCornerRelief
Smd Relief type of Corner Attributes.
Definition: zwapi_cmd_sheetmetal_data.h:86
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
@ VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:89
VX_CORNER_RELIEF_V_CUTOUT
@ VX_CORNER_RELIEF_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:91
VX_CORNER_RELIEF_U_CUTOUT
@ VX_CORNER_RELIEF_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:90
VX_CORNER_RELIEF_CIRCULAR_CUTOUT
@ VX_CORNER_RELIEF_CIRCULAR_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:88
VX_CORNER_RELIEF_CLOSED
@ VX_CORNER_RELIEF_CLOSED
closed
Definition: zwapi_cmd_sheetmetal_data.h:87
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdRelief

enum evxSmdRelief

#include <zwapi_cmd_sheetmetal_data.h>

Smd Relief type.

Enumerator
VX_RELIEF_RECTANGLE | Rectangle.
VX_RELIEF_OBROUND | Obround.
VX_RELIEF_NONE | None.
VX_RELIEF_STRETCH | Stretch.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 73 of file zwapi_cmd_sheetmetal_data.h.

74 {
75 VX_RELIEF_RECTANGLE = 0,
76 VX_RELIEF_OBROUND = 1,
77 VX_RELIEF_NONE = 2,
78 VX_RELIEF_STRETCH = 3,
79 }evxSmdRelief;
evxSmdRelief
evxSmdRelief
Smd Relief type.
Definition: zwapi_cmd_sheetmetal_data.h:74
VX_RELIEF_STRETCH
@ VX_RELIEF_STRETCH
Stretch.
Definition: zwapi_cmd_sheetmetal_data.h:78
VX_RELIEF_RECTANGLE
@ VX_RELIEF_RECTANGLE
Rectangle.
Definition: zwapi_cmd_sheetmetal_data.h:75
VX_RELIEF_OBROUND
@ VX_RELIEF_OBROUND
Obround.
Definition: zwapi_cmd_sheetmetal_data.h:76
VX_RELIEF_NONE
@ VX_RELIEF_NONE
None.
Definition: zwapi_cmd_sheetmetal_data.h:77
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCornerReliefTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxCornerReliefTyp

enum evxCornerReliefTyp

#include <zwapi_cmd_sheetmetal_data.h>

corner relief type

Enumerator
VX_CORNER_CLOSED | closed
VX_CORNER_CIRCL_CUTOUT | circular cutout
VX_CORNER_RECT_CUTOUT | rectangular cutout
VX_CORNER_U_CUTOUT | U cutout.
VX_CORNER_V_CUTOUT | V cutout.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 965 of file zwapi_cmd_sheetmetal_data.h.

966 {
967 VX_CORNER_CLOSED = 0,
968 VX_CORNER_CIRCL_CUTOUT,
969 VX_CORNER_RECT_CUTOUT,
970 VX_CORNER_U_CUTOUT,
971 VX_CORNER_V_CUTOUT,
972 }evxCornerReliefTyp;
evxCornerReliefTyp
evxCornerReliefTyp
corner relief type
Definition: zwapi_cmd_sheetmetal_data.h:966
VX_CORNER_V_CUTOUT
@ VX_CORNER_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:971
VX_CORNER_CLOSED
@ VX_CORNER_CLOSED
closed
Definition: zwapi_cmd_sheetmetal_data.h:967
VX_CORNER_U_CUTOUT
@ VX_CORNER_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:970
VX_CORNER_RECT_CUTOUT
@ VX_CORNER_RECT_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:969
VX_CORNER_CIRCL_CUTOUT
@ VX_CORNER_CIRCL_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:968
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdChangeBendType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdChangeBendType

enum evxSmdChangeBendType

#include <zwapi_cmd_sheetmetal_data.h>

change bend type

Enumerator
VX_SMD_CHANGE_BEND_DEFAULT | Both bend radius and angle can be changed.
VX_SMD_CHANGE_BEND_FOLD_LENGTH | Only bend radius of picked bends and geometries nearby will be changed keeping other dimensions of the fold shape unchanged. The unfold length is changed.
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH | Both bend radius and angle can be changed keep the over all unfold length of the shape unchanged.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 1250 of file zwapi_cmd_sheetmetal_data.h.

1251 {
1252 VX_SMD_CHANGE_BEND_DEFAULT,
1253 VX_SMD_CHANGE_BEND_FOLD_LENGTH,
1256 VX_SMD_CHANGE_BEND_UNFOLD_LENGTH,
1257 } evxSmdChangeBendType;
evxSmdChangeBendType
evxSmdChangeBendType
change bend type
Definition: zwapi_cmd_sheetmetal_data.h:1251
VX_SMD_CHANGE_BEND_FOLD_LENGTH
@ VX_SMD_CHANGE_BEND_FOLD_LENGTH
Only bend radius of picked bends and geometries nearby will be changed keeping other dimensions of th...
Definition: zwapi_cmd_sheetmetal_data.h:1253
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
@ VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
Both bend radius and angle can be changed keep the over all unfold length of the shape unchanged.
Definition: zwapi_cmd_sheetmetal_data.h:1256
VX_SMD_CHANGE_BEND_DEFAULT
@ VX_SMD_CHANGE_BEND_DEFAULT
Both bend radius and angle can be changed.
Definition: zwapi_cmd_sheetmetal_data.h:1252
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdJogPosition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdJogPosition

enum evxSmdJogPosition

#include <zwapi_cmd_sheetmetal_data.h>

Smd Jog Parameters Position.

Enumerator
VX_SMD_JOG_OUTER | Bend is farther from stationary point than line.
VX_SMD_JOG_INNER | Bend is close to stationary point than line.
VX_SMD_JOG_MIDDLE | The line stays in the middle of bend.
VX_SMD_JOG_MATERIAL_INSIDE | In form state, fold line at the outside face of the fold region.
VX_SMD_JOG_MATERIAL_OUTSIDE | In form state, fold line at the inside face of the fold region.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 738 of file zwapi_cmd_sheetmetal_data.h.

739 {
740 VX_SMD_JOG_OUTER,
741 VX_SMD_JOG_INNER,
742 VX_SMD_JOG_MIDDLE,
743 VX_SMD_JOG_MATERIAL_INSIDE,
744 VX_SMD_JOG_MATERIAL_OUTSIDE,
745 } evxSmdJogPosition;
evxSmdJogPosition
evxSmdJogPosition
Smd Jog Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:739
VX_SMD_JOG_MIDDLE
@ VX_SMD_JOG_MIDDLE
The line stays in the middle of bend.
Definition: zwapi_cmd_sheetmetal_data.h:742
VX_SMD_JOG_OUTER
@ VX_SMD_JOG_OUTER
Bend is farther from stationary point than line.
Definition: zwapi_cmd_sheetmetal_data.h:740
VX_SMD_JOG_INNER
@ VX_SMD_JOG_INNER
Bend is close to stationary point than line.
Definition: zwapi_cmd_sheetmetal_data.h:741
VX_SMD_JOG_MATERIAL_OUTSIDE
@ VX_SMD_JOG_MATERIAL_OUTSIDE
In form state, fold line at the inside face of the fold region.
Definition: zwapi_cmd_sheetmetal_data.h:744
VX_SMD_JOG_MATERIAL_INSIDE
@ VX_SMD_JOG_MATERIAL_INSIDE
In form state, fold line at the outside face of the fold region.
Definition: zwapi_cmd_sheetmetal_data.h:743
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdHemBendType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdHemBendType

enum evxSmdHemBendType

#include <zwapi_cmd_sheetmetal_data.h>

Smd Bend Type of Hem Flange.

Enumerator
VX_SMD_HEM_BEND_CLOSED | Close.
VX_SMD_HEM_BEND_OPEN | Open.
VX_SMD_HEM_BEND_CLOSEDLOOP | Closed loop.
VX_SMD_HEM_BEND_OPENLOOP | Open loop.
VX_SMD_HEM_BEND_CENTEREDLOOP | Centered loop.
VX_SMD_HEM_BEND_SBEND | S bend.
VX_SMD_HEM_BEND_CURL | Curl.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 486 of file zwapi_cmd_sheetmetal_data.h.

487 {
488 VX_SMD_HEM_BEND_CLOSED,
489 VX_SMD_HEM_BEND_OPEN,
490 VX_SMD_HEM_BEND_CLOSEDLOOP,
491 VX_SMD_HEM_BEND_OPENLOOP,
492 VX_SMD_HEM_BEND_CENTEREDLOOP,
493 VX_SMD_HEM_BEND_SBEND,
494 VX_SMD_HEM_BEND_CURL,
495 } evxSmdHemBendType;
evxSmdHemBendType
evxSmdHemBendType
Smd Bend Type of Hem Flange.
Definition: zwapi_cmd_sheetmetal_data.h:487
VX_SMD_HEM_BEND_CENTEREDLOOP
@ VX_SMD_HEM_BEND_CENTEREDLOOP
Centered loop.
Definition: zwapi_cmd_sheetmetal_data.h:492
VX_SMD_HEM_BEND_CLOSED
@ VX_SMD_HEM_BEND_CLOSED
Close.
Definition: zwapi_cmd_sheetmetal_data.h:488
VX_SMD_HEM_BEND_CLOSEDLOOP
@ VX_SMD_HEM_BEND_CLOSEDLOOP
Closed loop.
Definition: zwapi_cmd_sheetmetal_data.h:490
VX_SMD_HEM_BEND_OPENLOOP
@ VX_SMD_HEM_BEND_OPENLOOP
Open loop.
Definition: zwapi_cmd_sheetmetal_data.h:491
VX_SMD_HEM_BEND_SBEND
@ VX_SMD_HEM_BEND_SBEND
S bend.
Definition: zwapi_cmd_sheetmetal_data.h:493
VX_SMD_HEM_BEND_OPEN
@ VX_SMD_HEM_BEND_OPEN
Open.
Definition: zwapi_cmd_sheetmetal_data.h:489
VX_SMD_HEM_BEND_CURL
@ VX_SMD_HEM_BEND_CURL
Curl.
Definition: zwapi_cmd_sheetmetal_data.h:494
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdLftFlangeMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdLftFlangeMethod

enum evxSmdLftFlangeMethod

#include <zwapi_cmd_sheetmetal_data.h>

Lofted Flange method.

Enumerator
VX_SMD_GENERAL_LOFTING | The surfaces generated are the same as those generated by solid lofting.
VX_SMD_FLATTENABLE_LOFTING | Open - loop contour and bending lofting.
VX_SMD_BENDING_LOFTING | The number of segments of the arc is controlled according to the maximum arc height, bending number, maximum chord length and maximum chord angle. When lofting, bend lofting according to the contour after section.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 567 of file zwapi_cmd_sheetmetal_data.h.

568 {
569 VX_SMD_GENERAL_LOFTING,
570 VX_SMD_FLATTENABLE_LOFTING,
571 VX_SMD_BENDING_LOFTING,
574 } evxSmdLftFlangeMethod;
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
Lofted Flange method.
Definition: zwapi_cmd_sheetmetal_data.h:568
VX_SMD_FLATTENABLE_LOFTING
@ VX_SMD_FLATTENABLE_LOFTING
Open - loop contour and bending lofting.
Definition: zwapi_cmd_sheetmetal_data.h:570
VX_SMD_BENDING_LOFTING
@ VX_SMD_BENDING_LOFTING
The number of segments of the arc is controlled according to the maximum arc height,...
Definition: zwapi_cmd_sheetmetal_data.h:571
VX_SMD_GENERAL_LOFTING
@ VX_SMD_GENERAL_LOFTING
The surfaces generated are the same as those generated by solid lofting.
Definition: zwapi_cmd_sheetmetal_data.h:569
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdRipType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdRipType

enum evxSmdRipType

#include <zwapi_cmd_sheetmetal_data.h>

smd rip type

Enumerator
VX_SMD_RIP_BOTH_SIDES | two sides
VX_SMD_RIP_LEFT_SIDE | left side
VX_SMD_RIP_RIGHT_SIDE | right side

Definition at line 1299 of file zwapi_cmd_sheetmetal_data.h.

1300 {
1301 VX_SMD_RIP_BOTH_SIDES,
1302 VX_SMD_RIP_LEFT_SIDE,
1303 VX_SMD_RIP_RIGHT_SIDE,
1304 } evxSmdRipType;
evxSmdRipType
evxSmdRipType
smd rip type
Definition: zwapi_cmd_sheetmetal_data.h:1300
VX_SMD_RIP_RIGHT_SIDE
@ VX_SMD_RIP_RIGHT_SIDE
right side
Definition: zwapi_cmd_sheetmetal_data.h:1303
VX_SMD_RIP_LEFT_SIDE
@ VX_SMD_RIP_LEFT_SIDE
left side
Definition: zwapi_cmd_sheetmetal_data.h:1302
VX_SMD_RIP_BOTH_SIDES
@ VX_SMD_RIP_BOTH_SIDES
two sides
Definition: zwapi_cmd_sheetmetal_data.h:1301
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdLftCutMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdLftCutMethod

enum evxSmdLftCutMethod

#include <zwapi_cmd_sheetmetal_data.h>

Lofted Flange Cutting Method.

Enumerator
VX_SMD_LFG_MAX_ARC_HEIGHT | This method requires that the arc/ellipse corresponding to each segment line of the graph arc have the same arc height (the arc height of different arcs can be different), and not greater than the control value. The default unit is mm.
VX_SMD_LFG_NUMBER_BEND | The control value is the number of line segments in each arc/ellipse. It has no unit and is an integer value.
VX_SMD_LFG_MAX_CHORD_LENGTH | This method requires that the chord length of each arc/ellipse arc is equal (the chord length of different arcs can be different), and the length is not greater than the control value. The default unit is mm.
VX_SMD_LFG_MAX_ARC_CHORD_ANGLE | This method requires that the maximum Angle between the tangent vector of the two ends of the arc and the chord is the same (the Angle of the chord of different arcs may be different), and is not greater than the control value. The default unit is degree.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 580 of file zwapi_cmd_sheetmetal_data.h.

581 {
582 VX_SMD_LFG_MAX_ARC_HEIGHT,
585 VX_SMD_LFG_NUMBER_BEND,
587 VX_SMD_LFG_MAX_CHORD_LENGTH,
590 VX_SMD_LFG_MAX_ARC_CHORD_ANGLE,
593 } evxSmdLftCutMethod;
evxSmdLftCutMethod
evxSmdLftCutMethod
Lofted Flange Cutting Method.
Definition: zwapi_cmd_sheetmetal_data.h:581
VX_SMD_LFG_MAX_CHORD_LENGTH
@ VX_SMD_LFG_MAX_CHORD_LENGTH
This method requires that the chord length of each arc/ellipse arc is equal (the chord length of diff...
Definition: zwapi_cmd_sheetmetal_data.h:587
VX_SMD_LFG_MAX_ARC_HEIGHT
@ VX_SMD_LFG_MAX_ARC_HEIGHT
This method requires that the arc/ellipse corresponding to each segment line of the graph arc have th...
Definition: zwapi_cmd_sheetmetal_data.h:582
VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
@ VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
This method requires that the maximum Angle between the tangent vector of the two ends of the arc and...
Definition: zwapi_cmd_sheetmetal_data.h:590
VX_SMD_LFG_NUMBER_BEND
@ VX_SMD_LFG_NUMBER_BEND
The control value is the number of line segments in each arc/ellipse. It has no unit and is an intege...
Definition: zwapi_cmd_sheetmetal_data.h:585
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdPosition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdPosition

enum evxSmdPosition

#include <zwapi_cmd_sheetmetal_data.h>

Smd Flange Parameters Position.

Enumerator
VX_POSITION_MATERIAL_INSIDE | Material inside.
VX_POSITION_MATERIAL_OUTSIDE | Material outside.
VX_POSITION_NATURAL | Natural.
VX_POSITION_OFFSET | Offset.
VX_POSITION_VIRTUAL_SHARP | Virtual sharp.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 32 of file zwapi_cmd_sheetmetal_data.h.

33 {
34 VX_POSITION_MATERIAL_INSIDE,
35 VX_POSITION_MATERIAL_OUTSIDE,
36 VX_POSITION_NATURAL,
37 VX_POSITION_OFFSET,
38 VX_POSITION_VIRTUAL_SHARP,
39 }evxSmdPosition;
evxSmdPosition
evxSmdPosition
Smd Flange Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:33
VX_POSITION_MATERIAL_OUTSIDE
@ VX_POSITION_MATERIAL_OUTSIDE
Material outside.
Definition: zwapi_cmd_sheetmetal_data.h:35
VX_POSITION_VIRTUAL_SHARP
@ VX_POSITION_VIRTUAL_SHARP
Virtual sharp.
Definition: zwapi_cmd_sheetmetal_data.h:38
VX_POSITION_MATERIAL_INSIDE
@ VX_POSITION_MATERIAL_INSIDE
Material inside.
Definition: zwapi_cmd_sheetmetal_data.h:34
VX_POSITION_OFFSET
@ VX_POSITION_OFFSET
Offset.
Definition: zwapi_cmd_sheetmetal_data.h:37
VX_POSITION_NATURAL
@ VX_POSITION_NATURAL
Natural.
Definition: zwapi_cmd_sheetmetal_data.h:36
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdReliefLengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdReliefLengthType

enum evxSmdReliefLengthType

#include <zwapi_cmd_sheetmetal_data.h>

Smd Relief Length Type of Flange.

Enumerator
VX_RELIEF_LENGTH_TYPE_TO_EDGE | to edge
VX_RELIEF_LENGTH_TYPE_THROUGH_ALL | through all
VX_RELIEF_LENGTH_TYPE_VALUE | value

Definition at line 152 of file zwapi_cmd_sheetmetal_data.h.

153 {
154 VX_RELIEF_LENGTH_TYPE_TO_EDGE,
155 VX_RELIEF_LENGTH_TYPE_THROUGH_ALL,
156 VX_RELIEF_LENGTH_TYPE_VALUE
157 } evxSmdReliefLengthType;
evxSmdReliefLengthType
evxSmdReliefLengthType
Smd Relief Length Type of Flange.
Definition: zwapi_cmd_sheetmetal_data.h:153
VX_RELIEF_LENGTH_TYPE_VALUE
@ VX_RELIEF_LENGTH_TYPE_VALUE
value
Definition: zwapi_cmd_sheetmetal_data.h:156
VX_RELIEF_LENGTH_TYPE_TO_EDGE
@ VX_RELIEF_LENGTH_TYPE_TO_EDGE
to edge
Definition: zwapi_cmd_sheetmetal_data.h:154
VX_RELIEF_LENGTH_TYPE_THROUGH_ALL
@ VX_RELIEF_LENGTH_TYPE_THROUGH_ALL
through all
Definition: zwapi_cmd_sheetmetal_data.h:155
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCornerOverlapTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxCornerOverlapTyp

enum evxCornerOverlapTyp

#include <zwapi_cmd_sheetmetal_data.h>

corner overlap type

Enumerator
VX_CORNER_UNDERLAP | underlap
VX_CORNER_OVERLAP | overlap
VX_CONER_NATURAL | natural
Examples
part\smdFtrCrtTest.cpp.

Definition at line 978 of file zwapi_cmd_sheetmetal_data.h.

979 {
980 VX_CORNER_UNDERLAP = 0,
981 VX_CORNER_OVERLAP,
982 VX_CONER_NATURAL,
983 }evxCornerOverlapTyp;
evxCornerOverlapTyp
evxCornerOverlapTyp
corner overlap type
Definition: zwapi_cmd_sheetmetal_data.h:979
VX_CORNER_UNDERLAP
@ VX_CORNER_UNDERLAP
underlap
Definition: zwapi_cmd_sheetmetal_data.h:980
VX_CORNER_OVERLAP
@ VX_CORNER_OVERLAP
overlap
Definition: zwapi_cmd_sheetmetal_data.h:981
VX_CONER_NATURAL
@ VX_CONER_NATURAL
natural
Definition: zwapi_cmd_sheetmetal_data.h:982
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdBendLengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdBendLengthType

enum evxSmdBendLengthType

#include <zwapi_cmd_sheetmetal_data.h>

Smd Bend Attributes Length type.

Enumerator
VX_BEND_STANDARD_LENGTH | Standard length.
VX_BEND_OUTER_HEIGHT | Outer height.
VX_BEND_INNER_HEIGHT | Inner height.
VX_BEND_EXTRAPOLATED_LENGTH | Extrapolated length.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 45 of file zwapi_cmd_sheetmetal_data.h.

46 {
47 VX_BEND_STANDARD_LENGTH,
48 VX_BEND_OUTER_HEIGHT,
49 VX_BEND_INNER_HEIGHT,
50 VX_BEND_EXTRAPOLATED_LENGTH,
51 }evxSmdBendLengthType;
evxSmdBendLengthType
evxSmdBendLengthType
Smd Bend Attributes Length type.
Definition: zwapi_cmd_sheetmetal_data.h:46
VX_BEND_STANDARD_LENGTH
@ VX_BEND_STANDARD_LENGTH
Standard length.
Definition: zwapi_cmd_sheetmetal_data.h:47
VX_BEND_INNER_HEIGHT
@ VX_BEND_INNER_HEIGHT
Inner height.
Definition: zwapi_cmd_sheetmetal_data.h:49
VX_BEND_OUTER_HEIGHT
@ VX_BEND_OUTER_HEIGHT
Outer height.
Definition: zwapi_cmd_sheetmetal_data.h:48
VX_BEND_EXTRAPOLATED_LENGTH
@ VX_BEND_EXTRAPOLATED_LENGTH
Extrapolated length.
Definition: zwapi_cmd_sheetmetal_data.h:50
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdKFactorType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdKFactorType

enum evxSmdKFactorType

#include <zwapi_cmd_sheetmetal_data.h>

K-factor Definition type.

Enumerator
VX_SMD_KTYPE_CUSTOM | custom
VX_SMD_KTYPE_FROM_MATERIAL | from material
VX_SMD_KTYPE_BEND_TABLE | bend table
VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE | bend allowance table
VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA | bend allowance formula
VX_SMD_KTYPE_BEND_DEDUCTION_TABLE | bend deduction table
VX_SMD_KTYPE_BEND_DEDUCTIOIN | bend deduction
VX_SMD_KTYPE_BEND_ALLOWANCE | bend allowance, svxExtrudeFlangeData::kType do not apply it.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 57 of file zwapi_cmd_sheetmetal_data.h.

58 {
59 VX_SMD_KTYPE_CUSTOM,
60 VX_SMD_KTYPE_FROM_MATERIAL,
61 VX_SMD_KTYPE_BEND_TABLE,
62 VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE,
63 VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA,
64 VX_SMD_KTYPE_BEND_DEDUCTION_TABLE,
65 VX_SMD_KTYPE_BEND_DEDUCTIOIN,
66 VX_SMD_KTYPE_BEND_ALLOWANCE,
67 } evxSmdKFactorType;
evxSmdKFactorType
evxSmdKFactorType
K-factor Definition type.
Definition: zwapi_cmd_sheetmetal_data.h:58
VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA
@ VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA
bend allowance formula
Definition: zwapi_cmd_sheetmetal_data.h:63
VX_SMD_KTYPE_BEND_DEDUCTION_TABLE
@ VX_SMD_KTYPE_BEND_DEDUCTION_TABLE
bend deduction table
Definition: zwapi_cmd_sheetmetal_data.h:64
VX_SMD_KTYPE_CUSTOM
@ VX_SMD_KTYPE_CUSTOM
custom
Definition: zwapi_cmd_sheetmetal_data.h:59
VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE
@ VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE
bend allowance table
Definition: zwapi_cmd_sheetmetal_data.h:62
VX_SMD_KTYPE_BEND_DEDUCTIOIN
@ VX_SMD_KTYPE_BEND_DEDUCTIOIN
bend deduction
Definition: zwapi_cmd_sheetmetal_data.h:65
VX_SMD_KTYPE_BEND_TABLE
@ VX_SMD_KTYPE_BEND_TABLE
bend table
Definition: zwapi_cmd_sheetmetal_data.h:61
VX_SMD_KTYPE_FROM_MATERIAL
@ VX_SMD_KTYPE_FROM_MATERIAL
from material
Definition: zwapi_cmd_sheetmetal_data.h:60
VX_SMD_KTYPE_BEND_ALLOWANCE
@ VX_SMD_KTYPE_BEND_ALLOWANCE
bend allowance, svxExtrudeFlangeData::kType do not apply it.
Definition: zwapi_cmd_sheetmetal_data.h:66
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExtFlangeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxExtFlangeType

enum evxExtFlangeType

#include <zwapi_cmd_sheetmetal_data.h>

Smd extrude type.

Enumerator
VX_EXTFLANGE_1SIDE | 1 side
VX_EXTFLANGE_2SIDES | 2 sides
VX_EXTFLANGE_SYMMETRICAL | symmetrical
Examples
part\smdFtrCrtTest.cpp.

Definition at line 190 of file zwapi_cmd_sheetmetal_data.h.

191 {
192 VX_EXTFLANGE_1SIDE,
193 VX_EXTFLANGE_2SIDES,
194 VX_EXTFLANGE_SYMMETRICAL,
195 } evxExtFlangeType;
evxExtFlangeType
evxExtFlangeType
Smd extrude type.
Definition: zwapi_cmd_sheetmetal_data.h:191
VX_EXTFLANGE_1SIDE
@ VX_EXTFLANGE_1SIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:192
VX_EXTFLANGE_2SIDES
@ VX_EXTFLANGE_2SIDES
2 sides
Definition: zwapi_cmd_sheetmetal_data.h:193
VX_EXTFLANGE_SYMMETRICAL
@ VX_EXTFLANGE_SYMMETRICAL
symmetrical
Definition: zwapi_cmd_sheetmetal_data.h:194
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPunchTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxPunchTyp

enum evxPunchTyp

#include <zwapi_cmd_sheetmetal_data.h>

Punch type.

Enumerator
VX_PUNCH_SHAPE | Punch from Shape.
VX_PUNCH_FILE | Punch from File.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 1032 of file zwapi_cmd_sheetmetal_data.h.

1033 {
1034 VX_PUNCH_SHAPE = 0,
1035 VX_PUNCH_FILE = 1,
1036 }evxPunchTyp;
evxPunchTyp
evxPunchTyp
Punch type.
Definition: zwapi_cmd_sheetmetal_data.h:1033
VX_PUNCH_SHAPE
@ VX_PUNCH_SHAPE
Punch from Shape.
Definition: zwapi_cmd_sheetmetal_data.h:1034
VX_PUNCH_FILE
@ VX_PUNCH_FILE
Punch from File.
Definition: zwapi_cmd_sheetmetal_data.h:1035
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdWebTaperType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdWebTaperType

enum evxSmdWebTaperType

#include <zwapi_cmd_sheetmetal_data.h>

smd bend web taper type

Enumerator
VX_SMD_TAPER_WEB_NONE | Tapers only the bend.
VX_SMD_TAPER_WEB_FACE | Tapers the bend and the adjacent web. The web taper is terminated at the next bend. You can specify a different value for the taper angle of the web.
VX_SMD_TAPER_WEB_FACE_CHAIN | Tapers the selected bend and all the webs and bends in the chain using the specified taper angle value. You can specify a different value for the taper angle of the web.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 846 of file zwapi_cmd_sheetmetal_data.h.

847 {
848 VX_SMD_TAPER_WEB_NONE,
849 VX_SMD_TAPER_WEB_FACE,
852 VX_SMD_TAPER_WEB_FACE_CHAIN,
854 } evxSmdWebTaperType;
evxSmdWebTaperType
evxSmdWebTaperType
smd bend web taper type
Definition: zwapi_cmd_sheetmetal_data.h:847
VX_SMD_TAPER_WEB_NONE
@ VX_SMD_TAPER_WEB_NONE
Tapers only the bend.
Definition: zwapi_cmd_sheetmetal_data.h:848
VX_SMD_TAPER_WEB_FACE
@ VX_SMD_TAPER_WEB_FACE
Tapers the bend and the adjacent web. The web taper is terminated at the next bend....
Definition: zwapi_cmd_sheetmetal_data.h:849
VX_SMD_TAPER_WEB_FACE_CHAIN
@ VX_SMD_TAPER_WEB_FACE_CHAIN
Tapers the selected bend and all the webs and bends in the chain using the specified taper angle valu...
Definition: zwapi_cmd_sheetmetal_data.h:852
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdExtendSideMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sheet Metal Commands Data
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ evxSmdExtendSideMethod

enum evxSmdExtendSideMethod

#include <zwapi_cmd_sheetmetal_data.h>

extend flange side method

Enumerator
VX_SMD_EXTEND_SIDE_NORMAL | Extend the flange normal to the edge.
VX_SMD_EXTEND_SIDE_ALONG | Extend along the edge.
Examples
part\smdFtrCrtTest.cpp.

Definition at line 806 of file zwapi_cmd_sheetmetal_data.h.

807 {
808 VX_SMD_EXTEND_SIDE_NORMAL,
809 VX_SMD_EXTEND_SIDE_ALONG,
810 } evxSmdExtendSideMethod;
evxSmdExtendSideMethod
evxSmdExtendSideMethod
extend flange side method
Definition: zwapi_cmd_sheetmetal_data.h:807
VX_SMD_EXTEND_SIDE_ALONG
@ VX_SMD_EXTEND_SIDE_ALONG
Extend along the edge.
Definition: zwapi_cmd_sheetmetal_data.h:809
VX_SMD_EXTEND_SIDE_NORMAL
@ VX_SMD_EXTEND_SIDE_NORMAL
Extend the flange normal to the edge.
Definition: zwapi_cmd_sheetmetal_data.h:808
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxRotateSetting

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxRotateSetting

enum evxRotateSetting

#include <zwapi_cmd_sk_cmds_data.h>

rotate setting

Enumerator
VX_ROTATE_MOVE | Move, default value.
VX_ROTATE_COPY | Copy.

Definition at line 693 of file zwapi_cmd_sk_cmds_data.h.

694 {
695 VX_ROTATE_MOVE = 1,
696 VX_ROTATE_COPY,
697 }evxRotateSetting;
evxRotateSetting
evxRotateSetting
rotate setting
Definition: zwapi_cmd_sk_cmds_data.h:694
VX_ROTATE_MOVE
@ VX_ROTATE_MOVE
Move, default value.
Definition: zwapi_cmd_sk_cmds_data.h:695
VX_ROTATE_COPY
@ VX_ROTATE_COPY
Copy.
Definition: zwapi_cmd_sk_cmds_data.h:696
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxRotateType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxRotateType

enum evxRotateType

#include <zwapi_cmd_sk_cmds_data.h>

rotate type

Enumerator
VX_ROTATE_ANGLE | Angle, default value.
VX_ROTATE_POINTS | Points.

Definition at line 683 of file zwapi_cmd_sk_cmds_data.h.

684 {
685 VX_ROTATE_ANGLE = 0,
686 VX_ROTATE_POINTS,
687 }evxRotateType;
evxRotateType
evxRotateType
rotate type
Definition: zwapi_cmd_sk_cmds_data.h:684
VX_ROTATE_ANGLE
@ VX_ROTATE_ANGLE
Angle, default value.
Definition: zwapi_cmd_sk_cmds_data.h:685
VX_ROTATE_POINTS
@ VX_ROTATE_POINTS
Points.
Definition: zwapi_cmd_sk_cmds_data.h:686
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDrawingMoveDirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxDrawingMoveDirType

enum evxDrawingMoveDirType

#include <zwapi_cmd_sk_cmds_data.h>

Sketch/Drawing move direction type.

Enumerator
VX_DRAWING_TWOPOINTS | two points
VX_DRAWING_HORIZONTAL | horizontal
VX_DRAWING_VERTICAL | vertical

Definition at line 643 of file zwapi_cmd_sk_cmds_data.h.

644 {
645 VX_DRAWING_TWOPOINTS,
646 VX_DRAWING_HORIZONTAL,
647 VX_DRAWING_VERTICAL,
648 } evxDrawingMoveDirType;
evxDrawingMoveDirType
evxDrawingMoveDirType
Sketch/Drawing move direction type.
Definition: zwapi_cmd_sk_cmds_data.h:644
VX_DRAWING_TWOPOINTS
@ VX_DRAWING_TWOPOINTS
two points
Definition: zwapi_cmd_sk_cmds_data.h:645
VX_DRAWING_VERTICAL
@ VX_DRAWING_VERTICAL
vertical
Definition: zwapi_cmd_sk_cmds_data.h:647
VX_DRAWING_HORIZONTAL
@ VX_DRAWING_HORIZONTAL
horizontal
Definition: zwapi_cmd_sk_cmds_data.h:646
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxConsDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxConsDimType

enum evxConsDimType

#include <zwapi_cmd_sk_cmds_data.h>

type of sketch constraint dimension

Enumerator
VX_SK_CONSDIM_UNKNOW | undefine.
VX_SK_CONSDIM_LINEAR | type of linear dimension
VX_SK_CONSDIM_LINEAR_OFFSET | type of linear offset dimension
VX_SK_CONSDIM_ANGULAR | type of angular dimension
VX_SK_CONSDIM_RADIAL | type of radial/diametric dimension
VX_SK_CONSDIM_ARC_LENGTH | type of arc length dimension
VX_SK_CONSDIM_SYMMETRY | type of symmetry dimension
VX_SK_CONSDIM_PERIMETER | type of perimeter dimension

Definition at line 567 of file zwapi_cmd_sk_cmds_data.h.

568 {
569 VX_SK_CONSDIM_UNKNOW = -1,
570 VX_SK_CONSDIM_LINEAR,
571 VX_SK_CONSDIM_LINEAR_OFFSET,
572 VX_SK_CONSDIM_ANGULAR,
573 VX_SK_CONSDIM_RADIAL,
574 VX_SK_CONSDIM_ARC_LENGTH,
575 VX_SK_CONSDIM_SYMMETRY,
576 VX_SK_CONSDIM_PERIMETER,
577 }evxConsDimType;
evxConsDimType
evxConsDimType
type of sketch constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:568
VX_SK_CONSDIM_RADIAL
@ VX_SK_CONSDIM_RADIAL
type of radial/diametric dimension
Definition: zwapi_cmd_sk_cmds_data.h:573
VX_SK_CONSDIM_LINEAR
@ VX_SK_CONSDIM_LINEAR
type of linear dimension
Definition: zwapi_cmd_sk_cmds_data.h:570
VX_SK_CONSDIM_SYMMETRY
@ VX_SK_CONSDIM_SYMMETRY
type of symmetry dimension
Definition: zwapi_cmd_sk_cmds_data.h:575
VX_SK_CONSDIM_UNKNOW
@ VX_SK_CONSDIM_UNKNOW
undefine.
Definition: zwapi_cmd_sk_cmds_data.h:569
VX_SK_CONSDIM_LINEAR_OFFSET
@ VX_SK_CONSDIM_LINEAR_OFFSET
type of linear offset dimension
Definition: zwapi_cmd_sk_cmds_data.h:571
VX_SK_CONSDIM_ANGULAR
@ VX_SK_CONSDIM_ANGULAR
type of angular dimension
Definition: zwapi_cmd_sk_cmds_data.h:572
VX_SK_CONSDIM_ARC_LENGTH
@ VX_SK_CONSDIM_ARC_LENGTH
type of arc length dimension
Definition: zwapi_cmd_sk_cmds_data.h:574
VX_SK_CONSDIM_PERIMETER
@ VX_SK_CONSDIM_PERIMETER
type of perimeter dimension
Definition: zwapi_cmd_sk_cmds_data.h:576
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkRefMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkRefMethod

enum evxSkRefMethod

#include <zwapi_cmd_sk_cmds_data.h>

sketch reference geometry method

Enumerator
VX_SK_REF_PROJECTION | projection method
VX_SK_REF_INTERSECTION | intersection method
Examples
sketch\skDrawingTest.cpp.

Definition at line 200 of file zwapi_cmd_sk_cmds_data.h.

201 {
202 VX_SK_REF_PROJECTION,
203 VX_SK_REF_INTERSECTION,
204 } evxSkRefMethod;
evxSkRefMethod
evxSkRefMethod
sketch reference geometry method
Definition: zwapi_cmd_sk_cmds_data.h:201
VX_SK_REF_PROJECTION
@ VX_SK_REF_PROJECTION
projection method
Definition: zwapi_cmd_sk_cmds_data.h:202
VX_SK_REF_INTERSECTION
@ VX_SK_REF_INTERSECTION
intersection method
Definition: zwapi_cmd_sk_cmds_data.h:203
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkRefOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkRefOption

enum evxSkRefOption

#include <zwapi_cmd_sk_cmds_data.h>

sketch reference type

Enumerator
VX_SK_REF_SINGLE | single
VX_SK_REF_CHAIN | chain
VX_SK_REF_LOOPS | loops
VX_SK_REF_POINT | point
Examples
sketch\skDrawingTest.cpp.

Definition at line 210 of file zwapi_cmd_sk_cmds_data.h.

211 {
212 VX_SK_REF_SINGLE,
213 VX_SK_REF_CHAIN,
214 VX_SK_REF_LOOPS,
215 VX_SK_REF_POINT,
216 } evxSkRefOption;
evxSkRefOption
evxSkRefOption
sketch reference type
Definition: zwapi_cmd_sk_cmds_data.h:211
VX_SK_REF_CHAIN
@ VX_SK_REF_CHAIN
chain
Definition: zwapi_cmd_sk_cmds_data.h:213
VX_SK_REF_POINT
@ VX_SK_REF_POINT
point
Definition: zwapi_cmd_sk_cmds_data.h:215
VX_SK_REF_SINGLE
@ VX_SK_REF_SINGLE
single
Definition: zwapi_cmd_sk_cmds_data.h:212
VX_SK_REF_LOOPS
@ VX_SK_REF_LOOPS
loops
Definition: zwapi_cmd_sk_cmds_data.h:214
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxGeomConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxGeomConsType

enum evxGeomConsType

#include <zwapi_cmd_sk_cmds_data.h>

type of sketch geometry constraint

Enumerator
VX_SK_CONS_FIX | point fixed constraint
VX_SK_CONS_ALI_Y | points horizontal constraint
VX_SK_CONS_ALI_X | points vertical constraint
VX_SK_CONS_MID | point to midpoint constraint
VX_SK_CONS_ON_CRV | point to line/curve constraint
VX_SK_CONS_ISECT | point to intersection constraint
VX_SK_CONS_COIN | point coincident constraint
VX_SK_CONS_HOR | line horizontal constraint
VX_SK_CONS_VER | line vertical constraint
VX_SK_CONS_SYM | entity symmetrical constraint
VX_SK_CONS_PERP | line perpendicular constraint
VX_SK_CONS_PARA | line parallel constraint
VX_SK_CONS_COLINLN | line collinear constraint
VX_SK_CONS_TANG | line tangent constraint
VX_SK_CONS_EQL_LEN | line equal length constraint
VX_SK_CONS_EQL_CURVATURE | line equal curvature constraint
VX_SK_CONS_CONC | point to center constraint
VX_SK_CONS_EQL_RAD | arc or circle equal radius constraint
VX_SK_CONS_SYM_DST | distance symmetrical constraint, created by mirror command
VX_SK_CONS_SYM_ANG | angle symmetrical constraint, created by mirror command
VX_SK_CONS_PTN | pattern constraint, created by pattern command
VX_SK_CONS_OFFSET | offset constraint, created by offset command

Definition at line 531 of file zwapi_cmd_sk_cmds_data.h.

532 {
533 VX_SK_CONS_UNKNOWN,
534 VX_SK_CONS_FIX,
535 VX_SK_CONS_ALI_Y,
536 VX_SK_CONS_ALI_X,
537 VX_SK_CONS_MID,
538 VX_SK_CONS_ON_CRV,
539 VX_SK_CONS_ISECT,
540 VX_SK_CONS_COIN,
541 VX_SK_CONS_HOR,
542 VX_SK_CONS_VER,
543 VX_SK_CONS_SYM,
544 VX_SK_CONS_PERP,
545 VX_SK_CONS_PARA,
546 VX_SK_CONS_COLINLN,
547 VX_SK_CONS_TANG,
548 VX_SK_CONS_EQL_LEN,
549 VX_SK_CONS_EQL_CURVATURE,
550 VX_SK_CONS_CONC,
551 VX_SK_CONS_EQL_RAD,
553 /* the following constraint types are created automatically by command and cannot be created by constraint command */
554 VX_SK_CONS_SYM_DST,
555 VX_SK_CONS_SYM_ANG,
556 VX_SK_CONS_PTN,
557 VX_SK_CONS_OFFSET
558 } evxGeomConsType;
evxGeomConsType
evxGeomConsType
type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:532
VX_SK_CONS_VER
@ VX_SK_CONS_VER
line vertical constraint
Definition: zwapi_cmd_sk_cmds_data.h:542
VX_SK_CONS_ISECT
@ VX_SK_CONS_ISECT
point to intersection constraint
Definition: zwapi_cmd_sk_cmds_data.h:539
VX_SK_CONS_EQL_CURVATURE
@ VX_SK_CONS_EQL_CURVATURE
line equal curvature constraint
Definition: zwapi_cmd_sk_cmds_data.h:549
VX_SK_CONS_PARA
@ VX_SK_CONS_PARA
line parallel constraint
Definition: zwapi_cmd_sk_cmds_data.h:545
VX_SK_CONS_EQL_RAD
@ VX_SK_CONS_EQL_RAD
arc or circle equal radius constraint
Definition: zwapi_cmd_sk_cmds_data.h:551
VX_SK_CONS_ALI_Y
@ VX_SK_CONS_ALI_Y
points horizontal constraint
Definition: zwapi_cmd_sk_cmds_data.h:535
VX_SK_CONS_FIX
@ VX_SK_CONS_FIX
point fixed constraint
Definition: zwapi_cmd_sk_cmds_data.h:534
VX_SK_CONS_ALI_X
@ VX_SK_CONS_ALI_X
points vertical constraint
Definition: zwapi_cmd_sk_cmds_data.h:536
VX_SK_CONS_MID
@ VX_SK_CONS_MID
point to midpoint constraint
Definition: zwapi_cmd_sk_cmds_data.h:537
VX_SK_CONS_HOR
@ VX_SK_CONS_HOR
line horizontal constraint
Definition: zwapi_cmd_sk_cmds_data.h:541
VX_SK_CONS_SYM_DST
@ VX_SK_CONS_SYM_DST
distance symmetrical constraint, created by mirror command
Definition: zwapi_cmd_sk_cmds_data.h:554
VX_SK_CONS_SYM_ANG
@ VX_SK_CONS_SYM_ANG
angle symmetrical constraint, created by mirror command
Definition: zwapi_cmd_sk_cmds_data.h:555
VX_SK_CONS_ON_CRV
@ VX_SK_CONS_ON_CRV
point to line/curve constraint
Definition: zwapi_cmd_sk_cmds_data.h:538
VX_SK_CONS_CONC
@ VX_SK_CONS_CONC
point to center constraint
Definition: zwapi_cmd_sk_cmds_data.h:550
VX_SK_CONS_COLINLN
@ VX_SK_CONS_COLINLN
line collinear constraint
Definition: zwapi_cmd_sk_cmds_data.h:546
VX_SK_CONS_SYM
@ VX_SK_CONS_SYM
entity symmetrical constraint
Definition: zwapi_cmd_sk_cmds_data.h:543
VX_SK_CONS_COIN
@ VX_SK_CONS_COIN
point coincident constraint
Definition: zwapi_cmd_sk_cmds_data.h:540
VX_SK_CONS_EQL_LEN
@ VX_SK_CONS_EQL_LEN
line equal length constraint
Definition: zwapi_cmd_sk_cmds_data.h:548
VX_SK_CONS_TANG
@ VX_SK_CONS_TANG
line tangent constraint
Definition: zwapi_cmd_sk_cmds_data.h:547
VX_SK_CONS_PTN
@ VX_SK_CONS_PTN
pattern constraint, created by pattern command
Definition: zwapi_cmd_sk_cmds_data.h:556
VX_SK_CONS_PERP
@ VX_SK_CONS_PERP
line perpendicular constraint
Definition: zwapi_cmd_sk_cmds_data.h:544
VX_SK_CONS_OFFSET
@ VX_SK_CONS_OFFSET
offset constraint, created by offset command
Definition: zwapi_cmd_sk_cmds_data.h:557
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkChainOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkChainOption

enum evxSkChainOption

#include <zwapi_cmd_sk_cmds_data.h>

sketch reference chain option

Enumerator
VX_SK_CHAIN_PICK | chain pick
VX_SK_CHAIN_BETWEEN_PICKS | chain between picks
Examples
sketch\skDrawingTest.cpp.

Definition at line 222 of file zwapi_cmd_sk_cmds_data.h.

223 {
224 VX_SK_CHAIN_PICK,
225 VX_SK_CHAIN_BETWEEN_PICKS,
226 } evxSkChainOption;
evxSkChainOption
evxSkChainOption
sketch reference chain option
Definition: zwapi_cmd_sk_cmds_data.h:223
VX_SK_CHAIN_PICK
@ VX_SK_CHAIN_PICK
chain pick
Definition: zwapi_cmd_sk_cmds_data.h:224
VX_SK_CHAIN_BETWEEN_PICKS
@ VX_SK_CHAIN_BETWEEN_PICKS
chain between picks
Definition: zwapi_cmd_sk_cmds_data.h:225
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkLoopOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkLoopOption

enum evxSkLoopOption

#include <zwapi_cmd_sk_cmds_data.h>

sketch reference loop option

Enumerator
VX_SK_LOOP_ALL | all loops of surface
VX_SK_LOOP_BOUNDARY | boundary of surface
VX_SK_LOOP_SHARED | shared edges between multiple surfaces
VX_SK_LOOP_INNER | inner loop of surface
VX_SK_LOOP_OUTER | outer loop of surface
VX_SK_LOOP_OPEN_BOUNDARY | open boundary of surface
VX_SK_LOOP_NON_SHARED_BOUNDARY | non-shared boundary of the picked surfaces
VX_SK_LOOP_SILHOUETTE | silhouette of the picked surface
Examples
sketch\skDrawingTest.cpp.

Definition at line 232 of file zwapi_cmd_sk_cmds_data.h.

233 {
234 VX_SK_LOOP_ALL,
235 VX_SK_LOOP_BOUNDARY,
236 VX_SK_LOOP_SHARED,
237 VX_SK_LOOP_INNER,
238 VX_SK_LOOP_OUTER,
239 VX_SK_LOOP_OPEN_BOUNDARY,
240 VX_SK_LOOP_NON_SHARED_BOUNDARY,
241 VX_SK_LOOP_SILHOUETTE,
242 } evxSkLoopOption;
evxSkLoopOption
evxSkLoopOption
sketch reference loop option
Definition: zwapi_cmd_sk_cmds_data.h:233
VX_SK_LOOP_OUTER
@ VX_SK_LOOP_OUTER
outer loop of surface
Definition: zwapi_cmd_sk_cmds_data.h:238
VX_SK_LOOP_INNER
@ VX_SK_LOOP_INNER
inner loop of surface
Definition: zwapi_cmd_sk_cmds_data.h:237
VX_SK_LOOP_NON_SHARED_BOUNDARY
@ VX_SK_LOOP_NON_SHARED_BOUNDARY
non-shared boundary of the picked surfaces
Definition: zwapi_cmd_sk_cmds_data.h:240
VX_SK_LOOP_SHARED
@ VX_SK_LOOP_SHARED
shared edges between multiple surfaces
Definition: zwapi_cmd_sk_cmds_data.h:236
VX_SK_LOOP_SILHOUETTE
@ VX_SK_LOOP_SILHOUETTE
silhouette of the picked surface
Definition: zwapi_cmd_sk_cmds_data.h:241
VX_SK_LOOP_OPEN_BOUNDARY
@ VX_SK_LOOP_OPEN_BOUNDARY
open boundary of surface
Definition: zwapi_cmd_sk_cmds_data.h:239
VX_SK_LOOP_ALL
@ VX_SK_LOOP_ALL
all loops of surface
Definition: zwapi_cmd_sk_cmds_data.h:234
VX_SK_LOOP_BOUNDARY
@ VX_SK_LOOP_BOUNDARY
boundary of surface
Definition: zwapi_cmd_sk_cmds_data.h:235
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkSpacingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkSpacingType

enum evxSkSpacingType

#include <zwapi_cmd_sk_cmds_data.h>

sketch pattern spacing method

Enumerator
VX_NUMBER_PITCH | number and pitch option
VX_NUMBER_SPAN | number and span option
VX_PITCH_SPAN | pitch and span option

Definition at line 743 of file zwapi_cmd_sk_cmds_data.h.

744 {
745 VX_NUMBER_PITCH,
746 VX_NUMBER_SPAN,
747 VX_PITCH_SPAN,
748 } evxSkSpacingType;
evxSkSpacingType
evxSkSpacingType
sketch pattern spacing method
Definition: zwapi_cmd_sk_cmds_data.h:744
VX_NUMBER_PITCH
@ VX_NUMBER_PITCH
number and pitch option
Definition: zwapi_cmd_sk_cmds_data.h:745
VX_PITCH_SPAN
@ VX_PITCH_SPAN
pitch and span option
Definition: zwapi_cmd_sk_cmds_data.h:747
VX_NUMBER_SPAN
@ VX_NUMBER_SPAN
number and span option
Definition: zwapi_cmd_sk_cmds_data.h:746
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkChamferExtenOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkChamferExtenOpt

enum evxSkChamferExtenOpt

#include <zwapi_cmd_sk_cmds_data.h>

control the path of extended curves in chamfer/fillet of sheeting or sketch

Enumerator
VX_CHMEXT_LINEAR | The extension follows a linear path.
VX_CHMEXT_CIRCULAR | The extension follows an arc path in the direction of curvature.
VX_CHMEXT_REFLECT | The extension follows a reflective path opposite the direction of curvature.

Definition at line 343 of file zwapi_cmd_sk_cmds_data.h.

344 {
345 VX_CHMEXT_LINEAR = 1,
346 VX_CHMEXT_CIRCULAR,
347 VX_CHMEXT_REFLECT
348 } evxSkChamferExtenOpt;
evxSkChamferExtenOpt
evxSkChamferExtenOpt
control the path of extended curves in chamfer/fillet of sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:344
VX_CHMEXT_REFLECT
@ VX_CHMEXT_REFLECT
The extension follows a reflective path opposite the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:347
VX_CHMEXT_CIRCULAR
@ VX_CHMEXT_CIRCULAR
The extension follows an arc path in the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:346
VX_CHMEXT_LINEAR
@ VX_CHMEXT_LINEAR
The extension follows a linear path.
Definition: zwapi_cmd_sk_cmds_data.h:345
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxReadyTextMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxReadyTextMethods

enum evxReadyTextMethods

#include <zwapi_cmd_sk_cmds_data.h>

Create Sketch ready text Methods.

Enumerator
VX_ON_CRV | on curve text
VX_BOX | box text

Definition at line 110 of file zwapi_cmd_sk_cmds_data.h.

111 {
112 VX_ON_CRV = 1,
113 VX_BOX = 2,
114 } evxReadyTextMethods;
evxReadyTextMethods
evxReadyTextMethods
Create Sketch ready text Methods.
Definition: zwapi_cmd_sk_cmds_data.h:111
VX_BOX
@ VX_BOX
box text
Definition: zwapi_cmd_sk_cmds_data.h:113
VX_ON_CRV
@ VX_ON_CRV
on curve text
Definition: zwapi_cmd_sk_cmds_data.h:112
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkNgonsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkNgonsType

enum evxSkNgonsType

#include <zwapi_cmd_sk_cmds_data.h>

sketch polygon method

Enumerator
VX_SK_NGONS_IN_R | inscribed radius
VX_SK_NGONS_CIR_R | circumscribed radius
VX_SK_NGONS_SIDE_LEN | side length
VX_SK_NGONS_IN_BOUND | inscribed boundary
VX_SK_NGONS_CIR_BOUND | circumscribed boundary
VX_SK_NGONS_SIDE_BOUND | side boundary

Definition at line 160 of file zwapi_cmd_sk_cmds_data.h.

161 {
162 VX_SK_NGONS_IN_R,
163 VX_SK_NGONS_CIR_R,
164 VX_SK_NGONS_SIDE_LEN,
165 VX_SK_NGONS_IN_BOUND,
166 VX_SK_NGONS_CIR_BOUND,
167 VX_SK_NGONS_SIDE_BOUND,
168 } evxSkNgonsType;
evxSkNgonsType
evxSkNgonsType
sketch polygon method
Definition: zwapi_cmd_sk_cmds_data.h:161
VX_SK_NGONS_CIR_R
@ VX_SK_NGONS_CIR_R
circumscribed radius
Definition: zwapi_cmd_sk_cmds_data.h:163
VX_SK_NGONS_CIR_BOUND
@ VX_SK_NGONS_CIR_BOUND
circumscribed boundary
Definition: zwapi_cmd_sk_cmds_data.h:166
VX_SK_NGONS_IN_R
@ VX_SK_NGONS_IN_R
inscribed radius
Definition: zwapi_cmd_sk_cmds_data.h:162
VX_SK_NGONS_SIDE_BOUND
@ VX_SK_NGONS_SIDE_BOUND
side boundary
Definition: zwapi_cmd_sk_cmds_data.h:167
VX_SK_NGONS_IN_BOUND
@ VX_SK_NGONS_IN_BOUND
inscribed boundary
Definition: zwapi_cmd_sk_cmds_data.h:165
VX_SK_NGONS_SIDE_LEN
@ VX_SK_NGONS_SIDE_LEN
side length
Definition: zwapi_cmd_sk_cmds_data.h:164
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkPatternType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkPatternType

enum evxSkPatternType

#include <zwapi_cmd_sk_cmds_data.h>

sketch pattern method

Enumerator
VX_SKPATTERN_LINEAR | linear pattern
VX_SKPATTERN_CIRCULAR | circular pattern
VX_SKPATTERN_AT_CURVES | pattern in space using one or more input curves

Definition at line 732 of file zwapi_cmd_sk_cmds_data.h.

733 {
734 VX_SKPATTERN_LINEAR,
735 VX_SKPATTERN_CIRCULAR,
736 VX_SKPATTERN_AT_CURVES,
737 } evxSkPatternType;
evxSkPatternType
evxSkPatternType
sketch pattern method
Definition: zwapi_cmd_sk_cmds_data.h:733
VX_SKPATTERN_LINEAR
@ VX_SKPATTERN_LINEAR
linear pattern
Definition: zwapi_cmd_sk_cmds_data.h:734
VX_SKPATTERN_CIRCULAR
@ VX_SKPATTERN_CIRCULAR
circular pattern
Definition: zwapi_cmd_sk_cmds_data.h:735
VX_SKPATTERN_AT_CURVES
@ VX_SKPATTERN_AT_CURVES
pattern in space using one or more input curves
Definition: zwapi_cmd_sk_cmds_data.h:736
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxGeomConsSubType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxGeomConsSubType

enum evxGeomConsSubType

#include <zwapi_cmd_sk_cmds_data.h>

sub type of sketch geometry constraint

Enumerator
VX_SK_CONS_XY_COORDS_CONS | both the X and Y coordinates are constrained, used to VX_SK_CONS_FIX
VX_SK_CONS_X_COORD_CONS | only the X coordinate is constrained, used to VX_SK_CONS_FIX
VX_SK_CONS_Y_COORD_CONS | only the Y coordinate is constrained, used to VX_SK_CONS_FIX
VX_SK_PNT_TO_ARC_MIDPNT_CONS | point to arc midpoint constraint, used to VX_SK_CONS_MID
VX_SK_PNTS_SYMMETRY_CONS | mark as points symmetry, used to VX_SK_CONS_SYM

Definition at line 518 of file zwapi_cmd_sk_cmds_data.h.

519 {
520 VX_SK_CONS_XY_COORDS_CONS = 0,
521 VX_SK_CONS_X_COORD_CONS,
522 VX_SK_CONS_Y_COORD_CONS,
523 VX_SK_PNT_TO_ARC_MIDPNT_CONS,
524 VX_SK_PNTS_SYMMETRY_CONS,
525 } evxGeomConsSubType;
evxGeomConsSubType
evxGeomConsSubType
sub type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:519
VX_SK_CONS_X_COORD_CONS
@ VX_SK_CONS_X_COORD_CONS
only the X coordinate is constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:521
VX_SK_CONS_XY_COORDS_CONS
@ VX_SK_CONS_XY_COORDS_CONS
both the X and Y coordinates are constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:520
VX_SK_PNT_TO_ARC_MIDPNT_CONS
@ VX_SK_PNT_TO_ARC_MIDPNT_CONS
point to arc midpoint constraint, used to VX_SK_CONS_MID
Definition: zwapi_cmd_sk_cmds_data.h:523
VX_SK_CONS_Y_COORD_CONS
@ VX_SK_CONS_Y_COORD_CONS
only the Y coordinate is constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:522
VX_SK_PNTS_SYMMETRY_CONS
@ VX_SK_PNTS_SYMMETRY_CONS
mark as points symmetry, used to VX_SK_CONS_SYM
Definition: zwapi_cmd_sk_cmds_data.h:524
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxMoveType2D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxMoveType2D

enum evxMoveType2D

#include <zwapi_cmd_sk_cmds_data.h>

Move and Copy Methods(2D)

Enumerator
VX_PNT_TO_PNT_2D | copy/move entities along a direction (2D)
VX_ALONG_DIR_2D | copy/move entities form point to point (2D)

Definition at line 620 of file zwapi_cmd_sk_cmds_data.h.

621 {
622 VX_PNT_TO_PNT_2D,
623 VX_ALONG_DIR_2D,
624 } evxMoveType2D;
evxMoveType2D
evxMoveType2D
Move and Copy Methods(2D)
Definition: zwapi_cmd_sk_cmds_data.h:621
VX_PNT_TO_PNT_2D
@ VX_PNT_TO_PNT_2D
copy/move entities along a direction (2D)
Definition: zwapi_cmd_sk_cmds_data.h:622
VX_ALONG_DIR_2D
@ VX_ALONG_DIR_2D
copy/move entities form point to point (2D)
Definition: zwapi_cmd_sk_cmds_data.h:623
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxConic3PntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxConic3PntType

enum evxConic3PntType

#include <zwapi_cmd_sk_cmds_data.h>

3 Point Conic type

Enumerator
VX_CONIC_SHOULDER | Shoulder, 3 Point Conic default value.
VX_CONIC_TANGENT | Tangent.

Definition at line 297 of file zwapi_cmd_sk_cmds_data.h.

298 {
299 VX_CONIC_SHOULDER = 0,
300 VX_CONIC_TANGENT = 1,
301 }evxConic3PntType;
evxConic3PntType
evxConic3PntType
3 Point Conic type
Definition: zwapi_cmd_sk_cmds_data.h:298
VX_CONIC_TANGENT
@ VX_CONIC_TANGENT
Tangent.
Definition: zwapi_cmd_sk_cmds_data.h:300
VX_CONIC_SHOULDER
@ VX_CONIC_SHOULDER
Shoulder, 3 Point Conic default value.
Definition: zwapi_cmd_sk_cmds_data.h:299
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkAxisMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkAxisMethods

enum evxSkAxisMethods

#include <zwapi_cmd_sk_cmds_data.h>

Create Sketch Axis Methods.

Enumerator
VX_SK_AXIS_TWO_PNT | Two Point.
VX_SK_AXIS_PARAPT | Parallel and a pin point.
VX_SK_AXIS_PERPENDICULAR | Perpendicular and a pin point.
VX_SK_AXIS_ANGLE | Angle.
VX_SK_AXIS_PARAOFF | Parallel and Offset.
VX_SK_AXIS_HORIZ | Horizontal.
VX_SK_AXIS_VERT | Vertical.

Definition at line 32 of file zwapi_cmd_sk_cmds_data.h.

33 {
34 VX_SK_AXIS_TWO_PNT = 0,
35 VX_SK_AXIS_PARAPT = 1,
36 VX_SK_AXIS_PERPENDICULAR = 2,
37 VX_SK_AXIS_ANGLE = 3,
38 VX_SK_AXIS_PARAOFF = 4,
39 VX_SK_AXIS_HORIZ = 5,
40 VX_SK_AXIS_VERT = 6,
41 } evxSkAxisMethods;
evxSkAxisMethods
evxSkAxisMethods
Create Sketch Axis Methods.
Definition: zwapi_cmd_sk_cmds_data.h:33
VX_SK_AXIS_PARAOFF
@ VX_SK_AXIS_PARAOFF
Parallel and Offset.
Definition: zwapi_cmd_sk_cmds_data.h:38
VX_SK_AXIS_PARAPT
@ VX_SK_AXIS_PARAPT
Parallel and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:35
VX_SK_AXIS_TWO_PNT
@ VX_SK_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_sk_cmds_data.h:34
VX_SK_AXIS_VERT
@ VX_SK_AXIS_VERT
Vertical.
Definition: zwapi_cmd_sk_cmds_data.h:40
VX_SK_AXIS_ANGLE
@ VX_SK_AXIS_ANGLE
Angle.
Definition: zwapi_cmd_sk_cmds_data.h:37
VX_SK_AXIS_HORIZ
@ VX_SK_AXIS_HORIZ
Horizontal.
Definition: zwapi_cmd_sk_cmds_data.h:39
VX_SK_AXIS_PERPENDICULAR
@ VX_SK_AXIS_PERPENDICULAR
Perpendicular and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:36
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTrimSplitCor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxTrimSplitCor

enum evxTrimSplitCor

#include <zwapi_cmd_sk_cmds_data.h>

trim/split to corner option method

Enumerator
VX_SPLIT_COR_LINEAR | lionear option
VX_SPLIT_COR_ARC | arc option
VX_SPLIT_COR_REFLECT | reflect option

Definition at line 418 of file zwapi_cmd_sk_cmds_data.h.

419 {
420 VX_SPLIT_COR_LINEAR,
421 VX_SPLIT_COR_ARC,
422 VX_SPLIT_COR_REFLECT,
423 } evxTrimSplitCor;
evxTrimSplitCor
evxTrimSplitCor
trim/split to corner option method
Definition: zwapi_cmd_sk_cmds_data.h:419
VX_SPLIT_COR_LINEAR
@ VX_SPLIT_COR_LINEAR
lionear option
Definition: zwapi_cmd_sk_cmds_data.h:420
VX_SPLIT_COR_REFLECT
@ VX_SPLIT_COR_REFLECT
reflect option
Definition: zwapi_cmd_sk_cmds_data.h:422
VX_SPLIT_COR_ARC
@ VX_SPLIT_COR_ARC
arc option
Definition: zwapi_cmd_sk_cmds_data.h:421
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTrimSplit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxTrimSplit

enum evxTrimSplit

#include <zwapi_cmd_sk_cmds_data.h>

trim/extend extension method

Enumerator
VX_SPLIT_KEEP | keep option
VX_SPLIT_DELETE | delete option
VX_SPLIT_BREAK | berak option

Definition at line 407 of file zwapi_cmd_sk_cmds_data.h.

408 {
409 VX_SPLIT_KEEP,
410 VX_SPLIT_DELETE,
411 VX_SPLIT_BREAK,
412 } evxTrimSplit;
evxTrimSplit
evxTrimSplit
trim/extend extension method
Definition: zwapi_cmd_sk_cmds_data.h:408
VX_SPLIT_KEEP
@ VX_SPLIT_KEEP
keep option
Definition: zwapi_cmd_sk_cmds_data.h:409
VX_SPLIT_DELETE
@ VX_SPLIT_DELETE
delete option
Definition: zwapi_cmd_sk_cmds_data.h:410
VX_SPLIT_BREAK
@ VX_SPLIT_BREAK
berak option
Definition: zwapi_cmd_sk_cmds_data.h:411
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkCopyDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkCopyDir

enum evxSkCopyDir

#include <zwapi_cmd_sk_cmds_data.h>

sketch copy from point to point direction method

Enumerator
VX_SK_COPY_DIR_TWO | two points
VX_SK_COPY_DIR_HORIZONTAL | horizontal
VX_SK_COPY_DIR_VERTICAL | vertical

Definition at line 813 of file zwapi_cmd_sk_cmds_data.h.

814 {
815 VX_SK_COPY_DIR_TWO,
816 VX_SK_COPY_DIR_HORIZONTAL,
817 VX_SK_COPY_DIR_VERTICAL,
818 } evxSkCopyDir;
evxSkCopyDir
evxSkCopyDir
sketch copy from point to point direction method
Definition: zwapi_cmd_sk_cmds_data.h:814
VX_SK_COPY_DIR_HORIZONTAL
@ VX_SK_COPY_DIR_HORIZONTAL
horizontal
Definition: zwapi_cmd_sk_cmds_data.h:816
VX_SK_COPY_DIR_VERTICAL
@ VX_SK_COPY_DIR_VERTICAL
vertical
Definition: zwapi_cmd_sk_cmds_data.h:817
VX_SK_COPY_DIR_TWO
@ VX_SK_COPY_DIR_TWO
two points
Definition: zwapi_cmd_sk_cmds_data.h:815
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTrimExtension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxTrimExtension

enum evxTrimExtension

#include <zwapi_cmd_sk_cmds_data.h>

trim/extend extension method

Enumerator
VX_EXT_LINEAR | linear option
VX_EXT_ARC | arc option
VX_EXT_REFLECT | reflect option
VX_EXT_CRV_DIM | curvature diminishing option

Definition at line 395 of file zwapi_cmd_sk_cmds_data.h.

396 {
397 VX_EXT_LINEAR = 1,
398 VX_EXT_ARC,
399 VX_EXT_REFLECT,
400 VX_EXT_CRV_DIM
401 } evxTrimExtension;
evxTrimExtension
evxTrimExtension
trim/extend extension method
Definition: zwapi_cmd_sk_cmds_data.h:396
VX_EXT_LINEAR
@ VX_EXT_LINEAR
linear option
Definition: zwapi_cmd_sk_cmds_data.h:397
VX_EXT_ARC
@ VX_EXT_ARC
arc option
Definition: zwapi_cmd_sk_cmds_data.h:398
VX_EXT_REFLECT
@ VX_EXT_REFLECT
reflect option
Definition: zwapi_cmd_sk_cmds_data.h:399
VX_EXT_CRV_DIM
@ VX_EXT_CRV_DIM
curvature diminishing option
Definition: zwapi_cmd_sk_cmds_data.h:400
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkChamferTrimOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkChamferTrimOpt

enum evxSkChamferTrimOpt

#include <zwapi_cmd_sk_cmds_data.h>

option of trim in chamfer/fillet of sheeting or sketch

Enumerator
VX_CHMTRIM_NO | No trim/extend is performed.
VX_CHMTRIM_BOTH | Trim/Extend both curves.
VX_CHMTRIM_FIRST | Trim/Extend only the first selected curve.
VX_CHMTRIM_SECOND | Trim/extend only the second selected curve.

Definition at line 331 of file zwapi_cmd_sk_cmds_data.h.

332 {
333 VX_CHMTRIM_NO = 0,
334 VX_CHMTRIM_BOTH,
335 VX_CHMTRIM_FIRST,
336 VX_CHMTRIM_SECOND
337 } evxSkChamferTrimOpt;
evxSkChamferTrimOpt
evxSkChamferTrimOpt
option of trim in chamfer/fillet of sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:332
VX_CHMTRIM_FIRST
@ VX_CHMTRIM_FIRST
Trim/Extend only the first selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:335
VX_CHMTRIM_BOTH
@ VX_CHMTRIM_BOTH
Trim/Extend both curves.
Definition: zwapi_cmd_sk_cmds_data.h:334
VX_CHMTRIM_SECOND
@ VX_CHMTRIM_SECOND
Trim/extend only the second selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:336
VX_CHMTRIM_NO
@ VX_CHMTRIM_NO
No trim/extend is performed.
Definition: zwapi_cmd_sk_cmds_data.h:333
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkChamferOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkChamferOpt

enum evxSkChamferOpt

#include <zwapi_cmd_sk_cmds_data.h>

option of chamfer in sheeting or sketch

Enumerator
VX_CHMOPT_SETBACK | a chamfer of equal setback values between two curves
VX_CHMOPT_TWOSETBACK | a chamfer with different setback values between two curves
VX_CHMOPT_SETBACKANDDIS | a chamfer by specifying the setback and an angle

Definition at line 320 of file zwapi_cmd_sk_cmds_data.h.

321 {
322 VX_CHMOPT_SETBACK = 0,
323 VX_CHMOPT_TWOSETBACK,
324 VX_CHMOPT_SETBACKANDDIS
325 } evxSkChamferOpt;
evxSkChamferOpt
evxSkChamferOpt
option of chamfer in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:321
VX_CHMOPT_SETBACKANDDIS
@ VX_CHMOPT_SETBACKANDDIS
a chamfer by specifying the setback and an angle
Definition: zwapi_cmd_sk_cmds_data.h:324
VX_CHMOPT_TWOSETBACK
@ VX_CHMOPT_TWOSETBACK
a chamfer with different setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:323
VX_CHMOPT_SETBACK
@ VX_CHMOPT_SETBACK
a chamfer of equal setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:322
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSkCopyType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sketch Commands Data
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ evxSkCopyType

enum evxSkCopyType

#include <zwapi_cmd_sk_cmds_data.h>

sketch copy method

Enumerator
VX_SK_COPY_PNT | copy entities from point to point
VX_SK_COPY_DIR | copy entities along a direction

Definition at line 803 of file zwapi_cmd_sk_cmds_data.h.

804 {
805 VX_SK_COPY_PNT,
806 VX_SK_COPY_DIR,
807 } evxSkCopyType;
evxSkCopyType
evxSkCopyType
sketch copy method
Definition: zwapi_cmd_sk_cmds_data.h:804
VX_SK_COPY_DIR
@ VX_SK_COPY_DIR
copy entities along a direction
Definition: zwapi_cmd_sk_cmds_data.h:806
VX_SK_COPY_PNT
@ VX_SK_COPY_PNT
copy entities from point to point
Definition: zwapi_cmd_sk_cmds_data.h:805
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxHatchPtnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Create Sketch Commands Data
evxHatchPtnType
evxHatchPtnType
svxHatchPtnData
svxSketchData

◆ evxHatchPtnType

enum evxHatchPtnType

#include <zwapi_cmd_sk_create_data.h>

hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sketch or cross-hatch command to see.

Enumerator
VX_HATCH_PATTERN_ANSI31 | ANSI31.
VX_HATCH_PATTERN_ANSI32 | ANSI32.
VX_HATCH_PATTERN_ANSI33 | ANSI33.
VX_HATCH_PATTERN_ANSI34 | ANSI34.
VX_HATCH_PATTERN_ANSI35 | ANSI35.
VX_HATCH_PATTERN_ANSI36 | ANSI36.
VX_HATCH_PATTERN_ANSI37 | ANSI37.
VX_HATCH_PATTERN_ANSI38 | ANSI38.
VX_HATCH_PATTERN_SHADOW_PLATE | SHADOW_PLATE.
VX_HATCH_PATTERN_BRICK | BRICK.
VX_HATCH_PATTERN_CORK | CORK.
VX_HATCH_PATTERN_CROSS | CROSS.
VX_HATCH_PATTERN_DASH | DASH.
VX_HATCH_PATTERN_LIMESTONE | LIMESTONE.
VX_HATCH_PATTERN_DOTS | DOTS.
VX_HATCH_PATTERN_EARTH | EARTH.
VX_HATCH_PATTERN_EXPANSION | EXPANSION.
VX_HATCH_PATTERN_GRASS | GRASS.
VX_HATCH_PATTERN_GRATE | GRATE.
VX_HATCH_PATTERN_HEXAGON | HEXAGON.
VX_HATCH_PATTERN_HONEYCOMB | HONEYCOMB.
VX_HATCH_PATTERN_SQUARES | SQUARES.
VX_HATCH_PATTERN_MOONYANG | MOONYANG.
VX_HATCH_PATTERN_BOX | BOX.
VX_HATCH_PATTERN_BRASS | BRASS.
VX_HATCH_PATTERN_BRSTONE | BRSTONE.
VX_HATCH_PATTERN_CLAY | CLAY.
VX_HATCH_PATTERN_ESCHER | ESCHER.
VX_HATCH_PATTERN_GRAVEL | GRAVEL.
VX_HATCH_PATTERN_HOUND | HOUND.
VX_HATCH_PATTERN_INSUL | INSUL.
VX_HATCH_PATTERN_ACAD_ISO02W100 | ACAD_ISO02W100.
VX_HATCH_PATTERN_ACAD_ISO03W100 | ACAD_ISO03W100.
VX_HATCH_PATTERN_ACAD_ISO04W100 | ACAD_ISO04W100.
VX_HATCH_PATTERN_ACAD_ISO05W100 | ACAD_ISO05W100.
VX_HATCH_PATTERN_ACAD_ISO06W100 | ACAD_ISO06W100.
VX_HATCH_PATTERN_ACAD_ISO07W100 | ACAD_ISO07W100.
VX_HATCH_PATTERN_ACAD_ISO08W100 | ACAD_ISO08W100.
VX_HATCH_PATTERN_ACAD_ISO09W100 | ACAD_ISO09W100.
VX_HATCH_PATTERN_ACAD_ISO10W100 | ACAD_ISO10W100.
VX_HATCH_PATTERN_ACAD_ISO11W100 | ACAD_ISO11W100.
VX_HATCH_PATTERN_ACAD_ISO12W100 | ACAD_ISO12W100.
VX_HATCH_PATTERN_ACAD_ISO13W100 | ACAD_ISO13W100.
VX_HATCH_PATTERN_ACAD_ISO14W100 | ACAD_ISO14W100.
VX_HATCH_PATTERN_ACAD_ISO15W100 | ACAD_ISO15W100.
VX_HATCH_PATTERN_JIS_LC_20 | JIS_LC_20.
VX_HATCH_PATTERN_JIS_LC_20A | JIS_LC_20A.
VX_HATCH_PATTERN_JIS_LC_8A | JIS_LC_8A.
VX_HATCH_PATTERN_JIS_LC_8 | JIS_LC_8.
VX_HATCH_PATTERN_JIS_RC_10 | JIS_RC_10.
VX_HATCH_PATTERN_JIS_RC_15 | JIS_RC_15.
VX_HATCH_PATTERN_JIS_RC_18 | JIS_RC_18.
VX_HATCH_PATTERN_JIS_RC_30 | JIS_RC_30.
VX_HATCH_PATTERN_JIS_STN_1E | JIS_STN_1E.
VX_HATCH_PATTERN_JIS_STN_2_5 | JIS_STN_2_5.
VX_HATCH_PATTERN_JIS_WOOD | JIS_WOOD.
VX_HATCH_PATTERN_LINE | LINE.
VX_HATCH_PATTERN_MUDST | MUDST.
VX_HATCH_PATTERN_NET | NET.
VX_HATCH_PATTERN_NET3 | NET3.
VX_HATCH_PATTERN_PLAST | PLAST.
VX_HATCH_PATTERN_PLASTI | PLASTI.
VX_HATCH_PATTERN_SACNCR | SACNCR.
VX_HATCH_PATTERN_STARS | STARS.
VX_HATCH_PATTERN_STEEL | STEEL.
VX_HATCH_PATTERN_SWAMP | SWAMP.
VX_HATCH_PATTERN_TRANS | TRANS.
VX_HATCH_PATTERN_TRIANG | TRIANG.
VX_HATCH_PATTERN_ZIGZAG | ZIGZAG.
VX_HATCH_PATTERN_SOLID | SOLID.

Definition at line 63 of file zwapi_cmd_sk_create_data.h.

64 {
65 VX_HATCH_PATTERN_ANSI31,
66 VX_HATCH_PATTERN_ANSI32,
67 VX_HATCH_PATTERN_ANSI33,
68 VX_HATCH_PATTERN_ANSI34,
69 VX_HATCH_PATTERN_ANSI35,
70 VX_HATCH_PATTERN_ANSI36,
71 VX_HATCH_PATTERN_ANSI37,
72 VX_HATCH_PATTERN_ANSI38,
73 VX_HATCH_PATTERN_SHADOW_PLATE,
74 VX_HATCH_PATTERN_BRICK,
75 VX_HATCH_PATTERN_CORK,
76 VX_HATCH_PATTERN_CROSS,
77 VX_HATCH_PATTERN_DASH,
78 VX_HATCH_PATTERN_LIMESTONE,
79 VX_HATCH_PATTERN_DOTS,
80 VX_HATCH_PATTERN_EARTH,
81 VX_HATCH_PATTERN_EXPANSION,
82 VX_HATCH_PATTERN_GRASS,
83 VX_HATCH_PATTERN_GRATE,
84 VX_HATCH_PATTERN_HEXAGON,
85 VX_HATCH_PATTERN_HONEYCOMB,
86 VX_HATCH_PATTERN_SQUARES,
87 VX_HATCH_PATTERN_MOONYANG,
88 VX_HATCH_PATTERN_BOX,
89 VX_HATCH_PATTERN_BRASS,
90 VX_HATCH_PATTERN_BRSTONE,
91 VX_HATCH_PATTERN_CLAY,
92 VX_HATCH_PATTERN_ESCHER,
93 VX_HATCH_PATTERN_GRAVEL,
94 VX_HATCH_PATTERN_HOUND,
95 VX_HATCH_PATTERN_INSUL,
96 VX_HATCH_PATTERN_ACAD_ISO02W100,
97 VX_HATCH_PATTERN_ACAD_ISO03W100,
98 VX_HATCH_PATTERN_ACAD_ISO04W100,
99 VX_HATCH_PATTERN_ACAD_ISO05W100,
100 VX_HATCH_PATTERN_ACAD_ISO06W100,
101 VX_HATCH_PATTERN_ACAD_ISO07W100,
102 VX_HATCH_PATTERN_ACAD_ISO08W100,
103 VX_HATCH_PATTERN_ACAD_ISO09W100,
104 VX_HATCH_PATTERN_ACAD_ISO10W100,
105 VX_HATCH_PATTERN_ACAD_ISO11W100,
106 VX_HATCH_PATTERN_ACAD_ISO12W100,
107 VX_HATCH_PATTERN_ACAD_ISO13W100,
108 VX_HATCH_PATTERN_ACAD_ISO14W100,
109 VX_HATCH_PATTERN_ACAD_ISO15W100,
110 VX_HATCH_PATTERN_JIS_LC_20,
111 VX_HATCH_PATTERN_JIS_LC_20A,
112 VX_HATCH_PATTERN_JIS_LC_8A,
113 VX_HATCH_PATTERN_JIS_LC_8,
114 VX_HATCH_PATTERN_JIS_RC_10,
115 VX_HATCH_PATTERN_JIS_RC_15,
116 VX_HATCH_PATTERN_JIS_RC_18,
117 VX_HATCH_PATTERN_JIS_RC_30,
118 VX_HATCH_PATTERN_JIS_STN_1E,
119 VX_HATCH_PATTERN_JIS_STN_2_5,
120 VX_HATCH_PATTERN_JIS_WOOD,
121 VX_HATCH_PATTERN_LINE,
122 VX_HATCH_PATTERN_MUDST,
123 VX_HATCH_PATTERN_NET,
124 VX_HATCH_PATTERN_NET3,
125 VX_HATCH_PATTERN_PLAST,
126 VX_HATCH_PATTERN_PLASTI,
127 VX_HATCH_PATTERN_SACNCR,
128 VX_HATCH_PATTERN_STARS,
129 VX_HATCH_PATTERN_STEEL,
130 VX_HATCH_PATTERN_SWAMP,
131 VX_HATCH_PATTERN_TRANS,
132 VX_HATCH_PATTERN_TRIANG,
133 VX_HATCH_PATTERN_ZIGZAG,
134 VX_HATCH_PATTERN_SOLID,
135 } evxHatchPtnType;
evxHatchPtnType
evxHatchPtnType
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sk...
Definition: zwapi_cmd_sk_create_data.h:64
VX_HATCH_PATTERN_MUDST
@ VX_HATCH_PATTERN_MUDST
MUDST.
Definition: zwapi_cmd_sk_create_data.h:122
VX_HATCH_PATTERN_JIS_RC_18
@ VX_HATCH_PATTERN_JIS_RC_18
JIS_RC_18.
Definition: zwapi_cmd_sk_create_data.h:116
VX_HATCH_PATTERN_HOUND
@ VX_HATCH_PATTERN_HOUND
HOUND.
Definition: zwapi_cmd_sk_create_data.h:94
VX_HATCH_PATTERN_EARTH
@ VX_HATCH_PATTERN_EARTH
EARTH.
Definition: zwapi_cmd_sk_create_data.h:80
VX_HATCH_PATTERN_ACAD_ISO05W100
@ VX_HATCH_PATTERN_ACAD_ISO05W100
ACAD_ISO05W100.
Definition: zwapi_cmd_sk_create_data.h:99
VX_HATCH_PATTERN_INSUL
@ VX_HATCH_PATTERN_INSUL
INSUL.
Definition: zwapi_cmd_sk_create_data.h:95
VX_HATCH_PATTERN_SOLID
@ VX_HATCH_PATTERN_SOLID
SOLID.
Definition: zwapi_cmd_sk_create_data.h:134
VX_HATCH_PATTERN_TRANS
@ VX_HATCH_PATTERN_TRANS
TRANS.
Definition: zwapi_cmd_sk_create_data.h:131
VX_HATCH_PATTERN_ACAD_ISO07W100
@ VX_HATCH_PATTERN_ACAD_ISO07W100
ACAD_ISO07W100.
Definition: zwapi_cmd_sk_create_data.h:101
VX_HATCH_PATTERN_STEEL
@ VX_HATCH_PATTERN_STEEL
STEEL.
Definition: zwapi_cmd_sk_create_data.h:129
VX_HATCH_PATTERN_JIS_STN_2_5
@ VX_HATCH_PATTERN_JIS_STN_2_5
JIS_STN_2_5.
Definition: zwapi_cmd_sk_create_data.h:119
VX_HATCH_PATTERN_ACAD_ISO03W100
@ VX_HATCH_PATTERN_ACAD_ISO03W100
ACAD_ISO03W100.
Definition: zwapi_cmd_sk_create_data.h:97
VX_HATCH_PATTERN_CLAY
@ VX_HATCH_PATTERN_CLAY
CLAY.
Definition: zwapi_cmd_sk_create_data.h:91
VX_HATCH_PATTERN_SQUARES
@ VX_HATCH_PATTERN_SQUARES
SQUARES.
Definition: zwapi_cmd_sk_create_data.h:86
VX_HATCH_PATTERN_ANSI38
@ VX_HATCH_PATTERN_ANSI38
ANSI38.
Definition: zwapi_cmd_sk_create_data.h:72
VX_HATCH_PATTERN_HONEYCOMB
@ VX_HATCH_PATTERN_HONEYCOMB
HONEYCOMB.
Definition: zwapi_cmd_sk_create_data.h:85
VX_HATCH_PATTERN_ACAD_ISO10W100
@ VX_HATCH_PATTERN_ACAD_ISO10W100
ACAD_ISO10W100.
Definition: zwapi_cmd_sk_create_data.h:104
VX_HATCH_PATTERN_ACAD_ISO09W100
@ VX_HATCH_PATTERN_ACAD_ISO09W100
ACAD_ISO09W100.
Definition: zwapi_cmd_sk_create_data.h:103
VX_HATCH_PATTERN_GRAVEL
@ VX_HATCH_PATTERN_GRAVEL
GRAVEL.
Definition: zwapi_cmd_sk_create_data.h:93
VX_HATCH_PATTERN_ACAD_ISO14W100
@ VX_HATCH_PATTERN_ACAD_ISO14W100
ACAD_ISO14W100.
Definition: zwapi_cmd_sk_create_data.h:108
VX_HATCH_PATTERN_LIMESTONE
@ VX_HATCH_PATTERN_LIMESTONE
LIMESTONE.
Definition: zwapi_cmd_sk_create_data.h:78
VX_HATCH_PATTERN_JIS_RC_15
@ VX_HATCH_PATTERN_JIS_RC_15
JIS_RC_15.
Definition: zwapi_cmd_sk_create_data.h:115
VX_HATCH_PATTERN_PLASTI
@ VX_HATCH_PATTERN_PLASTI
PLASTI.
Definition: zwapi_cmd_sk_create_data.h:126
VX_HATCH_PATTERN_ANSI33
@ VX_HATCH_PATTERN_ANSI33
ANSI33.
Definition: zwapi_cmd_sk_create_data.h:67
VX_HATCH_PATTERN_DASH
@ VX_HATCH_PATTERN_DASH
DASH.
Definition: zwapi_cmd_sk_create_data.h:77
VX_HATCH_PATTERN_ANSI35
@ VX_HATCH_PATTERN_ANSI35
ANSI35.
Definition: zwapi_cmd_sk_create_data.h:69
VX_HATCH_PATTERN_JIS_STN_1E
@ VX_HATCH_PATTERN_JIS_STN_1E
JIS_STN_1E.
Definition: zwapi_cmd_sk_create_data.h:118
VX_HATCH_PATTERN_ESCHER
@ VX_HATCH_PATTERN_ESCHER
ESCHER.
Definition: zwapi_cmd_sk_create_data.h:92
VX_HATCH_PATTERN_ANSI36
@ VX_HATCH_PATTERN_ANSI36
ANSI36.
Definition: zwapi_cmd_sk_create_data.h:70
VX_HATCH_PATTERN_EXPANSION
@ VX_HATCH_PATTERN_EXPANSION
EXPANSION.
Definition: zwapi_cmd_sk_create_data.h:81
VX_HATCH_PATTERN_ANSI37
@ VX_HATCH_PATTERN_ANSI37
ANSI37.
Definition: zwapi_cmd_sk_create_data.h:71
VX_HATCH_PATTERN_GRATE
@ VX_HATCH_PATTERN_GRATE
GRATE.
Definition: zwapi_cmd_sk_create_data.h:83
VX_HATCH_PATTERN_JIS_LC_20A
@ VX_HATCH_PATTERN_JIS_LC_20A
JIS_LC_20A.
Definition: zwapi_cmd_sk_create_data.h:111
VX_HATCH_PATTERN_ACAD_ISO15W100
@ VX_HATCH_PATTERN_ACAD_ISO15W100
ACAD_ISO15W100.
Definition: zwapi_cmd_sk_create_data.h:109
VX_HATCH_PATTERN_SWAMP
@ VX_HATCH_PATTERN_SWAMP
SWAMP.
Definition: zwapi_cmd_sk_create_data.h:130
VX_HATCH_PATTERN_HEXAGON
@ VX_HATCH_PATTERN_HEXAGON
HEXAGON.
Definition: zwapi_cmd_sk_create_data.h:84
VX_HATCH_PATTERN_JIS_RC_10
@ VX_HATCH_PATTERN_JIS_RC_10
JIS_RC_10.
Definition: zwapi_cmd_sk_create_data.h:114
VX_HATCH_PATTERN_GRASS
@ VX_HATCH_PATTERN_GRASS
GRASS.
Definition: zwapi_cmd_sk_create_data.h:82
VX_HATCH_PATTERN_PLAST
@ VX_HATCH_PATTERN_PLAST
PLAST.
Definition: zwapi_cmd_sk_create_data.h:125
VX_HATCH_PATTERN_ACAD_ISO12W100
@ VX_HATCH_PATTERN_ACAD_ISO12W100
ACAD_ISO12W100.
Definition: zwapi_cmd_sk_create_data.h:106
VX_HATCH_PATTERN_ACAD_ISO08W100
@ VX_HATCH_PATTERN_ACAD_ISO08W100
ACAD_ISO08W100.
Definition: zwapi_cmd_sk_create_data.h:102
VX_HATCH_PATTERN_MOONYANG
@ VX_HATCH_PATTERN_MOONYANG
MOONYANG.
Definition: zwapi_cmd_sk_create_data.h:87
VX_HATCH_PATTERN_BRASS
@ VX_HATCH_PATTERN_BRASS
BRASS.
Definition: zwapi_cmd_sk_create_data.h:89
VX_HATCH_PATTERN_TRIANG
@ VX_HATCH_PATTERN_TRIANG
TRIANG.
Definition: zwapi_cmd_sk_create_data.h:132
VX_HATCH_PATTERN_JIS_LC_8
@ VX_HATCH_PATTERN_JIS_LC_8
JIS_LC_8.
Definition: zwapi_cmd_sk_create_data.h:113
VX_HATCH_PATTERN_JIS_LC_20
@ VX_HATCH_PATTERN_JIS_LC_20
JIS_LC_20.
Definition: zwapi_cmd_sk_create_data.h:110
VX_HATCH_PATTERN_JIS_LC_8A
@ VX_HATCH_PATTERN_JIS_LC_8A
JIS_LC_8A.
Definition: zwapi_cmd_sk_create_data.h:112
VX_HATCH_PATTERN_ACAD_ISO02W100
@ VX_HATCH_PATTERN_ACAD_ISO02W100
ACAD_ISO02W100.
Definition: zwapi_cmd_sk_create_data.h:96
VX_HATCH_PATTERN_BOX
@ VX_HATCH_PATTERN_BOX
BOX.
Definition: zwapi_cmd_sk_create_data.h:88
VX_HATCH_PATTERN_SHADOW_PLATE
@ VX_HATCH_PATTERN_SHADOW_PLATE
SHADOW_PLATE.
Definition: zwapi_cmd_sk_create_data.h:73
VX_HATCH_PATTERN_BRSTONE
@ VX_HATCH_PATTERN_BRSTONE
BRSTONE.
Definition: zwapi_cmd_sk_create_data.h:90
VX_HATCH_PATTERN_BRICK
@ VX_HATCH_PATTERN_BRICK
BRICK.
Definition: zwapi_cmd_sk_create_data.h:74
VX_HATCH_PATTERN_ANSI34
@ VX_HATCH_PATTERN_ANSI34
ANSI34.
Definition: zwapi_cmd_sk_create_data.h:68
VX_HATCH_PATTERN_JIS_RC_30
@ VX_HATCH_PATTERN_JIS_RC_30
JIS_RC_30.
Definition: zwapi_cmd_sk_create_data.h:117
VX_HATCH_PATTERN_JIS_WOOD
@ VX_HATCH_PATTERN_JIS_WOOD
JIS_WOOD.
Definition: zwapi_cmd_sk_create_data.h:120
VX_HATCH_PATTERN_LINE
@ VX_HATCH_PATTERN_LINE
LINE.
Definition: zwapi_cmd_sk_create_data.h:121
VX_HATCH_PATTERN_ACAD_ISO11W100
@ VX_HATCH_PATTERN_ACAD_ISO11W100
ACAD_ISO11W100.
Definition: zwapi_cmd_sk_create_data.h:105
VX_HATCH_PATTERN_NET
@ VX_HATCH_PATTERN_NET
NET.
Definition: zwapi_cmd_sk_create_data.h:123
VX_HATCH_PATTERN_CORK
@ VX_HATCH_PATTERN_CORK
CORK.
Definition: zwapi_cmd_sk_create_data.h:75
VX_HATCH_PATTERN_ZIGZAG
@ VX_HATCH_PATTERN_ZIGZAG
ZIGZAG.
Definition: zwapi_cmd_sk_create_data.h:133
VX_HATCH_PATTERN_ACAD_ISO06W100
@ VX_HATCH_PATTERN_ACAD_ISO06W100
ACAD_ISO06W100.
Definition: zwapi_cmd_sk_create_data.h:100
VX_HATCH_PATTERN_ACAD_ISO13W100
@ VX_HATCH_PATTERN_ACAD_ISO13W100
ACAD_ISO13W100.
Definition: zwapi_cmd_sk_create_data.h:107
VX_HATCH_PATTERN_ACAD_ISO04W100
@ VX_HATCH_PATTERN_ACAD_ISO04W100
ACAD_ISO04W100.
Definition: zwapi_cmd_sk_create_data.h:98
VX_HATCH_PATTERN_ANSI31
@ VX_HATCH_PATTERN_ANSI31
ANSI31.
Definition: zwapi_cmd_sk_create_data.h:65
VX_HATCH_PATTERN_NET3
@ VX_HATCH_PATTERN_NET3
NET3.
Definition: zwapi_cmd_sk_create_data.h:124
VX_HATCH_PATTERN_ANSI32
@ VX_HATCH_PATTERN_ANSI32
ANSI32.
Definition: zwapi_cmd_sk_create_data.h:66
VX_HATCH_PATTERN_DOTS
@ VX_HATCH_PATTERN_DOTS
DOTS.
Definition: zwapi_cmd_sk_create_data.h:79
VX_HATCH_PATTERN_STARS
@ VX_HATCH_PATTERN_STARS
STARS.
Definition: zwapi_cmd_sk_create_data.h:128
VX_HATCH_PATTERN_SACNCR
@ VX_HATCH_PATTERN_SACNCR
SACNCR.
Definition: zwapi_cmd_sk_create_data.h:127
VX_HATCH_PATTERN_CROSS
@ VX_HATCH_PATTERN_CROSS
CROSS.
Definition: zwapi_cmd_sk_create_data.h:76
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDistanceMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Sub Commands Data
evxDistanceMethod
evxDistanceMethod
svxLoftBndCons
svxPntBy2Lines
svxPntByOffset

◆ evxDistanceMethod

enum evxDistanceMethod

#include <zwapi_cmd_subcmd_data.h>

the distance method of the distance field, it can set the value by the specified sub-command

Enumerator
VX_INPU_VALUE | the start/end field by the input number
VX_BY_THROUGH_ALL | the start/end field by the through all method
VX_TO_POINT | the start/end field by the to point method
VX_TO_FACES | the start/end field by the to faces method
VX_TO_EXTEND_FACE | the start/end field by the to extend face method(extrude)
VX_TO_FACE | the start/end field by the to extend face method (normal cut)
Examples
part\smdFtrCrtTest.cpp.

Definition at line 56 of file zwapi_cmd_subcmd_data.h.

57 {
58 VX_INPU_VALUE = 0,
59 VX_BY_THROUGH_ALL = 1,
60 VX_TO_POINT = 2,
61 VX_TO_FACES = 3,
62 VX_TO_EXTEND_FACE = 4,
63 VX_TO_FACE = 5,
64 } evxDistanceMethod;
evxDistanceMethod
evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
Definition: zwapi_cmd_subcmd_data.h:57
VX_TO_POINT
@ VX_TO_POINT
the start/end field by the to point method
Definition: zwapi_cmd_subcmd_data.h:60
VX_TO_FACES
@ VX_TO_FACES
the start/end field by the to faces method
Definition: zwapi_cmd_subcmd_data.h:61
VX_INPU_VALUE
@ VX_INPU_VALUE
the start/end field by the input number
Definition: zwapi_cmd_subcmd_data.h:58
VX_TO_EXTEND_FACE
@ VX_TO_EXTEND_FACE
the start/end field by the to extend face method(extrude)
Definition: zwapi_cmd_subcmd_data.h:62
VX_BY_THROUGH_ALL
@ VX_BY_THROUGH_ALL
the start/end field by the through all method
Definition: zwapi_cmd_subcmd_data.h:59
VX_TO_FACE
@ VX_TO_FACE
the start/end field by the to extend face method (normal cut)
Definition: zwapi_cmd_subcmd_data.h:63
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCircleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCircleType

enum evxCircleType

#include <zwapi_cmd_wireframe_data.h>

3D circle type

Enumerator
VX_CIRCLE_BOUNDARY | create a circle by defining its center and a boundary point
VX_CIRCLE_RADIUS | create a circle by defining its center and radius or diameter
VX_CIRCLE_THROUGH | create a circle by defining 3 boundary points
VX_CIRCLE_2PT_RADIUS | create a circle by defining 2 boundary points and radius
VX_CIRCLE_2POINT | create a circle by defining 2 boundary points

Definition at line 96 of file zwapi_cmd_wireframe_data.h.

97 {
98 VX_CIRCLE_BOUNDARY = 1,
99 VX_CIRCLE_RADIUS = 2,
100 VX_CIRCLE_THROUGH = 0,
101 VX_CIRCLE_2PT_RADIUS = 3,
102 VX_CIRCLE_2POINT = 4,
103 } evxCircleType;
evxCircleType
evxCircleType
3D circle type
Definition: zwapi_cmd_wireframe_data.h:97
VX_CIRCLE_RADIUS
@ VX_CIRCLE_RADIUS
create a circle by defining its center and radius or diameter
Definition: zwapi_cmd_wireframe_data.h:99
VX_CIRCLE_THROUGH
@ VX_CIRCLE_THROUGH
create a circle by defining 3 boundary points
Definition: zwapi_cmd_wireframe_data.h:100
VX_CIRCLE_2POINT
@ VX_CIRCLE_2POINT
create a circle by defining 2 boundary points
Definition: zwapi_cmd_wireframe_data.h:102
VX_CIRCLE_2PT_RADIUS
@ VX_CIRCLE_2PT_RADIUS
create a circle by defining 2 boundary points and radius
Definition: zwapi_cmd_wireframe_data.h:101
VX_CIRCLE_BOUNDARY
@ VX_CIRCLE_BOUNDARY
create a circle by defining its center and a boundary point
Definition: zwapi_cmd_wireframe_data.h:98
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvBlendDirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvBlendDirType

enum evxCrvBlendDirType

#include <zwapi_cmd_wireframe_data.h>

blend location type for face to blend

Enumerator
VX_CURVE_BLEND_DIR_SECTIONAL | An angle relative to ISO U is defined to set up blend direction.
VX_CURVE_BLEND_DIR_ISO_U | ISO U works as the blend direction and a % of iso u can defined to settle the blend location.
VX_CURVE_BLEND_DIR_ISO_V | ISO V works as the blend direction and a % of iso v can defined to settle the blend location.
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 389 of file zwapi_cmd_wireframe_data.h.

390 {
391 VX_CURVE_BLEND_DIR_SECTIONAL = 0,
392 VX_CURVE_BLEND_DIR_ISO_U = 1,
393 VX_CURVE_BLEND_DIR_ISO_V = 2,
394 }evxCrvBlendDirType;
evxCrvBlendDirType
evxCrvBlendDirType
blend location type for face to blend
Definition: zwapi_cmd_wireframe_data.h:390
VX_CURVE_BLEND_DIR_ISO_V
@ VX_CURVE_BLEND_DIR_ISO_V
ISO V works as the blend direction and a % of iso v can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:393
VX_CURVE_BLEND_DIR_SECTIONAL
@ VX_CURVE_BLEND_DIR_SECTIONAL
An angle relative to ISO U is defined to set up blend direction.
Definition: zwapi_cmd_wireframe_data.h:391
VX_CURVE_BLEND_DIR_ISO_U
@ VX_CURVE_BLEND_DIR_ISO_U
ISO U works as the blend direction and a % of iso u can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:392
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvIsoUVType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvIsoUVType

enum evxCrvIsoUVType

#include <zwapi_cmd_wireframe_data.h>

iso-curve U or V settings

Enumerator
VX_CRV_ISO_UV_U | U-isoline.
VX_CRV_ISO_UV_V | V-isoline.
VX_CRV_ISO_UV_BOTH | both

Definition at line 246 of file zwapi_cmd_wireframe_data.h.

247 {
248 VX_CRV_ISO_UV_U = 0,
249 VX_CRV_ISO_UV_V = 1,
250 VX_CRV_ISO_UV_BOTH = 2,
251 }evxCrvIsoUVType;
evxCrvIsoUVType
evxCrvIsoUVType
iso-curve U or V settings
Definition: zwapi_cmd_wireframe_data.h:247
VX_CRV_ISO_UV_V
@ VX_CRV_ISO_UV_V
V-isoline.
Definition: zwapi_cmd_wireframe_data.h:249
VX_CRV_ISO_UV_BOTH
@ VX_CRV_ISO_UV_BOTH
both
Definition: zwapi_cmd_wireframe_data.h:250
VX_CRV_ISO_UV_U
@ VX_CRV_ISO_UV_U
U-isoline.
Definition: zwapi_cmd_wireframe_data.h:248
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxRectangleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxRectangleType

enum evxRectangleType

#include <zwapi_cmd_wireframe_data.h>

3D ellipse & rectangle type

Enumerator
VX_RECT_2PT | two points
VX_RECT_WIDTH_HEIGHT | width and height
VX_RECT_3PT | three points

Definition at line 139 of file zwapi_cmd_wireframe_data.h.

140 {
141 VX_RECT_2PT = 0,
142 VX_RECT_WIDTH_HEIGHT = 1,
143 VX_RECT_3PT = 2
144 } evxRectangleType;
evxRectangleType
evxRectangleType
3D ellipse & rectangle type
Definition: zwapi_cmd_wireframe_data.h:140
VX_RECT_3PT
@ VX_RECT_3PT
three points
Definition: zwapi_cmd_wireframe_data.h:143
VX_RECT_2PT
@ VX_RECT_2PT
two points
Definition: zwapi_cmd_wireframe_data.h:141
VX_RECT_WIDTH_HEIGHT
@ VX_RECT_WIDTH_HEIGHT
width and height
Definition: zwapi_cmd_wireframe_data.h:142
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxIsoclineCrvType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxIsoclineCrvType

enum evxIsoclineCrvType

#include <zwapi_cmd_wireframe_data.h>

create isocline curve with a single angle/multiple angles

Enumerator
VX_CRV_ISOCLINE_SINGLE | single angle
VX_CRV_ISOCLINE_MULTIPLE | multiple angles

Definition at line 288 of file zwapi_cmd_wireframe_data.h.

289 {
290 VX_CRV_ISOCLINE_SINGLE = 0,
291 VX_CRV_ISOCLINE_MULTIPLE = 1,
292 }evxIsoclineCrvType;
evxIsoclineCrvType
evxIsoclineCrvType
create isocline curve with a single angle/multiple angles
Definition: zwapi_cmd_wireframe_data.h:289
VX_CRV_ISOCLINE_MULTIPLE
@ VX_CRV_ISOCLINE_MULTIPLE
multiple angles
Definition: zwapi_cmd_wireframe_data.h:291
VX_CRV_ISOCLINE_SINGLE
@ VX_CRV_ISOCLINE_SINGLE
single angle
Definition: zwapi_cmd_wireframe_data.h:290
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxArcType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxArcType

enum evxArcType

#include <zwapi_cmd_wireframe_data.h>

3D arc type

Enumerator
VX_ARC_THROUGH | create an arc by defining its two endpoints and a third point that arc passes through
VX_ARC_RADIUS | create an arc by defining its two endpoints and radius
VX_ARC_CENTER | create an arc by defining its center and two endpoints
VX_ARC_ANGLE | create an arc by defining its center, radius, start angle and arc angle

Definition at line 64 of file zwapi_cmd_wireframe_data.h.

65 {
66 VX_ARC_THROUGH = 0,
67 VX_ARC_RADIUS = 1,
68 VX_ARC_CENTER = 2,
69 VX_ARC_ANGLE = 3,
70 } evxArcType;
evxArcType
evxArcType
3D arc type
Definition: zwapi_cmd_wireframe_data.h:65
VX_ARC_ANGLE
@ VX_ARC_ANGLE
create an arc by defining its center, radius, start angle and arc angle
Definition: zwapi_cmd_wireframe_data.h:69
VX_ARC_THROUGH
@ VX_ARC_THROUGH
create an arc by defining its two endpoints and a third point that arc passes through
Definition: zwapi_cmd_wireframe_data.h:66
VX_ARC_RADIUS
@ VX_ARC_RADIUS
create an arc by defining its two endpoints and radius
Definition: zwapi_cmd_wireframe_data.h:67
VX_ARC_CENTER
@ VX_ARC_CENTER
create an arc by defining its center and two endpoints
Definition: zwapi_cmd_wireframe_data.h:68
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvFilletMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvFilletMethods

enum evxCrvFilletMethods

#include <zwapi_cmd_wireframe_data.h>

curve fillet method

Enumerator
VX_CRV_FILLET_RADIUS | radius
VX_CRV_FILLET_BOUNDARY | boundary

Definition at line 491 of file zwapi_cmd_wireframe_data.h.

492 {
493 VX_CRV_FILLET_RADIUS = 0,
494 VX_CRV_FILLET_BOUNDARY = 1,
495 }evxCrvFilletMethods;
evxCrvFilletMethods
evxCrvFilletMethods
curve fillet method
Definition: zwapi_cmd_wireframe_data.h:492
VX_CRV_FILLET_RADIUS
@ VX_CRV_FILLET_RADIUS
radius
Definition: zwapi_cmd_wireframe_data.h:493
VX_CRV_FILLET_BOUNDARY
@ VX_CRV_FILLET_BOUNDARY
boundary
Definition: zwapi_cmd_wireframe_data.h:494
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvChamferMethods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvChamferMethods

enum evxCrvChamferMethods

#include <zwapi_cmd_wireframe_data.h>

curve chamfer method

Enumerator
VX_CRV_CHAMFER_SETBACK | setback
VX_CRV_CHAMFER_TWO_SETBACKS | two setbacks
VX_CRV_CHAMFER_SETBACK_AND_ANGLE | setback and angle

Definition at line 533 of file zwapi_cmd_wireframe_data.h.

534 {
535 VX_CRV_CHAMFER_SETBACK = 0,
536 VX_CRV_CHAMFER_TWO_SETBACKS = 1,
537 VX_CRV_CHAMFER_SETBACK_AND_ANGLE = 2,
538 }evxCrvChamferMethods;
evxCrvChamferMethods
evxCrvChamferMethods
curve chamfer method
Definition: zwapi_cmd_wireframe_data.h:534
VX_CRV_CHAMFER_SETBACK
@ VX_CRV_CHAMFER_SETBACK
setback
Definition: zwapi_cmd_wireframe_data.h:535
VX_CRV_CHAMFER_SETBACK_AND_ANGLE
@ VX_CRV_CHAMFER_SETBACK_AND_ANGLE
setback and angle
Definition: zwapi_cmd_wireframe_data.h:537
VX_CRV_CHAMFER_TWO_SETBACKS
@ VX_CRV_CHAMFER_TWO_SETBACKS
two setbacks
Definition: zwapi_cmd_wireframe_data.h:536
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvTrimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvTrimType

enum evxCrvTrimType

#include <zwapi_cmd_wireframe_data.h>

curve trim type

Enumerator
VX_CRV_TRIM_NONE | no trim
VX_CRV_TRIM_BOTH | trim both curves
VX_CRV_TRIM_FIRST | trim only the first curves
VX_CRV_TRIM_SECOND | trim only the second curves

Definition at line 479 of file zwapi_cmd_wireframe_data.h.

480 {
481 VX_CRV_TRIM_NONE = 0,
482 VX_CRV_TRIM_BOTH = 1,
483 VX_CRV_TRIM_FIRST = 2,
484 VX_CRV_TRIM_SECOND = 3,
485 }evxCrvTrimType;
evxCrvTrimType
evxCrvTrimType
curve trim type
Definition: zwapi_cmd_wireframe_data.h:480
VX_CRV_TRIM_NONE
@ VX_CRV_TRIM_NONE
no trim
Definition: zwapi_cmd_wireframe_data.h:481
VX_CRV_TRIM_SECOND
@ VX_CRV_TRIM_SECOND
trim only the second curves
Definition: zwapi_cmd_wireframe_data.h:484
VX_CRV_TRIM_BOTH
@ VX_CRV_TRIM_BOTH
trim both curves
Definition: zwapi_cmd_wireframe_data.h:482
VX_CRV_TRIM_FIRST
@ VX_CRV_TRIM_FIRST
trim only the first curves
Definition: zwapi_cmd_wireframe_data.h:483
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvIsoType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvIsoType

enum evxCrvIsoType

#include <zwapi_cmd_wireframe_data.h>

iso-curve type

Enumerator
VX_CRV_ISO_AT_POINT | at point
VX_CRV_ISO_AT_UV | ar U/V parameter
VX_CRV_ISO_MULTIPLE | multiple

Definition at line 235 of file zwapi_cmd_wireframe_data.h.

236 {
237 VX_CRV_ISO_AT_POINT = 0,
238 VX_CRV_ISO_AT_UV = 1,
239 VX_CRV_ISO_MULTIPLE = 2,
240 }evxCrvIsoType;
evxCrvIsoType
evxCrvIsoType
iso-curve type
Definition: zwapi_cmd_wireframe_data.h:236
VX_CRV_ISO_AT_UV
@ VX_CRV_ISO_AT_UV
ar U/V parameter
Definition: zwapi_cmd_wireframe_data.h:238
VX_CRV_ISO_MULTIPLE
@ VX_CRV_ISO_MULTIPLE
multiple
Definition: zwapi_cmd_wireframe_data.h:239
VX_CRV_ISO_AT_POINT
@ VX_CRV_ISO_AT_POINT
at point
Definition: zwapi_cmd_wireframe_data.h:237
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvBlendPosType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvBlendPosType

enum evxCrvBlendPosType

#include <zwapi_cmd_wireframe_data.h>

blend location type for curve to blend

Enumerator
VX_CURVE_BLEND_POS_ARC_LENGTH | location to blend is defined by arc length
VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH | location to blend is defined by % of arc length
VX_CURVE_BLEND_POS_THROUGH_POINT | Picking a pick on curve as the blend location.
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 378 of file zwapi_cmd_wireframe_data.h.

379 {
380 VX_CURVE_BLEND_POS_ARC_LENGTH = 0,
381 VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH = 1,
382 VX_CURVE_BLEND_POS_THROUGH_POINT = 2,
383 }evxCrvBlendPosType;
evxCrvBlendPosType
evxCrvBlendPosType
blend location type for curve to blend
Definition: zwapi_cmd_wireframe_data.h:379
VX_CURVE_BLEND_POS_THROUGH_POINT
@ VX_CURVE_BLEND_POS_THROUGH_POINT
Picking a pick on curve as the blend location.
Definition: zwapi_cmd_wireframe_data.h:382
VX_CURVE_BLEND_POS_ARC_LENGTH
@ VX_CURVE_BLEND_POS_ARC_LENGTH
location to blend is defined by arc length
Definition: zwapi_cmd_wireframe_data.h:380
VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
@ VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
location to blend is defined by % of arc length
Definition: zwapi_cmd_wireframe_data.h:381
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxLineType

enum evxLineType

#include <zwapi_cmd_wireframe_data.h>

3D line type

Enumerator
VX_LINE_2PT | create a line between two points
VX_LINE_ALONG_DIR | create a line in the same direction as the reference by start point and length
VX_LINE_PARALLEL | create a line parallel to the reference direction by point and length
VX_LINE_PERP | create a line between two points and perpendicular to the reference direction
VX_LINE_ANGLE | create a line between two points and at an angle to the reference direction
VX_LINE_MIDDDLE | create a line by conforming the middle point and a end point

Definition at line 32 of file zwapi_cmd_wireframe_data.h.

33 {
34 VX_LINE_2PT = 0,
35 VX_LINE_ALONG_DIR = 1,
36 VX_LINE_PARALLEL = 2,
37 VX_LINE_PERP = 3,
38 VX_LINE_ANGLE = 4,
39 VX_LINE_MIDDDLE = 5,
40 } evxLineType;
evxLineType
evxLineType
3D line type
Definition: zwapi_cmd_wireframe_data.h:33
VX_LINE_ANGLE
@ VX_LINE_ANGLE
create a line between two points and at an angle to the reference direction
Definition: zwapi_cmd_wireframe_data.h:38
VX_LINE_ALONG_DIR
@ VX_LINE_ALONG_DIR
create a line in the same direction as the reference by start point and length
Definition: zwapi_cmd_wireframe_data.h:35
VX_LINE_PERP
@ VX_LINE_PERP
create a line between two points and perpendicular to the reference direction
Definition: zwapi_cmd_wireframe_data.h:37
VX_LINE_PARALLEL
@ VX_LINE_PARALLEL
create a line parallel to the reference direction by point and length
Definition: zwapi_cmd_wireframe_data.h:36
VX_LINE_2PT
@ VX_LINE_2PT
create a line between two points
Definition: zwapi_cmd_wireframe_data.h:34
VX_LINE_MIDDDLE
@ VX_LINE_MIDDDLE
create a line by conforming the middle point and a end point
Definition: zwapi_cmd_wireframe_data.h:39
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvBlendTrimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvBlendTrimType

enum evxCrvBlendTrimType

#include <zwapi_cmd_wireframe_data.h>

trim (or extend) curves type of curve blend

Enumerator
VX_CURVE_BLEND_NO_TRIM | Add the fillet or chamfer without modifying the existing curves. No trim/extend is performed.
VX_CURVE_BLEND_TRIM_BOTH | Trim/Extend both curves.
VX_CURVE_BLEND_TRIM_FIRST | Trim/Extend only the first selected curve.
VX_CURVE_BLEND_TRIM_SECOND | Trim/extend only the second selected curve.
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 366 of file zwapi_cmd_wireframe_data.h.

367 {
368 VX_CURVE_BLEND_NO_TRIM = 0,
369 VX_CURVE_BLEND_TRIM_BOTH = 1,
370 VX_CURVE_BLEND_TRIM_FIRST = 2,
371 VX_CURVE_BLEND_TRIM_SECOND = 3,
372 }evxCrvBlendTrimType;
evxCrvBlendTrimType
evxCrvBlendTrimType
trim (or extend) curves type of curve blend
Definition: zwapi_cmd_wireframe_data.h:367
VX_CURVE_BLEND_TRIM_FIRST
@ VX_CURVE_BLEND_TRIM_FIRST
Trim/Extend only the first selected curve.
Definition: zwapi_cmd_wireframe_data.h:370
VX_CURVE_BLEND_TRIM_BOTH
@ VX_CURVE_BLEND_TRIM_BOTH
Trim/Extend both curves.
Definition: zwapi_cmd_wireframe_data.h:369
VX_CURVE_BLEND_NO_TRIM
@ VX_CURVE_BLEND_NO_TRIM
Add the fillet or chamfer without modifying the existing curves. No trim/extend is performed.
Definition: zwapi_cmd_wireframe_data.h:368
VX_CURVE_BLEND_TRIM_SECOND
@ VX_CURVE_BLEND_TRIM_SECOND
Trim/extend only the second selected curve.
Definition: zwapi_cmd_wireframe_data.h:371
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxCrvBlendObjType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxCrvBlendObjType

enum evxCrvBlendObjType

#include <zwapi_cmd_wireframe_data.h>

select a curve or face as object to start/end blended

Enumerator
VX_CURVE_BLEND_CURVE | curve
VX_CURVE_BLEND_FACE | face

Definition at line 427 of file zwapi_cmd_wireframe_data.h.

428 {
429 VX_CURVE_BLEND_CURVE = 0,
430 VX_CURVE_BLEND_FACE = 1,
431 }evxCrvBlendObjType;
evxCrvBlendObjType
evxCrvBlendObjType
select a curve or face as object to start/end blended
Definition: zwapi_cmd_wireframe_data.h:428
VX_CURVE_BLEND_FACE
@ VX_CURVE_BLEND_FACE
face
Definition: zwapi_cmd_wireframe_data.h:430
VX_CURVE_BLEND_CURVE
@ VX_CURVE_BLEND_CURVE
curve
Definition: zwapi_cmd_wireframe_data.h:429
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTrimWithCrvType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Wireframe Commands Data
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ evxTrimWithCrvType

enum evxTrimWithCrvType

#include <zwapi_cmd_wireframe_data.h>

trim with curve mode

Enumerator
VX_TRIM_WITH_CRV_KEEP | The segment of the trimmed curves selected will be kept.
VX_TRIM_WITH_CRV_DELETE | The segment of the trimmed curves selected will be deleted.
VX_TRIM_WITH_CRV_SPLIT | The trimmed curves will be split at the boundary curves (or point).
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 585 of file zwapi_cmd_wireframe_data.h.

586 {
587 VX_TRIM_WITH_CRV_KEEP = 0,
588 VX_TRIM_WITH_CRV_DELETE = 1,
589 VX_TRIM_WITH_CRV_SPLIT = 2,
590 }evxTrimWithCrvType;
evxTrimWithCrvType
evxTrimWithCrvType
trim with curve mode
Definition: zwapi_cmd_wireframe_data.h:586
VX_TRIM_WITH_CRV_KEEP
@ VX_TRIM_WITH_CRV_KEEP
The segment of the trimmed curves selected will be kept.
Definition: zwapi_cmd_wireframe_data.h:587
VX_TRIM_WITH_CRV_DELETE
@ VX_TRIM_WITH_CRV_DELETE
The segment of the trimmed curves selected will be deleted.
Definition: zwapi_cmd_wireframe_data.h:588
VX_TRIM_WITH_CRV_SPLIT
@ VX_TRIM_WITH_CRV_SPLIT
The trimmed curves will be split at the boundary curves (or point).
Definition: zwapi_cmd_wireframe_data.h:589
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDatumDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxDatumDispMode

enum evxDatumDispMode

#include <zwapi_display.h>

display mode of datum plane

Enumerator
VX_DSP_PLN_XY | display XY only
VX_DSP_PLN_RECT_XY | display rectangle and XY axis
VX_DSP_PLN_RECT_XYZ | display rectangle and XYZ axis
VX_DSP_PLN_RECT | display rectangle only
VX_DSP_PLN_QURT | display a quarter of rectangle only
VX_DSP_PLN_RECT_XY_FIX | display rectangle and XY axis with fix size
VX_DSP_PLN_RECT_XYZ_FIX | display rectangle and XYZ axis with fix size
VX_DSP_PLN_RECT_FIX | display (a quarter of) rectangle only with fix size
VX_DSP_PLN_XYZ | display XYZ only

Definition at line 128 of file zwapi_display.h.

129 {
130 VX_DSP_PLN_XY = 0,
131 VX_DSP_PLN_RECT_XY = 1,
132 VX_DSP_PLN_RECT_XYZ = 2,
133 VX_DSP_PLN_RECT = 3,
134 VX_DSP_PLN_QURT = 4,
135 VX_DSP_PLN_RECT_XY_FIX = 5,
136 VX_DSP_PLN_RECT_XYZ_FIX = 6,
137 VX_DSP_PLN_RECT_FIX = 7,
138 VX_DSP_PLN_XYZ = 8
139 }evxDatumDispMode;
evxDatumDispMode
evxDatumDispMode
display mode of datum plane
Definition: zwapi_display.h:129
VX_DSP_PLN_RECT_XY_FIX
@ VX_DSP_PLN_RECT_XY_FIX
display rectangle and XY axis with fix size
Definition: zwapi_display.h:135
VX_DSP_PLN_RECT_XYZ
@ VX_DSP_PLN_RECT_XYZ
display rectangle and XYZ axis
Definition: zwapi_display.h:132
VX_DSP_PLN_XYZ
@ VX_DSP_PLN_XYZ
display XYZ only
Definition: zwapi_display.h:138
VX_DSP_PLN_RECT
@ VX_DSP_PLN_RECT
display rectangle only
Definition: zwapi_display.h:133
VX_DSP_PLN_RECT_XYZ_FIX
@ VX_DSP_PLN_RECT_XYZ_FIX
display rectangle and XYZ axis with fix size
Definition: zwapi_display.h:136
VX_DSP_PLN_QURT
@ VX_DSP_PLN_QURT
display a quarter of rectangle only
Definition: zwapi_display.h:134
VX_DSP_PLN_XY
@ VX_DSP_PLN_XY
display XY only
Definition: zwapi_display.h:130
VX_DSP_PLN_RECT_XY
@ VX_DSP_PLN_RECT_XY
display rectangle and XY axis
Definition: zwapi_display.h:131
VX_DSP_PLN_RECT_FIX
@ VX_DSP_PLN_RECT_FIX
display (a quarter of) rectangle only with fix size
Definition: zwapi_display.h:137
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDispAttrib

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxDispAttrib

enum evxDispAttrib

#include <zwapi_display.h>

display attribute types

Definition at line 39 of file zwapi_display.h.

40 {
41 VX_DISP_POINT = 0,
42 VX_DISP_LINE = 1,
43 VX_DISP_FACE = 2
44 } evxDispAttrib;
evxDispAttrib
evxDispAttrib
display attribute types
Definition: zwapi_display.h:40
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxVisualDispItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxVisualDispItem

enum evxVisualDispItem

#include <zwapi_display.h>

visual display item

Enumerator
VX_VISUAL_DISP_FRAME_TRIAD | frame triad display in visual manager
VX_VISUAL_DISP_COMPASS_TRIAD | compass triad display in visual manager
VX_VISUAL_DISP_TRIAD_TRANS | show hidden in visual manager

Definition at line 75 of file zwapi_display.h.

76 {
77 VX_VISUAL_DISP_FRAME_TRIAD = 0,
78 VX_VISUAL_DISP_COMPASS_TRIAD = 1,
79 VX_VISUAL_DISP_TRIAD_TRANS = 2
80 } evxVisualDispItem;
evxVisualDispItem
evxVisualDispItem
visual display item
Definition: zwapi_display.h:76
VX_VISUAL_DISP_FRAME_TRIAD
@ VX_VISUAL_DISP_FRAME_TRIAD
frame triad display in visual manager
Definition: zwapi_display.h:77
VX_VISUAL_DISP_TRIAD_TRANS
@ VX_VISUAL_DISP_TRIAD_TRANS
show hidden in visual manager
Definition: zwapi_display.h:79
VX_VISUAL_DISP_COMPASS_TRIAD
@ VX_VISUAL_DISP_COMPASS_TRIAD
compass triad display in visual manager
Definition: zwapi_display.h:78
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDispItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxDispItem

enum evxDispItem

#include <zwapi_display.h>

display (i.e. GUI) item

Enumerator
VX_DISP_SCREEN | screen
VX_DISP_PREVIEW | preview
VX_DISP_FORMS | forms
VX_DISP_ALL | all

Definition at line 63 of file zwapi_display.h.

64 {
65 VX_DISP_SCREEN = 0,
66 VX_DISP_PREVIEW = 1,
67 VX_DISP_FORMS = 2,
68 VX_DISP_ALL = 3
69 } evxDispItem;
evxDispItem
evxDispItem
display (i.e. GUI) item
Definition: zwapi_display.h:64
VX_DISP_FORMS
@ VX_DISP_FORMS
forms
Definition: zwapi_display.h:67
VX_DISP_ALL
@ VX_DISP_ALL
all
Definition: zwapi_display.h:68
VX_DISP_PREVIEW
@ VX_DISP_PREVIEW
preview
Definition: zwapi_display.h:66
VX_DISP_SCREEN
@ VX_DISP_SCREEN
screen
Definition: zwapi_display.h:65
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxAxisDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxAxisDispMode

enum evxAxisDispMode

#include <zwapi_display.h>

display mode of datum axis

Enumerator
VX_DSP_AXIS_ARROW_LINE | display arrow line
VX_DSP_AXIS_DASH_LINE | display dash line without arrow

Definition at line 145 of file zwapi_display.h.

146 {
147 VX_DSP_AXIS_ARROW_LINE = 0,
148 VX_DSP_AXIS_DASH_LINE = 1
149 }evxAxisDispMode;
evxAxisDispMode
evxAxisDispMode
display mode of datum axis
Definition: zwapi_display.h:146
VX_DSP_AXIS_ARROW_LINE
@ VX_DSP_AXIS_ARROW_LINE
display arrow line
Definition: zwapi_display.h:147
VX_DSP_AXIS_DASH_LINE
@ VX_DSP_AXIS_DASH_LINE
display dash line without arrow
Definition: zwapi_display.h:148
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxLightType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxLightType

enum evxLightType

#include <zwapi_display.h>

light source type

Enumerator
V_LIGHT_NULL | undefined
V_LIGHT_AMB | ambient light source
V_LIGHT_DIR | directional light source
V_LIGHT_POS | positional light source
V_LIGHT_SPOT | spot light source
V_LIGHT_EYE | light source located at view position

Definition at line 90 of file zwapi_display.h.

91 {
92 V_LIGHT_NULL = 0,
93 V_LIGHT_AMB = 1,
94 V_LIGHT_DIR = 2,
95 V_LIGHT_POS = 3,
96 V_LIGHT_SPOT = 4,
97 V_LIGHT_EYE = 5
98 } evxLightType;
evxLightType
evxLightType
light source type
Definition: zwapi_display.h:91
V_LIGHT_SPOT
@ V_LIGHT_SPOT
spot light source
Definition: zwapi_display.h:96
V_LIGHT_AMB
@ V_LIGHT_AMB
ambient light source
Definition: zwapi_display.h:93
V_LIGHT_DIR
@ V_LIGHT_DIR
directional light source
Definition: zwapi_display.h:94
V_LIGHT_POS
@ V_LIGHT_POS
positional light source
Definition: zwapi_display.h:95
V_LIGHT_EYE
@ V_LIGHT_EYE
light source located at view position
Definition: zwapi_display.h:97
V_LIGHT_NULL
@ V_LIGHT_NULL
undefined
Definition: zwapi_display.h:92
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Display
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ evxDispMode

enum evxDispMode

#include <zwapi_display.h>

display mode

Enumerator
VX_DISP_WIRE | wireframe display without showing facet edges
VX_DISP_SHADE | shaded surfaces
VX_DISP_HIDD_APPROX | approximate hidden line display
VX_DISP_HIDD_EXACT | shade analyze mode (contour lines, etc)
VX_DISP_EDGE | multiple mode (allows shade/wire/hidden/zebra at same time

Definition at line 50 of file zwapi_display.h.

51 {
52 VX_DISP_WIRE = 1,
53 VX_DISP_SHADE = 2,
54 VX_DISP_HIDD_APPROX = 3,
55 VX_DISP_HIDD_EXACT = 4,
56 VX_DISP_EDGE = 5
57 } evxDispMode;
evxDispMode
evxDispMode
display mode
Definition: zwapi_display.h:51
VX_DISP_HIDD_APPROX
@ VX_DISP_HIDD_APPROX
approximate hidden line display
Definition: zwapi_display.h:54
VX_DISP_EDGE
@ VX_DISP_EDGE
multiple mode (allows shade/wire/hidden/zebra at same time
Definition: zwapi_display.h:56
VX_DISP_WIRE
@ VX_DISP_WIRE
wireframe display without showing facet edges
Definition: zwapi_display.h:52
VX_DISP_SHADE
@ VX_DISP_SHADE
shaded surfaces
Definition: zwapi_display.h:53
VX_DISP_HIDD_EXACT
@ VX_DISP_HIDD_EXACT
shade analyze mode (contour lines, etc)
Definition: zwapi_display.h:55
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxHorizontalMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxHorizontalMethod

enum evxHorizontalMethod

#include <zwapi_dwg_data.h>

horizontal method

Enumerator
VX_HORIZONTAL_NORMAL | normal
VX_HORIZONTAL_LEFT | left
VX_HORIZONTAL_CENTER | center
VX_HORIZONTAL_RIGHT | right

Definition at line 311 of file zwapi_dwg_data.h.

312 {
313 VX_HORIZONTAL_NORMAL,
314 VX_HORIZONTAL_LEFT,
315 VX_HORIZONTAL_CENTER,
316 VX_HORIZONTAL_RIGHT,
317 } evxHorizontalMethod;
evxHorizontalMethod
evxHorizontalMethod
horizontal method
Definition: zwapi_dwg_data.h:312
VX_HORIZONTAL_CENTER
@ VX_HORIZONTAL_CENTER
center
Definition: zwapi_dwg_data.h:315
VX_HORIZONTAL_NORMAL
@ VX_HORIZONTAL_NORMAL
normal
Definition: zwapi_dwg_data.h:313
VX_HORIZONTAL_RIGHT
@ VX_HORIZONTAL_RIGHT
right
Definition: zwapi_dwg_data.h:316
VX_HORIZONTAL_LEFT
@ VX_HORIZONTAL_LEFT
left
Definition: zwapi_dwg_data.h:314
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTextAlignWordWrap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxTextAlignWordWrap

enum evxTextAlignWordWrap

#include <zwapi_dwg_data.h>

fit method

Enumerator
VX_TEXTALIGN_NONE | none
VX_TEXTALIGN_WORDWRAP | word wrap
VX_TEXTALIGN_AUTOSIZETEXT | auto size text

Definition at line 300 of file zwapi_dwg_data.h.

301 {
302 VX_TEXTALIGN_NONE,
303 VX_TEXTALIGN_WORDWRAP,
304 VX_TEXTALIGN_AUTOSIZETEXT,
305 } evxTextAlignWordWrap;
evxTextAlignWordWrap
evxTextAlignWordWrap
fit method
Definition: zwapi_dwg_data.h:301
VX_TEXTALIGN_NONE
@ VX_TEXTALIGN_NONE
none
Definition: zwapi_dwg_data.h:302
VX_TEXTALIGN_AUTOSIZETEXT
@ VX_TEXTALIGN_AUTOSIZETEXT
auto size text
Definition: zwapi_dwg_data.h:304
VX_TEXTALIGN_WORDWRAP
@ VX_TEXTALIGN_WORDWRAP
word wrap
Definition: zwapi_dwg_data.h:303
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTextFontType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxTextFontType

enum evxTextFontType

#include <zwapi_dwg_data.h>

font type

Enumerator
VX_FONTTYPE_NORMAL | none
VX_FONTTYPE_PROPORTIONAL | proportional
VX_FONTTYPE_FIXED | fixed

Definition at line 278 of file zwapi_dwg_data.h.

279 {
280 VX_FONTTYPE_NORMAL,
281 VX_FONTTYPE_PROPORTIONAL,
282 VX_FONTTYPE_FIXED,
283 } evxTextFontType;
evxTextFontType
evxTextFontType
font type
Definition: zwapi_dwg_data.h:279
VX_FONTTYPE_NORMAL
@ VX_FONTTYPE_NORMAL
none
Definition: zwapi_dwg_data.h:280
VX_FONTTYPE_PROPORTIONAL
@ VX_FONTTYPE_PROPORTIONAL
proportional
Definition: zwapi_dwg_data.h:281
VX_FONTTYPE_FIXED
@ VX_FONTTYPE_FIXED
fixed
Definition: zwapi_dwg_data.h:282
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTextAlignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxTextAlignment

enum evxTextAlignment

#include <zwapi_dwg_data.h>

justification

Enumerator
VX_ALIGNMENT_LEFT | align left
VX_ALIGNMENT_CENTER | align center
VX_ALIGNMENT_RIGHT | aling right

Definition at line 369 of file zwapi_dwg_data.h.

370 {
371 VX_ALIGNMENT_LEFT = 1,
372 VX_ALIGNMENT_CENTER,
373 VX_ALIGNMENT_RIGHT,
374 } evxTextAlignment;
evxTextAlignment
evxTextAlignment
justification
Definition: zwapi_dwg_data.h:370
VX_ALIGNMENT_RIGHT
@ VX_ALIGNMENT_RIGHT
aling right
Definition: zwapi_dwg_data.h:373
VX_ALIGNMENT_LEFT
@ VX_ALIGNMENT_LEFT
align left
Definition: zwapi_dwg_data.h:371
VX_ALIGNMENT_CENTER
@ VX_ALIGNMENT_CENTER
align center
Definition: zwapi_dwg_data.h:372
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxSymbolType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxSymbolType

enum evxSymbolType

#include <zwapi_dwg_data.h>

symbol object type

Enumerator
VX_SYM_ALL | any symbol
VX_SYM_USER | user defined symbol
VX_SYM_SURF | surface finish
VX_SYM_WELD | weld
VX_SYM_IMAGE | image
VX_SYM_ORIGIN | origin symbol
VX_SYM_BEAD | caterpillar
VX_SYM_ENDTRT | end treatment
VX_SYM_OPEN_LINK | OLE object.
VX_SYM_HOLE_MARK | hole mark

Definition at line 156 of file zwapi_dwg_data.h.

157 {
158 VX_SYM_ALL = -1,
159 VX_SYM_USER = 0,
160 VX_SYM_SURF = 1,
161 VX_SYM_WELD = 2,
162 VX_SYM_IMAGE = 3,
163 VX_SYM_ORIGIN = 4,
164 VX_SYM_BEAD = 5,
165 VX_SYM_ENDTRT = 6,
166 VX_SYM_OPEN_LINK = 7,
167 VX_SYM_HOLE_MARK = 8,
168 } evxSymbolType;
evxSymbolType
evxSymbolType
symbol object type
Definition: zwapi_dwg_data.h:157
VX_SYM_ALL
@ VX_SYM_ALL
any symbol
Definition: zwapi_dwg_data.h:158
VX_SYM_BEAD
@ VX_SYM_BEAD
caterpillar
Definition: zwapi_dwg_data.h:164
VX_SYM_ENDTRT
@ VX_SYM_ENDTRT
end treatment
Definition: zwapi_dwg_data.h:165
VX_SYM_USER
@ VX_SYM_USER
user defined symbol
Definition: zwapi_dwg_data.h:159
VX_SYM_HOLE_MARK
@ VX_SYM_HOLE_MARK
hole mark
Definition: zwapi_dwg_data.h:167
VX_SYM_OPEN_LINK
@ VX_SYM_OPEN_LINK
OLE object.
Definition: zwapi_dwg_data.h:166
VX_SYM_IMAGE
@ VX_SYM_IMAGE
image
Definition: zwapi_dwg_data.h:162
VX_SYM_SURF
@ VX_SYM_SURF
surface finish
Definition: zwapi_dwg_data.h:160
VX_SYM_WELD
@ VX_SYM_WELD
weld
Definition: zwapi_dwg_data.h:161
VX_SYM_ORIGIN
@ VX_SYM_ORIGIN
origin symbol
Definition: zwapi_dwg_data.h:163
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTableType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxTableType

enum evxTableType

#include <zwapi_dwg_data.h>

table type

Enumerator
VX_TABLE_ALL | any table type
VX_TABLE_USER | User table.
VX_TABLE_BOM | BOM table.
VX_TABLE_HOLE | Hole table.
VX_TABLE_TRODE | Electrode table.
VX_TABLE_WDSEG | Structural BOM table.
VX_TABLE_WELD | Weld table.
VX_TABLE_PNT | Point table.
VX_TABLE_DIM | Dimension table.
VX_TABLE_REV | Revision table.

Definition at line 203 of file zwapi_dwg_data.h.

204 {
205 VX_TABLE_ALL = 0,
206 VX_TABLE_USER = 1,
207 VX_TABLE_BOM = 2,
208 VX_TABLE_HOLE = 3,
209 VX_TABLE_TRODE = 4,
210 VX_TABLE_WDSEG = 5,
211 VX_TABLE_WELD = 6,
212 VX_TABLE_PNT = 7,
213 VX_TABLE_DIM = 8,
214 VX_TABLE_REV = 9
215 } evxTableType;
evxTableType
evxTableType
table type
Definition: zwapi_dwg_data.h:204
VX_TABLE_REV
@ VX_TABLE_REV
Revision table.
Definition: zwapi_dwg_data.h:214
VX_TABLE_HOLE
@ VX_TABLE_HOLE
Hole table.
Definition: zwapi_dwg_data.h:208
VX_TABLE_PNT
@ VX_TABLE_PNT
Point table.
Definition: zwapi_dwg_data.h:212
VX_TABLE_BOM
@ VX_TABLE_BOM
BOM table.
Definition: zwapi_dwg_data.h:207
VX_TABLE_TRODE
@ VX_TABLE_TRODE
Electrode table.
Definition: zwapi_dwg_data.h:209
VX_TABLE_WELD
@ VX_TABLE_WELD
Weld table.
Definition: zwapi_dwg_data.h:211
VX_TABLE_ALL
@ VX_TABLE_ALL
any table type
Definition: zwapi_dwg_data.h:205
VX_TABLE_DIM
@ VX_TABLE_DIM
Dimension table.
Definition: zwapi_dwg_data.h:213
VX_TABLE_WDSEG
@ VX_TABLE_WDSEG
Structural BOM table.
Definition: zwapi_dwg_data.h:210
VX_TABLE_USER
@ VX_TABLE_USER
User table.
Definition: zwapi_dwg_data.h:206
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxViewProjAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxViewProjAngle

enum evxViewProjAngle

#include <zwapi_dwg_data.h>

drawing view projection angle

Enumerator
VX_VIEW_PROJ_ANG_ALL | any view type
VX_VIEW_3RD_UP | view projected 3rd angle from above
VX_VIEW_3RD_DN | view projected 3rd angle from below
VX_VIEW_3RD_RT | view projected 3rd angle from right
VX_VIEW_3RD_LT | view projected 3rd angle from left
VX_VIEW_1ST_UP | view projected 1st angle from above
VX_VIEW_1ST_DN | view projected 1st angle from below
VX_VIEW_1ST_RT | view projected 1st angle from right
VX_VIEW_1ST_LT | view projected 1st angle from left
VX_VIEW_3RD_PRJ_ANG | view projected at angle, 3rd angle projection
VX_VIEW_1ST_PRJ_ANG | view projected at angle, 1st angle projection

Definition at line 109 of file zwapi_dwg_data.h.

110 {
111 VX_VIEW_PROJ_ANG_ALL = 0,
112 VX_VIEW_3RD_UP = 1,
113 VX_VIEW_3RD_DN = 2,
114 VX_VIEW_3RD_RT = 3,
115 VX_VIEW_3RD_LT = 4,
116 VX_VIEW_1ST_UP = 5,
117 VX_VIEW_1ST_DN = 6,
118 VX_VIEW_1ST_RT = 7,
119 VX_VIEW_1ST_LT = 8,
120 VX_VIEW_3RD_PRJ_ANG = 9,
121 VX_VIEW_1ST_PRJ_ANG = 10,
122 } evxViewProjAngle;
evxViewProjAngle
evxViewProjAngle
drawing view projection angle
Definition: zwapi_dwg_data.h:110
VX_VIEW_3RD_UP
@ VX_VIEW_3RD_UP
view projected 3rd angle from above
Definition: zwapi_dwg_data.h:112
VX_VIEW_1ST_RT
@ VX_VIEW_1ST_RT
view projected 1st angle from right
Definition: zwapi_dwg_data.h:118
VX_VIEW_3RD_LT
@ VX_VIEW_3RD_LT
view projected 3rd angle from left
Definition: zwapi_dwg_data.h:115
VX_VIEW_3RD_RT
@ VX_VIEW_3RD_RT
view projected 3rd angle from right
Definition: zwapi_dwg_data.h:114
VX_VIEW_3RD_PRJ_ANG
@ VX_VIEW_3RD_PRJ_ANG
view projected at angle, 3rd angle projection
Definition: zwapi_dwg_data.h:120
VX_VIEW_1ST_PRJ_ANG
@ VX_VIEW_1ST_PRJ_ANG
view projected at angle, 1st angle projection
Definition: zwapi_dwg_data.h:121
VX_VIEW_1ST_UP
@ VX_VIEW_1ST_UP
view projected 1st angle from above
Definition: zwapi_dwg_data.h:116
VX_VIEW_1ST_LT
@ VX_VIEW_1ST_LT
view projected 1st angle from left
Definition: zwapi_dwg_data.h:119
VX_VIEW_1ST_DN
@ VX_VIEW_1ST_DN
view projected 1st angle from below
Definition: zwapi_dwg_data.h:117
VX_VIEW_PROJ_ANG_ALL
@ VX_VIEW_PROJ_ANG_ALL
any view type
Definition: zwapi_dwg_data.h:111
VX_VIEW_3RD_DN
@ VX_VIEW_3RD_DN
view projected 3rd angle from below
Definition: zwapi_dwg_data.h:113
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxViewType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxViewType

enum evxViewType

#include <zwapi_dwg_data.h>

view type

Enumerator
VX_VIEW_ALL | any view type
VX_VIEW_BASE | base view
VX_VIEW_PROJ | project view
VX_VIEW_SECT | section view
VX_VIEW_DET | detail view
VX_VIEW_DEFN | definition view

Definition at line 95 of file zwapi_dwg_data.h.

96 {
97 VX_VIEW_ALL = 0,
98 VX_VIEW_BASE = 1,
99 VX_VIEW_PROJ = 2,
100 VX_VIEW_SECT = 3,
101 VX_VIEW_DET = 4,
102 VX_VIEW_DEFN = 5
103 } evxViewType;
evxViewType
evxViewType
view type
Definition: zwapi_dwg_data.h:96
VX_VIEW_DET
@ VX_VIEW_DET
detail view
Definition: zwapi_dwg_data.h:101
VX_VIEW_BASE
@ VX_VIEW_BASE
base view
Definition: zwapi_dwg_data.h:98
VX_VIEW_ALL
@ VX_VIEW_ALL
any view type
Definition: zwapi_dwg_data.h:97
VX_VIEW_SECT
@ VX_VIEW_SECT
section view
Definition: zwapi_dwg_data.h:100
VX_VIEW_PROJ
@ VX_VIEW_PROJ
project view
Definition: zwapi_dwg_data.h:99
VX_VIEW_DEFN
@ VX_VIEW_DEFN
definition view
Definition: zwapi_dwg_data.h:102
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxVerticalMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxVerticalMethod

enum evxVerticalMethod

#include <zwapi_dwg_data.h>

vertical method

Enumerator
VX_VERTICAL_NORMAL | normal
VX_VERTICAL_TOP | top
VX_VERTICAL_CAP | cap
VX_VERTICAL_HALF | half
VX_VERTICAL_BASE | base
VX_VERTICAL_BOTTOM | bottom

Definition at line 323 of file zwapi_dwg_data.h.

324 {
325 VX_VERTICAL_NORMAL,
326 VX_VERTICAL_TOP,
327 VX_VERTICAL_CAP,
328 VX_VERTICAL_HALF,
329 VX_VERTICAL_BASE,
330 VX_VERTICAL_BOTTOM,
331 } evxVerticalMethod;
evxVerticalMethod
evxVerticalMethod
vertical method
Definition: zwapi_dwg_data.h:324
VX_VERTICAL_HALF
@ VX_VERTICAL_HALF
half
Definition: zwapi_dwg_data.h:328
VX_VERTICAL_TOP
@ VX_VERTICAL_TOP
top
Definition: zwapi_dwg_data.h:326
VX_VERTICAL_CAP
@ VX_VERTICAL_CAP
cap
Definition: zwapi_dwg_data.h:327
VX_VERTICAL_BASE
@ VX_VERTICAL_BASE
base
Definition: zwapi_dwg_data.h:329
VX_VERTICAL_BOTTOM
@ VX_VERTICAL_BOTTOM
bottom
Definition: zwapi_dwg_data.h:330
VX_VERTICAL_NORMAL
@ VX_VERTICAL_NORMAL
normal
Definition: zwapi_dwg_data.h:325
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxBrkLineCutSty

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxBrkLineCutSty

enum evxBrkLineCutSty

#include <zwapi_dwg_data.h>

break Line style

Enumerator
VX_ZEROZIGZAG_BRKLINE | line
VX_ONEZIGZAG_BRKLINE | single ZigZag of broken line
VX_TWOZIGZAG_BRKLINE | double ZigZag of broken line
VX_CURVE_BRKLINE | curve

Definition at line 128 of file zwapi_dwg_data.h.

129 {
130 VX_ZEROZIGZAG_BRKLINE = 0,
131 VX_ONEZIGZAG_BRKLINE,
132 VX_TWOZIGZAG_BRKLINE,
133 VX_CURVE_BRKLINE
134 } evxBrkLineCutSty;
evxBrkLineCutSty
evxBrkLineCutSty
break Line style
Definition: zwapi_dwg_data.h:129
VX_ZEROZIGZAG_BRKLINE
@ VX_ZEROZIGZAG_BRKLINE
line
Definition: zwapi_dwg_data.h:130
VX_ONEZIGZAG_BRKLINE
@ VX_ONEZIGZAG_BRKLINE
single ZigZag of broken line
Definition: zwapi_dwg_data.h:131
VX_CURVE_BRKLINE
@ VX_CURVE_BRKLINE
curve
Definition: zwapi_dwg_data.h:133
VX_TWOZIGZAG_BRKLINE
@ VX_TWOZIGZAG_BRKLINE
double ZigZag of broken line
Definition: zwapi_dwg_data.h:132
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxTextStroke

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxTextStroke

enum evxTextStroke

#include <zwapi_dwg_data.h>

text precision

Enumerator
VX_STROKE_COARSE | coarse
VX_STROKE_MEDIUM | medium
VX_STROKE_FINE | fine

Definition at line 289 of file zwapi_dwg_data.h.

290 {
291 VX_STROKE_COARSE,
292 VX_STROKE_MEDIUM,
293 VX_STROKE_FINE,
294 } evxTextStroke;
evxTextStroke
evxTextStroke
text precision
Definition: zwapi_dwg_data.h:290
VX_STROKE_FINE
@ VX_STROKE_FINE
fine
Definition: zwapi_dwg_data.h:293
VX_STROKE_COARSE
@ VX_STROKE_COARSE
coarse
Definition: zwapi_dwg_data.h:291
VX_STROKE_MEDIUM
@ VX_STROKE_MEDIUM
medium
Definition: zwapi_dwg_data.h:292
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDwgStyleManagerMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Drawing Data
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ evxDwgStyleManagerMethod

enum evxDwgStyleManagerMethod

#include <zwapi_dwg_data.h>

style manager type

Enumerator
VX_STYLEMANAGER_TEXT | text
VX_STYLEMANAGER_ANNO_LEADER | leader label
VX_STYLEMANAGER_ANNO_BALLOON | balloon label
VX_STYLEMANAGER_ANNO_DATUM_FEATURE | datum feature
VX_STYLEMANAGER_ANNO_DATUM_TARGET | datum target
VX_STYLEMANAGER_ANNO_FEATURE_CONTROL | feature control symbol
VX_STYLEMANAGER_DIM_LINEAR | linear
VX_STYLEMANAGER_DIM_ANGULAR | angular
VX_STYLEMANAGER_DIM_RADIAL | radial/diametric
VX_STYLEMANAGER_DIM_ARC | arc length
VX_STYLEMANAGER_DIM_CHAMFER | chamfer
VX_STYLEMANAGER_DIM_HOLECALLOUT | hole callout
VX_STYLEMANAGER_DIM_ORDINATE | ordinate
VX_STYLEMANAGER_SYM_WELD | weld symbol
VX_STYLEMANAGER_SYM_SRF_FINISH | surface finish symbol
VX_STYLEMANAGER_TABLE_USER | user table
VX_STYLEMANAGER_TABLE_BOM | bom table
VX_STYLEMANAGER_TABLE_HOLE | hole table
VX_STYLEMANAGER_TABLE_EDM | edm table
VX_STYLEMANAGER_TABLE_STRUCTURAL | structural table
VX_STYLEMANAGER_TABLE_WELD | weld table
VX_STYLEMANAGER_TABLE_REVISION | revision table
VX_STYLEMANAGER_VIEW_BASE | base view
VX_STYLEMANAGER_VIEW_PROJECTION | projection view
VX_STYLEMANAGER_VIEW_AUXILIARY | auxiliary view
VX_STYLEMANAGER_VIEW_SECTION | section view
VX_STYLEMANAGER_VIEW_DETAIL | detail view
VX_STYLEMANAGER_VIEW_ALTERNATE | alternate view

Definition at line 237 of file zwapi_dwg_data.h.

238 {
239 VX_STYLEMANAGER_TEXT,
241 VX_STYLEMANAGER_ANNO_LEADER,
242 VX_STYLEMANAGER_ANNO_BALLOON,
243 VX_STYLEMANAGER_ANNO_DATUM_FEATURE,
244 VX_STYLEMANAGER_ANNO_DATUM_TARGET,
245 VX_STYLEMANAGER_ANNO_FEATURE_CONTROL,
247 VX_STYLEMANAGER_DIM_LINEAR,
248 VX_STYLEMANAGER_DIM_ANGULAR,
249 VX_STYLEMANAGER_DIM_RADIAL,
250 VX_STYLEMANAGER_DIM_ARC,
251 VX_STYLEMANAGER_DIM_CHAMFER,
252 VX_STYLEMANAGER_DIM_HOLECALLOUT,
253 VX_STYLEMANAGER_DIM_ORDINATE,
255 VX_STYLEMANAGER_SYM_WELD,
256 VX_STYLEMANAGER_SYM_SRF_FINISH,
258 VX_STYLEMANAGER_TABLE_USER,
259 VX_STYLEMANAGER_TABLE_BOM,
260 VX_STYLEMANAGER_TABLE_HOLE,
261 VX_STYLEMANAGER_TABLE_EDM,
262 VX_STYLEMANAGER_TABLE_STRUCTURAL,
263 VX_STYLEMANAGER_TABLE_WELD,
264 VX_STYLEMANAGER_TABLE_REVISION,
266 VX_STYLEMANAGER_VIEW_BASE,
267 VX_STYLEMANAGER_VIEW_PROJECTION,
268 VX_STYLEMANAGER_VIEW_AUXILIARY,
269 VX_STYLEMANAGER_VIEW_SECTION,
270 VX_STYLEMANAGER_VIEW_DETAIL,
271 VX_STYLEMANAGER_VIEW_ALTERNATE,
272 } evxDwgStyleManagerMethod;
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
style manager type
Definition: zwapi_dwg_data.h:238
VX_STYLEMANAGER_ANNO_BALLOON
@ VX_STYLEMANAGER_ANNO_BALLOON
balloon label
Definition: zwapi_dwg_data.h:242
VX_STYLEMANAGER_TABLE_REVISION
@ VX_STYLEMANAGER_TABLE_REVISION
revision table
Definition: zwapi_dwg_data.h:264
VX_STYLEMANAGER_TEXT
@ VX_STYLEMANAGER_TEXT
text
Definition: zwapi_dwg_data.h:239
VX_STYLEMANAGER_TABLE_HOLE
@ VX_STYLEMANAGER_TABLE_HOLE
hole table
Definition: zwapi_dwg_data.h:260
VX_STYLEMANAGER_VIEW_PROJECTION
@ VX_STYLEMANAGER_VIEW_PROJECTION
projection view
Definition: zwapi_dwg_data.h:267
VX_STYLEMANAGER_DIM_CHAMFER
@ VX_STYLEMANAGER_DIM_CHAMFER
chamfer
Definition: zwapi_dwg_data.h:251
VX_STYLEMANAGER_TABLE_EDM
@ VX_STYLEMANAGER_TABLE_EDM
edm table
Definition: zwapi_dwg_data.h:261
VX_STYLEMANAGER_DIM_LINEAR
@ VX_STYLEMANAGER_DIM_LINEAR
linear
Definition: zwapi_dwg_data.h:247
VX_STYLEMANAGER_TABLE_BOM
@ VX_STYLEMANAGER_TABLE_BOM
bom table
Definition: zwapi_dwg_data.h:259
VX_STYLEMANAGER_ANNO_DATUM_TARGET
@ VX_STYLEMANAGER_ANNO_DATUM_TARGET
datum target
Definition: zwapi_dwg_data.h:244
VX_STYLEMANAGER_VIEW_AUXILIARY
@ VX_STYLEMANAGER_VIEW_AUXILIARY
auxiliary view
Definition: zwapi_dwg_data.h:268
VX_STYLEMANAGER_SYM_WELD
@ VX_STYLEMANAGER_SYM_WELD
weld symbol
Definition: zwapi_dwg_data.h:255
VX_STYLEMANAGER_SYM_SRF_FINISH
@ VX_STYLEMANAGER_SYM_SRF_FINISH
surface finish symbol
Definition: zwapi_dwg_data.h:256
VX_STYLEMANAGER_TABLE_STRUCTURAL
@ VX_STYLEMANAGER_TABLE_STRUCTURAL
structural table
Definition: zwapi_dwg_data.h:262
VX_STYLEMANAGER_TABLE_WELD
@ VX_STYLEMANAGER_TABLE_WELD
weld table
Definition: zwapi_dwg_data.h:263
VX_STYLEMANAGER_DIM_ARC
@ VX_STYLEMANAGER_DIM_ARC
arc length
Definition: zwapi_dwg_data.h:250
VX_STYLEMANAGER_DIM_RADIAL
@ VX_STYLEMANAGER_DIM_RADIAL
radial/diametric
Definition: zwapi_dwg_data.h:249
VX_STYLEMANAGER_ANNO_LEADER
@ VX_STYLEMANAGER_ANNO_LEADER
leader label
Definition: zwapi_dwg_data.h:241
VX_STYLEMANAGER_TABLE_USER
@ VX_STYLEMANAGER_TABLE_USER
user table
Definition: zwapi_dwg_data.h:258
VX_STYLEMANAGER_VIEW_SECTION
@ VX_STYLEMANAGER_VIEW_SECTION
section view
Definition: zwapi_dwg_data.h:269
VX_STYLEMANAGER_ANNO_FEATURE_CONTROL
@ VX_STYLEMANAGER_ANNO_FEATURE_CONTROL
feature control symbol
Definition: zwapi_dwg_data.h:245
VX_STYLEMANAGER_VIEW_DETAIL
@ VX_STYLEMANAGER_VIEW_DETAIL
detail view
Definition: zwapi_dwg_data.h:270
VX_STYLEMANAGER_VIEW_BASE
@ VX_STYLEMANAGER_VIEW_BASE
base view
Definition: zwapi_dwg_data.h:266
VX_STYLEMANAGER_DIM_ORDINATE
@ VX_STYLEMANAGER_DIM_ORDINATE
ordinate
Definition: zwapi_dwg_data.h:253
VX_STYLEMANAGER_DIM_ANGULAR
@ VX_STYLEMANAGER_DIM_ANGULAR
angular
Definition: zwapi_dwg_data.h:248
VX_STYLEMANAGER_ANNO_DATUM_FEATURE
@ VX_STYLEMANAGER_ANNO_DATUM_FEATURE
datum feature
Definition: zwapi_dwg_data.h:243
VX_STYLEMANAGER_VIEW_ALTERNATE
@ VX_STYLEMANAGER_VIEW_ALTERNATE
alternate view
Definition: zwapi_dwg_data.h:271
VX_STYLEMANAGER_DIM_HOLECALLOUT
@ VX_STYLEMANAGER_DIM_HOLECALLOUT
hole callout
Definition: zwapi_dwg_data.h:252
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFileType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxFileType

enum evxFileType

#include <zwapi_file_data.h>

file type

Enumerator
VX_FILE_ALL | all file
VX_FILE_PART | Z3PRT file.
VX_FILE_ASSEMBLY | Z3ASM file.
VX_FILE_SHEET | Z3DRW file.
VX_FILE_SKETCH | Z3SKH file.
VX_FILE_CAMPLAN | Z3CAM file.

Definition at line 31 of file zwapi_file_data.h.

32 {
33 VX_FILE_ALL = 0,
34 VX_FILE_PART = 1,
35 VX_FILE_ASSEMBLY,
36 VX_FILE_SHEET,
37 VX_FILE_SKETCH,
38 VX_FILE_CAMPLAN,
39 } evxFileType;
evxFileType
evxFileType
file type
Definition: zwapi_file_data.h:32
VX_FILE_SHEET
@ VX_FILE_SHEET
Z3DRW file.
Definition: zwapi_file_data.h:36
VX_FILE_CAMPLAN
@ VX_FILE_CAMPLAN
Z3CAM file.
Definition: zwapi_file_data.h:38
VX_FILE_ALL
@ VX_FILE_ALL
all file
Definition: zwapi_file_data.h:33
VX_FILE_ASSEMBLY
@ VX_FILE_ASSEMBLY
Z3ASM file.
Definition: zwapi_file_data.h:35
VX_FILE_PART
@ VX_FILE_PART
Z3PRT file.
Definition: zwapi_file_data.h:34
VX_FILE_SKETCH
@ VX_FILE_SKETCH
Z3SKH file.
Definition: zwapi_file_data.h:37
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxRemoveTextFontType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxRemoveTextFontType

enum evxRemoveTextFontType

#include <zwapi_file_data.h>

remove text font info type.

Enumerator
VX_TEXT_FONT_TYPE_NONE | none
VX_TEXT_FONT_TYPE_ALL | all
VX_TEXT_FONT_TYPE_EXCLUDE | exclude sheet format and table.

Definition at line 270 of file zwapi_file_data.h.

271 {
272 VX_TEXT_FONT_TYPE_NONE = 0,
273 VX_TEXT_FONT_TYPE_ALL = 1,
274 VX_TEXT_FONT_TYPE_EXCLUDE = 2,
275 } evxRemoveTextFontType;
evxRemoveTextFontType
evxRemoveTextFontType
remove text font info type.
Definition: zwapi_file_data.h:271
VX_TEXT_FONT_TYPE_EXCLUDE
@ VX_TEXT_FONT_TYPE_EXCLUDE
exclude sheet format and table.
Definition: zwapi_file_data.h:274
VX_TEXT_FONT_TYPE_NONE
@ VX_TEXT_FONT_TYPE_NONE
none
Definition: zwapi_file_data.h:272
VX_TEXT_FONT_TYPE_ALL
@ VX_TEXT_FONT_TYPE_ALL
all
Definition: zwapi_file_data.h:273
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDWGVer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxDWGVer

enum evxDWGVer

#include <zwapi_file_data.h>

version of DWG

Enumerator
VX_DWG_VERSION_2018 | version 2018
VX_DWG_VERSION_2013 | version 2013
VX_DWG_VERSION_2010 | version 2010
VX_DWG_VERSION_2007 | version 2007
VX_DWG_VERSION_2004 | version 2004
VX_DWG_VERSION_2000 | version 2000
VX_DWG_VERSION_R14 | version r14
VX_DWG_VERSION_R13 | version r13
VX_DWG_VERSION_R11_R12 | version r11 or r12

Definition at line 204 of file zwapi_file_data.h.

205 {
206 VX_DWG_VERSION_2018 = 1,
207 VX_DWG_VERSION_2013 = 2,
208 VX_DWG_VERSION_2010 = 3,
209 VX_DWG_VERSION_2007,
210 VX_DWG_VERSION_2004,
211 VX_DWG_VERSION_2000,
212 VX_DWG_VERSION_R14,
213 VX_DWG_VERSION_R13,
214 VX_DWG_VERSION_R11_R12,
215 }evxDWGVer;
evxDWGVer
evxDWGVer
version of DWG
Definition: zwapi_file_data.h:205
VX_DWG_VERSION_2013
@ VX_DWG_VERSION_2013
version 2013
Definition: zwapi_file_data.h:207
VX_DWG_VERSION_R11_R12
@ VX_DWG_VERSION_R11_R12
version r11 or r12
Definition: zwapi_file_data.h:214
VX_DWG_VERSION_R14
@ VX_DWG_VERSION_R14
version r14
Definition: zwapi_file_data.h:212
VX_DWG_VERSION_2004
@ VX_DWG_VERSION_2004
version 2004
Definition: zwapi_file_data.h:210
VX_DWG_VERSION_R13
@ VX_DWG_VERSION_R13
version r13
Definition: zwapi_file_data.h:213
VX_DWG_VERSION_2018
@ VX_DWG_VERSION_2018
version 2018
Definition: zwapi_file_data.h:206
VX_DWG_VERSION_2000
@ VX_DWG_VERSION_2000
version 2000
Definition: zwapi_file_data.h:211
VX_DWG_VERSION_2010
@ VX_DWG_VERSION_2010
version 2010
Definition: zwapi_file_data.h:208
VX_DWG_VERSION_2007
@ VX_DWG_VERSION_2007
version 2007
Definition: zwapi_file_data.h:209
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPTSHistoryType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxPTSHistoryType

enum evxPTSHistoryType

#include <zwapi_file_data.h>

operation type stored in part's history

Enumerator
VX_PTS_HISTORY_SUBPART | sub-part
VX_PTS_HISTORY_BACKUP | backup
VX_PTS_HISTORY_ENCAPSULATE | encapsulate
VX_PTS_HISTORY_NOBACKUP | no backup

Definition at line 603 of file zwapi_file_data.h.

604 {
605 VX_PTS_HISTORY_SUBPART = 0,
606 VX_PTS_HISTORY_BACKUP = 1,
607 VX_PTS_HISTORY_ENCAPSULATE = 2,
608 VX_PTS_HISTORY_NOBACKUP = 3,
609 } evxPTSHistoryType;
evxPTSHistoryType
evxPTSHistoryType
operation type stored in part's history
Definition: zwapi_file_data.h:604
VX_PTS_HISTORY_NOBACKUP
@ VX_PTS_HISTORY_NOBACKUP
no backup
Definition: zwapi_file_data.h:608
VX_PTS_HISTORY_BACKUP
@ VX_PTS_HISTORY_BACKUP
backup
Definition: zwapi_file_data.h:606
VX_PTS_HISTORY_SUBPART
@ VX_PTS_HISTORY_SUBPART
sub-part
Definition: zwapi_file_data.h:605
VX_PTS_HISTORY_ENCAPSULATE
@ VX_PTS_HISTORY_ENCAPSULATE
encapsulate
Definition: zwapi_file_data.h:607
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxImportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxImportType

enum evxImportType

#include <zwapi_file_data.h>

file import type

Enumerator
VX_IMPORT_TYPE_ALL | import all files types
VX_IMPORT_TYPE_PARASOLID | import .x_t file
VX_IMPORT_TYPE_DWG_DXF | import .dwg/.dxf file
VX_IMPORT_TYPE_STEP | import .stp/.step file
VX_IMPORT_TYPE_SAT | import .sat/.sab file
VX_IMPORT_TYPE_IGES | import .igs/.iges file
VX_IMPORT_TYPE_CATIA4 | import .model/.exp... file
VX_IMPORT_TYPE_CATIA5 | import .CATPart/.CATProduct file
VX_IMPORT_TYPE_INVENTOR | import .ipt/.iam file
VX_IMPORT_TYPE_JT | import .jt file
VX_IMPORT_TYPE_PROE_CERO | import .prt/.asm file
VX_IMPORT_TYPE_SOLIDEDGE | import .par/.psm... file
VX_IMPORT_TYPE_SOLIDWORKS | import .sldprt/.sldasm file
VX_IMPORT_TYPE_UG | import .prt file
VX_IMPORT_TYPE_STL | import .stl file
VX_IMPORT_TYPE_GPH | import .3rd graphic format file
VX_IMPORT_PTS_FROM_FILE | import points form ASCII file (.txt, .asc, .csv, .dat, .exp, .pts, .xyz are supported)

Definition at line 470 of file zwapi_file_data.h.

471 {
472 VX_IMPORT_TYPE_ALL = 0,
473 VX_IMPORT_TYPE_PARASOLID = 1,
474 VX_IMPORT_TYPE_DWG_DXF = 2,
475 VX_IMPORT_TYPE_STEP,
476 VX_IMPORT_TYPE_SAT,
477 VX_IMPORT_TYPE_IGES,
478 VX_IMPORT_TYPE_CATIA4,
479 VX_IMPORT_TYPE_CATIA5,
480 VX_IMPORT_TYPE_INVENTOR,
481 VX_IMPORT_TYPE_JT,
482 VX_IMPORT_TYPE_PROE_CERO,
483 VX_IMPORT_TYPE_SOLIDEDGE,
484 VX_IMPORT_TYPE_SOLIDWORKS,
485 VX_IMPORT_TYPE_UG,
486 VX_IMPORT_TYPE_STL,
487 VX_IMPORT_TYPE_GPH,
488 VX_IMPORT_PTS_FROM_FILE,
489 }evxImportType;
evxImportType
evxImportType
file import type
Definition: zwapi_file_data.h:471
VX_IMPORT_TYPE_SOLIDWORKS
@ VX_IMPORT_TYPE_SOLIDWORKS
import .sldprt/.sldasm file
Definition: zwapi_file_data.h:484
VX_IMPORT_TYPE_GPH
@ VX_IMPORT_TYPE_GPH
import .3rd graphic format file
Definition: zwapi_file_data.h:487
VX_IMPORT_TYPE_INVENTOR
@ VX_IMPORT_TYPE_INVENTOR
import .ipt/.iam file
Definition: zwapi_file_data.h:480
VX_IMPORT_TYPE_CATIA5
@ VX_IMPORT_TYPE_CATIA5
import .CATPart/.CATProduct file
Definition: zwapi_file_data.h:479
VX_IMPORT_PTS_FROM_FILE
@ VX_IMPORT_PTS_FROM_FILE
import points form ASCII file (.txt, .asc, .csv, .dat, .exp, .pts, .xyz are supported)
Definition: zwapi_file_data.h:488
VX_IMPORT_TYPE_PARASOLID
@ VX_IMPORT_TYPE_PARASOLID
import .x_t file
Definition: zwapi_file_data.h:473
VX_IMPORT_TYPE_JT
@ VX_IMPORT_TYPE_JT
import .jt file
Definition: zwapi_file_data.h:481
VX_IMPORT_TYPE_IGES
@ VX_IMPORT_TYPE_IGES
import .igs/.iges file
Definition: zwapi_file_data.h:477
VX_IMPORT_TYPE_STL
@ VX_IMPORT_TYPE_STL
import .stl file
Definition: zwapi_file_data.h:486
VX_IMPORT_TYPE_SOLIDEDGE
@ VX_IMPORT_TYPE_SOLIDEDGE
import .par/.psm... file
Definition: zwapi_file_data.h:483
VX_IMPORT_TYPE_STEP
@ VX_IMPORT_TYPE_STEP
import .stp/.step file
Definition: zwapi_file_data.h:475
VX_IMPORT_TYPE_DWG_DXF
@ VX_IMPORT_TYPE_DWG_DXF
import .dwg/.dxf file
Definition: zwapi_file_data.h:474
VX_IMPORT_TYPE_UG
@ VX_IMPORT_TYPE_UG
import .prt file
Definition: zwapi_file_data.h:485
VX_IMPORT_TYPE_CATIA4
@ VX_IMPORT_TYPE_CATIA4
import .model/.exp... file
Definition: zwapi_file_data.h:478
VX_IMPORT_TYPE_SAT
@ VX_IMPORT_TYPE_SAT
import .sat/.sab file
Definition: zwapi_file_data.h:476
VX_IMPORT_TYPE_PROE_CERO
@ VX_IMPORT_TYPE_PROE_CERO
import .prt/.asm file
Definition: zwapi_file_data.h:482
VX_IMPORT_TYPE_ALL
@ VX_IMPORT_TYPE_ALL
import all files types
Definition: zwapi_file_data.h:472
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDWGDXFReadAsUnits

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxDWGDXFReadAsUnits

enum evxDWGDXFReadAsUnits

#include <zwapi_file_data.h>

dwg dxf import options of read as units

Enumerator
VX_UNIT_DWGDXF_INCHES | inches
VX_UNIT_DWGDXF_FEET | feet
VX_UNIT_DWGDXF_MILES | miles
VX_UNIT_DWGDXF_MILIMETERS | milimeters
VX_UNIT_DWGDXF_CENTIMETERS | centimeters
VX_UNIT_DWGDXF_METERS | meters
VX_UNIT_DWGDXF_KILOMETERS | kilometers
VX_UNIT_DWGDXF_MICROINCHES | microinches
VX_UNIT_DWGDXF_MILS | mils
VX_UNIT_DWGDXF_YARDS | yards
VX_UNIT_DWGDXF_ANGSTROMS | angstroms
VX_UNIT_DWGDXF_NANOMETERS | nanometers
VX_UNIT_DWGDXF_MICRONS | microns
VX_UNIT_DWGDXF_DECIMETERS | decimeters
VX_UNIT_DWGDXF_DEKAMETERS | dekameters
VX_UNIT_DWGDXF_HECTOMETERS | hectometers
VX_UNIT_DWGDXF_GIGAMETERS | gigameters
VX_UNIT_DWGDXF_ASTRONOMICAL | astronomical
VX_UNIT_DWGDXF_LIGHTYEARS | lightyears
VX_UNIT_DWGDXF_PARSECS | parsecs

Definition at line 533 of file zwapi_file_data.h.

534 {
535 VX_UNIT_DWGDXF_INCHES = 1,
536 VX_UNIT_DWGDXF_FEET = 2,
537 VX_UNIT_DWGDXF_MILES = 3,
538 VX_UNIT_DWGDXF_MILIMETERS = 4,
539 VX_UNIT_DWGDXF_CENTIMETERS = 5,
540 VX_UNIT_DWGDXF_METERS = 6,
541 VX_UNIT_DWGDXF_KILOMETERS = 7,
542 VX_UNIT_DWGDXF_MICROINCHES = 8,
543 VX_UNIT_DWGDXF_MILS = 9,
544 VX_UNIT_DWGDXF_YARDS = 10,
545 VX_UNIT_DWGDXF_ANGSTROMS = 11,
546 VX_UNIT_DWGDXF_NANOMETERS = 12,
547 VX_UNIT_DWGDXF_MICRONS = 13,
548 VX_UNIT_DWGDXF_DECIMETERS = 14,
549 VX_UNIT_DWGDXF_DEKAMETERS = 15,
550 VX_UNIT_DWGDXF_HECTOMETERS = 16,
551 VX_UNIT_DWGDXF_GIGAMETERS = 17,
552 VX_UNIT_DWGDXF_ASTRONOMICAL = 18,
553 VX_UNIT_DWGDXF_LIGHTYEARS = 19,
554 VX_UNIT_DWGDXF_PARSECS = 20,
555 } evxDWGDXFReadAsUnits;
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
dwg dxf import options of read as units
Definition: zwapi_file_data.h:534
VX_UNIT_DWGDXF_MILIMETERS
@ VX_UNIT_DWGDXF_MILIMETERS
milimeters
Definition: zwapi_file_data.h:538
VX_UNIT_DWGDXF_LIGHTYEARS
@ VX_UNIT_DWGDXF_LIGHTYEARS
lightyears
Definition: zwapi_file_data.h:553
VX_UNIT_DWGDXF_PARSECS
@ VX_UNIT_DWGDXF_PARSECS
parsecs
Definition: zwapi_file_data.h:554
VX_UNIT_DWGDXF_CENTIMETERS
@ VX_UNIT_DWGDXF_CENTIMETERS
centimeters
Definition: zwapi_file_data.h:539
VX_UNIT_DWGDXF_MICRONS
@ VX_UNIT_DWGDXF_MICRONS
microns
Definition: zwapi_file_data.h:547
VX_UNIT_DWGDXF_MICROINCHES
@ VX_UNIT_DWGDXF_MICROINCHES
microinches
Definition: zwapi_file_data.h:542
VX_UNIT_DWGDXF_MILS
@ VX_UNIT_DWGDXF_MILS
mils
Definition: zwapi_file_data.h:543
VX_UNIT_DWGDXF_FEET
@ VX_UNIT_DWGDXF_FEET
feet
Definition: zwapi_file_data.h:536
VX_UNIT_DWGDXF_HECTOMETERS
@ VX_UNIT_DWGDXF_HECTOMETERS
hectometers
Definition: zwapi_file_data.h:550
VX_UNIT_DWGDXF_ASTRONOMICAL
@ VX_UNIT_DWGDXF_ASTRONOMICAL
astronomical
Definition: zwapi_file_data.h:552
VX_UNIT_DWGDXF_GIGAMETERS
@ VX_UNIT_DWGDXF_GIGAMETERS
gigameters
Definition: zwapi_file_data.h:551
VX_UNIT_DWGDXF_YARDS
@ VX_UNIT_DWGDXF_YARDS
yards
Definition: zwapi_file_data.h:544
VX_UNIT_DWGDXF_DECIMETERS
@ VX_UNIT_DWGDXF_DECIMETERS
decimeters
Definition: zwapi_file_data.h:548
VX_UNIT_DWGDXF_ANGSTROMS
@ VX_UNIT_DWGDXF_ANGSTROMS
angstroms
Definition: zwapi_file_data.h:545
VX_UNIT_DWGDXF_METERS
@ VX_UNIT_DWGDXF_METERS
meters
Definition: zwapi_file_data.h:540
VX_UNIT_DWGDXF_INCHES
@ VX_UNIT_DWGDXF_INCHES
inches
Definition: zwapi_file_data.h:535
VX_UNIT_DWGDXF_NANOMETERS
@ VX_UNIT_DWGDXF_NANOMETERS
nanometers
Definition: zwapi_file_data.h:546
VX_UNIT_DWGDXF_DEKAMETERS
@ VX_UNIT_DWGDXF_DEKAMETERS
dekameters
Definition: zwapi_file_data.h:549
VX_UNIT_DWGDXF_KILOMETERS
@ VX_UNIT_DWGDXF_KILOMETERS
kilometers
Definition: zwapi_file_data.h:541
VX_UNIT_DWGDXF_MILES
@ VX_UNIT_DWGDXF_MILES
miles
Definition: zwapi_file_data.h:537
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxImgType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxImgType

enum evxImgType

#include <zwapi_file_data.h>

export image type

Enumerator
VX_EXPORT_IMG_TYPE_BMP | bmp
VX_EXPORT_IMG_TYPE_GIF | gif
VX_EXPORT_IMG_TYPE_PNG | png
VX_EXPORT_IMG_TYPE_TIFF | tiff
VX_EXPORT_IMG_TYPE_JPEG | jpeg

Definition at line 100 of file zwapi_file_data.h.

101 {
102 VX_EXPORT_IMG_TYPE_BMP = 1,
103 VX_EXPORT_IMG_TYPE_GIF,
104 VX_EXPORT_IMG_TYPE_PNG,
105 VX_EXPORT_IMG_TYPE_TIFF,
106 VX_EXPORT_IMG_TYPE_JPEG
107 } evxImgType;
evxImgType
evxImgType
export image type
Definition: zwapi_file_data.h:101
VX_EXPORT_IMG_TYPE_JPEG
@ VX_EXPORT_IMG_TYPE_JPEG
jpeg
Definition: zwapi_file_data.h:106
VX_EXPORT_IMG_TYPE_PNG
@ VX_EXPORT_IMG_TYPE_PNG
png
Definition: zwapi_file_data.h:104
VX_EXPORT_IMG_TYPE_TIFF
@ VX_EXPORT_IMG_TYPE_TIFF
tiff
Definition: zwapi_file_data.h:105
VX_EXPORT_IMG_TYPE_BMP
@ VX_EXPORT_IMG_TYPE_BMP
bmp
Definition: zwapi_file_data.h:102
VX_EXPORT_IMG_TYPE_GIF
@ VX_EXPORT_IMG_TYPE_GIF
gif
Definition: zwapi_file_data.h:103
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxImgBkgndMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxImgBkgndMode

enum evxImgBkgndMode

#include <zwapi_file_data.h>

export image background mode

Enumerator
VX_EXPORT_IMG_BKGND_MODE_CURRENT | use current graphic window background color as the image background color
VX_EXPORT_IMG_BKGND_MODE_CUSTOM | use the Color to define your favorite image background color

Definition at line 79 of file zwapi_file_data.h.

80 {
81 VX_EXPORT_IMG_BKGND_MODE_CURRENT = 0,
82 VX_EXPORT_IMG_BKGND_MODE_CUSTOM
83 } evxImgBkgndMode;
evxImgBkgndMode
evxImgBkgndMode
export image background mode
Definition: zwapi_file_data.h:80
VX_EXPORT_IMG_BKGND_MODE_CUSTOM
@ VX_EXPORT_IMG_BKGND_MODE_CUSTOM
use the Color to define your favorite image background color
Definition: zwapi_file_data.h:82
VX_EXPORT_IMG_BKGND_MODE_CURRENT
@ VX_EXPORT_IMG_BKGND_MODE_CURRENT
use current graphic window background color as the image background color
Definition: zwapi_file_data.h:81
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPdfType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxPdfType

enum evxPdfType

#include <zwapi_file_data.h>

export pdf type

Enumerator
VX_EXPORT_PDF_TYPE_RASTER | load the raster image into pdf
VX_EXPORT_PDF_TYPE_VECTOR | create the vector graphic data into pdf (set this value to Sheet file)
VX_EXPORT_PDF_TYPE_OBJECT | export type is 3D

Definition at line 113 of file zwapi_file_data.h.

114 {
115 VX_EXPORT_PDF_TYPE_RASTER = 1,
116 VX_EXPORT_PDF_TYPE_VECTOR,
117 VX_EXPORT_PDF_TYPE_OBJECT
118 } evxPdfType;
evxPdfType
evxPdfType
export pdf type
Definition: zwapi_file_data.h:114
VX_EXPORT_PDF_TYPE_OBJECT
@ VX_EXPORT_PDF_TYPE_OBJECT
export type is 3D
Definition: zwapi_file_data.h:117
VX_EXPORT_PDF_TYPE_RASTER
@ VX_EXPORT_PDF_TYPE_RASTER
load the raster image into pdf
Definition: zwapi_file_data.h:115
VX_EXPORT_PDF_TYPE_VECTOR
@ VX_EXPORT_PDF_TYPE_VECTOR
create the vector graphic data into pdf (set this value to Sheet file)
Definition: zwapi_file_data.h:116
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxExportType

enum evxExportType

#include <zwapi_file_data.h>

export file type

Enumerator
VX_EXPORT_TYPE_IMG | the data is defined by struct svxImgData
VX_EXPORT_TYPE_PDF | the data is defined by struct svxPdfData
VX_EXPORT_TYPE_GRP | the data is defined by struct svxGRPData
VX_EXPORT_TYPE_DWG | the data is defined by struct svxDWGData
VX_EXPORT_TYPE_IGES | the data is defined by struct svxIGESData
VX_EXPORT_TYPE_STEP | the data is defined by struct svxSTEPData
VX_EXPORT_TYPE_JT | the data is defined by struct svxJTData
VX_EXPORT_TYPE_PARA_TEXT | the data is defined by struct svxPARAData
VX_EXPORT_TYPE_PARA_BINARY | the data is defined by struct svxPARAData
VX_EXPORT_TYPE_CAT5_PART | the data is defined by struct svxCAT5Data
VX_EXPORT_TYPE_CAT5_ASM | the data is defined by struct svxCAT5Data
VX_EXPORT_TYPE_HTML | the data is defined by struct svxHTMLData
VX_EXPORT_TYPE_STL | the data is defined by struct svxSTLData
VX_EXPORT_TYPE_OBJ | the data is defined by struct svxOBJData

Definition at line 669 of file zwapi_file_data.h.

670 {
671 VX_EXPORT_TYPE_IMG = 1,
672 VX_EXPORT_TYPE_PDF,
673 VX_EXPORT_TYPE_GRP,
674 VX_EXPORT_TYPE_DWG,
675 VX_EXPORT_TYPE_IGES,
676 VX_EXPORT_TYPE_STEP,
677 VX_EXPORT_TYPE_JT,
678 VX_EXPORT_TYPE_PARA_TEXT,
679 VX_EXPORT_TYPE_PARA_BINARY,
680 VX_EXPORT_TYPE_CAT5_PART,
681 VX_EXPORT_TYPE_CAT5_ASM,
682 VX_EXPORT_TYPE_HTML,
683 VX_EXPORT_TYPE_STL,
684 VX_EXPORT_TYPE_OBJ,
685 } evxExportType;
evxExportType
evxExportType
export file type
Definition: zwapi_file_data.h:670
VX_EXPORT_TYPE_DWG
@ VX_EXPORT_TYPE_DWG
the data is defined by struct svxDWGData
Definition: zwapi_file_data.h:674
VX_EXPORT_TYPE_PARA_TEXT
@ VX_EXPORT_TYPE_PARA_TEXT
the data is defined by struct svxPARAData
Definition: zwapi_file_data.h:678
VX_EXPORT_TYPE_OBJ
@ VX_EXPORT_TYPE_OBJ
the data is defined by struct svxOBJData
Definition: zwapi_file_data.h:684
VX_EXPORT_TYPE_CAT5_ASM
@ VX_EXPORT_TYPE_CAT5_ASM
the data is defined by struct svxCAT5Data
Definition: zwapi_file_data.h:681
VX_EXPORT_TYPE_PARA_BINARY
@ VX_EXPORT_TYPE_PARA_BINARY
the data is defined by struct svxPARAData
Definition: zwapi_file_data.h:679
VX_EXPORT_TYPE_IGES
@ VX_EXPORT_TYPE_IGES
the data is defined by struct svxIGESData
Definition: zwapi_file_data.h:675
VX_EXPORT_TYPE_IMG
@ VX_EXPORT_TYPE_IMG
the data is defined by struct svxImgData
Definition: zwapi_file_data.h:671
VX_EXPORT_TYPE_GRP
@ VX_EXPORT_TYPE_GRP
the data is defined by struct svxGRPData
Definition: zwapi_file_data.h:673
VX_EXPORT_TYPE_PDF
@ VX_EXPORT_TYPE_PDF
the data is defined by struct svxPdfData
Definition: zwapi_file_data.h:672
VX_EXPORT_TYPE_STL
@ VX_EXPORT_TYPE_STL
the data is defined by struct svxSTLData
Definition: zwapi_file_data.h:683
VX_EXPORT_TYPE_STEP
@ VX_EXPORT_TYPE_STEP
the data is defined by struct svxSTEPData
Definition: zwapi_file_data.h:676
VX_EXPORT_TYPE_CAT5_PART
@ VX_EXPORT_TYPE_CAT5_PART
the data is defined by struct svxCAT5Data
Definition: zwapi_file_data.h:680
VX_EXPORT_TYPE_HTML
@ VX_EXPORT_TYPE_HTML
the data is defined by struct svxHTMLData
Definition: zwapi_file_data.h:682
VX_EXPORT_TYPE_JT
@ VX_EXPORT_TYPE_JT
the data is defined by struct svxJTData
Definition: zwapi_file_data.h:677
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExportExcludeColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxExportExcludeColor

enum evxExportExcludeColor

#include <zwapi_file_data.h>

exclude attribute(color) of *.dwg/*.dxf

Enumerator
VX_EXCLUDE_COLOR_GREEN | The color of the 1st row,1st column (R=0, G=255, B=0)
VX_EXCLUDE_COLOR_RED | The color of the 1st row,2nd column (R=255, G=0, B=0)
VX_EXCLUDE_COLOR_BROWN | The color of the 1st row,3rd column (R=160, G=96, B=0)
VX_EXCLUDE_COLOR_GOLDENROD | The color of the 2nd row,1st column (R=255, G=188, B=0)
VX_EXCLUDE_COLOR_MED_BLUE | The color of the 2nd row,2nd column (R=0, G=255, B=255)
VX_EXCLUDE_COLOR_DARK_MAGENTA | The color of the 2nd row,3rd column (R=255, G=0, B=255)
VX_EXCLUDE_COLOR_DARK_GREY | The color of the 3rd row,1st column (R=96, G=96, B=96)
VX_EXCLUDE_COLOR_DARK_BLUE | The color of the 3rd row,2nd column (R=0, G=0, B=255)
VX_EXCLUDE_COLOR_VIOLET | The color of the 3rd row,3rd column (R=140, G=140, B=235)
VX_EXCLUDE_COLOR_LIGHT_GREEN | The color of the 4th row,1st column (R=160, G=255, B=160)
VX_EXCLUDE_COLOR_LIGHT_BLUE | The color of the 4th row,2nd column (R=160, G=255, B=255)
VX_EXCLUDE_COLOR_ROSE | The color of the 4th row,3rd column (R=255, G=160, B=160)
VX_EXCLUDE_COLOR_LIGHT_MAGENTA | The color of the 5th row,1st column (R=255, G=160, B=255)
VX_EXCLUDE_COLOR_LIGHT_GREY | The color of the 5th row,2nd column (R=160, G=160, B=160)
VX_EXCLUDE_COLOR_WHITE | The color of the 5th row,3rd column (R=255, G=255, B=255)

Definition at line 247 of file zwapi_file_data.h.

248 {
249 VX_EXCLUDE_COLOR_GREEN = 0x1,
250 VX_EXCLUDE_COLOR_RED = 0x2,
251 VX_EXCLUDE_COLOR_BROWN = 0x4,
252 VX_EXCLUDE_COLOR_GOLDENROD = 0x8,
253 VX_EXCLUDE_COLOR_MED_BLUE = 0x10,
254 VX_EXCLUDE_COLOR_DARK_MAGENTA = 0x20,
255 VX_EXCLUDE_COLOR_DARK_GREY = 0x40,
256 VX_EXCLUDE_COLOR_DARK_BLUE = 0x80,
257 VX_EXCLUDE_COLOR_VIOLET = 0x100,
258 VX_EXCLUDE_COLOR_LIGHT_GREEN = 0x200,
259 VX_EXCLUDE_COLOR_LIGHT_BLUE = 0x400,
260 VX_EXCLUDE_COLOR_ROSE = 0x800,
261 VX_EXCLUDE_COLOR_LIGHT_MAGENTA = 0x1000,
262 VX_EXCLUDE_COLOR_LIGHT_GREY = 0x2000,
263 VX_EXCLUDE_COLOR_WHITE = 0x4000,
264 } evxExportExcludeColor;
evxExportExcludeColor
evxExportExcludeColor
exclude attribute(color) of *.dwg/*.dxf
Definition: zwapi_file_data.h:248
VX_EXCLUDE_COLOR_LIGHT_BLUE
@ VX_EXCLUDE_COLOR_LIGHT_BLUE
The color of the 4th row,2nd column (R=160, G=255, B=255)
Definition: zwapi_file_data.h:259
VX_EXCLUDE_COLOR_ROSE
@ VX_EXCLUDE_COLOR_ROSE
The color of the 4th row,3rd column (R=255, G=160, B=160)
Definition: zwapi_file_data.h:260
VX_EXCLUDE_COLOR_LIGHT_MAGENTA
@ VX_EXCLUDE_COLOR_LIGHT_MAGENTA
The color of the 5th row,1st column (R=255, G=160, B=255)
Definition: zwapi_file_data.h:261
VX_EXCLUDE_COLOR_GOLDENROD
@ VX_EXCLUDE_COLOR_GOLDENROD
The color of the 2nd row,1st column (R=255, G=188, B=0)
Definition: zwapi_file_data.h:252
VX_EXCLUDE_COLOR_LIGHT_GREEN
@ VX_EXCLUDE_COLOR_LIGHT_GREEN
The color of the 4th row,1st column (R=160, G=255, B=160)
Definition: zwapi_file_data.h:258
VX_EXCLUDE_COLOR_LIGHT_GREY
@ VX_EXCLUDE_COLOR_LIGHT_GREY
The color of the 5th row,2nd column (R=160, G=160, B=160)
Definition: zwapi_file_data.h:262
VX_EXCLUDE_COLOR_BROWN
@ VX_EXCLUDE_COLOR_BROWN
The color of the 1st row,3rd column (R=160, G=96, B=0)
Definition: zwapi_file_data.h:251
VX_EXCLUDE_COLOR_DARK_BLUE
@ VX_EXCLUDE_COLOR_DARK_BLUE
The color of the 3rd row,2nd column (R=0, G=0, B=255)
Definition: zwapi_file_data.h:256
VX_EXCLUDE_COLOR_VIOLET
@ VX_EXCLUDE_COLOR_VIOLET
The color of the 3rd row,3rd column (R=140, G=140, B=235)
Definition: zwapi_file_data.h:257
VX_EXCLUDE_COLOR_GREEN
@ VX_EXCLUDE_COLOR_GREEN
The color of the 1st row,1st column (R=0, G=255, B=0)
Definition: zwapi_file_data.h:249
VX_EXCLUDE_COLOR_WHITE
@ VX_EXCLUDE_COLOR_WHITE
The color of the 5th row,3rd column (R=255, G=255, B=255)
Definition: zwapi_file_data.h:263
VX_EXCLUDE_COLOR_DARK_MAGENTA
@ VX_EXCLUDE_COLOR_DARK_MAGENTA
The color of the 2nd row,3rd column (R=255, G=0, B=255)
Definition: zwapi_file_data.h:254
VX_EXCLUDE_COLOR_MED_BLUE
@ VX_EXCLUDE_COLOR_MED_BLUE
The color of the 2nd row,2nd column (R=0, G=255, B=255)
Definition: zwapi_file_data.h:253
VX_EXCLUDE_COLOR_RED
@ VX_EXCLUDE_COLOR_RED
The color of the 1st row,2nd column (R=255, G=0, B=0)
Definition: zwapi_file_data.h:250
VX_EXCLUDE_COLOR_DARK_GREY
@ VX_EXCLUDE_COLOR_DARK_GREY
The color of the 3rd row,1st column (R=96, G=96, B=96)
Definition: zwapi_file_data.h:255
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxImgColorMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxImgColorMode

enum evxImgColorMode

#include <zwapi_file_data.h>

export image color mode

Enumerator
VX_EXPORT_IMG_COLOR_MODE_24BITS | 24bits mode
VX_EXPORT_IMG_COLOR_MODE_8BITS | 8bits mode
VX_EXPORT_IMG_COLOR_MODE_COlORIZED | colorizeo mode
VX_EXPORT_IMG_COLOR_MODE_MONOCHROME | monochrome mode
VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE | grayscale mode

Definition at line 66 of file zwapi_file_data.h.

67 {
68 VX_EXPORT_IMG_COLOR_MODE_24BITS = 0,
69 VX_EXPORT_IMG_COLOR_MODE_8BITS = 1,
70 VX_EXPORT_IMG_COLOR_MODE_COlORIZED = 0,
71 VX_EXPORT_IMG_COLOR_MODE_MONOCHROME = 2,
72 VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE = 3
73 } evxImgColorMode;
evxImgColorMode
evxImgColorMode
export image color mode
Definition: zwapi_file_data.h:67
VX_EXPORT_IMG_COLOR_MODE_8BITS
@ VX_EXPORT_IMG_COLOR_MODE_8BITS
8bits mode
Definition: zwapi_file_data.h:69
VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE
@ VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE
grayscale mode
Definition: zwapi_file_data.h:72
VX_EXPORT_IMG_COLOR_MODE_COlORIZED
@ VX_EXPORT_IMG_COLOR_MODE_COlORIZED
colorizeo mode
Definition: zwapi_file_data.h:70
VX_EXPORT_IMG_COLOR_MODE_MONOCHROME
@ VX_EXPORT_IMG_COLOR_MODE_MONOCHROME
monochrome mode
Definition: zwapi_file_data.h:71
VX_EXPORT_IMG_COLOR_MODE_24BITS
@ VX_EXPORT_IMG_COLOR_MODE_24BITS
24bits mode
Definition: zwapi_file_data.h:68
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: _evxDocAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ _evxDocAction

enum _evxDocAction

#include <zwapi_file_data.h>

file action type

Enumerator
VX_DOC_CREATED | called after file created
VX_DOC_SAVING | called before file saving
VX_DOC_SAVED | called after file saved
VX_DOC_PRECHANGE | called before file change
VX_DOC_CHANGED | called after file changed
VX_DOC_PREOPEN | called before file open
VX_DOC_OPENED | called after file opened
VX_DOC_TITLEUPDATE | called before the window title updating after file changed

Definition at line 707 of file zwapi_file_data.h.

708 {
709 VX_DOC_CREATED = 0,
710 VX_DOC_SAVING,
711 VX_DOC_SAVED,
712 VX_DOC_PRECHANGE,
713 VX_DOC_CHANGED,
714 VX_DOC_PREOPEN,
715 VX_DOC_OPENED,
716 VX_DOC_TITLEUPDATE,
717 }evxDocAction;
VX_DOC_SAVED
@ VX_DOC_SAVED
called after file saved
Definition: zwapi_file_data.h:711
VX_DOC_CREATED
@ VX_DOC_CREATED
called after file created
Definition: zwapi_file_data.h:709
VX_DOC_CHANGED
@ VX_DOC_CHANGED
called after file changed
Definition: zwapi_file_data.h:713
VX_DOC_PREOPEN
@ VX_DOC_PREOPEN
called before file open
Definition: zwapi_file_data.h:714
VX_DOC_TITLEUPDATE
@ VX_DOC_TITLEUPDATE
called before the window title updating after file changed
Definition: zwapi_file_data.h:716
VX_DOC_PRECHANGE
@ VX_DOC_PRECHANGE
called before file change
Definition: zwapi_file_data.h:712
VX_DOC_OPENED
@ VX_DOC_OPENED
called after file opened
Definition: zwapi_file_data.h:715
VX_DOC_SAVING
@ VX_DOC_SAVING
called before file saving
Definition: zwapi_file_data.h:710
evxDocAction
enum _evxDocAction evxDocAction
file action type
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDWGDXFConvertMeshTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxDWGDXFConvertMeshTo

enum evxDWGDXFConvertMeshTo

#include <zwapi_file_data.h>

dwg dxf file import of convert polygon mesh to

Enumerator
VX_DWGDXF_MESHTO_STL_BLOCKS | convert all polygon meshes into STL Blocks
VX_DWGDXF_MESHTO_LINES | convert all polygon meshing into line segments interconnected at each vertex, similar to how the mesh was originally defined. This is the "light weight" option
VX_DWGDXF_MESHTO_PLANAR_FACES | convert all polygon meshing into line segments interconnected at each vertex but also connected with planar faces

Definition at line 442 of file zwapi_file_data.h.

443 {
444 VX_DWGDXF_MESHTO_STL_BLOCKS = 1,
445 VX_DWGDXF_MESHTO_LINES = 2,
447 VX_DWGDXF_MESHTO_PLANAR_FACES = 3,
449 }evxDWGDXFConvertMeshTo;
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
dwg dxf file import of convert polygon mesh to
Definition: zwapi_file_data.h:443
VX_DWGDXF_MESHTO_PLANAR_FACES
@ VX_DWGDXF_MESHTO_PLANAR_FACES
convert all polygon meshing into line segments interconnected at each vertex but also connected with ...
Definition: zwapi_file_data.h:447
VX_DWGDXF_MESHTO_LINES
@ VX_DWGDXF_MESHTO_LINES
convert all polygon meshing into line segments interconnected at each vertex, similar to how the mesh...
Definition: zwapi_file_data.h:445
VX_DWGDXF_MESHTO_STL_BLOCKS
@ VX_DWGDXF_MESHTO_STL_BLOCKS
convert all polygon meshes into STL Blocks
Definition: zwapi_file_data.h:444
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxPdfRangeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxPdfRangeMode

enum evxPdfRangeMode

#include <zwapi_file_data.h>

export pdf range mode

Enumerator
VX_EXPORT_PDF_RANGE_MODE_NORMAL | export are-display
VX_EXPORT_PDF_RANGE_MODE_EXTENTS | export are-extent
VX_EXPORT_PDF_RANGE_MODE_CUSTOM | export are-windows

Definition at line 124 of file zwapi_file_data.h.

125 {
126 VX_EXPORT_PDF_RANGE_MODE_NORMAL = 0,
127 VX_EXPORT_PDF_RANGE_MODE_EXTENTS,
128 VX_EXPORT_PDF_RANGE_MODE_CUSTOM
129 } evxPdfRangeMode;
evxPdfRangeMode
evxPdfRangeMode
export pdf range mode
Definition: zwapi_file_data.h:125
VX_EXPORT_PDF_RANGE_MODE_NORMAL
@ VX_EXPORT_PDF_RANGE_MODE_NORMAL
export are-display
Definition: zwapi_file_data.h:126
VX_EXPORT_PDF_RANGE_MODE_CUSTOM
@ VX_EXPORT_PDF_RANGE_MODE_CUSTOM
export are-windows
Definition: zwapi_file_data.h:128
VX_EXPORT_PDF_RANGE_MODE_EXTENTS
@ VX_EXPORT_PDF_RANGE_MODE_EXTENTS
export are-extent
Definition: zwapi_file_data.h:127
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxImgRangeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxImgRangeMode

enum evxImgRangeMode

#include <zwapi_file_data.h>

export image range mode

Enumerator
VX_EXPORT_IMG_RANGE_MODE_NORMAL | exports what is displayed currently in the geographic window
VX_EXPORT_IMG_RANGE_MODE_EXTENTS | use a max envelope box of all entities as the export extent to export a snap image with its size defined by Paper Size
VX_EXPORT_IMG_RANGE_MODE_CUSTOM | select a area to export through window-picking

Definition at line 89 of file zwapi_file_data.h.

90 {
91 VX_EXPORT_IMG_RANGE_MODE_NORMAL = 0,
92 VX_EXPORT_IMG_RANGE_MODE_EXTENTS,
93 VX_EXPORT_IMG_RANGE_MODE_CUSTOM
94 } evxImgRangeMode;
evxImgRangeMode
evxImgRangeMode
export image range mode
Definition: zwapi_file_data.h:90
VX_EXPORT_IMG_RANGE_MODE_EXTENTS
@ VX_EXPORT_IMG_RANGE_MODE_EXTENTS
use a max envelope box of all entities as the export extent to export a snap image with its size defi...
Definition: zwapi_file_data.h:92
VX_EXPORT_IMG_RANGE_MODE_CUSTOM
@ VX_EXPORT_IMG_RANGE_MODE_CUSTOM
select a area to export through window-picking
Definition: zwapi_file_data.h:93
VX_EXPORT_IMG_RANGE_MODE_NORMAL
@ VX_EXPORT_IMG_RANGE_MODE_NORMAL
exports what is displayed currently in the geographic window
Definition: zwapi_file_data.h:91
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFileSubtype

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxFileSubtype

enum evxFileSubtype

#include <zwapi_file_data.h>

file sub-type

Enumerator
VX_SUBTYPE_NONE | no subtype
VX_NORMAL_PART | subtype normal part for Z3PRT file
VX_ECAD_BOARD_PART | subtype ECAD part for Z3PRT file
VX_NORMAL_ASSEMBLY | subtype normal assembly for Z3ASM file
VX_ECAD_ASSEMBLY | subtype ECAD assembly for Z3ASM file
VX_ROUTING_ASSEMBLY | subtype routing assembly for Z3ASM file
VX_SMD_PART | subtype sheet metal part for Z3PRT file
VX_HARNESS_ASSEMBLY | subtype harness assembly for Z3ASM file
VX_HARNESS_PART | subtype harness part for Z3PRT file
VX_MASTERLAYOUT_PART | subtype master layout part for Z3PRT file

Definition at line 45 of file zwapi_file_data.h.

46 {
47 VX_SUBTYPE_NONE = 0,
48 VX_NORMAL_PART,
49 VX_ECAD_BOARD_PART,
50 VX_NORMAL_ASSEMBLY,
51 VX_ECAD_ASSEMBLY,
52 VX_ROUTING_ASSEMBLY,
53 VX_SMD_PART,
54 VX_HARNESS_ASSEMBLY,
55 VX_HARNESS_PART,
56 VX_MASTERLAYOUT_PART,
57 } evxFileSubtype;
evxFileSubtype
evxFileSubtype
file sub-type
Definition: zwapi_file_data.h:46
VX_MASTERLAYOUT_PART
@ VX_MASTERLAYOUT_PART
subtype master layout part for Z3PRT file
Definition: zwapi_file_data.h:56
VX_ECAD_BOARD_PART
@ VX_ECAD_BOARD_PART
subtype ECAD part for Z3PRT file
Definition: zwapi_file_data.h:49
VX_ROUTING_ASSEMBLY
@ VX_ROUTING_ASSEMBLY
subtype routing assembly for Z3ASM file
Definition: zwapi_file_data.h:52
VX_HARNESS_ASSEMBLY
@ VX_HARNESS_ASSEMBLY
subtype harness assembly for Z3ASM file
Definition: zwapi_file_data.h:54
VX_NORMAL_ASSEMBLY
@ VX_NORMAL_ASSEMBLY
subtype normal assembly for Z3ASM file
Definition: zwapi_file_data.h:50
VX_ECAD_ASSEMBLY
@ VX_ECAD_ASSEMBLY
subtype ECAD assembly for Z3ASM file
Definition: zwapi_file_data.h:51
VX_SMD_PART
@ VX_SMD_PART
subtype sheet metal part for Z3PRT file
Definition: zwapi_file_data.h:53
VX_HARNESS_PART
@ VX_HARNESS_PART
subtype harness part for Z3PRT file
Definition: zwapi_file_data.h:55
VX_NORMAL_PART
@ VX_NORMAL_PART
subtype normal part for Z3PRT file
Definition: zwapi_file_data.h:48
VX_SUBTYPE_NONE
@ VX_SUBTYPE_NONE
no subtype
Definition: zwapi_file_data.h:47
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDWGDXFExcludeColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxDWGDXFExcludeColor

enum evxDWGDXFExcludeColor

#include <zwapi_file_data.h>

import dwg dxf file, exclude color

Enumerator
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED | R=255, G=0, B=0.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN | R=0, G=255, B=0.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE | R=0, G=255, B=255.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW | R=255, G=188, B=0.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA | R=255, G=0, B=255.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN | R=160, G=255, B=255.
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE | R=255, G=255, B=255.

Definition at line 455 of file zwapi_file_data.h.

456 {
457 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED = 0x1,
458 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN = 0x2,
459 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE = 0x4,
460 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW = 0x8,
461 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA = 0x10,
462 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN = 0x20,
463 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE = 0x40,
464 } evxDWGDXFExcludeColor;
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
import dwg dxf file, exclude color
Definition: zwapi_file_data.h:456
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN
R=0, G=255, B=0.
Definition: zwapi_file_data.h:458
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN
R=160, G=255, B=255.
Definition: zwapi_file_data.h:462
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA
R=255, G=0, B=255.
Definition: zwapi_file_data.h:461
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE
R=255, G=255, B=255.
Definition: zwapi_file_data.h:463
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW
R=255, G=188, B=0.
Definition: zwapi_file_data.h:460
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED
R=255, G=0, B=0.
Definition: zwapi_file_data.h:457
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE
R=0, G=255, B=255.
Definition: zwapi_file_data.h:459
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExportExcludeWidthStyle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxExportExcludeWidthStyle

enum evxExportExcludeWidthStyle

#include <zwapi_file_data.h>

exclude attribute(no color) of *.dwg/*.dxf

Enumerator
VX_EXCLUDE_WIDTH_STYLE_1 | width-Light | style-Solid
VX_EXCLUDE_WIDTH_STYLE_2 | width-Thin | style-Dot
VX_EXCLUDE_WIDTH_STYLE_3 | width-Medium | style-Dash-Dot
VX_EXCLUDE_WIDTH_STYLE_4 | width-Thick | style-Long-Dash
VX_EXCLUDE_WIDTH_STYLE_5 | width-Heavy | style-Dash

Definition at line 234 of file zwapi_file_data.h.

235 {
236 VX_EXCLUDE_WIDTH_STYLE_1 = 0x1,
237 VX_EXCLUDE_WIDTH_STYLE_2 = 0x2,
238 VX_EXCLUDE_WIDTH_STYLE_3 = 0x4,
239 VX_EXCLUDE_WIDTH_STYLE_4 = 0x8,
240 VX_EXCLUDE_WIDTH_STYLE_5 = 0x10,
241 } evxExportExcludeWidthStyle;
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
exclude attribute(no color) of *.dwg/*.dxf
Definition: zwapi_file_data.h:235
VX_EXCLUDE_WIDTH_STYLE_5
@ VX_EXCLUDE_WIDTH_STYLE_5
width-Heavy | style-Dash
Definition: zwapi_file_data.h:240
VX_EXCLUDE_WIDTH_STYLE_2
@ VX_EXCLUDE_WIDTH_STYLE_2
width-Thin | style-Dot
Definition: zwapi_file_data.h:237
VX_EXCLUDE_WIDTH_STYLE_4
@ VX_EXCLUDE_WIDTH_STYLE_4
width-Thick | style-Long-Dash
Definition: zwapi_file_data.h:239
VX_EXCLUDE_WIDTH_STYLE_1
@ VX_EXCLUDE_WIDTH_STYLE_1
width-Light | style-Solid
Definition: zwapi_file_data.h:236
VX_EXCLUDE_WIDTH_STYLE_3
@ VX_EXCLUDE_WIDTH_STYLE_3
width-Medium | style-Dash-Dot
Definition: zwapi_file_data.h:238
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxJTVer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxJTVer

enum evxJTVer

#include <zwapi_file_data.h>

version of JT

Enumerator
VX_JT_VER_6_4 | version: 6.4
VX_JT_VER_7_0 | version: 7.0
VX_JT_VER_8_0 | version: 8.0
VX_JT_VER_8_1 | version: 8.1
VX_JT_VER_8_2 | version: 8.2
VX_JT_VER_8_3 | version: 8.3
VX_JT_VER_9_0 | version: 9.0
VX_JT_VER_9_1 | version: 9.1
VX_JT_VER_9_2 | version: 9.2
VX_JT_VER_9_3 | version: 9.3
VX_JT_VER_9_4 | version: 9.4
VX_JT_VER_9_5 | version: 9.5
VX_JT_VER_10_0 | version: 10.0
VX_JT_VER_10_1 | version: 10.1
VX_JT_VER_10_2 | version: 10.2
VX_JT_VER_10_3 | version: 10.3
VX_JT_VER_10_4 | version: 10.4

Definition at line 357 of file zwapi_file_data.h.

358 {
359 VX_JT_VER_6_4,
360 VX_JT_VER_7_0,
361 VX_JT_VER_8_0,
362 VX_JT_VER_8_1,
363 VX_JT_VER_8_2,
364 VX_JT_VER_8_3,
365 VX_JT_VER_9_0,
366 VX_JT_VER_9_1,
367 VX_JT_VER_9_2,
368 VX_JT_VER_9_3,
369 VX_JT_VER_9_4,
370 VX_JT_VER_9_5,
371 VX_JT_VER_10_0,
372 VX_JT_VER_10_1,
373 VX_JT_VER_10_2,
374 VX_JT_VER_10_3,
375 VX_JT_VER_10_4,
376 }evxJTVer;
evxJTVer
evxJTVer
version of JT
Definition: zwapi_file_data.h:358
VX_JT_VER_10_2
@ VX_JT_VER_10_2
version: 10.2
Definition: zwapi_file_data.h:373
VX_JT_VER_10_0
@ VX_JT_VER_10_0
version: 10.0
Definition: zwapi_file_data.h:371
VX_JT_VER_9_5
@ VX_JT_VER_9_5
version: 9.5
Definition: zwapi_file_data.h:370
VX_JT_VER_10_1
@ VX_JT_VER_10_1
version: 10.1
Definition: zwapi_file_data.h:372
VX_JT_VER_8_0
@ VX_JT_VER_8_0
version: 8.0
Definition: zwapi_file_data.h:361
VX_JT_VER_8_3
@ VX_JT_VER_8_3
version: 8.3
Definition: zwapi_file_data.h:364
VX_JT_VER_9_4
@ VX_JT_VER_9_4
version: 9.4
Definition: zwapi_file_data.h:369
VX_JT_VER_8_2
@ VX_JT_VER_8_2
version: 8.2
Definition: zwapi_file_data.h:363
VX_JT_VER_10_4
@ VX_JT_VER_10_4
version: 10.4
Definition: zwapi_file_data.h:375
VX_JT_VER_6_4
@ VX_JT_VER_6_4
version: 6.4
Definition: zwapi_file_data.h:359
VX_JT_VER_9_0
@ VX_JT_VER_9_0
version: 9.0
Definition: zwapi_file_data.h:365
VX_JT_VER_9_2
@ VX_JT_VER_9_2
version: 9.2
Definition: zwapi_file_data.h:367
VX_JT_VER_8_1
@ VX_JT_VER_8_1
version: 8.1
Definition: zwapi_file_data.h:362
VX_JT_VER_7_0
@ VX_JT_VER_7_0
version: 7.0
Definition: zwapi_file_data.h:360
VX_JT_VER_9_3
@ VX_JT_VER_9_3
version: 9.3
Definition: zwapi_file_data.h:368
VX_JT_VER_9_1
@ VX_JT_VER_9_1
version: 9.1
Definition: zwapi_file_data.h:366
VX_JT_VER_10_3
@ VX_JT_VER_10_3
version: 10.3
Definition: zwapi_file_data.h:374
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxExportExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Data
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ evxExportExcludeGeom

enum evxExportExcludeGeom

#include <zwapi_file_data.h>

export exclude geometry

Enumerator
VX_EXCLUDE_CURVE | exclude curve
VX_EXCLUDE_SURFACE | exclude surface
VX_EXCLUDE_SOLID | exclude solid
VX_EXCLUDE_PLANE | exclude plane
VX_EXCLUDE_HATCH | exclude hatch
VX_EXCLUDE_DIMEN | exclude dimen
VX_EXCLUDE_TEXT | exclude text
VX_EXCLUDE_BLANKED | exclude blanked

Definition at line 691 of file zwapi_file_data.h.

692 {
693 VX_EXCLUDE_CURVE = 0x1,
694 VX_EXCLUDE_SURFACE = 0x2,
695 VX_EXCLUDE_SOLID = 0x4,
696 VX_EXCLUDE_PLANE = 0x8,
697 VX_EXCLUDE_HATCH = 0x10,
698 VX_EXCLUDE_DIMEN = 0x20,
699 VX_EXCLUDE_TEXT = 0x40,
700 VX_EXCLUDE_BLANKED = 0x80,
701 } evxExportExcludeGeom;
evxExportExcludeGeom
evxExportExcludeGeom
export exclude geometry
Definition: zwapi_file_data.h:692
VX_EXCLUDE_DIMEN
@ VX_EXCLUDE_DIMEN
exclude dimen
Definition: zwapi_file_data.h:698
VX_EXCLUDE_TEXT
@ VX_EXCLUDE_TEXT
exclude text
Definition: zwapi_file_data.h:699
VX_EXCLUDE_PLANE
@ VX_EXCLUDE_PLANE
exclude plane
Definition: zwapi_file_data.h:696
VX_EXCLUDE_CURVE
@ VX_EXCLUDE_CURVE
exclude curve
Definition: zwapi_file_data.h:693
VX_EXCLUDE_HATCH
@ VX_EXCLUDE_HATCH
exclude hatch
Definition: zwapi_file_data.h:697
VX_EXCLUDE_SOLID
@ VX_EXCLUDE_SOLID
exclude solid
Definition: zwapi_file_data.h:695
VX_EXCLUDE_BLANKED
@ VX_EXCLUDE_BLANKED
exclude blanked
Definition: zwapi_file_data.h:700
VX_EXCLUDE_SURFACE
@ VX_EXCLUDE_SURFACE
exclude surface
Definition: zwapi_file_data.h:694
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: _evxAppAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ _evxAppAction

enum _evxAppAction

#include <zwapi_global_apply.h>

application action type

Enumerator
VX_APP_PRECLOSE | called before process quit
VX_APP_STARTED | called after process start

Definition at line 57 of file zwapi_global_apply.h.

58 {
59 VX_APP_PRECLOSE = 0,
60 VX_APP_STARTED
61 }evxAppAction;
VX_APP_PRECLOSE
@ VX_APP_PRECLOSE
called before process quit
Definition: zwapi_global_apply.h:59
VX_APP_STARTED
@ VX_APP_STARTED
called after process start
Definition: zwapi_global_apply.h:60
evxAppAction
enum _evxAppAction evxAppAction
application action type
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Global Apply
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ evxGlobal

enum evxGlobal

#include <zwapi_global_apply.h>

global settings

Enumerator
VX_TOLERANCE | proximity tolerance (double)
VX_AUTO_MERGE | 1=auto-merge shells before boolean (int)
VX_EXACT_MATCH | 1=exact label matching enabled; 0=disabled (int)
VX_LOCALCOORDIDX | Local coordinate.
VX_CONS_DELAY_SOLVE | 1-delay solve the constraint (int)
VX_DIM_ATTR | part dimension attribute (svxPartDimAttr)

Definition at line 40 of file zwapi_global_apply.h.

41 {
42 VX_TOLERANCE = 1,
43 VX_AUTO_MERGE = 2,
44 VX_EXACT_MATCH = 3,
45 VX_LOCALCOORDIDX = 4,
46 VX_CONS_DELAY_SOLVE = 5,
47 VX_DIM_ATTR = 6,
48 } evxGlobal;
evxGlobal
evxGlobal
global settings
Definition: zwapi_global_apply.h:41
VX_TOLERANCE
@ VX_TOLERANCE
proximity tolerance (double)
Definition: zwapi_global_apply.h:42
VX_CONS_DELAY_SOLVE
@ VX_CONS_DELAY_SOLVE
1-delay solve the constraint (int)
Definition: zwapi_global_apply.h:46
VX_AUTO_MERGE
@ VX_AUTO_MERGE
1=auto-merge shells before boolean (int)
Definition: zwapi_global_apply.h:43
VX_EXACT_MATCH
@ VX_EXACT_MATCH
1=exact label matching enabled; 0=disabled (int)
Definition: zwapi_global_apply.h:44
VX_DIM_ATTR
@ VX_DIM_ATTR
part dimension attribute (svxPartDimAttr)
Definition: zwapi_global_apply.h:47
VX_LOCALCOORDIDX
@ VX_LOCALCOORDIDX
Local coordinate.
Definition: zwapi_global_apply.h:45
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxInfoLayerFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Layer
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ evxInfoLayerFlag

enum evxInfoLayerFlag

#include <zwapi_layer.h>

layer mask information

Enumerator
VX_LAYER_INFOR_NAME | find layer name
VX_LAYER_INFOR_DESC | find layer description
VX_LAYER_INFOR_ID | find layer id
VX_LAYER_INFOR_VISIBLE | find layer visible
VX_LAYER_INFOR_FREEZE | find layer freeze
VX_LAYER_INFOR_DISABLE | find layer disable
VX_LAYER_INFOR_COLOR | find layer color
VX_LAYER_INFOR_LINETYPE | find layer linetype
VX_LAYER_INFOR_LINEWIDTH | find layer linewidth
VX_LAYER_INFOR_NUMOBJ | find layer numble object
VX_LAYER_INFOR_FLTR | find layer filter info
VX_LAYER_INFOR_ALL | find layer all info

Definition at line 30 of file zwapi_layer.h.

31 {
32 VX_LAYER_INFOR_NAME = 0x00000001,
33 VX_LAYER_INFOR_DESC = 0x00000002,
34 VX_LAYER_INFOR_ID = 0x00000004,
35 VX_LAYER_INFOR_VISIBLE = 0x00000008,
36 VX_LAYER_INFOR_FREEZE = 0x000000010,
37 VX_LAYER_INFOR_DISABLE = 0x00000020,
38 VX_LAYER_INFOR_COLOR = 0x00000040,
39 VX_LAYER_INFOR_LINETYPE = 0x00000080,
40 VX_LAYER_INFOR_LINEWIDTH = 0x0000100,
41 VX_LAYER_INFOR_NUMOBJ = 0x0000200,
42 VX_LAYER_INFOR_FLTR = 0x0000400,
43 VX_LAYER_INFOR_ALL = 0xFFFFFFFF,
44 }evxInfoLayerFlag;
evxInfoLayerFlag
evxInfoLayerFlag
layer mask information
Definition: zwapi_layer.h:31
VX_LAYER_INFOR_DESC
@ VX_LAYER_INFOR_DESC
find layer description
Definition: zwapi_layer.h:33
VX_LAYER_INFOR_DISABLE
@ VX_LAYER_INFOR_DISABLE
find layer disable
Definition: zwapi_layer.h:37
VX_LAYER_INFOR_LINETYPE
@ VX_LAYER_INFOR_LINETYPE
find layer linetype
Definition: zwapi_layer.h:39
VX_LAYER_INFOR_LINEWIDTH
@ VX_LAYER_INFOR_LINEWIDTH
find layer linewidth
Definition: zwapi_layer.h:40
VX_LAYER_INFOR_VISIBLE
@ VX_LAYER_INFOR_VISIBLE
find layer visible
Definition: zwapi_layer.h:35
VX_LAYER_INFOR_FREEZE
@ VX_LAYER_INFOR_FREEZE
find layer freeze
Definition: zwapi_layer.h:36
VX_LAYER_INFOR_NAME
@ VX_LAYER_INFOR_NAME
find layer name
Definition: zwapi_layer.h:32
VX_LAYER_INFOR_ALL
@ VX_LAYER_INFOR_ALL
find layer all info
Definition: zwapi_layer.h:43
VX_LAYER_INFOR_ID
@ VX_LAYER_INFOR_ID
find layer id
Definition: zwapi_layer.h:34
VX_LAYER_INFOR_NUMOBJ
@ VX_LAYER_INFOR_NUMOBJ
find layer numble object
Definition: zwapi_layer.h:41
VX_LAYER_INFOR_COLOR
@ VX_LAYER_INFOR_COLOR
find layer color
Definition: zwapi_layer.h:38
VX_LAYER_INFOR_FLTR
@ VX_LAYER_INFOR_FLTR
find layer filter info
Definition: zwapi_layer.h:42
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxEdgeLoopType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Data
evxEdgeLoopType
evxEdgeLoopType
evxFaceFindType
evxFaceFindType
evxFaceTrim
evxFaceTrim
svxEvalCurv
svxFaceFind

◆ evxEdgeLoopType

enum evxEdgeLoopType

#include <zwapi_math_data.h>

type of loop in which the edge is located

Enumerator
VX_EDGE_LOOP_INNER | inner loop edges
VX_EDGE_LOOP_OUTER | outer loop edges
VX_EDGE_LOOP_ALL | all edges
VX_EDGE_LOOP_SHARED | shared edges
VX_EDGE_LOOP_BOUNDARY | boundary edges

Definition at line 94 of file zwapi_math_data.h.

95 {
96 VX_EDGE_LOOP_INNER = 0,
97 VX_EDGE_LOOP_OUTER = 1,
98 VX_EDGE_LOOP_ALL = 2,
99 VX_EDGE_LOOP_SHARED = 3,
100 VX_EDGE_LOOP_BOUNDARY = 4
101 } evxEdgeLoopType;
evxEdgeLoopType
evxEdgeLoopType
type of loop in which the edge is located
Definition: zwapi_math_data.h:95
VX_EDGE_LOOP_OUTER
@ VX_EDGE_LOOP_OUTER
outer loop edges
Definition: zwapi_math_data.h:97
VX_EDGE_LOOP_ALL
@ VX_EDGE_LOOP_ALL
all edges
Definition: zwapi_math_data.h:98
VX_EDGE_LOOP_SHARED
@ VX_EDGE_LOOP_SHARED
shared edges
Definition: zwapi_math_data.h:99
VX_EDGE_LOOP_INNER
@ VX_EDGE_LOOP_INNER
inner loop edges
Definition: zwapi_math_data.h:96
VX_EDGE_LOOP_BOUNDARY
@ VX_EDGE_LOOP_BOUNDARY
boundary edges
Definition: zwapi_math_data.h:100
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFaceTrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Data
evxEdgeLoopType
evxEdgeLoopType
evxFaceFindType
evxFaceFindType
evxFaceTrim
evxFaceTrim
svxEvalCurv
svxFaceFind

◆ evxFaceTrim

enum evxFaceTrim

#include <zwapi_math_data.h>

face trim-curve option

Enumerator
VX_TRIM_NONE | ignore all trim boundaries
VX_TRIM_ALL | use all face trim boundaries
VX_TRIM_OUTER | use only the outer trim boundaries

Definition at line 32 of file zwapi_math_data.h.

33 {
34 VX_TRIM_NONE = 0,
35 VX_TRIM_ALL = 1,
36 VX_TRIM_OUTER = 2
37 } evxFaceTrim;
evxFaceTrim
evxFaceTrim
face trim-curve option
Definition: zwapi_math_data.h:33
VX_TRIM_NONE
@ VX_TRIM_NONE
ignore all trim boundaries
Definition: zwapi_math_data.h:34
VX_TRIM_OUTER
@ VX_TRIM_OUTER
use only the outer trim boundaries
Definition: zwapi_math_data.h:36
VX_TRIM_ALL
@ VX_TRIM_ALL
use all face trim boundaries
Definition: zwapi_math_data.h:35
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxFaceFindType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Math Data
evxEdgeLoopType
evxEdgeLoopType
evxFaceFindType
evxFaceFindType
evxFaceTrim
evxFaceTrim
svxEvalCurv
svxFaceFind

◆ evxFaceFindType

enum evxFaceFindType

#include <zwapi_math_data.h>

face search types

Enumerator
VX_FIND_BOSS | find the faces that have the geometric characteristics of a boss
VX_FIND_POCKET | find the faces that have the geometric characteristics of a pocket
VX_FIND_HOLE | find the faces that have the geometric characteristics of a hole
VX_FIND_FILLET | find the faces that have the geometric characteristics of a network of fillet chains
VX_FIND_CUSTOM | find the faces based on the stop conditions set (evxFindRule)
VX_FIND_FINDER | base on seed face, find the faces that conforms to the set rules (evxFindRule)

Definition at line 62 of file zwapi_math_data.h.

63 {
64 VX_FIND_BOSS,
65 VX_FIND_POCKET,
66 VX_FIND_HOLE,
67 VX_FIND_FILLET,
68 VX_FIND_CUSTOM,
69 VX_FIND_FINDER,
70 } evxFaceFindType;
evxFaceFindType
evxFaceFindType
face search types
Definition: zwapi_math_data.h:63
VX_FIND_FILLET
@ VX_FIND_FILLET
find the faces that have the geometric characteristics of a network of fillet chains
Definition: zwapi_math_data.h:67
VX_FIND_CUSTOM
@ VX_FIND_CUSTOM
find the faces based on the stop conditions set (evxFindRule)
Definition: zwapi_math_data.h:68
VX_FIND_HOLE
@ VX_FIND_HOLE
find the faces that have the geometric characteristics of a hole
Definition: zwapi_math_data.h:66
VX_FIND_BOSS
@ VX_FIND_BOSS
find the faces that have the geometric characteristics of a boss
Definition: zwapi_math_data.h:64
VX_FIND_FINDER
@ VX_FIND_FINDER
base on seed face, find the faces that conforms to the set rules (evxFindRule)
Definition: zwapi_math_data.h:69
VX_FIND_POCKET
@ VX_FIND_POCKET
find the faces that have the geometric characteristics of a pocket
Definition: zwapi_math_data.h:65
Generated at Sun Apr 23 2023 16:41:43 for the ZWAPIOPEN


ZWAPIOPEN: evxDialogType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Message
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ evxDialogType

enum evxDialogType

#include <zwapi_message.h>

dialog form type of user prompt

Enumerator
VX_DIALOG_SAVE_AS

dialog of saveas

Definition at line 30 of file zwapi_message.h.

31 {
32 VX_DIALOG_SAVE_AS = 1
33 } evxDialogType;
evxDialogType
evxDialogType
dialog form type of user prompt
Definition: zwapi_message.h:31
VX_DIALOG_SAVE_AS
@ VX_DIALOG_SAVE_AS
dialog of saveas
Definition: zwapi_message.h:32
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxPlaneType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxPlaneType

enum evxPlaneType

#include <zwapi_part_data.h>

type of plane

Definition at line 399 of file zwapi_part_data.h.

400 {
401 VX_PLANE_TYPE_XY = 1,
402 VX_PLANE_TYPE_YZ = 2,
403 VX_PLANE_TYPE_XZ = 3
404 } evxPlaneType;
evxPlaneType
evxPlaneType
type of plane
Definition: zwapi_part_data.h:400
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxPMIEntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxPMIEntType

enum evxPMIEntType

#include <zwapi_part_data.h>

PMI entity type.

Enumerator
VX_PMI_ALL | all type
VX_PMI_DIM | dimension
VX_PMI_NOTE | note
VX_PMI_DTMF | datum feature
VX_PMI_DTMT | datum target
VX_PMI_FCS | feature control symbol
VX_PMI_CLCM | center mark and centerline
VX_PMI_SYMSRF | symbol surface
VX_PMI_SYMWELD | symbol WELD
VX_PMI_TABLE | PMI table.
VX_PMI_SYMBLK | symbol block

Definition at line 342 of file zwapi_part_data.h.

343 {
344 VX_PMI_ALL = 0x0000,
345 VX_PMI_DIM = 0x0001,
346 VX_PMI_NOTE = 0x0002,
347 VX_PMI_DTMF = 0x0004,
348 VX_PMI_DTMT = 0x0008,
349 VX_PMI_FCS = 0x0010,
350 VX_PMI_CLCM = 0x0020,
351 VX_PMI_SYMSRF = 0x0040,
352 VX_PMI_SYMWELD = 0x0080,
353 VX_PMI_TABLE = 0x0100,
354 VX_PMI_SYMBLK = 0x0200
355 } evxPMIEntType;
evxPMIEntType
evxPMIEntType
PMI entity type.
Definition: zwapi_part_data.h:343
VX_PMI_FCS
@ VX_PMI_FCS
feature control symbol
Definition: zwapi_part_data.h:349
VX_PMI_DIM
@ VX_PMI_DIM
dimension
Definition: zwapi_part_data.h:345
VX_PMI_SYMWELD
@ VX_PMI_SYMWELD
symbol WELD
Definition: zwapi_part_data.h:352
VX_PMI_DTMF
@ VX_PMI_DTMF
datum feature
Definition: zwapi_part_data.h:347
VX_PMI_DTMT
@ VX_PMI_DTMT
datum target
Definition: zwapi_part_data.h:348
VX_PMI_NOTE
@ VX_PMI_NOTE
note
Definition: zwapi_part_data.h:346
VX_PMI_CLCM
@ VX_PMI_CLCM
center mark and centerline
Definition: zwapi_part_data.h:350
VX_PMI_SYMBLK
@ VX_PMI_SYMBLK
symbol block
Definition: zwapi_part_data.h:354
VX_PMI_TABLE
@ VX_PMI_TABLE
PMI table.
Definition: zwapi_part_data.h:353
VX_PMI_ALL
@ VX_PMI_ALL
all type
Definition: zwapi_part_data.h:344
VX_PMI_SYMSRF
@ VX_PMI_SYMSRF
symbol surface
Definition: zwapi_part_data.h:351
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxAtItemLockStatus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxAtItemLockStatus

enum evxAtItemLockStatus

#include <zwapi_part_data.h>

Locking state of attribute item.

Enumerator
VX_AT_ITEM_UNLOCKED | attribute item unlocked
VX_AT_ITEM_LOCKED | lock attribute item and value
VX_AT_ITEM_LIMITED | lock attribute item but not value

Definition at line 76 of file zwapi_part_data.h.

77 {
78 VX_AT_ITEM_UNLOCKED = 0,
79 VX_AT_ITEM_LOCKED,
80 VX_AT_ITEM_LIMITED,
81 } evxAtItemLockStatus;
evxAtItemLockStatus
evxAtItemLockStatus
Locking state of attribute item.
Definition: zwapi_part_data.h:77
VX_AT_ITEM_UNLOCKED
@ VX_AT_ITEM_UNLOCKED
attribute item unlocked
Definition: zwapi_part_data.h:78
VX_AT_ITEM_LIMITED
@ VX_AT_ITEM_LIMITED
lock attribute item but not value
Definition: zwapi_part_data.h:80
VX_AT_ITEM_LOCKED
@ VX_AT_ITEM_LOCKED
lock attribute item and value
Definition: zwapi_part_data.h:79
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxBlockType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxBlockType

enum evxBlockType

#include <zwapi_part_data.h>

3D Block Type

Enumerator
VX_BLOCK_UNDEFINED | undefined 3D block type
VX_BLOCK_FACETS | block of 3D triangular facets
VX_BLOCK_POINTS | block of 3D points (i.e. point cloud)

Definition at line 114 of file zwapi_part_data.h.

115 {
116 VX_BLOCK_UNDEFINED = 0,
117 VX_BLOCK_FACETS = 1,
118 VX_BLOCK_POINTS = 2
119 } evxBlockType;
evxBlockType
evxBlockType
3D Block Type
Definition: zwapi_part_data.h:115
VX_BLOCK_FACETS
@ VX_BLOCK_FACETS
block of 3D triangular facets
Definition: zwapi_part_data.h:117
VX_BLOCK_POINTS
@ VX_BLOCK_POINTS
block of 3D points (i.e. point cloud)
Definition: zwapi_part_data.h:118
VX_BLOCK_UNDEFINED
@ VX_BLOCK_UNDEFINED
undefined 3D block type
Definition: zwapi_part_data.h:116
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxCfgTblMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxCfgTblMethod

enum evxCfgTblMethod

#include <zwapi_part_data.h>

configuration item method

Enumerator
VX_CFGTBL_MEHTOD_FTR | feature
VX_CFGTBL_MEHTOD_FTRDIM | feature dimension
VX_CFGTBL_MEHTOD_FTRVDATA | feature vdata
VX_CFGTBL_MEHTOD_PROFDIM | profile dimension
VX_CFGTBL_MEHTOD_VAR | variable
VX_CFGTBL_MEHTOD_ATTR | attribute
VX_CFGTBL_MEHTOD_PARTCOLOR | part color
VX_CFGTBL_MEHTOD_THREAD | thread
VX_CFGTBL_MEHTOD_THREADDEP | thread depth
VX_CFGTBL_MEHTOD_COMPPARTCFG | part config of the component
VX_CFGTBL_MEHTOD_COMPSUPP | suppress of component
VX_CFGTBL_MEHTOD_COMPCOLOR | component color
VX_CFGTBL_MEHTOD_ALIGNSUPP | align suppress
VX_CFGTBL_MEHTOD_ALIGNVALUE | align value

Definition at line 320 of file zwapi_part_data.h.

321 {
322 VX_CFGTBL_MEHTOD_FTR,
323 VX_CFGTBL_MEHTOD_FTRDIM,
324 VX_CFGTBL_MEHTOD_FTRVDATA,
325 VX_CFGTBL_MEHTOD_PROFDIM,
326 VX_CFGTBL_MEHTOD_VAR,
327 VX_CFGTBL_MEHTOD_ATTR,
328 VX_CFGTBL_MEHTOD_PARTCOLOR,
329 VX_CFGTBL_MEHTOD_THREAD,
330 VX_CFGTBL_MEHTOD_THREADDEP,
331 VX_CFGTBL_MEHTOD_COMPPARTCFG,
332 VX_CFGTBL_MEHTOD_COMPSUPP,
333 VX_CFGTBL_MEHTOD_COMPCOLOR,
334 VX_CFGTBL_MEHTOD_ALIGNSUPP,
335 VX_CFGTBL_MEHTOD_ALIGNVALUE,
336 } evxCfgTblMethod;
evxCfgTblMethod
evxCfgTblMethod
configuration item method
Definition: zwapi_part_data.h:321
VX_CFGTBL_MEHTOD_THREADDEP
@ VX_CFGTBL_MEHTOD_THREADDEP
thread depth
Definition: zwapi_part_data.h:330
VX_CFGTBL_MEHTOD_COMPCOLOR
@ VX_CFGTBL_MEHTOD_COMPCOLOR
component color
Definition: zwapi_part_data.h:333
VX_CFGTBL_MEHTOD_PROFDIM
@ VX_CFGTBL_MEHTOD_PROFDIM
profile dimension
Definition: zwapi_part_data.h:325
VX_CFGTBL_MEHTOD_THREAD
@ VX_CFGTBL_MEHTOD_THREAD
thread
Definition: zwapi_part_data.h:329
VX_CFGTBL_MEHTOD_COMPSUPP
@ VX_CFGTBL_MEHTOD_COMPSUPP
suppress of component
Definition: zwapi_part_data.h:332
VX_CFGTBL_MEHTOD_FTRDIM
@ VX_CFGTBL_MEHTOD_FTRDIM
feature dimension
Definition: zwapi_part_data.h:323
VX_CFGTBL_MEHTOD_FTR
@ VX_CFGTBL_MEHTOD_FTR
feature
Definition: zwapi_part_data.h:322
VX_CFGTBL_MEHTOD_COMPPARTCFG
@ VX_CFGTBL_MEHTOD_COMPPARTCFG
part config of the component
Definition: zwapi_part_data.h:331
VX_CFGTBL_MEHTOD_FTRVDATA
@ VX_CFGTBL_MEHTOD_FTRVDATA
feature vdata
Definition: zwapi_part_data.h:324
VX_CFGTBL_MEHTOD_PARTCOLOR
@ VX_CFGTBL_MEHTOD_PARTCOLOR
part color
Definition: zwapi_part_data.h:328
VX_CFGTBL_MEHTOD_ATTR
@ VX_CFGTBL_MEHTOD_ATTR
attribute
Definition: zwapi_part_data.h:327
VX_CFGTBL_MEHTOD_ALIGNVALUE
@ VX_CFGTBL_MEHTOD_ALIGNVALUE
align value
Definition: zwapi_part_data.h:335
VX_CFGTBL_MEHTOD_VAR
@ VX_CFGTBL_MEHTOD_VAR
variable
Definition: zwapi_part_data.h:326
VX_CFGTBL_MEHTOD_ALIGNSUPP
@ VX_CFGTBL_MEHTOD_ALIGNSUPP
align suppress
Definition: zwapi_part_data.h:334
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxRefineFacetsTolType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxRefineFacetsTolType

enum evxRefineFacetsTolType

#include <zwapi_part_data.h>

tolerance type of refine facets

Enumerator
VX_FACETS_TOL_PIXEL | pixel
VX_FACETS_TOL_DISTANCE | distance
VX_FACETS_TOL_ANGLE | angle

Definition at line 125 of file zwapi_part_data.h.

126 {
127 VX_FACETS_TOL_PIXEL,
128 VX_FACETS_TOL_DISTANCE,
129 VX_FACETS_TOL_ANGLE,
130 } evxRefineFacetsTolType;
evxRefineFacetsTolType
evxRefineFacetsTolType
tolerance type of refine facets
Definition: zwapi_part_data.h:126
VX_FACETS_TOL_PIXEL
@ VX_FACETS_TOL_PIXEL
pixel
Definition: zwapi_part_data.h:127
VX_FACETS_TOL_ANGLE
@ VX_FACETS_TOL_ANGLE
angle
Definition: zwapi_part_data.h:129
VX_FACETS_TOL_DISTANCE
@ VX_FACETS_TOL_DISTANCE
distance
Definition: zwapi_part_data.h:128
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxCfgThreadCmd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxCfgThreadCmd

enum evxCfgThreadCmd

#include <zwapi_part_data.h>

Hole type.

Enumerator
VX_NO_CMD | null
VX_FTHOLEMAIN | Create holes.
VX_FTTWKHOLE | Change the parameters of a hole without a history regen whether or not the hole is a native ZW3D feature.
VX_FTASSEMHOLE | Create hole in assembly.
VX_FTHOLEASGN | puts a feature into the active part's history to identify a hole from selected geometry
VX_CDHOLEPLUG | Create new holes centered in existing holes.
VX_CDTHRDADD | Add multiple/single thread attribute to cylindrical face.

Definition at line 153 of file zwapi_part_data.h.

154 {
155 VX_NO_CMD = 0,
156 VX_FTHOLEMAIN = 1,
157 VX_FTTWKHOLE = 2,
158 VX_FTASSEMHOLE = 3,
159 VX_FTHOLEASGN = 4,
160 VX_CDHOLEPLUG = 5,
161 VX_CDTHRDADD = 6,
162 }evxCfgThreadCmd;
evxCfgThreadCmd
evxCfgThreadCmd
Hole type.
Definition: zwapi_part_data.h:154
VX_FTHOLEASGN
@ VX_FTHOLEASGN
puts a feature into the active part's history to identify a hole from selected geometry
Definition: zwapi_part_data.h:159
VX_CDHOLEPLUG
@ VX_CDHOLEPLUG
Create new holes centered in existing holes.
Definition: zwapi_part_data.h:160
VX_FTASSEMHOLE
@ VX_FTASSEMHOLE
Create hole in assembly.
Definition: zwapi_part_data.h:158
VX_FTHOLEMAIN
@ VX_FTHOLEMAIN
Create holes.
Definition: zwapi_part_data.h:156
VX_NO_CMD
@ VX_NO_CMD
null
Definition: zwapi_part_data.h:155
VX_FTTWKHOLE
@ VX_FTTWKHOLE
Change the parameters of a hole without a history regen whether or not the hole is a native ZW3D feat...
Definition: zwapi_part_data.h:157
VX_CDTHRDADD
@ VX_CDTHRDADD
Add multiple/single thread attribute to cylindrical face.
Definition: zwapi_part_data.h:161
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxSmdSurfaceType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxSmdSurfaceType

enum evxSmdSurfaceType

#include <zwapi_part_data.h>

Sheet Metal surface type.

Enumerator
VX_SMD_SURF_NONE | undefined
VX_SMD_SURF_OTHER | other type
VX_SMD_SURF_SIDE | side of sheet metal
VX_SMD_SURF_FLANGE_STAT | flange face on one side of stationary face
VX_SMD_SURF_FLANGE_STAT_PAIR | the flange face of the opposite side of the stationary face

Definition at line 364 of file zwapi_part_data.h.

365 {
366 VX_SMD_SURF_NONE,
367 VX_SMD_SURF_OTHER,
368 VX_SMD_SURF_SIDE,
369 VX_SMD_SURF_FLANGE_STAT,
370 VX_SMD_SURF_FLANGE_STAT_PAIR,
371 } evxSmdSurfaceType;
evxSmdSurfaceType
evxSmdSurfaceType
Sheet Metal surface type.
Definition: zwapi_part_data.h:365
VX_SMD_SURF_FLANGE_STAT
@ VX_SMD_SURF_FLANGE_STAT
flange face on one side of stationary face
Definition: zwapi_part_data.h:369
VX_SMD_SURF_FLANGE_STAT_PAIR
@ VX_SMD_SURF_FLANGE_STAT_PAIR
the flange face of the opposite side of the stationary face
Definition: zwapi_part_data.h:370
VX_SMD_SURF_SIDE
@ VX_SMD_SURF_SIDE
side of sheet metal
Definition: zwapi_part_data.h:368
VX_SMD_SURF_NONE
@ VX_SMD_SURF_NONE
undefined
Definition: zwapi_part_data.h:366
VX_SMD_SURF_OTHER
@ VX_SMD_SURF_OTHER
other type
Definition: zwapi_part_data.h:367
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxFtrRegenStatus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Part Data
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ evxFtrRegenStatus

enum evxFtrRegenStatus

#include <zwapi_part_data.h>

regen status of feature

Enumerator
VX_FTR_REGEN_DEFAULT | default value
VX_FTR_REGEN_LINK_LOST | weak association data loss.
VX_FTR_REGEN_PARTIAL_INP_LOST | some strong correlation input data is lost.
VX_FTR_REGEN_VAR_LOST | variable data loss.
VX_FTR_REGEN_ENT_LOST | weak association entity reference data is lost.
VX_FTR_REGEN_OVER_CONSTRAINT | over constrain(mainly the constraints in the sketch)
VX_FTR_REGEN_UNDER_CONSTRAINT | under constrain(mainly the constraints in the sketch)

Definition at line 32 of file zwapi_part_data.h.

33 {
34 VX_FTR_REGEN_DEFAULT,
35 VX_FTR_REGEN_LINK_LOST,
36 VX_FTR_REGEN_PARTIAL_INP_LOST,
37 VX_FTR_REGEN_VAR_LOST,
38 VX_FTR_REGEN_ENT_LOST,
39 VX_FTR_REGEN_OVER_CONSTRAINT,
40 VX_FTR_REGEN_UNDER_CONSTRAINT,
41 } evxFtrRegenStatus;
evxFtrRegenStatus
evxFtrRegenStatus
regen status of feature
Definition: zwapi_part_data.h:33
VX_FTR_REGEN_DEFAULT
@ VX_FTR_REGEN_DEFAULT
default value
Definition: zwapi_part_data.h:34
VX_FTR_REGEN_ENT_LOST
@ VX_FTR_REGEN_ENT_LOST
weak association entity reference data is lost.
Definition: zwapi_part_data.h:38
VX_FTR_REGEN_VAR_LOST
@ VX_FTR_REGEN_VAR_LOST
variable data loss.
Definition: zwapi_part_data.h:37
VX_FTR_REGEN_OVER_CONSTRAINT
@ VX_FTR_REGEN_OVER_CONSTRAINT
over constrain(mainly the constraints in the sketch)
Definition: zwapi_part_data.h:39
VX_FTR_REGEN_UNDER_CONSTRAINT
@ VX_FTR_REGEN_UNDER_CONSTRAINT
under constrain(mainly the constraints in the sketch)
Definition: zwapi_part_data.h:40
VX_FTR_REGEN_PARTIAL_INP_LOST
@ VX_FTR_REGEN_PARTIAL_INP_LOST
some strong correlation input data is lost.
Definition: zwapi_part_data.h:36
VX_FTR_REGEN_LINK_LOST
@ VX_FTR_REGEN_LINK_LOST
weak association data loss.
Definition: zwapi_part_data.h:35
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxPreviewMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ evxPreviewMode

enum evxPreviewMode

#include <zwapi_root.h>

root object preview mode

Enumerator
VX_PREVIEW_OFF | off
VX_PREVIEW_GEOM | geom
VX_PREVIEW_ATTRIB | attribute

Definition at line 49 of file zwapi_root.h.

50 {
51 VX_PREVIEW_OFF = 0,
52 VX_PREVIEW_GEOM = 1,
53 VX_PREVIEW_ATTRIB = 2
54 } evxPreviewMode;
evxPreviewMode
evxPreviewMode
root object preview mode
Definition: zwapi_root.h:50
VX_PREVIEW_ATTRIB
@ VX_PREVIEW_ATTRIB
attribute
Definition: zwapi_root.h:53
VX_PREVIEW_GEOM
@ VX_PREVIEW_GEOM
geom
Definition: zwapi_root.h:52
VX_PREVIEW_OFF
@ VX_PREVIEW_OFF
off
Definition: zwapi_root.h:51
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxRootType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File Root
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ evxRootType

enum evxRootType

#include <zwapi_root.h>

root object type

Enumerator
VX_ROOT_PART | part
VX_ROOT_PART_NEW | part
VX_ROOT_SHEET | sheet
VX_ROOT_DRAWING | drawing
VX_ROOT_SKETCH | sketch
VX_ROOT_EQUATION_SET | eqution set
VX_ROOT_CAM_PLAN | cam plan

Definition at line 30 of file zwapi_root.h.

31 {
32 VX_ROOT_NULL = 0,
33 VX_ROOT_PART = 89,
34 VX_ROOT_PART_NEW = -VX_ROOT_PART,
35 VX_ROOT_SHEET = 90,
36 VX_ROOT_DRAWING = 91,
37 VX_ROOT_SKETCH = 70,
38 VX_ROOT_EQUATION_SET = 121,
39 VX_ROOT_CAM_PLAN = 200
40 } evxRootType;
evxRootType
evxRootType
root object type
Definition: zwapi_root.h:31
VX_ROOT_PART_NEW
@ VX_ROOT_PART_NEW
part
Definition: zwapi_root.h:34
VX_ROOT_CAM_PLAN
@ VX_ROOT_CAM_PLAN
cam plan
Definition: zwapi_root.h:39
VX_ROOT_PART
@ VX_ROOT_PART
part
Definition: zwapi_root.h:33
VX_ROOT_SHEET
@ VX_ROOT_SHEET
sheet
Definition: zwapi_root.h:35
VX_ROOT_DRAWING
@ VX_ROOT_DRAWING
drawing
Definition: zwapi_root.h:36
VX_ROOT_SKETCH
@ VX_ROOT_SKETCH
sketch
Definition: zwapi_root.h:37
VX_ROOT_EQUATION_SET
@ VX_ROOT_EQUATION_SET
eqution set
Definition: zwapi_root.h:38
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxFormAddTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxFormAddTo

enum evxFormAddTo

#include <zwapi_ui_data.h>

form type that the "Form" add to

Enumerator
VX_FILE_BROWSER | add the form to file browser
VX_UI_MANAGER | ..add the form to UI manager

Definition at line 32 of file zwapi_ui_data.h.

33 {
34 VX_FILE_BROWSER,
35 VX_UI_MANAGER,
36 }evxFormAddTo;
evxFormAddTo
evxFormAddTo
form type that the "Form" add to
Definition: zwapi_ui_data.h:33
VX_FILE_BROWSER
@ VX_FILE_BROWSER
add the form to file browser
Definition: zwapi_ui_data.h:34
VX_UI_MANAGER
@ VX_UI_MANAGER
..add the form to UI manager
Definition: zwapi_ui_data.h:35
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTreeItemType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTreeItemType

enum evxTreeItemType

#include <zwapi_ui_data.h>

tree widget item types

Enumerator
VX_ITEM | item
VX_FINISHMARK | finish mark

Definition at line 485 of file zwapi_ui_data.h.

486 {
487 VX_ITEM = 0,
488 VX_FINISHMARK = 1
489 } evxTreeItemType;
evxTreeItemType
evxTreeItemType
tree widget item types
Definition: zwapi_ui_data.h:486
VX_ITEM
@ VX_ITEM
item
Definition: zwapi_ui_data.h:487
VX_FINISHMARK
@ VX_FINISHMARK
finish mark
Definition: zwapi_ui_data.h:488
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxDateType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxDateType

enum evxDateType

#include <zwapi_ui_data.h>

data type

Enumerator
VX_DATE_WITH_TIME | with time
VX_DATE_ONLY | only date

Definition at line 325 of file zwapi_ui_data.h.

326 {
327 VX_DATE_WITH_TIME,
328 VX_DATE_ONLY,
329 } evxDateType;
evxDateType
evxDateType
data type
Definition: zwapi_ui_data.h:326
VX_DATE_ONLY
@ VX_DATE_ONLY
only date
Definition: zwapi_ui_data.h:328
VX_DATE_WITH_TIME
@ VX_DATE_WITH_TIME
with time
Definition: zwapi_ui_data.h:327
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTreeEvent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTreeEvent

enum evxTreeEvent

#include <zwapi_ui_data.h>

tree widget event types

Enumerator
VX_LEFT_DOWN | left mouse click down
VX_LEFT_UP | left mouse click up
VX_MIDDLE_DOWN | middle mouse click up
VX_MIDDLE_UP | middle mouse click up
VX_RIGHT_DOWN | right mouse click down
VX_RIGHT_UP | right mouse click up
VX_BOX_SELECTION_DONE | box selection over
VX_LABEL_CHANGED | label name check
VX_EDITOR_CLOSED | item editor closed
VX_DBL_LEFT | left mouse double click
VX_DROP | drop after dragging
VX_KEY_PRESS | key
VX_HOVER | normal hover
VX_HOVER_TIMEOUT | item hovered timeout

Definition at line 495 of file zwapi_ui_data.h.

496 {
497 VX_EMPTY = 0,
498 VX_LEFT_DOWN,
499 VX_LEFT_UP,
500 VX_MIDDLE_DOWN,
501 VX_MIDDLE_UP,
502 VX_RIGHT_DOWN,
503 VX_RIGHT_UP,
504 VX_BOX_SELECTION_DONE,
505 VX_LABEL_CHANGED,
506 VX_EDITOR_CLOSED,
507 VX_DBL_LEFT,
508 VX_DROP,
509 VX_KEY_PRESS,
510 VX_HOVER,
511 VX_HOVER_TIMEOUT,
512 VX_ENTER,
513 VX_LEAVE
514 } evxTreeEvent;
evxTreeEvent
evxTreeEvent
tree widget event types
Definition: zwapi_ui_data.h:496
VX_MIDDLE_DOWN
@ VX_MIDDLE_DOWN
middle mouse click up
Definition: zwapi_ui_data.h:500
VX_LEFT_UP
@ VX_LEFT_UP
left mouse click up
Definition: zwapi_ui_data.h:499
VX_LEFT_DOWN
@ VX_LEFT_DOWN
left mouse click down
Definition: zwapi_ui_data.h:498
VX_RIGHT_UP
@ VX_RIGHT_UP
right mouse click up
Definition: zwapi_ui_data.h:503
VX_HOVER_TIMEOUT
@ VX_HOVER_TIMEOUT
item hovered timeout
Definition: zwapi_ui_data.h:511
VX_EDITOR_CLOSED
@ VX_EDITOR_CLOSED
item editor closed
Definition: zwapi_ui_data.h:506
VX_RIGHT_DOWN
@ VX_RIGHT_DOWN
right mouse click down
Definition: zwapi_ui_data.h:502
VX_KEY_PRESS
@ VX_KEY_PRESS
key
Definition: zwapi_ui_data.h:509
VX_BOX_SELECTION_DONE
@ VX_BOX_SELECTION_DONE
box selection over
Definition: zwapi_ui_data.h:504
VX_HOVER
@ VX_HOVER
normal hover
Definition: zwapi_ui_data.h:510
VX_DROP
@ VX_DROP
drop after dragging
Definition: zwapi_ui_data.h:508
VX_DBL_LEFT
@ VX_DBL_LEFT
left mouse double click
Definition: zwapi_ui_data.h:507
VX_MIDDLE_UP
@ VX_MIDDLE_UP
middle mouse click up
Definition: zwapi_ui_data.h:501
VX_LABEL_CHANGED
@ VX_LABEL_CHANGED
label name check
Definition: zwapi_ui_data.h:505
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTableEvent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTableEvent

enum evxTableEvent

#include <zwapi_ui_data.h>

table widget event types

Enumerator
VX_LEFT_CLICK | left button click (mouse)
VX_RIGHT_CLICK | right button click (mouse)
VX_LEFT_DOUBLE_CLICK | left button double click (mouse)
VX_KEY_UP_DOWN | key up and down (keyboard)
VX_HOT_KEY | hotkey
VX_SORT | sort event
VX_DATA_CHANGED | data changed event
VX_CELL_BUTTON_CLICKED | button in table cell clicked event
VX_CELL_CLOSE_EDITOR | table cell close editor event

Definition at line 274 of file zwapi_ui_data.h.

275 {
276 VX_LEFT_CLICK = 2,
277 VX_RIGHT_CLICK = 4,
278 VX_LEFT_DOUBLE_CLICK,
279 VX_KEY_UP_DOWN,
280 VX_HOT_KEY = 9,
281 VX_SORT = 15,
282 VX_DATA_CHANGED,
283 VX_CELL_BUTTON_CLICKED,
284 VX_MOUSE_MOVE = 21,
285 VX_CELL_CLOSE_EDITOR = 23,
286 } evxTableEvent;
evxTableEvent
evxTableEvent
table widget event types
Definition: zwapi_ui_data.h:275
VX_SORT
@ VX_SORT
sort event
Definition: zwapi_ui_data.h:281
VX_KEY_UP_DOWN
@ VX_KEY_UP_DOWN
key up and down (keyboard)
Definition: zwapi_ui_data.h:279
VX_LEFT_CLICK
@ VX_LEFT_CLICK
left button click (mouse)
Definition: zwapi_ui_data.h:276
VX_DATA_CHANGED
@ VX_DATA_CHANGED
data changed event
Definition: zwapi_ui_data.h:282
VX_CELL_BUTTON_CLICKED
@ VX_CELL_BUTTON_CLICKED
button in table cell clicked event
Definition: zwapi_ui_data.h:283
VX_CELL_CLOSE_EDITOR
@ VX_CELL_CLOSE_EDITOR
table cell close editor event
Definition: zwapi_ui_data.h:285
VX_HOT_KEY
@ VX_HOT_KEY
hotkey
Definition: zwapi_ui_data.h:280
VX_RIGHT_CLICK
@ VX_RIGHT_CLICK
right button click (mouse)
Definition: zwapi_ui_data.h:277
VX_LEFT_DOUBLE_CLICK
@ VX_LEFT_DOUBLE_CLICK
left button double click (mouse)
Definition: zwapi_ui_data.h:278
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTableCellType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTableCellType

enum evxTableCellType

#include <zwapi_ui_data.h>

table cell types

Enumerator
VX_TABLECELL_TYPE_TEXT | text
VX_TABLECELL_TYPE_COMBOBOX | combobox
VX_TABLECELL_TYPE_CHECKBOX | checkbox
VX_TABLECELL_TYPE_INDEX_COMBOBOX | index combobox
VX_TABLECELL_TYPE_INPUT_COMBOBOX | input combobox
VX_TABLECELL_TYPE_TEXT_BUTTON | text button
VX_TABLECELL_TYPE_DATE | date
VX_TABLECELL_TYPE_COLOR | color
VX_TABLECELL_TYPE_NUMBER | number

Definition at line 433 of file zwapi_ui_data.h.

434 {
435 VX_TABLECELL_TYPE_TEXT = 0,
436 VX_TABLECELL_TYPE_COMBOBOX = 1,
437 VX_TABLECELL_TYPE_CHECKBOX = 2,
438 VX_TABLECELL_TYPE_INDEX_COMBOBOX = 3,
439 VX_TABLECELL_TYPE_INPUT_COMBOBOX = 4,
440 VX_TABLECELL_TYPE_TEXT_BUTTON = 5,
441 VX_TABLECELL_TYPE_DATE = 6,
442 VX_TABLECELL_TYPE_COLOR = 7,
443 VX_TABLECELL_TYPE_NUMBER = 8,
444 } evxTableCellType;
evxTableCellType
evxTableCellType
table cell types
Definition: zwapi_ui_data.h:434
VX_TABLECELL_TYPE_INDEX_COMBOBOX
@ VX_TABLECELL_TYPE_INDEX_COMBOBOX
index combobox
Definition: zwapi_ui_data.h:438
VX_TABLECELL_TYPE_COLOR
@ VX_TABLECELL_TYPE_COLOR
color
Definition: zwapi_ui_data.h:442
VX_TABLECELL_TYPE_TEXT
@ VX_TABLECELL_TYPE_TEXT
text
Definition: zwapi_ui_data.h:435
VX_TABLECELL_TYPE_NUMBER
@ VX_TABLECELL_TYPE_NUMBER
number
Definition: zwapi_ui_data.h:443
VX_TABLECELL_TYPE_CHECKBOX
@ VX_TABLECELL_TYPE_CHECKBOX
checkbox
Definition: zwapi_ui_data.h:437
VX_TABLECELL_TYPE_COMBOBOX
@ VX_TABLECELL_TYPE_COMBOBOX
combobox
Definition: zwapi_ui_data.h:436
VX_TABLECELL_TYPE_DATE
@ VX_TABLECELL_TYPE_DATE
date
Definition: zwapi_ui_data.h:441
VX_TABLECELL_TYPE_TEXT_BUTTON
@ VX_TABLECELL_TYPE_TEXT_BUTTON
text button
Definition: zwapi_ui_data.h:440
VX_TABLECELL_TYPE_INPUT_COMBOBOX
@ VX_TABLECELL_TYPE_INPUT_COMBOBOX
input combobox
Definition: zwapi_ui_data.h:439
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTreeCheckState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTreeCheckState

enum evxTreeCheckState

#include <zwapi_ui_data.h>

check tree item state

Enumerator
VX_TREE_ITEM_UNCHECKED | The item not checked.
VX_TREE_ITEM_BLACK_CHECKED | The item checked.

Definition at line 588 of file zwapi_ui_data.h.

589 {
590 VX_TREE_ITEM_UNCHECKED,
591 VX_TREE_ITEM_BLACK_CHECKED = 4
592 } evxTreeCheckState;
evxTreeCheckState
evxTreeCheckState
check tree item state
Definition: zwapi_ui_data.h:589
VX_TREE_ITEM_UNCHECKED
@ VX_TREE_ITEM_UNCHECKED
The item not checked.
Definition: zwapi_ui_data.h:590
VX_TREE_ITEM_BLACK_CHECKED
@ VX_TREE_ITEM_BLACK_CHECKED
The item checked.
Definition: zwapi_ui_data.h:591
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxFormFldClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxFormFldClass

enum evxFormFldClass

#include <zwapi_ui_data.h>

gui form template field (i.e. widget) classes

Enumerator
VX_FORM_FLD_NULL | null
VX_FORM_FLD_NUM | numeric input
VX_FORM_FLD_SLIDER | bounded numeric input (slider bar)
VX_FORM_FLD_TXT_IN | text input
VX_FORM_FLD_TXT_OUT | text output
VX_FORM_FLD_TXT_BTN | text input with an extra button
VX_FORM_FLD_TXT_LBL | toggle+label+text
VX_FORM_FLD_DATA | data input for handling a template
VX_FORM_FLD_LIST | scrolling list
VX_FORM_FLD_OPT | exclusive/non-exclusive group of options
VX_FORM_FLD_BTNS | menu button group
VX_FORM_FLD_GROUP | widget grouping entity
VX_FORM_FLD_LABEL | label only
VX_FORM_FLD_SEPARATOR | separator
VX_FORM_FLD_COLOR | color widget
VX_FORM_FLD_TREE | tree widget
VX_FORM_FLD_COMBO | combo widget
VX_FORM_FLD_TAB | tab widget
VX_FORM_FLD_PROGRESS | progress control widget
VX_FORM_FLD_TABLE | table widget

Definition at line 75 of file zwapi_ui_data.h.

76 {
77 VX_FORM_FLD_NULL = -1,
78 VX_FORM_FLD_NUM = 0,
79 VX_FORM_FLD_SLIDER = 1,
80 VX_FORM_FLD_TXT_IN = 2,
81 VX_FORM_FLD_TXT_OUT = 3,
82 VX_FORM_FLD_TXT_BTN = 4,
83 VX_FORM_FLD_TXT_LBL = 5,
84 VX_FORM_FLD_DATA = 6,
85 VX_FORM_FLD_LIST = 7,
86 VX_FORM_FLD_OPT = 8,
87 VX_FORM_FLD_BTNS = 9,
88 VX_FORM_FLD_GROUP = 10,
89 VX_FORM_FLD_LABEL = 11,
90 VX_FORM_FLD_SEPARATOR = 12,
91 VX_FORM_FLD_COLOR = 13,
92 VX_FORM_FLD_TREE = 14,
93 VX_FORM_FLD_COMBO = 15,
94 VX_FORM_FLD_TAB = 16,
95 VX_FORM_FLD_PROGRESS = 17,
96 VX_FORM_FLD_TABLE = 18
97 } evxFormFldClass;
evxFormFldClass
evxFormFldClass
gui form template field (i.e. widget) classes
Definition: zwapi_ui_data.h:76
VX_FORM_FLD_PROGRESS
@ VX_FORM_FLD_PROGRESS
progress control widget
Definition: zwapi_ui_data.h:95
VX_FORM_FLD_SEPARATOR
@ VX_FORM_FLD_SEPARATOR
separator
Definition: zwapi_ui_data.h:90
VX_FORM_FLD_OPT
@ VX_FORM_FLD_OPT
exclusive/non-exclusive group of options
Definition: zwapi_ui_data.h:86
VX_FORM_FLD_COLOR
@ VX_FORM_FLD_COLOR
color widget
Definition: zwapi_ui_data.h:91
VX_FORM_FLD_SLIDER
@ VX_FORM_FLD_SLIDER
bounded numeric input (slider bar)
Definition: zwapi_ui_data.h:79
VX_FORM_FLD_GROUP
@ VX_FORM_FLD_GROUP
widget grouping entity
Definition: zwapi_ui_data.h:88
VX_FORM_FLD_TAB
@ VX_FORM_FLD_TAB
tab widget
Definition: zwapi_ui_data.h:94
VX_FORM_FLD_TXT_OUT
@ VX_FORM_FLD_TXT_OUT
text output
Definition: zwapi_ui_data.h:81
VX_FORM_FLD_TREE
@ VX_FORM_FLD_TREE
tree widget
Definition: zwapi_ui_data.h:92
VX_FORM_FLD_BTNS
@ VX_FORM_FLD_BTNS
menu button group
Definition: zwapi_ui_data.h:87
VX_FORM_FLD_LIST
@ VX_FORM_FLD_LIST
scrolling list
Definition: zwapi_ui_data.h:85
VX_FORM_FLD_NULL
@ VX_FORM_FLD_NULL
null
Definition: zwapi_ui_data.h:77
VX_FORM_FLD_DATA
@ VX_FORM_FLD_DATA
data input for handling a template
Definition: zwapi_ui_data.h:84
VX_FORM_FLD_TXT_BTN
@ VX_FORM_FLD_TXT_BTN
text input with an extra button
Definition: zwapi_ui_data.h:82
VX_FORM_FLD_TXT_IN
@ VX_FORM_FLD_TXT_IN
text input
Definition: zwapi_ui_data.h:80
VX_FORM_FLD_LABEL
@ VX_FORM_FLD_LABEL
label only
Definition: zwapi_ui_data.h:89
VX_FORM_FLD_TXT_LBL
@ VX_FORM_FLD_TXT_LBL
toggle+label+text
Definition: zwapi_ui_data.h:83
VX_FORM_FLD_NUM
@ VX_FORM_FLD_NUM
numeric input
Definition: zwapi_ui_data.h:78
VX_FORM_FLD_COMBO
@ VX_FORM_FLD_COMBO
combo widget
Definition: zwapi_ui_data.h:93
VX_FORM_FLD_TABLE
@ VX_FORM_FLD_TABLE
table widget
Definition: zwapi_ui_data.h:96
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxUiEvt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxUiEvt

enum evxUiEvt

#include <zwapi_ui_data.h>

UI event type.

Enumerator
VX_UIEVT_INVALID | invalid
VX_UIEVT_HELP | help
VX_UIEVT_CANCEL | cancel
VX_UIEVT_RESET | reset
VX_UIEVT_APPLY | apply
VX_UIEVT_OKAY | accept
VX_UIEVT_DEF | default
VX_UIEVT_LBTNCLK | left button click (mouse)
VX_UIEVT_LBTNUP | left button click up (mouse)
VX_UIEVT_MBTNCLK | middle button click (mouse)
VX_UIEVT_RBTNCLK | right button click (mouse)
VX_UIEVT_LBTNDCLK | left button double click (mouse)
VX_UIEVT_CHAR | key up and down (keyboard)
VX_UIEVT_FOCUSKILL | keyboard kill focus
VX_UIEVT_SCROLL | slider (scroll)
VX_UIEVT_HOTKEY | hotkey
VX_UIEVT_CMDONOFF | command with on/off suffix
VX_UIEVT_FOCUSSET | keyboard set focus
VX_UIEVT_STRING | string
VX_UIEVT_HOVER | Hover for tooltip.
VX_UIEVT_LBTNDOWN | left button down event
VX_UIEVT_SORT | update sequence
VX_UIEVT_DATACHANGE | data change
VX_UIEVT_PREVIEW | preview
VX_UIEVT_SELCHANGED | system event log change
VX_UIEVT_STATECHANGED | change state
VX_UIEVT_MOUSEMOVE | mouse move event
VX_UIEVT_DROP | drop event
VX_UIEVT_IGNORE | ignore event

Definition at line 164 of file zwapi_ui_data.h.

165 {
166 VX_UIEVT_INVALID = -6,
167 VX_UIEVT_HELP = -5,
168 VX_UIEVT_CANCEL = -3,
169 VX_UIEVT_RESET = -2,
170 VX_UIEVT_APPLY = -1,
171 VX_UIEVT_OKAY = 0,
172 VX_UIEVT_DEF = 1,
173 VX_UIEVT_LBTNCLK,
174 VX_UIEVT_LBTNUP = VX_UIEVT_LBTNCLK,
175 VX_UIEVT_MBTNCLK,
176 VX_UIEVT_RBTNCLK,
177 VX_UIEVT_LBTNDCLK,
178 VX_UIEVT_CHAR,
179 VX_UIEVT_FOCUSKILL,
180 VX_UIEVT_SCROLL,
181 VX_UIEVT_HOTKEY,
182 VX_UIEVT_CMDONOFF,
183 VX_UIEVT_FOCUSSET,
184 VX_UIEVT_STRING,
185 VX_UIEVT_HOVER,
186 VX_UIEVT_LBTNDOWN,
187 VX_UIEVT_SORT,
188 VX_UIEVT_DATACHANGE,
189 VX_UIEVT_PREVIEW,
190 VX_UIEVT_SELCHANGED = 19,
191 VX_UIEVT_STATECHANGED,
192 VX_UIEVT_MOUSEMOVE,
193 VX_UIEVT_DROP = 22,
194 VX_UIEVT_IGNORE,
195 } evxUiEvt;
evxUiEvt
evxUiEvt
UI event type.
Definition: zwapi_ui_data.h:165
VX_UIEVT_MOUSEMOVE
@ VX_UIEVT_MOUSEMOVE
mouse move event
Definition: zwapi_ui_data.h:192
VX_UIEVT_LBTNDOWN
@ VX_UIEVT_LBTNDOWN
left button down event
Definition: zwapi_ui_data.h:186
VX_UIEVT_IGNORE
@ VX_UIEVT_IGNORE
ignore event
Definition: zwapi_ui_data.h:194
VX_UIEVT_CMDONOFF
@ VX_UIEVT_CMDONOFF
command with on/off suffix
Definition: zwapi_ui_data.h:182
VX_UIEVT_RBTNCLK
@ VX_UIEVT_RBTNCLK
right button click (mouse)
Definition: zwapi_ui_data.h:176
VX_UIEVT_SCROLL
@ VX_UIEVT_SCROLL
slider (scroll)
Definition: zwapi_ui_data.h:180
VX_UIEVT_DATACHANGE
@ VX_UIEVT_DATACHANGE
data change
Definition: zwapi_ui_data.h:188
VX_UIEVT_SELCHANGED
@ VX_UIEVT_SELCHANGED
system event log change
Definition: zwapi_ui_data.h:190
VX_UIEVT_STATECHANGED
@ VX_UIEVT_STATECHANGED
change state
Definition: zwapi_ui_data.h:191
VX_UIEVT_LBTNCLK
@ VX_UIEVT_LBTNCLK
left button click (mouse)
Definition: zwapi_ui_data.h:173
VX_UIEVT_DROP
@ VX_UIEVT_DROP
drop event
Definition: zwapi_ui_data.h:193
VX_UIEVT_PREVIEW
@ VX_UIEVT_PREVIEW
preview
Definition: zwapi_ui_data.h:189
VX_UIEVT_HELP
@ VX_UIEVT_HELP
help
Definition: zwapi_ui_data.h:167
VX_UIEVT_HOTKEY
@ VX_UIEVT_HOTKEY
hotkey
Definition: zwapi_ui_data.h:181
VX_UIEVT_STRING
@ VX_UIEVT_STRING
string
Definition: zwapi_ui_data.h:184
VX_UIEVT_CANCEL
@ VX_UIEVT_CANCEL
cancel
Definition: zwapi_ui_data.h:168
VX_UIEVT_CHAR
@ VX_UIEVT_CHAR
key up and down (keyboard)
Definition: zwapi_ui_data.h:178
VX_UIEVT_INVALID
@ VX_UIEVT_INVALID
invalid
Definition: zwapi_ui_data.h:166
VX_UIEVT_FOCUSSET
@ VX_UIEVT_FOCUSSET
keyboard set focus
Definition: zwapi_ui_data.h:183
VX_UIEVT_SORT
@ VX_UIEVT_SORT
update sequence
Definition: zwapi_ui_data.h:187
VX_UIEVT_DEF
@ VX_UIEVT_DEF
default
Definition: zwapi_ui_data.h:172
VX_UIEVT_OKAY
@ VX_UIEVT_OKAY
accept
Definition: zwapi_ui_data.h:171
VX_UIEVT_LBTNDCLK
@ VX_UIEVT_LBTNDCLK
left button double click (mouse)
Definition: zwapi_ui_data.h:177
VX_UIEVT_APPLY
@ VX_UIEVT_APPLY
apply
Definition: zwapi_ui_data.h:170
VX_UIEVT_RESET
@ VX_UIEVT_RESET
reset
Definition: zwapi_ui_data.h:169
VX_UIEVT_MBTNCLK
@ VX_UIEVT_MBTNCLK
middle button click (mouse)
Definition: zwapi_ui_data.h:175
VX_UIEVT_HOVER
@ VX_UIEVT_HOVER
Hover for tooltip.
Definition: zwapi_ui_data.h:185
VX_UIEVT_LBTNUP
@ VX_UIEVT_LBTNUP
left button click up (mouse)
Definition: zwapi_ui_data.h:174
VX_UIEVT_FOCUSKILL
@ VX_UIEVT_FOCUSKILL
keyboard kill focus
Definition: zwapi_ui_data.h:179
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTreeItemFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTreeItemFlag

enum evxTreeItemFlag

#include <zwapi_ui_data.h>

tree item data

Enumerator
VX_TREE_NO_ITEM_FLAGS | The item does not have any properties set.
VX_TREE_IS_SELECTABLE | The item can be selected.
VX_TREE_IS_EDITABLE | The item can be edited.
VX_TREE_IS_DRAG_ENABLE | The item be dragged.
VX_TREE_IS_DROP_ENABLE | The item be used as a drop target.
VX_TREE_IS_CHECKABLE | The item can be checked or unchecked by the user.
VX_TREE_IS_ENABLE | The user can interact with the item.
VX_TREE_IS_TRISTATE | The item's state depends on the state of its children.
VX_TREE_ITEM_NEVER_HAS_CHILDREN | The item never has child items.
VX_TREE_ITEM_IS_USER_TRISTATE | The user can cycle through three separate states.
VX_TREE_ITEM_IS_GRAY | The item shown in gray.

Definition at line 453 of file zwapi_ui_data.h.

454 {
455 VX_TREE_NO_ITEM_FLAGS = 0x0000,
456 VX_TREE_IS_SELECTABLE = 0x0001,
457 VX_TREE_IS_EDITABLE = 0x0002,
458 VX_TREE_IS_DRAG_ENABLE = 0x0004,
459 VX_TREE_IS_DROP_ENABLE = 0x0008,
460 VX_TREE_IS_CHECKABLE = 0x0010,
461 VX_TREE_IS_ENABLE = 0x0020,
462 VX_TREE_IS_TRISTATE = 0x0040,
463 VX_TREE_ITEM_NEVER_HAS_CHILDREN = 0x0080,
464 VX_TREE_ITEM_IS_USER_TRISTATE = 0x0100,
465 VX_TREE_ITEM_IS_GRAY = 0x00010000,
466 } evxTreeItemFlag;
evxTreeItemFlag
evxTreeItemFlag
tree item data
Definition: zwapi_ui_data.h:454
VX_TREE_ITEM_IS_USER_TRISTATE
@ VX_TREE_ITEM_IS_USER_TRISTATE
The user can cycle through three separate states.
Definition: zwapi_ui_data.h:464
VX_TREE_IS_DRAG_ENABLE
@ VX_TREE_IS_DRAG_ENABLE
The item be dragged.
Definition: zwapi_ui_data.h:458
VX_TREE_IS_CHECKABLE
@ VX_TREE_IS_CHECKABLE
The item can be checked or unchecked by the user.
Definition: zwapi_ui_data.h:460
VX_TREE_NO_ITEM_FLAGS
@ VX_TREE_NO_ITEM_FLAGS
The item does not have any properties set.
Definition: zwapi_ui_data.h:455
VX_TREE_IS_ENABLE
@ VX_TREE_IS_ENABLE
The user can interact with the item.
Definition: zwapi_ui_data.h:461
VX_TREE_ITEM_NEVER_HAS_CHILDREN
@ VX_TREE_ITEM_NEVER_HAS_CHILDREN
The item never has child items.
Definition: zwapi_ui_data.h:463
VX_TREE_IS_TRISTATE
@ VX_TREE_IS_TRISTATE
The item's state depends on the state of its children.
Definition: zwapi_ui_data.h:462
VX_TREE_IS_EDITABLE
@ VX_TREE_IS_EDITABLE
The item can be edited.
Definition: zwapi_ui_data.h:457
VX_TREE_IS_SELECTABLE
@ VX_TREE_IS_SELECTABLE
The item can be selected.
Definition: zwapi_ui_data.h:456
VX_TREE_IS_DROP_ENABLE
@ VX_TREE_IS_DROP_ENABLE
The item be used as a drop target.
Definition: zwapi_ui_data.h:459
VX_TREE_ITEM_IS_GRAY
@ VX_TREE_ITEM_IS_GRAY
The item shown in gray.
Definition: zwapi_ui_data.h:465
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxCmdFldClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxCmdFldClass

enum evxCmdFldClass

#include <zwapi_ui_data.h>

command template field classes

Enumerator
VX_CMD_FLD_NULL | null
VX_CMD_FLD_TEXT | text string
VX_CMD_FLD_NUM | number
VX_CMD_FLD_DIST | distance
VX_CMD_FLD_ANGLE | angle
VX_CMD_FLD_POINT | point
VX_CMD_FLD_ENTITY | entity
VX_CMD_FLD_OPTION | option
VX_CMD_FLD_CONT | continue
VX_CMD_FLD_FORM | gui form
VX_CMD_FLD_WIN | pick window
VX_CMD_FLD_CMD | input via a sub-command
VX_CMD_FLD_PIN | pin entity pick
VX_CMD_FLD_OPTGROUP | option group
VX_CMD_FLD_NUMUNIT | number with unit
VX_CMD_FLD_CUSTOMINPUT | custom input
VX_CMD_FLD_PICK | pick control

Definition at line 103 of file zwapi_ui_data.h.

104 {
105 VX_CMD_FLD_NULL = 0,
106 VX_CMD_FLD_TEXT = 1,
107 VX_CMD_FLD_NUM = 2,
108 VX_CMD_FLD_DIST = 3,
109 VX_CMD_FLD_ANGLE = 4,
110 VX_CMD_FLD_POINT = 5,
111 VX_CMD_FLD_ENTITY = 6,
112 VX_CMD_FLD_OPTION = 7,
113 VX_CMD_FLD_CONT = 8,
114 VX_CMD_FLD_FORM = 9,
115 VX_CMD_FLD_WIN = 10,
116 VX_CMD_FLD_CMD = 11,
117 VX_CMD_FLD_PIN = 12,
118 VX_CMD_FLD_OPTGROUP = 13,
119 VX_CMD_FLD_NUMUNIT = 14,
120 VX_CMD_FLD_CUSTOMINPUT = 15,
121 VX_CMD_FLD_PICK = 16,
122 } evxCmdFldClass;
evxCmdFldClass
evxCmdFldClass
command template field classes
Definition: zwapi_ui_data.h:104
VX_CMD_FLD_DIST
@ VX_CMD_FLD_DIST
distance
Definition: zwapi_ui_data.h:108
VX_CMD_FLD_POINT
@ VX_CMD_FLD_POINT
point
Definition: zwapi_ui_data.h:110
VX_CMD_FLD_WIN
@ VX_CMD_FLD_WIN
pick window
Definition: zwapi_ui_data.h:115
VX_CMD_FLD_OPTION
@ VX_CMD_FLD_OPTION
option
Definition: zwapi_ui_data.h:112
VX_CMD_FLD_TEXT
@ VX_CMD_FLD_TEXT
text string
Definition: zwapi_ui_data.h:106
VX_CMD_FLD_PIN
@ VX_CMD_FLD_PIN
pin entity pick
Definition: zwapi_ui_data.h:117
VX_CMD_FLD_CUSTOMINPUT
@ VX_CMD_FLD_CUSTOMINPUT
custom input
Definition: zwapi_ui_data.h:120
VX_CMD_FLD_CMD
@ VX_CMD_FLD_CMD
input via a sub-command
Definition: zwapi_ui_data.h:116
VX_CMD_FLD_NUM
@ VX_CMD_FLD_NUM
number
Definition: zwapi_ui_data.h:107
VX_CMD_FLD_CONT
@ VX_CMD_FLD_CONT
continue
Definition: zwapi_ui_data.h:113
VX_CMD_FLD_NUMUNIT
@ VX_CMD_FLD_NUMUNIT
number with unit
Definition: zwapi_ui_data.h:119
VX_CMD_FLD_ANGLE
@ VX_CMD_FLD_ANGLE
angle
Definition: zwapi_ui_data.h:109
VX_CMD_FLD_NULL
@ VX_CMD_FLD_NULL
null
Definition: zwapi_ui_data.h:105
VX_CMD_FLD_FORM
@ VX_CMD_FLD_FORM
gui form
Definition: zwapi_ui_data.h:114
VX_CMD_FLD_OPTGROUP
@ VX_CMD_FLD_OPTGROUP
option group
Definition: zwapi_ui_data.h:118
VX_CMD_FLD_ENTITY
@ VX_CMD_FLD_ENTITY
entity
Definition: zwapi_ui_data.h:111
VX_CMD_FLD_PICK
@ VX_CMD_FLD_PICK
pick control
Definition: zwapi_ui_data.h:121
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTreeHitPos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTreeHitPos

enum evxTreeHitPos

#include <zwapi_ui_data.h>

tree widget element codes

Enumerator
VXTHP_BUTTON | hit on expand button associated with a node
VXTHP_ICON | Hit on node's icon.
VXTHP_LABEL | Hit on node's label name.
VXTHP_ITEM | V_ZDM_ICON|V_ZDM_LABEL.
VXTHP_SPACE | Hit on design tree space.
VXTHP_CHECKBOX | Hit on the checkbox.
VXTHP_APD_ICON1 | Hit on node's second icon.
VXTHP_APD_ICON2 | Hit on node's third icon.
VXTHP_HEADER | Hit on the header of the tree.

Definition at line 520 of file zwapi_ui_data.h.

521 {
522 VXTHP_BUTTON = 0x0001,
523 VXTHP_ICON = 0x0002,
524 VXTHP_LABEL = 0x0004,
525 VXTHP_ITEM = 0x0006,
526 VXTHP_SPACE = 0x0008,
527 VXTHP_CHECKBOX = 0x0010,
528 VXTHP_APD_ICON1 = 0x0020,
529 VXTHP_APD_ICON2 = 0x0040,
530 VXTHP_HEADER = 0x0080,
531 } evxTreeHitPos;
evxTreeHitPos
evxTreeHitPos
tree widget element codes
Definition: zwapi_ui_data.h:521
VXTHP_CHECKBOX
@ VXTHP_CHECKBOX
Hit on the checkbox.
Definition: zwapi_ui_data.h:527
VXTHP_SPACE
@ VXTHP_SPACE
Hit on design tree space.
Definition: zwapi_ui_data.h:526
VXTHP_LABEL
@ VXTHP_LABEL
Hit on node's label name.
Definition: zwapi_ui_data.h:524
VXTHP_APD_ICON1
@ VXTHP_APD_ICON1
Hit on node's second icon.
Definition: zwapi_ui_data.h:528
VXTHP_ICON
@ VXTHP_ICON
Hit on node's icon.
Definition: zwapi_ui_data.h:523
VXTHP_ITEM
@ VXTHP_ITEM
V_ZDM_ICON|V_ZDM_LABEL.
Definition: zwapi_ui_data.h:525
VXTHP_BUTTON
@ VXTHP_BUTTON
hit on expand button associated with a node
Definition: zwapi_ui_data.h:522
VXTHP_HEADER
@ VXTHP_HEADER
Hit on the header of the tree.
Definition: zwapi_ui_data.h:530
VXTHP_APD_ICON2
@ VXTHP_APD_ICON2
Hit on node's third icon.
Definition: zwapi_ui_data.h:529
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxFormAction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxFormAction

enum evxFormAction

#include <zwapi_ui_data.h>

gui form action (see cvxFormFunc())

Enumerator
VX_FORM_INIT | initialize form
VX_FORM_CANCEL | take down the form
VX_FORM_RESET | reset form values
VX_FORM_APPLY | apply form values and leave form up
VX_FORM_OKAY | accept form values and take form down
VX_FORM_DEFAULT | default form values

Definition at line 45 of file zwapi_ui_data.h.

46 {
47 VX_FORM_INIT = -4,
48 VX_FORM_CANCEL = -3,
49 VX_FORM_RESET = -2,
50 VX_FORM_APPLY = -1,
51 VX_FORM_OKAY = 0,
52 VX_FORM_DEFAULT = 1
53 } evxFormAction;
evxFormAction
evxFormAction
gui form action (see cvxFormFunc())
Definition: zwapi_ui_data.h:46
VX_FORM_CANCEL
@ VX_FORM_CANCEL
take down the form
Definition: zwapi_ui_data.h:48
VX_FORM_DEFAULT
@ VX_FORM_DEFAULT
default form values
Definition: zwapi_ui_data.h:52
VX_FORM_APPLY
@ VX_FORM_APPLY
apply form values and leave form up
Definition: zwapi_ui_data.h:50
VX_FORM_INIT
@ VX_FORM_INIT
initialize form
Definition: zwapi_ui_data.h:47
VX_FORM_RESET
@ VX_FORM_RESET
reset form values
Definition: zwapi_ui_data.h:49
VX_FORM_OKAY
@ VX_FORM_OKAY
accept form values and take form down
Definition: zwapi_ui_data.h:51
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTableAlignFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTableAlignFlag

enum evxTableAlignFlag

#include <zwapi_ui_data.h>

table widget alignment mode

Enumerator
VX_TABLE_ALIGN_CENTER | align center
VX_TABLE_ALIGN_LEFT | align left
VX_TABLE_ALIGN_RIGHT | align right

Definition at line 292 of file zwapi_ui_data.h.

293 {
294 VX_TABLE_ALIGN_CENTER = 0,
295 VX_TABLE_ALIGN_LEFT = 1,
296 VX_TABLE_ALIGN_RIGHT = 2,
297 } evxTableAlignFlag;
evxTableAlignFlag
evxTableAlignFlag
table widget alignment mode
Definition: zwapi_ui_data.h:293
VX_TABLE_ALIGN_LEFT
@ VX_TABLE_ALIGN_LEFT
align left
Definition: zwapi_ui_data.h:295
VX_TABLE_ALIGN_RIGHT
@ VX_TABLE_ALIGN_RIGHT
align right
Definition: zwapi_ui_data.h:296
VX_TABLE_ALIGN_CENTER
@ VX_TABLE_ALIGN_CENTER
align center
Definition: zwapi_ui_data.h:294
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxTableResizeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxTableResizeMode

enum evxTableResizeMode

#include <zwapi_ui_data.h>

table widget resize mode

Enumerator
VX_TABLE_RESIZE_MODE_INTERACTIVE | QHeaderView::Interactive.
VX_TABLE_RESIZE_MODE_STRETCH | QHeaderView::Stretch.
VX_TABLE_RESIZE_MODE_FIXED | QHeaderView::Fixed.
VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS | QHeaderView::ResizeToContents.

Definition at line 303 of file zwapi_ui_data.h.

304 {
305 VX_TABLE_RESIZE_MODE_INTERACTIVE = 0,
306 VX_TABLE_RESIZE_MODE_STRETCH = 1,
307 VX_TABLE_RESIZE_MODE_FIXED = 2,
308 VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS = 3,
309 } evxTableResizeMode;
evxTableResizeMode
evxTableResizeMode
table widget resize mode
Definition: zwapi_ui_data.h:304
VX_TABLE_RESIZE_MODE_FIXED
@ VX_TABLE_RESIZE_MODE_FIXED
QHeaderView::Fixed.
Definition: zwapi_ui_data.h:307
VX_TABLE_RESIZE_MODE_STRETCH
@ VX_TABLE_RESIZE_MODE_STRETCH
QHeaderView::Stretch.
Definition: zwapi_ui_data.h:306
VX_TABLE_RESIZE_MODE_INTERACTIVE
@ VX_TABLE_RESIZE_MODE_INTERACTIVE
QHeaderView::Interactive.
Definition: zwapi_ui_data.h:305
VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS
@ VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS
QHeaderView::ResizeToContents.
Definition: zwapi_ui_data.h:308
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxAlignFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxAlignFlag

enum evxAlignFlag

#include <zwapi_ui_data.h>

ui alignment types

Enumerator
VX_ALIGN_CENTER | center align
VX_ALIGN_LEFT | left align
VX_ALIGN_RIGHT | right align

Definition at line 419 of file zwapi_ui_data.h.

420 {
421 VX_ALIGN_CENTER = 0,
422 VX_ALIGN_LEFT = 1,
423 VX_ALIGN_RIGHT = 2,
424 } evxAlignFlag;
evxAlignFlag
evxAlignFlag
ui alignment types
Definition: zwapi_ui_data.h:420
VX_ALIGN_RIGHT
@ VX_ALIGN_RIGHT
right align
Definition: zwapi_ui_data.h:423
VX_ALIGN_LEFT
@ VX_ALIGN_LEFT
left align
Definition: zwapi_ui_data.h:422
VX_ALIGN_CENTER
@ VX_ALIGN_CENTER
center align
Definition: zwapi_ui_data.h:421
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxCursorType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • UI Data
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ evxCursorType

enum evxCursorType

#include <zwapi_ui_data.h>

cursor display type

Enumerator
VX_CURSOR_STD | standard arrow cursor
VX_CURSOR_MOUSE | mouse shaped cursor
VX_CURSOR_BUSY | cursor used to indicate system is busy
VX_CURSOR_WRENCH | wrench shaped cursor
VX_CURSOR_PLIERS | cursor shaped like pliers
VX_CURSOR_SCREW_DRIVER | screw driver shaped cursor
VX_CURSOR_HAMMER | cursor shaped like a hammer
VX_CURSOR_TOGGLE | cursor with two semi-circular arrows
VX_CURSOR_HAND | cursor shaped like a hand
VX_CURSOR_WRENCH_PLUS | wrench shaped cursor with plus

Definition at line 143 of file zwapi_ui_data.h.

144 {
145 VX_CURSOR_STD = 0,
146 VX_CURSOR_MOUSE = 1,
147 VX_CURSOR_BUSY = 2,
148 VX_CURSOR_WRENCH = 3,
149 VX_CURSOR_PLIERS = 4,
150 VX_CURSOR_SCREW_DRIVER = 5,
151 VX_CURSOR_HAMMER = 6,
152 VX_CURSOR_TOGGLE = 7,
153 VX_CURSOR_HAND = 8,
154 VX_CURSOR_WRENCH_PLUS = 9
155 } evxCursorType;
evxCursorType
evxCursorType
cursor display type
Definition: zwapi_ui_data.h:144
VX_CURSOR_BUSY
@ VX_CURSOR_BUSY
cursor used to indicate system is busy
Definition: zwapi_ui_data.h:147
VX_CURSOR_STD
@ VX_CURSOR_STD
standard arrow cursor
Definition: zwapi_ui_data.h:145
VX_CURSOR_HAMMER
@ VX_CURSOR_HAMMER
cursor shaped like a hammer
Definition: zwapi_ui_data.h:151
VX_CURSOR_TOGGLE
@ VX_CURSOR_TOGGLE
cursor with two semi-circular arrows
Definition: zwapi_ui_data.h:152
VX_CURSOR_WRENCH_PLUS
@ VX_CURSOR_WRENCH_PLUS
wrench shaped cursor with plus
Definition: zwapi_ui_data.h:154
VX_CURSOR_PLIERS
@ VX_CURSOR_PLIERS
cursor shaped like pliers
Definition: zwapi_ui_data.h:149
VX_CURSOR_HAND
@ VX_CURSOR_HAND
cursor shaped like a hand
Definition: zwapi_ui_data.h:153
VX_CURSOR_SCREW_DRIVER
@ VX_CURSOR_SCREW_DRIVER
screw driver shaped cursor
Definition: zwapi_ui_data.h:150
VX_CURSOR_MOUSE
@ VX_CURSOR_MOUSE
mouse shaped cursor
Definition: zwapi_ui_data.h:146
VX_CURSOR_WRENCH
@ VX_CURSOR_WRENCH
wrench shaped cursor
Definition: zwapi_ui_data.h:148
Generated at Sun Apr 23 2023 16:41:44 for the ZWAPIOPEN


ZWAPIOPEN: evxPntInpOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ evxPntInpOpt

enum evxPntInpOpt

#include <zwapi_userinput.h>

point input options

Enumerator
VX_INP_PNT_GENERAL | general point
VX_INP_PNT_ON_ENTITY | point on entity
VX_INP_PNT_ON_CURVE | point on curve
VX_INP_PNT_ON_EDGE | point on edge
VX_INP_PNT_ON_CURVE_OR_EDGE | point on curve or edge
VX_INP_PNT_ON_ANY_FACE | point on any face
VX_INP_PNT_ON_FIELD_1_FACE | point on fidle 1 face(specifial face)
VX_INP_PNT_END | point end
VX_INP_PNT_ASSEMBLY | point in assembly environment
VX_INP_PNT_DIRECTION | point direction
VX_INP_PNT_ON_CRV_OR_PROF | point on curve or profile
VX_INP_PNT_ASSEM_FACE | point on assembly face
VX_INP_PNT_ASSEM_EDGE | point on assembly edge
VX_INP_PNT_ASSEM_CURVE | point on assembly curve

Definition at line 76 of file zwapi_userinput.h.

77 {
78 VX_INP_PNT_GENERAL = 0,
79 VX_INP_PNT_ON_ENTITY = 1,
80 VX_INP_PNT_ON_CURVE = 2,
81 VX_INP_PNT_ON_EDGE = 3,
82 VX_INP_PNT_ON_CURVE_OR_EDGE = 4,
83 VX_INP_PNT_ON_ANY_FACE = 5,
84 VX_INP_PNT_ON_FIELD_1_FACE = 6,
85 VX_INP_PNT_END = 7,
86 VX_INP_PNT_ASSEMBLY = 8,
87 VX_INP_PNT_DIRECTION = 9,
88 VX_INP_PNT_ON_CRV_OR_PROF = 10,
89 VX_INP_PNT_ASSEM_FACE = 11,
90 VX_INP_PNT_ASSEM_EDGE = 12,
91 VX_INP_PNT_ASSEM_CURVE = 13
92 } evxPntInpOpt;
evxPntInpOpt
evxPntInpOpt
point input options
Definition: zwapi_userinput.h:77
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CRV_OR_PROF
@ VX_INP_PNT_ON_CRV_OR_PROF
point on curve or profile
Definition: zwapi_userinput.h:88
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_END
@ VX_INP_PNT_END
point end
Definition: zwapi_userinput.h:85
VX_INP_PNT_ON_FIELD_1_FACE
@ VX_INP_PNT_ON_FIELD_1_FACE
point on fidle 1 face(specifial face)
Definition: zwapi_userinput.h:84
VX_INP_PNT_ASSEM_FACE
@ VX_INP_PNT_ASSEM_FACE
point on assembly face
Definition: zwapi_userinput.h:89
VX_INP_PNT_ASSEMBLY
@ VX_INP_PNT_ASSEMBLY
point in assembly environment
Definition: zwapi_userinput.h:86
VX_INP_PNT_ASSEM_CURVE
@ VX_INP_PNT_ASSEM_CURVE
point on assembly curve
Definition: zwapi_userinput.h:91
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
VX_INP_PNT_ASSEM_EDGE
@ VX_INP_PNT_ASSEM_EDGE
point on assembly edge
Definition: zwapi_userinput.h:90
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: evxEntInpOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • User Input
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ evxEntInpOpt

enum evxEntInpOpt

#include <zwapi_userinput.h>

entity input options

Enumerator
VX_INP_UNDEFINED | undefined
VX_INP_GENERAL_3D | pick 3d general entity
VX_INP_GENERAL_2D | pick 2d general entity
VX_INP_SHAPE | pick shape
VX_INP_FACE | pick face
VX_INP_SHAPE_OR_FACE | pick shape or face
VX_INP_EDGE | pick edge
VX_INP_CURVE | pick curve
VX_INP_EDGE_OR_CURVE | pick edge or curve
VX_INP_CURVE_LIST | pick curve list
VX_INP_PARTING_CURVE | pick parting curve
VX_INP_POINT | pick point
VX_INP_FEATURE | pick feature
VX_INP_SKETCH | pick sketch
VX_INP_DATUM_PLANE | pick datum plane
VX_INP_REF_PLANE | pick reference plane
VX_INP_3D_BLOCK | pick 3d block
VX_INP_LIGHT | pick light
VX_INP_LAYER | pick layer
VX_INP_REF_GEOM | pick reference geometry
VX_INP_WIREFRAME | pick wireframe
VX_INP_MOVE | pick move
VX_INP_BLANK | pick blank
VX_INP_ERASE | pick erase
VX_INP_INQUIRE | pick inquire
VX_INP_3D_GEOM | pick 3d geometry
VX_INP_TEXT | pick text
VX_INP_PROF | pick profile
VX_INP_COMP | select the top-level component
VX_INP_ASM_SHAPE | pick shape in the assembly
VX_INP_FACE_ON_SHAPE | pick face on shape
VX_INP_SUB_COMP | pick sub-component in pick-path, instead of the top-level component
VX_INP_CSYS | pick CSYS
VX_INP_AXIS_3D | pick 3d axis
VX_INP_AXIS_2D | pick 2d axis

Definition at line 30 of file zwapi_userinput.h.

31 {
32 VX_INP_UNDEFINED = 0,
33 VX_INP_GENERAL_3D = 1,
34 VX_INP_GENERAL_2D = 2,
35 VX_INP_SHAPE = 3,
36 VX_INP_FACE = 4,
37 VX_INP_SHAPE_OR_FACE = 5,
38 VX_INP_EDGE = 6,
39 VX_INP_CURVE = 7,
40 VX_INP_EDGE_OR_CURVE = 8,
41 VX_INP_CURVE_LIST = 9,
42 VX_INP_PARTING_CURVE = 10,
43 VX_INP_POINT = 11,
44 VX_INP_FEATURE = 12,
45 VX_INP_SKETCH = 13,
46 VX_INP_DATUM_PLANE = 14,
47 VX_INP_REF_PLANE = 15,
48 VX_INP_3D_BLOCK = 16,
49 VX_INP_LIGHT = 17,
50 VX_INP_LAYER = 18,
51 VX_INP_REF_GEOM = 19,
52 VX_INP_WIREFRAME = 20,
53 VX_INP_MOVE = 21,
54 VX_INP_BLANK = 22,
55 VX_INP_ERASE = 23,
56 VX_INP_INQUIRE = 24,
57 VX_INP_3D_GEOM = 25,
58 VX_INP_TEXT = 26,
59 VX_INP_PROF = 27,
60 VX_INP_COMP = 28,
61 VX_INP_ASM_SHAPE = 29,
62 VX_INP_FACE_ON_SHAPE = 30,
63 VX_INP_SUB_COMP = 31,
64 VX_INP_CSYS = 32,
65 VX_INP_AXIS_3D = 33,
66 VX_INP_AXIS_2D = 34,
67 } evxEntInpOpt;
evxEntInpOpt
evxEntInpOpt
entity input options
Definition: zwapi_userinput.h:31
VX_INP_LAYER
@ VX_INP_LAYER
pick layer
Definition: zwapi_userinput.h:50
VX_INP_UNDEFINED
@ VX_INP_UNDEFINED
undefined
Definition: zwapi_userinput.h:32
VX_INP_SHAPE_OR_FACE
@ VX_INP_SHAPE_OR_FACE
pick shape or face
Definition: zwapi_userinput.h:37
VX_INP_AXIS_3D
@ VX_INP_AXIS_3D
pick 3d axis
Definition: zwapi_userinput.h:65
VX_INP_3D_BLOCK
@ VX_INP_3D_BLOCK
pick 3d block
Definition: zwapi_userinput.h:48
VX_INP_SUB_COMP
@ VX_INP_SUB_COMP
pick sub-component in pick-path, instead of the top-level component
Definition: zwapi_userinput.h:63
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_TEXT
@ VX_INP_TEXT
pick text
Definition: zwapi_userinput.h:58
VX_INP_POINT
@ VX_INP_POINT
pick point
Definition: zwapi_userinput.h:43
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CURVE_LIST
@ VX_INP_CURVE_LIST
pick curve list
Definition: zwapi_userinput.h:41
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_CSYS
@ VX_INP_CSYS
pick CSYS
Definition: zwapi_userinput.h:64
VX_INP_INQUIRE
@ VX_INP_INQUIRE
pick inquire
Definition: zwapi_userinput.h:56
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_REF_GEOM
@ VX_INP_REF_GEOM
pick reference geometry
Definition: zwapi_userinput.h:51
VX_INP_COMP
@ VX_INP_COMP
select the top-level component
Definition: zwapi_userinput.h:60
VX_INP_WIREFRAME
@ VX_INP_WIREFRAME
pick wireframe
Definition: zwapi_userinput.h:52
VX_INP_MOVE
@ VX_INP_MOVE
pick move
Definition: zwapi_userinput.h:53
VX_INP_3D_GEOM
@ VX_INP_3D_GEOM
pick 3d geometry
Definition: zwapi_userinput.h:57
VX_INP_AXIS_2D
@ VX_INP_AXIS_2D
pick 2d axis
Definition: zwapi_userinput.h:66
VX_INP_FACE_ON_SHAPE
@ VX_INP_FACE_ON_SHAPE
pick face on shape
Definition: zwapi_userinput.h:62
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_ASM_SHAPE
@ VX_INP_ASM_SHAPE
pick shape in the assembly
Definition: zwapi_userinput.h:61
VX_INP_ERASE
@ VX_INP_ERASE
pick erase
Definition: zwapi_userinput.h:55
VX_INP_LIGHT
@ VX_INP_LIGHT
pick light
Definition: zwapi_userinput.h:49
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
VX_INP_FEATURE
@ VX_INP_FEATURE
pick feature
Definition: zwapi_userinput.h:44
VX_INP_BLANK
@ VX_INP_BLANK
pick blank
Definition: zwapi_userinput.h:54
VX_INP_PARTING_CURVE
@ VX_INP_PARTING_CURVE
pick parting curve
Definition: zwapi_userinput.h:42
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
Generated at Sun Apr 23 2023 16:41:46 for the ZWAPIOPEN


ZWAPIOPEN: evxCurveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxCurveType

enum evxCurveType

#include <zwapi_util.h>

curve types

Definition at line 1597 of file zwapi_util.h.

1598 {
1599 VX_CRV_UNDEFINED = 0,
1600 VX_CRV_LINE = 1,
1601 VX_CRV_ARC = 2,
1602 VX_CRV_CIRCLE = 3,
1603 VX_CRV_NURB = 4
1604 } evxCurveType;
evxCurveType
evxCurveType
curve types
Definition: zwapi_util.h:1598
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxAttributeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxAttributeType

enum evxAttributeType

#include <zwapi_util.h>

attribute data type

Enumerator
VX_ATTR_STRING | string
VX_ATTR_BOOL | bool
VX_ATTR_INT | integer
VX_ATTR_REAL | real number
VX_ATTR_DATE | date/time

Definition at line 1340 of file zwapi_util.h.

1341 {
1342 VX_ATTR_STRING = 0,
1343 VX_ATTR_BOOL = 1,
1344 VX_ATTR_INT = 2,
1345 VX_ATTR_REAL = 3,
1346 VX_ATTR_DATE = 4,
1347 } evxAttributeType;
evxAttributeType
evxAttributeType
attribute data type
Definition: zwapi_util.h:1341
VX_ATTR_INT
@ VX_ATTR_INT
integer
Definition: zwapi_util.h:1344
VX_ATTR_STRING
@ VX_ATTR_STRING
string
Definition: zwapi_util.h:1342
VX_ATTR_BOOL
@ VX_ATTR_BOOL
bool
Definition: zwapi_util.h:1343
VX_ATTR_DATE
@ VX_ATTR_DATE
date/time
Definition: zwapi_util.h:1346
VX_ATTR_REAL
@ VX_ATTR_REAL
real number
Definition: zwapi_util.h:1345
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEnvironment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxEnvironment

enum evxEnvironment

#include <zwapi_util.h>

zw3d environment

Enumerator
VX_ENV_Z3FILE | Z3File.
VX_ENV_SKETCH | sketch
VX_ENV_SHEET | sheet
VX_ENV_PACKET | packet
VX_ENV_CAM | cam
VX_ENV_ANIMATION | animation
VX_ENV_EXPLODEDVIEW | explodedView
VX_ENV_3DSKETCH | 3Dsketch
VX_ENV_PART | part
VX_ENV_ECAD_PART | ECAD part.
VX_ENV_ECAD_ASSEMBLY | ECAD assembly.
VX_ENV_ASSEMBLY | Assembly.
VX_ENV_PIPING | piping

Definition at line 2476 of file zwapi_util.h.

2477 {
2478 VX_ENV_Z3FILE = 2,
2479 VX_ENV_SKETCH,
2480 VX_ENV_SHEET,
2481 VX_ENV_PACKET,
2482 VX_ENV_CAM,
2483 VX_ENV_ANIMATION,
2484 VX_ENV_EXPLODEDVIEW,
2485 VX_ENV_3DSKETCH,
2486 VX_ENV_PART,
2487 VX_ENV_ECAD_PART,
2488 VX_ENV_ECAD_ASSEMBLY,
2489 VX_ENV_ASSEMBLY,
2490 VX_ENV_PIPING
2491 }evxEnvironment;
evxEnvironment
evxEnvironment
zw3d environment
Definition: zwapi_util.h:2477
VX_ENV_CAM
@ VX_ENV_CAM
cam
Definition: zwapi_util.h:2482
VX_ENV_ASSEMBLY
@ VX_ENV_ASSEMBLY
Assembly.
Definition: zwapi_util.h:2489
VX_ENV_SHEET
@ VX_ENV_SHEET
sheet
Definition: zwapi_util.h:2480
VX_ENV_EXPLODEDVIEW
@ VX_ENV_EXPLODEDVIEW
explodedView
Definition: zwapi_util.h:2484
VX_ENV_ANIMATION
@ VX_ENV_ANIMATION
animation
Definition: zwapi_util.h:2483
VX_ENV_3DSKETCH
@ VX_ENV_3DSKETCH
3Dsketch
Definition: zwapi_util.h:2485
VX_ENV_PIPING
@ VX_ENV_PIPING
piping
Definition: zwapi_util.h:2490
VX_ENV_PACKET
@ VX_ENV_PACKET
packet
Definition: zwapi_util.h:2481
VX_ENV_PART
@ VX_ENV_PART
part
Definition: zwapi_util.h:2486
VX_ENV_ECAD_ASSEMBLY
@ VX_ENV_ECAD_ASSEMBLY
ECAD assembly.
Definition: zwapi_util.h:2488
VX_ENV_Z3FILE
@ VX_ENV_Z3FILE
Z3File.
Definition: zwapi_util.h:2478
VX_ENV_ECAD_PART
@ VX_ENV_ECAD_PART
ECAD part.
Definition: zwapi_util.h:2487
VX_ENV_SKETCH
@ VX_ENV_SKETCH
sketch
Definition: zwapi_util.h:2479
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxFCSShapeSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxFCSShapeSym

enum evxFCSShapeSym

#include <zwapi_util.h>

FCS area shape symbol.

Enumerator
VX_SHP_NONE | none
VX_SHP_DIAMETER | diameter
VX_SHP_SPHERICAL_DIA | spherical diameter
VX_SHP_SQUARE | square

Definition at line 2128 of file zwapi_util.h.

2129 {
2130 VX_SHP_NONE = 0,
2131 VX_SHP_DIAMETER,
2132 VX_SHP_SPHERICAL_DIA,
2133 VX_SHP_SQUARE,
2134 } evxFCSShapeSym;
evxFCSShapeSym
evxFCSShapeSym
FCS area shape symbol.
Definition: zwapi_util.h:2129
VX_SHP_NONE
@ VX_SHP_NONE
none
Definition: zwapi_util.h:2130
VX_SHP_SPHERICAL_DIA
@ VX_SHP_SPHERICAL_DIA
spherical diameter
Definition: zwapi_util.h:2132
VX_SHP_DIAMETER
@ VX_SHP_DIAMETER
diameter
Definition: zwapi_util.h:2131
VX_SHP_SQUARE
@ VX_SHP_SQUARE
square
Definition: zwapi_util.h:2133
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxMassUnitType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxMassUnitType

enum evxMassUnitType

#include <zwapi_util.h>

system of mass units

Enumerator
VX_UNIT_GM | gram
VX_UNIT_KG | kilogram
VX_UNIT_OZ | ounce
VX_UNIT_LB | pound

Definition at line 399 of file zwapi_util.h.

400 {
401 VX_UNIT_GM = 11,
402 VX_UNIT_KG = 12,
403 VX_UNIT_OZ = 13,
404 VX_UNIT_LB = 14
405 } evxMassUnitType;
evxMassUnitType
evxMassUnitType
system of mass units
Definition: zwapi_util.h:400
VX_UNIT_OZ
@ VX_UNIT_OZ
ounce
Definition: zwapi_util.h:403
VX_UNIT_LB
@ VX_UNIT_LB
pound
Definition: zwapi_util.h:404
VX_UNIT_GM
@ VX_UNIT_GM
gram
Definition: zwapi_util.h:401
VX_UNIT_KG
@ VX_UNIT_KG
kilogram
Definition: zwapi_util.h:402
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxExtendOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxExtendOpt

enum evxExtendOpt

#include <zwapi_util.h>

curve/surface extension options

Enumerator
VX_EXTEND_UNDEFINED

linear extend is the default when extension is undefined

Definition at line 2299 of file zwapi_util.h.

2300 {
2301 VX_EXTEND_UNDEFINED = 0,
2302 VX_EXTEND_LINEAR = 1,
2303 VX_EXTEND_CIRCULAR = 2,
2304 VX_EXTEND_REFLECT = 3
2305 } evxExtendOpt;
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
VX_EXTEND_UNDEFINED
@ VX_EXTEND_UNDEFINED
linear extend is the default when extension is undefined
Definition: zwapi_util.h:2301
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxAngUnitType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxAngUnitType

enum evxAngUnitType

#include <zwapi_util.h>

system of angle units

Enumerator
VX_UNIT_DEG | degree
VX_UNIT_RAD | radian

Definition at line 1544 of file zwapi_util.h.

1545 {
1546 VX_UNIT_DEG = 8,
1547 VX_UNIT_RAD = 9
1548 } evxAngUnitType;
evxAngUnitType
evxAngUnitType
system of angle units
Definition: zwapi_util.h:1545
VX_UNIT_RAD
@ VX_UNIT_RAD
radian
Definition: zwapi_util.h:1547
VX_UNIT_DEG
@ VX_UNIT_DEG
degree
Definition: zwapi_util.h:1546
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxPlacingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxPlacingType

enum evxPlacingType

#include <zwapi_util.h>

placing adjustment type

Enumerator
VX_PLACING_NONE | none , 2d spline default value
VX_PLACING_VIEW | view , 3d spline default value
VX_PLACING_VECTOR | vector
VX_PLACING_WCS | WCS.
VX_PLACING_PLANE | PLANE.

Definition at line 2384 of file zwapi_util.h.

2385 {
2386 VX_PLACING_NONE = -1,
2387 VX_PLACING_VIEW = 0,
2388 VX_PLACING_VECTOR = 1,
2389 VX_PLACING_WCS = 2,
2390 VX_PLACING_PLANE = 3,
2391 }evxPlacingType;
evxPlacingType
evxPlacingType
placing adjustment type
Definition: zwapi_util.h:2385
VX_PLACING_WCS
@ VX_PLACING_WCS
WCS.
Definition: zwapi_util.h:2389
VX_PLACING_PLANE
@ VX_PLACING_PLANE
PLANE.
Definition: zwapi_util.h:2390
VX_PLACING_VECTOR
@ VX_PLACING_VECTOR
vector
Definition: zwapi_util.h:2388
VX_PLACING_VIEW
@ VX_PLACING_VIEW
view , 3d spline default value
Definition: zwapi_util.h:2387
VX_PLACING_NONE
@ VX_PLACING_NONE
none , 2d spline default value
Definition: zwapi_util.h:2386
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDirType

enum evxDirType

#include <zwapi_util.h>

type of direction

Enumerator
VX_START_DIR | start direction of curve, (if the input is face, get tangent direction of (u.min, v.min))
VX_END_DIR | end direction of curve, (if the input is face, get tangent direction of (u.max, v.max))
VX_PNT_DIR | tangent direction of point on face

Definition at line 578 of file zwapi_util.h.

579 {
580 VX_START_DIR,
581 VX_END_DIR,
582 VX_PNT_DIR,
583 } evxDirType;
evxDirType
evxDirType
type of direction
Definition: zwapi_util.h:579
VX_END_DIR
@ VX_END_DIR
end direction of curve, (if the input is face, get tangent direction of (u.max, v....
Definition: zwapi_util.h:581
VX_PNT_DIR
@ VX_PNT_DIR
tangent direction of point on face
Definition: zwapi_util.h:582
VX_START_DIR
@ VX_START_DIR
start direction of curve, (if the input is face, get tangent direction of (u.min, v....
Definition: zwapi_util.h:580
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDensityUnitType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDensityUnitType

enum evxDensityUnitType

#include <zwapi_util.h>

system of density units

Enumerator
VX_UNIT_DEN_KG_M3 | kg/m3
VX_UNIT_DEN_KG_MM3 | kg/mm3
VX_UNIT_DEN_G_MM3 | g/mm3
VX_UNIT_DEN_G_CM3 | g/cm3
VX_UNIT_DEN_LB_IN3 | lb/in3
VX_UNIT_DEN_LB_FT3 | lb/ft3
VX_UNIT_DEN_LB_YD3 | lb/yd3
VX_UNIT_DEN_OZ_IN3 | oz/in3
VX_UNIT_DEN_OZ_FT3 | oz/ft3
VX_UNIT_DEN_OZ_YD3 | oz/yd3
VX_UNIT_DEN_KG_DM3 | kg/dm3
VX_UNIT_DEN_G_DM3 | g/dm3

Definition at line 411 of file zwapi_util.h.

412 {
413 VX_UNIT_DEN_KG_M3 = 0,
414 VX_UNIT_DEN_KG_MM3 = 1,
415 VX_UNIT_DEN_G_MM3 = 2,
416 VX_UNIT_DEN_G_CM3 = 3,
417 VX_UNIT_DEN_LB_IN3 = 4,
418 VX_UNIT_DEN_LB_FT3 = 5,
419 VX_UNIT_DEN_LB_YD3 = 6,
420 VX_UNIT_DEN_OZ_IN3 = 7,
421 VX_UNIT_DEN_OZ_FT3 = 8,
422 VX_UNIT_DEN_OZ_YD3 = 9,
423 VX_UNIT_DEN_KG_DM3 = 10,
424 VX_UNIT_DEN_G_DM3 = 11,
425 } evxDensityUnitType;
evxDensityUnitType
evxDensityUnitType
system of density units
Definition: zwapi_util.h:412
VX_UNIT_DEN_G_CM3
@ VX_UNIT_DEN_G_CM3
g/cm3
Definition: zwapi_util.h:416
VX_UNIT_DEN_G_MM3
@ VX_UNIT_DEN_G_MM3
g/mm3
Definition: zwapi_util.h:415
VX_UNIT_DEN_KG_MM3
@ VX_UNIT_DEN_KG_MM3
kg/mm3
Definition: zwapi_util.h:414
VX_UNIT_DEN_OZ_YD3
@ VX_UNIT_DEN_OZ_YD3
oz/yd3
Definition: zwapi_util.h:422
VX_UNIT_DEN_OZ_FT3
@ VX_UNIT_DEN_OZ_FT3
oz/ft3
Definition: zwapi_util.h:421
VX_UNIT_DEN_LB_YD3
@ VX_UNIT_DEN_LB_YD3
lb/yd3
Definition: zwapi_util.h:419
VX_UNIT_DEN_OZ_IN3
@ VX_UNIT_DEN_OZ_IN3
oz/in3
Definition: zwapi_util.h:420
VX_UNIT_DEN_KG_DM3
@ VX_UNIT_DEN_KG_DM3
kg/dm3
Definition: zwapi_util.h:423
VX_UNIT_DEN_LB_IN3
@ VX_UNIT_DEN_LB_IN3
lb/in3
Definition: zwapi_util.h:417
VX_UNIT_DEN_LB_FT3
@ VX_UNIT_DEN_LB_FT3
lb/ft3
Definition: zwapi_util.h:418
VX_UNIT_DEN_KG_M3
@ VX_UNIT_DEN_KG_M3
kg/m3
Definition: zwapi_util.h:413
VX_UNIT_DEN_G_DM3
@ VX_UNIT_DEN_G_DM3
g/dm3
Definition: zwapi_util.h:424
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxVarType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxVarType

enum evxVarType

#include <zwapi_util.h>

variable types

Enumerator
VX_VAR_NUM | number
VX_VAR_STR | string
VX_VAR_PNT | point
VX_VAR_VEC | vector

Definition at line 1093 of file zwapi_util.h.

1094 {
1095 VX_VAR_NUM = 0,
1096 VX_VAR_STR = 1,
1097 VX_VAR_PNT = 2,
1098 VX_VAR_VEC = 3
1099 } evxVarType;
evxVarType
evxVarType
variable types
Definition: zwapi_util.h:1094
VX_VAR_NUM
@ VX_VAR_NUM
number
Definition: zwapi_util.h:1095
VX_VAR_PNT
@ VX_VAR_PNT
point
Definition: zwapi_util.h:1097
VX_VAR_STR
@ VX_VAR_STR
string
Definition: zwapi_util.h:1096
VX_VAR_VEC
@ VX_VAR_VEC
vector
Definition: zwapi_util.h:1098
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxAtItemId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxAtItemId

enum evxAtItemId

#include <zwapi_util.h>

standard id of attribute item

Enumerator
VX_AT_USER | user defined attributes
VX_AT_NAME | part name
VX_AT_NUMBER | part number
VX_AT_CLASS | CAM class.
VX_AT_DESIGNER | designer
VX_AT_COST | cost
VX_AT_SUPPLIER | supplier
VX_AT_DESCRIPT | description
VX_AT_KEYWORD | keyword
VX_AT_MANAGER | manager
VX_AT_MATERIAL | material
VX_AT_START | create time
VX_AT_END | last modified time
VX_AT_DERIVED | derived from
VX_AT_NO_SECTION | do not section
VX_AT_NO_HATCH | do not hatch
VX_AT_NO_BOM | do not list in BOM
VX_AT_NO_ROOTSHOW | do not list in root manager
VX_AT_DENSITY | density
VX_AT_FILEPATH | file path
VX_AT_SHEETPATH | corresponded drawing sheet: FILE NAME,SHEET ROOT NAME
VX_AT_CAMPATH | corresponded CAM object: FILE NAME,CAM ROOT NAME
VX_AT_SHEETCODE | sheet code
VX_AT_AREA | area
VX_AT_VOLUME | volume
VX_AT_MASS | mass property
VX_AT_LENGTH | length
VX_AT_WIDTH | width
VX_AT_HEIGHT | height
VX_AT_STOCK_SIZE | stock size
VX_AT_REVISION | revision
VX_AT_SHEET_SCALE | scale
VX_AT_SHEET_SEQUENCE | sequence
VX_AT_SHEET_AMOUNT | amount
VX_AT_SHEET_SIZE | size
VX_AT_SHEET_PROJECTION | projection
VX_AT_SHEET_FILEPATH | filepath

Definition at line 1291 of file zwapi_util.h.

1292 {
1293 /* The standard id of the part attribute item. */
1294 VX_AT_USER = 0,
1295 VX_AT_NAME = 1,
1296 VX_AT_NUMBER = 2,
1297 VX_AT_CLASS,
1298 VX_AT_DESIGNER,
1299 VX_AT_COST,
1300 VX_AT_SUPPLIER,
1301 VX_AT_DESCRIPT,
1302 VX_AT_KEYWORD,
1303 VX_AT_MANAGER,
1304 VX_AT_MATERIAL,
1305 VX_AT_START,
1306 VX_AT_END,
1307 VX_AT_DERIVED,
1308 VX_AT_NO_SECTION,
1309 VX_AT_NO_HATCH,
1310 VX_AT_NO_BOM,
1311 VX_AT_NO_ROOTSHOW,
1312 VX_AT_DENSITY = 18,
1313 VX_AT_FILEPATH = 20,
1314 VX_AT_SHEETPATH = 21,
1315 VX_AT_CAMPATH = 22,
1316 VX_AT_SHEETCODE = 23,
1318 VX_AT_AREA = 25,
1319 VX_AT_VOLUME = 26,
1320 VX_AT_MASS = 27,
1321 VX_AT_LENGTH = 28,
1322 VX_AT_WIDTH = 29,
1323 VX_AT_HEIGHT = 30,
1324 VX_AT_STOCK_SIZE = 43,
1325 VX_AT_REVISION = 47,
1327 /* The standard id of the sheet attribute item. */
1328 VX_AT_SHEET_SCALE = 200,
1329 VX_AT_SHEET_SEQUENCE = 201,
1330 VX_AT_SHEET_AMOUNT,
1331 VX_AT_SHEET_SIZE,
1332 VX_AT_SHEET_PROJECTION,
1333 VX_AT_SHEET_FILEPATH,
1334 } evxAtItemId;
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
VX_AT_SHEET_PROJECTION
@ VX_AT_SHEET_PROJECTION
projection
Definition: zwapi_util.h:1332
VX_AT_DESIGNER
@ VX_AT_DESIGNER
designer
Definition: zwapi_util.h:1298
VX_AT_SHEETPATH
@ VX_AT_SHEETPATH
corresponded drawing sheet: FILE NAME,SHEET ROOT NAME
Definition: zwapi_util.h:1314
VX_AT_SHEET_SCALE
@ VX_AT_SHEET_SCALE
scale
Definition: zwapi_util.h:1328
VX_AT_KEYWORD
@ VX_AT_KEYWORD
keyword
Definition: zwapi_util.h:1302
VX_AT_DERIVED
@ VX_AT_DERIVED
derived from
Definition: zwapi_util.h:1307
VX_AT_HEIGHT
@ VX_AT_HEIGHT
height
Definition: zwapi_util.h:1323
VX_AT_NAME
@ VX_AT_NAME
part name
Definition: zwapi_util.h:1295
VX_AT_FILEPATH
@ VX_AT_FILEPATH
file path
Definition: zwapi_util.h:1313
VX_AT_VOLUME
@ VX_AT_VOLUME
volume
Definition: zwapi_util.h:1319
VX_AT_AREA
@ VX_AT_AREA
area
Definition: zwapi_util.h:1318
VX_AT_REVISION
@ VX_AT_REVISION
revision
Definition: zwapi_util.h:1325
VX_AT_NO_ROOTSHOW
@ VX_AT_NO_ROOTSHOW
do not list in root manager
Definition: zwapi_util.h:1311
VX_AT_SHEETCODE
@ VX_AT_SHEETCODE
sheet code
Definition: zwapi_util.h:1316
VX_AT_WIDTH
@ VX_AT_WIDTH
width
Definition: zwapi_util.h:1322
VX_AT_NUMBER
@ VX_AT_NUMBER
part number
Definition: zwapi_util.h:1296
VX_AT_SHEET_FILEPATH
@ VX_AT_SHEET_FILEPATH
filepath
Definition: zwapi_util.h:1333
VX_AT_MANAGER
@ VX_AT_MANAGER
manager
Definition: zwapi_util.h:1303
VX_AT_STOCK_SIZE
@ VX_AT_STOCK_SIZE
stock size
Definition: zwapi_util.h:1324
VX_AT_NO_BOM
@ VX_AT_NO_BOM
do not list in BOM
Definition: zwapi_util.h:1310
VX_AT_CAMPATH
@ VX_AT_CAMPATH
corresponded CAM object: FILE NAME,CAM ROOT NAME
Definition: zwapi_util.h:1315
VX_AT_SUPPLIER
@ VX_AT_SUPPLIER
supplier
Definition: zwapi_util.h:1300
VX_AT_MASS
@ VX_AT_MASS
mass property
Definition: zwapi_util.h:1320
VX_AT_SHEET_SIZE
@ VX_AT_SHEET_SIZE
size
Definition: zwapi_util.h:1331
VX_AT_START
@ VX_AT_START
create time
Definition: zwapi_util.h:1305
VX_AT_DESCRIPT
@ VX_AT_DESCRIPT
description
Definition: zwapi_util.h:1301
VX_AT_LENGTH
@ VX_AT_LENGTH
length
Definition: zwapi_util.h:1321
VX_AT_NO_HATCH
@ VX_AT_NO_HATCH
do not hatch
Definition: zwapi_util.h:1309
VX_AT_END
@ VX_AT_END
last modified time
Definition: zwapi_util.h:1306
VX_AT_COST
@ VX_AT_COST
cost
Definition: zwapi_util.h:1299
VX_AT_DENSITY
@ VX_AT_DENSITY
density
Definition: zwapi_util.h:1312
VX_AT_SHEET_SEQUENCE
@ VX_AT_SHEET_SEQUENCE
sequence
Definition: zwapi_util.h:1329
VX_AT_SHEET_AMOUNT
@ VX_AT_SHEET_AMOUNT
amount
Definition: zwapi_util.h:1330
VX_AT_CLASS
@ VX_AT_CLASS
CAM class.
Definition: zwapi_util.h:1297
VX_AT_USER
@ VX_AT_USER
user defined attributes
Definition: zwapi_util.h:1294
VX_AT_MATERIAL
@ VX_AT_MATERIAL
material
Definition: zwapi_util.h:1304
VX_AT_NO_SECTION
@ VX_AT_NO_SECTION
do not section
Definition: zwapi_util.h:1308
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxSrfPrimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxSrfPrimType

enum evxSrfPrimType

#include <zwapi_util.h>

3D NURB surface type

Enumerator
VX_SF_PRIM_PLN | plane
VX_SF_PRIM_SPH | sphere
VX_SF_PRIM_CON | cone
VX_SF_PRIM_CYL | cylinder
VX_SF_PRIM_NURB | nurbs surface
VX_SF_PRIM_ELLSO | ellipsoid
VX_SF_PRIM_TORUS | torus

Definition at line 1754 of file zwapi_util.h.

1755 {
1756 VX_SF_PRIM_PLN,
1757 VX_SF_PRIM_SPH,
1758 VX_SF_PRIM_CON,
1759 VX_SF_PRIM_CYL,
1760 VX_SF_PRIM_NURB,
1761 VX_SF_PRIM_ELLSO,
1762 VX_SF_PRIM_TORUS
1763 } evxSrfPrimType;
evxSrfPrimType
evxSrfPrimType
3D NURB surface type
Definition: zwapi_util.h:1755
VX_SF_PRIM_CON
@ VX_SF_PRIM_CON
cone
Definition: zwapi_util.h:1758
VX_SF_PRIM_ELLSO
@ VX_SF_PRIM_ELLSO
ellipsoid
Definition: zwapi_util.h:1761
VX_SF_PRIM_PLN
@ VX_SF_PRIM_PLN
plane
Definition: zwapi_util.h:1756
VX_SF_PRIM_CYL
@ VX_SF_PRIM_CYL
cylinder
Definition: zwapi_util.h:1759
VX_SF_PRIM_SPH
@ VX_SF_PRIM_SPH
sphere
Definition: zwapi_util.h:1757
VX_SF_PRIM_NURB
@ VX_SF_PRIM_NURB
nurbs surface
Definition: zwapi_util.h:1760
VX_SF_PRIM_TORUS
@ VX_SF_PRIM_TORUS
torus
Definition: zwapi_util.h:1762
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDimType

enum evxDimType

#include <zwapi_util.h>

dimension type

Enumerator
VX_DIM_LINEAR | Linear dimension.
VX_DIM_BASELINE | Baseline dimension.
VX_DIM_CONTINUOUS | Continuous dimension.
VX_DIM_ORDINATE | Ordinate dimension.
VX_DIM_LINEAR_OFFSET | Linear Offset dimension.
VX_DIM_LINEAR_CHAMFER | Linear Chamfer dimension.
VX_DIM_ANGULAR | Angular dimension.
VX_DIM_RADIAL_DIAMETRIC | Radial/Diametric dimension.
VX_DIM_ARC_LENGTH | Arc Length dimension.
VX_DIM_SYMMETRY | Symmetry dimension.
VX_DIM_HLCALL | hole call out
VX_DIM_LABEL | leader label
VX_DIM_BALLOON | balloon
VX_DIM_DATUMF | datum feature
VX_DIM_DATUMT | datum target
VX_DIM_FCS | feature control symbol
VX_DIM_CLCM | centerline/center mark
VX_DIM_INTERSYM | intersection symbol

Definition at line 1933 of file zwapi_util.h.

1934 {
1935 VX_DIM_LINEAR = 1,
1936 VX_DIM_BASELINE = 2,
1937 VX_DIM_CONTINUOUS = 3,
1938 VX_DIM_ORDINATE = 4,
1939 VX_DIM_LINEAR_OFFSET = 5,
1940 VX_DIM_LINEAR_CHAMFER = 6,
1941 VX_DIM_ANGULAR = 7,
1942 VX_DIM_RADIAL_DIAMETRIC = 8,
1943 VX_DIM_ARC_LENGTH = 9,
1944 VX_DIM_SYMMETRY,
1945 VX_DIM_HLCALL,
1946 VX_DIM_LABEL,
1947 VX_DIM_BALLOON,
1948 VX_DIM_DATUMF,
1949 VX_DIM_DATUMT,
1950 VX_DIM_FCS,
1951 VX_DIM_CLCM,
1952 VX_DIM_INTERSYM,
1953 VX_DIM_LAST
1954 } evxDimType;
evxDimType
evxDimType
dimension type
Definition: zwapi_util.h:1934
VX_DIM_FCS
@ VX_DIM_FCS
feature control symbol
Definition: zwapi_util.h:1950
VX_DIM_CLCM
@ VX_DIM_CLCM
centerline/center mark
Definition: zwapi_util.h:1951
VX_DIM_DATUMT
@ VX_DIM_DATUMT
datum target
Definition: zwapi_util.h:1949
VX_DIM_SYMMETRY
@ VX_DIM_SYMMETRY
Symmetry dimension.
Definition: zwapi_util.h:1944
VX_DIM_ORDINATE
@ VX_DIM_ORDINATE
Ordinate dimension.
Definition: zwapi_util.h:1938
VX_DIM_HLCALL
@ VX_DIM_HLCALL
hole call out
Definition: zwapi_util.h:1945
VX_DIM_LABEL
@ VX_DIM_LABEL
leader label
Definition: zwapi_util.h:1946
VX_DIM_BALLOON
@ VX_DIM_BALLOON
balloon
Definition: zwapi_util.h:1947
VX_DIM_ANGULAR
@ VX_DIM_ANGULAR
Angular dimension.
Definition: zwapi_util.h:1941
VX_DIM_DATUMF
@ VX_DIM_DATUMF
datum feature
Definition: zwapi_util.h:1948
VX_DIM_INTERSYM
@ VX_DIM_INTERSYM
intersection symbol
Definition: zwapi_util.h:1952
VX_DIM_BASELINE
@ VX_DIM_BASELINE
Baseline dimension.
Definition: zwapi_util.h:1936
VX_DIM_CONTINUOUS
@ VX_DIM_CONTINUOUS
Continuous dimension.
Definition: zwapi_util.h:1937
VX_DIM_RADIAL_DIAMETRIC
@ VX_DIM_RADIAL_DIAMETRIC
Radial/Diametric dimension.
Definition: zwapi_util.h:1942
VX_DIM_LINEAR_CHAMFER
@ VX_DIM_LINEAR_CHAMFER
Linear Chamfer dimension.
Definition: zwapi_util.h:1940
VX_DIM_ARC_LENGTH
@ VX_DIM_ARC_LENGTH
Arc Length dimension.
Definition: zwapi_util.h:1943
VX_DIM_LINEAR_OFFSET
@ VX_DIM_LINEAR_OFFSET
Linear Offset dimension.
Definition: zwapi_util.h:1939
VX_DIM_LINEAR
@ VX_DIM_LINEAR
Linear dimension.
Definition: zwapi_util.h:1935
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxCmPlanDispMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxCmPlanDispMode

enum evxCmPlanDispMode

#include <zwapi_util.h>

cam plan display mode

Enumerator
CM_ACTIVE_LOCK | lock
CM_ACTIVE_PART | part
CM_ACTIVE_PROCESS | process
CM_ACTIVE_SETUP | setup
CM_ACTIVE_TOOLPATH | toolpath
CM_ACTIVE_MACHINE | machine
CM_ACTIVE_TOOL | tool
CM_ACTIVE_TACTIC | tactic
CM_ACTIVE_SPDFD | spdfd
CM_ACTIVE_CMCOMP | cmcomp
CM_ACTIVE_FTRGRP | ftrgrp
CM_ACTIVE_FTRSET | ftrset
CM_ACTIVE_NEST | nest
CM_ACTIVE_WIZARD | wizard
CM_ACTIVE_PUNCH | punch
CM_ACTIVE_HOLDER | holder

Definition at line 2524 of file zwapi_util.h.

2525 {
2526 CM_ACTIVE_LOCK = 0,
2527 CM_ACTIVE_PART = 1,
2528 CM_ACTIVE_PROCESS = 2,
2529 CM_ACTIVE_SETUP = 3,
2530 CM_ACTIVE_TOOLPATH = 4,
2531 CM_ACTIVE_MACHINE = 5,
2532 CM_ACTIVE_TOOL = 6,
2533 CM_ACTIVE_TACTIC = 7,
2534 CM_ACTIVE_SPDFD = 8,
2535 CM_ACTIVE_CMCOMP = 9,
2536 CM_ACTIVE_FTRGRP = 10,
2537 CM_ACTIVE_FTRSET = 11,
2538 CM_ACTIVE_NEST = 12,
2539 CM_ACTIVE_WIZARD = 13,
2540 CM_ACTIVE_PUNCH = 14,
2541 CM_ACTIVE_HOLDER = 15
2542 }evxCmPlanDispMode;
evxCmPlanDispMode
evxCmPlanDispMode
cam plan display mode
Definition: zwapi_util.h:2525
CM_ACTIVE_SETUP
@ CM_ACTIVE_SETUP
setup
Definition: zwapi_util.h:2529
CM_ACTIVE_CMCOMP
@ CM_ACTIVE_CMCOMP
cmcomp
Definition: zwapi_util.h:2535
CM_ACTIVE_TOOLPATH
@ CM_ACTIVE_TOOLPATH
toolpath
Definition: zwapi_util.h:2530
CM_ACTIVE_PART
@ CM_ACTIVE_PART
part
Definition: zwapi_util.h:2527
CM_ACTIVE_PUNCH
@ CM_ACTIVE_PUNCH
punch
Definition: zwapi_util.h:2540
CM_ACTIVE_LOCK
@ CM_ACTIVE_LOCK
lock
Definition: zwapi_util.h:2526
CM_ACTIVE_SPDFD
@ CM_ACTIVE_SPDFD
spdfd
Definition: zwapi_util.h:2534
CM_ACTIVE_WIZARD
@ CM_ACTIVE_WIZARD
wizard
Definition: zwapi_util.h:2539
CM_ACTIVE_FTRGRP
@ CM_ACTIVE_FTRGRP
ftrgrp
Definition: zwapi_util.h:2536
CM_ACTIVE_PROCESS
@ CM_ACTIVE_PROCESS
process
Definition: zwapi_util.h:2528
CM_ACTIVE_FTRSET
@ CM_ACTIVE_FTRSET
ftrset
Definition: zwapi_util.h:2537
CM_ACTIVE_MACHINE
@ CM_ACTIVE_MACHINE
machine
Definition: zwapi_util.h:2531
CM_ACTIVE_TOOL
@ CM_ACTIVE_TOOL
tool
Definition: zwapi_util.h:2532
CM_ACTIVE_HOLDER
@ CM_ACTIVE_HOLDER
holder
Definition: zwapi_util.h:2541
CM_ACTIVE_TACTIC
@ CM_ACTIVE_TACTIC
tactic
Definition: zwapi_util.h:2533
CM_ACTIVE_NEST
@ CM_ACTIVE_NEST
nest
Definition: zwapi_util.h:2538
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDateFormat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDateFormat

enum evxDateFormat

#include <zwapi_util.h>

date attribute format

Enumerator
VX_DATE_FROMAT_SHORT | short date
VX_DATE_FROMAT_LONG | long date
VX_DATE_FROMAT1 | yyyy/M/D
VX_DATE_FROMAT2 | yyyy-M-D
VX_DATE_FROMAT3 | yyyy.M.D
VX_DATE_FROMAT4 | yy/M/D
VX_DATE_FROMAT5 | yy-M-D
VX_DATE_FROMAT6 | yy.M.D

Definition at line 1353 of file zwapi_util.h.

1354 {
1355 VX_DATE_FROMAT_SHORT = 0,
1356 VX_DATE_FROMAT_LONG = 1,
1357 VX_DATE_FROMAT1 = 2,
1358 VX_DATE_FROMAT2 = 3,
1359 VX_DATE_FROMAT3 = 4,
1360 VX_DATE_FROMAT4 = 5,
1361 VX_DATE_FROMAT5 = 6,
1362 VX_DATE_FROMAT6 = 7,
1363 } evxDateFormat;
evxDateFormat
evxDateFormat
date attribute format
Definition: zwapi_util.h:1354
VX_DATE_FROMAT1
@ VX_DATE_FROMAT1
yyyy/M/D
Definition: zwapi_util.h:1357
VX_DATE_FROMAT6
@ VX_DATE_FROMAT6
yy.M.D
Definition: zwapi_util.h:1362
VX_DATE_FROMAT5
@ VX_DATE_FROMAT5
yy-M-D
Definition: zwapi_util.h:1361
VX_DATE_FROMAT2
@ VX_DATE_FROMAT2
yyyy-M-D
Definition: zwapi_util.h:1358
VX_DATE_FROMAT_LONG
@ VX_DATE_FROMAT_LONG
long date
Definition: zwapi_util.h:1356
VX_DATE_FROMAT4
@ VX_DATE_FROMAT4
yy/M/D
Definition: zwapi_util.h:1360
VX_DATE_FROMAT_SHORT
@ VX_DATE_FROMAT_SHORT
short date
Definition: zwapi_util.h:1355
VX_DATE_FROMAT3
@ VX_DATE_FROMAT3
yyyy.M.D
Definition: zwapi_util.h:1359
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxViewStd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxViewStd

enum evxViewStd

#include <zwapi_util.h>

standard 3D view orientations

Definition at line 2455 of file zwapi_util.h.

2456 {
2457 VX_VIEW_FRONT = 0,
2458 VX_VIEW_BACK = 1,
2459 VX_VIEW_TOP = 2,
2460 VX_VIEW_BOTTOM = 3,
2461 VX_VIEW_RIGHT = 4,
2462 VX_VIEW_LEFT = 5,
2463 VX_VIEW_ISO = 6,
2464 VX_VIEW_AUX = 7,
2465 VX_VIEW_PLANE = 8
2466 } evxViewStd;
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxFairingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxFairingType

enum evxFairingType

#include <zwapi_util.h>

fairing modes

Enumerator
VX_FAIRING_NONE | none
VX_FAIRING_ENERGY | energy
VX_FAIRING_VARIATION | variation
VX_FAIRING_JERK | jerk
VX_FAIRING_BEND | bend
VX_FAIRING_TENSION | tension
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 2314 of file zwapi_util.h.

2315 {
2316 VX_FAIRING_NONE = 0,
2317 VX_FAIRING_ENERGY = 1,
2318 VX_FAIRING_VARIATION = 2,
2319 VX_FAIRING_JERK = 3,
2320 VX_FAIRING_BEND = 4,
2321 VX_FAIRING_TENSION = 5,
2322 }evxFairingType;
evxFairingType
evxFairingType
fairing modes
Definition: zwapi_util.h:2315
VX_FAIRING_JERK
@ VX_FAIRING_JERK
jerk
Definition: zwapi_util.h:2319
VX_FAIRING_BEND
@ VX_FAIRING_BEND
bend
Definition: zwapi_util.h:2320
VX_FAIRING_ENERGY
@ VX_FAIRING_ENERGY
energy
Definition: zwapi_util.h:2317
VX_FAIRING_NONE
@ VX_FAIRING_NONE
none
Definition: zwapi_util.h:2316
VX_FAIRING_TENSION
@ VX_FAIRING_TENSION
tension
Definition: zwapi_util.h:2321
VX_FAIRING_VARIATION
@ VX_FAIRING_VARIATION
variation
Definition: zwapi_util.h:2318
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxFindRule

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxFindRule

enum evxFindRule

#include <zwapi_util.h>

face search rules

Enumerator
VX_STOP_FACE_FILLET | stop at fillet faces (fillets are added)
VX_STOP_EDGE_INNER_LOOP | stop at edges on inner loops on either face
VX_STOP_CONVEX_FLLT | stop at convex fillet faces (fillets are added)
VX_STOP_CONCAVE_FLLT | stop at concave fillet faces (fillets are added)
VX_STOP_CONVEX_EDGE | stop at convex edges
VX_STOP_CONCAVE_EDGE | stop at concave edges
VX_STOP_ADJACENCY_LEVEL | stop when face region grows through a set number of cycles, a face region grows in cycles, where the faces immediately adjacent to the seed are added in the first cycle, the faces immediately adjacent to those faces are added in the second cycle, and so on
VX_STOP_BOUNDARY_FACE | stop at boundary faces
VX_FIND_COAXIAL | find coaxial faces, seed face support cylinder,conical,sphere,torus
VX_FIND_TANGENT | find faces which is tangent to the seed
VX_FIND_COPLANAR | find faces which are in the same plane with the seed
VX_FIND_COPL_AXES | find faces whose axes are in the same plane with the seed, seed face support cylinder,conical
VX_FIND_EQU_RAD | find faces whose radius is equal to the seed, seed face support cylinder and sphere
VX_FIND_SYMMETRIC | find symmetric faces, seed face support cylinder,conical
VX_FIND_OFFSET | find face which has overlap regions with the seed and face normal is opposite, for a seed, only one offset face exists in a shape

Definition at line 1056 of file zwapi_util.h.

1057 {
1058 /* stop condition, only for VX_FIND_CUSTOM (evxFaceFindType) type */
1059 VX_STOP_FACE_FILLET = 0x00000001,
1060 VX_STOP_EDGE_INNER_LOOP = 0x00000002,
1061 VX_STOP_CONVEX_FLLT = 0x00000004,
1062 VX_STOP_CONCAVE_FLLT = 0x00000008,
1063 VX_STOP_CONVEX_EDGE = 0x00000010,
1064 VX_STOP_CONCAVE_EDGE = 0x00000020,
1065 VX_STOP_ADJACENCY_LEVEL = 0x00000040,
1070 VX_STOP_BOUNDARY_FACE = 0x00000080,
1073 /* find rules, only for VX_FIND_FINDER (evxFaceFindType) type */
1074 VX_FIND_COAXIAL = 0x00000001,
1075 VX_FIND_TANGENT = 0x00000002,
1076 VX_FIND_COPLANAR = 0x00000004,
1077 VX_FIND_COPL_AXES = 0x00000008,
1079 VX_FIND_EQU_RAD = 0x00000010,
1081 VX_FIND_SYMMETRIC = 0x00000020,
1082 VX_FIND_OFFSET = 0x00000040,
1084 } evxFindRule;
evxFindRule
evxFindRule
face search rules
Definition: zwapi_util.h:1057
VX_FIND_COPLANAR
@ VX_FIND_COPLANAR
find faces which are in the same plane with the seed
Definition: zwapi_util.h:1076
VX_FIND_OFFSET
@ VX_FIND_OFFSET
find face which has overlap regions with the seed and face normal is opposite, for a seed,...
Definition: zwapi_util.h:1082
VX_STOP_ADJACENCY_LEVEL
@ VX_STOP_ADJACENCY_LEVEL
stop when face region grows through a set number of cycles, a face region grows in cycles,...
Definition: zwapi_util.h:1065
VX_STOP_FACE_FILLET
@ VX_STOP_FACE_FILLET
stop at fillet faces (fillets are added)
Definition: zwapi_util.h:1059
VX_FIND_EQU_RAD
@ VX_FIND_EQU_RAD
find faces whose radius is equal to the seed, seed face support cylinder and sphere
Definition: zwapi_util.h:1079
VX_FIND_COAXIAL
@ VX_FIND_COAXIAL
find coaxial faces, seed face support cylinder,conical,sphere,torus
Definition: zwapi_util.h:1074
VX_FIND_TANGENT
@ VX_FIND_TANGENT
find faces which is tangent to the seed
Definition: zwapi_util.h:1075
VX_STOP_EDGE_INNER_LOOP
@ VX_STOP_EDGE_INNER_LOOP
stop at edges on inner loops on either face
Definition: zwapi_util.h:1060
VX_STOP_CONVEX_FLLT
@ VX_STOP_CONVEX_FLLT
stop at convex fillet faces (fillets are added)
Definition: zwapi_util.h:1061
VX_STOP_CONCAVE_FLLT
@ VX_STOP_CONCAVE_FLLT
stop at concave fillet faces (fillets are added)
Definition: zwapi_util.h:1062
VX_STOP_BOUNDARY_FACE
@ VX_STOP_BOUNDARY_FACE
stop at boundary faces
Definition: zwapi_util.h:1070
VX_FIND_SYMMETRIC
@ VX_FIND_SYMMETRIC
find symmetric faces, seed face support cylinder,conical
Definition: zwapi_util.h:1081
VX_STOP_CONVEX_EDGE
@ VX_STOP_CONVEX_EDGE
stop at convex edges
Definition: zwapi_util.h:1063
VX_FIND_COPL_AXES
@ VX_FIND_COPL_AXES
find faces whose axes are in the same plane with the seed, seed face support cylinder,...
Definition: zwapi_util.h:1077
VX_STOP_CONCAVE_EDGE
@ VX_STOP_CONCAVE_EDGE
stop at concave edges
Definition: zwapi_util.h:1064
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxPntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxPntType

enum evxPntType

#include <zwapi_util.h>

point input data types

Enumerator
VX_PNT3_ABS | defined by absolute coord. in object space
VX_PNT3_ENT | entity "critical" point (start, end, mid, center)
VX_PNT3_ON | point on entity defined in entity parameter space
VX_PNT3_TO | point on entity for "tangent to" or "extend to"
VX_PNT3_MID | curve midpoint
VX_PNT3_NUM | point object stores dimensionless numeric input
VX_PNT3_DST | point object stores linear numeric input
VX_PNT3_ANG | point object stores angular numeric input
VX_PNT3_TAN | point on entity for "tangent to"
VX_PNT3_FRAC | point on curve defined as fraction of curve length
VX_PNT3_REL | point defined relative to previous point
VX_PNT3_DATA | point defined by a VDATA object
VX_PNT3_ABS_COMP | defined by abs coord in space of active component

Definition at line 1523 of file zwapi_util.h.

1524 {
1525 VX_PNT3_ABS = 0,
1526 VX_PNT3_ENT = 1,
1527 VX_PNT3_ON = 2,
1528 VX_PNT3_TO = 3,
1529 VX_PNT3_MID = 4,
1530 VX_PNT3_NUM = 5,
1531 VX_PNT3_DST = 6,
1532 VX_PNT3_ANG = 7,
1533 VX_PNT3_TAN = 8,
1534 VX_PNT3_FRAC = 9,
1535 VX_PNT3_REL = 10,
1536 VX_PNT3_DATA = 11,
1537 VX_PNT3_ABS_COMP = 12
1538 } evxPntType;
evxPntType
evxPntType
point input data types
Definition: zwapi_util.h:1524
VX_PNT3_ENT
@ VX_PNT3_ENT
entity "critical" point (start, end, mid, center)
Definition: zwapi_util.h:1526
VX_PNT3_FRAC
@ VX_PNT3_FRAC
point on curve defined as fraction of curve length
Definition: zwapi_util.h:1534
VX_PNT3_ON
@ VX_PNT3_ON
point on entity defined in entity parameter space
Definition: zwapi_util.h:1527
VX_PNT3_DST
@ VX_PNT3_DST
point object stores linear numeric input
Definition: zwapi_util.h:1531
VX_PNT3_ABS
@ VX_PNT3_ABS
defined by absolute coord. in object space
Definition: zwapi_util.h:1525
VX_PNT3_ANG
@ VX_PNT3_ANG
point object stores angular numeric input
Definition: zwapi_util.h:1532
VX_PNT3_NUM
@ VX_PNT3_NUM
point object stores dimensionless numeric input
Definition: zwapi_util.h:1530
VX_PNT3_TO
@ VX_PNT3_TO
point on entity for "tangent to" or "extend to"
Definition: zwapi_util.h:1528
VX_PNT3_ABS_COMP
@ VX_PNT3_ABS_COMP
defined by abs coord in space of active component
Definition: zwapi_util.h:1537
VX_PNT3_TAN
@ VX_PNT3_TAN
point on entity for "tangent to"
Definition: zwapi_util.h:1533
VX_PNT3_MID
@ VX_PNT3_MID
curve midpoint
Definition: zwapi_util.h:1529
VX_PNT3_DATA
@ VX_PNT3_DATA
point defined by a VDATA object
Definition: zwapi_util.h:1536
VX_PNT3_REL
@ VX_PNT3_REL
point defined relative to previous point
Definition: zwapi_util.h:1535
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEdgeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxEdgeType

enum evxEdgeType

#include <zwapi_util.h>

type of edge

Enumerator
VX_EDGE_UNKNOWN | unknown
VX_EDGE_STANDARD | standard edge
VX_EDGE_SEAM | seam edge
VX_EDGE_DEGEN | degenerate edge

Definition at line 997 of file zwapi_util.h.

998 {
999 VX_EDGE_UNKNOWN = -1,
1000 VX_EDGE_STANDARD = 0,
1001 VX_EDGE_SEAM = 1,
1002 VX_EDGE_DEGEN = 2
1003 } evxEdgeType;
VX_EDGE_SEAM
@ VX_EDGE_SEAM
seam edge
Definition: zwapi_util.h:1001
VX_EDGE_STANDARD
@ VX_EDGE_STANDARD
standard edge
Definition: zwapi_util.h:1000
VX_EDGE_UNKNOWN
@ VX_EDGE_UNKNOWN
unknown
Definition: zwapi_util.h:999
VX_EDGE_DEGEN
@ VX_EDGE_DEGEN
degenerate edge
Definition: zwapi_util.h:1002
evxEdgeType
evxEdgeType
type of edge
Definition: zwapi_util.h:998
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEntFind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxEntFind

enum evxEntFind

#include <zwapi_util.h>

entity search types

Enumerator
VX_FIND_POINT | point
VX_FIND_CURVE | curve
VX_FIND_EDGE | edge
VX_FIND_WIRE | point, edge or curve
VX_FIND_FACE | face
VX_FIND_SKETCH | sketch
VX_FIND_CRV_LIST | 3D curve list
VX_FIND_SKETCH_OR_CRV_LIST | sketch or curve list
VX_FIND_PROFILE | curve, edge, sketch or curvelist
VX_FIND_EDGE_OR_CRV | edge or curve
VX_FIND_3D_BLOCK | 3D point or STL block
VX_FIND_DIM | dimension

Definition at line 1009 of file zwapi_util.h.

1010 {
1011 VX_FIND_POINT = 1,
1012 VX_FIND_CURVE = 2,
1013 VX_FIND_EDGE = 3,
1014 VX_FIND_WIRE = 4,
1015 VX_FIND_FACE = 5,
1016 VX_FIND_SKETCH = 6,
1017 VX_FIND_CRV_LIST = 7,
1018 VX_FIND_SKETCH_OR_CRV_LIST = 8,
1019 VX_FIND_PROFILE = 9,
1020 VX_FIND_EDGE_OR_CRV = 10,
1021 VX_FIND_3D_BLOCK = 14,
1022 VX_FIND_DIM = 15
1023 } evxEntFind;
evxEntFind
evxEntFind
entity search types
Definition: zwapi_util.h:1010
VX_FIND_EDGE
@ VX_FIND_EDGE
edge
Definition: zwapi_util.h:1013
VX_FIND_CURVE
@ VX_FIND_CURVE
curve
Definition: zwapi_util.h:1012
VX_FIND_WIRE
@ VX_FIND_WIRE
point, edge or curve
Definition: zwapi_util.h:1014
VX_FIND_SKETCH_OR_CRV_LIST
@ VX_FIND_SKETCH_OR_CRV_LIST
sketch or curve list
Definition: zwapi_util.h:1018
VX_FIND_DIM
@ VX_FIND_DIM
dimension
Definition: zwapi_util.h:1022
VX_FIND_SKETCH
@ VX_FIND_SKETCH
sketch
Definition: zwapi_util.h:1016
VX_FIND_POINT
@ VX_FIND_POINT
point
Definition: zwapi_util.h:1011
VX_FIND_FACE
@ VX_FIND_FACE
face
Definition: zwapi_util.h:1015
VX_FIND_PROFILE
@ VX_FIND_PROFILE
curve, edge, sketch or curvelist
Definition: zwapi_util.h:1019
VX_FIND_EDGE_OR_CRV
@ VX_FIND_EDGE_OR_CRV
edge or curve
Definition: zwapi_util.h:1020
VX_FIND_CRV_LIST
@ VX_FIND_CRV_LIST
3D curve list
Definition: zwapi_util.h:1017
VX_FIND_3D_BLOCK
@ VX_FIND_3D_BLOCK
3D point or STL block
Definition: zwapi_util.h:1021
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxUnitType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxUnitType

enum evxUnitType

#include <zwapi_util.h>

system of linear units

Enumerator
VX_UNIT_MICRON | micron
VX_UNIT_MILLIMETER | millimeter
VX_UNIT_CENTIMETER | centimeter
VX_UNIT_METER | meter
VX_UNIT_INCH | inch
VX_UNIT_FOOT | foot
VX_UNIT_YD | yard
VX_UNIT_DM | decimeter
VX_UNIT_MIL | mil

Definition at line 382 of file zwapi_util.h.

383 {
384 VX_UNIT_MICRON = 0,
385 VX_UNIT_MILLIMETER = 1,
386 VX_UNIT_CENTIMETER = 2,
387 VX_UNIT_METER = 3,
388 VX_UNIT_INCH = 4,
389 VX_UNIT_FOOT = 5,
390 VX_UNIT_YD = 6,
391 VX_UNIT_DM = 7,
392 VX_UNIT_MIL = 10
393 } evxUnitType;
evxUnitType
evxUnitType
system of linear units
Definition: zwapi_util.h:383
VX_UNIT_DM
@ VX_UNIT_DM
decimeter
Definition: zwapi_util.h:391
VX_UNIT_YD
@ VX_UNIT_YD
yard
Definition: zwapi_util.h:390
VX_UNIT_METER
@ VX_UNIT_METER
meter
Definition: zwapi_util.h:387
VX_UNIT_MIL
@ VX_UNIT_MIL
mil
Definition: zwapi_util.h:392
VX_UNIT_MILLIMETER
@ VX_UNIT_MILLIMETER
millimeter
Definition: zwapi_util.h:385
VX_UNIT_FOOT
@ VX_UNIT_FOOT
foot
Definition: zwapi_util.h:389
VX_UNIT_INCH
@ VX_UNIT_INCH
inch
Definition: zwapi_util.h:388
VX_UNIT_MICRON
@ VX_UNIT_MICRON
micron
Definition: zwapi_util.h:384
VX_UNIT_CENTIMETER
@ VX_UNIT_CENTIMETER
centimeter
Definition: zwapi_util.h:386
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxEntType

enum evxEntType

#include <zwapi_util.h>

entity types

Enumerator
VX_ENT_BREP | any brep entity (i.e. shape,face,loop,edge,vertex)
VX_ENT_OP | any history operation
VX_ENT_POINT | any point entity (2D or 3D)
VX_ENT_WIRE | any wireframe entity (line, arc, curve)
VX_ENT_ALL | any entity type
VX_ENT_SHAPE | b-rep shape (i.e. faceset)
VX_ENT_FACE | b-rep face
VX_ENT_EDGE | b-rep edge
VX_ENT_FTR | feature operation
VX_ENT_NRB_CRV | NURBS curve.
VX_ENT_LINE3 | 3D line
VX_ENT_LINE2 | 2D line
VX_ENT_CIRCLE3 | 3D circle
VX_ENT_CIRCLE2 | 2D circle
VX_ENT_ARC3 | 3D arc
VX_ENT_ARC2 | 2D arc
VX_ENT_POINT3 | 3D point
VX_ENT_POINT2 | 2D point
VX_ENT_LAYER | layer
VX_ENT_SKETCH | sketch
VX_ENT_REF_GEOM | reference geometry
VX_ENT_TEXT | text
VX_ENT_DIMEN | dimension
VX_ENT_ANNO | annotation text
VX_ENT_BLOCK | block
VX_ENT_DWG_VIEW | drawing view
VX_ENT_COMP | assembly component
VX_ENT_PART | part
VX_ENT_SHEET | drawing sheet
VX_ENT_PACKET | drawing packet
VX_ENT_DATUM | datum plane
VX_ENT_CRV_LIST | curve list
VX_ENT_PART_LINE | parting line
VX_ENT_HATCH | cross-hatch
VX_ENT_LIGHT | light source
VX_ENT_INT_CRV | interpolated curve
VX_ENT_VAR | variable
VX_ENT_EQN_SET | equation set
VX_ENT_SYMBOL | 2D symbol
VX_ENT_TRACE | sketch trace
VX_ENT_TABLE | table object
VX_ENT_VBREAKLINE | Break line.
VX_ENT_RDTXT | Ready sketch text.
VX_ENT_BALLOON | Text balloon.
VX_ENT_DRAWING | Drawing under the sheet.
VX_ENT_PMIENT | PMI entity.
VX_ENT_BLOCK2D | 2D sketch block
VX_ENT_BLKREF | block reference (the instance of 2d sketch block)
VX_ENT_AXIS | Datum axis.
VX_ENT_CSYS | Datum frame.
VX_ENT_AXIS_2D | 2D datum axis

Definition at line 916 of file zwapi_util.h.

917 {
918 VX_ENT_BREP = -4,
919 VX_ENT_OP = -3,
920 VX_ENT_POINT = -2,
921 VX_ENT_WIRE = -1,
922 VX_ENT_ALL = 0,
923 VX_ENT_SHAPE = 42,
924 VX_ENT_FACE = 43,
925 VX_ENT_EDGE = 46,
926 VX_ENT_FTR = 48,
927 VX_ENT_NRB_CRV = 54,
928 VX_ENT_LINE3 = 56,
929 VX_ENT_LINE2 = 58,
930 VX_ENT_CIRCLE3 = 60,
931 VX_ENT_CIRCLE2 = 61,
932 VX_ENT_ARC3 = 62,
933 VX_ENT_ARC2 = 63,
934 VX_ENT_POINT3 = 64,
935 VX_ENT_POINT2 = 65,
936 VX_ENT_LAYER = 67,
937 VX_ENT_SKETCH = 70,
938 VX_ENT_REF_GEOM = 72,
939 VX_ENT_TEXT = 76,
940 VX_ENT_DIMEN = 77,
941 VX_ENT_ANNO = 83,
942 VX_ENT_BLOCK = 86,
943 VX_ENT_DWG_VIEW = 87,
944 VX_ENT_COMP = 88,
945 VX_ENT_PART = 89,
946 VX_ENT_SHEET = 90,
947 VX_ENT_PACKET = 91,
948 VX_ENT_DATUM = 95,
949 VX_ENT_CRV_LIST = 102,
950 VX_ENT_PART_LINE = 106,
951 VX_ENT_HATCH = 111,
952 VX_ENT_LIGHT = 118,
953 VX_ENT_INT_CRV = 119,
954 VX_ENT_VAR = 120,
955 VX_ENT_EQN_SET = 121,
956 VX_ENT_SYMBOL = 123,
957 VX_ENT_TRACE = 133,
958 VX_ENT_TABLE = 144,
959 VX_ENT_VBREAKLINE = 182,
960 VX_ENT_RDTXT = 185,
961 VX_ENT_BALLOON = 168,
962 VX_ENT_DRAWING = 169,
963 VX_ENT_PMIENT = 190,
964 VX_ENT_BLOCK2D = 197,
965 VX_ENT_BLKREF = 198,
966 VX_ENT_AXIS = 311,
967 VX_ENT_CSYS = 312,
968 VX_ENT_AXIS_2D = 313,
969 } evxEntType;
evxEntType
evxEntType
entity types
Definition: zwapi_util.h:917
VX_ENT_PART
@ VX_ENT_PART
part
Definition: zwapi_util.h:945
VX_ENT_AXIS
@ VX_ENT_AXIS
Datum axis.
Definition: zwapi_util.h:966
VX_ENT_TABLE
@ VX_ENT_TABLE
table object
Definition: zwapi_util.h:958
VX_ENT_LINE2
@ VX_ENT_LINE2
2D line
Definition: zwapi_util.h:929
VX_ENT_BREP
@ VX_ENT_BREP
any brep entity (i.e. shape,face,loop,edge,vertex)
Definition: zwapi_util.h:918
VX_ENT_COMP
@ VX_ENT_COMP
assembly component
Definition: zwapi_util.h:944
VX_ENT_BALLOON
@ VX_ENT_BALLOON
Text balloon.
Definition: zwapi_util.h:961
VX_ENT_POINT2
@ VX_ENT_POINT2
2D point
Definition: zwapi_util.h:935
VX_ENT_PMIENT
@ VX_ENT_PMIENT
PMI entity.
Definition: zwapi_util.h:963
VX_ENT_FACE
@ VX_ENT_FACE
b-rep face
Definition: zwapi_util.h:924
VX_ENT_OP
@ VX_ENT_OP
any history operation
Definition: zwapi_util.h:919
VX_ENT_RDTXT
@ VX_ENT_RDTXT
Ready sketch text.
Definition: zwapi_util.h:960
VX_ENT_VBREAKLINE
@ VX_ENT_VBREAKLINE
Break line.
Definition: zwapi_util.h:959
VX_ENT_CRV_LIST
@ VX_ENT_CRV_LIST
curve list
Definition: zwapi_util.h:949
VX_ENT_AXIS_2D
@ VX_ENT_AXIS_2D
2D datum axis
Definition: zwapi_util.h:968
VX_ENT_VAR
@ VX_ENT_VAR
variable
Definition: zwapi_util.h:954
VX_ENT_REF_GEOM
@ VX_ENT_REF_GEOM
reference geometry
Definition: zwapi_util.h:938
VX_ENT_TRACE
@ VX_ENT_TRACE
sketch trace
Definition: zwapi_util.h:957
VX_ENT_LIGHT
@ VX_ENT_LIGHT
light source
Definition: zwapi_util.h:952
VX_ENT_BLOCK
@ VX_ENT_BLOCK
block
Definition: zwapi_util.h:942
VX_ENT_SHEET
@ VX_ENT_SHEET
drawing sheet
Definition: zwapi_util.h:946
VX_ENT_CIRCLE3
@ VX_ENT_CIRCLE3
3D circle
Definition: zwapi_util.h:930
VX_ENT_ARC2
@ VX_ENT_ARC2
2D arc
Definition: zwapi_util.h:933
VX_ENT_CSYS
@ VX_ENT_CSYS
Datum frame.
Definition: zwapi_util.h:967
VX_ENT_PACKET
@ VX_ENT_PACKET
drawing packet
Definition: zwapi_util.h:947
VX_ENT_BLKREF
@ VX_ENT_BLKREF
block reference (the instance of 2d sketch block)
Definition: zwapi_util.h:965
VX_ENT_BLOCK2D
@ VX_ENT_BLOCK2D
2D sketch block
Definition: zwapi_util.h:964
VX_ENT_ARC3
@ VX_ENT_ARC3
3D arc
Definition: zwapi_util.h:932
VX_ENT_LINE3
@ VX_ENT_LINE3
3D line
Definition: zwapi_util.h:928
VX_ENT_POINT3
@ VX_ENT_POINT3
3D point
Definition: zwapi_util.h:934
VX_ENT_SHAPE
@ VX_ENT_SHAPE
b-rep shape (i.e. faceset)
Definition: zwapi_util.h:923
VX_ENT_DRAWING
@ VX_ENT_DRAWING
Drawing under the sheet.
Definition: zwapi_util.h:962
VX_ENT_DATUM
@ VX_ENT_DATUM
datum plane
Definition: zwapi_util.h:948
VX_ENT_EQN_SET
@ VX_ENT_EQN_SET
equation set
Definition: zwapi_util.h:955
VX_ENT_SKETCH
@ VX_ENT_SKETCH
sketch
Definition: zwapi_util.h:937
VX_ENT_NRB_CRV
@ VX_ENT_NRB_CRV
NURBS curve.
Definition: zwapi_util.h:927
VX_ENT_FTR
@ VX_ENT_FTR
feature operation
Definition: zwapi_util.h:926
VX_ENT_DWG_VIEW
@ VX_ENT_DWG_VIEW
drawing view
Definition: zwapi_util.h:943
VX_ENT_CIRCLE2
@ VX_ENT_CIRCLE2
2D circle
Definition: zwapi_util.h:931
VX_ENT_TEXT
@ VX_ENT_TEXT
text
Definition: zwapi_util.h:939
VX_ENT_PART_LINE
@ VX_ENT_PART_LINE
parting line
Definition: zwapi_util.h:950
VX_ENT_WIRE
@ VX_ENT_WIRE
any wireframe entity (line, arc, curve)
Definition: zwapi_util.h:921
VX_ENT_DIMEN
@ VX_ENT_DIMEN
dimension
Definition: zwapi_util.h:940
VX_ENT_INT_CRV
@ VX_ENT_INT_CRV
interpolated curve
Definition: zwapi_util.h:953
VX_ENT_LAYER
@ VX_ENT_LAYER
layer
Definition: zwapi_util.h:936
VX_ENT_HATCH
@ VX_ENT_HATCH
cross-hatch
Definition: zwapi_util.h:951
VX_ENT_ANNO
@ VX_ENT_ANNO
annotation text
Definition: zwapi_util.h:941
VX_ENT_SYMBOL
@ VX_ENT_SYMBOL
2D symbol
Definition: zwapi_util.h:956
VX_ENT_EDGE
@ VX_ENT_EDGE
b-rep edge
Definition: zwapi_util.h:925
VX_ENT_ALL
@ VX_ENT_ALL
any entity type
Definition: zwapi_util.h:922
VX_ENT_POINT
@ VX_ENT_POINT
any point entity (2D or 3D)
Definition: zwapi_util.h:920
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxTextureOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxTextureOpt

enum evxTextureOpt

#include <zwapi_util.h>

texture map option

Definition at line 1239 of file zwapi_util.h.

1240 {
1241 V_TEXTURE_NULL = 0,
1242 V_TEXTURE_BLEND = 1,
1243 V_TEXTURE_DECAL = 2,
1244 V_TEXTURE_MODULATE = 3,
1245 V_TEXTURE_REPLACE = 4
1246 } evxTextureOpt;
evxTextureOpt
evxTextureOpt
texture map option
Definition: zwapi_util.h:1240
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDimLineMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDimLineMode

enum evxDimLineMode

#include <zwapi_util.h>

dimension Line Mode

Enumerator
VX_DIM_LINE_MODE_B | lingrp baseline
VX_DIM_LINE_MODE_C | lingrp continuous
VX_DIM_LINE_MODE_O | lingrp ordinate

Definition at line 2080 of file zwapi_util.h.

2081 {
2082 VX_DIM_LINE_MODE_B = 2,
2083 VX_DIM_LINE_MODE_C = 3,
2084 VX_DIM_LINE_MODE_O = 4,
2085 } evxDimLineMode;
evxDimLineMode
evxDimLineMode
dimension Line Mode
Definition: zwapi_util.h:2081
VX_DIM_LINE_MODE_O
@ VX_DIM_LINE_MODE_O
lingrp ordinate
Definition: zwapi_util.h:2084
VX_DIM_LINE_MODE_B
@ VX_DIM_LINE_MODE_B
lingrp baseline
Definition: zwapi_util.h:2082
VX_DIM_LINE_MODE_C
@ VX_DIM_LINE_MODE_C
lingrp continuous
Definition: zwapi_util.h:2083
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxVarNumType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxVarNumType

enum evxVarNumType

#include <zwapi_util.h>

sub types of numeric variable

Enumerator
VX_VAR_CONS | constant number (without unit)
VX_VAR_DST | distance (evxUnitType)
VX_VAR_ANG | angle (evxAngUnitType)
VX_VAR_MASS | mass (evxMassUnitType)
VX_VAR_DENSITY | density (evxDensityUnitType)
VX_VAR_AREA | area (evxUnitType)
VX_VAR_VOLUME | volume (evxUnitType)
VX_VAR_MASS_MOMENT | mass moment (evxMassMomentUnitType)

Definition at line 1105 of file zwapi_util.h.

1106 {
1107 VX_VAR_CONS = 0,
1108 VX_VAR_DST = 1,
1109 VX_VAR_ANG = 2,
1110 VX_VAR_MASS = 3,
1111 VX_VAR_DENSITY = 4,
1112 VX_VAR_AREA = 5,
1113 VX_VAR_VOLUME = 6,
1114 VX_VAR_MASS_MOMENT = 7
1115 } evxVarNumType;
evxVarNumType
evxVarNumType
sub types of numeric variable
Definition: zwapi_util.h:1106
VX_VAR_MASS_MOMENT
@ VX_VAR_MASS_MOMENT
mass moment (evxMassMomentUnitType)
Definition: zwapi_util.h:1114
VX_VAR_ANG
@ VX_VAR_ANG
angle (evxAngUnitType)
Definition: zwapi_util.h:1109
VX_VAR_MASS
@ VX_VAR_MASS
mass (evxMassUnitType)
Definition: zwapi_util.h:1110
VX_VAR_DENSITY
@ VX_VAR_DENSITY
density (evxDensityUnitType)
Definition: zwapi_util.h:1111
VX_VAR_AREA
@ VX_VAR_AREA
area (evxUnitType)
Definition: zwapi_util.h:1112
VX_VAR_DST
@ VX_VAR_DST
distance (evxUnitType)
Definition: zwapi_util.h:1108
VX_VAR_CONS
@ VX_VAR_CONS
constant number (without unit)
Definition: zwapi_util.h:1107
VX_VAR_VOLUME
@ VX_VAR_VOLUME
volume (evxUnitType)
Definition: zwapi_util.h:1113
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxViewLineAttrIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxViewLineAttrIdx

enum evxViewLineAttrIdx

#include <zwapi_util.h>

line type ids for view attribute line types

Enumerator
VX_VIS_LINE_ATTR | visible line attribute
VX_HID_LINE_ATTR | hidden line attribute
VX_TAN_LINE_ATTR | tangent line attribute
VX_SECT_LINE_ATTR | section line attribute
VX_DET_LINE_ATTR | detail border line attribute
VX_CENT_LINE_ATTR | center line attribute
VX_THRD_LINE_ATTR | thread line attribute
VX_VIEW_LINE_ATTR | view line attribute
VX_WIRE_LINE_ATTR | visible 3D curve attribute
VX_TAN_HID_LINE_ATTR | hidden tangent line attribute
VX_WIRE_HID_LINE_ATTR | hidden 3D curve attribute
VX_CENT_HID_LINE_ATTR | hidden center line attribute
VX_THRD_HID_LINE_ATTR | hidden thread line attribute
VX_BEND_LINE_ATTR | bend line attribute
VX_BEND_HID_LINE_ATTR | hidden bend line attribute
VX_THRD_END_LINE_ATTR | thread end line attribute
VX_THRD_END_HID_LINE_ATTR | hidden thread end line attribute
VX_CROP_LINE_ATTR | crop line attribute

Definition at line 1161 of file zwapi_util.h.

1162 {
1163 VX_VIS_LINE_ATTR = 0,
1164 VX_HID_LINE_ATTR = 1,
1165 VX_TAN_LINE_ATTR = 2,
1166 VX_SECT_LINE_ATTR = 3,
1167 VX_DET_LINE_ATTR = 4,
1168 VX_CENT_LINE_ATTR = 5,
1169 VX_THRD_LINE_ATTR = 6,
1170 VX_VIEW_LINE_ATTR = 7,
1171 VX_WIRE_LINE_ATTR = 8,
1172 VX_TAN_HID_LINE_ATTR = 9,
1173 VX_WIRE_HID_LINE_ATTR = 10,
1174 VX_CENT_HID_LINE_ATTR = 11,
1175 VX_THRD_HID_LINE_ATTR = 12,
1176 VX_BEND_LINE_ATTR = 13,
1177 VX_BEND_HID_LINE_ATTR = 14,
1178 VX_THRD_END_LINE_ATTR = 15,
1179 VX_THRD_END_HID_LINE_ATTR = 16,
1180 VX_CROP_LINE_ATTR = 17,
1181 } evxViewLineAttrIdx;
evxViewLineAttrIdx
evxViewLineAttrIdx
line type ids for view attribute line types
Definition: zwapi_util.h:1162
VX_THRD_END_HID_LINE_ATTR
@ VX_THRD_END_HID_LINE_ATTR
hidden thread end line attribute
Definition: zwapi_util.h:1179
VX_WIRE_LINE_ATTR
@ VX_WIRE_LINE_ATTR
visible 3D curve attribute
Definition: zwapi_util.h:1171
VX_SECT_LINE_ATTR
@ VX_SECT_LINE_ATTR
section line attribute
Definition: zwapi_util.h:1166
VX_VIS_LINE_ATTR
@ VX_VIS_LINE_ATTR
visible line attribute
Definition: zwapi_util.h:1163
VX_THRD_HID_LINE_ATTR
@ VX_THRD_HID_LINE_ATTR
hidden thread line attribute
Definition: zwapi_util.h:1175
VX_HID_LINE_ATTR
@ VX_HID_LINE_ATTR
hidden line attribute
Definition: zwapi_util.h:1164
VX_CROP_LINE_ATTR
@ VX_CROP_LINE_ATTR
crop line attribute
Definition: zwapi_util.h:1180
VX_TAN_LINE_ATTR
@ VX_TAN_LINE_ATTR
tangent line attribute
Definition: zwapi_util.h:1165
VX_WIRE_HID_LINE_ATTR
@ VX_WIRE_HID_LINE_ATTR
hidden 3D curve attribute
Definition: zwapi_util.h:1173
VX_CENT_LINE_ATTR
@ VX_CENT_LINE_ATTR
center line attribute
Definition: zwapi_util.h:1168
VX_BEND_HID_LINE_ATTR
@ VX_BEND_HID_LINE_ATTR
hidden bend line attribute
Definition: zwapi_util.h:1177
VX_THRD_END_LINE_ATTR
@ VX_THRD_END_LINE_ATTR
thread end line attribute
Definition: zwapi_util.h:1178
VX_THRD_LINE_ATTR
@ VX_THRD_LINE_ATTR
thread line attribute
Definition: zwapi_util.h:1169
VX_TAN_HID_LINE_ATTR
@ VX_TAN_HID_LINE_ATTR
hidden tangent line attribute
Definition: zwapi_util.h:1172
VX_BEND_LINE_ATTR
@ VX_BEND_LINE_ATTR
bend line attribute
Definition: zwapi_util.h:1176
VX_DET_LINE_ATTR
@ VX_DET_LINE_ATTR
detail border line attribute
Definition: zwapi_util.h:1167
VX_CENT_HID_LINE_ATTR
@ VX_CENT_HID_LINE_ATTR
hidden center line attribute
Definition: zwapi_util.h:1174
VX_VIEW_LINE_ATTR
@ VX_VIEW_LINE_ATTR
view line attribute
Definition: zwapi_util.h:1170
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxNumType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxNumType

enum evxNumType

#include <zwapi_util.h>

numeric input data types

Enumerator
VX_NUM_UNDEFINED | undefined
VX_NUM_NULL | undefined
VX_NUM_TO_FACE | distance/angle to face
VX_NUM_FACE_BND | boundary face
VX_NUM_TO_PNT | distance/angle to point
VX_NUM_THRU_PLUS | "through all" in positive direction
VX_NUM_THRU_MINUS | "through all" in negative direction
VX_NUM_CURVE_BND | boundary curve
VX_NUM_DATA | number defined by a VDATA object
VX_UNDEF | undefined
VX_NUM | dimensionless number (e.g. curve degree)
VX_DST | distance (mm)
VX_ANG | angle (deg)
VX_MASS | mass (kg)
VX_DENSITY | density (kg/m3)
VX_AREA | area (m2)
VX_VOLUME | volume (m3)
VX_MASS_MOMENT | mass moments (kg.mm2)

Definition at line 1495 of file zwapi_util.h.

1496 {
1497 /* output type VeNumType*/
1498 VX_NUM_UNDEFINED = -1,
1499 VX_NUM_NULL = 0,
1500 VX_NUM_TO_FACE = 1,
1501 VX_NUM_FACE_BND = 2,
1502 VX_NUM_TO_PNT = 3,
1503 VX_NUM_THRU_PLUS = 4,
1504 VX_NUM_THRU_MINUS = 5,
1505 VX_NUM_CURVE_BND = 6,
1506 VX_NUM_DATA = 7,
1507 /* input type VeNumClass*/
1508 VX_UNDEF = 0,
1509 VX_NUM = 1,
1510 VX_DST = 2,
1511 VX_ANG = 3,
1512 VX_MASS = 4,
1513 VX_DENSITY = 5,
1514 VX_AREA = 6,
1515 VX_VOLUME = 7,
1516 VX_MASS_MOMENT = 8
1517 } evxNumType;
evxNumType
evxNumType
numeric input data types
Definition: zwapi_util.h:1496
VX_ANG
@ VX_ANG
angle (deg)
Definition: zwapi_util.h:1511
VX_MASS
@ VX_MASS
mass (kg)
Definition: zwapi_util.h:1512
VX_NUM_FACE_BND
@ VX_NUM_FACE_BND
boundary face
Definition: zwapi_util.h:1501
VX_VOLUME
@ VX_VOLUME
volume (m3)
Definition: zwapi_util.h:1515
VX_NUM_THRU_PLUS
@ VX_NUM_THRU_PLUS
"through all" in positive direction
Definition: zwapi_util.h:1503
VX_NUM_CURVE_BND
@ VX_NUM_CURVE_BND
boundary curve
Definition: zwapi_util.h:1505
VX_NUM_TO_FACE
@ VX_NUM_TO_FACE
distance/angle to face
Definition: zwapi_util.h:1500
VX_NUM_THRU_MINUS
@ VX_NUM_THRU_MINUS
"through all" in negative direction
Definition: zwapi_util.h:1504
VX_NUM_UNDEFINED
@ VX_NUM_UNDEFINED
undefined
Definition: zwapi_util.h:1498
VX_NUM_NULL
@ VX_NUM_NULL
undefined
Definition: zwapi_util.h:1499
VX_MASS_MOMENT
@ VX_MASS_MOMENT
mass moments (kg.mm2)
Definition: zwapi_util.h:1516
VX_UNDEF
@ VX_UNDEF
undefined
Definition: zwapi_util.h:1508
VX_DST
@ VX_DST
distance (mm)
Definition: zwapi_util.h:1510
VX_DENSITY
@ VX_DENSITY
density (kg/m3)
Definition: zwapi_util.h:1513
VX_NUM_TO_PNT
@ VX_NUM_TO_PNT
distance/angle to point
Definition: zwapi_util.h:1502
VX_NUM
@ VX_NUM
dimensionless number (e.g. curve degree)
Definition: zwapi_util.h:1509
VX_NUM_DATA
@ VX_NUM_DATA
number defined by a VDATA object
Definition: zwapi_util.h:1506
VX_AREA
@ VX_AREA
area (m2)
Definition: zwapi_util.h:1514
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxTermType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxTermType

enum evxTermType

#include <zwapi_util.h>

terminator types

Enumerator
VX_TERM_OFF | arrowhead style: suppressed
VX_TERM_ARROW_15 | arrowhead style: arrow with 15-degree angle
VX_TERM_ARROW_30 | arrowhead style: arrow with 30-degree angle
VX_TERM_ARROW_60 | arrowhead style: arrow with 60-degree angle
VX_TERM_ARROW_H15 | arrowhead style: unfilled triangle with 15-degree angle
VX_TERM_ARROW_H30 | arrowhead style: unfilled triangle with 30-degree angle
VX_TERM_ARROW_H60 | arrowhead style: unfilled triangle with 60-degree angle
VX_TERM_ARROW_HF15 | arrowhead style: filled triangle with 15-degree angle
VX_TERM_ARROW_HF30 | arrowhead style: filled triangle with 30-degree angle
VX_TERM_ARROW_HF60 | arrowhead style: filled triangle with 60-degree angle
VX_TERM_TICK | arrowhead style: tick
VX_TERM_DOT | arrowhead style: unfilled point
VX_TERM_DOTF | arrowhead style: filled point

Definition at line 2192 of file zwapi_util.h.

2193 {
2194 VX_TERM_OFF = 0,
2195 VX_TERM_ARROW_15 = 1,
2196 VX_TERM_ARROW_30,
2197 VX_TERM_ARROW_60,
2198 VX_TERM_ARROW_H15,
2199 VX_TERM_ARROW_H30,
2200 VX_TERM_ARROW_H60,
2201 VX_TERM_ARROW_HF15,
2202 VX_TERM_ARROW_HF30,
2203 VX_TERM_ARROW_HF60,
2204 VX_TERM_TICK,
2205 VX_TERM_DOT,
2206 VX_TERM_DOTF
2207 } evxTermType;
evxTermType
evxTermType
terminator types
Definition: zwapi_util.h:2193
VX_TERM_ARROW_HF15
@ VX_TERM_ARROW_HF15
arrowhead style: filled triangle with 15-degree angle
Definition: zwapi_util.h:2201
VX_TERM_ARROW_HF60
@ VX_TERM_ARROW_HF60
arrowhead style: filled triangle with 60-degree angle
Definition: zwapi_util.h:2203
VX_TERM_DOT
@ VX_TERM_DOT
arrowhead style: unfilled point
Definition: zwapi_util.h:2205
VX_TERM_ARROW_15
@ VX_TERM_ARROW_15
arrowhead style: arrow with 15-degree angle
Definition: zwapi_util.h:2195
VX_TERM_DOTF
@ VX_TERM_DOTF
arrowhead style: filled point
Definition: zwapi_util.h:2206
VX_TERM_TICK
@ VX_TERM_TICK
arrowhead style: tick
Definition: zwapi_util.h:2204
VX_TERM_ARROW_30
@ VX_TERM_ARROW_30
arrowhead style: arrow with 30-degree angle
Definition: zwapi_util.h:2196
VX_TERM_ARROW_H60
@ VX_TERM_ARROW_H60
arrowhead style: unfilled triangle with 60-degree angle
Definition: zwapi_util.h:2200
VX_TERM_ARROW_HF30
@ VX_TERM_ARROW_HF30
arrowhead style: filled triangle with 30-degree angle
Definition: zwapi_util.h:2202
VX_TERM_ARROW_H15
@ VX_TERM_ARROW_H15
arrowhead style: unfilled triangle with 15-degree angle
Definition: zwapi_util.h:2198
VX_TERM_ARROW_60
@ VX_TERM_ARROW_60
arrowhead style: arrow with 60-degree angle
Definition: zwapi_util.h:2197
VX_TERM_ARROW_H30
@ VX_TERM_ARROW_H30
arrowhead style: unfilled triangle with 30-degree angle
Definition: zwapi_util.h:2199
VX_TERM_OFF
@ VX_TERM_OFF
arrowhead style: suppressed
Definition: zwapi_util.h:2194
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxColor

enum evxColor

#include <zwapi_util.h>

standard colors + index colors (see cvxColorRGB() for RGB color components)

Enumerator
VX_COLOR_GREEN | R=0, G=255, B=0.
VX_COLOR_RED | R=255, G=0, B=0.
VX_COLOR_BROWN | R=160, G=96, B=0.
VX_COLOR_GOLDENROD | R=255, G=188, B=0.
VX_COLOR_MED_BLUE | R=0, G=255, B=255.
VX_COLOR_DARK_MAGENTA | R=255, G=0, B=255.
VX_COLOR_DARK_GREY | R=96, G=96, B=96.
VX_COLOR_DARK_BLUE | R=0, G=0, B=255.
VX_COLOR_VIOLET | R=140, G=140, B=235.
VX_COLOR_LIGHT_GREEN | R=160, G=255, B=160.
VX_COLOR_LIGHT_BLUE | R=160, G=255, B=255.
VX_COLOR_ROSE | R=255, G=160, B=160.
VX_COLOR_LIGHT_MAGENTA | R=255, G=160, B=255.
VX_COLOR_LIGHT_GREY | R=160, G=160, B=160.
VX_COLOR_WHITE | R=255, G=255, B=255.
VX_COLOR_BLACK | R=0, G=0, B=0.
VX_COLOR_YELLOW | R=255, G=255, B=0.
VX_COLOR_MED_GREY | R=135, G=160, B=130.
VX_COLOR_PURPLE | R=102, G=0, B=153.
VX_COLOR_INDEX20 | R=255, G=63, B=0
VX_COLOR_INDEX21 | R=255, G=127, B=127, index color 11.
VX_COLOR_INDEX22 | R=204, G=51, B=0
VX_COLOR_INDEX23 | R=204, G=127, B=102.
VX_COLOR_INDEX24 | R=153, G=38, B=0
VX_COLOR_INDEX25 | R=153, G=95, B=76
VX_COLOR_INDEX26 | R=127, G=31, B=0
VX_COLOR_INDEX27 | R=127, G=79, B=63
VX_COLOR_INDEX28 | R=76, G=19, B=0
VX_COLOR_INDEX29 | R=76, G=47, B=38
VX_COLOR_INDEX30 | R=255, G=127, B=0
VX_COLOR_INDEX31 | R=255, G=191, B=127.
VX_COLOR_INDEX32 | R=204, G=102, B=0
VX_COLOR_INDEX33 | R=204, G=153, B=102.
VX_COLOR_INDEX34 | R=153, G=76, B=0
VX_COLOR_INDEX35 | R=153, G=114, B=76
VX_COLOR_INDEX36 | R=127, G=63, B=0
VX_COLOR_INDEX37 | R=127, G=95, B=63
VX_COLOR_INDEX38 | R=76, G=38, B=0
VX_COLOR_INDEX39 | R=76, G=57, B=38
VX_COLOR_INDEX40 | R=204, G=0, B=0, index color 12
VX_COLOR_INDEX41 | R=255, G=223, B=127.
VX_COLOR_INDEX42 | R=204, G=153, B=0
VX_COLOR_INDEX43 | R=204, G=178, B=102.
VX_COLOR_INDEX44 | R=204, G=102, B=102, index color 13.
VX_COLOR_INDEX45 | R=153, G=133, B=76
VX_COLOR_INDEX46 | R=127, G=95, B=0
VX_COLOR_INDEX47 | R=127, G=111, B=63
VX_COLOR_INDEX48 | R=76, G=57, B=0
VX_COLOR_INDEX49 | R=76, G=66, B=38
VX_COLOR_INDEX50 | R=153, G=0, B=0, index color 14
VX_COLOR_INDEX51 | R=255, G=255, B=127.
VX_COLOR_INDEX52 | R=204, G=204, B=0
VX_COLOR_INDEX53 | R=204, G=204, B=102.
VX_COLOR_INDEX54 | R=153, G=153, B=0
VX_COLOR_INDEX55 | R=153, G=153, B=76
VX_COLOR_INDEX56 | R=127, G=127, B=0
VX_COLOR_INDEX57 | R=127, G=127, B=63
VX_COLOR_INDEX58 | R=76, G=76, B=0
VX_COLOR_INDEX59 | R=76, G=76, B=38
VX_COLOR_INDEX60 | R=191, G=255, B=0
VX_COLOR_INDEX61 | R=223, G=255, B=127.
VX_COLOR_INDEX62 | R=153, G=204, B=0
VX_COLOR_INDEX63 | R=178, G=204, B=102.
VX_COLOR_INDEX64 | R=114, G=153, B=0
VX_COLOR_INDEX65 | R=133, G=153, B=76
VX_COLOR_INDEX66 | R=95, G=127, B=0
VX_COLOR_INDEX67 | R=111, G=127, B=63
VX_COLOR_INDEX68 | R=57, G=76, B=0
VX_COLOR_INDEX69 | R=66, G=76, B=38
VX_COLOR_INDEX70 | R=127, G=255, B=0
VX_COLOR_INDEX71 | R=191, G=255, B=127.
VX_COLOR_INDEX72 | R=102, G=204, B=0
VX_COLOR_INDEX73 | R=153, G=204, B=102.
VX_COLOR_INDEX74 | R=76, G=153, B=0
VX_COLOR_INDEX75 | R=114, G=153, B=76
VX_COLOR_INDEX76 | R=63, G=127, B=0
VX_COLOR_INDEX77 | R=95, G=127, B=63
VX_COLOR_INDEX78 | R=38, G=76, B=0
VX_COLOR_INDEX79 | R=57, G=76, B=38
VX_COLOR_INDEX80 | R=63, G=255, B=0
VX_COLOR_INDEX81 | R=153, G=76, B=76, index color 15
VX_COLOR_INDEX82 | R=51, G=204, B=0
VX_COLOR_INDEX83 | R=127, G=204, B=102.
VX_COLOR_INDEX84 | R=38, G=153, B=0
VX_COLOR_INDEX85 | R=95, G=153, B=76
VX_COLOR_INDEX86 | R=31, G=127, B=0
VX_COLOR_INDEX87 | R=79, G=127, B=63
VX_COLOR_INDEX88 | R=19, G=76, B=0
VX_COLOR_INDEX89 | R=47, G=76, B=28
VX_COLOR_INDEX90 | R=127, G=0, B=0, index color 16
VX_COLOR_INDEX91 | R=127, G=255, B=127.
VX_COLOR_INDEX92 | R=0, G=204, B=0
VX_COLOR_INDEX93 | R=102, G=204, B=102.
VX_COLOR_INDEX94 | R=0, G=153, B=0
VX_COLOR_INDEX95 | R=76, G=153, B=76
VX_COLOR_INDEX96 | R=0, G=127, B=0
VX_COLOR_INDEX97 | R=63, G=127, B=63
VX_COLOR_INDEX98 | R=0, G=76, B=0
VX_COLOR_INDEX99 | R=38, G=76, B=38
VX_COLOR_INDEX100 | R=0, G=255, B=63
VX_COLOR_INDEX101 | R=127, G=255, B=159.
VX_COLOR_INDEX102 | R=0, G=204, B=51
VX_COLOR_INDEX103 | R=102, G=204, B=127.
VX_COLOR_INDEX104 | R=0, G=153, B=38
VX_COLOR_INDEX105 | R=76, G=153, B=95
VX_COLOR_INDEX106 | R=0, G=127, B=31
VX_COLOR_INDEX107 | R=63, G=127, B=79
VX_COLOR_INDEX108 | R=0, G=76, B=19
VX_COLOR_INDEX109 | R=38, G=76, B=47
VX_COLOR_INDEX110 | R=0, G=255, B=127.
VX_COLOR_INDEX111 | R=127, G=255, B=191.
VX_COLOR_INDEX112 | R=0, G=204, B=102.
VX_COLOR_INDEX113 | R=102, G=204, B=153.
VX_COLOR_INDEX114 | R=0, G=153, B=76
VX_COLOR_INDEX115 | R=76, G=153, B=114.
VX_COLOR_INDEX116 | R=0, G=127, B=63
VX_COLOR_INDEX117 | R=63, G=127, B=95
VX_COLOR_INDEX118 | R=0, G=76, B=38
VX_COLOR_INDEX119 | R=38, G=76, B=57
VX_COLOR_INDEX120 | R=0, G=255, B=191.
VX_COLOR_INDEX121 | R=127, G=255, B=223.
VX_COLOR_INDEX122 | R=0, G=204, B=153.
VX_COLOR_INDEX123 | R=102, G=204, B=178.
VX_COLOR_INDEX124 | R=0, G=153, B=114.
VX_COLOR_INDEX125 | R=76, G=153, B=133.
VX_COLOR_INDEX126 | R=0, G=127, B=95
VX_COLOR_INDEX127 | R=63, G=127, B=111.
VX_COLOR_INDEX128 | R=0, G=76, B=57
VX_COLOR_INDEX129 | R=38, G=76, B=66
VX_COLOR_INDEX130 | R=127, G=63, B=63, index color 17
VX_COLOR_INDEX131 | R=76, G=38, B=38, index color 19
VX_COLOR_INDEX132 | R=0, G=204, B=204.
VX_COLOR_INDEX133 | R=102, G=204, B=204.
VX_COLOR_INDEX134 | R=0, G=153, B=153.
VX_COLOR_INDEX135 | R=76, G=153, B=153.
VX_COLOR_INDEX136 | R=0, G=127, B=127.
VX_COLOR_INDEX137 | R=63, G=127, B=127.
VX_COLOR_INDEX138 | R=0, G=76, B=76
VX_COLOR_INDEX139 | R=38, G=76, B=76
VX_COLOR_INDEX140 | R=0, G=191, B=255.
VX_COLOR_INDEX141 | R=127, G=223, B=255.
VX_COLOR_INDEX142 | R=0, G=153, B=204.
VX_COLOR_INDEX143 | R=102, G=178, B=204.
VX_COLOR_INDEX144 | R=0, G=114, B=153.
VX_COLOR_INDEX145 | R=76, G=133, B=153.
VX_COLOR_INDEX146 | R=0, G=95, B=127.
VX_COLOR_INDEX147 | R=63, G=111, B=127.
VX_COLOR_INDEX148 | R=0, G=57, B=76
VX_COLOR_INDEX149 | R=38, G=66, B=76
VX_COLOR_INDEX150 | R=0, G=127, B=255.
VX_COLOR_INDEX151 | R=127, G=191, B=255.
VX_COLOR_INDEX152 | R=0, G=102, B=204.
VX_COLOR_INDEX153 | R=102, G=153, B=204.
VX_COLOR_INDEX154 | R=0, G=76, B=153.
VX_COLOR_INDEX155 | R=76, G=114, B=153.
VX_COLOR_INDEX156 | R=0, G=63, B=127.
VX_COLOR_INDEX157 | R=63, G=95, B=127.
VX_COLOR_INDEX158 | R=0, G=38, B=76
VX_COLOR_INDEX159 | R=38, G=57, B=76
VX_COLOR_INDEX160 | R=0, G=63, B=255.
VX_COLOR_INDEX161 | R=127, G=159, B=255.
VX_COLOR_INDEX162 | R=0, G=51, B=204.
VX_COLOR_INDEX163 | R=102, G=127, B=204.
VX_COLOR_INDEX164 | R=0, G=38, B=153.
VX_COLOR_INDEX165 | R=76, G=95, B=153.
VX_COLOR_INDEX166 | R=0, G=31, B=127.
VX_COLOR_INDEX167 | R=63, G=79, B=127.
VX_COLOR_INDEX168 | R=0, G=19, B=76
VX_COLOR_INDEX169 | R=38, G=47, B=76
VX_COLOR_INDEX170 | R=255, G=127, B=159, index color 241.
VX_COLOR_INDEX171 | R=204, G=0, B=51, index color 242
VX_COLOR_INDEX172 | R=0, G=0, B=204.
VX_COLOR_INDEX173 | R=102, G=102, B=204.
VX_COLOR_INDEX174 | R=0, G=0, B=153.
VX_COLOR_INDEX175 | R=76, G=76, B=153.
VX_COLOR_INDEX176 | R=0, G=0, B=127.
VX_COLOR_INDEX177 | R=63, G=63, B=127.
VX_COLOR_INDEX178 | R=0, G=0, B=76
VX_COLOR_INDEX179 | R=38, G=38, B=76
VX_COLOR_INDEX180 | R=63, G=0, B=255.
VX_COLOR_INDEX181 | R=159, G=127, B=255.
VX_COLOR_INDEX182 | R=51, G=0, B=204.
VX_COLOR_INDEX183 | R=127, G=102, B=204.
VX_COLOR_INDEX184 | R=38, G=0, B=153.
VX_COLOR_INDEX185 | R=95, G=76, B=153.
VX_COLOR_INDEX186 | R=31, G=0, B=127.
VX_COLOR_INDEX187 | R=79, G=63, B=127.
VX_COLOR_INDEX188 | R=19, G=0, B=76
VX_COLOR_INDEX189 | R=47, G=38, B=76
VX_COLOR_INDEX190 | R=127, G=0, B=255.
VX_COLOR_INDEX191 | R=191, G=127, B=255.
VX_COLOR_INDEX192 | R=102, G=0, B=204.
VX_COLOR_INDEX193 | R=153, G=102, B=204.
VX_COLOR_INDEX194 | R=76, G=0, B=153.
VX_COLOR_INDEX195 | R=114, G=76, B=153.
VX_COLOR_INDEX196 | R=63, G=0, B=127.
VX_COLOR_INDEX197 | R=95, G=63, B=127.
VX_COLOR_INDEX198 | R=38, G=0, B=76
VX_COLOR_INDEX199 | R=57, G=38, B=76
VX_COLOR_INDEX200 | R=191, G=0, B=255.
VX_COLOR_INDEX201 | R=223, G=127, B=255.
VX_COLOR_INDEX202 | R=153, G=0, B=204.
VX_COLOR_INDEX203 | R=178, G=102, B=204.
VX_COLOR_INDEX204 | R=114, G=0, B=153.
VX_COLOR_INDEX205 | R=133, G=76, B=153.
VX_COLOR_INDEX206 | R=95, G=0, B=127.
VX_COLOR_INDEX207 | R=204, G=102, B=127, index color 243.
VX_COLOR_INDEX208 | R=57, G=0, B=76
VX_COLOR_INDEX209 | R=66, G=38, B=76
VX_COLOR_INDEX210 | R=153, G=0, B=38, index color 244
VX_COLOR_INDEX211 | R=153, G=76, B=95, index color 245
VX_COLOR_INDEX212 | R=204, G=0, B=204.
VX_COLOR_INDEX213 | R=204, G=102, B=204.
VX_COLOR_INDEX214 | R=153, G=0, B=153.
VX_COLOR_INDEX215 | R=153, G=76, B=153.
VX_COLOR_INDEX216 | R=127, G=0, B=127.
VX_COLOR_INDEX217 | R=127, G=63, B=127.
VX_COLOR_INDEX218 | R=76, G=0, B=76
VX_COLOR_INDEX219 | R=76, G=38, B=76
VX_COLOR_INDEX220 | R=255, G=0, B=191.
VX_COLOR_INDEX221 | R=255, G=127, B=223.
VX_COLOR_INDEX222 | R=204, G=0, B=153.
VX_COLOR_INDEX223 | R=204, G=102, B=178.
VX_COLOR_INDEX224 | R=153, G=0, B=114.
VX_COLOR_INDEX225 | R=153, G=76, B=133.
VX_COLOR_INDEX226 | R=127, G=0, B=95
VX_COLOR_INDEX227 | R=127, G=63, B=111.
VX_COLOR_INDEX228 | R=76, G=0, B=57
VX_COLOR_INDEX229 | R=76, G=38, B=66
VX_COLOR_INDEX230 | R=255, G=0, B=127.
VX_COLOR_INDEX231 | R=255, G=127, B=191.
VX_COLOR_INDEX232 | R=204, G=0, B=102.
VX_COLOR_INDEX233 | R=204, G=102, B=153.
VX_COLOR_INDEX234 | R=153, G=0, B=76
VX_COLOR_INDEX235 | R=153, G=76, B=114.
VX_COLOR_INDEX236 | R=127, G=0, B=63
VX_COLOR_INDEX237 | R=127, G=63, B=95
VX_COLOR_INDEX238 | R=76, G=0, B=38
VX_COLOR_INDEX239 | R=76, G=38, B=57
VX_COLOR_INDEX240 | R=255, G=0, B=63
VX_COLOR_INDEX241 | R=127, G=0, B=31, index color 246
VX_COLOR_INDEX242 | R=127, G=63, B=79, index color 247
VX_COLOR_INDEX243 | R=76, G=0, B=19, index color 248
VX_COLOR_INDEX244 | R=76, G=38, B=47, index color 249

Definition at line 640 of file zwapi_util.h.

641 {
642 VX_COLOR_RGB = -1,
643 VX_COLOR_NULL = 0,
644 VX_COLOR_GREEN = 1,
645 VX_COLOR_RED = 2,
646 VX_COLOR_BROWN = 3,
647 VX_COLOR_GOLDENROD = 4,
648 VX_COLOR_MED_BLUE = 5,
649 VX_COLOR_DARK_MAGENTA = 6,
650 VX_COLOR_DARK_GREY = 7,
651 VX_COLOR_DARK_BLUE = 8,
652 VX_COLOR_VIOLET = 9,
653 VX_COLOR_LIGHT_GREEN = 10,
654 VX_COLOR_LIGHT_BLUE = 11,
655 VX_COLOR_ROSE = 12,
656 VX_COLOR_LIGHT_MAGENTA = 13,
657 VX_COLOR_LIGHT_GREY = 14,
658 VX_COLOR_WHITE = 15,
659 VX_COLOR_BLACK = 16,
660 VX_COLOR_YELLOW = 17,
661 VX_COLOR_MED_GREY = 18,
662 VX_COLOR_PURPLE = 19,
663 VX_COLOR_STANDARD_LAST = VX_COLOR_PURPLE,
664
665 VX_COLOR_INDEX_BEGIN,
666 VX_COLOR_INDEX20 = VX_COLOR_INDEX_BEGIN,
667 VX_COLOR_INDEX21,
668 VX_COLOR_INDEX22,
669 VX_COLOR_INDEX23,
670 VX_COLOR_INDEX24,
671 VX_COLOR_INDEX25,
672 VX_COLOR_INDEX26,
673 VX_COLOR_INDEX27,
674 VX_COLOR_INDEX28,
675 VX_COLOR_INDEX29,
676 VX_COLOR_INDEX30,
677 VX_COLOR_INDEX31,
678 VX_COLOR_INDEX32,
679 VX_COLOR_INDEX33,
680 VX_COLOR_INDEX34,
681 VX_COLOR_INDEX35,
682 VX_COLOR_INDEX36,
683 VX_COLOR_INDEX37,
684 VX_COLOR_INDEX38,
685 VX_COLOR_INDEX39,
686 VX_COLOR_INDEX40,
687 VX_COLOR_INDEX41,
688 VX_COLOR_INDEX42,
689 VX_COLOR_INDEX43,
690 VX_COLOR_INDEX44,
691 VX_COLOR_INDEX45,
692 VX_COLOR_INDEX46,
693 VX_COLOR_INDEX47,
694 VX_COLOR_INDEX48,
695 VX_COLOR_INDEX49,
696 VX_COLOR_INDEX50,
697 VX_COLOR_INDEX51,
698 VX_COLOR_INDEX52,
699 VX_COLOR_INDEX53,
700 VX_COLOR_INDEX54,
701 VX_COLOR_INDEX55,
702 VX_COLOR_INDEX56,
703 VX_COLOR_INDEX57,
704 VX_COLOR_INDEX58,
705 VX_COLOR_INDEX59,
706 VX_COLOR_INDEX60,
707 VX_COLOR_INDEX61,
708 VX_COLOR_INDEX62,
709 VX_COLOR_INDEX63,
710 VX_COLOR_INDEX64,
711 VX_COLOR_INDEX65,
712 VX_COLOR_INDEX66,
713 VX_COLOR_INDEX67,
714 VX_COLOR_INDEX68,
715 VX_COLOR_INDEX69,
716 VX_COLOR_INDEX70,
717 VX_COLOR_INDEX71,
718 VX_COLOR_INDEX72,
719 VX_COLOR_INDEX73,
720 VX_COLOR_INDEX74,
721 VX_COLOR_INDEX75,
722 VX_COLOR_INDEX76,
723 VX_COLOR_INDEX77,
724 VX_COLOR_INDEX78,
725 VX_COLOR_INDEX79,
726 VX_COLOR_INDEX80,
727 VX_COLOR_INDEX81,
728 VX_COLOR_INDEX82,
729 VX_COLOR_INDEX83,
730 VX_COLOR_INDEX84,
731 VX_COLOR_INDEX85,
732 VX_COLOR_INDEX86,
733 VX_COLOR_INDEX87,
734 VX_COLOR_INDEX88,
735 VX_COLOR_INDEX89,
736 VX_COLOR_INDEX90,
737 VX_COLOR_INDEX91,
738 VX_COLOR_INDEX92,
739 VX_COLOR_INDEX93,
740 VX_COLOR_INDEX94,
741 VX_COLOR_INDEX95,
742 VX_COLOR_INDEX96,
743 VX_COLOR_INDEX97,
744 VX_COLOR_INDEX98,
745 VX_COLOR_INDEX99,
746 VX_COLOR_INDEX100,
747 VX_COLOR_INDEX101,
748 VX_COLOR_INDEX102,
749 VX_COLOR_INDEX103,
750 VX_COLOR_INDEX104,
751 VX_COLOR_INDEX105,
752 VX_COLOR_INDEX106,
753 VX_COLOR_INDEX107,
754 VX_COLOR_INDEX108,
755 VX_COLOR_INDEX109,
756 VX_COLOR_INDEX110,
757 VX_COLOR_INDEX111,
758 VX_COLOR_INDEX112,
759 VX_COLOR_INDEX113,
760 VX_COLOR_INDEX114,
761 VX_COLOR_INDEX115,
762 VX_COLOR_INDEX116,
763 VX_COLOR_INDEX117,
764 VX_COLOR_INDEX118,
765 VX_COLOR_INDEX119,
766 VX_COLOR_INDEX120,
767 VX_COLOR_INDEX121,
768 VX_COLOR_INDEX122,
769 VX_COLOR_INDEX123,
770 VX_COLOR_INDEX124,
771 VX_COLOR_INDEX125,
772 VX_COLOR_INDEX126,
773 VX_COLOR_INDEX127,
774 VX_COLOR_INDEX128,
775 VX_COLOR_INDEX129,
776 VX_COLOR_INDEX130,
777 VX_COLOR_INDEX131,
778 VX_COLOR_INDEX132,
779 VX_COLOR_INDEX133,
780 VX_COLOR_INDEX134,
781 VX_COLOR_INDEX135,
782 VX_COLOR_INDEX136,
783 VX_COLOR_INDEX137,
784 VX_COLOR_INDEX138,
785 VX_COLOR_INDEX139,
786 VX_COLOR_INDEX140,
787 VX_COLOR_INDEX141,
788 VX_COLOR_INDEX142,
789 VX_COLOR_INDEX143,
790 VX_COLOR_INDEX144,
791 VX_COLOR_INDEX145,
792 VX_COLOR_INDEX146,
793 VX_COLOR_INDEX147,
794 VX_COLOR_INDEX148,
795 VX_COLOR_INDEX149,
796 VX_COLOR_INDEX150,
797 VX_COLOR_INDEX151,
798 VX_COLOR_INDEX152,
799 VX_COLOR_INDEX153,
800 VX_COLOR_INDEX154,
801 VX_COLOR_INDEX155,
802 VX_COLOR_INDEX156,
803 VX_COLOR_INDEX157,
804 VX_COLOR_INDEX158,
805 VX_COLOR_INDEX159,
806 VX_COLOR_INDEX160,
807 VX_COLOR_INDEX161,
808 VX_COLOR_INDEX162,
809 VX_COLOR_INDEX163,
810 VX_COLOR_INDEX164,
811 VX_COLOR_INDEX165,
812 VX_COLOR_INDEX166,
813 VX_COLOR_INDEX167,
814 VX_COLOR_INDEX168,
815 VX_COLOR_INDEX169,
816 VX_COLOR_INDEX170,
817 VX_COLOR_INDEX171,
818 VX_COLOR_INDEX172,
819 VX_COLOR_INDEX173,
820 VX_COLOR_INDEX174,
821 VX_COLOR_INDEX175,
822 VX_COLOR_INDEX176,
823 VX_COLOR_INDEX177,
824 VX_COLOR_INDEX178,
825 VX_COLOR_INDEX179,
826 VX_COLOR_INDEX180,
827 VX_COLOR_INDEX181,
828 VX_COLOR_INDEX182,
829 VX_COLOR_INDEX183,
830 VX_COLOR_INDEX184,
831 VX_COLOR_INDEX185,
832 VX_COLOR_INDEX186,
833 VX_COLOR_INDEX187,
834 VX_COLOR_INDEX188,
835 VX_COLOR_INDEX189,
836 VX_COLOR_INDEX190,
837 VX_COLOR_INDEX191,
838 VX_COLOR_INDEX192,
839 VX_COLOR_INDEX193,
840 VX_COLOR_INDEX194,
841 VX_COLOR_INDEX195,
842 VX_COLOR_INDEX196,
843 VX_COLOR_INDEX197,
844 VX_COLOR_INDEX198,
845 VX_COLOR_INDEX199,
846 VX_COLOR_INDEX200,
847 VX_COLOR_INDEX201,
848 VX_COLOR_INDEX202,
849 VX_COLOR_INDEX203,
850 VX_COLOR_INDEX204,
851 VX_COLOR_INDEX205,
852 VX_COLOR_INDEX206,
853 VX_COLOR_INDEX207,
854 VX_COLOR_INDEX208,
855 VX_COLOR_INDEX209,
856 VX_COLOR_INDEX210,
857 VX_COLOR_INDEX211,
858 VX_COLOR_INDEX212,
859 VX_COLOR_INDEX213,
860 VX_COLOR_INDEX214,
861 VX_COLOR_INDEX215,
862 VX_COLOR_INDEX216,
863 VX_COLOR_INDEX217,
864 VX_COLOR_INDEX218,
865 VX_COLOR_INDEX219,
866 VX_COLOR_INDEX220,
867 VX_COLOR_INDEX221,
868 VX_COLOR_INDEX222,
869 VX_COLOR_INDEX223,
870 VX_COLOR_INDEX224,
871 VX_COLOR_INDEX225,
872 VX_COLOR_INDEX226,
873 VX_COLOR_INDEX227,
874 VX_COLOR_INDEX228,
875 VX_COLOR_INDEX229,
876 VX_COLOR_INDEX230,
877 VX_COLOR_INDEX231,
878 VX_COLOR_INDEX232,
879 VX_COLOR_INDEX233,
880 VX_COLOR_INDEX234,
881 VX_COLOR_INDEX235,
882 VX_COLOR_INDEX236,
883 VX_COLOR_INDEX237,
884 VX_COLOR_INDEX238,
885 VX_COLOR_INDEX239,
886 VX_COLOR_INDEX240,
887 VX_COLOR_INDEX241,
888 VX_COLOR_INDEX242,
889 VX_COLOR_INDEX243,
890 VX_COLOR_INDEX244,
891 VX_COLOR_INDEX_LAST = VX_COLOR_INDEX244,
892 VX_COLOR_LAST
893 } evxColor;
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
VX_COLOR_BROWN
@ VX_COLOR_BROWN
R=160, G=96, B=0.
Definition: zwapi_util.h:646
VX_COLOR_INDEX240
@ VX_COLOR_INDEX240
R=255, G=0, B=63
Definition: zwapi_util.h:886
VX_COLOR_INDEX39
@ VX_COLOR_INDEX39
R=76, G=57, B=38
Definition: zwapi_util.h:685
VX_COLOR_INDEX226
@ VX_COLOR_INDEX226
R=127, G=0, B=95
Definition: zwapi_util.h:872
VX_COLOR_INDEX71
@ VX_COLOR_INDEX71
R=191, G=255, B=127.
Definition: zwapi_util.h:717
VX_COLOR_INDEX98
@ VX_COLOR_INDEX98
R=0, G=76, B=0
Definition: zwapi_util.h:744
VX_COLOR_INDEX70
@ VX_COLOR_INDEX70
R=127, G=255, B=0
Definition: zwapi_util.h:716
VX_COLOR_INDEX38
@ VX_COLOR_INDEX38
R=76, G=38, B=0
Definition: zwapi_util.h:684
VX_COLOR_INDEX130
@ VX_COLOR_INDEX130
R=127, G=63, B=63, index color 17
Definition: zwapi_util.h:776
VX_COLOR_INDEX231
@ VX_COLOR_INDEX231
R=255, G=127, B=191.
Definition: zwapi_util.h:877
VX_COLOR_INDEX188
@ VX_COLOR_INDEX188
R=19, G=0, B=76
Definition: zwapi_util.h:834
VX_COLOR_INDEX93
@ VX_COLOR_INDEX93
R=102, G=204, B=102.
Definition: zwapi_util.h:739
VX_COLOR_INDEX103
@ VX_COLOR_INDEX103
R=102, G=204, B=127.
Definition: zwapi_util.h:749
VX_COLOR_INDEX213
@ VX_COLOR_INDEX213
R=204, G=102, B=204.
Definition: zwapi_util.h:859
VX_COLOR_INDEX235
@ VX_COLOR_INDEX235
R=153, G=76, B=114.
Definition: zwapi_util.h:881
VX_COLOR_INDEX94
@ VX_COLOR_INDEX94
R=0, G=153, B=0
Definition: zwapi_util.h:740
VX_COLOR_INDEX86
@ VX_COLOR_INDEX86
R=31, G=127, B=0
Definition: zwapi_util.h:732
VX_COLOR_INDEX236
@ VX_COLOR_INDEX236
R=127, G=0, B=63
Definition: zwapi_util.h:882
VX_COLOR_INDEX57
@ VX_COLOR_INDEX57
R=127, G=127, B=63
Definition: zwapi_util.h:703
VX_COLOR_INDEX173
@ VX_COLOR_INDEX173
R=102, G=102, B=204.
Definition: zwapi_util.h:819
VX_COLOR_INDEX137
@ VX_COLOR_INDEX137
R=63, G=127, B=127.
Definition: zwapi_util.h:783
VX_COLOR_INDEX203
@ VX_COLOR_INDEX203
R=178, G=102, B=204.
Definition: zwapi_util.h:849
VX_COLOR_INDEX45
@ VX_COLOR_INDEX45
R=153, G=133, B=76
Definition: zwapi_util.h:691
VX_COLOR_INDEX172
@ VX_COLOR_INDEX172
R=0, G=0, B=204.
Definition: zwapi_util.h:818
VX_COLOR_INDEX53
@ VX_COLOR_INDEX53
R=204, G=204, B=102.
Definition: zwapi_util.h:699
VX_COLOR_INDEX87
@ VX_COLOR_INDEX87
R=79, G=127, B=63
Definition: zwapi_util.h:733
VX_COLOR_INDEX34
@ VX_COLOR_INDEX34
R=153, G=76, B=0
Definition: zwapi_util.h:680
VX_COLOR_INDEX83
@ VX_COLOR_INDEX83
R=127, G=204, B=102.
Definition: zwapi_util.h:729
VX_COLOR_INDEX66
@ VX_COLOR_INDEX66
R=95, G=127, B=0
Definition: zwapi_util.h:712
VX_COLOR_INDEX214
@ VX_COLOR_INDEX214
R=153, G=0, B=153.
Definition: zwapi_util.h:860
VX_COLOR_INDEX80
@ VX_COLOR_INDEX80
R=63, G=255, B=0
Definition: zwapi_util.h:726
VX_COLOR_GOLDENROD
@ VX_COLOR_GOLDENROD
R=255, G=188, B=0.
Definition: zwapi_util.h:647
VX_COLOR_INDEX115
@ VX_COLOR_INDEX115
R=76, G=153, B=114.
Definition: zwapi_util.h:761
VX_COLOR_INDEX222
@ VX_COLOR_INDEX222
R=204, G=0, B=153.
Definition: zwapi_util.h:868
VX_COLOR_INDEX241
@ VX_COLOR_INDEX241
R=127, G=0, B=31, index color 246
Definition: zwapi_util.h:887
VX_COLOR_INDEX97
@ VX_COLOR_INDEX97
R=63, G=127, B=63
Definition: zwapi_util.h:743
VX_COLOR_VIOLET
@ VX_COLOR_VIOLET
R=140, G=140, B=235.
Definition: zwapi_util.h:652
VX_COLOR_INDEX28
@ VX_COLOR_INDEX28
R=76, G=19, B=0
Definition: zwapi_util.h:674
VX_COLOR_INDEX50
@ VX_COLOR_INDEX50
R=153, G=0, B=0, index color 14
Definition: zwapi_util.h:696
VX_COLOR_INDEX148
@ VX_COLOR_INDEX148
R=0, G=57, B=76
Definition: zwapi_util.h:794
VX_COLOR_INDEX232
@ VX_COLOR_INDEX232
R=204, G=0, B=102.
Definition: zwapi_util.h:878
VX_COLOR_INDEX164
@ VX_COLOR_INDEX164
R=0, G=38, B=153.
Definition: zwapi_util.h:810
VX_COLOR_INDEX239
@ VX_COLOR_INDEX239
R=76, G=38, B=57
Definition: zwapi_util.h:885
VX_COLOR_INDEX158
@ VX_COLOR_INDEX158
R=0, G=38, B=76
Definition: zwapi_util.h:804
VX_COLOR_INDEX152
@ VX_COLOR_INDEX152
R=0, G=102, B=204.
Definition: zwapi_util.h:798
VX_COLOR_INDEX182
@ VX_COLOR_INDEX182
R=51, G=0, B=204.
Definition: zwapi_util.h:828
VX_COLOR_INDEX215
@ VX_COLOR_INDEX215
R=153, G=76, B=153.
Definition: zwapi_util.h:861
VX_COLOR_INDEX233
@ VX_COLOR_INDEX233
R=204, G=102, B=153.
Definition: zwapi_util.h:879
VX_COLOR_INDEX194
@ VX_COLOR_INDEX194
R=76, G=0, B=153.
Definition: zwapi_util.h:840
VX_COLOR_INDEX202
@ VX_COLOR_INDEX202
R=153, G=0, B=204.
Definition: zwapi_util.h:848
VX_COLOR_DARK_BLUE
@ VX_COLOR_DARK_BLUE
R=0, G=0, B=255.
Definition: zwapi_util.h:651
VX_COLOR_PURPLE
@ VX_COLOR_PURPLE
R=102, G=0, B=153.
Definition: zwapi_util.h:662
VX_COLOR_INDEX44
@ VX_COLOR_INDEX44
R=204, G=102, B=102, index color 13.
Definition: zwapi_util.h:690
VX_COLOR_INDEX96
@ VX_COLOR_INDEX96
R=0, G=127, B=0
Definition: zwapi_util.h:742
VX_COLOR_INDEX157
@ VX_COLOR_INDEX157
R=63, G=95, B=127.
Definition: zwapi_util.h:803
VX_COLOR_INDEX178
@ VX_COLOR_INDEX178
R=0, G=0, B=76
Definition: zwapi_util.h:824
VX_COLOR_INDEX122
@ VX_COLOR_INDEX122
R=0, G=204, B=153.
Definition: zwapi_util.h:768
VX_COLOR_INDEX27
@ VX_COLOR_INDEX27
R=127, G=79, B=63
Definition: zwapi_util.h:673
VX_COLOR_INDEX59
@ VX_COLOR_INDEX59
R=76, G=76, B=38
Definition: zwapi_util.h:705
VX_COLOR_INDEX95
@ VX_COLOR_INDEX95
R=76, G=153, B=76
Definition: zwapi_util.h:741
VX_COLOR_INDEX85
@ VX_COLOR_INDEX85
R=95, G=153, B=76
Definition: zwapi_util.h:731
VX_COLOR_INDEX198
@ VX_COLOR_INDEX198
R=38, G=0, B=76
Definition: zwapi_util.h:844
VX_COLOR_INDEX207
@ VX_COLOR_INDEX207
R=204, G=102, B=127, index color 243.
Definition: zwapi_util.h:853
VX_COLOR_INDEX204
@ VX_COLOR_INDEX204
R=114, G=0, B=153.
Definition: zwapi_util.h:850
VX_COLOR_INDEX227
@ VX_COLOR_INDEX227
R=127, G=63, B=111.
Definition: zwapi_util.h:873
VX_COLOR_INDEX229
@ VX_COLOR_INDEX229
R=76, G=38, B=66
Definition: zwapi_util.h:875
VX_COLOR_INDEX126
@ VX_COLOR_INDEX126
R=0, G=127, B=95
Definition: zwapi_util.h:772
VX_COLOR_INDEX20
@ VX_COLOR_INDEX20
R=255, G=63, B=0
Definition: zwapi_util.h:666
VX_COLOR_INDEX184
@ VX_COLOR_INDEX184
R=38, G=0, B=153.
Definition: zwapi_util.h:830
VX_COLOR_INDEX183
@ VX_COLOR_INDEX183
R=127, G=102, B=204.
Definition: zwapi_util.h:829
VX_COLOR_INDEX104
@ VX_COLOR_INDEX104
R=0, G=153, B=38
Definition: zwapi_util.h:750
VX_COLOR_INDEX185
@ VX_COLOR_INDEX185
R=95, G=76, B=153.
Definition: zwapi_util.h:831
VX_COLOR_INDEX61
@ VX_COLOR_INDEX61
R=223, G=255, B=127.
Definition: zwapi_util.h:707
VX_COLOR_INDEX133
@ VX_COLOR_INDEX133
R=102, G=204, B=204.
Definition: zwapi_util.h:779
VX_COLOR_INDEX26
@ VX_COLOR_INDEX26
R=127, G=31, B=0
Definition: zwapi_util.h:672
VX_COLOR_INDEX219
@ VX_COLOR_INDEX219
R=76, G=38, B=76
Definition: zwapi_util.h:865
VX_COLOR_INDEX191
@ VX_COLOR_INDEX191
R=191, G=127, B=255.
Definition: zwapi_util.h:837
VX_COLOR_INDEX32
@ VX_COLOR_INDEX32
R=204, G=102, B=0
Definition: zwapi_util.h:678
VX_COLOR_INDEX123
@ VX_COLOR_INDEX123
R=102, G=204, B=178.
Definition: zwapi_util.h:769
VX_COLOR_INDEX127
@ VX_COLOR_INDEX127
R=63, G=127, B=111.
Definition: zwapi_util.h:773
VX_COLOR_INDEX140
@ VX_COLOR_INDEX140
R=0, G=191, B=255.
Definition: zwapi_util.h:786
VX_COLOR_INDEX177
@ VX_COLOR_INDEX177
R=63, G=63, B=127.
Definition: zwapi_util.h:823
VX_COLOR_INDEX200
@ VX_COLOR_INDEX200
R=191, G=0, B=255.
Definition: zwapi_util.h:846
VX_COLOR_INDEX74
@ VX_COLOR_INDEX74
R=76, G=153, B=0
Definition: zwapi_util.h:720
VX_COLOR_INDEX91
@ VX_COLOR_INDEX91
R=127, G=255, B=127.
Definition: zwapi_util.h:737
VX_COLOR_INDEX228
@ VX_COLOR_INDEX228
R=76, G=0, B=57
Definition: zwapi_util.h:874
VX_COLOR_INDEX154
@ VX_COLOR_INDEX154
R=0, G=76, B=153.
Definition: zwapi_util.h:800
VX_COLOR_INDEX181
@ VX_COLOR_INDEX181
R=159, G=127, B=255.
Definition: zwapi_util.h:827
VX_COLOR_INDEX101
@ VX_COLOR_INDEX101
R=127, G=255, B=159.
Definition: zwapi_util.h:747
VX_COLOR_INDEX58
@ VX_COLOR_INDEX58
R=76, G=76, B=0
Definition: zwapi_util.h:704
VX_COLOR_INDEX206
@ VX_COLOR_INDEX206
R=95, G=0, B=127.
Definition: zwapi_util.h:852
VX_COLOR_INDEX55
@ VX_COLOR_INDEX55
R=153, G=153, B=76
Definition: zwapi_util.h:701
VX_COLOR_INDEX29
@ VX_COLOR_INDEX29
R=76, G=47, B=38
Definition: zwapi_util.h:675
VX_COLOR_INDEX37
@ VX_COLOR_INDEX37
R=127, G=95, B=63
Definition: zwapi_util.h:683
VX_COLOR_INDEX143
@ VX_COLOR_INDEX143
R=102, G=178, B=204.
Definition: zwapi_util.h:789
VX_COLOR_INDEX242
@ VX_COLOR_INDEX242
R=127, G=63, B=79, index color 247
Definition: zwapi_util.h:888
VX_COLOR_INDEX138
@ VX_COLOR_INDEX138
R=0, G=76, B=76
Definition: zwapi_util.h:784
VX_COLOR_LIGHT_BLUE
@ VX_COLOR_LIGHT_BLUE
R=160, G=255, B=255.
Definition: zwapi_util.h:654
VX_COLOR_INDEX69
@ VX_COLOR_INDEX69
R=66, G=76, B=38
Definition: zwapi_util.h:715
VX_COLOR_INDEX145
@ VX_COLOR_INDEX145
R=76, G=133, B=153.
Definition: zwapi_util.h:791
VX_COLOR_INDEX136
@ VX_COLOR_INDEX136
R=0, G=127, B=127.
Definition: zwapi_util.h:782
VX_COLOR_INDEX107
@ VX_COLOR_INDEX107
R=63, G=127, B=79
Definition: zwapi_util.h:753
VX_COLOR_INDEX192
@ VX_COLOR_INDEX192
R=102, G=0, B=204.
Definition: zwapi_util.h:838
VX_COLOR_INDEX49
@ VX_COLOR_INDEX49
R=76, G=66, B=38
Definition: zwapi_util.h:695
VX_COLOR_INDEX46
@ VX_COLOR_INDEX46
R=127, G=95, B=0
Definition: zwapi_util.h:692
VX_COLOR_INDEX146
@ VX_COLOR_INDEX146
R=0, G=95, B=127.
Definition: zwapi_util.h:792
VX_COLOR_INDEX42
@ VX_COLOR_INDEX42
R=204, G=153, B=0
Definition: zwapi_util.h:688
VX_COLOR_INDEX144
@ VX_COLOR_INDEX144
R=0, G=114, B=153.
Definition: zwapi_util.h:790
VX_COLOR_MED_BLUE
@ VX_COLOR_MED_BLUE
R=0, G=255, B=255.
Definition: zwapi_util.h:648
VX_COLOR_RED
@ VX_COLOR_RED
R=255, G=0, B=0.
Definition: zwapi_util.h:645
VX_COLOR_INDEX150
@ VX_COLOR_INDEX150
R=0, G=127, B=255.
Definition: zwapi_util.h:796
VX_COLOR_INDEX189
@ VX_COLOR_INDEX189
R=47, G=38, B=76
Definition: zwapi_util.h:835
VX_COLOR_INDEX159
@ VX_COLOR_INDEX159
R=38, G=57, B=76
Definition: zwapi_util.h:805
VX_COLOR_INDEX197
@ VX_COLOR_INDEX197
R=95, G=63, B=127.
Definition: zwapi_util.h:843
VX_COLOR_INDEX65
@ VX_COLOR_INDEX65
R=133, G=153, B=76
Definition: zwapi_util.h:711
VX_COLOR_LIGHT_MAGENTA
@ VX_COLOR_LIGHT_MAGENTA
R=255, G=160, B=255.
Definition: zwapi_util.h:656
VX_COLOR_INDEX72
@ VX_COLOR_INDEX72
R=102, G=204, B=0
Definition: zwapi_util.h:718
VX_COLOR_INDEX21
@ VX_COLOR_INDEX21
R=255, G=127, B=127, index color 11.
Definition: zwapi_util.h:667
VX_COLOR_INDEX92
@ VX_COLOR_INDEX92
R=0, G=204, B=0
Definition: zwapi_util.h:738
VX_COLOR_INDEX199
@ VX_COLOR_INDEX199
R=57, G=38, B=76
Definition: zwapi_util.h:845
VX_COLOR_INDEX224
@ VX_COLOR_INDEX224
R=153, G=0, B=114.
Definition: zwapi_util.h:870
VX_COLOR_INDEX114
@ VX_COLOR_INDEX114
R=0, G=153, B=76
Definition: zwapi_util.h:760
VX_COLOR_INDEX208
@ VX_COLOR_INDEX208
R=57, G=0, B=76
Definition: zwapi_util.h:854
VX_COLOR_INDEX125
@ VX_COLOR_INDEX125
R=76, G=153, B=133.
Definition: zwapi_util.h:771
VX_COLOR_INDEX108
@ VX_COLOR_INDEX108
R=0, G=76, B=19
Definition: zwapi_util.h:754
VX_COLOR_INDEX119
@ VX_COLOR_INDEX119
R=38, G=76, B=57
Definition: zwapi_util.h:765
VX_COLOR_INDEX118
@ VX_COLOR_INDEX118
R=0, G=76, B=38
Definition: zwapi_util.h:764
VX_COLOR_INDEX212
@ VX_COLOR_INDEX212
R=204, G=0, B=204.
Definition: zwapi_util.h:858
VX_COLOR_INDEX134
@ VX_COLOR_INDEX134
R=0, G=153, B=153.
Definition: zwapi_util.h:780
VX_COLOR_INDEX35
@ VX_COLOR_INDEX35
R=153, G=114, B=76
Definition: zwapi_util.h:681
VX_COLOR_INDEX88
@ VX_COLOR_INDEX88
R=19, G=76, B=0
Definition: zwapi_util.h:734
VX_COLOR_INDEX225
@ VX_COLOR_INDEX225
R=153, G=76, B=133.
Definition: zwapi_util.h:871
VX_COLOR_INDEX82
@ VX_COLOR_INDEX82
R=51, G=204, B=0
Definition: zwapi_util.h:728
VX_COLOR_INDEX220
@ VX_COLOR_INDEX220
R=255, G=0, B=191.
Definition: zwapi_util.h:866
VX_COLOR_INDEX99
@ VX_COLOR_INDEX99
R=38, G=76, B=38
Definition: zwapi_util.h:745
VX_COLOR_INDEX167
@ VX_COLOR_INDEX167
R=63, G=79, B=127.
Definition: zwapi_util.h:813
VX_COLOR_INDEX216
@ VX_COLOR_INDEX216
R=127, G=0, B=127.
Definition: zwapi_util.h:862
VX_COLOR_INDEX25
@ VX_COLOR_INDEX25
R=153, G=95, B=76
Definition: zwapi_util.h:671
VX_COLOR_INDEX73
@ VX_COLOR_INDEX73
R=153, G=204, B=102.
Definition: zwapi_util.h:719
VX_COLOR_GREEN
@ VX_COLOR_GREEN
R=0, G=255, B=0.
Definition: zwapi_util.h:644
VX_COLOR_INDEX40
@ VX_COLOR_INDEX40
R=204, G=0, B=0, index color 12
Definition: zwapi_util.h:686
VX_COLOR_INDEX52
@ VX_COLOR_INDEX52
R=204, G=204, B=0
Definition: zwapi_util.h:698
VX_COLOR_WHITE
@ VX_COLOR_WHITE
R=255, G=255, B=255.
Definition: zwapi_util.h:658
VX_COLOR_INDEX23
@ VX_COLOR_INDEX23
R=204, G=127, B=102.
Definition: zwapi_util.h:669
VX_COLOR_INDEX156
@ VX_COLOR_INDEX156
R=0, G=63, B=127.
Definition: zwapi_util.h:802
VX_COLOR_INDEX217
@ VX_COLOR_INDEX217
R=127, G=63, B=127.
Definition: zwapi_util.h:863
VX_COLOR_INDEX84
@ VX_COLOR_INDEX84
R=38, G=153, B=0
Definition: zwapi_util.h:730
VX_COLOR_INDEX135
@ VX_COLOR_INDEX135
R=76, G=153, B=153.
Definition: zwapi_util.h:781
VX_COLOR_INDEX48
@ VX_COLOR_INDEX48
R=76, G=57, B=0
Definition: zwapi_util.h:694
VX_COLOR_INDEX155
@ VX_COLOR_INDEX155
R=76, G=114, B=153.
Definition: zwapi_util.h:801
VX_COLOR_INDEX111
@ VX_COLOR_INDEX111
R=127, G=255, B=191.
Definition: zwapi_util.h:757
VX_COLOR_INDEX141
@ VX_COLOR_INDEX141
R=127, G=223, B=255.
Definition: zwapi_util.h:787
VX_COLOR_INDEX171
@ VX_COLOR_INDEX171
R=204, G=0, B=51, index color 242
Definition: zwapi_util.h:817
VX_COLOR_INDEX175
@ VX_COLOR_INDEX175
R=76, G=76, B=153.
Definition: zwapi_util.h:821
VX_COLOR_YELLOW
@ VX_COLOR_YELLOW
R=255, G=255, B=0.
Definition: zwapi_util.h:660
VX_COLOR_DARK_GREY
@ VX_COLOR_DARK_GREY
R=96, G=96, B=96.
Definition: zwapi_util.h:650
VX_COLOR_INDEX211
@ VX_COLOR_INDEX211
R=153, G=76, B=95, index color 245
Definition: zwapi_util.h:857
VX_COLOR_INDEX124
@ VX_COLOR_INDEX124
R=0, G=153, B=114.
Definition: zwapi_util.h:770
VX_COLOR_INDEX210
@ VX_COLOR_INDEX210
R=153, G=0, B=38, index color 244
Definition: zwapi_util.h:856
VX_COLOR_INDEX121
@ VX_COLOR_INDEX121
R=127, G=255, B=223.
Definition: zwapi_util.h:767
VX_COLOR_DARK_MAGENTA
@ VX_COLOR_DARK_MAGENTA
R=255, G=0, B=255.
Definition: zwapi_util.h:649
VX_COLOR_INDEX165
@ VX_COLOR_INDEX165
R=76, G=95, B=153.
Definition: zwapi_util.h:811
VX_COLOR_INDEX149
@ VX_COLOR_INDEX149
R=38, G=66, B=76
Definition: zwapi_util.h:795
VX_COLOR_INDEX209
@ VX_COLOR_INDEX209
R=66, G=38, B=76
Definition: zwapi_util.h:855
VX_COLOR_INDEX116
@ VX_COLOR_INDEX116
R=0, G=127, B=63
Definition: zwapi_util.h:762
VX_COLOR_INDEX47
@ VX_COLOR_INDEX47
R=127, G=111, B=63
Definition: zwapi_util.h:693
VX_COLOR_INDEX234
@ VX_COLOR_INDEX234
R=153, G=0, B=76
Definition: zwapi_util.h:880
VX_COLOR_INDEX243
@ VX_COLOR_INDEX243
R=76, G=0, B=19, index color 248
Definition: zwapi_util.h:889
VX_COLOR_INDEX174
@ VX_COLOR_INDEX174
R=0, G=0, B=153.
Definition: zwapi_util.h:820
VX_COLOR_INDEX112
@ VX_COLOR_INDEX112
R=0, G=204, B=102.
Definition: zwapi_util.h:758
VX_COLOR_INDEX244
@ VX_COLOR_INDEX244
R=76, G=38, B=47, index color 249
Definition: zwapi_util.h:890
VX_COLOR_INDEX221
@ VX_COLOR_INDEX221
R=255, G=127, B=223.
Definition: zwapi_util.h:867
VX_COLOR_INDEX90
@ VX_COLOR_INDEX90
R=127, G=0, B=0, index color 16
Definition: zwapi_util.h:736
VX_COLOR_INDEX160
@ VX_COLOR_INDEX160
R=0, G=63, B=255.
Definition: zwapi_util.h:806
VX_COLOR_INDEX30
@ VX_COLOR_INDEX30
R=255, G=127, B=0
Definition: zwapi_util.h:676
VX_COLOR_INDEX139
@ VX_COLOR_INDEX139
R=38, G=76, B=76
Definition: zwapi_util.h:785
VX_COLOR_INDEX60
@ VX_COLOR_INDEX60
R=191, G=255, B=0
Definition: zwapi_util.h:706
VX_COLOR_INDEX196
@ VX_COLOR_INDEX196
R=63, G=0, B=127.
Definition: zwapi_util.h:842
VX_COLOR_INDEX64
@ VX_COLOR_INDEX64
R=114, G=153, B=0
Definition: zwapi_util.h:710
VX_COLOR_BLACK
@ VX_COLOR_BLACK
R=0, G=0, B=0.
Definition: zwapi_util.h:659
VX_COLOR_INDEX102
@ VX_COLOR_INDEX102
R=0, G=204, B=51
Definition: zwapi_util.h:748
VX_COLOR_INDEX100
@ VX_COLOR_INDEX100
R=0, G=255, B=63
Definition: zwapi_util.h:746
VX_COLOR_INDEX75
@ VX_COLOR_INDEX75
R=114, G=153, B=76
Definition: zwapi_util.h:721
VX_COLOR_INDEX110
@ VX_COLOR_INDEX110
R=0, G=255, B=127.
Definition: zwapi_util.h:756
VX_COLOR_INDEX43
@ VX_COLOR_INDEX43
R=204, G=178, B=102.
Definition: zwapi_util.h:689
VX_COLOR_INDEX193
@ VX_COLOR_INDEX193
R=153, G=102, B=204.
Definition: zwapi_util.h:839
VX_COLOR_INDEX79
@ VX_COLOR_INDEX79
R=57, G=76, B=38
Definition: zwapi_util.h:725
VX_COLOR_INDEX105
@ VX_COLOR_INDEX105
R=76, G=153, B=95
Definition: zwapi_util.h:751
VX_COLOR_INDEX24
@ VX_COLOR_INDEX24
R=153, G=38, B=0
Definition: zwapi_util.h:670
VX_COLOR_INDEX237
@ VX_COLOR_INDEX237
R=127, G=63, B=95
Definition: zwapi_util.h:883
VX_COLOR_MED_GREY
@ VX_COLOR_MED_GREY
R=135, G=160, B=130.
Definition: zwapi_util.h:661
VX_COLOR_INDEX187
@ VX_COLOR_INDEX187
R=79, G=63, B=127.
Definition: zwapi_util.h:833
VX_COLOR_INDEX22
@ VX_COLOR_INDEX22
R=204, G=51, B=0
Definition: zwapi_util.h:668
VX_COLOR_INDEX51
@ VX_COLOR_INDEX51
R=255, G=255, B=127.
Definition: zwapi_util.h:697
VX_COLOR_INDEX106
@ VX_COLOR_INDEX106
R=0, G=127, B=31
Definition: zwapi_util.h:752
VX_COLOR_INDEX201
@ VX_COLOR_INDEX201
R=223, G=127, B=255.
Definition: zwapi_util.h:847
VX_COLOR_INDEX109
@ VX_COLOR_INDEX109
R=38, G=76, B=47
Definition: zwapi_util.h:755
VX_COLOR_INDEX151
@ VX_COLOR_INDEX151
R=127, G=191, B=255.
Definition: zwapi_util.h:797
VX_COLOR_INDEX218
@ VX_COLOR_INDEX218
R=76, G=0, B=76
Definition: zwapi_util.h:864
VX_COLOR_INDEX179
@ VX_COLOR_INDEX179
R=38, G=38, B=76
Definition: zwapi_util.h:825
VX_COLOR_INDEX78
@ VX_COLOR_INDEX78
R=38, G=76, B=0
Definition: zwapi_util.h:724
VX_COLOR_INDEX67
@ VX_COLOR_INDEX67
R=111, G=127, B=63
Definition: zwapi_util.h:713
VX_COLOR_INDEX81
@ VX_COLOR_INDEX81
R=153, G=76, B=76, index color 15
Definition: zwapi_util.h:727
VX_COLOR_ROSE
@ VX_COLOR_ROSE
R=255, G=160, B=160.
Definition: zwapi_util.h:655
VX_COLOR_INDEX77
@ VX_COLOR_INDEX77
R=95, G=127, B=63
Definition: zwapi_util.h:723
VX_COLOR_INDEX163
@ VX_COLOR_INDEX163
R=102, G=127, B=204.
Definition: zwapi_util.h:809
VX_COLOR_INDEX120
@ VX_COLOR_INDEX120
R=0, G=255, B=191.
Definition: zwapi_util.h:766
VX_COLOR_INDEX205
@ VX_COLOR_INDEX205
R=133, G=76, B=153.
Definition: zwapi_util.h:851
VX_COLOR_INDEX68
@ VX_COLOR_INDEX68
R=57, G=76, B=0
Definition: zwapi_util.h:714
VX_COLOR_INDEX31
@ VX_COLOR_INDEX31
R=255, G=191, B=127.
Definition: zwapi_util.h:677
VX_COLOR_INDEX168
@ VX_COLOR_INDEX168
R=0, G=19, B=76
Definition: zwapi_util.h:814
VX_COLOR_LIGHT_GREY
@ VX_COLOR_LIGHT_GREY
R=160, G=160, B=160.
Definition: zwapi_util.h:657
VX_COLOR_INDEX128
@ VX_COLOR_INDEX128
R=0, G=76, B=57
Definition: zwapi_util.h:774
VX_COLOR_INDEX223
@ VX_COLOR_INDEX223
R=204, G=102, B=178.
Definition: zwapi_util.h:869
VX_COLOR_LIGHT_GREEN
@ VX_COLOR_LIGHT_GREEN
R=160, G=255, B=160.
Definition: zwapi_util.h:653
VX_COLOR_INDEX33
@ VX_COLOR_INDEX33
R=204, G=153, B=102.
Definition: zwapi_util.h:679
VX_COLOR_INDEX62
@ VX_COLOR_INDEX62
R=153, G=204, B=0
Definition: zwapi_util.h:708
VX_COLOR_INDEX176
@ VX_COLOR_INDEX176
R=0, G=0, B=127.
Definition: zwapi_util.h:822
VX_COLOR_INDEX162
@ VX_COLOR_INDEX162
R=0, G=51, B=204.
Definition: zwapi_util.h:808
VX_COLOR_INDEX142
@ VX_COLOR_INDEX142
R=0, G=153, B=204.
Definition: zwapi_util.h:788
VX_COLOR_INDEX180
@ VX_COLOR_INDEX180
R=63, G=0, B=255.
Definition: zwapi_util.h:826
VX_COLOR_INDEX36
@ VX_COLOR_INDEX36
R=127, G=63, B=0
Definition: zwapi_util.h:682
VX_COLOR_INDEX54
@ VX_COLOR_INDEX54
R=153, G=153, B=0
Definition: zwapi_util.h:700
VX_COLOR_INDEX129
@ VX_COLOR_INDEX129
R=38, G=76, B=66
Definition: zwapi_util.h:775
VX_COLOR_INDEX113
@ VX_COLOR_INDEX113
R=102, G=204, B=153.
Definition: zwapi_util.h:759
VX_COLOR_INDEX147
@ VX_COLOR_INDEX147
R=63, G=111, B=127.
Definition: zwapi_util.h:793
VX_COLOR_INDEX166
@ VX_COLOR_INDEX166
R=0, G=31, B=127.
Definition: zwapi_util.h:812
VX_COLOR_INDEX76
@ VX_COLOR_INDEX76
R=63, G=127, B=0
Definition: zwapi_util.h:722
VX_COLOR_INDEX230
@ VX_COLOR_INDEX230
R=255, G=0, B=127.
Definition: zwapi_util.h:876
VX_COLOR_INDEX190
@ VX_COLOR_INDEX190
R=127, G=0, B=255.
Definition: zwapi_util.h:836
VX_COLOR_INDEX89
@ VX_COLOR_INDEX89
R=47, G=76, B=28
Definition: zwapi_util.h:735
VX_COLOR_INDEX170
@ VX_COLOR_INDEX170
R=255, G=127, B=159, index color 241.
Definition: zwapi_util.h:816
VX_COLOR_INDEX63
@ VX_COLOR_INDEX63
R=178, G=204, B=102.
Definition: zwapi_util.h:709
VX_COLOR_INDEX56
@ VX_COLOR_INDEX56
R=127, G=127, B=0
Definition: zwapi_util.h:702
VX_COLOR_INDEX238
@ VX_COLOR_INDEX238
R=76, G=0, B=38
Definition: zwapi_util.h:884
VX_COLOR_INDEX169
@ VX_COLOR_INDEX169
R=38, G=47, B=76
Definition: zwapi_util.h:815
VX_COLOR_INDEX186
@ VX_COLOR_INDEX186
R=31, G=0, B=127.
Definition: zwapi_util.h:832
VX_COLOR_INDEX132
@ VX_COLOR_INDEX132
R=0, G=204, B=204.
Definition: zwapi_util.h:778
VX_COLOR_INDEX153
@ VX_COLOR_INDEX153
R=102, G=153, B=204.
Definition: zwapi_util.h:799
VX_COLOR_INDEX161
@ VX_COLOR_INDEX161
R=127, G=159, B=255.
Definition: zwapi_util.h:807
VX_COLOR_INDEX117
@ VX_COLOR_INDEX117
R=63, G=127, B=95
Definition: zwapi_util.h:763
VX_COLOR_INDEX195
@ VX_COLOR_INDEX195
R=114, G=76, B=153.
Definition: zwapi_util.h:841
VX_COLOR_INDEX41
@ VX_COLOR_INDEX41
R=255, G=223, B=127.
Definition: zwapi_util.h:687
VX_COLOR_INDEX131
@ VX_COLOR_INDEX131
R=76, G=38, B=38, index color 19
Definition: zwapi_util.h:777
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxMassMomentUnitType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxMassMomentUnitType

enum evxMassMomentUnitType

#include <zwapi_util.h>

system of mass moment units

Enumerator
VX_UNIT_MASSMOMENT_KGMM2 | kg.mm2
VX_UNIT_MASSMOMENT_KGM2 | kg.m2
VX_UNIT_MASSMOMENT_GMM2 | g.mm2
VX_UNIT_MASSMOMENT_GCM2 | g.cm2
VX_UNIT_MASSMOMENT_LBIN2 | lb.in2
VX_UNIT_MASSMOMENT_LBFT2 | lb.ft2
VX_UNIT_MASSMOMENT_LBYD2 | lb.yd2
VX_UNIT_MASSMOMENT_OZIN2 | oz.in2
VX_UNIT_MASSMOMENT_OZFT2 | oz.ft2
VX_UNIT_MASSMOMENT_OZYD2 | oz.yd2
VX_UNIT_MASSMOMENT_KGDM2 | kg.dm2
VX_UNIT_MASSMOMENT_GDM2 | g.dm2

Definition at line 431 of file zwapi_util.h.

432 {
433 VX_UNIT_MASSMOMENT_KGMM2 = 0,
434 VX_UNIT_MASSMOMENT_KGM2 = 1,
435 VX_UNIT_MASSMOMENT_GMM2 = 2,
436 VX_UNIT_MASSMOMENT_GCM2 = 3,
437 VX_UNIT_MASSMOMENT_LBIN2 = 4,
438 VX_UNIT_MASSMOMENT_LBFT2 = 5,
439 VX_UNIT_MASSMOMENT_LBYD2 = 6,
440 VX_UNIT_MASSMOMENT_OZIN2 = 7,
441 VX_UNIT_MASSMOMENT_OZFT2 = 8,
442 VX_UNIT_MASSMOMENT_OZYD2 = 9,
443 VX_UNIT_MASSMOMENT_KGDM2 = 10,
444 VX_UNIT_MASSMOMENT_GDM2 = 11,
445 } evxMassMomentUnitType;
evxMassMomentUnitType
evxMassMomentUnitType
system of mass moment units
Definition: zwapi_util.h:432
VX_UNIT_MASSMOMENT_OZFT2
@ VX_UNIT_MASSMOMENT_OZFT2
oz.ft2
Definition: zwapi_util.h:441
VX_UNIT_MASSMOMENT_OZIN2
@ VX_UNIT_MASSMOMENT_OZIN2
oz.in2
Definition: zwapi_util.h:440
VX_UNIT_MASSMOMENT_GMM2
@ VX_UNIT_MASSMOMENT_GMM2
g.mm2
Definition: zwapi_util.h:435
VX_UNIT_MASSMOMENT_GDM2
@ VX_UNIT_MASSMOMENT_GDM2
g.dm2
Definition: zwapi_util.h:444
VX_UNIT_MASSMOMENT_KGDM2
@ VX_UNIT_MASSMOMENT_KGDM2
kg.dm2
Definition: zwapi_util.h:443
VX_UNIT_MASSMOMENT_OZYD2
@ VX_UNIT_MASSMOMENT_OZYD2
oz.yd2
Definition: zwapi_util.h:442
VX_UNIT_MASSMOMENT_KGMM2
@ VX_UNIT_MASSMOMENT_KGMM2
kg.mm2
Definition: zwapi_util.h:433
VX_UNIT_MASSMOMENT_LBIN2
@ VX_UNIT_MASSMOMENT_LBIN2
lb.in2
Definition: zwapi_util.h:437
VX_UNIT_MASSMOMENT_LBFT2
@ VX_UNIT_MASSMOMENT_LBFT2
lb.ft2
Definition: zwapi_util.h:438
VX_UNIT_MASSMOMENT_GCM2
@ VX_UNIT_MASSMOMENT_GCM2
g.cm2
Definition: zwapi_util.h:436
VX_UNIT_MASSMOMENT_KGM2
@ VX_UNIT_MASSMOMENT_KGM2
kg.m2
Definition: zwapi_util.h:434
VX_UNIT_MASSMOMENT_LBYD2
@ VX_UNIT_MASSMOMENT_LBYD2
lb.yd2
Definition: zwapi_util.h:439
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEulerAngSeq

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxEulerAngSeq

enum evxEulerAngSeq

#include <zwapi_util.h>

Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.

Enumerator
VX_XYX | X-axis, Y-axis, X-axis.
VX_XZX | X-axis, Z-axis, X-axis.
VX_YXY | Y-axis, X-axis, Y-axis.
VX_YZY | Y-axis, Z-axis, Y-axis.
VX_ZXZ | Z-axis, X-axis, Z-axis.
VX_ZYZ | Z-axis, Y-axis, Z-axis.
VX_RPY | X-axis (Roll), Y-axis (Pitch), Z-axis (Yaw)
VX_RYP | X-axis (Roll), Z-axis (Yaw), Y-axis (Pitch)
VX_PRY | Y-axis (Pitch), X-axis (Roll), Z-axis (Yaw)
VX_PYR | Y-axis (Pitch), Z-axis (Yaw), X-axis (Roll)
VX_YRP | Z-axis (Yaw), X-axis (Roll), Y-axis (Pitch)
VX_YPR | Z-axis (Yaw), Y-axis (Pitch), X-axis (Roll)

Definition at line 504 of file zwapi_util.h.

505 {
506 /*
507 ** Proper Euler Angle - when the first and third rotation are around the same axes.
508 */
509 VX_XYX = 121,
510 VX_XZX = 131,
511 VX_YXY = 212,
512 VX_YZY = 232,
513 VX_ZXZ = 313,
514 VX_ZYZ = 323,
515 /*
516 ** Tait-Bryan or Roll-Pitch-Yaw Angles - when three rotations are around different axes.
517 */
518 VX_RPY = 123,
519 VX_RYP = 132,
520 VX_PRY = 213,
521 VX_PYR = 231,
522 VX_YRP = 312,
523 VX_YPR = 321
524 } evxEulerAngSeq;
evxEulerAngSeq
evxEulerAngSeq
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.
Definition: zwapi_util.h:505
VX_XZX
@ VX_XZX
X-axis, Z-axis, X-axis.
Definition: zwapi_util.h:510
VX_XYX
@ VX_XYX
X-axis, Y-axis, X-axis.
Definition: zwapi_util.h:509
VX_YXY
@ VX_YXY
Y-axis, X-axis, Y-axis.
Definition: zwapi_util.h:511
VX_YRP
@ VX_YRP
Z-axis (Yaw), X-axis (Roll), Y-axis (Pitch)
Definition: zwapi_util.h:522
VX_RYP
@ VX_RYP
X-axis (Roll), Z-axis (Yaw), Y-axis (Pitch)
Definition: zwapi_util.h:519
VX_PRY
@ VX_PRY
Y-axis (Pitch), X-axis (Roll), Z-axis (Yaw)
Definition: zwapi_util.h:520
VX_RPY
@ VX_RPY
X-axis (Roll), Y-axis (Pitch), Z-axis (Yaw)
Definition: zwapi_util.h:518
VX_ZYZ
@ VX_ZYZ
Z-axis, Y-axis, Z-axis.
Definition: zwapi_util.h:514
VX_YZY
@ VX_YZY
Y-axis, Z-axis, Y-axis.
Definition: zwapi_util.h:512
VX_PYR
@ VX_PYR
Y-axis (Pitch), Z-axis (Yaw), X-axis (Roll)
Definition: zwapi_util.h:521
VX_ZXZ
@ VX_ZXZ
Z-axis, X-axis, Z-axis.
Definition: zwapi_util.h:513
VX_YPR
@ VX_YPR
Z-axis (Yaw), Y-axis (Pitch), X-axis (Roll)
Definition: zwapi_util.h:523
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxLineWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxLineWidth

enum evxLineWidth

#include <zwapi_util.h>

line width

Enumerator
VX_WIDTH_UNDEFINED | undefined
VX_WIDTH_018 | 0.18 mm
VX_WIDTH_025 | 0.25 mm
VX_WIDTH_035 | 0.35 mm
VX_WIDTH_050 | 0.50 mm
VX_WIDTH_070 | 0.70 mm
VX_WIDTH_100 | 1.00 mm
VX_WIDTH_BYLAYER | by layer

Definition at line 1433 of file zwapi_util.h.

1434 {
1435 VX_WIDTH_UNDEFINED,
1436 VX_WIDTH_018,
1437 VX_WIDTH_025,
1438 VX_WIDTH_035,
1439 VX_WIDTH_050,
1440 VX_WIDTH_070,
1441 VX_WIDTH_100,
1443 VX_WIDTH_BYLAYER = 0xFF,
1444 } evxLineWidth;
evxLineWidth
evxLineWidth
line width
Definition: zwapi_util.h:1434
VX_WIDTH_018
@ VX_WIDTH_018
0.18 mm
Definition: zwapi_util.h:1436
VX_WIDTH_035
@ VX_WIDTH_035
0.35 mm
Definition: zwapi_util.h:1438
VX_WIDTH_050
@ VX_WIDTH_050
0.50 mm
Definition: zwapi_util.h:1439
VX_WIDTH_BYLAYER
@ VX_WIDTH_BYLAYER
by layer
Definition: zwapi_util.h:1443
VX_WIDTH_070
@ VX_WIDTH_070
0.70 mm
Definition: zwapi_util.h:1440
VX_WIDTH_UNDEFINED
@ VX_WIDTH_UNDEFINED
undefined
Definition: zwapi_util.h:1435
VX_WIDTH_025
@ VX_WIDTH_025
0.25 mm
Definition: zwapi_util.h:1437
VX_WIDTH_100
@ VX_WIDTH_100
1.00 mm
Definition: zwapi_util.h:1441
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxContinuityTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxContinuityTyp

enum evxContinuityTyp

#include <zwapi_util.h>

Continuity option.

Enumerator
VX_CONTIN_NONE | none
VX_CONTIN_G1 | tangent
VX_CONTIN_G2 | curvature
VX_CONTIN_G3 | flow
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 2354 of file zwapi_util.h.

2355 {
2356 VX_CONTIN_NONE = 0,
2357 VX_CONTIN_G1 = 1,
2358 VX_CONTIN_G2 = 2,
2359 VX_CONTIN_G3 = 3,
2360 } evxContinuityTyp;
evxContinuityTyp
evxContinuityTyp
Continuity option.
Definition: zwapi_util.h:2355
VX_CONTIN_G1
@ VX_CONTIN_G1
tangent
Definition: zwapi_util.h:2357
VX_CONTIN_NONE
@ VX_CONTIN_NONE
none
Definition: zwapi_util.h:2356
VX_CONTIN_G3
@ VX_CONTIN_G3
flow
Definition: zwapi_util.h:2359
VX_CONTIN_G2
@ VX_CONTIN_G2
curvature
Definition: zwapi_util.h:2358
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxSurfaceType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxSurfaceType

enum evxSurfaceType

#include <zwapi_util.h>

surface types

Definition at line 1698 of file zwapi_util.h.

1699 {
1700 VX_SRF_PLANE,
1701 VX_SRF_SPHERE,
1702 VX_SRF_CONE,
1703 VX_SRF_GRID,
1704 VX_SRF_CYLINDER,
1705 VX_SRF_EXTRUDE,
1706 VX_SRF_REVOLVE,
1707 VX_SRF_SWEEP_NOT_USED,
1708 VX_SRF_GEN,
1709 VX_SRF_OFFSET,
1710 VX_SRF_MESH,
1711 VX_SRF_RULED,
1712 VX_SRF_HEMIS,
1713 VX_SRF_FRUSTRUM,
1714 VX_SRF_DRAFT,
1715 VX_SRF_DRAFT_NPLN,
1716 VX_SRF_DRAFT_NUV,
1717 VX_SRF_ELLIPSOID,
1718 VX_SRF_3PT_PLANE,
1719 VX_SRF_BILIN_CNVX,
1720 VX_SRF_EXTRUDE_DRFT,
1721 VX_SRF_REVOLVE_PLN,
1722 VX_SRF_TORUS,
1723 VX_SRF_SMD_THCK_FC,
1724 VX_SRF_BEND_GEN,
1725 VX_SRF_PLANE_STAT_FC,
1726 VX_SRF_GEN_STAT_FC,
1727 VX_SRF_CIR_OFF,
1728 VX_SRF_VAR_OFF,
1729 VX_SRF_THRD_THDFC,
1730 VX_SRF_THRD_NTHDFC,
1731 VX_SRF_THRD_CONFC
1732 } evxSurfaceType;
evxSurfaceType
evxSurfaceType
surface types
Definition: zwapi_util.h:1699
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxAxisType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxAxisType

enum evxAxisType

#include <zwapi_util.h>

type of axis

Enumerator
VX_AXIS_X | x axis
VX_AXIS_Y | y axis
VX_AXIS_Z | z axis
Examples
part\asmConsTest.cpp.

Definition at line 358 of file zwapi_util.h.

359 {
360 VX_AXIS_X = 1,
361 VX_AXIS_Y = 2,
362 VX_AXIS_Z = 3,
363 } evxAxisType;
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
VX_AXIS_Z
@ VX_AXIS_Z
z axis
Definition: zwapi_util.h:362
VX_AXIS_Y
@ VX_AXIS_Y
y axis
Definition: zwapi_util.h:361
VX_AXIS_X
@ VX_AXIS_X
x axis
Definition: zwapi_util.h:360
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxHoleDimDataItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxHoleDimDataItem

enum evxHoleDimDataItem

#include <zwapi_util.h>

data sub-items of hole dimension

Enumerator
VX_HOLE_DIM_ITEM_ORG | original variable string
VX_HOLE_DIM_ITEM_QTY | number of same holes: <H_Q>
VX_HOLE_DIM_ITEM_DIA | hole diameter D1: <H_D1>
VX_HOLE_DIM_ITEM_DIA2 | hole diameter D2: <H_D2>
VX_HOLE_DIM_ITEM_LABEL | hole label: <H_L>
VX_HOLE_DIM_ITEM_DPTH | hole depth H1: <H_H1>
VX_HOLE_DIM_ITEM_DPTH2 | hole depth H2: <H_H2>
VX_HOLE_DIM_ITEM_ANG | hole angle: <H_A>
VX_HOLE_DIM_ITEM_THRD_DIA | hole thread diameter: <H_TD>
VX_HOLE_DIM_ITEM_THRD_DPTH | hole thread depth: <H_TH>
VX_HOLE_DIM_ITEM_PITCH | hole thread pitch: <H_TP>
VX_HOLE_DIM_THRD_STD | hole thread: <H_TS>
VX_HOLE_DIM_THRD_SIZ | hole thread size without pitch: <H_TZ>

Definition at line 2213 of file zwapi_util.h.

2214 {
2215 VX_HOLE_DIM_ITEM_ORG,
2216 VX_HOLE_DIM_ITEM_QTY,
2217 VX_HOLE_DIM_ITEM_DIA,
2218 VX_HOLE_DIM_ITEM_DIA2,
2219 VX_HOLE_DIM_ITEM_LABEL,
2220 VX_HOLE_DIM_ITEM_DPTH,
2221 VX_HOLE_DIM_ITEM_DPTH2,
2222 VX_HOLE_DIM_ITEM_ANG,
2223 VX_HOLE_DIM_ITEM_THRD_DIA,
2224 VX_HOLE_DIM_ITEM_THRD_DPTH,
2225 VX_HOLE_DIM_ITEM_PITCH,
2226 VX_HOLE_DIM_THRD_STD,
2227 VX_HOLE_DIM_THRD_SIZ,
2228 } evxHoleDimDataItem;
evxHoleDimDataItem
evxHoleDimDataItem
data sub-items of hole dimension
Definition: zwapi_util.h:2214
VX_HOLE_DIM_ITEM_THRD_DIA
@ VX_HOLE_DIM_ITEM_THRD_DIA
hole thread diameter: <H_TD>
Definition: zwapi_util.h:2223
VX_HOLE_DIM_ITEM_THRD_DPTH
@ VX_HOLE_DIM_ITEM_THRD_DPTH
hole thread depth: <H_TH>
Definition: zwapi_util.h:2224
VX_HOLE_DIM_ITEM_DPTH2
@ VX_HOLE_DIM_ITEM_DPTH2
hole depth H2: <H_H2>
Definition: zwapi_util.h:2221
VX_HOLE_DIM_ITEM_ORG
@ VX_HOLE_DIM_ITEM_ORG
original variable string
Definition: zwapi_util.h:2215
VX_HOLE_DIM_THRD_STD
@ VX_HOLE_DIM_THRD_STD
hole thread: <H_TS>
Definition: zwapi_util.h:2226
VX_HOLE_DIM_ITEM_QTY
@ VX_HOLE_DIM_ITEM_QTY
number of same holes: <H_Q>
Definition: zwapi_util.h:2216
VX_HOLE_DIM_THRD_SIZ
@ VX_HOLE_DIM_THRD_SIZ
hole thread size without pitch: <H_TZ>
Definition: zwapi_util.h:2227
VX_HOLE_DIM_ITEM_DIA
@ VX_HOLE_DIM_ITEM_DIA
hole diameter D1: <H_D1>
Definition: zwapi_util.h:2217
VX_HOLE_DIM_ITEM_DIA2
@ VX_HOLE_DIM_ITEM_DIA2
hole diameter D2: <H_D2>
Definition: zwapi_util.h:2218
VX_HOLE_DIM_ITEM_LABEL
@ VX_HOLE_DIM_ITEM_LABEL
hole label: <H_L>
Definition: zwapi_util.h:2219
VX_HOLE_DIM_ITEM_ANG
@ VX_HOLE_DIM_ITEM_ANG
hole angle: <H_A>
Definition: zwapi_util.h:2222
VX_HOLE_DIM_ITEM_DPTH
@ VX_HOLE_DIM_ITEM_DPTH
hole depth H1: <H_H1>
Definition: zwapi_util.h:2220
VX_HOLE_DIM_ITEM_PITCH
@ VX_HOLE_DIM_ITEM_PITCH
hole thread pitch: <H_TP>
Definition: zwapi_util.h:2225
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxErrors

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxErrors

enum evxErrors

#include <zwapi_util.h>

the return value of the API interfaces

Enumerator
ZW_API_NO_ERROR | no error
ZW_API_GENERAL_ERROR | general error
ZW_API_ROOT_OBJ_ACT_FAIL | could not activate the current root object
ZW_API_WRONG_ROOT_ENV | wrong type for the active root object (the root need to be part/sketch/drawing/cam, but is not)
ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR | wrong file type. either the file is single-object where a multi-object file is required, or the file is multi-object where a single-object file is required
ZW_API_ROOT_ERROR | the specified root can't be found
ZW_API_INVALID_INPUT | input parameter is invalid (pointer is NULL, object's id < 1, out of input vlaue...)
ZW_API_INPUT_ERROR | input error, an error occurred while preparing input data for zw3d command (cvxDataSet).
ZW_API_INPUT_TYPE_ERROR | the the input object doesn't match the required one
ZW_API_INVALID_OUTPUT | output parameter is invalid
ZW_API_FILE_LOCATE_FAIL | fail to locate the specified file. an error occurred when the file can't be found in the search path, current file path etc.
ZW_API_FILE_ERROR | the specified file does not exist in memory
ZW_API_OBJ_TYPE_ERROR | the type of the specified object is wrong
ZW_API_OBJ_DATA_GET_ERROR | wrong data of the object(fail to get the specified type data of the object, such as the parent feature of the shape etc.)
ZW_API_OBJ_DATA_SET_ERROR | fail to set the specified type data of the object, such as the specified attribute of the shape etc.
ZW_API_INVALID_OBJ | the specified object can't be find in the current environment or inactive
ZW_API_ENT_PATH_ERROR | wrong entity pick path
ZW_API_INVALID_ENT_PATH | invalid entity pick path
ZW_API_CMMD_INIT_ERROR | command initialization failure
ZW_API_CMMD_EXEC_ERROR | command execution failure
ZW_API_CMMD_DATA_ERROR | wrong data container of the specified command(VDATA object)
ZW_API_FUN_REGISTER_ERROR | function has been registered
ZW_API_FUN_UNLOAD_ERROR | function hasn't been registered and unload failed
ZW_API_MEMORY_ERROR | memory error. an error occurred while allocating memory
ZW_API_OUT_OF_RANGE | out of the memory range
ZW_API_MODELING_DATA_ERROR | geometric modeling data error
ZW_API_BOOLEAN_ADD_BASE_ERROR | boolean add failure, more than one base shapes intersect with the operator shape
ZW_API_INVALID_NAME | invalid name, name is empty or contains some of \/:*?"<>|
ZW_API_INVALID_PATH | invalid file path
ZW_API_INVALID_STRING | the string is empty
ZW_API_PATH_LEN_OVER_RANGE | the file path length is over range
ZW_API_NAME_LEN_OVER_RANGE | the file name length is over range
ZW_API_PATH_LEN_LESS_RANGE | the file path length is less 512 bytes
ZW_API_NAME_LEN_LESS_RANGE | the file name length is less 512 bytes
ZW_API_FORM_CREATE_FAIL | create form fails
ZW_API_FORM_SHOW_FAIL | show form fails
ZW_API_FORM_EXIST_ERROR | form doesn't exist
ZW_API_FORM_INIT_ERROR | Initialization failed.
ZW_API_TABLE_SETDATA_ERROR | fail to set table info
ZW_API_TABLE_GETDATA_ERROR | fail to get table info
ZW_API_LICENSE_NESTING_ERROR | nesting license fails
ZW_API_FUNCTION_CB_GET_ERROR | Failed to get callback function.
ZW_API_FUCNTION_CB_EXIST_ERROR | callback doesn't exist
ZW_API_FUCNTION_CB_EXECUTION_ERROR | callback function execution failed
ZW_API_CAM_OPTYPE_ERROR | wrong operation type
ZW_API_CAM_GETOPNAME_ERROR | fail to get operation name
ZW_API_CAM_GETOPBYTAC_ERROR | fail to get operation in tactic
ZW_API_CAM_GETOPERATION_ERROR | fail to get operation in cam plan
ZW_API_CAM_GETVDATA_ERROR | fail to get cam info
ZW_API_CAM_SETVDATA_ERROR | fail to set cam info
ZW_API_CAM_UPVADTA_ERROR | fail to update cam info
ZW_API_CAM_GETTACNAME_ERROR | fail to get tactic name
ZW_API_CAM_GETTACTIC_ERROR | fail to get tactic in cam plan
ZW_API_CAM_GETFTRGRP_ERROR | fail to get feature group data
ZW_API_CAM_GETFTRDBNAME_ERROR | fail to get ftr db name
ZW_API_CAM_GETFTR_ERROR | fail to get feature in cam plan
ZW_API_CAM_GETSETUP_ERROR | fail to get setup in cam plan
ZW_API_CAM_GETMACH_ERROR | fail to get machine in cam plan
ZW_API_CAM_GETMACHNAME_ERROR | fail to get machine name in cam plan
ZW_API_CAM_GETFOLDER_ERROR | fail to get folder in cam plan
ZW_API_CAM_GETFOLDERNAME_ERROR | fail to get folder name
ZW_API_CAM_GETFOLDERSUB_ERROR | fail to get folder sub item
ZW_API_CAM_GETTOOL_ERROR | fail to get tool in cam plan
ZW_API_CAM_GETTOOLNAME_ERROR | fail to get tool name in cam plan
ZW_API_CAM_GETHOLDER_ERROR | fail to get tool holder index
ZW_API_CAM_GETTOOLTYPE_ERROR | fail to get tool type
ZW_API_CAM_GETTOOLSUBTYPE_ERROR | fail to get tool sub type
ZW_API_CAM_GETTOOLID_ERROR | fail to get tool id
ZW_API_CAM_GETTOOLLEN_ERROR | fail to get tool length
ZW_API_CAM_GETTOOLDIA_ERROR | fail to get tool diameter
ZW_API_CAM_GETCMCOMP_ERROR | fail to get component in cam plan
ZW_API_CAM_GETCOMPCLASS_ERROR | fail to get component class
ZW_API_CAM_GETCOMPINDEX_ERROR | fail to get component index
ZW_API_CAM_GETCOMPVDATA_ERROR | fail to get component database
ZW_API_CAM_GETFRAME_ERROR | fail to get frame in cam plan
ZW_API_CAM_GETACTFRAME_ERROR | fail to get active frame
ZW_API_CAM_GETOUT_ERROR | fail to get output in cam plan
ZW_API_CAM_OUTCL_ERROR | fail to output cl
ZW_API_CAM_OUTNC_ERROR | fail to output nc
ZW_API_CAM_OUTOPLIST_ERROR | fail to output excel type operation list
ZW_API_CAM_OUTOPHTML_ERROR | fail to output html type operation list
ZW_API_CAM_OUTOPXML_ERROR | fail to output xml type operation list
ZW_API_CAM_OUTTOOL_ERROR | fail to output tool list
ZW_API_CAM_GUITOTXT_ERROR | fail to interface parameter change to data base
ZW_API_CAM_GUIFROMTXT_ERROR | fail to interface parameter get from data base
ZW_API_CAM_GETFORMSTATE_ERROR | fail to get cam form state
ZW_API_CAM_FORMDEFINE_ERROR | fail to define a cam form
ZW_API_CAM_GETFORMITEM_ERROR | fail to get cam form item
ZW_API_CAM_SETFORMITEM_ERROR | fail to set cam form item
ZW_API_CAM_GETTPATH_ERROR | fail to get tool path index
ZW_API_CAM_GETTPATHINFO_ERROR | fail to get tool path information
ZW_API_CAM_GETSPDFD_ERROR | fail to get speed and feed

Definition at line 34 of file zwapi_util.h.

35 {
36 /* success */
37 ZW_API_NO_ERROR = 0,
39 /* -1/1 is used as an interface custom return value */
40
41 /* ZW3D internal function fails */
42 ZW_API_GENERAL_ERROR = -10000,
44 /* root environment error */
45 ZW_API_ROOT_OBJ_ACT_FAIL = -5,
46 ZW_API_WRONG_ROOT_ENV = -6,
47 ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR = -7,
49 ZW_API_ROOT_ERROR = -8,
51 /* input/ output error */
52 ZW_API_INVALID_INPUT = -31,
53 ZW_API_INPUT_ERROR = -32,
54 ZW_API_INPUT_TYPE_ERROR = -33,
55 ZW_API_INVALID_OUTPUT = -34,
57 /* file fail */
58 ZW_API_FILE_LOCATE_FAIL = -61,
59 ZW_API_FILE_ERROR = -62,
61 /* object error */
62 ZW_API_OBJ_TYPE_ERROR = -91,
63 ZW_API_OBJ_DATA_GET_ERROR = -92,
64 ZW_API_OBJ_DATA_SET_ERROR = -93,
65 ZW_API_INVALID_OBJ = -94,
67 /* entity path error */
68 ZW_API_ENT_PATH_ERROR = -121,
69 ZW_API_INVALID_ENT_PATH = -122,
71 /* command error */
72 ZW_API_CMMD_INIT_ERROR = -151,
73 ZW_API_CMMD_EXEC_ERROR = -152,
74 ZW_API_CMMD_DATA_ERROR = -153,
75 /* command register error */
76 ZW_API_FUN_REGISTER_ERROR = -160,
77 ZW_API_FUN_UNLOAD_ERROR = -161,
79 /* memory error */
80 ZW_API_MEMORY_ERROR = -181,
81 ZW_API_OUT_OF_RANGE = -182,
83 /* modeling data error */
84 ZW_API_MODELING_DATA_ERROR = -211,
85 ZW_API_BOOLEAN_ADD_BASE_ERROR = -212,
87 /* string error */
88 ZW_API_INVALID_NAME = -241,
89 ZW_API_INVALID_PATH = -242,
90 ZW_API_INVALID_STRING = -243,
91 ZW_API_PATH_LEN_OVER_RANGE = -244,
92 ZW_API_NAME_LEN_OVER_RANGE = -245,
93 ZW_API_PATH_LEN_LESS_RANGE = -246,
94 ZW_API_NAME_LEN_LESS_RANGE = -247,
96 /* UI */
97 ZW_API_FORM_CREATE_FAIL = -271,
98 ZW_API_FORM_SHOW_FAIL = -272,
99 ZW_API_FORM_EXIST_ERROR = -273,
100 ZW_API_FORM_INIT_ERROR = -274,
102 /* Table */
103 ZW_API_TABLE_SETDATA_ERROR = -281,
104 ZW_API_TABLE_GETDATA_ERROR = -282,
106 /* License */
107 ZW_API_LICENSE_NESTING_ERROR = -301,
109 /* Function */
110 ZW_API_FUNCTION_CB_GET_ERROR = -401,
111 ZW_API_FUCNTION_CB_EXIST_ERROR = -402,
112 ZW_API_FUCNTION_CB_EXECUTION_ERROR = -403,
114 /* cam operation error */
115 ZW_API_CAM_OPTYPE_ERROR = -1001,
116 ZW_API_CAM_GETOPNAME_ERROR = -1002,
117 ZW_API_CAM_GETOPBYTAC_ERROR = -1003,
118 ZW_API_CAM_GETOPERATION_ERROR = -1004,
120 /* cam data error */
121 ZW_API_CAM_GETVDATA_ERROR = -1011,
122 ZW_API_CAM_SETVDATA_ERROR = -1012,
123 ZW_API_CAM_UPVADTA_ERROR = -1013,
125 /* cam tactic error */
126 ZW_API_CAM_GETTACNAME_ERROR = -1021,
127 ZW_API_CAM_GETTACTIC_ERROR = -1022,
129 /* cam feature error */
130 ZW_API_CAM_GETFTRGRP_ERROR = -1031,
131 ZW_API_CAM_GETFTRDBNAME_ERROR = -1032,
132 ZW_API_CAM_GETFTR_ERROR = -1033,
134 /* cam setup error */
135 ZW_API_CAM_GETSETUP_ERROR = -1041,
137 /* cam machine error */
138 ZW_API_CAM_GETMACH_ERROR = -1051,
139 ZW_API_CAM_GETMACHNAME_ERROR = -1052,
141 /* cam folder error */
142 ZW_API_CAM_GETFOLDER_ERROR = -1061,
143 ZW_API_CAM_GETFOLDERNAME_ERROR = -1062,
144 ZW_API_CAM_GETFOLDERSUB_ERROR = -1063,
146 /* cam tool error */
147 ZW_API_CAM_GETTOOL_ERROR = -1072,
148 ZW_API_CAM_GETTOOLNAME_ERROR = -1073,
149 ZW_API_CAM_GETHOLDER_ERROR = -1073,
150 ZW_API_CAM_GETTOOLTYPE_ERROR = -1074,
151 ZW_API_CAM_GETTOOLSUBTYPE_ERROR = -1075,
152 ZW_API_CAM_GETTOOLID_ERROR = -1076,
153 ZW_API_CAM_GETTOOLLEN_ERROR = -1077,
154 ZW_API_CAM_GETTOOLDIA_ERROR = -1078,
156 /* cam component error */
157 ZW_API_CAM_GETCMCOMP_ERROR = -1081,
158 ZW_API_CAM_GETCOMPCLASS_ERROR = -1082,
159 ZW_API_CAM_GETCOMPINDEX_ERROR = -1083,
160 ZW_API_CAM_GETCOMPVDATA_ERROR = -1084,
162 /* cam frame error */
163 ZW_API_CAM_GETFRAME_ERROR = -1091,
164 ZW_API_CAM_GETACTFRAME_ERROR = -1092,
166 /* cam output error */
167 ZW_API_CAM_GETOUT_ERROR = -1101,
168 ZW_API_CAM_OUTCL_ERROR = -1102,
169 ZW_API_CAM_OUTNC_ERROR = -1103,
170 ZW_API_CAM_OUTOPLIST_ERROR = -1104,
171 ZW_API_CAM_OUTOPHTML_ERROR = -1105,
172 ZW_API_CAM_OUTOPXML_ERROR = -1106,
173 ZW_API_CAM_OUTTOOL_ERROR = -1107,
175 /* cam gui error */
176 ZW_API_CAM_GUITOTXT_ERROR = -1111,
177 ZW_API_CAM_GUIFROMTXT_ERROR = -1112,
179 /* cam form error */
180 ZW_API_CAM_GETFORMSTATE_ERROR = -1121,
181 ZW_API_CAM_FORMDEFINE_ERROR = -1122,
182 ZW_API_CAM_GETFORMITEM_ERROR = -1123,
183 ZW_API_CAM_SETFORMITEM_ERROR = -1124,
185 /* cam tool path error */
186 ZW_API_CAM_GETTPATH_ERROR = -1131,
187 ZW_API_CAM_GETTPATHINFO_ERROR = -1132,
189 /* cam spdfd error */
190 ZW_API_CAM_GETSPDFD_ERROR = -1141
192 } evxErrors;
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
ZW_API_CAM_GETHOLDER_ERROR
@ ZW_API_CAM_GETHOLDER_ERROR
fail to get tool holder index
Definition: zwapi_util.h:149
ZW_API_CAM_GUIFROMTXT_ERROR
@ ZW_API_CAM_GUIFROMTXT_ERROR
fail to interface parameter get from data base
Definition: zwapi_util.h:177
ZW_API_CAM_GETOPERATION_ERROR
@ ZW_API_CAM_GETOPERATION_ERROR
fail to get operation in cam plan
Definition: zwapi_util.h:118
ZW_API_CAM_OUTCL_ERROR
@ ZW_API_CAM_OUTCL_ERROR
fail to output cl
Definition: zwapi_util.h:168
ZW_API_FILE_ERROR
@ ZW_API_FILE_ERROR
the specified file does not exist in memory
Definition: zwapi_util.h:59
ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
@ ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
wrong file type. either the file is single-object where a multi-object file is required,...
Definition: zwapi_util.h:47
ZW_API_FUNCTION_CB_GET_ERROR
@ ZW_API_FUNCTION_CB_GET_ERROR
Failed to get callback function.
Definition: zwapi_util.h:110
ZW_API_ENT_PATH_ERROR
@ ZW_API_ENT_PATH_ERROR
wrong entity pick path
Definition: zwapi_util.h:68
ZW_API_CAM_OUTTOOL_ERROR
@ ZW_API_CAM_OUTTOOL_ERROR
fail to output tool list
Definition: zwapi_util.h:173
ZW_API_GENERAL_ERROR
@ ZW_API_GENERAL_ERROR
general error
Definition: zwapi_util.h:42
ZW_API_CAM_GETCOMPCLASS_ERROR
@ ZW_API_CAM_GETCOMPCLASS_ERROR
fail to get component class
Definition: zwapi_util.h:158
ZW_API_NAME_LEN_OVER_RANGE
@ ZW_API_NAME_LEN_OVER_RANGE
the file name length is over range
Definition: zwapi_util.h:92
ZW_API_CAM_GETTPATHINFO_ERROR
@ ZW_API_CAM_GETTPATHINFO_ERROR
fail to get tool path information
Definition: zwapi_util.h:187
ZW_API_INVALID_STRING
@ ZW_API_INVALID_STRING
the string is empty
Definition: zwapi_util.h:90
ZW_API_CAM_GETOUT_ERROR
@ ZW_API_CAM_GETOUT_ERROR
fail to get output in cam plan
Definition: zwapi_util.h:167
ZW_API_CAM_GETFTRDBNAME_ERROR
@ ZW_API_CAM_GETFTRDBNAME_ERROR
fail to get ftr db name
Definition: zwapi_util.h:131
ZW_API_WRONG_ROOT_ENV
@ ZW_API_WRONG_ROOT_ENV
wrong type for the active root object (the root need to be part/sketch/drawing/cam,...
Definition: zwapi_util.h:46
ZW_API_CAM_GETOPBYTAC_ERROR
@ ZW_API_CAM_GETOPBYTAC_ERROR
fail to get operation in tactic
Definition: zwapi_util.h:117
ZW_API_OUT_OF_RANGE
@ ZW_API_OUT_OF_RANGE
out of the memory range
Definition: zwapi_util.h:81
ZW_API_INVALID_OBJ
@ ZW_API_INVALID_OBJ
the specified object can't be find in the current environment or inactive
Definition: zwapi_util.h:65
ZW_API_CAM_GETMACHNAME_ERROR
@ ZW_API_CAM_GETMACHNAME_ERROR
fail to get machine name in cam plan
Definition: zwapi_util.h:139
ZW_API_INVALID_ENT_PATH
@ ZW_API_INVALID_ENT_PATH
invalid entity pick path
Definition: zwapi_util.h:69
ZW_API_CAM_GETSPDFD_ERROR
@ ZW_API_CAM_GETSPDFD_ERROR
fail to get speed and feed
Definition: zwapi_util.h:190
ZW_API_CAM_OUTOPHTML_ERROR
@ ZW_API_CAM_OUTOPHTML_ERROR
fail to output html type operation list
Definition: zwapi_util.h:171
ZW_API_PATH_LEN_LESS_RANGE
@ ZW_API_PATH_LEN_LESS_RANGE
the file path length is less 512 bytes
Definition: zwapi_util.h:93
ZW_API_CAM_OUTNC_ERROR
@ ZW_API_CAM_OUTNC_ERROR
fail to output nc
Definition: zwapi_util.h:169
ZW_API_FILE_LOCATE_FAIL
@ ZW_API_FILE_LOCATE_FAIL
fail to locate the specified file. an error occurred when the file can't be found in the search path,...
Definition: zwapi_util.h:58
ZW_API_FUCNTION_CB_EXECUTION_ERROR
@ ZW_API_FUCNTION_CB_EXECUTION_ERROR
callback function execution failed
Definition: zwapi_util.h:112
ZW_API_ROOT_ERROR
@ ZW_API_ROOT_ERROR
the specified root can't be found
Definition: zwapi_util.h:49
ZW_API_NO_ERROR
@ ZW_API_NO_ERROR
no error
Definition: zwapi_util.h:37
ZW_API_CAM_GETMACH_ERROR
@ ZW_API_CAM_GETMACH_ERROR
fail to get machine in cam plan
Definition: zwapi_util.h:138
ZW_API_CAM_UPVADTA_ERROR
@ ZW_API_CAM_UPVADTA_ERROR
fail to update cam info
Definition: zwapi_util.h:123
ZW_API_ROOT_OBJ_ACT_FAIL
@ ZW_API_ROOT_OBJ_ACT_FAIL
could not activate the current root object
Definition: zwapi_util.h:45
ZW_API_CAM_GETCOMPVDATA_ERROR
@ ZW_API_CAM_GETCOMPVDATA_ERROR
fail to get component database
Definition: zwapi_util.h:160
ZW_API_CAM_GETTOOL_ERROR
@ ZW_API_CAM_GETTOOL_ERROR
fail to get tool in cam plan
Definition: zwapi_util.h:147
ZW_API_CAM_GETSETUP_ERROR
@ ZW_API_CAM_GETSETUP_ERROR
fail to get setup in cam plan
Definition: zwapi_util.h:135
ZW_API_CAM_OPTYPE_ERROR
@ ZW_API_CAM_OPTYPE_ERROR
wrong operation type
Definition: zwapi_util.h:115
ZW_API_FUCNTION_CB_EXIST_ERROR
@ ZW_API_FUCNTION_CB_EXIST_ERROR
callback doesn't exist
Definition: zwapi_util.h:111
ZW_API_CAM_GETCOMPINDEX_ERROR
@ ZW_API_CAM_GETCOMPINDEX_ERROR
fail to get component index
Definition: zwapi_util.h:159
ZW_API_FUN_UNLOAD_ERROR
@ ZW_API_FUN_UNLOAD_ERROR
function hasn't been registered and unload failed
Definition: zwapi_util.h:77
ZW_API_TABLE_SETDATA_ERROR
@ ZW_API_TABLE_SETDATA_ERROR
fail to set table info
Definition: zwapi_util.h:103
ZW_API_CAM_GETTOOLTYPE_ERROR
@ ZW_API_CAM_GETTOOLTYPE_ERROR
fail to get tool type
Definition: zwapi_util.h:150
ZW_API_CAM_GETTACNAME_ERROR
@ ZW_API_CAM_GETTACNAME_ERROR
fail to get tactic name
Definition: zwapi_util.h:126
ZW_API_CAM_GETTOOLNAME_ERROR
@ ZW_API_CAM_GETTOOLNAME_ERROR
fail to get tool name in cam plan
Definition: zwapi_util.h:148
ZW_API_INVALID_PATH
@ ZW_API_INVALID_PATH
invalid file path
Definition: zwapi_util.h:89
ZW_API_CAM_GETTACTIC_ERROR
@ ZW_API_CAM_GETTACTIC_ERROR
fail to get tactic in cam plan
Definition: zwapi_util.h:127
ZW_API_MEMORY_ERROR
@ ZW_API_MEMORY_ERROR
memory error. an error occurred while allocating memory
Definition: zwapi_util.h:80
ZW_API_OBJ_DATA_GET_ERROR
@ ZW_API_OBJ_DATA_GET_ERROR
wrong data of the object(fail to get the specified type data of the object, such as the parent featur...
Definition: zwapi_util.h:63
ZW_API_INPUT_ERROR
@ ZW_API_INPUT_ERROR
input error, an error occurred while preparing input data for zw3d command (cvxDataSet).
Definition: zwapi_util.h:53
ZW_API_CAM_GETFTR_ERROR
@ ZW_API_CAM_GETFTR_ERROR
fail to get feature in cam plan
Definition: zwapi_util.h:132
ZW_API_CAM_GETFOLDERNAME_ERROR
@ ZW_API_CAM_GETFOLDERNAME_ERROR
fail to get folder name
Definition: zwapi_util.h:143
ZW_API_TABLE_GETDATA_ERROR
@ ZW_API_TABLE_GETDATA_ERROR
fail to get table info
Definition: zwapi_util.h:104
ZW_API_CAM_GETFOLDER_ERROR
@ ZW_API_CAM_GETFOLDER_ERROR
fail to get folder in cam plan
Definition: zwapi_util.h:142
ZW_API_CAM_GETACTFRAME_ERROR
@ ZW_API_CAM_GETACTFRAME_ERROR
fail to get active frame
Definition: zwapi_util.h:164
ZW_API_FORM_EXIST_ERROR
@ ZW_API_FORM_EXIST_ERROR
form doesn't exist
Definition: zwapi_util.h:99
ZW_API_CAM_GETTOOLID_ERROR
@ ZW_API_CAM_GETTOOLID_ERROR
fail to get tool id
Definition: zwapi_util.h:152
ZW_API_CAM_OUTOPLIST_ERROR
@ ZW_API_CAM_OUTOPLIST_ERROR
fail to output excel type operation list
Definition: zwapi_util.h:170
ZW_API_CAM_FORMDEFINE_ERROR
@ ZW_API_CAM_FORMDEFINE_ERROR
fail to define a cam form
Definition: zwapi_util.h:181
ZW_API_INPUT_TYPE_ERROR
@ ZW_API_INPUT_TYPE_ERROR
the the input object doesn't match the required one
Definition: zwapi_util.h:54
ZW_API_CAM_GETFTRGRP_ERROR
@ ZW_API_CAM_GETFTRGRP_ERROR
fail to get feature group data
Definition: zwapi_util.h:130
ZW_API_MODELING_DATA_ERROR
@ ZW_API_MODELING_DATA_ERROR
geometric modeling data error
Definition: zwapi_util.h:84
ZW_API_CAM_GETTOOLSUBTYPE_ERROR
@ ZW_API_CAM_GETTOOLSUBTYPE_ERROR
fail to get tool sub type
Definition: zwapi_util.h:151
ZW_API_OBJ_DATA_SET_ERROR
@ ZW_API_OBJ_DATA_SET_ERROR
fail to set the specified type data of the object, such as the specified attribute of the shape etc.
Definition: zwapi_util.h:64
ZW_API_INVALID_OUTPUT
@ ZW_API_INVALID_OUTPUT
output parameter is invalid
Definition: zwapi_util.h:55
ZW_API_CAM_GETCMCOMP_ERROR
@ ZW_API_CAM_GETCMCOMP_ERROR
fail to get component in cam plan
Definition: zwapi_util.h:157
ZW_API_CAM_OUTOPXML_ERROR
@ ZW_API_CAM_OUTOPXML_ERROR
fail to output xml type operation list
Definition: zwapi_util.h:172
ZW_API_CMMD_EXEC_ERROR
@ ZW_API_CMMD_EXEC_ERROR
command execution failure
Definition: zwapi_util.h:73
ZW_API_CAM_GETFRAME_ERROR
@ ZW_API_CAM_GETFRAME_ERROR
fail to get frame in cam plan
Definition: zwapi_util.h:163
ZW_API_INVALID_NAME
@ ZW_API_INVALID_NAME
invalid name, name is empty or contains some of \/:*?"<>|
Definition: zwapi_util.h:88
ZW_API_OBJ_TYPE_ERROR
@ ZW_API_OBJ_TYPE_ERROR
the type of the specified object is wrong
Definition: zwapi_util.h:62
ZW_API_BOOLEAN_ADD_BASE_ERROR
@ ZW_API_BOOLEAN_ADD_BASE_ERROR
boolean add failure, more than one base shapes intersect with the operator shape
Definition: zwapi_util.h:85
ZW_API_CMMD_DATA_ERROR
@ ZW_API_CMMD_DATA_ERROR
wrong data container of the specified command(VDATA object)
Definition: zwapi_util.h:74
ZW_API_FORM_CREATE_FAIL
@ ZW_API_FORM_CREATE_FAIL
create form fails
Definition: zwapi_util.h:97
ZW_API_NAME_LEN_LESS_RANGE
@ ZW_API_NAME_LEN_LESS_RANGE
the file name length is less 512 bytes
Definition: zwapi_util.h:94
ZW_API_CMMD_INIT_ERROR
@ ZW_API_CMMD_INIT_ERROR
command initialization failure
Definition: zwapi_util.h:72
ZW_API_CAM_SETFORMITEM_ERROR
@ ZW_API_CAM_SETFORMITEM_ERROR
fail to set cam form item
Definition: zwapi_util.h:183
ZW_API_CAM_GETFORMSTATE_ERROR
@ ZW_API_CAM_GETFORMSTATE_ERROR
fail to get cam form state
Definition: zwapi_util.h:180
ZW_API_LICENSE_NESTING_ERROR
@ ZW_API_LICENSE_NESTING_ERROR
nesting license fails
Definition: zwapi_util.h:107
ZW_API_FORM_INIT_ERROR
@ ZW_API_FORM_INIT_ERROR
Initialization failed.
Definition: zwapi_util.h:100
ZW_API_CAM_SETVDATA_ERROR
@ ZW_API_CAM_SETVDATA_ERROR
fail to set cam info
Definition: zwapi_util.h:122
ZW_API_CAM_GETFOLDERSUB_ERROR
@ ZW_API_CAM_GETFOLDERSUB_ERROR
fail to get folder sub item
Definition: zwapi_util.h:144
ZW_API_PATH_LEN_OVER_RANGE
@ ZW_API_PATH_LEN_OVER_RANGE
the file path length is over range
Definition: zwapi_util.h:91
ZW_API_CAM_GETTPATH_ERROR
@ ZW_API_CAM_GETTPATH_ERROR
fail to get tool path index
Definition: zwapi_util.h:186
ZW_API_FORM_SHOW_FAIL
@ ZW_API_FORM_SHOW_FAIL
show form fails
Definition: zwapi_util.h:98
ZW_API_CAM_GETTOOLDIA_ERROR
@ ZW_API_CAM_GETTOOLDIA_ERROR
fail to get tool diameter
Definition: zwapi_util.h:154
ZW_API_CAM_GETTOOLLEN_ERROR
@ ZW_API_CAM_GETTOOLLEN_ERROR
fail to get tool length
Definition: zwapi_util.h:153
ZW_API_CAM_GETFORMITEM_ERROR
@ ZW_API_CAM_GETFORMITEM_ERROR
fail to get cam form item
Definition: zwapi_util.h:182
ZW_API_CAM_GETOPNAME_ERROR
@ ZW_API_CAM_GETOPNAME_ERROR
fail to get operation name
Definition: zwapi_util.h:116
ZW_API_FUN_REGISTER_ERROR
@ ZW_API_FUN_REGISTER_ERROR
function has been registered
Definition: zwapi_util.h:76
ZW_API_INVALID_INPUT
@ ZW_API_INVALID_INPUT
input parameter is invalid (pointer is NULL, object's id < 1, out of input vlaue.....
Definition: zwapi_util.h:52
ZW_API_CAM_GUITOTXT_ERROR
@ ZW_API_CAM_GUITOTXT_ERROR
fail to interface parameter change to data base
Definition: zwapi_util.h:176
ZW_API_CAM_GETVDATA_ERROR
@ ZW_API_CAM_GETVDATA_ERROR
fail to get cam info
Definition: zwapi_util.h:121
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxCmAttrValueType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxCmAttrValueType

enum evxCmAttrValueType

#include <zwapi_util.h>

cam data attribute type

Definition at line 2501 of file zwapi_util.h.

2502 {
2503 ZW_CAM_ATTR_VALUE_TYPE_INVALID = -1,
2504 ZW_CAM_ATTR_VALUE_TYPE_INTEGER = 0,
2505 ZW_CAM_ATTR_VALUE_TYPE_DOUBLE,
2506 ZW_CAM_ATTR_VALUE_TYPE_STRING
2507 }evxCmAttrValueType;
evxCmAttrValueType
evxCmAttrValueType
cam data attribute type
Definition: zwapi_util.h:2502
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxColorAppFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxColorAppFlag

enum evxColorAppFlag

#include <zwapi_util.h>

color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for the detail view

Enumerator
VX_COLOR_BYLAYER

color by layer.

Definition at line 904 of file zwapi_util.h.

905 {
906 VX_COLOR_BYLAYER = 253,
907 } evxColorAppFlag;
evxColorAppFlag
evxColorAppFlag
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for...
Definition: zwapi_util.h:905
VX_COLOR_BYLAYER
@ VX_COLOR_BYLAYER
color by layer.
Definition: zwapi_util.h:906
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDimTypeEx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDimTypeEx

enum evxDimTypeEx

#include <zwapi_util.h>

dimension type, more detailed than evxDimType

Enumerator
VX_DIM_EX_LH | horizontal dimension
VX_DIM_EX_LV | vertical dimension
VX_DIM_EX_LA | aligned dimension
VX_DIM_EX_LR | rotated dimension
VX_DIM_EX_LP | projected dimension
VX_DIM_EX_LHB | horizontal baseline dimension
VX_DIM_EX_LVB | vertical baseline dimension
VX_DIM_EX_LAB | aligned baseline dimension
VX_DIM_EX_LRB | rotated baseline dimension
VX_DIM_EX_LPB | projected baseline dimension
VX_DIM_EX_LHC | horizontal continuous dimension
VX_DIM_EX_LVC | vertical continuous dimension
VX_DIM_EX_LAC | aligned continuous dimension
VX_DIM_EX_LRC | rotated continuous dimension
VX_DIM_EX_LPC | projected continuous dimension
VX_DIM_EX_LHO | horizontal ordinate dimension
VX_DIM_EX_LVO | vertical ordinate dimension
VX_DIM_EX_LAO | aligned ordinate dimension
VX_DIM_EX_LRO | rotated ordinate dimension
VX_DIM_EX_LPO | projected ordinate dimension
VX_DIM_EX_LHVO | horizontal and vertical ordinate dimension
VX_DIM_EX_LO | offset dimension
VX_DIM_EX_LOS | special offset dimension - point to line
VX_DIM_EX_LSY | symmetry dimension
VX_DIM_EX_ASY | Angular symmetry dimension.
VX_DIM_EX_LCHV | horizontal-vertical chamfer dimension
VX_DIM_EX_LCA | aligned chamfer dimension
VX_DIM_EX_LCL | leader chamfer dimension
VX_DIM_EX_LCLP | leader chamfer dimension (always perpendicular)
VX_DIM_EX_LCLA | leader chamfer dimension (always along the chamfered line)
VX_DIM_EX_ANG | angular dimension
VX_DIM_EX_ANGH | horizontal-angular dimension
VX_DIM_EX_ANGV | vertical-angular dimension
VX_DIM_EX_ANGA | angular arc dimension
VX_DIM_EX_ANG3PT | 3 point angular dimension
VX_DIM_EX_RAD | radial dimension
VX_DIM_EX_RADBG | big radial dimension
VX_DIM_EX_RADBK | broken radial dimension
VX_DIM_EX_DIA | diametrical dimension
VX_DIM_EX_RADL | radial leader dimension
VX_DIM_EX_GDH | horizontal datum (1982) dimension
VX_DIM_EX_GDV | vertical datum (1982) dimension
VX_DIM_EX_GDHS | horizontal datum symbol (1994) dimension
VX_DIM_EX_GDVS | vertical datum symbol (1994) dimension
VX_DIM_EX_GDL | leader datum (1994) dimension (circle, arc, curves)
VX_DIM_EX_GDLS | leader datum (1994) dimension (line)
VX_DIM_EX_GDTP | GD&T datum target point dimension.
VX_DIM_EX_GDTC | GD&T datum target area dimension.
VX_DIM_EX_GDTR | GD&T datum target rectangle area dimension.
VX_DIM_EX_GDTL | GD&T datum target line area dimension.
VX_DIM_EX_LOB | offset baseline dimension
VX_DIM_EX_LOC | offset continuous dimension
VX_DIM_EX_LOO | offset ordinate dimension
VX_DIM_EX_LCH | horizontal chamfer dimension
VX_DIM_EX_LCV | vertical chamfer dimension
VX_DIM_EX_RADB | radial baseline dimension
VX_DIM_EX_RADC | radial continuous dimension
VX_DIM_EX_RADO | radial ordinate dimension
VX_DIM_EX_RADBGB | big radial baseline dimension
VX_DIM_EX_RADBGC | big radial continuous dimension
VX_DIM_EX_RADBGO | big radial ordinate dimension
VX_DIM_EX_RADBKB | broken radial baseline dimension
VX_DIM_EX_RADBKC | broken radial continuous dimension
VX_DIM_EX_RADBKO | broken radial ordinate dimension
VX_DIM_EX_RADS | special radial dimension
VX_DIM_EX_DIAB | diametrical baseline dimension
VX_DIM_EX_DIAC | diametrical continuous dimension
VX_DIM_EX_DIAO | diametrical ordinate dimension
VX_DIM_EX_ANGB | baseline angular dimension
VX_DIM_EX_ANGC | continuous angular dimension
VX_DIM_EX_ANGO | ordinate angular dimension
VX_DIM_EX_ANGHB | baseline horizontal-angular dimension
VX_DIM_EX_ANGHC | continuous horizontal-angular dimension
VX_DIM_EX_ANGHO | ordinate horizontal-angular dimension
VX_DIM_EX_ANGVB | baseline vertical-angular dimension
VX_DIM_EX_ANGVC | continuous vertical-angular dimension
VX_DIM_EX_ANGVO | ordinate vertical-angular dimension
VX_DIM_EX_ANGAB | baseline angular arc dimension
VX_DIM_EX_ANGAC | continuous angular arc dimension
VX_DIM_EX_ANGAO | ordinate angular arc dimension
VX_DIM_EX_LEAD | leader dimension
VX_DIM_EX_BALL | balloon dimension
VX_DIM_EX_CM | centerline/centermark dimension
VX_DIM_EX_GF | GD&T/feature symbol dimension.
VX_DIM_EX_GFL | leader GD&T/feature symbol dimension
VX_DIM_EX_GFP | profile GD&T/feature symbol dimension
VX_DIM_EX_LCLS | special chamfer leader dimension
VX_DIM_EX_CLC | centerline curve
VX_DIM_EX_CLBS | bisection centerline
VX_DIM_EX_ARCL | arc length
VX_DIM_EX_INTSYM | intersection symbol dimension
VX_DIM_EX_LORD | leader coordinate dimension
VX_DIM_EX_DPLS | datum projection dimension (line)
VX_DIM_EX_CRVL | spline curve length dimension
VX_DIM_EX_RHO | conic ratio Rho
VX_DIM_EX_CRVL3D | curve length
VX_DIM_EX_ELEV | elevation dimension
VX_DIM_EX_AUTO_LSY | auto symmetric dimension

Definition at line 1960 of file zwapi_util.h.

1961 {
1962 VX_DIM_EX_FIRST = 0,
1963
1964 VX_DIM_EX_LH = 1,
1965 VX_DIM_EX_LV = 5,
1966 VX_DIM_EX_LA = 9,
1967 VX_DIM_EX_LR = 13,
1968 VX_DIM_EX_LP = 17,
1970 VX_DIM_EX_LHB = 2,
1971 VX_DIM_EX_LVB = 6,
1972 VX_DIM_EX_LAB = 10,
1973 VX_DIM_EX_LRB = 14,
1974 VX_DIM_EX_LPB = 18,
1976 VX_DIM_EX_LHC = 3,
1977 VX_DIM_EX_LVC = 7,
1978 VX_DIM_EX_LAC = 11,
1979 VX_DIM_EX_LRC = 15,
1980 VX_DIM_EX_LPC = 19,
1982 VX_DIM_EX_LHO = 4,
1983 VX_DIM_EX_LVO = 8,
1984 VX_DIM_EX_LAO = 12,
1985 VX_DIM_EX_LRO = 16,
1986 VX_DIM_EX_LPO = 20,
1987 VX_DIM_EX_LHVO = 88,
1989 VX_DIM_EX_LO = 21,
1990 VX_DIM_EX_LOS = 25,
1992 VX_DIM_EX_LSY = 90,
1993 VX_DIM_EX_ASY = 93,
1995 VX_DIM_EX_LCHV = 26,
1996 VX_DIM_EX_LCA = 29,
1997 VX_DIM_EX_LCL = 30,
1998 VX_DIM_EX_LCLP = 80,
1999 VX_DIM_EX_LCLA = 83,
2001 VX_DIM_EX_ANG = 48,
2002 VX_DIM_EX_ANGH = 52,
2003 VX_DIM_EX_ANGV = 56,
2004 VX_DIM_EX_ANGA = 60,
2005 VX_DIM_EX_ANG3PT = 74,
2007 VX_DIM_EX_RAD = 31,
2008 VX_DIM_EX_RADBG = 35,
2009 VX_DIM_EX_RADBK = 39,
2010 VX_DIM_EX_DIA = 44,
2011 VX_DIM_EX_RADL = 76,
2013 VX_DIM_EX_GDH = 70,
2014 VX_DIM_EX_GDV = 71,
2015 VX_DIM_EX_GDHS = 77,
2016 VX_DIM_EX_GDVS = 78,
2017 VX_DIM_EX_GDL = 81,
2018 VX_DIM_EX_GDLS = 82,
2020 VX_DIM_EX_GDTP = 72,
2021 VX_DIM_EX_GDTC = 73,
2022 VX_DIM_EX_GDTR = 84,
2023 VX_DIM_EX_GDTL = 85,
2025 VX_DIM_EX_LOB = 22,
2026 VX_DIM_EX_LOC = 23,
2027 VX_DIM_EX_LOO = 24,
2028 VX_DIM_EX_LCH = 27,
2029 VX_DIM_EX_LCV = 28,
2030 VX_DIM_EX_RADB = 32,
2031 VX_DIM_EX_RADC = 33,
2032 VX_DIM_EX_RADO = 34,
2033 VX_DIM_EX_RADBGB = 36,
2034 VX_DIM_EX_RADBGC = 37,
2035 VX_DIM_EX_RADBGO = 38,
2036 VX_DIM_EX_RADBKB = 40,
2037 VX_DIM_EX_RADBKC = 41,
2038 VX_DIM_EX_RADBKO = 42,
2039 VX_DIM_EX_RADS = 43,
2040 VX_DIM_EX_DIAB = 45,
2041 VX_DIM_EX_DIAC = 46,
2042 VX_DIM_EX_DIAO = 47,
2043 VX_DIM_EX_ANGB = 49,
2044 VX_DIM_EX_ANGC = 50,
2045 VX_DIM_EX_ANGO = 51,
2046 VX_DIM_EX_ANGHB = 53,
2047 VX_DIM_EX_ANGHC = 54,
2048 VX_DIM_EX_ANGHO = 55,
2049 VX_DIM_EX_ANGVB = 57,
2050 VX_DIM_EX_ANGVC = 58,
2051 VX_DIM_EX_ANGVO = 59,
2052 VX_DIM_EX_ANGAB = 61,
2053 VX_DIM_EX_ANGAC = 62,
2054 VX_DIM_EX_ANGAO = 63,
2055 VX_DIM_EX_LEAD = 64,
2056 VX_DIM_EX_BALL = 65,
2057 VX_DIM_EX_CM = 66,
2058 VX_DIM_EX_GF = 67,
2059 VX_DIM_EX_GFL = 68,
2060 VX_DIM_EX_GFP = 69,
2061 VX_DIM_EX_LCLS = 75,
2062 VX_DIM_EX_CLC = 79,
2063 VX_DIM_EX_CLBS = 86,
2064 VX_DIM_EX_ARCL = 87,
2065 VX_DIM_EX_INTSYM = 89,
2066 VX_DIM_EX_LORD = 91,
2067 VX_DIM_EX_DPLS = 92,
2068 VX_DIM_EX_CRVL = 94,
2069 VX_DIM_EX_RHO = 95,
2070 VX_DIM_EX_CRVL3D = 96,
2071 VX_DIM_EX_ELEV = 97,
2072 VX_DIM_EX_AUTO_LSY = 98,
2073 VX_DIM_EX_LAST = 99
2074 } evxDimTypeEx;
evxDimTypeEx
evxDimTypeEx
dimension type, more detailed than evxDimType
Definition: zwapi_util.h:1961
VX_DIM_EX_DIA
@ VX_DIM_EX_DIA
diametrical dimension
Definition: zwapi_util.h:2010
VX_DIM_EX_GDV
@ VX_DIM_EX_GDV
vertical datum (1982) dimension
Definition: zwapi_util.h:2014
VX_DIM_EX_RADBGC
@ VX_DIM_EX_RADBGC
big radial continuous dimension
Definition: zwapi_util.h:2034
VX_DIM_EX_GDHS
@ VX_DIM_EX_GDHS
horizontal datum symbol (1994) dimension
Definition: zwapi_util.h:2015
VX_DIM_EX_LOC
@ VX_DIM_EX_LOC
offset continuous dimension
Definition: zwapi_util.h:2026
VX_DIM_EX_LO
@ VX_DIM_EX_LO
offset dimension
Definition: zwapi_util.h:1989
VX_DIM_EX_LCL
@ VX_DIM_EX_LCL
leader chamfer dimension
Definition: zwapi_util.h:1997
VX_DIM_EX_LCA
@ VX_DIM_EX_LCA
aligned chamfer dimension
Definition: zwapi_util.h:1996
VX_DIM_EX_LCV
@ VX_DIM_EX_LCV
vertical chamfer dimension
Definition: zwapi_util.h:2029
VX_DIM_EX_LPB
@ VX_DIM_EX_LPB
projected baseline dimension
Definition: zwapi_util.h:1974
VX_DIM_EX_LVC
@ VX_DIM_EX_LVC
vertical continuous dimension
Definition: zwapi_util.h:1977
VX_DIM_EX_GF
@ VX_DIM_EX_GF
GD&T/feature symbol dimension.
Definition: zwapi_util.h:2058
VX_DIM_EX_GDVS
@ VX_DIM_EX_GDVS
vertical datum symbol (1994) dimension
Definition: zwapi_util.h:2016
VX_DIM_EX_LOO
@ VX_DIM_EX_LOO
offset ordinate dimension
Definition: zwapi_util.h:2027
VX_DIM_EX_ANGB
@ VX_DIM_EX_ANGB
baseline angular dimension
Definition: zwapi_util.h:2043
VX_DIM_EX_CLC
@ VX_DIM_EX_CLC
centerline curve
Definition: zwapi_util.h:2062
VX_DIM_EX_LH
@ VX_DIM_EX_LH
horizontal dimension
Definition: zwapi_util.h:1964
VX_DIM_EX_INTSYM
@ VX_DIM_EX_INTSYM
intersection symbol dimension
Definition: zwapi_util.h:2065
VX_DIM_EX_AUTO_LSY
@ VX_DIM_EX_AUTO_LSY
auto symmetric dimension
Definition: zwapi_util.h:2072
VX_DIM_EX_GDTC
@ VX_DIM_EX_GDTC
GD&T datum target area dimension.
Definition: zwapi_util.h:2021
VX_DIM_EX_GDTP
@ VX_DIM_EX_GDTP
GD&T datum target point dimension.
Definition: zwapi_util.h:2020
VX_DIM_EX_ANGHC
@ VX_DIM_EX_ANGHC
continuous horizontal-angular dimension
Definition: zwapi_util.h:2047
VX_DIM_EX_ANGO
@ VX_DIM_EX_ANGO
ordinate angular dimension
Definition: zwapi_util.h:2045
VX_DIM_EX_LRC
@ VX_DIM_EX_LRC
rotated continuous dimension
Definition: zwapi_util.h:1979
VX_DIM_EX_ANGH
@ VX_DIM_EX_ANGH
horizontal-angular dimension
Definition: zwapi_util.h:2002
VX_DIM_EX_ANGAC
@ VX_DIM_EX_ANGAC
continuous angular arc dimension
Definition: zwapi_util.h:2053
VX_DIM_EX_LCHV
@ VX_DIM_EX_LCHV
horizontal-vertical chamfer dimension
Definition: zwapi_util.h:1995
VX_DIM_EX_ANGAO
@ VX_DIM_EX_ANGAO
ordinate angular arc dimension
Definition: zwapi_util.h:2054
VX_DIM_EX_LVO
@ VX_DIM_EX_LVO
vertical ordinate dimension
Definition: zwapi_util.h:1983
VX_DIM_EX_LVB
@ VX_DIM_EX_LVB
vertical baseline dimension
Definition: zwapi_util.h:1971
VX_DIM_EX_RADBG
@ VX_DIM_EX_RADBG
big radial dimension
Definition: zwapi_util.h:2008
VX_DIM_EX_GDTL
@ VX_DIM_EX_GDTL
GD&T datum target line area dimension.
Definition: zwapi_util.h:2023
VX_DIM_EX_LOS
@ VX_DIM_EX_LOS
special offset dimension - point to line
Definition: zwapi_util.h:1990
VX_DIM_EX_LAO
@ VX_DIM_EX_LAO
aligned ordinate dimension
Definition: zwapi_util.h:1984
VX_DIM_EX_RADO
@ VX_DIM_EX_RADO
radial ordinate dimension
Definition: zwapi_util.h:2032
VX_DIM_EX_RADS
@ VX_DIM_EX_RADS
special radial dimension
Definition: zwapi_util.h:2039
VX_DIM_EX_RHO
@ VX_DIM_EX_RHO
conic ratio Rho
Definition: zwapi_util.h:2069
VX_DIM_EX_GFL
@ VX_DIM_EX_GFL
leader GD&T/feature symbol dimension
Definition: zwapi_util.h:2059
VX_DIM_EX_LHC
@ VX_DIM_EX_LHC
horizontal continuous dimension
Definition: zwapi_util.h:1976
VX_DIM_EX_LORD
@ VX_DIM_EX_LORD
leader coordinate dimension
Definition: zwapi_util.h:2066
VX_DIM_EX_ANGV
@ VX_DIM_EX_ANGV
vertical-angular dimension
Definition: zwapi_util.h:2003
VX_DIM_EX_ASY
@ VX_DIM_EX_ASY
Angular symmetry dimension.
Definition: zwapi_util.h:1993
VX_DIM_EX_CM
@ VX_DIM_EX_CM
centerline/centermark dimension
Definition: zwapi_util.h:2057
VX_DIM_EX_CRVL
@ VX_DIM_EX_CRVL
spline curve length dimension
Definition: zwapi_util.h:2068
VX_DIM_EX_LAC
@ VX_DIM_EX_LAC
aligned continuous dimension
Definition: zwapi_util.h:1978
VX_DIM_EX_GDTR
@ VX_DIM_EX_GDTR
GD&T datum target rectangle area dimension.
Definition: zwapi_util.h:2022
VX_DIM_EX_DIAC
@ VX_DIM_EX_DIAC
diametrical continuous dimension
Definition: zwapi_util.h:2041
VX_DIM_EX_RADBGO
@ VX_DIM_EX_RADBGO
big radial ordinate dimension
Definition: zwapi_util.h:2035
VX_DIM_EX_ANGVO
@ VX_DIM_EX_ANGVO
ordinate vertical-angular dimension
Definition: zwapi_util.h:2051
VX_DIM_EX_ANGC
@ VX_DIM_EX_ANGC
continuous angular dimension
Definition: zwapi_util.h:2044
VX_DIM_EX_DPLS
@ VX_DIM_EX_DPLS
datum projection dimension (line)
Definition: zwapi_util.h:2067
VX_DIM_EX_ANGVB
@ VX_DIM_EX_ANGVB
baseline vertical-angular dimension
Definition: zwapi_util.h:2049
VX_DIM_EX_RADB
@ VX_DIM_EX_RADB
radial baseline dimension
Definition: zwapi_util.h:2030
VX_DIM_EX_RADBKB
@ VX_DIM_EX_RADBKB
broken radial baseline dimension
Definition: zwapi_util.h:2036
VX_DIM_EX_RADBKO
@ VX_DIM_EX_RADBKO
broken radial ordinate dimension
Definition: zwapi_util.h:2038
VX_DIM_EX_LRO
@ VX_DIM_EX_LRO
rotated ordinate dimension
Definition: zwapi_util.h:1985
VX_DIM_EX_RADBKC
@ VX_DIM_EX_RADBKC
broken radial continuous dimension
Definition: zwapi_util.h:2037
VX_DIM_EX_BALL
@ VX_DIM_EX_BALL
balloon dimension
Definition: zwapi_util.h:2056
VX_DIM_EX_RADC
@ VX_DIM_EX_RADC
radial continuous dimension
Definition: zwapi_util.h:2031
VX_DIM_EX_LCH
@ VX_DIM_EX_LCH
horizontal chamfer dimension
Definition: zwapi_util.h:2028
VX_DIM_EX_LHO
@ VX_DIM_EX_LHO
horizontal ordinate dimension
Definition: zwapi_util.h:1982
VX_DIM_EX_LRB
@ VX_DIM_EX_LRB
rotated baseline dimension
Definition: zwapi_util.h:1973
VX_DIM_EX_LPO
@ VX_DIM_EX_LPO
projected ordinate dimension
Definition: zwapi_util.h:1986
VX_DIM_EX_ANGVC
@ VX_DIM_EX_ANGVC
continuous vertical-angular dimension
Definition: zwapi_util.h:2050
VX_DIM_EX_CRVL3D
@ VX_DIM_EX_CRVL3D
curve length
Definition: zwapi_util.h:2070
VX_DIM_EX_CLBS
@ VX_DIM_EX_CLBS
bisection centerline
Definition: zwapi_util.h:2063
VX_DIM_EX_ANGHB
@ VX_DIM_EX_ANGHB
baseline horizontal-angular dimension
Definition: zwapi_util.h:2046
VX_DIM_EX_LA
@ VX_DIM_EX_LA
aligned dimension
Definition: zwapi_util.h:1966
VX_DIM_EX_RADBGB
@ VX_DIM_EX_RADBGB
big radial baseline dimension
Definition: zwapi_util.h:2033
VX_DIM_EX_ANGAB
@ VX_DIM_EX_ANGAB
baseline angular arc dimension
Definition: zwapi_util.h:2052
VX_DIM_EX_LHVO
@ VX_DIM_EX_LHVO
horizontal and vertical ordinate dimension
Definition: zwapi_util.h:1987
VX_DIM_EX_ANG
@ VX_DIM_EX_ANG
angular dimension
Definition: zwapi_util.h:2001
VX_DIM_EX_RADL
@ VX_DIM_EX_RADL
radial leader dimension
Definition: zwapi_util.h:2011
VX_DIM_EX_LPC
@ VX_DIM_EX_LPC
projected continuous dimension
Definition: zwapi_util.h:1980
VX_DIM_EX_LCLS
@ VX_DIM_EX_LCLS
special chamfer leader dimension
Definition: zwapi_util.h:2061
VX_DIM_EX_LHB
@ VX_DIM_EX_LHB
horizontal baseline dimension
Definition: zwapi_util.h:1970
VX_DIM_EX_RADBK
@ VX_DIM_EX_RADBK
broken radial dimension
Definition: zwapi_util.h:2009
VX_DIM_EX_LP
@ VX_DIM_EX_LP
projected dimension
Definition: zwapi_util.h:1968
VX_DIM_EX_LSY
@ VX_DIM_EX_LSY
symmetry dimension
Definition: zwapi_util.h:1992
VX_DIM_EX_RAD
@ VX_DIM_EX_RAD
radial dimension
Definition: zwapi_util.h:2007
VX_DIM_EX_ELEV
@ VX_DIM_EX_ELEV
elevation dimension
Definition: zwapi_util.h:2071
VX_DIM_EX_ANGA
@ VX_DIM_EX_ANGA
angular arc dimension
Definition: zwapi_util.h:2004
VX_DIM_EX_LR
@ VX_DIM_EX_LR
rotated dimension
Definition: zwapi_util.h:1967
VX_DIM_EX_LOB
@ VX_DIM_EX_LOB
offset baseline dimension
Definition: zwapi_util.h:2025
VX_DIM_EX_LCLP
@ VX_DIM_EX_LCLP
leader chamfer dimension (always perpendicular)
Definition: zwapi_util.h:1998
VX_DIM_EX_LCLA
@ VX_DIM_EX_LCLA
leader chamfer dimension (always along the chamfered line)
Definition: zwapi_util.h:1999
VX_DIM_EX_ANGHO
@ VX_DIM_EX_ANGHO
ordinate horizontal-angular dimension
Definition: zwapi_util.h:2048
VX_DIM_EX_ANG3PT
@ VX_DIM_EX_ANG3PT
3 point angular dimension
Definition: zwapi_util.h:2005
VX_DIM_EX_GDH
@ VX_DIM_EX_GDH
horizontal datum (1982) dimension
Definition: zwapi_util.h:2013
VX_DIM_EX_DIAO
@ VX_DIM_EX_DIAO
diametrical ordinate dimension
Definition: zwapi_util.h:2042
VX_DIM_EX_GDL
@ VX_DIM_EX_GDL
leader datum (1994) dimension (circle, arc, curves)
Definition: zwapi_util.h:2017
VX_DIM_EX_LAB
@ VX_DIM_EX_LAB
aligned baseline dimension
Definition: zwapi_util.h:1972
VX_DIM_EX_ARCL
@ VX_DIM_EX_ARCL
arc length
Definition: zwapi_util.h:2064
VX_DIM_EX_LEAD
@ VX_DIM_EX_LEAD
leader dimension
Definition: zwapi_util.h:2055
VX_DIM_EX_DIAB
@ VX_DIM_EX_DIAB
diametrical baseline dimension
Definition: zwapi_util.h:2040
VX_DIM_EX_LV
@ VX_DIM_EX_LV
vertical dimension
Definition: zwapi_util.h:1965
VX_DIM_EX_GFP
@ VX_DIM_EX_GFP
profile GD&T/feature symbol dimension
Definition: zwapi_util.h:2060
VX_DIM_EX_GDLS
@ VX_DIM_EX_GDLS
leader datum (1994) dimension (line)
Definition: zwapi_util.h:2018
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxFCSSymbol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxFCSSymbol

enum evxFCSSymbol

#include <zwapi_util.h>

FCS MD&T symbol.

Enumerator
VX_FCSSYM_NONE | none
VX_FCSSYM_STRAIGHTNESS | straightness
VX_FCSSYM_FLATNESS | flatness
VX_FCSSYM_CIRCULARITY | circularity
VX_FCSSYM_CYLINDRICITY | cylindricity
VX_FCSSYM_PARALLELISM | parallelism
VX_FCSSYM_PERPENDICULARITY | perpendicularity
VX_FCSSYM_ANGULARITY | angularity
VX_FCSSYM_POSITION | position
VX_FCSSYM_CONCENTRICITY | concentricity
VX_FCSSYM_SYMMETRY | symmetry
VX_FCSSYM_PROFILE_OF_LINE | profile of a line
VX_FCSSYM_PROFILE_OF_SURFACE | profile of a surface
VX_FCSSYM_CIRCULAR_RUNOUT | circular run-out
VX_FCSSYM_TOTAL_RUNOUT | total run-out

Definition at line 2105 of file zwapi_util.h.

2106 {
2107 VX_FCSSYM_NONE = 0,
2108 VX_FCSSYM_STRAIGHTNESS,
2109 VX_FCSSYM_FLATNESS,
2110 VX_FCSSYM_CIRCULARITY,
2111 VX_FCSSYM_CYLINDRICITY,
2112 VX_FCSSYM_PARALLELISM,
2113 VX_FCSSYM_PERPENDICULARITY,
2114 VX_FCSSYM_ANGULARITY,
2115 VX_FCSSYM_POSITION,
2116 VX_FCSSYM_CONCENTRICITY,
2117 VX_FCSSYM_SYMMETRY,
2118 VX_FCSSYM_PROFILE_OF_LINE,
2119 VX_FCSSYM_PROFILE_OF_SURFACE,
2120 VX_FCSSYM_CIRCULAR_RUNOUT,
2121 VX_FCSSYM_TOTAL_RUNOUT,
2122 } evxFCSSymbol;
evxFCSSymbol
evxFCSSymbol
FCS MD&T symbol.
Definition: zwapi_util.h:2106
VX_FCSSYM_SYMMETRY
@ VX_FCSSYM_SYMMETRY
symmetry
Definition: zwapi_util.h:2117
VX_FCSSYM_PROFILE_OF_SURFACE
@ VX_FCSSYM_PROFILE_OF_SURFACE
profile of a surface
Definition: zwapi_util.h:2119
VX_FCSSYM_POSITION
@ VX_FCSSYM_POSITION
position
Definition: zwapi_util.h:2115
VX_FCSSYM_TOTAL_RUNOUT
@ VX_FCSSYM_TOTAL_RUNOUT
total run-out
Definition: zwapi_util.h:2121
VX_FCSSYM_STRAIGHTNESS
@ VX_FCSSYM_STRAIGHTNESS
straightness
Definition: zwapi_util.h:2108
VX_FCSSYM_CONCENTRICITY
@ VX_FCSSYM_CONCENTRICITY
concentricity
Definition: zwapi_util.h:2116
VX_FCSSYM_CIRCULARITY
@ VX_FCSSYM_CIRCULARITY
circularity
Definition: zwapi_util.h:2110
VX_FCSSYM_CYLINDRICITY
@ VX_FCSSYM_CYLINDRICITY
cylindricity
Definition: zwapi_util.h:2111
VX_FCSSYM_FLATNESS
@ VX_FCSSYM_FLATNESS
flatness
Definition: zwapi_util.h:2109
VX_FCSSYM_NONE
@ VX_FCSSYM_NONE
none
Definition: zwapi_util.h:2107
VX_FCSSYM_PROFILE_OF_LINE
@ VX_FCSSYM_PROFILE_OF_LINE
profile of a line
Definition: zwapi_util.h:2118
VX_FCSSYM_PERPENDICULARITY
@ VX_FCSSYM_PERPENDICULARITY
perpendicularity
Definition: zwapi_util.h:2113
VX_FCSSYM_PARALLELISM
@ VX_FCSSYM_PARALLELISM
parallelism
Definition: zwapi_util.h:2112
VX_FCSSYM_ANGULARITY
@ VX_FCSSYM_ANGULARITY
angularity
Definition: zwapi_util.h:2114
VX_FCSSYM_CIRCULAR_RUNOUT
@ VX_FCSSYM_CIRCULAR_RUNOUT
circular run-out
Definition: zwapi_util.h:2120
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxGeomCritPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxGeomCritPnt

enum evxGeomCritPnt

#include <zwapi_util.h>

type of sketch geometry critical point

Enumerator
VX_NO_POINT | set the entity not the critical point of entity
VX_FREE_POINT | free point, non-critical point
VX_START_POINT | start point of curve or line (if the input is face, get point of (u.min, v.min))
VX_END_POINT | end point of curve or line (if the input is face, get point of (u.max, v.max))
VX_CENTER_POINT | center point, used only for arc or circle (if the input is face, get point of ((u.min+u.max)/2, (v.min+v.max)/2))
VX_SPLINE_DEFINING_POINT | control point, used only for splines
VX_MIDDLE_POINT | middle point of curve or line
VX_ORIGIN_POINT | origin of datum plane and datum CSYS
Examples
sketch\skDrawingTest.cpp.

Definition at line 533 of file zwapi_util.h.

534 {
535 VX_NO_POINT,
536 VX_FREE_POINT = 0,
537 VX_START_POINT,
538 VX_END_POINT,
539 VX_CENTER_POINT,
540 VX_SPLINE_DEFINING_POINT,
541 VX_MIDDLE_POINT,
542 VX_ORIGIN_POINT
543 } evxGeomCritPnt;
evxGeomCritPnt
evxGeomCritPnt
type of sketch geometry critical point
Definition: zwapi_util.h:534
VX_END_POINT
@ VX_END_POINT
end point of curve or line (if the input is face, get point of (u.max, v.max))
Definition: zwapi_util.h:538
VX_MIDDLE_POINT
@ VX_MIDDLE_POINT
middle point of curve or line
Definition: zwapi_util.h:541
VX_NO_POINT
@ VX_NO_POINT
set the entity not the critical point of entity
Definition: zwapi_util.h:535
VX_CENTER_POINT
@ VX_CENTER_POINT
center point, used only for arc or circle (if the input is face, get point of ((u....
Definition: zwapi_util.h:539
VX_FREE_POINT
@ VX_FREE_POINT
free point, non-critical point
Definition: zwapi_util.h:536
VX_ORIGIN_POINT
@ VX_ORIGIN_POINT
origin of datum plane and datum CSYS
Definition: zwapi_util.h:542
VX_START_POINT
@ VX_START_POINT
start point of curve or line (if the input is face, get point of (u.min, v.min))
Definition: zwapi_util.h:537
VX_SPLINE_DEFINING_POINT
@ VX_SPLINE_DEFINING_POINT
control point, used only for splines
Definition: zwapi_util.h:540
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxPntLocation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxPntLocation

enum evxPntLocation

#include <zwapi_util.h>

point location

Enumerator
VX_PNT_OUT | point lies outside the boundary
VX_PNT_ON | point lies on the boundary
VX_PNT_IN | point lies inside the boundary
VX_PNT_NULL | unable to classify point location

Definition at line 602 of file zwapi_util.h.

603 {
604 VX_PNT_OUT = -1,
605 VX_PNT_ON = 0,
606 VX_PNT_IN = 1,
607 VX_PNT_NULL = -2
608 } evxPntLocation;
evxPntLocation
evxPntLocation
point location
Definition: zwapi_util.h:603
VX_PNT_OUT
@ VX_PNT_OUT
point lies outside the boundary
Definition: zwapi_util.h:604
VX_PNT_IN
@ VX_PNT_IN
point lies inside the boundary
Definition: zwapi_util.h:606
VX_PNT_NULL
@ VX_PNT_NULL
unable to classify point location
Definition: zwapi_util.h:607
VX_PNT_ON
@ VX_PNT_ON
point lies on the boundary
Definition: zwapi_util.h:605
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxCmTreeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxCmTreeType

enum evxCmTreeType

#include <zwapi_util.h>

cam tree type

Enumerator
CM_TREE_OP | opdef in tree
CM_TREE_COMP | component in tree
CM_TREE_FLD | folder in tree
CM_TREE_FTR | ftr in tree

Definition at line 2548 of file zwapi_util.h.

2549 {
2550 CM_TREE_OP = 0,
2551 CM_TREE_COMP = 1,
2552 CM_TREE_FLD = 2,
2553 CM_TREE_FTR = 3,
2555 }evxCmTreeType;
evxCmTreeType
evxCmTreeType
cam tree type
Definition: zwapi_util.h:2549
CM_TREE_FTR
@ CM_TREE_FTR
ftr in tree
Definition: zwapi_util.h:2553
CM_TREE_COMP
@ CM_TREE_COMP
component in tree
Definition: zwapi_util.h:2551
CM_TREE_FLD
@ CM_TREE_FLD
folder in tree
Definition: zwapi_util.h:2552
CM_TREE_OP
@ CM_TREE_OP
opdef in tree
Definition: zwapi_util.h:2550
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxDimState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxDimState

enum evxDimState

#include <zwapi_util.h>

dimension state

Enumerator
VX_DM_REVISION | revision dimension
VX_DM_NOSCALE | not scale dimension
VX_DM_MODIFIED | modified dimension
VX_DM_DANGLING | dangling dimension
VX_DM_NORMAL | default, normal state
VX_DM_IN_OBJ | the dimension is in other object, only need text display data

Definition at line 2091 of file zwapi_util.h.

2092 {
2093 VX_DM_REVISION = -4,
2094 VX_DM_NOSCALE = -3,
2095 VX_DM_MODIFIED = -2,
2096 VX_DM_DANGLING = -1,
2097 VX_DM_NORMAL = 0,
2098 VX_DM_IN_OBJ = 1,
2099 } evxDimState;
evxDimState
evxDimState
dimension state
Definition: zwapi_util.h:2092
VX_DM_NOSCALE
@ VX_DM_NOSCALE
not scale dimension
Definition: zwapi_util.h:2094
VX_DM_IN_OBJ
@ VX_DM_IN_OBJ
the dimension is in other object, only need text display data
Definition: zwapi_util.h:2098
VX_DM_NORMAL
@ VX_DM_NORMAL
default, normal state
Definition: zwapi_util.h:2097
VX_DM_MODIFIED
@ VX_DM_MODIFIED
modified dimension
Definition: zwapi_util.h:2095
VX_DM_DANGLING
@ VX_DM_DANGLING
dangling dimension
Definition: zwapi_util.h:2096
VX_DM_REVISION
@ VX_DM_REVISION
revision dimension
Definition: zwapi_util.h:2093
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxTextureLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxTextureLoc

enum evxTextureLoc

#include <zwapi_util.h>

texture map origin point with respect to texture map rectangle

Definition at line 1252 of file zwapi_util.h.

1253 {
1254 V_TEXTURE_LOWER_LEFT = 0,
1255 V_TEXTURE_UPPER_LEFT = 1,
1256 V_TEXTURE_UPPER_RIGHT = 2,
1257 V_TEXTURE_LOWER_RIGHT = 3,
1258 V_TEXTURE_CENTER = 4
1259 } evxTextureLoc;
evxTextureLoc
evxTextureLoc
texture map origin point with respect to texture map rectangle
Definition: zwapi_util.h:1253
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxFCSLmsOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Common Data
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ evxFCSLmsOption

enum evxFCSLmsOption

#include <zwapi_util.h>

FCS LMS option.

Enumerator
VX_LMS_NONE | none
VX_LMS_MAX_MATERIAL | maximum material condition
VX_LMS_MIN_MATERIAL | least material condition
VX_LMS_FTR_SIZE_REGARDLESS | regardless of feature size

Definition at line 2140 of file zwapi_util.h.

2141 {
2142 VX_LMS_NONE = 0,
2143 VX_LMS_MAX_MATERIAL,
2144 VX_LMS_MIN_MATERIAL,
2145 VX_LMS_FTR_SIZE_REGARDLESS,
2146 } evxFCSLmsOption;
evxFCSLmsOption
evxFCSLmsOption
FCS LMS option.
Definition: zwapi_util.h:2141
VX_LMS_FTR_SIZE_REGARDLESS
@ VX_LMS_FTR_SIZE_REGARDLESS
regardless of feature size
Definition: zwapi_util.h:2145
VX_LMS_MAX_MATERIAL
@ VX_LMS_MAX_MATERIAL
maximum material condition
Definition: zwapi_util.h:2143
VX_LMS_MIN_MATERIAL
@ VX_LMS_MIN_MATERIAL
least material condition
Definition: zwapi_util.h:2144
VX_LMS_NONE
@ VX_LMS_NONE
none
Definition: zwapi_util.h:2142
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: evxEqnSetOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • Variable Common API
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ evxEqnSetOpt

enum evxEqnSetOpt

#include <zwapi_var.h>

equation set option

Enumerator
VX_EQN_MANUAL_SET_EQN | manually set every equations
VX_EQN_AUTO_OVERWRITE_ALL_EQN | auto overwrite all repeated equations
VX_EQN_AUTO_NEW_ALL_EQN | auto create copy for all repeated equations
VX_EQN_AUTO_CANCEL_ALL_EQN | auto cancel the operation for all repeated equations

Definition at line 32 of file zwapi_var.h.

33 {
34 VX_EQN_MANUAL_SET_EQN = 0,
35 VX_EQN_AUTO_OVERWRITE_ALL_EQN = 1,
36 VX_EQN_AUTO_NEW_ALL_EQN = 2,
37 VX_EQN_AUTO_CANCEL_ALL_EQN = -1
38 } evxEqnSetOpt;
evxEqnSetOpt
evxEqnSetOpt
equation set option
Definition: zwapi_var.h:33
VX_EQN_MANUAL_SET_EQN
@ VX_EQN_MANUAL_SET_EQN
manually set every equations
Definition: zwapi_var.h:34
VX_EQN_AUTO_CANCEL_ALL_EQN
@ VX_EQN_AUTO_CANCEL_ALL_EQN
auto cancel the operation for all repeated equations
Definition: zwapi_var.h:37
VX_EQN_AUTO_OVERWRITE_ALL_EQN
@ VX_EQN_AUTO_OVERWRITE_ALL_EQN
auto overwrite all repeated equations
Definition: zwapi_var.h:35
VX_EQN_AUTO_NEW_ALL_EQN
@ VX_EQN_AUTO_NEW_ALL_EQN
auto create copy for all repeated equations
Definition: zwapi_var.h:36
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: Introductions

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Introductions
Here is a list of all related documentation pages:
[detail level 12]
▼ ListPages
Release Notes
API Structure Introduction
Introduction to the ZW3D API
Frequently Asked Questions
Remote Communication with ZW3D
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: _svxAppActionParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
_svxAppActionParam Struct Reference
Common » Global Apply

application action parameter More...

#include <zwapi_global_apply.h>

Data Fields

int(* | pfn )(void *param)
callback function More...
void * | param
parameter More...

Detailed Description

application action parameter

Definition at line 67 of file zwapi_global_apply.h.

The documentation for this struct was generated from the following file:
  • zwapi_global_apply.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: _svxAppActionParam::pfn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • _svxAppActionParam
param
pfn

◆ pfn

int(* _svxAppActionParam::pfn) (void *param)

callback function

Definition at line 69 of file zwapi_global_apply.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: _svxAppActionParam::param

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • _svxAppActionParam
param
pfn

◆ param

void* _svxAppActionParam::param

parameter

Definition at line 70 of file zwapi_global_apply.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svx3DBomData Struct Reference
Assembly Objects » Assembly Data

3d BOM row data More...

#include <zwapi_asm_data.h>

Data Fields

int | cntRow
the total number of row in the table. More...
int | cntCol
the total number of column in the table. More...
vxLongName ** list
table data. More...

Detailed Description

3d BOM row data

Definition at line 76 of file zwapi_asm_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomData::list

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomData
cntCol
cntRow
list

◆ list

vxLongName** svx3DBomData::list

table data.

Definition at line 80 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomData::cntCol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomData
cntCol
cntRow
list

◆ cntCol

int svx3DBomData::cntCol

the total number of column in the table.

Definition at line 79 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomData::cntRow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomData
cntCol
cntRow
list

◆ cntRow

int svx3DBomData::cntRow

the total number of row in the table.

Definition at line 78 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svx3DBomSettingsData Struct Reference
Assembly Objects » Assembly Data

3D BOM display settings data More...

#include <zwapi_asm_data.h>

Data Structures

struct svxBomColumn

Data Fields

evx3DBomLevelDispMode mode
display mode More...
int | countColumn
number of columns display More...
struct svx3DBomSettingsData::svxBomColumn * | listColumnData

Detailed Description

3D BOM display settings data

Definition at line 58 of file zwapi_asm_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::svxBomColumn Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
  • svxBomColumn
Data Fields
svx3DBomSettingsData::svxBomColumn Struct Reference

Data Fields

vxLongName attrName
The name of the column attribute that will be displayed in the 3d bom table. More...
int | isCheck
1 if set the specified property name to display, else 0 More...
int | isTotal
isTotal indicates whether to select to display totals(1 or 0).default:0. Totals are usually displayed only if the content is numeric. More...

Detailed Description

Definition at line 62 of file zwapi_asm_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::svxBomColumn::isCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
  • svxBomColumn
attrName
isCheck
isTotal

◆ isCheck

int svx3DBomSettingsData::svxBomColumn::isCheck

1 if set the specified property name to display, else 0

Definition at line 65 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::svxBomColumn::attrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
  • svxBomColumn
attrName
isCheck
isTotal

◆ attrName

vxLongName svx3DBomSettingsData::svxBomColumn::attrName

The name of the column attribute that will be displayed in the 3d bom table.

Definition at line 64 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::svxBomColumn::isTotal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
  • svxBomColumn
attrName
isCheck
isTotal

◆ isTotal

int svx3DBomSettingsData::svxBomColumn::isTotal

isTotal indicates whether to select to display totals(1 or 0).default:0. Totals are usually displayed only if the content is numeric.

Definition at line 66 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::mode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
countColumn
mode

◆ mode

evx3DBomLevelDispMode svx3DBomSettingsData::mode

display mode

Definition at line 60 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svx3DBomSettingsData::countColumn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svx3DBomSettingsData
countColumn
mode

◆ countColumn

int svx3DBomSettingsData::countColumn

number of columns display

Definition at line 61 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlign Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

Alignment constraint. More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxData Entity1
"isPntOnCrv" or "isPntOnFace" required More...
svxData Entity2
"isPntOnCrv" or "isPntOnFace" required point must be defined in active part space (see cvxPntOnFace()) More...
evxAlignType Type
alignment type More...
double | Offset
distance between alignment entities More...
double | Angle
angle between alignment entities More...
int | isOpposite
1 to make entities opposite facing, else 0 More...
int | ShowExistingAlign
1 to display of existing alignment constraints for the active component, else 0 More...
evxAlignInterference Interference
interference options More...

Detailed Description

Alignment constraint.

Definition at line 173 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::ShowExistingAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ ShowExistingAlign

int svxAlign::ShowExistingAlign

1 to display of existing alignment constraints for the active component, else 0

Definition at line 184 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Type

evxAlignType svxAlign::Type

alignment type

Definition at line 180 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Entity2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Entity2

svxData svxAlign::Entity2

"isPntOnCrv" or "isPntOnFace" required point must be defined in active part space (see cvxPntOnFace())

Definition at line 176 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Offset

double svxAlign::Offset

distance between alignment entities

Definition at line 181 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::isOpposite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ isOpposite

int svxAlign::isOpposite

1 to make entities opposite facing, else 0

Definition at line 183 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Interference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Interference

evxAlignInterference svxAlign::Interference

interference options

Definition at line 185 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Angle

double svxAlign::Angle

angle between alignment entities

Definition at line 182 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlign::Entity1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlign
Angle
Entity1
Entity2
Interference
isOpposite
Offset
ShowExistingAlign
Type

◆ Entity1

svxData svxAlign::Entity1

"isPntOnCrv" or "isPntOnFace" required

Definition at line 175 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignFrame Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlignFrame Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

copy/move entities by aligning frames More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | idFrom
from frame More...
int | idTo
to frames More...

Detailed Description

copy/move entities by aligning frames

Definition at line 1547 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignFrame::idFrom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignFrame
idFrom
idTo

◆ idFrom

int svxAlignFrame::idFrom

from frame

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1549 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignFrame::idTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignFrame
idFrom
idTo

◆ idTo

int svxAlignFrame::idTo

to frames

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1550 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlignSecViewData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

aligned section view data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
the id of base view to section More...
svxPoint2 basePnt
base point of the section More...
int | cntBasePnts
the count of the base points More...
svxPoint2 * pBasePnts
points to define the section More...
int | cntAlignPnts
the count of the align points More...
svxPoint2 * pAlignPnts
points to define aligned cutting plane More...
svxPoint2 locPnt
the location for section view More...
svxViewSecMtd secMtd
section method More...
svxViewSecLine secLine
section line More...
svxViewSecOp secOp
section option More...

Detailed Description

aligned section view data

Definition at line 377 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::basePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ basePnt

svxPoint2 svxAlignSecViewData::basePnt

base point of the section

Definition at line 380 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::cntBasePnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ cntBasePnts

int svxAlignSecViewData::cntBasePnts

the count of the base points

Definition at line 381 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::secLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ secLine

svxViewSecLine svxAlignSecViewData::secLine

section line

Definition at line 387 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::locPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ locPnt

svxPoint2 svxAlignSecViewData::locPnt

the location for section view

Definition at line 385 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ idView

int svxAlignSecViewData::idView

the id of base view to section

Definition at line 379 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::pBasePnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ pBasePnts

svxPoint2* svxAlignSecViewData::pBasePnts

points to define the section

Definition at line 382 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::secMtd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ secMtd

svxViewSecMtd svxAlignSecViewData::secMtd

section method

Definition at line 386 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::cntAlignPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ cntAlignPnts

int svxAlignSecViewData::cntAlignPnts

the count of the align points

Definition at line 383 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::pAlignPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ pAlignPnts

svxPoint2* svxAlignSecViewData::pAlignPnts

points to define aligned cutting plane

Definition at line 384 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlignSecViewData::secOp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlignSecViewData
basePnt
cntAlignPnts
cntBasePnts
idView
locPnt
pAlignPnts
pBasePnts
secLine
secMtd
secOp

◆ secOp

svxViewSecOp svxAlignSecViewData::secOp

section option

Definition at line 388 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlongDir Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

copy/move entities along a direction More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPntOnEnt Dir
direction More...
double | Dist
distance value More...
int | UnuseAng
angle enable (default 0) More...
double | Ang
angle value More...

Detailed Description

copy/move entities along a direction

Definition at line 1525 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlongDir2D Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

copy/move entities along a direction (2D) More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxVector2 dir
move direction More...
double | distance
distance More...
svxPoint2 BasePoint
base point More...
double | angle
angle More...
double | scale
scale More...

Detailed Description

copy/move entities along a direction (2D)

Definition at line 630 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D::BasePoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir2D
angle
BasePoint
dir
distance
scale

◆ BasePoint

svxPoint2 svxAlongDir2D::BasePoint

base point

Examples
sketch\basicEditingTest.cpp.

Definition at line 634 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir2D
angle
BasePoint
dir
distance
scale

◆ scale

double svxAlongDir2D::scale

scale

Examples
sketch\basicEditingTest.cpp.

Definition at line 636 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir2D
angle
BasePoint
dir
distance
scale

◆ distance

double svxAlongDir2D::distance

distance

Examples
sketch\basicEditingTest.cpp.

Definition at line 633 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir2D
angle
BasePoint
dir
distance
scale

◆ dir

svxVector2 svxAlongDir2D::dir

move direction

Examples
sketch\basicEditingTest.cpp.

Definition at line 632 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir2D::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir2D
angle
BasePoint
dir
distance
scale

◆ angle

double svxAlongDir2D::angle

angle

Examples
sketch\basicEditingTest.cpp.

Definition at line 635 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir::Dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir
Ang
Dir
Dist
UnuseAng

◆ Dist

double svxAlongDir::Dist

distance value

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1528 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir::UnuseAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir
Ang
Dir
Dist
UnuseAng

◆ UnuseAng

int svxAlongDir::UnuseAng

angle enable (default 0)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1529 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir::Ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir
Ang
Dir
Dist
UnuseAng

◆ Ang

double svxAlongDir::Ang

angle value

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1530 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongDir::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongDir
Ang
Dir
Dist
UnuseAng

◆ Dir

svxPntOnEnt svxAlongDir::Dir

direction

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1527 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAlongPath Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

copy/move entities along path More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPntOnEnt Path
path More...
int | cntPnts
count of points More...
svxPntOnEnt * ToPnts
to points More...
int | FrameOpt
frame option(0-default frame, 1-at path, 2-selected) More...
int | IdFrame
frame is selected( if FrameOpt = 2) More...
evxSweepZOpt ZAxisOpt
Z Axis option. More...
svxPntOnEnt ZAxisCurve
entity data of z-axis (ignore when zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_TO_CRV- curve(set parent if the curve from the sketch) VX_SWP_Z_FIXED_DIR - use direction (just direction or direction from an curve/edge) More...
evxSweepXOpt XAxisOpt
X Axis option (exclude VX_SWP_X_FACE_NORMAL) More...
svxPntOnEnt XAxisCurve
entity data of x-axis (ignore when XAxisOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR- use direction (just direction or direction from an curve/edge) More...

Detailed Description

copy/move entities along path

Definition at line 1557 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::ZAxisCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ ZAxisCurve

svxPntOnEnt svxAlongPath::ZAxisCurve

entity data of z-axis (ignore when zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_TO_CRV- curve(set parent if the curve from the sketch) VX_SWP_Z_FIXED_DIR - use direction (just direction or direction from an curve/edge)

Definition at line 1565 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::Path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ Path

svxPntOnEnt svxAlongPath::Path

path

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1559 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::ZAxisOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ ZAxisOpt

evxSweepZOpt svxAlongPath::ZAxisOpt

Z Axis option.

Definition at line 1564 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::FrameOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ FrameOpt

int svxAlongPath::FrameOpt

frame option(0-default frame, 1-at path, 2-selected)

Definition at line 1562 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::cntPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ cntPnts

int svxAlongPath::cntPnts

count of points

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1560 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::IdFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ IdFrame

int svxAlongPath::IdFrame

frame is selected( if FrameOpt = 2)

Definition at line 1563 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::ToPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ ToPnts

svxPntOnEnt* svxAlongPath::ToPnts

to points

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1561 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::XAxisOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ XAxisOpt

evxSweepXOpt svxAlongPath::XAxisOpt

X Axis option (exclude VX_SWP_X_FACE_NORMAL)

Definition at line 1568 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAlongPath::XAxisCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAlongPath
cntPnts
FrameOpt
IdFrame
Path
ToPnts
XAxisCurve
XAxisOpt
ZAxisCurve
ZAxisOpt

◆ XAxisCurve

svxPntOnEnt svxAlongPath::XAxisCurve

entity data of x-axis (ignore when XAxisOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR- use direction (just direction or direction from an curve/edge)

Definition at line 1569 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxArcData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

3D arc data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxArcType arcType
type to create an arc More...
svxPntOnEntPath startPnt
start point of arc, used when type isn't VX_ARC_ANGLE More...
svxPntOnEntPath endPnt
end point of arc, used when type isn't VX_ARC_ANGLE More...
svxPntOnEntPath centerPnt
through point or center point of arc, used when type is VX_ARC_THROUGH or VX_ARC_CENTER More...
double | radius
radius of arc, used when type is VX_ARC_RADIUS More...
double | startAngle
start angle of arc (deg), used when type is VX_ARC_ANGLE More...
double | arcAngle
angle of arc (deg), used when type is VX_ARC_ANGLE More...
int | idAlignPln
id of the alignment datum plane or planar face(0 to ignore) More...
int | prjToPln
whether to project arc to alignment plane More...
int | arcDir
indicate the direction for angular input (0: counter; 1: clockwise), used when type is VX_ARC_CENTER or VX_ARC_CENTER More...
svxPntOnEntPath * location
indicate arc, used when type is VX_ARC_RADIUS More...

Detailed Description

3D arc data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 76 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::arcAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ arcAngle

double svxArcData::arcAngle

angle of arc (deg), used when type is VX_ARC_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 84 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ radius

double svxArcData::radius

radius of arc, used when type is VX_ARC_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 82 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ startPnt

svxPntOnEntPath svxArcData::startPnt

start point of arc, used when type isn't VX_ARC_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 79 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::endPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ endPnt

svxPntOnEntPath svxArcData::endPnt

end point of arc, used when type isn't VX_ARC_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 80 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::startAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ startAngle

double svxArcData::startAngle

start angle of arc (deg), used when type is VX_ARC_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 83 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::arcDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ arcDir

int svxArcData::arcDir

indicate the direction for angular input (0: counter; 1: clockwise), used when type is VX_ARC_CENTER or VX_ARC_CENTER

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 88 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::idAlignPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ idAlignPln

int svxArcData::idAlignPln

id of the alignment datum plane or planar face(0 to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 86 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::centerPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ centerPnt

svxPntOnEntPath svxArcData::centerPnt

through point or center point of arc, used when type is VX_ARC_THROUGH or VX_ARC_CENTER

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 81 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::prjToPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ prjToPln

int svxArcData::prjToPln

whether to project arc to alignment plane

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 87 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ location

svxPntOnEntPath* svxArcData::location

indicate arc, used when type is VX_ARC_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 89 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxArcData::arcType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxArcData
arcAngle
arcDir
arcType
centerPnt
endPnt
idAlignPln
location
prjToPln
radius
startAngle
startPnt

◆ arcType

evxArcType svxArcData::arcType

type to create an arc

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 78 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAreaProp Struct Reference
Common » General Entity API

area properties More...

#include <zwapi_general_ent.h>

Data Fields

svxPoint refPnt
ref point More...
svxPoint centPnt
centroid More...
double | dArea
area(mm^2) More...
double | dPerim
perimeter(mm) More...
double | dDensity
density(kg/mm^3) More...
double | dAMass
mass(kg) More...
svxPrfAreaProp * pAreaRef
area properties about ref More...
svxPrfAreaProp * pAreaCA
area properties about centroid More...

Detailed Description

area properties

Definition at line 30 of file zwapi_general_ent.h.

The documentation for this struct was generated from the following file:
  • zwapi_general_ent.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::dAMass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ dAMass

double svxAreaProp::dAMass

mass(kg)

Definition at line 37 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::refPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ refPnt

svxPoint svxAreaProp::refPnt

ref point

Definition at line 32 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::centPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ centPnt

svxPoint svxAreaProp::centPnt

centroid

Definition at line 33 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::dPerim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ dPerim

double svxAreaProp::dPerim

perimeter(mm)

Definition at line 35 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::pAreaCA

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ pAreaCA

svxPrfAreaProp* svxAreaProp::pAreaCA

area properties about centroid

Definition at line 39 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::pAreaRef

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ pAreaRef

svxPrfAreaProp* svxAreaProp::pAreaRef

area properties about ref

Definition at line 38 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::dDensity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ dDensity

double svxAreaProp::dDensity

density(kg/mm^3)

Definition at line 36 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAreaProp::dArea

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAreaProp
centPnt
dAMass
dArea
dDensity
dPerim
pAreaCA
pAreaRef
refPnt

◆ dArea

double svxAreaProp::dArea

area(mm^2)

Definition at line 34 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAroundDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAroundDir Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

rotate entities around a direction More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPntOnEnt Dir
direction More...
double Ang
angle value More...

Detailed Description

rotate entities around a direction

Definition at line 1537 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAroundDir::Ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAroundDir
Ang
Dir

◆ Ang

double svxAroundDir::Ang

angle value

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1540 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAroundDir::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAroundDir
Ang
Dir

◆ Dir

svxPntOnEnt svxAroundDir::Dir

direction

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1539 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAsmChmf Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly chamfer data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

union svxAsmChmfData
assembly chamfer data More...

Data Fields

evxAsmChmfType type
chamfer type More...
evxAsmChmfBase baseFace
base faces option.default:VX_ASM_CHMF_BASE_SEM More...
int | propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0 More...
int | numEnt
the number of entities More...
svxEntPath * pEnts
the list path of entities More...
union svxAsmChmf::svxAsmChmfData | chamfer

Detailed Description

assembly chamfer data

Definition at line 882 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
Data Fields
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf Struct Reference

edge chamfer type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

double | S
setback.default:5 More...
int | patch
whether to use patch for tight corners(0 = no, 1 = yes).default:0 More...
int | force
whether to force local corner(0 = no, 1 = yes).default:0 More...
int | mitred
whether to mitred corners(0 = no, 1 = yes).default:0 More...
int | trace
whether to trace corners(0 = no, 1 = yes).default:0 More...
int | undercut
whether to search for undercuts(0 = no, 1 = yes).default:0 More...
int | blend
whether to blend corners(0 = no, 1 = yes).default:0 More...
int | sample
whether to use specify sample density(0 = no, 1 = yes).default:0 More...
int | density
density.default:10 More...
evxAsmChmfFace filletFace
fillet face option.default:VX_ASM_CHMF_FACE_MATCH More...

Detailed Description

edge chamfer type

<

Definition at line 891 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::trace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ trace

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::trace

whether to trace corners(0 = no, 1 = yes).default:0

Definition at line 897 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::S

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ S

double svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::S

setback.default:5

Definition at line 893 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::patch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ patch

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::patch

whether to use patch for tight corners(0 = no, 1 = yes).default:0

Definition at line 894 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::undercut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ undercut

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::undercut

whether to search for undercuts(0 = no, 1 = yes).default:0

Definition at line 898 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::force

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ force

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::force

whether to force local corner(0 = no, 1 = yes).default:0

Definition at line 895 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::mitred

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ mitred

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::mitred

whether to mitred corners(0 = no, 1 = yes).default:0

Definition at line 896 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::density

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ density

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::density

density.default:10

Definition at line 901 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::sample

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ sample

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::sample

whether to use specify sample density(0 = no, 1 = yes).default:0

Definition at line 900 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::blend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ blend

int svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::blend

whether to blend corners(0 = no, 1 = yes).default:0

Definition at line 899 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::filletFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmEdgeChmf
blend
density
filletFace
force
mitred
patch
S
sample
trace
undercut

◆ filletFace

evxAsmChmfFace svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::filletFace

fillet face option.default:VX_ASM_CHMF_FACE_MATCH

Definition at line 902 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmVertexChmf
Data Fields
svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf Struct Reference

vertex chamfer type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

double S
setback.default:10 More...

Detailed Description

vertex chamfer type

<

Definition at line 904 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf::S

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
  • svxAsmVertexChmf
S

◆ S

double svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf::S

setback.default:10

Definition at line 906 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
baseFace
numEnt
pEnts
propagate
type

◆ pEnts

svxEntPath* svxAsmChmf::pEnts

the list path of entities

Definition at line 888 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
baseFace
numEnt
pEnts
propagate
type

◆ type

evxAsmChmfType svxAsmChmf::type

chamfer type

Definition at line 884 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::baseFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
baseFace
numEnt
pEnts
propagate
type

◆ baseFace

evxAsmChmfBase svxAsmChmf::baseFace

base faces option.default:VX_ASM_CHMF_BASE_SEM

Definition at line 885 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
baseFace
numEnt
pEnts
propagate
type

◆ numEnt

int svxAsmChmf::numEnt

the number of entities

Definition at line 887 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::propagate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
baseFace
numEnt
pEnts
propagate
type

◆ propagate

int svxAsmChmf::propagate

whether to propagate feature to components(0 = no, 1 = yes).default:0

Definition at line 886 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAsmCut Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly cut data More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | numCut
number of cutter entities More...
svxEntPath * pCuts
list of path's of cutter entities More...
int | numComp
number of component entities More...
svxEntPath * pComps
list of path's of component entities More...
int | propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0 More...
int | hide
whether to hide cutter(0 = no, 1 = yes).default:0 More...

Detailed Description

assembly cut data

Definition at line 814 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::numComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ numComp

int svxAsmCut::numComp

number of component entities

Definition at line 818 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::pCuts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ pCuts

svxEntPath* svxAsmCut::pCuts

list of path's of cutter entities

Definition at line 817 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::numCut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ numCut

int svxAsmCut::numCut

number of cutter entities

Definition at line 816 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::hide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ hide

int svxAsmCut::hide

whether to hide cutter(0 = no, 1 = yes).default:0

Definition at line 821 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::propagate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ propagate

int svxAsmCut::propagate

whether to propagate feature to components(0 = no, 1 = yes).default:0

Definition at line 820 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmCut::pComps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmCut
hide
numComp
numCut
pComps
pCuts
propagate

◆ pComps

svxEntPath* svxAsmCut::pComps

list of path's of component entities

Definition at line 819 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAsmFllt Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly fillet data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

union svxAsmFlltData
union of assembly fillet data More...

Data Fields

evxChamFlltType type
fillet type, "type" cannot be equal to VX_CHAMFLLT_ASYMMETRIC More...
int | undercut
whether to search for undercuts(0 = no, 1 = yes).default:0 More...
int | blend
whether to blend corners(0 = no, 1 = yes).default:0 More...
int | sample
whether to use specify sample density(0 = no, 1 = yes).default:0 More...
int | density
density.default:10 More...
evxAsmFlltBase baseFace
base faces option.default:VX_ASM_FLLT_BASE_SEW More...
int | propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0 More...
int | numEnt
the number of entities More...
svxEntPath * pEnts
the list path of entities More...
int * | vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_ASM_FLLT_VERTEX type, other types can be set to NULL More...
union svxAsmFllt::svxAsmFlltData | fillet

Detailed Description

assembly fillet data

Definition at line 828 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
Data Fields
svxAsmFllt::svxAsmFlltData::svxAsmEdge Struct Reference

edge fillet type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

double | R
radius.default:5 More...
double | relief
relief.default:0 More...
evxAsmFlltArc arc
arc option.default:VX_ASM_FLLT_ARC_CIR More...
double | conic
conic ratio.default:0.5 More...
int | hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0 More...
int | force
whether to force local corner(0 = no, 1 = yes).default:0 More...
int | mitred
whether to mitred corners(0 = no, 1 = yes).default:0 More...
int | trace
whether to trace corners(0 = no, 1 = yes).default:0 More...
evxAsmFlltFace filletFace
fillet face option.default:VX_ASM_FLLT_FACE_MATCH More...

Detailed Description

edge fillet type

<

Definition at line 844 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::arc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ arc

evxAsmFlltArc svxAsmFllt::svxAsmFlltData::svxAsmEdge::arc

arc option.default:VX_ASM_FLLT_ARC_CIR

Definition at line 848 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ relief

double svxAsmFllt::svxAsmFlltData::svxAsmEdge::relief

relief.default:0

Definition at line 847 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::force

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ force

int svxAsmFllt::svxAsmFlltData::svxAsmEdge::force

whether to force local corner(0 = no, 1 = yes).default:0

Definition at line 851 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::filletFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ filletFace

evxAsmFlltFace svxAsmFllt::svxAsmFlltData::svxAsmEdge::filletFace

fillet face option.default:VX_ASM_FLLT_FACE_MATCH

Definition at line 854 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::mitred

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ mitred

int svxAsmFllt::svxAsmFlltData::svxAsmEdge::mitred

whether to mitred corners(0 = no, 1 = yes).default:0

Definition at line 852 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::hold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ hold

int svxAsmFllt::svxAsmFlltData::svxAsmEdge::hold

whether to hold fillet to edge(0 = no, 1 = yes).default:0

Definition at line 850 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::trace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ trace

int svxAsmFllt::svxAsmFlltData::svxAsmEdge::trace

whether to trace corners(0 = no, 1 = yes).default:0

Definition at line 853 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::conic

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ conic

double svxAsmFllt::svxAsmFlltData::svxAsmEdge::conic

conic ratio.default:0.5

Definition at line 849 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmEdge::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmEdge
arc
conic
filletFace
force
hold
mitred
R
relief
trace

◆ R

double svxAsmFllt::svxAsmFlltData::svxAsmEdge::R

radius.default:5

Definition at line 846 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
Data Fields
svxAsmFllt::svxAsmFlltData::svxAsmLoop Struct Reference

loop fillet type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | numSel
the number of selected edges entities More...
svxEntPath * pSels
the list path of selected edges entities More...
double | R
radius.default:5 More...
double | relief
relief.default:0 More...
evxAsmFlltLoop loop
loop option.default:VX_ASM_FLLT_LOOP_OUT More...
evxAsmFlltArc arc
arc option.default:VX_ASM_FLLT_ARC_CIR More...
double | conic
conic ratio.default:0.5 More...
int | hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0 More...
int | force
whether to force local corner(0 = no, 1 = yes).default:0 More...
int | mitred
whether to mitred corners(0 = no, 1 = yes).default:0 More...
int | trace
whether to trace corners(0 = no, 1 = yes).default:0 More...
evxAsmFlltFace filletFace
fillet face option.default:VX_ASM_FLLT_FACE_MATCH More...

Detailed Description

loop fillet type

<

Definition at line 856 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::force

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ force

int svxAsmFllt::svxAsmFlltData::svxAsmLoop::force

whether to force local corner(0 = no, 1 = yes).default:0

Definition at line 866 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ R

double svxAsmFllt::svxAsmFlltData::svxAsmLoop::R

radius.default:5

Definition at line 860 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::arc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ arc

evxAsmFlltArc svxAsmFllt::svxAsmFlltData::svxAsmLoop::arc

arc option.default:VX_ASM_FLLT_ARC_CIR

Definition at line 863 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::mitred

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ mitred

int svxAsmFllt::svxAsmFlltData::svxAsmLoop::mitred

whether to mitred corners(0 = no, 1 = yes).default:0

Definition at line 867 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::conic

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ conic

double svxAsmFllt::svxAsmFlltData::svxAsmLoop::conic

conic ratio.default:0.5

Definition at line 864 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ relief

double svxAsmFllt::svxAsmFlltData::svxAsmLoop::relief

relief.default:0

Definition at line 861 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::pSels

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ pSels

svxEntPath* svxAsmFllt::svxAsmFlltData::svxAsmLoop::pSels

the list path of selected edges entities

Definition at line 859 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::filletFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ filletFace

evxAsmFlltFace svxAsmFllt::svxAsmFlltData::svxAsmLoop::filletFace

fillet face option.default:VX_ASM_FLLT_FACE_MATCH

Definition at line 869 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::trace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ trace

int svxAsmFllt::svxAsmFlltData::svxAsmLoop::trace

whether to trace corners(0 = no, 1 = yes).default:0

Definition at line 868 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::loop

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ loop

evxAsmFlltLoop svxAsmFllt::svxAsmFlltData::svxAsmLoop::loop

loop option.default:VX_ASM_FLLT_LOOP_OUT

Definition at line 862 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::hold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ hold

int svxAsmFllt::svxAsmFlltData::svxAsmLoop::hold

whether to hold fillet to edge(0 = no, 1 = yes).default:0

Definition at line 865 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmLoop::numSel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmLoop
arc
conic
filletFace
force
hold
loop
mitred
numSel
pSels
R
relief
trace

◆ numSel

int svxAsmFllt::svxAsmFlltData::svxAsmLoop::numSel

the number of selected edges entities

Definition at line 858 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmVertex Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmVertex
Data Fields
svxAsmFllt::svxAsmFlltData::svxAsmVertex Struct Reference

vertex fillet type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

double setback
setback.default:5 More...

Detailed Description

vertex fillet type

<

Definition at line 871 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData::svxAsmVertex::setback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
  • svxAsmVertex
setback

◆ setback

double svxAsmFllt::svxAsmFlltData::svxAsmVertex::setback

setback.default:5

Definition at line 873 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::blend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ blend

int svxAsmFllt::blend

whether to blend corners(0 = no, 1 = yes).default:0

Definition at line 832 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::vertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ vertex

int* svxAsmFllt::vertex

list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_ASM_FLLT_VERTEX type, other types can be set to NULL

Definition at line 839 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::baseFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ baseFace

evxAsmFlltBase svxAsmFllt::baseFace

base faces option.default:VX_ASM_FLLT_BASE_SEW

Definition at line 835 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::density

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ density

int svxAsmFllt::density

density.default:10

Definition at line 834 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::propagate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ propagate

int svxAsmFllt::propagate

whether to propagate feature to components(0 = no, 1 = yes).default:0

Definition at line 836 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::sample

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ sample

int svxAsmFllt::sample

whether to use specify sample density(0 = no, 1 = yes).default:0

Definition at line 833 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ type

evxChamFlltType svxAsmFllt::type

fillet type, "type" cannot be equal to VX_CHAMFLLT_ASYMMETRIC

Definition at line 830 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ pEnts

svxEntPath* svxAsmFllt::pEnts

the list path of entities

Definition at line 838 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ numEnt

int svxAsmFllt::numEnt

the number of entities

Definition at line 837 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::undercut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
baseFace
blend
density
numEnt
pEnts
propagate
sample
type
undercut
vertex

◆ undercut

int svxAsmFllt::undercut

whether to search for undercuts(0 = no, 1 = yes).default:0

Definition at line 831 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAsmGrpCompData Struct Reference

group as sub-assembly data More...

#include <zwapi_asm_data.h>

Data Fields

vxPath file
the file which the grouped sub-assembly to be created belongs to If isPartOnly = 0, user need to set this parameter. More...
vxRootName part
the name of the grouped sub-assembly to be created (part[0]=0 to use default) More...
int | isVirtual
1-the grouped sub-assembly is virtual assembly, else 0 More...
int | isPartOnly
1-create part only, 0-create file and part(only use for Z3) More...
int | count
count of paths More...
svxEntPath * paths
the components to be grouped More...

Detailed Description

group as sub-assembly data

Definition at line 90 of file zwapi_asm_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::isVirtual

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ isVirtual

int svxAsmGrpCompData::isVirtual

1-the grouped sub-assembly is virtual assembly, else 0

Definition at line 95 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::file

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ file

vxPath svxAsmGrpCompData::file

the file which the grouped sub-assembly to be created belongs to If isPartOnly = 0, user need to set this parameter.

Definition at line 92 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::paths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ paths

svxEntPath* svxAsmGrpCompData::paths

the components to be grouped

Definition at line 98 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::isPartOnly

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ isPartOnly

int svxAsmGrpCompData::isPartOnly

1-create part only, 0-create file and part(only use for Z3)

Definition at line 96 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ count

int svxAsmGrpCompData::count

count of paths

Definition at line 97 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmGrpCompData::part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmGrpCompData
count
file
isPartOnly
isVirtual
part
paths

◆ part

vxRootName svxAsmGrpCompData::part

the name of the grouped sub-assembly to be created (part[0]=0 to use default)

Definition at line 94 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAsmMirror Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly mirror data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

union AsmMirrorData
union of assembly Mirror data More...

Data Fields

evxAsmMirrorType type
mirror method More...
int | Count
number of base entities for mirror More...
svxEntPath * pEnts
list of path's of base entities More...
svxEntPath pPlane
the path of mirror plane entity More...
int | erase
whether to erase source geometry(0 = no, 1 = yes).default:0 More...
evxAsmMirrorCenter center
center option.default:VX_ASM_MIRROR_CTR_BOX More...
union svxAsmMirror::AsmMirrorData | mirror

Detailed Description

assembly mirror data

Definition at line 781 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
Data Fields
svxAsmMirror::AsmMirrorData::AsmDup Struct Reference

duplicate type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | geometry
whether to keep geometry associative(0 = no, 1 = yes).default:1 More...
int | position
whether to keep position associative(0 = no, 1 = yes).default:1 More...
evxAsmMirrorCategory cat
category option.default:VX_ASM_MIRROR_CAT_COPY More...
evxAsmMirrorSymm symm
self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ More...
svxEntPath idDatum
the path of datum plane entity More...

Detailed Description

duplicate type

<

Definition at line 799 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup::idDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
cat
geometry
idDatum
position
symm

◆ idDatum

svxEntPath svxAsmMirror::AsmMirrorData::AsmDup::idDatum

the path of datum plane entity

Definition at line 805 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
cat
geometry
idDatum
position
symm

◆ position

int svxAsmMirror::AsmMirrorData::AsmDup::position

whether to keep position associative(0 = no, 1 = yes).default:1

Definition at line 802 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup::symm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
cat
geometry
idDatum
position
symm

◆ symm

evxAsmMirrorSymm svxAsmMirror::AsmMirrorData::AsmDup::symm

self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ

Definition at line 804 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup::cat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
cat
geometry
idDatum
position
symm

◆ cat

evxAsmMirrorCategory svxAsmMirror::AsmMirrorData::AsmDup::cat

category option.default:VX_ASM_MIRROR_CAT_COPY

Definition at line 803 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::AsmDup::geometry

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • AsmDup
cat
geometry
idDatum
position
symm

◆ geometry

int svxAsmMirror::AsmMirrorData::AsmDup::geometry

whether to keep geometry associative(0 = no, 1 = yes).default:1

Definition at line 801 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
Data Fields
svxAsmMirror::AsmMirrorData::svxAsmCopy Struct Reference

copy type More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | isDissolve
1 if dissolve mirror relation, else 0. default:0 More...
int | whole
whether as a whole to mirror(0 = no, 1 = yes).default:0 More...
int | atParent
whether instances' attributes as parent(0 = no, 1 = yes).default:0 More...
evxAsmMirrorSymm symm
self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ More...
svxEntPath idDatum
the path of datum plane entity More...

Detailed Description

copy type

<

Definition at line 791 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy::idDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
atParent
idDatum
isDissolve
symm
whole

◆ idDatum

svxEntPath svxAsmMirror::AsmMirrorData::svxAsmCopy::idDatum

the path of datum plane entity

Definition at line 797 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy::atParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
atParent
idDatum
isDissolve
symm
whole

◆ atParent

int svxAsmMirror::AsmMirrorData::svxAsmCopy::atParent

whether instances' attributes as parent(0 = no, 1 = yes).default:0

Definition at line 795 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy::whole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
atParent
idDatum
isDissolve
symm
whole

◆ whole

int svxAsmMirror::AsmMirrorData::svxAsmCopy::whole

whether as a whole to mirror(0 = no, 1 = yes).default:0

Definition at line 794 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy::isDissolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
atParent
idDatum
isDissolve
symm
whole

◆ isDissolve

int svxAsmMirror::AsmMirrorData::svxAsmCopy::isDissolve

1 if dissolve mirror relation, else 0. default:0

Definition at line 793 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData::svxAsmCopy::symm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
  • svxAsmCopy
atParent
idDatum
isDissolve
symm
whole

◆ symm

evxAsmMirrorSymm svxAsmMirror::AsmMirrorData::svxAsmCopy::symm

self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ

Definition at line 796 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ center

evxAsmMirrorCenter svxAsmMirror::center

center option.default:VX_ASM_MIRROR_CTR_BOX

Definition at line 788 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ pEnts

svxEntPath* svxAsmMirror::pEnts

list of path's of base entities

Definition at line 785 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ Count

int svxAsmMirror::Count

number of base entities for mirror

Definition at line 784 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::pPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ pPlane

svxEntPath svxAsmMirror::pPlane

the path of mirror plane entity

Definition at line 786 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ type

evxAsmMirrorType svxAsmMirror::type

mirror method

Definition at line 783 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::erase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
center
Count
erase
pEnts
pPlane
type

◆ erase

int svxAsmMirror::erase

whether to erase source geometry(0 = no, 1 = yes).default:0

Definition at line 787 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAsmMove Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly move data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

union AsmMoveData
union of assembly Move data More...

Data Fields

evxAsmMoveType type
move method More...
int | Count
number of base entities for move More...
int * | idEnts
list of id's of base entities More...
int | copy
whether to copy (0 = no, 1 = yes).default:0 More...
union svxAsmMove::AsmMoveData | move

Detailed Description

assembly move data

Definition at line 715 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlignFrame Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlignFrame
Data Fields
svxAsmMove::AsmMoveData::svxAsmAlignFrame Struct Reference

align frame More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | fromFrame
the id of from frame entity More...
int | toFrame
the id of to frame entity More...

Detailed Description

align frame

<

Definition at line 755 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlignFrame::fromFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlignFrame
fromFrame
toFrame

◆ fromFrame

int svxAsmMove::AsmMoveData::svxAsmAlignFrame::fromFrame

the id of from frame entity

Definition at line 757 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlignFrame::toFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlignFrame
fromFrame
toFrame

◆ toFrame

int svxAsmMove::AsmMoveData::svxAsmAlignFrame::toFrame

the id of to frame entity

Definition at line 758 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
Data Fields
svxAsmMove::AsmMoveData::svxAsmAlongDir Struct Reference

along direction More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxVector dir
direction vector More...
double | dist
distance.default:0 More...
double | angle
angle.default:0 More...
int | useAng
whether to use angle (0 = no, 1 = yes).default:1 More...
int | numCopy
the number of copies.default:1 More...

Detailed Description

along direction

<

Definition at line 740 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
angle
dir
dist
numCopy
useAng

◆ angle

double svxAsmMove::AsmMoveData::svxAsmAlongDir::angle

angle.default:0

Definition at line 744 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir::numCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
angle
dir
dist
numCopy
useAng

◆ numCopy

int svxAsmMove::AsmMoveData::svxAsmAlongDir::numCopy

the number of copies.default:1

Definition at line 746 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir::useAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
angle
dir
dist
numCopy
useAng

◆ useAng

int svxAsmMove::AsmMoveData::svxAsmAlongDir::useAng

whether to use angle (0 = no, 1 = yes).default:1

Definition at line 745 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
angle
dir
dist
numCopy
useAng

◆ dir

svxVector svxAsmMove::AsmMoveData::svxAsmAlongDir::dir

direction vector

Definition at line 742 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAlongDir::dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAlongDir
angle
dir
dist
numCopy
useAng

◆ dist

double svxAsmMove::AsmMoveData::svxAsmAlongDir::dist

distance.default:0

Definition at line 743 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAroundDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAroundDir
Data Fields
svxAsmMove::AsmMoveData::svxAsmAroundDir Struct Reference

around direction More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxVector dir
direction vector More...
svxPntOnEnt location
axis location More...
double | angle
angle.default:0 More...
int | numCopy
the number of copies.default:1 More...

Detailed Description

around direction

<

Definition at line 748 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAroundDir::numCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAroundDir
angle
dir
location
numCopy

◆ numCopy

int svxAsmMove::AsmMoveData::svxAsmAroundDir::numCopy

the number of copies.default:1

Definition at line 753 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAroundDir::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAroundDir
angle
dir
location
numCopy

◆ dir

svxVector svxAsmMove::AsmMoveData::svxAsmAroundDir::dir

direction vector

Definition at line 750 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAroundDir::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAroundDir
angle
dir
location
numCopy

◆ angle

double svxAsmMove::AsmMoveData::svxAsmAroundDir::angle

angle.default:0

Definition at line 752 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmAroundDir::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmAroundDir
angle
dir
location
numCopy

◆ location

svxPntOnEnt svxAsmMove::AsmMoveData::svxAsmAroundDir::location

axis location

Definition at line 751 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
Data Fields
svxAsmMove::AsmMoveData::svxAsmDynamic Struct Reference

dynamic move More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int handle
whether to move handle only (0 = no, 1 = yes).default:0 More...
svxPntOnEnt position
the point of position More...
svxVector xAxis
the vector of x axis More...
svxVector yAxis
the vector of y axis More...
svxVector zAxis
the vector of z axis More...

Detailed Description

dynamic move

<

Definition at line 723 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic::yAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
handle
position
xAxis
yAxis
zAxis

◆ yAxis

svxVector svxAsmMove::AsmMoveData::svxAsmDynamic::yAxis

the vector of y axis

Definition at line 728 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
handle
position
xAxis
yAxis
zAxis

◆ position

svxPntOnEnt svxAsmMove::AsmMoveData::svxAsmDynamic::position

the point of position

Definition at line 726 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic::handle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
handle
position
xAxis
yAxis
zAxis

◆ handle

int svxAsmMove::AsmMoveData::svxAsmDynamic::handle

whether to move handle only (0 = no, 1 = yes).default:0

Definition at line 725 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic::zAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
handle
position
xAxis
yAxis
zAxis

◆ zAxis

svxVector svxAsmMove::AsmMoveData::svxAsmDynamic::zAxis

the vector of z axis

Definition at line 729 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmDynamic::xAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmDynamic
handle
position
xAxis
yAxis
zAxis

◆ xAxis

svxVector svxAsmMove::AsmMoveData::svxAsmDynamic::xAxis

the vector of x axis

Definition at line 727 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
Data Fields
svxAsmMove::AsmMoveData::svxAsmPnt Struct Reference

point to point More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxPntOnEnt fromPnt
from point More...
int | numToPnt
the number of to points More...
svxPntOnEnt * toPnt
the list of to points More...
int | useVec
1 if use vector,else 0. default:0 More...
svxVector fromVec
from vector More...
svxVector toVec
to vector More...

Detailed Description

point to point

<

Definition at line 731 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::toVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ toVec

svxVector svxAsmMove::AsmMoveData::svxAsmPnt::toVec

to vector

Definition at line 738 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::useVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ useVec

int svxAsmMove::AsmMoveData::svxAsmPnt::useVec

1 if use vector,else 0. default:0

Definition at line 736 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::fromVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ fromVec

svxVector svxAsmMove::AsmMoveData::svxAsmPnt::fromVec

from vector

Definition at line 737 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ fromPnt

svxPntOnEnt svxAsmMove::AsmMoveData::svxAsmPnt::fromPnt

from point

Definition at line 733 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::numToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ numToPnt

int svxAsmMove::AsmMoveData::svxAsmPnt::numToPnt

the number of to points

Definition at line 734 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmPnt::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmPnt
fromPnt
fromVec
numToPnt
toPnt
toVec
useVec

◆ toPnt

svxPntOnEnt* svxAsmMove::AsmMoveData::svxAsmPnt::toPnt

the list of to points

Definition at line 735 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
Data Fields
svxAsmMove::AsmMoveData::svxAsmSweep Struct Reference

sweep More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxPntOnEnt path
the point of path More...
int | numToPnt
the number of to points More...
svxPntOnEnt * toPnts
the list of to points More...
evxAsmMoveFrame frame
the frame option.default:VX_ASM_MOVE_FRAME_PATH More...
evxAsmMoveZSpine zSpine
the z-spine option.default:VX_ASM_MOVE_Z_NTR More...
int | spineCrv
the id of spine curve entity More...
svxVector parallel
the vector of parallel plane More...
evxAsmMoveXOrnt xOrient
the x-orient option.default:VX_ASM_MOVE_X_NTR More...
svxVector guide
the vector of guide plane More...
int | xAxisCrv
the id of x-axis curve entity More...
int | idSwp
the id of sweep frame entity More...

Detailed Description

sweep

<

Definition at line 760 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::numToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ numToPnt

int svxAsmMove::AsmMoveData::svxAsmSweep::numToPnt

the number of to points

Definition at line 763 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::spineCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ spineCrv

int svxAsmMove::AsmMoveData::svxAsmSweep::spineCrv

the id of spine curve entity

Definition at line 767 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::parallel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ parallel

svxVector svxAsmMove::AsmMoveData::svxAsmSweep::parallel

the vector of parallel plane

Definition at line 768 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::guide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ guide

svxVector svxAsmMove::AsmMoveData::svxAsmSweep::guide

the vector of guide plane

Definition at line 770 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ frame

evxAsmMoveFrame svxAsmMove::AsmMoveData::svxAsmSweep::frame

the frame option.default:VX_ASM_MOVE_FRAME_PATH

Definition at line 765 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ path

svxPntOnEnt svxAsmMove::AsmMoveData::svxAsmSweep::path

the point of path

Definition at line 762 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::idSwp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ idSwp

int svxAsmMove::AsmMoveData::svxAsmSweep::idSwp

the id of sweep frame entity

Definition at line 772 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::xAxisCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ xAxisCrv

int svxAsmMove::AsmMoveData::svxAsmSweep::xAxisCrv

the id of x-axis curve entity

Definition at line 771 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::toPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ toPnts

svxPntOnEnt* svxAsmMove::AsmMoveData::svxAsmSweep::toPnts

the list of to points

Definition at line 764 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::xOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ xOrient

evxAsmMoveXOrnt svxAsmMove::AsmMoveData::svxAsmSweep::xOrient

the x-orient option.default:VX_ASM_MOVE_X_NTR

Definition at line 769 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData::svxAsmSweep::zSpine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
  • svxAsmSweep
frame
guide
idSwp
numToPnt
parallel
path
spineCrv
toPnts
xAxisCrv
xOrient
zSpine

◆ zSpine

evxAsmMoveZSpine svxAsmMove::AsmMoveData::svxAsmSweep::zSpine

the z-spine option.default:VX_ASM_MOVE_Z_NTR

Definition at line 766 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
copy
Count
idEnts
type

◆ type

evxAsmMoveType svxAsmMove::type

move method

Definition at line 717 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
copy
Count
idEnts
type

◆ idEnts

int* svxAsmMove::idEnts

list of id's of base entities

Definition at line 719 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::copy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
copy
Count
idEnts
type

◆ copy

int svxAsmMove::copy

whether to copy (0 = no, 1 = yes).default:0

Definition at line 720 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
copy
Count
idEnts
type

◆ Count

int svxAsmMove::Count

number of base entities for move

Definition at line 718 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAsmPtnData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

assembly pattern data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

union svxAsmPtn
union of assembly Pattern data More...

Data Fields

evxAsmPatternType type
pattern method More...
int | Count
number of base components for pattern More...
int * | idEnts
list of id's of base components More...
int | useDir
whether to use second direction (0 = no, 1 = yes).default:0
More...
int | num [2]
the number of pattern on two directions.default:(2,1) More...
int | insComp
whether instanced as component (0 = no, 1 = yes).default:0 More...
int | ihrCons
whether inherit constraints (0 = no, 1 = yes).default:1 More...
int | atParent
whether is instances' attributes at parent (0 = no, 1 = yes).default:0 More...
union svxAsmPtnData::svxAsmPtn | ptnData
int | cntSkip
number of the instances to be skipped More...
int * | firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction) More...
int * | secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x More...

Detailed Description

assembly pattern data

Definition at line 630 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv Struct Reference

at curves pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

evxAsmPtnCrv crvOption
the method of curves.default:VX_ASM_PTN_CRV1 More...
int | numBnd
the number of boundary entities, if curve option is 1 curve, numBnd = 1; if curve option is 2 curves, numBnd = 2; if curve option is 3-4 curves, numBnd is 3 or 4. More...
int * | idBnd
the list id of boundary entities. More...
double | spacing [2]
the spacing of pattern in first and second directions.default:(20,20) More...
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE More...
double | minimum
the minimum of derive.default:0 More...
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_ALG_PTN More...
evxAsmPtnAlg alignment
the alignment method.default:VX_ASMpTN_NO_STAGGER More...
int | idFace
the id of face(idFace<=0 to ignore) More...
int | useFromPnt
1 is use fromPnt, else 0.default:0 More...
svxPntOnEnt fromPnt
from point More...
evxAsmPtnBnd boundary
the boundary option.default:VX_ASM_PTN_BND_AUTO More...

Detailed Description

at curves pattern

<

Definition at line 669 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::useFromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ useFromPnt

int svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::useFromPnt

1 is use fromPnt, else 0.default:0

Definition at line 682 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idBnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ idBnd

int* svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idBnd

the list id of boundary entities.

Definition at line 675 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::crvOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ crvOption

evxAsmPtnCrv svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::crvOption

the method of curves.default:VX_ASM_PTN_CRV1

Definition at line 671 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ idFace

int svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idFace

the id of face(idFace<=0 to ignore)

Definition at line 681 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ spacing

double svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::spacing[2]

the spacing of pattern in first and second directions.default:(20,20)

Definition at line 676 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::alignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ alignment

evxAsmPtnAlg svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::alignment

the alignment method.default:VX_ASMpTN_NO_STAGGER

Definition at line 680 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ fromPnt

svxPntOnEnt svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::fromPnt

from point

Definition at line 683 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ derive

evxAsmPtnDrv svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::derive

the method of derive.default:VX_ASM_PTN_DRV_NONE

Definition at line 677 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ stagger

evxAsmPtnStagger svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::stagger

the method of stagger.default:VX_ASM_PTN_ALG_PTN

Definition at line 679 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::minimum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ minimum

double svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::minimum

the minimum of derive.default:0

Definition at line 678 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::numBnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ numBnd

int svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::numBnd

the number of boundary entities, if curve option is 1 curve, numBnd = 1; if curve option is 2 curves, numBnd = 2; if curve option is 3-4 curves, numBnd is 3 or 4.

Definition at line 672 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::boundary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtCrv
alignment
boundary
crvOption
derive
fromPnt
idBnd
idFace
minimum
numBnd
spacing
stagger
useFromPnt

◆ boundary

evxAsmPtnBnd svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::boundary

the boundary option.default:VX_ASM_PTN_BND_AUTO

Definition at line 684 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmAtFace Struct Reference

at face pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | idFace
the id of face More...
double | spacing [2]
the spacing of pattern in first and second directions.default:(20,20) More...
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE More...
double | minimum
the minimum of derive.default:0 More...
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_NO_STAGGER More...
evxAsmPtnAlg alignment
the alignment method.default:VX_ASM_PTN_ALG_PTN More...
int | useFromPnt
1 is use fromPnt, else 0.default:0 More...
svxPntOnEnt fromPnt
from point More...
evxAsmPtnBnd boundary
the boundary option.default:VX_ASM_PTN_BND_AUTO More...

Detailed Description

at face pattern

<

Definition at line 686 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::minimum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ minimum

double svxAsmPtnData::svxAsmPtn::svxAsmAtFace::minimum

the minimum of derive.default:0

Definition at line 691 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ fromPnt

svxPntOnEnt svxAsmPtnData::svxAsmPtn::svxAsmAtFace::fromPnt

from point

Definition at line 695 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ stagger

evxAsmPtnStagger svxAsmPtnData::svxAsmPtn::svxAsmAtFace::stagger

the method of stagger.default:VX_ASM_PTN_NO_STAGGER

Definition at line 692 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ derive

evxAsmPtnDrv svxAsmPtnData::svxAsmPtn::svxAsmAtFace::derive

the method of derive.default:VX_ASM_PTN_DRV_NONE

Definition at line 690 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ idFace

int svxAsmPtnData::svxAsmPtn::svxAsmAtFace::idFace

the id of face

Definition at line 688 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ spacing

double svxAsmPtnData::svxAsmPtn::svxAsmAtFace::spacing[2]

the spacing of pattern in first and second directions.default:(20,20)

Definition at line 689 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::boundary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ boundary

evxAsmPtnBnd svxAsmPtnData::svxAsmPtn::svxAsmAtFace::boundary

the boundary option.default:VX_ASM_PTN_BND_AUTO

Definition at line 696 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::useFromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ useFromPnt

int svxAsmPtnData::svxAsmPtn::svxAsmAtFace::useFromPnt

1 is use fromPnt, else 0.default:0

Definition at line 694 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmAtFace::alignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmAtFace
alignment
boundary
derive
fromPnt
idFace
minimum
spacing
stagger
useFromPnt

◆ alignment

evxAsmPtnAlg svxAsmPtnData::svxAsmPtn::svxAsmAtFace::alignment

the alignment method.default:VX_ASM_PTN_ALG_PTN

Definition at line 693 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmCircular Struct Reference

circular pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxVector dir
first directions More...
double | spacing
the spacing of pattern in the directions.default:20 More...
double | angle
the angle of the direction.default:45 More...
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE More...
double | minimum
the minimum of derive.default:0 More...
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_ALG_PTN More...
evxAsmPtnAlg alignment
the alignment method.default:VX_ASM_PTN_NO_STAGGER More...

Detailed Description

circular pattern

<

Definition at line 649 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ derive

evxAsmPtnDrv svxAsmPtnData::svxAsmPtn::svxAsmCircular::derive

the method of derive.default:VX_ASM_PTN_DRV_NONE

Definition at line 654 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ stagger

evxAsmPtnStagger svxAsmPtnData::svxAsmPtn::svxAsmCircular::stagger

the method of stagger.default:VX_ASM_PTN_ALG_PTN

Definition at line 656 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ spacing

double svxAsmPtnData::svxAsmPtn::svxAsmCircular::spacing

the spacing of pattern in the directions.default:20

Definition at line 652 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::alignment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ alignment

evxAsmPtnAlg svxAsmPtnData::svxAsmPtn::svxAsmCircular::alignment

the alignment method.default:VX_ASM_PTN_NO_STAGGER

Definition at line 657 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ angle

double svxAsmPtnData::svxAsmPtn::svxAsmCircular::angle

the angle of the direction.default:45

Definition at line 653 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ dir

svxVector svxAsmPtnData::svxAsmPtn::svxAsmCircular::dir

first directions

Definition at line 651 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmCircular::minimum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmCircular
alignment
angle
derive
dir
minimum
spacing
stagger

◆ minimum

double svxAsmPtnData::svxAsmPtn::svxAsmCircular::minimum

the minimum of derive.default:0

Definition at line 655 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmLinear Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmLinear
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmLinear Struct Reference

linear pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxVector | dir [2]
first and second directions More...
double | spacing [2]
the spacing of pattern in first and second directions.default:(20,20) More...
int | seedOnly
whether pattern seed only.(0=no,1=yes).default:0 More...
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_NO_STAGGER More...

Detailed Description

linear pattern

<

Definition at line 642 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmLinear::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmLinear
dir
seedOnly
spacing
stagger

◆ stagger

evxAsmPtnStagger svxAsmPtnData::svxAsmPtn::svxAsmLinear::stagger

the method of stagger.default:VX_ASM_PTN_NO_STAGGER

Definition at line 647 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmLinear::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmLinear
dir
seedOnly
spacing
stagger

◆ dir

svxVector svxAsmPtnData::svxAsmPtn::svxAsmLinear::dir[2]

first and second directions

Definition at line 644 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmLinear::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmLinear
dir
seedOnly
spacing
stagger

◆ spacing

double svxAsmPtnData::svxAsmPtn::svxAsmLinear::spacing[2]

the spacing of pattern in first and second directions.default:(20,20)

Definition at line 645 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmLinear::seedOnly

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmLinear
dir
seedOnly
spacing
stagger

◆ seedOnly

int svxAsmPtnData::svxAsmPtn::svxAsmLinear::seedOnly

whether pattern seed only.(0=no,1=yes).default:0

Definition at line 646 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPattern Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPattern
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmPattern Struct Reference

at pattern pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxEntPath ptnFtrPath
the path of pattern entity More...

Detailed Description

at pattern pattern

<

Definition at line 665 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPattern::ptnFtrPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPattern
ptnFtrPath

◆ ptnFtrPath

svxEntPath svxAsmPtnData::svxAsmPtn::svxAsmPattern::ptnFtrPath

the path of pattern entity

Definition at line 667 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPntToPnt
Data Fields
svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt Struct Reference

point to point pattern More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxPntOnEnt basePnt
base point More...
int cnt
count of toPnt More...
svxPntOnEnt * toPnt
to point More...

Detailed Description

point to point pattern

<

Definition at line 659 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPntToPnt
basePnt
cnt
toPnt

◆ cnt

int svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::cnt

count of toPnt

Definition at line 662 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::basePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPntToPnt
basePnt
cnt
toPnt

◆ basePnt

svxPntOnEnt svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::basePnt

base point

Definition at line 661 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
  • svxAsmPntToPnt
basePnt
cnt
toPnt

◆ toPnt

svxPntOnEnt* svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::toPnt

to point

Definition at line 663 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::secondTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ secondTogglePos

int* svxAsmPtnData::secondTogglePos

the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x

Definition at line 701 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::atParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ atParent

int svxAsmPtnData::atParent

whether is instances' attributes at parent (0 = no, 1 = yes).default:0

Definition at line 639 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::ihrCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ ihrCons

int svxAsmPtnData::ihrCons

whether inherit constraints (0 = no, 1 = yes).default:1

Definition at line 638 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ Count

int svxAsmPtnData::Count

number of base components for pattern

Definition at line 633 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::useDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ useDir

int svxAsmPtnData::useDir

whether to use second direction (0 = no, 1 = yes).default:0

Definition at line 635 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ num

int svxAsmPtnData::num[2]

the number of pattern on two directions.default:(2,1)

Definition at line 636 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::cntSkip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ cntSkip

int svxAsmPtnData::cntSkip

number of the instances to be skipped

Definition at line 699 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::firstTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ firstTogglePos

int* svxAsmPtnData::firstTogglePos

the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction)

Definition at line 700 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ idEnts

int* svxAsmPtnData::idEnts

list of id's of base components

Definition at line 634 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::insComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ insComp

int svxAsmPtnData::insComp

whether instanced as component (0 = no, 1 = yes).default:0

Definition at line 637 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
atParent
cntSkip
Count
firstTogglePos
idEnts
ihrCons
insComp
num
secondTogglePos
type
useDir

◆ type

evxAsmPatternType svxAsmPtnData::type

pattern method

Definition at line 632 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAttribute Struct Reference
Common » Common Data

standard attribute data More...

#include <zwapi_util.h>

Data Fields

char | label [64]
attribute label More...
char | data [512]
attribute data More...
double | dValue
value for bool, integer, real number, date type More...
char | type
attribute type (evxAttributeType) More...
char | sub_type
sub type for real number type (use input type of evxNumType) More...
char | unit
unit type for non-constant real number (evxUnitType, evxAngUnitType...) or date format (evxDateFormat) More...
char | strValue [2048]
attribute value More...
int | has_eqn
flag to show whether there are some equations in "data/expression" More...

Detailed Description

standard attribute data

Definition at line 1369 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::label

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ label

char svxAttribute::label[64]

attribute label

Definition at line 1371 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ unit

char svxAttribute::unit

unit type for non-constant real number (evxUnitType, evxAngUnitType...) or date format (evxDateFormat)

Definition at line 1376 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ data

char svxAttribute::data[512]

attribute data

Definition at line 1372 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::sub_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ sub_type

char svxAttribute::sub_type

sub type for real number type (use input type of evxNumType)

Definition at line 1375 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::has_eqn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ has_eqn

int svxAttribute::has_eqn

flag to show whether there are some equations in "data/expression"

Definition at line 1378 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::strValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ strValue

char svxAttribute::strValue[2048]

attribute value

Definition at line 1377 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ type

char svxAttribute::type

attribute type (evxAttributeType)

Definition at line 1374 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAttribute::dValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAttribute
data
dValue
has_eqn
label
strValue
sub_type
type
unit

◆ dValue

double svxAttribute::dValue

value for bool, integer, real number, date type

Definition at line 1373 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAutoSet Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

dimension position More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | enable
svxAutoSet enabled or not More...
evxAutoDimType type
select auto dimension type More...
svxPntOnEnt refPnt
reference point, used when enable is 1 More...
evxAutoPlacement viewType
dimensions position / placement, default value:DIM_VIEW_BELOW_RIGHT More...
int | asgrp
1:auto dimensions are as group dimension* 0:not, default value:1 More...

Detailed Description

dimension position

Examples
drawing\dwgDimTest.cpp.

Definition at line 662 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet::refPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAutoSet
asgrp
enable
refPnt
type
viewType

◆ refPnt

svxPntOnEnt svxAutoSet::refPnt

reference point, used when enable is 1

Examples
drawing\dwgDimTest.cpp.

Definition at line 666 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAutoSet
asgrp
enable
refPnt
type
viewType

◆ type

evxAutoDimType svxAutoSet::type

select auto dimension type

Examples
drawing\dwgDimTest.cpp.

Definition at line 665 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet::viewType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAutoSet
asgrp
enable
refPnt
type
viewType

◆ viewType

evxAutoPlacement svxAutoSet::viewType

dimensions position / placement, default value:DIM_VIEW_BELOW_RIGHT

Examples
drawing\dwgDimTest.cpp.

Definition at line 667 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet::asgrp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAutoSet
asgrp
enable
refPnt
type
viewType

◆ asgrp

int svxAutoSet::asgrp

1:auto dimensions are as group dimension* 0:not, default value:1

Examples
drawing\dwgDimTest.cpp.

Definition at line 668 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAutoSet::enable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAutoSet
asgrp
enable
refPnt
type
viewType

◆ enable

int svxAutoSet::enable

svxAutoSet enabled or not

Examples
drawing\dwgDimTest.cpp.

Definition at line 664 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAuxViewData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Auxiliary view data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
the id of base view More...
int | idLine
line to define auxiliary view plane (this must be a line) More...
svxPoint2 locPnt
view location More...
svxPrjSetting settings
projection settings More...
svxViewArrow arrowInfo
view arrow More...

Detailed Description

Auxiliary view data.

Examples
drawing\dwgViewTest.cpp.

Definition at line 268 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData::settings

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAuxViewData
arrowInfo
idLine
idView
locPnt
settings

◆ settings

svxPrjSetting svxAuxViewData::settings

projection settings

Examples
drawing\dwgViewTest.cpp.

Definition at line 273 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData::idLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAuxViewData
arrowInfo
idLine
idView
locPnt
settings

◆ idLine

int svxAuxViewData::idLine

line to define auxiliary view plane (this must be a line)

Examples
drawing\dwgViewTest.cpp.

Definition at line 271 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData::arrowInfo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAuxViewData
arrowInfo
idLine
idView
locPnt
settings

◆ arrowInfo

svxViewArrow svxAuxViewData::arrowInfo

view arrow

Examples
drawing\dwgViewTest.cpp.

Definition at line 274 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAuxViewData
arrowInfo
idLine
idView
locPnt
settings

◆ idView

int svxAuxViewData::idView

the id of base view

Examples
drawing\dwgViewTest.cpp.

Definition at line 270 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAuxViewData::locPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAuxViewData
arrowInfo
idLine
idView
locPnt
settings

◆ locPnt

svxPoint2 svxAuxViewData::locPnt

view location

Examples
drawing\dwgViewTest.cpp.

Definition at line 272 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxis Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxAxis Struct Reference
Common » Common Data

3D axis More...

#include <zwapi_util.h>

Data Fields

svxPoint Pnt
point More...
svxVector Dir
direction More...

Detailed Description

3D axis

Examples
part\baseFtrCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 348 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxis::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxis
Dir
Pnt

◆ Dir

svxVector svxAxis::Dir

direction

Examples
part\baseFtrCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 351 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxis::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxis
Dir
Pnt

◆ Pnt

svxPoint svxAxis::Pnt

point

Examples
part\baseFtrCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 350 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxAxisData Struct Reference
Commands Creation » Part and Assembly Commands » Datum Commands Data

template command Axis input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

union evxAxisInpUnion
union of Axis input data More...

Data Fields

double | length
axis length More...
evxAxisMethods method
axis methods More...
union svxAxisData::evxAxisInpUnion | inpUnion
int | FlipDir
flip direction More...

Detailed Description

template command Axis input data

Examples
part\datumCrtTest.cpp.

Definition at line 49 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisFaceCenter Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisFaceCenter
Data Fields
svxAxisData::evxAxisInpUnion::AxisFaceCenter Struct Reference

face center Axis More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxEntPath Face
face More...

Detailed Description

face center Axis

<

Definition at line 66 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisFaceCenter::Face

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisFaceCenter
Face

◆ Face

svxEntPath svxAxisData::evxAxisInpUnion::AxisFaceCenter::Face

face

Examples
part\datumCrtTest.cpp.

Definition at line 68 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisGeomPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisGeomPnt
Data Fields
svxAxisData::evxAxisInpUnion::AxisGeomPnt Struct Reference

geometry More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint Pnt
picked Point More...
svxEntPath Path
entity/object pick path More...

Detailed Description

geometry

<

Definition at line 61 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisGeomPnt::Path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisGeomPnt
Path
Pnt

◆ Path

svxEntPath svxAxisData::evxAxisInpUnion::AxisGeomPnt::Path

entity/object pick path

Examples
part\datumCrtTest.cpp.

Definition at line 64 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisGeomPnt::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisGeomPnt
Path
Pnt

◆ Pnt

svxPoint svxAxisData::evxAxisInpUnion::AxisGeomPnt::Pnt

picked Point

Examples
part\datumCrtTest.cpp.

Definition at line 63 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisIntersectFaces Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisIntersectFaces
Data Fields
svxAxisData::evxAxisInpUnion::AxisIntersectFaces Struct Reference

intersect faces More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxEntPath Face1
1st face More...
svxEntPath Face2
2nd face More...

Detailed Description

intersect faces

<

Definition at line 70 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisIntersectFaces
Face1
Face2

◆ Face2

svxEntPath svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face2

2nd face

Examples
part\datumCrtTest.cpp.

Definition at line 73 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisIntersectFaces
Face1
Face2

◆ Face1

svxEntPath svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face1

1st face

Examples
part\datumCrtTest.cpp.

Definition at line 72 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisPntAndDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisPntAndDir
Data Fields
svxAxisData::evxAxisInpUnion::AxisPntAndDir Struct Reference

point and direction More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin point More...
svxVector Dir
direction More...

Detailed Description

point and direction

<

Definition at line 55 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisPntAndDir::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisPntAndDir
Dir
idOrgPnt
OrgPnt

◆ Dir

svxVector svxAxisData::evxAxisInpUnion::AxisPntAndDir::Dir

direction

Examples
part\datumCrtTest.cpp.

Definition at line 59 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisPntAndDir::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisPntAndDir
Dir
idOrgPnt
OrgPnt

◆ OrgPnt

svxPoint svxAxisData::evxAxisInpUnion::AxisPntAndDir::OrgPnt

origin point

Examples
part\datumCrtTest.cpp.

Definition at line 58 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisPntAndDir::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisPntAndDir
Dir
idOrgPnt
OrgPnt

◆ idOrgPnt

int svxAxisData::evxAxisInpUnion::AxisPntAndDir::idOrgPnt

id of the origin parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 57 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisTwoPnts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisTwoPnts
Data Fields
svxAxisData::evxAxisInpUnion::AxisTwoPnts Struct Reference

Two Points. More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int | idPnt1
id of the point1 parent entity More...
svxPoint Pnt1
1st point More...
int | idPnt2
id of the point2 parent entity More...
svxPoint Pnt2
2nd point More...

Detailed Description

Two Points.

<

Definition at line 75 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisTwoPnts
idPnt1
idPnt2
Pnt1
Pnt2

◆ idPnt2

int svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt2

id of the point2 parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 79 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisTwoPnts
idPnt1
idPnt2
Pnt1
Pnt2

◆ Pnt2

svxPoint svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt2

2nd point

Examples
part\datumCrtTest.cpp.

Definition at line 80 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisTwoPnts
idPnt1
idPnt2
Pnt1
Pnt2

◆ idPnt1

int svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt1

id of the point1 parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 77 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
  • AxisTwoPnts
idPnt1
idPnt2
Pnt1
Pnt2

◆ Pnt1

svxPoint svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt1

1st point

Examples
part\datumCrtTest.cpp.

Definition at line 78 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
FlipDir
length
method

◆ length

double svxAxisData::length

axis length

Examples
part\datumCrtTest.cpp.

Definition at line 51 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::FlipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
FlipDir
length
method

◆ FlipDir

int svxAxisData::FlipDir

flip direction

Examples
part\datumCrtTest.cpp.

Definition at line 83 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
FlipDir
length
method

◆ method

evxAxisMethods svxAxisData::method

axis methods

Examples
part\datumCrtTest.cpp.

Definition at line 52 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBndBox Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxBndBox Struct Reference
Common » Common Data

3D bounding box More...

#include <zwapi_util.h>

Data Fields

svxLimit X
the maximum and minimum values in the x direction of the boundle box More...
svxLimit Y
the maximum and minimum values in the y direction of the boundle box More...
svxLimit Z
the maximum and minimum values in the z direction of the boundle box More...

Detailed Description

3D bounding box

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 464 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBndBox::Z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBndBox
X
Y
Z

◆ Z

svxLimit svxBndBox::Z

the maximum and minimum values in the z direction of the boundle box

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 468 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBndBox::Y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBndBox
X
Y
Z

◆ Y

svxLimit svxBndBox::Y

the maximum and minimum values in the y direction of the boundle box

Definition at line 467 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBndBox::X

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBndBox
X
Y
Z

◆ X

svxLimit svxBndBox::X

the maximum and minimum values in the x direction of the boundle box

Definition at line 466 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxBoxData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

box data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
int | idPlane
optional datum plane, or 0 More...
int | useAxis
flag to use axis, 0 default More...
svxAxis axis
optional axis More...
svxPoint Center
center of box volume More...
double | X
length along X More...
double | Y
length along Y More...
double | Z
length along Z More...
vxName ftrName
feature name for "FtAllBox", 0 default More...

Detailed Description

box data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 45 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::useAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ useAxis

int svxBoxData::useAxis

flag to use axis, 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 49 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ Combine

evxBoolType svxBoxData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 47 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ idPlane

int svxBoxData::idPlane

optional datum plane, or 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 48 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ Center

svxPoint svxBoxData::Center

center of box volume

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 51 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::X

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ X

double svxBoxData::X

length along X

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 52 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::Y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ Y

double svxBoxData::Y

length along Y

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 53 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ ftrName

vxName svxBoxData::ftrName

feature name for "FtAllBox", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 55 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::Z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ Z

double svxBoxData::Z

length along Z

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 54 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBoxData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBoxData
axis
Center
Combine
ftrName
idPlane
useAxis
X
Y
Z

◆ axis

svxAxis svxBoxData::axis

optional axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 50 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxBrkLineData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

information we need when create break line More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | viewId
id of view More...
evxBrkLineType brkLnType
option of break line More...
svxPntOnEnt | pts [3]
3 input points depend on option of break line. only VX_SLANT_BRKLINE needs the third point, others need two points More...
double | gap
gap size More...
svxPoint2 dir
direction setting, only required when evxBrkLineType is VX_SLANT_BRKLINE More...

Detailed Description

information we need when create break line

Examples
drawing\dwgViewTest.cpp.

Definition at line 477 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData::pts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBrkLineData
brkLnType
dir
gap
pts
viewId

◆ pts

svxPntOnEnt svxBrkLineData::pts[3]

3 input points depend on option of break line. only VX_SLANT_BRKLINE needs the third point, others need two points

Examples
drawing\dwgViewTest.cpp.

Definition at line 481 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData::brkLnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBrkLineData
brkLnType
dir
gap
pts
viewId

◆ brkLnType

evxBrkLineType svxBrkLineData::brkLnType

option of break line

Examples
drawing\dwgViewTest.cpp.

Definition at line 480 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData::viewId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBrkLineData
brkLnType
dir
gap
pts
viewId

◆ viewId

int svxBrkLineData::viewId

id of view

Examples
drawing\dwgViewTest.cpp.

Definition at line 479 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBrkLineData
brkLnType
dir
gap
pts
viewId

◆ gap

double svxBrkLineData::gap

gap size

Examples
drawing\dwgViewTest.cpp.

Definition at line 483 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxBrkLineData::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxBrkLineData
brkLnType
dir
gap
pts
viewId

◆ dir

svxPoint2 svxBrkLineData::dir

direction setting, only required when evxBrkLineType is VX_SLANT_BRKLINE

Examples
drawing\dwgViewTest.cpp.

Definition at line 484 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCAT5Data Struct Reference
File » File Data

data of export CAT5 file More...

#include <zwapi_file_data.h>

Data Fields

int | FileVer
file version (15 ~ 28, 24-default) More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...

Detailed Description

data of export CAT5 file

Definition at line 418 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data::FileVer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCAT5Data
EntCnt
EntList
ExcludeGeom
ExportType
FileVer

◆ FileVer

int svxCAT5Data::FileVer

file version (15 ~ 28, 24-default)

Definition at line 420 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCAT5Data
EntCnt
EntList
ExcludeGeom
ExportType
FileVer

◆ EntCnt

int svxCAT5Data::EntCnt

the count of export entities if ExportType = 1

Definition at line 422 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCAT5Data
EntCnt
EntList
ExcludeGeom
ExportType
FileVer

◆ EntList

int* svxCAT5Data::EntList

the specified entities id list if ExportType = 1

Definition at line 423 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCAT5Data
EntCnt
EntList
ExcludeGeom
ExportType
FileVer

◆ ExportType

char svxCAT5Data::ExportType

0-All objects, 1-Specified entities

Definition at line 421 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCAT5Data::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCAT5Data
EntCnt
EntList
ExcludeGeom
ExportType
FileVer

◆ ExcludeGeom

int svxCAT5Data::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 424 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCSYSData Struct Reference
Commands Creation » Part and Assembly Commands » Datum Commands Data

template command CSYS input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

union evxCSYSInpUnion
union of csys input data More...

Data Fields

svxMatrix Frame
transformation matrix More...
evxCSYSMethods method
CSYS methods. More...
union svxCSYSData::evxCSYSInpUnion | inpUnion
double | dOffset
offset value More...
int | idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin More...
int | idXPnt
id of the XPoint parent entity More...
svxPoint XPnt
XPoint. More...
double | XAng
angle value X direction More...
double | YAng
angle value Y direction More...
double | ZAng
angle value Z direction More...

Detailed Description

template command CSYS input data

Examples
part\datumCrtTest.cpp.

Definition at line 347 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSByGeom Struct Reference

geometry More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint OrgPnt
Origin point. More...
svxEntPath Path
entity/object pick path More...
int | cnt
count of OrgPnts and Paths. More...
svxPoint * OrgPnts
origin points More...
svxEntPath * Paths
entity/object pick paths More...
int | offsetFirst
0 is offset first,else 1.default:0 More...
double | xOffset
x offset More...
double | yOffset
y offset More...
double | zOffset
z offset More...
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X) More...
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same. More...

Detailed Description

geometry

<

Definition at line 353 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ OrgPnt

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnt

Origin point.

Definition at line 356 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ cnt

int svxCSYSData::evxCSYSInpUnion::CSYSByGeom::cnt

count of OrgPnts and Paths.

Examples
part\datumCrtTest.cpp.

Definition at line 361 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::zOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ zOffset

double svxCSYSData::evxCSYSInpUnion::CSYSByGeom::zOffset

z offset

Examples
part\datumCrtTest.cpp.

Definition at line 369 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ Path

svxEntPath svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Path

entity/object pick path

Definition at line 357 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Paths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ Paths

svxEntPath* svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Paths

entity/object pick paths

Examples
part\datumCrtTest.cpp.

Definition at line 363 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::xOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ xOffset

double svxCSYSData::evxCSYSInpUnion::CSYSByGeom::xOffset

x offset

Examples
part\datumCrtTest.cpp.

Definition at line 367 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::offsetFirst

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ offsetFirst

int svxCSYSData::evxCSYSInpUnion::CSYSByGeom::offsetFirst

0 is offset first,else 1.default:0

Examples
part\datumCrtTest.cpp.

Definition at line 366 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::yOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ yOffset

double svxCSYSData::evxCSYSInpUnion::CSYSByGeom::yOffset

y offset

Examples
part\datumCrtTest.cpp.

Definition at line 368 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ OrgPnts

svxPoint* svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnts

origin points

Examples
part\datumCrtTest.cpp.

Definition at line 362 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::firstAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ firstAxis

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSByGeom::firstAxis

1st axis(default:VX_RESULTS_AXIS_X)

Examples
part\datumCrtTest.cpp.

Definition at line 372 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSByGeom::secondAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSByGeom
cnt
firstAxis
offsetFirst
OrgPnt
OrgPnts
Path
Paths
secondAxis
xOffset
yOffset
zOffset

◆ secondAxis

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSByGeom::secondAxis

2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.

Examples
part\datumCrtTest.cpp.

Definition at line 373 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSDynamic Struct Reference

dynamic More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int | idPosPnt
id of the position parent entity More...
svxPoint PosPnt
position point More...
svxPntByOffset * PosPntByOffset
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntBy2Lines) cvxPartPntByOffsetInit can initialize this parameter More...
svxPntBy2Lines * PosPntBy2Lines
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntByOffset) cvxPartPntBy2LinesInit can initialize this parameter More...
svxVector Xaxis
A axis. More...
svxVector Yaxis
Y axis. More...
svxVector Zaxis
Z axis. More...
int | isAutoOrint
1 is auto orientation,else 0.default:1 More...

Detailed Description

dynamic

<

Definition at line 455 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::isAutoOrint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ isAutoOrint

int svxCSYSData::evxCSYSInpUnion::CSYSDynamic::isAutoOrint

1 is auto orientation,else 0.default:1

Examples
part\datumCrtTest.cpp.

Definition at line 467 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ PosPntBy2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntBy2Lines

set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntByOffset) cvxPartPntBy2LinesInit can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 462 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Zaxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ Zaxis

svxVector svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Zaxis

Z axis.

Examples
part\datumCrtTest.cpp.

Definition at line 466 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ PosPntByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntByOffset

set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntBy2Lines) cvxPartPntByOffsetInit can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 459 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Xaxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ Xaxis

svxVector svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Xaxis

A axis.

Examples
part\datumCrtTest.cpp.

Definition at line 464 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::idPosPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ idPosPnt

int svxCSYSData::evxCSYSInpUnion::CSYSDynamic::idPosPnt

id of the position parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 457 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Yaxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ Yaxis

svxVector svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Yaxis

Y axis.

Examples
part\datumCrtTest.cpp.

Definition at line 465 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSDynamic
idPosPnt
isAutoOrint
PosPnt
PosPntBy2Lines
PosPntByOffset
Xaxis
Yaxis
Zaxis

◆ PosPnt

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPnt

position point

Examples
part\datumCrtTest.cpp.

Definition at line 458 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir Struct Reference

Plane and direction. More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxEntPath Face
face More...
evsResultsAxisMethod axisFc
axis(default:VX_RESULTS_AXIS_Z) More...
int | isFlipFc
1 is flip,else 0.default:0 More...
int | idPnt
id of the point parent entity More...
svxPoint Pnt
point More...
svxPntByOffset * PntByOffset
set the point by the offset sub-command (NULL to use (idPnt, Pnt) or PntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * PntBy2Lines
set the point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or PntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
svxVector Dir
direction, can use "DirOnEnt" to set the direction on the specified entity and flip the direction, Dir can be deprecated and can be ignored More...
svxPntOnEnt DirOnEnt
direction."DirOnEnt.useDir" has to be equal to 1."DirOnEnt.flipDir" can be set to reverse. More...
evsResultsAxisMethod axisDir
axis(default:VX_RESULTS_AXIS_X).The two axis cannot be the same. More...

Detailed Description

Plane and direction.

<

Definition at line 439 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ PntByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntByOffset

set the point by the offset sub-command (NULL to use (idPnt, Pnt) or PntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 446 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ Dir

svxVector svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Dir

direction, can use "DirOnEnt" to set the direction on the specified entity and flip the direction, Dir can be deprecated and can be ignored

Definition at line 451 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::idPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ idPnt

int svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::idPnt

id of the point parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 444 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::DirOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ DirOnEnt

svxPntOnEnt svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::DirOnEnt

direction."DirOnEnt.useDir" has to be equal to 1."DirOnEnt.flipDir" can be set to reverse.

Examples
part\datumCrtTest.cpp.

Definition at line 452 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Face

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ Face

svxEntPath svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Face

face

Examples
part\datumCrtTest.cpp.

Definition at line 441 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ Pnt

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Pnt

point

Examples
part\datumCrtTest.cpp.

Definition at line 445 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::isFlipFc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ isFlipFc

int svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::isFlipFc

1 is flip,else 0.default:0

Examples
part\datumCrtTest.cpp.

Definition at line 443 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisFc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ axisFc

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisFc

axis(default:VX_RESULTS_AXIS_Z)

Examples
part\datumCrtTest.cpp.

Definition at line 442 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ PntBy2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntBy2Lines

set the point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or PntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 449 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPlanAndDir
axisDir
axisFc
Dir
DirOnEnt
Face
idPnt
isFlipFc
Pnt
PntBy2Lines
PntByOffset

◆ axisDir

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisDir

axis(default:VX_RESULTS_AXIS_X).The two axis cannot be the same.

Examples
part\datumCrtTest.cpp.

Definition at line 453 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir Struct Reference

point and two directions More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin point More...
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
svxVector Dir1
direction1, can use "DirOnEnt1" to set the direction1 on the specified entity and flip the direction, Dir1 can be deprecated and can be ignored More...
svxPntOnEnt DirOnEnt1
direction1."DirOnEnt1.useDir" has to be equal to 1."DirOnEnt1.flipDir" can be set to reverse. More...
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X) More...
svxVector Dir2
direction2, can use "DirOnEnt2" to set the direction2 on the specified entity and flip the direction, Dir2 can be deprecated and can be ignored More...
svxPntOnEnt DirOnEnt2
direction2."DirOnEnt2.useDir" has to be equal to 1."DirOnEnt2.flipDir" can be set to reverse. More...
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y).The two axis cannot be the same. More...

Detailed Description

point and two directions

<

Definition at line 418 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ axis2

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis2

axis2(default:VX_RESULTS_AXIS_Y).The two axis cannot be the same.

Examples
part\datumCrtTest.cpp.

Definition at line 437 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ Dir1

svxVector svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir1

direction1, can use "DirOnEnt1" to set the direction1 on the specified entity and flip the direction, Dir1 can be deprecated and can be ignored

Definition at line 430 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ DirOnEnt1

svxPntOnEnt svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt1

direction1."DirOnEnt1.useDir" has to be equal to 1."DirOnEnt1.flipDir" can be set to reverse.

Examples
part\datumCrtTest.cpp.

Definition at line 431 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ Dir2

svxVector svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir2

direction2, can use "DirOnEnt2" to set the direction2 on the specified entity and flip the direction, Dir2 can be deprecated and can be ignored

Definition at line 435 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ idOrgPnt

int svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::idOrgPnt

id of the origin parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 421 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ DirOnEnt2

svxPntOnEnt svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt2

direction2."DirOnEnt2.useDir" has to be equal to 1."DirOnEnt2.flipDir" can be set to reverse.

Examples
part\datumCrtTest.cpp.

Definition at line 436 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ axis1

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis1

axis1(default:VX_RESULTS_AXIS_X)

Examples
part\datumCrtTest.cpp.

Definition at line 432 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ OrgPntByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntByOffset

set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 424 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ OrgPntBy2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntBy2Lines

set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 427 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSPntAnd2Dir
axis1
axis2
Dir1
Dir2
DirOnEnt1
DirOnEnt2
idOrgPnt
OrgPnt
OrgPntBy2Lines
OrgPntByOffset

◆ OrgPnt

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPnt

origin point

Examples
part\datumCrtTest.cpp.

Definition at line 422 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces Struct Reference

three faces More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxEntPath Face1
face1 More...
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X) More...
int | isFlip1
1 is flip,else 0. default:0. More...
svxEntPath Face2
face2 More...
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y) More...
int | isFlip2
1 is flip,else 0. default:0. More...
svxEntPath Face3
face3 More...
evsResultsAxisMethod axis3
axis3(default:VX_RESULTS_AXIS_Z).The three axis cannot be the same. More...

Detailed Description

three faces

<

Definition at line 405 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ Face3

svxEntPath svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face3

face3

Examples
part\datumCrtTest.cpp.

Definition at line 415 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ Face1

svxEntPath svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face1

face1

Examples
part\datumCrtTest.cpp.

Definition at line 407 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ Face2

svxEntPath svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face2

face2

Examples
part\datumCrtTest.cpp.

Definition at line 411 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ axis3

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis3

axis3(default:VX_RESULTS_AXIS_Z).The three axis cannot be the same.

Examples
part\datumCrtTest.cpp.

Definition at line 416 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ axis2

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis2

axis2(default:VX_RESULTS_AXIS_Y)

Examples
part\datumCrtTest.cpp.

Definition at line 412 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ axis1

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis1

axis1(default:VX_RESULTS_AXIS_X)

Examples
part\datumCrtTest.cpp.

Definition at line 408 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ isFlip1

int svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip1

1 is flip,else 0. default:0.

Examples
part\datumCrtTest.cpp.

Definition at line 409 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreeFaces
axis1
axis2
axis3
Face1
Face2
Face3
isFlip1
isFlip2

◆ isFlip2

int svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip2

1 is flip,else 0. default:0.

Examples
part\datumCrtTest.cpp.

Definition at line 413 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
Data Fields
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts Struct Reference

three points More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int | idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin point More...
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
int | idPnt1
id of the point1 parent entity More...
svxPoint Pnt1
point1 More...
svxPntByOffset * Pnt1ByOffset
set the point1 by the offset sub-command (NULL to use (idPnt1, Pnt1) or Pnt1By2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * Pnt1By2Lines
set the point2 by the from 2 lines sub-command (NULL to use (idPnt1, Pnt1) or Pnt1ByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X) More...
int | isFlip1
1 is flip,else 0.default:0 More...
int | idPnt2
id of the point2 parent entity More...
svxPoint Pnt2
Point2. More...
svxPntByOffset * Pnt2ByOffset
set the origin point by the offset sub-command (NULL to use (idPnt2, Pnt2) or Pnt2By2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * Pnt2By2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idPnt2, Pnt2) or Pnt2ByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same. More...
int | isFlip2
1 is flip,else 0.default:0 More...

Detailed Description

three points

<

Definition at line 375 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ idOrgPnt

int svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idOrgPnt

id of the origin parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 377 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2ByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt2ByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2ByOffset

set the origin point by the offset sub-command (NULL to use (idPnt2, Pnt2) or Pnt2By2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 397 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ OrgPnt

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPnt

origin point

Examples
part\datumCrtTest.cpp.

Definition at line 378 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ idPnt1

int svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt1

id of the point1 parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 385 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2By2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt2By2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2By2Lines

set the origin point by the from 2 lines sub-command (NULL to use (idPnt2, Pnt2) or Pnt2ByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Definition at line 400 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::firstAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ firstAxis

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::firstAxis

1st axis(default:VX_RESULTS_AXIS_X)

Examples
part\datumCrtTest.cpp.

Definition at line 392 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ OrgPntByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntByOffset

set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 379 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ isFlip1

int svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip1

1 is flip,else 0.default:0

Examples
part\datumCrtTest.cpp.

Definition at line 393 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt2

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2

Point2.

Examples
part\datumCrtTest.cpp.

Definition at line 396 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ OrgPntBy2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntBy2Lines

set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 382 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1ByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt1ByOffset

svxPntByOffset* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1ByOffset

set the point1 by the offset sub-command (NULL to use (idPnt1, Pnt1) or Pnt1By2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 387 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1By2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt1By2Lines

svxPntBy2Lines* svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1By2Lines

set the point2 by the from 2 lines sub-command (NULL to use (idPnt1, Pnt1) or Pnt1ByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 390 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ isFlip2

int svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip2

1 is flip,else 0.default:0

Examples
part\datumCrtTest.cpp.

Definition at line 403 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ Pnt1

svxPoint svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1

point1

Examples
part\datumCrtTest.cpp.

Definition at line 386 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::secondAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ secondAxis

evsResultsAxisMethod svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::secondAxis

2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.

Examples
part\datumCrtTest.cpp.

Definition at line 402 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
  • CSYSThreePnts
firstAxis
idOrgPnt
idPnt1
idPnt2
isFlip1
isFlip2
OrgPnt
OrgPntBy2Lines
OrgPntByOffset
Pnt1
Pnt1By2Lines
Pnt1ByOffset
Pnt2
Pnt2By2Lines
Pnt2ByOffset
secondAxis

◆ idPnt2

int svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt2

id of the point2 parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 395 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::XAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ XAng

double svxCSYSData::XAng

angle value X direction

Examples
part\datumCrtTest.cpp.

Definition at line 477 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::ZAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ ZAng

double svxCSYSData::ZAng

angle value Z direction

Examples
part\datumCrtTest.cpp.

Definition at line 479 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ method

evxCSYSMethods svxCSYSData::method

CSYS methods.

Definition at line 350 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ dOffset

double svxCSYSData::dOffset

offset value

Examples
part\datumCrtTest.cpp.

Definition at line 472 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::XPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ XPnt

svxPoint svxCSYSData::XPnt

XPoint.

Examples
part\datumCrtTest.cpp.

Definition at line 476 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::idXPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ idXPnt

int svxCSYSData::idXPnt

id of the XPoint parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 475 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::Frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ Frame

svxMatrix svxCSYSData::Frame

transformation matrix

Examples
part\datumCrtTest.cpp.

Definition at line 349 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ idOrgPnt

int svxCSYSData::idOrgPnt

id of the origin parent entity

Examples
part\datumCrtTest.cpp.

Definition at line 473 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ OrgPnt

svxPoint svxCSYSData::OrgPnt

origin

Examples
part\datumCrtTest.cpp.

Definition at line 474 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::YAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
dOffset
Frame
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ YAng

double svxCSYSData::YAng

angle value Y direction

Examples
part\datumCrtTest.cpp.

Definition at line 478 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCenMarkCirDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

center mark circle dim data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | iCntCens
the count of the center marks More...
svxPntOnEnt * pCens
point to the point for center marks(the length of list must equal to iCntCens) More...
int | iflg
optional open/close flag 0-Arc(open), 1-Circle(close) (note: 1 as default) More...
char | flgCenter
flag to use "center" (0 as default) More...
svxPntOnEnt center
arc center or circle center(if flgCenter = 1, the value is valid) if iflg = 0, the center is the arc center if iflg = 1, the center is the circle center More...

Detailed Description

center mark circle dim data

Examples
drawing\dwgDimTest.cpp.

Definition at line 1333 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData::iflg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenMarkCirDimData
center
flgCenter
iCntCens
iflg
pCens

◆ iflg

int svxCenMarkCirDimData::iflg

optional open/close flag 0-Arc(open), 1-Circle(close) (note: 1 as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1338 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData::pCens

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenMarkCirDimData
center
flgCenter
iCntCens
iflg
pCens

◆ pCens

svxPntOnEnt* svxCenMarkCirDimData::pCens

point to the point for center marks(the length of list must equal to iCntCens)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1336 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData::flgCenter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenMarkCirDimData
center
flgCenter
iCntCens
iflg
pCens

◆ flgCenter

char svxCenMarkCirDimData::flgCenter

flag to use "center" (0 as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1341 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenMarkCirDimData
center
flgCenter
iCntCens
iflg
pCens

◆ center

svxPntOnEnt svxCenMarkCirDimData::center

arc center or circle center(if flgCenter = 1, the value is valid) if iflg = 0, the center is the arc center if iflg = 1, the center is the circle center

Examples
drawing\dwgDimTest.cpp.

Definition at line 1342 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenMarkCirDimData::iCntCens

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenMarkCirDimData
center
flgCenter
iCntCens
iflg
pCens

◆ iCntCens

int svxCenMarkCirDimData::iCntCens

the count of the center marks

Examples
drawing\dwgDimTest.cpp.

Definition at line 1335 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCenterDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Center Mark Settings. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

double | cmSize
center line/mark size (short dash), default value:4.254534 More...
double | breakLen
extension lines break length (gap), default value:1.5 More...
double | overRun
extension lines overrun, default value:3.06324 More...
double | scaleFac
overall scale factor, default value:1 More...

Detailed Description

Center Mark Settings.

Definition at line 1293 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterDim::scaleFac

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterDim
breakLen
cmSize
overRun
scaleFac

◆ scaleFac

double svxCenterDim::scaleFac

overall scale factor, default value:1

Examples
drawing\dwgDimTest.cpp.

Definition at line 1298 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterDim::breakLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterDim
breakLen
cmSize
overRun
scaleFac

◆ breakLen

double svxCenterDim::breakLen

extension lines break length (gap), default value:1.5

Examples
drawing\dwgDimTest.cpp.

Definition at line 1296 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterDim::overRun

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterDim
breakLen
cmSize
overRun
scaleFac

◆ overRun

double svxCenterDim::overRun

extension lines overrun, default value:3.06324

Examples
drawing\dwgDimTest.cpp.

Definition at line 1297 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterDim::cmSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterDim
breakLen
cmSize
overRun
scaleFac

◆ cmSize

double svxCenterDim::cmSize

center line/mark size (short dash), default value:4.254534

Examples
drawing\dwgDimTest.cpp.

Definition at line 1295 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterLine Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCenterLine Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Center Line. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxCenterLineType iDimType
start point. if type = VX_CL_BY_TWO_LINES, the start point is regarded as the entity line of the point, if type = VX_CL_BY_TWO_POINTS, it is the start point of centerline More...
svxPntOnEnt zPntStart
end point. if type = VX_CL_BY_TWO_LINES, the end point is regarded as the entity line of the point, if type = VX_CL_BY_TWO_POINTS, it is the end point of centerline More...
svxPntOnEnt zPntEnd
end point More...
svxCenterDim zCenterDim
option param: center dimension attribute More...

Detailed Description

Center Line.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1361 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterLine::zPntStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterLine
iDimType
zCenterDim
zPntEnd
zPntStart

◆ zPntStart

svxPntOnEnt svxCenterLine::zPntStart

end point. if type = VX_CL_BY_TWO_LINES, the end point is regarded as the entity line of the point, if type = VX_CL_BY_TWO_POINTS, it is the end point of centerline

Examples
drawing\dwgDimTest.cpp.

Definition at line 1366 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterLine::zCenterDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterLine
iDimType
zCenterDim
zPntEnd
zPntStart

◆ zCenterDim

svxCenterDim svxCenterLine::zCenterDim

option param: center dimension attribute

Examples
drawing\dwgDimTest.cpp.

Definition at line 1370 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterLine::iDimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterLine
iDimType
zCenterDim
zPntEnd
zPntStart

◆ iDimType

evxCenterLineType svxCenterLine::iDimType

start point. if type = VX_CL_BY_TWO_LINES, the start point is regarded as the entity line of the point, if type = VX_CL_BY_TWO_POINTS, it is the start point of centerline

Examples
drawing\dwgDimTest.cpp.

Definition at line 1363 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterLine::zPntEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterLine
iDimType
zCenterDim
zPntEnd
zPntStart

◆ zPntEnd

svxPntOnEnt svxCenterLine::zPntEnd

end point

Examples
drawing\dwgDimTest.cpp.

Definition at line 1369 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCenterMark Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Center Mark. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idEntity
entity id More...
svxPoint zEntPnt
critical point of the entity More...
char | useRotPnt
whether to rotate the center line/mark toward a selected point.(0: no, 1: yes) More...
svxPntOnEnt zRotPnt
rotation point, just for cmType = VX_DM_CENMARK More...
evxCentDimType cmType
center mark type, default value:VX_DM_CENLINE More...
svxCenterDim zCenterDim
option param: center dimension attribute More...
int | slotType
Slot center mark type, valid when entity is a hole, default value:1. More...

Detailed Description

Center Mark.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1316 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::idEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ idEntity

int svxCenterMark::idEntity

entity id

Examples
drawing\dwgDimTest.cpp.

Definition at line 1318 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::useRotPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ useRotPnt

char svxCenterMark::useRotPnt

whether to rotate the center line/mark toward a selected point.(0: no, 1: yes)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1320 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::zCenterDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ zCenterDim

svxCenterDim svxCenterMark::zCenterDim

option param: center dimension attribute

Examples
drawing\dwgDimTest.cpp.

Definition at line 1323 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::zRotPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ zRotPnt

svxPntOnEnt svxCenterMark::zRotPnt

rotation point, just for cmType = VX_DM_CENMARK

Examples
drawing\dwgDimTest.cpp.

Definition at line 1321 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::zEntPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ zEntPnt

svxPoint svxCenterMark::zEntPnt

critical point of the entity

Examples
drawing\dwgDimTest.cpp.

Definition at line 1319 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::slotType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ slotType

int svxCenterMark::slotType

Slot center mark type, valid when entity is a hole, default value:1.

1: Slot centers;

2: Slot ends

Examples
drawing\dwgDimTest.cpp.

Definition at line 1324 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCenterMark::cmType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCenterMark
cmType
idEntity
slotType
useRotPnt
zCenterDim
zEntPnt
zRotPnt

◆ cmType

evxCentDimType svxCenterMark::cmType

center mark type, default value:VX_DM_CENLINE

Examples
drawing\dwgDimTest.cpp.

Definition at line 1322 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCf Struct Reference
Part Objects » Part Data

conversion factor More...

#include <zwapi_part_data.h>

Data Fields

double | value
value More...
vxName name
name (null-terminated string) More...
evxNumType klass
class More...
unsigned char | id
unique id ( see evxUnitType , evxAngUnitType and evxMassUnitType) More...

Detailed Description

conversion factor

Definition at line 168 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCf::klass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCf
id
klass
name
value

◆ klass

evxNumType svxCf::klass

class

Definition at line 172 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCf::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCf
id
klass
name
value

◆ name

vxName svxCf::name

name (null-terminated string)

Definition at line 171 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCf::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCf
id
klass
name
value

◆ value

double svxCf::value

value

Definition at line 170 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCf::id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCf
id
klass
name
value

◆ id

unsigned char svxCf::id

unique id ( see evxUnitType , evxAngUnitType and evxMassUnitType)

Definition at line 173 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxChamFlltData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

chamfer or fillet data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxChamFlltType type
chamfer or fillet type More...
int | nEdges
number of edges or vertexes to chamfer or fillet More...
int * | idEdge
list of index of edges to chamfer or fillet More...
int * | vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_CHAMFILT_VERTEX type, other types can be set to NULL More...
double | setback1
the first setback distance or radius More...
double | setback2
the second setback distance for VX_CHAMFILT_ASYMMETRIC type More...
double | angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type More...
double | relief
specify the amount of smoothing at a corner patch. When set to zero (0.0-default), the command decides where to trim the rails of the fillets meeting at a corner. Values greater than 0 add additional relief to corners. More...
int | arcType
specify the fillet arc type (0-circular arc, 1-conic arc, 2-G2 blend) More...
double | conicRatio
conic ratio for conic arc type (0~0.999999, 0.5-default) More...
double | weight [2]
endpoint weights for G2 blend arc type (0.1~5.0, 1.0-default) More...
int | filletToEdge
if set to 1, fillet held to nearby edges (0-default) More...
int | usePatch
whether to use patches in tight corners (0-default) More...
int | undercuts
if set to 1, the chamfer/fillet engine will look for cases where the new chamfer/fillet are completely undercutting a pre-existing feature. If found, the engine will attempt to extend and/or trim the old feature against the new chamfer/fillet (0-default) More...
int | localCorner
if set to 1, keep chamfering/filleting only to the edge, else the chamfer/fillet will extend to the surface where the edge is (0-default) More...
int | mitred
if set to 1, the chamfer/fillet engine will provide a mitred solution at corners of uniform convexity , else a corner patch will be added when all edges are chamfered (0-default) More...
int | traceCorners
if set to 1, the rails of the chamfer/fillet and corner patch faces are traced onto the support faces rather than being projected (0-default) More...
int | blendCorners
if set to 1, create a single smooth trimmed planar face for each corner via the FEM-based surface fitting method, else multiple tangent-continuous faces are used to patch corners (0-default) More...
int | continuity
continuous way (0-tangent, 1-curvature) More...
int | desity
the average number of sampling points along the edges of the blended corners (2~200) More...
int | baseFaces
base face processing method (0-sew, 1-trim, 2-divide, 3-no action) More...
int | filletFace
the tangency of the new chamfer/fillet faces (0-tangent match, 1-minimal, 2-maximal) More...
int | flip
1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE) More...
int | offsetType
method of offset, 0- offset distance, 1- offset surface(default:0, only used for Charmer feature) More...
svxPntOnEnt * setback1Pnt
setback1 value (NULL to ignore) More...
svxPntOnEnt * setback2Pnt
setback2 value (NULL to ignore) More...
int | cntList
count of set list, 0-to ignore More...
svxChamFlltSetData * pChamFlltDataList
data of each list, NULL to ignore More...

Detailed Description

chamfer or fillet data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 446 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::baseFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ baseFaces

int svxChamFlltData::baseFaces

base face processing method (0-sew, 1-trim, 2-divide, 3-no action)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 488 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::nEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ nEdges

int svxChamFlltData::nEdges

number of edges or vertexes to chamfer or fillet

Definition at line 450 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::traceCorners

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ traceCorners

int svxChamFlltData::traceCorners

if set to 1, the rails of the chamfer/fillet and corner patch faces are traced onto the support faces rather than being projected (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 480 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::setback2Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ setback2Pnt

svxPntOnEnt* svxChamFlltData::setback2Pnt

setback2 value (NULL to ignore)

Definition at line 496 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::cntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ cntList

int svxChamFlltData::cntList

count of set list, 0-to ignore

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 499 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::weight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ weight

double svxChamFlltData::weight[2]

endpoint weights for G2 blend arc type (0.1~5.0, 1.0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 466 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ angle

double svxChamFlltData::angle

the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 458 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::localCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ localCorner

int svxChamFlltData::localCorner

if set to 1, keep chamfering/filleting only to the edge, else the chamfer/fillet will extend to the surface where the edge is (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 475 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::vertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ vertex

int* svxChamFlltData::vertex

list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_CHAMFILT_VERTEX type, other types can be set to NULL

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 452 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::setback1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ setback1

double svxChamFlltData::setback1

the first setback distance or radius

Definition at line 456 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::setback2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ setback2

double svxChamFlltData::setback2

the second setback distance for VX_CHAMFILT_ASYMMETRIC type

Definition at line 457 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::setback1Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ setback1Pnt

svxPntOnEnt* svxChamFlltData::setback1Pnt

setback1 value (NULL to ignore)

Definition at line 495 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ flip

int svxChamFlltData::flip

1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE)

Definition at line 491 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::mitred

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ mitred

int svxChamFlltData::mitred

if set to 1, the chamfer/fillet engine will provide a mitred solution at corners of uniform convexity , else a corner patch will be added when all edges are chamfered (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 477 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::offsetType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ offsetType

int svxChamFlltData::offsetType

method of offset, 0- offset distance, 1- offset surface(default:0, only used for Charmer feature)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 492 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ idEdge

int* svxChamFlltData::idEdge

list of index of edges to chamfer or fillet

Definition at line 451 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ relief

double svxChamFlltData::relief

specify the amount of smoothing at a corner patch. When set to zero (0.0-default), the command decides where to trim the rails of the fillets meeting at a corner. Values greater than 0 add additional relief to corners.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 461 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::pChamFlltDataList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ pChamFlltDataList

svxChamFlltSetData* svxChamFlltData::pChamFlltDataList

data of each list, NULL to ignore

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 500 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::filletFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ filletFace

int svxChamFlltData::filletFace

the tangency of the new chamfer/fillet faces (0-tangent match, 1-minimal, 2-maximal)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 489 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::arcType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ arcType

int svxChamFlltData::arcType

specify the fillet arc type (0-circular arc, 1-conic arc, 2-G2 blend)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 464 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::undercuts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ undercuts

int svxChamFlltData::undercuts

if set to 1, the chamfer/fillet engine will look for cases where the new chamfer/fillet are completely undercutting a pre-existing feature. If found, the engine will attempt to extend and/or trim the old feature against the new chamfer/fillet (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 471 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::usePatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ usePatch

int svxChamFlltData::usePatch

whether to use patches in tight corners (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 470 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::continuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ continuity

int svxChamFlltData::continuity

continuous way (0-tangent, 1-curvature)

Definition at line 485 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::desity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ desity

int svxChamFlltData::desity

the average number of sampling points along the edges of the blended corners (2~200)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 486 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ type

evxChamFlltType svxChamFlltData::type

chamfer or fillet type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 448 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::blendCorners

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ blendCorners

int svxChamFlltData::blendCorners

if set to 1, create a single smooth trimmed planar face for each corner via the FEM-based surface fitting method, else multiple tangent-continuous faces are used to patch corners (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 482 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::filletToEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ filletToEdge

int svxChamFlltData::filletToEdge

if set to 1, fillet held to nearby edges (0-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 469 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltData::conicRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltData
angle
arcType
baseFaces
blendCorners
cntList
conicRatio
continuity
desity
filletFace
filletToEdge
flip
idEdge
localCorner
mitred
nEdges
offsetType
pChamFlltDataList
relief
setback1
setback1Pnt
setback2
setback2Pnt
traceCorners
type
undercuts
usePatch
vertex
weight

◆ conicRatio

double svxChamFlltData::conicRatio

conic ratio for conic arc type (0~0.999999, 0.5-default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 465 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxChamFlltSetData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

set-list data for chamfer or fillet command More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | nEdges
number of edges or vertexes to chamfer or fillet More...
int * | idEdge
list of index of edges to chamfer or fillet More...
int * | vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_CHAMFILT_VERTEX type, other types can be set to NULL More...
int | chordalFillet
if set to 1, use chordal instead of radius for fillet, the variable 'setback1' will be treated as 'Chordal L' (0-default) More...
double | setback1
the first setback distance or radius More...
double | setback2
the second setback distance for VX_CHAMFILT_ASYMMETRIC type More...
double | angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type More...
int | flip
1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE) More...
svxPntOnEnt * setback1Pnt
setback1 value (NULL to ignore) More...
svxPntOnEnt * setback2Pnt
setback2 value (NULL to ignore) More...

Detailed Description

set-list data for chamfer or fillet command

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 424 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::setback1Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ setback1Pnt

svxPntOnEnt* svxChamFlltSetData::setback1Pnt

setback1 value (NULL to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 438 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ angle

double svxChamFlltSetData::angle

the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 434 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::chordalFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ chordalFillet

int svxChamFlltSetData::chordalFillet

if set to 1, use chordal instead of radius for fillet, the variable 'setback1' will be treated as 'Chordal L' (0-default)

Definition at line 431 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ idEdge

int* svxChamFlltSetData::idEdge

list of index of edges to chamfer or fillet

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 427 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::setback1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ setback1

double svxChamFlltSetData::setback1

the first setback distance or radius

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 432 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::setback2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ setback2

double svxChamFlltSetData::setback2

the second setback distance for VX_CHAMFILT_ASYMMETRIC type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 433 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ flip

int svxChamFlltSetData::flip

1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE)

Definition at line 436 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::nEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ nEdges

int svxChamFlltSetData::nEdges

number of edges or vertexes to chamfer or fillet

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 426 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::vertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ vertex

int* svxChamFlltSetData::vertex

list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in this list should also be nEdges, only for VX_CHAMFILT_VERTEX type, other types can be set to NULL

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 428 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxChamFlltSetData::setback2Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxChamFlltSetData
angle
chordalFillet
flip
idEdge
nEdges
setback1
setback1Pnt
setback2
setback2Pnt
vertex

◆ setback2Pnt

svxPntOnEnt* svxChamFlltSetData::setback2Pnt

setback2 value (NULL to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 439 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCircleData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

3D circle data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxCircleType type
type to create a circle More...
svxPntOnEntPath centerPnt
center point of circle, used when type is VX_CIRCLE_BOUNDARY or VX_CIRCLE_RADIUS More...
svxPntOnEntPath | bndPnts [3]
boundary points of circle, fill the array with the number of bounding points required by type More...
int | useDiameter
indicate radius or diameter (0: radius; 1: diameter), used when type is VX_CIRCLE_RADIUS More...
double | radOrDia
radius or diameter of circle, used when type is VX_CIRCLE_RADIUS or VX_CIRCLE_2PT_RADIUS More...
int | idAlignPln
id of the alignment datum plane or planar face(0 to ignore) More...
int | prjToPln
whether to project circle to alignment plane More...
svxPntOnEntPath * location
indicate circle, used when type is VX_CIRCLE_2PT_RADIUS More...

Detailed Description

3D circle data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 109 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::idAlignPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ idAlignPln

int svxCircleData::idAlignPln

id of the alignment datum plane or planar face(0 to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 117 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ location

svxPntOnEntPath* svxCircleData::location

indicate circle, used when type is VX_CIRCLE_2PT_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 119 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::prjToPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ prjToPln

int svxCircleData::prjToPln

whether to project circle to alignment plane

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 118 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::bndPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ bndPnts

svxPntOnEntPath svxCircleData::bndPnts[3]

boundary points of circle, fill the array with the number of bounding points required by type

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 113 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::useDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ useDiameter

int svxCircleData::useDiameter

indicate radius or diameter (0: radius; 1: diameter), used when type is VX_CIRCLE_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 114 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::centerPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ centerPnt

svxPntOnEntPath svxCircleData::centerPnt

center point of circle, used when type is VX_CIRCLE_BOUNDARY or VX_CIRCLE_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 112 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::radOrDia

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ radOrDia

double svxCircleData::radOrDia

radius or diameter of circle, used when type is VX_CIRCLE_RADIUS or VX_CIRCLE_2PT_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 115 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircleData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircleData
bndPnts
centerPnt
idAlignPln
location
prjToPln
radOrDia
type
useDiameter

◆ type

evxCircleType svxCircleData::type

type to create a circle

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 111 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCircularBiRailData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

circular bi rail data More...

#include <zwapi_cmd_freeform_data.h>

Data Structures

union evxCircularBiRailInpUnion

Data Fields

evxCircularBiRailMethod method
method to create a new circular face (VX_CIRCULARBIRAIL_CONSTANT as default) More...
svxPntOnEntPath firstCrv
select the first path curve More...
svxPntOnEntPath secondCrv
select the second path curve More...
svxPntOnEntPath spineCrv
select the spine curve More...
union svxCircularBiRailData::evxCircularBiRailInpUnion inpUnion

Detailed Description

circular bi rail data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 191 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailCenter
Data Fields
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter Struct Reference

Data Fields

svxPntOnEntPath center
select the center curve More...
int solution
multiple solutions will be displayed More...

Detailed Description

Definition at line 210 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::solution

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailCenter
center
solution

◆ solution

int svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::solution

multiple solutions will be displayed

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 213 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailCenter
center
solution

◆ center

svxPntOnEntPath svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::center

select the center curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 212 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailConstant
Data Fields
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant Struct Reference

Data Fields

double | radius
constant radius More...
int | solution
multiple solutions will be displayed More...

Detailed Description

Definition at line 199 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailConstant
radius
solution

◆ radius

double svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::radius

constant radius

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 201 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::solution

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailConstant
radius
solution

◆ solution

int svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::solution

multiple solutions will be displayed

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 202 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailMiddle
Data Fields
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle Struct Reference

Data Fields

svxPntOnEntPath middle
select the middle curve More...

Detailed Description

Definition at line 215 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle::middle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailMiddle
middle

◆ middle

svxPntOnEntPath svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle::middle

select the middle curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 217 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailVariable
Data Fields
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable Struct Reference

Data Fields

int | solution
multiple solutions will be displayed More...
int | nRadSet
the count of list More...
svxRadiusSetData * pRadSet
store spines list with different radius More...

Detailed Description

Definition at line 204 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::solution

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailVariable
nRadSet
pRadSet
solution

◆ solution

int svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::solution

multiple solutions will be displayed

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 206 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::pRadSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailVariable
nRadSet
pRadSet
solution

◆ pRadSet

svxRadiusSetData* svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::pRadSet

store spines list with different radius

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 208 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::nRadSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
  • CircularBiRailVariable
nRadSet
pRadSet
solution

◆ nRadSet

int svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::nRadSet

the count of list

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 207 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::firstCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
firstCrv
method
secondCrv
spineCrv

◆ firstCrv

svxPntOnEntPath svxCircularBiRailData::firstCrv

select the first path curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 194 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::spineCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
firstCrv
method
secondCrv
spineCrv

◆ spineCrv

svxPntOnEntPath svxCircularBiRailData::spineCrv

select the spine curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 196 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
firstCrv
method
secondCrv
spineCrv

◆ method

evxCircularBiRailMethod svxCircularBiRailData::method

method to create a new circular face (VX_CIRCULARBIRAIL_CONSTANT as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 193 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::secondCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
firstCrv
method
secondCrv
spineCrv

◆ secondCrv

svxPntOnEntPath svxCircularBiRailData::secondCrv

select the second path curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 195 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCloseCornerData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Close Corner data (Note: if you don't care some parameters, set them as default values) More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union CornerData
union of close corner data More...

Data Fields

int | type
method, 0-close by edge, 1- close by bend(face)(0 as default) More...
union svxCloseCornerData::CornerData | cornerData
evxCornerOverlapTyp Overlp
(VX_CONER_NATURAL as default) More...
double | dGap
(0.1mm as default) More...

Detailed Description

template command Smd Close Corner data (Note: if you don't care some parameters, set them as default values)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 989 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByEdge Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByEdge
Data Fields
svxCloseCornerData::CornerData::svxByEdge Struct Reference

linear pattern More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

svxPntOnEnt Edg1Pnt
first face edge More...
svxPntOnEnt Edg2Pnt
second face edge More...

Detailed Description

linear pattern

<

Definition at line 994 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByEdge::Edg1Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByEdge
Edg1Pnt
Edg2Pnt

◆ Edg1Pnt

svxPntOnEnt svxCloseCornerData::CornerData::svxByEdge::Edg1Pnt

first face edge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 996 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByEdge::Edg2Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByEdge
Edg1Pnt
Edg2Pnt

◆ Edg2Pnt

svxPntOnEnt svxCloseCornerData::CornerData::svxByEdge::Edg2Pnt

second face edge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 997 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
Data Fields
svxCloseCornerData::CornerData::svxByFace Struct Reference

circular pattern More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idBend1
first bend face More...
int | idBend2
second bend face More...
int | CloseFlange
close the whole flange or not(1 as default) if set to 1, it closes all sub corners with the basic one. if set to 0, it only close basic one. More...
int | Miter
miter corner or not (1 as default) if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern. if set to 1, use curves to form the outline of the cuter. More...
evxCornerReliefTyp Relief
to trim the adjoining flanges (VX_CORNER_CLOSED as default) More...
int | OrgType
0-bend center, 1-corner point(1 as default, and it works when Relief != VX_CORNER_CLOSED) More...
double | dOffset
specify offset distance for origin (0.0 as default, use it when Relief!=VX_CORNER_CLOSED) More...
double | dDiam
diameter(4.0 as default, use it when Relief!=VX_CORNER_CLOSED && Relief!=VX_CORNER_RECT_CUTOUT) More...
double | dLength
specify length for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT) More...
double | dWidth
specify width for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT) More...
double | dAng1
specify first angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT) More...
double | dAng2
specify second angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT) More...

Detailed Description

circular pattern

<

Definition at line 1000 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dWidth

double svxCloseCornerData::CornerData::svxByFace::dWidth

specify width for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1015 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dLength

double svxCloseCornerData::CornerData::svxByFace::dLength

specify length for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1014 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::idBend1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ idBend1

int svxCloseCornerData::CornerData::svxByFace::idBend1

first bend face

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1002 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::OrgType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ OrgType

int svxCloseCornerData::CornerData::svxByFace::OrgType

0-bend center, 1-corner point(1 as default, and it works when Relief != VX_CORNER_CLOSED)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1011 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::idBend2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ idBend2

int svxCloseCornerData::CornerData::svxByFace::idBend2

second bend face

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1003 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dDiam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dDiam

double svxCloseCornerData::CornerData::svxByFace::dDiam

diameter(4.0 as default, use it when Relief!=VX_CORNER_CLOSED && Relief!=VX_CORNER_RECT_CUTOUT)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1013 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::CloseFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ CloseFlange

int svxCloseCornerData::CornerData::svxByFace::CloseFlange

close the whole flange or not(1 as default) if set to 1, it closes all sub corners with the basic one. if set to 0, it only close basic one.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1004 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dAng1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dAng1

double svxCloseCornerData::CornerData::svxByFace::dAng1

specify first angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1016 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dAng2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dAng2

double svxCloseCornerData::CornerData::svxByFace::dAng2

specify second angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1017 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::Relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ Relief

evxCornerReliefTyp svxCloseCornerData::CornerData::svxByFace::Relief

to trim the adjoining flanges (VX_CORNER_CLOSED as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1010 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::Miter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ Miter

int svxCloseCornerData::CornerData::svxByFace::Miter

miter corner or not (1 as default) if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern. if set to 1, use curves to form the outline of the cuter.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1007 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData::svxByFace::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
  • svxByFace
CloseFlange
dAng1
dAng2
dDiam
dLength
dOffset
dWidth
idBend1
idBend2
Miter
OrgType
Relief

◆ dOffset

double svxCloseCornerData::CornerData::svxByFace::dOffset

specify offset distance for origin (0.0 as default, use it when Relief!=VX_CORNER_CLOSED)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1012 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::dGap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
dGap
Overlp
type

◆ dGap

double svxCloseCornerData::dGap

(0.1mm as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1022 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::Overlp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
dGap
Overlp
type

◆ Overlp

evxCornerOverlapTyp svxCloseCornerData::Overlp

(VX_CONER_NATURAL as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1021 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
dGap
Overlp
type

◆ type

int svxCloseCornerData::type

method, 0-close by edge, 1- close by bend(face)(0 as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 991 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxClrChkData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

clearance check result data More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxEntPath BaseCompPath
base component pick path for clearance check More...
svxEntPath ChkCompPath
check component pick path for clearance check More...
svxPoint | Pnt [2]
points of component More...
double | ClrValue
clearance value More...
int | IferFlag
flag of interference More...

Detailed Description

clearance check result data

Definition at line 931 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData::BaseCompPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxClrChkData
BaseCompPath
ChkCompPath
ClrValue
IferFlag
Pnt

◆ BaseCompPath

svxEntPath svxClrChkData::BaseCompPath

base component pick path for clearance check

Definition at line 933 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData::IferFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxClrChkData
BaseCompPath
ChkCompPath
ClrValue
IferFlag
Pnt

◆ IferFlag

int svxClrChkData::IferFlag

flag of interference

Definition at line 937 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData::ClrValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxClrChkData
BaseCompPath
ChkCompPath
ClrValue
IferFlag
Pnt

◆ ClrValue

double svxClrChkData::ClrValue

clearance value

Definition at line 936 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData::ChkCompPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxClrChkData
BaseCompPath
ChkCompPath
ClrValue
IferFlag
Pnt

◆ ChkCompPath

svxEntPath svxClrChkData::ChkCompPath

check component pick path for clearance check

Definition at line 934 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxClrChkData::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxClrChkData
BaseCompPath
ChkCompPath
ClrValue
IferFlag
Pnt

◆ Pnt

svxPoint svxClrChkData::Pnt[2]

points of component

Definition at line 935 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmAttrValue Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCmAttrValue Struct Reference
Common » Common Data

cam data attribute value More...

#include <zwapi_util.h>

Data Fields

evxCmAttrValueType type
cam data attribute type More...
int | cnt
count of data More...
void * | data
user is response to free this memory More...

Detailed Description

cam data attribute value

Definition at line 2513 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmAttrValue::data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCmAttrValue
cnt
data
type

◆ data

void* svxCmAttrValue::data

user is response to free this memory

Definition at line 2517 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmAttrValue::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCmAttrValue
cnt
data
type

◆ cnt

int svxCmAttrValue::cnt

count of data

Definition at line 2516 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmAttrValue::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCmAttrValue
cnt
data
type

◆ type

evxCmAttrValueType svxCmAttrValue::type

cam data attribute type

Definition at line 2515 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmdActionParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCmdActionParam Struct Reference
Commands Creation » Command Definition » Command Data

command action parameter More...

#include <zwapi_cmd_data.h>

Data Fields

int(* | pfn )(void *param, const char *)
callback function, the 2nd parameter is the command name More...
void * | param
parameter More...

Detailed Description

command action parameter

Definition at line 70 of file zwapi_cmd_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmdActionParam::param

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCmdActionParam
param
pfn

◆ param

void* svxCmdActionParam::param

parameter

Definition at line 73 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCmdActionParam::pfn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCmdActionParam
param
pfn

◆ pfn

int(* svxCmdActionParam::pfn) (void *param, const char *)

callback function, the 2nd parameter is the command name

Definition at line 72 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColor Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxColor Struct Reference
Common » Common Data

RGB color (each component defined over 0 to 255) More...

#include <zwapi_util.h>

Data Fields

unsigned char | r
red color component (0-255) More...
unsigned char | g
green color component (0-255) More...
unsigned char | b
blue color component (0-255) More...

Detailed Description

RGB color (each component defined over 0 to 255)

Definition at line 617 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColor::r

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColor
b
g
r

◆ r

unsigned char svxColor::r

red color component (0-255)

Definition at line 619 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColor::g

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColor
b
g
r

◆ g

unsigned char svxColor::g

green color component (0-255)

Definition at line 620 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColor::b

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColor
b
g
r

◆ b

unsigned char svxColor::b

blue color component (0-255)

Definition at line 621 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColorf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxColorf Struct Reference
Common » Common Data

RGB color (floating point components defined over 0.0 to 1.0) More...

#include <zwapi_util.h>

Data Fields

float | r
red color component (0.0-1.0) More...
float | g
green color component (0.0-1.0) More...
float | b
blue color component (0.0-1.0) More...

Detailed Description

RGB color (floating point components defined over 0.0 to 1.0)

Definition at line 628 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColorf::g

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColorf
b
g
r

◆ g

float svxColorf::g

green color component (0.0-1.0)

Definition at line 631 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColorf::b

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColorf
b
g
r

◆ b

float svxColorf::b

blue color component (0.0-1.0)

Definition at line 632 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxColorf::r

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxColorf
b
g
r

◆ r

float svxColorf::r

red color component (0.0-1.0)

Definition at line 630 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCompData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

component data More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

vxLongPath Dir
pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames More...
vxLongPath File
name of file that contains "Part" More...
vxRootName Part
name of part to instance as a component More...
vxPath Comp
name to assign to new component in parent part set "Comp[0]=0" for default name (deprecated since zw3d 2022) More...
svxMatrix Frame
insertion frame for new component More...
int | Anchor
1 to anchor component, or 0 More...
int | AutoRegen
1 to regen component when parent is regen'd, or 0 More...
int | AutoDelete
1 to delete component when parent is deleted, or 0 More...
int | Copy
1 to copy "Part" before instancing, or 0 More...
vxLongName CopyName
name to assign to copied part when "Copy=1" if no name is given, the default name is output More...
int | Overwrite
0 to automatically avoid overwriting existing part 1 to prompt whether to overwrite existing part -1 to automatically overwrite existing part More...
vxLongPath DestFile
name of destination file if copying part If no name is given (DestFile[0]=0), the part is copied to the file of the parent assembly (deprecated since zw3d 2022) More...
int | Align
1 to align component with point or frame, or 0 More...
svxData AlignData
align data for point and frame align. use cvxDataGet() to get the data. More...
int | CopyPart
1 to copy "Part" before instancing, or 0 More...
vxName CfgName
config name, set "CfgName[0]=0" to use active config More...

Detailed Description

component data

Definition at line 33 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::AutoRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ AutoRegen

int svxCompData::AutoRegen

1 to regen component when parent is regen'd, or 0

Definition at line 45 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Dir

vxLongPath svxCompData::Dir

pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames

Definition at line 35 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Overwrite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Overwrite

int svxCompData::Overwrite

0 to automatically avoid overwriting existing part 1 to prompt whether to overwrite existing part -1 to automatically overwrite existing part

Definition at line 51 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::AutoDelete

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ AutoDelete

int svxCompData::AutoDelete

1 to delete component when parent is deleted, or 0

Definition at line 46 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::DestFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ DestFile

vxLongPath svxCompData::DestFile

name of destination file if copying part If no name is given (DestFile[0]=0), the part is copied to the file of the parent assembly (deprecated since zw3d 2022)

Definition at line 55 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Align

int svxCompData::Align

1 to align component with point or frame, or 0

Definition at line 59 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ File

vxLongPath svxCompData::File

name of file that contains "Part"

Definition at line 38 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::CopyPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ CopyPart

int svxCompData::CopyPart

1 to copy "Part" before instancing, or 0

Definition at line 63 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Anchor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Anchor

int svxCompData::Anchor

1 to anchor component, or 0

Definition at line 44 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Comp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Comp

vxPath svxCompData::Comp

name to assign to new component in parent part set "Comp[0]=0" for default name (deprecated since zw3d 2022)

Definition at line 40 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Part

vxRootName svxCompData::Part

name of part to instance as a component

Definition at line 39 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::CopyName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ CopyName

vxLongName svxCompData::CopyName

name to assign to copied part when "Copy=1" if no name is given, the default name is output

Definition at line 48 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::CfgName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ CfgName

vxName svxCompData::CfgName

config name, set "CfgName[0]=0" to use active config

Definition at line 64 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Frame

svxMatrix svxCompData::Frame

insertion frame for new component

Definition at line 43 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::AlignData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ AlignData

svxData svxCompData::AlignData

align data for point and frame align. use cvxDataGet() to get the data.

Definition at line 60 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompData::Copy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompData
Align
AlignData
Anchor
AutoDelete
AutoRegen
CfgName
Comp
Copy
CopyName
CopyPart
DestFile
Dir
File
Frame
Overwrite
Part

◆ Copy

int svxCompData::Copy

1 to copy "Part" before instancing, or 0

Definition at line 47 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCompIncludeData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

include component data More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

vxLongPath Dir
pathname of directory that contains "File", set "Dir[0]=0" to search default pathnames More...
vxLongPath File
name of file that contains "Part", set "File[0]=0 to use current file name" More...
vxRootName Part
name of part to instance as a component More...
vxName CfgName
config name, set "CfgName[0]=0" to use active config More...
vxName LayName
layer to insert, set "LayName[0]=0" to use active layer More...

Detailed Description

include component data

Definition at line 71 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData::Part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompIncludeData
CfgName
Dir
File
LayName
Part

◆ Part

vxRootName svxCompIncludeData::Part

name of part to instance as a component

Definition at line 76 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData::CfgName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompIncludeData
CfgName
Dir
File
LayName
Part

◆ CfgName

vxName svxCompIncludeData::CfgName

config name, set "CfgName[0]=0" to use active config

Definition at line 77 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData::LayName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompIncludeData
CfgName
Dir
File
LayName
Part

◆ LayName

vxName svxCompIncludeData::LayName

layer to insert, set "LayName[0]=0" to use active layer

Definition at line 78 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData::File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompIncludeData
CfgName
Dir
File
LayName
Part

◆ File

vxLongPath svxCompIncludeData::File

name of file that contains "Part", set "File[0]=0 to use current file name"

Definition at line 75 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompIncludeData::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompIncludeData
CfgName
Dir
File
LayName
Part

◆ Dir

vxLongPath svxCompIncludeData::Dir

pathname of directory that contains "File", set "Dir[0]=0" to search default pathnames

Definition at line 73 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompName Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCompName Struct Reference
Common » Common Data

brief component info More...

#include <zwapi_util.h>

Data Fields

vxLongPath File
name of file that contains "Part" More...
vxRootName Part
name of part to instance as a component More...

Detailed Description

brief component info

Definition at line 2286 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompName::File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompName
File
Part

◆ File

vxLongPath svxCompName::File

name of file that contains "Part"

Definition at line 2288 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCompName::Part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCompName
File
Part

◆ Part

vxRootName svxCompName::Part

name of part to instance as a component

Definition at line 2289 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCone Struct Reference
Common » Common Data

conical surface data More...

#include <zwapi_util.h>

Data Fields

double | radius1
bottom (lo u or v) radius More...
double | radius2
top (hi u or v) radius. More...
double | length
cone len between Max(radius1,radius2) and apex (length of the axis) More...
svxMatrix form
cone centered about xform
origin is at large radius
z-axis points from large radius to apex.
x-axis point to seam More...
int | lindir
= 1 : u defines the linear direction.
= 2 : v defines the linear direction. More...

Detailed Description

conical surface data

Definition at line 1792 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCone
form
length
lindir
radius1
radius2

◆ length

double svxCone::length

cone len between Max(radius1,radius2) and apex (length of the axis)

Definition at line 1796 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCone
form
length
lindir
radius1
radius2

◆ radius1

double svxCone::radius1

bottom (lo u or v) radius

Definition at line 1794 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCone
form
length
lindir
radius1
radius2

◆ form

svxMatrix svxCone::form

cone centered about xform
origin is at large radius
z-axis points from large radius to apex.
x-axis point to seam

Definition at line 1797 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCone
form
length
lindir
radius1
radius2

◆ radius2

double svxCone::radius2

top (hi u or v) radius.

Definition at line 1795 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCone::lindir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCone
form
length
lindir
radius1
radius2

◆ lindir

int svxCone::lindir

= 1 : u defines the linear direction.
= 2 : v defines the linear direction.

Definition at line 1801 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxConeData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

cone More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
svxPoint Center
center of bottom face More...
double | Radius1
the first radius (mm) in bottom face More...
double | Length
length (mm) along Z More...
double | Radius2
the second radius (mm), 0 default More...
int | useAxis
flag to use axis (0 to use plane, 1 to use axis) More...
int | idPlane
optional datum plane (0 to use XY plane) More...
svxAxis axis
optional axis More...
vxName ftrName
feature name for "FtAllCone", 0 default More...

Detailed Description

cone

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 78 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ Combine

evxBoolType svxConeData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 80 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::Length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ Length

double svxConeData::Length

length (mm) along Z

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 83 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ Center

svxPoint svxConeData::Center

center of bottom face

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 81 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ idPlane

int svxConeData::idPlane

optional datum plane (0 to use XY plane)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 87 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ axis

svxAxis svxConeData::axis

optional axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 88 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::useAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ useAxis

int svxConeData::useAxis

flag to use axis (0 to use plane, 1 to use axis)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 86 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::Radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ Radius2

double svxConeData::Radius2

the second radius (mm), 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 84 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::Radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ Radius1

double svxConeData::Radius1

the first radius (mm) in bottom face

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 82 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConeData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConeData
axis
Center
Combine
ftrName
idPlane
Length
Radius1
Radius2
useAxis

◆ ftrName

vxName svxConeData::ftrName

feature name for "FtAllCone", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 90 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxConic3ptData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

3 Point Conic command data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPntOnEnt StartPnt
Start point. More...
svxPntOnEnt EndPnt
End point. More...
svxPntOnEnt Point
Point. More...
evxConic3PntType PointType
Point type. More...
double Ratio
Conic Ratio, Range of this value is: 0.01 <= Ratio <= 0.99. More...

Detailed Description

3 Point Conic command data

Definition at line 307 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData::Point

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConic3ptData
EndPnt
Point
PointType
Ratio
StartPnt

◆ Point

svxPntOnEnt svxConic3ptData::Point

Point.

Definition at line 311 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData::Ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConic3ptData
EndPnt
Point
PointType
Ratio
StartPnt

◆ Ratio

double svxConic3ptData::Ratio

Conic Ratio, Range of this value is: 0.01 <= Ratio <= 0.99.

Definition at line 313 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData::PointType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConic3ptData
EndPnt
Point
PointType
Ratio
StartPnt

◆ PointType

evxConic3PntType svxConic3ptData::PointType

Point type.

Definition at line 312 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData::EndPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConic3ptData
EndPnt
Point
PointType
Ratio
StartPnt

◆ EndPnt

svxPntOnEnt svxConic3ptData::EndPnt

End point.

Definition at line 310 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConic3ptData::StartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConic3ptData
EndPnt
Point
PointType
Ratio
StartPnt

◆ StartPnt

svxPntOnEnt svxConic3ptData::StartPnt

Start point.

Definition at line 309 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxConicBiRailData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

conic bi rail data More...

#include <zwapi_cmd_freeform_data.h>

Data Structures

union evxConicBiRailInpUnion

Data Fields

evxConicBiRailMethod method
method to create a new conic face (VX_CONICBIRAIL_CONSTANT as default) More...
svxPntOnEntPath firstCrv
select the first path curve More...
svxPntOnEntPath secondCrv
select the second path curve More...
svxPntOnEntPath spineCrv
select the spine curve More...
union svxConicBiRailData::evxConicBiRailInpUnion inpUnion

Detailed Description

conic bi rail data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 241 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailCenter
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter Struct Reference

Data Fields

svxPntOnEntPath center
select the center curve More...
double ratio
conic ratio More...

Detailed Description

Definition at line 277 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailCenter
center
ratio

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 280 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailCenter
center
ratio

◆ center

svxPntOnEntPath svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::center

select the center curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 279 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailConstant
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant Struct Reference

Data Fields

double | radius
constant radius More...
double | ratio
conic ratio More...
int | solution
multiple solutions will be displayed More...

Detailed Description

Definition at line 249 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailConstant
radius
ratio
solution

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 252 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::solution

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailConstant
radius
ratio
solution

◆ solution

int svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::solution

multiple solutions will be displayed

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 253 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailConstant
radius
ratio
solution

◆ radius

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::radius

constant radius

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 251 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailHolder
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder Struct Reference

Data Fields

svxPntOnEntPath holder
select the shoulder curve More...
double ratio
conic ratio More...

Detailed Description

Definition at line 262 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::holder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailHolder
holder
ratio

◆ holder

svxPntOnEntPath svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::holder

select the shoulder curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 264 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailHolder
holder
ratio

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 265 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailIntersection
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection Struct Reference

Data Fields

svxPntOnEntPath holder
select the shoulder curve More...
svxPntOnEntPath tangent
select the tangent curve More...

Detailed Description

Definition at line 272 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::holder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailIntersection
holder
tangent

◆ holder

svxPntOnEntPath svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::holder

select the shoulder curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 274 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::tangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailIntersection
holder
tangent

◆ tangent

svxPntOnEntPath svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::tangent

select the tangent curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 275 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailTangent
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent Struct Reference

Data Fields

svxPntOnEntPath tangent
select the tangent curve More...
double ratio
conic ratio More...

Detailed Description

Definition at line 267 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailTangent
ratio
tangent

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 270 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::tangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailTangent
ratio
tangent

◆ tangent

svxPntOnEntPath svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::tangent

select the tangent curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 269 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailTangentEdges
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges Struct Reference

Data Fields

double ratio
conic ratio More...

Detailed Description

Definition at line 282 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailTangentEdges
ratio

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 284 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailVariable
Data Fields
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable Struct Reference

Data Fields

int | nRadSet
the count of list More...
svxRadiusSetData * pRadSet
store spines list with different radius More...
double | ratio
conic ratio More...
int | solution
multiple solutions will be displayed More...

Detailed Description

Definition at line 255 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::solution

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailVariable
nRadSet
pRadSet
ratio
solution

◆ solution

int svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::solution

multiple solutions will be displayed

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 260 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::nRadSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailVariable
nRadSet
pRadSet
ratio
solution

◆ nRadSet

int svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::nRadSet

the count of list

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 257 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::pRadSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailVariable
nRadSet
pRadSet
ratio
solution

◆ pRadSet

svxRadiusSetData* svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::pRadSet

store spines list with different radius

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 258 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
  • ConicBiRailVariable
nRadSet
pRadSet
ratio
solution

◆ ratio

double svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::ratio

conic ratio

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 259 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::spineCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
firstCrv
method
secondCrv
spineCrv

◆ spineCrv

svxPntOnEntPath svxConicBiRailData::spineCrv

select the spine curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 246 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
firstCrv
method
secondCrv
spineCrv

◆ method

evxConicBiRailMethod svxConicBiRailData::method

method to create a new conic face (VX_CONICBIRAIL_CONSTANT as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 243 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::secondCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
firstCrv
method
secondCrv
spineCrv

◆ secondCrv

svxPntOnEntPath svxConicBiRailData::secondCrv

select the second path curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 245 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::firstCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
firstCrv
method
secondCrv
spineCrv

◆ firstCrv

svxPntOnEntPath svxConicBiRailData::firstCrv

select the first path curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 244 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxConsData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly common constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | useRange
whether to apply constraint range (0-default) More...
double | value
exact value: offset distance or constraint angle (0.0-default) More...
svxLimit range
constraint range: offset distance or constraint angle More...
int | sameDir
same direction (0-default) More...
int | posOnly
only move position without creating constraint (0-default) More...
int | lockRotation
whether to lock rotation (0-default) More...

Detailed Description

custom data for assembly common constraint

Examples
part\asmConsTest.cpp.

Definition at line 220 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::useRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ useRange

int svxConsData::useRange

whether to apply constraint range (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 222 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::sameDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ sameDir

int svxConsData::sameDir

same direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 225 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::range

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ range

svxLimit svxConsData::range

constraint range: offset distance or constraint angle

Examples
part\asmConsTest.cpp.

Definition at line 224 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ value

double svxConsData::value

exact value: offset distance or constraint angle (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 223 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::posOnly

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ posOnly

int svxConsData::posOnly

only move position without creating constraint (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 226 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsData::lockRotation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsData
lockRotation
posOnly
range
sameDir
useRange
value

◆ lockRotation

int svxConsData::lockRotation

whether to lock rotation (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 227 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxConsDim Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of constraint dimension More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint firstPnt
first point More...
svxPoint secondPnt
second point, NULL if it doesn't need More...
svxPoint textPnt
text point More...
int | type
sub type of dimension
linear dimension: 1 = horizontal method, 2 = vertical method, 3 = aligned method
linear offset dimension: 1 = offset method, 2 = projected distance method
angular dimension: 1 = 2 curve method, 2 = horizontal method, 3 = vertical method, 4 = arc method
radial dimension: 1 = radial method, 2 = diameter method
arc length dimension: the value can be ignored More...
int | firstEnt
entity id which the first point on it, NULL if it doesn't need More...
int | secondEnt
entity id which the second point on it, NULL if it doesn't need More...

Detailed Description

data of constraint dimension

Definition at line 583 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::firstEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ firstEnt

int svxConsDim::firstEnt

entity id which the first point on it, NULL if it doesn't need

Definition at line 594 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ firstPnt

svxPoint svxConsDim::firstPnt

first point

Definition at line 585 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ type

int svxConsDim::type

sub type of dimension
linear dimension: 1 = horizontal method, 2 = vertical method, 3 = aligned method
linear offset dimension: 1 = offset method, 2 = projected distance method
angular dimension: 1 = 2 curve method, 2 = horizontal method, 3 = vertical method, 4 = arc method
radial dimension: 1 = radial method, 2 = diameter method
arc length dimension: the value can be ignored

Definition at line 588 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::secondEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ secondEnt

int svxConsDim::secondEnt

entity id which the second point on it, NULL if it doesn't need

Definition at line 595 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ secondPnt

svxPoint svxConsDim::secondPnt

second point, NULL if it doesn't need

Definition at line 586 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsDim::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsDim
firstEnt
firstPnt
secondEnt
secondPnt
textPnt
type

◆ textPnt

svxPoint svxConsDim::textPnt

text point

Definition at line 587 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxConsGeom Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of sketch geometry constraint object More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | isAxis
whether to use axis, 1 to use axis; 0 to use entity or point More...
svxPoint2 axis
specify axis, only X(1,0) and Y(0,1) axis of sketch are supported More...
int | idEntity
index of entity More...
evxGeomCritPnt critPnt
critical point, if you want to set an entity such as line rather than a critical point on the entity, set the variable to VX_NO_POINT More...
int | idPoint
used to indicate the control point of the spline (starting from 0) only used when pntType is VX_SPLINE_DEFINING_POINT More...

Detailed Description

data of sketch geometry constraint object

Definition at line 503 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom::idPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsGeom
axis
critPnt
idEntity
idPoint
isAxis

◆ idPoint

int svxConsGeom::idPoint

used to indicate the control point of the spline (starting from 0) only used when pntType is VX_SPLINE_DEFINING_POINT

Definition at line 510 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom::critPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsGeom
axis
critPnt
idEntity
idPoint
isAxis

◆ critPnt

evxGeomCritPnt svxConsGeom::critPnt

critical point, if you want to set an entity such as line rather than a critical point on the entity, set the variable to VX_NO_POINT

Definition at line 508 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom::idEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsGeom
axis
critPnt
idEntity
idPoint
isAxis

◆ idEntity

int svxConsGeom::idEntity

index of entity

Definition at line 507 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom::isAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsGeom
axis
critPnt
idEntity
idPoint
isAxis

◆ isAxis

int svxConsGeom::isAxis

whether to use axis, 1 to use axis; 0 to use entity or point

Definition at line 505 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConsGeom::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConsGeom
axis
critPnt
idEntity
idPoint
isAxis

◆ axis

svxPoint2 svxConsGeom::axis

specify axis, only X(1,0) and Y(0,1) axis of sketch are supported

Definition at line 506 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxControlPoints Struct Reference
Common » Common Data

curve control point data More...

#include <zwapi_util.h>

Data Fields

int | rat
1=RATIONAL, 0=NONRATIONAL control points
More...
int | dim
number of coordinates per control point (1-4) More...
int | plane
cp hyper plane type: 1:pnt, 2:line, 3:plane
More...
int | num_cp
number of control points in list More...
svxBndBox box
bounding box of control points More...
double * | coord
control point coordinates (possibly weighted) More...
int | free_mem
1 if memory referenced by "coord" should be free'd by cvxCurveFree() More...

Detailed Description

curve control point data

Definition at line 1626 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::coord

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ coord

double* svxControlPoints::coord

control point coordinates (possibly weighted)

if RATIONAL, points are of form (wx,wy,wz,w)

Definition at line 1633 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::dim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ dim

int svxControlPoints::dim

number of coordinates per control point (1-4)

Definition at line 1629 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::free_mem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ free_mem

int svxControlPoints::free_mem

1 if memory referenced by "coord" should be free'd by cvxCurveFree()

Definition at line 1635 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::plane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ plane

int svxControlPoints::plane

cp hyper plane type: 1:pnt, 2:line, 3:plane

Definition at line 1630 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::rat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ rat

int svxControlPoints::rat

1=RATIONAL, 0=NONRATIONAL control points

Definition at line 1628 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::num_cp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ num_cp

int svxControlPoints::num_cp

number of control points in list

Definition at line 1631 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxControlPoints::box

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxControlPoints
box
coord
dim
free_mem
num_cp
plane
rat

◆ box

svxBndBox svxControlPoints::box

bounding box of control points

Definition at line 1632 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCopyData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

template command Copy data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

union evxMethodUnion
union of copy data More...

Data Fields

evxMoveType method
copy methods More...
int | cntEnt
entity count More...
int * | pEnts
entities ID More...
union svxCopyData::evxMethodUnion | MethodUnion
int | CpyNum
copy number (just method = VX_ALONG_DIR or VX_AROUND_DIR, and must initialize to 1) More...
int | isNonAssoCopy
0-associative copy, 1-non associative copy(default 0) if set to 0, the duplicate will be associative with the original entities, else(set to 1) the duplicate and the original entities will be independent of each other More...
vxName layName
layer to copy if isNonAssoCopy is 1 More...

Detailed Description

template command Copy data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1597 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::CpyNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ CpyNum

int svxCopyData::CpyNum

copy number (just method = VX_ALONG_DIR or VX_AROUND_DIR, and must initialize to 1)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1611 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ pEnts

int* svxCopyData::pEnts

entities ID

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1601 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::layName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ layName

vxName svxCopyData::layName

layer to copy if isNonAssoCopy is 1

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1615 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ cntEnt

int svxCopyData::cntEnt

entity count

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1600 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::isNonAssoCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ isNonAssoCopy

int svxCopyData::isNonAssoCopy

0-associative copy, 1-non associative copy(default 0) if set to 0, the duplicate will be associative with the original entities, else(set to 1) the duplicate and the original entities will be independent of each other

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1612 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
cntEnt
CpyNum
isNonAssoCopy
layName
method
pEnts

◆ method

evxMoveType svxCopyData::method

copy methods

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1599 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCrvBlendCons Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve blend constraints More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union uvxCrvBlendCons

Data Fields

evxContinuityTyp continuity
continuity method used for refitting and blending the curves, VX_CONTIN_G1 as default More...
int | tangentDirFlip
1 to flip tangent direction, else 0 More...
double | weight
the weight factor, between 0.10 and 5.00 More...
union svxCrvBlendCons::uvxCrvBlendCons | inpUion

Detailed Description

curve blend constraints

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 400 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendCrv
Data Fields
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv Struct Reference

Data Fields

evxCrvBlendPosType pos
define specific location to blend, VX_CURVE_BLEND_POS_THROUGH_POINT as default More...
int | keepside
0-long, 1-short More...
double | value
arc length for VX_CURVE_BLEND_POS_ARC_LENGTH, or percentage of arc length for VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH More...
svxPntOnEntPath throughPnt
pick a point on curve as the blend location, for VX_CURVE_BLEND_POS_THROUGH_POINT More...

Detailed Description

Definition at line 407 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendCrv
keepside
pos
throughPnt
value

◆ value

double svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::value

arc length for VX_CURVE_BLEND_POS_ARC_LENGTH, or percentage of arc length for VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH

Definition at line 411 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::keepside

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendCrv
keepside
pos
throughPnt
value

◆ keepside

int svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::keepside

0-long, 1-short

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 410 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::pos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendCrv
keepside
pos
throughPnt
value

◆ pos

evxCrvBlendPosType svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::pos

define specific location to blend, VX_CURVE_BLEND_POS_THROUGH_POINT as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 409 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::throughPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendCrv
keepside
pos
throughPnt
value

◆ throughPnt

svxPntOnEntPath svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::throughPnt

pick a point on curve as the blend location, for VX_CURVE_BLEND_POS_THROUGH_POINT

Definition at line 413 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendFace
Data Fields
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace Struct Reference

Data Fields

evxCrvBlendDirType blendDir
define specific location to blend. VX_CURVE_BLEND_DIR_ISO_U as default More...
double value
percentage or angle More...

Detailed Description

Definition at line 415 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::blendDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendFace
blendDir
value

◆ blendDir

evxCrvBlendDirType svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::blendDir

define specific location to blend. VX_CURVE_BLEND_DIR_ISO_U as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 417 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
  • svxCrvBlendFace
blendDir
value

◆ value

double svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::value

percentage or angle

Definition at line 418 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::weight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
continuity
tangentDirFlip
weight

◆ weight

double svxCrvBlendCons::weight

the weight factor, between 0.10 and 5.00

Definition at line 404 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::tangentDirFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
continuity
tangentDirFlip
weight

◆ tangentDirFlip

int svxCrvBlendCons::tangentDirFlip

1 to flip tangent direction, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 403 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::continuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
continuity
tangentDirFlip
weight

◆ continuity

evxContinuityTyp svxCrvBlendCons::continuity

continuity method used for refitting and blending the curves, VX_CONTIN_G1 as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 402 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvBlendData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve blend data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxCrvBlendObjType startObjType
start object type, VX_CURVE_BLEND_CURVE as default More...
svxPntOnEntPath startObj
start object More...
int | startObjFlip
1 to flip start object position, else 0 More...
evxCrvBlendObjType endObjType
end object type, VX_CURVE_BLEND_CURVE as default More...
svxPntOnEntPath endObj
end object More...
int | endObjFlip
1 to flip end object position, else 0 More...
evxCrvBlendTrimType trim
trim type, VX_CURVE_BLEND_TRIM_BOTH as default More...
int | curvature
1 to display curvature, else 0 More...
int | endpointPick
1 to pick endpoint by default, else 0. 1 as default More...
svxCrvBlendCons * startCons
start constraints (NULL to ignore) More...
svxCrvBlendCons * endCons
end constraints (NULL to ignore) More...

Detailed Description

curve blend data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 437 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::curvature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ curvature

int svxCrvBlendData::curvature

1 to display curvature, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 447 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::endObjFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ endObjFlip

int svxCrvBlendData::endObjFlip

1 to flip end object position, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 444 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::endObjType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ endObjType

evxCrvBlendObjType svxCrvBlendData::endObjType

end object type, VX_CURVE_BLEND_CURVE as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 442 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::endObj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ endObj

svxPntOnEntPath svxCrvBlendData::endObj

end object

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 443 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::trim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ trim

evxCrvBlendTrimType svxCrvBlendData::trim

trim type, VX_CURVE_BLEND_TRIM_BOTH as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 446 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::endpointPick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ endpointPick

int svxCrvBlendData::endpointPick

1 to pick endpoint by default, else 0. 1 as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 448 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::startObj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ startObj

svxPntOnEntPath svxCrvBlendData::startObj

start object

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 440 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::endCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ endCons

svxCrvBlendCons* svxCrvBlendData::endCons

end constraints (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 451 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::startObjType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ startObjType

evxCrvBlendObjType svxCrvBlendData::startObjType

start object type, VX_CURVE_BLEND_CURVE as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 439 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::startObjFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ startObjFlip

int svxCrvBlendData::startObjFlip

1 to flip start object position, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 441 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendData::startCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendData
curvature
endCons
endObj
endObjFlip
endObjType
endpointPick
startCons
startObj
startObjFlip
startObjType
trim

◆ startCons

svxCrvBlendCons* svxCrvBlendData::startCons

start constraints (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 450 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferChainData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvChamferChainData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

chamfer chain data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | cnt
number of edges/curves to chamfer More...
int * | curves
I: pointer to list of edge/curve id's. More...
double | setback
setback (mm) More...
int | trimOriginal
1 to trim original curves, else 0. 1 as default More...

Detailed Description

chamfer chain data

Definition at line 573 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferChainData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferChainData
cnt
curves
setback
trimOriginal

◆ cnt

int svxCrvChamferChainData::cnt

number of edges/curves to chamfer

Definition at line 575 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferChainData::curves

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferChainData
cnt
curves
setback
trimOriginal

◆ curves

int* svxCrvChamferChainData::curves

I: pointer to list of edge/curve id's.

Definition at line 576 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferChainData::trimOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferChainData
cnt
curves
setback
trimOriginal

◆ trimOriginal

int svxCrvChamferChainData::trimOriginal

1 to trim original curves, else 0. 1 as default

Definition at line 578 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferChainData::setback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferChainData
cnt
curves
setback
trimOriginal

◆ setback

double svxCrvChamferChainData::setback

setback (mm)

Definition at line 577 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCrvChamferData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve chamfer data More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union evxCrvChamferInpUnion

Data Fields

evxCrvChamferMethods method
method to create a chamfer (VX_CRV_CHAMFER_SETBACK as default) More...
svxPntOnEntPath firstPnt
the first curve to chamfer More...
svxPntOnEntPath secondPnt
the second curve to chamfer More...
union svxCrvChamferData::evxCrvChamferInpUnion inpUnion
evxCrvTrimType trimType
trim type (VX_CRV_TRIM_BOTH as default) More...
evxExtendOpt extensionType
extension type (VX_EXTEND_CIRCULAR as default) More...

Detailed Description

curve chamfer data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 544 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferSetbackAndAngle
Data Fields
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle Struct Reference

Data Fields

double | setback
the first setback More...
double | angle
angle of the first curve More...

Detailed Description

Definition at line 559 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferSetbackAndAngle
angle
setback

◆ angle

double svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::angle

angle of the first curve

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 562 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::setback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferSetbackAndAngle
angle
setback

◆ setback

double svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::setback

the first setback

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 561 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferTwoSetbacks
Data Fields
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks Struct Reference

Data Fields

double | firstSetback
the first setback More...
double | secondSetback
the second setback More...

Detailed Description

Definition at line 553 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::firstSetback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferTwoSetbacks
firstSetback
secondSetback

◆ firstSetback

double svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::firstSetback

the first setback

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 555 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::secondSetback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
  • CrvChamferTwoSetbacks
firstSetback
secondSetback

◆ secondSetback

double svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::secondSetback

the second setback

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 556 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::trimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
extensionType
firstPnt
method
secondPnt
trimType

◆ trimType

evxCrvTrimType svxCrvChamferData::trimType

trim type (VX_CRV_TRIM_BOTH as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 565 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
extensionType
firstPnt
method
secondPnt
trimType

◆ method

evxCrvChamferMethods svxCrvChamferData::method

method to create a chamfer (VX_CRV_CHAMFER_SETBACK as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 546 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::extensionType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
extensionType
firstPnt
method
secondPnt
trimType

◆ extensionType

evxExtendOpt svxCrvChamferData::extensionType

extension type (VX_EXTEND_CIRCULAR as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 566 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
extensionType
firstPnt
method
secondPnt
trimType

◆ firstPnt

svxPntOnEntPath svxCrvChamferData::firstPnt

the first curve to chamfer

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 547 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
extensionType
firstPnt
method
secondPnt
trimType

◆ secondPnt

svxPntOnEntPath svxCrvChamferData::secondPnt

the second curve to chamfer

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 548 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvCombinedProjData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvCombinedProjData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

combined projection data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | firstCrv
the first curve to project More...
svxVector firstDir
the projection direction for the 1st curve More...
int | secondCrv
the second curve to project More...
svxVector secondDir
the projection direction for the 2nd curve More...

Detailed Description

combined projection data

Definition at line 355 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvCombinedProjData::firstDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvCombinedProjData
firstCrv
firstDir
secondCrv
secondDir

◆ firstDir

svxVector svxCrvCombinedProjData::firstDir

the projection direction for the 1st curve

Definition at line 358 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvCombinedProjData::firstCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvCombinedProjData
firstCrv
firstDir
secondCrv
secondDir

◆ firstCrv

int svxCrvCombinedProjData::firstCrv

the first curve to project

Definition at line 357 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvCombinedProjData::secondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvCombinedProjData
firstCrv
firstDir
secondCrv
secondDir

◆ secondDir

svxVector svxCrvCombinedProjData::secondDir

the projection direction for the 2nd curve

Definition at line 360 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvCombinedProjData::secondCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvCombinedProjData
firstCrv
firstDir
secondCrv
secondDir

◆ secondCrv

int svxCrvCombinedProjData::secondCrv

the second curve to project

Definition at line 359 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvContinuityData Struct Reference
Common » Common Data

data of curve continuity. More...

#include <zwapi_util.h>

Data Fields

int | idCrv1
id of curve1 More...
int | idCrv2
id of curve2 More...
double | position
Check this option to inquire the continuity of G0 position between the picked curves. More...
int | isPositionContinuous
1 is continuous position, else 0. More...
double | tangent
Check this option to inquire the continuity of G1 tangent between the picked curves. More...
int | isTangentContinuous
1 is continuous tangent, else 0. More...
double | curvature
Check this option to inquire the continuity of G2 curvature between the picked curves. More...
int | isCurvatureContinuous
1 is continuous curvature, else 0. More...
double | flow
Check this option to inquire the continuity of G3 flow between the picked curves. More...
int | isFlowContinuous
1 is continuous flow, else 0. More...

Detailed Description

data of curve continuity.

Definition at line 1644 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::tangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ tangent

double svxCrvContinuityData::tangent

Check this option to inquire the continuity of G1 tangent between the picked curves.

Definition at line 1650 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::idCrv1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ idCrv1

int svxCrvContinuityData::idCrv1

id of curve1

Definition at line 1646 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::flow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ flow

double svxCrvContinuityData::flow

Check this option to inquire the continuity of G3 flow between the picked curves.

Definition at line 1654 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::isFlowContinuous

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ isFlowContinuous

int svxCrvContinuityData::isFlowContinuous

1 is continuous flow, else 0.

Definition at line 1655 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::isTangentContinuous

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ isTangentContinuous

int svxCrvContinuityData::isTangentContinuous

1 is continuous tangent, else 0.

Definition at line 1651 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::curvature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ curvature

double svxCrvContinuityData::curvature

Check this option to inquire the continuity of G2 curvature between the picked curves.

Definition at line 1652 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::idCrv2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ idCrv2

int svxCrvContinuityData::idCrv2

id of curve2

Definition at line 1647 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ position

double svxCrvContinuityData::position

Check this option to inquire the continuity of G0 position between the picked curves.

Definition at line 1648 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::isCurvatureContinuous

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ isCurvatureContinuous

int svxCrvContinuityData::isCurvatureContinuous

1 is continuous curvature, else 0.

Definition at line 1653 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityData::isPositionContinuous

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityData
curvature
flow
idCrv1
idCrv2
isCurvatureContinuous
isFlowContinuous
isPositionContinuous
isTangentContinuous
position
tangent

◆ isPositionContinuous

int svxCrvContinuityData::isPositionContinuous

1 is continuous position, else 0.

Definition at line 1649 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityTolList Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvContinuityTolList Struct Reference
Common » Common Data

curve continuity tolerance list More...

#include <zwapi_util.h>

Data Fields

double | tolPosition
tolerance of position.default:0.01 Judge whether the two curves are G0 continuous tolerance.(in millimeters). More...
double | tolTangent
tolerance of tangent.default:0.5 Judge whether the two curves are G2 continuous tolerance.(degrees). More...
double | tolCurvature
tolerance of curvature.default:0.05 Judge whether the two curves are G2 continuous tolerance. More...
double | tolFlow
tolerance of flew.default:0.05 Judge whether the two curves are G3 continuous tolerance. More...

Detailed Description

curve continuity tolerance list

Definition at line 1662 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityTolList::tolTangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityTolList
tolCurvature
tolFlow
tolPosition
tolTangent

◆ tolTangent

double svxCrvContinuityTolList::tolTangent

tolerance of tangent.default:0.5 Judge whether the two curves are G2 continuous tolerance.(degrees).

Definition at line 1666 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityTolList::tolFlow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityTolList
tolCurvature
tolFlow
tolPosition
tolTangent

◆ tolFlow

double svxCrvContinuityTolList::tolFlow

tolerance of flew.default:0.05 Judge whether the two curves are G3 continuous tolerance.

Definition at line 1670 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityTolList::tolPosition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityTolList
tolCurvature
tolFlow
tolPosition
tolTangent

◆ tolPosition

double svxCrvContinuityTolList::tolPosition

tolerance of position.default:0.01 Judge whether the two curves are G0 continuous tolerance.(in millimeters).

Definition at line 1664 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvContinuityTolList::tolCurvature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvContinuityTolList
tolCurvature
tolFlow
tolPosition
tolTangent

◆ tolCurvature

double svxCrvContinuityTolList::tolCurvature

tolerance of curvature.default:0.05 Judge whether the two curves are G2 continuous tolerance.

Definition at line 1668 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvConvertTocData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvConvertTocData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

create arc and line segments from existing curves data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | cntCrvs
count of curves to convert More...
int * | idCrvs
id of curves to convert More...
double | tolerance
allowable tolerance for the conversion (0.5 as default) More...
int | keep
1 to keep original curves, else 0 (0 as default) More...

Detailed Description

create arc and line segments from existing curves data

Definition at line 628 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvConvertTocData::cntCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvConvertTocData
cntCrvs
idCrvs
keep
tolerance

◆ cntCrvs

int svxCrvConvertTocData::cntCrvs

count of curves to convert

Definition at line 630 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvConvertTocData::tolerance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvConvertTocData
cntCrvs
idCrvs
keep
tolerance

◆ tolerance

double svxCrvConvertTocData::tolerance

allowable tolerance for the conversion (0.5 as default)

Definition at line 632 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvConvertTocData::idCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvConvertTocData
cntCrvs
idCrvs
keep
tolerance

◆ idCrvs

int* svxCrvConvertTocData::idCrvs

id of curves to convert

Definition at line 631 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvConvertTocData::keep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvConvertTocData
cntCrvs
idCrvs
keep
tolerance

◆ keep

int svxCrvConvertTocData::keep

1 to keep original curves, else 0 (0 as default)

Definition at line 633 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvFilletChainData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve fillet chain data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | count
count of curves More...
int * | curves
list ids of curves More...
double | radius
radius to fillet More...
int | designerArc
whether to use designer arc (0 as default) More...
int | trimOriginal
whether to trim original curves (1 as default) More...

Detailed Description

curve fillet chain data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 520 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData::curves

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletChainData
count
curves
designerArc
radius
trimOriginal

◆ curves

int* svxCrvFilletChainData::curves

list ids of curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 523 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletChainData
count
curves
designerArc
radius
trimOriginal

◆ count

int svxCrvFilletChainData::count

count of curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 522 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData::trimOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletChainData
count
curves
designerArc
radius
trimOriginal

◆ trimOriginal

int svxCrvFilletChainData::trimOriginal

whether to trim original curves (1 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 526 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData::designerArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletChainData
count
curves
designerArc
radius
trimOriginal

◆ designerArc

int svxCrvFilletChainData::designerArc

whether to use designer arc (0 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 525 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletChainData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletChainData
count
curves
designerArc
radius
trimOriginal

◆ radius

double svxCrvFilletChainData::radius

radius to fillet

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 524 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxCrvFilletData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve fillet data More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union evxCrvFilletInpUnion

Data Fields

evxCrvFilletMethods method
method to create a fillet (VX_CRV_FILLET_RADIUS as default) More...
svxPntOnEntPath firstPnt
the first curve to fillet More...
svxPntOnEntPath secondPnt
the second curve to fillet More...
union svxCrvFilletData::evxCrvFilletInpUnion | inpUnion
evxCrvTrimType trimType
curve trim type (VX_CRV_TRIM_BOTH as default) More...
evxExtendOpt extensionType
extension type (VX_EXTEND_LINEAR as default) More...
int | designerArc
whether to use designer arc (0 as default) More...

Detailed Description

curve fillet data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 501 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ firstPnt

svxPntOnEntPath svxCrvFilletData::firstPnt

the first curve to fillet

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 504 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ method

evxCrvFilletMethods svxCrvFilletData::method

method to create a fillet (VX_CRV_FILLET_RADIUS as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 503 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::designerArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ designerArc

int svxCrvFilletData::designerArc

whether to use designer arc (0 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 513 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::extensionType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ extensionType

evxExtendOpt svxCrvFilletData::extensionType

extension type (VX_EXTEND_LINEAR as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 512 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ secondPnt

svxPntOnEntPath svxCrvFilletData::secondPnt

the second curve to fillet

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 505 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::trimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
designerArc
extensionType
firstPnt
method
secondPnt
trimType

◆ trimType

evxCrvTrimType svxCrvFilletData::trimType

curve trim type (VX_CRV_TRIM_BOTH as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 511 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvIntData Struct Reference
Common » Common Data

2D/3D interpolated curve More...

#include <zwapi_util.h>

Data Fields

int | isClosed
1 if curve is closed, 0 if open More...
int | Degree
curve degree (2 - 6) More...
int | Count
number of points to interpolate More...
svxPoint * Points
pointer to list of points to interpolate More...
int | UseStartTan
1 to use start tangent direction, else 0 More...
svxVector StartTan
normalized start tangent direction vector More...
double | StartScale
start tangent scale factor (0.1 - 10.0, 1.0 as default) More...
int | UseEndTan
1 to use start tangent direction, else 0 More...
svxVector EndTan
normalized end tangent direction vector More...
double | EndScale
end tangent scale factor (0.1 - 10.0, 1.0 as default) More...
int | Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension) More...

Detailed Description

2D/3D interpolated curve

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2328 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::UseEndTan

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ UseEndTan

int svxCrvIntData::UseEndTan

1 to use start tangent direction, else 0

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2342 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::EndScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ EndScale

double svxCrvIntData::EndScale

end tangent scale factor (0.1 - 10.0, 1.0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2344 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ Points

svxPoint* svxCrvIntData::Points

pointer to list of points to interpolate

(set Z coordinate to zero for 2D curves)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2334 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::StartTan

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ StartTan

svxVector svxCrvIntData::StartTan

normalized start tangent direction vector

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2339 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::isClosed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ isClosed

int svxCrvIntData::isClosed

1 if curve is closed, 0 if open

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2331 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ Count

int svxCrvIntData::Count

number of points to interpolate

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2333 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::UseStartTan

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ UseStartTan

int svxCrvIntData::UseStartTan

1 to use start tangent direction, else 0

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2338 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::Degree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ Degree

int svxCrvIntData::Degree

curve degree (2 - 6)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2332 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::StartScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ StartScale

double svxCrvIntData::StartScale

start tangent scale factor (0.1 - 10.0, 1.0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2340 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::EndTan

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ EndTan

svxVector svxCrvIntData::EndTan

normalized end tangent direction vector

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2343 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvIntData::Fairing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvIntData
Count
Degree
EndScale
EndTan
Fairing
isClosed
Points
StartScale
StartTan
UseEndTan
UseStartTan

◆ Fairing

int svxCrvIntData::Fairing

fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2346 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvOnFaceThuPts Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve on face through points data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | face
face to create the curve on More...
int | cntPts
number of points More...
svxPoint * pts
points on the face for the curve to pass through More...
int | isOpen
whether to create open curve, 1 as default More...
evxFairingType fairing
fairing mode, VX_FAIRING_NONE as default More...
svxCrvOnFaceThuPtsCons * startCons
start constraints (NULL to ignore) More...
svxCrvOnFaceThuPtsCons * endCons
end constraints (NULL to ignore) More...

Detailed Description

curve on face through points data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 220 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::face

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ face

int svxCrvOnFaceThuPts::face

face to create the curve on

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 222 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::fairing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ fairing

evxFairingType svxCrvOnFaceThuPts::fairing

fairing mode, VX_FAIRING_NONE as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 226 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::pts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ pts

svxPoint* svxCrvOnFaceThuPts::pts

points on the face for the curve to pass through

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 224 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::endCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ endCons

svxCrvOnFaceThuPtsCons* svxCrvOnFaceThuPts::endCons

end constraints (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 228 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::cntPts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ cntPts

int svxCrvOnFaceThuPts::cntPts

number of points

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 223 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::isOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ isOpen

int svxCrvOnFaceThuPts::isOpen

whether to create open curve, 1 as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 225 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPts::startCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPts
cntPts
endCons
face
fairing
isOpen
pts
startCons

◆ startCons

svxCrvOnFaceThuPtsCons* svxCrvOnFaceThuPts::startCons

start constraints (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 227 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPtsCons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvOnFaceThuPtsCons Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

curve on face through points constraint More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxContinuityTyp continuity
continuity method used for creating curves, between VX_CONTIN_NONE and VX_CONTIN_G2 (VX_CONTIN_NONE as default) More...
svxVector tan
tangent direction for the start or end of the curve More...
int | flip
whether to reverse the tangent direction More...
double | weight
tangent weight if an tangent direction is specified, between 0.1 and 10 More...

Detailed Description

curve on face through points constraint

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 207 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPtsCons::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPtsCons
continuity
flip
tan
weight

◆ flip

int svxCrvOnFaceThuPtsCons::flip

whether to reverse the tangent direction

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 212 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPtsCons::continuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPtsCons
continuity
flip
tan
weight

◆ continuity

evxContinuityTyp svxCrvOnFaceThuPtsCons::continuity

continuity method used for creating curves, between VX_CONTIN_NONE and VX_CONTIN_G2 (VX_CONTIN_NONE as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 209 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPtsCons::weight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPtsCons
continuity
flip
tan
weight

◆ weight

double svxCrvOnFaceThuPtsCons::weight

tangent weight if an tangent direction is specified, between 0.1 and 10

Definition at line 213 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvOnFaceThuPtsCons::tan

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvOnFaceThuPtsCons
continuity
flip
tan
weight

◆ tan

svxVector svxCrvOnFaceThuPtsCons::tan

tangent direction for the start or end of the curve

Definition at line 211 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvProjToFace Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

project to face data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | cntCrvs
count of curves More...
int * | pCrvs
a sketch or curves More...
int | cntFaces
count of faces More...
int * | pFaces
faces or datum planes to project curves onto More...
svxVector * pDir
By default, the projection direction is normal to the surface. Use this option to define a different direction to project onto the surface. (NULL to ignore) More...
int | biDir
Use this option to project the curves in both the positive and the negative directions relative to the direction of projection. More...
int | trim
Use this option to project only to the trim boundaries of a face. If you are projecting onto a trimmed face, set it to 0 will produce a curve that extends to the entire untrimmed boundary of the face, else set it to 1 (1 as default) More...

Detailed Description

project to face data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 173 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::trim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ trim

int svxCrvProjToFace::trim

Use this option to project only to the trim boundaries of a face. If you are projecting onto a trimmed face, set it to 0 will produce a curve that extends to the entire untrimmed boundary of the face, else set it to 1 (1 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 184 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::biDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ biDir

int svxCrvProjToFace::biDir

Use this option to project the curves in both the positive and the negative directions relative to the direction of projection.

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 182 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::pCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ pCrvs

int* svxCrvProjToFace::pCrvs

a sketch or curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 176 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::pFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ pFaces

int* svxCrvProjToFace::pFaces

faces or datum planes to project curves onto

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 178 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::pDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ pDir

svxVector* svxCrvProjToFace::pDir

By default, the projection direction is normal to the surface. Use this option to define a different direction to project onto the surface. (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 179 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::cntFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ cntFaces

int svxCrvProjToFace::cntFaces

count of faces

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 177 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvProjToFace::cntCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvProjToFace
biDir
cntCrvs
cntFaces
pCrvs
pDir
pFaces
trim

◆ cntCrvs

int svxCrvProjToFace::cntCrvs

count of curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 175 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCrvTrimToFacesData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

trim to faces data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | cntCrvs
count of curves or sketches to trim More...
int * | pCrvs
index of curves or sketches to trim More...
int | cntFaces
count of the trimming faces or shapes More...
int * | pFaces
index of the trimming faces or shapes More...
int | flip
1 to flip the arrows to keep the opposite side, else 0 More...

Detailed Description

trim to faces data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 615 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData::cntFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvTrimToFacesData
cntCrvs
cntFaces
flip
pCrvs
pFaces

◆ cntFaces

int svxCrvTrimToFacesData::cntFaces

count of the trimming faces or shapes

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 619 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData::pFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvTrimToFacesData
cntCrvs
cntFaces
flip
pCrvs
pFaces

◆ pFaces

int* svxCrvTrimToFacesData::pFaces

index of the trimming faces or shapes

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 620 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData::cntCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvTrimToFacesData
cntCrvs
cntFaces
flip
pCrvs
pFaces

◆ cntCrvs

int svxCrvTrimToFacesData::cntCrvs

count of curves or sketches to trim

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 617 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData::pCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvTrimToFacesData
cntCrvs
cntFaces
flip
pCrvs
pFaces

◆ pCrvs

int* svxCrvTrimToFacesData::pCrvs

index of curves or sketches to trim

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 618 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvTrimToFacesData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvTrimToFacesData
cntCrvs
cntFaces
flip
pCrvs
pFaces

◆ flip

int svxCrvTrimToFacesData::flip

1 to flip the arrows to keep the opposite side, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 621 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCurve Struct Reference
Common » Common Data

2D or 3D curvilinear geometry More...

#include <zwapi_util.h>

Data Fields

evxCurveType Type
curve type More...
svxMatrix Frame
local frame (origin is center of 3D circle/arc) More...
svxPoint P1
svxPoint P2
line start/end points or center of 2D circle/arc More...
double | A1
double | A2
arc start/end angles (degrees) More...
double | R
circle/arc radius More...
svxParameters T
NURB parameter space data. More...
svxControlPoints P
NURB control point data (mm) More...

Detailed Description

2D or 3D curvilinear geometry

Examples
part\shapeFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 1678 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::A2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ A2

double svxCurve::A2

arc start/end angles (degrees)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1684 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::A1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ A1

double svxCurve::A1
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1684 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::P1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ P1

svxPoint svxCurve::P1
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1683 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ Type

evxCurveType svxCurve::Type

curve type

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1680 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::P2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ P2

svxPoint svxCurve::P2

line start/end points or center of 2D circle/arc

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1683 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::T

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ T

svxParameters svxCurve::T

NURB parameter space data.

Definition at line 1687 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ R

double svxCurve::R

circle/arc radius

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1685 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::P

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ P

svxControlPoints svxCurve::P

NURB control point data (mm)

Definition at line 1688 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCurve::Frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCurve
A2
Frame
P
P2
R
T
Type

◆ Frame

svxMatrix svxCurve::Frame

local frame (origin is center of 3D circle/arc)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 1681 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCylData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

cylinder More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
int | idPlane
optional datum plane (0 to use XY plane) More...
int | useAxis
flag to use axis, 0 default More...
svxAxis axis
optional axis More...
svxPoint Center
center of bottom face More...
double | Radius
radius (mm) in XY plane More...
double | Length
length (mm) along Z More...
vxName ftrName
feature name for "FtAllCyl", 0 default More...

Detailed Description

cylinder

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 62 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ Combine

evxBoolType svxCylData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 64 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ idPlane

int svxCylData::idPlane

optional datum plane (0 to use XY plane)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 65 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ ftrName

vxName svxCylData::ftrName

feature name for "FtAllCyl", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 71 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::Radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ Radius

double svxCylData::Radius

radius (mm) in XY plane

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 69 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::Length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ Length

double svxCylData::Length

length (mm) along Z

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 70 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ Center

svxPoint svxCylData::Center

center of bottom face

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 68 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ axis

svxAxis svxCylData::axis

optional axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 67 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylData::useAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylData
axis
Center
Combine
ftrName
idPlane
Length
Radius
useAxis

◆ useAxis

int svxCylData::useAxis

flag to use axis, 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 66 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylinder Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxCylinder Struct Reference
Common » Common Data

cylindrical surface data More...

#include <zwapi_util.h>

Data Fields

double | radius
radius More...
double | length
length More...
svxMatrix form
cylinder centered about xform
origin is at low parameter value
z-axis points from low parameter to high parameter.
x-axis point to seam More...
int | lindir
= 1 : u defines the linear direction.
= 2 : v defines the linear direction. More...

Detailed Description

cylindrical surface data

Definition at line 1809 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylinder::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylinder
form
length
lindir
radius

◆ length

double svxCylinder::length

length

Definition at line 1812 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylinder::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylinder
form
length
lindir
radius

◆ radius

double svxCylinder::radius

radius

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1811 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylinder::lindir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylinder
form
length
lindir
radius

◆ lindir

int svxCylinder::lindir

= 1 : u defines the linear direction.
= 2 : v defines the linear direction.

Definition at line 1818 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxCylinder::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCylinder
form
length
lindir
radius

◆ form

svxMatrix svxCylinder::form

cylinder centered about xform
origin is at low parameter value
z-axis points from low parameter to high parameter.
x-axis point to seam

Definition at line 1813 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEAlignMove Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) align move data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

evxDEAlignMoveType type
DE(Direct Edit) align move type. More...
int | idMotion
id of the motion face entity More...
int | idStation
id of the stationary entity if type = VX_DE_ALIGN_MOVE_COPLANAR, entity should be plane face or datum plane if type = VX_DE_ALIGN_MOVE_CONCENTRIC, entity should be circle face or curve if type = VX_DE_ALIGN_MOVE_TANGENT, entity should be face or datum plane if type = VX_DE_ALIGN_MOVE_PARALLEL or VX_DE_ALIGN_MOVE_PERPENDICULAR, entity should be edge or plane face or datum plane if type = VX_DE_ALIGN_MOVE_ANGLE or VX_DE_ALIGN_MOVE_SYMMETRY, entity should be face or datum plane More...
int | numEnt
number of motion group face entities More...
int * | idEnts
list id of motion group face entities, can be null More...
svxPntOnEnt thruPnt
through point if type > VX_DE_ALIGN_MOVE_CONCENTRIC and type < VX_DE_ALIGN_MOVE_SYMMETRY, the through point is given by user. other type can be null More...
double | angle
angle.default:0 if type = VX_DE_ALIGN_MOVE_ANGLE, it is the angle of align move. other type can be null More...
int | idPlane
id of symmetry plane. if type = VX_DE_ALIGN_MOVE_SYMMETRY, the symmetry plane can be face of entity or datum plane, other type can be null More...
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO. More...

Detailed Description

part or assembly DE(Direct Edit) align move data

Definition at line 189 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ type

evxDEAlignMoveType svxDEAlignMove::type

DE(Direct Edit) align move type.

Definition at line 191 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ idPlane

int svxDEAlignMove::idPlane

id of symmetry plane. if type = VX_DE_ALIGN_MOVE_SYMMETRY, the symmetry plane can be face of entity or datum plane, other type can be null

Definition at line 210 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ idEnts

int* svxDEAlignMove::idEnts

list id of motion group face entities, can be null

Definition at line 202 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::idMotion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ idMotion

int svxDEAlignMove::idMotion

id of the motion face entity

Definition at line 192 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::overflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ overflow

evxDEFaceOverflow svxDEAlignMove::overflow

DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.

Definition at line 213 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::idStation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ idStation

int svxDEAlignMove::idStation

id of the stationary entity if type = VX_DE_ALIGN_MOVE_COPLANAR, entity should be plane face or datum plane if type = VX_DE_ALIGN_MOVE_CONCENTRIC, entity should be circle face or curve if type = VX_DE_ALIGN_MOVE_TANGENT, entity should be face or datum plane if type = VX_DE_ALIGN_MOVE_PARALLEL or VX_DE_ALIGN_MOVE_PERPENDICULAR, entity should be edge or plane face or datum plane if type = VX_DE_ALIGN_MOVE_ANGLE or VX_DE_ALIGN_MOVE_SYMMETRY, entity should be face or datum plane

Definition at line 193 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ numEnt

int svxDEAlignMove::numEnt

number of motion group face entities

Definition at line 201 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ angle

double svxDEAlignMove::angle

angle.default:0 if type = VX_DE_ALIGN_MOVE_ANGLE, it is the angle of align move. other type can be null

Definition at line 207 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEAlignMove::thruPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEAlignMove
angle
idEnts
idMotion
idPlane
idStation
numEnt
overflow
thruPnt
type

◆ thruPnt

svxPntOnEnt svxDEAlignMove::thruPnt

through point if type > VX_DE_ALIGN_MOVE_CONCENTRIC and type < VX_DE_ALIGN_MOVE_SYMMETRY, the through point is given by user. other type can be null

Definition at line 203 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxDECopy Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) copy data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

union svxDECopyData
Union of DE copy data. More...

Data Fields

evxDEMoveCopyType type
DE(Direct Edit) copy type. More...
int | numEnt
number of face entities need to be used DE(Direct Edit) copy command More...
int * | idEnts
list id of face entities need to be used DE(Direct Edit) copy command More...
union svxDECopy::svxDECopyData | copy

Detailed Description

part or assembly DE(Direct Edit) copy data

Definition at line 326 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
Data Fields
svxDECopy::svxDECopyData::svxDECopyDir Struct Reference

copy along a direction type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt dir
the direction of DE(Direct Edit) copy. the copy entities is copy along the direction More...
double | dist
the distance of DE(Direct Edit) copy.default:0. the entities copy distance along the direction More...
int | useAng
whether to use angle (0 = no, 1 = yes).default:1 More...
double | ang
the angle of DE(Direct Edit) copy.default:0. the entities rotation angle around the dir More...
int | useCopies
whether to have more than one copies (0 = no, 1 = yes).default:1 More...
int | copies
the copies of DE(Direct Edit) copy.default:1 More...

Detailed Description

copy along a direction type

<

Definition at line 353 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ dir

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyDir::dir

the direction of DE(Direct Edit) copy. the copy entities is copy along the direction

Definition at line 355 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::useCopies

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ useCopies

int svxDECopy::svxDECopyData::svxDECopyDir::useCopies

whether to have more than one copies (0 = no, 1 = yes).default:1

Definition at line 362 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ dist

double svxDECopy::svxDECopyData::svxDECopyDir::dist

the distance of DE(Direct Edit) copy.default:0. the entities copy distance along the direction

Definition at line 357 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::copies

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ copies

int svxDECopy::svxDECopyData::svxDECopyDir::copies

the copies of DE(Direct Edit) copy.default:1

Definition at line 363 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::useAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ useAng

int svxDECopy::svxDECopyData::svxDECopyDir::useAng

whether to use angle (0 = no, 1 = yes).default:1

Definition at line 359 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDir::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDir
ang
copies
dir
dist
useAng
useCopies

◆ ang

double svxDECopy::svxDECopyData::svxDECopyDir::ang

the angle of DE(Direct Edit) copy.default:0. the entities rotation angle around the dir

Definition at line 360 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
Data Fields
svxDECopy::svxDECopyData::svxDECopyDyn Struct Reference

dynamic copy type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int handle
whether to copy handle only (0 = no, 1 = yes).default:0 More...
svxPoint position
the position of handle direction user can adjust the handle position to move,copy or rotate entities More...
svxVector x
the x axis of handle direction.default:(1,0,0) More...
svxVector y
the y axis of handle direction.default:(0,1,0) More...
svxVector z
the z axis of handle direction.default:(0,0,1) More...

Detailed Description

dynamic copy type

<

Definition at line 333 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
handle
position
x
y
z

◆ y

svxVector svxDECopy::svxDECopyData::svxDECopyDyn::y

the y axis of handle direction.default:(0,1,0)

Definition at line 339 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
handle
position
x
y
z

◆ z

svxVector svxDECopy::svxDECopyData::svxDECopyDyn::z

the z axis of handle direction.default:(0,0,1)

Definition at line 340 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
handle
position
x
y
z

◆ x

svxVector svxDECopy::svxDECopyData::svxDECopyDyn::x

the x axis of handle direction.default:(1,0,0)

Definition at line 338 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
handle
position
x
y
z

◆ position

svxPoint svxDECopy::svxDECopyData::svxDECopyDyn::position

the position of handle direction user can adjust the handle position to move,copy or rotate entities

Definition at line 336 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyDyn::handle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyDyn
handle
position
x
y
z

◆ handle

int svxDECopy::svxDECopyData::svxDECopyDyn::handle

whether to copy handle only (0 = no, 1 = yes).default:0

Definition at line 335 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyFrame Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyFrame
Data Fields
svxDECopy::svxDECopyData::svxDECopyFrame Struct Reference

copy by aligning frame type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | fromFrmae
the from frame id of DE(Direct Edit) copy More...
int | cnt
number of toFrames More...
int * | toFrmaes
the to frame id of DE(Direct Edit) move More...

Detailed Description

copy by aligning frame type

<

Definition at line 374 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyFrame::fromFrmae

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyFrame
cnt
fromFrmae
toFrmaes

◆ fromFrmae

int svxDECopy::svxDECopyData::svxDECopyFrame::fromFrmae

the from frame id of DE(Direct Edit) copy

Definition at line 376 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyFrame::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyFrame
cnt
fromFrmae
toFrmaes

◆ cnt

int svxDECopy::svxDECopyData::svxDECopyFrame::cnt

number of toFrames

Definition at line 377 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyFrame::toFrmaes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyFrame
cnt
fromFrmae
toFrmaes

◆ toFrmaes

int* svxDECopy::svxDECopyData::svxDECopyFrame::toFrmaes

the to frame id of DE(Direct Edit) move

Definition at line 378 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
Data Fields
svxDECopy::svxDECopyData::svxDECopyPath Struct Reference

copy along path type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt pathPnt
the point on the path entities . the entities copy to the point pathPnt project on entities along the path More...
int | numPnt
number of the to point of DE(Direct Edit) copy More...
svxPntOnEnt * toPnt
list of the to point of DE(Direct Edit) copy More...
evxDEMoveCopyFrame frame
frame type.default:VX_DE_MOVE_FRAME_NATURAL More...
int | idSwp
the id of swp frame . if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame type can be null More...
evxDEMoveCopyZSpine zSpine
Z spine type.default:VX_DE_MOVE_Z_NATURAL. More...
int | idCrv
the curve of spine. if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can be null More...
svxPntOnEnt planeZ
the vector of plane. if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type can be null More...
evxDEMoveCopyXOrient xOrient
X orient type.default:VX_DE_MOVE_X_NATURAL. More...
svxPntOnEnt planeX
the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be null More...
svxPntOnEnt crv
the point on x-axis curve entity. if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve. other type can be null More...

Detailed Description

copy along path type

<

Definition at line 380 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ frame

evxDEMoveCopyFrame svxDECopy::svxDECopyData::svxDECopyPath::frame

frame type.default:VX_DE_MOVE_FRAME_NATURAL

Definition at line 387 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::planeZ

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ planeZ

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPath::planeZ

the vector of plane. if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type can be null

Definition at line 396 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::idSwp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ idSwp

int svxDECopy::svxDECopyData::svxDECopyPath::idSwp

the id of swp frame . if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame type can be null

Definition at line 388 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::numPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ numPnt

int svxDECopy::svxDECopyData::svxDECopyPath::numPnt

number of the to point of DE(Direct Edit) copy

Definition at line 384 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ idCrv

int svxDECopy::svxDECopyData::svxDECopyPath::idCrv

the curve of spine. if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can be null

Definition at line 393 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ toPnt

svxPntOnEnt* svxDECopy::svxDECopyData::svxDECopyPath::toPnt

list of the to point of DE(Direct Edit) copy

Definition at line 385 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::pathPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ pathPnt

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPath::pathPnt

the point on the path entities . the entities copy to the point pathPnt project on entities along the path

Definition at line 382 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::xOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ xOrient

evxDEMoveCopyXOrient svxDECopy::svxDECopyData::svxDECopyPath::xOrient

X orient type.default:VX_DE_MOVE_X_NATURAL.

Definition at line 400 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::zSpine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ zSpine

evxDEMoveCopyZSpine svxDECopy::svxDECopyData::svxDECopyPath::zSpine

Z spine type.default:VX_DE_MOVE_Z_NATURAL.

Definition at line 392 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::planeX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ planeX

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPath::planeX

the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be null

Definition at line 401 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPath::crv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPath
crv
frame
idCrv
idSwp
numPnt
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ crv

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPath::crv

the point on x-axis curve entity. if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve. other type can be null

Definition at line 404 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
Data Fields
svxDECopy::svxDECopyData::svxDECopyPnt Struct Reference

copy entities point to point type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt fromPnt
the start point of DE(Direct Edit) copy More...
int cntToPnt
count of toPnt More...
svxPntOnEnt * toPnt
the end point of DE(Direct Edit) copy. the relative position of toPnt and copy entities and the relative position . of fromPnt and old entities are same More...
svxPntOnEnt fromVec
the from vector More...
svxPntOnEnt toVec
the to vector the old entities rotate from fromVec to toVec, get the copy entities More...

Detailed Description

copy entities point to point type

<

Definition at line 342 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
cntToPnt
fromPnt
fromVec
toPnt
toVec

◆ toPnt

svxPntOnEnt* svxDECopy::svxDECopyData::svxDECopyPnt::toPnt

the end point of DE(Direct Edit) copy. the relative position of toPnt and copy entities and the relative position . of fromPnt and old entities are same

Definition at line 346 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt::cntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
cntToPnt
fromPnt
fromVec
toPnt
toVec

◆ cntToPnt

int svxDECopy::svxDECopyData::svxDECopyPnt::cntToPnt

count of toPnt

Definition at line 345 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt::fromVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
cntToPnt
fromPnt
fromVec
toPnt
toVec

◆ fromVec

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPnt::fromVec

the from vector

Definition at line 349 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
cntToPnt
fromPnt
fromVec
toPnt
toVec

◆ fromPnt

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPnt::fromPnt

the start point of DE(Direct Edit) copy

Definition at line 344 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyPnt::toVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyPnt
cntToPnt
fromPnt
fromVec
toPnt
toVec

◆ toVec

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyPnt::toVec

the to vector the old entities rotate from fromVec to toVec, get the copy entities

Definition at line 350 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyRotate Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyRotate
Data Fields
svxDECopy::svxDECopyData::svxDECopyRotate Struct Reference

rotate around a direction type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt dir
the direction of DE(Direct Edit) copy. the copy entities is copy along the direction More...
double | ang
the rotate angle of rotation.default:0 the entities rotate around axis about ang More...
int | useCopies
whether to have more than one copies (0 = no, 1 = yes).default:1 More...
int | copies
the copies of DE(Direct Edit) copy.default:1 More...

Detailed Description

rotate around a direction type

<

Definition at line 365 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyRotate::copies

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyRotate
ang
copies
dir
useCopies

◆ copies

int svxDECopy::svxDECopyData::svxDECopyRotate::copies

the copies of DE(Direct Edit) copy.default:1

Definition at line 372 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyRotate::useCopies

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyRotate
ang
copies
dir
useCopies

◆ useCopies

int svxDECopy::svxDECopyData::svxDECopyRotate::useCopies

whether to have more than one copies (0 = no, 1 = yes).default:1

Definition at line 371 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyRotate::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyRotate
ang
copies
dir
useCopies

◆ ang

double svxDECopy::svxDECopyData::svxDECopyRotate::ang

the rotate angle of rotation.default:0 the entities rotate around axis about ang

Definition at line 369 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData::svxDECopyRotate::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
  • svxDECopyRotate
ang
copies
dir
useCopies

◆ dir

svxPntOnEnt svxDECopy::svxDECopyData::svxDECopyRotate::dir

the direction of DE(Direct Edit) copy. the copy entities is copy along the direction

Definition at line 367 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
idEnts
numEnt
type

◆ type

evxDEMoveCopyType svxDECopy::type

DE(Direct Edit) copy type.

Definition at line 328 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
idEnts
numEnt
type

◆ idEnts

int* svxDECopy::idEnts

list id of face entities need to be used DE(Direct Edit) copy command

Definition at line 330 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
idEnts
numEnt
type

◆ numEnt

int svxDECopy::numEnt

number of face entities need to be used DE(Direct Edit) copy command

Definition at line 329 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEDimMove Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) dim move data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

evxDEDimMoveType type
DE(Direct Edit) align move type. More...
int | idMotion
id of the motion face entity More...
int | idStation
id of the stationary entity More...
int | isSwitch
switch point and entity.(0/1) if type=VX_DE_DIM_ANGULAR, ignore it. More...
svxPoint stationPnt
if type=VX_DE_DIM_LINEAR and isSwitch=1,apply it. else ignore it. this point must be on the surface of idStation. More...
int | numEnt
number of motion group face entities More...
int * | idEnts
list id of motion group face entities More...
double | dist
the dim move distance.default:0 if type = VX_DE_DIM_LINEAR, the distance is given by user other type can be null More...
svxPntOnEnt anchorPnt
through point if type = VX_DE_DIM_LINEAR, the point is given by user, can be null More...
svxPntOnEnt dir
measure direction if type = VX_DE_DIM_LINEAR, the direction is given by user, can be null More...
double | angle
angle.default:0 if type = VX_DE_DIM_ANGULAR, it is the angle of align move other type can be null More...
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO. More...

Detailed Description

part or assembly DE(Direct Edit) dim move data

Definition at line 230 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::anchorPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ anchorPnt

svxPntOnEnt svxDEDimMove::anchorPnt

through point if type = VX_DE_DIM_LINEAR, the point is given by user, can be null

Definition at line 244 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::idStation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ idStation

int svxDEDimMove::idStation

id of the stationary entity

Definition at line 234 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::isSwitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ isSwitch

int svxDEDimMove::isSwitch

switch point and entity.(0/1) if type=VX_DE_DIM_ANGULAR, ignore it.

Definition at line 235 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ angle

double svxDEDimMove::angle

angle.default:0 if type = VX_DE_DIM_ANGULAR, it is the angle of align move other type can be null

Definition at line 248 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ dist

double svxDEDimMove::dist

the dim move distance.default:0 if type = VX_DE_DIM_LINEAR, the distance is given by user other type can be null

Definition at line 241 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::idMotion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ idMotion

int svxDEDimMove::idMotion

id of the motion face entity

Definition at line 233 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::stationPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ stationPnt

svxPoint svxDEDimMove::stationPnt

if type=VX_DE_DIM_LINEAR and isSwitch=1,apply it. else ignore it. this point must be on the surface of idStation.

Definition at line 237 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ idEnts

int* svxDEDimMove::idEnts

list id of motion group face entities

Definition at line 240 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::overflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ overflow

evxDEFaceOverflow svxDEDimMove::overflow

DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.

Definition at line 251 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ dir

svxPntOnEnt svxDEDimMove::dir

measure direction if type = VX_DE_DIM_LINEAR, the direction is given by user, can be null

Definition at line 246 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ numEnt

int svxDEDimMove::numEnt

number of motion group face entities

Definition at line 239 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDimMove::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDimMove
anchorPnt
angle
dir
dist
idEnts
idMotion
idStation
isSwitch
numEnt
overflow
stationPnt
type

◆ type

evxDEDimMoveType svxDEDimMove::type

DE(Direct Edit) align move type.

Definition at line 232 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEDraft Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) draft data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | numFace
number of face entities to draft More...
int * | idFaces
list id of face entities to draft More...
int | numDraft
number of edge entities on the draft face More...
int * | idDrafts
list id of edge entities on the draft face More...
double | angle
the draft angle.default:0 More...
svxPntOnEnt dir
the draft direction More...
evxDEDraftSideType side
the type of side to draft.default:VX_DE_DRAFT_SIDE_SPILT More...
int | numEdge
number of parting edge entities to terminate draft More...
int * | idEgdes
list id of parting edge entities to terminate draft More...
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO. More...

Detailed Description

part or assembly DE(Direct Edit) draft data

Definition at line 304 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::overflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ overflow

evxDEFaceOverflow svxDEDraft::overflow

DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.

Definition at line 315 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::numDraft

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ numDraft

int svxDEDraft::numDraft

number of edge entities on the draft face

Definition at line 308 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ angle

double svxDEDraft::angle

the draft angle.default:0

Definition at line 310 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ idFaces

int* svxDEDraft::idFaces

list id of face entities to draft

Definition at line 307 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::idDrafts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ idDrafts

int* svxDEDraft::idDrafts

list id of edge entities on the draft face

Definition at line 309 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::numEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ numEdge

int svxDEDraft::numEdge

number of parting edge entities to terminate draft

Definition at line 313 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ dir

svxPntOnEnt svxDEDraft::dir

the draft direction

Definition at line 311 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::idEgdes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ idEgdes

int* svxDEDraft::idEgdes

list id of parting edge entities to terminate draft

Definition at line 314 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::numFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ numFace

int svxDEDraft::numFace

number of face entities to draft

Definition at line 306 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEDraft::side

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEDraft
angle
dir
idDrafts
idEgdes
idFaces
numDraft
numEdge
numFace
overflow
side

◆ side

evxDEDraftSideType svxDEDraft::side

the type of side to draft.default:VX_DE_DRAFT_SIDE_SPILT

Definition at line 312 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEFllt Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) modify fillet data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | numEnt
number of fillet entities need to be edited command More...
int * | idEnts
list id of fillet entities need to be edited command More...
double | R
the edit radius of fillet.default:5 More...
int | chain
whether to chain pick with same R(0 = no, 1 = yes).default:0 More...
double | relief
the relief of fillet.default:0 More...
int | arcType
the arc type of fillet(0 = circular, 1 = conic).default:0 More...
double | ratio
the conic ratio .default:0.5.
if arcType = 1, it can be given by user .
other type can be null More...
int | hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0 More...
int | strategy
closing strategy.default:0.
0 - auto.
1 - selected More...
int | numEdge
number of list edge or direction entities More...
int * | idEgdes
list id of list edge or direction entities More...

Detailed Description

part or assembly DE(Direct Edit) modify fillet data

Definition at line 579 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ numEnt

int svxDEFllt::numEnt

number of fillet entities need to be edited command

Definition at line 581 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ R

double svxDEFllt::R

the edit radius of fillet.default:5

Definition at line 583 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ idEnts

int* svxDEFllt::idEnts

list id of fillet entities need to be edited command

Definition at line 582 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::numEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ numEdge

int svxDEFllt::numEdge

number of list edge or direction entities

Definition at line 594 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::strategy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ strategy

int svxDEFllt::strategy

closing strategy.default:0.
0 - auto.
1 - selected

Definition at line 591 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::hold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ hold

int svxDEFllt::hold

whether to hold fillet to edge(0 = no, 1 = yes).default:0

Definition at line 590 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ relief

double svxDEFllt::relief

the relief of fillet.default:0

Definition at line 585 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::idEgdes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ idEgdes

int* svxDEFllt::idEgdes

list id of list edge or direction entities

Definition at line 595 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::chain

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ chain

int svxDEFllt::chain

whether to chain pick with same R(0 = no, 1 = yes).default:0

Definition at line 584 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ ratio

double svxDEFllt::ratio

the conic ratio .default:0.5.
if arcType = 1, it can be given by user .
other type can be null

Definition at line 587 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEFllt::arcType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEFllt
arcType
chain
hold
idEgdes
idEnts
numEdge
numEnt
R
ratio
relief
strategy

◆ arcType

int svxDEFllt::arcType

the arc type of fillet(0 = circular, 1 = conic).default:0

Definition at line 586 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMirror Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEMirror Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) mirror data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | numEnt
number of face entities need to be used DE(Direct Edit) mirror command More...
int * | idEnts
list id of face entities need to be used DE(Direct Edit) mirror command More...
int | idPlane
the id of symmetric plane, it should be datum plane, planar face or sketch More...
int | original
whether keep the original entities (0 = no, 1 = yes).default:1 0 - the entities move to the symmetRic place 1 - copy a symmetRic entities More...

Detailed Description

part or assembly DE(Direct Edit) mirror data

Definition at line 415 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMirror::original

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMirror
idEnts
idPlane
numEnt
original

◆ original

int svxDEMirror::original

whether keep the original entities (0 = no, 1 = yes).default:1 0 - the entities move to the symmetRic place 1 - copy a symmetRic entities

Definition at line 420 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMirror::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMirror
idEnts
idPlane
numEnt
original

◆ idEnts

int* svxDEMirror::idEnts

list id of face entities need to be used DE(Direct Edit) mirror command

Definition at line 418 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMirror::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMirror
idEnts
idPlane
numEnt
original

◆ numEnt

int svxDEMirror::numEnt

number of face entities need to be used DE(Direct Edit) mirror command

Definition at line 417 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMirror::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMirror
idEnts
idPlane
numEnt
original

◆ idPlane

int svxDEMirror::idPlane

the id of symmetric plane, it should be datum plane, planar face or sketch

Definition at line 419 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxDEMove Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) move data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

union svxDEMoveData
union of DE move type More...

Data Fields

evxDEMoveCopyType type
DE(Direct Edit) move type. More...
int | numEnt
number of face entities need to be used DE(Direct Edit) move command More...
int * | idEnts
list id of face entities need to be used DE(Direct Edit) move command More...
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO. More...
union svxDEMove::svxDEMoveData | move

Detailed Description

part or assembly DE(Direct Edit) move data

Definition at line 90 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDir
Data Fields
svxDEMove::svxDEMoveData::svxDEMoveDir Struct Reference

move along a direction type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt dir
the direction of DE(Direct Edit) move the move entities is move along the direction More...
double | dist
the distance of DE(Direct Edit) move.default:0 the entities move distance along the direction More...
double | ang
the angle of DE(Direct Edit) move.default:0 the entities rotation angle around the dir More...
int | angOption
whether to use angle (0 = no, 1 = yes) Default:1 More...

Detailed Description

move along a direction type

<

Definition at line 117 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDir::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDir
ang
angOption
dir
dist

◆ dir

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMoveDir::dir

the direction of DE(Direct Edit) move the move entities is move along the direction

Definition at line 119 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDir::angOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDir
ang
angOption
dir
dist

◆ angOption

int svxDEMove::svxDEMoveData::svxDEMoveDir::angOption

whether to use angle (0 = no, 1 = yes) Default:1

Definition at line 125 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDir::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDir
ang
angOption
dir
dist

◆ ang

double svxDEMove::svxDEMoveData::svxDEMoveDir::ang

the angle of DE(Direct Edit) move.default:0 the entities rotation angle around the dir

Definition at line 123 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDir::dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDir
ang
angOption
dir
dist

◆ dist

double svxDEMove::svxDEMoveData::svxDEMoveDir::dist

the distance of DE(Direct Edit) move.default:0 the entities move distance along the direction

Definition at line 121 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
Data Fields
svxDEMove::svxDEMoveData::svxDEMoveDyn Struct Reference

dynamic move type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int handle
whether to move handle only (0 = no, 1 = yes).Default:0 More...
svxPoint position
the position of handle direction user can adjust the handle position or move, copy, rotate entities More...
svxVector x
the x axis of handle direction.default:(1,0,0) More...
svxVector y
the y axis of handle direction.default:(0,1,0) More...
svxVector z
the z axis of handle direction.default:(0,0,1) More...

Detailed Description

dynamic move type

<

Definition at line 98 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn::handle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
handle
position
x
y
z

◆ handle

int svxDEMove::svxDEMoveData::svxDEMoveDyn::handle

whether to move handle only (0 = no, 1 = yes).Default:0

Definition at line 100 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
handle
position
x
y
z

◆ y

svxVector svxDEMove::svxDEMoveData::svxDEMoveDyn::y

the y axis of handle direction.default:(0,1,0)

Definition at line 104 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
handle
position
x
y
z

◆ z

svxVector svxDEMove::svxDEMoveData::svxDEMoveDyn::z

the z axis of handle direction.default:(0,0,1)

Definition at line 105 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
handle
position
x
y
z

◆ x

svxVector svxDEMove::svxDEMoveData::svxDEMoveDyn::x

the x axis of handle direction.default:(1,0,0)

Definition at line 103 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveDyn::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveDyn
handle
position
x
y
z

◆ position

svxPoint svxDEMove::svxDEMoveData::svxDEMoveDyn::position

the position of handle direction user can adjust the handle position or move, copy, rotate entities

Definition at line 101 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveFrame Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveFrame
Data Fields
svxDEMove::svxDEMoveData::svxDEMoveFrame Struct Reference

move by aligning frame type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | fromFrmae
the from frame id of DE(Direct Edit) move More...
int | toFrmae
the to frame id of DE(Direct Edit) move More...

Detailed Description

move by aligning frame type

<

Definition at line 135 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveFrame::fromFrmae

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveFrame
fromFrmae
toFrmae

◆ fromFrmae

int svxDEMove::svxDEMoveData::svxDEMoveFrame::fromFrmae

the from frame id of DE(Direct Edit) move

Definition at line 137 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveFrame::toFrmae

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveFrame
fromFrmae
toFrmae

◆ toFrmae

int svxDEMove::svxDEMoveData::svxDEMoveFrame::toFrmae

the to frame id of DE(Direct Edit) move

Definition at line 138 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
Data Fields
svxDEMove::svxDEMoveData::svxDEMovePath Struct Reference

move along path type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt pathPnt
the point on the path entities the entities move to the point pathPnt project on entities along the path More...
svxPntOnEnt toPnt
the to point of DE(Direct Edit) move More...
evxDEMoveCopyFrame frame
frame type.default:VX_DE_MOVE_FRAME_PATH More...
int | idSwp
the id of swp frame if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame type can be null More...
evxDEMoveCopyZSpine zSpine
Z spine type.default:VX_DE_MOVE_Z_NATURAL. More...
int | idCrv
the curve of spine if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can be null More...
svxPntOnEnt planeZ
the vector of plane if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type can be null More...
evxDEMoveCopyXOrient xOrient
X orient type.default:VX_DE_MOVE_X_NATURAL. More...
svxPntOnEnt planeX
the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be null More...
svxPntOnEnt crv
the point on x-axis curve entity if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve other type can be null More...

Detailed Description

move along path type

<

Definition at line 140 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ toPnt

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePath::toPnt

the to point of DE(Direct Edit) move

Definition at line 144 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::idSwp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ idSwp

int svxDEMove::svxDEMoveData::svxDEMovePath::idSwp

the id of swp frame if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame type can be null

Definition at line 147 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::planeX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ planeX

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePath::planeX

the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be null

Definition at line 160 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ idCrv

int svxDEMove::svxDEMoveData::svxDEMovePath::idCrv

the curve of spine if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can be null

Definition at line 152 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::crv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ crv

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePath::crv

the point on x-axis curve entity if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve other type can be null

Definition at line 163 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::xOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ xOrient

evxDEMoveCopyXOrient svxDEMove::svxDEMoveData::svxDEMovePath::xOrient

X orient type.default:VX_DE_MOVE_X_NATURAL.

Definition at line 159 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::pathPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ pathPnt

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePath::pathPnt

the point on the path entities the entities move to the point pathPnt project on entities along the path

Definition at line 142 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::planeZ

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ planeZ

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePath::planeZ

the vector of plane if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type can be null

Definition at line 155 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::zSpine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ zSpine

evxDEMoveCopyZSpine svxDEMove::svxDEMoveData::svxDEMovePath::zSpine

Z spine type.default:VX_DE_MOVE_Z_NATURAL.

Definition at line 151 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePath::frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePath
crv
frame
idCrv
idSwp
pathPnt
planeX
planeZ
toPnt
xOrient
zSpine

◆ frame

evxDEMoveCopyFrame svxDEMove::svxDEMoveData::svxDEMovePath::frame

frame type.default:VX_DE_MOVE_FRAME_PATH

Definition at line 146 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePnt
Data Fields
svxDEMove::svxDEMoveData::svxDEMovePnt Struct Reference

move entities point to point type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt fromPnt
the start point of DE(Direct Edit) move More...
svxPntOnEnt toPnt
the end point of DE(Direct Edit) move the relative position of toPnt and moved entities and the relative position of fromPnt and old entities are same More...
svxPntOnEnt fromVec
the from vector More...
svxPntOnEnt toVec
the to vector the old entities rotate from fromVec to toVec, get the move entities More...

Detailed Description

move entities point to point type

<

Definition at line 107 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePnt::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePnt
fromPnt
fromVec
toPnt
toVec

◆ fromPnt

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePnt::fromPnt

the start point of DE(Direct Edit) move

Definition at line 109 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePnt::toVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePnt
fromPnt
fromVec
toPnt
toVec

◆ toVec

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePnt::toVec

the to vector the old entities rotate from fromVec to toVec, get the move entities

Definition at line 114 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePnt::fromVec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePnt
fromPnt
fromVec
toPnt
toVec

◆ fromVec

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePnt::fromVec

the from vector

Definition at line 113 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMovePnt::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMovePnt
fromPnt
fromVec
toPnt
toVec

◆ toPnt

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMovePnt::toPnt

the end point of DE(Direct Edit) move the relative position of toPnt and moved entities and the relative position of fromPnt and old entities are same

Definition at line 110 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveRotate Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveRotate
Data Fields
svxDEMove::svxDEMoveData::svxDEMoveRotate Struct Reference

rotate around a direction type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt dir
the direction of DE(Direct Edit) move the move entities is move along the direction More...
svxPntOnEnt axis
the direction of rotation More...
double ang
the rotate angle of rotation.default:0 the entities rotate around axis about ang More...

Detailed Description

rotate around a direction type

<

Definition at line 127 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveRotate::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveRotate
ang
axis
dir

◆ ang

double svxDEMove::svxDEMoveData::svxDEMoveRotate::ang

the rotate angle of rotation.default:0 the entities rotate around axis about ang

Definition at line 132 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveRotate::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveRotate
ang
axis
dir

◆ dir

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMoveRotate::dir

the direction of DE(Direct Edit) move the move entities is move along the direction

Definition at line 129 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData::svxDEMoveRotate::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
  • svxDEMoveRotate
ang
axis
dir

◆ axis

svxPntOnEnt svxDEMove::svxDEMoveData::svxDEMoveRotate::axis

the direction of rotation

Definition at line 131 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
idEnts
numEnt
overflow
type

◆ type

evxDEMoveCopyType svxDEMove::type

DE(Direct Edit) move type.

Definition at line 92 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
idEnts
numEnt
overflow
type

◆ numEnt

int svxDEMove::numEnt

number of face entities need to be used DE(Direct Edit) move command

Definition at line 93 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
idEnts
numEnt
overflow
type

◆ idEnts

int* svxDEMove::idEnts

list id of face entities need to be used DE(Direct Edit) move command

Definition at line 94 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::overflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
idEnts
numEnt
overflow
type

◆ overflow

evxDEFaceOverflow svxDEMove::overflow

DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.

Definition at line 95 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDEOffset Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) face offset data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | numEnt
number of face entities to set offset More...
int * | idEnts
list id of face entities to set offset More...
double | dist
the offset distance.default:0 More...
evxDESideFaceType side
side face type.default:VX_DE_SIDE_FACE_CREATE More...
evxDEIsectType intersection
intersection.default:VX_DE_ISECT_NO_REMOVE More...
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO. More...

Detailed Description

part or assembly DE(Direct Edit) face offset data

Definition at line 278 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::overflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ overflow

evxDEFaceOverflow svxDEOffset::overflow

DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.

Definition at line 285 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::intersection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ intersection

evxDEIsectType svxDEOffset::intersection

intersection.default:VX_DE_ISECT_NO_REMOVE

Definition at line 284 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ idEnts

int* svxDEOffset::idEnts

list id of face entities to set offset

Definition at line 281 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ dist

double svxDEOffset::dist

the offset distance.default:0

Definition at line 282 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::side

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ side

evxDESideFaceType svxDEOffset::side

side face type.default:VX_DE_SIDE_FACE_CREATE

Definition at line 283 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEOffset::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEOffset
dist
idEnts
intersection
numEnt
overflow
side

◆ numEnt

int svxDEOffset::numEnt

number of face entities to set offset

Definition at line 280 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxDEPattern Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) pattern data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

union svxDEPtnData
union of De pattern data More...

Data Fields

evxDEPtnType type
DE(Direct Edit) pattern type. More...
int | numEnt
number of face entities need to be used DE(Direct Edit) pattern command More...
int * | idEnts
list id of face entities need to be used DE(Direct Edit) pattern command More...
union svxDEPattern::svxDEPtnData | ptn
int | cntSkip
number of the instances to be skipped More...
int * | firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction)
if type = 1 or 2 or 5 or 6, it can given by user
other type can be null More...
int * | secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x
More...

Detailed Description

part or assembly DE(Direct Edit) pattern data

Definition at line 477 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnCircular Struct Reference

circular DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt dir
the direction of the pattern More...
double | diameter
the diameter between the base entity and the first entity of pattern.default:0 More...
double | ang
the angle between direction and next direction.default:45 the next direction is given by dir and ang More...
int | num [2]
the number of pattern.default:(2,1) the 1st number is how many direction to form pattern the 2nd number is the number of entities on all direction More...
double | spacing
the spacing between entities in pattern on two direction.default:20 More...
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE More...
double | min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing More...
int | stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0 More...
int | align
the alignment type(0 = align with base, 1= align with pattern).default:1 More...

Detailed Description

circular DE(Direct Edit) pattern type

<

Definition at line 491 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ derive

evxDEPtnDerive svxDEPattern::svxDEPtnData::svxDEPtnCircular::derive

the derive type.default:VX_DE_PTN_DERIVE_NONE

Definition at line 501 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ dir

svxPntOnEnt svxDEPattern::svxDEPtnData::svxDEPtnCircular::dir

the direction of the pattern

Definition at line 493 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ num

int svxDEPattern::svxDEPtnData::svxDEPtnCircular::num[2]

the number of pattern.default:(2,1) the 1st number is how many direction to form pattern the 2nd number is the number of entities on all direction

Definition at line 497 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ stagger

int svxDEPattern::svxDEPtnData::svxDEPtnCircular::stagger

whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0

Definition at line 504 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::min

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ min

double svxDEPattern::svxDEPtnData::svxDEPtnCircular::min

the minimum spacing.default:0 drops out instances that do not have the minimum spacing

Definition at line 502 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ align

int svxDEPattern::svxDEPtnData::svxDEPtnCircular::align

the alignment type(0 = align with base, 1= align with pattern).default:1

Definition at line 505 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ ang

double svxDEPattern::svxDEPtnData::svxDEPtnCircular::ang

the angle between direction and next direction.default:45 the next direction is given by dir and ang

Definition at line 495 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ diameter

double svxDEPattern::svxDEPtnData::svxDEPtnCircular::diameter

the diameter between the base entity and the first entity of pattern.default:0

Definition at line 494 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCircular::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCircular
align
ang
derive
diameter
dir
min
num
spacing
stagger

◆ spacing

double svxDEPattern::svxDEPtnData::svxDEPtnCircular::spacing

the spacing between entities in pattern on two direction.default:20

Definition at line 500 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnCurve Struct Reference

at curve(s) DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

evxDEPtnCrv crvType
the curve method.default:VX_DE_PTN_CRV1 More...
int | numBound
number of boundary entities if type = 1, numBound = 1 if type = 2 or 3, numBound = 2 if type = 4, numBound = 4 More...
int * | pBounds
the list id of boundary entities More...
int | num [2]
the number of entity on two direction.default:(2,1) More...
double | spacing [2]
the spacing between entity on two direction.default:(20,20) More...
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE More...
double | min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing More...
int | stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0 More...
int | align
the alignment type(0 = align with base, 1= align with pattern).default:1 More...
int | idFace
the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on More...
int | useFromPnt
1 if use fromPnt, else 0. default:0 More...
svxPntOnEnt fromPnt
the from point, pick a point where the pattern starts from More...
evxDEPtnBound bound
the boundary type More...

Detailed Description

at curve(s) DE(Direct Edit) pattern type

<

Definition at line 520 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ spacing

double svxDEPattern::svxDEPtnData::svxDEPtnCurve::spacing[2]

the spacing between entity on two direction.default:(20,20)

Definition at line 529 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::bound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ bound

evxDEPtnBound svxDEPattern::svxDEPtnData::svxDEPtnCurve::bound

the boundary type

Definition at line 539 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ num

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::num[2]

the number of entity on two direction.default:(2,1)

Definition at line 528 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::numBound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ numBound

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::numBound

number of boundary entities if type = 1, numBound = 1 if type = 2 or 3, numBound = 2 if type = 4, numBound = 4

Definition at line 523 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::useFromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ useFromPnt

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::useFromPnt

1 if use fromPnt, else 0. default:0

Definition at line 537 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ idFace

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::idFace

the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on

Definition at line 535 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::crvType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ crvType

evxDEPtnCrv svxDEPattern::svxDEPtnData::svxDEPtnCurve::crvType

the curve method.default:VX_DE_PTN_CRV1

Definition at line 522 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ derive

evxDEPtnDerive svxDEPattern::svxDEPtnData::svxDEPtnCurve::derive

the derive type.default:VX_DE_PTN_DERIVE_NONE

Definition at line 530 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ align

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::align

the alignment type(0 = align with base, 1= align with pattern).default:1

Definition at line 534 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ fromPnt

svxPntOnEnt svxDEPattern::svxDEPtnData::svxDEPtnCurve::fromPnt

the from point, pick a point where the pattern starts from

Definition at line 538 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::min

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ min

double svxDEPattern::svxDEPtnData::svxDEPtnCurve::min

the minimum spacing.default:0 drops out instances that do not have the minimum spacing

Definition at line 531 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ stagger

int svxDEPattern::svxDEPtnData::svxDEPtnCurve::stagger

whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0

Definition at line 533 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnCurve::pBounds

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnCurve
align
bound
crvType
derive
fromPnt
idFace
min
num
numBound
pBounds
spacing
stagger
useFromPnt

◆ pBounds

int* svxDEPattern::svxDEPtnData::svxDEPtnCurve::pBounds

the list id of boundary entities

Definition at line 527 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnFace Struct Reference

at face DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | idFace
the id of on face entity the face that you want the pattern to be located on More...
int | num [2]
the number of entity on two direction.default:(2,1) More...
double | spacing [2]
the spacing between entity on two direction.default:(20,20) More...
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE More...
double | min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing More...
int | stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0 More...
int | align
the alignment type(0 = align with base, 1= align with pattern).default:1 More...
int | useFromPnt
1 if use fromPnt, else 0. default:0 More...
svxPntOnEnt fromPnt
the from point, pick a point where the pattern starts from More...
evxDEPtnBound bound
the boundary type More...

Detailed Description

at face DE(Direct Edit) pattern type

<

Definition at line 541 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ stagger

int svxDEPattern::svxDEPtnData::svxDEPtnFace::stagger

whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0

Definition at line 550 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ align

int svxDEPattern::svxDEPtnData::svxDEPtnFace::align

the alignment type(0 = align with base, 1= align with pattern).default:1

Definition at line 551 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ spacing

double svxDEPattern::svxDEPtnData::svxDEPtnFace::spacing[2]

the spacing between entity on two direction.default:(20,20)

Definition at line 546 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::min

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ min

double svxDEPattern::svxDEPtnData::svxDEPtnFace::min

the minimum spacing.default:0 drops out instances that do not have the minimum spacing

Definition at line 548 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ num

int svxDEPattern::svxDEPtnData::svxDEPtnFace::num[2]

the number of entity on two direction.default:(2,1)

Definition at line 545 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ fromPnt

svxPntOnEnt svxDEPattern::svxDEPtnData::svxDEPtnFace::fromPnt

the from point, pick a point where the pattern starts from

Definition at line 553 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ idFace

int svxDEPattern::svxDEPtnData::svxDEPtnFace::idFace

the id of on face entity the face that you want the pattern to be located on

Definition at line 543 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::bound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ bound

evxDEPtnBound svxDEPattern::svxDEPtnData::svxDEPtnFace::bound

the boundary type

Definition at line 554 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::useFromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ useFromPnt

int svxDEPattern::svxDEPtnData::svxDEPtnFace::useFromPnt

1 if use fromPnt, else 0. default:0

Definition at line 552 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnFace::derive

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnFace
align
bound
derive
fromPnt
idFace
min
num
spacing
stagger
useFromPnt

◆ derive

evxDEPtnDerive svxDEPattern::svxDEPtnData::svxDEPtnFace::derive

the derive type.default:VX_DE_PTN_DERIVE_NONE

Definition at line 547 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnLinear Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnLinear
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnLinear Struct Reference

linear DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt | dir [2]
the direction of the pattern More...
int | num [2]
the number of entity on two direction.default:(2,1) More...
double | spacing [2]
the spacing between entity on two direction.default:(20,20) More...
int | stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0 More...

Detailed Description

linear DE(Direct Edit) pattern type

<

Definition at line 484 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnLinear::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnLinear
dir
num
spacing
stagger

◆ dir

svxPntOnEnt svxDEPattern::svxDEPtnData::svxDEPtnLinear::dir[2]

the direction of the pattern

Definition at line 486 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnLinear::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnLinear
dir
num
spacing
stagger

◆ num

int svxDEPattern::svxDEPtnData::svxDEPtnLinear::num[2]

the number of entity on two direction.default:(2,1)

Definition at line 487 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnLinear::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnLinear
dir
num
spacing
stagger

◆ spacing

double svxDEPattern::svxDEPtnData::svxDEPtnLinear::spacing[2]

the spacing between entity on two direction.default:(20,20)

Definition at line 488 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnLinear::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnLinear
dir
num
spacing
stagger

◆ stagger

int svxDEPattern::svxDEPtnData::svxDEPtnLinear::stagger

whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0

Definition at line 489 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPattern Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPattern
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnPattern Struct Reference

at pattern DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int idPattern
the id of pattern feature More...

Detailed Description

at pattern DE(Direct Edit) pattern type

<

Definition at line 516 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPattern::idPattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPattern
idPattern

◆ idPattern

int svxDEPattern::svxDEPtnData::svxDEPtnPattern::idPattern

the id of pattern feature

Definition at line 518 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
Data Fields
svxDEPattern::svxDEPtnData::svxDEPtnPoint Struct Reference

point to point DE(Direct Edit) pattern type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

svxPntOnEnt fromPnt
the from point of pattern More...
int | numTo
number of to point More...
svxPntOnEnt * toPnts
the list of to point More...
int | align
the alignment type(0 = align with base, 1= align with pattern).default:1 More...
int | idFace
the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on More...

Detailed Description

point to point DE(Direct Edit) pattern type

<

Definition at line 507 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
align
fromPnt
idFace
numTo
toPnts

◆ fromPnt

svxPntOnEnt svxDEPattern::svxDEPtnData::svxDEPtnPoint::fromPnt

the from point of pattern

Definition at line 509 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
align
fromPnt
idFace
numTo
toPnts

◆ align

int svxDEPattern::svxDEPtnData::svxDEPtnPoint::align

the alignment type(0 = align with base, 1= align with pattern).default:1

Definition at line 512 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint::numTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
align
fromPnt
idFace
numTo
toPnts

◆ numTo

int svxDEPattern::svxDEPtnData::svxDEPtnPoint::numTo

number of to point

Definition at line 510 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
align
fromPnt
idFace
numTo
toPnts

◆ idFace

int svxDEPattern::svxDEPtnData::svxDEPtnPoint::idFace

the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on

Definition at line 513 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData::svxDEPtnPoint::toPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
  • svxDEPtnPoint
align
fromPnt
idFace
numTo
toPnts

◆ toPnts

svxPntOnEnt* svxDEPattern::svxDEPtnData::svxDEPtnPoint::toPnts

the list of to point

Definition at line 511 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ type

evxDEPtnType svxDEPattern::type

DE(Direct Edit) pattern type.

Definition at line 479 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::cntSkip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ cntSkip

int svxDEPattern::cntSkip

number of the instances to be skipped

Definition at line 557 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::firstTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ firstTogglePos

int* svxDEPattern::firstTogglePos

the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction)
if type = 1 or 2 or 5 or 6, it can given by user
other type can be null

Definition at line 558 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ idEnts

int* svxDEPattern::idEnts

list id of face entities need to be used DE(Direct Edit) pattern command

Definition at line 481 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ numEnt

int svxDEPattern::numEnt

number of face entities need to be used DE(Direct Edit) pattern command

Definition at line 480 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::secondTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
cntSkip
firstTogglePos
idEnts
numEnt
secondTogglePos
type

◆ secondTogglePos

int* svxDEPattern::secondTogglePos

the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x

Definition at line 561 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDERad Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDERad Struct Reference
Commands Creation » Part and Assembly Commands » Direct Edit Commands Data

part or assembly DE(Direct Edit) modify radius data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Fields

int | numEnt
number of face entities need to be edited radius command More...
int * | idEnts
list id of face entities need to be edited radius command More...
double | R
the edit radius of face.default:1 More...

Detailed Description

part or assembly DE(Direct Edit) modify radius data

Definition at line 602 of file zwapi_cmd_direct_edit_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDERad::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDERad
idEnts
numEnt
R

◆ numEnt

int svxDERad::numEnt

number of face entities need to be edited radius command

Definition at line 604 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDERad::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDERad
idEnts
numEnt
R

◆ R

double svxDERad::R

the edit radius of face.default:1

Definition at line 606 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDERad::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDERad
idEnts
numEnt
R

◆ idEnts

int* svxDERad::idEnts

list id of face entities need to be edited radius command

Definition at line 605 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDWGData Struct Reference
File » File Data

data of export DWG file More...

#include <zwapi_file_data.h>

Data Fields

evxDWGVer Version
version of DWG More...
char | FileType
export type of file. 0-DWG, 1- DFX(ASCLL), 2-DFX(Binary) make sure the file extension type is same with FileType More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
char | ExportLayer
0-All layers, 1- Specified layers More...
int | LayerCnt
the count of export layers if ExportLayer = 1 More...
int * | LayerList
the specified layers id list if ExportLayer = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...
int | ExcludeWidth
filter width type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2 More...
int | ExcludeStyle
filter style type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2 More...
int | ExcludeColor
filter color type(evxExportExcludeColor), like this: VX_EXCLUDE_COLOR_GREEN | VX_EXCLUDE_COLOR_RED More...
int | reduceData
1 if reduce data,else 0.default:1 More...
int | trimSurface
1 if trim surface,else 0.default:1 More...
int | freeSurface
1 if free surface,else 0.default:0 More...
int | mergeArc
1 if merge arc,else 0.default:0 More...
double | tolUVCurve
tolerance of UV curve.default:0.01 More...
double | tolCurve
tolerance of curve.default:0.01 More...
double | tolSurface
tolerance of surface.default:0.01 More...
int | isTrueColor
1 if true color,else 0. More...
int | exportSheetOnly
1 if export active sheet only, else export all sheets(0).default:1 More...
int | toModelSpace
1 if export to model space,else export to layout space(0).default:1 More...
int | individualFiles
1 if export as individual files,else 0.default:0. More...
int | dimStyleByBlock
1 if dimension style by block,else 0.default:0 More...
int | exportShtFmtEnts
1 if export sheet format entities,else 0.default:1 More...
int | drawingView
1 if export as curves, 2 if export as block, else export as block for each component(3).default:1 More...
int | toNewLayer
1 if export to new layer for each part,else 0.default:0. apply it if drawingView=3. More...
double | scale
scale output.default:1 More...
evxRemoveTextFontType textFontType
remove text font info type.default:VX_TEXT_FONT_TYPE_NONE More...
int | explodeHatch
1 if explode hatch as single line,else 0.default:0 More...
int | explodeText
1 if explode text as single line,else 0.default:0 More...

Detailed Description

data of export DWG file

Definition at line 281 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::toNewLayer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ toNewLayer

int svxDWGData::toNewLayer

1 if export to new layer for each part,else 0.default:0. apply it if drawingView=3.

Definition at line 317 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::freeSurface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ freeSurface

int svxDWGData::freeSurface

1 if free surface,else 0.default:0

Definition at line 305 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExcludeColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExcludeColor

int svxDWGData::ExcludeColor

filter color type(evxExportExcludeColor), like this: VX_EXCLUDE_COLOR_GREEN | VX_EXCLUDE_COLOR_RED

Definition at line 301 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::trimSurface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ trimSurface

int svxDWGData::trimSurface

1 if trim surface,else 0.default:1

Definition at line 304 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::tolCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ tolCurve

double svxDWGData::tolCurve

tolerance of curve.default:0.01

Definition at line 308 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::explodeHatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ explodeHatch

int svxDWGData::explodeHatch

1 if explode hatch as single line,else 0.default:0

Definition at line 320 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ EntList

int* svxDWGData::EntList

the specified entities id list if ExportType = 1

Definition at line 289 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::mergeArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ mergeArc

int svxDWGData::mergeArc

1 if merge arc,else 0.default:0

Definition at line 306 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExportLayer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExportLayer

char svxDWGData::ExportLayer

0-All layers, 1- Specified layers

Definition at line 291 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExcludeGeom

int svxDWGData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 295 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExcludeStyle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExcludeStyle

int svxDWGData::ExcludeStyle

filter style type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2

Definition at line 299 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExcludeWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExcludeWidth

int svxDWGData::ExcludeWidth

filter width type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2

Definition at line 297 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::isTrueColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ isTrueColor

int svxDWGData::isTrueColor

1 if true color,else 0.

Definition at line 310 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::exportShtFmtEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ exportShtFmtEnts

int svxDWGData::exportShtFmtEnts

1 if export sheet format entities,else 0.default:1

Definition at line 315 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::tolUVCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ tolUVCurve

double svxDWGData::tolUVCurve

tolerance of UV curve.default:0.01

Definition at line 307 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::exportSheetOnly

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ exportSheetOnly

int svxDWGData::exportSheetOnly

1 if export active sheet only, else export all sheets(0).default:1

Definition at line 311 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::Version

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ Version

evxDWGVer svxDWGData::Version

version of DWG

Definition at line 283 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::dimStyleByBlock

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ dimStyleByBlock

int svxDWGData::dimStyleByBlock

1 if dimension style by block,else 0.default:0

Definition at line 314 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::toModelSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ toModelSpace

int svxDWGData::toModelSpace

1 if export to model space,else export to layout space(0).default:1

Definition at line 312 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ scale

double svxDWGData::scale

scale output.default:1

Definition at line 318 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::individualFiles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ individualFiles

int svxDWGData::individualFiles

1 if export as individual files,else 0.default:0.

Definition at line 313 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ ExportType

char svxDWGData::ExportType

0-All objects, 1-Specified entities

Definition at line 287 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::tolSurface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ tolSurface

double svxDWGData::tolSurface

tolerance of surface.default:0.01

Definition at line 309 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::LayerList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ LayerList

int* svxDWGData::LayerList

the specified layers id list if ExportLayer = 1

Definition at line 293 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::drawingView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ drawingView

int svxDWGData::drawingView

1 if export as curves, 2 if export as block, else export as block for each component(3).default:1

Definition at line 316 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::textFontType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ textFontType

evxRemoveTextFontType svxDWGData::textFontType

remove text font info type.default:VX_TEXT_FONT_TYPE_NONE

Definition at line 319 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::explodeText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ explodeText

int svxDWGData::explodeText

1 if explode text as single line,else 0.default:0

Definition at line 321 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::LayerCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ LayerCnt

int svxDWGData::LayerCnt

the count of export layers if ExportLayer = 1

Definition at line 292 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ EntCnt

int svxDWGData::EntCnt

the count of export entities if ExportType = 1

Definition at line 288 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::reduceData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ reduceData

int svxDWGData::reduceData

1 if reduce data,else 0.default:1

Definition at line 303 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDWGData::FileType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDWGData
dimStyleByBlock
drawingView
EntCnt
EntList
ExcludeColor
ExcludeGeom
ExcludeStyle
ExcludeWidth
explodeHatch
explodeText
ExportLayer
exportSheetOnly
exportShtFmtEnts
ExportType
FileType
freeSurface
individualFiles
isTrueColor
LayerCnt
LayerList
mergeArc
reduceData
scale
textFontType
tolCurve
tolSurface
tolUVCurve
toModelSpace
toNewLayer
trimSurface
Version

◆ FileType

char svxDWGData::FileType

export type of file. 0-DWG, 1- DFX(ASCLL), 2-DFX(Binary) make sure the file extension type is same with FileType

Definition at line 284 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxData Struct Reference
Common » Common Data

command input data item More...

#include <zwapi_util.h>

Data Fields

char | isPoint
1 if "Pnt" is defined, else 0 More...
char | isEntity
1 if "idEntity" is defined, else 0 More...
char | isNumber
1 if "Num" is defined, else 0 More...
char | isDirection
1 if "Dir" is defined, else 0 More...
char | isText
1 if "Text" is defined, else 0 More...
char | isPntOnCrv
1 if point on curve, else 0. idEntity="curve id"; Pnt="point coordinates"; Param[0]="curve t param"; idParent is optional. For cvxPartAlign(), Param[0]="point id" in the control point list. For example, Param[0]=2.0 means using the the third control point. More...
char | isEndPnt
if "isPntOnCrv=1", set this flag to 1 if Param[0] is to be used to identify the closest endpoint on the specified curve (idEntity). More...
char | isPntOnFace
1 if point on face, else 0. idEntity="face id"; Pnt="point coordinates"; Param[0]="u parameter"; Param[1]="v parameter". More...
int | idEntity
entity/object id (0 if undefined) More...
int | idParent
id of parent entity (0 if undefined) More...
evxNumType NumType
numeric input type (input and output) More...
double | Num
numeric value More...
evxPntType PntType
point input type (output only) More...
svxPoint Pnt
point coordinates More...
svxVector Dir
unit direction vector More...
double | Param [3]
pick parameters (i.e. t value or point id) More...
char | Text [512]
text string (expression if "isNumber=1") More...
int | chkRepeatEnt
1 if check whether the input entities are duplicated, else 0.default:0 More...

Detailed Description

command input data item

Examples
part\datumCrtTest.cpp.

Definition at line 1554 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isEndPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isEndPnt

char svxData::isEndPnt

if "isPntOnCrv=1", set this flag to 1 if Param[0] is to be used to identify the closest endpoint on the specified curve (idEntity).

Definition at line 1569 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ Pnt

svxPoint svxData::Pnt

point coordinates

Examples
part\datumCrtTest.cpp.

Definition at line 1583 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isPoint

char svxData::isPoint

1 if "Pnt" is defined, else 0

Examples
part\datumCrtTest.cpp.

Definition at line 1557 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::Param

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ Param

double svxData::Param[3]

pick parameters (i.e. t value or point id)

Definition at line 1585 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::chkRepeatEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ chkRepeatEnt

int svxData::chkRepeatEnt

1 if check whether the input entities are duplicated, else 0.default:0

Definition at line 1587 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isText

char svxData::isText

1 if "Text" is defined, else 0

Definition at line 1561 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::Num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ Num

double svxData::Num

numeric value

Definition at line 1581 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isDirection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isDirection

char svxData::isDirection

1 if "Dir" is defined, else 0

Definition at line 1560 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isPntOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isPntOnCrv

char svxData::isPntOnCrv

1 if point on curve, else 0. idEntity="curve id"; Pnt="point coordinates"; Param[0]="curve t param"; idParent is optional. For cvxPartAlign(), Param[0]="point id" in the control point list. For example, Param[0]=2.0 means using the the third control point.

Definition at line 1562 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::Text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ Text

char svxData::Text[512]

text string (expression if "isNumber=1")

Definition at line 1586 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::NumType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ NumType

evxNumType svxData::NumType

numeric input type (input and output)

Definition at line 1580 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ idParent

int svxData::idParent

id of parent entity (0 if undefined)

Definition at line 1579 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isPntOnFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isPntOnFace

char svxData::isPntOnFace

1 if point on face, else 0. idEntity="face id"; Pnt="point coordinates"; Param[0]="u parameter"; Param[1]="v parameter".

various parameters that may be defined (see the flags above)

Definition at line 1573 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ Dir

svxVector svxData::Dir

unit direction vector

Definition at line 1584 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::PntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ PntType

evxPntType svxData::PntType

point input type (output only)

Definition at line 1582 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::idEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ idEntity

int svxData::idEntity

entity/object id (0 if undefined)

Definition at line 1578 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isNumber

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isNumber

char svxData::isNumber

1 if "Num" is defined, else 0

Definition at line 1559 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxData::isEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxData
chkRepeatEnt
Dir
idEntity
idParent
isDirection
isEndPnt
isEntity
isNumber
isPntOnCrv
isPntOnFace
isPoint
isText
Num
NumType
Param
Pnt
PntType
Text

◆ isEntity

char svxData::isEntity

1 if "idEntity" is defined, else 0

Definition at line 1558 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDatumDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

datum dim data(drawing) More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDatumDimType type
datum type. (note: VX_DATUM_NORMAL as default) More...
char * text
datum label name More...
svxPntOnEnt leadPnt
point coordinate of point on entity. if type = VX_DATUM_NORMAL, leadPnt is the txtPnt's projection on the entity if type = VX_DATUM_ANSI, leadPnt is a point on entity. More...
svxPntOnEnt txtPnt
point coordinate of text placement point. if type = VX_DATUM_NORMAL, txtPnt can be given arbitrarily. if type = VX_DATUM_ANSI, txtPnt is on the parellel or vertical line through leadPnt More...

Detailed Description

datum dim data(drawing)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1232 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumDimData::txtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumDimData
leadPnt
text
txtPnt
type

◆ txtPnt

svxPntOnEnt svxDatumDimData::txtPnt

point coordinate of text placement point. if type = VX_DATUM_NORMAL, txtPnt can be given arbitrarily. if type = VX_DATUM_ANSI, txtPnt is on the parellel or vertical line through leadPnt

Examples
drawing\dwgDimTest.cpp.

Definition at line 1240 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumDimData
leadPnt
text
txtPnt
type

◆ type

evxDatumDimType svxDatumDimData::type

datum type. (note: VX_DATUM_NORMAL as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1234 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumDimData::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumDimData
leadPnt
text
txtPnt
type

◆ text

char* svxDatumDimData::text

datum label name

Examples
drawing\dwgDimTest.cpp.

Definition at line 1236 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumDimData::leadPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumDimData
leadPnt
text
txtPnt
type

◆ leadPnt

svxPntOnEnt svxDatumDimData::leadPnt

point coordinate of point on entity. if type = VX_DATUM_NORMAL, leadPnt is the txtPnt's projection on the entity if type = VX_DATUM_ANSI, leadPnt is a point on entity.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1237 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDatumTargDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

datum target dim data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDatumTargDimType type
datum target type. (Note: VX_DATUMT_POINT as default) More...
svxPntOnEnt pnt
point coordinate of point on entity. More...
svxPntOnEnt textPnt
text point More...
svxPntOnEnt secPnt
2nd point (if type = VX_DATUMT_POINT, secPnt is 2nd point of a line other type can be ignored) More...
double | diameter
diameter (just for type = VX_DATUMT_RECTANGLE, other type can be ignored). if type = VX_DATUMT_RECTANGLE, it is diameter of the circle. More...
double | width
width (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE, it is width of the rectangle More...
double | height
height (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE, it is height of the rectangle More...
char * | text
datum text More...
char * | text2
datum text2 (text2 is valid when text is not empty) More...
char * | text3
datum text3 (text3 is valid when text2 is not empty) More...
int | iAreaSizeText
Area size text (0-Area size, 1-User text, 0 as default): to determine how the upper text of the datum target is generated. More...
char * | userText
user text (userText is valid when iAreaSizeText equals to 1): defines the text that is displayed instead of the actual area information More...

Detailed Description

datum target dim data

Examples
drawing\dwgDimTest.cpp.

Definition at line 1261 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::userText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ userText

char* svxDatumTargDimData::userText

user text (userText is valid when iAreaSizeText equals to 1): defines the text that is displayed instead of the actual area information

Examples
drawing\dwgDimTest.cpp.

Definition at line 1282 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ diameter

double svxDatumTargDimData::diameter

diameter (just for type = VX_DATUMT_RECTANGLE, other type can be ignored). if type = VX_DATUMT_RECTANGLE, it is diameter of the circle.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1271 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::text2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ text2

char* svxDatumTargDimData::text2

datum text2 (text2 is valid when text is not empty)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1278 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::text3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ text3

char* svxDatumTargDimData::text3

datum text3 (text3 is valid when text2 is not empty)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1279 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ text

char* svxDatumTargDimData::text

datum text

Examples
drawing\dwgDimTest.cpp.

Definition at line 1277 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ type

evxDatumTargDimType svxDatumTargDimData::type

datum target type. (Note: VX_DATUMT_POINT as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1263 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ textPnt

svxPntOnEnt svxDatumTargDimData::textPnt

text point

Examples
drawing\dwgDimTest.cpp.

Definition at line 1267 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ width

double svxDatumTargDimData::width

width (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE, it is width of the rectangle

Examples
drawing\dwgDimTest.cpp.

Definition at line 1273 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ height

double svxDatumTargDimData::height

height (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE, it is height of the rectangle

Examples
drawing\dwgDimTest.cpp.

Definition at line 1275 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::iAreaSizeText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ iAreaSizeText

int svxDatumTargDimData::iAreaSizeText

Area size text (0-Area size, 1-User text, 0 as default): to determine how the upper text of the datum target is generated.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1280 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ pnt

svxPntOnEnt svxDatumTargDimData::pnt

point coordinate of point on entity.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1266 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDatumTargDimData::secPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDatumTargDimData
diameter
height
iAreaSizeText
pnt
secPnt
text
text2
text3
textPnt
type
userText
width

◆ secPnt

svxPntOnEnt svxDatumTargDimData::secPnt

2nd point (if type = VX_DATUMT_POINT, secPnt is 2nd point of a line other type can be ignored)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1268 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDimAttr Struct Reference
Common » Common Data

Dimension attributes structure. More...

#include <zwapi_util.h>

Data Fields

char | prefix [32]
dimension prefix More...
char | suffix [32]
dimension suffix More...
char | tolPlus [8]
tolerance plus More...
char | tolMinus [8]
tolerance minus More...
char | fontName [36]
font name More...
int | extLnClr
extension lines color (evxColor) More...
int | dimLnClr
dimension lines color (evxColor) More...
int | dimTxtClr
dimension text color (evxColor) More...
int | symbolClr
symbol color More...
int | valFmt
dimension value text format (1-no tol, 2-limit, 3-unequal tol, 4-equal tol, 5-tol zone, 6-fit tol) More...
int | zeroSupp
zero suppression (1-none, 2-lead, 3-trail, 4-both) More...
int | decPlc
dimension text decimal places More...
double | chHgt
text height More...
double | chAsp
text character aspect ratio More...
double | chLnSpc
text character multi-line spacing More...
double | chSpc
text character spacing ratio More...
double | chSlant
slant angle of text More...
double | tolChHgtFac
tolerance text height scaling factor More...
int | dimTxtOrient
dimension text orientation(>=1) More...
int | LeaderAlign
dimension line (or leader) justification(0-center, 1-top, 2-half, 3-bottom) More...
evxTermType trmTyp1
arrowhead1 type More...
evxTermType trmTyp2
arrowhead2 type More...
int | dimLineSize
dimension line size(1-6) More...
int | extLineSize
extension line size(1-6) More...
int | dimLineType
dimension line type(0-5) More...
int | extLineType
extension line type(0-5) More...
int | dimTxtBold
dim. text bold flag (0-normal, 1-bold) More...
int | dimPrefixFlag
radial, diameter, and chamfer prefix on/off(0-on, 1-off) More...
int | altUnitFlag
1 if use alternate unites, else 0 More...
int | showUnit
show unit,(0-both not, 1-show main dim unit, 2-show unit for alt., 3-both ) More...
int | tolDecPlc
tolerance precision More...
int | altDecPlc
unit precision, if altUnitFlag = 1, apply it More...
int | altTolDecPlc
tolerance precision, if altUnitFlag = 1, apply it More...
evxUnitType altUnitTyp
alternate unit type More...
evxAngUnitType angAltUnitTyp
angular alternate unit type More...
int | suppLeader
1 if suppress the leader, else 0 More...
int | trmSuppFlg1
suppress arrowhead1 flag (0-on, 1-off) More...
int | trmSuppFlg2
suppress arrowhead2 flag (0-on, 1-off) More...
double | trmSize1
arrowhead1 size More...
double | trmSize2
arrowhead2 size More...

Detailed Description

Dimension attributes structure.

Definition at line 2234 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::chLnSpc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ chLnSpc

double svxDimAttr::chLnSpc

text character multi-line spacing

Definition at line 2251 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmTyp2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmTyp2

evxTermType svxDimAttr::trmTyp2

arrowhead2 type

Definition at line 2258 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::tolDecPlc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ tolDecPlc

int svxDimAttr::tolDecPlc

tolerance precision

Definition at line 2267 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::tolChHgtFac

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ tolChHgtFac

double svxDimAttr::tolChHgtFac

tolerance text height scaling factor

Definition at line 2254 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::extLnClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ extLnClr

int svxDimAttr::extLnClr

extension lines color (evxColor)

Definition at line 2241 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::chSlant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ chSlant

double svxDimAttr::chSlant

slant angle of text

Definition at line 2253 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::chAsp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ chAsp

double svxDimAttr::chAsp

text character aspect ratio

Definition at line 2250 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmSize1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmSize1

double svxDimAttr::trmSize1

arrowhead1 size

Definition at line 2275 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::chHgt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ chHgt

double svxDimAttr::chHgt

text height

Definition at line 2249 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimLineType

int svxDimAttr::dimLineType

dimension line type(0-5)

Definition at line 2261 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::showUnit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ showUnit

int svxDimAttr::showUnit

show unit,(0-both not, 1-show main dim unit, 2-show unit for alt., 3-both )

Definition at line 2266 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::decPlc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ decPlc

int svxDimAttr::decPlc

dimension text decimal places

Definition at line 2248 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::altUnitFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ altUnitFlag

int svxDimAttr::altUnitFlag

1 if use alternate unites, else 0

Definition at line 2265 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::altTolDecPlc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ altTolDecPlc

int svxDimAttr::altTolDecPlc

tolerance precision, if altUnitFlag = 1, apply it

Definition at line 2269 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::extLineSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ extLineSize

int svxDimAttr::extLineSize

extension line size(1-6)

Definition at line 2260 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::extLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ extLineType

int svxDimAttr::extLineType

extension line type(0-5)

Definition at line 2262 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::valFmt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ valFmt

int svxDimAttr::valFmt

dimension value text format (1-no tol, 2-limit, 3-unequal tol, 4-equal tol, 5-tol zone, 6-fit tol)

Definition at line 2245 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::suppLeader

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ suppLeader

int svxDimAttr::suppLeader

1 if suppress the leader, else 0

Definition at line 2272 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimTxtClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimTxtClr

int svxDimAttr::dimTxtClr

dimension text color (evxColor)

Definition at line 2243 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmTyp1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmTyp1

evxTermType svxDimAttr::trmTyp1

arrowhead1 type

Definition at line 2257 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimPrefixFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimPrefixFlag

int svxDimAttr::dimPrefixFlag

radial, diameter, and chamfer prefix on/off(0-on, 1-off)

Definition at line 2264 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimTxtBold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimTxtBold

int svxDimAttr::dimTxtBold

dim. text bold flag (0-normal, 1-bold)

Definition at line 2263 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::LeaderAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ LeaderAlign

int svxDimAttr::LeaderAlign

dimension line (or leader) justification(0-center, 1-top, 2-half, 3-bottom)

Definition at line 2256 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ fontName

char svxDimAttr::fontName[36]

font name

Definition at line 2240 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::prefix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ prefix

char svxDimAttr::prefix[32]

dimension prefix

Definition at line 2236 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::altDecPlc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ altDecPlc

int svxDimAttr::altDecPlc

unit precision, if altUnitFlag = 1, apply it

Definition at line 2268 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmSuppFlg2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmSuppFlg2

int svxDimAttr::trmSuppFlg2

suppress arrowhead2 flag (0-on, 1-off)

Definition at line 2274 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::altUnitTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ altUnitTyp

evxUnitType svxDimAttr::altUnitTyp

alternate unit type

Definition at line 2270 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimLnClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimLnClr

int svxDimAttr::dimLnClr

dimension lines color (evxColor)

Definition at line 2242 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::tolMinus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ tolMinus

char svxDimAttr::tolMinus[8]

tolerance minus

Definition at line 2239 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::symbolClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ symbolClr

int svxDimAttr::symbolClr

symbol color

Definition at line 2244 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::suffix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ suffix

char svxDimAttr::suffix[32]

dimension suffix

Definition at line 2237 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmSize2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmSize2

double svxDimAttr::trmSize2

arrowhead2 size

Definition at line 2276 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimLineSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimLineSize

int svxDimAttr::dimLineSize

dimension line size(1-6)

Definition at line 2259 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::zeroSupp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ zeroSupp

int svxDimAttr::zeroSupp

zero suppression (1-none, 2-lead, 3-trail, 4-both)

Definition at line 2247 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::angAltUnitTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ angAltUnitTyp

evxAngUnitType svxDimAttr::angAltUnitTyp

angular alternate unit type

Definition at line 2271 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::chSpc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ chSpc

double svxDimAttr::chSpc

text character spacing ratio

Definition at line 2252 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::tolPlus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ tolPlus

char svxDimAttr::tolPlus[8]

tolerance plus

Definition at line 2238 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::dimTxtOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ dimTxtOrient

int svxDimAttr::dimTxtOrient

dimension text orientation(>=1)

Definition at line 2255 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAttr::trmSuppFlg1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAttr
altDecPlc
altTolDecPlc
altUnitFlag
altUnitTyp
angAltUnitTyp
chAsp
chHgt
chLnSpc
chSlant
chSpc
decPlc
dimLineSize
dimLineType
dimLnClr
dimPrefixFlag
dimTxtBold
dimTxtClr
dimTxtOrient
extLineSize
extLineType
extLnClr
fontName
LeaderAlign
prefix
showUnit
suffix
suppLeader
symbolClr
tolChHgtFac
tolDecPlc
tolMinus
tolPlus
trmSize1
trmSize2
trmSuppFlg1
trmSuppFlg2
trmTyp1
trmTyp2
valFmt
zeroSupp

◆ trmSuppFlg1

int svxDimAttr::trmSuppFlg1

suppress arrowhead1 flag (0-on, 1-off)

Definition at line 2273 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDimAuto Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

auto dimension More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
index of View More...
evxAutoEntType entType
select entity type, default value:DIM_AUTO_ENT_ALL More...
int | cntEnt
entity ID count. if type = DIM_AUTO_ENT_PICKED, number of entities need to be created dimension, other type can be null More...
int * | pEntId
entity ID list. if type = DIM_AUTO_ENT_PICKED, list id of entities need to be created dimension, other type can be null More...
unsigned int | incAuto
evxAutoInclude mask. whether to include arc, circle, hole, line, R/hole callout, cylindrical dimensions and maximum dimensions(0 = no, 1 = yes) More...
int | checkOrg
origin check flag, default value:1 More...
svxPntOnEnt pntOrg
origin reference point, member critPnt should be entity critical point More...
svxAutoSet horDim
horizontal dimensions position/placement More...
svxAutoSet verDim
vertical dimensions position/placement More...

Detailed Description

auto dimension

Examples
drawing\dwgDimTest.cpp.

Definition at line 692 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ cntEnt

int svxDimAuto::cntEnt

entity ID count. if type = DIM_AUTO_ENT_PICKED, number of entities need to be created dimension, other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 696 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ idView

int svxDimAuto::idView

index of View

Examples
drawing\dwgDimTest.cpp.

Definition at line 694 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::checkOrg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ checkOrg

int svxDimAuto::checkOrg

origin check flag, default value:1

Examples
drawing\dwgDimTest.cpp.

Definition at line 705 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::horDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ horDim

svxAutoSet svxDimAuto::horDim

horizontal dimensions position/placement

Examples
drawing\dwgDimTest.cpp.

Definition at line 707 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::verDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ verDim

svxAutoSet svxDimAuto::verDim

vertical dimensions position/placement

Examples
drawing\dwgDimTest.cpp.

Definition at line 708 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::entType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ entType

evxAutoEntType svxDimAuto::entType

select entity type, default value:DIM_AUTO_ENT_ALL

Examples
drawing\dwgDimTest.cpp.

Definition at line 695 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::pEntId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ pEntId

int* svxDimAuto::pEntId

entity ID list. if type = DIM_AUTO_ENT_PICKED, list id of entities need to be created dimension, other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 699 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::pntOrg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ pntOrg

svxPntOnEnt svxDimAuto::pntOrg

origin reference point, member critPnt should be entity critical point

Examples
drawing\dwgDimTest.cpp.

Definition at line 706 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimAuto::incAuto

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimAuto
checkOrg
cntEnt
entType
horDim
idView
incAuto
pEntId
pntOrg
verDim

◆ incAuto

unsigned int svxDimAuto::incAuto

evxAutoInclude mask. whether to include arc, circle, hole, line, R/hole callout, cylindrical dimensions and maximum dimensions(0 = no, 1 = yes)

Examples
drawing\dwgDimTest.cpp.

Definition at line 702 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDimLabel Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Label. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | localPntCnt
localPnts list count More...
svxPntOnEnt * localPnts
localPnts info: specify the location of the arrow More...
int | leadPntCnt
leadPnts list count More...
svxPntOnEnt * leadPnts
leadPnts info: locate where additional leader arrow will point More...
char * | text
text content to be shown More...

Detailed Description

Label.

Definition at line 1067 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimLabel
leadPntCnt
leadPnts
localPntCnt
localPnts
text

◆ text

char* svxDimLabel::text

text content to be shown

Definition at line 1073 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel::localPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimLabel
leadPntCnt
leadPnts
localPntCnt
localPnts
text

◆ localPnts

svxPntOnEnt* svxDimLabel::localPnts

localPnts info: specify the location of the arrow

Definition at line 1070 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel::leadPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimLabel
leadPntCnt
leadPnts
localPntCnt
localPnts
text

◆ leadPnts

svxPntOnEnt* svxDimLabel::leadPnts

leadPnts info: locate where additional leader arrow will point

Definition at line 1072 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel::localPntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimLabel
leadPntCnt
leadPnts
localPntCnt
localPnts
text

◆ localPntCnt

int svxDimLabel::localPntCnt

localPnts list count

Definition at line 1069 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimLabel::leadPntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimLabel
leadPntCnt
leadPnts
localPntCnt
localPnts
text

◆ leadPntCnt

int svxDimLabel::leadPntCnt

leadPnts list count

Definition at line 1071 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDimpleData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

dimple data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | dimpleType
dimple type (0 = Plain Dimple, 1 = Flared Hole) More...
int | idPlane
id of planar face to place the dimple More...
int | idProfile
id of sketch defining the dimple perimeter, the sketch must be a closed sketch with one or more tangent continuous loops More...
int | notSew
flag whether sew shapes or not. 0 = to sew (default)
since R2024, it doesn't sew the new shapes and if user set it to 0, it will create a 'Sew' feature to sew the shapes More...
int | numShapes
number of shapes to sew More...
int * | idShapes
list of id's of shapes to sew More...
double | height
height measured from the selected face to the outside face of the dimple More...
double | angle
the side angle measured from the selected face More...
double | radius1
inner radius around the perimeter height of the dimple More...
double | radius2
outer radius around the perimeter of the dimple and tangent to the selected face More...
double | radius3
the outer fillet radius of the outside wall (default:1.0, 0.0-disable) doesn't use if dimpleType = 1 More...
int | flipFlange
1-flip the normal direction of the plane where the dimple is placed, else 0 (default:0) More...
int | prfOnDimpleTop
1-the top of the dimple is the size of the outline, and the bottom changes with the angle; 0-the bottom of the dimple is the size of the contour, and the top changes with the angle (default:1) More...
evxDimplePostion postion
postion type (default: VX_MATERIAL_OUTSIDE) dimpleType = 1, VX_BEND_OUTSIDE does not contain More...
vxName ftrName
feature name for "SmdDimple", 0 default More...

Detailed Description

dimple data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1123 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::prfOnDimpleTop

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ prfOnDimpleTop

int svxDimpleData::prfOnDimpleTop

1-the top of the dimple is the size of the outline, and the bottom changes with the angle; 0-the bottom of the dimple is the size of the contour, and the top changes with the angle (default:1)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1143 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ ftrName

vxName svxDimpleData::ftrName

feature name for "SmdDimple", 0 default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1149 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ numShapes

int svxDimpleData::numShapes

number of shapes to sew

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1132 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::radius3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ radius3

double svxDimpleData::radius3

the outer fillet radius of the outside wall (default:1.0, 0.0-disable) doesn't use if dimpleType = 1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1139 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ radius1

double svxDimpleData::radius1

inner radius around the perimeter height of the dimple

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1137 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::dimpleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ dimpleType

int svxDimpleData::dimpleType

dimple type (0 = Plain Dimple, 1 = Flared Hole)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1125 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ height

double svxDimpleData::height

height measured from the selected face to the outside face of the dimple

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1135 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::flipFlange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ flipFlange

int svxDimpleData::flipFlange

1-flip the normal direction of the plane where the dimple is placed, else 0 (default:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1142 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::postion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ postion

evxDimplePostion svxDimpleData::postion

postion type (default: VX_MATERIAL_OUTSIDE) dimpleType = 1, VX_BEND_OUTSIDE does not contain

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1146 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ idProfile

int svxDimpleData::idProfile

id of sketch defining the dimple perimeter, the sketch must be a closed sketch with one or more tangent continuous loops

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1127 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ angle

double svxDimpleData::angle

the side angle measured from the selected face

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1136 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ idPlane

int svxDimpleData::idPlane

id of planar face to place the dimple

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1126 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ idShapes

int* svxDimpleData::idShapes

list of id's of shapes to sew

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1133 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ radius2

double svxDimpleData::radius2

outer radius around the perimeter of the dimple and tangent to the selected face

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1138 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDimpleData::notSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDimpleData
angle
dimpleType
flipFlange
ftrName
height
idPlane
idProfile
idShapes
notSew
numShapes
postion
prfOnDimpleTop
radius1
radius2
radius3

◆ notSew

int svxDimpleData::notSew

flag whether sew shapes or not. 0 = to sew (default)
since R2024, it doesn't sew the new shapes and if user set it to 0, it will create a 'Sew' feature to sew the shapes

Definition at line 1130 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDirOnEntPath Struct Reference
Common » Common Data

direction of point on entity path definition, also can use to set a dynamic direction More...

#include <zwapi_util.h>

Data Fields

svxEntPath entPath
entity path that defines the direction More...
evxDirType dirType
direction type, only used when entPath is a curve and not a circle or face More...
svxPoint pnt
point coordinates, only used when entPath is a face and dirType is VX_PNT_DIR More...
svxVector dir
direction, only used when entPath is a invalid path (svxEntPath.Count < 2) More...
int flipDir
whether to flip direction (1 to flip, else 0). enable when the direction control support flip the direction More...

Detailed Description

direction of point on entity path definition, also can use to set a dynamic direction

Examples
part\partUtils.cpp.

Definition at line 589 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath::entPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDirOnEntPath
dir
dirType
entPath
flipDir
pnt

◆ entPath

svxEntPath svxDirOnEntPath::entPath

entity path that defines the direction

Examples
part\partUtils.cpp.

Definition at line 591 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath::dirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDirOnEntPath
dir
dirType
entPath
flipDir
pnt

◆ dirType

evxDirType svxDirOnEntPath::dirType

direction type, only used when entPath is a curve and not a circle or face

Examples
part\partUtils.cpp.

Definition at line 592 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath::flipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDirOnEntPath
dir
dirType
entPath
flipDir
pnt

◆ flipDir

int svxDirOnEntPath::flipDir

whether to flip direction (1 to flip, else 0). enable when the direction control support flip the direction

Examples
part\partUtils.cpp.

Definition at line 595 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDirOnEntPath
dir
dirType
entPath
flipDir
pnt

◆ pnt

svxPoint svxDirOnEntPath::pnt

point coordinates, only used when entPath is a face and dirType is VX_PNT_DIR

Definition at line 593 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDirOnEntPath::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDirOnEntPath
dir
dirType
entPath
flipDir
pnt

◆ dir

svxVector svxDirOnEntPath::dir

direction, only used when entPath is a invalid path (svxEntPath.Count < 2)

Examples
part\partUtils.cpp.

Definition at line 594 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDivideData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

divide data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numBase
number of shapes to divide More...
int * | idBase
id list of shape to divide More...
int | numCutter
number of dividing entities More...
int * | idCutters
list of dividing entities (shape, face, datum plane) More...
int | keepCutter
whether to keep dividing entities (0 = delete, 1 = keep, 2 = divide) More...
int | trimCap
whether to cap shape at the trimmed edges (1 = cap, 0 = uncap) More...
int | extend
extend method (1 = no extend, 0 = linear, 2 = circular) More...
vxName ftrName
feature name for "FtSolidSoloDiv", 0 default More...

Detailed Description

divide data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1067 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::keepCutter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ keepCutter

int svxDivideData::keepCutter

whether to keep dividing entities (0 = delete, 1 = keep, 2 = divide)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1075 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::numCutter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ numCutter

int svxDivideData::numCutter

number of dividing entities

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1071 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::trimCap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ trimCap

int svxDivideData::trimCap

whether to cap shape at the trimmed edges (1 = cap, 0 = uncap)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1076 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::extend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ extend

int svxDivideData::extend

extend method (1 = no extend, 0 = linear, 2 = circular)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1077 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::idCutters

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ idCutters

int* svxDivideData::idCutters

list of dividing entities (shape, face, datum plane)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1072 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::idBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ idBase

int* svxDivideData::idBase

id list of shape to divide

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1070 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ ftrName

vxName svxDivideData::ftrName

feature name for "FtSolidSoloDiv", 0 default

Definition at line 1079 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDivideData::numBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDivideData
extend
ftrName
idBase
idCutters
keepCutter
numBase
numCutter
trimCap

◆ numBase

int svxDivideData::numBase

number of shapes to divide

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1069 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDocActionParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDocActionParam Struct Reference
File » File Data

file action parameters More...

#include <zwapi_file_data.h>

Data Fields

int(* | pfn )(void *, const char *, const char *)
callback function. when set a callback for a file action,
this parameter should be a valid function pointer, to cancel the callback, this parameter should be NULL. More...
void * | param
parameter passed to pfn, if no need to pass parameters,
it should be NULL More...

Detailed Description

file action parameters

Definition at line 723 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDocActionParam::pfn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDocActionParam
param
pfn

◆ pfn

int(* svxDocActionParam::pfn) (void *, const char *, const char *)

callback function. when set a callback for a file action,
this parameter should be a valid function pointer, to cancel the callback, this parameter should be NULL.

Definition at line 725 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDocActionParam::param

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDocActionParam
param
pfn

◆ param

void* svxDocActionParam::param

parameter passed to pfn, if no need to pass parameters,
it should be NULL

Definition at line 728 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxDraftData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

template command Draft data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

union svxDraftStationaryEnt
Stationary Entity such as Faces and Edges. More...

Data Fields

evxDraftMethods Methods
Draft Methods. More...
evxDraftType Type
Draft Type in options can be picked. More...
int | iCntDataList
Picked Entity count will be filled in list. More...
int * | idEnt
List of picked Entity id. More...
double | AngleA1
Angle A1, if only one angle it is also Angle A. More...
double | AngleA2
Angle A2. More...
union svxDraftData::svxDraftStationaryEnt | StationEnt
svxVector DirP
Direction P. More...
int | DraftSideS
Draft Side S (0 = split, 1 = top, 2 = bottom, 3 = neutral, 0 for default) More...
int | Extention
Extention type (0 = linear, 1 = circular, 2 = Reflect, 3 = curvature diminishing, 0 for default) More...
int | iIsrecomputeflt
Whether to recompute fillets (0 = no, 1 = yes, 0 for default) More...
int | iIntersections
Whether to remove intersections (0 = do not remove, 1 = remove all, 0 for default) More...
int | iIsRemivtrgns
Whether to remove inverted regions (0 = no, 1 = yes, 1 for default) More...

Detailed Description

template command Draft data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 561 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationAndPrtingFace
Data Fields
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace Struct Reference

Stationary faces and Parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType) More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int * | StationaryFaces2
List of stationary faces in STATION_PARTING_FACE_DRAFT(evxDraftType) More...
int | cntStaFaces2
Stationary faces cnt. More...
int * | PartingFaces
List of parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType) More...
int | cntPrtFaces
Parting faces cnt. More...

Detailed Description

Stationary faces and Parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType)

<

Definition at line 578 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntPrtFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationAndPrtingFace
cntPrtFaces
cntStaFaces2
PartingFaces
StationaryFaces2

◆ cntPrtFaces

int svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntPrtFaces

Parting faces cnt.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 583 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::StationaryFaces2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationAndPrtingFace
cntPrtFaces
cntStaFaces2
PartingFaces
StationaryFaces2

◆ StationaryFaces2

int* svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::StationaryFaces2

List of stationary faces in STATION_PARTING_FACE_DRAFT(evxDraftType)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 580 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntStaFaces2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationAndPrtingFace
cntPrtFaces
cntStaFaces2
PartingFaces
StationaryFaces2

◆ cntStaFaces2

int svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntStaFaces2

Stationary faces cnt.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 581 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::PartingFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationAndPrtingFace
cntPrtFaces
cntStaFaces2
PartingFaces
StationaryFaces2

◆ PartingFaces

int* svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::PartingFaces

List of parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 582 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryFaces Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryFaces
Data Fields
svxDraftData::svxDraftStationaryEnt::StationaryFaces Struct Reference

Stationary faces in STATION_SYM_FACE_DRAFT(evxDraftType) and STATION_ASYM_FACE_DRAFT(evxDraftType) More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | cnt
Stationary Faces count. More...
int * | idEnt
List of stationary Faces id. More...

Detailed Description

Stationary faces in STATION_SYM_FACE_DRAFT(evxDraftType) and STATION_ASYM_FACE_DRAFT(evxDraftType)

<

Definition at line 572 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryFaces::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryFaces
cnt
idEnt

◆ cnt

int svxDraftData::svxDraftStationaryEnt::StationaryFaces::cnt

Stationary Faces count.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 574 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryFaces::idEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryFaces
cnt
idEnt

◆ idEnt

int* svxDraftData::svxDraftStationaryEnt::StationaryFaces::idEnt

List of stationary Faces id.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 575 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryPlane Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryPlane
Data Fields
svxDraftData::svxDraftStationaryEnt::StationaryPlane Struct Reference

Stationary plane in PRATING_EDGE_DRAFT(evxDraftMethods) More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | cnt
Stationary Plane count. More...
int * | idEnt
List of stationary Plane id. More...

Detailed Description

Stationary plane in PRATING_EDGE_DRAFT(evxDraftMethods)

<

Definition at line 586 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryPlane::idEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryPlane
cnt
idEnt

◆ idEnt

int* svxDraftData::svxDraftStationaryEnt::StationaryPlane::idEnt

List of stationary Plane id.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 589 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt::StationaryPlane::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
  • StationaryPlane
cnt
idEnt

◆ cnt

int svxDraftData::svxDraftStationaryEnt::StationaryPlane::cnt

Stationary Plane count.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 588 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::Methods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ Methods

evxDraftMethods svxDraftData::Methods

Draft Methods.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 563 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::iCntDataList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ iCntDataList

int svxDraftData::iCntDataList

Picked Entity count will be filled in list.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 565 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::AngleA2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ AngleA2

double svxDraftData::AngleA2

Angle A2.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 568 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::DirP

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ DirP

svxVector svxDraftData::DirP

Direction P.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 593 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::iIsRemivtrgns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ iIsRemivtrgns

int svxDraftData::iIsRemivtrgns

Whether to remove inverted regions (0 = no, 1 = yes, 1 for default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 598 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::idEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ idEnt

int* svxDraftData::idEnt

List of picked Entity id.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 566 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::AngleA1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ AngleA1

double svxDraftData::AngleA1

Angle A1, if only one angle it is also Angle A.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 567 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::DraftSideS

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ DraftSideS

int svxDraftData::DraftSideS

Draft Side S (0 = split, 1 = top, 2 = bottom, 3 = neutral, 0 for default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 594 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ Type

evxDraftType svxDraftData::Type

Draft Type in options can be picked.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 564 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::iIntersections

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ iIntersections

int svxDraftData::iIntersections

Whether to remove intersections (0 = do not remove, 1 = remove all, 0 for default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 597 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::iIsrecomputeflt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ iIsrecomputeflt

int svxDraftData::iIsrecomputeflt

Whether to recompute fillets (0 = no, 1 = yes, 0 for default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 596 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::Extention

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
AngleA1
AngleA2
DirP
DraftSideS
Extention
iCntDataList
idEnt
iIntersections
iIsrecomputeflt
iIsRemivtrgns
Methods
Type

◆ Extention

int svxDraftData::Extention

Extention type (0 = linear, 1 = circular, 2 = Reflect, 3 = curvature diminishing, 0 for default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 595 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDrawingAt Struct Reference
Drawing Objects » Drawing Data

Sheet Format Attributes structure. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName templateName
template name More...
int | idDwgTpl
0 to ignore this.
If there are multiple drawing pages in the template file of a drawing and user want to use the specified drawing as the template, user should use the id of the corresponding drawing.
Because the ZW3D platform does not support specifying sheet in drawing template temporarily, this parameter can only be used for setting.
The value of this variable cannot be obtained through the corresponding interface. More...
vxLongName configName
configuration name for drawing format More...
char | paper [16]
paper size name More...
char | useTemplate
1-use template,0-use custom More...
char | useConfig
1-use config,else 0 More...
double | width
drawing width More...
double | height
drawing height More...
char | useBorder
1: use border created by the parameters,else 0 More...
double | margin [4]
margin[0] the margin of the top;
margin[1] the margin of the right;
margin[2] the margin of the bottom;
margin[3] the margin of the left; More...
char | bound
0: no bound line;1: have bound line More...
char | centerMark
0: have no centering marks;1: have centering marks More...
char | partition
0: do not divide the border, 1: divide the border More...
int | partNum [2]
partNum[0]: the number of the partitions in the direction of horizontal; partNum[1]: the number of the partitions in the direction of vertical; More...
char | trimmingMark
0: no trimming mark; 1:have trimming mark; More...
vxLongName | blockTemplateName [3]
template name of drawing block,
blockTemplateName[0]: template name of title block,
blockTemplateName[1]: template name of additional list block,
blockTemplateName[2]: template name of code list block More...

Detailed Description

Sheet Format Attributes structure.

Definition at line 32 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::configName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ configName

vxLongName svxDrawingAt::configName

configuration name for drawing format

Definition at line 42 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ width

double svxDrawingAt::width

drawing width

Definition at line 46 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::blockTemplateName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ blockTemplateName

vxLongName svxDrawingAt::blockTemplateName[3]

template name of drawing block,
blockTemplateName[0]: template name of title block,
blockTemplateName[1]: template name of additional list block,
blockTemplateName[2]: template name of code list block

Definition at line 59 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::idDwgTpl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ idDwgTpl

int svxDrawingAt::idDwgTpl

0 to ignore this.
If there are multiple drawing pages in the template file of a drawing and user want to use the specified drawing as the template, user should use the id of the corresponding drawing.
Because the ZW3D platform does not support specifying sheet in drawing template temporarily, this parameter can only be used for setting.
The value of this variable cannot be obtained through the corresponding interface.

Definition at line 35 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::margin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ margin

double svxDrawingAt::margin[4]

margin[0] the margin of the top;
margin[1] the margin of the right;
margin[2] the margin of the bottom;
margin[3] the margin of the left;

Definition at line 49 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::useTemplate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ useTemplate

char svxDrawingAt::useTemplate

1-use template,0-use custom

Definition at line 44 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::trimmingMark

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ trimmingMark

char svxDrawingAt::trimmingMark

0: no trimming mark; 1:have trimming mark;

Definition at line 58 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::partNum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ partNum

int svxDrawingAt::partNum[2]

partNum[0]: the number of the partitions in the direction of horizontal; partNum[1]: the number of the partitions in the direction of vertical;

Definition at line 56 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ height

double svxDrawingAt::height

drawing height

Definition at line 47 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::useConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ useConfig

char svxDrawingAt::useConfig

1-use config,else 0

Definition at line 45 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::templateName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ templateName

vxLongName svxDrawingAt::templateName

template name

Definition at line 34 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::centerMark

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ centerMark

char svxDrawingAt::centerMark

0: have no centering marks;1: have centering marks

Definition at line 54 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::partition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ partition

char svxDrawingAt::partition

0: do not divide the border, 1: divide the border

Definition at line 55 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::bound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ bound

char svxDrawingAt::bound

0: no bound line;1: have bound line

Definition at line 53 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::paper

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ paper

char svxDrawingAt::paper[16]

paper size name

Definition at line 43 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDrawingAt::useBorder

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDrawingAt
blockTemplateName
bound
centerMark
configName
height
idDwgTpl
margin
paper
partition
partNum
templateName
trimmingMark
useBorder
useConfig
useTemplate
width

◆ useBorder

char svxDrawingAt::useBorder

1: use border created by the parameters,else 0

Definition at line 48 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgAngDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Angular dimension dim data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxAngDimType type
Angular or diametric type. More...
svxPntOnEnt Curve1
get one entity and point coordinate.
if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2nd curve.
if type = VX_ANG_HORIZONTAL, the angle is between 1st curve and horizontal line.
if type = VX_ANG_VERTICAL, the angle is between 1st curve and vertical line.
other type can be null More...
svxPntOnEnt Curve2
get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2nd curve. other can be null More...
svxPntOnEnt StartPnt
start point. if type = VX_ANG_THREEPOINT, the angle is between two line, 1st line through. StartPnt and BasePnt. other type can be null. More...
svxPntOnEnt BasePnt
base point. if type = VX_ANG_THREEPOINT, BasePnt is angle's vertex. other type can be null. More...
svxPntOnEnt EndPnt
end point. if type = VX_ANG_THREEPOINT, the angle is between two line, 2nd line through. BasePnt and EndPnt. other type can be null More...
svxPntOnEnt ArcPnt
arc point on arc. if type = VX_ANG_ARC, the angle is arc's angle. other type can be null More...
svxPntOnEnt QuadrantPnt
quadrant point. if type != VX_ANG_ARC, the point is position of text of angle. More...
svxPntOnEnt txtPnt
text point. if type = VX_ANG_ARC, the point is position of text of angle. other type can be null More...

Detailed Description

Angular dimension dim data.

Examples
drawing\dwgDimTest.cpp.

Definition at line 885 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ type

evxAngDimType svxDwgAngDimData::type

Angular or diametric type.

Examples
drawing\dwgDimTest.cpp.

Definition at line 887 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::ArcPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ ArcPnt

svxPntOnEnt svxDwgAngDimData::ArcPnt

arc point on arc. if type = VX_ANG_ARC, the angle is arc's angle. other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 908 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::Curve1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ Curve1

svxPntOnEnt svxDwgAngDimData::Curve1

get one entity and point coordinate.
if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2nd curve.
if type = VX_ANG_HORIZONTAL, the angle is between 1st curve and horizontal line.
if type = VX_ANG_VERTICAL, the angle is between 1st curve and vertical line.
other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 889 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::QuadrantPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ QuadrantPnt

svxPntOnEnt svxDwgAngDimData::QuadrantPnt

quadrant point. if type != VX_ANG_ARC, the point is position of text of angle.

Examples
drawing\dwgDimTest.cpp.

Definition at line 911 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::BasePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ BasePnt

svxPntOnEnt svxDwgAngDimData::BasePnt

base point. if type = VX_ANG_THREEPOINT, BasePnt is angle's vertex. other type can be null.

Examples
drawing\dwgDimTest.cpp.

Definition at line 901 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::StartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ StartPnt

svxPntOnEnt svxDwgAngDimData::StartPnt

start point. if type = VX_ANG_THREEPOINT, the angle is between two line, 1st line through. StartPnt and BasePnt. other type can be null.

Examples
drawing\dwgDimTest.cpp.

Definition at line 897 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::txtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ txtPnt

svxPntOnEnt svxDwgAngDimData::txtPnt

text point. if type = VX_ANG_ARC, the point is position of text of angle. other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 913 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::EndPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ EndPnt

svxPntOnEnt svxDwgAngDimData::EndPnt

end point. if type = VX_ANG_THREEPOINT, the angle is between two line, 2nd line through. BasePnt and EndPnt. other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 904 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAngDimData::Curve2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAngDimData
ArcPnt
BasePnt
Curve1
Curve2
EndPnt
QuadrantPnt
StartPnt
txtPnt
type

◆ Curve2

svxPntOnEnt svxDwgAngDimData::Curve2

get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2nd curve. other can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 894 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgArcDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgArcDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Arc dimension dim data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxPntOnEnt ArcEnt
get arc one entity More...
svxPntOnEnt txtPnt
text point : specify the location of the dimension text. More...

Detailed Description

Arc dimension dim data.

Examples
drawing\dwgDimTest.cpp.

Definition at line 955 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgArcDimData::ArcEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgArcDimData
ArcEnt
txtPnt

◆ ArcEnt

svxPntOnEnt svxDwgArcDimData::ArcEnt

get arc one entity

Examples
drawing\dwgDimTest.cpp.

Definition at line 957 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgArcDimData::txtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgArcDimData
ArcEnt
txtPnt

◆ txtPnt

svxPntOnEnt svxDwgArcDimData::txtPnt

text point : specify the location of the dimension text.

Examples
drawing\dwgDimTest.cpp.

Definition at line 958 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgAtBlnData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Information of creating auto balloon. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | viewIdCnt
count of view id More...
int * | viewIdList
list of view id More...
evxDwgAtBlnInsTyp instOpt
instances type (note: VX_ATBLNINS_IGNMULINS as default) More...
evxDwgAtBlnPtnType ptnType
pattern type (note: VX_ATBLNPAT_CONVEXHULL as default) More...
evxDwgAtBlnLeadAttach leadAttach
leader attachment (note: VX_ATBLNLEAATT_EDAGES as default) More...
vxUint32 offSet
specify the offset More...
evxDwgAtBlnSkpSd skipSides
prevent placing balloon labels along one side of the view. Be unusable when ptnType is VX_ATBLNPAT_CIRCULAR (note: VX_ATBLNSKPSD_NONE as default). More...
evxDwgAtBlnArrg arrangement
how the balloon labels will be arranged around the layout view. Used when have bom in sheeting, but must be initialized any time. (note: VX_ATBLNARR_NEAREST as default) More...
int | KepItem
flag of keeping item (0 no, else yes), Used when arrangement is not VX_ATBLLNARR_NEAREST. (note: 0 as default) More...
int | ItemId
index of the kept curve,used when KepItem is not 0. More...
int | OnlyBom
Whether the excluded components from BOM should be labeled. Used when have bom in sheeting. (0 no, else yes. Note: 1 as default) More...
int | OnlyWithoutBln
Whether label the components which are not labeled in any other views to eliminate duplicate balloons. Used when OnlyBom is not 0. (0 no, else yes. Note: 0 as default) More...

Detailed Description

Information of creating auto balloon.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1150 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::KepItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ KepItem

int svxDwgAtBlnData::KepItem

flag of keeping item (0 no, else yes), Used when arrangement is not VX_ATBLLNARR_NEAREST. (note: 0 as default)

Definition at line 1167 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::OnlyBom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ OnlyBom

int svxDwgAtBlnData::OnlyBom

Whether the excluded components from BOM should be labeled. Used when have bom in sheeting. (0 no, else yes. Note: 1 as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1170 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::viewIdCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ viewIdCnt

int svxDwgAtBlnData::viewIdCnt

count of view id

Examples
drawing\dwgDimTest.cpp.

Definition at line 1152 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::ptnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ ptnType

evxDwgAtBlnPtnType svxDwgAtBlnData::ptnType

pattern type (note: VX_ATBLNPAT_CONVEXHULL as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1156 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::leadAttach

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ leadAttach

evxDwgAtBlnLeadAttach svxDwgAtBlnData::leadAttach

leader attachment (note: VX_ATBLNLEAATT_EDAGES as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1158 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::viewIdList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ viewIdList

int* svxDwgAtBlnData::viewIdList

list of view id

Examples
drawing\dwgDimTest.cpp.

Definition at line 1153 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::offSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ offSet

vxUint32 svxDwgAtBlnData::offSet

specify the offset

Examples
drawing\dwgDimTest.cpp.

Definition at line 1160 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::instOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ instOpt

evxDwgAtBlnInsTyp svxDwgAtBlnData::instOpt

instances type (note: VX_ATBLNINS_IGNMULINS as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1154 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::skipSides

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ skipSides

evxDwgAtBlnSkpSd svxDwgAtBlnData::skipSides

prevent placing balloon labels along one side of the view. Be unusable when ptnType is VX_ATBLNPAT_CIRCULAR (note: VX_ATBLNSKPSD_NONE as default).

Examples
drawing\dwgDimTest.cpp.

Definition at line 1161 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::arrangement

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ arrangement

evxDwgAtBlnArrg svxDwgAtBlnData::arrangement

how the balloon labels will be arranged around the layout view. Used when have bom in sheeting, but must be initialized any time. (note: VX_ATBLNARR_NEAREST as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1164 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::ItemId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ ItemId

int svxDwgAtBlnData::ItemId

index of the kept curve,used when KepItem is not 0.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1169 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgAtBlnData::OnlyWithoutBln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgAtBlnData
arrangement
instOpt
ItemId
KepItem
leadAttach
offSet
OnlyBom
OnlyWithoutBln
ptnType
skipSides
viewIdCnt
viewIdList

◆ OnlyWithoutBln

int svxDwgAtBlnData::OnlyWithoutBln

Whether label the components which are not labeled in any other views to eliminate duplicate balloons. Used when OnlyBom is not 0. (0 no, else yes. Note: 0 as default)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1172 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgBalloonDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Balloon. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxBalloonCon condition
Text condition, default value:VX_BALLOON_CON_ID. More...
char * | text
text string More...
int | cntCrv
no. of Location data items More...
svxPntOnEnt * Points
list of "cntCrv" points More...
int | cntlead
no. of Lead pnts data items: to locate where additional leader arrows will point More...
svxPntOnEnt * leadPoints
list of "cntlead" points More...

Detailed Description

Balloon.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1080 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ cntCrv

int svxDwgBalloonDim::cntCrv

no. of Location data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 1084 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::leadPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ leadPoints

svxPntOnEnt* svxDwgBalloonDim::leadPoints

list of "cntlead" points

Examples
drawing\dwgDimTest.cpp.

Definition at line 1087 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ text

char* svxDwgBalloonDim::text

text string

Examples
drawing\dwgDimTest.cpp.

Definition at line 1083 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ Points

svxPntOnEnt* svxDwgBalloonDim::Points

list of "cntCrv" points

Examples
drawing\dwgDimTest.cpp.

Definition at line 1085 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::condition

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ condition

evxBalloonCon svxDwgBalloonDim::condition

Text condition, default value:VX_BALLOON_CON_ID.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1082 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBalloonDim::cntlead

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBalloonDim
cntCrv
cntlead
condition
leadPoints
Points
text

◆ cntlead

int svxDwgBalloonDim::cntlead

no. of Lead pnts data items: to locate where additional leader arrows will point

Examples
drawing\dwgDimTest.cpp.

Definition at line 1086 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgBom Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

BOM table data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
id of View More...
char * | name
name More...
evxLevelSet level
Level Setting, default value:VX_TOP_LEVEL_ONLY. More...
evxIndentedType indent
Indented type(default value:VX_DETAILED_NUM): to define how to number the components from the sub-assembly. More...
int | checkMax
whether to use Max traverse depth: 0(default value) no, else yes More...
int | Maxdepthval
Max traverse depth value(default value:1): to define which assembly level BOM should read out up to. More...
int | bomset
Settings by evxBomset, default value:VX_DERIVED_PARTS. More...
int | startID
starting ID, default value:1 More...
evxOrderType order
Order, default value:VX_ORDER_BYNAME. More...

Detailed Description

BOM table data.

Definition at line 543 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::order

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ order

evxOrderType svxDwgBom::order

Order, default value:VX_ORDER_BYNAME.

Definition at line 553 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::bomset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ bomset

int svxDwgBom::bomset

Settings by evxBomset, default value:VX_DERIVED_PARTS.

Definition at line 551 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ name

char* svxDwgBom::name

name

Definition at line 546 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::level

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ level

evxLevelSet svxDwgBom::level

Level Setting, default value:VX_TOP_LEVEL_ONLY.

Definition at line 547 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::Maxdepthval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ Maxdepthval

int svxDwgBom::Maxdepthval

Max traverse depth value(default value:1): to define which assembly level BOM should read out up to.

Definition at line 550 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::indent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ indent

evxIndentedType svxDwgBom::indent

Indented type(default value:VX_DETAILED_NUM): to define how to number the components from the sub-assembly.

Definition at line 548 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::checkMax

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ checkMax

int svxDwgBom::checkMax

whether to use Max traverse depth: 0(default value) no, else yes

Definition at line 549 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ idView

int svxDwgBom::idView

id of View

Definition at line 545 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBom::startID

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBom
bomset
checkMax
idView
indent
level
Maxdepthval
name
order
startID

◆ startID

int svxDwgBom::startID

starting ID, default value:1

Definition at line 552 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgBrkLineAt Struct Reference
Drawing Objects » Drawing Data

attribute of break line More...

#include <zwapi_dwg_data.h>

Data Fields

double | gap
gap size More...
evxBrkLineCutSty brkLnCutSty
cut style of break line More...
svxLineAt lineAtr
line attributes More...
vxName layerName
name of layer More...
int | styleIndex
index of style of break line More...

Detailed Description

attribute of break line

Definition at line 140 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt::styleIndex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrkLineAt
brkLnCutSty
gap
layerName
lineAtr
styleIndex

◆ styleIndex

int svxDwgBrkLineAt::styleIndex

index of style of break line

Definition at line 146 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt::lineAtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrkLineAt
brkLnCutSty
gap
layerName
lineAtr
styleIndex

◆ lineAtr

svxLineAt svxDwgBrkLineAt::lineAtr

line attributes

Definition at line 144 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrkLineAt
brkLnCutSty
gap
layerName
lineAtr
styleIndex

◆ gap

double svxDwgBrkLineAt::gap

gap size

Definition at line 142 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt::layerName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrkLineAt
brkLnCutSty
gap
layerName
lineAtr
styleIndex

◆ layerName

vxName svxDwgBrkLineAt::layerName

name of layer

Definition at line 145 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrkLineAt::brkLnCutSty

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrkLineAt
brkLnCutSty
gap
layerName
lineAtr
styleIndex

◆ brkLnCutSty

evxBrkLineCutSty svxDwgBrkLineAt::brkLnCutSty

cut style of break line

Definition at line 143 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgBrokenSectionData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Drawing Broken Section input infos. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDwgBndMethod method
Boundary Method. More...
int | idView
Base view. More...
svxPoint2 * bPoints
The boundary is made up of points. More...
int | countBPs
count of "bPoints" More...
evxDwgDepthType type
depth type More...
svxPoint2 dPoint
depth point More...
int | idCrv
curve id. if type == VX_DEPTH_POINT, point "dPoint" must be on the curve "idCrv" More...
double | dOffset
depth offset More...
int | dView
depth view More...
vxName name
3D name More...
int | isShow
show step lines More...
int | isDynamicHatch
dynamic hatch scaling and angle More...
svxPoint2 * oPoints
offset points More...
int | countOPs
count of "oPoints" More...

Detailed Description

Drawing Broken Section input infos.

Examples
drawing\dwgViewTest.cpp.

Definition at line 417 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ type

evxDwgDepthType svxDwgBrokenSectionData::type

depth type

Examples
drawing\dwgViewTest.cpp.

Definition at line 423 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ method

evxDwgBndMethod svxDwgBrokenSectionData::method

Boundary Method.

Examples
drawing\dwgViewTest.cpp.

Definition at line 419 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::dPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ dPoint

svxPoint2 svxDwgBrokenSectionData::dPoint

depth point

Examples
drawing\dwgViewTest.cpp.

Definition at line 424 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ idView

int svxDwgBrokenSectionData::idView

Base view.

Examples
drawing\dwgViewTest.cpp.

Definition at line 420 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::dView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ dView

int svxDwgBrokenSectionData::dView

depth view

Examples
drawing\dwgViewTest.cpp.

Definition at line 428 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::countBPs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ countBPs

int svxDwgBrokenSectionData::countBPs

count of "bPoints"

Examples
drawing\dwgViewTest.cpp.

Definition at line 422 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::isDynamicHatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ isDynamicHatch

int svxDwgBrokenSectionData::isDynamicHatch

dynamic hatch scaling and angle

Examples
drawing\dwgViewTest.cpp.

Definition at line 431 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::isShow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ isShow

int svxDwgBrokenSectionData::isShow

show step lines

Examples
drawing\dwgViewTest.cpp.

Definition at line 430 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::countOPs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ countOPs

int svxDwgBrokenSectionData::countOPs

count of "oPoints"

Examples
drawing\dwgViewTest.cpp.

Definition at line 433 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ name

vxName svxDwgBrokenSectionData::name

3D name

Examples
drawing\dwgViewTest.cpp.

Definition at line 429 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::bPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ bPoints

svxPoint2* svxDwgBrokenSectionData::bPoints

The boundary is made up of points.

Examples
drawing\dwgViewTest.cpp.

Definition at line 421 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ dOffset

double svxDwgBrokenSectionData::dOffset

depth offset

Examples
drawing\dwgViewTest.cpp.

Definition at line 427 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::oPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ oPoints

svxPoint2* svxDwgBrokenSectionData::oPoints

offset points

Examples
drawing\dwgViewTest.cpp.

Definition at line 432 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBrokenSectionData::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBrokenSectionData
bPoints
countBPs
countOPs
dOffset
dPoint
dView
idCrv
idView
isDynamicHatch
isShow
method
name
oPoints
type

◆ idCrv

int svxDwgBrokenSectionData::idCrv

curve id. if type == VX_DEPTH_POINT, point "dPoint" must be on the curve "idCrv"

Examples
drawing\dwgViewTest.cpp.

Definition at line 425 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBundleDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgBundleDimData Struct Reference
Drawing Objects » Drawing Data

data of dimension bundle More...

#include <zwapi_dwg_data.h>

Data Fields

int | dimBundleId
dimension bundle id More...
int | count
count of points More...
svxPoint2 * pnts
list of point More...
double | dimValue
dimension value More...

Detailed Description

data of dimension bundle

Definition at line 221 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBundleDimData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBundleDimData
count
dimBundleId
dimValue
pnts

◆ count

int svxDwgBundleDimData::count

count of points

Definition at line 224 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBundleDimData::pnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBundleDimData
count
dimBundleId
dimValue
pnts

◆ pnts

svxPoint2* svxDwgBundleDimData::pnts

list of point

Definition at line 225 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBundleDimData::dimBundleId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBundleDimData
count
dimBundleId
dimValue
pnts

◆ dimBundleId

int svxDwgBundleDimData::dimBundleId

dimension bundle id

Definition at line 223 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgBundleDimData::dimValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgBundleDimData
count
dimBundleId
dimValue
pnts

◆ dimValue

double svxDwgBundleDimData::dimValue

dimension value

Definition at line 226 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgConsDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgConsDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

data of constraint dimension More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDimLineType type
type of dimension default value:horizontal method More...
svxPntOnEnt firstPnt
first point More...
svxPntOnEnt secondPnt
second point More...
svxPntOnEnt textPnt
text point: to locate the dimension text More...

Detailed Description

data of constraint dimension

Definition at line 731 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgConsDim::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgConsDim
firstPnt
secondPnt
textPnt
type

◆ firstPnt

svxPntOnEnt svxDwgConsDim::firstPnt

first point

Examples
drawing\dwgDimTest.cpp.

Definition at line 734 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgConsDim::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgConsDim
firstPnt
secondPnt
textPnt
type

◆ type

evxDimLineType svxDwgConsDim::type

type of dimension default value:horizontal method

Examples
drawing\dwgDimTest.cpp.

Definition at line 733 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgConsDim::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgConsDim
firstPnt
secondPnt
textPnt
type

◆ secondPnt

svxPntOnEnt svxDwgConsDim::secondPnt

second point

Examples
drawing\dwgDimTest.cpp.

Definition at line 735 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgConsDim::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgConsDim
firstPnt
secondPnt
textPnt
type

◆ textPnt

svxPntOnEnt svxDwgConsDim::textPnt

text point: to locate the dimension text

Examples
drawing\dwgDimTest.cpp.

Definition at line 736 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgDetailData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Drawing Detail input infos. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDwgDetailMethod method
Detail Method. More...
int | idView
Base view. More...
int | PntCount
all points count More...
svxPntOnEnt * pPnts
pick points defining the detail boundary More...
svxPntOnEnt NotePnt
pick point for note More...
int | iMultiplier
local magnification More...
svxPntOnEnt Location
local detail view position More...

Detailed Description

Drawing Detail input infos.

Examples
drawing\dwgViewTest.cpp.

Definition at line 451 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::PntCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ PntCount

int svxDwgDetailData::PntCount

all points count

Examples
drawing\dwgViewTest.cpp.

Definition at line 455 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::Location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ Location

svxPntOnEnt svxDwgDetailData::Location

local detail view position

Examples
drawing\dwgViewTest.cpp.

Definition at line 459 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::pPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ pPnts

svxPntOnEnt* svxDwgDetailData::pPnts

pick points defining the detail boundary

Examples
drawing\dwgViewTest.cpp.

Definition at line 456 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ method

evxDwgDetailMethod svxDwgDetailData::method

Detail Method.

Examples
drawing\dwgViewTest.cpp.

Definition at line 453 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ idView

int svxDwgDetailData::idView

Base view.

Examples
drawing\dwgViewTest.cpp.

Definition at line 454 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::iMultiplier

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ iMultiplier

int svxDwgDetailData::iMultiplier

local magnification

Examples
drawing\dwgViewTest.cpp.

Definition at line 458 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgDetailData::NotePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgDetailData
idView
iMultiplier
Location
method
NotePnt
PntCount
pPnts

◆ NotePnt

svxPntOnEnt svxDwgDetailData::NotePnt

pick point for note

Examples
drawing\dwgViewTest.cpp.

Definition at line 457 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgFtrCtrl Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Datum Control. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

char * | text
FCS text name. More...
int | cntCrv
no. of Location data items More...
svxPntOnEnt * Points
list of "cntCrv" points More...
int | cntlead
no. of Lead pts data items More...
svxPntOnEnt * leadPoints
list of "cntlead" points More...
int | cntauxiLoc
no. of Auxiliary location data items More...
svxPntOnEnt * auxiPoints
list of "cntauxiLoc" points More...

Detailed Description

Datum Control.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1207 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::leadPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ leadPoints

svxPntOnEnt* svxDwgFtrCtrl::leadPoints

list of "cntlead" points

Examples
drawing\dwgDimTest.cpp.

Definition at line 1213 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::cntauxiLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ cntauxiLoc

int svxDwgFtrCtrl::cntauxiLoc

no. of Auxiliary location data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 1214 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ text

char* svxDwgFtrCtrl::text

FCS text name.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1209 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ Points

svxPntOnEnt* svxDwgFtrCtrl::Points

list of "cntCrv" points

Examples
drawing\dwgDimTest.cpp.

Definition at line 1211 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::cntlead

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ cntlead

int svxDwgFtrCtrl::cntlead

no. of Lead pts data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 1212 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::auxiPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ auxiPoints

svxPntOnEnt* svxDwgFtrCtrl::auxiPoints

list of "cntauxiLoc" points

Examples
drawing\dwgDimTest.cpp.

Definition at line 1215 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgFtrCtrl::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgFtrCtrl
auxiPoints
cntauxiLoc
cntCrv
cntlead
leadPoints
Points
text

◆ cntCrv

int svxDwgFtrCtrl::cntCrv

no. of Location data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 1210 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgHoleCallOutDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Hole Callout. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
id of View More...
int | cntCrv
number of pCrvs or Pnts. the layout view where the holes are displayed true to their diameters. More...
int * | pCrvs
list of Holes data. the holes anywhere on their perimeter diameter More...
svxPoint2 * pnts
list of text point. NULL to use default value. (the new variable when the ZW_API_VERSION is 2730) More...
int | ignoreDup
Ignore duplicate hole callout, 1 is ignored,0 not, default value:0 1 - if you want to exclude the marked holes of the same specification. More...
unsigned int | iCalloutemt
Callout Elements by evxCalloutEmt combined, default value:VX_CALLOUTEMT_VALID. More...

Detailed Description

Hole Callout.

Examples
drawing\dwgDimTest.cpp.

Definition at line 987 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ cntCrv

int svxDwgHoleCallOutDim::cntCrv

number of pCrvs or Pnts. the layout view where the holes are displayed true to their diameters.

Examples
drawing\dwgDimTest.cpp.

Definition at line 990 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::pnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ pnts

svxPoint2* svxDwgHoleCallOutDim::pnts

list of text point. NULL to use default value. (the new variable when the ZW_API_VERSION is 2730)

Examples
drawing\dwgDimTest.cpp.

Definition at line 994 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::iCalloutemt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ iCalloutemt

unsigned int svxDwgHoleCallOutDim::iCalloutemt

Callout Elements by evxCalloutEmt combined, default value:VX_CALLOUTEMT_VALID.

Examples
drawing\dwgDimTest.cpp.

Definition at line 998 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::ignoreDup

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ ignoreDup

int svxDwgHoleCallOutDim::ignoreDup

Ignore duplicate hole callout, 1 is ignored,0 not, default value:0 1 - if you want to exclude the marked holes of the same specification.

Examples
drawing\dwgDimTest.cpp.

Definition at line 996 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::pCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ pCrvs

int* svxDwgHoleCallOutDim::pCrvs

list of Holes data. the holes anywhere on their perimeter diameter

Examples
drawing\dwgDimTest.cpp.

Definition at line 992 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleCallOutDim::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleCallOutDim
cntCrv
iCalloutemt
idView
ignoreDup
pCrvs
pnts

◆ idView

int svxDwgHoleCallOutDim::idView

id of View

Examples
drawing\dwgDimTest.cpp.

Definition at line 989 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgHoleMark Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing sheet hole mark data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDwgHoleMarkType type
hole mark option More...
int | numCir
number of circle entities need to be marked More...
int * | idCirs
list id of circle entities need to be marked if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4, the circle is given by user other type can be null More...
int | idView
id of view if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, auto mark the hole of the view other type can be null More...
int | backface
whether to mark backfacing holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available More...
int | hidden
whether to mark hidden holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available More...
int | boolean
whether to mark boolean holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available More...
int | sameD
whether to filter same diameter(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4, the option is available More...
evxDwgHoleMarkPtn pattern
pattern of manual hole mark(if type = 2, the option is available).default:VX_DWG_HOLE_MARK_UP_LEFT_4 More...

Detailed Description

drawing sheet hole mark data

Definition at line 1566 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::idCirs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ idCirs

int* svxDwgHoleMark::idCirs

list id of circle entities need to be marked if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4, the circle is given by user other type can be null

Definition at line 1570 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ idView

int svxDwgHoleMark::idView

id of view if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, auto mark the hole of the view other type can be null

Definition at line 1573 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::pattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ pattern

evxDwgHoleMarkPtn svxDwgHoleMark::pattern

pattern of manual hole mark(if type = 2, the option is available).default:VX_DWG_HOLE_MARK_UP_LEFT_4

Definition at line 1584 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ type

evxDwgHoleMarkType svxDwgHoleMark::type

hole mark option

Definition at line 1568 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::hidden

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ hidden

int svxDwgHoleMark::hidden

whether to mark hidden holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available

Definition at line 1578 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::boolean

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ boolean

int svxDwgHoleMark::boolean

whether to mark boolean holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available

Definition at line 1580 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::numCir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ numCir

int svxDwgHoleMark::numCir

number of circle entities need to be marked

Definition at line 1569 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::sameD

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ sameD

int svxDwgHoleMark::sameD

whether to filter same diameter(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4, the option is available

Definition at line 1582 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgHoleMark::backface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgHoleMark
backface
boolean
hidden
idCirs
idView
numCir
pattern
sameD
type

◆ backface

int svxDwgHoleMark::backface

whether to mark backfacing holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, the option is available

Definition at line 1576 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgIsectSym Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgIsectSym Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing intersection symbol data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxPntOnEnt fistEdge
point of the first line or arc, create intersection symbol between two entity More...
svxPntOnEnt secondEdge
point of the second line or arc More...

Detailed Description

drawing intersection symbol data

Definition at line 1525 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgIsectSym::secondEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgIsectSym
fistEdge
secondEdge

◆ secondEdge

svxPntOnEnt svxDwgIsectSym::secondEdge

point of the second line or arc

Definition at line 1529 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgIsectSym::fistEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgIsectSym
fistEdge
secondEdge

◆ fistEdge

svxPntOnEnt svxDwgIsectSym::fistEdge

point of the first line or arc, create intersection symbol between two entity

Definition at line 1527 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgLineDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Linear. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxDwgConsDim cons
constraint dimension, 5 type of line dimension More...
double angle
dimension angle. if type = VX_DIM_LINE_LR, it is the angle between target line and vertical line, other type can be null More...
svxPntOnEnt dirPnt
the point on the project line. if type = VX_DIM_LINE_LP, the point is on the project line, can regard as the entity of project line, other type can be null More...

Detailed Description

Linear.

Examples
drawing\dwgDimTest.cpp.

Definition at line 743 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineDim::dirPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineDim
angle
cons
dirPnt

◆ dirPnt

svxPntOnEnt svxDwgLineDim::dirPnt

the point on the project line. if type = VX_DIM_LINE_LP, the point is on the project line, can regard as the entity of project line, other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 749 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineDim::cons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineDim
angle
cons
dirPnt

◆ cons

svxDwgConsDim svxDwgLineDim::cons

constraint dimension, 5 type of line dimension

Examples
drawing\dwgDimTest.cpp.

Definition at line 745 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineDim::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineDim
angle
cons
dirPnt

◆ angle

double svxDwgLineDim::angle

dimension angle. if type = VX_DIM_LINE_LR, it is the angle between target line and vertical line, other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 746 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineGrpDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgLineGrpDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Baseline, Continuous. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxDwgLineDim sub
Linear constraint dimension. More...
int cntCrv
no. of Points data items More...
svxPntOnEnt * Points
list of "cntCrv" Points More...

Detailed Description

Baseline, Continuous.

Examples
drawing\dwgDimTest.cpp.

Definition at line 758 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineGrpDim::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineGrpDim
cntCrv
Points
sub

◆ cntCrv

int svxDwgLineGrpDim::cntCrv

no. of Points data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 761 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineGrpDim::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineGrpDim
cntCrv
Points
sub

◆ Points

svxPntOnEnt* svxDwgLineGrpDim::Points

list of "cntCrv" Points

Examples
drawing\dwgDimTest.cpp.

Definition at line 762 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineGrpDim::sub

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineGrpDim
cntCrv
Points
sub

◆ sub

svxDwgLineDim svxDwgLineGrpDim::sub

Linear constraint dimension.

Examples
drawing\dwgDimTest.cpp.

Definition at line 760 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineOffsetDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgLineOffsetDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Linear Offset. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxDimLineOffset type
type of dimension default value:VX_DIM_OFFSET_LOL More...
svxPntOnEnt firstPnt
VX_DIM_OFFSET_LOL: first line ; VX_DIM_OFFSET_LOP: first line. More...
svxPntOnEnt secondPnt
VX_DIM_OFFSET_LOL: second line; VX_DIM_OFFSET_LOP: point. More...
svxPntOnEnt textPnt
text point: select a point to locate the dimension text More...

Detailed Description

Linear Offset.

Examples
drawing\dwgDimTest.cpp.

Definition at line 805 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineOffsetDim::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineOffsetDim
firstPnt
secondPnt
textPnt
type

◆ firstPnt

svxPntOnEnt svxDwgLineOffsetDim::firstPnt

VX_DIM_OFFSET_LOL: first line ; VX_DIM_OFFSET_LOP: first line.

Examples
drawing\dwgDimTest.cpp.

Definition at line 808 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineOffsetDim::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineOffsetDim
firstPnt
secondPnt
textPnt
type

◆ type

evxDimLineOffset svxDwgLineOffsetDim::type

type of dimension default value:VX_DIM_OFFSET_LOL

Examples
drawing\dwgDimTest.cpp.

Definition at line 807 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineOffsetDim::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineOffsetDim
firstPnt
secondPnt
textPnt
type

◆ secondPnt

svxPntOnEnt svxDwgLineOffsetDim::secondPnt

VX_DIM_OFFSET_LOL: second line; VX_DIM_OFFSET_LOP: point.

Examples
drawing\dwgDimTest.cpp.

Definition at line 809 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLineOffsetDim::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLineOffsetDim
firstPnt
secondPnt
textPnt
type

◆ textPnt

svxPntOnEnt svxDwgLineOffsetDim::textPnt

text point: select a point to locate the dimension text

Examples
drawing\dwgDimTest.cpp.

Definition at line 810 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgLnrChmDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

the info of the linear chamfer dim More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxPntOnEnt LineEnt
ID and point data of line (the idEnt of "LineEnt" must be valid). if type = VX_LEADER_CHAMFERDIM, the arrow is point at LineEnt on the chamfer entity, other type the LineEnt represent the specified chamfer. More...
evxDwgLnrChmDimType dimType
type of line linear chamfer Dim More...
evxDwgLnrChmDimTexType dimTexType
type of Text, only required when "dimType" is VX_LEADER_CHAMFERDIM More...
svxPntOnEnt textPnt
point coordinate of text placement point. When "dimType" is VX_HORZORVERT_CHAMFERDIM, this presents, horizontal point coordinate of text placement point More...
svxPntOnEnt verTextPnt
point coordinate of vertical text placement point, only required when "dimType" is VX_HORZORVERT_CHAMFERDIM More...

Detailed Description

the info of the linear chamfer dim

Examples
drawing\dwgDimTest.cpp.

Definition at line 854 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData::dimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLnrChmDimData
dimTexType
dimType
LineEnt
textPnt
verTextPnt

◆ dimType

evxDwgLnrChmDimType svxDwgLnrChmDimData::dimType

type of line linear chamfer Dim

Examples
drawing\dwgDimTest.cpp.

Definition at line 859 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData::verTextPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLnrChmDimData
dimTexType
dimType
LineEnt
textPnt
verTextPnt

◆ verTextPnt

svxPntOnEnt svxDwgLnrChmDimData::verTextPnt

point coordinate of vertical text placement point, only required when "dimType" is VX_HORZORVERT_CHAMFERDIM

Examples
drawing\dwgDimTest.cpp.

Definition at line 864 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData::dimTexType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLnrChmDimData
dimTexType
dimType
LineEnt
textPnt
verTextPnt

◆ dimTexType

evxDwgLnrChmDimTexType svxDwgLnrChmDimData::dimTexType

type of Text, only required when "dimType" is VX_LEADER_CHAMFERDIM

Examples
drawing\dwgDimTest.cpp.

Definition at line 860 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData::LineEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLnrChmDimData
dimTexType
dimType
LineEnt
textPnt
verTextPnt

◆ LineEnt

svxPntOnEnt svxDwgLnrChmDimData::LineEnt

ID and point data of line (the idEnt of "LineEnt" must be valid). if type = VX_LEADER_CHAMFERDIM, the arrow is point at LineEnt on the chamfer entity, other type the LineEnt represent the specified chamfer.

Examples
drawing\dwgDimTest.cpp.

Definition at line 856 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgLnrChmDimData::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgLnrChmDimData
dimTexType
dimType
LineEnt
textPnt
verTextPnt

◆ textPnt

svxPntOnEnt svxDwgLnrChmDimData::textPnt

point coordinate of text placement point. When "dimType" is VX_HORZORVERT_CHAMFERDIM, this presents, horizontal point coordinate of text placement point

Examples
drawing\dwgDimTest.cpp.

Definition at line 861 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgOrdinateDim Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Ordinate. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxDwgLineDim sub
Linear constraint dimension, 6 type of line dimension. More...
int | cntCrv
no. of Points data items More...
svxPntOnEnt * Points
list of "cntCrv" Points More...
int | reverseAxis1
reverse direction, default value:0 More...
int | reverseAxis2
reverse direction, default value:0 More...
int | idEnt
Share origin (Group dimension), 0 to ignore. More...
svxPntOnEnt | textPnt [2]
Horizontal(textPnt[0]) and Vertical(textPnt[1]) text point, used only for sub.cons.type is VX_DIM_LINE_LO. More...

Detailed Description

Ordinate.

Examples
drawing\dwgDimTest.cpp.

Definition at line 769 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::reverseAxis2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ reverseAxis2

int svxDwgOrdinateDim::reverseAxis2

reverse direction, default value:0

Examples
drawing\dwgDimTest.cpp.

Definition at line 775 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ textPnt

svxPntOnEnt svxDwgOrdinateDim::textPnt[2]

Horizontal(textPnt[0]) and Vertical(textPnt[1]) text point, used only for sub.cons.type is VX_DIM_LINE_LO.

Examples
drawing\dwgDimTest.cpp.

Definition at line 777 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::reverseAxis1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ reverseAxis1

int svxDwgOrdinateDim::reverseAxis1

reverse direction, default value:0

Examples
drawing\dwgDimTest.cpp.

Definition at line 774 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ Points

svxPntOnEnt* svxDwgOrdinateDim::Points

list of "cntCrv" Points

Examples
drawing\dwgDimTest.cpp.

Definition at line 773 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ cntCrv

int svxDwgOrdinateDim::cntCrv

no. of Points data items

Examples
drawing\dwgDimTest.cpp.

Definition at line 772 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::idEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ idEnt

int svxDwgOrdinateDim::idEnt

Share origin (Group dimension), 0 to ignore.

Examples
drawing\dwgDimTest.cpp.

Definition at line 776 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgOrdinateDim::sub

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgOrdinateDim
cntCrv
idEnt
Points
reverseAxis1
reverseAxis2
sub
textPnt

◆ sub

svxDwgLineDim svxDwgOrdinateDim::sub

Linear constraint dimension, 6 type of line dimension.

Examples
drawing\dwgDimTest.cpp.

Definition at line 771 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgRotView Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgRotView Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Rotate View. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
id of View More...
evxRotViewType view
type of View (default value:VX_ROTVIEW_TOP): to set the view projection direction More...
evxAxisType axis
type of Axis, default value:VX_AXIS_Z More...
double | angle
rotate angle default value:0 More...

Detailed Description

Rotate View.

Definition at line 613 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgRotView::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgRotView
angle
axis
idView
view

◆ idView

int svxDwgRotView::idView

id of View

Definition at line 615 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgRotView::view

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgRotView
angle
axis
idView
view

◆ view

evxRotViewType svxDwgRotView::view

type of View (default value:VX_ROTVIEW_TOP): to set the view projection direction

Definition at line 616 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgRotView::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgRotView
angle
axis
idView
view

◆ axis

evxAxisType svxDwgRotView::axis

type of Axis, default value:VX_AXIS_Z

Definition at line 617 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgRotView::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgRotView
angle
axis
idView
view

◆ angle

double svxDwgRotView::angle

rotate angle default value:0

Definition at line 618 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStkBlnData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

information of creating stack balloons More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idBlnDim
index of main balloon. It must be index of V_DM_BALL(not stack balloon) More...
int | entCnt
count of input entity corresponding to pIndexEntityList More...
int * | pEntIdList
input entity index list. Index must be VV3REF/VNCURV/VICURV/ VLINE2/VCIRCLE2/VARC2/V_DM_BALL(not stack balloon) More...
evxDwgStkBlnPtn stkBlnPtn
pattern of stack balloons More...
char | autoSort
flag of auto sort (0-no, else yes. Note:0 as default) if set to non-zero, the balloons can be stacked in turn. More...

Detailed Description

information of creating stack balloons

Examples
drawing\dwgDimTest.cpp.

Definition at line 1192 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData::entCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStkBlnData
autoSort
entCnt
idBlnDim
pEntIdList
stkBlnPtn

◆ entCnt

int svxDwgStkBlnData::entCnt

count of input entity corresponding to pIndexEntityList

Examples
drawing\dwgDimTest.cpp.

Definition at line 1195 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData::autoSort

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStkBlnData
autoSort
entCnt
idBlnDim
pEntIdList
stkBlnPtn

◆ autoSort

char svxDwgStkBlnData::autoSort

flag of auto sort (0-no, else yes. Note:0 as default) if set to non-zero, the balloons can be stacked in turn.

Examples
drawing\dwgDimTest.cpp.

Definition at line 1199 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData::idBlnDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStkBlnData
autoSort
entCnt
idBlnDim
pEntIdList
stkBlnPtn

◆ idBlnDim

int svxDwgStkBlnData::idBlnDim

index of main balloon. It must be index of V_DM_BALL(not stack balloon)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1194 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData::pEntIdList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStkBlnData
autoSort
entCnt
idBlnDim
pEntIdList
stkBlnPtn

◆ pEntIdList

int* svxDwgStkBlnData::pEntIdList

input entity index list. Index must be VV3REF/VNCURV/VICURV/ VLINE2/VCIRCLE2/VARC2/V_DM_BALL(not stack balloon)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1196 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStkBlnData::stkBlnPtn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStkBlnData
autoSort
entCnt
idBlnDim
pEntIdList
stkBlnPtn

◆ stkBlnPtn

evxDwgStkBlnPtn svxDwgStkBlnData::stkBlnPtn

pattern of stack balloons

Examples
drawing\dwgDimTest.cpp.

Definition at line 1198 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStyleManagerAnnoDimText Struct Reference
Drawing Objects » Drawing Data

the text attribute of the annotation/dimension in the style manager. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName fontName
font name More...
vxLongName fontName2
secondary font name More...
int | underline
underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02. More...
int | bold
1 is bold text, else 0. More...
int | color
text color(see evxColor/evxColorAppFlag) More...
evxTextAlignment align
text alignment More...
double | charHeight
text height More...
double | charAspect
character aspect = width /height More...
double | multiLineSpace
spacing between multiple lines of text. More...
double | charSpacing
character spacing. More...
double | charSlant
slant angle of each character. More...
double | tolchHgtFac
tolerance of char height factor.(only dimension can use this variable.) More...

Detailed Description

the text attribute of the annotation/dimension in the style manager.

Definition at line 380 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::charSlant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ charSlant

double svxDwgStyleManagerAnnoDimText::charSlant

slant angle of each character.

Definition at line 396 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::charAspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ charAspect

double svxDwgStyleManagerAnnoDimText::charAspect

character aspect = width /height

Definition at line 393 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::bold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ bold

int svxDwgStyleManagerAnnoDimText::bold

1 is bold text, else 0.

Definition at line 388 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::tolchHgtFac

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ tolchHgtFac

double svxDwgStyleManagerAnnoDimText::tolchHgtFac

tolerance of char height factor.(only dimension can use this variable.)

Definition at line 397 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::multiLineSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ multiLineSpace

double svxDwgStyleManagerAnnoDimText::multiLineSpace

spacing between multiple lines of text.

Definition at line 394 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::charHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ charHeight

double svxDwgStyleManagerAnnoDimText::charHeight

text height

Definition at line 392 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ color

int svxDwgStyleManagerAnnoDimText::color

text color(see evxColor/evxColorAppFlag)

Definition at line 389 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ fontName

vxLongName svxDwgStyleManagerAnnoDimText::fontName

font name

Definition at line 382 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ align

evxTextAlignment svxDwgStyleManagerAnnoDimText::align

text alignment

Definition at line 390 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ charSpacing

double svxDwgStyleManagerAnnoDimText::charSpacing

character spacing.

Definition at line 395 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ underline

int svxDwgStyleManagerAnnoDimText::underline

underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02.

Definition at line 384 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerAnnoDimText::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerAnnoDimText
align
bold
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
tolchHgtFac
underline

◆ fontName2

vxLongName svxDwgStyleManagerAnnoDimText::fontName2

secondary font name

Definition at line 383 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStyleManagerSymText Struct Reference
Drawing Objects » Drawing Data

the text attribute of the weld(or surface finish) in the style manager. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName fontName
font name More...
vxLongName fontName2
secondary font name More...
int | underline
underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02. More...
int | color
text color(see evxColor/evxColorAppFlag) More...
double | charHeight
text height More...
double | charAspect
character aspect = width /height More...
double | charSpacing
character spacing. More...

Detailed Description

the text attribute of the weld(or surface finish) in the style manager.

Definition at line 430 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ fontName2

vxLongName svxDwgStyleManagerSymText::fontName2

secondary font name

Definition at line 433 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::charAspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ charAspect

double svxDwgStyleManagerSymText::charAspect

character aspect = width /height

Definition at line 440 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ charSpacing

double svxDwgStyleManagerSymText::charSpacing

character spacing.

Definition at line 441 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ underline

int svxDwgStyleManagerSymText::underline

underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02.

Definition at line 434 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ fontName

vxLongName svxDwgStyleManagerSymText::fontName

font name

Definition at line 432 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ color

int svxDwgStyleManagerSymText::color

text color(see evxColor/evxColorAppFlag)

Definition at line 438 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerSymText::charHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerSymText
charAspect
charHeight
charSpacing
color
fontName
fontName2
underline

◆ charHeight

double svxDwgStyleManagerSymText::charHeight

text height

Definition at line 439 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStyleManagerTableText Struct Reference
Drawing Objects » Drawing Data

the text attribute of the table in the style manager. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName fontName
font name More...
vxLongName fontName2
secondary font name More...
int | underline
underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02. More...
int | bold
1 is bold text, else 0. More...
int | color
text color(see evxColor/evxColorAppFlag) More...
evxTextFontType fontType
font type More...
evxTextAlignWordWrap fitMethod
fit method More...
evxHorizontalMethod horizontal
horizontal text alignment More...
evxVerticalMethod vertical
vertical text alignment More...
double | charHeight
text height More...
double | charAspect
character aspect = width /height More...
double | multiLineSpace
spacing between multiple lines of text. More...
double | charSpacing
character spacing. More...
double | charSlant
slant angle of each character. More...

Detailed Description

the text attribute of the table in the style manager.

Definition at line 404 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::multiLineSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ multiLineSpace

double svxDwgStyleManagerTableText::multiLineSpace

spacing between multiple lines of text.

Definition at line 421 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::bold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ bold

int svxDwgStyleManagerTableText::bold

1 is bold text, else 0.

Definition at line 412 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::vertical

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ vertical

evxVerticalMethod svxDwgStyleManagerTableText::vertical

vertical text alignment

Definition at line 417 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ color

int svxDwgStyleManagerTableText::color

text color(see evxColor/evxColorAppFlag)

Definition at line 413 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ underline

int svxDwgStyleManagerTableText::underline

underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02.

Definition at line 408 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::horizontal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ horizontal

evxHorizontalMethod svxDwgStyleManagerTableText::horizontal

horizontal text alignment

Definition at line 416 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ fontName

vxLongName svxDwgStyleManagerTableText::fontName

font name

Definition at line 406 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::charAspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ charAspect

double svxDwgStyleManagerTableText::charAspect

character aspect = width /height

Definition at line 420 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ charSpacing

double svxDwgStyleManagerTableText::charSpacing

character spacing.

Definition at line 422 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::charHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ charHeight

double svxDwgStyleManagerTableText::charHeight

text height

Definition at line 419 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ fontName2

vxLongName svxDwgStyleManagerTableText::fontName2

secondary font name

Definition at line 407 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::charSlant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ charSlant

double svxDwgStyleManagerTableText::charSlant

slant angle of each character.

Definition at line 423 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::fitMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ fitMethod

evxTextAlignWordWrap svxDwgStyleManagerTableText::fitMethod

fit method

Definition at line 415 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerTableText::fontType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerTableText
bold
charAspect
charHeight
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
multiLineSpace
underline
vertical

◆ fontType

evxTextFontType svxDwgStyleManagerTableText::fontType

font type

Definition at line 414 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStyleManagerText Struct Reference
Drawing Objects » Drawing Data

the text attribute of the text in the style manager. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName fontName
font name More...
vxLongName fontName2
secondary font name More...
int | underline
underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02. More...
int | color
text color(see evxColor/evxColorAppFlag) More...
evxLineWidth width
line size More...
evxTextFontType fontType
font type More...
evxTextStroke stroke
text precision More...
evxTextAlignWordWrap fitMethod
fit method More...
evxHorizontalMethod horizontal
horizontal text alignment More...
int | horizontalType
horizontal text alignment type: 0 is line, 1 is paragraph. More...
evxVerticalMethod vertical
vertical text alignment More...
int | verticalType
vertical text alignment type:0 is line, 1 is paragraph. More...
double | charHeight
text height More...
double | charAspect
character aspect = width /height More...
double | multiLineSpace
spacing between multiple lines of text. More...
double | charSpacing
character spacing. More...
double | charSlant
slant angle of each character. More...
double | textAngle
text angle. 0 degress to the right. More...
double | charPath
text path as angle 0.0 - 360.0 degrees. More...
double | textExpansion
factor of text expansion along path. More...

Detailed Description

the text attribute of the text in the style manager.

Definition at line 337 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ charSpacing

double svxDwgStyleManagerText::charSpacing

character spacing.

Definition at line 358 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::horizontal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ horizontal

evxHorizontalMethod svxDwgStyleManagerText::horizontal

horizontal text alignment

Definition at line 350 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::charHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ charHeight

double svxDwgStyleManagerText::charHeight

text height

Definition at line 355 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::charSlant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ charSlant

double svxDwgStyleManagerText::charSlant

slant angle of each character.

Definition at line 359 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ fontName2

vxLongName svxDwgStyleManagerText::fontName2

secondary font name

Definition at line 340 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::fontType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ fontType

evxTextFontType svxDwgStyleManagerText::fontType

font type

Definition at line 347 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ width

evxLineWidth svxDwgStyleManagerText::width

line size

Definition at line 346 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::charPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ charPath

double svxDwgStyleManagerText::charPath

text path as angle 0.0 - 360.0 degrees.

Definition at line 361 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::stroke

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ stroke

evxTextStroke svxDwgStyleManagerText::stroke

text precision

Definition at line 348 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ underline

int svxDwgStyleManagerText::underline

underline flag: 0x01,
overline flag: 0x02,
delete line flag 0x04.
if underline and overline, underline=0x01|0x02.

Definition at line 341 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ color

int svxDwgStyleManagerText::color

text color(see evxColor/evxColorAppFlag)

Definition at line 345 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::charAspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ charAspect

double svxDwgStyleManagerText::charAspect

character aspect = width /height

Definition at line 356 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::horizontalType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ horizontalType

int svxDwgStyleManagerText::horizontalType

horizontal text alignment type: 0 is line, 1 is paragraph.

Definition at line 351 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::fitMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ fitMethod

evxTextAlignWordWrap svxDwgStyleManagerText::fitMethod

fit method

Definition at line 349 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::vertical

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ vertical

evxVerticalMethod svxDwgStyleManagerText::vertical

vertical text alignment

Definition at line 352 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ fontName

vxLongName svxDwgStyleManagerText::fontName

font name

Definition at line 339 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::multiLineSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ multiLineSpace

double svxDwgStyleManagerText::multiLineSpace

spacing between multiple lines of text.

Definition at line 357 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::textAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ textAngle

double svxDwgStyleManagerText::textAngle

text angle. 0 degress to the right.

Definition at line 360 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::textExpansion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ textExpansion

double svxDwgStyleManagerText::textExpansion

factor of text expansion along path.

Definition at line 362 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerText::verticalType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerText
charAspect
charHeight
charPath
charSlant
charSpacing
color
fitMethod
fontName
fontName2
fontType
horizontal
horizontalType
multiLineSpace
stroke
textAngle
textExpansion
underline
vertical
verticalType
width

◆ verticalType

int svxDwgStyleManagerText::verticalType

vertical text alignment type:0 is line, 1 is paragraph.

Definition at line 353 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgStyleManagerViewText Struct Reference
Drawing Objects » Drawing Data

the text attribute of the view in the style manager. More...

#include <zwapi_dwg_data.h>

Data Fields

vxLongName fontName
font name More...
vxLongName fontName2
secondary font name More...
int | underline
1 if underline flag, else 0. More...
int | color
text color(see evxColor/evxColorAppFlag) More...
evxTextAlignment align
text align More...
double | charHeight
text height More...
double | charAspect
character aspect = width /height More...
double | multiLineSpace
spacing between multiple lines of text. More...
double | charSpacing
character spacing. More...
double | charSlant
slant angle of each character. More...

Detailed Description

the text attribute of the view in the style manager.

Definition at line 448 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::multiLineSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ multiLineSpace

double svxDwgStyleManagerViewText::multiLineSpace

spacing between multiple lines of text.

Definition at line 457 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ align

evxTextAlignment svxDwgStyleManagerViewText::align

text align

Definition at line 454 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ color

int svxDwgStyleManagerViewText::color

text color(see evxColor/evxColorAppFlag)

Definition at line 453 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ underline

int svxDwgStyleManagerViewText::underline

1 if underline flag, else 0.

Definition at line 452 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::charSlant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ charSlant

double svxDwgStyleManagerViewText::charSlant

slant angle of each character.

Definition at line 459 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::charHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ charHeight

double svxDwgStyleManagerViewText::charHeight

text height

Definition at line 455 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::charAspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ charAspect

double svxDwgStyleManagerViewText::charAspect

character aspect = width /height

Definition at line 456 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ fontName

vxLongName svxDwgStyleManagerViewText::fontName

font name

Definition at line 450 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ charSpacing

double svxDwgStyleManagerViewText::charSpacing

character spacing.

Definition at line 458 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgStyleManagerViewText::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgStyleManagerViewText
align
charAspect
charHeight
charSlant
charSpacing
color
fontName
fontName2
multiLineSpace
underline

◆ fontName2

vxLongName svxDwgStyleManagerViewText::fontName2

secondary font name

Definition at line 451 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgSymmetryDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Symmetry dimension data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxSymmetryDimType type
Symmetry dimension type. More...
svxPntOnEnt Pnt
point coordinate of point on entity, just for type = 0 More...
svxPntOnEnt LinePnt
line point coordinates, just for type = 1 More...
svxPntOnEnt CenterLinePnt
Center Line point coordinates. More...
svxPntOnEnt txtPnt
text point More...
int autoSwitchAttr
1 is auto switch dimension attributes. else 0. This parameter can only be used in the sketch environment. More...

Detailed Description

Symmetry dimension data.

Examples
drawing\dwgDimTest.cpp.

Definition at line 817 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ type

evxSymmetryDimType svxDwgSymmetryDimData::type

Symmetry dimension type.

Examples
drawing\dwgDimTest.cpp.

Definition at line 819 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::LinePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ LinePnt

svxPntOnEnt svxDwgSymmetryDimData::LinePnt

line point coordinates, just for type = 1

Examples
drawing\dwgDimTest.cpp.

Definition at line 821 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::autoSwitchAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ autoSwitchAttr

int svxDwgSymmetryDimData::autoSwitchAttr

1 is auto switch dimension attributes. else 0. This parameter can only be used in the sketch environment.

Definition at line 824 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::CenterLinePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ CenterLinePnt

svxPntOnEnt svxDwgSymmetryDimData::CenterLinePnt

Center Line point coordinates.

Examples
drawing\dwgDimTest.cpp.

Definition at line 822 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::txtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ txtPnt

svxPntOnEnt svxDwgSymmetryDimData::txtPnt

text point

Examples
drawing\dwgDimTest.cpp.

Definition at line 823 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgSymmetryDimData::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgSymmetryDimData
autoSwitchAttr
CenterLinePnt
LinePnt
Pnt
txtPnt
type

◆ Pnt

svxPntOnEnt svxDwgSymmetryDimData::Pnt

point coordinate of point on entity, just for type = 0

Examples
drawing\dwgDimTest.cpp.

Definition at line 820 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgTblInsert Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDwgTblInsert Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

insert Table More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int idTable
insert table id More...
svxPoint2 crtpnt
Point. More...
evxOriginType origin
Origin, default value:VX_TOP_LEFT. More...

Detailed Description

insert Table

Definition at line 577 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgTblInsert::crtpnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgTblInsert
crtpnt
idTable
origin

◆ crtpnt

svxPoint2 svxDwgTblInsert::crtpnt

Point.

Definition at line 580 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgTblInsert::idTable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgTblInsert
crtpnt
idTable
origin

◆ idTable

int svxDwgTblInsert::idTable

insert table id

Definition at line 579 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDwgTblInsert::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDwgTblInsert
crtpnt
idTable
origin

◆ origin

evxOriginType svxDwgTblInsert::origin

Origin, default value:VX_TOP_LEFT.

Definition at line 581 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxDymMove Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

dynamic copy/move entities More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int MoveHand
move handle only(default 0) More...
svxPoint Pos
Position. More...
svxVector XAxis
X Axis. More...
svxVector YAxis
Y Axis. More...
svxVector ZAxis
Z Axis. More...

Detailed Description

dynamic copy/move entities

Definition at line 1499 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove::YAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDymMove
MoveHand
Pos
XAxis
YAxis
ZAxis

◆ YAxis

svxVector svxDymMove::YAxis

Y Axis.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1504 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove::MoveHand

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDymMove
MoveHand
Pos
XAxis
YAxis
ZAxis

◆ MoveHand

int svxDymMove::MoveHand

move handle only(default 0)

Definition at line 1501 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove::XAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDymMove
MoveHand
Pos
XAxis
YAxis
ZAxis

◆ XAxis

svxVector svxDymMove::XAxis

X Axis.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1503 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove::ZAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDymMove
MoveHand
Pos
XAxis
YAxis
ZAxis

◆ ZAxis

svxVector svxDymMove::ZAxis

Z Axis.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1505 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDymMove::Pos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDymMove
MoveHand
Pos
XAxis
YAxis
ZAxis

◆ Pos

svxPoint svxDymMove::Pos

Position.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1502 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEcadRgnSetData Struct Reference
Commands Creation » Part and Assembly Commands » ECAD Board Commands Data

Region set data. More...

#include <zwapi_cmd_ecadboard_data.h>

Data Fields

evxEcadRgnSetType Type
the type of the region setting More...
int | idCosmeticSk
id of the cosmetic sketch More...
int | Volume
3d volume (0 as default) More...
double | Height
region height(0.0 as default) More...
int | KeepType
0-keep in, 1- keep out (0 as default, 1 as default if Type = VX_VIA_RGN) More...
vxLongName RgnType
input the region type (Type = VX_OTHER_RGN) More...
evxEcadRgnOwner Owner
region owner More...
evxColor Color
region color (VX_COLOR_LIGHT_MAGENTA as default) More...

Detailed Description

Region set data.

Definition at line 56 of file zwapi_cmd_ecadboard_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_ecadboard_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::Color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ Color

evxColor svxEcadRgnSetData::Color

region color (VX_COLOR_LIGHT_MAGENTA as default)

Definition at line 65 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::Height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ Height

double svxEcadRgnSetData::Height

region height(0.0 as default)

Definition at line 61 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::Owner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ Owner

evxEcadRgnOwner svxEcadRgnSetData::Owner

region owner

Definition at line 64 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::Volume

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ Volume

int svxEcadRgnSetData::Volume

3d volume (0 as default)

Definition at line 60 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ Type

evxEcadRgnSetType svxEcadRgnSetData::Type

the type of the region setting

Definition at line 58 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::RgnType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ RgnType

vxLongName svxEcadRgnSetData::RgnType

input the region type (Type = VX_OTHER_RGN)

Definition at line 63 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::KeepType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ KeepType

int svxEcadRgnSetData::KeepType

0-keep in, 1- keep out (0 as default, 1 as default if Type = VX_VIA_RGN)

Definition at line 62 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEcadRgnSetData::idCosmeticSk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEcadRgnSetData
Color
Height
idCosmeticSk
KeepType
Owner
RgnType
Type
Volume

◆ idCosmeticSk

int svxEcadRgnSetData::idCosmeticSk

id of the cosmetic sketch

Definition at line 59 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEdgeDispData Struct Reference
Part Objects » Part Data

edge display data More...

#include <zwapi_part_data.h>

Data Fields

int | wireCnt
count of wireDispData More...
svxPoint * wireDispData
display data of wireframe More...
int | shadeCnt1
count of shadeDispData1 More...
svxPoint * shadeDispData1
display data1 of shade. This is the display data of one of the two faces adjacent to the edge on the edge. More...
int | shadeCnt2
count of shadeDispData2 More...
svxPoint * shadeDispData2
display data2 of shade. This is the display data of the other of the two faces adjacent to the edge on the edge. More...

Detailed Description

edge display data

Definition at line 380 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::shadeDispData2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ shadeDispData2

svxPoint* svxEdgeDispData::shadeDispData2

display data2 of shade. This is the display data of the other of the two faces adjacent to the edge on the edge.

Definition at line 388 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::wireDispData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ wireDispData

svxPoint* svxEdgeDispData::wireDispData

display data of wireframe

Definition at line 383 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::shadeCnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ shadeCnt2

int svxEdgeDispData::shadeCnt2

count of shadeDispData2

Definition at line 387 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::shadeCnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ shadeCnt1

int svxEdgeDispData::shadeCnt1

count of shadeDispData1

Definition at line 384 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::wireCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ wireCnt

int svxEdgeDispData::wireCnt

count of wireDispData

Definition at line 382 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEdgeDispData::shadeDispData1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEdgeDispData
shadeCnt1
shadeCnt2
shadeDispData1
shadeDispData2
wireCnt
wireDispData

◆ shadeDispData1

svxPoint* svxEdgeDispData::shadeDispData1

display data1 of shade. This is the display data of one of the two faces adjacent to the edge on the edge.

Definition at line 385 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEllipse Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of ellipse More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint centroid
centroid of ellipse More...
double | width
width of ellipse More...
double | height
height of ellipse More...
double | startAng
start angle of ellipse (deg - CCW from X axis). the arc is the part of ellipse from start angle to end angle More...
double | endAng
end angle of ellipse (deg - CCW from the first decided axis of ellipse) More...
double | rotationAng
rotation angle of ellipse (deg - CCW from the first decided axis of ellipse) More...

Detailed Description

data of ellipse

Examples
sketch\skDrawingTest.cpp.

Definition at line 95 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::rotationAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ rotationAng

double svxEllipse::rotationAng

rotation angle of ellipse (deg - CCW from the first decided axis of ellipse)

Definition at line 103 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ width

double svxEllipse::width

width of ellipse

Examples
sketch\skDrawingTest.cpp.

Definition at line 98 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::startAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ startAng

double svxEllipse::startAng

start angle of ellipse (deg - CCW from X axis). the arc is the part of ellipse from start angle to end angle

Definition at line 100 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::endAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ endAng

double svxEllipse::endAng

end angle of ellipse (deg - CCW from the first decided axis of ellipse)

Definition at line 102 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::centroid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ centroid

svxPoint svxEllipse::centroid

centroid of ellipse

Examples
sketch\skDrawingTest.cpp.

Definition at line 97 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipse::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipse
centroid
endAng
height
rotationAng
startAng
width

◆ height

double svxEllipse::height

height of ellipse

Examples
sketch\skDrawingTest.cpp.

Definition at line 99 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEllipsoid Struct Reference
Common » Common Data

ellipsoid surface data More...

#include <zwapi_util.h>

Data Fields

double | xlen
length along x-axis More...
double | ylen
length along y-axis More...
double | zlen
length along z-axis More...
svxMatrix form
ellipsoid centered about xform More...
int | poleis01
= 1 : poles (if they exist) are at extreme V parameters
= 0 : poles (if they exist) are at extreme U parameters More...

Detailed Description

ellipsoid surface data

Definition at line 1843 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid::poleis01

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipsoid
form
poleis01
xlen
ylen
zlen

◆ poleis01

int svxEllipsoid::poleis01

= 1 : poles (if they exist) are at extreme V parameters
= 0 : poles (if they exist) are at extreme U parameters

Definition at line 1849 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid::ylen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipsoid
form
poleis01
xlen
ylen
zlen

◆ ylen

double svxEllipsoid::ylen

length along y-axis

Definition at line 1846 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipsoid
form
poleis01
xlen
ylen
zlen

◆ form

svxMatrix svxEllipsoid::form

ellipsoid centered about xform

Definition at line 1848 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid::zlen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipsoid
form
poleis01
xlen
ylen
zlen

◆ zlen

double svxEllipsoid::zlen

length along z-axis

Definition at line 1847 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllipsoid::xlen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllipsoid
form
poleis01
xlen
ylen
zlen

◆ xlen

double svxEllipsoid::xlen

length along x-axis

Definition at line 1845 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEllsoData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

ellipsoid More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
svxPoint Center
sphere center point More...
double | xLen
length of the ellipsoid along the x (mm) More...
double | yLen
length of the ellipsoid along the y (mm) More...
double | zLen
length of the ellipsoid along the z (mm) More...
int | useAxis
flag to use axis (0 to use plane, 1 to use axis) More...
int | idPlane
optional datum plane (0 to use XY plane) More...
svxAxis axis
optional axis More...
vxName ftrName
feature name for "FtAllEllso", 0 default More...

Detailed Description

ellipsoid

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 110 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::yLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ yLen

double svxEllsoData::yLen

length of the ellipsoid along the y (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 115 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ ftrName

vxName svxEllsoData::ftrName

feature name for "FtAllEllso", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 122 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ idPlane

int svxEllsoData::idPlane

optional datum plane (0 to use XY plane)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 119 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::zLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ zLen

double svxEllsoData::zLen

length of the ellipsoid along the z (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 116 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ Combine

evxBoolType svxEllsoData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 112 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::useAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ useAxis

int svxEllsoData::useAxis

flag to use axis (0 to use plane, 1 to use axis)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 118 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ Center

svxPoint svxEllsoData::Center

sphere center point

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 113 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ axis

svxAxis svxEllsoData::axis

optional axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 120 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEllsoData::xLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEllsoData
axis
Center
Combine
ftrName
idPlane
useAxis
xLen
yLen
zLen

◆ xLen

double svxEllsoData::xLen

length of the ellipsoid along the x (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 114 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEnlargeFaceData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

enlarge face data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | idFace
index of face to enlarge More...
int | applyAll
whether all the edges will be extended the same distance (0 as default) More...
double | distance
the distance to enlarge, used only when applyAll is 1 More...
double | u0
set u0 to extend one edge, used only when applyAll is 0 More...
double | u1
set u1 to extend one edge, used only when applyAll is 0 More...
double | v0
set v0 to extend one edge, used only when applyAll is 0 More...
double | v1
set v1 to extend one edge, used only when applyAll is 0 More...
int | keepOriginal
whether to keep original face (1 as default) More...
evxFaceExtType extension
extension type (VX_FACE_EXTENSION_LINEAR as default) More...

Detailed Description

enlarge face data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 420 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::applyAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ applyAll

int svxEnlargeFaceData::applyAll

whether all the edges will be extended the same distance (0 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 423 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::keepOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ keepOriginal

int svxEnlargeFaceData::keepOriginal

whether to keep original face (1 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 429 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::v0

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ v0

double svxEnlargeFaceData::v0

set v0 to extend one edge, used only when applyAll is 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 427 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ distance

double svxEnlargeFaceData::distance

the distance to enlarge, used only when applyAll is 1

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 424 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ idFace

int svxEnlargeFaceData::idFace

index of face to enlarge

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 422 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::u1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ u1

double svxEnlargeFaceData::u1

set u1 to extend one edge, used only when applyAll is 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 426 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::extension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ extension

evxFaceExtType svxEnlargeFaceData::extension

extension type (VX_FACE_EXTENSION_LINEAR as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 430 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::v1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ v1

double svxEnlargeFaceData::v1

set v1 to extend one edge, used only when applyAll is 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 428 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEnlargeFaceData::u0

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEnlargeFaceData
applyAll
distance
extension
idFace
keepOriginal
u0
u1
v0
v1

◆ u0

double svxEnlargeFaceData::u0

set u0 to extend one edge, used only when applyAll is 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 425 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEntFind Struct Reference
Common » Common Data

entity search data More...

#include <zwapi_util.h>

Data Fields

evxEntFind Option
type of entity to search for More...
svxPoint RefPnt
find entity closest to this reference point More...
evxColor Color
entity color (0 to ignore, VX_COLOR_RGB to use RGB parameters) More...
svxColor Rgb
RGB color if "Color = VX_COLOR_RGB". More...
int | CheckLayer
1 to check layer number (0 to ignore) More...
int | Layer
entity layer number (0 to 255) More...
int | idFeature
parent feature id (0 to ignore) More...
int | isPlane
1 if face entity must be "planer" (0 to ignore) More...
int | isHole
1 if face/edge must belong to a hole (0 to ignore) More...
int | isLine
1 if curve or edge must be linear (0 to ignore) More...
evxEdgeType edgeType
edge type (VX_EDGE_UNKNOWN to ignore) More...
int | idEntity
id of entity found by search (0 if not found) More...
svxPoint Pnt
projection of reference point onto entity More...
double | Dist
distance from reference point to entity More...

Detailed Description

entity search data

Definition at line 1029 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Option

evxEntFind svxEntFind::Option

type of entity to search for

Definition at line 1032 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Pnt

svxPoint svxEntFind::Pnt

projection of reference point onto entity

Definition at line 1048 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::CheckLayer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ CheckLayer

int svxEntFind::CheckLayer

1 to check layer number (0 to ignore)

Definition at line 1038 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Layer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Layer

int svxEntFind::Layer

entity layer number (0 to 255)

Definition at line 1039 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::RefPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ RefPnt

svxPoint svxEntFind::RefPnt

find entity closest to this reference point

Definition at line 1033 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::edgeType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ edgeType

evxEdgeType svxEntFind::edgeType

edge type (VX_EDGE_UNKNOWN to ignore)

Definition at line 1044 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Color

evxColor svxEntFind::Color

entity color (0 to ignore, VX_COLOR_RGB to use RGB parameters)

Definition at line 1036 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Dist

double svxEntFind::Dist

distance from reference point to entity

Definition at line 1049 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::Rgb

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ Rgb

svxColor svxEntFind::Rgb

RGB color if "Color = VX_COLOR_RGB".

Definition at line 1037 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::isPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ isPlane

int svxEntFind::isPlane

1 if face entity must be "planer" (0 to ignore)

Definition at line 1041 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::idEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ idEntity

int svxEntFind::idEntity

id of entity found by search (0 if not found)

Definition at line 1047 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::isHole

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ isHole

int svxEntFind::isHole

1 if face/edge must belong to a hole (0 to ignore)

Definition at line 1042 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::idFeature

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ idFeature

int svxEntFind::idFeature

parent feature id (0 to ignore)

Definition at line 1040 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntFind::isLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntFind
CheckLayer
Color
Dist
edgeType
idEntity
idFeature
isHole
isLine
isPlane
Layer
Option
Pnt
RefPnt
Rgb

◆ isLine

int svxEntFind::isLine

1 if curve or edge must be linear (0 to ignore)

Definition at line 1043 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEntPath Struct Reference
Common » Common Data

entity pick path(sync with VsPickPath) More...

#include <zwapi_util.h>

Data Fields

int | Count
number of id's in the path More...
int | Id [V_PP_LEN]
list of id's that define the path to an entity
Id[0] = -1; path begins with top-level parent file/object (target path)
Id[0] = -2; path begins with currently active root object (root path)
Id[1] = id of first parent entity in path
Id[N] = id of child entity to act upon
See cvxEntPathToRoot() to convert target path to root path More...

Detailed Description

entity pick path(sync with VsPickPath)

Examples
drawing\dwgDimTest.cpp, part\asmConsTest.cpp, part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 267 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPath::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntPath
Count
Id

◆ Count

int svxEntPath::Count

number of id's in the path

Examples
drawing\dwgDimTest.cpp, part\datumCrtTest.cpp, and part\partUtils.cpp.

Definition at line 269 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPath::Id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntPath
Count
Id

◆ Id

int svxEntPath::Id[V_PP_LEN]

list of id's that define the path to an entity
Id[0] = -1; path begins with top-level parent file/object (target path)
Id[0] = -2; path begins with currently active root object (root path)
Id[1] = id of first parent entity in path
Id[N] = id of child entity to act upon
See cvxEntPathToRoot() to convert target path to root path

Examples
drawing\dwgDimTest.cpp, part\datumCrtTest.cpp, and part\smdFtrCrtTest.cpp.

Definition at line 270 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPick Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEntPick Struct Reference
Common » Common Data

entity pick (includes optional parent entity) More...

#include <zwapi_util.h>

Data Fields

int | idEntity
entity id More...
int | idParent
id of entity's parent object (i.e. sketch) or "0" if the entity is a direct child of the target object (i.e. part) More...

Detailed Description

entity pick (includes optional parent entity)

Examples
part\partUtils.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 975 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPick::idEntity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntPick
idEntity
idParent

◆ idEntity

int svxEntPick::idEntity

entity id

Definition at line 977 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEntPick::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEntPick
idEntity
idParent

◆ idParent

int svxEntPick::idParent

id of entity's parent object (i.e. sketch) or "0" if the entity is a direct child of the target object (i.e. part)

Definition at line 978 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEvalCurv Struct Reference
Math » Math Data

curve evaluate More...

#include <zwapi_math_data.h>

Data Fields

int level
level of evaluation
More...
svxPoint pnt
level 0 - x,y,z (or u,v)
More...
svxPoint deriv_1
level 1 - x',y' (or u',v')
More...
svxPoint deriv_2
level 2 - x'',y'' (or u'',v'')
More...
svxPoint deriv_3
level 3 - x''',y''',z''' (or u''',v''')
More...

Detailed Description

curve evaluate

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 46 of file zwapi_math_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalCurv
deriv_1
deriv_2
deriv_3
level
pnt

◆ pnt

svxPoint svxEvalCurv::pnt

level 0 - x,y,z (or u,v)

Definition at line 49 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv::level

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalCurv
deriv_1
deriv_2
deriv_3
level
pnt

◆ level

int svxEvalCurv::level

level of evaluation

Definition at line 48 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv::deriv_2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalCurv
deriv_1
deriv_2
deriv_3
level
pnt

◆ deriv_2

svxPoint svxEvalCurv::deriv_2

level 2 - x'',y'' (or u'',v'')

Definition at line 51 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv::deriv_1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalCurv
deriv_1
deriv_2
deriv_3
level
pnt

◆ deriv_1

svxPoint svxEvalCurv::deriv_1

level 1 - x',y' (or u',v')

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 50 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalCurv::deriv_3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalCurv
deriv_1
deriv_2
deriv_3
level
pnt

◆ deriv_3

svxPoint svxEvalCurv::deriv_3

level 3 - x''',y''',z''' (or u''',v''')

Definition at line 52 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxEvalSurf Struct Reference
Brep » Brep Data

surface evaluate More...

#include <zwapi_brep_data.h>

Data Fields

int level
level of evaluation
More...
svxPoint pnt
level 0 - x,y,z on surface
More...
svxPoint normal
level 1 - unit normal vector
More...
svxPoint partial_u
level 1 - tangential component w/r u
More...
svxPoint partial_v
level 1 - tangential component w/r v
More...
svxPoint partial_uu
level 2 - 2nd partial w/r u
More...
svxPoint partial_uv
level 2 - 2nd partial w/r uv
More...
svxPoint partial_vv
level 2 - 2nd partial w/r v
More...
svxPoint partial_uuu
level 3 - 3rd partial w.r.t u
More...
svxPoint partial_vuu
level 3 - 3rd partial w.r.t uv
More...
svxPoint partial_uvv
level 3 - 3rd partial w.r.t uv
More...
svxPoint partial_vvv
level 3 - 3rd partial w.r.t v
More...
svxPoint partial_uuuu
level 4 - 4th partial w.r.t u
More...
svxPoint partial_vuuu
level 4 - 4th partial w.r.t uv
More...
svxPoint partial_uuvv
level 4 - 4th partial w.r.t uv
More...
svxPoint partial_uvvv
level 4 - 4th partial w.r.t vv
More...
svxPoint partial_vvvv
level 4 - 4th partial w.r.t v
More...

Detailed Description

surface evaluate

Definition at line 76 of file zwapi_brep_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uuu

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uuu

svxPoint svxEvalSurf::partial_uuu

level 3 - 3rd partial w.r.t u

Definition at line 86 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_vuu

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_vuu

svxPoint svxEvalSurf::partial_vuu

level 3 - 3rd partial w.r.t uv

Definition at line 87 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_vvv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_vvv

svxPoint svxEvalSurf::partial_vvv

level 3 - 3rd partial w.r.t v

Definition at line 89 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_vvvv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_vvvv

svxPoint svxEvalSurf::partial_vvvv

level 4 - 4th partial w.r.t v

Definition at line 94 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uuuu

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uuuu

svxPoint svxEvalSurf::partial_uuuu

level 4 - 4th partial w.r.t u

Definition at line 90 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_vuuu

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_vuuu

svxPoint svxEvalSurf::partial_vuuu

level 4 - 4th partial w.r.t uv

Definition at line 91 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uu

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uu

svxPoint svxEvalSurf::partial_uu

level 2 - 2nd partial w/r u

Definition at line 83 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uv

svxPoint svxEvalSurf::partial_uv

level 2 - 2nd partial w/r uv

Definition at line 84 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::level

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ level

int svxEvalSurf::level

level of evaluation

Definition at line 78 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uvvv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uvvv

svxPoint svxEvalSurf::partial_uvvv

level 4 - 4th partial w.r.t vv

Definition at line 93 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uuvv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uuvv

svxPoint svxEvalSurf::partial_uuvv

level 4 - 4th partial w.r.t uv

Definition at line 92 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_uvv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_uvv

svxPoint svxEvalSurf::partial_uvv

level 3 - 3rd partial w.r.t uv

Definition at line 88 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_v

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_v

svxPoint svxEvalSurf::partial_v

level 1 - tangential component w/r v

Definition at line 82 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_vv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_vv

svxPoint svxEvalSurf::partial_vv

level 2 - 2nd partial w/r v

Definition at line 85 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::partial_u

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ partial_u

svxPoint svxEvalSurf::partial_u

level 1 - tangential component w/r u

Definition at line 81 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ pnt

svxPoint svxEvalSurf::pnt

level 0 - x,y,z on surface

Definition at line 79 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxEvalSurf::normal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxEvalSurf
level
normal
partial_u
partial_uu
partial_uuu
partial_uuuu
partial_uuvv
partial_uv
partial_uvv
partial_uvvv
partial_v
partial_vuu
partial_vuuu
partial_vv
partial_vvv
partial_vvvv
pnt

◆ normal

svxPoint svxEvalSurf::normal

level 1 - unit normal vector

Definition at line 80 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxExplodeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxExplodeData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

data of explode command More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | numFace
Number of selected faces. More...
int * | pFace
Id list of faces to explode. More...
int | ConnectFc
flag to use Group connected faces, 0 default More...
int | RebudEdge
flag to use Rebuild edges along boundary, 1 default More...

Detailed Description

data of explode command

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 384 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxExplodeData::RebudEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExplodeData
ConnectFc
numFace
pFace
RebudEdge

◆ RebudEdge

int svxExplodeData::RebudEdge

flag to use Rebuild edges along boundary, 1 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 390 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExplodeData::pFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExplodeData
ConnectFc
numFace
pFace
RebudEdge

◆ pFace

int* svxExplodeData::pFace

Id list of faces to explode.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 387 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExplodeData::ConnectFc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExplodeData
ConnectFc
numFace
pFace
RebudEdge

◆ ConnectFc

int svxExplodeData::ConnectFc

flag to use Group connected faces, 0 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 389 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxExplodeData::numFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExplodeData
ConnectFc
numFace
pFace
RebudEdge

◆ numFace

int svxExplodeData::numFace

Number of selected faces.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 386 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxExtendData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

template command Extend Face data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | idFace
id face (if idFace is 0/-1, it will get from the first edge ) More...
int | cntEdge
count of the extend edges(0-extend all the edges of the face and the idFace must be valid More...
int * | pEdgList
the edges that belonging to the face(NUll to use idFace get all the edges) More...
double * | pDistList
the extend distance list, every edge can be extended with a different value (NULL to use fDist) More...
double | fDist
the extend distance if pDistList is NULL More...
int | iMerge
merge extended face(1-merge, 0-no, initialize 1 as the default) More...
int | iKeepFace
keep the original face(1-keep, 0-no, initialize 0 as the default) More...
int | iExtension
extend method(0-liner, 1-reflect, 2-circular, 4-curvature diminishing, 0-default value) More...

Detailed Description

template command Extend Face data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 318 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::pEdgList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ pEdgList

int* svxExtendData::pEdgList

the edges that belonging to the face(NUll to use idFace get all the edges)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 322 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::fDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ fDist

double svxExtendData::fDist

the extend distance if pDistList is NULL

Definition at line 324 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::pDistList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ pDistList

double* svxExtendData::pDistList

the extend distance list, every edge can be extended with a different value (NULL to use fDist)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 323 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::iExtension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ iExtension

int svxExtendData::iExtension

extend method(0-liner, 1-reflect, 2-circular, 4-curvature diminishing, 0-default value)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 327 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::cntEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ cntEdge

int svxExtendData::cntEdge

count of the extend edges(0-extend all the edges of the face and the idFace must be valid

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 321 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ idFace

int svxExtendData::idFace

id face (if idFace is 0/-1, it will get from the first edge )

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 320 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::iMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ iMerge

int svxExtendData::iMerge

merge extended face(1-merge, 0-no, initialize 1 as the default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 325 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendData::iKeepFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendData
cntEdge
fDist
idFace
iExtension
iKeepFace
iMerge
pDistList
pEdgList

◆ iKeepFace

int svxExtendData::iKeepFace

keep the original face(1-keep, 0-no, initialize 0 as the default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 326 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxExtendShapeData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

extend shape data More...

#include <zwapi_cmd_freeform_data.h>

Data Structures

union evxExtendShapeInpUnion

Data Fields

evxExtendShapeMethod method
method to extend shape (VX_EXTEND_OPEN_SHAPE as default) More...
double | distance
specify the distance to extend. More...
union svxExtendShapeData::evxExtendShapeInpUnion | inpUnion
evxFaceExtType faceExtension
face extension type (VX_FACE_EXT_LINEAR as default) More...
evxEdgeExtensionType edgeExtension
edge extension type (VX_EDGE_EXTENSION_TANGENT as default) More...

Detailed Description

extend shape data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 468 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendGeneralShape
Data Fields
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape Struct Reference

Data Fields

int | nFaces
count of faces to extend More...
int * | idFaces
list of faces to extend More...
int | nEdges
count of edges to extend More...
int * | idEdges
list of edges to extend, the edges should be the edges of the extended faces
More...

Detailed Description

Definition at line 485 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendGeneralShape
idEdges
idFaces
nEdges
nFaces

◆ nEdges

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nEdges

count of edges to extend

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 489 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendGeneralShape
idEdges
idFaces
nEdges
nFaces

◆ idEdges

int* svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idEdges

list of edges to extend, the edges should be the edges of the extended faces

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 490 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendGeneralShape
idEdges
idFaces
nEdges
nFaces

◆ nFaces

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nFaces

count of faces to extend

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 487 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendGeneralShape
idEdges
idFaces
nEdges
nFaces

◆ idFaces

int* svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idFaces

list of faces to extend

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 488 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
Data Fields
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape Struct Reference

Data Fields

int | nEdges
count of edges to extend More...
int * | idEdges
list of edges to extend More...
evxExtendFaceMethod option
extension open face option (VX_EXTEND_FACE_NONE as default) More...
int | nFaces
count of faces to extend to (0 to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT More...
int * | idFaces
list of faces to extend to (NULL to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT More...
int | createFaces
whether to create new linear extension faces More...
int | loftFaces
whether to create new loft extension faces More...

Detailed Description

Definition at line 475 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ option

evxExtendFaceMethod svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::option

extension open face option (VX_EXTEND_FACE_NONE as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 479 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ idEdges

int* svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idEdges

list of edges to extend

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 478 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ nFaces

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nFaces

count of faces to extend to (0 to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 480 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ idFaces

int* svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idFaces

list of faces to extend to (NULL to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 481 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ nEdges

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nEdges

count of edges to extend

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 477 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::loftFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ loftFaces

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::loftFaces

whether to create new loft extension faces

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 483 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::createFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
  • ExtendOpenShape
createFaces
idEdges
idFaces
loftFaces
nEdges
nFaces
option

◆ createFaces

int svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::createFaces

whether to create new linear extension faces

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 482 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::faceExtension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
distance
edgeExtension
faceExtension
method

◆ faceExtension

evxFaceExtType svxExtendShapeData::faceExtension

face extension type (VX_FACE_EXT_LINEAR as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 494 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
distance
edgeExtension
faceExtension
method

◆ distance

double svxExtendShapeData::distance

specify the distance to extend.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 471 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
distance
edgeExtension
faceExtension
method

◆ method

evxExtendShapeMethod svxExtendShapeData::method

method to extend shape (VX_EXTEND_OPEN_SHAPE as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 470 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::edgeExtension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
distance
edgeExtension
faceExtension
method

◆ edgeExtension

evxEdgeExtensionType svxExtendShapeData::edgeExtension

edge extension type (VX_EDGE_EXTENSION_TANGENT as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 495 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxExtrudeData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

extruded shape More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
int | idProfile
profile (sketch or curvelist) More...
double | Start
start distance (mm) More...
double | End
end distance (mm) More...
double | Draft
draft angle (deg) More...
int | Blend
corner blend option More...
int | UseDirection
1 to use optional extrusion direction, else 0 More...
svxVector Direction
optional extrusion direction More...
double | Twist
twist angle (deg) More...
svxPoint Pivot
pivot point if twist is non-zero More...
double | Offset
profile offset (mm) (0 if undefined) More...
double | Thickness
wall thickness (mm) (0 if undefined) More...
int | iKeep
keep profile (1-keep, 0-not keep, not use since 2400) More...
int | numBooleanEnts
count of shapes in BooleanEnts array, use 0 if BooleanEnts is NULL More...
int * | BooleanEnts
id list of shapes to combine with extrusion, use NULL if Combine is VX_BOOL_NONE or to combine extrusion with all visible shapes More...
vxName ftrName
feature name for "FtAllExt", 0 default More...
int | FlipFaceDir
1-flip face direction, else 0 (0:default value, valid when the idProfile is open or CapType == VX_END_CAP_NONE) More...
int | FlipRemoveArea
1-flip bool remove area, else 0 (0:default value, valid when Combine == VX_BOOL_REMOVE) More...
evxDistanceMethod StartType
start type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face) More...
evxDistanceMethod EndType
end type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face) More...
int | idStartEnt
the entity id of start field if StartType > 1 More...
int | idEndEnt
the entity id of end field if EndType > 1 More...
double | StartOffset
start offset value if StartType >= 3 More...
double | EndOffset
end offset value if EndType >= 3 More...
svxPoint * StartToPnt
set the point if StartType > 1 , (NULL to ignore, it will use the start point of idStartEnt) More...
svxPoint * EndToPnt
set the point if EndType > 1 , (NULL to ignore, it will use the start point of idEndEnt) More...
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness) More...
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open) More...
int | cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is open; valid if Combine is VX_BOOL_ADD and the idProfile is close) More...
int * | CapFace
cap face id list (NULL to ignore) More...

Detailed Description

extruded shape

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 164 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::StartToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ StartToPnt

svxPoint* svxExtrudeData::StartToPnt

set the point if StartType > 1 , (NULL to ignore, it will use the start point of idStartEnt)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 199 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::UseDirection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ UseDirection

int svxExtrudeData::UseDirection

1 to use optional extrusion direction, else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 175 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::OffsetTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ OffsetTyp

evxOffsetType svxExtrudeData::OffsetTyp

option of offset(set the value of Offset and Thickness)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 202 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::idStartEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ idStartEnt

int svxExtrudeData::idStartEnt

the entity id of start field if StartType > 1

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 195 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::CapType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ CapType

evxCapType svxExtrudeData::CapType

end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 203 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Combine

evxBoolType svxExtrudeData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 166 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Direction

svxVector svxExtrudeData::Direction

optional extrusion direction

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 176 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::EndOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ EndOffset

double svxExtrudeData::EndOffset

end offset value if EndType >= 3

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 198 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Draft

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Draft

double svxExtrudeData::Draft

draft angle (deg)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 171 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::FlipFaceDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ FlipFaceDir

int svxExtrudeData::FlipFaceDir

1-flip face direction, else 0 (0:default value, valid when the idProfile is open or CapType == VX_END_CAP_NONE)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 191 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::cntCap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ cntCap

int svxExtrudeData::cntCap

count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is open; valid if Combine is VX_BOOL_ADD and the idProfile is close)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 204 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::EndToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ EndToPnt

svxPoint* svxExtrudeData::EndToPnt

set the point if EndType > 1 , (NULL to ignore, it will use the start point of idEndEnt)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 200 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::BooleanEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ BooleanEnts

int* svxExtrudeData::BooleanEnts

id list of shapes to combine with extrusion, use NULL if Combine is VX_BOOL_NONE or to combine extrusion with all visible shapes

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 187 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Start

double svxExtrudeData::Start

start distance (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 168 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::End

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ End

double svxExtrudeData::End

end distance (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 169 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::EndType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ EndType

evxDistanceMethod svxExtrudeData::EndType

end type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 194 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::CapFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ CapFace

int* svxExtrudeData::CapFace

cap face id list (NULL to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 207 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ idProfile

int svxExtrudeData::idProfile

profile (sketch or curvelist)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 167 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::numBooleanEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ numBooleanEnts

int svxExtrudeData::numBooleanEnts

count of shapes in BooleanEnts array, use 0 if BooleanEnts is NULL

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 186 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::idEndEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ idEndEnt

int svxExtrudeData::idEndEnt

the entity id of end field if EndType > 1

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 196 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::FlipRemoveArea

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ FlipRemoveArea

int svxExtrudeData::FlipRemoveArea

1-flip bool remove area, else 0 (0:default value, valid when Combine == VX_BOOL_REMOVE)

Definition at line 192 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ ftrName

vxName svxExtrudeData::ftrName

feature name for "FtAllExt", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 189 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Offset

double svxExtrudeData::Offset

profile offset (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 181 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Twist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Twist

double svxExtrudeData::Twist

twist angle (deg)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 178 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::iKeep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ iKeep

int svxExtrudeData::iKeep

keep profile (1-keep, 0-not keep, not use since 2400)

Definition at line 184 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Thickness

double svxExtrudeData::Thickness

wall thickness (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 182 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::StartOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ StartOffset

double svxExtrudeData::StartOffset

start offset value if StartType >= 3

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 197 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Pivot

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Pivot

svxPoint svxExtrudeData::Pivot

pivot point if twist is non-zero

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 179 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::StartType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ StartType

evxDistanceMethod svxExtrudeData::StartType

start type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 193 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeData::Blend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeData
Blend
BooleanEnts
CapFace
CapType
cntCap
Combine
Direction
Draft
End
EndOffset
EndToPnt
EndType
FlipFaceDir
FlipRemoveArea
ftrName
idEndEnt
idProfile
idStartEnt
iKeep
numBooleanEnts
Offset
OffsetTyp
Pivot
Start
StartOffset
StartToPnt
StartType
Thickness
Twist
UseDirection

◆ Blend

int svxExtrudeData::Blend

corner blend option

(0-variable, 1-constant, 2-round)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 172 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxExtrudeFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Extrude Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idProfile
id of profile More...
evxExtFlangeType extType
extrude type More...
double | start
start distance More...
double | end
end distance More...
double * | thickness
thickness. NULL to use default More...
int | isOpposite
1 if opposite the direction of the flange, else 0 (default:0) More...
double * | radius
radius NULL to use default More...
evxSmdKFactorType * kType
k_factor definition type. NULL to use default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double * | kValue
k_factor. NULL to use default More...
svxPntOnEnt * PntOnCrv
rip point, point on curve, (NULL to ignore) More...
double | RipSize
rip size. the minimum value of "RipSize" is twice the tolerance More...

Detailed Description

template command Smd Extrude Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 216 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::PntOnCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ PntOnCrv

svxPntOnEnt* svxExtrudeFlangeData::PntOnCrv

rip point, point on curve, (NULL to ignore)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 229 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::isOpposite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ isOpposite

int svxExtrudeFlangeData::isOpposite

1 if opposite the direction of the flange, else 0 (default:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 223 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ start

double svxExtrudeFlangeData::start

start distance

Examples
part\smdFtrCrtTest.cpp.

Definition at line 220 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ radius

double* svxExtrudeFlangeData::radius

radius NULL to use default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 224 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ thickness

double* svxExtrudeFlangeData::thickness

thickness. NULL to use default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 222 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::extType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ extType

evxExtFlangeType svxExtrudeFlangeData::extType

extrude type

Examples
part\smdFtrCrtTest.cpp.

Definition at line 219 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ kValue

double* svxExtrudeFlangeData::kValue

k_factor. NULL to use default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 228 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::end

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ end

double svxExtrudeFlangeData::end

end distance

Examples
part\smdFtrCrtTest.cpp.

Definition at line 221 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ kType

evxSmdKFactorType* svxExtrudeFlangeData::kType

k_factor definition type. NULL to use default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 225 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ idProfile

int svxExtrudeFlangeData::idProfile

id of profile

Examples
part\smdFtrCrtTest.cpp.

Definition at line 218 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxExtrudeFlangeData::RipSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtrudeFlangeData
end
extType
idProfile
isOpposite
kType
kValue
PntOnCrv
radius
RipSize
start
thickness

◆ RipSize

double svxExtrudeFlangeData::RipSize

rip size. the minimum value of "RipSize" is twice the tolerance

Examples
part\smdFtrCrtTest.cpp.

Definition at line 230 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFCSData Struct Reference
Common » Common Data

FCS data. More...

#include <zwapi_util.h>

Data Fields

evxFCSSymbol sym
FCS's MD&T symbol. More...
svxFCSTol | tol [2]
FCS's tolerance. More...
svxFCSDatum | datum [3][3]
FCS's datum. More...

Detailed Description

FCS data.

Definition at line 2181 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSData
datum
sym
tol

◆ tol

svxFCSTol svxFCSData::tol[2]

FCS's tolerance.

Definition at line 2184 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSData::sym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSData
datum
sym
tol

◆ sym

evxFCSSymbol svxFCSData::sym

FCS's MD&T symbol.

Definition at line 2183 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSData::datum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSData
datum
sym
tol

◆ datum

svxFCSDatum svxFCSData::datum[3][3]

FCS's datum.

Definition at line 2185 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSDatum Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFCSDatum Struct Reference
Common » Common Data

FCS datum data. More...

#include <zwapi_util.h>

Data Fields

int | isValid
valid data (0-no, 1-yes) More...
vxLongName datum
datum More...
evxFCSLmsOption lmsOpt
LMS options. More...
int | freeState
free state (0-no, 1-yes) More...

Detailed Description

FCS datum data.

Definition at line 2169 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSDatum::datum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSDatum
datum
freeState
isValid
lmsOpt

◆ datum

vxLongName svxFCSDatum::datum

datum

Definition at line 2172 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSDatum::isValid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSDatum
datum
freeState
isValid
lmsOpt

◆ isValid

int svxFCSDatum::isValid

valid data (0-no, 1-yes)

Definition at line 2171 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSDatum::freeState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSDatum
datum
freeState
isValid
lmsOpt

◆ freeState

int svxFCSDatum::freeState

free state (0-no, 1-yes)

Definition at line 2174 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSDatum::lmsOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSDatum
datum
freeState
isValid
lmsOpt

◆ lmsOpt

evxFCSLmsOption svxFCSDatum::lmsOpt

LMS options.

Definition at line 2173 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFCSTol Struct Reference
Common » Common Data

FCS tolerance data. More...

#include <zwapi_util.h>

Data Fields

int | isValid
valid data (0-no, 1-yes) More...
evxFCSShapeSym shapeSym
area shape symbol More...
vxLongName tol
tolerance More...
evxFCSLmsOption lmsOpt
LMS options. More...
int | freeState
free state (0-no, 1-yes) More...
int | tangentPlane
tangent plane (0-no, 1-yes) More...
int | projTolFlag
projected tolerance flag (0-no, 1-yes) More...
vxLongName projTol
projected tolerance More...
int | statisticalTol
statistical tolerance (0-no, 1-yes) More...

Detailed Description

FCS tolerance data.

Definition at line 2152 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ tol

vxLongName svxFCSTol::tol

tolerance

Definition at line 2156 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::isValid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ isValid

int svxFCSTol::isValid

valid data (0-no, 1-yes)

Definition at line 2154 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::tangentPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ tangentPlane

int svxFCSTol::tangentPlane

tangent plane (0-no, 1-yes)

Definition at line 2159 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::statisticalTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ statisticalTol

int svxFCSTol::statisticalTol

statistical tolerance (0-no, 1-yes)

Definition at line 2162 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::projTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ projTol

vxLongName svxFCSTol::projTol

projected tolerance

Definition at line 2161 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::shapeSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ shapeSym

evxFCSShapeSym svxFCSTol::shapeSym

area shape symbol

Definition at line 2155 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::projTolFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ projTolFlag

int svxFCSTol::projTolFlag

projected tolerance flag (0-no, 1-yes)

Definition at line 2160 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::lmsOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ lmsOpt

evxFCSLmsOption svxFCSTol::lmsOpt

LMS options.

Definition at line 2157 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFCSTol::freeState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFCSTol
freeState
isValid
lmsOpt
projTol
projTolFlag
shapeSym
statisticalTol
tangentPlane
tol

◆ freeState

int svxFCSTol::freeState

free state (0-no, 1-yes)

Definition at line 2158 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFaceAt Struct Reference
Common » Common Data

face display attributes More...

#include <zwapi_util.h>

Data Fields

unsigned char | reflectance
reflectance More...
unsigned char | refraction
refraction More...
unsigned char | exp
specular reflection exponent (0-128) More...
unsigned char | trans
transparency setting (0-100) More...
unsigned char | ambient
ambient reflection coeff. (0-100) More...
unsigned char | diffuse
diffuse reflection coeff. (0-100) More...
unsigned char | specular
specular reflection coeff. (0-100) More...
unsigned char | emission
emission coeff. (0-100) More...
svxColor front_color
color of front side More...
svxColor back_color
color of back side More...
svxColor spec_color
specular color More...

Detailed Description

face display attributes

Definition at line 1139 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::front_color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ front_color

svxColor svxFaceAt::front_color

color of front side

Definition at line 1149 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::emission

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ emission

unsigned char svxFaceAt::emission

emission coeff. (0-100)

Definition at line 1148 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::exp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ exp

unsigned char svxFaceAt::exp

specular reflection exponent (0-128)

Definition at line 1143 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::refraction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ refraction

unsigned char svxFaceAt::refraction

refraction

Definition at line 1142 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::trans

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ trans

unsigned char svxFaceAt::trans

transparency setting (0-100)

Definition at line 1144 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::specular

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ specular

unsigned char svxFaceAt::specular

specular reflection coeff. (0-100)

Definition at line 1147 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::reflectance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ reflectance

unsigned char svxFaceAt::reflectance

reflectance

Definition at line 1141 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::ambient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ ambient

unsigned char svxFaceAt::ambient

ambient reflection coeff. (0-100)

Definition at line 1145 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::spec_color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ spec_color

svxColor svxFaceAt::spec_color

specular color

Definition at line 1151 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::back_color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ back_color

svxColor svxFaceAt::back_color

color of back side

Definition at line 1150 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceAt::diffuse

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceAt
ambient
back_color
diffuse
emission
exp
front_color
reflectance
refraction
spec_color
specular
trans

◆ diffuse

unsigned char svxFaceAt::diffuse

diffuse reflection coeff. (0-100)

Definition at line 1146 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxFaceCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

face curve data More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union uvxFaceCrvData

Data Fields

int | method
create face curves method (0-from edges, 1-from projected curves) More...
int | cntFaces
count of faces on which to create the face curves More...
int * | pFaces
index of faces on which to create the face curves More...
int | partingLine
1 to add the selected Edges as parting line, else 0 More...
union svxFaceCrvData::uvxFaceCrvData | inpUion

Detailed Description

face curve data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 323 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromEdges Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromEdges
Data Fields
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges Struct Reference

Data Fields

int | cntEdge
count of edges More...
int * | pEdge
If this field is empty, face curves are created surrounding the region formed by the selected faces. If you pick specific edges for this field, face curves are created only from those selected edges, but a selected edge will be ignored if it is not adjacent to one of the selected faces, or if it is adjacent to several selected faces. More...
int | seam
1 to create face curves along seam edges, 0 to ignore More...

Detailed Description

Definition at line 331 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::seam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromEdges
cntEdge
pEdge
seam

◆ seam

int svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::seam

1 to create face curves along seam edges, 0 to ignore

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 339 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::pEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromEdges
cntEdge
pEdge
seam

◆ pEdge

int* svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::pEdge

If this field is empty, face curves are created surrounding the region formed by the selected faces. If you pick specific edges for this field, face curves are created only from those selected edges, but a selected edge will be ignored if it is not adjacent to one of the selected faces, or if it is adjacent to several selected faces.

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 334 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::cntEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromEdges
cntEdge
pEdge
seam

◆ cntEdge

int svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::cntEdge

count of edges

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 333 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromProjCrv
Data Fields
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv Struct Reference

Data Fields

int | cntCrv
count of curves More...
int * | pCrv
curves, sketches, curve lists and edges to project onto the selected faces More...
svxVector * dir
direction curves are projected onto (NULL to projected in the direction of minimum distance from the curve to that face) More...

Detailed Description

Definition at line 341 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromProjCrv
cntCrv
dir
pCrv

◆ cntCrv

int svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::cntCrv

count of curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 343 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromProjCrv
cntCrv
dir
pCrv

◆ dir

svxVector* svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::dir

direction curves are projected onto (NULL to projected in the direction of minimum distance from the curve to that face)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 345 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::pCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
  • uvxFromProjCrv
cntCrv
dir
pCrv

◆ pCrv

int* svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::pCrv

curves, sketches, curve lists and edges to project onto the selected faces

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 344 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::cntFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
cntFaces
method
partingLine
pFaces

◆ cntFaces

int svxFaceCrvData::cntFaces

count of faces on which to create the face curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 326 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::pFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
cntFaces
method
partingLine
pFaces

◆ pFaces

int* svxFaceCrvData::pFaces

index of faces on which to create the face curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 327 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::partingLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
cntFaces
method
partingLine
pFaces

◆ partingLine

int svxFaceCrvData::partingLine

1 to add the selected Edges as parting line, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 328 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
cntFaces
method
partingLine
pFaces

◆ method

int svxFaceCrvData::method

create face curves method (0-from edges, 1-from projected curves)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 325 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFaceFind Struct Reference
Math » Math Data

face search data More...

#include <zwapi_math_data.h>

Data Fields

int | numSeeds
number of seed faces More...
int * | idSeeds
list of seed faces More...
evxFaceFindType Option
type of face to search for More...
int | Rule
face search rules(evxFindRule),like this:VX_STOP_FACE_FILLET | VX_STOP_FACE_FILLET, used only for VX_FIND_CUSTOM & VX_FIND_FINDER(evxFaceFindType) type More...
int | numEdges
number of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type
More...
int * | idEdges
list of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type More...
int | AdjCnt
adjacency count(>0), used only when Rule contain VX_STOP_ADJACENCY_LEVEL More...
int | numFaces
number of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE More...
int * | idFaces
list of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE More...

Detailed Description

face search data

Definition at line 76 of file zwapi_math_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::Option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ Option

evxFaceFindType svxFaceFind::Option

type of face to search for

Definition at line 80 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::numEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ numEdges

int svxFaceFind::numEdges

number of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type

Definition at line 83 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::Rule

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ Rule

int svxFaceFind::Rule

face search rules(evxFindRule),like this:VX_STOP_FACE_FILLET | VX_STOP_FACE_FILLET, used only for VX_FIND_CUSTOM & VX_FIND_FINDER(evxFaceFindType) type

Definition at line 81 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::numFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ numFaces

int svxFaceFind::numFaces

number of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE

Definition at line 86 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ idEdges

int* svxFaceFind::idEdges

list of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type

Definition at line 84 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::AdjCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ AdjCnt

int svxFaceFind::AdjCnt

adjacency count(>0), used only when Rule contain VX_STOP_ADJACENCY_LEVEL

Definition at line 85 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::idSeeds

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ idSeeds

int* svxFaceFind::idSeeds

list of seed faces

Definition at line 79 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ idFaces

int* svxFaceFind::idFaces

list of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE

Definition at line 87 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFind::numSeeds

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFind
AdjCnt
idEdges
idFaces
idSeeds
numEdges
numFaces
numSeeds
Option
Rule

◆ numSeeds

int svxFaceFind::numSeeds

number of seed faces

Definition at line 78 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFaceFlltData Struct Reference

Data Fields

int | cntFace
int * | idFace
evxFaceFlltType | faceFlltType
int | idTangetFace
double | radius
int | baseFaces
int | searchFlag

Detailed Description

Definition at line 518 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::searchFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ searchFlag

int svxFaceFlltData::searchFlag

Definition at line 526 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::baseFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ baseFaces

int svxFaceFlltData::baseFaces

Definition at line 525 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::faceFlltType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ faceFlltType

evxFaceFlltType svxFaceFlltData::faceFlltType

Definition at line 522 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::cntFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ cntFace

int svxFaceFlltData::cntFace

Definition at line 520 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::idTangetFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ idTangetFace

int svxFaceFlltData::idTangetFace

Definition at line 523 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ idFace

int* svxFaceFlltData::idFace

Definition at line 521 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceFlltData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceFlltData

◆ radius

double svxFaceFlltData::radius

Definition at line 524 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFaceOffData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape face offset data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | type
face offset type (0 = constant, 1 = variable) More...
int | numFaces
number of faces for offset More...
int * | idFaces
list of id's of faces for offset More...
double | offset
offset value More...
int | numOffsetSet
number of face offset set More...
int * | idFaceSet
list of id's of faces in offset set More...
double * | offsetSet
list of offset value in offset set More...
int | sideFaces
whether to create side faces (0 = do not create, 1 = create, 2 = force) More...
int | extension
extension type of offset face (0 = linear, 1 = circular, 2 = reflect, 3 = curvature diminishing) More...
int | intersect
whether to remove self intersecting faces (0 = do not remove, 1 = remove all) More...
vxName ftrName
feature name for "FtOffsetFace1", 0 default More...

Detailed Description

shape face offset data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 985 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ type

int svxFaceOffData::type

face offset type (0 = constant, 1 = variable)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 987 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::numOffsetSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ numOffsetSet

int svxFaceOffData::numOffsetSet

number of face offset set

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 995 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::sideFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ sideFaces

int svxFaceOffData::sideFaces

whether to create side faces (0 = do not create, 1 = create, 2 = force)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 999 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ ftrName

vxName svxFaceOffData::ftrName

feature name for "FtOffsetFace1", 0 default

Definition at line 1003 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::idFaceSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ idFaceSet

int* svxFaceOffData::idFaceSet

list of id's of faces in offset set

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 996 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::numFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ numFaces

int svxFaceOffData::numFaces

number of faces for offset

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 990 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::extension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ extension

int svxFaceOffData::extension

extension type of offset face (0 = linear, 1 = circular, 2 = reflect, 3 = curvature diminishing)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1000 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ offset

double svxFaceOffData::offset

offset value

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 992 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::offsetSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ offsetSet

double* svxFaceOffData::offsetSet

list of offset value in offset set

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 997 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::intersect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ intersect

int svxFaceOffData::intersect

whether to remove self intersecting faces (0 = do not remove, 1 = remove all)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1001 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceOffData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceOffData
extension
ftrName
idFaces
idFaceSet
intersect
numFaces
numOffsetSet
offset
offsetSet
sideFaces
type

◆ idFaces

int* svxFaceOffData::idFaces

list of id's of faces for offset

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 991 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFacets Struct Reference
Common » Common Data

3D facets defined by triangle strips More...

#include <zwapi_util.h>

Data Fields

int | numTriStrip
number of triangle strips in TriStrip list More...
int * | TriStrip
list of integer indices that define triangle strips More...
int | numVertex
number of vertices in Vertex list More...
svxPointf * Vertex
list of vertex coordinates (x,y,z) More...
svxPointf * Normal
list of vertex normals (i,j,k unit direction vector); Normal is optional and may be NULL More...
svxPoint2f * ST
list of vertex texture coordinates (s,t from 0.0 to 1.0); ST is optional and may be NULL More...
svxFaceAt At
optional display attributes More...
svxTextureAt Tx
optional texture attributes More...
svxShaderAt Sh
optional shader attributes More...
svxPoint2f * UV
list of UV coordinates corresponding to vertex coordinates; UV is optional and may be NULL More...
svxColorf * RGB
list of vertex colors (r,g,b components from 0.0 to 1.0; see cvxColorfToColor() for conversion to svxColor); RGB is optional and may be NULL (NOTE: The RGB field is a placeholder for a future enhancement and is not yet supported. Colors assigned to this field will be ignored when a facet block is displayed.) More...

Detailed Description

3D facets defined by triangle strips

Definition at line 1891 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::RGB

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ RGB

svxColorf* svxFacets::RGB

list of vertex colors (r,g,b components from 0.0 to 1.0; see cvxColorfToColor() for conversion to svxColor); RGB is optional and may be NULL (NOTE: The RGB field is a placeholder for a future enhancement and is not yet supported. Colors assigned to this field will be ignored when a facet block is displayed.)

Definition at line 1919 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::Sh

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ Sh

svxShaderAt svxFacets::Sh

optional shader attributes

Definition at line 1916 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::At

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ At

svxFaceAt svxFacets::At

optional display attributes

Definition at line 1914 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::ST

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ ST

svxPoint2f* svxFacets::ST

list of vertex texture coordinates (s,t from 0.0 to 1.0); ST is optional and may be NULL

Definition at line 1912 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::Vertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ Vertex

svxPointf* svxFacets::Vertex

list of vertex coordinates (x,y,z)

Definition at line 1909 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::Normal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ Normal

svxPointf* svxFacets::Normal

list of vertex normals (i,j,k unit direction vector); Normal is optional and may be NULL

Definition at line 1910 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::UV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ UV

svxPoint2f* svxFacets::UV

list of UV coordinates corresponding to vertex coordinates; UV is optional and may be NULL

Definition at line 1917 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::Tx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ Tx

svxTextureAt svxFacets::Tx

optional texture attributes

Definition at line 1915 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::numVertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ numVertex

int svxFacets::numVertex

number of vertices in Vertex list

Definition at line 1908 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::TriStrip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ TriStrip

int* svxFacets::TriStrip

list of integer indices that define triangle strips

This list has the format "num_vertices_in_strip_1, <br> index_of_vertex_1,index_of_vertex_2,...,index_of_vertex_N, <br> num_vertices_in_strip_2,..." where an index is an offset
into the list of Vertex/Normal/ST/UV/RGB coordinates, numbered
from 0. A triangle strip defined by N vertices defines
N-2 triangles. For example, if a triangle strip is
defined by 5 vertices whose indices are {0,1,2,3,4},
then it contains 3 triangles defined by vertices {0,1,2},
{2,1,3} and {2,3,4} (when using data from a triangle strip,
note that vertex order is implicitly reversed for alternating
triangles when calculating the implied normal direction
of each triangle's plane).

Definition at line 1894 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFacets::numTriStrip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFacets
At
Normal
numTriStrip
numVertex
RGB
Sh
ST
TriStrip
Tx
UV
Vertex

◆ numTriStrip

int svxFacets::numTriStrip

number of triangle strips in TriStrip list

Definition at line 1893 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxFcsOffsetData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

faces offset data More...

#include <zwapi_cmd_freeform_data.h>

Data Structures

struct svxVarOffset
faces offset variable data More...

Data Fields

int | count
count of "faces" More...
int * | faces
list of face id More...
double | offset
offset More...
int | keepSurface
1 is keep original surface, else 0 More...
int | keepEdge
1 is keep edge connectivity, else 0 More...
int | cnt
count of "list", cnt=0 to ignore More...
struct svxFcsOffsetData::svxVarOffset * | list
NULL to ignore.

Detailed Description

faces offset data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 296 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::svxVarOffset Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
  • svxVarOffset
Data Fields
svxFcsOffsetData::svxVarOffset Struct Reference

faces offset variable data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

svxPntOnEnt pntOnEnt
set point on face(or edge) More...
double pntOffset
offset More...

Detailed Description

faces offset variable data

<

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 307 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::svxVarOffset::pntOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
  • svxVarOffset
pntOffset
pntOnEnt

◆ pntOffset

double svxFcsOffsetData::svxVarOffset::pntOffset

offset

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 310 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::svxVarOffset::pntOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
  • svxVarOffset
pntOffset
pntOnEnt

◆ pntOnEnt

svxPntOnEnt svxFcsOffsetData::svxVarOffset::pntOnEnt

set point on face(or edge)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 309 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::keepEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ keepEdge

int svxFcsOffsetData::keepEdge

1 is keep edge connectivity, else 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 303 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::keepSurface

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ keepSurface

int svxFcsOffsetData::keepSurface

1 is keep original surface, else 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 302 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ offset

double svxFcsOffsetData::offset

offset

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 300 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ cnt

int svxFcsOffsetData::cnt

count of "list", cnt=0 to ignore

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 306 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::faces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ faces

int* svxFcsOffsetData::faces

list of face id

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 299 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFcsOffsetData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFcsOffsetData
cnt
count
faces
keepEdge
keepSurface
list
offset

◆ count

int svxFcsOffsetData::count

count of "faces"

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 298 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFilletBlendData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

freeForm filletBlend data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | type
whether to create an intelligent blend face with a specified radius (0 = without radius, 1 = with radius) More...
svxPntOnEntPath from
select the first (from) curve or face More...
svxPntOnEntPath to
select the second (to) curve or face More...
svxPntOnEntPath through
this field is available only if type = 0. select the curve or face to pass through or you can enter a fillet radius More...
double | radius
this field is available only if type = 1. if Blend with a Radius is selected, use this to specify the desired radius of the blend face More...
evxSpineType spineType
specify the drive curve method More...
int | idCurve
this field is available only if spineType = VX_SPINE_SPINE. select a curve to be used as the spine More...
svxVector plane
this field is available only if spineType = VX_SPINE_PARALLEL. select a parallel plane More...
evxCroSecType croSecType
specify the arc type that will define the cross-sectional shape of the face More...
double | conicRatio
this field is available only if croSecType = VX_CRO_SEC_CONIC (the range of 0 - 1. default = 0.5) More...
double | startWeight
this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND More...
double | endWeight
this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND More...
int | sewShapes
whether to sew the shapes automatically (0 = not sew, 1 = sew. default = 1) since R2024, it doesn't sew the new shapes and if user set it to 1, it will create a 'Sew' feature to sew the shapes More...
int | numShapes
this field is available only if sewShapes = 1. the number of the sewed shapes More...
int * | idShapes
this field is available only if sewShapes = 1. the shapes to be sewed More...
evxSewingType sewingType
options to modify the supporting faces More...
evxCappingType cappingType
methods of trimming the ends of the fillets More...

Detailed Description

freeForm filletBlend data

Definition at line 78 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::sewingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ sewingType

evxSewingType svxFilletBlendData::sewingType

options to modify the supporting faces

Definition at line 101 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ type

int svxFilletBlendData::type

whether to create an intelligent blend face with a specified radius (0 = without radius, 1 = with radius)

Definition at line 81 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::endWeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ endWeight

double svxFilletBlendData::endWeight

this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND

Definition at line 94 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::idCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ idCurve

int svxFilletBlendData::idCurve

this field is available only if spineType = VX_SPINE_SPINE. select a curve to be used as the spine

Definition at line 88 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::through

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ through

svxPntOnEntPath svxFilletBlendData::through

this field is available only if type = 0. select the curve or face to pass through or you can enter a fillet radius

Definition at line 84 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::startWeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ startWeight

double svxFilletBlendData::startWeight

this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND

Definition at line 93 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::croSecType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ croSecType

evxCroSecType svxFilletBlendData::croSecType

specify the arc type that will define the cross-sectional shape of the face

Definition at line 91 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::from

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ from

svxPntOnEntPath svxFilletBlendData::from

select the first (from) curve or face

Definition at line 82 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::plane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ plane

svxVector svxFilletBlendData::plane

this field is available only if spineType = VX_SPINE_PARALLEL. select a parallel plane

Definition at line 89 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::spineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ spineType

evxSpineType svxFilletBlendData::spineType

specify the drive curve method

Definition at line 87 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ numShapes

int svxFilletBlendData::numShapes

this field is available only if sewShapes = 1. the number of the sewed shapes

Definition at line 98 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::cappingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ cappingType

evxCappingType svxFilletBlendData::cappingType

methods of trimming the ends of the fillets

Definition at line 102 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ idShapes

int* svxFilletBlendData::idShapes

this field is available only if sewShapes = 1. the shapes to be sewed

Definition at line 99 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ radius

double svxFilletBlendData::radius

this field is available only if type = 1. if Blend with a Radius is selected, use this to specify the desired radius of the blend face

Definition at line 85 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::to

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ to

svxPntOnEntPath svxFilletBlendData::to

select the second (to) curve or face

Definition at line 83 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::conicRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ conicRatio

double svxFilletBlendData::conicRatio

this field is available only if croSecType = VX_CRO_SEC_CONIC (the range of 0 - 1. default = 0.5)

Definition at line 92 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFilletBlendData::sewShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFilletBlendData
cappingType
conicRatio
croSecType
endWeight
from
idCurve
idShapes
numShapes
plane
radius
sewingType
sewShapes
spineType
startWeight
through
to
type

◆ sewShapes

int svxFilletBlendData::sewShapes

whether to sew the shapes automatically (0 = not sew, 1 = sew. default = 1) since R2024, it doesn't sew the new shapes and if user set it to 1, it will create a 'Sew' feature to sew the shapes

Definition at line 96 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxFlagExtThreadData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

flag ext thread data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

struct svxCustomInfo
if type[0]==0, apply it. More...

Data Fields

int | count
count of "Faces" More...
svxPoint * Faces
faces More...
int * | IdFaces
id(IdFaces[0]) of face(Faces[0]) More...
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "StandardValue" to "type" More...
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "size" More...
struct svxFlagExtThreadData::svxCustomInfo | custom
evxFlagThreadDepthType LengthType
length type More...
double | length
length More...
int | isChamfer
1 if end chamfer ,else 0 More...
double | SetBack
SetBack. More...
double | angle
angle More...

Detailed Description

flag ext thread data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 874 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::svxCustomInfo Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
  • svxCustomInfo
Data Fields
svxFlagExtThreadData::svxCustomInfo Struct Reference

if type[0]==0, apply it. More...

#include <zwapi_cmd_shape_data.h>

Data Fields

double | diamter
diameter More...
int | isThread
1 if thread/unit ,else pitch More...
double | value
isThread is 0, value is pitch value,else Thread/Unit value More...
int | useDiam
1-use diameter, 0 use the diameter of the first input face (default: 0) More...

Detailed Description

if type[0]==0, apply it.

<

Definition at line 885 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::svxCustomInfo::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
  • svxCustomInfo
diamter
isThread
useDiam
value

◆ value

double svxFlagExtThreadData::svxCustomInfo::value

isThread is 0, value is pitch value,else Thread/Unit value

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 889 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::svxCustomInfo::isThread

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
  • svxCustomInfo
diamter
isThread
useDiam
value

◆ isThread

int svxFlagExtThreadData::svxCustomInfo::isThread

1 if thread/unit ,else pitch

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 888 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::svxCustomInfo::diamter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
  • svxCustomInfo
diamter
isThread
useDiam
value

◆ diamter

double svxFlagExtThreadData::svxCustomInfo::diamter

diameter

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 887 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::svxCustomInfo::useDiam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
  • svxCustomInfo
diamter
isThread
useDiam
value

◆ useDiam

int svxFlagExtThreadData::svxCustomInfo::useDiam

1-use diameter, 0 use the diameter of the first input face (default: 0)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 890 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::IdFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ IdFaces

int* svxFlagExtThreadData::IdFaces

id(IdFaces[0]) of face(Faces[0])

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 878 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ type

vxLongName svxFlagExtThreadData::type

flag thread hole type The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "StandardValue" to "type"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 879 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::LengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ LengthType

evxFlagThreadDepthType svxFlagExtThreadData::LengthType

length type

If LengthType = VX_FLAG_THREAD_DEPTH_FULL, the thread length is the length of the selected cylindrical face.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 892 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ count

int svxFlagExtThreadData::count

count of "Faces"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 876 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::isChamfer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ isChamfer

int svxFlagExtThreadData::isChamfer

1 if end chamfer ,else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 896 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::SetBack

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ SetBack

double svxFlagExtThreadData::SetBack

SetBack.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 898 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ angle

double svxFlagExtThreadData::angle

angle

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 899 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::Faces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ Faces

svxPoint* svxFlagExtThreadData::Faces

faces

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 877 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ size

vxLongName svxFlagExtThreadData::size

flag thread hole size The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "size"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 882 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagExtThreadData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagExtThreadData
angle
count
Faces
IdFaces
isChamfer
length
LengthType
SetBack
size
type

◆ length

double svxFlagExtThreadData::length

length

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 895 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxFlagHoleData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

flag hole data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

struct | svxCustomData
if type[0]==0, apply it. More...
struct | svxFilterCondition
filter condition data More...

Data Fields

int | FaceId
face id More...
int | count
count of "HolesId" More...
int * | HolesId
list of hole id More...
int | isUseFilter
1 if use hole filter,else 0 More...
struct svxFlagHoleData::svxFilterCondition | FilterData
int | isUseFlaggedThread
1 if use flagged as thread hole,else 0 More...
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "StandardValue" to "type" More...
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "size" More...
struct svxFlagHoleData::svxCustomData | custom
evxFlagThreadDepthType DepthType
depth type if DepthType = VX_FLAG_THREAD_DEPTH_FULL, the thread depth is the hole depth. More...
double | depth
depth : if DepthType = VX_FLAG_THREAD_DEPTH_CUSTOM, users can specify the thread depth into the hole feature. More...
svxPntOnEnt * DepthPnt
set the depth by "To point" More...
vxLongName CalloutLabel
callout label More...
int | isAddD1
1 if add D1 tolerance ,else 0 More...
double | UpperLimit
upper limit More...
double | LowerLimit
lower limit More...
evxThreadHoleClass ThreadClass
thread class More...
int | isMachine
1 if do not machine,else 0 More...
int | isCounter
1 if counter sink hole as simple hole with chamfer More...

Detailed Description

flag hole data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 801 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxCustomData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxCustomData
Data Fields
svxFlagHoleData::svxCustomData Struct Reference

if type[0]==0, apply it. More...

#include <zwapi_cmd_shape_data.h>

Data Fields

double | diamter
diameter More...
int | isPitch
1 if pitch ,else thread/unit More...
double | value
isPitch is 1,value is pitch value,else Thread/Unit value More...

Detailed Description

if type[0]==0, apply it.

<

Definition at line 827 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxCustomData::isPitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxCustomData
diamter
isPitch
value

◆ isPitch

int svxFlagHoleData::svxCustomData::isPitch

1 if pitch ,else thread/unit

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 830 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxCustomData::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxCustomData
diamter
isPitch
value

◆ value

double svxFlagHoleData::svxCustomData::value

isPitch is 1,value is pitch value,else Thread/Unit value

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 831 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxCustomData::diamter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxCustomData
diamter
isPitch
value

◆ diamter

double svxFlagHoleData::svxCustomData::diamter

diameter

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 829 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
Data Fields
svxFlagHoleData::svxFilterCondition Struct Reference

filter condition data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxHoleType HoleShape
hole shape More...
int | isOnlyCylindrical
1 if only whole cylindrical,else 0 More...
int | isDiameter
1 if edit diameter,else 0 More...
double | DiameterStart
diameter start More...
double | DiameterEnd
diameter end More...
int | isDepth
1 if edit depth ,else 0 More...
double | DepthStart
depth start More...
double | DepthEnd
depth end More...

Detailed Description

filter condition data

<

Definition at line 808 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::DepthStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ DepthStart

double svxFlagHoleData::svxFilterCondition::DepthStart

depth start

Definition at line 816 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::HoleShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ HoleShape

evxHoleType svxFlagHoleData::svxFilterCondition::HoleShape

hole shape

Definition at line 810 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::DiameterEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ DiameterEnd

double svxFlagHoleData::svxFilterCondition::DiameterEnd

diameter end

Definition at line 814 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::isDepth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ isDepth

int svxFlagHoleData::svxFilterCondition::isDepth

1 if edit depth ,else 0

Definition at line 815 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::isDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ isDiameter

int svxFlagHoleData::svxFilterCondition::isDiameter

1 if edit diameter,else 0

Definition at line 812 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::isOnlyCylindrical

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ isOnlyCylindrical

int svxFlagHoleData::svxFilterCondition::isOnlyCylindrical

1 if only whole cylindrical,else 0

Definition at line 811 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::DepthEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ DepthEnd

double svxFlagHoleData::svxFilterCondition::DepthEnd

depth end

Definition at line 817 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::svxFilterCondition::DiameterStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
  • svxFilterCondition
DepthEnd
DepthStart
DiameterEnd
DiameterStart
HoleShape
isDepth
isDiameter
isOnlyCylindrical

◆ DiameterStart

double svxFlagHoleData::svxFilterCondition::DiameterStart

diameter start

Definition at line 813 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::isCounter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ isCounter

int svxFlagHoleData::isCounter

1 if counter sink hole as simple hole with chamfer

Definition at line 846 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::DepthPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ DepthPnt

svxPntOnEnt* svxFlagHoleData::DepthPnt

set the depth by "To point"

Definition at line 837 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::isMachine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ isMachine

int svxFlagHoleData::isMachine

1 if do not machine,else 0

Definition at line 844 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::LowerLimit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ LowerLimit

double svxFlagHoleData::LowerLimit

lower limit

Definition at line 842 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::depth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ depth

double svxFlagHoleData::depth

depth : if DepthType = VX_FLAG_THREAD_DEPTH_CUSTOM, users can specify the thread depth into the hole feature.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 835 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::DepthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ DepthType

evxFlagThreadDepthType svxFlagHoleData::DepthType

depth type if DepthType = VX_FLAG_THREAD_DEPTH_FULL, the thread depth is the hole depth.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 833 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::isUseFlaggedThread

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ isUseFlaggedThread

int svxFlagHoleData::isUseFlaggedThread

1 if use flagged as thread hole,else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 820 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::CalloutLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ CalloutLabel

vxLongName svxFlagHoleData::CalloutLabel

callout label

Definition at line 839 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::UpperLimit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ UpperLimit

double svxFlagHoleData::UpperLimit

upper limit

Definition at line 841 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::isAddD1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ isAddD1

int svxFlagHoleData::isAddD1

1 if add D1 tolerance ,else 0

Definition at line 840 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::HolesId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ HolesId

int* svxFlagHoleData::HolesId

list of hole id

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 805 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::isUseFilter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ isUseFilter

int svxFlagHoleData::isUseFilter

1 if use hole filter,else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 807 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::FaceId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ FaceId

int svxFlagHoleData::FaceId

face id

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 803 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::ThreadClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ ThreadClass

evxThreadHoleClass svxFlagHoleData::ThreadClass

thread class

Definition at line 843 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ type

vxLongName svxFlagHoleData::type

flag thread hole type The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "StandardValue" to "type"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 821 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ count

int svxFlagHoleData::count

count of "HolesId"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 804 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFlagHoleData::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFlagHoleData
CalloutLabel
count
depth
DepthPnt
DepthType
FaceId
HolesId
isAddD1
isCounter
isMachine
isUseFilter
isUseFlaggedThread
LowerLimit
size
ThreadClass
type
UpperLimit

◆ size

vxLongName svxFlagHoleData::size

flag thread hole size The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "size"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 824 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFldData Struct Reference
Commands Creation » Command Definition » Command Data

field data More...

#include <zwapi_cmd_data.h>

Data Fields

int | fld_id
id of field More...
vxLongName fld_name
name of field (i.e. label, maybe is empty string) More...
evxFldType fld_type
type of field More...
int | count
number of field data More...
svxData * fld_data
list of field data More...

Detailed Description

field data

Definition at line 151 of file zwapi_cmd_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData::fld_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFldData
count
fld_data
fld_id
fld_name
fld_type

◆ fld_type

evxFldType svxFldData::fld_type

type of field

Definition at line 155 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData::fld_id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFldData
count
fld_data
fld_id
fld_name
fld_type

◆ fld_id

int svxFldData::fld_id

id of field

Definition at line 153 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData::fld_data

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFldData
count
fld_data
fld_id
fld_name
fld_type

◆ fld_data

svxData* svxFldData::fld_data

list of field data

Definition at line 157 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFldData
count
fld_data
fld_id
fld_name
fld_type

◆ count

int svxFldData::count

number of field data

Definition at line 156 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFldData::fld_name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFldData
count
fld_data
fld_id
fld_name
fld_type

◆ fld_name

vxLongName svxFldData::fld_name

name of field (i.e. label, maybe is empty string)

Definition at line 154 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFoldData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Fold data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idShape
shape id More...
int | idStationary
Stationary face id (0/-1 to ignored) More...
int | BendFaceCnts
Bend face counts(0 to ignored) More...
int * | idBendFace
Bend faces id (NULL to ignored) More...
int | CrvCnts
Curve list counts(0 to ignored) More...
int * | idCrv
curve list on the sheet metal(NULL to ignored) More...

Detailed Description

template command Smd Fold data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1179 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idCrv

int* svxFoldData::idCrv

curve list on the sheet metal(NULL to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1186 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::idBendFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idBendFace

int* svxFoldData::idBendFace

Bend faces id (NULL to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1184 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::CrvCnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ CrvCnts

int svxFoldData::CrvCnts

Curve list counts(0 to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1185 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::BendFaceCnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ BendFaceCnts

int svxFoldData::BendFaceCnts

Bend face counts(0 to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1183 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idShape

int svxFoldData::idShape

shape id

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1181 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFoldData::idStationary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idStationary

int svxFoldData::idStationary

Stationary face id (0/-1 to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1182 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFormInfo Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFormInfo Struct Reference
UI » UI Data

form info that the "Form" add to. When user wants to add a form to UI manager or File browser by using dll,
he has to create svxFormInfo to store form information and Use cvxFormInsertTo() or cvxFormAddTO() to add. More...

#include <zwapi_ui_data.h>

Data Fields

vxLongName Formname
form name More...
vxLongName Iconame
icon name More...
vxLongName Labelname
page label More...
vxPath Tooltips
tooltips More...

Detailed Description

form info that the "Form" add to. When user wants to add a form to UI manager or File browser by using dll,
he has to create svxFormInfo to store form information and Use cvxFormInsertTo() or cvxFormAddTO() to add.

Definition at line 60 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFormInfo::Labelname

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFormInfo
Formname
Iconame
Labelname
Tooltips

◆ Labelname

vxLongName svxFormInfo::Labelname

page label

Definition at line 64 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFormInfo::Tooltips

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFormInfo
Formname
Iconame
Labelname
Tooltips

◆ Tooltips

vxPath svxFormInfo::Tooltips

tooltips

Definition at line 65 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFormInfo::Formname

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFormInfo
Formname
Iconame
Labelname
Tooltips

◆ Formname

vxLongName svxFormInfo::Formname

form name

Definition at line 62 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFormInfo::Iconame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFormInfo
Formname
Iconame
Labelname
Tooltips

◆ Iconame

vxLongName svxFormInfo::Iconame

icon name

Definition at line 63 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxFulSecViewData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

full section view data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | idView
the id of base view to section More...
int | iCnt
the count of the points More...
svxPoint2 * pPnts
points to define section More...
svxPoint2 locPnt
the location for section view More...
svxViewSecMtd secMtd
section method More...
svxViewSecLine secLine
section line More...
svxViewSecOp secOp
section option More...

Detailed Description

full section view data

Examples
drawing\dwgViewTest.cpp.

Definition at line 360 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::idView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ idView

int svxFulSecViewData::idView

the id of base view to section

Examples
drawing\dwgViewTest.cpp.

Definition at line 362 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::pPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ pPnts

svxPoint2* svxFulSecViewData::pPnts

points to define section

Examples
drawing\dwgViewTest.cpp.

Definition at line 365 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::iCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ iCnt

int svxFulSecViewData::iCnt

the count of the points

Examples
drawing\dwgViewTest.cpp.

Definition at line 364 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::secMtd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ secMtd

svxViewSecMtd svxFulSecViewData::secMtd

section method

Examples
drawing\dwgViewTest.cpp.

Definition at line 368 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::locPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ locPnt

svxPoint2 svxFulSecViewData::locPnt

the location for section view

Examples
drawing\dwgViewTest.cpp.

Definition at line 367 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::secLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ secLine

svxViewSecLine svxFulSecViewData::secLine

section line

Examples
drawing\dwgViewTest.cpp.

Definition at line 369 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFulSecViewData::secOp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFulSecViewData
iCnt
idView
locPnt
pPnts
secLine
secMtd
secOp

◆ secOp

svxViewSecOp svxFulSecViewData::secOp

section option

Examples
drawing\dwgViewTest.cpp.

Definition at line 370 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGRPData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxGRPData Struct Reference
File » File Data

data of export GRP file More...

#include <zwapi_file_data.h>

Data Fields

char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...

Detailed Description

data of export GRP file

Definition at line 221 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGRPData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGRPData
EntCnt
EntList
ExcludeGeom
ExportType

◆ EntList

int* svxGRPData::EntList

the specified entities id list if ExportType = 1

Definition at line 225 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGRPData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGRPData
EntCnt
EntList
ExcludeGeom
ExportType

◆ EntCnt

int svxGRPData::EntCnt

the count of export entities if ExportType = 1

Definition at line 224 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGRPData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGRPData
EntCnt
EntList
ExcludeGeom
ExportType

◆ ExportType

char svxGRPData::ExportType

0-All objects, 1-Specified entities

Definition at line 223 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGRPData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGRPData
EntCnt
EntList
ExcludeGeom
ExportType

◆ ExcludeGeom

int svxGRPData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 226 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxGearConsData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly gear constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

double | angle
constraint angle (0.0-default) More...
int | ratioType
ratio type (0: ratio; 1: teeth; 0-default) More...
double | ratio
ratio value, used when type is ratio (1.0-default) More...
double | teeth [2]
teeth, used when type is teeth (0.0-default) More...
int | flip
whether to flip the direction (0-default) More...

Detailed Description

custom data for assembly gear constraint

Examples
part\asmConsTest.cpp.

Definition at line 234 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGearConsData
angle
flip
ratio
ratioType
teeth

◆ ratio

double svxGearConsData::ratio

ratio value, used when type is ratio (1.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 238 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData::ratioType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGearConsData
angle
flip
ratio
ratioType
teeth

◆ ratioType

int svxGearConsData::ratioType

ratio type (0: ratio; 1: teeth; 0-default)

Examples
part\asmConsTest.cpp.

Definition at line 237 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGearConsData
angle
flip
ratio
ratioType
teeth

◆ flip

int svxGearConsData::flip

whether to flip the direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 240 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData::teeth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGearConsData
angle
flip
ratio
ratioType
teeth

◆ teeth

double svxGearConsData::teeth[2]

teeth, used when type is teeth (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 239 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGearConsData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGearConsData
angle
flip
ratio
ratioType
teeth

◆ angle

double svxGearConsData::angle

constraint angle (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 236 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxGeomExport Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

geometry export More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | numEnts
number of geometry entities to export More...
int * | idEnts
id's of geometry entities to export More...
vxLongPath File
destination file (set File[0]=0 to use active file) More...
vxRootName Part
name of destination part (new or existing) More...
svxMatrix Frame
local coordinate frame More...
int | Option
0 - add import operation to destination part.
1 - add import operation and then "encapsulate" history.
2 - add import operation and then "backup" history. (Option 1 is recommended) More...
int | AddComponent
1 to instance part as component; else 0 . For Z3PRt, it not valid More...
int | NoExportOp
1 to disable logging of "Export" operation; else 0 More...
int | Unblank
1 to unblank exported entities in destination part More...

Detailed Description

geometry export

Definition at line 85 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::Option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ Option

int svxGeomExport::Option

0 - add import operation to destination part.
1 - add import operation and then "encapsulate" history.
2 - add import operation and then "backup" history. (Option 1 is recommended)

Definition at line 92 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::numEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ numEnts

int svxGeomExport::numEnts

number of geometry entities to export

Definition at line 87 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::Unblank

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ Unblank

int svxGeomExport::Unblank

1 to unblank exported entities in destination part

Definition at line 99 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ File

vxLongPath svxGeomExport::File

destination file (set File[0]=0 to use active file)

Definition at line 89 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::AddComponent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ AddComponent

int svxGeomExport::AddComponent

1 to instance part as component; else 0 . For Z3PRt, it not valid

Definition at line 97 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::Frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ Frame

svxMatrix svxGeomExport::Frame

local coordinate frame

Definition at line 91 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::Part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ Part

vxRootName svxGeomExport::Part

name of destination part (new or existing)

Definition at line 90 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ idEnts

int* svxGeomExport::idEnts

id's of geometry entities to export

Definition at line 88 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxGeomExport::NoExportOp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxGeomExport
AddComponent
File
Frame
idEnts
NoExportOp
numEnts
Option
Part
Unblank

◆ NoExportOp

int svxGeomExport::NoExportOp

1 to disable logging of "Export" operation; else 0

Definition at line 98 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHTMLData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxHTMLData Struct Reference
File » File Data

data of export HTML file More...

#include <zwapi_file_data.h>

Data Fields

int | AutoZip
auto zip (1 = yes, 0 = no) More...
char | Password [128]
password of html file More...

Detailed Description

data of export HTML file

Definition at line 432 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHTMLData::Password

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHTMLData
AutoZip
Password

◆ Password

char svxHTMLData::Password[128]

password of html file

Definition at line 435 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHTMLData::AutoZip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHTMLData
AutoZip
Password

◆ AutoZip

int svxHTMLData::AutoZip

auto zip (1 = yes, 0 = no)

Definition at line 434 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxHatchAttr Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

hatch attributes More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxHatchType type
hatch type default: VX_HATCH_STANDARD More...
evxHatchPtnType pattern
hatch pattern method default: VX_HATCH_PATTERN_ANSI31 More...
double | angle
angle attribute default: 0.0 More...
double | space
spacing attribute default: 3.175 More...
svxPoint2 origin
origin point default: {0.0,0.0} More...
evxColor color
color attribute default: VX_COLOR_BLACK More...
evxLineWidth width
line width default: VX_WIDTH_018 More...

Detailed Description

hatch attributes

Definition at line 1610 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ width

evxLineWidth svxHatchAttr::width

line width default: VX_WIDTH_018

Definition at line 1624 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ type

evxHatchType svxHatchAttr::type

hatch type default: VX_HATCH_STANDARD

Definition at line 1612 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ color

evxColor svxHatchAttr::color

color attribute default: VX_COLOR_BLACK

Definition at line 1622 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::space

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ space

double svxHatchAttr::space

spacing attribute default: 3.175

Definition at line 1618 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ angle

double svxHatchAttr::angle

angle attribute default: 0.0

Definition at line 1616 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::pattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ pattern

evxHatchPtnType svxHatchAttr::pattern

hatch pattern method default: VX_HATCH_PATTERN_ANSI31

Definition at line 1614 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchAttr::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchAttr
angle
color
origin
pattern
space
type
width

◆ origin

svxPoint2 svxHatchAttr::origin

origin point default: {0.0,0.0}

Definition at line 1620 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchPtnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxHatchPtnData Struct Reference
Commands Creation » Part and Assembly Commands » Create Sketch Commands Data

cosmetic sketch hatch pattern definition data More...

#include <zwapi_cmd_sk_create_data.h>

Data Fields

evxHatchPtnType pattern
hatch pattern method default: VX_HATCH_PATTERN_ANSI31 More...
double | angle
angle attribute default: 0.0 More...
double | space
spacing attribute default: 3.175 More...
evxColor color
color attribute default: VX_COLOR_BLACK More...

Detailed Description

cosmetic sketch hatch pattern definition data

Examples
part\skCrtTest.cpp.

Definition at line 141 of file zwapi_cmd_sk_create_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_create_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchPtnData::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchPtnData
angle
color
pattern
space

◆ color

evxColor svxHatchPtnData::color

color attribute default: VX_COLOR_BLACK

Definition at line 149 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchPtnData::space

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchPtnData
angle
color
pattern
space

◆ space

double svxHatchPtnData::space

spacing attribute default: 3.175

Examples
part\skCrtTest.cpp.

Definition at line 147 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchPtnData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchPtnData
angle
color
pattern
space

◆ angle

double svxHatchPtnData::angle

angle attribute default: 0.0

Examples
part\skCrtTest.cpp.

Definition at line 145 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHatchPtnData::pattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHatchPtnData
angle
color
pattern
space

◆ pattern

evxHatchPtnType svxHatchPtnData::pattern

hatch pattern method default: VX_HATCH_PATTERN_ANSI31

Definition at line 143 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleChams Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxHoleChams Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

Hole chamfer, added in 1900. More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | fCham
Flag if chamfer. More...
int | fChamSym
Flag if it is symmetric chamfer. More...
double | chamDst
Chamfer distance. More...
double | chamAngle
Chamfer angle. More...

Detailed Description

Hole chamfer, added in 1900.

Definition at line 673 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleChams::fChamSym

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleChams
chamAngle
chamDst
fCham
fChamSym

◆ fChamSym

int svxHoleChams::fChamSym

Flag if it is symmetric chamfer.

Definition at line 676 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleChams::chamAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleChams
chamAngle
chamDst
fCham
fChamSym

◆ chamAngle

double svxHoleChams::chamAngle

Chamfer angle.

Definition at line 678 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleChams::fCham

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleChams
chamAngle
chamDst
fCham
fChamSym

◆ fCham

int svxHoleChams::fCham

Flag if chamfer.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 675 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleChams::chamDst

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleChams
chamAngle
chamDst
fCham
fChamSym

◆ chamDst

double svxHoleChams::chamDst

Chamfer distance.

Definition at line 677 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxHoleData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

hole data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxHoleType Type
hole type (general hole or thread hole) More...
int | idInsFace
id of insertion face. 0 to ignore More...
int | Count
number of holes More...
svxPoint * Points
list of "Count" hole insertion points (calling procedure must allocate/deallocate) More...
double | Diameter1
1st diameter (mm) More...
double | Depth1
1st depth (mm) More...
double | Diameter2
2nd diameter (mm, countersunk holes) More...
double | Depth2
2nd depth (mm, countersunk holes) More...
double | TaperAngle
taper angle (degrees) More...
double | TipAngle
tip angle (degrees) (0 is mapped to 180, 118 is default) More...
evxEndCondition End
hole end condition More...
int | idUntilFace
id of "until" face (0 if not required) More...
int | UseDirection
1 to use "Direction" input ; 0 for default (the hole feature(s) will be perpendicular to the face) More...
svxVector Direction
optional direction for hole centerline More...
int | OpNoRemove
bool operation type (0 means remove for default, 1 is none) More...
int | cntShps
count of shapes. if OpNoRemove = 0,apply it. if OpNoRemove=0 and cngShps=0, remove default. More...
int * | idShapes
list of shape id. if OpNoRemove = 0 and cntShps > 0,apply it. More...
int | NoProjPntLoc
1 not to project location point, 0 to project More...
double | slotLength
slot length (mm) More...
double | slotAngle
slot angle (deg) More...
evxThreadType ThreadType
thread type More...
vxLongName ThreadSize
thread size. The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "ThreadSize" Custom if ThreadSize[0] == 0 . More...
double | ThreadDiameter
thread diameter (mm) More...
double | ThreadLength
thread length (mm) More...
double | ThreadsPerUnit
threads per unit (0 if not used) More...
double | ThreadPitch
thread pitch (mm) (0 if not used) More...
int | fThrdClass
T/F flag for thread class, added in 1900 version. More...
int | thrdClass
thread class 1B/2B/3B, added in 1900 version More...
svxHoleChams sCham
Start chamfer. More...
svxHoleChams mCham
Middle chamfer for counter bore or spot face bore. More...
svxHoleChams eCham
End chamfer. More...
int | fExtTap
Flag if extend with taper direction for tapered or counter-sink hole. More...
int | fExtStart
Flag if extend the start of hole. More...
int | UseTol
1 to use tolerances; or 0 More...
double | TolIn
inner tolerance on Diameter 1 More...
double | TolOut
outer tolerance on Diameter 1 More...
int | UseD2Tol
T/F flag for ID2 Tol input choice, add in 1900 version. More...
double | D2InTol
D2 tolerance lower limit, added in 1900 version. More...
double | D2OutTol
D2 tolerance upper limit, added in 1900 version. More...
char | Callout [128]
callout text string More...
int | DoNotMachine
1 to ignore hole in CAM, or 0 More...
evxHoleOpt HoleOpt
different hole to create More...
evxClearHoleType ClearHoleType
hole type (when HoleOpt = VX_CLEARANCE_HOLE) More...
vxLongName Standard
user can find it in file Simple.xml(zw3d/supp/Simple.xml) More...
vxLongName Screw
user can find it in file Simple.xml(zw3d/supp/Simple.xml) More...
vxLongName Size
user can find it in file Simple.xml(zw3d/supp/Simple.xml) More...
vxLongName Fit
"Close","Normal","Loose","Custom" More...
int | idSketch
use sketch to create the hole (HoleOpt = VX_PROFILE_HOLE, 0 to ignore) More...
int | AddBase
1 is add base, else 0. default:1. More...

Detailed Description

hole data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 696 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ClearHoleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ClearHoleType

evxClearHoleType svxHoleData::ClearHoleType

hole type (when HoleOpt = VX_CLEARANCE_HOLE)

Definition at line 757 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::AddBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ AddBase

int svxHoleData::AddBase

1 is add base, else 0. default:1.

Definition at line 765 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::NoProjPntLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ NoProjPntLoc

int svxHoleData::NoProjPntLoc

1 not to project location point, 0 to project

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 720 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::UseTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ UseTol

int svxHoleData::UseTol

1 to use tolerances; or 0

Definition at line 743 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::D2InTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ D2InTol

double svxHoleData::D2InTol

D2 tolerance lower limit, added in 1900 version.

Definition at line 748 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::idInsFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ idInsFace

int svxHoleData::idInsFace

id of insertion face. 0 to ignore

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 700 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::fExtStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ fExtStart

int svxHoleData::fExtStart

Flag if extend the start of hole.

Definition at line 741 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Fit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Fit

vxLongName svxHoleData::Fit

"Close","Normal","Loose","Custom"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 761 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Screw

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Screw

vxLongName svxHoleData::Screw

user can find it in file Simple.xml(zw3d/supp/Simple.xml)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 759 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::sCham

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ sCham

svxHoleChams svxHoleData::sCham

Start chamfer.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 737 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::fThrdClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ fThrdClass

int svxHoleData::fThrdClass

T/F flag for thread class, added in 1900 version.

Definition at line 734 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadPitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadPitch

double svxHoleData::ThreadPitch

thread pitch (mm) (0 if not used)

Definition at line 733 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ idShapes

int* svxHoleData::idShapes

list of shape id. if OpNoRemove = 0 and cntShps > 0,apply it.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 719 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::idUntilFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ idUntilFace

int svxHoleData::idUntilFace

id of "until" face (0 if not required)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 711 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::UseDirection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ UseDirection

int svxHoleData::UseDirection

1 to use "Direction" input ; 0 for default (the hole feature(s) will be perpendicular to the face)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 712 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::slotLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ slotLength

double svxHoleData::slotLength

slot length (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 721 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Count

int svxHoleData::Count

number of holes

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 701 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadDiameter

double svxHoleData::ThreadDiameter

thread diameter (mm)

Definition at line 730 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::fExtTap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ fExtTap

int svxHoleData::fExtTap

Flag if extend with taper direction for tapered or counter-sink hole.

Definition at line 740 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Standard

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Standard

vxLongName svxHoleData::Standard

user can find it in file Simple.xml(zw3d/supp/Simple.xml)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 758 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Depth1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Depth1

double svxHoleData::Depth1

1st depth (mm)

Definition at line 705 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::OpNoRemove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ OpNoRemove

int svxHoleData::OpNoRemove

bool operation type (0 means remove for default, 1 is none)

Definition at line 715 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::End

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ End

evxEndCondition svxHoleData::End

hole end condition

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 710 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadLength

double svxHoleData::ThreadLength

thread length (mm)

Definition at line 731 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::idSketch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ idSketch

int svxHoleData::idSketch

use sketch to create the hole (HoleOpt = VX_PROFILE_HOLE, 0 to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 762 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::slotAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ slotAngle

double svxHoleData::slotAngle

slot angle (deg)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 722 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::cntShps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ cntShps

int svxHoleData::cntShps

count of shapes. if OpNoRemove = 0,apply it. if OpNoRemove=0 and cngShps=0, remove default.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 716 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::DoNotMachine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ DoNotMachine

int svxHoleData::DoNotMachine

1 to ignore hole in CAM, or 0

Definition at line 753 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::TaperAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ TaperAngle

double svxHoleData::TaperAngle

taper angle (degrees)

Definition at line 708 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::HoleOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ HoleOpt

evxHoleOpt svxHoleData::HoleOpt

different hole to create

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 756 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Depth2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Depth2

double svxHoleData::Depth2

2nd depth (mm, countersunk holes)

Definition at line 707 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Callout

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Callout

char svxHoleData::Callout[128]

callout text string

Definition at line 752 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::mCham

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ mCham

svxHoleChams svxHoleData::mCham

Middle chamfer for counter bore or spot face bore.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 738 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::UseD2Tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ UseD2Tol

int svxHoleData::UseD2Tol

T/F flag for ID2 Tol input choice, add in 1900 version.

Definition at line 747 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::eCham

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ eCham

svxHoleChams svxHoleData::eCham

End chamfer.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 739 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Size

vxLongName svxHoleData::Size

user can find it in file Simple.xml(zw3d/supp/Simple.xml)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 760 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Direction

svxVector svxHoleData::Direction

optional direction for hole centerline

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 714 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadSize

vxLongName svxHoleData::ThreadSize

thread size. The size of the data is very large ,so user can find it in file Thread.xml(zw3d/supp/Thread.xml) Copy the value of "SizeValue" to "ThreadSize" Custom if ThreadSize[0] == 0 .

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 726 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Diameter2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Diameter2

double svxHoleData::Diameter2

2nd diameter (mm, countersunk holes)

Definition at line 706 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::TolIn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ TolIn

double svxHoleData::TolIn

inner tolerance on Diameter 1

Definition at line 744 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::TipAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ TipAngle

double svxHoleData::TipAngle

tip angle (degrees) (0 is mapped to 180, 118 is default)

Definition at line 709 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadsPerUnit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadsPerUnit

double svxHoleData::ThreadsPerUnit

threads per unit (0 if not used)

Definition at line 732 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::TolOut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ TolOut

double svxHoleData::TolOut

outer tolerance on Diameter 1

Definition at line 745 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::thrdClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ thrdClass

int svxHoleData::thrdClass

thread class 1B/2B/3B, added in 1900 version

Definition at line 735 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::D2OutTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ D2OutTol

double svxHoleData::D2OutTol

D2 tolerance upper limit, added in 1900 version.

Definition at line 749 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Type

evxHoleType svxHoleData::Type

hole type (general hole or thread hole)

Definition at line 699 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Diameter1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Diameter1

double svxHoleData::Diameter1

1st diameter (mm)

Definition at line 704 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::ThreadType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ ThreadType

evxThreadType svxHoleData::ThreadType

thread type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 725 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxHoleData::Points

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxHoleData
AddBase
Callout
ClearHoleType
cntShps
Count
D2InTol
D2OutTol
Depth1
Depth2
Diameter1
Diameter2
Direction
DoNotMachine
eCham
End
fExtStart
fExtTap
Fit
fThrdClass
HoleOpt
idInsFace
idShapes
idSketch
idUntilFace
mCham
NoProjPntLoc
OpNoRemove
Points
sCham
Screw
Size
slotAngle
slotLength
Standard
TaperAngle
thrdClass
ThreadDiameter
ThreadLength
ThreadPitch
ThreadSize
ThreadsPerUnit
ThreadType
TipAngle
TolIn
TolOut
Type
UseD2Tol
UseDirection
UseTol

◆ Points

svxPoint* svxHoleData::Points

list of "Count" hole insertion points (calling procedure must allocate/deallocate)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 702 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxIGESData Struct Reference
File » File Data

data of export IGEES file More...

#include <zwapi_file_data.h>

Data Fields

char | Coordinate
0-World, 1- Local (0-default) More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...

Detailed Description

data of export IGEES file

Definition at line 328 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIGESData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType

◆ EntList

int* svxIGESData::EntList

the specified entities id list if ExportType = 1

Definition at line 333 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData::Coordinate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIGESData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType

◆ Coordinate

char svxIGESData::Coordinate

0-World, 1- Local (0-default)

Definition at line 330 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIGESData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType

◆ ExcludeGeom

int svxIGESData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 334 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIGESData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType

◆ ExportType

char svxIGESData::ExportType

0-All objects, 1-Specified entities

Definition at line 331 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIGESData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIGESData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType

◆ EntCnt

int svxIGESData::EntCnt

the count of export entities if ExportType = 1

Definition at line 332 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxIferChkResData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

Interference check result data. More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

svxEntPath BaseCompPath
base component pick path for interference check More...
vxLongName BaseCompName
base component name for interference check More...
svxEntPath ChkCompPath
check component pick path for interference check More...
vxLongName ChkCompName
check component name for interference check More...
double IferVolme
volume of interference (mm^3) More...

Detailed Description

Interference check result data.

Definition at line 918 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData::ChkCompPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIferChkResData
BaseCompName
BaseCompPath
ChkCompName
ChkCompPath
IferVolme

◆ ChkCompPath

svxEntPath svxIferChkResData::ChkCompPath

check component pick path for interference check

Definition at line 922 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData::IferVolme

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIferChkResData
BaseCompName
BaseCompPath
ChkCompName
ChkCompPath
IferVolme

◆ IferVolme

double svxIferChkResData::IferVolme

volume of interference (mm^3)

Definition at line 924 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData::BaseCompPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIferChkResData
BaseCompName
BaseCompPath
ChkCompName
ChkCompPath
IferVolme

◆ BaseCompPath

svxEntPath svxIferChkResData::BaseCompPath

base component pick path for interference check

Definition at line 920 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData::BaseCompName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIferChkResData
BaseCompName
BaseCompPath
ChkCompName
ChkCompPath
IferVolme

◆ BaseCompName

vxLongName svxIferChkResData::BaseCompName

base component name for interference check

Definition at line 921 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIferChkResData::ChkCompName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIferChkResData
BaseCompName
BaseCompPath
ChkCompName
ChkCompPath
IferVolme

◆ ChkCompName

vxLongName svxIferChkResData::ChkCompName

check component name for interference check

Definition at line 923 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImgData Struct Reference
File » File Data

data of export image file More...

#include <zwapi_file_data.h>

Data Fields

evxImgType Type
image type More...
evxImgColorMode ColorMode
set color More...
unsigned int | Width
width for the paper More...
unsigned int | Height
height for the paper More...
unsigned int | Quality
only if the jpeg format is selected to output. set image quality between 0 and 100 More...
evxImgBkgndMode BkgndMode
background color
More...
svxColor Background
set it if BkgndMode is VX_EXPORT_IMG_BKGND_MODE_CUSTOM More...
evxImgRangeMode RangeMode
export area mode More...
svxBndBox Rect
set it if RangeMode is VX_EXPORT_IMG_RANGE_MODE_CUSTOM More...

Detailed Description

data of export image file

Definition at line 135 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Width

unsigned int svxImgData::Width

width for the paper

Definition at line 139 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Type

evxImgType svxImgData::Type

image type

Definition at line 137 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Height

unsigned int svxImgData::Height

height for the paper

Definition at line 140 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Quality

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Quality

unsigned int svxImgData::Quality

only if the jpeg format is selected to output. set image quality between 0 and 100

Definition at line 141 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::BkgndMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ BkgndMode

evxImgBkgndMode svxImgData::BkgndMode

background color

Definition at line 143 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Background

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Background

svxColor svxImgData::Background

set it if BkgndMode is VX_EXPORT_IMG_BKGND_MODE_CUSTOM

Definition at line 144 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::Rect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ Rect

svxBndBox svxImgData::Rect

set it if RangeMode is VX_EXPORT_IMG_RANGE_MODE_CUSTOM

Definition at line 146 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::RangeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ RangeMode

evxImgRangeMode svxImgData::RangeMode

export area mode

Definition at line 145 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImgData::ColorMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImgData
Background
BkgndMode
ColorMode
Height
Quality
RangeMode
Rect
Type
Width

◆ ColorMode

evxImgColorMode svxImgData::ColorMode

set color

Definition at line 138 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportData Struct Reference
File » File Data

file import data More...

#include <zwapi_file_data.h>

Data Fields

evxImportType type
import type More...
vxLongPath filePath
import file path More...
int | importTo
0-current object, 1-new object, 2-new file More...
int | importTarget
0-default, 1-part,2-sheet,3-sketch, if it doesn't need this param, use the default value. More...
void * | reserved
reserved for future (should be NULL for API developers currently) More...
void * | general
setting general properties.NULL to use default.
if the Type is VX_IMPORT_TYPE_UG, the data is svxImportUGData,
if the Type is VX_IMPORT_TYPE_STEP, the data is svxImportSTEPData.
if the Type is VX_IMPORT_TYPE_DWG_DXF, the data is svxImportDwgDxfData.
if the Type is VX_IMPORT_TYPE_STL, the data is svxImportSTLData. if the Type is VX_IMPORT_PTS_FROM_FILE, the data is svxImportPTSData. More...

Detailed Description

file import data

Definition at line 629 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::importTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ importTo

int svxImportData::importTo

0-current object, 1-new object, 2-new file

Definition at line 633 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::general

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ general

void* svxImportData::general

setting general properties.NULL to use default.
if the Type is VX_IMPORT_TYPE_UG, the data is svxImportUGData,
if the Type is VX_IMPORT_TYPE_STEP, the data is svxImportSTEPData.
if the Type is VX_IMPORT_TYPE_DWG_DXF, the data is svxImportDwgDxfData.
if the Type is VX_IMPORT_TYPE_STL, the data is svxImportSTLData. if the Type is VX_IMPORT_PTS_FROM_FILE, the data is svxImportPTSData.

Definition at line 637 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::reserved

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ reserved

void* svxImportData::reserved

reserved for future (should be NULL for API developers currently)

Definition at line 636 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::filePath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ filePath

vxLongPath svxImportData::filePath

import file path

Definition at line 632 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::importTarget

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ importTarget

int svxImportData::importTarget

0-default, 1-part,2-sheet,3-sketch, if it doesn't need this param, use the default value.

Definition at line 634 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportData
filePath
general
importTarget
importTo
reserved
type

◆ type

evxImportType svxImportData::type

import type

Definition at line 631 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportDwgDxfData Struct Reference
File » File Data

setting properties if import dwg/dxf file More...

#include <zwapi_file_data.h>

Data Fields

int | isAutoSew
1 is auto sew geometry, else 0. More...
int | isAutoAct
1 is auto activate part, else 0. More...
int | isAutoSubPart
1 is auto create sub-part, else 0. More...
int | isConvertPolylines
1 is convert polylines into curves, else 0. More...
int | isRefine
1 is refine polyline curves, else 0. More...
int | isReadLayers
1 is read empty layers, else 0. More...
int | isExplodeDim
1 is explode dimension, else 0. More...
evxDWGDXFConvertMeshTo convertMeshTo
convert polygon mesh to. More...
vxName placement
CSYS name. if placement[0] = 0 or placement="", use default CSYS. More...
int | isUnitFile
1 use file units, else 0. More...
int | isUnitReadAs
1 read as, else 0. More...
evxDWGDXFReadAsUnits fileUnits
units. More...
int | isConvertToUnits
convert to ZW3D units. evxUnitType(no apply VX_UNIT_FOOT) More...
int | isModelSpace
1 is model space, else 0. More...
int | isPaperSpace
1 is paper space, else 0. More...
int | excludeGeom
exclude geometry(evxExportExcludeGeom) like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...
int | excludeWidth
exclude width(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2 More...
int | excludeStyle
exclude style(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2 More...
int | excludeColor
exclude color(evxDWGDXFExcludeColor) like this: VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED | VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN More...

Detailed Description

setting properties if import dwg/dxf file

Definition at line 561 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isAutoSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isAutoSew

int svxImportDwgDxfData::isAutoSew

1 is auto sew geometry, else 0.

Definition at line 563 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::convertMeshTo

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ convertMeshTo

evxDWGDXFConvertMeshTo svxImportDwgDxfData::convertMeshTo

convert polygon mesh to.

Definition at line 570 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::placement

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ placement

vxName svxImportDwgDxfData::placement

CSYS name. if placement[0] = 0 or placement="", use default CSYS.

Definition at line 571 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isRefine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isRefine

int svxImportDwgDxfData::isRefine

1 is refine polyline curves, else 0.

Definition at line 567 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isConvertPolylines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isConvertPolylines

int svxImportDwgDxfData::isConvertPolylines

1 is convert polylines into curves, else 0.

Definition at line 566 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isAutoSubPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isAutoSubPart

int svxImportDwgDxfData::isAutoSubPart

1 is auto create sub-part, else 0.

Definition at line 565 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isUnitFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isUnitFile

int svxImportDwgDxfData::isUnitFile

1 use file units, else 0.

Definition at line 572 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isReadLayers

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isReadLayers

int svxImportDwgDxfData::isReadLayers

1 is read empty layers, else 0.

Definition at line 568 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::fileUnits

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ fileUnits

evxDWGDXFReadAsUnits svxImportDwgDxfData::fileUnits

units.

Definition at line 574 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isConvertToUnits

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isConvertToUnits

int svxImportDwgDxfData::isConvertToUnits

convert to ZW3D units. evxUnitType(no apply VX_UNIT_FOOT)

Definition at line 575 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::excludeColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ excludeColor

int svxImportDwgDxfData::excludeColor

exclude color(evxDWGDXFExcludeColor) like this: VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED | VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN

Definition at line 584 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::excludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ excludeGeom

int svxImportDwgDxfData::excludeGeom

exclude geometry(evxExportExcludeGeom) like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 578 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isUnitReadAs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isUnitReadAs

int svxImportDwgDxfData::isUnitReadAs

1 read as, else 0.

Definition at line 573 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isPaperSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isPaperSpace

int svxImportDwgDxfData::isPaperSpace

1 is paper space, else 0.

Definition at line 577 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isModelSpace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isModelSpace

int svxImportDwgDxfData::isModelSpace

1 is model space, else 0.

Definition at line 576 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isAutoAct

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isAutoAct

int svxImportDwgDxfData::isAutoAct

1 is auto activate part, else 0.

Definition at line 564 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::excludeWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ excludeWidth

int svxImportDwgDxfData::excludeWidth

exclude width(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2

Definition at line 580 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::isExplodeDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ isExplodeDim

int svxImportDwgDxfData::isExplodeDim

1 is explode dimension, else 0.

Definition at line 569 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportDwgDxfData::excludeStyle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportDwgDxfData
convertMeshTo
excludeColor
excludeGeom
excludeStyle
excludeWidth
fileUnits
isAutoAct
isAutoSew
isAutoSubPart
isConvertPolylines
isConvertToUnits
isExplodeDim
isModelSpace
isPaperSpace
isReadLayers
isRefine
isUnitFile
isUnitReadAs
placement

◆ excludeStyle

int svxImportDwgDxfData::excludeStyle

exclude style(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYLE_2

Definition at line 582 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportPTSData Struct Reference
File » File Data

setting properties if import points form ASCII file More...

#include <zwapi_file_data.h>

Data Fields

vxLongName groupName
the group name of points to import (groupName[0] = 0 to import all points) More...
int | createPtBlock
1 to create point block, else 0. More...
int | reducePtSet
1 to reduce point set, else 0. More...
int | manual
method for removing points (1: remove according to the tolerance; 0: automatic; 1 as default) More...
double | tolerance
tolerance used with the manual method (0.01 as default) More...
evxPTSHistoryType history
operation type stored in part's history (VX_PTS_HISTORY_NOBACKUP as default) More...

Detailed Description

setting properties if import points form ASCII file

Definition at line 615 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::createPtBlock

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ createPtBlock

int svxImportPTSData::createPtBlock

1 to create point block, else 0.

Definition at line 618 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::manual

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ manual

int svxImportPTSData::manual

method for removing points (1: remove according to the tolerance; 0: automatic; 1 as default)

Definition at line 620 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::groupName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ groupName

vxLongName svxImportPTSData::groupName

the group name of points to import (groupName[0] = 0 to import all points)

Definition at line 617 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::history

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ history

evxPTSHistoryType svxImportPTSData::history

operation type stored in part's history (VX_PTS_HISTORY_NOBACKUP as default)

Definition at line 622 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::tolerance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ tolerance

double svxImportPTSData::tolerance

tolerance used with the manual method (0.01 as default)

Definition at line 621 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportPTSData::reducePtSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportPTSData
createPtBlock
groupName
history
manual
reducePtSet
tolerance

◆ reducePtSet

int svxImportPTSData::reducePtSet

1 to reduce point set, else 0.

Definition at line 619 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportSTEPData Struct Reference
File » File Data

setting general properties if import stp/step file More...

#include <zwapi_file_data.h>

Data Fields

int | isAll
1 is select all options, else 0 More...
int | isAutoSew
1 is auto sew geometry, else 0 More...
int | isActivatePart
1 is auto activate part, else 0. More...
int | isSubPart
1 is auto create sub-part, else 0. More...
int | isTrimEdges
1 is break trim edges, else 0. More...
int | isForceClose
1 is Force close, else 0. More...
int | isSewParts
1 is sew unique parts, else 0. More...
int | isHiddenEnts
1 is read hidden entities, else 0. More...
int | isKeepDire
1 is keep origin face direction, else 0. More...
vxLongName placement
CSYS name. if placement[0] = 0 or placement="", use default CSYS. plancement[0]=0 if isAll=1. More...

Detailed Description

setting general properties if import stp/step file

Definition at line 495 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isSewParts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isSewParts

int svxImportSTEPData::isSewParts

1 is sew unique parts, else 0.

Definition at line 503 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isHiddenEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isHiddenEnts

int svxImportSTEPData::isHiddenEnts

1 is read hidden entities, else 0.

Definition at line 504 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isForceClose

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isForceClose

int svxImportSTEPData::isForceClose

1 is Force close, else 0.

Definition at line 502 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isKeepDire

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isKeepDire

int svxImportSTEPData::isKeepDire

1 is keep origin face direction, else 0.

Definition at line 505 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::placement

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ placement

vxLongName svxImportSTEPData::placement

CSYS name. if placement[0] = 0 or placement="", use default CSYS. plancement[0]=0 if isAll=1.

Definition at line 506 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isSubPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isSubPart

int svxImportSTEPData::isSubPart

1 is auto create sub-part, else 0.

Definition at line 500 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isTrimEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isTrimEdges

int svxImportSTEPData::isTrimEdges

1 is break trim edges, else 0.

Definition at line 501 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isAutoSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isAutoSew

int svxImportSTEPData::isAutoSew

1 is auto sew geometry, else 0

Definition at line 498 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isActivatePart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isActivatePart

int svxImportSTEPData::isActivatePart

1 is auto activate part, else 0.

Definition at line 499 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTEPData::isAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTEPData
isActivatePart
isAll
isAutoSew
isForceClose
isHiddenEnts
isKeepDire
isSewParts
isSubPart
isTrimEdges
placement

◆ isAll

int svxImportSTEPData::isAll

1 is select all options, else 0

Definition at line 497 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTLData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportSTLData Struct Reference
File » File Data

setting properties if import stl file More...

#include <zwapi_file_data.h>

Data Fields

int | isAutoSubPart
1 is auto create sub-part, else 0. More...
int | isAutoAct
1 is auto activate part, else 0. More...
int | isTrimEdges
1 is break trim edges, else 0. More...

Detailed Description

setting properties if import stl file

Definition at line 592 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTLData::isAutoAct

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTLData
isAutoAct
isAutoSubPart
isTrimEdges

◆ isAutoAct

int svxImportSTLData::isAutoAct

1 is auto activate part, else 0.

Definition at line 595 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTLData::isAutoSubPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTLData
isAutoAct
isAutoSubPart
isTrimEdges

◆ isAutoSubPart

int svxImportSTLData::isAutoSubPart

1 is auto create sub-part, else 0.

Definition at line 594 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportSTLData::isTrimEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportSTLData
isAutoAct
isAutoSubPart
isTrimEdges

◆ isTrimEdges

int svxImportSTLData::isTrimEdges

1 is break trim edges, else 0.

Definition at line 596 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxImportUGData Struct Reference
File » File Data

setting properties if import prt file More...

#include <zwapi_file_data.h>

Data Fields

int | isAll
1 is select all options, else 0 More...
int | isActivatePart
1 is auto activate part, else 0. More...
int | isSubPart
1 is auto create sub-part, else 0. More...
int | isAssoImport
1 is associative import, else 0. More...
int | importMode
1 is normal, else 2 is quick import. More...
int | isFreeCrv
1 is free curve, else 0. More...
int | isFreePnt
1 is free point, else 0. More...
int | isSheetBody
1 is sheet body, else 0. More...
int | isHiddenEnt
1 is hidden entity, else 0. More...
int | isSuppComp
1 is suppressed component, else 0. More...
int | PMI
1 is none, 2 is visual, 3 is semantic. More...

Detailed Description

setting properties if import prt file

Definition at line 514 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isFreePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isFreePnt

int svxImportUGData::isFreePnt

1 is free point, else 0.

Definition at line 522 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isAssoImport

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isAssoImport

int svxImportUGData::isAssoImport

1 is associative import, else 0.

Definition at line 519 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::PMI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ PMI

int svxImportUGData::PMI

1 is none, 2 is visual, 3 is semantic.

Definition at line 526 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isFreeCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isFreeCrv

int svxImportUGData::isFreeCrv

1 is free curve, else 0.

Definition at line 521 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::importMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ importMode

int svxImportUGData::importMode

1 is normal, else 2 is quick import.

Definition at line 520 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isActivatePart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isActivatePart

int svxImportUGData::isActivatePart

1 is auto activate part, else 0.

Definition at line 517 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isSuppComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isSuppComp

int svxImportUGData::isSuppComp

1 is suppressed component, else 0.

Definition at line 525 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isHiddenEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isHiddenEnt

int svxImportUGData::isHiddenEnt

1 is hidden entity, else 0.

Definition at line 524 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isSubPart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isSubPart

int svxImportUGData::isSubPart

1 is auto create sub-part, else 0.

Definition at line 518 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isAll

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isAll

int svxImportUGData::isAll

1 is select all options, else 0

Definition at line 516 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxImportUGData::isSheetBody

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxImportUGData
importMode
isActivatePart
isAll
isAssoImport
isFreeCrv
isFreePnt
isHiddenEnt
isSheetBody
isSubPart
isSuppComp
PMI

◆ isSheetBody

int svxImportUGData::isSheetBody

1 is sheet body, else 0.

Definition at line 523 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxInlayData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

inlay data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numFaces
number of faces to receive the inlay More...
int * | idFaces
list of id's of faces to receive the inlay More...
int | numCrvs
number of curves that defines a inlay boundary More...
int * | idCrvs
list of curves that defines a inlay boundary (sketch, curve, curve list, sketch block) More...
double | offset
offset distance, positive raises the faces while negative sinks the faces More...
int | projType
projection method (0 = in place(none), 1 = face normal, 2 = directed, 3 = bi-directional) More...
svxVector projDir
projection direction, only used when projType = 2 More...
svxVector inlayDir
inlay direction of curves More...
int | draftAbout
specify which plane to draft about ( 0 = base, 1 = offset, 2 = middle) More...
double | draftAngle
draft angle for the side faces More...
int | filletType
fillet type ( 0 = circular, 1 = chamfer) More...
int | filletAbout
specify which edges to fillet ( 0 = both, 1 = base, 2 = offset) More...
double | filletRad
fillet radius More...
vxName ftrName
feature name for "FtInlay", 0 default More...

Detailed Description

inlay data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1132 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::projType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ projType

int svxInlayData::projType

projection method (0 = in place(none), 1 = face normal, 2 = directed, 3 = bi-directional)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1140 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::numCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ numCrvs

int svxInlayData::numCrvs

number of curves that defines a inlay boundary

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1136 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::inlayDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ inlayDir

svxVector svxInlayData::inlayDir

inlay direction of curves

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1142 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::idCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ idCrvs

int* svxInlayData::idCrvs

list of curves that defines a inlay boundary (sketch, curve, curve list, sketch block)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1137 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ ftrName

vxName svxInlayData::ftrName

feature name for "FtInlay", 0 default

Definition at line 1149 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::filletAbout

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ filletAbout

int svxInlayData::filletAbout

specify which edges to fillet ( 0 = both, 1 = base, 2 = offset)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1146 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::draftAbout

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ draftAbout

int svxInlayData::draftAbout

specify which plane to draft about ( 0 = base, 1 = offset, 2 = middle)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1143 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::numFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ numFaces

int svxInlayData::numFaces

number of faces to receive the inlay

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1134 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ offset

double svxInlayData::offset

offset distance, positive raises the faces while negative sinks the faces

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1138 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ idFaces

int* svxInlayData::idFaces

list of id's of faces to receive the inlay

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1135 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::projDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ projDir

svxVector svxInlayData::projDir

projection direction, only used when projType = 2

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1141 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::draftAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ draftAngle

double svxInlayData::draftAngle

draft angle for the side faces

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1144 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::filletRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ filletRad

double svxInlayData::filletRad

fillet radius

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1147 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInlayData::filletType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInlayData
draftAbout
draftAngle
filletAbout
filletRad
filletType
ftrName
idCrvs
idFaces
inlayDir
numCrvs
numFaces
offset
projDir
projType

◆ filletType

int svxInlayData::filletType

fillet type ( 0 = circular, 1 = chamfer)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1145 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxInterCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

inter curve More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | iEntCout1
The number of faces selected for the first field. More...
int | iEntCout2
The number of faces selected for the second field. More...
int * | idEnt1
Select all face ids for the first field. More...
int * | idEnt2
Select all face ids for the second field. More...
int | trim
1 to trim intersection curves to face boundaries; 0 does not not trim the curve, 1 default More...

Detailed Description

inter curve

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 193 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData::iEntCout2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInterCrvData
idEnt1
idEnt2
iEntCout1
iEntCout2
trim

◆ iEntCout2

int svxInterCrvData::iEntCout2

The number of faces selected for the second field.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 196 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData::idEnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInterCrvData
idEnt1
idEnt2
iEntCout1
iEntCout2
trim

◆ idEnt2

int* svxInterCrvData::idEnt2

Select all face ids for the second field.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 198 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData::idEnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInterCrvData
idEnt1
idEnt2
iEntCout1
iEntCout2
trim

◆ idEnt1

int* svxInterCrvData::idEnt1

Select all face ids for the first field.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 197 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData::trim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInterCrvData
idEnt1
idEnt2
iEntCout1
iEntCout2
trim

◆ trim

int svxInterCrvData::trim

1 to trim intersection curves to face boundaries; 0 does not not trim the curve, 1 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 199 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxInterCrvData::iEntCout1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxInterCrvData
idEnt1
idEnt2
iEntCout1
iEntCout2
trim

◆ iEntCout1

int svxInterCrvData::iEntCout1

The number of faces selected for the first field.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 195 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxIsoCrvOnFaceData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

iso-curve on face data More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union uvxCrvIsoData

Data Fields

evxCrvIsoType crvIsoType
iso-curve on face methods More...
int | face
face from which the U and V curves will be extracted More...
union svxIsoCrvOnFaceData::uvxCrvIsoData | inpUion

Detailed Description

iso-curve on face data

Definition at line 257 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtPoint
Data Fields
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint Struct Reference

Data Fields

svxPoint point
a point on the face for the iso-curve to pass through
More...
evxCrvIsoUVType type
to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default More...

Detailed Description

Definition at line 263 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtPoint
point
type

◆ type

evxCrvIsoUVType svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::type

to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default

Definition at line 266 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::point

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtPoint
point
type

◆ point

svxPoint svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::point

a point on the face for the iso-curve to pass through

Definition at line 265 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtUVParam
Data Fields
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam Struct Reference

Data Fields

double | U
U parameter where the iso-curve(s) will be located. More...
double | V
V parameter where the iso-curve(s) will be located. More...
evxCrvIsoUVType type
to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default More...

Detailed Description

Definition at line 268 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::V

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtUVParam
type
U
V

◆ V

double svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::V

V parameter where the iso-curve(s) will be located.

Definition at line 271 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::U

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtUVParam
type
U
V

◆ U

double svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::U

U parameter where the iso-curve(s) will be located.

Definition at line 270 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoAtUVParam
type
U
V

◆ type

evxCrvIsoUVType svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::type

to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default

Definition at line 272 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoMultiple
Data Fields
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple Struct Reference

Data Fields

int | numU
number of U iso-curves More...
int | numV
number of V iso-curves More...
double | offsetU
place the U iso-curves at an offset distance from their default location More...
double | offsetV
place the V iso-curves at an offset distance from their default location More...

Detailed Description

Definition at line 274 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetU

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoMultiple
numU
numV
offsetU
offsetV

◆ offsetU

double svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetU

place the U iso-curves at an offset distance from their default location

Definition at line 278 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoMultiple
numU
numV
offsetU
offsetV

◆ numV

int svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numV

number of V iso-curves

Definition at line 277 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoMultiple
numU
numV
offsetU
offsetV

◆ offsetV

double svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetV

place the V iso-curves at an offset distance from their default location

Definition at line 279 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numU

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
  • svxCrvIsoMultiple
numU
numV
offsetU
offsetV

◆ numU

int svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numU

number of U iso-curves

Definition at line 276 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::crvIsoType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
crvIsoType
face

◆ crvIsoType

evxCrvIsoType svxIsoCrvOnFaceData::crvIsoType

iso-curve on face methods

Definition at line 259 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::face

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
crvIsoType
face

◆ face

int svxIsoCrvOnFaceData::face

face from which the U and V curves will be extracted

Definition at line 260 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxIsoclineCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

isocline curve data More...

#include <zwapi_cmd_wireframe_data.h>

Data Structures

union uvxCrvIsoclineData

Data Fields

int * | idFaces
id of faces to create isocline curves More...
int | cntFaces
number of faces to create isocline curves More...
svxVector direction
reference direction More...
evxIsoclineCrvType crvType
isocline curve's creation type, VX_CRV_ISOCLINE_SINGLE as default More...
union svxIsoclineCrvData::uvxCrvIsoclineData | inpUion

Detailed Description

isocline curve data

Definition at line 298 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvMultiple
Data Fields
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple Struct Reference

Data Fields

double | interval
angle between the isocline (between 0.01 to 90) More...
double | start
start angle between the reference direction and the face normal (between -90 to 90) More...
double | end
end angle between the reference direction and the face normal (between -90 to 90) More...

Detailed Description

Definition at line 310 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvMultiple
end
interval
start

◆ start

double svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::start

start angle between the reference direction and the face normal (between -90 to 90)

Definition at line 313 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::end

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvMultiple
end
interval
start

◆ end

double svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::end

end angle between the reference direction and the face normal (between -90 to 90)

Definition at line 314 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::interval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvMultiple
end
interval
start

◆ interval

double svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::interval

angle between the isocline (between 0.01 to 90)

Definition at line 312 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvSingle
Data Fields
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle Struct Reference

Data Fields

double angle
angle between the reference direction and the face normal (between -90 to 90) More...

Detailed Description

Definition at line 306 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
  • svxIsoclineCrvSingle
angle

◆ angle

double svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle::angle

angle between the reference direction and the face normal (between -90 to 90)

Definition at line 308 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::cntFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
cntFaces
crvType
direction
idFaces

◆ cntFaces

int svxIsoclineCrvData::cntFaces

number of faces to create isocline curves

Definition at line 301 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
cntFaces
crvType
direction
idFaces

◆ direction

svxVector svxIsoclineCrvData::direction

reference direction

Definition at line 302 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::crvType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
cntFaces
crvType
direction
idFaces

◆ crvType

evxIsoclineCrvType svxIsoclineCrvData::crvType

isocline curve's creation type, VX_CRV_ISOCLINE_SINGLE as default

Definition at line 303 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
cntFaces
crvType
direction
idFaces

◆ idFaces

int* svxIsoclineCrvData::idFaces

id of faces to create isocline curves

Definition at line 300 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxJTData Struct Reference
File » File Data

data of export JT file More...

#include <zwapi_file_data.h>

Data Fields

evxJTVer Version
JT version (VX_JT_VER_10_0-default) More...
char | Structure
0-Monolithic, 1-Per part, 2-Full shatter (0-default) More...
char | Writetype
0-All, 1-Parts only, 2-Assembly only (0-default) More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...
int | ExportPMI
0-None, 1-All (0-default) More...

Detailed Description

data of export JT file

Definition at line 382 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ EntList

int* svxJTData::EntList

the specified entities id list if ExportType = 1

Definition at line 389 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::Structure

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ Structure

char svxJTData::Structure

0-Monolithic, 1-Per part, 2-Full shatter (0-default)

Definition at line 385 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ ExcludeGeom

int svxJTData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 390 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ ExportType

char svxJTData::ExportType

0-All objects, 1-Specified entities

Definition at line 387 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ EntCnt

int svxJTData::EntCnt

the count of export entities if ExportType = 1

Definition at line 388 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::Version

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ Version

evxJTVer svxJTData::Version

JT version (VX_JT_VER_10_0-default)

Definition at line 384 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::ExportPMI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ ExportPMI

int svxJTData::ExportPMI

0-None, 1-All (0-default)

Definition at line 392 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxJTData::Writetype

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxJTData
EntCnt
EntList
ExcludeGeom
ExportPMI
ExportType
Structure
Version
Writetype

◆ Writetype

char svxJTData::Writetype

0-All, 1-Parts only, 2-Assembly only (0-default)

Definition at line 386 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxKeyEvent Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxKeyEvent Struct Reference
UI » UI Data

keyboard event More...

#include <zwapi_ui_data.h>

Data Fields

unsigned int | modifier
Synchronous key:CTRL, SHIFT, ALT, or WIN key etc. More...
unsigned int | keyCode
A~Z, F1~F12, 0~9 etc, mapping to Microsoft virtual key directly. More...

Detailed Description

keyboard event

Definition at line 315 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxKeyEvent::keyCode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxKeyEvent
keyCode
modifier

◆ keyCode

unsigned int svxKeyEvent::keyCode

A~Z, F1~F12, 0~9 etc, mapping to Microsoft virtual key directly.

Definition at line 318 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxKeyEvent::modifier

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxKeyEvent
keyCode
modifier

◆ modifier

unsigned int svxKeyEvent::modifier

Synchronous key:CTRL, SHIFT, ALT, or WIN key etc.

Definition at line 317 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLabelCoorDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

label coordinate dim data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

char | type
label coordinate type More...
svxPntOnEnt orgPnt
origin point of label coordinate dimension More...
int | cntPnt
count of the point need to give the coordinates More...
svxPntOnEnt * pPnts
point to the coordinate point of dimension(length of list must equal to cntPnt) More...
svxPntOnEnt * pTxtPnts
point to the text point of dimension if needs customization, the length of list must equal to cntPnt, pTxtPnts[i].idEnt = -1, use default text point. NULL, use default text point to be text point More...
char * | text
text(NULL or empty to be formatted as <C_X>,<C_Y>,<C_Z>, you can also custom text) More...

Detailed Description

label coordinate dim data

Examples
drawing\dwgDimTest.cpp.

Definition at line 1008 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ orgPnt

svxPntOnEnt svxLabelCoorDimData::orgPnt

origin point of label coordinate dimension

Examples
drawing\dwgDimTest.cpp.

Definition at line 1013 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::cntPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ cntPnt

int svxLabelCoorDimData::cntPnt

count of the point need to give the coordinates

Examples
drawing\dwgDimTest.cpp.

Definition at line 1015 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::pPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ pPnts

svxPntOnEnt* svxLabelCoorDimData::pPnts

point to the coordinate point of dimension(length of list must equal to cntPnt)

Examples
drawing\dwgDimTest.cpp.

Definition at line 1016 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ type

char svxLabelCoorDimData::type

label coordinate type

1-Auto text placement

2-Pick text placement

Examples
drawing\dwgDimTest.cpp.

Definition at line 1010 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::pTxtPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ pTxtPnts

svxPntOnEnt* svxLabelCoorDimData::pTxtPnts

point to the text point of dimension if needs customization, the length of list must equal to cntPnt, pTxtPnts[i].idEnt = -1, use default text point. NULL, use default text point to be text point

Examples
drawing\dwgDimTest.cpp.

Definition at line 1017 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLabelCoorDimData::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLabelCoorDimData
cntPnt
orgPnt
pPnts
pTxtPnts
text
type

◆ text

char* svxLabelCoorDimData::text

text(NULL or empty to be formatted as <C_X>,<C_Y>,<C_Z>, you can also custom text)

Definition at line 1021 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLayerInfo Struct Reference
Common » Layer

layer information More...

#include <zwapi_layer.h>

Data Fields

int | mask
obtain specified information from mask (evxInfoLayerFlag). obtain sName and sDesc infos if mask = VX_LAYER_INFOR_NAME|VX_LAYER_INFOR_DESC More...
char | sName [32]
layer name More...
char | sDesc [512]
layer description More...
unsigned char | uLayerId
layer id More...
unsigned char | uVisible
layer visible More...
unsigned char | uFrozen
layer freeze More...
unsigned char | uDisable
layer disable More...
unsigned char | uColor
layer color More...
unsigned char | uLineType
layer linetype More...
unsigned char | ulineWidth
layer linewidth More...
char | category [512]
category, like this CURVES;SHEETS More...
int | iNumObj
layer number object More...

Detailed Description

layer information

Definition at line 50 of file zwapi_layer.h.

The documentation for this struct was generated from the following file:
  • zwapi_layer.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uDisable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uDisable

unsigned char svxLayerInfo::uDisable

layer disable

Definition at line 59 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uLayerId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uLayerId

unsigned char svxLayerInfo::uLayerId

layer id

Definition at line 56 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::ulineWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ ulineWidth

unsigned char svxLayerInfo::ulineWidth

layer linewidth

Definition at line 62 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::sName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ sName

char svxLayerInfo::sName[32]

layer name

Definition at line 54 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::category

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ category

char svxLayerInfo::category[512]

category, like this CURVES;SHEETS

Definition at line 63 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::sDesc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ sDesc

char svxLayerInfo::sDesc[512]

layer description

Definition at line 55 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uLineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uLineType

unsigned char svxLayerInfo::uLineType

layer linetype

Definition at line 61 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uColor

unsigned char svxLayerInfo::uColor

layer color

Definition at line 60 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::mask

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ mask

int svxLayerInfo::mask

obtain specified information from mask (evxInfoLayerFlag). obtain sName and sDesc infos if mask = VX_LAYER_INFOR_NAME|VX_LAYER_INFOR_DESC

Definition at line 52 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uVisible

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uVisible

unsigned char svxLayerInfo::uVisible

layer visible

Definition at line 57 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::uFrozen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ uFrozen

unsigned char svxLayerInfo::uFrozen

layer freeze

Definition at line 58 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLayerInfo::iNumObj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLayerInfo
category
iNumObj
mask
sDesc
sName
uColor
uDisable
uFrozen
uLayerId
uLineType
ulineWidth
uVisible

◆ iNumObj

int svxLayerInfo::iNumObj

layer number object

Definition at line 64 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLight Struct Reference
Common » Display

light source More...

#include <zwapi_display.h>

Data Fields

vxName name
light source name More...
evxLightType type
light source type More...
svxPoint pos
light position in definition space More...
svxPoint dir
light direction in definition space More...
svxPoint target_pnt
target point for spot light More...
float | intensity
light intensity (0.0-1.0) More...
float | angle_1
spotlight cutoff angle (0-180 deg) More...
float | angle_2
spotlight constant intensity angle (0-180 deg) More...
float | exp
spotlight exponent (0-128) More...
float | c1
float | c2
float | c3
attenuation coefficients More...
svxColor color
light color (rgb) More...
char | off
1-light is OFF, else ON More...
char | shadow
1-cast shadows, else 0 More...

Detailed Description

light source

Definition at line 104 of file zwapi_display.h.

The documentation for this struct was generated from the following file:
  • zwapi_display.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ dir

svxPoint svxLight::dir

light direction in definition space

Definition at line 109 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::intensity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ intensity

float svxLight::intensity

light intensity (0.0-1.0)

Definition at line 111 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ color

svxColor svxLight::color

light color (rgb)

Definition at line 116 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::angle_2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ angle_2

float svxLight::angle_2

spotlight constant intensity angle (0-180 deg)

Definition at line 113 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::c3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ c3

float svxLight::c3

attenuation coefficients

Definition at line 115 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::c2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ c2

float svxLight::c2

Definition at line 115 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ name

vxName svxLight::name

light source name

Definition at line 106 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::off

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ off

char svxLight::off

1-light is OFF, else ON

Definition at line 117 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::shadow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ shadow

char svxLight::shadow

1-cast shadows, else 0

Definition at line 118 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::target_pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ target_pnt

svxPoint svxLight::target_pnt

target point for spot light

Definition at line 110 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ type

evxLightType svxLight::type

light source type

Definition at line 107 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::angle_1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ angle_1

float svxLight::angle_1

spotlight cutoff angle (0-180 deg)

Definition at line 112 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::c1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ c1

float svxLight::c1

Definition at line 115 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::exp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ exp

float svxLight::exp

spotlight exponent (0-128)

Definition at line 114 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLight::pos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLight
angle_1
angle_2
c3
color
dir
exp
intensity
name
off
pos
shadow
target_pnt
type

◆ pos

svxPoint svxLight::pos

light position in definition space

Definition at line 108 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLimit Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLimit Struct Reference
Common » Common Data

limits More...

#include <zwapi_util.h>

Data Fields

double | min
maximum More...
double | max
minimum More...

Detailed Description

limits

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 454 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLimit::max

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLimit
max
min

◆ max

double svxLimit::max

minimum

Examples
part\asmConsTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 457 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLimit::min

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLimit
max
min

◆ min

double svxLimit::min

maximum

Examples
part\asmConsTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 456 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLineAt Struct Reference
Common » Common Data

Line attributes. More...

#include <zwapi_util.h>

Data Fields

evxColor color
line/marker color (VX_COLOR_NULL-VX_COLOR_LAST) More...
unsigned char | type
line/marker type (0-15) More...
unsigned char | size
line/marker size (1-6) More...

Detailed Description

Line attributes.

Definition at line 1422 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineAt::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineAt
color
size
type

◆ type

unsigned char svxLineAt::type

line/marker type (0-15)

Definition at line 1425 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineAt::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineAt
color
size
type

◆ size

unsigned char svxLineAt::size

line/marker size (1-6)

Definition at line 1426 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineAt::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineAt
color
size
type

◆ color

evxColor svxLineAt::color

line/marker color (VX_COLOR_NULL-VX_COLOR_LAST)

Definition at line 1424 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLineData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

3D line data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxLineType lineType
type to create line More...
svxDirOnEntPath refDir
reference direction, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL, VX_LINE_PERP, VX_LINE_ANGLE More...
svxPntOnEntPath point1
start point or middle point More...
svxPntOnEntPath point2
the end point, used when type is VX_LINE_2PT, VX_LINE_PERP, VX_LINE_ANGLE, VX_LINE_MIDDDLE More...
double | length
length of line, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL More...
double | offset
offset distance from the reference direction, used when type is VX_LINE_PARALLEL More...
double | angle
angle from the reference direction, used when type is VX_LINE_ANGLE More...
int | idAlignPln
id of the alignment datum plane or planar face(0 to ignore), used when type is VX_LINE_2PT, VX_LINE_MIDDDLE More...
int | prjToPln
whether to project line to alignment plane, used when type is VX_LINE_2PT, VX_LINE_MIDDDLE More...

Detailed Description

3D line data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 46 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ length

double svxLineData::length

length of line, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 52 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::refDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ refDir

svxDirOnEntPath svxLineData::refDir

reference direction, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL, VX_LINE_PERP, VX_LINE_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 49 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::prjToPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ prjToPln

int svxLineData::prjToPln

whether to project line to alignment plane, used when type is VX_LINE_2PT, VX_LINE_MIDDDLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 57 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::idAlignPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ idAlignPln

int svxLineData::idAlignPln

id of the alignment datum plane or planar face(0 to ignore), used when type is VX_LINE_2PT, VX_LINE_MIDDDLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 56 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::point2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ point2

svxPntOnEntPath svxLineData::point2

the end point, used when type is VX_LINE_2PT, VX_LINE_PERP, VX_LINE_ANGLE, VX_LINE_MIDDDLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 51 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ angle

double svxLineData::angle

angle from the reference direction, used when type is VX_LINE_ANGLE

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 54 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ offset

double svxLineData::offset

offset distance from the reference direction, used when type is VX_LINE_PARALLEL

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 53 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::point1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ point1

svxPntOnEntPath svxLineData::point1

start point or middle point

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 50 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLineData::lineType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLineData
angle
idAlignPln
length
lineType
offset
point1
point2
prjToPln
refDir

◆ lineType

evxLineType svxLineData::lineType

type to create line

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 48 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLinearCpData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLinearCpData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly linear couple constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | ratioType
ratio type (0: ratio; 1: distance; 0-default) More...
double | ratio
ratio value, used when type is ratio (1.0-default) More...
double | distance [2]
distance, used when type is distance (0.0-default) More...
int | flip
whether to flip the direction (0-default) More...

Detailed Description

custom data for assembly linear couple constraint

Examples
part\asmConsTest.cpp.

Definition at line 299 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLinearCpData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLinearCpData
distance
flip
ratio
ratioType

◆ flip

int svxLinearCpData::flip

whether to flip the direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 304 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLinearCpData::ratio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLinearCpData
distance
flip
ratio
ratioType

◆ ratio

double svxLinearCpData::ratio

ratio value, used when type is ratio (1.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 302 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLinearCpData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLinearCpData
distance
flip
ratio
ratioType

◆ distance

double svxLinearCpData::distance[2]

distance, used when type is distance (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 303 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLinearCpData::ratioType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLinearCpData
distance
flip
ratio
ratioType

◆ ratioType

int svxLinearCpData::ratioType

ratio type (0: ratio; 1: distance; 0-default)

Examples
part\asmConsTest.cpp.

Definition at line 301 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLipData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

lip data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numEdges
number of edges to apply lip More...
int * | idEdge
list of edges to apply lip More...
int * | idFace
list of faces on first side, the face must be associated with lip edge More...
double | offset1
the first offset distance. Lip setback distances are +/- relative to the face normal. Only -/- setback lips on convex edges and +/+ offset lips on concave edges are supported at this time. More...
double | offset2
the second offset distance More...
vxName ftrName
feature name for "FtLip", 0 default More...

Detailed Description

lip data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 922 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ idFace

int* svxLipData::idFace

list of faces on first side, the face must be associated with lip edge

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 927 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::offset2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ offset2

double svxLipData::offset2

the second offset distance

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 931 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::numEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ numEdges

int svxLipData::numEdges

number of edges to apply lip

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 925 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ ftrName

vxName svxLipData::ftrName

feature name for "FtLip", 0 default

Definition at line 932 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ idEdge

int* svxLipData::idEdge

list of edges to apply lip

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 926 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLipData::offset1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLipData
ftrName
idEdge
idFace
numEdges
offset1
offset2

◆ offset1

double svxLipData::offset1

the first offset distance. Lip setback distances are +/- relative to the face normal. Only -/- setback lips on convex edges and +/+ offset lips on concave edges are supported at this time.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 929 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxListCallBackParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxListCallBackParam Struct Reference
UI » UI Data

ListWidget event date. More...

#include <zwapi_ui_data.h>

Data Fields

evxUiEvt evt
event type More...
int | iRow
row number More...
int | key
the vale of keyboard More...

Detailed Description

ListWidget event date.

Definition at line 201 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxListCallBackParam::iRow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxListCallBackParam
evt
iRow
key

◆ iRow

int svxListCallBackParam::iRow

row number

Definition at line 204 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxListCallBackParam::evt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxListCallBackParam
evt
iRow
key

◆ evt

evxUiEvt svxListCallBackParam::evt

event type

Definition at line 203 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxListCallBackParam::key

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxListCallBackParam
evt
iRow
key

◆ key

int svxListCallBackParam::key

the vale of keyboard

Definition at line 205 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftBndCons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLoftBndCons Struct Reference
Commands Creation » Part and Assembly Commands » Sub Commands Data

loft boundary constraints More...

#include <zwapi_cmd_subcmd_data.h>

Data Fields

int | continuity
specify the continuity level at end of loft (0 = None, 1 = tangent, 2 = curvature, 3 = flow) More...
int | direction
specify direction of loft at start and end profiles (0 = perpendicular, 1 = along edges) More...
double | weight
specify the amount of the loft affected by the enforcement of tangency More...
int | idFace
id of tangency, it's ignored when a single face on the edges or continuity = 0, 0 to use default face More...

Detailed Description

loft boundary constraints

Definition at line 70 of file zwapi_cmd_subcmd_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_subcmd_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftBndCons::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftBndCons
continuity
direction
idFace
weight

◆ idFace

int svxLoftBndCons::idFace

id of tangency, it's ignored when a single face on the edges or continuity = 0, 0 to use default face

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 75 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftBndCons::weight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftBndCons
continuity
direction
idFace
weight

◆ weight

double svxLoftBndCons::weight

specify the amount of the loft affected by the enforcement of tangency

Examples
part\shapeFtrCrtTest.cpp, and part\smdFtrCrtTest.cpp.

Definition at line 74 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftBndCons::continuity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftBndCons
continuity
direction
idFace
weight

◆ continuity

int svxLoftBndCons::continuity

specify the continuity level at end of loft (0 = None, 1 = tangent, 2 = curvature, 3 = flow)

Examples
part\shapeFtrCrtTest.cpp, and part\smdFtrCrtTest.cpp.

Definition at line 72 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftBndCons::direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftBndCons
continuity
direction
idFace
weight

◆ direction

int svxLoftBndCons::direction

specify direction of loft at start and end profiles (0 = perpendicular, 1 = along edges)

Examples
part\shapeFtrCrtTest.cpp, and part\smdFtrCrtTest.cpp.

Definition at line 73 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLoftData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

loft data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType combine
combination method More...
evxLoftType type
loft method More...
int | idStartParent
id of the parent entity where the starting point is located More...
svxPoint startPnt
starting point coordinate More...
int | numProfs
number of profiles for loft More...
svxLoftProfile * profs
list of profiles data More...
int | idEndParent
id of the parent entity where the ending point is located More...
svxPoint endPnt
ending point coordinate More...
svxLoftBndCons | bndCons [2]
boundary constraints data of start and end profiles More...
int | endCap
end cap option (0-both, 1-start, 2-end, 3-none) More...
int | close
whether to generate a closed loft (1 = yes, 0 = no) More...
vxName ftrName
feature name for "FtAllLft1", 0 default More...

Detailed Description

loft data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 387 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::endCap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ endCap

int svxLoftData::endCap

end cap option (0-both, 1-start, 2-end, 3-none)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 399 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::idEndParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ idEndParent

int svxLoftData::idEndParent

id of the parent entity where the ending point is located

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 395 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::profs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ profs

svxLoftProfile* svxLoftData::profs

list of profiles data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 394 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::close

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ close

int svxLoftData::close

whether to generate a closed loft (1 = yes, 0 = no)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 400 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ type

evxLoftType svxLoftData::type

loft method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 390 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ startPnt

svxPoint svxLoftData::startPnt

starting point coordinate

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 392 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ combine

evxBoolType svxLoftData::combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 389 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::bndCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ bndCons

svxLoftBndCons svxLoftData::bndCons[2]

boundary constraints data of start and end profiles

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 398 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::endPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ endPnt

svxPoint svxLoftData::endPnt

ending point coordinate

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 396 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::numProfs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ numProfs

int svxLoftData::numProfs

number of profiles for loft

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 393 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::idStartParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ idStartParent

int svxLoftData::idStartParent

id of the parent entity where the starting point is located

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 391 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftData
bndCons
close
combine
endCap
endPnt
ftrName
idEndParent
idStartParent
numProfs
profs
startPnt
type

◆ ftrName

vxName svxLoftData::ftrName

feature name for "FtAllLft1", 0 default

Definition at line 402 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLoftProfile Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

loft profile data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | idParent
id of profile curve's parent sketch or curve list More...
int | idProfile
id of profile curve for loft (curve, edge, parting line) More...
int | profDir
specify the orientation of the profile (0 = from start point to end point, otherwise 1) More...
int | useStartPnt
1 = use the specified starting point, 0 = use the default starting point More...
svxPoint startPnt
starting point coordinate, only setting when useStartPnt = 1 More...

Detailed Description

loft profile data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 362 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile::useStartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftProfile
idParent
idProfile
profDir
startPnt
useStartPnt

◆ useStartPnt

int svxLoftProfile::useStartPnt

1 = use the specified starting point, 0 = use the default starting point

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 367 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftProfile
idParent
idProfile
profDir
startPnt
useStartPnt

◆ idParent

int svxLoftProfile::idParent

id of profile curve's parent sketch or curve list

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 364 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftProfile
idParent
idProfile
profDir
startPnt
useStartPnt

◆ startPnt

svxPoint svxLoftProfile::startPnt

starting point coordinate, only setting when useStartPnt = 1

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 368 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile::profDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftProfile
idParent
idProfile
profDir
startPnt
useStartPnt

◆ profDir

int svxLoftProfile::profDir

specify the orientation of the profile (0 = from start point to end point, otherwise 1)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 366 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLoftProfile::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLoftProfile
idParent
idProfile
profDir
startPnt
useStartPnt

◆ idProfile

int svxLoftProfile::idProfile

id of profile curve for loft (curve, edge, parting line)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 365 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxLouverData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Louver data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idPlane
id of planar face for louver placement More...
int | idProf
id of profile More...
double | dHeight
louver height (3.0mm as default) More...
double | dAng
louver angle (45deg as default) More...
double | dR1
1st louver radius (1.0mm as default) More...
double | dR2
2nd louver radius (1.0mm as default) More...
double | dWidth
louver width (6.0mm as default) More...
int | Flip
whether to flip the louver 180 degrees about the sketch line(0-no as default, 1-yes) More...
int | notSew
flag whether sew shapes or not. 0 = to sew (default)
since R2024, it doesn't sew the new shapes and if user set it to 0, it will create a 'Sew' feature to sew the shapes More...
int | cntSew
count of sew shapes More...
int * | pSewShape
id list of sew shapes (NULL to sew with all shapes) More...

Detailed Description

template command Smd Louver data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1156 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::dHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ dHeight

double svxLouverData::dHeight

louver height (3.0mm as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1160 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::cntSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ cntSew

int svxLouverData::cntSew

count of sew shapes

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1168 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::dR2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ dR2

double svxLouverData::dR2

2nd louver radius (1.0mm as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1163 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::idProf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ idProf

int svxLouverData::idProf

id of profile

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1159 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::dWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ dWidth

double svxLouverData::dWidth

louver width (6.0mm as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1164 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ idPlane

int svxLouverData::idPlane

id of planar face for louver placement

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1158 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::Flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ Flip

int svxLouverData::Flip

whether to flip the louver 180 degrees about the sketch line(0-no as default, 1-yes)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1165 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::dAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ dAng

double svxLouverData::dAng

louver angle (45deg as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1161 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::pSewShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ pSewShape

int* svxLouverData::pSewShape

id list of sew shapes (NULL to sew with all shapes)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1169 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::notSew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ notSew

int svxLouverData::notSew

flag whether sew shapes or not. 0 = to sew (default)
since R2024, it doesn't sew the new shapes and if user set it to 0, it will create a 'Sew' feature to sew the shapes

Definition at line 1166 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxLouverData::dR1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxLouverData
cntSew
dAng
dHeight
dR1
dR2
dWidth
Flip
idPlane
idProf
notSew
pSewShape

◆ dR1

double svxLouverData::dR1

1st louver radius (1.0mm as default)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1162 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMassProp Struct Reference
Brep » Brep Data

mass attributes More...

#include <zwapi_brep_data.h>

Data Fields

double | Density
Density (kg/m^3) More...
double | Area
Area (mm^2) More...
double | Volume
Volume (mm^3) More...
double | Mass
Mass (kg) More...
svxPoint Center
Centroid (i.e. Center of Gravity) More...
svxVector | Axis [3]
Principal axes relative to global xyz frame. More...
double | Im [6]
Moments of inertia relative to xyz axes. More...
double | Ip [3]
Moments of inertia relative to principal axes. More...
double | Rad [3]
Radii of gyration relative to principal axes. More...

Detailed Description

mass attributes

Definition at line 46 of file zwapi_brep_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Area

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Area

double svxMassProp::Area

Area (mm^2)

Definition at line 49 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Im

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Im

double svxMassProp::Im[6]

Moments of inertia relative to xyz axes.

Definition at line 54 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Volume

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Volume

double svxMassProp::Volume

Volume (mm^3)

Definition at line 50 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Rad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Rad

double svxMassProp::Rad[3]

Radii of gyration relative to principal axes.

Definition at line 56 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Ip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Ip

double svxMassProp::Ip[3]

Moments of inertia relative to principal axes.

Definition at line 55 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Center

svxPoint svxMassProp::Center

Centroid (i.e. Center of Gravity)

Definition at line 52 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Axis

svxVector svxMassProp::Axis[3]

Principal axes relative to global xyz frame.

Definition at line 53 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Mass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Mass

double svxMassProp::Mass

Mass (kg)

Definition at line 51 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMassProp::Density

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMassProp
Area
Axis
Center
Density
Im
Ip
Mass
Rad
Volume

◆ Density

double svxMassProp::Density

Density (kg/m^3)

Definition at line 48 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMatEuler Struct Reference
Common » Common Data

Euler angles and translate vector. More...

#include <zwapi_util.h>

Data Fields

double | ang1st
1st rotate angle (Rad) More...
double | ang2nd
2nd rotate angle (Rad) More...
double | ang3rd
3rd rotate angle (Rad) More...
double | x
x location More...
double | y
y location More...
double | z
z location More...

Detailed Description

Euler angles and translate vector.

Definition at line 490 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ y

double svxMatEuler::y

y location

Definition at line 496 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::ang1st

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ ang1st

double svxMatEuler::ang1st

1st rotate angle (Rad)

Definition at line 492 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::ang3rd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ ang3rd

double svxMatEuler::ang3rd

3rd rotate angle (Rad)

Definition at line 494 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ z

double svxMatEuler::z

z location

Definition at line 497 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ x

double svxMatEuler::x

x location

Definition at line 495 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatEuler::ang2nd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatEuler
ang1st
ang2nd
ang3rd
x
y
z

◆ ang2nd

double svxMatEuler::ang2nd

2nd rotate angle (Rad)

Definition at line 493 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMatrix Struct Reference
Common » Common Data

3D transformation matrix or coordinate frame (local to world) More...

#include <zwapi_util.h>

Data Fields

char | identity
1 if identity matrix, else 0 More...
double | xx
double | yx
double | zx
double | xt
cosines of X axis and origin X (xt) More...
double | xy
double | yy
double | zy
double | yt
cosines of Y axis and origin Y (yt) More...
double | xz
double | yz
double | zz
double | zt
cosines of Z axis and origin Z (zt) More...

Detailed Description

3D transformation matrix or coordinate frame (local to world)

Examples
part\asmConsTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 478 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::xt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ xt

double svxMatrix::xt

cosines of X axis and origin X (xt)

Examples
part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 481 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::zy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ zy

double svxMatrix::zy
Examples
part\shapeFtrCrtTest.cpp.

Definition at line 482 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::xy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ xy

double svxMatrix::xy
Examples
part\baseFtrCrtTest.cpp.

Definition at line 482 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::yz

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ yz

double svxMatrix::yz
Examples
part\baseFtrCrtTest.cpp.

Definition at line 483 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::zz

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ zz

double svxMatrix::zz
Examples
part\datumCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 483 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::yx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ yx

double svxMatrix::yx
Examples
part\baseFtrCrtTest.cpp.

Definition at line 481 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::zx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ zx

double svxMatrix::zx
Examples
part\shapeFtrCrtTest.cpp.

Definition at line 481 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::xz

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ xz

double svxMatrix::xz
Examples
part\baseFtrCrtTest.cpp.

Definition at line 483 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::zt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ zt

double svxMatrix::zt

cosines of Z axis and origin Z (zt)

Examples
part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, and part\skCrtTest.cpp.

Definition at line 483 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::yt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ yt

double svxMatrix::yt

cosines of Y axis and origin Y (yt)

Examples
part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, and part\skCrtTest.cpp.

Definition at line 482 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::identity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ identity

char svxMatrix::identity

1 if identity matrix, else 0

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 480 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::xx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ xx

double svxMatrix::xx
Examples
part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 481 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMatrix::yy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMatrix
identity
xt
yt
zt

◆ yy

double svxMatrix::yy
Examples
part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 482 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrData2D Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMirrData2D Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

template command Mirror data(2D) More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | cntEnt
Entity count. More...
int * | pEnts
Entities ID. More...
int | Line
Line(Symmetry axis) ID. More...
int | KeepOrigEnt
Flag to use "Keep original entities" ,1 is default
More...

Detailed Description

template command Mirror data(2D)

Examples
sketch\basicEditingTest.cpp.

Definition at line 720 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrData2D::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrData2D
cntEnt
KeepOrigEnt
Line
pEnts

◆ cntEnt

int svxMirrData2D::cntEnt

Entity count.

Examples
sketch\basicEditingTest.cpp.

Definition at line 722 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrData2D::KeepOrigEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrData2D
cntEnt
KeepOrigEnt
Line
pEnts

◆ KeepOrigEnt

int svxMirrData2D::KeepOrigEnt

Flag to use "Keep original entities" ,1 is default

Examples
sketch\basicEditingTest.cpp.

Definition at line 725 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrData2D::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrData2D
cntEnt
KeepOrigEnt
Line
pEnts

◆ pEnts

int* svxMirrData2D::pEnts

Entities ID.

Examples
sketch\basicEditingTest.cpp.

Definition at line 723 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrData2D::Line

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrData2D
cntEnt
KeepOrigEnt
Line
pEnts

◆ Line

int svxMirrData2D::Line

Line(Symmetry axis) ID.

Examples
sketch\basicEditingTest.cpp.

Definition at line 724 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMirrorFtr Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

mirror feature data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numFtrs
number of features to mirror More...
int * | idFtrs
list of features ids More...
int | idPlane
id of mirror plane (datum plane, planar face or sketch) More...
evxBoolType combine
combination method More...
int | numShapes
number of shapes to boolean More...
int * | idShapes
list of id's of shapes to boolean More...
int | keep
whether to keep the original features (0 = no keep, 1 = keep) More...
vxName ftrName
feature name for "FtMirrorFtr", 0 default More...

Detailed Description

mirror feature data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1467 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ idPlane

int svxMirrorFtr::idPlane

id of mirror plane (datum plane, planar face or sketch)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1471 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ numShapes

int svxMirrorFtr::numShapes

number of shapes to boolean

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1474 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::numFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ numFtrs

int svxMirrorFtr::numFtrs

number of features to mirror

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1469 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ idShapes

int* svxMirrorFtr::idShapes

list of id's of shapes to boolean

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1475 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ combine

evxBoolType svxMirrorFtr::combine

combination method

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1473 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::idFtrs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ idFtrs

int* svxMirrorFtr::idFtrs

list of features ids

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1470 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::keep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ keep

int svxMirrorFtr::keep

whether to keep the original features (0 = no keep, 1 = keep)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1477 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorFtr::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorFtr
combine
ftrName
idFtrs
idPlane
idShapes
keep
numFtrs
numShapes

◆ ftrName

vxName svxMirrorFtr::ftrName

feature name for "FtMirrorFtr", 0 default

Definition at line 1478 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMirrorGeom Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

mirror geometry data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numEnts
number of entities to mirror More...
int * | idEnts
list of geometry entity ids More...
int | idPlane
id of mirror plane (datum plane, planar face or sketch) More...
evxBoolType combine
combination method More...
int | numShapes
number of shapes to boolean More...
int * | idShapes
list of id's of shapes to boolean More...
int | keep
whether to keep the original entities (0 = no keep, 1 = keep) More...
int | assoCopy
whether to keep associated with the original entities (0 = no, 1 = yes) More...
vxName ftrName
feature name for "FtMirrorGeom", 0 default More...

Detailed Description

mirror geometry data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1447 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::assoCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ assoCopy

int svxMirrorGeom::assoCopy

whether to keep associated with the original entities (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1458 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ numShapes

int svxMirrorGeom::numShapes

number of shapes to boolean

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1454 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::numEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ numEnts

int svxMirrorGeom::numEnts

number of entities to mirror

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1449 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::keep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ keep

int svxMirrorGeom::keep

whether to keep the original entities (0 = no keep, 1 = keep)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1457 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ idPlane

int svxMirrorGeom::idPlane

id of mirror plane (datum plane, planar face or sketch)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1451 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ ftrName

vxName svxMirrorGeom::ftrName

feature name for "FtMirrorGeom", 0 default

Definition at line 1460 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ idShapes

int* svxMirrorGeom::idShapes

list of id's of shapes to boolean

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1455 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ idEnts

int* svxMirrorGeom::idEnts

list of geometry entity ids

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1450 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMirrorGeom::combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMirrorGeom
assoCopy
combine
ftrName
idEnts
idPlane
idShapes
keep
numEnts
numShapes

◆ combine

evxBoolType svxMirrorGeom::combine

combination method

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1453 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMorphToCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape morph to curve data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numGeometry
numbers of morphed shapes More...
int * | idGeometry
select geometry to morph More...
int | idFromCurve
from curve is where the morph will start More...
int | idToCurve
to curve is where the morph will end More...
int | miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default) More...
int | bendOrTranslate
allow the morph transformation to be a straight translation or a bend (0 = bend, 1 = translate. default = 0) More...
double | infulence [2]
specify radius of influence (min = 0. default = 20) More...
int | rigid [2]
specify radius for rigid motion (min = 0, max = 100, inc = 1. default = 0) More...
int | bulge [2]
specify bulge factor for transition region (min = 0, max = 100, inc = 1. default = 50) More...
int | slope [2]
specify slope for transition region (min = 0, max = 100, inc = 1. default = 50) More...
int | flatOrPeak [2]
this determines whether the surfaces at the new point location are rounded (flat) or sharp (peak) (0 = flat, 1 = peak. default = 1) More...
int | numStationary
numbers of stationary shapes More...
int * | idStationary
stationary shapes More...

Detailed Description

shape morph to curve data

Definition at line 1245 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::idGeometry

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ idGeometry

int* svxMorphToCrvData::idGeometry

select geometry to morph

Definition at line 1249 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::numStationary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ numStationary

int svxMorphToCrvData::numStationary

numbers of stationary shapes

Definition at line 1263 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::flatOrPeak

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ flatOrPeak

int svxMorphToCrvData::flatOrPeak[2]

this determines whether the surfaces at the new point location are rounded (flat) or sharp (peak) (0 = flat, 1 = peak. default = 1)

Definition at line 1262 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::bulge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ bulge

int svxMorphToCrvData::bulge[2]

specify bulge factor for transition region (min = 0, max = 100, inc = 1. default = 50)

Definition at line 1260 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::numGeometry

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ numGeometry

int svxMorphToCrvData::numGeometry

numbers of morphed shapes

Definition at line 1248 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::idFromCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ idFromCurve

int svxMorphToCrvData::idFromCurve

from curve is where the morph will start

Definition at line 1250 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::slope

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ slope

int svxMorphToCrvData::slope[2]

specify slope for transition region (min = 0, max = 100, inc = 1. default = 50)

Definition at line 1261 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::infulence

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ infulence

double svxMorphToCrvData::infulence[2]

specify radius of influence (min = 0. default = 20)

Definition at line 1258 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::idToCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ idToCurve

int svxMorphToCrvData::idToCurve

to curve is where the morph will end

Definition at line 1251 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::rigid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ rigid

int svxMorphToCrvData::rigid[2]

specify radius for rigid motion (min = 0, max = 100, inc = 1. default = 0)

Definition at line 1259 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::miniSurfData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ miniSurfData

int svxMorphToCrvData::miniSurfData

whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)

Definition at line 1253 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::bendOrTranslate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ bendOrTranslate

int svxMorphToCrvData::bendOrTranslate

allow the morph transformation to be a straight translation or a bend (0 = bend, 1 = translate. default = 0)

on the Move tab, you define the Geometry that will move and the parameters that affect how much nearby geometry will move. on the Lock tab, you define the Stationary geometry that will not move and the same transition parameters. ~[0] is in Move tab, ~[1] is in Lock tab

Definition at line 1254 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMorphToCrvData::idStationary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMorphToCrvData
bendOrTranslate
bulge
flatOrPeak
idFromCurve
idGeometry
idStationary
idToCurve
infulence
miniSurfData
numGeometry
numStationary
rigid
slope

◆ idStationary

int* svxMorphToCrvData::idStationary

stationary shapes

Definition at line 1264 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxMoveData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

template command Move data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

union evxMethodsUnion
union of move data More...

Data Fields

evxMoveType method
move methods More...
int | cntEnt
entity count More...
int * | pEnts
entities ID More...
union svxMoveData::evxMethodsUnion | MethodUnion

Detailed Description

template command Move data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1577 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxMoveData2D Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

template command Move data(2D) More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union evxMethodsUnion2D
move data More...

Data Fields

evxMoveType2D methods
Move Methods. More...
int | cntEnt
Entity count. More...
int * | pEnts
Entities ID. More...
union svxMoveData2D::evxMethodsUnion2D | MethodUnion2D

Detailed Description

template command Move data(2D)

Examples
sketch\basicEditingTest.cpp.

Definition at line 667 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
cntEnt
methods
pEnts

◆ pEnts

int* svxMoveData2D::pEnts

Entities ID.

Examples
sketch\basicEditingTest.cpp.

Definition at line 671 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::methods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
cntEnt
methods
pEnts

◆ methods

evxMoveType2D svxMoveData2D::methods

Move Methods.

Examples
sketch\basicEditingTest.cpp.

Definition at line 669 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
cntEnt
methods
pEnts

◆ cntEnt

int svxMoveData2D::cntEnt

Entity count.

Examples
sketch\basicEditingTest.cpp.

Definition at line 670 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
cntEnt
method
pEnts

◆ method

evxMoveType svxMoveData::method

move methods

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1579 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
cntEnt
method
pEnts

◆ pEnts

int* svxMoveData::pEnts

entities ID

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1581 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
cntEnt
method
pEnts

◆ cntEnt

int svxMoveData::cntEnt

entity count

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1580 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMovePntToPnt Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

copy/move entities form point to point More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPntOnEnt FromPnt
from point More...
svxPntOnEnt ToPnt
to point More...
svxPntOnEnt FromVector
from vector More...
svxPntOnEnt ToVector
to vector More...

Detailed Description

copy/move entities form point to point

Definition at line 1512 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxMovePntToPnt2D Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

copy/move entities form point to point (2D) More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint2 FromPoint
from point More...
svxPoint2 ToPoint
to point More...
evxDrawingMoveDirType type
direction type More...
double | angle
angle More...
double | scale
scale More...

Detailed Description

copy/move entities form point to point (2D)

Definition at line 654 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt2D
angle
FromPoint
scale
ToPoint
type

◆ type

evxDrawingMoveDirType svxMovePntToPnt2D::type

direction type

Examples
sketch\basicEditingTest.cpp.

Definition at line 658 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D::FromPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt2D
angle
FromPoint
scale
ToPoint
type

◆ FromPoint

svxPoint2 svxMovePntToPnt2D::FromPoint

from point

Examples
sketch\basicEditingTest.cpp.

Definition at line 656 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt2D
angle
FromPoint
scale
ToPoint
type

◆ angle

double svxMovePntToPnt2D::angle

angle

Examples
sketch\basicEditingTest.cpp.

Definition at line 659 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D::ToPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt2D
angle
FromPoint
scale
ToPoint
type

◆ ToPoint

svxPoint2 svxMovePntToPnt2D::ToPoint

to point

Examples
sketch\basicEditingTest.cpp.

Definition at line 657 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt2D::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt2D
angle
FromPoint
scale
ToPoint
type

◆ scale

double svxMovePntToPnt2D::scale

scale

Examples
sketch\basicEditingTest.cpp.

Definition at line 660 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt::ToVector

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt
FromPnt
FromVector
ToPnt
ToVector

◆ ToVector

svxPntOnEnt svxMovePntToPnt::ToVector

to vector

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1518 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt::ToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt
FromPnt
FromVector
ToPnt
ToVector

◆ ToPnt

svxPntOnEnt svxMovePntToPnt::ToPnt

to point

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1515 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt::FromVector

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt
FromPnt
FromVector
ToPnt
ToVector

◆ FromVector

svxPntOnEnt svxMovePntToPnt::FromVector

from vector

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1517 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMovePntToPnt::FromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMovePntToPnt
FromPnt
FromVector
ToPnt
ToVector

◆ FromPnt

svxPntOnEnt svxMovePntToPnt::FromPnt

from point

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1514 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxNSidedData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

template command N-sided data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | numCrv
count of the paths More...
int * | pCrv
id of curves More...
int * | pCrvParent
parent index of curves (-1/NULL to ignore) More...
int | sewShape
flag to sew shapes or not. 1 = to sew , (default) since R2024, it doesn't sew the new shapes and if user set it to 1, it will create a 'Sew' feature to sew the shapes More...
int | numShape
count of the shapes, valid if sewShape set to 1, can be ignored More...
int * | pShape
index of the shapes, valid if sewShape set to 1, can be ignored More...
int | tangent
tangent at boundary , 0 = no (default), 1 = tangent More...
evxRefitOpt refit
enum for Refit options, 0 = no, 1 = tangent , 2 = curvature, 3 = direct (default) More...
double | dTol
Tolerance, 0.01 (default) More...

Detailed Description

template command N-sided data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 121 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::pCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ pCrv

int* svxNSidedData::pCrv

id of curves

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 124 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::refit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ refit

evxRefitOpt svxNSidedData::refit

enum for Refit options, 0 = no, 1 = tangent , 2 = curvature, 3 = direct (default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 131 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::tangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ tangent

int svxNSidedData::tangent

tangent at boundary , 0 = no (default), 1 = tangent

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 130 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::pCrvParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ pCrvParent

int* svxNSidedData::pCrvParent

parent index of curves (-1/NULL to ignore)

Definition at line 125 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::pShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ pShape

int* svxNSidedData::pShape

index of the shapes, valid if sewShape set to 1, can be ignored

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 129 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::sewShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ sewShape

int svxNSidedData::sewShape

flag to sew shapes or not. 1 = to sew , (default) since R2024, it doesn't sew the new shapes and if user set it to 1, it will create a 'Sew' feature to sew the shapes

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 126 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::numShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ numShape

int svxNSidedData::numShape

count of the shapes, valid if sewShape set to 1, can be ignored

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 128 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::numCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ numCrv

int svxNSidedData::numCrv

count of the paths

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 123 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNSidedData::dTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNSidedData
dTol
numCrv
numShape
pCrv
pCrvParent
pShape
refit
sewShape
tangent

◆ dTol

double svxNSidedData::dTol

Tolerance, 0.01 (default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 132 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxNcSetting Struct Reference
Cam » Cam Forms API

cam nc output setting More...

#include <zwapi_cm_forms.h>

Data Fields

vxName machine
char | filename [512]
vxName part_id
vxName programmer
vxName space
vxName tool_changes
vxName spd_fd
vxName tool_num
vxName coolant
char | prog_comment [256]

Detailed Description

cam nc output setting

Definition at line 30 of file zwapi_cm_forms.h.

The documentation for this struct was generated from the following file:
  • zwapi_cm_forms.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::filename

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ filename

char svxNcSetting::filename[512]

Definition at line 33 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::tool_changes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ tool_changes

vxName svxNcSetting::tool_changes

Definition at line 37 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::space

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ space

vxName svxNcSetting::space

Definition at line 36 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::part_id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ part_id

vxName svxNcSetting::part_id

Definition at line 34 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::machine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ machine

vxName svxNcSetting::machine

Definition at line 32 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::tool_num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ tool_num

vxName svxNcSetting::tool_num

Definition at line 39 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::coolant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ coolant

vxName svxNcSetting::coolant

Definition at line 40 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::spd_fd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ spd_fd

vxName svxNcSetting::spd_fd

Definition at line 38 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::programmer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ programmer

vxName svxNcSetting::programmer

Definition at line 35 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNcSetting::prog_comment

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNcSetting

◆ prog_comment

char svxNcSetting::prog_comment[256]

Definition at line 41 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxNewPlaneData Struct Reference
Commands Creation » Part and Assembly Commands » Datum Commands Data

New template command Plane input data. More...

#include <zwapi_cmd_datum_data.h>

Data Structures

union evxNewPlaneMethodsUnion
union of plane input data More...

Data Fields

evxNewPlaneMethods method
methods More...
union svxNewPlaneData::evxNewPlaneMethodsUnion | inpUnion
int | isFlipDir
1 if flip direction, else 0
method = VX_NEW_PLANE_GEOMETRY, VX_NEW_PLANE_THREE_POINTS, VX_NEW_PLANE_ON_CURVE, VX_NEW_PLANE_VIEW_PLANE it means "Flip direction" option;
method = VX_NEW_PLANE_OFFSET_PLANE, VX_NEW_PLANE_ANGLE_FACE, it means "Flip the direction of face" More...
double | dOffset
offset More...
svxPoint * orgPnt
origin (NULL to ignore) More...
svxPoint * xPoint
X point (NULL to ignore) More...
double | xAng
angle value X direction More...
double | yAng
angle value Y direction More...
double | zAng
angle value Z direction More...

Detailed Description

New template command Plane input data.

Examples
part\datumCrtTest.cpp.

Definition at line 208 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc Struct Reference

angle to face :VX_NEW_PLANE_ANGLE_FACE More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint orgPnt
origin on "path" More...
svxEntPath path
face path More...
svxPoint axis
point on line(or edge) More...
svxEntPath linePath
line or edge path More...
double angle
angle (default: 45) More...

Detailed Description

angle to face :VX_NEW_PLANE_ANGLE_FACE

<

Definition at line 280 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
angle
axis
linePath
orgPnt
path

◆ angle

double svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::angle

angle (default: 45)

Examples
part\datumCrtTest.cpp.

Definition at line 286 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::linePath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
angle
axis
linePath
orgPnt
path

◆ linePath

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::linePath

line or edge path

Examples
part\datumCrtTest.cpp.

Definition at line 285 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
angle
axis
linePath
orgPnt
path

◆ orgPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::orgPnt

origin on "path"

Examples
part\datumCrtTest.cpp.

Definition at line 282 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
angle
axis
linePath
orgPnt
path

◆ path

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::path

face path

Examples
part\datumCrtTest.cpp.

Definition at line 283 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneAngToFc
angle
axis
linePath
orgPnt
path

◆ axis

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::axis

point on line(or edge)

Examples
part\datumCrtTest.cpp.

Definition at line 284 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic Struct Reference

dynamic :VX_NEW_PLANE_DYNAMIC More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint posPnt
position More...
svxPntByOffset * posPntByOffset
set the position point by the offset sub-command (NULL to use posPnt or PosPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * posPntBy2Lines
set the position point by the from 2 lines sub-command (NULL to use posPnt or PosPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
svxVector xAxis
X Axis. More...
svxVector yAxis
Y Axis. More...
svxVector zAxis
Z Axis. More...
int autoOrient
1 if auto orientation, else 0 More...

Detailed Description

dynamic :VX_NEW_PLANE_DYNAMIC

<

Definition at line 261 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::autoOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ autoOrient

int svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::autoOrient

1 if auto orientation, else 0

Examples
part\datumCrtTest.cpp.

Definition at line 272 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::xAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ xAxis

svxVector svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::xAxis

X Axis.

Examples
part\datumCrtTest.cpp.

Definition at line 269 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::yAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ yAxis

svxVector svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::yAxis

Y Axis.

Examples
part\datumCrtTest.cpp.

Definition at line 270 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ posPntBy2Lines

svxPntBy2Lines* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntBy2Lines

set the position point by the from 2 lines sub-command (NULL to use posPnt or PosPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 267 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ posPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPnt

position

Examples
part\datumCrtTest.cpp.

Definition at line 263 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::zAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ zAxis

svxVector svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::zAxis

Z Axis.

Examples
part\datumCrtTest.cpp.

Definition at line 271 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneDynamic
autoOrient
posPnt
posPntBy2Lines
posPntByOffset
xAxis
yAxis
zAxis

◆ posPntByOffset

svxPntByOffset* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntByOffset

set the position point by the offset sub-command (NULL to use posPnt or PosPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 264 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry Struct Reference

geometry :VX_NEW_PLANE_GEOMETRY More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint pnt
Picked Point. More...
svxEntPath path
entity/object pick path More...
int | cnt
count of pnts and paths More...
svxPoint * pnts
picked points More...
svxEntPath * paths
entity/object pick paths More...
double | offset
offset the new datum from the target geometry More...
double | angle
angle (default: 45) More...

Detailed Description

geometry :VX_NEW_PLANE_GEOMETRY

<

Definition at line 213 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::paths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ paths

svxEntPath* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::paths

entity/object pick paths

Examples
part\datumCrtTest.cpp.

Definition at line 223 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ offset

double svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::offset

offset the new datum from the target geometry

Examples
part\datumCrtTest.cpp.

Definition at line 226 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ cnt

int svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::cnt

count of pnts and paths

Examples
part\datumCrtTest.cpp.

Definition at line 221 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ path

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::path

entity/object pick path

Definition at line 217 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ angle

double svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::angle

angle (default: 45)

Examples
part\datumCrtTest.cpp.

Definition at line 227 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ pnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnt

Picked Point.

Definition at line 216 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneGeometry
angle
cnt
offset
path
paths
pnt
pnts

◆ pnts

svxPoint* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnts

picked points

Examples
part\datumCrtTest.cpp.

Definition at line 222 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOffset
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset Struct Reference

offset plane :VX_NEW_PLANE_OFFSET_PLANE More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint orgPnt
origin on "path" More...
svxEntPath path
face path More...
double offset
offset More...

Detailed Description

offset plane :VX_NEW_PLANE_OFFSET_PLANE

<

Definition at line 274 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOffset
offset
orgPnt
path

◆ offset

double svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::offset

offset

Examples
part\datumCrtTest.cpp.

Definition at line 278 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOffset
offset
orgPnt
path

◆ path

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::path

face path

Examples
part\datumCrtTest.cpp.

Definition at line 277 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOffset
offset
orgPnt
path

◆ orgPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::orgPnt

origin on "path"

Examples
part\datumCrtTest.cpp.

Definition at line 276 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve Struct Reference

on curve :VX_NEW_PLANE_ON_CURVE More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint orgPnt
This variable is deprecated and can be ignored. This has no effect on the previous Settings. More...
svxEntPath path
Curve C path. More...
int | isPercent
1 if use percent, 2 if use distance More...
double | num
if isPercent = 1, num is Percent; if isPercent = 2, num is distance. More...
evxOnCrvDirType dirType
direction type More...
svxEntPath CrvPath
Curve path. More...

Detailed Description

on curve :VX_NEW_PLANE_ON_CURVE

<

Definition at line 288 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::dirType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ dirType

evxOnCrvDirType svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::dirType

direction type

Examples
part\datumCrtTest.cpp.

Definition at line 294 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ num

double svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::num

if isPercent = 1, num is Percent; if isPercent = 2, num is distance.

Examples
part\datumCrtTest.cpp.

Definition at line 293 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ path

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::path

Curve C path.

Examples
part\datumCrtTest.cpp.

Definition at line 291 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ orgPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::orgPnt

This variable is deprecated and can be ignored. This has no effect on the previous Settings.

Definition at line 290 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::isPercent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ isPercent

int svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::isPercent

1 if use percent, 2 if use distance

Examples
part\datumCrtTest.cpp.

Definition at line 292 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::CrvPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneOnCurve
CrvPath
dirType
isPercent
num
orgPnt
path

◆ CrvPath

svxEntPath svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::CrvPath

Curve path.

Examples
part\datumCrtTest.cpp.

Definition at line 295 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt Struct Reference

three point :VX_NEW_PLANE_THREE_POINTS More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint orgPnt
origin More...
svxPntByOffset * orgPntByOffset
set the origin point by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * orgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
svxPoint xPnt
XPoint. More...
svxPntByOffset * xPntByOffset
set the XPoint by the offset sub-command (NULL to use xPnt or xPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * xPntBy2Lines
set the XPoint by the from 2 lines sub-command (NULL to use xPnt or xPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...
svxPoint yPnt
YPoint. More...
svxPntByOffset * yPntByOffset
set the YPoint by the offset sub-command (NULL to use yPnt or yPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * yPntBy2Lines
set the YPoint by the from 2 lines sub-command (NULL to use yPnt or yPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...

Detailed Description

three point :VX_NEW_PLANE_THREE_POINTS

<

Definition at line 229 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ orgPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPnt

origin

Examples
part\datumCrtTest.cpp.

Definition at line 231 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ xPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPnt

XPoint.

Examples
part\datumCrtTest.cpp.

Definition at line 238 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ xPntBy2Lines

svxPntBy2Lines* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntBy2Lines

set the XPoint by the from 2 lines sub-command (NULL to use xPnt or xPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 242 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ xPntByOffset

svxPntByOffset* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntByOffset

set the XPoint by the offset sub-command (NULL to use xPnt or xPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 239 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ yPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPnt

YPoint.

Examples
part\datumCrtTest.cpp.

Definition at line 245 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ yPntBy2Lines

svxPntBy2Lines* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntBy2Lines

set the YPoint by the from 2 lines sub-command (NULL to use yPnt or yPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 249 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ orgPntBy2Lines

svxPntBy2Lines* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntBy2Lines

set the origin point by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 235 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ orgPntByOffset

svxPntByOffset* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntByOffset

set the origin point by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 232 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewPlaneThreePnt
orgPnt
orgPntBy2Lines
orgPntByOffset
xPnt
xPntBy2Lines
xPntByOffset
yPnt
yPntBy2Lines
yPntByOffset

◆ yPntByOffset

svxPntByOffset* svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntByOffset

set the YPoint by the offset sub-command (NULL to use yPnt or yPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 246 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewviewPlane
Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane Struct Reference

view plane :VX_NEW_PLANE_VIEW_PLANE More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint orgPnt
origin More...
svxPntByOffset * orgPntByOffset
set the origin by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter More...
svxPntBy2Lines * orgPntBy2Lines
set the origin by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter More...

Detailed Description

view plane :VX_NEW_PLANE_VIEW_PLANE

<

Definition at line 252 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntByOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewviewPlane
orgPnt
orgPntBy2Lines
orgPntByOffset

◆ orgPntByOffset

svxPntByOffset* svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntByOffset

set the origin by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 255 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewviewPlane
orgPnt
orgPntBy2Lines
orgPntByOffset

◆ orgPnt

svxPoint svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPnt

origin

Definition at line 254 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntBy2Lines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
  • NewviewPlane
orgPnt
orgPntBy2Lines
orgPntByOffset

◆ orgPntBy2Lines

svxPntBy2Lines* svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntBy2Lines

set the origin by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2LinesInit() can initialize this parameter

Examples
part\datumCrtTest.cpp.

Definition at line 258 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::isFlipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ isFlipDir

int svxNewPlaneData::isFlipDir

1 if flip direction, else 0
method = VX_NEW_PLANE_GEOMETRY, VX_NEW_PLANE_THREE_POINTS, VX_NEW_PLANE_ON_CURVE, VX_NEW_PLANE_VIEW_PLANE it means "Flip direction" option;
method = VX_NEW_PLANE_OFFSET_PLANE, VX_NEW_PLANE_ANGLE_FACE, it means "Flip the direction of face"

Examples
part\datumCrtTest.cpp.

Definition at line 300 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::orgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ orgPnt

svxPoint* svxNewPlaneData::orgPnt

origin (NULL to ignore)

Examples
part\datumCrtTest.cpp.

Definition at line 307 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::yAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ yAng

double svxNewPlaneData::yAng

angle value Y direction

Examples
part\datumCrtTest.cpp.

Definition at line 310 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::xPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ xPoint

svxPoint* svxNewPlaneData::xPoint

X point (NULL to ignore)

Examples
part\datumCrtTest.cpp.

Definition at line 308 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::xAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ xAng

double svxNewPlaneData::xAng

angle value X direction

Examples
part\datumCrtTest.cpp.

Definition at line 309 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::zAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ zAng

double svxNewPlaneData::zAng

angle value Z direction

Examples
part\datumCrtTest.cpp.

Definition at line 311 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ dOffset

double svxNewPlaneData::dOffset

offset

Examples
part\datumCrtTest.cpp.

Definition at line 306 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
dOffset
isFlipDir
method
orgPnt
xAng
xPoint
yAng
zAng

◆ method

evxNewPlaneMethods svxNewPlaneData::method

methods

Examples
part\datumCrtTest.cpp.

Definition at line 210 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxNormalCutData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Normal Cut data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

evxNormCutTyp cutType
normal cut option, default value:VX_NORMCUT_BOTHSIDES More...
int | idProfile
Profile P. More...
int | cntShape
Cut Shapes count. More...
int * | shapeList
Cut Shapes List. More...
evxExtrudeType extType
extrude type, default value:VX_EXTRUDE_TYPE_ONESIDE More...
double | dStart
Start S, default value:10.0. More...
double | dEnd
End E, default value:-10.0. More...
svxVector * Dir
Direction (NULL can be ignored) More...
int | Flip
Flip side to cut, default value:0. More...
evxDistanceMethod startType
start type (0 = input value, 1 = through all, 2= to point, 5 = to face) More...
evxDistanceMethod endType
end type (0 = input value, 1 = through all, 2= to point, 5 = to face) More...
int | idStartEnt
the entity id of start field if startType > 1 More...
int | idEndEnt
the entity id of end field if endType > 1 More...
svxPoint * startToPnt
if startType = 2, NULL to ignore More...
svxPoint * endToPnt
if endType = 2, NULL to ignore More...

Detailed Description

template command Smd Normal Cut data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 938 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::Flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ Flip

int svxNormalCutData::Flip

Flip side to cut, default value:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 948 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::cutType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ cutType

evxNormCutTyp svxNormalCutData::cutType

normal cut option, default value:VX_NORMCUT_BOTHSIDES

Examples
part\smdFtrCrtTest.cpp.

Definition at line 940 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::dEnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ dEnd

double svxNormalCutData::dEnd

End E, default value:-10.0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 946 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::idStartEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ idStartEnt

int svxNormalCutData::idStartEnt

the entity id of start field if startType > 1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 952 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::cntShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ cntShape

int svxNormalCutData::cntShape

Cut Shapes count.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 942 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::dStart

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ dStart

double svxNormalCutData::dStart

Start S, default value:10.0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 945 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::endType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ endType

evxDistanceMethod svxNormalCutData::endType

end type (0 = input value, 1 = through all, 2= to point, 5 = to face)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 951 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ idProfile

int svxNormalCutData::idProfile

Profile P.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 941 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ Dir

svxVector* svxNormalCutData::Dir

Direction (NULL can be ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 947 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::startType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ startType

evxDistanceMethod svxNormalCutData::startType

start type (0 = input value, 1 = through all, 2= to point, 5 = to face)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 950 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::idEndEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ idEndEnt

int svxNormalCutData::idEndEnt

the entity id of end field if endType > 1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 953 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::startToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ startToPnt

svxPoint* svxNormalCutData::startToPnt

if startType = 2, NULL to ignore

Examples
part\smdFtrCrtTest.cpp.

Definition at line 954 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::shapeList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ shapeList

int* svxNormalCutData::shapeList

Cut Shapes List.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 943 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::endToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ endToPnt

svxPoint* svxNormalCutData::endToPnt

if endType = 2, NULL to ignore

Examples
part\smdFtrCrtTest.cpp.

Definition at line 955 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNormalCutData::extType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNormalCutData
cntShape
cutType
dEnd
Dir
dStart
endToPnt
endType
extType
Flip
idEndEnt
idProfile
idStartEnt
shapeList
startToPnt
startType

◆ extType

evxExtrudeType svxNormalCutData::extType

extrude type, default value:VX_EXTRUDE_TYPE_ONESIDE

Examples
part\smdFtrCrtTest.cpp.

Definition at line 944 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxOBJData Struct Reference
File » File Data

data of export obj file More...

#include <zwapi_file_data.h>

Data Fields

int | ExportMaterial
whether to export the material file(*.mtl file) (1-default) More...
int | OptimizeVertex
whether to optimize vertex (1-default) More...
int | CopyTextureFile
whether to export the texture file to output directory (0-default) More...
double | ChordHeight
chord height tessellation tolerance (0.01-default) More...
int | OutputDecimal
decimal in *.obj file (4-default) More...
int | ExportType
0-All objects, 1-Specified entities (0-default) More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(only support VX_EXCLUDE_BLANKED), (default: ExcludeGeom=VX_EXCLUDE_BLANKED) More...

Detailed Description

data of export obj file

Definition at line 649 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ EntCnt

int svxOBJData::EntCnt

the count of export entities if ExportType = 1

Definition at line 658 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::OptimizeVertex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ OptimizeVertex

int svxOBJData::OptimizeVertex

whether to optimize vertex (1-default)

Definition at line 652 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ EntList

int* svxOBJData::EntList

the specified entities id list if ExportType = 1

Definition at line 659 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ ExportType

int svxOBJData::ExportType

0-All objects, 1-Specified entities (0-default)

Definition at line 657 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::OutputDecimal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ OutputDecimal

int svxOBJData::OutputDecimal

decimal in *.obj file (4-default)

Definition at line 655 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ ExcludeGeom

int svxOBJData::ExcludeGeom

filter geometry type(only support VX_EXCLUDE_BLANKED), (default: ExcludeGeom=VX_EXCLUDE_BLANKED)

Definition at line 661 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::ChordHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ ChordHeight

double svxOBJData::ChordHeight

chord height tessellation tolerance (0.01-default)

Definition at line 654 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::ExportMaterial

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ ExportMaterial

int svxOBJData::ExportMaterial

whether to export the material file(*.mtl file) (1-default)

Definition at line 651 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxOBJData::CopyTextureFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxOBJData
ChordHeight
CopyTextureFile
EntCnt
EntList
ExcludeGeom
ExportMaterial
ExportType
OptimizeVertex
OutputDecimal

◆ CopyTextureFile

int svxOBJData::CopyTextureFile

whether to export the texture file to output directory (0-default)

Definition at line 653 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPARAData Struct Reference
File » File Data

data of export PARA file More...

#include <zwapi_file_data.h>

Data Fields

char | Coordinate
0-World, 1-Local (0-default) More...
char | OutPut
0-Assembly, 1-Part (1-default) More...
int | FileVer
file version (7 ~ 30, 19-default) More...
int | WriteFreeCrv
whether to write free curve (1 = yes, 0 = no) More...
int | WriteFreePnt
whether to write free point (1 = yes, 0 = no) More...
int | HealErr
whether to auto heal topology error (1 = yes, 0 = no) More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...

Detailed Description

data of export PARA file

Definition at line 399 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ EntCnt

int svxPARAData::EntCnt

the count of export entities if ExportType = 1

Definition at line 408 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::WriteFreePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ WriteFreePnt

int svxPARAData::WriteFreePnt

whether to write free point (1 = yes, 0 = no)

Definition at line 405 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::HealErr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ HealErr

int svxPARAData::HealErr

whether to auto heal topology error (1 = yes, 0 = no)

Definition at line 406 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::Coordinate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ Coordinate

char svxPARAData::Coordinate

0-World, 1-Local (0-default)

Definition at line 401 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::WriteFreeCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ WriteFreeCrv

int svxPARAData::WriteFreeCrv

whether to write free curve (1 = yes, 0 = no)

Definition at line 404 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ ExcludeGeom

int svxPARAData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 410 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ EntList

int* svxPARAData::EntList

the specified entities id list if ExportType = 1

Definition at line 409 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::FileVer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ FileVer

int svxPARAData::FileVer

file version (7 ~ 30, 19-default)

Definition at line 403 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ ExportType

char svxPARAData::ExportType

0-All objects, 1-Specified entities

Definition at line 407 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPARAData::OutPut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPARAData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportType
FileVer
HealErr
OutPut
WriteFreeCrv
WriteFreePnt

◆ OutPut

char svxPARAData::OutPut

0-Assembly, 1-Part (1-default)

Definition at line 402 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxParameters Struct Reference
Common » Common Data

curve parameter space data More...

#include <zwapi_util.h>

Data Fields

int | closed
1=closed curve, 0=open curve More...
int | degree
degree (order = deg + 1) More...
int | num_knots
number of knots More...
svxLimit bnd
boundaries of parameter space More...
double * | knots
array of knot values More...
int | free_mem
1 if memory referenced by "knots" should be free'd by cvxCurveFree() More...

Detailed Description

curve parameter space data

Definition at line 1610 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::knots

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ knots

double* svxParameters::knots

array of knot values

Definition at line 1616 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::bnd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ bnd

svxLimit svxParameters::bnd

boundaries of parameter space

Definition at line 1615 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::num_knots

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ num_knots

int svxParameters::num_knots

number of knots

Definition at line 1614 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::degree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ degree

int svxParameters::degree

degree (order = deg + 1)

Definition at line 1613 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::free_mem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ free_mem

int svxParameters::free_mem

1 if memory referenced by "knots" should be free'd by cvxCurveFree()

Definition at line 1617 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxParameters::closed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxParameters
bnd
closed
degree
free_mem
knots
num_knots

◆ closed

int svxParameters::closed

1=closed curve, 0=open curve

Definition at line 1612 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartAttribute Struct Reference
Common » Common Data

part attribute structure More...

#include <zwapi_util.h>

Data Fields

int | Version
attribute version More...
int | UserAttributeCount
count of UserAttribute More...
svxAttribute | UserAttribute [64]
user Attribute(Up to 64 user attributes). More...
svxAttribute Name
name attribute More...
svxAttribute Number
number attribute More...
svxAttribute Partclass
part class attribute More...
svxAttribute Designer
designer attribute More...
svxAttribute Cost
cost attribute More...
svxAttribute Supplier
supplier attribute More...
svxAttribute Description
description attribute More...
svxAttribute Keyword
keyword attribute More...
svxAttribute Manager
manager attribute More...
svxAttribute Material
material attribute More...
svxAttribute Startdate
start date attribute More...
svxAttribute Enddate
end date attribute More...
svxAttribute Derived
derived attribute More...
svxAttribute No_section
set "data" to "yes" or "no" More...
svxAttribute No_hatch
set "data" to "yes" or "no" More...
svxAttribute | Dimen [20]
dimension attribute, these attributes had been converted to a configuration table attributes or variables since R2018.
if there is a configuration table in current part, you can use cvxPartInqCfgTblInfos() to get and cvxCfgTblInfosSet() to modify.
or these attributes converted variables, you can use cvxPartVarGet() and cvxPartVarSet(). More...
svxAttribute No_bom
set "data" to "yes" or "no" More...
svxAttribute File_path
file path More...
svxAttribute No_rootshow
set "data" to "yes" or "no" More...
svxAttribute sheet_code
sheet code attribute More...

Detailed Description

part attribute structure

Definition at line 1385 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Cost

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Cost

svxAttribute svxPartAttribute::Cost

cost attribute

Definition at line 1394 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::No_rootshow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ No_rootshow

svxAttribute svxPartAttribute::No_rootshow

set "data" to "yes" or "no"

Definition at line 1410 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::UserAttributeCount

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ UserAttributeCount

int svxPartAttribute::UserAttributeCount

count of UserAttribute

Definition at line 1388 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Manager

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Manager

svxAttribute svxPartAttribute::Manager

manager attribute

Definition at line 1398 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Number

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Number

svxAttribute svxPartAttribute::Number

number attribute

Definition at line 1391 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Version

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Version

int svxPartAttribute::Version

attribute version

Definition at line 1387 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Supplier

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Supplier

svxAttribute svxPartAttribute::Supplier

supplier attribute

Definition at line 1395 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Description

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Description

svxAttribute svxPartAttribute::Description

description attribute

Definition at line 1396 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Startdate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Startdate

svxAttribute svxPartAttribute::Startdate

start date attribute

Definition at line 1400 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::No_hatch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ No_hatch

svxAttribute svxPartAttribute::No_hatch

set "data" to "yes" or "no"

Definition at line 1404 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::No_bom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ No_bom

svxAttribute svxPartAttribute::No_bom

set "data" to "yes" or "no"

Definition at line 1408 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::No_section

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ No_section

svxAttribute svxPartAttribute::No_section

set "data" to "yes" or "no"

Definition at line 1403 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::UserAttribute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ UserAttribute

svxAttribute svxPartAttribute::UserAttribute[64]

user Attribute(Up to 64 user attributes).

Definition at line 1389 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Dimen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Dimen

svxAttribute svxPartAttribute::Dimen[20]

dimension attribute, these attributes had been converted to a configuration table attributes or variables since R2018.
if there is a configuration table in current part, you can use cvxPartInqCfgTblInfos() to get and cvxCfgTblInfosSet() to modify.
or these attributes converted variables, you can use cvxPartVarGet() and cvxPartVarSet().

Definition at line 1405 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Designer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Designer

svxAttribute svxPartAttribute::Designer

designer attribute

Definition at line 1393 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Material

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Material

svxAttribute svxPartAttribute::Material

material attribute

Definition at line 1399 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Name

svxAttribute svxPartAttribute::Name

name attribute

Definition at line 1390 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Partclass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Partclass

svxAttribute svxPartAttribute::Partclass

part class attribute

Definition at line 1392 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Enddate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Enddate

svxAttribute svxPartAttribute::Enddate

end date attribute

Definition at line 1401 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::File_path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ File_path

svxAttribute svxPartAttribute::File_path

file path

Definition at line 1409 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Keyword

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Keyword

svxAttribute svxPartAttribute::Keyword

keyword attribute

Definition at line 1397 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::Derived

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ Derived

svxAttribute svxPartAttribute::Derived

derived attribute

Definition at line 1402 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartAttribute::sheet_code

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartAttribute
Cost
Derived
Description
Designer
Dimen
Enddate
File_path
Keyword
Manager
Material
Name
No_bom
No_hatch
No_rootshow
No_section
Number
Partclass
sheet_code
Startdate
Supplier
UserAttribute
UserAttributeCount
Version

◆ sheet_code

svxAttribute svxPartAttribute::sheet_code

sheet code attribute

Definition at line 1411 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartCalcAttrData Struct Reference
Part Objects » Part Data

part physical attributes data More...

#include <zwapi_part_data.h>

Data Fields

double | Length
length of part More...
double | Width
width of part More...
double | Height
hight of part More...
double | Volume
volume of part More...
double | Area
surface area of part More...
double | Mass
mass of part More...
double | Density
density of part(kg/mm3) More...
svxPoint Centroid
center of gravity of part More...

Detailed Description

part physical attributes data

Definition at line 50 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Centroid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Centroid

svxPoint svxPartCalcAttrData::Centroid

center of gravity of part

Definition at line 59 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Volume

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Volume

double svxPartCalcAttrData::Volume

volume of part

Definition at line 55 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Area

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Area

double svxPartCalcAttrData::Area

surface area of part

Definition at line 56 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Width

double svxPartCalcAttrData::Width

width of part

Definition at line 53 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Mass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Mass

double svxPartCalcAttrData::Mass

mass of part

Definition at line 57 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Height

double svxPartCalcAttrData::Height

hight of part

Definition at line 54 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Density

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Density

double svxPartCalcAttrData::Density

density of part(kg/mm3)

Definition at line 58 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCalcAttrData::Length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCalcAttrData
Area
Centroid
Density
Height
Length
Mass
Volume
Width

◆ Length

double svxPartCalcAttrData::Length

length of part

Definition at line 52 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxPartCfgInfo Struct Reference
Part Objects » Part Data

config table infos More...

#include <zwapi_part_data.h>

Data Structures

struct | svxAligns
constraint of component or assembly infos More...
struct | svxAlignValue
constraint value infos More...
struct | svxAttributes
attribute properties infos More...
struct | svxComponents
component infos More...
struct | svxFtrDimensions
feature dimension infos More...
struct | svxFtrVdataVal
feature's vdata infos More...
struct | svxOutDefVal
variables preceded by "*" are not used to drive the seed part More...
struct | svxProfDimensions
profile dimension infos More...
struct | svxRegenObjs
regen object infos More...
struct | svxThreadDeps
thread depth infos More...
struct | svxThreads
thread infos More...
struct | svxVariables
equation manager infos More...

Data Fields

vxName ConfigName
configuration name More...
int | CfgIdx
configuration id More...
int | ConfigId
the row number of the table(0,1,...) More...
svxColor colorval
color of attributes or config table More...
int | fCfged
1 if colorval exist,else 0 More...
struct svxPartCfgInfo::svxRegenObjs * | RegenObjs
int | CntRO
numbers of "RegenObjs" More...
struct svxPartCfgInfo::svxFtrDimensions * | FtrDim
int | CntFD
numbers of "FtrDim" More...
struct svxPartCfgInfo::svxProfDimensions * | ProfDim
int | CntPD
numbers of "ProfDim" More...
struct svxPartCfgInfo::svxVariables * | var
int | CntVar
numbers of "var" More...
struct svxPartCfgInfo::svxAttributes * | attr
int | CntAttr
numbers of "attr" More...
struct svxPartCfgInfo::svxComponents * | comp
int | CntComp
numbers of "comp" More...
struct svxPartCfgInfo::svxThreads * | threads
int | CntThreads
numbers of "threads" More...
struct svxPartCfgInfo::svxThreadDeps * | ThreadDeps
int | CntTD
numbers of "ThreadDeps" More...
struct svxPartCfgInfo::svxAligns * | align
int | CntAlign
numbers of "align" More...
struct svxPartCfgInfo::svxAlignValue * | AlignValue
int | CntAV
numbers of "AlignValue" More...
struct svxPartCfgInfo::svxFtrVdataVal * | FtrVdataValue
int | CntFVV
numbers of "FtrVdataValue" More...
struct svxPartCfgInfo::svxOutDefVal * | OutDefVal
int | CntODV
numbers of "OutDefVal" More...
int * | RegenObjsFailed
list of regen object failed More...
int | CntROF
numbers of "RegenObjsFailed" More...

Detailed Description

config table infos

Definition at line 180 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
Data Fields
svxPartCfgInfo::svxAlignValue Struct Reference

constraint value infos More...

#include <zwapi_part_data.h>

Data Fields

int | AlignIdx
index of component More...
svxUid uid
feature uid of the dimension More...
int | DataId
the value's data id in the feature More...
vxName ValValue
value of align More...
svxCf unit
unit for value More...

Detailed Description

constraint value infos

<

Definition at line 282 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
AlignIdx
DataId
uid
unit
ValValue

◆ unit

svxCf svxPartCfgInfo::svxAlignValue::unit

unit for value

Definition at line 288 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue::AlignIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
AlignIdx
DataId
uid
unit
ValValue

◆ AlignIdx

int svxPartCfgInfo::svxAlignValue::AlignIdx

index of component

Definition at line 284 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue::DataId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
AlignIdx
DataId
uid
unit
ValValue

◆ DataId

int svxPartCfgInfo::svxAlignValue::DataId

the value's data id in the feature

Definition at line 286 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue::ValValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
AlignIdx
DataId
uid
unit
ValValue

◆ ValValue

vxName svxPartCfgInfo::svxAlignValue::ValValue

value of align

Definition at line 287 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAlignValue::uid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAlignValue
AlignIdx
DataId
uid
unit
ValValue

◆ uid

svxUid svxPartCfgInfo::svxAlignValue::uid

feature uid of the dimension

Definition at line 285 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAligns Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAligns
Data Fields
svxPartCfgInfo::svxAligns Struct Reference

constraint of component or assembly infos More...

#include <zwapi_part_data.h>

Data Fields

int | AlignIdx
index of component More...
int | suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed. More...
vxName expr
expression of align More...

Detailed Description

constraint of component or assembly infos

<

Definition at line 274 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAligns::AlignIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAligns
AlignIdx
expr
suppressed

◆ AlignIdx

int svxPartCfgInfo::svxAligns::AlignIdx

index of component

Definition at line 276 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAligns::suppressed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAligns
AlignIdx
expr
suppressed

◆ suppressed

int svxPartCfgInfo::svxAligns::suppressed

-1 if undefined.0 is unsuppressed, 1 is suppressed.

Definition at line 277 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAligns::expr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAligns
AlignIdx
expr
suppressed

◆ expr

vxName svxPartCfgInfo::svxAligns::expr

expression of align

Definition at line 278 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
Data Fields
svxPartCfgInfo::svxAttributes Struct Reference

attribute properties infos More...

#include <zwapi_part_data.h>

Data Fields

int | AttrIdx
index of Attributes More...
evxAtItemId itemId
The standard id of the part attribute item. More...
char | type
type of Attributes More...
char | SubType
subtype of Attributes More...
double | dvalue
0 if undefined More...
vxLongName expr
the expression of condition suppressed More...
int | fCfged
0 if undefined More...
int | fUserDefined
1 if the value is user defined, else 0, only used for calculated attributes More...
svxCf unit
unit for value More...

Detailed Description

attribute properties infos

<

Definition at line 225 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::AttrIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ AttrIdx

int svxPartCfgInfo::svxAttributes::AttrIdx

index of Attributes

Definition at line 227 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::SubType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ SubType

char svxPartCfgInfo::svxAttributes::SubType

subtype of Attributes

Definition at line 230 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ type

char svxPartCfgInfo::svxAttributes::type

type of Attributes

Definition at line 229 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::fUserDefined

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ fUserDefined

int svxPartCfgInfo::svxAttributes::fUserDefined

1 if the value is user defined, else 0, only used for calculated attributes

Definition at line 234 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::fCfged

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ fCfged

int svxPartCfgInfo::svxAttributes::fCfged

0 if undefined

Definition at line 233 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::dvalue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ dvalue

double svxPartCfgInfo::svxAttributes::dvalue

0 if undefined

Definition at line 231 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::expr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ expr

vxLongName svxPartCfgInfo::svxAttributes::expr

the expression of condition suppressed

Definition at line 232 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::itemId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ itemId

evxAtItemId svxPartCfgInfo::svxAttributes::itemId

The standard id of the part attribute item.

Definition at line 228 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxAttributes::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxAttributes
AttrIdx
dvalue
expr
fCfged
fUserDefined
itemId
SubType
type
unit

◆ unit

svxCf svxPartCfgInfo::svxAttributes::unit

unit for value

Definition at line 235 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
Data Fields
svxPartCfgInfo::svxComponents Struct Reference

component infos More...

#include <zwapi_part_data.h>

Data Fields

int | CompIdx
index of component More...
int | suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed. More...
vxName expr
the expression of condition suppressed More...
int | PartStateId
-1 if undefined More...
vxName CfgName
the CfgName, alway is empty More...
svxColor color
color of components More...
int | fCfged
1 if color exist,else 0 More...

Detailed Description

component infos

<

Definition at line 239 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::CompIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ CompIdx

int svxPartCfgInfo::svxComponents::CompIdx

index of component

Definition at line 241 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::fCfged

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ fCfged

int svxPartCfgInfo::svxComponents::fCfged

1 if color exist,else 0

Definition at line 247 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::CfgName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ CfgName

vxName svxPartCfgInfo::svxComponents::CfgName

the CfgName, alway is empty

Definition at line 245 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ color

svxColor svxPartCfgInfo::svxComponents::color

color of components

Definition at line 246 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::suppressed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ suppressed

int svxPartCfgInfo::svxComponents::suppressed

-1 if undefined.0 is unsuppressed, 1 is suppressed.

Definition at line 242 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::expr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ expr

vxName svxPartCfgInfo::svxComponents::expr

the expression of condition suppressed

Definition at line 243 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxComponents::PartStateId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxComponents
CfgName
color
CompIdx
expr
fCfged
PartStateId
suppressed

◆ PartStateId

int svxPartCfgInfo::svxComponents::PartStateId

-1 if undefined

Definition at line 244 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
Data Fields
svxPartCfgInfo::svxFtrDimensions Struct Reference

feature dimension infos More...

#include <zwapi_part_data.h>

Data Fields

svxUid uid
feature uid of the dimension More...
int | DataId
dimension's data id in the feature More...
int | DimIdx
index of dimension More...
int | fAssm
1,the dimension should be in assembly tree More...
vxName value
value of the dimension More...
svxCf unit
unit for value More...
int | ftr
auxiliary data More...

Detailed Description

feature dimension infos

<

Definition at line 196 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::DimIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ DimIdx

int svxPartCfgInfo::svxFtrDimensions::DimIdx

index of dimension

Definition at line 200 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::fAssm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ fAssm

int svxPartCfgInfo::svxFtrDimensions::fAssm

1,the dimension should be in assembly tree

Definition at line 201 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ unit

svxCf svxPartCfgInfo::svxFtrDimensions::unit

unit for value

Definition at line 203 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::ftr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ ftr

int svxPartCfgInfo::svxFtrDimensions::ftr

auxiliary data

Definition at line 204 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::DataId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ DataId

int svxPartCfgInfo::svxFtrDimensions::DataId

dimension's data id in the feature

Definition at line 199 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ value

vxName svxPartCfgInfo::svxFtrDimensions::value

value of the dimension

Definition at line 202 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrDimensions::uid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrDimensions
DataId
DimIdx
fAssm
ftr
uid
unit
value

◆ uid

svxUid svxPartCfgInfo::svxFtrDimensions::uid

feature uid of the dimension

Definition at line 198 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
Data Fields
svxPartCfgInfo::svxFtrVdataVal Struct Reference

feature's vdata infos More...

#include <zwapi_part_data.h>

Data Fields

svxUid uid
feature uid of the vdata More...
int | DataId
data id in the feature More...
int | idx_ftr
index of feature More...
int | fAssm
1, the feature is a assembly feature More...
vxName value
value of feature More...
int | ftr
auxiliary data More...
svxCf unit
unit for value More...

Detailed Description

feature's vdata infos

<

Definition at line 292 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::fAssm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ fAssm

int svxPartCfgInfo::svxFtrVdataVal::fAssm

1, the feature is a assembly feature

Definition at line 297 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ value

vxName svxPartCfgInfo::svxFtrVdataVal::value

value of feature

Definition at line 298 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::idx_ftr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ idx_ftr

int svxPartCfgInfo::svxFtrVdataVal::idx_ftr

index of feature

Definition at line 296 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::DataId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ DataId

int svxPartCfgInfo::svxFtrVdataVal::DataId

data id in the feature

Definition at line 295 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::uid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ uid

svxUid svxPartCfgInfo::svxFtrVdataVal::uid

feature uid of the vdata

Definition at line 294 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::ftr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ ftr

int svxPartCfgInfo::svxFtrVdataVal::ftr

auxiliary data

Definition at line 299 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxFtrVdataVal::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxFtrVdataVal
DataId
fAssm
ftr
idx_ftr
uid
unit
value

◆ unit

svxCf svxPartCfgInfo::svxFtrVdataVal::unit

unit for value

Definition at line 300 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxOutDefVal Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxOutDefVal
Data Fields
svxPartCfgInfo::svxOutDefVal Struct Reference

variables preceded by "*" are not used to drive the seed part More...

#include <zwapi_part_data.h>

Data Fields

vxName key
key of outside defined value More...
vxName value
value of outside defined value More...

Detailed Description

variables preceded by "*" are not used to drive the seed part

<

Definition at line 305 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxOutDefVal::key

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxOutDefVal
key
value

◆ key

vxName svxPartCfgInfo::svxOutDefVal::key

key of outside defined value

Definition at line 307 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxOutDefVal::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxOutDefVal
key
value

◆ value

vxName svxPartCfgInfo::svxOutDefVal::value

value of outside defined value

Definition at line 308 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxProfDimensions Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxProfDimensions
Data Fields
svxPartCfgInfo::svxProfDimensions Struct Reference

profile dimension infos More...

#include <zwapi_part_data.h>

Data Fields

int DimIdx
index of dimension More...
vxName value
value of dimension More...
svxCf unit
unit for value More...

Detailed Description

profile dimension infos

<

Definition at line 208 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxProfDimensions::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxProfDimensions
DimIdx
unit
value

◆ value

vxName svxPartCfgInfo::svxProfDimensions::value

value of dimension

Definition at line 211 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxProfDimensions::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxProfDimensions
DimIdx
unit
value

◆ unit

svxCf svxPartCfgInfo::svxProfDimensions::unit

unit for value

Definition at line 212 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxProfDimensions::DimIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxProfDimensions
DimIdx
unit
value

◆ DimIdx

int svxPartCfgInfo::svxProfDimensions::DimIdx

index of dimension

Definition at line 210 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxRegenObjs Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxRegenObjs
Data Fields
svxPartCfgInfo::svxRegenObjs Struct Reference

regen object infos More...

#include <zwapi_part_data.h>

Data Fields

int | idx
index of regenerate object More...
int | suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed. More...
vxName expr
the expression of condition suppressed More...

Detailed Description

regen object infos

<

Definition at line 188 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxRegenObjs::expr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxRegenObjs
expr
idx
suppressed

◆ expr

vxName svxPartCfgInfo::svxRegenObjs::expr

the expression of condition suppressed

Definition at line 192 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxRegenObjs::idx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxRegenObjs
expr
idx
suppressed

◆ idx

int svxPartCfgInfo::svxRegenObjs::idx

index of regenerate object

Definition at line 190 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxRegenObjs::suppressed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxRegenObjs
expr
idx
suppressed

◆ suppressed

int svxPartCfgInfo::svxRegenObjs::suppressed

-1 if undefined.0 is unsuppressed, 1 is suppressed.

Definition at line 191 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
Data Fields
svxPartCfgInfo::svxThreadDeps Struct Reference

thread depth infos More...

#include <zwapi_part_data.h>

Data Fields

svxUid uid
feature uid of the dimension More...
int | FtrIdx
index of feature More...
evxCfgThreadCmd fCmd
1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD More...
int | deptype
depth type of thread More...
vxName depth
depth of thread More...

Detailed Description

thread depth infos

<

Definition at line 264 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps::fCmd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
depth
deptype
fCmd
FtrIdx
uid

◆ fCmd

evxCfgThreadCmd svxPartCfgInfo::svxThreadDeps::fCmd

1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD

Definition at line 268 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps::FtrIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
depth
deptype
fCmd
FtrIdx
uid

◆ FtrIdx

int svxPartCfgInfo::svxThreadDeps::FtrIdx

index of feature

Definition at line 267 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps::deptype

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
depth
deptype
fCmd
FtrIdx
uid

◆ deptype

int svxPartCfgInfo::svxThreadDeps::deptype

depth type of thread

Definition at line 269 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps::depth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
depth
deptype
fCmd
FtrIdx
uid

◆ depth

vxName svxPartCfgInfo::svxThreadDeps::depth

depth of thread

Definition at line 270 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreadDeps::uid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreadDeps
depth
deptype
fCmd
FtrIdx
uid

◆ uid

svxUid svxPartCfgInfo::svxThreadDeps::uid

feature uid of the dimension

Definition at line 266 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
Data Fields
svxPartCfgInfo::svxThreads Struct Reference

thread infos More...

#include <zwapi_part_data.h>

Data Fields

svxUid uid
feature uid of the dimension More...
int FtrIdx
index of feature More...
evxCfgThreadCmd fCmd
1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD More...
vxName threadType
thread Type More...
vxName threadsize
thread size More...
vxName threadDia
thread Diameter More...
vxName pitch
pitch More...
vxName threadUnit
Thread Unit. More...

Detailed Description

thread infos

<

Definition at line 251 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::threadType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ threadType

vxName svxPartCfgInfo::svxThreads::threadType

thread Type

Definition at line 256 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ pitch

vxName svxPartCfgInfo::svxThreads::pitch

pitch

Definition at line 259 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::FtrIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ FtrIdx

int svxPartCfgInfo::svxThreads::FtrIdx

index of feature

Definition at line 254 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::fCmd

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ fCmd

evxCfgThreadCmd svxPartCfgInfo::svxThreads::fCmd

1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD

Definition at line 255 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::uid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ uid

svxUid svxPartCfgInfo::svxThreads::uid

feature uid of the dimension

Definition at line 253 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::threadUnit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ threadUnit

vxName svxPartCfgInfo::svxThreads::threadUnit

Thread Unit.

Definition at line 260 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::threadsize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ threadsize

vxName svxPartCfgInfo::svxThreads::threadsize

thread size

Definition at line 257 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxThreads::threadDia

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxThreads
fCmd
FtrIdx
pitch
threadDia
threadsize
threadType
threadUnit
uid

◆ threadDia

vxName svxPartCfgInfo::svxThreads::threadDia

thread Diameter

Definition at line 258 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxVariables Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxVariables
Data Fields
svxPartCfgInfo::svxVariables Struct Reference

equation manager infos More...

#include <zwapi_part_data.h>

Data Fields

int | EqIdx
index of Variables More...
char | type
type of Variables More...
vxName value
value of Variables More...
svxCf unit
unit for value More...

Detailed Description

equation manager infos

<

Definition at line 216 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxVariables::EqIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxVariables
EqIdx
type
unit
value

◆ EqIdx

int svxPartCfgInfo::svxVariables::EqIdx

index of Variables

Definition at line 218 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxVariables::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxVariables
EqIdx
type
unit
value

◆ type

char svxPartCfgInfo::svxVariables::type

type of Variables

Definition at line 219 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxVariables::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxVariables
EqIdx
type
unit
value

◆ value

vxName svxPartCfgInfo::svxVariables::value

value of Variables

Definition at line 220 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::svxVariables::unit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
  • svxVariables
EqIdx
type
unit
value

◆ unit

svxCf svxPartCfgInfo::svxVariables::unit

unit for value

Definition at line 221 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::colorval

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ colorval

svxColor svxPartCfgInfo::colorval

color of attributes or config table

Definition at line 185 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntFVV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntFVV

int svxPartCfgInfo::CntFVV

numbers of "FtrVdataValue"

Definition at line 302 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::ConfigName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ ConfigName

vxName svxPartCfgInfo::ConfigName

configuration name

Definition at line 182 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntAV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntAV

int svxPartCfgInfo::CntAV

numbers of "AlignValue"

Definition at line 290 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntPD

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntPD

int svxPartCfgInfo::CntPD

numbers of "ProfDim"

Definition at line 214 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntAttr

int svxPartCfgInfo::CntAttr

numbers of "attr"

Definition at line 237 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntRO

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntRO

int svxPartCfgInfo::CntRO

numbers of "RegenObjs"

Definition at line 194 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntVar

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntVar

int svxPartCfgInfo::CntVar

numbers of "var"

Definition at line 223 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::fCfged

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ fCfged

int svxPartCfgInfo::fCfged

1 if colorval exist,else 0

Definition at line 186 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntFD

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntFD

int svxPartCfgInfo::CntFD

numbers of "FtrDim"

Definition at line 206 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntThreads

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntThreads

int svxPartCfgInfo::CntThreads

numbers of "threads"

Definition at line 262 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntComp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntComp

int svxPartCfgInfo::CntComp

numbers of "comp"

Definition at line 249 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::ConfigId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ ConfigId

int svxPartCfgInfo::ConfigId

the row number of the table(0,1,...)

Definition at line 184 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntROF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntROF

int svxPartCfgInfo::CntROF

numbers of "RegenObjsFailed"

Definition at line 313 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntAlign

int svxPartCfgInfo::CntAlign

numbers of "align"

Definition at line 280 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntODV

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntODV

int svxPartCfgInfo::CntODV

numbers of "OutDefVal"

Definition at line 310 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::RegenObjsFailed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ RegenObjsFailed

int* svxPartCfgInfo::RegenObjsFailed

list of regen object failed

Definition at line 312 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CfgIdx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CfgIdx

int svxPartCfgInfo::CfgIdx

configuration id

Definition at line 183 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartCfgInfo::CntTD

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartCfgInfo
CfgIdx
CntAlign
CntAttr
CntAV
CntComp
CntFD
CntFVV
CntODV
CntPD
CntRO
CntROF
CntTD
CntThreads
CntVar
colorval
ConfigId
ConfigName
fCfged
RegenObjsFailed

◆ CntTD

int svxPartCfgInfo::CntTD

numbers of "ThreadDeps"

Definition at line 272 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPartDimAttr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartDimAttr Struct Reference
Common » Global Apply

part dimension attribute More...

#include <zwapi_global_apply.h>

Data Fields

evxColor color
color of dimension More...
int decimal
number of decimal places of dimension (0 ~ 5) More...

Detailed Description

part dimension attribute

Definition at line 30 of file zwapi_global_apply.h.

The documentation for this struct was generated from the following file:
  • zwapi_global_apply.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartDimAttr::decimal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartDimAttr
color
decimal

◆ decimal

int svxPartDimAttr::decimal

number of decimal places of dimension (0 ~ 5)

Definition at line 33 of file zwapi_global_apply.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartDimAttr::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartDimAttr
color
decimal

◆ color

evxColor svxPartDimAttr::color

color of dimension

Definition at line 32 of file zwapi_global_apply.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartInstData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

copy external part data More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

vxLongPath Dir
pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames More...
vxLongPath File
name of ZW3D file that contains "Part" More...
vxRootName Part
name of part that to be copied More...
svxMatrix Frame
insertion frame for sub-part,the insert point is the original point of frame More...
int | CopyWire
1 to copy wireframe, or 0 More...
int | CopyDim
1 to copy dimension, or 0 More...
int | Option
0 - sub-part with associative copy. 1 - sub-part with history.
2 - history copied into this part.
3 - associative copy in this part. More...

Detailed Description

copy external part data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 106 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::Dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ Dir

vxLongPath svxPartInstData::Dir

pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 108 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::Option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ Option

int svxPartInstData::Option

0 - sub-part with associative copy. 1 - sub-part with history.
2 - history copied into this part.
3 - associative copy in this part.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 118 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ File

vxLongPath svxPartInstData::File

name of ZW3D file that contains "Part"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 111 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::CopyWire

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ CopyWire

int svxPartInstData::CopyWire

1 to copy wireframe, or 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 116 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::Part

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ Part

vxRootName svxPartInstData::Part

name of part that to be copied

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 112 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::Frame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ Frame

svxMatrix svxPartInstData::Frame

insertion frame for sub-part,the insert point is the original point of frame

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 113 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartInstData::CopyDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartInstData
CopyDim
CopyWire
Dir
File
Frame
Option
Part

◆ CopyDim

int svxPartInstData::CopyDim

1 to copy dimension, or 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 117 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartMaterial Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartMaterial Struct Reference
Part Objects » Part Data

Part material physical attributes. More...

#include <zwapi_part_data.h>

Data Fields

double density
material density(kg/m3) More...

Detailed Description

Part material physical attributes.

Definition at line 66 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartMaterial::density

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartMaterial
density

◆ density

double svxPartMaterial::density

material density(kg/m3)

Definition at line 69 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartSelfX Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPartSelfX Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

part resolveSelfX data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numEnt
number of shape entities to resolve self intersection More...
int * | idEnts
list of shape entities to resolve self intersection More...
int | region
whether to remove inverted regions (0 = no, 1 = yes).Default:1. More...

Detailed Description

part resolveSelfX data

Definition at line 1156 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartSelfX::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartSelfX
idEnts
numEnt
region

◆ numEnt

int svxPartSelfX::numEnt

number of shape entities to resolve self intersection

Definition at line 1158 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartSelfX::region

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartSelfX
idEnts
numEnt
region

◆ region

int svxPartSelfX::region

whether to remove inverted regions (0 = no, 1 = yes).Default:1.

Definition at line 1160 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPartSelfX::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPartSelfX
idEnts
numEnt
region

◆ idEnts

int* svxPartSelfX::idEnts

list of shape entities to resolve self intersection

Definition at line 1159 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPathConsData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly path constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

evxPathConsType pathConsType
path constraint type (VX_PATH_CONS_FREE-default) More...
double | distance
distance from the end of the path (0.0-default) More...
double | percent
distance percent from the end of the path (0.0-default) More...
int | flipDim
whether to flip dimension (0-default) More...
evxPitchYawType pitchYawType
pitch/yaw type (VX_PITCH_YAW_FREE-default) More...
evxAxisType axisToTangent
specify axis tangent to path (VX_AXIS_X-default) More...
int | flipTangentDir
whether to flip the tangential direction (0-default) More...
evxRollCtrlType rollCtrlType
roll control type (VX_ROLL_CTRL_FREE-default) More...
svxEntPath upVector
entity to specify up vector (edge, curve, face, datum plane, point) More...
evxAxisType axisToAlign
specify axis to align to the up vector (VX_AXIS_X-default) More...
int | flipAlignDir
whether to flip the alignment direction (0-default) More...

Detailed Description

custom data for assembly path constraint

Examples
part\asmConsTest.cpp.

Definition at line 278 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::axisToTangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ axisToTangent

evxAxisType svxPathConsData::axisToTangent

specify axis tangent to path (VX_AXIS_X-default)

Examples
part\asmConsTest.cpp.

Definition at line 286 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::flipTangentDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ flipTangentDir

int svxPathConsData::flipTangentDir

whether to flip the tangential direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 287 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::axisToAlign

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ axisToAlign

evxAxisType svxPathConsData::axisToAlign

specify axis to align to the up vector (VX_AXIS_X-default)

Examples
part\asmConsTest.cpp.

Definition at line 291 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ distance

double svxPathConsData::distance

distance from the end of the path (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 281 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::upVector

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ upVector

svxEntPath svxPathConsData::upVector

entity to specify up vector (edge, curve, face, datum plane, point)

Examples
part\asmConsTest.cpp.

Definition at line 290 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::pathConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ pathConsType

evxPathConsType svxPathConsData::pathConsType

path constraint type (VX_PATH_CONS_FREE-default)

Examples
part\asmConsTest.cpp.

Definition at line 280 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::flipAlignDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ flipAlignDir

int svxPathConsData::flipAlignDir

whether to flip the alignment direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 292 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::flipDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ flipDim

int svxPathConsData::flipDim

whether to flip dimension (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 283 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::percent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ percent

double svxPathConsData::percent

distance percent from the end of the path (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 282 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::rollCtrlType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ rollCtrlType

evxRollCtrlType svxPathConsData::rollCtrlType

roll control type (VX_ROLL_CTRL_FREE-default)

Examples
part\asmConsTest.cpp.

Definition at line 289 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPathConsData::pitchYawType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPathConsData
axisToAlign
axisToTangent
distance
flipAlignDir
flipDim
flipTangentDir
pathConsType
percent
pitchYawType
rollCtrlType
upVector

◆ pitchYawType

evxPitchYawType svxPathConsData::pitchYawType

pitch/yaw type (VX_PITCH_YAW_FREE-default)

Examples
part\asmConsTest.cpp.

Definition at line 285 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPdfData Struct Reference
File » File Data

data of export pdf file More...

#include <zwapi_file_data.h>

Data Fields

evxPdfType Type
export pdf type More...
int | Color
all black color or not, 1- MONOCHROME, 2-GRAYSCALE, 3-COLORIZED More...
int | Font
embed font or not, can be ignored More...
int | Dpi
DPI of pdf. More...
int | TextOutStyle
text output 1:text, 0:polygon lines More...
float | LineWidthScale
line width scale factor(0.01~10) More...
float | PaperWidth
width of page More...
float | PaperHeight
height of the page More...
evxPdfRangeMode RangeMode
export mode, VX_EXPORT_PDF_RANGE_MODE_NORMAL-Rect can be ignored More...
svxBndBox Rect
export extent More...
char | Author [128]
author of pdf More...
char | Title [128]
title of pdf More...
char | Subject [128]
subject of pdf More...
char | Password [128]
password of pdf More...
char | Description [8192]
description of pdf More...
int | ExportMultiSheet
export multiple sheets to one pdf file, 1- active sheet, 2-one pdf for each, 3-one pdf for all (default: 1) More...

Detailed Description

data of export pdf file

Definition at line 153 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::LineWidthScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ LineWidthScale

float svxPdfData::LineWidthScale

line width scale factor(0.01~10)

Definition at line 160 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::ExportMultiSheet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ ExportMultiSheet

int svxPdfData::ExportMultiSheet

export multiple sheets to one pdf file, 1- active sheet, 2-one pdf for each, 3-one pdf for all (default: 1)

Definition at line 170 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Subject

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Subject

char svxPdfData::Subject[128]

subject of pdf

Definition at line 167 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Author

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Author

char svxPdfData::Author[128]

author of pdf

Definition at line 165 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Password

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Password

char svxPdfData::Password[128]

password of pdf

Definition at line 168 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Font

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Font

int svxPdfData::Font

embed font or not, can be ignored

Definition at line 157 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Dpi

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Dpi

int svxPdfData::Dpi

DPI of pdf.

Definition at line 158 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::PaperHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ PaperHeight

float svxPdfData::PaperHeight

height of the page

Definition at line 162 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Color

int svxPdfData::Color

all black color or not, 1- MONOCHROME, 2-GRAYSCALE, 3-COLORIZED

Definition at line 156 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::TextOutStyle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ TextOutStyle

int svxPdfData::TextOutStyle

text output 1:text, 0:polygon lines

Definition at line 159 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Rect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Rect

svxBndBox svxPdfData::Rect

export extent

Definition at line 164 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::PaperWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ PaperWidth

float svxPdfData::PaperWidth

width of page

Definition at line 161 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Type

evxPdfType svxPdfData::Type

export pdf type

Definition at line 155 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Description

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Description

char svxPdfData::Description[8192]

description of pdf

Definition at line 169 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::RangeMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ RangeMode

evxPdfRangeMode svxPdfData::RangeMode

export mode, VX_EXPORT_PDF_RANGE_MODE_NORMAL-Rect can be ignored

Definition at line 163 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPdfData::Title

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPdfData
Author
Color
Description
Dpi
ExportMultiSheet
Font
LineWidthScale
PaperHeight
PaperWidth
Password
RangeMode
Rect
Subject
TextOutStyle
Title
Type

◆ Title

char svxPdfData::Title[128]

title of pdf

Definition at line 166 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPerimeterDimData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of perimeter dimension More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | cnt
count of listCrvId More...
int * | listCrvId
list of curve id More...
svxPoint textPnt
text point More...
int | variant
0 is auto,the system will atutomatically modify the selected curves' length according to the perimeter. 1 is manual,the perimeter is defined by moved curve field.user can modify the length of the selected curve to define the perimeter. More...
int | variantCrvId
variant curve id.apply it if variant = 1. More...

Detailed Description

data of perimeter dimension

Definition at line 602 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPerimeterDimData
cnt
listCrvId
textPnt
variant
variantCrvId

◆ cnt

int svxPerimeterDimData::cnt

count of listCrvId

Definition at line 604 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData::variant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPerimeterDimData
cnt
listCrvId
textPnt
variant
variantCrvId

◆ variant

int svxPerimeterDimData::variant

0 is auto,the system will atutomatically modify the selected curves' length according to the perimeter. 1 is manual,the perimeter is defined by moved curve field.user can modify the length of the selected curve to define the perimeter.

Definition at line 607 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData::variantCrvId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPerimeterDimData
cnt
listCrvId
textPnt
variant
variantCrvId

◆ variantCrvId

int svxPerimeterDimData::variantCrvId

variant curve id.apply it if variant = 1.

Definition at line 610 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData::listCrvId

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPerimeterDimData
cnt
listCrvId
textPnt
variant
variantCrvId

◆ listCrvId

int* svxPerimeterDimData::listCrvId

list of curve id

Definition at line 605 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPerimeterDimData::textPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPerimeterDimData
cnt
listCrvId
textPnt
variant
variantCrvId

◆ textPnt

svxPoint svxPerimeterDimData::textPnt

text point

Definition at line 606 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlane Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPlane Struct Reference
Common » Common Data

data of plane More...

#include <zwapi_util.h>

Data Fields

double | xlen
extents of the XY plane More...
double | ylen
extents in the XY plane More...
svxMatrix form
plane centered about xform More...

Detailed Description

data of plane

Definition at line 1769 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlane::ylen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlane
form
xlen
ylen

◆ ylen

double svxPlane::ylen

extents in the XY plane

Definition at line 1772 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlane::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlane
form
xlen
ylen

◆ form

svxMatrix svxPlane::form

plane centered about xform

Definition at line 1773 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlane::xlen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlane
form
xlen
ylen

◆ xlen

double svxPlane::xlen

extents of the XY plane

Definition at line 1771 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxPlaneData Struct Reference
Commands Creation » Part and Assembly Commands » Datum Commands Data

template command Plane input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

union evxPlnInpUnion
union of plane data More...

Data Fields

evxPlaneMethods method
methods More...
union svxPlaneData::evxPlnInpUnion | inpUnion
evxPlaneAlign AlignType
plane orientation align type More...
double | dOffset
offset value More...
int | idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin More...
int | idXPnt
id of the XPoint parent entity More...
svxPoint XPnt
XPoint. More...
double | XAng
angle value X direction More...
double | YAng
angle value Y direction More...
double | ZAng
angle value Z direction More...

Detailed Description

template command Plane input data

Examples
part\datumCrtTest.cpp.

Definition at line 120 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlaneXYZ Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlaneXYZ
Data Fields
svxPlaneData::evxPlnInpUnion::PlaneXYZ Struct Reference

use XY Plane/ XZ Plane/ YZ Plan More...

#include <zwapi_cmd_datum_data.h>

Data Fields

double Offset
offset More...

Detailed Description

use XY Plane/ XZ Plane/ YZ Plan

<

Definition at line 139 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlaneXYZ::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlaneXYZ
Offset

◆ Offset

double svxPlaneData::evxPlnInpUnion::PlaneXYZ::Offset

offset

Definition at line 141 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
Data Fields
svxPlaneData::evxPlnInpUnion::PlnDynamic Struct Reference

Dynamic. More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int idPosPnt
id of the position parent entity More...
svxPoint PosPnt
position More...
svxVector XAxis
X Axis. More...
svxVector YAxis
Y Axis. More...
svxVector ZAxis
Z Axis. More...

Detailed Description

Dynamic.

<

Definition at line 154 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic::idPosPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
idPosPnt
PosPnt
XAxis
YAxis
ZAxis

◆ idPosPnt

int svxPlaneData::evxPlnInpUnion::PlnDynamic::idPosPnt

id of the position parent entity

Definition at line 156 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic::PosPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
idPosPnt
PosPnt
XAxis
YAxis
ZAxis

◆ PosPnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnDynamic::PosPnt

position

Definition at line 157 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic::YAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
idPosPnt
PosPnt
XAxis
YAxis
ZAxis

◆ YAxis

svxVector svxPlaneData::evxPlnInpUnion::PlnDynamic::YAxis

Y Axis.

Definition at line 159 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic::ZAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
idPosPnt
PosPnt
XAxis
YAxis
ZAxis

◆ ZAxis

svxVector svxPlaneData::evxPlnInpUnion::PlnDynamic::ZAxis

Z Axis.

Definition at line 160 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnDynamic::XAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnDynamic
idPosPnt
PosPnt
XAxis
YAxis
ZAxis

◆ XAxis

svxVector svxPlaneData::evxPlnInpUnion::PlnDynamic::XAxis

X Axis.

Definition at line 158 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnGeomPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnGeomPnt
Data Fields
svxPlaneData::evxPlnInpUnion::PlnGeomPnt Struct Reference

geometry More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint Pnt
picked Point More...
svxEntPath Path
entity/object pick path More...

Detailed Description

geometry

<

Definition at line 125 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnGeomPnt
Path
Pnt

◆ Path

svxEntPath svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Path

entity/object pick path

Definition at line 128 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnGeomPnt
Path
Pnt

◆ Pnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Pnt

picked Point

Definition at line 127 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
Data Fields
svxPlaneData::evxPlnInpUnion::PlnThreePnts Struct Reference

three point More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int | idOrgPnt
id of the origin parent entity More...
svxPoint OrgPnt
origin More...
int | idXPnt
id of the XPoint parent entity More...
svxPoint XPnt
XPoint. More...
int | idYPnt
id of the YPoint parent entity More...
svxPoint YPnt
YPoint. More...

Detailed Description

three point

<

Definition at line 130 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::idXPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ idXPnt

int svxPlaneData::evxPlnInpUnion::PlnThreePnts::idXPnt

id of the XPoint parent entity

Definition at line 134 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ idOrgPnt

int svxPlaneData::evxPlnInpUnion::PlnThreePnts::idOrgPnt

id of the origin parent entity

Definition at line 132 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::YPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ YPnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnThreePnts::YPnt

YPoint.

Definition at line 137 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::idYPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ idYPnt

int svxPlaneData::evxPlnInpUnion::PlnThreePnts::idYPnt

id of the YPoint parent entity

Definition at line 136 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ OrgPnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnThreePnts::OrgPnt

origin

Definition at line 133 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnThreePnts::XPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnThreePnts
idOrgPnt
idXPnt
idYPnt
OrgPnt
XPnt
YPnt

◆ XPnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnThreePnts::XPnt

XPoint.

Definition at line 135 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnTwoEnts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnTwoEnts
Data Fields
svxPlaneData::evxPlnInpUnion::PlnTwoEnts Struct Reference

Two Entities. More...

#include <zwapi_cmd_datum_data.h>

Data Fields

int | idEnt1
id of the Entity1 parent entity More...
svxPoint Ent1Pnt
entity 1 point More...
int | idEnt2
id of the Entity2 parent entity More...
svxPoint Ent2Pnt
entity 2 point More...

Detailed Description

Two Entities.

<

Definition at line 147 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnTwoEnts
Ent1Pnt
Ent2Pnt
idEnt1
idEnt2

◆ idEnt2

int svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt2

id of the Entity2 parent entity

Definition at line 151 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent2Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnTwoEnts
Ent1Pnt
Ent2Pnt
idEnt1
idEnt2

◆ Ent2Pnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent2Pnt

entity 2 point

Definition at line 152 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnTwoEnts
Ent1Pnt
Ent2Pnt
idEnt1
idEnt2

◆ idEnt1

int svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt1

id of the Entity1 parent entity

Definition at line 149 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent1Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • PlnTwoEnts
Ent1Pnt
Ent2Pnt
idEnt1
idEnt2

◆ Ent1Pnt

svxPoint svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent1Pnt

entity 1 point

Definition at line 150 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::viewPlane Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • viewPlane
Data Fields
svxPlaneData::evxPlnInpUnion::viewPlane Struct Reference

view plane More...

#include <zwapi_cmd_datum_data.h>

Data Fields

svxPoint OrgPnt
origin More...

Detailed Description

view plane

<

Definition at line 143 of file zwapi_cmd_datum_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion::viewPlane::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
  • viewPlane
OrgPnt

◆ OrgPnt

svxPoint svxPlaneData::evxPlnInpUnion::viewPlane::OrgPnt

origin

Definition at line 145 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::idOrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ idOrgPnt

int svxPlaneData::idOrgPnt

id of the origin parent entity

Definition at line 168 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ dOffset

double svxPlaneData::dOffset

offset value

Definition at line 167 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::AlignType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ AlignType

evxPlaneAlign svxPlaneData::AlignType

plane orientation align type

Definition at line 164 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::XAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ XAng

double svxPlaneData::XAng

angle value X direction

Definition at line 172 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::OrgPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ OrgPnt

svxPoint svxPlaneData::OrgPnt

origin

Definition at line 169 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::XPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ XPnt

svxPoint svxPlaneData::XPnt

XPoint.

Definition at line 171 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::YAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ YAng

double svxPlaneData::YAng

angle value Y direction

Definition at line 173 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::ZAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ ZAng

double svxPlaneData::ZAng

angle value Z direction

Definition at line 174 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::idXPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ idXPnt

int svxPlaneData::idXPnt

id of the XPoint parent entity

Definition at line 170 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
AlignType
dOffset
idOrgPnt
idXPnt
method
OrgPnt
XAng
XPnt
YAng
ZAng

◆ method

evxPlaneMethods svxPlaneData::method

methods

Definition at line 122 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntBy2Lines Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPntBy2Lines Struct Reference
Commands Creation » Part and Assembly Commands » Sub Commands Data

the data to get the point by From 2 Lines command More...

#include <zwapi_cmd_subcmd_data.h>

Data Fields

svxPntOnEnt pntOnCrv1
point on first edge/line More...
svxPntOnEnt pntOnCrv2
point on second edge/line More...
double | dDst1
distance from the first edge/line More...
double | dDst2
distance from the second edge/line More...

Detailed Description

the data to get the point by From 2 Lines command

Examples
part\datumCrtTest.cpp.

Definition at line 44 of file zwapi_cmd_subcmd_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_subcmd_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntBy2Lines::dDst1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntBy2Lines
dDst1
dDst2
pntOnCrv1
pntOnCrv2

◆ dDst1

double svxPntBy2Lines::dDst1

distance from the first edge/line

Examples
part\datumCrtTest.cpp.

Definition at line 48 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntBy2Lines::pntOnCrv1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntBy2Lines
dDst1
dDst2
pntOnCrv1
pntOnCrv2

◆ pntOnCrv1

svxPntOnEnt svxPntBy2Lines::pntOnCrv1

point on first edge/line

Examples
part\datumCrtTest.cpp.

Definition at line 46 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntBy2Lines::pntOnCrv2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntBy2Lines
dDst1
dDst2
pntOnCrv1
pntOnCrv2

◆ pntOnCrv2

svxPntOnEnt svxPntBy2Lines::pntOnCrv2

point on second edge/line

Examples
part\datumCrtTest.cpp.

Definition at line 47 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntBy2Lines::dDst2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntBy2Lines
dDst1
dDst2
pntOnCrv1
pntOnCrv2

◆ dDst2

double svxPntBy2Lines::dDst2

distance from the second edge/line

Examples
part\datumCrtTest.cpp.

Definition at line 49 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntByOffset Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPntByOffset Struct Reference
Commands Creation » Part and Assembly Commands » Sub Commands Data

the data to get the point by Offset command More...

#include <zwapi_cmd_subcmd_data.h>

Data Fields

svxPntOnEnt pntOnEnt
point on entity More...
double | xOffset
x offset value More...
double | yOffset
y offset value More...
double | zOffset
z offset value More...

Detailed Description

the data to get the point by Offset command

Examples
part\datumCrtTest.cpp.

Definition at line 32 of file zwapi_cmd_subcmd_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_subcmd_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntByOffset::yOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntByOffset
pntOnEnt
xOffset
yOffset
zOffset

◆ yOffset

double svxPntByOffset::yOffset

y offset value

Examples
part\datumCrtTest.cpp.

Definition at line 36 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntByOffset::zOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntByOffset
pntOnEnt
xOffset
yOffset
zOffset

◆ zOffset

double svxPntByOffset::zOffset

z offset value

Examples
part\datumCrtTest.cpp.

Definition at line 37 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntByOffset::pntOnEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntByOffset
pntOnEnt
xOffset
yOffset
zOffset

◆ pntOnEnt

svxPntOnEnt svxPntByOffset::pntOnEnt

point on entity

Examples
part\datumCrtTest.cpp.

Definition at line 34 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntByOffset::xOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntByOffset
pntOnEnt
xOffset
yOffset
zOffset

◆ xOffset

double svxPntByOffset::xOffset

x offset value

Examples
part\datumCrtTest.cpp.

Definition at line 35 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPntOnEnt Struct Reference
Common » Common Data

point on entity definition, also can use to set a dynamic point More...

#include <zwapi_util.h>

Data Fields

int | idEnt
entity id that the point on (-1/0 to ignore) More...
int | idParent
entity parent id (-1/0 to ignore, profile/view id if idEnt is 2d entity) More...
int | useCritPnt
1- use critTyp, else 0 (idEnt must be valid if useCritPnt is 1) More...
evxGeomCritPnt critTyp
type of critical point More...
int | idControlPnt
id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING_POINT More...
svxPoint pnt
input point(useCritPnt = 1 to ignore) More...
svxVector dir
direction of the input point More...
int | useDir
1-use as a direction, else 0 More...
int | flipDir
1-flip direction, else 0. enable when the direction control support flip the direction More...

Detailed Description

point on entity definition, also can use to set a dynamic point

Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\baseFtrCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 549 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::idEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ idEnt

int svxPntOnEnt::idEnt

entity id that the point on (-1/0 to ignore)

Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 551 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::idControlPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ idControlPnt

int svxPntOnEnt::idControlPnt

id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING_POINT

Examples
part\partUtils.cpp.

Definition at line 555 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::useDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ useDir

int svxPntOnEnt::useDir

1-use as a direction, else 0

Examples
part\partUtils.cpp, and part\shapeFtrCrtTest.cpp.

Definition at line 558 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ idParent

int svxPntOnEnt::idParent

entity parent id (-1/0 to ignore, profile/view id if idEnt is 2d entity)

Definition at line 552 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ pnt

svxPoint svxPntOnEnt::pnt

input point(useCritPnt = 1 to ignore)

Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 556 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ dir

svxVector svxPntOnEnt::dir

direction of the input point

Examples
part\partUtils.cpp.

Definition at line 557 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::flipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ flipDir

int svxPntOnEnt::flipDir

1-flip direction, else 0. enable when the direction control support flip the direction

Examples
part\partUtils.cpp.

Definition at line 559 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::useCritPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ useCritPnt

int svxPntOnEnt::useCritPnt

1- use critTyp, else 0 (idEnt must be valid if useCritPnt is 1)

Examples
drawing\dwgDimTest.cpp, and part\partUtils.cpp.

Definition at line 553 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEnt::critTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEnt
critTyp
dir
flipDir
idControlPnt
idEnt
idParent
pnt
useCritPnt
useDir

◆ critTyp

evxGeomCritPnt svxPntOnEnt::critTyp

type of critical point

Examples
drawing\dwgDimTest.cpp, and part\partUtils.cpp.

Definition at line 554 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEntPath Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPntOnEntPath Struct Reference
Common » Common Data

point on entity path definition, also can use to set a dynamic point More...

#include <zwapi_util.h>

Data Fields

evxGeomCritPnt pntType
point type More...
int idControlPnt
id of the control point of the spline (starting from 0), only used when pntType is VX_SPLINE_DEFINING_POINT More...
svxEntPath entPath
entity path that the point on More...
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT More...

Detailed Description

point on entity path definition, also can use to set a dynamic point

Examples
part\asmConsTest.cpp, part\partUtils.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 566 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEntPath::entPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEntPath
entPath
idControlPnt
pnt
pntType

◆ entPath

svxEntPath svxPntOnEntPath::entPath

entity path that the point on

Examples
part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 570 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEntPath::pntType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEntPath
entPath
idControlPnt
pnt
pntType

◆ pntType

evxGeomCritPnt svxPntOnEntPath::pntType

point type

Examples
part\partUtils.cpp, and sketch\skDrawingTest.cpp.

Definition at line 568 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEntPath::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEntPath
entPath
idControlPnt
pnt
pntType

◆ pnt

svxPoint svxPntOnEntPath::pnt

point coordinates, only used when pntType is VX_FREE_POINT

Examples
part\asmConsTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 571 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPntOnEntPath::idControlPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPntOnEntPath
entPath
idControlPnt
pnt
pntType

◆ idControlPnt

int svxPntOnEntPath::idControlPnt

id of the control point of the spline (starting from 0), only used when pntType is VX_SPLINE_DEFINING_POINT

Examples
part\partUtils.cpp, and sketch\skDrawingTest.cpp.

Definition at line 569 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPoint Struct Reference
Common » Common Data

3D point More...

#include <zwapi_util.h>

Data Fields

double | x
double | y
double | z

Detailed Description

3D point

Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\asmConsTest.cpp, part\baseFtrCrtTest.cpp, part\datumCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\partUtils.cpp, part\pmiCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\skCrtTest.cpp, part\smdFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 305 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2 Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPoint2 Struct Reference
Common » Common Data

2D point More...

#include <zwapi_util.h>

Data Fields

double | x
double | y

Detailed Description

2D point

Examples
drawing\dwgDimTest.cpp, drawing\dwgTableTest.cpp, drawing\dwgViewTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 285 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint2

◆ y

double svxPoint2::y
Examples
sketch\skDrawingTest.cpp.

Definition at line 288 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint2

◆ x

double svxPoint2::x
Examples
drawing\dwgViewTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 287 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2f Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPoint2f Struct Reference
Common » Common Data

2D point(single precision floating point) More...

#include <zwapi_util.h>

Data Fields

float | x
float | y

Detailed Description

2D point(single precision floating point)

Definition at line 295 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2f::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint2f

◆ y

float svxPoint2f::y

Definition at line 298 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint2f::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint2f

◆ x

float svxPoint2f::x

Definition at line 297 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint

◆ y

double svxPoint::y
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 308 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint

◆ z

double svxPoint::z
Examples
part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 309 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPoint::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPoint

◆ x

double svxPoint::x
Examples
drawing\dwgDimTest.cpp, drawing\dwgViewTest.cpp, part\datumCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\wireframeFtrCrtTest.cpp, sketch\basicEditingTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 307 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPointf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPointf Struct Reference
Common » Common Data

3D point (single precision floating point) More...

#include <zwapi_util.h>

Data Fields

float | x
float | y
float | z

Detailed Description

3D point (single precision floating point)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 316 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPointf::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPointf

◆ x

float svxPointf::x

Definition at line 318 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPointf::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPointf

◆ z

float svxPointf::z

Definition at line 320 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPointf::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPointf

◆ y

float svxPointf::y

Definition at line 319 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPolylineData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

3D polyline data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | numPoint
number of points to construct polyline More...
svxPntOnEnt * pPoints
pointer to list of points to construct polyline More...
int | idAligPln
id of Align plane, -1 as default More...
int | projectToPln
1-project to the align plane, else 0 (1 as default) More...
int | pntOnPln
1-points on align plane, else 0 (0 as default) More...

Detailed Description

3D polyline data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 126 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData::projectToPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPolylineData
idAligPln
numPoint
pntOnPln
pPoints
projectToPln

◆ projectToPln

int svxPolylineData::projectToPln

1-project to the align plane, else 0 (1 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 131 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData::pPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPolylineData
idAligPln
numPoint
pntOnPln
pPoints
projectToPln

◆ pPoints

svxPntOnEnt* svxPolylineData::pPoints

pointer to list of points to construct polyline

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 129 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData::pntOnPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPolylineData
idAligPln
numPoint
pntOnPln
pPoints
projectToPln

◆ pntOnPln

int svxPolylineData::pntOnPln

1-points on align plane, else 0 (0 as default)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 132 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData::idAligPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPolylineData
idAligPln
numPoint
pntOnPln
pPoints
projectToPln

◆ idAligPln

int svxPolylineData::idAligPln

id of Align plane, -1 as default

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 130 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPolylineData::numPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPolylineData
idAligPln
numPoint
pntOnPln
pPoints
projectToPln

◆ numPoint

int svxPolylineData::numPoint

number of points to construct polyline

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 128 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPreEdge Struct Reference
Brep » Brep Data

pre-edge information More...

#include <zwapi_brep_data.h>

Data Fields

svxLimit Limits
limits of pre-edge within its parameter space More...
int | idLoop
id of parent loop More...
int | idEdge
id of parent edge More...
int | idNext
id of next pre-edge in loop direction More...
int | idGeom
id of uv curve geometry More...
int | EdgeDir
direction relative to edge (1=same, -1=opposite) More...
int | LoopDir
direction relative to loop (1=same, -1=opposite) More...

Detailed Description

pre-edge information

Definition at line 31 of file zwapi_brep_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::Limits

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ Limits

svxLimit svxPreEdge::Limits

limits of pre-edge within its parameter space

Definition at line 33 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::idGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ idGeom

int svxPreEdge::idGeom

id of uv curve geometry

Definition at line 37 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::idNext

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ idNext

int svxPreEdge::idNext

id of next pre-edge in loop direction

Definition at line 36 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::LoopDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ LoopDir

int svxPreEdge::LoopDir

direction relative to loop (1=same, -1=opposite)

Definition at line 39 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::idLoop

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ idLoop

int svxPreEdge::idLoop

id of parent loop

Definition at line 34 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ idEdge

int svxPreEdge::idEdge

id of parent edge

Definition at line 35 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPreEdge::EdgeDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPreEdge
EdgeDir
idEdge
idGeom
idLoop
idNext
Limits
LoopDir

◆ EdgeDir

int svxPreEdge::EdgeDir

direction relative to edge (1=same, -1=opposite)

Definition at line 38 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPrfAreaProp Struct Reference
Common » Common Data

profile area property More...

#include <zwapi_util.h>

Data Fields

svxPoint2 org
Origin for calculating the properties. More...
svxPoint2 centroid
Centroid. More...
double | area
Area. More...
double | Ix
Inertia about x axis at org. More...
double | Iy
Inertia about y axis at org. More...
double | Ir
Inertia about z axis at org. More...
double | Ixy
Product of Inertia at org. More...
double | Kx
Radius of Gyration about x axis at org. More...
double | Ky
Radius of Gyration about y axis at org. More...
double | Kr
Radius of Gyration about z axis at org. More...
double | Pmin
Principal axis of which inertia is minimum. More...
double | Pmax
Principal axis of which inertia is maximum. More...
double | Imin
Inertia about Pmin. More...
double | Imax
Inertia about Pmax. More...

Detailed Description

profile area property

Definition at line 1210 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Ir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Ir

double svxPrfAreaProp::Ir

Inertia about z axis at org.

Definition at line 1219 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Ky

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Ky

double svxPrfAreaProp::Ky

Radius of Gyration about y axis at org.

Definition at line 1223 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::area

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ area

double svxPrfAreaProp::area

Area.

Definition at line 1215 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Imin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Imin

double svxPrfAreaProp::Imin

Inertia about Pmin.

Definition at line 1228 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Kx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Kx

double svxPrfAreaProp::Kx

Radius of Gyration about x axis at org.

Definition at line 1222 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::centroid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ centroid

svxPoint2 svxPrfAreaProp::centroid

Centroid.

Definition at line 1213 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Iy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Iy

double svxPrfAreaProp::Iy

Inertia about y axis at org.

Definition at line 1218 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Pmax

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Pmax

double svxPrfAreaProp::Pmax

Principal axis of which inertia is maximum.

Definition at line 1227 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Ixy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Ixy

double svxPrfAreaProp::Ixy

Product of Inertia at org.

Definition at line 1220 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Pmin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Pmin

double svxPrfAreaProp::Pmin

Principal axis of which inertia is minimum.

Definition at line 1226 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Kr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Kr

double svxPrfAreaProp::Kr

Radius of Gyration about z axis at org.

Definition at line 1224 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::org

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ org

svxPoint2 svxPrfAreaProp::org

Origin for calculating the properties.

Definition at line 1212 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Ix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Ix

double svxPrfAreaProp::Ix

Inertia about x axis at org.

Definition at line 1217 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrfAreaProp::Imax

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrfAreaProp
area
centroid
Imax
Imin
Ir
Ix
Ixy
Iy
Kr
Kx
Ky
org
Pmax
Pmin

◆ Imax

double svxPrfAreaProp::Imax

Inertia about Pmax.

Definition at line 1229 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrjSetting Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPrjSetting Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Projection or Auxiliary view's projection settings. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxViewPrjAngType prjType
Projection or Auxiliary view's projection angle (VX_VIEW_PRJANG3RD as default) More...
evxViewDimType dimType
Projection or Auxiliary view's dimension type (VX_VIEW_DIMTYPEPRJ as default) More...

Detailed Description

Projection or Auxiliary view's projection settings.

Definition at line 244 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrjSetting::prjType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrjSetting
dimType
prjType

◆ prjType

evxViewPrjAngType svxPrjSetting::prjType

Projection or Auxiliary view's projection angle (VX_VIEW_PRJANG3RD as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 246 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPrjSetting::dimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPrjSetting
dimType
prjType

◆ dimType

evxViewDimType svxPrjSetting::dimType

Projection or Auxiliary view's dimension type (VX_VIEW_DIMTYPEPRJ as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 247 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxPtnData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

pattern data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

union PtnData
union of part pattern data More...

Data Fields

evxBoolType combine
combination method More...
evxPatternType type
pattern method More...
union svxPtnData::PtnData | ptnData
int | useBasePnt
whether to use base point (0 = no, 1 = yes) More...
int | idParent
id of the parent entity of point, set id to 0 when no parent object exists More...
svxPoint basePnt
base point, the value is ignored if useBasePnt = 0 More...
int | relocateBase
whether to relocate base object (0 = no, 1 = yes) 1 - ensure that the array base point is at the desired array location, depending on the specified base point More...
int | deriveType
derive method (0 = by spacing and number, 1 = by number, 2 = by spacing) More...
double | minPer
percentage of the minimum spacing, instances less than this will be deleted More...
vxName ftrName
feature name, 0 default More...
int | cntSkip
number of the instances to be skipped More...
int * | skipList
the instances position id (exp.(0,1)-(id:1),(0,2)-(id:2),(1,0)-(id:10000),(2,5)-(id:20005)
note: the first direction is column, the second direction is row.
since 2700 the first direction is row, the second direction is column.
If you don't know how to set the skip id, you can set the following two parameters and initialize skipList = NULL More...
int * | firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction) More...
int * | secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x More...

Detailed Description

pattern data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1292 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
Data Fields
svxPtnData::PtnData::svxCircular Struct Reference

circular pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxAxis axis
rotation axis for the pattern More...
double | diameter
rotation diameter for the pattern More...
int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0 More...
double | angle
spacing between the instances measured in degrees More...
double | spacing
pattern spacing in second direction, the value is ignored if useSecondDir = 0 More...

Detailed Description

circular pattern

<

Definition at line 1306 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ spacing

double svxPtnData::PtnData::svxCircular::spacing

pattern spacing in second direction, the value is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1313 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ num

int svxPtnData::PtnData::svxCircular::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1311 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxCircular::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1310 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ angle

double svxPtnData::PtnData::svxCircular::angle

spacing between the instances measured in degrees

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1312 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ diameter

double svxPtnData::PtnData::svxCircular::diameter

rotation diameter for the pattern

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1309 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxCircular::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxCircular
angle
axis
diameter
num
spacing
useSecondDir

◆ axis

svxAxis svxPtnData::PtnData::svxCircular::axis

rotation axis for the pattern

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1308 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxLinear Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxLinear
Data Fields
svxPtnData::PtnData::svxLinear Struct Reference

linear pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
svxVector | dir [2]
first and second direction, the second direction is ignored if useSecondDir = 0 More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0 More...
double | spacing [2]
pattern spacing in both direction, the second direction is ignored if useSecondDir = 0 More...

Detailed Description

linear pattern

<

Definition at line 1299 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxLinear::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxLinear
dir
num
spacing
useSecondDir

◆ dir

svxVector svxPtnData::PtnData::svxLinear::dir[2]

first and second direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1302 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxLinear::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxLinear
dir
num
spacing
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxLinear::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1301 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxLinear::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxLinear
dir
num
spacing
useSecondDir

◆ num

int svxPtnData::PtnData::svxLinear::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1303 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxLinear::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxLinear
dir
num
spacing
useSecondDir

◆ spacing

double svxPtnData::PtnData::svxLinear::spacing[2]

pattern spacing in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1304 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPattern Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPattern
Data Fields
svxPtnData::PtnData::svxPattern Struct Reference

pattern based on pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int idPtnFtr
id of pattern feature More...

Detailed Description

pattern based on pattern

<

Definition at line 1334 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPattern::idPtnFtr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPattern
idPtnFtr

◆ idPtnFtr

int svxPtnData::PtnData::svxPattern::idPtnFtr

id of pattern feature

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1336 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
Data Fields
svxPtnData::PtnData::svxPntFill Struct Reference

fill pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | type
type (0 = square, 1 = diamond, 2 = hexagon, 3 = concentric, 4 = spiral, 5 = along sketch curves) More...
int | idSketch
id of sketch More...
double | spacing
pattern spacing More...
double | angle
rotation angle, the value is ignored when type = 5 More...
double | border
border, the value is ignored when type = 5 More...
double | radius
rotation radius, used only when type is 3 or 4 More...

Detailed Description

fill pattern

<

Definition at line 1355 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ angle

double svxPtnData::PtnData::svxPntFill::angle

rotation angle, the value is ignored when type = 5

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1360 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ spacing

double svxPtnData::PtnData::svxPntFill::spacing

pattern spacing

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1359 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ radius

double svxPtnData::PtnData::svxPntFill::radius

rotation radius, used only when type is 3 or 4

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1362 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::border

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ border

double svxPtnData::PtnData::svxPntFill::border

border, the value is ignored when type = 5

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1361 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::idSketch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ idSketch

int svxPtnData::PtnData::svxPntFill::idSketch

id of sketch

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1358 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntFill::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntFill
angle
border
idSketch
radius
spacing
type

◆ type

int svxPtnData::PtnData::svxPntFill::type

type (0 = square, 1 = diamond, 2 = hexagon, 3 = concentric, 4 = spiral, 5 = along sketch curves)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1357 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntToPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntToPnt
Data Fields
svxPtnData::PtnData::svxPntToPnt Struct Reference

point to point pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numPnts
number of point, parent and point value should be set in pairs More...
int * | idParPnt
list of id's of the parent of point, set id to 0 when no parent object exists More...
svxPoint * pnt
list of point coordinates More...

Detailed Description

point to point pattern

<

Definition at line 1328 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntToPnt::numPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntToPnt
idParPnt
numPnts
pnt

◆ numPnts

int svxPtnData::PtnData::svxPntToPnt::numPnts

number of point, parent and point value should be set in pairs

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1330 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntToPnt::idParPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntToPnt
idParPnt
numPnts
pnt

◆ idParPnt

int* svxPtnData::PtnData::svxPntToPnt::idParPnt

list of id's of the parent of point, set id to 0 when no parent object exists

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1331 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntToPnt::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntToPnt
idParPnt
numPnts
pnt

◆ pnt

svxPoint* svxPtnData::PtnData::svxPntToPnt::pnt

list of point coordinates

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1332 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntVar Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntVar
Data Fields
svxPtnData::PtnData::svxPntVar Struct Reference

feature pattern by variant parameters when inpData.type = VX_PATTERN_BY_VAR More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0 More...

Detailed Description

feature pattern by variant parameters when inpData.type = VX_PATTERN_BY_VAR

<

Definition at line 1364 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntVar::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntVar
num
useSecondDir

◆ num

int svxPtnData::PtnData::svxPntVar::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1367 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPntVar::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPntVar
num
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxPntVar::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1366 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
Data Fields
svxPtnData::PtnData::svxPolygon Struct Reference

polygon pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxAxis axis
central axis for the pattern More...
int | numSides
number of sides, it has to be greater than 2 More...
int | spacingType
pattern ways (0 = number per side, 1 = pitch between instances) More...
int | number
number of per side, used only when spacingType = 0 More...
double | pitch
pitch between instances, used only when spacingType = 1 More...
int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
int | numConcentric
number of concentric polygons, the value is ignored if useSecondDir = 0 More...
double | spacing
spacing of between rings radiating outward, the value is ignored if useSecondDir = 0 More...

Detailed Description

polygon pattern

<

Definition at line 1315 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::spacingType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ spacingType

int svxPtnData::PtnData::svxPolygon::spacingType

pattern ways (0 = number per side, 1 = pitch between instances)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1320 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxPolygon::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1324 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ spacing

double svxPtnData::PtnData::svxPolygon::spacing

spacing of between rings radiating outward, the value is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1326 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ pitch

double svxPtnData::PtnData::svxPolygon::pitch

pitch between instances, used only when spacingType = 1

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1322 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::number

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ number

int svxPtnData::PtnData::svxPolygon::number

number of per side, used only when spacingType = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1321 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ axis

svxAxis svxPtnData::PtnData::svxPolygon::axis

central axis for the pattern

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1317 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::numSides

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ numSides

int svxPtnData::PtnData::svxPolygon::numSides

number of sides, it has to be greater than 2

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1318 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPolygon::numConcentric

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPolygon
axis
number
numConcentric
numSides
pitch
spacing
spacingType
useSecondDir

◆ numConcentric

int svxPtnData::PtnData::svxPolygon::numConcentric

number of concentric polygons, the value is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1325 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
Data Fields
svxPtnData::PtnData::svxPtnCrv Struct Reference

curve pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | curveType
curve method (0 = 1 curve, 1 = 2 curves together, 2 = 2 curves across, 3 = 3~4 curves) More...
int | numCrvs
number of curves, can't go beyond 4 curves More...
int * | idCrvs
list of id's of curves More...
int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0 More...
double | spacing [2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0 More...

Detailed Description

curve pattern

<

Definition at line 1338 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::curveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ curveType

int svxPtnData::PtnData::svxPtnCrv::curveType

curve method (0 = 1 curve, 1 = 2 curves together, 2 = 2 curves across, 3 = 3~4 curves)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1340 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ spacing

double svxPtnData::PtnData::svxPtnCrv::spacing[2]

pattern spacing in second direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1346 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::idCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ idCrvs

int* svxPtnData::PtnData::svxPtnCrv::idCrvs

list of id's of curves

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1342 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ num

int svxPtnData::PtnData::svxPtnCrv::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1345 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxPtnCrv::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1344 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnCrv::numCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnCrv
curveType
idCrvs
num
numCrvs
spacing
useSecondDir

◆ numCrvs

int svxPtnData::PtnData::svxPtnCrv::numCrvs

number of curves, can't go beyond 4 curves

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1341 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnFace Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnFace
Data Fields
svxPtnData::PtnData::svxPtnFace Struct Reference

face pattern More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | idFace
id of face More...
int | useSecondDir
whether to use second direction (0 = no, 1 = yes) More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0 More...
double | spacing [2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0 More...

Detailed Description

face pattern

<

Definition at line 1348 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnFace::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnFace
idFace
num
spacing
useSecondDir

◆ spacing

double svxPtnData::PtnData::svxPtnFace::spacing[2]

pattern spacing in second direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1353 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnFace::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnFace
idFace
num
spacing
useSecondDir

◆ useSecondDir

int svxPtnData::PtnData::svxPtnFace::useSecondDir

whether to use second direction (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1351 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnFace::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnFace
idFace
num
spacing
useSecondDir

◆ num

int svxPtnData::PtnData::svxPtnFace::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1352 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData::svxPtnFace::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
  • svxPtnFace
idFace
num
spacing
useSecondDir

◆ idFace

int svxPtnData::PtnData::svxPtnFace::idFace

id of face

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1350 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ idParent

int svxPtnData::idParent

id of the parent entity of point, set id to 0 when no parent object exists

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1372 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::cntSkip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ cntSkip

int svxPtnData::cntSkip

number of the instances to be skipped

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1382 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ combine

evxBoolType svxPtnData::combine

combination method

Definition at line 1294 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::basePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ basePnt

svxPoint svxPtnData::basePnt

base point, the value is ignored if useBasePnt = 0

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1373 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ type

evxPatternType svxPtnData::type

pattern method

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1295 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ ftrName

vxName svxPtnData::ftrName

feature name, 0 default

Definition at line 1380 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::firstTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ firstTogglePos

int* svxPtnData::firstTogglePos

the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1387 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::minPer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ minPer

double svxPtnData::minPer

percentage of the minimum spacing, instances less than this will be deleted

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1379 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::skipList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ skipList

int* svxPtnData::skipList

the instances position id (exp.(0,1)-(id:1),(0,2)-(id:2),(1,0)-(id:10000),(2,5)-(id:20005)
note: the first direction is column, the second direction is row.
since 2700 the first direction is row, the second direction is column.
If you don't know how to set the skip id, you can set the following two parameters and initialize skipList = NULL

Definition at line 1383 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::useBasePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ useBasePnt

int svxPtnData::useBasePnt

whether to use base point (0 = no, 1 = yes)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1371 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::deriveType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ deriveType

int svxPtnData::deriveType

derive method (0 = by spacing and number, 1 = by number, 2 = by spacing)

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1378 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::relocateBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ relocateBase

int svxPtnData::relocateBase

whether to relocate base object (0 = no, 1 = yes) 1 - ensure that the array base point is at the desired array location, depending on the specified base point

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1374 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::secondTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
basePnt
cntSkip
combine
deriveType
firstTogglePos
ftrName
idParent
minPer
relocateBase
secondTogglePos
skipList
type
useBasePnt

◆ secondTogglePos

int* svxPtnData::secondTogglePos

the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction) can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1388 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnFtr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPtnFtr Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

pattern feature data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPtnData * inpData
base input data of pattern feature command More...
int | inc
0-the value to be set, 1- the value to be increased More...
int | cntDim
count dimension to change the value More...
svxPtnVarTbl * pTableVal
the table dimension information,
More...

Detailed Description

pattern feature data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1435 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnFtr::pTableVal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnFtr
cntDim
inc
inpData
pTableVal

◆ pTableVal

svxPtnVarTbl* svxPtnFtr::pTableVal

the table dimension information,

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1440 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnFtr::inc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnFtr
cntDim
inc
inpData
pTableVal

◆ inc

int svxPtnFtr::inc

0-the value to be set, 1- the value to be increased

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1438 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnFtr::cntDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnFtr
cntDim
inc
inpData
pTableVal

◆ cntDim

int svxPtnFtr::cntDim

count dimension to change the value

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1439 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnFtr::inpData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnFtr
cntDim
inc
inpData
pTableVal

◆ inpData

svxPtnData* svxPtnFtr::inpData

base input data of pattern feature command

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1437 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnGeom Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPtnGeom Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

pattern geometry data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPtnData * inpData
base input data of pattern geometry command More...
int nonAssoCopy
non-associative copy (0 = no, 1 = yes), used only for geometry pattern
if set to 0, it will create explicit geometries which can't be redefined
if set to 1, the pattern instances will be associative with the original entities More...

Detailed Description

pattern geometry data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1402 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnGeom::nonAssoCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnGeom
inpData
nonAssoCopy

◆ nonAssoCopy

int svxPtnGeom::nonAssoCopy

non-associative copy (0 = no, 1 = yes), used only for geometry pattern
if set to 0, it will create explicit geometries which can't be redefined
if set to 1, the pattern instances will be associative with the original entities

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1405 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnGeom::inpData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnGeom
inpData
nonAssoCopy

◆ inpData

svxPtnData* svxPtnGeom::inpData

base input data of pattern geometry command

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1404 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnVarTbl Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPtnVarTbl Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

table dimension information More...

#include <zwapi_cmd_shape_data.h>

Data Fields

vxName dimName
the name of the dimension to change the value More...
int | cntCell
count of cells to be set More...
int * | pCell
double * | pVal
the dimension value to be set. More...

Detailed Description

table dimension information

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1414 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnVarTbl::pCell

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnVarTbl
cntCell
dimName
pCell
pVal

◆ pCell

int* svxPtnVarTbl::pCell

@brief the instances position id, such as: first direction x number is 3 and second direction y number is 2, B is the base feature

y ^ * O O if the '*' should be modified, pCell[i] = 1;
| B & O if the '&' should be modified, pCell[i] = 10000;
|----—> x

normally pCell[i] = x*10000+y; and B(0,0) can't be modified.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1418 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnVarTbl::dimName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnVarTbl
cntCell
dimName
pCell
pVal

◆ dimName

vxName svxPtnVarTbl::dimName

the name of the dimension to change the value

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1416 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnVarTbl::cntCell

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnVarTbl
cntCell
dimName
pCell
pVal

◆ cntCell

int svxPtnVarTbl::cntCell

count of cells to be set

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1417 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnVarTbl::pVal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnVarTbl
cntCell
dimName
pCell
pVal

◆ pVal

double* svxPtnVarTbl::pVal

the dimension value to be set.

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1428 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPunch Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

part punch data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numBase
number of base entities More...
int * | idBases
list of base entities' id More...
int | idPunch
id of punch shape entity More...
int | numBound
number of boundary face entities More...
int * | idBounds
list of boundary faces' id More...
double | thickness
thickness represents the shell offset.default:2 More...

Detailed Description

part punch data

Definition at line 1167 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::numBound

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ numBound

int svxPunch::numBound

number of boundary face entities

Definition at line 1172 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ thickness

double svxPunch::thickness

thickness represents the shell offset.default:2

Definition at line 1174 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::idBounds

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ idBounds

int* svxPunch::idBounds

list of boundary faces' id

Definition at line 1173 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::idPunch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ idPunch

int svxPunch::idPunch

id of punch shape entity

Definition at line 1171 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::numBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ numBase

int svxPunch::numBase

number of base entities

Definition at line 1169 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunch::idBases

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunch
idBases
idBounds
idPunch
numBase
numBound
thickness

◆ idBases

int* svxPunch::idBases

list of base entities' id

Definition at line 1170 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxPunchCons Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

punch constraint More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

evxConsType alignTyp
alignment type (default value: VX_CONCENTRIC) More...
svxEntPath pathEnt1
first entity path (initialize as(2,-1,idEnt)) More...
int | ent1FormFile
1 if the first entity from the punch file, else 0 (default value:0) More...
svxEntPath pathEnt2
second entity path (initialize as(2,-1,idEnt)) More...
int | ent2FormFile
1 if the second entity from the punch file, else 0 (default value:0) More...
double | dOffset
offset value (default value: 0) More...
double | dAng
angle value (default value: 0) More...
int | Flip
1-flip the alignment direction, else 0 (default value:0) More...

Detailed Description

punch constraint

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1052 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::pathEnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ pathEnt1

svxEntPath svxPunchCons::pathEnt1

first entity path (initialize as(2,-1,idEnt))

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1056 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::alignTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ alignTyp

evxConsType svxPunchCons::alignTyp

alignment type (default value: VX_CONCENTRIC)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1054 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::Flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ Flip

int svxPunchCons::Flip

1-flip the alignment direction, else 0 (default value:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1065 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::dAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ dAng

double svxPunchCons::dAng

angle value (default value: 0)

Definition at line 1063 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::pathEnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ pathEnt2

svxEntPath svxPunchCons::pathEnt2

second entity path (initialize as(2,-1,idEnt))

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1058 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::ent1FormFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ ent1FormFile

int svxPunchCons::ent1FormFile

1 if the first entity from the punch file, else 0 (default value:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1057 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ dOffset

double svxPunchCons::dOffset

offset value (default value: 0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1061 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchCons::ent2FormFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchCons
alignTyp
dAng
dOffset
ent1FormFile
ent2FormFile
Flip
pathEnt1
pathEnt2

◆ ent2FormFile

int svxPunchCons::ent2FormFile

1 if the second entity from the punch file, else 0 (default value:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1059 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxPunchData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

Punch data. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union LocData
union of punch data More...

Data Fields

evxPunchTyp punchTyp
Punch option, default value:VX_PUNCH_SHAPE. More...
int | idBase
boundary face on base (face id) More...
int | cntOpen
count of open faces (0 to ignore) More...
int * | pOpenList
open faces from punch shape (NULL to ignore) if punchTyp = VX_PUNCH_FILE, pOpenList must from the punch file More...
int | addFillet
fillet placement edges,default value:0 if set to 1, user can set the fillet radius of intersected edge between punch and sheet metal More...
double | dRadius
radius for dRadius, default value:5 More...
int | addFillet2
fillet non placement edges,default value:0 More...
double | dRadius2
radius for addFillet2, default value:5 More...
int | idPunch
a punch shape (shape id) More...
vxLongPath pathPunch
punch file path, used option in VX_PUNCH_FILE More...
evxPunchLocType locTyp
location Type, default value:VX_LOCATION_POINT More...
svxPoint localPnt
punch point, used option in VX_PUNCH_FILE(default:(0,0,0)) More...
int | relation
Related with source, default value:1, used option in VX_PUNCH_FILE if set to 1, the punch result changes as the punch in source changes if set to 0, the change of punch will not effect the existing punch. More...
union svxPunchData::LocData | locData

Detailed Description

Punch data.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1072 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData::ByCons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
  • ByCons
Data Fields
svxPunchData::LocData::ByCons Struct Reference

point + constraint More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int cntCons
count of constraint data (0 to ignore) More...
svxPunchCons * punchCons
constraint data list(NUll to ignore) More...

Detailed Description

point + constraint

<

Definition at line 1100 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData::ByCons::cntCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
  • ByCons
cntCons
punchCons

◆ cntCons

int svxPunchData::LocData::ByCons::cntCons

count of constraint data (0 to ignore)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1102 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData::ByCons::punchCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
  • ByCons
cntCons
punchCons

◆ punchCons

svxPunchCons* svxPunchData::LocData::ByCons::punchCons

constraint data list(NUll to ignore)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1103 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData::ByPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
  • ByPnt
Data Fields
svxPunchData::LocData::ByPnt Struct Reference

point + frame More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int idFrame
Frame, used option in VX_PUNCH_FILE (-1/0 to ignored) More...

Detailed Description

point + frame

<

Definition at line 1095 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData::ByPnt::idFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
  • ByPnt
idFrame

◆ idFrame

int svxPunchData::LocData::ByPnt::idFrame

Frame, used option in VX_PUNCH_FILE (-1/0 to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1097 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::punchTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ punchTyp

evxPunchTyp svxPunchData::punchTyp

Punch option, default value:VX_PUNCH_SHAPE.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1074 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::addFillet2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ addFillet2

int svxPunchData::addFillet2

fillet non placement edges,default value:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1082 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::cntOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ cntOpen

int svxPunchData::cntOpen

count of open faces (0 to ignore)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1076 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::idBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ idBase

int svxPunchData::idBase

boundary face on base (face id)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1075 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::locTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ locTyp

evxPunchLocType svxPunchData::locTyp

location Type, default value:VX_LOCATION_POINT

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1088 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::addFillet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ addFillet

int svxPunchData::addFillet

fillet placement edges,default value:0 if set to 1, user can set the fillet radius of intersected edge between punch and sheet metal

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1079 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::relation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ relation

int svxPunchData::relation

Related with source, default value:1, used option in VX_PUNCH_FILE if set to 1, the punch result changes as the punch in source changes if set to 0, the change of punch will not effect the existing punch.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1090 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::pOpenList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ pOpenList

int* svxPunchData::pOpenList

open faces from punch shape (NULL to ignore) if punchTyp = VX_PUNCH_FILE, pOpenList must from the punch file

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1077 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::dRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ dRadius

double svxPunchData::dRadius

radius for dRadius, default value:5

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1081 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::localPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ localPnt

svxPoint svxPunchData::localPnt

punch point, used option in VX_PUNCH_FILE(default:(0,0,0))

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1089 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::idPunch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ idPunch

int svxPunchData::idPunch

a punch shape (shape id)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1085 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::pathPunch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ pathPunch

vxLongPath svxPunchData::pathPunch

punch file path, used option in VX_PUNCH_FILE

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1087 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::dRadius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
addFillet
addFillet2
cntOpen
dRadius
dRadius2
idBase
idPunch
localPnt
locTyp
pathPunch
pOpenList
punchTyp
relation

◆ dRadius2

double svxPunchData::dRadius2

radius for addFillet2, default value:5

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1083 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRackPinionData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRackPinionData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly rack and pinion constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default) More...
double | value
translate value (1.0-default) More...
int | flip
whether to flip the direction (0-default) More...

Detailed Description

custom data for assembly rack and pinion constraint

Examples
part\asmConsTest.cpp.

Definition at line 311 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRackPinionData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRackPinionData
flip
transType
value

◆ flip

int svxRackPinionData::flip

whether to flip the direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 315 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRackPinionData::transType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRackPinionData
flip
transType
value

◆ transType

int svxRackPinionData::transType

translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)

Examples
part\asmConsTest.cpp.

Definition at line 313 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRackPinionData::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRackPinionData
flip
transType
value

◆ value

double svxRackPinionData::value

translate value (1.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 314 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadDimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRadDimData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

radial or diametric dim data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxRadDimType type
radial or diametric type More...
svxPntOnEnt arcPnt
point coordinate of point on entity (entPnt will be projected to the entity if entPnt is not on entity). (the curve idEnt can't be a line) More...
svxPntOnEnt brkPnt
break point. if type = VX_RAD_BROKEN, the line through arcPnt and the arc center will be cut at the intersection of above line and the line through brkPnt vertical to above line other type can be null More...
svxPntOnEnt txtPnt
text point: specify the location the dimension text More...

Detailed Description

radial or diametric dim data

Examples
drawing\dwgDimTest.cpp.

Definition at line 936 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadDimData::brkPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadDimData
arcPnt
brkPnt
txtPnt
type

◆ brkPnt

svxPntOnEnt svxRadDimData::brkPnt

break point. if type = VX_RAD_BROKEN, the line through arcPnt and the arc center will be cut at the intersection of above line and the line through brkPnt vertical to above line other type can be null

Examples
drawing\dwgDimTest.cpp.

Definition at line 943 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadDimData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadDimData
arcPnt
brkPnt
txtPnt
type

◆ type

evxRadDimType svxRadDimData::type

radial or diametric type

Examples
drawing\dwgDimTest.cpp.

Definition at line 938 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadDimData::txtPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadDimData
arcPnt
brkPnt
txtPnt
type

◆ txtPnt

svxPntOnEnt svxRadDimData::txtPnt

text point: specify the location the dimension text

Examples
drawing\dwgDimTest.cpp.

Definition at line 948 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadDimData::arcPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadDimData
arcPnt
brkPnt
txtPnt
type

◆ arcPnt

svxPntOnEnt svxRadDimData::arcPnt

point coordinate of point on entity (entPnt will be projected to the entity if entPnt is not on entity). (the curve idEnt can't be a line)

Examples
drawing\dwgDimTest.cpp.

Definition at line 940 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadiusSetData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRadiusSetData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

radius set data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | idCurve
set the curve More...
svxPntOnEntPath pnt
set the point More...
double | radius
set the radius More...
int | radiusFlat
whether to mark the radius as flat More...

Detailed Description

radius set data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 179 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadiusSetData::idCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadiusSetData
idCurve
pnt
radius
radiusFlat

◆ idCurve

int svxRadiusSetData::idCurve

set the curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 181 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadiusSetData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadiusSetData
idCurve
pnt
radius
radiusFlat

◆ radius

double svxRadiusSetData::radius

set the radius

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 183 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadiusSetData::radiusFlat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadiusSetData
idCurve
pnt
radius
radiusFlat

◆ radiusFlat

int svxRadiusSetData::radiusFlat

whether to mark the radius as flat

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 184 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRadiusSetData::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRadiusSetData
idCurve
pnt
radius
radiusFlat

◆ pnt

svxPntOnEntPath svxRadiusSetData::pnt

set the point

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 182 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxReadyText Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of ready sketch text More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union evxSkTextMethodsUnion
union of sketch text data More...

Data Fields

char * | text
text string More...
vxLongName font
font name More...
double | size
text height More...
int | style
text style(1:Regular; 2:Italic; 3:Bold; 4.Bold Italic) More...
double | spacing
character space More...
svxPoint origin
text position More...
int | flipY
Horizontal flip. More...
int | mirror
Mirror. More...
evxReadyTextMethods methods
ready text methods More...
double | WidthText
Text width. More...
double | VerticalSpacing
Vertical Spacing. More...
union svxReadyText::evxSkTextMethodsUnion | methodsUnion

Detailed Description

data of ready sketch text

Examples
sketch\skDrawingTest.cpp.

Definition at line 120 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::BoxText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • BoxText
Data Fields
svxReadyText::evxSkTextMethodsUnion::BoxText Struct Reference

box text data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint AlignPoint
Align Point. More...
double | WidthSetting
Setting Width. More...
double | HeightSetting
Setting Height. More...

Detailed Description

box text data

<

Definition at line 147 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::BoxText::WidthSetting

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • BoxText
AlignPoint
HeightSetting
WidthSetting

◆ WidthSetting

double svxReadyText::evxSkTextMethodsUnion::BoxText::WidthSetting

Setting Width.

Examples
sketch\skDrawingTest.cpp.

Definition at line 150 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::BoxText::AlignPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • BoxText
AlignPoint
HeightSetting
WidthSetting

◆ AlignPoint

svxPoint svxReadyText::evxSkTextMethodsUnion::BoxText::AlignPoint

Align Point.

Examples
sketch\skDrawingTest.cpp.

Definition at line 149 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::BoxText::HeightSetting

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • BoxText
AlignPoint
HeightSetting
WidthSetting

◆ HeightSetting

double svxReadyText::evxSkTextMethodsUnion::BoxText::HeightSetting

Setting Height.

Examples
sketch\skDrawingTest.cpp.

Definition at line 151 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
Data Fields
svxReadyText::evxSkTextMethodsUnion::OnCrvText Struct Reference

On curve text data. More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | reverseCurve
Reverse curve. More...
int | placeTextAtOrg
Place text at origin. More...
int | reduceTxtDat
Reduce text data. More...
int | KeepTextShape
Keep Text Shape. More...
int | idxCurve
curve index More...

Detailed Description

On curve text data.

<

Definition at line 139 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText::placeTextAtOrg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
idxCurve
KeepTextShape
placeTextAtOrg
reduceTxtDat
reverseCurve

◆ placeTextAtOrg

int svxReadyText::evxSkTextMethodsUnion::OnCrvText::placeTextAtOrg

Place text at origin.

Examples
sketch\skDrawingTest.cpp.

Definition at line 142 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText::reduceTxtDat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
idxCurve
KeepTextShape
placeTextAtOrg
reduceTxtDat
reverseCurve

◆ reduceTxtDat

int svxReadyText::evxSkTextMethodsUnion::OnCrvText::reduceTxtDat

Reduce text data.

Examples
sketch\skDrawingTest.cpp.

Definition at line 143 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText::idxCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
idxCurve
KeepTextShape
placeTextAtOrg
reduceTxtDat
reverseCurve

◆ idxCurve

int svxReadyText::evxSkTextMethodsUnion::OnCrvText::idxCurve

curve index

Examples
sketch\skDrawingTest.cpp.

Definition at line 145 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText::reverseCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
idxCurve
KeepTextShape
placeTextAtOrg
reduceTxtDat
reverseCurve

◆ reverseCurve

int svxReadyText::evxSkTextMethodsUnion::OnCrvText::reverseCurve

Reverse curve.

Examples
sketch\skDrawingTest.cpp.

Definition at line 141 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion::OnCrvText::KeepTextShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
  • OnCrvText
idxCurve
KeepTextShape
placeTextAtOrg
reduceTxtDat
reverseCurve

◆ KeepTextShape

int svxReadyText::evxSkTextMethodsUnion::OnCrvText::KeepTextShape

Keep Text Shape.

Examples
sketch\skDrawingTest.cpp.

Definition at line 144 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::methods

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ methods

evxReadyTextMethods svxReadyText::methods

ready text methods

Examples
sketch\skDrawingTest.cpp.

Definition at line 132 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::style

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ style

int svxReadyText::style

text style(1:Regular; 2:Italic; 3:Bold; 4.Bold Italic)

Examples
sketch\skDrawingTest.cpp.

Definition at line 125 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ origin

svxPoint svxReadyText::origin

text position

Examples
sketch\skDrawingTest.cpp.

Definition at line 128 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::mirror

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ mirror

int svxReadyText::mirror

Mirror.

Examples
sketch\skDrawingTest.cpp.

Definition at line 130 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::flipY

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ flipY

int svxReadyText::flipY

Horizontal flip.

Examples
sketch\skDrawingTest.cpp.

Definition at line 129 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ spacing

double svxReadyText::spacing

character space

Examples
sketch\skDrawingTest.cpp.

Definition at line 126 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::VerticalSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ VerticalSpacing

double svxReadyText::VerticalSpacing

Vertical Spacing.

Examples
sketch\skDrawingTest.cpp.

Definition at line 135 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ size

double svxReadyText::size

text height

Examples
sketch\skDrawingTest.cpp.

Definition at line 124 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ text

char* svxReadyText::text

text string

Examples
sketch\skDrawingTest.cpp.

Definition at line 122 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::WidthText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ WidthText

double svxReadyText::WidthText

Text width.

Examples
sketch\skDrawingTest.cpp.

Definition at line 134 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::font

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
flipY
font
methods
mirror
origin
size
spacing
style
text
VerticalSpacing
WidthText

◆ font

vxLongName svxReadyText::font

font name

Definition at line 123 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRectangle Struct Reference
UI » UI Data

Rectangle data. More...

#include <zwapi_ui_data.h>

Data Fields

long | left
long | top
long | right
long | bottom

Detailed Description

Rectangle data.

Definition at line 259 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangle::left

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangle

◆ left

long svxRectangle::left

Definition at line 261 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangle::right

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangle

◆ right

long svxRectangle::right

Definition at line 263 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangle::top

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangle

◆ top

long svxRectangle::top

Definition at line 262 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangle::bottom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangle

◆ bottom

long svxRectangle::bottom

Definition at line 264 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRectangleData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

3D ellipse & rectangle data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

evxRectangleType type
type to make rectangle More...
int | idPlane
not required if "type" is VX_RECT_3PT More...
int | firstPtType
type of 1st input point (0 corner, 1 center) More...
svxPoint | pts [3]
3 input points depend on "type" More...
double | width
width if "type" is VX_RECT_WIDTH_HEIGHT More...
double | height
height if "type" is VX_RECT_WIDTH_HEIGHT More...
double | angle
rotation angle More...
int | prjFirstPt
1 to project first point to plane, 0 not More...
int | parallelogram
0 rectangle, 1 parallelogram More...

Detailed Description

3D ellipse & rectangle data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 150 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::parallelogram

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ parallelogram

int svxRectangleData::parallelogram

0 rectangle, 1 parallelogram

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 163 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::pts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ pts

svxPoint svxRectangleData::pts[3]

3 input points depend on "type"

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 156 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ width

double svxRectangleData::width

width if "type" is VX_RECT_WIDTH_HEIGHT

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 157 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::firstPtType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ firstPtType

int svxRectangleData::firstPtType

type of 1st input point (0 corner, 1 center)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 155 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ angle

double svxRectangleData::angle

rotation angle

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 161 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ height

double svxRectangleData::height

height if "type" is VX_RECT_WIDTH_HEIGHT

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 158 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ type

evxRectangleType svxRectangleData::type

type to make rectangle

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 153 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ idPlane

int svxRectangleData::idPlane

not required if "type" is VX_RECT_3PT

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 154 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRectangleData::prjFirstPt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRectangleData
angle
firstPtType
height
idPlane
parallelogram
prjFirstPt
pts
type
width

◆ prjFirstPt

int svxRectangleData::prjFirstPt

1 to project first point to plane, 0 not

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 162 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRefEntData Struct Reference
Drawing Objects » Drawing Data

reference entity data. More...

#include <zwapi_dwg_data.h>

Data Fields

vxPath fileName
file name More...
vxRootName partName
part name More...
vxLongName shellName
shell name More...
svxEntPath compPath
pick-path of the component More...
char | entClass
0: component; 1: solid shell; 2: surface shell More...
int | depth
depth of the component (top=0,1,2...) More...

Detailed Description

reference entity data.

fileName,partName and entClass parameters of this structure must be filled in, and other parameters are optional according to whether the referenced part or assembly.

if entClass=0,compPath and depth must be entered. if entClass>0,shellName must be entered.

Definition at line 78 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::entClass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ entClass

char svxRefEntData::entClass

0: component; 1: solid shell; 2: surface shell

Definition at line 84 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::compPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ compPath

svxEntPath svxRefEntData::compPath

pick-path of the component

Definition at line 83 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::depth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ depth

int svxRefEntData::depth

depth of the component (top=0,1,2...)

Definition at line 85 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::partName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ partName

vxRootName svxRefEntData::partName

part name

Definition at line 81 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::shellName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ shellName

vxLongName svxRefEntData::shellName

shell name

Definition at line 82 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefEntData::fileName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefEntData
compPath
depth
entClass
fileName
partName
shellName

◆ fileName

vxPath svxRefEntData::fileName

file name

Definition at line 80 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRefineFacets Struct Reference
Part Objects » Part Data

refine facets data More...

#include <zwapi_part_data.h>

Data Fields

int | idFace
face id More...
evxRefineFacetsTolType type
tolerance type.default:VX_FACETS_TOL_PIXEL More...
double | edgeTol
edge tolerance.min=0.001,default:1. apply it if type=VX_FACETS_TOL_DISTANCE or VX_FACETS_TOL_ANGLE. More...
double | facetTol
facet tolerance.min=0.001.default:1. apply it if type=VX_FACETS_TOL_DISTANCE. More...
double | angleTol
angle tolerance.min=1,max=30,default:5. apply it if type=VX_FACETS_TOL_ANGLE. More...

Detailed Description

refine facets data

Definition at line 136 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets::facetTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefineFacets
angleTol
edgeTol
facetTol
idFace
type

◆ facetTol

double svxRefineFacets::facetTol

facet tolerance.min=0.001.default:1. apply it if type=VX_FACETS_TOL_DISTANCE.

Definition at line 142 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets::edgeTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefineFacets
angleTol
edgeTol
facetTol
idFace
type

◆ edgeTol

double svxRefineFacets::edgeTol

edge tolerance.min=0.001,default:1. apply it if type=VX_FACETS_TOL_DISTANCE or VX_FACETS_TOL_ANGLE.

Definition at line 141 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets::angleTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefineFacets
angleTol
edgeTol
facetTol
idFace
type

◆ angleTol

double svxRefineFacets::angleTol

angle tolerance.min=1,max=30,default:5. apply it if type=VX_FACETS_TOL_ANGLE.

Definition at line 143 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefineFacets
angleTol
edgeTol
facetTol
idFace
type

◆ type

evxRefineFacetsTolType svxRefineFacets::type

tolerance type.default:VX_FACETS_TOL_PIXEL

Definition at line 139 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRefineFacets::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRefineFacets
angleTol
edgeTol
facetTol
idFace
type

◆ idFace

int svxRefineFacets::idFace

face id

Definition at line 138 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxReplaceData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape replace data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numBases
numbers of replaced base faces More...
int * | idBases
list of id's of replaced base faces More...
int | idPlace
id of face for displacement More...
double | offset
offset value More...
evxOverflowType faceOverflow
used to control face overflow behavior. VX_OF_AUTOMATIC default More...
int | keepReplaceFace
whether to keep the displacement face (0 = not reserve, 1 = reserve. 0 default) More...

Detailed Description

shape replace data

Definition at line 1118 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ offset

double svxReplaceData::offset

offset value

Definition at line 1123 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::keepReplaceFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ keepReplaceFace

int svxReplaceData::keepReplaceFace

whether to keep the displacement face (0 = not reserve, 1 = reserve. 0 default)

Definition at line 1125 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::faceOverflow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ faceOverflow

evxOverflowType svxReplaceData::faceOverflow

used to control face overflow behavior. VX_OF_AUTOMATIC default

Definition at line 1124 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::numBases

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ numBases

int svxReplaceData::numBases

numbers of replaced base faces

Definition at line 1120 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::idBases

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ idBases

int* svxReplaceData::idBases

list of id's of replaced base faces

Definition at line 1121 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReplaceData::idPlace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReplaceData
faceOverflow
idBases
idPlace
keepReplaceFace
numBases
offset

◆ idPlace

int svxReplaceData::idPlace

id of face for displacement

Definition at line 1122 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRevolveData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

revolved shape More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
int | idProfile
profile (sketch or curvelist) More...
double | Start
start angle (deg) More...
double | End
end angle (deg) More...
svxAxis Axis
axis of revolution More...
double | Offset
profile offset (mm) (0 if undefined) More...
double | Thickness
wall thickness (mm) (0 if undefined) More...
int | idAxis
index of idAxis (-1/0 to ignore) More...
int | idParent
parent index if idAxis is a geometry of the profile (-1/0 to ignore) More...
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness) More...
evxDistanceMethod StartType
start type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE, VX_TO_FACE More...
evxDistanceMethod EndType
end type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE, VX_TO_FACE More...
int | idStartEnt
entity id if StartType != VX_INPU_VALUE (-1 to ignore) More...
int | idEndEnt
entity id if EndType != VX_INPU_VALUE (-1 to ignore) More...
svxPoint * StartPnt
start point (NULL to ignore, it will get the point (umin,vmin) of the idStartEnt if StartType = VX_EXT_TO_FACE/VX_TO_EXTEND_FACE)) More...
svxPoint * EndPnt
end point (NULL to ignore, it will get the point (umin,vmin) of the idEndEnt if EndType = VX_EXT_TO_FACE/VX_TO_EXTEND_FACE)) More...
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open) More...
int | Flip
flip face direction (0 as default, CapType=VX_END_CAP_NONE) More...

Detailed Description

revolved shape

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 214 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::StartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ StartPnt

svxPoint* svxRevolveData::StartPnt

start point (NULL to ignore, it will get the point (umin,vmin) of the idStartEnt if StartType = VX_EXT_TO_FACE/VX_TO_EXTEND_FACE))

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 235 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::EndPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ EndPnt

svxPoint* svxRevolveData::EndPnt

end point (NULL to ignore, it will get the point (umin,vmin) of the idEndEnt if EndType = VX_EXT_TO_FACE/VX_TO_EXTEND_FACE))

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 236 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ idParent

int svxRevolveData::idParent

parent index if idAxis is a geometry of the profile (-1/0 to ignore)

Definition at line 226 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::End

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ End

double svxRevolveData::End

end angle (deg)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 219 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::EndType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ EndType

evxDistanceMethod svxRevolveData::EndType

end type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE, VX_TO_FACE

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 232 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::CapType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ CapType

evxCapType svxRevolveData::CapType

end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 237 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Thickness

double svxRevolveData::Thickness

wall thickness (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 223 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::OffsetTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ OffsetTyp

evxOffsetType svxRevolveData::OffsetTyp

option of offset(set the value of Offset and Thickness)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 228 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::idAxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ idAxis

int svxRevolveData::idAxis

index of idAxis (-1/0 to ignore)

Definition at line 225 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Start

double svxRevolveData::Start

start angle (deg)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 218 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Offset

double svxRevolveData::Offset

profile offset (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 222 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Flip

int svxRevolveData::Flip

flip face direction (0 as default, CapType=VX_END_CAP_NONE)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 238 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::idEndEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ idEndEnt

int svxRevolveData::idEndEnt

entity id if EndType != VX_INPU_VALUE (-1 to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 234 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::StartType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ StartType

evxDistanceMethod svxRevolveData::StartType

start type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE, VX_TO_FACE

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 231 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::idStartEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ idStartEnt

int svxRevolveData::idStartEnt

entity id if StartType != VX_INPU_VALUE (-1 to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 233 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ idProfile

int svxRevolveData::idProfile

profile (sketch or curvelist)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 217 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Combine

evxBoolType svxRevolveData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 216 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRevolveData::Axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRevolveData
Axis
CapType
Combine
End
EndPnt
EndType
Flip
idAxis
idEndEnt
idParent
idProfile
idStartEnt
Offset
OffsetTyp
Start
StartPnt
StartType
Thickness

◆ Axis

svxAxis svxRevolveData::Axis

axis of revolution

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 220 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRibData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

rib data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | idShape
id of boolean shape, -1 to auto boolean, but since R2024, only support one shape and it will fail if there are multi-shapes intersect with the rib More...
int | idParent
id of profile curve's parent sketch or curvelist More...
int | idProfile
index of profile curve More...
int | direction
extrude direction (0 = Parallel to sketch(default), 1 = Vertical to sketch) More...
int | widthType
thickness type (0 = Fist side, 1 = Two sides(default), 2 = Second side) More...
double | width
rib thickness (mm) (default:10) More...
double | angle
draft angle (default:0) More...
int | idPlane
draft plane, set when angle > 0.0 More...
int | numBndFaces
number of rib boundary faces. More...
int * | idBndFaces
list of rib boundary faces More...
int | flipDir
flip the material direction (1 = yes, 0 = no) More...
vxName ftrName
feature name for "FtRib", 0 default More...

Detailed Description

rib data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 853 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ idParent

int svxRibData::idParent

id of profile curve's parent sketch or curvelist

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 857 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ angle

double svxRibData::angle

draft angle (default:0)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 862 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::numBndFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ numBndFaces

int svxRibData::numBndFaces

number of rib boundary faces.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 864 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ width

double svxRibData::width

rib thickness (mm) (default:10)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 861 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::idBndFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ idBndFaces

int* svxRibData::idBndFaces

list of rib boundary faces

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 865 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ idPlane

int svxRibData::idPlane

draft plane, set when angle > 0.0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 863 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ idShape

int svxRibData::idShape

id of boolean shape, -1 to auto boolean, but since R2024, only support one shape and it will fail if there are multi-shapes intersect with the rib

Definition at line 855 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ ftrName

vxName svxRibData::ftrName

feature name for "FtRib", 0 default

Definition at line 867 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::flipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ flipDir

int svxRibData::flipDir

flip the material direction (1 = yes, 0 = no)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 866 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ idProfile

int svxRibData::idProfile

index of profile curve

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 858 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ direction

int svxRibData::direction

extrude direction (0 = Parallel to sketch(default), 1 = Vertical to sketch)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 859 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRibData::widthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRibData
angle
direction
flipDir
ftrName
idBndFaces
idParent
idPlane
idProfile
idShape
numBndFaces
width
widthType

◆ widthType

int svxRibData::widthType

thickness type (0 = Fist side, 1 = Two sides(default), 2 = Second side)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 860 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRootSepData Struct Reference
Common » File Root

separate root to file More...

#include <zwapi_root.h>

Data Fields

int | cntRoots
count of roots More...
vxLongName * roots
list of root More...
int | keep
1 is keep the objects in original file, else 0.default:1 More...
int | oneObj
1 is one object per file, else 0. default:1 More...
int | openSepFile
1 is open the separate files,else 0. default:0 More...
vxPath dir
save directory of separate files More...
int | option
when the file name is repeated, 0 is auto rename, 1 is manual rename, 2 is skip.default:0 More...
vxLongName name
file name.apply it if option=1. More...

Detailed Description

separate root to file

Definition at line 1156 of file zwapi_root.h.

The documentation for this struct was generated from the following file:
  • zwapi_root.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ dir

vxPath svxRootSepData::dir

save directory of separate files

Definition at line 1163 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::keep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ keep

int svxRootSepData::keep

1 is keep the objects in original file, else 0.default:1

Definition at line 1160 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ option

int svxRootSepData::option

when the file name is repeated, 0 is auto rename, 1 is manual rename, 2 is skip.default:0

Definition at line 1164 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ name

vxLongName svxRootSepData::name

file name.apply it if option=1.

Definition at line 1165 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::cntRoots

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ cntRoots

int svxRootSepData::cntRoots

count of roots

Definition at line 1158 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::openSepFile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ openSepFile

int svxRootSepData::openSepFile

1 is open the separate files,else 0. default:0

Definition at line 1162 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::oneObj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ oneObj

int svxRootSepData::oneObj

1 is one object per file, else 0. default:1

Definition at line 1161 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRootSepData::roots

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRootSepData
cntRoots
dir
keep
name
oneObj
openSepFile
option
roots

◆ roots

vxLongName* svxRootSepData::roots

list of root

Definition at line 1159 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRotateData2D Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

template command Rotate data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | cntEnt
Entity count. More...
int * | pEnts
Entities ID. More...
svxPntOnEnt Pnt
Base point. More...
evxRotateType Type
Option to set rotate type, VX_ROTATE_ANGLE is default. More...
double | Angle
Rotate angle, 0 if Type is VX_POTATE_POINTS. More...
svxPntOnEnt Start
Start point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE. More...
svxPntOnEnt End
End point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE. More...
evxRotateSetting Setting
Rotate settings, VX_ROTATE_MOVE is default. More...
int | cntCopy
Copy count, 0 if Setting is VX_ROTATE_MOVE. More...

Detailed Description

template command Rotate data

Examples
sketch\basicEditingTest.cpp.

Definition at line 703 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::pEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ pEnts

int* svxRotateData2D::pEnts

Entities ID.

Examples
sketch\basicEditingTest.cpp.

Definition at line 706 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::cntCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ cntCopy

int svxRotateData2D::cntCopy

Copy count, 0 if Setting is VX_ROTATE_MOVE.

Examples
sketch\basicEditingTest.cpp.

Definition at line 713 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::cntEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ cntEnt

int svxRotateData2D::cntEnt

Entity count.

Examples
sketch\basicEditingTest.cpp.

Definition at line 705 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::Start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ Start

svxPntOnEnt svxRotateData2D::Start

Start point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.

Examples
sketch\basicEditingTest.cpp.

Definition at line 710 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::Angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ Angle

double svxRotateData2D::Angle

Rotate angle, 0 if Type is VX_POTATE_POINTS.

Examples
sketch\basicEditingTest.cpp.

Definition at line 709 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::End

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ End

svxPntOnEnt svxRotateData2D::End

End point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.

Examples
sketch\basicEditingTest.cpp.

Definition at line 711 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::Setting

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ Setting

evxRotateSetting svxRotateData2D::Setting

Rotate settings, VX_ROTATE_MOVE is default.

Examples
sketch\basicEditingTest.cpp.

Definition at line 712 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ Pnt

svxPntOnEnt svxRotateData2D::Pnt

Base point.

Examples
sketch\basicEditingTest.cpp.

Definition at line 707 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRotateData2D::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRotateData2D
Angle
cntCopy
cntEnt
End
pEnts
Pnt
Setting
Start
Type

◆ Type

evxRotateType svxRotateData2D::Type

Option to set rotate type, VX_ROTATE_ANGLE is default.

Examples
sketch\basicEditingTest.cpp.

Definition at line 708 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRoughTexts Struct Reference
Commands Creation » Part and Assembly Commands » PMI Commands Data

Roughness PMI text define. More...

#include <zwapi_cmd_pmi_data.h>

Data Fields

char | a1 [65]
max roughness average (or =NULL) More...
char | a2 [65]
min roughness average (or =NULL) More...
char | b [65]
processing method/treatment (or =NULL) More...
char | c [65]
sampling length/roughness cutout (or =NULL) More...
char | e [65]
machining allowance (or =NULL) More...
char | f1 [65]
Rz, roughness value (or =NULL) More...
char | f2 [65]
other roughness value/spacing (or =NULL) More...
char | f3 [65]
third row optional string (or =NULL) More...

Detailed Description

Roughness PMI text define.

Examples
part\pmiCrtTest.cpp.

Definition at line 30 of file zwapi_cmd_pmi_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_pmi_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::f2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ f2

char svxRoughTexts::f2[65]

other roughness value/spacing (or =NULL)

Definition at line 38 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::f3

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ f3

char svxRoughTexts::f3[65]

third row optional string (or =NULL)

Definition at line 39 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::e

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ e

char svxRoughTexts::e[65]

machining allowance (or =NULL)

Definition at line 36 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::a2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ a2

char svxRoughTexts::a2[65]

min roughness average (or =NULL)

Definition at line 33 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::c

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ c

char svxRoughTexts::c[65]

sampling length/roughness cutout (or =NULL)

Definition at line 35 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::b

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ b

char svxRoughTexts::b[65]

processing method/treatment (or =NULL)

Definition at line 34 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::f1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ f1

char svxRoughTexts::f1[65]

Rz, roughness value (or =NULL)

Definition at line 37 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRoughTexts::a1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRoughTexts
a1
a2
b
c
e
f1
f2
f3

◆ a1

char svxRoughTexts::a1[65]

max roughness average (or =NULL)

Definition at line 32 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRuledData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxRuledData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

ruled data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

svxPntOnEntPath firstCrv
select the first curve More...
svxPntOnEntPath secondCrv
select the second curve More...
svxPntOnEntPath spineCrv
select the spine curve More...
int trimPlane
whether to attempt trimmed plane (1 as default) More...

Detailed Description

ruled data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 155 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRuledData::secondCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRuledData
firstCrv
secondCrv
spineCrv
trimPlane

◆ secondCrv

svxPntOnEntPath svxRuledData::secondCrv

select the second curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 158 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRuledData::firstCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRuledData
firstCrv
secondCrv
spineCrv
trimPlane

◆ firstCrv

svxPntOnEntPath svxRuledData::firstCrv

select the first curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 157 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRuledData::spineCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRuledData
firstCrv
secondCrv
spineCrv
trimPlane

◆ spineCrv

svxPntOnEntPath svxRuledData::spineCrv

select the spine curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 159 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxRuledData::trimPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxRuledData
firstCrv
secondCrv
spineCrv
trimPlane

◆ trimPlane

int svxRuledData::trimPlane

whether to attempt trimmed plane (1 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 160 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSTEPData Struct Reference
File » File Data

data of export STEP file More...

#include <zwapi_file_data.h>

Data Fields

char | AppProtocol
0-AP203, 1-AP214 (1-default), 2-AP242 More...
char | OutPut
0-PART, 1-Assembly (1-default) More...
char | ExportType
0-All objects, 1-Specified entities More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE More...

Detailed Description

data of export STEP file

Definition at line 342 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ ExcludeGeom

int svxSTEPData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE

Definition at line 349 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ EntList

int* svxSTEPData::EntList

the specified entities id list if ExportType = 1

Definition at line 348 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ ExportType

char svxSTEPData::ExportType

0-All objects, 1-Specified entities

Definition at line 346 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::AppProtocol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ AppProtocol

char svxSTEPData::AppProtocol

0-AP203, 1-AP214 (1-default), 2-AP242

Definition at line 344 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ EntCnt

int svxSTEPData::EntCnt

the count of export entities if ExportType = 1

Definition at line 347 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTEPData::OutPut

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTEPData
AppProtocol
EntCnt
EntList
ExcludeGeom
ExportType
OutPut

◆ OutPut

char svxSTEPData::OutPut

0-PART, 1-Assembly (1-default)

Definition at line 345 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTL Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSTL Struct Reference
Part Objects » Part Data

3D STL facets More...

#include <zwapi_part_data.h>

Data Fields

char * | name
name
More...
int | nFacet
number of facet
More...
svxTriangle * facets
Array of STLfacet
More...
double | dTol
Tolerance to use when extracting facets
More...

Detailed Description

3D STL facets

Definition at line 90 of file zwapi_part_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_part_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTL::facets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTL
dTol
facets
name
nFacet

◆ facets

svxTriangle* svxSTL::facets

Array of STLfacet

When users create triangular patches through interface cvxPartFacetsBySTL,
They need to ensure that the incoming normal matches the normal calculated
through the tree points of the triangle.
If the normal contradicts each other, the calculated normal will be used.
Calculate the normal of the triangle according to the order of incoming points.
The three points should be transmitted counterclockwise.

A
| \
B -C

The value of variable facets[i].Pnt should be passed in the order of ABC or BCA or CAB,not CBA.

Definition at line 94 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTL::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTL
dTol
facets
name
nFacet

◆ name

char* svxSTL::name

name

Definition at line 92 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTL::dTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTL
dTol
facets
name
nFacet

◆ dTol

double svxSTL::dTol

Tolerance to use when extracting facets

Definition at line 107 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTL::nFacet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTL
dTol
facets
name
nFacet

◆ nFacet

int svxSTL::nFacet

number of facet

Definition at line 93 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSTLData Struct Reference
File » File Data

data of export STL file More...

#include <zwapi_file_data.h>

Data Fields

int | Coordinate
coordinate, 0-world, 1-local (0-default) More...
int | FileFormat
1 is ASCII file format, else 0. default:0 More...
int | Translate
1 is translate to positive quadrant, else 0. default:0 More...
int | RefineFacets
1 is refine facets to close volume, else 0. default:0
More...
int | TwistAnalysis
1 is apply twist analysis, else 0. default:0 More...
double | TessellationTol
chord height tessellation tolerance.default:0.01 More...
double | MeshSize
maximum mesh size.default:0 More...
int | ExportType
0-All objects, 1-Specified entities (0-default) More...
int | EntCnt
the count of export entities if ExportType = 1 More...
int * | EntList
the specified entities id list if ExportType = 1 More...
int | ExportLayer
0-All layers, 1- Specified layers (0-default) More...
int | LayerCnt
the count of export layers if ExportLayer = 1 More...
int * | LayerList
the specified layers id list if ExportLayer = 1 More...
int | ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE (default: ExcludeGeom=VX_EXCLUDE_BLANKED) More...

Detailed Description

data of export STL file

Definition at line 177 of file zwapi_file_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_file_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::EntCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ EntCnt

int svxSTLData::EntCnt

the count of export entities if ExportType = 1

Definition at line 188 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::Translate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ Translate

int svxSTLData::Translate

1 is translate to positive quadrant, else 0. default:0

Definition at line 181 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::FileFormat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ FileFormat

int svxSTLData::FileFormat

1 is ASCII file format, else 0. default:0

Definition at line 180 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::LayerList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ LayerList

int* svxSTLData::LayerList

the specified layers id list if ExportLayer = 1

Definition at line 193 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::TwistAnalysis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ TwistAnalysis

int svxSTLData::TwistAnalysis

1 is apply twist analysis, else 0. default:0

Definition at line 183 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::Coordinate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ Coordinate

int svxSTLData::Coordinate

coordinate, 0-world, 1-local (0-default)

Definition at line 179 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::ExcludeGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ ExcludeGeom

int svxSTLData::ExcludeGeom

filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE (default: ExcludeGeom=VX_EXCLUDE_BLANKED)

Definition at line 195 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::RefineFacets

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ RefineFacets

int svxSTLData::RefineFacets

1 is refine facets to close volume, else 0. default:0

Definition at line 182 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::ExportLayer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ ExportLayer

int svxSTLData::ExportLayer

0-All layers, 1- Specified layers (0-default)

Definition at line 191 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::EntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ EntList

int* svxSTLData::EntList

the specified entities id list if ExportType = 1

Definition at line 189 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::TessellationTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ TessellationTol

double svxSTLData::TessellationTol

chord height tessellation tolerance.default:0.01

Definition at line 184 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::MeshSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ MeshSize

double svxSTLData::MeshSize

maximum mesh size.default:0

Definition at line 185 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::LayerCnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ LayerCnt

int svxSTLData::LayerCnt

the count of export layers if ExportLayer = 1

Definition at line 192 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSTLData::ExportType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSTLData
Coordinate
EntCnt
EntList
ExcludeGeom
ExportLayer
ExportType
FileFormat
LayerCnt
LayerList
MeshSize
RefineFacets
TessellationTol
Translate
TwistAnalysis

◆ ExportType

int svxSTLData::ExportType

0-All objects, 1-Specified entities (0-default)

Definition at line 187 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxScrewConsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxScrewConsData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly screw constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default) More...
double | value
translate value (1.0-default) More...
int | flip
whether to flip the direction (0-default) More...
int | faceDir
face direction (0: opposite; 1: same facing; 0-default) More...

Detailed Description

custom data for assembly screw constraint

Examples
part\asmConsTest.cpp.

Definition at line 322 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxScrewConsData::faceDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxScrewConsData
faceDir
flip
transType
value

◆ faceDir

int svxScrewConsData::faceDir

face direction (0: opposite; 1: same facing; 0-default)

Examples
part\asmConsTest.cpp.

Definition at line 327 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxScrewConsData::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxScrewConsData
faceDir
flip
transType
value

◆ value

double svxScrewConsData::value

translate value (1.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 325 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxScrewConsData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxScrewConsData
faceDir
flip
transType
value

◆ flip

int svxScrewConsData::flip

whether to flip the direction (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 326 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxScrewConsData::transType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxScrewConsData
faceDir
flip
transType
value

◆ transType

int svxScrewConsData::transType

translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)

Examples
part\asmConsTest.cpp.

Definition at line 324 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSewData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSewData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

faces sew data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

double | tol
tolerance value, default(0.01) More...
char | multEdg
enable multiple edge matching or not More...
char | forceClose
force object to sew into solid More...

Detailed Description

faces sew data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 397 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSewData::forceClose

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSewData
forceClose
multEdg
tol

◆ forceClose

char svxSewData::forceClose

force object to sew into solid

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 401 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSewData::multEdg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSewData
forceClose
multEdg
tol

◆ multEdg

char svxSewData::multEdg

enable multiple edge matching or not

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 400 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSewData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSewData
forceClose
multEdg
tol

◆ tol

double svxSewData::tol

tolerance value, default(0.01)

Definition at line 399 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShaderAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxShaderAt Struct Reference
Common » Common Data

shader attribute More...

#include <zwapi_util.h>

Data Fields

vxName name
shader name (blank if undefined) More...
vxPath file
shader path/file name (blank if undefined) More...
svxColor | color [4]
shader colors More...
double | param [10]
shader parameters More...

Detailed Description

shader attribute

Definition at line 1879 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShaderAt::file

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShaderAt
color
file
name
param

◆ file

vxPath svxShaderAt::file

shader path/file name (blank if undefined)

Definition at line 1882 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShaderAt::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShaderAt
color
file
name
param

◆ color

svxColor svxShaderAt::color[4]

shader colors

Definition at line 1883 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShaderAt::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShaderAt
color
file
name
param

◆ name

vxName svxShaderAt::name

shader name (blank if undefined)

Definition at line 1881 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShaderAt::param

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShaderAt
color
file
name
param

◆ param

double svxShaderAt::param[10]

shader parameters

Definition at line 1884 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxShellData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

template command Shell input data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | idShape
shape S id More...
double | dThick
thick T More...
int | cntOpenFace
open faces' count More...
int * | pIdOpenFace
open faces' id More...
int | cntList
the count of the sub_data will be filled in List More...
int * | pIdFace
face F ids More...
double * | pOffSet
offset T array ,it must be correspond to pIdFaces one by one More...
int | sideFaces
create side faces 0 to no
1 to yes (Generally 1) :create any required side faces during the offset to maintain a closed solid More...
int | KeepPrimFace
Keep primitive faces 0 to no (Generally 1)
1 to yes : primitive faces remaining as primitive after Shell. More...
int | Intersect
intersections
1 to do not remove. Ignore self intersecting faces.
2 to remove fast. Limited to removing self intersections on or near faces that become completely inverted, such as a fillet that is offset more than its radius.(Generally 2)
3 to remove all. Remove self intersections and inverted regions (including inverted inner loop cases) as well as can be done. Faces that intersect other faces in the shape will be split. More...

Detailed Description

template command Shell input data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1010 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::sideFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ sideFaces

int svxShellData::sideFaces

create side faces 0 to no
1 to yes (Generally 1) :create any required side faces during the offset to maintain a closed solid

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1024 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::cntList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ cntList

int svxShellData::cntList

the count of the sub_data will be filled in List

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1019 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ idShape

int svxShellData::idShape

shape S id

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1012 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::pIdOpenFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ pIdOpenFace

int* svxShellData::pIdOpenFace

open faces' id

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1016 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::dThick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ dThick

double svxShellData::dThick

thick T

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1013 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::cntOpenFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ cntOpenFace

int svxShellData::cntOpenFace

open faces' count

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1015 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::Intersect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ Intersect

int svxShellData::Intersect

intersections
1 to do not remove. Ignore self intersecting faces.
2 to remove fast. Limited to removing self intersections on or near faces that become completely inverted, such as a fillet that is offset more than its radius.(Generally 2)
3 to remove all. Remove self intersections and inverted regions (including inverted inner loop cases) as well as can be done. Faces that intersect other faces in the shape will be split.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1030 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::KeepPrimFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ KeepPrimFace

int svxShellData::KeepPrimFace

Keep primitive faces 0 to no (Generally 1)
1 to yes : primitive faces remaining as primitive after Shell.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1027 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::pOffSet

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ pOffSet

double* svxShellData::pOffSet

offset T array ,it must be correspond to pIdFaces one by one

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1021 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxShellData::pIdFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxShellData
cntList
cntOpenFace
dThick
idShape
Intersect
KeepPrimFace
pIdFace
pIdOpenFace
pOffSet
sideFaces

◆ pIdFace

int* svxShellData::pIdFace

face F ids

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1020 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSkAxisData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

data of sketch Axis More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union evxSkAxisMethodsUnion
union of sketch axis data More...

Data Fields

evxSkAxisMethods Method
Sketch Axis Methods. More...
int | idEnt1
id of the First Point parent entity(0 to ignore) More...
svxPoint2 Pnt1
first Point.
if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2.
if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to reference line and through Pnt1.
if type = VX_SK_AXIS_ANGLE, the axis is the line vertical to reference line and through Pnt1.
if type = VX_SK_AXIS_PARAOFF, the axis and the reference line form angle Angle, and the axis through Pnt1.
if type = VX_SK_AXIS_HORIZ, the axis is parallel to x-axis and through Pnt1.
if type = VX_SK_AXIS_VERT, the axis is vertical to x-axis and through Pnt1.
if type = VX_SK_AXIS_PERPENDICULAR, can be null. More...
int | idRefEnt
id of the RefLine parent entity. if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to reference line and through Pnt1.
if type = VX_SK_AXIS_ANGLE, the axis is the line vertical to reference line and through Pnt1.
if type = VX_SK_AXIS_PARAOFF, the axis and the reference line form angle Angle, and the axis through Pnt1.
other type can be null More...
svxPoint2 RefPnt
Ref Line point. More...
union svxSkAxisData::evxSkAxisMethodsUnion | inpUnion
int | ConstGeom
1-Construction Geometry, else 0 (1 as default) More...

Detailed Description

data of sketch Axis

Examples
sketch\skDrawingTest.cpp.

Definition at line 47 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxis2Pnt
Data Fields
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt Struct Reference

Two Points. More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int idEnt2
id of the Second Parent entity (0 to ignore) More...
svxPoint2 Pnt2
second point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. other type can be null More...

Detailed Description

Two Points.

<

Definition at line 67 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::Pnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxis2Pnt
idEnt2
Pnt2

◆ Pnt2

svxPoint2 svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::Pnt2

second point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. other type can be null

Examples
sketch\skDrawingTest.cpp.

Definition at line 70 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::idEnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxis2Pnt
idEnt2
Pnt2

◆ idEnt2

int svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::idEnt2

id of the Second Parent entity (0 to ignore)

Examples
sketch\skDrawingTest.cpp.

Definition at line 69 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxisAngle
Data Fields
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle Struct Reference

Angle. More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

double Angle
Angle. if type = VX_SK_AXIS_ANGLE, it is the angle between axis and reference line. other type can be null. More...

Detailed Description

Angle.

<

Definition at line 81 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle::Angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxisAngle
Angle

◆ Angle

double svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle::Angle

Angle. if type = VX_SK_AXIS_ANGLE, it is the angle between axis and reference line. other type can be null.

Examples
sketch\skDrawingTest.cpp.

Definition at line 83 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxisParaOff
Data Fields
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff Struct Reference

Parallel and Offset. More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

double Offset
Offset. if type = VX_SK_AXIS_PARAOFF, the axis is parallel to reference line, and the distance between axis and reference line is Offset. other type can be null. More...

Detailed Description

Parallel and Offset.

<

Definition at line 74 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
  • SkAxisParaOff
Offset

◆ Offset

double svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff::Offset

Offset. if type = VX_SK_AXIS_PARAOFF, the axis is parallel to reference line, and the distance between axis and reference line is Offset. other type can be null.

Examples
sketch\skDrawingTest.cpp.

Definition at line 76 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::Pnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ Pnt1

svxPoint2 svxSkAxisData::Pnt1

first Point.
if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2.
if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to reference line and through Pnt1.
if type = VX_SK_AXIS_ANGLE, the axis is the line vertical to reference line and through Pnt1.
if type = VX_SK_AXIS_PARAOFF, the axis and the reference line form angle Angle, and the axis through Pnt1.
if type = VX_SK_AXIS_HORIZ, the axis is parallel to x-axis and through Pnt1.
if type = VX_SK_AXIS_VERT, the axis is vertical to x-axis and through Pnt1.
if type = VX_SK_AXIS_PERPENDICULAR, can be null.

Examples
sketch\skDrawingTest.cpp.

Definition at line 51 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::idEnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ idEnt1

int svxSkAxisData::idEnt1

id of the First Point parent entity(0 to ignore)

Examples
sketch\skDrawingTest.cpp.

Definition at line 50 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::Method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ Method

evxSkAxisMethods svxSkAxisData::Method

Sketch Axis Methods.

Examples
sketch\skDrawingTest.cpp.

Definition at line 49 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::RefPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ RefPnt

svxPoint2 svxSkAxisData::RefPnt

Ref Line point.

Examples
sketch\skDrawingTest.cpp.

Definition at line 64 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::idRefEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ idRefEnt

int svxSkAxisData::idRefEnt

id of the RefLine parent entity. if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to reference line and through Pnt1.
if type = VX_SK_AXIS_ANGLE, the axis is the line vertical to reference line and through Pnt1.
if type = VX_SK_AXIS_PARAOFF, the axis and the reference line form angle Angle, and the axis through Pnt1.
other type can be null

Examples
sketch\skDrawingTest.cpp.

Definition at line 59 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::ConstGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
ConstGeom
idEnt1
idRefEnt
Method
Pnt1
RefPnt

◆ ConstGeom

int svxSkAxisData::ConstGeom

1-Construction Geometry, else 0 (1 as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 88 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkChamferData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

information of chamfer in sheeting or sketch More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

evxSkChamferOpt chamferOpt
option of chamfer More...
int | idFirCurve
first setback value. if type = VX_CHMOPT_SETBACK, it is setback value for 2 curves. if type != VX_CHMOPT_SETBACK, it is setback value for 1st curve More...
svxPoint2 firPnt
a point on the first curve More...
int | idSecCurve
second setback value. if type = VX_CHMOPT_TWOSETBACK,it is setback value for 2nd curve. other type can be null More...
svxPoint2 secPnt
a point on the second curve More...
double | firSetBack
first setback value, when chamferOpt is VX_CHMOPT_SETBACK it represents setback value More...
double | secSetBack
second setback value, only needed when chamferOpt is VX_CHMOPT_TWOSETBACK More...
double | angValue
specifying the angle of the first curve, if type = VX_CHMOPT_SETBACKANDDIS, the setback value for 2nd curve is decided by the line form by first setback position and the angle. other type can be null More...
evxSkChamferTrimOpt chmTrimOpt
trim (or extend) curves More...
evxSkChamferExtenOpt chmExtOpt
control the path of extended curves More...

Detailed Description

information of chamfer in sheeting or sketch

Examples
sketch\skDrawingTest.cpp.

Definition at line 370 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::firPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ firPnt

svxPoint2 svxSkChamferData::firPnt

a point on the first curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 376 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::idFirCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ idFirCurve

int svxSkChamferData::idFirCurve

first setback value. if type = VX_CHMOPT_SETBACK, it is setback value for 2 curves. if type != VX_CHMOPT_SETBACK, it is setback value for 1st curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 373 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::secSetBack

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ secSetBack

double svxSkChamferData::secSetBack

second setback value, only needed when chamferOpt is VX_CHMOPT_TWOSETBACK

Examples
sketch\skDrawingTest.cpp.

Definition at line 382 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::idSecCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ idSecCurve

int svxSkChamferData::idSecCurve

second setback value. if type = VX_CHMOPT_TWOSETBACK,it is setback value for 2nd curve. other type can be null

Examples
sketch\skDrawingTest.cpp.

Definition at line 377 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::chamferOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ chamferOpt

evxSkChamferOpt svxSkChamferData::chamferOpt

option of chamfer

Examples
sketch\skDrawingTest.cpp.

Definition at line 372 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::secPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ secPnt

svxPoint2 svxSkChamferData::secPnt

a point on the second curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 380 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::angValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ angValue

double svxSkChamferData::angValue

specifying the angle of the first curve, if type = VX_CHMOPT_SETBACKANDDIS, the setback value for 2nd curve is decided by the line form by first setback position and the angle. other type can be null

Examples
sketch\skDrawingTest.cpp.

Definition at line 383 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::chmExtOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ chmExtOpt

evxSkChamferExtenOpt svxSkChamferData::chmExtOpt

control the path of extended curves

Examples
sketch\skDrawingTest.cpp.

Definition at line 388 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::firSetBack

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ firSetBack

double svxSkChamferData::firSetBack

first setback value, when chamferOpt is VX_CHMOPT_SETBACK it represents setback value

Examples
sketch\skDrawingTest.cpp.

Definition at line 381 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkChamferData::chmTrimOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkChamferData
angValue
chamferOpt
chmExtOpt
chmTrimOpt
firPnt
firSetBack
idFirCurve
idSecCurve
secPnt
secSetBack

◆ chmTrimOpt

evxSkChamferTrimOpt svxSkChamferData::chmTrimOpt

trim (or extend) curves

Examples
sketch\skDrawingTest.cpp.

Definition at line 387 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSkCopy Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch copy data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union svxSkCopyData
union of sketch copy data More...

Data Fields

evxSkCopyType type
copy option More...
int | numEnt
number of entities to copy More...
int * | idEnts
list id of entities to copy More...
int | numCpy
copy number More...
double | angle
the rotate angle.default:0 More...
double | scale
the scale of copy entities.default:1 More...
union svxSkCopy::svxSkCopyData | cpy

Detailed Description

sketch copy data

Definition at line 824 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyDir Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyDir
Data Fields
svxSkCopy::svxSkCopyData::svxSkCopyDir Struct Reference

along a direction type More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPntOnEnt dir
direction of copy More...
double distance
distance of copy.default:10 More...
svxPoint2 basePnt
base point of copy More...

Detailed Description

along a direction type

<

Definition at line 840 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyDir::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyDir
basePnt
dir
distance

◆ dir

svxPntOnEnt svxSkCopy::svxSkCopyData::svxSkCopyDir::dir

direction of copy

Definition at line 842 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyDir::basePnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyDir
basePnt
dir
distance

◆ basePnt

svxPoint2 svxSkCopy::svxSkCopyData::svxSkCopyDir::basePnt

base point of copy

Definition at line 844 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyDir::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyDir
basePnt
dir
distance

◆ distance

double svxSkCopy::svxSkCopyData::svxSkCopyDir::distance

distance of copy.default:10

Definition at line 843 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyPnt
Data Fields
svxSkCopy::svxSkCopyData::svxSkCopyPnt Struct Reference

point to point copy type More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint2 fromPnt
from point More...
svxPoint2 toPnt
to point More...
evxSkCopyDir dirOption
direction option.default:VX_SK_COPY_DIR_TWO More...

Detailed Description

point to point copy type

<

Definition at line 834 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyPnt::dirOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyPnt
dirOption
fromPnt
toPnt

◆ dirOption

evxSkCopyDir svxSkCopy::svxSkCopyData::svxSkCopyPnt::dirOption

direction option.default:VX_SK_COPY_DIR_TWO

Definition at line 838 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyPnt::toPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyPnt
dirOption
fromPnt
toPnt

◆ toPnt

svxPoint2 svxSkCopy::svxSkCopyData::svxSkCopyPnt::toPnt

to point

Definition at line 837 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData::svxSkCopyPnt::fromPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
  • svxSkCopyPnt
dirOption
fromPnt
toPnt

◆ fromPnt

svxPoint2 svxSkCopy::svxSkCopyData::svxSkCopyPnt::fromPnt

from point

Definition at line 836 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ scale

double svxSkCopy::scale

the scale of copy entities.default:1

Definition at line 831 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ angle

double svxSkCopy::angle

the rotate angle.default:0

Definition at line 830 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ idEnts

int* svxSkCopy::idEnts

list id of entities to copy

Definition at line 828 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ type

evxSkCopyType svxSkCopy::type

copy option

Definition at line 826 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::numCpy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ numCpy

int svxSkCopy::numCpy

copy number

Definition at line 829 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
angle
idEnts
numCpy
numEnt
scale
type

◆ numEnt

int svxSkCopy::numEnt

number of entities to copy

Definition at line 827 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkFilletData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

information of fillet in sheeting or sketch More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | idFirCurve
first specified curve More...
svxPoint2 firPnt
a point on the first curve More...
int | idSecCurve
second specified curve More...
svxPoint2 secPnt
a point on the second curve More...
double | radius
radius of fillet More...
int | designArc
flag to use design arc, 0 no else yes More...
evxSkChamferTrimOpt fltTrimOpt
trim (or extend) curves More...
evxSkChamferExtenOpt fltExtOpt
control the path of extended curves More...

Detailed Description

information of fillet in sheeting or sketch

Examples
sketch\skDrawingTest.cpp.

Definition at line 354 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::fltTrimOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ fltTrimOpt

evxSkChamferTrimOpt svxSkFilletData::fltTrimOpt

trim (or extend) curves

Examples
sketch\skDrawingTest.cpp.

Definition at line 362 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::fltExtOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ fltExtOpt

evxSkChamferExtenOpt svxSkFilletData::fltExtOpt

control the path of extended curves

Examples
sketch\skDrawingTest.cpp.

Definition at line 363 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::idSecCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ idSecCurve

int svxSkFilletData::idSecCurve

second specified curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 358 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ radius

double svxSkFilletData::radius

radius of fillet

Examples
sketch\skDrawingTest.cpp.

Definition at line 360 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::secPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ secPnt

svxPoint2 svxSkFilletData::secPnt

a point on the second curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 359 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::firPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ firPnt

svxPoint2 svxSkFilletData::firPnt

a point on the first curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 357 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::designArc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ designArc

int svxSkFilletData::designArc

flag to use design arc, 0 no else yes

Examples
sketch\skDrawingTest.cpp.

Definition at line 361 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkFilletData::idFirCurve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkFilletData
designArc
firPnt
fltExtOpt
fltTrimOpt
idFirCurve
idSecCurve
radius
secPnt

◆ idFirCurve

int svxSkFilletData::idFirCurve

first specified curve

Examples
sketch\skDrawingTest.cpp.

Definition at line 356 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkNestingBlankData Struct Reference

blank data of Sketch Nesting More...

#include <zwapi_cmd_sk_app_data.h>

Data Fields

int | cnt
count of listBlank More...
int * | listBlank
list of entity id. Select sketch entities to define a blank, the selected sketch entities also must meet the following rules�� Inner and outer loops must be closed and cannot intersect, and inner loop cannot be nested. More...
double | margin
Define the gap in 4 directions of blank.The fields is valid only when selecting rectangle method.default:0. More...
double | topMargin
Define the gap top the blank.This field is valid only when selecting custom method.default:0. More...
double | bottomMargin
Define the gap bottom the blank.This field is valid only when selecting custom method.default:0. More...
double | leftMargin
Define the gap left the blank.This field is valid only when selecting custom method.default:0. More...
double | rightMargin
Define the gap right the blank.This field is valid only when selecting custom method.default:0. More...
int | method
"Blank Margin" offers 2 ways to define: even and uneven margin in 4 directions. 0 is rectangle, 1 is custom.default:1 More...
vxLongName blankName
Specify each blank a name to distinguish each other.If not specified, a default name is specified. More...

Detailed Description

blank data of Sketch Nesting

Definition at line 57 of file zwapi_cmd_sk_app_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_app_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::bottomMargin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ bottomMargin

double svxSkNestingBlankData::bottomMargin

Define the gap bottom the blank.This field is valid only when selecting custom method.default:0.

Definition at line 65 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ method

int svxSkNestingBlankData::method

"Blank Margin" offers 2 ways to define: even and uneven margin in 4 directions. 0 is rectangle, 1 is custom.default:1

Definition at line 68 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::rightMargin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ rightMargin

double svxSkNestingBlankData::rightMargin

Define the gap right the blank.This field is valid only when selecting custom method.default:0.

Definition at line 67 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::blankName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ blankName

vxLongName svxSkNestingBlankData::blankName

Specify each blank a name to distinguish each other.If not specified, a default name is specified.

Definition at line 70 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::listBlank

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ listBlank

int* svxSkNestingBlankData::listBlank

list of entity id. Select sketch entities to define a blank, the selected sketch entities also must meet the following rules�� Inner and outer loops must be closed and cannot intersect, and inner loop cannot be nested.

Definition at line 60 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::margin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ margin

double svxSkNestingBlankData::margin

Define the gap in 4 directions of blank.The fields is valid only when selecting rectangle method.default:0.

Definition at line 63 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ cnt

int svxSkNestingBlankData::cnt

count of listBlank

Definition at line 59 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::topMargin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ topMargin

double svxSkNestingBlankData::topMargin

Define the gap top the blank.This field is valid only when selecting custom method.default:0.

Definition at line 64 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingBlankData::leftMargin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingBlankData
blankName
bottomMargin
cnt
leftMargin
listBlank
margin
method
rightMargin
topMargin

◆ leftMargin

double svxSkNestingBlankData::leftMargin

Define the gap left the blank.This field is valid only when selecting custom method.default:0.

Definition at line 66 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkNestingData Struct Reference

Nesting data of sketch. More...

#include <zwapi_cmd_sk_app_data.h>

Data Fields

int | cntPrf
count of profiles More...
svxSkNestingProfileData * profiles
list of profile data More...
int | cntBlk
count of blanks More...
svxSkNestingBlankData * blanks
list of blank data More...
double | timeToNest
Specify the time to be calculated for nesting.Nesting result can be different basing on how long the nesting time is using. Normally the longer the time is, the better the result is. Users can input a suitable time balancing the result and time cost. More...
vxName reportName
Specify a name for nesting report.If not specified, a default name is specified. More...
vxLongName reportDir
Specify save path and file name for nesting report.If not specified, the default save path and file name will be used.
for example: reportDir="D:\ZW3D\Nesting result.html".
"D:\ZW3D\" is the path where the file is saved. It can be changed according to the user's wishes. <br> "Nesting result" is name. It can be changed. <br> but,the reportDir must contain ".html",otherwise the interface cannot be used normally. More...

Detailed Description

Nesting data of sketch.

Definition at line 78 of file zwapi_cmd_sk_app_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_app_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::reportDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ reportDir

vxLongName svxSkNestingData::reportDir

Specify save path and file name for nesting report.If not specified, the default save path and file name will be used.
for example: reportDir="D:\ZW3D\Nesting result.html".
"D:\ZW3D\" is the path where the file is saved. It can be changed according to the user's wishes. <br> "Nesting result" is name. It can be changed. <br> but,the reportDir must contain ".html",otherwise the interface cannot be used normally.

Definition at line 88 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::timeToNest

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ timeToNest

double svxSkNestingData::timeToNest

Specify the time to be calculated for nesting.Nesting result can be different basing on how long the nesting time is using. Normally the longer the time is, the better the result is. Users can input a suitable time balancing the result and time cost.

Definition at line 84 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::reportName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ reportName

vxName svxSkNestingData::reportName

Specify a name for nesting report.If not specified, a default name is specified.

Definition at line 87 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::cntBlk

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ cntBlk

int svxSkNestingData::cntBlk

count of blanks

Definition at line 82 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::cntPrf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ cntPrf

int svxSkNestingData::cntPrf

count of profiles

Definition at line 80 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::blanks

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ blanks

svxSkNestingBlankData* svxSkNestingData::blanks

list of blank data

Definition at line 83 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingData::profiles

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingData
blanks
cntBlk
cntPrf
profiles
reportDir
reportName
timeToNest

◆ profiles

svxSkNestingProfileData* svxSkNestingData::profiles

list of profile data

Definition at line 81 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkNestingProfileData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

profile data of Sketch Nesting More...

#include <zwapi_cmd_sk_app_data.h>

Data Fields

int | cnt
count of listProfile More...
int * | listProfile
list of entity id.Select sketch entities to define a profile, the selected sketch entities must meet the following rules�� Inner and outer loops must be closed and cannot intersect, and inner loop cannot be nested. More...
int | quantity
Define how much the profile defined above is planned to nest. If the blank is big enough, the profile will be nested as the plan quantity, but if not, the actual nesting quantity will be less than the plan.default:1(min=1,max=100000) More...
double | margin
Define the gap around the profile.default:0. More...
double | minAngle
Specify the angle range allowing the profile rotating during nesting if needed to accommodate the profile as much as possible.default:0(min=0,max=360) More...
double | maxAngle
Specify the angle range allowing the profile rotating during nesting if needed to accommodate the profile as much as possible.default:360.(min=0,max=360) More...
int | flip
Define whether the profile can be flip around during nest when necessary.1 if flip,else 0. default:0. More...
int | priority
Define the nest sequence when multiple profiles are about to nest.the range is 1~5.The highest priority is 1.default:1. More...
vxLongName profileName
Specify each profile a name to distinguish each other.If not specified, a default name is specified. More...

Detailed Description

profile data of Sketch Nesting

Definition at line 33 of file zwapi_cmd_sk_app_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_app_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::profileName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ profileName

vxLongName svxSkNestingProfileData::profileName

Specify each profile a name to distinguish each other.If not specified, a default name is specified.

Definition at line 49 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::priority

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ priority

int svxSkNestingProfileData::priority

Define the nest sequence when multiple profiles are about to nest.the range is 1~5.The highest priority is 1.default:1.

Definition at line 48 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ cnt

int svxSkNestingProfileData::cnt

count of listProfile

Definition at line 35 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::margin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ margin

double svxSkNestingProfileData::margin

Define the gap around the profile.default:0.

Definition at line 42 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::quantity

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ quantity

int svxSkNestingProfileData::quantity

Define how much the profile defined above is planned to nest. If the blank is big enough, the profile will be nested as the plan quantity, but if not, the actual nesting quantity will be less than the plan.default:1(min=1,max=100000)

Definition at line 39 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::maxAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ maxAngle

double svxSkNestingProfileData::maxAngle

Specify the angle range allowing the profile rotating during nesting if needed to accommodate the profile as much as possible.default:360.(min=0,max=360)

Definition at line 45 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::minAngle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ minAngle

double svxSkNestingProfileData::minAngle

Specify the angle range allowing the profile rotating during nesting if needed to accommodate the profile as much as possible.default:0(min=0,max=360)

Definition at line 43 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ flip

int svxSkNestingProfileData::flip

Define whether the profile can be flip around during nest when necessary.1 if flip,else 0. default:0.

Definition at line 47 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNestingProfileData::listProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNestingProfileData
cnt
flip
listProfile
margin
maxAngle
minAngle
priority
profileName
quantity

◆ listProfile

int* svxSkNestingProfileData::listProfile

list of entity id.Select sketch entities to define a profile, the selected sketch entities must meet the following rules�� Inner and outer loops must be closed and cannot intersect, and inner loop cannot be nested.

Definition at line 36 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkNgons Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch polygon data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

evxSkNgonsType type
polygon option More...
svxPoint2 center
the center point of polygon. if type != VX_SK_NGONS_SIDE_LEN, and type != VX_SK_NGONS_SIDE_BOUND, the point should be given. other type can be null More...
double | R
the radius or length of polygon.default:10.
if type = VX_SK_NGONS_IN_R, it is radius of circle have inscribed polygon.
if type = VX_SK_NGONS_CIR_R, it is radius of circle have outer polygon.
if type = VX_SK_NGONS_SIDE_LEN, it is the length of polygon's sides.
other type can be null More...
int | numSide
number of sides.default:6 More...
double | angle
the rotate angle.default:0 More...
svxPoint2 corner
corner point of polygon. if type = VX_SK_NGONS_SIDE_LEN or VX_SK_NGONS_SIDE_BOUND, the point should be given. other type can be null More...
svxPoint2 boundary
boundary point of polygon . if type = VX_SK_NGONS_IN_BOUND or VX_SK_NGONS_SIDE_BOUND, the point is a vertex of polygon.
if type = VX_SK_NGONS_CIR_BOUND, the point is the midpoint of an side on polygon.
other type can be null More...

Detailed Description

sketch polygon data

Definition at line 174 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ center

svxPoint2 svxSkNgons::center

the center point of polygon. if type != VX_SK_NGONS_SIDE_LEN, and type != VX_SK_NGONS_SIDE_BOUND, the point should be given. other type can be null

Definition at line 177 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ R

double svxSkNgons::R

the radius or length of polygon.default:10.
if type = VX_SK_NGONS_IN_R, it is radius of circle have inscribed polygon.
if type = VX_SK_NGONS_CIR_R, it is radius of circle have outer polygon.
if type = VX_SK_NGONS_SIDE_LEN, it is the length of polygon's sides.
other type can be null

Definition at line 180 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::corner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ corner

svxPoint2 svxSkNgons::corner

corner point of polygon. if type = VX_SK_NGONS_SIDE_LEN or VX_SK_NGONS_SIDE_BOUND, the point should be given. other type can be null

Definition at line 187 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ type

evxSkNgonsType svxSkNgons::type

polygon option

Definition at line 176 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::boundary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ boundary

svxPoint2 svxSkNgons::boundary

boundary point of polygon . if type = VX_SK_NGONS_IN_BOUND or VX_SK_NGONS_SIDE_BOUND, the point is a vertex of polygon.
if type = VX_SK_NGONS_CIR_BOUND, the point is the midpoint of an side on polygon.
other type can be null

Definition at line 190 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ angle

double svxSkNgons::angle

the rotate angle.default:0

Definition at line 186 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkNgons::numSide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkNgons
angle
boundary
center
corner
numSide
R
type

◆ numSide

int svxSkNgons::numSide

number of sides.default:6

Definition at line 185 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPowerTrim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkPowerTrim Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch power trim data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPoint2 startPnt
start point of power trim More...
svxPoint2 endPnt
end point of power trim More...

Detailed Description

sketch power trim data

Definition at line 429 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPowerTrim::endPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPowerTrim
endPnt
startPnt

◆ endPnt

svxPoint2 svxSkPowerTrim::endPnt

end point of power trim

Definition at line 432 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPowerTrim::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPowerTrim
endPnt
startPnt

◆ startPnt

svxPoint2 svxSkPowerTrim::startPnt

start point of power trim

Definition at line 431 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSkPtnData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch pattern data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union SkPtnData
union of sketch pattern data More...

Data Fields

evxSkPatternType type
pattern method More...
int | count
number of entities for pattern More...
int * | idEnts
list of id's of entities More...
int | addDim
whether to add dimension (0 = no, 1 = yes).default:1
More...
union svxSkPtnData::SkPtnData | ptnData
int | cntSkip
number of the instances to be skipped More...
int * | firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction) More...
int * | secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction)
can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x
More...

Detailed Description

sketch pattern data

Definition at line 754 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
Data Fields
svxSkPtnData::SkPtnData::svxSkCircular Struct Reference

circular pattern More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPntOnEnt center
rotation center point for the pattern. More...
int | num
pattern number.default:2 More...
evxSkSpacingType spacing
pattern spacing type.default:VX_NUMBER_PITCH More...
double | pitch
spacing between the instances measured in pitch angle degrees.default:60 More...
double | span
spacing between the instances measured in span angle degrees.default:360 More...

Detailed Description

circular pattern

<

Definition at line 771 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular::pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
center
num
pitch
spacing
span

◆ pitch

double svxSkPtnData::SkPtnData::svxSkCircular::pitch

spacing between the instances measured in pitch angle degrees.default:60

Definition at line 776 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
center
num
pitch
spacing
span

◆ spacing

evxSkSpacingType svxSkPtnData::SkPtnData::svxSkCircular::spacing

pattern spacing type.default:VX_NUMBER_PITCH

Definition at line 775 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
center
num
pitch
spacing
span

◆ num

int svxSkPtnData::SkPtnData::svxSkCircular::num

pattern number.default:2

Definition at line 774 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular::span

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
center
num
pitch
spacing
span

◆ span

double svxSkPtnData::SkPtnData::svxSkCircular::span

spacing between the instances measured in span angle degrees.default:360

Definition at line 777 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkCircular::center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkCircular
center
num
pitch
spacing
span

◆ center

svxPntOnEnt svxSkPtnData::SkPtnData::svxSkCircular::center

rotation center point for the pattern.

Definition at line 773 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
Data Fields
svxSkPtnData::SkPtnData::svxSkLinear Struct Reference

linear pattern More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | useSecondDir
0 if user don't use second direction,else 1.default:0 More...
svxVector | dir [2]
first and second direction.the second direction is ignored if useSecondDir = 0. More...
int | num [2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0.default:(2,1) More...
evxSkSpacingType | spacing [2]
pattern spacing type in both direction, the second direction is ignored if useSecondDir = 0.default:(VX_NUMBER_PITCH,VX_NUMBER_PITCH) More...
double | pitch [2]
pattern pitch dist in both direction, the second direction is ignored if useSecondDir = 0.default:(5,5) More...
double | span [2]
pattern span dist in both direction, the second direction is ignored if useSecondDir = 0.default:(100,100) More...

Detailed Description

linear pattern

<

Definition at line 762 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ pitch

double svxSkPtnData::SkPtnData::svxSkLinear::pitch[2]

pattern pitch dist in both direction, the second direction is ignored if useSecondDir = 0.default:(5,5)

Definition at line 768 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::useSecondDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ useSecondDir

int svxSkPtnData::SkPtnData::svxSkLinear::useSecondDir

0 if user don't use second direction,else 1.default:0

Definition at line 764 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ spacing

evxSkSpacingType svxSkPtnData::SkPtnData::svxSkLinear::spacing[2]

pattern spacing type in both direction, the second direction is ignored if useSecondDir = 0.default:(VX_NUMBER_PITCH,VX_NUMBER_PITCH)

Definition at line 767 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ dir

svxVector svxSkPtnData::SkPtnData::svxSkLinear::dir[2]

first and second direction.the second direction is ignored if useSecondDir = 0.

Definition at line 765 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::span

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ span

double svxSkPtnData::SkPtnData::svxSkLinear::span[2]

pattern span dist in both direction, the second direction is ignored if useSecondDir = 0.default:(100,100)

Definition at line 769 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkLinear::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkLinear
dir
num
pitch
spacing
span
useSecondDir

◆ num

int svxSkPtnData::SkPtnData::svxSkLinear::num[2]

pattern number in both direction, the second direction is ignored if useSecondDir = 0.default:(2,1)

Definition at line 766 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkPtnCrv Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkPtnCrv
Data Fields
svxSkPtnData::SkPtnData::svxSkPtnCrv Struct Reference

curve pattern More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPntOnEnt crvid
pattern curve id More...
int | num
pattern number.default:2 More...
evxSkSpacingType spacing
pattern spacing type.default:VX_NUMBER_PITCH More...
double | pitch
pattern pitch dist.default:5 More...

Detailed Description

curve pattern

<

Definition at line 779 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkPtnCrv::crvid

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkPtnCrv
crvid
num
pitch
spacing

◆ crvid

svxPntOnEnt svxSkPtnData::SkPtnData::svxSkPtnCrv::crvid

pattern curve id

Definition at line 781 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkPtnCrv::pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkPtnCrv
crvid
num
pitch
spacing

◆ pitch

double svxSkPtnData::SkPtnData::svxSkPtnCrv::pitch

pattern pitch dist.default:5

Definition at line 784 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkPtnCrv::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkPtnCrv
crvid
num
pitch
spacing

◆ num

int svxSkPtnData::SkPtnData::svxSkPtnCrv::num

pattern number.default:2

Definition at line 782 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData::svxSkPtnCrv::spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
  • svxSkPtnCrv
crvid
num
pitch
spacing

◆ spacing

evxSkSpacingType svxSkPtnData::SkPtnData::svxSkPtnCrv::spacing

pattern spacing type.default:VX_NUMBER_PITCH

Definition at line 783 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ type

evxSkPatternType svxSkPtnData::type

pattern method

Definition at line 756 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::cntSkip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ cntSkip

int svxSkPtnData::cntSkip

number of the instances to be skipped

Definition at line 787 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ idEnts

int* svxSkPtnData::idEnts

list of id's of entities

Definition at line 758 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::addDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ addDim

int svxSkPtnData::addDim

whether to add dimension (0 = no, 1 = yes).default:1

Definition at line 759 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::secondTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ secondTogglePos

int* svxSkPtnData::secondTogglePos

the position id of the patterned entities in the second direction (start form 0, the nTH position in the second direction)
can be null if just pattern the first direction.
such as: linear.num = {3,2}, linear.dir[0] = {1,0,0}, linear.dir[1] = {0, 1, 0}
y
^ O O * if the '*' should be skipped, firstTogglePos[0] = 2, secondTogglePos[0] = 1
| O & O if the '&' should be skipped, firstTogglePos[0] = 1, secondTogglePos[0] = 0
|----—> x

Definition at line 789 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ count

int svxSkPtnData::count

number of entities for pattern

Definition at line 757 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::firstTogglePos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
addDim
cntSkip
count
firstTogglePos
idEnts
secondTogglePos
type

◆ firstTogglePos

int* svxSkPtnData::firstTogglePos

the position id of the patterned entities in the first direction (start form 0, the nTH position in the first direction)

Definition at line 788 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSkRefData Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch reference geometry data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

union evxSkRefInpUnion

Data Fields

evxSkRefMethod method
reference method (VX_SK_REF_PROJECTION as default) More...
evxSkRefOption option
reference option (VX_SK_REF_SINGLE as default) More...
union svxSkRefData::evxSkRefInpUnion | inpUnion
int | constructGeom
whether to create construction geometry (1 or 0, 1 as default) More...
int | recordState
whether to record the state of the history of the part from which the reference geometry is extracted (0 as default) More...

Detailed Description

sketch reference geometry data

Examples
sketch\skDrawingTest.cpp.

Definition at line 248 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceChain Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceChain
Data Fields
svxSkRefData::evxSkRefInpUnion::ReferenceChain Struct Reference

Data Fields

evxSkChainOption option
chain option (VX_SK_CHAIN_PICK as default) More...
int numEnt
number of entities to reference More...
svxEntPath * entPaths
list paths of entities to reference More...

Detailed Description

Definition at line 260 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceChain::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceChain
entPaths
numEnt
option

◆ numEnt

int svxSkRefData::evxSkRefInpUnion::ReferenceChain::numEnt

number of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 263 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceChain::entPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceChain
entPaths
numEnt
option

◆ entPaths

svxEntPath* svxSkRefData::evxSkRefInpUnion::ReferenceChain::entPaths

list paths of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 264 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceChain::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceChain
entPaths
numEnt
option

◆ option

evxSkChainOption svxSkRefData::evxSkRefInpUnion::ReferenceChain::option

chain option (VX_SK_CHAIN_PICK as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 262 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceLoop Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceLoop
Data Fields
svxSkRefData::evxSkRefInpUnion::ReferenceLoop Struct Reference

Data Fields

evxSkLoopOption option
loop option (VX_SK_LOOP_ALL as default) More...
int numEnt
number of entities to reference More...
svxEntPath * entPaths
list paths of entities to reference More...

Detailed Description

Definition at line 266 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceLoop::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceLoop
entPaths
numEnt
option

◆ numEnt

int svxSkRefData::evxSkRefInpUnion::ReferenceLoop::numEnt

number of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 269 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceLoop::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceLoop
entPaths
numEnt
option

◆ option

evxSkLoopOption svxSkRefData::evxSkRefInpUnion::ReferenceLoop::option

loop option (VX_SK_LOOP_ALL as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 268 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceLoop::entPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceLoop
entPaths
numEnt
option

◆ entPaths

svxEntPath* svxSkRefData::evxSkRefInpUnion::ReferenceLoop::entPaths

list paths of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 270 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferencePoint Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferencePoint
Data Fields
svxSkRefData::evxSkRefInpUnion::ReferencePoint Struct Reference

Data Fields

svxPntOnEntPath pnt
reference point More...

Detailed Description

Definition at line 272 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferencePoint::pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferencePoint
pnt

◆ pnt

svxPntOnEntPath svxSkRefData::evxSkRefInpUnion::ReferencePoint::pnt

reference point

Examples
sketch\skDrawingTest.cpp.

Definition at line 274 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceSingle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceSingle
Data Fields
svxSkRefData::evxSkRefInpUnion::ReferenceSingle Struct Reference

Data Fields

int numEnt
number of entities to reference More...
svxEntPath * entPaths
list paths of entities to reference More...

Detailed Description

Definition at line 255 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceSingle::numEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceSingle
entPaths
numEnt

◆ numEnt

int svxSkRefData::evxSkRefInpUnion::ReferenceSingle::numEnt

number of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 257 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion::ReferenceSingle::entPaths

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
  • ReferenceSingle
entPaths
numEnt

◆ entPaths

svxEntPath* svxSkRefData::evxSkRefInpUnion::ReferenceSingle::entPaths

list paths of entities to reference

Examples
sketch\skDrawingTest.cpp.

Definition at line 258 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
constructGeom
method
option
recordState

◆ method

evxSkRefMethod svxSkRefData::method

reference method (VX_SK_REF_PROJECTION as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 250 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::constructGeom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
constructGeom
method
option
recordState

◆ constructGeom

int svxSkRefData::constructGeom

whether to create construction geometry (1 or 0, 1 as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 278 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::recordState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
constructGeom
method
option
recordState

◆ recordState

int svxSkRefData::recordState

whether to record the state of the history of the part from which the reference geometry is extracted (0 as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 279 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
constructGeom
method
option
recordState

◆ option

evxSkRefOption svxSkRefData::option

reference option (VX_SK_REF_SINGLE as default)

Examples
sketch\skDrawingTest.cpp.

Definition at line 251 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkSplitIsect Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkSplitIsect Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch split at intersection data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | Count
the number of the entities More...
int * | idEnts
the id of the entities More...
int | SelfIsect
whether split at self intersections (0 = no, 1 = yes).default:1 More...
int | CrvIsect
whether split at curve-curve intersections (0 = no, 1 = yes).default:1 More...

Detailed Description

sketch split at intersection data

Definition at line 488 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkSplitIsect::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkSplitIsect
Count
CrvIsect
idEnts
SelfIsect

◆ idEnts

int* svxSkSplitIsect::idEnts

the id of the entities

Definition at line 491 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkSplitIsect::SelfIsect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkSplitIsect
Count
CrvIsect
idEnts
SelfIsect

◆ SelfIsect

int svxSkSplitIsect::SelfIsect

whether split at self intersections (0 = no, 1 = yes).default:1

Definition at line 492 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkSplitIsect::CrvIsect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkSplitIsect
Count
CrvIsect
idEnts
SelfIsect

◆ CrvIsect

int svxSkSplitIsect::CrvIsect

whether split at curve-curve intersections (0 = no, 1 = yes).default:1

Definition at line 493 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkSplitIsect::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkSplitIsect
Count
CrvIsect
idEnts
SelfIsect

◆ Count

int svxSkSplitIsect::Count

the number of the entities

Definition at line 490 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimExt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkTrimExt Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch trim or extend data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int numCrv
the number of the curve need to trim of extend More...
svxPntOnEnt * curves
the start points of the curves need to trim or extend More...
svxPntOnEnt dest
the destination point of the trim or extend More...
evxTrimExtension extension
the extension type.default:VX_EXT_ARC More...

Detailed Description

sketch trim or extend data

Definition at line 439 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimExt::curves

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimExt
curves
dest
extension
numCrv

◆ curves

svxPntOnEnt* svxSkTrimExt::curves

the start points of the curves need to trim or extend

Definition at line 442 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimExt::dest

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimExt
curves
dest
extension
numCrv

◆ dest

svxPntOnEnt svxSkTrimExt::dest

the destination point of the trim or extend

Definition at line 443 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimExt::numCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimExt
curves
dest
extension
numCrv

◆ numCrv

int svxSkTrimExt::numCrv

the number of the curve need to trim of extend

Definition at line 441 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimExt::extension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimExt
curves
dest
extension
numCrv

◆ extension

evxTrimExtension svxSkTrimExt::extension

the extension type.default:VX_EXT_ARC

Definition at line 444 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkTrimSplit Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch trim or split data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | count
the number of the entities More...
int * | idEnts
the id of the entities More...
int | numSeg
the number of segments More...
svxPntOnEnt * segments
the list points of segments More...
evxTrimSplit trimOption
the trim type.default:VX_SPLIT_DELETE More...

Detailed Description

sketch trim or split data

Definition at line 451 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit::segments

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplit
count
idEnts
numSeg
segments
trimOption

◆ segments

svxPntOnEnt* svxSkTrimSplit::segments

the list points of segments

Definition at line 456 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplit
count
idEnts
numSeg
segments
trimOption

◆ count

int svxSkTrimSplit::count

the number of the entities

Definition at line 453 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit::numSeg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplit
count
idEnts
numSeg
segments
trimOption

◆ numSeg

int svxSkTrimSplit::numSeg

the number of segments

Definition at line 455 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplit
count
idEnts
numSeg
segments
trimOption

◆ idEnts

int* svxSkTrimSplit::idEnts

the id of the entities

Definition at line 454 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplit::trimOption

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplit
count
idEnts
numSeg
segments
trimOption

◆ trimOption

evxTrimSplit svxSkTrimSplit::trimOption

the trim type.default:VX_SPLIT_DELETE

Definition at line 457 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitCor Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkTrimSplitCor Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch trim or split to corner data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxPntOnEnt firstPnt
the first point More...
svxPntOnEnt secondPnt
the second point More...
evxTrimSplitCor extension
the extension type.default:VX_SPLIT_COR_REFLECT More...

Detailed Description

sketch trim or split to corner data

Definition at line 477 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitCor::extension

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitCor
extension
firstPnt
secondPnt

◆ extension

evxTrimSplitCor svxSkTrimSplitCor::extension

the extension type.default:VX_SPLIT_COR_REFLECT

Definition at line 481 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitCor::firstPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitCor
extension
firstPnt
secondPnt

◆ firstPnt

svxPntOnEnt svxSkTrimSplitCor::firstPnt

the first point

Definition at line 479 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitCor::secondPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitCor
extension
firstPnt
secondPnt

◆ secondPnt

svxPntOnEnt svxSkTrimSplitCor::secondPnt

the second point

Definition at line 480 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSkTrimSplitPnt Struct Reference
Commands Creation » Sketch Commands » Sketch Commands Data

sketch trim or split at point data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

int | idCrv
the id of the curve More...
int | numPnt
the number of point More...
svxPntOnEnt * pnts
the list points More...
int | numSeg
the number of segments More...
svxPntOnEnt * segments
the list points of segments More...

Detailed Description

sketch trim or split at point data

Definition at line 464 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt::pnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitPnt
idCrv
numPnt
numSeg
pnts
segments

◆ pnts

svxPntOnEnt* svxSkTrimSplitPnt::pnts

the list points

Definition at line 468 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitPnt
idCrv
numPnt
numSeg
pnts
segments

◆ idCrv

int svxSkTrimSplitPnt::idCrv

the id of the curve

Definition at line 466 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt::segments

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitPnt
idCrv
numPnt
numSeg
pnts
segments

◆ segments

svxPntOnEnt* svxSkTrimSplitPnt::segments

the list points of segments

Definition at line 470 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt::numPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitPnt
idCrv
numPnt
numSeg
pnts
segments

◆ numPnt

int svxSkTrimSplitPnt::numPnt

the number of point

Definition at line 467 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSkTrimSplitPnt::numSeg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkTrimSplitPnt
idCrv
numPnt
numSeg
pnts
segments

◆ numSeg

int svxSkTrimSplitPnt::numSeg

the number of segments

Definition at line 469 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSketchData Struct Reference
Commands Creation » Part and Assembly Commands » Create Sketch Commands Data

sketch definition data More...

#include <zwapi_cmd_sk_create_data.h>

Data Fields

svxEntPath Plane
pick path of insertion to locate the sketch (datum plane,planar face,sketch) More...
int | RedefUpDir
whether to redefine Y-axis of sketch (0: use the default direction of the insertion plane 1: use input data to redefine the Y-axis of sketch) More...
int | idUpEnt
specify the entity used to define the Y-axis, 0 to ignore (edge,curve,axis,datum plane) More...
int | idUpParam
specify direction of Y-axis (0: use the positive direction of the edge or curve, or X-axis of datum plane 1: use the negative direction of the edge or curve, or Y-axis of datum plane) More...
svxVector UpDir
direction of Y-axis, can be ignored if idUpEnt > 0 More...
int | RedefOrigin
whether to redefine origin of sketch (0: use the default origin of the insertion plane 1: use centroid of the insertion plane as the origin of sketch 2: use input data to redefine the origin of sketch) More...
int | idOrgEnt
specify the parent entity where the origin locate, 0 to ignore (edge,curve,face,datum plane,point) More...
evxGeomCritPnt critPnt
specify the critical point of edge or curve More...
int | idPnt
id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING_POINT More...
svxPoint Origin
origin of sketch, can be ignored if idOrgEnt > 0 and use the critical point of entity More...
int | xDirRev
whether to reverse X-axis direction More...

Detailed Description

sketch definition data

Examples
part\skCrtTest.cpp.

Definition at line 32 of file zwapi_cmd_sk_create_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sk_create_data.h
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::xDirRev

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ xDirRev

int svxSketchData::xDirRev

whether to reverse X-axis direction

Examples
part\skCrtTest.cpp.

Definition at line 56 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::idUpEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ idUpEnt

int svxSketchData::idUpEnt

specify the entity used to define the Y-axis, 0 to ignore (edge,curve,axis,datum plane)

Examples
part\skCrtTest.cpp.

Definition at line 40 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::idUpParam

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ idUpParam

int svxSketchData::idUpParam

specify direction of Y-axis (0: use the positive direction of the edge or curve, or X-axis of datum plane 1: use the negative direction of the edge or curve, or Y-axis of datum plane)

Examples
part\skCrtTest.cpp.

Definition at line 41 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::Plane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ Plane

svxEntPath svxSketchData::Plane

pick path of insertion to locate the sketch (datum plane,planar face,sketch)

Examples
part\skCrtTest.cpp.

Definition at line 34 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::Origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ Origin

svxPoint svxSketchData::Origin

origin of sketch, can be ignored if idOrgEnt > 0 and use the critical point of entity

Examples
part\skCrtTest.cpp.

Definition at line 54 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::RedefOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ RedefOrigin

int svxSketchData::RedefOrigin

whether to redefine origin of sketch (0: use the default origin of the insertion plane 1: use centroid of the insertion plane as the origin of sketch 2: use input data to redefine the origin of sketch)

Examples
part\skCrtTest.cpp.

Definition at line 47 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::critPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ critPnt

evxGeomCritPnt svxSketchData::critPnt

specify the critical point of edge or curve

Definition at line 52 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::idPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ idPnt

int svxSketchData::idPnt

id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING_POINT

Definition at line 53 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::idOrgEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ idOrgEnt

int svxSketchData::idOrgEnt

specify the parent entity where the origin locate, 0 to ignore (edge,curve,face,datum plane,point)

Examples
part\skCrtTest.cpp.

Definition at line 51 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::UpDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ UpDir

svxVector svxSketchData::UpDir

direction of Y-axis, can be ignored if idUpEnt > 0

Examples
part\skCrtTest.cpp.

Definition at line 44 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSketchData::RedefUpDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSketchData
critPnt
idOrgEnt
idPnt
idUpEnt
idUpParam
Origin
Plane
RedefOrigin
RedefUpDir
UpDir
xDirRev

◆ RedefUpDir

int svxSketchData::RedefUpDir

whether to redefine Y-axis of sketch (0: use the default direction of the insertion plane 1: use input data to redefine the Y-axis of sketch)

Definition at line 37 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSlotConsData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSlotConsData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly slot constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

evxSlotConsType slotConsType
slot constraint type (VX_SLOT_CONS_FREE-default) More...
double | distance
distance from the end of the path (0.0-default) More...
double | percent
distance percent from the end of the path (0.0-default) More...
int | flip
whether to flip dimension (0-default) More...

Detailed Description

custom data for assembly slot constraint

Examples
part\asmConsTest.cpp.

Definition at line 346 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSlotConsData::slotConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSlotConsData
distance
flip
percent
slotConsType

◆ slotConsType

evxSlotConsType svxSlotConsData::slotConsType

slot constraint type (VX_SLOT_CONS_FREE-default)

Examples
part\asmConsTest.cpp.

Definition at line 348 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSlotConsData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSlotConsData
distance
flip
percent
slotConsType

◆ flip

int svxSlotConsData::flip

whether to flip dimension (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 351 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSlotConsData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSlotConsData
distance
flip
percent
slotConsType

◆ distance

double svxSlotConsData::distance

distance from the end of the path (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 349 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSlotConsData::percent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSlotConsData
distance
flip
percent
slotConsType

◆ percent

double svxSlotConsData::percent

distance percent from the end of the path (0.0-default)

Examples
part\asmConsTest.cpp.

Definition at line 350 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdAt Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

sheet metal attribute More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | dThick
thickness (1.0 as default) More...
double | dRadius
radius (5.0 as default) More...
evxSmdPosition position
sheet metal position.default:VX_POSITION_NATURAL More...
double | dOffset
specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore.default:0 More...
evxSmdBendLengthType lengthType
length type.default:VX_BEND_STANDARD_LENGTH More...
double | dLength
flange length.default:40 More...
evxSmdKFactorType kType
active sheet metal K factor type More...
double | dKFactor
K-Factor (0.41 as default) More...
double | dKBendDed
bend deduction.default:3.5 More...
double | dKBendAllow
bend allowance.default:8.5 More...
evxSmdRelief reliefType
relief type.default:VX_RELIEF_OBROUND More...
double | dWidRatio
relief width ratio.default:1.5 More...
double | dWidValue
relief width value.default:1 More...
double | dDepRatio
relief depth ratio.default:0 More...
double | dDepValue
relief depth value.default:1 More...
int | isCloseCorner
corner close type.default:0 More...
int | isMiter
corner miter type.default:1 More...
evxSmdCornerRelief reliefCorType
corner relief type.default:VX_CORNER_RELIEF_CLOSED More...
double | dCorGap
corner gap.default:0.1 More...
int | iCorOrigin
corner origin.default:0 More...
double | dCorOffset
corner offset.default:-1 More...
double | dCorLength
corner length.default:4 More...
double | dCorWidth
corner width.default:4 More...
double | dCorDiameter
corner diameter.default:4 More...
double | dCorAngle1
corner angle 1.default:30 More...
double | dCorAngle2
corner angle 2.default:30 More...
double | dFlatTol
flat tolerance.default:0.1 More...

Detailed Description

sheet metal attribute

Definition at line 98 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::reliefType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ reliefType

evxSmdRelief svxSmdAt::reliefType

relief type.default:VX_RELIEF_OBROUND

Definition at line 114 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dWidRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dWidRatio

double svxSmdAt::dWidRatio

relief width ratio.default:1.5

Definition at line 115 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dWidValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dWidValue

double svxSmdAt::dWidValue

relief width value.default:1

Definition at line 116 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorDiameter

double svxSmdAt::dCorDiameter

corner diameter.default:4

Definition at line 128 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dLength

double svxSmdAt::dLength

flange length.default:40

Definition at line 107 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::isCloseCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ isCloseCorner

int svxSmdAt::isCloseCorner

corner close type.default:0

Definition at line 120 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dDepRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dDepRatio

double svxSmdAt::dDepRatio

relief depth ratio.default:0

Definition at line 117 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ lengthType

evxSmdBendLengthType svxSmdAt::lengthType

length type.default:VX_BEND_STANDARD_LENGTH

Definition at line 106 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ position

evxSmdPosition svxSmdAt::position

sheet metal position.default:VX_POSITION_NATURAL

Definition at line 104 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::isMiter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ isMiter

int svxSmdAt::isMiter

corner miter type.default:1

Definition at line 121 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dThick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dThick

double svxSmdAt::dThick

thickness (1.0 as default)

Definition at line 101 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dDepValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dDepValue

double svxSmdAt::dDepValue

relief depth value.default:1

Definition at line 118 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:01 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ kType

evxSmdKFactorType svxSmdAt::kType

active sheet metal K factor type

Definition at line 109 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dRadius

double svxSmdAt::dRadius

radius (5.0 as default)

Definition at line 102 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorOffset

double svxSmdAt::dCorOffset

corner offset.default:-1

Definition at line 125 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dKBendAllow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dKBendAllow

double svxSmdAt::dKBendAllow

bend allowance.default:8.5

Definition at line 112 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorAngle2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorAngle2

double svxSmdAt::dCorAngle2

corner angle 2.default:30

Definition at line 130 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::iCorOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ iCorOrigin

int svxSmdAt::iCorOrigin

corner origin.default:0

Definition at line 124 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::reliefCorType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ reliefCorType

evxSmdCornerRelief svxSmdAt::reliefCorType

corner relief type.default:VX_CORNER_RELIEF_CLOSED

Definition at line 122 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorLength

double svxSmdAt::dCorLength

corner length.default:4

Definition at line 126 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dKFactor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dKFactor

double svxSmdAt::dKFactor

K-Factor (0.41 as default)

Definition at line 110 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dFlatTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dFlatTol

double svxSmdAt::dFlatTol

flat tolerance.default:0.1

Definition at line 132 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorWidth

double svxSmdAt::dCorWidth

corner width.default:4

Definition at line 127 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorAngle1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorAngle1

double svxSmdAt::dCorAngle1

corner angle 1.default:30

Definition at line 129 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dOffset

double svxSmdAt::dOffset

specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore.default:0

Definition at line 105 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dCorGap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dCorGap

double svxSmdAt::dCorGap

corner gap.default:0.1

Definition at line 123 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdAt::dKBendDed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdAt
dCorAngle1
dCorAngle2
dCorDiameter
dCorGap
dCorLength
dCorOffset
dCorWidth
dDepRatio
dDepValue
dFlatTol
dKBendAllow
dKBendDed
dKFactor
dLength
dOffset
dRadius
dThick
dWidRatio
dWidValue
iCorOrigin
isCloseCorner
isMiter
kType
lengthType
position
reliefCorType
reliefType

◆ dKBendDed

double svxSmdAt::dKBendDed

bend deduction.default:3.5

Definition at line 111 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdBendTaperData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd bend taper data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idBend
Select a bend face to taper one or both sides of the flange. The edges of the flange are tapered in the direction of the arrow. More...
int | opposite
Check(opposite=1) this box to flip the arrows, and system will reset the stationary face.default:0
More...
evxSmdTaperSideMethod method
Specify the side you want to taper.default:VX_SMD_TAPER_SIDES_BOTH. More...
svxSmdBendTaperDefData defData
bend taper definition side data More...
svxSmdBendTaperDefData defData2
apply it if method = VX_SMD_TAPER_SIDES_BOTH,else ignore it. More...

Detailed Description

template command Smd bend taper data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 903 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData::defData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperData
defData
defData2
idBend
method
opposite

◆ defData

svxSmdBendTaperDefData svxSmdBendTaperData::defData

bend taper definition side data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 909 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData::defData2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperData
defData
defData2
idBend
method
opposite

◆ defData2

svxSmdBendTaperDefData svxSmdBendTaperData::defData2

apply it if method = VX_SMD_TAPER_SIDES_BOTH,else ignore it.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 910 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData::opposite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperData
defData
defData2
idBend
method
opposite

◆ opposite

int svxSmdBendTaperData::opposite

Check(opposite=1) this box to flip the arrows, and system will reset the stationary face.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 907 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperData
defData
defData2
idBend
method
opposite

◆ method

evxSmdTaperSideMethod svxSmdBendTaperData::method

Specify the side you want to taper.default:VX_SMD_TAPER_SIDES_BOTH.

Definition at line 908 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperData::idBend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperData
defData
defData2
idBend
method
opposite

◆ idBend

int svxSmdBendTaperData::idBend

Select a bend face to taper one or both sides of the flange. The edges of the flange are tapered in the direction of the arrow.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 905 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdBendTaperDefData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

smd bend taper definition side data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxSmdTaperDefInfos
union of smd bend taper definition data More...

Data Fields

int | taperType
0 is linear,Use an angle value or a distance value to taper the bend.
1 is tangent,Use a distance value to taper the bend. The edge of the bend is tangent to the web. default:0. More...
union svxSmdBendTaperDefData::uvxSmdTaperDefInfos | inpUnion
evxSmdWebTaperType webTaperType
Creates tapers that start from the web.default:VX_SMD_TAPER_WEB_NONE. More...
double | angle
apply it if webTaperType != VX_SMD_TAPER_WEB_NONE, else ignore it.default:5 More...

Detailed Description

smd bend taper definition side data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 860 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdLinear
Data Fields
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear Struct Reference

smd linear data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | method
0 is setback,Specify a distance value to taper the bend.
1 is end radius,Specify an angle value to taper the bend. default:0 More...
double | value
Angle or setback.default:5. More...

Detailed Description

smd linear data

<

Definition at line 867 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdLinear
method
value

◆ method

int svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::method

0 is setback,Specify a distance value to taper the bend.
1 is end radius,Specify an angle value to taper the bend. default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 869 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdLinear
method
value

◆ value

double svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::value

Angle or setback.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 872 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdTangent
Data Fields
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent Struct Reference

smd tangent data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | setback
Specify the distance value to taper.default:5. More...
int | isAutoCompute
1 is auto compute radius,else 0. default:1 More...
double | sRadius
start radius. apply it if isAutoCompute=0. default:2 More...
double | eRadius
end radius. apply it if isAutoCompute=0. default:2 More...

Detailed Description

smd tangent data

<

Definition at line 874 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::isAutoCompute

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdTangent
eRadius
isAutoCompute
setback
sRadius

◆ isAutoCompute

int svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::isAutoCompute

1 is auto compute radius,else 0. default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 877 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::eRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdTangent
eRadius
isAutoCompute
setback
sRadius

◆ eRadius

double svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::eRadius

end radius. apply it if isAutoCompute=0. default:2

Examples
part\smdFtrCrtTest.cpp.

Definition at line 879 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::sRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdTangent
eRadius
isAutoCompute
setback
sRadius

◆ sRadius

double svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::sRadius

start radius. apply it if isAutoCompute=0. default:2

Examples
part\smdFtrCrtTest.cpp.

Definition at line 878 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::setback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
  • svxSmdTangent
eRadius
isAutoCompute
setback
sRadius

◆ setback

double svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::setback

Specify the distance value to taper.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 876 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
angle
taperType
webTaperType

◆ angle

double svxSmdBendTaperDefData::angle

apply it if webTaperType != VX_SMD_TAPER_WEB_NONE, else ignore it.default:5

Examples
part\smdFtrCrtTest.cpp.

Definition at line 884 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::webTaperType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
angle
taperType
webTaperType

◆ webTaperType

evxSmdWebTaperType svxSmdBendTaperDefData::webTaperType

Creates tapers that start from the web.default:VX_SMD_TAPER_WEB_NONE.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 883 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::taperType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
angle
taperType
webTaperType

◆ taperType

int svxSmdBendTaperDefData::taperType

0 is linear,Use an angle value or a distance value to taper the bend.
1 is tangent,Use a distance value to taper the bend. The edge of the bend is tangent to the web. default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 862 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdChangeBendData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd change bend data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxSmdChangeBend
union of smd change bend data More...

Data Fields

evxSmdChangeBendType type
Specify change bend type from the following.default:VX_SMD_CHANGE_BEND_DEFAULT. More...
int | cnt
count of bendFcs More...
int * | bendFcs
Select the bend faces to change. More...
double | radius
Set the radius of bends.default:5. More...
union svxSmdChangeBendData::uvxSmdChangeBend | inpUnion

Detailed Description

template command Smd change bend data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1263 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendDefault
Data Fields
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault Struct Reference

VX_SMD_CHANGE_BEND_DEFAULT. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | angle
Set the angle of bends.default:90. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

VX_SMD_CHANGE_BEND_DEFAULT.

<

Definition at line 1271 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendDefault
angle
isUseGlobal
kType
kValue

◆ angle

double svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::angle

Set the angle of bends.default:90.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1273 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendDefault
angle
isUseGlobal
kType
kValue

◆ kType

evxSmdKFactorType svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1275 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendDefault
angle
isUseGlobal
kType
kValue

◆ kValue

double svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1276 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendDefault
angle
isUseGlobal
kType
kValue

◆ isUseGlobal

int svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1274 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendFold
Data Fields
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold Struct Reference

VX_SMD_CHANGE_BEND_FOLD_LENGTH. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

VX_SMD_CHANGE_BEND_FOLD_LENGTH.

<

Definition at line 1278 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendFold
isUseGlobal
kType
kValue

◆ kValue

double svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1282 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendFold
isUseGlobal
kType
kValue

◆ isUseGlobal

int svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1280 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendFold
isUseGlobal
kType
kValue

◆ kType

evxSmdKFactorType svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1281 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendUnfold
Data Fields
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold Struct Reference

VX_SMD_CHANGE_BEND_UNFOLD_LENGTH. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | stationary
This face remains stationary when the part is folded or unfolded. More...
double | angle
Set the angle of bends.default:90. More...

Detailed Description

VX_SMD_CHANGE_BEND_UNFOLD_LENGTH.

<

Definition at line 1284 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::stationary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendUnfold
angle
stationary

◆ stationary

int svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::stationary

This face remains stationary when the part is folded or unfolded.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1286 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
  • svxChangeBendUnfold
angle
stationary

◆ angle

double svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::angle

Set the angle of bends.default:90.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1287 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::bendFcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
bendFcs
cnt
radius
type

◆ bendFcs

int* svxSmdChangeBendData::bendFcs

Select the bend faces to change.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1267 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
bendFcs
cnt
radius
type

◆ cnt

int svxSmdChangeBendData::cnt

count of bendFcs

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1266 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
bendFcs
cnt
radius
type

◆ type

evxSmdChangeBendType svxSmdChangeBendData::type

Specify change bend type from the following.default:VX_SMD_CHANGE_BEND_DEFAULT.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1265 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
bendFcs
cnt
radius
type

◆ radius

double svxSmdChangeBendData::radius

Set the radius of bends.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1268 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdExtendFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Extend Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxExtFlangeData
union of smd extend flange data More...

Data Fields

evxSmdExtendFlangeMethod type
extend type.default:VX_SMD_EXTEND_BY_VALUE More...
int | idEdge
Select a edge to extend. More...
union svxSmdExtendFlangeData::uvxExtFlangeData | inpUnion
evxSmdExtendSideMethod sideType1
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_SIDE_NORMAL. More...
int | extendSrfToEdge1
Check this box to extend the bend adjacent to the edge together.default:0. More...
evxSmdExtendSideMethod sideType2
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_SIDE_NORMAL. More...
int | extendSrfToEdge2
Check this box to extend the bend adjacent to the edge together.default:0. More...

Detailed Description

template command Smd Extend Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 816 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
  • uvxExtFlangeData
  • svxExtFlangeData
Data Fields
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData Struct Reference

apply it if type != VX_SMD_EXTEND_BY_VALUE More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idPlane
Specify a plane or datum as reference object. More...
double | offset
Specify the distance between the plane and the edge.default:0 The flange will extend beyond the plane when you enter a negative number.
More...

Detailed Description

apply it if type != VX_SMD_EXTEND_BY_VALUE

<

Definition at line 826 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
  • uvxExtFlangeData
  • svxExtFlangeData
idPlane
offset

◆ idPlane

int svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::idPlane

Specify a plane or datum as reference object.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 828 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
  • uvxExtFlangeData
  • svxExtFlangeData
idPlane
offset

◆ offset

double svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::offset

Specify the distance between the plane and the edge.default:0 The flange will extend beyond the plane when you enter a negative number.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 829 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::extendSrfToEdge2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ extendSrfToEdge2

int svxSmdExtendFlangeData::extendSrfToEdge2

Check this box to extend the bend adjacent to the edge together.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 839 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ type

evxSmdExtendFlangeMethod svxSmdExtendFlangeData::type

extend type.default:VX_SMD_EXTEND_BY_VALUE

Examples
part\smdFtrCrtTest.cpp.

Definition at line 818 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ idEdge

int svxSmdExtendFlangeData::idEdge

Select a edge to extend.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 819 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::sideType2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ sideType2

evxSmdExtendSideMethod svxSmdExtendFlangeData::sideType2

Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_SIDE_NORMAL.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 837 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::sideType1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ sideType1

evxSmdExtendSideMethod svxSmdExtendFlangeData::sideType1

Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_SIDE_NORMAL.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 834 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::extendSrfToEdge1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
extendSrfToEdge1
extendSrfToEdge2
idEdge
sideType1
sideType2
type

◆ extendSrfToEdge1

int svxSmdExtendFlangeData::extendSrfToEdge1

Check this box to extend the bend adjacent to the edge together.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 836 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdExtrudeTabData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Extrude Tab data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idProfile
id of profile More...
double * | Thickness
thickness. NULL to use global default More...
int | isMerge
1 if merge, else 0 as default More...
int | isOpposite
1 if opposite the direction of the tab, else 0 as default More...
int | idMergeShape
id of the shape to be merged. Note:since 2700, this parameter must be set, if you don't set this parameter before, you can find the shape where the profile is located as the base shape. More...

Detailed Description

template command Smd Extrude Tab data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 201 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData::isOpposite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtrudeTabData
idMergeShape
idProfile
isMerge
isOpposite
Thickness

◆ isOpposite

int svxSmdExtrudeTabData::isOpposite

1 if opposite the direction of the tab, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 206 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtrudeTabData
idMergeShape
idProfile
isMerge
isOpposite
Thickness

◆ idProfile

int svxSmdExtrudeTabData::idProfile

id of profile

Examples
part\smdFtrCrtTest.cpp.

Definition at line 203 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData::isMerge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtrudeTabData
idMergeShape
idProfile
isMerge
isOpposite
Thickness

◆ isMerge

int svxSmdExtrudeTabData::isMerge

1 if merge, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 205 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData::Thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtrudeTabData
idMergeShape
idProfile
isMerge
isOpposite
Thickness

◆ Thickness

double* svxSmdExtrudeTabData::Thickness

thickness. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 204 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtrudeTabData::idMergeShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtrudeTabData
idMergeShape
idProfile
isMerge
isOpposite
Thickness

◆ idMergeShape

int svxSmdExtrudeTabData::idMergeShape

id of the shape to be merged. Note:since 2700, this parameter must be set, if you don't set this parameter before, you can find the shape where the profile is located as the base shape.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 207 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | count
count of idEdges More...
int * | idEdges
list of idEdges More...
int | widthType
width type: 0 = use start and end, 1 = use start and length, default = 0 More...
double | start
start More...
double | end
end More...
double | length
length More...
int | isFlip
flip flanges direction: 1 = flip, default = 0 More...
evxSmdPosition position
flange parameters position. default = global value More...
double | positionOffset
position offset. if position = VX_POSITION_OFFSET, apply it. default = global value More...
evxSmdBendType bendType
bend type. default = VX_BEND_SIMPLE More...
double | radius1
radius1. default = global value More...
double | radius2
radius2. default = global value More...
double | length1
length1 More...
double | length2
length2 More...
double | angle
angle More...
double | height
height More...
evxSmdBendLengthType lengthType
length type. default = global value More...
int | sBendSize
s bend size. 0 = use height, 1 = use length2, default = 0 More...
int | isEqualR
judge if radius2 equals radius1. 1 = equal, default = 0 More...
int | isTrim
trim adjacent bends. 1 = trim, default = 0 More...
int | idProfile
id of profile More...
evxSmdKFactorType kType
k-factor definition type. default = global value K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double | kValue
k_factor depends on kType. default = global value More...
int | isRelief
relief for insufficient length. 1 = relief, default = 0 More...
int | isDefine
define each side separately. 0 = use startRelief only, 1 = use both startRelief and endRelief, default = 0 More...
svxSmdReliefData startRelief
relief of start. default = global value More...
svxSmdReliefData endRelief
relief of end. default = global value More...
int | isResolve
resolve flange interface. 1 = resolve, default = 0 More...
double | interfaceGap
interface gap. default = 0.5 More...
double | interfaceOffset
interface offset. default = 0.5 More...
int | interfaceType
interface type. 1 = open, 0 = closed, default = 0 More...
int | isCorner
1 = close corner, 0 = ignore corner attributes, default = global value.
More...
int | isMiter
1 = miter corner, default = global value. if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern if set to 1, use curves to form the outli8ne of the cuter which is trying to meet the defined Gap around the corner. More...
evxSmdCornerRelief corRelief
corner relief type. default = global value More...
double | corGap
corner Gap. default = global value More...
int | corOrigin
0 = bend center, 1 = corner point. default = global value More...
double | corOffset
offset. default = global value More...
double | corLength
length. default = global value More...
double | corWidth
width. default = global value More...
double | corDiameter
diameter. default = global value More...
double | corAngle1
angle 1. default = global value More...
double | corAngle2
angle 2. default = global value More...
double | tol
Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.) default = global value. More...

Detailed Description

template command Smd Flange data

Definition at line 256 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isResolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isResolve

int svxSmdFlangeData::isResolve

resolve flange interface. 1 = resolve, default = 0

Definition at line 315 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::interfaceOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ interfaceOffset

double svxSmdFlangeData::interfaceOffset

interface offset. default = 0.5

Definition at line 317 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corAngle2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corAngle2

double svxSmdFlangeData::corAngle2

angle 2. default = global value

Definition at line 340 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ kValue

double svxSmdFlangeData::kValue

k_factor depends on kType. default = global value

Definition at line 307 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corGap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corGap

double svxSmdFlangeData::corGap

corner Gap. default = global value

Definition at line 333 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corDiameter

double svxSmdFlangeData::corDiameter

diameter. default = global value

Definition at line 338 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::endRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ endRelief

svxSmdReliefData svxSmdFlangeData::endRelief

relief of end. default = global value

Definition at line 313 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ height

double svxSmdFlangeData::height

height

Definition at line 290 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isMiter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isMiter

int svxSmdFlangeData::isMiter

1 = miter corner, default = global value. if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern if set to 1, use curves to form the outli8ne of the cuter which is trying to meet the defined Gap around the corner.

Definition at line 329 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::widthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ widthType

int svxSmdFlangeData::widthType

width type: 0 = use start and end, 1 = use start and length, default = 0

Definition at line 261 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::bendType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ bendType

evxSmdBendType svxSmdFlangeData::bendType

bend type. default = VX_BEND_SIMPLE

Definition at line 284 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corLength

double svxSmdFlangeData::corLength

length. default = global value

Definition at line 336 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ radius1

double svxSmdFlangeData::radius1

radius1. default = global value

Definition at line 285 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corAngle1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corAngle1

double svxSmdFlangeData::corAngle1

angle 1. default = global value

Definition at line 339 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ idEdges

int* svxSmdFlangeData::idEdges

list of idEdges

Definition at line 260 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corOffset

double svxSmdFlangeData::corOffset

offset. default = global value

Definition at line 335 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::startRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ startRelief

svxSmdReliefData svxSmdFlangeData::startRelief

relief of start. default = global value

Definition at line 312 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::sBendSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ sBendSize

int svxSmdFlangeData::sBendSize

s bend size. 0 = use height, 1 = use length2, default = 0

Definition at line 292 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corRelief

evxSmdCornerRelief svxSmdFlangeData::corRelief

corner relief type. default = global value

Definition at line 332 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::interfaceGap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ interfaceGap

double svxSmdFlangeData::interfaceGap

interface gap. default = 0.5

Definition at line 316 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ kType

evxSmdKFactorType svxSmdFlangeData::kType

k-factor definition type. default = global value K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Definition at line 304 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ position

evxSmdPosition svxSmdFlangeData::position

flange parameters position. default = global value

Definition at line 267 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isFlip

int svxSmdFlangeData::isFlip

flip flanges direction: 1 = flip, default = 0

Definition at line 265 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ angle

double svxSmdFlangeData::angle

angle

Definition at line 289 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::end

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ end

double svxSmdFlangeData::end

end

Definition at line 263 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::length2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ length2

double svxSmdFlangeData::length2

length2

Definition at line 288 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::length1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ length1

double svxSmdFlangeData::length1

length1

Definition at line 287 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::positionOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ positionOffset

double svxSmdFlangeData::positionOffset

position offset. if position = VX_POSITION_OFFSET, apply it. default = global value

Definition at line 268 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ radius2

double svxSmdFlangeData::radius2

radius2. default = global value

Definition at line 286 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isTrim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isTrim

int svxSmdFlangeData::isTrim

trim adjacent bends. 1 = trim, default = 0

Definition at line 294 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isEqualR

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isEqualR

int svxSmdFlangeData::isEqualR

judge if radius2 equals radius1. 1 = equal, default = 0

Definition at line 293 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ length

double svxSmdFlangeData::length

length

Definition at line 264 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corOrigin

int svxSmdFlangeData::corOrigin

0 = bend center, 1 = corner point. default = global value

Definition at line 334 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isDefine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isDefine

int svxSmdFlangeData::isDefine

define each side separately. 0 = use startRelief only, 1 = use both startRelief and endRelief, default = 0

Definition at line 310 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isCorner

int svxSmdFlangeData::isCorner

1 = close corner, 0 = ignore corner attributes, default = global value.

Definition at line 328 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::corWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ corWidth

double svxSmdFlangeData::corWidth

width. default = global value

Definition at line 337 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ count

int svxSmdFlangeData::count

count of idEdges

Definition at line 259 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ tol

double svxSmdFlangeData::tol

Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.) default = global value.

Definition at line 342 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ lengthType

evxSmdBendLengthType svxSmdFlangeData::lengthType

length type. default = global value

Definition at line 291 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::interfaceType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ interfaceType

int svxSmdFlangeData::interfaceType

interface type. 1 = open, 0 = closed, default = 0

Definition at line 318 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ start

double svxSmdFlangeData::start

start

Definition at line 262 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ idProfile

int svxSmdFlangeData::idProfile

id of profile

Definition at line 295 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeData::isRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeData
angle
bendType
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
end
endRelief
height
idEdges
idProfile
interfaceGap
interfaceOffset
interfaceType
isCorner
isDefine
isEqualR
isFlip
isMiter
isRelief
isResolve
isTrim
kType
kValue
length
length1
length2
lengthType
position
positionOffset
radius1
radius2
sBendSize
start
startRelief
tol
widthType

◆ isRelief

int svxSmdFlangeData::isRelief

relief for insufficient length. 1 = relief, default = 0

Definition at line 309 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdFlangeProfData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Flange with Profile data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idEdge
id of edge More...
int * | idProfile
id of profile, NULL to ignore More...
evxSmdPosition * position
position type. NULL to use global default More...
double * | offset
offset, specify the offset value of the flange. if *position = VX_POSITION_OFFSET, using this. NULL to use global default More...
double * | radius
radius. NULL to use global default More...
double | angle
angle (0-180). 90 as default More...
evxSmdBendLengthType * lengthType
length type. NULL to use global default More...
double * | length
length. NULL to use global default More...
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double * | kValue
k_factor. NULL to use global default More...
int | isRelief
1 if relief for insufficient length , else 0 as default if set to 1, user can create relief for partial flange even the length between the bound of the flange and the end of the picked edge which is insufficient. More...
int | isDefSepa
1 if define each side separately ,else 0 as default More...
svxSmdReliefData * startRelief
relief of start More...
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this More...
double * | tol
Flat Tolerance. NULL to use global default. More...

Detailed Description

template command Smd Flange with Profile data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 416 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::isRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ isRelief

int svxSmdFlangeProfData::isRelief

1 if relief for insufficient length , else 0 as default if set to 1, user can create relief for partial flange even the length between the bound of the flange and the end of the picked edge which is insufficient.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 434 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ radius

double* svxSmdFlangeProfData::radius

radius. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 424 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ idEdge

int svxSmdFlangeProfData::idEdge

id of edge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 418 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::isDefSepa

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ isDefSepa

int svxSmdFlangeProfData::isDefSepa

1 if define each side separately ,else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 437 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ tol

double* svxSmdFlangeProfData::tol

Flat Tolerance. NULL to use global default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 441 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ lengthType

evxSmdBendLengthType* svxSmdFlangeProfData::lengthType

length type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 426 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ length

double* svxSmdFlangeProfData::length

length. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 427 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ offset

double* svxSmdFlangeProfData::offset

offset, specify the offset value of the flange. if *position = VX_POSITION_OFFSET, using this. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 421 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ idProfile

int* svxSmdFlangeProfData::idProfile

id of profile, NULL to ignore

Examples
part\smdFtrCrtTest.cpp.

Definition at line 419 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ position

evxSmdPosition* svxSmdFlangeProfData::position

position type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 420 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::startRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ startRelief

svxSmdReliefData* svxSmdFlangeProfData::startRelief

relief of start

Examples
part\smdFtrCrtTest.cpp.

Definition at line 438 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ kValue

double* svxSmdFlangeProfData::kValue

k_factor. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 432 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ angle

double svxSmdFlangeProfData::angle

angle (0-180). 90 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 425 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ kType

evxSmdKFactorType* svxSmdFlangeProfData::kType

k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 429 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlangeProfData::endRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlangeProfData
angle
endRelief
idEdge
idProfile
isDefSepa
isRelief
kType
kValue
length
lengthType
offset
position
radius
startRelief
tol

◆ endRelief

svxSmdReliefData* svxSmdFlangeProfData::endRelief

relief of end. if isDefineSeparately = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 439 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdFlattenData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd flatten data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idShape
shape id More...
int | idFace
Select the bend faces to flatten.0/-1 to ignore it. More...
double | offset
Set the offset distance between the flatten entity and the flatten pattern.default:20. More...
int | useDir
1 is use direction, else 0.default:0 More...
svxVector direction
Select the direction for offset. More...
int | includePattern
Check(=1) this option if user wants to quickly project to the generated flat view of sheet metal model by the flat pattern. Flatten pattern can be exported as DWG or DXF for applying to other production process. default:0. More...
int | ignoreTangent
Check(=1) this option if user wants to adjsut the tangent edges from flat pattern that can be shown or hidden.default:0. if includePattern = 0, the ignoreTangent can't be changed. if includePattern = 1, the ignoreTangent can be given by user. More...
int | useDirPMI
1 is use PMI direction, else 0. default:0 More...
svxVector dirPMI
linear PMI direction. More...

Detailed Description

template command Smd flatten data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1207 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::includePattern

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ includePattern

int svxSmdFlattenData::includePattern

Check(=1) this option if user wants to quickly project to the generated flat view of sheet metal model by the flat pattern. Flatten pattern can be exported as DWG or DXF for applying to other production process. default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1214 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ offset

double svxSmdFlattenData::offset

Set the offset distance between the flatten entity and the flatten pattern.default:20.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1211 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::dirPMI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ dirPMI

svxVector svxSmdFlattenData::dirPMI

linear PMI direction.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1223 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ idFace

int svxSmdFlattenData::idFace

Select the bend faces to flatten.0/-1 to ignore it.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1210 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::ignoreTangent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ ignoreTangent

int svxSmdFlattenData::ignoreTangent

Check(=1) this option if user wants to adjsut the tangent edges from flat pattern that can be shown or hidden.default:0. if includePattern = 0, the ignoreTangent can't be changed. if includePattern = 1, the ignoreTangent can be given by user.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1218 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ idShape

int svxSmdFlattenData::idShape

shape id

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1209 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ direction

svxVector svxSmdFlattenData::direction

Select the direction for offset.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1213 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::useDirPMI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ useDirPMI

int svxSmdFlattenData::useDirPMI

1 is use PMI direction, else 0. default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1222 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFlattenData::useDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFlattenData
direction
dirPMI
idFace
idShape
ignoreTangent
includePattern
offset
useDir
useDirPMI

◆ useDir

int svxSmdFlattenData::useDir

1 is use direction, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1212 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdFoldByLineData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Fold by Line data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idLine
Select a line. It can be a 3 dimensional line or a sketch line. More...
int | idProfile
id of sketch, if idLine is one curve of the sketch (-1/0 if idLine is a line or a sketch) More...
int | idFace
Specify the plane face where inner bends are created. More...
int | flipSide
bend direction, 1- flip side to keep, else 0 (default:0) More...
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER. More...
double | angle
Specify the bend angle.default:90. More...
double | radius
Specify the inner radius value of bend.default:5. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

template command Smd Fold by Line data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 751 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ isUseGlobal

int svxSmdFoldByLineData::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 760 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ radius

double svxSmdFoldByLineData::radius

Specify the inner radius value of bend.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 759 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ position

evxSmdJogPosition svxSmdFoldByLineData::position

Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 757 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ angle

double svxSmdFoldByLineData::angle

Specify the bend angle.default:90.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 758 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ idProfile

int svxSmdFoldByLineData::idProfile

id of sketch, if idLine is one curve of the sketch (-1/0 if idLine is a line or a sketch)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 754 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::flipSide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ flipSide

int svxSmdFoldByLineData::flipSide

bend direction, 1- flip side to keep, else 0 (default:0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 756 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ kValue

double svxSmdFoldByLineData::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 762 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::idLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ idLine

int svxSmdFoldByLineData::idLine

Select a line. It can be a 3 dimensional line or a sketch line.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 753 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ kType

evxSmdKFactorType svxSmdFoldByLineData::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 761 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFoldByLineData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFoldByLineData
angle
flipSide
idFace
idLine
idProfile
isUseGlobal
kType
kValue
position
radius

◆ idFace

int svxSmdFoldByLineData::idFace

Specify the plane face where inner bends are created.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 755 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdFullFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Full Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | count
count of "idEdges" More...
int * | idEdges
list of idEdge More...
int | isFlip
indicate flange direction: 1 if flip the flanges, else 0 as default More...
evxSmdPosition * position
flange parameters position. NULL to use global default More...
double * | offset
offset, if position = VX_POSITION_OFFSET,apply it. NULL to use global default More...
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double * | kValue
k_factor. NULL to use global default More...
double * | tol
Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.) NULL to use global default. More...
int | isResolve
1 if resolve flange interference ,else 0 as default 1-to make the flanges not intersect when the created flanges are intersected. More...
double | gap
Gap. 0.5 is default. More...
int | bend
bend, 0 if simple, 1 if S bend. default is 0 More...
double * | radius1
radius r1. NULL to use global default More...
double | angle
angle (> 0). 90 as default More...
evxSmdBendLengthType * lengthType
length type. NULL to use global default More...
double * | length
length. NULL to use global default More...
double * | radius2
radius r2, if bend = 0, ignore this. NULL to use global default More...
int | sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this. More...
double | Size
size (height or length), if bend = 0, ignore this More...
int | isDefSepa
1 if define each side separately, else 0 as default More...
svxSmdReliefData * startRelief
relief of start More...
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this More...
evxSmdCornerRelief * corRelief
corner relief type. NULL to use global default More...
int * | isCorner
1 if close corner, else 0.
NULL to use global default
if isCorner = 0, ignore the following variables More...
int * | isMiter
1 if miter corner, else 0. NULL to use global default
if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern
if set to 1, use curves to form the outli8ne of the cuter which is trying to meet the defined Gap around the corner. More...
double * | corGap
corner Gap. NULL to use global default More...
int * | corOrigin
0 is bend center, 1 is corner point. NULL to use global default More...
double * | corOffset
offset. NULL to use global default More...
double * | corLength
length. NULL to use global default More...
double * | corWidth
width. NULL to use global default More...
double * | corDiameter
diameter. NULL to use global default More...
double * | corAngle1
angle 1. NULL to use global default More...
double * | corAngle2
angle 2. NULL to use global default More...

Detailed Description

template command Smd Full Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 353 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::isDefSepa

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ isDefSepa

int svxSmdFullFlangeData::isDefSepa

1 if define each side separately, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 379 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corOffset

double* svxSmdFullFlangeData::corOffset

offset. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 404 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ gap

double svxSmdFullFlangeData::gap

Gap. 0.5 is default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 368 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ kValue

double* svxSmdFullFlangeData::kValue

k_factor. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 363 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ idEdges

int* svxSmdFullFlangeData::idEdges

list of idEdge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 356 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ radius1

double* svxSmdFullFlangeData::radius1

radius r1. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 371 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ radius2

double* svxSmdFullFlangeData::radius2

radius r2, if bend = 0, ignore this. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 375 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ position

evxSmdPosition* svxSmdFullFlangeData::position

flange parameters position. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 358 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corDiameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corDiameter

double* svxSmdFullFlangeData::corDiameter

diameter. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 407 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ lengthType

evxSmdBendLengthType* svxSmdFullFlangeData::lengthType

length type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 373 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ kType

evxSmdKFactorType* svxSmdFullFlangeData::kType

k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 360 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::startRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ startRelief

svxSmdReliefData* svxSmdFullFlangeData::startRelief

relief of start

Examples
part\smdFtrCrtTest.cpp.

Definition at line 380 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::endRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ endRelief

svxSmdReliefData* svxSmdFullFlangeData::endRelief

relief of end. if isDefineSeparately = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 381 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ length

double* svxSmdFullFlangeData::length

length. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 374 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::isMiter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ isMiter

int* svxSmdFullFlangeData::isMiter

1 if miter corner, else 0. NULL to use global default
if set to 0, use straight lines to form the outline of the cuter which is going to cut the corner on the unfold pattern
if set to 1, use curves to form the outli8ne of the cuter which is trying to meet the defined Gap around the corner.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 399 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corOrigin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corOrigin

int* svxSmdFullFlangeData::corOrigin

0 is bend center, 1 is corner point. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 403 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corWidth

double* svxSmdFullFlangeData::corWidth

width. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 406 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::isResolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ isResolve

int svxSmdFullFlangeData::isResolve

1 if resolve flange interference ,else 0 as default 1-to make the flanges not intersect when the created flanges are intersected.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 366 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corRelief

evxSmdCornerRelief* svxSmdFullFlangeData::corRelief

corner relief type. NULL to use global default

     evxSmdCornerRelief               |     the following variables is valid
VX_CORNER_RELIEF_CLOSED               |  isMiter,corGap
VX_CORNER_RELIEF_CIRCULAR_CUTOUT      |  isMiter,corGap,corOrigin,corOffset,corDiameter
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT   |  isMiter,corGap,corOrigin,corOffset,corLength,corWidth
VX_CORNER_RELIEF_U_CUTOUT             |  isMiter,corGap,corOrigin,corOffset,corDiameter
VX_CORNER_RELIEF_V_CUTOUT             |  isMiter,corGap,corOrigin,corOffset,corDiameter,corAngle1,corAngle2
Examples
part\smdFtrCrtTest.cpp.

Definition at line 395 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corAngle1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corAngle1

double* svxSmdFullFlangeData::corAngle1

angle 1. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 408 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corGap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corGap

double* svxSmdFullFlangeData::corGap

corner Gap. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 402 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::isCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ isCorner

int* svxSmdFullFlangeData::isCorner

1 if close corner, else 0.
NULL to use global default
if isCorner = 0, ignore the following variables

Examples
part\smdFtrCrtTest.cpp.

Definition at line 396 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::sBendSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ sBendSize

int svxSmdFullFlangeData::sBendSize

S bend size (1 is length, 0 is height), if bend = 0, ignore this.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 376 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ count

int svxSmdFullFlangeData::count

count of "idEdges"

Examples
part\smdFtrCrtTest.cpp.

Definition at line 355 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ tol

double* svxSmdFullFlangeData::tol

Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.) NULL to use global default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 364 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::isFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ isFlip

int svxSmdFullFlangeData::isFlip

indicate flange direction: 1 if flip the flanges, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 357 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ offset

double* svxSmdFullFlangeData::offset

offset, if position = VX_POSITION_OFFSET,apply it. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 359 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corLength

double* svxSmdFullFlangeData::corLength

length. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 405 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ angle

double svxSmdFullFlangeData::angle

angle (> 0). 90 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 372 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::Size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ Size

double svxSmdFullFlangeData::Size

size (height or length), if bend = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 377 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::corAngle2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ corAngle2

double* svxSmdFullFlangeData::corAngle2

angle 2. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 409 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdFullFlangeData::bend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdFullFlangeData
angle
bend
corAngle1
corAngle2
corDiameter
corGap
corLength
corOffset
corOrigin
corRelief
corWidth
count
endRelief
gap
idEdges
isCorner
isDefSepa
isFlip
isMiter
isResolve
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
startRelief
tol

◆ bend

int svxSmdFullFlangeData::bend

bend, 0 if simple, 1 if S bend. default is 0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 370 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdHemFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Hem Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxSmdHemData
union of smd hem data More...

Data Fields

int | hemType
0 is Full hem, 1 is Partial hem. default is 0 More...
int | isFlip
1 if flip the hems, else 0 as default More...
union svxSmdHemFlangeData::uvxSmdHemData | hemData
evxSmdPosition * position
position type. NULL to use global default More...
double * | offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default More...
evxSmdHemBendType bendType
bend type. default is VX_SMD_HEM_BEND_CLOSED More...
int | isEqual
1 if equal radii ,else 0 as default More...
double | length1
Length L1. More...
double | length2
Length L2. More...
double * | radius1
Radius R1. NULL to use global default. More...
double * | radius2
Radius R2. NULL to use global default. More...
double | angle
angle( >1). 270 as default More...
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double * | kValue
k_factor. NULL to use global default More...
int | isDefSepa
1 if define each side separately ,else 0 as default More...
svxSmdReliefData * startRelief
relief of start More...
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this More...

Detailed Description

template command Smd Hem Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 501 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdFullHemData
Data Fields
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData Struct Reference

if hemType = 0, using the following variables More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | count
count of idEdges More...
int * | idEdges
list of idEdge. More...
int | isMiterHem
1 if miter hem, else 0 as default More...
double | gapSize
miter gap size. if isMiterHem = 1, apply it. default is 0.1 More...

Detailed Description

if hemType = 0, using the following variables

<

Definition at line 507 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::idEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdFullHemData
count
gapSize
idEdges
isMiterHem

◆ idEdges

int* svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::idEdges

list of idEdge.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 510 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdFullHemData
count
gapSize
idEdges
isMiterHem

◆ count

int svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::count

count of idEdges

Examples
part\smdFtrCrtTest.cpp.

Definition at line 509 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::gapSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdFullHemData
count
gapSize
idEdges
isMiterHem

◆ gapSize

double svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::gapSize

miter gap size. if isMiterHem = 1, apply it. default is 0.1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 513 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::isMiterHem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdFullHemData
count
gapSize
idEdges
isMiterHem

◆ isMiterHem

int svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::isMiterHem

1 if miter hem, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 512 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
Data Fields
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData Struct Reference

if hemType = 1, using the following variables More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idEdge
id of edge More...
int | widthType
0 is Start-Width, 1 is Start-End. default is 0 More...
double | start
start(>=0) More...
double | end
end(>=start). if widthType = 1, using this More...
double | width
width(>=start). if widthType = 0 ,using this More...
int | isRelief
1 if relief for insufficient length, else 0 as default More...
svxPntOnEnt * startPnt
use "To Point" to get the value of "start" (NULL to use start) More...
svxPntOnEnt * endPnt
use "To Point" to get the value of "end" (NULL to use end) More...
svxPntOnEnt * widthPnt
use "To Point" to get the value of "width" (NULL to use width) More...

Detailed Description

if hemType = 1, using the following variables

<

Definition at line 515 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ idEdge

int svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::idEdge

id of edge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 517 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ widthPnt

svxPntOnEnt* svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthPnt

use "To Point" to get the value of "width" (NULL to use width)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 526 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::end

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ end

double svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::end

end(>=start). if widthType = 1, using this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 520 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ widthType

int svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthType

0 is Start-Width, 1 is Start-End. default is 0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 518 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ start

double svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::start

start(>=0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 519 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::isRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ isRelief

int svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::isRelief

1 if relief for insufficient length, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 522 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::endPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ endPnt

svxPntOnEnt* svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::endPnt

use "To Point" to get the value of "end" (NULL to use end)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 525 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ width

double svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::width

width(>=start). if widthType = 0 ,using this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 521 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
  • svxSmdPartHemData
end
endPnt
idEdge
isRelief
start
startPnt
width
widthPnt
widthType

◆ startPnt

svxPntOnEnt* svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::startPnt

use "To Point" to get the value of "start" (NULL to use start)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 524 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ kType

evxSmdKFactorType* svxSmdHemFlangeData::kType

k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 553 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ offset

double* svxSmdHemFlangeData::offset

offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 531 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ position

evxSmdPosition* svxSmdHemFlangeData::position

position type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 530 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::hemType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ hemType

int svxSmdHemFlangeData::hemType

0 is Full hem, 1 is Partial hem. default is 0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 503 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::isFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ isFlip

int svxSmdHemFlangeData::isFlip

1 if flip the hems, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 504 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::startRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ startRelief

svxSmdReliefData* svxSmdHemFlangeData::startRelief

relief of start

Examples
part\smdFtrCrtTest.cpp.

Definition at line 559 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ radius1

double* svxSmdHemFlangeData::radius1

Radius R1. NULL to use global default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 549 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ kValue

double* svxSmdHemFlangeData::kValue

k_factor. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 556 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::length1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ length1

double svxSmdHemFlangeData::length1

Length L1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 547 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::bendType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ bendType

evxSmdHemBendType svxSmdHemFlangeData::bendType

bend type. default is VX_SMD_HEM_BEND_CLOSED

      bendType                 |       apply variables
VX_SMD_HEM_BEND_CLOSED         |         length1
VX_SMD_HEM_BEND_OPEN           |      length1,radius1
VX_SMD_HEM_BEND_CLOSEDLOOP     |      length1,radius1
VX_SMD_HEM_BEND_OPENLOOP       |      radius1,angle
VX_SMD_HEM_BEND_CENTEREDLOOP   | isEqualRadii,radius1,radius2,angle
VX_SMD_HEM_BEND_SBEND          | isEqualRadii,length1,length2,radius1,radius2
VX_SMD_HEM_BEND_CURL           | length1,length2,radius1,radius2
Examples
part\smdFtrCrtTest.cpp.

Definition at line 545 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ angle

double svxSmdHemFlangeData::angle

angle( >1). 270 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 551 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::isDefSepa

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ isDefSepa

int svxSmdHemFlangeData::isDefSepa

1 if define each side separately ,else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 558 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::isEqual

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ isEqual

int svxSmdHemFlangeData::isEqual

1 if equal radii ,else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 546 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::length2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ length2

double svxSmdHemFlangeData::length2

Length L2.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 548 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::endRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ endRelief

svxSmdReliefData* svxSmdHemFlangeData::endRelief

relief of end. if isDefSepa = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 560 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
angle
bendType
endRelief
hemType
isDefSepa
isEqual
isFlip
kType
kValue
length1
length2
offset
position
radius1
radius2
startRelief

◆ radius2

double* svxSmdHemFlangeData::radius2

Radius R2. NULL to use global default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 550 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdJogData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Jog data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idLine
id line. Make sure it is a straight line. More...
int | idFace
id face.Specify the plane face where inner bends are created. More...
int | reverseSide
1 is reverse the stationary side, else 0.default:0 More...
int | heightType
0 is inner: Measure the height from the sketch plane of the fold line, extend to the total height. Then offset a distance according to the thickeness of the material.
1 is outer: Measure the height from the sketch plane of the fold line, extend to the total height. default:0 More...
double | height
input a value to define the height of the jog.default:40 More...
int | keepProjLen
1 is keep the projection length, else 0.default:1 More...
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER. More...
double | radius
Specify the inner radius value of bend.default:5. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

template command Smd Jog data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 769 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::keepProjLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ keepProjLen

int svxSmdJogData::keepProjLen

1 is keep the projection length, else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 780 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::reverseSide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ reverseSide

int svxSmdJogData::reverseSide

1 is reverse the stationary side, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 773 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ isUseGlobal

int svxSmdJogData::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 783 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ position

evxSmdJogPosition svxSmdJogData::position

Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 781 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ idFace

int svxSmdJogData::idFace

id face.Specify the plane face where inner bends are created.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 772 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::heightType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ heightType

int svxSmdJogData::heightType

0 is inner: Measure the height from the sketch plane of the fold line, extend to the total height. Then offset a distance according to the thickeness of the material.
1 is outer: Measure the height from the sketch plane of the fold line, extend to the total height. default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 774 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::idLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ idLine

int svxSmdJogData::idLine

id line. Make sure it is a straight line.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 771 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ kValue

double svxSmdJogData::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 785 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ height

double svxSmdJogData::height

input a value to define the height of the jog.default:40

Examples
part\smdFtrCrtTest.cpp.

Definition at line 779 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ kType

evxSmdKFactorType svxSmdJogData::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 784 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdJogData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdJogData
height
heightType
idFace
idLine
isUseGlobal
keepProjLen
kType
kValue
position
radius
reverseSide

◆ radius

double svxSmdJogData::radius

Specify the inner radius value of bend.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 782 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdLinearUnfoldData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd linear unfold data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idFace
Specify the face to fix.0/-1 to ignore it. More...
int | cnt
count of bendFcs More...
int * | bendFcs
Specify bend faces to lay out. More...
double | angle
Specify the angle to unfold.default:90. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...
int | addStatus
Check(=1) this option to create a newly copied part which is associative with the original one.default:0. More...
svxVector dir
Select linear unfold direction.default:{1,0,0}. More...
double | distance
Enter distance along linear unfold direction.default:0.1. More...

Detailed Description

template command Smd linear unfold data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1230 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::bendFcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ bendFcs

int* svxSmdLinearUnfoldData::bendFcs

Specify bend faces to lay out.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1234 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ isUseGlobal

int svxSmdLinearUnfoldData::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1237 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ kType

evxSmdKFactorType svxSmdLinearUnfoldData::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1238 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::dir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ dir

svxVector svxSmdLinearUnfoldData::dir

Select linear unfold direction.default:{1,0,0}.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1242 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ angle

double svxSmdLinearUnfoldData::angle

Specify the angle to unfold.default:90.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1235 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ idFace

int svxSmdLinearUnfoldData::idFace

Specify the face to fix.0/-1 to ignore it.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1232 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ cnt

int svxSmdLinearUnfoldData::cnt

count of bendFcs

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1233 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ kValue

double svxSmdLinearUnfoldData::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1239 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::addStatus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ addStatus

int svxSmdLinearUnfoldData::addStatus

Check(=1) this option to create a newly copied part which is associative with the original one.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1241 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLinearUnfoldData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLinearUnfoldData
addStatus
angle
bendFcs
cnt
dir
distance
idFace
isUseGlobal
kType
kValue

◆ distance

double svxSmdLinearUnfoldData::distance

Enter distance along linear unfold direction.default:0.1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1243 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdLoftedFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Lofted Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxLftFlange
union of smd lofted flange data More...

Data Fields

evxSmdLftFlangeMethod method
Lofted Flange method.default:VX_SMD_FLATTENABLE_LOFTING. More...
double | thickness
Specifies the thickness for the profile.default:1. Recommended minimum value is not less than two times of Part Tolerance. More...
int | isOpposite
1 is Flip the direction of lofted flange, else 0.default:0 More...
double | radius
Specifies the bend radius of profile.default:5. More...
union svxSmdLoftedFlangeData::uvxLftFlange | inpUnion

Detailed Description

template command Smd Lofted Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 599 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
Data Fields
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend Struct Reference

VX_SMD_BENDING_LOFTING. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idProf1
id of profile1 More...
int | flip1
1 is flip profile1, else 0.default:0 More...
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed. More...
int | idProf2
id of profile2 More...
int | flip2
1 is flip profile1, else 0.default:0 More...
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed. More...
double | cutLength
Specify the cut length.default:1. More...
evxSmdLftCutMethod cutMethod
Pick the position to place the cut point.default:VX_SMD_LFG_MAX_ARC_HEIGHT. More...
double | cutValue
cutting value.default:1 More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

VX_SMD_BENDING_LOFTING.

<

Definition at line 642 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ isUseGlobal

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 657 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutValue

double svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutValue

cutting value.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 656 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ idProf1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf1

id of profile1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 644 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutLength

double svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutLength

Specify the cut length.default:1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 654 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutPnt1

svxPntOnEnt svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt1

Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 646 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutMethod

evxSmdLftCutMethod svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutMethod

Pick the position to place the cut point.default:VX_SMD_LFG_MAX_ARC_HEIGHT.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 655 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ idProf2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf2

id of profile2

Examples
part\smdFtrCrtTest.cpp.

Definition at line 649 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutPnt2

svxPntOnEnt svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt2

Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 651 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ kValue

double svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 659 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ flip2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip2

1 is flip profile1, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 650 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ flip1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip1

1 is flip profile1, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 645 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftBend
cutLength
cutMethod
cutPnt1
cutPnt2
cutValue
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ kType

evxSmdKFactorType svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 658 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
Data Fields
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat Struct Reference

VX_SMD_FLATTENABLE_LOFTING. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idProf1
id of profile1 More...
int | flip1
1 is flip profile1, else 0.default:0 More...
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed. More...
int | idProf2
id of profile2 More...
int | flip2
1 is flip profile1, else 0.default:0 More...
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed. More...
double | cutLength
Specify the cut length.default:1. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...

Detailed Description

VX_SMD_FLATTENABLE_LOFTING.

<

Definition at line 625 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ flip1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip1

1 is flip profile1, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 628 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ idProf2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf2

id of profile2

Examples
part\smdFtrCrtTest.cpp.

Definition at line 632 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ idProf1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf1

id of profile1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 627 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ kValue

double svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 640 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ flip2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip2

1 is flip profile1, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 633 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutPnt1

svxPntOnEnt svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt1

Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 629 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutLength

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutLength

double svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutLength

Specify the cut length.default:1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 637 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ isUseGlobal

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 638 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ cutPnt2

svxPntOnEnt svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt2

Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 634 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftFlat
cutLength
cutPnt1
cutPnt2
flip1
flip2
idProf1
idProf2
isUseGlobal
kType
kValue

◆ kType

evxSmdKFactorType svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 639 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
Data Fields
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral Struct Reference

VX_SMD_GENERAL_LOFTING. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | count1
count of listLines1 More...
int * | listLines1
list of line(edge/curve) id More...
int | flip1
1 is flip, else 0.default:0 More...
int | count2
count of listLines2 More...
int * | listLines2
list of line(edge/curve) id More...
int | flip2
1 is flip, else 0.default:0 More...
int | cntShps
count of boolShps,cntShps=0 to use default. More...
int * | boolShps
Specify the boolean operation and the boolean shapes. More...
svxLoftBndCons | bndCons [2]
boundary constraints More...
int | scale
An additional scale factor that is applied to the Weight slider bar. This is only needed when the extreme position of the slider bar is insufficient for your design task. More...

Detailed Description

VX_SMD_GENERAL_LOFTING.

<

Definition at line 608 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ flip1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip1

1 is flip, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 612 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ count1

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count1

count of listLines1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 610 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ listLines1

int* svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines1

list of line(edge/curve) id

Examples
part\smdFtrCrtTest.cpp.

Definition at line 611 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ flip2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip2

1 is flip, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 616 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ count2

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count2

count of listLines2

Examples
part\smdFtrCrtTest.cpp.

Definition at line 614 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::cntShps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ cntShps

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::cntShps

count of boolShps,cntShps=0 to use default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 618 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::boolShps

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ boolShps

int* svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::boolShps

Specify the boolean operation and the boolean shapes.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 619 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::bndCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ bndCons

svxLoftBndCons svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::bndCons[2]

boundary constraints

Examples
part\smdFtrCrtTest.cpp.

Definition at line 620 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ listLines2

int* svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines2

list of line(edge/curve) id

Examples
part\smdFtrCrtTest.cpp.

Definition at line 615 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
  • svxSmdLftGeneral
bndCons
boolShps
cntShps
count1
count2
flip1
flip2
listLines1
listLines2
scale

◆ scale

int svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::scale

An additional scale factor that is applied to the Weight slider bar. This is only needed when the extreme position of the slider bar is insufficient for your design task.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 621 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
isOpposite
method
radius
thickness

◆ thickness

double svxSmdLoftedFlangeData::thickness

Specifies the thickness for the profile.default:1. Recommended minimum value is not less than two times of Part Tolerance.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 602 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
isOpposite
method
radius
thickness

◆ method

evxSmdLftFlangeMethod svxSmdLoftedFlangeData::method

Lofted Flange method.default:VX_SMD_FLATTENABLE_LOFTING.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 601 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::isOpposite

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
isOpposite
method
radius
thickness

◆ isOpposite

int svxSmdLoftedFlangeData::isOpposite

1 is Flip the direction of lofted flange, else 0.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 604 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
isOpposite
method
radius
thickness

◆ radius

double svxSmdLoftedFlangeData::radius

Specifies the bend radius of profile.default:5.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 605 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdMarkBendData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd mark bend data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idFace
This face remains stationary when the part is folded or unfolded. More...
int | cnt
count of bendFcs More...
int * | bendFcs
Select the inner or outer bend faces. Bend faces can be marked while the sheet metal part is in its unfolded state. More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...
double | thickness
sheet metal thickness.default:1.0 More...
double | flatTol
Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.default:0.10. More...

Detailed Description

template command Smd mark bend data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1322 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ kValue

double svxSmdMarkBendData::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1330 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::bendFcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ bendFcs

int* svxSmdMarkBendData::bendFcs

Select the inner or outer bend faces. Bend faces can be marked while the sheet metal part is in its unfolded state.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1326 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ thickness

double svxSmdMarkBendData::thickness

sheet metal thickness.default:1.0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1331 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::flatTol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ flatTol

double svxSmdMarkBendData::flatTol

Refers to the flat tolerance allowed for sheet metal parts in their unfolded state.default:0.10.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1332 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ idFace

int svxSmdMarkBendData::idFace

This face remains stationary when the part is folded or unfolded.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1324 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ kType

evxSmdKFactorType svxSmdMarkBendData::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1329 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ isUseGlobal

int svxSmdMarkBendData::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1328 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdMarkBendData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdMarkBendData
bendFcs
cnt
flatTol
idFace
isUseGlobal
kType
kValue
thickness

◆ cnt

int svxSmdMarkBendData::cnt

count of bendFcs

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1325 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdPartialFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Partial Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idEdge
id of edge More...
int | isRevert
1 if switch start point, else 0 as default More...
int | isFlip
1 if flip the flange, else 0 as default More...
int | widthType
0 is Start-Width, 1 is Start-End. default is 0 More...
double | start
start(>=0) More...
double | end
end(!=start). if widthType = 1, using this More...
double | width
width(>=start). if widthType = 0, using this More...
evxSmdPosition * position
position type. NULL to use global default More...
double * | offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default More...
int | bend
bend, 0 if simple, 1 if S bend. default is 0 More...
double * | radius1
radius r1. NULL to use global default More...
double | angle
angle (>0). 90 as default More...
evxSmdBendLengthType * lengthType
length type. NULL to use global default More...
double * | length
length. NULL to use global default More...
double * | radius2
radius r2, if bend = 0, ignore this. NULL to use global default More...
int | sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this. More...
double | Size
size (height or length), if bend = 0, ignore this More...
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors. More...
double * | kValue
k_factor. NULL to use global default More...
int | isRelief
1 if relief for insufficient length , else 0 as default More...
int | isDefSepa
1 if define each side separately ,else 0 as default More...
svxSmdReliefData * startRelief
relief of start More...
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this More...
double * | tol
Flat Tolerance. NULL to use global default. More...

Detailed Description

template command Smd Partial Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 448 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::isRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ isRelief

int svxSmdPartialFlangeData::isRelief

1 if relief for insufficient length , else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 474 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::Size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ Size

double svxSmdPartialFlangeData::Size

size (height or length), if bend = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 467 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::sBendSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ sBendSize

int svxSmdPartialFlangeData::sBendSize

S bend size (1 is length, 0 is height), if bend = 0, ignore this.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 466 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::startRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ startRelief

svxSmdReliefData* svxSmdPartialFlangeData::startRelief

relief of start

Examples
part\smdFtrCrtTest.cpp.

Definition at line 476 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::radius1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ radius1

double* svxSmdPartialFlangeData::radius1

radius r1. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 461 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ length

double* svxSmdPartialFlangeData::length

length. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 464 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ angle

double svxSmdPartialFlangeData::angle

angle (>0). 90 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 462 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::isDefSepa

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ isDefSepa

int svxSmdPartialFlangeData::isDefSepa

1 if define each side separately ,else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 475 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ kType

evxSmdKFactorType* svxSmdPartialFlangeData::kType

k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral axis within the thickness of the sheet metal, and is affected by multiple factors.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 469 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::radius2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ radius2

double* svxSmdPartialFlangeData::radius2

radius r2, if bend = 0, ignore this. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 465 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::endRelief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ endRelief

svxSmdReliefData* svxSmdPartialFlangeData::endRelief

relief of end. if isDefSepa = 0, ignore this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 477 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ offset

double* svxSmdPartialFlangeData::offset

offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 458 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ position

evxSmdPosition* svxSmdPartialFlangeData::position

position type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 457 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::end

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ end

double svxSmdPartialFlangeData::end

end(!=start). if widthType = 1, using this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 455 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::idEdge

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ idEdge

int svxSmdPartialFlangeData::idEdge

id of edge

Examples
part\smdFtrCrtTest.cpp.

Definition at line 450 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ kValue

double* svxSmdPartialFlangeData::kValue

k_factor. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 472 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ lengthType

evxSmdBendLengthType* svxSmdPartialFlangeData::lengthType

length type. NULL to use global default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 463 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ width

double svxSmdPartialFlangeData::width

width(>=start). if widthType = 0, using this

Examples
part\smdFtrCrtTest.cpp.

Definition at line 456 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::start

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ start

double svxSmdPartialFlangeData::start

start(>=0)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 454 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::bend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ bend

int svxSmdPartialFlangeData::bend

bend, 0 if simple, 1 if S bend. default is 0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 460 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::tol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ tol

double* svxSmdPartialFlangeData::tol

Flat Tolerance. NULL to use global default.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 479 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::isFlip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ isFlip

int svxSmdPartialFlangeData::isFlip

1 if flip the flange, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 452 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::widthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ widthType

int svxSmdPartialFlangeData::widthType

0 is Start-Width, 1 is Start-End. default is 0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 453 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdPartialFlangeData::isRevert

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdPartialFlangeData
angle
bend
end
endRelief
idEdge
isDefSepa
isFlip
isRelief
isRevert
kType
kValue
length
lengthType
offset
position
radius1
radius2
sBendSize
Size
start
startRelief
tol
width
widthType

◆ isRevert

int svxSmdPartialFlangeData::isRevert

1 if switch start point, else 0 as default

Examples
part\smdFtrCrtTest.cpp.

Definition at line 451 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdReliefData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

Smd Relief data, use cvxPartSmdReliefDataInit to initialize it. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | isCustom
the value of "isCustom" indicates whether the following variables use custom values(evxSmdCalCustom) ( 1 ~~ 31 ) if isCustom = VX_CUSTOM_ISWIDTHRATIO | VX_CUSTOM_RELIEFWIDTH, "isWidthRatio" and "ReliefWidth" are custom value, other values use global default. you can ignore this parameter when initializing it with cvxPartSmdReliefDataInit() More...
evxSmdRelief relief
relief type. default is global value More...
int | upToBend
1 if up to bend. default is 0 More...
evxSmdReliefLengthType lengthType
length type. default is VX_RELIEF_LENGTH_TYPE_TO_EDGE More...
double | lengthVal
length value. when lengthType = VX_RELIEF_LENGTH_TYPE_VALUE, apply it. More...
int | isWidthRatio
1 if relief width ratio, else 2 is value. default is global value More...
double | ReliefWidth
ratio or value. default is global value More...
int | isDepthRatio
1 if relief depth ratio, else 2 is value. default is global value More...
double | ReliefDepth
ratio or value. default is global value More...

Detailed Description

Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 163 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::lengthVal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ lengthVal

double svxSmdReliefData::lengthVal

length value. when lengthType = VX_RELIEF_LENGTH_TYPE_VALUE, apply it.

Definition at line 174 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::isWidthRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ isWidthRatio

int svxSmdReliefData::isWidthRatio

1 if relief width ratio, else 2 is value. default is global value

Examples
part\smdFtrCrtTest.cpp.

Definition at line 176 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::ReliefDepth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ ReliefDepth

double svxSmdReliefData::ReliefDepth

ratio or value. default is global value

Examples
part\smdFtrCrtTest.cpp.

Definition at line 180 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::isDepthRatio

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ isDepthRatio

int svxSmdReliefData::isDepthRatio

1 if relief depth ratio, else 2 is value. default is global value

Examples
part\smdFtrCrtTest.cpp.

Definition at line 179 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ relief

evxSmdRelief svxSmdReliefData::relief

relief type. default is global value

Examples
part\smdFtrCrtTest.cpp.

Definition at line 170 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::isCustom

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ isCustom

int svxSmdReliefData::isCustom

the value of "isCustom" indicates whether the following variables use custom values(evxSmdCalCustom) ( 1 ~~ 31 ) if isCustom = VX_CUSTOM_ISWIDTHRATIO | VX_CUSTOM_RELIEFWIDTH, "isWidthRatio" and "ReliefWidth" are custom value, other values use global default. you can ignore this parameter when initializing it with cvxPartSmdReliefDataInit()

Definition at line 165 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::upToBend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ upToBend

int svxSmdReliefData::upToBend

1 if up to bend. default is 0

Definition at line 172 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::lengthType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ lengthType

evxSmdReliefLengthType svxSmdReliefData::lengthType

length type. default is VX_RELIEF_LENGTH_TYPE_TO_EDGE

Definition at line 173 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdReliefData::ReliefWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdReliefData
isCustom
isDepthRatio
isWidthRatio
lengthType
lengthVal
relief
ReliefDepth
ReliefWidth
upToBend

◆ ReliefWidth

double svxSmdReliefData::ReliefWidth

ratio or value. default is global value

Examples
part\smdFtrCrtTest.cpp.

Definition at line 177 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdRipData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSmdRipData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd rip data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

evxSmdRipType type
rip type.default:VX_SMD_RIP_BOTH_SIDES More...
int | cnt
count of ids More...
int * | ids
Choose edges/lines to create a rip. More...
double | gap
Set the gap size.default:0.1. More...

Detailed Description

template command Smd rip data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1310 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdRipData::ids

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdRipData
cnt
gap
ids
type

◆ ids

int* svxSmdRipData::ids

Choose edges/lines to create a rip.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1314 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdRipData::cnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdRipData
cnt
gap
ids
type

◆ cnt

int svxSmdRipData::cnt

count of ids

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1313 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdRipData::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdRipData
cnt
gap
ids
type

◆ gap

double svxSmdRipData::gap

Set the gap size.default:0.1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1315 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdRipData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdRipData
cnt
gap
ids
type

◆ type

evxSmdRipType svxSmdRipData::type

rip type.default:VX_SMD_RIP_BOTH_SIDES

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1312 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxSmdSweptFlangeData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Swept Flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

union uvxSmdSweptFlange
union of smd swept flange data More...

Data Fields

int | idFace
This face remains stationary when the part is folded or unfolded. More...
int | idProfile
Set the open, non-intersecting profile sketch used to create the sweep. More...
int | count
count of sweptPath More...
int * | sweptPath
Set the path along which the profile sweeps. You can select a series of existing sheet metal edges for the path. The start point of the path must lie on the plane of the profile. More...
evxSmdPosition position
Use this option to specify the position of the added sheet metal flange. The position of the flange is specified relative to the selected edge. VX_POSITION_VIRTUAL_SHARP cannot be used here. More...
double | offset
specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore.default:0 More...
double | radius
Specifies the inner bend radius applied to flange features. More...
int | keepMerged
1 is keep merged edges, else 0. default:0 More...
int | isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1 More...
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM More...
double | kValue
k_factor. default:0.41 More...
evxSmdCornerRelief relief
Use this option to trim the adjoining flanges. More...
int | miterCorner
1 is miter corner, else 0. default:1. More...
union svxSmdSweptFlangeData::uvxSmdSweptFlange | inpUnion

Detailed Description

template command Smd Swept Flange data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 668 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefCircular
Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular Struct Reference

VX_CORNER_RELIEF_CIRCULAR_CUTOUT. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | gap
Specify the gap for the closed corner.default:0. More...
int | origin
0 is bend center, 1 is corner point.default:1 More...
double | offset
Specify an offset distance from the origin of the Cutout.default:0. More...
double | diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4. More...

Detailed Description

VX_CORNER_RELIEF_CIRCULAR_CUTOUT.

<

Definition at line 697 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefCircular
diameter
gap
offset
origin

◆ gap

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::gap

Specify the gap for the closed corner.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 699 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefCircular
diameter
gap
offset
origin

◆ diameter

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::diameter

Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 702 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefCircular
diameter
gap
offset
origin

◆ origin

int svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::origin

0 is bend center, 1 is corner point.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 700 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefCircular
diameter
gap
offset
origin

◆ offset

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::offset

Specify an offset distance from the origin of the Cutout.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 701 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefClosed
Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed Struct Reference

VX_CORNER_RELIEF_CLOSED. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double gap
Specify the gap for the closed corner.default:0. More...

Detailed Description

VX_CORNER_RELIEF_CLOSED.

<

Definition at line 692 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefClosed
gap

◆ gap

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed::gap

Specify the gap for the closed corner.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 694 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular Struct Reference

VX_CORNER_RELIEF_RECTANGULAR_CUTOUT. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | gap
Specify the gap for the closed corner.default:0. More...
int | origin
0 is bend center, 1 is corner point.default:1 More...
double | offset
Specify an offset distance from the origin of the Cutout.default:0. More...
double | length
Specify the length of the Rectangular Cutout.default:4. More...
double | width
Specify the width of the Rectangular Cutout.default:4. More...

Detailed Description

VX_CORNER_RELIEF_RECTANGULAR_CUTOUT.

<

Definition at line 705 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
gap
length
offset
origin
width

◆ length

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::length

Specify the length of the Rectangular Cutout.default:4.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 710 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
gap
length
offset
origin
width

◆ offset

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::offset

Specify an offset distance from the origin of the Cutout.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 709 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
gap
length
offset
origin
width

◆ width

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::width

Specify the width of the Rectangular Cutout.default:4.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 711 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
gap
length
offset
origin
width

◆ gap

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::gap

Specify the gap for the closed corner.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 707 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefRectangular
gap
length
offset
origin
width

◆ origin

int svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::origin

0 is bend center, 1 is corner point.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 708 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefUCutout
Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout Struct Reference

VX_CORNER_RELIEF_U_CUTOUT. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | gap
Specify the gap for the closed corner.default:0. More...
int | origin
0 is bend center, 1 is corner point.default:1 More...
double | offset
Specify an offset distance from the origin of the Cutout.default:0. More...
double | diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4. More...

Detailed Description

VX_CORNER_RELIEF_U_CUTOUT.

<

Definition at line 714 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefUCutout
diameter
gap
offset
origin

◆ origin

int svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::origin

0 is bend center, 1 is corner point.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 717 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefUCutout
diameter
gap
offset
origin

◆ diameter

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::diameter

Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 719 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefUCutout
diameter
gap
offset
origin

◆ offset

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::offset

Specify an offset distance from the origin of the Cutout.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 718 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefUCutout
diameter
gap
offset
origin

◆ gap

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::gap

Specify the gap for the closed corner.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 716 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout Struct Reference

VX_CORNER_RELIEF_V_CUTOUT. More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

double | gap
Specify the gap for the closed corner.default:0. More...
int | origin
0 is bend center, 1 is corner point.default:1 More...
double | offset
Specify an offset distance from the origin of the Cutout.default:0. More...
double | diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4. More...
double | angle1
Specify the angle of the V Cutout.default:30. More...
double | angle2
Specify the angle of the V Cutout.default:30. More...

Detailed Description

VX_CORNER_RELIEF_V_CUTOUT.

<

Definition at line 722 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle1

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ angle1

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle1

Specify the angle of the V Cutout.default:30.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 728 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::gap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ gap

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::gap

Specify the gap for the closed corner.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 724 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ offset

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::offset

Specify an offset distance from the origin of the Cutout.default:0.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 726 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ origin

int svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::origin

0 is bend center, 1 is corner point.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 725 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ angle2

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle2

Specify the angle of the V Cutout.default:30.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 729 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
  • svxSmdReliefVCutout
angle1
angle2
diameter
gap
offset
origin

◆ diameter

double svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::diameter

Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 727 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::miterCorner

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ miterCorner

int svxSmdSweptFlangeData::miterCorner

1 is miter corner, else 0. default:1.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 689 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::kValue

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ kValue

double svxSmdSweptFlangeData::kValue

k_factor. default:0.41

Examples
part\smdFtrCrtTest.cpp.

Definition at line 686 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::position

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ position

evxSmdPosition svxSmdSweptFlangeData::position

Use this option to specify the position of the added sheet metal flange. The position of the flange is specified relative to the selected edge. VX_POSITION_VIRTUAL_SHARP cannot be used here.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 677 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::isUseGlobal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ isUseGlobal

int svxSmdSweptFlangeData::isUseGlobal

1 is use global setting(the following parameters are not to set),else 0.default:1

Examples
part\smdFtrCrtTest.cpp.

Definition at line 684 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ offset

double svxSmdSweptFlangeData::offset

specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore.default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 680 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::idFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ idFace

int svxSmdSweptFlangeData::idFace

This face remains stationary when the part is folded or unfolded.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 670 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::keepMerged

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ keepMerged

int svxSmdSweptFlangeData::keepMerged

1 is keep merged edges, else 0. default:0

Examples
part\smdFtrCrtTest.cpp.

Definition at line 682 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ idProfile

int svxSmdSweptFlangeData::idProfile

Set the open, non-intersecting profile sketch used to create the sweep.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 671 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ count

int svxSmdSweptFlangeData::count

count of sweptPath

Examples
part\smdFtrCrtTest.cpp.

Definition at line 672 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::sweptPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ sweptPath

int* svxSmdSweptFlangeData::sweptPath

Set the path along which the profile sweeps. You can select a series of existing sheet metal edges for the path. The start point of the path must lie on the plane of the profile.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 673 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ radius

double svxSmdSweptFlangeData::radius

Specifies the inner bend radius applied to flange features.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 681 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::relief

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ relief

evxSmdCornerRelief svxSmdSweptFlangeData::relief

Use this option to trim the adjoining flanges.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 688 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::kType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
count
idFace
idProfile
isUseGlobal
keepMerged
kType
kValue
miterCorner
offset
position
radius
relief
sweptPath

◆ kType

evxSmdKFactorType svxSmdSweptFlangeData::kType

k_factor definition type.default:VX_SMD_KTYPE_CUSTOM

Examples
part\smdFtrCrtTest.cpp.

Definition at line 685 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphere Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSphere Struct Reference
Common » Common Data

spherical surface data More...

#include <zwapi_util.h>

Data Fields

double | radius
radius More...
svxMatrix form
sphere centered about xform More...
int | poleis01
= 1 : poles (if they exist) are at extreme V parameters = 0 : poles (if they exist) are at extreme U parameters More...

Detailed Description

spherical surface data

Definition at line 1780 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphere::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphere
form
poleis01
radius

◆ radius

double svxSphere::radius

radius

Definition at line 1782 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphere::poleis01

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphere
form
poleis01
radius

◆ poleis01

int svxSphere::poleis01

= 1 : poles (if they exist) are at extreme V parameters = 0 : poles (if they exist) are at extreme U parameters

Definition at line 1784 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphere::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphere
form
poleis01
radius

◆ form

svxMatrix svxSphere::form

sphere centered about xform

Definition at line 1783 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphereData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSphereData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

sphere More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
svxPoint Center
sphere center point More...
double Radius
sphere radius (mm) More...
vxName ftrName
feature name for "FtAllSph", 0 default More...

Detailed Description

sphere

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 97 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphereData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphereData
Center
Combine
ftrName
Radius

◆ ftrName

vxName svxSphereData::ftrName

feature name for "FtAllSph", 0 default

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 103 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphereData::Radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphereData
Center
Combine
ftrName
Radius

◆ Radius

double svxSphereData::Radius

sphere radius (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 101 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphereData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphereData
Center
Combine
ftrName
Radius

◆ Combine

evxBoolType svxSphereData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 99 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSphereData::Center

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSphereData
Center
Combine
ftrName
Radius

◆ Center

svxPoint svxSphereData::Center

sphere center point

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 100 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSpiralCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

spiral curve data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

svxPoint startPnt
the start point More...
svxVector axis
the spiral axis, it can be the coordinate axis, line or point More...
double | turns
the number of turns More...
double | offset
the value the turn offset, that is the distance between two turns. A positive value indicates an external offset. A negative value indicates an internal offset. More...
int | revolve
1 to revolve the curve clockwise about the specified axis, else revolve the curve anti-clockwise.
More...
svxVector * pRefDir
the reference direction for spiral curve (NULL to ignore) More...
double | ang
the angle of spiral curve More...

Detailed Description

spiral curve data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 458 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ offset

double svxSpiralCrvData::offset

the value the turn offset, that is the distance between two turns. A positive value indicates an external offset. A negative value indicates an internal offset.

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 463 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::pRefDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ pRefDir

svxVector* svxSpiralCrvData::pRefDir

the reference direction for spiral curve (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 467 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ axis

svxVector svxSpiralCrvData::axis

the spiral axis, it can be the coordinate axis, line or point

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 461 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::turns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ turns

double svxSpiralCrvData::turns

the number of turns

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 462 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::ang

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ ang

double svxSpiralCrvData::ang

the angle of spiral curve

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 468 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::revolve

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ revolve

int svxSpiralCrvData::revolve

1 to revolve the curve clockwise about the specified axis, else revolve the curve anti-clockwise.

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 465 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralCrvData::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralCrvData
ang
axis
offset
pRefDir
revolve
startPnt
turns

◆ startPnt

svxPoint svxSpiralCrvData::startPnt

the start point

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 460 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSpiralSweepData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

spiral swept shape More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxPntOnEntPath pntOnPro
a point at profile (sketch, curve, edge, curveList). If the type of profile is sketch, set useCritPnt to 1 for getting point automatically More...
svxVector axis
axis of spiral sweep More...
double | turns
the number of turns More...
double | dst
the distance along the axis for each turn More...
evxBoolType combine
combination method. (VX_BOOL_NONE as default) More...
int | cntShapes
count of boolean shapes More...
int * | idShapes
id of boolean shapes More...
evxLeadType leadType
lead type(set the value of leadRad and leadAng). (VX_LEAD_NONE as default) More...
double | leadRad
determines a pivot point while the angle specifies the number of degrees the profile is rotated. (0 if undefined) More...
double | leadAng
for lead Out, the angle is measured from the point on the profile furthest away from the axis of rotation;
for lead In, the point closest to the axis is used. (0 if undefined) More...
evxCapType capType
end cap type(invalid if the idProfile is open). (VX_END_CAP_BOTH as default) More...
evxOffsetType offsetType
option of offset(set the value of Offset and Thickness). (VX_OFFSET_NONE as default) More...
double | offset
profile offset (mm) (0 if undefined) More...
double | thickness
wall thickness (mm) (0 if undefined) More...
double | taperAng
taper angle used to create pipe threads, tapered coils, etc More...
int | isClockwise
judge the spiral to turn clockwise about the axis direction. (1 = clockwise, 0 as default) More...
int | isFlipDir
flip the spiral direction of the thread. (1 = flip, 0 as default) More...

Detailed Description

spiral swept shape

Definition at line 330 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ offset

double svxSpiralSweepData::offset

profile offset (mm) (0 if undefined)

Definition at line 349 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::taperAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ taperAng

double svxSpiralSweepData::taperAng

taper angle used to create pipe threads, tapered coils, etc

Definition at line 352 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::cntShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ cntShapes

int svxSpiralSweepData::cntShapes

count of boolean shapes

Definition at line 339 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::isFlipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ isFlipDir

int svxSpiralSweepData::isFlipDir

flip the spiral direction of the thread. (1 = flip, 0 as default)

Definition at line 354 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::leadAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ leadAng

double svxSpiralSweepData::leadAng

for lead Out, the angle is measured from the point on the profile furthest away from the axis of rotation;
for lead In, the point closest to the axis is used. (0 if undefined)

Definition at line 344 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::leadType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ leadType

evxLeadType svxSpiralSweepData::leadType

lead type(set the value of leadRad and leadAng). (VX_LEAD_NONE as default)

Definition at line 342 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::isClockwise

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ isClockwise

int svxSpiralSweepData::isClockwise

judge the spiral to turn clockwise about the axis direction. (1 = clockwise, 0 as default)

Definition at line 353 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::turns

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ turns

double svxSpiralSweepData::turns

the number of turns

Definition at line 335 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ thickness

double svxSpiralSweepData::thickness

wall thickness (mm) (0 if undefined)

Definition at line 350 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ idShapes

int* svxSpiralSweepData::idShapes

id of boolean shapes

Definition at line 340 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::leadRad

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ leadRad

double svxSpiralSweepData::leadRad

determines a pivot point while the angle specifies the number of degrees the profile is rotated. (0 if undefined)

Definition at line 343 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ combine

evxBoolType svxSpiralSweepData::combine

combination method. (VX_BOOL_NONE as default)

Definition at line 338 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::dst

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ dst

double svxSpiralSweepData::dst

the distance along the axis for each turn

Definition at line 336 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::capType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ capType

evxCapType svxSpiralSweepData::capType

end cap type(invalid if the idProfile is open). (VX_END_CAP_BOTH as default)

Definition at line 346 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::offsetType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ offsetType

evxOffsetType svxSpiralSweepData::offsetType

option of offset(set the value of Offset and Thickness). (VX_OFFSET_NONE as default)

Definition at line 348 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::pntOnPro

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ pntOnPro

svxPntOnEntPath svxSpiralSweepData::pntOnPro

a point at profile (sketch, curve, edge, curveList). If the type of profile is sketch, set useCritPnt to 1 for getting point automatically

Definition at line 333 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSpiralSweepData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSpiralSweepData
axis
capType
cntShapes
combine
dst
idShapes
isClockwise
isFlipDir
leadAng
leadRad
leadType
offset
offsetType
pntOnPro
taperAng
thickness
turns

◆ axis

svxVector svxSpiralSweepData::axis

axis of spiral sweep

Definition at line 334 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSplineData Struct Reference
Common » Common Data

Spline command data. More...

#include <zwapi_util.h>

Data Fields

int | SplineTyp
0- through point, 1- control point (0 as default)) More...
int | Count
count of points More...
svxSplinePnt * Pnts
point list More...
int | Degree
degree (3 as default) More...
int | CreateCrvOpen
1-create curve open, 0-create close curve(1 as default) More...
int | Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension) More...
int | SingleSeg
single segment (0 as default) More...
evxPlacingType PlacingTyp
placing adjustment type More...
svxVector PlacingDir
Placing adjustment director (PlacingTyp = VX_PLACING_VECTOR) More...
int | UseOrient
1-use orientation tool (0 as default, PlacingTyp = VX_PLACING_VIEW) More...
svxEntPath PlacingPln
reference fram (part entity path can be initialized as(PlacingPln.Count = 2; PlacingPln.Id={-1, idFace}) ) (PlacingTyp = VX_PLACING_PLANE) More...
int | PlacingPrj
1-project to plane, else 0 (0 as default, PlacingTyp = VX_PLACING_PLANE) More...
svxEntPath AlignPlane
align plane (part entity path can be initialized as(alignEnt.Count = 2; alignEnt.Id={-1, idFace}) ) More...
int | PrjToPln
1-project to the align plane, else 0 (1 as default) More...
int | PntOnPln
1-points on align plane, else 0 (0 as default) More...
int | AlignTyp
Align type, 0-auto, 1-select, (1 as default) More...

Detailed Description

Spline command data.

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2397 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PntOnPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PntOnPln

int svxSplineData::PntOnPln

1-points on align plane, else 0 (0 as default)

Definition at line 2427 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::AlignPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ AlignPlane

svxEntPath svxSplineData::AlignPlane

align plane (part entity path can be initialized as(alignEnt.Count = 2; alignEnt.Id={-1, idFace}) )

Definition at line 2425 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::SplineTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ SplineTyp

int svxSplineData::SplineTyp

0- through point, 1- control point (0 as default))

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2400 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::CreateCrvOpen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ CreateCrvOpen

int svxSplineData::CreateCrvOpen

1-create curve open, 0-create close curve(1 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2406 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::UseOrient

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ UseOrient

int svxSplineData::UseOrient

1-use orientation tool (0 as default, PlacingTyp = VX_PLACING_VIEW)

Definition at line 2416 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PrjToPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PrjToPln

int svxSplineData::PrjToPln

1-project to the align plane, else 0 (1 as default)

Definition at line 2426 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PlacingTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PlacingTyp

evxPlacingType svxSplineData::PlacingTyp

placing adjustment type

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2412 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PlacingDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PlacingDir

svxVector svxSplineData::PlacingDir

Placing adjustment director (PlacingTyp = VX_PLACING_VECTOR)

the following parameters used when create 3d curve

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2413 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::Degree

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ Degree

int svxSplineData::Degree

degree (3 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2403 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::Fairing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ Fairing

int svxSplineData::Fairing

fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2407 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::SingleSeg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ SingleSeg

int svxSplineData::SingleSeg

single segment (0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2409 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PlacingPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PlacingPln

svxEntPath svxSplineData::PlacingPln

reference fram (part entity path can be initialized as(PlacingPln.Count = 2; PlacingPln.Id={-1, idFace}) ) (PlacingTyp = VX_PLACING_PLANE)

Definition at line 2418 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ Count

int svxSplineData::Count

count of points

Definition at line 2401 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::AlignTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ AlignTyp

int svxSplineData::AlignTyp

Align type, 0-auto, 1-select, (1 as default)

Definition at line 2428 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::PlacingPrj

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ PlacingPrj

int svxSplineData::PlacingPrj

1-project to plane, else 0 (0 as default, PlacingTyp = VX_PLACING_PLANE)

Definition at line 2420 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplineData::Pnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplineData
AlignPlane
AlignTyp
Count
CreateCrvOpen
Degree
Fairing
PlacingDir
PlacingPln
PlacingPrj
PlacingTyp
PntOnPln
Pnts
PrjToPln
SingleSeg
SplineTyp
UseOrient

◆ Pnts

svxSplinePnt* svxSplineData::Pnts

point list

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2402 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSplinePnt Struct Reference
Common » Common Data

Spline point. More...

#include <zwapi_util.h>

Data Fields

svxPoint Pnt
point More...
int | UseCons
1-use the constraints data ,else 0 (0 as default) More...
evxContinuityTyp ContinuityTyp
continuity type (VX_NONE as default) More...
svxVector TangDir
tangent direction at this point (ContinuityTyp != VX_CONTIN_NONE) More...
int | UseG1Manitude
1-use G1 magnitude, else 0 (0 as default) More...
double | dG1Manitude
G1 magnitude (use this when UseG1Manitude != 0 ) More...
int | UseG2Radius
1-use G2 radius, else 0 (0 as default) More...
double | dG2Radius
G2 radius(use this when UseG2Radius != 0) More...
int | FlipDir
1-flip the TangDir, else 0 (0 as default) More...

Detailed Description

Spline point.

Definition at line 2366 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ Pnt

svxPoint svxSplinePnt::Pnt

point

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2368 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::TangDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ TangDir

svxVector svxSplinePnt::TangDir

tangent direction at this point (ContinuityTyp != VX_CONTIN_NONE)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2372 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::ContinuityTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ ContinuityTyp

evxContinuityTyp svxSplinePnt::ContinuityTyp

continuity type (VX_NONE as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2371 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::FlipDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ FlipDir

int svxSplinePnt::FlipDir

1-flip the TangDir, else 0 (0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2377 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::UseG2Radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ UseG2Radius

int svxSplinePnt::UseG2Radius

1-use G2 radius, else 0 (0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2375 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::dG2Radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ dG2Radius

double svxSplinePnt::dG2Radius

G2 radius(use this when UseG2Radius != 0)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2376 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::UseG1Manitude

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ UseG1Manitude

int svxSplinePnt::UseG1Manitude

1-use G1 magnitude, else 0 (0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2373 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::UseCons

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ UseCons

int svxSplinePnt::UseCons

1-use the constraints data ,else 0 (0 as default)

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2369 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplinePnt::dG1Manitude

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplinePnt
ContinuityTyp
dG1Manitude
dG2Radius
FlipDir
Pnt
TangDir
UseCons
UseG1Manitude
UseG2Radius

◆ dG1Manitude

double svxSplinePnt::dG1Manitude

G1 magnitude (use this when UseG1Manitude != 0 )

Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 2374 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSplitWithCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

split with curve data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | nFaces
count of faces or shapes to split More...
int * | idFaces
list of faces or shapes to split More...
int | nCrvs
count of split curves (0 to use intersecting curves to split faces) More...
int * | idCrvs
list of split curves (NULL to use intersecting curves to split faces) More...
evxTrimCrvsProjtype prjMethod
method to project the trimming curves onto the subject faces (VX_TRIMCRV_IN_PLACE as default) More...
svxVector direction
projection direction, used when prjMethod is VX_TRIMCRV_DIRECTED or VX_TRIMCRV_BI_DIRECTIONAL More...
int | explodeEdges
whether all new edges will be unsewn from the shape (0 as default) More...
int | extendCrvs
whether to automatically extend trim curves to boundary (0 as default) More...
int | removeSpurs
whether to remove the excess spurs and face edges (1 as default) More...

Detailed Description

split with curve data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 502 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::direction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ direction

svxVector svxSplitWithCrvData::direction

projection direction, used when prjMethod is VX_TRIMCRV_DIRECTED or VX_TRIMCRV_BI_DIRECTIONAL

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 509 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::nFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ nFaces

int svxSplitWithCrvData::nFaces

count of faces or shapes to split

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 504 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::explodeEdges

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ explodeEdges

int svxSplitWithCrvData::explodeEdges

whether all new edges will be unsewn from the shape (0 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 510 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::removeSpurs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ removeSpurs

int svxSplitWithCrvData::removeSpurs

whether to remove the excess spurs and face edges (1 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 512 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::nCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ nCrvs

int svxSplitWithCrvData::nCrvs

count of split curves (0 to use intersecting curves to split faces)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 506 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::idCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ idCrvs

int* svxSplitWithCrvData::idCrvs

list of split curves (NULL to use intersecting curves to split faces)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 507 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::prjMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ prjMethod

evxTrimCrvsProjtype svxSplitWithCrvData::prjMethod

method to project the trimming curves onto the subject faces (VX_TRIMCRV_IN_PLACE as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 508 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ idFaces

int* svxSplitWithCrvData::idFaces

list of faces or shapes to split

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 505 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSplitWithCrvData::extendCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSplitWithCrvData
direction
explodeEdges
extendCrvs
idCrvs
idFaces
nCrvs
nFaces
prjMethod
removeSpurs

◆ extendCrvs

int svxSplitWithCrvData::extendCrvs

whether to automatically extend trim curves to boundary (0 as default)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 511 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSrfPrim Struct Reference
Common » Common Data

3D NURB surface data More...

#include <zwapi_util.h>

Data Fields

evxSrfPrimType srfType
surface type More...
union {
svxPlane pln
data of plane More...
svxSphere sph
spherical surface data More...
svxCone con
conical surface data More...
svxCylinder cyl
cylindrical surface data More...
svxSurface srf
nurbs surface data More...
svxEllipsoid ellso
ellipsoid surface data More...
svxTorus torus
circular surface data More...
} srfData

Detailed Description

3D NURB surface data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1857 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::srf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ srf

svxSurface svxSrfPrim::srf

nurbs surface data

Definition at line 1866 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::cyl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ cyl

svxCylinder svxSrfPrim::cyl

cylindrical surface data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1865 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::srfType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ srfType

evxSrfPrimType svxSrfPrim::srfType

surface type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1859 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::pln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ pln

svxPlane svxSrfPrim::pln

data of plane

Definition at line 1862 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::sph

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ sph

svxSphere svxSrfPrim::sph

spherical surface data

Definition at line 1863 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::con

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ con

svxCone svxSrfPrim::con

conical surface data

Definition at line 1864 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::ellso

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ ellso

svxEllipsoid svxSrfPrim::ellso

ellipsoid surface data

Definition at line 1867 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSrfPrim::torus

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSrfPrim
con
cyl
ellso
pln
sph
srf
srfType
torus

◆ torus

svxTorus svxSrfPrim::torus

circular surface data

Definition at line 1868 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxStockData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

stock data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxStockOpt option
stock type(1:Block, 2:Cylinder) More...
int | numEnts
number of entities to enclose More...
int * | idEnts
list of entities to enclose (shape, face, block) More...
int | adjustType
Type of adjust value (0 = By side, 1 = By total) More...
int | decimal
number of decimal place More...
vxName ftrName
feature name for "FtExtStock2", 0 default More...
int | idPlane
id of reference plane to orient the stock, 0 to use default plane paralleled to XY datum (datum, planar face, sketch) More...
double | length [2]
when adjustType = 0, increment of length in the positive and negative directions when adjustType = 1, stock total length, just set the first value More...
double | width [2]
when adjustType = 0, increment of width in the positive and negative directions when adjustType = 1, stock total width, just set the first value More...
double | height [2]
when adjustType = 0, increment of height in the positive and negative directions when adjustType = 1, stock total height, just set the first value More...
svxAxis axis
spiral axis to specify the rotational center of the cylinder More...
int | axisPos
specify the center axis position of the cylinder (0 = on the setting axis, 1 = on the center of the shape More...
double | radius
when adjustType = 0, increment of radius when adjustType = 1, stock radius More...
double | cylHgt [2]
when adjustType = 0, increment of cylinder height in the positive and negative directions when adjustType = 1, cylinder total height, just set the first value More...

Detailed Description

stock data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 949 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ ftrName

vxName svxStockData::ftrName

feature name for "FtExtStock2", 0 default

Definition at line 956 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ length

double svxStockData::length[2]

when adjustType = 0, increment of length in the positive and negative directions when adjustType = 1, stock total length, just set the first value

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 961 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ axis

svxAxis svxStockData::axis

spiral axis to specify the rotational center of the cylinder

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 969 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::numEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ numEnts

int svxStockData::numEnts

number of entities to enclose

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 952 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ height

double svxStockData::height[2]

when adjustType = 0, increment of height in the positive and negative directions when adjustType = 1, stock total height, just set the first value

Definition at line 965 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::axisPos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ axisPos

int svxStockData::axisPos

specify the center axis position of the cylinder (0 = on the setting axis, 1 = on the center of the shape

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 970 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::adjustType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ adjustType

int svxStockData::adjustType

Type of adjust value (0 = By side, 1 = By total)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 954 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ width

double svxStockData::width[2]

when adjustType = 0, increment of width in the positive and negative directions when adjustType = 1, stock total width, just set the first value

Definition at line 963 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ radius

double svxStockData::radius

when adjustType = 0, increment of radius when adjustType = 1, stock radius

Definition at line 972 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ idPlane

int svxStockData::idPlane

id of reference plane to orient the stock, 0 to use default plane paralleled to XY datum (datum, planar face, sketch)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 959 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ option

evxStockOpt svxStockData::option

stock type(1:Block, 2:Cylinder)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 951 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::idEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ idEnts

int* svxStockData::idEnts

list of entities to enclose (shape, face, block)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 953 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::decimal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ decimal

int svxStockData::decimal

number of decimal place

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 955 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStockData::cylHgt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStockData
adjustType
axis
axisPos
cylHgt
decimal
ftrName
height
idEnts
idPlane
length
numEnts
option
radius
width

◆ cylHgt

double svxStockData::cylHgt[2]

when adjustType = 0, increment of cylinder height in the positive and negative directions when adjustType = 1, cylinder total height, just set the first value

Definition at line 974 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxStretchData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape stretch data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numShapes
numbers of stretched shapes More...
int * | idShapes
specify the shapes that will be stretched More...
int | idDatum
specify a plane that defines the XY coordinate system and the stretch center More...
double | xRange
specify the stretch range in X direction. 100 default More...
double | yRange
specify the stretch range in Y direction. 100 default More...
double | zRange
specify the stretch range in Z direction. 100 default More...
double | xScale
specify the scaling factor in X direction. 100 default More...
double | yScale
specify the scaling factor in Y direction. 100 default More...
double | zScale
specify the scaling factor in Z direction. 100 default More...
int | framework
controls the shape of the stretch shape (0 = Box, 1 = Ellipsoid. 0 default) More...
int | uniStress
whether to use the same scaling factor (0 = not use, 1 = use. 0 default) More...
int | keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default) More...
int | miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default) More...

Detailed Description

shape stretch data

Definition at line 1220 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::xRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ xRange

double svxStretchData::xRange

specify the stretch range in X direction. 100 default

Definition at line 1227 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::yScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ yScale

double svxStretchData::yScale

specify the scaling factor in Y direction. 100 default

Definition at line 1232 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::keepOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ keepOriginal

int svxStretchData::keepOriginal

whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)

Definition at line 1237 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::idDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ idDatum

int svxStretchData::idDatum

specify a plane that defines the XY coordinate system and the stretch center

Definition at line 1225 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::zScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ zScale

double svxStretchData::zScale

specify the scaling factor in Z direction. 100 default

Definition at line 1233 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::uniStress

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ uniStress

int svxStretchData::uniStress

whether to use the same scaling factor (0 = not use, 1 = use. 0 default)

Definition at line 1236 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ idShapes

int* svxStretchData::idShapes

specify the shapes that will be stretched

Definition at line 1224 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::xScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ xScale

double svxStretchData::xScale

specify the scaling factor in X direction. 100 default

Definition at line 1231 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::yRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ yRange

double svxStretchData::yRange

specify the stretch range in Y direction. 100 default

Definition at line 1228 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::framework

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ framework

int svxStretchData::framework

controls the shape of the stretch shape (0 = Box, 1 = Ellipsoid. 0 default)

Definition at line 1235 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::miniSurfData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ miniSurfData

int svxStretchData::miniSurfData

whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)

Definition at line 1238 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::zRange

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ zRange

double svxStretchData::zRange

specify the stretch range in Z direction. 100 default

Definition at line 1229 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxStretchData::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxStretchData
framework
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
uniStress
xRange
xScale
yRange
yScale
zRange
zScale

◆ numShapes

int svxStretchData::numShapes

numbers of stretched shapes

Definition at line 1223 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSurface Struct Reference
Common » Common Data

3D NURB surface (untrimmed) More...

#include <zwapi_util.h>

Data Fields

evxSurfaceType Type
surface type More...
int OutNormal
1 if the surface's natural normal points towards the outside of the shape it is associated with; 0 if the surface's natural normal points inward. More...
svxParameters U
NURB parameter space data in U direction. More...
svxParameters V
NURB parameter space data in V direction. More...
svxControlPoints P
NURB control point data (mm) More...

Detailed Description

3D NURB surface (untrimmed)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1738 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSurface
OutNormal
P
Type
U
V

◆ Type

evxSurfaceType svxSurface::Type

surface type

Definition at line 1740 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface::P

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSurface
OutNormal
P
Type
U
V

◆ P

svxControlPoints svxSurface::P

NURB control point data (mm)

Definition at line 1747 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface::OutNormal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSurface
OutNormal
P
Type
U
V

◆ OutNormal

int svxSurface::OutNormal

1 if the surface's natural normal points towards the outside of the shape it is associated with; 0 if the surface's natural normal points inward.

Definition at line 1741 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface::U

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSurface
OutNormal
P
Type
U
V

◆ U

svxParameters svxSurface::U

NURB parameter space data in U direction.

Definition at line 1745 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSurface::V

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSurface
OutNormal
P
Type
U
V

◆ V

svxParameters svxSurface::V

NURB parameter space data in V direction.

Definition at line 1746 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSweepData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

swept shape More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxBoolType Combine
combination method More...
int | idProfile
profile (sketch, curve, edge, curvelist) More...
int | idPath
id of curve that identifies the sweep path More...
svxPoint StartPnt
point that identifies start of path curve More...
int | idParent
id of path curve's parent sketch or curvelist More...
int | UseParent
1 to use curve's parent as the sweep path, else 0 More...
evxSweepOpt Option
sweep option(VX_SWP_AT_PROFILE as default) More...
int | idFrame
id of sweep frame if Option=VX_SWP_FRAME, else 0 More...
int | idXaxis
id of X-axis point, curve or plane (0 if undefined or tangent to path) More...
int | idZaxis
id of Z-axis point, curve or plane (0 if undefined or minimum twist) More...
double | Offset
profile offset (mm) (0 if undefined) More...
double | Thickness
wall thickness (mm) (0 if undefined) More...
int | useStartPnt
1- user "StartPnt", else 0 it will get the start point of the "idPath" More...
evxSweepXOpt xOpt
type of X-axis More...
evxSweepZOpt zOpt
type of Y-axis More...
svxPntOnEnt * xEnt
entity data of x-axis (NULL to ignore or use idZaxis or xOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR- use direction (just direction or direction from an curve/edge) VX_SWP_X_XAXIS_CRV - point on curve(set parent if the curve from the sketch) VX_SWP_X_FACE_NORMAL - face More...
svxPntOnEnt * zEnt
entity data of z-axis (NULL to ignore or use idZaxis or zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_TO_CRV- curve(set parent if the curve from the sketch) VX_SWP_Z_FIXED_DIR - use direction (just direction or direction from an curve/edge) More...
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness) More...
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open) More...
int | cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is open; valid if Combine is VX_BOOL_ADD and the idProfile is close) More...
int * | CapFace
cap face id list (NULL to ignore) More...
int | MergeFc
merge tangent faces (0 as default) More...

Detailed Description

swept shape

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 281 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idProfile

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idProfile

int svxSweepData::idProfile

profile (sketch, curve, edge, curvelist)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 284 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idXaxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idXaxis

int svxSweepData::idXaxis

id of X-axis point, curve or plane (0 if undefined or tangent to path)

Definition at line 296 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::useStartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ useStartPnt

int svxSweepData::useStartPnt

1- user "StartPnt", else 0 it will get the start point of the "idPath"

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 303 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::xEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ xEnt

svxPntOnEnt* svxSweepData::xEnt

entity data of x-axis (NULL to ignore or use idZaxis or xOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR- use direction (just direction or direction from an curve/edge) VX_SWP_X_XAXIS_CRV - point on curve(set parent if the curve from the sketch) VX_SWP_X_FACE_NORMAL - face

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 307 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::cntCap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ cntCap

int svxSweepData::cntCap

count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is open; valid if Combine is VX_BOOL_ADD and the idProfile is close)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 319 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::CapFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ CapFace

int* svxSweepData::CapFace

cap face id list (NULL to ignore)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 322 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::xOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ xOpt

evxSweepXOpt svxSweepData::xOpt

type of X-axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 305 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::StartPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ StartPnt

svxPoint svxSweepData::StartPnt

point that identifies start of path curve

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 286 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::zEnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ zEnt

svxPntOnEnt* svxSweepData::zEnt

entity data of z-axis (NULL to ignore or use idZaxis or zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_TO_CRV- curve(set parent if the curve from the sketch) VX_SWP_Z_FIXED_DIR - use direction (just direction or direction from an curve/edge)

offset type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 312 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::UseParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ UseParent

int svxSweepData::UseParent

1 to use curve's parent as the sweep path, else 0

Definition at line 290 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idPath

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idPath

int svxSweepData::idPath

id of curve that identifies the sweep path

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 285 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::CapType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ CapType

evxCapType svxSweepData::CapType

end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 318 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::Option

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ Option

evxSweepOpt svxSweepData::Option

sweep option(VX_SWP_AT_PROFILE as default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 292 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::Offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ Offset

double svxSweepData::Offset

profile offset (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 300 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idFrame

int svxSweepData::idFrame

id of sweep frame if Option=VX_SWP_FRAME, else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 294 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::MergeFc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ MergeFc

int svxSweepData::MergeFc

merge tangent faces (0 as default)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 323 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::zOpt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ zOpt

evxSweepZOpt svxSweepData::zOpt

type of Y-axis

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 306 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idZaxis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idZaxis

int svxSweepData::idZaxis

id of Z-axis point, curve or plane (0 if undefined or minimum twist)

Definition at line 298 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::Thickness

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ Thickness

double svxSweepData::Thickness

wall thickness (mm) (0 if undefined)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 301 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::idParent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ idParent

int svxSweepData::idParent

id of path curve's parent sketch or curvelist

Definition at line 289 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::Combine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ Combine

evxBoolType svxSweepData::Combine

combination method

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 283 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSweepData::OffsetTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSweepData
CapFace
CapType
cntCap
Combine
idFrame
idParent
idPath
idProfile
idXaxis
idZaxis
MergeFc
Offset
OffsetTyp
Option
StartPnt
Thickness
UseParent
useStartPnt
xEnt
xOpt
zEnt
zOpt

◆ OffsetTyp

evxOffsetType svxSweepData::OffsetTyp

option of offset(set the value of Offset and Thickness)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 316 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSymAttr Struct Reference
Drawing Objects » Drawing Data

symbol attributes structure More...

#include <zwapi_dwg_data.h>

Data Fields

int | allCir
all round circle (0-suppressed) More...
int | extLine
extender line (0-suppressed) More...
double | extLineSize
extender line size More...
evxTermType termType
terminator type More...
double | termSize
terminator size More...
char | fontName [37]
font name More...
char | fontName2 [37]
secondary font name More...
int | textTyp
text orientation (0-horizontal, 1-align) More...
int | bold
text bold flag: 0-normal, 1-bold More...
int | underLine
text underline flag: 0-normal, 1-underline More...
int | autoTxtFlg
auto change text direction flag More...
double | charHgt
text height More...
double | charAsp
text character aspect = width / height More...
double | charSpacing
text character spacing More...
evxColor textClr
text color More...
double | scaleFac
scale factor More...
svxLineAt symAttr
general symbol attribute More...
svxLineAt leaderAttr
leader line attributes More...

Detailed Description

symbol attributes structure

Definition at line 174 of file zwapi_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::autoTxtFlg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ autoTxtFlg

int svxSymAttr::autoTxtFlg

auto change text direction flag

Definition at line 186 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::underLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ underLine

int svxSymAttr::underLine

text underline flag: 0-normal, 1-underline

Definition at line 185 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::charHgt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ charHgt

double svxSymAttr::charHgt

text height

Definition at line 187 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::extLine

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ extLine

int svxSymAttr::extLine

extender line (0-suppressed)

Definition at line 177 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::allCir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ allCir

int svxSymAttr::allCir

all round circle (0-suppressed)

Definition at line 176 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::charAsp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ charAsp

double svxSymAttr::charAsp

text character aspect = width / height

Definition at line 188 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::termType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ termType

evxTermType svxSymAttr::termType

terminator type

Definition at line 179 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::symAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ symAttr

svxLineAt svxSymAttr::symAttr

general symbol attribute

Definition at line 192 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::leaderAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ leaderAttr

svxLineAt svxSymAttr::leaderAttr

leader line attributes

Definition at line 193 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::textTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ textTyp

int svxSymAttr::textTyp

text orientation (0-horizontal, 1-align)

Definition at line 183 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::fontName2

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ fontName2

char svxSymAttr::fontName2[37]

secondary font name

Definition at line 182 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ fontName

char svxSymAttr::fontName[37]

font name

Definition at line 181 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::scaleFac

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ scaleFac

double svxSymAttr::scaleFac

scale factor

Definition at line 191 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::extLineSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ extLineSize

double svxSymAttr::extLineSize

extender line size

Definition at line 178 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::termSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ termSize

double svxSymAttr::termSize

terminator size

Definition at line 180 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::charSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ charSpacing

double svxSymAttr::charSpacing

text character spacing

Definition at line 189 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::bold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ bold

int svxSymAttr::bold

text bold flag: 0-normal, 1-bold

Definition at line 184 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymAttr::textClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymAttr
allCir
autoTxtFlg
bold
charAsp
charHgt
charSpacing
extLine
extLineSize
fontName
fontName2
leaderAttr
scaleFac
symAttr
termSize
termType
textClr
textTyp
underLine

◆ textClr

evxColor svxSymAttr::textClr

text color

Definition at line 190 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSymImg Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

image data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

vxPath path
image path or user define string More...
int | firstPtType
type of 1st input point (0 corner, 1 center) More...
svxPoint2 | pts [2]
2 input points depend on "type" More...
double | width
width More...
double | height
height More...
double | angle
rotation angle(degree) More...
double | opaque
opaque factor More...
int | flip
flip flag (0-none, 1-with, 2-with y ) More...
int | locked
1-lock aspect ratio,0 not More...

Detailed Description

image data

Definition at line 1507 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ flip

int svxSymImg::flip

flip flag (0-none, 1-with, 2-with y )

Definition at line 1517 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::opaque

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ opaque

double svxSymImg::opaque

opaque factor

Definition at line 1516 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ angle

double svxSymImg::angle

rotation angle(degree)

Definition at line 1515 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ width

double svxSymImg::width

width

Definition at line 1513 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ height

double svxSymImg::height

height

Definition at line 1514 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::firstPtType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ firstPtType

int svxSymImg::firstPtType

type of 1st input point (0 corner, 1 center)

Definition at line 1511 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::pts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ pts

svxPoint2 svxSymImg::pts[2]

2 input points depend on "type"

Definition at line 1512 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::locked

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ locked

int svxSymImg::locked

1-lock aspect ratio,0 not

Definition at line 1518 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymImg::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymImg
angle
firstPtType
flip
height
locked
opaque
path
pts
width

◆ path

vxPath svxSymImg::path

image path or user define string

Definition at line 1510 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSymSurf Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

surface finish data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxSymSurf symTyp
symbol type More...
evxSurfPtnSym lay
surface pattern symbol More...
int | grinding
grinding More...
char | maxR [65]
max roughness average (or =NULL) More...
char | minR [65]
min roughness average (or =NULL) More...
char | procMeth [65]
processing method/treatment (or =NULL) More...
char | sampR [65]
sampling length/roughness cutout (or =NULL) More...
char | machAllow [65]
machining allowance (or =NULL) More...
char | R [65]
Rz, roughness value (or =NULL) More...
char | otherR [65]
other roughness value/spacing (or =NULL) More...
char | optStr [65]
third row optional string (or =NULL) More...
int | prepFlag
perpendicular flag (0-no, 1-perpendicular, 2-reverse) More...
double | rotation
rotation angle(degree), only used when prepFlag = 0 More...
int | useLeadPnt
whether to use leader point More...
svxPoint2 leadPoint
coordinate of the leader point, only used when useleadPnt = 1 More...

Detailed Description

surface finish data

Definition at line 1484 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::maxR

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ maxR

char svxSymSurf::maxR[65]

max roughness average (or =NULL)

Definition at line 1489 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::prepFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ prepFlag

int svxSymSurf::prepFlag

perpendicular flag (0-no, 1-perpendicular, 2-reverse)

Definition at line 1497 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::minR

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ minR

char svxSymSurf::minR[65]

min roughness average (or =NULL)

Definition at line 1490 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::otherR

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ otherR

char svxSymSurf::otherR[65]

other roughness value/spacing (or =NULL)

Definition at line 1495 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::useLeadPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ useLeadPnt

int svxSymSurf::useLeadPnt

whether to use leader point

Definition at line 1499 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::symTyp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ symTyp

evxSymSurf svxSymSurf::symTyp

symbol type

Definition at line 1486 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::grinding

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ grinding

int svxSymSurf::grinding

grinding

Definition at line 1488 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::procMeth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ procMeth

char svxSymSurf::procMeth[65]

processing method/treatment (or =NULL)

Definition at line 1491 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::leadPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ leadPoint

svxPoint2 svxSymSurf::leadPoint

coordinate of the leader point, only used when useleadPnt = 1

Definition at line 1500 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::R

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ R

char svxSymSurf::R[65]

Rz, roughness value (or =NULL)

Definition at line 1494 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::rotation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ rotation

double svxSymSurf::rotation

rotation angle(degree), only used when prepFlag = 0

Definition at line 1498 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::lay

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ lay

evxSurfPtnSym svxSymSurf::lay

surface pattern symbol

Definition at line 1487 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::sampR

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ sampR

char svxSymSurf::sampR[65]

sampling length/roughness cutout (or =NULL)

Definition at line 1492 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::machAllow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ machAllow

char svxSymSurf::machAllow[65]

machining allowance (or =NULL)

Definition at line 1493 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymSurf::optStr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymSurf
grinding
lay
leadPoint
machAllow
maxR
minR
optStr
otherR
prepFlag
procMeth
R
rotation
sampR
symTyp
useLeadPnt

◆ optStr

char svxSymSurf::optStr[65]

third row optional string (or =NULL)

Definition at line 1496 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxSymWeld Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

Weld data. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxWeldFinishSym finishSymUp
finish symbol (other side) More...
evxWeldContourSym contourSymUp
contour symbol (other side) More...
int | lineFlg
line flag 0:plain, 1:below, 2:above More...
int | stagger
stagger (0: suppress; 1: enable) More...
int | filletSecUp
2nd fillet (other side) (0: suppress; 1: enable) More...
int | weldSymUp
weld symbol (other side) (1 ~ 35) More...
int | fieldFlg
field flag (0: suppress; 1: enable) More...
int | aroundCir
all round circle (0 ~ 2) More...
int | tail
tail (0 ~ 2) More...
int | weldSymDwn
weld symbol (arrow side) (1 ~ 35) More...
int | filletSecDwn
2nd fillet (arrow side) (0: suppress; 1: enable) More...
evxWeldContourSym contourSymDwn
contour symbol (arrow side) More...
evxWeldFinishSym finishSymDwn
finish symbol (arrow side) More...
int | inWeldTbl
include in weld table flag More...
char | GrooveAngUp [33]
groove angle (arrow side) More...
char | filleSecSzUp [33]
2nd fillet size (other side) More...
char | filletSecLenUp [33]
2nd fillet length (other side) More...
char | depthPrepUp [33]
depth of preparation, size or strength, effective throat, or groove weld size More...
char | weldLenPitchUp [33]
length and pitch of weld More...
char | tailRef [65]
tail reference More...
char | depthPrepDwn [33]
depth of preparation, size or strength, effective throat, or groove weld size More...
char | weldLenPitchDwn [33]
length and pitch of weld More...
char | filletSecSzDwn [33]
2nd fillet size (arrow side) More...
char | filletSecLenDwn [33]
2nd fillet length (arrow side) More...
char | weldRoot [33]
root opening/depth of filling/number of weld More...
char | grooveAngDwn [33]
groove angle (other side) More...
char | weldOtherRoot [33]
root opening/depth of filling/number of weld (other side) More...
double | gapSpacing
ratio for symbol gap More...
int | useLocPoint
whether to use location point setting, 0 to use default point More...
svxPoint2 locPoint
the coordinate of location point More...
int | numJogs
number of jog points More...
svxPoint2 * jogPoints
list of coordinate of jog points More...
int | numLeaders
number of leader points More...
svxPoint2 * leaderPoints
list of coordinate of leader points More...

Detailed Description

Weld data.

Definition at line 1407 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::locPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ locPoint

svxPoint2 svxSymWeld::locPoint

the coordinate of location point

Definition at line 1440 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldSymDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldSymDwn

int svxSymWeld::weldSymDwn

weld symbol (arrow side) (1 ~ 35)

Definition at line 1418 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::gapSpacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ gapSpacing

double svxSymWeld::gapSpacing

ratio for symbol gap

Definition at line 1438 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::tail

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ tail

int svxSymWeld::tail

tail (0 ~ 2)

Definition at line 1417 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::tailRef

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ tailRef

char svxSymWeld::tailRef[65]

tail reference

Definition at line 1429 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldRoot

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldRoot

char svxSymWeld::weldRoot[33]

root opening/depth of filling/number of weld

Definition at line 1435 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filleSecSzUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filleSecSzUp

char svxSymWeld::filleSecSzUp[33]

2nd fillet size (other side)

Definition at line 1424 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::numLeaders

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ numLeaders

int svxSymWeld::numLeaders

number of leader points

Definition at line 1443 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filletSecUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filletSecUp

int svxSymWeld::filletSecUp

2nd fillet (other side) (0: suppress; 1: enable)

Definition at line 1413 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filletSecDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filletSecDwn

int svxSymWeld::filletSecDwn

2nd fillet (arrow side) (0: suppress; 1: enable)

Definition at line 1419 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::stagger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ stagger

int svxSymWeld::stagger

stagger (0: suppress; 1: enable)

Definition at line 1412 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::grooveAngDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ grooveAngDwn

char svxSymWeld::grooveAngDwn[33]

groove angle (other side)

Definition at line 1436 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::finishSymDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ finishSymDwn

evxWeldFinishSym svxSymWeld::finishSymDwn

finish symbol (arrow side)

Definition at line 1421 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldLenPitchUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldLenPitchUp

char svxSymWeld::weldLenPitchUp[33]

length and pitch of weld

Definition at line 1428 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::useLocPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ useLocPoint

int svxSymWeld::useLocPoint

whether to use location point setting, 0 to use default point

Definition at line 1439 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::lineFlg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ lineFlg

int svxSymWeld::lineFlg

line flag 0:plain, 1:below, 2:above

Definition at line 1411 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldOtherRoot

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldOtherRoot

char svxSymWeld::weldOtherRoot[33]

root opening/depth of filling/number of weld (other side)

Definition at line 1437 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::aroundCir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ aroundCir

int svxSymWeld::aroundCir

all round circle (0 ~ 2)

Definition at line 1416 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::numJogs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ numJogs

int svxSymWeld::numJogs

number of jog points

Definition at line 1441 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::leaderPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ leaderPoints

svxPoint2* svxSymWeld::leaderPoints

list of coordinate of leader points

Definition at line 1444 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::inWeldTbl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ inWeldTbl

int svxSymWeld::inWeldTbl

include in weld table flag

Definition at line 1422 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filletSecSzDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filletSecSzDwn

char svxSymWeld::filletSecSzDwn[33]

2nd fillet size (arrow side)

Definition at line 1433 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldLenPitchDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldLenPitchDwn

char svxSymWeld::weldLenPitchDwn[33]

length and pitch of weld

Definition at line 1432 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::fieldFlg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ fieldFlg

int svxSymWeld::fieldFlg

field flag (0: suppress; 1: enable)

Definition at line 1415 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::depthPrepDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ depthPrepDwn

char svxSymWeld::depthPrepDwn[33]

depth of preparation, size or strength, effective throat, or groove weld size

Definition at line 1430 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::depthPrepUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ depthPrepUp

char svxSymWeld::depthPrepUp[33]

depth of preparation, size or strength, effective throat, or groove weld size

Definition at line 1426 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::finishSymUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ finishSymUp

evxWeldFinishSym svxSymWeld::finishSymUp

finish symbol (other side)

Definition at line 1409 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::contourSymUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ contourSymUp

evxWeldContourSym svxSymWeld::contourSymUp

contour symbol (other side)

Definition at line 1410 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::contourSymDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ contourSymDwn

evxWeldContourSym svxSymWeld::contourSymDwn

contour symbol (arrow side)

Definition at line 1420 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::weldSymUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ weldSymUp

int svxSymWeld::weldSymUp

weld symbol (other side) (1 ~ 35)

Definition at line 1414 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::jogPoints

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ jogPoints

svxPoint2* svxSymWeld::jogPoints

list of coordinate of jog points

Definition at line 1442 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filletSecLenDwn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filletSecLenDwn

char svxSymWeld::filletSecLenDwn[33]

2nd fillet length (arrow side)

Definition at line 1434 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::filletSecLenUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ filletSecLenUp

char svxSymWeld::filletSecLenUp[33]

2nd fillet length (other side)

Definition at line 1425 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxSymWeld::GrooveAngUp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSymWeld
aroundCir
contourSymDwn
contourSymUp
depthPrepDwn
depthPrepUp
fieldFlg
filleSecSzUp
filletSecDwn
filletSecLenDwn
filletSecLenUp
filletSecSzDwn
filletSecUp
finishSymDwn
finishSymUp
gapSpacing
grooveAngDwn
GrooveAngUp
inWeldTbl
jogPoints
leaderPoints
lineFlg
locPoint
numJogs
numLeaders
stagger
tail
tailRef
useLocPoint
weldLenPitchDwn
weldLenPitchUp
weldOtherRoot
weldRoot
weldSymDwn
weldSymUp

◆ GrooveAngUp

char svxSymWeld::GrooveAngUp[33]

groove angle (arrow side)

Definition at line 1423 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTableAt Struct Reference
UI » UI Data

table attributes More...

#include <zwapi_ui_data.h>

Data Fields

int | Row
int | Col
specification of row/column that attributes are applied to; Row > -1 and Col > -1 identifies a specific cell in the table; Row > -1 and Col = -1 identifies an entire row; Row = -1 and Col > -1 identifies an entire column; Row = -1 and Col = -1 identifies the entire table. More...
int | RowHeight
row height; 0 to ignore; -1 for default height More...
int | ColWidth
column width; 0 to ignore; -1 for default height More...
int | SetBgColor
1 to set background color of table cells specified by "Row" and "Col"; 0 to ignore. More...
svxColor BgColor
background color if "SetBgColor = 1" More...
int | SetFgColor
1 to set foreground color of table cells specified by "Row" and "Col"; 0 to ignore. More...
svxColor FgColor
foreground color if "SetFgColor = 1" More...
int | SortRows
1 to sort rows on column header; -1 to not sort; 0 to ignore More...
int | AutoSize
1 to auto-size all rows to the size of the largest item; 2 to auto-size all columns to the size of the largest item; 3 to auto-size all rows and columns; -1 to disable auto-size; 0 to ignore. More...
int | AllowResize
1 to allow rows to be resized; 2 to allow columns to be resized; 3 to allow both to be resized; -1 to disable resize; 0 to ignore. The priority of auto size is higher than that of allowsize. More...
int | Editable
1 to make cells specified by "Row" and "Col" editable; -1 to make specified cells not editable; 0 to ignore. More...

Detailed Description

table attributes

Definition at line 215 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::SetBgColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ SetBgColor

int svxTableAt::SetBgColor

1 to set background color of table cells specified by "Row" and "Col"; 0 to ignore.

Definition at line 227 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::ColWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ ColWidth

int svxTableAt::ColWidth

column width; 0 to ignore; -1 for default height

Definition at line 225 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::AutoSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ AutoSize

int svxTableAt::AutoSize

1 to auto-size all rows to the size of the largest item; 2 to auto-size all columns to the size of the largest item; 3 to auto-size all rows and columns; -1 to disable auto-size; 0 to ignore.

Definition at line 239 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::BgColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ BgColor

svxColor svxTableAt::BgColor

background color if "SetBgColor = 1"

Definition at line 230 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::FgColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ FgColor

svxColor svxTableAt::FgColor

foreground color if "SetFgColor = 1"

Definition at line 235 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::Col

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ Col

int svxTableAt::Col

specification of row/column that attributes are applied to; Row > -1 and Col > -1 identifies a specific cell in the table; Row > -1 and Col = -1 identifies an entire row; Row = -1 and Col > -1 identifies an entire column; Row = -1 and Col = -1 identifies the entire table.

Definition at line 217 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::Row

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ Row

int svxTableAt::Row

Definition at line 217 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::Editable

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ Editable

int svxTableAt::Editable

1 to make cells specified by "Row" and "Col" editable; -1 to make specified cells not editable; 0 to ignore.

Definition at line 250 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::RowHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ RowHeight

int svxTableAt::RowHeight

row height; 0 to ignore; -1 for default height

Definition at line 224 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::SetFgColor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ SetFgColor

int svxTableAt::SetFgColor

1 to set foreground color of table cells specified by "Row" and "Col"; 0 to ignore.

Definition at line 232 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::AllowResize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ AllowResize

int svxTableAt::AllowResize

1 to allow rows to be resized; 2 to allow columns to be resized; 3 to allow both to be resized; -1 to disable resize; 0 to ignore. The priority of auto size is higher than that of allowsize.

Definition at line 245 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableAt::SortRows

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableAt
AllowResize
AutoSize
BgColor
Col
ColWidth
Editable
FgColor
RowHeight
SetBgColor
SetFgColor
SortRows

◆ SortRows

int svxTableAt::SortRows

1 to sort rows on column header; -1 to not sort; 0 to ignore

Definition at line 237 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTableCallBackParam Struct Reference
UI » UI Data

table widget callback function parameters More...

#include <zwapi_ui_data.h>

Data Fields

evxTableEvent evt
table widget event types More...
svxKeyEvent key
keyboard event More...
int | iRow
row More...
int | iCol
column More...
svxTableCellData cellData
table cell data More...
int * | pResult
int | iSortSequenceSize
size of aSortSequence More...
int * | aSortSequence

Detailed Description

table widget callback function parameters

Definition at line 400 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::key

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ key

svxKeyEvent svxTableCallBackParam::key

keyboard event

Definition at line 403 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::iRow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ iRow

int svxTableCallBackParam::iRow

row

Definition at line 404 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::iCol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ iCol

int svxTableCallBackParam::iCol

column

Definition at line 405 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::aSortSequence

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ aSortSequence

int* svxTableCallBackParam::aSortSequence

Definition at line 409 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::cellData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ cellData

svxTableCellData svxTableCallBackParam::cellData

table cell data

Definition at line 406 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::pResult

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ pResult

int* svxTableCallBackParam::pResult

Definition at line 407 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::iSortSequenceSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ iSortSequenceSize

int svxTableCallBackParam::iSortSequenceSize

size of aSortSequence

Definition at line 408 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCallBackParam::evt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCallBackParam
cellData
evt
iCol
iRow
iSortSequenceSize
key

◆ evt

evxTableEvent svxTableCallBackParam::evt

table widget event types

Definition at line 402 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxTableCellData Struct Reference
UI » UI Data

table cell data More...

#include <zwapi_ui_data.h>

Data Structures

union | svxCellData
struct | svxCompareData

Data Fields

union svxTableCellData::svxCellData | cellData
int | iAttrData
struct svxTableCellData::svxCompareData | compareData
int | idx
int | txtMaxLen
const char * | placeHolderText
void * | validator

Detailed Description

table cell data

Definition at line 335 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxCheckData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxCheckData
Data Fields
svxTableCellData::svxCellData::svxCheckData Struct Reference

Data Fields

const char * | psLabel
In. More...
int | iCheck
In/Out. More...

Detailed Description

Definition at line 357 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxCheckData::iCheck

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxCheckData
iCheck
psLabel

◆ iCheck

int svxTableCellData::svxCellData::svxCheckData::iCheck

In/Out.

Definition at line 360 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxCheckData::psLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxCheckData
iCheck
psLabel

◆ psLabel

const char* svxTableCellData::svxCellData::svxCheckData::psLabel

In.

Definition at line 359 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
Data Fields
svxTableCellData::svxCellData::svxColorData Struct Reference

Data Fields

unsigned char | type
In: 0-true color, 1-index color, 2-include FROM PART. More...
int | clrIndex
In/Out. More...
int | r
int | g
int | b
In/Out. More...

Detailed Description

Definition at line 367 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData::g

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
b
clrIndex
type

◆ g

int svxTableCellData::svxCellData::svxColorData::g

Definition at line 371 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData::clrIndex

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
b
clrIndex
type

◆ clrIndex

int svxTableCellData::svxCellData::svxColorData::clrIndex

In/Out.

Definition at line 370 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
b
clrIndex
type

◆ type

unsigned char svxTableCellData::svxCellData::svxColorData::type

In: 0-true color, 1-index color, 2-include FROM PART.

Definition at line 369 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData::r

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
b
clrIndex
type

◆ r

int svxTableCellData::svxCellData::svxColorData::r

Definition at line 371 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxColorData::b

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxColorData
b
clrIndex
type

◆ b

int svxTableCellData::svxCellData::svxColorData::b

In/Out.

Definition at line 371 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
Data Fields
svxTableCellData::svxCellData::svxComboData Struct Reference

Data Fields

const char * | pImageList
In. More...
const char * | pTextList
In. More...
char * | pSelTextBuf
In/Out. More...
int | nBufSize
In. More...
int | iSel
In/Out. More...

Detailed Description

Definition at line 349 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData::iSel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
iSel
nBufSize
pImageList
pSelTextBuf
pTextList

◆ iSel

int svxTableCellData::svxCellData::svxComboData::iSel

In/Out.

Definition at line 355 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData::nBufSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
iSel
nBufSize
pImageList
pSelTextBuf
pTextList

◆ nBufSize

int svxTableCellData::svxCellData::svxComboData::nBufSize

In.

Definition at line 354 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData::pImageList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
iSel
nBufSize
pImageList
pSelTextBuf
pTextList

◆ pImageList

const char* svxTableCellData::svxCellData::svxComboData::pImageList

In.

Definition at line 351 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData::pSelTextBuf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
iSel
nBufSize
pImageList
pSelTextBuf
pTextList

◆ pSelTextBuf

char* svxTableCellData::svxCellData::svxComboData::pSelTextBuf

In/Out.

Definition at line 353 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxComboData::pTextList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxComboData
iSel
nBufSize
pImageList
pSelTextBuf
pTextList

◆ pTextList

const char* svxTableCellData::svxCellData::svxComboData::pTextList

In.

Definition at line 352 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxDateData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxDateData
Data Fields
svxTableCellData::svxCellData::svxDateData Struct Reference

Data Fields

int secsFromEpoch
In/Out. More...
evxDateType dateType
In. More...

Detailed Description

Definition at line 362 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxDateData::dateType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxDateData
dateType
secsFromEpoch

◆ dateType

evxDateType svxTableCellData::svxCellData::svxDateData::dateType

In.

Definition at line 365 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxDateData::secsFromEpoch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxDateData
dateType
secsFromEpoch

◆ secsFromEpoch

int svxTableCellData::svxCellData::svxDateData::secsFromEpoch

In/Out.

Definition at line 364 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxNumData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxNumData
Data Fields
svxTableCellData::svxCellData::svxNumData Struct Reference

Data Fields

int | iMin
In. More...
int | iMax
In. More...
char * | buf
In/Out. More...
int | nBufSize
In. More...

Detailed Description

Definition at line 373 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxNumData::iMin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxNumData
buf
iMax
iMin
nBufSize

◆ iMin

int svxTableCellData::svxCellData::svxNumData::iMin

In.

Definition at line 375 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxNumData::buf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxNumData
buf
iMax
iMin
nBufSize

◆ buf

char* svxTableCellData::svxCellData::svxNumData::buf

In/Out.

Definition at line 377 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxNumData::nBufSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxNumData
buf
iMax
iMin
nBufSize

◆ nBufSize

int svxTableCellData::svxCellData::svxNumData::nBufSize

In.

Definition at line 378 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxNumData::iMax

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxNumData
buf
iMax
iMin
nBufSize

◆ iMax

int svxTableCellData::svxCellData::svxNumData::iMax

In.

Definition at line 376 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
Data Fields
svxTableCellData::svxCellData::svxTextData Struct Reference

Data Fields

const char * | pImage
In. More...
char * | buf
In/Out. More...
int | nBufSize
In. More...
const char * | btnToolTip
In. More...
int | btnWidth
In. More...
int | btnHeight
In. More...
unsigned char | isCIF
In: 0-ANSI string, 1-buf is multi-byte string in CIF format. More...

Detailed Description

Definition at line 339 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::btnWidth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ btnWidth

int svxTableCellData::svxCellData::svxTextData::btnWidth

In.

Definition at line 345 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::btnToolTip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ btnToolTip

const char* svxTableCellData::svxCellData::svxTextData::btnToolTip

In.

Definition at line 344 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::buf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ buf

char* svxTableCellData::svxCellData::svxTextData::buf

In/Out.

Definition at line 342 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::nBufSize

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ nBufSize

int svxTableCellData::svxCellData::svxTextData::nBufSize

In.

Definition at line 343 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::isCIF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ isCIF

unsigned char svxTableCellData::svxCellData::svxTextData::isCIF

In: 0-ANSI string, 1-buf is multi-byte string in CIF format.

Definition at line 347 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::pImage

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ pImage

const char* svxTableCellData::svxCellData::svxTextData::pImage

In.

Definition at line 341 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData::svxTextData::btnHeight

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
  • svxTextData
btnHeight
btnToolTip
btnWidth
buf
isCIF
nBufSize
pImage

◆ btnHeight

int svxTableCellData::svxCellData::svxTextData::btnHeight

In.

Definition at line 346 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
Data Fields
svxTableCellData::svxCompareData Struct Reference

Data Fields

int | iType
In 1-integer, 2-string, 3-double. More...
int | iInteger
In. More...
const char * | pString
In. More...
double | dDouble
In. More...
int | iKeyCol
In. More...

Detailed Description

Definition at line 382 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData::dDouble

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
dDouble
iInteger
iKeyCol
iType
pString

◆ dDouble

double svxTableCellData::svxCompareData::dDouble

In.

Definition at line 387 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData::iKeyCol

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
dDouble
iInteger
iKeyCol
iType
pString

◆ iKeyCol

int svxTableCellData::svxCompareData::iKeyCol

In.

Definition at line 388 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData::iType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
dDouble
iInteger
iKeyCol
iType
pString

◆ iType

int svxTableCellData::svxCompareData::iType

In 1-integer, 2-string, 3-double.

Definition at line 384 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData::iInteger

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
dDouble
iInteger
iKeyCol
iType
pString

◆ iInteger

int svxTableCellData::svxCompareData::iInteger

In.

Definition at line 385 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCompareData::pString

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCompareData
dDouble
iInteger
iKeyCol
iType
pString

◆ pString

const char* svxTableCellData::svxCompareData::pString

In.

Definition at line 386 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::idx

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData

◆ idx

int svxTableCellData::idx

Definition at line 390 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::placeHolderText

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData

◆ placeHolderText

const char* svxTableCellData::placeHolderText

Definition at line 392 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::validator

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData

◆ validator

void* svxTableCellData::validator

Definition at line 393 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::iAttrData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData

◆ iAttrData

int svxTableCellData::iAttrData

Definition at line 381 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::txtMaxLen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData

◆ txtMaxLen

int svxTableCellData::txtMaxLen

Definition at line 391 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTaperData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape taper data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numShapes
numbers of taper shapes More...
int * | idShapes
specify the shapes that will be tapered More...
int | idDatum
specify a plane that defines the XY coordinate system of the geometry that is to be tapered More...
double | range
specify the distance to the datum. More...
double | factor
specify the size of the smaller side of the tapered shape. More...
svxVector * axis
specify the optional taper axis. nullptr default More...
int | keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default) More...
int | miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default) More...

Detailed Description

shape taper data

Definition at line 1202 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::factor

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ factor

double svxTaperData::factor

specify the size of the smaller side of the tapered shape.

Definition at line 1209 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::idDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ idDatum

int svxTaperData::idDatum

specify a plane that defines the XY coordinate system of the geometry that is to be tapered

Definition at line 1207 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ idShapes

int* svxTaperData::idShapes

specify the shapes that will be tapered

Definition at line 1206 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ numShapes

int svxTaperData::numShapes

numbers of taper shapes

Definition at line 1205 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::range

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ range

double svxTaperData::range

specify the distance to the datum.

Definition at line 1208 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::keepOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ keepOriginal

int svxTaperData::keepOriginal

whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)

Definition at line 1212 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::miniSurfData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ miniSurfData

int svxTaperData::miniSurfData

whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)

Definition at line 1213 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTaperData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTaperData
axis
factor
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ axis

svxVector* svxTaperData::axis

specify the optional taper axis. nullptr default

Definition at line 1211 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTextAt Struct Reference
Common » Common Data

text attribute More...

#include <zwapi_util.h>

Data Fields

unsigned char | bold
bold flag 0-normal, 1-bold More...
unsigned char | underline
underline flag 0x01-ul, overline flag 0x02-ol, delete line flag 0x04-dl More...
unsigned char | italic
italic flag 0-normal, 1-italic More...
unsigned char | word_wrap
fit method 0-none, 1-word wrap, 2-auto size text More...
char | fontName [36]
font name More...
float | char_height
text height More...
float | char_aspect
width of text, char_aspect = width / height More...
float | multi_line_space
Vertical spacing between text. More...
float | char_spacing
Horizontal spacing between text. More...
evxColor color
unsigned char | size
the width of line More...
unsigned char | precision
text precision More...
unsigned char | font_type
font type (ex: proportional) More...
unsigned char | hor_align_type
horizontal text alignment type More...
unsigned char | hor_align
horizontal text alignment More...
unsigned char | vert_align_type
vertical text alignment type More...
unsigned char | vert_align
vertical text alignment More...
float | path
path of text as angle 0.0-360.0 degrees
More...
float | text_angle
slope of text More...
float | char_slant
slant of text More...
float | text_expansion
Multiplier for text expansion. More...
float | first_line_ind
first line indent More...
float | hanging_ind
hanging indent More...
float | right_ind
right indent More...

Detailed Description

text attribute

Examples
drawing\dwgTableTest.cpp.

Definition at line 1453 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::right_ind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ right_ind

float svxTextAt::right_ind

right indent

Definition at line 1485 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::char_spacing

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ char_spacing

float svxTextAt::char_spacing

Horizontal spacing between text.

Definition at line 1466 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::text_expansion

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ text_expansion

float svxTextAt::text_expansion

Multiplier for text expansion.

Definition at line 1481 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::hor_align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ hor_align

unsigned char svxTextAt::hor_align

horizontal text alignment

Definition at line 1474 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::precision

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ precision

unsigned char svxTextAt::precision

text precision

Definition at line 1470 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::char_height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ char_height

float svxTextAt::char_height

text height

Examples
drawing\dwgTableTest.cpp.

Definition at line 1463 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ path

float svxTextAt::path

path of text as angle 0.0-360.0 degrees

Definition at line 1478 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::vert_align

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ vert_align

unsigned char svxTextAt::vert_align

vertical text alignment

Definition at line 1476 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::font_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ font_type

unsigned char svxTextAt::font_type

font type (ex: proportional)

Definition at line 1471 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::italic

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ italic

unsigned char svxTextAt::italic

italic flag 0-normal, 1-italic

Examples
drawing\dwgTableTest.cpp.

Definition at line 1459 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::bold

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ bold

unsigned char svxTextAt::bold

bold flag 0-normal, 1-bold

Examples
drawing\dwgTableTest.cpp.

Definition at line 1455 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::multi_line_space

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ multi_line_space

float svxTextAt::multi_line_space

Vertical spacing between text.

Definition at line 1465 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::char_slant

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ char_slant

float svxTextAt::char_slant

slant of text

Definition at line 1480 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::hor_align_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ hor_align_type

unsigned char svxTextAt::hor_align_type

horizontal text alignment type

Definition at line 1473 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ size

unsigned char svxTextAt::size

the width of line

Definition at line 1469 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::word_wrap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ word_wrap

unsigned char svxTextAt::word_wrap

fit method 0-none, 1-word wrap, 2-auto size text

Definition at line 1460 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::text_angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ text_angle

float svxTextAt::text_angle

slope of text

Definition at line 1479 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::underline

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ underline

unsigned char svxTextAt::underline

underline flag 0x01-ul, overline flag 0x02-ol, delete line flag 0x04-dl

Examples
drawing\dwgTableTest.cpp.

Definition at line 1456 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ color

evxColor svxTextAt::color
Examples
drawing\dwgTableTest.cpp.

Definition at line 1468 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::fontName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ fontName

char svxTextAt::fontName[36]

font name

Examples
drawing\dwgTableTest.cpp.

Definition at line 1461 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::vert_align_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ vert_align_type

unsigned char svxTextAt::vert_align_type

vertical text alignment type

Definition at line 1475 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::first_line_ind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ first_line_ind

float svxTextAt::first_line_ind

first line indent

Definition at line 1483 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::char_aspect

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ char_aspect

float svxTextAt::char_aspect

width of text, char_aspect = width / height

Examples
drawing\dwgTableTest.cpp.

Definition at line 1464 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextAt::hanging_ind

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextAt
bold
char_aspect
char_height
char_slant
char_spacing
first_line_ind
font_type
fontName
hanging_ind
hor_align
hor_align_type
italic
multi_line_space
path
precision
right_ind
size
text_angle
text_expansion
underline
vert_align
vert_align_type
word_wrap

◆ hanging_ind

float svxTextAt::hanging_ind

hanging indent

Definition at line 1484 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTextLoc Struct Reference
Common » Text Common API

text location More...

#include <zwapi_text.h>

Data Fields

unsigned char | mirror
mirror flag 0-normal , 1-mirror More...
float | text_radius
radius of arc that the text follows More...
float | scale
text scale factor More...
svxPoint2f origin_point
text origin point More...
svxPoint2f align_point
text alignment point More...
svxPoint2f | mirror_axis [2]
two points defining mirror axis More...
svxPoint2f | bbox [2]
two points defining text bounding box More...

Detailed Description

text location

Definition at line 30 of file zwapi_text.h.

The documentation for this struct was generated from the following file:
  • zwapi_text.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::bbox

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ bbox

svxPoint2f svxTextLoc::bbox[2]

two points defining text bounding box

Definition at line 38 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::origin_point

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ origin_point

svxPoint2f svxTextLoc::origin_point

text origin point

Definition at line 35 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::text_radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ text_radius

float svxTextLoc::text_radius

radius of arc that the text follows

Definition at line 33 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::mirror

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ mirror

unsigned char svxTextLoc::mirror

mirror flag 0-normal , 1-mirror

Definition at line 32 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::align_point

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ align_point

svxPoint2f svxTextLoc::align_point

text alignment point

Definition at line 36 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::scale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ scale

float svxTextLoc::scale

text scale factor

Definition at line 34 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextLoc::mirror_axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextLoc
align_point
bbox
mirror
mirror_axis
origin_point
scale
text_radius

◆ mirror_axis

svxPoint2f svxTextLoc::mirror_axis[2]

two points defining mirror axis

Definition at line 37 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTextureAt Struct Reference
Common » Common Data

texture attribute More...

#include <zwapi_util.h>

Data Fields

evxTextureOpt opt
texture option (zero if undefined) More...
vxPath file
texture path/file name (blank if undefined) More...
unsigned char | dimen
texture dimension (1-3) More...
unsigned char | repeat
1 to repeat texture, else 0 More...
float | trans
texture transparency (0 to 1.0) More...
double | height
texture height (mm) More...
double | width
texture width (mm) More...
double | angle
texture angle (deg) More...
svxPoint origin
texture origin More...
int | use_embed
as an input, 1 means a pre-existing embedded
image takes precedence over file, 0 means file
replaces any pre-existing embedded image; as
an output, 1 means an embedded image exists
for file, 0 means there is no embedded image. More...
evxTextureLoc location
texture location relative to origin More...

Detailed Description

texture attribute

Definition at line 1265 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::repeat

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ repeat

unsigned char svxTextureAt::repeat

1 to repeat texture, else 0

Definition at line 1270 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::trans

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ trans

float svxTextureAt::trans

texture transparency (0 to 1.0)

Definition at line 1271 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::dimen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ dimen

unsigned char svxTextureAt::dimen

texture dimension (1-3)

Definition at line 1269 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::file

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ file

vxPath svxTextureAt::file

texture path/file name (blank if undefined)

Definition at line 1268 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::height

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ height

double svxTextureAt::height

texture height (mm)

Definition at line 1272 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::use_embed

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ use_embed

int svxTextureAt::use_embed

as an input, 1 means a pre-existing embedded
image takes precedence over file, 0 means file
replaces any pre-existing embedded image; as
an output, 1 means an embedded image exists
for file, 0 means there is no embedded image.

Definition at line 1276 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ angle

double svxTextureAt::angle

texture angle (deg)

Definition at line 1274 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::width

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ width

double svxTextureAt::width

texture width (mm)

Definition at line 1273 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ origin

svxPoint svxTextureAt::origin

texture origin

Definition at line 1275 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ location

evxTextureLoc svxTextureAt::location

texture location relative to origin

Definition at line 1281 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTextureAt::opt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTextureAt
angle
dimen
file
height
location
opt
origin
repeat
trans
use_embed
width

◆ opt

evxTextureOpt svxTextureAt::opt

texture option (zero if undefined)

Definition at line 1267 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxThickenData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

thicken data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | type
specify the selection of object (0 = sheet, 1 = Faces) More...
double | thick
thicken thickness, the value cannot be zero (negative: internal offset, positive: external offset) More...
vxName ftrName
feature name for "FtThicken", 0 default More...
int | idShape
id of shape to thicken More...
int | keep
whether to keep the original sheet (1 = yes, 0 = no) More...
int | numFaces
number of faces to thicken More...
int * | idFaces
list of faces to thicken More...
int | numOffset
number of additional offset More...
int * | idOffFaces
list of additional offset faces More...
double * | thickT
list of additional offset value More...

Detailed Description

thicken data

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1042 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ ftrName

vxName svxThickenData::ftrName

feature name for "FtThicken", 0 default

Definition at line 1047 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::thick

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ thick

double svxThickenData::thick

thicken thickness, the value cannot be zero (negative: internal offset, positive: external offset)

Definition at line 1045 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ idFaces

int* svxThickenData::idFaces

list of faces to thicken

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1055 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ idShape

int svxThickenData::idShape

id of shape to thicken

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1050 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::numFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ numFaces

int svxThickenData::numFaces

number of faces to thicken

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1054 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ type

int svxThickenData::type

specify the selection of object (0 = sheet, 1 = Faces)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1044 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::idOffFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ idOffFaces

int* svxThickenData::idOffFaces

list of additional offset faces

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1059 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::numOffset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ numOffset

int svxThickenData::numOffset

number of additional offset

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1058 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::keep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ keep

int svxThickenData::keep

whether to keep the original sheet (1 = yes, 0 = no)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1051 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThickenData::thickT

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThickenData
ftrName
idFaces
idOffFaces
idShape
keep
numFaces
numOffset
thick
thickT
type

◆ thickT

double* svxThickenData::thickT

list of additional offset value

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1060 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxThreadData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

thread definition More...

#include <zwapi_cmd_shape_data.h>

Data Fields

evxThreadType Type
thread type More...
double | Diameter
thread diameter (mm) More...
double | Length
thread length (mm) More...
double | PerUnit
threads per unit (0 if not used) More...
double | Pitch
thread pitch (mm) (0 if not used) More...
int | EndChamfer
1=Yes; 0=No Input the setback and the angle to create chamfer on the end of the face nearest the selection point. More...

Detailed Description

thread definition

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 906 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::PerUnit

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ PerUnit

double svxThreadData::PerUnit

threads per unit (0 if not used)

Definition at line 911 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::Length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ Length

double svxThreadData::Length

thread length (mm)

Definition at line 910 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::Pitch

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ Pitch

double svxThreadData::Pitch

thread pitch (mm) (0 if not used)

Definition at line 912 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::Diameter

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ Diameter

double svxThreadData::Diameter

thread diameter (mm)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 909 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::EndChamfer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ EndChamfer

int svxThreadData::EndChamfer

1=Yes; 0=No Input the setback and the angle to create chamfer on the end of the face nearest the selection point.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 913 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxThreadData::Type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxThreadData
Diameter
EndChamfer
Length
PerUnit
Pitch
Type

◆ Type

evxThreadType svxThreadData::Type

thread type

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 908 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTorus Struct Reference
Common » Common Data

circular surface data More...

#include <zwapi_util.h>

Data Fields

double | dPathRadius
revolve path or spine radius More...
double | dProfRadius
xsect or profile radius More...
svxMatrix form
torus centered about xform
z-axis points out of plane
x-axis point to seam More...
int | fSpineDir
= 1 : u defines the spine direction.
= 0 : v defines the spine direction. More...
int | fApplemon
= 1 : Apple
= 2 : Lemon More...

Detailed Description

circular surface data

Definition at line 1826 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus::fApplemon

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTorus
dPathRadius
dProfRadius
fApplemon
form
fSpineDir

◆ fApplemon

int svxTorus::fApplemon

= 1 : Apple
= 2 : Lemon

Definition at line 1835 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus::dPathRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTorus
dPathRadius
dProfRadius
fApplemon
form
fSpineDir

◆ dPathRadius

double svxTorus::dPathRadius

revolve path or spine radius

Definition at line 1828 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus::fSpineDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTorus
dPathRadius
dProfRadius
fApplemon
form
fSpineDir

◆ fSpineDir

int svxTorus::fSpineDir

= 1 : u defines the spine direction.
= 0 : v defines the spine direction.

Definition at line 1833 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus::form

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTorus
dPathRadius
dProfRadius
fApplemon
form
fSpineDir

◆ form

svxMatrix svxTorus::form

torus centered about xform
z-axis points out of plane
x-axis point to seam

Definition at line 1830 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTorus::dProfRadius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTorus
dPathRadius
dProfRadius
fApplemon
form
fSpineDir

◆ dProfRadius

double svxTorus::dProfRadius

xsect or profile radius

Definition at line 1829 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTplFld Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTplFld Struct Reference
UI » UI Data

template field data More...

#include <zwapi_ui_data.h>

Data Fields

char | Name [65]
field name (i.e. label) More...
int | Id
command field or gui widget id More...
int | Class
see evxFormFldClass or evxCmdFldClass More...
void * | Callback
pointer to field's callback function More...

Detailed Description

template field data

Definition at line 128 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTplFld::Name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTplFld
Callback
Class
Id
Name

◆ Name

char svxTplFld::Name[65]

field name (i.e. label)

Definition at line 130 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTplFld::Id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTplFld
Callback
Class
Id
Name

◆ Id

int svxTplFld::Id

command field or gui widget id

Definition at line 131 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTplFld::Class

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTplFld
Callback
Class
Id
Name

◆ Class

int svxTplFld::Class

see evxFormFldClass or evxCmdFldClass

Definition at line 132 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTplFld::Callback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTplFld
Callback
Class
Id
Name

◆ Callback

void* svxTplFld::Callback

pointer to field's callback function

Definition at line 133 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxTreeCbParam Struct Reference
UI » UI Data

tree widget callback function parameters More...

#include <zwapi_ui_data.h>

Data Structures

union uvxU

Data Fields

evxTreeEvent mode
const char * | shell
int | field
vxTreeItemId item
current hover id More...
int | column
the column where the current item is located More...
union svxTreeCbParam::uvxU | uvxu
svxKeyEvent key
key More...
int | state
1:state is on, 0:state is off or V_ZDM_EXPAND/V_ZDM_COLLAPSE More...
int | itemIsDisabled
1:node is disabled, 0:node is enabled if success/ok/enable next procedure, assign it to 0, else to 1 More...

Detailed Description

tree widget callback function parameters

Definition at line 537 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
Data Fields
svxTreeCbParam::uvxU::svxDRAG Struct Reference

drag multiple nodes More...

#include <zwapi_ui_data.h>

Data Fields

vxTreeItemId pressedItem
vxTreeItemId * selection
int | num
vxTreeItemId droppedItem
int | dropPos
0:item,1:above,2:below,3:viewport, More...

Detailed Description

drag multiple nodes

<

Definition at line 546 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
dropPos

◆ num

int svxTreeCbParam::uvxU::svxDRAG::num

Definition at line 550 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG::pressedItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
dropPos

◆ pressedItem

vxTreeItemId svxTreeCbParam::uvxU::svxDRAG::pressedItem

Definition at line 548 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG::selection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
dropPos

◆ selection

vxTreeItemId* svxTreeCbParam::uvxU::svxDRAG::selection

Definition at line 549 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG::droppedItem

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
dropPos

◆ droppedItem

vxTreeItemId svxTreeCbParam::uvxU::svxDRAG::droppedItem

Definition at line 551 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxDRAG::dropPos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxDRAG
dropPos

◆ dropPos

int svxTreeCbParam::uvxU::svxDRAG::dropPos

0:item,1:above,2:below,3:viewport,

Definition at line 552 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxHIT Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxHIT
Data Fields
svxTreeCbParam::uvxU::svxHIT Struct Reference

Data Fields

evxTreeHitPos pos
Clicking position (evxTreeHitPos) More...

Detailed Description

Definition at line 555 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxHIT::pos

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxHIT
pos

◆ pos

evxTreeHitPos svxTreeCbParam::uvxU::svxHIT::pos

Clicking position (evxTreeHitPos)

Definition at line 557 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxLABELEDIT Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxLABELEDIT
Data Fields
svxTreeCbParam::uvxU::svxLABELEDIT Struct Reference

Data Fields

char * text
pointer to node's label string More...

Detailed Description

Definition at line 566 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxLABELEDIT::text

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxLABELEDIT
text

◆ text

char* svxTreeCbParam::uvxU::svxLABELEDIT::text

pointer to node's label string

Definition at line 568 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxSELECTION Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxSELECTION
Data Fields
svxTreeCbParam::uvxU::svxSELECTION Struct Reference

multiple nodes selection More...

#include <zwapi_ui_data.h>

Data Fields

vxTreeItemId * idList
int num

Detailed Description

multiple nodes selection

<

Definition at line 560 of file zwapi_ui_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxSELECTION::idList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxSELECTION

◆ idList

vxTreeItemId* svxTreeCbParam::uvxU::svxSELECTION::idList

Definition at line 562 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU::svxSELECTION::num

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
  • svxSELECTION

◆ num

int svxTreeCbParam::uvxU::svxSELECTION::num

Definition at line 563 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::field

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ field

int svxTreeCbParam::field

Definition at line 541 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::itemIsDisabled

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ itemIsDisabled

int svxTreeCbParam::itemIsDisabled

1:node is disabled, 0:node is enabled if success/ok/enable next procedure, assign it to 0, else to 1

Definition at line 577 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::key

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ key

svxKeyEvent svxTreeCbParam::key

key

Definition at line 572 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::mode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ mode

evxTreeEvent svxTreeCbParam::mode

Definition at line 539 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::state

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ state

int svxTreeCbParam::state

1:state is on, 0:state is off or V_ZDM_EXPAND/V_ZDM_COLLAPSE

Definition at line 574 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::shell

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ shell

const char* svxTreeCbParam::shell

Definition at line 540 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::item

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ item

vxTreeItemId svxTreeCbParam::item

current hover id

Definition at line 542 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::column

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
column
item
itemIsDisabled
key
state

◆ column

int svxTreeCbParam::column

the column where the current item is located

Definition at line 543 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTriangle Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTriangle Struct Reference
Common » Common Data

3D triangle More...

#include <zwapi_util.h>

Data Fields

svxPoint Pnt [3]
triangle vertices More...
svxVector Normal
outward-facing normal More...

Detailed Description

3D triangle

Definition at line 369 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTriangle::Normal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTriangle
Normal
Pnt

◆ Normal

svxVector svxTriangle::Normal

outward-facing normal

Definition at line 372 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTriangle::Pnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTriangle
Normal
Pnt

◆ Pnt

svxPoint svxTriangle::Pnt[3]

triangle vertices

Definition at line 371 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTrimData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

Trim data. More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numBase
number of shapes to trimming More...
int * | idBase
id list of shape to trimming More...
int | numTrimm
number of trimming entities More...
int * | idTrimmer
list of trimming entities (shape, face, datum plane) More...
int | flip
1-flip side to keep, else 0 More...
int | trimType
1-trim with all simultaneously, else 0 More...
int | trimCap
whether to cap shape at the trimming edges (0 = uncap, 1 = cap) More...
int | keepTrimm
whether to keep trimming shapes (0 = delete, 1 = keep) More...
int | extend
extend method (1 = no extend, 0 = linear, 2 = circular) More...
vxName ftrName
feature name for "FtSolidSoloTrm", 0 default More...

Detailed Description

Trim data.

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1086 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ flip

int svxTrimData::flip

1-flip side to keep, else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1093 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::idTrimmer

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ idTrimmer

int* svxTrimData::idTrimmer

list of trimming entities (shape, face, datum plane)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1091 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::trimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ trimType

int svxTrimData::trimType

1-trim with all simultaneously, else 0

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1094 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::trimCap

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ trimCap

int svxTrimData::trimCap

whether to cap shape at the trimming edges (0 = uncap, 1 = cap)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1095 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::keepTrimm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ keepTrimm

int svxTrimData::keepTrimm

whether to keep trimming shapes (0 = delete, 1 = keep)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1096 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::ftrName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ ftrName

vxName svxTrimData::ftrName

feature name for "FtSolidSoloTrm", 0 default

Definition at line 1099 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::extend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ extend

int svxTrimData::extend

extend method (1 = no extend, 0 = linear, 2 = circular)

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1097 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::numTrimm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ numTrimm

int svxTrimData::numTrimm

number of trimming entities

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1090 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::numBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ numBase

int svxTrimData::numBase

number of shapes to trimming

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1088 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimData::idBase

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimData
extend
flip
ftrName
idBase
idTrimmer
keepTrimm
numBase
numTrimm
trimCap
trimType

◆ idBase

int* svxTrimData::idBase

id list of shape to trimming

Examples
part\shapeFtrCrtTest.cpp.

Definition at line 1089 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTrimPlnData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

template command Trimmed Plane data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | cntCrv
count of input curve(required) More...
int * | pCrvList
input curve id list(required) More...
int | idProf
id of profile if pCrvList are 2d curves, else -1/0 as the initialized value More...
char | sew
flag of sew or not(1-sew, else 0) More...
int | cntBool
count of boolean shapes(0 to ignore) More...
int * | pBooolList
list boolean shapes(null to ignore) More...
int | idPlane
id of reference plane(-1/0 to ignore) More...

Detailed Description

template command Trimmed Plane data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 139 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::pBooolList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ pBooolList

int* svxTrimPlnData::pBooolList

list boolean shapes(null to ignore)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 146 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::cntBool

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ cntBool

int svxTrimPlnData::cntBool

count of boolean shapes(0 to ignore)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 145 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::pCrvList

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ pCrvList

int* svxTrimPlnData::pCrvList

input curve id list(required)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 142 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::sew

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ sew

char svxTrimPlnData::sew

flag of sew or not(1-sew, else 0)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 144 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::idPlane

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ idPlane

int svxTrimPlnData::idPlane

id of reference plane(-1/0 to ignore)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 147 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::cntCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ cntCrv

int svxTrimPlnData::cntCrv

count of input curve(required)

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 141 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimPlnData::idProf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimPlnData
cntBool
cntCrv
idPlane
idProf
pBooolList
pCrvList
sew

◆ idProf

int svxTrimPlnData::idProf

id of profile if pCrvList are 2d curves, else -1/0 as the initialized value

Definition at line 143 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTrimToCurvesData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

template command Trim to Curves input data More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | cntFcs
count of idFaces More...
int * | idFaces
list of id face More...
int | cntCrvs
count of idCurves More...
int * | idCurves
list of id curve More...
int | toKeep
0 is faces to keep, 1 is faces to remove More...
int | cntPnts
count of sides More...
svxPntOnEnt * sides
point on ent More...
evxTrimCrvsProjtype projection
projection More...
svxVector * dirction
direction, NULL to ignore More...
int | isCheckerboard
1 is trim to checkerboard, else 0 More...
int | isExtend
1 is extend curves to boundary, else 0 More...

Detailed Description

template command Trim to Curves input data

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 363 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::toKeep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ toKeep

int svxTrimToCurvesData::toKeep

0 is faces to keep, 1 is faces to remove

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 369 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::isCheckerboard

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ isCheckerboard

int svxTrimToCurvesData::isCheckerboard

1 is trim to checkerboard, else 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 376 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::dirction

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ dirction

svxVector* svxTrimToCurvesData::dirction

direction, NULL to ignore

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 375 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::cntPnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ cntPnts

int svxTrimToCurvesData::cntPnts

count of sides

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 370 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::isExtend

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ isExtend

int svxTrimToCurvesData::isExtend

1 is extend curves to boundary, else 0

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 377 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::cntCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ cntCrvs

int svxTrimToCurvesData::cntCrvs

count of idCurves

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 367 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::projection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ projection

evxTrimCrvsProjtype svxTrimToCurvesData::projection

projection

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 374 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::idFaces

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ idFaces

int* svxTrimToCurvesData::idFaces

list of id face

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 366 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::sides

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ sides

svxPntOnEnt* svxTrimToCurvesData::sides

point on ent

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 371 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::cntFcs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ cntFcs

int svxTrimToCurvesData::cntFcs

count of idFaces

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 365 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToCurvesData::idCurves

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToCurvesData
cntCrvs
cntFcs
cntPnts
dirction
idCurves
idFaces
isCheckerboard
isExtend
projection
sides
toKeep

◆ idCurves

int* svxTrimToCurvesData::idCurves

list of id curve

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 368 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTrimToFacesData Struct Reference
Commands Creation » Part and Assembly Commands » Free Form Commands Data

trim to faces More...

#include <zwapi_cmd_freeform_data.h>

Data Fields

int | numFace
Number of faces to Trim. More...
int * | pFace
Id list of faces to Trim. More...
int | numTrimming
Number of trimming entities. More...
int * | pTrimming
Id list of trimming entities. More...
int | FlipSide
flag to use "Flip side to keep", 0 default More...
int | TrimWith
flag to use "Trim with all simultaneously", 0 default More...
int | ExtendTrimming
flag to use "Extend trimming faces", 0 default More...
int | KeepTrimming
flag to use "Keep trimming faces", 1 default More...

Detailed Description

trim to faces

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 334 of file zwapi_cmd_freeform_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::numTrimming

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ numTrimming

int svxTrimToFacesData::numTrimming

Number of trimming entities.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 338 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::TrimWith

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ TrimWith

int svxTrimToFacesData::TrimWith

flag to use "Trim with all simultaneously", 0 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 342 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::pTrimming

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ pTrimming

int* svxTrimToFacesData::pTrimming

Id list of trimming entities.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 339 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::pFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ pFace

int* svxTrimToFacesData::pFace

Id list of faces to Trim.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 337 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::numFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ numFace

int svxTrimToFacesData::numFace

Number of faces to Trim.

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 336 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::FlipSide

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ FlipSide

int svxTrimToFacesData::FlipSide

flag to use "Flip side to keep", 0 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 341 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::ExtendTrimming

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ ExtendTrimming

int svxTrimToFacesData::ExtendTrimming

flag to use "Extend trimming faces", 0 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 343 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimToFacesData::KeepTrimming

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimToFacesData
ExtendTrimming
FlipSide
KeepTrimming
numFace
numTrimming
pFace
pTrimming
TrimWith

◆ KeepTrimming

int svxTrimToFacesData::KeepTrimming

flag to use "Keep trimming faces", 1 default

Examples
part\freeFormFtrCrtTest.cpp.

Definition at line 344 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTrimWithCrvData Struct Reference
Commands Creation » Part and Assembly Commands » Wireframe Commands Data

trim with curve data More...

#include <zwapi_cmd_wireframe_data.h>

Data Fields

int | cntCrvs
number of curves More...
int * | pCrvs
curves to use as boundaries More...
int | cntDelSeg
number of curve segments More...
svxPntOnEntPath * pDelSeg
curve segments where you want them to be trimmed away More...
evxTrimWithCrvType trimMode
trim mode More...
svxPntOnEntPath * pPln
Use this option to trim non-intersection 3D curves. You can project the curves onto a plane and determine the intersection. The intersection points are then projected back to the trimming curves.
If you do not select a plane, then the minimum distance between the curves is used for the trimming points. (NULL to ignore) More...

Detailed Description

trim with curve data

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 596 of file zwapi_cmd_wireframe_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::cntDelSeg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ cntDelSeg

int svxTrimWithCrvData::cntDelSeg

number of curve segments

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 600 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::pDelSeg

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ pDelSeg

svxPntOnEntPath* svxTrimWithCrvData::pDelSeg

curve segments where you want them to be trimmed away

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 601 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::cntCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ cntCrvs

int svxTrimWithCrvData::cntCrvs

number of curves

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 598 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::trimMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ trimMode

evxTrimWithCrvType svxTrimWithCrvData::trimMode

trim mode

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 602 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::pPln

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ pPln

svxPntOnEntPath* svxTrimWithCrvData::pPln

Use this option to trim non-intersection 3D curves. You can project the curves onto a plane and determine the intersection. The intersection points are then projected back to the trimming curves.
If you do not select a plane, then the minimum distance between the curves is used for the trimming points. (NULL to ignore)

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 603 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTrimWithCrvData::pCrvs

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTrimWithCrvData
cntCrvs
cntDelSeg
pCrvs
pDelSeg
pPln
trimMode

◆ pCrvs

int* svxTrimWithCrvData::pCrvs

curves to use as boundaries

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 599 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxTwistData Struct Reference
Commands Creation » Part and Assembly Commands » Shape Commands Data

shape twist data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

int | numShapes
numbers of twisted shapes More...
int * | idShapes
specify the shapes that will be twisted More...
int | idDatum
specify a plane that defines the XY coordinate system and the twist center More...
double | range
the distance to the origin of the selected datum. 100 default More...
double | angle
specify the largest rotate angle in twist range. 180 default More...
svxVector * axis
specify the optional taper axis. nullptr default More...
int | keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default) More...
int | miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default) More...

Detailed Description

shape twist data

Definition at line 1184 of file zwapi_cmd_shape_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::axis

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ axis

svxVector* svxTwistData::axis

specify the optional taper axis. nullptr default

Definition at line 1193 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::keepOriginal

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ keepOriginal

int svxTwistData::keepOriginal

whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)

Definition at line 1194 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::range

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ range

double svxTwistData::range

the distance to the origin of the selected datum. 100 default

Definition at line 1190 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::angle

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ angle

double svxTwistData::angle

specify the largest rotate angle in twist range. 180 default

Definition at line 1191 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::miniSurfData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ miniSurfData

int svxTwistData::miniSurfData

whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)

Definition at line 1195 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::idShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ idShapes

int* svxTwistData::idShapes

specify the shapes that will be twisted

Definition at line 1188 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::numShapes

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ numShapes

int svxTwistData::numShapes

numbers of twisted shapes

Definition at line 1187 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxTwistData::idDatum

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTwistData
angle
axis
idDatum
idShapes
keepOriginal
miniSurfData
numShapes
range

◆ idDatum

int svxTwistData::idDatum

specify a plane that defines the XY coordinate system and the twist center

Definition at line 1189 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUDFParam Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxUDFParam Struct Reference
Commands Creation » Part and Assembly Commands » UDF Data

field parameters of UDF command More...

#include <zwapi_cmd_udf_data.h>

Data Fields

int | fld_id
id of field More...
int | is_list
1- is list, else 0 More...
evxFldType fld_type
type of field More...
vxLongName description
description of parameter, use to set the different data More...

Detailed Description

field parameters of UDF command

Definition at line 32 of file zwapi_cmd_udf_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_udf_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUDFParam::is_list

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUDFParam
description
fld_id
fld_type
is_list

◆ is_list

int svxUDFParam::is_list

1- is list, else 0

Definition at line 35 of file zwapi_cmd_udf_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUDFParam::fld_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUDFParam
description
fld_id
fld_type
is_list

◆ fld_type

evxFldType svxUDFParam::fld_type

type of field

Definition at line 36 of file zwapi_cmd_udf_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUDFParam::fld_id

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUDFParam
description
fld_id
fld_type
is_list

◆ fld_id

int svxUDFParam::fld_id

id of field

Definition at line 34 of file zwapi_cmd_udf_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUDFParam::description

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUDFParam
description
fld_id
fld_type
is_list

◆ description

vxLongName svxUDFParam::description

description of parameter, use to set the different data

Definition at line 37 of file zwapi_cmd_udf_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUid Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxUid Struct Reference
Common » Common Data

entity unique identifier More...

#include <zwapi_util.h>

Data Fields

int | Time
base time More...
int | Rand
random number More...
int | Count
entity count More...

Detailed Description

entity unique identifier

Definition at line 986 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUid::Time

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUid
Count
Rand
Time

◆ Time

int svxUid::Time

base time

Definition at line 988 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUid::Count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUid
Count
Rand
Time

◆ Count

int svxUid::Count

entity count

Definition at line 990 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUid::Rand

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUid
Count
Rand
Time

◆ Rand

int svxUid::Rand

random number

Definition at line 989 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxUnfoldData Struct Reference
Commands Creation » Part and Assembly Commands » Sheet Metal Commands Data

template command Smd Unfold data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Fields

int | idShape
shape id More...
int | idStationary
Stationary face id. More...
int | BendFaceCnts
Bend face counts. More...
int * | idBendFace
Bend faces id. More...
int | CrvCnts
Curve list counts(0 to ignored) More...
int * | idCrv
curve list on the sheet metal(NULL to ignored) More...

Detailed Description

template command Smd Unfold data

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1193 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::CrvCnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ CrvCnts

int svxUnfoldData::CrvCnts

Curve list counts(0 to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1199 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::idShape

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idShape

int svxUnfoldData::idShape

shape id

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1195 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::BendFaceCnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ BendFaceCnts

int svxUnfoldData::BendFaceCnts

Bend face counts.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1197 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::idStationary

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idStationary

int svxUnfoldData::idStationary

Stationary face id.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1196 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::idBendFace

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idBendFace

int* svxUnfoldData::idBendFace

Bend faces id.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1198 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUnfoldData::idCrv

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUnfoldData
BendFaceCnts
CrvCnts
idBendFace
idCrv
idShape
idStationary

◆ idCrv

int* svxUnfoldData::idCrv

curve list on the sheet metal(NULL to ignored)

Examples
part\smdFtrCrtTest.cpp.

Definition at line 1200 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUniJointData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxUniJointData Struct Reference
Commands Creation » Part and Assembly Commands » Assembly Commands Data

custom data for assembly universal joint constraint More...

#include <zwapi_cmd_assembly_data.h>

Data Fields

int | jointConsType
universal joint constraint type (0: constant velocity; 1: variable velocity; 1-default) More...
int | flip
whether to flip dimension (0-default) More...

Detailed Description

custom data for assembly universal joint constraint

Examples
part\asmConsTest.cpp.

Definition at line 358 of file zwapi_cmd_assembly_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUniJointData::jointConsType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUniJointData
flip
jointConsType

◆ jointConsType

int svxUniJointData::jointConsType

universal joint constraint type (0: constant velocity; 1: variable velocity; 1-default)

Examples
part\asmConsTest.cpp.

Definition at line 360 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxUniJointData::flip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxUniJointData
flip
jointConsType

◆ flip

int svxUniJointData::flip

whether to flip dimension (0-default)

Examples
part\asmConsTest.cpp.

Definition at line 361 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxVariable Struct Reference
Common » Common Data

numeric variable More...

#include <zwapi_util.h>

Data Fields

vxName Name
variable name More...
double | Value
value is not required if Expression is defined More...
svxPoint pnt_val
the value of point is not required if Expression is defined More...
vxVarExp Expression
optional expression (Expression[0]=0 if undefined) More...
char | type
variable type (value of evxVarType) More...
char | sub_type
sub type of numeric variable (value of evxVarNumType) More...
char | unit_type
unit type (see evxVarNumType), evxUnitType for point type More...

Detailed Description

numeric variable

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1121 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::Value

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ Value

double svxVariable::Value

value is not required if Expression is defined

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1124 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::Name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ Name

vxName svxVariable::Name

variable name

Definition at line 1123 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::Expression

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ Expression

vxVarExp svxVariable::Expression

optional expression (Expression[0]=0 if undefined)

Definition at line 1126 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ type

char svxVariable::type

variable type (value of evxVarType)

Definition at line 1127 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::unit_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ unit_type

char svxVariable::unit_type

unit type (see evxVarNumType), evxUnitType for point type

Definition at line 1129 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::pnt_val

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ pnt_val

svxPoint svxVariable::pnt_val

the value of point is not required if Expression is defined

Definition at line 1125 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVariable::sub_type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVariable
Expression
Name
pnt_val
sub_type
type
unit_type
Value

◆ sub_type

char svxVariable::sub_type

sub type of numeric variable (value of evxVarNumType)

Definition at line 1128 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxVector Struct Reference
Common » Common Data

3D vector More...

#include <zwapi_util.h>

Data Fields

double | x
double | y
double | z

Detailed Description

3D vector

Examples
part\baseFtrCrtTest.cpp, part\freeFormFtrCrtTest.cpp, part\shapeFtrCrtTest.cpp, part\smdFtrCrtTest.cpp, and part\wireframeFtrCrtTest.cpp.

Definition at line 337 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector2 Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxVector2 Struct Reference
Common » Common Data

2D vector More...

#include <zwapi_util.h>

Data Fields

double | x
double | y

Detailed Description

2D vector

Definition at line 327 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector2::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVector2

◆ y

double svxVector2::y

Definition at line 330 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector2::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVector2

◆ x

double svxVector2::x

Definition at line 329 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector::y

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVector

◆ y

double svxVector::y
Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 340 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector::z

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVector

◆ z

double svxVector::z
Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 341 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxVector::x

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxVector

◆ x

double svxVector::x
Examples
part\wireframeFtrCrtTest.cpp, and sketch\skDrawingTest.cpp.

Definition at line 339 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxView Struct Reference
Common » Common Data

view data(Z3PRT,Z3ASM) More...

#include <zwapi_util.h>

Data Fields

vxName Name
view name More...
svxMatrix Matrix
view matrix (i.e. transform) More...
float | Extent
view extent More...
float | FrontDist
distance from view origin to front clip plane More...
float | BackDist
distance from view origin to back clip plane More...
float | PRP_Dist
distance from view origin to projection reference point (PRP) More...
char | Display
1-display this view, 0-don't display this view More...
char | Clip
1-clip to front/back plane, 0-don't clip More...
char | Project
projection method, 0-parallel, 1-perspective More...

Detailed Description

view data(Z3PRT,Z3ASM)

Definition at line 2438 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::BackDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ BackDist

float svxView::BackDist

distance from view origin to back clip plane

Definition at line 2444 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::PRP_Dist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ PRP_Dist

float svxView::PRP_Dist

distance from view origin to projection reference point (PRP)

Definition at line 2445 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Name

vxName svxView::Name

view name

Definition at line 2440 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Extent

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Extent

float svxView::Extent

view extent

Definition at line 2442 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Project

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Project

char svxView::Project

projection method, 0-parallel, 1-perspective

Definition at line 2448 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Matrix

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Matrix

svxMatrix svxView::Matrix

view matrix (i.e. transform)

Definition at line 2441 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::FrontDist

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ FrontDist

float svxView::FrontDist

distance from view origin to front clip plane

Definition at line 2443 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Clip

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Clip

char svxView::Clip

1-clip to front/back plane, 0-don't clip

Definition at line 2447 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxView::Display

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxView
BackDist
Clip
Display
Extent
FrontDist
Matrix
Name
Project
PRP_Dist

◆ Display

char svxView::Display

1-display this view, 0-don't display this view

Definition at line 2446 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewArrow Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewArrow Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

view projection arrow More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

double | offset
view line offset distance (20.0 as default) More...
int | iFlag
iFlag = 0, startPnt and entPnt will use default value (user input is invalid) iFlag > 0, startPnt and entPnt of user input are valid More...
svxPoint2 startPnt
arrow start location More...
svxPoint2 endPnt
arrow end location More...

Detailed Description

view projection arrow

Definition at line 254 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewArrow::offset

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewArrow
endPnt
iFlag
offset
startPnt

◆ offset

double svxViewArrow::offset

view line offset distance (20.0 as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 256 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewArrow::endPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewArrow
endPnt
iFlag
offset
startPnt

◆ endPnt

svxPoint2 svxViewArrow::endPnt

arrow end location

Examples
drawing\dwgViewTest.cpp.

Definition at line 261 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewArrow::startPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewArrow
endPnt
iFlag
offset
startPnt

◆ startPnt

svxPoint2 svxViewArrow::startPnt

arrow start location

Examples
drawing\dwgViewTest.cpp.

Definition at line 260 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewArrow::iFlag

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewArrow
endPnt
iFlag
offset
startPnt

◆ iFlag

int svxViewArrow::iFlag

iFlag = 0, startPnt and entPnt will use default value (user input is invalid) iFlag > 0, startPnt and entPnt of user input are valid

Examples
drawing\dwgViewTest.cpp.

Definition at line 258 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewAt Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

View layout display attributes. More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

svxWireAt zWireAt
Attributes for wireframe. More...
char | fHLROn
display mode (0 ~ 3) More...
char | fBiarc
convert curves to arc on(1)/off(0) More...
char | fDupFlt
remove duplicated curves on(1)/off(0) More...
char | fShwDim
show dimensions from part (1) or not(0) More...
char | fShwLbl
show label (1) or not(0) More...
char | fShwScl
show scale (1) or not(0) More...
char | fShwPmi
show PMI entities inherited from part (1/2) or not(0) More...
char | fExplod
Explode mode (1) or not(0) More...
char | fNoProp
hidden line check for intersecting shapes off (1)/on(0) More...
char | fThread
show threads on (1)/off(0) More...
char | fCentLin
show center lines on (1)/off(0) More...
char | fBendLin
show bend lines from sheet metal on (1)/off(0) More...
char | fWirefrm
show 3D curves from part on (1)/off(0) More...
char | fNoRegen
do not Regen View on (1)/off(0) More...
char | fAnno
show texts from part on (1)/off(0) More...
char | fBeads
show weld beads from part (1) or not(0) More...
svxWireAt | zLnAt [18]
view line type (see evxViewLineAttrIdx) display attributes More...
char | fShw3DOrig
show 3D zero point (1) or not (0) More...
char | fHiddenLin
show hidden lines on(1)/off(0) More...
vxName label
view label More...
char | fScaleType
scale type
0 view scale explicitly assigned to view by user
1 view scale comes from sheet preference
2 view scale comes from parent view More...
double | dSclRatioX
Scale ratio value X. More...
double | dSclRatioY
Scale ratio value Y. More...
double | dScale
decimal display scale More...

Detailed Description

View layout display attributes.

Examples
drawing\dwgViewTest.cpp.

Definition at line 76 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fBeads

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fBeads

char svxViewAt::fBeads

show weld beads from part (1) or not(0)

Definition at line 95 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fBendLin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fBendLin

char svxViewAt::fBendLin

show bend lines from sheet metal on (1)/off(0)

Definition at line 91 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::dSclRatioX

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ dSclRatioX

double svxViewAt::dSclRatioX

Scale ratio value X.

Definition at line 104 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fHiddenLin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fHiddenLin

char svxViewAt::fHiddenLin

show hidden lines on(1)/off(0)

Definition at line 98 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::zWireAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ zWireAt

svxWireAt svxViewAt::zWireAt

Attributes for wireframe.

Definition at line 78 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fDupFlt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fDupFlt

char svxViewAt::fDupFlt

remove duplicated curves on(1)/off(0)

Definition at line 81 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fNoRegen

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fNoRegen

char svxViewAt::fNoRegen

do not Regen View on (1)/off(0)

Definition at line 93 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fShwLbl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fShwLbl

char svxViewAt::fShwLbl

show label (1) or not(0)

Definition at line 83 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::dScale

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ dScale

double svxViewAt::dScale

decimal display scale

Definition at line 106 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fShwPmi

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fShwPmi

char svxViewAt::fShwPmi

show PMI entities inherited from part (1/2) or not(0)

1: inherit parallel PMI; 2: inherit all PMI

Definition at line 85 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::dSclRatioY

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ dSclRatioY

double svxViewAt::dSclRatioY

Scale ratio value Y.

Definition at line 105 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fShwScl

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fShwScl

char svxViewAt::fShwScl

show scale (1) or not(0)

Definition at line 84 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fThread

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fThread

char svxViewAt::fThread

show threads on (1)/off(0)

Definition at line 89 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fShw3DOrig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fShw3DOrig

char svxViewAt::fShw3DOrig

show 3D zero point (1) or not (0)

Definition at line 97 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fNoProp

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fNoProp

char svxViewAt::fNoProp

hidden line check for intersecting shapes off (1)/on(0)

Definition at line 88 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fWirefrm

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fWirefrm

char svxViewAt::fWirefrm

show 3D curves from part on (1)/off(0)

Definition at line 92 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fHLROn

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fHLROn

char svxViewAt::fHLROn

display mode (0 ~ 3)

Definition at line 79 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fShwDim

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fShwDim

char svxViewAt::fShwDim

show dimensions from part (1) or not(0)

Definition at line 82 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fExplod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fExplod

char svxViewAt::fExplod

Explode mode (1) or not(0)

Definition at line 87 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::label

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ label

vxName svxViewAt::label

view label

Definition at line 99 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fCentLin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fCentLin

char svxViewAt::fCentLin

show center lines on (1)/off(0)

Definition at line 90 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fScaleType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fScaleType

char svxViewAt::fScaleType

scale type
0 view scale explicitly assigned to view by user
1 view scale comes from sheet preference
2 view scale comes from parent view

Definition at line 100 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fAnno

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fAnno

char svxViewAt::fAnno

show texts from part on (1)/off(0)

Definition at line 94 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::zLnAt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ zLnAt

svxWireAt svxViewAt::zLnAt[18]

view line type (see evxViewLineAttrIdx) display attributes

Definition at line 96 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewAt::fBiarc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewAt
dScale
dSclRatioX
dSclRatioY
fAnno
fBeads
fBendLin
fBiarc
fCentLin
fDupFlt
fExplod
fHiddenLin
fHLROn
fNoProp
fNoRegen
fScaleType
fShw3DOrig
fShwDim
fShwLbl
fShwPmi
fShwScl
fThread
fWirefrm
label
zLnAt
zWireAt

◆ fBiarc

char svxViewAt::fBiarc

convert curves to arc on(1)/off(0)

Definition at line 80 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewLayoutData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing view layout data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

vxPath name
file name of the projected part or assembly (file that is unloaded must use the full path) More...
vxRootName root
root name.(This parameter is required only when the z3 file is passed in.) More...
svxViewLocationData location
location of the views More...
int | isIgnoreLoc
1 if ignore location and use default,else 0 More...
svxViewLayoutMethod method
layout method More...
int | isIgnoreMethod
1 if ignore method and use default,else 0 More...
svxViewAt viewAttr
view attribute More...
int | isIgnoreAttr
1 if ignore viewAttr and use default,else 0 More...
int | coordinate
projection coordinate system, default:1 to use the global coordinate system More...
vxName PartConfig
part config name ,PartConfig[0]=0 to ignore More...
vxName CompConfig
component configuration name, CompConfig[0]=0 to ignore More...
int | ExplodedView
exploded view ,default:0 More...
int | state
index for the backup feature, default:-1 More...
int | DimensionType
0 if projected, 1 if true. default:0. More...
int | isCalculate
1 if calculate part center ,else 0. default:1 More...
int | cntBlankRefEnts
count of blankRefEntsData. 0 to ignore. More...
svxRefEntData * blankRefEntsData
list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidden after the view is generated. More...

Detailed Description

drawing view layout data

Examples
drawing\dwgViewTest.cpp.

Definition at line 113 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ location

svxViewLocationData svxViewLayoutData::location

location of the views

Examples
drawing\dwgViewTest.cpp.

Definition at line 117 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::blankRefEntsData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ blankRefEntsData

svxRefEntData* svxViewLayoutData::blankRefEntsData

list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidden after the view is generated.

Definition at line 131 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::cntBlankRefEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ cntBlankRefEnts

int svxViewLayoutData::cntBlankRefEnts

count of blankRefEntsData. 0 to ignore.

Definition at line 130 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::method

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ method

svxViewLayoutMethod svxViewLayoutData::method

layout method

Examples
drawing\dwgViewTest.cpp.

Definition at line 119 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::name

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ name

vxPath svxViewLayoutData::name

file name of the projected part or assembly (file that is unloaded must use the full path)

Examples
drawing\dwgViewTest.cpp.

Definition at line 115 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::isIgnoreAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ isIgnoreAttr

int svxViewLayoutData::isIgnoreAttr

1 if ignore viewAttr and use default,else 0

Examples
drawing\dwgViewTest.cpp.

Definition at line 122 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::CompConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ CompConfig

vxName svxViewLayoutData::CompConfig

component configuration name, CompConfig[0]=0 to ignore

Definition at line 125 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::isIgnoreLoc

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ isIgnoreLoc

int svxViewLayoutData::isIgnoreLoc

1 if ignore location and use default,else 0

Examples
drawing\dwgViewTest.cpp.

Definition at line 118 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::root

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ root

vxRootName svxViewLayoutData::root

root name.(This parameter is required only when the z3 file is passed in.)

Definition at line 116 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::DimensionType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ DimensionType

int svxViewLayoutData::DimensionType

0 if projected, 1 if true. default:0.

Examples
drawing\dwgViewTest.cpp.

Definition at line 128 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::coordinate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ coordinate

int svxViewLayoutData::coordinate

projection coordinate system, default:1 to use the global coordinate system

Examples
drawing\dwgViewTest.cpp.

Definition at line 123 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::ExplodedView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ ExplodedView

int svxViewLayoutData::ExplodedView

exploded view ,default:0

Examples
drawing\dwgViewTest.cpp.

Definition at line 126 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::PartConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ PartConfig

vxName svxViewLayoutData::PartConfig

part config name ,PartConfig[0]=0 to ignore

Examples
drawing\dwgViewTest.cpp.

Definition at line 124 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::isIgnoreMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ isIgnoreMethod

int svxViewLayoutData::isIgnoreMethod

1 if ignore method and use default,else 0

Examples
drawing\dwgViewTest.cpp.

Definition at line 120 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::state

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ state

int svxViewLayoutData::state

index for the backup feature, default:-1

Examples
drawing\dwgViewTest.cpp.

Definition at line 127 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::isCalculate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ isCalculate

int svxViewLayoutData::isCalculate

1 if calculate part center ,else 0. default:1

Examples
drawing\dwgViewTest.cpp.

Definition at line 129 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutData::viewAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutData
blankRefEntsData
cntBlankRefEnts
CompConfig
coordinate
DimensionType
ExplodedView
isCalculate
isIgnoreAttr
isIgnoreLoc
isIgnoreMethod
location
method
name
PartConfig
root
state
viewAttr

◆ viewAttr

svxViewAt svxViewLayoutData::viewAttr

view attribute

Examples
drawing\dwgViewTest.cpp.

Definition at line 121 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutMethod Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewLayoutMethod Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing view layout method More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | projection
1 if the first perspective,
2 if the third perspective
default:2 More...
int | count
The number of valid values for "StdMethod"
"count" has a maximum of 7 and a minimum of 1.
default:3. More...
evxViewStd | StdMethod [7]
StdMethod[0] is base view orientations, others are projection view orientations
StdMethod[0] is in the range of VX_VIEW_FRONT to VX_VIEW_LEFT
other StdMethod is in the range of VX_VIEW_FRONT to VX_VIEW_ISO
default:[0]= VX_VIEW_FRONT,[1]=VX_VIEW_TOP,[2]=VX_VIEW_RIGHT. More...

Detailed Description

drawing view layout method

Definition at line 58 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutMethod::count

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutMethod
count
projection
StdMethod

◆ count

int svxViewLayoutMethod::count

The number of valid values for "StdMethod"
"count" has a maximum of 7 and a minimum of 1.
default:3.

Examples
drawing\dwgViewTest.cpp.

Definition at line 63 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutMethod::projection

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutMethod
count
projection
StdMethod

◆ projection

int svxViewLayoutMethod::projection

1 if the first perspective,
2 if the third perspective
default:2

Examples
drawing\dwgViewTest.cpp.

Definition at line 60 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLayoutMethod::StdMethod

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLayoutMethod
count
projection
StdMethod

◆ StdMethod

evxViewStd svxViewLayoutMethod::StdMethod[7]

StdMethod[0] is base view orientations, others are projection view orientations
StdMethod[0] is in the range of VX_VIEW_FRONT to VX_VIEW_LEFT
other StdMethod is in the range of VX_VIEW_FRONT to VX_VIEW_ISO
default:[0]= VX_VIEW_FRONT,[1]=VX_VIEW_TOP,[2]=VX_VIEW_RIGHT.

Examples
drawing\dwgViewTest.cpp.

Definition at line 66 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLocationData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewLocationData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing view location data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxViewLocationType type
drawing view location type More...
svxPoint2 FirstPoint
the first point (ignore this if type is VX_LOCATION_AUTO ) More...
svxPoint2 SecondPoint
the second point (ignore this if type is not VX_LOCATION_CORNER ) More...

Detailed Description

drawing view location data

Definition at line 45 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLocationData::SecondPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLocationData
FirstPoint
SecondPoint
type

◆ SecondPoint

svxPoint2 svxViewLocationData::SecondPoint

the second point (ignore this if type is not VX_LOCATION_CORNER )

Examples
drawing\dwgViewTest.cpp.

Definition at line 50 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLocationData::FirstPoint

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLocationData
FirstPoint
SecondPoint
type

◆ FirstPoint

svxPoint2 svxViewLocationData::FirstPoint

the first point (ignore this if type is VX_LOCATION_AUTO )

Examples
drawing\dwgViewTest.cpp.

Definition at line 48 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewLocationData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewLocationData
FirstPoint
SecondPoint
type

◆ type

evxViewLocationType svxViewLocationData::type

drawing view location type

Examples
drawing\dwgViewTest.cpp.

Definition at line 47 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecLine Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewSecLine Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

section line More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

char * | viewLabel
view label (example: "A" becomes "A-A") the label doesn't duplicate the existing label null or "" to use default label More...
int | iFlipArrow
flip arrow or not (0 as default) More...
int | iShowStepLines
show step lines or not (0 as default) More...

Detailed Description

section line

Definition at line 336 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecLine::iShowStepLines

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecLine
iFlipArrow
iShowStepLines
viewLabel

◆ iShowStepLines

int svxViewSecLine::iShowStepLines

show step lines or not (0 as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 342 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecLine::viewLabel

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecLine
iFlipArrow
iShowStepLines
viewLabel

◆ viewLabel

char* svxViewSecLine::viewLabel

view label (example: "A" becomes "A-A") the label doesn't duplicate the existing label null or "" to use default label

Examples
drawing\dwgViewTest.cpp.

Definition at line 338 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecLine::iFlipArrow

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecLine
iFlipArrow
iShowStepLines
viewLabel

◆ iFlipArrow

int svxViewSecLine::iFlipArrow

flip arrow or not (0 as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 341 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewSecMtd Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

section method More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

evxSecMtdType mtdType
section method (VX_METHOD_TRIMPART as default) More...
int | iCloseOpenProf
close open profiles or not (1 as default) More...
int | iDynScalAng
dynamic hatch scaling and angle or not (1 as default) More...
int | inheritSecBasView
inherit section from base view or not if base view is not section view, this value can be ignored if base view is section view, this value equals to 0 or 1 More...
evxLocType locType
location type (VX_LOC_ORTHOGONAL as default) More...
evxViewDimType dimType
dimension type (VX_VIEW_DIMTYPEPRJ as default) More...
double | dSecDepth
section depth (if mtdType = VX_METHOD_SECCURVE, this can be ignored.) this parameter would be ignored in aligned section view. More...
evxLocAngType locAngType
location angle type More...
double | dLocAng
location angle (only used when locAngType = VX_LOC_ANG_CUSTOM) More...

Detailed Description

section method

Definition at line 316 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::locAngType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ locAngType

evxLocAngType svxViewSecMtd::locAngType

location angle type

Definition at line 328 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::inheritSecBasView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ inheritSecBasView

int svxViewSecMtd::inheritSecBasView

inherit section from base view or not if base view is not section view, this value can be ignored if base view is section view, this value equals to 0 or 1

Examples
drawing\dwgViewTest.cpp.

Definition at line 321 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::dLocAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ dLocAng

double svxViewSecMtd::dLocAng

location angle (only used when locAngType = VX_LOC_ANG_CUSTOM)

Definition at line 329 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::mtdType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ mtdType

evxSecMtdType svxViewSecMtd::mtdType

section method (VX_METHOD_TRIMPART as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 318 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::iCloseOpenProf

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ iCloseOpenProf

int svxViewSecMtd::iCloseOpenProf

close open profiles or not (1 as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 319 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::iDynScalAng

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ iDynScalAng

int svxViewSecMtd::iDynScalAng

dynamic hatch scaling and angle or not (1 as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 320 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::dimType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ dimType

evxViewDimType svxViewSecMtd::dimType

dimension type (VX_VIEW_DIMTYPEPRJ as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 325 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::locType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ locType

evxLocType svxViewSecMtd::locType

location type (VX_LOC_ORTHOGONAL as default)

Examples
drawing\dwgViewTest.cpp.

Definition at line 324 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecMtd::dSecDepth

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecMtd
dimType
dLocAng
dSecDepth
iCloseOpenProf
iDynScalAng
inheritSecBasView
locAngType
locType
mtdType

◆ dSecDepth

double svxViewSecMtd::dSecDepth

section depth (if mtdType = VX_METHOD_SECCURVE, this can be ignored.) this parameter would be ignored in aligned section view.

Definition at line 326 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecOp Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxViewSecOp Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

section option More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

int | iSecState
component section state from part More...
int | iHatchState
component hatch state from part More...
int | iHatchClr
hatch color from part More...

Detailed Description

section option

Definition at line 349 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecOp::iSecState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecOp
iHatchClr
iHatchState
iSecState

◆ iSecState

int svxViewSecOp::iSecState

component section state from part

Examples
drawing\dwgViewTest.cpp.

Definition at line 351 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecOp::iHatchClr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecOp
iHatchClr
iHatchState
iSecState

◆ iHatchClr

int svxViewSecOp::iHatchClr

hatch color from part

Examples
drawing\dwgViewTest.cpp.

Definition at line 353 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewSecOp::iHatchState

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewSecOp
iHatchClr
iHatchState
iSecState

◆ iHatchState

int svxViewSecOp::iHatchState

component hatch state from part

Definition at line 352 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Structures | Data Fields
svxViewStandardData Struct Reference
Commands Creation » Drawing Commands » Drawing Commands Data

drawing view standard data More...

#include <zwapi_cmd_dwg_data.h>

Data Structures

union uvxViewTypeData
union of view type data More...

Data Fields

vxLongPath path
file path More...
vxLongPath fileName
file name (including the extension) More...
vxRootName rootName
root name More...
int | type
1 is use view manager custom view name(this manager in part environment), 2 is use flattening feature name of a sheet metal module(this manager in part environment),
0 is use native type More...
union svxViewStandardData::uvxViewTypeData | option
svxPoint2 location
location More...
int | isIgnoreAttr
1 if ignore viewAttr and use default,else 0 More...
svxViewAt viewAttr
view attribute More...
int | origin
Origin ,default:1. More...
int | coordinate
coordinate,default:1 More...
vxName partConfig
part config name ,PartConfig[0]=0 to ignore More...
vxName compConfig
component configuration name, CompConfig[0]=0 to ignore More...
int | explodedView
exploded view ,default:0 More...
int | isDispTrails
1 if display exploded trails ,else 0.default:0 More...
int | state
index for the backup feature, default:1 More...
int | dimensionType
0 if projected, 1 if true. default:0. More...
int | isCalculate
1 if calculate part center ,else 0. default:1 More...
int | isOrientation
1 if view orientation from parent, else 0. default:1 More...
int | cntBlankRefEnts
count of blankRefEntsData. 0 to ignore. More...
svxRefEntData * blankRefEntsData
list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidden after the view is generated. More...

Detailed Description

drawing view standard data

Examples
drawing\dwgViewTest.cpp.

Definition at line 188 of file zwapi_cmd_dwg_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::origin

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ origin

int svxViewStandardData::origin

Origin ,default:1.

Examples
drawing\dwgViewTest.cpp.

Definition at line 205 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::coordinate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ coordinate

int svxViewStandardData::coordinate

coordinate,default:1

Examples
drawing\dwgViewTest.cpp.

Definition at line 206 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::location

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ location

svxPoint2 svxViewStandardData::location

location

Examples
drawing\dwgViewTest.cpp.

Definition at line 202 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::blankRefEntsData

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ blankRefEntsData

svxRefEntData* svxViewStandardData::blankRefEntsData

list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidden after the view is generated.

Definition at line 216 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::explodedView

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ explodedView

int svxViewStandardData::explodedView

exploded view ,default:0

Examples
drawing\dwgViewTest.cpp.

Definition at line 209 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::viewAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ viewAttr

svxViewAt svxViewStandardData::viewAttr

view attribute

Examples
drawing\dwgViewTest.cpp.

Definition at line 204 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::isDispTrails

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ isDispTrails

int svxViewStandardData::isDispTrails

1 if display exploded trails ,else 0.default:0

Examples
drawing\dwgViewTest.cpp.

Definition at line 210 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::fileName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ fileName

vxLongPath svxViewStandardData::fileName

file name (including the extension)

Examples
drawing\dwgViewTest.cpp.

Definition at line 191 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::state

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ state

int svxViewStandardData::state

index for the backup feature, default:1

Examples
drawing\dwgViewTest.cpp.

Definition at line 211 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ type

int svxViewStandardData::type

1 is use view manager custom view name(this manager in part environment), 2 is use flattening feature name of a sheet metal module(this manager in part environment),
0 is use native type

Examples
drawing\dwgViewTest.cpp.

Definition at line 193 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::cntBlankRefEnts

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ cntBlankRefEnts

int svxViewStandardData::cntBlankRefEnts

count of blankRefEntsData. 0 to ignore.

Definition at line 215 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::compConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ compConfig

vxName svxViewStandardData::compConfig

component configuration name, CompConfig[0]=0 to ignore

Definition at line 208 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::dimensionType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ dimensionType

int svxViewStandardData::dimensionType

0 if projected, 1 if true. default:0.

Examples
drawing\dwgViewTest.cpp.

Definition at line 212 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::rootName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ rootName

vxRootName svxViewStandardData::rootName

root name

Examples
drawing\dwgViewTest.cpp.

Definition at line 192 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::isOrientation

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ isOrientation

int svxViewStandardData::isOrientation

1 if view orientation from parent, else 0. default:1

Examples
drawing\dwgViewTest.cpp.

Definition at line 214 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::path

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ path

vxLongPath svxViewStandardData::path

file path

Examples
drawing\dwgViewTest.cpp.

Definition at line 190 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::partConfig

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ partConfig

vxName svxViewStandardData::partConfig

part config name ,PartConfig[0]=0 to ignore

Examples
drawing\dwgViewTest.cpp.

Definition at line 207 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::isIgnoreAttr

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ isIgnoreAttr

int svxViewStandardData::isIgnoreAttr

1 if ignore viewAttr and use default,else 0

Examples
drawing\dwgViewTest.cpp.

Definition at line 203 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::isCalculate

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
blankRefEntsData
cntBlankRefEnts
compConfig
coordinate
dimensionType
explodedView
fileName
isCalculate
isDispTrails
isIgnoreAttr
isOrientation
location
origin
partConfig
path
rootName
state
type
viewAttr

◆ isCalculate

int svxViewStandardData::isCalculate

1 if calculate part center ,else 0. default:1

Examples
drawing\dwgViewTest.cpp.

Definition at line 213 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxWeldAttr Struct Reference
Brep » Brep Data

weldment attribute More...

#include <zwapi_brep_data.h>

Data Fields

svxAttribute spec
spec More...
svxAttribute description
description More...
svxAttribute material
material More...
svxAttribute mass
mass More...
svxAttribute length
length More...

Detailed Description

weldment attribute

Definition at line 63 of file zwapi_brep_data.h.

The documentation for this struct was generated from the following file:
  • zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr::mass

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWeldAttr
description
length
mass
material
spec

◆ mass

svxAttribute svxWeldAttr::mass

mass

Definition at line 68 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr::length

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWeldAttr
description
length
mass
material
spec

◆ length

svxAttribute svxWeldAttr::length

length

Definition at line 69 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr::spec

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWeldAttr
description
length
mass
material
spec

◆ spec

svxAttribute svxWeldAttr::spec

spec

Definition at line 65 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr::description

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWeldAttr
description
length
mass
material
spec

◆ description

svxAttribute svxWeldAttr::description

description

Definition at line 66 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWeldAttr::material

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWeldAttr
description
length
mass
material
spec

◆ material

svxAttribute svxWeldAttr::material

material

Definition at line 67 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWireAt Struct Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
Data Fields
svxWireAt Struct Reference
Common » Common Data

wire display attributes More...

#include <zwapi_util.h>

Data Fields

unsigned char | color
color (0 if bundle undefined, else 1 through (VX_COLOR_LAST-1), ColorEnv[]) More...
unsigned char | type
line/marker type ( >= 0) More...
unsigned char | size
line/marker size ( >= 1) More...
char | mode
display mode
-3, permanently blanked
-2, used for assembly alignment
-1, blanked
0, normal
1, highlight
2, lowlight
3, highlight and change line style
4, lowlight and change line style More...

Detailed Description

wire display attributes

Definition at line 1187 of file zwapi_util.h.

The documentation for this struct was generated from the following file:
  • zwapi_util.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWireAt::size

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWireAt
color
mode
size
type

◆ size

unsigned char svxWireAt::size

line/marker size ( >= 1)

Definition at line 1191 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWireAt::type

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWireAt
color
mode
size
type

◆ type

unsigned char svxWireAt::type

line/marker type ( >= 0)

Definition at line 1190 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWireAt::mode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWireAt
color
mode
size
type

◆ mode

char svxWireAt::mode

display mode
-3, permanently blanked
-2, used for assembly alignment
-1, blanked
0, normal
1, highlight
2, lowlight
3, highlight and change line style
4, lowlight and change line style

Definition at line 1192 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxWireAt::color

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxWireAt
color
mode
size
type

◆ color

unsigned char svxWireAt::color

color (0 if bundle undefined, else 1 through (VX_COLOR_LAST-1), ColorEnv[])

Definition at line 1189 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmChmf::svxAsmChmfData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmChmf
  • svxAsmChmfData
Data Structures | Data Fields
svxAsmChmf::svxAsmChmfData Union Reference

assembly chamfer data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

struct | svxAsmEdgeChmf
edge chamfer type More...
struct | svxAsmVertexChmf
vertex chamfer type More...

Data Fields

struct svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf | edge
struct svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf | vertex

Detailed Description

assembly chamfer data

<

Definition at line 889 of file zwapi_cmd_assembly_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmFllt::svxAsmFlltData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmFllt
  • svxAsmFlltData
Data Structures | Data Fields
svxAsmFllt::svxAsmFlltData Union Reference

union of assembly fillet data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

struct | svxAsmEdge
edge fillet type More...
struct | svxAsmLoop
loop fillet type More...
struct | svxAsmVertex
vertex fillet type More...

Data Fields

struct svxAsmFllt::svxAsmFlltData::svxAsmEdge | edge
struct svxAsmFllt::svxAsmFlltData::svxAsmLoop | loop
struct svxAsmFllt::svxAsmFlltData::svxAsmVertex | vertex

Detailed Description

union of assembly fillet data

<

Definition at line 842 of file zwapi_cmd_assembly_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:47 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMirror::AsmMirrorData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMirror
  • AsmMirrorData
Data Structures | Data Fields
svxAsmMirror::AsmMirrorData Union Reference

union of assembly Mirror data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

struct | AsmDup
duplicate type More...
struct | svxAsmCopy
copy type More...

Data Fields

struct svxAsmMirror::AsmMirrorData::svxAsmCopy | copy
struct svxAsmMirror::AsmMirrorData::AsmDup | duplicate

Detailed Description

union of assembly Mirror data

<

Definition at line 789 of file zwapi_cmd_assembly_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmMove::AsmMoveData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmMove
  • AsmMoveData
Data Structures | Data Fields
svxAsmMove::AsmMoveData Union Reference

union of assembly Move data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

struct | svxAsmAlignFrame
align frame More...
struct | svxAsmAlongDir
along direction More...
struct | svxAsmAroundDir
around direction More...
struct | svxAsmDynamic
dynamic move More...
struct | svxAsmPnt
point to point More...
struct | svxAsmSweep
sweep More...

Data Fields

struct svxAsmMove::AsmMoveData::svxAsmDynamic | dynamic
struct svxAsmMove::AsmMoveData::svxAsmPnt | pnt
struct svxAsmMove::AsmMoveData::svxAsmAlongDir | alongDir
struct svxAsmMove::AsmMoveData::svxAsmAroundDir | aroundDir
struct svxAsmMove::AsmMoveData::svxAsmAlignFrame | align
struct svxAsmMove::AsmMoveData::svxAsmSweep | sweep

Detailed Description

union of assembly Move data

<

Definition at line 721 of file zwapi_cmd_assembly_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAsmPtnData::svxAsmPtn Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAsmPtnData
  • svxAsmPtn
Data Structures | Data Fields
svxAsmPtnData::svxAsmPtn Union Reference

union of assembly Pattern data More...

#include <zwapi_cmd_assembly_data.h>

Data Structures

struct | svxAsmAtCrv
at curves pattern More...
struct | svxAsmAtFace
at face pattern More...
struct | svxAsmCircular
circular pattern More...
struct | svxAsmLinear
linear pattern More...
struct | svxAsmPattern
at pattern pattern More...
struct | svxAsmPntToPnt
point to point pattern More...

Data Fields

struct svxAsmPtnData::svxAsmPtn::svxAsmLinear | linear
struct svxAsmPtnData::svxAsmPtn::svxAsmCircular | circular
struct svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt | point
struct svxAsmPtnData::svxAsmPtn::svxAsmPattern | pattern
struct svxAsmPtnData::svxAsmPtn::svxAsmAtCrv | curve
struct svxAsmPtnData::svxAsmPtn::svxAsmAtFace | face

Detailed Description

union of assembly Pattern data

<

Definition at line 640 of file zwapi_cmd_assembly_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxAxisData::evxAxisInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxAxisData
  • evxAxisInpUnion
Data Structures | Data Fields
svxAxisData::evxAxisInpUnion Union Reference

union of Axis input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

struct | AxisFaceCenter
face center Axis More...
struct | AxisGeomPnt
geometry More...
struct | AxisIntersectFaces
intersect faces More...
struct | AxisPntAndDir
point and direction More...
struct | AxisTwoPnts
Two Points. More...

Data Fields

struct svxAxisData::evxAxisInpUnion::AxisPntAndDir | pntDir
struct svxAxisData::evxAxisInpUnion::AxisGeomPnt | geomPnt
struct svxAxisData::evxAxisInpUnion::AxisFaceCenter | facCenter
struct svxAxisData::evxAxisInpUnion::AxisIntersectFaces | interFaces
struct svxAxisData::evxAxisInpUnion::AxisTwoPnts | twoPnts

Detailed Description

union of Axis input data

<

Definition at line 53 of file zwapi_cmd_datum_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:48 for the ZWAPIOPEN


ZWAPIOPEN: svxCSYSData::evxCSYSInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCSYSData
  • evxCSYSInpUnion
Data Structures | Data Fields
svxCSYSData::evxCSYSInpUnion Union Reference

union of csys input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

struct | CSYSByGeom
geometry More...
struct | CSYSDynamic
dynamic More...
struct | CSYSPlanAndDir
Plane and direction. More...
struct | CSYSPntAnd2Dir
point and two directions More...
struct | CSYSThreeFaces
three faces More...
struct | CSYSThreePnts
three points More...

Data Fields

struct svxCSYSData::evxCSYSInpUnion::CSYSByGeom | byGeom
struct svxCSYSData::evxCSYSInpUnion::CSYSThreePnts | threePnts
struct svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces | threeFaces
struct svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir | pntAnd2Dir
struct svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir | PlanAndDir
struct svxCSYSData::evxCSYSInpUnion::CSYSDynamic | dynamic

Detailed Description

union of csys input data

<

Definition at line 351 of file zwapi_cmd_datum_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:51 for the ZWAPIOPEN


ZWAPIOPEN: svxCircularBiRailData::evxCircularBiRailInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCircularBiRailData
  • evxCircularBiRailInpUnion
Data Structures | Data Fields
svxCircularBiRailData::evxCircularBiRailInpUnion Union Reference

Data Structures

struct | CircularBiRailCenter
struct | CircularBiRailConstant
struct | CircularBiRailMiddle
struct | CircularBiRailVariable

Data Fields

struct svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant | constant
struct svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable | variable
struct svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter | center
struct svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle | middle

Detailed Description

Definition at line 197 of file zwapi_cmd_freeform_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCloseCornerData::CornerData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCloseCornerData
  • CornerData
Data Structures | Data Fields
svxCloseCornerData::CornerData Union Reference

union of close corner data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxByEdge
linear pattern More...
struct | svxByFace
circular pattern More...

Data Fields

struct svxCloseCornerData::CornerData::svxByEdge | byEdge
struct svxCloseCornerData::CornerData::svxByFace | byFace

Detailed Description

union of close corner data

<

Definition at line 992 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxConicBiRailData::evxConicBiRailInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxConicBiRailData
  • evxConicBiRailInpUnion
Data Structures | Data Fields
svxConicBiRailData::evxConicBiRailInpUnion Union Reference

Data Structures

struct | ConicBiRailCenter
struct | ConicBiRailConstant
struct | ConicBiRailHolder
struct | ConicBiRailIntersection
struct | ConicBiRailTangent
struct | ConicBiRailTangentEdges
struct | ConicBiRailVariable

Data Fields

struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant | constant
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable | variable
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder | holder
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent | tangent
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection | intersection
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter | center
struct svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges | tangentEdges

Detailed Description

Definition at line 247 of file zwapi_cmd_freeform_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
Data Fields
svxCopyData::evxMethodUnion Union Reference

union of copy data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxDymMove DymCopy
dynamic copy More...
svxMovePntToPnt PntToPnt
point to point More...
svxAlongDir AlongDir
along direction data More...
svxAroundDir AroundDir
around direction data More...
svxAlignFrame AlignFrame
copy entities by aligning frames More...
svxAlongPath Sweep
sweep along path More...

Detailed Description

union of copy data

<

Definition at line 1602 of file zwapi_cmd_shape_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::AlongDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ AlongDir

svxAlongDir svxCopyData::evxMethodUnion::AlongDir

along direction data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1606 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::Sweep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ Sweep

svxAlongPath svxCopyData::evxMethodUnion::Sweep

sweep along path

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1609 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::AlignFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ AlignFrame

svxAlignFrame svxCopyData::evxMethodUnion::AlignFrame

copy entities by aligning frames

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1608 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::AroundDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ AroundDir

svxAroundDir svxCopyData::evxMethodUnion::AroundDir

around direction data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1607 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::DymCopy

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ DymCopy

svxDymMove svxCopyData::evxMethodUnion::DymCopy

dynamic copy

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1604 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCopyData::evxMethodUnion::PntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCopyData
  • evxMethodUnion
AlignFrame
AlongDir
AroundDir
DymCopy
PntToPnt
Sweep

◆ PntToPnt

svxMovePntToPnt svxCopyData::evxMethodUnion::PntToPnt

point to point

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1605 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvBlendCons::uvxCrvBlendCons Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvBlendCons
  • uvxCrvBlendCons
Data Structures | Data Fields
svxCrvBlendCons::uvxCrvBlendCons Union Reference

Data Structures

struct | svxCrvBlendCrv
struct | svxCrvBlendFace

Data Fields

struct svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv | crv
struct svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace | face

Detailed Description

Definition at line 405 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
Data Structures | Data Fields
svxCrvChamferData::evxCrvChamferInpUnion Union Reference

Data Structures

struct | CrvChamferSetbackAndAngle
struct | CrvChamferTwoSetbacks

Data Fields

double | setback
setback is a straight line distance between the vertex and the new setback point More...
struct svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks | twoSetbacks
struct svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle | setbackAndAngle

Detailed Description

Definition at line 549 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvChamferData::evxCrvChamferInpUnion::setback

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvChamferData
  • evxCrvChamferInpUnion
setback

◆ setback

double svxCrvChamferData::evxCrvChamferInpUnion::setback

setback is a straight line distance between the vertex and the new setback point

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 551 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::evxCrvFilletInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
  • evxCrvFilletInpUnion
Data Fields
svxCrvFilletData::evxCrvFilletInpUnion Union Reference

Data Fields

double radius
radius to fillet if method is VX_CRV_FILLET_RADIUS More...
svxPntOnEntPath settingPnt
point between the two picked curves to create a full fillet if method is VX_CRV_FILLET_BOUNDARY More...

Detailed Description

Definition at line 506 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::evxCrvFilletInpUnion::settingPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
  • evxCrvFilletInpUnion
radius
settingPnt

◆ settingPnt

svxPntOnEntPath svxCrvFilletData::evxCrvFilletInpUnion::settingPnt

point between the two picked curves to create a full fillet if method is VX_CRV_FILLET_BOUNDARY

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 509 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxCrvFilletData::evxCrvFilletInpUnion::radius

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxCrvFilletData
  • evxCrvFilletInpUnion
radius
settingPnt

◆ radius

double svxCrvFilletData::evxCrvFilletInpUnion::radius

radius to fillet if method is VX_CRV_FILLET_RADIUS

Examples
part\wireframeFtrCrtTest.cpp.

Definition at line 508 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:49 for the ZWAPIOPEN


ZWAPIOPEN: svxDECopy::svxDECopyData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDECopy
  • svxDECopyData
Data Structures | Data Fields
svxDECopy::svxDECopyData Union Reference

Union of DE copy data. More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

struct | svxDECopyDir
copy along a direction type More...
struct | svxDECopyDyn
dynamic copy type More...
struct | svxDECopyFrame
copy by aligning frame type More...
struct | svxDECopyPath
copy along path type More...
struct | svxDECopyPnt
copy entities point to point type More...
struct | svxDECopyRotate
rotate around a direction type More...

Data Fields

struct svxDECopy::svxDECopyData::svxDECopyDyn | dynamic
struct svxDECopy::svxDECopyData::svxDECopyPnt | point
struct svxDECopy::svxDECopyData::svxDECopyDir | direction
struct svxDECopy::svxDECopyData::svxDECopyRotate | rotate
struct svxDECopy::svxDECopyData::svxDECopyFrame | frame
struct svxDECopy::svxDECopyData::svxDECopyPath | path

Detailed Description

Union of DE copy data.

<

Definition at line 331 of file zwapi_cmd_direct_edit_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEMove::svxDEMoveData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEMove
  • svxDEMoveData
Data Structures | Data Fields
svxDEMove::svxDEMoveData Union Reference

union of DE move type More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

struct | svxDEMoveDir
move along a direction type More...
struct | svxDEMoveDyn
dynamic move type More...
struct | svxDEMoveFrame
move by aligning frame type More...
struct | svxDEMovePath
move along path type More...
struct | svxDEMovePnt
move entities point to point type More...
struct | svxDEMoveRotate
rotate around a direction type More...

Data Fields

struct svxDEMove::svxDEMoveData::svxDEMoveDyn | dynamic
struct svxDEMove::svxDEMoveData::svxDEMovePnt | point
struct svxDEMove::svxDEMoveData::svxDEMoveDir | direction
struct svxDEMove::svxDEMoveData::svxDEMoveRotate | rotate
struct svxDEMove::svxDEMoveData::svxDEMoveFrame | frame
struct svxDEMove::svxDEMoveData::svxDEMovePath | path

Detailed Description

union of DE move type

<

Definition at line 96 of file zwapi_cmd_direct_edit_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDEPattern::svxDEPtnData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDEPattern
  • svxDEPtnData
Data Structures | Data Fields
svxDEPattern::svxDEPtnData Union Reference

union of De pattern data More...

#include <zwapi_cmd_direct_edit_data.h>

Data Structures

struct | svxDEPtnCircular
circular DE(Direct Edit) pattern type More...
struct | svxDEPtnCurve
at curve(s) DE(Direct Edit) pattern type More...
struct | svxDEPtnFace
at face DE(Direct Edit) pattern type More...
struct | svxDEPtnLinear
linear DE(Direct Edit) pattern type More...
struct | svxDEPtnPattern
at pattern DE(Direct Edit) pattern type More...
struct | svxDEPtnPoint
point to point DE(Direct Edit) pattern type More...

Data Fields

struct svxDEPattern::svxDEPtnData::svxDEPtnLinear | linear
struct svxDEPattern::svxDEPtnData::svxDEPtnCircular | circular
struct svxDEPattern::svxDEPtnData::svxDEPtnPoint | point
struct svxDEPattern::svxDEPtnData::svxDEPtnPattern | pattern
struct svxDEPattern::svxDEPtnData::svxDEPtnCurve | curve
struct svxDEPattern::svxDEPtnData::svxDEPtnFace | face

Detailed Description

union of De pattern data

<

Definition at line 482 of file zwapi_cmd_direct_edit_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxDraftData::svxDraftStationaryEnt Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxDraftData
  • svxDraftStationaryEnt
Data Structures | Data Fields
svxDraftData::svxDraftStationaryEnt Union Reference

Stationary Entity such as Faces and Edges. More...

#include <zwapi_cmd_shape_data.h>

Data Structures

struct | StationAndPrtingFace
Stationary faces and Parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType) More...
struct | StationaryFaces
Stationary faces in STATION_SYM_FACE_DRAFT(evxDraftType) and STATION_ASYM_FACE_DRAFT(evxDraftType) More...
struct | StationaryPlane
Stationary plane in PRATING_EDGE_DRAFT(evxDraftMethods) More...

Data Fields

struct svxDraftData::svxDraftStationaryEnt::StationaryFaces | stationaryFaces
struct svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace | staAndPrtFace
struct svxDraftData::svxDraftStationaryEnt::StationaryPlane | stationaryPlane

Detailed Description

Stationary Entity such as Faces and Edges.

<

Definition at line 570 of file zwapi_cmd_shape_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:52 for the ZWAPIOPEN


ZWAPIOPEN: svxExtendShapeData::evxExtendShapeInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxExtendShapeData
  • evxExtendShapeInpUnion
Data Structures | Data Fields
svxExtendShapeData::evxExtendShapeInpUnion Union Reference

Data Structures

struct | ExtendGeneralShape
struct | ExtendOpenShape

Data Fields

struct svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape | open
struct svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape | general

Detailed Description

Definition at line 473 of file zwapi_cmd_freeform_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxFaceCrvData::uvxFaceCrvData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxFaceCrvData
  • uvxFaceCrvData
Data Structures | Data Fields
svxFaceCrvData::uvxFaceCrvData Union Reference

Data Structures

struct | uvxFromEdges
struct | uvxFromProjCrv

Data Fields

struct svxFaceCrvData::uvxFaceCrvData::uvxFromEdges | fromEdge
create face curves from edges data
struct svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv | fromProjCrv
create face curves from projected curves data

Detailed Description

Definition at line 329 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoCrvOnFaceData::uvxCrvIsoData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoCrvOnFaceData
  • uvxCrvIsoData
Data Structures | Data Fields
svxIsoCrvOnFaceData::uvxCrvIsoData Union Reference

Data Structures

struct | svxCrvIsoAtPoint
struct | svxCrvIsoAtUVParam
struct | svxCrvIsoMultiple

Data Fields

struct svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint | atPoint
struct svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam | UVParam
struct svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple | multiple

Detailed Description

Definition at line 261 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxIsoclineCrvData::uvxCrvIsoclineData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxIsoclineCrvData
  • uvxCrvIsoclineData
Data Structures | Data Fields
svxIsoclineCrvData::uvxCrvIsoclineData Union Reference

Data Structures

struct | svxIsoclineCrvMultiple
struct | svxIsoclineCrvSingle

Data Fields

struct svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle | single
create isocline curve with a single angle
struct svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple | multiple
create isocline curves with multiple angles

Detailed Description

Definition at line 304 of file zwapi_cmd_wireframe_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:53 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::evxMethodsUnion2D Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
  • evxMethodsUnion2D
Data Fields
svxMoveData2D::evxMethodsUnion2D Union Reference

move data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Fields

svxAlongDir2D AlongDir2D
along direction data(2D) More...
svxMovePntToPnt2D PntToPnt2D
point to point(2D) More...

Detailed Description

move data

<

Definition at line 672 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::evxMethodsUnion2D::PntToPnt2D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
  • evxMethodsUnion2D
AlongDir2D
PntToPnt2D

◆ PntToPnt2D

svxMovePntToPnt2D svxMoveData2D::evxMethodsUnion2D::PntToPnt2D

point to point(2D)

Examples
sketch\basicEditingTest.cpp.

Definition at line 675 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData2D::evxMethodsUnion2D::AlongDir2D

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData2D
  • evxMethodsUnion2D
AlongDir2D
PntToPnt2D

◆ AlongDir2D

svxAlongDir2D svxMoveData2D::evxMethodsUnion2D::AlongDir2D

along direction data(2D)

Examples
sketch\basicEditingTest.cpp.

Definition at line 674 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
Data Fields
svxMoveData::evxMethodsUnion Union Reference

union of move data More...

#include <zwapi_cmd_shape_data.h>

Data Fields

svxDymMove DymMove
dynamic move More...
svxMovePntToPnt PntToPnt
point to point More...
svxAlongDir AlongDir
along direction data More...
svxAroundDir AroundDir
around direction data More...
svxAlignFrame AlignFrame
copy entities by aligning frames More...
svxAlongPath Sweep
sweep along path More...

Detailed Description

union of move data

<

Definition at line 1582 of file zwapi_cmd_shape_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::AlignFrame

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ AlignFrame

svxAlignFrame svxMoveData::evxMethodsUnion::AlignFrame

copy entities by aligning frames

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1588 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::AlongDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ AlongDir

svxAlongDir svxMoveData::evxMethodsUnion::AlongDir

along direction data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1586 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::Sweep

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ Sweep

svxAlongPath svxMoveData::evxMethodsUnion::Sweep

sweep along path

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1589 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::DymMove

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ DymMove

svxDymMove svxMoveData::evxMethodsUnion::DymMove

dynamic move

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1584 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::AroundDir

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ AroundDir

svxAroundDir svxMoveData::evxMethodsUnion::AroundDir

around direction data

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1587 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxMoveData::evxMethodsUnion::PntToPnt

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxMoveData
  • evxMethodsUnion
AlignFrame
AlongDir
AroundDir
DymMove
PntToPnt
Sweep

◆ PntToPnt

svxMovePntToPnt svxMoveData::evxMethodsUnion::PntToPnt

point to point

Examples
part\baseFtrCrtTest.cpp.

Definition at line 1585 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxNewPlaneData::evxNewPlaneMethodsUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxNewPlaneData
  • evxNewPlaneMethodsUnion
Data Structures | Data Fields
svxNewPlaneData::evxNewPlaneMethodsUnion Union Reference

union of plane input data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

struct | NewPlaneAngToFc
angle to face :VX_NEW_PLANE_ANGLE_FACE More...
struct | NewPlaneDynamic
dynamic :VX_NEW_PLANE_DYNAMIC More...
struct | NewPlaneGeometry
geometry :VX_NEW_PLANE_GEOMETRY More...
struct | NewPlaneOffset
offset plane :VX_NEW_PLANE_OFFSET_PLANE More...
struct | NewPlaneOnCurve
on curve :VX_NEW_PLANE_ON_CURVE More...
struct | NewPlaneThreePnt
three point :VX_NEW_PLANE_THREE_POINTS More...
struct | NewviewPlane
view plane :VX_NEW_PLANE_VIEW_PLANE More...

Data Fields

struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry | geom
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt | threePnts
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane | view
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic | dynamic
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset | pOffset
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc | angToFc
struct svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve | onCrv

Detailed Description

union of plane input data

<

Definition at line 211 of file zwapi_cmd_datum_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:54 for the ZWAPIOPEN


ZWAPIOPEN: svxPlaneData::evxPlnInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPlaneData
  • evxPlnInpUnion
Data Structures | Data Fields
svxPlaneData::evxPlnInpUnion Union Reference

union of plane data More...

#include <zwapi_cmd_datum_data.h>

Data Structures

struct | PlaneXYZ
use XY Plane/ XZ Plane/ YZ Plan More...
struct | PlnDynamic
Dynamic. More...
struct | PlnGeomPnt
geometry More...
struct | PlnThreePnts
three point More...
struct | PlnTwoEnts
Two Entities. More...
struct | viewPlane
view plane More...

Data Fields

struct svxPlaneData::evxPlnInpUnion::PlnGeomPnt | geomPnt
struct svxPlaneData::evxPlnInpUnion::PlnThreePnts | threePnts
struct svxPlaneData::evxPlnInpUnion::PlaneXYZ | xyz
struct svxPlaneData::evxPlnInpUnion::viewPlane | viewPln
struct svxPlaneData::evxPlnInpUnion::PlnTwoEnts | twoEnts
struct svxPlaneData::evxPlnInpUnion::PlnDynamic | dynamic

Detailed Description

union of plane data

<

Definition at line 123 of file zwapi_cmd_datum_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:55 for the ZWAPIOPEN


ZWAPIOPEN: svxPtnData::PtnData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPtnData
  • PtnData
Data Structures | Data Fields
svxPtnData::PtnData Union Reference

union of part pattern data More...

#include <zwapi_cmd_shape_data.h>

Data Structures

struct | svxCircular
circular pattern More...
struct | svxLinear
linear pattern More...
struct | svxPattern
pattern based on pattern More...
struct | svxPntFill
fill pattern More...
struct | svxPntToPnt
point to point pattern More...
struct | svxPntVar
feature pattern by variant parameters when inpData.type = VX_PATTERN_BY_VAR More...
struct | svxPolygon
polygon pattern More...
struct | svxPtnCrv
curve pattern More...
struct | svxPtnFace
face pattern More...

Data Fields

struct svxPtnData::PtnData::svxLinear | linear
struct svxPtnData::PtnData::svxCircular | circular
struct svxPtnData::PtnData::svxPolygon | polygon
struct svxPtnData::PtnData::svxPntToPnt | PntToPnt
struct svxPtnData::PtnData::svxPattern | pattern
struct svxPtnData::PtnData::svxPtnCrv | ptnCrv
struct svxPtnData::PtnData::svxPtnFace | ptnFace
struct svxPtnData::PtnData::svxPntFill | ptnFill
struct svxPtnData::PtnData::svxPntVar | ptnVar

Detailed Description

union of part pattern data

<

Definition at line 1297 of file zwapi_cmd_shape_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxPunchData::LocData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxPunchData
  • LocData
Data Structures | Data Fields
svxPunchData::LocData Union Reference

union of punch data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | ByCons
point + constraint More...
struct | ByPnt
point + frame More...

Data Fields

struct svxPunchData::LocData::ByPnt | byPnt
struct svxPunchData::LocData::ByCons | byCons

Detailed Description

union of punch data

<

Definition at line 1093 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxReadyText::evxSkTextMethodsUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxReadyText
  • evxSkTextMethodsUnion
Data Structures | Data Fields
svxReadyText::evxSkTextMethodsUnion Union Reference

union of sketch text data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

struct | BoxText
box text data More...
struct | OnCrvText
On curve text data. More...

Data Fields

struct svxReadyText::evxSkTextMethodsUnion::OnCrvText | oncrvtext
struct svxReadyText::evxSkTextMethodsUnion::BoxText | boxtext

Detailed Description

union of sketch text data

<

Definition at line 137 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:56 for the ZWAPIOPEN


ZWAPIOPEN: svxSkAxisData::evxSkAxisMethodsUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkAxisData
  • evxSkAxisMethodsUnion
Data Structures | Data Fields
svxSkAxisData::evxSkAxisMethodsUnion Union Reference

union of sketch axis data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

struct | SkAxis2Pnt
Two Points. More...
struct | SkAxisAngle
Angle. More...
struct | SkAxisParaOff
Parallel and Offset. More...

Data Fields

struct svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt | axis2pnt
struct svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff | axisParaOff
struct svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle | axisAng

Detailed Description

union of sketch axis data

<

Definition at line 65 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:57 for the ZWAPIOPEN


ZWAPIOPEN: svxSkCopy::svxSkCopyData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkCopy
  • svxSkCopyData
Data Structures | Data Fields
svxSkCopy::svxSkCopyData Union Reference

union of sketch copy data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

struct | svxSkCopyDir
along a direction type More...
struct | svxSkCopyPnt
point to point copy type More...

Data Fields

struct svxSkCopy::svxSkCopyData::svxSkCopyPnt | pnt
struct svxSkCopy::svxSkCopyData::svxSkCopyDir | dir

Detailed Description

union of sketch copy data

<

Definition at line 832 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:58 for the ZWAPIOPEN


ZWAPIOPEN: svxSkPtnData::SkPtnData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkPtnData
  • SkPtnData
Data Structures | Data Fields
svxSkPtnData::SkPtnData Union Reference

union of sketch pattern data More...

#include <zwapi_cmd_sk_cmds_data.h>

Data Structures

struct | svxSkCircular
circular pattern More...
struct | svxSkLinear
linear pattern More...
struct | svxSkPtnCrv
curve pattern More...

Data Fields

struct svxSkPtnData::SkPtnData::svxSkLinear | linear
struct svxSkPtnData::SkPtnData::svxSkCircular | circular
struct svxSkPtnData::SkPtnData::svxSkPtnCrv | ptnCrv

Detailed Description

union of sketch pattern data

<

Definition at line 760 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:59 for the ZWAPIOPEN


ZWAPIOPEN: svxSkRefData::evxSkRefInpUnion Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSkRefData
  • evxSkRefInpUnion
Data Structures | Data Fields
svxSkRefData::evxSkRefInpUnion Union Reference

Data Structures

struct | ReferenceChain
struct | ReferenceLoop
struct | ReferencePoint
struct | ReferenceSingle

Data Fields

struct svxSkRefData::evxSkRefInpUnion::ReferenceSingle | single
struct svxSkRefData::evxSkRefInpUnion::ReferenceChain | chain
struct svxSkRefData::evxSkRefInpUnion::ReferenceLoop | loop
struct svxSkRefData::evxSkRefInpUnion::ReferencePoint | point

Detailed Description

Definition at line 253 of file zwapi_cmd_sk_cmds_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:42:00 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdBendTaperDefData::uvxSmdTaperDefInfos Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdBendTaperDefData
  • uvxSmdTaperDefInfos
Data Structures | Data Fields
svxSmdBendTaperDefData::uvxSmdTaperDefInfos Union Reference

union of smd bend taper definition data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxSmdLinear
smd linear data More...
struct | svxSmdTangent
smd tangent data More...

Data Fields

struct svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear | linear
struct svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent | tangent

Detailed Description

union of smd bend taper definition data

<

Definition at line 865 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdChangeBendData::uvxSmdChangeBend Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdChangeBendData
  • uvxSmdChangeBend
Data Structures | Data Fields
svxSmdChangeBendData::uvxSmdChangeBend Union Reference

union of smd change bend data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxChangeBendDefault
VX_SMD_CHANGE_BEND_DEFAULT. More...
struct | svxChangeBendFold
VX_SMD_CHANGE_BEND_FOLD_LENGTH. More...
struct | svxChangeBendUnfold
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH. More...

Data Fields

struct svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault | defaultInfo
struct svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold | fold
struct svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold | unfold

Detailed Description

union of smd change bend data

<

Definition at line 1269 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::uvxExtFlangeData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
  • uvxExtFlangeData
Data Structures | Data Fields
svxSmdExtendFlangeData::uvxExtFlangeData Union Reference

union of smd extend flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct svxExtFlangeData
apply it if type != VX_SMD_EXTEND_BY_VALUE More...

Data Fields

double | distance
Specify a value to extend.default:0.1 The flange will stretch out when you enter a positive number, and will be cut when you enter negative number. Apply it if type = VX_SMD_EXTEND_BY_VALUE. More...
struct svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData | nonByValue

Detailed Description

union of smd extend flange data

<

Definition at line 820 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdExtendFlangeData::uvxExtFlangeData::distance

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdExtendFlangeData
  • uvxExtFlangeData
distance

◆ distance

double svxSmdExtendFlangeData::uvxExtFlangeData::distance

Specify a value to extend.default:0.1 The flange will stretch out when you enter a positive number, and will be cut when you enter negative number. Apply it if type = VX_SMD_EXTEND_BY_VALUE.

Examples
part\smdFtrCrtTest.cpp.

Definition at line 822 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:42:02 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdHemFlangeData::uvxSmdHemData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdHemFlangeData
  • uvxSmdHemData
Data Structures | Data Fields
svxSmdHemFlangeData::uvxSmdHemData Union Reference

union of smd hem data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxSmdFullHemData
if hemType = 0, using the following variables More...
struct | svxSmdPartHemData
if hemType = 1, using the following variables More...

Data Fields

struct svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData | full
struct svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData | partial

Detailed Description

union of smd hem data

<

Definition at line 505 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdLoftedFlangeData::uvxLftFlange Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdLoftedFlangeData
  • uvxLftFlange
Data Structures | Data Fields
svxSmdLoftedFlangeData::uvxLftFlange Union Reference

union of smd lofted flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxSmdLftBend
VX_SMD_BENDING_LOFTING. More...
struct | svxSmdLftFlat
VX_SMD_FLATTENABLE_LOFTING. More...
struct | svxSmdLftGeneral
VX_SMD_GENERAL_LOFTING. More...

Data Fields

struct svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral | general
struct svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat | flattenable
struct svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend | bending

Detailed Description

union of smd lofted flange data

<

Definition at line 606 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxSmdSweptFlangeData::uvxSmdSweptFlange Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxSmdSweptFlangeData
  • uvxSmdSweptFlange
Data Structures | Data Fields
svxSmdSweptFlangeData::uvxSmdSweptFlange Union Reference

union of smd swept flange data More...

#include <zwapi_cmd_sheetmetal_data.h>

Data Structures

struct | svxSmdReliefCircular
VX_CORNER_RELIEF_CIRCULAR_CUTOUT. More...
struct | svxSmdReliefClosed
VX_CORNER_RELIEF_CLOSED. More...
struct | svxSmdReliefRectangular
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT. More...
struct | svxSmdReliefUCutout
VX_CORNER_RELIEF_U_CUTOUT. More...
struct | svxSmdReliefVCutout
VX_CORNER_RELIEF_V_CUTOUT. More...

Data Fields

struct svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed | closed
struct svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular | circular
struct svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular | rectangular
struct svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout | uCutout
struct svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout | vCutout

Detailed Description

union of smd swept flange data

<

Definition at line 690 of file zwapi_cmd_sheetmetal_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:42:03 for the ZWAPIOPEN


ZWAPIOPEN: svxTableCellData::svxCellData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTableCellData
  • svxCellData
Data Structures | Data Fields
svxTableCellData::svxCellData Union Reference

Data Structures

struct | svxCheckData
struct | svxColorData
struct | svxComboData
struct | svxDateData
struct | svxNumData
struct | svxTextData

Data Fields

struct svxTableCellData::svxCellData::svxTextData | textData
struct svxTableCellData::svxCellData::svxComboData | comboData
struct svxTableCellData::svxCellData::svxCheckData | checkBoxData
struct svxTableCellData::svxCellData::svxDateData | dateData
struct svxTableCellData::svxCellData::svxColorData | colorData
struct svxTableCellData::svxCellData::svxNumData | numData

Detailed Description

Definition at line 337 of file zwapi_ui_data.h.

The documentation for this union was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:04 for the ZWAPIOPEN


ZWAPIOPEN: svxTreeCbParam::uvxU Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxTreeCbParam
  • uvxU
Data Structures | Data Fields
svxTreeCbParam::uvxU Union Reference

Data Structures

struct | svxDRAG
drag multiple nodes More...
struct | svxHIT
struct | svxLABELEDIT
struct | svxSELECTION
multiple nodes selection More...

Data Fields

struct svxTreeCbParam::uvxU::svxDRAG | svxdrag
struct svxTreeCbParam::uvxU::svxHIT | svxhit
struct svxTreeCbParam::uvxU::svxSELECTION | svxselection
struct svxTreeCbParam::uvxU::svxLABELEDIT | svxlabel

Detailed Description

Definition at line 544 of file zwapi_ui_data.h.

The documentation for this union was generated from the following file:
  • zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::uvxViewTypeData Union Reference

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
  • uvxViewTypeData
Data Fields
svxViewStandardData::uvxViewTypeData Union Reference

union of view type data More...

#include <zwapi_cmd_dwg_data.h>

Data Fields

vxName viewName
view Name. if type = 1,apply it. More...
vxName flatName
flatten Name. if type = 2, apply it. More...
evxViewTypeEx viewType
View type(1-7,28-34,39). if type = 0,apply it. More...

Detailed Description

union of view type data

<

Definition at line 196 of file zwapi_cmd_dwg_data.h.

The documentation for this union was generated from the following file:
  • zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::uvxViewTypeData::flatName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
  • uvxViewTypeData
flatName
viewName
viewType

◆ flatName

vxName svxViewStandardData::uvxViewTypeData::flatName

flatten Name. if type = 2, apply it.

Examples
drawing\dwgViewTest.cpp.

Definition at line 199 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::uvxViewTypeData::viewName

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
  • uvxViewTypeData
flatName
viewName
viewType

◆ viewName

vxName svxViewStandardData::uvxViewTypeData::viewName

view Name. if type = 1,apply it.

Examples
drawing\dwgViewTest.cpp.

Definition at line 198 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: svxViewStandardData::uvxViewTypeData::viewType

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • svxViewStandardData
  • uvxViewTypeData
flatName
viewName
viewType

◆ viewType

evxViewTypeEx svxViewStandardData::uvxViewTypeData::viewType

View type(1-7,28-34,39). if type = 0,apply it.

Examples
drawing\dwgViewTest.cpp.

Definition at line 200 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:42:05 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASM_COMP_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_comp.h
cvxAsmReorder
cvxAssemCompVisAll
cvxBomDataFree
cvxCompBomDispDataGet
cvxCompBomExcludedGet
cvxCompBomPathByPart
cvxCompBomSettingGet
cvxCompBomSettingSet
cvxCompCfgIdGet
cvxCompExpandStateGet
cvxCompExpandStateSet
cvxCompFolderIns
cvxCompFromAsmFtr
cvxCompGetRefPart
cvxCompGetRefPartByLongPath
cvxCompHighlight
cvxCompInqOpenShapes
cvxCompInqPart
cvxCompInqPartByPath
cvxCompInqPartByPathByLongPath
cvxCompInqPaths
cvxCompInqRenderMode
cvxCompIsFileLost
cvxCompIsUnplaced
cvxCompIsUnplacedByPath
cvxCompIsVirtual
cvxCompMakeVirtual
cvxCompRegenSet
cvxCompSelectedStateGet
cvxCompSelectedStateSet
cvxCompShapeInqOpenEdges
cvxCompSuppressGet
cvxCompSuppressGetByPath
cvxCompUnHighlight
cvxCompVisGet
cvxPartInqAsmFldChildEnts
cvxPartInqAsmFolders
cvxPartInqAsmFtrList
cvxPartInqAsmIsFlex
cvxPartInqAsmIsFlexByPath
cvxPartInqComps
cvxPartInqComps2
cvxPartInqCompsInfo
cvxPartInqCompsInfoByLongPath
cvxPartInqFlexAsmMat
cvxSubPartFlag

◆ ZW_API_ASM_COMP_H

#define ZW_API_ASM_COMP_H

Definition at line 19 of file zwapi_asm_comp.h.
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_comp.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_comp.h
Go to the documentation of this file.
1
17#pragma once
18#ifndef ZW_API_ASM_COMP_H /* this ifndef surrounds entire header */
19#define ZW_API_ASM_COMP_H
20
21#include "zwapi_asm_data.h"
22
23#ifdef __cplusplus
24extern "C" {
25#endif /* __cplusplus */
26
27//====================================================================================================================
29//====================================================================================================================
30/******************************************************************************/
56extern evxErrors cvxPartInqAsmFolders(const vxLongPath File, const vxRootName Part, int type, int* count, int** Folders);
57
58
59/******************************************************************************/
87extern evxErrors cvxPartInqAsmFldChildEnts(const vxLongPath File, const vxRootName Part, int idFolder, int incSubFld, int* count, int** Ents);
88
89//====================================================================================================================
91//====================================================================================================================
92/******************************************************************************/
116extern evxErrors cvxPartInqAsmFtrList(const vxLongPath File,const vxRootName Part, int* Count, int** Features);
117
118//====================================================================================================================
120//====================================================================================================================
121/******************************************************************************/
140extern evxErrors cvxPartInqComps(const vxLongPath File,const vxRootName Part, int* Count, int** Comps);
141
142/******************************************************************************/
163extern evxErrors cvxPartInqComps2(const vxLongPath File, const vxRootName Part, int Option, int* Count, int** Comps);
164
165/******************************************************************************/
200extern evxErrors cvxPartInqCompsInfo(const vxPath Path, const vxRootName Name, int* Count, vxPath** Paths, vxRootName** Names);
201
202/******************************************************************************/
237extern evxErrors cvxPartInqCompsInfoByLongPath(const vxLongPath Path,const vxRootName Name, int* Count, vxLongPath** Paths, vxRootName** Names);
238
239/******************************************************************************/
262extern evxErrors cvxCompInqPaths(svxEntPath* CompPath, int Depth, int IgnoreHidden, int* PathCnt, svxEntPath** lstPath);
263
264//====================================================================================================================
266//====================================================================================================================
267/******************************************************************************/
288extern evxErrors cvxCompInqPart(int idComp, char* File, int nFileBytes, char* Part, int nPartBytes);
289
290/******************************************************************************/
314extern evxErrors cvxCompInqPartByPath(const svxEntPath* CompPath, vxPath fileName, vxRootName partName);
315
316/******************************************************************************/
343extern evxErrors cvxCompInqPartByPathByLongPath(const svxEntPath* CompPath, char* fileName,int sizeDir,vxRootName partName);
344
345/******************************************************************************/
372extern evxErrors cvxCompGetRefPart(int* Count, vxPath** BinName, vxRootName** RootName);
373
374/******************************************************************************/
401extern evxErrors cvxCompGetRefPartByLongPath(int* Count, vxLongPath** BinName, vxRootName** RootName);
402
403
404//====================================================================================================================
406//====================================================================================================================
407/******************************************************************************/
425extern evxErrors cvxPartInqAsmIsFlex(int idComp, int* isFlexible);
426
427/******************************************************************************/
447extern evxErrors cvxPartInqAsmIsFlexByPath(svxEntPath AsmPath, int* isFlexible);
448
449/******************************************************************************/
466extern evxErrors cvxCompSuppressGet(int idComp, int* suppress);
467
468/******************************************************************************/
487extern evxErrors cvxCompSuppressGetByPath(svxEntPath* path, int* suppress);
488
489/******************************************************************************/
505extern evxErrors cvxAssemCompVisAll(int* nSize, int** ppath_mode);
506
507/******************************************************************************/
527extern evxErrors cvxCompVisGet(svxEntPath* CompPath, int* Vis);
528
529/**********************************************************************
530*! -Blank/Unblank- : zwapi_asm_opts.h
531* extern int cvxCompVisSet(svxEntPath* CompPath, int Vis);
532**********************************************************************/
533/******************************************************************************/
547extern void cvxCompHighlight(svxEntPath* CompPath, svxColor* color);
548
549/******************************************************************************/
562extern void cvxCompUnHighlight(svxEntPath* CompPath);
563
564/******************************************************************************/
582extern evxErrors cvxCompMakeVirtual(svxEntPath* CompPath);
583
584/******************************************************************************/
602extern evxErrors cvxCompIsVirtual(svxEntPath* CompPath, int* isVirtual);
603
604/******************************************************************************/
620extern evxErrors cvxCompInqRenderMode(svxEntPath* CompPath, evxRenderMode* RenderMode);
621
622/**********************************************************************
623*! -Display- : zwapi_asm_opts.h
624* extern int cvxCompSetRenderMode(svxEntPath* CompPath, evxRenderMode RenderMode);
625**********************************************************************/
626
627/******************************************************************************/
645extern evxErrors cvxCompIsUnplaced(int idx_Comp, int* isUnplaced);
646
647/******************************************************************************/
667extern evxErrors cvxCompIsUnplacedByPath(const svxEntPath* path, int* isUnplaced);
668
669/******************************************************************************/
689extern evxErrors cvxCompIsFileLost(const svxEntPath* path, int* isFileLost);
690
691/******************************************************************************/
707extern evxErrors cvxCompExpandStateGet(const svxEntPath* path, int* isExpand);
708
709/******************************************************************************/
724extern evxErrors cvxCompExpandStateSet(const svxEntPath* path, int expand);
725
726/******************************************************************************/
746extern evxErrors cvxCompSelectedStateGet(const svxEntPath* path, int* isSelected);
747
748/******************************************************************************/
768extern evxErrors cvxCompSelectedStateSet(const svxEntPath* path, int selected);
769
770/******************************************************************************/
788extern evxErrors cvxCompBomExcludedGet(svxEntPath EntPath, int* exclude);
789
790/******************************************************************************/
810extern evxErrors cvxCompBomSettingGet(svx3DBomSettingsData* data);
811
812/******************************************************************************/
833extern evxErrors cvxCompBomSettingSet(svx3DBomSettingsData* data);
834
835/******************************************************************************/
857extern evxErrors cvxCompBomDispDataGet(svx3DBomData* data);
858
859/******************************************************************************/
870extern void cvxBomDataFree(svx3DBomData* data);
871
872/******************************************************************************/
895extern evxErrors cvxCompBomPathByPart(const vxLongName part, int* cnt, svxEntPath** paths);
896
897/******************************************************************************/
919extern evxErrors cvxCompRegenSet(int idComp, int Regen);
920
921/**********************************************************************
922* *! -Dissolve Assembly- : zwapi_asm_opts.h
923* extern int cvxAsmDissolve(const svxEntPath* path);
924**********************************************************************/
925
926//====================================================================================================================
928//====================================================================================================================
929
930/******************************************************************************/
947extern evxErrors cvxPartInqFlexAsmMat(svxEntPath AsmPath, svxMatrix* AsmMat);
948
949/******************************************************************************/
970extern evxErrors cvxCompInqOpenShapes(svxEntPath* CompPath, int IgnoreHide, int* numShps, svxEntPath** shpPaths);
971
972/******************************************************************************/
989extern evxErrors cvxCompShapeInqOpenEdges(svxEntPath* ShpPath, int* numEdg, svxEntPath** edgPaths);
990
991/******************************************************************************/
1010extern evxErrors cvxCompCfgIdGet(const svxEntPath* path, int* idCfg);
1011
1012/******************************************************************************/
1033extern evxErrors cvxCompFolderIns(int cnt, const int* idCom, const vxLongName folderName, int* idFolder);
1034
1035/**********************************************************************
1036* *! -Configurations- : zwapi_asm_opts.h
1037* extern int cvxCompCfgIdSet(const svxEntPath* path, int idCfg);
1038**********************************************************************/
1039
1040/******************************************************************************/
1074extern evxErrors cvxCompFromAsmFtr(svxEntPath* path, int* isFromAsmFtr);
1075
1076//====================================================================================================================
1078//====================================================================================================================
1079/******************************************************************************/
1102extern evxErrors cvxAsmReorder(const vxLongPath fileName, const vxRootName rootName, int idEnt, evxReorderLoc reorderLoc, int idPreEnt);
1103
1104//====================================================================================================================
1106//====================================================================================================================
1107/******************************************************************************/
1141extern evxErrors cvxSubPartFlag(const vxLongPath File, const vxRootName Part, int isSubPart);
1142
1143/*
1144*********************************************************************
1145** END HEADER FILE
1146*********************************************************************
1147*/
1148
1149#ifdef __cplusplus
1150 }
1151#endif /* __cplusplus */
1152
1153#endif /* ZW_API_ASM_COMP_H */
cvxCompFolderIns
evxErrors cvxCompFolderIns(int cnt, const int *idCom, const vxLongName folderName, int *idFolder)
cvxPartInqCompsInfo
evxErrors cvxPartInqCompsInfo(const vxPath Path, const vxRootName Name, int *Count, vxPath **Paths, vxRootName **Names)
cvxAsmReorder
evxErrors cvxAsmReorder(const vxLongPath fileName, const vxRootName rootName, int idEnt, evxReorderLoc reorderLoc, int idPreEnt)
cvxCompExpandStateGet
evxErrors cvxCompExpandStateGet(const svxEntPath *path, int *isExpand)
cvxCompIsUnplacedByPath
evxErrors cvxCompIsUnplacedByPath(const svxEntPath *path, int *isUnplaced)
cvxCompShapeInqOpenEdges
evxErrors cvxCompShapeInqOpenEdges(svxEntPath *ShpPath, int *numEdg, svxEntPath **edgPaths)
cvxCompIsVirtual
evxErrors cvxCompIsVirtual(svxEntPath *CompPath, int *isVirtual)
cvxCompBomSettingGet
evxErrors cvxCompBomSettingGet(svx3DBomSettingsData *data)
cvxSubPartFlag
evxErrors cvxSubPartFlag(const vxLongPath File, const vxRootName Part, int isSubPart)
cvxCompSelectedStateSet
evxErrors cvxCompSelectedStateSet(const svxEntPath *path, int selected)
cvxCompInqPartByPathByLongPath
evxErrors cvxCompInqPartByPathByLongPath(const svxEntPath *CompPath, char *fileName, int sizeDir, vxRootName partName)
cvxCompExpandStateSet
evxErrors cvxCompExpandStateSet(const svxEntPath *path, int expand)
cvxCompBomExcludedGet
evxErrors cvxCompBomExcludedGet(svxEntPath EntPath, int *exclude)
cvxPartInqComps
evxErrors cvxPartInqComps(const vxLongPath File, const vxRootName Part, int *Count, int **Comps)
cvxCompInqPartByPath
evxErrors cvxCompInqPartByPath(const svxEntPath *CompPath, vxPath fileName, vxRootName partName)
cvxCompBomSettingSet
evxErrors cvxCompBomSettingSet(svx3DBomSettingsData *data)
cvxCompBomDispDataGet
evxErrors cvxCompBomDispDataGet(svx3DBomData *data)
cvxPartInqAsmFtrList
evxErrors cvxPartInqAsmFtrList(const vxLongPath File, const vxRootName Part, int *Count, int **Features)
cvxCompIsUnplaced
evxErrors cvxCompIsUnplaced(int idx_Comp, int *isUnplaced)
cvxPartInqFlexAsmMat
evxErrors cvxPartInqFlexAsmMat(svxEntPath AsmPath, svxMatrix *AsmMat)
cvxBomDataFree
void cvxBomDataFree(svx3DBomData *data)
cvxCompMakeVirtual
evxErrors cvxCompMakeVirtual(svxEntPath *CompPath)
cvxCompGetRefPart
evxErrors cvxCompGetRefPart(int *Count, vxPath **BinName, vxRootName **RootName)
cvxCompUnHighlight
void cvxCompUnHighlight(svxEntPath *CompPath)
cvxCompFromAsmFtr
evxErrors cvxCompFromAsmFtr(svxEntPath *path, int *isFromAsmFtr)
cvxCompGetRefPartByLongPath
evxErrors cvxCompGetRefPartByLongPath(int *Count, vxLongPath **BinName, vxRootName **RootName)
cvxCompSuppressGet
evxErrors cvxCompSuppressGet(int idComp, int *suppress)
cvxCompInqPaths
evxErrors cvxCompInqPaths(svxEntPath *CompPath, int Depth, int IgnoreHidden, int *PathCnt, svxEntPath **lstPath)
cvxCompVisGet
evxErrors cvxCompVisGet(svxEntPath *CompPath, int *Vis)
cvxCompInqPart
evxErrors cvxCompInqPart(int idComp, char *File, int nFileBytes, char *Part, int nPartBytes)
cvxCompCfgIdGet
evxErrors cvxCompCfgIdGet(const svxEntPath *path, int *idCfg)
cvxPartInqComps2
evxErrors cvxPartInqComps2(const vxLongPath File, const vxRootName Part, int Option, int *Count, int **Comps)
cvxCompIsFileLost
evxErrors cvxCompIsFileLost(const svxEntPath *path, int *isFileLost)
cvxCompInqOpenShapes
evxErrors cvxCompInqOpenShapes(svxEntPath *CompPath, int IgnoreHide, int *numShps, svxEntPath **shpPaths)
cvxPartInqAsmFolders
evxErrors cvxPartInqAsmFolders(const vxLongPath File, const vxRootName Part, int type, int *count, int **Folders)
cvxCompInqRenderMode
evxErrors cvxCompInqRenderMode(svxEntPath *CompPath, evxRenderMode *RenderMode)
cvxPartInqAsmIsFlex
evxErrors cvxPartInqAsmIsFlex(int idComp, int *isFlexible)
cvxCompBomPathByPart
evxErrors cvxCompBomPathByPart(const vxLongName part, int *cnt, svxEntPath **paths)
cvxCompSelectedStateGet
evxErrors cvxCompSelectedStateGet(const svxEntPath *path, int *isSelected)
cvxPartInqCompsInfoByLongPath
evxErrors cvxPartInqCompsInfoByLongPath(const vxLongPath Path, const vxRootName Name, int *Count, vxLongPath **Paths, vxRootName **Names)
cvxPartInqAsmIsFlexByPath
evxErrors cvxPartInqAsmIsFlexByPath(svxEntPath AsmPath, int *isFlexible)
cvxPartInqAsmFldChildEnts
evxErrors cvxPartInqAsmFldChildEnts(const vxLongPath File, const vxRootName Part, int idFolder, int incSubFld, int *count, int **Ents)
cvxAssemCompVisAll
evxErrors cvxAssemCompVisAll(int *nSize, int **ppath_mode)
cvxCompSuppressGetByPath
evxErrors cvxCompSuppressGetByPath(svxEntPath *path, int *suppress)
cvxCompRegenSet
evxErrors cvxCompRegenSet(int idComp, int Regen)
cvxCompHighlight
void cvxCompHighlight(svxEntPath *CompPath, svxColor *color)
evxReorderLoc
evxReorderLoc
Reorder location.
Definition: zwapi_asm_data.h:34
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svx3DBomData
3d BOM row data
Definition: zwapi_asm_data.h:77
svx3DBomSettingsData
3D BOM display settings data
Definition: zwapi_asm_data.h:59
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
evxRenderMode
evxRenderMode
Render mode.
Definition: zwapi_asm_data.h:106
zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_COMP_AT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_comp_attribute.h
cvxCompFaceAtGet
cvxCompFaceAtSet
cvxCompUserAtDel
cvxCompUserAtGet
cvxCompUserAtSet

◆ ZW_API_COMP_AT_H

#define ZW_API_COMP_AT_H

Definition at line 17 of file zwapi_asm_comp_attribute.h.
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_comp_attribute.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_comp_attribute.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_COMP_AT_H /* this ifndef surrounds entire header */
17#define ZW_API_COMP_AT_H
18
19#include "zwapi_asm_data.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
28/******************************************************************************/
51extern evxErrors cvxCompUserAtGet(svxEntPath* Comp, int* Count, svxAttribute** UserAt);
52
53/******************************************************************************/
74extern evxErrors cvxCompUserAtSet(svxEntPath* Comp, int Count, svxAttribute* UserAt);
75
76/******************************************************************************/
98extern evxErrors cvxCompUserAtDel(svxEntPath* Comp, int Count, svxAttribute* UserAt);
99
100/******************************************************************************/
122extern evxErrors cvxCompFaceAtGet(const svxEntPath* CompPath, svxFaceAt* At);
123
124/******************************************************************************/
142extern evxErrors cvxCompFaceAtSet(int Count, svxEntPath* CompPath, svxFaceAt* At);
143
144/*
145*********************************************************************
146** END HEADER FILE
147*********************************************************************
148*/
149
150#ifdef __cplusplus
151 }
152#endif /* __cplusplus */
153
154#endif /* ZW_API_COMP_AT_H */
cvxCompFaceAtSet
evxErrors cvxCompFaceAtSet(int Count, svxEntPath *CompPath, svxFaceAt *At)
cvxCompUserAtGet
evxErrors cvxCompUserAtGet(svxEntPath *Comp, int *Count, svxAttribute **UserAt)
cvxCompUserAtSet
evxErrors cvxCompUserAtSet(svxEntPath *Comp, int Count, svxAttribute *UserAt)
cvxCompFaceAtGet
evxErrors cvxCompFaceAtGet(const svxEntPath *CompPath, svxFaceAt *At)
cvxCompUserAtDel
evxErrors cvxCompUserAtDel(svxEntPath *Comp, int Count, svxAttribute *UserAt)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxFaceAt
face display attributes
Definition: zwapi_util.h:1140
zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASM_CONSTRAINT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_constraint.h
cvxCompInqConsState
cvxCompInqConstraints
cvxConsInqConsData
cvxConsInqRefEnts
cvxConsInqType

◆ ZW_API_ASM_CONSTRAINT_H

#define ZW_API_ASM_CONSTRAINT_H

Definition at line 17 of file zwapi_asm_constraint.h.
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_constraint.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_constraint.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_ASM_CONSTRAINT_H /* this ifndef surrounds entire header */
17#define ZW_API_ASM_CONSTRAINT_H
18
19#include "zwapi_asm_data.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
28/******************************************************************************/
46extern evxErrors cvxConsInqType(int idCons, evxConsType* consType);
47
48/******************************************************************************/
70extern evxErrors cvxConsInqRefEnts(int idCons, int* count, svxEntPath** entPaths);
71
72/******************************************************************************/
91extern evxErrors cvxConsInqConsData(int idCons, svxConsData* ConsData);
92
93/******************************************************************************/
111extern evxErrors cvxCompInqConsState(int idComp, evxConsState* consState);
112
113/******************************************************************************/
135extern evxErrors cvxCompInqConstraints(svxEntPath* CompPath, int* count, int** cons);
136
137/*
138*********************************************************************
139** END HEADER FILE
140*********************************************************************
141*/
142
143#ifdef __cplusplus
144 }
145#endif /* __cplusplus */
146
147#endif /* ZW_API_ASM_CONSTRAINT_H */
cvxConsInqConsData
evxErrors cvxConsInqConsData(int idCons, svxConsData *ConsData)
cvxCompInqConstraints
evxErrors cvxCompInqConstraints(svxEntPath *CompPath, int *count, int **cons)
cvxCompInqConsState
evxErrors cvxCompInqConsState(int idComp, evxConsState *consState)
cvxConsInqRefEnts
evxErrors cvxConsInqRefEnts(int idCons, int *count, svxEntPath **entPaths)
cvxConsInqType
evxErrors cvxConsInqType(int idCons, evxConsType *consType)
evxConsType
evxConsType
assembly constraint type
Definition: zwapi_cmd_assembly_data.h:193
evxConsState
evxConsState
constraint state of component
Definition: zwapi_cmd_assembly_data.h:369
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxConsData
custom data for assembly common constraint
Definition: zwapi_cmd_assembly_data.h:221
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: evxRenderMode

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_data.h
evx3DBomLevelDispMode
evx3DBomLevelDispMode
evxRenderMode
evxRenderMode
evxReorderLoc
evxReorderLoc
svx3DBomData
svx3DBomSettingsData
svxAsmGrpCompData

◆ evxRenderMode

enum evxRenderMode

Render mode.

Enumerator
VX_RENDER_NONE | no render mode
VX_RENDER_WIRE | wireframe
VX_RENDER_SHADE | shaded
VX_RENDER_HIDD_APPROX | hidden line
VX_RENDER_ANALYZE | analyze
VX_RENDER_TRANSPARENT | transparent

Definition at line 105 of file zwapi_asm_data.h.

106 {
107 VX_RENDER_NONE = 0,
108 VX_RENDER_WIRE = 1,
109 VX_RENDER_SHADE = 2,
110 VX_RENDER_HIDD_APPROX = 3,
111 VX_RENDER_ANALYZE = 4,
112 VX_RENDER_TRANSPARENT = 9
113 } evxRenderMode;
evxRenderMode
evxRenderMode
Render mode.
Definition: zwapi_asm_data.h:106
VX_RENDER_NONE
@ VX_RENDER_NONE
no render mode
Definition: zwapi_asm_data.h:107
VX_RENDER_HIDD_APPROX
@ VX_RENDER_HIDD_APPROX
hidden line
Definition: zwapi_asm_data.h:110
VX_RENDER_ANALYZE
@ VX_RENDER_ANALYZE
analyze
Definition: zwapi_asm_data.h:111
VX_RENDER_TRANSPARENT
@ VX_RENDER_TRANSPARENT
transparent
Definition: zwapi_asm_data.h:112
VX_RENDER_SHADE
@ VX_RENDER_SHADE
shaded
Definition: zwapi_asm_data.h:109
VX_RENDER_WIRE
@ VX_RENDER_WIRE
wireframe
Definition: zwapi_asm_data.h:108
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASM_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_data.h
evx3DBomLevelDispMode
evx3DBomLevelDispMode
evxRenderMode
evxRenderMode
evxReorderLoc
evxReorderLoc
svx3DBomData
svx3DBomSettingsData
svxAsmGrpCompData

◆ ZW_API_ASM_DATA_H

#define ZW_API_ASM_DATA_H

Definition at line 17 of file zwapi_asm_data.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_ASM_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_ASM_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_assembly_data.h"
21
22#ifdef __cplusplus
23extern "C" {
24#endif /* __cplusplus */
25
26//====================================================================================================================
28//====================================================================================================================
33typedef enum evxReorderLoc
34 {
35 VX_REORDER_FIRST = 0,
36 VX_REORDER_LAST = 1,
37 VX_REORDER_AFTER = 2,
38 } evxReorderLoc;
39
45typedef enum evx3DBomLevelDispMode
46 {
47 VX_3DBOM_TOP_LEVEL_ONLY = 1,
48 VX_3DBOM_PARTS_ONLY = 2,
49 VX_3DBOM_INDENTED = 3,
50 VX_3DBOM_SHAPE_ONLY = 4,
51 VX_3DBOM_ALLCOMPONENTS = 5,
52 } evx3DBomLevelDispMode;
53
58typedef struct svx3DBomSettingsData
59 {
60 evx3DBomLevelDispMode mode;
61 int countColumn;
62 struct svxBomColumn
63 {
64 vxLongName attrName;
65 int isCheck;
66 int isTotal;
68 }* listColumnData;
69
70 } svx3DBomSettingsData;
71
76typedef struct svx3DBomData
77 {
78 int cntRow;
79 int cntCol;
80 vxLongName** list;
81 } svx3DBomData;
82
83//====================================================================================================================
85//====================================================================================================================
90typedef struct svxAsmGrpCompData
91 {
92 vxPath file;
94 vxRootName part;
95 int isVirtual;
96 int isPartOnly;
97 int count;
98 svxEntPath* paths;
99 } svxAsmGrpCompData;
100
105typedef enum evxRenderMode
106 {
107 VX_RENDER_NONE = 0,
108 VX_RENDER_WIRE = 1,
109 VX_RENDER_SHADE = 2,
110 VX_RENDER_HIDD_APPROX = 3,
111 VX_RENDER_ANALYZE = 4,
112 VX_RENDER_TRANSPARENT = 9
113 } evxRenderMode;
114
115/*
116*********************************************************************
117** END HEADER FILE
118*********************************************************************
119*/
120#ifdef __cplusplus
121 }
122#endif /* __cplusplus */
123#endif /* ZW_API_ASM_DATA_H */
evx3DBomLevelDispMode
evx3DBomLevelDispMode
level display settings.
Definition: zwapi_asm_data.h:46
VX_3DBOM_TOP_LEVEL_ONLY
@ VX_3DBOM_TOP_LEVEL_ONLY
Select this item to display only the top-level components.
Definition: zwapi_asm_data.h:47
VX_3DBOM_PARTS_ONLY
@ VX_3DBOM_PARTS_ONLY
Select this item to display only parts.
Definition: zwapi_asm_data.h:48
VX_3DBOM_INDENTED
@ VX_3DBOM_INDENTED
Select this item and indent it by assembly level.
Definition: zwapi_asm_data.h:49
VX_3DBOM_SHAPE_ONLY
@ VX_3DBOM_SHAPE_ONLY
Select this item to display only the shapes.
Definition: zwapi_asm_data.h:50
VX_3DBOM_ALLCOMPONENTS
@ VX_3DBOM_ALLCOMPONENTS
Select this item to display all components that belong to the same level.
Definition: zwapi_asm_data.h:51
evxReorderLoc
evxReorderLoc
Reorder location.
Definition: zwapi_asm_data.h:34
VX_REORDER_LAST
@ VX_REORDER_LAST
insert the object as the last object
Definition: zwapi_asm_data.h:36
VX_REORDER_AFTER
@ VX_REORDER_AFTER
insert the object after the specified object
Definition: zwapi_asm_data.h:37
VX_REORDER_FIRST
@ VX_REORDER_FIRST
insert the object as the first object
Definition: zwapi_asm_data.h:35
svx3DBomSettingsData
struct svx3DBomSettingsData svx3DBomSettingsData
3D BOM display settings data
svx3DBomData
struct svx3DBomData svx3DBomData
3d BOM row data
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
svx3DBomData::cntCol
int cntCol
the total number of column in the table.
Definition: zwapi_asm_data.h:79
svx3DBomData::list
vxLongName ** list
table data.
Definition: zwapi_asm_data.h:80
svx3DBomData::cntRow
int cntRow
the total number of row in the table.
Definition: zwapi_asm_data.h:78
svx3DBomData
3d BOM row data
Definition: zwapi_asm_data.h:77
svx3DBomSettingsData::svxBomColumn::attrName
vxLongName attrName
The name of the column attribute that will be displayed in the 3d bom table.
Definition: zwapi_asm_data.h:64
svx3DBomSettingsData::svxBomColumn::isCheck
int isCheck
1 if set the specified property name to display, else 0
Definition: zwapi_asm_data.h:65
svx3DBomSettingsData::svxBomColumn::isTotal
int isTotal
isTotal indicates whether to select to display totals(1 or 0).default:0. Totals are usually displayed...
Definition: zwapi_asm_data.h:66
svx3DBomSettingsData::svxBomColumn
Definition: zwapi_asm_data.h:63
svx3DBomSettingsData::mode
evx3DBomLevelDispMode mode
display mode
Definition: zwapi_asm_data.h:60
svx3DBomSettingsData::countColumn
int countColumn
number of columns display
Definition: zwapi_asm_data.h:61
svx3DBomSettingsData
3D BOM display settings data
Definition: zwapi_asm_data.h:59
svxAsmGrpCompData::paths
svxEntPath * paths
the components to be grouped
Definition: zwapi_asm_data.h:98
svxAsmGrpCompData::file
vxPath file
the file which the grouped sub-assembly to be created belongs to If isPartOnly = 0,...
Definition: zwapi_asm_data.h:92
svxAsmGrpCompData::part
vxRootName part
the name of the grouped sub-assembly to be created (part[0]=0 to use default)
Definition: zwapi_asm_data.h:94
svxAsmGrpCompData::count
int count
count of paths
Definition: zwapi_asm_data.h:97
svxAsmGrpCompData::isVirtual
int isVirtual
1-the grouped sub-assembly is virtual assembly, else 0
Definition: zwapi_asm_data.h:95
svxAsmGrpCompData::isPartOnly
int isPartOnly
1-create part only, 0-create file and part(only use for Z3)
Definition: zwapi_asm_data.h:96
svxAsmGrpCompData
group as sub-assembly data
Definition: zwapi_asm_data.h:91
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
evxRenderMode
evxRenderMode
Render mode.
Definition: zwapi_asm_data.h:106
VX_RENDER_NONE
@ VX_RENDER_NONE
no render mode
Definition: zwapi_asm_data.h:107
VX_RENDER_HIDD_APPROX
@ VX_RENDER_HIDD_APPROX
hidden line
Definition: zwapi_asm_data.h:110
VX_RENDER_ANALYZE
@ VX_RENDER_ANALYZE
analyze
Definition: zwapi_asm_data.h:111
VX_RENDER_TRANSPARENT
@ VX_RENDER_TRANSPARENT
transparent
Definition: zwapi_asm_data.h:112
VX_RENDER_SHADE
@ VX_RENDER_SHADE
shaded
Definition: zwapi_asm_data.h:109
VX_RENDER_WIRE
@ VX_RENDER_WIRE
wireframe
Definition: zwapi_asm_data.h:108
svxAsmGrpCompData
struct svxAsmGrpCompData svxAsmGrpCompData
group as sub-assembly data
zwapi_cmd_assembly_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASM_OPTS_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_opts.h
cvxAsmAddToFavorites
cvxAsmDissolve
cvxAsmFavoritesEnable
cvxAsmGrpComp
cvxAsmRemoveFromFavorites
cvxAsmUpdateCompRef
cvxCompCfgIdSet
cvxCompEditPart
cvxCompEditPartByPath
cvxCompIsLightweightByPath
cvxCompLightweightSetByPath
cvxCompRegen
cvxCompSetPart
cvxCompSetRenderMode
cvxCompShift
cvxCompSuppress
cvxCompSuppressByPath
cvxCompVisSet
cvxConsDel
cvxConsEnable
cvxConsRedefine
cvxSubPartIns

◆ ZW_API_ASM_OPTS_H

#define ZW_API_ASM_OPTS_H

Definition at line 15 of file zwapi_asm_opts.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_opts.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_opts.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_ASM_OPTS_H /* this ifndef surrounds entire header */
15#define ZW_API_ASM_OPTS_H
16
17#include "zwapi_asm_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
59extern evxErrors cvxAsmDissolve(const svxEntPath* path);
60
61/******************************************************************************/
100extern evxErrors cvxAsmGrpComp(svxAsmGrpCompData* data);
101
102/******************************************************************************/
123extern evxErrors cvxAsmAddToFavorites(svxEntPath* path);
124
125/******************************************************************************/
146extern evxErrors cvxAsmRemoveFromFavorites(svxEntPath* path);
147
148/******************************************************************************/
168extern int cvxAsmFavoritesEnable(svxEntPath* path);
169
170/******************************************************************************/
186extern evxErrors cvxAsmUpdateCompRef(const char* OldRootName, const char* NewRootName);
187
188//====================================================================================================================
190//====================================================================================================================
191/******************************************************************************/
213extern evxErrors cvxCompEditPart(int idComp);
214
215/******************************************************************************/
237extern evxErrors cvxCompEditPartByPath(const svxEntPath* compPath);
238
239/******************************************************************************/
259extern evxErrors cvxCompRegen(svxEntPath* Path, int flag);
260
261/******************************************************************************/
282extern evxErrors cvxCompSetPart(int idComp, const vxLongPath File, const vxRootName Part);
283
284/******************************************************************************/
299extern evxErrors cvxCompIsLightweightByPath(const svxEntPath* compPath, int* isLightweight);
300
301/******************************************************************************/
322extern evxErrors cvxCompLightweightSetByPath(const svxEntPath* compPaths, int compCount, int load, int isRecursive);
323
324/******************************************************************************/
340extern evxErrors cvxCompSetRenderMode(svxEntPath* CompPath, evxRenderMode RenderMode);
341
342/******************************************************************************/
362extern evxErrors cvxCompShift(int idComp);
363
364/******************************************************************************/
385extern evxErrors cvxCompSuppress(int idComp, int suppress);
386
387/******************************************************************************/
410extern evxErrors cvxCompSuppressByPath(int Count, svxEntPath* CompPaths, int suppress);
411
412/******************************************************************************/
431extern evxErrors cvxCompVisSet(svxEntPath* CompPath, int Vis);
432
433/******************************************************************************/
451extern evxErrors cvxCompCfgIdSet(const svxEntPath* path, int idCfg);
452
453//====================================================================================================================
455//====================================================================================================================
456/******************************************************************************/
475extern evxErrors cvxConsRedefine(int idCons);
476
477/******************************************************************************/
497extern evxErrors cvxConsEnable(int count, int* idCons, int enable);
498
499/******************************************************************************/
518extern evxErrors cvxConsDel(int count, int* idCons);
519
520//====================================================================================================================
522//====================================================================================================================
523/******************************************************************************/
550extern evxErrors cvxSubPartIns(const vxRootName Name, int AutoRegen, int MergeDimen);
551
552/*
553*********************************************************************
554** END HEADER FILE
555*********************************************************************
556*/
557
558#ifdef __cplusplus
559 }
560#endif /* __cplusplus */
561
562#endif /* ZW_API_ASM_OPTS_H */
cvxConsRedefine
evxErrors cvxConsRedefine(int idCons)
cvxSubPartIns
evxErrors cvxSubPartIns(const vxRootName Name, int AutoRegen, int MergeDimen)
cvxAsmRemoveFromFavorites
evxErrors cvxAsmRemoveFromFavorites(svxEntPath *path)
cvxAsmDissolve
evxErrors cvxAsmDissolve(const svxEntPath *path)
cvxAsmAddToFavorites
evxErrors cvxAsmAddToFavorites(svxEntPath *path)
cvxCompLightweightSetByPath
evxErrors cvxCompLightweightSetByPath(const svxEntPath *compPaths, int compCount, int load, int isRecursive)
cvxConsDel
evxErrors cvxConsDel(int count, int *idCons)
cvxCompRegen
evxErrors cvxCompRegen(svxEntPath *Path, int flag)
cvxCompIsLightweightByPath
evxErrors cvxCompIsLightweightByPath(const svxEntPath *compPath, int *isLightweight)
cvxCompVisSet
evxErrors cvxCompVisSet(svxEntPath *CompPath, int Vis)
cvxCompSetRenderMode
evxErrors cvxCompSetRenderMode(svxEntPath *CompPath, evxRenderMode RenderMode)
cvxCompSuppressByPath
evxErrors cvxCompSuppressByPath(int Count, svxEntPath *CompPaths, int suppress)
cvxCompEditPartByPath
evxErrors cvxCompEditPartByPath(const svxEntPath *compPath)
cvxConsEnable
evxErrors cvxConsEnable(int count, int *idCons, int enable)
cvxAsmFavoritesEnable
int cvxAsmFavoritesEnable(svxEntPath *path)
cvxCompShift
evxErrors cvxCompShift(int idComp)
cvxCompSetPart
evxErrors cvxCompSetPart(int idComp, const vxLongPath File, const vxRootName Part)
cvxCompCfgIdSet
evxErrors cvxCompCfgIdSet(const svxEntPath *path, int idCfg)
cvxAsmGrpComp
evxErrors cvxAsmGrpComp(svxAsmGrpCompData *data)
cvxCompEditPart
evxErrors cvxCompEditPart(int idComp)
cvxAsmUpdateCompRef
evxErrors cvxAsmUpdateCompRef(const char *OldRootName, const char *NewRootName)
cvxCompSuppress
evxErrors cvxCompSuppress(int idComp, int suppress)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAsmGrpCompData
group as sub-assembly data
Definition: zwapi_asm_data.h:91
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
evxRenderMode
evxRenderMode
Render mode.
Definition: zwapi_asm_data.h:106
zwapi_asm_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_REUSE_LIBRARY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_asm_reuselibrary.h
cvxInstPartAsShp
cvxLibPartAdjust
cvxLibPartIns

◆ ZW_API_REUSE_LIBRARY_H

#define ZW_API_REUSE_LIBRARY_H

Definition at line 15 of file zwapi_asm_reuselibrary.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_asm_reuselibrary.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_asm_reuselibrary.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_REUSE_LIBRARY_H /* this ifndef surrounds entire header */
15#define ZW_API_REUSE_LIBRARY_H
16
17#include "zwapi_cmd_assembly_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
61extern int cvxLibPartIns(const svxCompData* Comp, const char* InstanceName,
62 const char* ValStr, int fFileType, int fInsShape, int* idComp);
63
64/******************************************************************************/
82extern evxErrors cvxInstPartAsShp(const svxCompData* Comp);
83
84/******************************************************************************/
107extern evxErrors cvxLibPartAdjust(int idComp, const vxLongPath File, const vxRootName Part, const char* ValStr, const char* InstanceName);
108
109/*
110*********************************************************************
111** END HEADER FILE
112*********************************************************************
113*/
114#ifdef __cplusplus
115 }
116#endif /* __cplusplus */
117#endif /* ZW_API_REUSE_LIBRARY_H */
cvxLibPartIns
int cvxLibPartIns(const svxCompData *Comp, const char *InstanceName, const char *ValStr, int fFileType, int fInsShape, int *idComp)
cvxInstPartAsShp
evxErrors cvxInstPartAsShp(const svxCompData *Comp)
cvxLibPartAdjust
evxErrors cvxLibPartAdjust(int idComp, const vxLongPath File, const vxRootName Part, const char *ValStr, const char *InstanceName)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCompData
component data
Definition: zwapi_cmd_assembly_data.h:34
zwapi_cmd_assembly_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_BREP_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_data.h
svxEvalSurf
svxMassProp
svxPreEdge
svxWeldAttr

◆ ZW_API_BREP_DATA_H

#define ZW_API_BREP_DATA_H

Definition at line 17 of file zwapi_brep_data.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_BREP_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_BREP_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24//====================================================================================================================
26//====================================================================================================================
31typedef struct svxPreEdge
32 {
33 svxLimit Limits;
34 int idLoop;
35 int idEdge;
36 int idNext;
37 int idGeom;
38 int EdgeDir;
39 int LoopDir;
40 } svxPreEdge;
41
46typedef struct svxMassProp
47 {
48 double Density;
49 double Area;
50 double Volume;
51 double Mass;
52 svxPoint Center;
53 svxVector Axis[3];
54 double Im[6];
55 double Ip[3];
56 double Rad[3];
57 } svxMassProp;
58
63typedef struct svxWeldAttr
64 {
65 svxAttribute spec;
66 svxAttribute description;
67 svxAttribute material;
68 svxAttribute mass;
69 svxAttribute length;
70 }svxWeldAttr;
71
76typedef struct svxEvalSurf
77 {
78 int level;
79 svxPoint pnt;
80 svxPoint normal;
81 svxPoint partial_u;
82 svxPoint partial_v;
83 svxPoint partial_uu;
84 svxPoint partial_uv;
85 svxPoint partial_vv;
86 svxPoint partial_uuu;
87 svxPoint partial_vuu;
88 svxPoint partial_uvv;
89 svxPoint partial_vvv;
90 svxPoint partial_uuuu;
91 svxPoint partial_vuuu;
92 svxPoint partial_uuvv;
93 svxPoint partial_uvvv;
94 svxPoint partial_vvvv;
95 } svxEvalSurf;
96
97#ifdef __cplusplus
98 }
99#endif /* __cplusplus */
100#endif /* ZW_API_BREP_DATA_H */
svxMassProp
struct svxMassProp svxMassProp
mass attributes
svxPreEdge
struct svxPreEdge svxPreEdge
pre-edge information
svxEvalSurf
struct svxEvalSurf svxEvalSurf
surface evaluate
svxWeldAttr
struct svxWeldAttr svxWeldAttr
weldment attribute
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxEvalSurf::partial_vvvv
svxPoint partial_vvvv
level 4 - 4th partial w.r.t v
Definition: zwapi_brep_data.h:94
svxEvalSurf::partial_uuu
svxPoint partial_uuu
level 3 - 3rd partial w.r.t u
Definition: zwapi_brep_data.h:86
svxEvalSurf::partial_uvvv
svxPoint partial_uvvv
level 4 - 4th partial w.r.t vv
Definition: zwapi_brep_data.h:93
svxEvalSurf::partial_vuu
svxPoint partial_vuu
level 3 - 3rd partial w.r.t uv
Definition: zwapi_brep_data.h:87
svxEvalSurf::partial_vvv
svxPoint partial_vvv
level 3 - 3rd partial w.r.t v
Definition: zwapi_brep_data.h:89
svxEvalSurf::partial_uu
svxPoint partial_uu
level 2 - 2nd partial w/r u
Definition: zwapi_brep_data.h:83
svxEvalSurf::partial_uuuu
svxPoint partial_uuuu
level 4 - 4th partial w.r.t u
Definition: zwapi_brep_data.h:90
svxEvalSurf::partial_uv
svxPoint partial_uv
level 2 - 2nd partial w/r uv
Definition: zwapi_brep_data.h:84
svxEvalSurf::level
int level
level of evaluation
Definition: zwapi_brep_data.h:78
svxEvalSurf::partial_vuuu
svxPoint partial_vuuu
level 4 - 4th partial w.r.t uv
Definition: zwapi_brep_data.h:91
svxEvalSurf::partial_uvv
svxPoint partial_uvv
level 3 - 3rd partial w.r.t uv
Definition: zwapi_brep_data.h:88
svxEvalSurf::partial_uuvv
svxPoint partial_uuvv
level 4 - 4th partial w.r.t uv
Definition: zwapi_brep_data.h:92
svxEvalSurf::partial_v
svxPoint partial_v
level 1 - tangential component w/r v
Definition: zwapi_brep_data.h:82
svxEvalSurf::partial_vv
svxPoint partial_vv
level 2 - 2nd partial w/r v
Definition: zwapi_brep_data.h:85
svxEvalSurf::partial_u
svxPoint partial_u
level 1 - tangential component w/r u
Definition: zwapi_brep_data.h:81
svxEvalSurf::pnt
svxPoint pnt
level 0 - x,y,z on surface
Definition: zwapi_brep_data.h:79
svxEvalSurf::normal
svxPoint normal
level 1 - unit normal vector
Definition: zwapi_brep_data.h:80
svxEvalSurf
surface evaluate
Definition: zwapi_brep_data.h:77
svxLimit
limits
Definition: zwapi_util.h:455
svxMassProp::Im
double Im[6]
Moments of inertia relative to xyz axes.
Definition: zwapi_brep_data.h:54
svxMassProp::Rad
double Rad[3]
Radii of gyration relative to principal axes.
Definition: zwapi_brep_data.h:56
svxMassProp::Area
double Area
Area (mm^2)
Definition: zwapi_brep_data.h:49
svxMassProp::Center
svxPoint Center
Centroid (i.e. Center of Gravity)
Definition: zwapi_brep_data.h:52
svxMassProp::Ip
double Ip[3]
Moments of inertia relative to principal axes.
Definition: zwapi_brep_data.h:55
svxMassProp::Volume
double Volume
Volume (mm^3)
Definition: zwapi_brep_data.h:50
svxMassProp::Density
double Density
Density (kg/m^3)
Definition: zwapi_brep_data.h:48
svxMassProp::Axis
svxVector Axis[3]
Principal axes relative to global xyz frame.
Definition: zwapi_brep_data.h:53
svxMassProp::Mass
double Mass
Mass (kg)
Definition: zwapi_brep_data.h:51
svxMassProp
mass attributes
Definition: zwapi_brep_data.h:47
svxPoint
3D point
Definition: zwapi_util.h:306
svxPreEdge::Limits
svxLimit Limits
limits of pre-edge within its parameter space
Definition: zwapi_brep_data.h:33
svxPreEdge::idGeom
int idGeom
id of uv curve geometry
Definition: zwapi_brep_data.h:37
svxPreEdge::idNext
int idNext
id of next pre-edge in loop direction
Definition: zwapi_brep_data.h:36
svxPreEdge::LoopDir
int LoopDir
direction relative to loop (1=same, -1=opposite)
Definition: zwapi_brep_data.h:39
svxPreEdge::idLoop
int idLoop
id of parent loop
Definition: zwapi_brep_data.h:34
svxPreEdge::idEdge
int idEdge
id of parent edge
Definition: zwapi_brep_data.h:35
svxPreEdge::EdgeDir
int EdgeDir
direction relative to edge (1=same, -1=opposite)
Definition: zwapi_brep_data.h:38
svxPreEdge
pre-edge information
Definition: zwapi_brep_data.h:32
svxVector
3D vector
Definition: zwapi_util.h:338
svxWeldAttr::spec
svxAttribute spec
spec
Definition: zwapi_brep_data.h:65
svxWeldAttr::description
svxAttribute description
description
Definition: zwapi_brep_data.h:66
svxWeldAttr::length
svxAttribute length
length
Definition: zwapi_brep_data.h:69
svxWeldAttr::mass
svxAttribute mass
mass
Definition: zwapi_brep_data.h:68
svxWeldAttr::material
svxAttribute material
material
Definition: zwapi_brep_data.h:67
svxWeldAttr
weldment attribute
Definition: zwapi_brep_data.h:64
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_EDGE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_edge.h
cvxPartInqEdgeCrv
cvxPartInqEdgeFaces
cvxPartInqEdgeLoop
cvxPartInqEdgeOpen
cvxPartInqEdgePreEdges
cvxPartInqEdgeShape
cvxPartInqEdgeType

◆ ZW_API_EDGE_H

#define ZW_API_EDGE_H

Definition at line 15 of file zwapi_brep_edge.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_edge.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_edge.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_EDGE_H /* this ifndef surrounds entire header */
15#define ZW_API_EDGE_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
42extern int cvxPartInqEdgeOpen(int idEdge);
43
44/******************************************************************************/
62extern evxErrors cvxPartInqEdgeType(int idEdge, evxEdgeType* EdgeType);
63
64/******************************************************************************/
84extern evxErrors cvxPartInqEdgeFaces(int idEdge, int* Count, int** Faces);
85
86/******************************************************************************/
104extern evxErrors cvxPartInqEdgePreEdges(int idEdge, int* Count, int** PreEdges);
105
106/******************************************************************************/
123extern evxErrors cvxPartInqEdgeLoop(int idFace, int idEdge, int* idLoop);
124
125/******************************************************************************/
141extern evxErrors cvxPartInqEdgeShape(int idEdge, int* idShape);
142
143/******************************************************************************/
180extern evxErrors cvxPartInqEdgeCrv(int idEdge, int idFace, svxCurve* Crv);
181
182
183/*
184*********************************************************************
185** END HEADER FILE
186*********************************************************************
187*/
188
189#ifdef __cplusplus
190 }
191#endif /* __cplusplus */
192
193#endif /* ZW_API_EDGE_H */
cvxPartInqEdgeShape
evxErrors cvxPartInqEdgeShape(int idEdge, int *idShape)
cvxPartInqEdgeLoop
evxErrors cvxPartInqEdgeLoop(int idFace, int idEdge, int *idLoop)
cvxPartInqEdgeFaces
evxErrors cvxPartInqEdgeFaces(int idEdge, int *Count, int **Faces)
cvxPartInqEdgeCrv
evxErrors cvxPartInqEdgeCrv(int idEdge, int idFace, svxCurve *Crv)
cvxPartInqEdgePreEdges
evxErrors cvxPartInqEdgePreEdges(int idEdge, int *Count, int **PreEdges)
cvxPartInqEdgeType
evxErrors cvxPartInqEdgeType(int idEdge, evxEdgeType *EdgeType)
cvxPartInqEdgeOpen
int cvxPartInqEdgeOpen(int idEdge)
evxEdgeType
evxEdgeType
type of edge
Definition: zwapi_util.h:998
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FACE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_face.h
cvxFaceEval
cvxFaceEval2
cvxFaceEvalGeom
cvxFaceGetArea
cvxFaceGetMaxCurvature
cvxFaceInqBend
cvxFaceInqExtreme
cvxFaceIsConcave
cvxFaceIsPlanar
cvxFaceParam
cvxFacePntLoc
cvxFacePntProj
cvxFaceRadialIntegrity
cvxFaceRadius
cvxPartDelFaceTx
cvxPartInqFaceAt
cvxPartInqFaceBox
cvxPartInqFaceCrvs
cvxPartInqFaceEdges
cvxPartInqFaceFillet
cvxPartInqFaceGeom
cvxPartInqFaceLoops
cvxPartInqFaceSh
cvxPartInqFaceShape
cvxPartInqFaceSrf
cvxPartInqFaceSrfPrim
cvxPartInqFaceTx
cvxPartInqFaceTxFile
cvxPartInqFaceTxFileByLongPath
cvxPartSetFaceAt
cvxPartSetFaceAtInit
cvxPartSetFaceTx
cvxSrfPrimFree
cvxSurfaceFree

◆ ZW_API_FACE_H

#define ZW_API_FACE_H

Definition at line 15 of file zwapi_brep_face.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_face.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_face.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_FACE_H /* this ifndef surrounds entire header */
15#define ZW_API_FACE_H
16
17#include "zwapi_brep_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxPartInqFaceAt(int idFace, svxFaceAt* At);
46
47/******************************************************************************/
103extern evxErrors cvxPartInqFaceSh(int idFace, svxShaderAt* Sh);
104
105/******************************************************************************/
131extern evxErrors cvxPartInqFaceTx(int idFace, svxTextureAt* Tx);
132
133/******************************************************************************/
150extern evxErrors cvxFaceGetArea(const int faceId, const double tolerance, double* area);
151
152/******************************************************************************/
177extern evxErrors cvxFaceGetMaxCurvature(const int faceId, const svxPoint2 uvPoint,
178 svxPoint* point, svxPoint* normal, svxPoint* direction, double* minCurvature,
179 double* maxCurvature, double* curvature, svxPoint* curvatureDirection, svxPoint* curvatureCenter);
180
181/******************************************************************************/
199extern evxErrors cvxPartSetFaceAtInit(svxFaceAt* data);
200
201/******************************************************************************/
225extern evxErrors cvxPartSetFaceAt(int Count, int* idFaces, const svxFaceAt* At);
226
227/******************************************************************************/
250extern evxErrors cvxPartSetFaceTx(int idFace, const svxTextureAt* Tx);
251
252/******************************************************************************/
272extern evxErrors cvxPartDelFaceTx(int Count, const int* idFaces);
273
274//====================================================================================================================
276//====================================================================================================================
277/******************************************************************************/
312extern evxErrors cvxPartInqFaceTxFile(int idFace, vxPath Path);
313
314/******************************************************************************/
355extern evxErrors cvxPartInqFaceTxFileByLongPath(int idFace, char* Path, int sizePath);
356
357/******************************************************************************/
376extern evxErrors cvxPartInqFaceBox(int idFace, svxBndBox* Box);
377
378/******************************************************************************/
404extern evxErrors cvxPartInqFaceCrvs(int idFace, int* Count, svxCurve** TrimCurves);
405
406/******************************************************************************/
426extern evxErrors cvxPartInqFaceEdges(int idFace, int* Count, int** Edges);
427
428/******************************************************************************/
452extern evxErrors cvxPartInqFaceLoops(int idFace, int Inner, int* Count, int** Loops);
453
454/******************************************************************************/
476extern evxErrors cvxPartInqFaceSrf(int idFace, svxSurface* Srf);
477
478/******************************************************************************/
489extern void cvxSurfaceFree(svxSurface* Srf);
490
491/******************************************************************************/
515extern evxErrors cvxPartInqFaceSrfPrim(int idFace, svxSrfPrim* SrfPrim);
516
517/******************************************************************************/
528extern void cvxSrfPrimFree(svxSrfPrim* SrfPrim);
529
530/******************************************************************************/
546extern evxErrors cvxPartInqFaceShape(int idFace, int* idShape);
547
548/******************************************************************************/
564extern evxErrors cvxPartInqFaceGeom(int idFace, int* idGeom);
565
566/******************************************************************************/
586extern evxErrors cvxPartInqFaceFillet(int idFace, int* isFilletFace);
587
588/******************************************************************************/
608extern evxErrors cvxFaceRadius(int idFace, double* Radius);
609
610/******************************************************************************/
634extern evxErrors cvxFaceInqBend(int idFace, int* bendFlag, double* bendRad, double* neutralRad,
635 double* angle, double* thick, double* kFactor, double* flatTol);
636
637/******************************************************************************/
653extern int cvxFaceIsConcave(int idFace);
654
655/******************************************************************************/
672extern int cvxFaceIsPlanar(int idFace);
673
674/******************************************************************************/
700extern evxErrors cvxFaceInqExtreme(int idFace, const svxVector* Dir, int* Count, int** idEnts, svxPoint* Point);
701
702//====================================================================================================================
704//====================================================================================================================
705/******************************************************************************/
738extern evxErrors cvxFaceEval(int idFace, double U, double V, svxPoint* Point, svxVector* Normal);
739
740/******************************************************************************/
775extern evxErrors cvxFaceEval2(int idFace, double U, double V, svxPoint* Point, svxVector* Normal, svxVector* Utan, svxVector* Vtan);
776
777/******************************************************************************/
798extern evxErrors cvxFaceParam(int idFace, svxLimit* U, svxLimit* V);
799
800/******************************************************************************/
820extern evxErrors cvxFacePntLoc(int idFace, double U, double V, evxPntLocation* Loc);
821
822/******************************************************************************/
843extern evxErrors cvxFacePntProj(int idFace, svxPoint* Point, double* U, double* V);
844
845/******************************************************************************/
866extern evxErrors cvxFaceRadialIntegrity(int idFace, double* URatio, double* VRatio);
867
868/******************************************************************************/
909extern evxErrors cvxFaceEvalGeom(int idFace, double U, double V, int Level, svxEvalSurf* EvalSrf);
910
911/*
912*********************************************************************
913** END HEADER FILE
914*********************************************************************
915*/
916
917#ifdef __cplusplus
918 }
919#endif /* __cplusplus */
920
921#endif /* ZW_API_FACE_H */
cvxFacePntProj
evxErrors cvxFacePntProj(int idFace, svxPoint *Point, double *U, double *V)
cvxFaceGetArea
evxErrors cvxFaceGetArea(const int faceId, const double tolerance, double *area)
cvxFaceEvalGeom
evxErrors cvxFaceEvalGeom(int idFace, double U, double V, int Level, svxEvalSurf *EvalSrf)
cvxPartInqFaceBox
evxErrors cvxPartInqFaceBox(int idFace, svxBndBox *Box)
cvxPartInqFaceFillet
evxErrors cvxPartInqFaceFillet(int idFace, int *isFilletFace)
cvxPartInqFaceEdges
evxErrors cvxPartInqFaceEdges(int idFace, int *Count, int **Edges)
cvxPartInqFaceGeom
evxErrors cvxPartInqFaceGeom(int idFace, int *idGeom)
cvxPartInqFaceCrvs
evxErrors cvxPartInqFaceCrvs(int idFace, int *Count, svxCurve **TrimCurves)
cvxFaceParam
evxErrors cvxFaceParam(int idFace, svxLimit *U, svxLimit *V)
cvxFaceRadius
evxErrors cvxFaceRadius(int idFace, double *Radius)
cvxFaceGetMaxCurvature
evxErrors cvxFaceGetMaxCurvature(const int faceId, const svxPoint2 uvPoint, svxPoint *point, svxPoint *normal, svxPoint *direction, double *minCurvature, double *maxCurvature, double *curvature, svxPoint *curvatureDirection, svxPoint *curvatureCenter)
cvxPartSetFaceTx
evxErrors cvxPartSetFaceTx(int idFace, const svxTextureAt *Tx)
cvxSrfPrimFree
void cvxSrfPrimFree(svxSrfPrim *SrfPrim)
cvxPartInqFaceSrf
evxErrors cvxPartInqFaceSrf(int idFace, svxSurface *Srf)
cvxPartInqFaceTxFileByLongPath
evxErrors cvxPartInqFaceTxFileByLongPath(int idFace, char *Path, int sizePath)
cvxPartInqFaceSh
evxErrors cvxPartInqFaceSh(int idFace, svxShaderAt *Sh)
cvxPartInqFaceTx
evxErrors cvxPartInqFaceTx(int idFace, svxTextureAt *Tx)
cvxFacePntLoc
evxErrors cvxFacePntLoc(int idFace, double U, double V, evxPntLocation *Loc)
cvxSurfaceFree
void cvxSurfaceFree(svxSurface *Srf)
cvxFaceInqBend
evxErrors cvxFaceInqBend(int idFace, int *bendFlag, double *bendRad, double *neutralRad, double *angle, double *thick, double *kFactor, double *flatTol)
cvxPartDelFaceTx
evxErrors cvxPartDelFaceTx(int Count, const int *idFaces)
cvxPartInqFaceShape
evxErrors cvxPartInqFaceShape(int idFace, int *idShape)
cvxFaceEval
evxErrors cvxFaceEval(int idFace, double U, double V, svxPoint *Point, svxVector *Normal)
cvxFaceRadialIntegrity
evxErrors cvxFaceRadialIntegrity(int idFace, double *URatio, double *VRatio)
cvxFaceInqExtreme
evxErrors cvxFaceInqExtreme(int idFace, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)
cvxFaceIsPlanar
int cvxFaceIsPlanar(int idFace)
cvxPartInqFaceAt
evxErrors cvxPartInqFaceAt(int idFace, svxFaceAt *At)
cvxPartInqFaceTxFile
evxErrors cvxPartInqFaceTxFile(int idFace, vxPath Path)
cvxPartSetFaceAt
evxErrors cvxPartSetFaceAt(int Count, int *idFaces, const svxFaceAt *At)
cvxPartSetFaceAtInit
evxErrors cvxPartSetFaceAtInit(svxFaceAt *data)
cvxPartInqFaceLoops
evxErrors cvxPartInqFaceLoops(int idFace, int Inner, int *Count, int **Loops)
cvxFaceEval2
evxErrors cvxFaceEval2(int idFace, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
cvxFaceIsConcave
int cvxFaceIsConcave(int idFace)
cvxPartInqFaceSrfPrim
evxErrors cvxPartInqFaceSrfPrim(int idFace, svxSrfPrim *SrfPrim)
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxPntLocation
evxPntLocation
point location
Definition: zwapi_util.h:603
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEvalSurf
surface evaluate
Definition: zwapi_brep_data.h:77
svxFaceAt
face display attributes
Definition: zwapi_util.h:1140
svxLimit
limits
Definition: zwapi_util.h:455
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxShaderAt
shader attribute
Definition: zwapi_util.h:1880
svxSrfPrim
3D NURB surface data
Definition: zwapi_util.h:1858
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
svxTextureAt
texture attribute
Definition: zwapi_util.h:1266
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_LOOP_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_loop.h
cvxPartInqLoopEdges
cvxPartInqLoopFace
cvxPartInqLoopInner
cvxPartInqLoopPreEdges

◆ ZW_API_LOOP_H

#define ZW_API_LOOP_H

Definition at line 15 of file zwapi_brep_loop.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_loop.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_loop.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_LOOP_H /* this ifndef surrounds entire header */
15#define ZW_API_LOOP_H
16
17
18#ifdef __cplusplus
19extern "C" {
20#endif /* __cplusplus */
21
22//====================================================================================================================
24//====================================================================================================================
25/******************************************************************************/
49extern evxErrors cvxPartInqLoopEdges(int idLoop, int* Count, int** Edges);
50
51/******************************************************************************/
67extern evxErrors cvxPartInqLoopFace(int idLoop, int* idFace);
68
69/******************************************************************************/
94extern evxErrors cvxPartInqLoopPreEdges(int idLoop, int* Count, int** PreEdges);
95
96/******************************************************************************/
115extern evxErrors cvxPartInqLoopInner(int idLoop, int* isInner);
116
117/*
118*********************************************************************
119** END HEADER FILE
120*********************************************************************
121*/
122#ifdef __cplusplus
123 }
124#endif /* __cplusplus */
125
126#endif /* ZW_API_LOOP_H */
cvxPartInqLoopFace
evxErrors cvxPartInqLoopFace(int idLoop, int *idFace)
cvxPartInqLoopPreEdges
evxErrors cvxPartInqLoopPreEdges(int idLoop, int *Count, int **PreEdges)
cvxPartInqLoopInner
evxErrors cvxPartInqLoopInner(int idLoop, int *isInner)
cvxPartInqLoopEdges
evxErrors cvxPartInqLoopEdges(int idLoop, int *Count, int **Edges)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PREEDGE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_preedge.h
cvxPartInqPreEdgeInfo
cvxPartInqPreEdgeStartPnt

◆ ZW_API_PREEDGE_H

#define ZW_API_PREEDGE_H

Definition at line 15 of file zwapi_brep_preedge.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_preedge.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_preedge.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PREEDGE_H /* this ifndef surrounds entire header */
15#define ZW_API_PREEDGE_H
16
17#include "zwapi_brep_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxPartInqPreEdgeInfo(int idPreEdge, svxPreEdge* PreEdge);
44
45/******************************************************************************/
63extern evxErrors cvxPartInqPreEdgeStartPnt(int idPreEdge, int* idEdge, svxPoint2* StartPnt);
64
65/**********************************************************************
66*! -pre-edge Evaluate- : zwapi_math_nurbscurve.h
67* extern evxErrors cvxPreEdgeEval(const int idPreEdge, const double t, const int level, svxEvalCurv* eval);
68**********************************************************************/
69
70/*
71*********************************************************************
72** END HEADER FILE
73*********************************************************************
74*/
75
76#ifdef __cplusplus
77 }
78#endif /* __cplusplus */
79
80#endif /* ZW_API_H */
cvxPartInqPreEdgeStartPnt
evxErrors cvxPartInqPreEdgeStartPnt(int idPreEdge, int *idEdge, svxPoint2 *StartPnt)
cvxPartInqPreEdgeInfo
evxErrors cvxPartInqPreEdgeInfo(int idPreEdge, svxPreEdge *PreEdge)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPreEdge
pre-edge information
Definition: zwapi_brep_data.h:32
zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SAHPE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_shape.h
cvxInstShpGetMatrix
cvxPartInqEntShape
cvxPartInqShapeBox
cvxPartInqShapeComp
cvxPartInqShapeEdges
cvxPartInqShapeExtreme
cvxPartInqShapeFaces
cvxPartInqShapeFtrs
cvxPartInqShapeMass
cvxPartInqShapeOpen
cvxPartInqShapes
cvxPartShapeStructGet
cvxShellAtGet
cvxShellAtItemGet
cvxShellAtItemSet

◆ ZW_API_SAHPE_H

#define ZW_API_SAHPE_H

Definition at line 15 of file zwapi_brep_shape.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_shape.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_shape.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SHAPE_H /* this ifndef surrounds entire header */
15#define ZW_API_SAHPE_H
16
17#include "zwapi_brep_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxShellAtGet(int idShape, svxPartAttribute* At);
44
45/******************************************************************************/
70extern evxErrors cvxShellAtItemGet(int idShape, evxAtItemId itemId, svxAttribute* At);
71
72/******************************************************************************/
97extern evxErrors cvxShellAtItemSet(int idShape, evxAtItemId itemId, svxAttribute* At);
98
99/******************************************************************************/
116extern evxErrors cvxPartInqShapeOpen(int idShape, int* isOpen);
117
118/******************************************************************************/
147extern evxErrors cvxPartInqShapeBox(int idShape, svxMatrix* Mat, svxBndBox* Box);
148
149/******************************************************************************/
171extern evxErrors cvxPartInqShapeMass(int idShape, double Density, svxMassProp* Prop);
172
173/******************************************************************************/
193extern evxErrors cvxPartShapeStructGet(int idShape, svxWeldAttr* at);
194
195//====================================================================================================================
197//====================================================================================================================
198/******************************************************************************/
218extern evxErrors cvxPartInqShapes(const vxLongPath File, const vxRootName Part, int* Count, int** Shapes);
219
220/******************************************************************************/
239extern evxErrors cvxPartInqShapeComp(int idShape, int* idComp);
240
241/******************************************************************************/
261extern evxErrors cvxPartInqShapeEdges(int idShape, int* Count, int** Edges);
262
263/******************************************************************************/
283extern evxErrors cvxPartInqShapeFaces(int idShape, int* Count, int** Faces);
284
285/******************************************************************************/
314extern evxErrors cvxPartInqShapeFtrs(int idShape, int Option, int* Count, int** Features);
315
316/******************************************************************************/
345extern evxErrors cvxPartInqShapeExtreme(int idShape, const svxVector* Dir, int* Count, int** idEnts, svxPoint* Point);
346
347/******************************************************************************/
367extern evxErrors cvxInstShpGetMatrix(int idShape, svxMatrix* Matrix);
368
369//====================================================================================================================
371//====================================================================================================================
372/******************************************************************************/
392extern evxErrors cvxPartInqEntShape(int idEntity, int* idShape);
393
394/*
395*********************************************************************
396** END HEADER FILE
397*********************************************************************
398*/
399
400#ifdef __cplusplus
401 }
402#endif /* __cplusplus */
403
404#endif /* ZW_API_H */
cvxShellAtGet
evxErrors cvxShellAtGet(int idShape, svxPartAttribute *At)
cvxPartInqShapeMass
evxErrors cvxPartInqShapeMass(int idShape, double Density, svxMassProp *Prop)
cvxShellAtItemGet
evxErrors cvxShellAtItemGet(int idShape, evxAtItemId itemId, svxAttribute *At)
cvxPartInqEntShape
evxErrors cvxPartInqEntShape(int idEntity, int *idShape)
cvxPartShapeStructGet
evxErrors cvxPartShapeStructGet(int idShape, svxWeldAttr *at)
cvxPartInqShapes
evxErrors cvxPartInqShapes(const vxLongPath File, const vxRootName Part, int *Count, int **Shapes)
cvxPartInqShapeFtrs
evxErrors cvxPartInqShapeFtrs(int idShape, int Option, int *Count, int **Features)
cvxPartInqShapeEdges
evxErrors cvxPartInqShapeEdges(int idShape, int *Count, int **Edges)
cvxInstShpGetMatrix
evxErrors cvxInstShpGetMatrix(int idShape, svxMatrix *Matrix)
cvxPartInqShapeComp
evxErrors cvxPartInqShapeComp(int idShape, int *idComp)
cvxPartInqShapeFaces
evxErrors cvxPartInqShapeFaces(int idShape, int *Count, int **Faces)
cvxPartInqShapeOpen
evxErrors cvxPartInqShapeOpen(int idShape, int *isOpen)
cvxPartInqShapeExtreme
evxErrors cvxPartInqShapeExtreme(int idShape, const svxVector *Dir, int *Count, int **idEnts, svxPoint *Point)
cvxPartInqShapeBox
evxErrors cvxPartInqShapeBox(int idShape, svxMatrix *Mat, svxBndBox *Box)
cvxShellAtItemSet
evxErrors cvxShellAtItemSet(int idShape, evxAtItemId itemId, svxAttribute *At)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxMassProp
mass attributes
Definition: zwapi_brep_data.h:47
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPartAttribute
part attribute structure
Definition: zwapi_util.h:1386
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
svxWeldAttr
weldment attribute
Definition: zwapi_brep_data.h:64
zwapi_brep_data.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_VERTEX_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_brep_vertex.h
cvxPartInqVertexEdges

◆ ZW_API_VERTEX_H

#define ZW_API_VERTEX_H

Definition at line 15 of file zwapi_brep_vertex.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_brep_vertex.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_brep_vertex.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_VERTEX_H /* this ifndef surrounds entire header */
15#define ZW_API_VERTEX_H
16
17#ifdef __cplusplus
18extern "C" {
19#endif /* __cplusplus */
20
21//====================================================================================================================
23//====================================================================================================================
24/******************************************************************************/
46extern evxErrors cvxPartInqVertexEdges(int idEdge, int EndPnt, int* Count, int** Edges);
47
48/*
49*********************************************************************
50** END HEADER FILE
51*********************************************************************
52*/
53
54#ifdef __cplusplus
55 }
56#endif /* __cplusplus */
57
58#endif /* ZW_API_VERTEX_H */
cvxPartInqVertexEdges
evxErrors cvxPartInqVertexEdges(int idEdge, int EndPnt, int *Count, int **Edges)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_COMP_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_comp.h
cvxCmCompDelete
cvxCmCompGetAttr
cvxCmCompInqInfo
cvxCmCompInqInfoByLongPath
cvxCmCompInsert
cvxCmCompSetAttr
cvxCmPlanSkNew
evxCmCompAtrr
evxCmCompAtrr
evxCmCompClass
evxCmCompClass

◆ ZW_API_CAM_COMP_H

#define ZW_API_CAM_COMP_H

Definition at line 15 of file zwapi_cm_comp.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_comp.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_comp.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_COMP_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_COMP_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmCompClass
31 {
32 ZW_CAM_COMP_CLASS_PART,
33 ZW_CAM_COMP_CLASS_CLAMP,
34 ZW_CAM_COMP_CLASS_STOCK,
35 ZW_CAM_COMP_CLASS_TABLE,
36 ZW_CAM_COMP_CLASS_TOOLHOLDER,
37 ZW_CAM_COMP_CLASS_ATTACHMENT
38 }evxCmCompClass;
39
44typedef enum evxCmCompAtrr
45 {
46 ZW_CAM_COMP_ATTR_FACES,
47 ZW_CAM_COMP_ATTR_CLASS,
48 ZW_CAM_COMP_ATTR_CDCOMP
49 }evxCmCompAtrr;
50
51//====================================================================================================================
53//====================================================================================================================
54/******************************************************************************/
71extern evxErrors cvxCmCompInsert(char* fileName, char* shapeName, int* idx_CmComp);
72
73/******************************************************************************/
86extern evxErrors cvxCmCompDelete(int idx_CmComp);
87
88/******************************************************************************/
120extern evxErrors cvxCmCompGetAttr(int idx_Cmcomp, int cnt, evxCmCompAtrr* attr, svxCmAttrValue** pValue);
121
122/******************************************************************************/
143extern evxErrors cvxCmCompSetAttr(int idx_Cmcomp, int cnt, evxCmCompAtrr* attr, svxCmAttrValue* value);
144
145/******************************************************************************/
164extern evxErrors cvxCmCompInqInfo(int* compCnt, vxPath** compNames, vxPath** compPaths);
165
166/******************************************************************************/
185extern evxErrors cvxCmCompInqInfoByLongPath(int* compCnt, vxLongPath** compNames, vxLongPath** compPaths);
186
187/******************************************************************************/
209extern evxErrors cvxCmPlanSkNew(svxMatrix* Plane, int* idSketch);
210
211/*
212*********************************************************************
213** END HEADER FILE
214*********************************************************************
215*/
216#ifdef __cplusplus
217 }
218#endif /* __cplusplus */
219#endif /* ZW_API_CAM_COMP_H */
cvxCmCompGetAttr
evxErrors cvxCmCompGetAttr(int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue **pValue)
cvxCmPlanSkNew
evxErrors cvxCmPlanSkNew(svxMatrix *Plane, int *idSketch)
cvxCmCompInqInfoByLongPath
evxErrors cvxCmCompInqInfoByLongPath(int *compCnt, vxLongPath **compNames, vxLongPath **compPaths)
evxCmCompClass
evxCmCompClass
cam component class
Definition: zwapi_cm_comp.h:31
cvxCmCompInsert
evxErrors cvxCmCompInsert(char *fileName, char *shapeName, int *idx_CmComp)
cvxCmCompSetAttr
evxErrors cvxCmCompSetAttr(int idx_Cmcomp, int cnt, evxCmCompAtrr *attr, svxCmAttrValue *value)
evxCmCompAtrr
evxCmCompAtrr
cam component attribute
Definition: zwapi_cm_comp.h:45
cvxCmCompDelete
evxErrors cvxCmCompDelete(int idx_CmComp)
cvxCmCompInqInfo
evxErrors cvxCmCompInqInfo(int *compCnt, vxPath **compNames, vxPath **compPaths)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_FOLDER_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_folder.h
cvxCmFldRename
cvxCmFolderGetAttr
cvxCmFolderInqOps
cvxCmObjGetTreeId
cvxCmOpInsFolder
evxCmFolderAttr
evxCmFolderAttr

◆ ZW_API_CAM_FOLDER_H

#define ZW_API_CAM_FOLDER_H

Definition at line 15 of file zwapi_cm_folder.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_folder.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_folder.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_FOLDER_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_FOLDER_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmFolderAttr
31 {
32 CM_FOLDER_NAME,
33 CM_FOLDER_SUB
34 }evxCmFolderAttr;
35
36//====================================================================================================================
38//====================================================================================================================
39/******************************************************************************/
66extern evxErrors cvxCmFolderGetAttr(int idx_folder, int cnt, int* attr, svxCmAttrValue* value);
67
68/******************************************************************************/
84extern evxErrors cvxCmFolderInqOps(const vxLongPath folder_name, int* op_cnt, int** op_list);
85
86/******************************************************************************/
100extern evxErrors cvxCmOpInsFolder(int* idx_out);
101
102/******************************************************************************/
122extern evxErrors cvxCmObjGetTreeId(int idx_in, int* tree_id, evxCmTreeType treeType);
123
124/******************************************************************************/
140extern evxErrors cvxCmFldRename(int idx_fld, vxLongName fld_newName);
141
142
143#ifdef __cplusplus
144 }
145#endif /* __cplusplus */
146#endif /* ZW_API_CAM_FOLDER_H */
cvxCmFolderGetAttr
evxErrors cvxCmFolderGetAttr(int idx_folder, int cnt, int *attr, svxCmAttrValue *value)
cvxCmObjGetTreeId
evxErrors cvxCmObjGetTreeId(int idx_in, int *tree_id, evxCmTreeType treeType)
cvxCmFolderInqOps
evxErrors cvxCmFolderInqOps(const vxLongPath folder_name, int *op_cnt, int **op_list)
evxCmFolderAttr
evxCmFolderAttr
cam folder attribute
Definition: zwapi_cm_folder.h:31
cvxCmOpInsFolder
evxErrors cvxCmOpInsFolder(int *idx_out)
cvxCmFldRename
evxErrors cvxCmFldRename(int idx_fld, vxLongName fld_newName)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxCmTreeType
evxCmTreeType
cam tree type
Definition: zwapi_util.h:2549
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_FORM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_forms.h
cvxCmGetClearance
cvxCmGetOutputNCSet
cvxCmMsgClear
cvxCmOpsOutputNc
cvxCmOutputDelNC
cvxCmOutputDelOps
cvxCmOutputInsNC
cvxCmOutputInsOps
cvxCmOutputManhours
cvxCmOutputNC
cvxCmSetClearance
cvxCmSetOutputNCSet
cvxCmSetSAndF
evxCmOutFldType
evxCmOutFldType
evxCmOutType
evxCmOutType
svxNcSetting

◆ ZW_API_CAM_FORM_H

#define ZW_API_CAM_FORM_H

Definition at line 15 of file zwapi_cm_forms.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_forms.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_forms.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_FORM_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_FORM_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef struct svxNcSetting
31 {
32 vxName machine;
33 char filename[512];
34 vxName part_id;
35 vxName programmer;
36 vxName space;
37 vxName tool_changes;
38 vxName spd_fd;
39 vxName tool_num;
40 vxName coolant;
41 char prog_comment[256];
42 } svxNcSetting;
43
48typedef enum evxCmOutFldType
49 {
50 CM_OUTFLD_FLD,
51 CM_OUTFLD_NC
52 }evxCmOutFldType;
53
58typedef enum evxCmOutType
59 {
60 CM_OUT_CL,
61 CM_OUT_NC,
62 CM_OUT_TOOL,
63 CM_OUT_OP,
64 CM_OUT_XML,
65 CM_OUT_HTML
66 }evxCmOutType;
67
68//====================================================================================================================
70//====================================================================================================================
71/******************************************************************************/
91extern evxErrors cvxCmSetClearance(double dClearZ, double dAppZ, double dRtZ, double dAutoClear, int iMiniClr);
92
93/******************************************************************************/
114extern evxErrors cvxCmGetClearance(double* dClearZ, double* dAppZ, double* dRtZ, double* dAutoClear, int* iMiniClr);
115
116/******************************************************************************/
129extern evxErrors cvxCmSetSAndF(double FeedRough, double FeedFinish, double SpeedRough, double SpeedFinish, char* pName);
130
131/******************************************************************************/
150extern evxErrors cvxCmOutputManhours(int* idx_opedef, int cnt, double* manhours);
151
152/******************************************************************************/
170extern evxErrors cvxCmOutputInsNC(int idx_fld, int* idx_out, evxCmOutFldType fldType);
171
172/******************************************************************************/
187extern evxErrors cvxCmOutputDelNC(int idx_in, evxCmOutFldType fldType);
188
189/******************************************************************************/
206extern evxErrors cvxCmGetOutputNCSet(int idx_nc, svxNcSetting* ncSet);
207
208/******************************************************************************/
232extern evxErrors cvxCmSetOutputNCSet(int idx_nc, svxNcSetting* ncSet);
233
234/******************************************************************************/
250extern evxErrors cvxCmOutputInsOps(int idx_nc, int cnt, int* idx_op);
251
252/******************************************************************************/
268extern evxErrors cvxCmOutputDelOps(int idx_nc, int cnt, int* idx_op);
269
270/******************************************************************************/
291extern evxErrors cvxCmOutputNC(int idx_nc, evxCmOutType outType);
292
293/******************************************************************************/
312extern evxErrors cvxCmOpsOutputNc(int op_cnt, int* idx_opList, int* idx_nc);
313
314/******************************************************************************/
325extern evxErrors cvxCmMsgClear();
326
327
328#ifdef __cplusplus
329 }
330#endif /* __cplusplus */
331#endif /* ZW_API_CAM_FORM_H */
evxCmOutFldType
evxCmOutFldType
cam output folder type
Definition: zwapi_cm_forms.h:49
evxCmOutType
evxCmOutType
cam output type
Definition: zwapi_cm_forms.h:59
cvxCmOutputInsNC
evxErrors cvxCmOutputInsNC(int idx_fld, int *idx_out, evxCmOutFldType fldType)
cvxCmOutputDelOps
evxErrors cvxCmOutputDelOps(int idx_nc, int cnt, int *idx_op)
cvxCmMsgClear
evxErrors cvxCmMsgClear()
cvxCmOutputInsOps
evxErrors cvxCmOutputInsOps(int idx_nc, int cnt, int *idx_op)
cvxCmGetOutputNCSet
evxErrors cvxCmGetOutputNCSet(int idx_nc, svxNcSetting *ncSet)
cvxCmGetClearance
evxErrors cvxCmGetClearance(double *dClearZ, double *dAppZ, double *dRtZ, double *dAutoClear, int *iMiniClr)
cvxCmSetOutputNCSet
evxErrors cvxCmSetOutputNCSet(int idx_nc, svxNcSetting *ncSet)
cvxCmOutputManhours
evxErrors cvxCmOutputManhours(int *idx_opedef, int cnt, double *manhours)
cvxCmOutputNC
evxErrors cvxCmOutputNC(int idx_nc, evxCmOutType outType)
cvxCmSetClearance
evxErrors cvxCmSetClearance(double dClearZ, double dAppZ, double dRtZ, double dAutoClear, int iMiniClr)
cvxCmOutputDelNC
evxErrors cvxCmOutputDelNC(int idx_in, evxCmOutFldType fldType)
cvxCmSetSAndF
evxErrors cvxCmSetSAndF(double FeedRough, double FeedFinish, double SpeedRough, double SpeedFinish, char *pName)
cvxCmOpsOutputNc
evxErrors cvxCmOpsOutputNc(int op_cnt, int *idx_opList, int *idx_nc)
svxNcSetting
struct svxNcSetting svxNcSetting
cam nc output setting
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxNcSetting
cam nc output setting
Definition: zwapi_cm_forms.h:31
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_FRAME_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_frame.h
cvxCmFrameDelete
cvxCmFrameGetActive
cvxCmFrameGetAttr
cvxCmFrameGetMatrix
cvxCmFrameInsert
cvxCmFrameInsert2
cvxCmFrameSetAttr
cvxCmOpAddFrame
evxCmFrameAttr
evxCmFrameAttr

◆ ZW_API_CAM_FRAME_H

#define ZW_API_CAM_FRAME_H

Definition at line 15 of file zwapi_cm_frame.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_frame.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_frame.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_FRAME_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_FRAME_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmFrameAttr
31 {
32 /* Definition Form */
33 CM_FRAME_NAME,
34 CM_FRAME_CLEAR_Z,
35 CM_FRAME_APPROACH_Z,
36 CM_FRAME_RETRACT_Z
37 }evxCmFrameAttr;
38
39//====================================================================================================================
41//====================================================================================================================
42/******************************************************************************/
64extern evxErrors cvxCmFrameInsert(vxName frame_name, svxPoint origin_point, svxPoint x_point, svxPoint y_point, int* idx_frame);
65
66/******************************************************************************/
79extern evxErrors cvxCmFrameDelete(int idx_frame);
80
81/******************************************************************************/
99extern evxErrors cvxCmFrameGetAttr(int idx_frame, evxCmFrameAttr attr, svxCmAttrValue* value);
100
101/******************************************************************************/
120extern evxErrors cvxCmFrameSetAttr(int idx_frame, evxCmFrameAttr attr, svxCmAttrValue* value);
121
122/******************************************************************************/
141extern evxErrors cvxCmFrameInsert2(const vxName frame_name, svxMatrix frame_mat, int* idx_frame);
142
143/******************************************************************************/
161extern evxErrors cvxCmOpAddFrame(int idxOp, int idxFrame);
162
163/******************************************************************************/
178extern evxErrors cvxCmFrameGetMatrix(int idxFrame, svxMatrix* frameMat);
179
180/******************************************************************************/
195extern evxErrors cvxCmFrameGetActive(int* idx_actFrame);
196
197
198#ifdef __cplusplus
199 }
200#endif /* __cplusplus */
201#endif /* ZW_API_CAM_FRAME_H */
cvxCmFrameGetAttr
evxErrors cvxCmFrameGetAttr(int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
cvxCmFrameInsert
evxErrors cvxCmFrameInsert(vxName frame_name, svxPoint origin_point, svxPoint x_point, svxPoint y_point, int *idx_frame)
cvxCmFrameGetActive
evxErrors cvxCmFrameGetActive(int *idx_actFrame)
evxCmFrameAttr
evxCmFrameAttr
cam frame attribute
Definition: zwapi_cm_frame.h:31
cvxCmFrameInsert2
evxErrors cvxCmFrameInsert2(const vxName frame_name, svxMatrix frame_mat, int *idx_frame)
cvxCmFrameDelete
evxErrors cvxCmFrameDelete(int idx_frame)
cvxCmFrameGetMatrix
evxErrors cvxCmFrameGetMatrix(int idxFrame, svxMatrix *frameMat)
cvxCmFrameSetAttr
evxErrors cvxCmFrameSetAttr(int idx_frame, evxCmFrameAttr attr, svxCmAttrValue *value)
cvxCmOpAddFrame
evxErrors cvxCmOpAddFrame(int idxOp, int idxFrame)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_FEATURE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_ftr.h
cvxCmFtrDelete
cvxCmFtrGetAttr
cvxCmFtrGetComp
cvxCmFtrInqType
cvxCmFtrInsert
cvxCmFtrInsertHole
cvxCmFtrInsertNew
cvxCmFtrInsertSK
cvxCmFtrInsertWithoutHoles
cvxCmFtrRename
cvxCmFtrSetAttr
cvxCmGetCrvId
cvxCmPlanDispSetMode
cvxCmProfSetAttr
evxCmFtrAttr
evxCmFtrAttr
evxCmFtrProfileType
evxCmFtrProfileType
evxCmFtrType
evxCmFtrType
evxCmProfileCuvAttr
evxCmProfileCuvAttr
evxCmProfileTolLoc
evxCmProfileTolLoc

◆ ZW_API_CAM_FEATURE_H

#define ZW_API_CAM_FEATURE_H

Definition at line 15 of file zwapi_cm_ftr.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_ftr.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_ftr.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_FEATURE_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_FEATURE_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmFtrType
31 {
32 ZW_CAM_FEATURE_SOLID = 1,
33 ZW_CAM_FEATURE_POCKET = 2,
34 ZW_CAM_FEATURE_HOLE = 3,
35 ZW_CAM_FEATURE_SLOT = 4,
36 ZW_CAM_FEATURE_PROFILE = 5,
37 ZW_CAM_FEATURE_STEP = 6,
38 ZW_CAM_FEATURE_SURFACE = 7,
39 ZW_CAM_FEATURE_CHAMFER = 8,
40 ZW_CAM_FEATURE_CRND = 9,
41 ZW_CAM_FEATURE_FACE = 10,
42 ZW_CAM_FEATURE_BOSS = 11,
43 ZW_CAM_FEATURE_FLAT = 12
44 }evxCmFtrType;
45
50typedef enum evxCmFtrAttr
51 {
52 CM_FEATURE_TYPE
53 }evxCmFtrAttr;
54
59typedef enum evxCmFtrProfileType
60 {
61 PART,
62 CONTAIN
63 }evxCmFtrProfileType;
64
69typedef enum evxCmProfileCuvAttr
70 {
71 V_CM_PRF_OFFSET = 0,
72 V_CM_PRF_DRAFT = 1,
73 V_CM_PRF_TOOLLOC = 2,
74 }evxCmProfileCuvAttr;
75
80typedef enum evxCmProfileTolLoc
81 {
82 V_CM_PRF_ON = 0,
83 V_CM_PRF_TAN = 1,
84 V_CM_PRF_PAST = 2,
85 }evxCmProfileTolLoc;
86
87//====================================================================================================================
89//====================================================================================================================
90/******************************************************************************/
109extern evxErrors cvxCmFtrInsert(evxCmFtrType ftrType, int idx_CmComp, int cnt, int* geom, int* idx_FtrGrp);
110
111/******************************************************************************/
124extern evxErrors cvxCmFtrInsertNew(evxCmFtrType ftrType, int cnt, int* geom, double* depths, int* idx_FtrGrp);
125
126/******************************************************************************/
154extern evxErrors cvxCmFtrInsertWithoutHoles(evxCmFtrType ftrType, const vxName ftrName, int cnt, int* geom, int* idxFtrGrp);
155
156/******************************************************************************/
183extern evxErrors cvxCmFtrInsertSK(evxCmFtrType ftrType, const vxName ftrName, int idxSk, int cnt, int* geom, int* idxFtrGrp);
184
185/******************************************************************************/
203extern evxErrors cvxCmFtrGetComp(int* comp_cnt, int** idxComp);
204
205/******************************************************************************/
220extern evxErrors cvxCmGetCrvId(int* numLine, int** lstLines);
221
222/******************************************************************************/
248extern evxErrors cvxCmFtrInsertHole(const vxName ftrName, int cnt, int* geom, double* depths, int* idxFtrGrp);
249
250/******************************************************************************/
264extern evxErrors cvxCmPlanDispSetMode(evxCmPlanDispMode iMode);
265
266/******************************************************************************/
279extern evxErrors cvxCmFtrDelete(int idx_ftrgrp);
280
281/******************************************************************************/
293extern evxErrors cvxCmFtrGetAttr(int idx_ftrgrp, int cnt, evxCmFtrAttr* attr, svxCmAttrValue* value);
294
295/******************************************************************************/
314extern evxErrors cvxCmFtrSetAttr(int idx_ftrgrp, int cnt, evxCmFtrAttr* attr, svxCmAttrValue* value);
315
316/******************************************************************************/
331extern evxErrors cvxCmFtrRename(int idx_ftr, vxLongName newFtrName);
332
333/******************************************************************************/
353extern evxErrors cvxCmProfSetAttr(int prof_idx, int curve_idx, double newOffset, double newDraft, int tolloc);
354
355
356/******************************************************************************/
371extern evxErrors cvxCmFtrInqType(int idx_Ftr, evxCmFtrType* ftrType);
372
373
374#ifdef __cplusplus
375 }
376#endif /* __cplusplus */
377#endif /* ZW_API_CAM_FEATURE_H */
cvxCmFtrRename
evxErrors cvxCmFtrRename(int idx_ftr, vxLongName newFtrName)
cvxCmFtrInqType
evxErrors cvxCmFtrInqType(int idx_Ftr, evxCmFtrType *ftrType)
cvxCmFtrDelete
evxErrors cvxCmFtrDelete(int idx_ftrgrp)
cvxCmFtrInsert
evxErrors cvxCmFtrInsert(evxCmFtrType ftrType, int idx_CmComp, int cnt, int *geom, int *idx_FtrGrp)
cvxCmFtrGetComp
evxErrors cvxCmFtrGetComp(int *comp_cnt, int **idxComp)
evxCmProfileCuvAttr
evxCmProfileCuvAttr
cam profile feature curve attribute
Definition: zwapi_cm_ftr.h:70
V_CM_PRF_OFFSET
@ V_CM_PRF_OFFSET
curve's offset
Definition: zwapi_cm_ftr.h:71
V_CM_PRF_TOOLLOC
@ V_CM_PRF_TOOLLOC
curve's tool location
Definition: zwapi_cm_ftr.h:73
V_CM_PRF_DRAFT
@ V_CM_PRF_DRAFT
curve's draft
Definition: zwapi_cm_ftr.h:72
evxCmFtrAttr
evxCmFtrAttr
cam feature attribute
Definition: zwapi_cm_ftr.h:51
evxCmFtrType
evxCmFtrType
cam feature type
Definition: zwapi_cm_ftr.h:31
ZW_CAM_FEATURE_PROFILE
@ ZW_CAM_FEATURE_PROFILE
profile feature
Definition: zwapi_cm_ftr.h:36
ZW_CAM_FEATURE_POCKET
@ ZW_CAM_FEATURE_POCKET
pocket feature
Definition: zwapi_cm_ftr.h:33
ZW_CAM_FEATURE_CHAMFER
@ ZW_CAM_FEATURE_CHAMFER
chamfer feature
Definition: zwapi_cm_ftr.h:39
ZW_CAM_FEATURE_FACE
@ ZW_CAM_FEATURE_FACE
face feature
Definition: zwapi_cm_ftr.h:41
ZW_CAM_FEATURE_HOLE
@ ZW_CAM_FEATURE_HOLE
hole feature
Definition: zwapi_cm_ftr.h:34
ZW_CAM_FEATURE_FLAT
@ ZW_CAM_FEATURE_FLAT
flat region feature
Definition: zwapi_cm_ftr.h:43
ZW_CAM_FEATURE_STEP
@ ZW_CAM_FEATURE_STEP
step feature
Definition: zwapi_cm_ftr.h:37
ZW_CAM_FEATURE_SLOT
@ ZW_CAM_FEATURE_SLOT
slot feature
Definition: zwapi_cm_ftr.h:35
ZW_CAM_FEATURE_CRND
@ ZW_CAM_FEATURE_CRND
cround feature
Definition: zwapi_cm_ftr.h:40
ZW_CAM_FEATURE_BOSS
@ ZW_CAM_FEATURE_BOSS
boss feature
Definition: zwapi_cm_ftr.h:42
ZW_CAM_FEATURE_SURFACE
@ ZW_CAM_FEATURE_SURFACE
surface feature
Definition: zwapi_cm_ftr.h:38
ZW_CAM_FEATURE_SOLID
@ ZW_CAM_FEATURE_SOLID
solid feature
Definition: zwapi_cm_ftr.h:32
cvxCmFtrInsertNew
evxErrors cvxCmFtrInsertNew(evxCmFtrType ftrType, int cnt, int *geom, double *depths, int *idx_FtrGrp)
evxCmProfileTolLoc
evxCmProfileTolLoc
cam profile feature tool location type
Definition: zwapi_cm_ftr.h:81
V_CM_PRF_ON
@ V_CM_PRF_ON
tool is on curve
Definition: zwapi_cm_ftr.h:82
V_CM_PRF_TAN
@ V_CM_PRF_TAN
tool is tangent curve
Definition: zwapi_cm_ftr.h:83
V_CM_PRF_PAST
@ V_CM_PRF_PAST
tool is past curve
Definition: zwapi_cm_ftr.h:84
cvxCmGetCrvId
evxErrors cvxCmGetCrvId(int *numLine, int **lstLines)
evxCmFtrProfileType
evxCmFtrProfileType
cam profile feature type
Definition: zwapi_cm_ftr.h:60
cvxCmPlanDispSetMode
evxErrors cvxCmPlanDispSetMode(evxCmPlanDispMode iMode)
cvxCmFtrInsertHole
evxErrors cvxCmFtrInsertHole(const vxName ftrName, int cnt, int *geom, double *depths, int *idxFtrGrp)
cvxCmFtrSetAttr
evxErrors cvxCmFtrSetAttr(int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
cvxCmProfSetAttr
evxErrors cvxCmProfSetAttr(int prof_idx, int curve_idx, double newOffset, double newDraft, int tolloc)
cvxCmFtrInsertWithoutHoles
evxErrors cvxCmFtrInsertWithoutHoles(evxCmFtrType ftrType, const vxName ftrName, int cnt, int *geom, int *idxFtrGrp)
cvxCmFtrGetAttr
evxErrors cvxCmFtrGetAttr(int idx_ftrgrp, int cnt, evxCmFtrAttr *attr, svxCmAttrValue *value)
cvxCmFtrInsertSK
evxErrors cvxCmFtrInsertSK(evxCmFtrType ftrType, const vxName ftrName, int idxSk, int cnt, int *geom, int *idxFtrGrp)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxCmPlanDispMode
evxCmPlanDispMode
cam plan display mode
Definition: zwapi_util.h:2525
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:32 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_MACH_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_machine.h
cvxCmMachineActive
cvxCmMachineDelete
cvxCmMachineGetAttr
cvxCmMachineInsert
cvxCmMachineSetAttr
cvxCmToolChangerDelete
cvxCmToolChangerInsert
evxCmMachAttr
evxCmMachAttr
evxCmMachClass
evxCmMachClass
evxCmMachCutCompenation
evxCmMachCutCompenation
evxCmMachSubType
evxCmMachSubType
evxCmMachType
evxCmMachType

◆ ZW_API_CAM_MACH_H

#define ZW_API_CAM_MACH_H

Definition at line 15 of file zwapi_cm_machine.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_machine.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_machine.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_MACH_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_MACH_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmMachClass
31 {
32 TWO_AXIS_MC,
33 THREE_AXIS_MC
34 }evxCmMachClass;
35
40typedef enum evxCmMachType
41 {
42 CM_MACH_TYPE_VERTICAL,
43 CM_MACH_TYPE_HORIZNTAL
44 }evxCmMachType;
45
50typedef enum evxCmMachSubType
51 {
52 CM_MACH_SUBTYPE_ROTATING_HEAD,
53 CM_MACH_SUBTYPE_ROTATING_TABLE
54 }evxCmMachSubType;
55
60typedef enum evxCmMachCutCompenation
61 {
62 CM_MACH_CUT_COMPENSATION_NONE,
63 CM_MACH_CUT_COMPENSATION_LENGTH,
64 CM_MACH_CUT_COMPENSATION_CENTER
65 }evxCmMachCutCompenation;
66
71typedef enum evxCmMachAttr
72 {
73 /* Definition Form */
74 CM_MACH_NAME,
75 CM_MACH_CLASS,
76 CM_MACH_TYPE,
77 CM_MACH_SUBTYPE,
78 CM_MACH_POST_CONFIGURATION,
79 CM_MACH_CUT_COMPENSATION,
80 /* Others */
81 }evxCmMachAttr;
82
83//====================================================================================================================
85//====================================================================================================================
86/******************************************************************************/
114extern evxErrors cvxCmMachineInsert(evxCmMachClass machine_class, evxCmMachType machine_type, evxCmMachSubType sub_type, int* idx_machine);
115
116/******************************************************************************/
131extern evxErrors cvxCmMachineActive(int idx_machine);
132
133/******************************************************************************/
146extern evxErrors cvxCmMachineDelete(int idx_machine);
147
148/******************************************************************************/
166extern evxErrors cvxCmMachineGetAttr(int idx_machine, evxCmMachAttr attr, svxCmAttrValue* value);
167
168/******************************************************************************/
197extern evxErrors cvxCmMachineSetAttr(int idx_machine, evxCmMachAttr attr, svxCmAttrValue* value);
198
199/******************************************************************************/
214extern evxErrors cvxCmToolChangerInsert(int idx_toolchanger, int Location, int Diameter, int Height);
215
216/******************************************************************************/
226extern evxErrors cvxCmToolChangerDelete(int idx_toolchanger);
227
228
229#ifdef __cplusplus
230 }
231#endif /* __cplusplus */
232#endif /* ZW_API_CAM_MACH_H */
cvxCmMachineInsert
evxErrors cvxCmMachineInsert(evxCmMachClass machine_class, evxCmMachType machine_type, evxCmMachSubType sub_type, int *idx_machine)
evxCmMachSubType
evxCmMachSubType
cam machine sub type
Definition: zwapi_cm_machine.h:51
cvxCmMachineActive
evxErrors cvxCmMachineActive(int idx_machine)
cvxCmMachineDelete
evxErrors cvxCmMachineDelete(int idx_machine)
cvxCmToolChangerDelete
evxErrors cvxCmToolChangerDelete(int idx_toolchanger)
cvxCmMachineSetAttr
evxErrors cvxCmMachineSetAttr(int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxCmMachAttr
evxCmMachAttr
cam machine attribute
Definition: zwapi_cm_machine.h:72
cvxCmMachineGetAttr
evxErrors cvxCmMachineGetAttr(int idx_machine, evxCmMachAttr attr, svxCmAttrValue *value)
evxCmMachClass
evxCmMachClass
cam machine class
Definition: zwapi_cm_machine.h:31
evxCmMachType
evxCmMachType
cam machine type
Definition: zwapi_cm_machine.h:41
evxCmMachCutCompenation
evxCmMachCutCompenation
cam machine cut type
Definition: zwapi_cm_machine.h:61
cvxCmToolChangerInsert
evxErrors cvxCmToolChangerInsert(int idx_toolchanger, int Location, int Diameter, int Height)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_OPERATION_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_op.h
cvxCmOpAddComp
cvxCmOpAddFtr
cvxCmOpAddTool
cvxCmOpCalTPath
cvxCmOpDelete
cvxCmOpDrag
cvxCmOpDuplicate
cvxCmOpGetAttr
cvxCmOpGetAttr2
cvxCmOpGetIdxFromName
cvxCmOpInqClass
cvxCmOpInqTypeS
cvxCmOpInsert
cvxCmOpRemoveComp
cvxCmOpRemoveFtr
cvxCmOpRemoveTool
cvxCmOpRename
cvxCmOpSetAttr
cvxCmOpSetAttr2
cvxCmOpSetAttrAsCfg
cvxCmOpSetBasicAttr
cvxCmOpSetClass
cvxCmOpSetSpeed
cvxCmSetOpPoint
cvxCmSetOpPoints
evxCm2XOpAttr
evxCm2XOpAttr
evxCmOpClass
evxCmOpClass
evxCmOpType
evxCmOpType
evxCmQmOpAttr
evxCmQmOpAttr

◆ ZW_API_CAM_OPERATION_H

#define ZW_API_CAM_OPERATION_H

Definition at line 15 of file zwapi_cm_op.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_op.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_op.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_OPERATION_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_OPERATION_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmOpType
31 {
32 /* Drill:0-19*/
33 ZW_CAM_OPERATION_CENTER = 0,
34 ZW_CAM_OPERATION_DRILL,
35 ZW_CAM_OPERATION_PECK,
36 ZW_CAM_OPERATION_CHIP,
37 ZW_CAM_OPERATION_REAM,
38 ZW_CAM_OPERATION_BORE,
39 ZW_CAM_OPERATION_FINEBORE,
40 ZW_CAM_OPERATION_COUNTERBORE,
41 ZW_CAM_OPERATION_COUNTERSINK,
42 ZW_CAM_OPERATION_TAP,
43 /* 2X:20-34*/
44 ZW_CAM_OPERATION_PROFILECUT = 20,
45 ZW_CAM_OPERATION_SPIRAL,
46 ZW_CAM_OPERATION_ZIGZAG,
47 ZW_CAM_OPERATION_BOX,
48 ZW_CAM_OPERATION_CONTOUR,
49 ZW_CAM_OPERATION_CHAMFER,
50 ZW_CAM_OPERATION_COURNER_ROUND,
51 ZW_CAM_OPERATION_HELICAL,
52 ZW_CAM_OPERATION_RAMP,
53 ZW_CAM_OPERATION_TOPFACE_CUT,
54 ZW_CAM_OPERATION_NESTING,
55 ZW_CAM_OPERATION_INTER_PATH_MOVE,
56 ZW_CAM_OPERATION_THREADMILL,
57 /* Turning:35-49*/
58 ZW_CAM_OPERATION_DRILL_TURNING = 35,
59 ZW_CAM_OPERATION_FACING,
60 ZW_CAM_OPERATION_ROUGH,
61 ZW_CAM_OPERATION_FINISH,
62 ZW_CAM_OPERATION_GROOVE,
63 ZW_CAM_OPERATION_THREADING,
64 ZW_CAM_OPERATION_PARTOFF,
65 /* 3X:50-79*/
66 ZW_CAM_OPERATION_SPIRAL_ROUGH = 50,
67 ZW_CAM_OPERATION_ZIGZAG_ROUGH,
68 ZW_CAM_OPERATION_BOX_ROUGH,
69 ZW_CAM_OPERATION_CONTOUR_ROUGH,
70 ZW_CAM_OPERATION_SPIRAL_CAST = 55,
71 ZW_CAM_OPERATION_ZIGZAG_CAST,
72 ZW_CAM_OPERATION_BOX_CAST,
73 ZW_CAM_OPERATION_CONTOUR_CAST,
74 ZW_CAM_OPERATION_SPIRAL_FINISH = 60,
75 ZW_CAM_OPERATION_ZIGZAG_FINISH,
76 ZW_CAM_OPERATION_BOX_FINISH,
77 ZW_CAM_OPERATION_CONTOUR_FINISH,
78 ZW_CAM_OPERATION_PROFILE_FINISH,
79 ZW_CAM_OPERATION_SIDE,
80 ZW_CAM_OPERATION_PEELING,
81 ZW_CAM_OPERATION_ISO,
82 ZW_CAM_OPERATION_3XISO,
83 ZW_CAM_OPERATION_MAP,
84 ZW_CAM_OPERATION_REST,
85 ZW_CAM_OPERATION_PENCIL_TRACE,
86 ZW_CAM_OPERATION_SCALLOP_REMOVAL,
87 ZW_CAM_OPERATION_SURFACE_ENGRAVING,
88 /* QM:80-109*/
89 ZW_CAM_OPERATION_SMOOTHFLOW = 80,
90 ZW_CAM_OPERATION_OFFSET2D,
91 ZW_CAM_OPERATION_LACE_ROUGH,
92 ZW_CAM_OPERATION_PLUNGE,
93 ZW_CAM_OPERATION_PRE_DRILL,
94 ZW_CAM_OPERATION_OFFSET3D,
95 ZW_CAM_OPERATION_LACE_FINISH,
96 ZW_CAM_OPERATION_ANGLE_LIMITING_FINISHING,
97 ZW_CAM_OPERATION_DRIVE_CURVE,
98 ZW_CAM_OPERATION_ZLEVEL,
99 ZW_CAM_OPERATION_PENCIL,
100 ZW_CAM_OPERATION_FLOW_3D,
101 ZW_CAM_OPERATION_BULGE,
102 ZW_CAM_OPERATION_ENGRAVE_2D,
103 ZW_CAM_OPERATION_SMOOTHFLOW_HSM = 95,
104 ZW_CAM_OPERATION_OFFSET2D_HSM,
105 ZW_CAM_OPERATION_LACE_HSM,
106 ZW_CAM_OPERATION_FLOW_HSM,
107 ZW_CAM_OPERATION_CORNERFINISH,
108 ZW_CAM_OPERATION_FLATFINISH,
109 /* 5X:110-129*/
110 ZW_CAM_OPERATION_PLANE = 110,
111 ZW_CAM_OPERATION_SWARF,
112 ZW_CAM_OPERATION_DRIVECURVE_5X,
113 ZW_CAM_OPERATION_INTERACTIVE,
114 ZW_CAM_OPERATION_FLOW_5X,
115 ZW_CAM_OPERATION_SIDE_5X,
116 ZW_CAM_OPERATION_GUIDE_SURFACE_ISO
117 }evxCmOpType;
118
123typedef enum evxCm2XOpAttr
124 {
125 ZW_CAM_2X_OPERATION_ATTR_NAME = 300,
126 ZW_CAM_2X_OPERATION_ATTR_FRAME,
127 ZW_CAM_2X_OPERATION_ATTR_PATH_TOL,
128 }evxCm2XOpAttr;
129
134typedef enum evxCmQmOpAttr
135 {
136 ZW_CAM_QM_OPERATION_ATTR_NAME = 400,
137 ZW_CAM_QM_OPERATION_ATTR_FRAME,
138 ZW_CAM_QM_OPERATION_ATTR_PATH_TOL,
139 ZW_CAM_QM_OPERATION_ATTR_SURF_THICK,
140 ZW_CAM_QM_OPERATION_ATTR_Z_SURF_THICK,
141 ZW_CAM_QM_OPERATION_ATTR_TOOL,
142 ZW_CAM_QM_OPERATION_ATTR_MINTOOLHEIGHT,
143 ZW_CAM_QM_OPERATION_ATTR_CLASS,
144 ZW_CAM_QM_OPERATION_ATTR_LIMIT_TOPZ,
145 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOMZ,
146 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE,
147 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_ZDISPLACEMENT,
148 ZW_CAM_QM_OPERATION_ATTR_LIMIT_BOTTOM_CURVE_OFFSET
149 }evxCmQmOpAttr;
150
155typedef enum evxCmOpClass
156 {
157 CM_OP_ROUGH = 0,
158 CM_OP_FINISH = 1,
159 }evxCmOpClass;
160
161//====================================================================================================================
163//====================================================================================================================
164/******************************************************************************/
181extern evxErrors cvxCmOpInsert(evxCmOpType opType, int* idx_Op);
182
183/******************************************************************************/
196extern evxErrors cvxCmOpDelete(int idx_Op);
197
198/******************************************************************************/
214extern evxErrors cvxCmOpDuplicate(int idx_Op, int* cpyOp);
215
216/******************************************************************************/
230extern evxErrors cvxCmOpAddComp(int idx_Op, int idx_CmComp);
231
232/******************************************************************************/
246extern evxErrors cvxCmOpRemoveComp(int idx_Op, int idx_CmComp);
247
248/******************************************************************************/
264extern evxErrors cvxCmOpAddFtr(int idx_Op, int idx_FtrGrp);
265
266/******************************************************************************/
280extern evxErrors cvxCmOpRemoveFtr(int idx_Op, int idx_ftrgrp);
281
282/******************************************************************************/
295extern evxErrors cvxCmOpCalTPath(int idx_Op);
296
297/******************************************************************************/
314extern evxErrors cvxCmOpAddTool(int idx_Op, int idx_Tool);
315
316/******************************************************************************/
329extern evxErrors cvxCmOpRemoveTool(int idx_Op);
330
331/******************************************************************************/
401extern evxErrors cvxCmOpGetAttr(int idx_Op, int cnt, int* attr, svxCmAttrValue* value);
402
403/******************************************************************************/
430extern evxErrors cvxCmOpSetAttr(int idx_Op, int cnt, int* attr, svxCmAttrValue* value);
431
432/******************************************************************************/
447extern evxErrors cvxCmOpSetAttrAsCfg(int idx_Op, const vxLongPath cfg_location);
448
449/******************************************************************************/
462extern evxErrors cvxCmOpCalTPath(int idx_Op);
463
464/******************************************************************************/
475extern evxErrors cvxCmOpSetSpeed(int idx_op, vxName spdfdName);
476
477/******************************************************************************/
496extern evxErrors cvxCmOpSetAttr2(int idx_op, int field, int item, const char* value);
497
498/******************************************************************************/
515extern evxErrors cvxCmOpGetAttr2(int idx_op, int field, int item, int* is_on, char* value);
516
517/******************************************************************************/
534extern evxErrors cvxCmOpGetIdxFromName(vxLongName op_name, int* op_index);
535
536/******************************************************************************/
552extern evxErrors cvxCmSetOpPoint(int idx_op, svxPoint p0, int field);
553
554/******************************************************************************/
566extern evxErrors cvxCmSetOpPoints(int idx_op, int num, svxPoint* pts, int field);
567
568/******************************************************************************/
583extern evxErrors cvxCmOpRename(int idx_op, vxLongName op_newName);
584
585/******************************************************************************/
602extern evxErrors cvxCmOpDrag(int drag_idx, evxCmTreeType drag_type, int drop_idx, evxCmTreeType drop_type, int iPos);
603
604
605
606/******************************************************************************/
627extern evxErrors cvxCmOpSetBasicAttr(int idx_op, int field, int item, const char* value);
628
629/******************************************************************************/
644extern evxErrors cvxCmOpInqClass(int idx_Op, evxCmOpClass* opClass);
645
646/******************************************************************************/
666extern evxErrors cvxCmOpSetClass(int idx_Op, evxCmOpClass opClass);
667
668/******************************************************************************/
688extern evxErrors cvxCmOpInqTypeS(int idx_Op,char* opType, int nByte);
689
690#ifdef __cplusplus
691 }
692#endif /* __cplusplus */
693#endif /* ZW_API_CAM_OPERATION_H */
cvxCmOpSetClass
evxErrors cvxCmOpSetClass(int idx_Op, evxCmOpClass opClass)
cvxCmOpDelete
evxErrors cvxCmOpDelete(int idx_Op)
evxCm2XOpAttr
evxCm2XOpAttr
cam mill2 operation attribute
Definition: zwapi_cm_op.h:124
cvxCmOpAddFtr
evxErrors cvxCmOpAddFtr(int idx_Op, int idx_FtrGrp)
cvxCmOpInqClass
evxErrors cvxCmOpInqClass(int idx_Op, evxCmOpClass *opClass)
cvxCmOpCalTPath
evxErrors cvxCmOpCalTPath(int idx_Op)
cvxCmSetOpPoints
evxErrors cvxCmSetOpPoints(int idx_op, int num, svxPoint *pts, int field)
evxCmOpType
evxCmOpType
cam operation type
Definition: zwapi_cm_op.h:31
evxCmQmOpAttr
evxCmQmOpAttr
cam qm operation attribute
Definition: zwapi_cm_op.h:135
cvxCmOpDrag
evxErrors cvxCmOpDrag(int drag_idx, evxCmTreeType drag_type, int drop_idx, evxCmTreeType drop_type, int iPos)
cvxCmSetOpPoint
evxErrors cvxCmSetOpPoint(int idx_op, svxPoint p0, int field)
cvxCmOpSetAttr2
evxErrors cvxCmOpSetAttr2(int idx_op, int field, int item, const char *value)
cvxCmOpGetAttr
evxErrors cvxCmOpGetAttr(int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
cvxCmOpSetAttr
evxErrors cvxCmOpSetAttr(int idx_Op, int cnt, int *attr, svxCmAttrValue *value)
cvxCmOpDuplicate
evxErrors cvxCmOpDuplicate(int idx_Op, int *cpyOp)
cvxCmOpSetBasicAttr
evxErrors cvxCmOpSetBasicAttr(int idx_op, int field, int item, const char *value)
cvxCmOpAddComp
evxErrors cvxCmOpAddComp(int idx_Op, int idx_CmComp)
cvxCmOpRemoveTool
evxErrors cvxCmOpRemoveTool(int idx_Op)
cvxCmOpGetIdxFromName
evxErrors cvxCmOpGetIdxFromName(vxLongName op_name, int *op_index)
cvxCmOpRename
evxErrors cvxCmOpRename(int idx_op, vxLongName op_newName)
cvxCmOpRemoveFtr
evxErrors cvxCmOpRemoveFtr(int idx_Op, int idx_ftrgrp)
evxCmOpClass
evxCmOpClass
cam operation class: finish or rough
Definition: zwapi_cm_op.h:156
CM_OP_FINISH
@ CM_OP_FINISH
finish operation
Definition: zwapi_cm_op.h:158
CM_OP_ROUGH
@ CM_OP_ROUGH
rough operation
Definition: zwapi_cm_op.h:157
cvxCmOpSetSpeed
evxErrors cvxCmOpSetSpeed(int idx_op, vxName spdfdName)
cvxCmOpInqTypeS
evxErrors cvxCmOpInqTypeS(int idx_Op, char *opType, int nByte)
cvxCmOpSetAttrAsCfg
evxErrors cvxCmOpSetAttrAsCfg(int idx_Op, const vxLongPath cfg_location)
cvxCmOpGetAttr2
evxErrors cvxCmOpGetAttr2(int idx_op, int field, int item, int *is_on, char *value)
cvxCmOpAddTool
evxErrors cvxCmOpAddTool(int idx_Op, int idx_Tool)
cvxCmOpRemoveComp
evxErrors cvxCmOpRemoveComp(int idx_Op, int idx_CmComp)
cvxCmOpInsert
evxErrors cvxCmOpInsert(evxCmOpType opType, int *idx_Op)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxCmTreeType
evxCmTreeType
cam tree type
Definition: zwapi_util.h:2549
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_QUERY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_query.h
cvxCmClashDetect
cvxCmConfigFileGetString
cvxCmGougeDetect
cvxCmInqAl
cvxCmInqIndexFromName
cvxCmInqOpName
cvxCmSolidVerify
evxCmObjType
evxCmObjType

◆ ZW_API_CAM_QUERY_H

#define ZW_API_CAM_QUERY_H

Definition at line 15 of file zwapi_cm_query.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_query.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_query.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_QUERY_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_QUERY_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmObjType
31 {
32 CM_OPERATION,
33 CM_OPFOLDER,
34 CM_TOOL,
35 CM_MACHINE,
36 CM_CMCOMP,
37 CM_FTR,
38 CM_FRAME,
39 CM_OUT
40 }evxCmObjType;
41
42//====================================================================================================================
44//====================================================================================================================
45/******************************************************************************/
71extern evxErrors cvxCmInqAl(evxCmObjType type, int* cnt, int** idx_obj);
72
73/******************************************************************************/
88extern evxErrors cvxCmSolidVerify(int* gouge);
89
90/******************************************************************************/
107extern evxErrors cvxCmClashDetect(int partIdx, int stockIdx, int cnt, int* idx_op);
108
109/******************************************************************************/
126extern evxErrors cvxCmGougeDetect(int partIdx, int stockIdx, int cnt, int* idx_op);
127
128/******************************************************************************/
150extern evxErrors cvxCmConfigFileGetString(const char* form, int field, int casesensitive,
151 char* dbstring, char* guistring, int* ifound);
152
153/******************************************************************************/
168extern evxErrors cvxCmInqOpName(int idx_op, vxLongName opName);
169
170/******************************************************************************/
197extern evxErrors cvxCmInqIndexFromName(evxCmObjType objClass, vxLongName sName, int* index);
198
199
200#ifdef __cplusplus
201 }
202#endif /* __cplusplus */
203#endif /* ZW_API_CAM_QUERY_H */
cvxCmConfigFileGetString
evxErrors cvxCmConfigFileGetString(const char *form, int field, int casesensitive, char *dbstring, char *guistring, int *ifound)
cvxCmInqIndexFromName
evxErrors cvxCmInqIndexFromName(evxCmObjType objClass, vxLongName sName, int *index)
cvxCmGougeDetect
evxErrors cvxCmGougeDetect(int partIdx, int stockIdx, int cnt, int *idx_op)
cvxCmInqOpName
evxErrors cvxCmInqOpName(int idx_op, vxLongName opName)
evxCmObjType
evxCmObjType
cam object type
Definition: zwapi_cm_query.h:31
cvxCmInqAl
evxErrors cvxCmInqAl(evxCmObjType type, int *cnt, int **idx_obj)
cvxCmClashDetect
evxErrors cvxCmClashDetect(int partIdx, int stockIdx, int cnt, int *idx_op)
cvxCmSolidVerify
evxErrors cvxCmSolidVerify(int *gouge)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CAM_TOOL_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cm_tool.h
cvxCmHolderInsertAsTemplate
cvxCmSpeedInsertAsTemplate
cvxCmToolDelete
cvxCmToolGetAttr
cvxCmToolGetData
cvxCmToolInsert
cvxCmToolInsertAsTemplate
cvxCmToolSetAttr
evxCmToolAttr
evxCmToolAttr
evxCmToolSubType
evxCmToolSubType
evxCmToolType
evxCmToolType

◆ ZW_API_CAM_TOOL_H

#define ZW_API_CAM_TOOL_H

Definition at line 15 of file zwapi_cm_tool.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cm_tool.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cm_tool.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CAM_TOOL_H /* this ifndef surrounds entire header */
15#define ZW_API_CAM_TOOL_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxCmToolType
31 {
32 CM_TOOL_TYPE_MILL,
33 CM_TOOL_TYPE_FLAME,
34 CM_TOOL_TYPE_DRILL,
35 CM_TOOL_TYPE_TAP,
36 CM_TOOL_TYPE_CENTER,
37 CM_TOOL_TYPE_CHAMFER,
38 CM_TOOL_TYPE_REAM,
39 CM_TOOL_TYPE_BORE
40 }evxCmToolType;
41
46typedef enum evxCmToolSubType
47 {
48 CM_TOOL_SUBTYPE_NULL = -1,
49 CM_TOOL_SUBTYPE_BALLNOSE,
50 CM_TOOL_SUBTYPE_BULLNOSE,
51 CM_TOOL_SUBTYPE_ENDNOSE
52 }evxCmToolSubType;
53
58typedef enum evxCmToolAttr
59 {
60 CM_TOOL_NAME = 400,
61 CM_TOOL_TYPE,
62 CM_TOOL_SUBTYPE,
63 CM_TOOL_ID,
64 CM_TOOL_LEN,
65 CM_TOOL_CUTTERDIAMETER,
66 CM_TOOL_HOLDER,
67 /* tool register data in active machine */
68 CM_TOOLCHANGER_LOCATION,
69 CM_TOOLCHANGER_DIAMETER,
70 CM_TOOLCHANGER_HEIGHT
71 }evxCmToolAttr;
72
73//====================================================================================================================
75//====================================================================================================================
76/******************************************************************************/
98extern evxErrors cvxCmToolInsert(evxCmToolType tltype, evxCmToolSubType subtype, int* idx_tool);
99
100/******************************************************************************/
122extern evxErrors cvxCmToolInsertAsTemplate(const vxLongPath template_path, const vxName file_name, const vxName library_name,const vxName tool_name, int* idx_tool);
123
124/******************************************************************************/
137extern evxErrors cvxCmToolDelete(int idx_tool);
138
139/******************************************************************************/
152extern evxErrors cvxCmToolGetAttr(int idx_tool, evxCmToolAttr attr, svxCmAttrValue* value);
153
154/******************************************************************************/
206extern evxErrors cvxCmToolSetAttr(int idx_tool, evxCmToolAttr attr, svxCmAttrValue* value);
207
208/******************************************************************************/
229extern evxErrors cvxCmHolderInsertAsTemplate(const vxLongPath template_path, const vxName file_name,
230 const vxName library_name, const vxName holder_name, int* idx_holder);
231
232/******************************************************************************/
245extern evxErrors cvxCmSpeedInsertAsTemplate(const vxLongPath template_path, const vxName file_name,
246 const vxName library_name,const vxName spdfd_name, int* idx_speed);
247
248/******************************************************************************/
272extern evxErrors cvxCmToolGetData(int idx_tool, evxCmToolAttr attr, char* value);
273
274
275#ifdef __cplusplus
276 }
277#endif /* __cplusplus */
278#endif /* ZW_API_CAM_TOOL_H */
cvxCmToolDelete
evxErrors cvxCmToolDelete(int idx_tool)
evxCmToolType
evxCmToolType
cam tool type
Definition: zwapi_cm_tool.h:31
CM_TOOL_TYPE_CHAMFER
@ CM_TOOL_TYPE_CHAMFER
chamfer
Definition: zwapi_cm_tool.h:37
CM_TOOL_TYPE_REAM
@ CM_TOOL_TYPE_REAM
ream
Definition: zwapi_cm_tool.h:38
CM_TOOL_TYPE_FLAME
@ CM_TOOL_TYPE_FLAME
flame
Definition: zwapi_cm_tool.h:33
CM_TOOL_TYPE_TAP
@ CM_TOOL_TYPE_TAP
tap
Definition: zwapi_cm_tool.h:35
CM_TOOL_TYPE_MILL
@ CM_TOOL_TYPE_MILL
mill
Definition: zwapi_cm_tool.h:32
CM_TOOL_TYPE_CENTER
@ CM_TOOL_TYPE_CENTER
center
Definition: zwapi_cm_tool.h:36
CM_TOOL_TYPE_BORE
@ CM_TOOL_TYPE_BORE
bore
Definition: zwapi_cm_tool.h:39
CM_TOOL_TYPE_DRILL
@ CM_TOOL_TYPE_DRILL
drill
Definition: zwapi_cm_tool.h:34
cvxCmToolInsertAsTemplate
evxErrors cvxCmToolInsertAsTemplate(const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName tool_name, int *idx_tool)
cvxCmHolderInsertAsTemplate
evxErrors cvxCmHolderInsertAsTemplate(const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName holder_name, int *idx_holder)
cvxCmToolGetData
evxErrors cvxCmToolGetData(int idx_tool, evxCmToolAttr attr, char *value)
evxCmToolAttr
evxCmToolAttr
cam tool attribute
Definition: zwapi_cm_tool.h:59
CM_TOOL_TYPE
@ CM_TOOL_TYPE
tool type
Definition: zwapi_cm_tool.h:61
CM_TOOL_LEN
@ CM_TOOL_LEN
tool_length
Definition: zwapi_cm_tool.h:64
CM_TOOL_NAME
@ CM_TOOL_NAME
tool name
Definition: zwapi_cm_tool.h:60
CM_TOOL_ID
@ CM_TOOL_ID
tool id
Definition: zwapi_cm_tool.h:63
CM_TOOL_CUTTERDIAMETER
@ CM_TOOL_CUTTERDIAMETER
tool diameter
Definition: zwapi_cm_tool.h:65
CM_TOOL_HOLDER
@ CM_TOOL_HOLDER
tool holder name
Definition: zwapi_cm_tool.h:66
CM_TOOL_SUBTYPE
@ CM_TOOL_SUBTYPE
tool subtype
Definition: zwapi_cm_tool.h:62
cvxCmToolGetAttr
evxErrors cvxCmToolGetAttr(int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
cvxCmToolSetAttr
evxErrors cvxCmToolSetAttr(int idx_tool, evxCmToolAttr attr, svxCmAttrValue *value)
cvxCmSpeedInsertAsTemplate
evxErrors cvxCmSpeedInsertAsTemplate(const vxLongPath template_path, const vxName file_name, const vxName library_name, const vxName spdfd_name, int *idx_speed)
evxCmToolSubType
evxCmToolSubType
cam tool sub type
Definition: zwapi_cm_tool.h:47
CM_TOOL_SUBTYPE_NULL
@ CM_TOOL_SUBTYPE_NULL
NULL.
Definition: zwapi_cm_tool.h:48
CM_TOOL_SUBTYPE_BALLNOSE
@ CM_TOOL_SUBTYPE_BALLNOSE
taperball
Definition: zwapi_cm_tool.h:49
CM_TOOL_SUBTYPE_ENDNOSE
@ CM_TOOL_SUBTYPE_ENDNOSE
end
Definition: zwapi_cm_tool.h:51
CM_TOOL_SUBTYPE_BULLNOSE
@ CM_TOOL_SUBTYPE_BULLNOSE
taperbull
Definition: zwapi_cm_tool.h:50
cvxCmToolInsert
evxErrors cvxCmToolInsert(evxCmToolType tltype, evxCmToolSubType subtype, int *idx_tool)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CMD_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd.h
cvxCmdAction
cvxCmdBuffer
cvxCmdCallback
cvxCmdChkLic
cvxCmdFunc
cvxCmdFuncUnload
cvxCmdMacro
cvxCmdMacro2
cvxCmdRegisterRcc
cvxCmdSend
cvxCmdUnRegisterRcc
cvxCmdVariable
cvxCmdVariableUnload
cvxMacroInqPath
cvxMacroInqPathByLongPath
cvxNewCommand

◆ ZW_API_CMD_H

#define ZW_API_CMD_H

Definition at line 15 of file zwapi_cmd.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_CMD_H /* this ifndef surrounds entire header */
15#define ZW_API_CMD_H
16
17#include "zwapi_cmd_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
36extern void cvxNewCommand(void);
37
38/******************************************************************************/
55extern void cvxCmdBuffer(const char* String, int Priority);
56
57/******************************************************************************/
69extern void cvxCmdSend(char* CommandString);
70
71//====================================================================================================================
73//====================================================================================================================
74/******************************************************************************/
87extern evxErrors cvxCmdChkLic(const vxName Name);
88
89/******************************************************************************/
119extern evxErrors cvxCmdAction(evxCmdAction type, svxCmdActionParam* param);
120
121//====================================================================================================================
123//====================================================================================================================
124/******************************************************************************/
176extern evxErrors cvxCmdFunc(const vxName Name, void* Function, double Code);
177
178/******************************************************************************/
208extern void cvxCmdCallback(const vxName Name, void* Function);
209
210/******************************************************************************/
227extern evxErrors cvxCmdFuncUnload(const vxName Name);
228
229/******************************************************************************/
249extern void cvxCmdVariable(vxName Name, void* Variable);
250
251/******************************************************************************/
266extern evxErrors cvxCmdVariableUnload(const vxName Name);
267
268/******************************************************************************/
283extern evxErrors cvxCmdRegisterRcc(vxName File);
284
285/******************************************************************************/
300extern evxErrors cvxCmdUnRegisterRcc(vxName File);
301
302//====================================================================================================================
304//====================================================================================================================
305/******************************************************************************/
352extern evxErrors cvxCmdMacro(char* Input, char** Output);
353
354/******************************************************************************/
371extern evxErrors cvxCmdMacro2(char* path);
372
373/******************************************************************************/
389extern evxErrors cvxMacroInqPath(vxPath path, vxPath file);
390
391
392/******************************************************************************/
415extern evxErrors cvxMacroInqPathByLongPath(char* path, int sizepath, char* file, int filesize);
416
417/*
418*********************************************************************
419** END HEADER FILE
420*********************************************************************
421*/
422
423#ifdef __cplusplus
424 }
425#endif /* __cplusplus */
426
427#endif /* ZW_API_CMD_H */
evxCmdAction
evxCmdAction
command action type
Definition: zwapi_cmd_data.h:51
cvxMacroInqPath
evxErrors cvxMacroInqPath(vxPath path, vxPath file)
cvxCmdMacro
evxErrors cvxCmdMacro(char *Input, char **Output)
cvxCmdSend
void cvxCmdSend(char *CommandString)
cvxMacroInqPathByLongPath
evxErrors cvxMacroInqPathByLongPath(char *path, int sizepath, char *file, int filesize)
cvxCmdChkLic
evxErrors cvxCmdChkLic(const vxName Name)
cvxCmdFuncUnload
evxErrors cvxCmdFuncUnload(const vxName Name)
cvxNewCommand
void cvxNewCommand(void)
cvxCmdCallback
void cvxCmdCallback(const vxName Name, void *Function)
cvxCmdVariable
void cvxCmdVariable(vxName Name, void *Variable)
cvxCmdUnRegisterRcc
evxErrors cvxCmdUnRegisterRcc(vxName File)
cvxCmdMacro2
evxErrors cvxCmdMacro2(char *path)
cvxCmdFunc
evxErrors cvxCmdFunc(const vxName Name, void *Function, double Code)
cvxCmdRegisterRcc
evxErrors cvxCmdRegisterRcc(vxName File)
cvxCmdAction
evxErrors cvxCmdAction(evxCmdAction type, svxCmdActionParam *param)
cvxCmdBuffer
void cvxCmdBuffer(const char *String, int Priority)
cvxCmdVariableUnload
evxErrors cvxCmdVariableUnload(const vxName Name)
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCmdActionParam
command action parameter
Definition: zwapi_cmd_data.h:71
zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASSEMBLY_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_assembly.h
cvxAsmChamfer
cvxAsmChamferInit
cvxAsmCut
cvxAsmCutInit
cvxAsmFillet
cvxAsmFilletInit
cvxCompAddAngularCons
cvxCompAddCamCons
cvxCompAddCoincidentCons
cvxCompAddConcentricCons
cvxCompAddDistanceCons
cvxCompAddFrameCons
cvxCompAddGearCons
cvxCompAddLinearCoupleCons
cvxCompAddLockCons
cvxCompAddMiddleCons
cvxCompAddParallelCons
cvxCompAddPathCons
cvxCompAddPerpendicularCons
cvxCompAddRackPinionCons
cvxCompAddScrewCons
cvxCompAddSlotCons
cvxCompAddSymmetryCons
cvxCompAddTangentCons
cvxCompAddUniJointCons
cvxCompClearCheck
cvxCompExtract
cvxCompIferCheck
cvxCompInclude
cvxCompIns
cvxCompIsectShpChk
cvxCompIsectShpChk2
cvxCompMerge
cvxCompMerge2
cvxCompMirror
cvxCompMirrorInit
cvxCompMove
cvxCompMoveInit
cvxCompPtn
cvxCompPtnInit
cvxPartAlign
cvxPartAnchor
cvxPartGeomExport
cvxPartGeomExportII
cvxPartIns

◆ ZW_API_ASSEMBLY_FTR_H

#define ZW_API_ASSEMBLY_FTR_H

Definition at line 15 of file zwapi_cmd_assembly.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_assembly.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_assembly.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_ASSEMBLY_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_ASSEMBLY_FTR_H
16
17#include "zwapi_cmd_assembly_data.h"
18#include "zwapi_cmd_shape_data.h"
19
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
28/******************************************************************************/
70extern int cvxCompIns(svxCompData* Comp, int* idComp);
71
72/******************************************************************************/
94extern evxErrors cvxCompInclude(const svxCompIncludeData* Comp, int* idComp);
95
96/******************************************************************************/
133extern evxErrors cvxCompMerge(evxBoolType Combine, int idComp, int* idShape);
134
135/******************************************************************************/
172extern evxErrors cvxCompMerge2(evxBoolType Combine, int idComp, int MergeDim, int MergeWire, int* idShape);
173
174/******************************************************************************/
207extern evxErrors cvxCompExtract(int idShape, svxMatrix* Frame, vxLongName Name, int NewFile, evxResponse Overwrite, int* idComp);
208
209/******************************************************************************/
230extern evxErrors cvxPartGeomExport(svxGeomExport* Data);
231
232/******************************************************************************/
253extern evxErrors cvxPartGeomExportII(svxGeomExport* Data);
254
255/******************************************************************************/
279extern evxErrors cvxPartIns(svxPartInstData* Part, int* Count, int** ShapeList);
280
281
282//====================================================================================================================
284//====================================================================================================================
285/******************************************************************************/
310extern evxErrors cvxCompAddCoincidentCons(svxEntPath* Ent1, svxPoint* Pnt1, svxEntPath* Ent2, svxPoint* Pnt2, svxConsData* ConsData, int* idCons);
311
312/******************************************************************************/
334extern evxErrors cvxCompAddTangentCons(svxEntPath* Ent1, svxEntPath* Ent2, svxConsData* ConsData, int* idCons);
335
336/******************************************************************************/
360extern evxErrors cvxCompAddConcentricCons(svxEntPath* Ent1, svxPoint* Pnt1, svxEntPath* Ent2,
361 svxPoint* Pnt2, svxConsData* ConsData, int* idCons);
362
363/******************************************************************************/
385extern evxErrors cvxCompAddParallelCons(svxEntPath* Ent1, svxEntPath* Ent2, svxConsData* ConsData, int* idCons);
386
387/******************************************************************************/
409extern evxErrors cvxCompAddPerpendicularCons(svxEntPath* Ent1, svxEntPath* Ent2, svxConsData* ConsData, int* idCons);
410
411/******************************************************************************/
433extern evxErrors cvxCompAddAngularCons(svxEntPath* Ent1, svxEntPath* Ent2, svxConsData* ConsData, int* idCons);
434
435/******************************************************************************/
457extern evxErrors cvxCompAddLockCons(svxEntPath* Comp1, svxEntPath* Comp2, svxConsData* ConsData, int* idCons);
458
459/******************************************************************************/
483extern evxErrors cvxCompAddDistanceCons(svxEntPath* Ent1, svxPoint* Pnt1, svxEntPath* Ent2,
484 svxPoint* Pnt2, svxConsData* ConsData, int* idCons);
485
486/******************************************************************************/
510extern evxErrors cvxCompAddMiddleCons(svxEntPath* BaseEnt1, svxEntPath* BaseEnt2, int nCenter,
511 svxEntPath* CenterEnts, svxConsData* ConsData, int* idCons);
512
513/******************************************************************************/
536extern evxErrors cvxCompAddSymmetryCons(svxEntPath* Plane, svxEntPath* SymEnt1, svxEntPath* SymEnt2, svxConsData* ConsData, int* idCons);
537
538/******************************************************************************/
560extern evxErrors cvxCompAddFrameCons(svxEntPath* Datum1, svxEntPath* Datum2, svxConsData* ConsData, int* idCons);
561
562
563//====================================================================================================================
565//====================================================================================================================
566/******************************************************************************/
589extern evxErrors cvxCompAddGearCons(const svxEntPath* Gear1, const svxEntPath* Gear2, const svxGearConsData* ConsData, int* idCons);
590
591/******************************************************************************/
617extern evxErrors cvxCompAddPathCons(const svxPntOnEntPath* Pnt, int nPaths, const svxEntPath* Paths, const svxPathConsData* ConsData, int* idCons);
618
619/******************************************************************************/
644extern evxErrors cvxCompAddLinearCoupleCons(const svxEntPath* Comp1, const svxEntPath* Dir1,
645 const svxEntPath* Comp2, const svxEntPath* Dir2, const svxLinearCpData* ConsData, int* idCons);
646
647/******************************************************************************/
670extern evxErrors cvxCompAddRackPinionCons(const svxEntPath* Rack, const svxEntPath* Pinion, const svxRackPinionData* ConsData, int* idCons);
671
672/******************************************************************************/
695extern evxErrors cvxCompAddScrewCons(const svxEntPath* ScrewEnt, const svxEntPath* LinearEnt, const svxScrewConsData* ConsData, int* idCons);
696
697/******************************************************************************/
721extern evxErrors cvxCompAddSlotCons(const svxEntPath* Ent, int nSlots, const svxEntPath* Slots, const svxSlotConsData* ConsData, int* idCons);
722
723/******************************************************************************/
746extern evxErrors cvxCompAddCamCons(const svxEntPath* Ent, int nCamFaces, const svxEntPath* CamFaces, int* idCons);
747
748/******************************************************************************/
773extern evxErrors cvxCompAddUniJointCons(const svxEntPath* Shaft1, const svxPntOnEntPath* HingePnt1, const svxEntPath* Shaft2, const svxPntOnEntPath* HingePnt2, const svxUniJointData* ConsData, int* idCons);
774
775//====================================================================================================================
777//====================================================================================================================
778/******************************************************************************/
794extern evxErrors cvxPartAlign(svxAlign* Align);
795
796/******************************************************************************/
814extern evxErrors cvxPartAnchor(int idEntity);
815
816//====================================================================================================================
818//====================================================================================================================
819
820/******************************************************************************/
838extern evxErrors cvxCompPtnInit(evxAsmPatternType type, svxAsmPtnData* data);
839
840/******************************************************************************/
866extern evxErrors cvxCompPtn(const svxAsmPtnData* data, int* idPattern);
867
868/******************************************************************************/
886extern evxErrors cvxCompMoveInit(evxAsmMoveType type, svxAsmMove* data);
887
888/******************************************************************************/
914extern evxErrors cvxCompMove(const svxAsmMove* data);
915
916/******************************************************************************/
934extern evxErrors cvxCompMirrorInit(evxAsmMirrorType type, svxAsmMirror* data);
935
936/******************************************************************************/
964extern evxErrors cvxCompMirror(const svxAsmMirror* data, int* idMirror);
965
966/******************************************************************************/
983extern evxErrors cvxAsmCutInit(svxAsmCut* data);
984
985/******************************************************************************/
1011extern evxErrors cvxAsmCut(const svxAsmCut* data, int* idCut);
1012
1013/******************************************************************************/
1031extern evxErrors cvxAsmFilletInit(evxChamFlltType type, svxAsmFllt* data);
1032
1033/******************************************************************************/
1061extern evxErrors cvxAsmFillet(const svxAsmFllt* data, int* idFllt);
1062
1063/******************************************************************************/
1081extern evxErrors cvxAsmChamferInit(evxAsmChmfType type, svxAsmChmf* data);
1082
1083/******************************************************************************/
1111extern evxErrors cvxAsmChamfer(const svxAsmChmf* data, int* idChmf);
1112
1113//====================================================================================================================
1115//====================================================================================================================
1116/******************************************************************************/
1135extern evxErrors cvxCompIsectShpChk(svxEntPath* BaseShpPath, svxEntPath* OpShpPath, int* fInterfer);
1136
1137/******************************************************************************/
1158extern evxErrors cvxCompIsectShpChk2(svxEntPath* BaseShpPath, svxEntPath* OpShpPath, int fClosedChk, int* fInterfer);
1159
1160/******************************************************************************/
1186extern evxErrors cvxCompIferCheck(svxEntPath* BaseComp, svxEntPath* ChkComp, int SubAsmAsWhole,
1187 int IgnoreHidden, int* IferCnt, svxIferChkResData** IferResults);
1188
1189/******************************************************************************/
1217extern evxErrors cvxCompClearCheck(int Count, svxEntPath* Comps, double Clear, int ChkCompShp, int IgnoreHidden,
1218 int ChkSubAsm, int* ClrCnt, svxClrChkData** ClrDatas);
1219
1220
1221//====================================================================================================================
1223//====================================================================================================================
1224/**********************************************************************
1225*! -Reference- : zwapi_cmd_dataexchange.h
1226* extern evxErrors cvxPartRefGeom(svxEntPath*, int Associative, int* idGeom);
1227**********************************************************************/
1228
1229/*
1230*********************************************************************
1231** END HEADER FILE
1232*********************************************************************
1233*/
1234
1235#ifdef __cplusplus
1236 }
1237#endif /* __cplusplus */
1238
1239#endif /* ZW_API_ASSEMBLY_FTR_H */
evxAsmMoveType
evxAsmMoveType
assembly move method
Definition: zwapi_cmd_assembly_data.h:455
evxResponse
evxResponse
response to user prompt
Definition: zwapi_cmd_assembly_data.h:129
evxAsmPatternType
evxAsmPatternType
assembly pattern method
Definition: zwapi_cmd_assembly_data.h:387
evxAsmChmfType
evxAsmChmfType
assembly chamfer method
Definition: zwapi_cmd_assembly_data.h:598
evxAsmMirrorType
evxAsmMirrorType
assembly mirror method
Definition: zwapi_cmd_assembly_data.h:502
cvxCompInclude
evxErrors cvxCompInclude(const svxCompIncludeData *Comp, int *idComp)
cvxCompMerge
evxErrors cvxCompMerge(evxBoolType Combine, int idComp, int *idShape)
cvxCompIns
int cvxCompIns(svxCompData *Comp, int *idComp)
cvxCompAddLockCons
evxErrors cvxCompAddLockCons(svxEntPath *Comp1, svxEntPath *Comp2, svxConsData *ConsData, int *idCons)
cvxCompAddGearCons
evxErrors cvxCompAddGearCons(const svxEntPath *Gear1, const svxEntPath *Gear2, const svxGearConsData *ConsData, int *idCons)
cvxAsmFillet
evxErrors cvxAsmFillet(const svxAsmFllt *data, int *idFllt)
cvxCompMirror
evxErrors cvxCompMirror(const svxAsmMirror *data, int *idMirror)
cvxCompAddUniJointCons
evxErrors cvxCompAddUniJointCons(const svxEntPath *Shaft1, const svxPntOnEntPath *HingePnt1, const svxEntPath *Shaft2, const svxPntOnEntPath *HingePnt2, const svxUniJointData *ConsData, int *idCons)
cvxCompAddMiddleCons
evxErrors cvxCompAddMiddleCons(svxEntPath *BaseEnt1, svxEntPath *BaseEnt2, int nCenter, svxEntPath *CenterEnts, svxConsData *ConsData, int *idCons)
cvxAsmFilletInit
evxErrors cvxAsmFilletInit(evxChamFlltType type, svxAsmFllt *data)
cvxCompAddConcentricCons
evxErrors cvxCompAddConcentricCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxCompAddTangentCons
evxErrors cvxCompAddTangentCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompPtn
evxErrors cvxCompPtn(const svxAsmPtnData *data, int *idPattern)
cvxCompIferCheck
evxErrors cvxCompIferCheck(svxEntPath *BaseComp, svxEntPath *ChkComp, int SubAsmAsWhole, int IgnoreHidden, int *IferCnt, svxIferChkResData **IferResults)
cvxCompAddLinearCoupleCons
evxErrors cvxCompAddLinearCoupleCons(const svxEntPath *Comp1, const svxEntPath *Dir1, const svxEntPath *Comp2, const svxEntPath *Dir2, const svxLinearCpData *ConsData, int *idCons)
cvxAsmCut
evxErrors cvxAsmCut(const svxAsmCut *data, int *idCut)
cvxCompAddPathCons
evxErrors cvxCompAddPathCons(const svxPntOnEntPath *Pnt, int nPaths, const svxEntPath *Paths, const svxPathConsData *ConsData, int *idCons)
cvxCompMirrorInit
evxErrors cvxCompMirrorInit(evxAsmMirrorType type, svxAsmMirror *data)
cvxPartGeomExportII
evxErrors cvxPartGeomExportII(svxGeomExport *Data)
cvxAsmChamferInit
evxErrors cvxAsmChamferInit(evxAsmChmfType type, svxAsmChmf *data)
cvxAsmCutInit
evxErrors cvxAsmCutInit(svxAsmCut *data)
cvxCompAddFrameCons
evxErrors cvxCompAddFrameCons(svxEntPath *Datum1, svxEntPath *Datum2, svxConsData *ConsData, int *idCons)
cvxCompClearCheck
evxErrors cvxCompClearCheck(int Count, svxEntPath *Comps, double Clear, int ChkCompShp, int IgnoreHidden, int ChkSubAsm, int *ClrCnt, svxClrChkData **ClrDatas)
cvxPartAnchor
evxErrors cvxPartAnchor(int idEntity)
cvxCompAddDistanceCons
evxErrors cvxCompAddDistanceCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxPartAlign
evxErrors cvxPartAlign(svxAlign *Align)
cvxCompAddCoincidentCons
evxErrors cvxCompAddCoincidentCons(svxEntPath *Ent1, svxPoint *Pnt1, svxEntPath *Ent2, svxPoint *Pnt2, svxConsData *ConsData, int *idCons)
cvxCompAddScrewCons
evxErrors cvxCompAddScrewCons(const svxEntPath *ScrewEnt, const svxEntPath *LinearEnt, const svxScrewConsData *ConsData, int *idCons)
cvxCompIsectShpChk2
evxErrors cvxCompIsectShpChk2(svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int fClosedChk, int *fInterfer)
cvxCompAddSymmetryCons
evxErrors cvxCompAddSymmetryCons(svxEntPath *Plane, svxEntPath *SymEnt1, svxEntPath *SymEnt2, svxConsData *ConsData, int *idCons)
cvxCompAddRackPinionCons
evxErrors cvxCompAddRackPinionCons(const svxEntPath *Rack, const svxEntPath *Pinion, const svxRackPinionData *ConsData, int *idCons)
cvxCompAddAngularCons
evxErrors cvxCompAddAngularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompIsectShpChk
evxErrors cvxCompIsectShpChk(svxEntPath *BaseShpPath, svxEntPath *OpShpPath, int *fInterfer)
cvxPartIns
evxErrors cvxPartIns(svxPartInstData *Part, int *Count, int **ShapeList)
cvxCompAddPerpendicularCons
evxErrors cvxCompAddPerpendicularCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompExtract
evxErrors cvxCompExtract(int idShape, svxMatrix *Frame, vxLongName Name, int NewFile, evxResponse Overwrite, int *idComp)
cvxCompMerge2
evxErrors cvxCompMerge2(evxBoolType Combine, int idComp, int MergeDim, int MergeWire, int *idShape)
cvxCompMove
evxErrors cvxCompMove(const svxAsmMove *data)
cvxCompAddCamCons
evxErrors cvxCompAddCamCons(const svxEntPath *Ent, int nCamFaces, const svxEntPath *CamFaces, int *idCons)
cvxAsmChamfer
evxErrors cvxAsmChamfer(const svxAsmChmf *data, int *idChmf)
cvxPartGeomExport
evxErrors cvxPartGeomExport(svxGeomExport *Data)
cvxCompPtnInit
evxErrors cvxCompPtnInit(evxAsmPatternType type, svxAsmPtnData *data)
cvxCompMoveInit
evxErrors cvxCompMoveInit(evxAsmMoveType type, svxAsmMove *data)
cvxCompAddParallelCons
evxErrors cvxCompAddParallelCons(svxEntPath *Ent1, svxEntPath *Ent2, svxConsData *ConsData, int *idCons)
cvxCompAddSlotCons
evxErrors cvxCompAddSlotCons(const svxEntPath *Ent, int nSlots, const svxEntPath *Slots, const svxSlotConsData *ConsData, int *idCons)
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
evxChamFlltType
evxChamFlltType
chamfer or fillet types
Definition: zwapi_cmd_shape_data.h:413
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAlign
Alignment constraint.
Definition: zwapi_cmd_assembly_data.h:174
svxAsmChmf
assembly chamfer data
Definition: zwapi_cmd_assembly_data.h:883
svxAsmCut
assembly cut data
Definition: zwapi_cmd_assembly_data.h:815
svxAsmFllt
assembly fillet data
Definition: zwapi_cmd_assembly_data.h:829
svxAsmMirror
assembly mirror data
Definition: zwapi_cmd_assembly_data.h:782
svxAsmMove
assembly move data
Definition: zwapi_cmd_assembly_data.h:716
svxAsmPtnData
assembly pattern data
Definition: zwapi_cmd_assembly_data.h:631
svxClrChkData
clearance check result data
Definition: zwapi_cmd_assembly_data.h:932
svxCompData
component data
Definition: zwapi_cmd_assembly_data.h:34
svxCompIncludeData
include component data
Definition: zwapi_cmd_assembly_data.h:72
svxConsData
custom data for assembly common constraint
Definition: zwapi_cmd_assembly_data.h:221
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxGearConsData
custom data for assembly gear constraint
Definition: zwapi_cmd_assembly_data.h:235
svxGeomExport
geometry export
Definition: zwapi_cmd_assembly_data.h:86
svxIferChkResData
Interference check result data.
Definition: zwapi_cmd_assembly_data.h:919
svxLinearCpData
custom data for assembly linear couple constraint
Definition: zwapi_cmd_assembly_data.h:300
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPartInstData
copy external part data
Definition: zwapi_cmd_assembly_data.h:107
svxPathConsData
custom data for assembly path constraint
Definition: zwapi_cmd_assembly_data.h:279
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxRackPinionData
custom data for assembly rack and pinion constraint
Definition: zwapi_cmd_assembly_data.h:312
svxScrewConsData
custom data for assembly screw constraint
Definition: zwapi_cmd_assembly_data.h:323
svxSlotConsData
custom data for assembly slot constraint
Definition: zwapi_cmd_assembly_data.h:347
svxUniJointData
custom data for assembly universal joint constraint
Definition: zwapi_cmd_assembly_data.h:359
zwapi_cmd_assembly_data.h
zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ASSEMBLY_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_assembly_data.h
evxAlignInterference
evxAlignInterference
evxAlignType
evxAlignType
evxAsmChmfBase
evxAsmChmfBase
evxAsmChmfFace
evxAsmChmfFace
evxAsmChmfType
evxAsmChmfType
evxAsmFlltArc
evxAsmFlltArc
evxAsmFlltBase
evxAsmFlltBase
evxAsmFlltFace
evxAsmFlltFace
evxAsmFlltLoop
evxAsmFlltLoop
evxAsmMirrorCategory
evxAsmMirrorCategory
evxAsmMirrorCenter
evxAsmMirrorCenter
evxAsmMirrorSymm
evxAsmMirrorSymm
evxAsmMirrorType
evxAsmMirrorType
evxAsmMoveFrame
evxAsmMoveFrame
evxAsmMoveType
evxAsmMoveType
evxAsmMoveXOrnt
evxAsmMoveXOrnt
evxAsmMoveZSpine
evxAsmMoveZSpine
evxAsmPatternType
evxAsmPatternType
evxAsmPtnAlg
evxAsmPtnAlg
evxAsmPtnBnd
evxAsmPtnBnd
evxAsmPtnCrv
evxAsmPtnCrv
evxAsmPtnDrv
evxAsmPtnDrv
evxAsmPtnStagger
evxAsmPtnStagger
evxConsState
evxConsState
evxConsType
evxConsType
evxPathConsType
evxPathConsType
evxPitchYawType
evxPitchYawType
evxResponse
evxResponse
evxRollCtrlType
evxRollCtrlType
evxSlotConsType
evxSlotConsType
svxAlign
svxAsmChmf
svxAsmCut
svxAsmFllt
svxAsmMirror
svxAsmMove
svxAsmPtnData
svxClrChkData
svxCompData
svxCompIncludeData
svxConsData
svxGearConsData
svxGeomExport
svxIferChkResData
svxLinearCpData
svxPartInstData
svxPathConsData
svxRackPinionData
svxScrewConsData
svxSlotConsData
svxUniJointData

◆ ZW_API_ASSEMBLY_FTR_DATA_H

#define ZW_API_ASSEMBLY_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_assembly_data.h.
Generated at Sun Apr 23 2023 16:41:36 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_assembly_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_assembly_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_ASSEMBLY_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_ASSEMBLY_FTR_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_shape_data.h"
21
22#ifdef __cplusplus
23extern "C" {
24#endif /* __cplusplus */
25
26//====================================================================================================================
28//====================================================================================================================
33typedef struct svxCompData
34 {
35 vxLongPath Dir;
38 vxLongPath File;
39 vxRootName Part;
40 vxPath Comp;
43 svxMatrix Frame;
44 int Anchor;
45 int AutoRegen;
46 int AutoDelete;
47 int Copy;
48 vxLongName CopyName;
51 int Overwrite;
55 vxLongPath DestFile;
59 int Align;
60 svxData AlignData;
63 int CopyPart;
64 vxName CfgName;
65 } svxCompData;
66
71typedef struct svxCompIncludeData
72 {
73 vxLongPath Dir;
75 vxLongPath File;
76 vxRootName Part;
77 vxName CfgName;
78 vxName LayName;
79 } svxCompIncludeData;
80
85typedef struct svxGeomExport
86 {
87 int numEnts;
88 int* idEnts;
89 vxLongPath File;
90 vxRootName Part;
91 svxMatrix Frame;
92 int Option;
97 int AddComponent;
98 int NoExportOp;
99 int Unblank;
100 } svxGeomExport;
101
106typedef struct svxPartInstData
107 {
108 vxLongPath Dir;
111 vxLongPath File;
112 vxRootName Part;
113 svxMatrix Frame;
116 int CopyWire;
117 int CopyDim;
118 int Option;
122 }svxPartInstData;
123
128typedef enum evxResponse
129 {
130 VX_CANCEL = -1,
131 VX_NO = 0,
132 VX_YES = 1,
133 VX_YES_ALL = 2
134 } evxResponse;
135
136//====================================================================================================================
138//====================================================================================================================
143typedef enum evxAlignType
144 {
145 VX_ALIGN_COINCIDENT = 0,
146 VX_ALIGN_TANGENT = 1,
147 VX_ALIGN_CONCENTRIC = 2,
148 VX_ALIGN_PARALLEL = 3,
149 VX_ALIGN_PERPENDICULAR = 4,
150 VX_ALIGN_ANGLE = 5
151 } evxAlignType;
152
157typedef enum evxAlignInterference
158 {
159 VX_INTERFERENCE_NONE = 0,
160 VX_INTERFERENCE_HIGHLIGHT = 1,
163 VX_INTERFERENCE_STOP_AT = 2,
166 VX_INTERFERENCE_ADD_ALIGN = 3
167 } evxAlignInterference;
168
173typedef struct svxAlign
174 {
175 svxData Entity1;
176 svxData Entity2;
180 evxAlignType Type;
181 double Offset;
182 double Angle;
183 int isOpposite;
184 int ShowExistingAlign;
185 evxAlignInterference Interference;
186 } svxAlign;
187
192typedef enum evxConsType
193 {
194 VX_NONE = 0x00000L,
195 VX_CONCENTRIC = 0x00001L,
196 VX_COINCIDENT = 0x00002L,
197 VX_TANGENT = 0x00004L,
198 VX_PARALLEL = 0x00008L,
199 VX_PERPENDICULAR = 0x00010L,
200 VX_AT_DISTANCE = 0x00040L,
201 VX_AT_ANGLE_FULL = 0x00080L,
202 VX_GEAR = 0x00100L,
203 VX_SYMMETRIC = 0x00200L,
204 VX_ADV_LOCKED = 0x00400L,
205 VX_ADV_MIDDLE = 0x00800L,
206 VX_ADV_FRAME = 0x01000L,
207 VX_ADV_PATH = 0x02000L,
208 VX_MC_LINEAR_COUPLER = 0x04000L,
209 VX_MC_RACK_PINION = 0x08000L,
210 VX_MC_SCREW = 0x10000L,
211 VX_MC_SLOT = 0x2000000L,
212 VX_MC_CAM = 0x4000000L,
213 VX_MC_UNIV_JOINT = 0x00104L,
214 } evxConsType;
215
220typedef struct svxConsData
221 {
222 int useRange;
223 double value;
224 svxLimit range;
225 int sameDir;
226 int posOnly;
227 int lockRotation;
228 } svxConsData;
229
234typedef struct svxGearConsData
235 {
236 double angle;
237 int ratioType;
238 double ratio;
239 double teeth[2];
240 int flip;
241 } svxGearConsData;
242
247typedef enum evxPathConsType
248 {
249 VX_PATH_CONS_FREE = 0,
250 VX_PATH_CONS_DISTANCE = 1,
251 VX_PATH_CONS_PERCENT = 2,
252 } evxPathConsType;
253
258typedef enum evxPitchYawType
259 {
260 VX_PITCH_YAW_FREE = 0,
261 VX_PITCH_YAW_FOLLOW_PATH = 1,
262 } evxPitchYawType;
263
268typedef enum evxRollCtrlType
269 {
270 VX_ROLL_CTRL_FREE = 0,
271 VX_ROLL_CTRL_UP_VEC = 1,
272 } evxRollCtrlType;
273
278typedef struct svxPathConsData
279 {
280 evxPathConsType pathConsType;
281 double distance;
282 double percent;
283 int flipDim;
285 evxPitchYawType pitchYawType;
286 evxAxisType axisToTangent;
287 int flipTangentDir;
289 evxRollCtrlType rollCtrlType;
290 svxEntPath upVector;
291 evxAxisType axisToAlign;
292 int flipAlignDir;
293 } svxPathConsData;
294
299typedef struct svxLinearCpData
300 {
301 int ratioType;
302 double ratio;
303 double distance[2];
304 int flip;
305 } svxLinearCpData;
306
311typedef struct svxRackPinionData
312 {
313 int transType;
314 double value;
315 int flip;
316 } svxRackPinionData;
317
322typedef struct svxScrewConsData
323 {
324 int transType;
325 double value;
326 int flip;
327 int faceDir;
328 } svxScrewConsData;
329
334typedef enum evxSlotConsType
335 {
336 VX_SLOT_CONS_FREE = 0,
337 VX_SLOT_CONS_CENTER = 1,
338 VX_SLOT_CONS_DISTANCE = 2,
339 VX_SLOT_CONS_PERCENT = 3,
340 } evxSlotConsType;
341
346typedef struct svxSlotConsData
347 {
348 evxSlotConsType slotConsType;
349 double distance;
350 double percent;
351 int flip;
352 } svxSlotConsData;
353
358typedef struct svxUniJointData
359 {
360 int jointConsType;
361 int flip;
362 } svxUniJointData;
363
368typedef enum evxConsState
369 {
370 VX_UNKNOWN,
371 VX_UN_CONSTRAINED,
372 VX_UNDER_CONSTRAINED,
373 VX_WELL_CONSTRAINED,
374 VX_FIXED,
375 VX_OVER_CONSTRAINED,
376 } evxConsState;
377
378//====================================================================================================================
380//====================================================================================================================
381
386typedef enum evxAsmPatternType
387 {
388 VX_ASM_PTN_LINEAR,
389 VX_ASM_PTN_CIRCULAR,
390 VX_ASM_PTN_POINT,
391 VX_ASM_PTN_PATTERN,
392 VX_ASM_PTN_CRV,
393 VX_ASM_PTN_FACE,
394 } evxAsmPatternType;
395
400typedef enum evxAsmPtnStagger
401 {
402 VX_ASM_PTN_NO_STAGGER,
403 VX_ASM_PTN_STAGGER,
404 } evxAsmPtnStagger;
405
410typedef enum evxAsmPtnDrv
411 {
412 VX_ASM_PTN_DRV_NONE,
413 VX_ASM_PTN_DRV_SPACING,
414 VX_ASM_PTN_DRV_NUM,
415 } evxAsmPtnDrv;
416
421typedef enum evxAsmPtnAlg
422 {
423 VX_ASM_PTN_ALG_BASE,
424 VX_ASM_PTN_ALG_PTN,
425 } evxAsmPtnAlg;
426
431typedef enum evxAsmPtnCrv
432 {
433 VX_ASM_PTN_CRV1,
434 VX_ASM_PTN_CRV2_TOG,
435 VX_ASM_PTN_CRV2_ACROSS,
436 VX_ASM_PTN_CRV3,
437 } evxAsmPtnCrv;
438
443typedef enum evxAsmPtnBnd
444 {
445 VX_ASM_PTN_BND_AUTO,
446 VX_ASM_PTN_BND_PALCE,
447 VX_ASM_PTN_BND_MOVE,
448 } evxAsmPtnBnd;
449
454typedef enum evxAsmMoveType
455 {
456 VX_ASM_MOVE_PNT = 1,
457 VX_ASM_MOVE_ALONG_DIR,
458 VX_ASM_MOVE_ALIGN,
459 VX_ASM_MOVE_SWEEP,
460 VX_ASM_MOVE_AROUND_DIR,
461 VX_ASM_MOVE_DYNAMIC,
462 } evxAsmMoveType;
463
468typedef enum evxAsmMoveFrame
469 {
470 VX_ASM_MOVE_FRAME_NTR,
471 VX_ASM_MOVE_FRAME_PATH,
472 VX_ASM_MOVE_FRAME_SLC,
473 } evxAsmMoveFrame;
474
479typedef enum evxAsmMoveZSpine
480 {
481 VX_ASM_MOVE_Z_NTR,
482 VX_ASM_MOVE_Z_SPINE,
483 VX_ASM_MOVE_Z_PARALLEL,
484 } evxAsmMoveZSpine;
485
490typedef enum evxAsmMoveXOrnt
491 {
492 VX_ASM_MOVE_X_NTR,
493 VX_ASM_MOVE_X_GUIDE,
494 VX_ASM_MOVE_X_AXIS,
495 } evxAsmMoveXOrnt;
496
501typedef enum evxAsmMirrorType
502 {
503 VX_ASM_MIRROR_COPY,
504 VX_ASM_MIRROR_DUP,
505 } evxAsmMirrorType;
506
511typedef enum evxAsmMirrorSymm
512 {
513 VX_ASM_MIRROR_SYMM_XZ,
514 VX_ASM_MIRROR_SYMM_YZ,
515 VX_ASM_MIRROR_SYMM_XY,
516 VX_ASM_MIRROR_SYMM_C,
517 VX_ASM_MIRROR_SYMM_XCZC,
518 VX_ASM_MIRROR_SYMM_YCZC,
519 VX_ASM_MIRROR_SYMM_XCYC,
520 VX_ASM_MIRROR_SYMM_NONE,
521 } evxAsmMirrorSymm;
522
528typedef enum evxAsmMirrorCenter
529 {
530 VX_ASM_MIRROR_CTR_BOX,
531 VX_ASM_MIRROR_CTR_MASS,
532 VX_ASM_MIRROR_CTR_FRAME,
533 } evxAsmMirrorCenter;
534
539typedef enum evxAsmMirrorCategory
540 {
541 VX_ASM_MIRROR_CAT_COPY,
542 VX_ASM_MIRROR_CAT_DUP,
543 VX_ASM_MIRROR_CAT_DEL,
544 } evxAsmMirrorCategory;
545
550typedef enum evxAsmFlltArc
551 {
552 VX_ASM_FLLT_ARC_CIR,
553 VX_ASM_FLLT_ARC_CONIC,
554 } evxAsmFlltArc;
555
560typedef enum evxAsmFlltBase
561 {
562 VX_ASM_FLLT_BASE_NO,
563 VX_ASM_FLLT_BASE_DIV,
564 VX_ASM_FLLT_BASE_TRIM,
565 VX_ASM_FLLT_BASE_SEW,
566 } evxAsmFlltBase;
567
572typedef enum evxAsmFlltFace
573 {
574 VX_ASM_FLLT_FACE_MAX,
575 VX_ASM_FLLT_FACE_MIN,
576 VX_ASM_FLLT_FACE_MATCH,
577 } evxAsmFlltFace;
578
583typedef enum evxAsmFlltLoop
584 {
585 VX_ASM_FLLT_LOOP_IN,
586 VX_ASM_FLLT_LOOP_OUT,
587 VX_ASM_FLLT_LOOP_SHARE,
588 VX_ASM_FLLT_LOOP_BOUND,
589 VX_ASM_FLLT_LOOP_ALL,
590 VX_ASM_FLLT_LOOP_SELECT,
591 } evxAsmFlltLoop;
592
597typedef enum evxAsmChmfType
598 {
599 VX_ASM_CHMF_EDGE,
600 VX_ASM_CHMF_VERTEX = 2,
601 } evxAsmChmfType;
602
607typedef enum evxAsmChmfBase
608 {
609 VX_ASM_CHMF_BASE_NO,
610 VX_ASM_CHMF_BASE_DIV,
611 VX_ASM_CHMF_BASE_TRIM,
612 VX_ASM_CHMF_BASE_SEW,
613 } evxAsmChmfBase;
614
619typedef enum evxAsmChmfFace
620 {
621 VX_ASM_CHMF_FACE_MAX,
622 VX_ASM_CHMF_FACE_MIN,
623 VX_ASM_CHMF_FACE_MATCH,
624 } evxAsmChmfFace;
625
630typedef struct svxAsmPtnData
631 {
632 evxAsmPatternType type;
633 int Count;
634 int* idEnts;
635 int useDir;
636 int num[2];
637 int insComp;
638 int ihrCons;
639 int atParent;
640 union svxAsmPtn
641 {
642 struct svxAsmLinear
643 {
644 svxVector dir[2];
645 double spacing[2];
646 int seedOnly;
647 evxAsmPtnStagger stagger;
648 }linear;
649 struct svxAsmCircular
650 {
651 svxVector dir;
652 double spacing;
653 double angle;
654 evxAsmPtnDrv derive;
655 double minimum;
656 evxAsmPtnStagger stagger;
657 evxAsmPtnAlg alignment;
658 }circular;
659 struct svxAsmPntToPnt
660 {
661 svxPntOnEnt basePnt;
662 int cnt;
663 svxPntOnEnt* toPnt;
664 }point;
665 struct svxAsmPattern
666 {
667 svxEntPath ptnFtrPath;
668 }pattern;
669 struct svxAsmAtCrv
670 {
671 evxAsmPtnCrv crvOption;
672 int numBnd;
675 int* idBnd;
676 double spacing[2];
677 evxAsmPtnDrv derive;
678 double minimum;
679 evxAsmPtnStagger stagger;
680 evxAsmPtnAlg alignment;
681 int idFace;
682 int useFromPnt;
683 svxPntOnEnt fromPnt;
684 evxAsmPtnBnd boundary;
685 }curve;
686 struct svxAsmAtFace
687 {
688 int idFace;
689 double spacing[2];
690 evxAsmPtnDrv derive;
691 double minimum;
692 evxAsmPtnStagger stagger;
693 evxAsmPtnAlg alignment;
694 int useFromPnt;
695 svxPntOnEnt fromPnt;
696 evxAsmPtnBnd boundary;
697 }face;
698 }ptnData;
699 int cntSkip;
700 int* firstTogglePos;
701 int* secondTogglePos;
709 } svxAsmPtnData;
710
715typedef struct svxAsmMove
716 {
717 evxAsmMoveType type;
718 int Count;
719 int* idEnts;
720 int copy;
721 union AsmMoveData
722 {
723 struct svxAsmDynamic
724 {
725 int handle;
726 svxPntOnEnt position;
727 svxVector xAxis;
728 svxVector yAxis;
729 svxVector zAxis;
730 }dynamic;
731 struct svxAsmPnt
732 {
733 svxPntOnEnt fromPnt;
734 int numToPnt;
735 svxPntOnEnt* toPnt;
736 int useVec;
737 svxVector fromVec;
738 svxVector toVec;
739 }pnt;
740 struct svxAsmAlongDir
741 {
742 svxVector dir;
743 double dist;
744 double angle;
745 int useAng;
746 int numCopy;
747 }alongDir;
748 struct svxAsmAroundDir
749 {
750 svxVector dir;
751 svxPntOnEnt location;
752 double angle;
753 int numCopy;
754 }aroundDir;
755 struct svxAsmAlignFrame
756 {
757 int fromFrame;
758 int toFrame;
759 }align;
760 struct svxAsmSweep
761 {
762 svxPntOnEnt path;
763 int numToPnt;
764 svxPntOnEnt* toPnts;
765 evxAsmMoveFrame frame;
766 evxAsmMoveZSpine zSpine;
767 int spineCrv;
768 svxVector parallel;
769 evxAsmMoveXOrnt xOrient;
770 svxVector guide;
771 int xAxisCrv;
772 int idSwp;
773 }sweep;
774 }move;
775 } svxAsmMove;
776
781typedef struct svxAsmMirror
782 {
783 evxAsmMirrorType type;
784 int Count;
785 svxEntPath* pEnts;
786 svxEntPath pPlane;
787 int erase;
788 evxAsmMirrorCenter center;
789 union AsmMirrorData
790 {
791 struct svxAsmCopy
792 {
793 int isDissolve;
794 int whole;
795 int atParent;
796 evxAsmMirrorSymm symm;
797 svxEntPath idDatum;
798 }copy;
799 struct AsmDup
800 {
801 int geometry;
802 int position;
803 evxAsmMirrorCategory cat;
804 evxAsmMirrorSymm symm;
805 svxEntPath idDatum;
806 }duplicate;
807 }mirror;
808 } svxAsmMirror;
809
814typedef struct svxAsmCut
815 {
816 int numCut;
817 svxEntPath* pCuts;
818 int numComp;
819 svxEntPath* pComps;
820 int propagate;
821 int hide;
822 } svxAsmCut;
823
828typedef struct svxAsmFllt
829 {
830 evxChamFlltType type;
831 int undercut;
832 int blend;
833 int sample;
834 int density;
835 evxAsmFlltBase baseFace;
836 int propagate;
837 int numEnt;
838 svxEntPath* pEnts;
839 int* vertex;
842 union svxAsmFlltData
843 {
844 struct svxAsmEdge
845 {
846 double R;
847 double relief;
848 evxAsmFlltArc arc;
849 double conic;
850 int hold;
851 int force;
852 int mitred;
853 int trace;
854 evxAsmFlltFace filletFace;
855 }edge;
856 struct svxAsmLoop
857 {
858 int numSel;
859 svxEntPath* pSels;
860 double R;
861 double relief;
862 evxAsmFlltLoop loop;
863 evxAsmFlltArc arc;
864 double conic;
865 int hold;
866 int force;
867 int mitred;
868 int trace;
869 evxAsmFlltFace filletFace;
870 }loop;
871 struct svxAsmVertex
872 {
873 double setback;
874 }vertex;
875 }fillet;
876 } svxAsmFllt;
877
882typedef struct svxAsmChmf
883 {
884 evxAsmChmfType type;
885 evxAsmChmfBase baseFace;
886 int propagate;
887 int numEnt;
888 svxEntPath* pEnts;
889 union svxAsmChmfData
890 {
891 struct svxAsmEdgeChmf
892 {
893 double S;
894 int patch;
895 int force;
896 int mitred;
897 int trace;
898 int undercut;
899 int blend;
900 int sample;
901 int density;
902 evxAsmChmfFace filletFace;
903 }edge;
904 struct svxAsmVertexChmf
905 {
906 double S;
907 }vertex;
908 }chamfer;
909 } svxAsmChmf;
910
911//====================================================================================================================
913//====================================================================================================================
918typedef struct svxIferChkResData
919 {
920 svxEntPath BaseCompPath;
921 vxLongName BaseCompName;
922 svxEntPath ChkCompPath;
923 vxLongName ChkCompName;
924 double IferVolme;
925 }svxIferChkResData;
926
931typedef struct svxClrChkData
932 {
933 svxEntPath BaseCompPath;
934 svxEntPath ChkCompPath;
935 svxPoint Pnt[2];
936 double ClrValue;
937 int IferFlag;
938 }svxClrChkData;
939
940/*
941*********************************************************************
942** END HEADER FILE
943*********************************************************************
944*/
945
946#ifdef __cplusplus
947 }
948#endif /* __cplusplus */
949
950#endif /* ZW_API_ASSEMBLY_FTR_DATA_H */
evxAsmPtnDrv
evxAsmPtnDrv
assembly pattern derive method
Definition: zwapi_cmd_assembly_data.h:411
VX_ASM_PTN_DRV_SPACING
@ VX_ASM_PTN_DRV_SPACING
spacing option
Definition: zwapi_cmd_assembly_data.h:413
VX_ASM_PTN_DRV_NONE
@ VX_ASM_PTN_DRV_NONE
none option
Definition: zwapi_cmd_assembly_data.h:412
VX_ASM_PTN_DRV_NUM
@ VX_ASM_PTN_DRV_NUM
number option
Definition: zwapi_cmd_assembly_data.h:414
evxAsmMoveType
evxAsmMoveType
assembly move method
Definition: zwapi_cmd_assembly_data.h:455
VX_ASM_MOVE_SWEEP
@ VX_ASM_MOVE_SWEEP
sweep option
Definition: zwapi_cmd_assembly_data.h:459
VX_ASM_MOVE_DYNAMIC
@ VX_ASM_MOVE_DYNAMIC
dynamic move option
Definition: zwapi_cmd_assembly_data.h:461
VX_ASM_MOVE_PNT
@ VX_ASM_MOVE_PNT
point to point option
Definition: zwapi_cmd_assembly_data.h:456
VX_ASM_MOVE_ALIGN
@ VX_ASM_MOVE_ALIGN
align frames option
Definition: zwapi_cmd_assembly_data.h:458
VX_ASM_MOVE_AROUND_DIR
@ VX_ASM_MOVE_AROUND_DIR
around direction option
Definition: zwapi_cmd_assembly_data.h:460
VX_ASM_MOVE_ALONG_DIR
@ VX_ASM_MOVE_ALONG_DIR
along direction option
Definition: zwapi_cmd_assembly_data.h:457
evxAsmFlltLoop
evxAsmFlltLoop
assembly fillet loop method
Definition: zwapi_cmd_assembly_data.h:584
VX_ASM_FLLT_LOOP_IN
@ VX_ASM_FLLT_LOOP_IN
inner option
Definition: zwapi_cmd_assembly_data.h:585
VX_ASM_FLLT_LOOP_SELECT
@ VX_ASM_FLLT_LOOP_SELECT
selected option
Definition: zwapi_cmd_assembly_data.h:590
VX_ASM_FLLT_LOOP_BOUND
@ VX_ASM_FLLT_LOOP_BOUND
boundary option
Definition: zwapi_cmd_assembly_data.h:588
VX_ASM_FLLT_LOOP_ALL
@ VX_ASM_FLLT_LOOP_ALL
all option
Definition: zwapi_cmd_assembly_data.h:589
VX_ASM_FLLT_LOOP_SHARE
@ VX_ASM_FLLT_LOOP_SHARE
shared option
Definition: zwapi_cmd_assembly_data.h:587
VX_ASM_FLLT_LOOP_OUT
@ VX_ASM_FLLT_LOOP_OUT
outer option
Definition: zwapi_cmd_assembly_data.h:586
evxAsmPtnBnd
evxAsmPtnBnd
assembly pattern boundary method
Definition: zwapi_cmd_assembly_data.h:444
VX_ASM_PTN_BND_PALCE
@ VX_ASM_PTN_BND_PALCE
in palce option
Definition: zwapi_cmd_assembly_data.h:446
VX_ASM_PTN_BND_AUTO
@ VX_ASM_PTN_BND_AUTO
move option
Definition: zwapi_cmd_assembly_data.h:445
VX_ASM_PTN_BND_MOVE
@ VX_ASM_PTN_BND_MOVE
move option
Definition: zwapi_cmd_assembly_data.h:447
evxAsmFlltArc
evxAsmFlltArc
assembly fillet arc method
Definition: zwapi_cmd_assembly_data.h:551
VX_ASM_FLLT_ARC_CONIC
@ VX_ASM_FLLT_ARC_CONIC
conic arc type
Definition: zwapi_cmd_assembly_data.h:553
VX_ASM_FLLT_ARC_CIR
@ VX_ASM_FLLT_ARC_CIR
circular arc type
Definition: zwapi_cmd_assembly_data.h:552
evxAlignInterference
evxAlignInterference
interference type
Definition: zwapi_cmd_assembly_data.h:158
VX_INTERFERENCE_HIGHLIGHT
@ VX_INTERFERENCE_HIGHLIGHT
when you drag a component, it will pause when interference is detected and the intersecting faces wil...
Definition: zwapi_cmd_assembly_data.h:160
VX_INTERFERENCE_STOP_AT
@ VX_INTERFERENCE_STOP_AT
this is similar to the VX_INTERFERENCE_HIGHLIGHT option but the component is stopped at the point of ...
Definition: zwapi_cmd_assembly_data.h:163
VX_INTERFERENCE_ADD_ALIGN
@ VX_INTERFERENCE_ADD_ALIGN
add constraint
Definition: zwapi_cmd_assembly_data.h:166
VX_INTERFERENCE_NONE
@ VX_INTERFERENCE_NONE
do not check for interference when dragging a component
Definition: zwapi_cmd_assembly_data.h:159
evxAsmPtnCrv
evxAsmPtnCrv
assembly pattern curves method
Definition: zwapi_cmd_assembly_data.h:432
VX_ASM_PTN_CRV1
@ VX_ASM_PTN_CRV1
1 curve option
Definition: zwapi_cmd_assembly_data.h:433
VX_ASM_PTN_CRV2_ACROSS
@ VX_ASM_PTN_CRV2_ACROSS
2 cruves across option
Definition: zwapi_cmd_assembly_data.h:435
VX_ASM_PTN_CRV2_TOG
@ VX_ASM_PTN_CRV2_TOG
2 cruves together option
Definition: zwapi_cmd_assembly_data.h:434
VX_ASM_PTN_CRV3
@ VX_ASM_PTN_CRV3
3-4 curves option
Definition: zwapi_cmd_assembly_data.h:436
evxAsmPtnStagger
evxAsmPtnStagger
assembly pattern stagger method
Definition: zwapi_cmd_assembly_data.h:401
VX_ASM_PTN_NO_STAGGER
@ VX_ASM_PTN_NO_STAGGER
no stagger option
Definition: zwapi_cmd_assembly_data.h:402
VX_ASM_PTN_STAGGER
@ VX_ASM_PTN_STAGGER
stagger pattern option
Definition: zwapi_cmd_assembly_data.h:403
evxAlignType
evxAlignType
part component/shape alignment
Definition: zwapi_cmd_assembly_data.h:144
VX_ALIGN_PERPENDICULAR
@ VX_ALIGN_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_assembly_data.h:149
VX_ALIGN_ANGLE
@ VX_ALIGN_ANGLE
angle
Definition: zwapi_cmd_assembly_data.h:150
VX_ALIGN_CONCENTRIC
@ VX_ALIGN_CONCENTRIC
concentric
Definition: zwapi_cmd_assembly_data.h:147
VX_ALIGN_PARALLEL
@ VX_ALIGN_PARALLEL
parallel
Definition: zwapi_cmd_assembly_data.h:148
VX_ALIGN_COINCIDENT
@ VX_ALIGN_COINCIDENT
coincident
Definition: zwapi_cmd_assembly_data.h:145
VX_ALIGN_TANGENT
@ VX_ALIGN_TANGENT
tangent
Definition: zwapi_cmd_assembly_data.h:146
evxAsmMirrorSymm
evxAsmMirrorSymm
assembly mirror self-symmetric method
Definition: zwapi_cmd_assembly_data.h:512
VX_ASM_MIRROR_SYMM_YZ
@ VX_ASM_MIRROR_SYMM_YZ
YZ option.
Definition: zwapi_cmd_assembly_data.h:514
VX_ASM_MIRROR_SYMM_YCZC
@ VX_ASM_MIRROR_SYMM_YCZC
YcZc option.
Definition: zwapi_cmd_assembly_data.h:518
VX_ASM_MIRROR_SYMM_C
@ VX_ASM_MIRROR_SYMM_C
C option.
Definition: zwapi_cmd_assembly_data.h:516
VX_ASM_MIRROR_SYMM_XZ
@ VX_ASM_MIRROR_SYMM_XZ
XZ option.
Definition: zwapi_cmd_assembly_data.h:513
VX_ASM_MIRROR_SYMM_XCZC
@ VX_ASM_MIRROR_SYMM_XCZC
XcZc option.
Definition: zwapi_cmd_assembly_data.h:517
VX_ASM_MIRROR_SYMM_NONE
@ VX_ASM_MIRROR_SYMM_NONE
none option
Definition: zwapi_cmd_assembly_data.h:520
VX_ASM_MIRROR_SYMM_XY
@ VX_ASM_MIRROR_SYMM_XY
XY option.
Definition: zwapi_cmd_assembly_data.h:515
VX_ASM_MIRROR_SYMM_XCYC
@ VX_ASM_MIRROR_SYMM_XCYC
XcYc option.
Definition: zwapi_cmd_assembly_data.h:519
evxRollCtrlType
evxRollCtrlType
roll control type
Definition: zwapi_cmd_assembly_data.h:269
VX_ROLL_CTRL_FREE
@ VX_ROLL_CTRL_FREE
the roll of component is not constrained
Definition: zwapi_cmd_assembly_data.h:270
VX_ROLL_CTRL_UP_VEC
@ VX_ROLL_CTRL_UP_VEC
constraint an axis of component to align with the specified vector
Definition: zwapi_cmd_assembly_data.h:271
evxAsmFlltFace
evxAsmFlltFace
assembly fillet fillet face method
Definition: zwapi_cmd_assembly_data.h:573
VX_ASM_FLLT_FACE_MIN
@ VX_ASM_FLLT_FACE_MIN
minimal option
Definition: zwapi_cmd_assembly_data.h:575
VX_ASM_FLLT_FACE_MAX
@ VX_ASM_FLLT_FACE_MAX
maximal option
Definition: zwapi_cmd_assembly_data.h:574
VX_ASM_FLLT_FACE_MATCH
@ VX_ASM_FLLT_FACE_MATCH
tangent match option
Definition: zwapi_cmd_assembly_data.h:576
evxSlotConsType
evxSlotConsType
slot constraint type
Definition: zwapi_cmd_assembly_data.h:335
VX_SLOT_CONS_PERCENT
@ VX_SLOT_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of slot
Definition: zwapi_cmd_assembly_data.h:339
VX_SLOT_CONS_DISTANCE
@ VX_SLOT_CONS_DISTANCE
constraint component to a specified distance from the end of slot
Definition: zwapi_cmd_assembly_data.h:338
VX_SLOT_CONS_CENTER
@ VX_SLOT_CONS_CENTER
constraint component in the center of slot
Definition: zwapi_cmd_assembly_data.h:337
VX_SLOT_CONS_FREE
@ VX_SLOT_CONS_FREE
component can move along the slot
Definition: zwapi_cmd_assembly_data.h:336
evxAsmChmfFace
evxAsmChmfFace
assembly chamfer fillet face method
Definition: zwapi_cmd_assembly_data.h:620
VX_ASM_CHMF_FACE_MATCH
@ VX_ASM_CHMF_FACE_MATCH
tangent match option
Definition: zwapi_cmd_assembly_data.h:623
VX_ASM_CHMF_FACE_MAX
@ VX_ASM_CHMF_FACE_MAX
maximal option
Definition: zwapi_cmd_assembly_data.h:621
VX_ASM_CHMF_FACE_MIN
@ VX_ASM_CHMF_FACE_MIN
minimal option
Definition: zwapi_cmd_assembly_data.h:622
evxAsmMoveXOrnt
evxAsmMoveXOrnt
assembly move x-orient method
Definition: zwapi_cmd_assembly_data.h:491
VX_ASM_MOVE_X_NTR
@ VX_ASM_MOVE_X_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:492
VX_ASM_MOVE_X_AXIS
@ VX_ASM_MOVE_X_AXIS
x-axis curve option
Definition: zwapi_cmd_assembly_data.h:494
VX_ASM_MOVE_X_GUIDE
@ VX_ASM_MOVE_X_GUIDE
guide plane option
Definition: zwapi_cmd_assembly_data.h:493
evxResponse
evxResponse
response to user prompt
Definition: zwapi_cmd_assembly_data.h:129
VX_CANCEL
@ VX_CANCEL
cancel
Definition: zwapi_cmd_assembly_data.h:130
VX_YES
@ VX_YES
yes
Definition: zwapi_cmd_assembly_data.h:132
VX_YES_ALL
@ VX_YES_ALL
yes all
Definition: zwapi_cmd_assembly_data.h:133
VX_NO
@ VX_NO
no
Definition: zwapi_cmd_assembly_data.h:131
evxAsmMirrorCategory
evxAsmMirrorCategory
assembly mirror category method
Definition: zwapi_cmd_assembly_data.h:540
VX_ASM_MIRROR_CAT_DUP
@ VX_ASM_MIRROR_CAT_DUP
duplicate option
Definition: zwapi_cmd_assembly_data.h:542
VX_ASM_MIRROR_CAT_DEL
@ VX_ASM_MIRROR_CAT_DEL
delete option
Definition: zwapi_cmd_assembly_data.h:543
VX_ASM_MIRROR_CAT_COPY
@ VX_ASM_MIRROR_CAT_COPY
copy option
Definition: zwapi_cmd_assembly_data.h:541
evxConsType
evxConsType
assembly constraint type
Definition: zwapi_cmd_assembly_data.h:193
VX_PARALLEL
@ VX_PARALLEL
Parallel constraint.
Definition: zwapi_cmd_assembly_data.h:198
VX_MC_SLOT
@ VX_MC_SLOT
Slot constraint.
Definition: zwapi_cmd_assembly_data.h:211
VX_COINCIDENT
@ VX_COINCIDENT
Coincident constraint.
Definition: zwapi_cmd_assembly_data.h:196
VX_MC_CAM
@ VX_MC_CAM
Cam constraint.
Definition: zwapi_cmd_assembly_data.h:212
VX_TANGENT
@ VX_TANGENT
Tangent constraint.
Definition: zwapi_cmd_assembly_data.h:197
VX_CONCENTRIC
@ VX_CONCENTRIC
Concentric constraint.
Definition: zwapi_cmd_assembly_data.h:195
VX_AT_DISTANCE
@ VX_AT_DISTANCE
Distance constraint.
Definition: zwapi_cmd_assembly_data.h:200
VX_MC_UNIV_JOINT
@ VX_MC_UNIV_JOINT
universal joint constraint
Definition: zwapi_cmd_assembly_data.h:213
VX_ADV_LOCKED
@ VX_ADV_LOCKED
Lock constraint.
Definition: zwapi_cmd_assembly_data.h:204
VX_AT_ANGLE_FULL
@ VX_AT_ANGLE_FULL
At angle constraint.
Definition: zwapi_cmd_assembly_data.h:201
VX_SYMMETRIC
@ VX_SYMMETRIC
Symmetry constraint.
Definition: zwapi_cmd_assembly_data.h:203
VX_GEAR
@ VX_GEAR
Gear constraint.
Definition: zwapi_cmd_assembly_data.h:202
VX_ADV_MIDDLE
@ VX_ADV_MIDDLE
Middle constraint.
Definition: zwapi_cmd_assembly_data.h:205
VX_MC_RACK_PINION
@ VX_MC_RACK_PINION
Rack and pinion constraint.
Definition: zwapi_cmd_assembly_data.h:209
VX_MC_LINEAR_COUPLER
@ VX_MC_LINEAR_COUPLER
Linear couple constraint.
Definition: zwapi_cmd_assembly_data.h:208
VX_PERPENDICULAR
@ VX_PERPENDICULAR
Perpendicular constraint.
Definition: zwapi_cmd_assembly_data.h:199
VX_ADV_FRAME
@ VX_ADV_FRAME
Frame constraint.
Definition: zwapi_cmd_assembly_data.h:206
VX_MC_SCREW
@ VX_MC_SCREW
Screw constraint.
Definition: zwapi_cmd_assembly_data.h:210
VX_ADV_PATH
@ VX_ADV_PATH
Path constraint.
Definition: zwapi_cmd_assembly_data.h:207
evxAsmPatternType
evxAsmPatternType
assembly pattern method
Definition: zwapi_cmd_assembly_data.h:387
VX_ASM_PTN_PATTERN
@ VX_ASM_PTN_PATTERN
at pattern option
Definition: zwapi_cmd_assembly_data.h:391
VX_ASM_PTN_CIRCULAR
@ VX_ASM_PTN_CIRCULAR
circular option
Definition: zwapi_cmd_assembly_data.h:389
VX_ASM_PTN_LINEAR
@ VX_ASM_PTN_LINEAR
linear option
Definition: zwapi_cmd_assembly_data.h:388
VX_ASM_PTN_POINT
@ VX_ASM_PTN_POINT
piont to point option
Definition: zwapi_cmd_assembly_data.h:390
VX_ASM_PTN_CRV
@ VX_ASM_PTN_CRV
at curves option
Definition: zwapi_cmd_assembly_data.h:392
VX_ASM_PTN_FACE
@ VX_ASM_PTN_FACE
at face option
Definition: zwapi_cmd_assembly_data.h:393
evxAsmChmfType
evxAsmChmfType
assembly chamfer method
Definition: zwapi_cmd_assembly_data.h:598
VX_ASM_CHMF_VERTEX
@ VX_ASM_CHMF_VERTEX
vertex chamfer type
Definition: zwapi_cmd_assembly_data.h:600
VX_ASM_CHMF_EDGE
@ VX_ASM_CHMF_EDGE
edge chamfer type
Definition: zwapi_cmd_assembly_data.h:599
evxAsmMirrorType
evxAsmMirrorType
assembly mirror method
Definition: zwapi_cmd_assembly_data.h:502
VX_ASM_MIRROR_COPY
@ VX_ASM_MIRROR_COPY
copy option
Definition: zwapi_cmd_assembly_data.h:503
VX_ASM_MIRROR_DUP
@ VX_ASM_MIRROR_DUP
duplicate option
Definition: zwapi_cmd_assembly_data.h:504
evxPathConsType
evxPathConsType
path constraint type
Definition: zwapi_cmd_assembly_data.h:248
VX_PATH_CONS_DISTANCE
@ VX_PATH_CONS_DISTANCE
constraint component to a specified distance from the end of the path
Definition: zwapi_cmd_assembly_data.h:250
VX_PATH_CONS_PERCENT
@ VX_PATH_CONS_PERCENT
constraint component to a distance specified by a percentage from the end of the path
Definition: zwapi_cmd_assembly_data.h:251
VX_PATH_CONS_FREE
@ VX_PATH_CONS_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:249
evxAsmMoveFrame
evxAsmMoveFrame
assembly move frame method
Definition: zwapi_cmd_assembly_data.h:469
VX_ASM_MOVE_FRAME_PATH
@ VX_ASM_MOVE_FRAME_PATH
at path option
Definition: zwapi_cmd_assembly_data.h:471
VX_ASM_MOVE_FRAME_NTR
@ VX_ASM_MOVE_FRAME_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:470
VX_ASM_MOVE_FRAME_SLC
@ VX_ASM_MOVE_FRAME_SLC
selected option
Definition: zwapi_cmd_assembly_data.h:472
evxConsState
evxConsState
constraint state of component
Definition: zwapi_cmd_assembly_data.h:369
VX_UN_CONSTRAINED
@ VX_UN_CONSTRAINED
the component is not constrained
Definition: zwapi_cmd_assembly_data.h:371
VX_UNDER_CONSTRAINED
@ VX_UNDER_CONSTRAINED
the component can still move
Definition: zwapi_cmd_assembly_data.h:372
VX_OVER_CONSTRAINED
@ VX_OVER_CONSTRAINED
the component has conflicting or redundant constraints
Definition: zwapi_cmd_assembly_data.h:375
VX_FIXED
@ VX_FIXED
the component is fixed and will not move
Definition: zwapi_cmd_assembly_data.h:374
VX_UNKNOWN
@ VX_UNKNOWN
unknown
Definition: zwapi_cmd_assembly_data.h:370
VX_WELL_CONSTRAINED
@ VX_WELL_CONSTRAINED
the component is completely and correctly constrained
Definition: zwapi_cmd_assembly_data.h:373
evxAsmFlltBase
evxAsmFlltBase
assembly fillet base faces method
Definition: zwapi_cmd_assembly_data.h:561
VX_ASM_FLLT_BASE_DIV
@ VX_ASM_FLLT_BASE_DIV
divide option
Definition: zwapi_cmd_assembly_data.h:563
VX_ASM_FLLT_BASE_TRIM
@ VX_ASM_FLLT_BASE_TRIM
trim option
Definition: zwapi_cmd_assembly_data.h:564
VX_ASM_FLLT_BASE_NO
@ VX_ASM_FLLT_BASE_NO
no action option
Definition: zwapi_cmd_assembly_data.h:562
VX_ASM_FLLT_BASE_SEW
@ VX_ASM_FLLT_BASE_SEW
sew option
Definition: zwapi_cmd_assembly_data.h:565
evxAsmMoveZSpine
evxAsmMoveZSpine
assembly move z-spine method
Definition: zwapi_cmd_assembly_data.h:480
VX_ASM_MOVE_Z_PARALLEL
@ VX_ASM_MOVE_Z_PARALLEL
paallel option
Definition: zwapi_cmd_assembly_data.h:483
VX_ASM_MOVE_Z_NTR
@ VX_ASM_MOVE_Z_NTR
natural option
Definition: zwapi_cmd_assembly_data.h:481
VX_ASM_MOVE_Z_SPINE
@ VX_ASM_MOVE_Z_SPINE
spine option
Definition: zwapi_cmd_assembly_data.h:482
evxPitchYawType
evxPitchYawType
pitch/yaw type
Definition: zwapi_cmd_assembly_data.h:259
VX_PITCH_YAW_FOLLOW_PATH
@ VX_PITCH_YAW_FOLLOW_PATH
constraint an axis of component to be tangent to the path
Definition: zwapi_cmd_assembly_data.h:261
VX_PITCH_YAW_FREE
@ VX_PITCH_YAW_FREE
component can move along the path
Definition: zwapi_cmd_assembly_data.h:260
evxAsmPtnAlg
evxAsmPtnAlg
assembly pattern alignment method
Definition: zwapi_cmd_assembly_data.h:422
VX_ASM_PTN_ALG_BASE
@ VX_ASM_PTN_ALG_BASE
align with base option
Definition: zwapi_cmd_assembly_data.h:423
VX_ASM_PTN_ALG_PTN
@ VX_ASM_PTN_ALG_PTN
align with pattern option
Definition: zwapi_cmd_assembly_data.h:424
evxAsmChmfBase
evxAsmChmfBase
assembly chamfer base faces method
Definition: zwapi_cmd_assembly_data.h:608
VX_ASM_CHMF_BASE_NO
@ VX_ASM_CHMF_BASE_NO
no action option
Definition: zwapi_cmd_assembly_data.h:609
VX_ASM_CHMF_BASE_SEW
@ VX_ASM_CHMF_BASE_SEW
sew option
Definition: zwapi_cmd_assembly_data.h:612
VX_ASM_CHMF_BASE_DIV
@ VX_ASM_CHMF_BASE_DIV
divide option
Definition: zwapi_cmd_assembly_data.h:610
VX_ASM_CHMF_BASE_TRIM
@ VX_ASM_CHMF_BASE_TRIM
trim option
Definition: zwapi_cmd_assembly_data.h:611
evxAsmMirrorCenter
evxAsmMirrorCenter
assembly mirror center method
Definition: zwapi_cmd_assembly_data.h:529
VX_ASM_MIRROR_CTR_MASS
@ VX_ASM_MIRROR_CTR_MASS
mass option
Definition: zwapi_cmd_assembly_data.h:531
VX_ASM_MIRROR_CTR_BOX
@ VX_ASM_MIRROR_CTR_BOX
bounding box option
Definition: zwapi_cmd_assembly_data.h:530
VX_ASM_MIRROR_CTR_FRAME
@ VX_ASM_MIRROR_CTR_FRAME
frame option
Definition: zwapi_cmd_assembly_data.h:532
svxPathConsData
struct svxPathConsData svxPathConsData
custom data for assembly path constraint
svxSlotConsData
struct svxSlotConsData svxSlotConsData
custom data for assembly slot constraint
svxAsmMove
struct svxAsmMove svxAsmMove
assembly move data
svxConsData
struct svxConsData svxConsData
custom data for assembly common constraint
svxGeomExport
struct svxGeomExport svxGeomExport
geometry export
svxAsmFllt
struct svxAsmFllt svxAsmFllt
assembly fillet data
svxLinearCpData
struct svxLinearCpData svxLinearCpData
custom data for assembly linear couple constraint
svxIferChkResData
struct svxIferChkResData svxIferChkResData
Interference check result data.
svxRackPinionData
struct svxRackPinionData svxRackPinionData
custom data for assembly rack and pinion constraint
svxGearConsData
struct svxGearConsData svxGearConsData
custom data for assembly gear constraint
svxAsmCut
struct svxAsmCut svxAsmCut
assembly cut data
svxPartInstData
struct svxPartInstData svxPartInstData
copy external part data
svxCompIncludeData
struct svxCompIncludeData svxCompIncludeData
include component data
svxAlign
struct svxAlign svxAlign
Alignment constraint.
svxClrChkData
struct svxClrChkData svxClrChkData
clearance check result data
svxCompData
struct svxCompData svxCompData
component data
svxAsmMirror
struct svxAsmMirror svxAsmMirror
assembly mirror data
svxAsmChmf
struct svxAsmChmf svxAsmChmf
assembly chamfer data
svxScrewConsData
struct svxScrewConsData svxScrewConsData
custom data for assembly screw constraint
svxUniJointData
struct svxUniJointData svxUniJointData
custom data for assembly universal joint constraint
svxAsmPtnData
struct svxAsmPtnData svxAsmPtnData
assembly pattern data
evxChamFlltType
evxChamFlltType
chamfer or fillet types
Definition: zwapi_cmd_shape_data.h:413
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAlign::ShowExistingAlign
int ShowExistingAlign
1 to display of existing alignment constraints for the active component, else 0
Definition: zwapi_cmd_assembly_data.h:184
svxAlign::Offset
double Offset
distance between alignment entities
Definition: zwapi_cmd_assembly_data.h:181
svxAlign::Type
evxAlignType Type
alignment type
Definition: zwapi_cmd_assembly_data.h:180
svxAlign::Entity2
svxData Entity2
"isPntOnCrv" or "isPntOnFace" required point must be defined in active part space (see cvxPntOnFace()...
Definition: zwapi_cmd_assembly_data.h:176
svxAlign::isOpposite
int isOpposite
1 to make entities opposite facing, else 0
Definition: zwapi_cmd_assembly_data.h:183
svxAlign::Interference
evxAlignInterference Interference
interference options
Definition: zwapi_cmd_assembly_data.h:185
svxAlign::Angle
double Angle
angle between alignment entities
Definition: zwapi_cmd_assembly_data.h:182
svxAlign::Entity1
svxData Entity1
"isPntOnCrv" or "isPntOnFace" required
Definition: zwapi_cmd_assembly_data.h:175
svxAlign
Alignment constraint.
Definition: zwapi_cmd_assembly_data.h:174
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::mitred
int mitred
whether to mitred corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:896
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::trace
int trace
whether to trace corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:897
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::force
int force
whether to force local corner(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:895
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::patch
int patch
whether to use patch for tight corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:894
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::undercut
int undercut
whether to search for undercuts(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:898
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::S
double S
setback.default:5
Definition: zwapi_cmd_assembly_data.h:893
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::density
int density
density.default:10
Definition: zwapi_cmd_assembly_data.h:901
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::sample
int sample
whether to use specify sample density(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:900
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::blend
int blend
whether to blend corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:899
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf::filletFace
evxAsmChmfFace filletFace
fillet face option.default:VX_ASM_CHMF_FACE_MATCH
Definition: zwapi_cmd_assembly_data.h:902
svxAsmChmf::svxAsmChmfData::svxAsmEdgeChmf
edge chamfer type
Definition: zwapi_cmd_assembly_data.h:892
svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf::S
double S
setback.default:10
Definition: zwapi_cmd_assembly_data.h:906
svxAsmChmf::svxAsmChmfData::svxAsmVertexChmf
vertex chamfer type
Definition: zwapi_cmd_assembly_data.h:905
svxAsmChmf::pEnts
svxEntPath * pEnts
the list path of entities
Definition: zwapi_cmd_assembly_data.h:888
svxAsmChmf::type
evxAsmChmfType type
chamfer type
Definition: zwapi_cmd_assembly_data.h:884
svxAsmChmf::baseFace
evxAsmChmfBase baseFace
base faces option.default:VX_ASM_CHMF_BASE_SEM
Definition: zwapi_cmd_assembly_data.h:885
svxAsmChmf::numEnt
int numEnt
the number of entities
Definition: zwapi_cmd_assembly_data.h:887
svxAsmChmf::propagate
int propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:886
svxAsmChmf
assembly chamfer data
Definition: zwapi_cmd_assembly_data.h:883
svxAsmCut::numComp
int numComp
number of component entities
Definition: zwapi_cmd_assembly_data.h:818
svxAsmCut::pCuts
svxEntPath * pCuts
list of path's of cutter entities
Definition: zwapi_cmd_assembly_data.h:817
svxAsmCut::numCut
int numCut
number of cutter entities
Definition: zwapi_cmd_assembly_data.h:816
svxAsmCut::hide
int hide
whether to hide cutter(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:821
svxAsmCut::propagate
int propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:820
svxAsmCut::pComps
svxEntPath * pComps
list of path's of component entities
Definition: zwapi_cmd_assembly_data.h:819
svxAsmCut
assembly cut data
Definition: zwapi_cmd_assembly_data.h:815
svxAsmFllt::svxAsmFlltData::svxAsmEdge::hold
int hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:850
svxAsmFllt::svxAsmFlltData::svxAsmEdge::filletFace
evxAsmFlltFace filletFace
fillet face option.default:VX_ASM_FLLT_FACE_MATCH
Definition: zwapi_cmd_assembly_data.h:854
svxAsmFllt::svxAsmFlltData::svxAsmEdge::arc
evxAsmFlltArc arc
arc option.default:VX_ASM_FLLT_ARC_CIR
Definition: zwapi_cmd_assembly_data.h:848
svxAsmFllt::svxAsmFlltData::svxAsmEdge::force
int force
whether to force local corner(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:851
svxAsmFllt::svxAsmFlltData::svxAsmEdge::mitred
int mitred
whether to mitred corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:852
svxAsmFllt::svxAsmFlltData::svxAsmEdge::relief
double relief
relief.default:0
Definition: zwapi_cmd_assembly_data.h:847
svxAsmFllt::svxAsmFlltData::svxAsmEdge::trace
int trace
whether to trace corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:853
svxAsmFllt::svxAsmFlltData::svxAsmEdge::conic
double conic
conic ratio.default:0.5
Definition: zwapi_cmd_assembly_data.h:849
svxAsmFllt::svxAsmFlltData::svxAsmEdge::R
double R
radius.default:5
Definition: zwapi_cmd_assembly_data.h:846
svxAsmFllt::svxAsmFlltData::svxAsmEdge
edge fillet type
Definition: zwapi_cmd_assembly_data.h:845
svxAsmFllt::svxAsmFlltData::svxAsmLoop::force
int force
whether to force local corner(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:866
svxAsmFllt::svxAsmFlltData::svxAsmLoop::arc
evxAsmFlltArc arc
arc option.default:VX_ASM_FLLT_ARC_CIR
Definition: zwapi_cmd_assembly_data.h:863
svxAsmFllt::svxAsmFlltData::svxAsmLoop::R
double R
radius.default:5
Definition: zwapi_cmd_assembly_data.h:860
svxAsmFllt::svxAsmFlltData::svxAsmLoop::mitred
int mitred
whether to mitred corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:867
svxAsmFllt::svxAsmFlltData::svxAsmLoop::conic
double conic
conic ratio.default:0.5
Definition: zwapi_cmd_assembly_data.h:864
svxAsmFllt::svxAsmFlltData::svxAsmLoop::relief
double relief
relief.default:0
Definition: zwapi_cmd_assembly_data.h:861
svxAsmFllt::svxAsmFlltData::svxAsmLoop::pSels
svxEntPath * pSels
the list path of selected edges entities
Definition: zwapi_cmd_assembly_data.h:859
svxAsmFllt::svxAsmFlltData::svxAsmLoop::filletFace
evxAsmFlltFace filletFace
fillet face option.default:VX_ASM_FLLT_FACE_MATCH
Definition: zwapi_cmd_assembly_data.h:869
svxAsmFllt::svxAsmFlltData::svxAsmLoop::trace
int trace
whether to trace corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:868
svxAsmFllt::svxAsmFlltData::svxAsmLoop::loop
evxAsmFlltLoop loop
loop option.default:VX_ASM_FLLT_LOOP_OUT
Definition: zwapi_cmd_assembly_data.h:862
svxAsmFllt::svxAsmFlltData::svxAsmLoop::hold
int hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:865
svxAsmFllt::svxAsmFlltData::svxAsmLoop::numSel
int numSel
the number of selected edges entities
Definition: zwapi_cmd_assembly_data.h:858
svxAsmFllt::svxAsmFlltData::svxAsmLoop
loop fillet type
Definition: zwapi_cmd_assembly_data.h:857
svxAsmFllt::svxAsmFlltData::svxAsmVertex::setback
double setback
setback.default:5
Definition: zwapi_cmd_assembly_data.h:873
svxAsmFllt::svxAsmFlltData::svxAsmVertex
vertex fillet type
Definition: zwapi_cmd_assembly_data.h:872
svxAsmFllt::blend
int blend
whether to blend corners(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:832
svxAsmFllt::sample
int sample
whether to use specify sample density(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:833
svxAsmFllt::vertex
int * vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in thi...
Definition: zwapi_cmd_assembly_data.h:839
svxAsmFllt::propagate
int propagate
whether to propagate feature to components(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:836
svxAsmFllt::type
evxChamFlltType type
fillet type, "type" cannot be equal to VX_CHAMFLLT_ASYMMETRIC
Definition: zwapi_cmd_assembly_data.h:830
svxAsmFllt::baseFace
evxAsmFlltBase baseFace
base faces option.default:VX_ASM_FLLT_BASE_SEW
Definition: zwapi_cmd_assembly_data.h:835
svxAsmFllt::density
int density
density.default:10
Definition: zwapi_cmd_assembly_data.h:834
svxAsmFllt::pEnts
svxEntPath * pEnts
the list path of entities
Definition: zwapi_cmd_assembly_data.h:838
svxAsmFllt::numEnt
int numEnt
the number of entities
Definition: zwapi_cmd_assembly_data.h:837
svxAsmFllt::undercut
int undercut
whether to search for undercuts(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:831
svxAsmFllt
assembly fillet data
Definition: zwapi_cmd_assembly_data.h:829
svxAsmMirror::AsmMirrorData::AsmDup::cat
evxAsmMirrorCategory cat
category option.default:VX_ASM_MIRROR_CAT_COPY
Definition: zwapi_cmd_assembly_data.h:803
svxAsmMirror::AsmMirrorData::AsmDup::idDatum
svxEntPath idDatum
the path of datum plane entity
Definition: zwapi_cmd_assembly_data.h:805
svxAsmMirror::AsmMirrorData::AsmDup::position
int position
whether to keep position associative(0 = no, 1 = yes).default:1
Definition: zwapi_cmd_assembly_data.h:802
svxAsmMirror::AsmMirrorData::AsmDup::symm
evxAsmMirrorSymm symm
self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ
Definition: zwapi_cmd_assembly_data.h:804
svxAsmMirror::AsmMirrorData::AsmDup::geometry
int geometry
whether to keep geometry associative(0 = no, 1 = yes).default:1
Definition: zwapi_cmd_assembly_data.h:801
svxAsmMirror::AsmMirrorData::AsmDup
duplicate type
Definition: zwapi_cmd_assembly_data.h:800
svxAsmMirror::AsmMirrorData::svxAsmCopy::atParent
int atParent
whether instances' attributes as parent(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:795
svxAsmMirror::AsmMirrorData::svxAsmCopy::idDatum
svxEntPath idDatum
the path of datum plane entity
Definition: zwapi_cmd_assembly_data.h:797
svxAsmMirror::AsmMirrorData::svxAsmCopy::whole
int whole
whether as a whole to mirror(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:794
svxAsmMirror::AsmMirrorData::svxAsmCopy::isDissolve
int isDissolve
1 if dissolve mirror relation, else 0. default:0
Definition: zwapi_cmd_assembly_data.h:793
svxAsmMirror::AsmMirrorData::svxAsmCopy::symm
evxAsmMirrorSymm symm
self-symmetric option.default:VX_ASM_MIRROR_SYMM_XZ
Definition: zwapi_cmd_assembly_data.h:796
svxAsmMirror::AsmMirrorData::svxAsmCopy
copy type
Definition: zwapi_cmd_assembly_data.h:792
svxAsmMirror::center
evxAsmMirrorCenter center
center option.default:VX_ASM_MIRROR_CTR_BOX
Definition: zwapi_cmd_assembly_data.h:788
svxAsmMirror::pEnts
svxEntPath * pEnts
list of path's of base entities
Definition: zwapi_cmd_assembly_data.h:785
svxAsmMirror::Count
int Count
number of base entities for mirror
Definition: zwapi_cmd_assembly_data.h:784
svxAsmMirror::pPlane
svxEntPath pPlane
the path of mirror plane entity
Definition: zwapi_cmd_assembly_data.h:786
svxAsmMirror::type
evxAsmMirrorType type
mirror method
Definition: zwapi_cmd_assembly_data.h:783
svxAsmMirror::erase
int erase
whether to erase source geometry(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:787
svxAsmMirror
assembly mirror data
Definition: zwapi_cmd_assembly_data.h:782
svxAsmMove::AsmMoveData::svxAsmAlignFrame::fromFrame
int fromFrame
the id of from frame entity
Definition: zwapi_cmd_assembly_data.h:757
svxAsmMove::AsmMoveData::svxAsmAlignFrame::toFrame
int toFrame
the id of to frame entity
Definition: zwapi_cmd_assembly_data.h:758
svxAsmMove::AsmMoveData::svxAsmAlignFrame
align frame
Definition: zwapi_cmd_assembly_data.h:756
svxAsmMove::AsmMoveData::svxAsmAlongDir::angle
double angle
angle.default:0
Definition: zwapi_cmd_assembly_data.h:744
svxAsmMove::AsmMoveData::svxAsmAlongDir::numCopy
int numCopy
the number of copies.default:1
Definition: zwapi_cmd_assembly_data.h:746
svxAsmMove::AsmMoveData::svxAsmAlongDir::useAng
int useAng
whether to use angle (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_assembly_data.h:745
svxAsmMove::AsmMoveData::svxAsmAlongDir::dir
svxVector dir
direction vector
Definition: zwapi_cmd_assembly_data.h:742
svxAsmMove::AsmMoveData::svxAsmAlongDir::dist
double dist
distance.default:0
Definition: zwapi_cmd_assembly_data.h:743
svxAsmMove::AsmMoveData::svxAsmAlongDir
along direction
Definition: zwapi_cmd_assembly_data.h:741
svxAsmMove::AsmMoveData::svxAsmAroundDir::angle
double angle
angle.default:0
Definition: zwapi_cmd_assembly_data.h:752
svxAsmMove::AsmMoveData::svxAsmAroundDir::numCopy
int numCopy
the number of copies.default:1
Definition: zwapi_cmd_assembly_data.h:753
svxAsmMove::AsmMoveData::svxAsmAroundDir::dir
svxVector dir
direction vector
Definition: zwapi_cmd_assembly_data.h:750
svxAsmMove::AsmMoveData::svxAsmAroundDir::location
svxPntOnEnt location
axis location
Definition: zwapi_cmd_assembly_data.h:751
svxAsmMove::AsmMoveData::svxAsmAroundDir
around direction
Definition: zwapi_cmd_assembly_data.h:749
svxAsmMove::AsmMoveData::svxAsmDynamic::yAxis
svxVector yAxis
the vector of y axis
Definition: zwapi_cmd_assembly_data.h:728
svxAsmMove::AsmMoveData::svxAsmDynamic::position
svxPntOnEnt position
the point of position
Definition: zwapi_cmd_assembly_data.h:726
svxAsmMove::AsmMoveData::svxAsmDynamic::handle
int handle
whether to move handle only (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:725
svxAsmMove::AsmMoveData::svxAsmDynamic::zAxis
svxVector zAxis
the vector of z axis
Definition: zwapi_cmd_assembly_data.h:729
svxAsmMove::AsmMoveData::svxAsmDynamic::xAxis
svxVector xAxis
the vector of x axis
Definition: zwapi_cmd_assembly_data.h:727
svxAsmMove::AsmMoveData::svxAsmDynamic
dynamic move
Definition: zwapi_cmd_assembly_data.h:724
svxAsmMove::AsmMoveData::svxAsmPnt::numToPnt
int numToPnt
the number of to points
Definition: zwapi_cmd_assembly_data.h:734
svxAsmMove::AsmMoveData::svxAsmPnt::fromVec
svxVector fromVec
from vector
Definition: zwapi_cmd_assembly_data.h:737
svxAsmMove::AsmMoveData::svxAsmPnt::fromPnt
svxPntOnEnt fromPnt
from point
Definition: zwapi_cmd_assembly_data.h:733
svxAsmMove::AsmMoveData::svxAsmPnt::toVec
svxVector toVec
to vector
Definition: zwapi_cmd_assembly_data.h:738
svxAsmMove::AsmMoveData::svxAsmPnt::useVec
int useVec
1 if use vector,else 0. default:0
Definition: zwapi_cmd_assembly_data.h:736
svxAsmMove::AsmMoveData::svxAsmPnt::toPnt
svxPntOnEnt * toPnt
the list of to points
Definition: zwapi_cmd_assembly_data.h:735
svxAsmMove::AsmMoveData::svxAsmPnt
point to point
Definition: zwapi_cmd_assembly_data.h:732
svxAsmMove::AsmMoveData::svxAsmSweep::xOrient
evxAsmMoveXOrnt xOrient
the x-orient option.default:VX_ASM_MOVE_X_NTR
Definition: zwapi_cmd_assembly_data.h:769
svxAsmMove::AsmMoveData::svxAsmSweep::numToPnt
int numToPnt
the number of to points
Definition: zwapi_cmd_assembly_data.h:763
svxAsmMove::AsmMoveData::svxAsmSweep::xAxisCrv
int xAxisCrv
the id of x-axis curve entity
Definition: zwapi_cmd_assembly_data.h:771
svxAsmMove::AsmMoveData::svxAsmSweep::idSwp
int idSwp
the id of sweep frame entity
Definition: zwapi_cmd_assembly_data.h:772
svxAsmMove::AsmMoveData::svxAsmSweep::toPnts
svxPntOnEnt * toPnts
the list of to points
Definition: zwapi_cmd_assembly_data.h:764
svxAsmMove::AsmMoveData::svxAsmSweep::spineCrv
int spineCrv
the id of spine curve entity
Definition: zwapi_cmd_assembly_data.h:767
svxAsmMove::AsmMoveData::svxAsmSweep::parallel
svxVector parallel
the vector of parallel plane
Definition: zwapi_cmd_assembly_data.h:768
svxAsmMove::AsmMoveData::svxAsmSweep::guide
svxVector guide
the vector of guide plane
Definition: zwapi_cmd_assembly_data.h:770
svxAsmMove::AsmMoveData::svxAsmSweep::frame
evxAsmMoveFrame frame
the frame option.default:VX_ASM_MOVE_FRAME_PATH
Definition: zwapi_cmd_assembly_data.h:765
svxAsmMove::AsmMoveData::svxAsmSweep::path
svxPntOnEnt path
the point of path
Definition: zwapi_cmd_assembly_data.h:762
svxAsmMove::AsmMoveData::svxAsmSweep::zSpine
evxAsmMoveZSpine zSpine
the z-spine option.default:VX_ASM_MOVE_Z_NTR
Definition: zwapi_cmd_assembly_data.h:766
svxAsmMove::AsmMoveData::svxAsmSweep
sweep
Definition: zwapi_cmd_assembly_data.h:761
svxAsmMove::idEnts
int * idEnts
list of id's of base entities
Definition: zwapi_cmd_assembly_data.h:719
svxAsmMove::type
evxAsmMoveType type
move method
Definition: zwapi_cmd_assembly_data.h:717
svxAsmMove::copy
int copy
whether to copy (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:720
svxAsmMove::Count
int Count
number of base entities for move
Definition: zwapi_cmd_assembly_data.h:718
svxAsmMove
assembly move data
Definition: zwapi_cmd_assembly_data.h:716
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::spacing
double spacing[2]
the spacing of pattern in first and second directions.default:(20,20)
Definition: zwapi_cmd_assembly_data.h:676
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::alignment
evxAsmPtnAlg alignment
the alignment method.default:VX_ASMpTN_NO_STAGGER
Definition: zwapi_cmd_assembly_data.h:680
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::fromPnt
svxPntOnEnt fromPnt
from point
Definition: zwapi_cmd_assembly_data.h:683
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::useFromPnt
int useFromPnt
1 is use fromPnt, else 0.default:0
Definition: zwapi_cmd_assembly_data.h:682
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::derive
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE
Definition: zwapi_cmd_assembly_data.h:677
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idBnd
int * idBnd
the list id of boundary entities.
Definition: zwapi_cmd_assembly_data.h:675
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::idFace
int idFace
the id of face(idFace<=0 to ignore)
Definition: zwapi_cmd_assembly_data.h:681
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::crvOption
evxAsmPtnCrv crvOption
the method of curves.default:VX_ASM_PTN_CRV1
Definition: zwapi_cmd_assembly_data.h:671
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::stagger
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_ALG_PTN
Definition: zwapi_cmd_assembly_data.h:679
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::minimum
double minimum
the minimum of derive.default:0
Definition: zwapi_cmd_assembly_data.h:678
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::numBnd
int numBnd
the number of boundary entities, if curve option is 1 curve, numBnd = 1; if curve option is 2 curves,...
Definition: zwapi_cmd_assembly_data.h:672
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv::boundary
evxAsmPtnBnd boundary
the boundary option.default:VX_ASM_PTN_BND_AUTO
Definition: zwapi_cmd_assembly_data.h:684
svxAsmPtnData::svxAsmPtn::svxAsmAtCrv
at curves pattern
Definition: zwapi_cmd_assembly_data.h:670
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::minimum
double minimum
the minimum of derive.default:0
Definition: zwapi_cmd_assembly_data.h:691
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::stagger
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_NO_STAGGER
Definition: zwapi_cmd_assembly_data.h:692
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::derive
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE
Definition: zwapi_cmd_assembly_data.h:690
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::fromPnt
svxPntOnEnt fromPnt
from point
Definition: zwapi_cmd_assembly_data.h:695
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::idFace
int idFace
the id of face
Definition: zwapi_cmd_assembly_data.h:688
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::spacing
double spacing[2]
the spacing of pattern in first and second directions.default:(20,20)
Definition: zwapi_cmd_assembly_data.h:689
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::boundary
evxAsmPtnBnd boundary
the boundary option.default:VX_ASM_PTN_BND_AUTO
Definition: zwapi_cmd_assembly_data.h:696
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::useFromPnt
int useFromPnt
1 is use fromPnt, else 0.default:0
Definition: zwapi_cmd_assembly_data.h:694
svxAsmPtnData::svxAsmPtn::svxAsmAtFace::alignment
evxAsmPtnAlg alignment
the alignment method.default:VX_ASM_PTN_ALG_PTN
Definition: zwapi_cmd_assembly_data.h:693
svxAsmPtnData::svxAsmPtn::svxAsmAtFace
at face pattern
Definition: zwapi_cmd_assembly_data.h:687
svxAsmPtnData::svxAsmPtn::svxAsmCircular::spacing
double spacing
the spacing of pattern in the directions.default:20
Definition: zwapi_cmd_assembly_data.h:652
svxAsmPtnData::svxAsmPtn::svxAsmCircular::alignment
evxAsmPtnAlg alignment
the alignment method.default:VX_ASM_PTN_NO_STAGGER
Definition: zwapi_cmd_assembly_data.h:657
svxAsmPtnData::svxAsmPtn::svxAsmCircular::angle
double angle
the angle of the direction.default:45
Definition: zwapi_cmd_assembly_data.h:653
svxAsmPtnData::svxAsmPtn::svxAsmCircular::derive
evxAsmPtnDrv derive
the method of derive.default:VX_ASM_PTN_DRV_NONE
Definition: zwapi_cmd_assembly_data.h:654
svxAsmPtnData::svxAsmPtn::svxAsmCircular::stagger
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_ALG_PTN
Definition: zwapi_cmd_assembly_data.h:656
svxAsmPtnData::svxAsmPtn::svxAsmCircular::dir
svxVector dir
first directions
Definition: zwapi_cmd_assembly_data.h:651
svxAsmPtnData::svxAsmPtn::svxAsmCircular::minimum
double minimum
the minimum of derive.default:0
Definition: zwapi_cmd_assembly_data.h:655
svxAsmPtnData::svxAsmPtn::svxAsmCircular
circular pattern
Definition: zwapi_cmd_assembly_data.h:650
svxAsmPtnData::svxAsmPtn::svxAsmLinear::dir
svxVector dir[2]
first and second directions
Definition: zwapi_cmd_assembly_data.h:644
svxAsmPtnData::svxAsmPtn::svxAsmLinear::spacing
double spacing[2]
the spacing of pattern in first and second directions.default:(20,20)
Definition: zwapi_cmd_assembly_data.h:645
svxAsmPtnData::svxAsmPtn::svxAsmLinear::stagger
evxAsmPtnStagger stagger
the method of stagger.default:VX_ASM_PTN_NO_STAGGER
Definition: zwapi_cmd_assembly_data.h:647
svxAsmPtnData::svxAsmPtn::svxAsmLinear::seedOnly
int seedOnly
whether pattern seed only.(0=no,1=yes).default:0
Definition: zwapi_cmd_assembly_data.h:646
svxAsmPtnData::svxAsmPtn::svxAsmLinear
linear pattern
Definition: zwapi_cmd_assembly_data.h:643
svxAsmPtnData::svxAsmPtn::svxAsmPattern::ptnFtrPath
svxEntPath ptnFtrPath
the path of pattern entity
Definition: zwapi_cmd_assembly_data.h:667
svxAsmPtnData::svxAsmPtn::svxAsmPattern
at pattern pattern
Definition: zwapi_cmd_assembly_data.h:666
svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::cnt
int cnt
count of toPnt
Definition: zwapi_cmd_assembly_data.h:662
svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::basePnt
svxPntOnEnt basePnt
base point
Definition: zwapi_cmd_assembly_data.h:661
svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt::toPnt
svxPntOnEnt * toPnt
to point
Definition: zwapi_cmd_assembly_data.h:663
svxAsmPtnData::svxAsmPtn::svxAsmPntToPnt
point to point pattern
Definition: zwapi_cmd_assembly_data.h:660
svxAsmPtnData::cntSkip
int cntSkip
number of the instances to be skipped
Definition: zwapi_cmd_assembly_data.h:699
svxAsmPtnData::secondTogglePos
int * secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in ...
Definition: zwapi_cmd_assembly_data.h:701
svxAsmPtnData::firstTogglePos
int * firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in t...
Definition: zwapi_cmd_assembly_data.h:700
svxAsmPtnData::ihrCons
int ihrCons
whether inherit constraints (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_assembly_data.h:638
svxAsmPtnData::idEnts
int * idEnts
list of id's of base components
Definition: zwapi_cmd_assembly_data.h:634
svxAsmPtnData::insComp
int insComp
whether instanced as component (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:637
svxAsmPtnData::Count
int Count
number of base components for pattern
Definition: zwapi_cmd_assembly_data.h:633
svxAsmPtnData::atParent
int atParent
whether is instances' attributes at parent (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:639
svxAsmPtnData::useDir
int useDir
whether to use second direction (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_assembly_data.h:635
svxAsmPtnData::num
int num[2]
the number of pattern on two directions.default:(2,1)
Definition: zwapi_cmd_assembly_data.h:636
svxAsmPtnData::type
evxAsmPatternType type
pattern method
Definition: zwapi_cmd_assembly_data.h:632
svxAsmPtnData
assembly pattern data
Definition: zwapi_cmd_assembly_data.h:631
svxClrChkData::ClrValue
double ClrValue
clearance value
Definition: zwapi_cmd_assembly_data.h:936
svxClrChkData::BaseCompPath
svxEntPath BaseCompPath
base component pick path for clearance check
Definition: zwapi_cmd_assembly_data.h:933
svxClrChkData::IferFlag
int IferFlag
flag of interference
Definition: zwapi_cmd_assembly_data.h:937
svxClrChkData::ChkCompPath
svxEntPath ChkCompPath
check component pick path for clearance check
Definition: zwapi_cmd_assembly_data.h:934
svxClrChkData::Pnt
svxPoint Pnt[2]
points of component
Definition: zwapi_cmd_assembly_data.h:935
svxClrChkData
clearance check result data
Definition: zwapi_cmd_assembly_data.h:932
svxCompData::CopyName
vxLongName CopyName
name to assign to copied part when "Copy=1" if no name is given, the default name is output
Definition: zwapi_cmd_assembly_data.h:48
svxCompData::Part
vxRootName Part
name of part to instance as a component
Definition: zwapi_cmd_assembly_data.h:39
svxCompData::Align
int Align
1 to align component with point or frame, or 0
Definition: zwapi_cmd_assembly_data.h:59
svxCompData::File
vxLongPath File
name of file that contains "Part"
Definition: zwapi_cmd_assembly_data.h:38
svxCompData::Comp
vxPath Comp
name to assign to new component in parent part set "Comp[0]=0" for default name (deprecated since zw3...
Definition: zwapi_cmd_assembly_data.h:40
svxCompData::AutoRegen
int AutoRegen
1 to regen component when parent is regen'd, or 0
Definition: zwapi_cmd_assembly_data.h:45
svxCompData::Dir
vxLongPath Dir
pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames
Definition: zwapi_cmd_assembly_data.h:35
svxCompData::CopyPart
int CopyPart
1 to copy "Part" before instancing, or 0
Definition: zwapi_cmd_assembly_data.h:63
svxCompData::Overwrite
int Overwrite
0 to automatically avoid overwriting existing part 1 to prompt whether to overwrite existing part -1 ...
Definition: zwapi_cmd_assembly_data.h:51
svxCompData::AutoDelete
int AutoDelete
1 to delete component when parent is deleted, or 0
Definition: zwapi_cmd_assembly_data.h:46
svxCompData::DestFile
vxLongPath DestFile
name of destination file if copying part If no name is given (DestFile[0]=0), the part is copied to t...
Definition: zwapi_cmd_assembly_data.h:55
svxCompData::Anchor
int Anchor
1 to anchor component, or 0
Definition: zwapi_cmd_assembly_data.h:44
svxCompData::CfgName
vxName CfgName
config name, set "CfgName[0]=0" to use active config
Definition: zwapi_cmd_assembly_data.h:64
svxCompData::Frame
svxMatrix Frame
insertion frame for new component
Definition: zwapi_cmd_assembly_data.h:43
svxCompData::AlignData
svxData AlignData
align data for point and frame align. use cvxDataGet() to get the data.
Definition: zwapi_cmd_assembly_data.h:60
svxCompData::Copy
int Copy
1 to copy "Part" before instancing, or 0
Definition: zwapi_cmd_assembly_data.h:47
svxCompData
component data
Definition: zwapi_cmd_assembly_data.h:34
svxCompIncludeData::Part
vxRootName Part
name of part to instance as a component
Definition: zwapi_cmd_assembly_data.h:76
svxCompIncludeData::CfgName
vxName CfgName
config name, set "CfgName[0]=0" to use active config
Definition: zwapi_cmd_assembly_data.h:77
svxCompIncludeData::LayName
vxName LayName
layer to insert, set "LayName[0]=0" to use active layer
Definition: zwapi_cmd_assembly_data.h:78
svxCompIncludeData::File
vxLongPath File
name of file that contains "Part", set "File[0]=0 to use current file name"
Definition: zwapi_cmd_assembly_data.h:75
svxCompIncludeData::Dir
vxLongPath Dir
pathname of directory that contains "File", set "Dir[0]=0" to search default pathnames
Definition: zwapi_cmd_assembly_data.h:73
svxCompIncludeData
include component data
Definition: zwapi_cmd_assembly_data.h:72
svxConsData::range
svxLimit range
constraint range: offset distance or constraint angle
Definition: zwapi_cmd_assembly_data.h:224
svxConsData::sameDir
int sameDir
same direction (0-default)
Definition: zwapi_cmd_assembly_data.h:225
svxConsData::useRange
int useRange
whether to apply constraint range (0-default)
Definition: zwapi_cmd_assembly_data.h:222
svxConsData::posOnly
int posOnly
only move position without creating constraint (0-default)
Definition: zwapi_cmd_assembly_data.h:226
svxConsData::value
double value
exact value: offset distance or constraint angle (0.0-default)
Definition: zwapi_cmd_assembly_data.h:223
svxConsData::lockRotation
int lockRotation
whether to lock rotation (0-default)
Definition: zwapi_cmd_assembly_data.h:227
svxConsData
custom data for assembly common constraint
Definition: zwapi_cmd_assembly_data.h:221
svxData
command input data item
Definition: zwapi_util.h:1555
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxGearConsData::ratio
double ratio
ratio value, used when type is ratio (1.0-default)
Definition: zwapi_cmd_assembly_data.h:238
svxGearConsData::ratioType
int ratioType
ratio type (0: ratio; 1: teeth; 0-default)
Definition: zwapi_cmd_assembly_data.h:237
svxGearConsData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:240
svxGearConsData::teeth
double teeth[2]
teeth, used when type is teeth (0.0-default)
Definition: zwapi_cmd_assembly_data.h:239
svxGearConsData::angle
double angle
constraint angle (0.0-default)
Definition: zwapi_cmd_assembly_data.h:236
svxGearConsData
custom data for assembly gear constraint
Definition: zwapi_cmd_assembly_data.h:235
svxGeomExport::Option
int Option
0 - add import operation to destination part. 1 - add import operation and then "encapsulate" histo...
Definition: zwapi_cmd_assembly_data.h:92
svxGeomExport::numEnts
int numEnts
number of geometry entities to export
Definition: zwapi_cmd_assembly_data.h:87
svxGeomExport::File
vxLongPath File
destination file (set File[0]=0 to use active file)
Definition: zwapi_cmd_assembly_data.h:89
svxGeomExport::Unblank
int Unblank
1 to unblank exported entities in destination part
Definition: zwapi_cmd_assembly_data.h:99
svxGeomExport::AddComponent
int AddComponent
1 to instance part as component; else 0 . For Z3PRt, it not valid
Definition: zwapi_cmd_assembly_data.h:97
svxGeomExport::Frame
svxMatrix Frame
local coordinate frame
Definition: zwapi_cmd_assembly_data.h:91
svxGeomExport::Part
vxRootName Part
name of destination part (new or existing)
Definition: zwapi_cmd_assembly_data.h:90
svxGeomExport::idEnts
int * idEnts
id's of geometry entities to export
Definition: zwapi_cmd_assembly_data.h:88
svxGeomExport::NoExportOp
int NoExportOp
1 to disable logging of "Export" operation; else 0
Definition: zwapi_cmd_assembly_data.h:98
svxGeomExport
geometry export
Definition: zwapi_cmd_assembly_data.h:86
svxIferChkResData::ChkCompPath
svxEntPath ChkCompPath
check component pick path for interference check
Definition: zwapi_cmd_assembly_data.h:922
svxIferChkResData::IferVolme
double IferVolme
volume of interference (mm^3)
Definition: zwapi_cmd_assembly_data.h:924
svxIferChkResData::BaseCompPath
svxEntPath BaseCompPath
base component pick path for interference check
Definition: zwapi_cmd_assembly_data.h:920
svxIferChkResData::BaseCompName
vxLongName BaseCompName
base component name for interference check
Definition: zwapi_cmd_assembly_data.h:921
svxIferChkResData::ChkCompName
vxLongName ChkCompName
check component name for interference check
Definition: zwapi_cmd_assembly_data.h:923
svxIferChkResData
Interference check result data.
Definition: zwapi_cmd_assembly_data.h:919
svxLimit
limits
Definition: zwapi_util.h:455
svxLinearCpData::distance
double distance[2]
distance, used when type is distance (0.0-default)
Definition: zwapi_cmd_assembly_data.h:303
svxLinearCpData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:304
svxLinearCpData::ratio
double ratio
ratio value, used when type is ratio (1.0-default)
Definition: zwapi_cmd_assembly_data.h:302
svxLinearCpData::ratioType
int ratioType
ratio type (0: ratio; 1: distance; 0-default)
Definition: zwapi_cmd_assembly_data.h:301
svxLinearCpData
custom data for assembly linear couple constraint
Definition: zwapi_cmd_assembly_data.h:300
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPartInstData::CopyWire
int CopyWire
1 to copy wireframe, or 0
Definition: zwapi_cmd_assembly_data.h:116
svxPartInstData::File
vxLongPath File
name of ZW3D file that contains "Part"
Definition: zwapi_cmd_assembly_data.h:111
svxPartInstData::Option
int Option
0 - sub-part with associative copy. 1 - sub-part with history. 2 - history copied into this part....
Definition: zwapi_cmd_assembly_data.h:118
svxPartInstData::Dir
vxLongPath Dir
pathname of directory that contains "File" set "Dir[0]=0" to search default pathnames
Definition: zwapi_cmd_assembly_data.h:108
svxPartInstData::Part
vxRootName Part
name of part that to be copied
Definition: zwapi_cmd_assembly_data.h:112
svxPartInstData::Frame
svxMatrix Frame
insertion frame for sub-part,the insert point is the original point of frame
Definition: zwapi_cmd_assembly_data.h:113
svxPartInstData::CopyDim
int CopyDim
1 to copy dimension, or 0
Definition: zwapi_cmd_assembly_data.h:117
svxPartInstData
copy external part data
Definition: zwapi_cmd_assembly_data.h:107
svxPathConsData::axisToTangent
evxAxisType axisToTangent
specify axis tangent to path (VX_AXIS_X-default)
Definition: zwapi_cmd_assembly_data.h:286
svxPathConsData::flipTangentDir
int flipTangentDir
whether to flip the tangential direction (0-default)
Definition: zwapi_cmd_assembly_data.h:287
svxPathConsData::axisToAlign
evxAxisType axisToAlign
specify axis to align to the up vector (VX_AXIS_X-default)
Definition: zwapi_cmd_assembly_data.h:291
svxPathConsData::distance
double distance
distance from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:281
svxPathConsData::upVector
svxEntPath upVector
entity to specify up vector (edge, curve, face, datum plane, point)
Definition: zwapi_cmd_assembly_data.h:290
svxPathConsData::pathConsType
evxPathConsType pathConsType
path constraint type (VX_PATH_CONS_FREE-default)
Definition: zwapi_cmd_assembly_data.h:280
svxPathConsData::flipAlignDir
int flipAlignDir
whether to flip the alignment direction (0-default)
Definition: zwapi_cmd_assembly_data.h:292
svxPathConsData::percent
double percent
distance percent from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:282
svxPathConsData::flipDim
int flipDim
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:283
svxPathConsData::rollCtrlType
evxRollCtrlType rollCtrlType
roll control type (VX_ROLL_CTRL_FREE-default)
Definition: zwapi_cmd_assembly_data.h:289
svxPathConsData::pitchYawType
evxPitchYawType pitchYawType
pitch/yaw type (VX_PITCH_YAW_FREE-default)
Definition: zwapi_cmd_assembly_data.h:285
svxPathConsData
custom data for assembly path constraint
Definition: zwapi_cmd_assembly_data.h:279
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxRackPinionData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:315
svxRackPinionData::transType
int transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)
Definition: zwapi_cmd_assembly_data.h:313
svxRackPinionData::value
double value
translate value (1.0-default)
Definition: zwapi_cmd_assembly_data.h:314
svxRackPinionData
custom data for assembly rack and pinion constraint
Definition: zwapi_cmd_assembly_data.h:312
svxScrewConsData::faceDir
int faceDir
face direction (0: opposite; 1: same facing; 0-default)
Definition: zwapi_cmd_assembly_data.h:327
svxScrewConsData::value
double value
translate value (1.0-default)
Definition: zwapi_cmd_assembly_data.h:325
svxScrewConsData::flip
int flip
whether to flip the direction (0-default)
Definition: zwapi_cmd_assembly_data.h:326
svxScrewConsData::transType
int transType
translate type (0: revolutions/distance; 1: distance/revolutions; 0-default)
Definition: zwapi_cmd_assembly_data.h:324
svxScrewConsData
custom data for assembly screw constraint
Definition: zwapi_cmd_assembly_data.h:323
svxSlotConsData::slotConsType
evxSlotConsType slotConsType
slot constraint type (VX_SLOT_CONS_FREE-default)
Definition: zwapi_cmd_assembly_data.h:348
svxSlotConsData::distance
double distance
distance from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:349
svxSlotConsData::flip
int flip
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:351
svxSlotConsData::percent
double percent
distance percent from the end of the path (0.0-default)
Definition: zwapi_cmd_assembly_data.h:350
svxSlotConsData
custom data for assembly slot constraint
Definition: zwapi_cmd_assembly_data.h:347
svxUniJointData::jointConsType
int jointConsType
universal joint constraint type (0: constant velocity; 1: variable velocity; 1-default)
Definition: zwapi_cmd_assembly_data.h:360
svxUniJointData::flip
int flip
whether to flip dimension (0-default)
Definition: zwapi_cmd_assembly_data.h:361
svxUniJointData
custom data for assembly universal joint constraint
Definition: zwapi_cmd_assembly_data.h:359
svxVector
3D vector
Definition: zwapi_util.h:338
svxAsmChmf::svxAsmChmfData
assembly chamfer data
Definition: zwapi_cmd_assembly_data.h:890
svxAsmFllt::svxAsmFlltData
union of assembly fillet data
Definition: zwapi_cmd_assembly_data.h:843
svxAsmMirror::AsmMirrorData
union of assembly Mirror data
Definition: zwapi_cmd_assembly_data.h:790
svxAsmMove::AsmMoveData
union of assembly Move data
Definition: zwapi_cmd_assembly_data.h:722
svxAsmPtnData::svxAsmPtn
union of assembly Pattern data
Definition: zwapi_cmd_assembly_data.h:641
zwapi_cmd_shape_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_GENERAL

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_GENERAL

#define VX_CODE_GENERAL 0.0

Definition at line 29 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_HEALING

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_HEALING

#define VX_CODE_HEALING 4294967296.0

Definition at line 39 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_PARTSOLUTIONS

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_PARTSOLUTIONS

#define VX_CODE_PARTSOLUTIONS 32768.0

Definition at line 43 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_WIREFRAME

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_WIREFRAME

#define VX_CODE_WIREFRAME 8589934592.0

Definition at line 34 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_DRAFTING

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_DRAFTING

#define VX_CODE_DRAFTING 4.0

Definition at line 33 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_MOLD_DESIGN

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_MOLD_DESIGN

#define VX_CODE_MOLD_DESIGN 1024.0

Definition at line 38 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_POST

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_POST

#define VX_CODE_POST 2199023255552.0

Definition at line 40 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_MODELING

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_MODELING

#define VX_CODE_MODELING 512.0

Definition at line 35 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ASSEMBLY

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ASSEMBLY

#define VX_CODE_ASSEMBLY 2.0

Definition at line 31 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ELECTRODE

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ELECTRODE

#define VX_CODE_ELECTRODE 1152921504606846976.0

Definition at line 42 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ADV_MODELING

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ADV_MODELING

#define VX_CODE_ADV_MODELING 34359738368.0

Definition at line 36 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_MISUMI

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_MISUMI

#define VX_CODE_MISUMI VX_CODE_GENERAL

Definition at line 44 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ADV_SURF

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ADV_SURF

#define VX_CODE_ADV_SURF 256.0

Definition at line 37 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_KEYSHOT

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_KEYSHOT

#define VX_CODE_KEYSHOT 576460752303423488.0

Definition at line 41 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CMD_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ ZW_API_CMD_DATA_H

#define ZW_API_CMD_DATA_H

Definition at line 17 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ADV_ASSEMBLY

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ADV_ASSEMBLY

#define VX_CODE_ADV_ASSEMBLY 17179869184.0

Definition at line 32 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: VX_CODE_ADV_RENDERING

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_data.h
evxCmdAction
evxCmdAction
evxCmdState
evxCmdState
evxCmdType
evxCmdType
evxFldNumType
evxFldNumType
evxFldType
evxFldType
svxCmdActionParam
svxFldData

◆ VX_CODE_ADV_RENDERING

#define VX_CODE_ADV_RENDERING 1.0

Definition at line 30 of file zwapi_cmd_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_CMD_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_CMD_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
28/* command license codes */
29#define VX_CODE_GENERAL 0.0
30#define VX_CODE_ADV_RENDERING 1.0
31#define VX_CODE_ASSEMBLY 2.0
32#define VX_CODE_ADV_ASSEMBLY 17179869184.0
33#define VX_CODE_DRAFTING 4.0
34#define VX_CODE_WIREFRAME 8589934592.0
35#define VX_CODE_MODELING 512.0
36#define VX_CODE_ADV_MODELING 34359738368.0
37#define VX_CODE_ADV_SURF 256.0
38#define VX_CODE_MOLD_DESIGN 1024.0
39#define VX_CODE_HEALING 4294967296.0
40#define VX_CODE_POST 2199023255552.0
41#define VX_CODE_KEYSHOT 576460752303423488.0
42#define VX_CODE_ELECTRODE 1152921504606846976.0
43#define VX_CODE_PARTSOLUTIONS 32768.0
44#define VX_CODE_MISUMI VX_CODE_GENERAL
45
50typedef enum evxCmdAction
51 {
52 VX_CMD_START = 0,
53 VX_CMD_FINISHED,
54 }evxCmdAction;
55
60typedef enum evxCmdState
61 {
62 VX_CMD_ENABLE = 0,
63 VX_CMD_DISABLE = 1,
64 } evxCmdState;
65
70typedef struct svxCmdActionParam
71 {
72 int(*pfn)(void* param, const char*);
73 void* param;
74 }svxCmdActionParam;
75
80typedef enum evxCmdType
81 {
82 VX_STANDARD_COMMAND = -1,
83 VX_HIST_GENERAL = 0,
84 VX_HIST_SOLID_CREATE = 11,
85 VX_HIST_SOLID_EDIT = 12,
86 VX_HIST_SURF_CREATE = 13,
87 VX_HIST_SURF_EDIT = 14,
88 VX_HIST_CRV_CREATE = 15,
89 VX_HIST_CRV_EDIT = 16,
90 VX_HIST_COMP = 17,
91 VX_HIST_SKETCH = 18,
92 VX_HIST_DATUM = 19,
93 VX_HIST_FILLET = 20,
94 VX_HIST_SHELL = 21,
95 VX_HIST_SHT_METAL = 22,
96 VX_HIST_HOLE = 23,
97 VX_HIST_CRV_LIST = 24,
98 VX_HIST_IMPORT = 25,
99 VX_HIST_REF_GEOM = 26,
100 VX_HIST_EQN = 27,
101 VX_HIST_HEAL = 28,
102 VX_HIST_ERASE = 29,
103 VX_HIST_BLANK = 30,
104 VX_HIST_ATTRIBUTE = 33,
105 VX_HIST_RENDER = 34,
106 VX_HIST_ANALYZE = 35,
107 VX_HIST_MOVE = 37,
108 VX_HIST_TEXT = 38,
109 VX_HIST_POINT = 39,
110 VX_HIST_DRAFT = 40,
111 VX_HIST_ASSEMBLY = 41,
112 VX_HIST_TAG = 42,
113 VX_HIST_MOLD = 43
114 } evxCmdType;
115
116//====================================================================================================================
118//====================================================================================================================
123typedef enum evxFldNumType
124 {
125 VX_INP_DOUBLE = 0,
126 VX_INP_INTEGER = 1,
127 VX_INP_DISTANCE = 2,
128 VX_INP_ANGLE = 3
129 } evxFldNumType;
130
135typedef enum evxFldType
136 {
137 VX_FLD_NULL = 0,
138 VX_FLD_NUM = 1,
139 VX_FLD_DST = 2,
140 VX_FLD_ANG = 3,
141 VX_FLD_PNT = 4,
142 VX_FLD_ENT = 5,
143 VX_FLD_TXT = 6,
144 VX_FLD_DATA = 7,
145 }evxFldType;
146
151typedef struct svxFldData
152 {
153 int fld_id;
154 vxLongName fld_name;
155 evxFldType fld_type;
156 int count;
157 svxData* fld_data;
158 }svxFldData;
159
160/*
161*********************************************************************
162** END HEADER FILE
163*********************************************************************
164*/
165
166#ifdef __cplusplus
167 }
168#endif /* __cplusplus */
169
170#endif /* ZW_API_CMD_DATA_H */
evxFldType
evxFldType
point input data types
Definition: zwapi_cmd_data.h:136
VX_FLD_NULL
@ VX_FLD_NULL
NULL if error.
Definition: zwapi_cmd_data.h:137
VX_FLD_ENT
@ VX_FLD_ENT
entity pick
Definition: zwapi_cmd_data.h:142
VX_FLD_DATA
@ VX_FLD_DATA
data container (i.e. VDATA)
Definition: zwapi_cmd_data.h:144
VX_FLD_TXT
@ VX_FLD_TXT
text
Definition: zwapi_cmd_data.h:143
VX_FLD_ANG
@ VX_FLD_ANG
angle (radians)
Definition: zwapi_cmd_data.h:140
VX_FLD_NUM
@ VX_FLD_NUM
dimensionless number
Definition: zwapi_cmd_data.h:138
VX_FLD_DST
@ VX_FLD_DST
distance (mm)
Definition: zwapi_cmd_data.h:139
VX_FLD_PNT
@ VX_FLD_PNT
3D point
Definition: zwapi_cmd_data.h:141
evxCmdState
evxCmdState
command state type
Definition: zwapi_cmd_data.h:61
VX_CMD_DISABLE
@ VX_CMD_DISABLE
command state type: disable
Definition: zwapi_cmd_data.h:63
VX_CMD_ENABLE
@ VX_CMD_ENABLE
command state type: enable
Definition: zwapi_cmd_data.h:62
evxFldNumType
evxFldNumType
numeric input field type
Definition: zwapi_cmd_data.h:124
VX_INP_ANGLE
@ VX_INP_ANGLE
angle
Definition: zwapi_cmd_data.h:128
VX_INP_DISTANCE
@ VX_INP_DISTANCE
distance
Definition: zwapi_cmd_data.h:127
VX_INP_DOUBLE
@ VX_INP_DOUBLE
double
Definition: zwapi_cmd_data.h:125
VX_INP_INTEGER
@ VX_INP_INTEGER
int
Definition: zwapi_cmd_data.h:126
evxCmdType
evxCmdType
command types
Definition: zwapi_cmd_data.h:81
VX_HIST_ASSEMBLY
@ VX_HIST_ASSEMBLY
"assembly" history operation
Definition: zwapi_cmd_data.h:111
VX_HIST_REF_GEOM
@ VX_HIST_REF_GEOM
"reference geometry" history operation
Definition: zwapi_cmd_data.h:99
VX_HIST_HOLE
@ VX_HIST_HOLE
"hole" history operation
Definition: zwapi_cmd_data.h:96
VX_HIST_SURF_CREATE
@ VX_HIST_SURF_CREATE
"surface create" history operation
Definition: zwapi_cmd_data.h:86
VX_HIST_MOLD
@ VX_HIST_MOLD
"mold design" history operation
Definition: zwapi_cmd_data.h:113
VX_HIST_CRV_EDIT
@ VX_HIST_CRV_EDIT
"curve edit" history operation
Definition: zwapi_cmd_data.h:89
VX_HIST_DATUM
@ VX_HIST_DATUM
"datum" history operation
Definition: zwapi_cmd_data.h:92
VX_HIST_SKETCH
@ VX_HIST_SKETCH
"sketch" history operation
Definition: zwapi_cmd_data.h:91
VX_HIST_SOLID_CREATE
@ VX_HIST_SOLID_CREATE
"solid create" history operation
Definition: zwapi_cmd_data.h:84
VX_HIST_TAG
@ VX_HIST_TAG
"tag" history operation
Definition: zwapi_cmd_data.h:112
VX_HIST_POINT
@ VX_HIST_POINT
"point" history operation
Definition: zwapi_cmd_data.h:109
VX_HIST_RENDER
@ VX_HIST_RENDER
"rendering" history operation
Definition: zwapi_cmd_data.h:105
VX_HIST_SURF_EDIT
@ VX_HIST_SURF_EDIT
"surface edit" history operation
Definition: zwapi_cmd_data.h:87
VX_HIST_SOLID_EDIT
@ VX_HIST_SOLID_EDIT
"solid edit" history operation
Definition: zwapi_cmd_data.h:85
VX_HIST_EQN
@ VX_HIST_EQN
"equation" history operation
Definition: zwapi_cmd_data.h:100
VX_HIST_DRAFT
@ VX_HIST_DRAFT
"draft" history operation
Definition: zwapi_cmd_data.h:110
VX_HIST_TEXT
@ VX_HIST_TEXT
"text" history operation
Definition: zwapi_cmd_data.h:108
VX_HIST_ANALYZE
@ VX_HIST_ANALYZE
"analyze" history operation
Definition: zwapi_cmd_data.h:106
VX_HIST_ERASE
@ VX_HIST_ERASE
"erase" history operation
Definition: zwapi_cmd_data.h:102
VX_HIST_COMP
@ VX_HIST_COMP
"component" history operation
Definition: zwapi_cmd_data.h:90
VX_STANDARD_COMMAND
@ VX_STANDARD_COMMAND
non-history command
Definition: zwapi_cmd_data.h:82
VX_HIST_CRV_LIST
@ VX_HIST_CRV_LIST
"curve list" history operation
Definition: zwapi_cmd_data.h:97
VX_HIST_FILLET
@ VX_HIST_FILLET
"fillet/chamfer" history operation
Definition: zwapi_cmd_data.h:93
VX_HIST_MOVE
@ VX_HIST_MOVE
"copy/move/pattern" history operation
Definition: zwapi_cmd_data.h:107
VX_HIST_HEAL
@ VX_HIST_HEAL
"heal" history operation
Definition: zwapi_cmd_data.h:101
VX_HIST_BLANK
@ VX_HIST_BLANK
"blank/unblank" history operation
Definition: zwapi_cmd_data.h:103
VX_HIST_IMPORT
@ VX_HIST_IMPORT
"import" history operation
Definition: zwapi_cmd_data.h:98
VX_HIST_GENERAL
@ VX_HIST_GENERAL
general-purpose history operation
Definition: zwapi_cmd_data.h:83
VX_HIST_SHT_METAL
@ VX_HIST_SHT_METAL
"sheet metal" history operation
Definition: zwapi_cmd_data.h:95
VX_HIST_SHELL
@ VX_HIST_SHELL
"shell" history operation
Definition: zwapi_cmd_data.h:94
VX_HIST_ATTRIBUTE
@ VX_HIST_ATTRIBUTE
"attributes" history operation
Definition: zwapi_cmd_data.h:104
VX_HIST_CRV_CREATE
@ VX_HIST_CRV_CREATE
"curve create" history operation
Definition: zwapi_cmd_data.h:88
evxCmdAction
evxCmdAction
command action type
Definition: zwapi_cmd_data.h:51
VX_CMD_FINISHED
@ VX_CMD_FINISHED
called after command finished
Definition: zwapi_cmd_data.h:53
VX_CMD_START
@ VX_CMD_START
called before command start
Definition: zwapi_cmd_data.h:52
svxFldData
struct svxFldData svxFldData
field data
svxCmdActionParam
struct svxCmdActionParam svxCmdActionParam
command action parameter
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
svxCmdActionParam::param
void * param
parameter
Definition: zwapi_cmd_data.h:73
svxCmdActionParam::pfn
int(* pfn)(void *param, const char *)
callback function, the 2nd parameter is the command name
Definition: zwapi_cmd_data.h:72
svxCmdActionParam
command action parameter
Definition: zwapi_cmd_data.h:71
svxData
command input data item
Definition: zwapi_util.h:1555
svxFldData::fld_data
svxData * fld_data
list of field data
Definition: zwapi_cmd_data.h:157
svxFldData::fld_id
int fld_id
id of field
Definition: zwapi_cmd_data.h:153
svxFldData::count
int count
number of field data
Definition: zwapi_cmd_data.h:156
svxFldData::fld_type
evxFldType fld_type
type of field
Definition: zwapi_cmd_data.h:155
svxFldData::fld_name
vxLongName fld_name
name of field (i.e. label, maybe is empty string)
Definition: zwapi_cmd_data.h:154
svxFldData
field data
Definition: zwapi_cmd_data.h:152
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DATA_EXCHANGE_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dataexchange.h
cvxPartPublishSet
cvxPartRefGeom

◆ ZW_API_DATA_EXCHANGE_FTR_H

#define ZW_API_DATA_EXCHANGE_FTR_H

Definition at line 15 of file zwapi_cmd_dataexchange.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dataexchange.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dataexchange.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DATA_EXCHANGE_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_DATA_EXCHANGE_FTR_H
16
17#include "zwapi_cmd_dataexchange_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/**********************************************************************
27*! -Import- : zwapi_file.h
28* extern evxErrors cvxFileImportInit(svxImportData* data, evxImportType type, void* general);
29* extern evxErrors cvxFileImport(svxImportData* importData);
30**********************************************************************/
31/**********************************************************************
32*! -Multi-Import- : zwapi_file.h
33* extern evxErrors cvxFileImportMulti(int Count, const vxLongName* PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void* Setting);
34**********************************************************************/
35/******************************************************************************/
63extern evxErrors cvxPartRefGeom(svxEntPath* GeomPath, int AssociativeCopy, int* idGeom);
64
65/******************************************************************************/
90extern evxErrors cvxPartPublishSet(const vxName Name, int Count, const int* idEnts, int* idPubSet);
91
92//====================================================================================================================
94//====================================================================================================================
95/**********************************************************************
96*! -Import- : zwapi_file.h
97* extern evxErrors cvxFileExportInit(evxExportType type, int imgType, void* data);
98* extern evxErrors cvxFileExport(evxExportType Type, vxPath Path, void* Data);
99**********************************************************************/
100/**********************************************************************
101*! -Import- : zwapi_file.h
102* extern evxErrors cvxFileExportMulti(int Count, const vxLongName* FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void* Data);
103**********************************************************************/
104
105/*
106*********************************************************************
107** END HEADER FILE
108*********************************************************************
109*/
110
111#ifdef V_VXAPILOC_H
112#include "api/inc/VxApiLoc.h"
113#endif
114
115#ifdef __cplusplus
116 }
117#endif /* __cplusplus */
118
119#endif /* ZW_API_DATA_EXCHANGE_FTR_H */
cvxPartRefGeom
evxErrors cvxPartRefGeom(svxEntPath *GeomPath, int AssociativeCopy, int *idGeom)
cvxPartPublishSet
evxErrors cvxPartPublishSet(const vxName Name, int Count, const int *idEnts, int *idPubSet)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
zwapi_cmd_dataexchange_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DATA_EXCHANGE_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dataexchange_data.h

◆ ZW_API_DATA_EXCHANGE_FTR_DATA_H

#define ZW_API_DATA_EXCHANGE_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_dataexchange_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dataexchange_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dataexchange_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_DATA_EXCHANGE_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_DATA_EXCHANGE_FTR_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25/*
26*********************************************************************
27** END HEADER FILE
28*********************************************************************
29*/
30#ifdef __cplusplus
31 }
32#endif /* __cplusplus */
33
34#endif /* ZW_API_DATA_EXCHANGE_FTR_DATA_H */
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DATUM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_datum.h
cvxPartActiveAsLCS
cvxPartAxisNew
cvxPartCSYSNew
cvxPartCSYSNewInit
cvxPartDatum
cvxPartDatum2
cvxPartNewDatum
cvxPartPlaneAdd
cvxPartPlaneAddInit
cvxPartPlaneNew
cvxPartPlnCrv
cvxPartPlnCrv2
cvxPartPlnSrf
cvxPartPlnSrf2

◆ ZW_API_DATUM_H

#define ZW_API_DATUM_H

Definition at line 15 of file zwapi_cmd_datum.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_datum.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_datum.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DATUM_H /* this ifndef surrounds entire header */
15#define ZW_API_DATUM_H
16
17#include "zwapi_cmd_datum_data.h"
18
19/*
20*********************************************************************
21*! Command of Datum
22*********************************************************************
23*/
24#ifdef __cplusplus
25extern "C" {
26#endif /* __cplusplus */
27
28//====================================================================================================================
30//====================================================================================================================
31/******************************************************************************/
54extern evxErrors cvxPartAxisNew(svxAxisData* Axis, int* idAxis);
55
56//====================================================================================================================
58//====================================================================================================================
59/******************************************************************************/
82extern evxErrors cvxPartDatum(svxMatrix* Frame, int* idDatum);
83
84/******************************************************************************/
106extern evxErrors cvxPartDatum2(svxMatrix* Frame, int iCode, int* idDatum);
107
108/******************************************************************************/
128extern evxErrors cvxPartNewDatum(svxMatrix* Frame, int* idDatum);
129
130/******************************************************************************/
158extern evxErrors cvxPartPlnCrv(int idCrv, svxPoint* Origin, svxPoint* Xaxis, int* idPln);
159
160/******************************************************************************/
202extern evxErrors cvxPartPlnCrv2(int idCrv, svxData* Origin, svxData* Xaxis, int Flip, int* idPln);
203
204/******************************************************************************/
226extern evxErrors cvxPartPlnSrf(int idFace, svxPoint* Origin, int* idPln);
227
228/******************************************************************************/
261extern evxErrors cvxPartPlnSrf2(int idFace, svxPoint* Origin, svxPoint* XZ, int Flip, int* idPln);
262
263/******************************************************************************/
284extern evxErrors cvxPartPlaneNew(svxPlaneData* Plane, int* idPlane);
285
286/******************************************************************************/
304extern evxErrors cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
305
306/******************************************************************************/
332extern evxErrors cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
333
334//====================================================================================================================
336//====================================================================================================================
337/******************************************************************************/
355extern evxErrors cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
356
357/******************************************************************************/
380extern evxErrors cvxPartCSYSNew(svxCSYSData* CSYS, int* idCSYS);
381
382//====================================================================================================================
384//====================================================================================================================
385/******************************************************************************/
401extern evxErrors cvxPartActiveAsLCS(int id);
402
403/*
404*********************************************************************
405** END HEADER FILE
406*********************************************************************
407*/
408#ifdef __cplusplus
409 }
410#endif /* __cplusplus */
411
412#endif /* ZW_API_DATUM_H */
evxNewPlaneMethods
evxNewPlaneMethods
New Plane Methods.
Definition: zwapi_cmd_datum_data.h:182
evxCSYSMethods
evxCSYSMethods
CSYS Methods.
Definition: zwapi_cmd_datum_data.h:322
cvxPartPlaneNew
evxErrors cvxPartPlaneNew(svxPlaneData *Plane, int *idPlane)
cvxPartPlnCrv
evxErrors cvxPartPlnCrv(int idCrv, svxPoint *Origin, svxPoint *Xaxis, int *idPln)
cvxPartNewDatum
evxErrors cvxPartNewDatum(svxMatrix *Frame, int *idDatum)
cvxPartPlnSrf2
evxErrors cvxPartPlnSrf2(int idFace, svxPoint *Origin, svxPoint *XZ, int Flip, int *idPln)
cvxPartCSYSNew
evxErrors cvxPartCSYSNew(svxCSYSData *CSYS, int *idCSYS)
cvxPartPlnSrf
evxErrors cvxPartPlnSrf(int idFace, svxPoint *Origin, int *idPln)
cvxPartCSYSNewInit
evxErrors cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData *data)
cvxPartDatum
evxErrors cvxPartDatum(svxMatrix *Frame, int *idDatum)
cvxPartDatum2
evxErrors cvxPartDatum2(svxMatrix *Frame, int iCode, int *idDatum)
cvxPartActiveAsLCS
evxErrors cvxPartActiveAsLCS(int id)
cvxPartPlnCrv2
evxErrors cvxPartPlnCrv2(int idCrv, svxData *Origin, svxData *Xaxis, int Flip, int *idPln)
cvxPartAxisNew
evxErrors cvxPartAxisNew(svxAxisData *Axis, int *idAxis)
cvxPartPlaneAdd
evxErrors cvxPartPlaneAdd(const svxNewPlaneData *plane, int *idPlane)
cvxPartPlaneAddInit
evxErrors cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData *data)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAxisData
template command Axis input data
Definition: zwapi_cmd_datum_data.h:50
svxCSYSData
template command CSYS input data
Definition: zwapi_cmd_datum_data.h:348
svxData
command input data item
Definition: zwapi_util.h:1555
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxNewPlaneData
New template command Plane input data.
Definition: zwapi_cmd_datum_data.h:209
svxPlaneData
template command Plane input data
Definition: zwapi_cmd_datum_data.h:121
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_cmd_datum_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DATUM_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_datum_data.h
evsResultsAxisMethod
evsResultsAxisMethod
evxAxisMethods
evxAxisMethods
evxCSYSMethods
evxCSYSMethods
evxNewPlaneMethods
evxNewPlaneMethods
evxOnCrvDirType
evxOnCrvDirType
evxPlaneAlign
evxPlaneAlign
evxPlaneMethods
evxPlaneMethods
svxAxisData
svxCSYSData
svxNewPlaneData
svxPlaneData

◆ ZW_API_DATUM_DATA_H

#define ZW_API_DATUM_DATA_H

Definition at line 17 of file zwapi_cmd_datum_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_datum_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_datum_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_DATUM_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_DATUM_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_subcmd_data.h"
21
22#ifdef __cplusplus
23extern "C" {
24#endif /* __cplusplus */
25
26//====================================================================================================================
28//====================================================================================================================
33typedef enum evxAxisMethods
34 {
35 VX_AXIS_GEOMETRY = 0,
36 VX_AXIS_FACE_CENTER = 1,
37 VX_AXIS_XX = 2,
38 VX_AXIS_YY = 3,
39 VX_AXIS_ZZ = 4,
40 VX_AXIS_TWO_PNT = 5,
41 VX_AXIS_PNT_DIR = 6,
42 VX_AXIS_INTERSECT_FACES = 7,
43 } evxAxisMethods;
44
49typedef struct svxAxisData
50 {
51 double length;
52 evxAxisMethods method;
53 union evxAxisInpUnion
54 {
55 struct AxisPntAndDir
56 {
57 int idOrgPnt;
58 svxPoint OrgPnt;
59 svxVector Dir;
60 } pntDir;
61 struct AxisGeomPnt
62 {
63 svxPoint Pnt;
64 svxEntPath Path;
65 } geomPnt;
66 struct AxisFaceCenter
67 {
68 svxEntPath Face;
69 } facCenter;
70 struct AxisIntersectFaces
71 {
72 svxEntPath Face1;
73 svxEntPath Face2;
74 } interFaces;
75 struct AxisTwoPnts
76 {
77 int idPnt1;
78 svxPoint Pnt1;
79 int idPnt2;
80 svxPoint Pnt2;
81 } twoPnts;
82 } inpUnion;
83 int FlipDir;
84 } svxAxisData;
85
86//====================================================================================================================
88//====================================================================================================================
93typedef enum evxPlaneMethods
94 {
95 VX_PLANE_GEOMETRY = 0,
96 VX_PLANE_THREE_POINTS = 1,
97 VX_PLANE_XY = 2,
98 VX_PLANE_XZ = 3,
99 VX_PLANE_YZ = 4,
100 VX_PLANE_VIEW_PLANE = 5,
101 VX_PLANE_TWO_ENTITIES = 6,
102 VX_PLANE_DYNAMIC = 7,
103 } evxPlaneMethods;
104
109typedef enum evxPlaneAlign
110 {
111 VX_PLANE_ALIGN_TO_XY = 1,
112 VX_PLANE_ALIGN_TO_XZ = 2,
113 VX_PLANE_ALIGN_TO_YZ = 3,
114 } evxPlaneAlign;
115
120typedef struct svxPlaneData
121 {
122 evxPlaneMethods method;
123 union evxPlnInpUnion
124 {
125 struct PlnGeomPnt
126 {
127 svxPoint Pnt;
128 svxEntPath Path;
129 }geomPnt;
130 struct PlnThreePnts
131 {
132 int idOrgPnt;
133 svxPoint OrgPnt;
134 int idXPnt;
135 svxPoint XPnt;
136 int idYPnt;
137 svxPoint YPnt;
138 } threePnts;
139 struct PlaneXYZ
140 {
141 double Offset;
142 }xyz;
143 struct viewPlane
144 {
145 svxPoint OrgPnt;
146 } viewPln;
147 struct PlnTwoEnts
148 {
149 int idEnt1;
150 svxPoint Ent1Pnt;
151 int idEnt2;
152 svxPoint Ent2Pnt;
153 } twoEnts;
154 struct PlnDynamic
155 {
156 int idPosPnt;
157 svxPoint PosPnt;
158 svxVector XAxis;
159 svxVector YAxis;
160 svxVector ZAxis;
161 } dynamic;
162 } inpUnion;
163
164 evxPlaneAlign AlignType;
166 /* the follows can be set according to the requirements(Orientation) */
167 double dOffset;
168 int idOrgPnt;
169 svxPoint OrgPnt;
170 int idXPnt;
171 svxPoint XPnt;
172 double XAng;
173 double YAng;
174 double ZAng;
175 } svxPlaneData;
176
181typedef enum evxNewPlaneMethods
182 {
183 VX_NEW_PLANE_THREE_POINTS = 1,
184 VX_NEW_PLANE_VIEW_PLANE = 5,
185 VX_NEW_PLANE_DYNAMIC = 7,
186 VX_NEW_PLANE_GEOMETRY = 11,
187 VX_NEW_PLANE_OFFSET_PLANE = 12,
188 VX_NEW_PLANE_ANGLE_FACE = 13,
189 VX_NEW_PLANE_ON_CURVE = 14,
190 }evxNewPlaneMethods;
191
196typedef enum evxOnCrvDirType
197 {
198 VX_ONCRV_TANGENT,
199 VX_ONCRV_PERPENDICULAR,
200 VX_ONCRV_PERPENDICULAR_TO_CURVE,
201 VX_ONCRV_TANGENT_TO_CURVE,
202 } evxOnCrvDirType;
203
208typedef struct svxNewPlaneData
209 {
210 evxNewPlaneMethods method;
211 union evxNewPlaneMethodsUnion
212 {
213 struct NewPlaneGeometry
214 {
215 /* Use (cnt, pnts, paths) if input multiple entities */
216 svxPoint pnt;
217 svxEntPath path;
219 /* don't need to set pnts and paths if cnt = 0 or use pnt and path to set "Geometry"
220 (suggest to use the following variables, pnt and path may be deprecated in the next version) */
221 int cnt;
222 svxPoint* pnts;
223 svxEntPath* paths;
225 /* Results */
226 double offset;
227 double angle;
228 } geom;
229 struct NewPlaneThreePnt
230 {
231 svxPoint orgPnt;
232 svxPntByOffset* orgPntByOffset;
235 svxPntBy2Lines* orgPntBy2Lines;
238 svxPoint xPnt;
239 svxPntByOffset* xPntByOffset;
242 svxPntBy2Lines* xPntBy2Lines;
245 svxPoint yPnt;
246 svxPntByOffset* yPntByOffset;
249 svxPntBy2Lines* yPntBy2Lines;
251 } threePnts;
252 struct NewviewPlane
253 {
254 svxPoint orgPnt;
255 svxPntByOffset* orgPntByOffset;
258 svxPntBy2Lines* orgPntBy2Lines;
260 } view;
261 struct NewPlaneDynamic
262 {
263 svxPoint posPnt;
264 svxPntByOffset* posPntByOffset;
267 svxPntBy2Lines* posPntBy2Lines;
269 svxVector xAxis;
270 svxVector yAxis;
271 svxVector zAxis;
272 int autoOrient;
273 } dynamic;
274 struct NewPlaneOffset
275 {
276 svxPoint orgPnt;
277 svxEntPath path;
278 double offset;
279 } pOffset;
280 struct NewPlaneAngToFc
281 {
282 svxPoint orgPnt;
283 svxEntPath path;
284 svxPoint axis;
285 svxEntPath linePath;
286 double angle;
287 } angToFc;
288 struct NewPlaneOnCurve
289 {
290 svxPoint orgPnt;
291 svxEntPath path;
292 int isPercent;
293 double num;
294 evxOnCrvDirType dirType;
295 svxEntPath CrvPath;
296 } onCrv;
297 } inpUnion;
298
299 /* if "methods" = VX_NEW_PLANE_DYNAMIC, the following variables will not be applied. */
300 int isFlipDir;
305 /* the follows can be set according to the requirements(Orientation) */
306 double dOffset;
307 svxPoint* orgPnt;
308 svxPoint* xPoint;
309 double xAng;
310 double yAng;
311 double zAng;
312 } svxNewPlaneData;
313
314//====================================================================================================================
316//====================================================================================================================
321typedef enum evxCSYSMethods
322 {
323 VX_CSYS_THREE_POINTS = 1,
324 VX_CSYS_ONLY_MATRIX = 6,
325 VX_CSYS_DYNAMIC = 7,
326 VX_CSYS_THREE_FACES = 8,
327 VX_CSYS_PNT_AND_TWO_DIR = 9,
328 VX_CSYS_PLANE_PNT_AND_DIR = 10,
329 VX_CSYS_GEOMETRY = 11,
330 } evxCSYSMethods;
331
336typedef enum evsResultsAxisMethod
337 {
338 VX_RESULTS_AXIS_X,
339 VX_RESULTS_AXIS_Y,
340 VX_RESULTS_AXIS_Z,
341 } evsResultsAxisMethod;
342
347typedef struct svxCSYSData
348 {
349 svxMatrix Frame;
350 evxCSYSMethods method;
351 union evxCSYSInpUnion
352 {
353 struct CSYSByGeom
354 {
355 /* Use (cnt, OrgPnts, Paths) if input multiple entities */
356 svxPoint OrgPnt;
357 svxEntPath Path;
359 /* don't need to set OrgPnts and Paths if cnt = 0 or use OrgPnt and Path to set "Entities"
360 (suggest to use the following variables, OrgPnt and Path may be deprecated in the next version) */
361 int cnt;
362 svxPoint* OrgPnts;
363 svxEntPath* Paths;
365 /* offset data when select a CSYS as input */
366 int offsetFirst;
367 double xOffset;
368 double yOffset;
369 double zOffset;
371 /* the position of axes when select edges or faces */
372 evsResultsAxisMethod firstAxis;
373 evsResultsAxisMethod secondAxis;
374 } byGeom;
375 struct CSYSThreePnts
376 {
377 int idOrgPnt;
378 svxPoint OrgPnt;
379 svxPntByOffset* OrgPntByOffset;
382 svxPntBy2Lines* OrgPntBy2Lines;
385 int idPnt1;
386 svxPoint Pnt1;
387 svxPntByOffset* Pnt1ByOffset;
390 svxPntBy2Lines* Pnt1By2Lines;
392 evsResultsAxisMethod firstAxis;
393 int isFlip1;
395 int idPnt2;
396 svxPoint Pnt2;
397 svxPntByOffset* Pnt2ByOffset;
400 svxPntBy2Lines* Pnt2By2Lines;
402 evsResultsAxisMethod secondAxis;
403 int isFlip2;
404 } threePnts;
405 struct CSYSThreeFaces
406 {
407 svxEntPath Face1;
408 evsResultsAxisMethod axis1;
409 int isFlip1;
411 svxEntPath Face2;
412 evsResultsAxisMethod axis2;
413 int isFlip2;
415 svxEntPath Face3;
416 evsResultsAxisMethod axis3;
417 } threeFaces;
418 struct CSYSPntAnd2Dir
419 {
420 /* set origin point */
421 int idOrgPnt;
422 svxPoint OrgPnt;
424 svxPntByOffset* OrgPntByOffset;
427 svxPntBy2Lines* OrgPntBy2Lines;
429 /* set first direction */
430 svxVector Dir1;
431 svxPntOnEnt DirOnEnt1;
432 evsResultsAxisMethod axis1;
434 /* set second direction */
435 svxVector Dir2;
436 svxPntOnEnt DirOnEnt2;
437 evsResultsAxisMethod axis2;
438 } pntAnd2Dir;
439 struct CSYSPlanAndDir
440 {
441 svxEntPath Face;
442 evsResultsAxisMethod axisFc;
443 int isFlipFc;
444 int idPnt;
445 svxPoint Pnt;
446 svxPntByOffset* PntByOffset;
449 svxPntBy2Lines* PntBy2Lines;
451 svxVector Dir;
452 svxPntOnEnt DirOnEnt;
453 evsResultsAxisMethod axisDir;
454 } PlanAndDir;
455 struct CSYSDynamic
456 {
457 int idPosPnt;
458 svxPoint PosPnt;
459 svxPntByOffset* PosPntByOffset;
462 svxPntBy2Lines* PosPntBy2Lines;
464 svxVector Xaxis;
465 svxVector Yaxis;
466 svxVector Zaxis;
467 int isAutoOrint;
468 } dynamic;
469 } inpUnion;
470
471 /* the follows can be set according to the requirements(Orientation) */
472 double dOffset;
473 int idOrgPnt;
474 svxPoint OrgPnt;
475 int idXPnt;
476 svxPoint XPnt;
477 double XAng;
478 double YAng;
479 double ZAng;
480 } svxCSYSData;
481
482/*
483*********************************************************************
484** END HEADER FILE
485*********************************************************************
486*/
487
488#ifdef __cplusplus
489 }
490#endif /* __cplusplus */
491
492#endif /* ZW_API_DATUM_DATA_H */
evxNewPlaneMethods
evxNewPlaneMethods
New Plane Methods.
Definition: zwapi_cmd_datum_data.h:182
VX_NEW_PLANE_VIEW_PLANE
@ VX_NEW_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:184
VX_NEW_PLANE_GEOMETRY
@ VX_NEW_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:186
VX_NEW_PLANE_ON_CURVE
@ VX_NEW_PLANE_ON_CURVE
on curve
Definition: zwapi_cmd_datum_data.h:189
VX_NEW_PLANE_ANGLE_FACE
@ VX_NEW_PLANE_ANGLE_FACE
angle to face
Definition: zwapi_cmd_datum_data.h:188
VX_NEW_PLANE_THREE_POINTS
@ VX_NEW_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:183
VX_NEW_PLANE_OFFSET_PLANE
@ VX_NEW_PLANE_OFFSET_PLANE
offset plane
Definition: zwapi_cmd_datum_data.h:187
VX_NEW_PLANE_DYNAMIC
@ VX_NEW_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:185
evsResultsAxisMethod
evsResultsAxisMethod
Results axis.
Definition: zwapi_cmd_datum_data.h:337
VX_RESULTS_AXIS_Y
@ VX_RESULTS_AXIS_Y
Y direction.
Definition: zwapi_cmd_datum_data.h:339
VX_RESULTS_AXIS_X
@ VX_RESULTS_AXIS_X
X direction.
Definition: zwapi_cmd_datum_data.h:338
VX_RESULTS_AXIS_Z
@ VX_RESULTS_AXIS_Z
Z direction.
Definition: zwapi_cmd_datum_data.h:340
evxPlaneAlign
evxPlaneAlign
Plane Orientation Align type.
Definition: zwapi_cmd_datum_data.h:110
VX_PLANE_ALIGN_TO_XZ
@ VX_PLANE_ALIGN_TO_XZ
align to XZ of geometry frame
Definition: zwapi_cmd_datum_data.h:112
VX_PLANE_ALIGN_TO_YZ
@ VX_PLANE_ALIGN_TO_YZ
align to YZ of geometry frame
Definition: zwapi_cmd_datum_data.h:113
VX_PLANE_ALIGN_TO_XY
@ VX_PLANE_ALIGN_TO_XY
align to XY of geometry frame
Definition: zwapi_cmd_datum_data.h:111
evxPlaneMethods
evxPlaneMethods
Plane Methods.
Definition: zwapi_cmd_datum_data.h:94
VX_PLANE_DYNAMIC
@ VX_PLANE_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:102
VX_PLANE_XY
@ VX_PLANE_XY
XY Plane.
Definition: zwapi_cmd_datum_data.h:97
VX_PLANE_VIEW_PLANE
@ VX_PLANE_VIEW_PLANE
view plane
Definition: zwapi_cmd_datum_data.h:100
VX_PLANE_GEOMETRY
@ VX_PLANE_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:95
VX_PLANE_YZ
@ VX_PLANE_YZ
YZ Plane.
Definition: zwapi_cmd_datum_data.h:99
VX_PLANE_XZ
@ VX_PLANE_XZ
XZ Plane.
Definition: zwapi_cmd_datum_data.h:98
VX_PLANE_TWO_ENTITIES
@ VX_PLANE_TWO_ENTITIES
two entities
Definition: zwapi_cmd_datum_data.h:101
VX_PLANE_THREE_POINTS
@ VX_PLANE_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:96
evxOnCrvDirType
evxOnCrvDirType
Plane direction type.
Definition: zwapi_cmd_datum_data.h:197
VX_ONCRV_TANGENT_TO_CURVE
@ VX_ONCRV_TANGENT_TO_CURVE
tangent to curve
Definition: zwapi_cmd_datum_data.h:201
VX_ONCRV_PERPENDICULAR_TO_CURVE
@ VX_ONCRV_PERPENDICULAR_TO_CURVE
perpendicular to curve
Definition: zwapi_cmd_datum_data.h:200
VX_ONCRV_TANGENT
@ VX_ONCRV_TANGENT
tangent
Definition: zwapi_cmd_datum_data.h:198
VX_ONCRV_PERPENDICULAR
@ VX_ONCRV_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_datum_data.h:199
evxCSYSMethods
evxCSYSMethods
CSYS Methods.
Definition: zwapi_cmd_datum_data.h:322
VX_CSYS_THREE_FACES
@ VX_CSYS_THREE_FACES
three faces
Definition: zwapi_cmd_datum_data.h:326
VX_CSYS_GEOMETRY
@ VX_CSYS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:329
VX_CSYS_DYNAMIC
@ VX_CSYS_DYNAMIC
dynamic
Definition: zwapi_cmd_datum_data.h:325
VX_CSYS_PLANE_PNT_AND_DIR
@ VX_CSYS_PLANE_PNT_AND_DIR
plane point and direction
Definition: zwapi_cmd_datum_data.h:328
VX_CSYS_ONLY_MATRIX
@ VX_CSYS_ONLY_MATRIX
only input CSYS matrix
Definition: zwapi_cmd_datum_data.h:324
VX_CSYS_PNT_AND_TWO_DIR
@ VX_CSYS_PNT_AND_TWO_DIR
point and two directions
Definition: zwapi_cmd_datum_data.h:327
VX_CSYS_THREE_POINTS
@ VX_CSYS_THREE_POINTS
three points
Definition: zwapi_cmd_datum_data.h:323
evxAxisMethods
evxAxisMethods
Axis Methods.
Definition: zwapi_cmd_datum_data.h:34
VX_AXIS_GEOMETRY
@ VX_AXIS_GEOMETRY
geometry
Definition: zwapi_cmd_datum_data.h:35
VX_AXIS_INTERSECT_FACES
@ VX_AXIS_INTERSECT_FACES
intersect faces
Definition: zwapi_cmd_datum_data.h:42
VX_AXIS_TWO_PNT
@ VX_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_datum_data.h:40
VX_AXIS_FACE_CENTER
@ VX_AXIS_FACE_CENTER
face center axis
Definition: zwapi_cmd_datum_data.h:36
VX_AXIS_YY
@ VX_AXIS_YY
Y Axis.
Definition: zwapi_cmd_datum_data.h:38
VX_AXIS_PNT_DIR
@ VX_AXIS_PNT_DIR
point and Direction
Definition: zwapi_cmd_datum_data.h:41
VX_AXIS_XX
@ VX_AXIS_XX
X Axis.
Definition: zwapi_cmd_datum_data.h:37
VX_AXIS_ZZ
@ VX_AXIS_ZZ
Z Axis.
Definition: zwapi_cmd_datum_data.h:39
svxAxisData
struct svxAxisData svxAxisData
template command Axis input data
svxNewPlaneData
struct svxNewPlaneData svxNewPlaneData
New template command Plane input data.
svxCSYSData
struct svxCSYSData svxCSYSData
template command CSYS input data
svxPlaneData
struct svxPlaneData svxPlaneData
template command Plane input data
svxAxisData::evxAxisInpUnion::AxisFaceCenter::Face
svxEntPath Face
face
Definition: zwapi_cmd_datum_data.h:68
svxAxisData::evxAxisInpUnion::AxisFaceCenter
face center Axis
Definition: zwapi_cmd_datum_data.h:67
svxAxisData::evxAxisInpUnion::AxisGeomPnt::Path
svxEntPath Path
entity/object pick path
Definition: zwapi_cmd_datum_data.h:64
svxAxisData::evxAxisInpUnion::AxisGeomPnt::Pnt
svxPoint Pnt
picked Point
Definition: zwapi_cmd_datum_data.h:63
svxAxisData::evxAxisInpUnion::AxisGeomPnt
geometry
Definition: zwapi_cmd_datum_data.h:62
svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face2
svxEntPath Face2
2nd face
Definition: zwapi_cmd_datum_data.h:73
svxAxisData::evxAxisInpUnion::AxisIntersectFaces::Face1
svxEntPath Face1
1st face
Definition: zwapi_cmd_datum_data.h:72
svxAxisData::evxAxisInpUnion::AxisIntersectFaces
intersect faces
Definition: zwapi_cmd_datum_data.h:71
svxAxisData::evxAxisInpUnion::AxisPntAndDir::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:58
svxAxisData::evxAxisInpUnion::AxisPntAndDir::Dir
svxVector Dir
direction
Definition: zwapi_cmd_datum_data.h:59
svxAxisData::evxAxisInpUnion::AxisPntAndDir::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:57
svxAxisData::evxAxisInpUnion::AxisPntAndDir
point and direction
Definition: zwapi_cmd_datum_data.h:56
svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt2
svxPoint Pnt2
2nd point
Definition: zwapi_cmd_datum_data.h:80
svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt2
int idPnt2
id of the point2 parent entity
Definition: zwapi_cmd_datum_data.h:79
svxAxisData::evxAxisInpUnion::AxisTwoPnts::idPnt1
int idPnt1
id of the point1 parent entity
Definition: zwapi_cmd_datum_data.h:77
svxAxisData::evxAxisInpUnion::AxisTwoPnts::Pnt1
svxPoint Pnt1
1st point
Definition: zwapi_cmd_datum_data.h:78
svxAxisData::evxAxisInpUnion::AxisTwoPnts
Two Points.
Definition: zwapi_cmd_datum_data.h:76
svxAxisData::length
double length
axis length
Definition: zwapi_cmd_datum_data.h:51
svxAxisData::FlipDir
int FlipDir
flip direction
Definition: zwapi_cmd_datum_data.h:83
svxAxisData::method
evxAxisMethods method
axis methods
Definition: zwapi_cmd_datum_data.h:52
svxAxisData
template command Axis input data
Definition: zwapi_cmd_datum_data.h:50
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnt
svxPoint OrgPnt
Origin point.
Definition: zwapi_cmd_datum_data.h:356
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::cnt
int cnt
count of OrgPnts and Paths.
Definition: zwapi_cmd_datum_data.h:361
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::zOffset
double zOffset
z offset
Definition: zwapi_cmd_datum_data.h:369
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::OrgPnts
svxPoint * OrgPnts
origin points
Definition: zwapi_cmd_datum_data.h:362
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::offsetFirst
int offsetFirst
0 is offset first,else 1.default:0
Definition: zwapi_cmd_datum_data.h:366
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Path
svxEntPath Path
entity/object pick path
Definition: zwapi_cmd_datum_data.h:357
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::yOffset
double yOffset
y offset
Definition: zwapi_cmd_datum_data.h:368
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::Paths
svxEntPath * Paths
entity/object pick paths
Definition: zwapi_cmd_datum_data.h:363
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::xOffset
double xOffset
x offset
Definition: zwapi_cmd_datum_data.h:367
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::firstAxis
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:372
svxCSYSData::evxCSYSInpUnion::CSYSByGeom::secondAxis
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:373
svxCSYSData::evxCSYSInpUnion::CSYSByGeom
geometry
Definition: zwapi_cmd_datum_data.h:354
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Xaxis
svxVector Xaxis
A axis.
Definition: zwapi_cmd_datum_data.h:464
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Zaxis
svxVector Zaxis
Z axis.
Definition: zwapi_cmd_datum_data.h:466
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::idPosPnt
int idPosPnt
id of the position parent entity
Definition: zwapi_cmd_datum_data.h:457
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::isAutoOrint
int isAutoOrint
1 is auto orientation,else 0.default:1
Definition: zwapi_cmd_datum_data.h:467
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntBy2Lines
svxPntBy2Lines * PosPntBy2Lines
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntByOffset) c...
Definition: zwapi_cmd_datum_data.h:462
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPntByOffset
svxPntByOffset * PosPntByOffset
set the position point by the offset sub-command (NULL to use (idPosPnt, PosPnt) or PosPntBy2Lines) c...
Definition: zwapi_cmd_datum_data.h:459
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::Yaxis
svxVector Yaxis
Y axis.
Definition: zwapi_cmd_datum_data.h:465
svxCSYSData::evxCSYSInpUnion::CSYSDynamic::PosPnt
svxPoint PosPnt
position point
Definition: zwapi_cmd_datum_data.h:458
svxCSYSData::evxCSYSInpUnion::CSYSDynamic
dynamic
Definition: zwapi_cmd_datum_data.h:456
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Face
svxEntPath Face
face
Definition: zwapi_cmd_datum_data.h:441
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::DirOnEnt
svxPntOnEnt DirOnEnt
direction."DirOnEnt.useDir" has to be equal to 1."DirOnEnt.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:452
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntByOffset
svxPntByOffset * PntByOffset
set the point by the offset sub-command (NULL to use (idPnt, Pnt) or PntBy2Lines) cvxPartPntByOffsetI...
Definition: zwapi_cmd_datum_data.h:446
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Pnt
svxPoint Pnt
point
Definition: zwapi_cmd_datum_data.h:445
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::Dir
svxVector Dir
direction, can use "DirOnEnt" to set the direction on the specified entity and flip the direction,...
Definition: zwapi_cmd_datum_data.h:451
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::idPnt
int idPnt
id of the point parent entity
Definition: zwapi_cmd_datum_data.h:444
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::isFlipFc
int isFlipFc
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:443
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisFc
evsResultsAxisMethod axisFc
axis(default:VX_RESULTS_AXIS_Z)
Definition: zwapi_cmd_datum_data.h:442
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::PntBy2Lines
svxPntBy2Lines * PntBy2Lines
set the point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or PntByOffset) cvxPartPntBy2...
Definition: zwapi_cmd_datum_data.h:449
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir::axisDir
evsResultsAxisMethod axisDir
axis(default:VX_RESULTS_AXIS_X).The two axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:453
svxCSYSData::evxCSYSInpUnion::CSYSPlanAndDir
Plane and direction.
Definition: zwapi_cmd_datum_data.h:440
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis2
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y).The two axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:437
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:421
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt2
svxPntOnEnt DirOnEnt2
direction2."DirOnEnt2.useDir" has to be equal to 1."DirOnEnt2.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:436
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir1
svxVector Dir1
direction1, can use "DirOnEnt1" to set the direction1 on the specified entity and flip the direction,...
Definition: zwapi_cmd_datum_data.h:430
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::axis1
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:432
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::DirOnEnt1
svxPntOnEnt DirOnEnt1
direction1."DirOnEnt1.useDir" has to be equal to 1."DirOnEnt1.flipDir" can be set to reverse.
Definition: zwapi_cmd_datum_data.h:431
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::Dir2
svxVector Dir2
direction2, can use "DirOnEnt2" to set the direction2 on the specified entity and flip the direction,...
Definition: zwapi_cmd_datum_data.h:435
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntByOffset
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cv...
Definition: zwapi_cmd_datum_data.h:424
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPntBy2Lines
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffse...
Definition: zwapi_cmd_datum_data.h:427
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:422
svxCSYSData::evxCSYSInpUnion::CSYSPntAnd2Dir
point and two directions
Definition: zwapi_cmd_datum_data.h:419
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face3
svxEntPath Face3
face3
Definition: zwapi_cmd_datum_data.h:415
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face1
svxEntPath Face1
face1
Definition: zwapi_cmd_datum_data.h:407
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::Face2
svxEntPath Face2
face2
Definition: zwapi_cmd_datum_data.h:411
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis3
evsResultsAxisMethod axis3
axis3(default:VX_RESULTS_AXIS_Z).The three axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:416
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis2
evsResultsAxisMethod axis2
axis2(default:VX_RESULTS_AXIS_Y)
Definition: zwapi_cmd_datum_data.h:412
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::axis1
evsResultsAxisMethod axis1
axis1(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:408
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip1
int isFlip1
1 is flip,else 0. default:0.
Definition: zwapi_cmd_datum_data.h:409
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces::isFlip2
int isFlip2
1 is flip,else 0. default:0.
Definition: zwapi_cmd_datum_data.h:413
svxCSYSData::evxCSYSInpUnion::CSYSThreeFaces
three faces
Definition: zwapi_cmd_datum_data.h:406
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:377
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntByOffset
svxPntByOffset * OrgPntByOffset
set the origin point by the offset sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByO2Lines) cv...
Definition: zwapi_cmd_datum_data.h:379
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1ByOffset
svxPntByOffset * Pnt1ByOffset
set the point1 by the offset sub-command (NULL to use (idPnt1, Pnt1) or Pnt1By2Lines) cvxPartPntByOff...
Definition: zwapi_cmd_datum_data.h:387
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPntBy2Lines
svxPntBy2Lines * OrgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idOrgPnt, OrgPnt) or OrgPntByOffse...
Definition: zwapi_cmd_datum_data.h:382
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2ByOffset
svxPntByOffset * Pnt2ByOffset
set the origin point by the offset sub-command (NULL to use (idPnt2, Pnt2) or Pnt2By2Lines) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:397
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::OrgPnt
svxPoint OrgPnt
origin point
Definition: zwapi_cmd_datum_data.h:378
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt1
int idPnt1
id of the point1 parent entity
Definition: zwapi_cmd_datum_data.h:385
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip1
int isFlip1
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:393
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2By2Lines
svxPntBy2Lines * Pnt2By2Lines
set the origin point by the from 2 lines sub-command (NULL to use (idPnt2, Pnt2) or Pnt2ByOffset) cvx...
Definition: zwapi_cmd_datum_data.h:400
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt2
svxPoint Pnt2
Point2.
Definition: zwapi_cmd_datum_data.h:396
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::firstAxis
evsResultsAxisMethod firstAxis
1st axis(default:VX_RESULTS_AXIS_X)
Definition: zwapi_cmd_datum_data.h:392
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1By2Lines
svxPntBy2Lines * Pnt1By2Lines
set the point2 by the from 2 lines sub-command (NULL to use (idPnt1, Pnt1) or Pnt1ByOffset) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:390
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::Pnt1
svxPoint Pnt1
point1
Definition: zwapi_cmd_datum_data.h:386
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::isFlip2
int isFlip2
1 is flip,else 0.default:0
Definition: zwapi_cmd_datum_data.h:403
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::secondAxis
evsResultsAxisMethod secondAxis
2nd axis(default:VX_RESULTS_AXIS_Y). 1st axis and 2nd axis cannot be the same.
Definition: zwapi_cmd_datum_data.h:402
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts::idPnt2
int idPnt2
id of the point2 parent entity
Definition: zwapi_cmd_datum_data.h:395
svxCSYSData::evxCSYSInpUnion::CSYSThreePnts
three points
Definition: zwapi_cmd_datum_data.h:376
svxCSYSData::XAng
double XAng
angle value X direction
Definition: zwapi_cmd_datum_data.h:477
svxCSYSData::method
evxCSYSMethods method
CSYS methods.
Definition: zwapi_cmd_datum_data.h:350
svxCSYSData::dOffset
double dOffset
offset value
Definition: zwapi_cmd_datum_data.h:472
svxCSYSData::XPnt
svxPoint XPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:476
svxCSYSData::ZAng
double ZAng
angle value Z direction
Definition: zwapi_cmd_datum_data.h:479
svxCSYSData::idXPnt
int idXPnt
id of the XPoint parent entity
Definition: zwapi_cmd_datum_data.h:475
svxCSYSData::Frame
svxMatrix Frame
transformation matrix
Definition: zwapi_cmd_datum_data.h:349
svxCSYSData::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:473
svxCSYSData::OrgPnt
svxPoint OrgPnt
origin
Definition: zwapi_cmd_datum_data.h:474
svxCSYSData::YAng
double YAng
angle value Y direction
Definition: zwapi_cmd_datum_data.h:478
svxCSYSData
template command CSYS input data
Definition: zwapi_cmd_datum_data.h:348
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::angle
double angle
angle (default: 45)
Definition: zwapi_cmd_datum_data.h:286
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::linePath
svxEntPath linePath
line or edge path
Definition: zwapi_cmd_datum_data.h:285
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::orgPnt
svxPoint orgPnt
origin on "path"
Definition: zwapi_cmd_datum_data.h:282
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::path
svxEntPath path
face path
Definition: zwapi_cmd_datum_data.h:283
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc::axis
svxPoint axis
point on line(or edge)
Definition: zwapi_cmd_datum_data.h:284
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneAngToFc
angle to face :VX_NEW_PLANE_ANGLE_FACE
Definition: zwapi_cmd_datum_data.h:281
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::yAxis
svxVector yAxis
Y Axis.
Definition: zwapi_cmd_datum_data.h:270
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::xAxis
svxVector xAxis
X Axis.
Definition: zwapi_cmd_datum_data.h:269
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPnt
svxPoint posPnt
position
Definition: zwapi_cmd_datum_data.h:263
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntBy2Lines
svxPntBy2Lines * posPntBy2Lines
set the position point by the from 2 lines sub-command (NULL to use posPnt or PosPntByOffset) cvxPart...
Definition: zwapi_cmd_datum_data.h:267
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::autoOrient
int autoOrient
1 if auto orientation, else 0
Definition: zwapi_cmd_datum_data.h:272
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::zAxis
svxVector zAxis
Z Axis.
Definition: zwapi_cmd_datum_data.h:271
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic::posPntByOffset
svxPntByOffset * posPntByOffset
set the position point by the offset sub-command (NULL to use posPnt or PosPntBy2Lines) cvxPartPntByO...
Definition: zwapi_cmd_datum_data.h:264
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneDynamic
dynamic :VX_NEW_PLANE_DYNAMIC
Definition: zwapi_cmd_datum_data.h:262
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::cnt
int cnt
count of pnts and paths
Definition: zwapi_cmd_datum_data.h:221
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::paths
svxEntPath * paths
entity/object pick paths
Definition: zwapi_cmd_datum_data.h:223
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::offset
double offset
offset the new datum from the target geometry
Definition: zwapi_cmd_datum_data.h:226
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::angle
double angle
angle (default: 45)
Definition: zwapi_cmd_datum_data.h:227
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::path
svxEntPath path
entity/object pick path
Definition: zwapi_cmd_datum_data.h:217
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnt
svxPoint pnt
Picked Point.
Definition: zwapi_cmd_datum_data.h:216
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry::pnts
svxPoint * pnts
picked points
Definition: zwapi_cmd_datum_data.h:222
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneGeometry
geometry :VX_NEW_PLANE_GEOMETRY
Definition: zwapi_cmd_datum_data.h:214
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::orgPnt
svxPoint orgPnt
origin on "path"
Definition: zwapi_cmd_datum_data.h:276
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::offset
double offset
offset
Definition: zwapi_cmd_datum_data.h:278
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset::path
svxEntPath path
face path
Definition: zwapi_cmd_datum_data.h:277
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOffset
offset plane :VX_NEW_PLANE_OFFSET_PLANE
Definition: zwapi_cmd_datum_data.h:275
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::dirType
evxOnCrvDirType dirType
direction type
Definition: zwapi_cmd_datum_data.h:294
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::orgPnt
svxPoint orgPnt
This variable is deprecated and can be ignored. This has no effect on the previous Settings.
Definition: zwapi_cmd_datum_data.h:290
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::isPercent
int isPercent
1 if use percent, 2 if use distance
Definition: zwapi_cmd_datum_data.h:292
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::path
svxEntPath path
Curve C path.
Definition: zwapi_cmd_datum_data.h:291
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::num
double num
if isPercent = 1, num is Percent; if isPercent = 2, num is distance.
Definition: zwapi_cmd_datum_data.h:293
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve::CrvPath
svxEntPath CrvPath
Curve path.
Definition: zwapi_cmd_datum_data.h:295
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneOnCurve
on curve :VX_NEW_PLANE_ON_CURVE
Definition: zwapi_cmd_datum_data.h:289
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPnt
svxPoint xPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:238
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPnt
svxPoint orgPnt
origin
Definition: zwapi_cmd_datum_data.h:231
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntByOffset
svxPntByOffset * xPntByOffset
set the XPoint by the offset sub-command (NULL to use xPnt or xPntBy2Lines) cvxPartPntByOffsetInit() ...
Definition: zwapi_cmd_datum_data.h:239
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::xPntBy2Lines
svxPntBy2Lines * xPntBy2Lines
set the XPoint by the from 2 lines sub-command (NULL to use xPnt or xPntByOffset) cvxPartPntBy2LinesI...
Definition: zwapi_cmd_datum_data.h:242
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPnt
svxPoint yPnt
YPoint.
Definition: zwapi_cmd_datum_data.h:245
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntBy2Lines
svxPntBy2Lines * yPntBy2Lines
set the YPoint by the from 2 lines sub-command (NULL to use yPnt or yPntByOffset) cvxPartPntBy2LinesI...
Definition: zwapi_cmd_datum_data.h:249
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntBy2Lines
svxPntBy2Lines * orgPntBy2Lines
set the origin point by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPn...
Definition: zwapi_cmd_datum_data.h:235
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::orgPntByOffset
svxPntByOffset * orgPntByOffset
set the origin point by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOff...
Definition: zwapi_cmd_datum_data.h:232
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt::yPntByOffset
svxPntByOffset * yPntByOffset
set the YPoint by the offset sub-command (NULL to use yPnt or yPntBy2Lines) cvxPartPntByOffsetInit() ...
Definition: zwapi_cmd_datum_data.h:246
svxNewPlaneData::evxNewPlaneMethodsUnion::NewPlaneThreePnt
three point :VX_NEW_PLANE_THREE_POINTS
Definition: zwapi_cmd_datum_data.h:230
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntByOffset
svxPntByOffset * orgPntByOffset
set the origin by the offset sub-command (NULL to use orgPnt or orgPntBy2Lines) cvxPartPntByOffsetIni...
Definition: zwapi_cmd_datum_data.h:255
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPnt
svxPoint orgPnt
origin
Definition: zwapi_cmd_datum_data.h:254
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane::orgPntBy2Lines
svxPntBy2Lines * orgPntBy2Lines
set the origin by the from 2 lines sub-command (NULL to use orgPnt or orgPntByOffset) cvxPartPntBy2Li...
Definition: zwapi_cmd_datum_data.h:258
svxNewPlaneData::evxNewPlaneMethodsUnion::NewviewPlane
view plane :VX_NEW_PLANE_VIEW_PLANE
Definition: zwapi_cmd_datum_data.h:253
svxNewPlaneData::yAng
double yAng
angle value Y direction
Definition: zwapi_cmd_datum_data.h:310
svxNewPlaneData::xPoint
svxPoint * xPoint
X point (NULL to ignore)
Definition: zwapi_cmd_datum_data.h:308
svxNewPlaneData::isFlipDir
int isFlipDir
1 if flip direction, else 0 method = VX_NEW_PLANE_GEOMETRY, VX_NEW_PLANE_THREE_POINTS,...
Definition: zwapi_cmd_datum_data.h:300
svxNewPlaneData::zAng
double zAng
angle value Z direction
Definition: zwapi_cmd_datum_data.h:311
svxNewPlaneData::xAng
double xAng
angle value X direction
Definition: zwapi_cmd_datum_data.h:309
svxNewPlaneData::orgPnt
svxPoint * orgPnt
origin (NULL to ignore)
Definition: zwapi_cmd_datum_data.h:307
svxNewPlaneData::dOffset
double dOffset
offset
Definition: zwapi_cmd_datum_data.h:306
svxNewPlaneData::method
evxNewPlaneMethods method
methods
Definition: zwapi_cmd_datum_data.h:210
svxNewPlaneData
New template command Plane input data.
Definition: zwapi_cmd_datum_data.h:209
svxPlaneData::evxPlnInpUnion::PlaneXYZ::Offset
double Offset
offset
Definition: zwapi_cmd_datum_data.h:141
svxPlaneData::evxPlnInpUnion::PlaneXYZ
use XY Plane/ XZ Plane/ YZ Plan
Definition: zwapi_cmd_datum_data.h:140
svxPlaneData::evxPlnInpUnion::PlnDynamic::idPosPnt
int idPosPnt
id of the position parent entity
Definition: zwapi_cmd_datum_data.h:156
svxPlaneData::evxPlnInpUnion::PlnDynamic::ZAxis
svxVector ZAxis
Z Axis.
Definition: zwapi_cmd_datum_data.h:160
svxPlaneData::evxPlnInpUnion::PlnDynamic::PosPnt
svxPoint PosPnt
position
Definition: zwapi_cmd_datum_data.h:157
svxPlaneData::evxPlnInpUnion::PlnDynamic::YAxis
svxVector YAxis
Y Axis.
Definition: zwapi_cmd_datum_data.h:159
svxPlaneData::evxPlnInpUnion::PlnDynamic::XAxis
svxVector XAxis
X Axis.
Definition: zwapi_cmd_datum_data.h:158
svxPlaneData::evxPlnInpUnion::PlnDynamic
Dynamic.
Definition: zwapi_cmd_datum_data.h:155
svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Path
svxEntPath Path
entity/object pick path
Definition: zwapi_cmd_datum_data.h:128
svxPlaneData::evxPlnInpUnion::PlnGeomPnt::Pnt
svxPoint Pnt
picked Point
Definition: zwapi_cmd_datum_data.h:127
svxPlaneData::evxPlnInpUnion::PlnGeomPnt
geometry
Definition: zwapi_cmd_datum_data.h:126
svxPlaneData::evxPlnInpUnion::PlnThreePnts::idXPnt
int idXPnt
id of the XPoint parent entity
Definition: zwapi_cmd_datum_data.h:134
svxPlaneData::evxPlnInpUnion::PlnThreePnts::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:132
svxPlaneData::evxPlnInpUnion::PlnThreePnts::YPnt
svxPoint YPnt
YPoint.
Definition: zwapi_cmd_datum_data.h:137
svxPlaneData::evxPlnInpUnion::PlnThreePnts::idYPnt
int idYPnt
id of the YPoint parent entity
Definition: zwapi_cmd_datum_data.h:136
svxPlaneData::evxPlnInpUnion::PlnThreePnts::OrgPnt
svxPoint OrgPnt
origin
Definition: zwapi_cmd_datum_data.h:133
svxPlaneData::evxPlnInpUnion::PlnThreePnts::XPnt
svxPoint XPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:135
svxPlaneData::evxPlnInpUnion::PlnThreePnts
three point
Definition: zwapi_cmd_datum_data.h:131
svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt1
int idEnt1
id of the Entity1 parent entity
Definition: zwapi_cmd_datum_data.h:149
svxPlaneData::evxPlnInpUnion::PlnTwoEnts::idEnt2
int idEnt2
id of the Entity2 parent entity
Definition: zwapi_cmd_datum_data.h:151
svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent2Pnt
svxPoint Ent2Pnt
entity 2 point
Definition: zwapi_cmd_datum_data.h:152
svxPlaneData::evxPlnInpUnion::PlnTwoEnts::Ent1Pnt
svxPoint Ent1Pnt
entity 1 point
Definition: zwapi_cmd_datum_data.h:150
svxPlaneData::evxPlnInpUnion::PlnTwoEnts
Two Entities.
Definition: zwapi_cmd_datum_data.h:148
svxPlaneData::evxPlnInpUnion::viewPlane::OrgPnt
svxPoint OrgPnt
origin
Definition: zwapi_cmd_datum_data.h:145
svxPlaneData::evxPlnInpUnion::viewPlane
view plane
Definition: zwapi_cmd_datum_data.h:144
svxPlaneData::idOrgPnt
int idOrgPnt
id of the origin parent entity
Definition: zwapi_cmd_datum_data.h:168
svxPlaneData::XAng
double XAng
angle value X direction
Definition: zwapi_cmd_datum_data.h:172
svxPlaneData::OrgPnt
svxPoint OrgPnt
origin
Definition: zwapi_cmd_datum_data.h:169
svxPlaneData::AlignType
evxPlaneAlign AlignType
plane orientation align type
Definition: zwapi_cmd_datum_data.h:164
svxPlaneData::dOffset
double dOffset
offset value
Definition: zwapi_cmd_datum_data.h:167
svxPlaneData::XPnt
svxPoint XPnt
XPoint.
Definition: zwapi_cmd_datum_data.h:171
svxPlaneData::YAng
double YAng
angle value Y direction
Definition: zwapi_cmd_datum_data.h:173
svxPlaneData::ZAng
double ZAng
angle value Z direction
Definition: zwapi_cmd_datum_data.h:174
svxPlaneData::idXPnt
int idXPnt
id of the XPoint parent entity
Definition: zwapi_cmd_datum_data.h:170
svxPlaneData::method
evxPlaneMethods method
methods
Definition: zwapi_cmd_datum_data.h:122
svxPlaneData
template command Plane input data
Definition: zwapi_cmd_datum_data.h:121
svxPntBy2Lines
the data to get the point by From 2 Lines command
Definition: zwapi_cmd_subcmd_data.h:45
svxPntByOffset
the data to get the point by Offset command
Definition: zwapi_cmd_subcmd_data.h:33
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
svxAxisData::evxAxisInpUnion
union of Axis input data
Definition: zwapi_cmd_datum_data.h:54
svxCSYSData::evxCSYSInpUnion
union of csys input data
Definition: zwapi_cmd_datum_data.h:352
svxNewPlaneData::evxNewPlaneMethodsUnion
union of plane input data
Definition: zwapi_cmd_datum_data.h:212
svxPlaneData::evxPlnInpUnion
union of plane data
Definition: zwapi_cmd_datum_data.h:124
zwapi_cmd_subcmd_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DIRECT_EDIT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_direct_edit.h
cvxPartDEAlignMove
cvxPartDEAlignMoveInit
cvxPartDECopy
cvxPartDECopyInit
cvxPartDEDimMove
cvxPartDEDimMoveInit
cvxPartDEDraft
cvxPartDEDraftInit
cvxPartDEFllt
cvxPartDEFlltInit
cvxPartDEMirror
cvxPartDEMirrorInit
cvxPartDEMove
cvxPartDEMoveInit
cvxPartDEOffset
cvxPartDEOffsetInit
cvxPartDEPtn
cvxPartDEPtnInit
cvxPartDERad
cvxPartDERadInit

◆ ZW_API_DIRECT_EDIT_H

#define ZW_API_DIRECT_EDIT_H

Definition at line 15 of file zwapi_cmd_direct_edit.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_direct_edit.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_direct_edit.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DIRECT_EDIT_H /* this ifndef surrounds entire header */
15#define ZW_API_DIRECT_EDIT_H
16
17#include "zwapi_cmd_direct_edit_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26
27/******************************************************************************/
45extern evxErrors cvxPartDEMoveInit(evxDEMoveCopyType type, svxDEMove* data);
46
47/******************************************************************************/
71extern evxErrors cvxPartDEMove(const svxDEMove* data, int* idMove);
72
73/******************************************************************************/
91extern evxErrors cvxPartDEAlignMoveInit(evxDEAlignMoveType type, svxDEAlignMove* data);
92
93/******************************************************************************/
113extern evxErrors cvxPartDEAlignMove(const svxDEAlignMove* data, int* idMove);
114
115/******************************************************************************/
133extern evxErrors cvxPartDEDimMoveInit(evxDEDimMoveType type, svxDEDimMove* data);
134
135/******************************************************************************/
159extern evxErrors cvxPartDEDimMove(const svxDEDimMove* data, int* idMove);
160
161/******************************************************************************/
178extern evxErrors cvxPartDEOffsetInit(svxDEOffset* data);
179
180/******************************************************************************/
203extern evxErrors cvxPartDEOffset(const svxDEOffset* data, int* idOffset);
204
205/******************************************************************************/
221extern evxErrors cvxPartDEDraftInit(svxDEDraft* data);
222
223/******************************************************************************/
246extern evxErrors cvxPartDEDraft(const svxDEDraft* data, int* idDraft);
247
248//====================================================================================================================
250//====================================================================================================================
251
252/******************************************************************************/
270extern evxErrors cvxPartDECopyInit(evxDEMoveCopyType type, svxDECopy* data);
271
272/******************************************************************************/
299extern evxErrors cvxPartDECopy(const svxDECopy* data, int* idCopy);
300
301/******************************************************************************/
318extern evxErrors cvxPartDEMirrorInit(svxDEMirror* data);
319
320/******************************************************************************/
343extern evxErrors cvxPartDEMirror(const svxDEMirror* data, int* idMirror);
344
345/******************************************************************************/
363extern evxErrors cvxPartDEPtnInit(evxDEPtnType type, svxDEPattern* data);
364
365/******************************************************************************/
389extern evxErrors cvxPartDEPtn(const svxDEPattern* data, int* idPtn);
390
391//====================================================================================================================
393//====================================================================================================================
394
395/******************************************************************************/
412extern evxErrors cvxPartDEFlltInit(svxDEFllt* data);
413
414/******************************************************************************/
437extern evxErrors cvxPartDEFllt(const svxDEFllt* data, int* idFllt);
438
439/******************************************************************************/
456extern evxErrors cvxPartDERadInit(svxDERad* data);
457
458/******************************************************************************/
481extern evxErrors cvxPartDERad(const svxDERad* data, int* idRad);
482
483/*
484*********************************************************************
485** END HEADER FILE
486*********************************************************************
487*/
488#ifdef __cplusplus
489 }
490#endif /* __cplusplus */
491
492#endif /* ZW_API_DATUM_H */
evxDEMoveCopyType
evxDEMoveCopyType
part or assembly DE(Direct Edit) move or copy method
Definition: zwapi_cmd_direct_edit_data.h:32
evxDEPtnType
evxDEPtnType
part or assembly DE(Direct Edit) pattern method
Definition: zwapi_cmd_direct_edit_data.h:430
evxDEAlignMoveType
evxDEAlignMoveType
part or assembly DE(Direct Edit) align move method
Definition: zwapi_cmd_direct_edit_data.h:175
evxDEDimMoveType
evxDEDimMoveType
part or assembly DE(Direct Edit) dim move method
Definition: zwapi_cmd_direct_edit_data.h:221
cvxPartDEOffset
evxErrors cvxPartDEOffset(const svxDEOffset *data, int *idOffset)
cvxPartDERad
evxErrors cvxPartDERad(const svxDERad *data, int *idRad)
cvxPartDEDimMove
evxErrors cvxPartDEDimMove(const svxDEDimMove *data, int *idMove)
cvxPartDECopyInit
evxErrors cvxPartDECopyInit(evxDEMoveCopyType type, svxDECopy *data)
cvxPartDEFlltInit
evxErrors cvxPartDEFlltInit(svxDEFllt *data)
cvxPartDECopy
evxErrors cvxPartDECopy(const svxDECopy *data, int *idCopy)
cvxPartDEPtn
evxErrors cvxPartDEPtn(const svxDEPattern *data, int *idPtn)
cvxPartDEMirror
evxErrors cvxPartDEMirror(const svxDEMirror *data, int *idMirror)
cvxPartDEDraftInit
evxErrors cvxPartDEDraftInit(svxDEDraft *data)
cvxPartDEMoveInit
evxErrors cvxPartDEMoveInit(evxDEMoveCopyType type, svxDEMove *data)
cvxPartDEOffsetInit
evxErrors cvxPartDEOffsetInit(svxDEOffset *data)
cvxPartDEMirrorInit
evxErrors cvxPartDEMirrorInit(svxDEMirror *data)
cvxPartDEAlignMove
evxErrors cvxPartDEAlignMove(const svxDEAlignMove *data, int *idMove)
cvxPartDERadInit
evxErrors cvxPartDERadInit(svxDERad *data)
cvxPartDEFllt
evxErrors cvxPartDEFllt(const svxDEFllt *data, int *idFllt)
cvxPartDEMove
evxErrors cvxPartDEMove(const svxDEMove *data, int *idMove)
cvxPartDEPtnInit
evxErrors cvxPartDEPtnInit(evxDEPtnType type, svxDEPattern *data)
cvxPartDEAlignMoveInit
evxErrors cvxPartDEAlignMoveInit(evxDEAlignMoveType type, svxDEAlignMove *data)
cvxPartDEDimMoveInit
evxErrors cvxPartDEDimMoveInit(evxDEDimMoveType type, svxDEDimMove *data)
cvxPartDEDraft
evxErrors cvxPartDEDraft(const svxDEDraft *data, int *idDraft)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxDEAlignMove
part or assembly DE(Direct Edit) align move data
Definition: zwapi_cmd_direct_edit_data.h:190
svxDECopy
part or assembly DE(Direct Edit) copy data
Definition: zwapi_cmd_direct_edit_data.h:327
svxDEDimMove
part or assembly DE(Direct Edit) dim move data
Definition: zwapi_cmd_direct_edit_data.h:231
svxDEDraft
part or assembly DE(Direct Edit) draft data
Definition: zwapi_cmd_direct_edit_data.h:305
svxDEFllt
part or assembly DE(Direct Edit) modify fillet data
Definition: zwapi_cmd_direct_edit_data.h:580
svxDEMirror
part or assembly DE(Direct Edit) mirror data
Definition: zwapi_cmd_direct_edit_data.h:416
svxDEMove
part or assembly DE(Direct Edit) move data
Definition: zwapi_cmd_direct_edit_data.h:91
svxDEOffset
part or assembly DE(Direct Edit) face offset data
Definition: zwapi_cmd_direct_edit_data.h:279
svxDEPattern
part or assembly DE(Direct Edit) pattern data
Definition: zwapi_cmd_direct_edit_data.h:478
svxDERad
part or assembly DE(Direct Edit) modify radius data
Definition: zwapi_cmd_direct_edit_data.h:603
zwapi_cmd_direct_edit_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DIRECT_EDIT_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_direct_edit_data.h
evxDEAlignMoveType
evxDEAlignMoveType
evxDEDimMoveType
evxDEDimMoveType
evxDEDraftSideType
evxDEDraftSideType
evxDEFaceOverflow
evxDEFaceOverflow
evxDEIsectType
evxDEIsectType
evxDEMoveCopyFrame
evxDEMoveCopyFrame
evxDEMoveCopyType
evxDEMoveCopyType
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
evxDEPtnBound
evxDEPtnBound
evxDEPtnCrv
evxDEPtnCrv
evxDEPtnDerive
evxDEPtnDerive
evxDEPtnType
evxDEPtnType
evxDESideFaceType
evxDESideFaceType
svxDEAlignMove
svxDECopy
svxDEDimMove
svxDEDraft
svxDEFllt
svxDEMirror
svxDEMove
svxDEOffset
svxDEPattern
svxDERad

◆ ZW_API_DIRECT_EDIT_DATA_H

#define ZW_API_DIRECT_EDIT_DATA_H

Definition at line 15 of file zwapi_cmd_direct_edit_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_direct_edit_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_direct_edit_data.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DIRECT_EDIT_DATA_H /* this ifndef surrounds entire header */
15#define ZW_API_DIRECT_EDIT_DATA_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26
31typedef enum evxDEMoveCopyType
32 {
33 VX_DE_MOVE_PNT_TO_PNT = 1,
34 VX_DE_MOVE_ALONG_DIR = 2,
35 VX_DE_MOVE_FRAME = 3,
36 VX_DE_MOVE_PATH = 4,
37 VX_DE_MOVE_AROUND_DIR = 5,
38 VX_DE_MOVE_DYNAMIC = 6,
39 } evxDEMoveCopyType;
40
45typedef enum evxDEFaceOverflow
46 {
47 VX_DE_OVERFLOW_AUTO,
48 VX_DE_OVERFLOW_CHANGE,
49 VX_DE_OVERFLOW_STATION,
50 VX_DE_OVERFLOW_CAP,
51 } evxDEFaceOverflow;
52
57typedef enum evxDEMoveCopyFrame
58 {
59 VX_DE_MOVE_FRAME_NATURAL,
60 VX_DE_MOVE_FRAME_PATH,
61 VX_DE_MOVE_FRAME_SELECT,
62 } evxDEMoveCopyFrame;
63
68typedef enum evxDEMoveCopyZSpine
69 {
70 VX_DE_MOVE_Z_NATURAL,
71 VX_DE_MOVE_Z_SPINE,
72 VX_DE_MOVE_Z_PARALLEL,
73 } evxDEMoveCopyZSpine;
74
79typedef enum evxDEMoveCopyXOrient
80 {
81 VX_DE_MOVE_X_NATURAL,
82 VX_DE_MOVE_X_PLANE,
83 VX_DE_MOVE_X_CURVE,
84 } evxDEMoveCopyXOrient;
85
90typedef struct svxDEMove
91 {
92 evxDEMoveCopyType type;
93 int numEnt;
94 int* idEnts;
95 evxDEFaceOverflow overflow;
96 union svxDEMoveData
97 {
98 struct svxDEMoveDyn
99 {
100 int handle;
101 svxPoint position;
103 svxVector x;
104 svxVector y;
105 svxVector z;
106 }dynamic;
107 struct svxDEMovePnt
108 {
109 svxPntOnEnt fromPnt;
110 svxPntOnEnt toPnt;
113 svxPntOnEnt fromVec;
114 svxPntOnEnt toVec;
116 }point;
117 struct svxDEMoveDir
118 {
119 svxPntOnEnt dir;
121 double dist;
123 double ang;
125 int angOption;
126 }direction;
127 struct svxDEMoveRotate
128 {
129 svxPntOnEnt dir;
131 svxPntOnEnt axis;
132 double ang;
134 }rotate;
135 struct svxDEMoveFrame
136 {
137 int fromFrmae;
138 int toFrmae;
139 }frame;
140 struct svxDEMovePath
141 {
142 svxPntOnEnt pathPnt;
144 svxPntOnEnt toPnt;
146 evxDEMoveCopyFrame frame;
147 int idSwp;
151 evxDEMoveCopyZSpine zSpine;
152 int idCrv;
155 svxPntOnEnt planeZ;
159 evxDEMoveCopyXOrient xOrient;
160 svxPntOnEnt planeX;
163 svxPntOnEnt crv;
166 }path;
167 }move;
168 } svxDEMove;
169
174typedef enum evxDEAlignMoveType
175 {
176 VX_DE_ALIGN_MOVE_COPLANAR = 1,
177 VX_DE_ALIGN_MOVE_CONCENTRIC = 2,
178 VX_DE_ALIGN_MOVE_TANGENT = 3,
179 VX_DE_ALIGN_MOVE_PARALLEL = 4,
180 VX_DE_ALIGN_MOVE_PERPENDICULAR = 5,
181 VX_DE_ALIGN_MOVE_ANGLE = 6,
182 VX_DE_ALIGN_MOVE_SYMMETRY = 7,
183 } evxDEAlignMoveType;
184
189typedef struct svxDEAlignMove
190 {
191 evxDEAlignMoveType type;
192 int idMotion;
193 int idStation;
201 int numEnt;
202 int* idEnts;
203 svxPntOnEnt thruPnt;
207 double angle;
210 int idPlane;
213 evxDEFaceOverflow overflow;
214 } svxDEAlignMove;
215
220typedef enum evxDEDimMoveType
221 {
222 VX_DE_DIM_LINEAR = 1,
223 VX_DE_DIM_ANGULAR = 2,
224 } evxDEDimMoveType;
225
230typedef struct svxDEDimMove
231 {
232 evxDEDimMoveType type;
233 int idMotion;
234 int idStation;
235 int isSwitch;
237 svxPoint stationPnt;
239 int numEnt;
240 int* idEnts;
241 double dist;
244 svxPntOnEnt anchorPnt;
246 svxPntOnEnt dir;
248 double angle;
251 evxDEFaceOverflow overflow;
252 } svxDEDimMove;
253
258typedef enum evxDESideFaceType
259 {
260 VX_DE_SIDE_FACE_NO_CREATE,
261 VX_DE_SIDE_FACE_CREATE,
262 } evxDESideFaceType;
263
268typedef enum evxDEIsectType
269 {
270 VX_DE_ISECT_NO_REMOVE,
271 VX_DE_ISECT_REMOVE,
272 } evxDEIsectType;
273
278typedef struct svxDEOffset
279 {
280 int numEnt;
281 int* idEnts;
282 double dist;
283 evxDESideFaceType side;
284 evxDEIsectType intersection;
285 evxDEFaceOverflow overflow;
286 } svxDEOffset;
287
292typedef enum evxDEDraftSideType
293 {
294 VX_DE_DRAFT_SIDE_TOP,
295 VX_DE_DRAFT_SIDE_BOTTOM,
296 VX_DE_DRAFT_SIDE_SPILT,
297 VX_DE_DRAFT_SIDE_NEUTRAL,
298 } evxDEDraftSideType;
299
304typedef struct svxDEDraft
305 {
306 int numFace;
307 int* idFaces;
308 int numDraft;
309 int* idDrafts;
310 double angle;
311 svxPntOnEnt dir;
312 evxDEDraftSideType side;
313 int numEdge;
314 int* idEgdes;
315 evxDEFaceOverflow overflow;
316 } svxDEDraft;
317
318//====================================================================================================================
320//====================================================================================================================
321
326typedef struct svxDECopy
327 {
328 evxDEMoveCopyType type;
329 int numEnt;
330 int* idEnts;
331 union svxDECopyData
332 {
333 struct svxDECopyDyn
334 {
335 int handle;
336 svxPoint position;
338 svxVector x;
339 svxVector y;
340 svxVector z;
341 }dynamic;
342 struct svxDECopyPnt
343 {
344 svxPntOnEnt fromPnt;
345 int cntToPnt;
346 svxPntOnEnt* toPnt;
349 svxPntOnEnt fromVec;
350 svxPntOnEnt toVec;
352 }point;
353 struct svxDECopyDir
354 {
355 svxPntOnEnt dir;
357 double dist;
359 int useAng;
360 double ang;
362 int useCopies;
363 int copies;
364 }direction;
365 struct svxDECopyRotate
366 {
367 svxPntOnEnt dir;
369 double ang;
371 int useCopies;
372 int copies;
373 }rotate;
374 struct svxDECopyFrame
375 {
376 int fromFrmae;
377 int cnt;
378 int* toFrmaes;
379 }frame;
380 struct svxDECopyPath
381 {
382 svxPntOnEnt pathPnt;
384 int numPnt;
385 svxPntOnEnt* toPnt;
387 evxDEMoveCopyFrame frame;
388 int idSwp;
392 evxDEMoveCopyZSpine zSpine;
393 int idCrv;
396 svxPntOnEnt planeZ;
400 evxDEMoveCopyXOrient xOrient;
401 svxPntOnEnt planeX;
404 svxPntOnEnt crv;
407 }path;
408 }copy;
409 } svxDECopy;
410
415typedef struct svxDEMirror
416 {
417 int numEnt;
418 int* idEnts;
419 int idPlane;
420 int original;
423 } svxDEMirror;
424
429typedef enum evxDEPtnType
430 {
431 VX_DE_PTN_LINEAR,
432 VX_DE_PTN_CIRCULAR,
433 VX_DE_PTN_POINT,
434 VX_DE_PTN_PATTERN,
435 VX_DE_PTN_CURVE,
436 VX_DE_PTN_FACE,
437 } evxDEPtnType;
438
443typedef enum evxDEPtnDerive
444 {
445 VX_DE_PTN_DERIVE_NONE,
446 VX_DE_PTN_DERIVE_SPACING,
447 VX_DE_PTN_DERIVE_NUMBER,
448 } evxDEPtnDerive;
449
454typedef enum evxDEPtnCrv
455 {
456 VX_DE_PTN_CRV1,
457 VX_DE_PTN_CRV2_TGT,
458 VX_DE_PTN_CRV2_ACR,
459 VX_DE_PTN_CRV3,
460 } evxDEPtnCrv;
461
466typedef enum evxDEPtnBound
467 {
468 VX_DE_PTN_BOUND_AUTO,
469 VX_DE_PTN_BOUND_PLACE,
470 VX_DE_PTN_BOUND_MOVE,
471 } evxDEPtnBound;
472
477typedef struct svxDEPattern
478 {
479 evxDEPtnType type;
480 int numEnt;
481 int* idEnts;
482 union svxDEPtnData
483 {
484 struct svxDEPtnLinear
485 {
486 svxPntOnEnt dir[2];
487 int num[2];
488 double spacing[2];
489 int stagger;
490 }linear;
491 struct svxDEPtnCircular
492 {
493 svxPntOnEnt dir;
494 double diameter;
495 double ang;
497 int num[2];
500 double spacing;
501 evxDEPtnDerive derive;
502 double min;
504 int stagger;
505 int align;
506 }circular;
507 struct svxDEPtnPoint
508 {
509 svxPntOnEnt fromPnt;
510 int numTo;
511 svxPntOnEnt* toPnts;
512 int align;
513 int idFace;
515 }point;
516 struct svxDEPtnPattern
517 {
518 int idPattern;
519 }pattern;
520 struct svxDEPtnCurve
521 {
522 evxDEPtnCrv crvType;
523 int numBound;
527 int* pBounds;
528 int num[2];
529 double spacing[2];
530 evxDEPtnDerive derive;
531 double min;
533 int stagger;
534 int align;
535 int idFace;
537 int useFromPnt;
538 svxPntOnEnt fromPnt;
539 evxDEPtnBound bound;
540 }curve;
541 struct svxDEPtnFace
542 {
543 int idFace;
545 int num[2];
546 double spacing[2];
547 evxDEPtnDerive derive;
548 double min;
550 int stagger;
551 int align;
552 int useFromPnt;
553 svxPntOnEnt fromPnt;
554 evxDEPtnBound bound;
555 }face;
556 }ptn;
557 int cntSkip;
558 int* firstTogglePos;
561 int* secondTogglePos;
569 } svxDEPattern;
570
571//====================================================================================================================
573//====================================================================================================================
574
579typedef struct svxDEFllt
580 {
581 int numEnt;
582 int* idEnts;
583 double R;
584 int chain;
585 double relief;
586 int arcType;
587 double ratio;
590 int hold;
591 int strategy;
594 int numEdge;
595 int* idEgdes;
596 } svxDEFllt;
597
602typedef struct svxDERad
603 {
604 int numEnt;
605 int* idEnts;
606 double R;
607 } svxDERad;
608
609/*
610*********************************************************************
611** END HEADER FILE
612*********************************************************************
613*/
614
615#ifdef __cplusplus
616 }
617#endif /* __cplusplus */
618
619#endif /* ZW_API_DATUM_DATA_H */
evxDEPtnBound
evxDEPtnBound
part or assembly DE(Direct Edit) pattern boundary method
Definition: zwapi_cmd_direct_edit_data.h:467
VX_DE_PTN_BOUND_PLACE
@ VX_DE_PTN_BOUND_PLACE
in place
Definition: zwapi_cmd_direct_edit_data.h:469
VX_DE_PTN_BOUND_AUTO
@ VX_DE_PTN_BOUND_AUTO
auto
Definition: zwapi_cmd_direct_edit_data.h:468
VX_DE_PTN_BOUND_MOVE
@ VX_DE_PTN_BOUND_MOVE
move
Definition: zwapi_cmd_direct_edit_data.h:470
evxDEMoveCopyType
evxDEMoveCopyType
part or assembly DE(Direct Edit) move or copy method
Definition: zwapi_cmd_direct_edit_data.h:32
VX_DE_MOVE_DYNAMIC
@ VX_DE_MOVE_DYNAMIC
dynamic move or copy
Definition: zwapi_cmd_direct_edit_data.h:38
VX_DE_MOVE_PNT_TO_PNT
@ VX_DE_MOVE_PNT_TO_PNT
move or copy entities point to point
Definition: zwapi_cmd_direct_edit_data.h:33
VX_DE_MOVE_ALONG_DIR
@ VX_DE_MOVE_ALONG_DIR
move or copy entities along a dirction
Definition: zwapi_cmd_direct_edit_data.h:34
VX_DE_MOVE_PATH
@ VX_DE_MOVE_PATH
move or copy entities along path
Definition: zwapi_cmd_direct_edit_data.h:36
VX_DE_MOVE_AROUND_DIR
@ VX_DE_MOVE_AROUND_DIR
rotate entities around a dirction
Definition: zwapi_cmd_direct_edit_data.h:37
VX_DE_MOVE_FRAME
@ VX_DE_MOVE_FRAME
move or copy entities by aligning frame
Definition: zwapi_cmd_direct_edit_data.h:35
evxDESideFaceType
evxDESideFaceType
part or assembly DE(Direct Edit) side face method
Definition: zwapi_cmd_direct_edit_data.h:259
VX_DE_SIDE_FACE_NO_CREATE
@ VX_DE_SIDE_FACE_NO_CREATE
do not create
Definition: zwapi_cmd_direct_edit_data.h:260
VX_DE_SIDE_FACE_CREATE
@ VX_DE_SIDE_FACE_CREATE
create
Definition: zwapi_cmd_direct_edit_data.h:261
evxDEFaceOverflow
evxDEFaceOverflow
part or assembly DE(Direct Edit) move overflow method
Definition: zwapi_cmd_direct_edit_data.h:46
VX_DE_OVERFLOW_CAP
@ VX_DE_OVERFLOW_CAP
extend cap face
Definition: zwapi_cmd_direct_edit_data.h:50
VX_DE_OVERFLOW_AUTO
@ VX_DE_OVERFLOW_AUTO
automatic
Definition: zwapi_cmd_direct_edit_data.h:47
VX_DE_OVERFLOW_STATION
@ VX_DE_OVERFLOW_STATION
extend stationary face
Definition: zwapi_cmd_direct_edit_data.h:49
VX_DE_OVERFLOW_CHANGE
@ VX_DE_OVERFLOW_CHANGE
extend change face
Definition: zwapi_cmd_direct_edit_data.h:48
evxDEPtnType
evxDEPtnType
part or assembly DE(Direct Edit) pattern method
Definition: zwapi_cmd_direct_edit_data.h:430
VX_DE_PTN_CURVE
@ VX_DE_PTN_CURVE
at curve
Definition: zwapi_cmd_direct_edit_data.h:435
VX_DE_PTN_FACE
@ VX_DE_PTN_FACE
at face
Definition: zwapi_cmd_direct_edit_data.h:436
VX_DE_PTN_PATTERN
@ VX_DE_PTN_PATTERN
at pattern
Definition: zwapi_cmd_direct_edit_data.h:434
VX_DE_PTN_LINEAR
@ VX_DE_PTN_LINEAR
linear
Definition: zwapi_cmd_direct_edit_data.h:431
VX_DE_PTN_POINT
@ VX_DE_PTN_POINT
point to point
Definition: zwapi_cmd_direct_edit_data.h:433
VX_DE_PTN_CIRCULAR
@ VX_DE_PTN_CIRCULAR
circular
Definition: zwapi_cmd_direct_edit_data.h:432
evxDEIsectType
evxDEIsectType
part or assembly DE(Direct Edit) intersection method
Definition: zwapi_cmd_direct_edit_data.h:269
VX_DE_ISECT_REMOVE
@ VX_DE_ISECT_REMOVE
remove
Definition: zwapi_cmd_direct_edit_data.h:271
VX_DE_ISECT_NO_REMOVE
@ VX_DE_ISECT_NO_REMOVE
do not remove
Definition: zwapi_cmd_direct_edit_data.h:270
evxDEMoveCopyFrame
evxDEMoveCopyFrame
part or assembly DE(Direct Edit) move or copy frame method
Definition: zwapi_cmd_direct_edit_data.h:58
VX_DE_MOVE_FRAME_PATH
@ VX_DE_MOVE_FRAME_PATH
at path
Definition: zwapi_cmd_direct_edit_data.h:60
VX_DE_MOVE_FRAME_SELECT
@ VX_DE_MOVE_FRAME_SELECT
selected
Definition: zwapi_cmd_direct_edit_data.h:61
VX_DE_MOVE_FRAME_NATURAL
@ VX_DE_MOVE_FRAME_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:59
evxDEPtnDerive
evxDEPtnDerive
part or assembly DE(Direct Edit) pattern derive method
Definition: zwapi_cmd_direct_edit_data.h:444
VX_DE_PTN_DERIVE_SPACING
@ VX_DE_PTN_DERIVE_SPACING
spacing
Definition: zwapi_cmd_direct_edit_data.h:446
VX_DE_PTN_DERIVE_NUMBER
@ VX_DE_PTN_DERIVE_NUMBER
number
Definition: zwapi_cmd_direct_edit_data.h:447
VX_DE_PTN_DERIVE_NONE
@ VX_DE_PTN_DERIVE_NONE
none
Definition: zwapi_cmd_direct_edit_data.h:445
evxDEAlignMoveType
evxDEAlignMoveType
part or assembly DE(Direct Edit) align move method
Definition: zwapi_cmd_direct_edit_data.h:175
VX_DE_ALIGN_MOVE_TANGENT
@ VX_DE_ALIGN_MOVE_TANGENT
tangent
Definition: zwapi_cmd_direct_edit_data.h:178
VX_DE_ALIGN_MOVE_SYMMETRY
@ VX_DE_ALIGN_MOVE_SYMMETRY
symmetric
Definition: zwapi_cmd_direct_edit_data.h:182
VX_DE_ALIGN_MOVE_CONCENTRIC
@ VX_DE_ALIGN_MOVE_CONCENTRIC
concentric
Definition: zwapi_cmd_direct_edit_data.h:177
VX_DE_ALIGN_MOVE_ANGLE
@ VX_DE_ALIGN_MOVE_ANGLE
at angle
Definition: zwapi_cmd_direct_edit_data.h:181
VX_DE_ALIGN_MOVE_PARALLEL
@ VX_DE_ALIGN_MOVE_PARALLEL
parallel
Definition: zwapi_cmd_direct_edit_data.h:179
VX_DE_ALIGN_MOVE_PERPENDICULAR
@ VX_DE_ALIGN_MOVE_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_direct_edit_data.h:180
VX_DE_ALIGN_MOVE_COPLANAR
@ VX_DE_ALIGN_MOVE_COPLANAR
coplanar
Definition: zwapi_cmd_direct_edit_data.h:176
evxDEPtnCrv
evxDEPtnCrv
part or assembly DE(Direct Edit) pattern at curve method
Definition: zwapi_cmd_direct_edit_data.h:455
VX_DE_PTN_CRV2_ACR
@ VX_DE_PTN_CRV2_ACR
two curves across
Definition: zwapi_cmd_direct_edit_data.h:458
VX_DE_PTN_CRV2_TGT
@ VX_DE_PTN_CRV2_TGT
two curves together
Definition: zwapi_cmd_direct_edit_data.h:457
VX_DE_PTN_CRV3
@ VX_DE_PTN_CRV3
three or four curves
Definition: zwapi_cmd_direct_edit_data.h:459
VX_DE_PTN_CRV1
@ VX_DE_PTN_CRV1
one curve
Definition: zwapi_cmd_direct_edit_data.h:456
evxDEMoveCopyXOrient
evxDEMoveCopyXOrient
part or assembly DE(Direct Edit) move or copy X-orient method
Definition: zwapi_cmd_direct_edit_data.h:80
VX_DE_MOVE_X_CURVE
@ VX_DE_MOVE_X_CURVE
x-axis curve
Definition: zwapi_cmd_direct_edit_data.h:83
VX_DE_MOVE_X_PLANE
@ VX_DE_MOVE_X_PLANE
guide plane
Definition: zwapi_cmd_direct_edit_data.h:82
VX_DE_MOVE_X_NATURAL
@ VX_DE_MOVE_X_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:81
evxDEMoveCopyZSpine
evxDEMoveCopyZSpine
part or assembly DE(Direct Edit) move or copy Z-spine method
Definition: zwapi_cmd_direct_edit_data.h:69
VX_DE_MOVE_Z_NATURAL
@ VX_DE_MOVE_Z_NATURAL
natural
Definition: zwapi_cmd_direct_edit_data.h:70
VX_DE_MOVE_Z_SPINE
@ VX_DE_MOVE_Z_SPINE
spine
Definition: zwapi_cmd_direct_edit_data.h:71
VX_DE_MOVE_Z_PARALLEL
@ VX_DE_MOVE_Z_PARALLEL
parallel
Definition: zwapi_cmd_direct_edit_data.h:72
evxDEDraftSideType
evxDEDraftSideType
part or assembly DE(Direct Edit) draft about side method
Definition: zwapi_cmd_direct_edit_data.h:293
VX_DE_DRAFT_SIDE_TOP
@ VX_DE_DRAFT_SIDE_TOP
top
Definition: zwapi_cmd_direct_edit_data.h:294
VX_DE_DRAFT_SIDE_BOTTOM
@ VX_DE_DRAFT_SIDE_BOTTOM
bottom
Definition: zwapi_cmd_direct_edit_data.h:295
VX_DE_DRAFT_SIDE_SPILT
@ VX_DE_DRAFT_SIDE_SPILT
split
Definition: zwapi_cmd_direct_edit_data.h:296
VX_DE_DRAFT_SIDE_NEUTRAL
@ VX_DE_DRAFT_SIDE_NEUTRAL
neutral
Definition: zwapi_cmd_direct_edit_data.h:297
evxDEDimMoveType
evxDEDimMoveType
part or assembly DE(Direct Edit) dim move method
Definition: zwapi_cmd_direct_edit_data.h:221
VX_DE_DIM_LINEAR
@ VX_DE_DIM_LINEAR
linear
Definition: zwapi_cmd_direct_edit_data.h:222
VX_DE_DIM_ANGULAR
@ VX_DE_DIM_ANGULAR
angular
Definition: zwapi_cmd_direct_edit_data.h:223
svxDECopy
struct svxDECopy svxDECopy
part or assembly DE(Direct Edit) copy data
svxDEDimMove
struct svxDEDimMove svxDEDimMove
part or assembly DE(Direct Edit) dim move data
svxDEPattern
struct svxDEPattern svxDEPattern
part or assembly DE(Direct Edit) pattern data
svxDEMove
struct svxDEMove svxDEMove
part or assembly DE(Direct Edit) move data
svxDEOffset
struct svxDEOffset svxDEOffset
part or assembly DE(Direct Edit) face offset data
svxDEDraft
struct svxDEDraft svxDEDraft
part or assembly DE(Direct Edit) draft data
svxDERad
struct svxDERad svxDERad
part or assembly DE(Direct Edit) modify radius data
svxDEAlignMove
struct svxDEAlignMove svxDEAlignMove
part or assembly DE(Direct Edit) align move data
svxDEMirror
struct svxDEMirror svxDEMirror
part or assembly DE(Direct Edit) mirror data
svxDEFllt
struct svxDEFllt svxDEFllt
part or assembly DE(Direct Edit) modify fillet data
svxDEAlignMove::idPlane
int idPlane
id of symmetry plane. if type = VX_DE_ALIGN_MOVE_SYMMETRY, the symmetry plane can be face of entity o...
Definition: zwapi_cmd_direct_edit_data.h:210
svxDEAlignMove::idStation
int idStation
id of the stationary entity if type = VX_DE_ALIGN_MOVE_COPLANAR, entity should be plane face or datum...
Definition: zwapi_cmd_direct_edit_data.h:193
svxDEAlignMove::idMotion
int idMotion
id of the motion face entity
Definition: zwapi_cmd_direct_edit_data.h:192
svxDEAlignMove::overflow
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.
Definition: zwapi_cmd_direct_edit_data.h:213
svxDEAlignMove::type
evxDEAlignMoveType type
DE(Direct Edit) align move type.
Definition: zwapi_cmd_direct_edit_data.h:191
svxDEAlignMove::idEnts
int * idEnts
list id of motion group face entities, can be null
Definition: zwapi_cmd_direct_edit_data.h:202
svxDEAlignMove::numEnt
int numEnt
number of motion group face entities
Definition: zwapi_cmd_direct_edit_data.h:201
svxDEAlignMove::angle
double angle
angle.default:0 if type = VX_DE_ALIGN_MOVE_ANGLE, it is the angle of align move. other type can be nu...
Definition: zwapi_cmd_direct_edit_data.h:207
svxDEAlignMove::thruPnt
svxPntOnEnt thruPnt
through point if type > VX_DE_ALIGN_MOVE_CONCENTRIC and type < VX_DE_ALIGN_MOVE_SYMMETRY,...
Definition: zwapi_cmd_direct_edit_data.h:203
svxDEAlignMove
part or assembly DE(Direct Edit) align move data
Definition: zwapi_cmd_direct_edit_data.h:190
svxDECopy::svxDECopyData::svxDECopyDir::dir
svxPntOnEnt dir
the direction of DE(Direct Edit) copy. the copy entities is copy along the direction
Definition: zwapi_cmd_direct_edit_data.h:355
svxDECopy::svxDECopyData::svxDECopyDir::copies
int copies
the copies of DE(Direct Edit) copy.default:1
Definition: zwapi_cmd_direct_edit_data.h:363
svxDECopy::svxDECopyData::svxDECopyDir::dist
double dist
the distance of DE(Direct Edit) copy.default:0. the entities copy distance along the direction
Definition: zwapi_cmd_direct_edit_data.h:357
svxDECopy::svxDECopyData::svxDECopyDir::useCopies
int useCopies
whether to have more than one copies (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_direct_edit_data.h:362
svxDECopy::svxDECopyData::svxDECopyDir::useAng
int useAng
whether to use angle (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_direct_edit_data.h:359
svxDECopy::svxDECopyData::svxDECopyDir::ang
double ang
the angle of DE(Direct Edit) copy.default:0. the entities rotation angle around the dir
Definition: zwapi_cmd_direct_edit_data.h:360
svxDECopy::svxDECopyData::svxDECopyDir
copy along a direction type
Definition: zwapi_cmd_direct_edit_data.h:354
svxDECopy::svxDECopyData::svxDECopyDyn::x
svxVector x
the x axis of handle direction.default:(1,0,0)
Definition: zwapi_cmd_direct_edit_data.h:338
svxDECopy::svxDECopyData::svxDECopyDyn::y
svxVector y
the y axis of handle direction.default:(0,1,0)
Definition: zwapi_cmd_direct_edit_data.h:339
svxDECopy::svxDECopyData::svxDECopyDyn::z
svxVector z
the z axis of handle direction.default:(0,0,1)
Definition: zwapi_cmd_direct_edit_data.h:340
svxDECopy::svxDECopyData::svxDECopyDyn::position
svxPoint position
the position of handle direction user can adjust the handle position to move,copy or rotate entities
Definition: zwapi_cmd_direct_edit_data.h:336
svxDECopy::svxDECopyData::svxDECopyDyn::handle
int handle
whether to copy handle only (0 = no, 1 = yes).default:0
Definition: zwapi_cmd_direct_edit_data.h:335
svxDECopy::svxDECopyData::svxDECopyDyn
dynamic copy type
Definition: zwapi_cmd_direct_edit_data.h:334
svxDECopy::svxDECopyData::svxDECopyFrame::fromFrmae
int fromFrmae
the from frame id of DE(Direct Edit) copy
Definition: zwapi_cmd_direct_edit_data.h:376
svxDECopy::svxDECopyData::svxDECopyFrame::cnt
int cnt
number of toFrames
Definition: zwapi_cmd_direct_edit_data.h:377
svxDECopy::svxDECopyData::svxDECopyFrame::toFrmaes
int * toFrmaes
the to frame id of DE(Direct Edit) move
Definition: zwapi_cmd_direct_edit_data.h:378
svxDECopy::svxDECopyData::svxDECopyFrame
copy by aligning frame type
Definition: zwapi_cmd_direct_edit_data.h:375
svxDECopy::svxDECopyData::svxDECopyPath::idCrv
int idCrv
the curve of spine. if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can...
Definition: zwapi_cmd_direct_edit_data.h:393
svxDECopy::svxDECopyData::svxDECopyPath::zSpine
evxDEMoveCopyZSpine zSpine
Z spine type.default:VX_DE_MOVE_Z_NATURAL.
Definition: zwapi_cmd_direct_edit_data.h:392
svxDECopy::svxDECopyData::svxDECopyPath::frame
evxDEMoveCopyFrame frame
frame type.default:VX_DE_MOVE_FRAME_NATURAL
Definition: zwapi_cmd_direct_edit_data.h:387
svxDECopy::svxDECopyData::svxDECopyPath::numPnt
int numPnt
number of the to point of DE(Direct Edit) copy
Definition: zwapi_cmd_direct_edit_data.h:384
svxDECopy::svxDECopyData::svxDECopyPath::toPnt
svxPntOnEnt * toPnt
list of the to point of DE(Direct Edit) copy
Definition: zwapi_cmd_direct_edit_data.h:385
svxDECopy::svxDECopyData::svxDECopyPath::pathPnt
svxPntOnEnt pathPnt
the point on the path entities . the entities copy to the point pathPnt project on entities along the...
Definition: zwapi_cmd_direct_edit_data.h:382
svxDECopy::svxDECopyData::svxDECopyPath::xOrient
evxDEMoveCopyXOrient xOrient
X orient type.default:VX_DE_MOVE_X_NATURAL.
Definition: zwapi_cmd_direct_edit_data.h:400
svxDECopy::svxDECopyData::svxDECopyPath::planeZ
svxPntOnEnt planeZ
the vector of plane. if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type ...
Definition: zwapi_cmd_direct_edit_data.h:396
svxDECopy::svxDECopyData::svxDECopyPath::idSwp
int idSwp
the id of swp frame . if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame...
Definition: zwapi_cmd_direct_edit_data.h:388
svxDECopy::svxDECopyData::svxDECopyPath::planeX
svxPntOnEnt planeX
the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be...
Definition: zwapi_cmd_direct_edit_data.h:401
svxDECopy::svxDECopyData::svxDECopyPath::crv
svxPntOnEnt crv
the point on x-axis curve entity. if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve....
Definition: zwapi_cmd_direct_edit_data.h:404
svxDECopy::svxDECopyData::svxDECopyPath
copy along path type
Definition: zwapi_cmd_direct_edit_data.h:381
svxDECopy::svxDECopyData::svxDECopyPnt::cntToPnt
int cntToPnt
count of toPnt
Definition: zwapi_cmd_direct_edit_data.h:345
svxDECopy::svxDECopyData::svxDECopyPnt::toPnt
svxPntOnEnt * toPnt
the end point of DE(Direct Edit) copy. the relative position of toPnt and copy entities and the relat...
Definition: zwapi_cmd_direct_edit_data.h:346
svxDECopy::svxDECopyData::svxDECopyPnt::fromVec
svxPntOnEnt fromVec
the from vector
Definition: zwapi_cmd_direct_edit_data.h:349
svxDECopy::svxDECopyData::svxDECopyPnt::fromPnt
svxPntOnEnt fromPnt
the start point of DE(Direct Edit) copy
Definition: zwapi_cmd_direct_edit_data.h:344
svxDECopy::svxDECopyData::svxDECopyPnt::toVec
svxPntOnEnt toVec
the to vector the old entities rotate from fromVec to toVec, get the copy entities
Definition: zwapi_cmd_direct_edit_data.h:350
svxDECopy::svxDECopyData::svxDECopyPnt
copy entities point to point type
Definition: zwapi_cmd_direct_edit_data.h:343
svxDECopy::svxDECopyData::svxDECopyRotate::ang
double ang
the rotate angle of rotation.default:0 the entities rotate around axis about ang
Definition: zwapi_cmd_direct_edit_data.h:369
svxDECopy::svxDECopyData::svxDECopyRotate::copies
int copies
the copies of DE(Direct Edit) copy.default:1
Definition: zwapi_cmd_direct_edit_data.h:372
svxDECopy::svxDECopyData::svxDECopyRotate::useCopies
int useCopies
whether to have more than one copies (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_direct_edit_data.h:371
svxDECopy::svxDECopyData::svxDECopyRotate::dir
svxPntOnEnt dir
the direction of DE(Direct Edit) copy. the copy entities is copy along the direction
Definition: zwapi_cmd_direct_edit_data.h:367
svxDECopy::svxDECopyData::svxDECopyRotate
rotate around a direction type
Definition: zwapi_cmd_direct_edit_data.h:366
svxDECopy::type
evxDEMoveCopyType type
DE(Direct Edit) copy type.
Definition: zwapi_cmd_direct_edit_data.h:328
svxDECopy::numEnt
int numEnt
number of face entities need to be used DE(Direct Edit) copy command
Definition: zwapi_cmd_direct_edit_data.h:329
svxDECopy::idEnts
int * idEnts
list id of face entities need to be used DE(Direct Edit) copy command
Definition: zwapi_cmd_direct_edit_data.h:330
svxDECopy
part or assembly DE(Direct Edit) copy data
Definition: zwapi_cmd_direct_edit_data.h:327
svxDEDimMove::dir
svxPntOnEnt dir
measure direction if type = VX_DE_DIM_LINEAR, the direction is given by user, can be null
Definition: zwapi_cmd_direct_edit_data.h:246
svxDEDimMove::isSwitch
int isSwitch
switch point and entity.(0/1) if type=VX_DE_DIM_ANGULAR, ignore it.
Definition: zwapi_cmd_direct_edit_data.h:235
svxDEDimMove::anchorPnt
svxPntOnEnt anchorPnt
through point if type = VX_DE_DIM_LINEAR, the point is given by user, can be null
Definition: zwapi_cmd_direct_edit_data.h:244
svxDEDimMove::overflow
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.
Definition: zwapi_cmd_direct_edit_data.h:251
svxDEDimMove::angle
double angle
angle.default:0 if type = VX_DE_DIM_ANGULAR, it is the angle of align move other type can be null
Definition: zwapi_cmd_direct_edit_data.h:248
svxDEDimMove::idStation
int idStation
id of the stationary entity
Definition: zwapi_cmd_direct_edit_data.h:234
svxDEDimMove::idMotion
int idMotion
id of the motion face entity
Definition: zwapi_cmd_direct_edit_data.h:233
svxDEDimMove::stationPnt
svxPoint stationPnt
if type=VX_DE_DIM_LINEAR and isSwitch=1,apply it. else ignore it. this point must be on the surface o...
Definition: zwapi_cmd_direct_edit_data.h:237
svxDEDimMove::idEnts
int * idEnts
list id of motion group face entities
Definition: zwapi_cmd_direct_edit_data.h:240
svxDEDimMove::dist
double dist
the dim move distance.default:0 if type = VX_DE_DIM_LINEAR, the distance is given by user other type ...
Definition: zwapi_cmd_direct_edit_data.h:241
svxDEDimMove::numEnt
int numEnt
number of motion group face entities
Definition: zwapi_cmd_direct_edit_data.h:239
svxDEDimMove::type
evxDEDimMoveType type
DE(Direct Edit) align move type.
Definition: zwapi_cmd_direct_edit_data.h:232
svxDEDimMove
part or assembly DE(Direct Edit) dim move data
Definition: zwapi_cmd_direct_edit_data.h:231
svxDEDraft::numEdge
int numEdge
number of parting edge entities to terminate draft
Definition: zwapi_cmd_direct_edit_data.h:313
svxDEDraft::idDrafts
int * idDrafts
list id of edge entities on the draft face
Definition: zwapi_cmd_direct_edit_data.h:309
svxDEDraft::overflow
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.
Definition: zwapi_cmd_direct_edit_data.h:315
svxDEDraft::dir
svxPntOnEnt dir
the draft direction
Definition: zwapi_cmd_direct_edit_data.h:311
svxDEDraft::idFaces
int * idFaces
list id of face entities to draft
Definition: zwapi_cmd_direct_edit_data.h:307
svxDEDraft::numDraft
int numDraft
number of edge entities on the draft face
Definition: zwapi_cmd_direct_edit_data.h:308
svxDEDraft::angle
double angle
the draft angle.default:0
Definition: zwapi_cmd_direct_edit_data.h:310
svxDEDraft::idEgdes
int * idEgdes
list id of parting edge entities to terminate draft
Definition: zwapi_cmd_direct_edit_data.h:314
svxDEDraft::side
evxDEDraftSideType side
the type of side to draft.default:VX_DE_DRAFT_SIDE_SPILT
Definition: zwapi_cmd_direct_edit_data.h:312
svxDEDraft::numFace
int numFace
number of face entities to draft
Definition: zwapi_cmd_direct_edit_data.h:306
svxDEDraft
part or assembly DE(Direct Edit) draft data
Definition: zwapi_cmd_direct_edit_data.h:305
svxDEFllt::idEnts
int * idEnts
list id of fillet entities need to be edited command
Definition: zwapi_cmd_direct_edit_data.h:582
svxDEFllt::numEnt
int numEnt
number of fillet entities need to be edited command
Definition: zwapi_cmd_direct_edit_data.h:581
svxDEFllt::strategy
int strategy
closing strategy.default:0. 0 - auto. 1 - selected
Definition: zwapi_cmd_direct_edit_data.h:591
svxDEFllt::R
double R
the edit radius of fillet.default:5
Definition: zwapi_cmd_direct_edit_data.h:583
svxDEFllt::numEdge
int numEdge
number of list edge or direction entities
Definition: zwapi_cmd_direct_edit_data.h:594
svxDEFllt::hold
int hold
whether to hold fillet to edge(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_direct_edit_data.h:590
svxDEFllt::relief
double relief
the relief of fillet.default:0
Definition: zwapi_cmd_direct_edit_data.h:585
svxDEFllt::idEgdes
int * idEgdes
list id of list edge or direction entities
Definition: zwapi_cmd_direct_edit_data.h:595
svxDEFllt::chain
int chain
whether to chain pick with same R(0 = no, 1 = yes).default:0
Definition: zwapi_cmd_direct_edit_data.h:584
svxDEFllt::ratio
double ratio
the conic ratio .default:0.5. if arcType = 1, it can be given by user . other type can be null
Definition: zwapi_cmd_direct_edit_data.h:587
svxDEFllt::arcType
int arcType
the arc type of fillet(0 = circular, 1 = conic).default:0
Definition: zwapi_cmd_direct_edit_data.h:586
svxDEFllt
part or assembly DE(Direct Edit) modify fillet data
Definition: zwapi_cmd_direct_edit_data.h:580
svxDEMirror::original
int original
whether keep the original entities (0 = no, 1 = yes).default:1 0 - the entities move to the symmetRic...
Definition: zwapi_cmd_direct_edit_data.h:420
svxDEMirror::numEnt
int numEnt
number of face entities need to be used DE(Direct Edit) mirror command
Definition: zwapi_cmd_direct_edit_data.h:417
svxDEMirror::idEnts
int * idEnts
list id of face entities need to be used DE(Direct Edit) mirror command
Definition: zwapi_cmd_direct_edit_data.h:418
svxDEMirror::idPlane
int idPlane
the id of symmetric plane, it should be datum plane, planar face or sketch
Definition: zwapi_cmd_direct_edit_data.h:419
svxDEMirror
part or assembly DE(Direct Edit) mirror data
Definition: zwapi_cmd_direct_edit_data.h:416
svxDEMove::svxDEMoveData::svxDEMoveDir::dir
svxPntOnEnt dir
the direction of DE(Direct Edit) move the move entities is move along the direction
Definition: zwapi_cmd_direct_edit_data.h:119
svxDEMove::svxDEMoveData::svxDEMoveDir::angOption
int angOption
whether to use angle (0 = no, 1 = yes) Default:1
Definition: zwapi_cmd_direct_edit_data.h:125
svxDEMove::svxDEMoveData::svxDEMoveDir::ang
double ang
the angle of DE(Direct Edit) move.default:0 the entities rotation angle around the dir
Definition: zwapi_cmd_direct_edit_data.h:123
svxDEMove::svxDEMoveData::svxDEMoveDir::dist
double dist
the distance of DE(Direct Edit) move.default:0 the entities move distance along the direction
Definition: zwapi_cmd_direct_edit_data.h:121
svxDEMove::svxDEMoveData::svxDEMoveDir
move along a direction type
Definition: zwapi_cmd_direct_edit_data.h:118
svxDEMove::svxDEMoveData::svxDEMoveDyn::handle
int handle
whether to move handle only (0 = no, 1 = yes).Default:0
Definition: zwapi_cmd_direct_edit_data.h:100
svxDEMove::svxDEMoveData::svxDEMoveDyn::y
svxVector y
the y axis of handle direction.default:(0,1,0)
Definition: zwapi_cmd_direct_edit_data.h:104
svxDEMove::svxDEMoveData::svxDEMoveDyn::z
svxVector z
the z axis of handle direction.default:(0,0,1)
Definition: zwapi_cmd_direct_edit_data.h:105
svxDEMove::svxDEMoveData::svxDEMoveDyn::x
svxVector x
the x axis of handle direction.default:(1,0,0)
Definition: zwapi_cmd_direct_edit_data.h:103
svxDEMove::svxDEMoveData::svxDEMoveDyn::position
svxPoint position
the position of handle direction user can adjust the handle position or move, copy,...
Definition: zwapi_cmd_direct_edit_data.h:101
svxDEMove::svxDEMoveData::svxDEMoveDyn
dynamic move type
Definition: zwapi_cmd_direct_edit_data.h:99
svxDEMove::svxDEMoveData::svxDEMoveFrame::fromFrmae
int fromFrmae
the from frame id of DE(Direct Edit) move
Definition: zwapi_cmd_direct_edit_data.h:137
svxDEMove::svxDEMoveData::svxDEMoveFrame::toFrmae
int toFrmae
the to frame id of DE(Direct Edit) move
Definition: zwapi_cmd_direct_edit_data.h:138
svxDEMove::svxDEMoveData::svxDEMoveFrame
move by aligning frame type
Definition: zwapi_cmd_direct_edit_data.h:136
svxDEMove::svxDEMoveData::svxDEMovePath::xOrient
evxDEMoveCopyXOrient xOrient
X orient type.default:VX_DE_MOVE_X_NATURAL.
Definition: zwapi_cmd_direct_edit_data.h:159
svxDEMove::svxDEMoveData::svxDEMovePath::crv
svxPntOnEnt crv
the point on x-axis curve entity if xOrient = VX_DE_MOVE_X_CURVE, it is the point on x-axis curve oth...
Definition: zwapi_cmd_direct_edit_data.h:163
svxDEMove::svxDEMoveData::svxDEMovePath::toPnt
svxPntOnEnt toPnt
the to point of DE(Direct Edit) move
Definition: zwapi_cmd_direct_edit_data.h:144
svxDEMove::svxDEMoveData::svxDEMovePath::idSwp
int idSwp
the id of swp frame if frame = VX_DE_MOVE_FRAME_SELECT, the swp frame is given by idSwp other frame t...
Definition: zwapi_cmd_direct_edit_data.h:147
svxDEMove::svxDEMoveData::svxDEMovePath::planeX
svxPntOnEnt planeX
the vector of plane if xOrient = VX_DE_MOVE_X_PLANE, it is the point on guide plane other type can be...
Definition: zwapi_cmd_direct_edit_data.h:160
svxDEMove::svxDEMoveData::svxDEMovePath::idCrv
int idCrv
the curve of spine if zSpine = VX_DE_MOVE_Z_SPINE, the curve is given by idCrv other zSpine type can ...
Definition: zwapi_cmd_direct_edit_data.h:152
svxDEMove::svxDEMoveData::svxDEMovePath::pathPnt
svxPntOnEnt pathPnt
the point on the path entities the entities move to the point pathPnt project on entities along the p...
Definition: zwapi_cmd_direct_edit_data.h:142
svxDEMove::svxDEMoveData::svxDEMovePath::planeZ
svxPntOnEnt planeZ
the vector of plane if zSpine = VX_DE_MOVE_Z_PARALLEL, it is the point on parallel plane other type c...
Definition: zwapi_cmd_direct_edit_data.h:155
svxDEMove::svxDEMoveData::svxDEMovePath::zSpine
evxDEMoveCopyZSpine zSpine
Z spine type.default:VX_DE_MOVE_Z_NATURAL.
Definition: zwapi_cmd_direct_edit_data.h:151
svxDEMove::svxDEMoveData::svxDEMovePath::frame
evxDEMoveCopyFrame frame
frame type.default:VX_DE_MOVE_FRAME_PATH
Definition: zwapi_cmd_direct_edit_data.h:146
svxDEMove::svxDEMoveData::svxDEMovePath
move along path type
Definition: zwapi_cmd_direct_edit_data.h:141
svxDEMove::svxDEMoveData::svxDEMovePnt::toVec
svxPntOnEnt toVec
the to vector the old entities rotate from fromVec to toVec, get the move entities
Definition: zwapi_cmd_direct_edit_data.h:114
svxDEMove::svxDEMoveData::svxDEMovePnt::fromVec
svxPntOnEnt fromVec
the from vector
Definition: zwapi_cmd_direct_edit_data.h:113
svxDEMove::svxDEMoveData::svxDEMovePnt::fromPnt
svxPntOnEnt fromPnt
the start point of DE(Direct Edit) move
Definition: zwapi_cmd_direct_edit_data.h:109
svxDEMove::svxDEMoveData::svxDEMovePnt::toPnt
svxPntOnEnt toPnt
the end point of DE(Direct Edit) move the relative position of toPnt and moved entities and the relat...
Definition: zwapi_cmd_direct_edit_data.h:110
svxDEMove::svxDEMoveData::svxDEMovePnt
move entities point to point type
Definition: zwapi_cmd_direct_edit_data.h:108
svxDEMove::svxDEMoveData::svxDEMoveRotate::ang
double ang
the rotate angle of rotation.default:0 the entities rotate around axis about ang
Definition: zwapi_cmd_direct_edit_data.h:132
svxDEMove::svxDEMoveData::svxDEMoveRotate::axis
svxPntOnEnt axis
the direction of rotation
Definition: zwapi_cmd_direct_edit_data.h:131
svxDEMove::svxDEMoveData::svxDEMoveRotate::dir
svxPntOnEnt dir
the direction of DE(Direct Edit) move the move entities is move along the direction
Definition: zwapi_cmd_direct_edit_data.h:129
svxDEMove::svxDEMoveData::svxDEMoveRotate
rotate around a direction type
Definition: zwapi_cmd_direct_edit_data.h:128
svxDEMove::type
evxDEMoveCopyType type
DE(Direct Edit) move type.
Definition: zwapi_cmd_direct_edit_data.h:92
svxDEMove::numEnt
int numEnt
number of face entities need to be used DE(Direct Edit) move command
Definition: zwapi_cmd_direct_edit_data.h:93
svxDEMove::idEnts
int * idEnts
list id of face entities need to be used DE(Direct Edit) move command
Definition: zwapi_cmd_direct_edit_data.h:94
svxDEMove::overflow
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.
Definition: zwapi_cmd_direct_edit_data.h:95
svxDEMove
part or assembly DE(Direct Edit) move data
Definition: zwapi_cmd_direct_edit_data.h:91
svxDEOffset::overflow
evxDEFaceOverflow overflow
DE(Direct Edit) overflow type.default:VX_DE_OVERFLOW_AUTO.
Definition: zwapi_cmd_direct_edit_data.h:285
svxDEOffset::idEnts
int * idEnts
list id of face entities to set offset
Definition: zwapi_cmd_direct_edit_data.h:281
svxDEOffset::intersection
evxDEIsectType intersection
intersection.default:VX_DE_ISECT_NO_REMOVE
Definition: zwapi_cmd_direct_edit_data.h:284
svxDEOffset::dist
double dist
the offset distance.default:0
Definition: zwapi_cmd_direct_edit_data.h:282
svxDEOffset::side
evxDESideFaceType side
side face type.default:VX_DE_SIDE_FACE_CREATE
Definition: zwapi_cmd_direct_edit_data.h:283
svxDEOffset::numEnt
int numEnt
number of face entities to set offset
Definition: zwapi_cmd_direct_edit_data.h:280
svxDEOffset
part or assembly DE(Direct Edit) face offset data
Definition: zwapi_cmd_direct_edit_data.h:279
svxDEPattern::svxDEPtnData::svxDEPtnCircular::num
int num[2]
the number of pattern.default:(2,1) the 1st number is how many direction to form pattern the 2nd numb...
Definition: zwapi_cmd_direct_edit_data.h:497
svxDEPattern::svxDEPtnData::svxDEPtnCircular::derive
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE
Definition: zwapi_cmd_direct_edit_data.h:501
svxDEPattern::svxDEPtnData::svxDEPtnCircular::stagger
int stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0
Definition: zwapi_cmd_direct_edit_data.h:504
svxDEPattern::svxDEPtnData::svxDEPtnCircular::dir
svxPntOnEnt dir
the direction of the pattern
Definition: zwapi_cmd_direct_edit_data.h:493
svxDEPattern::svxDEPtnData::svxDEPtnCircular::min
double min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing
Definition: zwapi_cmd_direct_edit_data.h:502
svxDEPattern::svxDEPtnData::svxDEPtnCircular::align
int align
the alignment type(0 = align with base, 1= align with pattern).default:1
Definition: zwapi_cmd_direct_edit_data.h:505
svxDEPattern::svxDEPtnData::svxDEPtnCircular::diameter
double diameter
the diameter between the base entity and the first entity of pattern.default:0
Definition: zwapi_cmd_direct_edit_data.h:494
svxDEPattern::svxDEPtnData::svxDEPtnCircular::ang
double ang
the angle between direction and next direction.default:45 the next direction is given by dir and ang
Definition: zwapi_cmd_direct_edit_data.h:495
svxDEPattern::svxDEPtnData::svxDEPtnCircular::spacing
double spacing
the spacing between entities in pattern on two direction.default:20
Definition: zwapi_cmd_direct_edit_data.h:500
svxDEPattern::svxDEPtnData::svxDEPtnCircular
circular DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:492
svxDEPattern::svxDEPtnData::svxDEPtnCurve::crvType
evxDEPtnCrv crvType
the curve method.default:VX_DE_PTN_CRV1
Definition: zwapi_cmd_direct_edit_data.h:522
svxDEPattern::svxDEPtnData::svxDEPtnCurve::spacing
double spacing[2]
the spacing between entity on two direction.default:(20,20)
Definition: zwapi_cmd_direct_edit_data.h:529
svxDEPattern::svxDEPtnData::svxDEPtnCurve::num
int num[2]
the number of entity on two direction.default:(2,1)
Definition: zwapi_cmd_direct_edit_data.h:528
svxDEPattern::svxDEPtnData::svxDEPtnCurve::bound
evxDEPtnBound bound
the boundary type
Definition: zwapi_cmd_direct_edit_data.h:539
svxDEPattern::svxDEPtnData::svxDEPtnCurve::idFace
int idFace
the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on
Definition: zwapi_cmd_direct_edit_data.h:535
svxDEPattern::svxDEPtnData::svxDEPtnCurve::numBound
int numBound
number of boundary entities if type = 1, numBound = 1 if type = 2 or 3, numBound = 2 if type = 4,...
Definition: zwapi_cmd_direct_edit_data.h:523
svxDEPattern::svxDEPtnData::svxDEPtnCurve::useFromPnt
int useFromPnt
1 if use fromPnt, else 0. default:0
Definition: zwapi_cmd_direct_edit_data.h:537
svxDEPattern::svxDEPtnData::svxDEPtnCurve::derive
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE
Definition: zwapi_cmd_direct_edit_data.h:530
svxDEPattern::svxDEPtnData::svxDEPtnCurve::align
int align
the alignment type(0 = align with base, 1= align with pattern).default:1
Definition: zwapi_cmd_direct_edit_data.h:534
svxDEPattern::svxDEPtnData::svxDEPtnCurve::fromPnt
svxPntOnEnt fromPnt
the from point, pick a point where the pattern starts from
Definition: zwapi_cmd_direct_edit_data.h:538
svxDEPattern::svxDEPtnData::svxDEPtnCurve::min
double min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing
Definition: zwapi_cmd_direct_edit_data.h:531
svxDEPattern::svxDEPtnData::svxDEPtnCurve::stagger
int stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0
Definition: zwapi_cmd_direct_edit_data.h:533
svxDEPattern::svxDEPtnData::svxDEPtnCurve::pBounds
int * pBounds
the list id of boundary entities
Definition: zwapi_cmd_direct_edit_data.h:527
svxDEPattern::svxDEPtnData::svxDEPtnCurve
at curve(s) DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:521
svxDEPattern::svxDEPtnData::svxDEPtnFace::spacing
double spacing[2]
the spacing between entity on two direction.default:(20,20)
Definition: zwapi_cmd_direct_edit_data.h:546
svxDEPattern::svxDEPtnData::svxDEPtnFace::align
int align
the alignment type(0 = align with base, 1= align with pattern).default:1
Definition: zwapi_cmd_direct_edit_data.h:551
svxDEPattern::svxDEPtnData::svxDEPtnFace::stagger
int stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0
Definition: zwapi_cmd_direct_edit_data.h:550
svxDEPattern::svxDEPtnData::svxDEPtnFace::min
double min
the minimum spacing.default:0 drops out instances that do not have the minimum spacing
Definition: zwapi_cmd_direct_edit_data.h:548
svxDEPattern::svxDEPtnData::svxDEPtnFace::num
int num[2]
the number of entity on two direction.default:(2,1)
Definition: zwapi_cmd_direct_edit_data.h:545
svxDEPattern::svxDEPtnData::svxDEPtnFace::fromPnt
svxPntOnEnt fromPnt
the from point, pick a point where the pattern starts from
Definition: zwapi_cmd_direct_edit_data.h:553
svxDEPattern::svxDEPtnData::svxDEPtnFace::idFace
int idFace
the id of on face entity the face that you want the pattern to be located on
Definition: zwapi_cmd_direct_edit_data.h:543
svxDEPattern::svxDEPtnData::svxDEPtnFace::bound
evxDEPtnBound bound
the boundary type
Definition: zwapi_cmd_direct_edit_data.h:554
svxDEPattern::svxDEPtnData::svxDEPtnFace::useFromPnt
int useFromPnt
1 if use fromPnt, else 0. default:0
Definition: zwapi_cmd_direct_edit_data.h:552
svxDEPattern::svxDEPtnData::svxDEPtnFace::derive
evxDEPtnDerive derive
the derive type.default:VX_DE_PTN_DERIVE_NONE
Definition: zwapi_cmd_direct_edit_data.h:547
svxDEPattern::svxDEPtnData::svxDEPtnFace
at face DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:542
svxDEPattern::svxDEPtnData::svxDEPtnLinear::spacing
double spacing[2]
the spacing between entity on two direction.default:(20,20)
Definition: zwapi_cmd_direct_edit_data.h:488
svxDEPattern::svxDEPtnData::svxDEPtnLinear::stagger
int stagger
whether use stagger pattern (0 = no stagger, 1 = stagger pattern).default:0
Definition: zwapi_cmd_direct_edit_data.h:489
svxDEPattern::svxDEPtnData::svxDEPtnLinear::dir
svxPntOnEnt dir[2]
the direction of the pattern
Definition: zwapi_cmd_direct_edit_data.h:486
svxDEPattern::svxDEPtnData::svxDEPtnLinear::num
int num[2]
the number of entity on two direction.default:(2,1)
Definition: zwapi_cmd_direct_edit_data.h:487
svxDEPattern::svxDEPtnData::svxDEPtnLinear
linear DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:485
svxDEPattern::svxDEPtnData::svxDEPtnPattern::idPattern
int idPattern
the id of pattern feature
Definition: zwapi_cmd_direct_edit_data.h:518
svxDEPattern::svxDEPtnData::svxDEPtnPattern
at pattern DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:517
svxDEPattern::svxDEPtnData::svxDEPtnPoint::fromPnt
svxPntOnEnt fromPnt
the from point of pattern
Definition: zwapi_cmd_direct_edit_data.h:509
svxDEPattern::svxDEPtnData::svxDEPtnPoint::align
int align
the alignment type(0 = align with base, 1= align with pattern).default:1
Definition: zwapi_cmd_direct_edit_data.h:512
svxDEPattern::svxDEPtnData::svxDEPtnPoint::numTo
int numTo
number of to point
Definition: zwapi_cmd_direct_edit_data.h:510
svxDEPattern::svxDEPtnData::svxDEPtnPoint::idFace
int idFace
the id of on face entity.idFace<=0 to ignore. the face that you want the pattern to be located on
Definition: zwapi_cmd_direct_edit_data.h:513
svxDEPattern::svxDEPtnData::svxDEPtnPoint::toPnts
svxPntOnEnt * toPnts
the list of to point
Definition: zwapi_cmd_direct_edit_data.h:511
svxDEPattern::svxDEPtnData::svxDEPtnPoint
point to point DE(Direct Edit) pattern type
Definition: zwapi_cmd_direct_edit_data.h:508
svxDEPattern::firstTogglePos
int * firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in t...
Definition: zwapi_cmd_direct_edit_data.h:558
svxDEPattern::type
evxDEPtnType type
DE(Direct Edit) pattern type.
Definition: zwapi_cmd_direct_edit_data.h:479
svxDEPattern::idEnts
int * idEnts
list id of face entities need to be used DE(Direct Edit) pattern command
Definition: zwapi_cmd_direct_edit_data.h:481
svxDEPattern::cntSkip
int cntSkip
number of the instances to be skipped
Definition: zwapi_cmd_direct_edit_data.h:557
svxDEPattern::numEnt
int numEnt
number of face entities need to be used DE(Direct Edit) pattern command
Definition: zwapi_cmd_direct_edit_data.h:480
svxDEPattern::secondTogglePos
int * secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in ...
Definition: zwapi_cmd_direct_edit_data.h:561
svxDEPattern
part or assembly DE(Direct Edit) pattern data
Definition: zwapi_cmd_direct_edit_data.h:478
svxDERad::numEnt
int numEnt
number of face entities need to be edited radius command
Definition: zwapi_cmd_direct_edit_data.h:604
svxDERad::R
double R
the edit radius of face.default:1
Definition: zwapi_cmd_direct_edit_data.h:606
svxDERad::idEnts
int * idEnts
list id of face entities need to be edited radius command
Definition: zwapi_cmd_direct_edit_data.h:605
svxDERad
part or assembly DE(Direct Edit) modify radius data
Definition: zwapi_cmd_direct_edit_data.h:603
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
svxDECopy::svxDECopyData
Union of DE copy data.
Definition: zwapi_cmd_direct_edit_data.h:332
svxDEMove::svxDEMoveData
union of DE move type
Definition: zwapi_cmd_direct_edit_data.h:97
svxDEPattern::svxDEPtnData
union of De pattern data
Definition: zwapi_cmd_direct_edit_data.h:483
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_CMD_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dwg_data.h
evxAngDimType
evxAngDimType
evxAutoDimType
evxAutoDimType
evxAutoEntType
evxAutoEntType
evxAutoInclude
evxAutoInclude
evxAutoPlacement
evxAutoPlacement
evxBalloonCon
evxBalloonCon
evxBomset
evxBomset
evxBrkLineType
evxBrkLineType
evxCalloutEmt
evxCalloutEmt
evxCentDimType
evxCentDimType
evxCenterLineType
evxCenterLineType
evxDatumDimType
evxDatumDimType
evxDatumTargDimType
evxDatumTargDimType
evxDimLineOffset
evxDimLineOffset
evxDimLineType
evxDimLineType
evxDwgAtBlnArrg
evxDwgAtBlnArrg
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
evxDwgBndMethod
evxDwgBndMethod
evxDwgDepthType
evxDwgDepthType
evxDwgDetailMethod
evxDwgDetailMethod
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
evxDwgHoleMarkType
evxDwgHoleMarkType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
evxDwgLnrChmDimType
evxDwgLnrChmDimType
evxDwgStkBlnPtn
evxDwgStkBlnPtn
evxHatchType
evxHatchType
evxIndentedType
evxIndentedType
evxLevelSet
evxLevelSet
evxLocAngType
evxLocAngType
evxLocType
evxLocType
evxOrderType
evxOrderType
evxOriginType
evxOriginType
evxRadDimType
evxRadDimType
evxRotViewType
evxRotViewType
evxSecMtdType
evxSecMtdType
evxSurfPtnSym
evxSurfPtnSym
evxSymmetryDimType
evxSymmetryDimType
evxSymSurf
evxSymSurf
evxViewDimType
evxViewDimType
evxViewLocationType
evxViewLocationType
evxViewPrjAngType
evxViewPrjAngType
evxViewTypeEx
evxViewTypeEx
evxWeldContourSym
evxWeldContourSym
evxWeldFinishSym
evxWeldFinishSym
svxAlignSecViewData
svxAutoSet
svxAuxViewData
svxBrkLineData
svxCenMarkCirDimData
svxCenterDim
svxCenterLine
svxCenterMark
svxDatumDimData
svxDatumTargDimData
svxDimAuto
svxDimLabel
svxDwgAngDimData
svxDwgArcDimData
svxDwgAtBlnData
svxDwgBalloonDim
svxDwgBom
svxDwgBrokenSectionData
svxDwgConsDim
svxDwgDetailData
svxDwgFtrCtrl
svxDwgHoleCallOutDim
svxDwgHoleMark
svxDwgIsectSym
svxDwgLineDim
svxDwgLineGrpDim
svxDwgLineOffsetDim
svxDwgLnrChmDimData
svxDwgOrdinateDim
svxDwgRotView
svxDwgStkBlnData
svxDwgSymmetryDimData
svxDwgTblInsert
svxFulSecViewData
svxHatchAttr
svxLabelCoorDimData
svxPrjSetting
svxRadDimData
svxSymImg
svxSymSurf
svxSymWeld
svxViewArrow
svxViewAt
svxViewLayoutData
svxViewLayoutMethod
svxViewLocationData
svxViewSecLine
svxViewSecMtd
svxViewSecOp
svxViewStandardData

◆ ZW_API_DWG_CMD_DATA_H

#define ZW_API_DWG_CMD_DATA_H

Definition at line 17 of file zwapi_cmd_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dwg_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_DWG_CMD_DATA_H /* *his ifndef surrounds entire header */
17#define ZW_API_DWG_CMD_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_sk_create_data.h"
21#include "zwapi_dwg_data.h"
22
23#ifdef __cplusplus
24extern "C" {
25#endif /* __cplusplus */
26
27//====================================================================================================================
29//====================================================================================================================
34typedef enum evxViewLocationType
35 {
36 VX_LOCATION_AUTO,
37 VX_LOCATION_CENTER,
38 VX_LOCATION_CORNER,
39 } evxViewLocationType;
40
45typedef struct svxViewLocationData
46 {
47 evxViewLocationType type;
48 svxPoint2 FirstPoint;
50 svxPoint2 SecondPoint;
52 } svxViewLocationData;
53
58typedef struct svxViewLayoutMethod
59 {
60 int projection;
63 int count;
66 evxViewStd StdMethod[7];
70 } svxViewLayoutMethod;
71
76typedef struct svxViewAt
77 {
78 svxWireAt zWireAt;
79 char fHLROn;
80 char fBiarc;
81 char fDupFlt;
82 char fShwDim;
83 char fShwLbl;
84 char fShwScl;
85 char fShwPmi;
87 char fExplod;
88 char fNoProp;
89 char fThread;
90 char fCentLin;
91 char fBendLin;
92 char fWirefrm;
93 char fNoRegen;
94 char fAnno;
95 char fBeads;
96 svxWireAt zLnAt[18];
97 char fShw3DOrig;
98 char fHiddenLin;
99 vxName label;
100 char fScaleType;
104 double dSclRatioX;
105 double dSclRatioY;
106 double dScale;
107 } svxViewAt;
108
113typedef struct svxViewLayoutData
114 {
115 vxPath name;
116 vxRootName root;
117 svxViewLocationData location;
118 int isIgnoreLoc;
119 svxViewLayoutMethod method;
120 int isIgnoreMethod;
121 svxViewAt viewAttr;
122 int isIgnoreAttr;
123 int coordinate;
124 vxName PartConfig;
125 vxName CompConfig;
126 int ExplodedView;
127 int state;
128 int DimensionType;
129 int isCalculate;
130 int cntBlankRefEnts;
131 svxRefEntData* blankRefEntsData;
133 } svxViewLayoutData;
134
139typedef enum evxViewTypeEx
140 {
141 VX_VU_NULL = 0,
142 VX_VU_TOP = 1,
143 VX_VU_FRONT = 2,
144 VX_VU_RIGHT = 3,
145 VX_VU_BACK = 4,
146 VX_VU_BOTTOM = 5,
147 VX_VU_LEFT = 6,
148 VX_VU_ISO_FRONT = 7,
149 VX_VU_AUX = 8,
150 VX_VU_NAME = 9,
151 VX_VU_3RD_UP = 10,
152 VX_VU_3RD_DN = 11,
153 VX_VU_3RD_RT = 12,
154 VX_VU_3RD_LT = 13,
155 VX_VU_1ST_UP = 14,
156 VX_VU_1ST_DN = 15,
157 VX_VU_1ST_RT = 16,
158 VX_VU_1ST_LT = 17,
159 VX_VU_3RD_PRJ_ANG = 18,
160 VX_VU_DETAIL = 19,
161 VX_VU_SECTION = 20,
162 VX_VU_DETAIL_DEF = 21,
163 VX_VU_SECTION_DEF = 22,
164 VX_VU_REV_SECT_DEF = 23,
165 VX_VU_ROTATE = 24,
166 VX_VU_ALIGN_SECT_DEF = 25,
167 VX_VU_PRJ_ANG_ARROWS = 26,
168 VX_VU_BEND_SECT_DEF = 27,
169 VX_VU_ISO_LFT = 28,
170 VX_VU_ISO_LBT = 29,
171 VX_VU_ISO_RBT = 30,
172 VX_VU_ISO_RFB = 31,
173 VX_VU_ISO_LFB = 32,
174 VX_VU_ISO_LBB = 33,
175 VX_VU_ISO_RBB = 34,
176 VX_VU_NAME_SECT_DEF = 35,
177 VX_VU_1ST_PRJ_ANG = 36,
178 VX_VU_BRKSECT = 37,
179 VX_VU_ISOSECT = 38,
180 VX_VU_DIMETRIC = 39,
181 VX_VU_SMD = 40
182 } evxViewTypeEx;
183
188typedef struct svxViewStandardData
189 {
190 vxLongPath path;
191 vxLongPath fileName;
192 vxRootName rootName;
193 int type;
196 union uvxViewTypeData
197 {
198 vxName viewName;
199 vxName flatName;
200 evxViewTypeEx viewType;
201 } option;
202 svxPoint2 location;
203 int isIgnoreAttr;
204 svxViewAt viewAttr;
205 int origin;
206 int coordinate;
207 vxName partConfig;
208 vxName compConfig;
209 int explodedView;
210 int isDispTrails;
211 int state;
212 int dimensionType;
213 int isCalculate;
214 int isOrientation;
215 int cntBlankRefEnts;
216 svxRefEntData* blankRefEntsData;
218 } svxViewStandardData;
219
224typedef enum evxViewPrjAngType
225 {
226 VX_VIEW_PRJANG1ST = 1,
227 VX_VIEW_PRJANG3RD = 2,
228 } evxViewPrjAngType;
229
234typedef enum evxViewDimType
235 {
236 VX_VIEW_DIMTYPEPRJ = 0,
237 VX_VIEW_DIMTYPETRUE = 1,
238 } evxViewDimType;
239
244typedef struct svxPrjSetting
245 {
246 evxViewPrjAngType prjType;
247 evxViewDimType dimType;
248 } svxPrjSetting;
249
254typedef struct svxViewArrow
255 {
256 double offset;
258 int iFlag;
260 svxPoint2 startPnt;
261 svxPoint2 endPnt;
262 } svxViewArrow;
263
268typedef struct svxAuxViewData
269 {
270 int idView;
271 int idLine;
272 svxPoint2 locPnt;
273 svxPrjSetting settings;
274 svxViewArrow arrowInfo;
275 } svxAuxViewData;
276
281typedef enum evxSecMtdType
282 {
283 VX_METHOD_SECCURVE = 1,
284 VX_METHOD_TRIMPART = 2,
285 VX_METHOD_TRIMSURF = 3,
286 } evxSecMtdType;
287
292typedef enum evxLocType
293 {
294 VX_LOC_HORIZONTAL = 1,
295 VX_LOC_VERTICAL = 2,
296 VX_LOC_ORTHOGONAL = 3,
297 VX_LOC_NONE = 4,
298 } evxLocType;
299
304typedef enum evxLocAngType
305 {
306 VX_LOC_ANG_DEFAULT = 0,
307 VX_LOC_ANG_HORIZONTAL = 1,
308 VX_LOC_ANG_VERTICAL = 2,
309 VX_LOC_ANG_CUSTOM = 3,
310 } evxLocAngType;
311
316typedef struct svxViewSecMtd
317 {
318 evxSecMtdType mtdType;
319 int iCloseOpenProf;
320 int iDynScalAng;
321 int inheritSecBasView;
324 evxLocType locType;
325 evxViewDimType dimType;
326 double dSecDepth;
328 evxLocAngType locAngType;
329 double dLocAng;
330 } svxViewSecMtd;
331
336typedef struct svxViewSecLine
337 {
338 char* viewLabel;
341 int iFlipArrow;
342 int iShowStepLines;
343 } svxViewSecLine;
344
349typedef struct svxViewSecOp
350 {
351 int iSecState;
352 int iHatchState;
353 int iHatchClr;
354 } svxViewSecOp;
355
360typedef struct svxFulSecViewData
361 {
362 int idView;
364 int iCnt;
365 svxPoint2* pPnts;
367 svxPoint2 locPnt;
368 svxViewSecMtd secMtd;
369 svxViewSecLine secLine;
370 svxViewSecOp secOp;
371 } svxFulSecViewData;
372
377typedef struct svxAlignSecViewData
378 {
379 int idView;
380 svxPoint2 basePnt;
381 int cntBasePnts;
382 svxPoint2* pBasePnts;
383 int cntAlignPnts;
384 svxPoint2* pAlignPnts;
385 svxPoint2 locPnt;
386 svxViewSecMtd secMtd;
387 svxViewSecLine secLine;
388 svxViewSecOp secOp;
389 } svxAlignSecViewData;
390
395typedef enum evxDwgBndMethod
396 {
397 VX_RECTANGULAR_BOUNDARY = 1,
398 VX_CIRCULAR_BOUNDARY,
399 VX_POLYLINE_BOUNDARY,
400 } evxDwgBndMethod;
401
406typedef enum evxDwgDepthType
407 {
408 VX_DEPTH_POINT,
409 VX_DEPTH_SECTION_PLANE,
410 VX_DEPTH_3D_NAMED,
411 } evxDwgDepthType;
412
417typedef struct svxDwgBrokenSectionData
418 {
419 evxDwgBndMethod method;
420 int idView;
421 svxPoint2* bPoints;
422 int countBPs;
423 evxDwgDepthType type;
424 svxPoint2 dPoint;
425 int idCrv;
427 double dOffset;
428 int dView;
429 vxName name;
430 int isShow;
431 int isDynamicHatch;
432 svxPoint2* oPoints;
433 int countOPs;
434 } svxDwgBrokenSectionData;
435
440typedef enum evxDwgDetailMethod
441 {
442 VX_RECTANGULAR_DETAIL = 1,
443 VX_CIRCULAR_DETAIL = 2,
444 VX_POLYLINE_DETAIL,
445 } evxDwgDetailMethod;
446
451typedef struct svxDwgDetailData
452 {
453 evxDwgDetailMethod method;
454 int idView;
455 int PntCount;
456 svxPntOnEnt* pPnts;
457 svxPntOnEnt NotePnt;
458 int iMultiplier;
459 svxPntOnEnt Location;
460 } svxDwgDetailData;
461
466typedef enum evxBrkLineType
467 {
468 VX_HOR_BRKLINE = 0,
469 VX_VER_BRKLINE,
470 VX_SLANT_BRKLINE
471 } evxBrkLineType;
472
477typedef struct svxBrkLineData
478 {
479 int viewId;
480 evxBrkLineType brkLnType;
481 svxPntOnEnt pts[3];
483 double gap;
484 svxPoint2 dir;
485 } svxBrkLineData;
486
487//====================================================================================================================
489//====================================================================================================================
494typedef enum evxLevelSet
495 {
496 VX_TOP_LEVEL_ONLY = 0,
497 VX_PARTS_ONLY = 1,
498 VX_INDENTED = 3,
499 VX_BALLOON_ONLY = 4,
500 } evxLevelSet;
501
506typedef enum evxIndentedType
507 {
508 VX_NO_NUM = 0,
509 VX_DETAILED_NUM = 1,
510 VX_FLAT_NUM = 2,
511 } evxIndentedType;
512
517typedef enum evxOrderType
518 {
519 VX_ORDER_BYNAME = 0,
520 VX_ORDER_REGEN_IDS = 1,
521 VX_ORDER_ASASM = 2,
522 } evxOrderType;
523
528typedef enum evxBomset
529 {
530 VX_BOM_INVALID = 0x0000,
531 VX_SET_DISP_CFG = 0x0001,
532 VX_DERIVED_PARTS = 0x0002,
533 VX_SYNC_BOM = 0x0004,
534 VX_KEEP_MISSING = 0x0008,
535 VX_STRIKE_THROUGH = 0x0010,
536 VX_BOM_VALID = 0xFFFF
537 } evxBomset;
538
543typedef struct svxDwgBom
544 {
545 int idView;
546 char* name;
547 evxLevelSet level;
548 evxIndentedType indent;
549 int checkMax;
550 int Maxdepthval;
551 int bomset;
552 int startID;
553 evxOrderType order;
554 }svxDwgBom;
555
560typedef enum evxOriginType
561 {
562 VX_TOP_LEFT = 0,
563 VX_TOP_CENTER = 1,
564 VX_TOP_RIGHT = 2,
565 VX_MID_LEFT,
566 VX_MID_CENTER,
567 VX_MID_RIGHT,
568 VX_BOTTOM_LEFT,
569 VX_BOTTOM_CENTER,
570 VX_BOTTOM_RIGHT,
571 } evxOriginType;
572
577typedef struct svxDwgTblInsert
578 {
579 int idTable;
580 svxPoint2 crtpnt;
581 evxOriginType origin;
582 }svxDwgTblInsert;
583
584//====================================================================================================================
586//====================================================================================================================
591typedef enum evxRotViewType
592 {
593 VX_ROTVIEW_TOP = 1,
594 VX_ROTVIEW_FRONT = 2,
595 VX_ROTVIEW_RIGHT,
596 VX_ROTVIEW_BACK,
597 VX_ROTVIEW_BOTTOM,
598 VX_ROTVIEW_LEFT,
599 VX_ROTVIEW_ISOMETRIC,
600 VX_ROTVIEW_ISOMETRIC_LFT,
601 VX_ROTVIEW_ISOMETRIC_LBT,
602 VX_ROTVIEW_ISOMETRIC_RBT,
603 VX_ROTVIEW_ISOMETRIC_RFB,
604 VX_ROTVIEW_ISOMETRIC_LFB,
605 VX_ROTVIEW_ISOMETRIC_LBB,
606 VX_ROTVIEW_ISOMETRIC_RBB,
607 } evxRotViewType;
608
613typedef struct svxDwgRotView
614 {
615 int idView;
616 evxRotViewType view;
617 evxAxisType axis;
618 double angle;
619 }svxDwgRotView;
620
621//====================================================================================================================
623//====================================================================================================================
628typedef enum evxAutoEntType
629 {
630 DIM_AUTO_ENT_ALL = 0,
631 DIM_AUTO_ENT_ARC_CIRCLE,
632 DIM_AUTO_ENT_PICKED
633 }evxAutoEntType;
634
639typedef enum evxAutoDimType
640 {
641 DIM_AUTO_BASELINE = 0,
642 DIM_AUTO_CONTINUOUS = 1,
643 DIM_AUTO_ORDINATE = 2,
644 DIM_AUTO_LABEL_COORDINATE = 3,
645 }evxAutoDimType;
646
651typedef enum evxAutoPlacement
652 {
653 DIM_VIEW_ABOVE_LEFT = 0,
654 DIM_VIEW_BELOW_RIGHT,
655 DIM_VIEW_BOTH,
656 }evxAutoPlacement;
657
662typedef struct svxAutoSet
663 {
664 int enable;
665 evxAutoDimType type;
666 svxPntOnEnt refPnt;
667 evxAutoPlacement viewType;
668 int asgrp;
669 }svxAutoSet;
670
675typedef enum evxAutoInclude
676 {
677 VX_AUTOINC_INVALID = 0x00000000,
678 VX_AUTOINC_ARC = 0x00000001,
679 VX_AUTOINC_CIRCLE = 0x00000002,
680 VX_AUTOINC_HOLE = 0x00000004,
681 VX_AUTOINC_LINE = 0x00000008,
682 VX_AUTOINC_HOLE_CALLOUT = 0x00000010,
683 VX_AUTOINC_CYLIND_DIM = 0x00000020,
684 VX_AUTOINC_MAXIMUM_DIM = 0x00000040,
685 VX_AUTOINC_VALID = 0xFFFFFFFF
686 } evxAutoInclude;
687
692typedef struct svxDimAuto
693 {
694 int idView;
695 evxAutoEntType entType;
696 int cntEnt;
699 int* pEntId;
702 unsigned int incAuto;
705 int checkOrg;
706 svxPntOnEnt pntOrg;
707 svxAutoSet horDim;
708 svxAutoSet verDim;
709 }svxDimAuto;
710
715typedef enum evxDimLineType
716 {
717 VX_DIM_LINE_LH = 1,
718 VX_DIM_LINE_LV = 2,
719 VX_DIM_LINE_LA = 3,
720 VX_DIM_LINE_LR = 4,
721 VX_DIM_LINE_LP = 5,
722 VX_DIM_LINE_LO = 6,
725 } evxDimLineType;
726
731typedef struct svxDwgConsDim
732 {
733 evxDimLineType type;
734 svxPntOnEnt firstPnt;
735 svxPntOnEnt secondPnt;
736 svxPntOnEnt textPnt;
737 }svxDwgConsDim;
738
743typedef struct svxDwgLineDim
744 {
745 svxDwgConsDim cons;
746 double angle;
749 svxPntOnEnt dirPnt;
752 }svxDwgLineDim;
753
758typedef struct svxDwgLineGrpDim
759 {
760 svxDwgLineDim sub;
761 int cntCrv;
762 svxPntOnEnt* Points;
763 }svxDwgLineGrpDim;
764
769typedef struct svxDwgOrdinateDim
770 {
771 svxDwgLineDim sub;
772 int cntCrv;
773 svxPntOnEnt* Points;
774 int reverseAxis1;
775 int reverseAxis2;
776 int idEnt;
777 svxPntOnEnt textPnt[2];
779 }svxDwgOrdinateDim;
780
785typedef enum evxSymmetryDimType
786 {
787 VX_SYM_LINEAR = 1,
788 VX_SYM_ANGULAR = 2,
789 } evxSymmetryDimType;
790
795typedef enum evxDimLineOffset
796 {
797 VX_DIM_OFFSET_LOL = 1,
798 VX_DIM_OFFSET_LOP = 2,
799 } evxDimLineOffset;
800
805typedef struct svxDwgLineOffsetDim
806 {
807 evxDimLineOffset type;
808 svxPntOnEnt firstPnt;
809 svxPntOnEnt secondPnt;
810 svxPntOnEnt textPnt;
811 }svxDwgLineOffsetDim;
812
817typedef struct svxDwgSymmetryDimData
818 {
819 evxSymmetryDimType type;
820 svxPntOnEnt Pnt;
821 svxPntOnEnt LinePnt;
822 svxPntOnEnt CenterLinePnt;
823 svxPntOnEnt txtPnt;
824 int autoSwitchAttr;
826 } svxDwgSymmetryDimData;
827
832typedef enum evxDwgLnrChmDimType
833 {
834 VX_LEADER_CHAMFERDIM = 1,
835 VX_ALIGNED_CHAMFERDIM,
836 VX_HORZORVERT_CHAMFERDIM
837 } evxDwgLnrChmDimType;
838
843typedef enum evxDwgLnrChmDimTexType
844 {
845 VX_TEXT_NOR_CHAMFERDIM = 0,
846 VX_TEXT_PERPENDICULAR_CHAMFERDIM,
847 VX_TEXT_ALGMODLIN_CHAMFERDIM
848 } evxDwgLnrChmDimTexType;
849
854typedef struct svxDwgLnrChmDimData
855 {
856 svxPntOnEnt LineEnt;
859 evxDwgLnrChmDimType dimType;
860 evxDwgLnrChmDimTexType dimTexType;
861 svxPntOnEnt textPnt;
864 svxPntOnEnt verTextPnt;
866 } svxDwgLnrChmDimData;
867
872typedef enum evxAngDimType
873 {
874 VX_ANG_TWOCURVES = 1,
875 VX_ANG_HORIZONTAL = 2,
876 VX_ANG_VERTICAL = 3,
877 VX_ANG_THREEPOINT = 4,
878 VX_ANG_ARC = 5,
879 }evxAngDimType;
880
885typedef struct svxDwgAngDimData
886 {
887 evxAngDimType type;
889 svxPntOnEnt Curve1;
894 svxPntOnEnt Curve2;
897 svxPntOnEnt StartPnt;
901 svxPntOnEnt BasePnt;
904 svxPntOnEnt EndPnt;
908 svxPntOnEnt ArcPnt;
911 svxPntOnEnt QuadrantPnt;
913 svxPntOnEnt txtPnt;
916 }svxDwgAngDimData;
917
922typedef enum evxRadDimType
923 {
924 VX_RAD_RADIAL = 1,
925 VX_RAD_BROKEN = 2,
926 VX_RAD_LARGE = 3,
927 VX_RAD_LEADER = 4,
928 VX_RAD_DIAMETER = 5,
929 VX_RAD_LINEAR = 6
930 } evxRadDimType;
931
936typedef struct svxRadDimData
937 {
938 evxRadDimType type;
940 svxPntOnEnt arcPnt;
943 svxPntOnEnt brkPnt;
948 svxPntOnEnt txtPnt;
949 } svxRadDimData;
950
955typedef struct svxDwgArcDimData
956 {
957 svxPntOnEnt ArcEnt;
958 svxPntOnEnt txtPnt;
959 }svxDwgArcDimData;
960
965typedef enum evxCalloutEmt
966 {
967 VX_CALLOUTEMT_INVALID = 0x00000000,
968 VX_CALLOUTEMT_QUALITY = 0x00000001,
969 VX_CALLOUTEMT_DIAMETER = 0x00000002,
970 VX_CALLOUTEMT_DIAMETER_D2 = 0x00000004,
971 VX_CALLOUTEMT_DEPTH = 0x00000008,
972 VX_CALLOUTEMT_DEPTH_H2 = 0x00000010,
973 VX_CALLOUTEMT_THREAD_DIA = 0x00000020,
974 VX_CALLOUTEMT_THREAD_PITCH = 0x00000040,
975 VX_CALLOUTEMT_THREAD_DEPTH = 0x00000080,
976 VX_CALLOUTEMT_ANGLE = 0x00000100,
977 VX_CALLOUTEMT_CALLOUT_LABEL = 0x00000200,
978 VX_CALLOUTEMT_MULTIPLE_LINE = 0x00000400,
979 VX_CALLOUTEMT_SLOT_LENGTH = 0x00000800,
980 VX_CALLOUTEMT_VALID = 0xFFFFFFFF
981 } evxCalloutEmt;
982
987typedef struct svxDwgHoleCallOutDim
988 {
989 int idView;
990 int cntCrv;
992 int* pCrvs;
994 svxPoint2* pnts;
996 int ignoreDup;
998 unsigned int iCalloutemt;
999 }svxDwgHoleCallOutDim;
1000
1001//====================================================================================================================
1003//====================================================================================================================
1008typedef struct svxLabelCoorDimData
1009 {
1010 char type;
1013 svxPntOnEnt orgPnt;
1015 int cntPnt;
1016 svxPntOnEnt* pPnts;
1017 svxPntOnEnt* pTxtPnts;
1021 char* text;
1022 } svxLabelCoorDimData;
1023
1028typedef enum evxBalloonCon
1029 {
1030 VX_BALLOON_CON_USERTEXT = 0,
1031 VX_BALLOON_CON_ID = 1,
1032 VX_BALLOON_CON_NAME = 2,
1033 VX_BALLOON_CON_NUMBER = 3,
1034 VX_BALLOON_CON_CLASS,
1035 VX_BALLOON_CON_DESIGNER,
1036 VX_BALLOON_CON_COST,
1037 VX_BALLOON_CON_SUPPLIER,
1038 VX_BALLOON_CON_MATERIAL,
1039 VX_BALLOON_CON_QUANTITY,
1040 VX_BALLOON_CON_MANAGER,
1041 VX_BALLOON_CON_REMARKS,
1042 VX_BALLOON_CON_DESCRIPTION,
1043 VX_BALLOON_CON_KEYWORDS,
1044 VX_BALLOON_CON_DERIVEDFROM,
1045 VX_BALLOON_CON_STARTDATE,
1046 VX_BALLOON_CON_ENDDATE,
1047 VX_BALLOON_CON_MASS,
1048 VX_BALLOON_CON_VOLUME,
1049 VX_BALLOON_CON_TOTALMASS,
1050 VX_BALLOON_CON_DENSITY,
1051 VX_BALLOON_CON_PARTCFG,
1052 VX_BALLOON_CON_FILEPATH,
1053 VX_BALLOON_CON_SIZE,
1054 VX_BALLOON_CON_LENGTH,
1055 VX_BALLOON_CON_WIDTH,
1056 VX_BALLOON_CON_HEIGHT,
1057 VX_BALLOON_CON_AREA,
1058 VX_BALLOON_CON_LEGEND,
1059 VX_BALLOON_CON_STOCKSIZE,
1060 VX_BALLOON_CON_VISIBLE,
1061 } evxBalloonCon;
1062
1067typedef struct svxDimLabel
1068 {
1069 int localPntCnt;
1070 svxPntOnEnt* localPnts;
1071 int leadPntCnt;
1072 svxPntOnEnt* leadPnts;
1073 char* text;
1074 }svxDimLabel;
1075
1080typedef struct svxDwgBalloonDim
1081 {
1082 evxBalloonCon condition;
1083 char* text;
1084 int cntCrv;
1085 svxPntOnEnt* Points;
1086 int cntlead;
1087 svxPntOnEnt* leadPoints;
1088 }svxDwgBalloonDim;
1089
1094typedef enum evxDwgAtBlnInsTyp
1095 {
1096 VX_ATBLNINS_IGNMULINS = 0,
1097 VX_ATBLNINS_MULLEAINS = 1,
1098 VX_ATBLNINS_EACHINS = 2
1099 } evxDwgAtBlnInsTyp;
1100
1105typedef enum evxDwgAtBlnPtnType
1106 {
1107 VX_ATBLNPAT_CONVEXHULL = 1,
1108 VX_ATBLNPAT_SQUARE = 2,
1109 VX_ATBLNPAT_CIRCULAR = 3
1110 } evxDwgAtBlnPtnType;
1111
1116typedef enum evxDwgAtBlnLeadAttach
1117 {
1118 VX_ATBLNLEAATT_EDAGES = 1,
1119 VX_ATBLNLEAATT_FACES = 2
1120 } evxDwgAtBlnLeadAttach;
1121
1126typedef enum evxDwgAtBlnSkpSd
1127 {
1128 VX_ATBLNSKPSD_NONE = 0,
1129 VX_ATBLNSKPSD_LEFT = 1,
1130 VX_ATBLNSKPSD_TOP = 2,
1131 VX_ATBLNSKPSD_RIGHT = 4,
1132 VX_ATBLNSKPSD_BOTTOM = 8
1133 } evxDwgAtBlnSkpSd;
1134
1139typedef enum evxDwgAtBlnArrg
1140 {
1141 VX_ATBLNARR_NEAREST = 1,
1142 VX_ATBLNARR_CW = 2,
1143 VX_ATBLNARR_CCW = 3
1144 } evxDwgAtBlnArrg;
1145
1150typedef struct svxDwgAtBlnData
1151 {
1152 int viewIdCnt;
1153 int* viewIdList;
1154 evxDwgAtBlnInsTyp instOpt;
1156 evxDwgAtBlnPtnType ptnType;
1158 evxDwgAtBlnLeadAttach leadAttach;
1160 vxUint32 offSet;
1161 evxDwgAtBlnSkpSd skipSides;
1164 evxDwgAtBlnArrg arrangement;
1167 int KepItem;
1169 int ItemId;
1170 int OnlyBom;
1172 int OnlyWithoutBln;
1174 } svxDwgAtBlnData;
1175
1180typedef enum evxDwgStkBlnPtn
1181 {
1182 VX_STKBLNPAT_HORRIGHT = 1,
1183 VX_STKBLNPAT_HORLEFT,
1184 VX_STKBLNPAT_VERUP,
1185 VX_STKBLNPAT_VERDOWN
1186 } evxDwgStkBlnPtn;
1187
1192typedef struct svxDwgStkBlnData
1193 {
1194 int idBlnDim;
1195 int entCnt;
1196 int* pEntIdList;
1198 evxDwgStkBlnPtn stkBlnPtn;
1199 char autoSort;
1201 } svxDwgStkBlnData;
1202
1207typedef struct svxDwgFtrCtrl
1208 {
1209 char* text;
1210 int cntCrv;
1211 svxPntOnEnt* Points;
1212 int cntlead;
1213 svxPntOnEnt* leadPoints;
1214 int cntauxiLoc;
1215 svxPntOnEnt* auxiPoints;
1216 }svxDwgFtrCtrl;
1217
1222typedef enum evxDatumDimType
1223 {
1224 VX_DATUM_NORMAL = 1,
1225 VX_DATUM_ANSI = 2,
1226 } evxDatumDimType;
1227
1232typedef struct svxDatumDimData
1233 {
1234 evxDatumDimType type;
1236 char* text;
1237 svxPntOnEnt leadPnt;
1240 svxPntOnEnt txtPnt;
1243 } svxDatumDimData;
1244
1249typedef enum evxDatumTargDimType
1250 {
1251 VX_DATUMT_CIRCLE = 0,
1252 VX_DATUMT_RECTANGLE = 1,
1253 VX_DATUMT_LINE = 2,
1254 VX_DATUMT_POINT = 3,
1255 } evxDatumTargDimType;
1256
1261typedef struct svxDatumTargDimData
1262 {
1263 evxDatumTargDimType type;
1266 svxPntOnEnt pnt;
1267 svxPntOnEnt textPnt;
1268 svxPntOnEnt secPnt;
1271 double diameter;
1273 double width;
1275 double height;
1277 char* text;
1278 char* text2;
1279 char* text3;
1280 int iAreaSizeText;
1282 char* userText;
1284 } svxDatumTargDimData;
1285
1286//====================================================================================================================
1288//====================================================================================================================
1293typedef struct svxCenterDim
1294 {
1295 double cmSize;
1296 double breakLen;
1297 double overRun;
1298 double scaleFac;
1299 }svxCenterDim;
1300
1305typedef enum evxCentDimType
1306 {
1307 VX_DM_CENMARK = 1,
1308 VX_DM_CENLINE,
1309 VX_DM_CENDLINE
1310 }evxCentDimType;
1311
1316typedef struct svxCenterMark
1317 {
1318 int idEntity;
1319 svxPoint zEntPnt;
1320 char useRotPnt;
1321 svxPntOnEnt zRotPnt;
1322 evxCentDimType cmType;
1323 svxCenterDim zCenterDim;
1324 int slotType;
1327 }svxCenterMark;
1328
1333typedef struct svxCenMarkCirDimData
1334 {
1335 int iCntCens;
1336 svxPntOnEnt* pCens;
1338 int iflg;
1341 char flgCenter;
1342 svxPntOnEnt center;
1345 } svxCenMarkCirDimData;
1346
1351typedef enum evxCenterLineType
1352 {
1353 VX_CL_BY_TWO_LINES = 1,
1354 VX_CL_BY_TWO_POINTS,
1355 }evxCenterLineType;
1356
1361typedef struct svxCenterLine
1362 {
1363 evxCenterLineType iDimType;
1366 svxPntOnEnt zPntStart;
1369 svxPntOnEnt zPntEnd;
1370 svxCenterDim zCenterDim;
1371 }svxCenterLine;
1372
1377typedef enum evxWeldFinishSym
1378 {
1379 VX_WELD_FINISH_NONE = 1,
1380 VX_WELD_FINISH_CHIPPING,
1381 VX_WELD_FINISH_GRINDING,
1382 VX_WELD_FINISH_HAMMERING,
1383 VX_WELD_FINISH_MACHINING,
1384 VX_WELD_FINISH_ROLLING,
1385 VX_WELD_FINISH_UNSPECIFIED,
1386 } evxWeldFinishSym;
1387
1392typedef enum evxWeldContourSym
1393 {
1394 VX_WELD_COUNTOUR_NONE = 1,
1395 VX_WELD_COUNTOUR_FLAT,
1396 VX_WELD_COUNTOUR_CONVEX,
1397 VX_WELD_COUNTOUR_CONCAVE,
1398 VX_WELD_COUNTOUR_BLEND_TOES,
1399 VX_WELD_COUNTOUR_STRIP_PERMANENT,
1400 VX_WELD_COUNTOUR_STRIP_REMOVABLE,
1401 } evxWeldContourSym;
1402
1407typedef struct svxSymWeld
1408 {
1409 evxWeldFinishSym finishSymUp;
1410 evxWeldContourSym contourSymUp;
1411 int lineFlg;
1412 int stagger;
1413 int filletSecUp;
1414 int weldSymUp;
1415 int fieldFlg;
1416 int aroundCir;
1417 int tail;
1418 int weldSymDwn;
1419 int filletSecDwn;
1420 evxWeldContourSym contourSymDwn;
1421 evxWeldFinishSym finishSymDwn;
1422 int inWeldTbl;
1423 char GrooveAngUp[33];
1424 char filleSecSzUp[33];
1425 char filletSecLenUp[33];
1426 char depthPrepUp[33];
1428 char weldLenPitchUp[33];
1429 char tailRef[65];
1430 char depthPrepDwn[33];
1432 char weldLenPitchDwn[33];
1433 char filletSecSzDwn[33];
1434 char filletSecLenDwn[33];
1435 char weldRoot[33];
1436 char grooveAngDwn[33];
1437 char weldOtherRoot[33];
1438 double gapSpacing;
1439 int useLocPoint;
1440 svxPoint2 locPoint;
1441 int numJogs;
1442 svxPoint2* jogPoints;
1443 int numLeaders;
1444 svxPoint2* leaderPoints;
1445 }svxSymWeld;
1446
1451typedef enum evxSymSurf
1452 {
1453 VX_SYMSURF_BAS = 0,
1454 VX_SYMSURF_MRR,
1455 VX_SYMSURF_MRP,
1456 VX_SYMSURF_JIS1,
1457 VX_SYMSURF_JIS2,
1458 VX_SYMSURF_JIS3,
1459 VX_SYMSURF_JIS4,
1460 VX_SYMSURF_JISNM
1461 } evxSymSurf;
1462
1463
1468typedef enum evxSurfPtnSym
1469 {
1470 VX_SURF_PTNSYM_NONE = 0,
1471 VX_SURF_PTNSYM_RADIAL,
1472 VX_SURF_PTNSYM_PERPENDICULAR,
1473 VX_SURF_PTNSYM_ANGULAR,
1474 VX_SURF_PTNSYM_MULTI_DIR,
1475 VX_SURF_PTNSYM_CIRCULAR,
1476 VX_SURF_PTNSYM_PARALLEL,
1477 VX_SURF_PTNSYM_PARTICULATE
1478 } evxSurfPtnSym;
1479
1484typedef struct svxSymSurf
1485 {
1486 evxSymSurf symTyp;
1487 evxSurfPtnSym lay;
1488 int grinding;
1489 char maxR[65];
1490 char minR[65];
1491 char procMeth[65];
1492 char sampR[65];
1493 char machAllow[65];
1494 char R[65];
1495 char otherR[65];
1496 char optStr[65];
1497 int prepFlag;
1498 double rotation;
1499 int useLeadPnt;
1500 svxPoint2 leadPoint;
1501 }svxSymSurf;
1502
1507typedef struct svxSymImg
1508 {
1509 /* required inputs */
1510 vxPath path;
1511 int firstPtType;
1512 svxPoint2 pts[2];
1513 double width;
1514 double height;
1515 double angle;
1516 double opaque;
1517 int flip;
1518 int locked;
1519 } svxSymImg;
1520
1525typedef struct svxDwgIsectSym
1526 {
1527 svxPntOnEnt fistEdge;
1529 svxPntOnEnt secondEdge;
1530 } svxDwgIsectSym;
1531
1536typedef enum evxDwgHoleMarkType
1537 {
1538 VX_DWG_HOLE_MARK_AUTO,
1539 VX_DWG_HOLE_MARK_MANUAL,
1540 } evxDwgHoleMarkType;
1541
1546typedef enum evxDwgHoleMarkPtn
1547 {
1548 VX_DWG_HOLE_MARK_UP_LEFT_4,
1549 VX_DWG_HOLE_MARK_UP_RIGHT_4,
1550 VX_DWG_HOLE_MARK_DOWN_LEFT_4,
1551 VX_DWG_HOLE_MARK_DOWN_RIGHT_4,
1552 VX_DWG_HOLE_MARK_LEFT_BEVEL_4,
1553 VX_DWG_HOLE_MARK_RIGHT_BEVEL_4,
1554 VX_DWG_HOLE_MARK_UP_LEFT_12,
1555 VX_DWG_HOLE_MARK_UP_RIGHT_12,
1556 VX_DWG_HOLE_MARK_DOWN_LEFT_12,
1557 VX_DWG_HOLE_MARK_DOWN_RIGHT_12,
1558 VX_DWG_HOLE_MARK_LEFT_BEVEL_12,
1559 VX_DWG_HOLE_MARK_RIGHT_BEVEL_12,
1560 } evxDwgHoleMarkPtn;
1561
1566typedef struct svxDwgHoleMark
1567 {
1568 evxDwgHoleMarkType type;
1569 int numCir;
1570 int* idCirs;
1573 int idView;
1576 int backface;
1578 int hidden;
1580 int boolean;
1582 int sameD;
1584 evxDwgHoleMarkPtn pattern;
1585 } svxDwgHoleMark;
1586
1587//====================================================================================================================
1589//====================================================================================================================
1590
1595typedef enum evxHatchType
1596 {
1597 VX_HATCH_CUSTOM = -1,
1598 VX_HATCH_STANDARD,
1599 VX_HATCH_ANSI,
1600 VX_HATCH_ISO,
1601 VX_HATCH_DIN,
1602 VX_HATCH_JIS,
1603 VX_HATCH_GB,
1604 } evxHatchType;
1605
1610typedef struct svxHatchAttr
1611 {
1612 evxHatchType type;
1614 evxHatchPtnType pattern;
1616 double angle;
1618 double space;
1620 svxPoint2 origin;
1622 evxColor color;
1624 evxLineWidth width;
1626 } svxHatchAttr;
1627
1628/*
1629*********************************************************************
1630** END HEADER FILE
1631*********************************************************************
1632*/
1633
1634#ifdef __cplusplus
1635 }
1636#endif /* __cplusplus */
1637
1638#endif /* ZW_API_DWG_CMD_DATA_H */
evxLocType
evxLocType
section location
Definition: zwapi_cmd_dwg_data.h:293
VX_LOC_HORIZONTAL
@ VX_LOC_HORIZONTAL
Location : Horizontal.
Definition: zwapi_cmd_dwg_data.h:294
VX_LOC_ORTHOGONAL
@ VX_LOC_ORTHOGONAL
Location : Orthogonal.
Definition: zwapi_cmd_dwg_data.h:296
VX_LOC_VERTICAL
@ VX_LOC_VERTICAL
Location : Vertical.
Definition: zwapi_cmd_dwg_data.h:295
VX_LOC_NONE
@ VX_LOC_NONE
Location : None.
Definition: zwapi_cmd_dwg_data.h:297
evxBrkLineType
evxBrkLineType
option of break line
Definition: zwapi_cmd_dwg_data.h:467
VX_VER_BRKLINE
@ VX_VER_BRKLINE
Vertical break line.
Definition: zwapi_cmd_dwg_data.h:469
VX_SLANT_BRKLINE
@ VX_SLANT_BRKLINE
Slant break line.
Definition: zwapi_cmd_dwg_data.h:470
VX_HOR_BRKLINE
@ VX_HOR_BRKLINE
Horizontal break line.
Definition: zwapi_cmd_dwg_data.h:468
evxRadDimType
evxRadDimType
radial or diametric dim type
Definition: zwapi_cmd_dwg_data.h:923
VX_RAD_DIAMETER
@ VX_RAD_DIAMETER
diametric dimension
Definition: zwapi_cmd_dwg_data.h:928
VX_RAD_LEADER
@ VX_RAD_LEADER
leader radial dimension
Definition: zwapi_cmd_dwg_data.h:927
VX_RAD_LARGE
@ VX_RAD_LARGE
large radial dimension
Definition: zwapi_cmd_dwg_data.h:926
VX_RAD_BROKEN
@ VX_RAD_BROKEN
broken radial dimension
Definition: zwapi_cmd_dwg_data.h:925
VX_RAD_RADIAL
@ VX_RAD_RADIAL
radial dimension
Definition: zwapi_cmd_dwg_data.h:924
VX_RAD_LINEAR
@ VX_RAD_LINEAR
linear diameter
Definition: zwapi_cmd_dwg_data.h:929
evxHatchType
evxHatchType
hatch type
Definition: zwapi_cmd_dwg_data.h:1596
VX_HATCH_ANSI
@ VX_HATCH_ANSI
hatch style (ANSI)
Definition: zwapi_cmd_dwg_data.h:1599
VX_HATCH_DIN
@ VX_HATCH_DIN
hatch style (DIN)
Definition: zwapi_cmd_dwg_data.h:1601
VX_HATCH_CUSTOM
@ VX_HATCH_CUSTOM
custom hatch style
Definition: zwapi_cmd_dwg_data.h:1597
VX_HATCH_STANDARD
@ VX_HATCH_STANDARD
from standard
Definition: zwapi_cmd_dwg_data.h:1598
VX_HATCH_ISO
@ VX_HATCH_ISO
hatch style (ISO)
Definition: zwapi_cmd_dwg_data.h:1600
VX_HATCH_JIS
@ VX_HATCH_JIS
hatch style (JIS)
Definition: zwapi_cmd_dwg_data.h:1602
VX_HATCH_GB
@ VX_HATCH_GB
hatch style (GB)
Definition: zwapi_cmd_dwg_data.h:1603
evxAutoPlacement
evxAutoPlacement
dimension position/placement
Definition: zwapi_cmd_dwg_data.h:652
DIM_VIEW_ABOVE_LEFT
@ DIM_VIEW_ABOVE_LEFT
left or above of view
Definition: zwapi_cmd_dwg_data.h:653
DIM_VIEW_BELOW_RIGHT
@ DIM_VIEW_BELOW_RIGHT
right or below of view
Definition: zwapi_cmd_dwg_data.h:654
DIM_VIEW_BOTH
@ DIM_VIEW_BOTH
both of view
Definition: zwapi_cmd_dwg_data.h:655
evxDwgAtBlnSkpSd
evxDwgAtBlnSkpSd
Skip sides of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1127
VX_ATBLNSKPSD_BOTTOM
@ VX_ATBLNSKPSD_BOTTOM
skip bottom
Definition: zwapi_cmd_dwg_data.h:1132
VX_ATBLNSKPSD_RIGHT
@ VX_ATBLNSKPSD_RIGHT
skip right
Definition: zwapi_cmd_dwg_data.h:1131
VX_ATBLNSKPSD_TOP
@ VX_ATBLNSKPSD_TOP
skip top
Definition: zwapi_cmd_dwg_data.h:1130
VX_ATBLNSKPSD_LEFT
@ VX_ATBLNSKPSD_LEFT
skip left
Definition: zwapi_cmd_dwg_data.h:1129
VX_ATBLNSKPSD_NONE
@ VX_ATBLNSKPSD_NONE
skip none
Definition: zwapi_cmd_dwg_data.h:1128
evxDatumDimType
evxDatumDimType
datum dim type
Definition: zwapi_cmd_dwg_data.h:1223
VX_DATUM_NORMAL
@ VX_DATUM_NORMAL
normal datum feature symbol
Definition: zwapi_cmd_dwg_data.h:1224
VX_DATUM_ANSI
@ VX_DATUM_ANSI
based on ANSI(per 1982)
Definition: zwapi_cmd_dwg_data.h:1225
evxDwgLnrChmDimTexType
evxDwgLnrChmDimTexType
text style of leader linear chamfer dim in sheeting
Definition: zwapi_cmd_dwg_data.h:844
VX_TEXT_PERPENDICULAR_CHAMFERDIM
@ VX_TEXT_PERPENDICULAR_CHAMFERDIM
always perpendicular
Definition: zwapi_cmd_dwg_data.h:846
VX_TEXT_ALGMODLIN_CHAMFERDIM
@ VX_TEXT_ALGMODLIN_CHAMFERDIM
along the model line
Definition: zwapi_cmd_dwg_data.h:847
VX_TEXT_NOR_CHAMFERDIM
@ VX_TEXT_NOR_CHAMFERDIM
normal
Definition: zwapi_cmd_dwg_data.h:845
evxOrderType
evxOrderType
order type
Definition: zwapi_cmd_dwg_data.h:518
VX_ORDER_ASASM
@ VX_ORDER_ASASM
Order as assembly.
Definition: zwapi_cmd_dwg_data.h:521
VX_ORDER_BYNAME
@ VX_ORDER_BYNAME
Order by name.
Definition: zwapi_cmd_dwg_data.h:519
VX_ORDER_REGEN_IDS
@ VX_ORDER_REGEN_IDS
Regenerate IDs after sort.
Definition: zwapi_cmd_dwg_data.h:520
evxRotViewType
evxRotViewType
type of view
Definition: zwapi_cmd_dwg_data.h:592
VX_ROTVIEW_BOTTOM
@ VX_ROTVIEW_BOTTOM
bottom
Definition: zwapi_cmd_dwg_data.h:597
VX_ROTVIEW_ISOMETRIC
@ VX_ROTVIEW_ISOMETRIC
isometric
Definition: zwapi_cmd_dwg_data.h:599
VX_ROTVIEW_FRONT
@ VX_ROTVIEW_FRONT
front
Definition: zwapi_cmd_dwg_data.h:594
VX_ROTVIEW_ISOMETRIC_LBT
@ VX_ROTVIEW_ISOMETRIC_LBT
isometric_left-back-top
Definition: zwapi_cmd_dwg_data.h:601
VX_ROTVIEW_BACK
@ VX_ROTVIEW_BACK
back
Definition: zwapi_cmd_dwg_data.h:596
VX_ROTVIEW_TOP
@ VX_ROTVIEW_TOP
top
Definition: zwapi_cmd_dwg_data.h:593
VX_ROTVIEW_ISOMETRIC_RBT
@ VX_ROTVIEW_ISOMETRIC_RBT
isometric_right-back-top
Definition: zwapi_cmd_dwg_data.h:602
VX_ROTVIEW_ISOMETRIC_LBB
@ VX_ROTVIEW_ISOMETRIC_LBB
isometric_left-back-bottom
Definition: zwapi_cmd_dwg_data.h:605
VX_ROTVIEW_ISOMETRIC_RFB
@ VX_ROTVIEW_ISOMETRIC_RFB
isometric_right-front-bottom
Definition: zwapi_cmd_dwg_data.h:603
VX_ROTVIEW_ISOMETRIC_LFT
@ VX_ROTVIEW_ISOMETRIC_LFT
isometric_left-front-top
Definition: zwapi_cmd_dwg_data.h:600
VX_ROTVIEW_ISOMETRIC_RBB
@ VX_ROTVIEW_ISOMETRIC_RBB
isometric_right-back-bottom
Definition: zwapi_cmd_dwg_data.h:606
VX_ROTVIEW_LEFT
@ VX_ROTVIEW_LEFT
left
Definition: zwapi_cmd_dwg_data.h:598
VX_ROTVIEW_RIGHT
@ VX_ROTVIEW_RIGHT
right
Definition: zwapi_cmd_dwg_data.h:595
VX_ROTVIEW_ISOMETRIC_LFB
@ VX_ROTVIEW_ISOMETRIC_LFB
isometric_left-front-bottom
Definition: zwapi_cmd_dwg_data.h:604
evxViewDimType
evxViewDimType
view dimension type
Definition: zwapi_cmd_dwg_data.h:235
VX_VIEW_DIMTYPEPRJ
@ VX_VIEW_DIMTYPEPRJ
dimension type : Projected
Definition: zwapi_cmd_dwg_data.h:236
VX_VIEW_DIMTYPETRUE
@ VX_VIEW_DIMTYPETRUE
dimension type : True
Definition: zwapi_cmd_dwg_data.h:237
evxDwgAtBlnPtnType
evxDwgAtBlnPtnType
Pattern type of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1106
VX_ATBLNPAT_SQUARE
@ VX_ATBLNPAT_SQUARE
square around the layout view
Definition: zwapi_cmd_dwg_data.h:1108
VX_ATBLNPAT_CIRCULAR
@ VX_ATBLNPAT_CIRCULAR
circular around the layout view
Definition: zwapi_cmd_dwg_data.h:1109
VX_ATBLNPAT_CONVEXHULL
@ VX_ATBLNPAT_CONVEXHULL
convex hull around the layout view
Definition: zwapi_cmd_dwg_data.h:1107
evxLevelSet
evxLevelSet
level set
Definition: zwapi_cmd_dwg_data.h:495
VX_INDENTED
@ VX_INDENTED
Indented.
Definition: zwapi_cmd_dwg_data.h:498
VX_BALLOON_ONLY
@ VX_BALLOON_ONLY
by balloon only
Definition: zwapi_cmd_dwg_data.h:499
VX_PARTS_ONLY
@ VX_PARTS_ONLY
Parts only.
Definition: zwapi_cmd_dwg_data.h:497
VX_TOP_LEVEL_ONLY
@ VX_TOP_LEVEL_ONLY
Top-level only.
Definition: zwapi_cmd_dwg_data.h:496
evxDwgDepthType
evxDwgDepthType
Drawing Broken Section Depth type.
Definition: zwapi_cmd_dwg_data.h:407
VX_DEPTH_POINT
@ VX_DEPTH_POINT
point
Definition: zwapi_cmd_dwg_data.h:408
VX_DEPTH_SECTION_PLANE
@ VX_DEPTH_SECTION_PLANE
section plane
Definition: zwapi_cmd_dwg_data.h:409
VX_DEPTH_3D_NAMED
@ VX_DEPTH_3D_NAMED
3d named
Definition: zwapi_cmd_dwg_data.h:410
evxDimLineType
evxDimLineType
dimension Line type
Definition: zwapi_cmd_dwg_data.h:716
VX_DIM_LINE_LH
@ VX_DIM_LINE_LH
horizontal dimension
Definition: zwapi_cmd_dwg_data.h:717
VX_DIM_LINE_LA
@ VX_DIM_LINE_LA
aligned dimension
Definition: zwapi_cmd_dwg_data.h:719
VX_DIM_LINE_LR
@ VX_DIM_LINE_LR
rotated dimension
Definition: zwapi_cmd_dwg_data.h:720
VX_DIM_LINE_LV
@ VX_DIM_LINE_LV
vertical dimension
Definition: zwapi_cmd_dwg_data.h:718
VX_DIM_LINE_LO
@ VX_DIM_LINE_LO
ordinate dimension, only used in cvxDwgOrdinateDimAdd(): create a linear ordinate horizontal dimensio...
Definition: zwapi_cmd_dwg_data.h:722
VX_DIM_LINE_LP
@ VX_DIM_LINE_LP
projected dimension
Definition: zwapi_cmd_dwg_data.h:721
evxDimLineOffset
evxDimLineOffset
dimension off type
Definition: zwapi_cmd_dwg_data.h:796
VX_DIM_OFFSET_LOP
@ VX_DIM_OFFSET_LOP
point to line (Projected Distance Method)
Definition: zwapi_cmd_dwg_data.h:798
VX_DIM_OFFSET_LOL
@ VX_DIM_OFFSET_LOL
line to line (Offset Method)
Definition: zwapi_cmd_dwg_data.h:797
evxDwgAtBlnArrg
evxDwgAtBlnArrg
Arrangement of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1140
VX_ATBLNARR_CCW
@ VX_ATBLNARR_CCW
arranged in counter - clockwise order
Definition: zwapi_cmd_dwg_data.h:1143
VX_ATBLNARR_NEAREST
@ VX_ATBLNARR_NEAREST
simply located nearest to the component being labeled
Definition: zwapi_cmd_dwg_data.h:1141
VX_ATBLNARR_CW
@ VX_ATBLNARR_CW
arranged in clockwise order
Definition: zwapi_cmd_dwg_data.h:1142
evxDwgAtBlnInsTyp
evxDwgAtBlnInsTyp
Type of instances in auto balloon.
Definition: zwapi_cmd_dwg_data.h:1095
VX_ATBLNINS_MULLEAINS
@ VX_ATBLNINS_MULLEAINS
multi-leader for multiple instances
Definition: zwapi_cmd_dwg_data.h:1097
VX_ATBLNINS_EACHINS
@ VX_ATBLNINS_EACHINS
one for each instances
Definition: zwapi_cmd_dwg_data.h:1098
VX_ATBLNINS_IGNMULINS
@ VX_ATBLNINS_IGNMULINS
ignore multiple instances
Definition: zwapi_cmd_dwg_data.h:1096
evxAutoDimType
evxAutoDimType
auto dimension type
Definition: zwapi_cmd_dwg_data.h:640
DIM_AUTO_LABEL_COORDINATE
@ DIM_AUTO_LABEL_COORDINATE
label ordinate dimension
Definition: zwapi_cmd_dwg_data.h:644
DIM_AUTO_BASELINE
@ DIM_AUTO_BASELINE
baseline
Definition: zwapi_cmd_dwg_data.h:641
DIM_AUTO_CONTINUOUS
@ DIM_AUTO_CONTINUOUS
continuous
Definition: zwapi_cmd_dwg_data.h:642
DIM_AUTO_ORDINATE
@ DIM_AUTO_ORDINATE
ordinate dimension
Definition: zwapi_cmd_dwg_data.h:643
evxDwgAtBlnLeadAttach
evxDwgAtBlnLeadAttach
Leader attachment of auto balloon.
Definition: zwapi_cmd_dwg_data.h:1117
VX_ATBLNLEAATT_FACES
@ VX_ATBLNLEAATT_FACES
attach to face
Definition: zwapi_cmd_dwg_data.h:1119
VX_ATBLNLEAATT_EDAGES
@ VX_ATBLNLEAATT_EDAGES
attach to edges
Definition: zwapi_cmd_dwg_data.h:1118
evxAngDimType
evxAngDimType
angular dimension type
Definition: zwapi_cmd_dwg_data.h:873
VX_ANG_HORIZONTAL
@ VX_ANG_HORIZONTAL
horizontal angular dimension
Definition: zwapi_cmd_dwg_data.h:875
VX_ANG_ARC
@ VX_ANG_ARC
arc angular dimension
Definition: zwapi_cmd_dwg_data.h:878
VX_ANG_VERTICAL
@ VX_ANG_VERTICAL
vertical angular dimension
Definition: zwapi_cmd_dwg_data.h:876
VX_ANG_THREEPOINT
@ VX_ANG_THREEPOINT
3 point angular dimension
Definition: zwapi_cmd_dwg_data.h:877
VX_ANG_TWOCURVES
@ VX_ANG_TWOCURVES
2 curves angular dimension
Definition: zwapi_cmd_dwg_data.h:874
evxCalloutEmt
evxCalloutEmt
Callout Elements.
Definition: zwapi_cmd_dwg_data.h:966
VX_CALLOUTEMT_DIAMETER_D2
@ VX_CALLOUTEMT_DIAMETER_D2
Diameter(D2)
Definition: zwapi_cmd_dwg_data.h:970
VX_CALLOUTEMT_MULTIPLE_LINE
@ VX_CALLOUTEMT_MULTIPLE_LINE
Multiple Lines.
Definition: zwapi_cmd_dwg_data.h:978
VX_CALLOUTEMT_SLOT_LENGTH
@ VX_CALLOUTEMT_SLOT_LENGTH
Slot Length.
Definition: zwapi_cmd_dwg_data.h:979
VX_CALLOUTEMT_THREAD_DIA
@ VX_CALLOUTEMT_THREAD_DIA
Thread Diameter.
Definition: zwapi_cmd_dwg_data.h:973
VX_CALLOUTEMT_VALID
@ VX_CALLOUTEMT_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:980
VX_CALLOUTEMT_QUALITY
@ VX_CALLOUTEMT_QUALITY
Quality.
Definition: zwapi_cmd_dwg_data.h:968
VX_CALLOUTEMT_DIAMETER
@ VX_CALLOUTEMT_DIAMETER
Diameter.
Definition: zwapi_cmd_dwg_data.h:969
VX_CALLOUTEMT_DEPTH_H2
@ VX_CALLOUTEMT_DEPTH_H2
Depth(H2)
Definition: zwapi_cmd_dwg_data.h:972
VX_CALLOUTEMT_THREAD_PITCH
@ VX_CALLOUTEMT_THREAD_PITCH
Thread Pitch.
Definition: zwapi_cmd_dwg_data.h:974
VX_CALLOUTEMT_INVALID
@ VX_CALLOUTEMT_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:967
VX_CALLOUTEMT_DEPTH
@ VX_CALLOUTEMT_DEPTH
Depth.
Definition: zwapi_cmd_dwg_data.h:971
VX_CALLOUTEMT_THREAD_DEPTH
@ VX_CALLOUTEMT_THREAD_DEPTH
Thread Depth.
Definition: zwapi_cmd_dwg_data.h:975
VX_CALLOUTEMT_CALLOUT_LABEL
@ VX_CALLOUTEMT_CALLOUT_LABEL
Callout Label.
Definition: zwapi_cmd_dwg_data.h:977
VX_CALLOUTEMT_ANGLE
@ VX_CALLOUTEMT_ANGLE
Angle.
Definition: zwapi_cmd_dwg_data.h:976
evxWeldFinishSym
evxWeldFinishSym
finish symbol of weld symbol
Definition: zwapi_cmd_dwg_data.h:1378
VX_WELD_FINISH_CHIPPING
@ VX_WELD_FINISH_CHIPPING
chipping
Definition: zwapi_cmd_dwg_data.h:1380
VX_WELD_FINISH_UNSPECIFIED
@ VX_WELD_FINISH_UNSPECIFIED
unspecified
Definition: zwapi_cmd_dwg_data.h:1385
VX_WELD_FINISH_HAMMERING
@ VX_WELD_FINISH_HAMMERING
hammering
Definition: zwapi_cmd_dwg_data.h:1382
VX_WELD_FINISH_NONE
@ VX_WELD_FINISH_NONE
none
Definition: zwapi_cmd_dwg_data.h:1379
VX_WELD_FINISH_MACHINING
@ VX_WELD_FINISH_MACHINING
machining
Definition: zwapi_cmd_dwg_data.h:1383
VX_WELD_FINISH_GRINDING
@ VX_WELD_FINISH_GRINDING
grinding
Definition: zwapi_cmd_dwg_data.h:1381
VX_WELD_FINISH_ROLLING
@ VX_WELD_FINISH_ROLLING
rolling
Definition: zwapi_cmd_dwg_data.h:1384
evxDwgLnrChmDimType
evxDwgLnrChmDimType
type of linear chamfer dim in sheeting
Definition: zwapi_cmd_dwg_data.h:833
VX_LEADER_CHAMFERDIM
@ VX_LEADER_CHAMFERDIM
leader linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:834
VX_HORZORVERT_CHAMFERDIM
@ VX_HORZORVERT_CHAMFERDIM
horizontal/vertical linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:836
VX_ALIGNED_CHAMFERDIM
@ VX_ALIGNED_CHAMFERDIM
aligned linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:835
evxOriginType
evxOriginType
origin type
Definition: zwapi_cmd_dwg_data.h:561
VX_MID_RIGHT
@ VX_MID_RIGHT
Mid-Right.
Definition: zwapi_cmd_dwg_data.h:567
VX_BOTTOM_LEFT
@ VX_BOTTOM_LEFT
Bottom-Left.
Definition: zwapi_cmd_dwg_data.h:568
VX_MID_LEFT
@ VX_MID_LEFT
Mid-Left.
Definition: zwapi_cmd_dwg_data.h:565
VX_MID_CENTER
@ VX_MID_CENTER
Mid-Center.
Definition: zwapi_cmd_dwg_data.h:566
VX_TOP_CENTER
@ VX_TOP_CENTER
Top-Center.
Definition: zwapi_cmd_dwg_data.h:563
VX_BOTTOM_CENTER
@ VX_BOTTOM_CENTER
Bottom-Center.
Definition: zwapi_cmd_dwg_data.h:569
VX_TOP_RIGHT
@ VX_TOP_RIGHT
Top-Right.
Definition: zwapi_cmd_dwg_data.h:564
VX_TOP_LEFT
@ VX_TOP_LEFT
Top-Left.
Definition: zwapi_cmd_dwg_data.h:562
VX_BOTTOM_RIGHT
@ VX_BOTTOM_RIGHT
Bottom-Right.
Definition: zwapi_cmd_dwg_data.h:570
evxDwgHoleMarkPtn
evxDwgHoleMarkPtn
drawing sheet hole mark pattern method
Definition: zwapi_cmd_dwg_data.h:1547
VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
@ VX_DWG_HOLE_MARK_RIGHT_BEVEL_12
right-bevel 1/12
Definition: zwapi_cmd_dwg_data.h:1559
VX_DWG_HOLE_MARK_UP_LEFT_4
@ VX_DWG_HOLE_MARK_UP_LEFT_4
up-left 1/4
Definition: zwapi_cmd_dwg_data.h:1548
VX_DWG_HOLE_MARK_DOWN_RIGHT_4
@ VX_DWG_HOLE_MARK_DOWN_RIGHT_4
down-right 1/4
Definition: zwapi_cmd_dwg_data.h:1551
VX_DWG_HOLE_MARK_UP_LEFT_12
@ VX_DWG_HOLE_MARK_UP_LEFT_12
up-left 1/12
Definition: zwapi_cmd_dwg_data.h:1554
VX_DWG_HOLE_MARK_UP_RIGHT_12
@ VX_DWG_HOLE_MARK_UP_RIGHT_12
up-right 1/12
Definition: zwapi_cmd_dwg_data.h:1555
VX_DWG_HOLE_MARK_DOWN_LEFT_4
@ VX_DWG_HOLE_MARK_DOWN_LEFT_4
down-left 1/4
Definition: zwapi_cmd_dwg_data.h:1550
VX_DWG_HOLE_MARK_LEFT_BEVEL_12
@ VX_DWG_HOLE_MARK_LEFT_BEVEL_12
left-bevel 1/12
Definition: zwapi_cmd_dwg_data.h:1558
VX_DWG_HOLE_MARK_UP_RIGHT_4
@ VX_DWG_HOLE_MARK_UP_RIGHT_4
up-right 1/4
Definition: zwapi_cmd_dwg_data.h:1549
VX_DWG_HOLE_MARK_LEFT_BEVEL_4
@ VX_DWG_HOLE_MARK_LEFT_BEVEL_4
left-bevel 1/4
Definition: zwapi_cmd_dwg_data.h:1552
VX_DWG_HOLE_MARK_DOWN_RIGHT_12
@ VX_DWG_HOLE_MARK_DOWN_RIGHT_12
down-right 1/12
Definition: zwapi_cmd_dwg_data.h:1557
VX_DWG_HOLE_MARK_RIGHT_BEVEL_4
@ VX_DWG_HOLE_MARK_RIGHT_BEVEL_4
right-bevel 1/4
Definition: zwapi_cmd_dwg_data.h:1553
VX_DWG_HOLE_MARK_DOWN_LEFT_12
@ VX_DWG_HOLE_MARK_DOWN_LEFT_12
down-left 1/12
Definition: zwapi_cmd_dwg_data.h:1556
evxViewTypeEx
evxViewTypeEx
View type, more detailed than evxViewType.
Definition: zwapi_cmd_dwg_data.h:140
VX_VU_1ST_UP
@ VX_VU_1ST_UP
view projected 1st angle from above
Definition: zwapi_cmd_dwg_data.h:155
VX_VU_DIMETRIC
@ VX_VU_DIMETRIC
dimetric view
Definition: zwapi_cmd_dwg_data.h:180
VX_VU_ISO_RFB
@ VX_VU_ISO_RFB
right-front-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:172
VX_VU_NAME_SECT_DEF
@ VX_VU_NAME_SECT_DEF
3D named sect def'n
Definition: zwapi_cmd_dwg_data.h:176
VX_VU_ISO_LBT
@ VX_VU_ISO_LBT
left-back-top side isometric view
Definition: zwapi_cmd_dwg_data.h:170
VX_VU_3RD_RT
@ VX_VU_3RD_RT
view projected 3rd angle from right
Definition: zwapi_cmd_dwg_data.h:153
VX_VU_REV_SECT_DEF
@ VX_VU_REV_SECT_DEF
revolved section definition
Definition: zwapi_cmd_dwg_data.h:164
VX_VU_BOTTOM
@ VX_VU_BOTTOM
bottom view
Definition: zwapi_cmd_dwg_data.h:146
VX_VU_PRJ_ANG_ARROWS
@ VX_VU_PRJ_ANG_ARROWS
aux view arrows
Definition: zwapi_cmd_dwg_data.h:167
VX_VU_DETAIL
@ VX_VU_DETAIL
detail view
Definition: zwapi_cmd_dwg_data.h:160
VX_VU_3RD_PRJ_ANG
@ VX_VU_3RD_PRJ_ANG
view projected at angle, 3rd angle projection
Definition: zwapi_cmd_dwg_data.h:159
VX_VU_NAME
@ VX_VU_NAME
named view
Definition: zwapi_cmd_dwg_data.h:150
VX_VU_3RD_LT
@ VX_VU_3RD_LT
view projected 3rd angle from left
Definition: zwapi_cmd_dwg_data.h:154
VX_VU_BEND_SECT_DEF
@ VX_VU_BEND_SECT_DEF
bend section definition
Definition: zwapi_cmd_dwg_data.h:168
VX_VU_DETAIL_DEF
@ VX_VU_DETAIL_DEF
detail definition
Definition: zwapi_cmd_dwg_data.h:162
VX_VU_ISOSECT
@ VX_VU_ISOSECT
3D isometric section view
Definition: zwapi_cmd_dwg_data.h:179
VX_VU_1ST_PRJ_ANG
@ VX_VU_1ST_PRJ_ANG
view projected at angle, 1st angle projection
Definition: zwapi_cmd_dwg_data.h:177
VX_VU_SECTION
@ VX_VU_SECTION
section view
Definition: zwapi_cmd_dwg_data.h:161
VX_VU_ISO_RBT
@ VX_VU_ISO_RBT
right-back-top side isometric view
Definition: zwapi_cmd_dwg_data.h:171
VX_VU_ISO_LFB
@ VX_VU_ISO_LFB
left-front-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:173
VX_VU_ISO_LFT
@ VX_VU_ISO_LFT
left-front-top side isometric view
Definition: zwapi_cmd_dwg_data.h:169
VX_VU_SMD
@ VX_VU_SMD
selected sheet metal flat item view
Definition: zwapi_cmd_dwg_data.h:181
VX_VU_FRONT
@ VX_VU_FRONT
front view
Definition: zwapi_cmd_dwg_data.h:143
VX_VU_3RD_DN
@ VX_VU_3RD_DN
view projected 3rd angle from below
Definition: zwapi_cmd_dwg_data.h:152
VX_VU_RIGHT
@ VX_VU_RIGHT
right view
Definition: zwapi_cmd_dwg_data.h:144
VX_VU_AUX
@ VX_VU_AUX
"auxiliary" view
Definition: zwapi_cmd_dwg_data.h:149
VX_VU_ISO_LBB
@ VX_VU_ISO_LBB
left-back-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:174
VX_VU_ALIGN_SECT_DEF
@ VX_VU_ALIGN_SECT_DEF
aligned section definition
Definition: zwapi_cmd_dwg_data.h:166
VX_VU_1ST_DN
@ VX_VU_1ST_DN
view projected 1st angle from below
Definition: zwapi_cmd_dwg_data.h:156
VX_VU_ISO_FRONT
@ VX_VU_ISO_FRONT
front isometric view
Definition: zwapi_cmd_dwg_data.h:148
VX_VU_NULL
@ VX_VU_NULL
undefined
Definition: zwapi_cmd_dwg_data.h:141
VX_VU_ISO_RBB
@ VX_VU_ISO_RBB
right-back-bottom side isometric view
Definition: zwapi_cmd_dwg_data.h:175
VX_VU_LEFT
@ VX_VU_LEFT
left view
Definition: zwapi_cmd_dwg_data.h:147
VX_VU_1ST_RT
@ VX_VU_1ST_RT
view projected 1st angle from right
Definition: zwapi_cmd_dwg_data.h:157
VX_VU_1ST_LT
@ VX_VU_1ST_LT
view projected 1st angle from left
Definition: zwapi_cmd_dwg_data.h:158
VX_VU_SECTION_DEF
@ VX_VU_SECTION_DEF
section definition
Definition: zwapi_cmd_dwg_data.h:163
VX_VU_BACK
@ VX_VU_BACK
back view
Definition: zwapi_cmd_dwg_data.h:145
VX_VU_3RD_UP
@ VX_VU_3RD_UP
view projected 3rd angle from above
Definition: zwapi_cmd_dwg_data.h:151
VX_VU_TOP
@ VX_VU_TOP
top view
Definition: zwapi_cmd_dwg_data.h:142
VX_VU_ROTATE
@ VX_VU_ROTATE
rotated view
Definition: zwapi_cmd_dwg_data.h:165
VX_VU_BRKSECT
@ VX_VU_BRKSECT
broken section
Definition: zwapi_cmd_dwg_data.h:178
evxSymSurf
evxSymSurf
symbol type of surface roughness
Definition: zwapi_cmd_dwg_data.h:1452
VX_SYMSURF_JISNM
@ VX_SYMSURF_JISNM
JIS no machining.
Definition: zwapi_cmd_dwg_data.h:1460
VX_SYMSURF_MRR
@ VX_SYMSURF_MRR
material removal required
Definition: zwapi_cmd_dwg_data.h:1454
VX_SYMSURF_JIS1
@ VX_SYMSURF_JIS1
JIS surface texture 1.
Definition: zwapi_cmd_dwg_data.h:1456
VX_SYMSURF_BAS
@ VX_SYMSURF_BAS
basic
Definition: zwapi_cmd_dwg_data.h:1453
VX_SYMSURF_JIS4
@ VX_SYMSURF_JIS4
JIS surface texture 4.
Definition: zwapi_cmd_dwg_data.h:1459
VX_SYMSURF_JIS2
@ VX_SYMSURF_JIS2
JIS surface texture 2.
Definition: zwapi_cmd_dwg_data.h:1457
VX_SYMSURF_JIS3
@ VX_SYMSURF_JIS3
JIS surface texture 3.
Definition: zwapi_cmd_dwg_data.h:1458
VX_SYMSURF_MRP
@ VX_SYMSURF_MRP
material removal prohibited
Definition: zwapi_cmd_dwg_data.h:1455
evxIndentedType
evxIndentedType
indent type
Definition: zwapi_cmd_dwg_data.h:507
VX_DETAILED_NUM
@ VX_DETAILED_NUM
Detailed numbering.
Definition: zwapi_cmd_dwg_data.h:509
VX_NO_NUM
@ VX_NO_NUM
No numbering.
Definition: zwapi_cmd_dwg_data.h:508
VX_FLAT_NUM
@ VX_FLAT_NUM
Flat numbering.
Definition: zwapi_cmd_dwg_data.h:510
evxSecMtdType
evxSecMtdType
section method type
Definition: zwapi_cmd_dwg_data.h:282
VX_METHOD_SECCURVE
@ VX_METHOD_SECCURVE
Section Method : Sect Curves.
Definition: zwapi_cmd_dwg_data.h:283
VX_METHOD_TRIMPART
@ VX_METHOD_TRIMPART
Section Method : Trimmed Part.
Definition: zwapi_cmd_dwg_data.h:284
VX_METHOD_TRIMSURF
@ VX_METHOD_TRIMSURF
Section Method : Trimmed Surface.
Definition: zwapi_cmd_dwg_data.h:285
evxDwgDetailMethod
evxDwgDetailMethod
Drawing Detail Method.
Definition: zwapi_cmd_dwg_data.h:441
VX_POLYLINE_DETAIL
@ VX_POLYLINE_DETAIL
polyline detail view
Definition: zwapi_cmd_dwg_data.h:444
VX_CIRCULAR_DETAIL
@ VX_CIRCULAR_DETAIL
circular detail view
Definition: zwapi_cmd_dwg_data.h:443
VX_RECTANGULAR_DETAIL
@ VX_RECTANGULAR_DETAIL
rectangular detail view
Definition: zwapi_cmd_dwg_data.h:442
evxAutoEntType
evxAutoEntType
select geometry entity type
Definition: zwapi_cmd_dwg_data.h:629
DIM_AUTO_ENT_ARC_CIRCLE
@ DIM_AUTO_ENT_ARC_CIRCLE
entity type is all arc/circle
Definition: zwapi_cmd_dwg_data.h:631
DIM_AUTO_ENT_ALL
@ DIM_AUTO_ENT_ALL
entity type is all
Definition: zwapi_cmd_dwg_data.h:630
DIM_AUTO_ENT_PICKED
@ DIM_AUTO_ENT_PICKED
entity type is picked by user
Definition: zwapi_cmd_dwg_data.h:632
evxBomset
evxBomset
BOM set.
Definition: zwapi_cmd_dwg_data.h:529
VX_BOM_VALID
@ VX_BOM_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:536
VX_SET_DISP_CFG
@ VX_SET_DISP_CFG
Display configurations of the same as one item.
Definition: zwapi_cmd_dwg_data.h:531
VX_BOM_INVALID
@ VX_BOM_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:530
VX_KEEP_MISSING
@ VX_KEEP_MISSING
Keep missing item.
Definition: zwapi_cmd_dwg_data.h:534
VX_STRIKE_THROUGH
@ VX_STRIKE_THROUGH
Strike through.
Definition: zwapi_cmd_dwg_data.h:535
VX_SYNC_BOM
@ VX_SYNC_BOM
Sync BOM table with part attributes.
Definition: zwapi_cmd_dwg_data.h:533
VX_DERIVED_PARTS
@ VX_DERIVED_PARTS
Derived parts as instances of source part.
Definition: zwapi_cmd_dwg_data.h:532
evxAutoInclude
evxAutoInclude
auto dimension include
Definition: zwapi_cmd_dwg_data.h:676
VX_AUTOINC_ARC
@ VX_AUTOINC_ARC
Include arc.
Definition: zwapi_cmd_dwg_data.h:678
VX_AUTOINC_HOLE_CALLOUT
@ VX_AUTOINC_HOLE_CALLOUT
Include Hole callout
Definition: zwapi_cmd_dwg_data.h:682
VX_AUTOINC_LINE
@ VX_AUTOINC_LINE
Include line.
Definition: zwapi_cmd_dwg_data.h:681
VX_AUTOINC_MAXIMUM_DIM
@ VX_AUTOINC_MAXIMUM_DIM
Include maximum dimensions.
Definition: zwapi_cmd_dwg_data.h:684
VX_AUTOINC_CYLIND_DIM
@ VX_AUTOINC_CYLIND_DIM
Include cylindrical dimensions.
Definition: zwapi_cmd_dwg_data.h:683
VX_AUTOINC_VALID
@ VX_AUTOINC_VALID
all is valid
Definition: zwapi_cmd_dwg_data.h:685
VX_AUTOINC_CIRCLE
@ VX_AUTOINC_CIRCLE
Include circle.
Definition: zwapi_cmd_dwg_data.h:679
VX_AUTOINC_INVALID
@ VX_AUTOINC_INVALID
all is not valid
Definition: zwapi_cmd_dwg_data.h:677
VX_AUTOINC_HOLE
@ VX_AUTOINC_HOLE
Include hole.
Definition: zwapi_cmd_dwg_data.h:680
evxCenterLineType
evxCenterLineType
centerline type
Definition: zwapi_cmd_dwg_data.h:1352
VX_CL_BY_TWO_POINTS
@ VX_CL_BY_TWO_POINTS
draw by two points(Based on pick point)
Definition: zwapi_cmd_dwg_data.h:1354
VX_CL_BY_TWO_LINES
@ VX_CL_BY_TWO_LINES
draw by two lines(Based to curve)
Definition: zwapi_cmd_dwg_data.h:1353
evxDwgStkBlnPtn
evxDwgStkBlnPtn
pattern of stack balloons
Definition: zwapi_cmd_dwg_data.h:1181
VX_STKBLNPAT_HORRIGHT
@ VX_STKBLNPAT_HORRIGHT
horizontal right
Definition: zwapi_cmd_dwg_data.h:1182
VX_STKBLNPAT_VERUP
@ VX_STKBLNPAT_VERUP
vertical up
Definition: zwapi_cmd_dwg_data.h:1184
VX_STKBLNPAT_VERDOWN
@ VX_STKBLNPAT_VERDOWN
vertical down
Definition: zwapi_cmd_dwg_data.h:1185
VX_STKBLNPAT_HORLEFT
@ VX_STKBLNPAT_HORLEFT
horizontal left
Definition: zwapi_cmd_dwg_data.h:1183
evxWeldContourSym
evxWeldContourSym
contour symbol of weld symbol
Definition: zwapi_cmd_dwg_data.h:1393
VX_WELD_COUNTOUR_FLAT
@ VX_WELD_COUNTOUR_FLAT
flat
Definition: zwapi_cmd_dwg_data.h:1395
VX_WELD_COUNTOUR_CONCAVE
@ VX_WELD_COUNTOUR_CONCAVE
concave
Definition: zwapi_cmd_dwg_data.h:1397
VX_WELD_COUNTOUR_BLEND_TOES
@ VX_WELD_COUNTOUR_BLEND_TOES
blended toes
Definition: zwapi_cmd_dwg_data.h:1398
VX_WELD_COUNTOUR_NONE
@ VX_WELD_COUNTOUR_NONE
none
Definition: zwapi_cmd_dwg_data.h:1394
VX_WELD_COUNTOUR_STRIP_REMOVABLE
@ VX_WELD_COUNTOUR_STRIP_REMOVABLE
backing strip removable
Definition: zwapi_cmd_dwg_data.h:1400
VX_WELD_COUNTOUR_CONVEX
@ VX_WELD_COUNTOUR_CONVEX
convex
Definition: zwapi_cmd_dwg_data.h:1396
VX_WELD_COUNTOUR_STRIP_PERMANENT
@ VX_WELD_COUNTOUR_STRIP_PERMANENT
backing strip permanent
Definition: zwapi_cmd_dwg_data.h:1399
evxBalloonCon
evxBalloonCon
balloon text Condition
Definition: zwapi_cmd_dwg_data.h:1029
VX_BALLOON_CON_CLASS
@ VX_BALLOON_CON_CLASS
class
Definition: zwapi_cmd_dwg_data.h:1034
VX_BALLOON_CON_HEIGHT
@ VX_BALLOON_CON_HEIGHT
height
Definition: zwapi_cmd_dwg_data.h:1056
VX_BALLOON_CON_DENSITY
@ VX_BALLOON_CON_DENSITY
density
Definition: zwapi_cmd_dwg_data.h:1050
VX_BALLOON_CON_STARTDATE
@ VX_BALLOON_CON_STARTDATE
start date
Definition: zwapi_cmd_dwg_data.h:1045
VX_BALLOON_CON_MASS
@ VX_BALLOON_CON_MASS
mass
Definition: zwapi_cmd_dwg_data.h:1047
VX_BALLOON_CON_ENDDATE
@ VX_BALLOON_CON_ENDDATE
end date
Definition: zwapi_cmd_dwg_data.h:1046
VX_BALLOON_CON_PARTCFG
@ VX_BALLOON_CON_PARTCFG
part config
Definition: zwapi_cmd_dwg_data.h:1051
VX_BALLOON_CON_USERTEXT
@ VX_BALLOON_CON_USERTEXT
user text
Definition: zwapi_cmd_dwg_data.h:1030
VX_BALLOON_CON_MANAGER
@ VX_BALLOON_CON_MANAGER
manager
Definition: zwapi_cmd_dwg_data.h:1040
VX_BALLOON_CON_DESCRIPTION
@ VX_BALLOON_CON_DESCRIPTION
description
Definition: zwapi_cmd_dwg_data.h:1042
VX_BALLOON_CON_TOTALMASS
@ VX_BALLOON_CON_TOTALMASS
total mass
Definition: zwapi_cmd_dwg_data.h:1049
VX_BALLOON_CON_DESIGNER
@ VX_BALLOON_CON_DESIGNER
designer
Definition: zwapi_cmd_dwg_data.h:1035
VX_BALLOON_CON_MATERIAL
@ VX_BALLOON_CON_MATERIAL
material
Definition: zwapi_cmd_dwg_data.h:1038
VX_BALLOON_CON_LENGTH
@ VX_BALLOON_CON_LENGTH
length
Definition: zwapi_cmd_dwg_data.h:1054
VX_BALLOON_CON_STOCKSIZE
@ VX_BALLOON_CON_STOCKSIZE
stock size
Definition: zwapi_cmd_dwg_data.h:1059
VX_BALLOON_CON_DERIVEDFROM
@ VX_BALLOON_CON_DERIVEDFROM
derived from
Definition: zwapi_cmd_dwg_data.h:1044
VX_BALLOON_CON_VOLUME
@ VX_BALLOON_CON_VOLUME
volume
Definition: zwapi_cmd_dwg_data.h:1048
VX_BALLOON_CON_FILEPATH
@ VX_BALLOON_CON_FILEPATH
source file path
Definition: zwapi_cmd_dwg_data.h:1052
VX_BALLOON_CON_VISIBLE
@ VX_BALLOON_CON_VISIBLE
visible
Definition: zwapi_cmd_dwg_data.h:1060
VX_BALLOON_CON_QUANTITY
@ VX_BALLOON_CON_QUANTITY
quantity
Definition: zwapi_cmd_dwg_data.h:1039
VX_BALLOON_CON_COST
@ VX_BALLOON_CON_COST
cost
Definition: zwapi_cmd_dwg_data.h:1036
VX_BALLOON_CON_ID
@ VX_BALLOON_CON_ID
id
Definition: zwapi_cmd_dwg_data.h:1031
VX_BALLOON_CON_WIDTH
@ VX_BALLOON_CON_WIDTH
width
Definition: zwapi_cmd_dwg_data.h:1055
VX_BALLOON_CON_NAME
@ VX_BALLOON_CON_NAME
name
Definition: zwapi_cmd_dwg_data.h:1032
VX_BALLOON_CON_AREA
@ VX_BALLOON_CON_AREA
area
Definition: zwapi_cmd_dwg_data.h:1057
VX_BALLOON_CON_SIZE
@ VX_BALLOON_CON_SIZE
size
Definition: zwapi_cmd_dwg_data.h:1053
VX_BALLOON_CON_LEGEND
@ VX_BALLOON_CON_LEGEND
legend
Definition: zwapi_cmd_dwg_data.h:1058
VX_BALLOON_CON_SUPPLIER
@ VX_BALLOON_CON_SUPPLIER
supplier
Definition: zwapi_cmd_dwg_data.h:1037
VX_BALLOON_CON_KEYWORDS
@ VX_BALLOON_CON_KEYWORDS
keywords
Definition: zwapi_cmd_dwg_data.h:1043
VX_BALLOON_CON_NUMBER
@ VX_BALLOON_CON_NUMBER
number
Definition: zwapi_cmd_dwg_data.h:1033
VX_BALLOON_CON_REMARKS
@ VX_BALLOON_CON_REMARKS
remarks
Definition: zwapi_cmd_dwg_data.h:1041
evxViewPrjAngType
evxViewPrjAngType
view projection type
Definition: zwapi_cmd_dwg_data.h:225
VX_VIEW_PRJANG3RD
@ VX_VIEW_PRJANG3RD
3rd angle
Definition: zwapi_cmd_dwg_data.h:227
VX_VIEW_PRJANG1ST
@ VX_VIEW_PRJANG1ST
1st angle
Definition: zwapi_cmd_dwg_data.h:226
evxCentDimType
evxCentDimType
center mark type
Definition: zwapi_cmd_dwg_data.h:1306
VX_DM_CENDLINE
@ VX_DM_CENDLINE
Center Line: create a centerline mark between lines, arcs or circle.
Definition: zwapi_cmd_dwg_data.h:1309
VX_DM_CENMARK
@ VX_DM_CENMARK
Center Mark: create a center mark at an arc or circle.
Definition: zwapi_cmd_dwg_data.h:1307
VX_DM_CENLINE
@ VX_DM_CENLINE
Center Mark Circle: place a centerline through a circular pattern such as bolt holes.
Definition: zwapi_cmd_dwg_data.h:1308
evxDwgBndMethod
evxDwgBndMethod
Drawing Broken Section Boundary Method.
Definition: zwapi_cmd_dwg_data.h:396
VX_RECTANGULAR_BOUNDARY
@ VX_RECTANGULAR_BOUNDARY
Rectangular boundary.
Definition: zwapi_cmd_dwg_data.h:397
VX_CIRCULAR_BOUNDARY
@ VX_CIRCULAR_BOUNDARY
Circular boundary.
Definition: zwapi_cmd_dwg_data.h:398
VX_POLYLINE_BOUNDARY
@ VX_POLYLINE_BOUNDARY
Polyline boundary.
Definition: zwapi_cmd_dwg_data.h:399
evxSurfPtnSym
evxSurfPtnSym
pattern symbol of surface roughness
Definition: zwapi_cmd_dwg_data.h:1469
VX_SURF_PTNSYM_PARTICULATE
@ VX_SURF_PTNSYM_PARTICULATE
particulate
Definition: zwapi_cmd_dwg_data.h:1477
VX_SURF_PTNSYM_MULTI_DIR
@ VX_SURF_PTNSYM_MULTI_DIR
multi-directional
Definition: zwapi_cmd_dwg_data.h:1474
VX_SURF_PTNSYM_RADIAL
@ VX_SURF_PTNSYM_RADIAL
radial
Definition: zwapi_cmd_dwg_data.h:1471
VX_SURF_PTNSYM_PERPENDICULAR
@ VX_SURF_PTNSYM_PERPENDICULAR
perpendicular
Definition: zwapi_cmd_dwg_data.h:1472
VX_SURF_PTNSYM_PARALLEL
@ VX_SURF_PTNSYM_PARALLEL
parallel
Definition: zwapi_cmd_dwg_data.h:1476
VX_SURF_PTNSYM_ANGULAR
@ VX_SURF_PTNSYM_ANGULAR
angular
Definition: zwapi_cmd_dwg_data.h:1473
VX_SURF_PTNSYM_CIRCULAR
@ VX_SURF_PTNSYM_CIRCULAR
circular
Definition: zwapi_cmd_dwg_data.h:1475
VX_SURF_PTNSYM_NONE
@ VX_SURF_PTNSYM_NONE
none
Definition: zwapi_cmd_dwg_data.h:1470
evxViewLocationType
evxViewLocationType
drawing view location type
Definition: zwapi_cmd_dwg_data.h:35
VX_LOCATION_CENTER
@ VX_LOCATION_CENTER
set center point
Definition: zwapi_cmd_dwg_data.h:37
VX_LOCATION_AUTO
@ VX_LOCATION_AUTO
automatic set-up
Definition: zwapi_cmd_dwg_data.h:36
VX_LOCATION_CORNER
@ VX_LOCATION_CORNER
set corner points
Definition: zwapi_cmd_dwg_data.h:38
evxDatumTargDimType
evxDatumTargDimType
datum target dim type
Definition: zwapi_cmd_dwg_data.h:1250
VX_DATUMT_POINT
@ VX_DATUMT_POINT
datum target - Point
Definition: zwapi_cmd_dwg_data.h:1254
VX_DATUMT_CIRCLE
@ VX_DATUMT_CIRCLE
datum target - Circle
Definition: zwapi_cmd_dwg_data.h:1251
VX_DATUMT_LINE
@ VX_DATUMT_LINE
datum target - Line
Definition: zwapi_cmd_dwg_data.h:1253
VX_DATUMT_RECTANGLE
@ VX_DATUMT_RECTANGLE
datum target - Rectangle
Definition: zwapi_cmd_dwg_data.h:1252
evxLocAngType
evxLocAngType
location angle
Definition: zwapi_cmd_dwg_data.h:305
VX_LOC_ANG_DEFAULT
@ VX_LOC_ANG_DEFAULT
default
Definition: zwapi_cmd_dwg_data.h:306
VX_LOC_ANG_CUSTOM
@ VX_LOC_ANG_CUSTOM
custom
Definition: zwapi_cmd_dwg_data.h:309
VX_LOC_ANG_HORIZONTAL
@ VX_LOC_ANG_HORIZONTAL
horizontal
Definition: zwapi_cmd_dwg_data.h:307
VX_LOC_ANG_VERTICAL
@ VX_LOC_ANG_VERTICAL
vertical
Definition: zwapi_cmd_dwg_data.h:308
evxSymmetryDimType
evxSymmetryDimType
symmetry dimension type
Definition: zwapi_cmd_dwg_data.h:786
VX_SYM_ANGULAR
@ VX_SYM_ANGULAR
angular dimension
Definition: zwapi_cmd_dwg_data.h:788
VX_SYM_LINEAR
@ VX_SYM_LINEAR
linear dimension
Definition: zwapi_cmd_dwg_data.h:787
evxDwgHoleMarkType
evxDwgHoleMarkType
drawing sheet hole mark method
Definition: zwapi_cmd_dwg_data.h:1537
VX_DWG_HOLE_MARK_AUTO
@ VX_DWG_HOLE_MARK_AUTO
auto pick
Definition: zwapi_cmd_dwg_data.h:1538
VX_DWG_HOLE_MARK_MANUAL
@ VX_DWG_HOLE_MARK_MANUAL
manual pick
Definition: zwapi_cmd_dwg_data.h:1539
svxViewLayoutData
struct svxViewLayoutData svxViewLayoutData
drawing view layout data
svxViewSecLine
struct svxViewSecLine svxViewSecLine
section line
svxViewStandardData
struct svxViewStandardData svxViewStandardData
drawing view standard data
svxSymSurf
struct svxSymSurf svxSymSurf
surface finish data
svxDwgRotView
struct svxDwgRotView svxDwgRotView
Rotate View.
svxDwgFtrCtrl
struct svxDwgFtrCtrl svxDwgFtrCtrl
Datum Control.
svxDwgHoleCallOutDim
struct svxDwgHoleCallOutDim svxDwgHoleCallOutDim
Hole Callout.
svxDwgTblInsert
struct svxDwgTblInsert svxDwgTblInsert
insert Table
svxDimLabel
struct svxDimLabel svxDimLabel
Label.
svxCenterLine
struct svxCenterLine svxCenterLine
Center Line.
svxDwgDetailData
struct svxDwgDetailData svxDwgDetailData
Drawing Detail input infos.
svxDimAuto
struct svxDimAuto svxDimAuto
auto dimension
svxViewLocationData
struct svxViewLocationData svxViewLocationData
drawing view location data
svxDwgLineGrpDim
struct svxDwgLineGrpDim svxDwgLineGrpDim
Baseline, Continuous.
svxViewLayoutMethod
struct svxViewLayoutMethod svxViewLayoutMethod
drawing view layout method
svxDwgConsDim
struct svxDwgConsDim svxDwgConsDim
data of constraint dimension
svxDwgBrokenSectionData
struct svxDwgBrokenSectionData svxDwgBrokenSectionData
Drawing Broken Section input infos.
svxDatumTargDimData
struct svxDatumTargDimData svxDatumTargDimData
datum target dim data
svxDwgLineOffsetDim
struct svxDwgLineOffsetDim svxDwgLineOffsetDim
Linear Offset.
svxViewAt
struct svxViewAt svxViewAt
View layout display attributes.
svxAuxViewData
struct svxAuxViewData svxAuxViewData
Auxiliary view data.
svxSymImg
struct svxSymImg svxSymImg
image data
svxCenterMark
struct svxCenterMark svxCenterMark
Center Mark.
svxDwgOrdinateDim
struct svxDwgOrdinateDim svxDwgOrdinateDim
Ordinate.
svxDatumDimData
struct svxDatumDimData svxDatumDimData
datum dim data(drawing)
svxDwgArcDimData
struct svxDwgArcDimData svxDwgArcDimData
Arc dimension dim data.
svxBrkLineData
struct svxBrkLineData svxBrkLineData
information we need when create break line
svxDwgSymmetryDimData
struct svxDwgSymmetryDimData svxDwgSymmetryDimData
Symmetry dimension data.
svxRadDimData
struct svxRadDimData svxRadDimData
radial or diametric dim data
svxDwgBom
struct svxDwgBom svxDwgBom
BOM table data.
svxHatchAttr
struct svxHatchAttr svxHatchAttr
hatch attributes
svxViewArrow
struct svxViewArrow svxViewArrow
view projection arrow
svxFulSecViewData
struct svxFulSecViewData svxFulSecViewData
full section view data
svxDwgLineDim
struct svxDwgLineDim svxDwgLineDim
Linear.
svxSymWeld
struct svxSymWeld svxSymWeld
Weld data.
svxAutoSet
struct svxAutoSet svxAutoSet
dimension position
svxDwgAngDimData
struct svxDwgAngDimData svxDwgAngDimData
Angular dimension dim data.
svxLabelCoorDimData
struct svxLabelCoorDimData svxLabelCoorDimData
label coordinate dim data
svxDwgBalloonDim
struct svxDwgBalloonDim svxDwgBalloonDim
Balloon.
svxDwgHoleMark
struct svxDwgHoleMark svxDwgHoleMark
drawing sheet hole mark data
svxCenMarkCirDimData
struct svxCenMarkCirDimData svxCenMarkCirDimData
center mark circle dim data
svxDwgIsectSym
struct svxDwgIsectSym svxDwgIsectSym
drawing intersection symbol data
svxDwgStkBlnData
struct svxDwgStkBlnData svxDwgStkBlnData
information of creating stack balloons
svxAlignSecViewData
struct svxAlignSecViewData svxAlignSecViewData
aligned section view data
svxDwgAtBlnData
struct svxDwgAtBlnData svxDwgAtBlnData
Information of creating auto balloon.
svxCenterDim
struct svxCenterDim svxCenterDim
Center Mark Settings.
svxViewSecMtd
struct svxViewSecMtd svxViewSecMtd
section method
svxPrjSetting
struct svxPrjSetting svxPrjSetting
Projection or Auxiliary view's projection settings.
svxViewSecOp
struct svxViewSecOp svxViewSecOp
section option
svxDwgLnrChmDimData
struct svxDwgLnrChmDimData svxDwgLnrChmDimData
the info of the linear chamfer dim
evxHatchPtnType
evxHatchPtnType
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sk...
Definition: zwapi_cmd_sk_create_data.h:64
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxUint32
unsigned int vxUint32
32 bit unsigned integer
Definition: zwapi_util.h:250
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxLineWidth
evxLineWidth
line width
Definition: zwapi_util.h:1434
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAlignSecViewData::idView
int idView
the id of base view to section
Definition: zwapi_cmd_dwg_data.h:379
svxAlignSecViewData::locPnt
svxPoint2 locPnt
the location for section view
Definition: zwapi_cmd_dwg_data.h:385
svxAlignSecViewData::cntBasePnts
int cntBasePnts
the count of the base points
Definition: zwapi_cmd_dwg_data.h:381
svxAlignSecViewData::secLine
svxViewSecLine secLine
section line
Definition: zwapi_cmd_dwg_data.h:387
svxAlignSecViewData::basePnt
svxPoint2 basePnt
base point of the section
Definition: zwapi_cmd_dwg_data.h:380
svxAlignSecViewData::pBasePnts
svxPoint2 * pBasePnts
points to define the section
Definition: zwapi_cmd_dwg_data.h:382
svxAlignSecViewData::secMtd
svxViewSecMtd secMtd
section method
Definition: zwapi_cmd_dwg_data.h:386
svxAlignSecViewData::cntAlignPnts
int cntAlignPnts
the count of the align points
Definition: zwapi_cmd_dwg_data.h:383
svxAlignSecViewData::pAlignPnts
svxPoint2 * pAlignPnts
points to define aligned cutting plane
Definition: zwapi_cmd_dwg_data.h:384
svxAlignSecViewData::secOp
svxViewSecOp secOp
section option
Definition: zwapi_cmd_dwg_data.h:388
svxAlignSecViewData
aligned section view data
Definition: zwapi_cmd_dwg_data.h:378
svxAutoSet::type
evxAutoDimType type
select auto dimension type
Definition: zwapi_cmd_dwg_data.h:665
svxAutoSet::asgrp
int asgrp
1:auto dimensions are as group dimension* 0:not, default value:1
Definition: zwapi_cmd_dwg_data.h:668
svxAutoSet::viewType
evxAutoPlacement viewType
dimensions position / placement, default value:DIM_VIEW_BELOW_RIGHT
Definition: zwapi_cmd_dwg_data.h:667
svxAutoSet::refPnt
svxPntOnEnt refPnt
reference point, used when enable is 1
Definition: zwapi_cmd_dwg_data.h:666
svxAutoSet::enable
int enable
svxAutoSet enabled or not
Definition: zwapi_cmd_dwg_data.h:664
svxAutoSet
dimension position
Definition: zwapi_cmd_dwg_data.h:663
svxAuxViewData::arrowInfo
svxViewArrow arrowInfo
view arrow
Definition: zwapi_cmd_dwg_data.h:274
svxAuxViewData::idView
int idView
the id of base view
Definition: zwapi_cmd_dwg_data.h:270
svxAuxViewData::idLine
int idLine
line to define auxiliary view plane (this must be a line)
Definition: zwapi_cmd_dwg_data.h:271
svxAuxViewData::settings
svxPrjSetting settings
projection settings
Definition: zwapi_cmd_dwg_data.h:273
svxAuxViewData::locPnt
svxPoint2 locPnt
view location
Definition: zwapi_cmd_dwg_data.h:272
svxAuxViewData
Auxiliary view data.
Definition: zwapi_cmd_dwg_data.h:269
svxBrkLineData::pts
svxPntOnEnt pts[3]
3 input points depend on option of break line. only VX_SLANT_BRKLINE needs the third point,...
Definition: zwapi_cmd_dwg_data.h:481
svxBrkLineData::brkLnType
evxBrkLineType brkLnType
option of break line
Definition: zwapi_cmd_dwg_data.h:480
svxBrkLineData::viewId
int viewId
id of view
Definition: zwapi_cmd_dwg_data.h:479
svxBrkLineData::gap
double gap
gap size
Definition: zwapi_cmd_dwg_data.h:483
svxBrkLineData::dir
svxPoint2 dir
direction setting, only required when evxBrkLineType is VX_SLANT_BRKLINE
Definition: zwapi_cmd_dwg_data.h:484
svxBrkLineData
information we need when create break line
Definition: zwapi_cmd_dwg_data.h:478
svxCenMarkCirDimData::pCens
svxPntOnEnt * pCens
point to the point for center marks(the length of list must equal to iCntCens)
Definition: zwapi_cmd_dwg_data.h:1336
svxCenMarkCirDimData::iflg
int iflg
optional open/close flag 0-Arc(open), 1-Circle(close) (note: 1 as default)
Definition: zwapi_cmd_dwg_data.h:1338
svxCenMarkCirDimData::flgCenter
char flgCenter
flag to use "center" (0 as default)
Definition: zwapi_cmd_dwg_data.h:1341
svxCenMarkCirDimData::center
svxPntOnEnt center
arc center or circle center(if flgCenter = 1, the value is valid) if iflg = 0, the center is the arc ...
Definition: zwapi_cmd_dwg_data.h:1342
svxCenMarkCirDimData::iCntCens
int iCntCens
the count of the center marks
Definition: zwapi_cmd_dwg_data.h:1335
svxCenMarkCirDimData
center mark circle dim data
Definition: zwapi_cmd_dwg_data.h:1334
svxCenterDim::scaleFac
double scaleFac
overall scale factor, default value:1
Definition: zwapi_cmd_dwg_data.h:1298
svxCenterDim::breakLen
double breakLen
extension lines break length (gap), default value:1.5
Definition: zwapi_cmd_dwg_data.h:1296
svxCenterDim::overRun
double overRun
extension lines overrun, default value:3.06324
Definition: zwapi_cmd_dwg_data.h:1297
svxCenterDim::cmSize
double cmSize
center line/mark size (short dash), default value:4.254534
Definition: zwapi_cmd_dwg_data.h:1295
svxCenterDim
Center Mark Settings.
Definition: zwapi_cmd_dwg_data.h:1294
svxCenterLine::zCenterDim
svxCenterDim zCenterDim
option param: center dimension attribute
Definition: zwapi_cmd_dwg_data.h:1370
svxCenterLine::iDimType
evxCenterLineType iDimType
start point. if type = VX_CL_BY_TWO_LINES, the start point is regarded as the entity line of the poin...
Definition: zwapi_cmd_dwg_data.h:1363
svxCenterLine::zPntStart
svxPntOnEnt zPntStart
end point. if type = VX_CL_BY_TWO_LINES, the end point is regarded as the entity line of the point,...
Definition: zwapi_cmd_dwg_data.h:1366
svxCenterLine::zPntEnd
svxPntOnEnt zPntEnd
end point
Definition: zwapi_cmd_dwg_data.h:1369
svxCenterLine
Center Line.
Definition: zwapi_cmd_dwg_data.h:1362
svxCenterMark::idEntity
int idEntity
entity id
Definition: zwapi_cmd_dwg_data.h:1318
svxCenterMark::zCenterDim
svxCenterDim zCenterDim
option param: center dimension attribute
Definition: zwapi_cmd_dwg_data.h:1323
svxCenterMark::zRotPnt
svxPntOnEnt zRotPnt
rotation point, just for cmType = VX_DM_CENMARK
Definition: zwapi_cmd_dwg_data.h:1321
svxCenterMark::zEntPnt
svxPoint zEntPnt
critical point of the entity
Definition: zwapi_cmd_dwg_data.h:1319
svxCenterMark::useRotPnt
char useRotPnt
whether to rotate the center line/mark toward a selected point.(0: no, 1: yes)
Definition: zwapi_cmd_dwg_data.h:1320
svxCenterMark::slotType
int slotType
Slot center mark type, valid when entity is a hole, default value:1.
Definition: zwapi_cmd_dwg_data.h:1324
svxCenterMark::cmType
evxCentDimType cmType
center mark type, default value:VX_DM_CENLINE
Definition: zwapi_cmd_dwg_data.h:1322
svxCenterMark
Center Mark.
Definition: zwapi_cmd_dwg_data.h:1317
svxDatumDimData::type
evxDatumDimType type
datum type. (note: VX_DATUM_NORMAL as default)
Definition: zwapi_cmd_dwg_data.h:1234
svxDatumDimData::txtPnt
svxPntOnEnt txtPnt
point coordinate of text placement point. if type = VX_DATUM_NORMAL, txtPnt can be given arbitrarily....
Definition: zwapi_cmd_dwg_data.h:1240
svxDatumDimData::text
char * text
datum label name
Definition: zwapi_cmd_dwg_data.h:1236
svxDatumDimData::leadPnt
svxPntOnEnt leadPnt
point coordinate of point on entity. if type = VX_DATUM_NORMAL, leadPnt is the txtPnt's projection on...
Definition: zwapi_cmd_dwg_data.h:1237
svxDatumDimData
datum dim data(drawing)
Definition: zwapi_cmd_dwg_data.h:1233
svxDatumTargDimData::userText
char * userText
user text (userText is valid when iAreaSizeText equals to 1): defines the text that is displayed inst...
Definition: zwapi_cmd_dwg_data.h:1282
svxDatumTargDimData::diameter
double diameter
diameter (just for type = VX_DATUMT_RECTANGLE, other type can be ignored). if type = VX_DATUMT_RECTAN...
Definition: zwapi_cmd_dwg_data.h:1271
svxDatumTargDimData::text2
char * text2
datum text2 (text2 is valid when text is not empty)
Definition: zwapi_cmd_dwg_data.h:1278
svxDatumTargDimData::text3
char * text3
datum text3 (text3 is valid when text2 is not empty)
Definition: zwapi_cmd_dwg_data.h:1279
svxDatumTargDimData::textPnt
svxPntOnEnt textPnt
text point
Definition: zwapi_cmd_dwg_data.h:1267
svxDatumTargDimData::text
char * text
datum text
Definition: zwapi_cmd_dwg_data.h:1277
svxDatumTargDimData::type
evxDatumTargDimType type
datum target type. (Note: VX_DATUMT_POINT as default)
Definition: zwapi_cmd_dwg_data.h:1263
svxDatumTargDimData::width
double width
width (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE,...
Definition: zwapi_cmd_dwg_data.h:1273
svxDatumTargDimData::height
double height
height (just for type = VX_DATUMT_LINE, other type can be ignored). if type = VX_DATUMT_LINE,...
Definition: zwapi_cmd_dwg_data.h:1275
svxDatumTargDimData::iAreaSizeText
int iAreaSizeText
Area size text (0-Area size, 1-User text, 0 as default): to determine how the upper text of the datum...
Definition: zwapi_cmd_dwg_data.h:1280
svxDatumTargDimData::pnt
svxPntOnEnt pnt
point coordinate of point on entity.
Definition: zwapi_cmd_dwg_data.h:1266
svxDatumTargDimData::secPnt
svxPntOnEnt secPnt
2nd point (if type = VX_DATUMT_POINT, secPnt is 2nd point of a line other type can be ignored)
Definition: zwapi_cmd_dwg_data.h:1268
svxDatumTargDimData
datum target dim data
Definition: zwapi_cmd_dwg_data.h:1262
svxDimAuto::cntEnt
int cntEnt
entity ID count. if type = DIM_AUTO_ENT_PICKED, number of entities need to be created dimension,...
Definition: zwapi_cmd_dwg_data.h:696
svxDimAuto::checkOrg
int checkOrg
origin check flag, default value:1
Definition: zwapi_cmd_dwg_data.h:705
svxDimAuto::horDim
svxAutoSet horDim
horizontal dimensions position/placement
Definition: zwapi_cmd_dwg_data.h:707
svxDimAuto::idView
int idView
index of View
Definition: zwapi_cmd_dwg_data.h:694
svxDimAuto::verDim
svxAutoSet verDim
vertical dimensions position/placement
Definition: zwapi_cmd_dwg_data.h:708
svxDimAuto::entType
evxAutoEntType entType
select entity type, default value:DIM_AUTO_ENT_ALL
Definition: zwapi_cmd_dwg_data.h:695
svxDimAuto::pntOrg
svxPntOnEnt pntOrg
origin reference point, member critPnt should be entity critical point
Definition: zwapi_cmd_dwg_data.h:706
svxDimAuto::incAuto
unsigned int incAuto
evxAutoInclude mask. whether to include arc, circle, hole, line, R/hole callout, cylindrical dimensio...
Definition: zwapi_cmd_dwg_data.h:702
svxDimAuto::pEntId
int * pEntId
entity ID list. if type = DIM_AUTO_ENT_PICKED, list id of entities need to be created dimension,...
Definition: zwapi_cmd_dwg_data.h:699
svxDimAuto
auto dimension
Definition: zwapi_cmd_dwg_data.h:693
svxDimLabel::text
char * text
text content to be shown
Definition: zwapi_cmd_dwg_data.h:1073
svxDimLabel::localPnts
svxPntOnEnt * localPnts
localPnts info: specify the location of the arrow
Definition: zwapi_cmd_dwg_data.h:1070
svxDimLabel::leadPnts
svxPntOnEnt * leadPnts
leadPnts info: locate where additional leader arrow will point
Definition: zwapi_cmd_dwg_data.h:1072
svxDimLabel::localPntCnt
int localPntCnt
localPnts list count
Definition: zwapi_cmd_dwg_data.h:1069
svxDimLabel::leadPntCnt
int leadPntCnt
leadPnts list count
Definition: zwapi_cmd_dwg_data.h:1071
svxDimLabel
Label.
Definition: zwapi_cmd_dwg_data.h:1068
svxDwgAngDimData::txtPnt
svxPntOnEnt txtPnt
text point. if type = VX_ANG_ARC, the point is position of text of angle. other type can be null
Definition: zwapi_cmd_dwg_data.h:913
svxDwgAngDimData::type
evxAngDimType type
Angular or diametric type.
Definition: zwapi_cmd_dwg_data.h:887
svxDwgAngDimData::StartPnt
svxPntOnEnt StartPnt
start point. if type = VX_ANG_THREEPOINT, the angle is between two line, 1st line through....
Definition: zwapi_cmd_dwg_data.h:897
svxDwgAngDimData::BasePnt
svxPntOnEnt BasePnt
base point. if type = VX_ANG_THREEPOINT, BasePnt is angle's vertex. other type can be null.
Definition: zwapi_cmd_dwg_data.h:901
svxDwgAngDimData::Curve1
svxPntOnEnt Curve1
get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and...
Definition: zwapi_cmd_dwg_data.h:889
svxDwgAngDimData::QuadrantPnt
svxPntOnEnt QuadrantPnt
quadrant point. if type != VX_ANG_ARC, the point is position of text of angle.
Definition: zwapi_cmd_dwg_data.h:911
svxDwgAngDimData::ArcPnt
svxPntOnEnt ArcPnt
arc point on arc. if type = VX_ANG_ARC, the angle is arc's angle. other type can be null
Definition: zwapi_cmd_dwg_data.h:908
svxDwgAngDimData::EndPnt
svxPntOnEnt EndPnt
end point. if type = VX_ANG_THREEPOINT, the angle is between two line, 2nd line through....
Definition: zwapi_cmd_dwg_data.h:904
svxDwgAngDimData::Curve2
svxPntOnEnt Curve2
get one entity and point coordinate. if type = VX_ANG_TWOCURVES, the angle is between 1st curve and 2...
Definition: zwapi_cmd_dwg_data.h:894
svxDwgAngDimData
Angular dimension dim data.
Definition: zwapi_cmd_dwg_data.h:886
svxDwgArcDimData::txtPnt
svxPntOnEnt txtPnt
text point : specify the location of the dimension text.
Definition: zwapi_cmd_dwg_data.h:958
svxDwgArcDimData::ArcEnt
svxPntOnEnt ArcEnt
get arc one entity
Definition: zwapi_cmd_dwg_data.h:957
svxDwgArcDimData
Arc dimension dim data.
Definition: zwapi_cmd_dwg_data.h:956
svxDwgAtBlnData::viewIdCnt
int viewIdCnt
count of view id
Definition: zwapi_cmd_dwg_data.h:1152
svxDwgAtBlnData::ptnType
evxDwgAtBlnPtnType ptnType
pattern type (note: VX_ATBLNPAT_CONVEXHULL as default)
Definition: zwapi_cmd_dwg_data.h:1156
svxDwgAtBlnData::leadAttach
evxDwgAtBlnLeadAttach leadAttach
leader attachment (note: VX_ATBLNLEAATT_EDAGES as default)
Definition: zwapi_cmd_dwg_data.h:1158
svxDwgAtBlnData::viewIdList
int * viewIdList
list of view id
Definition: zwapi_cmd_dwg_data.h:1153
svxDwgAtBlnData::KepItem
int KepItem
flag of keeping item (0 no, else yes), Used when arrangement is not VX_ATBLLNARR_NEAREST....
Definition: zwapi_cmd_dwg_data.h:1167
svxDwgAtBlnData::offSet
vxUint32 offSet
specify the offset
Definition: zwapi_cmd_dwg_data.h:1160
svxDwgAtBlnData::OnlyBom
int OnlyBom
Whether the excluded components from BOM should be labeled. Used when have bom in sheeting....
Definition: zwapi_cmd_dwg_data.h:1170
svxDwgAtBlnData::instOpt
evxDwgAtBlnInsTyp instOpt
instances type (note: VX_ATBLNINS_IGNMULINS as default)
Definition: zwapi_cmd_dwg_data.h:1154
svxDwgAtBlnData::skipSides
evxDwgAtBlnSkpSd skipSides
prevent placing balloon labels along one side of the view. Be unusable when ptnType is VX_ATBLNPAT_CI...
Definition: zwapi_cmd_dwg_data.h:1161
svxDwgAtBlnData::arrangement
evxDwgAtBlnArrg arrangement
how the balloon labels will be arranged around the layout view. Used when have bom in sheeting,...
Definition: zwapi_cmd_dwg_data.h:1164
svxDwgAtBlnData::ItemId
int ItemId
index of the kept curve,used when KepItem is not 0.
Definition: zwapi_cmd_dwg_data.h:1169
svxDwgAtBlnData::OnlyWithoutBln
int OnlyWithoutBln
Whether label the components which are not labeled in any other views to eliminate duplicate balloons...
Definition: zwapi_cmd_dwg_data.h:1172
svxDwgAtBlnData
Information of creating auto balloon.
Definition: zwapi_cmd_dwg_data.h:1151
svxDwgBalloonDim::cntCrv
int cntCrv
no. of Location data items
Definition: zwapi_cmd_dwg_data.h:1084
svxDwgBalloonDim::leadPoints
svxPntOnEnt * leadPoints
list of "cntlead" points
Definition: zwapi_cmd_dwg_data.h:1087
svxDwgBalloonDim::Points
svxPntOnEnt * Points
list of "cntCrv" points
Definition: zwapi_cmd_dwg_data.h:1085
svxDwgBalloonDim::text
char * text
text string
Definition: zwapi_cmd_dwg_data.h:1083
svxDwgBalloonDim::condition
evxBalloonCon condition
Text condition, default value:VX_BALLOON_CON_ID.
Definition: zwapi_cmd_dwg_data.h:1082
svxDwgBalloonDim::cntlead
int cntlead
no. of Lead pnts data items: to locate where additional leader arrows will point
Definition: zwapi_cmd_dwg_data.h:1086
svxDwgBalloonDim
Balloon.
Definition: zwapi_cmd_dwg_data.h:1081
svxDwgBom::name
char * name
name
Definition: zwapi_cmd_dwg_data.h:546
svxDwgBom::level
evxLevelSet level
Level Setting, default value:VX_TOP_LEVEL_ONLY.
Definition: zwapi_cmd_dwg_data.h:547
svxDwgBom::Maxdepthval
int Maxdepthval
Max traverse depth value(default value:1): to define which assembly level BOM should read out up to.
Definition: zwapi_cmd_dwg_data.h:550
svxDwgBom::order
evxOrderType order
Order, default value:VX_ORDER_BYNAME.
Definition: zwapi_cmd_dwg_data.h:553
svxDwgBom::indent
evxIndentedType indent
Indented type(default value:VX_DETAILED_NUM): to define how to number the components from the sub-ass...
Definition: zwapi_cmd_dwg_data.h:548
svxDwgBom::bomset
int bomset
Settings by evxBomset, default value:VX_DERIVED_PARTS.
Definition: zwapi_cmd_dwg_data.h:551
svxDwgBom::checkMax
int checkMax
whether to use Max traverse depth: 0(default value) no, else yes
Definition: zwapi_cmd_dwg_data.h:549
svxDwgBom::idView
int idView
id of View
Definition: zwapi_cmd_dwg_data.h:545
svxDwgBom::startID
int startID
starting ID, default value:1
Definition: zwapi_cmd_dwg_data.h:552
svxDwgBom
BOM table data.
Definition: zwapi_cmd_dwg_data.h:544
svxDwgBrokenSectionData::type
evxDwgDepthType type
depth type
Definition: zwapi_cmd_dwg_data.h:423
svxDwgBrokenSectionData::idView
int idView
Base view.
Definition: zwapi_cmd_dwg_data.h:420
svxDwgBrokenSectionData::dPoint
svxPoint2 dPoint
depth point
Definition: zwapi_cmd_dwg_data.h:424
svxDwgBrokenSectionData::countBPs
int countBPs
count of "bPoints"
Definition: zwapi_cmd_dwg_data.h:422
svxDwgBrokenSectionData::method
evxDwgBndMethod method
Boundary Method.
Definition: zwapi_cmd_dwg_data.h:419
svxDwgBrokenSectionData::dView
int dView
depth view
Definition: zwapi_cmd_dwg_data.h:428
svxDwgBrokenSectionData::isDynamicHatch
int isDynamicHatch
dynamic hatch scaling and angle
Definition: zwapi_cmd_dwg_data.h:431
svxDwgBrokenSectionData::isShow
int isShow
show step lines
Definition: zwapi_cmd_dwg_data.h:430
svxDwgBrokenSectionData::countOPs
int countOPs
count of "oPoints"
Definition: zwapi_cmd_dwg_data.h:433
svxDwgBrokenSectionData::name
vxName name
3D name
Definition: zwapi_cmd_dwg_data.h:429
svxDwgBrokenSectionData::bPoints
svxPoint2 * bPoints
The boundary is made up of points.
Definition: zwapi_cmd_dwg_data.h:421
svxDwgBrokenSectionData::dOffset
double dOffset
depth offset
Definition: zwapi_cmd_dwg_data.h:427
svxDwgBrokenSectionData::oPoints
svxPoint2 * oPoints
offset points
Definition: zwapi_cmd_dwg_data.h:432
svxDwgBrokenSectionData::idCrv
int idCrv
curve id. if type == VX_DEPTH_POINT, point "dPoint" must be on the curve "idCrv"
Definition: zwapi_cmd_dwg_data.h:425
svxDwgBrokenSectionData
Drawing Broken Section input infos.
Definition: zwapi_cmd_dwg_data.h:418
svxDwgConsDim::type
evxDimLineType type
type of dimension default value:horizontal method
Definition: zwapi_cmd_dwg_data.h:733
svxDwgConsDim::firstPnt
svxPntOnEnt firstPnt
first point
Definition: zwapi_cmd_dwg_data.h:734
svxDwgConsDim::textPnt
svxPntOnEnt textPnt
text point: to locate the dimension text
Definition: zwapi_cmd_dwg_data.h:736
svxDwgConsDim::secondPnt
svxPntOnEnt secondPnt
second point
Definition: zwapi_cmd_dwg_data.h:735
svxDwgConsDim
data of constraint dimension
Definition: zwapi_cmd_dwg_data.h:732
svxDwgDetailData::pPnts
svxPntOnEnt * pPnts
pick points defining the detail boundary
Definition: zwapi_cmd_dwg_data.h:456
svxDwgDetailData::Location
svxPntOnEnt Location
local detail view position
Definition: zwapi_cmd_dwg_data.h:459
svxDwgDetailData::method
evxDwgDetailMethod method
Detail Method.
Definition: zwapi_cmd_dwg_data.h:453
svxDwgDetailData::PntCount
int PntCount
all points count
Definition: zwapi_cmd_dwg_data.h:455
svxDwgDetailData::idView
int idView
Base view.
Definition: zwapi_cmd_dwg_data.h:454
svxDwgDetailData::iMultiplier
int iMultiplier
local magnification
Definition: zwapi_cmd_dwg_data.h:458
svxDwgDetailData::NotePnt
svxPntOnEnt NotePnt
pick point for note
Definition: zwapi_cmd_dwg_data.h:457
svxDwgDetailData
Drawing Detail input infos.
Definition: zwapi_cmd_dwg_data.h:452
svxDwgFtrCtrl::text
char * text
FCS text name.
Definition: zwapi_cmd_dwg_data.h:1209
svxDwgFtrCtrl::leadPoints
svxPntOnEnt * leadPoints
list of "cntlead" points
Definition: zwapi_cmd_dwg_data.h:1213
svxDwgFtrCtrl::Points
svxPntOnEnt * Points
list of "cntCrv" points
Definition: zwapi_cmd_dwg_data.h:1211
svxDwgFtrCtrl::cntauxiLoc
int cntauxiLoc
no. of Auxiliary location data items
Definition: zwapi_cmd_dwg_data.h:1214
svxDwgFtrCtrl::cntlead
int cntlead
no. of Lead pts data items
Definition: zwapi_cmd_dwg_data.h:1212
svxDwgFtrCtrl::auxiPoints
svxPntOnEnt * auxiPoints
list of "cntauxiLoc" points
Definition: zwapi_cmd_dwg_data.h:1215
svxDwgFtrCtrl::cntCrv
int cntCrv
no. of Location data items
Definition: zwapi_cmd_dwg_data.h:1210
svxDwgFtrCtrl
Datum Control.
Definition: zwapi_cmd_dwg_data.h:1208
svxDwgHoleCallOutDim::cntCrv
int cntCrv
number of pCrvs or Pnts. the layout view where the holes are displayed true to their diameters.
Definition: zwapi_cmd_dwg_data.h:990
svxDwgHoleCallOutDim::ignoreDup
int ignoreDup
Ignore duplicate hole callout, 1 is ignored,0 not, default value:0 1 - if you want to exclude the mar...
Definition: zwapi_cmd_dwg_data.h:996
svxDwgHoleCallOutDim::pnts
svxPoint2 * pnts
list of text point. NULL to use default value. (the new variable when the ZW_API_VERSION is 2730)
Definition: zwapi_cmd_dwg_data.h:994
svxDwgHoleCallOutDim::iCalloutemt
unsigned int iCalloutemt
Callout Elements by evxCalloutEmt combined, default value:VX_CALLOUTEMT_VALID.
Definition: zwapi_cmd_dwg_data.h:998
svxDwgHoleCallOutDim::pCrvs
int * pCrvs
list of Holes data. the holes anywhere on their perimeter diameter
Definition: zwapi_cmd_dwg_data.h:992
svxDwgHoleCallOutDim::idView
int idView
id of View
Definition: zwapi_cmd_dwg_data.h:989
svxDwgHoleCallOutDim
Hole Callout.
Definition: zwapi_cmd_dwg_data.h:988
svxDwgHoleMark::pattern
evxDwgHoleMarkPtn pattern
pattern of manual hole mark(if type = 2, the option is available).default:VX_DWG_HOLE_MARK_UP_LEFT_4
Definition: zwapi_cmd_dwg_data.h:1584
svxDwgHoleMark::idCirs
int * idCirs
list id of circle entities need to be marked if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4,...
Definition: zwapi_cmd_dwg_data.h:1570
svxDwgHoleMark::type
evxDwgHoleMarkType type
hole mark option
Definition: zwapi_cmd_dwg_data.h:1568
svxDwgHoleMark::idView
int idView
id of view if type = VX_DWG_HOLE_MARK_UP_RIGHT_4, auto mark the hole of the view other type can be nu...
Definition: zwapi_cmd_dwg_data.h:1573
svxDwgHoleMark::hidden
int hidden
whether to mark hidden holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4,...
Definition: zwapi_cmd_dwg_data.h:1578
svxDwgHoleMark::boolean
int boolean
whether to mark boolean holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4,...
Definition: zwapi_cmd_dwg_data.h:1580
svxDwgHoleMark::numCir
int numCir
number of circle entities need to be marked
Definition: zwapi_cmd_dwg_data.h:1569
svxDwgHoleMark::sameD
int sameD
whether to filter same diameter(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_DOWN_LEFT_4,...
Definition: zwapi_cmd_dwg_data.h:1582
svxDwgHoleMark::backface
int backface
whether to mark backfacing holes(0 = no, 1 = yes).default:0 if type = VX_DWG_HOLE_MARK_UP_RIGHT_4,...
Definition: zwapi_cmd_dwg_data.h:1576
svxDwgHoleMark
drawing sheet hole mark data
Definition: zwapi_cmd_dwg_data.h:1567
svxDwgIsectSym::fistEdge
svxPntOnEnt fistEdge
point of the first line or arc, create intersection symbol between two entity
Definition: zwapi_cmd_dwg_data.h:1527
svxDwgIsectSym::secondEdge
svxPntOnEnt secondEdge
point of the second line or arc
Definition: zwapi_cmd_dwg_data.h:1529
svxDwgIsectSym
drawing intersection symbol data
Definition: zwapi_cmd_dwg_data.h:1526
svxDwgLineDim::dirPnt
svxPntOnEnt dirPnt
the point on the project line. if type = VX_DIM_LINE_LP, the point is on the project line,...
Definition: zwapi_cmd_dwg_data.h:749
svxDwgLineDim::angle
double angle
dimension angle. if type = VX_DIM_LINE_LR, it is the angle between target line and vertical line,...
Definition: zwapi_cmd_dwg_data.h:746
svxDwgLineDim::cons
svxDwgConsDim cons
constraint dimension, 5 type of line dimension
Definition: zwapi_cmd_dwg_data.h:745
svxDwgLineDim
Linear.
Definition: zwapi_cmd_dwg_data.h:744
svxDwgLineGrpDim::Points
svxPntOnEnt * Points
list of "cntCrv" Points
Definition: zwapi_cmd_dwg_data.h:762
svxDwgLineGrpDim::cntCrv
int cntCrv
no. of Points data items
Definition: zwapi_cmd_dwg_data.h:761
svxDwgLineGrpDim::sub
svxDwgLineDim sub
Linear constraint dimension.
Definition: zwapi_cmd_dwg_data.h:760
svxDwgLineGrpDim
Baseline, Continuous.
Definition: zwapi_cmd_dwg_data.h:759
svxDwgLineOffsetDim::type
evxDimLineOffset type
type of dimension default value:VX_DIM_OFFSET_LOL
Definition: zwapi_cmd_dwg_data.h:807
svxDwgLineOffsetDim::firstPnt
svxPntOnEnt firstPnt
VX_DIM_OFFSET_LOL: first line ; VX_DIM_OFFSET_LOP: first line.
Definition: zwapi_cmd_dwg_data.h:808
svxDwgLineOffsetDim::secondPnt
svxPntOnEnt secondPnt
VX_DIM_OFFSET_LOL: second line; VX_DIM_OFFSET_LOP: point.
Definition: zwapi_cmd_dwg_data.h:809
svxDwgLineOffsetDim::textPnt
svxPntOnEnt textPnt
text point: select a point to locate the dimension text
Definition: zwapi_cmd_dwg_data.h:810
svxDwgLineOffsetDim
Linear Offset.
Definition: zwapi_cmd_dwg_data.h:806
svxDwgLnrChmDimData::LineEnt
svxPntOnEnt LineEnt
ID and point data of line (the idEnt of "LineEnt" must be valid). if type = VX_LEADER_CHAMFERDIM,...
Definition: zwapi_cmd_dwg_data.h:856
svxDwgLnrChmDimData::textPnt
svxPntOnEnt textPnt
point coordinate of text placement point. When "dimType" is VX_HORZORVERT_CHAMFERDIM,...
Definition: zwapi_cmd_dwg_data.h:861
svxDwgLnrChmDimData::dimType
evxDwgLnrChmDimType dimType
type of line linear chamfer Dim
Definition: zwapi_cmd_dwg_data.h:859
svxDwgLnrChmDimData::verTextPnt
svxPntOnEnt verTextPnt
point coordinate of vertical text placement point, only required when "dimType" is VX_HORZORVERT_CHAM...
Definition: zwapi_cmd_dwg_data.h:864
svxDwgLnrChmDimData::dimTexType
evxDwgLnrChmDimTexType dimTexType
type of Text, only required when "dimType" is VX_LEADER_CHAMFERDIM
Definition: zwapi_cmd_dwg_data.h:860
svxDwgLnrChmDimData
the info of the linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:855
svxDwgOrdinateDim::reverseAxis2
int reverseAxis2
reverse direction, default value:0
Definition: zwapi_cmd_dwg_data.h:775
svxDwgOrdinateDim::textPnt
svxPntOnEnt textPnt[2]
Horizontal(textPnt[0]) and Vertical(textPnt[1]) text point, used only for sub.cons....
Definition: zwapi_cmd_dwg_data.h:777
svxDwgOrdinateDim::reverseAxis1
int reverseAxis1
reverse direction, default value:0
Definition: zwapi_cmd_dwg_data.h:774
svxDwgOrdinateDim::Points
svxPntOnEnt * Points
list of "cntCrv" Points
Definition: zwapi_cmd_dwg_data.h:773
svxDwgOrdinateDim::cntCrv
int cntCrv
no. of Points data items
Definition: zwapi_cmd_dwg_data.h:772
svxDwgOrdinateDim::idEnt
int idEnt
Share origin (Group dimension), 0 to ignore.
Definition: zwapi_cmd_dwg_data.h:776
svxDwgOrdinateDim::sub
svxDwgLineDim sub
Linear constraint dimension, 6 type of line dimension.
Definition: zwapi_cmd_dwg_data.h:771
svxDwgOrdinateDim
Ordinate.
Definition: zwapi_cmd_dwg_data.h:770
svxDwgRotView::axis
evxAxisType axis
type of Axis, default value:VX_AXIS_Z
Definition: zwapi_cmd_dwg_data.h:617
svxDwgRotView::idView
int idView
id of View
Definition: zwapi_cmd_dwg_data.h:615
svxDwgRotView::view
evxRotViewType view
type of View (default value:VX_ROTVIEW_TOP): to set the view projection direction
Definition: zwapi_cmd_dwg_data.h:616
svxDwgRotView::angle
double angle
rotate angle default value:0
Definition: zwapi_cmd_dwg_data.h:618
svxDwgRotView
Rotate View.
Definition: zwapi_cmd_dwg_data.h:614
svxDwgStkBlnData::entCnt
int entCnt
count of input entity corresponding to pIndexEntityList
Definition: zwapi_cmd_dwg_data.h:1195
svxDwgStkBlnData::autoSort
char autoSort
flag of auto sort (0-no, else yes. Note:0 as default) if set to non-zero, the balloons can be stacked...
Definition: zwapi_cmd_dwg_data.h:1199
svxDwgStkBlnData::idBlnDim
int idBlnDim
index of main balloon. It must be index of V_DM_BALL(not stack balloon)
Definition: zwapi_cmd_dwg_data.h:1194
svxDwgStkBlnData::pEntIdList
int * pEntIdList
input entity index list. Index must be VV3REF/VNCURV/VICURV/ VLINE2/VCIRCLE2/VARC2/V_DM_BALL(not stac...
Definition: zwapi_cmd_dwg_data.h:1196
svxDwgStkBlnData::stkBlnPtn
evxDwgStkBlnPtn stkBlnPtn
pattern of stack balloons
Definition: zwapi_cmd_dwg_data.h:1198
svxDwgStkBlnData
information of creating stack balloons
Definition: zwapi_cmd_dwg_data.h:1193
svxDwgSymmetryDimData::Pnt
svxPntOnEnt Pnt
point coordinate of point on entity, just for type = 0
Definition: zwapi_cmd_dwg_data.h:820
svxDwgSymmetryDimData::type
evxSymmetryDimType type
Symmetry dimension type.
Definition: zwapi_cmd_dwg_data.h:819
svxDwgSymmetryDimData::LinePnt
svxPntOnEnt LinePnt
line point coordinates, just for type = 1
Definition: zwapi_cmd_dwg_data.h:821
svxDwgSymmetryDimData::autoSwitchAttr
int autoSwitchAttr
1 is auto switch dimension attributes. else 0. This parameter can only be used in the sketch environm...
Definition: zwapi_cmd_dwg_data.h:824
svxDwgSymmetryDimData::txtPnt
svxPntOnEnt txtPnt
text point
Definition: zwapi_cmd_dwg_data.h:823
svxDwgSymmetryDimData::CenterLinePnt
svxPntOnEnt CenterLinePnt
Center Line point coordinates.
Definition: zwapi_cmd_dwg_data.h:822
svxDwgSymmetryDimData
Symmetry dimension data.
Definition: zwapi_cmd_dwg_data.h:818
svxDwgTblInsert::origin
evxOriginType origin
Origin, default value:VX_TOP_LEFT.
Definition: zwapi_cmd_dwg_data.h:581
svxDwgTblInsert::crtpnt
svxPoint2 crtpnt
Point.
Definition: zwapi_cmd_dwg_data.h:580
svxDwgTblInsert::idTable
int idTable
insert table id
Definition: zwapi_cmd_dwg_data.h:579
svxDwgTblInsert
insert Table
Definition: zwapi_cmd_dwg_data.h:578
svxFulSecViewData::pPnts
svxPoint2 * pPnts
points to define section
Definition: zwapi_cmd_dwg_data.h:365
svxFulSecViewData::idView
int idView
the id of base view to section
Definition: zwapi_cmd_dwg_data.h:362
svxFulSecViewData::iCnt
int iCnt
the count of the points
Definition: zwapi_cmd_dwg_data.h:364
svxFulSecViewData::secMtd
svxViewSecMtd secMtd
section method
Definition: zwapi_cmd_dwg_data.h:368
svxFulSecViewData::secLine
svxViewSecLine secLine
section line
Definition: zwapi_cmd_dwg_data.h:369
svxFulSecViewData::locPnt
svxPoint2 locPnt
the location for section view
Definition: zwapi_cmd_dwg_data.h:367
svxFulSecViewData::secOp
svxViewSecOp secOp
section option
Definition: zwapi_cmd_dwg_data.h:370
svxFulSecViewData
full section view data
Definition: zwapi_cmd_dwg_data.h:361
svxHatchAttr::space
double space
spacing attribute default: 3.175
Definition: zwapi_cmd_dwg_data.h:1618
svxHatchAttr::type
evxHatchType type
hatch type default: VX_HATCH_STANDARD
Definition: zwapi_cmd_dwg_data.h:1612
svxHatchAttr::color
evxColor color
color attribute default: VX_COLOR_BLACK
Definition: zwapi_cmd_dwg_data.h:1622
svxHatchAttr::width
evxLineWidth width
line width default: VX_WIDTH_018
Definition: zwapi_cmd_dwg_data.h:1624
svxHatchAttr::angle
double angle
angle attribute default: 0.0
Definition: zwapi_cmd_dwg_data.h:1616
svxHatchAttr::pattern
evxHatchPtnType pattern
hatch pattern method default: VX_HATCH_PATTERN_ANSI31
Definition: zwapi_cmd_dwg_data.h:1614
svxHatchAttr::origin
svxPoint2 origin
origin point default: {0.0,0.0}
Definition: zwapi_cmd_dwg_data.h:1620
svxHatchAttr
hatch attributes
Definition: zwapi_cmd_dwg_data.h:1611
svxLabelCoorDimData::orgPnt
svxPntOnEnt orgPnt
origin point of label coordinate dimension
Definition: zwapi_cmd_dwg_data.h:1013
svxLabelCoorDimData::cntPnt
int cntPnt
count of the point need to give the coordinates
Definition: zwapi_cmd_dwg_data.h:1015
svxLabelCoorDimData::pPnts
svxPntOnEnt * pPnts
point to the coordinate point of dimension(length of list must equal to cntPnt)
Definition: zwapi_cmd_dwg_data.h:1016
svxLabelCoorDimData::type
char type
label coordinate type
Definition: zwapi_cmd_dwg_data.h:1010
svxLabelCoorDimData::pTxtPnts
svxPntOnEnt * pTxtPnts
point to the text point of dimension if needs customization, the length of list must equal to cntPnt,...
Definition: zwapi_cmd_dwg_data.h:1017
svxLabelCoorDimData::text
char * text
text(NULL or empty to be formatted as <C_X>,<C_Y>,<C_Z>, you can also custom text)
Definition: zwapi_cmd_dwg_data.h:1021
svxLabelCoorDimData
label coordinate dim data
Definition: zwapi_cmd_dwg_data.h:1009
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxPrjSetting::prjType
evxViewPrjAngType prjType
Projection or Auxiliary view's projection angle (VX_VIEW_PRJANG3RD as default)
Definition: zwapi_cmd_dwg_data.h:246
svxPrjSetting::dimType
evxViewDimType dimType
Projection or Auxiliary view's dimension type (VX_VIEW_DIMTYPEPRJ as default)
Definition: zwapi_cmd_dwg_data.h:247
svxPrjSetting
Projection or Auxiliary view's projection settings.
Definition: zwapi_cmd_dwg_data.h:245
svxRadDimData::brkPnt
svxPntOnEnt brkPnt
break point. if type = VX_RAD_BROKEN, the line through arcPnt and the arc center will be cut at the i...
Definition: zwapi_cmd_dwg_data.h:943
svxRadDimData::type
evxRadDimType type
radial or diametric type
Definition: zwapi_cmd_dwg_data.h:938
svxRadDimData::txtPnt
svxPntOnEnt txtPnt
text point: specify the location the dimension text
Definition: zwapi_cmd_dwg_data.h:948
svxRadDimData::arcPnt
svxPntOnEnt arcPnt
point coordinate of point on entity (entPnt will be projected to the entity if entPnt is not on entit...
Definition: zwapi_cmd_dwg_data.h:940
svxRadDimData
radial or diametric dim data
Definition: zwapi_cmd_dwg_data.h:937
svxRefEntData
reference entity data.
Definition: zwapi_dwg_data.h:79
svxSymImg::width
double width
width
Definition: zwapi_cmd_dwg_data.h:1513
svxSymImg::height
double height
height
Definition: zwapi_cmd_dwg_data.h:1514
svxSymImg::pts
svxPoint2 pts[2]
2 input points depend on "type"
Definition: zwapi_cmd_dwg_data.h:1512
svxSymImg::flip
int flip
flip flag (0-none, 1-with, 2-with y )
Definition: zwapi_cmd_dwg_data.h:1517
svxSymImg::firstPtType
int firstPtType
type of 1st input point (0 corner, 1 center)
Definition: zwapi_cmd_dwg_data.h:1511
svxSymImg::opaque
double opaque
opaque factor
Definition: zwapi_cmd_dwg_data.h:1516
svxSymImg::angle
double angle
rotation angle(degree)
Definition: zwapi_cmd_dwg_data.h:1515
svxSymImg::locked
int locked
1-lock aspect ratio,0 not
Definition: zwapi_cmd_dwg_data.h:1518
svxSymImg::path
vxPath path
image path or user define string
Definition: zwapi_cmd_dwg_data.h:1510
svxSymImg
image data
Definition: zwapi_cmd_dwg_data.h:1508
svxSymSurf::R
char R[65]
Rz, roughness value (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1494
svxSymSurf::leadPoint
svxPoint2 leadPoint
coordinate of the leader point, only used when useleadPnt = 1
Definition: zwapi_cmd_dwg_data.h:1500
svxSymSurf::maxR
char maxR[65]
max roughness average (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1489
svxSymSurf::prepFlag
int prepFlag
perpendicular flag (0-no, 1-perpendicular, 2-reverse)
Definition: zwapi_cmd_dwg_data.h:1497
svxSymSurf::procMeth
char procMeth[65]
processing method/treatment (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1491
svxSymSurf::otherR
char otherR[65]
other roughness value/spacing (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1495
svxSymSurf::useLeadPnt
int useLeadPnt
whether to use leader point
Definition: zwapi_cmd_dwg_data.h:1499
svxSymSurf::symTyp
evxSymSurf symTyp
symbol type
Definition: zwapi_cmd_dwg_data.h:1486
svxSymSurf::minR
char minR[65]
min roughness average (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1490
svxSymSurf::grinding
int grinding
grinding
Definition: zwapi_cmd_dwg_data.h:1488
svxSymSurf::rotation
double rotation
rotation angle(degree), only used when prepFlag = 0
Definition: zwapi_cmd_dwg_data.h:1498
svxSymSurf::lay
evxSurfPtnSym lay
surface pattern symbol
Definition: zwapi_cmd_dwg_data.h:1487
svxSymSurf::sampR
char sampR[65]
sampling length/roughness cutout (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1492
svxSymSurf::machAllow
char machAllow[65]
machining allowance (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1493
svxSymSurf::optStr
char optStr[65]
third row optional string (or =NULL)
Definition: zwapi_cmd_dwg_data.h:1496
svxSymSurf
surface finish data
Definition: zwapi_cmd_dwg_data.h:1485
svxSymWeld::locPoint
svxPoint2 locPoint
the coordinate of location point
Definition: zwapi_cmd_dwg_data.h:1440
svxSymWeld::tail
int tail
tail (0 ~ 2)
Definition: zwapi_cmd_dwg_data.h:1417
svxSymWeld::weldSymDwn
int weldSymDwn
weld symbol (arrow side) (1 ~ 35)
Definition: zwapi_cmd_dwg_data.h:1418
svxSymWeld::tailRef
char tailRef[65]
tail reference
Definition: zwapi_cmd_dwg_data.h:1429
svxSymWeld::weldRoot
char weldRoot[33]
root opening/depth of filling/number of weld
Definition: zwapi_cmd_dwg_data.h:1435
svxSymWeld::stagger
int stagger
stagger (0: suppress; 1: enable)
Definition: zwapi_cmd_dwg_data.h:1412
svxSymWeld::lineFlg
int lineFlg
line flag 0:plain, 1:below, 2:above
Definition: zwapi_cmd_dwg_data.h:1411
svxSymWeld::numJogs
int numJogs
number of jog points
Definition: zwapi_cmd_dwg_data.h:1441
svxSymWeld::leaderPoints
svxPoint2 * leaderPoints
list of coordinate of leader points
Definition: zwapi_cmd_dwg_data.h:1444
svxSymWeld::weldOtherRoot
char weldOtherRoot[33]
root opening/depth of filling/number of weld (other side)
Definition: zwapi_cmd_dwg_data.h:1437
svxSymWeld::gapSpacing
double gapSpacing
ratio for symbol gap
Definition: zwapi_cmd_dwg_data.h:1438
svxSymWeld::grooveAngDwn
char grooveAngDwn[33]
groove angle (other side)
Definition: zwapi_cmd_dwg_data.h:1436
svxSymWeld::finishSymDwn
evxWeldFinishSym finishSymDwn
finish symbol (arrow side)
Definition: zwapi_cmd_dwg_data.h:1421
svxSymWeld::filleSecSzUp
char filleSecSzUp[33]
2nd fillet size (other side)
Definition: zwapi_cmd_dwg_data.h:1424
svxSymWeld::numLeaders
int numLeaders
number of leader points
Definition: zwapi_cmd_dwg_data.h:1443
svxSymWeld::filletSecUp
int filletSecUp
2nd fillet (other side) (0: suppress; 1: enable)
Definition: zwapi_cmd_dwg_data.h:1413
svxSymWeld::weldLenPitchUp
char weldLenPitchUp[33]
length and pitch of weld
Definition: zwapi_cmd_dwg_data.h:1428
svxSymWeld::useLocPoint
int useLocPoint
whether to use location point setting, 0 to use default point
Definition: zwapi_cmd_dwg_data.h:1439
svxSymWeld::filletSecDwn
int filletSecDwn
2nd fillet (arrow side) (0: suppress; 1: enable)
Definition: zwapi_cmd_dwg_data.h:1419
svxSymWeld::aroundCir
int aroundCir
all round circle (0 ~ 2)
Definition: zwapi_cmd_dwg_data.h:1416
svxSymWeld::inWeldTbl
int inWeldTbl
include in weld table flag
Definition: zwapi_cmd_dwg_data.h:1422
svxSymWeld::filletSecSzDwn
char filletSecSzDwn[33]
2nd fillet size (arrow side)
Definition: zwapi_cmd_dwg_data.h:1433
svxSymWeld::weldLenPitchDwn
char weldLenPitchDwn[33]
length and pitch of weld
Definition: zwapi_cmd_dwg_data.h:1432
svxSymWeld::fieldFlg
int fieldFlg
field flag (0: suppress; 1: enable)
Definition: zwapi_cmd_dwg_data.h:1415
svxSymWeld::depthPrepDwn
char depthPrepDwn[33]
depth of preparation, size or strength, effective throat, or groove weld size
Definition: zwapi_cmd_dwg_data.h:1430
svxSymWeld::depthPrepUp
char depthPrepUp[33]
depth of preparation, size or strength, effective throat, or groove weld size
Definition: zwapi_cmd_dwg_data.h:1426
svxSymWeld::finishSymUp
evxWeldFinishSym finishSymUp
finish symbol (other side)
Definition: zwapi_cmd_dwg_data.h:1409
svxSymWeld::contourSymDwn
evxWeldContourSym contourSymDwn
contour symbol (arrow side)
Definition: zwapi_cmd_dwg_data.h:1420
svxSymWeld::contourSymUp
evxWeldContourSym contourSymUp
contour symbol (other side)
Definition: zwapi_cmd_dwg_data.h:1410
svxSymWeld::weldSymUp
int weldSymUp
weld symbol (other side) (1 ~ 35)
Definition: zwapi_cmd_dwg_data.h:1414
svxSymWeld::filletSecLenDwn
char filletSecLenDwn[33]
2nd fillet length (arrow side)
Definition: zwapi_cmd_dwg_data.h:1434
svxSymWeld::jogPoints
svxPoint2 * jogPoints
list of coordinate of jog points
Definition: zwapi_cmd_dwg_data.h:1442
svxSymWeld::filletSecLenUp
char filletSecLenUp[33]
2nd fillet length (other side)
Definition: zwapi_cmd_dwg_data.h:1425
svxSymWeld::GrooveAngUp
char GrooveAngUp[33]
groove angle (arrow side)
Definition: zwapi_cmd_dwg_data.h:1423
svxSymWeld
Weld data.
Definition: zwapi_cmd_dwg_data.h:1408
svxViewArrow::endPnt
svxPoint2 endPnt
arrow end location
Definition: zwapi_cmd_dwg_data.h:261
svxViewArrow::startPnt
svxPoint2 startPnt
arrow start location
Definition: zwapi_cmd_dwg_data.h:260
svxViewArrow::offset
double offset
view line offset distance (20.0 as default)
Definition: zwapi_cmd_dwg_data.h:256
svxViewArrow::iFlag
int iFlag
iFlag = 0, startPnt and entPnt will use default value (user input is invalid) iFlag > 0,...
Definition: zwapi_cmd_dwg_data.h:258
svxViewArrow
view projection arrow
Definition: zwapi_cmd_dwg_data.h:255
svxViewAt::fBeads
char fBeads
show weld beads from part (1) or not(0)
Definition: zwapi_cmd_dwg_data.h:95
svxViewAt::fShwScl
char fShwScl
show scale (1) or not(0)
Definition: zwapi_cmd_dwg_data.h:84
svxViewAt::fBendLin
char fBendLin
show bend lines from sheet metal on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:91
svxViewAt::fNoRegen
char fNoRegen
do not Regen View on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:93
svxViewAt::fThread
char fThread
show threads on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:89
svxViewAt::fShwLbl
char fShwLbl
show label (1) or not(0)
Definition: zwapi_cmd_dwg_data.h:83
svxViewAt::dScale
double dScale
decimal display scale
Definition: zwapi_cmd_dwg_data.h:106
svxViewAt::dSclRatioX
double dSclRatioX
Scale ratio value X.
Definition: zwapi_cmd_dwg_data.h:104
svxViewAt::fHiddenLin
char fHiddenLin
show hidden lines on(1)/off(0)
Definition: zwapi_cmd_dwg_data.h:98
svxViewAt::fShwPmi
char fShwPmi
show PMI entities inherited from part (1/2) or not(0)
Definition: zwapi_cmd_dwg_data.h:85
svxViewAt::zWireAt
svxWireAt zWireAt
Attributes for wireframe.
Definition: zwapi_cmd_dwg_data.h:78
svxViewAt::dSclRatioY
double dSclRatioY
Scale ratio value Y.
Definition: zwapi_cmd_dwg_data.h:105
svxViewAt::fDupFlt
char fDupFlt
remove duplicated curves on(1)/off(0)
Definition: zwapi_cmd_dwg_data.h:81
svxViewAt::fShw3DOrig
char fShw3DOrig
show 3D zero point (1) or not (0)
Definition: zwapi_cmd_dwg_data.h:97
svxViewAt::fNoProp
char fNoProp
hidden line check for intersecting shapes off (1)/on(0)
Definition: zwapi_cmd_dwg_data.h:88
svxViewAt::fWirefrm
char fWirefrm
show 3D curves from part on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:92
svxViewAt::fHLROn
char fHLROn
display mode (0 ~ 3)
Definition: zwapi_cmd_dwg_data.h:79
svxViewAt::fExplod
char fExplod
Explode mode (1) or not(0)
Definition: zwapi_cmd_dwg_data.h:87
svxViewAt::fShwDim
char fShwDim
show dimensions from part (1) or not(0)
Definition: zwapi_cmd_dwg_data.h:82
svxViewAt::label
vxName label
view label
Definition: zwapi_cmd_dwg_data.h:99
svxViewAt::fCentLin
char fCentLin
show center lines on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:90
svxViewAt::fScaleType
char fScaleType
scale type 0 view scale explicitly assigned to view by user 1 view scale comes from sheet prefere...
Definition: zwapi_cmd_dwg_data.h:100
svxViewAt::fAnno
char fAnno
show texts from part on (1)/off(0)
Definition: zwapi_cmd_dwg_data.h:94
svxViewAt::zLnAt
svxWireAt zLnAt[18]
view line type (see evxViewLineAttrIdx) display attributes
Definition: zwapi_cmd_dwg_data.h:96
svxViewAt::fBiarc
char fBiarc
convert curves to arc on(1)/off(0)
Definition: zwapi_cmd_dwg_data.h:80
svxViewAt
View layout display attributes.
Definition: zwapi_cmd_dwg_data.h:77
svxViewLayoutData::location
svxViewLocationData location
location of the views
Definition: zwapi_cmd_dwg_data.h:117
svxViewLayoutData::ExplodedView
int ExplodedView
exploded view ,default:0
Definition: zwapi_cmd_dwg_data.h:126
svxViewLayoutData::isIgnoreLoc
int isIgnoreLoc
1 if ignore location and use default,else 0
Definition: zwapi_cmd_dwg_data.h:118
svxViewLayoutData::root
vxRootName root
root name.(This parameter is required only when the z3 file is passed in.)
Definition: zwapi_cmd_dwg_data.h:116
svxViewLayoutData::blankRefEntsData
svxRefEntData * blankRefEntsData
list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidd...
Definition: zwapi_cmd_dwg_data.h:131
svxViewLayoutData::DimensionType
int DimensionType
0 if projected, 1 if true. default:0.
Definition: zwapi_cmd_dwg_data.h:128
svxViewLayoutData::cntBlankRefEnts
int cntBlankRefEnts
count of blankRefEntsData. 0 to ignore.
Definition: zwapi_cmd_dwg_data.h:130
svxViewLayoutData::method
svxViewLayoutMethod method
layout method
Definition: zwapi_cmd_dwg_data.h:119
svxViewLayoutData::name
vxPath name
file name of the projected part or assembly (file that is unloaded must use the full path)
Definition: zwapi_cmd_dwg_data.h:115
svxViewLayoutData::isIgnoreAttr
int isIgnoreAttr
1 if ignore viewAttr and use default,else 0
Definition: zwapi_cmd_dwg_data.h:122
svxViewLayoutData::CompConfig
vxName CompConfig
component configuration name, CompConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:125
svxViewLayoutData::coordinate
int coordinate
projection coordinate system, default:1 to use the global coordinate system
Definition: zwapi_cmd_dwg_data.h:123
svxViewLayoutData::PartConfig
vxName PartConfig
part config name ,PartConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:124
svxViewLayoutData::isIgnoreMethod
int isIgnoreMethod
1 if ignore method and use default,else 0
Definition: zwapi_cmd_dwg_data.h:120
svxViewLayoutData::isCalculate
int isCalculate
1 if calculate part center ,else 0. default:1
Definition: zwapi_cmd_dwg_data.h:129
svxViewLayoutData::state
int state
index for the backup feature, default:-1
Definition: zwapi_cmd_dwg_data.h:127
svxViewLayoutData::viewAttr
svxViewAt viewAttr
view attribute
Definition: zwapi_cmd_dwg_data.h:121
svxViewLayoutData
drawing view layout data
Definition: zwapi_cmd_dwg_data.h:114
svxViewLayoutMethod::count
int count
The number of valid values for "StdMethod" "count" has a maximum of 7 and a minimum of 1....
Definition: zwapi_cmd_dwg_data.h:63
svxViewLayoutMethod::projection
int projection
1 if the first perspective, 2 if the third perspective default:2
Definition: zwapi_cmd_dwg_data.h:60
svxViewLayoutMethod::StdMethod
evxViewStd StdMethod[7]
StdMethod[0] is base view orientations, others are projection view orientations StdMethod[0] is in ...
Definition: zwapi_cmd_dwg_data.h:66
svxViewLayoutMethod
drawing view layout method
Definition: zwapi_cmd_dwg_data.h:59
svxViewLocationData::FirstPoint
svxPoint2 FirstPoint
the first point (ignore this if type is VX_LOCATION_AUTO )
Definition: zwapi_cmd_dwg_data.h:48
svxViewLocationData::SecondPoint
svxPoint2 SecondPoint
the second point (ignore this if type is not VX_LOCATION_CORNER )
Definition: zwapi_cmd_dwg_data.h:50
svxViewLocationData::type
evxViewLocationType type
drawing view location type
Definition: zwapi_cmd_dwg_data.h:47
svxViewLocationData
drawing view location data
Definition: zwapi_cmd_dwg_data.h:46
svxViewSecLine::viewLabel
char * viewLabel
view label (example: "A" becomes "A-A") the label doesn't duplicate the existing label null or "" to ...
Definition: zwapi_cmd_dwg_data.h:338
svxViewSecLine::iShowStepLines
int iShowStepLines
show step lines or not (0 as default)
Definition: zwapi_cmd_dwg_data.h:342
svxViewSecLine::iFlipArrow
int iFlipArrow
flip arrow or not (0 as default)
Definition: zwapi_cmd_dwg_data.h:341
svxViewSecLine
section line
Definition: zwapi_cmd_dwg_data.h:337
svxViewSecMtd::iDynScalAng
int iDynScalAng
dynamic hatch scaling and angle or not (1 as default)
Definition: zwapi_cmd_dwg_data.h:320
svxViewSecMtd::locAngType
evxLocAngType locAngType
location angle type
Definition: zwapi_cmd_dwg_data.h:328
svxViewSecMtd::inheritSecBasView
int inheritSecBasView
inherit section from base view or not if base view is not section view, this value can be ignored if ...
Definition: zwapi_cmd_dwg_data.h:321
svxViewSecMtd::dLocAng
double dLocAng
location angle (only used when locAngType = VX_LOC_ANG_CUSTOM)
Definition: zwapi_cmd_dwg_data.h:329
svxViewSecMtd::mtdType
evxSecMtdType mtdType
section method (VX_METHOD_TRIMPART as default)
Definition: zwapi_cmd_dwg_data.h:318
svxViewSecMtd::dimType
evxViewDimType dimType
dimension type (VX_VIEW_DIMTYPEPRJ as default)
Definition: zwapi_cmd_dwg_data.h:325
svxViewSecMtd::iCloseOpenProf
int iCloseOpenProf
close open profiles or not (1 as default)
Definition: zwapi_cmd_dwg_data.h:319
svxViewSecMtd::locType
evxLocType locType
location type (VX_LOC_ORTHOGONAL as default)
Definition: zwapi_cmd_dwg_data.h:324
svxViewSecMtd::dSecDepth
double dSecDepth
section depth (if mtdType = VX_METHOD_SECCURVE, this can be ignored.) this parameter would be ignored...
Definition: zwapi_cmd_dwg_data.h:326
svxViewSecMtd
section method
Definition: zwapi_cmd_dwg_data.h:317
svxViewSecOp::iSecState
int iSecState
component section state from part
Definition: zwapi_cmd_dwg_data.h:351
svxViewSecOp::iHatchClr
int iHatchClr
hatch color from part
Definition: zwapi_cmd_dwg_data.h:353
svxViewSecOp::iHatchState
int iHatchState
component hatch state from part
Definition: zwapi_cmd_dwg_data.h:352
svxViewSecOp
section option
Definition: zwapi_cmd_dwg_data.h:350
svxViewStandardData::isDispTrails
int isDispTrails
1 if display exploded trails ,else 0.default:0
Definition: zwapi_cmd_dwg_data.h:210
svxViewStandardData::compConfig
vxName compConfig
component configuration name, CompConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:208
svxViewStandardData::origin
int origin
Origin ,default:1.
Definition: zwapi_cmd_dwg_data.h:205
svxViewStandardData::fileName
vxLongPath fileName
file name (including the extension)
Definition: zwapi_cmd_dwg_data.h:191
svxViewStandardData::state
int state
index for the backup feature, default:1
Definition: zwapi_cmd_dwg_data.h:211
svxViewStandardData::rootName
vxRootName rootName
root name
Definition: zwapi_cmd_dwg_data.h:192
svxViewStandardData::coordinate
int coordinate
coordinate,default:1
Definition: zwapi_cmd_dwg_data.h:206
svxViewStandardData::location
svxPoint2 location
location
Definition: zwapi_cmd_dwg_data.h:202
svxViewStandardData::blankRefEntsData
svxRefEntData * blankRefEntsData
list of reference entity data.cntBlankRefEnts=0 to ignore it. This variable represents an entity hidd...
Definition: zwapi_cmd_dwg_data.h:216
svxViewStandardData::explodedView
int explodedView
exploded view ,default:0
Definition: zwapi_cmd_dwg_data.h:209
svxViewStandardData::type
int type
1 is use view manager custom view name(this manager in part environment), 2 is use flattening feature...
Definition: zwapi_cmd_dwg_data.h:193
svxViewStandardData::dimensionType
int dimensionType
0 if projected, 1 if true. default:0.
Definition: zwapi_cmd_dwg_data.h:212
svxViewStandardData::viewAttr
svxViewAt viewAttr
view attribute
Definition: zwapi_cmd_dwg_data.h:204
svxViewStandardData::cntBlankRefEnts
int cntBlankRefEnts
count of blankRefEntsData. 0 to ignore.
Definition: zwapi_cmd_dwg_data.h:215
svxViewStandardData::isOrientation
int isOrientation
1 if view orientation from parent, else 0. default:1
Definition: zwapi_cmd_dwg_data.h:214
svxViewStandardData::path
vxLongPath path
file path
Definition: zwapi_cmd_dwg_data.h:190
svxViewStandardData::partConfig
vxName partConfig
part config name ,PartConfig[0]=0 to ignore
Definition: zwapi_cmd_dwg_data.h:207
svxViewStandardData::isIgnoreAttr
int isIgnoreAttr
1 if ignore viewAttr and use default,else 0
Definition: zwapi_cmd_dwg_data.h:203
svxViewStandardData::isCalculate
int isCalculate
1 if calculate part center ,else 0. default:1
Definition: zwapi_cmd_dwg_data.h:213
svxViewStandardData
drawing view standard data
Definition: zwapi_cmd_dwg_data.h:189
svxWireAt
wire display attributes
Definition: zwapi_util.h:1188
svxViewStandardData::uvxViewTypeData::viewName
vxName viewName
view Name. if type = 1,apply it.
Definition: zwapi_cmd_dwg_data.h:198
svxViewStandardData::uvxViewTypeData::flatName
vxName flatName
flatten Name. if type = 2, apply it.
Definition: zwapi_cmd_dwg_data.h:199
svxViewStandardData::uvxViewTypeData::viewType
evxViewTypeEx viewType
View type(1-7,28-34,39). if type = 0,apply it.
Definition: zwapi_cmd_dwg_data.h:200
svxViewStandardData::uvxViewTypeData
union of view type data
Definition: zwapi_cmd_dwg_data.h:197
zwapi_cmd_sk_create_data.h
zwapi_dwg_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DIMENSION_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dwg_dimension.h
cvxDwgAngDimAdd
cvxDwgArcDimAdd
cvxDwgAutoBlnAdd
cvxDwgAutoBlnAddInit
cvxDwgAutoDimAdd
cvxDwgAutoDimAddInit
cvxDwgBalloonDimAdd
cvxDwgBaseLineDimAdd
cvxDwgCenMarkCirDimAdd
cvxDwgCenMarkCirDimAddInit
cvxDwgCenterLineDimAdd
cvxDwgCenterLineDimAddInit
cvxDwgCenterMarkDimAdd
cvxDwgCenterMarkDimAddInit
cvxDwgContinuousDimAdd
cvxDwgDatumDimAdd
cvxDwgDatumTargDimAdd
cvxDwgDatumTargDimAddInit
cvxDwgFtrCtrlDimAdd
cvxDwgHoleCallOutDimAdd
cvxDwgHoleCallOutDimAddinit
cvxDwgHoleMark
cvxDwgHoleMarkInit
cvxDwgInsertSymbol
cvxDwgIsectSym
cvxDwgLabelCoorDimAdd
cvxDwgLabelDimAdd
cvxDwgLineDimAdd
cvxDwgLineOffsetDimAdd
cvxDwgLnrChmDimAdd
cvxDwgLnrChmDimAddInit
cvxDwgOrdinateDimAdd
cvxDwgRadDimAdd
cvxDwgStkBlnAdd
cvxDwgStkBlnAddInit
cvxDwgSymImgNew
cvxDwgSymImgNewInit
cvxDwgSymmetryDimAdd
cvxDwgSymSurfNew
cvxDwgSymSurfNewInit
cvxDwgSymWeldNew
cvxDwgSymWeldNewInit
cvxDwgUserSymNew

◆ ZW_API_DIMENSION_H

#define ZW_API_DIMENSION_H

Definition at line 15 of file zwapi_cmd_dwg_dimension.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_dimension.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dwg_dimension.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DIMENSION_H /* this ifndef surrounds entire header */
15#define ZW_API_DIMENSION_H
16
17#include "zwapi_cmd_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
48extern evxErrors cvxDwgAutoDimAdd(const svxDimAuto* pDimData, int* idDim);
49
50/******************************************************************************/
67extern evxErrors cvxDwgAutoDimAddInit(svxDimAuto* data);
68
69/******************************************************************************/
95extern evxErrors cvxDwgLineDimAdd(const svxDwgLineDim* pData, int* idDim);
96
97/******************************************************************************/
123extern evxErrors cvxDwgBaseLineDimAdd(const svxDwgLineGrpDim* pData, int* idDim);
124
125/******************************************************************************/
151extern evxErrors cvxDwgContinuousDimAdd(const svxDwgLineGrpDim* pData, int* idDim);
152
153/******************************************************************************/
180extern evxErrors cvxDwgOrdinateDimAdd(const svxDwgOrdinateDim* pData, int* idDim);
181
182/******************************************************************************/
206extern evxErrors cvxDwgLineOffsetDimAdd(const svxDwgLineOffsetDim* pData, int* idDim);
207
208/******************************************************************************/
227extern evxErrors cvxDwgSymmetryDimAdd(const svxDwgSymmetryDimData* symmetryDimData, int* idDim);
228
229/******************************************************************************/
246extern evxErrors cvxDwgLnrChmDimAddInit(svxDwgLnrChmDimData* data);
247
248/******************************************************************************/
271extern evxErrors cvxDwgLnrChmDimAdd(const svxDwgLnrChmDimData* DimData, int* idDim);
272
273/******************************************************************************/
292extern evxErrors cvxDwgAngDimAdd(const svxDwgAngDimData* angDimData, int* idDim);
293
294/******************************************************************************/
313extern evxErrors cvxDwgRadDimAdd(const svxRadDimData* radDimData, int* idDim);
314
315/******************************************************************************/
334extern evxErrors cvxDwgArcDimAdd(const svxDwgArcDimData* arcDimData, int* idDim);
335
336/******************************************************************************/
353extern evxErrors cvxDwgHoleCallOutDimAddinit(svxDwgHoleCallOutDim* data);
354
355/******************************************************************************/
380extern evxErrors cvxDwgHoleCallOutDimAdd(const svxDwgHoleCallOutDim* pData, int* numDim, int** idDims);
381
382
383//====================================================================================================================
385//====================================================================================================================
386/******************************************************************************/
405extern evxErrors cvxDwgLabelCoorDimAdd(const svxLabelCoorDimData* coorDimData, int* idDim);
406
407/******************************************************************************/
426extern evxErrors cvxDwgLabelDimAdd(const svxDimLabel* pLabel, int* idDim);
427
428/******************************************************************************/
448extern evxErrors cvxDwgBalloonDimAdd(const svxDwgBalloonDim* pData, int* idDim);
449
450/******************************************************************************/
467extern evxErrors cvxDwgAutoBlnAddInit(svxDwgAtBlnData* data);
468
469/******************************************************************************/
493extern evxErrors cvxDwgAutoBlnAdd(const svxDwgAtBlnData* atBlnData, int* idDimCount, int** idDimList);
494
495/******************************************************************************/
512extern evxErrors cvxDwgStkBlnAddInit(svxDwgStkBlnData* data);
513
514/******************************************************************************/
539extern evxErrors cvxDwgStkBlnAdd(const svxDwgStkBlnData* stkBlnData, int* idDimCount, int** idDimList);
540
541/******************************************************************************/
560extern evxErrors cvxDwgFtrCtrlDimAdd(const svxDwgFtrCtrl* pData, int* idDim);
561
562/******************************************************************************/
581extern evxErrors cvxDwgDatumDimAdd(const svxDatumDimData* datumData, int* idDim);
582
583/******************************************************************************/
600extern evxErrors cvxDwgDatumTargDimAddInit(svxDatumTargDimData* data);
601
602/******************************************************************************/
625extern evxErrors cvxDwgDatumTargDimAdd(const svxDatumTargDimData* datumTData, int* idDim);
626
627//====================================================================================================================
629//====================================================================================================================
630/******************************************************************************/
647extern evxErrors cvxDwgCenterMarkDimAddInit(svxCenterMark* data);
648
649/******************************************************************************/
680extern evxErrors cvxDwgCenterMarkDimAdd(const svxCenterMark* pzCenterMark, int* idDim);
681
682/******************************************************************************/
699extern evxErrors cvxDwgCenMarkCirDimAddInit(svxCenMarkCirDimData* data);
700
701/******************************************************************************/
723extern evxErrors cvxDwgCenMarkCirDimAdd(const svxCenMarkCirDimData* cmcDimData, int* idDim);
724
725/******************************************************************************/
742extern evxErrors cvxDwgCenterLineDimAddInit(svxCenterLine* data);
743
744/******************************************************************************/
777extern evxErrors cvxDwgCenterLineDimAdd(const svxCenterLine* pzCenterLine, int* idDim);
778
779/******************************************************************************/
804extern evxErrors cvxDwgSymWeldNew(int idEnt, svxPoint2* refPoint, const svxSymWeld* data, int* idSymWeld);
805
806/******************************************************************************/
824extern evxErrors cvxDwgSymWeldNewInit(svxSymWeld* data);
825
826/******************************************************************************/
844extern evxErrors cvxDwgSymSurfNewInit(svxSymSurf* data);
845
846/******************************************************************************/
871extern evxErrors cvxDwgSymSurfNew(int idEnt, svxPoint2* refPoint, const svxSymSurf* data, int* idSymSurf);
872
873/******************************************************************************/
903extern evxErrors cvxDwgSymImgNew(svxSymImg* data, int embed, int locked, int* idSymImg);
904
905/******************************************************************************/
922extern evxErrors cvxDwgSymImgNewInit(svxSymImg* data);
923
924/******************************************************************************/
947extern evxErrors cvxDwgInsertSymbol(const vxLongPath fileName,const vxLongName symName, svxPoint2* pnt, int* symId);
948
949/******************************************************************************/
978extern evxErrors cvxDwgUserSymNew(int count, int* idEnt, svxPoint2* BasePnt, const vxRootName Name, int* idBlock);
979
980/******************************************************************************/
999extern evxErrors cvxDwgIsectSym(const svxDwgIsectSym* data, int* idSym);
1000
1001/******************************************************************************/
1019extern evxErrors cvxDwgHoleMarkInit(evxDwgHoleMarkType type, svxDwgHoleMark* data);
1020
1021/******************************************************************************/
1043extern evxErrors cvxDwgHoleMark(const svxDwgHoleMark* data);
1044
1045/*
1046*********************************************************************
1047** END HEADER FILE
1048*********************************************************************
1049*/
1050
1051#ifdef __cplusplus
1052 }
1053#endif /* __cplusplus */
1054
1055#endif /* ZW_API_DIMENSION_H */
evxDwgHoleMarkType
evxDwgHoleMarkType
drawing sheet hole mark method
Definition: zwapi_cmd_dwg_data.h:1537
cvxDwgIsectSym
evxErrors cvxDwgIsectSym(const svxDwgIsectSym *data, int *idSym)
cvxDwgCenterLineDimAddInit
evxErrors cvxDwgCenterLineDimAddInit(svxCenterLine *data)
cvxDwgCenMarkCirDimAddInit
evxErrors cvxDwgCenMarkCirDimAddInit(svxCenMarkCirDimData *data)
cvxDwgContinuousDimAdd
evxErrors cvxDwgContinuousDimAdd(const svxDwgLineGrpDim *pData, int *idDim)
cvxDwgHoleCallOutDimAddinit
evxErrors cvxDwgHoleCallOutDimAddinit(svxDwgHoleCallOutDim *data)
cvxDwgUserSymNew
evxErrors cvxDwgUserSymNew(int count, int *idEnt, svxPoint2 *BasePnt, const vxRootName Name, int *idBlock)
cvxDwgSymSurfNewInit
evxErrors cvxDwgSymSurfNewInit(svxSymSurf *data)
cvxDwgRadDimAdd
evxErrors cvxDwgRadDimAdd(const svxRadDimData *radDimData, int *idDim)
cvxDwgSymImgNewInit
evxErrors cvxDwgSymImgNewInit(svxSymImg *data)
cvxDwgStkBlnAddInit
evxErrors cvxDwgStkBlnAddInit(svxDwgStkBlnData *data)
cvxDwgLabelDimAdd
evxErrors cvxDwgLabelDimAdd(const svxDimLabel *pLabel, int *idDim)
cvxDwgDatumDimAdd
evxErrors cvxDwgDatumDimAdd(const svxDatumDimData *datumData, int *idDim)
cvxDwgBalloonDimAdd
evxErrors cvxDwgBalloonDimAdd(const svxDwgBalloonDim *pData, int *idDim)
cvxDwgArcDimAdd
evxErrors cvxDwgArcDimAdd(const svxDwgArcDimData *arcDimData, int *idDim)
cvxDwgAutoDimAddInit
evxErrors cvxDwgAutoDimAddInit(svxDimAuto *data)
cvxDwgCenterLineDimAdd
evxErrors cvxDwgCenterLineDimAdd(const svxCenterLine *pzCenterLine, int *idDim)
cvxDwgAngDimAdd
evxErrors cvxDwgAngDimAdd(const svxDwgAngDimData *angDimData, int *idDim)
cvxDwgOrdinateDimAdd
evxErrors cvxDwgOrdinateDimAdd(const svxDwgOrdinateDim *pData, int *idDim)
cvxDwgLineDimAdd
evxErrors cvxDwgLineDimAdd(const svxDwgLineDim *pData, int *idDim)
cvxDwgAutoDimAdd
evxErrors cvxDwgAutoDimAdd(const svxDimAuto *pDimData, int *idDim)
cvxDwgHoleCallOutDimAdd
evxErrors cvxDwgHoleCallOutDimAdd(const svxDwgHoleCallOutDim *pData, int *numDim, int **idDims)
cvxDwgHoleMarkInit
evxErrors cvxDwgHoleMarkInit(evxDwgHoleMarkType type, svxDwgHoleMark *data)
cvxDwgAutoBlnAddInit
evxErrors cvxDwgAutoBlnAddInit(svxDwgAtBlnData *data)
cvxDwgSymSurfNew
evxErrors cvxDwgSymSurfNew(int idEnt, svxPoint2 *refPoint, const svxSymSurf *data, int *idSymSurf)
cvxDwgCenterMarkDimAdd
evxErrors cvxDwgCenterMarkDimAdd(const svxCenterMark *pzCenterMark, int *idDim)
cvxDwgSymImgNew
evxErrors cvxDwgSymImgNew(svxSymImg *data, int embed, int locked, int *idSymImg)
cvxDwgSymWeldNewInit
evxErrors cvxDwgSymWeldNewInit(svxSymWeld *data)
cvxDwgDatumTargDimAdd
evxErrors cvxDwgDatumTargDimAdd(const svxDatumTargDimData *datumTData, int *idDim)
cvxDwgBaseLineDimAdd
evxErrors cvxDwgBaseLineDimAdd(const svxDwgLineGrpDim *pData, int *idDim)
cvxDwgLnrChmDimAdd
evxErrors cvxDwgLnrChmDimAdd(const svxDwgLnrChmDimData *DimData, int *idDim)
cvxDwgFtrCtrlDimAdd
evxErrors cvxDwgFtrCtrlDimAdd(const svxDwgFtrCtrl *pData, int *idDim)
cvxDwgSymmetryDimAdd
evxErrors cvxDwgSymmetryDimAdd(const svxDwgSymmetryDimData *symmetryDimData, int *idDim)
cvxDwgHoleMark
evxErrors cvxDwgHoleMark(const svxDwgHoleMark *data)
cvxDwgAutoBlnAdd
evxErrors cvxDwgAutoBlnAdd(const svxDwgAtBlnData *atBlnData, int *idDimCount, int **idDimList)
cvxDwgSymWeldNew
evxErrors cvxDwgSymWeldNew(int idEnt, svxPoint2 *refPoint, const svxSymWeld *data, int *idSymWeld)
cvxDwgLineOffsetDimAdd
evxErrors cvxDwgLineOffsetDimAdd(const svxDwgLineOffsetDim *pData, int *idDim)
cvxDwgCenMarkCirDimAdd
evxErrors cvxDwgCenMarkCirDimAdd(const svxCenMarkCirDimData *cmcDimData, int *idDim)
cvxDwgInsertSymbol
evxErrors cvxDwgInsertSymbol(const vxLongPath fileName, const vxLongName symName, svxPoint2 *pnt, int *symId)
cvxDwgStkBlnAdd
evxErrors cvxDwgStkBlnAdd(const svxDwgStkBlnData *stkBlnData, int *idDimCount, int **idDimList)
cvxDwgDatumTargDimAddInit
evxErrors cvxDwgDatumTargDimAddInit(svxDatumTargDimData *data)
cvxDwgCenterMarkDimAddInit
evxErrors cvxDwgCenterMarkDimAddInit(svxCenterMark *data)
cvxDwgLnrChmDimAddInit
evxErrors cvxDwgLnrChmDimAddInit(svxDwgLnrChmDimData *data)
cvxDwgLabelCoorDimAdd
evxErrors cvxDwgLabelCoorDimAdd(const svxLabelCoorDimData *coorDimData, int *idDim)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCenMarkCirDimData
center mark circle dim data
Definition: zwapi_cmd_dwg_data.h:1334
svxCenterLine
Center Line.
Definition: zwapi_cmd_dwg_data.h:1362
svxCenterMark
Center Mark.
Definition: zwapi_cmd_dwg_data.h:1317
svxDatumDimData
datum dim data(drawing)
Definition: zwapi_cmd_dwg_data.h:1233
svxDatumTargDimData
datum target dim data
Definition: zwapi_cmd_dwg_data.h:1262
svxDimAuto
auto dimension
Definition: zwapi_cmd_dwg_data.h:693
svxDimLabel
Label.
Definition: zwapi_cmd_dwg_data.h:1068
svxDwgAngDimData
Angular dimension dim data.
Definition: zwapi_cmd_dwg_data.h:886
svxDwgArcDimData
Arc dimension dim data.
Definition: zwapi_cmd_dwg_data.h:956
svxDwgAtBlnData
Information of creating auto balloon.
Definition: zwapi_cmd_dwg_data.h:1151
svxDwgBalloonDim
Balloon.
Definition: zwapi_cmd_dwg_data.h:1081
svxDwgFtrCtrl
Datum Control.
Definition: zwapi_cmd_dwg_data.h:1208
svxDwgHoleCallOutDim
Hole Callout.
Definition: zwapi_cmd_dwg_data.h:988
svxDwgHoleMark
drawing sheet hole mark data
Definition: zwapi_cmd_dwg_data.h:1567
svxDwgIsectSym
drawing intersection symbol data
Definition: zwapi_cmd_dwg_data.h:1526
svxDwgLineDim
Linear.
Definition: zwapi_cmd_dwg_data.h:744
svxDwgLineGrpDim
Baseline, Continuous.
Definition: zwapi_cmd_dwg_data.h:759
svxDwgLineOffsetDim
Linear Offset.
Definition: zwapi_cmd_dwg_data.h:806
svxDwgLnrChmDimData
the info of the linear chamfer dim
Definition: zwapi_cmd_dwg_data.h:855
svxDwgOrdinateDim
Ordinate.
Definition: zwapi_cmd_dwg_data.h:770
svxDwgStkBlnData
information of creating stack balloons
Definition: zwapi_cmd_dwg_data.h:1193
svxDwgSymmetryDimData
Symmetry dimension data.
Definition: zwapi_cmd_dwg_data.h:818
svxLabelCoorDimData
label coordinate dim data
Definition: zwapi_cmd_dwg_data.h:1009
svxPoint2
2D point
Definition: zwapi_util.h:286
svxRadDimData
radial or diametric dim data
Definition: zwapi_cmd_dwg_data.h:937
svxSymImg
image data
Definition: zwapi_cmd_dwg_data.h:1508
svxSymSurf
surface finish data
Definition: zwapi_cmd_dwg_data.h:1485
svxSymWeld
Weld data.
Definition: zwapi_cmd_dwg_data.h:1408
zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DRAWING_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dwg_drawing.h
cvxDwgCrossHatch
cvxDwgCrossHatchInit
cvxDwgEntMoveAlongDirection
cvxDwgEntMovePntToPnt

◆ ZW_API_DRAWING_H

#define ZW_API_DRAWING_H

Definition at line 15 of file zwapi_cmd_dwg_drawing.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_drawing.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dwg_drawing.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DRAWING_H /* this ifndef surrounds entire header */
15#define ZW_API_DRAWING_H
16
17#include "zwapi_cmd_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/**********************************************************************
27*! -Line- : zwapi_cmd_sk_cmds_data.h
28* cvxSkLine2pt(svxPoint2 *Start, svxPoint2 *End, int *idEnt);
29**********************************************************************/
30/**********************************************************************
31*! -Circle- : zwapi_cmd_sk_cmds_data.h
32* extern evxErrors cvxSkCir3pt(svxPoint2 *P1, svxPoint2 *P2, svxPoint2 *P3, int *idEnt);
33* extern evxErrors cvxSkCirRad(svxPoint2 *Center, double Radius, int *idEnt);
34**********************************************************************/
35/**********************************************************************
36*! -Arc- : zwapi_cmd_sk_cmds_data.h
37* extern evxErrors cvxSkArc3pt(svxPoint2*Start, svxPoint2*End, svxPoint2*Mid, int*idEnt);
38* extern evxErrors cvxSkArcRad(svxPoint2*Center, double R, double S, double E, int*idEnt);
39**********************************************************************/
40/**********************************************************************
41*! -Polygon- : zwapi_cmd_sk_cmds_data.h
42* extern evxErrors cvxSkAddPolyline(int cntPnt, svxPoint2* pnts, int addCns);
43* extern evxErrors cvxSkArcRad(svxPoint2*Center, double R, double S, double E, int*idEnt);
44**********************************************************************/
45/**********************************************************************
46*! -Polygon- : zwapi_cmd_sk_cmds_data.h
47* extern evxErrors cvxSkEllipseInit(svxEllipse* data);
48* extern evxErrors cvxSkEllipse(svxEllipse *ellipse, int *idEnt);
49**********************************************************************/
50/******************************************************************************/
67extern evxErrors cvxDwgCrossHatchInit(svxHatchAttr* data);
68
69/******************************************************************************/
96extern evxErrors cvxDwgCrossHatch(int countEnts, int* idEnts, int countPnts, svxPoint2* insides, int isSplit, svxHatchAttr* hatch, int* idEnt);
97
98/**********************************************************************
99*! -Text- : zwapi_cmd_sk_cmds_data.h
100* extern evxErrors cvxEntTextNew(char* String, int Type, svxPoint2 Pnt[2], int* idEnt);
101**********************************************************************/
102/**********************************************************************
103*! -Point- : zwapi_cmd_sk_cmds_data.h
104* extern evxErrors cvxSkPnt(svxPoint2 *Point, int *idEnt);
105**********************************************************************/
106/**********************************************************************
107*! -Sketch- : zwapi_sk_create.h
108* extern evxErrors cvxPartSkNew(svxMatrix* Plane, int* idEnt);
109* extern evxErrors cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
110**********************************************************************/
111
112//====================================================================================================================
114//====================================================================================================================
115/**********************************************************************
116*! -Spline- : zwapi_cmd_sk_cmds_data.h
117* extern evxErrors cvxSkSplineInit(svxSplineData* data, int count);
118* extern evxErrors cvxSkSpline(const svxSplineData* PntData, int* idEnt);
119* extern evxErrors cvxSkCrvIntInit(svxCrvIntData* data);
120* extern evxErrors cvxSkCrvInt(svxCrvIntData *Crv, int *idEnt);
121**********************************************************************/
122
123//====================================================================================================================
125//====================================================================================================================
126/**********************************************************************
127*! -Fillet- : zwapi_cmd_sk_cmds_data.h
128* extern evxErrors cvxSkFilletInit(svxSkFilletData* data);
129* extern evxErrors cvxSkFillet(const svxSkFilletData* filletData, int* idFillet);
130**********************************************************************/
131
132/**********************************************************************
133*! -Chamfer- : zwapi_cmd_sk_cmds_data.h
134* extern evxErrors cvxSkChamferInit(svxSkChamferData* data);
135* extern evxErrors cvxSkChamfer(const svxSkChamferData* chmData, int* idChamfer);
136**********************************************************************/
137
138//====================================================================================================================
140//====================================================================================================================
141/******************************************************************************/
169extern evxErrors cvxDwgEntMovePntToPnt(int idEnt, svxPoint2* Start, svxPoint2* End, evxDrawingMoveDirType type, double angle, double scale);
170
171/******************************************************************************/
198extern evxErrors cvxDwgEntMoveAlongDirection(int idEnt, svxVector2* Direction, double Distance, svxPoint2* BasePoint, double angle, double scale);
199
200
201/**********************************************************************
202*! -Move- : zwapi_cmd_sk_cmds_data.h
203* extern evxErrors cvxSkMoveInit(evxMoveType2D type, svxMoveData2D* data);
204* extern evxErrors cvxSkMove(const svxMoveData2D* data);
205**********************************************************************/
206
207/**********************************************************************
208*! -Scale- : zwapi_cmd_sk_cmds_data.h
209* extern evxErrors cvxSkScale(int Count, int* idEnts, double X, double Y, svxPoint2* Pnt);
210**********************************************************************/
211
212
213/*
214*********************************************************************
215** END HEADER FILE
216*********************************************************************
217*/
218
219#ifdef __cplusplus
220 }
221#endif /* __cplusplus */
222
223#endif /* ZW_API_DRAWING_H */
cvxDwgCrossHatch
evxErrors cvxDwgCrossHatch(int countEnts, int *idEnts, int countPnts, svxPoint2 *insides, int isSplit, svxHatchAttr *hatch, int *idEnt)
cvxDwgEntMoveAlongDirection
evxErrors cvxDwgEntMoveAlongDirection(int idEnt, svxVector2 *Direction, double Distance, svxPoint2 *BasePoint, double angle, double scale)
cvxDwgCrossHatchInit
evxErrors cvxDwgCrossHatchInit(svxHatchAttr *data)
cvxDwgEntMovePntToPnt
evxErrors cvxDwgEntMovePntToPnt(int idEnt, svxPoint2 *Start, svxPoint2 *End, evxDrawingMoveDirType type, double angle, double scale)
evxDrawingMoveDirType
evxDrawingMoveDirType
Sketch/Drawing move direction type.
Definition: zwapi_cmd_sk_cmds_data.h:644
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxHatchAttr
hatch attributes
Definition: zwapi_cmd_dwg_data.h:1611
svxPoint2
2D point
Definition: zwapi_util.h:286
svxVector2
2D vector
Definition: zwapi_util.h:328
zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_LAYOUT

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_dwg_layout.h
cvxDwgRotateView
cvxDwgRotateViewinit
cvxDwgTableBom
cvxDwgTableBomInit
cvxDwgTableInsert
cvxDwgUserTableCreate
cvxDwgUserTableCreateByTemplate
cvxDwgViewAlignedSection
cvxDwgViewAlignedSectionInit
cvxDwgViewAuxiliary
cvxDwgViewAuxiliaryInit
cvxDwgViewBrkLine
cvxDwgViewBrkLineInit
cvxDwgViewBrokenSection
cvxDwgViewBrokenSectionInit
cvxDwgViewDetail
cvxDwgViewDetailInit
cvxDwgViewFullSection
cvxDwgViewFullSectionInit
cvxDwgViewLayout
cvxDwgViewLayoutInit
cvxDwgViewProjection
cvxDwgViewRotate
cvxDwgViewStandard
cvxDwgViewStandardInit

◆ ZW_API_LAYOUT

#define ZW_API_LAYOUT

Definition at line 15 of file zwapi_cmd_dwg_layout.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_dwg_layout.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_dwg_layout.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_LAYOUT /* this ifndef surrounds entire header */
15#define ZW_API_LAYOUT
16
17#include "zwapi_cmd_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxDwgViewLayoutInit(svxViewLayoutData* data);
44
45/******************************************************************************/
69extern evxErrors cvxDwgViewLayout(svxViewLayoutData* data);
70
71/******************************************************************************/
88extern evxErrors cvxDwgViewStandardInit(svxViewStandardData* data);
89
90/******************************************************************************/
116extern evxErrors cvxDwgViewStandard(const svxViewStandardData* data, int* idView);
117
118/******************************************************************************/
147extern evxErrors cvxDwgViewProjection(int idBaseView, svxPoint2* location, int Projection, int DimType, svxViewAt* ViewAttr, int* idProjView);
148
149/******************************************************************************/
166extern evxErrors cvxDwgViewAuxiliaryInit(svxAuxViewData* data);
167
168/******************************************************************************/
191extern evxErrors cvxDwgViewAuxiliary(const svxAuxViewData* auxViewData, int* idView);
192
193/******************************************************************************/
210extern evxErrors cvxDwgViewFullSectionInit(svxFulSecViewData* data);
211
212/******************************************************************************/
238extern evxErrors cvxDwgViewFullSection(const svxFulSecViewData* fulSecViewData, int* idView);
239
240/******************************************************************************/
257extern evxErrors cvxDwgViewAlignedSectionInit(svxAlignSecViewData* data);
258
259/******************************************************************************/
276extern evxErrors cvxDwgViewAlignedSection(const svxAlignSecViewData* alignSecViewData, int* idView);
277
278/******************************************************************************/
295extern evxErrors cvxDwgViewBrokenSectionInit(svxDwgBrokenSectionData* data);
296
297/******************************************************************************/
331extern evxErrors cvxDwgViewBrokenSection(svxDwgBrokenSectionData* data, int* idView);
332
333/******************************************************************************/
350extern evxErrors cvxDwgViewDetailInit(svxDwgDetailData* data);
351
352/******************************************************************************/
374extern evxErrors cvxDwgViewDetail(const svxDwgDetailData* data, int* idView);
375
376/******************************************************************************/
393extern evxErrors cvxDwgViewBrkLineInit(svxBrkLineData* data);
394
395/******************************************************************************/
417extern evxErrors cvxDwgViewBrkLine(const svxBrkLineData* brkLineInfo, int* brkLnViewId);
418
419
420//====================================================================================================================
422//====================================================================================================================
423/******************************************************************************/
440extern evxErrors cvxDwgTableBomInit(svxDwgBom* data);
441
442/******************************************************************************/
465extern evxErrors cvxDwgTableBom(const svxDwgBom* pData, int* idTbl);
466
467/******************************************************************************/
481extern evxErrors cvxDwgTableInsert(const svxDwgTblInsert* pData);
482
483/******************************************************************************/
516extern evxErrors cvxDwgUserTableCreate(const vxName name, int iRow, int iCol, svxPoint2* pnt, int origin, int* idTable);
517
518/******************************************************************************/
551extern evxErrors cvxDwgUserTableCreateByTemplate(const vxName name,const vxLongPath tplPath, svxPoint2* pnt, int origin, int* idTable);
552
553//====================================================================================================================
555//====================================================================================================================
556/******************************************************************************/
573extern evxErrors cvxDwgRotateViewinit(svxDwgRotView* data);
574
575/******************************************************************************/
596extern evxErrors cvxDwgRotateView(const svxDwgRotView* pData);
597
598/******************************************************************************/
613extern evxErrors cvxDwgViewRotate(int idView, double angle);
614
615
616/*
617*********************************************************************
618** END HEADER FILE
619*********************************************************************
620*/
621
622#ifdef V_VXAPILOC_H
623#include "api/inc/VxApiLoc.h"
624#endif
625
626#ifdef __cplusplus
627 }
628#endif /* __cplusplus */
629
630#endif /* ZW_API_LAYOUT */
cvxDwgViewDetail
evxErrors cvxDwgViewDetail(const svxDwgDetailData *data, int *idView)
cvxDwgRotateView
evxErrors cvxDwgRotateView(const svxDwgRotView *pData)
cvxDwgViewStandardInit
evxErrors cvxDwgViewStandardInit(svxViewStandardData *data)
cvxDwgViewBrkLine
evxErrors cvxDwgViewBrkLine(const svxBrkLineData *brkLineInfo, int *brkLnViewId)
cvxDwgViewAuxiliaryInit
evxErrors cvxDwgViewAuxiliaryInit(svxAuxViewData *data)
cvxDwgViewFullSection
evxErrors cvxDwgViewFullSection(const svxFulSecViewData *fulSecViewData, int *idView)
cvxDwgViewAuxiliary
evxErrors cvxDwgViewAuxiliary(const svxAuxViewData *auxViewData, int *idView)
cvxDwgViewBrokenSectionInit
evxErrors cvxDwgViewBrokenSectionInit(svxDwgBrokenSectionData *data)
cvxDwgRotateViewinit
evxErrors cvxDwgRotateViewinit(svxDwgRotView *data)
cvxDwgViewFullSectionInit
evxErrors cvxDwgViewFullSectionInit(svxFulSecViewData *data)
cvxDwgTableInsert
evxErrors cvxDwgTableInsert(const svxDwgTblInsert *pData)
cvxDwgTableBom
evxErrors cvxDwgTableBom(const svxDwgBom *pData, int *idTbl)
cvxDwgViewStandard
evxErrors cvxDwgViewStandard(const svxViewStandardData *data, int *idView)
cvxDwgViewRotate
evxErrors cvxDwgViewRotate(int idView, double angle)
cvxDwgUserTableCreateByTemplate
evxErrors cvxDwgUserTableCreateByTemplate(const vxName name, const vxLongPath tplPath, svxPoint2 *pnt, int origin, int *idTable)
cvxDwgViewAlignedSectionInit
evxErrors cvxDwgViewAlignedSectionInit(svxAlignSecViewData *data)
cvxDwgViewBrkLineInit
evxErrors cvxDwgViewBrkLineInit(svxBrkLineData *data)
cvxDwgViewBrokenSection
evxErrors cvxDwgViewBrokenSection(svxDwgBrokenSectionData *data, int *idView)
cvxDwgViewDetailInit
evxErrors cvxDwgViewDetailInit(svxDwgDetailData *data)
cvxDwgViewLayoutInit
evxErrors cvxDwgViewLayoutInit(svxViewLayoutData *data)
cvxDwgUserTableCreate
evxErrors cvxDwgUserTableCreate(const vxName name, int iRow, int iCol, svxPoint2 *pnt, int origin, int *idTable)
cvxDwgViewAlignedSection
evxErrors cvxDwgViewAlignedSection(const svxAlignSecViewData *alignSecViewData, int *idView)
cvxDwgTableBomInit
evxErrors cvxDwgTableBomInit(svxDwgBom *data)
cvxDwgViewProjection
evxErrors cvxDwgViewProjection(int idBaseView, svxPoint2 *location, int Projection, int DimType, svxViewAt *ViewAttr, int *idProjView)
cvxDwgViewLayout
evxErrors cvxDwgViewLayout(svxViewLayoutData *data)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAlignSecViewData
aligned section view data
Definition: zwapi_cmd_dwg_data.h:378
svxAuxViewData
Auxiliary view data.
Definition: zwapi_cmd_dwg_data.h:269
svxBrkLineData
information we need when create break line
Definition: zwapi_cmd_dwg_data.h:478
svxDwgBom
BOM table data.
Definition: zwapi_cmd_dwg_data.h:544
svxDwgBrokenSectionData
Drawing Broken Section input infos.
Definition: zwapi_cmd_dwg_data.h:418
svxDwgDetailData
Drawing Detail input infos.
Definition: zwapi_cmd_dwg_data.h:452
svxDwgRotView
Rotate View.
Definition: zwapi_cmd_dwg_data.h:614
svxDwgTblInsert
insert Table
Definition: zwapi_cmd_dwg_data.h:578
svxFulSecViewData
full section view data
Definition: zwapi_cmd_dwg_data.h:361
svxPoint2
2D point
Definition: zwapi_util.h:286
svxViewAt
View layout display attributes.
Definition: zwapi_cmd_dwg_data.h:77
svxViewLayoutData
drawing view layout data
Definition: zwapi_cmd_dwg_data.h:114
svxViewStandardData
drawing view standard data
Definition: zwapi_cmd_dwg_data.h:189
zwapi_cmd_dwg_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_ECAD_BOARD_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_ecadboard.h
cvxPartEcadRgnCut
cvxPartEcadRgnSet
cvxPartEcadRgnSetInit

◆ ZW_API_ECAD_BOARD_H

#define ZW_API_ECAD_BOARD_H

Definition at line 15 of file zwapi_cmd_ecadboard.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_ecadboard.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_ecadboard.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_ECAD_BOARD_H /* this ifndef surrounds entire header */
15#define ZW_API_ECAD_BOARD_H
16
17#include "zwapi_cmd_ecadboard_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22//====================================================================================================================
24//====================================================================================================================
25/**********************************************************************
26*! -Sketch- : zwapi_cmd_sk_create.h
27* extern evxErrors cvxPartSkNew(svxMatrix* Plane, int* idEnt);
28* extern evxErrors cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
29**********************************************************************/
30
31/**********************************************************************
32*! -Cosmetic sketch- : zwapi_cmd_sk_create.h
33* extern evxErrors cvxHatchPtnDataInit(svxHatchPtnData* data);
34* extern evxErrors cvxPartCosSkPlane(const svxSketchData* SkData, int isAddHatPtn, const svxHatchPtnData* PatData, int* idSketch);
35**********************************************************************/
36
37/**********************************************************************
38*! -Extrude Tab- : zwapi_cmd_sheetmetal.h
39* extern evxErrors cvxPartSmdExtrudeTabInit(svxSmdExtrudeTabData* data);
40* extern evxErrors cvxPartSmdExtrudeTab(const svxSmdExtrudeTabData* data, int* idExtTab);
41**********************************************************************/
42
43/**********************************************************************
44*! -Full Flange- : zwapi_cmd_sheetmetal.h
45* extern evxErrors cvxPartSmdFullFlangeInit(svxSmdFullFlangeData* data);
46* extern evxErrors cvxPartSmdFullFlange(const svxSmdFullFlangeData* data, int* idFull);
47**********************************************************************/
48
49/**********************************************************************
50*! -Partial Flange- : zwapi_cmd_sheetmetal.h
51* extern evxErrors cvxPartSmdPartialFlangeInit(svxSmdPartialFlangeData* data);
52* extern evxErrors cvxPartSmdPartialFlange(const svxSmdPartialFlangeData* data, int* idPartial);
53**********************************************************************/
54
55/**********************************************************************
56*! -Lofted Flange- : zwapi_cmd_sheetmetal.h
57* extern evxErrors cvxPartSmdLftFlangeInit(evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData* data);
58* extern evxErrors cvxPartSmdLftFlange(const svxSmdLoftedFlangeData* data, int* idLft);
59**********************************************************************/
60
61//====================================================================================================================
63//====================================================================================================================
64/**********************************************************************
65*! -N-sided- : zwapi_cmd_freeform.h
66* extern evxErrors cvxPartNSidedInit(svxNSidedData* data);
67* extern evxErrors cvxPartNSided(const svxNSidedData* NSidedData, int* idShape);
68**********************************************************************/
69
70//====================================================================================================================
72//====================================================================================================================
73/******************************************************************************/
90extern evxErrors cvxPartEcadRgnSetInit(svxEcadRgnSetData* data);
91
92/******************************************************************************/
114extern evxErrors cvxPartEcadRgnSet(const svxEcadRgnSetData* pRgnSetData, int* idFtr);
115
116/******************************************************************************/
136extern evxErrors cvxPartEcadRgnCut(int idSketch, int* idFtr);
137
138/**********************************************************************
139*! -Fillet- : zwapi_cmd_shape.h
140* extern evxErrors cvxPartFilletAllInit(svxChamFlltData* data);
141* extern evxErrors cvxPartFilletAll(const svxChamFlltData* Fillet, int* idFillet);
142**********************************************************************/
143
144/**********************************************************************
145*! -Chamfer- : zwapi_cmd_shape.h
146* extern evxErrors cvxChamFlltSetDataInit(svxChamFlltSetData* data);
147* extern evxErrors cvxPartChamferAllInit(svxChamFlltData* data);
148* extern evxErrors cvxPartChamferAll(const svxChamFlltData* Chamfer, int* idChamfer);
149**********************************************************************/
150
151/**********************************************************************
152*! -Hole- : zwapi_cmd_shape.h
153* extern evxErrors cvxPartHoleInit(evxHoleOpt HoleOpt, int type, svxHoleData* data);
154* extern evxErrors cvxPartHole(svxHoleData* Data, int* idOp);
155**********************************************************************/
156
157/**********************************************************************
158*! -Add Shape/Remove shape/Intersect shape- : zwapi_cmd_shape.h
159* extern evxErrors cvxPartBool(evxBoolType, int idBase, int Count, int* Shapes, int Keep);
160* extern evxErrors cvxPartBool2(evxBoolType Type, int BaseCount, int* BaseList, int OpCount, int* OpList, int* ResultCount, int** ResultList);
161* extern evxErrors cvxPartBool3(evxBoolType Type, int BaseCount, int* BaseList, int OpCount, int* OpList, int FaceCount, int* FaceList, int* ResultCount, int** ResultList);
162**********************************************************************/
163
164//====================================================================================================================
166//====================================================================================================================
167/**********************************************************************
168*! -Fold- : zwapi_cmd_sheetmetal.h
169* extern evxErrors cvxPartSmdFoldByLineInit(svxSmdFoldByLineData* data);
170* extern evxErrors cvxPartSmdFoldByLine(const svxSmdFoldByLineData* data, int* idFbl);
171**********************************************************************/
172
173/**********************************************************************
174*! -Unfold- : zwapi_cmd_sheetmetal.h
175* extern evxErrors cvxPartSmdUnfold(const svxUnfoldData* Unfold, int* idSmdUnfold);
176**********************************************************************/
177
178/**********************************************************************
179*! -Flatten- : zwapi_cmd_sheetmetal.h
180* extern evxErrors cvxPartSmdFlattenInit(svxSmdFlattenData* data);
181* extern evxErrors cvxPartSmdFlatten(const svxSmdFlattenData* data, int* idFtr);
182**********************************************************************/
183
184/**********************************************************************
185*! -Linear Unfold- : zwapi_cmd_sheetmetal.h
186* extern evxErrors cvxPartSmdLnUnfoldInit(svxSmdLinearUnfoldData* data);
187* extern evxErrors cvxPartSmdLnUnfold(const svxSmdLinearUnfoldData* data, int* idFtr);
188**********************************************************************/
189
190/**********************************************************************
191*! -Linear Unfold- : zwapi_cmd_sheetmetal.h
192* extern evxErrors cvxPartSmdChangeBendInit(evxSmdChangeBendType type, svxSmdChangeBendData* data);
193* extern evxErrors cvxPartSmdChangeBend(const svxSmdChangeBendData* data, int* idFtr);
194**********************************************************************/
195
196//====================================================================================================================
198//====================================================================================================================
199/**********************************************************************
200*! -Pattern Geometry- : zwapi_cmd_shape.h
201* extern int cvxPartPatternGeom(int Count, int* idEnts, const svxPtnGeom* Pattern, int* idPattern);
202**********************************************************************/
203
204/**********************************************************************
205*! -Pattern Feature- : zwapi_cmd_shape.h
206* extern int cvxPartPatternFtr(int Count, int* idFtrs, const svxPtnFtr* Pattern, int* idPattern);
207**********************************************************************/
208
209/**********************************************************************
210*! -Mirror Geometry- : zwapi_cmd_shape.h
211* extern int cvxPartMirrorGeom(svxMirrorGeom* Mirror, int* NumNewEnts, int** idNewEnts);
212**********************************************************************/
213
214/**********************************************************************
215*! -Mirror Feature- : zwapi_cmd_shape.h
216* extern int cvxPartMirrorFtr(svxMirrorFtr* Mirror, int* idFtr);
217**********************************************************************/
218
219/**********************************************************************
220*! -Move- : zwapi_cmd_shape.h
221* extern int cvxPartMove(const svxMoveData *Move, int *idMove);
222**********************************************************************/
223
224/**********************************************************************
225*! -Copy- : zwapi_cmd_shape.h
226* extern int cvxPartCopy(const svxCopyData *Copy, int *idCopy);
227**********************************************************************/
228
229/**********************************************************************
230*! -Scale- : zwapi_cmd_shape.h
231* extern int cvxPartScale(int Count, int* idEnts, double X, double Y, double Z, int idDatum);
232* extern int cvxPartScale2(int Count, int* idEnts, double X, double Y, double Z, int idDatum, svxPoint* CentPnt);
233**********************************************************************/
234
235//====================================================================================================================
237//====================================================================================================================
238/**********************************************************************
239*! -Datum Axis- : zwapi_datum.h
240* extern int cvxPartAxisNew(svxAxisData *Axis, int *idAxis);
241**********************************************************************/
242
243/**********************************************************************
244*! -Datum Plane- : zwapi_datum.h
245* extern int cvxPartDatum(svxMatrix* Frame, int* idDatum);
246* extern int cvxPartDatum2(svxMatrix* Frame, int iCode, int* idDatum);
247* extern int cvxPartNewDatum(svxMatrix* Frame, int* idDatum);
248* extern int cvxPartPlnCrv(int idCrv, svxPoint* Origin, svxPoint* Xaxis, int* idPln);
249* extern int cvxPartPlnCrv2(int idCrv, svxData* Origin, svxData* Xaxis, int Flip, int* idPln);
250* extern int cvxPartPlnSrf(int idFace, svxPoint* Origin, int* idPln);
251* extern int cvxPartPlnSrf2(int idFace, svxPoint* Origin, svxPoint* XZ, int Flip, int* idPln);
252* extern int cvxPartPlaneNew(svxPlaneData* Plane, int* idPlane);
253* extern int cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
254* extern int cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
255**********************************************************************/
256
257/**********************************************************************
258*! -Datum CSYS- : zwapi_datum.h
259* extern int cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
260* extern int cvxPartCSYSNew(svxCSYSData* CSYS, int* idCSYS);
261**********************************************************************/
262
263/**********************************************************************
264*! -LCS- : zwapi_datum.h
265* extern int cvxPartActiveAsLCS(int id);
266**********************************************************************/
267
268/*
269*********************************************************************
270** END HEADER FILE
271*********************************************************************
272*/
273
274#ifdef __cplusplus
275 }
276#endif /* __cplusplus */
277
278#endif /* ZW_API_ECAD_BOARD_H */
cvxPartEcadRgnSet
evxErrors cvxPartEcadRgnSet(const svxEcadRgnSetData *pRgnSetData, int *idFtr)
cvxPartEcadRgnCut
evxErrors cvxPartEcadRgnCut(int idSketch, int *idFtr)
cvxPartEcadRgnSetInit
evxErrors cvxPartEcadRgnSetInit(svxEcadRgnSetData *data)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxEcadRgnSetData
Region set data.
Definition: zwapi_cmd_ecadboard_data.h:57
zwapi_cmd_ecadboard_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_DATA_ECAD_BOARD_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_ecadboard_data.h
evxEcadRgnOwner
evxEcadRgnOwner
evxEcadRgnSetType
evxEcadRgnSetType
svxEcadRgnSetData

◆ ZW_DATA_ECAD_BOARD_DATA_H

#define ZW_DATA_ECAD_BOARD_DATA_H

Definition at line 17 of file zwapi_cmd_ecadboard_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_ecadboard_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_ecadboard_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_DATA_ECAD_BOARD_DATA_H /* this ifndef surrounds entire header */
17#define ZW_DATA_ECAD_BOARD_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxEcadRgnSetType
33 {
34 VX_ROUTING_RGN = 0,
35 VX_PLACEMENT_RGN = 1,
36 VX_VIA_RGN = 2,
37 VX_OTHER_RGN = 3,
38 VX_PLACEMENT_GRP_RGN = 4,
39 }evxEcadRgnSetType;
40
45typedef enum evxEcadRgnOwner
46 {
47 VX_MCAD_RGN = 0,
48 VX_ECAD_RGN = 1,
49 VX_UNOWNED_RGN = 2,
50 }evxEcadRgnOwner;
51
56typedef struct svxEcadRgnSetData
57 {
58 evxEcadRgnSetType Type;
59 int idCosmeticSk;
60 int Volume;
61 double Height;
62 int KeepType;
63 vxLongName RgnType;
64 evxEcadRgnOwner Owner;
65 evxColor Color;
66 }svxEcadRgnSetData;
67
68/*
69*********************************************************************
70** END HEADER FILE
71*********************************************************************
72*/
73
74#ifdef __cplusplus
75 }
76#endif /* __cplusplus */
77
78#endif /* ZW_DATA_ECAD_BOARD_DATA_H */
evxEcadRgnOwner
evxEcadRgnOwner
region owner
Definition: zwapi_cmd_ecadboard_data.h:46
VX_MCAD_RGN
@ VX_MCAD_RGN
MCAD region.
Definition: zwapi_cmd_ecadboard_data.h:47
VX_UNOWNED_RGN
@ VX_UNOWNED_RGN
unowned region
Definition: zwapi_cmd_ecadboard_data.h:49
VX_ECAD_RGN
@ VX_ECAD_RGN
ECAD region.
Definition: zwapi_cmd_ecadboard_data.h:48
evxEcadRgnSetType
evxEcadRgnSetType
region setting type
Definition: zwapi_cmd_ecadboard_data.h:33
VX_OTHER_RGN
@ VX_OTHER_RGN
other region
Definition: zwapi_cmd_ecadboard_data.h:37
VX_PLACEMENT_GRP_RGN
@ VX_PLACEMENT_GRP_RGN
placement group region
Definition: zwapi_cmd_ecadboard_data.h:38
VX_VIA_RGN
@ VX_VIA_RGN
via region
Definition: zwapi_cmd_ecadboard_data.h:36
VX_PLACEMENT_RGN
@ VX_PLACEMENT_RGN
placement region
Definition: zwapi_cmd_ecadboard_data.h:35
VX_ROUTING_RGN
@ VX_ROUTING_RGN
routing region
Definition: zwapi_cmd_ecadboard_data.h:34
svxEcadRgnSetData
struct svxEcadRgnSetData svxEcadRgnSetData
Region set data.
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
svxEcadRgnSetData::Height
double Height
region height(0.0 as default)
Definition: zwapi_cmd_ecadboard_data.h:61
svxEcadRgnSetData::Color
evxColor Color
region color (VX_COLOR_LIGHT_MAGENTA as default)
Definition: zwapi_cmd_ecadboard_data.h:65
svxEcadRgnSetData::Type
evxEcadRgnSetType Type
the type of the region setting
Definition: zwapi_cmd_ecadboard_data.h:58
svxEcadRgnSetData::Owner
evxEcadRgnOwner Owner
region owner
Definition: zwapi_cmd_ecadboard_data.h:64
svxEcadRgnSetData::Volume
int Volume
3d volume (0 as default)
Definition: zwapi_cmd_ecadboard_data.h:60
svxEcadRgnSetData::RgnType
vxLongName RgnType
input the region type (Type = VX_OTHER_RGN)
Definition: zwapi_cmd_ecadboard_data.h:63
svxEcadRgnSetData::KeepType
int KeepType
0-keep in, 1- keep out (0 as default, 1 as default if Type = VX_VIA_RGN)
Definition: zwapi_cmd_ecadboard_data.h:62
svxEcadRgnSetData::idCosmeticSk
int idCosmeticSk
id of the cosmetic sketch
Definition: zwapi_cmd_ecadboard_data.h:59
svxEcadRgnSetData
Region set data.
Definition: zwapi_cmd_ecadboard_data.h:57
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FREEFORM_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_freeform.h
cvxFaceReverse
cvxFaceReverseDir
cvxPartCircularBiRail
cvxPartCircularBiRailInit
cvxPartConicBiRail
cvxPartConicBiRailInit
cvxPartEnlargeFace
cvxPartEnlargeFaceInit
cvxPartExplode
cvxPartExplodeInit
cvxPartExtendFace
cvxPartExtendFaceInit
cvxPartExtendShape
cvxPartExtendShapeInit
cvxPartFacesetSew
cvxPartFacesetSewInit
cvxPartFacesOffset
cvxPartFacesOffsetInit
cvxPartFilletBlend
cvxPartFilletBlendInit
cvxPartModifyIsolineNum
cvxPartNSided
cvxPartNSidedInit
cvxPartRuled
cvxPartRuledInit
cvxPartSetFaceDir
cvxPartSewForce
cvxPartSplitWithCrv
cvxPartSplitWithCrvInit
cvxPartTrimmedPlane
cvxPartTrimmedPlaneInit
cvxPartTrimToCrvs
cvxPartTrimToFaces
cvxPartTrimToFacesInit

◆ ZW_API_FREEFORM_FTR_H

#define ZW_API_FREEFORM_FTR_H

Definition at line 15 of file zwapi_cmd_freeform.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_freeform.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_freeform.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_FREEFORM_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_FREEFORM_FTR_H
16
17#include "zwapi_cmd_freeform_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxPartFilletBlendInit(svxFilletBlendData* data);
44
45/******************************************************************************/
65extern evxErrors cvxPartFilletBlend(const svxFilletBlendData* FilletBlend, int* idFilletBlend);
66
67/******************************************************************************/
84extern evxErrors cvxPartNSidedInit(svxNSidedData* data);
85
86/******************************************************************************/
110extern evxErrors cvxPartNSided(const svxNSidedData* NSidedData, int* idShape);
111
112/******************************************************************************/
129extern evxErrors cvxPartTrimmedPlaneInit(svxTrimPlnData* data);
130
131/******************************************************************************/
155extern evxErrors cvxPartTrimmedPlane(svxTrimPlnData* data, int* newShp);
156
157/******************************************************************************/
174extern evxErrors cvxPartRuledInit(svxRuledData* data);
175
176/******************************************************************************/
197extern evxErrors cvxPartRuled(const svxRuledData* data, int* idFace);
198
199/******************************************************************************/
217extern evxErrors cvxPartCircularBiRailInit(evxCircularBiRailMethod method, svxCircularBiRailData* data);
218
219/******************************************************************************/
242extern evxErrors cvxPartCircularBiRail(const svxCircularBiRailData* data, int* idFace);
243
244/******************************************************************************/
262extern evxErrors cvxPartConicBiRailInit(evxConicBiRailMethod method, svxConicBiRailData* data);
263
264/******************************************************************************/
288extern evxErrors cvxPartConicBiRail(const svxConicBiRailData* data, int* idFace);
289
290//====================================================================================================================
292//====================================================================================================================
293/******************************************************************************/
310extern evxErrors cvxPartFacesOffsetInit(svxFcsOffsetData* data);
311
312/******************************************************************************/
335extern evxErrors cvxPartFacesOffset(const svxFcsOffsetData* data, int* idFtr);
336
337/******************************************************************************/
354extern evxErrors cvxPartExtendFaceInit(svxExtendData* data);
355
356/******************************************************************************/
376extern evxErrors cvxPartExtendFace(svxExtendData* data, int* newFtr);
377
378/******************************************************************************/
395extern evxErrors cvxPartTrimToFacesInit(svxTrimToFacesData* data);
396
397/******************************************************************************/
419extern evxErrors cvxPartTrimToFaces(const svxTrimToFacesData* data, int* idTrim);
420
421/******************************************************************************/
440extern evxErrors cvxPartTrimToCrvs(const svxTrimToCurvesData* trimData, int* idTrim);
441
442/******************************************************************************/
461extern evxErrors cvxPartSetFaceDir(int count, int* idFaces, const svxVector* dir);
462
463/******************************************************************************/
491extern evxErrors cvxFaceReverse(int numFaces, int* idFaces);
492
493/******************************************************************************/
517extern evxErrors cvxFaceReverseDir(int numFaces, int* idFaces);
518
519/******************************************************************************/
540extern evxErrors cvxPartModifyIsolineNum(int count, int* idFaces, int Uisoline, int Visoline);
541
542/******************************************************************************/
559extern evxErrors cvxPartExplodeInit(svxExplodeData* data);
560
561/******************************************************************************/
585extern evxErrors cvxPartExplode(const svxExplodeData* ExplodeData, int* numShape, int** idShapes);
586
587/******************************************************************************/
604extern evxErrors cvxPartFacesetSewInit(svxSewData* data);
605
606/******************************************************************************/
632extern evxErrors cvxPartFacesetSew(int count, int* shapes, svxSewData* param, int* newFtr);
633
634/******************************************************************************/
659extern evxErrors cvxPartSewForce(double Tol);
660
661/******************************************************************************/
678extern evxErrors cvxPartEnlargeFaceInit(svxEnlargeFaceData* data);
679
680/******************************************************************************/
703extern evxErrors cvxPartEnlargeFace(const svxEnlargeFaceData* data, int* idFace);
704
705/******************************************************************************/
722extern evxErrors cvxPartExtendShapeInit(svxExtendShapeData* data);
723
724/******************************************************************************/
746extern evxErrors cvxPartExtendShape(const svxExtendShapeData* data, int* idFtr);
747
748/******************************************************************************/
765extern evxErrors cvxPartSplitWithCrvInit(svxSplitWithCrvData* data);
766
767/******************************************************************************/
791extern evxErrors cvxPartSplitWithCrv(const svxSplitWithCrvData* data, int* idFtr);
792
793//====================================================================================================================
795//====================================================================================================================
796/**********************************************************************
797*! -Pattern Geometry- : zwapi_cmd_shape.h
798* extern int cvxPartPatternGeom(int Count, int* idEnts, const svxPtnGeom* Pattern, int* idPattern);
799**********************************************************************/
800
801/**********************************************************************
802*! -Pattern Feature- : zwapi_cmd_shape.h
803* extern int cvxPartPatternFtr(int Count, int* idFtrs, const svxPtnFtr* Pattern, int* idPattern);
804**********************************************************************/
805
806/**********************************************************************
807*! -Mirror Geometry- : zwapi_cmd_shape.h
808* extern int cvxPartMirrorGeom(svxMirrorGeom* Mirror, int* NumNewEnts, int** idNewEnts);
809**********************************************************************/
810
811/**********************************************************************
812*! -Mirror Feature- : zwapi_cmd_shape.h
813* extern int cvxPartMirrorFtr(svxMirrorFtr* Mirror, int* idFtr);
814**********************************************************************/
815
816/**********************************************************************
817*! -Move- : zwapi_cmd_shape.h
818* extern int cvxPartMove(const svxMoveData *Move, int *idMove);
819**********************************************************************/
820
821/**********************************************************************
822*! -Copy- : zwapi_cmd_shape.h
823* extern int cvxPartCopy(const svxCopyData *Copy, int *idCopy);
824**********************************************************************/
825
826/**********************************************************************
827*! -Scale- : zwapi_cmd_shape.h
828* extern int cvxPartScale(int Count, int* idEnts, double X, double Y, double Z, int idDatum);
829* extern int cvxPartScale2(int Count, int* idEnts, double X, double Y, double Z, int idDatum, svxPoint* CentPnt);
830**********************************************************************/
831
832//====================================================================================================================
834//====================================================================================================================
835/**********************************************************************
836*! -Datum Axis- : zwapi_datum.h
837* extern int cvxPartAxisNew(svxAxisData *Axis, int *idAxis);
838**********************************************************************/
839
840/**********************************************************************
841*! -Datum Plane- : zwapi_datum.h
842* extern int cvxPartDatum(svxMatrix* Frame, int* idDatum);
843* extern int cvxPartDatum2(svxMatrix* Frame, int iCode, int* idDatum);
844* extern int cvxPartNewDatum(svxMatrix* Frame, int* idDatum);
845* extern int cvxPartPlnCrv(int idCrv, svxPoint* Origin, svxPoint* Xaxis, int* idPln);
846* extern int cvxPartPlnCrv2(int idCrv, svxData* Origin, svxData* Xaxis, int Flip, int* idPln);
847* extern int cvxPartPlnSrf(int idFace, svxPoint* Origin, int* idPln);
848* extern int cvxPartPlnSrf2(int idFace, svxPoint* Origin, svxPoint* XZ, int Flip, int* idPln);
849* extern int cvxPartPlaneNew(svxPlaneData* Plane, int* idPlane);
850* extern int cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
851* extern int cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
852**********************************************************************/
853
854/**********************************************************************
855*! -Datum CSYS- : zwapi_datum.h
856* extern int cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
857* extern int cvxPartCSYSNew(svxCSYSData* CSYS, int* idCSYS);
858**********************************************************************/
859
860/**********************************************************************
861*! -LCS- : zwapi_datum.h
862* extern int cvxPartActiveAsLCS(int id);
863**********************************************************************/
864
865/*
866*********************************************************************
867** END HEADER FILE
868*********************************************************************
869*/
870
871#ifdef V_VXAPILOC_H
872#include "api/inc/VxApiLoc.h"
873#endif
874
875#ifdef __cplusplus
876 }
877#endif /* __cplusplus */
878
879#endif /* ZW_API_FREEFORM_FTR_H */
evxCircularBiRailMethod
evxCircularBiRailMethod
circular bi rail method
Definition: zwapi_cmd_freeform_data.h:168
evxConicBiRailMethod
evxConicBiRailMethod
conic bi rail method
Definition: zwapi_cmd_freeform_data.h:227
cvxFaceReverse
evxErrors cvxFaceReverse(int numFaces, int *idFaces)
cvxPartExplodeInit
evxErrors cvxPartExplodeInit(svxExplodeData *data)
cvxPartModifyIsolineNum
evxErrors cvxPartModifyIsolineNum(int count, int *idFaces, int Uisoline, int Visoline)
cvxPartCircularBiRailInit
evxErrors cvxPartCircularBiRailInit(evxCircularBiRailMethod method, svxCircularBiRailData *data)
cvxPartExtendFace
evxErrors cvxPartExtendFace(svxExtendData *data, int *newFtr)
cvxPartEnlargeFaceInit
evxErrors cvxPartEnlargeFaceInit(svxEnlargeFaceData *data)
cvxPartEnlargeFace
evxErrors cvxPartEnlargeFace(const svxEnlargeFaceData *data, int *idFace)
cvxPartTrimToFacesInit
evxErrors cvxPartTrimToFacesInit(svxTrimToFacesData *data)
cvxPartRuledInit
evxErrors cvxPartRuledInit(svxRuledData *data)
cvxPartCircularBiRail
evxErrors cvxPartCircularBiRail(const svxCircularBiRailData *data, int *idFace)
cvxPartSplitWithCrv
evxErrors cvxPartSplitWithCrv(const svxSplitWithCrvData *data, int *idFtr)
cvxPartExplode
evxErrors cvxPartExplode(const svxExplodeData *ExplodeData, int *numShape, int **idShapes)
cvxPartFilletBlend
evxErrors cvxPartFilletBlend(const svxFilletBlendData *FilletBlend, int *idFilletBlend)
cvxPartNSidedInit
evxErrors cvxPartNSidedInit(svxNSidedData *data)
cvxPartConicBiRailInit
evxErrors cvxPartConicBiRailInit(evxConicBiRailMethod method, svxConicBiRailData *data)
cvxPartFacesOffsetInit
evxErrors cvxPartFacesOffsetInit(svxFcsOffsetData *data)
cvxPartFacesetSew
evxErrors cvxPartFacesetSew(int count, int *shapes, svxSewData *param, int *newFtr)
cvxPartNSided
evxErrors cvxPartNSided(const svxNSidedData *NSidedData, int *idShape)
cvxPartConicBiRail
evxErrors cvxPartConicBiRail(const svxConicBiRailData *data, int *idFace)
cvxPartTrimToFaces
evxErrors cvxPartTrimToFaces(const svxTrimToFacesData *data, int *idTrim)
cvxFaceReverseDir
evxErrors cvxFaceReverseDir(int numFaces, int *idFaces)
cvxPartExtendFaceInit
evxErrors cvxPartExtendFaceInit(svxExtendData *data)
cvxPartSplitWithCrvInit
evxErrors cvxPartSplitWithCrvInit(svxSplitWithCrvData *data)
cvxPartTrimmedPlaneInit
evxErrors cvxPartTrimmedPlaneInit(svxTrimPlnData *data)
cvxPartSewForce
evxErrors cvxPartSewForce(double Tol)
cvxPartTrimToCrvs
evxErrors cvxPartTrimToCrvs(const svxTrimToCurvesData *trimData, int *idTrim)
cvxPartExtendShape
evxErrors cvxPartExtendShape(const svxExtendShapeData *data, int *idFtr)
cvxPartFacesetSewInit
evxErrors cvxPartFacesetSewInit(svxSewData *data)
cvxPartExtendShapeInit
evxErrors cvxPartExtendShapeInit(svxExtendShapeData *data)
cvxPartRuled
evxErrors cvxPartRuled(const svxRuledData *data, int *idFace)
cvxPartTrimmedPlane
evxErrors cvxPartTrimmedPlane(svxTrimPlnData *data, int *newShp)
cvxPartFilletBlendInit
evxErrors cvxPartFilletBlendInit(svxFilletBlendData *data)
cvxPartSetFaceDir
evxErrors cvxPartSetFaceDir(int count, int *idFaces, const svxVector *dir)
cvxPartFacesOffset
evxErrors cvxPartFacesOffset(const svxFcsOffsetData *data, int *idFtr)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCircularBiRailData
circular bi rail data
Definition: zwapi_cmd_freeform_data.h:192
svxConicBiRailData
conic bi rail data
Definition: zwapi_cmd_freeform_data.h:242
svxEnlargeFaceData
enlarge face data
Definition: zwapi_cmd_freeform_data.h:421
svxExplodeData
data of explode command
Definition: zwapi_cmd_freeform_data.h:385
svxExtendData
template command Extend Face data
Definition: zwapi_cmd_freeform_data.h:319
svxExtendShapeData
extend shape data
Definition: zwapi_cmd_freeform_data.h:469
svxFcsOffsetData
faces offset data
Definition: zwapi_cmd_freeform_data.h:297
svxFilletBlendData
freeForm filletBlend data
Definition: zwapi_cmd_freeform_data.h:79
svxNSidedData
template command N-sided data
Definition: zwapi_cmd_freeform_data.h:122
svxRuledData
ruled data
Definition: zwapi_cmd_freeform_data.h:156
svxSewData
faces sew data
Definition: zwapi_cmd_freeform_data.h:398
svxSplitWithCrvData
split with curve data
Definition: zwapi_cmd_freeform_data.h:503
svxTrimPlnData
template command Trimmed Plane data
Definition: zwapi_cmd_freeform_data.h:140
svxTrimToCurvesData
template command Trim to Curves input data
Definition: zwapi_cmd_freeform_data.h:364
svxTrimToFacesData
trim to faces
Definition: zwapi_cmd_freeform_data.h:335
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_cmd_freeform_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FREEFORM_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_freeform_data.h
evxCappingType
evxCappingType
evxCircularBiRailMethod
evxCircularBiRailMethod
evxConicBiRailMethod
evxConicBiRailMethod
evxCroSecType
evxCroSecType
evxEdgeExtensionType
evxEdgeExtensionType
evxExtendFaceMethod
evxExtendFaceMethod
evxExtendShapeMethod
evxExtendShapeMethod
evxFaceExtType
evxFaceExtType
evxRefitOpt
evxRefitOpt
evxSewingType
evxSewingType
evxSpineType
evxSpineType
evxTrimCrvsProjtype
evxTrimCrvsProjtype
svxCircularBiRailData
svxConicBiRailData
svxEnlargeFaceData
svxExplodeData
svxExtendData
svxExtendShapeData
svxFcsOffsetData
svxFilletBlendData
svxNSidedData
svxRadiusSetData
svxRuledData
svxSewData
svxSplitWithCrvData
svxTrimPlnData
svxTrimToCurvesData
svxTrimToFacesData

◆ ZW_API_FREEFORM_FTR_DATA_H

#define ZW_API_FREEFORM_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_freeform_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_freeform_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_freeform_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_FREEFORM_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_FREEFORM_FTR_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxSpineType
33 {
34 VX_SPINE_NATURAL = 0,
35 VX_SPINE_SPINE = 1,
36 VX_SPINE_PARALLEL = 2,
37 } evxSpineType;
38
43typedef enum evxCroSecType
44 {
45 VX_CRO_SEC_CIRCULAR = 0,
46 VX_CRO_SEC_CONIC = 1,
47 VX_CRO_SEC_G2BLEND = 2,
48 VX_CRO_SEC_G3BLEND = 3,
49 } evxCroSecType;
50
55typedef enum evxSewingType
56 {
57 VX_SEWING_NOACTION = 0,
58 VX_SEWING_DIVIDE = 1,
59 VX_SEWING_TRIM = 2,
60 VX_SEWING_SEW = 3,
61 } evxSewingType;
62
67typedef enum evxCappingType
68 {
69 VX_CAPPING_MAXIMAL = 0,
70 VX_CAPPING_MINIMAL = 1,
71 VX_CAPPING_TANGENT = 2,
72 } evxCappingType;
73
78typedef struct svxFilletBlendData
79 {
80 /* Required */
81 int type;
82 svxPntOnEntPath from;
83 svxPntOnEntPath to;
84 svxPntOnEntPath through;
85 double radius;
86 /* Orientation */
87 evxSpineType spineType;
88 int idCurve;
89 svxVector plane;
90 /* Shape of Blend */
91 evxCroSecType croSecType;
92 double conicRatio;
93 double startWeight;
94 double endWeight;
95 /* Sew */
96 int sewShapes;
98 int numShapes;
99 int* idShapes;
100 /* Settings */
101 evxSewingType sewingType;
102 evxCappingType cappingType;
103 } svxFilletBlendData;
104
109typedef enum evxRefitOpt
110 {
111 VX_REFIT_NO = 0,
112 VX_REFIT_TANGENT = 1,
113 VX_REFIT_CURVATURE = 2,
114 VX_REFIT_DIRECT = 3,
115 } evxRefitOpt;
116
121typedef struct svxNSidedData
122 {
123 int numCrv;
124 int* pCrv;
125 int* pCrvParent;
126 int sewShape;
128 int numShape;
129 int* pShape;
130 int tangent;
131 evxRefitOpt refit;
132 double dTol;
133 } svxNSidedData;
134
139typedef struct svxTrimPlnData
140 {
141 int cntCrv;
142 int* pCrvList;
143 int idProf;
144 char sew;
145 int cntBool;
146 int* pBooolList;
147 int idPlane;
148 }svxTrimPlnData;
149
150
155typedef struct svxRuledData
156 {
157 svxPntOnEntPath firstCrv;
158 svxPntOnEntPath secondCrv;
159 svxPntOnEntPath spineCrv;
160 int trimPlane;
161 }svxRuledData;
162
167typedef enum evxCircularBiRailMethod
168 {
169 VX_CIRCULARBIRAIL_CONSTANT = 0,
170 VX_CIRCULARBIRAIL_VARIABLE,
171 VX_CIRCULARBIRAIL_CENTER,
172 VX_CIRCULARBIRAIL_MIDDLE,
173 }evxCircularBiRailMethod;
174
179typedef struct svxRadiusSetData
180 {
181 int idCurve;
182 svxPntOnEntPath pnt;
183 double radius;
184 int radiusFlat;
185 }svxRadiusSetData;
186
191typedef struct svxCircularBiRailData
192 {
193 evxCircularBiRailMethod method;
194 svxPntOnEntPath firstCrv;
195 svxPntOnEntPath secondCrv;
196 svxPntOnEntPath spineCrv;
197 union evxCircularBiRailInpUnion
198 {
199 struct CircularBiRailConstant
200 {
201 double radius;
202 int solution;
203 }constant;
204 struct CircularBiRailVariable
205 {
206 int solution;
207 int nRadSet;
208 svxRadiusSetData* pRadSet;
209 }variable;
210 struct CircularBiRailCenter
211 {
212 svxPntOnEntPath center;
213 int solution;
214 }center;
215 struct CircularBiRailMiddle
216 {
217 svxPntOnEntPath middle;
218 }middle;
219 }inpUnion;
220 }svxCircularBiRailData;
221
226typedef enum evxConicBiRailMethod
227 {
228 VX_CONICBIRAIL_CONSTANT = 0,
229 VX_CONICBIRAIL_VARIABLE,
230 VX_CONICBIRAIL_HOLDER,
231 VX_CONICBIRAIL_TANGENT,
232 VX_CONICBIRAIL_INTERSECTION,
233 VX_CONICBIRAIL_CENTER,
234 VX_CONICBIRAIL_TANGENTEDGES,
235 }evxConicBiRailMethod;
236
241typedef struct svxConicBiRailData
242 {
243 evxConicBiRailMethod method;
244 svxPntOnEntPath firstCrv;
245 svxPntOnEntPath secondCrv;
246 svxPntOnEntPath spineCrv;
247 union evxConicBiRailInpUnion
248 {
249 struct ConicBiRailConstant
250 {
251 double radius;
252 double ratio;
253 int solution;
254 }constant;
255 struct ConicBiRailVariable
256 {
257 int nRadSet;
258 svxRadiusSetData* pRadSet;
259 double ratio;
260 int solution;
261 }variable;
262 struct ConicBiRailHolder
263 {
264 svxPntOnEntPath holder;
265 double ratio;
266 }holder;
267 struct ConicBiRailTangent
268 {
269 svxPntOnEntPath tangent;
270 double ratio;
271 }tangent;
272 struct ConicBiRailIntersection
273 {
274 svxPntOnEntPath holder;
275 svxPntOnEntPath tangent;
276 }intersection;
277 struct ConicBiRailCenter
278 {
279 svxPntOnEntPath center;
280 double ratio;
281 }center;
282 struct ConicBiRailTangentEdges
283 {
284 double ratio;
285 }tangentEdges;
286 }inpUnion;
287 }svxConicBiRailData;
288
289//====================================================================================================================
291//====================================================================================================================
296typedef struct svxFcsOffsetData
297 {
298 int count;
299 int* faces;
300 double offset;
302 int keepSurface;
303 int keepEdge;
305 /* variable offset */
306 int cnt;
307 struct svxVarOffset
308 {
309 svxPntOnEnt pntOnEnt;
310 double pntOffset;
311 } *list;
312 } svxFcsOffsetData;
313
318typedef struct svxExtendData
319 {
320 int idFace;
321 int cntEdge;
322 int* pEdgList;
323 double* pDistList;
324 double fDist;
325 int iMerge;
326 int iKeepFace;
327 int iExtension;
328 }svxExtendData;
329
334typedef struct svxTrimToFacesData
335 {
336 int numFace;
337 int* pFace;
338 int numTrimming;
339 int* pTrimming;
341 int FlipSide;
342 int TrimWith;
343 int ExtendTrimming;
344 int KeepTrimming;
345 }svxTrimToFacesData;
346
351typedef enum evxTrimCrvsProjtype
352 {
353 VX_TRIMCRV_IN_PLACE,
354 VX_TRIMCRV_FACE_NORMAL,
355 VX_TRIMCRV_DIRECTED,
356 VX_TRIMCRV_BI_DIRECTIONAL,
357 } evxTrimCrvsProjtype;
358
363typedef struct svxTrimToCurvesData
364 {
365 int cntFcs;
366 int* idFaces;
367 int cntCrvs;
368 int* idCurves;
369 int toKeep;
370 int cntPnts;
371 svxPntOnEnt* sides;
373 /* Settings */
374 evxTrimCrvsProjtype projection;
375 svxVector* dirction;
376 int isCheckerboard;
377 int isExtend;
378 } svxTrimToCurvesData;
379
384typedef struct svxExplodeData
385 {
386 int numFace;
387 int* pFace;
389 int ConnectFc;
390 int RebudEdge;
391 } svxExplodeData;
392
397typedef struct svxSewData
398 {
399 double tol;
400 char multEdg;
401 char forceClose;
402 }svxSewData;
403
408typedef enum evxFaceExtType
409 {
410 VX_FACE_EXT_LINEAR = 0,
411 VX_FACE_EXT_REFLECT,
412 VX_FACE_EXT_CIRCULAR,
413 VX_FACE_EXT_CURVATURE_DIMINISHING = 4,
414 }evxFaceExtType;
415
420typedef struct svxEnlargeFaceData
421 {
422 int idFace;
423 int applyAll;
424 double distance;
425 double u0;
426 double u1;
427 double v0;
428 double v1;
429 int keepOriginal;
430 evxFaceExtType extension;
431 }svxEnlargeFaceData;
432
437typedef enum evxExtendShapeMethod
438 {
439 VX_EXTEND_OPEN_SHAPE = 0,
440 VX_EXTEND_GENERAL_SHAPE = 1,
441 }evxExtendShapeMethod;
442
447typedef enum evxEdgeExtensionType
448 {
449 VX_EDGE_EXTENSION_TANGENT = 0,
450 VX_EDGE_EXTENSION_ORTHOGONAL,
451 }evxEdgeExtensionType;
452
457typedef enum evxExtendFaceMethod
458 {
459 VX_EXTEND_FACE_NONE = 0,
460 VX_EXTEND_FACE_CLOSE_ENTIRE_GAP,
461 VX_EXTEND_FACE_DIRECT_EDIT,
462 }evxExtendFaceMethod;
463
468typedef struct svxExtendShapeData
469 {
470 evxExtendShapeMethod method;
471 double distance;
473 union evxExtendShapeInpUnion
474 {
475 struct ExtendOpenShape
476 {
477 int nEdges;
478 int* idEdges;
479 evxExtendFaceMethod option;
480 int nFaces;
481 int* idFaces;
482 int createFaces;
483 int loftFaces;
484 }open;
485 struct ExtendGeneralShape
486 {
487 int nFaces;
488 int* idFaces;
489 int nEdges;
490 int* idEdges;
491 }general;
492 }inpUnion;
493
494 evxFaceExtType faceExtension;
495 evxEdgeExtensionType edgeExtension;
496 }svxExtendShapeData;
497
502typedef struct svxSplitWithCrvData
503 {
504 int nFaces;
505 int* idFaces;
506 int nCrvs;
507 int* idCrvs;
508 evxTrimCrvsProjtype prjMethod;
509 svxVector direction;
510 int explodeEdges;
511 int extendCrvs;
512 int removeSpurs;
513 }svxSplitWithCrvData;
514
515/*
516*********************************************************************
517** END HEADER FILE
518*********************************************************************
519*/
520
521#ifdef __cplusplus
522 }
523#endif /* __cplusplus */
524
525#endif /* ZW_API_FREEFORM_FTR_DATA_H */
evxEdgeExtensionType
evxEdgeExtensionType
edge extension type
Definition: zwapi_cmd_freeform_data.h:448
VX_EDGE_EXTENSION_TANGENT
@ VX_EDGE_EXTENSION_TANGENT
tangent
Definition: zwapi_cmd_freeform_data.h:449
VX_EDGE_EXTENSION_ORTHOGONAL
@ VX_EDGE_EXTENSION_ORTHOGONAL
orthogonal
Definition: zwapi_cmd_freeform_data.h:450
evxCircularBiRailMethod
evxCircularBiRailMethod
circular bi rail method
Definition: zwapi_cmd_freeform_data.h:168
VX_CIRCULARBIRAIL_MIDDLE
@ VX_CIRCULARBIRAIL_MIDDLE
radius is defined implicitly by a middle curve
Definition: zwapi_cmd_freeform_data.h:172
VX_CIRCULARBIRAIL_CENTER
@ VX_CIRCULARBIRAIL_CENTER
radius is defined implicitly by a center curve
Definition: zwapi_cmd_freeform_data.h:171
VX_CIRCULARBIRAIL_VARIABLE
@ VX_CIRCULARBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:170
VX_CIRCULARBIRAIL_CONSTANT
@ VX_CIRCULARBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:169
evxSewingType
evxSewingType
sewing type
Definition: zwapi_cmd_freeform_data.h:56
VX_SEWING_SEW
@ VX_SEWING_SEW
divide, trim and sew the base faces with the fillet faces
Definition: zwapi_cmd_freeform_data.h:60
VX_SEWING_DIVIDE
@ VX_SEWING_DIVIDE
divide the base faces at the fillet tangents
Definition: zwapi_cmd_freeform_data.h:58
VX_SEWING_TRIM
@ VX_SEWING_TRIM
divide and trim away the base faces at the fillet tangents
Definition: zwapi_cmd_freeform_data.h:59
VX_SEWING_NOACTION
@ VX_SEWING_NOACTION
leave the base faces as is
Definition: zwapi_cmd_freeform_data.h:57
evxExtendFaceMethod
evxExtendFaceMethod
extend face method
Definition: zwapi_cmd_freeform_data.h:458
VX_EXTEND_FACE_CLOSE_ENTIRE_GAP
@ VX_EXTEND_FACE_CLOSE_ENTIRE_GAP
close entire gap
Definition: zwapi_cmd_freeform_data.h:460
VX_EXTEND_FACE_NONE
@ VX_EXTEND_FACE_NONE
none
Definition: zwapi_cmd_freeform_data.h:459
VX_EXTEND_FACE_DIRECT_EDIT
@ VX_EXTEND_FACE_DIRECT_EDIT
direct edit
Definition: zwapi_cmd_freeform_data.h:461
evxRefitOpt
evxRefitOpt
N-SIDED.
Definition: zwapi_cmd_freeform_data.h:110
VX_REFIT_CURVATURE
@ VX_REFIT_CURVATURE
curvature
Definition: zwapi_cmd_freeform_data.h:113
VX_REFIT_NO
@ VX_REFIT_NO
none
Definition: zwapi_cmd_freeform_data.h:111
VX_REFIT_TANGENT
@ VX_REFIT_TANGENT
tangent
Definition: zwapi_cmd_freeform_data.h:112
VX_REFIT_DIRECT
@ VX_REFIT_DIRECT
direct
Definition: zwapi_cmd_freeform_data.h:114
evxConicBiRailMethod
evxConicBiRailMethod
conic bi rail method
Definition: zwapi_cmd_freeform_data.h:227
VX_CONICBIRAIL_INTERSECTION
@ VX_CONICBIRAIL_INTERSECTION
using a tangent curve and a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:232
VX_CONICBIRAIL_CONSTANT
@ VX_CONICBIRAIL_CONSTANT
with constant radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:228
VX_CONICBIRAIL_CENTER
@ VX_CONICBIRAIL_CENTER
using a center curve
Definition: zwapi_cmd_freeform_data.h:233
VX_CONICBIRAIL_TANGENT
@ VX_CONICBIRAIL_TANGENT
using a tangent curve.
Definition: zwapi_cmd_freeform_data.h:231
VX_CONICBIRAIL_VARIABLE
@ VX_CONICBIRAIL_VARIABLE
with variable radius between the two path curves
Definition: zwapi_cmd_freeform_data.h:229
VX_CONICBIRAIL_TANGENTEDGES
@ VX_CONICBIRAIL_TANGENTEDGES
tangent to two existing face edges.
Definition: zwapi_cmd_freeform_data.h:234
VX_CONICBIRAIL_HOLDER
@ VX_CONICBIRAIL_HOLDER
using a shoulder curve.
Definition: zwapi_cmd_freeform_data.h:230
evxSpineType
evxSpineType
spine type
Definition: zwapi_cmd_freeform_data.h:33
VX_SPINE_NATURAL
@ VX_SPINE_NATURAL
no drive curve is used
Definition: zwapi_cmd_freeform_data.h:34
VX_SPINE_PARALLEL
@ VX_SPINE_PARALLEL
the face is created by moving an infinite plane containing cross-sections of the face parallel to a p...
Definition: zwapi_cmd_freeform_data.h:36
VX_SPINE_SPINE
@ VX_SPINE_SPINE
a spine curve will be used as the drive curve
Definition: zwapi_cmd_freeform_data.h:35
evxCappingType
evxCappingType
capping type
Definition: zwapi_cmd_freeform_data.h:68
VX_CAPPING_MAXIMAL
@ VX_CAPPING_MAXIMAL
trim the fillet to the wider pair of face boundaries
Definition: zwapi_cmd_freeform_data.h:69
VX_CAPPING_TANGENT
@ VX_CAPPING_TANGENT
create a blended curve matching the tangency of the boundaries of the two supporting faces
Definition: zwapi_cmd_freeform_data.h:71
VX_CAPPING_MINIMAL
@ VX_CAPPING_MINIMAL
trim the fillet to the narrower pair of face boundaries
Definition: zwapi_cmd_freeform_data.h:70
evxTrimCrvsProjtype
evxTrimCrvsProjtype
projection types of "trim to curves"
Definition: zwapi_cmd_freeform_data.h:352
VX_TRIMCRV_FACE_NORMAL
@ VX_TRIMCRV_FACE_NORMAL
face normal
Definition: zwapi_cmd_freeform_data.h:354
VX_TRIMCRV_IN_PLACE
@ VX_TRIMCRV_IN_PLACE
in place(none)
Definition: zwapi_cmd_freeform_data.h:353
VX_TRIMCRV_DIRECTED
@ VX_TRIMCRV_DIRECTED
directed
Definition: zwapi_cmd_freeform_data.h:355
VX_TRIMCRV_BI_DIRECTIONAL
@ VX_TRIMCRV_BI_DIRECTIONAL
bi-directional
Definition: zwapi_cmd_freeform_data.h:356
evxExtendShapeMethod
evxExtendShapeMethod
extend shape type
Definition: zwapi_cmd_freeform_data.h:438
VX_EXTEND_GENERAL_SHAPE
@ VX_EXTEND_GENERAL_SHAPE
extend general shape
Definition: zwapi_cmd_freeform_data.h:440
VX_EXTEND_OPEN_SHAPE
@ VX_EXTEND_OPEN_SHAPE
extend open shape
Definition: zwapi_cmd_freeform_data.h:439
evxFaceExtType
evxFaceExtType
face extension type
Definition: zwapi_cmd_freeform_data.h:409
VX_FACE_EXT_CIRCULAR
@ VX_FACE_EXT_CIRCULAR
circular
Definition: zwapi_cmd_freeform_data.h:412
VX_FACE_EXT_REFLECT
@ VX_FACE_EXT_REFLECT
reflect
Definition: zwapi_cmd_freeform_data.h:411
VX_FACE_EXT_LINEAR
@ VX_FACE_EXT_LINEAR
linear
Definition: zwapi_cmd_freeform_data.h:410
VX_FACE_EXT_CURVATURE_DIMINISHING
@ VX_FACE_EXT_CURVATURE_DIMINISHING
curvature diminishing
Definition: zwapi_cmd_freeform_data.h:413
evxCroSecType
evxCroSecType
cross-section type
Definition: zwapi_cmd_freeform_data.h:44
VX_CRO_SEC_G2BLEND
@ VX_CRO_SEC_G2BLEND
create the face using G2 Blend cross-sections
Definition: zwapi_cmd_freeform_data.h:47
VX_CRO_SEC_G3BLEND
@ VX_CRO_SEC_G3BLEND
create the face using G3 Blend cross-sections
Definition: zwapi_cmd_freeform_data.h:48
VX_CRO_SEC_CIRCULAR
@ VX_CRO_SEC_CIRCULAR
create the face using circular arc cross-sections
Definition: zwapi_cmd_freeform_data.h:45
VX_CRO_SEC_CONIC
@ VX_CRO_SEC_CONIC
create the face using conic arc cross-sections
Definition: zwapi_cmd_freeform_data.h:46
svxRadiusSetData
struct svxRadiusSetData svxRadiusSetData
radius set data
svxEnlargeFaceData
struct svxEnlargeFaceData svxEnlargeFaceData
enlarge face data
svxTrimToCurvesData
struct svxTrimToCurvesData svxTrimToCurvesData
template command Trim to Curves input data
svxFcsOffsetData
struct svxFcsOffsetData svxFcsOffsetData
faces offset data
svxExtendShapeData
struct svxExtendShapeData svxExtendShapeData
extend shape data
svxTrimPlnData
struct svxTrimPlnData svxTrimPlnData
template command Trimmed Plane data
svxFilletBlendData
struct svxFilletBlendData svxFilletBlendData
freeForm filletBlend data
svxNSidedData
struct svxNSidedData svxNSidedData
template command N-sided data
svxExplodeData
struct svxExplodeData svxExplodeData
data of explode command
svxSewData
struct svxSewData svxSewData
faces sew data
svxConicBiRailData
struct svxConicBiRailData svxConicBiRailData
conic bi rail data
svxTrimToFacesData
struct svxTrimToFacesData svxTrimToFacesData
trim to faces
svxSplitWithCrvData
struct svxSplitWithCrvData svxSplitWithCrvData
split with curve data
svxExtendData
struct svxExtendData svxExtendData
template command Extend Face data
svxRuledData
struct svxRuledData svxRuledData
ruled data
svxCircularBiRailData
struct svxCircularBiRailData svxCircularBiRailData
circular bi rail data
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::center
svxPntOnEntPath center
select the center curve
Definition: zwapi_cmd_freeform_data.h:212
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:213
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailCenter
Definition: zwapi_cmd_freeform_data.h:211
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::radius
double radius
constant radius
Definition: zwapi_cmd_freeform_data.h:201
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:202
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailConstant
Definition: zwapi_cmd_freeform_data.h:200
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle::middle
svxPntOnEntPath middle
select the middle curve
Definition: zwapi_cmd_freeform_data.h:217
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailMiddle
Definition: zwapi_cmd_freeform_data.h:216
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:206
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::pRadSet
svxRadiusSetData * pRadSet
store spines list with different radius
Definition: zwapi_cmd_freeform_data.h:208
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable::nRadSet
int nRadSet
the count of list
Definition: zwapi_cmd_freeform_data.h:207
svxCircularBiRailData::evxCircularBiRailInpUnion::CircularBiRailVariable
Definition: zwapi_cmd_freeform_data.h:205
svxCircularBiRailData::firstCrv
svxPntOnEntPath firstCrv
select the first path curve
Definition: zwapi_cmd_freeform_data.h:194
svxCircularBiRailData::method
evxCircularBiRailMethod method
method to create a new circular face (VX_CIRCULARBIRAIL_CONSTANT as default)
Definition: zwapi_cmd_freeform_data.h:193
svxCircularBiRailData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:196
svxCircularBiRailData::secondCrv
svxPntOnEntPath secondCrv
select the second path curve
Definition: zwapi_cmd_freeform_data.h:195
svxCircularBiRailData
circular bi rail data
Definition: zwapi_cmd_freeform_data.h:192
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:280
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter::center
svxPntOnEntPath center
select the center curve
Definition: zwapi_cmd_freeform_data.h:279
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailCenter
Definition: zwapi_cmd_freeform_data.h:278
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:252
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:253
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant::radius
double radius
constant radius
Definition: zwapi_cmd_freeform_data.h:251
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailConstant
Definition: zwapi_cmd_freeform_data.h:250
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::holder
svxPntOnEntPath holder
select the shoulder curve
Definition: zwapi_cmd_freeform_data.h:264
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:265
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailHolder
Definition: zwapi_cmd_freeform_data.h:263
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::holder
svxPntOnEntPath holder
select the shoulder curve
Definition: zwapi_cmd_freeform_data.h:274
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection::tangent
svxPntOnEntPath tangent
select the tangent curve
Definition: zwapi_cmd_freeform_data.h:275
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailIntersection
Definition: zwapi_cmd_freeform_data.h:273
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::tangent
svxPntOnEntPath tangent
select the tangent curve
Definition: zwapi_cmd_freeform_data.h:269
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:270
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:284
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangentEdges
Definition: zwapi_cmd_freeform_data.h:283
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailTangent
Definition: zwapi_cmd_freeform_data.h:268
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::nRadSet
int nRadSet
the count of list
Definition: zwapi_cmd_freeform_data.h:257
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::solution
int solution
multiple solutions will be displayed
Definition: zwapi_cmd_freeform_data.h:260
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::pRadSet
svxRadiusSetData * pRadSet
store spines list with different radius
Definition: zwapi_cmd_freeform_data.h:258
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable::ratio
double ratio
conic ratio
Definition: zwapi_cmd_freeform_data.h:259
svxConicBiRailData::evxConicBiRailInpUnion::ConicBiRailVariable
Definition: zwapi_cmd_freeform_data.h:256
svxConicBiRailData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:246
svxConicBiRailData::method
evxConicBiRailMethod method
method to create a new conic face (VX_CONICBIRAIL_CONSTANT as default)
Definition: zwapi_cmd_freeform_data.h:243
svxConicBiRailData::secondCrv
svxPntOnEntPath secondCrv
select the second path curve
Definition: zwapi_cmd_freeform_data.h:245
svxConicBiRailData::firstCrv
svxPntOnEntPath firstCrv
select the first path curve
Definition: zwapi_cmd_freeform_data.h:244
svxConicBiRailData
conic bi rail data
Definition: zwapi_cmd_freeform_data.h:242
svxEnlargeFaceData::applyAll
int applyAll
whether all the edges will be extended the same distance (0 as default)
Definition: zwapi_cmd_freeform_data.h:423
svxEnlargeFaceData::keepOriginal
int keepOriginal
whether to keep original face (1 as default)
Definition: zwapi_cmd_freeform_data.h:429
svxEnlargeFaceData::v0
double v0
set v0 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:427
svxEnlargeFaceData::distance
double distance
the distance to enlarge, used only when applyAll is 1
Definition: zwapi_cmd_freeform_data.h:424
svxEnlargeFaceData::idFace
int idFace
index of face to enlarge
Definition: zwapi_cmd_freeform_data.h:422
svxEnlargeFaceData::u1
double u1
set u1 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:426
svxEnlargeFaceData::extension
evxFaceExtType extension
extension type (VX_FACE_EXTENSION_LINEAR as default)
Definition: zwapi_cmd_freeform_data.h:430
svxEnlargeFaceData::v1
double v1
set v1 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:428
svxEnlargeFaceData::u0
double u0
set u0 to extend one edge, used only when applyAll is 0
Definition: zwapi_cmd_freeform_data.h:425
svxEnlargeFaceData
enlarge face data
Definition: zwapi_cmd_freeform_data.h:421
svxExplodeData::RebudEdge
int RebudEdge
flag to use Rebuild edges along boundary, 1 default
Definition: zwapi_cmd_freeform_data.h:390
svxExplodeData::pFace
int * pFace
Id list of faces to explode.
Definition: zwapi_cmd_freeform_data.h:387
svxExplodeData::ConnectFc
int ConnectFc
flag to use Group connected faces, 0 default
Definition: zwapi_cmd_freeform_data.h:389
svxExplodeData::numFace
int numFace
Number of selected faces.
Definition: zwapi_cmd_freeform_data.h:386
svxExplodeData
data of explode command
Definition: zwapi_cmd_freeform_data.h:385
svxExtendData::cntEdge
int cntEdge
count of the extend edges(0-extend all the edges of the face and the idFace must be valid
Definition: zwapi_cmd_freeform_data.h:321
svxExtendData::iExtension
int iExtension
extend method(0-liner, 1-reflect, 2-circular, 4-curvature diminishing, 0-default value)
Definition: zwapi_cmd_freeform_data.h:327
svxExtendData::pDistList
double * pDistList
the extend distance list, every edge can be extended with a different value (NULL to use fDist)
Definition: zwapi_cmd_freeform_data.h:323
svxExtendData::fDist
double fDist
the extend distance if pDistList is NULL
Definition: zwapi_cmd_freeform_data.h:324
svxExtendData::pEdgList
int * pEdgList
the edges that belonging to the face(NUll to use idFace get all the edges)
Definition: zwapi_cmd_freeform_data.h:322
svxExtendData::idFace
int idFace
id face (if idFace is 0/-1, it will get from the first edge )
Definition: zwapi_cmd_freeform_data.h:320
svxExtendData::iMerge
int iMerge
merge extended face(1-merge, 0-no, initialize 1 as the default)
Definition: zwapi_cmd_freeform_data.h:325
svxExtendData::iKeepFace
int iKeepFace
keep the original face(1-keep, 0-no, initialize 0 as the default)
Definition: zwapi_cmd_freeform_data.h:326
svxExtendData
template command Extend Face data
Definition: zwapi_cmd_freeform_data.h:319
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idEdges
int * idEdges
list of edges to extend, the edges should be the edges of the extended faces
Definition: zwapi_cmd_freeform_data.h:490
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nEdges
int nEdges
count of edges to extend
Definition: zwapi_cmd_freeform_data.h:489
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::nFaces
int nFaces
count of faces to extend
Definition: zwapi_cmd_freeform_data.h:487
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape::idFaces
int * idFaces
list of faces to extend
Definition: zwapi_cmd_freeform_data.h:488
svxExtendShapeData::evxExtendShapeInpUnion::ExtendGeneralShape
Definition: zwapi_cmd_freeform_data.h:486
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nEdges
int nEdges
count of edges to extend
Definition: zwapi_cmd_freeform_data.h:477
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::option
evxExtendFaceMethod option
extension open face option (VX_EXTEND_FACE_NONE as default)
Definition: zwapi_cmd_freeform_data.h:479
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idEdges
int * idEdges
list of edges to extend
Definition: zwapi_cmd_freeform_data.h:478
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::nFaces
int nFaces
count of faces to extend to (0 to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT
Definition: zwapi_cmd_freeform_data.h:480
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::idFaces
int * idFaces
list of faces to extend to (NULL to ignore), used only when option is VX_EXTEND_FACE_DIRECT_EDIT
Definition: zwapi_cmd_freeform_data.h:481
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::loftFaces
int loftFaces
whether to create new loft extension faces
Definition: zwapi_cmd_freeform_data.h:483
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape::createFaces
int createFaces
whether to create new linear extension faces
Definition: zwapi_cmd_freeform_data.h:482
svxExtendShapeData::evxExtendShapeInpUnion::ExtendOpenShape
Definition: zwapi_cmd_freeform_data.h:476
svxExtendShapeData::faceExtension
evxFaceExtType faceExtension
face extension type (VX_FACE_EXT_LINEAR as default)
Definition: zwapi_cmd_freeform_data.h:494
svxExtendShapeData::distance
double distance
specify the distance to extend.
Definition: zwapi_cmd_freeform_data.h:471
svxExtendShapeData::method
evxExtendShapeMethod method
method to extend shape (VX_EXTEND_OPEN_SHAPE as default)
Definition: zwapi_cmd_freeform_data.h:470
svxExtendShapeData::edgeExtension
evxEdgeExtensionType edgeExtension
edge extension type (VX_EDGE_EXTENSION_TANGENT as default)
Definition: zwapi_cmd_freeform_data.h:495
svxExtendShapeData
extend shape data
Definition: zwapi_cmd_freeform_data.h:469
svxFcsOffsetData::svxVarOffset::pntOffset
double pntOffset
offset
Definition: zwapi_cmd_freeform_data.h:310
svxFcsOffsetData::svxVarOffset::pntOnEnt
svxPntOnEnt pntOnEnt
set point on face(or edge)
Definition: zwapi_cmd_freeform_data.h:309
svxFcsOffsetData::svxVarOffset
faces offset variable data
Definition: zwapi_cmd_freeform_data.h:308
svxFcsOffsetData::offset
double offset
offset
Definition: zwapi_cmd_freeform_data.h:300
svxFcsOffsetData::cnt
int cnt
count of "list", cnt=0 to ignore
Definition: zwapi_cmd_freeform_data.h:306
svxFcsOffsetData::keepEdge
int keepEdge
1 is keep edge connectivity, else 0
Definition: zwapi_cmd_freeform_data.h:303
svxFcsOffsetData::keepSurface
int keepSurface
1 is keep original surface, else 0
Definition: zwapi_cmd_freeform_data.h:302
svxFcsOffsetData::faces
int * faces
list of face id
Definition: zwapi_cmd_freeform_data.h:299
svxFcsOffsetData::count
int count
count of "faces"
Definition: zwapi_cmd_freeform_data.h:298
svxFcsOffsetData
faces offset data
Definition: zwapi_cmd_freeform_data.h:297
svxFcsOffsetData::list
struct svxFcsOffsetData::svxVarOffset * list
NULL to ignore.
svxFilletBlendData::through
svxPntOnEntPath through
this field is available only if type = 0. select the curve or face to pass through or you can enter a...
Definition: zwapi_cmd_freeform_data.h:84
svxFilletBlendData::endWeight
double endWeight
this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND
Definition: zwapi_cmd_freeform_data.h:94
svxFilletBlendData::startWeight
double startWeight
this field is available only if croSecType = VX_CRO_SEC_G2BLEND or VX_CRO_SEC_G3BLEND
Definition: zwapi_cmd_freeform_data.h:93
svxFilletBlendData::sewingType
evxSewingType sewingType
options to modify the supporting faces
Definition: zwapi_cmd_freeform_data.h:101
svxFilletBlendData::from
svxPntOnEntPath from
select the first (from) curve or face
Definition: zwapi_cmd_freeform_data.h:82
svxFilletBlendData::croSecType
evxCroSecType croSecType
specify the arc type that will define the cross-sectional shape of the face
Definition: zwapi_cmd_freeform_data.h:91
svxFilletBlendData::idCurve
int idCurve
this field is available only if spineType = VX_SPINE_SPINE. select a curve to be used as the spine
Definition: zwapi_cmd_freeform_data.h:88
svxFilletBlendData::type
int type
whether to create an intelligent blend face with a specified radius (0 = without radius,...
Definition: zwapi_cmd_freeform_data.h:81
svxFilletBlendData::spineType
evxSpineType spineType
specify the drive curve method
Definition: zwapi_cmd_freeform_data.h:87
svxFilletBlendData::plane
svxVector plane
this field is available only if spineType = VX_SPINE_PARALLEL. select a parallel plane
Definition: zwapi_cmd_freeform_data.h:89
svxFilletBlendData::numShapes
int numShapes
this field is available only if sewShapes = 1. the number of the sewed shapes
Definition: zwapi_cmd_freeform_data.h:98
svxFilletBlendData::cappingType
evxCappingType cappingType
methods of trimming the ends of the fillets
Definition: zwapi_cmd_freeform_data.h:102
svxFilletBlendData::idShapes
int * idShapes
this field is available only if sewShapes = 1. the shapes to be sewed
Definition: zwapi_cmd_freeform_data.h:99
svxFilletBlendData::radius
double radius
this field is available only if type = 1. if Blend with a Radius is selected, use this to specify the...
Definition: zwapi_cmd_freeform_data.h:85
svxFilletBlendData::to
svxPntOnEntPath to
select the second (to) curve or face
Definition: zwapi_cmd_freeform_data.h:83
svxFilletBlendData::conicRatio
double conicRatio
this field is available only if croSecType = VX_CRO_SEC_CONIC (the range of 0 - 1....
Definition: zwapi_cmd_freeform_data.h:92
svxFilletBlendData::sewShapes
int sewShapes
whether to sew the shapes automatically (0 = not sew, 1 = sew. default = 1) since R2024,...
Definition: zwapi_cmd_freeform_data.h:96
svxFilletBlendData
freeForm filletBlend data
Definition: zwapi_cmd_freeform_data.h:79
svxNSidedData::pShape
int * pShape
index of the shapes, valid if sewShape set to 1, can be ignored
Definition: zwapi_cmd_freeform_data.h:129
svxNSidedData::pCrv
int * pCrv
id of curves
Definition: zwapi_cmd_freeform_data.h:124
svxNSidedData::refit
evxRefitOpt refit
enum for Refit options, 0 = no, 1 = tangent , 2 = curvature, 3 = direct (default)
Definition: zwapi_cmd_freeform_data.h:131
svxNSidedData::sewShape
int sewShape
flag to sew shapes or not. 1 = to sew , (default) since R2024, it doesn't sew the new shapes and if u...
Definition: zwapi_cmd_freeform_data.h:126
svxNSidedData::tangent
int tangent
tangent at boundary , 0 = no (default), 1 = tangent
Definition: zwapi_cmd_freeform_data.h:130
svxNSidedData::pCrvParent
int * pCrvParent
parent index of curves (-1/NULL to ignore)
Definition: zwapi_cmd_freeform_data.h:125
svxNSidedData::numShape
int numShape
count of the shapes, valid if sewShape set to 1, can be ignored
Definition: zwapi_cmd_freeform_data.h:128
svxNSidedData::numCrv
int numCrv
count of the paths
Definition: zwapi_cmd_freeform_data.h:123
svxNSidedData::dTol
double dTol
Tolerance, 0.01 (default)
Definition: zwapi_cmd_freeform_data.h:132
svxNSidedData
template command N-sided data
Definition: zwapi_cmd_freeform_data.h:122
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxRadiusSetData::idCurve
int idCurve
set the curve
Definition: zwapi_cmd_freeform_data.h:181
svxRadiusSetData::radius
double radius
set the radius
Definition: zwapi_cmd_freeform_data.h:183
svxRadiusSetData::radiusFlat
int radiusFlat
whether to mark the radius as flat
Definition: zwapi_cmd_freeform_data.h:184
svxRadiusSetData::pnt
svxPntOnEntPath pnt
set the point
Definition: zwapi_cmd_freeform_data.h:182
svxRadiusSetData
radius set data
Definition: zwapi_cmd_freeform_data.h:180
svxRuledData::secondCrv
svxPntOnEntPath secondCrv
select the second curve
Definition: zwapi_cmd_freeform_data.h:158
svxRuledData::firstCrv
svxPntOnEntPath firstCrv
select the first curve
Definition: zwapi_cmd_freeform_data.h:157
svxRuledData::spineCrv
svxPntOnEntPath spineCrv
select the spine curve
Definition: zwapi_cmd_freeform_data.h:159
svxRuledData::trimPlane
int trimPlane
whether to attempt trimmed plane (1 as default)
Definition: zwapi_cmd_freeform_data.h:160
svxRuledData
ruled data
Definition: zwapi_cmd_freeform_data.h:156
svxSewData::forceClose
char forceClose
force object to sew into solid
Definition: zwapi_cmd_freeform_data.h:401
svxSewData::multEdg
char multEdg
enable multiple edge matching or not
Definition: zwapi_cmd_freeform_data.h:400
svxSewData::tol
double tol
tolerance value, default(0.01)
Definition: zwapi_cmd_freeform_data.h:399
svxSewData
faces sew data
Definition: zwapi_cmd_freeform_data.h:398
svxSplitWithCrvData::explodeEdges
int explodeEdges
whether all new edges will be unsewn from the shape (0 as default)
Definition: zwapi_cmd_freeform_data.h:510
svxSplitWithCrvData::direction
svxVector direction
projection direction, used when prjMethod is VX_TRIMCRV_DIRECTED or VX_TRIMCRV_BI_DIRECTIONAL
Definition: zwapi_cmd_freeform_data.h:509
svxSplitWithCrvData::removeSpurs
int removeSpurs
whether to remove the excess spurs and face edges (1 as default)
Definition: zwapi_cmd_freeform_data.h:512
svxSplitWithCrvData::nCrvs
int nCrvs
count of split curves (0 to use intersecting curves to split faces)
Definition: zwapi_cmd_freeform_data.h:506
svxSplitWithCrvData::idCrvs
int * idCrvs
list of split curves (NULL to use intersecting curves to split faces)
Definition: zwapi_cmd_freeform_data.h:507
svxSplitWithCrvData::nFaces
int nFaces
count of faces or shapes to split
Definition: zwapi_cmd_freeform_data.h:504
svxSplitWithCrvData::prjMethod
evxTrimCrvsProjtype prjMethod
method to project the trimming curves onto the subject faces (VX_TRIMCRV_IN_PLACE as default)
Definition: zwapi_cmd_freeform_data.h:508
svxSplitWithCrvData::idFaces
int * idFaces
list of faces or shapes to split
Definition: zwapi_cmd_freeform_data.h:505
svxSplitWithCrvData::extendCrvs
int extendCrvs
whether to automatically extend trim curves to boundary (0 as default)
Definition: zwapi_cmd_freeform_data.h:511
svxSplitWithCrvData
split with curve data
Definition: zwapi_cmd_freeform_data.h:503
svxTrimPlnData::idPlane
int idPlane
id of reference plane(-1/0 to ignore)
Definition: zwapi_cmd_freeform_data.h:147
svxTrimPlnData::pBooolList
int * pBooolList
list boolean shapes(null to ignore)
Definition: zwapi_cmd_freeform_data.h:146
svxTrimPlnData::cntBool
int cntBool
count of boolean shapes(0 to ignore)
Definition: zwapi_cmd_freeform_data.h:145
svxTrimPlnData::pCrvList
int * pCrvList
input curve id list(required)
Definition: zwapi_cmd_freeform_data.h:142
svxTrimPlnData::sew
char sew
flag of sew or not(1-sew, else 0)
Definition: zwapi_cmd_freeform_data.h:144
svxTrimPlnData::cntCrv
int cntCrv
count of input curve(required)
Definition: zwapi_cmd_freeform_data.h:141
svxTrimPlnData::idProf
int idProf
id of profile if pCrvList are 2d curves, else -1/0 as the initialized value
Definition: zwapi_cmd_freeform_data.h:143
svxTrimPlnData
template command Trimmed Plane data
Definition: zwapi_cmd_freeform_data.h:140
svxTrimToCurvesData::cntPnts
int cntPnts
count of sides
Definition: zwapi_cmd_freeform_data.h:370
svxTrimToCurvesData::toKeep
int toKeep
0 is faces to keep, 1 is faces to remove
Definition: zwapi_cmd_freeform_data.h:369
svxTrimToCurvesData::projection
evxTrimCrvsProjtype projection
projection
Definition: zwapi_cmd_freeform_data.h:374
svxTrimToCurvesData::idFaces
int * idFaces
list of id face
Definition: zwapi_cmd_freeform_data.h:366
svxTrimToCurvesData::isExtend
int isExtend
1 is extend curves to boundary, else 0
Definition: zwapi_cmd_freeform_data.h:377
svxTrimToCurvesData::isCheckerboard
int isCheckerboard
1 is trim to checkerboard, else 0
Definition: zwapi_cmd_freeform_data.h:376
svxTrimToCurvesData::cntCrvs
int cntCrvs
count of idCurves
Definition: zwapi_cmd_freeform_data.h:367
svxTrimToCurvesData::dirction
svxVector * dirction
direction, NULL to ignore
Definition: zwapi_cmd_freeform_data.h:375
svxTrimToCurvesData::sides
svxPntOnEnt * sides
point on ent
Definition: zwapi_cmd_freeform_data.h:371
svxTrimToCurvesData::cntFcs
int cntFcs
count of idFaces
Definition: zwapi_cmd_freeform_data.h:365
svxTrimToCurvesData::idCurves
int * idCurves
list of id curve
Definition: zwapi_cmd_freeform_data.h:368
svxTrimToCurvesData
template command Trim to Curves input data
Definition: zwapi_cmd_freeform_data.h:364
svxTrimToFacesData::pFace
int * pFace
Id list of faces to Trim.
Definition: zwapi_cmd_freeform_data.h:337
svxTrimToFacesData::pTrimming
int * pTrimming
Id list of trimming entities.
Definition: zwapi_cmd_freeform_data.h:339
svxTrimToFacesData::TrimWith
int TrimWith
flag to use "Trim with all simultaneously", 0 default
Definition: zwapi_cmd_freeform_data.h:342
svxTrimToFacesData::numTrimming
int numTrimming
Number of trimming entities.
Definition: zwapi_cmd_freeform_data.h:338
svxTrimToFacesData::numFace
int numFace
Number of faces to Trim.
Definition: zwapi_cmd_freeform_data.h:336
svxTrimToFacesData::FlipSide
int FlipSide
flag to use "Flip side to keep", 0 default
Definition: zwapi_cmd_freeform_data.h:341
svxTrimToFacesData::ExtendTrimming
int ExtendTrimming
flag to use "Extend trimming faces", 0 default
Definition: zwapi_cmd_freeform_data.h:343
svxTrimToFacesData::KeepTrimming
int KeepTrimming
flag to use "Keep trimming faces", 1 default
Definition: zwapi_cmd_freeform_data.h:344
svxTrimToFacesData
trim to faces
Definition: zwapi_cmd_freeform_data.h:335
svxVector
3D vector
Definition: zwapi_util.h:338
svxCircularBiRailData::evxCircularBiRailInpUnion
Definition: zwapi_cmd_freeform_data.h:198
svxConicBiRailData::evxConicBiRailInpUnion
Definition: zwapi_cmd_freeform_data.h:248
svxExtendShapeData::evxExtendShapeInpUnion
Definition: zwapi_cmd_freeform_data.h:474
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PARAM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_paramdefine_param.h
cvxAuxFrameSetAxisVec
cvxAuxFrameSetDirXYZOrgBuddy
cvxAuxFrameSetOrigin
cvxAuxFrameShow
cvxDataClear
cvxDataDel
cvxDataDelItem
cvxDataDelUnHi
cvxDataFree
cvxDataGet
cvxDataGetAll
cvxDataGetColor
cvxDataGetEnt
cvxDataGetEnts
cvxDataGetItemData
cvxDataGetItemList
cvxDataGetList
cvxDataGetMatrix
cvxDataGetNum
cvxDataGetOpt
cvxDataGetPath
cvxDataGetPaths
cvxDataGetPnt
cvxDataGetPntOnEnt
cvxDataGetPnts
cvxDataGetPntsOnEnts
cvxDataGetPromote
cvxDataGetText
cvxDataGrpRem
cvxDataInit
cvxDataInqActive
cvxDataInqParent
cvxDataName
cvxDataSet
cvxDataSetColor
cvxDataSetDirOnEntPath
cvxDataSetMatrix
cvxDataSetPath
cvxDataSetPntByPath
cvxDataSetPntOnCrv
cvxDataSetPntOnCrvPath
cvxDataSetPntOnEnt
cvxDataSetPntOnEntPath
cvxDataSetPntOnFace
cvxDataSetPntOnFace2
cvxDataSetPromote
cvxDataToFeature
cvxDataZero
cvxFldDataFree
cvxMoveSetAuxFrameElem

◆ ZW_API_PARAM_H

#define ZW_API_PARAM_H

Definition at line 15 of file zwapi_cmd_paramdefine_param.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_paramdefine_param.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_paramdefine_param.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PARAM_H /* this ifndef surrounds entire header */
15#define ZW_API_PARAM_H
16
17#include "zwapi_cmd_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22//====================================================================================================================
24//====================================================================================================================
25/******************************************************************************/
42extern evxErrors cvxDataInit(const vxName Template, int* idData);
43
44//====================================================================================================================
46//====================================================================================================================
47/******************************************************************************/
58extern void cvxDataZero(svxData* Data);
59
60/******************************************************************************/
85extern evxErrors cvxDataSet(int idData, int idField, svxData* Data);
86
87/******************************************************************************/
105extern evxErrors cvxDataSetColor(int idData, int idField, svxColor* Color);
106
107/******************************************************************************/
123extern evxErrors cvxDataSetPath(int idData, int idField, svxEntPath* Ent);
124
125/******************************************************************************/
149extern evxErrors cvxDataSetPromote(int idData, int idField, int Promote);
150
151/******************************************************************************/
174extern evxErrors cvxDataSetPntOnCrv(int idData, int idField, int idCrv, svxPoint* Pnt);
175
176/******************************************************************************/
195extern evxErrors cvxDataSetPntOnFace(int idData, int idField, int idComp, int idFace);
196
197/******************************************************************************/
217extern evxErrors cvxDataSetPntOnFace2(int idData, int idField, int idFace, svxPoint* Pnt);
218
219/******************************************************************************/
247extern evxErrors cvxDataSetPntByPath(int idData, int idField, svxEntPath* entPath, svxPoint* pnt);
248
249/******************************************************************************/
275extern evxErrors cvxDataSetPntOnCrvPath(int idData, int idField, int critPnt, const svxEntPath* crvPath, const svxPoint* pnt);
276
277/******************************************************************************/
298extern evxErrors cvxDataSetPntOnEnt(int idData, int idField, const svxPntOnEnt* pntData);
299
300/******************************************************************************/
321extern evxErrors cvxDataSetPntOnEntPath(int idData, int idField, const svxPntOnEntPath* pntData);
322
323/******************************************************************************/
344extern evxErrors cvxDataSetDirOnEntPath(int idData, int idField, const svxDirOnEntPath* dirData);
345
346/******************************************************************************/
362extern evxErrors cvxDataSetMatrix(int idData, int idField, const svxMatrix* mat);
363
364/******************************************************************************/
401extern evxErrors cvxDataToFeature(int idData, int idFeature, int ExcludeRegen);
402
403
404//====================================================================================================================
406//====================================================================================================================
407/******************************************************************************/
444extern evxErrors cvxDataGet(int idData, int idField, svxData* Data);
445
446/******************************************************************************/
464extern evxErrors cvxDataGetColor(int idData, int idField, svxColor* Color);
465
466/******************************************************************************/
486extern evxErrors cvxDataGetEnt(int idData, int idField, int* idEnt, int* idParent);
487
488/******************************************************************************/
510extern evxErrors cvxDataGetEnts(int idData, int idField, int* Count, int** idEnts);
511
512/******************************************************************************/
539extern evxErrors cvxDataGetList(int idData, int idField, int* Count, svxData** Data);
540
541/******************************************************************************/
558extern evxErrors cvxDataGetNum(int idData, int idField, double* Number);
559
560/******************************************************************************/
575extern int cvxDataGetOpt(int idData, int idField);
576
577/******************************************************************************/
612extern int cvxDataGetPath(int idData, int idField, int* FirstEnt, svxEntPath* Ent);
613
614/******************************************************************************/
636extern evxErrors cvxDataGetPaths(int idData, int idField, int* count, svxEntPath** paths);
637
638/******************************************************************************/
655extern evxErrors cvxDataGetPnt(int idData, int idField, svxPoint* Pnt);
656
657/******************************************************************************/
680extern evxErrors cvxDataGetPnts(int idData, int idField, int* Count, svxPoint** Pnts);
681
682/******************************************************************************/
702extern evxErrors cvxDataGetPntOnEnt(int idData, int idField, svxPoint* pnt, svxEntPath* path);
703
704/******************************************************************************/
729extern evxErrors cvxDataGetPntsOnEnts(int idData, int idField, int* count, svxPoint** pnts, svxEntPath** paths);
730
731/******************************************************************************/
754extern evxErrors cvxDataGetPromote(int idData, int idField, int* Promote);
755
756/******************************************************************************/
789extern evxErrors cvxDataGetText(int idData, int idField, int NumBytes, char* Text);
790
791/******************************************************************************/
809extern evxErrors cvxDataGetMatrix(int idData, int idField, svxMatrix* Matrix);
810
811/******************************************************************************/
834extern evxErrors cvxDataGetItemList(int idData, int idField, int* Count, int** idItems);
835
836/******************************************************************************/
852extern evxErrors cvxDataGetItemData(int idItem, svxData* Data);
853
854/******************************************************************************/
880extern evxErrors cvxDataGetAll(int idData, int* numFld, svxFldData** fldData);
881
882/******************************************************************************/
894extern void cvxFldDataFree(int Count, svxFldData** fldData);
895
896
897//====================================================================================================================
899//====================================================================================================================
900/******************************************************************************/
915extern evxErrors cvxDataClear(int idData, int idField);
916
917/******************************************************************************/
932extern evxErrors cvxDataDel(int idData, int idField);
933
934/******************************************************************************/
951extern evxErrors cvxDataDelItem(int idData, int idField, int iEnt);
952
953/******************************************************************************/
968extern evxErrors cvxDataDelUnHi(int idData, int idField);
969
970/******************************************************************************/
984extern evxErrors cvxDataFree(int idData);
985
986/******************************************************************************/
1003extern evxErrors cvxDataGrpRem(int idData, int idField, int idItem);
1004
1005
1006//====================================================================================================================
1008//====================================================================================================================
1009/******************************************************************************/
1022extern evxErrors cvxDataInqActive(int* idData);
1023
1024/******************************************************************************/
1038extern evxErrors cvxDataInqParent(int* idData);
1039
1040/******************************************************************************/
1053extern char* cvxDataName(int idData);
1054
1055
1056//====================================================================================================================
1058//====================================================================================================================
1059/******************************************************************************/
1074extern void cvxAuxFrameShow(int idData, int entField, int matField);
1075
1076/******************************************************************************/
1087extern void cvxAuxFrameSetOrigin(const svxPoint* Origin);
1088
1089/******************************************************************************/
1101extern void cvxAuxFrameSetAxisVec(evxAxisType AxisType, const svxVector* AxisDir);
1102
1103/******************************************************************************/
1118extern void cvxAuxFrameSetDirXYZOrgBuddy(int idData, int idXFld, int idYFld, int idZFld, int idOrgFld);
1119
1120/******************************************************************************/
1139extern void cvxMoveSetAuxFrameElem(int iElem);
1140
1141
1142/*
1143*********************************************************************
1144** END HEADER FILE
1145*********************************************************************
1146*/
1147
1148#ifdef __cplusplus
1149 }
1150#endif /* __cplusplus */
1151
1152#endif /* ZW_API_PARAM_H */
cvxDataGetText
evxErrors cvxDataGetText(int idData, int idField, int NumBytes, char *Text)
cvxDataClear
evxErrors cvxDataClear(int idData, int idField)
cvxDataInit
evxErrors cvxDataInit(const vxName Template, int *idData)
cvxDataGetPromote
evxErrors cvxDataGetPromote(int idData, int idField, int *Promote)
cvxDataGetPnt
evxErrors cvxDataGetPnt(int idData, int idField, svxPoint *Pnt)
cvxDataSetPntOnCrvPath
evxErrors cvxDataSetPntOnCrvPath(int idData, int idField, int critPnt, const svxEntPath *crvPath, const svxPoint *pnt)
cvxDataSetMatrix
evxErrors cvxDataSetMatrix(int idData, int idField, const svxMatrix *mat)
cvxDataGetOpt
int cvxDataGetOpt(int idData, int idField)
cvxDataSetPntOnFace2
evxErrors cvxDataSetPntOnFace2(int idData, int idField, int idFace, svxPoint *Pnt)
cvxDataName
char * cvxDataName(int idData)
cvxDataGetEnt
evxErrors cvxDataGetEnt(int idData, int idField, int *idEnt, int *idParent)
cvxDataSetPntByPath
evxErrors cvxDataSetPntByPath(int idData, int idField, svxEntPath *entPath, svxPoint *pnt)
cvxDataSetPntOnFace
evxErrors cvxDataSetPntOnFace(int idData, int idField, int idComp, int idFace)
cvxDataGrpRem
evxErrors cvxDataGrpRem(int idData, int idField, int idItem)
cvxDataInqParent
evxErrors cvxDataInqParent(int *idData)
cvxDataSetPntOnEnt
evxErrors cvxDataSetPntOnEnt(int idData, int idField, const svxPntOnEnt *pntData)
cvxDataGet
evxErrors cvxDataGet(int idData, int idField, svxData *Data)
cvxDataSetPath
evxErrors cvxDataSetPath(int idData, int idField, svxEntPath *Ent)
cvxDataGetItemList
evxErrors cvxDataGetItemList(int idData, int idField, int *Count, int **idItems)
cvxDataToFeature
evxErrors cvxDataToFeature(int idData, int idFeature, int ExcludeRegen)
cvxAuxFrameSetDirXYZOrgBuddy
void cvxAuxFrameSetDirXYZOrgBuddy(int idData, int idXFld, int idYFld, int idZFld, int idOrgFld)
cvxDataDel
evxErrors cvxDataDel(int idData, int idField)
cvxDataGetAll
evxErrors cvxDataGetAll(int idData, int *numFld, svxFldData **fldData)
cvxDataGetNum
evxErrors cvxDataGetNum(int idData, int idField, double *Number)
cvxDataGetColor
evxErrors cvxDataGetColor(int idData, int idField, svxColor *Color)
cvxAuxFrameSetAxisVec
void cvxAuxFrameSetAxisVec(evxAxisType AxisType, const svxVector *AxisDir)
cvxDataSet
evxErrors cvxDataSet(int idData, int idField, svxData *Data)
cvxDataSetPromote
evxErrors cvxDataSetPromote(int idData, int idField, int Promote)
cvxDataInqActive
evxErrors cvxDataInqActive(int *idData)
cvxAuxFrameShow
void cvxAuxFrameShow(int idData, int entField, int matField)
cvxDataGetItemData
evxErrors cvxDataGetItemData(int idItem, svxData *Data)
cvxDataSetDirOnEntPath
evxErrors cvxDataSetDirOnEntPath(int idData, int idField, const svxDirOnEntPath *dirData)
cvxDataGetMatrix
evxErrors cvxDataGetMatrix(int idData, int idField, svxMatrix *Matrix)
cvxDataGetEnts
evxErrors cvxDataGetEnts(int idData, int idField, int *Count, int **idEnts)
cvxDataZero
void cvxDataZero(svxData *Data)
cvxDataSetPntOnEntPath
evxErrors cvxDataSetPntOnEntPath(int idData, int idField, const svxPntOnEntPath *pntData)
cvxDataGetPath
int cvxDataGetPath(int idData, int idField, int *FirstEnt, svxEntPath *Ent)
cvxDataFree
evxErrors cvxDataFree(int idData)
cvxDataDelUnHi
evxErrors cvxDataDelUnHi(int idData, int idField)
cvxDataGetList
evxErrors cvxDataGetList(int idData, int idField, int *Count, svxData **Data)
cvxAuxFrameSetOrigin
void cvxAuxFrameSetOrigin(const svxPoint *Origin)
cvxDataSetPntOnCrv
evxErrors cvxDataSetPntOnCrv(int idData, int idField, int idCrv, svxPoint *Pnt)
cvxDataSetColor
evxErrors cvxDataSetColor(int idData, int idField, svxColor *Color)
cvxDataGetPntsOnEnts
evxErrors cvxDataGetPntsOnEnts(int idData, int idField, int *count, svxPoint **pnts, svxEntPath **paths)
cvxDataGetPntOnEnt
evxErrors cvxDataGetPntOnEnt(int idData, int idField, svxPoint *pnt, svxEntPath *path)
cvxDataDelItem
evxErrors cvxDataDelItem(int idData, int idField, int iEnt)
cvxDataGetPaths
evxErrors cvxDataGetPaths(int idData, int idField, int *count, svxEntPath **paths)
cvxMoveSetAuxFrameElem
void cvxMoveSetAuxFrameElem(int iElem)
cvxDataGetPnts
evxErrors cvxDataGetPnts(int idData, int idField, int *Count, svxPoint **Pnts)
cvxFldDataFree
void cvxFldDataFree(int Count, svxFldData **fldData)
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxData
command input data item
Definition: zwapi_util.h:1555
svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
Definition: zwapi_util.h:590
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxFldData
field data
Definition: zwapi_cmd_data.h:152
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TPL_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_paramdefine_tpl.h
cvxCmdEval
cvxCmdExec
cvxCmdExec2
cvxCmdExecWithOut
cvxCmdInput
cvxCmdInqActive
cvxCmdInteract
cvxCmdMarker
cvxCmdStateGet
cvxCmdStateSet
cvxCmdTemplate
cvxCmdTemplateUnload
cvxEchoColorAtGet
cvxEchoColorAtSet
cvxEchoColorGet
cvxEchoColorSet
cvxEchoCustomEnd
cvxEchoCustomStart
cvxEchoDraw
cvxEchoEnd
cvxEchoEscDisable
cvxEchoEscRestore
cvxEchoStart
cvxTplInqFnCust
cvxTplInqFnEcho
cvxTplInqFnInit
cvxTplInqFnTerm

◆ ZW_API_TPL_H

#define ZW_API_TPL_H

Definition at line 15 of file zwapi_cmd_paramdefine_tpl.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_paramdefine_tpl.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_paramdefine_tpl.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TPL_H /* this ifndef surrounds entire header */
15#define ZW_API_TPL_H
16
17#include "zwapi_cmd_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
61extern int cvxCmdEval(vxName Name, int idData);
62
63/******************************************************************************/
94extern int cvxCmdExec(int idData);
95
96/******************************************************************************/
110extern evxErrors cvxCmdExec2(int idData);
111
112/******************************************************************************/
126extern evxErrors cvxCmdExecWithOut(int idData, int* idOut);
127
128//====================================================================================================================
130//====================================================================================================================
131/******************************************************************************/
158extern evxErrors cvxCmdInput(const vxName Name, int idDataIn, int* idDataOut);
159
160/******************************************************************************/
177extern evxErrors cvxCmdInteract(const vxName Name);
178
179/******************************************************************************/
190extern void cvxCmdInqActive(vxName Name);
191
192/******************************************************************************/
217extern void cvxCmdMarker(const vxName Okay, const vxName Cancel);
218
219/******************************************************************************/
234extern evxErrors cvxCmdStateGet(vxName CmdName, evxCmdState* State);
235
236/******************************************************************************/
250extern evxErrors cvxCmdStateSet(vxName CmdName, evxCmdState State);
251
252
253//====================================================================================================================
255//====================================================================================================================
256/******************************************************************************/
311extern evxErrors cvxCmdTemplate(const vxLongPath File);
312
313/******************************************************************************/
329extern evxErrors cvxCmdTemplateUnload(const vxLongPath File);
330
331//====================================================================================================================
333//====================================================================================================================
334/******************************************************************************/
345extern void cvxEchoColorGet(evxColor* Color);
346
347/******************************************************************************/
357extern void cvxEchoColorSet(evxColor Color);
358
359/******************************************************************************/
370extern void cvxEchoColorAtSet(svxWireAt* at);
371
372/******************************************************************************/
383extern void cvxEchoColorAtGet(svxWireAt* at);
384
385/******************************************************************************/
428extern void cvxEchoCustomStart();
429
430/******************************************************************************/
439extern void cvxEchoCustomEnd();
440
441/******************************************************************************/
447extern void cvxEchoDraw();
448
449/******************************************************************************/
461extern void cvxEchoStart();
462
463/******************************************************************************/
474extern void cvxEchoEnd();
475
476/******************************************************************************/
499extern void cvxEchoEscDisable();
500
501/******************************************************************************/
508extern void cvxEchoEscRestore();
509
510
511//====================================================================================================================
513//====================================================================================================================
514/******************************************************************************/
531extern evxErrors cvxTplInqFnCust(vxName Name, int NumBytes, char* FnName);
532
533/******************************************************************************/
550extern evxErrors cvxTplInqFnEcho(vxName Name, int NumBytes, char* FnName);
551
552/******************************************************************************/
569extern evxErrors cvxTplInqFnInit(vxName Name, int NumBytes, char* FnName);
570
571/******************************************************************************/
588extern evxErrors cvxTplInqFnTerm(vxName Name, int NumBytes, char* FnName);
589
590/*
591*********************************************************************
592** END HEADER FILE
593*********************************************************************
594*/
595
596#ifdef __cplusplus
597 }
598#endif /* __cplusplus */
599
600#endif /* ZW_API_TPL_H */
evxCmdState
evxCmdState
command state type
Definition: zwapi_cmd_data.h:61
cvxCmdInqActive
void cvxCmdInqActive(vxName Name)
cvxEchoDraw
void cvxEchoDraw()
cvxCmdStateSet
evxErrors cvxCmdStateSet(vxName CmdName, evxCmdState State)
cvxEchoColorAtSet
void cvxEchoColorAtSet(svxWireAt *at)
cvxEchoEnd
void cvxEchoEnd()
cvxEchoColorAtGet
void cvxEchoColorAtGet(svxWireAt *at)
cvxCmdTemplateUnload
evxErrors cvxCmdTemplateUnload(const vxLongPath File)
cvxTplInqFnCust
evxErrors cvxTplInqFnCust(vxName Name, int NumBytes, char *FnName)
cvxCmdMarker
void cvxCmdMarker(const vxName Okay, const vxName Cancel)
cvxEchoStart
void cvxEchoStart()
cvxEchoColorGet
void cvxEchoColorGet(evxColor *Color)
cvxEchoCustomStart
void cvxEchoCustomStart()
cvxCmdExec
int cvxCmdExec(int idData)
cvxCmdStateGet
evxErrors cvxCmdStateGet(vxName CmdName, evxCmdState *State)
cvxEchoEscRestore
void cvxEchoEscRestore()
cvxCmdExec2
evxErrors cvxCmdExec2(int idData)
cvxTplInqFnEcho
evxErrors cvxTplInqFnEcho(vxName Name, int NumBytes, char *FnName)
cvxEchoEscDisable
void cvxEchoEscDisable()
cvxCmdTemplate
evxErrors cvxCmdTemplate(const vxLongPath File)
cvxCmdExecWithOut
evxErrors cvxCmdExecWithOut(int idData, int *idOut)
cvxCmdInteract
evxErrors cvxCmdInteract(const vxName Name)
cvxCmdInput
evxErrors cvxCmdInput(const vxName Name, int idDataIn, int *idDataOut)
cvxEchoCustomEnd
void cvxEchoCustomEnd()
cvxTplInqFnInit
evxErrors cvxTplInqFnInit(vxName Name, int NumBytes, char *FnName)
cvxTplInqFnTerm
evxErrors cvxTplInqFnTerm(vxName Name, int NumBytes, char *FnName)
cvxCmdEval
int cvxCmdEval(vxName Name, int idData)
cvxEchoColorSet
void cvxEchoColorSet(evxColor Color)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxWireAt
wire display attributes
Definition: zwapi_util.h:1188
zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PMI_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_pmi.h
cvxPartAddAngleDim
cvxPartAddArcDim
cvxPartAddBalloon
cvxPartAddCenLinDim
cvxPartAddCenMarkDim
cvxPartAddChamferDim
cvxPartAddCoorDim
cvxPartAddDatumDim
cvxPartAddDatumTargetDim
cvxPartAddFcsDim
cvxPartAddLabelDim
cvxPartAddLineDim
cvxPartAddPMIText
cvxPartAddRadDim
cvxPartAddSymmetryDim
cvxPartAddSymSrfDim

◆ ZW_API_PMI_H

#define ZW_API_PMI_H

Definition at line 15 of file zwapi_cmd_pmi.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_pmi.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_pmi.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PMI_H /* this ifndef surrounds entire header */
15#define ZW_API_PMI_H
16
17#include "zwapi_cmd_pmi_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
51extern evxErrors cvxPartAddLineDim(int idEnt1, int idEnt2, const svxPoint* TextPnt, int idPlane, int* idDim);
52
53/******************************************************************************/
77extern evxErrors cvxPartAddSymmetryDim(svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int* idDim);
78
79/******************************************************************************/
104extern evxErrors cvxPartAddAngleDim(int idEnt1, int idEnt2, const svxPoint* TextPnt, int idPlane, int* idDim);
105
106/******************************************************************************/
131extern evxErrors cvxPartAddRadDim(int idEnt, int radType, const char* text, const svxPoint* TextPnt, int idPlane, int* idDim);
132
133/******************************************************************************/
158extern evxErrors cvxPartAddChamferDim(int idEnt1, int idEnt2, const svxPoint* TextPos, int idPlane, int* idDim);
159
160/******************************************************************************/
184extern evxErrors cvxPartAddArcDim(int idEnt, const char* text, const svxPoint* TextPnt, int idPlane, int* idDim);
185
186
187//====================================================================================================================
189//====================================================================================================================
190/******************************************************************************/
217extern evxErrors cvxPartAddCoorDim(svxPoint* LeaderPnt, int idParent, const svxPoint* TextPnt, int idDatum, int idPlane, int* idDim);
218
219/******************************************************************************/
246extern evxErrors cvxPartAddLabelDim(int idEnt, svxPoint* leadPnt, const svxPoint* TextPnt, char* text, int idPlane, int* idDim);
247
248/******************************************************************************/
273extern evxErrors cvxPartAddDatumDim(int idEnt, svxPoint* leadPnt, const svxPoint* TextPnt, char* text, int idPlane, int* idDim);
274
275/******************************************************************************/
304extern evxErrors cvxPartAddDatumTargetDim(int idEnt, int radRype, double diameter, double width, double height, svxPoint* leadPnt, const svxPoint* TextPnt, char* text, int idPlane, int* idDim);
305
306/******************************************************************************/
331extern evxErrors cvxPartAddFcsDim(int idEnt, svxPoint* leadPnt, const svxPoint* TextPnt, char* text, int idPlane, int* idDim);
332
333/******************************************************************************/
359extern evxErrors cvxPartAddSymSrfDim(int idEnt, svxPoint* leadPnt, const svxPoint* TextPnt, svxRoughTexts* textGrp, int idPlane, int* idDim);
360
361/******************************************************************************/
383extern evxErrors cvxPartAddCenLinDim(int idEnt, int idPlane, int* idDim);
384
385/******************************************************************************/
407extern evxErrors cvxPartAddCenMarkDim(int idEnt, int idPlane, int* idDim);
408
409
410//====================================================================================================================
412//====================================================================================================================
413/******************************************************************************/
435extern evxErrors cvxPartAddPMIText(svxPoint* TextPnt, char* text, int idPlane, int* idDim);
436
437/******************************************************************************/
460extern evxErrors cvxPartAddBalloon(svxPoint* TextPnt, char* text, int fImage, int idPlane, int* idDim);
461
462
463/*
464*********************************************************************
465** END HEADER FILE
466*********************************************************************
467*/
468
469#ifdef __cplusplus
470 }
471#endif /* __cplusplus */
472
473#endif /* ZW_API_PMI_H */
cvxPartAddRadDim
evxErrors cvxPartAddRadDim(int idEnt, int radType, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddArcDim
evxErrors cvxPartAddArcDim(int idEnt, const char *text, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddBalloon
evxErrors cvxPartAddBalloon(svxPoint *TextPnt, char *text, int fImage, int idPlane, int *idDim)
cvxPartAddSymSrfDim
evxErrors cvxPartAddSymSrfDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, svxRoughTexts *textGrp, int idPlane, int *idDim)
cvxPartAddSymmetryDim
evxErrors cvxPartAddSymmetryDim(svxPntOnEnt iEntId, svxPntOnEnt iCenterLineId, svxPntOnEnt TextPnt, int idPlane, int *idDim)
cvxPartAddFcsDim
evxErrors cvxPartAddFcsDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddCoorDim
evxErrors cvxPartAddCoorDim(svxPoint *LeaderPnt, int idParent, const svxPoint *TextPnt, int idDatum, int idPlane, int *idDim)
cvxPartAddPMIText
evxErrors cvxPartAddPMIText(svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddLabelDim
evxErrors cvxPartAddLabelDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddCenLinDim
evxErrors cvxPartAddCenLinDim(int idEnt, int idPlane, int *idDim)
cvxPartAddCenMarkDim
evxErrors cvxPartAddCenMarkDim(int idEnt, int idPlane, int *idDim)
cvxPartAddDatumTargetDim
evxErrors cvxPartAddDatumTargetDim(int idEnt, int radRype, double diameter, double width, double height, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
cvxPartAddAngleDim
evxErrors cvxPartAddAngleDim(int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddLineDim
evxErrors cvxPartAddLineDim(int idEnt1, int idEnt2, const svxPoint *TextPnt, int idPlane, int *idDim)
cvxPartAddChamferDim
evxErrors cvxPartAddChamferDim(int idEnt1, int idEnt2, const svxPoint *TextPos, int idPlane, int *idDim)
cvxPartAddDatumDim
evxErrors cvxPartAddDatumDim(int idEnt, svxPoint *leadPnt, const svxPoint *TextPnt, char *text, int idPlane, int *idDim)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxRoughTexts
Roughness PMI text define.
Definition: zwapi_cmd_pmi_data.h:31
zwapi_cmd_pmi_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PMI_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_pmi_data.h
svxRoughTexts

◆ ZW_API_PMI_DATA_H

#define ZW_API_PMI_DATA_H

Definition at line 17 of file zwapi_cmd_pmi_data.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_pmi_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_pmi_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_PMI_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_PMI_DATA_H
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef struct svxRoughTexts
31 {
32 char a1[65];
33 char a2[65];
34 char b[65];
35 char c[65];
36 char e[65];
37 char f1[65];
38 char f2[65];
39 char f3[65];
40 }svxRoughTexts;
41
42/*
43*********************************************************************
44** END HEADER FILE
45*********************************************************************
46*/
47
48#ifdef __cplusplus
49 }
50#endif /* __cplusplus */
51
52#endif /* ZW_API_PMI_DATA_H */
svxRoughTexts
struct svxRoughTexts svxRoughTexts
Roughness PMI text define.
svxRoughTexts::e
char e[65]
machining allowance (or =NULL)
Definition: zwapi_cmd_pmi_data.h:36
svxRoughTexts::f2
char f2[65]
other roughness value/spacing (or =NULL)
Definition: zwapi_cmd_pmi_data.h:38
svxRoughTexts::f3
char f3[65]
third row optional string (or =NULL)
Definition: zwapi_cmd_pmi_data.h:39
svxRoughTexts::a2
char a2[65]
min roughness average (or =NULL)
Definition: zwapi_cmd_pmi_data.h:33
svxRoughTexts::c
char c[65]
sampling length/roughness cutout (or =NULL)
Definition: zwapi_cmd_pmi_data.h:35
svxRoughTexts::b
char b[65]
processing method/treatment (or =NULL)
Definition: zwapi_cmd_pmi_data.h:34
svxRoughTexts::a1
char a1[65]
max roughness average (or =NULL)
Definition: zwapi_cmd_pmi_data.h:32
svxRoughTexts::f1
char f1[65]
Rz, roughness value (or =NULL)
Definition: zwapi_cmd_pmi_data.h:37
svxRoughTexts
Roughness PMI text define.
Definition: zwapi_cmd_pmi_data.h:31
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SHAPE_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_shape.h
cvxChamFlltSetDataInit
cvxPartBool
cvxPartBool2
cvxPartBool3
cvxPartBox
cvxPartBoxInit
cvxPartChamAng
cvxPartChamAsym
cvxPartChamConst
cvxPartChamferAll
cvxPartChamferAllInit
cvxPartCone
cvxPartConeInit
cvxPartCopy
cvxPartCopyDirDis
cvxPartCopyInit
cvxPartCopyPntToPnt
cvxPartCopyTransform
cvxPartCopyTransformList
cvxPartCyl
cvxPartCylInit
cvxPartDivide
cvxPartDivideInit
cvxPartDraft
cvxPartDraftInit
cvxPartEllipsoid
cvxPartEllipsoidInit
cvxPartExtrude
cvxPartExtrudeInit
cvxPartFaceFillet
cvxPartFaceFilletInit
cvxPartFaceOffset
cvxPartFillet
cvxPartFilletAll
cvxPartFilletAllInit
cvxPartFlagExtThread
cvxPartFlagExtThreadInit
cvxPartFlagHoles
cvxPartFlagHolesInit
cvxPartHole
cvxPartHoleInit
cvxPartInlay
cvxPartInlayInit
cvxPartLip
cvxPartLipInit
cvxPartLoft
cvxPartLoftInit
cvxPartMirrorFtr
cvxPartMirrorFtrInit
cvxPartMirrorGeom
cvxPartMirrorGeominit
cvxPartModifyHole
cvxPartModifyHoleInit
cvxPartMorphToCrv
cvxPartMorphToCrvInit
cvxPartMove
cvxPartMovePntToPnt
cvxPartMoveTransform
cvxPartMoveTransformList
cvxPartPatternFtr
cvxPartPatternGeom
cvxPartPunch
cvxPartPunchInit
cvxPartReplace
cvxPartReplaceInit
cvxPartRevolve
cvxPartRevolveInit
cvxPartRib
cvxPartRibInit
cvxPartScale
cvxPartScale2
cvxPartSelfX
cvxPartSelfXInit
cvxPartShapeFaceOffset
cvxPartShapeFaceOffsetInit
cvxPartShell
cvxPartShellInit
cvxPartSimplify
cvxPartSphere
cvxPartSphereInit
cvxPartSpiralSweep
cvxPartSpiralSweepInit
cvxPartStock
cvxPartStockInit
cvxPartStretch
cvxPartStretchInit
cvxPartSweep
cvxPartSweepInit
cvxPartTaper
cvxPartTaperInit
cvxPartThicken
cvxPartThickenInit
cvxPartThreadAt
cvxPartThreadAtInit
cvxPartTrim
cvxPartTrimInit
cvxPartTwist
cvxPartTwistInit
cvxPtnDataInit
cvxPtnVarTblInit

◆ ZW_API_SHAPE_FTR_H

#define ZW_API_SHAPE_FTR_H

Definition at line 15 of file zwapi_cmd_shape.h.
Generated at Sun Apr 23 2023 16:41:37 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_shape.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_shape.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SHAPE_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_SHAPE_FTR_H
16
17#include "zwapi_cmd_shape_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/**********************************************************************
27*! -Sketch- : zwapi_cmd_sk_create.h
28* extern int cvxPartSkNew(svxMatrix* Plane, int* idEnt);
29* extern int cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
30**********************************************************************/
31
32/**********************************************************************
33*! -Cosmetic Sketch- : zwapi_cmd_sk_create.h
34* extern int cvxPartSkNew(svxMatrix* Plane, int* idEnt);
35* extern int cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
36**********************************************************************/
37
38/******************************************************************************/
55extern evxErrors cvxPartBoxInit(svxBoxData* data);
56
57/******************************************************************************/
85extern evxErrors cvxPartBox(svxBoxData* Box, int* idShape);
86
87/******************************************************************************/
104extern evxErrors cvxPartCylInit(svxCylData* data);
105
106/******************************************************************************/
134extern evxErrors cvxPartCyl(svxCylData* Cyl, int* idShape);
135
136/******************************************************************************/
153extern evxErrors cvxPartConeInit(svxConeData* data);
154
155/******************************************************************************/
183extern evxErrors cvxPartCone(svxConeData* Cone, int* idShape);
184
185/******************************************************************************/
202extern evxErrors cvxPartSphereInit(svxSphereData* data);
203
204/******************************************************************************/
232extern evxErrors cvxPartSphere(svxSphereData* Sphere, int* idShape);
233
234/******************************************************************************/
251extern evxErrors cvxPartEllipsoidInit(svxEllsoData* data);
252
253/******************************************************************************/
281extern evxErrors cvxPartEllipsoid(svxEllsoData* Ellso, int* idShape);
282
283/******************************************************************************/
300extern evxErrors cvxPartExtrudeInit(svxExtrudeData* data);
301
302/******************************************************************************/
331extern evxErrors cvxPartExtrude(svxExtrudeData* Ext, int* idShape);
332
333/******************************************************************************/
350extern evxErrors cvxPartRevolveInit(svxRevolveData* data);
351
352/******************************************************************************/
382extern evxErrors cvxPartRevolve(svxRevolveData* Rev, int* idShape);
383
384/******************************************************************************/
401extern evxErrors cvxPartSweepInit(svxSweepData* data);
402
403/******************************************************************************/
434extern evxErrors cvxPartSweep(svxSweepData* Swp, void* Options, int* idShape);
435
436/******************************************************************************/
453extern evxErrors cvxPartSpiralSweepInit(svxSpiralSweepData* data);
454
455/******************************************************************************/
484extern evxErrors cvxPartSpiralSweep(const svxSpiralSweepData* SpiralSwp, int* idShape);
485
486/******************************************************************************/
503extern evxErrors cvxPartLoftInit(svxLoftData* data);
504
505/******************************************************************************/
530extern evxErrors cvxPartLoft(svxLoftData* Loft, int* idShape);
531
532
533//====================================================================================================================
535//====================================================================================================================
536/******************************************************************************/
559extern evxErrors cvxPartFillet(int Count, int* Edges, double Radius);
560
561/******************************************************************************/
578extern evxErrors cvxPartFilletAllInit(svxChamFlltData* data);
579
580/******************************************************************************/
601extern evxErrors cvxPartFilletAll(const svxChamFlltData* Fillet, int* idFillet);
602
603/******************************************************************************/
620extern evxErrors cvxPartFaceFilletInit(svxFaceFlltData* data);
621
622/******************************************************************************/
643extern evxErrors cvxPartFaceFillet(const svxFaceFlltData* data, int* idFillet);
644
645/******************************************************************************/
665extern evxErrors cvxPartChamConst(int Count, int* Edges, double Setback);
666
667/******************************************************************************/
686extern evxErrors cvxPartChamAng(int Count, int* Edges, int idFace, double Setback, double Angle);
687
688/******************************************************************************/
707extern evxErrors cvxPartChamAsym(int Count, int* Edges, int idFace, double Setback1, double Setback2);
708
709/******************************************************************************/
726extern evxErrors cvxChamFlltSetDataInit(svxChamFlltSetData* data);
727
728/******************************************************************************/
745extern evxErrors cvxPartChamferAllInit(svxChamFlltData* data);
746
747/******************************************************************************/
769extern evxErrors cvxPartChamferAll(const svxChamFlltData* Chamfer, int* idChamfer);
770
771/******************************************************************************/
789extern evxErrors cvxPartDraftInit(evxDraftMethods method, svxDraftData* data);
790
791/******************************************************************************/
817extern evxErrors cvxPartDraft(const svxDraftData* Draft, int* idDraft);
818
819/******************************************************************************/
842extern evxErrors cvxPartHoleInit(evxHoleOpt HoleOpt, int type, svxHoleData* data);
843
844/******************************************************************************/
869extern evxErrors cvxPartHole(svxHoleData* Data, int* idOp);
870
871/******************************************************************************/
896extern evxErrors cvxPartModifyHoleInit(int idFace, svxHoleData* data);
897
898/******************************************************************************/
921extern evxErrors cvxPartModifyHole(int cntFace, int* pFace, const svxHoleData* data, int* idFtr);
922
923/******************************************************************************/
940extern evxErrors cvxPartFlagHolesInit(svxFlagHoleData* data);
941
942/******************************************************************************/
965extern evxErrors cvxPartFlagHoles(const svxFlagHoleData* data, int* idFtr);
966
967/******************************************************************************/
984extern evxErrors cvxPartRibInit(svxRibData* data);
985
986/******************************************************************************/
1011extern evxErrors cvxPartRib(svxRibData* Rib, int* idRib);
1012
1013/******************************************************************************/
1030extern evxErrors cvxPartFlagExtThreadInit(svxFlagExtThreadData* data);
1031
1032/******************************************************************************/
1055extern evxErrors cvxPartFlagExtThread(const svxFlagExtThreadData* data, int* idFtr);
1056
1057/******************************************************************************/
1074extern evxErrors cvxPartThreadAtInit(svxThreadData* data);
1075
1076/******************************************************************************/
1106extern evxErrors cvxPartThreadAt(int idFace, svxPoint* Pnt, svxThreadData* Thread);
1107
1108/******************************************************************************/
1125extern evxErrors cvxPartLipInit(svxLipData* data);
1126
1127/******************************************************************************/
1151extern evxErrors cvxPartLip(svxLipData* Lip, int* idLip);
1152
1153/******************************************************************************/
1170extern evxErrors cvxPartStockInit(svxStockData* data);
1171
1172/******************************************************************************/
1195extern evxErrors cvxPartStock(svxStockData* Stock, int* idShape);
1196
1197
1198//====================================================================================================================
1200//====================================================================================================================
1201/******************************************************************************/
1222extern evxErrors cvxPartFaceOffset(int idFace, double Dis, int Keep);
1223
1224/******************************************************************************/
1241extern evxErrors cvxPartShapeFaceOffsetInit(svxFaceOffData* data);
1242
1243/******************************************************************************/
1265extern evxErrors cvxPartShapeFaceOffset(svxFaceOffData* Offset, int* idOffset);
1266
1267/******************************************************************************/
1284extern evxErrors cvxPartShellInit(svxShellData* data);
1285
1286/******************************************************************************/
1312extern evxErrors cvxPartShell(const svxShellData* Shell, int* idShell);
1313
1314/******************************************************************************/
1331extern evxErrors cvxPartThickenInit(svxThickenData* data);
1332
1333/******************************************************************************/
1355extern evxErrors cvxPartThicken(svxThickenData* Thicken, int* idShape);
1356
1357/******************************************************************************/
1379extern evxErrors cvxPartBool(evxBoolType Type, int idBase, int Count, int* Shapes, int Keep);
1380
1381/******************************************************************************/
1415extern evxErrors cvxPartBool2(evxBoolType Type, int BaseCount, int* BaseList, int OpCount, int* OpList, int* ResultCount, int** ResultList);
1416
1417/******************************************************************************/
1457extern evxErrors cvxPartBool3(evxBoolType Type, int BaseCount, int* BaseList, int OpCount,
1458 int* OpList, int FaceCount, int* FaceList, int* ResultCount, int** ResultList);
1459
1460/******************************************************************************/
1477extern evxErrors cvxPartDivideInit(svxDivideData* data);
1478
1479/******************************************************************************/
1508extern evxErrors cvxPartDivide(svxDivideData* Divide, int* numShape, int** idShapes);
1509
1510/******************************************************************************/
1527extern evxErrors cvxPartTrimInit(svxTrimData* data);
1528
1529/******************************************************************************/
1557extern evxErrors cvxPartTrim(svxTrimData* Trim, int* numShape, int** idShapes);
1558
1559/******************************************************************************/
1580extern evxErrors cvxPartSimplify(int numEnts, int* idEnts, int* idSimplify);
1581
1582/******************************************************************************/
1599extern evxErrors cvxPartReplaceInit(svxReplaceData* data);
1600
1601/******************************************************************************/
1621extern evxErrors cvxPartReplace(const svxReplaceData* Replace, int* idReplace);
1622
1623/******************************************************************************/
1640extern evxErrors cvxPartInlayInit(svxInlayData* data);
1641
1642/******************************************************************************/
1668extern evxErrors cvxPartInlay(svxInlayData* Inlay, int* idInlay);
1669
1670/******************************************************************************/
1686extern evxErrors cvxPartSelfXInit(svxPartSelfX* data);
1687
1688/******************************************************************************/
1717extern evxErrors cvxPartSelfX(const svxPartSelfX* data, int* idShape);
1718
1719/******************************************************************************/
1735extern evxErrors cvxPartPunchInit(svxPunch* data);
1736
1737/******************************************************************************/
1760extern evxErrors cvxPartPunch(const svxPunch* data, int* idPunch);
1761
1762//====================================================================================================================
1764//====================================================================================================================
1765/******************************************************************************/
1782extern evxErrors cvxPartTwistInit(svxTwistData* data);
1783
1784/******************************************************************************/
1804extern evxErrors cvxPartTwist(const svxTwistData* Twist, int* idTwist);
1805
1806/******************************************************************************/
1823extern evxErrors cvxPartTaperInit(svxTaperData* data);
1824
1825/******************************************************************************/
1845extern evxErrors cvxPartTaper(const svxTaperData* Taper, int* idTaper);
1846
1847/******************************************************************************/
1864extern evxErrors cvxPartStretchInit(svxStretchData* data);
1865
1866/******************************************************************************/
1886extern evxErrors cvxPartStretch(const svxStretchData* Stretch, int* idStretch);
1887
1888/******************************************************************************/
1905extern evxErrors cvxPartMorphToCrvInit(svxMorphToCrvData* data);
1906
1907/******************************************************************************/
1927extern evxErrors cvxPartMorphToCrv(const svxMorphToCrvData* MorphToCrv, int* idMorphToCrv);
1928
1929
1930//====================================================================================================================
1932//====================================================================================================================
1933/******************************************************************************/
1951extern evxErrors cvxPtnDataInit(evxPatternType type, svxPtnData* data);
1952
1953/******************************************************************************/
1980extern evxErrors cvxPartPatternGeom(int Count, int* idEnts, const svxPtnGeom* Pattern, int* idPattern);
1981
1982/******************************************************************************/
2020extern evxErrors cvxPtnVarTblInit(int firstNum, int secondNum, const char* dimName, svxPtnVarTbl* ptnVarTbl);
2021
2022/******************************************************************************/
2049extern evxErrors cvxPartPatternFtr(int Count, int* idFtrs, const svxPtnFtr* Pattern, int* idPattern);
2050
2051/******************************************************************************/
2068extern evxErrors cvxPartMirrorGeominit(svxMirrorGeom* data);
2069
2070/******************************************************************************/
2096extern evxErrors cvxPartMirrorGeom(svxMirrorGeom* Mirror, int* NumNewEnts, int** idNewEnts);
2097
2098/******************************************************************************/
2115extern evxErrors cvxPartMirrorFtrInit(svxMirrorFtr* data);
2116
2117/******************************************************************************/
2139extern evxErrors cvxPartMirrorFtr(svxMirrorFtr* Mirror, int* idFtr);
2140
2141/******************************************************************************/
2165extern evxErrors cvxPartMovePntToPnt(int idEntity, svxAxis* Start, svxAxis* End);
2166
2167/******************************************************************************/
2189extern evxErrors cvxPartMoveTransform(int idEntity, const svxMatrix* Mat);
2190
2191/******************************************************************************/
2219extern evxErrors cvxPartMoveTransformList(int Count, const int* Entities, const svxMatrix* Mat);
2220
2221/******************************************************************************/
2243extern evxErrors cvxPartMove(const svxMoveData* Move, int* idMove);
2244
2245/******************************************************************************/
2268extern evxErrors cvxPartCopyDirDis(int idEntity, svxVector* Dir, double Dis, int* idCopy);
2269
2270/******************************************************************************/
2295extern evxErrors cvxPartCopyPntToPnt(int idEntity, svxAxis* Start, svxAxis* End, int* idCopy);
2296
2297/******************************************************************************/
2321extern evxErrors cvxPartCopyTransform(int idEntity, const svxMatrix* Mat, int* idCopy);
2322
2323/******************************************************************************/
2349extern evxErrors cvxPartCopyTransformList(const int Count, const int* Entities, const svxMatrix* Mat, int* EntCnt, int** idList);
2350
2351/******************************************************************************/
2368extern evxErrors cvxPartCopyInit(svxCopyData* data);
2369
2370/******************************************************************************/
2395extern evxErrors cvxPartCopy(const svxCopyData* Copy, int* idCopy);
2396
2397/******************************************************************************/
2426extern evxErrors cvxPartScale(int Count, int* idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum);
2427
2428/******************************************************************************/
2458extern evxErrors cvxPartScale2(int Count, int* idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum, svxPoint* CentPnt);
2459
2460
2461//====================================================================================================================
2463//====================================================================================================================
2464/**********************************************************************
2465*! -Datum Axis- : zwapi_cmd_datum.h
2466* extern int cvxPartAxisNew(svxAxisData *Axis, int *idAxis);
2467**********************************************************************/
2468
2469/**********************************************************************
2470*! -Datum Plane- : zwapi_cmd_datum.h
2471* extern int cvxPartDatum(svxMatrix* Frame, int* idDatum);
2472* extern int cvxPartDatum2(svxMatrix* Frame, int iCode, int* idDatum);
2473* extern int cvxPartNewDatum(svxMatrix* Frame, int* idDatum);
2474* extern int cvxPartPlnCrv(int idCrv, svxPoint* Origin, svxPoint* Xaxis, int* idPln);
2475* extern int cvxPartPlnCrv2(int idCrv, svxData* Origin, svxData* Xaxis, int Flip, int* idPln);
2476* extern int cvxPartPlnSrf(int idFace, svxPoint* Origin, int* idPln);
2477* extern int cvxPartPlnSrf2(int idFace, svxPoint* Origin, svxPoint* XZ, int Flip, int* idPln);
2478* extern int cvxPartPlaneNew(svxPlaneData* Plane, int* idPlane);
2479* extern int cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
2480* extern int cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
2481**********************************************************************/
2482
2483/**********************************************************************
2484*! -Datum CSYS- : zwapi_cmd_datum.h
2485* extern int cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
2486* extern int cvxPartCSYSNew(svxCSYSData* CSYS, int* idCSYS);
2487**********************************************************************/
2488
2489/**********************************************************************
2490*! -LCS- : zwapi_cmd_datum.h
2491* extern int cvxPartActiveAsLCS(int id);
2492**********************************************************************/
2493
2494/*
2495*********************************************************************
2496** END HEADER FILE
2497*********************************************************************
2498*/
2499
2500#ifdef __cplusplus
2501 }
2502#endif /* __cplusplus */
2503
2504#endif /* ZW_API_SHAPE_FTR_H */
evxPatternType
evxPatternType
pattern method
Definition: zwapi_cmd_shape_data.h:1276
evxDraftMethods
evxDraftMethods
draft methods
Definition: zwapi_cmd_shape_data.h:534
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
evxHoleOpt
evxHoleOpt
hole option
Definition: zwapi_cmd_shape_data.h:606
cvxPartPatternGeom
evxErrors cvxPartPatternGeom(int Count, int *idEnts, const svxPtnGeom *Pattern, int *idPattern)
cvxPartCopy
evxErrors cvxPartCopy(const svxCopyData *Copy, int *idCopy)
cvxPartFaceOffset
evxErrors cvxPartFaceOffset(int idFace, double Dis, int Keep)
cvxPartFaceFilletInit
evxErrors cvxPartFaceFilletInit(svxFaceFlltData *data)
cvxPartDivide
evxErrors cvxPartDivide(svxDivideData *Divide, int *numShape, int **idShapes)
cvxPartMoveTransform
evxErrors cvxPartMoveTransform(int idEntity, const svxMatrix *Mat)
cvxPartTwist
evxErrors cvxPartTwist(const svxTwistData *Twist, int *idTwist)
cvxPartCopyInit
evxErrors cvxPartCopyInit(svxCopyData *data)
cvxPartChamAsym
evxErrors cvxPartChamAsym(int Count, int *Edges, int idFace, double Setback1, double Setback2)
cvxPartDraft
evxErrors cvxPartDraft(const svxDraftData *Draft, int *idDraft)
cvxPartFilletAllInit
evxErrors cvxPartFilletAllInit(svxChamFlltData *data)
cvxPartTaper
evxErrors cvxPartTaper(const svxTaperData *Taper, int *idTaper)
cvxPartModifyHole
evxErrors cvxPartModifyHole(int cntFace, int *pFace, const svxHoleData *data, int *idFtr)
cvxPartMoveTransformList
evxErrors cvxPartMoveTransformList(int Count, const int *Entities, const svxMatrix *Mat)
cvxPartBool2
evxErrors cvxPartBool2(evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int *ResultCount, int **ResultList)
cvxPartDraftInit
evxErrors cvxPartDraftInit(evxDraftMethods method, svxDraftData *data)
cvxPartPunchInit
evxErrors cvxPartPunchInit(svxPunch *data)
cvxPartChamAng
evxErrors cvxPartChamAng(int Count, int *Edges, int idFace, double Setback, double Angle)
cvxPartScale
evxErrors cvxPartScale(int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum)
cvxPartSelfXInit
evxErrors cvxPartSelfXInit(svxPartSelfX *data)
cvxPartEllipsoidInit
evxErrors cvxPartEllipsoidInit(svxEllsoData *data)
cvxPartStretch
evxErrors cvxPartStretch(const svxStretchData *Stretch, int *idStretch)
cvxPartMorphToCrvInit
evxErrors cvxPartMorphToCrvInit(svxMorphToCrvData *data)
cvxPartCone
evxErrors cvxPartCone(svxConeData *Cone, int *idShape)
cvxPartReplace
evxErrors cvxPartReplace(const svxReplaceData *Replace, int *idReplace)
cvxPartLipInit
evxErrors cvxPartLipInit(svxLipData *data)
cvxPartRib
evxErrors cvxPartRib(svxRibData *Rib, int *idRib)
cvxPartPatternFtr
evxErrors cvxPartPatternFtr(int Count, int *idFtrs, const svxPtnFtr *Pattern, int *idPattern)
cvxPartConeInit
evxErrors cvxPartConeInit(svxConeData *data)
cvxPartLip
evxErrors cvxPartLip(svxLipData *Lip, int *idLip)
cvxPartStretchInit
evxErrors cvxPartStretchInit(svxStretchData *data)
cvxPartMovePntToPnt
evxErrors cvxPartMovePntToPnt(int idEntity, svxAxis *Start, svxAxis *End)
cvxPartCopyTransform
evxErrors cvxPartCopyTransform(int idEntity, const svxMatrix *Mat, int *idCopy)
cvxPartFlagExtThreadInit
evxErrors cvxPartFlagExtThreadInit(svxFlagExtThreadData *data)
cvxPartShell
evxErrors cvxPartShell(const svxShellData *Shell, int *idShell)
cvxPartFlagHoles
evxErrors cvxPartFlagHoles(const svxFlagHoleData *data, int *idFtr)
cvxPartStock
evxErrors cvxPartStock(svxStockData *Stock, int *idShape)
cvxPartSphereInit
evxErrors cvxPartSphereInit(svxSphereData *data)
cvxPartShellInit
evxErrors cvxPartShellInit(svxShellData *data)
cvxPartSphere
evxErrors cvxPartSphere(svxSphereData *Sphere, int *idShape)
cvxPartEllipsoid
evxErrors cvxPartEllipsoid(svxEllsoData *Ellso, int *idShape)
cvxPartCylInit
evxErrors cvxPartCylInit(svxCylData *data)
cvxPartRevolveInit
evxErrors cvxPartRevolveInit(svxRevolveData *data)
cvxPartMorphToCrv
evxErrors cvxPartMorphToCrv(const svxMorphToCrvData *MorphToCrv, int *idMorphToCrv)
cvxPartInlayInit
evxErrors cvxPartInlayInit(svxInlayData *data)
cvxPartRibInit
evxErrors cvxPartRibInit(svxRibData *data)
cvxPartTrim
evxErrors cvxPartTrim(svxTrimData *Trim, int *numShape, int **idShapes)
cvxPartStockInit
evxErrors cvxPartStockInit(svxStockData *data)
cvxPartDivideInit
evxErrors cvxPartDivideInit(svxDivideData *data)
cvxPartBoxInit
evxErrors cvxPartBoxInit(svxBoxData *data)
cvxPartThickenInit
evxErrors cvxPartThickenInit(svxThickenData *data)
cvxPartMirrorGeominit
evxErrors cvxPartMirrorGeominit(svxMirrorGeom *data)
cvxPartBox
evxErrors cvxPartBox(svxBoxData *Box, int *idShape)
cvxPartMirrorGeom
evxErrors cvxPartMirrorGeom(svxMirrorGeom *Mirror, int *NumNewEnts, int **idNewEnts)
cvxPartSimplify
evxErrors cvxPartSimplify(int numEnts, int *idEnts, int *idSimplify)
cvxPartShapeFaceOffset
evxErrors cvxPartShapeFaceOffset(svxFaceOffData *Offset, int *idOffset)
cvxPartFlagHolesInit
evxErrors cvxPartFlagHolesInit(svxFlagHoleData *data)
cvxPartFlagExtThread
evxErrors cvxPartFlagExtThread(const svxFlagExtThreadData *data, int *idFtr)
cvxPartCopyPntToPnt
evxErrors cvxPartCopyPntToPnt(int idEntity, svxAxis *Start, svxAxis *End, int *idCopy)
cvxPartCopyTransformList
evxErrors cvxPartCopyTransformList(const int Count, const int *Entities, const svxMatrix *Mat, int *EntCnt, int **idList)
cvxPartChamferAll
evxErrors cvxPartChamferAll(const svxChamFlltData *Chamfer, int *idChamfer)
cvxPartHoleInit
evxErrors cvxPartHoleInit(evxHoleOpt HoleOpt, int type, svxHoleData *data)
cvxPartRevolve
evxErrors cvxPartRevolve(svxRevolveData *Rev, int *idShape)
cvxPartMirrorFtrInit
evxErrors cvxPartMirrorFtrInit(svxMirrorFtr *data)
cvxPartModifyHoleInit
evxErrors cvxPartModifyHoleInit(int idFace, svxHoleData *data)
cvxPartTaperInit
evxErrors cvxPartTaperInit(svxTaperData *data)
cvxPartInlay
evxErrors cvxPartInlay(svxInlayData *Inlay, int *idInlay)
cvxPartThreadAt
evxErrors cvxPartThreadAt(int idFace, svxPoint *Pnt, svxThreadData *Thread)
cvxPtnDataInit
evxErrors cvxPtnDataInit(evxPatternType type, svxPtnData *data)
cvxPartHole
evxErrors cvxPartHole(svxHoleData *Data, int *idOp)
cvxPartReplaceInit
evxErrors cvxPartReplaceInit(svxReplaceData *data)
cvxPartSpiralSweep
evxErrors cvxPartSpiralSweep(const svxSpiralSweepData *SpiralSwp, int *idShape)
cvxPartSweep
evxErrors cvxPartSweep(svxSweepData *Swp, void *Options, int *idShape)
cvxPartExtrude
evxErrors cvxPartExtrude(svxExtrudeData *Ext, int *idShape)
cvxChamFlltSetDataInit
evxErrors cvxChamFlltSetDataInit(svxChamFlltSetData *data)
cvxPartBool3
evxErrors cvxPartBool3(evxBoolType Type, int BaseCount, int *BaseList, int OpCount, int *OpList, int FaceCount, int *FaceList, int *ResultCount, int **ResultList)
cvxPartChamferAllInit
evxErrors cvxPartChamferAllInit(svxChamFlltData *data)
cvxPartScale2
evxErrors cvxPartScale2(int Count, int *idEnts, double X_scale, double Y_scale, double Z_scale, int idDatum, svxPoint *CentPnt)
cvxPartFaceFillet
evxErrors cvxPartFaceFillet(const svxFaceFlltData *data, int *idFillet)
cvxPartLoftInit
evxErrors cvxPartLoftInit(svxLoftData *data)
cvxPartThicken
evxErrors cvxPartThicken(svxThickenData *Thicken, int *idShape)
cvxPartLoft
evxErrors cvxPartLoft(svxLoftData *Loft, int *idShape)
cvxPartThreadAtInit
evxErrors cvxPartThreadAtInit(svxThreadData *data)
cvxPtnVarTblInit
evxErrors cvxPtnVarTblInit(int firstNum, int secondNum, const char *dimName, svxPtnVarTbl *ptnVarTbl)
cvxPartCopyDirDis
evxErrors cvxPartCopyDirDis(int idEntity, svxVector *Dir, double Dis, int *idCopy)
cvxPartChamConst
evxErrors cvxPartChamConst(int Count, int *Edges, double Setback)
cvxPartCyl
evxErrors cvxPartCyl(svxCylData *Cyl, int *idShape)
cvxPartTwistInit
evxErrors cvxPartTwistInit(svxTwistData *data)
cvxPartBool
evxErrors cvxPartBool(evxBoolType Type, int idBase, int Count, int *Shapes, int Keep)
cvxPartFilletAll
evxErrors cvxPartFilletAll(const svxChamFlltData *Fillet, int *idFillet)
cvxPartMove
evxErrors cvxPartMove(const svxMoveData *Move, int *idMove)
cvxPartShapeFaceOffsetInit
evxErrors cvxPartShapeFaceOffsetInit(svxFaceOffData *data)
cvxPartSpiralSweepInit
evxErrors cvxPartSpiralSweepInit(svxSpiralSweepData *data)
cvxPartTrimInit
evxErrors cvxPartTrimInit(svxTrimData *data)
cvxPartSweepInit
evxErrors cvxPartSweepInit(svxSweepData *data)
cvxPartExtrudeInit
evxErrors cvxPartExtrudeInit(svxExtrudeData *data)
cvxPartSelfX
evxErrors cvxPartSelfX(const svxPartSelfX *data, int *idShape)
cvxPartPunch
evxErrors cvxPartPunch(const svxPunch *data, int *idPunch)
cvxPartFillet
evxErrors cvxPartFillet(int Count, int *Edges, double Radius)
cvxPartMirrorFtr
evxErrors cvxPartMirrorFtr(svxMirrorFtr *Mirror, int *idFtr)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBoxData
box data
Definition: zwapi_cmd_shape_data.h:46
svxChamFlltData
chamfer or fillet data
Definition: zwapi_cmd_shape_data.h:447
svxChamFlltSetData
set-list data for chamfer or fillet command
Definition: zwapi_cmd_shape_data.h:425
svxConeData
cone
Definition: zwapi_cmd_shape_data.h:79
svxCopyData
template command Copy data
Definition: zwapi_cmd_shape_data.h:1598
svxCylData
cylinder
Definition: zwapi_cmd_shape_data.h:63
svxDivideData
divide data
Definition: zwapi_cmd_shape_data.h:1068
svxDraftData
template command Draft data
Definition: zwapi_cmd_shape_data.h:562
svxEllsoData
ellipsoid
Definition: zwapi_cmd_shape_data.h:111
svxExtrudeData
extruded shape
Definition: zwapi_cmd_shape_data.h:165
svxFaceFlltData
Definition: zwapi_cmd_shape_data.h:519
svxFaceOffData
shape face offset data
Definition: zwapi_cmd_shape_data.h:986
svxFlagExtThreadData
flag ext thread data
Definition: zwapi_cmd_shape_data.h:875
svxFlagHoleData
flag hole data
Definition: zwapi_cmd_shape_data.h:802
svxHoleData
hole data
Definition: zwapi_cmd_shape_data.h:697
svxInlayData
inlay data
Definition: zwapi_cmd_shape_data.h:1133
svxLipData
lip data
Definition: zwapi_cmd_shape_data.h:923
svxLoftData
loft data
Definition: zwapi_cmd_shape_data.h:388
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxMirrorFtr
mirror feature data
Definition: zwapi_cmd_shape_data.h:1468
svxMirrorGeom
mirror geometry data
Definition: zwapi_cmd_shape_data.h:1448
svxMorphToCrvData
shape morph to curve data
Definition: zwapi_cmd_shape_data.h:1246
svxMoveData
template command Move data
Definition: zwapi_cmd_shape_data.h:1578
svxPartSelfX
part resolveSelfX data
Definition: zwapi_cmd_shape_data.h:1157
svxPoint
3D point
Definition: zwapi_util.h:306
svxPtnData
pattern data
Definition: zwapi_cmd_shape_data.h:1293
svxPtnFtr
pattern feature data
Definition: zwapi_cmd_shape_data.h:1436
svxPtnGeom
pattern geometry data
Definition: zwapi_cmd_shape_data.h:1403
svxPtnVarTbl
table dimension information
Definition: zwapi_cmd_shape_data.h:1415
svxPunch
part punch data
Definition: zwapi_cmd_shape_data.h:1168
svxReplaceData
shape replace data
Definition: zwapi_cmd_shape_data.h:1119
svxRevolveData
revolved shape
Definition: zwapi_cmd_shape_data.h:215
svxRibData
rib data
Definition: zwapi_cmd_shape_data.h:854
svxShellData
template command Shell input data
Definition: zwapi_cmd_shape_data.h:1011
svxSphereData
sphere
Definition: zwapi_cmd_shape_data.h:98
svxSpiralSweepData
spiral swept shape
Definition: zwapi_cmd_shape_data.h:331
svxStockData
stock data
Definition: zwapi_cmd_shape_data.h:950
svxStretchData
shape stretch data
Definition: zwapi_cmd_shape_data.h:1221
svxSweepData
swept shape
Definition: zwapi_cmd_shape_data.h:282
svxTaperData
shape taper data
Definition: zwapi_cmd_shape_data.h:1203
svxThickenData
thicken data
Definition: zwapi_cmd_shape_data.h:1043
svxThreadData
thread definition
Definition: zwapi_cmd_shape_data.h:907
svxTrimData
Trim data.
Definition: zwapi_cmd_shape_data.h:1087
svxTwistData
shape twist data
Definition: zwapi_cmd_shape_data.h:1185
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SHAPE_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_shape_data.h
evxBoolType
evxBoolType
evxCapType
evxCapType
evxChamFlltType
evxChamFlltType
evxClearHoleType
evxClearHoleType
evxDraftMethods
evxDraftMethods
evxDraftType
evxDraftType
evxEndCondition
evxEndCondition
evxFlagThreadDepthType
evxFlagThreadDepthType
evxHoleOpt
evxHoleOpt
evxHoleType
evxHoleType
evxLeadType
evxLeadType
evxLoftType
evxLoftType
evxMoveType
evxMoveType
evxOffsetType
evxOffsetType
evxOverflowType
evxOverflowType
evxPatternType
evxPatternType
evxStockOpt
evxStockOpt
evxSweepOpt
evxSweepOpt
evxSweepXOpt
evxSweepXOpt
evxSweepZOpt
evxSweepZOpt
evxThreadHoleClass
evxThreadHoleClass
evxThreadType
evxThreadType
svxAlignFrame
svxAlongDir
svxAlongPath
svxAroundDir
svxBoxData
svxChamFlltData
svxChamFlltSetData
svxConeData
svxCopyData
svxCylData
svxDivideData
svxDraftData
svxDymMove
svxEllsoData
svxExtrudeData
svxFaceOffData
svxFlagExtThreadData
svxFlagHoleData
svxHoleChams
svxHoleData
svxInlayData
svxLipData
svxLoftData
svxLoftProfile
svxMirrorFtr
svxMirrorGeom
svxMorphToCrvData
svxMoveData
svxMovePntToPnt
svxPartSelfX
svxPtnData
svxPtnFtr
svxPtnGeom
svxPtnVarTbl
svxPunch
svxReplaceData
svxRevolveData
svxRibData
svxShellData
svxSphereData
svxSpiralSweepData
svxStockData
svxStretchData
svxSweepData
svxTaperData
svxThickenData
svxThreadData
svxTrimData
svxTwistData

◆ ZW_API_SHAPE_FTR_DATA_H

#define ZW_API_SHAPE_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_shape_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_shape_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_shape_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SHAPE_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_SHAPE_FTR_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_subcmd_data.h"
21
22#ifdef __cplusplus
23extern "C" {
24#endif /* __cplusplus */
25
26//====================================================================================================================
28//====================================================================================================================
33typedef enum evxBoolType
34 {
35 VX_BOOL_NONE = 0,
36 VX_BOOL_ADD = 1,
37 VX_BOOL_REMOVE = 2,
38 VX_BOOL_INTERSECT = 3
39 } evxBoolType;
40
45typedef struct svxBoxData
46 {
47 evxBoolType Combine;
48 int idPlane;
49 int useAxis;
50 svxAxis axis;
51 svxPoint Center;
52 double X;
53 double Y;
54 double Z;
55 vxName ftrName;
56 } svxBoxData;
57
62typedef struct svxCylData
63 {
64 evxBoolType Combine;
65 int idPlane;
66 int useAxis;
67 svxAxis axis;
68 svxPoint Center;
69 double Radius;
70 double Length;
71 vxName ftrName;
72 } svxCylData;
73
78typedef struct svxConeData
79 {
80 evxBoolType Combine;
81 svxPoint Center;
82 double Radius1;
83 double Length;
84 double Radius2;
86 int useAxis;
87 int idPlane;
88 svxAxis axis;
90 vxName ftrName;
91 } svxConeData;
92
97typedef struct svxSphereData
98 {
99 evxBoolType Combine;
100 svxPoint Center;
101 double Radius;
103 vxName ftrName;
104 } svxSphereData;
105
110typedef struct svxEllsoData
111 {
112 evxBoolType Combine;
113 svxPoint Center;
114 double xLen;
115 double yLen;
116 double zLen;
118 int useAxis;
119 int idPlane;
120 svxAxis axis;
122 vxName ftrName;
123 } svxEllsoData;
124
129typedef enum evxOffsetType
130 {
131 VX_OFFSET_NONE = 0,
132 VX_OFFSET_SHRINK = 1,
133 VX_OFFSET_THICKEN = 2,
134 VX_OFFSET_THICKEN_SAME = 3,
135 } evxOffsetType;
136
141typedef enum evxLeadType
142 {
143 VX_LEAD_IN = 0,
144 VX_LEAD_OUT = 1,
145 VX_LEAD_NONE = 2,
146 } evxLeadType;
147
152typedef enum evxCapType
153 {
154 VX_END_CAP_BOTH = 0,
155 VX_END_CAP_START = 1,
156 VX_END_CAP_END = 2,
157 VX_END_CAP_NONE = 3,
158 }evxCapType;
159
164typedef struct svxExtrudeData
165 {
166 evxBoolType Combine;
167 int idProfile;
168 double Start;
169 double End;
171 double Draft;
172 int Blend;
175 int UseDirection;
176 svxVector Direction;
178 double Twist;
179 svxPoint Pivot;
181 double Offset;
182 double Thickness;
184 int iKeep;
186 int numBooleanEnts;
187 int* BooleanEnts;
189 vxName ftrName;
191 int FlipFaceDir;
192 int FlipRemoveArea;
193 evxDistanceMethod StartType;
194 evxDistanceMethod EndType;
195 int idStartEnt;
196 int idEndEnt;
197 double StartOffset;
198 double EndOffset;
199 svxPoint* StartToPnt;
200 svxPoint* EndToPnt;
202 evxOffsetType OffsetTyp;
203 evxCapType CapType;
204 int cntCap;
207 int* CapFace;
208 } svxExtrudeData;
209
214typedef struct svxRevolveData
215 {
216 evxBoolType Combine;
217 int idProfile;
218 double Start;
219 double End;
220 svxAxis Axis;
222 double Offset;
223 double Thickness;
225 int idAxis;
226 int idParent;
228 evxOffsetType OffsetTyp;
230 /* To point/ To face/ To Extended Face for "Start" and "End" */
231 evxDistanceMethod StartType;
232 evxDistanceMethod EndType;
233 int idStartEnt;
234 int idEndEnt;
235 svxPoint* StartPnt;
236 svxPoint* EndPnt;
237 evxCapType CapType;
238 int Flip;
239 } svxRevolveData;
240
245typedef enum evxSweepOpt
246 {
247 VX_SWP_NATURAL = 0,
248 VX_SWP_AT_PATH = 1,
249 VX_SWP_FRAME = 2,
250 VX_SWP_AT_PROFILE = 3,
251 VX_SWP_ALONG_PATH = 4
252 } evxSweepOpt;
253
258typedef enum evxSweepXOpt
259 {
260 VX_SWP_X_MIN_TWIST = 0,
261 VX_SWP_X_FIXED_DIR = 1,
262 VX_SWP_X_XAXIS_CRV = 2,
263 VX_SWP_X_FACE_NORMAL = 3,
264 } evxSweepXOpt;
265
270typedef enum evxSweepZOpt
271 {
272 VX_SWP_Z_TANG_TO_PATH = 0,
273 VX_SWP_Z_TANG_TO_CRV = 1,
274 VX_SWP_Z_FIXED_DIR = 2,
275 } evxSweepZOpt;
276
281typedef struct svxSweepData
282 {
283 evxBoolType Combine;
284 int idProfile;
285 int idPath;
286 svxPoint StartPnt;
288 /* defined relative to curve's coordinate frame */
289 int idParent;
290 int UseParent;
292 evxSweepOpt Option;
294 int idFrame;
296 int idXaxis;
298 int idZaxis;
300 double Offset;
301 double Thickness;
303 int useStartPnt;
304 /* set the type of Xaxis and Zaxis, set the following parameters or just set idXaxis and idZaxis */
305 evxSweepXOpt xOpt;
306 evxSweepZOpt zOpt;
307 svxPntOnEnt* xEnt;
312 svxPntOnEnt* zEnt;
316 evxOffsetType OffsetTyp;
318 evxCapType CapType;
319 int cntCap;
322 int* CapFace;
323 int MergeFc;
324 } svxSweepData;
325
330typedef struct svxSpiralSweepData
331 {
332 /* Required */
333 svxPntOnEntPath pntOnPro;
334 svxVector axis;
335 double turns;
336 double dst;
337 /* Boolean */
338 evxBoolType combine;
339 int cntShapes;
340 int *idShapes;
341 /* Lead */
342 evxLeadType leadType;
343 double leadRad;
344 double leadAng;
346 evxCapType capType;
347 /* Offset */
348 evxOffsetType offsetType;
349 double offset;
350 double thickness;
351 /* Settings */
352 double taperAng;
353 int isClockwise;
354 int isFlipDir;
355 } svxSpiralSweepData;
356
357
362typedef struct svxLoftProfile
363 {
364 int idParent;
365 int idProfile;
366 int profDir;
367 int useStartPnt;
368 svxPoint startPnt;
369 } svxLoftProfile;
370
375typedef enum evxLoftType
376 {
377 VX_LOFT_PROFS,
378 VX_LOFT_START_PNT_PROFS,
379 VX_LOFT_END_PNT_PROFS,
380 VX_LOFT_BOTH_PNTS_PROFS
381 } evxLoftType;
382
387typedef struct svxLoftData
388 {
389 evxBoolType combine;
390 evxLoftType type;
391 int idStartParent;
392 svxPoint startPnt;
393 int numProfs;
394 svxLoftProfile* profs;
395 int idEndParent;
396 svxPoint endPnt;
398 svxLoftBndCons bndCons[2];
399 int endCap;
400 int close;
402 vxName ftrName;
403 } svxLoftData;
404
405//====================================================================================================================
407//====================================================================================================================
412typedef enum evxChamFlltType
413 {
414 VX_CHAMFLLT_SYMMETRIC,
415 VX_CHAMFLLT_ASYMMETRIC,
416 VX_CHAMFLLT_SETBACK_ANGLE,
417 VX_CHAMFLLT_VERTEX
418 } evxChamFlltType;
419
424typedef struct svxChamFlltSetData
425 {
426 int nEdges;
427 int* idEdge;
428 int* vertex;
431 int chordalFillet;
432 double setback1;
433 double setback2;
434 double angle;
436 int flip;
438 svxPntOnEnt* setback1Pnt;
439 svxPntOnEnt* setback2Pnt;
440 }svxChamFlltSetData;
441
446typedef struct svxChamFlltData
447 {
448 evxChamFlltType type;
450 int nEdges;
451 int* idEdge;
452 int* vertex;
456 double setback1;
457 double setback2;
458 double angle;
460 /* The following parameters are used to set shape of fillet, only used for fillet feature */
461 double relief;
464 int arcType;
465 double conicRatio;
466 double weight[2];
468 /* The following parameters are used to set rollover control */
469 int filletToEdge;
470 int usePatch;
471 int undercuts;
475 int localCorner;
477 int mitred;
480 int traceCorners;
482 int blendCorners;
485 int continuity;
486 int desity;
488 int baseFaces;
489 int filletFace;
491 int flip;
492 int offsetType;
494 /* use To-point* to set the value */
495 svxPntOnEnt* setback1Pnt;
496 svxPntOnEnt* setback2Pnt;
498 /* use set-list to set the data (edges/setback/angle) to each list */
499 int cntList;
500 svxChamFlltSetData* pChamFlltDataList;
501 } svxChamFlltData;
502
503/* face fillet type */
504typedef enum evxFaceFlltType
505 {
506 VX_FACE_FFLT_FACE = 0, /* tangent face */
507 VX_FACE_FFLT_RADIUS = 1, /* by radius */
508 }evxFaceFlltType;
509
510/* face fillet base faces type*/
511typedef enum evxFaceFlltBaseType
512 {
513 VX_FACE_FFLT_BASE_FACE_NONE = 0, /* none */
514 VX_FACE_FFLT_BASE_FACE_SEW = 3, /* sew */
515 }evxFaceFlltBaseType;
516
517/* face fillet data */
518typedef struct svxFaceFlltData
519 {
520 int cntFace; /* count face to fillet */
521 int* idFace; /* face id list to fillet */
522 evxFaceFlltType faceFlltType; /* face fillet type (VX_FACE_FFLT_FACE as default)*/
523 int idTangetFace; /* tangent face id if faceFlltType = VX_FACE_FFLT_FACE */
524 double radius; /* fillet radius if faceFlltType = VX_FACE_FFLT_RADIUS */
525 int baseFaces; /* base faces type (VX_FACE_FFLT_BASE_FACE_SEW as default) */
526 int searchFlag; /* 1-search for undercut, else 0 (1 as default) */
527 }svxFaceFlltData;
528
533typedef enum evxDraftMethods
534 {
535 VX_EDGE_DRAFT = 1,
536 VX_FACE_DRAFT = 2,
537 VX_PRATING_EDGE_DRAFT = 3
538 } evxDraftMethods;
539
544typedef enum evxDraftType
545 {
546 VX_DRAFT_TYPE_NONE = 0,
547 /* Edge Draft */
548 VX_SYM_EDGE_DRAFT = 1,
549 VX_ASYM_EDGE_DRAFT = 2,
551 /* Face Draft */
552 VX_STATION_SYM_FACE_DRAFT = 3,
553 VX_STATION_ASYM_FACE_DRAFT = 4,
554 VX_STATION_PARTING_FACE_DRAFT = 5,
555 } evxDraftType;
556
561typedef struct svxDraftData
562 {
563 evxDraftMethods Methods;
564 evxDraftType Type;
565 int iCntDataList;
566 int* idEnt;
567 double AngleA1;
568 double AngleA2;
570 union svxDraftStationaryEnt
571 {
572 struct StationaryFaces
573 {
574 int cnt;
575 int* idEnt;
576 } stationaryFaces;
577
578 struct StationAndPrtingFace
579 {
580 int* StationaryFaces2;
581 int cntStaFaces2;
582 int* PartingFaces;
583 int cntPrtFaces;
584 } staAndPrtFace;
585
586 struct StationaryPlane
587 {
588 int cnt;
589 int* idEnt;
590 } stationaryPlane;
591 } StationEnt;
592
593 svxVector DirP;
594 int DraftSideS;
595 int Extention;
596 int iIsrecomputeflt;
597 int iIntersections;
598 int iIsRemivtrgns;
599 } svxDraftData;
600
605typedef enum evxHoleOpt
606 {
607 VX_GENERAL_HOLE = 0,
608 VX_CLEARANCE_HOLE = 1,
609 VX_THREAD_HOLE = 2,
610 VX_PROFILE_HOLE = 3,
611 }evxHoleOpt;
612
617typedef enum evxHoleType
618 {
619 VX_HOLE_SHAPE_ALL = -1,
620 VX_HOLE_SIMPLE = 0,
621 VX_HOLE_TAPERED = 1,
622 VX_HOLE_COUNTER_BORE = 2,
623 VX_HOLE_COUNTER_SUNK = 3,
624 VX_HOLE_SPOT_FACE = 4
625 } evxHoleType;
626
631typedef enum evxClearHoleType
632 {
633 VX_CLEAR_HOLE_SIMPLE = 0,
634 VX_CLEAR_HOLE_COUNT_BORE = 2,
635 VX_CLEAR_HOLE_COUNT_SINK = 3,
636 VX_CLEAR_HOLE_SLOT = 5,
637 VX_CLEAR_HOLE_COUNT_SINK_SLOT = 6,
638 VX_CLEAR_HOLE_COUNT_BORE_SLOT = 7,
639 }evxClearHoleType;
640
645typedef enum evxThreadType
646 {
647 VX_THREAD_NONE = 1,
648 VX_THREAD_CUSTOM = 2,
649 VX_THREAD_M = 3,
650 VX_THREAD_UNC = 4,
651 VX_THREAD_UNF = 5,
652 VX_THREAD_ISO7 = 6,
653 VX_THREAD_ISO228 = 7,
654 VX_THREAD_NPT = 8,
655 VX_THREAD_NPSM = 9,
656 VX_THREAD_MC = 10,
657 VX_THREAD_MF = 11,
658 VX_THREAD_UN = 12,
659 VX_THREAD_UNEF = 13,
660 VX_THREAD_UNJ = 14,
661 VX_THREAD_UNJC = 15,
662 VX_THREAD_UNJF = 16,
663 VX_THREAD_UNJEF = 17,
664 VX_THREAD_ACME = 18,
665 VX_THREAD_BSP = 19,
666 VX_THREAD_BSTP = 20
667 } evxThreadType;
668
673typedef struct svxHoleChams
674 {
675 int fCham;
676 int fChamSym;
677 double chamDst;
678 double chamAngle;
679 }svxHoleChams;
680
685typedef enum evxEndCondition
686 {
687 VX_BLIND = 0,
688 VX_UNTIL_FACE = 1,
689 VX_THROUGH_ALL = 2
690 } evxEndCondition;
691
696typedef struct svxHoleData
697 {
698 /* Geometry */
699 evxHoleType Type;
700 int idInsFace;
701 int Count;
702 svxPoint* Points;
704 double Diameter1;
705 double Depth1;
706 double Diameter2;
707 double Depth2;
708 double TaperAngle;
709 double TipAngle;
710 evxEndCondition End;
711 int idUntilFace;
712 int UseDirection;
714 svxVector Direction;
715 int OpNoRemove;
716 int cntShps;
719 int* idShapes;
720 int NoProjPntLoc;
721 double slotLength;
722 double slotAngle;
724 /* Thread */
725 evxThreadType ThreadType;
726 vxLongName ThreadSize;
730 double ThreadDiameter;
731 double ThreadLength;
732 double ThreadsPerUnit;
733 double ThreadPitch;
734 int fThrdClass;
735 int thrdClass;
737 svxHoleChams sCham;
738 svxHoleChams mCham;
739 svxHoleChams eCham;
740 int fExtTap;
741 int fExtStart;
742 /* Tolerance */
743 int UseTol;
744 double TolIn;
745 double TolOut;
747 int UseD2Tol;
748 double D2InTol;
749 double D2OutTol;
751 /* Other */
752 char Callout[128];
753 int DoNotMachine;
755 /* clearance hole/ profile hole(2700)*/
756 evxHoleOpt HoleOpt;
757 evxClearHoleType ClearHoleType;
758 vxLongName Standard;
759 vxLongName Screw;
760 vxLongName Size;
761 vxLongName Fit;
762 int idSketch;
764 /* if Type=VX_HOLE_TAPERED, apply it. */
765 int AddBase;
766 } svxHoleData;
767
772typedef enum evxThreadHoleClass
773 {
774 VX_THREAD_HOLE_UNDEFINED,
775 VX_THREAD_HOLE_1B,
776 VX_THREAD_HOLE_2B,
777 VX_THREAD_HOLE_3B,
778 } evxThreadHoleClass;
779
784typedef enum evxFlagThreadDepthType
785 {
786 VX_FLAG_THREAD_UNDEFINED,
787 VX_FLAG_THREAD_DEPTH_DEFAULT,
788 VX_FLAG_THREAD_DEPTH_1XDIAMETER,
789 VX_FLAG_THREAD_DEPTH_15XDIAMETER,
790 VX_FLAG_THREAD_DEPTH_2XDIAMETER,
791 VX_FLAG_THREAD_DEPTH_25XDIAMETER,
792 VX_FLAG_THREAD_DEPTH_3XDIAMETER,
793 VX_FLAG_THREAD_DEPTH_FULL,
794 VX_FLAG_THREAD_DEPTH_CUSTOM,
795 } evxFlagThreadDepthType;
796
801typedef struct svxFlagHoleData
802 {
803 int FaceId;
804 int count;
805 int* HolesId;
807 int isUseFilter;
808 struct svxFilterCondition
809 {
810 evxHoleType HoleShape;
811 int isOnlyCylindrical;
812 int isDiameter;
813 double DiameterStart;
814 double DiameterEnd;
815 int isDepth;
816 double DepthStart;
817 double DepthEnd;
818 } FilterData;
819
820 int isUseFlaggedThread;
821 vxLongName type;
824 vxLongName size;
827 struct svxCustomData
828 {
829 double diamter;
830 int isPitch;
831 double value;
832 } custom;
833 evxFlagThreadDepthType DepthType;
835 double depth;
837 svxPntOnEnt* DepthPnt;
839 vxLongName CalloutLabel;
840 int isAddD1;
841 double UpperLimit;
842 double LowerLimit;
843 evxThreadHoleClass ThreadClass;
844 int isMachine;
846 int isCounter;
847 } svxFlagHoleData;
848
853typedef struct svxRibData
854 {
855 int idShape;
857 int idParent;
858 int idProfile;
859 int direction;
860 int widthType;
861 double width;
862 double angle;
863 int idPlane;
864 int numBndFaces;
865 int* idBndFaces;
866 int flipDir;
867 vxName ftrName;
868 } svxRibData;
869
874typedef struct svxFlagExtThreadData
875 {
876 int count;
877 svxPoint* Faces;
878 int* IdFaces;
879 vxLongName type;
882 vxLongName size;
885 struct svxCustomInfo
886 {
887 double diamter;
888 int isThread;
889 double value;
890 int useDiam;
891 } custom;
892 evxFlagThreadDepthType LengthType;
895 double length;
896 int isChamfer;
897 /* Input the SetBack and angle to create chamfer on the end of the face nearest the selection point.*/
898 double SetBack;
899 double angle;
900 } svxFlagExtThreadData;
901
906typedef struct svxThreadData
907 {
908 evxThreadType Type;
909 double Diameter;
910 double Length;
911 double PerUnit;
912 double Pitch;
913 int EndChamfer;
916 } svxThreadData;
917
922typedef struct svxLipData
923 {
924 /* specified lip edge, the edge and the face specifying the first side should be set in pairs */
925 int numEdges;
926 int* idEdge;
927 int* idFace;
929 double offset1;
931 double offset2;
932 vxName ftrName;
933 } svxLipData;
934
939typedef enum evxStockOpt
940 {
941 VX_STOCK_BLOCK = 1,
942 VX_STOCK_CYLINDER = 2,
943 } evxStockOpt;
944
949typedef struct svxStockData
950 {
951 evxStockOpt option;
952 int numEnts;
953 int* idEnts;
954 int adjustType;
955 int decimal;
956 vxName ftrName;
958 /* the relevant setting for stock type VX_STOCK_BLOCK */
959 int idPlane;
961 double length[2];
963 double width[2];
965 double height[2];
968 /* the relevant setting for stock type VX_STOCK_CYLINDER */
969 svxAxis axis;
970 int axisPos;
972 double radius;
974 double cylHgt[2];
976 } svxStockData;
977
978//====================================================================================================================
980//====================================================================================================================
985typedef struct svxFaceOffData
986 {
987 int type;
989 /* the relevant setting for constant type (type = 0) */
990 int numFaces;
991 int* idFaces;
992 double offset;
994 /* the relevant setting for variable type (type = 1), face and offset value should be set in pairs */
995 int numOffsetSet;
996 int* idFaceSet;
997 double* offsetSet;
999 int sideFaces;
1000 int extension;
1001 int intersect;
1003 vxName ftrName;
1004 } svxFaceOffData;
1005
1010typedef struct svxShellData
1011 {
1012 int idShape;
1013 double dThick;
1014 /* Select which faces if any should be deleted from offset consideration.These faces will reside in the new feature but will not be offset. */
1015 int cntOpenFace;
1016 int* pIdOpenFace;
1018 /* set the offset value to specified face */
1019 int cntList;
1020 int* pIdFace;
1021 double* pOffSet;
1023 /* Settings */
1024 int sideFaces;
1027 int KeepPrimFace;
1030 int Intersect;
1036 } svxShellData;
1037
1042typedef struct svxThickenData
1043 {
1044 int type;
1045 double thick;
1047 vxName ftrName;
1049 /* the relevant setting for sheet type (type = 0) */
1050 int idShape;
1051 int keep;
1053 /* the relevant setting for Faces type (type = 1) */
1054 int numFaces;
1055 int* idFaces;
1057 /* set additional offset, the face and the thick must be set in pairs */
1058 int numOffset;
1059 int* idOffFaces;
1060 double* thickT;
1061 } svxThickenData;
1062
1067typedef struct svxDivideData
1068 {
1069 int numBase;
1070 int* idBase;
1071 int numCutter;
1072 int* idCutters;
1074 /* the relevant setting for sheet type (type = 0) */
1075 int keepCutter;
1076 int trimCap;
1077 int extend;
1079 vxName ftrName;
1080 } svxDivideData;
1081
1086typedef struct svxTrimData
1087 {
1088 int numBase;
1089 int* idBase;
1090 int numTrimm;
1091 int* idTrimmer;
1093 int flip;
1094 int trimType;
1095 int trimCap;
1096 int keepTrimm;
1097 int extend;
1099 vxName ftrName;
1100 } svxTrimData;
1101
1106typedef enum evxOverflowType
1107 {
1108 VX_OF_AUTOMATIC = 0,
1109 VX_OF_CHANGE = 1,
1110 VX_OF_STATIONARY = 2,
1111 VX_OF_CAP = 3,
1112 } evxOverflowType;
1113
1118typedef struct svxReplaceData
1119 {
1120 int numBases;
1121 int* idBases;
1122 int idPlace;
1123 double offset;
1124 evxOverflowType faceOverflow;
1125 int keepReplaceFace;
1126 } svxReplaceData;
1127
1132typedef struct svxInlayData
1133 {
1134 int numFaces;
1135 int* idFaces;
1136 int numCrvs;
1137 int* idCrvs;
1138 double offset;
1140 int projType;
1141 svxVector projDir;
1142 svxVector inlayDir;
1143 int draftAbout;
1144 double draftAngle;
1145 int filletType;
1146 int filletAbout;
1147 double filletRad;
1149 vxName ftrName;
1150 } svxInlayData;
1151
1156typedef struct svxPartSelfX
1157 {
1158 int numEnt;
1159 int* idEnts;
1160 int region;
1161 } svxPartSelfX;
1162
1167typedef struct svxPunch
1168 {
1169 int numBase;
1170 int* idBases;
1171 int idPunch;
1172 int numBound;
1173 int* idBounds;
1174 double thickness;
1175 } svxPunch;
1176
1177//====================================================================================================================
1179//====================================================================================================================
1184typedef struct svxTwistData
1185 {
1186 /* Required */
1187 int numShapes;
1188 int* idShapes;
1189 int idDatum;
1190 double range;
1191 double angle;
1192 /* Settings */
1193 svxVector* axis;
1194 int keepOriginal;
1195 int miniSurfData;
1196 } svxTwistData;
1197
1202typedef struct svxTaperData
1203 {
1204 /* Required */
1205 int numShapes;
1206 int* idShapes;
1207 int idDatum;
1208 double range;
1209 double factor;
1210 /* Settings */
1211 svxVector* axis;
1212 int keepOriginal;
1213 int miniSurfData;
1214 } svxTaperData;
1215
1220typedef struct svxStretchData
1221 {
1222 /* Required */
1223 int numShapes;
1224 int* idShapes;
1225 int idDatum;
1226 /* Range */
1227 double xRange;
1228 double yRange;
1229 double zRange;
1230 /* Scale */
1231 double xScale;
1232 double yScale;
1233 double zScale;
1234 /* Settings */
1235 int framework;
1236 int uniStress;
1237 int keepOriginal;
1238 int miniSurfData;
1239 } svxStretchData;
1240
1245typedef struct svxMorphToCrvData
1246 {
1247 /* Required */
1248 int numGeometry;
1249 int* idGeometry;
1250 int idFromCurve;
1251 int idToCurve;
1252 /* Settings */
1253 int miniSurfData;
1254 int bendOrTranslate;
1258 double infulence[2];
1259 int rigid[2];
1260 int bulge[2];
1261 int slope[2];
1262 int flatOrPeak[2];
1263 int numStationary;
1264 int* idStationary;
1265 } svxMorphToCrvData;
1266
1267//====================================================================================================================
1269//====================================================================================================================
1270/* */
1275typedef enum evxPatternType
1276 {
1277 VX_PATTERN_LINEAR,
1278 VX_PATTERN_CIRCULAR,
1279 VX_PATTERN_PNT_TO_PNT,
1280 VX_PATTERN_AT_PATTERN,
1281 VX_PATTERN_AT_CURVES,
1282 VX_PATTERN_AT_FACE,
1283 VX_PATTERN_POLYGON,
1284 VX_PATTERN_FILL_PATTERN,
1285 VX_PATTERN_BY_VAR,
1286 } evxPatternType;
1287
1292typedef struct svxPtnData
1293 {
1294 evxBoolType combine;
1295 evxPatternType type;
1297 union PtnData
1298 {
1299 struct svxLinear
1300 {
1301 int useSecondDir;
1302 svxVector dir[2];
1303 int num[2];
1304 double spacing[2];
1305 } linear;
1306 struct svxCircular
1307 {
1308 svxAxis axis;
1309 double diameter;
1310 int useSecondDir;
1311 int num[2];
1312 double angle;
1313 double spacing;
1314 } circular;
1315 struct svxPolygon
1316 {
1317 svxAxis axis;
1318 int numSides;
1320 int spacingType;
1321 int number;
1322 double pitch;
1324 int useSecondDir;
1325 int numConcentric;
1326 double spacing;
1327 } polygon;
1328 struct svxPntToPnt
1329 {
1330 int numPnts;
1331 int* idParPnt;
1332 svxPoint* pnt;
1333 } PntToPnt;
1334 struct svxPattern
1335 {
1336 int idPtnFtr;
1337 } pattern;
1338 struct svxPtnCrv
1339 {
1340 int curveType;
1341 int numCrvs;
1342 int* idCrvs;
1344 int useSecondDir;
1345 int num[2];
1346 double spacing[2];
1347 } ptnCrv;
1348 struct svxPtnFace
1349 {
1350 int idFace;
1351 int useSecondDir;
1352 int num[2];
1353 double spacing[2];
1354 } ptnFace;
1355 struct svxPntFill
1356 {
1357 int type;
1358 int idSketch;
1359 double spacing;
1360 double angle;
1361 double border;
1362 double radius;
1363 } ptnFill;
1364 struct svxPntVar
1365 {
1366 int useSecondDir;
1367 int num[2];
1368 } ptnVar;
1369 } ptnData;
1370
1371 int useBasePnt;
1372 int idParent;
1373 svxPoint basePnt;
1374 int relocateBase;
1378 int deriveType;
1379 double minPer;
1380 vxName ftrName;
1382 int cntSkip;
1383 int* skipList;
1387 int* firstTogglePos;
1388 int* secondTogglePos;
1396 } svxPtnData;
1397
1402typedef struct svxPtnGeom
1403 {
1404 svxPtnData* inpData;
1405 int nonAssoCopy;
1408 }svxPtnGeom;
1409
1414typedef struct svxPtnVarTbl
1415 {
1416 vxName dimName;
1417 int cntCell;
1418 int* pCell;
1428 double* pVal;
1429 }svxPtnVarTbl;
1430
1435typedef struct svxPtnFtr
1436 {
1437 svxPtnData* inpData;
1438 int inc;
1439 int cntDim;
1440 svxPtnVarTbl* pTableVal;
1441 }svxPtnFtr;
1442
1447typedef struct svxMirrorGeom
1448 {
1449 int numEnts;
1450 int* idEnts;
1451 int idPlane;
1453 evxBoolType combine;
1454 int numShapes;
1455 int* idShapes;
1457 int keep;
1458 int assoCopy;
1460 vxName ftrName;
1461 } svxMirrorGeom;
1462
1467typedef struct svxMirrorFtr
1468 {
1469 int numFtrs;
1470 int* idFtrs;
1471 int idPlane;
1473 evxBoolType combine;
1474 int numShapes;
1475 int* idShapes;
1477 int keep;
1478 vxName ftrName;
1479 } svxMirrorFtr;
1480
1485typedef enum evxMoveType
1486 {
1487 VX_PNT_TO_PNT = 1,
1488 VX_ALONG_DIR = 2,
1489 VX_ASLIGN_FRAMES = 3,
1490 VX_SWEEP_ALONG_PATH = 4,
1491 VX_AROUND_DIR = 5,
1492 VX_DYNAMIC_MOVE = 6,
1493 } evxMoveType;
1494
1499typedef struct svxDymMove
1500 {
1501 int MoveHand;
1502 svxPoint Pos;
1503 svxVector XAxis;
1504 svxVector YAxis;
1505 svxVector ZAxis;
1506 }svxDymMove;
1507
1512typedef struct svxMovePntToPnt
1513 {
1514 svxPntOnEnt FromPnt;
1515 svxPntOnEnt ToPnt;
1516 /*modify the alignment while moving or copying*/
1517 svxPntOnEnt FromVector;
1518 svxPntOnEnt ToVector;
1519 } svxMovePntToPnt;
1520
1525typedef struct svxAlongDir
1526 {
1527 svxPntOnEnt Dir;
1528 double Dist;
1529 int UnuseAng;
1530 double Ang;
1531 } svxAlongDir;
1532
1537typedef struct svxAroundDir
1538 {
1539 svxPntOnEnt Dir;
1540 double Ang;
1541 } svxAroundDir;
1542
1547typedef struct svxAlignFrame
1548 {
1549 int idFrom;
1550 int idTo;
1551 } svxAlignFrame;
1552
1557typedef struct svxAlongPath
1558 {
1559 svxPntOnEnt Path;
1560 int cntPnts;
1561 svxPntOnEnt* ToPnts;
1562 int FrameOpt;
1563 int IdFrame;
1564 evxSweepZOpt ZAxisOpt;
1565 svxPntOnEnt ZAxisCurve;
1568 evxSweepXOpt XAxisOpt;
1569 svxPntOnEnt XAxisCurve;
1571 } svxAlongPath;
1572
1577typedef struct svxMoveData
1578 {
1579 evxMoveType method;
1580 int cntEnt;
1581 int* pEnts;
1582 union evxMethodsUnion
1583 {
1584 svxDymMove DymMove;
1585 svxMovePntToPnt PntToPnt;
1586 svxAlongDir AlongDir;
1587 svxAroundDir AroundDir;
1588 svxAlignFrame AlignFrame;
1589 svxAlongPath Sweep;
1590 } MethodUnion;
1591 } svxMoveData;
1592
1597typedef struct svxCopyData
1598 {
1599 evxMoveType method;
1600 int cntEnt;
1601 int* pEnts;
1602 union evxMethodUnion
1603 {
1604 svxDymMove DymCopy;
1605 svxMovePntToPnt PntToPnt;
1606 svxAlongDir AlongDir;
1607 svxAroundDir AroundDir;
1608 svxAlignFrame AlignFrame;
1609 svxAlongPath Sweep;
1610 } MethodUnion;
1611 int CpyNum;
1612 int isNonAssoCopy;
1615 vxName layName;
1616 } svxCopyData;
1617
1618/*
1619*********************************************************************
1620** END HEADER FILE
1621*********************************************************************
1622*/
1623
1624#ifdef __cplusplus
1625 }
1626#endif /* __cplusplus */
1627
1628#endif /* ZW_API_SHAPE_FTR_DATA_H */
evxSweepZOpt
evxSweepZOpt
sweep Zaxis option
Definition: zwapi_cmd_shape_data.h:271
VX_SWP_Z_FIXED_DIR
@ VX_SWP_Z_FIXED_DIR
parallel with the fixed direction
Definition: zwapi_cmd_shape_data.h:274
VX_SWP_Z_TANG_TO_PATH
@ VX_SWP_Z_TANG_TO_PATH
tangent to path (default)
Definition: zwapi_cmd_shape_data.h:272
VX_SWP_Z_TANG_TO_CRV
@ VX_SWP_Z_TANG_TO_CRV
tangent to curve
Definition: zwapi_cmd_shape_data.h:273
evxLeadType
evxLeadType
lead type
Definition: zwapi_cmd_shape_data.h:142
VX_LEAD_OUT
@ VX_LEAD_OUT
transitions the spiral out away from the center of the axis for threaded cuts
Definition: zwapi_cmd_shape_data.h:144
VX_LEAD_IN
@ VX_LEAD_IN
transitions the spiral in toward the center of the axis for spiral solids and threaded bosses
Definition: zwapi_cmd_shape_data.h:143
VX_LEAD_NONE
@ VX_LEAD_NONE
no lead in/out applied
Definition: zwapi_cmd_shape_data.h:145
evxHoleType
evxHoleType
hole types
Definition: zwapi_cmd_shape_data.h:618
VX_HOLE_SIMPLE
@ VX_HOLE_SIMPLE
simple
Definition: zwapi_cmd_shape_data.h:620
VX_HOLE_TAPERED
@ VX_HOLE_TAPERED
tapered
Definition: zwapi_cmd_shape_data.h:621
VX_HOLE_SPOT_FACE
@ VX_HOLE_SPOT_FACE
spot_face
Definition: zwapi_cmd_shape_data.h:624
VX_HOLE_COUNTER_SUNK
@ VX_HOLE_COUNTER_SUNK
counter_sunk
Definition: zwapi_cmd_shape_data.h:623
VX_HOLE_SHAPE_ALL
@ VX_HOLE_SHAPE_ALL
all,used in "flag holes"
Definition: zwapi_cmd_shape_data.h:619
VX_HOLE_COUNTER_BORE
@ VX_HOLE_COUNTER_BORE
counter_bore
Definition: zwapi_cmd_shape_data.h:622
evxThreadHoleClass
evxThreadHoleClass
thread class for flag holes
Definition: zwapi_cmd_shape_data.h:773
VX_THREAD_HOLE_1B
@ VX_THREAD_HOLE_1B
1B
Definition: zwapi_cmd_shape_data.h:775
VX_THREAD_HOLE_UNDEFINED
@ VX_THREAD_HOLE_UNDEFINED
undefined
Definition: zwapi_cmd_shape_data.h:774
VX_THREAD_HOLE_3B
@ VX_THREAD_HOLE_3B
3B
Definition: zwapi_cmd_shape_data.h:777
VX_THREAD_HOLE_2B
@ VX_THREAD_HOLE_2B
2B
Definition: zwapi_cmd_shape_data.h:776
evxMoveType
evxMoveType
Move and Copy Methods.
Definition: zwapi_cmd_shape_data.h:1486
VX_DYNAMIC_MOVE
@ VX_DYNAMIC_MOVE
dynamic copy/move entities
Definition: zwapi_cmd_shape_data.h:1492
VX_SWEEP_ALONG_PATH
@ VX_SWEEP_ALONG_PATH
copy/move entities along path
Definition: zwapi_cmd_shape_data.h:1490
VX_ASLIGN_FRAMES
@ VX_ASLIGN_FRAMES
copy/move entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1489
VX_PNT_TO_PNT
@ VX_PNT_TO_PNT
copy/move entities form point to point
Definition: zwapi_cmd_shape_data.h:1487
VX_AROUND_DIR
@ VX_AROUND_DIR
rotate entities around a direction
Definition: zwapi_cmd_shape_data.h:1491
VX_ALONG_DIR
@ VX_ALONG_DIR
copy/move entities along a direction
Definition: zwapi_cmd_shape_data.h:1488
evxOverflowType
evxOverflowType
overflow types
Definition: zwapi_cmd_shape_data.h:1107
VX_OF_AUTOMATIC
@ VX_OF_AUTOMATIC
automatically choose the faces to extend
Definition: zwapi_cmd_shape_data.h:1108
VX_OF_CAP
@ VX_OF_CAP
extend cap face
Definition: zwapi_cmd_shape_data.h:1111
VX_OF_STATIONARY
@ VX_OF_STATIONARY
extend stationary face
Definition: zwapi_cmd_shape_data.h:1110
VX_OF_CHANGE
@ VX_OF_CHANGE
extend change face
Definition: zwapi_cmd_shape_data.h:1109
evxEndCondition
evxEndCondition
hole end conditions
Definition: zwapi_cmd_shape_data.h:686
VX_THROUGH_ALL
@ VX_THROUGH_ALL
through all
Definition: zwapi_cmd_shape_data.h:689
VX_UNTIL_FACE
@ VX_UNTIL_FACE
until face
Definition: zwapi_cmd_shape_data.h:688
VX_BLIND
@ VX_BLIND
blind
Definition: zwapi_cmd_shape_data.h:687
evxOffsetType
evxOffsetType
offset type
Definition: zwapi_cmd_shape_data.h:130
VX_OFFSET_THICKEN_SAME
@ VX_OFFSET_THICKEN_SAME
Thicken same.
Definition: zwapi_cmd_shape_data.h:134
VX_OFFSET_NONE
@ VX_OFFSET_NONE
none
Definition: zwapi_cmd_shape_data.h:131
VX_OFFSET_THICKEN
@ VX_OFFSET_THICKEN
Thicken.
Definition: zwapi_cmd_shape_data.h:133
VX_OFFSET_SHRINK
@ VX_OFFSET_SHRINK
Shrink / Expand.
Definition: zwapi_cmd_shape_data.h:132
evxClearHoleType
evxClearHoleType
hole type of clearance hole
Definition: zwapi_cmd_shape_data.h:632
VX_CLEAR_HOLE_COUNT_SINK_SLOT
@ VX_CLEAR_HOLE_COUNT_SINK_SLOT
countersink slot
Definition: zwapi_cmd_shape_data.h:637
VX_CLEAR_HOLE_SIMPLE
@ VX_CLEAR_HOLE_SIMPLE
simple
Definition: zwapi_cmd_shape_data.h:633
VX_CLEAR_HOLE_COUNT_BORE_SLOT
@ VX_CLEAR_HOLE_COUNT_BORE_SLOT
counterbore slot
Definition: zwapi_cmd_shape_data.h:638
VX_CLEAR_HOLE_COUNT_SINK
@ VX_CLEAR_HOLE_COUNT_SINK
counter-sink
Definition: zwapi_cmd_shape_data.h:635
VX_CLEAR_HOLE_SLOT
@ VX_CLEAR_HOLE_SLOT
slot
Definition: zwapi_cmd_shape_data.h:636
VX_CLEAR_HOLE_COUNT_BORE
@ VX_CLEAR_HOLE_COUNT_BORE
counter-Bore
Definition: zwapi_cmd_shape_data.h:634
evxDraftType
evxDraftType
draft type
Definition: zwapi_cmd_shape_data.h:545
VX_STATION_ASYM_FACE_DRAFT
@ VX_STATION_ASYM_FACE_DRAFT
Stationary Asymmetric.
Definition: zwapi_cmd_shape_data.h:553
VX_STATION_PARTING_FACE_DRAFT
@ VX_STATION_PARTING_FACE_DRAFT
Stationary and parting.
Definition: zwapi_cmd_shape_data.h:554
VX_ASYM_EDGE_DRAFT
@ VX_ASYM_EDGE_DRAFT
Asymmetric draft.
Definition: zwapi_cmd_shape_data.h:549
VX_DRAFT_TYPE_NONE
@ VX_DRAFT_TYPE_NONE
no draft type
Definition: zwapi_cmd_shape_data.h:546
VX_STATION_SYM_FACE_DRAFT
@ VX_STATION_SYM_FACE_DRAFT
Stationary symmetric.
Definition: zwapi_cmd_shape_data.h:552
VX_SYM_EDGE_DRAFT
@ VX_SYM_EDGE_DRAFT
Symmetric draft.
Definition: zwapi_cmd_shape_data.h:548
evxPatternType
evxPatternType
pattern method
Definition: zwapi_cmd_shape_data.h:1276
VX_PATTERN_PNT_TO_PNT
@ VX_PATTERN_PNT_TO_PNT
irregular pattern of objects from point to point
Definition: zwapi_cmd_shape_data.h:1279
VX_PATTERN_CIRCULAR
@ VX_PATTERN_CIRCULAR
circular pattern
Definition: zwapi_cmd_shape_data.h:1278
VX_PATTERN_POLYGON
@ VX_PATTERN_POLYGON
polygon pattern
Definition: zwapi_cmd_shape_data.h:1283
VX_PATTERN_FILL_PATTERN
@ VX_PATTERN_FILL_PATTERN
fill pattern
Definition: zwapi_cmd_shape_data.h:1284
VX_PATTERN_AT_FACE
@ VX_PATTERN_AT_FACE
pattern in space using an existing surface
Definition: zwapi_cmd_shape_data.h:1282
VX_PATTERN_AT_PATTERN
@ VX_PATTERN_AT_PATTERN
pattern of objects at locations defined by a previous pattern
Definition: zwapi_cmd_shape_data.h:1280
VX_PATTERN_AT_CURVES
@ VX_PATTERN_AT_CURVES
pattern in space using one or more input curves
Definition: zwapi_cmd_shape_data.h:1281
VX_PATTERN_LINEAR
@ VX_PATTERN_LINEAR
linear pattern
Definition: zwapi_cmd_shape_data.h:1277
VX_PATTERN_BY_VAR
@ VX_PATTERN_BY_VAR
feature pattern by variant parameters(just use pattern feature command)
Definition: zwapi_cmd_shape_data.h:1285
evxSweepOpt
evxSweepOpt
sweep option
Definition: zwapi_cmd_shape_data.h:246
VX_SWP_NATURAL
@ VX_SWP_NATURAL
Default frame.
Definition: zwapi_cmd_shape_data.h:247
VX_SWP_AT_PROFILE
@ VX_SWP_AT_PROFILE
At intersection.
Definition: zwapi_cmd_shape_data.h:250
VX_SWP_FRAME
@ VX_SWP_FRAME
Selected.
Definition: zwapi_cmd_shape_data.h:249
VX_SWP_ALONG_PATH
@ VX_SWP_ALONG_PATH
Along Path.
Definition: zwapi_cmd_shape_data.h:251
VX_SWP_AT_PATH
@ VX_SWP_AT_PATH
At Path.
Definition: zwapi_cmd_shape_data.h:248
evxDraftMethods
evxDraftMethods
draft methods
Definition: zwapi_cmd_shape_data.h:534
VX_FACE_DRAFT
@ VX_FACE_DRAFT
Face Draft.
Definition: zwapi_cmd_shape_data.h:536
VX_EDGE_DRAFT
@ VX_EDGE_DRAFT
Edge Draft.
Definition: zwapi_cmd_shape_data.h:535
VX_PRATING_EDGE_DRAFT
@ VX_PRATING_EDGE_DRAFT
Parting Edge Draft.
Definition: zwapi_cmd_shape_data.h:537
evxBoolType
evxBoolType
boolean combination method
Definition: zwapi_cmd_shape_data.h:34
VX_BOOL_REMOVE
@ VX_BOOL_REMOVE
remove
Definition: zwapi_cmd_shape_data.h:37
VX_BOOL_INTERSECT
@ VX_BOOL_INTERSECT
intersect
Definition: zwapi_cmd_shape_data.h:38
VX_BOOL_ADD
@ VX_BOOL_ADD
add
Definition: zwapi_cmd_shape_data.h:36
VX_BOOL_NONE
@ VX_BOOL_NONE
base
Definition: zwapi_cmd_shape_data.h:35
evxSweepXOpt
evxSweepXOpt
sweep Xaxis option
Definition: zwapi_cmd_shape_data.h:259
VX_SWP_X_FACE_NORMAL
@ VX_SWP_X_FACE_NORMAL
face normal
Definition: zwapi_cmd_shape_data.h:263
VX_SWP_X_MIN_TWIST
@ VX_SWP_X_MIN_TWIST
minimum twist (default)
Definition: zwapi_cmd_shape_data.h:260
VX_SWP_X_FIXED_DIR
@ VX_SWP_X_FIXED_DIR
fixed direction
Definition: zwapi_cmd_shape_data.h:261
VX_SWP_X_XAXIS_CRV
@ VX_SWP_X_XAXIS_CRV
X-axis curve.
Definition: zwapi_cmd_shape_data.h:262
evxStockOpt
evxStockOpt
stock type
Definition: zwapi_cmd_shape_data.h:940
VX_STOCK_BLOCK
@ VX_STOCK_BLOCK
block type
Definition: zwapi_cmd_shape_data.h:941
VX_STOCK_CYLINDER
@ VX_STOCK_CYLINDER
cylinder type
Definition: zwapi_cmd_shape_data.h:942
evxFlagThreadDepthType
evxFlagThreadDepthType
flagged as thread hole depth type
Definition: zwapi_cmd_shape_data.h:785
VX_FLAG_THREAD_UNDEFINED
@ VX_FLAG_THREAD_UNDEFINED
undefined
Definition: zwapi_cmd_shape_data.h:786
VX_FLAG_THREAD_DEPTH_1XDIAMETER
@ VX_FLAG_THREAD_DEPTH_1XDIAMETER
1.0 x diameter
Definition: zwapi_cmd_shape_data.h:788
VX_FLAG_THREAD_DEPTH_CUSTOM
@ VX_FLAG_THREAD_DEPTH_CUSTOM
custom
Definition: zwapi_cmd_shape_data.h:794
VX_FLAG_THREAD_DEPTH_15XDIAMETER
@ VX_FLAG_THREAD_DEPTH_15XDIAMETER
1.5 x diameter
Definition: zwapi_cmd_shape_data.h:789
VX_FLAG_THREAD_DEPTH_FULL
@ VX_FLAG_THREAD_DEPTH_FULL
full
Definition: zwapi_cmd_shape_data.h:793
VX_FLAG_THREAD_DEPTH_25XDIAMETER
@ VX_FLAG_THREAD_DEPTH_25XDIAMETER
2.5 x diameter
Definition: zwapi_cmd_shape_data.h:791
VX_FLAG_THREAD_DEPTH_DEFAULT
@ VX_FLAG_THREAD_DEPTH_DEFAULT
default
Definition: zwapi_cmd_shape_data.h:787
VX_FLAG_THREAD_DEPTH_2XDIAMETER
@ VX_FLAG_THREAD_DEPTH_2XDIAMETER
2.0 x diameter
Definition: zwapi_cmd_shape_data.h:790
VX_FLAG_THREAD_DEPTH_3XDIAMETER
@ VX_FLAG_THREAD_DEPTH_3XDIAMETER
3.0 x diameter
Definition: zwapi_cmd_shape_data.h:792
evxChamFlltType
evxChamFlltType
chamfer or fillet types
Definition: zwapi_cmd_shape_data.h:413
VX_CHAMFLLT_ASYMMETRIC
@ VX_CHAMFLLT_ASYMMETRIC
asymmetric chamfer or fillet: double offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:415
VX_CHAMFLLT_SETBACK_ANGLE
@ VX_CHAMFLLT_SETBACK_ANGLE
asymmetric chamfer or fillet: offset and angle chamfer at edge
Definition: zwapi_cmd_shape_data.h:416
VX_CHAMFLLT_VERTEX
@ VX_CHAMFLLT_VERTEX
vertex chamfer or fillet: single offset chamfer at vertex
Definition: zwapi_cmd_shape_data.h:417
VX_CHAMFLLT_SYMMETRIC
@ VX_CHAMFLLT_SYMMETRIC
symmetric chamfer or fillet: single offset chamfer at edge
Definition: zwapi_cmd_shape_data.h:414
evxLoftType
evxLoftType
loft method
Definition: zwapi_cmd_shape_data.h:376
VX_LOFT_END_PNT_PROFS
@ VX_LOFT_END_PNT_PROFS
loft based on ending point and profiles
Definition: zwapi_cmd_shape_data.h:379
VX_LOFT_BOTH_PNTS_PROFS
@ VX_LOFT_BOTH_PNTS_PROFS
loft based on both end points and profiles
Definition: zwapi_cmd_shape_data.h:380
VX_LOFT_PROFS
@ VX_LOFT_PROFS
loft profiles in the order of profiles selection
Definition: zwapi_cmd_shape_data.h:377
VX_LOFT_START_PNT_PROFS
@ VX_LOFT_START_PNT_PROFS
loft based on starting point and profiles
Definition: zwapi_cmd_shape_data.h:378
evxHoleOpt
evxHoleOpt
hole option
Definition: zwapi_cmd_shape_data.h:606
VX_GENERAL_HOLE
@ VX_GENERAL_HOLE
general hole
Definition: zwapi_cmd_shape_data.h:607
VX_CLEARANCE_HOLE
@ VX_CLEARANCE_HOLE
clearance hole
Definition: zwapi_cmd_shape_data.h:608
VX_THREAD_HOLE
@ VX_THREAD_HOLE
thread hole
Definition: zwapi_cmd_shape_data.h:609
VX_PROFILE_HOLE
@ VX_PROFILE_HOLE
profile hole
Definition: zwapi_cmd_shape_data.h:610
evxThreadType
evxThreadType
hole thread types
Definition: zwapi_cmd_shape_data.h:646
evxCapType
evxCapType
End caps.
Definition: zwapi_cmd_shape_data.h:153
VX_END_CAP_BOTH
@ VX_END_CAP_BOTH
both
Definition: zwapi_cmd_shape_data.h:154
VX_END_CAP_NONE
@ VX_END_CAP_NONE
none
Definition: zwapi_cmd_shape_data.h:157
VX_END_CAP_END
@ VX_END_CAP_END
end
Definition: zwapi_cmd_shape_data.h:156
VX_END_CAP_START
@ VX_END_CAP_START
start
Definition: zwapi_cmd_shape_data.h:155
svxSphereData
struct svxSphereData svxSphereData
sphere
svxConeData
struct svxConeData svxConeData
cone
svxLoftData
struct svxLoftData svxLoftData
loft data
svxRibData
struct svxRibData svxRibData
rib data
svxStockData
struct svxStockData svxStockData
stock data
svxThreadData
struct svxThreadData svxThreadData
thread definition
svxHoleData
struct svxHoleData svxHoleData
hole data
svxPartSelfX
struct svxPartSelfX svxPartSelfX
part resolveSelfX data
svxAlignFrame
struct svxAlignFrame svxAlignFrame
copy/move entities by aligning frames
svxReplaceData
struct svxReplaceData svxReplaceData
shape replace data
svxDymMove
struct svxDymMove svxDymMove
dynamic copy/move entities
svxCylData
struct svxCylData svxCylData
cylinder
svxBoxData
struct svxBoxData svxBoxData
box data
svxStretchData
struct svxStretchData svxStretchData
shape stretch data
svxDivideData
struct svxDivideData svxDivideData
divide data
svxCopyData
struct svxCopyData svxCopyData
template command Copy data
svxPtnData
struct svxPtnData svxPtnData
pattern data
svxPtnFtr
struct svxPtnFtr svxPtnFtr
pattern feature data
svxSpiralSweepData
struct svxSpiralSweepData svxSpiralSweepData
spiral swept shape
svxDraftData
struct svxDraftData svxDraftData
template command Draft data
svxLoftProfile
struct svxLoftProfile svxLoftProfile
loft profile data
svxThickenData
struct svxThickenData svxThickenData
thicken data
svxMoveData
struct svxMoveData svxMoveData
template command Move data
svxAroundDir
struct svxAroundDir svxAroundDir
rotate entities around a direction
svxLipData
struct svxLipData svxLipData
lip data
svxChamFlltSetData
struct svxChamFlltSetData svxChamFlltSetData
set-list data for chamfer or fillet command
svxRevolveData
struct svxRevolveData svxRevolveData
revolved shape
svxAlongDir
struct svxAlongDir svxAlongDir
copy/move entities along a direction
svxTwistData
struct svxTwistData svxTwistData
shape twist data
svxFlagHoleData
struct svxFlagHoleData svxFlagHoleData
flag hole data
svxAlongPath
struct svxAlongPath svxAlongPath
copy/move entities along path
svxMovePntToPnt
struct svxMovePntToPnt svxMovePntToPnt
copy/move entities form point to point
svxInlayData
struct svxInlayData svxInlayData
inlay data
svxFaceOffData
struct svxFaceOffData svxFaceOffData
shape face offset data
svxEllsoData
struct svxEllsoData svxEllsoData
ellipsoid
svxMorphToCrvData
struct svxMorphToCrvData svxMorphToCrvData
shape morph to curve data
svxHoleChams
struct svxHoleChams svxHoleChams
Hole chamfer, added in 1900.
svxPtnGeom
struct svxPtnGeom svxPtnGeom
pattern geometry data
svxMirrorFtr
struct svxMirrorFtr svxMirrorFtr
mirror feature data
svxPunch
struct svxPunch svxPunch
part punch data
svxChamFlltData
struct svxChamFlltData svxChamFlltData
chamfer or fillet data
svxShellData
struct svxShellData svxShellData
template command Shell input data
svxPtnVarTbl
struct svxPtnVarTbl svxPtnVarTbl
table dimension information
svxFlagExtThreadData
struct svxFlagExtThreadData svxFlagExtThreadData
flag ext thread data
svxExtrudeData
struct svxExtrudeData svxExtrudeData
extruded shape
svxTaperData
struct svxTaperData svxTaperData
shape taper data
svxSweepData
struct svxSweepData svxSweepData
swept shape
svxTrimData
struct svxTrimData svxTrimData
Trim data.
svxMirrorGeom
struct svxMirrorGeom svxMirrorGeom
mirror geometry data
evxDistanceMethod
evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
Definition: zwapi_cmd_subcmd_data.h:57
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAlignFrame::idFrom
int idFrom
from frame
Definition: zwapi_cmd_shape_data.h:1549
svxAlignFrame::idTo
int idTo
to frames
Definition: zwapi_cmd_shape_data.h:1550
svxAlignFrame
copy/move entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1548
svxAlongDir::Dist
double Dist
distance value
Definition: zwapi_cmd_shape_data.h:1528
svxAlongDir::UnuseAng
int UnuseAng
angle enable (default 0)
Definition: zwapi_cmd_shape_data.h:1529
svxAlongDir::Ang
double Ang
angle value
Definition: zwapi_cmd_shape_data.h:1530
svxAlongDir::Dir
svxPntOnEnt Dir
direction
Definition: zwapi_cmd_shape_data.h:1527
svxAlongDir
copy/move entities along a direction
Definition: zwapi_cmd_shape_data.h:1526
svxAlongPath::ZAxisOpt
evxSweepZOpt ZAxisOpt
Z Axis option.
Definition: zwapi_cmd_shape_data.h:1564
svxAlongPath::ZAxisCurve
svxPntOnEnt ZAxisCurve
entity data of z-axis (ignore when zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_TO_CRV- curve(set pare...
Definition: zwapi_cmd_shape_data.h:1565
svxAlongPath::IdFrame
int IdFrame
frame is selected( if FrameOpt = 2)
Definition: zwapi_cmd_shape_data.h:1563
svxAlongPath::ToPnts
svxPntOnEnt * ToPnts
to points
Definition: zwapi_cmd_shape_data.h:1561
svxAlongPath::Path
svxPntOnEnt Path
path
Definition: zwapi_cmd_shape_data.h:1559
svxAlongPath::FrameOpt
int FrameOpt
frame option(0-default frame, 1-at path, 2-selected)
Definition: zwapi_cmd_shape_data.h:1562
svxAlongPath::cntPnts
int cntPnts
count of points
Definition: zwapi_cmd_shape_data.h:1560
svxAlongPath::XAxisOpt
evxSweepXOpt XAxisOpt
X Axis option (exclude VX_SWP_X_FACE_NORMAL)
Definition: zwapi_cmd_shape_data.h:1568
svxAlongPath::XAxisCurve
svxPntOnEnt XAxisCurve
entity data of x-axis (ignore when XAxisOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR- use direction (...
Definition: zwapi_cmd_shape_data.h:1569
svxAlongPath
copy/move entities along path
Definition: zwapi_cmd_shape_data.h:1558
svxAroundDir::Ang
double Ang
angle value
Definition: zwapi_cmd_shape_data.h:1540
svxAroundDir::Dir
svxPntOnEnt Dir
direction
Definition: zwapi_cmd_shape_data.h:1539
svxAroundDir
rotate entities around a direction
Definition: zwapi_cmd_shape_data.h:1538
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBoxData::idPlane
int idPlane
optional datum plane, or 0
Definition: zwapi_cmd_shape_data.h:48
svxBoxData::Center
svxPoint Center
center of box volume
Definition: zwapi_cmd_shape_data.h:51
svxBoxData::useAxis
int useAxis
flag to use axis, 0 default
Definition: zwapi_cmd_shape_data.h:49
svxBoxData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:47
svxBoxData::X
double X
length along X
Definition: zwapi_cmd_shape_data.h:52
svxBoxData::Y
double Y
length along Y
Definition: zwapi_cmd_shape_data.h:53
svxBoxData::ftrName
vxName ftrName
feature name for "FtAllBox", 0 default
Definition: zwapi_cmd_shape_data.h:55
svxBoxData::Z
double Z
length along Z
Definition: zwapi_cmd_shape_data.h:54
svxBoxData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:50
svxBoxData
box data
Definition: zwapi_cmd_shape_data.h:46
svxChamFlltData::baseFaces
int baseFaces
base face processing method (0-sew, 1-trim, 2-divide, 3-no action)
Definition: zwapi_cmd_shape_data.h:488
svxChamFlltData::setback2Pnt
svxPntOnEnt * setback2Pnt
setback2 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:496
svxChamFlltData::setback1Pnt
svxPntOnEnt * setback1Pnt
setback1 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:495
svxChamFlltData::cntList
int cntList
count of set list, 0-to ignore
Definition: zwapi_cmd_shape_data.h:499
svxChamFlltData::flip
int flip
1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE)
Definition: zwapi_cmd_shape_data.h:491
svxChamFlltData::weight
double weight[2]
endpoint weights for G2 blend arc type (0.1~5.0, 1.0-default)
Definition: zwapi_cmd_shape_data.h:466
svxChamFlltData::setback2
double setback2
the second setback distance for VX_CHAMFILT_ASYMMETRIC type
Definition: zwapi_cmd_shape_data.h:457
svxChamFlltData::nEdges
int nEdges
number of edges or vertexes to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:450
svxChamFlltData::traceCorners
int traceCorners
if set to 1, the rails of the chamfer/fillet and corner patch faces are traced onto the support faces...
Definition: zwapi_cmd_shape_data.h:480
svxChamFlltData::vertex
int * vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in thi...
Definition: zwapi_cmd_shape_data.h:452
svxChamFlltData::angle
double angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type
Definition: zwapi_cmd_shape_data.h:458
svxChamFlltData::setback1
double setback1
the first setback distance or radius
Definition: zwapi_cmd_shape_data.h:456
svxChamFlltData::localCorner
int localCorner
if set to 1, keep chamfering/filleting only to the edge, else the chamfer/fillet will extend to the s...
Definition: zwapi_cmd_shape_data.h:475
svxChamFlltData::mitred
int mitred
if set to 1, the chamfer/fillet engine will provide a mitred solution at corners of uniform convexity...
Definition: zwapi_cmd_shape_data.h:477
svxChamFlltData::offsetType
int offsetType
method of offset, 0- offset distance, 1- offset surface(default:0, only used for Charmer feature)
Definition: zwapi_cmd_shape_data.h:492
svxChamFlltData::idEdge
int * idEdge
list of index of edges to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:451
svxChamFlltData::relief
double relief
specify the amount of smoothing at a corner patch. When set to zero (0.0-default),...
Definition: zwapi_cmd_shape_data.h:461
svxChamFlltData::pChamFlltDataList
svxChamFlltSetData * pChamFlltDataList
data of each list, NULL to ignore
Definition: zwapi_cmd_shape_data.h:500
svxChamFlltData::filletFace
int filletFace
the tangency of the new chamfer/fillet faces (0-tangent match, 1-minimal, 2-maximal)
Definition: zwapi_cmd_shape_data.h:489
svxChamFlltData::arcType
int arcType
specify the fillet arc type (0-circular arc, 1-conic arc, 2-G2 blend)
Definition: zwapi_cmd_shape_data.h:464
svxChamFlltData::usePatch
int usePatch
whether to use patches in tight corners (0-default)
Definition: zwapi_cmd_shape_data.h:470
svxChamFlltData::undercuts
int undercuts
if set to 1, the chamfer/fillet engine will look for cases where the new chamfer/fillet are completel...
Definition: zwapi_cmd_shape_data.h:471
svxChamFlltData::continuity
int continuity
continuous way (0-tangent, 1-curvature)
Definition: zwapi_cmd_shape_data.h:485
svxChamFlltData::desity
int desity
the average number of sampling points along the edges of the blended corners (2~200)
Definition: zwapi_cmd_shape_data.h:486
svxChamFlltData::type
evxChamFlltType type
chamfer or fillet type
Definition: zwapi_cmd_shape_data.h:448
svxChamFlltData::filletToEdge
int filletToEdge
if set to 1, fillet held to nearby edges (0-default)
Definition: zwapi_cmd_shape_data.h:469
svxChamFlltData::blendCorners
int blendCorners
if set to 1, create a single smooth trimmed planar face for each corner via the FEM-based surface fit...
Definition: zwapi_cmd_shape_data.h:482
svxChamFlltData::conicRatio
double conicRatio
conic ratio for conic arc type (0~0.999999, 0.5-default)
Definition: zwapi_cmd_shape_data.h:465
svxChamFlltData
chamfer or fillet data
Definition: zwapi_cmd_shape_data.h:447
svxChamFlltSetData::idEdge
int * idEdge
list of index of edges to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:427
svxChamFlltSetData::angle
double angle
the angle of the setback for VX_CHAMFILT_SEEDBACK_ANGLE type
Definition: zwapi_cmd_shape_data.h:434
svxChamFlltSetData::setback1
double setback1
the first setback distance or radius
Definition: zwapi_cmd_shape_data.h:432
svxChamFlltSetData::chordalFillet
int chordalFillet
if set to 1, use chordal instead of radius for fillet, the variable 'setback1' will be treated as 'Ch...
Definition: zwapi_cmd_shape_data.h:431
svxChamFlltSetData::setback1Pnt
svxPntOnEnt * setback1Pnt
setback1 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:438
svxChamFlltSetData::flip
int flip
1-flip the edge direction, else 0 (type = VX_CHAMFLLT_ASYMMETRIC/VX_CHAMFLLT_SETBACK_ANGLE)
Definition: zwapi_cmd_shape_data.h:436
svxChamFlltSetData::setback2
double setback2
the second setback distance for VX_CHAMFILT_ASYMMETRIC type
Definition: zwapi_cmd_shape_data.h:433
svxChamFlltSetData::nEdges
int nEdges
number of edges or vertexes to chamfer or fillet
Definition: zwapi_cmd_shape_data.h:426
svxChamFlltSetData::vertex
int * vertex
list of endpoints for edges (0-starting vertex, 1-end vertex), like idEdge, the number of data in thi...
Definition: zwapi_cmd_shape_data.h:428
svxChamFlltSetData::setback2Pnt
svxPntOnEnt * setback2Pnt
setback2 value (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:439
svxChamFlltSetData
set-list data for chamfer or fillet command
Definition: zwapi_cmd_shape_data.h:425
svxConeData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:80
svxConeData::Center
svxPoint Center
center of bottom face
Definition: zwapi_cmd_shape_data.h:81
svxConeData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:87
svxConeData::Length
double Length
length (mm) along Z
Definition: zwapi_cmd_shape_data.h:83
svxConeData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:88
svxConeData::useAxis
int useAxis
flag to use axis (0 to use plane, 1 to use axis)
Definition: zwapi_cmd_shape_data.h:86
svxConeData::Radius2
double Radius2
the second radius (mm), 0 default
Definition: zwapi_cmd_shape_data.h:84
svxConeData::Radius1
double Radius1
the first radius (mm) in bottom face
Definition: zwapi_cmd_shape_data.h:82
svxConeData::ftrName
vxName ftrName
feature name for "FtAllCone", 0 default
Definition: zwapi_cmd_shape_data.h:90
svxConeData
cone
Definition: zwapi_cmd_shape_data.h:79
svxCopyData::layName
vxName layName
layer to copy if isNonAssoCopy is 1
Definition: zwapi_cmd_shape_data.h:1615
svxCopyData::CpyNum
int CpyNum
copy number (just method = VX_ALONG_DIR or VX_AROUND_DIR, and must initialize to 1)
Definition: zwapi_cmd_shape_data.h:1611
svxCopyData::pEnts
int * pEnts
entities ID
Definition: zwapi_cmd_shape_data.h:1601
svxCopyData::cntEnt
int cntEnt
entity count
Definition: zwapi_cmd_shape_data.h:1600
svxCopyData::isNonAssoCopy
int isNonAssoCopy
0-associative copy, 1-non associative copy(default 0) if set to 0, the duplicate will be associative ...
Definition: zwapi_cmd_shape_data.h:1612
svxCopyData::method
evxMoveType method
copy methods
Definition: zwapi_cmd_shape_data.h:1599
svxCopyData
template command Copy data
Definition: zwapi_cmd_shape_data.h:1598
svxCylData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:64
svxCylData::ftrName
vxName ftrName
feature name for "FtAllCyl", 0 default
Definition: zwapi_cmd_shape_data.h:71
svxCylData::Radius
double Radius
radius (mm) in XY plane
Definition: zwapi_cmd_shape_data.h:69
svxCylData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:65
svxCylData::Length
double Length
length (mm) along Z
Definition: zwapi_cmd_shape_data.h:70
svxCylData::Center
svxPoint Center
center of bottom face
Definition: zwapi_cmd_shape_data.h:68
svxCylData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:67
svxCylData::useAxis
int useAxis
flag to use axis, 0 default
Definition: zwapi_cmd_shape_data.h:66
svxCylData
cylinder
Definition: zwapi_cmd_shape_data.h:63
svxDivideData::trimCap
int trimCap
whether to cap shape at the trimmed edges (1 = cap, 0 = uncap)
Definition: zwapi_cmd_shape_data.h:1076
svxDivideData::extend
int extend
extend method (1 = no extend, 0 = linear, 2 = circular)
Definition: zwapi_cmd_shape_data.h:1077
svxDivideData::numCutter
int numCutter
number of dividing entities
Definition: zwapi_cmd_shape_data.h:1071
svxDivideData::idCutters
int * idCutters
list of dividing entities (shape, face, datum plane)
Definition: zwapi_cmd_shape_data.h:1072
svxDivideData::keepCutter
int keepCutter
whether to keep dividing entities (0 = delete, 1 = keep, 2 = divide)
Definition: zwapi_cmd_shape_data.h:1075
svxDivideData::idBase
int * idBase
id list of shape to divide
Definition: zwapi_cmd_shape_data.h:1070
svxDivideData::ftrName
vxName ftrName
feature name for "FtSolidSoloDiv", 0 default
Definition: zwapi_cmd_shape_data.h:1079
svxDivideData::numBase
int numBase
number of shapes to divide
Definition: zwapi_cmd_shape_data.h:1069
svxDivideData
divide data
Definition: zwapi_cmd_shape_data.h:1068
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntStaFaces2
int cntStaFaces2
Stationary faces cnt.
Definition: zwapi_cmd_shape_data.h:581
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::cntPrtFaces
int cntPrtFaces
Parting faces cnt.
Definition: zwapi_cmd_shape_data.h:583
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::StationaryFaces2
int * StationaryFaces2
List of stationary faces in STATION_PARTING_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:580
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace::PartingFaces
int * PartingFaces
List of parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:582
svxDraftData::svxDraftStationaryEnt::StationAndPrtingFace
Stationary faces and Parting faces in STATION_PARTING_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:579
svxDraftData::svxDraftStationaryEnt::StationaryFaces::cnt
int cnt
Stationary Faces count.
Definition: zwapi_cmd_shape_data.h:574
svxDraftData::svxDraftStationaryEnt::StationaryFaces::idEnt
int * idEnt
List of stationary Faces id.
Definition: zwapi_cmd_shape_data.h:575
svxDraftData::svxDraftStationaryEnt::StationaryFaces
Stationary faces in STATION_SYM_FACE_DRAFT(evxDraftType) and STATION_ASYM_FACE_DRAFT(evxDraftType)
Definition: zwapi_cmd_shape_data.h:573
svxDraftData::svxDraftStationaryEnt::StationaryPlane::idEnt
int * idEnt
List of stationary Plane id.
Definition: zwapi_cmd_shape_data.h:589
svxDraftData::svxDraftStationaryEnt::StationaryPlane::cnt
int cnt
Stationary Plane count.
Definition: zwapi_cmd_shape_data.h:588
svxDraftData::svxDraftStationaryEnt::StationaryPlane
Stationary plane in PRATING_EDGE_DRAFT(evxDraftMethods)
Definition: zwapi_cmd_shape_data.h:587
svxDraftData::Methods
evxDraftMethods Methods
Draft Methods.
Definition: zwapi_cmd_shape_data.h:563
svxDraftData::iIsRemivtrgns
int iIsRemivtrgns
Whether to remove inverted regions (0 = no, 1 = yes, 1 for default)
Definition: zwapi_cmd_shape_data.h:598
svxDraftData::idEnt
int * idEnt
List of picked Entity id.
Definition: zwapi_cmd_shape_data.h:566
svxDraftData::AngleA1
double AngleA1
Angle A1, if only one angle it is also Angle A.
Definition: zwapi_cmd_shape_data.h:567
svxDraftData::Type
evxDraftType Type
Draft Type in options can be picked.
Definition: zwapi_cmd_shape_data.h:564
svxDraftData::iCntDataList
int iCntDataList
Picked Entity count will be filled in list.
Definition: zwapi_cmd_shape_data.h:565
svxDraftData::AngleA2
double AngleA2
Angle A2.
Definition: zwapi_cmd_shape_data.h:568
svxDraftData::DraftSideS
int DraftSideS
Draft Side S (0 = split, 1 = top, 2 = bottom, 3 = neutral, 0 for default)
Definition: zwapi_cmd_shape_data.h:594
svxDraftData::DirP
svxVector DirP
Direction P.
Definition: zwapi_cmd_shape_data.h:593
svxDraftData::iIntersections
int iIntersections
Whether to remove intersections (0 = do not remove, 1 = remove all, 0 for default)
Definition: zwapi_cmd_shape_data.h:597
svxDraftData::iIsrecomputeflt
int iIsrecomputeflt
Whether to recompute fillets (0 = no, 1 = yes, 0 for default)
Definition: zwapi_cmd_shape_data.h:596
svxDraftData::Extention
int Extention
Extention type (0 = linear, 1 = circular, 2 = Reflect, 3 = curvature diminishing, 0 for default)
Definition: zwapi_cmd_shape_data.h:595
svxDraftData
template command Draft data
Definition: zwapi_cmd_shape_data.h:562
svxDymMove::MoveHand
int MoveHand
move handle only(default 0)
Definition: zwapi_cmd_shape_data.h:1501
svxDymMove::YAxis
svxVector YAxis
Y Axis.
Definition: zwapi_cmd_shape_data.h:1504
svxDymMove::XAxis
svxVector XAxis
X Axis.
Definition: zwapi_cmd_shape_data.h:1503
svxDymMove::ZAxis
svxVector ZAxis
Z Axis.
Definition: zwapi_cmd_shape_data.h:1505
svxDymMove::Pos
svxPoint Pos
Position.
Definition: zwapi_cmd_shape_data.h:1502
svxDymMove
dynamic copy/move entities
Definition: zwapi_cmd_shape_data.h:1500
svxEllsoData::zLen
double zLen
length of the ellipsoid along the z (mm)
Definition: zwapi_cmd_shape_data.h:116
svxEllsoData::yLen
double yLen
length of the ellipsoid along the y (mm)
Definition: zwapi_cmd_shape_data.h:115
svxEllsoData::ftrName
vxName ftrName
feature name for "FtAllEllso", 0 default
Definition: zwapi_cmd_shape_data.h:122
svxEllsoData::idPlane
int idPlane
optional datum plane (0 to use XY plane)
Definition: zwapi_cmd_shape_data.h:119
svxEllsoData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:112
svxEllsoData::useAxis
int useAxis
flag to use axis (0 to use plane, 1 to use axis)
Definition: zwapi_cmd_shape_data.h:118
svxEllsoData::Center
svxPoint Center
sphere center point
Definition: zwapi_cmd_shape_data.h:113
svxEllsoData::axis
svxAxis axis
optional axis
Definition: zwapi_cmd_shape_data.h:120
svxEllsoData::xLen
double xLen
length of the ellipsoid along the x (mm)
Definition: zwapi_cmd_shape_data.h:114
svxEllsoData
ellipsoid
Definition: zwapi_cmd_shape_data.h:111
svxExtrudeData::StartToPnt
svxPoint * StartToPnt
set the point if StartType > 1 , (NULL to ignore, it will use the start point of idStartEnt)
Definition: zwapi_cmd_shape_data.h:199
svxExtrudeData::EndType
evxDistanceMethod EndType
end type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)
Definition: zwapi_cmd_shape_data.h:194
svxExtrudeData::UseDirection
int UseDirection
1 to use optional extrusion direction, else 0
Definition: zwapi_cmd_shape_data.h:175
svxExtrudeData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:202
svxExtrudeData::idStartEnt
int idStartEnt
the entity id of start field if StartType > 1
Definition: zwapi_cmd_shape_data.h:195
svxExtrudeData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:203
svxExtrudeData::CapFace
int * CapFace
cap face id list (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:207
svxExtrudeData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:166
svxExtrudeData::ftrName
vxName ftrName
feature name for "FtAllExt", 0 default
Definition: zwapi_cmd_shape_data.h:189
svxExtrudeData::cntCap
int cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is o...
Definition: zwapi_cmd_shape_data.h:204
svxExtrudeData::EndToPnt
svxPoint * EndToPnt
set the point if EndType > 1 , (NULL to ignore, it will use the start point of idEndEnt)
Definition: zwapi_cmd_shape_data.h:200
svxExtrudeData::BooleanEnts
int * BooleanEnts
id list of shapes to combine with extrusion, use NULL if Combine is VX_BOOL_NONE or to combine extrus...
Definition: zwapi_cmd_shape_data.h:187
svxExtrudeData::idEndEnt
int idEndEnt
the entity id of end field if EndType > 1
Definition: zwapi_cmd_shape_data.h:196
svxExtrudeData::Direction
svxVector Direction
optional extrusion direction
Definition: zwapi_cmd_shape_data.h:176
svxExtrudeData::EndOffset
double EndOffset
end offset value if EndType >= 3
Definition: zwapi_cmd_shape_data.h:198
svxExtrudeData::Draft
double Draft
draft angle (deg)
Definition: zwapi_cmd_shape_data.h:171
svxExtrudeData::Start
double Start
start distance (mm)
Definition: zwapi_cmd_shape_data.h:168
svxExtrudeData::FlipRemoveArea
int FlipRemoveArea
1-flip bool remove area, else 0 (0:default value, valid when Combine == VX_BOOL_REMOVE)
Definition: zwapi_cmd_shape_data.h:192
svxExtrudeData::idProfile
int idProfile
profile (sketch or curvelist)
Definition: zwapi_cmd_shape_data.h:167
svxExtrudeData::End
double End
end distance (mm)
Definition: zwapi_cmd_shape_data.h:169
svxExtrudeData::numBooleanEnts
int numBooleanEnts
count of shapes in BooleanEnts array, use 0 if BooleanEnts is NULL
Definition: zwapi_cmd_shape_data.h:186
svxExtrudeData::FlipFaceDir
int FlipFaceDir
1-flip face direction, else 0 (0:default value, valid when the idProfile is open or CapType == VX_END...
Definition: zwapi_cmd_shape_data.h:191
svxExtrudeData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:181
svxExtrudeData::Twist
double Twist
twist angle (deg)
Definition: zwapi_cmd_shape_data.h:178
svxExtrudeData::iKeep
int iKeep
keep profile (1-keep, 0-not keep, not use since 2400)
Definition: zwapi_cmd_shape_data.h:184
svxExtrudeData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:182
svxExtrudeData::StartOffset
double StartOffset
start offset value if StartType >= 3
Definition: zwapi_cmd_shape_data.h:197
svxExtrudeData::Pivot
svxPoint Pivot
pivot point if twist is non-zero
Definition: zwapi_cmd_shape_data.h:179
svxExtrudeData::StartType
evxDistanceMethod StartType
start type (0 = input value, 1 = through all, 2= to point, 3 = to faces, 4=to Extend Face)
Definition: zwapi_cmd_shape_data.h:193
svxExtrudeData::Blend
int Blend
corner blend option
Definition: zwapi_cmd_shape_data.h:172
svxExtrudeData
extruded shape
Definition: zwapi_cmd_shape_data.h:165
svxFaceFlltData
Definition: zwapi_cmd_shape_data.h:519
svxFaceOffData::numOffsetSet
int numOffsetSet
number of face offset set
Definition: zwapi_cmd_shape_data.h:995
svxFaceOffData::sideFaces
int sideFaces
whether to create side faces (0 = do not create, 1 = create, 2 = force)
Definition: zwapi_cmd_shape_data.h:999
svxFaceOffData::ftrName
vxName ftrName
feature name for "FtOffsetFace1", 0 default
Definition: zwapi_cmd_shape_data.h:1003
svxFaceOffData::idFaceSet
int * idFaceSet
list of id's of faces in offset set
Definition: zwapi_cmd_shape_data.h:996
svxFaceOffData::numFaces
int numFaces
number of faces for offset
Definition: zwapi_cmd_shape_data.h:990
svxFaceOffData::type
int type
face offset type (0 = constant, 1 = variable)
Definition: zwapi_cmd_shape_data.h:987
svxFaceOffData::extension
int extension
extension type of offset face (0 = linear, 1 = circular, 2 = reflect, 3 = curvature diminishing)
Definition: zwapi_cmd_shape_data.h:1000
svxFaceOffData::offset
double offset
offset value
Definition: zwapi_cmd_shape_data.h:992
svxFaceOffData::intersect
int intersect
whether to remove self intersecting faces (0 = do not remove, 1 = remove all)
Definition: zwapi_cmd_shape_data.h:1001
svxFaceOffData::idFaces
int * idFaces
list of id's of faces for offset
Definition: zwapi_cmd_shape_data.h:991
svxFaceOffData::offsetSet
double * offsetSet
list of offset value in offset set
Definition: zwapi_cmd_shape_data.h:997
svxFaceOffData
shape face offset data
Definition: zwapi_cmd_shape_data.h:986
svxFlagExtThreadData::svxCustomInfo::value
double value
isThread is 0, value is pitch value,else Thread/Unit value
Definition: zwapi_cmd_shape_data.h:889
svxFlagExtThreadData::svxCustomInfo::isThread
int isThread
1 if thread/unit ,else pitch
Definition: zwapi_cmd_shape_data.h:888
svxFlagExtThreadData::svxCustomInfo::diamter
double diamter
diameter
Definition: zwapi_cmd_shape_data.h:887
svxFlagExtThreadData::svxCustomInfo::useDiam
int useDiam
1-use diameter, 0 use the diameter of the first input face (default: 0)
Definition: zwapi_cmd_shape_data.h:890
svxFlagExtThreadData::svxCustomInfo
if type[0]==0, apply it.
Definition: zwapi_cmd_shape_data.h:886
svxFlagExtThreadData::type
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:879
svxFlagExtThreadData::LengthType
evxFlagThreadDepthType LengthType
length type
Definition: zwapi_cmd_shape_data.h:892
svxFlagExtThreadData::count
int count
count of "Faces"
Definition: zwapi_cmd_shape_data.h:876
svxFlagExtThreadData::SetBack
double SetBack
SetBack.
Definition: zwapi_cmd_shape_data.h:898
svxFlagExtThreadData::isChamfer
int isChamfer
1 if end chamfer ,else 0
Definition: zwapi_cmd_shape_data.h:896
svxFlagExtThreadData::IdFaces
int * IdFaces
id(IdFaces[0]) of face(Faces[0])
Definition: zwapi_cmd_shape_data.h:878
svxFlagExtThreadData::angle
double angle
angle
Definition: zwapi_cmd_shape_data.h:899
svxFlagExtThreadData::Faces
svxPoint * Faces
faces
Definition: zwapi_cmd_shape_data.h:877
svxFlagExtThreadData::size
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:882
svxFlagExtThreadData::length
double length
length
Definition: zwapi_cmd_shape_data.h:895
svxFlagExtThreadData
flag ext thread data
Definition: zwapi_cmd_shape_data.h:875
svxFlagHoleData::svxCustomData::isPitch
int isPitch
1 if pitch ,else thread/unit
Definition: zwapi_cmd_shape_data.h:830
svxFlagHoleData::svxCustomData::value
double value
isPitch is 1,value is pitch value,else Thread/Unit value
Definition: zwapi_cmd_shape_data.h:831
svxFlagHoleData::svxCustomData::diamter
double diamter
diameter
Definition: zwapi_cmd_shape_data.h:829
svxFlagHoleData::svxCustomData
if type[0]==0, apply it.
Definition: zwapi_cmd_shape_data.h:828
svxFlagHoleData::svxFilterCondition::HoleShape
evxHoleType HoleShape
hole shape
Definition: zwapi_cmd_shape_data.h:810
svxFlagHoleData::svxFilterCondition::DepthStart
double DepthStart
depth start
Definition: zwapi_cmd_shape_data.h:816
svxFlagHoleData::svxFilterCondition::DiameterEnd
double DiameterEnd
diameter end
Definition: zwapi_cmd_shape_data.h:814
svxFlagHoleData::svxFilterCondition::DepthEnd
double DepthEnd
depth end
Definition: zwapi_cmd_shape_data.h:817
svxFlagHoleData::svxFilterCondition::isDepth
int isDepth
1 if edit depth ,else 0
Definition: zwapi_cmd_shape_data.h:815
svxFlagHoleData::svxFilterCondition::isDiameter
int isDiameter
1 if edit diameter,else 0
Definition: zwapi_cmd_shape_data.h:812
svxFlagHoleData::svxFilterCondition::isOnlyCylindrical
int isOnlyCylindrical
1 if only whole cylindrical,else 0
Definition: zwapi_cmd_shape_data.h:811
svxFlagHoleData::svxFilterCondition::DiameterStart
double DiameterStart
diameter start
Definition: zwapi_cmd_shape_data.h:813
svxFlagHoleData::svxFilterCondition
filter condition data
Definition: zwapi_cmd_shape_data.h:809
svxFlagHoleData::UpperLimit
double UpperLimit
upper limit
Definition: zwapi_cmd_shape_data.h:841
svxFlagHoleData::CalloutLabel
vxLongName CalloutLabel
callout label
Definition: zwapi_cmd_shape_data.h:839
svxFlagHoleData::isCounter
int isCounter
1 if counter sink hole as simple hole with chamfer
Definition: zwapi_cmd_shape_data.h:846
svxFlagHoleData::DepthType
evxFlagThreadDepthType DepthType
depth type if DepthType = VX_FLAG_THREAD_DEPTH_FULL, the thread depth is the hole depth.
Definition: zwapi_cmd_shape_data.h:833
svxFlagHoleData::DepthPnt
svxPntOnEnt * DepthPnt
set the depth by "To point"
Definition: zwapi_cmd_shape_data.h:837
svxFlagHoleData::isUseFlaggedThread
int isUseFlaggedThread
1 if use flagged as thread hole,else 0
Definition: zwapi_cmd_shape_data.h:820
svxFlagHoleData::HolesId
int * HolesId
list of hole id
Definition: zwapi_cmd_shape_data.h:805
svxFlagHoleData::isAddD1
int isAddD1
1 if add D1 tolerance ,else 0
Definition: zwapi_cmd_shape_data.h:840
svxFlagHoleData::isMachine
int isMachine
1 if do not machine,else 0
Definition: zwapi_cmd_shape_data.h:844
svxFlagHoleData::LowerLimit
double LowerLimit
lower limit
Definition: zwapi_cmd_shape_data.h:842
svxFlagHoleData::depth
double depth
depth : if DepthType = VX_FLAG_THREAD_DEPTH_CUSTOM, users can specify the thread depth into the hole ...
Definition: zwapi_cmd_shape_data.h:835
svxFlagHoleData::isUseFilter
int isUseFilter
1 if use hole filter,else 0
Definition: zwapi_cmd_shape_data.h:807
svxFlagHoleData::FaceId
int FaceId
face id
Definition: zwapi_cmd_shape_data.h:803
svxFlagHoleData::ThreadClass
evxThreadHoleClass ThreadClass
thread class
Definition: zwapi_cmd_shape_data.h:843
svxFlagHoleData::type
vxLongName type
flag thread hole type The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:821
svxFlagHoleData::count
int count
count of "HolesId"
Definition: zwapi_cmd_shape_data.h:804
svxFlagHoleData::size
vxLongName size
flag thread hole size The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:824
svxFlagHoleData
flag hole data
Definition: zwapi_cmd_shape_data.h:802
svxHoleChams::fChamSym
int fChamSym
Flag if it is symmetric chamfer.
Definition: zwapi_cmd_shape_data.h:676
svxHoleChams::chamAngle
double chamAngle
Chamfer angle.
Definition: zwapi_cmd_shape_data.h:678
svxHoleChams::fCham
int fCham
Flag if chamfer.
Definition: zwapi_cmd_shape_data.h:675
svxHoleChams::chamDst
double chamDst
Chamfer distance.
Definition: zwapi_cmd_shape_data.h:677
svxHoleChams
Hole chamfer, added in 1900.
Definition: zwapi_cmd_shape_data.h:674
svxHoleData::ClearHoleType
evxClearHoleType ClearHoleType
hole type (when HoleOpt = VX_CLEARANCE_HOLE)
Definition: zwapi_cmd_shape_data.h:757
svxHoleData::fThrdClass
int fThrdClass
T/F flag for thread class, added in 1900 version.
Definition: zwapi_cmd_shape_data.h:734
svxHoleData::AddBase
int AddBase
1 is add base, else 0. default:1.
Definition: zwapi_cmd_shape_data.h:765
svxHoleData::NoProjPntLoc
int NoProjPntLoc
1 not to project location point, 0 to project
Definition: zwapi_cmd_shape_data.h:720
svxHoleData::ThreadPitch
double ThreadPitch
thread pitch (mm) (0 if not used)
Definition: zwapi_cmd_shape_data.h:733
svxHoleData::idShapes
int * idShapes
list of shape id. if OpNoRemove = 0 and cntShps > 0,apply it.
Definition: zwapi_cmd_shape_data.h:719
svxHoleData::idSketch
int idSketch
use sketch to create the hole (HoleOpt = VX_PROFILE_HOLE, 0 to ignore)
Definition: zwapi_cmd_shape_data.h:762
svxHoleData::ThreadDiameter
double ThreadDiameter
thread diameter (mm)
Definition: zwapi_cmd_shape_data.h:730
svxHoleData::UseTol
int UseTol
1 to use tolerances; or 0
Definition: zwapi_cmd_shape_data.h:743
svxHoleData::fExtTap
int fExtTap
Flag if extend with taper direction for tapered or counter-sink hole.
Definition: zwapi_cmd_shape_data.h:740
svxHoleData::TaperAngle
double TaperAngle
taper angle (degrees)
Definition: zwapi_cmd_shape_data.h:708
svxHoleData::slotAngle
double slotAngle
slot angle (deg)
Definition: zwapi_cmd_shape_data.h:722
svxHoleData::D2InTol
double D2InTol
D2 tolerance lower limit, added in 1900 version.
Definition: zwapi_cmd_shape_data.h:748
svxHoleData::OpNoRemove
int OpNoRemove
bool operation type (0 means remove for default, 1 is none)
Definition: zwapi_cmd_shape_data.h:715
svxHoleData::idInsFace
int idInsFace
id of insertion face. 0 to ignore
Definition: zwapi_cmd_shape_data.h:700
svxHoleData::Standard
vxLongName Standard
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:758
svxHoleData::idUntilFace
int idUntilFace
id of "until" face (0 if not required)
Definition: zwapi_cmd_shape_data.h:711
svxHoleData::End
evxEndCondition End
hole end condition
Definition: zwapi_cmd_shape_data.h:710
svxHoleData::HoleOpt
evxHoleOpt HoleOpt
different hole to create
Definition: zwapi_cmd_shape_data.h:756
svxHoleData::fExtStart
int fExtStart
Flag if extend the start of hole.
Definition: zwapi_cmd_shape_data.h:741
svxHoleData::Fit
vxLongName Fit
"Close","Normal","Loose","Custom"
Definition: zwapi_cmd_shape_data.h:761
svxHoleData::cntShps
int cntShps
count of shapes. if OpNoRemove = 0,apply it. if OpNoRemove=0 and cngShps=0, remove default.
Definition: zwapi_cmd_shape_data.h:716
svxHoleData::UseDirection
int UseDirection
1 to use "Direction" input ; 0 for default (the hole feature(s) will be perpendicular to the face)
Definition: zwapi_cmd_shape_data.h:712
svxHoleData::Depth2
double Depth2
2nd depth (mm, countersunk holes)
Definition: zwapi_cmd_shape_data.h:707
svxHoleData::Screw
vxLongName Screw
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:759
svxHoleData::ThreadLength
double ThreadLength
thread length (mm)
Definition: zwapi_cmd_shape_data.h:731
svxHoleData::DoNotMachine
int DoNotMachine
1 to ignore hole in CAM, or 0
Definition: zwapi_cmd_shape_data.h:753
svxHoleData::sCham
svxHoleChams sCham
Start chamfer.
Definition: zwapi_cmd_shape_data.h:737
svxHoleData::Callout
char Callout[128]
callout text string
Definition: zwapi_cmd_shape_data.h:752
svxHoleData::slotLength
double slotLength
slot length (mm)
Definition: zwapi_cmd_shape_data.h:721
svxHoleData::Depth1
double Depth1
1st depth (mm)
Definition: zwapi_cmd_shape_data.h:705
svxHoleData::Count
int Count
number of holes
Definition: zwapi_cmd_shape_data.h:701
svxHoleData::mCham
svxHoleChams mCham
Middle chamfer for counter bore or spot face bore.
Definition: zwapi_cmd_shape_data.h:738
svxHoleData::UseD2Tol
int UseD2Tol
T/F flag for ID2 Tol input choice, add in 1900 version.
Definition: zwapi_cmd_shape_data.h:747
svxHoleData::eCham
svxHoleChams eCham
End chamfer.
Definition: zwapi_cmd_shape_data.h:739
svxHoleData::ThreadSize
vxLongName ThreadSize
thread size. The size of the data is very large ,so user can find it in file Thread....
Definition: zwapi_cmd_shape_data.h:726
svxHoleData::Size
vxLongName Size
user can find it in file Simple.xml(zw3d/supp/Simple.xml)
Definition: zwapi_cmd_shape_data.h:760
svxHoleData::Direction
svxVector Direction
optional direction for hole centerline
Definition: zwapi_cmd_shape_data.h:714
svxHoleData::Diameter2
double Diameter2
2nd diameter (mm, countersunk holes)
Definition: zwapi_cmd_shape_data.h:706
svxHoleData::TolIn
double TolIn
inner tolerance on Diameter 1
Definition: zwapi_cmd_shape_data.h:744
svxHoleData::TipAngle
double TipAngle
tip angle (degrees) (0 is mapped to 180, 118 is default)
Definition: zwapi_cmd_shape_data.h:709
svxHoleData::ThreadsPerUnit
double ThreadsPerUnit
threads per unit (0 if not used)
Definition: zwapi_cmd_shape_data.h:732
svxHoleData::TolOut
double TolOut
outer tolerance on Diameter 1
Definition: zwapi_cmd_shape_data.h:745
svxHoleData::thrdClass
int thrdClass
thread class 1B/2B/3B, added in 1900 version
Definition: zwapi_cmd_shape_data.h:735
svxHoleData::D2OutTol
double D2OutTol
D2 tolerance upper limit, added in 1900 version.
Definition: zwapi_cmd_shape_data.h:749
svxHoleData::Type
evxHoleType Type
hole type (general hole or thread hole)
Definition: zwapi_cmd_shape_data.h:699
svxHoleData::Diameter1
double Diameter1
1st diameter (mm)
Definition: zwapi_cmd_shape_data.h:704
svxHoleData::ThreadType
evxThreadType ThreadType
thread type
Definition: zwapi_cmd_shape_data.h:725
svxHoleData::Points
svxPoint * Points
list of "Count" hole insertion points (calling procedure must allocate/deallocate)
Definition: zwapi_cmd_shape_data.h:702
svxHoleData
hole data
Definition: zwapi_cmd_shape_data.h:697
svxInlayData::numCrvs
int numCrvs
number of curves that defines a inlay boundary
Definition: zwapi_cmd_shape_data.h:1136
svxInlayData::draftAbout
int draftAbout
specify which plane to draft about ( 0 = base, 1 = offset, 2 = middle)
Definition: zwapi_cmd_shape_data.h:1143
svxInlayData::filletAbout
int filletAbout
specify which edges to fillet ( 0 = both, 1 = base, 2 = offset)
Definition: zwapi_cmd_shape_data.h:1146
svxInlayData::inlayDir
svxVector inlayDir
inlay direction of curves
Definition: zwapi_cmd_shape_data.h:1142
svxInlayData::ftrName
vxName ftrName
feature name for "FtInlay", 0 default
Definition: zwapi_cmd_shape_data.h:1149
svxInlayData::idCrvs
int * idCrvs
list of curves that defines a inlay boundary (sketch, curve, curve list, sketch block)
Definition: zwapi_cmd_shape_data.h:1137
svxInlayData::projType
int projType
projection method (0 = in place(none), 1 = face normal, 2 = directed, 3 = bi-directional)
Definition: zwapi_cmd_shape_data.h:1140
svxInlayData::numFaces
int numFaces
number of faces to receive the inlay
Definition: zwapi_cmd_shape_data.h:1134
svxInlayData::offset
double offset
offset distance, positive raises the faces while negative sinks the faces
Definition: zwapi_cmd_shape_data.h:1138
svxInlayData::idFaces
int * idFaces
list of id's of faces to receive the inlay
Definition: zwapi_cmd_shape_data.h:1135
svxInlayData::projDir
svxVector projDir
projection direction, only used when projType = 2
Definition: zwapi_cmd_shape_data.h:1141
svxInlayData::draftAngle
double draftAngle
draft angle for the side faces
Definition: zwapi_cmd_shape_data.h:1144
svxInlayData::filletRad
double filletRad
fillet radius
Definition: zwapi_cmd_shape_data.h:1147
svxInlayData::filletType
int filletType
fillet type ( 0 = circular, 1 = chamfer)
Definition: zwapi_cmd_shape_data.h:1145
svxInlayData
inlay data
Definition: zwapi_cmd_shape_data.h:1133
svxLipData::idEdge
int * idEdge
list of edges to apply lip
Definition: zwapi_cmd_shape_data.h:926
svxLipData::idFace
int * idFace
list of faces on first side, the face must be associated with lip edge
Definition: zwapi_cmd_shape_data.h:927
svxLipData::numEdges
int numEdges
number of edges to apply lip
Definition: zwapi_cmd_shape_data.h:925
svxLipData::ftrName
vxName ftrName
feature name for "FtLip", 0 default
Definition: zwapi_cmd_shape_data.h:932
svxLipData::offset2
double offset2
the second offset distance
Definition: zwapi_cmd_shape_data.h:931
svxLipData::offset1
double offset1
the first offset distance. Lip setback distances are +/- relative to the face normal....
Definition: zwapi_cmd_shape_data.h:929
svxLipData
lip data
Definition: zwapi_cmd_shape_data.h:923
svxLoftBndCons
loft boundary constraints
Definition: zwapi_cmd_subcmd_data.h:71
svxLoftData::numProfs
int numProfs
number of profiles for loft
Definition: zwapi_cmd_shape_data.h:393
svxLoftData::bndCons
svxLoftBndCons bndCons[2]
boundary constraints data of start and end profiles
Definition: zwapi_cmd_shape_data.h:398
svxLoftData::endPnt
svxPoint endPnt
ending point coordinate
Definition: zwapi_cmd_shape_data.h:396
svxLoftData::endCap
int endCap
end cap option (0-both, 1-start, 2-end, 3-none)
Definition: zwapi_cmd_shape_data.h:399
svxLoftData::idEndParent
int idEndParent
id of the parent entity where the ending point is located
Definition: zwapi_cmd_shape_data.h:395
svxLoftData::startPnt
svxPoint startPnt
starting point coordinate
Definition: zwapi_cmd_shape_data.h:392
svxLoftData::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:389
svxLoftData::profs
svxLoftProfile * profs
list of profiles data
Definition: zwapi_cmd_shape_data.h:394
svxLoftData::close
int close
whether to generate a closed loft (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:400
svxLoftData::type
evxLoftType type
loft method
Definition: zwapi_cmd_shape_data.h:390
svxLoftData::idStartParent
int idStartParent
id of the parent entity where the starting point is located
Definition: zwapi_cmd_shape_data.h:391
svxLoftData::ftrName
vxName ftrName
feature name for "FtAllLft1", 0 default
Definition: zwapi_cmd_shape_data.h:402
svxLoftData
loft data
Definition: zwapi_cmd_shape_data.h:388
svxLoftProfile::idParent
int idParent
id of profile curve's parent sketch or curve list
Definition: zwapi_cmd_shape_data.h:364
svxLoftProfile::startPnt
svxPoint startPnt
starting point coordinate, only setting when useStartPnt = 1
Definition: zwapi_cmd_shape_data.h:368
svxLoftProfile::useStartPnt
int useStartPnt
1 = use the specified starting point, 0 = use the default starting point
Definition: zwapi_cmd_shape_data.h:367
svxLoftProfile::profDir
int profDir
specify the orientation of the profile (0 = from start point to end point, otherwise 1)
Definition: zwapi_cmd_shape_data.h:366
svxLoftProfile::idProfile
int idProfile
id of profile curve for loft (curve, edge, parting line)
Definition: zwapi_cmd_shape_data.h:365
svxLoftProfile
loft profile data
Definition: zwapi_cmd_shape_data.h:363
svxMirrorFtr::idPlane
int idPlane
id of mirror plane (datum plane, planar face or sketch)
Definition: zwapi_cmd_shape_data.h:1471
svxMirrorFtr::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:1473
svxMirrorFtr::idShapes
int * idShapes
list of id's of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1475
svxMirrorFtr::numShapes
int numShapes
number of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1474
svxMirrorFtr::numFtrs
int numFtrs
number of features to mirror
Definition: zwapi_cmd_shape_data.h:1469
svxMirrorFtr::idFtrs
int * idFtrs
list of features ids
Definition: zwapi_cmd_shape_data.h:1470
svxMirrorFtr::keep
int keep
whether to keep the original features (0 = no keep, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1477
svxMirrorFtr::ftrName
vxName ftrName
feature name for "FtMirrorFtr", 0 default
Definition: zwapi_cmd_shape_data.h:1478
svxMirrorFtr
mirror feature data
Definition: zwapi_cmd_shape_data.h:1468
svxMirrorGeom::idPlane
int idPlane
id of mirror plane (datum plane, planar face or sketch)
Definition: zwapi_cmd_shape_data.h:1451
svxMirrorGeom::assoCopy
int assoCopy
whether to keep associated with the original entities (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1458
svxMirrorGeom::numShapes
int numShapes
number of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1454
svxMirrorGeom::numEnts
int numEnts
number of entities to mirror
Definition: zwapi_cmd_shape_data.h:1449
svxMirrorGeom::ftrName
vxName ftrName
feature name for "FtMirrorGeom", 0 default
Definition: zwapi_cmd_shape_data.h:1460
svxMirrorGeom::keep
int keep
whether to keep the original entities (0 = no keep, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1457
svxMirrorGeom::idShapes
int * idShapes
list of id's of shapes to boolean
Definition: zwapi_cmd_shape_data.h:1455
svxMirrorGeom::idEnts
int * idEnts
list of geometry entity ids
Definition: zwapi_cmd_shape_data.h:1450
svxMirrorGeom::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:1453
svxMirrorGeom
mirror geometry data
Definition: zwapi_cmd_shape_data.h:1448
svxMorphToCrvData::idGeometry
int * idGeometry
select geometry to morph
Definition: zwapi_cmd_shape_data.h:1249
svxMorphToCrvData::flatOrPeak
int flatOrPeak[2]
this determines whether the surfaces at the new point location are rounded (flat) or sharp (peak) (0 ...
Definition: zwapi_cmd_shape_data.h:1262
svxMorphToCrvData::numGeometry
int numGeometry
numbers of morphed shapes
Definition: zwapi_cmd_shape_data.h:1248
svxMorphToCrvData::infulence
double infulence[2]
specify radius of influence (min = 0. default = 20)
Definition: zwapi_cmd_shape_data.h:1258
svxMorphToCrvData::idToCurve
int idToCurve
to curve is where the morph will end
Definition: zwapi_cmd_shape_data.h:1251
svxMorphToCrvData::rigid
int rigid[2]
specify radius for rigid motion (min = 0, max = 100, inc = 1. default = 0)
Definition: zwapi_cmd_shape_data.h:1259
svxMorphToCrvData::bulge
int bulge[2]
specify bulge factor for transition region (min = 0, max = 100, inc = 1. default = 50)
Definition: zwapi_cmd_shape_data.h:1260
svxMorphToCrvData::idFromCurve
int idFromCurve
from curve is where the morph will start
Definition: zwapi_cmd_shape_data.h:1250
svxMorphToCrvData::slope
int slope[2]
specify slope for transition region (min = 0, max = 100, inc = 1. default = 50)
Definition: zwapi_cmd_shape_data.h:1261
svxMorphToCrvData::numStationary
int numStationary
numbers of stationary shapes
Definition: zwapi_cmd_shape_data.h:1263
svxMorphToCrvData::miniSurfData
int miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)
Definition: zwapi_cmd_shape_data.h:1253
svxMorphToCrvData::bendOrTranslate
int bendOrTranslate
allow the morph transformation to be a straight translation or a bend (0 = bend, 1 = translate....
Definition: zwapi_cmd_shape_data.h:1254
svxMorphToCrvData::idStationary
int * idStationary
stationary shapes
Definition: zwapi_cmd_shape_data.h:1264
svxMorphToCrvData
shape morph to curve data
Definition: zwapi_cmd_shape_data.h:1246
svxMoveData::method
evxMoveType method
move methods
Definition: zwapi_cmd_shape_data.h:1579
svxMoveData::pEnts
int * pEnts
entities ID
Definition: zwapi_cmd_shape_data.h:1581
svxMoveData::cntEnt
int cntEnt
entity count
Definition: zwapi_cmd_shape_data.h:1580
svxMoveData
template command Move data
Definition: zwapi_cmd_shape_data.h:1578
svxMovePntToPnt::ToVector
svxPntOnEnt ToVector
to vector
Definition: zwapi_cmd_shape_data.h:1518
svxMovePntToPnt::FromVector
svxPntOnEnt FromVector
from vector
Definition: zwapi_cmd_shape_data.h:1517
svxMovePntToPnt::ToPnt
svxPntOnEnt ToPnt
to point
Definition: zwapi_cmd_shape_data.h:1515
svxMovePntToPnt::FromPnt
svxPntOnEnt FromPnt
from point
Definition: zwapi_cmd_shape_data.h:1514
svxMovePntToPnt
copy/move entities form point to point
Definition: zwapi_cmd_shape_data.h:1513
svxPartSelfX::numEnt
int numEnt
number of shape entities to resolve self intersection
Definition: zwapi_cmd_shape_data.h:1158
svxPartSelfX::region
int region
whether to remove inverted regions (0 = no, 1 = yes).Default:1.
Definition: zwapi_cmd_shape_data.h:1160
svxPartSelfX::idEnts
int * idEnts
list of shape entities to resolve self intersection
Definition: zwapi_cmd_shape_data.h:1159
svxPartSelfX
part resolveSelfX data
Definition: zwapi_cmd_shape_data.h:1157
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxPtnData::PtnData::svxCircular::spacing
double spacing
pattern spacing in second direction, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1313
svxPtnData::PtnData::svxCircular::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1311
svxPtnData::PtnData::svxCircular::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1310
svxPtnData::PtnData::svxCircular::angle
double angle
spacing between the instances measured in degrees
Definition: zwapi_cmd_shape_data.h:1312
svxPtnData::PtnData::svxCircular::diameter
double diameter
rotation diameter for the pattern
Definition: zwapi_cmd_shape_data.h:1309
svxPtnData::PtnData::svxCircular::axis
svxAxis axis
rotation axis for the pattern
Definition: zwapi_cmd_shape_data.h:1308
svxPtnData::PtnData::svxCircular
circular pattern
Definition: zwapi_cmd_shape_data.h:1307
svxPtnData::PtnData::svxLinear::dir
svxVector dir[2]
first and second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1302
svxPtnData::PtnData::svxLinear::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1303
svxPtnData::PtnData::svxLinear::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1301
svxPtnData::PtnData::svxLinear::spacing
double spacing[2]
pattern spacing in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1304
svxPtnData::PtnData::svxLinear
linear pattern
Definition: zwapi_cmd_shape_data.h:1300
svxPtnData::PtnData::svxPattern::idPtnFtr
int idPtnFtr
id of pattern feature
Definition: zwapi_cmd_shape_data.h:1336
svxPtnData::PtnData::svxPattern
pattern based on pattern
Definition: zwapi_cmd_shape_data.h:1335
svxPtnData::PtnData::svxPntFill::spacing
double spacing
pattern spacing
Definition: zwapi_cmd_shape_data.h:1359
svxPtnData::PtnData::svxPntFill::angle
double angle
rotation angle, the value is ignored when type = 5
Definition: zwapi_cmd_shape_data.h:1360
svxPtnData::PtnData::svxPntFill::radius
double radius
rotation radius, used only when type is 3 or 4
Definition: zwapi_cmd_shape_data.h:1362
svxPtnData::PtnData::svxPntFill::border
double border
border, the value is ignored when type = 5
Definition: zwapi_cmd_shape_data.h:1361
svxPtnData::PtnData::svxPntFill::idSketch
int idSketch
id of sketch
Definition: zwapi_cmd_shape_data.h:1358
svxPtnData::PtnData::svxPntFill::type
int type
type (0 = square, 1 = diamond, 2 = hexagon, 3 = concentric, 4 = spiral, 5 = along sketch curves)
Definition: zwapi_cmd_shape_data.h:1357
svxPtnData::PtnData::svxPntFill
fill pattern
Definition: zwapi_cmd_shape_data.h:1356
svxPtnData::PtnData::svxPntToPnt::pnt
svxPoint * pnt
list of point coordinates
Definition: zwapi_cmd_shape_data.h:1332
svxPtnData::PtnData::svxPntToPnt::idParPnt
int * idParPnt
list of id's of the parent of point, set id to 0 when no parent object exists
Definition: zwapi_cmd_shape_data.h:1331
svxPtnData::PtnData::svxPntToPnt::numPnts
int numPnts
number of point, parent and point value should be set in pairs
Definition: zwapi_cmd_shape_data.h:1330
svxPtnData::PtnData::svxPntToPnt
point to point pattern
Definition: zwapi_cmd_shape_data.h:1329
svxPtnData::PtnData::svxPntVar::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1367
svxPtnData::PtnData::svxPntVar::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1366
svxPtnData::PtnData::svxPntVar
feature pattern by variant parameters when inpData.type = VX_PATTERN_BY_VAR
Definition: zwapi_cmd_shape_data.h:1365
svxPtnData::PtnData::svxPolygon::spacing
double spacing
spacing of between rings radiating outward, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1326
svxPtnData::PtnData::svxPolygon::spacingType
int spacingType
pattern ways (0 = number per side, 1 = pitch between instances)
Definition: zwapi_cmd_shape_data.h:1320
svxPtnData::PtnData::svxPolygon::pitch
double pitch
pitch between instances, used only when spacingType = 1
Definition: zwapi_cmd_shape_data.h:1322
svxPtnData::PtnData::svxPolygon::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1324
svxPtnData::PtnData::svxPolygon::number
int number
number of per side, used only when spacingType = 0
Definition: zwapi_cmd_shape_data.h:1321
svxPtnData::PtnData::svxPolygon::axis
svxAxis axis
central axis for the pattern
Definition: zwapi_cmd_shape_data.h:1317
svxPtnData::PtnData::svxPolygon::numSides
int numSides
number of sides, it has to be greater than 2
Definition: zwapi_cmd_shape_data.h:1318
svxPtnData::PtnData::svxPolygon::numConcentric
int numConcentric
number of concentric polygons, the value is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1325
svxPtnData::PtnData::svxPolygon
polygon pattern
Definition: zwapi_cmd_shape_data.h:1316
svxPtnData::PtnData::svxPtnCrv::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1345
svxPtnData::PtnData::svxPtnCrv::curveType
int curveType
curve method (0 = 1 curve, 1 = 2 curves together, 2 = 2 curves across, 3 = 3~4 curves)
Definition: zwapi_cmd_shape_data.h:1340
svxPtnData::PtnData::svxPtnCrv::spacing
double spacing[2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1346
svxPtnData::PtnData::svxPtnCrv::idCrvs
int * idCrvs
list of id's of curves
Definition: zwapi_cmd_shape_data.h:1342
svxPtnData::PtnData::svxPtnCrv::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1344
svxPtnData::PtnData::svxPtnCrv::numCrvs
int numCrvs
number of curves, can't go beyond 4 curves
Definition: zwapi_cmd_shape_data.h:1341
svxPtnData::PtnData::svxPtnCrv
curve pattern
Definition: zwapi_cmd_shape_data.h:1339
svxPtnData::PtnData::svxPtnFace::spacing
double spacing[2]
pattern spacing in second direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1353
svxPtnData::PtnData::svxPtnFace::useSecondDir
int useSecondDir
whether to use second direction (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1351
svxPtnData::PtnData::svxPtnFace::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0
Definition: zwapi_cmd_shape_data.h:1352
svxPtnData::PtnData::svxPtnFace::idFace
int idFace
id of face
Definition: zwapi_cmd_shape_data.h:1350
svxPtnData::PtnData::svxPtnFace
face pattern
Definition: zwapi_cmd_shape_data.h:1349
svxPtnData::idParent
int idParent
id of the parent entity of point, set id to 0 when no parent object exists
Definition: zwapi_cmd_shape_data.h:1372
svxPtnData::cntSkip
int cntSkip
number of the instances to be skipped
Definition: zwapi_cmd_shape_data.h:1382
svxPtnData::combine
evxBoolType combine
combination method
Definition: zwapi_cmd_shape_data.h:1294
svxPtnData::firstTogglePos
int * firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in t...
Definition: zwapi_cmd_shape_data.h:1387
svxPtnData::basePnt
svxPoint basePnt
base point, the value is ignored if useBasePnt = 0
Definition: zwapi_cmd_shape_data.h:1373
svxPtnData::type
evxPatternType type
pattern method
Definition: zwapi_cmd_shape_data.h:1295
svxPtnData::ftrName
vxName ftrName
feature name, 0 default
Definition: zwapi_cmd_shape_data.h:1380
svxPtnData::minPer
double minPer
percentage of the minimum spacing, instances less than this will be deleted
Definition: zwapi_cmd_shape_data.h:1379
svxPtnData::skipList
int * skipList
the instances position id (exp.(0,1)-(id:1),(0,2)-(id:2),(1,0)-(id:10000),(2,5)-(id:20005) note: th...
Definition: zwapi_cmd_shape_data.h:1383
svxPtnData::useBasePnt
int useBasePnt
whether to use base point (0 = no, 1 = yes)
Definition: zwapi_cmd_shape_data.h:1371
svxPtnData::deriveType
int deriveType
derive method (0 = by spacing and number, 1 = by number, 2 = by spacing)
Definition: zwapi_cmd_shape_data.h:1378
svxPtnData::relocateBase
int relocateBase
whether to relocate base object (0 = no, 1 = yes) 1 - ensure that the array base point is at the desi...
Definition: zwapi_cmd_shape_data.h:1374
svxPtnData::secondTogglePos
int * secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in ...
Definition: zwapi_cmd_shape_data.h:1388
svxPtnData
pattern data
Definition: zwapi_cmd_shape_data.h:1293
svxPtnFtr::pTableVal
svxPtnVarTbl * pTableVal
the table dimension information,
Definition: zwapi_cmd_shape_data.h:1440
svxPtnFtr::cntDim
int cntDim
count dimension to change the value
Definition: zwapi_cmd_shape_data.h:1439
svxPtnFtr::inc
int inc
0-the value to be set, 1- the value to be increased
Definition: zwapi_cmd_shape_data.h:1438
svxPtnFtr::inpData
svxPtnData * inpData
base input data of pattern feature command
Definition: zwapi_cmd_shape_data.h:1437
svxPtnFtr
pattern feature data
Definition: zwapi_cmd_shape_data.h:1436
svxPtnGeom::inpData
svxPtnData * inpData
base input data of pattern geometry command
Definition: zwapi_cmd_shape_data.h:1404
svxPtnGeom::nonAssoCopy
int nonAssoCopy
non-associative copy (0 = no, 1 = yes), used only for geometry pattern if set to 0,...
Definition: zwapi_cmd_shape_data.h:1405
svxPtnGeom
pattern geometry data
Definition: zwapi_cmd_shape_data.h:1403
svxPtnVarTbl::pCell
int * pCell
Definition: zwapi_cmd_shape_data.h:1418
svxPtnVarTbl::dimName
vxName dimName
the name of the dimension to change the value
Definition: zwapi_cmd_shape_data.h:1416
svxPtnVarTbl::cntCell
int cntCell
count of cells to be set
Definition: zwapi_cmd_shape_data.h:1417
svxPtnVarTbl::pVal
double * pVal
the dimension value to be set.
Definition: zwapi_cmd_shape_data.h:1428
svxPtnVarTbl
table dimension information
Definition: zwapi_cmd_shape_data.h:1415
svxPunch::idBounds
int * idBounds
list of boundary faces' id
Definition: zwapi_cmd_shape_data.h:1173
svxPunch::numBound
int numBound
number of boundary face entities
Definition: zwapi_cmd_shape_data.h:1172
svxPunch::thickness
double thickness
thickness represents the shell offset.default:2
Definition: zwapi_cmd_shape_data.h:1174
svxPunch::idPunch
int idPunch
id of punch shape entity
Definition: zwapi_cmd_shape_data.h:1171
svxPunch::numBase
int numBase
number of base entities
Definition: zwapi_cmd_shape_data.h:1169
svxPunch::idBases
int * idBases
list of base entities' id
Definition: zwapi_cmd_shape_data.h:1170
svxPunch
part punch data
Definition: zwapi_cmd_shape_data.h:1168
svxReplaceData::offset
double offset
offset value
Definition: zwapi_cmd_shape_data.h:1123
svxReplaceData::faceOverflow
evxOverflowType faceOverflow
used to control face overflow behavior. VX_OF_AUTOMATIC default
Definition: zwapi_cmd_shape_data.h:1124
svxReplaceData::keepReplaceFace
int keepReplaceFace
whether to keep the displacement face (0 = not reserve, 1 = reserve. 0 default)
Definition: zwapi_cmd_shape_data.h:1125
svxReplaceData::numBases
int numBases
numbers of replaced base faces
Definition: zwapi_cmd_shape_data.h:1120
svxReplaceData::idBases
int * idBases
list of id's of replaced base faces
Definition: zwapi_cmd_shape_data.h:1121
svxReplaceData::idPlace
int idPlace
id of face for displacement
Definition: zwapi_cmd_shape_data.h:1122
svxReplaceData
shape replace data
Definition: zwapi_cmd_shape_data.h:1119
svxRevolveData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:223
svxRevolveData::StartPnt
svxPoint * StartPnt
start point (NULL to ignore, it will get the point (umin,vmin) of the idStartEnt if StartType = VX_EX...
Definition: zwapi_cmd_shape_data.h:235
svxRevolveData::Flip
int Flip
flip face direction (0 as default, CapType=VX_END_CAP_NONE)
Definition: zwapi_cmd_shape_data.h:238
svxRevolveData::Start
double Start
start angle (deg)
Definition: zwapi_cmd_shape_data.h:218
svxRevolveData::EndPnt
svxPoint * EndPnt
end point (NULL to ignore, it will get the point (umin,vmin) of the idEndEnt if EndType = VX_EXT_TO_F...
Definition: zwapi_cmd_shape_data.h:236
svxRevolveData::idParent
int idParent
parent index if idAxis is a geometry of the profile (-1/0 to ignore)
Definition: zwapi_cmd_shape_data.h:226
svxRevolveData::idEndEnt
int idEndEnt
entity id if EndType != VX_INPU_VALUE (-1 to ignore)
Definition: zwapi_cmd_shape_data.h:234
svxRevolveData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:228
svxRevolveData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:222
svxRevolveData::idAxis
int idAxis
index of idAxis (-1/0 to ignore)
Definition: zwapi_cmd_shape_data.h:225
svxRevolveData::End
double End
end angle (deg)
Definition: zwapi_cmd_shape_data.h:219
svxRevolveData::EndType
evxDistanceMethod EndType
end type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE,...
Definition: zwapi_cmd_shape_data.h:232
svxRevolveData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:237
svxRevolveData::StartType
evxDistanceMethod StartType
start type (values: VX_INPU_VALUE, VX_BY_THROUGH_ALL, VX_TO_POINT, VX_TO_EXTEND_FACE,...
Definition: zwapi_cmd_shape_data.h:231
svxRevolveData::idStartEnt
int idStartEnt
entity id if StartType != VX_INPU_VALUE (-1 to ignore)
Definition: zwapi_cmd_shape_data.h:233
svxRevolveData::idProfile
int idProfile
profile (sketch or curvelist)
Definition: zwapi_cmd_shape_data.h:217
svxRevolveData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:216
svxRevolveData::Axis
svxAxis Axis
axis of revolution
Definition: zwapi_cmd_shape_data.h:220
svxRevolveData
revolved shape
Definition: zwapi_cmd_shape_data.h:215
svxRibData::numBndFaces
int numBndFaces
number of rib boundary faces.
Definition: zwapi_cmd_shape_data.h:864
svxRibData::width
double width
rib thickness (mm) (default:10)
Definition: zwapi_cmd_shape_data.h:861
svxRibData::idBndFaces
int * idBndFaces
list of rib boundary faces
Definition: zwapi_cmd_shape_data.h:865
svxRibData::idParent
int idParent
id of profile curve's parent sketch or curvelist
Definition: zwapi_cmd_shape_data.h:857
svxRibData::flipDir
int flipDir
flip the material direction (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:866
svxRibData::idProfile
int idProfile
index of profile curve
Definition: zwapi_cmd_shape_data.h:858
svxRibData::idPlane
int idPlane
draft plane, set when angle > 0.0
Definition: zwapi_cmd_shape_data.h:863
svxRibData::idShape
int idShape
id of boolean shape, -1 to auto boolean, but since R2024, only support one shape and it will fail if ...
Definition: zwapi_cmd_shape_data.h:855
svxRibData::ftrName
vxName ftrName
feature name for "FtRib", 0 default
Definition: zwapi_cmd_shape_data.h:867
svxRibData::angle
double angle
draft angle (default:0)
Definition: zwapi_cmd_shape_data.h:862
svxRibData::direction
int direction
extrude direction (0 = Parallel to sketch(default), 1 = Vertical to sketch)
Definition: zwapi_cmd_shape_data.h:859
svxRibData::widthType
int widthType
thickness type (0 = Fist side, 1 = Two sides(default), 2 = Second side)
Definition: zwapi_cmd_shape_data.h:860
svxRibData
rib data
Definition: zwapi_cmd_shape_data.h:854
svxShellData::cntList
int cntList
the count of the sub_data will be filled in List
Definition: zwapi_cmd_shape_data.h:1019
svxShellData::sideFaces
int sideFaces
create side faces 0 to no 1 to yes (Generally 1) :create any required side faces during the offset ...
Definition: zwapi_cmd_shape_data.h:1024
svxShellData::Intersect
int Intersect
intersections 1 to do not remove. Ignore self intersecting faces. 2 to remove fast....
Definition: zwapi_cmd_shape_data.h:1030
svxShellData::idShape
int idShape
shape S id
Definition: zwapi_cmd_shape_data.h:1012
svxShellData::pIdOpenFace
int * pIdOpenFace
open faces' id
Definition: zwapi_cmd_shape_data.h:1016
svxShellData::dThick
double dThick
thick T
Definition: zwapi_cmd_shape_data.h:1013
svxShellData::cntOpenFace
int cntOpenFace
open faces' count
Definition: zwapi_cmd_shape_data.h:1015
svxShellData::KeepPrimFace
int KeepPrimFace
Keep primitive faces 0 to no (Generally 1) 1 to yes : primitive faces remaining as primitive after ...
Definition: zwapi_cmd_shape_data.h:1027
svxShellData::pOffSet
double * pOffSet
offset T array ,it must be correspond to pIdFaces one by one
Definition: zwapi_cmd_shape_data.h:1021
svxShellData::pIdFace
int * pIdFace
face F ids
Definition: zwapi_cmd_shape_data.h:1020
svxShellData
template command Shell input data
Definition: zwapi_cmd_shape_data.h:1011
svxSphereData::Radius
double Radius
sphere radius (mm)
Definition: zwapi_cmd_shape_data.h:101
svxSphereData::ftrName
vxName ftrName
feature name for "FtAllSph", 0 default
Definition: zwapi_cmd_shape_data.h:103
svxSphereData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:99
svxSphereData::Center
svxPoint Center
sphere center point
Definition: zwapi_cmd_shape_data.h:100
svxSphereData
sphere
Definition: zwapi_cmd_shape_data.h:98
svxSpiralSweepData::turns
double turns
the number of turns
Definition: zwapi_cmd_shape_data.h:335
svxSpiralSweepData::offset
double offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:349
svxSpiralSweepData::thickness
double thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:350
svxSpiralSweepData::leadRad
double leadRad
determines a pivot point while the angle specifies the number of degrees the profile is rotated....
Definition: zwapi_cmd_shape_data.h:343
svxSpiralSweepData::idShapes
int * idShapes
id of boolean shapes
Definition: zwapi_cmd_shape_data.h:340
svxSpiralSweepData::dst
double dst
the distance along the axis for each turn
Definition: zwapi_cmd_shape_data.h:336
svxSpiralSweepData::combine
evxBoolType combine
combination method. (VX_BOOL_NONE as default)
Definition: zwapi_cmd_shape_data.h:338
svxSpiralSweepData::isFlipDir
int isFlipDir
flip the spiral direction of the thread. (1 = flip, 0 as default)
Definition: zwapi_cmd_shape_data.h:354
svxSpiralSweepData::leadAng
double leadAng
for lead Out, the angle is measured from the point on the profile furthest away from the axis of rota...
Definition: zwapi_cmd_shape_data.h:344
svxSpiralSweepData::leadType
evxLeadType leadType
lead type(set the value of leadRad and leadAng). (VX_LEAD_NONE as default)
Definition: zwapi_cmd_shape_data.h:342
svxSpiralSweepData::isClockwise
int isClockwise
judge the spiral to turn clockwise about the axis direction. (1 = clockwise, 0 as default)
Definition: zwapi_cmd_shape_data.h:353
svxSpiralSweepData::taperAng
double taperAng
taper angle used to create pipe threads, tapered coils, etc
Definition: zwapi_cmd_shape_data.h:352
svxSpiralSweepData::cntShapes
int cntShapes
count of boolean shapes
Definition: zwapi_cmd_shape_data.h:339
svxSpiralSweepData::capType
evxCapType capType
end cap type(invalid if the idProfile is open). (VX_END_CAP_BOTH as default)
Definition: zwapi_cmd_shape_data.h:346
svxSpiralSweepData::offsetType
evxOffsetType offsetType
option of offset(set the value of Offset and Thickness). (VX_OFFSET_NONE as default)
Definition: zwapi_cmd_shape_data.h:348
svxSpiralSweepData::pntOnPro
svxPntOnEntPath pntOnPro
a point at profile (sketch, curve, edge, curveList). If the type of profile is sketch,...
Definition: zwapi_cmd_shape_data.h:333
svxSpiralSweepData::axis
svxVector axis
axis of spiral sweep
Definition: zwapi_cmd_shape_data.h:334
svxSpiralSweepData
spiral swept shape
Definition: zwapi_cmd_shape_data.h:331
svxStockData::length
double length[2]
when adjustType = 0, increment of length in the positive and negative directions when adjustType = 1,...
Definition: zwapi_cmd_shape_data.h:961
svxStockData::radius
double radius
when adjustType = 0, increment of radius when adjustType = 1, stock radius
Definition: zwapi_cmd_shape_data.h:972
svxStockData::axisPos
int axisPos
specify the center axis position of the cylinder (0 = on the setting axis, 1 = on the center of the s...
Definition: zwapi_cmd_shape_data.h:970
svxStockData::numEnts
int numEnts
number of entities to enclose
Definition: zwapi_cmd_shape_data.h:952
svxStockData::width
double width[2]
when adjustType = 0, increment of width in the positive and negative directions when adjustType = 1,...
Definition: zwapi_cmd_shape_data.h:963
svxStockData::height
double height[2]
when adjustType = 0, increment of height in the positive and negative directions when adjustType = 1,...
Definition: zwapi_cmd_shape_data.h:965
svxStockData::axis
svxAxis axis
spiral axis to specify the rotational center of the cylinder
Definition: zwapi_cmd_shape_data.h:969
svxStockData::adjustType
int adjustType
Type of adjust value (0 = By side, 1 = By total)
Definition: zwapi_cmd_shape_data.h:954
svxStockData::ftrName
vxName ftrName
feature name for "FtExtStock2", 0 default
Definition: zwapi_cmd_shape_data.h:956
svxStockData::idPlane
int idPlane
id of reference plane to orient the stock, 0 to use default plane paralleled to XY datum (datum,...
Definition: zwapi_cmd_shape_data.h:959
svxStockData::option
evxStockOpt option
stock type(1:Block, 2:Cylinder)
Definition: zwapi_cmd_shape_data.h:951
svxStockData::decimal
int decimal
number of decimal place
Definition: zwapi_cmd_shape_data.h:955
svxStockData::idEnts
int * idEnts
list of entities to enclose (shape, face, block)
Definition: zwapi_cmd_shape_data.h:953
svxStockData::cylHgt
double cylHgt[2]
when adjustType = 0, increment of cylinder height in the positive and negative directions when adjust...
Definition: zwapi_cmd_shape_data.h:974
svxStockData
stock data
Definition: zwapi_cmd_shape_data.h:950
svxStretchData::xRange
double xRange
specify the stretch range in X direction. 100 default
Definition: zwapi_cmd_shape_data.h:1227
svxStretchData::zScale
double zScale
specify the scaling factor in Z direction. 100 default
Definition: zwapi_cmd_shape_data.h:1233
svxStretchData::uniStress
int uniStress
whether to use the same scaling factor (0 = not use, 1 = use. 0 default)
Definition: zwapi_cmd_shape_data.h:1236
svxStretchData::framework
int framework
controls the shape of the stretch shape (0 = Box, 1 = Ellipsoid. 0 default)
Definition: zwapi_cmd_shape_data.h:1235
svxStretchData::xScale
double xScale
specify the scaling factor in X direction. 100 default
Definition: zwapi_cmd_shape_data.h:1231
svxStretchData::yScale
double yScale
specify the scaling factor in Y direction. 100 default
Definition: zwapi_cmd_shape_data.h:1232
svxStretchData::yRange
double yRange
specify the stretch range in Y direction. 100 default
Definition: zwapi_cmd_shape_data.h:1228
svxStretchData::keepOriginal
int keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)
Definition: zwapi_cmd_shape_data.h:1237
svxStretchData::idDatum
int idDatum
specify a plane that defines the XY coordinate system and the stretch center
Definition: zwapi_cmd_shape_data.h:1225
svxStretchData::idShapes
int * idShapes
specify the shapes that will be stretched
Definition: zwapi_cmd_shape_data.h:1224
svxStretchData::miniSurfData
int miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)
Definition: zwapi_cmd_shape_data.h:1238
svxStretchData::zRange
double zRange
specify the stretch range in Z direction. 100 default
Definition: zwapi_cmd_shape_data.h:1229
svxStretchData::numShapes
int numShapes
numbers of stretched shapes
Definition: zwapi_cmd_shape_data.h:1223
svxStretchData
shape stretch data
Definition: zwapi_cmd_shape_data.h:1221
svxSweepData::idXaxis
int idXaxis
id of X-axis point, curve or plane (0 if undefined or tangent to path)
Definition: zwapi_cmd_shape_data.h:296
svxSweepData::xOpt
evxSweepXOpt xOpt
type of X-axis
Definition: zwapi_cmd_shape_data.h:305
svxSweepData::useStartPnt
int useStartPnt
1- user "StartPnt", else 0 it will get the start point of the "idPath"
Definition: zwapi_cmd_shape_data.h:303
svxSweepData::xEnt
svxPntOnEnt * xEnt
entity data of x-axis (NULL to ignore or use idZaxis or xOpt = VX_SWP_X_MIN_TWIST) VX_SWP_X_FIXED_DIR...
Definition: zwapi_cmd_shape_data.h:307
svxSweepData::StartPnt
svxPoint StartPnt
point that identifies start of path curve
Definition: zwapi_cmd_shape_data.h:286
svxSweepData::cntCap
int cntCap
count cap face (0 to ignore; valid if Combine is VX_BOOL_ADD or VX_BOOL_Remove and the idProfile is o...
Definition: zwapi_cmd_shape_data.h:319
svxSweepData::idPath
int idPath
id of curve that identifies the sweep path
Definition: zwapi_cmd_shape_data.h:285
svxSweepData::UseParent
int UseParent
1 to use curve's parent as the sweep path, else 0
Definition: zwapi_cmd_shape_data.h:290
svxSweepData::CapFace
int * CapFace
cap face id list (NULL to ignore)
Definition: zwapi_cmd_shape_data.h:322
svxSweepData::zEnt
svxPntOnEnt * zEnt
entity data of z-axis (NULL to ignore or use idZaxis or zOpt = VX_SWP_Z_TANG_TO_PATH) VX_SWP_Z_TANG_T...
Definition: zwapi_cmd_shape_data.h:312
svxSweepData::idProfile
int idProfile
profile (sketch, curve, edge, curvelist)
Definition: zwapi_cmd_shape_data.h:284
svxSweepData::CapType
evxCapType CapType
end cap type (VX_END_CAP_BOTH as default, invalid if the idProfile is open)
Definition: zwapi_cmd_shape_data.h:318
svxSweepData::Option
evxSweepOpt Option
sweep option(VX_SWP_AT_PROFILE as default)
Definition: zwapi_cmd_shape_data.h:292
svxSweepData::Offset
double Offset
profile offset (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:300
svxSweepData::idFrame
int idFrame
id of sweep frame if Option=VX_SWP_FRAME, else 0
Definition: zwapi_cmd_shape_data.h:294
svxSweepData::MergeFc
int MergeFc
merge tangent faces (0 as default)
Definition: zwapi_cmd_shape_data.h:323
svxSweepData::zOpt
evxSweepZOpt zOpt
type of Y-axis
Definition: zwapi_cmd_shape_data.h:306
svxSweepData::idZaxis
int idZaxis
id of Z-axis point, curve or plane (0 if undefined or minimum twist)
Definition: zwapi_cmd_shape_data.h:298
svxSweepData::Thickness
double Thickness
wall thickness (mm) (0 if undefined)
Definition: zwapi_cmd_shape_data.h:301
svxSweepData::idParent
int idParent
id of path curve's parent sketch or curvelist
Definition: zwapi_cmd_shape_data.h:289
svxSweepData::Combine
evxBoolType Combine
combination method
Definition: zwapi_cmd_shape_data.h:283
svxSweepData::OffsetTyp
evxOffsetType OffsetTyp
option of offset(set the value of Offset and Thickness)
Definition: zwapi_cmd_shape_data.h:316
svxSweepData
swept shape
Definition: zwapi_cmd_shape_data.h:282
svxTaperData::factor
double factor
specify the size of the smaller side of the tapered shape.
Definition: zwapi_cmd_shape_data.h:1209
svxTaperData::idShapes
int * idShapes
specify the shapes that will be tapered
Definition: zwapi_cmd_shape_data.h:1206
svxTaperData::miniSurfData
int miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)
Definition: zwapi_cmd_shape_data.h:1213
svxTaperData::numShapes
int numShapes
numbers of taper shapes
Definition: zwapi_cmd_shape_data.h:1205
svxTaperData::range
double range
specify the distance to the datum.
Definition: zwapi_cmd_shape_data.h:1208
svxTaperData::idDatum
int idDatum
specify a plane that defines the XY coordinate system of the geometry that is to be tapered
Definition: zwapi_cmd_shape_data.h:1207
svxTaperData::keepOriginal
int keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)
Definition: zwapi_cmd_shape_data.h:1212
svxTaperData::axis
svxVector * axis
specify the optional taper axis. nullptr default
Definition: zwapi_cmd_shape_data.h:1211
svxTaperData
shape taper data
Definition: zwapi_cmd_shape_data.h:1203
svxThickenData::thick
double thick
thicken thickness, the value cannot be zero (negative: internal offset, positive: external offset)
Definition: zwapi_cmd_shape_data.h:1045
svxThickenData::idShape
int idShape
id of shape to thicken
Definition: zwapi_cmd_shape_data.h:1050
svxThickenData::ftrName
vxName ftrName
feature name for "FtThicken", 0 default
Definition: zwapi_cmd_shape_data.h:1047
svxThickenData::numFaces
int numFaces
number of faces to thicken
Definition: zwapi_cmd_shape_data.h:1054
svxThickenData::idFaces
int * idFaces
list of faces to thicken
Definition: zwapi_cmd_shape_data.h:1055
svxThickenData::type
int type
specify the selection of object (0 = sheet, 1 = Faces)
Definition: zwapi_cmd_shape_data.h:1044
svxThickenData::idOffFaces
int * idOffFaces
list of additional offset faces
Definition: zwapi_cmd_shape_data.h:1059
svxThickenData::numOffset
int numOffset
number of additional offset
Definition: zwapi_cmd_shape_data.h:1058
svxThickenData::keep
int keep
whether to keep the original sheet (1 = yes, 0 = no)
Definition: zwapi_cmd_shape_data.h:1051
svxThickenData::thickT
double * thickT
list of additional offset value
Definition: zwapi_cmd_shape_data.h:1060
svxThickenData
thicken data
Definition: zwapi_cmd_shape_data.h:1043
svxThreadData::PerUnit
double PerUnit
threads per unit (0 if not used)
Definition: zwapi_cmd_shape_data.h:911
svxThreadData::Length
double Length
thread length (mm)
Definition: zwapi_cmd_shape_data.h:910
svxThreadData::Pitch
double Pitch
thread pitch (mm) (0 if not used)
Definition: zwapi_cmd_shape_data.h:912
svxThreadData::Diameter
double Diameter
thread diameter (mm)
Definition: zwapi_cmd_shape_data.h:909
svxThreadData::EndChamfer
int EndChamfer
1=Yes; 0=No Input the setback and the angle to create chamfer on the end of the face nearest the sele...
Definition: zwapi_cmd_shape_data.h:913
svxThreadData::Type
evxThreadType Type
thread type
Definition: zwapi_cmd_shape_data.h:908
svxThreadData
thread definition
Definition: zwapi_cmd_shape_data.h:907
svxTrimData::idTrimmer
int * idTrimmer
list of trimming entities (shape, face, datum plane)
Definition: zwapi_cmd_shape_data.h:1091
svxTrimData::flip
int flip
1-flip side to keep, else 0
Definition: zwapi_cmd_shape_data.h:1093
svxTrimData::trimCap
int trimCap
whether to cap shape at the trimming edges (0 = uncap, 1 = cap)
Definition: zwapi_cmd_shape_data.h:1095
svxTrimData::keepTrimm
int keepTrimm
whether to keep trimming shapes (0 = delete, 1 = keep)
Definition: zwapi_cmd_shape_data.h:1096
svxTrimData::trimType
int trimType
1-trim with all simultaneously, else 0
Definition: zwapi_cmd_shape_data.h:1094
svxTrimData::ftrName
vxName ftrName
feature name for "FtSolidSoloTrm", 0 default
Definition: zwapi_cmd_shape_data.h:1099
svxTrimData::extend
int extend
extend method (1 = no extend, 0 = linear, 2 = circular)
Definition: zwapi_cmd_shape_data.h:1097
svxTrimData::numTrimm
int numTrimm
number of trimming entities
Definition: zwapi_cmd_shape_data.h:1090
svxTrimData::numBase
int numBase
number of shapes to trimming
Definition: zwapi_cmd_shape_data.h:1088
svxTrimData::idBase
int * idBase
id list of shape to trimming
Definition: zwapi_cmd_shape_data.h:1089
svxTrimData
Trim data.
Definition: zwapi_cmd_shape_data.h:1087
svxTwistData::keepOriginal
int keepOriginal
whether to keep the original shape (0 = not reserve, 1 = reserve. 0 default)
Definition: zwapi_cmd_shape_data.h:1194
svxTwistData::axis
svxVector * axis
specify the optional taper axis. nullptr default
Definition: zwapi_cmd_shape_data.h:1193
svxTwistData::angle
double angle
specify the largest rotate angle in twist range. 180 default
Definition: zwapi_cmd_shape_data.h:1191
svxTwistData::range
double range
the distance to the origin of the selected datum. 100 default
Definition: zwapi_cmd_shape_data.h:1190
svxTwistData::miniSurfData
int miniSurfData
whether to minimize surface data (0 = not minimize, 1 = minimize. 1 default)
Definition: zwapi_cmd_shape_data.h:1195
svxTwistData::idShapes
int * idShapes
specify the shapes that will be twisted
Definition: zwapi_cmd_shape_data.h:1188
svxTwistData::numShapes
int numShapes
numbers of twisted shapes
Definition: zwapi_cmd_shape_data.h:1187
svxTwistData::idDatum
int idDatum
specify a plane that defines the XY coordinate system and the twist center
Definition: zwapi_cmd_shape_data.h:1189
svxTwistData
shape twist data
Definition: zwapi_cmd_shape_data.h:1185
svxVector
3D vector
Definition: zwapi_util.h:338
svxCopyData::evxMethodUnion::AroundDir
svxAroundDir AroundDir
around direction data
Definition: zwapi_cmd_shape_data.h:1607
svxCopyData::evxMethodUnion::AlongDir
svxAlongDir AlongDir
along direction data
Definition: zwapi_cmd_shape_data.h:1606
svxCopyData::evxMethodUnion::Sweep
svxAlongPath Sweep
sweep along path
Definition: zwapi_cmd_shape_data.h:1609
svxCopyData::evxMethodUnion::AlignFrame
svxAlignFrame AlignFrame
copy entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1608
svxCopyData::evxMethodUnion::DymCopy
svxDymMove DymCopy
dynamic copy
Definition: zwapi_cmd_shape_data.h:1604
svxCopyData::evxMethodUnion::PntToPnt
svxMovePntToPnt PntToPnt
point to point
Definition: zwapi_cmd_shape_data.h:1605
svxCopyData::evxMethodUnion
union of copy data
Definition: zwapi_cmd_shape_data.h:1603
svxDraftData::svxDraftStationaryEnt
Stationary Entity such as Faces and Edges.
Definition: zwapi_cmd_shape_data.h:571
svxMoveData::evxMethodsUnion::AlongDir
svxAlongDir AlongDir
along direction data
Definition: zwapi_cmd_shape_data.h:1586
svxMoveData::evxMethodsUnion::AlignFrame
svxAlignFrame AlignFrame
copy entities by aligning frames
Definition: zwapi_cmd_shape_data.h:1588
svxMoveData::evxMethodsUnion::Sweep
svxAlongPath Sweep
sweep along path
Definition: zwapi_cmd_shape_data.h:1589
svxMoveData::evxMethodsUnion::DymMove
svxDymMove DymMove
dynamic move
Definition: zwapi_cmd_shape_data.h:1584
svxMoveData::evxMethodsUnion::AroundDir
svxAroundDir AroundDir
around direction data
Definition: zwapi_cmd_shape_data.h:1587
svxMoveData::evxMethodsUnion::PntToPnt
svxMovePntToPnt PntToPnt
point to point
Definition: zwapi_cmd_shape_data.h:1585
svxMoveData::evxMethodsUnion
union of move data
Definition: zwapi_cmd_shape_data.h:1583
svxPtnData::PtnData
union of part pattern data
Definition: zwapi_cmd_shape_data.h:1298
zwapi_cmd_subcmd_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SHEET_METAL_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sheetmetal.h
cvxPartSmdBendTaper
cvxPartSmdBendTaperDefDataInit
cvxPartSmdBendTaperInit
cvxPartSmdChangeBend
cvxPartSmdChangeBendInit
cvxPartSmdCloseCorner
cvxPartSmdCloseCornerInit
cvxPartSmdDimple
cvxPartSmdDimpleInit
cvxPartSmdExtendFlange
cvxPartSmdExtendFlangeInit
cvxPartSmdExtrudeFlange
cvxPartSmdExtrudeFlangeinit
cvxPartSmdExtrudeTab
cvxPartSmdExtrudeTabInit
cvxPartSmdFlange
cvxPartSmdFlangeInit
cvxPartSmdFlatten
cvxPartSmdFlattenInit
cvxPartSmdFold
cvxPartSmdFoldByLine
cvxPartSmdFoldByLineInit
cvxPartSmdFullFlange
cvxPartSmdFullFlangeInit
cvxPartSmdHemFlange
cvxPartSmdHemFlangeInit
cvxPartSmdJog
cvxPartSmdJogInit
cvxPartSmdLftFlange
cvxPartSmdLftFlangeInit
cvxPartSmdLnUnfold
cvxPartSmdLnUnfoldInit
cvxPartSmdLouver
cvxPartSmdLouverInit
cvxPartSmdMarkBend
cvxPartSmdMarkBendInit
cvxPartSmdNormalCut
cvxPartSmdNormalCutinit
cvxPartSmdPartialFlange
cvxPartSmdPartialFlangeInit
cvxPartSmdProfFlange
cvxPartSmdProfFlangeInit
cvxPartSmdProfFlangeProfMatInit
cvxPartSmdPunch
cvxPartSmdPunchInit
cvxPartSmdReliefDataInit
cvxPartSmdRip
cvxPartSmdRipInit
cvxPartSmdSweptFlange
cvxPartSmdSweptFlangeInit
cvxPartSmdUnfold

◆ ZW_API_SHEET_METAL_FTR_H

#define ZW_API_SHEET_METAL_FTR_H

Definition at line 15 of file zwapi_cmd_sheetmetal.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sheetmetal.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sheetmetal.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SHEET_METAL_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_SHEET_METAL_FTR_H
16
17#include "zwapi_cmd_sheetmetal_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/**********************************************************************
27*! -Sketch- : zwapi_cmd_sk_create.h
28* extern evxErrors cvxPartSkNew(svxMatrix* Plane, int* idEnt);
29* extern evxErrors cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
30**********************************************************************/
31
32/******************************************************************************/
53extern evxErrors cvxPartSmdExtrudeTabInit(svxSmdExtrudeTabData* data);
54
55/******************************************************************************/
78extern evxErrors cvxPartSmdExtrudeTab(const svxSmdExtrudeTabData* data, int* idExtTab);
79
80/******************************************************************************/
101extern evxErrors cvxPartSmdExtrudeFlangeinit(svxExtrudeFlangeData* data);
102
103/******************************************************************************/
125extern evxErrors cvxPartSmdExtrudeFlange(const svxExtrudeFlangeData* data, int* idExtFlange);
126
127
128//====================================================================================================================
130//====================================================================================================================
131
132/******************************************************************************/
150extern evxErrors cvxPartSmdReliefDataInit(svxSmdReliefData* data);
151
152/******************************************************************************/
173extern evxErrors cvxPartSmdFullFlangeInit(svxSmdFullFlangeData* data);
174
175/******************************************************************************/
198extern evxErrors cvxPartSmdFullFlange(const svxSmdFullFlangeData* data, int* idFull);
199
200/******************************************************************************/
221extern evxErrors cvxPartSmdProfFlangeProfMatInit(int idEdge, double angle, svxMatrix* skMat);
222
223/******************************************************************************/
244extern evxErrors cvxPartSmdProfFlangeInit(svxSmdFlangeProfData* data);
245
246/******************************************************************************/
273extern evxErrors cvxPartSmdProfFlange(const svxSmdFlangeProfData* data, int* idFlange);
274
275/******************************************************************************/
296extern evxErrors cvxPartSmdPartialFlangeInit(svxSmdPartialFlangeData* data);
297
298/******************************************************************************/
320extern evxErrors cvxPartSmdPartialFlange(const svxSmdPartialFlangeData* data, int* idPartial);
321
322/******************************************************************************/
344extern evxErrors cvxPartSmdHemFlangeInit(int hemType, svxSmdHemFlangeData* data);
345
346/******************************************************************************/
370extern evxErrors cvxPartSmdHemFlange(const svxSmdHemFlangeData* data, int* idHem);
371
372
373/******************************************************************************/
391extern evxErrors cvxPartSmdLftFlangeInit(evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData* data);
392
393/******************************************************************************/
416extern evxErrors cvxPartSmdLftFlange(const svxSmdLoftedFlangeData* data, int* idLft);
417
418/******************************************************************************/
436extern evxErrors cvxPartSmdSweptFlangeInit(evxSmdCornerRelief corType, svxSmdSweptFlangeData* data);
437
438/******************************************************************************/
462extern evxErrors cvxPartSmdSweptFlange(const svxSmdSweptFlangeData* data, int* idSwept);
463
464/******************************************************************************/
481extern evxErrors cvxPartSmdFoldByLineInit(svxSmdFoldByLineData* data);
482
483/******************************************************************************/
506extern evxErrors cvxPartSmdFoldByLine(const svxSmdFoldByLineData* data, int* idFbl);
507
508/******************************************************************************/
525extern evxErrors cvxPartSmdJogInit(svxSmdJogData* data);
526
527/******************************************************************************/
551extern evxErrors cvxPartSmdJog(const svxSmdJogData* data, int* idJog);
552
553
554//====================================================================================================================
556//====================================================================================================================
557/******************************************************************************/
575extern evxErrors cvxPartSmdExtendFlangeInit(evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData* data);
576
577/******************************************************************************/
603extern evxErrors cvxPartSmdExtendFlange(const svxSmdExtendFlangeData* data, int* idFtr);
604
605/******************************************************************************/
624extern evxErrors cvxPartSmdFlangeInit(svxSmdFlangeData* data);
625
626/******************************************************************************/
652extern evxErrors cvxPartSmdFlange(const svxSmdFlangeData* data, int* idFlange);
653
654/******************************************************************************/
674extern evxErrors cvxPartSmdBendTaperDefDataInit(int taperType, svxSmdBendTaperDefData* data);
675
676/******************************************************************************/
695extern evxErrors cvxPartSmdBendTaperInit(evxSmdTaperSideMethod method, svxSmdBendTaperData* data);
696
697/******************************************************************************/
723extern evxErrors cvxPartSmdBendTaper(const svxSmdBendTaperData* data, int* idFtr);
724
725/******************************************************************************/
742extern evxErrors cvxPartSmdNormalCutinit(svxNormalCutData* data);
743
744/******************************************************************************/
768extern evxErrors cvxPartSmdNormalCut(const svxNormalCutData* pData, int* numShape, int** idShapes);
769
770
771//====================================================================================================================
773//====================================================================================================================
774/******************************************************************************/
792extern evxErrors cvxPartSmdCloseCornerInit(int type, svxCloseCornerData* data);
793
794/******************************************************************************/
819extern evxErrors cvxPartSmdCloseCorner(const svxCloseCornerData* CornerData, int* idSmdCorner);
820
821
822//====================================================================================================================
824//====================================================================================================================
825/******************************************************************************/
842extern evxErrors cvxPartSmdDimpleInit(svxDimpleData* data);
843
844/******************************************************************************/
868extern evxErrors cvxPartSmdDimple(svxDimpleData* Dimple, int* idDimple);
869
870/******************************************************************************/
887extern evxErrors cvxPartSmdLouverInit(svxLouverData* data);
888
889/******************************************************************************/
914extern evxErrors cvxPartSmdLouver(const svxLouverData* LouverData, int* idSmdLouver);
915
916/******************************************************************************/
933extern evxErrors cvxPartSmdPunchInit(svxPunchData* data);
934
935/******************************************************************************/
959extern evxErrors cvxPartSmdPunch(const svxPunchData* pData, int* idShape);
960
961
962//====================================================================================================================
964//====================================================================================================================
965/******************************************************************************/
987extern evxErrors cvxPartSmdFold(const svxFoldData* Fold, int* idSmdFold);
988
989/******************************************************************************/
1011extern evxErrors cvxPartSmdUnfold(const svxUnfoldData* Unfold, int* idSmdUnfold);
1012
1013
1014/******************************************************************************/
1031extern evxErrors cvxPartSmdFlattenInit(svxSmdFlattenData* data);
1032
1033/******************************************************************************/
1061extern evxErrors cvxPartSmdFlatten(const svxSmdFlattenData* data, int* idFtr);
1062
1063/******************************************************************************/
1080extern evxErrors cvxPartSmdLnUnfoldInit(svxSmdLinearUnfoldData* data);
1081
1082/******************************************************************************/
1105extern evxErrors cvxPartSmdLnUnfold(const svxSmdLinearUnfoldData* data, int* idFtr);
1106
1107/******************************************************************************/
1125extern evxErrors cvxPartSmdChangeBendInit(evxSmdChangeBendType type, svxSmdChangeBendData* data);
1126
1127/******************************************************************************/
1149extern evxErrors cvxPartSmdChangeBend(const svxSmdChangeBendData* data, int* idFtr);
1150
1151
1152//====================================================================================================================
1154//====================================================================================================================
1155/******************************************************************************/
1172extern evxErrors cvxPartSmdRipInit(svxSmdRipData* data);
1173
1174/******************************************************************************/
1196extern evxErrors cvxPartSmdRip(const svxSmdRipData* data, int* idFtr);
1197
1198/******************************************************************************/
1215extern evxErrors cvxPartSmdMarkBendInit(svxSmdMarkBendData* data);
1216
1217/******************************************************************************/
1242extern evxErrors cvxPartSmdMarkBend(const svxSmdMarkBendData* data, int* idFtr);
1243
1244//====================================================================================================================
1246//====================================================================================================================
1247/**********************************************************************
1248*! -Pattern Geometry- : zwapi_cmd_shape.h
1249* extern int cvxPartPatternGeom(int Count, int* idEnts, const svxPtnGeom* Pattern, int* idPattern);
1250**********************************************************************/
1251
1252/**********************************************************************
1253*! -Pattern Feature- : zwapi_cmd_shape.h
1254* extern int cvxPartPatternFtr(int Count, int* idFtrs, const svxPtnFtr* Pattern, int* idPattern);
1255**********************************************************************/
1256
1257/**********************************************************************
1258*! -Mirror Geometry- : zwapi_cmd_shape.h
1259* extern int cvxPartMirrorGeom(svxMirrorGeom* Mirror, int* NumNewEnts, int** idNewEnts);
1260**********************************************************************/
1261
1262/**********************************************************************
1263*! -Mirror Feature- : zwapi_cmd_shape.h
1264* extern int cvxPartMirrorFtr(svxMirrorFtr* Mirror, int* idFtr);
1265**********************************************************************/
1266
1267/**********************************************************************
1268*! -Fillet- : zwapi_cmd_shape.h
1269* extern evxErrors cvxPartFillet(int Count, int* Edges, double Radius);
1270* extern evxErrors cvxPartFilletAllInit(svxChamFlltData* data);
1271* extern evxErrors cvxPartFilletAll(const svxChamFlltData* Fillet, int* idFillet);
1272**********************************************************************/
1273
1274/**********************************************************************
1275*! -Chamfer- : zwapi_cmd_shape.h
1276* extern evxErrors cvxPartChamConst(int Count, int* Edges, double Sb);
1277* extern evxErrors cvxPartChamAng(int Cnt, int* Edges, int idFace, double Sb, double Angle);
1278* extern evxErrors cvxPartChamAsym(int Cnt, int* Edges, int idFace, double Sb1, double Sb2);
1279* extern evxErrors cvxChamFlltSetDataInit(svxChamFlltSetData* data);
1280* extern evxErrors cvxPartChamferAllInit(svxChamFlltData* data);
1281* extern evxErrors cvxPartChamferAll(const svxChamFlltData* Chamfer, int* idChamfer);
1282**********************************************************************/
1283
1284/*
1285*********************************************************************
1286** END HEADER FILE
1287*********************************************************************
1288*/
1289#ifdef __cplusplus
1290 }
1291#endif /* __cplusplus */
1292
1293#endif /* ZW_API_SHEET_METAL_FTR_H */
evxSmdTaperSideMethod
evxSmdTaperSideMethod
smd bend taper sides
Definition: zwapi_cmd_sheetmetal_data.h:892
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
Lofted Flange method.
Definition: zwapi_cmd_sheetmetal_data.h:568
evxSmdCornerRelief
evxSmdCornerRelief
Smd Relief type of Corner Attributes.
Definition: zwapi_cmd_sheetmetal_data.h:86
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
extend flange method
Definition: zwapi_cmd_sheetmetal_data.h:796
evxSmdChangeBendType
evxSmdChangeBendType
change bend type
Definition: zwapi_cmd_sheetmetal_data.h:1251
cvxPartSmdHemFlange
evxErrors cvxPartSmdHemFlange(const svxSmdHemFlangeData *data, int *idHem)
cvxPartSmdPartialFlange
evxErrors cvxPartSmdPartialFlange(const svxSmdPartialFlangeData *data, int *idPartial)
cvxPartSmdFlattenInit
evxErrors cvxPartSmdFlattenInit(svxSmdFlattenData *data)
cvxPartSmdExtrudeTab
evxErrors cvxPartSmdExtrudeTab(const svxSmdExtrudeTabData *data, int *idExtTab)
cvxPartSmdLftFlange
evxErrors cvxPartSmdLftFlange(const svxSmdLoftedFlangeData *data, int *idLft)
cvxPartSmdLnUnfold
evxErrors cvxPartSmdLnUnfold(const svxSmdLinearUnfoldData *data, int *idFtr)
cvxPartSmdLnUnfoldInit
evxErrors cvxPartSmdLnUnfoldInit(svxSmdLinearUnfoldData *data)
cvxPartSmdBendTaper
evxErrors cvxPartSmdBendTaper(const svxSmdBendTaperData *data, int *idFtr)
cvxPartSmdExtendFlange
evxErrors cvxPartSmdExtendFlange(const svxSmdExtendFlangeData *data, int *idFtr)
cvxPartSmdFoldByLine
evxErrors cvxPartSmdFoldByLine(const svxSmdFoldByLineData *data, int *idFbl)
cvxPartSmdDimpleInit
evxErrors cvxPartSmdDimpleInit(svxDimpleData *data)
cvxPartSmdMarkBend
evxErrors cvxPartSmdMarkBend(const svxSmdMarkBendData *data, int *idFtr)
cvxPartSmdFlangeInit
evxErrors cvxPartSmdFlangeInit(svxSmdFlangeData *data)
cvxPartSmdSweptFlange
evxErrors cvxPartSmdSweptFlange(const svxSmdSweptFlangeData *data, int *idSwept)
cvxPartSmdFullFlangeInit
evxErrors cvxPartSmdFullFlangeInit(svxSmdFullFlangeData *data)
cvxPartSmdExtrudeFlangeinit
evxErrors cvxPartSmdExtrudeFlangeinit(svxExtrudeFlangeData *data)
cvxPartSmdExtendFlangeInit
evxErrors cvxPartSmdExtendFlangeInit(evxSmdExtendFlangeMethod type, svxSmdExtendFlangeData *data)
cvxPartSmdProfFlangeProfMatInit
evxErrors cvxPartSmdProfFlangeProfMatInit(int idEdge, double angle, svxMatrix *skMat)
cvxPartSmdChangeBend
evxErrors cvxPartSmdChangeBend(const svxSmdChangeBendData *data, int *idFtr)
cvxPartSmdFullFlange
evxErrors cvxPartSmdFullFlange(const svxSmdFullFlangeData *data, int *idFull)
cvxPartSmdProfFlange
evxErrors cvxPartSmdProfFlange(const svxSmdFlangeProfData *data, int *idFlange)
cvxPartSmdFlatten
evxErrors cvxPartSmdFlatten(const svxSmdFlattenData *data, int *idFtr)
cvxPartSmdPunchInit
evxErrors cvxPartSmdPunchInit(svxPunchData *data)
cvxPartSmdProfFlangeInit
evxErrors cvxPartSmdProfFlangeInit(svxSmdFlangeProfData *data)
cvxPartSmdBendTaperDefDataInit
evxErrors cvxPartSmdBendTaperDefDataInit(int taperType, svxSmdBendTaperDefData *data)
cvxPartSmdFoldByLineInit
evxErrors cvxPartSmdFoldByLineInit(svxSmdFoldByLineData *data)
cvxPartSmdLouver
evxErrors cvxPartSmdLouver(const svxLouverData *LouverData, int *idSmdLouver)
cvxPartSmdHemFlangeInit
evxErrors cvxPartSmdHemFlangeInit(int hemType, svxSmdHemFlangeData *data)
cvxPartSmdDimple
evxErrors cvxPartSmdDimple(svxDimpleData *Dimple, int *idDimple)
cvxPartSmdExtrudeTabInit
evxErrors cvxPartSmdExtrudeTabInit(svxSmdExtrudeTabData *data)
cvxPartSmdChangeBendInit
evxErrors cvxPartSmdChangeBendInit(evxSmdChangeBendType type, svxSmdChangeBendData *data)
cvxPartSmdPunch
evxErrors cvxPartSmdPunch(const svxPunchData *pData, int *idShape)
cvxPartSmdLouverInit
evxErrors cvxPartSmdLouverInit(svxLouverData *data)
cvxPartSmdCloseCornerInit
evxErrors cvxPartSmdCloseCornerInit(int type, svxCloseCornerData *data)
cvxPartSmdUnfold
evxErrors cvxPartSmdUnfold(const svxUnfoldData *Unfold, int *idSmdUnfold)
cvxPartSmdSweptFlangeInit
evxErrors cvxPartSmdSweptFlangeInit(evxSmdCornerRelief corType, svxSmdSweptFlangeData *data)
cvxPartSmdJog
evxErrors cvxPartSmdJog(const svxSmdJogData *data, int *idJog)
cvxPartSmdNormalCut
evxErrors cvxPartSmdNormalCut(const svxNormalCutData *pData, int *numShape, int **idShapes)
cvxPartSmdMarkBendInit
evxErrors cvxPartSmdMarkBendInit(svxSmdMarkBendData *data)
cvxPartSmdNormalCutinit
evxErrors cvxPartSmdNormalCutinit(svxNormalCutData *data)
cvxPartSmdExtrudeFlange
evxErrors cvxPartSmdExtrudeFlange(const svxExtrudeFlangeData *data, int *idExtFlange)
cvxPartSmdLftFlangeInit
evxErrors cvxPartSmdLftFlangeInit(evxSmdLftFlangeMethod method, svxSmdLoftedFlangeData *data)
cvxPartSmdReliefDataInit
evxErrors cvxPartSmdReliefDataInit(svxSmdReliefData *data)
cvxPartSmdFlange
evxErrors cvxPartSmdFlange(const svxSmdFlangeData *data, int *idFlange)
cvxPartSmdBendTaperInit
evxErrors cvxPartSmdBendTaperInit(evxSmdTaperSideMethod method, svxSmdBendTaperData *data)
cvxPartSmdCloseCorner
evxErrors cvxPartSmdCloseCorner(const svxCloseCornerData *CornerData, int *idSmdCorner)
cvxPartSmdRipInit
evxErrors cvxPartSmdRipInit(svxSmdRipData *data)
cvxPartSmdPartialFlangeInit
evxErrors cvxPartSmdPartialFlangeInit(svxSmdPartialFlangeData *data)
cvxPartSmdFold
evxErrors cvxPartSmdFold(const svxFoldData *Fold, int *idSmdFold)
cvxPartSmdJogInit
evxErrors cvxPartSmdJogInit(svxSmdJogData *data)
cvxPartSmdRip
evxErrors cvxPartSmdRip(const svxSmdRipData *data, int *idFtr)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default ...
Definition: zwapi_cmd_sheetmetal_data.h:990
svxDimpleData
dimple data
Definition: zwapi_cmd_sheetmetal_data.h:1124
svxExtrudeFlangeData
template command Smd Extrude Flange data
Definition: zwapi_cmd_sheetmetal_data.h:217
svxFoldData
template command Smd Fold data
Definition: zwapi_cmd_sheetmetal_data.h:1180
svxLouverData
template command Smd Louver data
Definition: zwapi_cmd_sheetmetal_data.h:1157
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxNormalCutData
template command Smd Normal Cut data
Definition: zwapi_cmd_sheetmetal_data.h:939
svxPunchData
Punch data.
Definition: zwapi_cmd_sheetmetal_data.h:1073
svxSmdBendTaperData
template command Smd bend taper data
Definition: zwapi_cmd_sheetmetal_data.h:904
svxSmdBendTaperDefData
smd bend taper definition side data
Definition: zwapi_cmd_sheetmetal_data.h:861
svxSmdChangeBendData
template command Smd change bend data
Definition: zwapi_cmd_sheetmetal_data.h:1264
svxSmdExtendFlangeData
template command Smd Extend Flange data
Definition: zwapi_cmd_sheetmetal_data.h:817
svxSmdExtrudeTabData
template command Smd Extrude Tab data
Definition: zwapi_cmd_sheetmetal_data.h:202
svxSmdFlangeData
template command Smd Flange data
Definition: zwapi_cmd_sheetmetal_data.h:257
svxSmdFlangeProfData
template command Smd Flange with Profile data
Definition: zwapi_cmd_sheetmetal_data.h:417
svxSmdFlattenData
template command Smd flatten data
Definition: zwapi_cmd_sheetmetal_data.h:1208
svxSmdFoldByLineData
template command Smd Fold by Line data
Definition: zwapi_cmd_sheetmetal_data.h:752
svxSmdFullFlangeData
template command Smd Full Flange data
Definition: zwapi_cmd_sheetmetal_data.h:354
svxSmdHemFlangeData
template command Smd Hem Flange data
Definition: zwapi_cmd_sheetmetal_data.h:502
svxSmdJogData
template command Smd Jog data
Definition: zwapi_cmd_sheetmetal_data.h:770
svxSmdLinearUnfoldData
template command Smd linear unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1231
svxSmdLoftedFlangeData
template command Smd Lofted Flange data
Definition: zwapi_cmd_sheetmetal_data.h:600
svxSmdMarkBendData
template command Smd mark bend data
Definition: zwapi_cmd_sheetmetal_data.h:1323
svxSmdPartialFlangeData
template command Smd Partial Flange data
Definition: zwapi_cmd_sheetmetal_data.h:449
svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.
Definition: zwapi_cmd_sheetmetal_data.h:164
svxSmdRipData
template command Smd rip data
Definition: zwapi_cmd_sheetmetal_data.h:1311
svxSmdSweptFlangeData
template command Smd Swept Flange data
Definition: zwapi_cmd_sheetmetal_data.h:669
svxUnfoldData
template command Smd Unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1194
zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SHEET_METAL_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sheetmetal_data.h
evxCornerOverlapTyp
evxCornerOverlapTyp
evxCornerReliefTyp
evxCornerReliefTyp
evxDimplePostion
evxDimplePostion
evxExtFlangeType
evxExtFlangeType
evxExtrudeType
evxExtrudeType
evxNormCutTyp
evxNormCutTyp
evxPunchLocType
evxPunchLocType
evxPunchTyp
evxPunchTyp
evxSmdBendLengthType
evxSmdBendLengthType
evxSmdBendType
evxSmdBendType
evxSmdCalCustom
evxSmdCalCustom
evxSmdChangeBendType
evxSmdChangeBendType
evxSmdCornerRelief
evxSmdCornerRelief
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
evxSmdExtendSideMethod
evxSmdExtendSideMethod
evxSmdHemBendType
evxSmdHemBendType
evxSmdJogPosition
evxSmdJogPosition
evxSmdKFactorType
evxSmdKFactorType
evxSmdLftCutMethod
evxSmdLftCutMethod
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
evxSmdPosition
evxSmdPosition
evxSmdRelief
evxSmdRelief
evxSmdReliefLengthType
evxSmdReliefLengthType
evxSmdRipType
evxSmdRipType
evxSmdTaperSideMethod
evxSmdTaperSideMethod
evxSmdWebTaperType
evxSmdWebTaperType
svxCloseCornerData
svxDimpleData
svxExtrudeFlangeData
svxFoldData
svxLouverData
svxNormalCutData
svxPunchCons
svxPunchData
svxSmdAt
svxSmdBendTaperData
svxSmdBendTaperDefData
svxSmdChangeBendData
svxSmdExtendFlangeData
svxSmdExtrudeTabData
svxSmdFlangeData
svxSmdFlangeProfData
svxSmdFlattenData
svxSmdFoldByLineData
svxSmdFullFlangeData
svxSmdHemFlangeData
svxSmdJogData
svxSmdLinearUnfoldData
svxSmdLoftedFlangeData
svxSmdMarkBendData
svxSmdPartialFlangeData
svxSmdReliefData
svxSmdRipData
svxSmdSweptFlangeData
svxUnfoldData

◆ ZW_API_SHEET_METAL_FTR_DATA_H

#define ZW_API_SHEET_METAL_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_sheetmetal_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sheetmetal_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sheetmetal_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SHEET_METAL_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_SHEET_METAL_FTR_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxSmdPosition
33 {
34 VX_POSITION_MATERIAL_INSIDE,
35 VX_POSITION_MATERIAL_OUTSIDE,
36 VX_POSITION_NATURAL,
37 VX_POSITION_OFFSET,
38 VX_POSITION_VIRTUAL_SHARP,
39 }evxSmdPosition;
40
45typedef enum evxSmdBendLengthType
46 {
47 VX_BEND_STANDARD_LENGTH,
48 VX_BEND_OUTER_HEIGHT,
49 VX_BEND_INNER_HEIGHT,
50 VX_BEND_EXTRAPOLATED_LENGTH,
51 }evxSmdBendLengthType;
52
57typedef enum evxSmdKFactorType
58 {
59 VX_SMD_KTYPE_CUSTOM,
60 VX_SMD_KTYPE_FROM_MATERIAL,
61 VX_SMD_KTYPE_BEND_TABLE,
62 VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE,
63 VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA,
64 VX_SMD_KTYPE_BEND_DEDUCTION_TABLE,
65 VX_SMD_KTYPE_BEND_DEDUCTIOIN,
66 VX_SMD_KTYPE_BEND_ALLOWANCE,
67 } evxSmdKFactorType;
68
73typedef enum evxSmdRelief
74 {
75 VX_RELIEF_RECTANGLE = 0,
76 VX_RELIEF_OBROUND = 1,
77 VX_RELIEF_NONE = 2,
78 VX_RELIEF_STRETCH = 3,
79 }evxSmdRelief;
80
85typedef enum evxSmdCornerRelief
86 {
87 VX_CORNER_RELIEF_CLOSED,
88 VX_CORNER_RELIEF_CIRCULAR_CUTOUT,
89 VX_CORNER_RELIEF_RECTANGULAR_CUTOUT,
90 VX_CORNER_RELIEF_U_CUTOUT,
91 VX_CORNER_RELIEF_V_CUTOUT,
92 } evxSmdCornerRelief;
93
98typedef struct svxSmdAt
99 {
100 /* Global Value */
101 double dThick;
102 double dRadius;
103 /* Flange Parameters */
104 evxSmdPosition position;
105 double dOffset;
106 evxSmdBendLengthType lengthType;
107 double dLength;
108 /* K-factor */
109 evxSmdKFactorType kType;
110 double dKFactor;
111 double dKBendDed;
112 double dKBendAllow;
113 /* Relief */
114 evxSmdRelief reliefType;
115 double dWidRatio;
116 double dWidValue;
117 double dDepRatio;
118 double dDepValue;
119 /* Corner Attributes */
120 int isCloseCorner;
121 int isMiter;
122 evxSmdCornerRelief reliefCorType;
123 double dCorGap;
124 int iCorOrigin;
125 double dCorOffset;
126 double dCorLength;
127 double dCorWidth;
128 double dCorDiameter;
129 double dCorAngle1;
130 double dCorAngle2;
131 /* setting */
132 double dFlatTol;
133 }svxSmdAt;
134
139typedef enum evxSmdCalCustom
140 {
141 VX_CUSTOM_RELIEF = 0x00000001,
142 VX_CUSTOM_ISWIDTHRATIO = 0x00000002,
143 VX_CUSTOM_RELIEFWIDTH = 0x00000004,
144 VX_CUSTOM_ISDEPTHRATIO = 0x00000008,
145 VX_CUSTOM_RELIEFDEPTH = 0x00000010,
146 } evxSmdCalCustom;
147
152typedef enum evxSmdReliefLengthType
153 {
154 VX_RELIEF_LENGTH_TYPE_TO_EDGE,
155 VX_RELIEF_LENGTH_TYPE_THROUGH_ALL,
156 VX_RELIEF_LENGTH_TYPE_VALUE
157 } evxSmdReliefLengthType;
158
163typedef struct svxSmdReliefData
164 {
165 int isCustom;
170 evxSmdRelief relief;
171 /* length */
172 int upToBend;
173 evxSmdReliefLengthType lengthType;
174 double lengthVal;
175 /* width */
176 int isWidthRatio;
177 double ReliefWidth;
178 /* depth */
179 int isDepthRatio;
180 double ReliefDepth;
181 }svxSmdReliefData;
182
183//====================================================================================================================
185//====================================================================================================================
190typedef enum evxExtFlangeType
191 {
192 VX_EXTFLANGE_1SIDE,
193 VX_EXTFLANGE_2SIDES,
194 VX_EXTFLANGE_SYMMETRICAL,
195 } evxExtFlangeType;
196
201typedef struct svxSmdExtrudeTabData
202 {
203 int idProfile;
204 double* Thickness;
205 int isMerge;
206 int isOpposite;
207 int idMergeShape;
210 } svxSmdExtrudeTabData;
211
216typedef struct svxExtrudeFlangeData
217 {
218 int idProfile;
219 evxExtFlangeType extType;
220 double start;
221 double end;
222 double* thickness;
223 int isOpposite;
224 double* radius;
225 evxSmdKFactorType* kType;
228 double* kValue;
229 svxPntOnEnt* PntOnCrv;
230 double RipSize;
231 } svxExtrudeFlangeData;
232
237typedef enum evxSmdBendType
238 {
239 VX_BEND_SIMPLE = 0,
240 VX_BEND_S_BEND = 1,
241 VX_BEND_CLOSED = 5,
242 VX_BEND_OPEN = 6,
243 VX_BEND_JOGGLE = 4,
244 VX_BEND_CURL = 2,
245 VX_BEND_Z_BEND = 7,
246 VX_BEND_CLOSED_LOOP = 8,
247 VX_BEND_OPEN_LOOP = 9,
248 VX_BEND_CENTERED_LOOP = 10,
249 VX_BEND_USER_DEFINED = 11
250 } evxSmdBendType;
251
256typedef struct svxSmdFlangeData
257 {
258 /* Required */
259 int count;
260 int* idEdges;
261 int widthType;
262 double start;
263 double end;
264 double length;
265 int isFlip;
266 /* Flange Parameters */
267 evxSmdPosition position;
268 double positionOffset;
269 /* Bend Attributes */
270 /*
271 evxSmdBendType | the following variables is valid
272 VX_BEND_SIMPLE | radius1, length1, angle, lengthType
273 VX_BEND_S_BEND | radius1, radius2(isEqualR), length1, length2, height, lengthType, sBendSize,
274 VX_BEND_CLOSED | length1
275 VX_BEND_OPEN | radius1, length1
276 VX_BEND_JOGGLE | length1, length2
277 VX_BEND_CURL | radius1, radius2, length1, length2
278 VX_BEND_Z_BEND | radius1, radius2(isEqualR), length1, length2
279 VX_BEND_CLOSED_LOOP | radius1, length1
280 VX_BEND_OPEN_LOOP | radius1, angle
281 VX_BEND_CENTERED_LOOP | radius1, radius2(isEqualR), angle
282 VX_BEND_USER_DEFINED | radius1, idProfile
283 */
284 evxSmdBendType bendType;
285 double radius1;
286 double radius2;
287 double length1;
288 double length2;
289 double angle;
290 double height;
291 evxSmdBendLengthType lengthType;
292 int sBendSize;
293 int isEqualR;
294 int isTrim;
295 int idProfile;
296 /* K-factor Definition */
297 /*
298 evxSmdKFactorType | kValue
299 VX_SMD_KTYPE_CUSTOM | VsSmdAt.k_factor
300 VX_SMD_KTYPE_BEND_DEDUCTIOIN | VsSmdAt.d_k_bend_ded
301 VX_SMD_KTYPE_BEND_ALLOWANCE | VsSmdAt.d_k_bend_allow
302 others | 0
303 */
304 evxSmdKFactorType kType;
307 double kValue;
308 /* Relief */
309 int isRelief;
310 int isDefine;
312 svxSmdReliefData startRelief;
313 svxSmdReliefData endRelief;
314 /* Flange Interface */
315 int isResolve;
316 double interfaceGap;
317 double interfaceOffset;
318 int interfaceType;
319 /* Corner Attributes */
320 /*
321 evxSmdCornerRelief | the following variables is valid
322 VX_CORNER_RELIEF_CLOSED | isMiter, corGap
323 VX_CORNER_RELIEF_CIRCULAR_CUTOUT | isMiter, corGap, corOrigin, corOffset, corDiameter
324 VX_CORNER_RELIEF_RECTANGULAR_CUTOUT | isMiter, corGap, corOrigin, corOffset, corLength, corWidth
325 VX_CORNER_RELIEF_U_CUTOUT | isMiter, corGap, corOrigin, corOffset, corDiameter
326 VX_CORNER_RELIEF_V_CUTOUT | isMiter, corGap, corOrigin, corOffset, corDiameter, corAngle1, corAngle2
327 */
328 int isCorner;
329 int isMiter;
332 evxSmdCornerRelief corRelief;
333 double corGap;
334 int corOrigin;
335 double corOffset;
336 double corLength;
337 double corWidth;
338 double corDiameter;
339 double corAngle1;
340 double corAngle2;
341 /* Settings */
342 double tol;
344 } svxSmdFlangeData;
345
346//====================================================================================================================
348//====================================================================================================================
353typedef struct svxSmdFullFlangeData
354 {
355 int count;
356 int* idEdges;
357 int isFlip;
358 evxSmdPosition* position;
359 double* offset;
360 evxSmdKFactorType* kType;
363 double* kValue;
364 double* tol;
366 int isResolve;
368 double gap;
369 /* Bend Attributes */
370 int bend;
371 double* radius1;
372 double angle;
373 evxSmdBendLengthType* lengthType;
374 double* length;
375 double* radius2;
376 int sBendSize;
377 double Size;
378 /* Relief */
379 int isDefSepa;
380 svxSmdReliefData* startRelief;
381 svxSmdReliefData* endRelief;
382 /* Corner Attributes */
383
395 evxSmdCornerRelief* corRelief;
396 int* isCorner;
399 int* isMiter;
402 double* corGap;
403 int* corOrigin;
404 double* corOffset;
405 double* corLength;
406 double* corWidth;
407 double* corDiameter;
408 double* corAngle1;
409 double* corAngle2;
410 }svxSmdFullFlangeData;
411
416typedef struct svxSmdFlangeProfData
417 {
418 int idEdge;
419 int* idProfile;
420 evxSmdPosition* position;
421 double* offset;
423 /* Bend Attributes */
424 double* radius;
425 double angle;
426 evxSmdBendLengthType* lengthType;
427 double* length;
428 /* K-factor Definition */
429 evxSmdKFactorType* kType;
432 double* kValue;
433 /* Relief */
434 int isRelief;
437 int isDefSepa;
438 svxSmdReliefData* startRelief;
439 svxSmdReliefData* endRelief;
441 double* tol;
442 } svxSmdFlangeProfData;
443
448typedef struct svxSmdPartialFlangeData
449 {
450 int idEdge;
451 int isRevert;
452 int isFlip;
453 int widthType;
454 double start;
455 double end;
456 double width;
457 evxSmdPosition* position;
458 double* offset;
459 /* Bend Attributes */
460 int bend;
461 double* radius1;
462 double angle;
463 evxSmdBendLengthType* lengthType;
464 double* length;
465 double* radius2;
466 int sBendSize;
467 double Size;
468 /* K-factor Definition */
469 evxSmdKFactorType* kType;
472 double* kValue;
473 /* Relief */
474 int isRelief;
475 int isDefSepa;
476 svxSmdReliefData* startRelief;
477 svxSmdReliefData* endRelief;
479 double* tol;
480 } svxSmdPartialFlangeData;
481
486typedef enum evxSmdHemBendType
487 {
488 VX_SMD_HEM_BEND_CLOSED,
489 VX_SMD_HEM_BEND_OPEN,
490 VX_SMD_HEM_BEND_CLOSEDLOOP,
491 VX_SMD_HEM_BEND_OPENLOOP,
492 VX_SMD_HEM_BEND_CENTEREDLOOP,
493 VX_SMD_HEM_BEND_SBEND,
494 VX_SMD_HEM_BEND_CURL,
495 } evxSmdHemBendType;
496
501typedef struct svxSmdHemFlangeData
502 {
503 int hemType;
504 int isFlip;
505 union uvxSmdHemData
506 {
507 struct svxSmdFullHemData
508 {
509 int count;
510 int* idEdges;
511 /* Miter */
512 int isMiterHem;
513 double gapSize;
514 } full;
515 struct svxSmdPartHemData
516 {
517 int idEdge;
518 int widthType;
519 double start;
520 double end;
521 double width;
522 int isRelief;
524 svxPntOnEnt* startPnt;
525 svxPntOnEnt* endPnt;
526 svxPntOnEnt* widthPnt;
527 }partial;
528 } hemData;
529
530 evxSmdPosition* position;
531 double* offset;
545 evxSmdHemBendType bendType;
546 int isEqual;
547 double length1;
548 double length2;
549 double* radius1;
550 double* radius2;
551 double angle;
552 /* K-factor Definition */
553 evxSmdKFactorType* kType;
556 double* kValue;
557 /* Relief */
558 int isDefSepa;
559 svxSmdReliefData* startRelief;
560 svxSmdReliefData* endRelief;
561 } svxSmdHemFlangeData;
562
567typedef enum evxSmdLftFlangeMethod
568 {
569 VX_SMD_GENERAL_LOFTING,
570 VX_SMD_FLATTENABLE_LOFTING,
571 VX_SMD_BENDING_LOFTING,
574 } evxSmdLftFlangeMethod;
575
580typedef enum evxSmdLftCutMethod
581 {
582 VX_SMD_LFG_MAX_ARC_HEIGHT,
585 VX_SMD_LFG_NUMBER_BEND,
587 VX_SMD_LFG_MAX_CHORD_LENGTH,
590 VX_SMD_LFG_MAX_ARC_CHORD_ANGLE,
593 } evxSmdLftCutMethod;
594
599typedef struct svxSmdLoftedFlangeData
600 {
601 evxSmdLftFlangeMethod method;
602 double thickness;
604 int isOpposite;
605 double radius;
606 union uvxLftFlange
607 {
608 struct svxSmdLftGeneral
609 {
610 int count1;
611 int* listLines1;
612 int flip1;
614 int count2;
615 int* listLines2;
616 int flip2;
618 int cntShps;
619 int* boolShps;
620 svxLoftBndCons bndCons[2];
621 int scale;
624 } general;
625 struct svxSmdLftFlat
626 {
627 int idProf1;
628 int flip1;
629 svxPntOnEnt cutPnt1;
632 int idProf2;
633 int flip2;
634 svxPntOnEnt cutPnt2;
637 double cutLength;
638 int isUseGlobal;
639 evxSmdKFactorType kType;
640 double kValue;
641 } flattenable;
642 struct svxSmdLftBend
643 {
644 int idProf1;
645 int flip1;
646 svxPntOnEnt cutPnt1;
649 int idProf2;
650 int flip2;
651 svxPntOnEnt cutPnt2;
654 double cutLength;
655 evxSmdLftCutMethod cutMethod;
656 double cutValue;
657 int isUseGlobal;
658 evxSmdKFactorType kType;
659 double kValue;
660 } bending;
661 }inpUnion;
662 } svxSmdLoftedFlangeData;
663
668typedef struct svxSmdSweptFlangeData
669 {
670 int idFace;
671 int idProfile;
672 int count;
673 int* sweptPath;
677 evxSmdPosition position;
680 double offset;
681 double radius;
682 int keepMerged;
684 int isUseGlobal;
685 evxSmdKFactorType kType;
686 double kValue;
688 evxSmdCornerRelief relief;
689 int miterCorner;
690 union uvxSmdSweptFlange
691 {
692 struct svxSmdReliefClosed
693 {
694 double gap;
695 } closed;
696
697 struct svxSmdReliefCircular
698 {
699 double gap;
700 int origin;
701 double offset;
702 double diameter;
703 } circular;
704
705 struct svxSmdReliefRectangular
706 {
707 double gap;
708 int origin;
709 double offset;
710 double length;
711 double width;
712 } rectangular;
713
714 struct svxSmdReliefUCutout
715 {
716 double gap;
717 int origin;
718 double offset;
719 double diameter;
720 } uCutout;
721
722 struct svxSmdReliefVCutout
723 {
724 double gap;
725 int origin;
726 double offset;
727 double diameter;
728 double angle1;
729 double angle2;
730 } vCutout;
731 }inpUnion;
732 } svxSmdSweptFlangeData;
733
738typedef enum evxSmdJogPosition
739 {
740 VX_SMD_JOG_OUTER,
741 VX_SMD_JOG_INNER,
742 VX_SMD_JOG_MIDDLE,
743 VX_SMD_JOG_MATERIAL_INSIDE,
744 VX_SMD_JOG_MATERIAL_OUTSIDE,
745 } evxSmdJogPosition;
746
751typedef struct svxSmdFoldByLineData
752 {
753 int idLine;
754 int idProfile;
755 int idFace;
756 int flipSide;
757 evxSmdJogPosition position;
758 double angle;
759 double radius;
760 int isUseGlobal;
761 evxSmdKFactorType kType;
762 double kValue;
763 } svxSmdFoldByLineData;
764
769typedef struct svxSmdJogData
770 {
771 int idLine;
772 int idFace;
773 int reverseSide;
774 int heightType;
779 double height;
780 int keepProjLen;
781 evxSmdJogPosition position;
782 double radius;
783 int isUseGlobal;
784 evxSmdKFactorType kType;
785 double kValue;
786 } svxSmdJogData;
787
788//====================================================================================================================
790//====================================================================================================================
795typedef enum evxSmdExtendFlangeMethod
796 {
797 VX_SMD_EXTEND_BY_VALUE,
798 VX_SMD_EXTEND_THROUGH_UNTIL,
799 VX_SMD_EXTEND_TO_SELECTED,
800 } evxSmdExtendFlangeMethod;
801
806typedef enum evxSmdExtendSideMethod
807 {
808 VX_SMD_EXTEND_SIDE_NORMAL,
809 VX_SMD_EXTEND_SIDE_ALONG,
810 } evxSmdExtendSideMethod;
811
816typedef struct svxSmdExtendFlangeData
817 {
818 evxSmdExtendFlangeMethod type;
819 int idEdge;
820 union uvxExtFlangeData
821 {
822 double distance;
826 struct svxExtFlangeData
827 {
828 int idPlane;
829 double offset;
831 } nonByValue;
832 } inpUnion;
833
834 evxSmdExtendSideMethod sideType1;
836 int extendSrfToEdge1;
837 evxSmdExtendSideMethod sideType2;
839 int extendSrfToEdge2;
840 } svxSmdExtendFlangeData;
841
846typedef enum evxSmdWebTaperType
847 {
848 VX_SMD_TAPER_WEB_NONE,
849 VX_SMD_TAPER_WEB_FACE,
852 VX_SMD_TAPER_WEB_FACE_CHAIN,
854 } evxSmdWebTaperType;
855
860typedef struct svxSmdBendTaperDefData
861 {
862 int taperType;
865 union uvxSmdTaperDefInfos
866 {
867 struct svxSmdLinear
868 {
869 int method;
872 double value;
873 } linear;
874 struct svxSmdTangent
875 {
876 double setback;
877 int isAutoCompute;
878 double sRadius;
879 double eRadius;
880 } tangent;
881 } inpUnion;
882
883 evxSmdWebTaperType webTaperType;
884 double angle;
885 } svxSmdBendTaperDefData;
886
891typedef enum evxSmdTaperSideMethod
892 {
893 VX_SMD_TAPER_SIDES_BOTH,
894 VX_SMD_TAPER_SIDES_SIDE1,
895 VX_SMD_TAPER_SIDES_SIDE2,
896 VX_SMD_TAPER_SIDES_SYMMETRY,
897 } evxSmdTaperSideMethod;
898
903typedef struct svxSmdBendTaperData
904 {
905 int idBend;
907 int opposite;
908 evxSmdTaperSideMethod method;
909 svxSmdBendTaperDefData defData;
910 svxSmdBendTaperDefData defData2;
911 } svxSmdBendTaperData;
912
917typedef enum evxExtrudeType
918 {
919 VX_EXTRUDE_TYPE_ONESIDE = 0,
920 VX_EXTRUDE_TYPE_TWOSIDE = 1,
921 VX_EXTRUDE_TYPE_SYMMETRICAL,
922 }evxExtrudeType;
923
928typedef enum evxNormCutTyp
929 {
930 VX_NORMCUT_BOTHSIDES = 0,
931 VX_NORMCUT_MIDDLE = 1,
932 }evxNormCutTyp;
933
938typedef struct svxNormalCutData
939 {
940 evxNormCutTyp cutType;
941 int idProfile;
942 int cntShape;
943 int* shapeList;
944 evxExtrudeType extType;
945 double dStart;
946 double dEnd;
947 svxVector* Dir;
948 int Flip;
950 evxDistanceMethod startType;
951 evxDistanceMethod endType;
952 int idStartEnt;
953 int idEndEnt;
954 svxPoint* startToPnt;
955 svxPoint* endToPnt;
956 }svxNormalCutData;
957
958//====================================================================================================================
960//====================================================================================================================
965typedef enum evxCornerReliefTyp
966 {
967 VX_CORNER_CLOSED = 0,
968 VX_CORNER_CIRCL_CUTOUT,
969 VX_CORNER_RECT_CUTOUT,
970 VX_CORNER_U_CUTOUT,
971 VX_CORNER_V_CUTOUT,
972 }evxCornerReliefTyp;
973
978typedef enum evxCornerOverlapTyp
979 {
980 VX_CORNER_UNDERLAP = 0,
981 VX_CORNER_OVERLAP,
982 VX_CONER_NATURAL,
983 }evxCornerOverlapTyp;
984
989typedef struct svxCloseCornerData
990 {
991 int type;
992 union CornerData
993 {
994 struct svxByEdge
995 {
996 svxPntOnEnt Edg1Pnt;
997 svxPntOnEnt Edg2Pnt;
998 } byEdge;
999
1000 struct svxByFace
1001 {
1002 int idBend1;
1003 int idBend2;
1004 int CloseFlange;
1007 int Miter;
1010 evxCornerReliefTyp Relief;
1011 int OrgType;
1012 double dOffset;
1013 double dDiam;
1014 double dLength;
1015 double dWidth;
1016 double dAng1;
1017 double dAng2;
1018 }byFace;
1019 } cornerData;
1020
1021 evxCornerOverlapTyp Overlp;
1022 double dGap;
1023 }svxCloseCornerData;
1024
1025//====================================================================================================================
1027//====================================================================================================================
1032typedef enum evxPunchTyp
1033 {
1034 VX_PUNCH_SHAPE = 0,
1035 VX_PUNCH_FILE = 1,
1036 }evxPunchTyp;
1037
1042typedef enum evxPunchLocType
1043 {
1044 VX_LOCATION_POINT = 0,
1045 VX_LOCATION_CONSTRAINT = 1,
1046 }evxPunchLocType;
1047
1052typedef struct svxPunchCons
1053 {
1054 evxConsType alignTyp;
1055 /* note: one of entities must form the insert punch file */
1056 svxEntPath pathEnt1;
1057 int ent1FormFile;
1058 svxEntPath pathEnt2;
1059 int ent2FormFile;
1060 /* The following parameter is used when alignTyp = VX_COINCIDENT/VX_TANGENT */
1061 double dOffset;
1062 /* The following parameter is used when alignTyp = VX_GEAR */
1063 double dAng;
1064 /* The following parameter is used when alignTyp ! VX_ADV_FRAME/ */
1065 int Flip;
1066 }svxPunchCons;
1067
1072typedef struct svxPunchData
1073 {
1074 evxPunchTyp punchTyp;
1075 int idBase;
1076 int cntOpen;
1077 int* pOpenList;
1079 int addFillet;
1081 double dRadius;
1082 int addFillet2;
1083 double dRadius2;
1084 /* The following parameters are used when punchTyp = VX_PUNCH_SHAPE */
1085 int idPunch;
1086 /* The following parameters are used when punchTyp = VX_PUNCH_FILE */
1087 vxLongPath pathPunch;
1088 evxPunchLocType locTyp;
1089 svxPoint localPnt;
1090 int relation;
1093 union LocData
1094 {
1095 struct ByPnt
1096 {
1097 int idFrame;
1098 }byPnt;
1099
1100 struct ByCons
1101 {
1102 int cntCons;
1103 svxPunchCons* punchCons;
1104 }byCons;
1105 }locData;
1106 }svxPunchData;
1107
1112typedef enum evxDimplePostion
1113 {
1114 VX_MATERIAL_OUTSIDE = 0,
1115 VX_MATERIAL_INSIDE,
1116 VX_BEND_OUTSIDE,
1117 } evxDimplePostion;
1118
1123typedef struct svxDimpleData
1124 {
1125 int dimpleType;
1126 int idPlane;
1127 int idProfile;
1130 int notSew;
1132 int numShapes;
1133 int* idShapes;
1135 double height;
1136 double angle;
1137 double radius1;
1138 double radius2;
1139 double radius3;
1142 int flipFlange;
1143 int prfOnDimpleTop;
1146 evxDimplePostion postion;
1149 vxName ftrName;
1150 } svxDimpleData;
1151
1156typedef struct svxLouverData
1157 {
1158 int idPlane;
1159 int idProf;
1160 double dHeight;
1161 double dAng;
1162 double dR1;
1163 double dR2;
1164 double dWidth;
1165 int Flip;
1166 int notSew;
1168 int cntSew;
1169 int* pSewShape;
1170 }svxLouverData;
1171
1172//====================================================================================================================
1174//====================================================================================================================
1179typedef struct svxFoldData
1180 {
1181 int idShape;
1182 int idStationary;
1183 int BendFaceCnts;
1184 int* idBendFace;
1185 int CrvCnts;
1186 int* idCrv;
1187 } svxFoldData;
1188
1193typedef struct svxUnfoldData
1194 {
1195 int idShape;
1196 int idStationary;
1197 int BendFaceCnts;
1198 int* idBendFace;
1199 int CrvCnts;
1200 int* idCrv;
1201 } svxUnfoldData;
1202
1207typedef struct svxSmdFlattenData
1208 {
1209 int idShape;
1210 int idFace;
1211 double offset;
1212 int useDir;
1213 svxVector direction;
1214 int includePattern;
1218 int ignoreTangent;
1222 int useDirPMI;
1223 svxVector dirPMI;
1224 } svxSmdFlattenData;
1225
1230typedef struct svxSmdLinearUnfoldData
1231 {
1232 int idFace;
1233 int cnt;
1234 int* bendFcs;
1235 double angle;
1237 int isUseGlobal;
1238 evxSmdKFactorType kType;
1239 double kValue;
1241 int addStatus;
1242 svxVector dir;
1243 double distance;
1244 } svxSmdLinearUnfoldData;
1245
1250typedef enum evxSmdChangeBendType
1251 {
1252 VX_SMD_CHANGE_BEND_DEFAULT,
1253 VX_SMD_CHANGE_BEND_FOLD_LENGTH,
1256 VX_SMD_CHANGE_BEND_UNFOLD_LENGTH,
1257 } evxSmdChangeBendType;
1258
1263typedef struct svxSmdChangeBendData
1264 {
1265 evxSmdChangeBendType type;
1266 int cnt;
1267 int* bendFcs;
1268 double radius;
1269 union uvxSmdChangeBend
1270 {
1271 struct svxChangeBendDefault
1272 {
1273 double angle;
1274 int isUseGlobal;
1275 evxSmdKFactorType kType;
1276 double kValue;
1277 } defaultInfo;
1278 struct svxChangeBendFold
1279 {
1280 int isUseGlobal;
1281 evxSmdKFactorType kType;
1282 double kValue;
1283 } fold;
1284 struct svxChangeBendUnfold
1285 {
1286 int stationary;
1287 double angle;
1288 } unfold;
1289 } inpUnion;
1290 } svxSmdChangeBendData;
1291
1292//====================================================================================================================
1294//====================================================================================================================
1299typedef enum evxSmdRipType
1300 {
1301 VX_SMD_RIP_BOTH_SIDES,
1302 VX_SMD_RIP_LEFT_SIDE,
1303 VX_SMD_RIP_RIGHT_SIDE,
1304 } evxSmdRipType;
1305
1310typedef struct svxSmdRipData
1311 {
1312 evxSmdRipType type;
1313 int cnt;
1314 int* ids;
1315 double gap;
1316 } svxSmdRipData;
1317
1322typedef struct svxSmdMarkBendData
1323 {
1324 int idFace;
1325 int cnt;
1326 int* bendFcs;
1328 int isUseGlobal;
1329 evxSmdKFactorType kType;
1330 double kValue;
1331 double thickness;
1332 double flatTol;
1333 } svxSmdMarkBendData;
1334
1335/*
1336*********************************************************************
1337** END HEADER FILE
1338*********************************************************************
1339*/
1340#ifdef __cplusplus
1341 }
1342#endif /* __cplusplus */
1343
1344#endif /* ZW_API_SHEET_METAL_FTR_DATA_H */
evxConsType
evxConsType
assembly constraint type
Definition: zwapi_cmd_assembly_data.h:193
evxSmdBendType
evxSmdBendType
Smd Bend Type of Flange.
Definition: zwapi_cmd_sheetmetal_data.h:238
VX_BEND_Z_BEND
@ VX_BEND_Z_BEND
Z bend.
Definition: zwapi_cmd_sheetmetal_data.h:245
VX_BEND_CLOSED_LOOP
@ VX_BEND_CLOSED_LOOP
Closed loop.
Definition: zwapi_cmd_sheetmetal_data.h:246
VX_BEND_S_BEND
@ VX_BEND_S_BEND
S bend.
Definition: zwapi_cmd_sheetmetal_data.h:240
VX_BEND_CLOSED
@ VX_BEND_CLOSED
Closed.
Definition: zwapi_cmd_sheetmetal_data.h:241
VX_BEND_SIMPLE
@ VX_BEND_SIMPLE
Simple.
Definition: zwapi_cmd_sheetmetal_data.h:239
VX_BEND_JOGGLE
@ VX_BEND_JOGGLE
Joggle.
Definition: zwapi_cmd_sheetmetal_data.h:243
VX_BEND_OPEN_LOOP
@ VX_BEND_OPEN_LOOP
Open loop.
Definition: zwapi_cmd_sheetmetal_data.h:247
VX_BEND_OPEN
@ VX_BEND_OPEN
Open.
Definition: zwapi_cmd_sheetmetal_data.h:242
VX_BEND_CENTERED_LOOP
@ VX_BEND_CENTERED_LOOP
Centered loop.
Definition: zwapi_cmd_sheetmetal_data.h:248
VX_BEND_USER_DEFINED
@ VX_BEND_USER_DEFINED
user defined
Definition: zwapi_cmd_sheetmetal_data.h:249
VX_BEND_CURL
@ VX_BEND_CURL
Curl.
Definition: zwapi_cmd_sheetmetal_data.h:244
evxSmdTaperSideMethod
evxSmdTaperSideMethod
smd bend taper sides
Definition: zwapi_cmd_sheetmetal_data.h:892
VX_SMD_TAPER_SIDES_SIDE2
@ VX_SMD_TAPER_SIDES_SIDE2
Tapers the second side of the flange. You can see a preview of the result.
Definition: zwapi_cmd_sheetmetal_data.h:895
VX_SMD_TAPER_SIDES_SYMMETRY
@ VX_SMD_TAPER_SIDES_SYMMETRY
Tapers both sides equally of the flange.
Definition: zwapi_cmd_sheetmetal_data.h:896
VX_SMD_TAPER_SIDES_SIDE1
@ VX_SMD_TAPER_SIDES_SIDE1
Tapers the first side of the flange. You can see a preview of the result.
Definition: zwapi_cmd_sheetmetal_data.h:894
VX_SMD_TAPER_SIDES_BOTH
@ VX_SMD_TAPER_SIDES_BOTH
Tapers both sides of the flange. You can set different values for each side.
Definition: zwapi_cmd_sheetmetal_data.h:893
evxNormCutTyp
evxNormCutTyp
Normal Cut command.
Definition: zwapi_cmd_sheetmetal_data.h:929
VX_NORMCUT_MIDDLE
@ VX_NORMCUT_MIDDLE
Normal to Middle.
Definition: zwapi_cmd_sheetmetal_data.h:931
VX_NORMCUT_BOTHSIDES
@ VX_NORMCUT_BOTHSIDES
Normal to Both Sides.
Definition: zwapi_cmd_sheetmetal_data.h:930
evxDimplePostion
evxDimplePostion
dimple position type
Definition: zwapi_cmd_sheetmetal_data.h:1113
VX_MATERIAL_OUTSIDE
@ VX_MATERIAL_OUTSIDE
material outside: set the dimple outside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1114
VX_BEND_OUTSIDE
@ VX_BEND_OUTSIDE
bend outside: set the dimple outside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1116
VX_MATERIAL_INSIDE
@ VX_MATERIAL_INSIDE
material inside: set the dimple inside the sketch
Definition: zwapi_cmd_sheetmetal_data.h:1115
evxSmdCalCustom
evxSmdCalCustom
the enumeration is used to determine whether the values in the "svxSmdReliefData" are custom
Definition: zwapi_cmd_sheetmetal_data.h:140
VX_CUSTOM_ISWIDTHRATIO
@ VX_CUSTOM_ISWIDTHRATIO
"isWidthRatio" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:142
VX_CUSTOM_RELIEFDEPTH
@ VX_CUSTOM_RELIEFDEPTH
"ReliefDepth" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:145
VX_CUSTOM_RELIEFWIDTH
@ VX_CUSTOM_RELIEFWIDTH
"ReliefWidth" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:143
VX_CUSTOM_ISDEPTHRATIO
@ VX_CUSTOM_ISDEPTHRATIO
"isDepthRatio" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:144
VX_CUSTOM_RELIEF
@ VX_CUSTOM_RELIEF
"relief" is a custom value
Definition: zwapi_cmd_sheetmetal_data.h:141
evxSmdHemBendType
evxSmdHemBendType
Smd Bend Type of Hem Flange.
Definition: zwapi_cmd_sheetmetal_data.h:487
VX_SMD_HEM_BEND_CENTEREDLOOP
@ VX_SMD_HEM_BEND_CENTEREDLOOP
Centered loop.
Definition: zwapi_cmd_sheetmetal_data.h:492
VX_SMD_HEM_BEND_CLOSED
@ VX_SMD_HEM_BEND_CLOSED
Close.
Definition: zwapi_cmd_sheetmetal_data.h:488
VX_SMD_HEM_BEND_CLOSEDLOOP
@ VX_SMD_HEM_BEND_CLOSEDLOOP
Closed loop.
Definition: zwapi_cmd_sheetmetal_data.h:490
VX_SMD_HEM_BEND_OPENLOOP
@ VX_SMD_HEM_BEND_OPENLOOP
Open loop.
Definition: zwapi_cmd_sheetmetal_data.h:491
VX_SMD_HEM_BEND_SBEND
@ VX_SMD_HEM_BEND_SBEND
S bend.
Definition: zwapi_cmd_sheetmetal_data.h:493
VX_SMD_HEM_BEND_OPEN
@ VX_SMD_HEM_BEND_OPEN
Open.
Definition: zwapi_cmd_sheetmetal_data.h:489
VX_SMD_HEM_BEND_CURL
@ VX_SMD_HEM_BEND_CURL
Curl.
Definition: zwapi_cmd_sheetmetal_data.h:494
evxExtrudeType
evxExtrudeType
extrude type
Definition: zwapi_cmd_sheetmetal_data.h:918
VX_EXTRUDE_TYPE_ONESIDE
@ VX_EXTRUDE_TYPE_ONESIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:919
VX_EXTRUDE_TYPE_SYMMETRICAL
@ VX_EXTRUDE_TYPE_SYMMETRICAL
Symmetrical.
Definition: zwapi_cmd_sheetmetal_data.h:921
VX_EXTRUDE_TYPE_TWOSIDE
@ VX_EXTRUDE_TYPE_TWOSIDE
2 side
Definition: zwapi_cmd_sheetmetal_data.h:920
evxSmdLftFlangeMethod
evxSmdLftFlangeMethod
Lofted Flange method.
Definition: zwapi_cmd_sheetmetal_data.h:568
VX_SMD_FLATTENABLE_LOFTING
@ VX_SMD_FLATTENABLE_LOFTING
Open - loop contour and bending lofting.
Definition: zwapi_cmd_sheetmetal_data.h:570
VX_SMD_BENDING_LOFTING
@ VX_SMD_BENDING_LOFTING
The number of segments of the arc is controlled according to the maximum arc height,...
Definition: zwapi_cmd_sheetmetal_data.h:571
VX_SMD_GENERAL_LOFTING
@ VX_SMD_GENERAL_LOFTING
The surfaces generated are the same as those generated by solid lofting.
Definition: zwapi_cmd_sheetmetal_data.h:569
evxSmdCornerRelief
evxSmdCornerRelief
Smd Relief type of Corner Attributes.
Definition: zwapi_cmd_sheetmetal_data.h:86
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
@ VX_CORNER_RELIEF_RECTANGULAR_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:89
VX_CORNER_RELIEF_V_CUTOUT
@ VX_CORNER_RELIEF_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:91
VX_CORNER_RELIEF_U_CUTOUT
@ VX_CORNER_RELIEF_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:90
VX_CORNER_RELIEF_CIRCULAR_CUTOUT
@ VX_CORNER_RELIEF_CIRCULAR_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:88
VX_CORNER_RELIEF_CLOSED
@ VX_CORNER_RELIEF_CLOSED
closed
Definition: zwapi_cmd_sheetmetal_data.h:87
evxSmdRelief
evxSmdRelief
Smd Relief type.
Definition: zwapi_cmd_sheetmetal_data.h:74
VX_RELIEF_STRETCH
@ VX_RELIEF_STRETCH
Stretch.
Definition: zwapi_cmd_sheetmetal_data.h:78
VX_RELIEF_RECTANGLE
@ VX_RELIEF_RECTANGLE
Rectangle.
Definition: zwapi_cmd_sheetmetal_data.h:75
VX_RELIEF_OBROUND
@ VX_RELIEF_OBROUND
Obround.
Definition: zwapi_cmd_sheetmetal_data.h:76
VX_RELIEF_NONE
@ VX_RELIEF_NONE
None.
Definition: zwapi_cmd_sheetmetal_data.h:77
evxCornerReliefTyp
evxCornerReliefTyp
corner relief type
Definition: zwapi_cmd_sheetmetal_data.h:966
VX_CORNER_V_CUTOUT
@ VX_CORNER_V_CUTOUT
V cutout.
Definition: zwapi_cmd_sheetmetal_data.h:971
VX_CORNER_CLOSED
@ VX_CORNER_CLOSED
closed
Definition: zwapi_cmd_sheetmetal_data.h:967
VX_CORNER_U_CUTOUT
@ VX_CORNER_U_CUTOUT
U cutout.
Definition: zwapi_cmd_sheetmetal_data.h:970
VX_CORNER_RECT_CUTOUT
@ VX_CORNER_RECT_CUTOUT
rectangular cutout
Definition: zwapi_cmd_sheetmetal_data.h:969
VX_CORNER_CIRCL_CUTOUT
@ VX_CORNER_CIRCL_CUTOUT
circular cutout
Definition: zwapi_cmd_sheetmetal_data.h:968
evxSmdExtendFlangeMethod
evxSmdExtendFlangeMethod
extend flange method
Definition: zwapi_cmd_sheetmetal_data.h:796
VX_SMD_EXTEND_TO_SELECTED
@ VX_SMD_EXTEND_TO_SELECTED
Extends up to the plane.
Definition: zwapi_cmd_sheetmetal_data.h:799
VX_SMD_EXTEND_THROUGH_UNTIL
@ VX_SMD_EXTEND_THROUGH_UNTIL
Extends to intersect the plane.
Definition: zwapi_cmd_sheetmetal_data.h:798
VX_SMD_EXTEND_BY_VALUE
@ VX_SMD_EXTEND_BY_VALUE
Extends by a specfied value.
Definition: zwapi_cmd_sheetmetal_data.h:797
evxSmdRipType
evxSmdRipType
smd rip type
Definition: zwapi_cmd_sheetmetal_data.h:1300
VX_SMD_RIP_RIGHT_SIDE
@ VX_SMD_RIP_RIGHT_SIDE
right side
Definition: zwapi_cmd_sheetmetal_data.h:1303
VX_SMD_RIP_LEFT_SIDE
@ VX_SMD_RIP_LEFT_SIDE
left side
Definition: zwapi_cmd_sheetmetal_data.h:1302
VX_SMD_RIP_BOTH_SIDES
@ VX_SMD_RIP_BOTH_SIDES
two sides
Definition: zwapi_cmd_sheetmetal_data.h:1301
evxPunchLocType
evxPunchLocType
location type of punch command
Definition: zwapi_cmd_sheetmetal_data.h:1043
VX_LOCATION_CONSTRAINT
@ VX_LOCATION_CONSTRAINT
Constraint.
Definition: zwapi_cmd_sheetmetal_data.h:1045
VX_LOCATION_POINT
@ VX_LOCATION_POINT
Point.
Definition: zwapi_cmd_sheetmetal_data.h:1044
evxSmdJogPosition
evxSmdJogPosition
Smd Jog Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:739
VX_SMD_JOG_MIDDLE
@ VX_SMD_JOG_MIDDLE
The line stays in the middle of bend.
Definition: zwapi_cmd_sheetmetal_data.h:742
VX_SMD_JOG_OUTER
@ VX_SMD_JOG_OUTER
Bend is farther from stationary point than line.
Definition: zwapi_cmd_sheetmetal_data.h:740
VX_SMD_JOG_INNER
@ VX_SMD_JOG_INNER
Bend is close to stationary point than line.
Definition: zwapi_cmd_sheetmetal_data.h:741
VX_SMD_JOG_MATERIAL_OUTSIDE
@ VX_SMD_JOG_MATERIAL_OUTSIDE
In form state, fold line at the inside face of the fold region.
Definition: zwapi_cmd_sheetmetal_data.h:744
VX_SMD_JOG_MATERIAL_INSIDE
@ VX_SMD_JOG_MATERIAL_INSIDE
In form state, fold line at the outside face of the fold region.
Definition: zwapi_cmd_sheetmetal_data.h:743
evxSmdChangeBendType
evxSmdChangeBendType
change bend type
Definition: zwapi_cmd_sheetmetal_data.h:1251
VX_SMD_CHANGE_BEND_FOLD_LENGTH
@ VX_SMD_CHANGE_BEND_FOLD_LENGTH
Only bend radius of picked bends and geometries nearby will be changed keeping other dimensions of th...
Definition: zwapi_cmd_sheetmetal_data.h:1253
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
@ VX_SMD_CHANGE_BEND_UNFOLD_LENGTH
Both bend radius and angle can be changed keep the over all unfold length of the shape unchanged.
Definition: zwapi_cmd_sheetmetal_data.h:1256
VX_SMD_CHANGE_BEND_DEFAULT
@ VX_SMD_CHANGE_BEND_DEFAULT
Both bend radius and angle can be changed.
Definition: zwapi_cmd_sheetmetal_data.h:1252
evxSmdLftCutMethod
evxSmdLftCutMethod
Lofted Flange Cutting Method.
Definition: zwapi_cmd_sheetmetal_data.h:581
VX_SMD_LFG_MAX_CHORD_LENGTH
@ VX_SMD_LFG_MAX_CHORD_LENGTH
This method requires that the chord length of each arc/ellipse arc is equal (the chord length of diff...
Definition: zwapi_cmd_sheetmetal_data.h:587
VX_SMD_LFG_MAX_ARC_HEIGHT
@ VX_SMD_LFG_MAX_ARC_HEIGHT
This method requires that the arc/ellipse corresponding to each segment line of the graph arc have th...
Definition: zwapi_cmd_sheetmetal_data.h:582
VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
@ VX_SMD_LFG_MAX_ARC_CHORD_ANGLE
This method requires that the maximum Angle between the tangent vector of the two ends of the arc and...
Definition: zwapi_cmd_sheetmetal_data.h:590
VX_SMD_LFG_NUMBER_BEND
@ VX_SMD_LFG_NUMBER_BEND
The control value is the number of line segments in each arc/ellipse. It has no unit and is an intege...
Definition: zwapi_cmd_sheetmetal_data.h:585
evxSmdPosition
evxSmdPosition
Smd Flange Parameters Position.
Definition: zwapi_cmd_sheetmetal_data.h:33
VX_POSITION_MATERIAL_OUTSIDE
@ VX_POSITION_MATERIAL_OUTSIDE
Material outside.
Definition: zwapi_cmd_sheetmetal_data.h:35
VX_POSITION_VIRTUAL_SHARP
@ VX_POSITION_VIRTUAL_SHARP
Virtual sharp.
Definition: zwapi_cmd_sheetmetal_data.h:38
VX_POSITION_MATERIAL_INSIDE
@ VX_POSITION_MATERIAL_INSIDE
Material inside.
Definition: zwapi_cmd_sheetmetal_data.h:34
VX_POSITION_OFFSET
@ VX_POSITION_OFFSET
Offset.
Definition: zwapi_cmd_sheetmetal_data.h:37
VX_POSITION_NATURAL
@ VX_POSITION_NATURAL
Natural.
Definition: zwapi_cmd_sheetmetal_data.h:36
evxSmdReliefLengthType
evxSmdReliefLengthType
Smd Relief Length Type of Flange.
Definition: zwapi_cmd_sheetmetal_data.h:153
VX_RELIEF_LENGTH_TYPE_VALUE
@ VX_RELIEF_LENGTH_TYPE_VALUE
value
Definition: zwapi_cmd_sheetmetal_data.h:156
VX_RELIEF_LENGTH_TYPE_TO_EDGE
@ VX_RELIEF_LENGTH_TYPE_TO_EDGE
to edge
Definition: zwapi_cmd_sheetmetal_data.h:154
VX_RELIEF_LENGTH_TYPE_THROUGH_ALL
@ VX_RELIEF_LENGTH_TYPE_THROUGH_ALL
through all
Definition: zwapi_cmd_sheetmetal_data.h:155
evxCornerOverlapTyp
evxCornerOverlapTyp
corner overlap type
Definition: zwapi_cmd_sheetmetal_data.h:979
VX_CORNER_UNDERLAP
@ VX_CORNER_UNDERLAP
underlap
Definition: zwapi_cmd_sheetmetal_data.h:980
VX_CORNER_OVERLAP
@ VX_CORNER_OVERLAP
overlap
Definition: zwapi_cmd_sheetmetal_data.h:981
VX_CONER_NATURAL
@ VX_CONER_NATURAL
natural
Definition: zwapi_cmd_sheetmetal_data.h:982
evxSmdBendLengthType
evxSmdBendLengthType
Smd Bend Attributes Length type.
Definition: zwapi_cmd_sheetmetal_data.h:46
VX_BEND_STANDARD_LENGTH
@ VX_BEND_STANDARD_LENGTH
Standard length.
Definition: zwapi_cmd_sheetmetal_data.h:47
VX_BEND_INNER_HEIGHT
@ VX_BEND_INNER_HEIGHT
Inner height.
Definition: zwapi_cmd_sheetmetal_data.h:49
VX_BEND_OUTER_HEIGHT
@ VX_BEND_OUTER_HEIGHT
Outer height.
Definition: zwapi_cmd_sheetmetal_data.h:48
VX_BEND_EXTRAPOLATED_LENGTH
@ VX_BEND_EXTRAPOLATED_LENGTH
Extrapolated length.
Definition: zwapi_cmd_sheetmetal_data.h:50
evxSmdWebTaperType
evxSmdWebTaperType
smd bend web taper type
Definition: zwapi_cmd_sheetmetal_data.h:847
VX_SMD_TAPER_WEB_NONE
@ VX_SMD_TAPER_WEB_NONE
Tapers only the bend.
Definition: zwapi_cmd_sheetmetal_data.h:848
VX_SMD_TAPER_WEB_FACE
@ VX_SMD_TAPER_WEB_FACE
Tapers the bend and the adjacent web. The web taper is terminated at the next bend....
Definition: zwapi_cmd_sheetmetal_data.h:849
VX_SMD_TAPER_WEB_FACE_CHAIN
@ VX_SMD_TAPER_WEB_FACE_CHAIN
Tapers the selected bend and all the webs and bends in the chain using the specified taper angle valu...
Definition: zwapi_cmd_sheetmetal_data.h:852
evxSmdKFactorType
evxSmdKFactorType
K-factor Definition type.
Definition: zwapi_cmd_sheetmetal_data.h:58
VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA
@ VX_SMD_KTYPE_BEND_ALLOWANCE_FORMULA
bend allowance formula
Definition: zwapi_cmd_sheetmetal_data.h:63
VX_SMD_KTYPE_BEND_DEDUCTION_TABLE
@ VX_SMD_KTYPE_BEND_DEDUCTION_TABLE
bend deduction table
Definition: zwapi_cmd_sheetmetal_data.h:64
VX_SMD_KTYPE_CUSTOM
@ VX_SMD_KTYPE_CUSTOM
custom
Definition: zwapi_cmd_sheetmetal_data.h:59
VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE
@ VX_SMD_KTYPE_BEND_ALLOWANCE_TABLE
bend allowance table
Definition: zwapi_cmd_sheetmetal_data.h:62
VX_SMD_KTYPE_BEND_DEDUCTIOIN
@ VX_SMD_KTYPE_BEND_DEDUCTIOIN
bend deduction
Definition: zwapi_cmd_sheetmetal_data.h:65
VX_SMD_KTYPE_BEND_TABLE
@ VX_SMD_KTYPE_BEND_TABLE
bend table
Definition: zwapi_cmd_sheetmetal_data.h:61
VX_SMD_KTYPE_FROM_MATERIAL
@ VX_SMD_KTYPE_FROM_MATERIAL
from material
Definition: zwapi_cmd_sheetmetal_data.h:60
VX_SMD_KTYPE_BEND_ALLOWANCE
@ VX_SMD_KTYPE_BEND_ALLOWANCE
bend allowance, svxExtrudeFlangeData::kType do not apply it.
Definition: zwapi_cmd_sheetmetal_data.h:66
evxPunchTyp
evxPunchTyp
Punch type.
Definition: zwapi_cmd_sheetmetal_data.h:1033
VX_PUNCH_SHAPE
@ VX_PUNCH_SHAPE
Punch from Shape.
Definition: zwapi_cmd_sheetmetal_data.h:1034
VX_PUNCH_FILE
@ VX_PUNCH_FILE
Punch from File.
Definition: zwapi_cmd_sheetmetal_data.h:1035
evxExtFlangeType
evxExtFlangeType
Smd extrude type.
Definition: zwapi_cmd_sheetmetal_data.h:191
VX_EXTFLANGE_1SIDE
@ VX_EXTFLANGE_1SIDE
1 side
Definition: zwapi_cmd_sheetmetal_data.h:192
VX_EXTFLANGE_2SIDES
@ VX_EXTFLANGE_2SIDES
2 sides
Definition: zwapi_cmd_sheetmetal_data.h:193
VX_EXTFLANGE_SYMMETRICAL
@ VX_EXTFLANGE_SYMMETRICAL
symmetrical
Definition: zwapi_cmd_sheetmetal_data.h:194
evxSmdExtendSideMethod
evxSmdExtendSideMethod
extend flange side method
Definition: zwapi_cmd_sheetmetal_data.h:807
VX_SMD_EXTEND_SIDE_ALONG
@ VX_SMD_EXTEND_SIDE_ALONG
Extend along the edge.
Definition: zwapi_cmd_sheetmetal_data.h:809
VX_SMD_EXTEND_SIDE_NORMAL
@ VX_SMD_EXTEND_SIDE_NORMAL
Extend the flange normal to the edge.
Definition: zwapi_cmd_sheetmetal_data.h:808
svxNormalCutData
struct svxNormalCutData svxNormalCutData
template command Smd Normal Cut data
svxExtrudeFlangeData
struct svxExtrudeFlangeData svxExtrudeFlangeData
template command Smd Extrude Flange data
svxSmdChangeBendData
struct svxSmdChangeBendData svxSmdChangeBendData
template command Smd change bend data
svxSmdFullFlangeData
struct svxSmdFullFlangeData svxSmdFullFlangeData
template command Smd Full Flange data
svxSmdAt
struct svxSmdAt svxSmdAt
sheet metal attribute
svxUnfoldData
struct svxUnfoldData svxUnfoldData
template command Smd Unfold data
svxSmdJogData
struct svxSmdJogData svxSmdJogData
template command Smd Jog data
svxSmdHemFlangeData
struct svxSmdHemFlangeData svxSmdHemFlangeData
template command Smd Hem Flange data
svxFoldData
struct svxFoldData svxFoldData
template command Smd Fold data
svxCloseCornerData
struct svxCloseCornerData svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default ...
svxSmdBendTaperDefData
struct svxSmdBendTaperDefData svxSmdBendTaperDefData
smd bend taper definition side data
svxSmdExtrudeTabData
struct svxSmdExtrudeTabData svxSmdExtrudeTabData
template command Smd Extrude Tab data
svxSmdFlattenData
struct svxSmdFlattenData svxSmdFlattenData
template command Smd flatten data
svxSmdPartialFlangeData
struct svxSmdPartialFlangeData svxSmdPartialFlangeData
template command Smd Partial Flange data
svxPunchCons
struct svxPunchCons svxPunchCons
punch constraint
svxLouverData
struct svxLouverData svxLouverData
template command Smd Louver data
svxSmdReliefData
struct svxSmdReliefData svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.
svxSmdFlangeProfData
struct svxSmdFlangeProfData svxSmdFlangeProfData
template command Smd Flange with Profile data
svxSmdRipData
struct svxSmdRipData svxSmdRipData
template command Smd rip data
svxPunchData
struct svxPunchData svxPunchData
Punch data.
svxSmdMarkBendData
struct svxSmdMarkBendData svxSmdMarkBendData
template command Smd mark bend data
svxSmdLoftedFlangeData
struct svxSmdLoftedFlangeData svxSmdLoftedFlangeData
template command Smd Lofted Flange data
svxDimpleData
struct svxDimpleData svxDimpleData
dimple data
svxSmdExtendFlangeData
struct svxSmdExtendFlangeData svxSmdExtendFlangeData
template command Smd Extend Flange data
svxSmdSweptFlangeData
struct svxSmdSweptFlangeData svxSmdSweptFlangeData
template command Smd Swept Flange data
svxSmdBendTaperData
struct svxSmdBendTaperData svxSmdBendTaperData
template command Smd bend taper data
svxSmdFoldByLineData
struct svxSmdFoldByLineData svxSmdFoldByLineData
template command Smd Fold by Line data
svxSmdFlangeData
struct svxSmdFlangeData svxSmdFlangeData
template command Smd Flange data
svxSmdLinearUnfoldData
struct svxSmdLinearUnfoldData svxSmdLinearUnfoldData
template command Smd linear unfold data
evxDistanceMethod
evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
Definition: zwapi_cmd_subcmd_data.h:57
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCloseCornerData::CornerData::svxByEdge::Edg2Pnt
svxPntOnEnt Edg2Pnt
second face edge
Definition: zwapi_cmd_sheetmetal_data.h:997
svxCloseCornerData::CornerData::svxByEdge::Edg1Pnt
svxPntOnEnt Edg1Pnt
first face edge
Definition: zwapi_cmd_sheetmetal_data.h:996
svxCloseCornerData::CornerData::svxByEdge
linear pattern
Definition: zwapi_cmd_sheetmetal_data.h:995
svxCloseCornerData::CornerData::svxByFace::idBend2
int idBend2
second bend face
Definition: zwapi_cmd_sheetmetal_data.h:1003
svxCloseCornerData::CornerData::svxByFace::dWidth
double dWidth
specify width for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1015
svxCloseCornerData::CornerData::svxByFace::dLength
double dLength
specify length for rectangular cut (4.0 as default, use it when Relief=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1014
svxCloseCornerData::CornerData::svxByFace::dDiam
double dDiam
diameter(4.0 as default, use it when Relief!=VX_CORNER_CLOSED && Relief!=VX_CORNER_RECT_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1013
svxCloseCornerData::CornerData::svxByFace::idBend1
int idBend1
first bend face
Definition: zwapi_cmd_sheetmetal_data.h:1002
svxCloseCornerData::CornerData::svxByFace::OrgType
int OrgType
0-bend center, 1-corner point(1 as default, and it works when Relief != VX_CORNER_CLOSED)
Definition: zwapi_cmd_sheetmetal_data.h:1011
svxCloseCornerData::CornerData::svxByFace::CloseFlange
int CloseFlange
close the whole flange or not(1 as default) if set to 1, it closes all sub corners with the basic one...
Definition: zwapi_cmd_sheetmetal_data.h:1004
svxCloseCornerData::CornerData::svxByFace::dAng1
double dAng1
specify first angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1016
svxCloseCornerData::CornerData::svxByFace::dAng2
double dAng2
specify second angle for V cut (30 as default, use it when Relief=VX_CORNER_V_CUTOUT)
Definition: zwapi_cmd_sheetmetal_data.h:1017
svxCloseCornerData::CornerData::svxByFace::Relief
evxCornerReliefTyp Relief
to trim the adjoining flanges (VX_CORNER_CLOSED as default)
Definition: zwapi_cmd_sheetmetal_data.h:1010
svxCloseCornerData::CornerData::svxByFace::Miter
int Miter
miter corner or not (1 as default) if set to 0, use straight lines to form the outline of the cuter w...
Definition: zwapi_cmd_sheetmetal_data.h:1007
svxCloseCornerData::CornerData::svxByFace::dOffset
double dOffset
specify offset distance for origin (0.0 as default, use it when Relief!=VX_CORNER_CLOSED)
Definition: zwapi_cmd_sheetmetal_data.h:1012
svxCloseCornerData::CornerData::svxByFace
circular pattern
Definition: zwapi_cmd_sheetmetal_data.h:1001
svxCloseCornerData::dGap
double dGap
(0.1mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1022
svxCloseCornerData::Overlp
evxCornerOverlapTyp Overlp
(VX_CONER_NATURAL as default)
Definition: zwapi_cmd_sheetmetal_data.h:1021
svxCloseCornerData::type
int type
method, 0-close by edge, 1- close by bend(face)(0 as default)
Definition: zwapi_cmd_sheetmetal_data.h:991
svxCloseCornerData
template command Smd Close Corner data (Note: if you don't care some parameters, set them as default ...
Definition: zwapi_cmd_sheetmetal_data.h:990
svxDimpleData::prfOnDimpleTop
int prfOnDimpleTop
1-the top of the dimple is the size of the outline, and the bottom changes with the angle; 0-the bott...
Definition: zwapi_cmd_sheetmetal_data.h:1143
svxDimpleData::ftrName
vxName ftrName
feature name for "SmdDimple", 0 default
Definition: zwapi_cmd_sheetmetal_data.h:1149
svxDimpleData::radius1
double radius1
inner radius around the perimeter height of the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1137
svxDimpleData::radius3
double radius3
the outer fillet radius of the outside wall (default:1.0, 0.0-disable) doesn't use if dimpleType = 1
Definition: zwapi_cmd_sheetmetal_data.h:1139
svxDimpleData::dimpleType
int dimpleType
dimple type (0 = Plain Dimple, 1 = Flared Hole)
Definition: zwapi_cmd_sheetmetal_data.h:1125
svxDimpleData::numShapes
int numShapes
number of shapes to sew
Definition: zwapi_cmd_sheetmetal_data.h:1132
svxDimpleData::height
double height
height measured from the selected face to the outside face of the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1135
svxDimpleData::flipFlange
int flipFlange
1-flip the normal direction of the plane where the dimple is placed, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:1142
svxDimpleData::postion
evxDimplePostion postion
postion type (default: VX_MATERIAL_OUTSIDE) dimpleType = 1, VX_BEND_OUTSIDE does not contain
Definition: zwapi_cmd_sheetmetal_data.h:1146
svxDimpleData::idProfile
int idProfile
id of sketch defining the dimple perimeter, the sketch must be a closed sketch with one or more tange...
Definition: zwapi_cmd_sheetmetal_data.h:1127
svxDimpleData::angle
double angle
the side angle measured from the selected face
Definition: zwapi_cmd_sheetmetal_data.h:1136
svxDimpleData::idPlane
int idPlane
id of planar face to place the dimple
Definition: zwapi_cmd_sheetmetal_data.h:1126
svxDimpleData::idShapes
int * idShapes
list of id's of shapes to sew
Definition: zwapi_cmd_sheetmetal_data.h:1133
svxDimpleData::radius2
double radius2
outer radius around the perimeter of the dimple and tangent to the selected face
Definition: zwapi_cmd_sheetmetal_data.h:1138
svxDimpleData::notSew
int notSew
flag whether sew shapes or not. 0 = to sew (default) since R2024, it doesn't sew the new shapes and...
Definition: zwapi_cmd_sheetmetal_data.h:1130
svxDimpleData
dimple data
Definition: zwapi_cmd_sheetmetal_data.h:1124
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxExtrudeFlangeData::end
double end
end distance
Definition: zwapi_cmd_sheetmetal_data.h:221
svxExtrudeFlangeData::kValue
double * kValue
k_factor. NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:228
svxExtrudeFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use default K-Factor indicates the location of the neutral axis wit...
Definition: zwapi_cmd_sheetmetal_data.h:225
svxExtrudeFlangeData::PntOnCrv
svxPntOnEnt * PntOnCrv
rip point, point on curve, (NULL to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:229
svxExtrudeFlangeData::radius
double * radius
radius NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:224
svxExtrudeFlangeData::thickness
double * thickness
thickness. NULL to use default
Definition: zwapi_cmd_sheetmetal_data.h:222
svxExtrudeFlangeData::isOpposite
int isOpposite
1 if opposite the direction of the flange, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:223
svxExtrudeFlangeData::extType
evxExtFlangeType extType
extrude type
Definition: zwapi_cmd_sheetmetal_data.h:219
svxExtrudeFlangeData::start
double start
start distance
Definition: zwapi_cmd_sheetmetal_data.h:220
svxExtrudeFlangeData::idProfile
int idProfile
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:218
svxExtrudeFlangeData::RipSize
double RipSize
rip size. the minimum value of "RipSize" is twice the tolerance
Definition: zwapi_cmd_sheetmetal_data.h:230
svxExtrudeFlangeData
template command Smd Extrude Flange data
Definition: zwapi_cmd_sheetmetal_data.h:217
svxFoldData::idCrv
int * idCrv
curve list on the sheet metal(NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1186
svxFoldData::idBendFace
int * idBendFace
Bend faces id (NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1184
svxFoldData::CrvCnts
int CrvCnts
Curve list counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1185
svxFoldData::BendFaceCnts
int BendFaceCnts
Bend face counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1183
svxFoldData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1181
svxFoldData::idStationary
int idStationary
Stationary face id (0/-1 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1182
svxFoldData
template command Smd Fold data
Definition: zwapi_cmd_sheetmetal_data.h:1180
svxLoftBndCons
loft boundary constraints
Definition: zwapi_cmd_subcmd_data.h:71
svxLouverData::dAng
double dAng
louver angle (45deg as default)
Definition: zwapi_cmd_sheetmetal_data.h:1161
svxLouverData::idProf
int idProf
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:1159
svxLouverData::Flip
int Flip
whether to flip the louver 180 degrees about the sketch line(0-no as default, 1-yes)
Definition: zwapi_cmd_sheetmetal_data.h:1165
svxLouverData::idPlane
int idPlane
id of planar face for louver placement
Definition: zwapi_cmd_sheetmetal_data.h:1158
svxLouverData::dHeight
double dHeight
louver height (3.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1160
svxLouverData::cntSew
int cntSew
count of sew shapes
Definition: zwapi_cmd_sheetmetal_data.h:1168
svxLouverData::dR2
double dR2
2nd louver radius (1.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1163
svxLouverData::dWidth
double dWidth
louver width (6.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1164
svxLouverData::pSewShape
int * pSewShape
id list of sew shapes (NULL to sew with all shapes)
Definition: zwapi_cmd_sheetmetal_data.h:1169
svxLouverData::notSew
int notSew
flag whether sew shapes or not. 0 = to sew (default) since R2024, it doesn't sew the new shapes and...
Definition: zwapi_cmd_sheetmetal_data.h:1166
svxLouverData::dR1
double dR1
1st louver radius (1.0mm as default)
Definition: zwapi_cmd_sheetmetal_data.h:1162
svxLouverData
template command Smd Louver data
Definition: zwapi_cmd_sheetmetal_data.h:1157
svxNormalCutData::cntShape
int cntShape
Cut Shapes count.
Definition: zwapi_cmd_sheetmetal_data.h:942
svxNormalCutData::idProfile
int idProfile
Profile P.
Definition: zwapi_cmd_sheetmetal_data.h:941
svxNormalCutData::endType
evxDistanceMethod endType
end type (0 = input value, 1 = through all, 2= to point, 5 = to face)
Definition: zwapi_cmd_sheetmetal_data.h:951
svxNormalCutData::Flip
int Flip
Flip side to cut, default value:0.
Definition: zwapi_cmd_sheetmetal_data.h:948
svxNormalCutData::idStartEnt
int idStartEnt
the entity id of start field if startType > 1
Definition: zwapi_cmd_sheetmetal_data.h:952
svxNormalCutData::dStart
double dStart
Start S, default value:10.0.
Definition: zwapi_cmd_sheetmetal_data.h:945
svxNormalCutData::cutType
evxNormCutTyp cutType
normal cut option, default value:VX_NORMCUT_BOTHSIDES
Definition: zwapi_cmd_sheetmetal_data.h:940
svxNormalCutData::dEnd
double dEnd
End E, default value:-10.0.
Definition: zwapi_cmd_sheetmetal_data.h:946
svxNormalCutData::Dir
svxVector * Dir
Direction (NULL can be ignored)
Definition: zwapi_cmd_sheetmetal_data.h:947
svxNormalCutData::idEndEnt
int idEndEnt
the entity id of end field if endType > 1
Definition: zwapi_cmd_sheetmetal_data.h:953
svxNormalCutData::startType
evxDistanceMethod startType
start type (0 = input value, 1 = through all, 2= to point, 5 = to face)
Definition: zwapi_cmd_sheetmetal_data.h:950
svxNormalCutData::startToPnt
svxPoint * startToPnt
if startType = 2, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:954
svxNormalCutData::shapeList
int * shapeList
Cut Shapes List.
Definition: zwapi_cmd_sheetmetal_data.h:943
svxNormalCutData::endToPnt
svxPoint * endToPnt
if endType = 2, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:955
svxNormalCutData::extType
evxExtrudeType extType
extrude type, default value:VX_EXTRUDE_TYPE_ONESIDE
Definition: zwapi_cmd_sheetmetal_data.h:944
svxNormalCutData
template command Smd Normal Cut data
Definition: zwapi_cmd_sheetmetal_data.h:939
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint
3D point
Definition: zwapi_util.h:306
svxPunchCons::dAng
double dAng
angle value (default value: 0)
Definition: zwapi_cmd_sheetmetal_data.h:1063
svxPunchCons::Flip
int Flip
1-flip the alignment direction, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1065
svxPunchCons::pathEnt1
svxEntPath pathEnt1
first entity path (initialize as(2,-1,idEnt))
Definition: zwapi_cmd_sheetmetal_data.h:1056
svxPunchCons::alignTyp
evxConsType alignTyp
alignment type (default value: VX_CONCENTRIC)
Definition: zwapi_cmd_sheetmetal_data.h:1054
svxPunchCons::ent1FormFile
int ent1FormFile
1 if the first entity from the punch file, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1057
svxPunchCons::pathEnt2
svxEntPath pathEnt2
second entity path (initialize as(2,-1,idEnt))
Definition: zwapi_cmd_sheetmetal_data.h:1058
svxPunchCons::dOffset
double dOffset
offset value (default value: 0)
Definition: zwapi_cmd_sheetmetal_data.h:1061
svxPunchCons::ent2FormFile
int ent2FormFile
1 if the second entity from the punch file, else 0 (default value:0)
Definition: zwapi_cmd_sheetmetal_data.h:1059
svxPunchCons
punch constraint
Definition: zwapi_cmd_sheetmetal_data.h:1053
svxPunchData::LocData::ByCons::cntCons
int cntCons
count of constraint data (0 to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1102
svxPunchData::LocData::ByCons::punchCons
svxPunchCons * punchCons
constraint data list(NUll to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1103
svxPunchData::LocData::ByCons
point + constraint
Definition: zwapi_cmd_sheetmetal_data.h:1101
svxPunchData::LocData::ByPnt::idFrame
int idFrame
Frame, used option in VX_PUNCH_FILE (-1/0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1097
svxPunchData::LocData::ByPnt
point + frame
Definition: zwapi_cmd_sheetmetal_data.h:1096
svxPunchData::punchTyp
evxPunchTyp punchTyp
Punch option, default value:VX_PUNCH_SHAPE.
Definition: zwapi_cmd_sheetmetal_data.h:1074
svxPunchData::addFillet2
int addFillet2
fillet non placement edges,default value:0
Definition: zwapi_cmd_sheetmetal_data.h:1082
svxPunchData::locTyp
evxPunchLocType locTyp
location Type, default value:VX_LOCATION_POINT
Definition: zwapi_cmd_sheetmetal_data.h:1088
svxPunchData::dRadius
double dRadius
radius for dRadius, default value:5
Definition: zwapi_cmd_sheetmetal_data.h:1081
svxPunchData::localPnt
svxPoint localPnt
punch point, used option in VX_PUNCH_FILE(default:(0,0,0))
Definition: zwapi_cmd_sheetmetal_data.h:1089
svxPunchData::cntOpen
int cntOpen
count of open faces (0 to ignore)
Definition: zwapi_cmd_sheetmetal_data.h:1076
svxPunchData::addFillet
int addFillet
fillet placement edges,default value:0 if set to 1, user can set the fillet radius of intersected edg...
Definition: zwapi_cmd_sheetmetal_data.h:1079
svxPunchData::relation
int relation
Related with source, default value:1, used option in VX_PUNCH_FILE if set to 1, the punch result chan...
Definition: zwapi_cmd_sheetmetal_data.h:1090
svxPunchData::idBase
int idBase
boundary face on base (face id)
Definition: zwapi_cmd_sheetmetal_data.h:1075
svxPunchData::pathPunch
vxLongPath pathPunch
punch file path, used option in VX_PUNCH_FILE
Definition: zwapi_cmd_sheetmetal_data.h:1087
svxPunchData::pOpenList
int * pOpenList
open faces from punch shape (NULL to ignore) if punchTyp = VX_PUNCH_FILE, pOpenList must from the pun...
Definition: zwapi_cmd_sheetmetal_data.h:1077
svxPunchData::idPunch
int idPunch
a punch shape (shape id)
Definition: zwapi_cmd_sheetmetal_data.h:1085
svxPunchData::dRadius2
double dRadius2
radius for addFillet2, default value:5
Definition: zwapi_cmd_sheetmetal_data.h:1083
svxPunchData
Punch data.
Definition: zwapi_cmd_sheetmetal_data.h:1073
svxSmdAt::position
evxSmdPosition position
sheet metal position.default:VX_POSITION_NATURAL
Definition: zwapi_cmd_sheetmetal_data.h:104
svxSmdAt::isCloseCorner
int isCloseCorner
corner close type.default:0
Definition: zwapi_cmd_sheetmetal_data.h:120
svxSmdAt::reliefType
evxSmdRelief reliefType
relief type.default:VX_RELIEF_OBROUND
Definition: zwapi_cmd_sheetmetal_data.h:114
svxSmdAt::dWidRatio
double dWidRatio
relief width ratio.default:1.5
Definition: zwapi_cmd_sheetmetal_data.h:115
svxSmdAt::dCorOffset
double dCorOffset
corner offset.default:-1
Definition: zwapi_cmd_sheetmetal_data.h:125
svxSmdAt::dCorAngle2
double dCorAngle2
corner angle 2.default:30
Definition: zwapi_cmd_sheetmetal_data.h:130
svxSmdAt::isMiter
int isMiter
corner miter type.default:1
Definition: zwapi_cmd_sheetmetal_data.h:121
svxSmdAt::kType
evxSmdKFactorType kType
active sheet metal K factor type
Definition: zwapi_cmd_sheetmetal_data.h:109
svxSmdAt::dThick
double dThick
thickness (1.0 as default)
Definition: zwapi_cmd_sheetmetal_data.h:101
svxSmdAt::dDepValue
double dDepValue
relief depth value.default:1
Definition: zwapi_cmd_sheetmetal_data.h:118
svxSmdAt::dWidValue
double dWidValue
relief width value.default:1
Definition: zwapi_cmd_sheetmetal_data.h:116
svxSmdAt::dDepRatio
double dDepRatio
relief depth ratio.default:0
Definition: zwapi_cmd_sheetmetal_data.h:117
svxSmdAt::dCorDiameter
double dCorDiameter
corner diameter.default:4
Definition: zwapi_cmd_sheetmetal_data.h:128
svxSmdAt::dKBendAllow
double dKBendAllow
bend allowance.default:8.5
Definition: zwapi_cmd_sheetmetal_data.h:112
svxSmdAt::dRadius
double dRadius
radius (5.0 as default)
Definition: zwapi_cmd_sheetmetal_data.h:102
svxSmdAt::lengthType
evxSmdBendLengthType lengthType
length type.default:VX_BEND_STANDARD_LENGTH
Definition: zwapi_cmd_sheetmetal_data.h:106
svxSmdAt::iCorOrigin
int iCorOrigin
corner origin.default:0
Definition: zwapi_cmd_sheetmetal_data.h:124
svxSmdAt::dLength
double dLength
flange length.default:40
Definition: zwapi_cmd_sheetmetal_data.h:107
svxSmdAt::reliefCorType
evxSmdCornerRelief reliefCorType
corner relief type.default:VX_CORNER_RELIEF_CLOSED
Definition: zwapi_cmd_sheetmetal_data.h:122
svxSmdAt::dCorLength
double dCorLength
corner length.default:4
Definition: zwapi_cmd_sheetmetal_data.h:126
svxSmdAt::dFlatTol
double dFlatTol
flat tolerance.default:0.1
Definition: zwapi_cmd_sheetmetal_data.h:132
svxSmdAt::dKFactor
double dKFactor
K-Factor (0.41 as default)
Definition: zwapi_cmd_sheetmetal_data.h:110
svxSmdAt::dCorWidth
double dCorWidth
corner width.default:4
Definition: zwapi_cmd_sheetmetal_data.h:127
svxSmdAt::dCorAngle1
double dCorAngle1
corner angle 1.default:30
Definition: zwapi_cmd_sheetmetal_data.h:129
svxSmdAt::dCorGap
double dCorGap
corner gap.default:0.1
Definition: zwapi_cmd_sheetmetal_data.h:123
svxSmdAt::dOffset
double dOffset
specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore....
Definition: zwapi_cmd_sheetmetal_data.h:105
svxSmdAt::dKBendDed
double dKBendDed
bend deduction.default:3.5
Definition: zwapi_cmd_sheetmetal_data.h:111
svxSmdAt
sheet metal attribute
Definition: zwapi_cmd_sheetmetal_data.h:99
svxSmdBendTaperData::opposite
int opposite
Check(opposite=1) this box to flip the arrows, and system will reset the stationary face....
Definition: zwapi_cmd_sheetmetal_data.h:907
svxSmdBendTaperData::defData2
svxSmdBendTaperDefData defData2
apply it if method = VX_SMD_TAPER_SIDES_BOTH,else ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:910
svxSmdBendTaperData::defData
svxSmdBendTaperDefData defData
bend taper definition side data
Definition: zwapi_cmd_sheetmetal_data.h:909
svxSmdBendTaperData::method
evxSmdTaperSideMethod method
Specify the side you want to taper.default:VX_SMD_TAPER_SIDES_BOTH.
Definition: zwapi_cmd_sheetmetal_data.h:908
svxSmdBendTaperData::idBend
int idBend
Select a bend face to taper one or both sides of the flange. The edges of the flange are tapered in t...
Definition: zwapi_cmd_sheetmetal_data.h:905
svxSmdBendTaperData
template command Smd bend taper data
Definition: zwapi_cmd_sheetmetal_data.h:904
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::method
int method
0 is setback,Specify a distance value to taper the bend. 1 is end radius,Specify an angle value to ...
Definition: zwapi_cmd_sheetmetal_data.h:869
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear::value
double value
Angle or setback.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:872
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdLinear
smd linear data
Definition: zwapi_cmd_sheetmetal_data.h:868
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::isAutoCompute
int isAutoCompute
1 is auto compute radius,else 0. default:1
Definition: zwapi_cmd_sheetmetal_data.h:877
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::eRadius
double eRadius
end radius. apply it if isAutoCompute=0. default:2
Definition: zwapi_cmd_sheetmetal_data.h:879
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::sRadius
double sRadius
start radius. apply it if isAutoCompute=0. default:2
Definition: zwapi_cmd_sheetmetal_data.h:878
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent::setback
double setback
Specify the distance value to taper.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:876
svxSmdBendTaperDefData::uvxSmdTaperDefInfos::svxSmdTangent
smd tangent data
Definition: zwapi_cmd_sheetmetal_data.h:875
svxSmdBendTaperDefData::angle
double angle
apply it if webTaperType != VX_SMD_TAPER_WEB_NONE, else ignore it.default:5
Definition: zwapi_cmd_sheetmetal_data.h:884
svxSmdBendTaperDefData::webTaperType
evxSmdWebTaperType webTaperType
Creates tapers that start from the web.default:VX_SMD_TAPER_WEB_NONE.
Definition: zwapi_cmd_sheetmetal_data.h:883
svxSmdBendTaperDefData::taperType
int taperType
0 is linear,Use an angle value or a distance value to taper the bend. 1 is tangent,...
Definition: zwapi_cmd_sheetmetal_data.h:862
svxSmdBendTaperDefData
smd bend taper definition side data
Definition: zwapi_cmd_sheetmetal_data.h:861
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1274
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::angle
double angle
Set the angle of bends.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1273
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1276
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1275
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendDefault
VX_SMD_CHANGE_BEND_DEFAULT.
Definition: zwapi_cmd_sheetmetal_data.h:1272
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1282
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1280
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1281
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendFold
VX_SMD_CHANGE_BEND_FOLD_LENGTH.
Definition: zwapi_cmd_sheetmetal_data.h:1279
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::stationary
int stationary
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:1286
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold::angle
double angle
Set the angle of bends.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1287
svxSmdChangeBendData::uvxSmdChangeBend::svxChangeBendUnfold
VX_SMD_CHANGE_BEND_UNFOLD_LENGTH.
Definition: zwapi_cmd_sheetmetal_data.h:1285
svxSmdChangeBendData::bendFcs
int * bendFcs
Select the bend faces to change.
Definition: zwapi_cmd_sheetmetal_data.h:1267
svxSmdChangeBendData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1266
svxSmdChangeBendData::type
evxSmdChangeBendType type
Specify change bend type from the following.default:VX_SMD_CHANGE_BEND_DEFAULT.
Definition: zwapi_cmd_sheetmetal_data.h:1265
svxSmdChangeBendData::radius
double radius
Set the radius of bends.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:1268
svxSmdChangeBendData
template command Smd change bend data
Definition: zwapi_cmd_sheetmetal_data.h:1264
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::idPlane
int idPlane
Specify a plane or datum as reference object.
Definition: zwapi_cmd_sheetmetal_data.h:828
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData::offset
double offset
Specify the distance between the plane and the edge.default:0 The flange will extend beyond the plane...
Definition: zwapi_cmd_sheetmetal_data.h:829
svxSmdExtendFlangeData::uvxExtFlangeData::svxExtFlangeData
apply it if type != VX_SMD_EXTEND_BY_VALUE
Definition: zwapi_cmd_sheetmetal_data.h:827
svxSmdExtendFlangeData::idEdge
int idEdge
Select a edge to extend.
Definition: zwapi_cmd_sheetmetal_data.h:819
svxSmdExtendFlangeData::extendSrfToEdge2
int extendSrfToEdge2
Check this box to extend the bend adjacent to the edge together.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:839
svxSmdExtendFlangeData::sideType2
evxSmdExtendSideMethod sideType2
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_S...
Definition: zwapi_cmd_sheetmetal_data.h:837
svxSmdExtendFlangeData::type
evxSmdExtendFlangeMethod type
extend type.default:VX_SMD_EXTEND_BY_VALUE
Definition: zwapi_cmd_sheetmetal_data.h:818
svxSmdExtendFlangeData::sideType1
evxSmdExtendSideMethod sideType1
Specify a method to controls the start and end sides of the flange extension. default:VX_SMD_EXTEND_S...
Definition: zwapi_cmd_sheetmetal_data.h:834
svxSmdExtendFlangeData::extendSrfToEdge1
int extendSrfToEdge1
Check this box to extend the bend adjacent to the edge together.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:836
svxSmdExtendFlangeData
template command Smd Extend Flange data
Definition: zwapi_cmd_sheetmetal_data.h:817
svxSmdExtrudeTabData::isMerge
int isMerge
1 if merge, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:205
svxSmdExtrudeTabData::isOpposite
int isOpposite
1 if opposite the direction of the tab, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:206
svxSmdExtrudeTabData::Thickness
double * Thickness
thickness. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:204
svxSmdExtrudeTabData::idProfile
int idProfile
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:203
svxSmdExtrudeTabData::idMergeShape
int idMergeShape
id of the shape to be merged. Note:since 2700, this parameter must be set, if you don't set this para...
Definition: zwapi_cmd_sheetmetal_data.h:207
svxSmdExtrudeTabData
template command Smd Extrude Tab data
Definition: zwapi_cmd_sheetmetal_data.h:202
svxSmdFlangeData::isMiter
int isMiter
1 = miter corner, default = global value. if set to 0, use straight lines to form the outline of the ...
Definition: zwapi_cmd_sheetmetal_data.h:329
svxSmdFlangeData::isResolve
int isResolve
resolve flange interface. 1 = resolve, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:315
svxSmdFlangeData::height
double height
height
Definition: zwapi_cmd_sheetmetal_data.h:290
svxSmdFlangeData::interfaceOffset
double interfaceOffset
interface offset. default = 0.5
Definition: zwapi_cmd_sheetmetal_data.h:317
svxSmdFlangeData::kType
evxSmdKFactorType kType
k-factor definition type. default = global value K-Factor indicates the location of the neutral axis ...
Definition: zwapi_cmd_sheetmetal_data.h:304
svxSmdFlangeData::corOffset
double corOffset
offset. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:335
svxSmdFlangeData::widthType
int widthType
width type: 0 = use start and end, 1 = use start and length, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:261
svxSmdFlangeData::corAngle2
double corAngle2
angle 2. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:340
svxSmdFlangeData::startRelief
svxSmdReliefData startRelief
relief of start. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:312
svxSmdFlangeData::sBendSize
int sBendSize
s bend size. 0 = use height, 1 = use length2, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:292
svxSmdFlangeData::kValue
double kValue
k_factor depends on kType. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:307
svxSmdFlangeData::corRelief
evxSmdCornerRelief corRelief
corner relief type. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:332
svxSmdFlangeData::isFlip
int isFlip
flip flanges direction: 1 = flip, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:265
svxSmdFlangeData::angle
double angle
angle
Definition: zwapi_cmd_sheetmetal_data.h:289
svxSmdFlangeData::bendType
evxSmdBendType bendType
bend type. default = VX_BEND_SIMPLE
Definition: zwapi_cmd_sheetmetal_data.h:284
svxSmdFlangeData::interfaceGap
double interfaceGap
interface gap. default = 0.5
Definition: zwapi_cmd_sheetmetal_data.h:316
svxSmdFlangeData::corGap
double corGap
corner Gap. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:333
svxSmdFlangeData::corLength
double corLength
length. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:336
svxSmdFlangeData::end
double end
end
Definition: zwapi_cmd_sheetmetal_data.h:263
svxSmdFlangeData::radius1
double radius1
radius1. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:285
svxSmdFlangeData::corAngle1
double corAngle1
angle 1. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:339
svxSmdFlangeData::position
evxSmdPosition position
flange parameters position. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:267
svxSmdFlangeData::idEdges
int * idEdges
list of idEdges
Definition: zwapi_cmd_sheetmetal_data.h:260
svxSmdFlangeData::corDiameter
double corDiameter
diameter. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:338
svxSmdFlangeData::endRelief
svxSmdReliefData endRelief
relief of end. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:313
svxSmdFlangeData::length2
double length2
length2
Definition: zwapi_cmd_sheetmetal_data.h:288
svxSmdFlangeData::length1
double length1
length1
Definition: zwapi_cmd_sheetmetal_data.h:287
svxSmdFlangeData::positionOffset
double positionOffset
position offset. if position = VX_POSITION_OFFSET, apply it. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:268
svxSmdFlangeData::radius2
double radius2
radius2. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:286
svxSmdFlangeData::isTrim
int isTrim
trim adjacent bends. 1 = trim, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:294
svxSmdFlangeData::isEqualR
int isEqualR
judge if radius2 equals radius1. 1 = equal, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:293
svxSmdFlangeData::corOrigin
int corOrigin
0 = bend center, 1 = corner point. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:334
svxSmdFlangeData::length
double length
length
Definition: zwapi_cmd_sheetmetal_data.h:264
svxSmdFlangeData::isDefine
int isDefine
define each side separately. 0 = use startRelief only, 1 = use both startRelief and endRelief,...
Definition: zwapi_cmd_sheetmetal_data.h:310
svxSmdFlangeData::isCorner
int isCorner
1 = close corner, 0 = ignore corner attributes, default = global value.
Definition: zwapi_cmd_sheetmetal_data.h:328
svxSmdFlangeData::corWidth
double corWidth
width. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:337
svxSmdFlangeData::count
int count
count of idEdges
Definition: zwapi_cmd_sheetmetal_data.h:259
svxSmdFlangeData::tol
double tol
Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state....
Definition: zwapi_cmd_sheetmetal_data.h:342
svxSmdFlangeData::lengthType
evxSmdBendLengthType lengthType
length type. default = global value
Definition: zwapi_cmd_sheetmetal_data.h:291
svxSmdFlangeData::interfaceType
int interfaceType
interface type. 1 = open, 0 = closed, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:318
svxSmdFlangeData::idProfile
int idProfile
id of profile
Definition: zwapi_cmd_sheetmetal_data.h:295
svxSmdFlangeData::start
double start
start
Definition: zwapi_cmd_sheetmetal_data.h:262
svxSmdFlangeData::isRelief
int isRelief
relief for insufficient length. 1 = relief, default = 0
Definition: zwapi_cmd_sheetmetal_data.h:309
svxSmdFlangeData
template command Smd Flange data
Definition: zwapi_cmd_sheetmetal_data.h:257
svxSmdFlangeProfData::isRelief
int isRelief
1 if relief for insufficient length , else 0 as default if set to 1, user can create relief for parti...
Definition: zwapi_cmd_sheetmetal_data.h:434
svxSmdFlangeProfData::tol
double * tol
Flat Tolerance. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:441
svxSmdFlangeProfData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:437
svxSmdFlangeProfData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:418
svxSmdFlangeProfData::radius
double * radius
radius. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:424
svxSmdFlangeProfData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:426
svxSmdFlangeProfData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:427
svxSmdFlangeProfData::idProfile
int * idProfile
id of profile, NULL to ignore
Definition: zwapi_cmd_sheetmetal_data.h:419
svxSmdFlangeProfData::offset
double * offset
offset, specify the offset value of the flange. if *position = VX_POSITION_OFFSET,...
Definition: zwapi_cmd_sheetmetal_data.h:421
svxSmdFlangeProfData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:420
svxSmdFlangeProfData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:438
svxSmdFlangeProfData::angle
double angle
angle (0-180). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:425
svxSmdFlangeProfData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:439
svxSmdFlangeProfData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:432
svxSmdFlangeProfData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:429
svxSmdFlangeProfData
template command Smd Flange with Profile data
Definition: zwapi_cmd_sheetmetal_data.h:417
svxSmdFlattenData::dirPMI
svxVector dirPMI
linear PMI direction.
Definition: zwapi_cmd_sheetmetal_data.h:1223
svxSmdFlattenData::ignoreTangent
int ignoreTangent
Check(=1) this option if user wants to adjsut the tangent edges from flat pattern that can be shown o...
Definition: zwapi_cmd_sheetmetal_data.h:1218
svxSmdFlattenData::idFace
int idFace
Select the bend faces to flatten.0/-1 to ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:1210
svxSmdFlattenData::includePattern
int includePattern
Check(=1) this option if user wants to quickly project to the generated flat view of sheet metal mode...
Definition: zwapi_cmd_sheetmetal_data.h:1214
svxSmdFlattenData::offset
double offset
Set the offset distance between the flatten entity and the flatten pattern.default:20.
Definition: zwapi_cmd_sheetmetal_data.h:1211
svxSmdFlattenData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1209
svxSmdFlattenData::direction
svxVector direction
Select the direction for offset.
Definition: zwapi_cmd_sheetmetal_data.h:1213
svxSmdFlattenData::useDirPMI
int useDirPMI
1 is use PMI direction, else 0. default:0
Definition: zwapi_cmd_sheetmetal_data.h:1222
svxSmdFlattenData::useDir
int useDir
1 is use direction, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:1212
svxSmdFlattenData
template command Smd flatten data
Definition: zwapi_cmd_sheetmetal_data.h:1208
svxSmdFoldByLineData::position
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.
Definition: zwapi_cmd_sheetmetal_data.h:757
svxSmdFoldByLineData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:760
svxSmdFoldByLineData::radius
double radius
Specify the inner radius value of bend.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:759
svxSmdFoldByLineData::angle
double angle
Specify the bend angle.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:758
svxSmdFoldByLineData::idProfile
int idProfile
id of sketch, if idLine is one curve of the sketch (-1/0 if idLine is a line or a sketch)
Definition: zwapi_cmd_sheetmetal_data.h:754
svxSmdFoldByLineData::flipSide
int flipSide
bend direction, 1- flip side to keep, else 0 (default:0)
Definition: zwapi_cmd_sheetmetal_data.h:756
svxSmdFoldByLineData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:762
svxSmdFoldByLineData::idLine
int idLine
Select a line. It can be a 3 dimensional line or a sketch line.
Definition: zwapi_cmd_sheetmetal_data.h:753
svxSmdFoldByLineData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:761
svxSmdFoldByLineData::idFace
int idFace
Specify the plane face where inner bends are created.
Definition: zwapi_cmd_sheetmetal_data.h:755
svxSmdFoldByLineData
template command Smd Fold by Line data
Definition: zwapi_cmd_sheetmetal_data.h:752
svxSmdFullFlangeData::radius2
double * radius2
radius r2, if bend = 0, ignore this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:375
svxSmdFullFlangeData::isDefSepa
int isDefSepa
1 if define each side separately, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:379
svxSmdFullFlangeData::corOffset
double * corOffset
offset. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:404
svxSmdFullFlangeData::gap
double gap
Gap. 0.5 is default.
Definition: zwapi_cmd_sheetmetal_data.h:368
svxSmdFullFlangeData::isResolve
int isResolve
1 if resolve flange interference ,else 0 as default 1-to make the flanges not intersect when the crea...
Definition: zwapi_cmd_sheetmetal_data.h:366
svxSmdFullFlangeData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:373
svxSmdFullFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:360
svxSmdFullFlangeData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:374
svxSmdFullFlangeData::corAngle1
double * corAngle1
angle 1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:408
svxSmdFullFlangeData::isMiter
int * isMiter
1 if miter corner, else 0. NULL to use global default if set to 0, use straight lines to form the o...
Definition: zwapi_cmd_sheetmetal_data.h:399
svxSmdFullFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:363
svxSmdFullFlangeData::idEdges
int * idEdges
list of idEdge
Definition: zwapi_cmd_sheetmetal_data.h:356
svxSmdFullFlangeData::corRelief
evxSmdCornerRelief * corRelief
corner relief type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:395
svxSmdFullFlangeData::corGap
double * corGap
corner Gap. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:402
svxSmdFullFlangeData::isCorner
int * isCorner
1 if close corner, else 0. NULL to use global default if isCorner = 0, ignore the following varia...
Definition: zwapi_cmd_sheetmetal_data.h:396
svxSmdFullFlangeData::corOrigin
int * corOrigin
0 is bend center, 1 is corner point. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:403
svxSmdFullFlangeData::sBendSize
int sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this.
Definition: zwapi_cmd_sheetmetal_data.h:376
svxSmdFullFlangeData::corWidth
double * corWidth
width. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:406
svxSmdFullFlangeData::radius1
double * radius1
radius r1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:371
svxSmdFullFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:380
svxSmdFullFlangeData::position
evxSmdPosition * position
flange parameters position. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:358
svxSmdFullFlangeData::corDiameter
double * corDiameter
diameter. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:407
svxSmdFullFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefineSeparately = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:381
svxSmdFullFlangeData::count
int count
count of "idEdges"
Definition: zwapi_cmd_sheetmetal_data.h:355
svxSmdFullFlangeData::tol
double * tol
Flat Tolerance. (Refers to the flat tolerance allowed for sheet metal parts in their unfolded state....
Definition: zwapi_cmd_sheetmetal_data.h:364
svxSmdFullFlangeData::isFlip
int isFlip
indicate flange direction: 1 if flip the flanges, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:357
svxSmdFullFlangeData::offset
double * offset
offset, if position = VX_POSITION_OFFSET,apply it. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:359
svxSmdFullFlangeData::angle
double angle
angle (> 0). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:372
svxSmdFullFlangeData::corLength
double * corLength
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:405
svxSmdFullFlangeData::Size
double Size
size (height or length), if bend = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:377
svxSmdFullFlangeData::corAngle2
double * corAngle2
angle 2. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:409
svxSmdFullFlangeData::bend
int bend
bend, 0 if simple, 1 if S bend. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:370
svxSmdFullFlangeData
template command Smd Full Flange data
Definition: zwapi_cmd_sheetmetal_data.h:354
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::idEdges
int * idEdges
list of idEdge.
Definition: zwapi_cmd_sheetmetal_data.h:510
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::count
int count
count of idEdges
Definition: zwapi_cmd_sheetmetal_data.h:509
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::gapSize
double gapSize
miter gap size. if isMiterHem = 1, apply it. default is 0.1
Definition: zwapi_cmd_sheetmetal_data.h:513
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData::isMiterHem
int isMiterHem
1 if miter hem, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:512
svxSmdHemFlangeData::uvxSmdHemData::svxSmdFullHemData
if hemType = 0, using the following variables
Definition: zwapi_cmd_sheetmetal_data.h:508
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:517
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthType
int widthType
0 is Start-Width, 1 is Start-End. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:518
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::isRelief
int isRelief
1 if relief for insufficient length, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:522
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::start
double start
start(>=0)
Definition: zwapi_cmd_sheetmetal_data.h:519
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::widthPnt
svxPntOnEnt * widthPnt
use "To Point" to get the value of "width" (NULL to use width)
Definition: zwapi_cmd_sheetmetal_data.h:526
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::end
double end
end(>=start). if widthType = 1, using this
Definition: zwapi_cmd_sheetmetal_data.h:520
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::endPnt
svxPntOnEnt * endPnt
use "To Point" to get the value of "end" (NULL to use end)
Definition: zwapi_cmd_sheetmetal_data.h:525
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::width
double width
width(>=start). if widthType = 0 ,using this
Definition: zwapi_cmd_sheetmetal_data.h:521
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData::startPnt
svxPntOnEnt * startPnt
use "To Point" to get the value of "start" (NULL to use start)
Definition: zwapi_cmd_sheetmetal_data.h:524
svxSmdHemFlangeData::uvxSmdHemData::svxSmdPartHemData
if hemType = 1, using the following variables
Definition: zwapi_cmd_sheetmetal_data.h:516
svxSmdHemFlangeData::hemType
int hemType
0 is Full hem, 1 is Partial hem. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:503
svxSmdHemFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:553
svxSmdHemFlangeData::offset
double * offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:531
svxSmdHemFlangeData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:558
svxSmdHemFlangeData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:530
svxSmdHemFlangeData::isEqual
int isEqual
1 if equal radii ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:546
svxSmdHemFlangeData::radius1
double * radius1
Radius R1. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:549
svxSmdHemFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:556
svxSmdHemFlangeData::bendType
evxSmdHemBendType bendType
bend type. default is VX_SMD_HEM_BEND_CLOSED
Definition: zwapi_cmd_sheetmetal_data.h:545
svxSmdHemFlangeData::length1
double length1
Length L1.
Definition: zwapi_cmd_sheetmetal_data.h:547
svxSmdHemFlangeData::isFlip
int isFlip
1 if flip the hems, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:504
svxSmdHemFlangeData::angle
double angle
angle( >1). 270 as default
Definition: zwapi_cmd_sheetmetal_data.h:551
svxSmdHemFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:559
svxSmdHemFlangeData::length2
double length2
Length L2.
Definition: zwapi_cmd_sheetmetal_data.h:548
svxSmdHemFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:560
svxSmdHemFlangeData::radius2
double * radius2
Radius R2. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:550
svxSmdHemFlangeData
template command Smd Hem Flange data
Definition: zwapi_cmd_sheetmetal_data.h:502
svxSmdJogData::keepProjLen
int keepProjLen
1 is keep the projection length, else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:780
svxSmdJogData::reverseSide
int reverseSide
1 is reverse the stationary side, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:773
svxSmdJogData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:783
svxSmdJogData::position
evxSmdJogPosition position
Specify the position relationship between bend and line.default:VX_SMD_JOG_INNER.
Definition: zwapi_cmd_sheetmetal_data.h:781
svxSmdJogData::idFace
int idFace
id face.Specify the plane face where inner bends are created.
Definition: zwapi_cmd_sheetmetal_data.h:772
svxSmdJogData::idLine
int idLine
id line. Make sure it is a straight line.
Definition: zwapi_cmd_sheetmetal_data.h:771
svxSmdJogData::heightType
int heightType
0 is inner: Measure the height from the sketch plane of the fold line, extend to the total height....
Definition: zwapi_cmd_sheetmetal_data.h:774
svxSmdJogData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:785
svxSmdJogData::height
double height
input a value to define the height of the jog.default:40
Definition: zwapi_cmd_sheetmetal_data.h:779
svxSmdJogData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:784
svxSmdJogData::radius
double radius
Specify the inner radius value of bend.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:782
svxSmdJogData
template command Smd Jog data
Definition: zwapi_cmd_sheetmetal_data.h:770
svxSmdLinearUnfoldData::bendFcs
int * bendFcs
Specify bend faces to lay out.
Definition: zwapi_cmd_sheetmetal_data.h:1234
svxSmdLinearUnfoldData::angle
double angle
Specify the angle to unfold.default:90.
Definition: zwapi_cmd_sheetmetal_data.h:1235
svxSmdLinearUnfoldData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1237
svxSmdLinearUnfoldData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1238
svxSmdLinearUnfoldData::idFace
int idFace
Specify the face to fix.0/-1 to ignore it.
Definition: zwapi_cmd_sheetmetal_data.h:1232
svxSmdLinearUnfoldData::dir
svxVector dir
Select linear unfold direction.default:{1,0,0}.
Definition: zwapi_cmd_sheetmetal_data.h:1242
svxSmdLinearUnfoldData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1233
svxSmdLinearUnfoldData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1239
svxSmdLinearUnfoldData::addStatus
int addStatus
Check(=1) this option to create a newly copied part which is associative with the original one....
Definition: zwapi_cmd_sheetmetal_data.h:1241
svxSmdLinearUnfoldData::distance
double distance
Enter distance along linear unfold direction.default:0.1.
Definition: zwapi_cmd_sheetmetal_data.h:1243
svxSmdLinearUnfoldData
template command Smd linear unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1231
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:657
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutValue
double cutValue
cutting value.default:1
Definition: zwapi_cmd_sheetmetal_data.h:656
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf1
int idProf1
id of profile1
Definition: zwapi_cmd_sheetmetal_data.h:644
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutLength
double cutLength
Specify the cut length.default:1.
Definition: zwapi_cmd_sheetmetal_data.h:654
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt1
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:646
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutMethod
evxSmdLftCutMethod cutMethod
Pick the position to place the cut point.default:VX_SMD_LFG_MAX_ARC_HEIGHT.
Definition: zwapi_cmd_sheetmetal_data.h:655
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::idProf2
int idProf2
id of profile2
Definition: zwapi_cmd_sheetmetal_data.h:649
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::cutPnt2
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:651
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:659
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip2
int flip2
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:650
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::flip1
int flip1
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:645
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:658
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftBend
VX_SMD_BENDING_LOFTING.
Definition: zwapi_cmd_sheetmetal_data.h:643
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip1
int flip1
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:628
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt1
svxPntOnEnt cutPnt1
Specify that a pointcut is selected in profile 1. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:629
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutLength
double cutLength
Specify the cut length.default:1.
Definition: zwapi_cmd_sheetmetal_data.h:637
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf2
int idProf2
id of profile2
Definition: zwapi_cmd_sheetmetal_data.h:632
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::idProf1
int idProf1
id of profile1
Definition: zwapi_cmd_sheetmetal_data.h:627
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:640
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:638
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::cutPnt2
svxPntOnEnt cutPnt2
Specify that a pointcut is selected in profile 2. No setup is required when the profile is closed.
Definition: zwapi_cmd_sheetmetal_data.h:634
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:639
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat::flip2
int flip2
1 is flip profile1, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:633
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftFlat
VX_SMD_FLATTENABLE_LOFTING.
Definition: zwapi_cmd_sheetmetal_data.h:626
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip2
int flip2
1 is flip, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:616
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines1
int * listLines1
list of line(edge/curve) id
Definition: zwapi_cmd_sheetmetal_data.h:611
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::flip1
int flip1
1 is flip, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:612
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::cntShps
int cntShps
count of boolShps,cntShps=0 to use default.
Definition: zwapi_cmd_sheetmetal_data.h:618
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::bndCons
svxLoftBndCons bndCons[2]
boundary constraints
Definition: zwapi_cmd_sheetmetal_data.h:620
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::boolShps
int * boolShps
Specify the boolean operation and the boolean shapes.
Definition: zwapi_cmd_sheetmetal_data.h:619
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count1
int count1
count of listLines1
Definition: zwapi_cmd_sheetmetal_data.h:610
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::count2
int count2
count of listLines2
Definition: zwapi_cmd_sheetmetal_data.h:614
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::listLines2
int * listLines2
list of line(edge/curve) id
Definition: zwapi_cmd_sheetmetal_data.h:615
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral::scale
int scale
An additional scale factor that is applied to the Weight slider bar. This is only needed when the ext...
Definition: zwapi_cmd_sheetmetal_data.h:621
svxSmdLoftedFlangeData::uvxLftFlange::svxSmdLftGeneral
VX_SMD_GENERAL_LOFTING.
Definition: zwapi_cmd_sheetmetal_data.h:609
svxSmdLoftedFlangeData::method
evxSmdLftFlangeMethod method
Lofted Flange method.default:VX_SMD_FLATTENABLE_LOFTING.
Definition: zwapi_cmd_sheetmetal_data.h:601
svxSmdLoftedFlangeData::thickness
double thickness
Specifies the thickness for the profile.default:1. Recommended minimum value is not less than two tim...
Definition: zwapi_cmd_sheetmetal_data.h:602
svxSmdLoftedFlangeData::isOpposite
int isOpposite
1 is Flip the direction of lofted flange, else 0.default:0
Definition: zwapi_cmd_sheetmetal_data.h:604
svxSmdLoftedFlangeData::radius
double radius
Specifies the bend radius of profile.default:5.
Definition: zwapi_cmd_sheetmetal_data.h:605
svxSmdLoftedFlangeData
template command Smd Lofted Flange data
Definition: zwapi_cmd_sheetmetal_data.h:600
svxSmdMarkBendData::thickness
double thickness
sheet metal thickness.default:1.0
Definition: zwapi_cmd_sheetmetal_data.h:1331
svxSmdMarkBendData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:1330
svxSmdMarkBendData::bendFcs
int * bendFcs
Select the inner or outer bend faces. Bend faces can be marked while the sheet metal part is in its u...
Definition: zwapi_cmd_sheetmetal_data.h:1326
svxSmdMarkBendData::idFace
int idFace
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:1324
svxSmdMarkBendData::flatTol
double flatTol
Refers to the flat tolerance allowed for sheet metal parts in their unfolded state....
Definition: zwapi_cmd_sheetmetal_data.h:1332
svxSmdMarkBendData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:1329
svxSmdMarkBendData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:1328
svxSmdMarkBendData::cnt
int cnt
count of bendFcs
Definition: zwapi_cmd_sheetmetal_data.h:1325
svxSmdMarkBendData
template command Smd mark bend data
Definition: zwapi_cmd_sheetmetal_data.h:1323
svxSmdPartialFlangeData::isRelief
int isRelief
1 if relief for insufficient length , else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:474
svxSmdPartialFlangeData::Size
double Size
size (height or length), if bend = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:467
svxSmdPartialFlangeData::idEdge
int idEdge
id of edge
Definition: zwapi_cmd_sheetmetal_data.h:450
svxSmdPartialFlangeData::kValue
double * kValue
k_factor. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:472
svxSmdPartialFlangeData::angle
double angle
angle (>0). 90 as default
Definition: zwapi_cmd_sheetmetal_data.h:462
svxSmdPartialFlangeData::sBendSize
int sBendSize
S bend size (1 is length, 0 is height), if bend = 0, ignore this.
Definition: zwapi_cmd_sheetmetal_data.h:466
svxSmdPartialFlangeData::isDefSepa
int isDefSepa
1 if define each side separately ,else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:475
svxSmdPartialFlangeData::kType
evxSmdKFactorType * kType
k_factor definition type. NULL to use global default K-Factor indicates the location of the neutral a...
Definition: zwapi_cmd_sheetmetal_data.h:469
svxSmdPartialFlangeData::radius1
double * radius1
radius r1. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:461
svxSmdPartialFlangeData::startRelief
svxSmdReliefData * startRelief
relief of start
Definition: zwapi_cmd_sheetmetal_data.h:476
svxSmdPartialFlangeData::radius2
double * radius2
radius r2, if bend = 0, ignore this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:465
svxSmdPartialFlangeData::endRelief
svxSmdReliefData * endRelief
relief of end. if isDefSepa = 0, ignore this
Definition: zwapi_cmd_sheetmetal_data.h:477
svxSmdPartialFlangeData::offset
double * offset
offset. if *position = VX_POSITION_OFFSET, using this. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:458
svxSmdPartialFlangeData::length
double * length
length. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:464
svxSmdPartialFlangeData::position
evxSmdPosition * position
position type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:457
svxSmdPartialFlangeData::lengthType
evxSmdBendLengthType * lengthType
length type. NULL to use global default
Definition: zwapi_cmd_sheetmetal_data.h:463
svxSmdPartialFlangeData::end
double end
end(!=start). if widthType = 1, using this
Definition: zwapi_cmd_sheetmetal_data.h:455
svxSmdPartialFlangeData::width
double width
width(>=start). if widthType = 0, using this
Definition: zwapi_cmd_sheetmetal_data.h:456
svxSmdPartialFlangeData::start
double start
start(>=0)
Definition: zwapi_cmd_sheetmetal_data.h:454
svxSmdPartialFlangeData::bend
int bend
bend, 0 if simple, 1 if S bend. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:460
svxSmdPartialFlangeData::tol
double * tol
Flat Tolerance. NULL to use global default.
Definition: zwapi_cmd_sheetmetal_data.h:479
svxSmdPartialFlangeData::isFlip
int isFlip
1 if flip the flange, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:452
svxSmdPartialFlangeData::widthType
int widthType
0 is Start-Width, 1 is Start-End. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:453
svxSmdPartialFlangeData::isRevert
int isRevert
1 if switch start point, else 0 as default
Definition: zwapi_cmd_sheetmetal_data.h:451
svxSmdPartialFlangeData
template command Smd Partial Flange data
Definition: zwapi_cmd_sheetmetal_data.h:449
svxSmdReliefData::lengthVal
double lengthVal
length value. when lengthType = VX_RELIEF_LENGTH_TYPE_VALUE, apply it.
Definition: zwapi_cmd_sheetmetal_data.h:174
svxSmdReliefData::isCustom
int isCustom
the value of "isCustom" indicates whether the following variables use custom values(evxSmdCalCustom) ...
Definition: zwapi_cmd_sheetmetal_data.h:165
svxSmdReliefData::isDepthRatio
int isDepthRatio
1 if relief depth ratio, else 2 is value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:179
svxSmdReliefData::relief
evxSmdRelief relief
relief type. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:170
svxSmdReliefData::isWidthRatio
int isWidthRatio
1 if relief width ratio, else 2 is value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:176
svxSmdReliefData::ReliefDepth
double ReliefDepth
ratio or value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:180
svxSmdReliefData::upToBend
int upToBend
1 if up to bend. default is 0
Definition: zwapi_cmd_sheetmetal_data.h:172
svxSmdReliefData::lengthType
evxSmdReliefLengthType lengthType
length type. default is VX_RELIEF_LENGTH_TYPE_TO_EDGE
Definition: zwapi_cmd_sheetmetal_data.h:173
svxSmdReliefData::ReliefWidth
double ReliefWidth
ratio or value. default is global value
Definition: zwapi_cmd_sheetmetal_data.h:177
svxSmdReliefData
Smd Relief data, use cvxPartSmdReliefDataInit to initialize it.
Definition: zwapi_cmd_sheetmetal_data.h:164
svxSmdRipData::cnt
int cnt
count of ids
Definition: zwapi_cmd_sheetmetal_data.h:1313
svxSmdRipData::ids
int * ids
Choose edges/lines to create a rip.
Definition: zwapi_cmd_sheetmetal_data.h:1314
svxSmdRipData::gap
double gap
Set the gap size.default:0.1.
Definition: zwapi_cmd_sheetmetal_data.h:1315
svxSmdRipData::type
evxSmdRipType type
rip type.default:VX_SMD_RIP_BOTH_SIDES
Definition: zwapi_cmd_sheetmetal_data.h:1312
svxSmdRipData
template command Smd rip data
Definition: zwapi_cmd_sheetmetal_data.h:1311
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:702
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:699
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:700
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:701
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefCircular
VX_CORNER_RELIEF_CIRCULAR_CUTOUT.
Definition: zwapi_cmd_sheetmetal_data.h:698
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:694
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefClosed
VX_CORNER_RELIEF_CLOSED.
Definition: zwapi_cmd_sheetmetal_data.h:693
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::length
double length
Specify the length of the Rectangular Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:710
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:709
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::width
double width
Specify the width of the Rectangular Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:711
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:707
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:708
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefRectangular
VX_CORNER_RELIEF_RECTANGULAR_CUTOUT.
Definition: zwapi_cmd_sheetmetal_data.h:706
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:716
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:717
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:718
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:719
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefUCutout
VX_CORNER_RELIEF_U_CUTOUT.
Definition: zwapi_cmd_sheetmetal_data.h:715
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle1
double angle1
Specify the angle of the V Cutout.default:30.
Definition: zwapi_cmd_sheetmetal_data.h:728
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::offset
double offset
Specify an offset distance from the origin of the Cutout.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:726
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::gap
double gap
Specify the gap for the closed corner.default:0.
Definition: zwapi_cmd_sheetmetal_data.h:724
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::origin
int origin
0 is bend center, 1 is corner point.default:1
Definition: zwapi_cmd_sheetmetal_data.h:725
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::angle2
double angle2
Specify the angle of the V Cutout.default:30.
Definition: zwapi_cmd_sheetmetal_data.h:729
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout::diameter
double diameter
Specify the diameter of Circular Cutout, U Cutout, V Cutout.default:4.
Definition: zwapi_cmd_sheetmetal_data.h:727
svxSmdSweptFlangeData::uvxSmdSweptFlange::svxSmdReliefVCutout
VX_CORNER_RELIEF_V_CUTOUT.
Definition: zwapi_cmd_sheetmetal_data.h:723
svxSmdSweptFlangeData::idFace
int idFace
This face remains stationary when the part is folded or unfolded.
Definition: zwapi_cmd_sheetmetal_data.h:670
svxSmdSweptFlangeData::miterCorner
int miterCorner
1 is miter corner, else 0. default:1.
Definition: zwapi_cmd_sheetmetal_data.h:689
svxSmdSweptFlangeData::kValue
double kValue
k_factor. default:0.41
Definition: zwapi_cmd_sheetmetal_data.h:686
svxSmdSweptFlangeData::isUseGlobal
int isUseGlobal
1 is use global setting(the following parameters are not to set),else 0.default:1
Definition: zwapi_cmd_sheetmetal_data.h:684
svxSmdSweptFlangeData::offset
double offset
specify the offset value of the flange if position = VX_POSITION_OFFSET, else ignore....
Definition: zwapi_cmd_sheetmetal_data.h:680
svxSmdSweptFlangeData::position
evxSmdPosition position
Use this option to specify the position of the added sheet metal flange. The position of the flange i...
Definition: zwapi_cmd_sheetmetal_data.h:677
svxSmdSweptFlangeData::keepMerged
int keepMerged
1 is keep merged edges, else 0. default:0
Definition: zwapi_cmd_sheetmetal_data.h:682
svxSmdSweptFlangeData::idProfile
int idProfile
Set the open, non-intersecting profile sketch used to create the sweep.
Definition: zwapi_cmd_sheetmetal_data.h:671
svxSmdSweptFlangeData::count
int count
count of sweptPath
Definition: zwapi_cmd_sheetmetal_data.h:672
svxSmdSweptFlangeData::sweptPath
int * sweptPath
Set the path along which the profile sweeps. You can select a series of existing sheet metal edges fo...
Definition: zwapi_cmd_sheetmetal_data.h:673
svxSmdSweptFlangeData::relief
evxSmdCornerRelief relief
Use this option to trim the adjoining flanges.
Definition: zwapi_cmd_sheetmetal_data.h:688
svxSmdSweptFlangeData::radius
double radius
Specifies the inner bend radius applied to flange features.
Definition: zwapi_cmd_sheetmetal_data.h:681
svxSmdSweptFlangeData::kType
evxSmdKFactorType kType
k_factor definition type.default:VX_SMD_KTYPE_CUSTOM
Definition: zwapi_cmd_sheetmetal_data.h:685
svxSmdSweptFlangeData
template command Smd Swept Flange data
Definition: zwapi_cmd_sheetmetal_data.h:669
svxUnfoldData::idStationary
int idStationary
Stationary face id.
Definition: zwapi_cmd_sheetmetal_data.h:1196
svxUnfoldData::CrvCnts
int CrvCnts
Curve list counts(0 to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1199
svxUnfoldData::BendFaceCnts
int BendFaceCnts
Bend face counts.
Definition: zwapi_cmd_sheetmetal_data.h:1197
svxUnfoldData::idShape
int idShape
shape id
Definition: zwapi_cmd_sheetmetal_data.h:1195
svxUnfoldData::idBendFace
int * idBendFace
Bend faces id.
Definition: zwapi_cmd_sheetmetal_data.h:1198
svxUnfoldData::idCrv
int * idCrv
curve list on the sheet metal(NULL to ignored)
Definition: zwapi_cmd_sheetmetal_data.h:1200
svxUnfoldData
template command Smd Unfold data
Definition: zwapi_cmd_sheetmetal_data.h:1194
svxVector
3D vector
Definition: zwapi_util.h:338
svxCloseCornerData::CornerData
union of close corner data
Definition: zwapi_cmd_sheetmetal_data.h:993
svxPunchData::LocData
union of punch data
Definition: zwapi_cmd_sheetmetal_data.h:1094
svxSmdBendTaperDefData::uvxSmdTaperDefInfos
union of smd bend taper definition data
Definition: zwapi_cmd_sheetmetal_data.h:866
svxSmdChangeBendData::uvxSmdChangeBend
union of smd change bend data
Definition: zwapi_cmd_sheetmetal_data.h:1270
svxSmdExtendFlangeData::uvxExtFlangeData::distance
double distance
Specify a value to extend.default:0.1 The flange will stretch out when you enter a positive number,...
Definition: zwapi_cmd_sheetmetal_data.h:822
svxSmdExtendFlangeData::uvxExtFlangeData
union of smd extend flange data
Definition: zwapi_cmd_sheetmetal_data.h:821
svxSmdHemFlangeData::uvxSmdHemData
union of smd hem data
Definition: zwapi_cmd_sheetmetal_data.h:506
svxSmdLoftedFlangeData::uvxLftFlange
union of smd lofted flange data
Definition: zwapi_cmd_sheetmetal_data.h:607
svxSmdSweptFlangeData::uvxSmdSweptFlange
union of smd swept flange data
Definition: zwapi_cmd_sheetmetal_data.h:691
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_APP_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_app.h
cvxSkNesting
cvxSkNestingBlankDataInit
cvxSkNestingInit
cvxSkNestingProfileDataInit

◆ ZW_API_SK_APP_H

#define ZW_API_SK_APP_H

Definition at line 21 of file zwapi_cmd_sk_app.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_app.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_app.h
Go to the documentation of this file.
1
19#pragma once
20#ifndef ZW_API_SK_APP_H /* this ifndef surrounds entire header */
21#define ZW_API_SK_APP_H
22
23#include "zwapi_cmd_sk_app_data.h"
24
25#ifdef __cplusplus
26extern "C" {
27#endif /* __cplusplus */
28
29
30//====================================================================================================================
32//====================================================================================================================
33
34/******************************************************************************/
52extern evxErrors cvxSkNestingProfileDataInit(svxSkNestingProfileData* data);
53
54/******************************************************************************/
72extern evxErrors cvxSkNestingBlankDataInit(svxSkNestingBlankData* data);
73
74/******************************************************************************/
91extern evxErrors cvxSkNestingInit(svxSkNestingData* data);
92
93/******************************************************************************/
124extern evxErrors cvxSkNesting(const svxSkNestingData* data);
125
126/*
127*********************************************************************
128** END HEADER FILE
129*********************************************************************
130*/
131
132#ifdef __cplusplus
133 }
134#endif /* __cplusplus */
135
136#endif /* ZW_API_SK_APP_H */
cvxSkNestingInit
evxErrors cvxSkNestingInit(svxSkNestingData *data)
cvxSkNestingProfileDataInit
evxErrors cvxSkNestingProfileDataInit(svxSkNestingProfileData *data)
cvxSkNestingBlankDataInit
evxErrors cvxSkNestingBlankDataInit(svxSkNestingBlankData *data)
cvxSkNesting
evxErrors cvxSkNesting(const svxSkNestingData *data)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxSkNestingBlankData
blank data of Sketch Nesting
Definition: zwapi_cmd_sk_app_data.h:58
svxSkNestingData
Nesting data of sketch.
Definition: zwapi_cmd_sk_app_data.h:79
svxSkNestingProfileData
profile data of Sketch Nesting
Definition: zwapi_cmd_sk_app_data.h:34
zwapi_cmd_sk_app_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_APP_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_app_data.h
svxSkNestingBlankData
svxSkNestingData
svxSkNestingProfileData

◆ ZW_API_SK_APP_DATA_H

#define ZW_API_SK_APP_DATA_H

Definition at line 16 of file zwapi_cmd_sk_app_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_app_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_app_data.h
Go to the documentation of this file.
1
14#pragma once
15#ifndef ZW_API_SK_APP_DATA_H /* this ifndef surrounds entire header */
16#define ZW_API_SK_APP_DATA_H
17
18#include "zwapi_util.h"
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24//====================================================================================================================
26//====================================================================================================================
27
33typedef struct svxSkNestingProfileData
34 {
35 int cnt;
36 int* listProfile;
39 int quantity;
42 double margin;
43 double minAngle;
45 double maxAngle;
47 int flip;
48 int priority;
49 vxLongName profileName;
50 } svxSkNestingProfileData;
51
57typedef struct svxSkNestingBlankData
58 {
59 int cnt;
60 int* listBlank;
63 double margin;
64 double topMargin;
65 double bottomMargin;
66 double leftMargin;
67 double rightMargin;
68 int method;
70 vxLongName blankName;
71 } svxSkNestingBlankData;
72
78typedef struct svxSkNestingData
79 {
80 int cntPrf;
81 svxSkNestingProfileData* profiles;
82 int cntBlk;
83 svxSkNestingBlankData* blanks;
84 double timeToNest;
87 vxName reportName;
88 vxLongName reportDir;
95 } svxSkNestingData;
96
97/*
98*********************************************************************
99** END HEADER FILE
100*********************************************************************
101*/
102
103#ifdef __cplusplus
104 }
105#endif /* __cplusplus */
106
107#endif /* ZW_API_SK_CMD_DATA_H */
svxSkNestingData
struct svxSkNestingData svxSkNestingData
Nesting data of sketch.
svxSkNestingProfileData
struct svxSkNestingProfileData svxSkNestingProfileData
profile data of Sketch Nesting
svxSkNestingBlankData
struct svxSkNestingBlankData svxSkNestingBlankData
blank data of Sketch Nesting
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxSkNestingBlankData::margin
double margin
Define the gap in 4 directions of blank.The fields is valid only when selecting rectangle method....
Definition: zwapi_cmd_sk_app_data.h:63
svxSkNestingBlankData::blankName
vxLongName blankName
Specify each blank a name to distinguish each other.If not specified, a default name is specified.
Definition: zwapi_cmd_sk_app_data.h:70
svxSkNestingBlankData::listBlank
int * listBlank
list of entity id. Select sketch entities to define a blank, the selected sketch entities also must m...
Definition: zwapi_cmd_sk_app_data.h:60
svxSkNestingBlankData::bottomMargin
double bottomMargin
Define the gap bottom the blank.This field is valid only when selecting custom method....
Definition: zwapi_cmd_sk_app_data.h:65
svxSkNestingBlankData::method
int method
"Blank Margin" offers 2 ways to define: even and uneven margin in 4 directions. 0 is rectangle,...
Definition: zwapi_cmd_sk_app_data.h:68
svxSkNestingBlankData::cnt
int cnt
count of listBlank
Definition: zwapi_cmd_sk_app_data.h:59
svxSkNestingBlankData::rightMargin
double rightMargin
Define the gap right the blank.This field is valid only when selecting custom method....
Definition: zwapi_cmd_sk_app_data.h:67
svxSkNestingBlankData::topMargin
double topMargin
Define the gap top the blank.This field is valid only when selecting custom method....
Definition: zwapi_cmd_sk_app_data.h:64
svxSkNestingBlankData::leftMargin
double leftMargin
Define the gap left the blank.This field is valid only when selecting custom method....
Definition: zwapi_cmd_sk_app_data.h:66
svxSkNestingBlankData
blank data of Sketch Nesting
Definition: zwapi_cmd_sk_app_data.h:58
svxSkNestingData::cntBlk
int cntBlk
count of blanks
Definition: zwapi_cmd_sk_app_data.h:82
svxSkNestingData::reportDir
vxLongName reportDir
Specify save path and file name for nesting report.If not specified, the default save path and file n...
Definition: zwapi_cmd_sk_app_data.h:88
svxSkNestingData::timeToNest
double timeToNest
Specify the time to be calculated for nesting.Nesting result can be different basing on how long the ...
Definition: zwapi_cmd_sk_app_data.h:84
svxSkNestingData::reportName
vxName reportName
Specify a name for nesting report.If not specified, a default name is specified.
Definition: zwapi_cmd_sk_app_data.h:87
svxSkNestingData::cntPrf
int cntPrf
count of profiles
Definition: zwapi_cmd_sk_app_data.h:80
svxSkNestingData::blanks
svxSkNestingBlankData * blanks
list of blank data
Definition: zwapi_cmd_sk_app_data.h:83
svxSkNestingData::profiles
svxSkNestingProfileData * profiles
list of profile data
Definition: zwapi_cmd_sk_app_data.h:81
svxSkNestingData
Nesting data of sketch.
Definition: zwapi_cmd_sk_app_data.h:79
svxSkNestingProfileData::profileName
vxLongName profileName
Specify each profile a name to distinguish each other.If not specified, a default name is specified.
Definition: zwapi_cmd_sk_app_data.h:49
svxSkNestingProfileData::priority
int priority
Define the nest sequence when multiple profiles are about to nest.the range is 1~5....
Definition: zwapi_cmd_sk_app_data.h:48
svxSkNestingProfileData::cnt
int cnt
count of listProfile
Definition: zwapi_cmd_sk_app_data.h:35
svxSkNestingProfileData::margin
double margin
Define the gap around the profile.default:0.
Definition: zwapi_cmd_sk_app_data.h:42
svxSkNestingProfileData::quantity
int quantity
Define how much the profile defined above is planned to nest. If the blank is big enough,...
Definition: zwapi_cmd_sk_app_data.h:39
svxSkNestingProfileData::maxAngle
double maxAngle
Specify the angle range allowing the profile rotating during nesting if needed to accommodate the pro...
Definition: zwapi_cmd_sk_app_data.h:45
svxSkNestingProfileData::minAngle
double minAngle
Specify the angle range allowing the profile rotating during nesting if needed to accommodate the pro...
Definition: zwapi_cmd_sk_app_data.h:43
svxSkNestingProfileData::flip
int flip
Define whether the profile can be flip around during nest when necessary.1 if flip,...
Definition: zwapi_cmd_sk_app_data.h:47
svxSkNestingProfileData::listProfile
int * listProfile
list of entity id.Select sketch entities to define a profile, the selected sketch entities must meet ...
Definition: zwapi_cmd_sk_app_data.h:36
svxSkNestingProfileData
profile data of Sketch Nesting
Definition: zwapi_cmd_sk_app_data.h:34
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_CMD_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_cmds.h
cvxEntTextNew
cvxSkAddConsDim
cvxSkAddGeomCons
cvxSkAddPerimeterDim
cvxSkAddPolyline
cvxSkArc3pt
cvxSkArcRad
cvxSkAutoAddCoinCons
cvxSkAutoAddCoinConsSkipRefGeom
cvxSkAutoCons
cvxSkAxis
cvxSkChamfer
cvxSkChamferInit
cvxSkCir3pt
cvxSkCirRad
cvxSkConic3pt
cvxSkConic3ptInit
cvxSkCopy
cvxSkCopyInit
cvxSkCrvInt
cvxSkCrvIntInit
cvxSkCrvIntScaleInit
cvxSkDelBowties
cvxSkEllipse
cvxSkEllipseInit
cvxSkFillet
cvxSkFilletInit
cvxSkLine2pt
cvxSkMirr
cvxSkMirrInit
cvxSkMove
cvxSkMoveInit
cvxSkNgons
cvxSkNgonsInit
cvxSkOneTouchTrim
cvxSkPattern
cvxSkPnt
cvxSkPntsOnCrv
cvxSkPowerTrim
cvxSkPtnDataInit
cvxSkReadyText
cvxSkReadyTextInit
cvxSkReference
cvxSkReferenceInit
cvxSkRotate
cvxSkRotateInit
cvxSkScale
cvxSkSpline
cvxSkSplineInit
cvxSkSplitIsect
cvxSkSplitIsectInit
cvxSkTrimExt
cvxSkTrimExtInit
cvxSkTrimSplitCor
cvxSkTrimSplitCorInit
cvxSkTrimSplitCrv
cvxSkTrimSplitInit
cvxSkTrimSplitPnt

◆ ZW_API_SK_CMD_H

#define ZW_API_SK_CMD_H

Definition at line 15 of file zwapi_cmd_sk_cmds.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_cmds.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_cmds.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SK_CMD_H /* this ifndef surrounds entire header */
15#define ZW_API_SK_CMD_H
16
17#include "zwapi_cmd_sk_cmds_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
46extern evxErrors cvxSkLine2pt(svxPoint2* Start, svxPoint2* End, int* idEnt);
47
48/******************************************************************************/
66extern evxErrors cvxSkAddPolyline(int cntPnt, svxPoint2* pnts, int addCns);
67
68/******************************************************************************/
87extern evxErrors cvxSkAxis(const svxSkAxisData* Axis, int* idAxis);
88
89/******************************************************************************/
110extern evxErrors cvxSkCir3pt(svxPoint2* P1, svxPoint2* P2, svxPoint2* P3, int* idEnt);
111
112/******************************************************************************/
130extern evxErrors cvxSkCirRad(svxPoint2* Center, double Radius, int* idEnt);
131
132/******************************************************************************/
153extern evxErrors cvxSkArc3pt(svxPoint2* Start, svxPoint2* End, svxPoint2* Mid, int* idEnt);
154
155/******************************************************************************/
175extern evxErrors cvxSkArcRad(svxPoint2* Center, double Radius, double Start, double End, int* idEnt);
176
177/******************************************************************************/
194extern evxErrors cvxSkEllipseInit(svxEllipse* data);
195
196/******************************************************************************/
218extern evxErrors cvxSkEllipse(svxEllipse* ellipse, int* idEnt);
219
220/******************************************************************************/
238extern evxErrors cvxSkPnt(svxPoint2* Point, int* idEnt);
239
240/******************************************************************************/
282extern evxErrors cvxSkPntsOnCrv(int idCrv, svxPoint* Pnt, int Num, double Dist, evxExtendOpt Opt, int* Count, int** idEnts);
283
284/******************************************************************************/
303extern evxErrors cvxSkReadyTextInit(evxReadyTextMethods method, svxReadyText* data);
304
305/******************************************************************************/
329extern evxErrors cvxSkReadyText(const svxReadyText* RdText, int* idRdText);
330
331/******************************************************************************/
352extern evxErrors cvxEntTextNew(char* String, int Type, svxPoint2 Pnt[2], int* idEnt);
353
354/******************************************************************************/
368extern evxErrors cvxSkNgonsInit(evxSkNgonsType type, svxSkNgons* data);
369
370/******************************************************************************/
393extern evxErrors cvxSkNgons(const svxSkNgons* Spl, int* cnt, int** idEnts);
394
395//====================================================================================================================
397//====================================================================================================================
398/******************************************************************************/
415extern evxErrors cvxSkCrvIntInit(svxCrvIntData* data);
416
417/******************************************************************************/
432extern evxErrors cvxSkCrvIntScaleInit(int nPnt, const svxPoint* pPnts, double* startScale, double* endScale);
433
434/******************************************************************************/
462extern evxErrors cvxSkCrvInt(svxCrvIntData* Crv, int* idEnt);
463
464/******************************************************************************/
491extern evxErrors cvxSkSplineInit(svxSplineData* data, int count);
492
493/******************************************************************************/
517extern evxErrors cvxSkSpline(const svxSplineData* PntData, int* idEnt);
518
519/******************************************************************************/
541extern evxErrors cvxSkConic3pt(const svxConic3ptData* Data, int* idEnt);
542
543/******************************************************************************/
559extern evxErrors cvxSkConic3ptInit(svxConic3ptData* Data);
560
561
562//====================================================================================================================
564//====================================================================================================================
565/******************************************************************************/
582extern evxErrors cvxSkFilletInit(svxSkFilletData* data);
583
584/******************************************************************************/
605extern evxErrors cvxSkFillet(const svxSkFilletData* filletData, int* idFillet);
606
607/******************************************************************************/
624extern evxErrors cvxSkChamferInit(svxSkChamferData* data);
625
626/******************************************************************************/
647extern evxErrors cvxSkChamfer(const svxSkChamferData* chmData, int* idChamfer);
648
649/******************************************************************************/
666extern evxErrors cvxSkPowerTrim(const svxSkPowerTrim* pwTrim);
667
668/******************************************************************************/
685extern evxErrors cvxSkOneTouchTrim(const svxPntOnEnt* pnt);
686
687/******************************************************************************/
700extern evxErrors cvxSkTrimExtInit(svxSkTrimExt* trimExt);
701
702/******************************************************************************/
722extern evxErrors cvxSkTrimExt(const svxSkTrimExt* trimExt);
723
724/******************************************************************************/
737extern evxErrors cvxSkTrimSplitInit(svxSkTrimSplit* trimSpl);
738
739/******************************************************************************/
759extern evxErrors cvxSkTrimSplitCrv(const svxSkTrimSplit* trimSpl);
760
761/******************************************************************************/
779extern evxErrors cvxSkTrimSplitPnt(const svxSkTrimSplitPnt* trimSpl);
780
781/******************************************************************************/
794extern evxErrors cvxSkTrimSplitCorInit(svxSkTrimSplitCor* trimSpl);
795
796/******************************************************************************/
817extern evxErrors cvxSkTrimSplitCor(const svxSkTrimSplitCor* trimSpl);
818
819/******************************************************************************/
837extern evxErrors cvxSkDelBowties(const int numCrv, const int* idCrv);
838
839/******************************************************************************/
852extern evxErrors cvxSkSplitIsectInit(svxSkSplitIsect* Spl);
853
854/******************************************************************************/
875extern evxErrors cvxSkSplitIsect(const svxSkSplitIsect* Spl);
876
877
878
879//====================================================================================================================
881//====================================================================================================================
882/******************************************************************************/
902extern evxErrors cvxSkAutoCons(svxConsGeom* BasePnt, int Count, int* idEnts);
903
904/******************************************************************************/
958extern evxErrors cvxSkAddGeomCons(evxGeomConsType type, int subType, int nGeoms, svxConsGeom* geoms, int* Count, int** idCons);
959
960/******************************************************************************/
974extern evxErrors cvxSkAutoAddCoinCons(int idSketch);
975
976/******************************************************************************/
994extern evxErrors cvxSkAutoAddCoinConsSkipRefGeom(int idSketch, int skipFlag, int solveFlag);
995
996
997//====================================================================================================================
999//====================================================================================================================
1000/******************************************************************************/
1032extern evxErrors cvxSkAddConsDim(evxConsDimType type, svxConsDim* pData);
1033
1034/******************************************************************************/
1054extern evxErrors cvxSkAddPerimeterDim(svxPerimeterDimData* data, int* idDim);
1055
1056//====================================================================================================================
1058//====================================================================================================================
1059/******************************************************************************/
1076extern evxErrors cvxSkReferenceInit(svxSkRefData* data);
1077
1078/******************************************************************************/
1101extern evxErrors cvxSkReference(const svxSkRefData* data, int* count, int** idRefEnts);
1102
1103//====================================================================================================================
1105//====================================================================================================================
1106/******************************************************************************/
1124extern evxErrors cvxSkMoveInit(evxMoveType2D type, svxMoveData2D* data);
1125
1126/******************************************************************************/
1149extern evxErrors cvxSkMove(const svxMoveData2D* data);
1150
1151/******************************************************************************/
1174extern evxErrors cvxSkRotate(const svxRotateData2D* data, int* cnt, int** idEnts);
1175
1176/******************************************************************************/
1192extern evxErrors cvxSkRotateInit(svxRotateData2D* data);
1193
1194/******************************************************************************/
1217extern evxErrors cvxSkMirr(const svxMirrData2D* data, int* cnt, int** idEnts);
1218
1219/******************************************************************************/
1235extern evxErrors cvxSkMirrInit(svxMirrData2D* data);
1236
1237/******************************************************************************/
1261extern evxErrors cvxSkScale(int Count, int* idEnts, double X_scale, double Y_scale, svxPoint2* Pnt);
1262
1263/******************************************************************************/
1281extern evxErrors cvxSkPtnDataInit(evxSkPatternType type, svxSkPtnData* data);
1282
1283/******************************************************************************/
1311extern evxErrors cvxSkPattern(const svxSkPtnData* Pattern, int* cnt, int** idEnts);
1312
1313/******************************************************************************/
1327extern evxErrors cvxSkCopyInit(evxSkCopyType type, svxSkCopy* data);
1328
1329/******************************************************************************/
1353extern evxErrors cvxSkCopy(const svxSkCopy* Spl, int* cnt, int** idEnts);
1354
1355/*
1356*********************************************************************
1357** END HEADER FILE
1358*********************************************************************
1359*/
1360
1361#ifdef __cplusplus
1362 }
1363#endif /* __cplusplus */
1364
1365#endif /* ZW_API_SK_CMD_H */
evxConsDimType
evxConsDimType
type of sketch constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:568
evxSkPatternType
evxSkPatternType
sketch pattern method
Definition: zwapi_cmd_sk_cmds_data.h:733
evxGeomConsType
evxGeomConsType
type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:532
evxReadyTextMethods
evxReadyTextMethods
Create Sketch ready text Methods.
Definition: zwapi_cmd_sk_cmds_data.h:111
evxMoveType2D
evxMoveType2D
Move and Copy Methods(2D)
Definition: zwapi_cmd_sk_cmds_data.h:621
evxSkNgonsType
evxSkNgonsType
sketch polygon method
Definition: zwapi_cmd_sk_cmds_data.h:161
evxSkCopyType
evxSkCopyType
sketch copy method
Definition: zwapi_cmd_sk_cmds_data.h:804
cvxSkPowerTrim
evxErrors cvxSkPowerTrim(const svxSkPowerTrim *pwTrim)
cvxSkArc3pt
evxErrors cvxSkArc3pt(svxPoint2 *Start, svxPoint2 *End, svxPoint2 *Mid, int *idEnt)
cvxSkRotate
evxErrors cvxSkRotate(const svxRotateData2D *data, int *cnt, int **idEnts)
cvxSkTrimSplitCrv
evxErrors cvxSkTrimSplitCrv(const svxSkTrimSplit *trimSpl)
cvxSkCrvIntScaleInit
evxErrors cvxSkCrvIntScaleInit(int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)
cvxSkDelBowties
evxErrors cvxSkDelBowties(const int numCrv, const int *idCrv)
cvxSkAddPerimeterDim
evxErrors cvxSkAddPerimeterDim(svxPerimeterDimData *data, int *idDim)
cvxSkOneTouchTrim
evxErrors cvxSkOneTouchTrim(const svxPntOnEnt *pnt)
cvxSkCrvIntInit
evxErrors cvxSkCrvIntInit(svxCrvIntData *data)
cvxSkCopy
evxErrors cvxSkCopy(const svxSkCopy *Spl, int *cnt, int **idEnts)
cvxSkTrimExt
evxErrors cvxSkTrimExt(const svxSkTrimExt *trimExt)
cvxSkMove
evxErrors cvxSkMove(const svxMoveData2D *data)
cvxSkMirr
evxErrors cvxSkMirr(const svxMirrData2D *data, int *cnt, int **idEnts)
cvxSkReadyText
evxErrors cvxSkReadyText(const svxReadyText *RdText, int *idRdText)
cvxSkNgonsInit
evxErrors cvxSkNgonsInit(evxSkNgonsType type, svxSkNgons *data)
cvxSkChamfer
evxErrors cvxSkChamfer(const svxSkChamferData *chmData, int *idChamfer)
cvxSkChamferInit
evxErrors cvxSkChamferInit(svxSkChamferData *data)
cvxSkPnt
evxErrors cvxSkPnt(svxPoint2 *Point, int *idEnt)
cvxSkNgons
evxErrors cvxSkNgons(const svxSkNgons *Spl, int *cnt, int **idEnts)
cvxSkSplineInit
evxErrors cvxSkSplineInit(svxSplineData *data, int count)
cvxSkCopyInit
evxErrors cvxSkCopyInit(evxSkCopyType type, svxSkCopy *data)
cvxSkArcRad
evxErrors cvxSkArcRad(svxPoint2 *Center, double Radius, double Start, double End, int *idEnt)
cvxSkSplitIsect
evxErrors cvxSkSplitIsect(const svxSkSplitIsect *Spl)
cvxSkAutoCons
evxErrors cvxSkAutoCons(svxConsGeom *BasePnt, int Count, int *idEnts)
cvxSkTrimSplitCorInit
evxErrors cvxSkTrimSplitCorInit(svxSkTrimSplitCor *trimSpl)
cvxSkConic3ptInit
evxErrors cvxSkConic3ptInit(svxConic3ptData *Data)
cvxSkTrimSplitInit
evxErrors cvxSkTrimSplitInit(svxSkTrimSplit *trimSpl)
cvxSkAddPolyline
evxErrors cvxSkAddPolyline(int cntPnt, svxPoint2 *pnts, int addCns)
cvxSkAddConsDim
evxErrors cvxSkAddConsDim(evxConsDimType type, svxConsDim *pData)
cvxSkCirRad
evxErrors cvxSkCirRad(svxPoint2 *Center, double Radius, int *idEnt)
cvxSkRotateInit
evxErrors cvxSkRotateInit(svxRotateData2D *data)
cvxSkLine2pt
evxErrors cvxSkLine2pt(svxPoint2 *Start, svxPoint2 *End, int *idEnt)
cvxEntTextNew
evxErrors cvxEntTextNew(char *String, int Type, svxPoint2 Pnt[2], int *idEnt)
cvxSkScale
evxErrors cvxSkScale(int Count, int *idEnts, double X_scale, double Y_scale, svxPoint2 *Pnt)
cvxSkFilletInit
evxErrors cvxSkFilletInit(svxSkFilletData *data)
cvxSkPtnDataInit
evxErrors cvxSkPtnDataInit(evxSkPatternType type, svxSkPtnData *data)
cvxSkMirrInit
evxErrors cvxSkMirrInit(svxMirrData2D *data)
cvxSkReadyTextInit
evxErrors cvxSkReadyTextInit(evxReadyTextMethods method, svxReadyText *data)
cvxSkReference
evxErrors cvxSkReference(const svxSkRefData *data, int *count, int **idRefEnts)
cvxSkReferenceInit
evxErrors cvxSkReferenceInit(svxSkRefData *data)
cvxSkTrimSplitCor
evxErrors cvxSkTrimSplitCor(const svxSkTrimSplitCor *trimSpl)
cvxSkMoveInit
evxErrors cvxSkMoveInit(evxMoveType2D type, svxMoveData2D *data)
cvxSkPntsOnCrv
evxErrors cvxSkPntsOnCrv(int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
cvxSkPattern
evxErrors cvxSkPattern(const svxSkPtnData *Pattern, int *cnt, int **idEnts)
cvxSkCir3pt
evxErrors cvxSkCir3pt(svxPoint2 *P1, svxPoint2 *P2, svxPoint2 *P3, int *idEnt)
cvxSkSpline
evxErrors cvxSkSpline(const svxSplineData *PntData, int *idEnt)
cvxSkAutoAddCoinConsSkipRefGeom
evxErrors cvxSkAutoAddCoinConsSkipRefGeom(int idSketch, int skipFlag, int solveFlag)
cvxSkAddGeomCons
evxErrors cvxSkAddGeomCons(evxGeomConsType type, int subType, int nGeoms, svxConsGeom *geoms, int *Count, int **idCons)
cvxSkSplitIsectInit
evxErrors cvxSkSplitIsectInit(svxSkSplitIsect *Spl)
cvxSkAxis
evxErrors cvxSkAxis(const svxSkAxisData *Axis, int *idAxis)
cvxSkEllipse
evxErrors cvxSkEllipse(svxEllipse *ellipse, int *idEnt)
cvxSkCrvInt
evxErrors cvxSkCrvInt(svxCrvIntData *Crv, int *idEnt)
cvxSkAutoAddCoinCons
evxErrors cvxSkAutoAddCoinCons(int idSketch)
cvxSkEllipseInit
evxErrors cvxSkEllipseInit(svxEllipse *data)
cvxSkFillet
evxErrors cvxSkFillet(const svxSkFilletData *filletData, int *idFillet)
cvxSkTrimExtInit
evxErrors cvxSkTrimExtInit(svxSkTrimExt *trimExt)
cvxSkTrimSplitPnt
evxErrors cvxSkTrimSplitPnt(const svxSkTrimSplitPnt *trimSpl)
cvxSkConic3pt
evxErrors cvxSkConic3pt(const svxConic3ptData *Data, int *idEnt)
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxConic3ptData
3 Point Conic command data
Definition: zwapi_cmd_sk_cmds_data.h:308
svxConsDim
data of constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:584
svxConsGeom
data of sketch geometry constraint object
Definition: zwapi_cmd_sk_cmds_data.h:504
svxCrvIntData
2D/3D interpolated curve
Definition: zwapi_util.h:2329
svxEllipse
data of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:96
svxMirrData2D
template command Mirror data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:721
svxMoveData2D
template command Move data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:668
svxPerimeterDimData
data of perimeter dimension
Definition: zwapi_cmd_sk_cmds_data.h:603
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxReadyText
data of ready sketch text
Definition: zwapi_cmd_sk_cmds_data.h:121
svxRotateData2D
template command Rotate data
Definition: zwapi_cmd_sk_cmds_data.h:704
svxSkAxisData
data of sketch Axis
Definition: zwapi_cmd_sk_cmds_data.h:48
svxSkChamferData
information of chamfer in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:371
svxSkCopy
sketch copy data
Definition: zwapi_cmd_sk_cmds_data.h:825
svxSkFilletData
information of fillet in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:355
svxSkNgons
sketch polygon data
Definition: zwapi_cmd_sk_cmds_data.h:175
svxSkPowerTrim
sketch power trim data
Definition: zwapi_cmd_sk_cmds_data.h:430
svxSkPtnData
sketch pattern data
Definition: zwapi_cmd_sk_cmds_data.h:755
svxSkRefData
sketch reference geometry data
Definition: zwapi_cmd_sk_cmds_data.h:249
svxSkSplitIsect
sketch split at intersection data
Definition: zwapi_cmd_sk_cmds_data.h:489
svxSkTrimExt
sketch trim or extend data
Definition: zwapi_cmd_sk_cmds_data.h:440
svxSkTrimSplitCor
sketch trim or split to corner data
Definition: zwapi_cmd_sk_cmds_data.h:478
svxSkTrimSplit
sketch trim or split data
Definition: zwapi_cmd_sk_cmds_data.h:452
svxSkTrimSplitPnt
sketch trim or split at point data
Definition: zwapi_cmd_sk_cmds_data.h:465
svxSplineData
Spline command data.
Definition: zwapi_util.h:2398
zwapi_cmd_sk_cmds_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_CMD_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_cmds_data.h
evxConic3PntType
evxConic3PntType
evxConsDimType
evxConsDimType
evxDrawingMoveDirType
evxDrawingMoveDirType
evxGeomConsSubType
evxGeomConsSubType
evxGeomConsType
evxGeomConsType
evxMoveType2D
evxMoveType2D
evxReadyTextMethods
evxReadyTextMethods
evxRotateSetting
evxRotateSetting
evxRotateType
evxRotateType
evxSkAxisMethods
evxSkAxisMethods
evxSkChainOption
evxSkChainOption
evxSkChamferExtenOpt
evxSkChamferExtenOpt
evxSkChamferOpt
evxSkChamferOpt
evxSkChamferTrimOpt
evxSkChamferTrimOpt
evxSkCopyDir
evxSkCopyDir
evxSkCopyType
evxSkCopyType
evxSkLoopOption
evxSkLoopOption
evxSkNgonsType
evxSkNgonsType
evxSkPatternType
evxSkPatternType
evxSkRefMethod
evxSkRefMethod
evxSkRefOption
evxSkRefOption
evxSkSpacingType
evxSkSpacingType
evxTrimExtension
evxTrimExtension
evxTrimSplit
evxTrimSplit
evxTrimSplitCor
evxTrimSplitCor
svxAlongDir2D
svxConic3ptData
svxConsDim
svxConsGeom
svxEllipse
svxMirrData2D
svxMoveData2D
svxMovePntToPnt2D
svxPerimeterDimData
svxReadyText
svxRotateData2D
svxSkAxisData
svxSkChamferData
svxSkCopy
svxSkFilletData
svxSkNgons
svxSkPowerTrim
svxSkPtnData
svxSkRefData
svxSkSplitIsect
svxSkTrimExt
svxSkTrimSplit
svxSkTrimSplitCor
svxSkTrimSplitPnt

◆ ZW_API_SK_CMD_DATA_H

#define ZW_API_SK_CMD_DATA_H

Definition at line 17 of file zwapi_cmd_sk_cmds_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_cmds_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_cmds_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SK_CMD_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_SK_CMD_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxSkAxisMethods
33 {
34 VX_SK_AXIS_TWO_PNT = 0,
35 VX_SK_AXIS_PARAPT = 1,
36 VX_SK_AXIS_PERPENDICULAR = 2,
37 VX_SK_AXIS_ANGLE = 3,
38 VX_SK_AXIS_PARAOFF = 4,
39 VX_SK_AXIS_HORIZ = 5,
40 VX_SK_AXIS_VERT = 6,
41 } evxSkAxisMethods;
42
47typedef struct svxSkAxisData
48 {
49 evxSkAxisMethods Method;
50 int idEnt1;
51 svxPoint2 Pnt1;
59 int idRefEnt;
64 svxPoint2 RefPnt;
65 union evxSkAxisMethodsUnion
66 {
67 struct SkAxis2Pnt
68 {
69 int idEnt2;
70 svxPoint2 Pnt2;
73 } axis2pnt;
74 struct SkAxisParaOff
75 {
76 double Offset;
80 } axisParaOff;
81 struct SkAxisAngle
82 {
83 double Angle;
86 } axisAng;
87 } inpUnion;
88 int ConstGeom;
89 } svxSkAxisData;
90
95typedef struct svxEllipse
96 {
97 svxPoint centroid;
98 double width;
99 double height;
100 double startAng;
102 double endAng;
103 double rotationAng;
104 }svxEllipse;
105
110typedef enum evxReadyTextMethods
111 {
112 VX_ON_CRV = 1,
113 VX_BOX = 2,
114 } evxReadyTextMethods;
115
120typedef struct svxReadyText
121 {
122 char* text;
123 vxLongName font;
124 double size;
125 int style;
126 double spacing;
128 svxPoint origin;
129 int flipY;
130 int mirror;
132 evxReadyTextMethods methods;
134 double WidthText;
135 double VerticalSpacing;
137 union evxSkTextMethodsUnion
138 {
139 struct OnCrvText
140 {
141 int reverseCurve;
142 int placeTextAtOrg;
143 int reduceTxtDat;
144 int KeepTextShape;
145 int idxCurve;
146 } oncrvtext;
147 struct BoxText
148 {
149 svxPoint AlignPoint;
150 double WidthSetting;
151 double HeightSetting;
152 } boxtext;
153 } methodsUnion;
154 }svxReadyText;
155
160typedef enum evxSkNgonsType
161 {
162 VX_SK_NGONS_IN_R,
163 VX_SK_NGONS_CIR_R,
164 VX_SK_NGONS_SIDE_LEN,
165 VX_SK_NGONS_IN_BOUND,
166 VX_SK_NGONS_CIR_BOUND,
167 VX_SK_NGONS_SIDE_BOUND,
168 } evxSkNgonsType;
169
174typedef struct svxSkNgons
175 {
176 evxSkNgonsType type;
177 svxPoint2 center;
180 double R;
185 int numSide;
186 double angle;
187 svxPoint2 corner;
190 svxPoint2 boundary;
194 } svxSkNgons;
195
200typedef enum evxSkRefMethod
201 {
202 VX_SK_REF_PROJECTION,
203 VX_SK_REF_INTERSECTION,
204 } evxSkRefMethod;
205
210typedef enum evxSkRefOption
211 {
212 VX_SK_REF_SINGLE,
213 VX_SK_REF_CHAIN,
214 VX_SK_REF_LOOPS,
215 VX_SK_REF_POINT,
216 } evxSkRefOption;
217
222typedef enum evxSkChainOption
223 {
224 VX_SK_CHAIN_PICK,
225 VX_SK_CHAIN_BETWEEN_PICKS,
226 } evxSkChainOption;
227
232typedef enum evxSkLoopOption
233 {
234 VX_SK_LOOP_ALL,
235 VX_SK_LOOP_BOUNDARY,
236 VX_SK_LOOP_SHARED,
237 VX_SK_LOOP_INNER,
238 VX_SK_LOOP_OUTER,
239 VX_SK_LOOP_OPEN_BOUNDARY,
240 VX_SK_LOOP_NON_SHARED_BOUNDARY,
241 VX_SK_LOOP_SILHOUETTE,
242 } evxSkLoopOption;
243
248typedef struct svxSkRefData
249 {
250 evxSkRefMethod method;
251 evxSkRefOption option;
253 union evxSkRefInpUnion
254 {
255 struct ReferenceSingle
256 {
257 int numEnt;
258 svxEntPath* entPaths;
259 }single;
260 struct ReferenceChain
261 {
262 evxSkChainOption option;
263 int numEnt;
264 svxEntPath* entPaths;
265 }chain;
266 struct ReferenceLoop
267 {
268 evxSkLoopOption option;
269 int numEnt;
270 svxEntPath* entPaths;
271 }loop;
272 struct ReferencePoint
273 {
274 svxPntOnEntPath pnt;
275 }point;
276 }inpUnion;
277
278 int constructGeom;
279 int recordState;
280 } svxSkRefData;
281
282//====================================================================================================================
284//====================================================================================================================
285/**********************************************************************
286*! -svxCrvIntData-
287* defined in "zwapi_util.h", its also the input data of cvxPartCrvInt
288**********************************************************************/
289
290//====================================================================================================================
292//====================================================================================================================
297typedef enum evxConic3PntType
298 {
299 VX_CONIC_SHOULDER = 0,
300 VX_CONIC_TANGENT = 1,
301 }evxConic3PntType;
302
307typedef struct svxConic3ptData
308 {
309 svxPntOnEnt StartPnt;
310 svxPntOnEnt EndPnt;
311 svxPntOnEnt Point;
312 evxConic3PntType PointType;
313 double Ratio;
314 }svxConic3ptData;
315
320typedef enum evxSkChamferOpt
321 {
322 VX_CHMOPT_SETBACK = 0,
323 VX_CHMOPT_TWOSETBACK,
324 VX_CHMOPT_SETBACKANDDIS
325 } evxSkChamferOpt;
326
331typedef enum evxSkChamferTrimOpt
332 {
333 VX_CHMTRIM_NO = 0,
334 VX_CHMTRIM_BOTH,
335 VX_CHMTRIM_FIRST,
336 VX_CHMTRIM_SECOND
337 } evxSkChamferTrimOpt;
338
343typedef enum evxSkChamferExtenOpt
344 {
345 VX_CHMEXT_LINEAR = 1,
346 VX_CHMEXT_CIRCULAR,
347 VX_CHMEXT_REFLECT
348 } evxSkChamferExtenOpt;
349
354typedef struct svxSkFilletData
355 {
356 int idFirCurve;
357 svxPoint2 firPnt;
358 int idSecCurve;
359 svxPoint2 secPnt;
360 double radius;
361 int designArc;
362 evxSkChamferTrimOpt fltTrimOpt;
363 evxSkChamferExtenOpt fltExtOpt;
364 } svxSkFilletData;
365
370typedef struct svxSkChamferData
371 {
372 evxSkChamferOpt chamferOpt;
373 int idFirCurve;
376 svxPoint2 firPnt;
377 int idSecCurve;
380 svxPoint2 secPnt;
381 double firSetBack;
382 double secSetBack;
383 double angValue;
387 evxSkChamferTrimOpt chmTrimOpt;
388 evxSkChamferExtenOpt chmExtOpt;
389 } svxSkChamferData;
390
395typedef enum evxTrimExtension
396 {
397 VX_EXT_LINEAR = 1,
398 VX_EXT_ARC,
399 VX_EXT_REFLECT,
400 VX_EXT_CRV_DIM
401 } evxTrimExtension;
402
407typedef enum evxTrimSplit
408 {
409 VX_SPLIT_KEEP,
410 VX_SPLIT_DELETE,
411 VX_SPLIT_BREAK,
412 } evxTrimSplit;
413
418typedef enum evxTrimSplitCor
419 {
420 VX_SPLIT_COR_LINEAR,
421 VX_SPLIT_COR_ARC,
422 VX_SPLIT_COR_REFLECT,
423 } evxTrimSplitCor;
424
429typedef struct svxSkPowerTrim
430 {
431 svxPoint2 startPnt;
432 svxPoint2 endPnt;
433 }svxSkPowerTrim;
434
439typedef struct svxSkTrimExt
440 {
441 int numCrv;
442 svxPntOnEnt* curves;
443 svxPntOnEnt dest;
444 evxTrimExtension extension;
445 }svxSkTrimExt;
446
451typedef struct svxSkTrimSplit
452 {
453 int count;
454 int* idEnts;
455 int numSeg;
456 svxPntOnEnt* segments;
457 evxTrimSplit trimOption;
458 }svxSkTrimSplit;
459
464typedef struct svxSkTrimSplitPnt
465 {
466 int idCrv;
467 int numPnt;
468 svxPntOnEnt* pnts;
469 int numSeg;
470 svxPntOnEnt* segments;
471 }svxSkTrimSplitPnt;
472
477typedef struct svxSkTrimSplitCor
478 {
479 svxPntOnEnt firstPnt;
480 svxPntOnEnt secondPnt;
481 evxTrimSplitCor extension;
482 }svxSkTrimSplitCor;
483
488typedef struct svxSkSplitIsect
489 {
490 int Count;
491 int* idEnts;
492 int SelfIsect;
493 int CrvIsect;
494 }svxSkSplitIsect;
495
496//====================================================================================================================
498//====================================================================================================================
503typedef struct svxConsGeom
504 {
505 int isAxis;
506 svxPoint2 axis;
507 int idEntity;
508 evxGeomCritPnt critPnt;
510 int idPoint;
512 }svxConsGeom;
513
518typedef enum evxGeomConsSubType
519 {
520 VX_SK_CONS_XY_COORDS_CONS = 0,
521 VX_SK_CONS_X_COORD_CONS,
522 VX_SK_CONS_Y_COORD_CONS,
523 VX_SK_PNT_TO_ARC_MIDPNT_CONS,
524 VX_SK_PNTS_SYMMETRY_CONS,
525 } evxGeomConsSubType;
526
531typedef enum evxGeomConsType
532 {
533 VX_SK_CONS_UNKNOWN,
534 VX_SK_CONS_FIX,
535 VX_SK_CONS_ALI_Y,
536 VX_SK_CONS_ALI_X,
537 VX_SK_CONS_MID,
538 VX_SK_CONS_ON_CRV,
539 VX_SK_CONS_ISECT,
540 VX_SK_CONS_COIN,
541 VX_SK_CONS_HOR,
542 VX_SK_CONS_VER,
543 VX_SK_CONS_SYM,
544 VX_SK_CONS_PERP,
545 VX_SK_CONS_PARA,
546 VX_SK_CONS_COLINLN,
547 VX_SK_CONS_TANG,
548 VX_SK_CONS_EQL_LEN,
549 VX_SK_CONS_EQL_CURVATURE,
550 VX_SK_CONS_CONC,
551 VX_SK_CONS_EQL_RAD,
553 /* the following constraint types are created automatically by command and cannot be created by constraint command */
554 VX_SK_CONS_SYM_DST,
555 VX_SK_CONS_SYM_ANG,
556 VX_SK_CONS_PTN,
557 VX_SK_CONS_OFFSET
558 } evxGeomConsType;
559
560//====================================================================================================================
562//====================================================================================================================
567typedef enum evxConsDimType
568 {
569 VX_SK_CONSDIM_UNKNOW = -1,
570 VX_SK_CONSDIM_LINEAR,
571 VX_SK_CONSDIM_LINEAR_OFFSET,
572 VX_SK_CONSDIM_ANGULAR,
573 VX_SK_CONSDIM_RADIAL,
574 VX_SK_CONSDIM_ARC_LENGTH,
575 VX_SK_CONSDIM_SYMMETRY,
576 VX_SK_CONSDIM_PERIMETER,
577 }evxConsDimType;
578
583typedef struct svxConsDim
584 {
585 svxPoint firstPnt;
586 svxPoint secondPnt;
587 svxPoint textPnt;
588 int type;
594 int firstEnt;
595 int secondEnt;
596 }svxConsDim;
597
602typedef struct svxPerimeterDimData
603 {
604 int cnt;
605 int* listCrvId;
606 svxPoint textPnt;
607 int variant;
610 int variantCrvId;
611 } svxPerimeterDimData;
612
613//====================================================================================================================
615//====================================================================================================================
620typedef enum evxMoveType2D
621 {
622 VX_PNT_TO_PNT_2D,
623 VX_ALONG_DIR_2D,
624 } evxMoveType2D;
625
630typedef struct svxAlongDir2D
631 {
632 svxVector2 dir;
633 double distance;
634 svxPoint2 BasePoint;
635 double angle;
636 double scale;
637 } svxAlongDir2D;
638
643typedef enum evxDrawingMoveDirType
644 {
645 VX_DRAWING_TWOPOINTS,
646 VX_DRAWING_HORIZONTAL,
647 VX_DRAWING_VERTICAL,
648 } evxDrawingMoveDirType;
649
654typedef struct svxMovePntToPnt2D
655 {
656 svxPoint2 FromPoint;
657 svxPoint2 ToPoint;
658 evxDrawingMoveDirType type;
659 double angle;
660 double scale;
661 } svxMovePntToPnt2D;
662
667typedef struct svxMoveData2D
668 {
669 evxMoveType2D methods;
670 int cntEnt;
671 int* pEnts;
672 union evxMethodsUnion2D
673 {
674 svxAlongDir2D AlongDir2D;
675 svxMovePntToPnt2D PntToPnt2D;
676 } MethodUnion2D;
677 } svxMoveData2D;
678
683typedef enum evxRotateType
684 {
685 VX_ROTATE_ANGLE = 0,
686 VX_ROTATE_POINTS,
687 }evxRotateType;
688
693typedef enum evxRotateSetting
694 {
695 VX_ROTATE_MOVE = 1,
696 VX_ROTATE_COPY,
697 }evxRotateSetting;
698
703typedef struct svxRotateData2D
704 {
705 int cntEnt;
706 int* pEnts;
707 svxPntOnEnt Pnt;
708 evxRotateType Type;
709 double Angle;
710 svxPntOnEnt Start;
711 svxPntOnEnt End;
712 evxRotateSetting Setting;
713 int cntCopy;
714 }svxRotateData2D;
715
720typedef struct svxMirrData2D
721 {
722 int cntEnt;
723 int* pEnts;
724 int Line;
725 int KeepOrigEnt;
726 }svxMirrData2D;
727
732typedef enum evxSkPatternType
733 {
734 VX_SKPATTERN_LINEAR,
735 VX_SKPATTERN_CIRCULAR,
736 VX_SKPATTERN_AT_CURVES,
737 } evxSkPatternType;
738
743typedef enum evxSkSpacingType
744 {
745 VX_NUMBER_PITCH,
746 VX_NUMBER_SPAN,
747 VX_PITCH_SPAN,
748 } evxSkSpacingType;
749
754typedef struct svxSkPtnData
755 {
756 evxSkPatternType type;
757 int count;
758 int* idEnts;
759 int addDim;
760 union SkPtnData
761 {
762 struct svxSkLinear
763 {
764 int useSecondDir;
765 svxVector dir[2];
766 int num[2];
767 evxSkSpacingType spacing[2];
768 double pitch[2];
769 double span[2];
770 } linear;
771 struct svxSkCircular
772 {
773 svxPntOnEnt center;
774 int num;
775 evxSkSpacingType spacing;
776 double pitch;
777 double span;
778 } circular;
779 struct svxSkPtnCrv
780 {
781 svxPntOnEnt crvid;
782 int num;
783 evxSkSpacingType spacing;
784 double pitch;
785 } ptnCrv;
786 }ptnData;
787 int cntSkip;
788 int *firstTogglePos;
789 int *secondTogglePos;
797 } svxSkPtnData;
798
803typedef enum evxSkCopyType
804 {
805 VX_SK_COPY_PNT,
806 VX_SK_COPY_DIR,
807 } evxSkCopyType;
808
813typedef enum evxSkCopyDir
814 {
815 VX_SK_COPY_DIR_TWO,
816 VX_SK_COPY_DIR_HORIZONTAL,
817 VX_SK_COPY_DIR_VERTICAL,
818 } evxSkCopyDir;
819
824typedef struct svxSkCopy
825 {
826 evxSkCopyType type;
827 int numEnt;
828 int* idEnts;
829 int numCpy;
830 double angle;
831 double scale;
832 union svxSkCopyData
833 {
834 struct svxSkCopyPnt
835 {
836 svxPoint2 fromPnt;
837 svxPoint2 toPnt;
838 evxSkCopyDir dirOption;
839 }pnt;
840 struct svxSkCopyDir
841 {
842 svxPntOnEnt dir;
843 double distance;
844 svxPoint2 basePnt;
845 }dir;
846 }cpy;
847 } svxSkCopy;
848
849/*
850*********************************************************************
851** END HEADER FILE
852*********************************************************************
853*/
854
855#ifdef __cplusplus
856 }
857#endif /* __cplusplus */
858
859#endif /* ZW_API_SK_CMD_DATA_H */
evxSkRefMethod
evxSkRefMethod
sketch reference geometry method
Definition: zwapi_cmd_sk_cmds_data.h:201
VX_SK_REF_PROJECTION
@ VX_SK_REF_PROJECTION
projection method
Definition: zwapi_cmd_sk_cmds_data.h:202
VX_SK_REF_INTERSECTION
@ VX_SK_REF_INTERSECTION
intersection method
Definition: zwapi_cmd_sk_cmds_data.h:203
evxConsDimType
evxConsDimType
type of sketch constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:568
VX_SK_CONSDIM_RADIAL
@ VX_SK_CONSDIM_RADIAL
type of radial/diametric dimension
Definition: zwapi_cmd_sk_cmds_data.h:573
VX_SK_CONSDIM_LINEAR
@ VX_SK_CONSDIM_LINEAR
type of linear dimension
Definition: zwapi_cmd_sk_cmds_data.h:570
VX_SK_CONSDIM_SYMMETRY
@ VX_SK_CONSDIM_SYMMETRY
type of symmetry dimension
Definition: zwapi_cmd_sk_cmds_data.h:575
VX_SK_CONSDIM_UNKNOW
@ VX_SK_CONSDIM_UNKNOW
undefine.
Definition: zwapi_cmd_sk_cmds_data.h:569
VX_SK_CONSDIM_LINEAR_OFFSET
@ VX_SK_CONSDIM_LINEAR_OFFSET
type of linear offset dimension
Definition: zwapi_cmd_sk_cmds_data.h:571
VX_SK_CONSDIM_ANGULAR
@ VX_SK_CONSDIM_ANGULAR
type of angular dimension
Definition: zwapi_cmd_sk_cmds_data.h:572
VX_SK_CONSDIM_ARC_LENGTH
@ VX_SK_CONSDIM_ARC_LENGTH
type of arc length dimension
Definition: zwapi_cmd_sk_cmds_data.h:574
VX_SK_CONSDIM_PERIMETER
@ VX_SK_CONSDIM_PERIMETER
type of perimeter dimension
Definition: zwapi_cmd_sk_cmds_data.h:576
evxSkSpacingType
evxSkSpacingType
sketch pattern spacing method
Definition: zwapi_cmd_sk_cmds_data.h:744
VX_NUMBER_PITCH
@ VX_NUMBER_PITCH
number and pitch option
Definition: zwapi_cmd_sk_cmds_data.h:745
VX_PITCH_SPAN
@ VX_PITCH_SPAN
pitch and span option
Definition: zwapi_cmd_sk_cmds_data.h:747
VX_NUMBER_SPAN
@ VX_NUMBER_SPAN
number and span option
Definition: zwapi_cmd_sk_cmds_data.h:746
evxSkRefOption
evxSkRefOption
sketch reference type
Definition: zwapi_cmd_sk_cmds_data.h:211
VX_SK_REF_CHAIN
@ VX_SK_REF_CHAIN
chain
Definition: zwapi_cmd_sk_cmds_data.h:213
VX_SK_REF_POINT
@ VX_SK_REF_POINT
point
Definition: zwapi_cmd_sk_cmds_data.h:215
VX_SK_REF_SINGLE
@ VX_SK_REF_SINGLE
single
Definition: zwapi_cmd_sk_cmds_data.h:212
VX_SK_REF_LOOPS
@ VX_SK_REF_LOOPS
loops
Definition: zwapi_cmd_sk_cmds_data.h:214
evxRotateSetting
evxRotateSetting
rotate setting
Definition: zwapi_cmd_sk_cmds_data.h:694
VX_ROTATE_MOVE
@ VX_ROTATE_MOVE
Move, default value.
Definition: zwapi_cmd_sk_cmds_data.h:695
VX_ROTATE_COPY
@ VX_ROTATE_COPY
Copy.
Definition: zwapi_cmd_sk_cmds_data.h:696
evxSkPatternType
evxSkPatternType
sketch pattern method
Definition: zwapi_cmd_sk_cmds_data.h:733
VX_SKPATTERN_LINEAR
@ VX_SKPATTERN_LINEAR
linear pattern
Definition: zwapi_cmd_sk_cmds_data.h:734
VX_SKPATTERN_CIRCULAR
@ VX_SKPATTERN_CIRCULAR
circular pattern
Definition: zwapi_cmd_sk_cmds_data.h:735
VX_SKPATTERN_AT_CURVES
@ VX_SKPATTERN_AT_CURVES
pattern in space using one or more input curves
Definition: zwapi_cmd_sk_cmds_data.h:736
evxSkChamferExtenOpt
evxSkChamferExtenOpt
control the path of extended curves in chamfer/fillet of sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:344
VX_CHMEXT_REFLECT
@ VX_CHMEXT_REFLECT
The extension follows a reflective path opposite the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:347
VX_CHMEXT_CIRCULAR
@ VX_CHMEXT_CIRCULAR
The extension follows an arc path in the direction of curvature.
Definition: zwapi_cmd_sk_cmds_data.h:346
VX_CHMEXT_LINEAR
@ VX_CHMEXT_LINEAR
The extension follows a linear path.
Definition: zwapi_cmd_sk_cmds_data.h:345
evxConic3PntType
evxConic3PntType
3 Point Conic type
Definition: zwapi_cmd_sk_cmds_data.h:298
VX_CONIC_TANGENT
@ VX_CONIC_TANGENT
Tangent.
Definition: zwapi_cmd_sk_cmds_data.h:300
VX_CONIC_SHOULDER
@ VX_CONIC_SHOULDER
Shoulder, 3 Point Conic default value.
Definition: zwapi_cmd_sk_cmds_data.h:299
evxGeomConsSubType
evxGeomConsSubType
sub type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:519
VX_SK_CONS_X_COORD_CONS
@ VX_SK_CONS_X_COORD_CONS
only the X coordinate is constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:521
VX_SK_CONS_XY_COORDS_CONS
@ VX_SK_CONS_XY_COORDS_CONS
both the X and Y coordinates are constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:520
VX_SK_PNT_TO_ARC_MIDPNT_CONS
@ VX_SK_PNT_TO_ARC_MIDPNT_CONS
point to arc midpoint constraint, used to VX_SK_CONS_MID
Definition: zwapi_cmd_sk_cmds_data.h:523
VX_SK_CONS_Y_COORD_CONS
@ VX_SK_CONS_Y_COORD_CONS
only the Y coordinate is constrained, used to VX_SK_CONS_FIX
Definition: zwapi_cmd_sk_cmds_data.h:522
VX_SK_PNTS_SYMMETRY_CONS
@ VX_SK_PNTS_SYMMETRY_CONS
mark as points symmetry, used to VX_SK_CONS_SYM
Definition: zwapi_cmd_sk_cmds_data.h:524
evxRotateType
evxRotateType
rotate type
Definition: zwapi_cmd_sk_cmds_data.h:684
VX_ROTATE_ANGLE
@ VX_ROTATE_ANGLE
Angle, default value.
Definition: zwapi_cmd_sk_cmds_data.h:685
VX_ROTATE_POINTS
@ VX_ROTATE_POINTS
Points.
Definition: zwapi_cmd_sk_cmds_data.h:686
evxDrawingMoveDirType
evxDrawingMoveDirType
Sketch/Drawing move direction type.
Definition: zwapi_cmd_sk_cmds_data.h:644
VX_DRAWING_TWOPOINTS
@ VX_DRAWING_TWOPOINTS
two points
Definition: zwapi_cmd_sk_cmds_data.h:645
VX_DRAWING_VERTICAL
@ VX_DRAWING_VERTICAL
vertical
Definition: zwapi_cmd_sk_cmds_data.h:647
VX_DRAWING_HORIZONTAL
@ VX_DRAWING_HORIZONTAL
horizontal
Definition: zwapi_cmd_sk_cmds_data.h:646
evxGeomConsType
evxGeomConsType
type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:532
VX_SK_CONS_VER
@ VX_SK_CONS_VER
line vertical constraint
Definition: zwapi_cmd_sk_cmds_data.h:542
VX_SK_CONS_ISECT
@ VX_SK_CONS_ISECT
point to intersection constraint
Definition: zwapi_cmd_sk_cmds_data.h:539
VX_SK_CONS_EQL_CURVATURE
@ VX_SK_CONS_EQL_CURVATURE
line equal curvature constraint
Definition: zwapi_cmd_sk_cmds_data.h:549
VX_SK_CONS_PARA
@ VX_SK_CONS_PARA
line parallel constraint
Definition: zwapi_cmd_sk_cmds_data.h:545
VX_SK_CONS_EQL_RAD
@ VX_SK_CONS_EQL_RAD
arc or circle equal radius constraint
Definition: zwapi_cmd_sk_cmds_data.h:551
VX_SK_CONS_ALI_Y
@ VX_SK_CONS_ALI_Y
points horizontal constraint
Definition: zwapi_cmd_sk_cmds_data.h:535
VX_SK_CONS_FIX
@ VX_SK_CONS_FIX
point fixed constraint
Definition: zwapi_cmd_sk_cmds_data.h:534
VX_SK_CONS_ALI_X
@ VX_SK_CONS_ALI_X
points vertical constraint
Definition: zwapi_cmd_sk_cmds_data.h:536
VX_SK_CONS_MID
@ VX_SK_CONS_MID
point to midpoint constraint
Definition: zwapi_cmd_sk_cmds_data.h:537
VX_SK_CONS_HOR
@ VX_SK_CONS_HOR
line horizontal constraint
Definition: zwapi_cmd_sk_cmds_data.h:541
VX_SK_CONS_SYM_DST
@ VX_SK_CONS_SYM_DST
distance symmetrical constraint, created by mirror command
Definition: zwapi_cmd_sk_cmds_data.h:554
VX_SK_CONS_SYM_ANG
@ VX_SK_CONS_SYM_ANG
angle symmetrical constraint, created by mirror command
Definition: zwapi_cmd_sk_cmds_data.h:555
VX_SK_CONS_ON_CRV
@ VX_SK_CONS_ON_CRV
point to line/curve constraint
Definition: zwapi_cmd_sk_cmds_data.h:538
VX_SK_CONS_CONC
@ VX_SK_CONS_CONC
point to center constraint
Definition: zwapi_cmd_sk_cmds_data.h:550
VX_SK_CONS_COLINLN
@ VX_SK_CONS_COLINLN
line collinear constraint
Definition: zwapi_cmd_sk_cmds_data.h:546
VX_SK_CONS_SYM
@ VX_SK_CONS_SYM
entity symmetrical constraint
Definition: zwapi_cmd_sk_cmds_data.h:543
VX_SK_CONS_COIN
@ VX_SK_CONS_COIN
point coincident constraint
Definition: zwapi_cmd_sk_cmds_data.h:540
VX_SK_CONS_EQL_LEN
@ VX_SK_CONS_EQL_LEN
line equal length constraint
Definition: zwapi_cmd_sk_cmds_data.h:548
VX_SK_CONS_TANG
@ VX_SK_CONS_TANG
line tangent constraint
Definition: zwapi_cmd_sk_cmds_data.h:547
VX_SK_CONS_PTN
@ VX_SK_CONS_PTN
pattern constraint, created by pattern command
Definition: zwapi_cmd_sk_cmds_data.h:556
VX_SK_CONS_PERP
@ VX_SK_CONS_PERP
line perpendicular constraint
Definition: zwapi_cmd_sk_cmds_data.h:544
VX_SK_CONS_OFFSET
@ VX_SK_CONS_OFFSET
offset constraint, created by offset command
Definition: zwapi_cmd_sk_cmds_data.h:557
evxReadyTextMethods
evxReadyTextMethods
Create Sketch ready text Methods.
Definition: zwapi_cmd_sk_cmds_data.h:111
VX_BOX
@ VX_BOX
box text
Definition: zwapi_cmd_sk_cmds_data.h:113
VX_ON_CRV
@ VX_ON_CRV
on curve text
Definition: zwapi_cmd_sk_cmds_data.h:112
evxSkChainOption
evxSkChainOption
sketch reference chain option
Definition: zwapi_cmd_sk_cmds_data.h:223
VX_SK_CHAIN_PICK
@ VX_SK_CHAIN_PICK
chain pick
Definition: zwapi_cmd_sk_cmds_data.h:224
VX_SK_CHAIN_BETWEEN_PICKS
@ VX_SK_CHAIN_BETWEEN_PICKS
chain between picks
Definition: zwapi_cmd_sk_cmds_data.h:225
evxMoveType2D
evxMoveType2D
Move and Copy Methods(2D)
Definition: zwapi_cmd_sk_cmds_data.h:621
VX_PNT_TO_PNT_2D
@ VX_PNT_TO_PNT_2D
copy/move entities along a direction (2D)
Definition: zwapi_cmd_sk_cmds_data.h:622
VX_ALONG_DIR_2D
@ VX_ALONG_DIR_2D
copy/move entities form point to point (2D)
Definition: zwapi_cmd_sk_cmds_data.h:623
evxSkLoopOption
evxSkLoopOption
sketch reference loop option
Definition: zwapi_cmd_sk_cmds_data.h:233
VX_SK_LOOP_OUTER
@ VX_SK_LOOP_OUTER
outer loop of surface
Definition: zwapi_cmd_sk_cmds_data.h:238
VX_SK_LOOP_INNER
@ VX_SK_LOOP_INNER
inner loop of surface
Definition: zwapi_cmd_sk_cmds_data.h:237
VX_SK_LOOP_NON_SHARED_BOUNDARY
@ VX_SK_LOOP_NON_SHARED_BOUNDARY
non-shared boundary of the picked surfaces
Definition: zwapi_cmd_sk_cmds_data.h:240
VX_SK_LOOP_SHARED
@ VX_SK_LOOP_SHARED
shared edges between multiple surfaces
Definition: zwapi_cmd_sk_cmds_data.h:236
VX_SK_LOOP_SILHOUETTE
@ VX_SK_LOOP_SILHOUETTE
silhouette of the picked surface
Definition: zwapi_cmd_sk_cmds_data.h:241
VX_SK_LOOP_OPEN_BOUNDARY
@ VX_SK_LOOP_OPEN_BOUNDARY
open boundary of surface
Definition: zwapi_cmd_sk_cmds_data.h:239
VX_SK_LOOP_ALL
@ VX_SK_LOOP_ALL
all loops of surface
Definition: zwapi_cmd_sk_cmds_data.h:234
VX_SK_LOOP_BOUNDARY
@ VX_SK_LOOP_BOUNDARY
boundary of surface
Definition: zwapi_cmd_sk_cmds_data.h:235
evxSkNgonsType
evxSkNgonsType
sketch polygon method
Definition: zwapi_cmd_sk_cmds_data.h:161
VX_SK_NGONS_CIR_R
@ VX_SK_NGONS_CIR_R
circumscribed radius
Definition: zwapi_cmd_sk_cmds_data.h:163
VX_SK_NGONS_CIR_BOUND
@ VX_SK_NGONS_CIR_BOUND
circumscribed boundary
Definition: zwapi_cmd_sk_cmds_data.h:166
VX_SK_NGONS_IN_R
@ VX_SK_NGONS_IN_R
inscribed radius
Definition: zwapi_cmd_sk_cmds_data.h:162
VX_SK_NGONS_SIDE_BOUND
@ VX_SK_NGONS_SIDE_BOUND
side boundary
Definition: zwapi_cmd_sk_cmds_data.h:167
VX_SK_NGONS_IN_BOUND
@ VX_SK_NGONS_IN_BOUND
inscribed boundary
Definition: zwapi_cmd_sk_cmds_data.h:165
VX_SK_NGONS_SIDE_LEN
@ VX_SK_NGONS_SIDE_LEN
side length
Definition: zwapi_cmd_sk_cmds_data.h:164
evxTrimSplitCor
evxTrimSplitCor
trim/split to corner option method
Definition: zwapi_cmd_sk_cmds_data.h:419
VX_SPLIT_COR_LINEAR
@ VX_SPLIT_COR_LINEAR
lionear option
Definition: zwapi_cmd_sk_cmds_data.h:420
VX_SPLIT_COR_REFLECT
@ VX_SPLIT_COR_REFLECT
reflect option
Definition: zwapi_cmd_sk_cmds_data.h:422
VX_SPLIT_COR_ARC
@ VX_SPLIT_COR_ARC
arc option
Definition: zwapi_cmd_sk_cmds_data.h:421
evxSkAxisMethods
evxSkAxisMethods
Create Sketch Axis Methods.
Definition: zwapi_cmd_sk_cmds_data.h:33
VX_SK_AXIS_PARAOFF
@ VX_SK_AXIS_PARAOFF
Parallel and Offset.
Definition: zwapi_cmd_sk_cmds_data.h:38
VX_SK_AXIS_PARAPT
@ VX_SK_AXIS_PARAPT
Parallel and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:35
VX_SK_AXIS_TWO_PNT
@ VX_SK_AXIS_TWO_PNT
Two Point.
Definition: zwapi_cmd_sk_cmds_data.h:34
VX_SK_AXIS_VERT
@ VX_SK_AXIS_VERT
Vertical.
Definition: zwapi_cmd_sk_cmds_data.h:40
VX_SK_AXIS_ANGLE
@ VX_SK_AXIS_ANGLE
Angle.
Definition: zwapi_cmd_sk_cmds_data.h:37
VX_SK_AXIS_HORIZ
@ VX_SK_AXIS_HORIZ
Horizontal.
Definition: zwapi_cmd_sk_cmds_data.h:39
VX_SK_AXIS_PERPENDICULAR
@ VX_SK_AXIS_PERPENDICULAR
Perpendicular and a pin point.
Definition: zwapi_cmd_sk_cmds_data.h:36
evxTrimSplit
evxTrimSplit
trim/extend extension method
Definition: zwapi_cmd_sk_cmds_data.h:408
VX_SPLIT_KEEP
@ VX_SPLIT_KEEP
keep option
Definition: zwapi_cmd_sk_cmds_data.h:409
VX_SPLIT_DELETE
@ VX_SPLIT_DELETE
delete option
Definition: zwapi_cmd_sk_cmds_data.h:410
VX_SPLIT_BREAK
@ VX_SPLIT_BREAK
berak option
Definition: zwapi_cmd_sk_cmds_data.h:411
evxTrimExtension
evxTrimExtension
trim/extend extension method
Definition: zwapi_cmd_sk_cmds_data.h:396
VX_EXT_LINEAR
@ VX_EXT_LINEAR
linear option
Definition: zwapi_cmd_sk_cmds_data.h:397
VX_EXT_ARC
@ VX_EXT_ARC
arc option
Definition: zwapi_cmd_sk_cmds_data.h:398
VX_EXT_REFLECT
@ VX_EXT_REFLECT
reflect option
Definition: zwapi_cmd_sk_cmds_data.h:399
VX_EXT_CRV_DIM
@ VX_EXT_CRV_DIM
curvature diminishing option
Definition: zwapi_cmd_sk_cmds_data.h:400
evxSkCopyDir
evxSkCopyDir
sketch copy from point to point direction method
Definition: zwapi_cmd_sk_cmds_data.h:814
VX_SK_COPY_DIR_HORIZONTAL
@ VX_SK_COPY_DIR_HORIZONTAL
horizontal
Definition: zwapi_cmd_sk_cmds_data.h:816
VX_SK_COPY_DIR_VERTICAL
@ VX_SK_COPY_DIR_VERTICAL
vertical
Definition: zwapi_cmd_sk_cmds_data.h:817
VX_SK_COPY_DIR_TWO
@ VX_SK_COPY_DIR_TWO
two points
Definition: zwapi_cmd_sk_cmds_data.h:815
evxSkChamferTrimOpt
evxSkChamferTrimOpt
option of trim in chamfer/fillet of sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:332
VX_CHMTRIM_FIRST
@ VX_CHMTRIM_FIRST
Trim/Extend only the first selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:335
VX_CHMTRIM_BOTH
@ VX_CHMTRIM_BOTH
Trim/Extend both curves.
Definition: zwapi_cmd_sk_cmds_data.h:334
VX_CHMTRIM_SECOND
@ VX_CHMTRIM_SECOND
Trim/extend only the second selected curve.
Definition: zwapi_cmd_sk_cmds_data.h:336
VX_CHMTRIM_NO
@ VX_CHMTRIM_NO
No trim/extend is performed.
Definition: zwapi_cmd_sk_cmds_data.h:333
evxSkChamferOpt
evxSkChamferOpt
option of chamfer in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:321
VX_CHMOPT_SETBACKANDDIS
@ VX_CHMOPT_SETBACKANDDIS
a chamfer by specifying the setback and an angle
Definition: zwapi_cmd_sk_cmds_data.h:324
VX_CHMOPT_TWOSETBACK
@ VX_CHMOPT_TWOSETBACK
a chamfer with different setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:323
VX_CHMOPT_SETBACK
@ VX_CHMOPT_SETBACK
a chamfer of equal setback values between two curves
Definition: zwapi_cmd_sk_cmds_data.h:322
evxSkCopyType
evxSkCopyType
sketch copy method
Definition: zwapi_cmd_sk_cmds_data.h:804
VX_SK_COPY_DIR
@ VX_SK_COPY_DIR
copy entities along a direction
Definition: zwapi_cmd_sk_cmds_data.h:806
VX_SK_COPY_PNT
@ VX_SK_COPY_PNT
copy entities from point to point
Definition: zwapi_cmd_sk_cmds_data.h:805
svxConsGeom
struct svxConsGeom svxConsGeom
data of sketch geometry constraint object
svxSkTrimSplitPnt
struct svxSkTrimSplitPnt svxSkTrimSplitPnt
sketch trim or split at point data
svxEllipse
struct svxEllipse svxEllipse
data of ellipse
svxSkTrimExt
struct svxSkTrimExt svxSkTrimExt
sketch trim or extend data
svxSkNgons
struct svxSkNgons svxSkNgons
sketch polygon data
svxConic3ptData
struct svxConic3ptData svxConic3ptData
3 Point Conic command data
svxMovePntToPnt2D
struct svxMovePntToPnt2D svxMovePntToPnt2D
copy/move entities form point to point (2D)
svxSkSplitIsect
struct svxSkSplitIsect svxSkSplitIsect
sketch split at intersection data
svxSkAxisData
struct svxSkAxisData svxSkAxisData
data of sketch Axis
svxRotateData2D
struct svxRotateData2D svxRotateData2D
template command Rotate data
svxSkPowerTrim
struct svxSkPowerTrim svxSkPowerTrim
sketch power trim data
svxSkTrimSplitCor
struct svxSkTrimSplitCor svxSkTrimSplitCor
sketch trim or split to corner data
svxSkCopy
struct svxSkCopy svxSkCopy
sketch copy data
svxSkPtnData
struct svxSkPtnData svxSkPtnData
sketch pattern data
svxAlongDir2D
struct svxAlongDir2D svxAlongDir2D
copy/move entities along a direction (2D)
svxMirrData2D
struct svxMirrData2D svxMirrData2D
template command Mirror data(2D)
svxReadyText
struct svxReadyText svxReadyText
data of ready sketch text
svxSkFilletData
struct svxSkFilletData svxSkFilletData
information of fillet in sheeting or sketch
svxSkTrimSplit
struct svxSkTrimSplit svxSkTrimSplit
sketch trim or split data
svxPerimeterDimData
struct svxPerimeterDimData svxPerimeterDimData
data of perimeter dimension
svxSkChamferData
struct svxSkChamferData svxSkChamferData
information of chamfer in sheeting or sketch
svxConsDim
struct svxConsDim svxConsDim
data of constraint dimension
svxSkRefData
struct svxSkRefData svxSkRefData
sketch reference geometry data
svxMoveData2D
struct svxMoveData2D svxMoveData2D
template command Move data(2D)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxGeomCritPnt
evxGeomCritPnt
type of sketch geometry critical point
Definition: zwapi_util.h:534
svxAlongDir2D::BasePoint
svxPoint2 BasePoint
base point
Definition: zwapi_cmd_sk_cmds_data.h:634
svxAlongDir2D::scale
double scale
scale
Definition: zwapi_cmd_sk_cmds_data.h:636
svxAlongDir2D::distance
double distance
distance
Definition: zwapi_cmd_sk_cmds_data.h:633
svxAlongDir2D::dir
svxVector2 dir
move direction
Definition: zwapi_cmd_sk_cmds_data.h:632
svxAlongDir2D::angle
double angle
angle
Definition: zwapi_cmd_sk_cmds_data.h:635
svxAlongDir2D
copy/move entities along a direction (2D)
Definition: zwapi_cmd_sk_cmds_data.h:631
svxConic3ptData::Point
svxPntOnEnt Point
Point.
Definition: zwapi_cmd_sk_cmds_data.h:311
svxConic3ptData::Ratio
double Ratio
Conic Ratio, Range of this value is: 0.01 <= Ratio <= 0.99.
Definition: zwapi_cmd_sk_cmds_data.h:313
svxConic3ptData::PointType
evxConic3PntType PointType
Point type.
Definition: zwapi_cmd_sk_cmds_data.h:312
svxConic3ptData::EndPnt
svxPntOnEnt EndPnt
End point.
Definition: zwapi_cmd_sk_cmds_data.h:310
svxConic3ptData::StartPnt
svxPntOnEnt StartPnt
Start point.
Definition: zwapi_cmd_sk_cmds_data.h:309
svxConic3ptData
3 Point Conic command data
Definition: zwapi_cmd_sk_cmds_data.h:308
svxConsDim::type
int type
sub type of dimension linear dimension: 1 = horizontal method, 2 = vertical method,...
Definition: zwapi_cmd_sk_cmds_data.h:588
svxConsDim::firstEnt
int firstEnt
entity id which the first point on it, NULL if it doesn't need
Definition: zwapi_cmd_sk_cmds_data.h:594
svxConsDim::firstPnt
svxPoint firstPnt
first point
Definition: zwapi_cmd_sk_cmds_data.h:585
svxConsDim::secondEnt
int secondEnt
entity id which the second point on it, NULL if it doesn't need
Definition: zwapi_cmd_sk_cmds_data.h:595
svxConsDim::secondPnt
svxPoint secondPnt
second point, NULL if it doesn't need
Definition: zwapi_cmd_sk_cmds_data.h:586
svxConsDim::textPnt
svxPoint textPnt
text point
Definition: zwapi_cmd_sk_cmds_data.h:587
svxConsDim
data of constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:584
svxConsGeom::idPoint
int idPoint
used to indicate the control point of the spline (starting from 0) only used when pntType is VX_SPLIN...
Definition: zwapi_cmd_sk_cmds_data.h:510
svxConsGeom::idEntity
int idEntity
index of entity
Definition: zwapi_cmd_sk_cmds_data.h:507
svxConsGeom::critPnt
evxGeomCritPnt critPnt
critical point, if you want to set an entity such as line rather than a critical point on the entity,...
Definition: zwapi_cmd_sk_cmds_data.h:508
svxConsGeom::isAxis
int isAxis
whether to use axis, 1 to use axis; 0 to use entity or point
Definition: zwapi_cmd_sk_cmds_data.h:505
svxConsGeom::axis
svxPoint2 axis
specify axis, only X(1,0) and Y(0,1) axis of sketch are supported
Definition: zwapi_cmd_sk_cmds_data.h:506
svxConsGeom
data of sketch geometry constraint object
Definition: zwapi_cmd_sk_cmds_data.h:504
svxEllipse::endAng
double endAng
end angle of ellipse (deg - CCW from the first decided axis of ellipse)
Definition: zwapi_cmd_sk_cmds_data.h:102
svxEllipse::rotationAng
double rotationAng
rotation angle of ellipse (deg - CCW from the first decided axis of ellipse)
Definition: zwapi_cmd_sk_cmds_data.h:103
svxEllipse::startAng
double startAng
start angle of ellipse (deg - CCW from X axis). the arc is the part of ellipse from start angle to en...
Definition: zwapi_cmd_sk_cmds_data.h:100
svxEllipse::width
double width
width of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:98
svxEllipse::centroid
svxPoint centroid
centroid of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:97
svxEllipse::height
double height
height of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:99
svxEllipse
data of ellipse
Definition: zwapi_cmd_sk_cmds_data.h:96
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMirrData2D::KeepOrigEnt
int KeepOrigEnt
Flag to use "Keep original entities" ,1 is default
Definition: zwapi_cmd_sk_cmds_data.h:725
svxMirrData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:722
svxMirrData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:723
svxMirrData2D::Line
int Line
Line(Symmetry axis) ID.
Definition: zwapi_cmd_sk_cmds_data.h:724
svxMirrData2D
template command Mirror data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:721
svxMoveData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:671
svxMoveData2D::methods
evxMoveType2D methods
Move Methods.
Definition: zwapi_cmd_sk_cmds_data.h:669
svxMoveData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:670
svxMoveData2D
template command Move data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:668
svxMovePntToPnt2D::type
evxDrawingMoveDirType type
direction type
Definition: zwapi_cmd_sk_cmds_data.h:658
svxMovePntToPnt2D::FromPoint
svxPoint2 FromPoint
from point
Definition: zwapi_cmd_sk_cmds_data.h:656
svxMovePntToPnt2D::angle
double angle
angle
Definition: zwapi_cmd_sk_cmds_data.h:659
svxMovePntToPnt2D::ToPoint
svxPoint2 ToPoint
to point
Definition: zwapi_cmd_sk_cmds_data.h:657
svxMovePntToPnt2D::scale
double scale
scale
Definition: zwapi_cmd_sk_cmds_data.h:660
svxMovePntToPnt2D
copy/move entities form point to point (2D)
Definition: zwapi_cmd_sk_cmds_data.h:655
svxPerimeterDimData::listCrvId
int * listCrvId
list of curve id
Definition: zwapi_cmd_sk_cmds_data.h:605
svxPerimeterDimData::variant
int variant
0 is auto,the system will atutomatically modify the selected curves' length according to the perimete...
Definition: zwapi_cmd_sk_cmds_data.h:607
svxPerimeterDimData::variantCrvId
int variantCrvId
variant curve id.apply it if variant = 1.
Definition: zwapi_cmd_sk_cmds_data.h:610
svxPerimeterDimData::cnt
int cnt
count of listCrvId
Definition: zwapi_cmd_sk_cmds_data.h:604
svxPerimeterDimData::textPnt
svxPoint textPnt
text point
Definition: zwapi_cmd_sk_cmds_data.h:606
svxPerimeterDimData
data of perimeter dimension
Definition: zwapi_cmd_sk_cmds_data.h:603
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxReadyText::evxSkTextMethodsUnion::BoxText::AlignPoint
svxPoint AlignPoint
Align Point.
Definition: zwapi_cmd_sk_cmds_data.h:149
svxReadyText::evxSkTextMethodsUnion::BoxText::HeightSetting
double HeightSetting
Setting Height.
Definition: zwapi_cmd_sk_cmds_data.h:151
svxReadyText::evxSkTextMethodsUnion::BoxText::WidthSetting
double WidthSetting
Setting Width.
Definition: zwapi_cmd_sk_cmds_data.h:150
svxReadyText::evxSkTextMethodsUnion::BoxText
box text data
Definition: zwapi_cmd_sk_cmds_data.h:148
svxReadyText::evxSkTextMethodsUnion::OnCrvText::placeTextAtOrg
int placeTextAtOrg
Place text at origin.
Definition: zwapi_cmd_sk_cmds_data.h:142
svxReadyText::evxSkTextMethodsUnion::OnCrvText::idxCurve
int idxCurve
curve index
Definition: zwapi_cmd_sk_cmds_data.h:145
svxReadyText::evxSkTextMethodsUnion::OnCrvText::reduceTxtDat
int reduceTxtDat
Reduce text data.
Definition: zwapi_cmd_sk_cmds_data.h:143
svxReadyText::evxSkTextMethodsUnion::OnCrvText::reverseCurve
int reverseCurve
Reverse curve.
Definition: zwapi_cmd_sk_cmds_data.h:141
svxReadyText::evxSkTextMethodsUnion::OnCrvText::KeepTextShape
int KeepTextShape
Keep Text Shape.
Definition: zwapi_cmd_sk_cmds_data.h:144
svxReadyText::evxSkTextMethodsUnion::OnCrvText
On curve text data.
Definition: zwapi_cmd_sk_cmds_data.h:140
svxReadyText::methods
evxReadyTextMethods methods
ready text methods
Definition: zwapi_cmd_sk_cmds_data.h:132
svxReadyText::flipY
int flipY
Horizontal flip.
Definition: zwapi_cmd_sk_cmds_data.h:129
svxReadyText::mirror
int mirror
Mirror.
Definition: zwapi_cmd_sk_cmds_data.h:130
svxReadyText::style
int style
text style(1:Regular; 2:Italic; 3:Bold; 4.Bold Italic)
Definition: zwapi_cmd_sk_cmds_data.h:125
svxReadyText::origin
svxPoint origin
text position
Definition: zwapi_cmd_sk_cmds_data.h:128
svxReadyText::spacing
double spacing
character space
Definition: zwapi_cmd_sk_cmds_data.h:126
svxReadyText::VerticalSpacing
double VerticalSpacing
Vertical Spacing.
Definition: zwapi_cmd_sk_cmds_data.h:135
svxReadyText::text
char * text
text string
Definition: zwapi_cmd_sk_cmds_data.h:122
svxReadyText::size
double size
text height
Definition: zwapi_cmd_sk_cmds_data.h:124
svxReadyText::WidthText
double WidthText
Text width.
Definition: zwapi_cmd_sk_cmds_data.h:134
svxReadyText::font
vxLongName font
font name
Definition: zwapi_cmd_sk_cmds_data.h:123
svxReadyText
data of ready sketch text
Definition: zwapi_cmd_sk_cmds_data.h:121
svxRotateData2D::End
svxPntOnEnt End
End point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.
Definition: zwapi_cmd_sk_cmds_data.h:711
svxRotateData2D::pEnts
int * pEnts
Entities ID.
Definition: zwapi_cmd_sk_cmds_data.h:706
svxRotateData2D::Angle
double Angle
Rotate angle, 0 if Type is VX_POTATE_POINTS.
Definition: zwapi_cmd_sk_cmds_data.h:709
svxRotateData2D::cntCopy
int cntCopy
Copy count, 0 if Setting is VX_ROTATE_MOVE.
Definition: zwapi_cmd_sk_cmds_data.h:713
svxRotateData2D::Pnt
svxPntOnEnt Pnt
Base point.
Definition: zwapi_cmd_sk_cmds_data.h:707
svxRotateData2D::Start
svxPntOnEnt Start
Start point for rotating, use cvxMemZero() set this value if Type is VX_ROTATE_ANGLE.
Definition: zwapi_cmd_sk_cmds_data.h:710
svxRotateData2D::Setting
evxRotateSetting Setting
Rotate settings, VX_ROTATE_MOVE is default.
Definition: zwapi_cmd_sk_cmds_data.h:712
svxRotateData2D::cntEnt
int cntEnt
Entity count.
Definition: zwapi_cmd_sk_cmds_data.h:705
svxRotateData2D::Type
evxRotateType Type
Option to set rotate type, VX_ROTATE_ANGLE is default.
Definition: zwapi_cmd_sk_cmds_data.h:708
svxRotateData2D
template command Rotate data
Definition: zwapi_cmd_sk_cmds_data.h:704
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::Pnt2
svxPoint2 Pnt2
second point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. other type can be null
Definition: zwapi_cmd_sk_cmds_data.h:70
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt::idEnt2
int idEnt2
id of the Second Parent entity (0 to ignore)
Definition: zwapi_cmd_sk_cmds_data.h:69
svxSkAxisData::evxSkAxisMethodsUnion::SkAxis2Pnt
Two Points.
Definition: zwapi_cmd_sk_cmds_data.h:68
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle::Angle
double Angle
Angle. if type = VX_SK_AXIS_ANGLE, it is the angle between axis and reference line....
Definition: zwapi_cmd_sk_cmds_data.h:83
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisAngle
Angle.
Definition: zwapi_cmd_sk_cmds_data.h:82
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff::Offset
double Offset
Offset. if type = VX_SK_AXIS_PARAOFF, the axis is parallel to reference line, and the distance betwee...
Definition: zwapi_cmd_sk_cmds_data.h:76
svxSkAxisData::evxSkAxisMethodsUnion::SkAxisParaOff
Parallel and Offset.
Definition: zwapi_cmd_sk_cmds_data.h:75
svxSkAxisData::idEnt1
int idEnt1
id of the First Point parent entity(0 to ignore)
Definition: zwapi_cmd_sk_cmds_data.h:50
svxSkAxisData::Method
evxSkAxisMethods Method
Sketch Axis Methods.
Definition: zwapi_cmd_sk_cmds_data.h:49
svxSkAxisData::idRefEnt
int idRefEnt
id of the RefLine parent entity. if type = VX_SK_AXIS_PARAPT, the axis is the line parallel to refere...
Definition: zwapi_cmd_sk_cmds_data.h:59
svxSkAxisData::Pnt1
svxPoint2 Pnt1
first Point. if type = VX_SK_AXIS_TWO_PNT, the axis is through Pnt1 and Pnt2. if type = VX_SK_AXI...
Definition: zwapi_cmd_sk_cmds_data.h:51
svxSkAxisData::RefPnt
svxPoint2 RefPnt
Ref Line point.
Definition: zwapi_cmd_sk_cmds_data.h:64
svxSkAxisData::ConstGeom
int ConstGeom
1-Construction Geometry, else 0 (1 as default)
Definition: zwapi_cmd_sk_cmds_data.h:88
svxSkAxisData
data of sketch Axis
Definition: zwapi_cmd_sk_cmds_data.h:48
svxSkChamferData::idFirCurve
int idFirCurve
first setback value. if type = VX_CHMOPT_SETBACK, it is setback value for 2 curves....
Definition: zwapi_cmd_sk_cmds_data.h:373
svxSkChamferData::secPnt
svxPoint2 secPnt
a point on the second curve
Definition: zwapi_cmd_sk_cmds_data.h:380
svxSkChamferData::angValue
double angValue
specifying the angle of the first curve, if type = VX_CHMOPT_SETBACKANDDIS, the setback value for 2nd...
Definition: zwapi_cmd_sk_cmds_data.h:383
svxSkChamferData::firPnt
svxPoint2 firPnt
a point on the first curve
Definition: zwapi_cmd_sk_cmds_data.h:376
svxSkChamferData::secSetBack
double secSetBack
second setback value, only needed when chamferOpt is VX_CHMOPT_TWOSETBACK
Definition: zwapi_cmd_sk_cmds_data.h:382
svxSkChamferData::chamferOpt
evxSkChamferOpt chamferOpt
option of chamfer
Definition: zwapi_cmd_sk_cmds_data.h:372
svxSkChamferData::idSecCurve
int idSecCurve
second setback value. if type = VX_CHMOPT_TWOSETBACK,it is setback value for 2nd curve....
Definition: zwapi_cmd_sk_cmds_data.h:377
svxSkChamferData::chmExtOpt
evxSkChamferExtenOpt chmExtOpt
control the path of extended curves
Definition: zwapi_cmd_sk_cmds_data.h:388
svxSkChamferData::firSetBack
double firSetBack
first setback value, when chamferOpt is VX_CHMOPT_SETBACK it represents setback value
Definition: zwapi_cmd_sk_cmds_data.h:381
svxSkChamferData::chmTrimOpt
evxSkChamferTrimOpt chmTrimOpt
trim (or extend) curves
Definition: zwapi_cmd_sk_cmds_data.h:387
svxSkChamferData
information of chamfer in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:371
svxSkCopy::svxSkCopyData::svxSkCopyDir::dir
svxPntOnEnt dir
direction of copy
Definition: zwapi_cmd_sk_cmds_data.h:842
svxSkCopy::svxSkCopyData::svxSkCopyDir::basePnt
svxPoint2 basePnt
base point of copy
Definition: zwapi_cmd_sk_cmds_data.h:844
svxSkCopy::svxSkCopyData::svxSkCopyDir::distance
double distance
distance of copy.default:10
Definition: zwapi_cmd_sk_cmds_data.h:843
svxSkCopy::svxSkCopyData::svxSkCopyDir
along a direction type
Definition: zwapi_cmd_sk_cmds_data.h:841
svxSkCopy::svxSkCopyData::svxSkCopyPnt::dirOption
evxSkCopyDir dirOption
direction option.default:VX_SK_COPY_DIR_TWO
Definition: zwapi_cmd_sk_cmds_data.h:838
svxSkCopy::svxSkCopyData::svxSkCopyPnt::toPnt
svxPoint2 toPnt
to point
Definition: zwapi_cmd_sk_cmds_data.h:837
svxSkCopy::svxSkCopyData::svxSkCopyPnt::fromPnt
svxPoint2 fromPnt
from point
Definition: zwapi_cmd_sk_cmds_data.h:836
svxSkCopy::svxSkCopyData::svxSkCopyPnt
point to point copy type
Definition: zwapi_cmd_sk_cmds_data.h:835
svxSkCopy::idEnts
int * idEnts
list id of entities to copy
Definition: zwapi_cmd_sk_cmds_data.h:828
svxSkCopy::scale
double scale
the scale of copy entities.default:1
Definition: zwapi_cmd_sk_cmds_data.h:831
svxSkCopy::type
evxSkCopyType type
copy option
Definition: zwapi_cmd_sk_cmds_data.h:826
svxSkCopy::angle
double angle
the rotate angle.default:0
Definition: zwapi_cmd_sk_cmds_data.h:830
svxSkCopy::numCpy
int numCpy
copy number
Definition: zwapi_cmd_sk_cmds_data.h:829
svxSkCopy::numEnt
int numEnt
number of entities to copy
Definition: zwapi_cmd_sk_cmds_data.h:827
svxSkCopy
sketch copy data
Definition: zwapi_cmd_sk_cmds_data.h:825
svxSkFilletData::fltTrimOpt
evxSkChamferTrimOpt fltTrimOpt
trim (or extend) curves
Definition: zwapi_cmd_sk_cmds_data.h:362
svxSkFilletData::fltExtOpt
evxSkChamferExtenOpt fltExtOpt
control the path of extended curves
Definition: zwapi_cmd_sk_cmds_data.h:363
svxSkFilletData::secPnt
svxPoint2 secPnt
a point on the second curve
Definition: zwapi_cmd_sk_cmds_data.h:359
svxSkFilletData::idSecCurve
int idSecCurve
second specified curve
Definition: zwapi_cmd_sk_cmds_data.h:358
svxSkFilletData::radius
double radius
radius of fillet
Definition: zwapi_cmd_sk_cmds_data.h:360
svxSkFilletData::firPnt
svxPoint2 firPnt
a point on the first curve
Definition: zwapi_cmd_sk_cmds_data.h:357
svxSkFilletData::designArc
int designArc
flag to use design arc, 0 no else yes
Definition: zwapi_cmd_sk_cmds_data.h:361
svxSkFilletData::idFirCurve
int idFirCurve
first specified curve
Definition: zwapi_cmd_sk_cmds_data.h:356
svxSkFilletData
information of fillet in sheeting or sketch
Definition: zwapi_cmd_sk_cmds_data.h:355
svxSkNgons::center
svxPoint2 center
the center point of polygon. if type != VX_SK_NGONS_SIDE_LEN, and type != VX_SK_NGONS_SIDE_BOUND,...
Definition: zwapi_cmd_sk_cmds_data.h:177
svxSkNgons::corner
svxPoint2 corner
corner point of polygon. if type = VX_SK_NGONS_SIDE_LEN or VX_SK_NGONS_SIDE_BOUND,...
Definition: zwapi_cmd_sk_cmds_data.h:187
svxSkNgons::R
double R
the radius or length of polygon.default:10. if type = VX_SK_NGONS_IN_R, it is radius of circle have...
Definition: zwapi_cmd_sk_cmds_data.h:180
svxSkNgons::type
evxSkNgonsType type
polygon option
Definition: zwapi_cmd_sk_cmds_data.h:176
svxSkNgons::angle
double angle
the rotate angle.default:0
Definition: zwapi_cmd_sk_cmds_data.h:186
svxSkNgons::boundary
svxPoint2 boundary
boundary point of polygon . if type = VX_SK_NGONS_IN_BOUND or VX_SK_NGONS_SIDE_BOUND,...
Definition: zwapi_cmd_sk_cmds_data.h:190
svxSkNgons::numSide
int numSide
number of sides.default:6
Definition: zwapi_cmd_sk_cmds_data.h:185
svxSkNgons
sketch polygon data
Definition: zwapi_cmd_sk_cmds_data.h:175
svxSkPowerTrim::endPnt
svxPoint2 endPnt
end point of power trim
Definition: zwapi_cmd_sk_cmds_data.h:432
svxSkPowerTrim::startPnt
svxPoint2 startPnt
start point of power trim
Definition: zwapi_cmd_sk_cmds_data.h:431
svxSkPowerTrim
sketch power trim data
Definition: zwapi_cmd_sk_cmds_data.h:430
svxSkPtnData::SkPtnData::svxSkCircular::pitch
double pitch
spacing between the instances measured in pitch angle degrees.default:60
Definition: zwapi_cmd_sk_cmds_data.h:776
svxSkPtnData::SkPtnData::svxSkCircular::spacing
evxSkSpacingType spacing
pattern spacing type.default:VX_NUMBER_PITCH
Definition: zwapi_cmd_sk_cmds_data.h:775
svxSkPtnData::SkPtnData::svxSkCircular::num
int num
pattern number.default:2
Definition: zwapi_cmd_sk_cmds_data.h:774
svxSkPtnData::SkPtnData::svxSkCircular::center
svxPntOnEnt center
rotation center point for the pattern.
Definition: zwapi_cmd_sk_cmds_data.h:773
svxSkPtnData::SkPtnData::svxSkCircular::span
double span
spacing between the instances measured in span angle degrees.default:360
Definition: zwapi_cmd_sk_cmds_data.h:777
svxSkPtnData::SkPtnData::svxSkCircular
circular pattern
Definition: zwapi_cmd_sk_cmds_data.h:772
svxSkPtnData::SkPtnData::svxSkLinear::pitch
double pitch[2]
pattern pitch dist in both direction, the second direction is ignored if useSecondDir = 0....
Definition: zwapi_cmd_sk_cmds_data.h:768
svxSkPtnData::SkPtnData::svxSkLinear::useSecondDir
int useSecondDir
0 if user don't use second direction,else 1.default:0
Definition: zwapi_cmd_sk_cmds_data.h:764
svxSkPtnData::SkPtnData::svxSkLinear::spacing
evxSkSpacingType spacing[2]
pattern spacing type in both direction, the second direction is ignored if useSecondDir = 0....
Definition: zwapi_cmd_sk_cmds_data.h:767
svxSkPtnData::SkPtnData::svxSkLinear::dir
svxVector dir[2]
first and second direction.the second direction is ignored if useSecondDir = 0.
Definition: zwapi_cmd_sk_cmds_data.h:765
svxSkPtnData::SkPtnData::svxSkLinear::span
double span[2]
pattern span dist in both direction, the second direction is ignored if useSecondDir = 0....
Definition: zwapi_cmd_sk_cmds_data.h:769
svxSkPtnData::SkPtnData::svxSkLinear::num
int num[2]
pattern number in both direction, the second direction is ignored if useSecondDir = 0....
Definition: zwapi_cmd_sk_cmds_data.h:766
svxSkPtnData::SkPtnData::svxSkLinear
linear pattern
Definition: zwapi_cmd_sk_cmds_data.h:763
svxSkPtnData::SkPtnData::svxSkPtnCrv::pitch
double pitch
pattern pitch dist.default:5
Definition: zwapi_cmd_sk_cmds_data.h:784
svxSkPtnData::SkPtnData::svxSkPtnCrv::spacing
evxSkSpacingType spacing
pattern spacing type.default:VX_NUMBER_PITCH
Definition: zwapi_cmd_sk_cmds_data.h:783
svxSkPtnData::SkPtnData::svxSkPtnCrv::crvid
svxPntOnEnt crvid
pattern curve id
Definition: zwapi_cmd_sk_cmds_data.h:781
svxSkPtnData::SkPtnData::svxSkPtnCrv::num
int num
pattern number.default:2
Definition: zwapi_cmd_sk_cmds_data.h:782
svxSkPtnData::SkPtnData::svxSkPtnCrv
curve pattern
Definition: zwapi_cmd_sk_cmds_data.h:780
svxSkPtnData::secondTogglePos
int * secondTogglePos
the position id of the patterned entities in the second direction (start form 0, the nTH position in ...
Definition: zwapi_cmd_sk_cmds_data.h:789
svxSkPtnData::count
int count
number of entities for pattern
Definition: zwapi_cmd_sk_cmds_data.h:757
svxSkPtnData::addDim
int addDim
whether to add dimension (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_sk_cmds_data.h:759
svxSkPtnData::type
evxSkPatternType type
pattern method
Definition: zwapi_cmd_sk_cmds_data.h:756
svxSkPtnData::cntSkip
int cntSkip
number of the instances to be skipped
Definition: zwapi_cmd_sk_cmds_data.h:787
svxSkPtnData::idEnts
int * idEnts
list of id's of entities
Definition: zwapi_cmd_sk_cmds_data.h:758
svxSkPtnData::firstTogglePos
int * firstTogglePos
the position id of the patterned entities in the first direction (start form 0, the nTH position in t...
Definition: zwapi_cmd_sk_cmds_data.h:788
svxSkPtnData
sketch pattern data
Definition: zwapi_cmd_sk_cmds_data.h:755
svxSkRefData::evxSkRefInpUnion::ReferenceChain::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:263
svxSkRefData::evxSkRefInpUnion::ReferenceChain::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:264
svxSkRefData::evxSkRefInpUnion::ReferenceChain::option
evxSkChainOption option
chain option (VX_SK_CHAIN_PICK as default)
Definition: zwapi_cmd_sk_cmds_data.h:262
svxSkRefData::evxSkRefInpUnion::ReferenceChain
Definition: zwapi_cmd_sk_cmds_data.h:261
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::option
evxSkLoopOption option
loop option (VX_SK_LOOP_ALL as default)
Definition: zwapi_cmd_sk_cmds_data.h:268
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:269
svxSkRefData::evxSkRefInpUnion::ReferenceLoop::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:270
svxSkRefData::evxSkRefInpUnion::ReferenceLoop
Definition: zwapi_cmd_sk_cmds_data.h:267
svxSkRefData::evxSkRefInpUnion::ReferencePoint::pnt
svxPntOnEntPath pnt
reference point
Definition: zwapi_cmd_sk_cmds_data.h:274
svxSkRefData::evxSkRefInpUnion::ReferencePoint
Definition: zwapi_cmd_sk_cmds_data.h:273
svxSkRefData::evxSkRefInpUnion::ReferenceSingle::numEnt
int numEnt
number of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:257
svxSkRefData::evxSkRefInpUnion::ReferenceSingle::entPaths
svxEntPath * entPaths
list paths of entities to reference
Definition: zwapi_cmd_sk_cmds_data.h:258
svxSkRefData::evxSkRefInpUnion::ReferenceSingle
Definition: zwapi_cmd_sk_cmds_data.h:256
svxSkRefData::method
evxSkRefMethod method
reference method (VX_SK_REF_PROJECTION as default)
Definition: zwapi_cmd_sk_cmds_data.h:250
svxSkRefData::constructGeom
int constructGeom
whether to create construction geometry (1 or 0, 1 as default)
Definition: zwapi_cmd_sk_cmds_data.h:278
svxSkRefData::recordState
int recordState
whether to record the state of the history of the part from which the reference geometry is extracted...
Definition: zwapi_cmd_sk_cmds_data.h:279
svxSkRefData::option
evxSkRefOption option
reference option (VX_SK_REF_SINGLE as default)
Definition: zwapi_cmd_sk_cmds_data.h:251
svxSkRefData
sketch reference geometry data
Definition: zwapi_cmd_sk_cmds_data.h:249
svxSkSplitIsect::idEnts
int * idEnts
the id of the entities
Definition: zwapi_cmd_sk_cmds_data.h:491
svxSkSplitIsect::SelfIsect
int SelfIsect
whether split at self intersections (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_sk_cmds_data.h:492
svxSkSplitIsect::CrvIsect
int CrvIsect
whether split at curve-curve intersections (0 = no, 1 = yes).default:1
Definition: zwapi_cmd_sk_cmds_data.h:493
svxSkSplitIsect::Count
int Count
the number of the entities
Definition: zwapi_cmd_sk_cmds_data.h:490
svxSkSplitIsect
sketch split at intersection data
Definition: zwapi_cmd_sk_cmds_data.h:489
svxSkTrimExt::curves
svxPntOnEnt * curves
the start points of the curves need to trim or extend
Definition: zwapi_cmd_sk_cmds_data.h:442
svxSkTrimExt::dest
svxPntOnEnt dest
the destination point of the trim or extend
Definition: zwapi_cmd_sk_cmds_data.h:443
svxSkTrimExt::numCrv
int numCrv
the number of the curve need to trim of extend
Definition: zwapi_cmd_sk_cmds_data.h:441
svxSkTrimExt::extension
evxTrimExtension extension
the extension type.default:VX_EXT_ARC
Definition: zwapi_cmd_sk_cmds_data.h:444
svxSkTrimExt
sketch trim or extend data
Definition: zwapi_cmd_sk_cmds_data.h:440
svxSkTrimSplit::segments
svxPntOnEnt * segments
the list points of segments
Definition: zwapi_cmd_sk_cmds_data.h:456
svxSkTrimSplit::count
int count
the number of the entities
Definition: zwapi_cmd_sk_cmds_data.h:453
svxSkTrimSplit::idEnts
int * idEnts
the id of the entities
Definition: zwapi_cmd_sk_cmds_data.h:454
svxSkTrimSplit::numSeg
int numSeg
the number of segments
Definition: zwapi_cmd_sk_cmds_data.h:455
svxSkTrimSplit::trimOption
evxTrimSplit trimOption
the trim type.default:VX_SPLIT_DELETE
Definition: zwapi_cmd_sk_cmds_data.h:457
svxSkTrimSplitCor::firstPnt
svxPntOnEnt firstPnt
the first point
Definition: zwapi_cmd_sk_cmds_data.h:479
svxSkTrimSplitCor::secondPnt
svxPntOnEnt secondPnt
the second point
Definition: zwapi_cmd_sk_cmds_data.h:480
svxSkTrimSplitCor::extension
evxTrimSplitCor extension
the extension type.default:VX_SPLIT_COR_REFLECT
Definition: zwapi_cmd_sk_cmds_data.h:481
svxSkTrimSplitCor
sketch trim or split to corner data
Definition: zwapi_cmd_sk_cmds_data.h:478
svxSkTrimSplit
sketch trim or split data
Definition: zwapi_cmd_sk_cmds_data.h:452
svxSkTrimSplitPnt::idCrv
int idCrv
the id of the curve
Definition: zwapi_cmd_sk_cmds_data.h:466
svxSkTrimSplitPnt::segments
svxPntOnEnt * segments
the list points of segments
Definition: zwapi_cmd_sk_cmds_data.h:470
svxSkTrimSplitPnt::pnts
svxPntOnEnt * pnts
the list points
Definition: zwapi_cmd_sk_cmds_data.h:468
svxSkTrimSplitPnt::numPnt
int numPnt
the number of point
Definition: zwapi_cmd_sk_cmds_data.h:467
svxSkTrimSplitPnt::numSeg
int numSeg
the number of segments
Definition: zwapi_cmd_sk_cmds_data.h:469
svxSkTrimSplitPnt
sketch trim or split at point data
Definition: zwapi_cmd_sk_cmds_data.h:465
svxVector2
2D vector
Definition: zwapi_util.h:328
svxVector
3D vector
Definition: zwapi_util.h:338
svxMoveData2D::evxMethodsUnion2D::PntToPnt2D
svxMovePntToPnt2D PntToPnt2D
point to point(2D)
Definition: zwapi_cmd_sk_cmds_data.h:675
svxMoveData2D::evxMethodsUnion2D::AlongDir2D
svxAlongDir2D AlongDir2D
along direction data(2D)
Definition: zwapi_cmd_sk_cmds_data.h:674
svxMoveData2D::evxMethodsUnion2D
move data
Definition: zwapi_cmd_sk_cmds_data.h:673
svxReadyText::evxSkTextMethodsUnion
union of sketch text data
Definition: zwapi_cmd_sk_cmds_data.h:138
svxSkAxisData::evxSkAxisMethodsUnion
union of sketch axis data
Definition: zwapi_cmd_sk_cmds_data.h:66
svxSkCopy::svxSkCopyData
union of sketch copy data
Definition: zwapi_cmd_sk_cmds_data.h:833
svxSkPtnData::SkPtnData
union of sketch pattern data
Definition: zwapi_cmd_sk_cmds_data.h:761
svxSkRefData::evxSkRefInpUnion
Definition: zwapi_cmd_sk_cmds_data.h:254
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SKETCH_CREATE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_create.h
cvxHatchPtnDataInit
cvxPartCosSkPlane
cvxPartSkIns
cvxPartSkIns2
cvxPartSkNew
cvxPartSkPlane

◆ ZW_API_SKETCH_CREATE_H

#define ZW_API_SKETCH_CREATE_H

Definition at line 15 of file zwapi_cmd_sk_create.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_create.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_create.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SKETCH_CREATE_H /* this ifndef surrounds entire header */
15#define ZW_API_SKETCH_CREATE_H
16
17#include "zwapi_cmd_sk_create_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
51extern evxErrors cvxPartSkIns(const vxLongPath File,const vxRootName Name, svxMatrix* Plane, int* idSketch);
52
53/******************************************************************************/
84extern evxErrors cvxPartSkIns2(const vxLongPath File,const vxRootName Name, int idPlane, int iAsso, int* idSketch);
85
86/******************************************************************************/
112extern evxErrors cvxPartSkNew(svxMatrix* Plane, int* idSketch);
113
114/******************************************************************************/
141extern evxErrors cvxPartSkPlane(svxSketchData* SkData, int* idSketch);
142
143/******************************************************************************/
160extern evxErrors cvxHatchPtnDataInit(svxHatchPtnData* data);
161
162/******************************************************************************/
194extern evxErrors cvxPartCosSkPlane(const svxSketchData* SkData, int isAddHatPtn, const svxHatchPtnData* PatData, int* idSketch);
195
196
197/*
198*********************************************************************
199** END HEADER FILE
200*********************************************************************
201*/
202#ifdef __cplusplus
203 }
204#endif /* __cplusplus */
205
206#endif /* ZW_API_SKETCH_CREATE_H */
cvxPartSkPlane
evxErrors cvxPartSkPlane(svxSketchData *SkData, int *idSketch)
cvxPartCosSkPlane
evxErrors cvxPartCosSkPlane(const svxSketchData *SkData, int isAddHatPtn, const svxHatchPtnData *PatData, int *idSketch)
cvxPartSkNew
evxErrors cvxPartSkNew(svxMatrix *Plane, int *idSketch)
cvxHatchPtnDataInit
evxErrors cvxHatchPtnDataInit(svxHatchPtnData *data)
cvxPartSkIns
evxErrors cvxPartSkIns(const vxLongPath File, const vxRootName Name, svxMatrix *Plane, int *idSketch)
cvxPartSkIns2
evxErrors cvxPartSkIns2(const vxLongPath File, const vxRootName Name, int idPlane, int iAsso, int *idSketch)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxHatchPtnData
cosmetic sketch hatch pattern definition data
Definition: zwapi_cmd_sk_create_data.h:142
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxSketchData
sketch definition data
Definition: zwapi_cmd_sk_create_data.h:33
zwapi_cmd_sk_create_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SKETCH_CREATE_DATA

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_sk_create_data.h
evxHatchPtnType
evxHatchPtnType
svxHatchPtnData
svxSketchData

◆ ZW_API_SKETCH_CREATE_DATA

#define ZW_API_SKETCH_CREATE_DATA

Definition at line 17 of file zwapi_cmd_sk_create_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_sk_create_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_sk_create_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SKETCH_CREATE_DATA /* this ifndef surrounds entire header */
17#define ZW_API_SKETCH_CREATE_DATA
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef struct svxSketchData
33 {
34 svxEntPath Plane;
36 /* The following parameters are used to define the Y-axis direction of the sketch */
37 int RedefUpDir;
40 int idUpEnt;
41 int idUpParam;
44 svxVector UpDir;
46 /* The following parameters are used to define the XY origin of the sketch */
47 int RedefOrigin;
51 int idOrgEnt;
52 evxGeomCritPnt critPnt;
53 int idPnt;
54 svxPoint Origin;
56 int xDirRev;
57 }svxSketchData;
58
63typedef enum evxHatchPtnType
64 {
65 VX_HATCH_PATTERN_ANSI31,
66 VX_HATCH_PATTERN_ANSI32,
67 VX_HATCH_PATTERN_ANSI33,
68 VX_HATCH_PATTERN_ANSI34,
69 VX_HATCH_PATTERN_ANSI35,
70 VX_HATCH_PATTERN_ANSI36,
71 VX_HATCH_PATTERN_ANSI37,
72 VX_HATCH_PATTERN_ANSI38,
73 VX_HATCH_PATTERN_SHADOW_PLATE,
74 VX_HATCH_PATTERN_BRICK,
75 VX_HATCH_PATTERN_CORK,
76 VX_HATCH_PATTERN_CROSS,
77 VX_HATCH_PATTERN_DASH,
78 VX_HATCH_PATTERN_LIMESTONE,
79 VX_HATCH_PATTERN_DOTS,
80 VX_HATCH_PATTERN_EARTH,
81 VX_HATCH_PATTERN_EXPANSION,
82 VX_HATCH_PATTERN_GRASS,
83 VX_HATCH_PATTERN_GRATE,
84 VX_HATCH_PATTERN_HEXAGON,
85 VX_HATCH_PATTERN_HONEYCOMB,
86 VX_HATCH_PATTERN_SQUARES,
87 VX_HATCH_PATTERN_MOONYANG,
88 VX_HATCH_PATTERN_BOX,
89 VX_HATCH_PATTERN_BRASS,
90 VX_HATCH_PATTERN_BRSTONE,
91 VX_HATCH_PATTERN_CLAY,
92 VX_HATCH_PATTERN_ESCHER,
93 VX_HATCH_PATTERN_GRAVEL,
94 VX_HATCH_PATTERN_HOUND,
95 VX_HATCH_PATTERN_INSUL,
96 VX_HATCH_PATTERN_ACAD_ISO02W100,
97 VX_HATCH_PATTERN_ACAD_ISO03W100,
98 VX_HATCH_PATTERN_ACAD_ISO04W100,
99 VX_HATCH_PATTERN_ACAD_ISO05W100,
100 VX_HATCH_PATTERN_ACAD_ISO06W100,
101 VX_HATCH_PATTERN_ACAD_ISO07W100,
102 VX_HATCH_PATTERN_ACAD_ISO08W100,
103 VX_HATCH_PATTERN_ACAD_ISO09W100,
104 VX_HATCH_PATTERN_ACAD_ISO10W100,
105 VX_HATCH_PATTERN_ACAD_ISO11W100,
106 VX_HATCH_PATTERN_ACAD_ISO12W100,
107 VX_HATCH_PATTERN_ACAD_ISO13W100,
108 VX_HATCH_PATTERN_ACAD_ISO14W100,
109 VX_HATCH_PATTERN_ACAD_ISO15W100,
110 VX_HATCH_PATTERN_JIS_LC_20,
111 VX_HATCH_PATTERN_JIS_LC_20A,
112 VX_HATCH_PATTERN_JIS_LC_8A,
113 VX_HATCH_PATTERN_JIS_LC_8,
114 VX_HATCH_PATTERN_JIS_RC_10,
115 VX_HATCH_PATTERN_JIS_RC_15,
116 VX_HATCH_PATTERN_JIS_RC_18,
117 VX_HATCH_PATTERN_JIS_RC_30,
118 VX_HATCH_PATTERN_JIS_STN_1E,
119 VX_HATCH_PATTERN_JIS_STN_2_5,
120 VX_HATCH_PATTERN_JIS_WOOD,
121 VX_HATCH_PATTERN_LINE,
122 VX_HATCH_PATTERN_MUDST,
123 VX_HATCH_PATTERN_NET,
124 VX_HATCH_PATTERN_NET3,
125 VX_HATCH_PATTERN_PLAST,
126 VX_HATCH_PATTERN_PLASTI,
127 VX_HATCH_PATTERN_SACNCR,
128 VX_HATCH_PATTERN_STARS,
129 VX_HATCH_PATTERN_STEEL,
130 VX_HATCH_PATTERN_SWAMP,
131 VX_HATCH_PATTERN_TRANS,
132 VX_HATCH_PATTERN_TRIANG,
133 VX_HATCH_PATTERN_ZIGZAG,
134 VX_HATCH_PATTERN_SOLID,
135 } evxHatchPtnType;
136
141typedef struct svxHatchPtnData
142 {
143 evxHatchPtnType pattern;
145 double angle;
147 double space;
149 evxColor color;
151 } svxHatchPtnData;
152
153/*
154*********************************************************************
155** END HEADER FILE
156*********************************************************************
157*/
158
159#ifdef __cplusplus
160 }
161#endif /* __cplusplus */
162
163#endif /* ZW_API_SKETCH_CREATE_DATA */
evxHatchPtnType
evxHatchPtnType
hatch pattern method Note: These hatch patterns cannot be described. Please open the ZW3D cosmetic-sk...
Definition: zwapi_cmd_sk_create_data.h:64
VX_HATCH_PATTERN_MUDST
@ VX_HATCH_PATTERN_MUDST
MUDST.
Definition: zwapi_cmd_sk_create_data.h:122
VX_HATCH_PATTERN_JIS_RC_18
@ VX_HATCH_PATTERN_JIS_RC_18
JIS_RC_18.
Definition: zwapi_cmd_sk_create_data.h:116
VX_HATCH_PATTERN_HOUND
@ VX_HATCH_PATTERN_HOUND
HOUND.
Definition: zwapi_cmd_sk_create_data.h:94
VX_HATCH_PATTERN_EARTH
@ VX_HATCH_PATTERN_EARTH
EARTH.
Definition: zwapi_cmd_sk_create_data.h:80
VX_HATCH_PATTERN_ACAD_ISO05W100
@ VX_HATCH_PATTERN_ACAD_ISO05W100
ACAD_ISO05W100.
Definition: zwapi_cmd_sk_create_data.h:99
VX_HATCH_PATTERN_INSUL
@ VX_HATCH_PATTERN_INSUL
INSUL.
Definition: zwapi_cmd_sk_create_data.h:95
VX_HATCH_PATTERN_SOLID
@ VX_HATCH_PATTERN_SOLID
SOLID.
Definition: zwapi_cmd_sk_create_data.h:134
VX_HATCH_PATTERN_TRANS
@ VX_HATCH_PATTERN_TRANS
TRANS.
Definition: zwapi_cmd_sk_create_data.h:131
VX_HATCH_PATTERN_ACAD_ISO07W100
@ VX_HATCH_PATTERN_ACAD_ISO07W100
ACAD_ISO07W100.
Definition: zwapi_cmd_sk_create_data.h:101
VX_HATCH_PATTERN_STEEL
@ VX_HATCH_PATTERN_STEEL
STEEL.
Definition: zwapi_cmd_sk_create_data.h:129
VX_HATCH_PATTERN_JIS_STN_2_5
@ VX_HATCH_PATTERN_JIS_STN_2_5
JIS_STN_2_5.
Definition: zwapi_cmd_sk_create_data.h:119
VX_HATCH_PATTERN_ACAD_ISO03W100
@ VX_HATCH_PATTERN_ACAD_ISO03W100
ACAD_ISO03W100.
Definition: zwapi_cmd_sk_create_data.h:97
VX_HATCH_PATTERN_CLAY
@ VX_HATCH_PATTERN_CLAY
CLAY.
Definition: zwapi_cmd_sk_create_data.h:91
VX_HATCH_PATTERN_SQUARES
@ VX_HATCH_PATTERN_SQUARES
SQUARES.
Definition: zwapi_cmd_sk_create_data.h:86
VX_HATCH_PATTERN_ANSI38
@ VX_HATCH_PATTERN_ANSI38
ANSI38.
Definition: zwapi_cmd_sk_create_data.h:72
VX_HATCH_PATTERN_HONEYCOMB
@ VX_HATCH_PATTERN_HONEYCOMB
HONEYCOMB.
Definition: zwapi_cmd_sk_create_data.h:85
VX_HATCH_PATTERN_ACAD_ISO10W100
@ VX_HATCH_PATTERN_ACAD_ISO10W100
ACAD_ISO10W100.
Definition: zwapi_cmd_sk_create_data.h:104
VX_HATCH_PATTERN_ACAD_ISO09W100
@ VX_HATCH_PATTERN_ACAD_ISO09W100
ACAD_ISO09W100.
Definition: zwapi_cmd_sk_create_data.h:103
VX_HATCH_PATTERN_GRAVEL
@ VX_HATCH_PATTERN_GRAVEL
GRAVEL.
Definition: zwapi_cmd_sk_create_data.h:93
VX_HATCH_PATTERN_ACAD_ISO14W100
@ VX_HATCH_PATTERN_ACAD_ISO14W100
ACAD_ISO14W100.
Definition: zwapi_cmd_sk_create_data.h:108
VX_HATCH_PATTERN_LIMESTONE
@ VX_HATCH_PATTERN_LIMESTONE
LIMESTONE.
Definition: zwapi_cmd_sk_create_data.h:78
VX_HATCH_PATTERN_JIS_RC_15
@ VX_HATCH_PATTERN_JIS_RC_15
JIS_RC_15.
Definition: zwapi_cmd_sk_create_data.h:115
VX_HATCH_PATTERN_PLASTI
@ VX_HATCH_PATTERN_PLASTI
PLASTI.
Definition: zwapi_cmd_sk_create_data.h:126
VX_HATCH_PATTERN_ANSI33
@ VX_HATCH_PATTERN_ANSI33
ANSI33.
Definition: zwapi_cmd_sk_create_data.h:67
VX_HATCH_PATTERN_DASH
@ VX_HATCH_PATTERN_DASH
DASH.
Definition: zwapi_cmd_sk_create_data.h:77
VX_HATCH_PATTERN_ANSI35
@ VX_HATCH_PATTERN_ANSI35
ANSI35.
Definition: zwapi_cmd_sk_create_data.h:69
VX_HATCH_PATTERN_JIS_STN_1E
@ VX_HATCH_PATTERN_JIS_STN_1E
JIS_STN_1E.
Definition: zwapi_cmd_sk_create_data.h:118
VX_HATCH_PATTERN_ESCHER
@ VX_HATCH_PATTERN_ESCHER
ESCHER.
Definition: zwapi_cmd_sk_create_data.h:92
VX_HATCH_PATTERN_ANSI36
@ VX_HATCH_PATTERN_ANSI36
ANSI36.
Definition: zwapi_cmd_sk_create_data.h:70
VX_HATCH_PATTERN_EXPANSION
@ VX_HATCH_PATTERN_EXPANSION
EXPANSION.
Definition: zwapi_cmd_sk_create_data.h:81
VX_HATCH_PATTERN_ANSI37
@ VX_HATCH_PATTERN_ANSI37
ANSI37.
Definition: zwapi_cmd_sk_create_data.h:71
VX_HATCH_PATTERN_GRATE
@ VX_HATCH_PATTERN_GRATE
GRATE.
Definition: zwapi_cmd_sk_create_data.h:83
VX_HATCH_PATTERN_JIS_LC_20A
@ VX_HATCH_PATTERN_JIS_LC_20A
JIS_LC_20A.
Definition: zwapi_cmd_sk_create_data.h:111
VX_HATCH_PATTERN_ACAD_ISO15W100
@ VX_HATCH_PATTERN_ACAD_ISO15W100
ACAD_ISO15W100.
Definition: zwapi_cmd_sk_create_data.h:109
VX_HATCH_PATTERN_SWAMP
@ VX_HATCH_PATTERN_SWAMP
SWAMP.
Definition: zwapi_cmd_sk_create_data.h:130
VX_HATCH_PATTERN_HEXAGON
@ VX_HATCH_PATTERN_HEXAGON
HEXAGON.
Definition: zwapi_cmd_sk_create_data.h:84
VX_HATCH_PATTERN_JIS_RC_10
@ VX_HATCH_PATTERN_JIS_RC_10
JIS_RC_10.
Definition: zwapi_cmd_sk_create_data.h:114
VX_HATCH_PATTERN_GRASS
@ VX_HATCH_PATTERN_GRASS
GRASS.
Definition: zwapi_cmd_sk_create_data.h:82
VX_HATCH_PATTERN_PLAST
@ VX_HATCH_PATTERN_PLAST
PLAST.
Definition: zwapi_cmd_sk_create_data.h:125
VX_HATCH_PATTERN_ACAD_ISO12W100
@ VX_HATCH_PATTERN_ACAD_ISO12W100
ACAD_ISO12W100.
Definition: zwapi_cmd_sk_create_data.h:106
VX_HATCH_PATTERN_ACAD_ISO08W100
@ VX_HATCH_PATTERN_ACAD_ISO08W100
ACAD_ISO08W100.
Definition: zwapi_cmd_sk_create_data.h:102
VX_HATCH_PATTERN_MOONYANG
@ VX_HATCH_PATTERN_MOONYANG
MOONYANG.
Definition: zwapi_cmd_sk_create_data.h:87
VX_HATCH_PATTERN_BRASS
@ VX_HATCH_PATTERN_BRASS
BRASS.
Definition: zwapi_cmd_sk_create_data.h:89
VX_HATCH_PATTERN_TRIANG
@ VX_HATCH_PATTERN_TRIANG
TRIANG.
Definition: zwapi_cmd_sk_create_data.h:132
VX_HATCH_PATTERN_JIS_LC_8
@ VX_HATCH_PATTERN_JIS_LC_8
JIS_LC_8.
Definition: zwapi_cmd_sk_create_data.h:113
VX_HATCH_PATTERN_JIS_LC_20
@ VX_HATCH_PATTERN_JIS_LC_20
JIS_LC_20.
Definition: zwapi_cmd_sk_create_data.h:110
VX_HATCH_PATTERN_JIS_LC_8A
@ VX_HATCH_PATTERN_JIS_LC_8A
JIS_LC_8A.
Definition: zwapi_cmd_sk_create_data.h:112
VX_HATCH_PATTERN_ACAD_ISO02W100
@ VX_HATCH_PATTERN_ACAD_ISO02W100
ACAD_ISO02W100.
Definition: zwapi_cmd_sk_create_data.h:96
VX_HATCH_PATTERN_BOX
@ VX_HATCH_PATTERN_BOX
BOX.
Definition: zwapi_cmd_sk_create_data.h:88
VX_HATCH_PATTERN_SHADOW_PLATE
@ VX_HATCH_PATTERN_SHADOW_PLATE
SHADOW_PLATE.
Definition: zwapi_cmd_sk_create_data.h:73
VX_HATCH_PATTERN_BRSTONE
@ VX_HATCH_PATTERN_BRSTONE
BRSTONE.
Definition: zwapi_cmd_sk_create_data.h:90
VX_HATCH_PATTERN_BRICK
@ VX_HATCH_PATTERN_BRICK
BRICK.
Definition: zwapi_cmd_sk_create_data.h:74
VX_HATCH_PATTERN_ANSI34
@ VX_HATCH_PATTERN_ANSI34
ANSI34.
Definition: zwapi_cmd_sk_create_data.h:68
VX_HATCH_PATTERN_JIS_RC_30
@ VX_HATCH_PATTERN_JIS_RC_30
JIS_RC_30.
Definition: zwapi_cmd_sk_create_data.h:117
VX_HATCH_PATTERN_JIS_WOOD
@ VX_HATCH_PATTERN_JIS_WOOD
JIS_WOOD.
Definition: zwapi_cmd_sk_create_data.h:120
VX_HATCH_PATTERN_LINE
@ VX_HATCH_PATTERN_LINE
LINE.
Definition: zwapi_cmd_sk_create_data.h:121
VX_HATCH_PATTERN_ACAD_ISO11W100
@ VX_HATCH_PATTERN_ACAD_ISO11W100
ACAD_ISO11W100.
Definition: zwapi_cmd_sk_create_data.h:105
VX_HATCH_PATTERN_NET
@ VX_HATCH_PATTERN_NET
NET.
Definition: zwapi_cmd_sk_create_data.h:123
VX_HATCH_PATTERN_CORK
@ VX_HATCH_PATTERN_CORK
CORK.
Definition: zwapi_cmd_sk_create_data.h:75
VX_HATCH_PATTERN_ZIGZAG
@ VX_HATCH_PATTERN_ZIGZAG
ZIGZAG.
Definition: zwapi_cmd_sk_create_data.h:133
VX_HATCH_PATTERN_ACAD_ISO06W100
@ VX_HATCH_PATTERN_ACAD_ISO06W100
ACAD_ISO06W100.
Definition: zwapi_cmd_sk_create_data.h:100
VX_HATCH_PATTERN_ACAD_ISO13W100
@ VX_HATCH_PATTERN_ACAD_ISO13W100
ACAD_ISO13W100.
Definition: zwapi_cmd_sk_create_data.h:107
VX_HATCH_PATTERN_ACAD_ISO04W100
@ VX_HATCH_PATTERN_ACAD_ISO04W100
ACAD_ISO04W100.
Definition: zwapi_cmd_sk_create_data.h:98
VX_HATCH_PATTERN_ANSI31
@ VX_HATCH_PATTERN_ANSI31
ANSI31.
Definition: zwapi_cmd_sk_create_data.h:65
VX_HATCH_PATTERN_NET3
@ VX_HATCH_PATTERN_NET3
NET3.
Definition: zwapi_cmd_sk_create_data.h:124
VX_HATCH_PATTERN_ANSI32
@ VX_HATCH_PATTERN_ANSI32
ANSI32.
Definition: zwapi_cmd_sk_create_data.h:66
VX_HATCH_PATTERN_DOTS
@ VX_HATCH_PATTERN_DOTS
DOTS.
Definition: zwapi_cmd_sk_create_data.h:79
VX_HATCH_PATTERN_STARS
@ VX_HATCH_PATTERN_STARS
STARS.
Definition: zwapi_cmd_sk_create_data.h:128
VX_HATCH_PATTERN_SACNCR
@ VX_HATCH_PATTERN_SACNCR
SACNCR.
Definition: zwapi_cmd_sk_create_data.h:127
VX_HATCH_PATTERN_CROSS
@ VX_HATCH_PATTERN_CROSS
CROSS.
Definition: zwapi_cmd_sk_create_data.h:76
svxHatchPtnData
struct svxHatchPtnData svxHatchPtnData
cosmetic sketch hatch pattern definition data
svxSketchData
struct svxSketchData svxSketchData
sketch definition data
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxGeomCritPnt
evxGeomCritPnt
type of sketch geometry critical point
Definition: zwapi_util.h:534
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxHatchPtnData::color
evxColor color
color attribute default: VX_COLOR_BLACK
Definition: zwapi_cmd_sk_create_data.h:149
svxHatchPtnData::space
double space
spacing attribute default: 3.175
Definition: zwapi_cmd_sk_create_data.h:147
svxHatchPtnData::angle
double angle
angle attribute default: 0.0
Definition: zwapi_cmd_sk_create_data.h:145
svxHatchPtnData::pattern
evxHatchPtnType pattern
hatch pattern method default: VX_HATCH_PATTERN_ANSI31
Definition: zwapi_cmd_sk_create_data.h:143
svxHatchPtnData
cosmetic sketch hatch pattern definition data
Definition: zwapi_cmd_sk_create_data.h:142
svxPoint
3D point
Definition: zwapi_util.h:306
svxSketchData::xDirRev
int xDirRev
whether to reverse X-axis direction
Definition: zwapi_cmd_sk_create_data.h:56
svxSketchData::Plane
svxEntPath Plane
pick path of insertion to locate the sketch (datum plane,planar face,sketch)
Definition: zwapi_cmd_sk_create_data.h:34
svxSketchData::idUpEnt
int idUpEnt
specify the entity used to define the Y-axis, 0 to ignore (edge,curve,axis,datum plane)
Definition: zwapi_cmd_sk_create_data.h:40
svxSketchData::idUpParam
int idUpParam
specify direction of Y-axis (0: use the positive direction of the edge or curve, or X-axis of datum p...
Definition: zwapi_cmd_sk_create_data.h:41
svxSketchData::Origin
svxPoint Origin
origin of sketch, can be ignored if idOrgEnt > 0 and use the critical point of entity
Definition: zwapi_cmd_sk_create_data.h:54
svxSketchData::critPnt
evxGeomCritPnt critPnt
specify the critical point of edge or curve
Definition: zwapi_cmd_sk_create_data.h:52
svxSketchData::RedefOrigin
int RedefOrigin
whether to redefine origin of sketch (0: use the default origin of the insertion plane 1: use centroi...
Definition: zwapi_cmd_sk_create_data.h:47
svxSketchData::idPnt
int idPnt
id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING...
Definition: zwapi_cmd_sk_create_data.h:53
svxSketchData::idOrgEnt
int idOrgEnt
specify the parent entity where the origin locate, 0 to ignore (edge,curve,face,datum plane,...
Definition: zwapi_cmd_sk_create_data.h:51
svxSketchData::UpDir
svxVector UpDir
direction of Y-axis, can be ignored if idUpEnt > 0
Definition: zwapi_cmd_sk_create_data.h:44
svxSketchData::RedefUpDir
int RedefUpDir
whether to redefine Y-axis of sketch (0: use the default direction of the insertion plane 1: use inpu...
Definition: zwapi_cmd_sk_create_data.h:37
svxSketchData
sketch definition data
Definition: zwapi_cmd_sk_create_data.h:33
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SUB_COMMAND_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_subcmd.h
cvxPartPntBy2LinesInit
cvxPartPntByOffsetInit

◆ ZW_API_SUB_COMMAND_H

#define ZW_API_SUB_COMMAND_H

Definition at line 15 of file zwapi_cmd_subcmd.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_subcmd.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_subcmd.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SUB_COMMAND_H /* this ifndef surrounds entire header */
15#define ZW_API_SUB_COMMAND_H
16
17#include "zwapi_cmd_subcmd_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxPartPntByOffsetInit(svxPntByOffset* data, int useCirPnt);
46
47/******************************************************************************/
67extern evxErrors cvxPartPntBy2LinesInit(svxPntBy2Lines* data, int useCirPnt);
68
69
70/*
71*********************************************************************
72** END HEADER FILE
73*********************************************************************
74*/
75
76#ifdef __cplusplus
77 }
78#endif /* __cplusplus */
79
80#endif /* zwapi_cmd_subcmd_data */
cvxPartPntByOffsetInit
evxErrors cvxPartPntByOffsetInit(svxPntByOffset *data, int useCirPnt)
cvxPartPntBy2LinesInit
evxErrors cvxPartPntBy2LinesInit(svxPntBy2Lines *data, int useCirPnt)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPntBy2Lines
the data to get the point by From 2 Lines command
Definition: zwapi_cmd_subcmd_data.h:45
svxPntByOffset
the data to get the point by Offset command
Definition: zwapi_cmd_subcmd_data.h:33
zwapi_cmd_subcmd_data.h
Generated at Sun Apr 23 2023 16:41:33 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SUB_COMMAND_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_subcmd_data.h
evxDistanceMethod
evxDistanceMethod
svxLoftBndCons
svxPntBy2Lines
svxPntByOffset

◆ ZW_API_SUB_COMMAND_DATA_H

#define ZW_API_SUB_COMMAND_DATA_H

Definition at line 17 of file zwapi_cmd_subcmd_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_subcmd_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_subcmd_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SUB_COMMAND_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_SUB_COMMAND_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef struct svxPntByOffset
33 {
34 svxPntOnEnt pntOnEnt;
35 double xOffset;
36 double yOffset;
37 double zOffset;
38 }svxPntByOffset;
39
44typedef struct svxPntBy2Lines
45 {
46 svxPntOnEnt pntOnCrv1;
47 svxPntOnEnt pntOnCrv2;
48 double dDst1;
49 double dDst2;
50 }svxPntBy2Lines;
51
56typedef enum evxDistanceMethod
57 {
58 VX_INPU_VALUE = 0,
59 VX_BY_THROUGH_ALL = 1,
60 VX_TO_POINT = 2,
61 VX_TO_FACES = 3,
62 VX_TO_EXTEND_FACE = 4,
63 VX_TO_FACE = 5,
64 } evxDistanceMethod;
65
70typedef struct svxLoftBndCons
71 {
72 int continuity;
73 int direction;
74 double weight;
75 int idFace;
77 } svxLoftBndCons;
78
79/*
80*********************************************************************
81** END HEADER FILE
82*********************************************************************
83*/
84
85#ifdef __cplusplus
86 }
87#endif /* __cplusplus */
88
89#endif /* ZW_API_SUB_COMMAND_DATA_H */
90
evxDistanceMethod
evxDistanceMethod
the distance method of the distance field, it can set the value by the specified sub-command
Definition: zwapi_cmd_subcmd_data.h:57
VX_TO_POINT
@ VX_TO_POINT
the start/end field by the to point method
Definition: zwapi_cmd_subcmd_data.h:60
VX_TO_FACES
@ VX_TO_FACES
the start/end field by the to faces method
Definition: zwapi_cmd_subcmd_data.h:61
VX_INPU_VALUE
@ VX_INPU_VALUE
the start/end field by the input number
Definition: zwapi_cmd_subcmd_data.h:58
VX_TO_EXTEND_FACE
@ VX_TO_EXTEND_FACE
the start/end field by the to extend face method(extrude)
Definition: zwapi_cmd_subcmd_data.h:62
VX_BY_THROUGH_ALL
@ VX_BY_THROUGH_ALL
the start/end field by the through all method
Definition: zwapi_cmd_subcmd_data.h:59
VX_TO_FACE
@ VX_TO_FACE
the start/end field by the to extend face method (normal cut)
Definition: zwapi_cmd_subcmd_data.h:63
svxPntBy2Lines
struct svxPntBy2Lines svxPntBy2Lines
the data to get the point by From 2 Lines command
svxLoftBndCons
struct svxLoftBndCons svxLoftBndCons
loft boundary constraints
svxPntByOffset
struct svxPntByOffset svxPntByOffset
the data to get the point by Offset command
svxLoftBndCons::idFace
int idFace
id of tangency, it's ignored when a single face on the edges or continuity = 0, 0 to use default face
Definition: zwapi_cmd_subcmd_data.h:75
svxLoftBndCons::continuity
int continuity
specify the continuity level at end of loft (0 = None, 1 = tangent, 2 = curvature,...
Definition: zwapi_cmd_subcmd_data.h:72
svxLoftBndCons::weight
double weight
specify the amount of the loft affected by the enforcement of tangency
Definition: zwapi_cmd_subcmd_data.h:74
svxLoftBndCons::direction
int direction
specify direction of loft at start and end profiles (0 = perpendicular, 1 = along edges)
Definition: zwapi_cmd_subcmd_data.h:73
svxLoftBndCons
loft boundary constraints
Definition: zwapi_cmd_subcmd_data.h:71
svxPntBy2Lines::dDst1
double dDst1
distance from the first edge/line
Definition: zwapi_cmd_subcmd_data.h:48
svxPntBy2Lines::pntOnCrv1
svxPntOnEnt pntOnCrv1
point on first edge/line
Definition: zwapi_cmd_subcmd_data.h:46
svxPntBy2Lines::dDst2
double dDst2
distance from the second edge/line
Definition: zwapi_cmd_subcmd_data.h:49
svxPntBy2Lines::pntOnCrv2
svxPntOnEnt pntOnCrv2
point on second edge/line
Definition: zwapi_cmd_subcmd_data.h:47
svxPntBy2Lines
the data to get the point by From 2 Lines command
Definition: zwapi_cmd_subcmd_data.h:45
svxPntByOffset::yOffset
double yOffset
y offset value
Definition: zwapi_cmd_subcmd_data.h:36
svxPntByOffset::zOffset
double zOffset
z offset value
Definition: zwapi_cmd_subcmd_data.h:37
svxPntByOffset::pntOnEnt
svxPntOnEnt pntOnEnt
point on entity
Definition: zwapi_cmd_subcmd_data.h:34
svxPntByOffset::xOffset
double xOffset
x offset value
Definition: zwapi_cmd_subcmd_data.h:35
svxPntByOffset
the data to get the point by Offset command
Definition: zwapi_cmd_subcmd_data.h:33
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_UDF_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_udf.h
cvxPartFtrIsUDF
cvxPartUDFExplode
cvxPartUDFInit
cvxPartUDFInqFlds
cvxPartUDFInqLongPath
cvxPartUDFInqPath
cvxPartUDFInqSubFtrs
cvxPartUDFInsPathGet
cvxPartUDFInsPathGetByLongPath
cvxPartUDFInsPathSet
cvxPartUDFReplace
cvxPartUDFTerm
cvxPartUDFWizardPathGet
cvxPartUDFWizardPathGetByLongPath
cvxPartUDFWizardPathSet

◆ ZW_API_UDF_H

#define ZW_API_UDF_H

Definition at line 15 of file zwapi_cmd_udf.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_udf.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_udf.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_UDF_H /* this ifndef surrounds entire header */
15#define ZW_API_UDF_H
16
17#include "zwapi_cmd_udf_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
46extern evxErrors cvxPartUDFInit(const vxLongPath udfPath);
47
48/******************************************************************************/
67extern evxErrors cvxPartUDFInqFlds(int* cnt, svxUDFParam** fldParams);
68
69/******************************************************************************/
75extern void cvxPartUDFTerm();
76
77/******************************************************************************/
93extern evxErrors cvxPartUDFExplode(int idFtr);
94
95
96//====================================================================================================================
98//====================================================================================================================
99/******************************************************************************/
115extern evxErrors cvxPartUDFInqPath(int idFtr, vxPath file);
116
117/******************************************************************************/
134extern evxErrors cvxPartUDFInqLongPath(int idFtr, char *file,int sizefile);
135
136/******************************************************************************/
158extern evxErrors cvxPartUDFInqSubFtrs(int idFtr, int* count, int** ftrList);
159
160/******************************************************************************/
175extern evxErrors cvxPartFtrIsUDF(int idFtr, int* isUDF);
176
177/******************************************************************************/
193extern evxErrors cvxPartUDFReplace(int idFtr, const vxLongPath file);
194
195
196//====================================================================================================================
198//====================================================================================================================
199/******************************************************************************/
212extern evxErrors cvxPartUDFWizardPathSet(const vxLongPath path);
213
214/******************************************************************************/
227extern evxErrors cvxPartUDFInsPathSet(const vxLongPath path);
228
229/******************************************************************************/
243extern evxErrors cvxPartUDFWizardPathGet(vxPath Dir);
244
245/******************************************************************************/
264extern evxErrors cvxPartUDFWizardPathGetByLongPath(char* Dir,int sizeDir);
265
266/******************************************************************************/
280extern evxErrors cvxPartUDFInsPathGet(vxPath Dir);
281
282/******************************************************************************/
299extern evxErrors cvxPartUDFInsPathGetByLongPath(char* Dir, int sizeDir);
300
301/*
302*********************************************************************
303** END HEADER FILE
304*********************************************************************
305*/
306
307#ifdef __cplusplus
308 }
309#endif /* __cplusplus */
310
311#endif /* ZW_API_UDF_H */
cvxPartUDFWizardPathGetByLongPath
evxErrors cvxPartUDFWizardPathGetByLongPath(char *Dir, int sizeDir)
cvxPartUDFInsPathGetByLongPath
evxErrors cvxPartUDFInsPathGetByLongPath(char *Dir, int sizeDir)
cvxPartFtrIsUDF
evxErrors cvxPartFtrIsUDF(int idFtr, int *isUDF)
cvxPartUDFInqFlds
evxErrors cvxPartUDFInqFlds(int *cnt, svxUDFParam **fldParams)
cvxPartUDFTerm
void cvxPartUDFTerm()
cvxPartUDFWizardPathSet
evxErrors cvxPartUDFWizardPathSet(const vxLongPath path)
cvxPartUDFExplode
evxErrors cvxPartUDFExplode(int idFtr)
cvxPartUDFInqLongPath
evxErrors cvxPartUDFInqLongPath(int idFtr, char *file, int sizefile)
cvxPartUDFInit
evxErrors cvxPartUDFInit(const vxLongPath udfPath)
cvxPartUDFInsPathGet
evxErrors cvxPartUDFInsPathGet(vxPath Dir)
cvxPartUDFInsPathSet
evxErrors cvxPartUDFInsPathSet(const vxLongPath path)
cvxPartUDFInqPath
evxErrors cvxPartUDFInqPath(int idFtr, vxPath file)
cvxPartUDFReplace
evxErrors cvxPartUDFReplace(int idFtr, const vxLongPath file)
cvxPartUDFWizardPathGet
evxErrors cvxPartUDFWizardPathGet(vxPath Dir)
cvxPartUDFInqSubFtrs
evxErrors cvxPartUDFInqSubFtrs(int idFtr, int *count, int **ftrList)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxUDFParam
field parameters of UDF command
Definition: zwapi_cmd_udf_data.h:33
zwapi_cmd_udf_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_UDF_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_udf_data.h
svxUDFParam

◆ ZW_API_UDF_DATA_H

#define ZW_API_UDF_DATA_H

Definition at line 17 of file zwapi_cmd_udf_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_udf_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_udf_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_UDF_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_UDF_DATA_H
18
19#include "zwapi_cmd_data.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef struct svxUDFParam
33 {
34 int fld_id;
35 int is_list;
36 evxFldType fld_type;
37 vxLongName description;
38 }svxUDFParam;
39
40/*
41*********************************************************************
42** END HEADER FILE
43*********************************************************************
44*/
45
46#ifdef __cplusplus
47 }
48#endif /* __cplusplus */
49
50#endif /* ZW_API_UDF_H */
evxFldType
evxFldType
point input data types
Definition: zwapi_cmd_data.h:136
svxUDFParam
struct svxUDFParam svxUDFParam
field parameters of UDF command
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
svxUDFParam::is_list
int is_list
1- is list, else 0
Definition: zwapi_cmd_udf_data.h:35
svxUDFParam::fld_type
evxFldType fld_type
type of field
Definition: zwapi_cmd_udf_data.h:36
svxUDFParam::fld_id
int fld_id
id of field
Definition: zwapi_cmd_udf_data.h:34
svxUDFParam::description
vxLongName description
description of parameter, use to set the different data
Definition: zwapi_cmd_udf_data.h:37
svxUDFParam
field parameters of UDF command
Definition: zwapi_cmd_udf_data.h:33
zwapi_cmd_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_WIREFRAME_FTR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_wireframe.h
cvxPartArc
cvxPartArc3pt
cvxPartArcInit
cvxPartArcRad
cvxPartBlendCrvs
cvxPartBlendCrvsConsInit
cvxPartBlendCrvsInit
cvxPartCir3pt
cvxPartCircle
cvxPartCircleInit
cvxPartCirRad
cvxPartCombinedProj
cvxPartConcentricArc
cvxPartCrvChamfer
cvxPartCrvChamferChain
cvxPartCrvChamferChainInit
cvxPartCrvChamferInit
cvxPartCrvConvertToArcs
cvxPartCrvConvertToArcsInit
cvxPartCrvFillet
cvxPartCrvFilletChain
cvxPartCrvFilletChainInit
cvxPartCrvFilletInit
cvxPartCrvInt
cvxPartCrvIntInit
cvxPartCrvIntScaleInit
cvxPartCrvList
cvxPartCrvOnFaceThruPts
cvxPartCrvOnFaceThruPtsInit
cvxPartCrvProjToFace
cvxPartCrvProjToFaceInit
cvxPartCrvSplitAtPnts
cvxPartCrvTrimToFaces
cvxPartCrvTrimWithCrv
cvxPartCurve
cvxPartCurveOffset
cvxPartCurveSilh
cvxPartEllipse
cvxPartEllipseInit
cvxPartExtractCenterlines
cvxPartFaceCurve
cvxPartFittingCrv
cvxPartInqReversedCurve
cvxPartInterXCurve
cvxPartInterXCurveInit
cvxPartIsoclineCurve
cvxPartIsoclineCurveInit
cvxPartIsoCurveOnFace
cvxPartIsoCurveOnFaceInit
cvxPartLine
cvxPartLine2pt
cvxPartLineInit
cvxPartPnt
cvxPartPntNew
cvxPartPnts
cvxPartPntsOnCrv
cvxPartPolyLine
cvxPartPolylineInit
cvxPartRectangle
cvxPartRectangleInit
cvxPartSpiralCurve
cvxPartSpline
cvxPartSplineInit
cvxSplinePntInit

◆ ZW_API_WIREFRAME_FTR_H

#define ZW_API_WIREFRAME_FTR_H

Definition at line 15 of file zwapi_cmd_wireframe.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_wireframe.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_wireframe.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_WIREFRAME_FTR_H /* this ifndef surrounds entire header */
15#define ZW_API_WIREFRAME_FTR_H
16
17#include "zwapi_cmd_wireframe_data.h"
18
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24//====================================================================================================================
26//====================================================================================================================
27/******************************************************************************/
47extern evxErrors cvxPartPnt(svxPoint* Point, int* idEnt);
48
49/******************************************************************************/
76extern evxErrors cvxPartPntNew(int Count, const svxPntOnEntPath* PntData, int idAlignPln, int PrjToPln, int* idPntFtr);
77
78/******************************************************************************/
96extern evxErrors cvxPartPnts(int Count, svxPoint* Points);
97
98/******************************************************************************/
139extern evxErrors cvxPartPntsOnCrv(int idCrv, svxPoint* Pnt, int Num, double Dist, evxExtendOpt Opt, int* Count, int** idEnts);
140
141/******************************************************************************/
163extern evxErrors cvxPartLine2pt(svxPoint* Start, svxPoint* End, int* idEnt);
164
165/******************************************************************************/
181extern evxErrors cvxPartLineInit(svxLineData* lineData);
182
183/******************************************************************************/
204extern evxErrors cvxPartLine(const svxLineData* lineData, int* idLine);
205
206/******************************************************************************/
222extern evxErrors cvxPartPolylineInit(svxPolylineData* data);
223
224/******************************************************************************/
248extern evxErrors cvxPartPolyLine(const svxPolylineData* polylinedata, int* Cnt, int** idEnt);
249
250/******************************************************************************/
272extern evxErrors cvxPartArc3pt(svxPoint* Start, svxPoint* End, svxPoint* Mid, int* idEnt);
273
274/******************************************************************************/
297extern evxErrors cvxPartArcRad(svxMatrix* Plane, double Radius, double Start, double End, int* idEnt);
298
299/******************************************************************************/
315extern evxErrors cvxPartArcInit(svxArcData* arcData);
316
317/******************************************************************************/
338extern evxErrors cvxPartArc(const svxArcData* arcData, int* idArc);
339
340/******************************************************************************/
356extern evxErrors cvxPartCircleInit(svxCircleData* circleData);
357
358/******************************************************************************/
379extern evxErrors cvxPartCircle(const svxCircleData* circleData, int* idCircle);
380
381/******************************************************************************/
399extern evxErrors cvxPartRectangleInit(svxRectangleData* data);
400
401/******************************************************************************/
427extern evxErrors cvxPartRectangle(svxRectangleData* rectData, int* iCnt, int** idEnt);
428
429/******************************************************************************/
450extern evxErrors cvxPartCir3pt(svxPoint* P1, svxPoint* P2, svxPoint* P3, int* idEnt);
451
452/******************************************************************************/
472extern evxErrors cvxPartCirRad(svxMatrix* Plane, double Radius, int* idEnt);
473
474/******************************************************************************/
491extern evxErrors cvxPartEllipseInit(svxRectangleData* data);
492
493/******************************************************************************/
517extern evxErrors cvxPartEllipse(svxRectangleData* ellipseData, int* idEnt);
518
519//====================================================================================================================
521//====================================================================================================================
522/******************************************************************************/
539extern evxErrors cvxPartCrvIntInit(svxCrvIntData* data);
540
541/******************************************************************************/
556extern evxErrors cvxPartCrvIntScaleInit(int nPnt, const svxPoint* pPnts, double* startScale, double* endScale);
557
558/******************************************************************************/
585extern evxErrors cvxPartCrvInt(svxCrvIntData* Crv, int* idEnt);
586
587/******************************************************************************/
614extern evxErrors cvxPartSplineInit(svxSplineData* data, int count);
615
616/******************************************************************************/
633extern evxErrors cvxSplinePntInit(svxSplinePnt* data);
634
635/******************************************************************************/
658extern evxErrors cvxPartSpline(const svxSplineData* PntData, int* idEnt);
659
660/******************************************************************************/
676extern evxErrors cvxPartCrvProjToFaceInit(svxCrvProjToFace* data);
677
678/******************************************************************************/
706extern evxErrors cvxPartCrvProjToFace(const svxCrvProjToFace* data, int* cntEnts, int** pEnts);
707
708/******************************************************************************/
725extern evxErrors cvxPartInterXCurveInit(svxInterCrvData* data);
726
727/******************************************************************************/
750extern evxErrors cvxPartInterXCurve(const svxInterCrvData* pSurf, int* idFtr);
751
752/******************************************************************************/
768extern evxErrors cvxPartCrvOnFaceThruPtsInit(svxCrvOnFaceThuPts* data);
769
770/******************************************************************************/
792extern evxErrors cvxPartCrvOnFaceThruPts(const svxCrvOnFaceThuPts* data, int* idEnt);
793
794/******************************************************************************/
811extern evxErrors cvxPartIsoCurveOnFaceInit(svxIsoCrvOnFaceData* data, evxCrvIsoType crvIsoType);
812
813/******************************************************************************/
840extern evxErrors cvxPartIsoCurveOnFace(const svxIsoCrvOnFaceData* data, int* cntEnts, int** idEnts);
841
842/******************************************************************************/
859extern evxErrors cvxPartIsoclineCurveInit(svxIsoclineCrvData* data, evxIsoclineCrvType type);
860
861/******************************************************************************/
886extern evxErrors cvxPartIsoclineCurve(const svxIsoclineCrvData* data, int* cntEnts, int** idEnts);
887
888/******************************************************************************/
912extern evxErrors cvxPartFaceCurve(const svxFaceCrvData* data, int* cntEnts, int** idEnts);
913
914/******************************************************************************/
939extern evxErrors cvxPartCombinedProj(const svxCrvCombinedProjData* data, int* cntEnts, int** idEnts);
940
941/******************************************************************************/
966extern evxErrors cvxPartExtractCenterlines(int cntFaces, int* idFaces, int extractAxis, int* cntEnts, int** idEnts);
967
968/******************************************************************************/
985extern evxErrors cvxPartBlendCrvsConsInit(svxCrvBlendCons* consData, evxCrvBlendObjType objType);
986
987/******************************************************************************/
1003extern evxErrors cvxPartBlendCrvsInit(svxCrvBlendData* data);
1004
1005/******************************************************************************/
1027extern evxErrors cvxPartBlendCrvs(const svxCrvBlendData* data, int* idEnt);
1028
1029/******************************************************************************/
1049extern evxErrors cvxPartCurveOffset(int idCurve, double Dis, int* idOut);
1050
1051/******************************************************************************/
1070extern evxErrors cvxPartSpiralCurve(const svxSpiralCrvData* data, int* idEnt);
1071
1072/******************************************************************************/
1094extern evxErrors cvxPartCrvList(int Count, int* Curves, int* idEnt);
1095
1096/******************************************************************************/
1114extern evxErrors cvxPartCurve(svxCurve* Crv, int* idEnt);
1115
1116/******************************************************************************/
1139extern evxErrors cvxPartCurveSilh(int idCurve, svxPoint* dir, int* iCnt, int** idList);
1140
1141/******************************************************************************/
1164extern evxErrors cvxPartFittingCrv(int iCnt, svxPoint* pnts, double tol, double smth, int* idEnt);
1165
1166//====================================================================================================================
1168//====================================================================================================================
1169/******************************************************************************/
1185extern evxErrors cvxPartCrvFilletInit(svxCrvFilletData* data);
1186
1187/******************************************************************************/
1205extern evxErrors cvxPartCrvFillet(const svxCrvFilletData* data, int* idFillet);
1206
1207/******************************************************************************/
1223extern evxErrors cvxPartCrvFilletChainInit(svxCrvFilletChainData* data);
1224
1225/******************************************************************************/
1243extern evxErrors cvxPartCrvFilletChain(const svxCrvFilletChainData* data, int* idFilletChain);
1244
1245/******************************************************************************/
1261extern evxErrors cvxPartCrvChamferInit(svxCrvChamferData* data);
1262
1263/******************************************************************************/
1283extern evxErrors cvxPartCrvChamfer(const svxCrvChamferData* data, int* idChamfer);
1284
1285/******************************************************************************/
1301extern evxErrors cvxPartCrvChamferChainInit(svxCrvChamferChainData* data);
1302
1303/******************************************************************************/
1325extern evxErrors cvxPartCrvChamferChain(const svxCrvChamferChainData* data, int* idChamfer);
1326
1327/******************************************************************************/
1345extern evxErrors cvxPartCrvTrimToFaces(const svxCrvTrimToFacesData* data, int* idTrim);
1346
1347/******************************************************************************/
1374extern evxErrors cvxPartCrvSplitAtPnts(int idCurve, int CountPnts, svxPoint* Points, int* CountCrvs, int** NewCrvs);
1375
1376/******************************************************************************/
1393extern evxErrors cvxPartInqReversedCurve(int idEnt, svxCurve* data);
1394
1395/******************************************************************************/
1421extern evxErrors cvxPartCrvTrimWithCrv(const svxTrimWithCrvData* data, int* CountCrvs, int** NewCrvs);
1422
1423/******************************************************************************/
1442extern evxErrors cvxPartConcentricArc(int refArc, double radius, int* idEnt);
1443
1444/******************************************************************************/
1461extern evxErrors cvxPartCrvConvertToArcsInit(svxCrvConvertTocData* data);
1462
1463/******************************************************************************/
1482extern evxErrors cvxPartCrvConvertToArcs(const svxCrvConvertTocData* data, int* cntArcs, int** idArcs);
1483
1484//====================================================================================================================
1486//====================================================================================================================
1487/**********************************************************************
1488*! -Pattern Geometry- : zwapi_cmd_shape.h
1489* extern int cvxPartPatternGeom(int Count, int* idEnts, const svxPtnGeom* Pattern, int* idPattern);
1490**********************************************************************/
1491
1492/**********************************************************************
1493*! -Pattern Feature- : zwapi_cmd_shape.h
1494* extern int cvxPartPatternFtr(int Count, int* idFtrs, const svxPtnFtr* Pattern, int* idPattern);
1495**********************************************************************/
1496
1497/**********************************************************************
1498*! -Mirror Geometry- : zwapi_cmd_shape.h
1499* extern int cvxPartMirrorGeom(svxMirrorGeom* Mirror, int* NumNewEnts, int** idNewEnts);
1500**********************************************************************/
1501
1502/**********************************************************************
1503*! -Mirror Feature- : zwapi_cmd_shape.h
1504* extern int cvxPartMirrorFtr(svxMirrorFtr* Mirror, int* idFtr);
1505**********************************************************************/
1506
1507/**********************************************************************
1508*! -Move- : zwapi_cmd_shape.h
1509* extern int cvxPartMove(const svxMoveData *Move, int *idMove);
1510**********************************************************************/
1511
1512/**********************************************************************
1513*! -Copy- : zwapi_cmd_shape.h
1514* extern int cvxPartCopy(const svxCopyData *Copy, int *idCopy);
1515**********************************************************************/
1516
1517/**********************************************************************
1518*! -Scale- : zwapi_cmd_shape.h
1519* extern int cvxPartScale(int Count, int* idEnts, double X, double Y, double Z, int idDatum);
1520* extern int cvxPartScale2(int Count, int* idEnts, double X, double Y, double Z, int idDatum, svxPoint* CentPnt);
1521**********************************************************************/
1522
1523//====================================================================================================================
1525//====================================================================================================================
1526/**********************************************************************
1527*! -Datum Axis- : zwapi_cmd_datum.h
1528* extern int cvxPartAxisNew(svxAxisData *Axis, int *idAxis);
1529**********************************************************************/
1530
1531/**********************************************************************
1532*! -Datum Plane- : zwapi_cmd_datum.h
1533* extern int cvxPartDatum(svxMatrix* Frame, int* idDatum);
1534* extern int cvxPartDatum2(svxMatrix* Frame, int iCode, int* idDatum);
1535* extern int cvxPartNewDatum(svxMatrix* Frame, int* idDatum);
1536* extern int cvxPartPlnCrv(int idCrv, svxPoint* Origin, svxPoint* Xaxis, int* idPln);
1537* extern int cvxPartPlnCrv2(int idCrv, svxData* Origin, svxData* Xaxis, int Flip, int* idPln);
1538* extern int cvxPartPlnSrf(int idFace, svxPoint* Origin, int* idPln);
1539* extern int cvxPartPlnSrf2(int idFace, svxPoint* Origin, svxPoint* XZ, int Flip, int* idPln);
1540* extern int cvxPartPlaneNew(svxPlaneData* Plane, int* idPlane);
1541* extern int cvxPartPlaneAddInit(evxNewPlaneMethods method, svxNewPlaneData* data);
1542* extern int cvxPartPlaneAdd(const svxNewPlaneData* plane, int* idPlane);
1543**********************************************************************/
1544
1545/**********************************************************************
1546*! -Datum CSYS- : zwapi_cmd_datum.h
1547* extern int cvxPartCSYSNewInit(evxCSYSMethods method, svxCSYSData* data);
1548* extern int cvxPartCSYSNew(svxCSYSData* CSYS, int* idCSYS);
1549**********************************************************************/
1550
1551/**********************************************************************
1552*! -LCS- : zwapi_cmd_datum.h
1553* extern int cvxPartActiveAsLCS(int id);
1554**********************************************************************/
1555/*
1556*********************************************************************
1557** END HEADER FILE
1558*********************************************************************
1559*/
1560
1561#ifdef __cplusplus
1562 }
1563#endif /* __cplusplus */
1564
1565#endif /* ZW_API_WIREFRAME_FTR_H */
evxIsoclineCrvType
evxIsoclineCrvType
create isocline curve with a single angle/multiple angles
Definition: zwapi_cmd_wireframe_data.h:289
evxCrvIsoType
evxCrvIsoType
iso-curve type
Definition: zwapi_cmd_wireframe_data.h:236
evxCrvBlendObjType
evxCrvBlendObjType
select a curve or face as object to start/end blended
Definition: zwapi_cmd_wireframe_data.h:428
cvxPartPntsOnCrv
evxErrors cvxPartPntsOnCrv(int idCrv, svxPoint *Pnt, int Num, double Dist, evxExtendOpt Opt, int *Count, int **idEnts)
cvxPartFittingCrv
evxErrors cvxPartFittingCrv(int iCnt, svxPoint *pnts, double tol, double smth, int *idEnt)
cvxPartBlendCrvsInit
evxErrors cvxPartBlendCrvsInit(svxCrvBlendData *data)
cvxPartCrvInt
evxErrors cvxPartCrvInt(svxCrvIntData *Crv, int *idEnt)
cvxPartCrvConvertToArcsInit
evxErrors cvxPartCrvConvertToArcsInit(svxCrvConvertTocData *data)
cvxPartFaceCurve
evxErrors cvxPartFaceCurve(const svxFaceCrvData *data, int *cntEnts, int **idEnts)
cvxPartRectangleInit
evxErrors cvxPartRectangleInit(svxRectangleData *data)
cvxPartIsoCurveOnFaceInit
evxErrors cvxPartIsoCurveOnFaceInit(svxIsoCrvOnFaceData *data, evxCrvIsoType crvIsoType)
cvxPartInterXCurveInit
evxErrors cvxPartInterXCurveInit(svxInterCrvData *data)
cvxPartSpiralCurve
evxErrors cvxPartSpiralCurve(const svxSpiralCrvData *data, int *idEnt)
cvxPartPolyLine
evxErrors cvxPartPolyLine(const svxPolylineData *polylinedata, int *Cnt, int **idEnt)
cvxPartCrvOnFaceThruPtsInit
evxErrors cvxPartCrvOnFaceThruPtsInit(svxCrvOnFaceThuPts *data)
cvxPartConcentricArc
evxErrors cvxPartConcentricArc(int refArc, double radius, int *idEnt)
cvxPartCrvChamferChainInit
evxErrors cvxPartCrvChamferChainInit(svxCrvChamferChainData *data)
cvxPartIsoclineCurve
evxErrors cvxPartIsoclineCurve(const svxIsoclineCrvData *data, int *cntEnts, int **idEnts)
cvxPartCrvChamfer
evxErrors cvxPartCrvChamfer(const svxCrvChamferData *data, int *idChamfer)
cvxPartPnts
evxErrors cvxPartPnts(int Count, svxPoint *Points)
cvxPartCrvTrimToFaces
evxErrors cvxPartCrvTrimToFaces(const svxCrvTrimToFacesData *data, int *idTrim)
cvxPartCrvChamferChain
evxErrors cvxPartCrvChamferChain(const svxCrvChamferChainData *data, int *idChamfer)
cvxPartLineInit
evxErrors cvxPartLineInit(svxLineData *lineData)
cvxPartBlendCrvsConsInit
evxErrors cvxPartBlendCrvsConsInit(svxCrvBlendCons *consData, evxCrvBlendObjType objType)
cvxPartCrvFilletChain
evxErrors cvxPartCrvFilletChain(const svxCrvFilletChainData *data, int *idFilletChain)
cvxPartCircle
evxErrors cvxPartCircle(const svxCircleData *circleData, int *idCircle)
cvxPartLine
evxErrors cvxPartLine(const svxLineData *lineData, int *idLine)
cvxSplinePntInit
evxErrors cvxSplinePntInit(svxSplinePnt *data)
cvxPartArcInit
evxErrors cvxPartArcInit(svxArcData *arcData)
cvxPartCombinedProj
evxErrors cvxPartCombinedProj(const svxCrvCombinedProjData *data, int *cntEnts, int **idEnts)
cvxPartPntNew
evxErrors cvxPartPntNew(int Count, const svxPntOnEntPath *PntData, int idAlignPln, int PrjToPln, int *idPntFtr)
cvxPartCrvProjToFace
evxErrors cvxPartCrvProjToFace(const svxCrvProjToFace *data, int *cntEnts, int **pEnts)
cvxPartCircleInit
evxErrors cvxPartCircleInit(svxCircleData *circleData)
cvxPartEllipse
evxErrors cvxPartEllipse(svxRectangleData *ellipseData, int *idEnt)
cvxPartEllipseInit
evxErrors cvxPartEllipseInit(svxRectangleData *data)
cvxPartIsoCurveOnFace
evxErrors cvxPartIsoCurveOnFace(const svxIsoCrvOnFaceData *data, int *cntEnts, int **idEnts)
cvxPartCrvIntScaleInit
evxErrors cvxPartCrvIntScaleInit(int nPnt, const svxPoint *pPnts, double *startScale, double *endScale)
cvxPartPolylineInit
evxErrors cvxPartPolylineInit(svxPolylineData *data)
cvxPartCurveOffset
evxErrors cvxPartCurveOffset(int idCurve, double Dis, int *idOut)
cvxPartCrvFillet
evxErrors cvxPartCrvFillet(const svxCrvFilletData *data, int *idFillet)
cvxPartInqReversedCurve
evxErrors cvxPartInqReversedCurve(int idEnt, svxCurve *data)
cvxPartCrvIntInit
evxErrors cvxPartCrvIntInit(svxCrvIntData *data)
cvxPartRectangle
evxErrors cvxPartRectangle(svxRectangleData *rectData, int *iCnt, int **idEnt)
cvxPartSplineInit
evxErrors cvxPartSplineInit(svxSplineData *data, int count)
cvxPartCrvFilletChainInit
evxErrors cvxPartCrvFilletChainInit(svxCrvFilletChainData *data)
cvxPartCurveSilh
evxErrors cvxPartCurveSilh(int idCurve, svxPoint *dir, int *iCnt, int **idList)
cvxPartCrvProjToFaceInit
evxErrors cvxPartCrvProjToFaceInit(svxCrvProjToFace *data)
cvxPartCir3pt
evxErrors cvxPartCir3pt(svxPoint *P1, svxPoint *P2, svxPoint *P3, int *idEnt)
cvxPartInterXCurve
evxErrors cvxPartInterXCurve(const svxInterCrvData *pSurf, int *idFtr)
cvxPartPnt
evxErrors cvxPartPnt(svxPoint *Point, int *idEnt)
cvxPartBlendCrvs
evxErrors cvxPartBlendCrvs(const svxCrvBlendData *data, int *idEnt)
cvxPartCrvTrimWithCrv
evxErrors cvxPartCrvTrimWithCrv(const svxTrimWithCrvData *data, int *CountCrvs, int **NewCrvs)
cvxPartArc3pt
evxErrors cvxPartArc3pt(svxPoint *Start, svxPoint *End, svxPoint *Mid, int *idEnt)
cvxPartCirRad
evxErrors cvxPartCirRad(svxMatrix *Plane, double Radius, int *idEnt)
cvxPartCrvChamferInit
evxErrors cvxPartCrvChamferInit(svxCrvChamferData *data)
cvxPartExtractCenterlines
evxErrors cvxPartExtractCenterlines(int cntFaces, int *idFaces, int extractAxis, int *cntEnts, int **idEnts)
cvxPartCurve
evxErrors cvxPartCurve(svxCurve *Crv, int *idEnt)
cvxPartArc
evxErrors cvxPartArc(const svxArcData *arcData, int *idArc)
cvxPartCrvConvertToArcs
evxErrors cvxPartCrvConvertToArcs(const svxCrvConvertTocData *data, int *cntArcs, int **idArcs)
cvxPartSpline
evxErrors cvxPartSpline(const svxSplineData *PntData, int *idEnt)
cvxPartCrvList
evxErrors cvxPartCrvList(int Count, int *Curves, int *idEnt)
cvxPartIsoclineCurveInit
evxErrors cvxPartIsoclineCurveInit(svxIsoclineCrvData *data, evxIsoclineCrvType type)
cvxPartCrvSplitAtPnts
evxErrors cvxPartCrvSplitAtPnts(int idCurve, int CountPnts, svxPoint *Points, int *CountCrvs, int **NewCrvs)
cvxPartArcRad
evxErrors cvxPartArcRad(svxMatrix *Plane, double Radius, double Start, double End, int *idEnt)
cvxPartLine2pt
evxErrors cvxPartLine2pt(svxPoint *Start, svxPoint *End, int *idEnt)
cvxPartCrvOnFaceThruPts
evxErrors cvxPartCrvOnFaceThruPts(const svxCrvOnFaceThuPts *data, int *idEnt)
cvxPartCrvFilletInit
evxErrors cvxPartCrvFilletInit(svxCrvFilletData *data)
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxArcData
3D arc data
Definition: zwapi_cmd_wireframe_data.h:77
svxCircleData
3D circle data
Definition: zwapi_cmd_wireframe_data.h:110
svxCrvBlendCons
curve blend constraints
Definition: zwapi_cmd_wireframe_data.h:401
svxCrvBlendData
curve blend data
Definition: zwapi_cmd_wireframe_data.h:438
svxCrvChamferChainData
chamfer chain data
Definition: zwapi_cmd_wireframe_data.h:574
svxCrvChamferData
curve chamfer data
Definition: zwapi_cmd_wireframe_data.h:545
svxCrvCombinedProjData
combined projection data
Definition: zwapi_cmd_wireframe_data.h:356
svxCrvConvertTocData
create arc and line segments from existing curves data
Definition: zwapi_cmd_wireframe_data.h:629
svxCrvFilletChainData
curve fillet chain data
Definition: zwapi_cmd_wireframe_data.h:521
svxCrvFilletData
curve fillet data
Definition: zwapi_cmd_wireframe_data.h:502
svxCrvIntData
2D/3D interpolated curve
Definition: zwapi_util.h:2329
svxCrvOnFaceThuPts
curve on face through points data
Definition: zwapi_cmd_wireframe_data.h:221
svxCrvProjToFace
project to face data
Definition: zwapi_cmd_wireframe_data.h:174
svxCrvTrimToFacesData
trim to faces data
Definition: zwapi_cmd_wireframe_data.h:616
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxFaceCrvData
face curve data
Definition: zwapi_cmd_wireframe_data.h:324
svxInterCrvData
inter curve
Definition: zwapi_cmd_wireframe_data.h:194
svxIsoCrvOnFaceData
iso-curve on face data
Definition: zwapi_cmd_wireframe_data.h:258
svxIsoclineCrvData
isocline curve data
Definition: zwapi_cmd_wireframe_data.h:299
svxLineData
3D line data
Definition: zwapi_cmd_wireframe_data.h:47
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxPolylineData
3D polyline data
Definition: zwapi_cmd_wireframe_data.h:127
svxRectangleData
3D ellipse & rectangle data
Definition: zwapi_cmd_wireframe_data.h:151
svxSpiralCrvData
spiral curve data
Definition: zwapi_cmd_wireframe_data.h:459
svxSplineData
Spline command data.
Definition: zwapi_util.h:2398
svxSplinePnt
Spline point.
Definition: zwapi_util.h:2367
svxTrimWithCrvData
trim with curve data
Definition: zwapi_cmd_wireframe_data.h:597
zwapi_cmd_wireframe_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_WIREFRAME_FTR_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_cmd_wireframe_data.h
evxArcType
evxArcType
evxCircleType
evxCircleType
evxCrvBlendDirType
evxCrvBlendDirType
evxCrvBlendObjType
evxCrvBlendObjType
evxCrvBlendPosType
evxCrvBlendPosType
evxCrvBlendTrimType
evxCrvBlendTrimType
evxCrvChamferMethods
evxCrvChamferMethods
evxCrvFilletMethods
evxCrvFilletMethods
evxCrvIsoType
evxCrvIsoType
evxCrvIsoUVType
evxCrvIsoUVType
evxCrvTrimType
evxCrvTrimType
evxIsoclineCrvType
evxIsoclineCrvType
evxLineType
evxLineType
evxRectangleType
evxRectangleType
evxTrimWithCrvType
evxTrimWithCrvType
svxArcData
svxCircleData
svxCrvBlendCons
svxCrvBlendData
svxCrvChamferChainData
svxCrvChamferData
svxCrvCombinedProjData
svxCrvConvertTocData
svxCrvFilletChainData
svxCrvFilletData
svxCrvOnFaceThuPts
svxCrvOnFaceThuPtsCons
svxCrvProjToFace
svxCrvTrimToFacesData
svxFaceCrvData
svxInterCrvData
svxIsoclineCrvData
svxIsoCrvOnFaceData
svxLineData
svxPolylineData
svxRectangleData
svxSpiralCrvData
svxTrimWithCrvData

◆ ZW_API_WIREFRAME_FTR_DATA_H

#define ZW_API_WIREFRAME_FTR_DATA_H

Definition at line 17 of file zwapi_cmd_wireframe_data.h.
Generated at Sun Apr 23 2023 16:41:38 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_cmd_wireframe_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_cmd_wireframe_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_WIREFRAME_FTR_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_WIREFRAME_FTR_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxLineType
33 {
34 VX_LINE_2PT = 0,
35 VX_LINE_ALONG_DIR = 1,
36 VX_LINE_PARALLEL = 2,
37 VX_LINE_PERP = 3,
38 VX_LINE_ANGLE = 4,
39 VX_LINE_MIDDDLE = 5,
40 } evxLineType;
41
46typedef struct svxLineData
47 {
48 evxLineType lineType;
49 svxDirOnEntPath refDir;
50 svxPntOnEntPath point1;
51 svxPntOnEntPath point2;
52 double length;
53 double offset;
54 double angle;
56 int idAlignPln;
57 int prjToPln;
58 } svxLineData;
59
64typedef enum evxArcType
65 {
66 VX_ARC_THROUGH = 0,
67 VX_ARC_RADIUS = 1,
68 VX_ARC_CENTER = 2,
69 VX_ARC_ANGLE = 3,
70 } evxArcType;
71
76typedef struct svxArcData
77 {
78 evxArcType arcType;
79 svxPntOnEntPath startPnt;
80 svxPntOnEntPath endPnt;
81 svxPntOnEntPath centerPnt;
82 double radius;
83 double startAngle;
84 double arcAngle;
86 int idAlignPln;
87 int prjToPln;
88 int arcDir;
89 svxPntOnEntPath* location;
90 } svxArcData;
91
96typedef enum evxCircleType
97 {
98 VX_CIRCLE_BOUNDARY = 1,
99 VX_CIRCLE_RADIUS = 2,
100 VX_CIRCLE_THROUGH = 0,
101 VX_CIRCLE_2PT_RADIUS = 3,
102 VX_CIRCLE_2POINT = 4,
103 } evxCircleType;
104
109typedef struct svxCircleData
110 {
111 evxCircleType type;
112 svxPntOnEntPath centerPnt;
113 svxPntOnEntPath bndPnts[3];
114 int useDiameter;
115 double radOrDia;
117 int idAlignPln;
118 int prjToPln;
119 svxPntOnEntPath* location;
120 } svxCircleData;
121
126typedef struct svxPolylineData
127 {
128 int numPoint;
129 svxPntOnEnt* pPoints;
130 int idAligPln;
131 int projectToPln;
132 int pntOnPln;
133 } svxPolylineData;
134
139typedef enum evxRectangleType
140 {
141 VX_RECT_2PT = 0,
142 VX_RECT_WIDTH_HEIGHT = 1,
143 VX_RECT_3PT = 2
144 } evxRectangleType;
145
150typedef struct svxRectangleData
151 {
152 /* required inputs */
153 evxRectangleType type;
154 int idPlane;
155 int firstPtType;
156 svxPoint pts[3];
157 double width;
158 double height;
160 /* optional inputs */
161 double angle;
162 int prjFirstPt;
163 int parallelogram;
164 } svxRectangleData;
165
166//====================================================================================================================
168//====================================================================================================================
173typedef struct svxCrvProjToFace
174 {
175 int cntCrvs;
176 int* pCrvs;
177 int cntFaces;
178 int* pFaces;
179 svxVector* pDir;
182 int biDir;
184 int trim;
187 }svxCrvProjToFace;
188
193typedef struct svxInterCrvData
194 {
195 int iEntCout1;
196 int iEntCout2;
197 int* idEnt1;
198 int* idEnt2;
199 int trim;
200 } svxInterCrvData;
201
202
207typedef struct svxCrvOnFaceThuPtsCons
208 {
209 evxContinuityTyp continuity;
211 svxVector tan;
212 int flip;
213 double weight;
214 }svxCrvOnFaceThuPtsCons;
215
220typedef struct svxCrvOnFaceThuPts
221 {
222 int face;
223 int cntPts;
224 svxPoint* pts;
225 int isOpen;
226 evxFairingType fairing;
227 svxCrvOnFaceThuPtsCons* startCons;
228 svxCrvOnFaceThuPtsCons* endCons;
229 }svxCrvOnFaceThuPts;
230
235typedef enum evxCrvIsoType
236 {
237 VX_CRV_ISO_AT_POINT = 0,
238 VX_CRV_ISO_AT_UV = 1,
239 VX_CRV_ISO_MULTIPLE = 2,
240 }evxCrvIsoType;
241
246typedef enum evxCrvIsoUVType
247 {
248 VX_CRV_ISO_UV_U = 0,
249 VX_CRV_ISO_UV_V = 1,
250 VX_CRV_ISO_UV_BOTH = 2,
251 }evxCrvIsoUVType;
252
257typedef struct svxIsoCrvOnFaceData
258 {
259 evxCrvIsoType crvIsoType;
260 int face;
261 union uvxCrvIsoData
262 {
263 struct svxCrvIsoAtPoint
264 {
265 svxPoint point;
266 evxCrvIsoUVType type;
267 }atPoint;
268 struct svxCrvIsoAtUVParam
269 {
270 double U;
271 double V;
272 evxCrvIsoUVType type;
273 }UVParam;
274 struct svxCrvIsoMultiple
275 {
276 int numU;
277 int numV;
278 double offsetU;
279 double offsetV;
280 }multiple;
281 }inpUion;
282 }svxIsoCrvOnFaceData;
283
288typedef enum evxIsoclineCrvType
289 {
290 VX_CRV_ISOCLINE_SINGLE = 0,
291 VX_CRV_ISOCLINE_MULTIPLE = 1,
292 }evxIsoclineCrvType;
293
298typedef struct svxIsoclineCrvData
299 {
300 int* idFaces;
301 int cntFaces;
302 svxVector direction;
303 evxIsoclineCrvType crvType;
304 union uvxCrvIsoclineData
305 {
306 struct svxIsoclineCrvSingle
307 {
308 double angle;
309 }single;
310 struct svxIsoclineCrvMultiple
311 {
312 double interval;
313 double start;
314 double end;
315 }multiple;
316 }inpUion;
317 }svxIsoclineCrvData;
318
323typedef struct svxFaceCrvData
324 {
325 int method;
326 int cntFaces;
327 int* pFaces;
328 int partingLine;
329 union uvxFaceCrvData
330 {
331 struct uvxFromEdges
332 {
333 int cntEdge;
334 int* pEdge;
339 int seam;
340 }fromEdge;
341 struct uvxFromProjCrv
342 {
343 int cntCrv;
344 int* pCrv;
345 svxVector* dir;
347 }fromProjCrv;
348 }inpUion;
349 }svxFaceCrvData;
350
355typedef struct svxCrvCombinedProjData
356 {
357 int firstCrv;
358 svxVector firstDir;
359 int secondCrv;
360 svxVector secondDir;
361 }svxCrvCombinedProjData;
366typedef enum evxCrvBlendTrimType
367 {
368 VX_CURVE_BLEND_NO_TRIM = 0,
369 VX_CURVE_BLEND_TRIM_BOTH = 1,
370 VX_CURVE_BLEND_TRIM_FIRST = 2,
371 VX_CURVE_BLEND_TRIM_SECOND = 3,
372 }evxCrvBlendTrimType;
373
378typedef enum evxCrvBlendPosType
379 {
380 VX_CURVE_BLEND_POS_ARC_LENGTH = 0,
381 VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH = 1,
382 VX_CURVE_BLEND_POS_THROUGH_POINT = 2,
383 }evxCrvBlendPosType;
384
389typedef enum evxCrvBlendDirType
390 {
391 VX_CURVE_BLEND_DIR_SECTIONAL = 0,
392 VX_CURVE_BLEND_DIR_ISO_U = 1,
393 VX_CURVE_BLEND_DIR_ISO_V = 2,
394 }evxCrvBlendDirType;
395
400typedef struct svxCrvBlendCons
401 {
402 evxContinuityTyp continuity;
403 int tangentDirFlip;
404 double weight;
405 union uvxCrvBlendCons
406 {
407 struct svxCrvBlendCrv
408 {
409 evxCrvBlendPosType pos;
410 int keepside;
411 double value;
413 svxPntOnEntPath throughPnt;
414 } crv;
415 struct svxCrvBlendFace
416 {
417 evxCrvBlendDirType blendDir;
418 double value;
419 } face;
420 }inpUion;
421 }svxCrvBlendCons;
422
427typedef enum evxCrvBlendObjType
428 {
429 VX_CURVE_BLEND_CURVE = 0,
430 VX_CURVE_BLEND_FACE = 1,
431 }evxCrvBlendObjType;
432
437typedef struct svxCrvBlendData
438 {
439 evxCrvBlendObjType startObjType;
440 svxPntOnEntPath startObj;
441 int startObjFlip;
442 evxCrvBlendObjType endObjType;
443 svxPntOnEntPath endObj;
444 int endObjFlip;
446 evxCrvBlendTrimType trim;
447 int curvature;
448 int endpointPick;
450 svxCrvBlendCons* startCons;
451 svxCrvBlendCons* endCons;
452 }svxCrvBlendData;
453
458typedef struct svxSpiralCrvData
459 {
460 svxPoint startPnt;
461 svxVector axis;
462 double turns;
463 double offset;
465 int revolve;
467 svxVector* pRefDir;
468 double ang;
469 }svxSpiralCrvData;
470
471//====================================================================================================================
473//====================================================================================================================
474
479typedef enum evxCrvTrimType
480 {
481 VX_CRV_TRIM_NONE = 0,
482 VX_CRV_TRIM_BOTH = 1,
483 VX_CRV_TRIM_FIRST = 2,
484 VX_CRV_TRIM_SECOND = 3,
485 }evxCrvTrimType;
486
491typedef enum evxCrvFilletMethods
492 {
493 VX_CRV_FILLET_RADIUS = 0,
494 VX_CRV_FILLET_BOUNDARY = 1,
495 }evxCrvFilletMethods;
496
501typedef struct svxCrvFilletData
502 {
503 evxCrvFilletMethods method;
504 svxPntOnEntPath firstPnt;
505 svxPntOnEntPath secondPnt;
506 union evxCrvFilletInpUnion
507 {
508 double radius;
509 svxPntOnEntPath settingPnt;
510 }inpUnion;
511 evxCrvTrimType trimType;
512 evxExtendOpt extensionType;
513 int designerArc;
514 }svxCrvFilletData;
515
520typedef struct svxCrvFilletChainData
521 {
522 int count;
523 int* curves;
524 double radius;
525 int designerArc;
526 int trimOriginal;
527 }svxCrvFilletChainData;
528
533typedef enum evxCrvChamferMethods
534 {
535 VX_CRV_CHAMFER_SETBACK = 0,
536 VX_CRV_CHAMFER_TWO_SETBACKS = 1,
537 VX_CRV_CHAMFER_SETBACK_AND_ANGLE = 2,
538 }evxCrvChamferMethods;
539
544typedef struct svxCrvChamferData
545 {
546 evxCrvChamferMethods method;
547 svxPntOnEntPath firstPnt;
548 svxPntOnEntPath secondPnt;
549 union evxCrvChamferInpUnion
550 {
551 double setback;
553 struct CrvChamferTwoSetbacks
554 {
555 double firstSetback;
556 double secondSetback;
557 }twoSetbacks;
558
559 struct CrvChamferSetbackAndAngle
560 {
561 double setback;
562 double angle;
563 }setbackAndAngle;
564 }inpUnion;
565 evxCrvTrimType trimType;
566 evxExtendOpt extensionType;
567 }svxCrvChamferData;
568
573typedef struct svxCrvChamferChainData
574 {
575 int cnt;
576 int* curves;
577 double setback;
578 int trimOriginal;
579 }svxCrvChamferChainData;
580
585typedef enum evxTrimWithCrvType
586 {
587 VX_TRIM_WITH_CRV_KEEP = 0,
588 VX_TRIM_WITH_CRV_DELETE = 1,
589 VX_TRIM_WITH_CRV_SPLIT = 2,
590 }evxTrimWithCrvType;
591
596typedef struct svxTrimWithCrvData
597 {
598 int cntCrvs;
599 int* pCrvs;
600 int cntDelSeg;
601 svxPntOnEntPath* pDelSeg;
602 evxTrimWithCrvType trimMode;
603 svxPntOnEntPath* pPln;
609 }svxTrimWithCrvData;
610
615typedef struct svxCrvTrimToFacesData
616 {
617 int cntCrvs;
618 int* pCrvs;
619 int cntFaces;
620 int* pFaces;
621 int flip;
622 }svxCrvTrimToFacesData;
623
628typedef struct svxCrvConvertTocData
629 {
630 int cntCrvs;
631 int* idCrvs;
632 double tolerance;
633 int keep;
634 }svxCrvConvertTocData;
635/*
636*********************************************************************
637** END HEADER FILE
638*********************************************************************
639*/
640
641#ifdef __cplusplus
642 }
643#endif /* __cplusplus */
644
645#endif /* ZW_API_WIREFRAME_FTR_DATA_H */
evxCrvBlendDirType
evxCrvBlendDirType
blend location type for face to blend
Definition: zwapi_cmd_wireframe_data.h:390
VX_CURVE_BLEND_DIR_ISO_V
@ VX_CURVE_BLEND_DIR_ISO_V
ISO V works as the blend direction and a % of iso v can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:393
VX_CURVE_BLEND_DIR_SECTIONAL
@ VX_CURVE_BLEND_DIR_SECTIONAL
An angle relative to ISO U is defined to set up blend direction.
Definition: zwapi_cmd_wireframe_data.h:391
VX_CURVE_BLEND_DIR_ISO_U
@ VX_CURVE_BLEND_DIR_ISO_U
ISO U works as the blend direction and a % of iso u can defined to settle the blend location.
Definition: zwapi_cmd_wireframe_data.h:392
evxCrvTrimType
evxCrvTrimType
curve trim type
Definition: zwapi_cmd_wireframe_data.h:480
VX_CRV_TRIM_NONE
@ VX_CRV_TRIM_NONE
no trim
Definition: zwapi_cmd_wireframe_data.h:481
VX_CRV_TRIM_SECOND
@ VX_CRV_TRIM_SECOND
trim only the second curves
Definition: zwapi_cmd_wireframe_data.h:484
VX_CRV_TRIM_BOTH
@ VX_CRV_TRIM_BOTH
trim both curves
Definition: zwapi_cmd_wireframe_data.h:482
VX_CRV_TRIM_FIRST
@ VX_CRV_TRIM_FIRST
trim only the first curves
Definition: zwapi_cmd_wireframe_data.h:483
evxRectangleType
evxRectangleType
3D ellipse & rectangle type
Definition: zwapi_cmd_wireframe_data.h:140
VX_RECT_3PT
@ VX_RECT_3PT
three points
Definition: zwapi_cmd_wireframe_data.h:143
VX_RECT_2PT
@ VX_RECT_2PT
two points
Definition: zwapi_cmd_wireframe_data.h:141
VX_RECT_WIDTH_HEIGHT
@ VX_RECT_WIDTH_HEIGHT
width and height
Definition: zwapi_cmd_wireframe_data.h:142
evxIsoclineCrvType
evxIsoclineCrvType
create isocline curve with a single angle/multiple angles
Definition: zwapi_cmd_wireframe_data.h:289
VX_CRV_ISOCLINE_MULTIPLE
@ VX_CRV_ISOCLINE_MULTIPLE
multiple angles
Definition: zwapi_cmd_wireframe_data.h:291
VX_CRV_ISOCLINE_SINGLE
@ VX_CRV_ISOCLINE_SINGLE
single angle
Definition: zwapi_cmd_wireframe_data.h:290
evxArcType
evxArcType
3D arc type
Definition: zwapi_cmd_wireframe_data.h:65
VX_ARC_ANGLE
@ VX_ARC_ANGLE
create an arc by defining its center, radius, start angle and arc angle
Definition: zwapi_cmd_wireframe_data.h:69
VX_ARC_THROUGH
@ VX_ARC_THROUGH
create an arc by defining its two endpoints and a third point that arc passes through
Definition: zwapi_cmd_wireframe_data.h:66
VX_ARC_RADIUS
@ VX_ARC_RADIUS
create an arc by defining its two endpoints and radius
Definition: zwapi_cmd_wireframe_data.h:67
VX_ARC_CENTER
@ VX_ARC_CENTER
create an arc by defining its center and two endpoints
Definition: zwapi_cmd_wireframe_data.h:68
evxCrvChamferMethods
evxCrvChamferMethods
curve chamfer method
Definition: zwapi_cmd_wireframe_data.h:534
VX_CRV_CHAMFER_SETBACK
@ VX_CRV_CHAMFER_SETBACK
setback
Definition: zwapi_cmd_wireframe_data.h:535
VX_CRV_CHAMFER_SETBACK_AND_ANGLE
@ VX_CRV_CHAMFER_SETBACK_AND_ANGLE
setback and angle
Definition: zwapi_cmd_wireframe_data.h:537
VX_CRV_CHAMFER_TWO_SETBACKS
@ VX_CRV_CHAMFER_TWO_SETBACKS
two setbacks
Definition: zwapi_cmd_wireframe_data.h:536
evxCrvIsoUVType
evxCrvIsoUVType
iso-curve U or V settings
Definition: zwapi_cmd_wireframe_data.h:247
VX_CRV_ISO_UV_V
@ VX_CRV_ISO_UV_V
V-isoline.
Definition: zwapi_cmd_wireframe_data.h:249
VX_CRV_ISO_UV_BOTH
@ VX_CRV_ISO_UV_BOTH
both
Definition: zwapi_cmd_wireframe_data.h:250
VX_CRV_ISO_UV_U
@ VX_CRV_ISO_UV_U
U-isoline.
Definition: zwapi_cmd_wireframe_data.h:248
evxCrvFilletMethods
evxCrvFilletMethods
curve fillet method
Definition: zwapi_cmd_wireframe_data.h:492
VX_CRV_FILLET_RADIUS
@ VX_CRV_FILLET_RADIUS
radius
Definition: zwapi_cmd_wireframe_data.h:493
VX_CRV_FILLET_BOUNDARY
@ VX_CRV_FILLET_BOUNDARY
boundary
Definition: zwapi_cmd_wireframe_data.h:494
evxCircleType
evxCircleType
3D circle type
Definition: zwapi_cmd_wireframe_data.h:97
VX_CIRCLE_RADIUS
@ VX_CIRCLE_RADIUS
create a circle by defining its center and radius or diameter
Definition: zwapi_cmd_wireframe_data.h:99
VX_CIRCLE_THROUGH
@ VX_CIRCLE_THROUGH
create a circle by defining 3 boundary points
Definition: zwapi_cmd_wireframe_data.h:100
VX_CIRCLE_2POINT
@ VX_CIRCLE_2POINT
create a circle by defining 2 boundary points
Definition: zwapi_cmd_wireframe_data.h:102
VX_CIRCLE_2PT_RADIUS
@ VX_CIRCLE_2PT_RADIUS
create a circle by defining 2 boundary points and radius
Definition: zwapi_cmd_wireframe_data.h:101
VX_CIRCLE_BOUNDARY
@ VX_CIRCLE_BOUNDARY
create a circle by defining its center and a boundary point
Definition: zwapi_cmd_wireframe_data.h:98
evxCrvIsoType
evxCrvIsoType
iso-curve type
Definition: zwapi_cmd_wireframe_data.h:236
VX_CRV_ISO_AT_UV
@ VX_CRV_ISO_AT_UV
ar U/V parameter
Definition: zwapi_cmd_wireframe_data.h:238
VX_CRV_ISO_MULTIPLE
@ VX_CRV_ISO_MULTIPLE
multiple
Definition: zwapi_cmd_wireframe_data.h:239
VX_CRV_ISO_AT_POINT
@ VX_CRV_ISO_AT_POINT
at point
Definition: zwapi_cmd_wireframe_data.h:237
evxCrvBlendPosType
evxCrvBlendPosType
blend location type for curve to blend
Definition: zwapi_cmd_wireframe_data.h:379
VX_CURVE_BLEND_POS_THROUGH_POINT
@ VX_CURVE_BLEND_POS_THROUGH_POINT
Picking a pick on curve as the blend location.
Definition: zwapi_cmd_wireframe_data.h:382
VX_CURVE_BLEND_POS_ARC_LENGTH
@ VX_CURVE_BLEND_POS_ARC_LENGTH
location to blend is defined by arc length
Definition: zwapi_cmd_wireframe_data.h:380
VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
@ VX_CURVE_BLEND_POS_PERCENT_ARC_LENGTH
location to blend is defined by % of arc length
Definition: zwapi_cmd_wireframe_data.h:381
evxLineType
evxLineType
3D line type
Definition: zwapi_cmd_wireframe_data.h:33
VX_LINE_ANGLE
@ VX_LINE_ANGLE
create a line between two points and at an angle to the reference direction
Definition: zwapi_cmd_wireframe_data.h:38
VX_LINE_ALONG_DIR
@ VX_LINE_ALONG_DIR
create a line in the same direction as the reference by start point and length
Definition: zwapi_cmd_wireframe_data.h:35
VX_LINE_PERP
@ VX_LINE_PERP
create a line between two points and perpendicular to the reference direction
Definition: zwapi_cmd_wireframe_data.h:37
VX_LINE_PARALLEL
@ VX_LINE_PARALLEL
create a line parallel to the reference direction by point and length
Definition: zwapi_cmd_wireframe_data.h:36
VX_LINE_2PT
@ VX_LINE_2PT
create a line between two points
Definition: zwapi_cmd_wireframe_data.h:34
VX_LINE_MIDDDLE
@ VX_LINE_MIDDDLE
create a line by conforming the middle point and a end point
Definition: zwapi_cmd_wireframe_data.h:39
evxCrvBlendTrimType
evxCrvBlendTrimType
trim (or extend) curves type of curve blend
Definition: zwapi_cmd_wireframe_data.h:367
VX_CURVE_BLEND_TRIM_FIRST
@ VX_CURVE_BLEND_TRIM_FIRST
Trim/Extend only the first selected curve.
Definition: zwapi_cmd_wireframe_data.h:370
VX_CURVE_BLEND_TRIM_BOTH
@ VX_CURVE_BLEND_TRIM_BOTH
Trim/Extend both curves.
Definition: zwapi_cmd_wireframe_data.h:369
VX_CURVE_BLEND_NO_TRIM
@ VX_CURVE_BLEND_NO_TRIM
Add the fillet or chamfer without modifying the existing curves. No trim/extend is performed.
Definition: zwapi_cmd_wireframe_data.h:368
VX_CURVE_BLEND_TRIM_SECOND
@ VX_CURVE_BLEND_TRIM_SECOND
Trim/extend only the second selected curve.
Definition: zwapi_cmd_wireframe_data.h:371
evxCrvBlendObjType
evxCrvBlendObjType
select a curve or face as object to start/end blended
Definition: zwapi_cmd_wireframe_data.h:428
VX_CURVE_BLEND_FACE
@ VX_CURVE_BLEND_FACE
face
Definition: zwapi_cmd_wireframe_data.h:430
VX_CURVE_BLEND_CURVE
@ VX_CURVE_BLEND_CURVE
curve
Definition: zwapi_cmd_wireframe_data.h:429
evxTrimWithCrvType
evxTrimWithCrvType
trim with curve mode
Definition: zwapi_cmd_wireframe_data.h:586
VX_TRIM_WITH_CRV_KEEP
@ VX_TRIM_WITH_CRV_KEEP
The segment of the trimmed curves selected will be kept.
Definition: zwapi_cmd_wireframe_data.h:587
VX_TRIM_WITH_CRV_DELETE
@ VX_TRIM_WITH_CRV_DELETE
The segment of the trimmed curves selected will be deleted.
Definition: zwapi_cmd_wireframe_data.h:588
VX_TRIM_WITH_CRV_SPLIT
@ VX_TRIM_WITH_CRV_SPLIT
The trimmed curves will be split at the boundary curves (or point).
Definition: zwapi_cmd_wireframe_data.h:589
svxCrvBlendData
struct svxCrvBlendData svxCrvBlendData
curve blend data
svxCrvOnFaceThuPts
struct svxCrvOnFaceThuPts svxCrvOnFaceThuPts
curve on face through points data
svxCrvChamferChainData
struct svxCrvChamferChainData svxCrvChamferChainData
chamfer chain data
svxCrvCombinedProjData
struct svxCrvCombinedProjData svxCrvCombinedProjData
combined projection data
svxCrvFilletChainData
struct svxCrvFilletChainData svxCrvFilletChainData
curve fillet chain data
svxFaceCrvData
struct svxFaceCrvData svxFaceCrvData
face curve data
svxArcData
struct svxArcData svxArcData
3D arc data
svxCrvConvertTocData
struct svxCrvConvertTocData svxCrvConvertTocData
create arc and line segments from existing curves data
svxCrvBlendCons
struct svxCrvBlendCons svxCrvBlendCons
curve blend constraints
svxCrvFilletData
struct svxCrvFilletData svxCrvFilletData
curve fillet data
svxCrvChamferData
struct svxCrvChamferData svxCrvChamferData
curve chamfer data
svxRectangleData
struct svxRectangleData svxRectangleData
3D ellipse & rectangle data
svxInterCrvData
struct svxInterCrvData svxInterCrvData
inter curve
svxCircleData
struct svxCircleData svxCircleData
3D circle data
svxPolylineData
struct svxPolylineData svxPolylineData
3D polyline data
svxIsoclineCrvData
struct svxIsoclineCrvData svxIsoclineCrvData
isocline curve data
svxCrvTrimToFacesData
struct svxCrvTrimToFacesData svxCrvTrimToFacesData
trim to faces data
svxCrvProjToFace
struct svxCrvProjToFace svxCrvProjToFace
project to face data
svxSpiralCrvData
struct svxSpiralCrvData svxSpiralCrvData
spiral curve data
svxCrvOnFaceThuPtsCons
struct svxCrvOnFaceThuPtsCons svxCrvOnFaceThuPtsCons
curve on face through points constraint
svxTrimWithCrvData
struct svxTrimWithCrvData svxTrimWithCrvData
trim with curve data
svxLineData
struct svxLineData svxLineData
3D line data
svxIsoCrvOnFaceData
struct svxIsoCrvOnFaceData svxIsoCrvOnFaceData
iso-curve on face data
evxFairingType
evxFairingType
fairing modes
Definition: zwapi_util.h:2315
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
evxContinuityTyp
evxContinuityTyp
Continuity option.
Definition: zwapi_util.h:2355
svxArcData::arcDir
int arcDir
indicate the direction for angular input (0: counter; 1: clockwise), used when type is VX_ARC_CENTER ...
Definition: zwapi_cmd_wireframe_data.h:88
svxArcData::arcAngle
double arcAngle
angle of arc (deg), used when type is VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:84
svxArcData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore)
Definition: zwapi_cmd_wireframe_data.h:86
svxArcData::startAngle
double startAngle
start angle of arc (deg), used when type is VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:83
svxArcData::radius
double radius
radius of arc, used when type is VX_ARC_RADIUS
Definition: zwapi_cmd_wireframe_data.h:82
svxArcData::startPnt
svxPntOnEntPath startPnt
start point of arc, used when type isn't VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:79
svxArcData::endPnt
svxPntOnEntPath endPnt
end point of arc, used when type isn't VX_ARC_ANGLE
Definition: zwapi_cmd_wireframe_data.h:80
svxArcData::centerPnt
svxPntOnEntPath centerPnt
through point or center point of arc, used when type is VX_ARC_THROUGH or VX_ARC_CENTER
Definition: zwapi_cmd_wireframe_data.h:81
svxArcData::prjToPln
int prjToPln
whether to project arc to alignment plane
Definition: zwapi_cmd_wireframe_data.h:87
svxArcData::location
svxPntOnEntPath * location
indicate arc, used when type is VX_ARC_RADIUS
Definition: zwapi_cmd_wireframe_data.h:89
svxArcData::arcType
evxArcType arcType
type to create an arc
Definition: zwapi_cmd_wireframe_data.h:78
svxArcData
3D arc data
Definition: zwapi_cmd_wireframe_data.h:77
svxCircleData::useDiameter
int useDiameter
indicate radius or diameter (0: radius; 1: diameter), used when type is VX_CIRCLE_RADIUS
Definition: zwapi_cmd_wireframe_data.h:114
svxCircleData::centerPnt
svxPntOnEntPath centerPnt
center point of circle, used when type is VX_CIRCLE_BOUNDARY or VX_CIRCLE_RADIUS
Definition: zwapi_cmd_wireframe_data.h:112
svxCircleData::location
svxPntOnEntPath * location
indicate circle, used when type is VX_CIRCLE_2PT_RADIUS
Definition: zwapi_cmd_wireframe_data.h:119
svxCircleData::prjToPln
int prjToPln
whether to project circle to alignment plane
Definition: zwapi_cmd_wireframe_data.h:118
svxCircleData::bndPnts
svxPntOnEntPath bndPnts[3]
boundary points of circle, fill the array with the number of bounding points required by type
Definition: zwapi_cmd_wireframe_data.h:113
svxCircleData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore)
Definition: zwapi_cmd_wireframe_data.h:117
svxCircleData::radOrDia
double radOrDia
radius or diameter of circle, used when type is VX_CIRCLE_RADIUS or VX_CIRCLE_2PT_RADIUS
Definition: zwapi_cmd_wireframe_data.h:115
svxCircleData::type
evxCircleType type
type to create a circle
Definition: zwapi_cmd_wireframe_data.h:111
svxCircleData
3D circle data
Definition: zwapi_cmd_wireframe_data.h:110
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::value
double value
arc length for VX_CURVE_BLEND_POS_ARC_LENGTH, or percentage of arc length for VX_CURVE_BLEND_POS_PERC...
Definition: zwapi_cmd_wireframe_data.h:411
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::keepside
int keepside
0-long, 1-short
Definition: zwapi_cmd_wireframe_data.h:410
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::pos
evxCrvBlendPosType pos
define specific location to blend, VX_CURVE_BLEND_POS_THROUGH_POINT as default
Definition: zwapi_cmd_wireframe_data.h:409
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv::throughPnt
svxPntOnEntPath throughPnt
pick a point on curve as the blend location, for VX_CURVE_BLEND_POS_THROUGH_POINT
Definition: zwapi_cmd_wireframe_data.h:413
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendCrv
Definition: zwapi_cmd_wireframe_data.h:408
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::blendDir
evxCrvBlendDirType blendDir
define specific location to blend. VX_CURVE_BLEND_DIR_ISO_U as default
Definition: zwapi_cmd_wireframe_data.h:417
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace::value
double value
percentage or angle
Definition: zwapi_cmd_wireframe_data.h:418
svxCrvBlendCons::uvxCrvBlendCons::svxCrvBlendFace
Definition: zwapi_cmd_wireframe_data.h:416
svxCrvBlendCons::weight
double weight
the weight factor, between 0.10 and 5.00
Definition: zwapi_cmd_wireframe_data.h:404
svxCrvBlendCons::tangentDirFlip
int tangentDirFlip
1 to flip tangent direction, else 0
Definition: zwapi_cmd_wireframe_data.h:403
svxCrvBlendCons::continuity
evxContinuityTyp continuity
continuity method used for refitting and blending the curves, VX_CONTIN_G1 as default
Definition: zwapi_cmd_wireframe_data.h:402
svxCrvBlendCons
curve blend constraints
Definition: zwapi_cmd_wireframe_data.h:401
svxCrvBlendData::endObjFlip
int endObjFlip
1 to flip end object position, else 0
Definition: zwapi_cmd_wireframe_data.h:444
svxCrvBlendData::curvature
int curvature
1 to display curvature, else 0
Definition: zwapi_cmd_wireframe_data.h:447
svxCrvBlendData::endObjType
evxCrvBlendObjType endObjType
end object type, VX_CURVE_BLEND_CURVE as default
Definition: zwapi_cmd_wireframe_data.h:442
svxCrvBlendData::trim
evxCrvBlendTrimType trim
trim type, VX_CURVE_BLEND_TRIM_BOTH as default
Definition: zwapi_cmd_wireframe_data.h:446
svxCrvBlendData::endObj
svxPntOnEntPath endObj
end object
Definition: zwapi_cmd_wireframe_data.h:443
svxCrvBlendData::endpointPick
int endpointPick
1 to pick endpoint by default, else 0. 1 as default
Definition: zwapi_cmd_wireframe_data.h:448
svxCrvBlendData::startObj
svxPntOnEntPath startObj
start object
Definition: zwapi_cmd_wireframe_data.h:440
svxCrvBlendData::endCons
svxCrvBlendCons * endCons
end constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:451
svxCrvBlendData::startObjFlip
int startObjFlip
1 to flip start object position, else 0
Definition: zwapi_cmd_wireframe_data.h:441
svxCrvBlendData::startObjType
evxCrvBlendObjType startObjType
start object type, VX_CURVE_BLEND_CURVE as default
Definition: zwapi_cmd_wireframe_data.h:439
svxCrvBlendData::startCons
svxCrvBlendCons * startCons
start constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:450
svxCrvBlendData
curve blend data
Definition: zwapi_cmd_wireframe_data.h:438
svxCrvChamferChainData::cnt
int cnt
number of edges/curves to chamfer
Definition: zwapi_cmd_wireframe_data.h:575
svxCrvChamferChainData::curves
int * curves
I: pointer to list of edge/curve id's.
Definition: zwapi_cmd_wireframe_data.h:576
svxCrvChamferChainData::setback
double setback
setback (mm)
Definition: zwapi_cmd_wireframe_data.h:577
svxCrvChamferChainData::trimOriginal
int trimOriginal
1 to trim original curves, else 0. 1 as default
Definition: zwapi_cmd_wireframe_data.h:578
svxCrvChamferChainData
chamfer chain data
Definition: zwapi_cmd_wireframe_data.h:574
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::angle
double angle
angle of the first curve
Definition: zwapi_cmd_wireframe_data.h:562
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle::setback
double setback
the first setback
Definition: zwapi_cmd_wireframe_data.h:561
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferSetbackAndAngle
Definition: zwapi_cmd_wireframe_data.h:560
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::secondSetback
double secondSetback
the second setback
Definition: zwapi_cmd_wireframe_data.h:556
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks::firstSetback
double firstSetback
the first setback
Definition: zwapi_cmd_wireframe_data.h:555
svxCrvChamferData::evxCrvChamferInpUnion::CrvChamferTwoSetbacks
Definition: zwapi_cmd_wireframe_data.h:554
svxCrvChamferData::trimType
evxCrvTrimType trimType
trim type (VX_CRV_TRIM_BOTH as default)
Definition: zwapi_cmd_wireframe_data.h:565
svxCrvChamferData::method
evxCrvChamferMethods method
method to create a chamfer (VX_CRV_CHAMFER_SETBACK as default)
Definition: zwapi_cmd_wireframe_data.h:546
svxCrvChamferData::extensionType
evxExtendOpt extensionType
extension type (VX_EXTEND_CIRCULAR as default)
Definition: zwapi_cmd_wireframe_data.h:566
svxCrvChamferData::firstPnt
svxPntOnEntPath firstPnt
the first curve to chamfer
Definition: zwapi_cmd_wireframe_data.h:547
svxCrvChamferData::secondPnt
svxPntOnEntPath secondPnt
the second curve to chamfer
Definition: zwapi_cmd_wireframe_data.h:548
svxCrvChamferData
curve chamfer data
Definition: zwapi_cmd_wireframe_data.h:545
svxCrvCombinedProjData::firstDir
svxVector firstDir
the projection direction for the 1st curve
Definition: zwapi_cmd_wireframe_data.h:358
svxCrvCombinedProjData::firstCrv
int firstCrv
the first curve to project
Definition: zwapi_cmd_wireframe_data.h:357
svxCrvCombinedProjData::secondDir
svxVector secondDir
the projection direction for the 2nd curve
Definition: zwapi_cmd_wireframe_data.h:360
svxCrvCombinedProjData::secondCrv
int secondCrv
the second curve to project
Definition: zwapi_cmd_wireframe_data.h:359
svxCrvCombinedProjData
combined projection data
Definition: zwapi_cmd_wireframe_data.h:356
svxCrvConvertTocData::cntCrvs
int cntCrvs
count of curves to convert
Definition: zwapi_cmd_wireframe_data.h:630
svxCrvConvertTocData::keep
int keep
1 to keep original curves, else 0 (0 as default)
Definition: zwapi_cmd_wireframe_data.h:633
svxCrvConvertTocData::tolerance
double tolerance
allowable tolerance for the conversion (0.5 as default)
Definition: zwapi_cmd_wireframe_data.h:632
svxCrvConvertTocData::idCrvs
int * idCrvs
id of curves to convert
Definition: zwapi_cmd_wireframe_data.h:631
svxCrvConvertTocData
create arc and line segments from existing curves data
Definition: zwapi_cmd_wireframe_data.h:629
svxCrvFilletChainData::trimOriginal
int trimOriginal
whether to trim original curves (1 as default)
Definition: zwapi_cmd_wireframe_data.h:526
svxCrvFilletChainData::count
int count
count of curves
Definition: zwapi_cmd_wireframe_data.h:522
svxCrvFilletChainData::designerArc
int designerArc
whether to use designer arc (0 as default)
Definition: zwapi_cmd_wireframe_data.h:525
svxCrvFilletChainData::curves
int * curves
list ids of curves
Definition: zwapi_cmd_wireframe_data.h:523
svxCrvFilletChainData::radius
double radius
radius to fillet
Definition: zwapi_cmd_wireframe_data.h:524
svxCrvFilletChainData
curve fillet chain data
Definition: zwapi_cmd_wireframe_data.h:521
svxCrvFilletData::firstPnt
svxPntOnEntPath firstPnt
the first curve to fillet
Definition: zwapi_cmd_wireframe_data.h:504
svxCrvFilletData::designerArc
int designerArc
whether to use designer arc (0 as default)
Definition: zwapi_cmd_wireframe_data.h:513
svxCrvFilletData::method
evxCrvFilletMethods method
method to create a fillet (VX_CRV_FILLET_RADIUS as default)
Definition: zwapi_cmd_wireframe_data.h:503
svxCrvFilletData::extensionType
evxExtendOpt extensionType
extension type (VX_EXTEND_LINEAR as default)
Definition: zwapi_cmd_wireframe_data.h:512
svxCrvFilletData::secondPnt
svxPntOnEntPath secondPnt
the second curve to fillet
Definition: zwapi_cmd_wireframe_data.h:505
svxCrvFilletData::trimType
evxCrvTrimType trimType
curve trim type (VX_CRV_TRIM_BOTH as default)
Definition: zwapi_cmd_wireframe_data.h:511
svxCrvFilletData
curve fillet data
Definition: zwapi_cmd_wireframe_data.h:502
svxCrvOnFaceThuPts::face
int face
face to create the curve on
Definition: zwapi_cmd_wireframe_data.h:222
svxCrvOnFaceThuPts::endCons
svxCrvOnFaceThuPtsCons * endCons
end constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:228
svxCrvOnFaceThuPts::fairing
evxFairingType fairing
fairing mode, VX_FAIRING_NONE as default
Definition: zwapi_cmd_wireframe_data.h:226
svxCrvOnFaceThuPts::pts
svxPoint * pts
points on the face for the curve to pass through
Definition: zwapi_cmd_wireframe_data.h:224
svxCrvOnFaceThuPts::cntPts
int cntPts
number of points
Definition: zwapi_cmd_wireframe_data.h:223
svxCrvOnFaceThuPts::startCons
svxCrvOnFaceThuPtsCons * startCons
start constraints (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:227
svxCrvOnFaceThuPts::isOpen
int isOpen
whether to create open curve, 1 as default
Definition: zwapi_cmd_wireframe_data.h:225
svxCrvOnFaceThuPtsCons::continuity
evxContinuityTyp continuity
continuity method used for creating curves, between VX_CONTIN_NONE and VX_CONTIN_G2 (VX_CONTIN_NONE a...
Definition: zwapi_cmd_wireframe_data.h:209
svxCrvOnFaceThuPtsCons::flip
int flip
whether to reverse the tangent direction
Definition: zwapi_cmd_wireframe_data.h:212
svxCrvOnFaceThuPtsCons::weight
double weight
tangent weight if an tangent direction is specified, between 0.1 and 10
Definition: zwapi_cmd_wireframe_data.h:213
svxCrvOnFaceThuPtsCons::tan
svxVector tan
tangent direction for the start or end of the curve
Definition: zwapi_cmd_wireframe_data.h:211
svxCrvOnFaceThuPtsCons
curve on face through points constraint
Definition: zwapi_cmd_wireframe_data.h:208
svxCrvOnFaceThuPts
curve on face through points data
Definition: zwapi_cmd_wireframe_data.h:221
svxCrvProjToFace::biDir
int biDir
Use this option to project the curves in both the positive and the negative directions relative to th...
Definition: zwapi_cmd_wireframe_data.h:182
svxCrvProjToFace::trim
int trim
Use this option to project only to the trim boundaries of a face. If you are projecting onto a trimme...
Definition: zwapi_cmd_wireframe_data.h:184
svxCrvProjToFace::pCrvs
int * pCrvs
a sketch or curves
Definition: zwapi_cmd_wireframe_data.h:176
svxCrvProjToFace::pFaces
int * pFaces
faces or datum planes to project curves onto
Definition: zwapi_cmd_wireframe_data.h:178
svxCrvProjToFace::pDir
svxVector * pDir
By default, the projection direction is normal to the surface. Use this option to define a different ...
Definition: zwapi_cmd_wireframe_data.h:179
svxCrvProjToFace::cntFaces
int cntFaces
count of faces
Definition: zwapi_cmd_wireframe_data.h:177
svxCrvProjToFace::cntCrvs
int cntCrvs
count of curves
Definition: zwapi_cmd_wireframe_data.h:175
svxCrvProjToFace
project to face data
Definition: zwapi_cmd_wireframe_data.h:174
svxCrvTrimToFacesData::cntFaces
int cntFaces
count of the trimming faces or shapes
Definition: zwapi_cmd_wireframe_data.h:619
svxCrvTrimToFacesData::pFaces
int * pFaces
index of the trimming faces or shapes
Definition: zwapi_cmd_wireframe_data.h:620
svxCrvTrimToFacesData::cntCrvs
int cntCrvs
count of curves or sketches to trim
Definition: zwapi_cmd_wireframe_data.h:617
svxCrvTrimToFacesData::pCrvs
int * pCrvs
index of curves or sketches to trim
Definition: zwapi_cmd_wireframe_data.h:618
svxCrvTrimToFacesData::flip
int flip
1 to flip the arrows to keep the opposite side, else 0
Definition: zwapi_cmd_wireframe_data.h:621
svxCrvTrimToFacesData
trim to faces data
Definition: zwapi_cmd_wireframe_data.h:616
svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
Definition: zwapi_util.h:590
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::seam
int seam
1 to create face curves along seam edges, 0 to ignore
Definition: zwapi_cmd_wireframe_data.h:339
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::pEdge
int * pEdge
If this field is empty, face curves are created surrounding the region formed by the selected faces....
Definition: zwapi_cmd_wireframe_data.h:334
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges::cntEdge
int cntEdge
count of edges
Definition: zwapi_cmd_wireframe_data.h:333
svxFaceCrvData::uvxFaceCrvData::uvxFromEdges
Definition: zwapi_cmd_wireframe_data.h:332
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::cntCrv
int cntCrv
count of curves
Definition: zwapi_cmd_wireframe_data.h:343
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::dir
svxVector * dir
direction curves are projected onto (NULL to projected in the direction of minimum distance from the ...
Definition: zwapi_cmd_wireframe_data.h:345
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv::pCrv
int * pCrv
curves, sketches, curve lists and edges to project onto the selected faces
Definition: zwapi_cmd_wireframe_data.h:344
svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv
Definition: zwapi_cmd_wireframe_data.h:342
svxFaceCrvData::method
int method
create face curves method (0-from edges, 1-from projected curves)
Definition: zwapi_cmd_wireframe_data.h:325
svxFaceCrvData::cntFaces
int cntFaces
count of faces on which to create the face curves
Definition: zwapi_cmd_wireframe_data.h:326
svxFaceCrvData::pFaces
int * pFaces
index of faces on which to create the face curves
Definition: zwapi_cmd_wireframe_data.h:327
svxFaceCrvData::partingLine
int partingLine
1 to add the selected Edges as parting line, else 0
Definition: zwapi_cmd_wireframe_data.h:328
svxFaceCrvData
face curve data
Definition: zwapi_cmd_wireframe_data.h:324
svxInterCrvData::iEntCout2
int iEntCout2
The number of faces selected for the second field.
Definition: zwapi_cmd_wireframe_data.h:196
svxInterCrvData::idEnt2
int * idEnt2
Select all face ids for the second field.
Definition: zwapi_cmd_wireframe_data.h:198
svxInterCrvData::idEnt1
int * idEnt1
Select all face ids for the first field.
Definition: zwapi_cmd_wireframe_data.h:197
svxInterCrvData::trim
int trim
1 to trim intersection curves to face boundaries; 0 does not not trim the curve, 1 default
Definition: zwapi_cmd_wireframe_data.h:199
svxInterCrvData::iEntCout1
int iEntCout1
The number of faces selected for the first field.
Definition: zwapi_cmd_wireframe_data.h:195
svxInterCrvData
inter curve
Definition: zwapi_cmd_wireframe_data.h:194
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::point
svxPoint point
a point on the face for the iso-curve to pass through
Definition: zwapi_cmd_wireframe_data.h:265
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint::type
evxCrvIsoUVType type
to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default
Definition: zwapi_cmd_wireframe_data.h:266
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtPoint
Definition: zwapi_cmd_wireframe_data.h:264
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::type
evxCrvIsoUVType type
to create only the U, the V or create both iso-curves. VX_CRV_ISO_UV_BOTH as default
Definition: zwapi_cmd_wireframe_data.h:272
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::U
double U
U parameter where the iso-curve(s) will be located.
Definition: zwapi_cmd_wireframe_data.h:270
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam::V
double V
V parameter where the iso-curve(s) will be located.
Definition: zwapi_cmd_wireframe_data.h:271
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoAtUVParam
Definition: zwapi_cmd_wireframe_data.h:269
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetV
double offsetV
place the V iso-curves at an offset distance from their default location
Definition: zwapi_cmd_wireframe_data.h:279
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numV
int numV
number of V iso-curves
Definition: zwapi_cmd_wireframe_data.h:277
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::offsetU
double offsetU
place the U iso-curves at an offset distance from their default location
Definition: zwapi_cmd_wireframe_data.h:278
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple::numU
int numU
number of U iso-curves
Definition: zwapi_cmd_wireframe_data.h:276
svxIsoCrvOnFaceData::uvxCrvIsoData::svxCrvIsoMultiple
Definition: zwapi_cmd_wireframe_data.h:275
svxIsoCrvOnFaceData::crvIsoType
evxCrvIsoType crvIsoType
iso-curve on face methods
Definition: zwapi_cmd_wireframe_data.h:259
svxIsoCrvOnFaceData::face
int face
face from which the U and V curves will be extracted
Definition: zwapi_cmd_wireframe_data.h:260
svxIsoCrvOnFaceData
iso-curve on face data
Definition: zwapi_cmd_wireframe_data.h:258
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::start
double start
start angle between the reference direction and the face normal (between -90 to 90)
Definition: zwapi_cmd_wireframe_data.h:313
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::end
double end
end angle between the reference direction and the face normal (between -90 to 90)
Definition: zwapi_cmd_wireframe_data.h:314
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple::interval
double interval
angle between the isocline (between 0.01 to 90)
Definition: zwapi_cmd_wireframe_data.h:312
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple
Definition: zwapi_cmd_wireframe_data.h:311
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle::angle
double angle
angle between the reference direction and the face normal (between -90 to 90)
Definition: zwapi_cmd_wireframe_data.h:308
svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle
Definition: zwapi_cmd_wireframe_data.h:307
svxIsoclineCrvData::cntFaces
int cntFaces
number of faces to create isocline curves
Definition: zwapi_cmd_wireframe_data.h:301
svxIsoclineCrvData::direction
svxVector direction
reference direction
Definition: zwapi_cmd_wireframe_data.h:302
svxIsoclineCrvData::crvType
evxIsoclineCrvType crvType
isocline curve's creation type, VX_CRV_ISOCLINE_SINGLE as default
Definition: zwapi_cmd_wireframe_data.h:303
svxIsoclineCrvData::idFaces
int * idFaces
id of faces to create isocline curves
Definition: zwapi_cmd_wireframe_data.h:300
svxIsoclineCrvData
isocline curve data
Definition: zwapi_cmd_wireframe_data.h:299
svxLineData::refDir
svxDirOnEntPath refDir
reference direction, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL, VX_LINE_PERP,...
Definition: zwapi_cmd_wireframe_data.h:49
svxLineData::length
double length
length of line, used when type is VX_LINE_ALONG_DIR, VX_LINE_PARALLEL
Definition: zwapi_cmd_wireframe_data.h:52
svxLineData::idAlignPln
int idAlignPln
id of the alignment datum plane or planar face(0 to ignore), used when type is VX_LINE_2PT,...
Definition: zwapi_cmd_wireframe_data.h:56
svxLineData::point2
svxPntOnEntPath point2
the end point, used when type is VX_LINE_2PT, VX_LINE_PERP, VX_LINE_ANGLE, VX_LINE_MIDDDLE
Definition: zwapi_cmd_wireframe_data.h:51
svxLineData::prjToPln
int prjToPln
whether to project line to alignment plane, used when type is VX_LINE_2PT, VX_LINE_MIDDDLE
Definition: zwapi_cmd_wireframe_data.h:57
svxLineData::angle
double angle
angle from the reference direction, used when type is VX_LINE_ANGLE
Definition: zwapi_cmd_wireframe_data.h:54
svxLineData::offset
double offset
offset distance from the reference direction, used when type is VX_LINE_PARALLEL
Definition: zwapi_cmd_wireframe_data.h:53
svxLineData::point1
svxPntOnEntPath point1
start point or middle point
Definition: zwapi_cmd_wireframe_data.h:50
svxLineData::lineType
evxLineType lineType
type to create line
Definition: zwapi_cmd_wireframe_data.h:48
svxLineData
3D line data
Definition: zwapi_cmd_wireframe_data.h:47
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint
3D point
Definition: zwapi_util.h:306
svxPolylineData::numPoint
int numPoint
number of points to construct polyline
Definition: zwapi_cmd_wireframe_data.h:128
svxPolylineData::projectToPln
int projectToPln
1-project to the align plane, else 0 (1 as default)
Definition: zwapi_cmd_wireframe_data.h:131
svxPolylineData::pPoints
svxPntOnEnt * pPoints
pointer to list of points to construct polyline
Definition: zwapi_cmd_wireframe_data.h:129
svxPolylineData::pntOnPln
int pntOnPln
1-points on align plane, else 0 (0 as default)
Definition: zwapi_cmd_wireframe_data.h:132
svxPolylineData::idAligPln
int idAligPln
id of Align plane, -1 as default
Definition: zwapi_cmd_wireframe_data.h:130
svxPolylineData
3D polyline data
Definition: zwapi_cmd_wireframe_data.h:127
svxRectangleData::pts
svxPoint pts[3]
3 input points depend on "type"
Definition: zwapi_cmd_wireframe_data.h:156
svxRectangleData::angle
double angle
rotation angle
Definition: zwapi_cmd_wireframe_data.h:161
svxRectangleData::parallelogram
int parallelogram
0 rectangle, 1 parallelogram
Definition: zwapi_cmd_wireframe_data.h:163
svxRectangleData::firstPtType
int firstPtType
type of 1st input point (0 corner, 1 center)
Definition: zwapi_cmd_wireframe_data.h:155
svxRectangleData::width
double width
width if "type" is VX_RECT_WIDTH_HEIGHT
Definition: zwapi_cmd_wireframe_data.h:157
svxRectangleData::height
double height
height if "type" is VX_RECT_WIDTH_HEIGHT
Definition: zwapi_cmd_wireframe_data.h:158
svxRectangleData::type
evxRectangleType type
type to make rectangle
Definition: zwapi_cmd_wireframe_data.h:153
svxRectangleData::idPlane
int idPlane
not required if "type" is VX_RECT_3PT
Definition: zwapi_cmd_wireframe_data.h:154
svxRectangleData::prjFirstPt
int prjFirstPt
1 to project first point to plane, 0 not
Definition: zwapi_cmd_wireframe_data.h:162
svxRectangleData
3D ellipse & rectangle data
Definition: zwapi_cmd_wireframe_data.h:151
svxSpiralCrvData::offset
double offset
the value the turn offset, that is the distance between two turns. A positive value indicates an exte...
Definition: zwapi_cmd_wireframe_data.h:463
svxSpiralCrvData::axis
svxVector axis
the spiral axis, it can be the coordinate axis, line or point
Definition: zwapi_cmd_wireframe_data.h:461
svxSpiralCrvData::pRefDir
svxVector * pRefDir
the reference direction for spiral curve (NULL to ignore)
Definition: zwapi_cmd_wireframe_data.h:467
svxSpiralCrvData::turns
double turns
the number of turns
Definition: zwapi_cmd_wireframe_data.h:462
svxSpiralCrvData::ang
double ang
the angle of spiral curve
Definition: zwapi_cmd_wireframe_data.h:468
svxSpiralCrvData::revolve
int revolve
1 to revolve the curve clockwise about the specified axis, else revolve the curve anti-clockwise.
Definition: zwapi_cmd_wireframe_data.h:465
svxSpiralCrvData::startPnt
svxPoint startPnt
the start point
Definition: zwapi_cmd_wireframe_data.h:460
svxSpiralCrvData
spiral curve data
Definition: zwapi_cmd_wireframe_data.h:459
svxTrimWithCrvData::trimMode
evxTrimWithCrvType trimMode
trim mode
Definition: zwapi_cmd_wireframe_data.h:602
svxTrimWithCrvData::cntDelSeg
int cntDelSeg
number of curve segments
Definition: zwapi_cmd_wireframe_data.h:600
svxTrimWithCrvData::pDelSeg
svxPntOnEntPath * pDelSeg
curve segments where you want them to be trimmed away
Definition: zwapi_cmd_wireframe_data.h:601
svxTrimWithCrvData::pPln
svxPntOnEntPath * pPln
Use this option to trim non-intersection 3D curves. You can project the curves onto a plane and deter...
Definition: zwapi_cmd_wireframe_data.h:603
svxTrimWithCrvData::cntCrvs
int cntCrvs
number of curves
Definition: zwapi_cmd_wireframe_data.h:598
svxTrimWithCrvData::pCrvs
int * pCrvs
curves to use as boundaries
Definition: zwapi_cmd_wireframe_data.h:599
svxTrimWithCrvData
trim with curve data
Definition: zwapi_cmd_wireframe_data.h:597
svxVector
3D vector
Definition: zwapi_util.h:338
svxCrvBlendCons::uvxCrvBlendCons
Definition: zwapi_cmd_wireframe_data.h:406
svxCrvChamferData::evxCrvChamferInpUnion::setback
double setback
setback is a straight line distance between the vertex and the new setback point
Definition: zwapi_cmd_wireframe_data.h:551
svxCrvChamferData::evxCrvChamferInpUnion
Definition: zwapi_cmd_wireframe_data.h:550
svxCrvFilletData::evxCrvFilletInpUnion::settingPnt
svxPntOnEntPath settingPnt
point between the two picked curves to create a full fillet if method is VX_CRV_FILLET_BOUNDARY
Definition: zwapi_cmd_wireframe_data.h:509
svxCrvFilletData::evxCrvFilletInpUnion::radius
double radius
radius to fillet if method is VX_CRV_FILLET_RADIUS
Definition: zwapi_cmd_wireframe_data.h:508
svxCrvFilletData::evxCrvFilletInpUnion
Definition: zwapi_cmd_wireframe_data.h:507
svxFaceCrvData::uvxFaceCrvData
Definition: zwapi_cmd_wireframe_data.h:330
svxFaceCrvData::uvxFaceCrvData::fromEdge
struct svxFaceCrvData::uvxFaceCrvData::uvxFromEdges fromEdge
create face curves from edges data
svxFaceCrvData::uvxFaceCrvData::fromProjCrv
struct svxFaceCrvData::uvxFaceCrvData::uvxFromProjCrv fromProjCrv
create face curves from projected curves data
svxIsoCrvOnFaceData::uvxCrvIsoData
Definition: zwapi_cmd_wireframe_data.h:262
svxIsoclineCrvData::uvxCrvIsoclineData
Definition: zwapi_cmd_wireframe_data.h:305
svxIsoclineCrvData::uvxCrvIsoclineData::single
struct svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvSingle single
create isocline curve with a single angle
svxIsoclineCrvData::uvxCrvIsoclineData::multiple
struct svxIsoclineCrvData::uvxCrvIsoclineData::svxIsoclineCrvMultiple multiple
create isocline curves with multiple angles
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_CONFIG_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_config.h
cvxConfigGetColor
cvxConfigGetInteger
cvxConfigGetNumber
cvxConfigGetOption
cvxConfigGetRgb
cvxConfigGetString
cvxConfigGetYesNo
cvxConfigPathGet
cvxConfigSetColor
cvxConfigSetInteger
cvxConfigSetNumber
cvxConfigSetOption
cvxConfigSetRgb
cvxConfigSetString
cvxConfigSetYesNo

◆ ZW_API_CONFIG_H

#define ZW_API_CONFIG_H

Definition at line 17 of file zwapi_config.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_config.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_config.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_CONFIG_H /* this ifndef surrounds entire header */
17#define ZW_API_CONFIG_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
28/******************************************************************************/
54extern void cvxConfigGetColor(const char* Name, evxColor* Color);
55
56/******************************************************************************/
76extern evxErrors cvxConfigGetInteger(const char* Name, int* Value);
77
78/******************************************************************************/
98extern evxErrors cvxConfigGetNumber(const char* Name, double* Value);
99
100/******************************************************************************/
139extern int cvxConfigGetOption(const char* Name, const char* Options);
140
141/******************************************************************************/
167extern evxErrors cvxConfigGetRgb(const char* Name, svxColor* Rgb);
168
169/******************************************************************************/
191extern evxErrors cvxConfigGetString(const char* Name, char* Str, int nBytes);
192
193/******************************************************************************/
214extern evxErrors cvxConfigGetYesNo(const char* Name, int* YesNo);
215
216/******************************************************************************/
236extern evxErrors cvxConfigPathGet(char *path,int sizepath);
237
238
239//====================================================================================================================
241//====================================================================================================================
242/******************************************************************************/
265extern evxErrors cvxConfigSetColor(const char* Name, evxColor Color);
266
267/******************************************************************************/
286extern evxErrors cvxConfigSetInteger(const char* Name, int Value);
287
288/******************************************************************************/
307extern evxErrors cvxConfigSetNumber(const char* Name, double Value);
308
309/******************************************************************************/
329extern evxErrors cvxConfigSetOption(const char* Name, const char* Option);
330
331/******************************************************************************/
356extern evxErrors cvxConfigSetRgb(const char* Name, svxColor* Rgb);
357
358/******************************************************************************/
377extern evxErrors cvxConfigSetString(const char* Name, char* Str);
378
379/******************************************************************************/
399extern evxErrors cvxConfigSetYesNo(const char* Name, int YesNo);
400
401
402/*
403*********************************************************************
404** END HEADER FILE
405*********************************************************************
406*/
407
408#ifdef __cplusplus
409 }
410#endif /* __cplusplus */
411
412#endif /* ZW_API_CONFIG_H */
cvxConfigGetYesNo
evxErrors cvxConfigGetYesNo(const char *Name, int *YesNo)
cvxConfigGetOption
int cvxConfigGetOption(const char *Name, const char *Options)
cvxConfigSetRgb
evxErrors cvxConfigSetRgb(const char *Name, svxColor *Rgb)
cvxConfigSetString
evxErrors cvxConfigSetString(const char *Name, char *Str)
cvxConfigSetColor
evxErrors cvxConfigSetColor(const char *Name, evxColor Color)
cvxConfigGetInteger
evxErrors cvxConfigGetInteger(const char *Name, int *Value)
cvxConfigGetString
evxErrors cvxConfigGetString(const char *Name, char *Str, int nBytes)
cvxConfigSetYesNo
evxErrors cvxConfigSetYesNo(const char *Name, int YesNo)
cvxConfigPathGet
evxErrors cvxConfigPathGet(char *path, int sizepath)
cvxConfigGetRgb
evxErrors cvxConfigGetRgb(const char *Name, svxColor *Rgb)
cvxConfigGetNumber
evxErrors cvxConfigGetNumber(const char *Name, double *Value)
cvxConfigSetOption
evxErrors cvxConfigSetOption(const char *Name, const char *Option)
cvxConfigSetInteger
evxErrors cvxConfigSetInteger(const char *Name, int Value)
cvxConfigSetNumber
evxErrors cvxConfigSetNumber(const char *Name, double Value)
cvxConfigGetColor
void cvxConfigGetColor(const char *Name, evxColor *Color)
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DIM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dim.h
cvxDimAtGetBySub
cvxDimFCSDataGet
cvxDimInqDimBundles
cvxDimInqDimLines
cvxDimInqDimPnts
cvxDimInqExtLines
cvxDimInqPos
cvxDimInqState
cvxDimInqText
cvxDimInqTextType
cvxDimInqTxtPnt
cvxDimInqType
cvxDimInqTypeEx
cvxDimInqVar
cvxDimIsRadius
cvxDimModTextType
cvxDimModTxt
cvxDimModTxtPnt
cvxDimValMod
cvxDimValModNoUpdate

◆ ZW_API_DIM_H

#define ZW_API_DIM_H

Definition at line 23 of file zwapi_dim.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dim.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dim.h
Go to the documentation of this file.
1
21#pragma once
22#ifndef ZW_API_DIM_H /* this ifndef surrounds entire header */
23#define ZW_API_DIM_H
24
25#include "zwapi_util.h"
26
27#ifdef __cplusplus
28extern "C" {
29#endif /* __cplusplus */
30
31//====================================================================================================================
33//====================================================================================================================
34/******************************************************************************/
51extern evxErrors cvxDimInqType(int idDim, evxDimType* type);
52
53/******************************************************************************/
71extern evxErrors cvxDimInqTypeEx(int idDim, evxDimTypeEx* typeEx);
72
73/******************************************************************************/
89extern evxErrors cvxDimIsRadius(int idDim, int* isRadius);
90
91/******************************************************************************/
108extern evxErrors cvxDimInqState(int idDim, evxDimState* state);
109
110/******************************************************************************/
131extern evxErrors cvxDimInqDimBundles(int idDim, int* Count, int** idBundles);
132
133/******************************************************************************/
155extern evxErrors cvxDimFCSDataGet(int idFCS, int* numOfFcs, svxFCSData** FcsData, vxLongName Note1, vxLongName Note2);
156
157
158//====================================================================================================================
160//====================================================================================================================
161/******************************************************************************/
180extern evxErrors cvxDimInqVar(int idDim, svxVariable* Var);
181
182/******************************************************************************/
203extern evxErrors cvxDimValMod(int idDim, char* exp);
204
205/******************************************************************************/
224extern evxErrors cvxDimValModNoUpdate(int idDim, char* exp);
225
226
227//====================================================================================================================
229//====================================================================================================================
230/******************************************************************************/
250extern evxErrors cvxDimInqText(int idDim, int subDim, char** pStr);
251
252/******************************************************************************/
269extern evxErrors cvxDimModTxt(int idDim, int subDim, char* pStr);
270
271/******************************************************************************/
287extern evxErrors cvxDimInqTextType(int idDim, int* Type);
288
289/******************************************************************************/
308extern evxErrors cvxDimModTextType(int idDim, int Type, char* text);
309
310/******************************************************************************/
327extern evxErrors cvxDimInqTxtPnt(int idDim, svxPoint* TextPnt);
328
329/******************************************************************************/
349extern evxErrors cvxDimModTxtPnt(int idDim, int center, svxPoint* TextPnt);
350
351
352//====================================================================================================================
354//====================================================================================================================
355/******************************************************************************/
371extern evxErrors cvxDimInqPos(int idDim, svxPoint* pPos);
372
373/******************************************************************************/
394extern evxErrors cvxDimInqDimPnts(int idDim, int* count, svxPoint** DimPnts);
395
396
397//====================================================================================================================
399//====================================================================================================================
400/******************************************************************************/
427extern evxErrors cvxDimInqDimLines(int idDim, int* count, svxCurve** DimCrvs);
428
429/******************************************************************************/
456extern evxErrors cvxDimInqExtLines(int idDim, int* count, svxCurve** DimCrvs);
457
458
459//====================================================================================================================
461//====================================================================================================================
462/**********************************************************************
463*! -Dimension Attribute- : zwapi_dwg_dim.h
464* extern evxErrors cvxDwgDimAtGet(int idDim, svxDimAttr* dmAttr);
465* extern evxErrors cvxDwgDimAtSet(int idDim, svxDimAttr* dmAttr);
466**********************************************************************/
467/******************************************************************************/
489extern evxErrors cvxDimAtGetBySub(int idDim, int subDim, svxDimAttr* dmAttr);
490
491
492/*
493*********************************************************************
494** END HEADER FILE
495*********************************************************************
496*/
497
498#ifdef __cplusplus
499 }
500#endif /* __cplusplus */
501
502#endif /* ZW_API_DIM_H */
cvxDimInqTxtPnt
evxErrors cvxDimInqTxtPnt(int idDim, svxPoint *TextPnt)
cvxDimValModNoUpdate
evxErrors cvxDimValModNoUpdate(int idDim, char *exp)
cvxDimInqText
evxErrors cvxDimInqText(int idDim, int subDim, char **pStr)
cvxDimAtGetBySub
evxErrors cvxDimAtGetBySub(int idDim, int subDim, svxDimAttr *dmAttr)
cvxDimInqTypeEx
evxErrors cvxDimInqTypeEx(int idDim, evxDimTypeEx *typeEx)
cvxDimModTxt
evxErrors cvxDimModTxt(int idDim, int subDim, char *pStr)
cvxDimInqDimPnts
evxErrors cvxDimInqDimPnts(int idDim, int *count, svxPoint **DimPnts)
cvxDimValMod
evxErrors cvxDimValMod(int idDim, char *exp)
cvxDimInqExtLines
evxErrors cvxDimInqExtLines(int idDim, int *count, svxCurve **DimCrvs)
cvxDimInqPos
evxErrors cvxDimInqPos(int idDim, svxPoint *pPos)
cvxDimModTextType
evxErrors cvxDimModTextType(int idDim, int Type, char *text)
cvxDimInqState
evxErrors cvxDimInqState(int idDim, evxDimState *state)
cvxDimInqVar
evxErrors cvxDimInqVar(int idDim, svxVariable *Var)
cvxDimInqDimLines
evxErrors cvxDimInqDimLines(int idDim, int *count, svxCurve **DimCrvs)
cvxDimModTxtPnt
evxErrors cvxDimModTxtPnt(int idDim, int center, svxPoint *TextPnt)
cvxDimFCSDataGet
evxErrors cvxDimFCSDataGet(int idFCS, int *numOfFcs, svxFCSData **FcsData, vxLongName Note1, vxLongName Note2)
cvxDimInqType
evxErrors cvxDimInqType(int idDim, evxDimType *type)
cvxDimIsRadius
evxErrors cvxDimIsRadius(int idDim, int *isRadius)
cvxDimInqTextType
evxErrors cvxDimInqTextType(int idDim, int *Type)
cvxDimInqDimBundles
evxErrors cvxDimInqDimBundles(int idDim, int *Count, int **idBundles)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxDimType
evxDimType
dimension type
Definition: zwapi_util.h:1934
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxDimTypeEx
evxDimTypeEx
dimension type, more detailed than evxDimType
Definition: zwapi_util.h:1961
evxDimState
evxDimState
dimension state
Definition: zwapi_util.h:2092
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxDimAttr
Dimension attributes structure.
Definition: zwapi_util.h:2235
svxFCSData
FCS data.
Definition: zwapi_util.h:2182
svxPoint
3D point
Definition: zwapi_util.h:306
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DISPLAY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_display.h
cvxAxisDispModeGet
cvxAxisDispModeSet
cvxDatumDispAttrGet
cvxDatumDispAttrSet
cvxDatumDispModeGet
cvxDatumDispModeSet
cvxDatumLocalVis
cvxDispColorGet
cvxDispColorSet
cvxDispDataUpdate
cvxDispGetLights
cvxDispModeGet
cvxDispModeSet
cvxDispRedraw
cvxDispRgbGet
cvxDispRgbSet
cvxDispSceneUpdate
cvxDispSetLights
cvxDispSetLightsInit
cvxDispState
cvxDispSwitch
cvxDispSwitchGet
cvxDispWindowRectGet
cvxDispZoomAll
cvxDispZoomAllIncludeDim
cvxDispZoomAt
cvxDispZoomIn
cvxDispZoomLimits
cvxShowDisp
cvxShowOpen
cvxVisDispStatusGet
evxAxisDispMode
evxAxisDispMode
evxDatumDispMode
evxDatumDispMode
evxDispAttrib
evxDispAttrib
evxDispItem
evxDispItem
evxDispMode
evxDispMode
evxLightType
evxLightType
evxVisualDispItem
evxVisualDispItem
svxLight
vxDispState

◆ ZW_API_DISPLAY_H

#define ZW_API_DISPLAY_H

Definition at line 17 of file zwapi_display.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_display.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_display.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_DISPLAY_H /* this ifndef surrounds entire header */
17#define ZW_API_DISPLAY_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef int vxDispState[10];
33
34
39typedef enum evxDispAttrib
40 {
41 VX_DISP_POINT = 0,
42 VX_DISP_LINE = 1,
43 VX_DISP_FACE = 2
44 } evxDispAttrib;
45
50typedef enum evxDispMode
51 {
52 VX_DISP_WIRE = 1,
53 VX_DISP_SHADE = 2,
54 VX_DISP_HIDD_APPROX = 3,
55 VX_DISP_HIDD_EXACT = 4,
56 VX_DISP_EDGE = 5
57 } evxDispMode;
58
63typedef enum evxDispItem
64 {
65 VX_DISP_SCREEN = 0,
66 VX_DISP_PREVIEW = 1,
67 VX_DISP_FORMS = 2,
68 VX_DISP_ALL = 3
69 } evxDispItem;
70
75typedef enum evxVisualDispItem
76 {
77 VX_VISUAL_DISP_FRAME_TRIAD = 0,
78 VX_VISUAL_DISP_COMPASS_TRIAD = 1,
79 VX_VISUAL_DISP_TRIAD_TRANS = 2
80 } evxVisualDispItem;
81
82
83//====================================================================================================================
85//====================================================================================================================
90typedef enum evxLightType
91 {
92 V_LIGHT_NULL = 0,
93 V_LIGHT_AMB = 1,
94 V_LIGHT_DIR = 2,
95 V_LIGHT_POS = 3,
96 V_LIGHT_SPOT = 4,
97 V_LIGHT_EYE = 5
98 } evxLightType;
99
104typedef struct svxLight
105 {
106 vxName name;
107 evxLightType type;
108 svxPoint pos;
109 svxPoint dir;
110 svxPoint target_pnt;
111 float intensity;
112 float angle_1;
113 float angle_2;
114 float exp;
115 float c1, c2, c3;
116 svxColor color;
117 char off;
118 char shadow;
119 } svxLight;
120
121//====================================================================================================================
123//====================================================================================================================
128typedef enum evxDatumDispMode
129 {
130 VX_DSP_PLN_XY = 0,
131 VX_DSP_PLN_RECT_XY = 1,
132 VX_DSP_PLN_RECT_XYZ = 2,
133 VX_DSP_PLN_RECT = 3,
134 VX_DSP_PLN_QURT = 4,
135 VX_DSP_PLN_RECT_XY_FIX = 5,
136 VX_DSP_PLN_RECT_XYZ_FIX = 6,
137 VX_DSP_PLN_RECT_FIX = 7,
138 VX_DSP_PLN_XYZ = 8
139 }evxDatumDispMode;
140
145typedef enum evxAxisDispMode
146 {
147 VX_DSP_AXIS_ARROW_LINE = 0,
148 VX_DSP_AXIS_DASH_LINE = 1
149 }evxAxisDispMode;
150
151//====================================================================================================================
153//====================================================================================================================
154/******************************************************************************/
169extern void cvxDispRedraw(void);
170
171/******************************************************************************/
179extern void cvxDispDataUpdate(void);
180
181/******************************************************************************/
192extern void cvxDispModeGet(evxDispMode* Mode);
193
194/******************************************************************************/
205extern void cvxDispModeSet(evxDispMode Mode);
206
207/******************************************************************************/
223extern void cvxDispRgbGet(evxDispAttrib Type, svxColor* Rgb);
224
225/******************************************************************************/
248extern void cvxDispRgbSet(evxDispAttrib Type, const svxColor* Rgb);
249
250/******************************************************************************/
270extern void cvxDispColorGet(evxDispAttrib Type, evxColor* Color);
271
272/******************************************************************************/
286extern void cvxDispColorSet(evxDispAttrib Type, evxColor Color);
287
288/******************************************************************************/
310extern void cvxDispSwitch(evxDispItem Item, int isOn);
311
312/******************************************************************************/
327extern void cvxDispSwitchGet(evxDispItem Item, int* isOn);
328
329/******************************************************************************/
350extern void cvxDispState(int Option, vxDispState State);
351
352/******************************************************************************/
364extern void cvxVisDispStatusGet(evxVisualDispItem Item, int* isOn);
365
366/******************************************************************************/
409extern evxErrors cvxDispSceneUpdate();
410
411/******************************************************************************/
428extern evxErrors cvxDispWindowRectGet(const int includeFrame, const int isGlobal, int* x, int* y, int* w, int* h);
429
430
431//====================================================================================================================
433//====================================================================================================================
434/******************************************************************************/
465extern evxErrors cvxDispGetLights(int* Count, svxLight** Lights);
466
467/******************************************************************************/
484extern evxErrors cvxDispSetLightsInit(svxLight* data);
485
486/******************************************************************************/
507extern evxErrors cvxDispSetLights(int Count, svxLight* Lights);
508
509
510//====================================================================================================================
512//====================================================================================================================
513/******************************************************************************/
525extern void cvxShowOpen(const vxLongPath File);
526
527/******************************************************************************/
534extern void cvxShowDisp(int SlideNumber);
535
536
537//====================================================================================================================
539//====================================================================================================================
540/******************************************************************************/
547extern void cvxDispZoomAll(int Redraw);
548
549/******************************************************************************/
556extern void cvxDispZoomAllIncludeDim(int Redraw);
557
558/******************************************************************************/
566extern void cvxDispZoomAt(const svxPoint point, const float factor);
567
568/******************************************************************************/
578extern evxErrors cvxDispZoomLimits(void);
579
580/******************************************************************************/
599extern evxErrors cvxDispZoomIn(int ZoomIn, const svxPoint2f StartPoint, const svxPoint2f EndPoint);
600
601
602//====================================================================================================================
604//====================================================================================================================
605/******************************************************************************/
612extern void cvxDatumLocalVis(int iVisible);
613
614/******************************************************************************/
628extern void cvxDatumDispModeSet(int idDatum, evxDatumDispMode DispMode);
629
630/******************************************************************************/
647extern evxErrors cvxDatumDispModeGet(int idDatum, evxDatumDispMode* DispMode);
648
649/******************************************************************************/
667extern evxErrors cvxDatumDispAttrGet(int idDatum, svxWireAt* DispAt);
668
669/******************************************************************************/
686extern evxErrors cvxDatumDispAttrSet(int idDatum, const svxWireAt* DispAt);
687
688/******************************************************************************/
706extern evxErrors cvxAxisDispModeGet(int idAxis, evxAxisDispMode* DspMode);
707
708/******************************************************************************/
725extern evxErrors cvxAxisDispModeSet(int idAxis, evxAxisDispMode DspMode);
726
727/*
728*********************************************************************
729** END HEADER FILE
730*********************************************************************
731*/
732#ifdef __cplusplus
733 }
734#endif /* __cplusplus */
735
736#endif /* ZW_API_DISPLAY_H */
cvxDispSceneUpdate
evxErrors cvxDispSceneUpdate()
cvxDispZoomLimits
evxErrors cvxDispZoomLimits(void)
cvxDispRgbGet
void cvxDispRgbGet(evxDispAttrib Type, svxColor *Rgb)
cvxDispSwitchGet
void cvxDispSwitchGet(evxDispItem Item, int *isOn)
cvxDispModeGet
void cvxDispModeGet(evxDispMode *Mode)
cvxDispZoomIn
evxErrors cvxDispZoomIn(int ZoomIn, const svxPoint2f StartPoint, const svxPoint2f EndPoint)
cvxVisDispStatusGet
void cvxVisDispStatusGet(evxVisualDispItem Item, int *isOn)
evxVisualDispItem
evxVisualDispItem
visual display item
Definition: zwapi_display.h:76
VX_VISUAL_DISP_FRAME_TRIAD
@ VX_VISUAL_DISP_FRAME_TRIAD
frame triad display in visual manager
Definition: zwapi_display.h:77
VX_VISUAL_DISP_TRIAD_TRANS
@ VX_VISUAL_DISP_TRIAD_TRANS
show hidden in visual manager
Definition: zwapi_display.h:79
VX_VISUAL_DISP_COMPASS_TRIAD
@ VX_VISUAL_DISP_COMPASS_TRIAD
compass triad display in visual manager
Definition: zwapi_display.h:78
cvxDispState
void cvxDispState(int Option, vxDispState State)
vxDispState
int vxDispState[10]
display state settings
Definition: zwapi_display.h:32
cvxDatumDispAttrSet
evxErrors cvxDatumDispAttrSet(int idDatum, const svxWireAt *DispAt)
evxDispAttrib
evxDispAttrib
display attribute types
Definition: zwapi_display.h:40
cvxDatumLocalVis
void cvxDatumLocalVis(int iVisible)
cvxDispGetLights
evxErrors cvxDispGetLights(int *Count, svxLight **Lights)
cvxDispDataUpdate
void cvxDispDataUpdate(void)
cvxShowOpen
void cvxShowOpen(const vxLongPath File)
cvxAxisDispModeGet
evxErrors cvxAxisDispModeGet(int idAxis, evxAxisDispMode *DspMode)
evxDatumDispMode
evxDatumDispMode
display mode of datum plane
Definition: zwapi_display.h:129
VX_DSP_PLN_RECT_XY_FIX
@ VX_DSP_PLN_RECT_XY_FIX
display rectangle and XY axis with fix size
Definition: zwapi_display.h:135
VX_DSP_PLN_RECT_XYZ
@ VX_DSP_PLN_RECT_XYZ
display rectangle and XYZ axis
Definition: zwapi_display.h:132
VX_DSP_PLN_XYZ
@ VX_DSP_PLN_XYZ
display XYZ only
Definition: zwapi_display.h:138
VX_DSP_PLN_RECT
@ VX_DSP_PLN_RECT
display rectangle only
Definition: zwapi_display.h:133
VX_DSP_PLN_RECT_XYZ_FIX
@ VX_DSP_PLN_RECT_XYZ_FIX
display rectangle and XYZ axis with fix size
Definition: zwapi_display.h:136
VX_DSP_PLN_QURT
@ VX_DSP_PLN_QURT
display a quarter of rectangle only
Definition: zwapi_display.h:134
VX_DSP_PLN_XY
@ VX_DSP_PLN_XY
display XY only
Definition: zwapi_display.h:130
VX_DSP_PLN_RECT_XY
@ VX_DSP_PLN_RECT_XY
display rectangle and XY axis
Definition: zwapi_display.h:131
VX_DSP_PLN_RECT_FIX
@ VX_DSP_PLN_RECT_FIX
display (a quarter of) rectangle only with fix size
Definition: zwapi_display.h:137
cvxDispWindowRectGet
evxErrors cvxDispWindowRectGet(const int includeFrame, const int isGlobal, int *x, int *y, int *w, int *h)
cvxDispSwitch
void cvxDispSwitch(evxDispItem Item, int isOn)
cvxDispRgbSet
void cvxDispRgbSet(evxDispAttrib Type, const svxColor *Rgb)
cvxDispZoomAt
void cvxDispZoomAt(const svxPoint point, const float factor)
cvxDispSetLights
evxErrors cvxDispSetLights(int Count, svxLight *Lights)
cvxDispSetLightsInit
evxErrors cvxDispSetLightsInit(svxLight *data)
evxDispItem
evxDispItem
display (i.e. GUI) item
Definition: zwapi_display.h:64
VX_DISP_FORMS
@ VX_DISP_FORMS
forms
Definition: zwapi_display.h:67
VX_DISP_ALL
@ VX_DISP_ALL
all
Definition: zwapi_display.h:68
VX_DISP_PREVIEW
@ VX_DISP_PREVIEW
preview
Definition: zwapi_display.h:66
VX_DISP_SCREEN
@ VX_DISP_SCREEN
screen
Definition: zwapi_display.h:65
cvxDispColorGet
void cvxDispColorGet(evxDispAttrib Type, evxColor *Color)
cvxDatumDispModeGet
evxErrors cvxDatumDispModeGet(int idDatum, evxDatumDispMode *DispMode)
cvxDispZoomAllIncludeDim
void cvxDispZoomAllIncludeDim(int Redraw)
cvxDispModeSet
void cvxDispModeSet(evxDispMode Mode)
cvxAxisDispModeSet
evxErrors cvxAxisDispModeSet(int idAxis, evxAxisDispMode DspMode)
cvxDatumDispModeSet
void cvxDatumDispModeSet(int idDatum, evxDatumDispMode DispMode)
cvxShowDisp
void cvxShowDisp(int SlideNumber)
evxAxisDispMode
evxAxisDispMode
display mode of datum axis
Definition: zwapi_display.h:146
VX_DSP_AXIS_ARROW_LINE
@ VX_DSP_AXIS_ARROW_LINE
display arrow line
Definition: zwapi_display.h:147
VX_DSP_AXIS_DASH_LINE
@ VX_DSP_AXIS_DASH_LINE
display dash line without arrow
Definition: zwapi_display.h:148
cvxDatumDispAttrGet
evxErrors cvxDatumDispAttrGet(int idDatum, svxWireAt *DispAt)
cvxDispRedraw
void cvxDispRedraw(void)
evxLightType
evxLightType
light source type
Definition: zwapi_display.h:91
V_LIGHT_SPOT
@ V_LIGHT_SPOT
spot light source
Definition: zwapi_display.h:96
V_LIGHT_AMB
@ V_LIGHT_AMB
ambient light source
Definition: zwapi_display.h:93
V_LIGHT_DIR
@ V_LIGHT_DIR
directional light source
Definition: zwapi_display.h:94
V_LIGHT_POS
@ V_LIGHT_POS
positional light source
Definition: zwapi_display.h:95
V_LIGHT_EYE
@ V_LIGHT_EYE
light source located at view position
Definition: zwapi_display.h:97
V_LIGHT_NULL
@ V_LIGHT_NULL
undefined
Definition: zwapi_display.h:92
cvxDispColorSet
void cvxDispColorSet(evxDispAttrib Type, evxColor Color)
evxDispMode
evxDispMode
display mode
Definition: zwapi_display.h:51
VX_DISP_HIDD_APPROX
@ VX_DISP_HIDD_APPROX
approximate hidden line display
Definition: zwapi_display.h:54
VX_DISP_EDGE
@ VX_DISP_EDGE
multiple mode (allows shade/wire/hidden/zebra at same time
Definition: zwapi_display.h:56
VX_DISP_WIRE
@ VX_DISP_WIRE
wireframe display without showing facet edges
Definition: zwapi_display.h:52
VX_DISP_SHADE
@ VX_DISP_SHADE
shaded surfaces
Definition: zwapi_display.h:53
VX_DISP_HIDD_EXACT
@ VX_DISP_HIDD_EXACT
shade analyze mode (contour lines, etc)
Definition: zwapi_display.h:55
cvxDispZoomAll
void cvxDispZoomAll(int Redraw)
svxLight
struct svxLight svxLight
light source
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxLight::color
svxColor color
light color (rgb)
Definition: zwapi_display.h:116
svxLight::off
char off
1-light is OFF, else ON
Definition: zwapi_display.h:117
svxLight::c3
float c3
attenuation coefficients
Definition: zwapi_display.h:115
svxLight::dir
svxPoint dir
light direction in definition space
Definition: zwapi_display.h:109
svxLight::shadow
char shadow
1-cast shadows, else 0
Definition: zwapi_display.h:118
svxLight::name
vxName name
light source name
Definition: zwapi_display.h:106
svxLight::intensity
float intensity
light intensity (0.0-1.0)
Definition: zwapi_display.h:111
svxLight::angle_2
float angle_2
spotlight constant intensity angle (0-180 deg)
Definition: zwapi_display.h:113
svxLight::target_pnt
svxPoint target_pnt
target point for spot light
Definition: zwapi_display.h:110
svxLight::angle_1
float angle_1
spotlight cutoff angle (0-180 deg)
Definition: zwapi_display.h:112
svxLight::type
evxLightType type
light source type
Definition: zwapi_display.h:107
svxLight::exp
float exp
spotlight exponent (0-128)
Definition: zwapi_display.h:114
svxLight::pos
svxPoint pos
light position in definition space
Definition: zwapi_display.h:108
svxLight
light source
Definition: zwapi_display.h:105
svxPoint2f
2D point(single precision floating point)
Definition: zwapi_util.h:296
svxPoint
3D point
Definition: zwapi_util.h:306
svxWireAt
wire display attributes
Definition: zwapi_util.h:1188
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_AT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_attribute.h
cvxDwgAtGet
cvxDwgAtItemGet
cvxDwgAtSet

◆ ZW_API_DWG_AT_H

#define ZW_API_DWG_AT_H

Definition at line 15 of file zwapi_dwg_attribute.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_attribute.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_attribute.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_AT_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_AT_H
16
17#include "zwapi_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
42extern evxErrors cvxDwgAtGet(int idDrawing, svxDrawingAt* drawingAt);
43
44/******************************************************************************/
62extern evxErrors cvxDwgAtSet(int idDrawing, svxDrawingAt* drawingAt);
63
64/******************************************************************************/
89extern evxErrors cvxDwgAtItemGet(evxAtItemId itemId, svxAttribute* At);
90
91/**********************************************************************
92*! -Item Attribute- : zwapi_part_attribute.h
93* extern evxErrors cvxPartAtItemGetInFile(vxLongName File, vxLongName Root, evxAtItemId itemId, svxAttribute *At);
94* extern evxErrors cvxPartAtItemSetInFile(vxLongName File, vxLongName Root, evxAtItemId itemId, svxAttribute *At);
95**********************************************************************/
96/*
97*********************************************************************
98** END HEADER FILE
99*********************************************************************
100*/
101
102#ifdef __cplusplus
103 }
104#endif /* __cplusplus */
105
106#endif /* ZW_API_DWG_AT_H */
cvxDwgAtSet
evxErrors cvxDwgAtSet(int idDrawing, svxDrawingAt *drawingAt)
cvxDwgAtItemGet
evxErrors cvxDwgAtItemGet(evxAtItemId itemId, svxAttribute *At)
cvxDwgAtGet
evxErrors cvxDwgAtGet(int idDrawing, svxDrawingAt *drawingAt)
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxDrawingAt
Sheet Format Attributes structure.
Definition: zwapi_dwg_data.h:33
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_data_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_data.h
evxBrkLineCutSty
evxBrkLineCutSty
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
evxHorizontalMethod
evxHorizontalMethod
evxSymbolType
evxSymbolType
evxTableType
evxTableType
evxTextAlignment
evxTextAlignment
evxTextAlignWordWrap
evxTextAlignWordWrap
evxTextFontType
evxTextFontType
evxTextStroke
evxTextStroke
evxVerticalMethod
evxVerticalMethod
evxViewProjAngle
evxViewProjAngle
evxViewType
evxViewType
svxDrawingAt
svxDwgBrkLineAt
svxDwgBundleDimData
svxDwgStyleManagerAnnoDimText
svxDwgStyleManagerSymText
svxDwgStyleManagerTableText
svxDwgStyleManagerText
svxDwgStyleManagerViewText
svxRefEntData
svxSymAttr

◆ zwapi_dwg_data_H

#define zwapi_dwg_data_H

Definition at line 17 of file zwapi_dwg_data.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef zwapi_dwg_data_H /* this ifndef surrounds entire header */
17#define zwapi_dwg_data_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef struct svxDrawingAt
33 {
34 vxLongName templateName;
35 int idDwgTpl;
42 vxLongName configName;
43 char paper[16];
44 char useTemplate;
45 char useConfig;
46 double width;
47 double height;
48 char useBorder;
49 double margin[4];
53 char bound;
54 char centerMark;
55 char partition;
56 int partNum[2];
58 char trimmingMark;
59 vxLongName blockTemplateName[3];
63 } svxDrawingAt;
64
65//====================================================================================================================
67//====================================================================================================================
78typedef struct svxRefEntData
79 {
80 vxPath fileName;
81 vxRootName partName;
82 vxLongName shellName;
83 svxEntPath compPath;
84 char entClass;
85 int depth;
86 }svxRefEntData;
87
88//====================================================================================================================
90//====================================================================================================================
95typedef enum evxViewType
96 {
97 VX_VIEW_ALL = 0,
98 VX_VIEW_BASE = 1,
99 VX_VIEW_PROJ = 2,
100 VX_VIEW_SECT = 3,
101 VX_VIEW_DET = 4,
102 VX_VIEW_DEFN = 5
103 } evxViewType;
104
109typedef enum evxViewProjAngle
110 {
111 VX_VIEW_PROJ_ANG_ALL = 0,
112 VX_VIEW_3RD_UP = 1,
113 VX_VIEW_3RD_DN = 2,
114 VX_VIEW_3RD_RT = 3,
115 VX_VIEW_3RD_LT = 4,
116 VX_VIEW_1ST_UP = 5,
117 VX_VIEW_1ST_DN = 6,
118 VX_VIEW_1ST_RT = 7,
119 VX_VIEW_1ST_LT = 8,
120 VX_VIEW_3RD_PRJ_ANG = 9,
121 VX_VIEW_1ST_PRJ_ANG = 10,
122 } evxViewProjAngle;
123
128typedef enum evxBrkLineCutSty
129 {
130 VX_ZEROZIGZAG_BRKLINE = 0,
131 VX_ONEZIGZAG_BRKLINE,
132 VX_TWOZIGZAG_BRKLINE,
133 VX_CURVE_BRKLINE
134 } evxBrkLineCutSty;
135
140typedef struct svxDwgBrkLineAt
141 {
142 double gap;
143 evxBrkLineCutSty brkLnCutSty;
144 svxLineAt lineAtr;
145 vxName layerName;
146 int styleIndex;
147 } svxDwgBrkLineAt;
148
149//====================================================================================================================
151//====================================================================================================================
156typedef enum evxSymbolType
157 {
158 VX_SYM_ALL = -1,
159 VX_SYM_USER = 0,
160 VX_SYM_SURF = 1,
161 VX_SYM_WELD = 2,
162 VX_SYM_IMAGE = 3,
163 VX_SYM_ORIGIN = 4,
164 VX_SYM_BEAD = 5,
165 VX_SYM_ENDTRT = 6,
166 VX_SYM_OPEN_LINK = 7,
167 VX_SYM_HOLE_MARK = 8,
168 } evxSymbolType;
169
174typedef struct svxSymAttr
175 {
176 int allCir;
177 int extLine;
178 double extLineSize;
179 evxTermType termType;
180 double termSize;
181 char fontName[37];
182 char fontName2[37];
183 int textTyp;
184 int bold;
185 int underLine;
186 int autoTxtFlg;
187 double charHgt;
188 double charAsp;
189 double charSpacing;
190 evxColor textClr;
191 double scaleFac;
192 svxLineAt symAttr;
193 svxLineAt leaderAttr;
194 } svxSymAttr;
195
196//====================================================================================================================
198//====================================================================================================================
203typedef enum evxTableType
204 {
205 VX_TABLE_ALL = 0,
206 VX_TABLE_USER = 1,
207 VX_TABLE_BOM = 2,
208 VX_TABLE_HOLE = 3,
209 VX_TABLE_TRODE = 4,
210 VX_TABLE_WDSEG = 5,
211 VX_TABLE_WELD = 6,
212 VX_TABLE_PNT = 7,
213 VX_TABLE_DIM = 8,
214 VX_TABLE_REV = 9
215 } evxTableType;
216
221typedef struct svxDwgBundleDimData
222 {
223 int dimBundleId;
224 int count;
225 svxPoint2* pnts;
226 double dimValue;
227 } svxDwgBundleDimData;
228
229//====================================================================================================================
231//====================================================================================================================
232
237typedef enum evxDwgStyleManagerMethod
238 {
239 VX_STYLEMANAGER_TEXT,
241 VX_STYLEMANAGER_ANNO_LEADER,
242 VX_STYLEMANAGER_ANNO_BALLOON,
243 VX_STYLEMANAGER_ANNO_DATUM_FEATURE,
244 VX_STYLEMANAGER_ANNO_DATUM_TARGET,
245 VX_STYLEMANAGER_ANNO_FEATURE_CONTROL,
247 VX_STYLEMANAGER_DIM_LINEAR,
248 VX_STYLEMANAGER_DIM_ANGULAR,
249 VX_STYLEMANAGER_DIM_RADIAL,
250 VX_STYLEMANAGER_DIM_ARC,
251 VX_STYLEMANAGER_DIM_CHAMFER,
252 VX_STYLEMANAGER_DIM_HOLECALLOUT,
253 VX_STYLEMANAGER_DIM_ORDINATE,
255 VX_STYLEMANAGER_SYM_WELD,
256 VX_STYLEMANAGER_SYM_SRF_FINISH,
258 VX_STYLEMANAGER_TABLE_USER,
259 VX_STYLEMANAGER_TABLE_BOM,
260 VX_STYLEMANAGER_TABLE_HOLE,
261 VX_STYLEMANAGER_TABLE_EDM,
262 VX_STYLEMANAGER_TABLE_STRUCTURAL,
263 VX_STYLEMANAGER_TABLE_WELD,
264 VX_STYLEMANAGER_TABLE_REVISION,
266 VX_STYLEMANAGER_VIEW_BASE,
267 VX_STYLEMANAGER_VIEW_PROJECTION,
268 VX_STYLEMANAGER_VIEW_AUXILIARY,
269 VX_STYLEMANAGER_VIEW_SECTION,
270 VX_STYLEMANAGER_VIEW_DETAIL,
271 VX_STYLEMANAGER_VIEW_ALTERNATE,
272 } evxDwgStyleManagerMethod;
273
278typedef enum evxTextFontType
279 {
280 VX_FONTTYPE_NORMAL,
281 VX_FONTTYPE_PROPORTIONAL,
282 VX_FONTTYPE_FIXED,
283 } evxTextFontType;
284
289typedef enum evxTextStroke
290 {
291 VX_STROKE_COARSE,
292 VX_STROKE_MEDIUM,
293 VX_STROKE_FINE,
294 } evxTextStroke;
295
300typedef enum evxTextAlignWordWrap
301 {
302 VX_TEXTALIGN_NONE,
303 VX_TEXTALIGN_WORDWRAP,
304 VX_TEXTALIGN_AUTOSIZETEXT,
305 } evxTextAlignWordWrap;
306
311typedef enum evxHorizontalMethod
312 {
313 VX_HORIZONTAL_NORMAL,
314 VX_HORIZONTAL_LEFT,
315 VX_HORIZONTAL_CENTER,
316 VX_HORIZONTAL_RIGHT,
317 } evxHorizontalMethod;
318
323typedef enum evxVerticalMethod
324 {
325 VX_VERTICAL_NORMAL,
326 VX_VERTICAL_TOP,
327 VX_VERTICAL_CAP,
328 VX_VERTICAL_HALF,
329 VX_VERTICAL_BASE,
330 VX_VERTICAL_BOTTOM,
331 } evxVerticalMethod;
332
337typedef struct svxDwgStyleManagerText
338 {
339 vxLongName fontName;
340 vxLongName fontName2;
341 int underline;
345 int color;
346 evxLineWidth width;
347 evxTextFontType fontType;
348 evxTextStroke stroke;
349 evxTextAlignWordWrap fitMethod;
350 evxHorizontalMethod horizontal;
351 int horizontalType;
352 evxVerticalMethod vertical;
353 int verticalType;
355 double charHeight;
356 double charAspect;
357 double multiLineSpace;
358 double charSpacing;
359 double charSlant;
360 double textAngle;
361 double charPath;
362 double textExpansion;
363 } svxDwgStyleManagerText;
364
369typedef enum evxTextAlignment
370 {
371 VX_ALIGNMENT_LEFT = 1,
372 VX_ALIGNMENT_CENTER,
373 VX_ALIGNMENT_RIGHT,
374 } evxTextAlignment;
375
380typedef struct svxDwgStyleManagerAnnoDimText
381 {
382 vxLongName fontName;
383 vxLongName fontName2;
384 int underline;
388 int bold;
389 int color;
390 evxTextAlignment align;
392 double charHeight;
393 double charAspect;
394 double multiLineSpace;
395 double charSpacing;
396 double charSlant;
397 double tolchHgtFac;
398 } svxDwgStyleManagerAnnoDimText;
399
404typedef struct svxDwgStyleManagerTableText
405 {
406 vxLongName fontName;
407 vxLongName fontName2;
408 int underline;
412 int bold;
413 int color;
414 evxTextFontType fontType;
415 evxTextAlignWordWrap fitMethod;
416 evxHorizontalMethod horizontal;
417 evxVerticalMethod vertical;
419 double charHeight;
420 double charAspect;
421 double multiLineSpace;
422 double charSpacing;
423 double charSlant;
424 } svxDwgStyleManagerTableText;
425
430typedef struct svxDwgStyleManagerSymText
431 {
432 vxLongName fontName;
433 vxLongName fontName2;
434 int underline;
438 int color;
439 double charHeight;
440 double charAspect;
441 double charSpacing;
442 } svxDwgStyleManagerSymText;
443
448typedef struct svxDwgStyleManagerViewText
449 {
450 vxLongName fontName;
451 vxLongName fontName2;
452 int underline;
453 int color;
454 evxTextAlignment align;
455 double charHeight;
456 double charAspect;
457 double multiLineSpace;
458 double charSpacing;
459 double charSlant;
460 } svxDwgStyleManagerViewText;
461
462#ifdef __cplusplus
463 }
464#endif /* __cplusplus */
465#endif /* zwapi_dwg_data_H */
evxHorizontalMethod
evxHorizontalMethod
horizontal method
Definition: zwapi_dwg_data.h:312
VX_HORIZONTAL_CENTER
@ VX_HORIZONTAL_CENTER
center
Definition: zwapi_dwg_data.h:315
VX_HORIZONTAL_NORMAL
@ VX_HORIZONTAL_NORMAL
normal
Definition: zwapi_dwg_data.h:313
VX_HORIZONTAL_RIGHT
@ VX_HORIZONTAL_RIGHT
right
Definition: zwapi_dwg_data.h:316
VX_HORIZONTAL_LEFT
@ VX_HORIZONTAL_LEFT
left
Definition: zwapi_dwg_data.h:314
evxTextAlignment
evxTextAlignment
justification
Definition: zwapi_dwg_data.h:370
VX_ALIGNMENT_RIGHT
@ VX_ALIGNMENT_RIGHT
aling right
Definition: zwapi_dwg_data.h:373
VX_ALIGNMENT_LEFT
@ VX_ALIGNMENT_LEFT
align left
Definition: zwapi_dwg_data.h:371
VX_ALIGNMENT_CENTER
@ VX_ALIGNMENT_CENTER
align center
Definition: zwapi_dwg_data.h:372
evxTextAlignWordWrap
evxTextAlignWordWrap
fit method
Definition: zwapi_dwg_data.h:301
VX_TEXTALIGN_NONE
@ VX_TEXTALIGN_NONE
none
Definition: zwapi_dwg_data.h:302
VX_TEXTALIGN_AUTOSIZETEXT
@ VX_TEXTALIGN_AUTOSIZETEXT
auto size text
Definition: zwapi_dwg_data.h:304
VX_TEXTALIGN_WORDWRAP
@ VX_TEXTALIGN_WORDWRAP
word wrap
Definition: zwapi_dwg_data.h:303
evxTableType
evxTableType
table type
Definition: zwapi_dwg_data.h:204
VX_TABLE_REV
@ VX_TABLE_REV
Revision table.
Definition: zwapi_dwg_data.h:214
VX_TABLE_HOLE
@ VX_TABLE_HOLE
Hole table.
Definition: zwapi_dwg_data.h:208
VX_TABLE_PNT
@ VX_TABLE_PNT
Point table.
Definition: zwapi_dwg_data.h:212
VX_TABLE_BOM
@ VX_TABLE_BOM
BOM table.
Definition: zwapi_dwg_data.h:207
VX_TABLE_TRODE
@ VX_TABLE_TRODE
Electrode table.
Definition: zwapi_dwg_data.h:209
VX_TABLE_WELD
@ VX_TABLE_WELD
Weld table.
Definition: zwapi_dwg_data.h:211
VX_TABLE_ALL
@ VX_TABLE_ALL
any table type
Definition: zwapi_dwg_data.h:205
VX_TABLE_DIM
@ VX_TABLE_DIM
Dimension table.
Definition: zwapi_dwg_data.h:213
VX_TABLE_WDSEG
@ VX_TABLE_WDSEG
Structural BOM table.
Definition: zwapi_dwg_data.h:210
VX_TABLE_USER
@ VX_TABLE_USER
User table.
Definition: zwapi_dwg_data.h:206
evxTextFontType
evxTextFontType
font type
Definition: zwapi_dwg_data.h:279
VX_FONTTYPE_NORMAL
@ VX_FONTTYPE_NORMAL
none
Definition: zwapi_dwg_data.h:280
VX_FONTTYPE_PROPORTIONAL
@ VX_FONTTYPE_PROPORTIONAL
proportional
Definition: zwapi_dwg_data.h:281
VX_FONTTYPE_FIXED
@ VX_FONTTYPE_FIXED
fixed
Definition: zwapi_dwg_data.h:282
evxSymbolType
evxSymbolType
symbol object type
Definition: zwapi_dwg_data.h:157
VX_SYM_ALL
@ VX_SYM_ALL
any symbol
Definition: zwapi_dwg_data.h:158
VX_SYM_BEAD
@ VX_SYM_BEAD
caterpillar
Definition: zwapi_dwg_data.h:164
VX_SYM_ENDTRT
@ VX_SYM_ENDTRT
end treatment
Definition: zwapi_dwg_data.h:165
VX_SYM_USER
@ VX_SYM_USER
user defined symbol
Definition: zwapi_dwg_data.h:159
VX_SYM_HOLE_MARK
@ VX_SYM_HOLE_MARK
hole mark
Definition: zwapi_dwg_data.h:167
VX_SYM_OPEN_LINK
@ VX_SYM_OPEN_LINK
OLE object.
Definition: zwapi_dwg_data.h:166
VX_SYM_IMAGE
@ VX_SYM_IMAGE
image
Definition: zwapi_dwg_data.h:162
VX_SYM_SURF
@ VX_SYM_SURF
surface finish
Definition: zwapi_dwg_data.h:160
VX_SYM_WELD
@ VX_SYM_WELD
weld
Definition: zwapi_dwg_data.h:161
VX_SYM_ORIGIN
@ VX_SYM_ORIGIN
origin symbol
Definition: zwapi_dwg_data.h:163
svxRefEntData
struct svxRefEntData svxRefEntData
reference entity data.
evxViewProjAngle
evxViewProjAngle
drawing view projection angle
Definition: zwapi_dwg_data.h:110
VX_VIEW_3RD_UP
@ VX_VIEW_3RD_UP
view projected 3rd angle from above
Definition: zwapi_dwg_data.h:112
VX_VIEW_1ST_RT
@ VX_VIEW_1ST_RT
view projected 1st angle from right
Definition: zwapi_dwg_data.h:118
VX_VIEW_3RD_LT
@ VX_VIEW_3RD_LT
view projected 3rd angle from left
Definition: zwapi_dwg_data.h:115
VX_VIEW_3RD_RT
@ VX_VIEW_3RD_RT
view projected 3rd angle from right
Definition: zwapi_dwg_data.h:114
VX_VIEW_3RD_PRJ_ANG
@ VX_VIEW_3RD_PRJ_ANG
view projected at angle, 3rd angle projection
Definition: zwapi_dwg_data.h:120
VX_VIEW_1ST_PRJ_ANG
@ VX_VIEW_1ST_PRJ_ANG
view projected at angle, 1st angle projection
Definition: zwapi_dwg_data.h:121
VX_VIEW_1ST_UP
@ VX_VIEW_1ST_UP
view projected 1st angle from above
Definition: zwapi_dwg_data.h:116
VX_VIEW_1ST_LT
@ VX_VIEW_1ST_LT
view projected 1st angle from left
Definition: zwapi_dwg_data.h:119
VX_VIEW_1ST_DN
@ VX_VIEW_1ST_DN
view projected 1st angle from below
Definition: zwapi_dwg_data.h:117
VX_VIEW_PROJ_ANG_ALL
@ VX_VIEW_PROJ_ANG_ALL
any view type
Definition: zwapi_dwg_data.h:111
VX_VIEW_3RD_DN
@ VX_VIEW_3RD_DN
view projected 3rd angle from below
Definition: zwapi_dwg_data.h:113
evxViewType
evxViewType
view type
Definition: zwapi_dwg_data.h:96
VX_VIEW_DET
@ VX_VIEW_DET
detail view
Definition: zwapi_dwg_data.h:101
VX_VIEW_BASE
@ VX_VIEW_BASE
base view
Definition: zwapi_dwg_data.h:98
VX_VIEW_ALL
@ VX_VIEW_ALL
any view type
Definition: zwapi_dwg_data.h:97
VX_VIEW_SECT
@ VX_VIEW_SECT
section view
Definition: zwapi_dwg_data.h:100
VX_VIEW_PROJ
@ VX_VIEW_PROJ
project view
Definition: zwapi_dwg_data.h:99
VX_VIEW_DEFN
@ VX_VIEW_DEFN
definition view
Definition: zwapi_dwg_data.h:102
evxVerticalMethod
evxVerticalMethod
vertical method
Definition: zwapi_dwg_data.h:324
VX_VERTICAL_HALF
@ VX_VERTICAL_HALF
half
Definition: zwapi_dwg_data.h:328
VX_VERTICAL_TOP
@ VX_VERTICAL_TOP
top
Definition: zwapi_dwg_data.h:326
VX_VERTICAL_CAP
@ VX_VERTICAL_CAP
cap
Definition: zwapi_dwg_data.h:327
VX_VERTICAL_BASE
@ VX_VERTICAL_BASE
base
Definition: zwapi_dwg_data.h:329
VX_VERTICAL_BOTTOM
@ VX_VERTICAL_BOTTOM
bottom
Definition: zwapi_dwg_data.h:330
VX_VERTICAL_NORMAL
@ VX_VERTICAL_NORMAL
normal
Definition: zwapi_dwg_data.h:325
evxBrkLineCutSty
evxBrkLineCutSty
break Line style
Definition: zwapi_dwg_data.h:129
VX_ZEROZIGZAG_BRKLINE
@ VX_ZEROZIGZAG_BRKLINE
line
Definition: zwapi_dwg_data.h:130
VX_ONEZIGZAG_BRKLINE
@ VX_ONEZIGZAG_BRKLINE
single ZigZag of broken line
Definition: zwapi_dwg_data.h:131
VX_CURVE_BRKLINE
@ VX_CURVE_BRKLINE
curve
Definition: zwapi_dwg_data.h:133
VX_TWOZIGZAG_BRKLINE
@ VX_TWOZIGZAG_BRKLINE
double ZigZag of broken line
Definition: zwapi_dwg_data.h:132
evxTextStroke
evxTextStroke
text precision
Definition: zwapi_dwg_data.h:290
VX_STROKE_FINE
@ VX_STROKE_FINE
fine
Definition: zwapi_dwg_data.h:293
VX_STROKE_COARSE
@ VX_STROKE_COARSE
coarse
Definition: zwapi_dwg_data.h:291
VX_STROKE_MEDIUM
@ VX_STROKE_MEDIUM
medium
Definition: zwapi_dwg_data.h:292
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
style manager type
Definition: zwapi_dwg_data.h:238
VX_STYLEMANAGER_ANNO_BALLOON
@ VX_STYLEMANAGER_ANNO_BALLOON
balloon label
Definition: zwapi_dwg_data.h:242
VX_STYLEMANAGER_TABLE_REVISION
@ VX_STYLEMANAGER_TABLE_REVISION
revision table
Definition: zwapi_dwg_data.h:264
VX_STYLEMANAGER_TEXT
@ VX_STYLEMANAGER_TEXT
text
Definition: zwapi_dwg_data.h:239
VX_STYLEMANAGER_TABLE_HOLE
@ VX_STYLEMANAGER_TABLE_HOLE
hole table
Definition: zwapi_dwg_data.h:260
VX_STYLEMANAGER_VIEW_PROJECTION
@ VX_STYLEMANAGER_VIEW_PROJECTION
projection view
Definition: zwapi_dwg_data.h:267
VX_STYLEMANAGER_DIM_CHAMFER
@ VX_STYLEMANAGER_DIM_CHAMFER
chamfer
Definition: zwapi_dwg_data.h:251
VX_STYLEMANAGER_TABLE_EDM
@ VX_STYLEMANAGER_TABLE_EDM
edm table
Definition: zwapi_dwg_data.h:261
VX_STYLEMANAGER_DIM_LINEAR
@ VX_STYLEMANAGER_DIM_LINEAR
linear
Definition: zwapi_dwg_data.h:247
VX_STYLEMANAGER_TABLE_BOM
@ VX_STYLEMANAGER_TABLE_BOM
bom table
Definition: zwapi_dwg_data.h:259
VX_STYLEMANAGER_ANNO_DATUM_TARGET
@ VX_STYLEMANAGER_ANNO_DATUM_TARGET
datum target
Definition: zwapi_dwg_data.h:244
VX_STYLEMANAGER_VIEW_AUXILIARY
@ VX_STYLEMANAGER_VIEW_AUXILIARY
auxiliary view
Definition: zwapi_dwg_data.h:268
VX_STYLEMANAGER_SYM_WELD
@ VX_STYLEMANAGER_SYM_WELD
weld symbol
Definition: zwapi_dwg_data.h:255
VX_STYLEMANAGER_SYM_SRF_FINISH
@ VX_STYLEMANAGER_SYM_SRF_FINISH
surface finish symbol
Definition: zwapi_dwg_data.h:256
VX_STYLEMANAGER_TABLE_STRUCTURAL
@ VX_STYLEMANAGER_TABLE_STRUCTURAL
structural table
Definition: zwapi_dwg_data.h:262
VX_STYLEMANAGER_TABLE_WELD
@ VX_STYLEMANAGER_TABLE_WELD
weld table
Definition: zwapi_dwg_data.h:263
VX_STYLEMANAGER_DIM_ARC
@ VX_STYLEMANAGER_DIM_ARC
arc length
Definition: zwapi_dwg_data.h:250
VX_STYLEMANAGER_DIM_RADIAL
@ VX_STYLEMANAGER_DIM_RADIAL
radial/diametric
Definition: zwapi_dwg_data.h:249
VX_STYLEMANAGER_ANNO_LEADER
@ VX_STYLEMANAGER_ANNO_LEADER
leader label
Definition: zwapi_dwg_data.h:241
VX_STYLEMANAGER_TABLE_USER
@ VX_STYLEMANAGER_TABLE_USER
user table
Definition: zwapi_dwg_data.h:258
VX_STYLEMANAGER_VIEW_SECTION
@ VX_STYLEMANAGER_VIEW_SECTION
section view
Definition: zwapi_dwg_data.h:269
VX_STYLEMANAGER_ANNO_FEATURE_CONTROL
@ VX_STYLEMANAGER_ANNO_FEATURE_CONTROL
feature control symbol
Definition: zwapi_dwg_data.h:245
VX_STYLEMANAGER_VIEW_DETAIL
@ VX_STYLEMANAGER_VIEW_DETAIL
detail view
Definition: zwapi_dwg_data.h:270
VX_STYLEMANAGER_VIEW_BASE
@ VX_STYLEMANAGER_VIEW_BASE
base view
Definition: zwapi_dwg_data.h:266
VX_STYLEMANAGER_DIM_ORDINATE
@ VX_STYLEMANAGER_DIM_ORDINATE
ordinate
Definition: zwapi_dwg_data.h:253
VX_STYLEMANAGER_DIM_ANGULAR
@ VX_STYLEMANAGER_DIM_ANGULAR
angular
Definition: zwapi_dwg_data.h:248
VX_STYLEMANAGER_ANNO_DATUM_FEATURE
@ VX_STYLEMANAGER_ANNO_DATUM_FEATURE
datum feature
Definition: zwapi_dwg_data.h:243
VX_STYLEMANAGER_VIEW_ALTERNATE
@ VX_STYLEMANAGER_VIEW_ALTERNATE
alternate view
Definition: zwapi_dwg_data.h:271
VX_STYLEMANAGER_DIM_HOLECALLOUT
@ VX_STYLEMANAGER_DIM_HOLECALLOUT
hole callout
Definition: zwapi_dwg_data.h:252
svxDwgStyleManagerViewText
struct svxDwgStyleManagerViewText svxDwgStyleManagerViewText
the text attribute of the view in the style manager.
svxDwgBrkLineAt
struct svxDwgBrkLineAt svxDwgBrkLineAt
attribute of break line
svxDwgStyleManagerText
struct svxDwgStyleManagerText svxDwgStyleManagerText
the text attribute of the text in the style manager.
svxDrawingAt
struct svxDrawingAt svxDrawingAt
Sheet Format Attributes structure.
svxDwgStyleManagerAnnoDimText
struct svxDwgStyleManagerAnnoDimText svxDwgStyleManagerAnnoDimText
the text attribute of the annotation/dimension in the style manager.
svxDwgStyleManagerSymText
struct svxDwgStyleManagerSymText svxDwgStyleManagerSymText
the text attribute of the weld(or surface finish) in the style manager.
svxSymAttr
struct svxSymAttr svxSymAttr
symbol attributes structure
svxDwgBundleDimData
struct svxDwgBundleDimData svxDwgBundleDimData
data of dimension bundle
svxDwgStyleManagerTableText
struct svxDwgStyleManagerTableText svxDwgStyleManagerTableText
the text attribute of the table in the style manager.
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxTermType
evxTermType
terminator types
Definition: zwapi_util.h:2193
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxLineWidth
evxLineWidth
line width
Definition: zwapi_util.h:1434
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxDrawingAt::partNum
int partNum[2]
partNum[0]: the number of the partitions in the direction of horizontal; partNum[1]: the number of th...
Definition: zwapi_dwg_data.h:56
svxDrawingAt::configName
vxLongName configName
configuration name for drawing format
Definition: zwapi_dwg_data.h:42
svxDrawingAt::width
double width
drawing width
Definition: zwapi_dwg_data.h:46
svxDrawingAt::trimmingMark
char trimmingMark
0: no trimming mark; 1:have trimming mark;
Definition: zwapi_dwg_data.h:58
svxDrawingAt::useTemplate
char useTemplate
1-use template,0-use custom
Definition: zwapi_dwg_data.h:44
svxDrawingAt::blockTemplateName
vxLongName blockTemplateName[3]
template name of drawing block, blockTemplateName[0]: template name of title block,...
Definition: zwapi_dwg_data.h:59
svxDrawingAt::margin
double margin[4]
margin[0] the margin of the top; margin[1] the margin of the right; margin[2] the margin of the b...
Definition: zwapi_dwg_data.h:49
svxDrawingAt::idDwgTpl
int idDwgTpl
0 to ignore this. If there are multiple drawing pages in the template file of a drawing and user wa...
Definition: zwapi_dwg_data.h:35
svxDrawingAt::height
double height
drawing height
Definition: zwapi_dwg_data.h:47
svxDrawingAt::useConfig
char useConfig
1-use config,else 0
Definition: zwapi_dwg_data.h:45
svxDrawingAt::templateName
vxLongName templateName
template name
Definition: zwapi_dwg_data.h:34
svxDrawingAt::centerMark
char centerMark
0: have no centering marks;1: have centering marks
Definition: zwapi_dwg_data.h:54
svxDrawingAt::bound
char bound
0: no bound line;1: have bound line
Definition: zwapi_dwg_data.h:53
svxDrawingAt::partition
char partition
0: do not divide the border, 1: divide the border
Definition: zwapi_dwg_data.h:55
svxDrawingAt::paper
char paper[16]
paper size name
Definition: zwapi_dwg_data.h:43
svxDrawingAt::useBorder
char useBorder
1: use border created by the parameters,else 0
Definition: zwapi_dwg_data.h:48
svxDrawingAt
Sheet Format Attributes structure.
Definition: zwapi_dwg_data.h:33
svxDwgBrkLineAt::layerName
vxName layerName
name of layer
Definition: zwapi_dwg_data.h:145
svxDwgBrkLineAt::styleIndex
int styleIndex
index of style of break line
Definition: zwapi_dwg_data.h:146
svxDwgBrkLineAt::gap
double gap
gap size
Definition: zwapi_dwg_data.h:142
svxDwgBrkLineAt::lineAtr
svxLineAt lineAtr
line attributes
Definition: zwapi_dwg_data.h:144
svxDwgBrkLineAt::brkLnCutSty
evxBrkLineCutSty brkLnCutSty
cut style of break line
Definition: zwapi_dwg_data.h:143
svxDwgBrkLineAt
attribute of break line
Definition: zwapi_dwg_data.h:141
svxDwgBundleDimData::dimBundleId
int dimBundleId
dimension bundle id
Definition: zwapi_dwg_data.h:223
svxDwgBundleDimData::count
int count
count of points
Definition: zwapi_dwg_data.h:224
svxDwgBundleDimData::pnts
svxPoint2 * pnts
list of point
Definition: zwapi_dwg_data.h:225
svxDwgBundleDimData::dimValue
double dimValue
dimension value
Definition: zwapi_dwg_data.h:226
svxDwgBundleDimData
data of dimension bundle
Definition: zwapi_dwg_data.h:222
svxDwgStyleManagerAnnoDimText::charSlant
double charSlant
slant angle of each character.
Definition: zwapi_dwg_data.h:396
svxDwgStyleManagerAnnoDimText::color
int color
text color(see evxColor/evxColorAppFlag)
Definition: zwapi_dwg_data.h:389
svxDwgStyleManagerAnnoDimText::charAspect
double charAspect
character aspect = width /height
Definition: zwapi_dwg_data.h:393
svxDwgStyleManagerAnnoDimText::bold
int bold
1 is bold text, else 0.
Definition: zwapi_dwg_data.h:388
svxDwgStyleManagerAnnoDimText::tolchHgtFac
double tolchHgtFac
tolerance of char height factor.(only dimension can use this variable.)
Definition: zwapi_dwg_data.h:397
svxDwgStyleManagerAnnoDimText::multiLineSpace
double multiLineSpace
spacing between multiple lines of text.
Definition: zwapi_dwg_data.h:394
svxDwgStyleManagerAnnoDimText::charHeight
double charHeight
text height
Definition: zwapi_dwg_data.h:392
svxDwgStyleManagerAnnoDimText::fontName
vxLongName fontName
font name
Definition: zwapi_dwg_data.h:382
svxDwgStyleManagerAnnoDimText::align
evxTextAlignment align
text alignment
Definition: zwapi_dwg_data.h:390
svxDwgStyleManagerAnnoDimText::charSpacing
double charSpacing
character spacing.
Definition: zwapi_dwg_data.h:395
svxDwgStyleManagerAnnoDimText::underline
int underline
underline flag: 0x01, overline flag: 0x02, delete line flag 0x04. if underline and overline,...
Definition: zwapi_dwg_data.h:384
svxDwgStyleManagerAnnoDimText::fontName2
vxLongName fontName2
secondary font name
Definition: zwapi_dwg_data.h:383
svxDwgStyleManagerAnnoDimText
the text attribute of the annotation/dimension in the style manager.
Definition: zwapi_dwg_data.h:381
svxDwgStyleManagerSymText::fontName
vxLongName fontName
font name
Definition: zwapi_dwg_data.h:432
svxDwgStyleManagerSymText::fontName2
vxLongName fontName2
secondary font name
Definition: zwapi_dwg_data.h:433
svxDwgStyleManagerSymText::charAspect
double charAspect
character aspect = width /height
Definition: zwapi_dwg_data.h:440
svxDwgStyleManagerSymText::underline
int underline
underline flag: 0x01, overline flag: 0x02, delete line flag 0x04. if underline and overline,...
Definition: zwapi_dwg_data.h:434
svxDwgStyleManagerSymText::charSpacing
double charSpacing
character spacing.
Definition: zwapi_dwg_data.h:441
svxDwgStyleManagerSymText::color
int color
text color(see evxColor/evxColorAppFlag)
Definition: zwapi_dwg_data.h:438
svxDwgStyleManagerSymText::charHeight
double charHeight
text height
Definition: zwapi_dwg_data.h:439
svxDwgStyleManagerSymText
the text attribute of the weld(or surface finish) in the style manager.
Definition: zwapi_dwg_data.h:431
svxDwgStyleManagerTableText::vertical
evxVerticalMethod vertical
vertical text alignment
Definition: zwapi_dwg_data.h:417
svxDwgStyleManagerTableText::multiLineSpace
double multiLineSpace
spacing between multiple lines of text.
Definition: zwapi_dwg_data.h:421
svxDwgStyleManagerTableText::bold
int bold
1 is bold text, else 0.
Definition: zwapi_dwg_data.h:412
svxDwgStyleManagerTableText::color
int color
text color(see evxColor/evxColorAppFlag)
Definition: zwapi_dwg_data.h:413
svxDwgStyleManagerTableText::horizontal
evxHorizontalMethod horizontal
horizontal text alignment
Definition: zwapi_dwg_data.h:416
svxDwgStyleManagerTableText::fontName
vxLongName fontName
font name
Definition: zwapi_dwg_data.h:406
svxDwgStyleManagerTableText::charSpacing
double charSpacing
character spacing.
Definition: zwapi_dwg_data.h:422
svxDwgStyleManagerTableText::charAspect
double charAspect
character aspect = width /height
Definition: zwapi_dwg_data.h:420
svxDwgStyleManagerTableText::underline
int underline
underline flag: 0x01, overline flag: 0x02, delete line flag 0x04. if underline and overline,...
Definition: zwapi_dwg_data.h:408
svxDwgStyleManagerTableText::charHeight
double charHeight
text height
Definition: zwapi_dwg_data.h:419
svxDwgStyleManagerTableText::fontName2
vxLongName fontName2
secondary font name
Definition: zwapi_dwg_data.h:407
svxDwgStyleManagerTableText::charSlant
double charSlant
slant angle of each character.
Definition: zwapi_dwg_data.h:423
svxDwgStyleManagerTableText::fitMethod
evxTextAlignWordWrap fitMethod
fit method
Definition: zwapi_dwg_data.h:415
svxDwgStyleManagerTableText::fontType
evxTextFontType fontType
font type
Definition: zwapi_dwg_data.h:414
svxDwgStyleManagerTableText
the text attribute of the table in the style manager.
Definition: zwapi_dwg_data.h:405
svxDwgStyleManagerText::charSpacing
double charSpacing
character spacing.
Definition: zwapi_dwg_data.h:358
svxDwgStyleManagerText::charSlant
double charSlant
slant angle of each character.
Definition: zwapi_dwg_data.h:359
svxDwgStyleManagerText::fontType
evxTextFontType fontType
font type
Definition: zwapi_dwg_data.h:347
svxDwgStyleManagerText::horizontal
evxHorizontalMethod horizontal
horizontal text alignment
Definition: zwapi_dwg_data.h:350
svxDwgStyleManagerText::fontName2
vxLongName fontName2
secondary font name
Definition: zwapi_dwg_data.h:340
svxDwgStyleManagerText::stroke
evxTextStroke stroke
text precision
Definition: zwapi_dwg_data.h:348
svxDwgStyleManagerText::width
evxLineWidth width
line size
Definition: zwapi_dwg_data.h:346
svxDwgStyleManagerText::charHeight
double charHeight
text height
Definition: zwapi_dwg_data.h:355
svxDwgStyleManagerText::charPath
double charPath
text path as angle 0.0 - 360.0 degrees.
Definition: zwapi_dwg_data.h:361
svxDwgStyleManagerText::underline
int underline
underline flag: 0x01, overline flag: 0x02, delete line flag 0x04. if underline and overline,...
Definition: zwapi_dwg_data.h:341
svxDwgStyleManagerText::color
int color
text color(see evxColor/evxColorAppFlag)
Definition: zwapi_dwg_data.h:345
svxDwgStyleManagerText::charAspect
double charAspect
character aspect = width /height
Definition: zwapi_dwg_data.h:356
svxDwgStyleManagerText::horizontalType
int horizontalType
horizontal text alignment type: 0 is line, 1 is paragraph.
Definition: zwapi_dwg_data.h:351
svxDwgStyleManagerText::fitMethod
evxTextAlignWordWrap fitMethod
fit method
Definition: zwapi_dwg_data.h:349
svxDwgStyleManagerText::vertical
evxVerticalMethod vertical
vertical text alignment
Definition: zwapi_dwg_data.h:352
svxDwgStyleManagerText::fontName
vxLongName fontName
font name
Definition: zwapi_dwg_data.h:339
svxDwgStyleManagerText::multiLineSpace
double multiLineSpace
spacing between multiple lines of text.
Definition: zwapi_dwg_data.h:357
svxDwgStyleManagerText::textAngle
double textAngle
text angle. 0 degress to the right.
Definition: zwapi_dwg_data.h:360
svxDwgStyleManagerText::textExpansion
double textExpansion
factor of text expansion along path.
Definition: zwapi_dwg_data.h:362
svxDwgStyleManagerText::verticalType
int verticalType
vertical text alignment type:0 is line, 1 is paragraph.
Definition: zwapi_dwg_data.h:353
svxDwgStyleManagerText
the text attribute of the text in the style manager.
Definition: zwapi_dwg_data.h:338
svxDwgStyleManagerViewText::underline
int underline
1 if underline flag, else 0.
Definition: zwapi_dwg_data.h:452
svxDwgStyleManagerViewText::multiLineSpace
double multiLineSpace
spacing between multiple lines of text.
Definition: zwapi_dwg_data.h:457
svxDwgStyleManagerViewText::align
evxTextAlignment align
text align
Definition: zwapi_dwg_data.h:454
svxDwgStyleManagerViewText::charHeight
double charHeight
text height
Definition: zwapi_dwg_data.h:455
svxDwgStyleManagerViewText::charSlant
double charSlant
slant angle of each character.
Definition: zwapi_dwg_data.h:459
svxDwgStyleManagerViewText::color
int color
text color(see evxColor/evxColorAppFlag)
Definition: zwapi_dwg_data.h:453
svxDwgStyleManagerViewText::fontName
vxLongName fontName
font name
Definition: zwapi_dwg_data.h:450
svxDwgStyleManagerViewText::charAspect
double charAspect
character aspect = width /height
Definition: zwapi_dwg_data.h:456
svxDwgStyleManagerViewText::charSpacing
double charSpacing
character spacing.
Definition: zwapi_dwg_data.h:458
svxDwgStyleManagerViewText::fontName2
vxLongName fontName2
secondary font name
Definition: zwapi_dwg_data.h:451
svxDwgStyleManagerViewText
the text attribute of the view in the style manager.
Definition: zwapi_dwg_data.h:449
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxLineAt
Line attributes.
Definition: zwapi_util.h:1423
svxPoint2
2D point
Definition: zwapi_util.h:286
svxRefEntData::depth
int depth
depth of the component (top=0,1,2...)
Definition: zwapi_dwg_data.h:85
svxRefEntData::entClass
char entClass
0: component; 1: solid shell; 2: surface shell
Definition: zwapi_dwg_data.h:84
svxRefEntData::partName
vxRootName partName
part name
Definition: zwapi_dwg_data.h:81
svxRefEntData::compPath
svxEntPath compPath
pick-path of the component
Definition: zwapi_dwg_data.h:83
svxRefEntData::shellName
vxLongName shellName
shell name
Definition: zwapi_dwg_data.h:82
svxRefEntData::fileName
vxPath fileName
file name
Definition: zwapi_dwg_data.h:80
svxRefEntData
reference entity data.
Definition: zwapi_dwg_data.h:79
svxSymAttr::textTyp
int textTyp
text orientation (0-horizontal, 1-align)
Definition: zwapi_dwg_data.h:183
svxSymAttr::symAttr
svxLineAt symAttr
general symbol attribute
Definition: zwapi_dwg_data.h:192
svxSymAttr::autoTxtFlg
int autoTxtFlg
auto change text direction flag
Definition: zwapi_dwg_data.h:186
svxSymAttr::extLine
int extLine
extender line (0-suppressed)
Definition: zwapi_dwg_data.h:177
svxSymAttr::charAsp
double charAsp
text character aspect = width / height
Definition: zwapi_dwg_data.h:188
svxSymAttr::termType
evxTermType termType
terminator type
Definition: zwapi_dwg_data.h:179
svxSymAttr::allCir
int allCir
all round circle (0-suppressed)
Definition: zwapi_dwg_data.h:176
svxSymAttr::underLine
int underLine
text underline flag: 0-normal, 1-underline
Definition: zwapi_dwg_data.h:185
svxSymAttr::leaderAttr
svxLineAt leaderAttr
leader line attributes
Definition: zwapi_dwg_data.h:193
svxSymAttr::charHgt
double charHgt
text height
Definition: zwapi_dwg_data.h:187
svxSymAttr::fontName2
char fontName2[37]
secondary font name
Definition: zwapi_dwg_data.h:182
svxSymAttr::scaleFac
double scaleFac
scale factor
Definition: zwapi_dwg_data.h:191
svxSymAttr::fontName
char fontName[37]
font name
Definition: zwapi_dwg_data.h:181
svxSymAttr::extLineSize
double extLineSize
extender line size
Definition: zwapi_dwg_data.h:178
svxSymAttr::termSize
double termSize
terminator size
Definition: zwapi_dwg_data.h:180
svxSymAttr::charSpacing
double charSpacing
text character spacing
Definition: zwapi_dwg_data.h:189
svxSymAttr::bold
int bold
text bold flag: 0-normal, 1-bold
Definition: zwapi_dwg_data.h:184
svxSymAttr::textClr
evxColor textClr
text color
Definition: zwapi_dwg_data.h:190
svxSymAttr
symbol attributes structure
Definition: zwapi_dwg_data.h:175
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_DIM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_dim.h
cvxDwgDimAtGet
cvxDwgDimAtSet
cvxDwgGetDimTextBox
cvxDwgInqBundleDataByDim
cvxDwgInqDimByDrawing
cvxDwgInqDimByView
cvxDwgInqDimEnts
cvxDwgInqDimGripPnts
cvxDwgInqDims

◆ ZW_API_DWG_DIM_H

#define ZW_API_DWG_DIM_H

Definition at line 15 of file zwapi_dwg_dim.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_dim.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_dim.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_DIM_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_DIM_H
16
17#include "zwapi_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
50extern evxErrors cvxDwgInqDims(int idDrawing, evxDimType* dimTypeList, int dimTypeCount, int* count, int** dims);
51
52/******************************************************************************/
72extern evxErrors cvxDwgInqDimEnts(int idDim, int* count, int** idEnts);
73
74/******************************************************************************/
94extern evxErrors cvxDwgInqDimGripPnts(int idDim, int* Num, svxPoint** Pnts);
95
96/******************************************************************************/
115extern evxErrors cvxDwgGetDimTextBox(int idDim, double* tbWid, double* tbHgt, double* chSlp, svxPoint2* txtPt);
116
117/******************************************************************************/
148extern evxErrors cvxDwgInqDimByView(int idView, int* count, int** idDims);
149
150/******************************************************************************/
181extern evxErrors cvxDwgInqDimByDrawing(int idDrawing, int* count, int** idDims);
182
183/******************************************************************************/
204extern evxErrors cvxDwgInqBundleDataByDim(int idDim, int* count, svxDwgBundleDimData** data);
205
206
207//====================================================================================================================
209//====================================================================================================================
210/******************************************************************************/
227extern evxErrors cvxDwgDimAtGet(int idDim, svxDimAttr* dmAttr);
228
229/******************************************************************************/
251extern evxErrors cvxDwgDimAtSet(int idDim, svxDimAttr* dmAttr);
252
253
254/*
255*********************************************************************
256** END HEADER FILE
257*********************************************************************
258*/
259
260#ifdef __cplusplus
261 }
262#endif /* __cplusplus */
263
264#endif /* ZW_API_DWG_DIM_H */
cvxDwgInqBundleDataByDim
evxErrors cvxDwgInqBundleDataByDim(int idDim, int *count, svxDwgBundleDimData **data)
cvxDwgInqDimByDrawing
evxErrors cvxDwgInqDimByDrawing(int idDrawing, int *count, int **idDims)
cvxDwgGetDimTextBox
evxErrors cvxDwgGetDimTextBox(int idDim, double *tbWid, double *tbHgt, double *chSlp, svxPoint2 *txtPt)
cvxDwgDimAtSet
evxErrors cvxDwgDimAtSet(int idDim, svxDimAttr *dmAttr)
cvxDwgInqDims
evxErrors cvxDwgInqDims(int idDrawing, evxDimType *dimTypeList, int dimTypeCount, int *count, int **dims)
cvxDwgInqDimGripPnts
evxErrors cvxDwgInqDimGripPnts(int idDim, int *Num, svxPoint **Pnts)
cvxDwgInqDimEnts
evxErrors cvxDwgInqDimEnts(int idDim, int *count, int **idEnts)
cvxDwgInqDimByView
evxErrors cvxDwgInqDimByView(int idView, int *count, int **idDims)
cvxDwgDimAtGet
evxErrors cvxDwgDimAtGet(int idDim, svxDimAttr *dmAttr)
evxDimType
evxDimType
dimension type
Definition: zwapi_util.h:1934
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxDimAttr
Dimension attributes structure.
Definition: zwapi_util.h:2235
svxDwgBundleDimData
data of dimension bundle
Definition: zwapi_dwg_data.h:222
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_drawing.h
cvxDwgActivate
cvxDwgFind
cvxDwgInqActive
cvxDwgInqBorderTitle
cvxDwgInqList
cvxDwgInqName
cvxDwgInqPart
cvxDwgRegen
cvxDwgSetRefPart
cvxDwgSheetAdd
cvxDwgSheetDel
cvxDwgSheetScaleGet
cvxDwgSheetScaleSet
cvxDwgStyleManagerWithTextAtGet

◆ ZW_API_DWG_H

#define ZW_API_DWG_H

Definition at line 15 of file zwapi_dwg_drawing.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_drawing.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_drawing.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_H
16
17#include "zwapi_dwg_data.h"
18#include "zwapi_cmd_dwg_data.h"
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24//====================================================================================================================
26//====================================================================================================================
27/******************************************************************************/
46extern evxErrors cvxDwgSheetAdd(vxLongName Name, int* idSheet);
47
48/******************************************************************************/
67extern evxErrors cvxDwgSheetDel(int count, int* idSheet);
68
69/******************************************************************************/
87extern evxErrors cvxDwgSheetScaleGet(int idSheet, double* scale);
88
89/******************************************************************************/
106extern evxErrors cvxDwgSheetScaleSet(int idSheet, double scale);
107
108
109//====================================================================================================================
111//====================================================================================================================
112/******************************************************************************/
132extern evxErrors cvxDwgInqList(int idRoot, int* count, int** idDrawings);
133
134/******************************************************************************/
152extern evxErrors cvxDwgInqName(int idDrawing, char* drawingName, int nBytes);
153
154/******************************************************************************/
172extern evxErrors cvxDwgFind(const vxRootName rootName, const vxLongName drawingName, int* idDrawing);
173
174/******************************************************************************/
192extern evxErrors cvxDwgInqBorderTitle(int idDrawing, int* idBorder, int* idBorderSkt, int* idTitle, int* idTitleSkt);
193
194/******************************************************************************/
211extern evxErrors cvxDwgInqPart(char* rootName, int* iCount, svxCompName** partList);
212
213/******************************************************************************/
239extern evxErrors cvxDwgSetRefPart(const char* File, const char* Root, int idxView, svxCompName* oldPart, svxCompName* newPart);
240
241/******************************************************************************/
254extern evxErrors cvxDwgActivate(vxLongName drawingName);
255
256/******************************************************************************/
271extern evxErrors cvxDwgInqActive(char* drawingName, int nBytes);
272
273/******************************************************************************/
294extern evxErrors cvxDwgRegen(int count, int* idViews, int isRegenUnModifiedView, int isRegenTable, int isPrompt, int isRegenSketch);
295
296//====================================================================================================================
298//====================================================================================================================
299
300/******************************************************************************/
333extern evxErrors cvxDwgStyleManagerWithTextAtGet(evxDwgStyleManagerMethod type, void* data);
334
335/*
336*********************************************************************
337** END HEADER FILE
338*********************************************************************
339*/
340
341#ifdef __cplusplus
342 }
343#endif /* __cplusplus */
344
345#endif /* ZW_API_DWG_H */
evxDwgStyleManagerMethod
evxDwgStyleManagerMethod
style manager type
Definition: zwapi_dwg_data.h:238
cvxDwgInqBorderTitle
evxErrors cvxDwgInqBorderTitle(int idDrawing, int *idBorder, int *idBorderSkt, int *idTitle, int *idTitleSkt)
cvxDwgInqActive
evxErrors cvxDwgInqActive(char *drawingName, int nBytes)
cvxDwgSheetDel
evxErrors cvxDwgSheetDel(int count, int *idSheet)
cvxDwgRegen
evxErrors cvxDwgRegen(int count, int *idViews, int isRegenUnModifiedView, int isRegenTable, int isPrompt, int isRegenSketch)
cvxDwgFind
evxErrors cvxDwgFind(const vxRootName rootName, const vxLongName drawingName, int *idDrawing)
cvxDwgInqPart
evxErrors cvxDwgInqPart(char *rootName, int *iCount, svxCompName **partList)
cvxDwgInqList
evxErrors cvxDwgInqList(int idRoot, int *count, int **idDrawings)
cvxDwgStyleManagerWithTextAtGet
evxErrors cvxDwgStyleManagerWithTextAtGet(evxDwgStyleManagerMethod type, void *data)
cvxDwgSheetScaleGet
evxErrors cvxDwgSheetScaleGet(int idSheet, double *scale)
cvxDwgSheetScaleSet
evxErrors cvxDwgSheetScaleSet(int idSheet, double scale)
cvxDwgSetRefPart
evxErrors cvxDwgSetRefPart(const char *File, const char *Root, int idxView, svxCompName *oldPart, svxCompName *newPart)
cvxDwgSheetAdd
evxErrors cvxDwgSheetAdd(vxLongName Name, int *idSheet)
cvxDwgInqName
evxErrors cvxDwgInqName(int idDrawing, char *drawingName, int nBytes)
cvxDwgActivate
evxErrors cvxDwgActivate(vxLongName drawingName)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCompName
brief component info
Definition: zwapi_util.h:2287
zwapi_cmd_dwg_data.h
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_GEOMETRY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_geometry.h
cvxDwgGeomGetView
cvxDwgHatchAssoCrvsGet
cvxDwgHatchAttrSet
cvxDwgInqGeom
cvxDwgInqHatchAttr
cvxDwgInqHatchIdByDrawing
cvxDwgInqHatchIdByView
cvxDwgInqText
cvxDwgRefEntDataGet
cvxDwgViewGeomGetShapeId
cvxDwgViewGeomInqList
cvxDwgViewInqRefEnts
cvxDwgViewPnt2DTo3D
cvxDwgViewPnt3DTo2D
cvxDwgViewRefBlankGet
cvxDwgViewRefBlankSet
cvxDwgViewRefCompVisSet
cvxDwgViewRefEntAtGet
cvxDwgViewRefEntAtSet

◆ ZW_API_DWG_GEOMETRY_H

#define ZW_API_DWG_GEOMETRY_H

Definition at line 15 of file zwapi_dwg_geometry.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_geometry.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_geometry.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_GEOMETRY_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_GEOMETRY_H
16
17#include "zwapi_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
47extern evxErrors cvxDwgInqGeom(int idDrawing, int* count, int** idEnts);
48
49/******************************************************************************/
70extern evxErrors cvxDwgInqText(int idDrawing, int* count, int** idEnts);
71
72/******************************************************************************/
90extern evxErrors cvxDwgInqHatchAttr(int idHatch, svxHatchAttr* HatchAttr);
91
92/******************************************************************************/
109extern evxErrors cvxDwgHatchAttrSet(int idHatch, svxHatchAttr HatchAttr);
110
111/******************************************************************************/
130extern evxErrors cvxDwgHatchAssoCrvsGet(int idHatch, int* count, int** AssocCrvs);
131
132/******************************************************************************/
154extern evxErrors cvxDwgInqHatchIdByView(int idView, int* count, int** idHatchs);
155
156/******************************************************************************/
178extern evxErrors cvxDwgInqHatchIdByDrawing(int idDrawing, int* count, int** idHatchs);
179
180/******************************************************************************/
198extern evxErrors cvxDwgRefEntDataGet(int idRefEnt, svxRefEntData* data);
199
200/******************************************************************************/
216extern evxErrors cvxDwgGeomGetView(int idGeom, int* idView);
217
218
219//====================================================================================================================
221//====================================================================================================================
222/******************************************************************************/
278extern evxErrors cvxDwgViewGeomInqList(int viewId, int option, int* count, int** indices);
279
280/******************************************************************************/
308extern evxErrors cvxDwgViewGeomGetShapeId(int geomId, char* fileName, int fileNameBytes, char* partName,
309 int partNameBytes, svxEntPath* pickPath, int* geom3DId, int* shapeId);
310
311/******************************************************************************/
332extern evxErrors cvxDwgViewRefCompVisSet(int idView, const vxLongPath fileName, const vxRootName partName, int show);
333
334/******************************************************************************/
355extern evxErrors cvxDwgViewInqRefEnts(int viewId, int* count, int** idRefEnts);
356
357/******************************************************************************/
374extern evxErrors cvxDwgViewRefBlankGet(int idRefEnt, int* blank);
375
376/******************************************************************************/
393extern evxErrors cvxDwgViewRefBlankSet(int idRefEnt, int blank);
394
395/******************************************************************************/
416extern evxErrors cvxDwgViewRefEntAtGet(int idRefEnt, int* clrValid, int* typeValid, int* widthValid, svxLineAt* entAt);
417
418/******************************************************************************/
439extern evxErrors cvxDwgViewRefEntAtSet(int idRefEnt, int clrValid, int typeValid, int widthValid, const svxLineAt* entAt);
440
441/******************************************************************************/
461extern evxErrors cvxDwgViewPnt2DTo3D(int pnt2DId, svxPoint* pnt3D);
462
463/******************************************************************************/
482extern evxErrors cvxDwgViewPnt3DTo2D(int viewId, svxPoint pnt3D, svxPoint2* pnt2D);
483
484
485/*
486*********************************************************************
487** END HEADER FILE
488*********************************************************************
489*/
490
491#ifdef __cplusplus
492 }
493#endif /* __cplusplus */
494
495#endif /* ZW_API_DWG_GEOMETRY_H */
cvxDwgViewRefEntAtSet
evxErrors cvxDwgViewRefEntAtSet(int idRefEnt, int clrValid, int typeValid, int widthValid, const svxLineAt *entAt)
cvxDwgViewInqRefEnts
evxErrors cvxDwgViewInqRefEnts(int viewId, int *count, int **idRefEnts)
cvxDwgViewRefEntAtGet
evxErrors cvxDwgViewRefEntAtGet(int idRefEnt, int *clrValid, int *typeValid, int *widthValid, svxLineAt *entAt)
cvxDwgHatchAssoCrvsGet
evxErrors cvxDwgHatchAssoCrvsGet(int idHatch, int *count, int **AssocCrvs)
cvxDwgInqHatchAttr
evxErrors cvxDwgInqHatchAttr(int idHatch, svxHatchAttr *HatchAttr)
cvxDwgHatchAttrSet
evxErrors cvxDwgHatchAttrSet(int idHatch, svxHatchAttr HatchAttr)
cvxDwgViewGeomGetShapeId
evxErrors cvxDwgViewGeomGetShapeId(int geomId, char *fileName, int fileNameBytes, char *partName, int partNameBytes, svxEntPath *pickPath, int *geom3DId, int *shapeId)
cvxDwgInqHatchIdByView
evxErrors cvxDwgInqHatchIdByView(int idView, int *count, int **idHatchs)
cvxDwgViewRefBlankSet
evxErrors cvxDwgViewRefBlankSet(int idRefEnt, int blank)
cvxDwgInqText
evxErrors cvxDwgInqText(int idDrawing, int *count, int **idEnts)
cvxDwgViewPnt3DTo2D
evxErrors cvxDwgViewPnt3DTo2D(int viewId, svxPoint pnt3D, svxPoint2 *pnt2D)
cvxDwgViewGeomInqList
evxErrors cvxDwgViewGeomInqList(int viewId, int option, int *count, int **indices)
cvxDwgRefEntDataGet
evxErrors cvxDwgRefEntDataGet(int idRefEnt, svxRefEntData *data)
cvxDwgInqHatchIdByDrawing
evxErrors cvxDwgInqHatchIdByDrawing(int idDrawing, int *count, int **idHatchs)
cvxDwgGeomGetView
evxErrors cvxDwgGeomGetView(int idGeom, int *idView)
cvxDwgViewRefCompVisSet
evxErrors cvxDwgViewRefCompVisSet(int idView, const vxLongPath fileName, const vxRootName partName, int show)
cvxDwgViewPnt2DTo3D
evxErrors cvxDwgViewPnt2DTo3D(int pnt2DId, svxPoint *pnt3D)
cvxDwgViewRefBlankGet
evxErrors cvxDwgViewRefBlankGet(int idRefEnt, int *blank)
cvxDwgInqGeom
evxErrors cvxDwgInqGeom(int idDrawing, int *count, int **idEnts)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxHatchAttr
hatch attributes
Definition: zwapi_cmd_dwg_data.h:1611
svxLineAt
Line attributes.
Definition: zwapi_util.h:1423
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxRefEntData
reference entity data.
Definition: zwapi_dwg_data.h:79
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_SYMBOL_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_symbol.h
cvxDwgInqSymEnts
cvxDwgInqSymObjList
cvxDwgInqSymType
cvxDwgSymAtGet
cvxDwgSymAtSet
cvxDwgSymImgAtGet
cvxDwgSymImgAtSet
cvxDwgSymInsPointGet
cvxDwgSymInsPointSet
cvxDwgSymLinkExport
cvxDwgSymLinkExportByLongPath
cvxDwgSymLinkGet
cvxDwgSymLinkGetByLongPath
cvxDwgSymSurfDataGet
cvxDwgSymSurfDataSet
cvxDwgSymWeldDataGet
cvxDwgSymWeldDataSet
cvxDwgUserSymObjGet
cvxShtInqSymbol
cvxSymWeldFree

◆ ZW_API_DWG_SYMBOL_H

#define ZW_API_DWG_SYMBOL_H

Definition at line 15 of file zwapi_dwg_symbol.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_symbol.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_symbol.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_SYMBOL_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_SYMBOL_H
16
17#include "zwapi_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23
24//====================================================================================================================
26//====================================================================================================================
27/******************************************************************************/
47extern evxErrors cvxShtInqSymbol(evxSymbolType type, int* Count, int** idEnts);
48
49/******************************************************************************/
68extern evxErrors cvxDwgInqSymObjList(int idSym, int* count, int** listId);
69
70/******************************************************************************/
89extern evxErrors cvxDwgInqSymType(int idSym, evxSymbolType* type);
90
91/******************************************************************************/
111extern evxErrors cvxDwgInqSymEnts(int idSym, int* Count, int** idEnts);
112
113
114//====================================================================================================================
116//====================================================================================================================
117/******************************************************************************/
136extern evxErrors cvxDwgSymAtGet(int idSym, svxSymAttr* symAttr);
137
138/******************************************************************************/
156extern evxErrors cvxDwgSymAtSet(int idSym, svxSymAttr* symAttr);
157
158/******************************************************************************/
174extern evxErrors cvxDwgSymImgAtGet(int idSymImg, svxSymImg* data);
175
176/******************************************************************************/
193extern evxErrors cvxDwgSymImgAtSet(int idSymImg, const svxSymImg* data);
194
195
196//====================================================================================================================
198//====================================================================================================================
199/******************************************************************************/
217extern evxErrors cvxDwgSymSurfDataGet(int idSymSurf, svxSymSurf* data);
218
219/******************************************************************************/
236extern evxErrors cvxDwgSymSurfDataSet(int idSymSurf, svxSymSurf* data);
237
238/******************************************************************************/
260extern evxErrors cvxDwgSymWeldDataGet(const int idSymWeld, svxSymWeld* data);
261
262/******************************************************************************/
279extern evxErrors cvxDwgSymWeldDataSet(const int idSymWeld, const svxSymWeld* data);
280
281/******************************************************************************/
292extern void cvxSymWeldFree(svxSymWeld* WeldData);
293
294/******************************************************************************/
315extern evxErrors cvxDwgUserSymObjGet(const int idSymUser, int* nObj, int** idObjs);
316
317/******************************************************************************/
337extern evxErrors cvxDwgSymInsPointGet(int idSym, svxPoint2* pnt);
338
339/******************************************************************************/
361extern evxErrors cvxDwgSymInsPointSet(int idSym, svxPoint2* pnt);
362
363/******************************************************************************/
380extern evxErrors cvxDwgSymLinkGet(const int idSymLink, vxPath filePath);
381
382/******************************************************************************/
404extern evxErrors cvxDwgSymLinkGetByLongPath(const int idSymLink, char *filePath,int sizePath);
405
406/******************************************************************************/
425extern evxErrors cvxDwgSymLinkExport(const int idSymLink, vxPath filePath);
426/******************************************************************************/
450extern evxErrors cvxDwgSymLinkExportByLongPath(const int idSymLink, char* filePath, int sizePath);
451
452/*
453*********************************************************************
454** END HEADER FILE
455*********************************************************************
456*/
457
458#ifdef __cplusplus
459 }
460#endif /* __cplusplus */
461
462#endif /* ZW_API_DWG_SYMBOL_H */
evxSymbolType
evxSymbolType
symbol object type
Definition: zwapi_dwg_data.h:157
cvxDwgSymInsPointSet
evxErrors cvxDwgSymInsPointSet(int idSym, svxPoint2 *pnt)
cvxShtInqSymbol
evxErrors cvxShtInqSymbol(evxSymbolType type, int *Count, int **idEnts)
cvxDwgSymWeldDataGet
evxErrors cvxDwgSymWeldDataGet(const int idSymWeld, svxSymWeld *data)
cvxDwgSymAtGet
evxErrors cvxDwgSymAtGet(int idSym, svxSymAttr *symAttr)
cvxDwgInqSymType
evxErrors cvxDwgInqSymType(int idSym, evxSymbolType *type)
cvxDwgSymAtSet
evxErrors cvxDwgSymAtSet(int idSym, svxSymAttr *symAttr)
cvxDwgSymLinkExportByLongPath
evxErrors cvxDwgSymLinkExportByLongPath(const int idSymLink, char *filePath, int sizePath)
cvxDwgSymSurfDataSet
evxErrors cvxDwgSymSurfDataSet(int idSymSurf, svxSymSurf *data)
cvxSymWeldFree
void cvxSymWeldFree(svxSymWeld *WeldData)
cvxDwgInqSymObjList
evxErrors cvxDwgInqSymObjList(int idSym, int *count, int **listId)
cvxDwgSymImgAtGet
evxErrors cvxDwgSymImgAtGet(int idSymImg, svxSymImg *data)
cvxDwgUserSymObjGet
evxErrors cvxDwgUserSymObjGet(const int idSymUser, int *nObj, int **idObjs)
cvxDwgSymLinkGetByLongPath
evxErrors cvxDwgSymLinkGetByLongPath(const int idSymLink, char *filePath, int sizePath)
cvxDwgSymWeldDataSet
evxErrors cvxDwgSymWeldDataSet(const int idSymWeld, const svxSymWeld *data)
cvxDwgSymSurfDataGet
evxErrors cvxDwgSymSurfDataGet(int idSymSurf, svxSymSurf *data)
cvxDwgSymLinkExport
evxErrors cvxDwgSymLinkExport(const int idSymLink, vxPath filePath)
cvxDwgSymLinkGet
evxErrors cvxDwgSymLinkGet(const int idSymLink, vxPath filePath)
cvxDwgInqSymEnts
evxErrors cvxDwgInqSymEnts(int idSym, int *Count, int **idEnts)
cvxDwgSymImgAtSet
evxErrors cvxDwgSymImgAtSet(int idSymImg, const svxSymImg *data)
cvxDwgSymInsPointGet
evxErrors cvxDwgSymInsPointGet(int idSym, svxPoint2 *pnt)
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPoint2
2D point
Definition: zwapi_util.h:286
svxSymAttr
symbol attributes structure
Definition: zwapi_dwg_data.h:175
svxSymImg
image data
Definition: zwapi_cmd_dwg_data.h:1508
svxSymSurf
surface finish data
Definition: zwapi_cmd_dwg_data.h:1485
svxSymWeld
Weld data.
Definition: zwapi_cmd_dwg_data.h:1408
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_TABLE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_table.h
cvxDwgGetTableSize
cvxDwgInqTables
cvxDwgInqTableType
cvxDwgTableAdjustSize
cvxDwgTableCellAtGet
cvxDwgTableCellAtSet
cvxDwgTableCellGet
cvxDwgTableCellSet
cvxDwgTableCellsMerge
cvxDwgTableCellsUnMerge
cvxDwgTableColDelete
cvxDwgTableColInsert
cvxDwgTableColWidthSet
cvxDwgTableExport
cvxDwgTableInsPntGet
cvxDwgTableInsPntSet
cvxDwgTableLinkToExcel
cvxDwgTableRowDelete
cvxDwgTableRowHeightSet
cvxDwgTableRowInsert

◆ ZW_API_DWG_TABLE_H

#define ZW_API_DWG_TABLE_H

Definition at line 15 of file zwapi_dwg_table.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_table.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_table.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_TABLE_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_TABLE_H
16
17#include "zwapi_dwg_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23
24//====================================================================================================================
26//====================================================================================================================
27/******************************************************************************/
47extern evxErrors cvxDwgInqTables(int idDrawing, evxTableType type, int* count, int** tables);
48
49/******************************************************************************/
68extern evxErrors cvxDwgInqTableType(int idTable, evxTableType* type);
69
70/******************************************************************************/
86extern evxErrors cvxDwgGetTableSize(int iTblIdx, int* pRowNum, int* pColNum);
87
88/******************************************************************************/
102extern evxErrors cvxDwgTableAdjustSize(int idTable);
103
104/******************************************************************************/
126extern evxErrors cvxDwgTableInsPntSet(int idTable, svxPoint2* pnt);
127
128/******************************************************************************/
148extern evxErrors cvxDwgTableInsPntGet(int idTable, svxPoint2* pnt);
149
150/******************************************************************************/
167extern evxErrors cvxDwgTableExport(int idTable, const vxLongPath path);
168
169/******************************************************************************/
184extern evxErrors cvxDwgTableLinkToExcel(int idTable, const vxLongPath path);
185
186//====================================================================================================================
188//====================================================================================================================
189/******************************************************************************/
207extern evxErrors cvxDwgTableRowHeightSet(int idTable, int Row, double Height);
208
209/******************************************************************************/
226extern evxErrors cvxDwgTableRowInsert(int idTable, int Row);
227
228/******************************************************************************/
245extern evxErrors cvxDwgTableRowDelete(int idTable, int Row);
246
247/******************************************************************************/
265extern evxErrors cvxDwgTableColWidthSet(int idTable, int Col, double Width);
266
267/******************************************************************************/
284extern evxErrors cvxDwgTableColInsert(int idTable, int Col);
285
286/******************************************************************************/
303extern evxErrors cvxDwgTableColDelete(int idTable, int Col);
304
305
306//====================================================================================================================
308//====================================================================================================================
309/******************************************************************************/
330extern evxErrors cvxDwgTableCellAtGet(int idTable, int Row, int Col, svxTextAt* TextAt);
331
332/******************************************************************************/
361extern evxErrors cvxDwgTableCellAtSet(int idTable, int Row, int Col, svxTextAt* TextAt);
362
363
364//====================================================================================================================
366//====================================================================================================================
367/******************************************************************************/
389extern evxErrors cvxDwgTableCellSet(int idTable, int Row, int Col, char* Value);
390
391/******************************************************************************/
413extern evxErrors cvxDwgTableCellGet(int idTable, int Row, int Col, char* Value, int nBytes);
414
415/******************************************************************************/
442extern void cvxDwgTableCellsMerge(int idTable, int startRow, int endRow, int startCol, int endCol, int kFirstData);
443
444/******************************************************************************/
462extern void cvxDwgTableCellsUnMerge(int idTable, int minRow, int maxRow, int minCol, int maxCol);
463
464
465/*
466*********************************************************************
467** END HEADER FILE
468*********************************************************************
469*/
470
471#ifdef __cplusplus
472 }
473#endif /* __cplusplus */
474
475#endif /* ZW_API_DWG_TABLE_H */
evxTableType
evxTableType
table type
Definition: zwapi_dwg_data.h:204
cvxDwgTableInsPntGet
evxErrors cvxDwgTableInsPntGet(int idTable, svxPoint2 *pnt)
cvxDwgInqTables
evxErrors cvxDwgInqTables(int idDrawing, evxTableType type, int *count, int **tables)
cvxDwgTableCellsUnMerge
void cvxDwgTableCellsUnMerge(int idTable, int minRow, int maxRow, int minCol, int maxCol)
cvxDwgTableCellGet
evxErrors cvxDwgTableCellGet(int idTable, int Row, int Col, char *Value, int nBytes)
cvxDwgTableInsPntSet
evxErrors cvxDwgTableInsPntSet(int idTable, svxPoint2 *pnt)
cvxDwgTableCellAtGet
evxErrors cvxDwgTableCellAtGet(int idTable, int Row, int Col, svxTextAt *TextAt)
cvxDwgTableAdjustSize
evxErrors cvxDwgTableAdjustSize(int idTable)
cvxDwgGetTableSize
evxErrors cvxDwgGetTableSize(int iTblIdx, int *pRowNum, int *pColNum)
cvxDwgTableRowInsert
evxErrors cvxDwgTableRowInsert(int idTable, int Row)
cvxDwgTableRowHeightSet
evxErrors cvxDwgTableRowHeightSet(int idTable, int Row, double Height)
cvxDwgTableColInsert
evxErrors cvxDwgTableColInsert(int idTable, int Col)
cvxDwgTableCellSet
evxErrors cvxDwgTableCellSet(int idTable, int Row, int Col, char *Value)
cvxDwgTableColDelete
evxErrors cvxDwgTableColDelete(int idTable, int Col)
cvxDwgTableCellAtSet
evxErrors cvxDwgTableCellAtSet(int idTable, int Row, int Col, svxTextAt *TextAt)
cvxDwgTableCellsMerge
void cvxDwgTableCellsMerge(int idTable, int startRow, int endRow, int startCol, int endCol, int kFirstData)
cvxDwgTableColWidthSet
evxErrors cvxDwgTableColWidthSet(int idTable, int Col, double Width)
cvxDwgTableLinkToExcel
evxErrors cvxDwgTableLinkToExcel(int idTable, const vxLongPath path)
cvxDwgTableExport
evxErrors cvxDwgTableExport(int idTable, const vxLongPath path)
cvxDwgTableRowDelete
evxErrors cvxDwgTableRowDelete(int idTable, int Row)
cvxDwgInqTableType
evxErrors cvxDwgInqTableType(int idTable, evxTableType *type)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPoint2
2D point
Definition: zwapi_util.h:286
svxTextAt
text attribute
Definition: zwapi_util.h:1454
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DWG_VIEW_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_dwg_view.h
cvxDwgAlignmentGet
cvxDwgBrkLineAtGet
cvxDwgBrkLineAtSet
cvxDwgInqViewMod
cvxDwgInqViews
cvxDwgInqViewType
cvxDwgInqViewTypeEx
cvxDwgViewAtGet
cvxDwgViewAtSet
cvxDwgViewDottedBorderGet
cvxDwgViewEntitiesAssociate
cvxDwgViewInqChildView
cvxDwgViewInqOrgPnt
cvxDwgViewInqPart
cvxDwgViewInqPartConfig
cvxDwgViewInqPartConfigByLongName
cvxDwgViewInqProjection
cvxDwgViewLocationGet
cvxDwgViewLockGet
cvxDwgViewLockSet

◆ ZW_API_DWG_VIEW_H

#define ZW_API_DWG_VIEW_H

Definition at line 15 of file zwapi_dwg_view.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_dwg_view.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_dwg_view.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DWG_VIEW_H /* this ifndef surrounds entire header */
15#define ZW_API_DWG_VIEW_H
16
17#include "zwapi_dwg_data.h"
18#include "zwapi_cmd_dwg_data.h"
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24//====================================================================================================================
26//====================================================================================================================
27/******************************************************************************/
46extern evxErrors cvxDwgInqViews(int idDrawing, evxViewType type, int* count, int** views);
47
48/******************************************************************************/
65extern evxErrors cvxDwgInqViewMod(int idDrawing, int* modified);
66
67/******************************************************************************/
85extern evxErrors cvxDwgInqViewType(int idView, evxViewType* type);
86
87/******************************************************************************/
107extern evxErrors cvxDwgInqViewTypeEx(int viewId, evxViewTypeEx* viewType);
108
109/******************************************************************************/
129extern evxErrors cvxDwgViewAtGet(int idView, svxViewAt* viewAttr);
130
131/******************************************************************************/
150extern evxErrors cvxDwgViewAtSet(int idView, svxViewAt* viewAttr);
151
152/******************************************************************************/
171extern evxErrors cvxDwgViewLockSet(int idView, int lock);
172
173/******************************************************************************/
191extern evxErrors cvxDwgViewLockGet(int idView, int* isLock);
192
193/******************************************************************************/
213extern evxErrors cvxDwgViewDottedBorderGet(int idView, svxPoint2* UpperLeft,
214 svxPoint2* UpperRight, svxPoint2* BottomLeft, svxPoint2* BottomRight);
215
216/******************************************************************************/
233extern evxErrors cvxDwgViewInqPart(int idView, svxCompName* part);
234
235/******************************************************************************/
253extern evxErrors cvxDwgViewInqPartConfig(int idView, vxName partCfg);
254
255/******************************************************************************/
274extern evxErrors cvxDwgViewInqPartConfigByLongName(int idView, char* partCfg, int size);
275
276/******************************************************************************/
295extern evxErrors cvxDwgViewInqChildView(int idView, int* count, int** idViews);
296
297/******************************************************************************/
313extern evxErrors cvxDwgViewEntitiesAssociate(int idView, int count, int* idEnts);
314
315/******************************************************************************/
334extern evxErrors cvxDwgViewInqProjection(int idView, evxViewProjAngle* projection);
335
336/******************************************************************************/
353extern evxErrors cvxDwgViewLocationGet(int idView, svxPoint2* point);
354
355/******************************************************************************/
370extern evxErrors cvxDwgAlignmentGet(int idView, int* align);
371
372/******************************************************************************/
390extern evxErrors cvxDwgViewInqOrgPnt(int idView, svxPoint2* pnt, int* idEnt);
391
392/******************************************************************************/
410extern evxErrors cvxDwgBrkLineAtSet(int brkLnViewId, const svxDwgBrkLineAt* brkLineAt);
411
412/******************************************************************************/
429extern evxErrors cvxDwgBrkLineAtGet(int brkLnViewId, svxDwgBrkLineAt* brkLineAt);
430
431
432/*
433*********************************************************************
434** END HEADER FILE
435*********************************************************************
436*/
437
438#ifdef __cplusplus
439 }
440#endif /* __cplusplus */
441
442#endif /* ZW_API_DWG_VIEW_H */
evxViewTypeEx
evxViewTypeEx
View type, more detailed than evxViewType.
Definition: zwapi_cmd_dwg_data.h:140
evxViewProjAngle
evxViewProjAngle
drawing view projection angle
Definition: zwapi_dwg_data.h:110
evxViewType
evxViewType
view type
Definition: zwapi_dwg_data.h:96
cvxDwgViewLockSet
evxErrors cvxDwgViewLockSet(int idView, int lock)
cvxDwgViewInqProjection
evxErrors cvxDwgViewInqProjection(int idView, evxViewProjAngle *projection)
cvxDwgInqViewMod
evxErrors cvxDwgInqViewMod(int idDrawing, int *modified)
cvxDwgViewInqPartConfig
evxErrors cvxDwgViewInqPartConfig(int idView, vxName partCfg)
cvxDwgBrkLineAtSet
evxErrors cvxDwgBrkLineAtSet(int brkLnViewId, const svxDwgBrkLineAt *brkLineAt)
cvxDwgInqViewType
evxErrors cvxDwgInqViewType(int idView, evxViewType *type)
cvxDwgViewAtSet
evxErrors cvxDwgViewAtSet(int idView, svxViewAt *viewAttr)
cvxDwgViewAtGet
evxErrors cvxDwgViewAtGet(int idView, svxViewAt *viewAttr)
cvxDwgViewInqOrgPnt
evxErrors cvxDwgViewInqOrgPnt(int idView, svxPoint2 *pnt, int *idEnt)
cvxDwgInqViewTypeEx
evxErrors cvxDwgInqViewTypeEx(int viewId, evxViewTypeEx *viewType)
cvxDwgViewLocationGet
evxErrors cvxDwgViewLocationGet(int idView, svxPoint2 *point)
cvxDwgAlignmentGet
evxErrors cvxDwgAlignmentGet(int idView, int *align)
cvxDwgViewEntitiesAssociate
evxErrors cvxDwgViewEntitiesAssociate(int idView, int count, int *idEnts)
cvxDwgViewInqChildView
evxErrors cvxDwgViewInqChildView(int idView, int *count, int **idViews)
cvxDwgViewInqPart
evxErrors cvxDwgViewInqPart(int idView, svxCompName *part)
cvxDwgInqViews
evxErrors cvxDwgInqViews(int idDrawing, evxViewType type, int *count, int **views)
cvxDwgViewInqPartConfigByLongName
evxErrors cvxDwgViewInqPartConfigByLongName(int idView, char *partCfg, int size)
cvxDwgViewDottedBorderGet
evxErrors cvxDwgViewDottedBorderGet(int idView, svxPoint2 *UpperLeft, svxPoint2 *UpperRight, svxPoint2 *BottomLeft, svxPoint2 *BottomRight)
cvxDwgViewLockGet
evxErrors cvxDwgViewLockGet(int idView, int *isLock)
cvxDwgBrkLineAtGet
evxErrors cvxDwgBrkLineAtGet(int brkLnViewId, svxDwgBrkLineAt *brkLineAt)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCompName
brief component info
Definition: zwapi_util.h:2287
svxDwgBrkLineAt
attribute of break line
Definition: zwapi_dwg_data.h:141
svxPoint2
2D point
Definition: zwapi_util.h:286
svxViewAt
View layout display attributes.
Definition: zwapi_cmd_dwg_data.h:77
zwapi_cmd_dwg_data.h
zwapi_dwg_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FILE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_file.h
cvxCompFileSaveAs
cvxFileAction
cvxFileActivate
cvxFileClose
cvxFileClose2
cvxFileCustomDataDel
cvxFileCustomDataGet
cvxFileCustomDataSet
cvxFileDescriptionGet
cvxFileDescriptionSet
cvxFileDirectory
cvxFileDirectoryByLongPath
cvxFileExport
cvxFileExportInit
cvxFileExportMulti
cvxFileExportMultiByLongPath
cvxFileImport
cvxFileImportInit
cvxFileImportMulti
cvxFileImportMultiByLongPath
cvxFileImportStl
cvxFileInqActive
cvxFileInqAsm
cvxFileInqAssemMode
cvxFileInqAssociatedList
cvxFileInqAssociatedListByLongName
cvxFileInqAssociatedListByLongPath
cvxFileInqAssociatedListByName
cvxFileInqOpen
cvxFileInqSubType
cvxFileIsModified
cvxFileIsUDF
cvxFileKeep
cvxFileLoadList
cvxFileLoadListByLongPath
cvxFileNameCheck
cvxFileNew
cvxFileNew2
cvxFileNewSingle
cvxFileOpen
cvxFileOpenList
cvxFileOpenListByLongPath
cvxFilePreviewExtract
cvxFileReOpen
cvxFileReplace
cvxFileSave
cvxFileSave2
cvxFileSave3
cvxFileSaveAll
cvxFileSaveAs
cvxFileSessionClear
cvxFilesSaveTo
cvxFilesSaveToByLongPath
cvxFileTypeGet
cvxFileTypeSet
cvxFileVersionGet
cvxPartSmdFlatPatternExport
cvxPartSmdFlatSolidExport
cvxSessionClear
cvxSessionRestore
cvxSessionSave
cvxUDFFileInqAssociatedList
cvxUDFFileInqAssociatedListByLongPath

◆ ZW_API_FILE_H

#define ZW_API_FILE_H

Definition at line 15 of file zwapi_file.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_file.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_FILE_H /* this ifndef surrounds entire header */
15#define ZW_API_FILE_H
16
17#include "zwapi_file_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern int cvxFileNameCheck(char* fileName, int nBytes);
46
47/******************************************************************************/
69extern evxErrors cvxFileNew(const vxLongPath Name);
70
71/******************************************************************************/
91extern evxErrors cvxFileNew2(const vxLongPath Name, char* Description);
92
93/******************************************************************************/
119extern evxErrors cvxFileNewSingle(const vxLongPath fileName, evxFileType fileType, evxFileSubtype fileSubtype, const char* templateName, char* fileDescription);
120
121//====================================================================================================================
123//====================================================================================================================
124/******************************************************************************/
159extern int cvxFileKeep(int fKeepOpen);
160
161/******************************************************************************/
181extern evxErrors cvxFileOpen(const vxLongPath File);
182
183/******************************************************************************/
204extern evxErrors cvxFileReOpen(const vxLongPath Name);
205
206/******************************************************************************/
227extern evxErrors cvxFileReplace(const vxLongPath filePath, const vxLongPath newData, int fDel);
228
229
230//====================================================================================================================
232//====================================================================================================================
233/******************************************************************************/
245extern evxErrors cvxFileSave(int Close);
246
247/******************************************************************************/
260extern evxErrors cvxFileSave2(int Close);
261
262/******************************************************************************/
278extern evxErrors cvxFileSave3(int Close, int DisPrompt, int Related);
279
280/******************************************************************************/
290extern evxErrors cvxFileSaveAll(void);
291
292/******************************************************************************/
310extern evxErrors cvxFileSaveAs(const vxLongPath File);
311
312/******************************************************************************/
334extern evxErrors cvxFilesSaveTo(int Count, const vxPath* FileList, const vxPath Path);
335
336/******************************************************************************/
358extern evxErrors cvxFilesSaveToByLongPath(int Count, const vxLongPath* FileList, const vxLongPath Path);
359
360/******************************************************************************/
389extern evxErrors cvxCompFileSaveAs(svxEntPath* CompPath, int UpdateFlag, const vxLongPath File);
390
391//====================================================================================================================
393//====================================================================================================================
394/******************************************************************************/
403extern void cvxFileClose(void);
404
405/******************************************************************************/
430extern void cvxFileClose2(const vxLongPath Name, int Option);
431
432
433//====================================================================================================================
435//====================================================================================================================
436/******************************************************************************/
447extern evxErrors cvxSessionClear(void);
448
449/******************************************************************************/
463extern evxErrors cvxFileSessionClear(const vxLongPath file);
464
465/******************************************************************************/
476extern evxErrors cvxSessionSave(void);
477
478/******************************************************************************/
489extern evxErrors cvxSessionRestore(void);
490
491//====================================================================================================================
493//====================================================================================================================
494/******************************************************************************/
521extern evxErrors cvxFileImportInit(svxImportData* data, evxImportType type, void* general);
522
523/******************************************************************************/
549extern evxErrors cvxFileImport(svxImportData* importData);
550
551/******************************************************************************/
587extern evxErrors cvxFileImportMulti(int Count, const vxPath* PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void* Setting);
588
589/******************************************************************************/
624extern evxErrors cvxFileImportMultiByLongPath(int Count, const vxLongPath* PathList, int SubFolder, const vxLongPath SavePath, evxImportType Type, const void* Setting);
625
626/******************************************************************************/
643extern evxErrors cvxFileImportStl(const char* path, int* idOut);
644
645/******************************************************************************/
667extern evxErrors cvxFileExportInit(evxExportType type, int imgType, void* data);
668
669/******************************************************************************/
700extern evxErrors cvxFileExport(evxExportType Type,const vxLongPath Path, void* Data);
701
702/******************************************************************************/
743extern evxErrors cvxFileExportMulti(int Count, const vxPath* FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void* Data);
744
745/******************************************************************************/
786extern evxErrors cvxFileExportMultiByLongPath(int Count, const vxLongPath* FileList, evxFileType Filter, evxExportType Type, const vxLongPath Path, void* Data);
787
788/******************************************************************************/
820extern evxErrors cvxPartSmdFlatSolidExport(int idFlatten, evxExportType type, const vxLongPath filePath, void* data);
821
822/******************************************************************************/
845extern evxErrors cvxPartSmdFlatPatternExport(int idFlatten, const vxLongPath filePath, const svxDWGData* data);
846
847//====================================================================================================================
849//====================================================================================================================
850/******************************************************************************/
881extern evxErrors cvxFileAction(evxDocAction type, svxDocActionParam* param);
882
883
884//====================================================================================================================
886//====================================================================================================================
887/******************************************************************************/
913extern evxErrors cvxFileActivate(const vxLongPath Name);
914
915/******************************************************************************/
928extern void cvxFileDirectory(vxPath Directory);
929
930/******************************************************************************/
948extern void cvxFileDirectoryByLongPath(char* Directory,int sizeDire);
949
950/******************************************************************************/
965extern void cvxFileInqActive(char* Name, int nBytes);
966
967/******************************************************************************/
979extern void cvxFileTypeGet(int* MultiObject);
980
981/******************************************************************************/
993extern void cvxFileTypeSet(int MultiObject);
994
995/******************************************************************************/
1016extern evxErrors cvxFileInqSubType(const vxLongPath fileName, evxFileSubtype* fileSubtype);
1017
1018/******************************************************************************/
1032extern void cvxFileInqOpen(char* Name, int nBytes);
1033
1034/******************************************************************************/
1050extern void cvxFileOpenList(int* count, vxPath** fileList);
1051
1052/******************************************************************************/
1068extern void cvxFileOpenListByLongPath(int* count, vxLongPath** fileList);
1069
1070/******************************************************************************/
1092extern evxErrors cvxFileLoadList(const int state, int* count, vxPath** fileList);
1093
1094/******************************************************************************/
1116extern evxErrors cvxFileLoadListByLongPath(int state, int* count, vxLongPath** fileList);
1117
1118/******************************************************************************/
1141extern evxErrors cvxFileVersionGet(const vxLongPath file, int* version);
1142
1143/******************************************************************************/
1161extern evxErrors cvxFileIsModified(const vxLongPath Name, int* Modified);
1162
1163/******************************************************************************/
1181extern evxErrors cvxFileInqAssociatedList(int* count, vxPath** fileList);
1182
1183/******************************************************************************/
1201extern evxErrors cvxFileInqAssociatedListByLongPath(int* count, vxLongPath** fileList);
1202
1203/******************************************************************************/
1226extern evxErrors cvxFileInqAssociatedListByName(const char* fileName, int nDepth, int* count, vxPath** fileList);
1227
1228/******************************************************************************/
1251extern evxErrors cvxFileInqAssociatedListByLongName(const char* fileName, int nDepth, int* count, vxLongPath** fileList);
1252
1253/******************************************************************************/
1268extern evxErrors cvxFilePreviewExtract(const vxLongPath SrcFile, const vxLongPath BmpFile);
1269
1270/******************************************************************************/
1288extern evxErrors cvxFileInqAsm(char* Name, int nBytes);
1289
1290/******************************************************************************/
1300extern char cvxFileInqAssemMode(void);
1301
1302
1303//====================================================================================================================
1305//====================================================================================================================
1306/******************************************************************************/
1323extern evxErrors cvxFileIsUDF(const vxLongPath path, const vxLongPath file, int* isUDF);
1324
1325/******************************************************************************/
1349extern evxErrors cvxUDFFileInqAssociatedList(const vxPath path, const vxPath file, int* count, vxPath** fileList);
1350
1351/******************************************************************************/
1375extern evxErrors cvxUDFFileInqAssociatedListByLongPath(const vxLongPath path, const vxLongPath file, int* count, vxLongPath** fileList);
1376
1377//====================================================================================================================
1379//====================================================================================================================
1380/******************************************************************************/
1396extern void cvxFileDescriptionSet(const vxLongPath Name, const char* Description);
1397
1398/******************************************************************************/
1415extern evxErrors cvxFileDescriptionGet(const vxLongPath Name, vxLongName Description);
1416
1417/******************************************************************************/
1434extern evxErrors cvxFileCustomDataSet(const vxLongPath file, const char* data, int dataLength);
1435
1436/******************************************************************************/
1455extern evxErrors cvxFileCustomDataGet(const vxLongPath file, char** data, int* dataLength);
1456
1457/******************************************************************************/
1470extern evxErrors cvxFileCustomDataDel(const vxLongPath file);
1471
1472
1473/*
1474*********************************************************************
1475** END HEADER FILE
1476*********************************************************************
1477*/
1478
1479#ifdef __cplusplus
1480 }
1481#endif /* __cplusplus */
1482
1483#endif /* ZW_API_FILE_H */
evxImportType
evxImportType
file import type
Definition: zwapi_file_data.h:471
evxFileType
evxFileType
file type
Definition: zwapi_file_data.h:32
evxExportType
evxExportType
export file type
Definition: zwapi_file_data.h:670
evxFileSubtype
evxFileSubtype
file sub-type
Definition: zwapi_file_data.h:46
evxDocAction
enum _evxDocAction evxDocAction
file action type
cvxFileSaveAs
evxErrors cvxFileSaveAs(const vxLongPath File)
cvxFileImportMultiByLongPath
evxErrors cvxFileImportMultiByLongPath(int Count, const vxLongPath *PathList, int SubFolder, const vxLongPath SavePath, evxImportType Type, const void *Setting)
cvxFileDirectoryByLongPath
void cvxFileDirectoryByLongPath(char *Directory, int sizeDire)
cvxFileOpenList
void cvxFileOpenList(int *count, vxPath **fileList)
cvxFileKeep
int cvxFileKeep(int fKeepOpen)
cvxFileInqOpen
void cvxFileInqOpen(char *Name, int nBytes)
cvxFileLoadListByLongPath
evxErrors cvxFileLoadListByLongPath(int state, int *count, vxLongPath **fileList)
cvxFileDirectory
void cvxFileDirectory(vxPath Directory)
cvxFileReplace
evxErrors cvxFileReplace(const vxLongPath filePath, const vxLongPath newData, int fDel)
cvxFileDescriptionGet
evxErrors cvxFileDescriptionGet(const vxLongPath Name, vxLongName Description)
cvxFileClose
void cvxFileClose(void)
cvxFileNew
evxErrors cvxFileNew(const vxLongPath Name)
cvxFileOpenListByLongPath
void cvxFileOpenListByLongPath(int *count, vxLongPath **fileList)
cvxFilePreviewExtract
evxErrors cvxFilePreviewExtract(const vxLongPath SrcFile, const vxLongPath BmpFile)
cvxFileExportInit
evxErrors cvxFileExportInit(evxExportType type, int imgType, void *data)
cvxFileReOpen
evxErrors cvxFileReOpen(const vxLongPath Name)
cvxFileTypeSet
void cvxFileTypeSet(int MultiObject)
cvxFileClose2
void cvxFileClose2(const vxLongPath Name, int Option)
cvxFileInqAsm
evxErrors cvxFileInqAsm(char *Name, int nBytes)
cvxFileInqAssociatedListByLongPath
evxErrors cvxFileInqAssociatedListByLongPath(int *count, vxLongPath **fileList)
cvxPartSmdFlatPatternExport
evxErrors cvxPartSmdFlatPatternExport(int idFlatten, const vxLongPath filePath, const svxDWGData *data)
cvxFileCustomDataDel
evxErrors cvxFileCustomDataDel(const vxLongPath file)
cvxFileExportMultiByLongPath
evxErrors cvxFileExportMultiByLongPath(int Count, const vxLongPath *FileList, evxFileType Filter, evxExportType Type, const vxLongPath Path, void *Data)
cvxFileSave
evxErrors cvxFileSave(int Close)
cvxFileSessionClear
evxErrors cvxFileSessionClear(const vxLongPath file)
cvxFileExport
evxErrors cvxFileExport(evxExportType Type, const vxLongPath Path, void *Data)
cvxSessionClear
evxErrors cvxSessionClear(void)
cvxFileImport
evxErrors cvxFileImport(svxImportData *importData)
cvxFileInqSubType
evxErrors cvxFileInqSubType(const vxLongPath fileName, evxFileSubtype *fileSubtype)
cvxFileDescriptionSet
void cvxFileDescriptionSet(const vxLongPath Name, const char *Description)
cvxFileAction
evxErrors cvxFileAction(evxDocAction type, svxDocActionParam *param)
cvxFileIsUDF
evxErrors cvxFileIsUDF(const vxLongPath path, const vxLongPath file, int *isUDF)
cvxFileCustomDataSet
evxErrors cvxFileCustomDataSet(const vxLongPath file, const char *data, int dataLength)
cvxFileLoadList
evxErrors cvxFileLoadList(const int state, int *count, vxPath **fileList)
cvxSessionSave
evxErrors cvxSessionSave(void)
cvxFilesSaveTo
evxErrors cvxFilesSaveTo(int Count, const vxPath *FileList, const vxPath Path)
cvxFileImportStl
evxErrors cvxFileImportStl(const char *path, int *idOut)
cvxFileTypeGet
void cvxFileTypeGet(int *MultiObject)
cvxFileInqActive
void cvxFileInqActive(char *Name, int nBytes)
cvxFileNewSingle
evxErrors cvxFileNewSingle(const vxLongPath fileName, evxFileType fileType, evxFileSubtype fileSubtype, const char *templateName, char *fileDescription)
cvxCompFileSaveAs
evxErrors cvxCompFileSaveAs(svxEntPath *CompPath, int UpdateFlag, const vxLongPath File)
cvxFileInqAssociatedListByName
evxErrors cvxFileInqAssociatedListByName(const char *fileName, int nDepth, int *count, vxPath **fileList)
cvxPartSmdFlatSolidExport
evxErrors cvxPartSmdFlatSolidExport(int idFlatten, evxExportType type, const vxLongPath filePath, void *data)
cvxFileExportMulti
evxErrors cvxFileExportMulti(int Count, const vxPath *FileList, evxFileType Filter, evxExportType Type, const vxPath Path, void *Data)
cvxFileImportMulti
evxErrors cvxFileImportMulti(int Count, const vxPath *PathList, int SubFolder, const vxPath SavePath, evxImportType Type, const void *Setting)
cvxFilesSaveToByLongPath
evxErrors cvxFilesSaveToByLongPath(int Count, const vxLongPath *FileList, const vxLongPath Path)
cvxUDFFileInqAssociatedList
evxErrors cvxUDFFileInqAssociatedList(const vxPath path, const vxPath file, int *count, vxPath **fileList)
cvxFileImportInit
evxErrors cvxFileImportInit(svxImportData *data, evxImportType type, void *general)
cvxFileActivate
evxErrors cvxFileActivate(const vxLongPath Name)
cvxFileNameCheck
int cvxFileNameCheck(char *fileName, int nBytes)
cvxFileInqAssociatedList
evxErrors cvxFileInqAssociatedList(int *count, vxPath **fileList)
cvxFileInqAssociatedListByLongName
evxErrors cvxFileInqAssociatedListByLongName(const char *fileName, int nDepth, int *count, vxLongPath **fileList)
cvxFileCustomDataGet
evxErrors cvxFileCustomDataGet(const vxLongPath file, char **data, int *dataLength)
cvxFileInqAssemMode
char cvxFileInqAssemMode(void)
cvxFileNew2
evxErrors cvxFileNew2(const vxLongPath Name, char *Description)
cvxFileIsModified
evxErrors cvxFileIsModified(const vxLongPath Name, int *Modified)
cvxFileSaveAll
evxErrors cvxFileSaveAll(void)
cvxFileSave3
evxErrors cvxFileSave3(int Close, int DisPrompt, int Related)
cvxFileSave2
evxErrors cvxFileSave2(int Close)
cvxFileVersionGet
evxErrors cvxFileVersionGet(const vxLongPath file, int *version)
cvxFileOpen
evxErrors cvxFileOpen(const vxLongPath File)
cvxUDFFileInqAssociatedListByLongPath
evxErrors cvxUDFFileInqAssociatedListByLongPath(const vxLongPath path, const vxLongPath file, int *count, vxLongPath **fileList)
cvxSessionRestore
evxErrors cvxSessionRestore(void)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxDWGData
data of export DWG file
Definition: zwapi_file_data.h:282
svxDocActionParam
file action parameters
Definition: zwapi_file_data.h:724
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxImportData
file import data
Definition: zwapi_file_data.h:630
zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FILE_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_file_data.h
_evxDocAction
evxDocAction
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
evxDWGVer
evxDWGVer
evxExportExcludeColor
evxExportExcludeColor
evxExportExcludeGeom
evxExportExcludeGeom
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
evxExportType
evxExportType
evxFileSubtype
evxFileSubtype
evxFileType
evxFileType
evxImgBkgndMode
evxImgBkgndMode
evxImgColorMode
evxImgColorMode
evxImgRangeMode
evxImgRangeMode
evxImgType
evxImgType
evxImportType
evxImportType
evxJTVer
evxJTVer
evxPdfRangeMode
evxPdfRangeMode
evxPdfType
evxPdfType
evxPTSHistoryType
evxPTSHistoryType
evxRemoveTextFontType
evxRemoveTextFontType
svxCAT5Data
svxDocActionParam
svxDWGData
svxGRPData
svxHTMLData
svxIGESData
svxImgData
svxImportData
svxImportDwgDxfData
svxImportPTSData
svxImportSTEPData
svxImportSTLData
svxImportUGData
svxJTData
svxOBJData
svxPARAData
svxPdfData
svxSTEPData
svxSTLData

◆ ZW_API_FILE_DATA_H

#define ZW_API_FILE_DATA_H

Definition at line 17 of file zwapi_file_data.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_file_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_FILE_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_FILE_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24//====================================================================================================================
26//====================================================================================================================
31typedef enum evxFileType
32 {
33 VX_FILE_ALL = 0,
34 VX_FILE_PART = 1,
35 VX_FILE_ASSEMBLY,
36 VX_FILE_SHEET,
37 VX_FILE_SKETCH,
38 VX_FILE_CAMPLAN,
39 } evxFileType;
40
45typedef enum evxFileSubtype
46 {
47 VX_SUBTYPE_NONE = 0,
48 VX_NORMAL_PART,
49 VX_ECAD_BOARD_PART,
50 VX_NORMAL_ASSEMBLY,
51 VX_ECAD_ASSEMBLY,
52 VX_ROUTING_ASSEMBLY,
53 VX_SMD_PART,
54 VX_HARNESS_ASSEMBLY,
55 VX_HARNESS_PART,
56 VX_MASTERLAYOUT_PART,
57 } evxFileSubtype;
58
59//====================================================================================================================
61//====================================================================================================================
66typedef enum evxImgColorMode
67 {
68 VX_EXPORT_IMG_COLOR_MODE_24BITS = 0,
69 VX_EXPORT_IMG_COLOR_MODE_8BITS = 1,
70 VX_EXPORT_IMG_COLOR_MODE_COlORIZED = 0,
71 VX_EXPORT_IMG_COLOR_MODE_MONOCHROME = 2,
72 VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE = 3
73 } evxImgColorMode;
74
79typedef enum evxImgBkgndMode
80 {
81 VX_EXPORT_IMG_BKGND_MODE_CURRENT = 0,
82 VX_EXPORT_IMG_BKGND_MODE_CUSTOM
83 } evxImgBkgndMode;
84
89typedef enum evxImgRangeMode
90 {
91 VX_EXPORT_IMG_RANGE_MODE_NORMAL = 0,
92 VX_EXPORT_IMG_RANGE_MODE_EXTENTS,
93 VX_EXPORT_IMG_RANGE_MODE_CUSTOM
94 } evxImgRangeMode;
95
100typedef enum evxImgType
101 {
102 VX_EXPORT_IMG_TYPE_BMP = 1,
103 VX_EXPORT_IMG_TYPE_GIF,
104 VX_EXPORT_IMG_TYPE_PNG,
105 VX_EXPORT_IMG_TYPE_TIFF,
106 VX_EXPORT_IMG_TYPE_JPEG
107 } evxImgType;
108
113typedef enum evxPdfType
114 {
115 VX_EXPORT_PDF_TYPE_RASTER = 1,
116 VX_EXPORT_PDF_TYPE_VECTOR,
117 VX_EXPORT_PDF_TYPE_OBJECT
118 } evxPdfType;
119
124typedef enum evxPdfRangeMode
125 {
126 VX_EXPORT_PDF_RANGE_MODE_NORMAL = 0,
127 VX_EXPORT_PDF_RANGE_MODE_EXTENTS,
128 VX_EXPORT_PDF_RANGE_MODE_CUSTOM
129 } evxPdfRangeMode;
130
135typedef struct svxImgData
136 {
137 evxImgType Type;
138 evxImgColorMode ColorMode;
139 unsigned int Width;
140 unsigned int Height;
141 unsigned int Quality;
143 evxImgBkgndMode BkgndMode;
144 svxColor Background;
145 evxImgRangeMode RangeMode;
146 svxBndBox Rect;
147 } svxImgData;
148
153typedef struct svxPdfData
154 {
155 evxPdfType Type;
156 int Color;
157 int Font;
158 int Dpi;
159 int TextOutStyle;
160 float LineWidthScale;
161 float PaperWidth;
162 float PaperHeight;
163 evxPdfRangeMode RangeMode;
164 svxBndBox Rect;
165 char Author[128];
166 char Title[128];
167 char Subject[128];
168 char Password[128];
169 char Description[8192];
170 int ExportMultiSheet;
171 } svxPdfData;
172
177typedef struct svxSTLData
178 {
179 int Coordinate;
180 int FileFormat;
181 int Translate;
182 int RefineFacets;
183 int TwistAnalysis;
184 double TessellationTol;
185 double MeshSize;
187 int ExportType;
188 int EntCnt;
189 int* EntList;
191 int ExportLayer;
192 int LayerCnt;
193 int* LayerList;
195 int ExcludeGeom;
198 } svxSTLData;
199
204typedef enum evxDWGVer
205 {
206 VX_DWG_VERSION_2018 = 1,
207 VX_DWG_VERSION_2013 = 2,
208 VX_DWG_VERSION_2010 = 3,
209 VX_DWG_VERSION_2007,
210 VX_DWG_VERSION_2004,
211 VX_DWG_VERSION_2000,
212 VX_DWG_VERSION_R14,
213 VX_DWG_VERSION_R13,
214 VX_DWG_VERSION_R11_R12,
215 }evxDWGVer;
216
221typedef struct svxGRPData
222 {
223 char ExportType;
224 int EntCnt;
225 int* EntList;
226 int ExcludeGeom;
228 }svxGRPData;
229
234typedef enum evxExportExcludeWidthStyle
235 {
236 VX_EXCLUDE_WIDTH_STYLE_1 = 0x1,
237 VX_EXCLUDE_WIDTH_STYLE_2 = 0x2,
238 VX_EXCLUDE_WIDTH_STYLE_3 = 0x4,
239 VX_EXCLUDE_WIDTH_STYLE_4 = 0x8,
240 VX_EXCLUDE_WIDTH_STYLE_5 = 0x10,
241 } evxExportExcludeWidthStyle;
242
247typedef enum evxExportExcludeColor
248 {
249 VX_EXCLUDE_COLOR_GREEN = 0x1,
250 VX_EXCLUDE_COLOR_RED = 0x2,
251 VX_EXCLUDE_COLOR_BROWN = 0x4,
252 VX_EXCLUDE_COLOR_GOLDENROD = 0x8,
253 VX_EXCLUDE_COLOR_MED_BLUE = 0x10,
254 VX_EXCLUDE_COLOR_DARK_MAGENTA = 0x20,
255 VX_EXCLUDE_COLOR_DARK_GREY = 0x40,
256 VX_EXCLUDE_COLOR_DARK_BLUE = 0x80,
257 VX_EXCLUDE_COLOR_VIOLET = 0x100,
258 VX_EXCLUDE_COLOR_LIGHT_GREEN = 0x200,
259 VX_EXCLUDE_COLOR_LIGHT_BLUE = 0x400,
260 VX_EXCLUDE_COLOR_ROSE = 0x800,
261 VX_EXCLUDE_COLOR_LIGHT_MAGENTA = 0x1000,
262 VX_EXCLUDE_COLOR_LIGHT_GREY = 0x2000,
263 VX_EXCLUDE_COLOR_WHITE = 0x4000,
264 } evxExportExcludeColor;
265
270typedef enum evxRemoveTextFontType
271 {
272 VX_TEXT_FONT_TYPE_NONE = 0,
273 VX_TEXT_FONT_TYPE_ALL = 1,
274 VX_TEXT_FONT_TYPE_EXCLUDE = 2,
275 } evxRemoveTextFontType;
276
281typedef struct svxDWGData
282 {
283 evxDWGVer Version;
284 char FileType;
287 char ExportType;
288 int EntCnt;
289 int* EntList;
291 char ExportLayer;
292 int LayerCnt;
293 int* LayerList;
295 int ExcludeGeom;
297 int ExcludeWidth;
299 int ExcludeStyle;
301 int ExcludeColor;
303 int reduceData;
304 int trimSurface;
305 int freeSurface;
306 int mergeArc;
307 double tolUVCurve;
308 double tolCurve;
309 double tolSurface;
310 int isTrueColor;
311 int exportSheetOnly;
312 int toModelSpace;
313 int individualFiles;
314 int dimStyleByBlock;
315 int exportShtFmtEnts;
316 int drawingView;
317 int toNewLayer;
318 double scale;
319 evxRemoveTextFontType textFontType;
320 int explodeHatch;
321 int explodeText;
322 }svxDWGData;
323
328typedef struct svxIGESData
329 {
330 char Coordinate;
331 char ExportType;
332 int EntCnt;
333 int* EntList;
334 int ExcludeGeom;
336 } svxIGESData;
337
342typedef struct svxSTEPData
343 {
344 char AppProtocol;
345 char OutPut;
346 char ExportType;
347 int EntCnt;
348 int* EntList;
349 int ExcludeGeom;
351 } svxSTEPData;
352
357typedef enum evxJTVer
358 {
359 VX_JT_VER_6_4,
360 VX_JT_VER_7_0,
361 VX_JT_VER_8_0,
362 VX_JT_VER_8_1,
363 VX_JT_VER_8_2,
364 VX_JT_VER_8_3,
365 VX_JT_VER_9_0,
366 VX_JT_VER_9_1,
367 VX_JT_VER_9_2,
368 VX_JT_VER_9_3,
369 VX_JT_VER_9_4,
370 VX_JT_VER_9_5,
371 VX_JT_VER_10_0,
372 VX_JT_VER_10_1,
373 VX_JT_VER_10_2,
374 VX_JT_VER_10_3,
375 VX_JT_VER_10_4,
376 }evxJTVer;
377
382typedef struct svxJTData
383 {
384 evxJTVer Version;
385 char Structure;
386 char Writetype;
387 char ExportType;
388 int EntCnt;
389 int* EntList;
390 int ExcludeGeom;
392 int ExportPMI;
393 } svxJTData;
394
399typedef struct svxPARAData
400 {
401 char Coordinate;
402 char OutPut;
403 int FileVer;
404 int WriteFreeCrv;
405 int WriteFreePnt;
406 int HealErr;
407 char ExportType;
408 int EntCnt;
409 int* EntList;
410 int ExcludeGeom;
412 } svxPARAData;
413
418typedef struct svxCAT5Data
419 {
420 int FileVer;
421 char ExportType;
422 int EntCnt;
423 int* EntList;
424 int ExcludeGeom;
426 } svxCAT5Data;
427
432typedef struct svxHTMLData
433 {
434 int AutoZip;
435 char Password[128];
436 } svxHTMLData;
437
442typedef enum evxDWGDXFConvertMeshTo
443 {
444 VX_DWGDXF_MESHTO_STL_BLOCKS = 1,
445 VX_DWGDXF_MESHTO_LINES = 2,
447 VX_DWGDXF_MESHTO_PLANAR_FACES = 3,
449 }evxDWGDXFConvertMeshTo;
450
455typedef enum evxDWGDXFExcludeColor
456 {
457 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED = 0x1,
458 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN = 0x2,
459 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE = 0x4,
460 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW = 0x8,
461 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA = 0x10,
462 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN = 0x20,
463 VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE = 0x40,
464 } evxDWGDXFExcludeColor;
465
470typedef enum evxImportType
471 {
472 VX_IMPORT_TYPE_ALL = 0,
473 VX_IMPORT_TYPE_PARASOLID = 1,
474 VX_IMPORT_TYPE_DWG_DXF = 2,
475 VX_IMPORT_TYPE_STEP,
476 VX_IMPORT_TYPE_SAT,
477 VX_IMPORT_TYPE_IGES,
478 VX_IMPORT_TYPE_CATIA4,
479 VX_IMPORT_TYPE_CATIA5,
480 VX_IMPORT_TYPE_INVENTOR,
481 VX_IMPORT_TYPE_JT,
482 VX_IMPORT_TYPE_PROE_CERO,
483 VX_IMPORT_TYPE_SOLIDEDGE,
484 VX_IMPORT_TYPE_SOLIDWORKS,
485 VX_IMPORT_TYPE_UG,
486 VX_IMPORT_TYPE_STL,
487 VX_IMPORT_TYPE_GPH,
488 VX_IMPORT_PTS_FROM_FILE,
489 }evxImportType;
490
495typedef struct svxImportSTEPData
496 {
497 int isAll;
498 int isAutoSew;
499 int isActivatePart;
500 int isSubPart;
501 int isTrimEdges;
502 int isForceClose;
503 int isSewParts;
504 int isHiddenEnts;
505 int isKeepDire;
506 vxLongName placement;
508 } svxImportSTEPData;
509
514typedef struct svxImportUGData
515 {
516 int isAll;
517 int isActivatePart;
518 int isSubPart;
519 int isAssoImport;
520 int importMode;
521 int isFreeCrv;
522 int isFreePnt;
523 int isSheetBody;
524 int isHiddenEnt;
525 int isSuppComp;
526 int PMI;
527 } svxImportUGData;
528
533typedef enum evxDWGDXFReadAsUnits
534 {
535 VX_UNIT_DWGDXF_INCHES = 1,
536 VX_UNIT_DWGDXF_FEET = 2,
537 VX_UNIT_DWGDXF_MILES = 3,
538 VX_UNIT_DWGDXF_MILIMETERS = 4,
539 VX_UNIT_DWGDXF_CENTIMETERS = 5,
540 VX_UNIT_DWGDXF_METERS = 6,
541 VX_UNIT_DWGDXF_KILOMETERS = 7,
542 VX_UNIT_DWGDXF_MICROINCHES = 8,
543 VX_UNIT_DWGDXF_MILS = 9,
544 VX_UNIT_DWGDXF_YARDS = 10,
545 VX_UNIT_DWGDXF_ANGSTROMS = 11,
546 VX_UNIT_DWGDXF_NANOMETERS = 12,
547 VX_UNIT_DWGDXF_MICRONS = 13,
548 VX_UNIT_DWGDXF_DECIMETERS = 14,
549 VX_UNIT_DWGDXF_DEKAMETERS = 15,
550 VX_UNIT_DWGDXF_HECTOMETERS = 16,
551 VX_UNIT_DWGDXF_GIGAMETERS = 17,
552 VX_UNIT_DWGDXF_ASTRONOMICAL = 18,
553 VX_UNIT_DWGDXF_LIGHTYEARS = 19,
554 VX_UNIT_DWGDXF_PARSECS = 20,
555 } evxDWGDXFReadAsUnits;
556
561typedef struct svxImportDwgDxfData
562 {
563 int isAutoSew;
564 int isAutoAct;
565 int isAutoSubPart;
566 int isConvertPolylines;
567 int isRefine;
568 int isReadLayers;
569 int isExplodeDim;
570 evxDWGDXFConvertMeshTo convertMeshTo;
571 vxName placement;
572 int isUnitFile;
573 int isUnitReadAs;
574 evxDWGDXFReadAsUnits fileUnits;
575 int isConvertToUnits;
576 int isModelSpace;
577 int isPaperSpace;
578 int excludeGeom;
580 int excludeWidth;
582 int excludeStyle;
584 int excludeColor;
586 } svxImportDwgDxfData;
587
592typedef struct svxImportSTLData
593 {
594 int isAutoSubPart;
595 int isAutoAct;
596 int isTrimEdges;
597 } svxImportSTLData;
598
603typedef enum evxPTSHistoryType
604 {
605 VX_PTS_HISTORY_SUBPART = 0,
606 VX_PTS_HISTORY_BACKUP = 1,
607 VX_PTS_HISTORY_ENCAPSULATE = 2,
608 VX_PTS_HISTORY_NOBACKUP = 3,
609 } evxPTSHistoryType;
610
615typedef struct svxImportPTSData
616 {
617 vxLongName groupName;
618 int createPtBlock;
619 int reducePtSet;
620 int manual;
621 double tolerance;
622 evxPTSHistoryType history;
623 } svxImportPTSData;
624
629typedef struct svxImportData
630 {
631 evxImportType type;
632 vxLongPath filePath;
633 int importTo;
634 int importTarget;
636 void* reserved;
637 void* general;
643 }svxImportData;
644
649typedef struct svxOBJData
650 {
651 int ExportMaterial;
652 int OptimizeVertex;
653 int CopyTextureFile;
654 double ChordHeight;
655 int OutputDecimal;
657 int ExportType;
658 int EntCnt;
659 int* EntList;
661 int ExcludeGeom;
663 } svxOBJData;
664
669typedef enum evxExportType
670 {
671 VX_EXPORT_TYPE_IMG = 1,
672 VX_EXPORT_TYPE_PDF,
673 VX_EXPORT_TYPE_GRP,
674 VX_EXPORT_TYPE_DWG,
675 VX_EXPORT_TYPE_IGES,
676 VX_EXPORT_TYPE_STEP,
677 VX_EXPORT_TYPE_JT,
678 VX_EXPORT_TYPE_PARA_TEXT,
679 VX_EXPORT_TYPE_PARA_BINARY,
680 VX_EXPORT_TYPE_CAT5_PART,
681 VX_EXPORT_TYPE_CAT5_ASM,
682 VX_EXPORT_TYPE_HTML,
683 VX_EXPORT_TYPE_STL,
684 VX_EXPORT_TYPE_OBJ,
685 } evxExportType;
686
691typedef enum evxExportExcludeGeom
692 {
693 VX_EXCLUDE_CURVE = 0x1,
694 VX_EXCLUDE_SURFACE = 0x2,
695 VX_EXCLUDE_SOLID = 0x4,
696 VX_EXCLUDE_PLANE = 0x8,
697 VX_EXCLUDE_HATCH = 0x10,
698 VX_EXCLUDE_DIMEN = 0x20,
699 VX_EXCLUDE_TEXT = 0x40,
700 VX_EXCLUDE_BLANKED = 0x80,
701 } evxExportExcludeGeom;
702
707typedef enum _evxDocAction
708 {
709 VX_DOC_CREATED = 0,
710 VX_DOC_SAVING,
711 VX_DOC_SAVED,
712 VX_DOC_PRECHANGE,
713 VX_DOC_CHANGED,
714 VX_DOC_PREOPEN,
715 VX_DOC_OPENED,
716 VX_DOC_TITLEUPDATE,
717 }evxDocAction;
718
723typedef struct svxDocActionParam
724 {
725 int(*pfn)(void*, const char*, const char*);
728 void* param;
730 }svxDocActionParam;
731
732#ifdef __cplusplus
733 }
734#endif /* __cplusplus */
735#endif /* ZW_API_FILE_DATA_H */
evxPTSHistoryType
evxPTSHistoryType
operation type stored in part's history
Definition: zwapi_file_data.h:604
VX_PTS_HISTORY_NOBACKUP
@ VX_PTS_HISTORY_NOBACKUP
no backup
Definition: zwapi_file_data.h:608
VX_PTS_HISTORY_BACKUP
@ VX_PTS_HISTORY_BACKUP
backup
Definition: zwapi_file_data.h:606
VX_PTS_HISTORY_SUBPART
@ VX_PTS_HISTORY_SUBPART
sub-part
Definition: zwapi_file_data.h:605
VX_PTS_HISTORY_ENCAPSULATE
@ VX_PTS_HISTORY_ENCAPSULATE
encapsulate
Definition: zwapi_file_data.h:607
evxImportType
evxImportType
file import type
Definition: zwapi_file_data.h:471
VX_IMPORT_TYPE_SOLIDWORKS
@ VX_IMPORT_TYPE_SOLIDWORKS
import .sldprt/.sldasm file
Definition: zwapi_file_data.h:484
VX_IMPORT_TYPE_GPH
@ VX_IMPORT_TYPE_GPH
import .3rd graphic format file
Definition: zwapi_file_data.h:487
VX_IMPORT_TYPE_INVENTOR
@ VX_IMPORT_TYPE_INVENTOR
import .ipt/.iam file
Definition: zwapi_file_data.h:480
VX_IMPORT_TYPE_CATIA5
@ VX_IMPORT_TYPE_CATIA5
import .CATPart/.CATProduct file
Definition: zwapi_file_data.h:479
VX_IMPORT_PTS_FROM_FILE
@ VX_IMPORT_PTS_FROM_FILE
import points form ASCII file (.txt, .asc, .csv, .dat, .exp, .pts, .xyz are supported)
Definition: zwapi_file_data.h:488
VX_IMPORT_TYPE_PARASOLID
@ VX_IMPORT_TYPE_PARASOLID
import .x_t file
Definition: zwapi_file_data.h:473
VX_IMPORT_TYPE_JT
@ VX_IMPORT_TYPE_JT
import .jt file
Definition: zwapi_file_data.h:481
VX_IMPORT_TYPE_IGES
@ VX_IMPORT_TYPE_IGES
import .igs/.iges file
Definition: zwapi_file_data.h:477
VX_IMPORT_TYPE_STL
@ VX_IMPORT_TYPE_STL
import .stl file
Definition: zwapi_file_data.h:486
VX_IMPORT_TYPE_SOLIDEDGE
@ VX_IMPORT_TYPE_SOLIDEDGE
import .par/.psm... file
Definition: zwapi_file_data.h:483
VX_IMPORT_TYPE_STEP
@ VX_IMPORT_TYPE_STEP
import .stp/.step file
Definition: zwapi_file_data.h:475
VX_IMPORT_TYPE_DWG_DXF
@ VX_IMPORT_TYPE_DWG_DXF
import .dwg/.dxf file
Definition: zwapi_file_data.h:474
VX_IMPORT_TYPE_UG
@ VX_IMPORT_TYPE_UG
import .prt file
Definition: zwapi_file_data.h:485
VX_IMPORT_TYPE_CATIA4
@ VX_IMPORT_TYPE_CATIA4
import .model/.exp... file
Definition: zwapi_file_data.h:478
VX_IMPORT_TYPE_SAT
@ VX_IMPORT_TYPE_SAT
import .sat/.sab file
Definition: zwapi_file_data.h:476
VX_IMPORT_TYPE_PROE_CERO
@ VX_IMPORT_TYPE_PROE_CERO
import .prt/.asm file
Definition: zwapi_file_data.h:482
VX_IMPORT_TYPE_ALL
@ VX_IMPORT_TYPE_ALL
import all files types
Definition: zwapi_file_data.h:472
_evxDocAction
_evxDocAction
file action type
Definition: zwapi_file_data.h:708
VX_DOC_SAVED
@ VX_DOC_SAVED
called after file saved
Definition: zwapi_file_data.h:711
VX_DOC_CREATED
@ VX_DOC_CREATED
called after file created
Definition: zwapi_file_data.h:709
VX_DOC_CHANGED
@ VX_DOC_CHANGED
called after file changed
Definition: zwapi_file_data.h:713
VX_DOC_PREOPEN
@ VX_DOC_PREOPEN
called before file open
Definition: zwapi_file_data.h:714
VX_DOC_TITLEUPDATE
@ VX_DOC_TITLEUPDATE
called before the window title updating after file changed
Definition: zwapi_file_data.h:716
VX_DOC_PRECHANGE
@ VX_DOC_PRECHANGE
called before file change
Definition: zwapi_file_data.h:712
VX_DOC_OPENED
@ VX_DOC_OPENED
called after file opened
Definition: zwapi_file_data.h:715
VX_DOC_SAVING
@ VX_DOC_SAVING
called before file saving
Definition: zwapi_file_data.h:710
evxPdfType
evxPdfType
export pdf type
Definition: zwapi_file_data.h:114
VX_EXPORT_PDF_TYPE_OBJECT
@ VX_EXPORT_PDF_TYPE_OBJECT
export type is 3D
Definition: zwapi_file_data.h:117
VX_EXPORT_PDF_TYPE_RASTER
@ VX_EXPORT_PDF_TYPE_RASTER
load the raster image into pdf
Definition: zwapi_file_data.h:115
VX_EXPORT_PDF_TYPE_VECTOR
@ VX_EXPORT_PDF_TYPE_VECTOR
create the vector graphic data into pdf (set this value to Sheet file)
Definition: zwapi_file_data.h:116
evxDWGDXFReadAsUnits
evxDWGDXFReadAsUnits
dwg dxf import options of read as units
Definition: zwapi_file_data.h:534
VX_UNIT_DWGDXF_MILIMETERS
@ VX_UNIT_DWGDXF_MILIMETERS
milimeters
Definition: zwapi_file_data.h:538
VX_UNIT_DWGDXF_LIGHTYEARS
@ VX_UNIT_DWGDXF_LIGHTYEARS
lightyears
Definition: zwapi_file_data.h:553
VX_UNIT_DWGDXF_PARSECS
@ VX_UNIT_DWGDXF_PARSECS
parsecs
Definition: zwapi_file_data.h:554
VX_UNIT_DWGDXF_CENTIMETERS
@ VX_UNIT_DWGDXF_CENTIMETERS
centimeters
Definition: zwapi_file_data.h:539
VX_UNIT_DWGDXF_MICRONS
@ VX_UNIT_DWGDXF_MICRONS
microns
Definition: zwapi_file_data.h:547
VX_UNIT_DWGDXF_MICROINCHES
@ VX_UNIT_DWGDXF_MICROINCHES
microinches
Definition: zwapi_file_data.h:542
VX_UNIT_DWGDXF_MILS
@ VX_UNIT_DWGDXF_MILS
mils
Definition: zwapi_file_data.h:543
VX_UNIT_DWGDXF_FEET
@ VX_UNIT_DWGDXF_FEET
feet
Definition: zwapi_file_data.h:536
VX_UNIT_DWGDXF_HECTOMETERS
@ VX_UNIT_DWGDXF_HECTOMETERS
hectometers
Definition: zwapi_file_data.h:550
VX_UNIT_DWGDXF_ASTRONOMICAL
@ VX_UNIT_DWGDXF_ASTRONOMICAL
astronomical
Definition: zwapi_file_data.h:552
VX_UNIT_DWGDXF_GIGAMETERS
@ VX_UNIT_DWGDXF_GIGAMETERS
gigameters
Definition: zwapi_file_data.h:551
VX_UNIT_DWGDXF_YARDS
@ VX_UNIT_DWGDXF_YARDS
yards
Definition: zwapi_file_data.h:544
VX_UNIT_DWGDXF_DECIMETERS
@ VX_UNIT_DWGDXF_DECIMETERS
decimeters
Definition: zwapi_file_data.h:548
VX_UNIT_DWGDXF_ANGSTROMS
@ VX_UNIT_DWGDXF_ANGSTROMS
angstroms
Definition: zwapi_file_data.h:545
VX_UNIT_DWGDXF_METERS
@ VX_UNIT_DWGDXF_METERS
meters
Definition: zwapi_file_data.h:540
VX_UNIT_DWGDXF_INCHES
@ VX_UNIT_DWGDXF_INCHES
inches
Definition: zwapi_file_data.h:535
VX_UNIT_DWGDXF_NANOMETERS
@ VX_UNIT_DWGDXF_NANOMETERS
nanometers
Definition: zwapi_file_data.h:546
VX_UNIT_DWGDXF_DEKAMETERS
@ VX_UNIT_DWGDXF_DEKAMETERS
dekameters
Definition: zwapi_file_data.h:549
VX_UNIT_DWGDXF_KILOMETERS
@ VX_UNIT_DWGDXF_KILOMETERS
kilometers
Definition: zwapi_file_data.h:541
VX_UNIT_DWGDXF_MILES
@ VX_UNIT_DWGDXF_MILES
miles
Definition: zwapi_file_data.h:537
evxFileType
evxFileType
file type
Definition: zwapi_file_data.h:32
VX_FILE_SHEET
@ VX_FILE_SHEET
Z3DRW file.
Definition: zwapi_file_data.h:36
VX_FILE_CAMPLAN
@ VX_FILE_CAMPLAN
Z3CAM file.
Definition: zwapi_file_data.h:38
VX_FILE_ALL
@ VX_FILE_ALL
all file
Definition: zwapi_file_data.h:33
VX_FILE_ASSEMBLY
@ VX_FILE_ASSEMBLY
Z3ASM file.
Definition: zwapi_file_data.h:35
VX_FILE_PART
@ VX_FILE_PART
Z3PRT file.
Definition: zwapi_file_data.h:34
VX_FILE_SKETCH
@ VX_FILE_SKETCH
Z3SKH file.
Definition: zwapi_file_data.h:37
evxExportType
evxExportType
export file type
Definition: zwapi_file_data.h:670
VX_EXPORT_TYPE_DWG
@ VX_EXPORT_TYPE_DWG
the data is defined by struct svxDWGData
Definition: zwapi_file_data.h:674
VX_EXPORT_TYPE_PARA_TEXT
@ VX_EXPORT_TYPE_PARA_TEXT
the data is defined by struct svxPARAData
Definition: zwapi_file_data.h:678
VX_EXPORT_TYPE_OBJ
@ VX_EXPORT_TYPE_OBJ
the data is defined by struct svxOBJData
Definition: zwapi_file_data.h:684
VX_EXPORT_TYPE_CAT5_ASM
@ VX_EXPORT_TYPE_CAT5_ASM
the data is defined by struct svxCAT5Data
Definition: zwapi_file_data.h:681
VX_EXPORT_TYPE_PARA_BINARY
@ VX_EXPORT_TYPE_PARA_BINARY
the data is defined by struct svxPARAData
Definition: zwapi_file_data.h:679
VX_EXPORT_TYPE_IGES
@ VX_EXPORT_TYPE_IGES
the data is defined by struct svxIGESData
Definition: zwapi_file_data.h:675
VX_EXPORT_TYPE_IMG
@ VX_EXPORT_TYPE_IMG
the data is defined by struct svxImgData
Definition: zwapi_file_data.h:671
VX_EXPORT_TYPE_GRP
@ VX_EXPORT_TYPE_GRP
the data is defined by struct svxGRPData
Definition: zwapi_file_data.h:673
VX_EXPORT_TYPE_PDF
@ VX_EXPORT_TYPE_PDF
the data is defined by struct svxPdfData
Definition: zwapi_file_data.h:672
VX_EXPORT_TYPE_STL
@ VX_EXPORT_TYPE_STL
the data is defined by struct svxSTLData
Definition: zwapi_file_data.h:683
VX_EXPORT_TYPE_STEP
@ VX_EXPORT_TYPE_STEP
the data is defined by struct svxSTEPData
Definition: zwapi_file_data.h:676
VX_EXPORT_TYPE_CAT5_PART
@ VX_EXPORT_TYPE_CAT5_PART
the data is defined by struct svxCAT5Data
Definition: zwapi_file_data.h:680
VX_EXPORT_TYPE_HTML
@ VX_EXPORT_TYPE_HTML
the data is defined by struct svxHTMLData
Definition: zwapi_file_data.h:682
VX_EXPORT_TYPE_JT
@ VX_EXPORT_TYPE_JT
the data is defined by struct svxJTData
Definition: zwapi_file_data.h:677
evxExportExcludeColor
evxExportExcludeColor
exclude attribute(color) of *.dwg/*.dxf
Definition: zwapi_file_data.h:248
VX_EXCLUDE_COLOR_LIGHT_BLUE
@ VX_EXCLUDE_COLOR_LIGHT_BLUE
The color of the 4th row,2nd column (R=160, G=255, B=255)
Definition: zwapi_file_data.h:259
VX_EXCLUDE_COLOR_ROSE
@ VX_EXCLUDE_COLOR_ROSE
The color of the 4th row,3rd column (R=255, G=160, B=160)
Definition: zwapi_file_data.h:260
VX_EXCLUDE_COLOR_LIGHT_MAGENTA
@ VX_EXCLUDE_COLOR_LIGHT_MAGENTA
The color of the 5th row,1st column (R=255, G=160, B=255)
Definition: zwapi_file_data.h:261
VX_EXCLUDE_COLOR_GOLDENROD
@ VX_EXCLUDE_COLOR_GOLDENROD
The color of the 2nd row,1st column (R=255, G=188, B=0)
Definition: zwapi_file_data.h:252
VX_EXCLUDE_COLOR_LIGHT_GREEN
@ VX_EXCLUDE_COLOR_LIGHT_GREEN
The color of the 4th row,1st column (R=160, G=255, B=160)
Definition: zwapi_file_data.h:258
VX_EXCLUDE_COLOR_LIGHT_GREY
@ VX_EXCLUDE_COLOR_LIGHT_GREY
The color of the 5th row,2nd column (R=160, G=160, B=160)
Definition: zwapi_file_data.h:262
VX_EXCLUDE_COLOR_BROWN
@ VX_EXCLUDE_COLOR_BROWN
The color of the 1st row,3rd column (R=160, G=96, B=0)
Definition: zwapi_file_data.h:251
VX_EXCLUDE_COLOR_DARK_BLUE
@ VX_EXCLUDE_COLOR_DARK_BLUE
The color of the 3rd row,2nd column (R=0, G=0, B=255)
Definition: zwapi_file_data.h:256
VX_EXCLUDE_COLOR_VIOLET
@ VX_EXCLUDE_COLOR_VIOLET
The color of the 3rd row,3rd column (R=140, G=140, B=235)
Definition: zwapi_file_data.h:257
VX_EXCLUDE_COLOR_GREEN
@ VX_EXCLUDE_COLOR_GREEN
The color of the 1st row,1st column (R=0, G=255, B=0)
Definition: zwapi_file_data.h:249
VX_EXCLUDE_COLOR_WHITE
@ VX_EXCLUDE_COLOR_WHITE
The color of the 5th row,3rd column (R=255, G=255, B=255)
Definition: zwapi_file_data.h:263
VX_EXCLUDE_COLOR_DARK_MAGENTA
@ VX_EXCLUDE_COLOR_DARK_MAGENTA
The color of the 2nd row,3rd column (R=255, G=0, B=255)
Definition: zwapi_file_data.h:254
VX_EXCLUDE_COLOR_MED_BLUE
@ VX_EXCLUDE_COLOR_MED_BLUE
The color of the 2nd row,2nd column (R=0, G=255, B=255)
Definition: zwapi_file_data.h:253
VX_EXCLUDE_COLOR_RED
@ VX_EXCLUDE_COLOR_RED
The color of the 1st row,2nd column (R=255, G=0, B=0)
Definition: zwapi_file_data.h:250
VX_EXCLUDE_COLOR_DARK_GREY
@ VX_EXCLUDE_COLOR_DARK_GREY
The color of the 3rd row,1st column (R=96, G=96, B=96)
Definition: zwapi_file_data.h:255
evxImgType
evxImgType
export image type
Definition: zwapi_file_data.h:101
VX_EXPORT_IMG_TYPE_JPEG
@ VX_EXPORT_IMG_TYPE_JPEG
jpeg
Definition: zwapi_file_data.h:106
VX_EXPORT_IMG_TYPE_PNG
@ VX_EXPORT_IMG_TYPE_PNG
png
Definition: zwapi_file_data.h:104
VX_EXPORT_IMG_TYPE_TIFF
@ VX_EXPORT_IMG_TYPE_TIFF
tiff
Definition: zwapi_file_data.h:105
VX_EXPORT_IMG_TYPE_BMP
@ VX_EXPORT_IMG_TYPE_BMP
bmp
Definition: zwapi_file_data.h:102
VX_EXPORT_IMG_TYPE_GIF
@ VX_EXPORT_IMG_TYPE_GIF
gif
Definition: zwapi_file_data.h:103
evxImgColorMode
evxImgColorMode
export image color mode
Definition: zwapi_file_data.h:67
VX_EXPORT_IMG_COLOR_MODE_8BITS
@ VX_EXPORT_IMG_COLOR_MODE_8BITS
8bits mode
Definition: zwapi_file_data.h:69
VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE
@ VX_EXPORT_IMG_COLOR_MODE_GRAYSCALE
grayscale mode
Definition: zwapi_file_data.h:72
VX_EXPORT_IMG_COLOR_MODE_COlORIZED
@ VX_EXPORT_IMG_COLOR_MODE_COlORIZED
colorizeo mode
Definition: zwapi_file_data.h:70
VX_EXPORT_IMG_COLOR_MODE_MONOCHROME
@ VX_EXPORT_IMG_COLOR_MODE_MONOCHROME
monochrome mode
Definition: zwapi_file_data.h:71
VX_EXPORT_IMG_COLOR_MODE_24BITS
@ VX_EXPORT_IMG_COLOR_MODE_24BITS
24bits mode
Definition: zwapi_file_data.h:68
evxRemoveTextFontType
evxRemoveTextFontType
remove text font info type.
Definition: zwapi_file_data.h:271
VX_TEXT_FONT_TYPE_EXCLUDE
@ VX_TEXT_FONT_TYPE_EXCLUDE
exclude sheet format and table.
Definition: zwapi_file_data.h:274
VX_TEXT_FONT_TYPE_NONE
@ VX_TEXT_FONT_TYPE_NONE
none
Definition: zwapi_file_data.h:272
VX_TEXT_FONT_TYPE_ALL
@ VX_TEXT_FONT_TYPE_ALL
all
Definition: zwapi_file_data.h:273
evxImgBkgndMode
evxImgBkgndMode
export image background mode
Definition: zwapi_file_data.h:80
VX_EXPORT_IMG_BKGND_MODE_CUSTOM
@ VX_EXPORT_IMG_BKGND_MODE_CUSTOM
use the Color to define your favorite image background color
Definition: zwapi_file_data.h:82
VX_EXPORT_IMG_BKGND_MODE_CURRENT
@ VX_EXPORT_IMG_BKGND_MODE_CURRENT
use current graphic window background color as the image background color
Definition: zwapi_file_data.h:81
evxDWGVer
evxDWGVer
version of DWG
Definition: zwapi_file_data.h:205
VX_DWG_VERSION_2013
@ VX_DWG_VERSION_2013
version 2013
Definition: zwapi_file_data.h:207
VX_DWG_VERSION_R11_R12
@ VX_DWG_VERSION_R11_R12
version r11 or r12
Definition: zwapi_file_data.h:214
VX_DWG_VERSION_R14
@ VX_DWG_VERSION_R14
version r14
Definition: zwapi_file_data.h:212
VX_DWG_VERSION_2004
@ VX_DWG_VERSION_2004
version 2004
Definition: zwapi_file_data.h:210
VX_DWG_VERSION_R13
@ VX_DWG_VERSION_R13
version r13
Definition: zwapi_file_data.h:213
VX_DWG_VERSION_2018
@ VX_DWG_VERSION_2018
version 2018
Definition: zwapi_file_data.h:206
VX_DWG_VERSION_2000
@ VX_DWG_VERSION_2000
version 2000
Definition: zwapi_file_data.h:211
VX_DWG_VERSION_2010
@ VX_DWG_VERSION_2010
version 2010
Definition: zwapi_file_data.h:208
VX_DWG_VERSION_2007
@ VX_DWG_VERSION_2007
version 2007
Definition: zwapi_file_data.h:209
evxPdfRangeMode
evxPdfRangeMode
export pdf range mode
Definition: zwapi_file_data.h:125
VX_EXPORT_PDF_RANGE_MODE_NORMAL
@ VX_EXPORT_PDF_RANGE_MODE_NORMAL
export are-display
Definition: zwapi_file_data.h:126
VX_EXPORT_PDF_RANGE_MODE_CUSTOM
@ VX_EXPORT_PDF_RANGE_MODE_CUSTOM
export are-windows
Definition: zwapi_file_data.h:128
VX_EXPORT_PDF_RANGE_MODE_EXTENTS
@ VX_EXPORT_PDF_RANGE_MODE_EXTENTS
export are-extent
Definition: zwapi_file_data.h:127
evxDWGDXFConvertMeshTo
evxDWGDXFConvertMeshTo
dwg dxf file import of convert polygon mesh to
Definition: zwapi_file_data.h:443
VX_DWGDXF_MESHTO_PLANAR_FACES
@ VX_DWGDXF_MESHTO_PLANAR_FACES
convert all polygon meshing into line segments interconnected at each vertex but also connected with ...
Definition: zwapi_file_data.h:447
VX_DWGDXF_MESHTO_LINES
@ VX_DWGDXF_MESHTO_LINES
convert all polygon meshing into line segments interconnected at each vertex, similar to how the mesh...
Definition: zwapi_file_data.h:445
VX_DWGDXF_MESHTO_STL_BLOCKS
@ VX_DWGDXF_MESHTO_STL_BLOCKS
convert all polygon meshes into STL Blocks
Definition: zwapi_file_data.h:444
evxImgRangeMode
evxImgRangeMode
export image range mode
Definition: zwapi_file_data.h:90
VX_EXPORT_IMG_RANGE_MODE_EXTENTS
@ VX_EXPORT_IMG_RANGE_MODE_EXTENTS
use a max envelope box of all entities as the export extent to export a snap image with its size defi...
Definition: zwapi_file_data.h:92
VX_EXPORT_IMG_RANGE_MODE_CUSTOM
@ VX_EXPORT_IMG_RANGE_MODE_CUSTOM
select a area to export through window-picking
Definition: zwapi_file_data.h:93
VX_EXPORT_IMG_RANGE_MODE_NORMAL
@ VX_EXPORT_IMG_RANGE_MODE_NORMAL
exports what is displayed currently in the geographic window
Definition: zwapi_file_data.h:91
evxFileSubtype
evxFileSubtype
file sub-type
Definition: zwapi_file_data.h:46
VX_MASTERLAYOUT_PART
@ VX_MASTERLAYOUT_PART
subtype master layout part for Z3PRT file
Definition: zwapi_file_data.h:56
VX_ECAD_BOARD_PART
@ VX_ECAD_BOARD_PART
subtype ECAD part for Z3PRT file
Definition: zwapi_file_data.h:49
VX_ROUTING_ASSEMBLY
@ VX_ROUTING_ASSEMBLY
subtype routing assembly for Z3ASM file
Definition: zwapi_file_data.h:52
VX_HARNESS_ASSEMBLY
@ VX_HARNESS_ASSEMBLY
subtype harness assembly for Z3ASM file
Definition: zwapi_file_data.h:54
VX_NORMAL_ASSEMBLY
@ VX_NORMAL_ASSEMBLY
subtype normal assembly for Z3ASM file
Definition: zwapi_file_data.h:50
VX_ECAD_ASSEMBLY
@ VX_ECAD_ASSEMBLY
subtype ECAD assembly for Z3ASM file
Definition: zwapi_file_data.h:51
VX_SMD_PART
@ VX_SMD_PART
subtype sheet metal part for Z3PRT file
Definition: zwapi_file_data.h:53
VX_HARNESS_PART
@ VX_HARNESS_PART
subtype harness part for Z3PRT file
Definition: zwapi_file_data.h:55
VX_NORMAL_PART
@ VX_NORMAL_PART
subtype normal part for Z3PRT file
Definition: zwapi_file_data.h:48
VX_SUBTYPE_NONE
@ VX_SUBTYPE_NONE
no subtype
Definition: zwapi_file_data.h:47
evxDWGDXFExcludeColor
evxDWGDXFExcludeColor
import dwg dxf file, exclude color
Definition: zwapi_file_data.h:456
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_GREEN
R=0, G=255, B=0.
Definition: zwapi_file_data.h:458
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RCYAN
R=160, G=255, B=255.
Definition: zwapi_file_data.h:462
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_MAGENTA
R=255, G=0, B=255.
Definition: zwapi_file_data.h:461
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_WHITE
R=255, G=255, B=255.
Definition: zwapi_file_data.h:463
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_YELLOW
R=255, G=188, B=0.
Definition: zwapi_file_data.h:460
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED
R=255, G=0, B=0.
Definition: zwapi_file_data.h:457
VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE
@ VX_DWGDXF_IMPORT_EXCLUDE_COLOR_BLUE
R=0, G=255, B=255.
Definition: zwapi_file_data.h:459
evxExportExcludeWidthStyle
evxExportExcludeWidthStyle
exclude attribute(no color) of *.dwg/*.dxf
Definition: zwapi_file_data.h:235
VX_EXCLUDE_WIDTH_STYLE_5
@ VX_EXCLUDE_WIDTH_STYLE_5
width-Heavy | style-Dash
Definition: zwapi_file_data.h:240
VX_EXCLUDE_WIDTH_STYLE_2
@ VX_EXCLUDE_WIDTH_STYLE_2
width-Thin | style-Dot
Definition: zwapi_file_data.h:237
VX_EXCLUDE_WIDTH_STYLE_4
@ VX_EXCLUDE_WIDTH_STYLE_4
width-Thick | style-Long-Dash
Definition: zwapi_file_data.h:239
VX_EXCLUDE_WIDTH_STYLE_1
@ VX_EXCLUDE_WIDTH_STYLE_1
width-Light | style-Solid
Definition: zwapi_file_data.h:236
VX_EXCLUDE_WIDTH_STYLE_3
@ VX_EXCLUDE_WIDTH_STYLE_3
width-Medium | style-Dash-Dot
Definition: zwapi_file_data.h:238
evxJTVer
evxJTVer
version of JT
Definition: zwapi_file_data.h:358
VX_JT_VER_10_2
@ VX_JT_VER_10_2
version: 10.2
Definition: zwapi_file_data.h:373
VX_JT_VER_10_0
@ VX_JT_VER_10_0
version: 10.0
Definition: zwapi_file_data.h:371
VX_JT_VER_9_5
@ VX_JT_VER_9_5
version: 9.5
Definition: zwapi_file_data.h:370
VX_JT_VER_10_1
@ VX_JT_VER_10_1
version: 10.1
Definition: zwapi_file_data.h:372
VX_JT_VER_8_0
@ VX_JT_VER_8_0
version: 8.0
Definition: zwapi_file_data.h:361
VX_JT_VER_8_3
@ VX_JT_VER_8_3
version: 8.3
Definition: zwapi_file_data.h:364
VX_JT_VER_9_4
@ VX_JT_VER_9_4
version: 9.4
Definition: zwapi_file_data.h:369
VX_JT_VER_8_2
@ VX_JT_VER_8_2
version: 8.2
Definition: zwapi_file_data.h:363
VX_JT_VER_10_4
@ VX_JT_VER_10_4
version: 10.4
Definition: zwapi_file_data.h:375
VX_JT_VER_6_4
@ VX_JT_VER_6_4
version: 6.4
Definition: zwapi_file_data.h:359
VX_JT_VER_9_0
@ VX_JT_VER_9_0
version: 9.0
Definition: zwapi_file_data.h:365
VX_JT_VER_9_2
@ VX_JT_VER_9_2
version: 9.2
Definition: zwapi_file_data.h:367
VX_JT_VER_8_1
@ VX_JT_VER_8_1
version: 8.1
Definition: zwapi_file_data.h:362
VX_JT_VER_7_0
@ VX_JT_VER_7_0
version: 7.0
Definition: zwapi_file_data.h:360
VX_JT_VER_9_3
@ VX_JT_VER_9_3
version: 9.3
Definition: zwapi_file_data.h:368
VX_JT_VER_9_1
@ VX_JT_VER_9_1
version: 9.1
Definition: zwapi_file_data.h:366
VX_JT_VER_10_3
@ VX_JT_VER_10_3
version: 10.3
Definition: zwapi_file_data.h:374
evxExportExcludeGeom
evxExportExcludeGeom
export exclude geometry
Definition: zwapi_file_data.h:692
VX_EXCLUDE_DIMEN
@ VX_EXCLUDE_DIMEN
exclude dimen
Definition: zwapi_file_data.h:698
VX_EXCLUDE_TEXT
@ VX_EXCLUDE_TEXT
exclude text
Definition: zwapi_file_data.h:699
VX_EXCLUDE_PLANE
@ VX_EXCLUDE_PLANE
exclude plane
Definition: zwapi_file_data.h:696
VX_EXCLUDE_CURVE
@ VX_EXCLUDE_CURVE
exclude curve
Definition: zwapi_file_data.h:693
VX_EXCLUDE_HATCH
@ VX_EXCLUDE_HATCH
exclude hatch
Definition: zwapi_file_data.h:697
VX_EXCLUDE_SOLID
@ VX_EXCLUDE_SOLID
exclude solid
Definition: zwapi_file_data.h:695
VX_EXCLUDE_BLANKED
@ VX_EXCLUDE_BLANKED
exclude blanked
Definition: zwapi_file_data.h:700
VX_EXCLUDE_SURFACE
@ VX_EXCLUDE_SURFACE
exclude surface
Definition: zwapi_file_data.h:694
svxJTData
struct svxJTData svxJTData
data of export JT file
svxImgData
struct svxImgData svxImgData
data of export image file
svxImportUGData
struct svxImportUGData svxImportUGData
setting properties if import prt file
evxDocAction
enum _evxDocAction evxDocAction
file action type
svxHTMLData
struct svxHTMLData svxHTMLData
data of export HTML file
svxImportDwgDxfData
struct svxImportDwgDxfData svxImportDwgDxfData
setting properties if import dwg/dxf file
svxDocActionParam
struct svxDocActionParam svxDocActionParam
file action parameters
svxImportSTLData
struct svxImportSTLData svxImportSTLData
setting properties if import stl file
svxSTLData
struct svxSTLData svxSTLData
data of export STL file
svxImportPTSData
struct svxImportPTSData svxImportPTSData
setting properties if import points form ASCII file
svxOBJData
struct svxOBJData svxOBJData
data of export obj file
svxGRPData
struct svxGRPData svxGRPData
data of export GRP file
svxDWGData
struct svxDWGData svxDWGData
data of export DWG file
svxIGESData
struct svxIGESData svxIGESData
data of export IGEES file
svxPdfData
struct svxPdfData svxPdfData
data of export pdf file
svxCAT5Data
struct svxCAT5Data svxCAT5Data
data of export CAT5 file
svxPARAData
struct svxPARAData svxPARAData
data of export PARA file
svxImportData
struct svxImportData svxImportData
file import data
svxImportSTEPData
struct svxImportSTEPData svxImportSTEPData
setting general properties if import stp/step file
svxSTEPData
struct svxSTEPData svxSTEPData
data of export STEP file
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCAT5Data::FileVer
int FileVer
file version (15 ~ 28, 24-default)
Definition: zwapi_file_data.h:420
svxCAT5Data::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:423
svxCAT5Data::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:422
svxCAT5Data::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:421
svxCAT5Data::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:424
svxCAT5Data
data of export CAT5 file
Definition: zwapi_file_data.h:419
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxDWGData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:289
svxDWGData::toNewLayer
int toNewLayer
1 if export to new layer for each part,else 0.default:0. apply it if drawingView=3.
Definition: zwapi_file_data.h:317
svxDWGData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:295
svxDWGData::ExcludeStyle
int ExcludeStyle
filter style type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH...
Definition: zwapi_file_data.h:299
svxDWGData::ExcludeWidth
int ExcludeWidth
filter width type(evxExportExcludeWidthStyle), like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH...
Definition: zwapi_file_data.h:297
svxDWGData::freeSurface
int freeSurface
1 if free surface,else 0.default:0
Definition: zwapi_file_data.h:305
svxDWGData::ExcludeColor
int ExcludeColor
filter color type(evxExportExcludeColor), like this: VX_EXCLUDE_COLOR_GREEN | VX_EXCLUDE_COLOR_RED
Definition: zwapi_file_data.h:301
svxDWGData::trimSurface
int trimSurface
1 if trim surface,else 0.default:1
Definition: zwapi_file_data.h:304
svxDWGData::isTrueColor
int isTrueColor
1 if true color,else 0.
Definition: zwapi_file_data.h:310
svxDWGData::tolCurve
double tolCurve
tolerance of curve.default:0.01
Definition: zwapi_file_data.h:308
svxDWGData::explodeHatch
int explodeHatch
1 if explode hatch as single line,else 0.default:0
Definition: zwapi_file_data.h:320
svxDWGData::exportShtFmtEnts
int exportShtFmtEnts
1 if export sheet format entities,else 0.default:1
Definition: zwapi_file_data.h:315
svxDWGData::mergeArc
int mergeArc
1 if merge arc,else 0.default:0
Definition: zwapi_file_data.h:306
svxDWGData::ExportLayer
char ExportLayer
0-All layers, 1- Specified layers
Definition: zwapi_file_data.h:291
svxDWGData::tolUVCurve
double tolUVCurve
tolerance of UV curve.default:0.01
Definition: zwapi_file_data.h:307
svxDWGData::exportSheetOnly
int exportSheetOnly
1 if export active sheet only, else export all sheets(0).default:1
Definition: zwapi_file_data.h:311
svxDWGData::Version
evxDWGVer Version
version of DWG
Definition: zwapi_file_data.h:283
svxDWGData::dimStyleByBlock
int dimStyleByBlock
1 if dimension style by block,else 0.default:0
Definition: zwapi_file_data.h:314
svxDWGData::toModelSpace
int toModelSpace
1 if export to model space,else export to layout space(0).default:1
Definition: zwapi_file_data.h:312
svxDWGData::scale
double scale
scale output.default:1
Definition: zwapi_file_data.h:318
svxDWGData::individualFiles
int individualFiles
1 if export as individual files,else 0.default:0.
Definition: zwapi_file_data.h:313
svxDWGData::tolSurface
double tolSurface
tolerance of surface.default:0.01
Definition: zwapi_file_data.h:309
svxDWGData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:287
svxDWGData::LayerList
int * LayerList
the specified layers id list if ExportLayer = 1
Definition: zwapi_file_data.h:293
svxDWGData::drawingView
int drawingView
1 if export as curves, 2 if export as block, else export as block for each component(3)....
Definition: zwapi_file_data.h:316
svxDWGData::textFontType
evxRemoveTextFontType textFontType
remove text font info type.default:VX_TEXT_FONT_TYPE_NONE
Definition: zwapi_file_data.h:319
svxDWGData::explodeText
int explodeText
1 if explode text as single line,else 0.default:0
Definition: zwapi_file_data.h:321
svxDWGData::LayerCnt
int LayerCnt
the count of export layers if ExportLayer = 1
Definition: zwapi_file_data.h:292
svxDWGData::reduceData
int reduceData
1 if reduce data,else 0.default:1
Definition: zwapi_file_data.h:303
svxDWGData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:288
svxDWGData::FileType
char FileType
export type of file. 0-DWG, 1- DFX(ASCLL), 2-DFX(Binary) make sure the file extension type is same wi...
Definition: zwapi_file_data.h:284
svxDWGData
data of export DWG file
Definition: zwapi_file_data.h:282
svxDocActionParam::pfn
int(* pfn)(void *, const char *, const char *)
callback function. when set a callback for a file action, this parameter should be a valid function...
Definition: zwapi_file_data.h:725
svxDocActionParam::param
void * param
parameter passed to pfn, if no need to pass parameters, it should be NULL
Definition: zwapi_file_data.h:728
svxDocActionParam
file action parameters
Definition: zwapi_file_data.h:724
svxGRPData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:225
svxGRPData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:223
svxGRPData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:224
svxGRPData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:226
svxGRPData
data of export GRP file
Definition: zwapi_file_data.h:222
svxHTMLData::AutoZip
int AutoZip
auto zip (1 = yes, 0 = no)
Definition: zwapi_file_data.h:434
svxHTMLData::Password
char Password[128]
password of html file
Definition: zwapi_file_data.h:435
svxHTMLData
data of export HTML file
Definition: zwapi_file_data.h:433
svxIGESData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:333
svxIGESData::Coordinate
char Coordinate
0-World, 1- Local (0-default)
Definition: zwapi_file_data.h:330
svxIGESData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:334
svxIGESData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:331
svxIGESData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:332
svxIGESData
data of export IGEES file
Definition: zwapi_file_data.h:329
svxImgData::Height
unsigned int Height
height for the paper
Definition: zwapi_file_data.h:140
svxImgData::Background
svxColor Background
set it if BkgndMode is VX_EXPORT_IMG_BKGND_MODE_CUSTOM
Definition: zwapi_file_data.h:144
svxImgData::Quality
unsigned int Quality
only if the jpeg format is selected to output. set image quality between 0 and 100
Definition: zwapi_file_data.h:141
svxImgData::Width
unsigned int Width
width for the paper
Definition: zwapi_file_data.h:139
svxImgData::Rect
svxBndBox Rect
set it if RangeMode is VX_EXPORT_IMG_RANGE_MODE_CUSTOM
Definition: zwapi_file_data.h:146
svxImgData::Type
evxImgType Type
image type
Definition: zwapi_file_data.h:137
svxImgData::BkgndMode
evxImgBkgndMode BkgndMode
background color
Definition: zwapi_file_data.h:143
svxImgData::RangeMode
evxImgRangeMode RangeMode
export area mode
Definition: zwapi_file_data.h:145
svxImgData::ColorMode
evxImgColorMode ColorMode
set color
Definition: zwapi_file_data.h:138
svxImgData
data of export image file
Definition: zwapi_file_data.h:136
svxImportData::importTo
int importTo
0-current object, 1-new object, 2-new file
Definition: zwapi_file_data.h:633
svxImportData::reserved
void * reserved
reserved for future (should be NULL for API developers currently)
Definition: zwapi_file_data.h:636
svxImportData::general
void * general
setting general properties.NULL to use default. if the Type is VX_IMPORT_TYPE_UG,...
Definition: zwapi_file_data.h:637
svxImportData::importTarget
int importTarget
0-default, 1-part,2-sheet,3-sketch, if it doesn't need this param, use the default value.
Definition: zwapi_file_data.h:634
svxImportData::type
evxImportType type
import type
Definition: zwapi_file_data.h:631
svxImportData::filePath
vxLongPath filePath
import file path
Definition: zwapi_file_data.h:632
svxImportData
file import data
Definition: zwapi_file_data.h:630
svxImportDwgDxfData::isAutoSew
int isAutoSew
1 is auto sew geometry, else 0.
Definition: zwapi_file_data.h:563
svxImportDwgDxfData::fileUnits
evxDWGDXFReadAsUnits fileUnits
units.
Definition: zwapi_file_data.h:574
svxImportDwgDxfData::isUnitReadAs
int isUnitReadAs
1 read as, else 0.
Definition: zwapi_file_data.h:573
svxImportDwgDxfData::isReadLayers
int isReadLayers
1 is read empty layers, else 0.
Definition: zwapi_file_data.h:568
svxImportDwgDxfData::convertMeshTo
evxDWGDXFConvertMeshTo convertMeshTo
convert polygon mesh to.
Definition: zwapi_file_data.h:570
svxImportDwgDxfData::placement
vxName placement
CSYS name. if placement[0] = 0 or placement="", use default CSYS.
Definition: zwapi_file_data.h:571
svxImportDwgDxfData::isRefine
int isRefine
1 is refine polyline curves, else 0.
Definition: zwapi_file_data.h:567
svxImportDwgDxfData::isConvertToUnits
int isConvertToUnits
convert to ZW3D units. evxUnitType(no apply VX_UNIT_FOOT)
Definition: zwapi_file_data.h:575
svxImportDwgDxfData::isConvertPolylines
int isConvertPolylines
1 is convert polylines into curves, else 0.
Definition: zwapi_file_data.h:566
svxImportDwgDxfData::excludeGeom
int excludeGeom
exclude geometry(evxExportExcludeGeom) like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:578
svxImportDwgDxfData::isAutoSubPart
int isAutoSubPart
1 is auto create sub-part, else 0.
Definition: zwapi_file_data.h:565
svxImportDwgDxfData::isUnitFile
int isUnitFile
1 use file units, else 0.
Definition: zwapi_file_data.h:572
svxImportDwgDxfData::excludeColor
int excludeColor
exclude color(evxDWGDXFExcludeColor) like this: VX_DWGDXF_IMPORT_EXCLUDE_COLOR_RED | VX_DWGDXF_IMPORT...
Definition: zwapi_file_data.h:584
svxImportDwgDxfData::isPaperSpace
int isPaperSpace
1 is paper space, else 0.
Definition: zwapi_file_data.h:577
svxImportDwgDxfData::isModelSpace
int isModelSpace
1 is model space, else 0.
Definition: zwapi_file_data.h:576
svxImportDwgDxfData::isAutoAct
int isAutoAct
1 is auto activate part, else 0.
Definition: zwapi_file_data.h:564
svxImportDwgDxfData::excludeWidth
int excludeWidth
exclude width(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYL...
Definition: zwapi_file_data.h:580
svxImportDwgDxfData::isExplodeDim
int isExplodeDim
1 is explode dimension, else 0.
Definition: zwapi_file_data.h:569
svxImportDwgDxfData::excludeStyle
int excludeStyle
exclude style(evxExportExcludeWidthStyle) like this: VX_EXCLUDE_WIDTH_STYLE_1 | VX_EXCLUDE_WIDTH_STYL...
Definition: zwapi_file_data.h:582
svxImportDwgDxfData
setting properties if import dwg/dxf file
Definition: zwapi_file_data.h:562
svxImportPTSData::createPtBlock
int createPtBlock
1 to create point block, else 0.
Definition: zwapi_file_data.h:618
svxImportPTSData::groupName
vxLongName groupName
the group name of points to import (groupName[0] = 0 to import all points)
Definition: zwapi_file_data.h:617
svxImportPTSData::manual
int manual
method for removing points (1: remove according to the tolerance; 0: automatic; 1 as default)
Definition: zwapi_file_data.h:620
svxImportPTSData::history
evxPTSHistoryType history
operation type stored in part's history (VX_PTS_HISTORY_NOBACKUP as default)
Definition: zwapi_file_data.h:622
svxImportPTSData::tolerance
double tolerance
tolerance used with the manual method (0.01 as default)
Definition: zwapi_file_data.h:621
svxImportPTSData::reducePtSet
int reducePtSet
1 to reduce point set, else 0.
Definition: zwapi_file_data.h:619
svxImportPTSData
setting properties if import points form ASCII file
Definition: zwapi_file_data.h:616
svxImportSTEPData::isSubPart
int isSubPart
1 is auto create sub-part, else 0.
Definition: zwapi_file_data.h:500
svxImportSTEPData::isSewParts
int isSewParts
1 is sew unique parts, else 0.
Definition: zwapi_file_data.h:503
svxImportSTEPData::isHiddenEnts
int isHiddenEnts
1 is read hidden entities, else 0.
Definition: zwapi_file_data.h:504
svxImportSTEPData::isForceClose
int isForceClose
1 is Force close, else 0.
Definition: zwapi_file_data.h:502
svxImportSTEPData::isTrimEdges
int isTrimEdges
1 is break trim edges, else 0.
Definition: zwapi_file_data.h:501
svxImportSTEPData::placement
vxLongName placement
CSYS name. if placement[0] = 0 or placement="", use default CSYS. plancement[0]=0 if isAll=1.
Definition: zwapi_file_data.h:506
svxImportSTEPData::isKeepDire
int isKeepDire
1 is keep origin face direction, else 0.
Definition: zwapi_file_data.h:505
svxImportSTEPData::isAutoSew
int isAutoSew
1 is auto sew geometry, else 0
Definition: zwapi_file_data.h:498
svxImportSTEPData::isActivatePart
int isActivatePart
1 is auto activate part, else 0.
Definition: zwapi_file_data.h:499
svxImportSTEPData::isAll
int isAll
1 is select all options, else 0
Definition: zwapi_file_data.h:497
svxImportSTEPData
setting general properties if import stp/step file
Definition: zwapi_file_data.h:496
svxImportSTLData::isAutoAct
int isAutoAct
1 is auto activate part, else 0.
Definition: zwapi_file_data.h:595
svxImportSTLData::isAutoSubPart
int isAutoSubPart
1 is auto create sub-part, else 0.
Definition: zwapi_file_data.h:594
svxImportSTLData::isTrimEdges
int isTrimEdges
1 is break trim edges, else 0.
Definition: zwapi_file_data.h:596
svxImportSTLData
setting properties if import stl file
Definition: zwapi_file_data.h:593
svxImportUGData::PMI
int PMI
1 is none, 2 is visual, 3 is semantic.
Definition: zwapi_file_data.h:526
svxImportUGData::isFreePnt
int isFreePnt
1 is free point, else 0.
Definition: zwapi_file_data.h:522
svxImportUGData::isAssoImport
int isAssoImport
1 is associative import, else 0.
Definition: zwapi_file_data.h:519
svxImportUGData::isFreeCrv
int isFreeCrv
1 is free curve, else 0.
Definition: zwapi_file_data.h:521
svxImportUGData::importMode
int importMode
1 is normal, else 2 is quick import.
Definition: zwapi_file_data.h:520
svxImportUGData::isActivatePart
int isActivatePart
1 is auto activate part, else 0.
Definition: zwapi_file_data.h:517
svxImportUGData::isSuppComp
int isSuppComp
1 is suppressed component, else 0.
Definition: zwapi_file_data.h:525
svxImportUGData::isHiddenEnt
int isHiddenEnt
1 is hidden entity, else 0.
Definition: zwapi_file_data.h:524
svxImportUGData::isSubPart
int isSubPart
1 is auto create sub-part, else 0.
Definition: zwapi_file_data.h:518
svxImportUGData::isAll
int isAll
1 is select all options, else 0
Definition: zwapi_file_data.h:516
svxImportUGData::isSheetBody
int isSheetBody
1 is sheet body, else 0.
Definition: zwapi_file_data.h:523
svxImportUGData
setting properties if import prt file
Definition: zwapi_file_data.h:515
svxJTData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:389
svxJTData::Structure
char Structure
0-Monolithic, 1-Per part, 2-Full shatter (0-default)
Definition: zwapi_file_data.h:385
svxJTData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:390
svxJTData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:387
svxJTData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:388
svxJTData::Version
evxJTVer Version
JT version (VX_JT_VER_10_0-default)
Definition: zwapi_file_data.h:384
svxJTData::ExportPMI
int ExportPMI
0-None, 1-All (0-default)
Definition: zwapi_file_data.h:392
svxJTData::Writetype
char Writetype
0-All, 1-Parts only, 2-Assembly only (0-default)
Definition: zwapi_file_data.h:386
svxJTData
data of export JT file
Definition: zwapi_file_data.h:383
svxOBJData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:658
svxOBJData::OptimizeVertex
int OptimizeVertex
whether to optimize vertex (1-default)
Definition: zwapi_file_data.h:652
svxOBJData::OutputDecimal
int OutputDecimal
decimal in *.obj file (4-default)
Definition: zwapi_file_data.h:655
svxOBJData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:659
svxOBJData::ExportType
int ExportType
0-All objects, 1-Specified entities (0-default)
Definition: zwapi_file_data.h:657
svxOBJData::ExcludeGeom
int ExcludeGeom
filter geometry type(only support VX_EXCLUDE_BLANKED), (default: ExcludeGeom=VX_EXCLUDE_BLANKED)
Definition: zwapi_file_data.h:661
svxOBJData::ChordHeight
double ChordHeight
chord height tessellation tolerance (0.01-default)
Definition: zwapi_file_data.h:654
svxOBJData::ExportMaterial
int ExportMaterial
whether to export the material file(*.mtl file) (1-default)
Definition: zwapi_file_data.h:651
svxOBJData::CopyTextureFile
int CopyTextureFile
whether to export the texture file to output directory (0-default)
Definition: zwapi_file_data.h:653
svxOBJData
data of export obj file
Definition: zwapi_file_data.h:650
svxPARAData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:408
svxPARAData::FileVer
int FileVer
file version (7 ~ 30, 19-default)
Definition: zwapi_file_data.h:403
svxPARAData::WriteFreePnt
int WriteFreePnt
whether to write free point (1 = yes, 0 = no)
Definition: zwapi_file_data.h:405
svxPARAData::HealErr
int HealErr
whether to auto heal topology error (1 = yes, 0 = no)
Definition: zwapi_file_data.h:406
svxPARAData::Coordinate
char Coordinate
0-World, 1-Local (0-default)
Definition: zwapi_file_data.h:401
svxPARAData::WriteFreeCrv
int WriteFreeCrv
whether to write free curve (1 = yes, 0 = no)
Definition: zwapi_file_data.h:404
svxPARAData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:410
svxPARAData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:409
svxPARAData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:407
svxPARAData::OutPut
char OutPut
0-Assembly, 1-Part (1-default)
Definition: zwapi_file_data.h:402
svxPARAData
data of export PARA file
Definition: zwapi_file_data.h:400
svxPdfData::Rect
svxBndBox Rect
export extent
Definition: zwapi_file_data.h:164
svxPdfData::Subject
char Subject[128]
subject of pdf
Definition: zwapi_file_data.h:167
svxPdfData::LineWidthScale
float LineWidthScale
line width scale factor(0.01~10)
Definition: zwapi_file_data.h:160
svxPdfData::TextOutStyle
int TextOutStyle
text output 1:text, 0:polygon lines
Definition: zwapi_file_data.h:159
svxPdfData::PaperHeight
float PaperHeight
height of the page
Definition: zwapi_file_data.h:162
svxPdfData::Author
char Author[128]
author of pdf
Definition: zwapi_file_data.h:165
svxPdfData::Password
char Password[128]
password of pdf
Definition: zwapi_file_data.h:168
svxPdfData::ExportMultiSheet
int ExportMultiSheet
export multiple sheets to one pdf file, 1- active sheet, 2-one pdf for each, 3-one pdf for all (defau...
Definition: zwapi_file_data.h:170
svxPdfData::Font
int Font
embed font or not, can be ignored
Definition: zwapi_file_data.h:157
svxPdfData::Dpi
int Dpi
DPI of pdf.
Definition: zwapi_file_data.h:158
svxPdfData::Color
int Color
all black color or not, 1- MONOCHROME, 2-GRAYSCALE, 3-COLORIZED
Definition: zwapi_file_data.h:156
svxPdfData::PaperWidth
float PaperWidth
width of page
Definition: zwapi_file_data.h:161
svxPdfData::Type
evxPdfType Type
export pdf type
Definition: zwapi_file_data.h:155
svxPdfData::Description
char Description[8192]
description of pdf
Definition: zwapi_file_data.h:169
svxPdfData::RangeMode
evxPdfRangeMode RangeMode
export mode, VX_EXPORT_PDF_RANGE_MODE_NORMAL-Rect can be ignored
Definition: zwapi_file_data.h:163
svxPdfData::Title
char Title[128]
title of pdf
Definition: zwapi_file_data.h:166
svxPdfData
data of export pdf file
Definition: zwapi_file_data.h:154
svxSTEPData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE
Definition: zwapi_file_data.h:349
svxSTEPData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:348
svxSTEPData::ExportType
char ExportType
0-All objects, 1-Specified entities
Definition: zwapi_file_data.h:346
svxSTEPData::AppProtocol
char AppProtocol
0-AP203, 1-AP214 (1-default), 2-AP242
Definition: zwapi_file_data.h:344
svxSTEPData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:347
svxSTEPData::OutPut
char OutPut
0-PART, 1-Assembly (1-default)
Definition: zwapi_file_data.h:345
svxSTEPData
data of export STEP file
Definition: zwapi_file_data.h:343
svxSTLData::Translate
int Translate
1 is translate to positive quadrant, else 0. default:0
Definition: zwapi_file_data.h:181
svxSTLData::EntCnt
int EntCnt
the count of export entities if ExportType = 1
Definition: zwapi_file_data.h:188
svxSTLData::ExcludeGeom
int ExcludeGeom
filter geometry type(evxExportExcludeGeom), like this: VX_EXCLUDE_CURVE | VX_EXCLUDE_SURFACE (default...
Definition: zwapi_file_data.h:195
svxSTLData::TwistAnalysis
int TwistAnalysis
1 is apply twist analysis, else 0. default:0
Definition: zwapi_file_data.h:183
svxSTLData::Coordinate
int Coordinate
coordinate, 0-world, 1-local (0-default)
Definition: zwapi_file_data.h:179
svxSTLData::RefineFacets
int RefineFacets
1 is refine facets to close volume, else 0. default:0
Definition: zwapi_file_data.h:182
svxSTLData::FileFormat
int FileFormat
1 is ASCII file format, else 0. default:0
Definition: zwapi_file_data.h:180
svxSTLData::ExportLayer
int ExportLayer
0-All layers, 1- Specified layers (0-default)
Definition: zwapi_file_data.h:191
svxSTLData::LayerList
int * LayerList
the specified layers id list if ExportLayer = 1
Definition: zwapi_file_data.h:193
svxSTLData::EntList
int * EntList
the specified entities id list if ExportType = 1
Definition: zwapi_file_data.h:189
svxSTLData::TessellationTol
double TessellationTol
chord height tessellation tolerance.default:0.01
Definition: zwapi_file_data.h:184
svxSTLData::MeshSize
double MeshSize
maximum mesh size.default:0
Definition: zwapi_file_data.h:185
svxSTLData::LayerCnt
int LayerCnt
the count of export layers if ExportLayer = 1
Definition: zwapi_file_data.h:192
svxSTLData::ExportType
int ExportType
0-All objects, 1-Specified entities (0-default)
Definition: zwapi_file_data.h:187
svxSTLData
data of export STL file
Definition: zwapi_file_data.h:178
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PATH_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_file_path.h
cvxFileNameLenIsOverrange
cvxFilePathLenIsOverrange
cvxPathAdd
cvxPathAddApiPath
cvxPathApiLib
cvxPathApiLibByLongPath
cvxPathCheck
cvxPathCheckActiveOnlyGet
cvxPathCheckActiveOnlySet
cvxPathCompose
cvxPathComposeByLongPath
cvxPathDel
cvxPathDelAll
cvxPathDelim
cvxPathDelimByLongPath
cvxPathDir
cvxPathDirByLongPath
cvxPathFile
cvxPathFile2
cvxPathFileByLongPath
cvxPathFind
cvxPathFindByFileName
cvxPathFindByLongPath
cvxPathInstall
cvxPathInstallByLongPath
cvxPathIsDebug
cvxPathSearchBeginAdd
cvxPathSearchFirst
cvxPathSearchGet
cvxPathSearchSet
cvxPathSet
cvxPathTemp
cvxPathTempByLongPath
cvxPathUserFolder
cvxPathUserFolderByLongPath

◆ ZW_API_PATH_H

#define ZW_API_PATH_H

Definition at line 15 of file zwapi_file_path.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_file_path.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_file_path.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PATH_H /* this ifndef surrounds entire header */
15#define ZW_API_PATH_H
16
17#include "zwapi_file_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
48extern evxErrors cvxPathAdd(const vxLongPath SearchDirectory);
49
50/******************************************************************************/
72extern evxErrors cvxPathSearchBeginAdd(const vxLongPath SearchDirectory);
73
74/******************************************************************************/
96extern evxErrors cvxPathAddApiPath(vxName LibName, char* SubFolder);
97
98/******************************************************************************/
117extern evxErrors cvxPathCompose(vxPath Path, const char* Name);
118
119/******************************************************************************/
138extern evxErrors cvxPathComposeByLongPath(char* Path, int sizePath, const char* Name);
139
140/******************************************************************************/
179extern evxErrors cvxPathCheck(const vxLongPath srcPath, char* desPath,int sizedes);
180
181//====================================================================================================================
183//====================================================================================================================
184/******************************************************************************/
214extern evxErrors cvxPathSet(const vxLongPath path);
215
216/******************************************************************************/
235extern void cvxPathSearchFirst(const vxLongPath Directory);
236
237//====================================================================================================================
239//====================================================================================================================
240/******************************************************************************/
252extern void cvxPathDel(const vxLongPath Path);
253
254/******************************************************************************/
260extern void cvxPathDelAll(void);
261
262/******************************************************************************/
275extern void cvxPathDelim(vxPath Path);
276
277/******************************************************************************/
291extern void cvxPathDelimByLongPath(char* Path, int sizePath);
292
293
294//====================================================================================================================
296//====================================================================================================================
297/******************************************************************************/
318extern int cvxPathApiLib(vxName LibName, vxPath LibDirectory);
319/******************************************************************************/
344extern int cvxPathApiLibByLongPath(const vxName LibName, char* LibDirectory,int sizeLib);
345
346/******************************************************************************/
360extern void cvxPathDir(vxPath FullPath, vxPath Directory);
361
362/******************************************************************************/
377extern void cvxPathDirByLongPath(const vxLongPath FullPath, char* Directory,int sizeDir);
378
379/******************************************************************************/
399extern void cvxPathFile(vxPath FullPath, vxPath FileName);
400
401/******************************************************************************/
422extern void cvxPathFileByLongPath(const vxLongPath FullPath, char* FileName,int sizeFile);
423
424/******************************************************************************/
446extern void cvxPathFile2(char* FullPath, int MaxNameLen, char* FileName);
447
448/******************************************************************************/
472extern int cvxPathFind(const vxName FileName, vxPath FullPath);
473
474/******************************************************************************/
498extern int cvxPathFindByLongPath(const vxName FileName, char* FullPath,int sizeFull);
499
500/******************************************************************************/
520extern int cvxPathFindByFileName(const char* fileName, char* fullPath, int sizeFullPath);
521
522/******************************************************************************/
533extern void cvxPathInstall(vxPath InstallDirectory);
534
535/******************************************************************************/
551extern void cvxPathInstallByLongPath(char*InstallDirectory,int sizeIns);
552
553/******************************************************************************/
565extern void cvxPathTemp(vxPath Directory);
566
567/******************************************************************************/
584extern void cvxPathTempByLongPath(char* Directory,int sizeDir);
585
586/******************************************************************************/
598extern void cvxPathUserFolder(vxPath Directory);
599
600/******************************************************************************/
617extern void cvxPathUserFolderByLongPath(char* Directory, int sizeDir);
618
619/******************************************************************************/
632extern int cvxPathIsDebug(const char* FolderName);
633
634
635//====================================================================================================================
637//====================================================================================================================
638/******************************************************************************/
644extern void cvxPathSearchSet(int Value);
645
646/******************************************************************************/
652extern int cvxPathSearchGet();
653
654/******************************************************************************/
660extern void cvxPathCheckActiveOnlySet(int Value);
661
662/******************************************************************************/
668extern int cvxPathCheckActiveOnlyGet();
669
670/******************************************************************************/
684extern evxErrors cvxFileNameLenIsOverrange(const char* file_name);
685
686/******************************************************************************/
700extern evxErrors cvxFilePathLenIsOverrange(const char* file_path);
701
702/*
703*********************************************************************
704** END HEADER FILE
705*********************************************************************
706*/
707#ifdef __cplusplus
708 }
709#endif /* __cplusplus */
710
711#endif /* ZW_API_PATH_H */
cvxPathSearchSet
void cvxPathSearchSet(int Value)
cvxPathIsDebug
int cvxPathIsDebug(const char *FolderName)
cvxPathFindByLongPath
int cvxPathFindByLongPath(const vxName FileName, char *FullPath, int sizeFull)
cvxPathAdd
evxErrors cvxPathAdd(const vxLongPath SearchDirectory)
cvxPathFindByFileName
int cvxPathFindByFileName(const char *fileName, char *fullPath, int sizeFullPath)
cvxPathFind
int cvxPathFind(const vxName FileName, vxPath FullPath)
cvxPathCheckActiveOnlySet
void cvxPathCheckActiveOnlySet(int Value)
cvxPathDelAll
void cvxPathDelAll(void)
cvxFilePathLenIsOverrange
evxErrors cvxFilePathLenIsOverrange(const char *file_path)
cvxPathCompose
evxErrors cvxPathCompose(vxPath Path, const char *Name)
cvxPathDirByLongPath
void cvxPathDirByLongPath(const vxLongPath FullPath, char *Directory, int sizeDir)
cvxPathSearchBeginAdd
evxErrors cvxPathSearchBeginAdd(const vxLongPath SearchDirectory)
cvxPathApiLib
int cvxPathApiLib(vxName LibName, vxPath LibDirectory)
cvxPathFile
void cvxPathFile(vxPath FullPath, vxPath FileName)
cvxPathDir
void cvxPathDir(vxPath FullPath, vxPath Directory)
cvxFileNameLenIsOverrange
evxErrors cvxFileNameLenIsOverrange(const char *file_name)
cvxPathInstall
void cvxPathInstall(vxPath InstallDirectory)
cvxPathSearchGet
int cvxPathSearchGet()
cvxPathDel
void cvxPathDel(const vxLongPath Path)
cvxPathTemp
void cvxPathTemp(vxPath Directory)
cvxPathCheck
evxErrors cvxPathCheck(const vxLongPath srcPath, char *desPath, int sizedes)
cvxPathSet
evxErrors cvxPathSet(const vxLongPath path)
cvxPathComposeByLongPath
evxErrors cvxPathComposeByLongPath(char *Path, int sizePath, const char *Name)
cvxPathAddApiPath
evxErrors cvxPathAddApiPath(vxName LibName, char *SubFolder)
cvxPathDelimByLongPath
void cvxPathDelimByLongPath(char *Path, int sizePath)
cvxPathApiLibByLongPath
int cvxPathApiLibByLongPath(const vxName LibName, char *LibDirectory, int sizeLib)
cvxPathUserFolder
void cvxPathUserFolder(vxPath Directory)
cvxPathInstallByLongPath
void cvxPathInstallByLongPath(char *InstallDirectory, int sizeIns)
cvxPathCheckActiveOnlyGet
int cvxPathCheckActiveOnlyGet()
cvxPathUserFolderByLongPath
void cvxPathUserFolderByLongPath(char *Directory, int sizeDir)
cvxPathSearchFirst
void cvxPathSearchFirst(const vxLongPath Directory)
cvxPathFileByLongPath
void cvxPathFileByLongPath(const vxLongPath FullPath, char *FileName, int sizeFile)
cvxPathTempByLongPath
void cvxPathTempByLongPath(char *Directory, int sizeDir)
cvxPathFile2
void cvxPathFile2(char *FullPath, int MaxNameLen, char *FileName)
cvxPathDelim
void cvxPathDelim(vxPath Path)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
zwapi_file_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_GENERAL_ENT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_general_ent.h
cvxEntActivate
cvxEntAddPick
cvxEntBlank
cvxEntBndBox
cvxEntBndBoxByPath
cvxEntByLabel
cvxEntByName
cvxEntByName2
cvxEntByUid
cvxEntClassName
cvxEntClassNum
cvxEntClassNumByPath
cvxEntColorGet
cvxEntColorSet
cvxEntComp
cvxEntEndPnt
cvxEntErase
cvxEntExists
cvxEntFind
cvxEntFind2
cvxEntGetInhSubIdx
cvxEntHighlight
cvxEntInqPathPicked
cvxEntInqPathSelected
cvxEntInqPicked
cvxEntInqSelected
cvxEntIsBlanked
cvxEntIsCurve
cvxEntIsElectrode
cvxEntLabelGet
cvxEntLabelSet
cvxEntLayer
cvxEntLayerId
cvxEntLineAtGet
cvxEntLineAtSet
cvxEntMatrix
cvxEntMatrix2
cvxEntMatrixSet
cvxEntName
cvxEntNameByPath
cvxEntNameSet
cvxEntNew
cvxEntNewAll
cvxEntNewList
cvxEntParent
cvxEntPathAddPick
cvxEntPnt
cvxEntRefEnt
cvxEntRgbGet
cvxEntRgbSet
cvxEntRgbSetNoAt
cvxEntSetNameTag
cvxEntSketch
cvxEntTransSet
cvxEntUidGet
cvxEntUidSet
cvxEntUnHighlight
cvxEntUnhighlightAll
cvxEntUnPickAll
cvxEntUnPickByPath
cvxEntUnPickLast
cvxEntUserAtDel
cvxEntUserAtGet
cvxEntUserAtSet
cvxPartInqEntBox
cvxPartInqEntByLabel
cvxPartInqEntFtr
cvxPartInqEntLabel
cvxPartInqTagNames
cvxPickDataClear
svxAreaProp

◆ ZW_API_GENERAL_ENT_H

#define ZW_API_GENERAL_ENT_H

Definition at line 15 of file zwapi_general_ent.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_general_ent.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_general_ent.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_GENERAL_ENT_H /* this ifndef surrounds entire header */
15#define ZW_API_GENERAL_ENT_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef struct svxAreaProp
31 {
32 svxPoint refPnt;
33 svxPoint centPnt;
34 double dArea;
35 double dPerim;
36 double dDensity;
37 double dAMass;
38 svxPrfAreaProp* pAreaRef;
39 svxPrfAreaProp* pAreaCA;
40 } svxAreaProp;
41
42//====================================================================================================================
44//====================================================================================================================
45/******************************************************************************/
71extern int cvxEntNew(int StartOp, evxEntType Type);
72
73/******************************************************************************/
104extern void cvxEntNewList(int StartOp, evxEntType Type, int* Count, int** idEnts);
105
106/******************************************************************************/
139extern evxErrors cvxEntNewAll(int startOp, evxEntType type, int* count, int** idEnts);
140
141
142//====================================================================================================================
144//====================================================================================================================
145/******************************************************************************/
163extern evxErrors cvxPartInqTagNames(int* Count, vxLongName** Names);
164
165//====================================================================================================================
167//====================================================================================================================
168/******************************************************************************/
199extern evxErrors cvxEntBlank(int Show, int Count, int* idEnts);
200
201/******************************************************************************/
215extern int cvxEntIsBlanked(int idEntity);
216
217/******************************************************************************/
229extern void cvxEntHighlight(int idEntity);
230
231/******************************************************************************/
243extern void cvxEntUnHighlight(int idEntity);
244
245/******************************************************************************/
256extern void cvxEntUnhighlightAll(void);
257
258/******************************************************************************/
276extern int cvxEntExists(int idEntity, evxEntType EntType);
277
278/******************************************************************************/
294extern evxErrors cvxEntInqSelected(int* Count, int** Ents);
295
296/******************************************************************************/
313extern evxErrors cvxEntInqPicked(int* Count, int** Ents);
314
315/******************************************************************************/
331extern evxErrors cvxEntInqPathSelected(int* Count, svxEntPath** Paths);
332
333/******************************************************************************/
351extern evxErrors cvxEntInqPathPicked(int* Count, svxEntPath** Paths);
352
353/******************************************************************************/
359extern void cvxEntUnPickAll();
360
361/******************************************************************************/
367extern void cvxEntUnPickLast();
368
369/******************************************************************************/
382extern evxErrors cvxEntUnPickByPath(const svxEntPath* path);
383
384/******************************************************************************/
398extern evxErrors cvxEntAddPick(int idx_ent);
399
400/******************************************************************************/
415extern evxErrors cvxEntPathAddPick(svxEntPath* entPath);
416
417/******************************************************************************/
423extern void cvxPickDataClear();
424
425//====================================================================================================================
427//====================================================================================================================
428/******************************************************************************/
448extern evxErrors cvxEntUserAtGet(int idEnt, int* count, svxAttribute** At);
449
450/******************************************************************************/
468extern evxErrors cvxEntUserAtSet(int idEnt, int count, svxAttribute* At);
469
470/******************************************************************************/
491extern evxErrors cvxEntUserAtDel(int idEnt, int count, svxAttribute* At);
492
493/******************************************************************************/
511extern evxErrors cvxEntColorGet(int idEntity, evxColor* Color);
512
513/******************************************************************************/
535extern evxErrors cvxEntColorSet(evxColor Color, int Count, int* idEnts);
536
537/******************************************************************************/
556extern evxErrors cvxEntRgbGet(int idEntity, svxColor* Color);
557
558/******************************************************************************/
583extern evxErrors cvxEntRgbSet(svxColor Color, int Count, int* idEnts);
584
585/******************************************************************************/
601extern evxErrors cvxEntRgbSetNoAt(svxColor Color, int Count, int* idEnts);
602
603/******************************************************************************/
625extern evxErrors cvxEntTransSet(int iTrans, int Count, int* idEnts);
626
627/******************************************************************************/
644extern evxErrors cvxEntLineAtGet(int idLine, svxLineAt* At);
645
646/******************************************************************************/
667extern evxErrors cvxEntLineAtSet(svxLineAt* At, int Count, int* idEnts);
668
669//====================================================================================================================
671//====================================================================================================================
672
673/******************************************************************************/
699extern evxErrors cvxEntUidGet(int idEntity, svxUid* Uid);
700
701/******************************************************************************/
725extern evxErrors cvxEntUidSet(int idEntity, const svxUid* Uid);
726
727/******************************************************************************/
759extern evxErrors cvxPartInqEntLabel(int idEntity, int** Label);
760
761/******************************************************************************/
793extern evxErrors cvxEntLabelGet(int idEntity, int** Label);
794
795/******************************************************************************/
814extern evxErrors cvxEntLabelSet(int idEntity, int* Label);
815
816/******************************************************************************/
835extern evxErrors cvxEntName(int idEntity, char* Name, int nBytes);
836
837/******************************************************************************/
860extern evxErrors cvxEntNameSet(int idEntity, const char* Name);
861
862/******************************************************************************/
878extern evxErrors cvxEntSetNameTag(int idx_ent, char* name);
879
880/******************************************************************************/
897extern evxErrors cvxEntLayer(int idEntity, vxName Layer);
898
899/******************************************************************************/
916extern evxErrors cvxEntLayerId(int idEntity, int* LayerId);
917
918/******************************************************************************/
935extern evxErrors cvxEntMatrix(int idEntity, svxMatrix* Matrix);
936
937/******************************************************************************/
956extern evxErrors cvxEntMatrix2(svxEntPath Entity, svxMatrix* Matrix);
957
958/******************************************************************************/
975extern evxErrors cvxEntMatrixSet(int idEntity, svxMatrix* Matrix);
976
977/******************************************************************************/
994extern evxErrors cvxPartInqEntFtr(int idEntity, int* idFeature);
995
996/******************************************************************************/
1012extern evxErrors cvxEntBndBox(int idEntity, svxBndBox* Box);
1013
1014/******************************************************************************/
1045extern evxErrors cvxEntBndBoxByPath(svxEntPath* path, int fTartCord, svxBndBox* bndBox);
1046
1047/******************************************************************************/
1069extern evxErrors cvxPartInqEntBox(int idEnt, const svxMatrix* Mat, svxBndBox* Box);
1070
1071
1072//====================================================================================================================
1074//====================================================================================================================
1075/******************************************************************************/
1093extern evxErrors cvxEntByLabel(int* Label, int Exact, int* idEntity);
1094
1095/******************************************************************************/
1111extern evxErrors cvxPartInqEntByLabel(int* Label, int flag, int* idEntity);
1112
1113/******************************************************************************/
1132extern evxErrors cvxEntByName(const char* Name, int* idEntity);
1133
1134/******************************************************************************/
1154extern evxErrors cvxEntByName2(const vxLongPath File,const vxRootName Root,const vxName Name, int* idEntity);
1155
1156/******************************************************************************/
1173extern evxErrors cvxEntNameByPath(const svxEntPath* Path, vxLongName Name);
1174
1175/******************************************************************************/
1191extern evxErrors cvxEntByUid(const svxUid* Uid, int* idEntity);
1192
1193/******************************************************************************/
1217extern evxErrors cvxEntFind(evxEntFind EntType, svxPoint* RefPnt, int* idEntity, svxPoint* Pnt, double* Dist);
1218
1219/******************************************************************************/
1234extern evxErrors cvxEntFind2(svxEntFind* Data);
1235
1236
1237//====================================================================================================================
1239//====================================================================================================================
1240/******************************************************************************/
1255extern void cvxEntClassName(int ClassNumber, char* ClassName);
1256
1257/******************************************************************************/
1272extern int cvxEntClassNum(int idEntity);
1273
1274/******************************************************************************/
1289extern int cvxEntClassNumByPath(svxEntPath* entPath);
1290
1291/******************************************************************************/
1305extern int cvxEntIsCurve(int idEntity);
1306
1307/******************************************************************************/
1320extern int cvxEntIsElectrode(int idEntity);
1321
1322
1323//====================================================================================================================
1325//====================================================================================================================
1326/******************************************************************************/
1352extern evxErrors cvxEntPnt(int idEntity, svxPoint* Pnt);
1353
1354/******************************************************************************/
1371extern evxErrors cvxEntEndPnt(int idEntity, svxPoint* Start, svxPoint* End);
1372
1373/******************************************************************************/
1389extern void cvxEntSketch(int idEntity, int* idSketch);
1390
1391/******************************************************************************/
1409extern evxErrors cvxEntParent(int idEntity, int* idParent);
1410
1411/******************************************************************************/
1432extern evxErrors cvxEntRefEnt(int idRefEnt, int* idEnt);
1433
1434/******************************************************************************/
1452extern evxErrors cvxEntGetInhSubIdx(int idx_ent, int klass, int sub_class, int* subIdx);
1453
1454/******************************************************************************/
1486extern evxErrors cvxEntComp(int idEntity, int* idComp, char* File, int nFileBytes, char* Parent, int nParentBytes);
1487
1488//====================================================================================================================
1490//====================================================================================================================
1491/******************************************************************************/
1510extern evxErrors cvxEntErase(svxEntPath* Ent);
1511
1512
1513//====================================================================================================================
1515//====================================================================================================================
1516/******************************************************************************/
1545extern int cvxEntActivate(svxEntPath* NewPath, int UpdateGUI, int* idEntity, svxEntPath* OldPath);
1546
1547
1548/*
1549*********************************************************************
1550** END HEADER FILE
1551*********************************************************************
1552*/
1553
1554#ifdef __cplusplus
1555 }
1556#endif /* __cplusplus */
1557
1558#endif /* ZW_API_GENERAL_ENT_H */
cvxEntRgbGet
evxErrors cvxEntRgbGet(int idEntity, svxColor *Color)
cvxEntBndBoxByPath
evxErrors cvxEntBndBoxByPath(svxEntPath *path, int fTartCord, svxBndBox *bndBox)
cvxEntEndPnt
evxErrors cvxEntEndPnt(int idEntity, svxPoint *Start, svxPoint *End)
cvxEntLineAtSet
evxErrors cvxEntLineAtSet(svxLineAt *At, int Count, int *idEnts)
cvxEntComp
evxErrors cvxEntComp(int idEntity, int *idComp, char *File, int nFileBytes, char *Parent, int nParentBytes)
cvxEntUserAtSet
evxErrors cvxEntUserAtSet(int idEnt, int count, svxAttribute *At)
cvxPartInqEntFtr
evxErrors cvxPartInqEntFtr(int idEntity, int *idFeature)
cvxEntUnHighlight
void cvxEntUnHighlight(int idEntity)
cvxEntExists
int cvxEntExists(int idEntity, evxEntType EntType)
cvxEntNew
int cvxEntNew(int StartOp, evxEntType Type)
cvxEntRefEnt
evxErrors cvxEntRefEnt(int idRefEnt, int *idEnt)
cvxEntBlank
evxErrors cvxEntBlank(int Show, int Count, int *idEnts)
cvxEntSetNameTag
evxErrors cvxEntSetNameTag(int idx_ent, char *name)
cvxEntInqPathSelected
evxErrors cvxEntInqPathSelected(int *Count, svxEntPath **Paths)
cvxPartInqEntLabel
evxErrors cvxPartInqEntLabel(int idEntity, int **Label)
cvxEntMatrix
evxErrors cvxEntMatrix(int idEntity, svxMatrix *Matrix)
cvxEntNewList
void cvxEntNewList(int StartOp, evxEntType Type, int *Count, int **idEnts)
cvxEntInqPicked
evxErrors cvxEntInqPicked(int *Count, int **Ents)
cvxEntIsCurve
int cvxEntIsCurve(int idEntity)
cvxEntUidSet
evxErrors cvxEntUidSet(int idEntity, const svxUid *Uid)
cvxEntFind
evxErrors cvxEntFind(evxEntFind EntType, svxPoint *RefPnt, int *idEntity, svxPoint *Pnt, double *Dist)
cvxEntLabelSet
evxErrors cvxEntLabelSet(int idEntity, int *Label)
cvxEntBndBox
evxErrors cvxEntBndBox(int idEntity, svxBndBox *Box)
cvxEntMatrix2
evxErrors cvxEntMatrix2(svxEntPath Entity, svxMatrix *Matrix)
cvxEntErase
evxErrors cvxEntErase(svxEntPath *Ent)
cvxEntClassName
void cvxEntClassName(int ClassNumber, char *ClassName)
cvxEntByName
evxErrors cvxEntByName(const char *Name, int *idEntity)
cvxEntLayerId
evxErrors cvxEntLayerId(int idEntity, int *LayerId)
cvxPartInqEntByLabel
evxErrors cvxPartInqEntByLabel(int *Label, int flag, int *idEntity)
cvxEntInqPathPicked
evxErrors cvxEntInqPathPicked(int *Count, svxEntPath **Paths)
cvxPartInqEntBox
evxErrors cvxPartInqEntBox(int idEnt, const svxMatrix *Mat, svxBndBox *Box)
cvxEntNameByPath
evxErrors cvxEntNameByPath(const svxEntPath *Path, vxLongName Name)
cvxEntByLabel
evxErrors cvxEntByLabel(int *Label, int Exact, int *idEntity)
cvxEntSketch
void cvxEntSketch(int idEntity, int *idSketch)
cvxEntHighlight
void cvxEntHighlight(int idEntity)
cvxEntUnPickByPath
evxErrors cvxEntUnPickByPath(const svxEntPath *path)
cvxEntAddPick
evxErrors cvxEntAddPick(int idx_ent)
cvxEntNameSet
evxErrors cvxEntNameSet(int idEntity, const char *Name)
cvxEntRgbSet
evxErrors cvxEntRgbSet(svxColor Color, int Count, int *idEnts)
cvxEntUserAtGet
evxErrors cvxEntUserAtGet(int idEnt, int *count, svxAttribute **At)
cvxEntClassNumByPath
int cvxEntClassNumByPath(svxEntPath *entPath)
cvxEntUnPickLast
void cvxEntUnPickLast()
cvxEntByName2
evxErrors cvxEntByName2(const vxLongPath File, const vxRootName Root, const vxName Name, int *idEntity)
cvxEntRgbSetNoAt
evxErrors cvxEntRgbSetNoAt(svxColor Color, int Count, int *idEnts)
cvxEntUserAtDel
evxErrors cvxEntUserAtDel(int idEnt, int count, svxAttribute *At)
cvxEntColorSet
evxErrors cvxEntColorSet(evxColor Color, int Count, int *idEnts)
cvxPartInqTagNames
evxErrors cvxPartInqTagNames(int *Count, vxLongName **Names)
cvxEntInqSelected
evxErrors cvxEntInqSelected(int *Count, int **Ents)
cvxEntTransSet
evxErrors cvxEntTransSet(int iTrans, int Count, int *idEnts)
cvxEntPnt
evxErrors cvxEntPnt(int idEntity, svxPoint *Pnt)
cvxEntIsElectrode
int cvxEntIsElectrode(int idEntity)
cvxEntNewAll
evxErrors cvxEntNewAll(int startOp, evxEntType type, int *count, int **idEnts)
cvxEntName
evxErrors cvxEntName(int idEntity, char *Name, int nBytes)
cvxEntClassNum
int cvxEntClassNum(int idEntity)
cvxEntByUid
evxErrors cvxEntByUid(const svxUid *Uid, int *idEntity)
cvxEntFind2
evxErrors cvxEntFind2(svxEntFind *Data)
cvxEntLabelGet
evxErrors cvxEntLabelGet(int idEntity, int **Label)
cvxEntLineAtGet
evxErrors cvxEntLineAtGet(int idLine, svxLineAt *At)
cvxEntUnPickAll
void cvxEntUnPickAll()
cvxEntPathAddPick
evxErrors cvxEntPathAddPick(svxEntPath *entPath)
cvxEntActivate
int cvxEntActivate(svxEntPath *NewPath, int UpdateGUI, int *idEntity, svxEntPath *OldPath)
cvxEntUnhighlightAll
void cvxEntUnhighlightAll(void)
cvxEntParent
evxErrors cvxEntParent(int idEntity, int *idParent)
cvxEntLayer
evxErrors cvxEntLayer(int idEntity, vxName Layer)
cvxEntUidGet
evxErrors cvxEntUidGet(int idEntity, svxUid *Uid)
cvxEntIsBlanked
int cvxEntIsBlanked(int idEntity)
cvxEntColorGet
evxErrors cvxEntColorGet(int idEntity, evxColor *Color)
cvxEntGetInhSubIdx
evxErrors cvxEntGetInhSubIdx(int idx_ent, int klass, int sub_class, int *subIdx)
cvxEntMatrixSet
evxErrors cvxEntMatrixSet(int idEntity, svxMatrix *Matrix)
cvxPickDataClear
void cvxPickDataClear()
svxAreaProp
struct svxAreaProp svxAreaProp
area properties
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxEntFind
evxEntFind
entity search types
Definition: zwapi_util.h:1010
evxEntType
evxEntType
entity types
Definition: zwapi_util.h:917
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAreaProp::dAMass
double dAMass
mass(kg)
Definition: zwapi_general_ent.h:37
svxAreaProp::centPnt
svxPoint centPnt
centroid
Definition: zwapi_general_ent.h:33
svxAreaProp::refPnt
svxPoint refPnt
ref point
Definition: zwapi_general_ent.h:32
svxAreaProp::dPerim
double dPerim
perimeter(mm)
Definition: zwapi_general_ent.h:35
svxAreaProp::pAreaCA
svxPrfAreaProp * pAreaCA
area properties about centroid
Definition: zwapi_general_ent.h:39
svxAreaProp::pAreaRef
svxPrfAreaProp * pAreaRef
area properties about ref
Definition: zwapi_general_ent.h:38
svxAreaProp::dDensity
double dDensity
density(kg/mm^3)
Definition: zwapi_general_ent.h:36
svxAreaProp::dArea
double dArea
area(mm^2)
Definition: zwapi_general_ent.h:34
svxAreaProp
area properties
Definition: zwapi_general_ent.h:31
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxEntFind
entity search data
Definition: zwapi_util.h:1030
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxLineAt
Line attributes.
Definition: zwapi_util.h:1423
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
svxPrfAreaProp
profile area property
Definition: zwapi_util.h:1211
svxUid
entity unique identifier
Definition: zwapi_util.h:987
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_GLOBAL_APPLY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_global_apply.h
_evxAppAction
cvxAppAction
cvxAutoRegenGet
cvxAutoRegenSet
cvxColorFilter
cvxColorfToColor
cvxColorNear
cvxColorRGB
cvxColorToColorf
cvxEscCheck
cvxEscDisable
cvxEscEnd
cvxEscRestore
cvxEscStart
cvxFilterActiveGet
cvxFilterListGet
cvxFontMap
cvxGlobalGet
cvxGlobalSet
cvxHelpDocLoad
cvxHostId
cvxLabelMatch
cvxLangGet
cvxNameIsOkay
cvxNoteGet
cvxNoteSet
cvxNotifyExit
cvxPluginRegPathGet
cvxPluginRegPathGetByLongPath
cvxSetMSMMoldInstalled
cvxSetMSMPressInstalled
cvxSkGridSpacingGet
cvxSkGridSpacingSet
cvxUnitGet
cvxUnitMassGet
cvxUnitMassSet
cvxUnitSet
cvxUnitToSys
cvxUnitToUser
cvxUnitTypeGet
cvxVersion
cvxVersionNum
evxAppAction
evxGlobal
evxGlobal
svxAppActionParam
svxPartDimAttr

◆ ZW_API_GLOBAL_APPLY_H

#define ZW_API_GLOBAL_APPLY_H

Definition at line 15 of file zwapi_global_apply.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_global_apply.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_global_apply.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_GLOBAL_APPLY_H /* this ifndef surrounds entire header */
15#define ZW_API_GLOBAL_APPLY_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef struct svxPartDimAttr
31 {
32 evxColor color;
33 int decimal;
34 } svxPartDimAttr;
35
40typedef enum evxGlobal
41 {
42 VX_TOLERANCE = 1,
43 VX_AUTO_MERGE = 2,
44 VX_EXACT_MATCH = 3,
45 VX_LOCALCOORDIDX = 4,
46 VX_CONS_DELAY_SOLVE = 5,
47 VX_DIM_ATTR = 6,
48 } evxGlobal;
49
50//====================================================================================================================
52//====================================================================================================================
57typedef enum _evxAppAction
58 {
59 VX_APP_PRECLOSE = 0,
60 VX_APP_STARTED
61 }evxAppAction;
62
67typedef struct _svxAppActionParam
68 {
69 int (*pfn)(void* param);
70 void* param;
71 }svxAppActionParam;
72
73//====================================================================================================================
75//====================================================================================================================
76/******************************************************************************/
95extern evxErrors cvxGlobalGet(evxGlobal Global, void* Data);
96
97/******************************************************************************/
121extern evxErrors cvxGlobalSet(evxGlobal Global, void* Data);
122
123/******************************************************************************/
143extern evxErrors cvxNoteGet(char** Note);
144
145/******************************************************************************/
160extern evxErrors cvxNoteSet(char* Note);
161
162/******************************************************************************/
173extern void cvxAutoRegenGet(int* Status);
174
175/******************************************************************************/
182extern void cvxAutoRegenSet(int Status);
183
184/******************************************************************************/
199extern void cvxLangGet(vxName Language);
200
201/******************************************************************************/
232extern void cvxFontMap(const char* zw3dFont, vxLongName mapFont);
233
234
235//====================================================================================================================
237//====================================================================================================================
238/******************************************************************************/
255extern void cvxUnitGet(evxUnitType* Type, vxName Name);
256
257/******************************************************************************/
271extern void cvxUnitTypeGet(char* unit_str, char* sub_type, char* unit_type);
272
273/******************************************************************************/
285extern void cvxUnitSet(evxUnitType Type);
286
287/******************************************************************************/
299extern void cvxUnitToSys(double* Distance);
300
301/******************************************************************************/
313extern void cvxUnitToUser(double* Distance);
314
315/******************************************************************************/
333extern evxErrors cvxUnitMassGet(evxMassUnitType* type, vxName name);
334
335/******************************************************************************/
348extern evxErrors cvxUnitMassSet(evxMassUnitType type);
349
350
351//====================================================================================================================
353//====================================================================================================================
354/******************************************************************************/
368extern evxErrors cvxSkGridSpacingGet(double* spacing);
369
370/******************************************************************************/
384extern evxErrors cvxSkGridSpacingSet(double spacing);
385
386
387//====================================================================================================================
389//====================================================================================================================
390/******************************************************************************/
408extern void cvxColorfToColor(const svxColorf* rgbf, svxColor* rgb);
409
410/******************************************************************************/
428extern void cvxColorToColorf(const svxColor* rgb, svxColorf* rgbf);
429
430/******************************************************************************/
448extern evxErrors cvxColorRGB(evxColor color, svxColor* rgb);
449
450/******************************************************************************/
462extern evxColor cvxColorNear(const svxColor* rgb);
463
464
465//====================================================================================================================
467//====================================================================================================================
468/******************************************************************************/
480extern int cvxEscCheck(void);
481
482/******************************************************************************/
492extern void cvxEscDisable(int* EscapeState);
493
494/******************************************************************************/
503extern void cvxEscRestore(int EscapeState);
504
505/******************************************************************************/
527extern void cvxEscStart(void);
528
529/******************************************************************************/
537extern void cvxEscEnd(void);
538
539
540//====================================================================================================================
542//====================================================================================================================
543/******************************************************************************/
559extern int cvxVersion(char* vxStatus);
560
561/******************************************************************************/
575extern void cvxVersionNum(vxLongName verNum);
576
577
578//====================================================================================================================
580//====================================================================================================================
581/******************************************************************************/
599extern void cvxFilterListGet(int* count, vxName* filterList);
600
601/******************************************************************************/
613extern void cvxColorFilter(int colorIdx);
614
615/******************************************************************************/
628extern evxErrors cvxFilterActiveGet(vxName Filter);
629
630
631//====================================================================================================================
633//====================================================================================================================
634/******************************************************************************/
648extern int cvxLabelMatch(int* Label1, int* Label2);
649
650/******************************************************************************/
675extern int cvxNameIsOkay(char* name, int size, int option);
676
677/******************************************************************************/
695extern void cvxHostId(double* idNetwork, double* idDongle);
696
697/******************************************************************************/
704extern void cvxNotifyExit(int opt);
705
706/******************************************************************************/
713extern void cvxSetMSMMoldInstalled(int IsInstalled);
714
715/******************************************************************************/
722extern void cvxSetMSMPressInstalled(int IsInstalled);
723
724/******************************************************************************/
744extern evxErrors cvxPluginRegPathGet(vxPath** pathList, int* pCnt, int is64);
745
746/******************************************************************************/
766extern evxErrors cvxPluginRegPathGetByLongPath(vxLongPath** pathList, int* pCnt, int is64);
767
768/******************************************************************************/
792extern evxErrors cvxHelpDocLoad(const vxLongPath filePath);
793
794//====================================================================================================================
796//====================================================================================================================
797/******************************************************************************/
823extern evxErrors cvxAppAction(evxAppAction type, svxAppActionParam* param);
824
825
826/*
827*********************************************************************
828** END HEADER FILE
829*********************************************************************
830*/
831
832#ifdef __cplusplus
833 }
834#endif /* __cplusplus */
835
836#endif /* ZW_API_GLOBAL_APPLY_H */
cvxColorFilter
void cvxColorFilter(int colorIdx)
cvxAppAction
evxErrors cvxAppAction(evxAppAction type, svxAppActionParam *param)
cvxPluginRegPathGetByLongPath
evxErrors cvxPluginRegPathGetByLongPath(vxLongPath **pathList, int *pCnt, int is64)
cvxUnitMassGet
evxErrors cvxUnitMassGet(evxMassUnitType *type, vxName name)
cvxUnitMassSet
evxErrors cvxUnitMassSet(evxMassUnitType type)
cvxSetMSMPressInstalled
void cvxSetMSMPressInstalled(int IsInstalled)
cvxGlobalSet
evxErrors cvxGlobalSet(evxGlobal Global, void *Data)
cvxFontMap
void cvxFontMap(const char *zw3dFont, vxLongName mapFont)
cvxColorRGB
evxErrors cvxColorRGB(evxColor color, svxColor *rgb)
cvxHostId
void cvxHostId(double *idNetwork, double *idDongle)
cvxHelpDocLoad
evxErrors cvxHelpDocLoad(const vxLongPath filePath)
cvxAutoRegenSet
void cvxAutoRegenSet(int Status)
cvxUnitToSys
void cvxUnitToSys(double *Distance)
cvxUnitTypeGet
void cvxUnitTypeGet(char *unit_str, char *sub_type, char *unit_type)
cvxColorToColorf
void cvxColorToColorf(const svxColor *rgb, svxColorf *rgbf)
cvxSkGridSpacingSet
evxErrors cvxSkGridSpacingSet(double spacing)
cvxEscCheck
int cvxEscCheck(void)
cvxVersion
int cvxVersion(char *vxStatus)
cvxEscEnd
void cvxEscEnd(void)
cvxUnitGet
void cvxUnitGet(evxUnitType *Type, vxName Name)
cvxEscRestore
void cvxEscRestore(int EscapeState)
cvxUnitSet
void cvxUnitSet(evxUnitType Type)
cvxNoteGet
evxErrors cvxNoteGet(char **Note)
cvxUnitToUser
void cvxUnitToUser(double *Distance)
cvxNotifyExit
void cvxNotifyExit(int opt)
cvxEscDisable
void cvxEscDisable(int *EscapeState)
_evxAppAction
_evxAppAction
application action type
Definition: zwapi_global_apply.h:58
VX_APP_PRECLOSE
@ VX_APP_PRECLOSE
called before process quit
Definition: zwapi_global_apply.h:59
VX_APP_STARTED
@ VX_APP_STARTED
called after process start
Definition: zwapi_global_apply.h:60
cvxVersionNum
void cvxVersionNum(vxLongName verNum)
cvxGlobalGet
evxErrors cvxGlobalGet(evxGlobal Global, void *Data)
cvxFilterListGet
void cvxFilterListGet(int *count, vxName *filterList)
cvxEscStart
void cvxEscStart(void)
cvxLangGet
void cvxLangGet(vxName Language)
evxGlobal
evxGlobal
global settings
Definition: zwapi_global_apply.h:41
VX_TOLERANCE
@ VX_TOLERANCE
proximity tolerance (double)
Definition: zwapi_global_apply.h:42
VX_CONS_DELAY_SOLVE
@ VX_CONS_DELAY_SOLVE
1-delay solve the constraint (int)
Definition: zwapi_global_apply.h:46
VX_AUTO_MERGE
@ VX_AUTO_MERGE
1=auto-merge shells before boolean (int)
Definition: zwapi_global_apply.h:43
VX_EXACT_MATCH
@ VX_EXACT_MATCH
1=exact label matching enabled; 0=disabled (int)
Definition: zwapi_global_apply.h:44
VX_DIM_ATTR
@ VX_DIM_ATTR
part dimension attribute (svxPartDimAttr)
Definition: zwapi_global_apply.h:47
VX_LOCALCOORDIDX
@ VX_LOCALCOORDIDX
Local coordinate.
Definition: zwapi_global_apply.h:45
cvxNoteSet
evxErrors cvxNoteSet(char *Note)
cvxSetMSMMoldInstalled
void cvxSetMSMMoldInstalled(int IsInstalled)
cvxLabelMatch
int cvxLabelMatch(int *Label1, int *Label2)
cvxFilterActiveGet
evxErrors cvxFilterActiveGet(vxName Filter)
cvxColorfToColor
void cvxColorfToColor(const svxColorf *rgbf, svxColor *rgb)
cvxColorNear
evxColor cvxColorNear(const svxColor *rgb)
cvxPluginRegPathGet
evxErrors cvxPluginRegPathGet(vxPath **pathList, int *pCnt, int is64)
cvxSkGridSpacingGet
evxErrors cvxSkGridSpacingGet(double *spacing)
cvxAutoRegenGet
void cvxAutoRegenGet(int *Status)
cvxNameIsOkay
int cvxNameIsOkay(char *name, int size, int option)
svxAppActionParam
struct _svxAppActionParam svxAppActionParam
application action parameter
evxAppAction
enum _evxAppAction evxAppAction
application action type
svxPartDimAttr
struct svxPartDimAttr svxPartDimAttr
part dimension attribute
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxMassUnitType
evxMassUnitType
system of mass units
Definition: zwapi_util.h:400
evxUnitType
evxUnitType
system of linear units
Definition: zwapi_util.h:383
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
_svxAppActionParam::pfn
int(* pfn)(void *param)
callback function
Definition: zwapi_global_apply.h:69
_svxAppActionParam::param
void * param
parameter
Definition: zwapi_global_apply.h:70
_svxAppActionParam
application action parameter
Definition: zwapi_global_apply.h:68
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxColorf
RGB color (floating point components defined over 0.0 to 1.0)
Definition: zwapi_util.h:629
svxPartDimAttr::decimal
int decimal
number of decimal places of dimension (0 ~ 5)
Definition: zwapi_global_apply.h:33
svxPartDimAttr::color
evxColor color
color of dimension
Definition: zwapi_global_apply.h:32
svxPartDimAttr
part dimension attribute
Definition: zwapi_global_apply.h:31
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_LAYER_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_layer.h
cvxActiveLayerNumGet
cvxActiveLayerNumSet
cvxLayerActivate
cvxLayerAdd
cvxLayerAdd2
cvxLayerAssign
cvxLayerDel
cvxLayerDel2
cvxLayerExists
cvxLayerExists2
cvxLayerGetAllCategory
cvxLayerId
cvxLayerIdModify
cvxLayerInfoExport
cvxLayerInfoGet
cvxLayerInfoImport
cvxLayerInfoSet
cvxLayerInqActive
cvxLayerInqEnts
cvxLayerList
cvxLayerName
cvxLayerNum
cvxLayerRefresh
cvxLayerShowAll
cvxLayerStateGet
cvxLayerStateSet
cvxLayerSync
evxInfoLayerFlag
evxInfoLayerFlag
svxLayerInfo

◆ ZW_API_LAYER_H

#define ZW_API_LAYER_H

Definition at line 15 of file zwapi_layer.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_layer.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_layer.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_LAYER_H /* this ifndef surrounds entire header */
15#define ZW_API_LAYER_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxInfoLayerFlag
31 {
32 VX_LAYER_INFOR_NAME = 0x00000001,
33 VX_LAYER_INFOR_DESC = 0x00000002,
34 VX_LAYER_INFOR_ID = 0x00000004,
35 VX_LAYER_INFOR_VISIBLE = 0x00000008,
36 VX_LAYER_INFOR_FREEZE = 0x000000010,
37 VX_LAYER_INFOR_DISABLE = 0x00000020,
38 VX_LAYER_INFOR_COLOR = 0x00000040,
39 VX_LAYER_INFOR_LINETYPE = 0x00000080,
40 VX_LAYER_INFOR_LINEWIDTH = 0x0000100,
41 VX_LAYER_INFOR_NUMOBJ = 0x0000200,
42 VX_LAYER_INFOR_FLTR = 0x0000400,
43 VX_LAYER_INFOR_ALL = 0xFFFFFFFF,
44 }evxInfoLayerFlag;
45
50typedef struct svxLayerInfo
51 {
52 int mask;
54 char sName[32];
55 char sDesc[512];
56 unsigned char uLayerId;
57 unsigned char uVisible;
58 unsigned char uFrozen;
59 unsigned char uDisable;
60 unsigned char uColor;
61 unsigned char uLineType;
62 unsigned char ulineWidth;
63 char category[512];
64 int iNumObj;
65 }svxLayerInfo;
66
67//====================================================================================================================
69//====================================================================================================================
70/******************************************************************************/
84extern evxErrors cvxLayerAdd(char* Name);
85
86/******************************************************************************/
101extern evxErrors cvxLayerAdd2(const svxLayerInfo* psLayerInfo, int* Number);
102
103/******************************************************************************/
117extern evxErrors cvxLayerDel(vxName Name);
118
119/******************************************************************************/
131extern evxErrors cvxLayerDel2(int Number);
132
133/******************************************************************************/
148extern evxErrors cvxLayerActivate(vxName Name);
149
150/******************************************************************************/
163extern evxErrors cvxLayerSync(void);
164
165/******************************************************************************/
178extern evxErrors cvxLayerShowAll(void);
179
180/******************************************************************************/
198extern evxErrors cvxLayerIdModify(int srcNumber, int tarNumber);
199
200
201//====================================================================================================================
203//====================================================================================================================
204/******************************************************************************/
215extern void cvxLayerInqActive(vxName Name);
216
217/******************************************************************************/
231extern int cvxLayerExists(vxName Name);
232
233/******************************************************************************/
247extern int cvxLayerExists2(int Number);
248
249/******************************************************************************/
265extern evxErrors cvxLayerId(vxName name, int* id);
266
267/******************************************************************************/
285extern evxErrors cvxLayerInqEnts(int Number, int* numEnt, svxEntPath** Paths);
286
287/******************************************************************************/
304extern evxErrors cvxLayerAssign(char* Name, int numEnt, int* idEnts);
305
306/******************************************************************************/
324extern evxErrors cvxLayerList(int* Count, vxName** Names);
325
326/******************************************************************************/
342extern evxErrors cvxLayerName(int Number, vxName Name);
343
344/******************************************************************************/
361extern evxErrors cvxLayerNum(vxName Name, int* Number);
362
363/******************************************************************************/
382extern evxErrors cvxLayerGetAllCategory(int* numCate, vxLongName** categories);
383
384/******************************************************************************/
396extern evxErrors cvxActiveLayerNumGet(int* Number);
397
398/******************************************************************************/
411extern evxErrors cvxActiveLayerNumSet(int Number);
412
413/******************************************************************************/
430extern evxErrors cvxLayerStateGet(vxName Name, int* isVisible, int* isFrozen);
431
432/******************************************************************************/
466extern evxErrors cvxLayerStateSet(vxName Name, int isVisible, int isFrozen);
467
468
469//====================================================================================================================
471//====================================================================================================================
472/******************************************************************************/
490extern evxErrors cvxLayerInfoGet(int Number, svxLayerInfo* pLayerInfo);
491
492/******************************************************************************/
515extern evxErrors cvxLayerInfoSet(int Number, const svxLayerInfo* pLayerInfo);
516
517/******************************************************************************/
531extern evxErrors cvxLayerInfoExport(const vxLongPath file);
532
533/******************************************************************************/
548extern evxErrors cvxLayerInfoImport(const vxLongPath file, int overWrite);
549
550/******************************************************************************/
555extern void cvxLayerRefresh();
556
557/*
558*********************************************************************
559** END HEADER FILE
560*********************************************************************
561*/
562
563#ifdef __cplusplus
564 }
565#endif /* __cplusplus */
566
567#endif /* ZW_API_LAYER_H */
cvxLayerInqActive
void cvxLayerInqActive(vxName Name)
cvxLayerExists2
int cvxLayerExists2(int Number)
cvxLayerAdd2
evxErrors cvxLayerAdd2(const svxLayerInfo *psLayerInfo, int *Number)
cvxLayerExists
int cvxLayerExists(vxName Name)
cvxLayerInfoImport
evxErrors cvxLayerInfoImport(const vxLongPath file, int overWrite)
evxInfoLayerFlag
evxInfoLayerFlag
layer mask information
Definition: zwapi_layer.h:31
VX_LAYER_INFOR_DESC
@ VX_LAYER_INFOR_DESC
find layer description
Definition: zwapi_layer.h:33
VX_LAYER_INFOR_DISABLE
@ VX_LAYER_INFOR_DISABLE
find layer disable
Definition: zwapi_layer.h:37
VX_LAYER_INFOR_LINETYPE
@ VX_LAYER_INFOR_LINETYPE
find layer linetype
Definition: zwapi_layer.h:39
VX_LAYER_INFOR_LINEWIDTH
@ VX_LAYER_INFOR_LINEWIDTH
find layer linewidth
Definition: zwapi_layer.h:40
VX_LAYER_INFOR_VISIBLE
@ VX_LAYER_INFOR_VISIBLE
find layer visible
Definition: zwapi_layer.h:35
VX_LAYER_INFOR_FREEZE
@ VX_LAYER_INFOR_FREEZE
find layer freeze
Definition: zwapi_layer.h:36
VX_LAYER_INFOR_NAME
@ VX_LAYER_INFOR_NAME
find layer name
Definition: zwapi_layer.h:32
VX_LAYER_INFOR_ALL
@ VX_LAYER_INFOR_ALL
find layer all info
Definition: zwapi_layer.h:43
VX_LAYER_INFOR_ID
@ VX_LAYER_INFOR_ID
find layer id
Definition: zwapi_layer.h:34
VX_LAYER_INFOR_NUMOBJ
@ VX_LAYER_INFOR_NUMOBJ
find layer numble object
Definition: zwapi_layer.h:41
VX_LAYER_INFOR_COLOR
@ VX_LAYER_INFOR_COLOR
find layer color
Definition: zwapi_layer.h:38
VX_LAYER_INFOR_FLTR
@ VX_LAYER_INFOR_FLTR
find layer filter info
Definition: zwapi_layer.h:42
cvxActiveLayerNumGet
evxErrors cvxActiveLayerNumGet(int *Number)
cvxLayerInfoGet
evxErrors cvxLayerInfoGet(int Number, svxLayerInfo *pLayerInfo)
cvxLayerInqEnts
evxErrors cvxLayerInqEnts(int Number, int *numEnt, svxEntPath **Paths)
cvxLayerGetAllCategory
evxErrors cvxLayerGetAllCategory(int *numCate, vxLongName **categories)
cvxLayerList
evxErrors cvxLayerList(int *Count, vxName **Names)
cvxLayerStateSet
evxErrors cvxLayerStateSet(vxName Name, int isVisible, int isFrozen)
cvxLayerId
evxErrors cvxLayerId(vxName name, int *id)
cvxLayerSync
evxErrors cvxLayerSync(void)
cvxLayerDel2
evxErrors cvxLayerDel2(int Number)
cvxLayerRefresh
void cvxLayerRefresh()
cvxLayerAdd
evxErrors cvxLayerAdd(char *Name)
cvxLayerIdModify
evxErrors cvxLayerIdModify(int srcNumber, int tarNumber)
cvxLayerShowAll
evxErrors cvxLayerShowAll(void)
cvxLayerStateGet
evxErrors cvxLayerStateGet(vxName Name, int *isVisible, int *isFrozen)
cvxLayerInfoSet
evxErrors cvxLayerInfoSet(int Number, const svxLayerInfo *pLayerInfo)
cvxLayerName
evxErrors cvxLayerName(int Number, vxName Name)
cvxLayerInfoExport
evxErrors cvxLayerInfoExport(const vxLongPath file)
cvxLayerAssign
evxErrors cvxLayerAssign(char *Name, int numEnt, int *idEnts)
cvxActiveLayerNumSet
evxErrors cvxActiveLayerNumSet(int Number)
cvxLayerActivate
evxErrors cvxLayerActivate(vxName Name)
cvxLayerDel
evxErrors cvxLayerDel(vxName Name)
cvxLayerNum
evxErrors cvxLayerNum(vxName Name, int *Number)
svxLayerInfo
struct svxLayerInfo svxLayerInfo
layer information
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxLayerInfo::sDesc
char sDesc[512]
layer description
Definition: zwapi_layer.h:55
svxLayerInfo::category
char category[512]
category, like this CURVES;SHEETS
Definition: zwapi_layer.h:63
svxLayerInfo::ulineWidth
unsigned char ulineWidth
layer linewidth
Definition: zwapi_layer.h:62
svxLayerInfo::uDisable
unsigned char uDisable
layer disable
Definition: zwapi_layer.h:59
svxLayerInfo::uLayerId
unsigned char uLayerId
layer id
Definition: zwapi_layer.h:56
svxLayerInfo::sName
char sName[32]
layer name
Definition: zwapi_layer.h:54
svxLayerInfo::uLineType
unsigned char uLineType
layer linetype
Definition: zwapi_layer.h:61
svxLayerInfo::uColor
unsigned char uColor
layer color
Definition: zwapi_layer.h:60
svxLayerInfo::mask
int mask
obtain specified information from mask (evxInfoLayerFlag). obtain sName and sDesc infos if mask = VX_...
Definition: zwapi_layer.h:52
svxLayerInfo::uVisible
unsigned char uVisible
layer visible
Definition: zwapi_layer.h:57
svxLayerInfo::uFrozen
unsigned char uFrozen
layer freeze
Definition: zwapi_layer.h:58
svxLayerInfo::iNumObj
int iNumObj
layer number object
Definition: zwapi_layer.h:64
svxLayerInfo
layer information
Definition: zwapi_layer.h:51
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_LIC_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_license.h
cvxLicActivate
cvxLicEvaluationGet
cvxLicIdentifierGet
cvxLicModulesGet
cvxLicRemove
cvxLicStandaloneEvaluationGet
cvxLicTypeCheck

◆ ZW_API_LIC_H

#define ZW_API_LIC_H

Definition at line 15 of file zwapi_license.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_license.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_license.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_LIC_H /* this ifndef surrounds entire header */
15#define ZW_API_LIC_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
40extern evxErrors cvxLicModulesGet(char szModules[1024]);
41
42/******************************************************************************/
55extern evxErrors cvxLicIdentifierGet(char szIdentifier[36]);
56
57/******************************************************************************/
72extern int cvxLicEvaluationGet(char szEvaluation[36]);
73
74/******************************************************************************/
87extern int cvxLicStandaloneEvaluationGet();
88
89/******************************************************************************/
103extern evxErrors cvxLicActivate(const char* pzEntitlement);
104
105/******************************************************************************/
119extern evxErrors cvxLicRemove(const char* pzEntitlement);
120
121/******************************************************************************/
133extern int cvxLicTypeCheck();
134
135
136/*
137*********************************************************************
138** END HEADER FILE
139*********************************************************************
140*/
141
142#ifdef __cplusplus
143 }
144#endif /* __cplusplus */
145
146#endif /* ZW_API_LIC_H */
cvxLicStandaloneEvaluationGet
int cvxLicStandaloneEvaluationGet()
cvxLicRemove
evxErrors cvxLicRemove(const char *pzEntitlement)
cvxLicIdentifierGet
evxErrors cvxLicIdentifierGet(char szIdentifier[36])
cvxLicActivate
evxErrors cvxLicActivate(const char *pzEntitlement)
cvxLicTypeCheck
int cvxLicTypeCheck()
cvxLicEvaluationGet
int cvxLicEvaluationGet(char szEvaluation[36])
cvxLicModulesGet
evxErrors cvxLicModulesGet(char szModules[1024])
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_MATH_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math.h
cvxAxisCrvDistance
cvxAxisDistance
cvxCrvPlaneParallelChk
cvxEntGetAngle
cvxEntGetDistance
cvxEntGetDistanceByPath
cvxPartInqEntsArea
cvxPartInqEntsAreaByPath
cvxPlaneDistance
cvxRoundNumber

◆ ZW_API_MATH_H

#define ZW_API_MATH_H

Definition at line 15 of file zwapi_math.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_MATH_H /* this ifndef surrounds entire header */
15#define ZW_API_MATH_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22//====================================================================================================================
24//====================================================================================================================
25/******************************************************************************/
71extern double cvxRoundNumber(double Num, double Step, double Tol, int Dir);
72
73//====================================================================================================================
75//====================================================================================================================
76/******************************************************************************/
98extern evxErrors cvxCrvPlaneParallelChk(const svxPoint* plnPnt, const svxVector* plnNormal, const svxCurve* Crv, double tol, int* isParallel, double* Distance);
99
100//====================================================================================================================
102//====================================================================================================================
103/******************************************************************************/
131extern evxErrors cvxAxisDistance(const svxAxis* Axis1, const svxAxis* Axis2, svxPoint* PntOnAxis1, svxPoint* PntOnAxis2, int* Flag);
132
133/******************************************************************************/
150extern evxErrors cvxAxisCrvDistance(const svxAxis* Axis, const svxCurve* Crv, svxPoint* pntOnAxis, svxPoint* pntOnCrv, double* Distance);
151
152/******************************************************************************/
170extern evxErrors cvxPlaneDistance(const svxPoint* PntOnPln1, const svxVector* NormalOfPln1, const svxPoint* PntOnPln2, const svxVector* NormalOfPln2, double* Distance);
171
172/******************************************************************************/
192extern evxErrors cvxEntGetDistance(int ent1, int ent2, svxPoint* p1, svxPoint* p2, double* dist);
193
194/******************************************************************************/
217extern evxErrors cvxEntGetDistanceByPath(svxEntPath* EntPath1, svxEntPath* EntPath2, svxPoint* Point1, svxPoint* Point2, double* MinDistance);
218
219//====================================================================================================================
221//====================================================================================================================
222/******************************************************************************/
245extern evxErrors cvxEntGetAngle(int ent1, int ent2, double* angle);
246
247/******************************************************************************/
273extern evxErrors cvxPartInqEntsArea(int cnt, int* crvList, svxAreaProp* areaProp);
274
275/******************************************************************************/
303extern evxErrors cvxPartInqEntsAreaByPath(int cnt, svxEntPath* crvList, svxAreaProp* areaProp);
304
305/*
306*********************************************************************
307** END HEADER FILE
308*********************************************************************
309*/
310
311#ifdef __cplusplus
312 }
313#endif /* __cplusplus */
314
315#endif /* ZW_API_MATH_H */
cvxEntGetDistance
evxErrors cvxEntGetDistance(int ent1, int ent2, svxPoint *p1, svxPoint *p2, double *dist)
cvxCrvPlaneParallelChk
evxErrors cvxCrvPlaneParallelChk(const svxPoint *plnPnt, const svxVector *plnNormal, const svxCurve *Crv, double tol, int *isParallel, double *Distance)
cvxAxisDistance
evxErrors cvxAxisDistance(const svxAxis *Axis1, const svxAxis *Axis2, svxPoint *PntOnAxis1, svxPoint *PntOnAxis2, int *Flag)
cvxEntGetAngle
evxErrors cvxEntGetAngle(int ent1, int ent2, double *angle)
cvxRoundNumber
double cvxRoundNumber(double Num, double Step, double Tol, int Dir)
cvxPartInqEntsArea
evxErrors cvxPartInqEntsArea(int cnt, int *crvList, svxAreaProp *areaProp)
cvxAxisCrvDistance
evxErrors cvxAxisCrvDistance(const svxAxis *Axis, const svxCurve *Crv, svxPoint *pntOnAxis, svxPoint *pntOnCrv, double *Distance)
cvxPlaneDistance
evxErrors cvxPlaneDistance(const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, double *Distance)
cvxEntGetDistanceByPath
evxErrors cvxEntGetDistanceByPath(svxEntPath *EntPath1, svxEntPath *EntPath2, svxPoint *Point1, svxPoint *Point2, double *MinDistance)
cvxPartInqEntsAreaByPath
evxErrors cvxPartInqEntsAreaByPath(int cnt, svxEntPath *crvList, svxAreaProp *areaProp)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAreaProp
area properties
Definition: zwapi_general_ent.h:31
svxAxis
3D axis
Definition: zwapi_util.h:349
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_BND_BOX_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_bndbox.h
cvxBndBoxAdd
cvxBndBoxCenter
cvxBndBoxContain
cvxBndBoxDist
cvxBndBoxInit
cvxBndBoxInit2
cvxBndBoxMerge
cvxBndBoxPntDist
cvxBndBoxPntLoc
cvxBndBoxPnts
cvxBndBoxSize
cvxBndBoxVolume

◆ ZW_API_BND_BOX_H

#define ZW_API_BND_BOX_H

Definition at line 15 of file zwapi_math_bndbox.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_bndbox.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_bndbox.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_BND_BOX_H /* this ifndef surrounds entire header */
15#define ZW_API_BND_BOX_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
37extern void cvxBndBoxInit(svxBndBox* Box);
38
39/******************************************************************************/
51extern void cvxBndBoxInit2(svxBndBox* Box);
52
53/******************************************************************************/
82extern void cvxBndBoxPnts(svxBndBox* Box, svxPoint* Pnts);
83
84/******************************************************************************/
98extern evxErrors cvxBndBoxCenter(const svxBndBox* Box, svxPoint* CenterPnt);
99
100/******************************************************************************/
115extern evxErrors cvxBndBoxPntLoc(const svxBndBox* Box, const svxPoint* Point, evxPntLocation* PntLoc);
116
117/******************************************************************************/
129extern void cvxBndBoxAdd(svxBndBox* Box, svxPoint* Pnt);
130
131/******************************************************************************/
143extern void cvxBndBoxMerge(const svxBndBox* Box1, svxBndBox* Box2);
144
145/******************************************************************************/
153extern double cvxBndBoxSize(svxBndBox* Box);
154
155/******************************************************************************/
163extern double cvxBndBoxVolume(const svxBndBox* Box);
164
165/******************************************************************************/
179extern int cvxBndBoxContain(const svxBndBox* BaseBox, const svxBndBox* OtherBox);
180
181/**********************************************************************
182*! -Bounding Box Transform- : zwapi_math_matrix.h
183* extern void cvxBndBoxTransform(svxMatrix* Mat, svxBndBox* Box);
184**********************************************************************/
185
186
187//====================================================================================================================
189//====================================================================================================================
190/******************************************************************************/
206extern evxErrors cvxBndBoxPntDist(const svxBndBox* Box, const svxPoint* Point, double* DistMin, double* DistMax);
207
208/******************************************************************************/
224extern evxErrors cvxBndBoxDist(const svxBndBox* Box1, const svxBndBox* Box2, double* DistMin, double* DistMax);
225
226/*
227*********************************************************************
228** END HEADER FILE
229*********************************************************************
230*/
231
232#ifdef __cplusplus
233 }
234#endif /* __cplusplus */
235#endif /* ZW_API_BND_BOX_H */
236
cvxBndBoxDist
evxErrors cvxBndBoxDist(const svxBndBox *Box1, const svxBndBox *Box2, double *DistMin, double *DistMax)
cvxBndBoxInit
void cvxBndBoxInit(svxBndBox *Box)
cvxBndBoxPntDist
evxErrors cvxBndBoxPntDist(const svxBndBox *Box, const svxPoint *Point, double *DistMin, double *DistMax)
cvxBndBoxPnts
void cvxBndBoxPnts(svxBndBox *Box, svxPoint *Pnts)
cvxBndBoxContain
int cvxBndBoxContain(const svxBndBox *BaseBox, const svxBndBox *OtherBox)
cvxBndBoxAdd
void cvxBndBoxAdd(svxBndBox *Box, svxPoint *Pnt)
cvxBndBoxMerge
void cvxBndBoxMerge(const svxBndBox *Box1, svxBndBox *Box2)
cvxBndBoxSize
double cvxBndBoxSize(svxBndBox *Box)
cvxBndBoxVolume
double cvxBndBoxVolume(const svxBndBox *Box)
cvxBndBoxPntLoc
evxErrors cvxBndBoxPntLoc(const svxBndBox *Box, const svxPoint *Point, evxPntLocation *PntLoc)
cvxBndBoxCenter
evxErrors cvxBndBoxCenter(const svxBndBox *Box, svxPoint *CenterPnt)
cvxBndBoxInit2
void cvxBndBoxInit2(svxBndBox *Box)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxPntLocation
evxPntLocation
point location
Definition: zwapi_util.h:603
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:34 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_MATH_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_data.h
evxEdgeLoopType
evxEdgeLoopType
evxFaceFindType
evxFaceFindType
evxFaceTrim
evxFaceTrim
svxEvalCurv
svxFaceFind

◆ ZW_API_MATH_DATA_H

#define ZW_API_MATH_DATA_H

Definition at line 17 of file zwapi_math_data.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_MATH_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_MATH_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxFaceTrim
33 {
34 VX_TRIM_NONE = 0,
35 VX_TRIM_ALL = 1,
36 VX_TRIM_OUTER = 2
37 } evxFaceTrim;
38
39//====================================================================================================================
41//====================================================================================================================
46typedef struct svxEvalCurv
47 {
48 int level;
49 svxPoint pnt;
50 svxPoint deriv_1;
51 svxPoint deriv_2;
52 svxPoint deriv_3;
53 } svxEvalCurv;
54
55//====================================================================================================================
57//====================================================================================================================
62typedef enum evxFaceFindType
63 {
64 VX_FIND_BOSS,
65 VX_FIND_POCKET,
66 VX_FIND_HOLE,
67 VX_FIND_FILLET,
68 VX_FIND_CUSTOM,
69 VX_FIND_FINDER,
70 } evxFaceFindType;
71
76typedef struct svxFaceFind
77 {
78 int numSeeds;
79 int* idSeeds;
80 evxFaceFindType Option;
81 int Rule;
83 int numEdges;
84 int* idEdges;
85 int AdjCnt;
86 int numFaces;
87 int* idFaces;
88 } svxFaceFind;
89
94typedef enum evxEdgeLoopType
95 {
96 VX_EDGE_LOOP_INNER = 0,
97 VX_EDGE_LOOP_OUTER = 1,
98 VX_EDGE_LOOP_ALL = 2,
99 VX_EDGE_LOOP_SHARED = 3,
100 VX_EDGE_LOOP_BOUNDARY = 4
101 } evxEdgeLoopType;
102
103
104#ifdef __cplusplus
105 }
106#endif /* __cplusplus */
107#endif /* ZW_API_MATH_DATA_H */
evxFaceTrim
evxFaceTrim
face trim-curve option
Definition: zwapi_math_data.h:33
VX_TRIM_NONE
@ VX_TRIM_NONE
ignore all trim boundaries
Definition: zwapi_math_data.h:34
VX_TRIM_OUTER
@ VX_TRIM_OUTER
use only the outer trim boundaries
Definition: zwapi_math_data.h:36
VX_TRIM_ALL
@ VX_TRIM_ALL
use all face trim boundaries
Definition: zwapi_math_data.h:35
evxEdgeLoopType
evxEdgeLoopType
type of loop in which the edge is located
Definition: zwapi_math_data.h:95
VX_EDGE_LOOP_OUTER
@ VX_EDGE_LOOP_OUTER
outer loop edges
Definition: zwapi_math_data.h:97
VX_EDGE_LOOP_ALL
@ VX_EDGE_LOOP_ALL
all edges
Definition: zwapi_math_data.h:98
VX_EDGE_LOOP_SHARED
@ VX_EDGE_LOOP_SHARED
shared edges
Definition: zwapi_math_data.h:99
VX_EDGE_LOOP_INNER
@ VX_EDGE_LOOP_INNER
inner loop edges
Definition: zwapi_math_data.h:96
VX_EDGE_LOOP_BOUNDARY
@ VX_EDGE_LOOP_BOUNDARY
boundary edges
Definition: zwapi_math_data.h:100
evxFaceFindType
evxFaceFindType
face search types
Definition: zwapi_math_data.h:63
VX_FIND_FILLET
@ VX_FIND_FILLET
find the faces that have the geometric characteristics of a network of fillet chains
Definition: zwapi_math_data.h:67
VX_FIND_CUSTOM
@ VX_FIND_CUSTOM
find the faces based on the stop conditions set (evxFindRule)
Definition: zwapi_math_data.h:68
VX_FIND_HOLE
@ VX_FIND_HOLE
find the faces that have the geometric characteristics of a hole
Definition: zwapi_math_data.h:66
VX_FIND_BOSS
@ VX_FIND_BOSS
find the faces that have the geometric characteristics of a boss
Definition: zwapi_math_data.h:64
VX_FIND_FINDER
@ VX_FIND_FINDER
base on seed face, find the faces that conforms to the set rules (evxFindRule)
Definition: zwapi_math_data.h:69
VX_FIND_POCKET
@ VX_FIND_POCKET
find the faces that have the geometric characteristics of a pocket
Definition: zwapi_math_data.h:65
svxFaceFind
struct svxFaceFind svxFaceFind
face search data
svxEvalCurv
struct svxEvalCurv svxEvalCurv
curve evaluate
svxEvalCurv::level
int level
level of evaluation
Definition: zwapi_math_data.h:48
svxEvalCurv::deriv_2
svxPoint deriv_2
level 2 - x'',y'' (or u'',v'')
Definition: zwapi_math_data.h:51
svxEvalCurv::pnt
svxPoint pnt
level 0 - x,y,z (or u,v)
Definition: zwapi_math_data.h:49
svxEvalCurv::deriv_1
svxPoint deriv_1
level 1 - x',y' (or u',v')
Definition: zwapi_math_data.h:50
svxEvalCurv::deriv_3
svxPoint deriv_3
level 3 - x''',y''',z''' (or u''',v''')
Definition: zwapi_math_data.h:52
svxEvalCurv
curve evaluate
Definition: zwapi_math_data.h:47
svxFaceFind::numFaces
int numFaces
number of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE
Definition: zwapi_math_data.h:86
svxFaceFind::numEdges
int numEdges
number of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type
Definition: zwapi_math_data.h:83
svxFaceFind::idEdges
int * idEdges
list of stop edges, used only for VX_FIND_CUSTOM(evxFaceFindType) type
Definition: zwapi_math_data.h:84
svxFaceFind::Rule
int Rule
face search rules(evxFindRule),like this:VX_STOP_FACE_FILLET | VX_STOP_FACE_FILLET,...
Definition: zwapi_math_data.h:81
svxFaceFind::Option
evxFaceFindType Option
type of face to search for
Definition: zwapi_math_data.h:80
svxFaceFind::AdjCnt
int AdjCnt
adjacency count(>0), used only when Rule contain VX_STOP_ADJACENCY_LEVEL
Definition: zwapi_math_data.h:85
svxFaceFind::idSeeds
int * idSeeds
list of seed faces
Definition: zwapi_math_data.h:79
svxFaceFind::idFaces
int * idFaces
list of stop faces, used only when Rule contain VX_STOP_BOUNDARY_FACE
Definition: zwapi_math_data.h:87
svxFaceFind::numSeeds
int numSeeds
number of seed faces
Definition: zwapi_math_data.h:78
svxFaceFind
face search data
Definition: zwapi_math_data.h:77
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_INSECT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_insect.h
cvxCompFind
cvxCompIsectShpShp
cvxIsectBndBoxBndBox
cvxIsectBndBoxPlane
cvxIsectCrvCrv
cvxIsectCrvFace
cvxIsectFaceFace
cvxIsectPlanePlane
cvxIsectRayBndBox
cvxIsectRayComp
cvxIsectRayComps
cvxIsectRayCrv
cvxIsectRayFace
cvxIsectRayFaceInfinite
cvxIsectRayPart
cvxIsectRayPartVis
cvxIsectRayPlane
cvxIsectRayShape
cvxIsectRayShapes
cvxPartIsectShpChk
cvxPartIsectShpChk2

◆ ZW_API_INSECT_H

#define ZW_API_INSECT_H

Definition at line 15 of file zwapi_math_insect.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_insect.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_insect.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_INSECT_H /* this ifndef surrounds entire header */
15#define ZW_API_INSECT_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
48extern evxErrors cvxIsectCrvCrv(int idCurve1, int idCurve2, int TangentOk, int* Count, svxPoint** Points);
49
50/******************************************************************************/
73extern evxErrors cvxIsectCrvFace(int idCurve, int idFace, int Trim, int TangentOk, int* Count, svxPoint** Points);
74
75/******************************************************************************/
103extern evxErrors cvxIsectFaceFace(int idFace1, int idFace2, evxFaceTrim Trim, int TangentOk, int* Count, svxCurve** Curves);
104
105
106//====================================================================================================================
108//====================================================================================================================
109/******************************************************************************/
130extern evxErrors cvxIsectRayCrv(svxAxis* Ray, int idCurve, int TangentOk, int* Count, svxPoint** Points);
131
132/******************************************************************************/
158extern evxErrors cvxIsectRayFace(int idFace, evxFaceTrim Trim, svxAxis* Ray, svxPoint* Point, svxPoint2* UV);
159
160/******************************************************************************/
188extern evxErrors cvxIsectRayFaceInfinite(int idFace, evxFaceTrim Trim, const svxAxis* Ray, int Infinite, int* Number, svxPoint** Pnts, svxPoint2** UVs);
189
190/******************************************************************************/
209extern int cvxIsectRayPlane(svxAxis* Ray, svxMatrix* Plane, svxPoint* Point);
210
211/******************************************************************************/
240extern evxErrors cvxIsectRayShape(int idShape, evxFaceTrim Trim, svxAxis* Ray, svxPoint* Point, int* idFace);
241
242/******************************************************************************/
272extern evxErrors cvxIsectRayShapes(int nShapes, int* idShapes, evxFaceTrim Trim, svxAxis* Ray, int* Number, svxPoint** Points, int** idFaces);
273
274/******************************************************************************/
304extern evxErrors cvxIsectRayPart(evxFaceTrim Trim, svxAxis* Ray, svxPoint* Point, int* idFace);
305
306/******************************************************************************/
326extern evxErrors cvxIsectRayPartVis(evxFaceTrim Trim, svxAxis* Ray, svxPoint* Point, int* idFace);
327
328/******************************************************************************/
358extern evxErrors cvxIsectRayComp(int idComp, evxFaceTrim Trim, svxAxis* Ray, svxPoint* Point);
359
360/******************************************************************************/
392extern evxErrors cvxIsectRayComps(int nComps, svxEntPath* CompPaths, evxFaceTrim Trim,
393 svxAxis* Ray, int* Number, svxPoint** Points, svxEntPath** FacePaths);
394
395/******************************************************************************/
423extern evxErrors cvxCompFind(evxFaceTrim Trim, svxAxis* Ray, double Dist, int SkipBlank, int* Count, int** Comps);
424
425/******************************************************************************/
442extern int cvxIsectRayBndBox(const svxAxis* Ray, const svxBndBox* Box, svxPoint* IsectPnt);
443
444//====================================================================================================================
446//====================================================================================================================
447/******************************************************************************/
465extern int cvxPartIsectShpChk(int idBaseShape, int idOpShape);
466
467/******************************************************************************/
489extern int cvxPartIsectShpChk2(int idBaseShape, int idOpShape, int fClosedChk);
490
491/******************************************************************************/
513extern int cvxCompIsectShpShp(const svxEntPath* basePath, const svxEntPath* opPath, evxFaceTrim trim, int* count, svxCurve** curves);
514
515/**********************************************************************
516*! -Interference Check- : zwapi_cmd_assembly.h
517* extern evxErrors cvxCompIsectShpChk(svxEntPath* BaseShpPath, svxEntPath* OpShpPath, int* fInterfer);
518* extern evxErrors cvxCompIsectShpChk2(svxEntPath* BaseShpPath, svxEntPath* OpShpPath, int fClosedChk, int* fInterfer);
519**********************************************************************/
520
521//====================================================================================================================
523//====================================================================================================================
524
525/******************************************************************************/
541extern int cvxIsectBndBoxBndBox(const svxBndBox* Box1, const svxBndBox* Box2);
542
543/******************************************************************************/
558extern int cvxIsectBndBoxPlane(const svxBndBox* Box, const svxPoint* PntOnPln, const svxVector* NormalOfPln);
559
560/******************************************************************************/
579extern int cvxIsectPlanePlane(const svxPoint* PntOnPln1, const svxVector* NormalOfPln1, const svxPoint* PntOnPln2, const svxVector* NormalOfPln2, svxAxis* IsectLine);
580
581/*
582*********************************************************************
583** END HEADER FILE
584*********************************************************************
585*/
586
587#ifdef __cplusplus
588 }
589#endif /* __cplusplus */
590
591#endif /* ZW_API_INSECT_H */
evxFaceTrim
evxFaceTrim
face trim-curve option
Definition: zwapi_math_data.h:33
cvxIsectCrvCrv
evxErrors cvxIsectCrvCrv(int idCurve1, int idCurve2, int TangentOk, int *Count, svxPoint **Points)
cvxIsectRayFace
evxErrors cvxIsectRayFace(int idFace, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, svxPoint2 *UV)
cvxIsectRayPartVis
evxErrors cvxIsectRayPartVis(evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
cvxPartIsectShpChk
int cvxPartIsectShpChk(int idBaseShape, int idOpShape)
cvxIsectRayPart
evxErrors cvxIsectRayPart(evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
cvxIsectRayComp
evxErrors cvxIsectRayComp(int idComp, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point)
cvxIsectBndBoxPlane
int cvxIsectBndBoxPlane(const svxBndBox *Box, const svxPoint *PntOnPln, const svxVector *NormalOfPln)
cvxIsectRayBndBox
int cvxIsectRayBndBox(const svxAxis *Ray, const svxBndBox *Box, svxPoint *IsectPnt)
cvxIsectRayCrv
evxErrors cvxIsectRayCrv(svxAxis *Ray, int idCurve, int TangentOk, int *Count, svxPoint **Points)
cvxIsectFaceFace
evxErrors cvxIsectFaceFace(int idFace1, int idFace2, evxFaceTrim Trim, int TangentOk, int *Count, svxCurve **Curves)
cvxCompFind
evxErrors cvxCompFind(evxFaceTrim Trim, svxAxis *Ray, double Dist, int SkipBlank, int *Count, int **Comps)
cvxIsectRayComps
evxErrors cvxIsectRayComps(int nComps, svxEntPath *CompPaths, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, svxEntPath **FacePaths)
cvxIsectRayPlane
int cvxIsectRayPlane(svxAxis *Ray, svxMatrix *Plane, svxPoint *Point)
cvxIsectPlanePlane
int cvxIsectPlanePlane(const svxPoint *PntOnPln1, const svxVector *NormalOfPln1, const svxPoint *PntOnPln2, const svxVector *NormalOfPln2, svxAxis *IsectLine)
cvxIsectCrvFace
evxErrors cvxIsectCrvFace(int idCurve, int idFace, int Trim, int TangentOk, int *Count, svxPoint **Points)
cvxCompIsectShpShp
int cvxCompIsectShpShp(const svxEntPath *basePath, const svxEntPath *opPath, evxFaceTrim trim, int *count, svxCurve **curves)
cvxIsectRayFaceInfinite
evxErrors cvxIsectRayFaceInfinite(int idFace, evxFaceTrim Trim, const svxAxis *Ray, int Infinite, int *Number, svxPoint **Pnts, svxPoint2 **UVs)
cvxIsectRayShape
evxErrors cvxIsectRayShape(int idShape, evxFaceTrim Trim, svxAxis *Ray, svxPoint *Point, int *idFace)
cvxIsectBndBoxBndBox
int cvxIsectBndBoxBndBox(const svxBndBox *Box1, const svxBndBox *Box2)
cvxIsectRayShapes
evxErrors cvxIsectRayShapes(int nShapes, int *idShapes, evxFaceTrim Trim, svxAxis *Ray, int *Number, svxPoint **Points, int **idFaces)
cvxPartIsectShpChk2
int cvxPartIsectShpChk2(int idBaseShape, int idOpShape, int fClosedChk)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_MATRIX_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_matrix.h
cvxAxisTransform
cvxBndBoxTransform
cvxCrvTransform
cvxMatEigen
cvxMatFromEuler
cvxMatGetPntVecs
cvxMatInit
cvxMatInvert
cvxMatMult
cvxMatPntVec
cvxMatPntVecs
cvxMatRotate
cvxMatScale
cvxMatSetIdentity
cvxMatToEuler
cvxMatTransform
cvxMatTranslate
cvxMatView
cvxPntTransform
cvxPntTransformList
cvxSrfTransform
cvxVecTransform

◆ ZW_API_MATRIX_H

#define ZW_API_MATRIX_H

Definition at line 15 of file zwapi_math_matrix.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_matrix.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_matrix.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_MATRIX_H /* this ifndef surrounds entire header */
15#define ZW_API_MATRIX_H
16
17#include "zwapi_math_data.h"
18
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24//====================================================================================================================
26//====================================================================================================================
27
28/******************************************************************************/
62extern evxErrors cvxMatEigen(const double Mat3x3[3][3], double* Values, svxVector* Vectors);
63
64/******************************************************************************/
75extern void cvxMatInit(svxMatrix* Mat);
76
77/******************************************************************************/
91extern void cvxMatInvert(svxMatrix* Mat, svxMatrix* InvMat);
92
93/******************************************************************************/
107extern void cvxMatMult(svxMatrix* Mat1, svxMatrix* Mat2, svxMatrix* Mat3);
108
109/******************************************************************************/
126extern void cvxMatPntVec(svxPoint* Origin, svxVector* zAxis, svxMatrix* Mat);
127
128/******************************************************************************/
150extern evxErrors cvxMatPntVecs(svxPoint* Origin, svxVector* xAxis, svxVector* yAxis, svxMatrix* Mat);
151
152/******************************************************************************/
169extern evxErrors cvxMatGetPntVecs(const svxMatrix* Mat, svxPoint* Origin, svxVector* xAxis, svxVector* yAxis, svxVector* zAxis);
170
171/******************************************************************************/
185extern void cvxMatRotate(svxMatrix* Mat, double Angle, svxAxis* Axis);
186
187/******************************************************************************/
203extern void cvxMatScale(svxMatrix* Mat, svxPoint* Point, double sX, double sY, double sZ);
204
205/******************************************************************************/
216extern void cvxMatSetIdentity(svxMatrix* Mat);
217
218/******************************************************************************/
230extern void cvxMatTransform(svxMatrix* Mat, svxMatrix* Frame);
231
232/******************************************************************************/
246extern void cvxMatTranslate(svxMatrix* Mat, double dX, double dY, double dZ);
247
248/******************************************************************************/
260extern void cvxMatView(svxMatrix* Mat, evxViewStd Type);
261
262/******************************************************************************/
292extern evxErrors cvxMatToEuler(evxEulerAngSeq Seq, svxMatrix* pMat, svxMatEuler* pzMatEuler);
293
294/******************************************************************************/
324extern evxErrors cvxMatFromEuler(evxEulerAngSeq Seq, const svxMatEuler* pzMatEuler, svxMatrix* pMat);
325
326
327//====================================================================================================================
329//====================================================================================================================
330/******************************************************************************/
345extern void cvxPntTransform(svxMatrix* Mat, svxPoint* Point);
346
347/******************************************************************************/
360extern void cvxPntTransformList(svxMatrix* Mat, int Count, svxPoint* Points);
361
362/******************************************************************************/
374extern void cvxAxisTransform(svxMatrix* Mat, svxAxis* Axis);
375
376/******************************************************************************/
388extern void cvxVecTransform(svxMatrix* Mat, svxVector* Vector);
389
390/******************************************************************************/
403extern void cvxCrvTransform(svxMatrix* Mat, svxCurve* Crv);
404
405/******************************************************************************/
418extern void cvxSrfTransform(svxMatrix* Mat, svxSurface* Srf);
419
420/******************************************************************************/
434extern void cvxBndBoxTransform(svxMatrix* Mat, svxBndBox* Box);
435
436
437/*
438*********************************************************************
439** END HEADER FILE
440*********************************************************************
441*/
442
443#ifdef __cplusplus
444 }
445#endif /* __cplusplus */
446
447#endif /* ZW_API_MATRIX_H */
cvxMatRotate
void cvxMatRotate(svxMatrix *Mat, double Angle, svxAxis *Axis)
cvxMatTranslate
void cvxMatTranslate(svxMatrix *Mat, double dX, double dY, double dZ)
cvxMatSetIdentity
void cvxMatSetIdentity(svxMatrix *Mat)
cvxCrvTransform
void cvxCrvTransform(svxMatrix *Mat, svxCurve *Crv)
cvxMatTransform
void cvxMatTransform(svxMatrix *Mat, svxMatrix *Frame)
cvxMatEigen
evxErrors cvxMatEigen(const double Mat3x3[3][3], double *Values, svxVector *Vectors)
cvxAxisTransform
void cvxAxisTransform(svxMatrix *Mat, svxAxis *Axis)
cvxMatPntVecs
evxErrors cvxMatPntVecs(svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxMatrix *Mat)
cvxMatFromEuler
evxErrors cvxMatFromEuler(evxEulerAngSeq Seq, const svxMatEuler *pzMatEuler, svxMatrix *pMat)
cvxMatMult
void cvxMatMult(svxMatrix *Mat1, svxMatrix *Mat2, svxMatrix *Mat3)
cvxPntTransform
void cvxPntTransform(svxMatrix *Mat, svxPoint *Point)
cvxMatInvert
void cvxMatInvert(svxMatrix *Mat, svxMatrix *InvMat)
cvxMatToEuler
evxErrors cvxMatToEuler(evxEulerAngSeq Seq, svxMatrix *pMat, svxMatEuler *pzMatEuler)
cvxPntTransformList
void cvxPntTransformList(svxMatrix *Mat, int Count, svxPoint *Points)
cvxMatView
void cvxMatView(svxMatrix *Mat, evxViewStd Type)
cvxMatPntVec
void cvxMatPntVec(svxPoint *Origin, svxVector *zAxis, svxMatrix *Mat)
cvxMatGetPntVecs
evxErrors cvxMatGetPntVecs(const svxMatrix *Mat, svxPoint *Origin, svxVector *xAxis, svxVector *yAxis, svxVector *zAxis)
cvxSrfTransform
void cvxSrfTransform(svxMatrix *Mat, svxSurface *Srf)
cvxBndBoxTransform
void cvxBndBoxTransform(svxMatrix *Mat, svxBndBox *Box)
cvxMatScale
void cvxMatScale(svxMatrix *Mat, svxPoint *Point, double sX, double sY, double sZ)
cvxVecTransform
void cvxVecTransform(svxMatrix *Mat, svxVector *Vector)
cvxMatInit
void cvxMatInit(svxMatrix *Mat)
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
evxEulerAngSeq
evxEulerAngSeq
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.
Definition: zwapi_util.h:505
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxMatEuler
Euler angles and translate vector.
Definition: zwapi_util.h:491
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_NURBS_CURVE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_nurbscurve.h
cvxCrvContinuityTolListInit
cvxCrvEval
cvxCrvEval2
cvxCrvEvalCrvtr
cvxCrvExtremum
cvxCrvGetCusps
cvxCrvGetInflections
cvxCrvGetPntAtDist
cvxCrvGetPntAtLenFraction
cvxCrvInqContinuity
cvxCrvInqExtreme
cvxCrvInqMultiContinuity
cvxCrvIsLine
cvxCrvLen
cvxCrvLen2
cvxCrvMinMaxRad
cvxCrvParam
cvxCrvPntProj
cvxPartCurveChainFind
cvxPartSew
cvxPreEdgeEval

◆ ZW_API_NURBS_CURVE_H

#define ZW_API_NURBS_CURVE_H

Definition at line 15 of file zwapi_math_nurbscurve.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_nurbscurve.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_nurbscurve.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_NURBS_CURVE_H /* this ifndef surrounds entire header */
15#define ZW_API_NURBS_CURVE_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
53extern evxErrors cvxCrvEval(int idCurve, double T, svxPoint* Point, svxVector* Normal);
54
55/******************************************************************************/
84extern evxErrors cvxCrvEval2(const int idCurve, const double t, const int level, svxEvalCurv* eval);
85
86/******************************************************************************/
118extern evxErrors cvxPreEdgeEval(const int idPreEdge, const double t, const int level, svxEvalCurv* eval);
119
120/******************************************************************************/
142extern evxErrors cvxCrvEvalCrvtr(const int idCurve, const double t, svxPoint* point, svxPoint* normal, double* curvature);
143
144
145//====================================================================================================================
147//====================================================================================================================
148/******************************************************************************/
161extern int cvxCrvIsLine(int idCurve);
162
163/******************************************************************************/
181extern evxErrors cvxCrvParam(int idCurve, svxLimit* T);
182
183/******************************************************************************/
203extern evxErrors cvxCrvMinMaxRad(int idCurve, double* minRad, double* maxRad, int* isFlat);
204
205/******************************************************************************/
226extern evxErrors cvxCrvInqContinuity(int Count, int* Curves, int* Continuity);
227
228/******************************************************************************/
244extern evxErrors cvxCrvContinuityTolListInit(svxCrvContinuityTolList* data);
245
246/******************************************************************************/
280extern evxErrors cvxCrvInqMultiContinuity(int cnt, const int* curves, const svxCrvContinuityTolList* tols, int* cntContinuity, svxCrvContinuityData** data);
281
282/******************************************************************************/
318extern evxErrors cvxPartCurveChainFind(int nSeeds, int* idSeeds, int type, int* Count, int** idCrvs);
319
320
321//====================================================================================================================
323//====================================================================================================================
324/******************************************************************************/
347extern evxErrors cvxCrvGetPntAtLenFraction(int idCurve, double Fraction, svxPoint* Point);
348
349/******************************************************************************/
370extern evxErrors cvxCrvPntProj(int idCurve, svxPoint* Pnt, double* T, svxPoint* ProjPnt);
371
372/******************************************************************************/
392extern evxErrors cvxCrvGetPntAtDist(int idCurve, double StartT, double Length, double* T, svxPoint* Point);
393
394/******************************************************************************/
416extern evxErrors cvxCrvGetInflections(int idCurve, int* Count, double** T, svxPoint** InfPnts);
417
418/******************************************************************************/
440extern evxErrors cvxCrvInqExtreme(int idCurve, const svxVector* Dir, int* isPerp, svxPoint* Point);
441
442/******************************************************************************/
464extern evxErrors cvxCrvExtremum(int idCurve, int* Count, svxPoint** Pnts, svxBndBox* BndBox);
465
466/******************************************************************************/
488extern evxErrors cvxCrvGetCusps(int idCurve, int* Count, double** T, svxPoint** Cusps);
489
490
491//====================================================================================================================
493//====================================================================================================================
494/******************************************************************************/
512extern evxErrors cvxCrvLen(int idCurve, double* Len);
513
514/******************************************************************************/
533extern evxErrors cvxCrvLen2(int idCurve, double T1, double T2, double* Length);
534
535
536//====================================================================================================================
538//====================================================================================================================
539/******************************************************************************/
559extern evxErrors cvxPartSew(double Tol, int* OpenEdges, double* MaxGap);
560
561
562/*
563*********************************************************************
564** END HEADER FILE
565*********************************************************************
566*/
567
568#ifdef __cplusplus
569 }
570#endif /* __cplusplus */
571#endif /* ZW_API_NURBS_CURVE_H */
cvxCrvInqMultiContinuity
evxErrors cvxCrvInqMultiContinuity(int cnt, const int *curves, const svxCrvContinuityTolList *tols, int *cntContinuity, svxCrvContinuityData **data)
cvxCrvExtremum
evxErrors cvxCrvExtremum(int idCurve, int *Count, svxPoint **Pnts, svxBndBox *BndBox)
cvxCrvEval2
evxErrors cvxCrvEval2(const int idCurve, const double t, const int level, svxEvalCurv *eval)
cvxCrvPntProj
evxErrors cvxCrvPntProj(int idCurve, svxPoint *Pnt, double *T, svxPoint *ProjPnt)
cvxCrvInqContinuity
evxErrors cvxCrvInqContinuity(int Count, int *Curves, int *Continuity)
cvxCrvGetInflections
evxErrors cvxCrvGetInflections(int idCurve, int *Count, double **T, svxPoint **InfPnts)
cvxCrvEval
evxErrors cvxCrvEval(int idCurve, double T, svxPoint *Point, svxVector *Normal)
cvxCrvParam
evxErrors cvxCrvParam(int idCurve, svxLimit *T)
cvxCrvMinMaxRad
evxErrors cvxCrvMinMaxRad(int idCurve, double *minRad, double *maxRad, int *isFlat)
cvxPartCurveChainFind
evxErrors cvxPartCurveChainFind(int nSeeds, int *idSeeds, int type, int *Count, int **idCrvs)
cvxCrvInqExtreme
evxErrors cvxCrvInqExtreme(int idCurve, const svxVector *Dir, int *isPerp, svxPoint *Point)
cvxCrvLen
evxErrors cvxCrvLen(int idCurve, double *Len)
cvxPreEdgeEval
evxErrors cvxPreEdgeEval(const int idPreEdge, const double t, const int level, svxEvalCurv *eval)
cvxCrvGetPntAtLenFraction
evxErrors cvxCrvGetPntAtLenFraction(int idCurve, double Fraction, svxPoint *Point)
cvxCrvEvalCrvtr
evxErrors cvxCrvEvalCrvtr(const int idCurve, const double t, svxPoint *point, svxPoint *normal, double *curvature)
cvxPartSew
evxErrors cvxPartSew(double Tol, int *OpenEdges, double *MaxGap)
cvxCrvContinuityTolListInit
evxErrors cvxCrvContinuityTolListInit(svxCrvContinuityTolList *data)
cvxCrvGetPntAtDist
evxErrors cvxCrvGetPntAtDist(int idCurve, double StartT, double Length, double *T, svxPoint *Point)
cvxCrvGetCusps
evxErrors cvxCrvGetCusps(int idCurve, int *Count, double **T, svxPoint **Cusps)
cvxCrvIsLine
int cvxCrvIsLine(int idCurve)
cvxCrvLen2
evxErrors cvxCrvLen2(int idCurve, double T1, double T2, double *Length)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCrvContinuityData
data of curve continuity.
Definition: zwapi_util.h:1645
svxCrvContinuityTolList
curve continuity tolerance list
Definition: zwapi_util.h:1663
svxEvalCurv
curve evaluate
Definition: zwapi_math_data.h:47
svxLimit
limits
Definition: zwapi_util.h:455
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_NURBS_SURFACE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_nurbssurface.h
cvxPartFace
cvxPartFaceEdgesFind
cvxPartFaceFind
cvxPartFaceMod
cvxSrfAxis
cvxSrfDiameterEval
cvxSrfEval
cvxSrfFindPoles
cvxSrfGetPole

◆ ZW_API_NURBS_SURFACE_H

#define ZW_API_NURBS_SURFACE_H

Definition at line 15 of file zwapi_math_nurbssurface.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_nurbssurface.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_nurbssurface.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_NURBS_SURFACE_H /* this ifndef surrounds entire header */
15#define ZW_API_NURBS_SURFACE_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
78extern evxErrors cvxPartFace(svxSurface* Srf, int NumCurves, svxCurve* TrimCurves, int Code, int Sew, double Tol, int* idFace);
79
80/******************************************************************************/
131extern evxErrors cvxPartFaceMod(int idFace, svxSurface* Srf, int NumCurves, svxCurve* TrimCurves, int Sew, double Tol);
132
133//====================================================================================================================
135//====================================================================================================================
136/******************************************************************************/
166extern evxErrors cvxSrfEval(svxSurface* Srf, double U, double V, svxPoint* Point, svxVector* Normal, svxVector* Utan, svxVector* Vtan);
167
168/******************************************************************************/
191extern evxErrors cvxSrfDiameterEval(svxSurface* Srf, double U, double V, double* Diameter);
192
193
194//====================================================================================================================
196//====================================================================================================================
197/******************************************************************************/
221extern evxErrors cvxPartFaceFind(svxFaceFind* findData, int* Count, int** idFaces);
222
223/******************************************************************************/
245extern evxErrors cvxPartFaceEdgesFind(int nSeeds, int* idSeeds, evxEdgeLoopType type, int* Count, int** idEdges);
246
247
248//====================================================================================================================
250//====================================================================================================================
251/******************************************************************************/
271extern evxErrors cvxSrfAxis(svxSurface* Srf, svxPoint* startPnt, svxPoint* endPnt);
272
273/******************************************************************************/
291extern evxErrors cvxSrfGetPole(svxSurface* srf, const svxPoint* dir, svxPoint* pnt);
292
293/******************************************************************************/
320extern int cvxSrfFindPoles(svxSurface* srf, double tol, int poles[4]);
321
322
323/*
324*********************************************************************
325** END HEADER FILE
326*********************************************************************
327*/
328
329#ifdef __cplusplus
330 }
331#endif /* __cplusplus */
332
333#endif /* ZW_API_NURBS_SURFACE_H */
evxEdgeLoopType
evxEdgeLoopType
type of loop in which the edge is located
Definition: zwapi_math_data.h:95
cvxPartFaceMod
evxErrors cvxPartFaceMod(int idFace, svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Sew, double Tol)
cvxSrfDiameterEval
evxErrors cvxSrfDiameterEval(svxSurface *Srf, double U, double V, double *Diameter)
cvxPartFaceEdgesFind
evxErrors cvxPartFaceEdgesFind(int nSeeds, int *idSeeds, evxEdgeLoopType type, int *Count, int **idEdges)
cvxPartFace
evxErrors cvxPartFace(svxSurface *Srf, int NumCurves, svxCurve *TrimCurves, int Code, int Sew, double Tol, int *idFace)
cvxSrfAxis
evxErrors cvxSrfAxis(svxSurface *Srf, svxPoint *startPnt, svxPoint *endPnt)
cvxSrfGetPole
evxErrors cvxSrfGetPole(svxSurface *srf, const svxPoint *dir, svxPoint *pnt)
cvxSrfFindPoles
int cvxSrfFindPoles(svxSurface *srf, double tol, int poles[4])
cvxPartFaceFind
evxErrors cvxPartFaceFind(svxFaceFind *findData, int *Count, int **idFaces)
cvxSrfEval
evxErrors cvxSrfEval(svxSurface *Srf, double U, double V, svxPoint *Point, svxVector *Normal, svxVector *Utan, svxVector *Vtan)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxFaceFind
face search data
Definition: zwapi_math_data.h:77
svxPoint
3D point
Definition: zwapi_util.h:306
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_POINT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_point.h
cvxAxisEvalPoint
cvxAxisPntDistance
cvxAxisPntProject
cvxPlaneEvalPoint
cvxPlanePntDistance
cvxPlanePntProject
cvxPlnThruPnts
cvxPntDist
cvxPntEntDist
cvxPntEntLoc
cvxPntIsCritical
cvxPntIsOn
cvxPntOnCrv
cvxPntOnFace
cvxPntPreEdgeDist
cvxPntProject
cvxPntTranslate
cvxPolyToTri

◆ ZW_API_POINT_H

#define ZW_API_POINT_H

Definition at line 15 of file zwapi_math_point.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_point.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_point.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_POINT_H /* this ifndef surrounds entire header */
15#define ZW_API_POINT_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
44extern int cvxPntIsCritical(svxPoint* pnt, int idCurve);
45
46/******************************************************************************/
58extern int cvxPntIsOn(svxPoint* Pnt, int idEntity);
59
60/******************************************************************************/
79extern evxErrors cvxPntOnCrv(int idCurve, double Fraction, svxPoint* Point);
80
81/******************************************************************************/
102extern evxErrors cvxPntOnFace(int idComp, int idFace, double Param[2], svxPoint* Point);
103
104/******************************************************************************/
121extern evxErrors cvxPntProject(svxPoint* Pnt, int idEntity, svxPoint* ProjPnt);
122
123/******************************************************************************/
141extern evxErrors cvxPntEntLoc(svxPoint* Pnt, int idEntity, evxPntLocation* PntLoc);
142
143/******************************************************************************/
159extern evxErrors cvxAxisPntProject(const svxAxis* Axis, const svxPoint* Pnt, svxPoint* ProjPnt);
160
161/******************************************************************************/
180extern int cvxPlanePntProject(const svxPoint* PlnPnt, const svxVector* PlnNormal, const svxPoint* Point, const svxVector* ProjectDir, svxPoint* ProjPnt);
181
182//====================================================================================================================
184//====================================================================================================================
185/******************************************************************************/
199extern void cvxPntTranslate(svxPoint* Point, svxVector* Vector, double Distance);
200
201/******************************************************************************/
213extern double cvxPntDist(const svxPoint* Point1, const svxPoint* Point2);
214
215/******************************************************************************/
234extern evxErrors cvxPntEntDist(const svxPoint* Point, int idEntity, svxPoint* TargetPnt, double* Distance);
235
236/******************************************************************************/
259extern evxErrors cvxPntPreEdgeDist(const svxPoint* Point, int idPreEdge, double* T, svxPoint* TargetPnt, double* Distance);
260
261/******************************************************************************/
277extern evxErrors cvxAxisPntDistance(const svxAxis* Axis, const svxPoint* Pnt, double* Distance);
278
279/******************************************************************************/
296extern evxErrors cvxPlanePntDistance(const svxPoint* PlnPnt, const svxVector* PlnNormal, const svxPoint* Point, double* Distance, svxPoint* ProjPnt);
297
298//====================================================================================================================
300//====================================================================================================================
301
302/******************************************************************************/
319extern evxErrors cvxAxisEvalPoint(const svxAxis* Axis, double Distance, svxPoint* Point);
320
321/******************************************************************************/
339extern evxErrors cvxPlaneEvalPoint(const svxPoint* Origin, const svxVector* xAxis, const svxVector* yAxis, double xDist, double yDist, svxPoint* Point);
340
341//====================================================================================================================
343//====================================================================================================================
344/******************************************************************************/
369extern int cvxPlnThruPnts(int PntCount, svxPoint* PntList, svxVector* Normal, double* D);
370
371/******************************************************************************/
404extern evxErrors cvxPolyToTri(int PntCount, svxPoint* PntList, int* VtxCount, int** VtxList);
405
406
407/*
408*********************************************************************
409** END HEADER FILE
410*********************************************************************
411*/
412
413#ifdef __cplusplus
414 }
415#endif /* __cplusplus */
416
417#endif /* ZW_API_POINT_H */
cvxPntEntLoc
evxErrors cvxPntEntLoc(svxPoint *Pnt, int idEntity, evxPntLocation *PntLoc)
cvxAxisPntDistance
evxErrors cvxAxisPntDistance(const svxAxis *Axis, const svxPoint *Pnt, double *Distance)
cvxPlnThruPnts
int cvxPlnThruPnts(int PntCount, svxPoint *PntList, svxVector *Normal, double *D)
cvxPntOnCrv
evxErrors cvxPntOnCrv(int idCurve, double Fraction, svxPoint *Point)
cvxAxisEvalPoint
evxErrors cvxAxisEvalPoint(const svxAxis *Axis, double Distance, svxPoint *Point)
cvxPlanePntProject
int cvxPlanePntProject(const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, const svxVector *ProjectDir, svxPoint *ProjPnt)
cvxPlaneEvalPoint
evxErrors cvxPlaneEvalPoint(const svxPoint *Origin, const svxVector *xAxis, const svxVector *yAxis, double xDist, double yDist, svxPoint *Point)
cvxAxisPntProject
evxErrors cvxAxisPntProject(const svxAxis *Axis, const svxPoint *Pnt, svxPoint *ProjPnt)
cvxPntDist
double cvxPntDist(const svxPoint *Point1, const svxPoint *Point2)
cvxPntIsCritical
int cvxPntIsCritical(svxPoint *pnt, int idCurve)
cvxPntProject
evxErrors cvxPntProject(svxPoint *Pnt, int idEntity, svxPoint *ProjPnt)
cvxPntOnFace
evxErrors cvxPntOnFace(int idComp, int idFace, double Param[2], svxPoint *Point)
cvxPlanePntDistance
evxErrors cvxPlanePntDistance(const svxPoint *PlnPnt, const svxVector *PlnNormal, const svxPoint *Point, double *Distance, svxPoint *ProjPnt)
cvxPntPreEdgeDist
evxErrors cvxPntPreEdgeDist(const svxPoint *Point, int idPreEdge, double *T, svxPoint *TargetPnt, double *Distance)
cvxPntTranslate
void cvxPntTranslate(svxPoint *Point, svxVector *Vector, double Distance)
cvxPntEntDist
evxErrors cvxPntEntDist(const svxPoint *Point, int idEntity, svxPoint *TargetPnt, double *Distance)
cvxPntIsOn
int cvxPntIsOn(svxPoint *Pnt, int idEntity)
cvxPolyToTri
evxErrors cvxPolyToTri(int PntCount, svxPoint *PntList, int *VtxCount, int **VtxList)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
evxPntLocation
evxPntLocation
point location
Definition: zwapi_util.h:603
svxAxis
3D axis
Definition: zwapi_util.h:349
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_VECTOR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_math_vector.h
cvxVecAngle
cvxVecCross
cvxVecInit
cvxVecNormalize
cvxVecParallelChk
cvxVecPerp
cvxVecReverse

◆ ZW_API_VECTOR_H

#define ZW_API_VECTOR_H

Definition at line 15 of file zwapi_math_vector.h.
Generated at Sun Apr 23 2023 16:41:39 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_math_vector.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_math_vector.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_VECTOR_H /* this ifndef surrounds entire header */
15#define ZW_API_VECTOR_H
16
17#include "zwapi_math_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
41extern void cvxVecInit(svxPoint* Point1, svxPoint* Point2, svxVector* Vector);
42
43/******************************************************************************/
54extern void cvxVecNormalize(svxVector* Vector);
55
56/******************************************************************************/
71extern void cvxVecAngle(svxVector* V1, svxVector* V2, double* Angle);
72
73/******************************************************************************/
87extern void cvxVecCross(svxVector* V1, svxVector* V2, svxVector* Cross);
88
89/******************************************************************************/
102extern void cvxVecPerp(svxVector* Vector, svxVector* Perp);
103
104/******************************************************************************/
115extern void cvxVecReverse(svxVector* Vector);
116
117/******************************************************************************/
154extern int cvxVecParallelChk(int Orient, svxVector* V1, svxVector* V2, double CosTol);
155
156
157/*
158*********************************************************************
159** END HEADER FILE
160*********************************************************************
161*/
162
163#ifdef __cplusplus
164 }
165#endif /* __cplusplus */
166
167#endif /* ZW_API_VECTOR_H */
168
169
170
cvxVecPerp
void cvxVecPerp(svxVector *Vector, svxVector *Perp)
cvxVecCross
void cvxVecCross(svxVector *V1, svxVector *V2, svxVector *Cross)
cvxVecReverse
void cvxVecReverse(svxVector *Vector)
cvxVecParallelChk
int cvxVecParallelChk(int Orient, svxVector *V1, svxVector *V2, double CosTol)
cvxVecInit
void cvxVecInit(svxPoint *Point1, svxPoint *Point2, svxVector *Vector)
cvxVecAngle
void cvxVecAngle(svxVector *V1, svxVector *V2, double *Angle)
cvxVecNormalize
void cvxVecNormalize(svxVector *Vector)
svxPoint
3D point
Definition: zwapi_util.h:306
svxVector
3D vector
Definition: zwapi_util.h:338
zwapi_math_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_MEM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_memory.h
cvxMemAlloc
cvxMemFree
cvxMemResize
cvxMemZero

◆ ZW_API_MEM_H

#define ZW_API_MEM_H

Definition at line 15 of file zwapi_memory.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_memory.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_memory.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_MEM_H /* this ifndef surrounds entire header */
15#define ZW_API_MEM_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
41extern evxErrors cvxMemAlloc(int NumBytes, void** MemPointer);
42
43/******************************************************************************/
60extern evxErrors cvxMemResize(int NumBytes, void** MemPointer);
61
62
63//====================================================================================================================
65//====================================================================================================================
66/******************************************************************************/
78extern void cvxMemZero(void* MemPointer, int NumBytes);
79
80
81//====================================================================================================================
83//====================================================================================================================
84/******************************************************************************/
97extern void cvxMemFree(void** MemPointer);
98
99
100/*
101*********************************************************************
102** END HEADER FILE
103*********************************************************************
104*/
105
106#ifdef __cplusplus
107 }
108#endif /* __cplusplus */
109
110#endif /* ZW_API_MEM_H */
cvxMemResize
evxErrors cvxMemResize(int NumBytes, void **MemPointer)
cvxMemAlloc
evxErrors cvxMemAlloc(int NumBytes, void **MemPointer)
cvxMemZero
void cvxMemZero(void *MemPointer, int NumBytes)
cvxMemFree
void cvxMemFree(void **MemPointer)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_MSG_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_message.h
cvxCrashPromptDisable
cvxCrashPromptEnable
cvxErrDisable
cvxErrEnable
cvxErrMsgGet
cvxLastErrGet
cvxLastErrSet
cvxLastWarningMsgEnable
cvxMessageBox
cvxMsgAreaClose
cvxMsgAreaOpen
cvxMsgAreaState
cvxMsgAreaStateGet
cvxMsgDisable
cvxMsgDisp
cvxMsgDisp2
cvxMsgEnable
cvxMsgFileLoad
cvxMsgPtr
cvxPromptDisable
cvxPromptEnable
cvxTranStatusDisable
cvxTranStatusEnable
cvxUserActionStatusGet
cvxUserActionStatusSet
cvxUserActionStatusSet2
evxDialogType
evxDialogType

◆ ZW_API_MSG_H

#define ZW_API_MSG_H

Definition at line 15 of file zwapi_message.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_message.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_message.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_MSG_H /* this ifndef surrounds entire header */
15#define ZW_API_MSG_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxDialogType
31 {
32 VX_DIALOG_SAVE_AS = 1
33 } evxDialogType;
34
35//====================================================================================================================
37//====================================================================================================================
38/******************************************************************************/
47extern void cvxErrDisable(void);
48
49/******************************************************************************/
55extern void cvxErrEnable(void);
56
57/******************************************************************************/
69extern void cvxMsgDisable(void);
70
71/******************************************************************************/
77extern void cvxMsgEnable(void);
78
79/******************************************************************************/
90extern void cvxLastWarningMsgEnable(int enable);
91
92/******************************************************************************/
98extern void cvxPromptDisable(void);
99
100/******************************************************************************/
106extern void cvxPromptEnable(void);
107
108/******************************************************************************/
116extern void cvxTranStatusDisable(void);
117
118/******************************************************************************/
126extern void cvxTranStatusEnable(void);
127
128/******************************************************************************/
136extern void cvxUserActionStatusGet(int* disableStatus);
137
138/******************************************************************************/
158extern void cvxUserActionStatusSet(int disable);
159
160/******************************************************************************/
167extern void cvxCrashPromptDisable();
168
169/******************************************************************************/
176extern void cvxCrashPromptEnable();
177
178/******************************************************************************/
199extern int cvxUserActionStatusSet2(evxDialogType type, int value);
200
201
202//====================================================================================================================
204//====================================================================================================================
205/******************************************************************************/
211extern void cvxMsgAreaClose(void);
212
213/******************************************************************************/
219extern void cvxMsgAreaOpen(void);
220
221/******************************************************************************/
234extern void cvxMsgAreaState(int);
235
236/******************************************************************************/
249extern evxErrors cvxMsgAreaStateGet(int* action);
250
251
252//====================================================================================================================
254//====================================================================================================================
255/******************************************************************************/
271extern evxErrors cvxMsgFileLoad(const vxLongPath File, int* idFile);
272
273/******************************************************************************/
285extern char* cvxMsgPtr(int idFile, int MessageNum);
286
287/******************************************************************************/
294extern void cvxMsgDisp(char* Text);
295
296/******************************************************************************/
315extern void cvxMsgDisp2(char* Text, int level);
316
317/******************************************************************************/
358extern evxErrors cvxMessageBox(int MsgType, int WndMode, const char* Title, const char* Message,
359 const char* Btn1Str, const char* Btn2Str, int* Action);
360
361//====================================================================================================================
363//====================================================================================================================
364/******************************************************************************/
373extern evxErrors cvxLastErrGet();
374
375/******************************************************************************/
382extern void cvxLastErrSet(evxErrors error);
383
384/******************************************************************************/
394extern const char* cvxErrMsgGet(evxErrors error);
395
396
397/*
398*********************************************************************
399** END HEADER FILE
400*********************************************************************
401*/
402
403#ifdef __cplusplus
404 }
405#endif /* __cplusplus */
406
407#endif /* ZW_API_MSG_H */
cvxErrEnable
void cvxErrEnable(void)
cvxMsgAreaClose
void cvxMsgAreaClose(void)
cvxMsgAreaState
void cvxMsgAreaState(int)
cvxUserActionStatusSet2
int cvxUserActionStatusSet2(evxDialogType type, int value)
cvxUserActionStatusGet
void cvxUserActionStatusGet(int *disableStatus)
cvxMsgDisp2
void cvxMsgDisp2(char *Text, int level)
cvxLastErrGet
evxErrors cvxLastErrGet()
cvxCrashPromptEnable
void cvxCrashPromptEnable()
cvxLastWarningMsgEnable
void cvxLastWarningMsgEnable(int enable)
cvxErrMsgGet
const char * cvxErrMsgGet(evxErrors error)
cvxMsgDisp
void cvxMsgDisp(char *Text)
cvxPromptDisable
void cvxPromptDisable(void)
cvxMsgAreaStateGet
evxErrors cvxMsgAreaStateGet(int *action)
cvxMsgPtr
char * cvxMsgPtr(int idFile, int MessageNum)
cvxMsgDisable
void cvxMsgDisable(void)
cvxPromptEnable
void cvxPromptEnable(void)
evxDialogType
evxDialogType
dialog form type of user prompt
Definition: zwapi_message.h:31
VX_DIALOG_SAVE_AS
@ VX_DIALOG_SAVE_AS
dialog of saveas
Definition: zwapi_message.h:32
cvxMessageBox
evxErrors cvxMessageBox(int MsgType, int WndMode, const char *Title, const char *Message, const char *Btn1Str, const char *Btn2Str, int *Action)
cvxUserActionStatusSet
void cvxUserActionStatusSet(int disable)
cvxLastErrSet
void cvxLastErrSet(evxErrors error)
cvxTranStatusDisable
void cvxTranStatusDisable(void)
cvxErrDisable
void cvxErrDisable(void)
cvxMsgFileLoad
evxErrors cvxMsgFileLoad(const vxLongPath File, int *idFile)
cvxTranStatusEnable
void cvxTranStatusEnable(void)
cvxCrashPromptDisable
void cvxCrashPromptDisable()
cvxMsgAreaOpen
void cvxMsgAreaOpen(void)
cvxMsgEnable
void cvxMsgEnable(void)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_AT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_attribute.h
cvxPartAtGet
cvxPartAtItemDel
cvxPartAtItemDesGet
cvxPartAtItemDesSet
cvxPartAtItemGet
cvxPartAtItemGetInFile
cvxPartAtItemLockGet
cvxPartAtItemLockGetInFile
cvxPartAtItemLockSet
cvxPartAtItemLockSetInFile
cvxPartAtItemSet
cvxPartAtItemSetInFile
cvxPartAtMod
cvxPartAtSet
cvxPartCalcAttrGet
cvxPartClosePartAt
cvxPartGetCustomStr
cvxPartMassProp
cvxPartMaterialDel
cvxPartMaterialGet
cvxPartMaterialSet
cvxPartPhyAttrCalc
cvxPartSetCustomStr
cvxPartShowPartAt
cvxPartUserAtExport
cvxPartUserAtGet
cvxPartUserAtSet
cvxPartVolumAndMassGet

◆ ZW_API_PART_AT_H

#define ZW_API_PART_AT_H

Definition at line 15 of file zwapi_part_attribute.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_attribute.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_attribute.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_AT_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_AT_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
44extern evxErrors cvxPartMassProp(void);
45
46/******************************************************************************/
62extern evxErrors cvxPartCalcAttrGet(int idPart, svxPartCalcAttrData* attr);
63
64/******************************************************************************/
82extern evxErrors cvxPartPhyAttrCalc(vxRootName Name);
83
84/******************************************************************************/
102extern evxErrors cvxPartVolumAndMassGet(vxRootName Name, double* dVolume, double* dMass);
103
104/******************************************************************************/
134extern evxErrors cvxPartMaterialGet(const vxLongPath fileName,const vxRootName rootName,const vxLongName material, svxPartMaterial* data);
135
136/******************************************************************************/
169extern evxErrors cvxPartMaterialSet(const vxLongPath fileName,const vxRootName rootName,const vxLongName material, const svxPartMaterial* data);
170
171/******************************************************************************/
194extern evxErrors cvxPartMaterialDel(const vxLongPath fileName,const vxRootName rootName,const vxLongName material);
195
196
197//====================================================================================================================
199//====================================================================================================================
200/******************************************************************************/
216extern evxErrors cvxPartAtGet(vxRootName Name, svxPartAttribute* At);
217
218/******************************************************************************/
264extern evxErrors cvxPartAtMod(vxRootName Name, svxPartAttribute* At);
265
266/******************************************************************************/
300extern evxErrors cvxPartAtSet(vxRootName Name, svxPartAttribute* At);
301
302/******************************************************************************/
322extern evxErrors cvxPartShowPartAt(const vxLongPath File, const vxRootName Root);
323
324/******************************************************************************/
332extern void cvxPartClosePartAt();
333
334/******************************************************************************/
356extern evxErrors cvxPartAtItemGet(evxAtItemId itemId, svxAttribute* At);
357
358/******************************************************************************/
382extern evxErrors cvxPartAtItemSet(evxAtItemId itemId, svxAttribute* At);
383
384/******************************************************************************/
422extern evxErrors cvxPartAtItemGetInFile(const vxLongPath File,const vxRootName Root, evxAtItemId itemId, svxAttribute* At);
423
424/******************************************************************************/
463extern evxErrors cvxPartAtItemSetInFile(const vxLongPath File,const vxRootName Root, evxAtItemId itemId, svxAttribute* At);
464
465/******************************************************************************/
488extern evxErrors cvxPartAtItemDel(evxAtItemId itemId, vxLongName label);
489
490/******************************************************************************/
515extern evxErrors cvxPartAtItemDesGet(evxAtItemId itemId, char* AtLable, char* AtDes, int nBytes);
516
517/******************************************************************************/
539extern evxErrors cvxPartAtItemDesSet(evxAtItemId itemId, char* AtLable, char* AtDes);
540
541/******************************************************************************/
560extern evxErrors cvxPartAtItemLockGet(char* AtLable, evxAtItemLockStatus* AtLockState);
561
562/******************************************************************************/
581extern evxErrors cvxPartAtItemLockSet(char* AtLable, evxAtItemLockStatus AtLockState);
582
583/******************************************************************************/
618extern evxErrors cvxPartAtItemLockGetInFile(const vxLongPath File,const vxRootName Root, char* AtLable, evxAtItemLockStatus* AtLockState);
619
620/******************************************************************************/
653extern evxErrors cvxPartAtItemLockSetInFile(const vxLongPath File, const vxRootName Root, const char* AtLable, evxAtItemLockStatus AtLockState);
654
655/******************************************************************************/
691extern evxErrors cvxPartUserAtGet(const vxLongPath File,const vxRootName Root, int* Count, svxAttribute** UserAt);
692
693/******************************************************************************/
729extern evxErrors cvxPartUserAtSet(const vxLongPath File,const vxRootName Root, int DelOrgAt, int Count, svxAttribute* UserAt);
730
731/******************************************************************************/
747extern evxErrors cvxPartUserAtExport(const vxLongPath filePath);
748
749//====================================================================================================================
751//====================================================================================================================
752/******************************************************************************/
768extern evxErrors cvxPartSetCustomStr(int idEnt, const char* CustomString, int* idStr);
769
770/******************************************************************************/
789extern evxErrors cvxPartGetCustomStr(int idEnt, int* idStr, char** CustomString);
790
791
792/*
793*********************************************************************
794** END HEADER FILE
795*********************************************************************
796*/
797
798#ifdef __cplusplus
799 }
800#endif /* __cplusplus */
801
802#endif /* ZW_API_PART_AT_H */
cvxPartAtItemLockSetInFile
evxErrors cvxPartAtItemLockSetInFile(const vxLongPath File, const vxRootName Root, const char *AtLable, evxAtItemLockStatus AtLockState)
cvxPartAtItemDel
evxErrors cvxPartAtItemDel(evxAtItemId itemId, vxLongName label)
cvxPartMaterialDel
evxErrors cvxPartMaterialDel(const vxLongPath fileName, const vxRootName rootName, const vxLongName material)
cvxPartUserAtGet
evxErrors cvxPartUserAtGet(const vxLongPath File, const vxRootName Root, int *Count, svxAttribute **UserAt)
cvxPartAtItemLockGetInFile
evxErrors cvxPartAtItemLockGetInFile(const vxLongPath File, const vxRootName Root, char *AtLable, evxAtItemLockStatus *AtLockState)
cvxPartAtGet
evxErrors cvxPartAtGet(vxRootName Name, svxPartAttribute *At)
cvxPartMassProp
evxErrors cvxPartMassProp(void)
cvxPartAtSet
evxErrors cvxPartAtSet(vxRootName Name, svxPartAttribute *At)
cvxPartShowPartAt
evxErrors cvxPartShowPartAt(const vxLongPath File, const vxRootName Root)
cvxPartAtItemLockGet
evxErrors cvxPartAtItemLockGet(char *AtLable, evxAtItemLockStatus *AtLockState)
cvxPartAtItemGet
evxErrors cvxPartAtItemGet(evxAtItemId itemId, svxAttribute *At)
cvxPartAtItemSetInFile
evxErrors cvxPartAtItemSetInFile(const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
cvxPartGetCustomStr
evxErrors cvxPartGetCustomStr(int idEnt, int *idStr, char **CustomString)
cvxPartAtItemLockSet
evxErrors cvxPartAtItemLockSet(char *AtLable, evxAtItemLockStatus AtLockState)
cvxPartUserAtSet
evxErrors cvxPartUserAtSet(const vxLongPath File, const vxRootName Root, int DelOrgAt, int Count, svxAttribute *UserAt)
cvxPartUserAtExport
evxErrors cvxPartUserAtExport(const vxLongPath filePath)
cvxPartSetCustomStr
evxErrors cvxPartSetCustomStr(int idEnt, const char *CustomString, int *idStr)
cvxPartMaterialGet
evxErrors cvxPartMaterialGet(const vxLongPath fileName, const vxRootName rootName, const vxLongName material, svxPartMaterial *data)
cvxPartAtItemSet
evxErrors cvxPartAtItemSet(evxAtItemId itemId, svxAttribute *At)
cvxPartPhyAttrCalc
evxErrors cvxPartPhyAttrCalc(vxRootName Name)
cvxPartCalcAttrGet
evxErrors cvxPartCalcAttrGet(int idPart, svxPartCalcAttrData *attr)
cvxPartAtItemDesGet
evxErrors cvxPartAtItemDesGet(evxAtItemId itemId, char *AtLable, char *AtDes, int nBytes)
cvxPartMaterialSet
evxErrors cvxPartMaterialSet(const vxLongPath fileName, const vxRootName rootName, const vxLongName material, const svxPartMaterial *data)
cvxPartAtMod
evxErrors cvxPartAtMod(vxRootName Name, svxPartAttribute *At)
cvxPartVolumAndMassGet
evxErrors cvxPartVolumAndMassGet(vxRootName Name, double *dVolume, double *dMass)
cvxPartAtItemDesSet
evxErrors cvxPartAtItemDesSet(evxAtItemId itemId, char *AtLable, char *AtDes)
cvxPartClosePartAt
void cvxPartClosePartAt()
cvxPartAtItemGetInFile
evxErrors cvxPartAtItemGetInFile(const vxLongPath File, const vxRootName Root, evxAtItemId itemId, svxAttribute *At)
evxAtItemLockStatus
evxAtItemLockStatus
Locking state of attribute item.
Definition: zwapi_part_data.h:77
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxPartAttribute
part attribute structure
Definition: zwapi_util.h:1386
svxPartCalcAttrData
part physical attributes data
Definition: zwapi_part_data.h:51
svxPartMaterial
Part material physical attributes.
Definition: zwapi_part_data.h:67
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_CONFIG_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_config.h
cvxCfgTblInfosSet
cvxPartCfgActivate
cvxPartCfgTblAdd
cvxPartCfgTblAttrSet
cvxPartCfgTblColorSet
cvxPartCfgTblInstNameSet
cvxPartCfgTblVarsSet
cvxPartFreeCfgTbl
cvxPartInqActiveCfg
cvxPartInqActiveCfgByName
cvxPartInqCfgList
cvxPartInqCfgListByName
cvxPartInqCfgTblInfos
cvxPartInqCfgTblInfosByName

◆ ZW_API_PART_CONFIG_H

#define ZW_API_PART_CONFIG_H

Definition at line 15 of file zwapi_part_config.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_config.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_config.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_CONFIG_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_CONFIG_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
48extern evxErrors cvxPartCfgTblAdd(vxName cfgName, char* cfgDes, int* idCfg);
49
50/******************************************************************************/
65extern evxErrors cvxPartCfgActivate(int idCfg);
66
67/******************************************************************************/
83extern evxErrors cvxPartInqActiveCfg(int* idCfg);
84
85/******************************************************************************/
104extern evxErrors cvxPartInqActiveCfgByName(const vxLongPath fileName, const vxRootName rootName, int* idCfg);
105
106
107//====================================================================================================================
109//====================================================================================================================
110/******************************************************************************/
129extern evxErrors cvxPartInqCfgList(int* Count, int** CfgList);
130
131/******************************************************************************/
154extern evxErrors cvxPartInqCfgListByName(const vxLongPath fileName, const vxRootName rootName, int* count, int** cfgList);
155
156
157//====================================================================================================================
159//====================================================================================================================
160/******************************************************************************/
188extern evxErrors cvxCfgTblInfosSet(int idCfg, svxPartCfgInfo* info);
189
190/******************************************************************************/
212extern evxErrors cvxPartInqCfgTblInfos(int idCfg, svxPartCfgInfo** partCfg);
213
214/******************************************************************************/
238extern evxErrors cvxPartInqCfgTblInfosByName(const vxLongPath fileName, const vxRootName rootName, int idCfg, svxPartCfgInfo** partCfg);
239
240/******************************************************************************/
252extern void cvxPartFreeCfgTbl(svxPartCfgInfo** cfginfo);
253
254/******************************************************************************/
284extern evxErrors cvxPartCfgTblAttrSet(int markDel, int idCfg, int cnt, evxAtItemId* types, svxAttribute* attrs);
285
286/******************************************************************************/
306extern evxErrors cvxPartCfgTblColorSet(int markDelClr, int idCfg, svxColor color);
307
308/******************************************************************************/
327extern evxErrors cvxPartCfgTblInstNameSet(int markDelInstName, int idCfg, vxLongName instanceName);
328
329/******************************************************************************/
352extern evxErrors cvxPartCfgTblVarsSet(int markDelVars, int idCfg, int cnt, svxVariable* vars);
353
354/*
355*********************************************************************
356** END HEADER FILE
357*********************************************************************
358*/
359
360#ifdef __cplusplus
361 }
362#endif /* __cplusplus */
363
364#endif /* ZW_API_PART_CONFIG_H */
cvxPartInqCfgList
evxErrors cvxPartInqCfgList(int *Count, int **CfgList)
cvxPartCfgTblVarsSet
evxErrors cvxPartCfgTblVarsSet(int markDelVars, int idCfg, int cnt, svxVariable *vars)
cvxPartCfgTblColorSet
evxErrors cvxPartCfgTblColorSet(int markDelClr, int idCfg, svxColor color)
cvxPartCfgActivate
evxErrors cvxPartCfgActivate(int idCfg)
cvxPartFreeCfgTbl
void cvxPartFreeCfgTbl(svxPartCfgInfo **cfginfo)
cvxPartInqActiveCfg
evxErrors cvxPartInqActiveCfg(int *idCfg)
cvxPartCfgTblAdd
evxErrors cvxPartCfgTblAdd(vxName cfgName, char *cfgDes, int *idCfg)
cvxPartInqCfgTblInfosByName
evxErrors cvxPartInqCfgTblInfosByName(const vxLongPath fileName, const vxRootName rootName, int idCfg, svxPartCfgInfo **partCfg)
cvxPartInqCfgTblInfos
evxErrors cvxPartInqCfgTblInfos(int idCfg, svxPartCfgInfo **partCfg)
cvxPartCfgTblAttrSet
evxErrors cvxPartCfgTblAttrSet(int markDel, int idCfg, int cnt, evxAtItemId *types, svxAttribute *attrs)
cvxCfgTblInfosSet
evxErrors cvxCfgTblInfosSet(int idCfg, svxPartCfgInfo *info)
cvxPartInqActiveCfgByName
evxErrors cvxPartInqActiveCfgByName(const vxLongPath fileName, const vxRootName rootName, int *idCfg)
cvxPartInqCfgListByName
evxErrors cvxPartInqCfgListByName(const vxLongPath fileName, const vxRootName rootName, int *count, int **cfgList)
cvxPartCfgTblInstNameSet
evxErrors cvxPartCfgTblInstNameSet(int markDelInstName, int idCfg, vxLongName instanceName)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxPartCfgInfo
config table infos
Definition: zwapi_part_data.h:181
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_data_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_data.h
evxAtItemLockStatus
evxAtItemLockStatus
evxBlockType
evxBlockType
evxCfgTblMethod
evxCfgTblMethod
evxCfgThreadCmd
evxCfgThreadCmd
evxFtrRegenStatus
evxFtrRegenStatus
evxPlaneType
evxPlaneType
evxPMIEntType
evxPMIEntType
evxRefineFacetsTolType
evxRefineFacetsTolType
evxSmdSurfaceType
evxSmdSurfaceType
svxCf
svxEdgeDispData
svxPartCalcAttrData
svxPartCfgInfo
svxPartMaterial
svxRefineFacets
svxSTL

◆ zwapi_part_data_H

#define zwapi_part_data_H

Definition at line 17 of file zwapi_part_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef zwapi_part_data_H /* this ifndef surrounds entire header */
17#define zwapi_part_data_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxFtrRegenStatus
33 {
34 VX_FTR_REGEN_DEFAULT,
35 VX_FTR_REGEN_LINK_LOST,
36 VX_FTR_REGEN_PARTIAL_INP_LOST,
37 VX_FTR_REGEN_VAR_LOST,
38 VX_FTR_REGEN_ENT_LOST,
39 VX_FTR_REGEN_OVER_CONSTRAINT,
40 VX_FTR_REGEN_UNDER_CONSTRAINT,
41 } evxFtrRegenStatus;
42
43//====================================================================================================================
45//====================================================================================================================
50typedef struct svxPartCalcAttrData
51 {
52 double Length;
53 double Width;
54 double Height;
55 double Volume;
56 double Area;
57 double Mass;
58 double Density;
59 svxPoint Centroid;
60 }svxPartCalcAttrData;
61
66typedef struct svxPartMaterial
67 {
68 /* At present,there is only on property of material density. */
69 double density;
70 } svxPartMaterial;
71
76typedef enum evxAtItemLockStatus
77 {
78 VX_AT_ITEM_UNLOCKED = 0,
79 VX_AT_ITEM_LOCKED,
80 VX_AT_ITEM_LIMITED,
81 } evxAtItemLockStatus;
82
83//====================================================================================================================
85//====================================================================================================================
90typedef struct svxSTL
91 {
92 char* name;
93 int nFacet;
94 svxTriangle* facets;
107 double dTol;
108 } svxSTL;
109
114typedef enum evxBlockType
115 {
116 VX_BLOCK_UNDEFINED = 0,
117 VX_BLOCK_FACETS = 1,
118 VX_BLOCK_POINTS = 2
119 } evxBlockType;
120
125typedef enum evxRefineFacetsTolType
126 {
127 VX_FACETS_TOL_PIXEL,
128 VX_FACETS_TOL_DISTANCE,
129 VX_FACETS_TOL_ANGLE,
130 } evxRefineFacetsTolType;
131
136typedef struct svxRefineFacets
137 {
138 int idFace;
139 evxRefineFacetsTolType type;
141 double edgeTol;
142 double facetTol;
143 double angleTol;
144 } svxRefineFacets;
145
146//====================================================================================================================
148//====================================================================================================================
153typedef enum evxCfgThreadCmd
154 {
155 VX_NO_CMD = 0,
156 VX_FTHOLEMAIN = 1,
157 VX_FTTWKHOLE = 2,
158 VX_FTASSEMHOLE = 3,
159 VX_FTHOLEASGN = 4,
160 VX_CDHOLEPLUG = 5,
161 VX_CDTHRDADD = 6,
162 }evxCfgThreadCmd;
163
168typedef struct svxCf
169 {
170 double value;
171 vxName name;
172 evxNumType klass;
173 unsigned char id;
174 }svxCf;
175
180typedef struct svxPartCfgInfo
181 {
182 vxName ConfigName;
183 int CfgIdx;
184 int ConfigId;
185 svxColor colorval;
186 int fCfged;
188 struct svxRegenObjs
189 {
190 int idx;
191 int suppressed;
192 vxName expr;
193 } *RegenObjs;
194 int CntRO;
196 struct svxFtrDimensions
197 {
198 svxUid uid;
199 int DataId;
200 int DimIdx;
201 int fAssm;
202 vxName value;
203 svxCf unit;
204 int ftr;
205 } *FtrDim;
206 int CntFD;
208 struct svxProfDimensions
209 {
210 int DimIdx;
211 vxName value;
212 svxCf unit;
213 } *ProfDim;
214 int CntPD;
216 struct svxVariables
217 {
218 int EqIdx;
219 char type;
220 vxName value;
221 svxCf unit;
222 } *var;
223 int CntVar;
225 struct svxAttributes
226 {
227 int AttrIdx;
228 evxAtItemId itemId;
229 char type;
230 char SubType;
231 double dvalue;
232 vxLongName expr;
233 int fCfged;
234 int fUserDefined;
235 svxCf unit;
236 } *attr;
237 int CntAttr;
239 struct svxComponents
240 {
241 int CompIdx;
242 int suppressed;
243 vxName expr;
244 int PartStateId;
245 vxName CfgName;
246 svxColor color;
247 int fCfged;
248 } *comp;
249 int CntComp;
251 struct svxThreads
252 {
253 svxUid uid;
254 int FtrIdx;
255 evxCfgThreadCmd fCmd;
256 vxName threadType;
257 vxName threadsize;
258 vxName threadDia;
259 vxName pitch;
260 vxName threadUnit;
261 } *threads;
262 int CntThreads;
264 struct svxThreadDeps
265 {
266 svxUid uid;
267 int FtrIdx;
268 evxCfgThreadCmd fCmd;
269 int deptype;
270 vxName depth;
271 } *ThreadDeps;
272 int CntTD;
274 struct svxAligns
275 {
276 int AlignIdx;
277 int suppressed;
278 vxName expr;
279 } *align;
280 int CntAlign;
282 struct svxAlignValue
283 {
284 int AlignIdx;
285 svxUid uid;
286 int DataId;
287 vxName ValValue;
288 svxCf unit;
289 } *AlignValue;
290 int CntAV;
292 struct svxFtrVdataVal
293 {
294 svxUid uid;
295 int DataId;
296 int idx_ftr;
297 int fAssm;
298 vxName value;
299 int ftr;
300 svxCf unit;
301 } *FtrVdataValue;
302 int CntFVV;
304 /* outside defined infos */
305 struct svxOutDefVal
306 {
307 vxName key;
308 vxName value;
309 } *OutDefVal;
310 int CntODV;
312 int* RegenObjsFailed;
313 int CntROF;
314 } svxPartCfgInfo;
315
320typedef enum evxCfgTblMethod
321 {
322 VX_CFGTBL_MEHTOD_FTR,
323 VX_CFGTBL_MEHTOD_FTRDIM,
324 VX_CFGTBL_MEHTOD_FTRVDATA,
325 VX_CFGTBL_MEHTOD_PROFDIM,
326 VX_CFGTBL_MEHTOD_VAR,
327 VX_CFGTBL_MEHTOD_ATTR,
328 VX_CFGTBL_MEHTOD_PARTCOLOR,
329 VX_CFGTBL_MEHTOD_THREAD,
330 VX_CFGTBL_MEHTOD_THREADDEP,
331 VX_CFGTBL_MEHTOD_COMPPARTCFG,
332 VX_CFGTBL_MEHTOD_COMPSUPP,
333 VX_CFGTBL_MEHTOD_COMPCOLOR,
334 VX_CFGTBL_MEHTOD_ALIGNSUPP,
335 VX_CFGTBL_MEHTOD_ALIGNVALUE,
336 } evxCfgTblMethod;
337
342typedef enum evxPMIEntType
343 {
344 VX_PMI_ALL = 0x0000,
345 VX_PMI_DIM = 0x0001,
346 VX_PMI_NOTE = 0x0002,
347 VX_PMI_DTMF = 0x0004,
348 VX_PMI_DTMT = 0x0008,
349 VX_PMI_FCS = 0x0010,
350 VX_PMI_CLCM = 0x0020,
351 VX_PMI_SYMSRF = 0x0040,
352 VX_PMI_SYMWELD = 0x0080,
353 VX_PMI_TABLE = 0x0100,
354 VX_PMI_SYMBLK = 0x0200
355 } evxPMIEntType;
356
357//====================================================================================================================
359//====================================================================================================================
364typedef enum evxSmdSurfaceType
365 {
366 VX_SMD_SURF_NONE,
367 VX_SMD_SURF_OTHER,
368 VX_SMD_SURF_SIDE,
369 VX_SMD_SURF_FLANGE_STAT,
370 VX_SMD_SURF_FLANGE_STAT_PAIR,
371 } evxSmdSurfaceType;
372
373//====================================================================================================================
375//====================================================================================================================
380typedef struct svxEdgeDispData
381 {
382 int wireCnt;
383 svxPoint* wireDispData;
384 int shadeCnt1;
385 svxPoint* shadeDispData1;
387 int shadeCnt2;
388 svxPoint* shadeDispData2;
390 } svxEdgeDispData;
391
392//====================================================================================================================
394//====================================================================================================================
399typedef enum evxPlaneType
400 {
401 VX_PLANE_TYPE_XY = 1,
402 VX_PLANE_TYPE_YZ = 2,
403 VX_PLANE_TYPE_XZ = 3
404 } evxPlaneType;
405
406/*
407*********************************************************************
408** END HEADER FILE
409*********************************************************************
410*/
411
412#ifdef __cplusplus
413 }
414#endif /* __cplusplus */
415
416#endif /* zwapi_part_data_H */
evxPlaneType
evxPlaneType
type of plane
Definition: zwapi_part_data.h:400
evxAtItemLockStatus
evxAtItemLockStatus
Locking state of attribute item.
Definition: zwapi_part_data.h:77
VX_AT_ITEM_UNLOCKED
@ VX_AT_ITEM_UNLOCKED
attribute item unlocked
Definition: zwapi_part_data.h:78
VX_AT_ITEM_LIMITED
@ VX_AT_ITEM_LIMITED
lock attribute item but not value
Definition: zwapi_part_data.h:80
VX_AT_ITEM_LOCKED
@ VX_AT_ITEM_LOCKED
lock attribute item and value
Definition: zwapi_part_data.h:79
evxBlockType
evxBlockType
3D Block Type
Definition: zwapi_part_data.h:115
VX_BLOCK_FACETS
@ VX_BLOCK_FACETS
block of 3D triangular facets
Definition: zwapi_part_data.h:117
VX_BLOCK_POINTS
@ VX_BLOCK_POINTS
block of 3D points (i.e. point cloud)
Definition: zwapi_part_data.h:118
VX_BLOCK_UNDEFINED
@ VX_BLOCK_UNDEFINED
undefined 3D block type
Definition: zwapi_part_data.h:116
evxPMIEntType
evxPMIEntType
PMI entity type.
Definition: zwapi_part_data.h:343
VX_PMI_FCS
@ VX_PMI_FCS
feature control symbol
Definition: zwapi_part_data.h:349
VX_PMI_DIM
@ VX_PMI_DIM
dimension
Definition: zwapi_part_data.h:345
VX_PMI_SYMWELD
@ VX_PMI_SYMWELD
symbol WELD
Definition: zwapi_part_data.h:352
VX_PMI_DTMF
@ VX_PMI_DTMF
datum feature
Definition: zwapi_part_data.h:347
VX_PMI_DTMT
@ VX_PMI_DTMT
datum target
Definition: zwapi_part_data.h:348
VX_PMI_NOTE
@ VX_PMI_NOTE
note
Definition: zwapi_part_data.h:346
VX_PMI_CLCM
@ VX_PMI_CLCM
center mark and centerline
Definition: zwapi_part_data.h:350
VX_PMI_SYMBLK
@ VX_PMI_SYMBLK
symbol block
Definition: zwapi_part_data.h:354
VX_PMI_TABLE
@ VX_PMI_TABLE
PMI table.
Definition: zwapi_part_data.h:353
VX_PMI_ALL
@ VX_PMI_ALL
all type
Definition: zwapi_part_data.h:344
VX_PMI_SYMSRF
@ VX_PMI_SYMSRF
symbol surface
Definition: zwapi_part_data.h:351
evxCfgTblMethod
evxCfgTblMethod
configuration item method
Definition: zwapi_part_data.h:321
VX_CFGTBL_MEHTOD_THREADDEP
@ VX_CFGTBL_MEHTOD_THREADDEP
thread depth
Definition: zwapi_part_data.h:330
VX_CFGTBL_MEHTOD_COMPCOLOR
@ VX_CFGTBL_MEHTOD_COMPCOLOR
component color
Definition: zwapi_part_data.h:333
VX_CFGTBL_MEHTOD_PROFDIM
@ VX_CFGTBL_MEHTOD_PROFDIM
profile dimension
Definition: zwapi_part_data.h:325
VX_CFGTBL_MEHTOD_THREAD
@ VX_CFGTBL_MEHTOD_THREAD
thread
Definition: zwapi_part_data.h:329
VX_CFGTBL_MEHTOD_COMPSUPP
@ VX_CFGTBL_MEHTOD_COMPSUPP
suppress of component
Definition: zwapi_part_data.h:332
VX_CFGTBL_MEHTOD_FTRDIM
@ VX_CFGTBL_MEHTOD_FTRDIM
feature dimension
Definition: zwapi_part_data.h:323
VX_CFGTBL_MEHTOD_FTR
@ VX_CFGTBL_MEHTOD_FTR
feature
Definition: zwapi_part_data.h:322
VX_CFGTBL_MEHTOD_COMPPARTCFG
@ VX_CFGTBL_MEHTOD_COMPPARTCFG
part config of the component
Definition: zwapi_part_data.h:331
VX_CFGTBL_MEHTOD_FTRVDATA
@ VX_CFGTBL_MEHTOD_FTRVDATA
feature vdata
Definition: zwapi_part_data.h:324
VX_CFGTBL_MEHTOD_PARTCOLOR
@ VX_CFGTBL_MEHTOD_PARTCOLOR
part color
Definition: zwapi_part_data.h:328
VX_CFGTBL_MEHTOD_ATTR
@ VX_CFGTBL_MEHTOD_ATTR
attribute
Definition: zwapi_part_data.h:327
VX_CFGTBL_MEHTOD_ALIGNVALUE
@ VX_CFGTBL_MEHTOD_ALIGNVALUE
align value
Definition: zwapi_part_data.h:335
VX_CFGTBL_MEHTOD_VAR
@ VX_CFGTBL_MEHTOD_VAR
variable
Definition: zwapi_part_data.h:326
VX_CFGTBL_MEHTOD_ALIGNSUPP
@ VX_CFGTBL_MEHTOD_ALIGNSUPP
align suppress
Definition: zwapi_part_data.h:334
evxCfgThreadCmd
evxCfgThreadCmd
Hole type.
Definition: zwapi_part_data.h:154
VX_FTHOLEASGN
@ VX_FTHOLEASGN
puts a feature into the active part's history to identify a hole from selected geometry
Definition: zwapi_part_data.h:159
VX_CDHOLEPLUG
@ VX_CDHOLEPLUG
Create new holes centered in existing holes.
Definition: zwapi_part_data.h:160
VX_FTASSEMHOLE
@ VX_FTASSEMHOLE
Create hole in assembly.
Definition: zwapi_part_data.h:158
VX_FTHOLEMAIN
@ VX_FTHOLEMAIN
Create holes.
Definition: zwapi_part_data.h:156
VX_NO_CMD
@ VX_NO_CMD
null
Definition: zwapi_part_data.h:155
VX_FTTWKHOLE
@ VX_FTTWKHOLE
Change the parameters of a hole without a history regen whether or not the hole is a native ZW3D feat...
Definition: zwapi_part_data.h:157
VX_CDTHRDADD
@ VX_CDTHRDADD
Add multiple/single thread attribute to cylindrical face.
Definition: zwapi_part_data.h:161
evxRefineFacetsTolType
evxRefineFacetsTolType
tolerance type of refine facets
Definition: zwapi_part_data.h:126
VX_FACETS_TOL_PIXEL
@ VX_FACETS_TOL_PIXEL
pixel
Definition: zwapi_part_data.h:127
VX_FACETS_TOL_ANGLE
@ VX_FACETS_TOL_ANGLE
angle
Definition: zwapi_part_data.h:129
VX_FACETS_TOL_DISTANCE
@ VX_FACETS_TOL_DISTANCE
distance
Definition: zwapi_part_data.h:128
evxSmdSurfaceType
evxSmdSurfaceType
Sheet Metal surface type.
Definition: zwapi_part_data.h:365
VX_SMD_SURF_FLANGE_STAT
@ VX_SMD_SURF_FLANGE_STAT
flange face on one side of stationary face
Definition: zwapi_part_data.h:369
VX_SMD_SURF_FLANGE_STAT_PAIR
@ VX_SMD_SURF_FLANGE_STAT_PAIR
the flange face of the opposite side of the stationary face
Definition: zwapi_part_data.h:370
VX_SMD_SURF_SIDE
@ VX_SMD_SURF_SIDE
side of sheet metal
Definition: zwapi_part_data.h:368
VX_SMD_SURF_NONE
@ VX_SMD_SURF_NONE
undefined
Definition: zwapi_part_data.h:366
VX_SMD_SURF_OTHER
@ VX_SMD_SURF_OTHER
other type
Definition: zwapi_part_data.h:367
evxFtrRegenStatus
evxFtrRegenStatus
regen status of feature
Definition: zwapi_part_data.h:33
VX_FTR_REGEN_DEFAULT
@ VX_FTR_REGEN_DEFAULT
default value
Definition: zwapi_part_data.h:34
VX_FTR_REGEN_ENT_LOST
@ VX_FTR_REGEN_ENT_LOST
weak association entity reference data is lost.
Definition: zwapi_part_data.h:38
VX_FTR_REGEN_VAR_LOST
@ VX_FTR_REGEN_VAR_LOST
variable data loss.
Definition: zwapi_part_data.h:37
VX_FTR_REGEN_OVER_CONSTRAINT
@ VX_FTR_REGEN_OVER_CONSTRAINT
over constrain(mainly the constraints in the sketch)
Definition: zwapi_part_data.h:39
VX_FTR_REGEN_UNDER_CONSTRAINT
@ VX_FTR_REGEN_UNDER_CONSTRAINT
under constrain(mainly the constraints in the sketch)
Definition: zwapi_part_data.h:40
VX_FTR_REGEN_PARTIAL_INP_LOST
@ VX_FTR_REGEN_PARTIAL_INP_LOST
some strong correlation input data is lost.
Definition: zwapi_part_data.h:36
VX_FTR_REGEN_LINK_LOST
@ VX_FTR_REGEN_LINK_LOST
weak association data loss.
Definition: zwapi_part_data.h:35
svxPartMaterial
struct svxPartMaterial svxPartMaterial
Part material physical attributes.
svxPartCfgInfo
struct svxPartCfgInfo svxPartCfgInfo
config table infos
svxSTL
struct svxSTL svxSTL
3D STL facets
svxCf
struct svxCf svxCf
conversion factor
svxEdgeDispData
struct svxEdgeDispData svxEdgeDispData
edge display data
svxPartCalcAttrData
struct svxPartCalcAttrData svxPartCalcAttrData
part physical attributes data
svxRefineFacets
struct svxRefineFacets svxRefineFacets
refine facets data
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
evxNumType
evxNumType
numeric input data types
Definition: zwapi_util.h:1496
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCf::klass
evxNumType klass
class
Definition: zwapi_part_data.h:172
svxCf::name
vxName name
name (null-terminated string)
Definition: zwapi_part_data.h:171
svxCf::value
double value
value
Definition: zwapi_part_data.h:170
svxCf::id
unsigned char id
unique id ( see evxUnitType , evxAngUnitType and evxMassUnitType)
Definition: zwapi_part_data.h:173
svxCf
conversion factor
Definition: zwapi_part_data.h:169
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxEdgeDispData::shadeDispData2
svxPoint * shadeDispData2
display data2 of shade. This is the display data of the other of the two faces adjacent to the edge o...
Definition: zwapi_part_data.h:388
svxEdgeDispData::wireDispData
svxPoint * wireDispData
display data of wireframe
Definition: zwapi_part_data.h:383
svxEdgeDispData::shadeCnt2
int shadeCnt2
count of shadeDispData2
Definition: zwapi_part_data.h:387
svxEdgeDispData::wireCnt
int wireCnt
count of wireDispData
Definition: zwapi_part_data.h:382
svxEdgeDispData::shadeCnt1
int shadeCnt1
count of shadeDispData1
Definition: zwapi_part_data.h:384
svxEdgeDispData::shadeDispData1
svxPoint * shadeDispData1
display data1 of shade. This is the display data of one of the two faces adjacent to the edge on the ...
Definition: zwapi_part_data.h:385
svxEdgeDispData
edge display data
Definition: zwapi_part_data.h:381
svxPartCalcAttrData::Volume
double Volume
volume of part
Definition: zwapi_part_data.h:55
svxPartCalcAttrData::Area
double Area
surface area of part
Definition: zwapi_part_data.h:56
svxPartCalcAttrData::Centroid
svxPoint Centroid
center of gravity of part
Definition: zwapi_part_data.h:59
svxPartCalcAttrData::Width
double Width
width of part
Definition: zwapi_part_data.h:53
svxPartCalcAttrData::Mass
double Mass
mass of part
Definition: zwapi_part_data.h:57
svxPartCalcAttrData::Height
double Height
hight of part
Definition: zwapi_part_data.h:54
svxPartCalcAttrData::Density
double Density
density of part(kg/mm3)
Definition: zwapi_part_data.h:58
svxPartCalcAttrData::Length
double Length
length of part
Definition: zwapi_part_data.h:52
svxPartCalcAttrData
part physical attributes data
Definition: zwapi_part_data.h:51
svxPartCfgInfo::svxAlignValue::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:288
svxPartCfgInfo::svxAlignValue::AlignIdx
int AlignIdx
index of component
Definition: zwapi_part_data.h:284
svxPartCfgInfo::svxAlignValue::DataId
int DataId
the value's data id in the feature
Definition: zwapi_part_data.h:286
svxPartCfgInfo::svxAlignValue::ValValue
vxName ValValue
value of align
Definition: zwapi_part_data.h:287
svxPartCfgInfo::svxAlignValue::uid
svxUid uid
feature uid of the dimension
Definition: zwapi_part_data.h:285
svxPartCfgInfo::svxAlignValue
constraint value infos
Definition: zwapi_part_data.h:283
svxPartCfgInfo::svxAligns::AlignIdx
int AlignIdx
index of component
Definition: zwapi_part_data.h:276
svxPartCfgInfo::svxAligns::suppressed
int suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed.
Definition: zwapi_part_data.h:277
svxPartCfgInfo::svxAligns::expr
vxName expr
expression of align
Definition: zwapi_part_data.h:278
svxPartCfgInfo::svxAligns
constraint of component or assembly infos
Definition: zwapi_part_data.h:275
svxPartCfgInfo::svxAttributes::fCfged
int fCfged
0 if undefined
Definition: zwapi_part_data.h:233
svxPartCfgInfo::svxAttributes::fUserDefined
int fUserDefined
1 if the value is user defined, else 0, only used for calculated attributes
Definition: zwapi_part_data.h:234
svxPartCfgInfo::svxAttributes::AttrIdx
int AttrIdx
index of Attributes
Definition: zwapi_part_data.h:227
svxPartCfgInfo::svxAttributes::dvalue
double dvalue
0 if undefined
Definition: zwapi_part_data.h:231
svxPartCfgInfo::svxAttributes::SubType
char SubType
subtype of Attributes
Definition: zwapi_part_data.h:230
svxPartCfgInfo::svxAttributes::type
char type
type of Attributes
Definition: zwapi_part_data.h:229
svxPartCfgInfo::svxAttributes::expr
vxLongName expr
the expression of condition suppressed
Definition: zwapi_part_data.h:232
svxPartCfgInfo::svxAttributes::itemId
evxAtItemId itemId
The standard id of the part attribute item.
Definition: zwapi_part_data.h:228
svxPartCfgInfo::svxAttributes::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:235
svxPartCfgInfo::svxAttributes
attribute properties infos
Definition: zwapi_part_data.h:226
svxPartCfgInfo::svxComponents::color
svxColor color
color of components
Definition: zwapi_part_data.h:246
svxPartCfgInfo::svxComponents::CfgName
vxName CfgName
the CfgName, alway is empty
Definition: zwapi_part_data.h:245
svxPartCfgInfo::svxComponents::CompIdx
int CompIdx
index of component
Definition: zwapi_part_data.h:241
svxPartCfgInfo::svxComponents::fCfged
int fCfged
1 if color exist,else 0
Definition: zwapi_part_data.h:247
svxPartCfgInfo::svxComponents::suppressed
int suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed.
Definition: zwapi_part_data.h:242
svxPartCfgInfo::svxComponents::expr
vxName expr
the expression of condition suppressed
Definition: zwapi_part_data.h:243
svxPartCfgInfo::svxComponents::PartStateId
int PartStateId
-1 if undefined
Definition: zwapi_part_data.h:244
svxPartCfgInfo::svxComponents
component infos
Definition: zwapi_part_data.h:240
svxPartCfgInfo::svxFtrDimensions::DimIdx
int DimIdx
index of dimension
Definition: zwapi_part_data.h:200
svxPartCfgInfo::svxFtrDimensions::fAssm
int fAssm
1,the dimension should be in assembly tree
Definition: zwapi_part_data.h:201
svxPartCfgInfo::svxFtrDimensions::DataId
int DataId
dimension's data id in the feature
Definition: zwapi_part_data.h:199
svxPartCfgInfo::svxFtrDimensions::ftr
int ftr
auxiliary data
Definition: zwapi_part_data.h:204
svxPartCfgInfo::svxFtrDimensions::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:203
svxPartCfgInfo::svxFtrDimensions::value
vxName value
value of the dimension
Definition: zwapi_part_data.h:202
svxPartCfgInfo::svxFtrDimensions::uid
svxUid uid
feature uid of the dimension
Definition: zwapi_part_data.h:198
svxPartCfgInfo::svxFtrDimensions
feature dimension infos
Definition: zwapi_part_data.h:197
svxPartCfgInfo::svxFtrVdataVal::fAssm
int fAssm
1, the feature is a assembly feature
Definition: zwapi_part_data.h:297
svxPartCfgInfo::svxFtrVdataVal::DataId
int DataId
data id in the feature
Definition: zwapi_part_data.h:295
svxPartCfgInfo::svxFtrVdataVal::value
vxName value
value of feature
Definition: zwapi_part_data.h:298
svxPartCfgInfo::svxFtrVdataVal::uid
svxUid uid
feature uid of the vdata
Definition: zwapi_part_data.h:294
svxPartCfgInfo::svxFtrVdataVal::idx_ftr
int idx_ftr
index of feature
Definition: zwapi_part_data.h:296
svxPartCfgInfo::svxFtrVdataVal::ftr
int ftr
auxiliary data
Definition: zwapi_part_data.h:299
svxPartCfgInfo::svxFtrVdataVal::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:300
svxPartCfgInfo::svxFtrVdataVal
feature's vdata infos
Definition: zwapi_part_data.h:293
svxPartCfgInfo::svxOutDefVal::key
vxName key
key of outside defined value
Definition: zwapi_part_data.h:307
svxPartCfgInfo::svxOutDefVal::value
vxName value
value of outside defined value
Definition: zwapi_part_data.h:308
svxPartCfgInfo::svxOutDefVal
variables preceded by "*" are not used to drive the seed part
Definition: zwapi_part_data.h:306
svxPartCfgInfo::svxProfDimensions::DimIdx
int DimIdx
index of dimension
Definition: zwapi_part_data.h:210
svxPartCfgInfo::svxProfDimensions::value
vxName value
value of dimension
Definition: zwapi_part_data.h:211
svxPartCfgInfo::svxProfDimensions::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:212
svxPartCfgInfo::svxProfDimensions
profile dimension infos
Definition: zwapi_part_data.h:209
svxPartCfgInfo::svxRegenObjs::expr
vxName expr
the expression of condition suppressed
Definition: zwapi_part_data.h:192
svxPartCfgInfo::svxRegenObjs::idx
int idx
index of regenerate object
Definition: zwapi_part_data.h:190
svxPartCfgInfo::svxRegenObjs::suppressed
int suppressed
-1 if undefined.0 is unsuppressed, 1 is suppressed.
Definition: zwapi_part_data.h:191
svxPartCfgInfo::svxRegenObjs
regen object infos
Definition: zwapi_part_data.h:189
svxPartCfgInfo::svxThreadDeps::FtrIdx
int FtrIdx
index of feature
Definition: zwapi_part_data.h:267
svxPartCfgInfo::svxThreadDeps::fCmd
evxCfgThreadCmd fCmd
1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD
Definition: zwapi_part_data.h:268
svxPartCfgInfo::svxThreadDeps::depth
vxName depth
depth of thread
Definition: zwapi_part_data.h:270
svxPartCfgInfo::svxThreadDeps::deptype
int deptype
depth type of thread
Definition: zwapi_part_data.h:269
svxPartCfgInfo::svxThreadDeps::uid
svxUid uid
feature uid of the dimension
Definition: zwapi_part_data.h:266
svxPartCfgInfo::svxThreadDeps
thread depth infos
Definition: zwapi_part_data.h:265
svxPartCfgInfo::svxThreads::FtrIdx
int FtrIdx
index of feature
Definition: zwapi_part_data.h:254
svxPartCfgInfo::svxThreads::threadType
vxName threadType
thread Type
Definition: zwapi_part_data.h:256
svxPartCfgInfo::svxThreads::fCmd
evxCfgThreadCmd fCmd
1: FTHOLEMAIN, 2: FTTWKHOLE, 3: FTASSEMHOLE, 4: FTHOLEASGN, 5: CDHOLEPLUG, 6:CDTHRDADD
Definition: zwapi_part_data.h:255
svxPartCfgInfo::svxThreads::pitch
vxName pitch
pitch
Definition: zwapi_part_data.h:259
svxPartCfgInfo::svxThreads::uid
svxUid uid
feature uid of the dimension
Definition: zwapi_part_data.h:253
svxPartCfgInfo::svxThreads::threadUnit
vxName threadUnit
Thread Unit.
Definition: zwapi_part_data.h:260
svxPartCfgInfo::svxThreads::threadsize
vxName threadsize
thread size
Definition: zwapi_part_data.h:257
svxPartCfgInfo::svxThreads::threadDia
vxName threadDia
thread Diameter
Definition: zwapi_part_data.h:258
svxPartCfgInfo::svxThreads
thread infos
Definition: zwapi_part_data.h:252
svxPartCfgInfo::svxVariables::EqIdx
int EqIdx
index of Variables
Definition: zwapi_part_data.h:218
svxPartCfgInfo::svxVariables::type
char type
type of Variables
Definition: zwapi_part_data.h:219
svxPartCfgInfo::svxVariables::value
vxName value
value of Variables
Definition: zwapi_part_data.h:220
svxPartCfgInfo::svxVariables::unit
svxCf unit
unit for value
Definition: zwapi_part_data.h:221
svxPartCfgInfo::svxVariables
equation manager infos
Definition: zwapi_part_data.h:217
svxPartCfgInfo::CntAttr
int CntAttr
numbers of "attr"
Definition: zwapi_part_data.h:237
svxPartCfgInfo::colorval
svxColor colorval
color of attributes or config table
Definition: zwapi_part_data.h:185
svxPartCfgInfo::CntFVV
int CntFVV
numbers of "FtrVdataValue"
Definition: zwapi_part_data.h:302
svxPartCfgInfo::CntComp
int CntComp
numbers of "comp"
Definition: zwapi_part_data.h:249
svxPartCfgInfo::CntFD
int CntFD
numbers of "FtrDim"
Definition: zwapi_part_data.h:206
svxPartCfgInfo::CntThreads
int CntThreads
numbers of "threads"
Definition: zwapi_part_data.h:262
svxPartCfgInfo::ConfigName
vxName ConfigName
configuration name
Definition: zwapi_part_data.h:182
svxPartCfgInfo::CntRO
int CntRO
numbers of "RegenObjs"
Definition: zwapi_part_data.h:194
svxPartCfgInfo::fCfged
int fCfged
1 if colorval exist,else 0
Definition: zwapi_part_data.h:186
svxPartCfgInfo::CntAV
int CntAV
numbers of "AlignValue"
Definition: zwapi_part_data.h:290
svxPartCfgInfo::CntVar
int CntVar
numbers of "var"
Definition: zwapi_part_data.h:223
svxPartCfgInfo::CntPD
int CntPD
numbers of "ProfDim"
Definition: zwapi_part_data.h:214
svxPartCfgInfo::ConfigId
int ConfigId
the row number of the table(0,1,...)
Definition: zwapi_part_data.h:184
svxPartCfgInfo::CntAlign
int CntAlign
numbers of "align"
Definition: zwapi_part_data.h:280
svxPartCfgInfo::CntROF
int CntROF
numbers of "RegenObjsFailed"
Definition: zwapi_part_data.h:313
svxPartCfgInfo::CntODV
int CntODV
numbers of "OutDefVal"
Definition: zwapi_part_data.h:310
svxPartCfgInfo::RegenObjsFailed
int * RegenObjsFailed
list of regen object failed
Definition: zwapi_part_data.h:312
svxPartCfgInfo::CfgIdx
int CfgIdx
configuration id
Definition: zwapi_part_data.h:183
svxPartCfgInfo::CntTD
int CntTD
numbers of "ThreadDeps"
Definition: zwapi_part_data.h:272
svxPartCfgInfo
config table infos
Definition: zwapi_part_data.h:181
svxPartMaterial::density
double density
material density(kg/m3)
Definition: zwapi_part_data.h:69
svxPartMaterial
Part material physical attributes.
Definition: zwapi_part_data.h:67
svxPoint
3D point
Definition: zwapi_util.h:306
svxRefineFacets::angleTol
double angleTol
angle tolerance.min=1,max=30,default:5. apply it if type=VX_FACETS_TOL_ANGLE.
Definition: zwapi_part_data.h:143
svxRefineFacets::facetTol
double facetTol
facet tolerance.min=0.001.default:1. apply it if type=VX_FACETS_TOL_DISTANCE.
Definition: zwapi_part_data.h:142
svxRefineFacets::edgeTol
double edgeTol
edge tolerance.min=0.001,default:1. apply it if type=VX_FACETS_TOL_DISTANCE or VX_FACETS_TOL_ANGLE.
Definition: zwapi_part_data.h:141
svxRefineFacets::type
evxRefineFacetsTolType type
tolerance type.default:VX_FACETS_TOL_PIXEL
Definition: zwapi_part_data.h:139
svxRefineFacets::idFace
int idFace
face id
Definition: zwapi_part_data.h:138
svxRefineFacets
refine facets data
Definition: zwapi_part_data.h:137
svxSTL::facets
svxTriangle * facets
Array of STLfacet
Definition: zwapi_part_data.h:94
svxSTL::name
char * name
name
Definition: zwapi_part_data.h:92
svxSTL::dTol
double dTol
Tolerance to use when extracting facets
Definition: zwapi_part_data.h:107
svxSTL::nFacet
int nFacet
number of facet
Definition: zwapi_part_data.h:93
svxSTL
3D STL facets
Definition: zwapi_part_data.h:91
svxTriangle
3D triangle
Definition: zwapi_util.h:370
svxUid
entity unique identifier
Definition: zwapi_util.h:987
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_DATUM_QUERY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_datum_query.h
cvxAxisGetData
cvxAxisInqDir
cvxAxisLengthGet
cvxAxisLengthSet
cvxCSYSGetData
cvxPartInqAxis
cvxPartInqCsys
cvxPartInqCSYSAxis
cvxPartInqCSYSPlane
cvxPartInqDefaultCSYS
cvxPartInqLCSMat
cvxPlaneGetData

◆ ZW_API_DATUM_QUERY_H

#define ZW_API_DATUM_QUERY_H

Definition at line 15 of file zwapi_part_datum_query.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_datum_query.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_datum_query.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_DATUM_QUERY_H /* this ifndef surrounds entire header */
15#define ZW_API_DATUM_QUERY_H
16
17#include "zwapi_cmd_datum_data.h"
18#include "zwapi_part_data.h"
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23
24/**********************************************************************
25*! zwapi_part_history.h - include the Axis, Datum and CSYS in the history tree
26* extern evxErrors cvxPartInqFtrList(int* Count, int** Features);
27**********************************************************************/
28//====================================================================================================================
30//====================================================================================================================
31/******************************************************************************/
48extern evxErrors cvxPartInqAxis(int* Count, int** Axis);
49
50/******************************************************************************/
67extern evxErrors cvxAxisInqDir(int idAxis, svxPoint* pPnt, svxPoint* pDir);
68
69/******************************************************************************/
89extern evxErrors cvxAxisGetData(int idAxis, svxAxisData* Axis);
90
91/******************************************************************************/
109extern evxErrors cvxAxisLengthGet(int idAxis, double* Length);
110
111/******************************************************************************/
129extern evxErrors cvxAxisLengthSet(int idAxis, double Length);
130
131//====================================================================================================================
133//====================================================================================================================
134/******************************************************************************/
155extern evxErrors cvxPlaneGetData(int idPlane, svxPlaneData* Plane);
156
157
158//====================================================================================================================
160//====================================================================================================================
161/******************************************************************************/
178extern evxErrors cvxPartInqCsys(int* Count, int** Csys);
179
180/******************************************************************************/
194extern evxErrors cvxPartInqDefaultCSYS(int* CSYS);
195
196/******************************************************************************/
213extern evxErrors cvxPartInqCSYSAxis(int idCSYS, evxAxisType AxisType, int* idAxis);
214
215/******************************************************************************/
232extern evxErrors cvxPartInqCSYSPlane(int idCSYS, evxPlaneType PlnType, int* idPlane);
233
234/******************************************************************************/
255extern evxErrors cvxCSYSGetData(int idCSYS, svxCSYSData* CSYS);
256
257/******************************************************************************/
267extern void cvxPartInqLCSMat(svxMatrix* mat);
268
269/*
270*********************************************************************
271** END HEADER FILE
272*********************************************************************
273*/
274#ifdef __cplusplus
275 }
276#endif /* __cplusplus */
277
278#endif /* ZW_API_DATUM_QUERY_H */
evxPlaneType
evxPlaneType
type of plane
Definition: zwapi_part_data.h:400
cvxPartInqDefaultCSYS
evxErrors cvxPartInqDefaultCSYS(int *CSYS)
cvxAxisGetData
evxErrors cvxAxisGetData(int idAxis, svxAxisData *Axis)
cvxCSYSGetData
evxErrors cvxCSYSGetData(int idCSYS, svxCSYSData *CSYS)
cvxPartInqCsys
evxErrors cvxPartInqCsys(int *Count, int **Csys)
cvxAxisLengthSet
evxErrors cvxAxisLengthSet(int idAxis, double Length)
cvxPlaneGetData
evxErrors cvxPlaneGetData(int idPlane, svxPlaneData *Plane)
cvxPartInqCSYSPlane
evxErrors cvxPartInqCSYSPlane(int idCSYS, evxPlaneType PlnType, int *idPlane)
cvxPartInqLCSMat
void cvxPartInqLCSMat(svxMatrix *mat)
cvxPartInqAxis
evxErrors cvxPartInqAxis(int *Count, int **Axis)
cvxAxisInqDir
evxErrors cvxAxisInqDir(int idAxis, svxPoint *pPnt, svxPoint *pDir)
cvxPartInqCSYSAxis
evxErrors cvxPartInqCSYSAxis(int idCSYS, evxAxisType AxisType, int *idAxis)
cvxAxisLengthGet
evxErrors cvxAxisLengthGet(int idAxis, double *Length)
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAxisData
template command Axis input data
Definition: zwapi_cmd_datum_data.h:50
svxCSYSData
template command CSYS input data
Definition: zwapi_cmd_datum_data.h:348
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPlaneData
template command Plane input data
Definition: zwapi_cmd_datum_data.h:121
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_cmd_datum_data.h
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_DIM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_dim.h
cvxPartInqDimIdxs
cvxPartInqDims
cvxPartInqPMIDimEnts
cvxPartInqPMIs
cvxPMIInqAssoEnts
cvxPMIInqBaseEnt
cvxPMIInqType
cvxPMIInqValid
cvxSymInqLeadLines
cvxSymInqRefPnt

◆ ZW_API_PART_DIM_H

#define ZW_API_PART_DIM_H

Definition at line 15 of file zwapi_part_dim.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_dim.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_dim.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_DIM_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_DIM_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxPartInqDims(const vxLongPath File, const vxRootName Part, int* Count, svxVariable** Variables);
46
47/******************************************************************************/
71extern evxErrors cvxPartInqPMIDimEnts(int idDim, int* Count, svxEntPath** EntPaths);
72
73/******************************************************************************/
92extern evxErrors cvxPartInqDimIdxs(const vxLongPath File, const vxRootName Part, int* Count, int** IdList);
93
94//====================================================================================================================
96//====================================================================================================================
97/******************************************************************************/
116extern evxErrors cvxPartInqPMIs(evxPMIEntType type, int* count, int** idPMIs);
117
118/******************************************************************************/
136extern evxErrors cvxPMIInqType(int idPMI, evxPMIEntType* type);
137
138/******************************************************************************/
156extern evxErrors cvxPMIInqBaseEnt(int idPMI, int* idBaseObj);
157
158/******************************************************************************/
183extern evxErrors cvxPMIInqAssoEnts(int idPMI, int* count, svxEntPath** entPaths);
184
185/******************************************************************************/
203extern evxErrors cvxPMIInqValid(int idPMI, int* isValid);
204
205
206//====================================================================================================================
208//====================================================================================================================
209/******************************************************************************/
224extern evxErrors cvxSymInqRefPnt(int idSym, svxPoint* RefPnt);
225
226/******************************************************************************/
252extern evxErrors cvxSymInqLeadLines(int idSym, int* count, svxCurve** LeadCrvs);
253
254
255/*
256*********************************************************************
257** END HEADER FILE
258*********************************************************************
259*/
260
261#ifdef __cplusplus
262 }
263#endif /* __cplusplus */
264
265#endif /* ZW_API_PART_DIM_H */
evxPMIEntType
evxPMIEntType
PMI entity type.
Definition: zwapi_part_data.h:343
cvxPMIInqValid
evxErrors cvxPMIInqValid(int idPMI, int *isValid)
cvxPMIInqBaseEnt
evxErrors cvxPMIInqBaseEnt(int idPMI, int *idBaseObj)
cvxPartInqPMIDimEnts
evxErrors cvxPartInqPMIDimEnts(int idDim, int *Count, svxEntPath **EntPaths)
cvxPMIInqType
evxErrors cvxPMIInqType(int idPMI, evxPMIEntType *type)
cvxPartInqDimIdxs
evxErrors cvxPartInqDimIdxs(const vxLongPath File, const vxRootName Part, int *Count, int **IdList)
cvxPartInqDims
evxErrors cvxPartInqDims(const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
cvxSymInqLeadLines
evxErrors cvxSymInqLeadLines(int idSym, int *count, svxCurve **LeadCrvs)
cvxPMIInqAssoEnts
evxErrors cvxPMIInqAssoEnts(int idPMI, int *count, svxEntPath **entPaths)
cvxSymInqRefPnt
evxErrors cvxSymInqRefPnt(int idSym, svxPoint *RefPnt)
cvxPartInqPMIs
evxErrors cvxPartInqPMIs(evxPMIEntType type, int *count, int **idPMIs)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxPoint
3D point
Definition: zwapi_util.h:306
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FACETS_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_facets.h
cvxFacetsFree
cvxPartEdgeDispData
cvxPartEdgeDispDataFree
cvxPartFacets
cvxPartFacetsBySTL
cvxPartFacetsConvertToSTL
cvxPartFacetsMod
cvxPartFacetsSetAt
cvxPartFacetsSetTx
cvxPartInqBlockPnts
cvxPartInqBlocks
cvxPartInqBlockType
cvxPartInqFaceFacets
cvxPartInqFaceFacets2
cvxPartInqFaceFacets2ByTol
cvxPartInqFaceFacetsByChord
cvxPartInqFacets
cvxPartInqFacets2
cvxPartInqFacetsTxFile
cvxPartInqFacetsTxFileByLongPath
cvxPartPntBlock
cvxPartProjStl
cvxPartRefineFacetsInit
cvxPartSTLConvertToFacets
cvxStlFree

◆ ZW_API_FACETS_H

#define ZW_API_FACETS_H

Definition at line 15 of file zwapi_part_facets.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_facets.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_facets.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_FACETS_H /* this ifndef surrounds entire header */
15#define ZW_API_FACETS_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
53extern int cvxPartPntBlock(vxLongName Name, int Count, svxPointf* Points, int* idEnt);
54
55/******************************************************************************/
89extern evxErrors cvxPartFacets(vxLongName Name, svxFacets* Facets, int* idBlock);
90
91/******************************************************************************/
117extern evxErrors cvxPartFacetsBySTL(const vxLongName name, const svxSTL* stl, int* idBlock);
118
119
120//====================================================================================================================
122//====================================================================================================================
123/******************************************************************************/
145extern evxErrors cvxPartInqBlocks(int* Count, int** Blocks);
146
147/******************************************************************************/
169extern evxErrors cvxPartInqBlockPnts(int idBlock, int* Count, svxPointf** Points);
170
171/******************************************************************************/
188extern evxErrors cvxPartInqBlockType(int idBlock, evxBlockType* Type);
189
190/******************************************************************************/
209extern evxErrors cvxPartInqFacets(int idBlock, svxSTL* Stl);
210
211/******************************************************************************/
238extern evxErrors cvxPartInqFacets2(int idBlock, svxFacets* Facets);
239
240/******************************************************************************/
268extern evxErrors cvxPartInqFacetsTxFile(int idBlock, vxPath Path);
269
270/******************************************************************************/
303extern evxErrors cvxPartInqFacetsTxFileByLongPath(int idBlock, char* Path,int sizePath);
304
305//====================================================================================================================
307//====================================================================================================================
308/******************************************************************************/
346extern evxErrors cvxPartFacetsMod(int idBlock, svxFacets* Facets);
347
348/******************************************************************************/
366extern evxErrors cvxPartFacetsSetAt(int idBlock, const svxFaceAt* At);
367
368/******************************************************************************/
396extern evxErrors cvxPartFacetsSetTx(int idBlock, const svxTextureAt* Tx);
397
398/******************************************************************************/
421extern evxErrors cvxPartProjStl(int idStl, int idPln, double tol, double smth, int* idCurve);
422
423//====================================================================================================================
425//====================================================================================================================
426/******************************************************************************/
449extern evxErrors cvxPartInqFaceFacets(int idFace, int* Count, svxTriangle** Facets);
450
451/******************************************************************************/
530extern evxErrors cvxPartInqFaceFacets2(int idFace, svxFacets* Facets);
531
532/******************************************************************************/
560extern evxErrors cvxPartInqFaceFacetsByChord(int idFace, double ChordHeight, int* Count, svxTriangle** Facets);
561
562/******************************************************************************/
579extern evxErrors cvxPartRefineFacetsInit(svxRefineFacets* data);
580
581/******************************************************************************/
615extern evxErrors cvxPartInqFaceFacets2ByTol(svxRefineFacets* RefineData, svxFacets* Facets);
616
617#ifdef _WIN64
618/******************************************************************************/
650extern evxErrors cvxPartFaceMesh(int idFace, double chord, double sideSize, int* count, svxTriangle** pnts);
651
652/******************************************************************************/
680extern evxErrors cvxPartFaceMeshPnts(int idFace, double chord, double sideSize, int* count, svxPoint** pnts);
681#endif
682
683//====================================================================================================================
685//====================================================================================================================
686
687/******************************************************************************/
703extern evxErrors cvxPartFacetsConvertToSTL(const svxFacets* facets, svxSTL* stl);
704
705/******************************************************************************/
721extern evxErrors cvxPartSTLConvertToFacets(const svxSTL* stl, svxFacets* facets);
722
723//====================================================================================================================
725//====================================================================================================================
726/******************************************************************************/
737extern void cvxFacetsFree(svxFacets* Facets);
738
739/******************************************************************************/
750extern void cvxStlFree(svxSTL* Stl);
751
752//====================================================================================================================
754//====================================================================================================================
755
756/******************************************************************************/
782extern evxErrors cvxPartEdgeDispData(int idEdge, svxEdgeDispData* data);
783
784/******************************************************************************/
792extern void cvxPartEdgeDispDataFree(svxEdgeDispData* data);
793
794/*
795*********************************************************************
796** END HEADER FILE
797*********************************************************************
798*/
799
800#ifdef __cplusplus
801 }
802#endif /* __cplusplus */
803
804#endif /* ZW_API_FACETS_H */
805
806
807
evxBlockType
evxBlockType
3D Block Type
Definition: zwapi_part_data.h:115
cvxStlFree
void cvxStlFree(svxSTL *Stl)
cvxPartFacets
evxErrors cvxPartFacets(vxLongName Name, svxFacets *Facets, int *idBlock)
cvxPartFacetsConvertToSTL
evxErrors cvxPartFacetsConvertToSTL(const svxFacets *facets, svxSTL *stl)
cvxPartPntBlock
int cvxPartPntBlock(vxLongName Name, int Count, svxPointf *Points, int *idEnt)
cvxPartFacetsSetAt
evxErrors cvxPartFacetsSetAt(int idBlock, const svxFaceAt *At)
cvxFacetsFree
void cvxFacetsFree(svxFacets *Facets)
cvxPartFacetsBySTL
evxErrors cvxPartFacetsBySTL(const vxLongName name, const svxSTL *stl, int *idBlock)
cvxPartFacetsMod
evxErrors cvxPartFacetsMod(int idBlock, svxFacets *Facets)
cvxPartFacetsSetTx
evxErrors cvxPartFacetsSetTx(int idBlock, const svxTextureAt *Tx)
cvxPartInqFaceFacetsByChord
evxErrors cvxPartInqFaceFacetsByChord(int idFace, double ChordHeight, int *Count, svxTriangle **Facets)
cvxPartRefineFacetsInit
evxErrors cvxPartRefineFacetsInit(svxRefineFacets *data)
cvxPartInqFacets2
evxErrors cvxPartInqFacets2(int idBlock, svxFacets *Facets)
cvxPartInqFaceFacets
evxErrors cvxPartInqFaceFacets(int idFace, int *Count, svxTriangle **Facets)
cvxPartProjStl
evxErrors cvxPartProjStl(int idStl, int idPln, double tol, double smth, int *idCurve)
cvxPartEdgeDispDataFree
void cvxPartEdgeDispDataFree(svxEdgeDispData *data)
cvxPartInqFaceFacets2
evxErrors cvxPartInqFaceFacets2(int idFace, svxFacets *Facets)
cvxPartInqBlocks
evxErrors cvxPartInqBlocks(int *Count, int **Blocks)
cvxPartInqBlockType
evxErrors cvxPartInqBlockType(int idBlock, evxBlockType *Type)
cvxPartEdgeDispData
evxErrors cvxPartEdgeDispData(int idEdge, svxEdgeDispData *data)
cvxPartInqBlockPnts
evxErrors cvxPartInqBlockPnts(int idBlock, int *Count, svxPointf **Points)
cvxPartInqFaceFacets2ByTol
evxErrors cvxPartInqFaceFacets2ByTol(svxRefineFacets *RefineData, svxFacets *Facets)
cvxPartSTLConvertToFacets
evxErrors cvxPartSTLConvertToFacets(const svxSTL *stl, svxFacets *facets)
cvxPartInqFacetsTxFileByLongPath
evxErrors cvxPartInqFacetsTxFileByLongPath(int idBlock, char *Path, int sizePath)
cvxPartInqFacets
evxErrors cvxPartInqFacets(int idBlock, svxSTL *Stl)
cvxPartInqFacetsTxFile
evxErrors cvxPartInqFacetsTxFile(int idBlock, vxPath Path)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxEdgeDispData
edge display data
Definition: zwapi_part_data.h:381
svxFaceAt
face display attributes
Definition: zwapi_util.h:1140
svxFacets
3D facets defined by triangle strips
Definition: zwapi_util.h:1892
svxPoint
3D point
Definition: zwapi_util.h:306
svxPointf
3D point (single precision floating point)
Definition: zwapi_util.h:317
svxRefineFacets
refine facets data
Definition: zwapi_part_data.h:137
svxSTL
3D STL facets
Definition: zwapi_part_data.h:91
svxTextureAt
texture attribute
Definition: zwapi_util.h:1266
svxTriangle
3D triangle
Definition: zwapi_util.h:370
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_HISTORY_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_history.h
cvxFtrIsSubPart
cvxPartFtrInqAuxFtrs
cvxPartFtrInqInpEnts
cvxPartFtrIsMissRef
cvxPartFtrUserAtDel
cvxPartFtrUserAtGet
cvxPartFtrUserAtSet
cvxPartHistList
cvxPartInqFtrAssoPart
cvxPartInqFtrAssoPartByLongPath
cvxPartInqFtrChildFtrs
cvxPartInqFtrData
cvxPartInqFtrEnts
cvxPartInqFtrGroup
cvxPartInqFtrList
cvxPartInqFtrParentFtrs
cvxPartInqFtrRegenStat
cvxPartInqFtrRegenStatus
cvxPartInqFtrTemplate
cvxPartInqFtrTol
cvxPartInqFtrVersion
cvxPartInqGroupFtrs
cvxPartInqGroupList
cvxPartPartialResults
cvxPartRedefineIsActive
cvxPartRegenFacets
cvxPartRegenIsActive

◆ ZW_API_HISTORY_H

#define ZW_API_HISTORY_H

Definition at line 15 of file zwapi_part_history.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_history.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_history.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_HISTORY_H /* this ifndef surrounds entire header */
15#define ZW_API_HISTORY_H
16
17#include "zwapi_part_data.h"
18
19
20#ifdef __cplusplus
21extern "C" {
22#endif /* __cplusplus */
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
36extern int cvxPartRegenIsActive(void);
37
38/******************************************************************************/
48extern int cvxPartRedefineIsActive(void);
49
50/******************************************************************************/
84extern evxErrors cvxPartRegenFacets(int Count, int* idFaces, int Assembly, int LOD, double Tol);
85
86/******************************************************************************/
101extern void cvxPartPartialResults(int Disable);
102
103
104//====================================================================================================================
106//====================================================================================================================
107/******************************************************************************/
134extern evxErrors cvxPartHistList(int Option, int* Cnts, int** HistList);
135
136/******************************************************************************/
158extern evxErrors cvxPartInqFtrList(int* Count, int** Features);
159
160
161//====================================================================================================================
163//====================================================================================================================
164/******************************************************************************/
181extern int cvxFtrIsSubPart(int idFtr);
182
183/******************************************************************************/
204extern int cvxPartFtrIsMissRef(int idFeature, char* status);
205
206/******************************************************************************/
229extern int cvxPartInqFtrAssoPart(int idFeature, vxPath file, vxRootName rootName);
230
231/******************************************************************************/
262extern int cvxPartInqFtrAssoPartByLongPath(int idFeature, char* file,int sizeFile ,char* rootName,int sizeRName);
263
264/******************************************************************************/
305extern int cvxPartInqFtrData(int idFeature, int iNoEval, int* idData);
306
307/******************************************************************************/
330extern int cvxPartFtrInqAuxFtrs(int idFtr, int* count, int** idAuxFtrs);
331
332/******************************************************************************/
350extern evxErrors cvxPartInqFtrTemplate(int idFeature, vxName Template);
351
352/******************************************************************************/
370extern evxErrors cvxPartInqFtrTol(int idFeature, double* Tolerance);
371
372/******************************************************************************/
397extern evxErrors cvxPartInqFtrRegenStat(int idFeature, char* stat);
398
399/******************************************************************************/
422extern evxErrors cvxPartInqFtrRegenStatus(int idFtr, evxFtrRegenStatus* status);
423
424/******************************************************************************/
443extern evxErrors cvxPartInqFtrVersion(int idFeature, int* Version);
444
445/******************************************************************************/
465extern evxErrors cvxPartInqFtrGroup(int idFeature, int* idGroup);
466
467
468//====================================================================================================================
470//====================================================================================================================
471/******************************************************************************/
491extern evxErrors cvxPartInqGroupFtrs(int idGroup, int* count, int** ftrList);
492
493/******************************************************************************/
515extern evxErrors cvxPartInqGroupList(int* count, int** groups);
516
517
518//====================================================================================================================
520//====================================================================================================================
521/******************************************************************************/
543extern evxErrors cvxPartInqFtrParentFtrs(int idFeature, int getAll, int* cnt, int** list);
544
545/******************************************************************************/
565extern evxErrors cvxPartInqFtrChildFtrs(int idFeature, int* cnt, int** list);
566
567
568//====================================================================================================================
570//====================================================================================================================
571/******************************************************************************/
597extern evxErrors cvxPartFtrInqInpEnts(int idFeature, evxEntType type, int* cnt, int** list);
598
599
600/******************************************************************************/
623extern evxErrors cvxPartInqFtrEnts(int idFeature, evxEntType EntType, int* Count, int** Ents);
624
625
626//====================================================================================================================
628//====================================================================================================================
629/******************************************************************************/
650extern evxErrors cvxPartFtrUserAtGet(int idFeature, int* Count, svxAttribute** UserAt);
651
652/******************************************************************************/
671extern evxErrors cvxPartFtrUserAtSet(int idFeature, int Count, svxAttribute* UserAt);
672
673/******************************************************************************/
693extern evxErrors cvxPartFtrUserAtDel(int idFeature, int Count, svxAttribute* UserAt);
694
695
696/*
697*********************************************************************
698** END HEADER FILE
699*********************************************************************
700*/
701
702#ifdef __cplusplus
703 }
704#endif /* __cplusplus */
705
706#endif /* ZW_API_HISTORY_H */
evxFtrRegenStatus
evxFtrRegenStatus
regen status of feature
Definition: zwapi_part_data.h:33
cvxPartInqFtrData
int cvxPartInqFtrData(int idFeature, int iNoEval, int *idData)
cvxFtrIsSubPart
int cvxFtrIsSubPart(int idFtr)
cvxPartInqFtrGroup
evxErrors cvxPartInqFtrGroup(int idFeature, int *idGroup)
cvxPartFtrUserAtSet
evxErrors cvxPartFtrUserAtSet(int idFeature, int Count, svxAttribute *UserAt)
cvxPartInqFtrList
evxErrors cvxPartInqFtrList(int *Count, int **Features)
cvxPartFtrUserAtDel
evxErrors cvxPartFtrUserAtDel(int idFeature, int Count, svxAttribute *UserAt)
cvxPartInqFtrVersion
evxErrors cvxPartInqFtrVersion(int idFeature, int *Version)
cvxPartInqGroupFtrs
evxErrors cvxPartInqGroupFtrs(int idGroup, int *count, int **ftrList)
cvxPartRegenFacets
evxErrors cvxPartRegenFacets(int Count, int *idFaces, int Assembly, int LOD, double Tol)
cvxPartInqFtrParentFtrs
evxErrors cvxPartInqFtrParentFtrs(int idFeature, int getAll, int *cnt, int **list)
cvxPartInqFtrRegenStat
evxErrors cvxPartInqFtrRegenStat(int idFeature, char *stat)
cvxPartFtrUserAtGet
evxErrors cvxPartFtrUserAtGet(int idFeature, int *Count, svxAttribute **UserAt)
cvxPartInqFtrAssoPart
int cvxPartInqFtrAssoPart(int idFeature, vxPath file, vxRootName rootName)
cvxPartHistList
evxErrors cvxPartHistList(int Option, int *Cnts, int **HistList)
cvxPartFtrInqInpEnts
evxErrors cvxPartFtrInqInpEnts(int idFeature, evxEntType type, int *cnt, int **list)
cvxPartInqFtrTol
evxErrors cvxPartInqFtrTol(int idFeature, double *Tolerance)
cvxPartInqFtrChildFtrs
evxErrors cvxPartInqFtrChildFtrs(int idFeature, int *cnt, int **list)
cvxPartFtrIsMissRef
int cvxPartFtrIsMissRef(int idFeature, char *status)
cvxPartInqFtrTemplate
evxErrors cvxPartInqFtrTemplate(int idFeature, vxName Template)
cvxPartRegenIsActive
int cvxPartRegenIsActive(void)
cvxPartInqFtrRegenStatus
evxErrors cvxPartInqFtrRegenStatus(int idFtr, evxFtrRegenStatus *status)
cvxPartFtrInqAuxFtrs
int cvxPartFtrInqAuxFtrs(int idFtr, int *count, int **idAuxFtrs)
cvxPartInqFtrEnts
evxErrors cvxPartInqFtrEnts(int idFeature, evxEntType EntType, int *Count, int **Ents)
cvxPartInqFtrAssoPartByLongPath
int cvxPartInqFtrAssoPartByLongPath(int idFeature, char *file, int sizeFile, char *rootName, int sizeRName)
cvxPartRedefineIsActive
int cvxPartRedefineIsActive(void)
cvxPartPartialResults
void cvxPartPartialResults(int Disable)
cvxPartInqGroupList
evxErrors cvxPartInqGroupList(int *count, int **groups)
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxEntType
evxEntType
entity types
Definition: zwapi_util.h:917
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_HOLE_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_hole.h
cvxPartFreeHoles
cvxPartInqHoles

◆ ZW_API_HOLE_H

#define ZW_API_HOLE_H

Definition at line 15 of file zwapi_part_hole.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_hole.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_hole.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_HOLE_H /* this ifndef surrounds entire header */
15#define ZW_API_HOLE_H
16
17#include "zwapi_cmd_shape_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
49extern evxErrors cvxPartInqHoles(const vxLongPath File, const vxRootName Part, int* Count, svxHoleData** Holes);
50
51/******************************************************************************/
64extern void cvxPartFreeHoles(int Count, svxHoleData** Holes);
65
66
67/*
68*********************************************************************
69** END HEADER FILE
70*********************************************************************
71*/
72
73#ifdef __cplusplus
74 }
75#endif /* __cplusplus */
76
77#endif /* ZW_API_HOLE_H */
cvxPartInqHoles
evxErrors cvxPartInqHoles(const vxLongPath File, const vxRootName Part, int *Count, svxHoleData **Holes)
cvxPartFreeHoles
void cvxPartFreeHoles(int Count, svxHoleData **Holes)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxHoleData
hole data
Definition: zwapi_cmd_shape_data.h:697
zwapi_cmd_shape_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_OBJ_QUERY

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_objs.h
cvxCurveFree
cvxPartInqAnnoTexts
cvxPartInqConstraints
cvxPartInqCrvList
cvxPartInqCrvLists
cvxPartInqCurve
cvxPartInqCurves
cvxPartInqPoints
cvxPartInqPublishSet
cvxPartInqPublishSets
cvxPartInqTempData
cvxPartInqTexts

◆ ZW_API_PART_OBJ_QUERY

#define ZW_API_PART_OBJ_QUERY

Definition at line 15 of file zwapi_part_objs.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_objs.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_objs.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_OBJ_QUERY /* this ifndef surrounds entire header */
15#define ZW_API_PART_OBJ_QUERY
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
44extern evxErrors cvxPartInqCurves(int* Count, int** Curves);
45
46/******************************************************************************/
64extern evxErrors cvxPartInqCrvLists(int* Count, int** CrvLists);
65
66/******************************************************************************/
94extern evxErrors cvxPartInqCrvList(int idCrvList, int* Count, svxEntPick** Curves);
95
96/******************************************************************************/
120extern evxErrors cvxPartInqCurve(int idEntity, int Nurb, svxCurve* Crv);
121
122/******************************************************************************/
133extern void cvxCurveFree(svxCurve* Crv);
134
135
136//====================================================================================================================
138//====================================================================================================================
139/******************************************************************************/
157extern evxErrors cvxPartInqPoints(int* count, int** pointIdx);
158
159
160//====================================================================================================================
162//====================================================================================================================
163/******************************************************************************/
184extern evxErrors cvxPartInqAnnoTexts(int* Count, int** Texts);
185
186/******************************************************************************/
207extern evxErrors cvxPartInqTexts(int* count, int** idTexts);
208
209//====================================================================================================================
211//====================================================================================================================
212/******************************************************************************/
232extern evxErrors cvxPartInqConstraints(const vxLongPath File,const vxRootName Part, int* count, int** cons);
233
234/******************************************************************************/
257extern evxErrors cvxPartInqTempData(int idPart, int* count, int** datas);
258
259//====================================================================================================================
261//====================================================================================================================
262/******************************************************************************/
298extern evxErrors cvxPartInqPublishSets(const vxLongPath File, const vxRootName Part, int* Count, int** idPubSets);
299
300/******************************************************************************/
340extern evxErrors cvxPartInqPublishSet(const vxLongPath File, const vxRootName Part, int idPubSet, vxName Name, int* Count, int** idEnts);
341
342/*
343*********************************************************************
344** END HEADER FILE
345*********************************************************************
346*/
347
348#ifdef __cplusplus
349 }
350#endif /* __cplusplus */
351
352#endif /* ZW_API_PART_OBJ_QUERY */
cvxPartInqCurve
evxErrors cvxPartInqCurve(int idEntity, int Nurb, svxCurve *Crv)
cvxPartInqAnnoTexts
evxErrors cvxPartInqAnnoTexts(int *Count, int **Texts)
cvxPartInqTexts
evxErrors cvxPartInqTexts(int *count, int **idTexts)
cvxPartInqCrvLists
evxErrors cvxPartInqCrvLists(int *Count, int **CrvLists)
cvxPartInqCrvList
evxErrors cvxPartInqCrvList(int idCrvList, int *Count, svxEntPick **Curves)
cvxPartInqCurves
evxErrors cvxPartInqCurves(int *Count, int **Curves)
cvxPartInqPublishSets
evxErrors cvxPartInqPublishSets(const vxLongPath File, const vxRootName Part, int *Count, int **idPubSets)
cvxPartInqTempData
evxErrors cvxPartInqTempData(int idPart, int *count, int **datas)
cvxPartInqPoints
evxErrors cvxPartInqPoints(int *count, int **pointIdx)
cvxPartInqConstraints
evxErrors cvxPartInqConstraints(const vxLongPath File, const vxRootName Part, int *count, int **cons)
cvxCurveFree
void cvxCurveFree(svxCurve *Crv)
cvxPartInqPublishSet
evxErrors cvxPartInqPublishSet(const vxLongPath File, const vxRootName Part, int idPubSet, vxName Name, int *Count, int **idEnts)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxEntPick
entity pick (includes optional parent entity)
Definition: zwapi_util.h:976
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_OPTS_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_opts.h
cvxHistBackup
cvxHistDisable
cvxHistEnable
cvxHistRedefine
cvxHistSkipTo
cvxPartBackup
cvxPartDelGrpFtr
cvxPartEncapsulate
cvxPartErase
cvxPartExit
cvxPartFtrPlayTo
cvxPartFtrSuppress
cvxPartHistAdd
cvxPartHistClip
cvxPartHistClipbyPath
cvxPartHistDel
cvxPartHistDelUtil
cvxPartHistEnd
cvxPartHistGroup
cvxPartHistInqGroup
cvxPartHistPaste
cvxPartHistRename
cvxPartHistScrollTo
cvxPartHistStart
cvxPartMkEntExternal
cvxPartPublishSetDel

◆ ZW_API_PART_OPTS_H

#define ZW_API_PART_OPTS_H

Definition at line 15 of file zwapi_part_opts.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_opts.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_opts.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_OPTS_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_OPTS_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22//====================================================================================================================
24//====================================================================================================================
25/******************************************************************************/
36extern void cvxPartExit(void);
37
38
39//====================================================================================================================
41//====================================================================================================================
42/******************************************************************************/
57extern evxErrors cvxPartBackup(void);
58
59/******************************************************************************/
73extern evxErrors cvxHistBackup(void);
74
75/******************************************************************************/
96extern evxErrors cvxPartEncapsulate(int Option, int KeepDimen);
97
98/******************************************************************************/
115extern evxErrors cvxPartHistStart(vxName Name);
116
117/******************************************************************************/
134extern evxErrors cvxPartHistEnd(void);
135
136
137//====================================================================================================================
139//====================================================================================================================
140/******************************************************************************/
155extern evxErrors cvxHistRedefine(vxName Operation);
156
157/******************************************************************************/
180extern evxErrors cvxHistSkipTo(char* Expression, vxName Operation, int* idOp);
181
182/******************************************************************************/
199extern evxErrors cvxPartFtrPlayTo(int idxFtrPlayTo, int state);
200
201/******************************************************************************/
220extern evxErrors cvxPartFtrSuppress(int count, int* idFeatures, char suppress);
221
222/******************************************************************************/
243extern evxErrors cvxPartHistGroup(int idFirst, int idLast, const vxName Name, int Close);
244
245/******************************************************************************/
267extern evxErrors cvxPartHistInqGroup(int idHistObj, int* idGroup);
268
269/******************************************************************************/
284extern evxErrors cvxPartHistPaste(void);
285
286/******************************************************************************/
307extern evxErrors cvxPartHistClip(int Cut, int Count, int* Operations);
308
309/******************************************************************************/
330extern evxErrors cvxPartHistClipbyPath(int Cut, int Count, svxEntPath* paths);
331
332/******************************************************************************/
356extern evxErrors cvxPartHistRename(int idOp, vxName Name, char* Descript);
357
358/******************************************************************************/
377extern evxErrors cvxPartHistDel(int Count, int* Operations);
378
379/******************************************************************************/
401extern evxErrors cvxPartHistDelUtil(int Count, int* Operations, int OpType);
402
403/******************************************************************************/
425extern evxErrors cvxPartDelGrpFtr(int idFtr, int delFtrs);
426
427
428/******************************************************************************/
448extern evxErrors cvxPartMkEntExternal(int idEnt, int external);
449
450
451/******************************************************************************/
460extern void cvxHistDisable(void);
461
462/******************************************************************************/
471extern void cvxHistEnable(void);
472
473
474//====================================================================================================================
476//====================================================================================================================
477/******************************************************************************/
512extern evxErrors cvxPartHistAdd(const int idData, const vxName FtrName, const int Option, int* idFtr);
513
514
515//====================================================================================================================
517//====================================================================================================================
518/******************************************************************************/
541extern evxErrors cvxPartErase(int Count, int* idEnts);
542
543/******************************************************************************/
559extern evxErrors cvxPartHistScrollTo(int idEnt);
560
561//====================================================================================================================
563//====================================================================================================================
564/******************************************************************************/
587extern evxErrors cvxPartPublishSetDel(int Count, const int* idPubSets);
588
589
590/*
591*********************************************************************
592** END HEADER FILE
593*********************************************************************
594*/
595
596#ifdef __cplusplus
597 }
598#endif /* __cplusplus */
599
600#endif /* ZW_API_PART_OPTS_H */
cvxHistSkipTo
evxErrors cvxHistSkipTo(char *Expression, vxName Operation, int *idOp)
cvxPartHistDel
evxErrors cvxPartHistDel(int Count, int *Operations)
cvxPartDelGrpFtr
evxErrors cvxPartDelGrpFtr(int idFtr, int delFtrs)
cvxPartBackup
evxErrors cvxPartBackup(void)
cvxHistDisable
void cvxHistDisable(void)
cvxPartErase
evxErrors cvxPartErase(int Count, int *idEnts)
cvxPartHistStart
evxErrors cvxPartHistStart(vxName Name)
cvxPartMkEntExternal
evxErrors cvxPartMkEntExternal(int idEnt, int external)
cvxPartEncapsulate
evxErrors cvxPartEncapsulate(int Option, int KeepDimen)
cvxPartPublishSetDel
evxErrors cvxPartPublishSetDel(int Count, const int *idPubSets)
cvxPartHistGroup
evxErrors cvxPartHistGroup(int idFirst, int idLast, const vxName Name, int Close)
cvxHistBackup
evxErrors cvxHistBackup(void)
cvxPartHistEnd
evxErrors cvxPartHistEnd(void)
cvxPartHistPaste
evxErrors cvxPartHistPaste(void)
cvxPartHistRename
evxErrors cvxPartHistRename(int idOp, vxName Name, char *Descript)
cvxPartFtrPlayTo
evxErrors cvxPartFtrPlayTo(int idxFtrPlayTo, int state)
cvxPartHistClip
evxErrors cvxPartHistClip(int Cut, int Count, int *Operations)
cvxHistRedefine
evxErrors cvxHistRedefine(vxName Operation)
cvxPartExit
void cvxPartExit(void)
cvxPartFtrSuppress
evxErrors cvxPartFtrSuppress(int count, int *idFeatures, char suppress)
cvxPartHistClipbyPath
evxErrors cvxPartHistClipbyPath(int Cut, int Count, svxEntPath *paths)
cvxPartHistInqGroup
evxErrors cvxPartHistInqGroup(int idHistObj, int *idGroup)
cvxPartHistDelUtil
evxErrors cvxPartHistDelUtil(int Count, int *Operations, int OpType)
cvxHistEnable
void cvxHistEnable(void)
cvxPartHistScrollTo
evxErrors cvxPartHistScrollTo(int idEnt)
cvxPartHistAdd
evxErrors cvxPartHistAdd(const int idData, const vxName FtrName, const int Option, int *idFtr)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SHEET_METAL_AT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_sheetmetal_attribute.h
cvxPartGetFlatSolids
cvxPartInqFlattens
cvxPartInqShtMetalThick
cvxPartInqSmdPairFaces
cvxPartInqSmdSrfType
cvxPartInqSmdStatFace
cvxPartInqSmdStatFcs
cvxPartSmdAtGet
cvxPartSmdAtSet
cvxPartSmdStatFaceSet

◆ ZW_API_SHEET_METAL_AT_H

#define ZW_API_SHEET_METAL_AT_H

Definition at line 15 of file zwapi_part_sheetmetal_attribute.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_sheetmetal_attribute.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_sheetmetal_attribute.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SHEET_METAL_AT_H /* this ifndef surrounds entire header */
15#define ZW_API_SHEET_METAL_AT_H
16
17#include "zwapi_cmd_sheetmetal_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
42extern evxErrors cvxPartSmdAtGet(svxSmdAt* at);
43
44/******************************************************************************/
66extern evxErrors cvxPartSmdAtSet(const svxSmdAt* at);
67
68
69//====================================================================================================================
71//====================================================================================================================
72/******************************************************************************/
106extern int cvxPartInqSmdStatFcs(int idShape, int* countStat, int** statFcs, int* countPair, int** pairStatFcs);
107
108/******************************************************************************/
128extern evxErrors cvxPartInqSmdStatFace(int idShape, int* idFace);
129
130/******************************************************************************/
151extern evxErrors cvxPartInqSmdPairFaces(int idFace, int* count, int** faces);
152
153/******************************************************************************/
171extern evxErrors cvxPartInqSmdSrfType(int idFace, evxSmdSurfaceType* type);
172
173/******************************************************************************/
190extern evxErrors cvxPartInqShtMetalThick(int idShape, double* thick);
191
192/******************************************************************************/
211extern evxErrors cvxPartSmdStatFaceSet(int idFace, int* idFtr);
212
213/******************************************************************************/
230extern evxErrors cvxPartGetFlatSolids(int* cnts, int** solids);
231
232//====================================================================================================================
234//====================================================================================================================
235/******************************************************************************/
262extern evxErrors cvxPartInqFlattens(int* count, int** idFlattens, vxLongName** flattenNames);
263
264
265/*
266*********************************************************************
267** END HEADER FILE
268*********************************************************************
269*/
270#ifdef __cplusplus
271 }
272#endif /* __cplusplus */
273
274#endif /* ZW_API_SHEET_METAL_AT_H */
evxSmdSurfaceType
evxSmdSurfaceType
Sheet Metal surface type.
Definition: zwapi_part_data.h:365
cvxPartInqSmdStatFcs
int cvxPartInqSmdStatFcs(int idShape, int *countStat, int **statFcs, int *countPair, int **pairStatFcs)
cvxPartSmdAtGet
evxErrors cvxPartSmdAtGet(svxSmdAt *at)
cvxPartInqSmdPairFaces
evxErrors cvxPartInqSmdPairFaces(int idFace, int *count, int **faces)
cvxPartInqFlattens
evxErrors cvxPartInqFlattens(int *count, int **idFlattens, vxLongName **flattenNames)
cvxPartGetFlatSolids
evxErrors cvxPartGetFlatSolids(int *cnts, int **solids)
cvxPartSmdAtSet
evxErrors cvxPartSmdAtSet(const svxSmdAt *at)
cvxPartInqSmdSrfType
evxErrors cvxPartInqSmdSrfType(int idFace, evxSmdSurfaceType *type)
cvxPartSmdStatFaceSet
evxErrors cvxPartSmdStatFaceSet(int idFace, int *idFtr)
cvxPartInqShtMetalThick
evxErrors cvxPartInqShtMetalThick(int idShape, double *thick)
cvxPartInqSmdStatFace
evxErrors cvxPartInqSmdStatFace(int idShape, int *idFace)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxSmdAt
sheet metal attribute
Definition: zwapi_cmd_sheetmetal_data.h:99
zwapi_cmd_sheetmetal_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_VAR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_var.h
cvxPartEqnMoveToEqnSet
cvxPartEqnSet
cvxPartEqnSetWithName
cvxPartInqEqnAllId
cvxPartInqVars
cvxPartVarAdd
cvxPartVarAddToEqnSet
cvxPartVarGet
cvxPartVarGetById
cvxPartVarSet

◆ ZW_API_PART_VAR_H

#define ZW_API_PART_VAR_H

Definition at line 15 of file zwapi_part_var.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_var.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_var.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_VAR_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_VAR_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxPartInqVars(const vxLongPath File,const vxRootName Part, int* Count, svxVariable** Variables);
46
47/******************************************************************************/
68extern evxErrors cvxPartInqEqnAllId(int* cntList, int** idList, int* cntSets, int** idSets);
69
70//====================================================================================================================
72//====================================================================================================================
73/******************************************************************************/
100extern evxErrors cvxPartVarAdd(svxVariable* Variable);
101
102/******************************************************************************/
130extern evxErrors cvxPartVarGet(svxVariable* Variable);
131
132/******************************************************************************/
155extern evxErrors cvxPartVarGetById(int idEqn, svxVariable* Variable);
156
157/******************************************************************************/
189extern evxErrors cvxPartVarSet(int Count, svxVariable* Variables, int Working);
190
191/******************************************************************************/
213extern evxErrors cvxPartEqnMoveToEqnSet(int idEqnSet, int cnt, const int* idListEqn);
214
215/******************************************************************************/
238extern evxErrors cvxPartVarAddToEqnSet(int idEqnSet, int cnt, const svxVariable* vars);
239
240/******************************************************************************/
259extern evxErrors cvxPartEqnSet(int Count, svxVariable* Variables);
260
261/******************************************************************************/
287extern evxErrors cvxPartEqnSetWithName(const vxLongName setName, int count, svxVariable* vars);
288
289/*
290*********************************************************************
291** END HEADER FILE
292*********************************************************************
293*/
294
295#ifdef __cplusplus
296 }
297#endif /* __cplusplus */
298
299#endif /* ZW_API_PART_VAR_H */
cvxPartVarGetById
evxErrors cvxPartVarGetById(int idEqn, svxVariable *Variable)
cvxPartEqnSet
evxErrors cvxPartEqnSet(int Count, svxVariable *Variables)
cvxPartVarAdd
evxErrors cvxPartVarAdd(svxVariable *Variable)
cvxPartInqEqnAllId
evxErrors cvxPartInqEqnAllId(int *cntList, int **idList, int *cntSets, int **idSets)
cvxPartVarGet
evxErrors cvxPartVarGet(svxVariable *Variable)
cvxPartVarAddToEqnSet
evxErrors cvxPartVarAddToEqnSet(int idEqnSet, int cnt, const svxVariable *vars)
cvxPartVarSet
evxErrors cvxPartVarSet(int Count, svxVariable *Variables, int Working)
cvxPartEqnMoveToEqnSet
evxErrors cvxPartEqnMoveToEqnSet(int idEqnSet, int cnt, const int *idListEqn)
cvxPartInqVars
evxErrors cvxPartInqVars(const vxLongPath File, const vxRootName Part, int *Count, svxVariable **Variables)
cvxPartEqnSetWithName
evxErrors cvxPartEqnSetWithName(const vxLongName setName, int count, svxVariable *vars)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_PART_VIEW_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_part_view.h
cvxPartClosePreview
cvxPartInqView
cvxPartInqViews
cvxPartShowAll
cvxPartShowPreview
cvxPartShowTarg
cvxPartViewAdd
cvxPartViewAddInit
cvxPartViewRecord

◆ ZW_API_PART_VIEW_H

#define ZW_API_PART_VIEW_H

Definition at line 15 of file zwapi_part_view.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_part_view.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_part_view.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_PART_VIEW_H /* this ifndef surrounds entire header */
15#define ZW_API_PART_VIEW_H
16
17#include "zwapi_part_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxPartInqView(int idView, svxView* View);
46
47/******************************************************************************/
68extern evxErrors cvxPartInqViews(int* Count, int** Views);
69
70/******************************************************************************/
88extern evxErrors cvxPartViewAddInit(svxView* data);
89
90/******************************************************************************/
111extern evxErrors cvxPartViewAdd(svxView* View, int* idView);
112
113/******************************************************************************/
129extern evxErrors cvxPartViewRecord(int idView, svxView* View);
130
131
132//====================================================================================================================
134//====================================================================================================================
135/******************************************************************************/
143extern void cvxPartShowAll(void);
144
145/******************************************************************************/
156extern void cvxPartShowTarg(void);
157
158/******************************************************************************/
182extern evxErrors cvxPartShowPreview(const vxLongPath fileName, const vxRootName rootName);
183
184/******************************************************************************/
192extern void cvxPartClosePreview();
193
194/*
195*********************************************************************
196** END HEADER FILE
197*********************************************************************
198*/
199#ifdef __cplusplus
200 }
201#endif /* __cplusplus */
202
203#endif /* ZW_API_PART_VIEW_H */
cvxPartViewAdd
evxErrors cvxPartViewAdd(svxView *View, int *idView)
cvxPartShowAll
void cvxPartShowAll(void)
cvxPartViewRecord
evxErrors cvxPartViewRecord(int idView, svxView *View)
cvxPartInqView
evxErrors cvxPartInqView(int idView, svxView *View)
cvxPartShowTarg
void cvxPartShowTarg(void)
cvxPartViewAddInit
evxErrors cvxPartViewAddInit(svxView *data)
cvxPartClosePreview
void cvxPartClosePreview()
cvxPartShowPreview
evxErrors cvxPartShowPreview(const vxLongPath fileName, const vxRootName rootName)
cvxPartInqViews
evxErrors cvxPartInqViews(int *Count, int **Views)
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxView
view data(Z3PRT,Z3ASM)
Definition: zwapi_util.h:2439
zwapi_part_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: Zw_API_ROOT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_root.h
cvxRootActivate
cvxRootActivate2
cvxRootActivateLoadAsmCtx
cvxRootAdd
cvxRootAdd2
cvxRootAdd2Bg
cvxRootAtItemGet
cvxRootAtItemSet
cvxRootCopy
cvxRootCustomDataAdd
cvxRootCustomDataDel
cvxRootCustomDataDelById
cvxRootCustomDataGet
cvxRootCustomDataGetAll
cvxRootCustomDataGetById
cvxRootCustomDataModById
cvxRootCustomDataSet
cvxRootDel
cvxRootExit
cvxRootId
cvxRootInqActive
cvxRootInqAsm
cvxRootInqCustomData
cvxRootInqMod
cvxRootInqModByName
cvxRootInqModSinceRegen
cvxRootInqSheetMetal
cvxRootInqSymbol
cvxRootIsAsm
cvxRootList
cvxRootPreviewGet
cvxRootPreviewSet
cvxRootRename
cvxRootRename2
cvxRootRenameMulti
cvxRootRenameMultiByLongPath
cvxRootSeparate
cvxRootSeparateInit
cvxRootTemplateFile
cvxRootVarGet
cvxRootVarSet
cvxRootVisibility
evxPreviewMode
evxPreviewMode
evxRootType
evxRootType
svxRootSepData

◆ Zw_API_ROOT_H

#define Zw_API_ROOT_H

Definition at line 15 of file zwapi_root.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_root.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_root.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef Zw_API_ROOT_H /* this ifndef surrounds entire header */
15#define Zw_API_ROOT_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxRootType
31 {
32 VX_ROOT_NULL = 0,
33 VX_ROOT_PART = 89,
34 VX_ROOT_PART_NEW = -VX_ROOT_PART,
35 VX_ROOT_SHEET = 90,
36 VX_ROOT_DRAWING = 91,
37 VX_ROOT_SKETCH = 70,
38 VX_ROOT_EQUATION_SET = 121,
39 VX_ROOT_CAM_PLAN = 200
40 } evxRootType;
41
42//====================================================================================================================
44//====================================================================================================================
49typedef enum evxPreviewMode
50 {
51 VX_PREVIEW_OFF = 0,
52 VX_PREVIEW_GEOM = 1,
53 VX_PREVIEW_ATTRIB = 2
54 } evxPreviewMode;
55
56//====================================================================================================================
58//====================================================================================================================
59/******************************************************************************/
76extern evxErrors cvxRootActivate(vxRootName Name);
77
78/******************************************************************************/
118extern evxErrors cvxRootActivate2(const vxLongPath File, const vxRootName Name);
119
120/******************************************************************************/
158extern evxErrors cvxRootActivateLoadAsmCtx(const vxLongPath File, const vxRootName Name, int isLoad);
159
160//====================================================================================================================
162//====================================================================================================================
163/******************************************************************************/
201extern evxErrors cvxRootAdd(evxRootType Type, vxRootName Name, const char* Template);
202
203/******************************************************************************/
226extern evxErrors cvxRootAdd2(evxRootType, vxRootName Name, const char* Template, char* Description);
227
228/******************************************************************************/
250extern int cvxRootAdd2Bg(evxRootType Type, vxRootName Name);
251
252/******************************************************************************/
284extern evxErrors cvxRootCopy(const vxLongPath SourceFile,const vxRootName SourceName,
285 const vxLongPath DestFile, vxRootName DestName, int Overwrite, int UpdateUid);
286
287/******************************************************************************/
301extern evxErrors cvxRootDel(vxRootName Name);
302
303/******************************************************************************/
310extern void cvxRootExit(void);
311
312
313//====================================================================================================================
315//====================================================================================================================
316/******************************************************************************/
335extern evxErrors cvxRootId(vxRootName Name, int* idRoot, evxRootType* Type);
336
337/******************************************************************************/
351extern void cvxRootInqActive(char* Name, int nBytes);
352
353/******************************************************************************/
368extern evxErrors cvxRootInqAsm(char* Name, int nBytes);
369
370/******************************************************************************/
388extern evxErrors cvxRootInqMod(int* Mod);
389
390/******************************************************************************/
412extern evxErrors cvxRootInqModByName(const vxLongPath fileName,const vxRootName rootName, int* mod);
413
414/******************************************************************************/
432extern evxErrors cvxRootInqModSinceRegen(int* Mod);
433
434/******************************************************************************/
457extern evxErrors cvxRootInqSymbol(const vxLongPath file, int* iCount, vxRootName** names);
458
459/******************************************************************************/
474extern evxErrors cvxRootIsAsm(const vxLongPath File,const vxRootName Part, int* isAsm);
475
476/******************************************************************************/
502extern evxErrors cvxRootList(const vxLongPath File, int* Count, vxRootName** Names);
503
504/******************************************************************************/
514extern evxPreviewMode cvxRootPreviewGet(void);
515
516/******************************************************************************/
529extern void cvxRootPreviewSet(evxPreviewMode Mode,const vxLongPath File,vxRootName Object);
530
531/******************************************************************************/
546extern void cvxRootTemplateFile(const vxLongPath File);
547
548
549//====================================================================================================================
551//====================================================================================================================
552/******************************************************************************/
578extern evxErrors cvxRootRename(vxRootName Name, vxRootName NewName, int Update);
579
580/******************************************************************************/
607extern evxErrors cvxRootRename2(vxRootName Name, vxRootName NewName, char* Descript, int Update);
608
609
610/******************************************************************************/
651extern evxErrors cvxRootRenameMulti(int Count, const vxPath* FileName, const vxRootName* RootName, const vxPath* NewFileName, const vxRootName* NewRootName, int fDelOriginal);
652/******************************************************************************/
698extern evxErrors cvxRootRenameMultiByLongPath(int Count, const vxLongPath* FileName, const vxRootName* RootName,const vxLongPath* NewFileName, const vxRootName* NewRootName, int fDelOriginal);
699
700
701//====================================================================================================================
703//====================================================================================================================
704/******************************************************************************/
734extern evxErrors cvxRootVarGet(vxRootName Name, svxVariable* Variable);
735
736/******************************************************************************/
798extern evxErrors cvxRootVarSet(vxRootName Name, int Count, svxVariable* Var, int Working);
799
800
801//====================================================================================================================
803//====================================================================================================================
804/******************************************************************************/
824extern void cvxRootVisibility(vxRootName Name, int Visible);
825
826/******************************************************************************/
843extern evxErrors cvxRootInqSheetMetal(const vxLongPath file, const vxRootName part, int* shtMetal);
844
845/******************************************************************************/
893extern evxErrors cvxRootAtItemGet(const vxLongPath file,const vxRootName root, evxAtItemId itemId, svxAttribute* at);
894
895/******************************************************************************/
941extern evxErrors cvxRootAtItemSet(const vxLongPath file,const vxRootName root, evxAtItemId itemId, svxAttribute* at);
942
943/******************************************************************************/
961extern evxErrors cvxRootCustomDataSet(const vxLongPath file, vxRootName objectName, char* data, int dataLength);
962
963/******************************************************************************/
983extern evxErrors cvxRootCustomDataGet(const vxLongPath file, const vxRootName objectName, char** data, int* dataLength);
984
985/******************************************************************************/
999extern evxErrors cvxRootCustomDataDel(const vxLongPath file, vxRootName objectName);
1000
1001/******************************************************************************/
1019extern evxErrors cvxRootCustomDataAdd(const vxLongPath file, const vxRootName root, const char* data, int* idCustomData);
1020
1021/******************************************************************************/
1043extern evxErrors cvxRootInqCustomData(const vxLongPath file, const vxRootName root, int* count, int** idCustomDatas);
1044
1045/******************************************************************************/
1081extern evxErrors cvxRootCustomDataGetAll(const vxLongPath file, const vxRootName root, int* count, char*** data);
1082
1083/******************************************************************************/
1106extern evxErrors cvxRootCustomDataGetById(const vxLongPath file, const vxRootName root, int idCustomData, char** data);
1107
1108/******************************************************************************/
1127extern evxErrors cvxRootCustomDataModById(const vxLongPath file, const vxRootName root, int idCustomData, const char* data);
1128
1129/******************************************************************************/
1146extern evxErrors cvxRootCustomDataDelById(const vxLongPath file, const vxRootName root, int count, const int* idCustomDatas);
1147
1148//====================================================================================================================
1150//====================================================================================================================
1151
1156typedef struct svxRootSepData
1157 {
1158 int cntRoots;
1159 vxLongName* roots;
1160 int keep;
1161 int oneObj;
1162 int openSepFile;
1163 vxPath dir;
1164 int option;
1165 vxLongName name;
1166 } svxRootSepData;
1167
1168/******************************************************************************/
1186extern evxErrors cvxRootSeparate(svxRootSepData* data);
1187
1188/******************************************************************************/
1203extern evxErrors cvxRootSeparateInit(svxRootSepData* data);
1204
1205/*
1206*********************************************************************
1207** END HEADER FILE
1208*********************************************************************
1209*/
1210
1211#ifdef __cplusplus
1212 }
1213#endif /* __cplusplus */
1214
1215#endif /* Zw_API_ROOT_H */
cvxRootCustomDataModById
evxErrors cvxRootCustomDataModById(const vxLongPath file, const vxRootName root, int idCustomData, const char *data)
cvxRootInqAsm
evxErrors cvxRootInqAsm(char *Name, int nBytes)
cvxRootCustomDataDel
evxErrors cvxRootCustomDataDel(const vxLongPath file, vxRootName objectName)
cvxRootInqModByName
evxErrors cvxRootInqModByName(const vxLongPath fileName, const vxRootName rootName, int *mod)
cvxRootInqCustomData
evxErrors cvxRootInqCustomData(const vxLongPath file, const vxRootName root, int *count, int **idCustomDatas)
cvxRootCustomDataGetAll
evxErrors cvxRootCustomDataGetAll(const vxLongPath file, const vxRootName root, int *count, char ***data)
cvxRootDel
evxErrors cvxRootDel(vxRootName Name)
cvxRootRenameMulti
evxErrors cvxRootRenameMulti(int Count, const vxPath *FileName, const vxRootName *RootName, const vxPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)
cvxRootIsAsm
evxErrors cvxRootIsAsm(const vxLongPath File, const vxRootName Part, int *isAsm)
cvxRootSeparate
evxErrors cvxRootSeparate(svxRootSepData *data)
cvxRootAdd2Bg
int cvxRootAdd2Bg(evxRootType Type, vxRootName Name)
cvxRootList
evxErrors cvxRootList(const vxLongPath File, int *Count, vxRootName **Names)
cvxRootAtItemGet
evxErrors cvxRootAtItemGet(const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
cvxRootInqMod
evxErrors cvxRootInqMod(int *Mod)
cvxRootInqSymbol
evxErrors cvxRootInqSymbol(const vxLongPath file, int *iCount, vxRootName **names)
cvxRootInqModSinceRegen
evxErrors cvxRootInqModSinceRegen(int *Mod)
cvxRootVarGet
evxErrors cvxRootVarGet(vxRootName Name, svxVariable *Variable)
cvxRootAdd
evxErrors cvxRootAdd(evxRootType Type, vxRootName Name, const char *Template)
cvxRootAdd2
evxErrors cvxRootAdd2(evxRootType, vxRootName Name, const char *Template, char *Description)
cvxRootInqSheetMetal
evxErrors cvxRootInqSheetMetal(const vxLongPath file, const vxRootName part, int *shtMetal)
cvxRootTemplateFile
void cvxRootTemplateFile(const vxLongPath File)
cvxRootId
evxErrors cvxRootId(vxRootName Name, int *idRoot, evxRootType *Type)
cvxRootVisibility
void cvxRootVisibility(vxRootName Name, int Visible)
evxPreviewMode
evxPreviewMode
root object preview mode
Definition: zwapi_root.h:50
VX_PREVIEW_ATTRIB
@ VX_PREVIEW_ATTRIB
attribute
Definition: zwapi_root.h:53
VX_PREVIEW_GEOM
@ VX_PREVIEW_GEOM
geom
Definition: zwapi_root.h:52
VX_PREVIEW_OFF
@ VX_PREVIEW_OFF
off
Definition: zwapi_root.h:51
cvxRootActivateLoadAsmCtx
evxErrors cvxRootActivateLoadAsmCtx(const vxLongPath File, const vxRootName Name, int isLoad)
cvxRootCustomDataGetById
evxErrors cvxRootCustomDataGetById(const vxLongPath file, const vxRootName root, int idCustomData, char **data)
cvxRootRename
evxErrors cvxRootRename(vxRootName Name, vxRootName NewName, int Update)
evxRootType
evxRootType
root object type
Definition: zwapi_root.h:31
VX_ROOT_PART_NEW
@ VX_ROOT_PART_NEW
part
Definition: zwapi_root.h:34
VX_ROOT_CAM_PLAN
@ VX_ROOT_CAM_PLAN
cam plan
Definition: zwapi_root.h:39
VX_ROOT_PART
@ VX_ROOT_PART
part
Definition: zwapi_root.h:33
VX_ROOT_SHEET
@ VX_ROOT_SHEET
sheet
Definition: zwapi_root.h:35
VX_ROOT_DRAWING
@ VX_ROOT_DRAWING
drawing
Definition: zwapi_root.h:36
VX_ROOT_SKETCH
@ VX_ROOT_SKETCH
sketch
Definition: zwapi_root.h:37
VX_ROOT_EQUATION_SET
@ VX_ROOT_EQUATION_SET
eqution set
Definition: zwapi_root.h:38
cvxRootActivate2
evxErrors cvxRootActivate2(const vxLongPath File, const vxRootName Name)
cvxRootPreviewGet
evxPreviewMode cvxRootPreviewGet(void)
cvxRootCustomDataAdd
evxErrors cvxRootCustomDataAdd(const vxLongPath file, const vxRootName root, const char *data, int *idCustomData)
cvxRootExit
void cvxRootExit(void)
cvxRootCopy
evxErrors cvxRootCopy(const vxLongPath SourceFile, const vxRootName SourceName, const vxLongPath DestFile, vxRootName DestName, int Overwrite, int UpdateUid)
cvxRootVarSet
evxErrors cvxRootVarSet(vxRootName Name, int Count, svxVariable *Var, int Working)
cvxRootCustomDataGet
evxErrors cvxRootCustomDataGet(const vxLongPath file, const vxRootName objectName, char **data, int *dataLength)
cvxRootSeparateInit
evxErrors cvxRootSeparateInit(svxRootSepData *data)
cvxRootRename2
evxErrors cvxRootRename2(vxRootName Name, vxRootName NewName, char *Descript, int Update)
cvxRootPreviewSet
void cvxRootPreviewSet(evxPreviewMode Mode, const vxLongPath File, vxRootName Object)
cvxRootRenameMultiByLongPath
evxErrors cvxRootRenameMultiByLongPath(int Count, const vxLongPath *FileName, const vxRootName *RootName, const vxLongPath *NewFileName, const vxRootName *NewRootName, int fDelOriginal)
cvxRootCustomDataDelById
evxErrors cvxRootCustomDataDelById(const vxLongPath file, const vxRootName root, int count, const int *idCustomDatas)
cvxRootActivate
evxErrors cvxRootActivate(vxRootName Name)
cvxRootInqActive
void cvxRootInqActive(char *Name, int nBytes)
cvxRootAtItemSet
evxErrors cvxRootAtItemSet(const vxLongPath file, const vxRootName root, evxAtItemId itemId, svxAttribute *at)
cvxRootCustomDataSet
evxErrors cvxRootCustomDataSet(const vxLongPath file, vxRootName objectName, char *data, int dataLength)
svxRootSepData
struct svxRootSepData svxRootSepData
separate root to file
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxRootSepData::dir
vxPath dir
save directory of separate files
Definition: zwapi_root.h:1163
svxRootSepData::keep
int keep
1 is keep the objects in original file, else 0.default:1
Definition: zwapi_root.h:1160
svxRootSepData::option
int option
when the file name is repeated, 0 is auto rename, 1 is manual rename, 2 is skip.default:0
Definition: zwapi_root.h:1164
svxRootSepData::name
vxLongName name
file name.apply it if option=1.
Definition: zwapi_root.h:1165
svxRootSepData::cntRoots
int cntRoots
count of roots
Definition: zwapi_root.h:1158
svxRootSepData::openSepFile
int openSepFile
1 is open the separate files,else 0. default:0
Definition: zwapi_root.h:1162
svxRootSepData::oneObj
int oneObj
1 is one object per file, else 0. default:1
Definition: zwapi_root.h:1161
svxRootSepData::roots
vxLongName * roots
list of root
Definition: zwapi_root.h:1159
svxRootSepData
separate root to file
Definition: zwapi_root.h:1157
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_AT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_attribute.h

◆ ZW_API_SK_AT_H

#define ZW_API_SK_AT_H

Definition at line 15 of file zwapi_sk_attribute.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_attribute.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_attribute.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SK_AT_H /* this ifndef surrounds entire header */
15#define ZW_API_SK_AT_H
16
17#ifdef __cplusplus
18extern "C" {
19#endif /* __cplusplus */
20
21/**********************************************************************
22*! -Feature Attribute- : zwapi_part_history.h
23* extern int cvxPartFtrUserAtGet(int idFeature, int *Count, svxAttribute** UserAt);
24* extern int cvxPartFtrUserAtSet(int idFeature, int Count, svxAttribute* UserAt);
25* extern int cvxPartFtrUserAtDel(int idFeature, int Count, svxAttribute* UserAt);
26**********************************************************************/
27/*
28*********************************************************************
29** END HEADER FILE
30*********************************************************************
31*/
32
33#ifdef __cplusplus
34 }
35#endif /* __cplusplus */
36
37#endif /* ZW_API_SK_AT_H */
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_data.h

◆ ZW_API_SK_DATA_H

#define ZW_API_SK_DATA_H

Definition at line 17 of file zwapi_sk_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_SK_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_SK_DATA_H
18
19#include "zwapi_util.h"
20#include "zwapi_cmd_sk_cmds_data.h"
21
22#ifdef __cplusplus
23extern "C" {
24#endif /* __cplusplus */
25
26/*
27*********************************************************************
28** END HEADER FILE
29*********************************************************************
30*/
31
32#ifdef __cplusplus
33 }
34#endif /* __cplusplus */
35
36#endif /* ZW_API_SK_DATA_H */
zwapi_cmd_sk_cmds_data.h
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_DIM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_dim.h
cvxSkInqDim
cvxSkInqDimRefFlag
cvxSkInqDimType

◆ ZW_API_SK_DIM_H

#define ZW_API_SK_DIM_H

Definition at line 15 of file zwapi_sk_dim.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_dim.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_dim.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SK_DIM_H /* this ifndef surrounds entire header */
15#define ZW_API_SK_DIM_H
16
17#include "zwapi_sk_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxSkInqDim(int* Count, int** idEnts);
46
47/******************************************************************************/
65extern evxErrors cvxSkInqDimType(int idDim, evxConsDimType* type);
66
67/******************************************************************************/
86extern evxErrors cvxSkInqDimRefFlag(int idDim, int* refFlag);
87
88
89/*
90*********************************************************************
91** END HEADER FILE
92*********************************************************************
93*/
94
95#ifdef __cplusplus
96 }
97#endif /* __cplusplus */
98
99#endif /* ZW_API_SK_DIM_H */
evxConsDimType
evxConsDimType
type of sketch constraint dimension
Definition: zwapi_cmd_sk_cmds_data.h:568
cvxSkInqDimType
evxErrors cvxSkInqDimType(int idDim, evxConsDimType *type)
cvxSkInqDim
evxErrors cvxSkInqDim(int *Count, int **idEnts)
cvxSkInqDimRefFlag
evxErrors cvxSkInqDimRefFlag(int idDim, int *refFlag)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_sk_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_objs.h
cvxReadyTextFree
cvxSkActivate
cvxSkBlockActivate
cvxSkBlockGetSketch
cvxSkBlockInqDim
cvxSkBlockInqGeom
cvxSkBlockInqGeomX
cvxSkBlockInqPnt
cvxSkBlockInqRefs
cvxSkBlockRefGetDefinition
cvxSkEntWireType
cvxSkInqAllAxis
cvxSkInqAllAxisById
cvxSkInqArea
cvxSkInqAxis
cvxSkInqAxisDir
cvxSkInqBlockReferences
cvxSkInqCns
cvxSkInqCnsById
cvxSkInqCnsGeoms
cvxSkInqCnsType
cvxSkInqCrvConnect
cvxSkInqExternalSk
cvxSkInqExternalSkByLongPath
cvxSkInqGeom
cvxSkInqGeomById
cvxSkInqGeomX
cvxSkInqGeomXById
cvxSkInqPlane
cvxSkInqPlanes
cvxSkInqPnt
cvxSkInqPntById
cvxSkInqReadyText
cvxSkInqRef
cvxSkInqRefById
cvxSkInqSketchBlocks
cvxSkInqText
cvxSkInqTextById
cvxSkIsCosmetic
cvxSkIsExternal
cvxSkReadyTextInqCrvs
cvxSkReadyTextInqText
cvxSkReadyTextModText
cvxSkSetWireType

◆ ZW_API_SK_H

#define ZW_API_SK_H

Definition at line 14 of file zwapi_sk_objs.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_objs.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_objs.h
Go to the documentation of this file.
1
12#pragma once
13#ifndef ZW_API_SK_H /* this ifndef surrounds entire header */
14#define ZW_API_SK_H
15
16#include "zwapi_sk_data.h"
17
18#ifdef __cplusplus
19extern "C" {
20#endif /* __cplusplus */
21
22//====================================================================================================================
24//====================================================================================================================
25/******************************************************************************/
42extern int cvxSkInqPlane(int idSketch, svxEntPath* plnPath);
43
44/******************************************************************************/
79extern evxErrors cvxSkInqPlanes(int idSketch, int* count, int** idFaces);
80
81/******************************************************************************/
94extern int cvxSkIsCosmetic(int IdSketch);
95
96/******************************************************************************/
111extern int cvxSkIsExternal(int IdSketch);
112
113/******************************************************************************/
136extern evxErrors cvxSkInqExternalSk(int idSketch, vxPath fileName, vxRootName rootName, vxLongName skName);
137
138/******************************************************************************/
167extern evxErrors cvxSkInqExternalSkByLongPath(int idSketch, char* fileName,int sizefile , vxRootName rootName, vxLongName skName);
168
169/******************************************************************************/
193extern int cvxSkInqArea(int nCrv, int* idCrvs, svxPoint2* innerPnt, svxPrfAreaProp* aboutCM, svxPrfAreaProp* aboutRf);
194
195/******************************************************************************/
216extern evxErrors cvxSkActivate(int idSketch, int UpdateGUI);
217
218
219//====================================================================================================================
221//====================================================================================================================
222/******************************************************************************/
241extern evxErrors cvxSkInqAxis(int idSketch, int* xAxis, int* yAxis);
242
243/******************************************************************************/
261extern evxErrors cvxSkInqAllAxis(int* Count, int** idEnts);
262
263/******************************************************************************/
282extern evxErrors cvxSkInqAllAxisById(int idSketch, int* count, int** idEnts);
283
284/******************************************************************************/
300extern evxErrors cvxSkInqAxisDir(int idAxis, svxPoint2* pPnt, svxPoint2* pDir);
301
302/******************************************************************************/
322extern evxErrors cvxSkInqGeom(int* Count, int** idEnts);
323
324/******************************************************************************/
345extern evxErrors cvxSkInqGeomById(int idSketch, int* count, int** idEnts);
346
347/******************************************************************************/
367extern evxErrors cvxSkInqGeomX(int* Count, int** idEnts);
368
369/******************************************************************************/
390extern evxErrors cvxSkInqGeomXById(int idSketch, int* count, int** idEnts);
391
392/******************************************************************************/
412extern evxErrors cvxSkInqPnt(int* Count, int** idEnts);
413
414/******************************************************************************/
435extern evxErrors cvxSkInqPntById(int idSketch, int* count, int** idEnts);
436
437/******************************************************************************/
457extern evxErrors cvxSkInqRef(int* Count, int** idEnts);
458
459/******************************************************************************/
480extern evxErrors cvxSkInqRefById(int idSketch, int* count, int** idEnts);
481
482/******************************************************************************/
502extern evxErrors cvxSkInqText(int* Count, int** idEnts);
503
504/******************************************************************************/
525extern evxErrors cvxSkInqTextById(int idSketch, int* count, int** idEnts);
526
527/******************************************************************************/
547extern evxErrors cvxSkInqCns(int* Count, int** idEnts);
548
549/******************************************************************************/
570extern evxErrors cvxSkInqCnsById(int idSketch, int* count, int** idEnts);
571
572
573//====================================================================================================================
575//====================================================================================================================
576/******************************************************************************/
593extern evxErrors cvxSkInqCrvConnect(int iCount, int* idCrvs, int* iUnMatch, int* iOverMatch);
594
595/******************************************************************************/
613extern evxErrors cvxSkEntWireType(int entId, int* type);
614
615/******************************************************************************/
636extern evxErrors cvxSkSetWireType(int nEnt, int* idEnt, int type);
637
638
639//====================================================================================================================
641//====================================================================================================================
642/******************************************************************************/
663extern evxErrors cvxSkInqReadyText(int idSketch, int* Count, int** idEnts);
664
665/******************************************************************************/
686extern evxErrors cvxSkReadyTextInqCrvs(int idRdText, int* Count, int** idCrvs);
687
688/******************************************************************************/
710extern evxErrors cvxSkReadyTextInqText(int idRdText, svxReadyText* RdText);
711
712/******************************************************************************/
729extern evxErrors cvxSkReadyTextModText(int idRdText, svxReadyText* RdText);
730
731/******************************************************************************/
742extern void cvxReadyTextFree(svxReadyText* RdText);
743
744
745//====================================================================================================================
747//====================================================================================================================
748/******************************************************************************/
770extern evxErrors cvxSkInqBlockReferences(int idSketch, int* Count, int** idEnts);
771
772/******************************************************************************/
791extern evxErrors cvxSkInqSketchBlocks(int* Count, int** idEnts, vxRootName** Names);
792
793/******************************************************************************/
817extern evxErrors cvxSkBlockActivate(int idBlock, int UpdateGUI);
818
819/******************************************************************************/
840extern evxErrors cvxSkBlockGetSketch(int idBlock, int* idSketch);
841
842/******************************************************************************/
861extern evxErrors cvxSkBlockRefGetDefinition(int idRef, int* idBlock);
862
863/******************************************************************************/
884extern evxErrors cvxSkBlockInqGeom(const vxRootName blockName, int* Count, int** idEnts);
885
886/******************************************************************************/
907extern evxErrors cvxSkBlockInqPnt(const vxRootName blockName, int* Count, int** idEnts);
908
909/******************************************************************************/
930extern evxErrors cvxSkBlockInqDim(const vxRootName blockName, int* Count, int** idEnts);
931
932/******************************************************************************/
953extern evxErrors cvxSkBlockInqGeomX(const vxRootName blockName, int* Count, int** idEnts);
954
955/******************************************************************************/
973extern evxErrors cvxSkBlockInqRefs(int idBlock, int* count, int** idEnts);
974
975
976//====================================================================================================================
978//====================================================================================================================
979/******************************************************************************/
1002extern evxErrors cvxSkInqCnsType(int idCons, evxGeomConsType* type, int* subType);
1003
1004/******************************************************************************/
1025extern evxErrors cvxSkInqCnsGeoms(int idCons, int* Count, svxConsGeom** geoms);
1026
1027
1028/*
1029*********************************************************************
1030** END HEADER FILE
1031*********************************************************************
1032*/
1033
1034#ifdef __cplusplus
1035 }
1036#endif /* __cplusplus */
1037
1038#endif /* ZW_API_SK_H */
evxGeomConsType
evxGeomConsType
type of sketch geometry constraint
Definition: zwapi_cmd_sk_cmds_data.h:532
cvxSkReadyTextInqCrvs
evxErrors cvxSkReadyTextInqCrvs(int idRdText, int *Count, int **idCrvs)
cvxSkInqPntById
evxErrors cvxSkInqPntById(int idSketch, int *count, int **idEnts)
cvxSkInqAxis
evxErrors cvxSkInqAxis(int idSketch, int *xAxis, int *yAxis)
cvxReadyTextFree
void cvxReadyTextFree(svxReadyText *RdText)
cvxSkBlockRefGetDefinition
evxErrors cvxSkBlockRefGetDefinition(int idRef, int *idBlock)
cvxSkBlockActivate
evxErrors cvxSkBlockActivate(int idBlock, int UpdateGUI)
cvxSkInqGeomX
evxErrors cvxSkInqGeomX(int *Count, int **idEnts)
cvxSkInqCnsById
evxErrors cvxSkInqCnsById(int idSketch, int *count, int **idEnts)
cvxSkInqRef
evxErrors cvxSkInqRef(int *Count, int **idEnts)
cvxSkReadyTextModText
evxErrors cvxSkReadyTextModText(int idRdText, svxReadyText *RdText)
cvxSkIsCosmetic
int cvxSkIsCosmetic(int IdSketch)
cvxSkReadyTextInqText
evxErrors cvxSkReadyTextInqText(int idRdText, svxReadyText *RdText)
cvxSkInqGeomXById
evxErrors cvxSkInqGeomXById(int idSketch, int *count, int **idEnts)
cvxSkInqAllAxis
evxErrors cvxSkInqAllAxis(int *Count, int **idEnts)
cvxSkInqCnsType
evxErrors cvxSkInqCnsType(int idCons, evxGeomConsType *type, int *subType)
cvxSkInqArea
int cvxSkInqArea(int nCrv, int *idCrvs, svxPoint2 *innerPnt, svxPrfAreaProp *aboutCM, svxPrfAreaProp *aboutRf)
cvxSkInqText
evxErrors cvxSkInqText(int *Count, int **idEnts)
cvxSkInqExternalSk
evxErrors cvxSkInqExternalSk(int idSketch, vxPath fileName, vxRootName rootName, vxLongName skName)
cvxSkInqCrvConnect
evxErrors cvxSkInqCrvConnect(int iCount, int *idCrvs, int *iUnMatch, int *iOverMatch)
cvxSkInqPnt
evxErrors cvxSkInqPnt(int *Count, int **idEnts)
cvxSkSetWireType
evxErrors cvxSkSetWireType(int nEnt, int *idEnt, int type)
cvxSkBlockGetSketch
evxErrors cvxSkBlockGetSketch(int idBlock, int *idSketch)
cvxSkInqBlockReferences
evxErrors cvxSkInqBlockReferences(int idSketch, int *Count, int **idEnts)
cvxSkActivate
evxErrors cvxSkActivate(int idSketch, int UpdateGUI)
cvxSkInqAxisDir
evxErrors cvxSkInqAxisDir(int idAxis, svxPoint2 *pPnt, svxPoint2 *pDir)
cvxSkInqPlanes
evxErrors cvxSkInqPlanes(int idSketch, int *count, int **idFaces)
cvxSkInqGeom
evxErrors cvxSkInqGeom(int *Count, int **idEnts)
cvxSkEntWireType
evxErrors cvxSkEntWireType(int entId, int *type)
cvxSkBlockInqPnt
evxErrors cvxSkBlockInqPnt(const vxRootName blockName, int *Count, int **idEnts)
cvxSkInqReadyText
evxErrors cvxSkInqReadyText(int idSketch, int *Count, int **idEnts)
cvxSkInqCns
evxErrors cvxSkInqCns(int *Count, int **idEnts)
cvxSkBlockInqGeom
evxErrors cvxSkBlockInqGeom(const vxRootName blockName, int *Count, int **idEnts)
cvxSkInqCnsGeoms
evxErrors cvxSkInqCnsGeoms(int idCons, int *Count, svxConsGeom **geoms)
cvxSkBlockInqRefs
evxErrors cvxSkBlockInqRefs(int idBlock, int *count, int **idEnts)
cvxSkInqSketchBlocks
evxErrors cvxSkInqSketchBlocks(int *Count, int **idEnts, vxRootName **Names)
cvxSkInqExternalSkByLongPath
evxErrors cvxSkInqExternalSkByLongPath(int idSketch, char *fileName, int sizefile, vxRootName rootName, vxLongName skName)
cvxSkBlockInqDim
evxErrors cvxSkBlockInqDim(const vxRootName blockName, int *Count, int **idEnts)
cvxSkBlockInqGeomX
evxErrors cvxSkBlockInqGeomX(const vxRootName blockName, int *Count, int **idEnts)
cvxSkInqPlane
int cvxSkInqPlane(int idSketch, svxEntPath *plnPath)
cvxSkInqTextById
evxErrors cvxSkInqTextById(int idSketch, int *count, int **idEnts)
cvxSkIsExternal
int cvxSkIsExternal(int IdSketch)
cvxSkInqAllAxisById
evxErrors cvxSkInqAllAxisById(int idSketch, int *count, int **idEnts)
cvxSkInqGeomById
evxErrors cvxSkInqGeomById(int idSketch, int *count, int **idEnts)
cvxSkInqRefById
evxErrors cvxSkInqRefById(int idSketch, int *count, int **idEnts)
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxConsGeom
data of sketch geometry constraint object
Definition: zwapi_cmd_sk_cmds_data.h:504
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPrfAreaProp
profile area property
Definition: zwapi_util.h:1211
svxReadyText
data of ready sketch text
Definition: zwapi_cmd_sk_cmds_data.h:121
zwapi_sk_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_OPTS_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_opts.h
cvxSkRegen

◆ ZW_API_SK_OPTS_H

#define ZW_API_SK_OPTS_H

Definition at line 15 of file zwapi_sk_opts.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_opts.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_opts.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SK_OPTS_H /* this ifndef surrounds entire header */
15#define ZW_API_SK_OPTS_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
33extern void cvxSkRegen();
34
35
36/*
37*********************************************************************
38** END HEADER FILE
39*********************************************************************
40*/
41
42#ifdef __cplusplus
43 }
44#endif /* __cplusplus */
45
46#endif /* ZW_API_SK_OPTS_H */
cvxSkRegen
void cvxSkRegen()
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SK_VAR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_sk_var.h
cvxSkInqVars
cvxSkVarAdd
cvxSkVarGet
cvxSkVarSet

◆ ZW_API_SK_VAR_H

#define ZW_API_SK_VAR_H

Definition at line 15 of file zwapi_sk_var.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_sk_var.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_sk_var.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SK_VAR_H /* this ifndef surrounds entire header */
15#define ZW_API_SK_VAR_H
16
17#include "zwapi_sk_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxSkVarAdd(svxVariable* Variable);
44
45/******************************************************************************/
67extern evxErrors cvxSkVarGet(svxVariable* Variable);
68
69/******************************************************************************/
86extern evxErrors cvxSkVarSet(int Count, svxVariable* Variables);
87
88/******************************************************************************/
106extern evxErrors cvxSkInqVars(int* Count, svxVariable** Variables);
107
108
109/*
110*********************************************************************
111** END HEADER FILE
112*********************************************************************
113*/
114
115#ifdef __cplusplus
116 }
117#endif /* __cplusplus */
118
119#endif /* ZW_API_SK_VAR_H */
cvxSkInqVars
evxErrors cvxSkInqVars(int *Count, svxVariable **Variables)
cvxSkVarSet
evxErrors cvxSkVarSet(int Count, svxVariable *Variables)
cvxSkVarGet
evxErrors cvxSkVarGet(svxVariable *Variable)
cvxSkVarAdd
evxErrors cvxSkVarAdd(svxVariable *Variable)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxVariable
numeric variable
Definition: zwapi_util.h:1122
zwapi_sk_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TEXT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_text.h
cvxEntTextAtGet
cvxEntTextAtSet
cvxEntTextInq
cvxEntTextLocGet
cvxEntTextMod
svxTextLoc

◆ ZW_API_TEXT_H

#define ZW_API_TEXT_H

Definition at line 15 of file zwapi_text.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_text.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_text.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TEXT_H /* this ifndef surrounds entire header */
15#define ZW_API_TEXT_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef struct svxTextLoc
31 {
32 unsigned char mirror;
33 float text_radius;
34 float scale;
35 svxPoint2f origin_point;
36 svxPoint2f align_point;
37 svxPoint2f mirror_axis[2];
38 svxPoint2f bbox[2];
39 }svxTextLoc;
40
41//====================================================================================================================
43//====================================================================================================================
44/******************************************************************************/
76extern evxErrors cvxEntTextInq(int idText, char** Text);
77
78/******************************************************************************/
96extern evxErrors cvxEntTextMod(int idText, char* Text);
97
98/******************************************************************************/
115extern evxErrors cvxEntTextAtGet(int idText, svxTextAt* At);
116
117/******************************************************************************/
134extern evxErrors cvxEntTextAtSet(int idText, svxTextAt* At);
135
136/******************************************************************************/
152extern evxErrors cvxEntTextLocGet(int idText, svxTextLoc* loc);
153
154
155/*
156*********************************************************************
157** END HEADER FILE
158*********************************************************************
159*/
160
161#ifdef __cplusplus
162 }
163#endif /* __cplusplus */
164
165#endif /* ZW_API_TEXT_H */
cvxEntTextLocGet
evxErrors cvxEntTextLocGet(int idText, svxTextLoc *loc)
cvxEntTextMod
evxErrors cvxEntTextMod(int idText, char *Text)
cvxEntTextAtSet
evxErrors cvxEntTextAtSet(int idText, svxTextAt *At)
cvxEntTextAtGet
evxErrors cvxEntTextAtGet(int idText, svxTextAt *At)
cvxEntTextInq
evxErrors cvxEntTextInq(int idText, char **Text)
svxTextLoc
struct svxTextLoc svxTextLoc
text location
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxPoint2f
2D point(single precision floating point)
Definition: zwapi_util.h:296
svxTextAt
text attribute
Definition: zwapi_util.h:1454
svxTextLoc::bbox
svxPoint2f bbox[2]
two points defining text bounding box
Definition: zwapi_text.h:38
svxTextLoc::origin_point
svxPoint2f origin_point
text origin point
Definition: zwapi_text.h:35
svxTextLoc::text_radius
float text_radius
radius of arc that the text follows
Definition: zwapi_text.h:33
svxTextLoc::mirror
unsigned char mirror
mirror flag 0-normal , 1-mirror
Definition: zwapi_text.h:32
svxTextLoc::align_point
svxPoint2f align_point
text alignment point
Definition: zwapi_text.h:36
svxTextLoc::scale
float scale
text scale factor
Definition: zwapi_text.h:34
svxTextLoc::mirror_axis
svxPoint2f mirror_axis[2]
two points defining mirror axis
Definition: zwapi_text.h:37
svxTextLoc
text location
Definition: zwapi_text.h:31
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TOOL_ENTPATH_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_tool_entpath.h
cvxEntPathAppendEnt
cvxEntPathAppendPath
cvxEntPathCmp
cvxEntPathGetParentComp
cvxEntPathInit
cvxEntPathInqActive
cvxEntPathToRoot

◆ ZW_API_TOOL_ENTPATH_H

#define ZW_API_TOOL_ENTPATH_H

Definition at line 15 of file zwapi_tool_entpath.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_tool_entpath.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_tool_entpath.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TOOL_ENTPATH_H /* this ifndef surrounds entire header */
15#define ZW_API_TOOL_ENTPATH_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
44extern evxErrors cvxEntPathInit(int idEntity, int idParent, svxEntPath* entPath);
45
46/******************************************************************************/
59extern evxErrors cvxEntPathInqActive(svxEntPath* entPath);
60
61/******************************************************************************/
76extern evxErrors cvxEntPathAppendEnt(svxEntPath* entPath, int idEntity);
77
78/******************************************************************************/
93extern evxErrors cvxEntPathAppendPath(svxEntPath* dstPath, const svxEntPath *srcPath);
94
95/******************************************************************************/
114extern evxErrors cvxEntPathToRoot(svxEntPath* EntPath);
115
116/******************************************************************************/
132extern int cvxEntPathCmp(const svxEntPath* EntPath1, const svxEntPath* EntPath2);
133
134/******************************************************************************/
150extern int cvxEntPathGetParentComp(const svxEntPath* entPath, svxEntPath* parentComp);
151
152
153#ifdef __cplusplus
154 }
155#endif /* __cplusplus */
156#endif /* ZW_API_TOOL_ENTPATH_H */
cvxEntPathInqActive
evxErrors cvxEntPathInqActive(svxEntPath *entPath)
cvxEntPathInit
evxErrors cvxEntPathInit(int idEntity, int idParent, svxEntPath *entPath)
cvxEntPathToRoot
evxErrors cvxEntPathToRoot(svxEntPath *EntPath)
cvxEntPathAppendPath
evxErrors cvxEntPathAppendPath(svxEntPath *dstPath, const svxEntPath *srcPath)
cvxEntPathCmp
int cvxEntPathCmp(const svxEntPath *EntPath1, const svxEntPath *EntPath2)
cvxEntPathAppendEnt
evxErrors cvxEntPathAppendEnt(svxEntPath *entPath, int idEntity)
cvxEntPathGetParentComp
int cvxEntPathGetParentComp(const svxEntPath *entPath, svxEntPath *parentComp)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_COMBOBOX_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_combobox.h
cvxComboCurrentItem
cvxComboCurrentText
cvxComboCurrentTextSet
cvxComboItemCount
cvxComboSetCurrentItem

◆ ZW_API_COMBOBOX_H

#define ZW_API_COMBOBOX_H

Definition at line 15 of file zwapi_ui_combobox.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_combobox.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_combobox.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_COMBOBOX_H /* this ifndef surrounds entire header */
15#define ZW_API_COMBOBOX_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
44extern evxErrors cvxComboCurrentItem(const char* sForm, int fldId, int* curIdx);
45
46/******************************************************************************/
63extern evxErrors cvxComboSetCurrentItem(const char* sForm, int field, int item);
64
65/******************************************************************************/
84extern evxErrors cvxComboCurrentText(const char* sForm, int idField, char* text, int sizeText);
85
86/******************************************************************************/
103extern evxErrors cvxComboCurrentTextSet(const char* sForm, int idField, const char* text);
104
105/******************************************************************************/
123extern evxErrors cvxComboItemCount(const char* sForm, int idField, int* count);
124
125/*
126*********************************************************************
127** END HEADER FILE
128*********************************************************************
129*/
130
131#ifdef __cplusplus
132 }
133#endif /* __cplusplus */
134
135#endif /* ZW_API_COMBOBOX_H */
cvxComboCurrentTextSet
evxErrors cvxComboCurrentTextSet(const char *sForm, int idField, const char *text)
cvxComboSetCurrentItem
evxErrors cvxComboSetCurrentItem(const char *sForm, int field, int item)
cvxComboCurrentText
evxErrors cvxComboCurrentText(const char *sForm, int idField, char *text, int sizeText)
cvxComboItemCount
evxErrors cvxComboItemCount(const char *sForm, int idField, int *count)
cvxComboCurrentItem
evxErrors cvxComboCurrentItem(const char *sForm, int fldId, int *curIdx)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_UI_DATA_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_data.h
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ ZW_API_UI_DATA_H

#define ZW_API_UI_DATA_H

Definition at line 17 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: VX_INVALID_ITEM

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_data.h
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ VX_INVALID_ITEM

#define VX_INVALID_ITEM ((vxTreeItemId)-1)

Definition at line 476 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: VX_INSERT_LAST

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_data.h
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ VX_INSERT_LAST

#define VX_INSERT_LAST ((vxTreeItemId)-1) /* Insert at last position */

Definition at line 478 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: VX_INSERT_FIRST

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_data.h
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ VX_INSERT_FIRST

#define VX_INSERT_FIRST ((vxTreeItemId)0) /* Insert node at first position */

Definition at line 479 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: VX_INVISIBLE_ROOT_ITEM

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_data.h
evxAlignFlag
evxAlignFlag
evxCmdFldClass
evxCmdFldClass
evxCursorType
evxCursorType
evxDateType
evxDateType
evxFormAction
evxFormAction
evxFormAddTo
evxFormAddTo
evxFormFldClass
evxFormFldClass
evxTableAlignFlag
evxTableAlignFlag
evxTableCellType
evxTableCellType
evxTableEvent
evxTableEvent
evxTableResizeMode
evxTableResizeMode
evxTreeCheckState
evxTreeCheckState
evxTreeEvent
evxTreeHitPos
evxTreeHitPos
evxTreeItemFlag
evxTreeItemFlag
evxTreeItemType
evxTreeItemType
evxUiEvt
evxUiEvt
svxFormInfo
svxKeyEvent
svxListCallBackParam
svxRectangle
svxTableAt
svxTableCallBackParam
svxTableCellData
svxTplFld
svxTreeCbParam
vxTreeItemId

◆ VX_INVISIBLE_ROOT_ITEM

#define VX_INVISIBLE_ROOT_ITEM ((vxTreeItemId)0)

Definition at line 477 of file zwapi_ui_data.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_data.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_data.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_UI_DATA_H /* this ifndef surrounds entire header */
17#define ZW_API_UI_DATA_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxFormAddTo
33 {
34 VX_FILE_BROWSER,
35 VX_UI_MANAGER,
36 }evxFormAddTo;
37
38//====================================================================================================================
40//====================================================================================================================
45typedef enum evxFormAction
46 {
47 VX_FORM_INIT = -4,
48 VX_FORM_CANCEL = -3,
49 VX_FORM_RESET = -2,
50 VX_FORM_APPLY = -1,
51 VX_FORM_OKAY = 0,
52 VX_FORM_DEFAULT = 1
53 } evxFormAction;
54
60typedef struct svxFormInfo
61 {
62 vxLongName Formname;
63 vxLongName Iconame;
64 vxLongName Labelname;
65 vxPath Tooltips;
66 } svxFormInfo;
67
68//====================================================================================================================
70//====================================================================================================================
75typedef enum evxFormFldClass
76 {
77 VX_FORM_FLD_NULL = -1,
78 VX_FORM_FLD_NUM = 0,
79 VX_FORM_FLD_SLIDER = 1,
80 VX_FORM_FLD_TXT_IN = 2,
81 VX_FORM_FLD_TXT_OUT = 3,
82 VX_FORM_FLD_TXT_BTN = 4,
83 VX_FORM_FLD_TXT_LBL = 5,
84 VX_FORM_FLD_DATA = 6,
85 VX_FORM_FLD_LIST = 7,
86 VX_FORM_FLD_OPT = 8,
87 VX_FORM_FLD_BTNS = 9,
88 VX_FORM_FLD_GROUP = 10,
89 VX_FORM_FLD_LABEL = 11,
90 VX_FORM_FLD_SEPARATOR = 12,
91 VX_FORM_FLD_COLOR = 13,
92 VX_FORM_FLD_TREE = 14,
93 VX_FORM_FLD_COMBO = 15,
94 VX_FORM_FLD_TAB = 16,
95 VX_FORM_FLD_PROGRESS = 17,
96 VX_FORM_FLD_TABLE = 18
97 } evxFormFldClass;
98
103typedef enum evxCmdFldClass
104 {
105 VX_CMD_FLD_NULL = 0,
106 VX_CMD_FLD_TEXT = 1,
107 VX_CMD_FLD_NUM = 2,
108 VX_CMD_FLD_DIST = 3,
109 VX_CMD_FLD_ANGLE = 4,
110 VX_CMD_FLD_POINT = 5,
111 VX_CMD_FLD_ENTITY = 6,
112 VX_CMD_FLD_OPTION = 7,
113 VX_CMD_FLD_CONT = 8,
114 VX_CMD_FLD_FORM = 9,
115 VX_CMD_FLD_WIN = 10,
116 VX_CMD_FLD_CMD = 11,
117 VX_CMD_FLD_PIN = 12,
118 VX_CMD_FLD_OPTGROUP = 13,
119 VX_CMD_FLD_NUMUNIT = 14,
120 VX_CMD_FLD_CUSTOMINPUT = 15,
121 VX_CMD_FLD_PICK = 16,
122 } evxCmdFldClass;
123
128typedef struct svxTplFld
129 {
130 char Name[65];
131 int Id;
132 int Class;
133 void* Callback;
134 } svxTplFld;
135
136//====================================================================================================================
138//====================================================================================================================
143typedef enum evxCursorType
144 {
145 VX_CURSOR_STD = 0,
146 VX_CURSOR_MOUSE = 1,
147 VX_CURSOR_BUSY = 2,
148 VX_CURSOR_WRENCH = 3,
149 VX_CURSOR_PLIERS = 4,
150 VX_CURSOR_SCREW_DRIVER = 5,
151 VX_CURSOR_HAMMER = 6,
152 VX_CURSOR_TOGGLE = 7,
153 VX_CURSOR_HAND = 8,
154 VX_CURSOR_WRENCH_PLUS = 9
155 } evxCursorType;
156
157//====================================================================================================================
159//====================================================================================================================
164typedef enum evxUiEvt
165 {
166 VX_UIEVT_INVALID = -6,
167 VX_UIEVT_HELP = -5,
168 VX_UIEVT_CANCEL = -3,
169 VX_UIEVT_RESET = -2,
170 VX_UIEVT_APPLY = -1,
171 VX_UIEVT_OKAY = 0,
172 VX_UIEVT_DEF = 1,
173 VX_UIEVT_LBTNCLK,
174 VX_UIEVT_LBTNUP = VX_UIEVT_LBTNCLK,
175 VX_UIEVT_MBTNCLK,
176 VX_UIEVT_RBTNCLK,
177 VX_UIEVT_LBTNDCLK,
178 VX_UIEVT_CHAR,
179 VX_UIEVT_FOCUSKILL,
180 VX_UIEVT_SCROLL,
181 VX_UIEVT_HOTKEY,
182 VX_UIEVT_CMDONOFF,
183 VX_UIEVT_FOCUSSET,
184 VX_UIEVT_STRING,
185 VX_UIEVT_HOVER,
186 VX_UIEVT_LBTNDOWN,
187 VX_UIEVT_SORT,
188 VX_UIEVT_DATACHANGE,
189 VX_UIEVT_PREVIEW,
190 VX_UIEVT_SELCHANGED = 19,
191 VX_UIEVT_STATECHANGED,
192 VX_UIEVT_MOUSEMOVE,
193 VX_UIEVT_DROP = 22,
194 VX_UIEVT_IGNORE,
195 } evxUiEvt;
196
201typedef struct svxListCallBackParam
202 {
203 evxUiEvt evt;
204 int iRow;
205 int key;
206 } svxListCallBackParam;
207
208//====================================================================================================================
210//====================================================================================================================
215typedef struct svxTableAt
216 {
217 int Row, Col;
224 int RowHeight;
225 int ColWidth;
227 int SetBgColor;
230 svxColor BgColor;
232 int SetFgColor;
235 svxColor FgColor;
237 int SortRows;
239 int AutoSize;
245 int AllowResize;
250 int Editable;
253 } svxTableAt;
254
259typedef struct svxRectangle
260 {
261 long left;
262 long top;
263 long right;
264 long bottom;
265 }svxRectangle;
266
267//====================================================================================================================
269//====================================================================================================================
274typedef enum evxTableEvent
275 {
276 VX_LEFT_CLICK = 2,
277 VX_RIGHT_CLICK = 4,
278 VX_LEFT_DOUBLE_CLICK,
279 VX_KEY_UP_DOWN,
280 VX_HOT_KEY = 9,
281 VX_SORT = 15,
282 VX_DATA_CHANGED,
283 VX_CELL_BUTTON_CLICKED,
284 VX_MOUSE_MOVE = 21,
285 VX_CELL_CLOSE_EDITOR = 23,
286 } evxTableEvent;
287
292typedef enum evxTableAlignFlag
293 {
294 VX_TABLE_ALIGN_CENTER = 0,
295 VX_TABLE_ALIGN_LEFT = 1,
296 VX_TABLE_ALIGN_RIGHT = 2,
297 } evxTableAlignFlag;
298
303typedef enum evxTableResizeMode
304 {
305 VX_TABLE_RESIZE_MODE_INTERACTIVE = 0,
306 VX_TABLE_RESIZE_MODE_STRETCH = 1,
307 VX_TABLE_RESIZE_MODE_FIXED = 2,
308 VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS = 3,
309 } evxTableResizeMode;
310
315typedef struct svxKeyEvent
316 {
317 unsigned int modifier;
318 unsigned int keyCode;
319 } svxKeyEvent;
320
325typedef enum evxDateType
326 {
327 VX_DATE_WITH_TIME,
328 VX_DATE_ONLY,
329 } evxDateType;
330
335typedef struct svxTableCellData
336 {
337 union svxCellData
338 {
339 struct svxTextData
340 {
341 const char* pImage;
342 char* buf;
343 int nBufSize;
344 const char* btnToolTip;
345 int btnWidth;
346 int btnHeight;
347 unsigned char isCIF;
348 } textData;
349 struct svxComboData
350 {
351 const char* pImageList;
352 const char* pTextList;
353 char* pSelTextBuf;
354 int nBufSize;
355 int iSel;
356 } comboData;
357 struct svxCheckData
358 {
359 const char* psLabel;
360 int iCheck;
361 } checkBoxData;
362 struct svxDateData
363 {
364 int secsFromEpoch;
365 evxDateType dateType;
366 } dateData;
367 struct svxColorData
368 {
369 unsigned char type;
370 int clrIndex;
371 int r, g, b;
372 } colorData;
373 struct svxNumData
374 {
375 int iMin;
376 int iMax;
377 char* buf;
378 int nBufSize;
379 }numData;
380 } cellData;
381 int iAttrData;
382 struct svxCompareData
383 {
384 int iType;
385 int iInteger;
386 const char* pString;
387 double dDouble;
388 int iKeyCol;
389 } compareData;
390 int idx;
391 int txtMaxLen;
392 const char* placeHolderText;
393 void* validator;
394 } svxTableCellData;
395
400typedef struct svxTableCallBackParam
401 {
402 evxTableEvent evt;
403 svxKeyEvent key;
404 int iRow;
405 int iCol;
406 svxTableCellData cellData;
407 int* pResult;
408 int iSortSequenceSize;
409 int* aSortSequence;
410 } svxTableCallBackParam;
411
412//====================================================================================================================
414//====================================================================================================================
419typedef enum evxAlignFlag
420 {
421 VX_ALIGN_CENTER = 0,
422 VX_ALIGN_LEFT = 1,
423 VX_ALIGN_RIGHT = 2,
424 } evxAlignFlag;
425
426//====================================================================================================================
428//====================================================================================================================
433typedef enum evxTableCellType
434 {
435 VX_TABLECELL_TYPE_TEXT = 0,
436 VX_TABLECELL_TYPE_COMBOBOX = 1,
437 VX_TABLECELL_TYPE_CHECKBOX = 2,
438 VX_TABLECELL_TYPE_INDEX_COMBOBOX = 3,
439 VX_TABLECELL_TYPE_INPUT_COMBOBOX = 4,
440 VX_TABLECELL_TYPE_TEXT_BUTTON = 5,
441 VX_TABLECELL_TYPE_DATE = 6,
442 VX_TABLECELL_TYPE_COLOR = 7,
443 VX_TABLECELL_TYPE_NUMBER = 8,
444 } evxTableCellType;
445
446//====================================================================================================================
448//====================================================================================================================
453typedef enum evxTreeItemFlag
454 {
455 VX_TREE_NO_ITEM_FLAGS = 0x0000,
456 VX_TREE_IS_SELECTABLE = 0x0001,
457 VX_TREE_IS_EDITABLE = 0x0002,
458 VX_TREE_IS_DRAG_ENABLE = 0x0004,
459 VX_TREE_IS_DROP_ENABLE = 0x0008,
460 VX_TREE_IS_CHECKABLE = 0x0010,
461 VX_TREE_IS_ENABLE = 0x0020,
462 VX_TREE_IS_TRISTATE = 0x0040,
463 VX_TREE_ITEM_NEVER_HAS_CHILDREN = 0x0080,
464 VX_TREE_ITEM_IS_USER_TRISTATE = 0x0100,
465 VX_TREE_ITEM_IS_GRAY = 0x00010000,
466 } evxTreeItemFlag;
467
472typedef int vxTreeItemId;
473
474
475/* tree widget item options */
476#define VX_INVALID_ITEM ((vxTreeItemId)-1)
477#define VX_INVISIBLE_ROOT_ITEM ((vxTreeItemId)0)
478#define VX_INSERT_LAST ((vxTreeItemId)-1) /* Insert at last position */
479#define VX_INSERT_FIRST ((vxTreeItemId)0) /* Insert node at first position */
480
485typedef enum evxTreeItemType
486 {
487 VX_ITEM = 0,
488 VX_FINISHMARK = 1
489 } evxTreeItemType;
490
495typedef enum
496 {
497 VX_EMPTY = 0,
498 VX_LEFT_DOWN,
499 VX_LEFT_UP,
500 VX_MIDDLE_DOWN,
501 VX_MIDDLE_UP,
502 VX_RIGHT_DOWN,
503 VX_RIGHT_UP,
504 VX_BOX_SELECTION_DONE,
505 VX_LABEL_CHANGED,
506 VX_EDITOR_CLOSED,
507 VX_DBL_LEFT,
508 VX_DROP,
509 VX_KEY_PRESS,
510 VX_HOVER,
511 VX_HOVER_TIMEOUT,
512 VX_ENTER,
513 VX_LEAVE
514 } evxTreeEvent;
515
520typedef enum evxTreeHitPos
521 {
522 VXTHP_BUTTON = 0x0001,
523 VXTHP_ICON = 0x0002,
524 VXTHP_LABEL = 0x0004,
525 VXTHP_ITEM = 0x0006,
526 VXTHP_SPACE = 0x0008,
527 VXTHP_CHECKBOX = 0x0010,
528 VXTHP_APD_ICON1 = 0x0020,
529 VXTHP_APD_ICON2 = 0x0040,
530 VXTHP_HEADER = 0x0080,
531 } evxTreeHitPos;
532
537typedef struct svxTreeCbParam
538 {
539 evxTreeEvent mode;
540 const char* shell;
541 int field;
542 vxTreeItemId item;
543 int column;
544 union uvxU
545 {
546 struct svxDRAG
547 {
548 vxTreeItemId pressedItem;
549 vxTreeItemId* selection;
550 int num;
551 vxTreeItemId droppedItem;
552 int dropPos;
553 } svxdrag;
554
555 struct svxHIT
556 {
557 evxTreeHitPos pos;
558 } svxhit;
559
560 struct svxSELECTION
561 {
562 vxTreeItemId* idList;
563 int num;
564 } svxselection;
565
566 struct svxLABELEDIT
567 {
568 char* text;
569 } svxlabel;
570 } uvxu;
571
572 svxKeyEvent key;
574 int state;
577 int itemIsDisabled;
579 } svxTreeCbParam;
580
581//====================================================================================================================
583//====================================================================================================================
588typedef enum evxTreeCheckState
589 {
590 VX_TREE_ITEM_UNCHECKED,
591 VX_TREE_ITEM_BLACK_CHECKED = 4
592 } evxTreeCheckState;
593
594/*
595*********************************************************************
596** END HEADER FILE
597*********************************************************************
598*/
599
600#ifdef __cplusplus
601 }
602#endif /* __cplusplus */
603
604#endif /* ZW_API_TREE_H */
evxTreeEvent
evxTreeEvent
tree widget event types
Definition: zwapi_ui_data.h:496
VX_MIDDLE_DOWN
@ VX_MIDDLE_DOWN
middle mouse click up
Definition: zwapi_ui_data.h:500
VX_LEFT_UP
@ VX_LEFT_UP
left mouse click up
Definition: zwapi_ui_data.h:499
VX_LEFT_DOWN
@ VX_LEFT_DOWN
left mouse click down
Definition: zwapi_ui_data.h:498
VX_RIGHT_UP
@ VX_RIGHT_UP
right mouse click up
Definition: zwapi_ui_data.h:503
VX_HOVER_TIMEOUT
@ VX_HOVER_TIMEOUT
item hovered timeout
Definition: zwapi_ui_data.h:511
VX_EDITOR_CLOSED
@ VX_EDITOR_CLOSED
item editor closed
Definition: zwapi_ui_data.h:506
VX_RIGHT_DOWN
@ VX_RIGHT_DOWN
right mouse click down
Definition: zwapi_ui_data.h:502
VX_KEY_PRESS
@ VX_KEY_PRESS
key
Definition: zwapi_ui_data.h:509
VX_BOX_SELECTION_DONE
@ VX_BOX_SELECTION_DONE
box selection over
Definition: zwapi_ui_data.h:504
VX_HOVER
@ VX_HOVER
normal hover
Definition: zwapi_ui_data.h:510
VX_DROP
@ VX_DROP
drop after dragging
Definition: zwapi_ui_data.h:508
VX_DBL_LEFT
@ VX_DBL_LEFT
left mouse double click
Definition: zwapi_ui_data.h:507
VX_MIDDLE_UP
@ VX_MIDDLE_UP
middle mouse click up
Definition: zwapi_ui_data.h:501
VX_LABEL_CHANGED
@ VX_LABEL_CHANGED
label name check
Definition: zwapi_ui_data.h:505
evxFormAddTo
evxFormAddTo
form type that the "Form" add to
Definition: zwapi_ui_data.h:33
VX_FILE_BROWSER
@ VX_FILE_BROWSER
add the form to file browser
Definition: zwapi_ui_data.h:34
VX_UI_MANAGER
@ VX_UI_MANAGER
..add the form to UI manager
Definition: zwapi_ui_data.h:35
evxTreeItemFlag
evxTreeItemFlag
tree item data
Definition: zwapi_ui_data.h:454
VX_TREE_ITEM_IS_USER_TRISTATE
@ VX_TREE_ITEM_IS_USER_TRISTATE
The user can cycle through three separate states.
Definition: zwapi_ui_data.h:464
VX_TREE_IS_DRAG_ENABLE
@ VX_TREE_IS_DRAG_ENABLE
The item be dragged.
Definition: zwapi_ui_data.h:458
VX_TREE_IS_CHECKABLE
@ VX_TREE_IS_CHECKABLE
The item can be checked or unchecked by the user.
Definition: zwapi_ui_data.h:460
VX_TREE_NO_ITEM_FLAGS
@ VX_TREE_NO_ITEM_FLAGS
The item does not have any properties set.
Definition: zwapi_ui_data.h:455
VX_TREE_IS_ENABLE
@ VX_TREE_IS_ENABLE
The user can interact with the item.
Definition: zwapi_ui_data.h:461
VX_TREE_ITEM_NEVER_HAS_CHILDREN
@ VX_TREE_ITEM_NEVER_HAS_CHILDREN
The item never has child items.
Definition: zwapi_ui_data.h:463
VX_TREE_IS_TRISTATE
@ VX_TREE_IS_TRISTATE
The item's state depends on the state of its children.
Definition: zwapi_ui_data.h:462
VX_TREE_IS_EDITABLE
@ VX_TREE_IS_EDITABLE
The item can be edited.
Definition: zwapi_ui_data.h:457
VX_TREE_IS_SELECTABLE
@ VX_TREE_IS_SELECTABLE
The item can be selected.
Definition: zwapi_ui_data.h:456
VX_TREE_IS_DROP_ENABLE
@ VX_TREE_IS_DROP_ENABLE
The item be used as a drop target.
Definition: zwapi_ui_data.h:459
VX_TREE_ITEM_IS_GRAY
@ VX_TREE_ITEM_IS_GRAY
The item shown in gray.
Definition: zwapi_ui_data.h:465
evxCmdFldClass
evxCmdFldClass
command template field classes
Definition: zwapi_ui_data.h:104
VX_CMD_FLD_DIST
@ VX_CMD_FLD_DIST
distance
Definition: zwapi_ui_data.h:108
VX_CMD_FLD_POINT
@ VX_CMD_FLD_POINT
point
Definition: zwapi_ui_data.h:110
VX_CMD_FLD_WIN
@ VX_CMD_FLD_WIN
pick window
Definition: zwapi_ui_data.h:115
VX_CMD_FLD_OPTION
@ VX_CMD_FLD_OPTION
option
Definition: zwapi_ui_data.h:112
VX_CMD_FLD_TEXT
@ VX_CMD_FLD_TEXT
text string
Definition: zwapi_ui_data.h:106
VX_CMD_FLD_PIN
@ VX_CMD_FLD_PIN
pin entity pick
Definition: zwapi_ui_data.h:117
VX_CMD_FLD_CUSTOMINPUT
@ VX_CMD_FLD_CUSTOMINPUT
custom input
Definition: zwapi_ui_data.h:120
VX_CMD_FLD_CMD
@ VX_CMD_FLD_CMD
input via a sub-command
Definition: zwapi_ui_data.h:116
VX_CMD_FLD_NUM
@ VX_CMD_FLD_NUM
number
Definition: zwapi_ui_data.h:107
VX_CMD_FLD_CONT
@ VX_CMD_FLD_CONT
continue
Definition: zwapi_ui_data.h:113
VX_CMD_FLD_NUMUNIT
@ VX_CMD_FLD_NUMUNIT
number with unit
Definition: zwapi_ui_data.h:119
VX_CMD_FLD_ANGLE
@ VX_CMD_FLD_ANGLE
angle
Definition: zwapi_ui_data.h:109
VX_CMD_FLD_NULL
@ VX_CMD_FLD_NULL
null
Definition: zwapi_ui_data.h:105
VX_CMD_FLD_FORM
@ VX_CMD_FLD_FORM
gui form
Definition: zwapi_ui_data.h:114
VX_CMD_FLD_OPTGROUP
@ VX_CMD_FLD_OPTGROUP
option group
Definition: zwapi_ui_data.h:118
VX_CMD_FLD_ENTITY
@ VX_CMD_FLD_ENTITY
entity
Definition: zwapi_ui_data.h:111
VX_CMD_FLD_PICK
@ VX_CMD_FLD_PICK
pick control
Definition: zwapi_ui_data.h:121
evxTreeHitPos
evxTreeHitPos
tree widget element codes
Definition: zwapi_ui_data.h:521
VXTHP_CHECKBOX
@ VXTHP_CHECKBOX
Hit on the checkbox.
Definition: zwapi_ui_data.h:527
VXTHP_SPACE
@ VXTHP_SPACE
Hit on design tree space.
Definition: zwapi_ui_data.h:526
VXTHP_LABEL
@ VXTHP_LABEL
Hit on node's label name.
Definition: zwapi_ui_data.h:524
VXTHP_APD_ICON1
@ VXTHP_APD_ICON1
Hit on node's second icon.
Definition: zwapi_ui_data.h:528
VXTHP_ICON
@ VXTHP_ICON
Hit on node's icon.
Definition: zwapi_ui_data.h:523
VXTHP_ITEM
@ VXTHP_ITEM
V_ZDM_ICON|V_ZDM_LABEL.
Definition: zwapi_ui_data.h:525
VXTHP_BUTTON
@ VXTHP_BUTTON
hit on expand button associated with a node
Definition: zwapi_ui_data.h:522
VXTHP_HEADER
@ VXTHP_HEADER
Hit on the header of the tree.
Definition: zwapi_ui_data.h:530
VXTHP_APD_ICON2
@ VXTHP_APD_ICON2
Hit on node's third icon.
Definition: zwapi_ui_data.h:529
evxTreeItemType
evxTreeItemType
tree widget item types
Definition: zwapi_ui_data.h:486
VX_ITEM
@ VX_ITEM
item
Definition: zwapi_ui_data.h:487
VX_FINISHMARK
@ VX_FINISHMARK
finish mark
Definition: zwapi_ui_data.h:488
evxDateType
evxDateType
data type
Definition: zwapi_ui_data.h:326
VX_DATE_ONLY
@ VX_DATE_ONLY
only date
Definition: zwapi_ui_data.h:328
VX_DATE_WITH_TIME
@ VX_DATE_WITH_TIME
with time
Definition: zwapi_ui_data.h:327
evxTreeCheckState
evxTreeCheckState
check tree item state
Definition: zwapi_ui_data.h:589
VX_TREE_ITEM_UNCHECKED
@ VX_TREE_ITEM_UNCHECKED
The item not checked.
Definition: zwapi_ui_data.h:590
VX_TREE_ITEM_BLACK_CHECKED
@ VX_TREE_ITEM_BLACK_CHECKED
The item checked.
Definition: zwapi_ui_data.h:591
evxFormFldClass
evxFormFldClass
gui form template field (i.e. widget) classes
Definition: zwapi_ui_data.h:76
VX_FORM_FLD_PROGRESS
@ VX_FORM_FLD_PROGRESS
progress control widget
Definition: zwapi_ui_data.h:95
VX_FORM_FLD_SEPARATOR
@ VX_FORM_FLD_SEPARATOR
separator
Definition: zwapi_ui_data.h:90
VX_FORM_FLD_OPT
@ VX_FORM_FLD_OPT
exclusive/non-exclusive group of options
Definition: zwapi_ui_data.h:86
VX_FORM_FLD_COLOR
@ VX_FORM_FLD_COLOR
color widget
Definition: zwapi_ui_data.h:91
VX_FORM_FLD_SLIDER
@ VX_FORM_FLD_SLIDER
bounded numeric input (slider bar)
Definition: zwapi_ui_data.h:79
VX_FORM_FLD_GROUP
@ VX_FORM_FLD_GROUP
widget grouping entity
Definition: zwapi_ui_data.h:88
VX_FORM_FLD_TAB
@ VX_FORM_FLD_TAB
tab widget
Definition: zwapi_ui_data.h:94
VX_FORM_FLD_TXT_OUT
@ VX_FORM_FLD_TXT_OUT
text output
Definition: zwapi_ui_data.h:81
VX_FORM_FLD_TREE
@ VX_FORM_FLD_TREE
tree widget
Definition: zwapi_ui_data.h:92
VX_FORM_FLD_BTNS
@ VX_FORM_FLD_BTNS
menu button group
Definition: zwapi_ui_data.h:87
VX_FORM_FLD_LIST
@ VX_FORM_FLD_LIST
scrolling list
Definition: zwapi_ui_data.h:85
VX_FORM_FLD_NULL
@ VX_FORM_FLD_NULL
null
Definition: zwapi_ui_data.h:77
VX_FORM_FLD_DATA
@ VX_FORM_FLD_DATA
data input for handling a template
Definition: zwapi_ui_data.h:84
VX_FORM_FLD_TXT_BTN
@ VX_FORM_FLD_TXT_BTN
text input with an extra button
Definition: zwapi_ui_data.h:82
VX_FORM_FLD_TXT_IN
@ VX_FORM_FLD_TXT_IN
text input
Definition: zwapi_ui_data.h:80
VX_FORM_FLD_LABEL
@ VX_FORM_FLD_LABEL
label only
Definition: zwapi_ui_data.h:89
VX_FORM_FLD_TXT_LBL
@ VX_FORM_FLD_TXT_LBL
toggle+label+text
Definition: zwapi_ui_data.h:83
VX_FORM_FLD_NUM
@ VX_FORM_FLD_NUM
numeric input
Definition: zwapi_ui_data.h:78
VX_FORM_FLD_COMBO
@ VX_FORM_FLD_COMBO
combo widget
Definition: zwapi_ui_data.h:93
VX_FORM_FLD_TABLE
@ VX_FORM_FLD_TABLE
table widget
Definition: zwapi_ui_data.h:96
evxUiEvt
evxUiEvt
UI event type.
Definition: zwapi_ui_data.h:165
VX_UIEVT_MOUSEMOVE
@ VX_UIEVT_MOUSEMOVE
mouse move event
Definition: zwapi_ui_data.h:192
VX_UIEVT_LBTNDOWN
@ VX_UIEVT_LBTNDOWN
left button down event
Definition: zwapi_ui_data.h:186
VX_UIEVT_IGNORE
@ VX_UIEVT_IGNORE
ignore event
Definition: zwapi_ui_data.h:194
VX_UIEVT_CMDONOFF
@ VX_UIEVT_CMDONOFF
command with on/off suffix
Definition: zwapi_ui_data.h:182
VX_UIEVT_RBTNCLK
@ VX_UIEVT_RBTNCLK
right button click (mouse)
Definition: zwapi_ui_data.h:176
VX_UIEVT_SCROLL
@ VX_UIEVT_SCROLL
slider (scroll)
Definition: zwapi_ui_data.h:180
VX_UIEVT_DATACHANGE
@ VX_UIEVT_DATACHANGE
data change
Definition: zwapi_ui_data.h:188
VX_UIEVT_SELCHANGED
@ VX_UIEVT_SELCHANGED
system event log change
Definition: zwapi_ui_data.h:190
VX_UIEVT_STATECHANGED
@ VX_UIEVT_STATECHANGED
change state
Definition: zwapi_ui_data.h:191
VX_UIEVT_LBTNCLK
@ VX_UIEVT_LBTNCLK
left button click (mouse)
Definition: zwapi_ui_data.h:173
VX_UIEVT_DROP
@ VX_UIEVT_DROP
drop event
Definition: zwapi_ui_data.h:193
VX_UIEVT_PREVIEW
@ VX_UIEVT_PREVIEW
preview
Definition: zwapi_ui_data.h:189
VX_UIEVT_HELP
@ VX_UIEVT_HELP
help
Definition: zwapi_ui_data.h:167
VX_UIEVT_HOTKEY
@ VX_UIEVT_HOTKEY
hotkey
Definition: zwapi_ui_data.h:181
VX_UIEVT_STRING
@ VX_UIEVT_STRING
string
Definition: zwapi_ui_data.h:184
VX_UIEVT_CANCEL
@ VX_UIEVT_CANCEL
cancel
Definition: zwapi_ui_data.h:168
VX_UIEVT_CHAR
@ VX_UIEVT_CHAR
key up and down (keyboard)
Definition: zwapi_ui_data.h:178
VX_UIEVT_INVALID
@ VX_UIEVT_INVALID
invalid
Definition: zwapi_ui_data.h:166
VX_UIEVT_FOCUSSET
@ VX_UIEVT_FOCUSSET
keyboard set focus
Definition: zwapi_ui_data.h:183
VX_UIEVT_SORT
@ VX_UIEVT_SORT
update sequence
Definition: zwapi_ui_data.h:187
VX_UIEVT_DEF
@ VX_UIEVT_DEF
default
Definition: zwapi_ui_data.h:172
VX_UIEVT_OKAY
@ VX_UIEVT_OKAY
accept
Definition: zwapi_ui_data.h:171
VX_UIEVT_LBTNDCLK
@ VX_UIEVT_LBTNDCLK
left button double click (mouse)
Definition: zwapi_ui_data.h:177
VX_UIEVT_APPLY
@ VX_UIEVT_APPLY
apply
Definition: zwapi_ui_data.h:170
VX_UIEVT_RESET
@ VX_UIEVT_RESET
reset
Definition: zwapi_ui_data.h:169
VX_UIEVT_MBTNCLK
@ VX_UIEVT_MBTNCLK
middle button click (mouse)
Definition: zwapi_ui_data.h:175
VX_UIEVT_HOVER
@ VX_UIEVT_HOVER
Hover for tooltip.
Definition: zwapi_ui_data.h:185
VX_UIEVT_LBTNUP
@ VX_UIEVT_LBTNUP
left button click up (mouse)
Definition: zwapi_ui_data.h:174
VX_UIEVT_FOCUSKILL
@ VX_UIEVT_FOCUSKILL
keyboard kill focus
Definition: zwapi_ui_data.h:179
evxFormAction
evxFormAction
gui form action (see cvxFormFunc())
Definition: zwapi_ui_data.h:46
VX_FORM_CANCEL
@ VX_FORM_CANCEL
take down the form
Definition: zwapi_ui_data.h:48
VX_FORM_DEFAULT
@ VX_FORM_DEFAULT
default form values
Definition: zwapi_ui_data.h:52
VX_FORM_APPLY
@ VX_FORM_APPLY
apply form values and leave form up
Definition: zwapi_ui_data.h:50
VX_FORM_INIT
@ VX_FORM_INIT
initialize form
Definition: zwapi_ui_data.h:47
VX_FORM_RESET
@ VX_FORM_RESET
reset form values
Definition: zwapi_ui_data.h:49
VX_FORM_OKAY
@ VX_FORM_OKAY
accept form values and take form down
Definition: zwapi_ui_data.h:51
evxTableEvent
evxTableEvent
table widget event types
Definition: zwapi_ui_data.h:275
VX_SORT
@ VX_SORT
sort event
Definition: zwapi_ui_data.h:281
VX_KEY_UP_DOWN
@ VX_KEY_UP_DOWN
key up and down (keyboard)
Definition: zwapi_ui_data.h:279
VX_LEFT_CLICK
@ VX_LEFT_CLICK
left button click (mouse)
Definition: zwapi_ui_data.h:276
VX_DATA_CHANGED
@ VX_DATA_CHANGED
data changed event
Definition: zwapi_ui_data.h:282
VX_CELL_BUTTON_CLICKED
@ VX_CELL_BUTTON_CLICKED
button in table cell clicked event
Definition: zwapi_ui_data.h:283
VX_CELL_CLOSE_EDITOR
@ VX_CELL_CLOSE_EDITOR
table cell close editor event
Definition: zwapi_ui_data.h:285
VX_HOT_KEY
@ VX_HOT_KEY
hotkey
Definition: zwapi_ui_data.h:280
VX_RIGHT_CLICK
@ VX_RIGHT_CLICK
right button click (mouse)
Definition: zwapi_ui_data.h:277
VX_LEFT_DOUBLE_CLICK
@ VX_LEFT_DOUBLE_CLICK
left button double click (mouse)
Definition: zwapi_ui_data.h:278
evxTableCellType
evxTableCellType
table cell types
Definition: zwapi_ui_data.h:434
VX_TABLECELL_TYPE_INDEX_COMBOBOX
@ VX_TABLECELL_TYPE_INDEX_COMBOBOX
index combobox
Definition: zwapi_ui_data.h:438
VX_TABLECELL_TYPE_COLOR
@ VX_TABLECELL_TYPE_COLOR
color
Definition: zwapi_ui_data.h:442
VX_TABLECELL_TYPE_TEXT
@ VX_TABLECELL_TYPE_TEXT
text
Definition: zwapi_ui_data.h:435
VX_TABLECELL_TYPE_NUMBER
@ VX_TABLECELL_TYPE_NUMBER
number
Definition: zwapi_ui_data.h:443
VX_TABLECELL_TYPE_CHECKBOX
@ VX_TABLECELL_TYPE_CHECKBOX
checkbox
Definition: zwapi_ui_data.h:437
VX_TABLECELL_TYPE_COMBOBOX
@ VX_TABLECELL_TYPE_COMBOBOX
combobox
Definition: zwapi_ui_data.h:436
VX_TABLECELL_TYPE_DATE
@ VX_TABLECELL_TYPE_DATE
date
Definition: zwapi_ui_data.h:441
VX_TABLECELL_TYPE_TEXT_BUTTON
@ VX_TABLECELL_TYPE_TEXT_BUTTON
text button
Definition: zwapi_ui_data.h:440
VX_TABLECELL_TYPE_INPUT_COMBOBOX
@ VX_TABLECELL_TYPE_INPUT_COMBOBOX
input combobox
Definition: zwapi_ui_data.h:439
evxTableAlignFlag
evxTableAlignFlag
table widget alignment mode
Definition: zwapi_ui_data.h:293
VX_TABLE_ALIGN_LEFT
@ VX_TABLE_ALIGN_LEFT
align left
Definition: zwapi_ui_data.h:295
VX_TABLE_ALIGN_RIGHT
@ VX_TABLE_ALIGN_RIGHT
align right
Definition: zwapi_ui_data.h:296
VX_TABLE_ALIGN_CENTER
@ VX_TABLE_ALIGN_CENTER
align center
Definition: zwapi_ui_data.h:294
evxTableResizeMode
evxTableResizeMode
table widget resize mode
Definition: zwapi_ui_data.h:304
VX_TABLE_RESIZE_MODE_FIXED
@ VX_TABLE_RESIZE_MODE_FIXED
QHeaderView::Fixed.
Definition: zwapi_ui_data.h:307
VX_TABLE_RESIZE_MODE_STRETCH
@ VX_TABLE_RESIZE_MODE_STRETCH
QHeaderView::Stretch.
Definition: zwapi_ui_data.h:306
VX_TABLE_RESIZE_MODE_INTERACTIVE
@ VX_TABLE_RESIZE_MODE_INTERACTIVE
QHeaderView::Interactive.
Definition: zwapi_ui_data.h:305
VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS
@ VX_TABLE_RESIZE_MODE_RESIZETOCONTENTS
QHeaderView::ResizeToContents.
Definition: zwapi_ui_data.h:308
vxTreeItemId
int vxTreeItemId
integer tree widget item id
Definition: zwapi_ui_data.h:472
evxAlignFlag
evxAlignFlag
ui alignment types
Definition: zwapi_ui_data.h:420
VX_ALIGN_RIGHT
@ VX_ALIGN_RIGHT
right align
Definition: zwapi_ui_data.h:423
VX_ALIGN_LEFT
@ VX_ALIGN_LEFT
left align
Definition: zwapi_ui_data.h:422
VX_ALIGN_CENTER
@ VX_ALIGN_CENTER
center align
Definition: zwapi_ui_data.h:421
evxCursorType
evxCursorType
cursor display type
Definition: zwapi_ui_data.h:144
VX_CURSOR_BUSY
@ VX_CURSOR_BUSY
cursor used to indicate system is busy
Definition: zwapi_ui_data.h:147
VX_CURSOR_STD
@ VX_CURSOR_STD
standard arrow cursor
Definition: zwapi_ui_data.h:145
VX_CURSOR_HAMMER
@ VX_CURSOR_HAMMER
cursor shaped like a hammer
Definition: zwapi_ui_data.h:151
VX_CURSOR_TOGGLE
@ VX_CURSOR_TOGGLE
cursor with two semi-circular arrows
Definition: zwapi_ui_data.h:152
VX_CURSOR_WRENCH_PLUS
@ VX_CURSOR_WRENCH_PLUS
wrench shaped cursor with plus
Definition: zwapi_ui_data.h:154
VX_CURSOR_PLIERS
@ VX_CURSOR_PLIERS
cursor shaped like pliers
Definition: zwapi_ui_data.h:149
VX_CURSOR_HAND
@ VX_CURSOR_HAND
cursor shaped like a hand
Definition: zwapi_ui_data.h:153
VX_CURSOR_SCREW_DRIVER
@ VX_CURSOR_SCREW_DRIVER
screw driver shaped cursor
Definition: zwapi_ui_data.h:150
VX_CURSOR_MOUSE
@ VX_CURSOR_MOUSE
mouse shaped cursor
Definition: zwapi_ui_data.h:146
VX_CURSOR_WRENCH
@ VX_CURSOR_WRENCH
wrench shaped cursor
Definition: zwapi_ui_data.h:148
svxTableAt
struct svxTableAt svxTableAt
table attributes
svxListCallBackParam
struct svxListCallBackParam svxListCallBackParam
ListWidget event date.
svxTableCellData
struct svxTableCellData svxTableCellData
table cell data
svxTableCallBackParam
struct svxTableCallBackParam svxTableCallBackParam
table widget callback function parameters
svxRectangle
struct svxRectangle svxRectangle
Rectangle data.
svxFormInfo
struct svxFormInfo svxFormInfo
form info that the "Form" add to. When user wants to add a form to UI manager or File browser by usin...
svxTplFld
struct svxTplFld svxTplFld
template field data
svxKeyEvent
struct svxKeyEvent svxKeyEvent
keyboard event
svxTreeCbParam
struct svxTreeCbParam svxTreeCbParam
tree widget callback function parameters
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxFormInfo::Labelname
vxLongName Labelname
page label
Definition: zwapi_ui_data.h:64
svxFormInfo::Tooltips
vxPath Tooltips
tooltips
Definition: zwapi_ui_data.h:65
svxFormInfo::Formname
vxLongName Formname
form name
Definition: zwapi_ui_data.h:62
svxFormInfo::Iconame
vxLongName Iconame
icon name
Definition: zwapi_ui_data.h:63
svxFormInfo
form info that the "Form" add to. When user wants to add a form to UI manager or File browser by usin...
Definition: zwapi_ui_data.h:61
svxKeyEvent::modifier
unsigned int modifier
Synchronous key:CTRL, SHIFT, ALT, or WIN key etc.
Definition: zwapi_ui_data.h:317
svxKeyEvent::keyCode
unsigned int keyCode
A~Z, F1~F12, 0~9 etc, mapping to Microsoft virtual key directly.
Definition: zwapi_ui_data.h:318
svxKeyEvent
keyboard event
Definition: zwapi_ui_data.h:316
svxListCallBackParam::iRow
int iRow
row number
Definition: zwapi_ui_data.h:204
svxListCallBackParam::evt
evxUiEvt evt
event type
Definition: zwapi_ui_data.h:203
svxListCallBackParam::key
int key
the vale of keyboard
Definition: zwapi_ui_data.h:205
svxListCallBackParam
ListWidget event date.
Definition: zwapi_ui_data.h:202
svxRectangle
Rectangle data.
Definition: zwapi_ui_data.h:260
svxTableAt::SetBgColor
int SetBgColor
1 to set background color of table cells specified by "Row" and "Col"; 0 to ignore.
Definition: zwapi_ui_data.h:227
svxTableAt::ColWidth
int ColWidth
column width; 0 to ignore; -1 for default height
Definition: zwapi_ui_data.h:225
svxTableAt::Editable
int Editable
1 to make cells specified by "Row" and "Col" editable; -1 to make specified cells not editable; 0 to ...
Definition: zwapi_ui_data.h:250
svxTableAt::FgColor
svxColor FgColor
foreground color if "SetFgColor = 1"
Definition: zwapi_ui_data.h:235
svxTableAt::AutoSize
int AutoSize
1 to auto-size all rows to the size of the largest item; 2 to auto-size all columns to the size of th...
Definition: zwapi_ui_data.h:239
svxTableAt::Col
int Col
specification of row/column that attributes are applied to; Row > -1 and Col > -1 identifies a specif...
Definition: zwapi_ui_data.h:217
svxTableAt::BgColor
svxColor BgColor
background color if "SetBgColor = 1"
Definition: zwapi_ui_data.h:230
svxTableAt::RowHeight
int RowHeight
row height; 0 to ignore; -1 for default height
Definition: zwapi_ui_data.h:224
svxTableAt::SetFgColor
int SetFgColor
1 to set foreground color of table cells specified by "Row" and "Col"; 0 to ignore.
Definition: zwapi_ui_data.h:232
svxTableAt::AllowResize
int AllowResize
1 to allow rows to be resized; 2 to allow columns to be resized; 3 to allow both to be resized; -1 to...
Definition: zwapi_ui_data.h:245
svxTableAt::SortRows
int SortRows
1 to sort rows on column header; -1 to not sort; 0 to ignore
Definition: zwapi_ui_data.h:237
svxTableAt
table attributes
Definition: zwapi_ui_data.h:216
svxTableCallBackParam::iSortSequenceSize
int iSortSequenceSize
size of aSortSequence
Definition: zwapi_ui_data.h:408
svxTableCallBackParam::key
svxKeyEvent key
keyboard event
Definition: zwapi_ui_data.h:403
svxTableCallBackParam::iRow
int iRow
row
Definition: zwapi_ui_data.h:404
svxTableCallBackParam::iCol
int iCol
column
Definition: zwapi_ui_data.h:405
svxTableCallBackParam::cellData
svxTableCellData cellData
table cell data
Definition: zwapi_ui_data.h:406
svxTableCallBackParam::evt
evxTableEvent evt
table widget event types
Definition: zwapi_ui_data.h:402
svxTableCallBackParam
table widget callback function parameters
Definition: zwapi_ui_data.h:401
svxTableCellData::svxCellData::svxCheckData::iCheck
int iCheck
In/Out.
Definition: zwapi_ui_data.h:360
svxTableCellData::svxCellData::svxCheckData::psLabel
const char * psLabel
In.
Definition: zwapi_ui_data.h:359
svxTableCellData::svxCellData::svxCheckData
Definition: zwapi_ui_data.h:358
svxTableCellData::svxCellData::svxColorData::clrIndex
int clrIndex
In/Out.
Definition: zwapi_ui_data.h:370
svxTableCellData::svxCellData::svxColorData::type
unsigned char type
In: 0-true color, 1-index color, 2-include FROM PART.
Definition: zwapi_ui_data.h:369
svxTableCellData::svxCellData::svxColorData::b
int b
In/Out.
Definition: zwapi_ui_data.h:371
svxTableCellData::svxCellData::svxColorData
Definition: zwapi_ui_data.h:368
svxTableCellData::svxCellData::svxComboData::pTextList
const char * pTextList
In.
Definition: zwapi_ui_data.h:352
svxTableCellData::svxCellData::svxComboData::iSel
int iSel
In/Out.
Definition: zwapi_ui_data.h:355
svxTableCellData::svxCellData::svxComboData::pSelTextBuf
char * pSelTextBuf
In/Out.
Definition: zwapi_ui_data.h:353
svxTableCellData::svxCellData::svxComboData::pImageList
const char * pImageList
In.
Definition: zwapi_ui_data.h:351
svxTableCellData::svxCellData::svxComboData::nBufSize
int nBufSize
In.
Definition: zwapi_ui_data.h:354
svxTableCellData::svxCellData::svxComboData
Definition: zwapi_ui_data.h:350
svxTableCellData::svxCellData::svxDateData::dateType
evxDateType dateType
In.
Definition: zwapi_ui_data.h:365
svxTableCellData::svxCellData::svxDateData::secsFromEpoch
int secsFromEpoch
In/Out.
Definition: zwapi_ui_data.h:364
svxTableCellData::svxCellData::svxDateData
Definition: zwapi_ui_data.h:363
svxTableCellData::svxCellData::svxNumData::iMin
int iMin
In.
Definition: zwapi_ui_data.h:375
svxTableCellData::svxCellData::svxNumData::buf
char * buf
In/Out.
Definition: zwapi_ui_data.h:377
svxTableCellData::svxCellData::svxNumData::nBufSize
int nBufSize
In.
Definition: zwapi_ui_data.h:378
svxTableCellData::svxCellData::svxNumData::iMax
int iMax
In.
Definition: zwapi_ui_data.h:376
svxTableCellData::svxCellData::svxNumData
Definition: zwapi_ui_data.h:374
svxTableCellData::svxCellData::svxTextData::btnWidth
int btnWidth
In.
Definition: zwapi_ui_data.h:345
svxTableCellData::svxCellData::svxTextData::pImage
const char * pImage
In.
Definition: zwapi_ui_data.h:341
svxTableCellData::svxCellData::svxTextData::btnToolTip
const char * btnToolTip
In.
Definition: zwapi_ui_data.h:344
svxTableCellData::svxCellData::svxTextData::isCIF
unsigned char isCIF
In: 0-ANSI string, 1-buf is multi-byte string in CIF format.
Definition: zwapi_ui_data.h:347
svxTableCellData::svxCellData::svxTextData::buf
char * buf
In/Out.
Definition: zwapi_ui_data.h:342
svxTableCellData::svxCellData::svxTextData::nBufSize
int nBufSize
In.
Definition: zwapi_ui_data.h:343
svxTableCellData::svxCellData::svxTextData::btnHeight
int btnHeight
In.
Definition: zwapi_ui_data.h:346
svxTableCellData::svxCellData::svxTextData
Definition: zwapi_ui_data.h:340
svxTableCellData::svxCompareData::dDouble
double dDouble
In.
Definition: zwapi_ui_data.h:387
svxTableCellData::svxCompareData::iKeyCol
int iKeyCol
In.
Definition: zwapi_ui_data.h:388
svxTableCellData::svxCompareData::iType
int iType
In 1-integer, 2-string, 3-double.
Definition: zwapi_ui_data.h:384
svxTableCellData::svxCompareData::iInteger
int iInteger
In.
Definition: zwapi_ui_data.h:385
svxTableCellData::svxCompareData::pString
const char * pString
In.
Definition: zwapi_ui_data.h:386
svxTableCellData::svxCompareData
Definition: zwapi_ui_data.h:383
svxTableCellData
table cell data
Definition: zwapi_ui_data.h:336
svxTplFld::Name
char Name[65]
field name (i.e. label)
Definition: zwapi_ui_data.h:130
svxTplFld::Id
int Id
command field or gui widget id
Definition: zwapi_ui_data.h:131
svxTplFld::Class
int Class
see evxFormFldClass or evxCmdFldClass
Definition: zwapi_ui_data.h:132
svxTplFld::Callback
void * Callback
pointer to field's callback function
Definition: zwapi_ui_data.h:133
svxTplFld
template field data
Definition: zwapi_ui_data.h:129
svxTreeCbParam::uvxU::svxDRAG::dropPos
int dropPos
0:item,1:above,2:below,3:viewport,
Definition: zwapi_ui_data.h:552
svxTreeCbParam::uvxU::svxDRAG
drag multiple nodes
Definition: zwapi_ui_data.h:547
svxTreeCbParam::uvxU::svxHIT::pos
evxTreeHitPos pos
Clicking position (evxTreeHitPos)
Definition: zwapi_ui_data.h:557
svxTreeCbParam::uvxU::svxHIT
Definition: zwapi_ui_data.h:556
svxTreeCbParam::uvxU::svxLABELEDIT::text
char * text
pointer to node's label string
Definition: zwapi_ui_data.h:568
svxTreeCbParam::uvxU::svxLABELEDIT
Definition: zwapi_ui_data.h:567
svxTreeCbParam::uvxU::svxSELECTION
multiple nodes selection
Definition: zwapi_ui_data.h:561
svxTreeCbParam::key
svxKeyEvent key
key
Definition: zwapi_ui_data.h:572
svxTreeCbParam::itemIsDisabled
int itemIsDisabled
1:node is disabled, 0:node is enabled if success/ok/enable next procedure, assign it to 0,...
Definition: zwapi_ui_data.h:577
svxTreeCbParam::state
int state
1:state is on, 0:state is off or V_ZDM_EXPAND/V_ZDM_COLLAPSE
Definition: zwapi_ui_data.h:574
svxTreeCbParam::item
vxTreeItemId item
current hover id
Definition: zwapi_ui_data.h:542
svxTreeCbParam::column
int column
the column where the current item is located
Definition: zwapi_ui_data.h:543
svxTreeCbParam
tree widget callback function parameters
Definition: zwapi_ui_data.h:538
svxTableCellData::svxCellData
Definition: zwapi_ui_data.h:338
svxTreeCbParam::uvxU
Definition: zwapi_ui_data.h:545
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_FORM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_form.h
cvxFieldCaretSet
cvxFieldClear
cvxFieldDisable
cvxFieldEnable
cvxFieldEnableGet
cvxFieldFocusSet
cvxFieldImageSet
cvxFieldInitFont
cvxFieldNumItems
cvxFieldTipSet
cvxFilterItemApply
cvxFormActiveField
cvxFormAddTo
cvxFormAdjustSize
cvxFormCallback
cvxFormCreate
cvxFormDataGet
cvxFormDataSet
cvxFormFieldGetCallback
cvxFormFieldVisSet
cvxFormFunc
cvxFormGetSize
cvxFormHide
cvxFormInqFld
cvxFormInsertTo
cvxFormKill
cvxFormLogKill
cvxFormRefresh
cvxFormRemoveFrom
cvxFormResize
cvxFormShow
cvxFormState
cvxFormTitleGet
cvxFormTitleSet
cvxFormUpdate
cvxFormVisibleSet
cvxFormWait
cvxFormWaitExit
cvxItemAdd
cvxItemCbxSet
cvxItemDel
cvxItemFind
cvxItemGet
cvxItemGetCheckState
cvxItemModify
cvxItemSelect
cvxItemSelected
cvxItemSelectText
cvxItemSet
cvxItemStateGet
cvxItemStateSet
cvxItemVisibleGet
cvxItemVisibleSet
cvxTplInqFieldOptions
cvxTplInqFields
cvxTplInqFieldType

◆ ZW_API_FORM_H

#define ZW_API_FORM_H

Definition at line 15 of file zwapi_ui_form.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_form.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_form.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_FORM_H /* this ifndef surrounds entire header */
15#define ZW_API_FORM_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
42extern evxErrors cvxFormCreate(char* Form, int Display);
43
44/******************************************************************************/
57extern void cvxFormShow(char* Form);
58
59/******************************************************************************/
71extern void cvxFormHide(char* Form);
72
73/******************************************************************************/
87extern void cvxFormKill(char* Form);
88
89/******************************************************************************/
101extern void cvxFormLogKill(char* Form);
102
103/******************************************************************************/
116extern void cvxFormRefresh(char* Form);
117
118/******************************************************************************/
143extern int cvxFormWait(char* Form);
144
145/******************************************************************************/
155extern void cvxFormWaitExit(int ReturnValue);
156
157/******************************************************************************/
174extern evxErrors cvxFormGetSize(const char* Form, int* Width, int* Height);
175
176/******************************************************************************/
192extern evxErrors cvxFormResize(char* Form, int Width, int Height);
193
194/******************************************************************************/
208extern evxErrors cvxFormAdjustSize(const char* Form);
209
210
211//====================================================================================================================
213//====================================================================================================================
214/******************************************************************************/
225extern void cvxFormAddTo(const char* Form, evxFormAddTo addTo);
226
227/******************************************************************************/
243 evxErrors cvxFormInsertTo(const svxFormInfo* FormInfo, int Index, evxFormAddTo AddTo);
244
245/******************************************************************************/
256extern void cvxFormRemoveFrom(const char* Form, evxFormAddTo removeFrom);
257
258
259//====================================================================================================================
261//====================================================================================================================
262/******************************************************************************/
278extern void cvxFormTitleGet(char* Form, int NumBytes, char* Title);
279
280/******************************************************************************/
293extern void cvxFormTitleSet(char* Form, char* Title);
294
295/******************************************************************************/
325extern evxErrors cvxFormDataGet(char* Form, char** Data);
326
327/******************************************************************************/
344extern evxErrors cvxFormDataSet(char* Form, char* Data);
345
346
347//====================================================================================================================
349//====================================================================================================================
350/******************************************************************************/
381extern void cvxFormFunc(vxName Name, void* Function, double Code);
382
383/******************************************************************************/
407extern void cvxFormCallback(vxName Name, void* Function);
408
409/******************************************************************************/
424extern evxErrors cvxFormFieldGetCallback(const char* form, int field, void** callback);
425
426
427//====================================================================================================================
429//====================================================================================================================
430/******************************************************************************/
438extern void cvxFormActiveField(int* idField);
439
440/******************************************************************************/
454extern int cvxFormState(char* Form);
455
456/******************************************************************************/
477extern evxErrors cvxFormVisibleSet(evxEnvironment Environment, const char* Form, int State, evxFormAddTo Type);
478
479/******************************************************************************/
495extern evxErrors cvxFormFieldVisSet(const char* form, int field, int state);
496
497
498//====================================================================================================================
500//====================================================================================================================
501/******************************************************************************/
521extern evxErrors cvxFormInqFld(vxName Name, int* Count, svxTplFld** Fields);
522
523/******************************************************************************/
541extern evxErrors cvxTplInqFields(const vxName Name, int* NumFld, int** idFields);
542
543/******************************************************************************/
560extern evxErrors cvxTplInqFieldType(const vxName Name, int idField, evxCmdFldClass* Type);
561
562/******************************************************************************/
581extern evxErrors cvxTplInqFieldOptions(const vxName Name, int idField, int NumBytes, char* Options);
582
583/******************************************************************************/
596extern void cvxFormUpdate(int idField);
597
598/******************************************************************************/
618extern void cvxFieldFocusSet(char* Form, int idField);
619
620/******************************************************************************/
640extern void cvxFieldNumItems(char* Form, int idField, int* NumItems);
641
642/******************************************************************************/
659extern void cvxFieldClear(char* Form, int idField);
660
661/******************************************************************************/
677extern void cvxFieldDisable(char* Form, int idField);
678
679/******************************************************************************/
695extern void cvxFieldEnable(char* Form, int idField);
696
697/******************************************************************************/
715extern int cvxFieldEnableGet(char* Form, int idField);
716
717/******************************************************************************/
733extern void cvxFilterItemApply(const char* panelName, const char* filterItem);
734
735/******************************************************************************/
754extern void cvxFieldImageSet(char* Form, int idField, char* Image);
755
756/******************************************************************************/
772extern void cvxFieldCaretSet(char* Form, int idField, int Position);
773
774/******************************************************************************/
791extern evxErrors cvxFieldTipSet(const char* sForm, int idField, const char* tip);
792
793/******************************************************************************/
879extern evxErrors cvxFieldInitFont(const char* Form, int idField, const char* Name, int hasZwFont);
880
881
882//====================================================================================================================
884//====================================================================================================================
885/******************************************************************************/
903extern void cvxItemAdd(char* Form, int idField, const char* Text);
904
905/******************************************************************************/
926extern void cvxItemGet(char* Form, int idField, int idItem, char* Text);
927
928/******************************************************************************/
962extern void cvxItemSet(char* Form, int idField, int idItem, char* Text);
963
964/******************************************************************************/
995extern void cvxItemModify(const char* Form, int idField, int idItem, const char* Text);
996
997/******************************************************************************/
1015extern void cvxItemDel(char* Form, int idField, int idItem);
1016
1017/******************************************************************************/
1043extern void cvxItemFind(char* Form, int idField, char* Text, int* idItem);
1044
1045/******************************************************************************/
1066extern void cvxItemCbxSet(char* Form, int idField, int idItem, int isOn);
1067
1068/******************************************************************************/
1085extern void cvxItemSelect(char* Form, int idField, int idItem);
1086
1087/******************************************************************************/
1104extern void cvxItemSelectText(char* Form, int idField, char* Text);
1105
1106/******************************************************************************/
1125extern void cvxItemSelected(char* Form, int idField, int* idItem);
1126
1127/******************************************************************************/
1145extern void cvxItemStateGet(char* Form, int idField, int idItem, int* isOn);
1146
1147/******************************************************************************/
1164extern void cvxItemStateSet(char* Form, int idField, int idItem, int isOn);
1165
1166/******************************************************************************/
1185extern evxErrors cvxItemGetCheckState(char* Form, int idField, int idItem, int* checkState);
1186
1187/******************************************************************************/
1205extern evxErrors cvxItemVisibleSet(const char* Form, int idField, int idItem, int state);
1206
1207/******************************************************************************/
1225extern evxErrors cvxItemVisibleGet(const char* Form, int idField, int idItem, int* state);
1226
1227
1228/*
1229*********************************************************************
1230** END HEADER FILE
1231*********************************************************************
1232*/
1233
1234#ifdef __cplusplus
1235 }
1236#endif /* __cplusplus */
1237
1238#endif /* ZW_API_FORM_H */
evxFormAddTo
evxFormAddTo
form type that the "Form" add to
Definition: zwapi_ui_data.h:33
evxCmdFldClass
evxCmdFldClass
command template field classes
Definition: zwapi_ui_data.h:104
cvxFormUpdate
void cvxFormUpdate(int idField)
cvxItemVisibleSet
evxErrors cvxItemVisibleSet(const char *Form, int idField, int idItem, int state)
cvxFieldDisable
void cvxFieldDisable(char *Form, int idField)
cvxFormInsertTo
evxErrors cvxFormInsertTo(const svxFormInfo *FormInfo, int Index, evxFormAddTo AddTo)
cvxItemSet
void cvxItemSet(char *Form, int idField, int idItem, char *Text)
cvxFormWaitExit
void cvxFormWaitExit(int ReturnValue)
cvxFieldCaretSet
void cvxFieldCaretSet(char *Form, int idField, int Position)
cvxFormCallback
void cvxFormCallback(vxName Name, void *Function)
cvxFormDataGet
evxErrors cvxFormDataGet(char *Form, char **Data)
cvxFieldEnableGet
int cvxFieldEnableGet(char *Form, int idField)
cvxFormState
int cvxFormState(char *Form)
cvxFieldClear
void cvxFieldClear(char *Form, int idField)
cvxFormFieldVisSet
evxErrors cvxFormFieldVisSet(const char *form, int field, int state)
cvxFormAddTo
void cvxFormAddTo(const char *Form, evxFormAddTo addTo)
cvxItemFind
void cvxItemFind(char *Form, int idField, char *Text, int *idItem)
cvxFilterItemApply
void cvxFilterItemApply(const char *panelName, const char *filterItem)
cvxFieldTipSet
evxErrors cvxFieldTipSet(const char *sForm, int idField, const char *tip)
cvxFormFunc
void cvxFormFunc(vxName Name, void *Function, double Code)
cvxFormWait
int cvxFormWait(char *Form)
cvxItemGetCheckState
evxErrors cvxItemGetCheckState(char *Form, int idField, int idItem, int *checkState)
cvxFormLogKill
void cvxFormLogKill(char *Form)
cvxTplInqFieldType
evxErrors cvxTplInqFieldType(const vxName Name, int idField, evxCmdFldClass *Type)
cvxItemCbxSet
void cvxItemCbxSet(char *Form, int idField, int idItem, int isOn)
cvxFormKill
void cvxFormKill(char *Form)
cvxItemSelected
void cvxItemSelected(char *Form, int idField, int *idItem)
cvxFormTitleSet
void cvxFormTitleSet(char *Form, char *Title)
cvxItemStateGet
void cvxItemStateGet(char *Form, int idField, int idItem, int *isOn)
cvxFormTitleGet
void cvxFormTitleGet(char *Form, int NumBytes, char *Title)
cvxItemAdd
void cvxItemAdd(char *Form, int idField, const char *Text)
cvxFormActiveField
void cvxFormActiveField(int *idField)
cvxTplInqFieldOptions
evxErrors cvxTplInqFieldOptions(const vxName Name, int idField, int NumBytes, char *Options)
cvxItemSelect
void cvxItemSelect(char *Form, int idField, int idItem)
cvxFormGetSize
evxErrors cvxFormGetSize(const char *Form, int *Width, int *Height)
cvxFormAdjustSize
evxErrors cvxFormAdjustSize(const char *Form)
cvxFormFieldGetCallback
evxErrors cvxFormFieldGetCallback(const char *form, int field, void **callback)
cvxFieldInitFont
evxErrors cvxFieldInitFont(const char *Form, int idField, const char *Name, int hasZwFont)
cvxFieldFocusSet
void cvxFieldFocusSet(char *Form, int idField)
cvxItemSelectText
void cvxItemSelectText(char *Form, int idField, char *Text)
cvxFieldEnable
void cvxFieldEnable(char *Form, int idField)
cvxItemDel
void cvxItemDel(char *Form, int idField, int idItem)
cvxFormResize
evxErrors cvxFormResize(char *Form, int Width, int Height)
cvxFormHide
void cvxFormHide(char *Form)
cvxFormRemoveFrom
void cvxFormRemoveFrom(const char *Form, evxFormAddTo removeFrom)
cvxItemGet
void cvxItemGet(char *Form, int idField, int idItem, char *Text)
cvxFormCreate
evxErrors cvxFormCreate(char *Form, int Display)
cvxItemModify
void cvxItemModify(const char *Form, int idField, int idItem, const char *Text)
cvxFormInqFld
evxErrors cvxFormInqFld(vxName Name, int *Count, svxTplFld **Fields)
cvxItemStateSet
void cvxItemStateSet(char *Form, int idField, int idItem, int isOn)
cvxFormVisibleSet
evxErrors cvxFormVisibleSet(evxEnvironment Environment, const char *Form, int State, evxFormAddTo Type)
cvxFormShow
void cvxFormShow(char *Form)
cvxFieldImageSet
void cvxFieldImageSet(char *Form, int idField, char *Image)
cvxFormRefresh
void cvxFormRefresh(char *Form)
cvxTplInqFields
evxErrors cvxTplInqFields(const vxName Name, int *NumFld, int **idFields)
cvxItemVisibleGet
evxErrors cvxItemVisibleGet(const char *Form, int idField, int idItem, int *state)
cvxFormDataSet
evxErrors cvxFormDataSet(char *Form, char *Data)
cvxFieldNumItems
void cvxFieldNumItems(char *Form, int idField, int *NumItems)
evxEnvironment
evxEnvironment
zw3d environment
Definition: zwapi_util.h:2477
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxFormInfo
form info that the "Form" add to. When user wants to add a form to UI manager or File browser by usin...
Definition: zwapi_ui_data.h:61
svxTplFld
template field data
Definition: zwapi_ui_data.h:129
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_GUI_SET_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_guiset.h
cvxCursorRestore
cvxCursorSet
cvxProgress
cvxUiSettingsApply
cvxUiSettingsCount
cvxUiSettingsCreate
cvxUiSettingsExists
cvxUiSettingsExport
cvxUiSettingsFetch
cvxUiSettingsImport
cvxUiSettingsRemove
cvxUiSettingsRename
cvxUiSettingsReset

◆ ZW_API_GUI_SET_H

#define ZW_API_GUI_SET_H

Definition at line 15 of file zwapi_ui_guiset.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_guiset.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_guiset.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_GUI_SET_H /* this ifndef surrounds entire header */
15#define ZW_API_GUI_SET_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
32extern int cvxUiSettingsCount(void);
33
34/******************************************************************************/
48extern evxErrors cvxUiSettingsCreate(char* Name, char* Base);
49
50/******************************************************************************/
64extern evxErrors cvxUiSettingsRename(char* Name, char* Dest);
65
66/******************************************************************************/
79extern evxErrors cvxUiSettingsRemove(char* Name);
80
81/******************************************************************************/
94extern evxErrors cvxUiSettingsImport(char* Path);
95
96/******************************************************************************/
111extern evxErrors cvxUiSettingsExport(char* Name, char* Path);
112
113/******************************************************************************/
126extern evxErrors cvxUiSettingsExists(char* Name);
127
128/******************************************************************************/
141extern evxErrors cvxUiSettingsApply(char* Name);
142
143/******************************************************************************/
156extern evxErrors cvxUiSettingsReset(char* Name);
157
158/******************************************************************************/
173extern evxErrors cvxUiSettingsFetch(int i, char* Name);
174
175
176//====================================================================================================================
178//====================================================================================================================
179/******************************************************************************/
188extern void cvxCursorSet(evxCursorType Type);
189
190/******************************************************************************/
197extern void cvxCursorRestore(void);
198
199/******************************************************************************/
207extern void cvxProgress(int iprogress);
208
209/*
210*********************************************************************
211** END HEADER FILE
212*********************************************************************
213*/
214
215#ifdef __cplusplus
216 }
217#endif /* __cplusplus */
218
219#endif /* ZW_API_GUI_SET_H */
evxCursorType
evxCursorType
cursor display type
Definition: zwapi_ui_data.h:144
cvxUiSettingsReset
evxErrors cvxUiSettingsReset(char *Name)
cvxCursorSet
void cvxCursorSet(evxCursorType Type)
cvxUiSettingsApply
evxErrors cvxUiSettingsApply(char *Name)
cvxUiSettingsImport
evxErrors cvxUiSettingsImport(char *Path)
cvxUiSettingsCount
int cvxUiSettingsCount(void)
cvxUiSettingsFetch
evxErrors cvxUiSettingsFetch(int i, char *Name)
cvxUiSettingsRemove
evxErrors cvxUiSettingsRemove(char *Name)
cvxUiSettingsRename
evxErrors cvxUiSettingsRename(char *Name, char *Dest)
cvxProgress
void cvxProgress(int iprogress)
cvxUiSettingsExport
evxErrors cvxUiSettingsExport(char *Name, char *Path)
cvxUiSettingsCreate
evxErrors cvxUiSettingsCreate(char *Name, char *Base)
cvxUiSettingsExists
evxErrors cvxUiSettingsExists(char *Name)
cvxCursorRestore
void cvxCursorRestore(void)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_LIST_WIDGET_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_listwidget.h
cvxListCallbackParamGet
cvxListItemToolTipGet
cvxListItemToolTipSet

◆ ZW_API_LIST_WIDGET_H

#define ZW_API_LIST_WIDGET_H

Definition at line 15 of file zwapi_ui_listwidget.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_listwidget.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_listwidget.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_LIST_WIDGET_H /* this ifndef surrounds entire header */
15#define ZW_API_LIST_WIDGET_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
50extern evxErrors cvxListCallbackParamGet(const char* form, int idField, svxListCallBackParam* param);
51
52/******************************************************************************/
70extern evxErrors cvxListItemToolTipSet(const char* form, int field, int row, const char* toolTip);
71
72/******************************************************************************/
92extern evxErrors cvxListItemToolTipGet(const char* form, int field, int row, char* toolTip, int size);
93
94
95/*
96*********************************************************************
97** END HEADER FILE
98*********************************************************************
99*/
100
101#ifdef __cplusplus
102 }
103#endif /* __cplusplus */
104
105#endif /* ZW_API_LIST_WIDGET_H */
cvxListItemToolTipGet
evxErrors cvxListItemToolTipGet(const char *form, int field, int row, char *toolTip, int size)
cvxListItemToolTipSet
evxErrors cvxListItemToolTipSet(const char *form, int field, int row, const char *toolTip)
cvxListCallbackParamGet
evxErrors cvxListCallbackParamGet(const char *form, int idField, svxListCallBackParam *param)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxListCallBackParam
ListWidget event date.
Definition: zwapi_ui_data.h:202
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_POPUP_FORM_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_popupform.h
cvxPopupDefine
cvxPopupItemActionGet
cvxPopupItemCheckedGet
cvxPopupItemInsert
cvxPopupItemIsExist
cvxPopupItemLabelGet
cvxPopupItemRemove
cvxPopupItemSetAction
cvxPopupItemSetCheckedByAction
cvxPopupItemSetEnabledByAction
cvxPopupItemSetVisibleByAction
cvxPopupItemVisibleGet
cvxPopupMenuCnt
cvxPopupSetVisible
cvxPopupShow
cvxPopupSubMenuActionsRemove
cvxPopupSubMenuCnt
cvxPopupSubMenuItemInsert
cvxPopupSubMenuItemRemove
cvxPopupSubMenuSeparatorInsert
cvxPopupSubMenuSetVisible
cvxPopupUpdate

◆ ZW_API_POPUP_FORM_H

#define ZW_API_POPUP_FORM_H

Definition at line 15 of file zwapi_ui_popupform.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_popupform.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_popupform.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_POPUP_FORM_H /* this ifndef surrounds entire header */
15#define ZW_API_POPUP_FORM_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
41extern int cvxPopupShow(const char* name);
42
43/******************************************************************************/
57extern evxErrors cvxPopupDefine(const char* name);
58
59/******************************************************************************/
73extern evxErrors cvxPopupUpdate(const char* Name);
74
75/******************************************************************************/
90extern evxErrors cvxPopupSetVisible(const char* name, int visible);
91
92
93//====================================================================================================================
95//====================================================================================================================
96/******************************************************************************/
112extern evxErrors cvxPopupMenuCnt(const char* Name, int* cnt);
113
114/******************************************************************************/
131extern evxErrors cvxPopupSubMenuCnt(const char* Name, const char* Sub, int* cnt);
132
133/******************************************************************************/
155extern evxErrors cvxPopupSubMenuItemInsert(const char* Name, const char* Sub, int index, const char* ActName, const char* Label, const char* Script, const char* Icon);
156
157/******************************************************************************/
176extern evxErrors cvxPopupSubMenuItemRemove(const char* name, const char* Sub, int index);
177
178/******************************************************************************/
198extern evxErrors cvxPopupSubMenuActionsRemove(const char* Name, const char* Sub, int iFirst, int iLast);
199
200/******************************************************************************/
217extern evxErrors cvxPopupSubMenuSeparatorInsert(const char* Name, const char* Sub);
218
219/******************************************************************************/
235extern evxErrors cvxPopupSubMenuSetVisible(const char* name, const char* sub, int visible);
236
237
238//====================================================================================================================
240//====================================================================================================================
241
242/******************************************************************************/
257extern int cvxPopupItemIsExist(const char* name, const char* action);
258
259/******************************************************************************/
278extern evxErrors cvxPopupItemInsert(const char* name, int index, const char* Label, const char* Action);
279
280/******************************************************************************/
296extern evxErrors cvxPopupItemRemove(const char* name, int index);
297
298/******************************************************************************/
316extern evxErrors cvxPopupItemActionGet(const char* name, int item, char* Action, int nByte);
317
318/******************************************************************************/
337extern evxErrors cvxPopupItemSetAction(const char* name, int index, const char* Action);
338
339/******************************************************************************/
357extern evxErrors cvxPopupItemLabelGet(const char* name, int item, char* Label, int nByte);
358
359/******************************************************************************/
379extern evxErrors cvxPopupItemCheckedGet(const char* name, int group, int item, int* Check);
380
381/******************************************************************************/
397extern evxErrors cvxPopupItemVisibleGet(const char* name, int item, int* Visible);
398
399/******************************************************************************/
416extern evxErrors cvxPopupItemSetVisibleByAction(const char* name, const char* action, int visible);
417
418/******************************************************************************/
435extern evxErrors cvxPopupItemSetEnabledByAction(const char* name, const char* action, int enabled);
436
437/******************************************************************************/
454extern evxErrors cvxPopupItemSetCheckedByAction(const char* name, const char* action, int checked);
455
456/*
457*********************************************************************
458** END HEADER FILE
459*********************************************************************
460*/
461
462#ifdef __cplusplus
463 }
464#endif /* __cplusplus */
465
466#endif /* ZW_API_POPUP_FORM_H */
cvxPopupItemSetVisibleByAction
evxErrors cvxPopupItemSetVisibleByAction(const char *name, const char *action, int visible)
cvxPopupDefine
evxErrors cvxPopupDefine(const char *name)
cvxPopupItemActionGet
evxErrors cvxPopupItemActionGet(const char *name, int item, char *Action, int nByte)
cvxPopupSubMenuItemRemove
evxErrors cvxPopupSubMenuItemRemove(const char *name, const char *Sub, int index)
cvxPopupSubMenuSeparatorInsert
evxErrors cvxPopupSubMenuSeparatorInsert(const char *Name, const char *Sub)
cvxPopupSubMenuItemInsert
evxErrors cvxPopupSubMenuItemInsert(const char *Name, const char *Sub, int index, const char *ActName, const char *Label, const char *Script, const char *Icon)
cvxPopupItemIsExist
int cvxPopupItemIsExist(const char *name, const char *action)
cvxPopupItemSetAction
evxErrors cvxPopupItemSetAction(const char *name, int index, const char *Action)
cvxPopupItemInsert
evxErrors cvxPopupItemInsert(const char *name, int index, const char *Label, const char *Action)
cvxPopupItemCheckedGet
evxErrors cvxPopupItemCheckedGet(const char *name, int group, int item, int *Check)
cvxPopupSubMenuSetVisible
evxErrors cvxPopupSubMenuSetVisible(const char *name, const char *sub, int visible)
cvxPopupShow
int cvxPopupShow(const char *name)
cvxPopupItemSetCheckedByAction
evxErrors cvxPopupItemSetCheckedByAction(const char *name, const char *action, int checked)
cvxPopupItemLabelGet
evxErrors cvxPopupItemLabelGet(const char *name, int item, char *Label, int nByte)
cvxPopupMenuCnt
evxErrors cvxPopupMenuCnt(const char *Name, int *cnt)
cvxPopupUpdate
evxErrors cvxPopupUpdate(const char *Name)
cvxPopupItemRemove
evxErrors cvxPopupItemRemove(const char *name, int index)
cvxPopupSetVisible
evxErrors cvxPopupSetVisible(const char *name, int visible)
cvxPopupItemVisibleGet
evxErrors cvxPopupItemVisibleGet(const char *name, int item, int *Visible)
cvxPopupSubMenuCnt
evxErrors cvxPopupSubMenuCnt(const char *Name, const char *Sub, int *cnt)
cvxPopupSubMenuActionsRemove
evxErrors cvxPopupSubMenuActionsRemove(const char *Name, const char *Sub, int iFirst, int iLast)
cvxPopupItemSetEnabledByAction
evxErrors cvxPopupItemSetEnabledByAction(const char *name, const char *action, int enabled)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_RIBBON_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_ribbon.h
cvxRibbonSetStatus
cvxSetTitleAppend

◆ ZW_API_RIBBON_H

#define ZW_API_RIBBON_H

Definition at line 15 of file zwapi_ui_ribbon.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_ribbon.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_ribbon.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_RIBBON_H /* this ifndef surrounds entire header */
15#define ZW_API_RIBBON_H
16
17#ifdef __cplusplus
18extern "C" {
19#endif /* __cplusplus */
20
21//====================================================================================================================
23//====================================================================================================================
24/******************************************************************************/
34extern void cvxRibbonSetStatus(int enable);
35
36/******************************************************************************/
44extern void cvxSetTitleAppend(const char* pStr);
45
46
47/*
48*********************************************************************
49** END HEADER FILE
50*********************************************************************
51*/
52
53#ifdef __cplusplus
54 }
55#endif /* __cplusplus */
56
57#endif /* ZW_API_RIBBON_H */
cvxSetTitleAppend
void cvxSetTitleAppend(const char *pStr)
cvxRibbonSetStatus
void cvxRibbonSetStatus(int enable)
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_SLIDER_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_slider.h
cvxSliderLimitGet
cvxSliderLimitSet

◆ ZW_API_SLIDER_H

#define ZW_API_SLIDER_H

Definition at line 15 of file zwapi_ui_slider.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_slider.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_slider.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_SLIDER_H /* this ifndef surrounds entire header */
15#define ZW_API_SLIDER_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
46extern evxErrors cvxSliderLimitGet(const char* Form, int idfield, double* min, double* max);
47
48/******************************************************************************/
68extern evxErrors cvxSliderLimitSet(const char* Form, int idfield, double min, double max);
69
70/*
71*********************************************************************
72** END HEADER FILE
73*********************************************************************
74*/
75
76#ifdef __cplusplus
77 }
78#endif /* __cplusplus */
79
80#endif /* ZW_API_SLIDER_H */
cvxSliderLimitGet
evxErrors cvxSliderLimitGet(const char *Form, int idfield, double *min, double *max)
cvxSliderLimitSet
evxErrors cvxSliderLimitSet(const char *Form, int idfield, double min, double max)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TABLE_WIDGET_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_tablewidget.h
cvxTableAtSet
cvxTableAtSetInit
cvxTableCallBackParamFree
cvxTableCallBackParamGet
cvxTableCellEnableSet
cvxTableCellTextGet
cvxTableCellTextSet
cvxTableCellTextSet2
cvxTableCellTipGet
cvxTableCellTipSet
cvxTableCheckSet
cvxTableColCnt
cvxTableColInsert
cvxTableColorGet
cvxTableColorSet
cvxTableColRemove
cvxTableComboGet
cvxTableComboSet
cvxTableComboSet2
cvxTableComboSetOption
cvxTableDateGet
cvxTableDateSet
cvxTableGetSelRange
cvxTableGetText
cvxTableHeaderCellCheck
cvxTableIndexComboSet
cvxTableIndexComboSet2
cvxTableInputComboSet
cvxTableInputComboSet2
cvxTableIsCheck
cvxTableNumGet
cvxTableNumSet
cvxTableRowCnt
cvxTableRowInsert
cvxTableRowRemove
cvxTableSetHeaderAlignment
cvxTableSetHeaderColResizeMode
cvxTableSetHeaderSectionSize
cvxTableSetHorHeaderList
cvxTableSetSelRange
cvxTableSetVerHeaderList
cvxTableSizeSet
cvxTableTypeGet
cvxTableUnselectAll
cvxTableVisSet

◆ ZW_API_TABLE_WIDGET_H

#define ZW_API_TABLE_WIDGET_H

Definition at line 15 of file zwapi_ui_tablewidget.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_tablewidget.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_tablewidget.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TABLE_WIDGET_H /* this ifndef surrounds entire header */
15#define ZW_API_TABLE_WIDGET_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
43extern evxErrors cvxTableAtSetInit(svxTableAt* data);
44
45/******************************************************************************/
66extern evxErrors cvxTableAtSet(char* Form, int idTable, svxTableAt* At);
67
68/******************************************************************************/
86extern evxErrors cvxTableSizeSet(char* Form, int idTable, int NumRow, int NumCol);
87
88/******************************************************************************/
110extern evxErrors cvxTableSetSelRange(const char* Form, int idTable, svxRectangle* SelRange, int bSelect);
111
112/******************************************************************************/
136extern evxErrors cvxTableGetSelRange(const char* Form, int idTable, int* RangeCnt, svxRectangle** SelRange);
137
138/******************************************************************************/
154extern evxErrors cvxTableUnselectAll(const char* Form, int idTable);
155
156
157//====================================================================================================================
159//====================================================================================================================
160/******************************************************************************/
181extern evxErrors cvxTableCallBackParamGet(const char* form, int idTable, svxTableCallBackParam* param);
182
183/******************************************************************************/
195extern void cvxTableCallBackParamFree(svxTableCallBackParam* param);
196
197
198//====================================================================================================================
200//====================================================================================================================
201/******************************************************************************/
216extern int cvxTableRowCnt(const char* Form, int idTable);
217
218/******************************************************************************/
233extern int cvxTableColCnt(const char* Form, int idTable);
234
235/******************************************************************************/
252extern evxErrors cvxTableRowInsert(const char* Form, int idTable, int Row);
253
254/******************************************************************************/
272extern evxErrors cvxTableRowRemove(const char* Form, int idTable, int Row);
273
274/******************************************************************************/
292extern evxErrors cvxTableColInsert(const char* Form, int idTable, int Col);
293
294/******************************************************************************/
312extern evxErrors cvxTableColRemove(const char* Form, int idTable, int Col);
313
314
315//====================================================================================================================
317//====================================================================================================================
318/******************************************************************************/
341extern evxErrors cvxTableComboSet(char* Form, int idTable, int Row, int Col, char* Options);
342
343/******************************************************************************/
369extern evxErrors cvxTableComboSet2(const char* Form, int idTable, int Row, int Col, char* Options, char* Images);
370
371/******************************************************************************/
393extern evxErrors cvxTableComboGet(const char* Form, int idTable, int Row, int Col, int* Index, char* Text, int nBytes);
394
395/******************************************************************************/
418extern evxErrors cvxTableIndexComboSet(char* Form, int idTable, int Row, int Col, char* Options);
419
420/******************************************************************************/
443extern evxErrors cvxTableInputComboSet(char* Form, int idTable, int Row, int Col, char* Options);
444
445/******************************************************************************/
472extern evxErrors cvxTableIndexComboSet2(const char* Form, int idTable, int Row, int Col, char* Options, char* Images);
473
474/******************************************************************************/
501extern evxErrors cvxTableInputComboSet2(const char* Form, int idTable, int Row, int Col, char* Options, char* Images);
502
503/******************************************************************************/
526extern evxErrors cvxTableComboSetOption(const char* Form, int idTable, int Row, int Col, int Index, char* IdxText);
527
528
529//====================================================================================================================
531//====================================================================================================================
532/******************************************************************************/
551extern evxErrors cvxTableTypeGet(const char* Form, int idTable, int Row, int Col, evxTableCellType* Type);
552
553/******************************************************************************/
571extern void cvxTableVisSet(char* Form, int idTable, int Row, int Col);
572
573/******************************************************************************/
591extern int cvxTableIsCheck(const char* Form, int idTable, int Row, int Col);
592
593/******************************************************************************/
613extern evxErrors cvxTableCheckSet(const char* Form, int idTable, int Row, int Col, int Check);
614
615/******************************************************************************/
636extern evxErrors cvxTableCellTextGet(char* Form, int idTable, int Row, int Col, char* text, int nBytes);
637
638/******************************************************************************/
655extern void cvxTableCellEnableSet(const char* Form, int idTable, int Row, int Col, int State);
656
657/******************************************************************************/
677extern void cvxTableCellTipSet(const char* Form, int idTable, int Row, int Col, const char* tip);
678
679/******************************************************************************/
703extern evxErrors cvxTableCellTipGet(const char* Form, int idTable, int Row, int Col, char* tip, int nBytes);
704
705/******************************************************************************/
724extern evxErrors cvxTableCellTextSet(char* Form, int idTable, int Row, int Col, char* text);
725
726/******************************************************************************/
746extern evxErrors cvxTableCellTextSet2(const char* Form, int idTable, int Row, int Col, char* Text, char* Image);
747
748/******************************************************************************/
768extern evxErrors cvxTableDateSet(const char* Form, int idTable, int Row, int Col, int Date, evxDateType DateType);
769
770/******************************************************************************/
791extern evxErrors cvxTableDateGet(const char* Form, int idTable, int Row, int Col, int* Date, evxDateType* DateType);
792
793/******************************************************************************/
814extern evxErrors cvxTableColorSet(const char* Form, int idTable, int Row, int Col, const svxColor* Color, int ClrIdx, unsigned char Type);
815
816/******************************************************************************/
838extern evxErrors cvxTableColorGet(const char* Form, int idTable, int Row, int Col, svxColor* Color, int* ClrIdx, unsigned char* Type);
839
840/******************************************************************************/
860extern evxErrors cvxTableNumSet(const char* Form, int idTable, int Row, int Col, const char* Num);
861
862/******************************************************************************/
883extern evxErrors cvxTableNumGet(const char* Form, int idTable, int Row, int Col, char* Num, int Bytes);
884
885/******************************************************************************/
908extern evxErrors cvxTableGetText(const char* Form, int idTable, int row, int col, char* text, int sizeText);
909
910//====================================================================================================================
912//====================================================================================================================
913
914/******************************************************************************/
935extern evxErrors cvxTableSetHorHeaderList(const char* Form, int idTable, int num, const char** pHeaderList);
936
937/******************************************************************************/
958extern evxErrors cvxTableSetVerHeaderList(const char* Form, int idTable, int num, const char** pHeaderList);
959
960/******************************************************************************/
978extern evxErrors cvxTableSetHeaderAlignment(const char* Form, int idTable, int isVertical, evxTableAlignFlag align);
979
980/******************************************************************************/
1007extern evxErrors cvxTableSetHeaderColResizeMode(const char* Form, int idTable, int col, evxTableResizeMode mode);
1008
1009/******************************************************************************/
1028extern evxErrors cvxTableSetHeaderSectionSize(const char* Form, int idTable, int size, int isMin);
1029
1030/******************************************************************************/
1054extern evxErrors cvxTableHeaderCellCheck(const char* Form, int idTable, int isVertical, int item, int check);
1055
1056
1057/*
1058*********************************************************************
1059** END HEADER FILE
1060*********************************************************************
1061*/
1062
1063#ifdef __cplusplus
1064 }
1065#endif /* __cplusplus */
1066
1067#endif /* ZW_API_TABLE_WIDGET_H */
evxDateType
evxDateType
data type
Definition: zwapi_ui_data.h:326
evxTableCellType
evxTableCellType
table cell types
Definition: zwapi_ui_data.h:434
evxTableAlignFlag
evxTableAlignFlag
table widget alignment mode
Definition: zwapi_ui_data.h:293
evxTableResizeMode
evxTableResizeMode
table widget resize mode
Definition: zwapi_ui_data.h:304
cvxTableDateGet
evxErrors cvxTableDateGet(const char *Form, int idTable, int Row, int Col, int *Date, evxDateType *DateType)
cvxTableColRemove
evxErrors cvxTableColRemove(const char *Form, int idTable, int Col)
cvxTableColorGet
evxErrors cvxTableColorGet(const char *Form, int idTable, int Row, int Col, svxColor *Color, int *ClrIdx, unsigned char *Type)
cvxTableIndexComboSet
evxErrors cvxTableIndexComboSet(char *Form, int idTable, int Row, int Col, char *Options)
cvxTableColInsert
evxErrors cvxTableColInsert(const char *Form, int idTable, int Col)
cvxTableGetSelRange
evxErrors cvxTableGetSelRange(const char *Form, int idTable, int *RangeCnt, svxRectangle **SelRange)
cvxTableRowRemove
evxErrors cvxTableRowRemove(const char *Form, int idTable, int Row)
cvxTableSetHeaderColResizeMode
evxErrors cvxTableSetHeaderColResizeMode(const char *Form, int idTable, int col, evxTableResizeMode mode)
cvxTableVisSet
void cvxTableVisSet(char *Form, int idTable, int Row, int Col)
cvxTableColCnt
int cvxTableColCnt(const char *Form, int idTable)
cvxTableIndexComboSet2
evxErrors cvxTableIndexComboSet2(const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
cvxTableDateSet
evxErrors cvxTableDateSet(const char *Form, int idTable, int Row, int Col, int Date, evxDateType DateType)
cvxTableSetHeaderSectionSize
evxErrors cvxTableSetHeaderSectionSize(const char *Form, int idTable, int size, int isMin)
cvxTableCheckSet
evxErrors cvxTableCheckSet(const char *Form, int idTable, int Row, int Col, int Check)
cvxTableSizeSet
evxErrors cvxTableSizeSet(char *Form, int idTable, int NumRow, int NumCol)
cvxTableGetText
evxErrors cvxTableGetText(const char *Form, int idTable, int row, int col, char *text, int sizeText)
cvxTableCellTextSet
evxErrors cvxTableCellTextSet(char *Form, int idTable, int Row, int Col, char *text)
cvxTableColorSet
evxErrors cvxTableColorSet(const char *Form, int idTable, int Row, int Col, const svxColor *Color, int ClrIdx, unsigned char Type)
cvxTableSetSelRange
evxErrors cvxTableSetSelRange(const char *Form, int idTable, svxRectangle *SelRange, int bSelect)
cvxTableComboSet
evxErrors cvxTableComboSet(char *Form, int idTable, int Row, int Col, char *Options)
cvxTableComboSetOption
evxErrors cvxTableComboSetOption(const char *Form, int idTable, int Row, int Col, int Index, char *IdxText)
cvxTableNumGet
evxErrors cvxTableNumGet(const char *Form, int idTable, int Row, int Col, char *Num, int Bytes)
cvxTableComboSet2
evxErrors cvxTableComboSet2(const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
cvxTableCellTextSet2
evxErrors cvxTableCellTextSet2(const char *Form, int idTable, int Row, int Col, char *Text, char *Image)
cvxTableCellTipGet
evxErrors cvxTableCellTipGet(const char *Form, int idTable, int Row, int Col, char *tip, int nBytes)
cvxTableAtSetInit
evxErrors cvxTableAtSetInit(svxTableAt *data)
cvxTableInputComboSet2
evxErrors cvxTableInputComboSet2(const char *Form, int idTable, int Row, int Col, char *Options, char *Images)
cvxTableCellTipSet
void cvxTableCellTipSet(const char *Form, int idTable, int Row, int Col, const char *tip)
cvxTableRowCnt
int cvxTableRowCnt(const char *Form, int idTable)
cvxTableIsCheck
int cvxTableIsCheck(const char *Form, int idTable, int Row, int Col)
cvxTableHeaderCellCheck
evxErrors cvxTableHeaderCellCheck(const char *Form, int idTable, int isVertical, int item, int check)
cvxTableInputComboSet
evxErrors cvxTableInputComboSet(char *Form, int idTable, int Row, int Col, char *Options)
cvxTableSetVerHeaderList
evxErrors cvxTableSetVerHeaderList(const char *Form, int idTable, int num, const char **pHeaderList)
cvxTableCallBackParamGet
evxErrors cvxTableCallBackParamGet(const char *form, int idTable, svxTableCallBackParam *param)
cvxTableSetHorHeaderList
evxErrors cvxTableSetHorHeaderList(const char *Form, int idTable, int num, const char **pHeaderList)
cvxTableCellEnableSet
void cvxTableCellEnableSet(const char *Form, int idTable, int Row, int Col, int State)
cvxTableTypeGet
evxErrors cvxTableTypeGet(const char *Form, int idTable, int Row, int Col, evxTableCellType *Type)
cvxTableSetHeaderAlignment
evxErrors cvxTableSetHeaderAlignment(const char *Form, int idTable, int isVertical, evxTableAlignFlag align)
cvxTableRowInsert
evxErrors cvxTableRowInsert(const char *Form, int idTable, int Row)
cvxTableComboGet
evxErrors cvxTableComboGet(const char *Form, int idTable, int Row, int Col, int *Index, char *Text, int nBytes)
cvxTableUnselectAll
evxErrors cvxTableUnselectAll(const char *Form, int idTable)
cvxTableCellTextGet
evxErrors cvxTableCellTextGet(char *Form, int idTable, int Row, int Col, char *text, int nBytes)
cvxTableNumSet
evxErrors cvxTableNumSet(const char *Form, int idTable, int Row, int Col, const char *Num)
cvxTableAtSet
evxErrors cvxTableAtSet(char *Form, int idTable, svxTableAt *At)
cvxTableCallBackParamFree
void cvxTableCallBackParamFree(svxTableCallBackParam *param)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxRectangle
Rectangle data.
Definition: zwapi_ui_data.h:260
svxTableAt
table attributes
Definition: zwapi_ui_data.h:216
svxTableCallBackParam
table widget callback function parameters
Definition: zwapi_ui_data.h:401
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TAB_WIDGET_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_tabwidget.h
cvxTabWidgetItemVisibleSet

◆ ZW_API_TAB_WIDGET_H

#define ZW_API_TAB_WIDGET_H

Definition at line 15 of file zwapi_ui_tabwidget.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_tabwidget.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_tabwidget.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TAB_WIDGET_H /* this ifndef surrounds entire header */
15#define ZW_API_TAB_WIDGET_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
45extern evxErrors cvxTabWidgetItemVisibleSet(const char* Form, int tabIdField, int tabIndex, char bVisible);
46
47/*
48*********************************************************************
49** END HEADER FILE
50*********************************************************************
51*/
52
53#ifdef __cplusplus
54}
55#endif /* __cplusplus */
56
57#endif /* ZW_API_TAB_WIDGET_H */
cvxTabWidgetItemVisibleSet
evxErrors cvxTabWidgetItemVisibleSet(const char *Form, int tabIdField, int tabIndex, char bVisible)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_TREE_VIEW_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_ui_treeview.h
cvxTreeAddItem
cvxTreeAutoResizeColumn
cvxTreeCollapseAll
cvxTreeDeleteItem
cvxTreeDeleteSubItem
cvxTreeEditItemByComboBox
cvxTreeEditItemByLineEdit
cvxTreeExpandAll
cvxTreeExpandItem
cvxTreeGetCbParam
cvxTreeGetChildItem
cvxTreeGetChildrenCount
cvxTreeGetColumnCount
cvxTreeGetColumnWidth
cvxTreeGetDBIdByItem
cvxTreeGetDescendants
cvxTreeGetItemCheckState
cvxTreeGetItemFlag
cvxTreeGetItemTextByColumn
cvxTreeGetNextSiblingItem
cvxTreeGetParentItem
cvxTreeGetPrevSiblingItem
cvxTreeGetSelectedItems
cvxTreeHeaderGetSize
cvxTreeIsColumnHidden
cvxTreeIsItemSelected
cvxTreeItemIsExpand
cvxTreeItemsCount
cvxTreeMoveItems
cvxTreeSelectItem
cvxTreeSetColumnCount
cvxTreeSetColumnHidden
cvxTreeSetColumnWidth
cvxTreeSetHeaderIcon
cvxTreeSetHeaderText
cvxTreeSetHeaderTextAlignment
cvxTreeSetItemCheckable
cvxTreeSetItemCheckState
cvxTreeSetItemFlag
cvxTreeSetItemIconNameByColumn
cvxTreeSetItemTextByColumn
cvxTreeSetItemTextColor
cvxTreeSetSelectionBehavior
cvxTreeSetSelectionMode
cvxTreeUnselectAll

◆ ZW_API_TREE_VIEW_H

#define ZW_API_TREE_VIEW_H

Definition at line 15 of file zwapi_ui_treeview.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_ui_treeview.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_ui_treeview.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_TREE_VIEW_H /* this ifndef surrounds entire header */
15#define ZW_API_TREE_VIEW_H
16
17#include "zwapi_ui_data.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
42extern void cvxTreeSetHeaderIcon(const char* name, int field, int section, const char* icon);
43
44/******************************************************************************/
65extern void cvxTreeSetHeaderText(const char* form, int field, int col, const char* text);
66
67/******************************************************************************/
86extern evxErrors cvxTreeHeaderGetSize(const char* form, int field, int* width, int* height);
87
88/******************************************************************************/
109extern evxErrors cvxTreeSetHeaderTextAlignment(const char* form, int field, int col, evxAlignFlag align);
110
111
112//====================================================================================================================
114//====================================================================================================================
115/******************************************************************************/
130extern void cvxTreeSetColumnCount(const char* form, int field, int count);
131
132/******************************************************************************/
148extern int cvxTreeGetColumnCount(const char* form, int field);
149
150/******************************************************************************/
165extern void cvxTreeSetColumnWidth(const char* form, int field, int col, int width);
166
167/******************************************************************************/
183extern int cvxTreeGetColumnWidth(const char* form, int field, int col);
184
185/******************************************************************************/
200extern void cvxTreeSetColumnHidden(const char* form, int field, int col, int hide);
201
202/******************************************************************************/
218extern int cvxTreeIsColumnHidden(const char* form, int field, int col);
219
220/******************************************************************************/
236extern evxErrors cvxTreeAutoResizeColumn(const char* form, int field, int col);
237
238
239//====================================================================================================================
241//====================================================================================================================
242/******************************************************************************/
255extern void cvxTreeExpandAll(const char* form, int field);
256
257/******************************************************************************/
270extern void cvxTreeCollapseAll(const char* form, int field);
271
272/******************************************************************************/
288extern evxErrors cvxTreeUnselectAll(const char* form, int field);
289
290/******************************************************************************/
311extern evxErrors cvxTreeSetSelectionMode(const char* form, int field, int mode);
312
313/******************************************************************************/
330extern evxErrors cvxTreeSetSelectionBehavior(const char* form, int field, int behavior);
331
332
333//====================================================================================================================
335//====================================================================================================================
336/******************************************************************************/
355extern evxErrors cvxTreeGetCbParam(const char* form, int field, int itemId, svxTreeCbParam* cbp);
356
357
358//====================================================================================================================
360//====================================================================================================================
361/******************************************************************************/
377extern int cvxTreeItemsCount(const char* form, int field);
378
379/******************************************************************************/
406extern evxErrors cvxTreeAddItem(const char* form, int field, int parentId, int siblingId, const char* label,
407 int imgIdx, int folderIdx, evxTreeItemType itemType, int dbIdx, int itemflag, int* outItemId, const char* cmdName);
408
409/******************************************************************************/
428extern evxErrors cvxTreeSetItemFlag(const char* form, int field, int count, int* ids, int flag);
429
430/******************************************************************************/
449extern evxErrors cvxTreeGetItemFlag(const char* form, int field, int id, int* flag);
450
451/******************************************************************************/
470extern evxErrors cvxTreeSetItemIconNameByColumn(const char* form, int field, int id, int col, const char* iconName);
471
472/******************************************************************************/
491extern evxErrors cvxTreeSetItemTextByColumn(const char* form, int field, int id, int col, const char* text);
492
493/******************************************************************************/
512extern void cvxTreeGetItemTextByColumn(const char* form, int field, int id, int col, char* text, int size);
513
514/******************************************************************************/
533extern evxErrors cvxTreeSetItemTextColor(const char* form, int field, int id, int col, svxColor* color);
534
535/******************************************************************************/
553extern evxErrors cvxTreeGetDBIdByItem(const char* form, int field, int id, int* objectIndex);
554
555/******************************************************************************/
572extern evxErrors cvxTreeDeleteItem(const char* form, int field, int id);
573
574/******************************************************************************/
591extern evxErrors cvxTreeDeleteSubItem(const char* form, int field, int id);
592
593/******************************************************************************/
612extern evxErrors cvxTreeEditItemByLineEdit(const char* form, int field, int id, int col, const char* defaultLabel);
613
614/******************************************************************************/
641extern evxErrors cvxTreeEditItemByComboBox(const char* form, int field, int id, int col, const char* Options, const char* Images, int curIndex);
642
643/******************************************************************************/
662extern evxErrors cvxTreeGetPrevSiblingItem(const char* form, int field, int id, int* prevId);
663
664/******************************************************************************/
683extern evxErrors cvxTreeGetNextSiblingItem(const char* form, int field, int id, int* nextId);
684
685/******************************************************************************/
706extern evxErrors cvxTreeGetChildItem(const char* form, int field, int id, int index, int* child_id);
707
708/******************************************************************************/
727extern evxErrors cvxTreeGetChildrenCount(const char* form, int field, int id, int* count);
728
729/******************************************************************************/
748extern evxErrors cvxTreeGetParentItem(const char* form, int field, int id, int* parent);
749
750/******************************************************************************/
772extern evxErrors cvxTreeMoveItems(const char* form, int field, int numNodes, int* ids, int insParentId, int siblingId);
773
774/******************************************************************************/
796extern evxErrors cvxTreeGetDescendants(const char* form, int field, int isAll, int parent, int* num, int** ids);
797
798/******************************************************************************/
817extern evxErrors cvxTreeGetSelectedItems(const char* form, int field, int* count, int** ids);
818
819
820//====================================================================================================================
822//====================================================================================================================
823/******************************************************************************/
840extern int cvxTreeIsItemSelected(const char* form, int field, int id);
841
842/******************************************************************************/
859extern evxErrors cvxTreeSelectItem(const char* form, int field, int id);
860
861/******************************************************************************/
879extern evxErrors cvxTreeSetItemCheckable(const char* form, int field, int id, int checkable);
880
881/******************************************************************************/
897extern evxTreeCheckState cvxTreeGetItemCheckState(const char* form, int field, int id);
898
899/******************************************************************************/
916extern void cvxTreeSetItemCheckState(const char* form, int field, int id, evxTreeCheckState checkState, int extToChild);
917
918/******************************************************************************/
935extern int cvxTreeItemIsExpand(const char* form, int field, int id);
936
937/******************************************************************************/
955extern evxErrors cvxTreeExpandItem(const char* form, int field, int id, int option);
956
957
958/*
959*********************************************************************
960** END HEADER FILE
961*********************************************************************
962*/
963
964#ifdef __cplusplus
965 }
966#endif /* __cplusplus */
967
968#endif /* ZW_API_TREE_VIEW_H */
evxTreeItemType
evxTreeItemType
tree widget item types
Definition: zwapi_ui_data.h:486
evxTreeCheckState
evxTreeCheckState
check tree item state
Definition: zwapi_ui_data.h:589
evxAlignFlag
evxAlignFlag
ui alignment types
Definition: zwapi_ui_data.h:420
cvxTreeAutoResizeColumn
evxErrors cvxTreeAutoResizeColumn(const char *form, int field, int col)
cvxTreeEditItemByLineEdit
evxErrors cvxTreeEditItemByLineEdit(const char *form, int field, int id, int col, const char *defaultLabel)
cvxTreeSetItemTextColor
evxErrors cvxTreeSetItemTextColor(const char *form, int field, int id, int col, svxColor *color)
cvxTreeGetColumnWidth
int cvxTreeGetColumnWidth(const char *form, int field, int col)
cvxTreeSetHeaderIcon
void cvxTreeSetHeaderIcon(const char *name, int field, int section, const char *icon)
cvxTreeExpandItem
evxErrors cvxTreeExpandItem(const char *form, int field, int id, int option)
cvxTreeSetHeaderTextAlignment
evxErrors cvxTreeSetHeaderTextAlignment(const char *form, int field, int col, evxAlignFlag align)
cvxTreeHeaderGetSize
evxErrors cvxTreeHeaderGetSize(const char *form, int field, int *width, int *height)
cvxTreeIsColumnHidden
int cvxTreeIsColumnHidden(const char *form, int field, int col)
cvxTreeGetSelectedItems
evxErrors cvxTreeGetSelectedItems(const char *form, int field, int *count, int **ids)
cvxTreeGetCbParam
evxErrors cvxTreeGetCbParam(const char *form, int field, int itemId, svxTreeCbParam *cbp)
cvxTreeMoveItems
evxErrors cvxTreeMoveItems(const char *form, int field, int numNodes, int *ids, int insParentId, int siblingId)
cvxTreeGetParentItem
evxErrors cvxTreeGetParentItem(const char *form, int field, int id, int *parent)
cvxTreeSetSelectionBehavior
evxErrors cvxTreeSetSelectionBehavior(const char *form, int field, int behavior)
cvxTreeSelectItem
evxErrors cvxTreeSelectItem(const char *form, int field, int id)
cvxTreeGetItemCheckState
evxTreeCheckState cvxTreeGetItemCheckState(const char *form, int field, int id)
cvxTreeGetChildItem
evxErrors cvxTreeGetChildItem(const char *form, int field, int id, int index, int *child_id)
cvxTreeSetItemCheckState
void cvxTreeSetItemCheckState(const char *form, int field, int id, evxTreeCheckState checkState, int extToChild)
cvxTreeSetItemCheckable
evxErrors cvxTreeSetItemCheckable(const char *form, int field, int id, int checkable)
cvxTreeEditItemByComboBox
evxErrors cvxTreeEditItemByComboBox(const char *form, int field, int id, int col, const char *Options, const char *Images, int curIndex)
cvxTreeItemIsExpand
int cvxTreeItemIsExpand(const char *form, int field, int id)
cvxTreeGetPrevSiblingItem
evxErrors cvxTreeGetPrevSiblingItem(const char *form, int field, int id, int *prevId)
cvxTreeSetItemTextByColumn
evxErrors cvxTreeSetItemTextByColumn(const char *form, int field, int id, int col, const char *text)
cvxTreeSetSelectionMode
evxErrors cvxTreeSetSelectionMode(const char *form, int field, int mode)
cvxTreeGetColumnCount
int cvxTreeGetColumnCount(const char *form, int field)
cvxTreeSetColumnWidth
void cvxTreeSetColumnWidth(const char *form, int field, int col, int width)
cvxTreeGetItemTextByColumn
void cvxTreeGetItemTextByColumn(const char *form, int field, int id, int col, char *text, int size)
cvxTreeSetColumnCount
void cvxTreeSetColumnCount(const char *form, int field, int count)
cvxTreeAddItem
evxErrors cvxTreeAddItem(const char *form, int field, int parentId, int siblingId, const char *label, int imgIdx, int folderIdx, evxTreeItemType itemType, int dbIdx, int itemflag, int *outItemId, const char *cmdName)
cvxTreeGetItemFlag
evxErrors cvxTreeGetItemFlag(const char *form, int field, int id, int *flag)
cvxTreeSetHeaderText
void cvxTreeSetHeaderText(const char *form, int field, int col, const char *text)
cvxTreeIsItemSelected
int cvxTreeIsItemSelected(const char *form, int field, int id)
cvxTreeSetColumnHidden
void cvxTreeSetColumnHidden(const char *form, int field, int col, int hide)
cvxTreeItemsCount
int cvxTreeItemsCount(const char *form, int field)
cvxTreeExpandAll
void cvxTreeExpandAll(const char *form, int field)
cvxTreeSetItemIconNameByColumn
evxErrors cvxTreeSetItemIconNameByColumn(const char *form, int field, int id, int col, const char *iconName)
cvxTreeUnselectAll
evxErrors cvxTreeUnselectAll(const char *form, int field)
cvxTreeCollapseAll
void cvxTreeCollapseAll(const char *form, int field)
cvxTreeGetNextSiblingItem
evxErrors cvxTreeGetNextSiblingItem(const char *form, int field, int id, int *nextId)
cvxTreeSetItemFlag
evxErrors cvxTreeSetItemFlag(const char *form, int field, int count, int *ids, int flag)
cvxTreeDeleteItem
evxErrors cvxTreeDeleteItem(const char *form, int field, int id)
cvxTreeGetChildrenCount
evxErrors cvxTreeGetChildrenCount(const char *form, int field, int id, int *count)
cvxTreeGetDescendants
evxErrors cvxTreeGetDescendants(const char *form, int field, int isAll, int parent, int *num, int **ids)
cvxTreeDeleteSubItem
evxErrors cvxTreeDeleteSubItem(const char *form, int field, int id)
cvxTreeGetDBIdByItem
evxErrors cvxTreeGetDBIdByItem(const char *form, int field, int id, int *objectIndex)
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxTreeCbParam
tree widget callback function parameters
Definition: zwapi_ui_data.h:538
zwapi_ui_data.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_USER_INPUT_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_userinput.h
cvxGetAngle
cvxGetDistance
cvxGetEnt
cvxGetEntPath
cvxGetEntPaths
cvxGetEntPathsMultiFilter
cvxGetEnts
cvxGetEntsMultiFilter
cvxGetExternalPick
cvxGetFile
cvxGetFileActiveField
cvxGetFileByLongPath
cvxGetFolder
cvxGetFolderActiveField
cvxGetFolderByLongPath
cvxGetNumber
cvxGetPoint
cvxGetPointOnEnt
cvxGetPoints
cvxGetPointsOnEnts
cvxGetResponse
cvxGetString
evxEntInpOpt
evxEntInpOpt
evxPntInpOpt
evxPntInpOpt

◆ ZW_API_USER_INPUT_H

#define ZW_API_USER_INPUT_H

Definition at line 15 of file zwapi_userinput.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_userinput.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_userinput.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_USER_INPUT_H /* this ifndef surrounds entire header */
15#define ZW_API_USER_INPUT_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
30typedef enum evxEntInpOpt
31 {
32 VX_INP_UNDEFINED = 0,
33 VX_INP_GENERAL_3D = 1,
34 VX_INP_GENERAL_2D = 2,
35 VX_INP_SHAPE = 3,
36 VX_INP_FACE = 4,
37 VX_INP_SHAPE_OR_FACE = 5,
38 VX_INP_EDGE = 6,
39 VX_INP_CURVE = 7,
40 VX_INP_EDGE_OR_CURVE = 8,
41 VX_INP_CURVE_LIST = 9,
42 VX_INP_PARTING_CURVE = 10,
43 VX_INP_POINT = 11,
44 VX_INP_FEATURE = 12,
45 VX_INP_SKETCH = 13,
46 VX_INP_DATUM_PLANE = 14,
47 VX_INP_REF_PLANE = 15,
48 VX_INP_3D_BLOCK = 16,
49 VX_INP_LIGHT = 17,
50 VX_INP_LAYER = 18,
51 VX_INP_REF_GEOM = 19,
52 VX_INP_WIREFRAME = 20,
53 VX_INP_MOVE = 21,
54 VX_INP_BLANK = 22,
55 VX_INP_ERASE = 23,
56 VX_INP_INQUIRE = 24,
57 VX_INP_3D_GEOM = 25,
58 VX_INP_TEXT = 26,
59 VX_INP_PROF = 27,
60 VX_INP_COMP = 28,
61 VX_INP_ASM_SHAPE = 29,
62 VX_INP_FACE_ON_SHAPE = 30,
63 VX_INP_SUB_COMP = 31,
64 VX_INP_CSYS = 32,
65 VX_INP_AXIS_3D = 33,
66 VX_INP_AXIS_2D = 34,
67 } evxEntInpOpt;
68
69//====================================================================================================================
71//====================================================================================================================
76typedef enum evxPntInpOpt
77 {
78 VX_INP_PNT_GENERAL = 0,
79 VX_INP_PNT_ON_ENTITY = 1,
80 VX_INP_PNT_ON_CURVE = 2,
81 VX_INP_PNT_ON_EDGE = 3,
82 VX_INP_PNT_ON_CURVE_OR_EDGE = 4,
83 VX_INP_PNT_ON_ANY_FACE = 5,
84 VX_INP_PNT_ON_FIELD_1_FACE = 6,
85 VX_INP_PNT_END = 7,
86 VX_INP_PNT_ASSEMBLY = 8,
87 VX_INP_PNT_DIRECTION = 9,
88 VX_INP_PNT_ON_CRV_OR_PROF = 10,
89 VX_INP_PNT_ASSEM_FACE = 11,
90 VX_INP_PNT_ASSEM_EDGE = 12,
91 VX_INP_PNT_ASSEM_CURVE = 13
92 } evxPntInpOpt;
93
94//====================================================================================================================
96//====================================================================================================================
97/******************************************************************************/
111extern evxErrors cvxGetAngle(const char* Prompt, double* Angle);
112
113/******************************************************************************/
127extern evxErrors cvxGetDistance(const char* Prompt, double* Distance);
128
129/******************************************************************************/
143extern evxErrors cvxGetNumber(const char* Prompt, double* Number);
144
145
146//====================================================================================================================
148//====================================================================================================================
149/******************************************************************************/
166extern evxErrors cvxGetEnt(const char* Prompt, evxEntInpOpt Opt, int EmptyOk, int* idEntity);
167
168/******************************************************************************/
187extern evxErrors cvxGetEnts(const char* Prompt, evxEntInpOpt Opt, int EmptyOk, int* Count, int** idEnts);
188
189/******************************************************************************/
207extern evxErrors cvxGetEntPath(const char* Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath* Path);
208
209/******************************************************************************/
228extern evxErrors cvxGetEntPaths(const char* Prompt, evxEntInpOpt Opt, int EmptyOk, int* Count, svxEntPath** Paths);
229
230/******************************************************************************/
251extern evxErrors cvxGetEntsMultiFilter(const char* Prompt, evxEntInpOpt* pOpt, int npOpt, int EmptyOk, int* Count, int** idEnts);
252
253/******************************************************************************/
274extern evxErrors cvxGetEntPathsMultiFilter(const char* Prompt, evxEntInpOpt* pOpt, int npOpt, int EmptyOk, int* Count, svxEntPath** Paths);
275
276/******************************************************************************/
321extern evxErrors cvxGetExternalPick(const char* Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint* Point, svxEntPath* EntPath, svxMatrix* Matrix);
322
323
324//====================================================================================================================
326//====================================================================================================================
327/******************************************************************************/
346extern evxErrors cvxGetPoint(const char* Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint* Point, int* idEntity);
347
348/******************************************************************************/
367extern evxErrors cvxGetPoints(const char* Prompt, evxPntInpOpt Opt, int EmptyOk, int* Count, svxPoint** Points);
368
369/******************************************************************************/
388extern evxErrors cvxGetPointOnEnt(const char* prompt, evxPntInpOpt opt, int emptyOk, svxPoint* point, svxEntPath* path);
389
390/******************************************************************************/
410extern evxErrors cvxGetPointsOnEnts(const char* prompt, evxPntInpOpt opt, int emptyOk, int* count, svxPoint** points, svxEntPath** paths);
411
412
413//====================================================================================================================
415//====================================================================================================================
416/******************************************************************************/
456extern void cvxGetFile(int Open, const char* Prompt, const char* Default, const char* Filter, char* Path);
457
458/******************************************************************************/
499extern void cvxGetFileByLongPath(int Open, const char* Prompt, const char* Default, const char* Filter, char* Path,int sizePath);
500
501/******************************************************************************/
565extern void cvxGetFileActiveField(int Open, const char* Prompt, const char* Default, const char* Filter);
566
567/******************************************************************************/
588extern void cvxGetFolder(const char* Prompt, char* Default, vxPath path);
589
590/******************************************************************************/
616extern void cvxGetFolderByLongPath(const char* Prompt, char* Default, char* Path,int sizePath);
617
618/******************************************************************************/
658extern void cvxGetFolderActiveField(const char* Prompt, const char* Default);
659
660
661//====================================================================================================================
663//====================================================================================================================
664/******************************************************************************/
684extern int cvxGetResponse(int Option, const char* Message);
685
686/******************************************************************************/
702extern int cvxGetString(const char* Prompt, const char* Default, int NumBytes, char* String);
703
704
705/*
706*********************************************************************
707** END HEADER FILE
708*********************************************************************
709*/
710
711#ifdef __cplusplus
712 }
713#endif /* __cplusplus */
714
715#endif /* ZW_API_USER_INPUT_H */
cvxGetNumber
evxErrors cvxGetNumber(const char *Prompt, double *Number)
cvxGetFolderActiveField
void cvxGetFolderActiveField(const char *Prompt, const char *Default)
cvxGetPointOnEnt
evxErrors cvxGetPointOnEnt(const char *prompt, evxPntInpOpt opt, int emptyOk, svxPoint *point, svxEntPath *path)
cvxGetEntPaths
evxErrors cvxGetEntPaths(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, svxEntPath **Paths)
cvxGetPointsOnEnts
evxErrors cvxGetPointsOnEnts(const char *prompt, evxPntInpOpt opt, int emptyOk, int *count, svxPoint **points, svxEntPath **paths)
cvxGetResponse
int cvxGetResponse(int Option, const char *Message)
cvxGetEntPathsMultiFilter
evxErrors cvxGetEntPathsMultiFilter(const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, svxEntPath **Paths)
cvxGetEnt
evxErrors cvxGetEnt(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *idEntity)
cvxGetEntsMultiFilter
evxErrors cvxGetEntsMultiFilter(const char *Prompt, evxEntInpOpt *pOpt, int npOpt, int EmptyOk, int *Count, int **idEnts)
evxPntInpOpt
evxPntInpOpt
point input options
Definition: zwapi_userinput.h:77
VX_INP_PNT_ON_CURVE
@ VX_INP_PNT_ON_CURVE
point on curve
Definition: zwapi_userinput.h:80
VX_INP_PNT_DIRECTION
@ VX_INP_PNT_DIRECTION
point direction
Definition: zwapi_userinput.h:87
VX_INP_PNT_ON_CRV_OR_PROF
@ VX_INP_PNT_ON_CRV_OR_PROF
point on curve or profile
Definition: zwapi_userinput.h:88
VX_INP_PNT_ON_ENTITY
@ VX_INP_PNT_ON_ENTITY
point on entity
Definition: zwapi_userinput.h:79
VX_INP_PNT_ON_CURVE_OR_EDGE
@ VX_INP_PNT_ON_CURVE_OR_EDGE
point on curve or edge
Definition: zwapi_userinput.h:82
VX_INP_PNT_ON_EDGE
@ VX_INP_PNT_ON_EDGE
point on edge
Definition: zwapi_userinput.h:81
VX_INP_PNT_GENERAL
@ VX_INP_PNT_GENERAL
general point
Definition: zwapi_userinput.h:78
VX_INP_PNT_END
@ VX_INP_PNT_END
point end
Definition: zwapi_userinput.h:85
VX_INP_PNT_ON_FIELD_1_FACE
@ VX_INP_PNT_ON_FIELD_1_FACE
point on fidle 1 face(specifial face)
Definition: zwapi_userinput.h:84
VX_INP_PNT_ASSEM_FACE
@ VX_INP_PNT_ASSEM_FACE
point on assembly face
Definition: zwapi_userinput.h:89
VX_INP_PNT_ASSEMBLY
@ VX_INP_PNT_ASSEMBLY
point in assembly environment
Definition: zwapi_userinput.h:86
VX_INP_PNT_ASSEM_CURVE
@ VX_INP_PNT_ASSEM_CURVE
point on assembly curve
Definition: zwapi_userinput.h:91
VX_INP_PNT_ON_ANY_FACE
@ VX_INP_PNT_ON_ANY_FACE
point on any face
Definition: zwapi_userinput.h:83
VX_INP_PNT_ASSEM_EDGE
@ VX_INP_PNT_ASSEM_EDGE
point on assembly edge
Definition: zwapi_userinput.h:90
cvxGetPoint
evxErrors cvxGetPoint(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, int *idEntity)
cvxGetEnts
evxErrors cvxGetEnts(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, int *Count, int **idEnts)
cvxGetFile
void cvxGetFile(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path)
cvxGetPoints
evxErrors cvxGetPoints(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, int *Count, svxPoint **Points)
cvxGetAngle
evxErrors cvxGetAngle(const char *Prompt, double *Angle)
cvxGetFolder
void cvxGetFolder(const char *Prompt, char *Default, vxPath path)
cvxGetEntPath
evxErrors cvxGetEntPath(const char *Prompt, evxEntInpOpt Opt, int EmptyOk, svxEntPath *Path)
cvxGetFolderByLongPath
void cvxGetFolderByLongPath(const char *Prompt, char *Default, char *Path, int sizePath)
cvxGetExternalPick
evxErrors cvxGetExternalPick(const char *Prompt, evxPntInpOpt Opt, int EmptyOk, svxPoint *Point, svxEntPath *EntPath, svxMatrix *Matrix)
cvxGetFileActiveField
void cvxGetFileActiveField(int Open, const char *Prompt, const char *Default, const char *Filter)
evxEntInpOpt
evxEntInpOpt
entity input options
Definition: zwapi_userinput.h:31
VX_INP_LAYER
@ VX_INP_LAYER
pick layer
Definition: zwapi_userinput.h:50
VX_INP_UNDEFINED
@ VX_INP_UNDEFINED
undefined
Definition: zwapi_userinput.h:32
VX_INP_SHAPE_OR_FACE
@ VX_INP_SHAPE_OR_FACE
pick shape or face
Definition: zwapi_userinput.h:37
VX_INP_AXIS_3D
@ VX_INP_AXIS_3D
pick 3d axis
Definition: zwapi_userinput.h:65
VX_INP_3D_BLOCK
@ VX_INP_3D_BLOCK
pick 3d block
Definition: zwapi_userinput.h:48
VX_INP_SUB_COMP
@ VX_INP_SUB_COMP
pick sub-component in pick-path, instead of the top-level component
Definition: zwapi_userinput.h:63
VX_INP_SHAPE
@ VX_INP_SHAPE
pick shape
Definition: zwapi_userinput.h:35
VX_INP_TEXT
@ VX_INP_TEXT
pick text
Definition: zwapi_userinput.h:58
VX_INP_POINT
@ VX_INP_POINT
pick point
Definition: zwapi_userinput.h:43
VX_INP_EDGE_OR_CURVE
@ VX_INP_EDGE_OR_CURVE
pick edge or curve
Definition: zwapi_userinput.h:40
VX_INP_CURVE_LIST
@ VX_INP_CURVE_LIST
pick curve list
Definition: zwapi_userinput.h:41
VX_INP_CURVE
@ VX_INP_CURVE
pick curve
Definition: zwapi_userinput.h:39
VX_INP_CSYS
@ VX_INP_CSYS
pick CSYS
Definition: zwapi_userinput.h:64
VX_INP_INQUIRE
@ VX_INP_INQUIRE
pick inquire
Definition: zwapi_userinput.h:56
VX_INP_DATUM_PLANE
@ VX_INP_DATUM_PLANE
pick datum plane
Definition: zwapi_userinput.h:46
VX_INP_REF_GEOM
@ VX_INP_REF_GEOM
pick reference geometry
Definition: zwapi_userinput.h:51
VX_INP_COMP
@ VX_INP_COMP
select the top-level component
Definition: zwapi_userinput.h:60
VX_INP_WIREFRAME
@ VX_INP_WIREFRAME
pick wireframe
Definition: zwapi_userinput.h:52
VX_INP_MOVE
@ VX_INP_MOVE
pick move
Definition: zwapi_userinput.h:53
VX_INP_3D_GEOM
@ VX_INP_3D_GEOM
pick 3d geometry
Definition: zwapi_userinput.h:57
VX_INP_AXIS_2D
@ VX_INP_AXIS_2D
pick 2d axis
Definition: zwapi_userinput.h:66
VX_INP_FACE_ON_SHAPE
@ VX_INP_FACE_ON_SHAPE
pick face on shape
Definition: zwapi_userinput.h:62
VX_INP_EDGE
@ VX_INP_EDGE
pick edge
Definition: zwapi_userinput.h:38
VX_INP_ASM_SHAPE
@ VX_INP_ASM_SHAPE
pick shape in the assembly
Definition: zwapi_userinput.h:61
VX_INP_ERASE
@ VX_INP_ERASE
pick erase
Definition: zwapi_userinput.h:55
VX_INP_LIGHT
@ VX_INP_LIGHT
pick light
Definition: zwapi_userinput.h:49
VX_INP_FACE
@ VX_INP_FACE
pick face
Definition: zwapi_userinput.h:36
VX_INP_SKETCH
@ VX_INP_SKETCH
pick sketch
Definition: zwapi_userinput.h:45
VX_INP_REF_PLANE
@ VX_INP_REF_PLANE
pick reference plane
Definition: zwapi_userinput.h:47
VX_INP_FEATURE
@ VX_INP_FEATURE
pick feature
Definition: zwapi_userinput.h:44
VX_INP_BLANK
@ VX_INP_BLANK
pick blank
Definition: zwapi_userinput.h:54
VX_INP_PARTING_CURVE
@ VX_INP_PARTING_CURVE
pick parting curve
Definition: zwapi_userinput.h:42
VX_INP_PROF
@ VX_INP_PROF
pick profile
Definition: zwapi_userinput.h:59
VX_INP_GENERAL_3D
@ VX_INP_GENERAL_3D
pick 3d general entity
Definition: zwapi_userinput.h:33
VX_INP_GENERAL_2D
@ VX_INP_GENERAL_2D
pick 2d general entity
Definition: zwapi_userinput.h:34
cvxGetDistance
evxErrors cvxGetDistance(const char *Prompt, double *Distance)
cvxGetFileByLongPath
void cvxGetFileByLongPath(int Open, const char *Prompt, const char *Default, const char *Filter, char *Path, int sizePath)
cvxGetString
int cvxGetString(const char *Prompt, const char *Default, int NumBytes, char *String)
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_UTIL_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_util.h
evxAngUnitType
evxAngUnitType
evxAtItemId
evxAtItemId
evxAttributeType
evxAttributeType
evxAxisType
evxAxisType
evxCmAttrValueType
evxCmAttrValueType
evxCmPlanDispMode
evxCmPlanDispMode
evxCmTreeType
evxCmTreeType
evxColor
evxColor
evxColorAppFlag
evxColorAppFlag
evxContinuityTyp
evxContinuityTyp
evxCurveType
evxCurveType
evxDateFormat
evxDateFormat
evxDensityUnitType
evxDensityUnitType
evxDimLineMode
evxDimLineMode
evxDimState
evxDimState
evxDimType
evxDimType
evxDimTypeEx
evxDimTypeEx
evxDirType
evxDirType
evxEdgeType
evxEdgeType
evxEntFind
evxEntFind
evxEntType
evxEntType
evxEnvironment
evxEnvironment
evxErrors
evxErrors
evxEulerAngSeq
evxEulerAngSeq
evxExtendOpt
evxExtendOpt
evxFairingType
evxFairingType
evxFCSLmsOption
evxFCSLmsOption
evxFCSShapeSym
evxFCSShapeSym
evxFCSSymbol
evxFCSSymbol
evxFindRule
evxFindRule
evxGeomCritPnt
evxGeomCritPnt
evxHoleDimDataItem
evxHoleDimDataItem
evxLineWidth
evxLineWidth
evxMassMomentUnitType
evxMassMomentUnitType
evxMassUnitType
evxMassUnitType
evxNumType
evxNumType
evxPlacingType
evxPlacingType
evxPntLocation
evxPntLocation
evxPntType
evxPntType
evxSrfPrimType
evxSrfPrimType
evxSurfaceType
evxSurfaceType
evxTermType
evxTermType
evxTextureLoc
evxTextureLoc
evxTextureOpt
evxTextureOpt
evxUnitType
evxUnitType
evxVarNumType
evxVarNumType
evxVarType
evxVarType
evxViewLineAttrIdx
evxViewLineAttrIdx
evxViewStd
evxViewStd
svxAttribute
svxAxis
svxBndBox
svxCmAttrValue
svxColor
svxColorf
svxCompName
svxCone
svxControlPoints
svxCrvContinuityData
svxCrvContinuityTolList
svxCrvIntData
svxCurve
svxCylinder
svxData
svxDimAttr
svxDirOnEntPath
svxEllipsoid
svxEntFind
svxEntPath
svxEntPick
svxFaceAt
svxFacets
svxFCSData
svxFCSDatum
svxFCSTol
svxLimit
svxLineAt
svxMatEuler
svxMatrix
svxParameters
svxPartAttribute
svxPlane
svxPntOnEnt
svxPntOnEntPath
svxPoint
svxPoint2
svxPoint2f
svxPointf
svxPrfAreaProp
svxShaderAt
svxSphere
svxSplineData
svxSplinePnt
svxSrfPrim
svxSurface
svxTextAt
svxTextureAt
svxTorus
svxTriangle
svxUid
svxVariable
svxVector
svxVector2
svxView
svxWireAt
V_PP_LEN
VX_API_VERSION
vxExp
vxLongName
vxLongPath
vxName
vxPath
vxRootName
vxUint32
vxVarExp

◆ ZW_API_UTIL_H

#define ZW_API_UTIL_H

Definition at line 15 of file zwapi_util.h.
Generated at Sun Apr 23 2023 16:41:40 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_util.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_util.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_UTIL_H /* this ifndef surrounds entire header */
15#define ZW_API_UTIL_H
16
17#ifdef __cplusplus
18extern "C" {
19#endif /* __cplusplus */
20
25#define VX_API_VERSION 2800
26
27//====================================================================================================================
29//====================================================================================================================
34typedef enum evxErrors
35 {
36 /* success */
37 ZW_API_NO_ERROR = 0,
39 /* -1/1 is used as an interface custom return value */
40
41 /* ZW3D internal function fails */
42 ZW_API_GENERAL_ERROR = -10000,
44 /* root environment error */
45 ZW_API_ROOT_OBJ_ACT_FAIL = -5,
46 ZW_API_WRONG_ROOT_ENV = -6,
47 ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR = -7,
49 ZW_API_ROOT_ERROR = -8,
51 /* input/ output error */
52 ZW_API_INVALID_INPUT = -31,
53 ZW_API_INPUT_ERROR = -32,
54 ZW_API_INPUT_TYPE_ERROR = -33,
55 ZW_API_INVALID_OUTPUT = -34,
57 /* file fail */
58 ZW_API_FILE_LOCATE_FAIL = -61,
59 ZW_API_FILE_ERROR = -62,
61 /* object error */
62 ZW_API_OBJ_TYPE_ERROR = -91,
63 ZW_API_OBJ_DATA_GET_ERROR = -92,
64 ZW_API_OBJ_DATA_SET_ERROR = -93,
65 ZW_API_INVALID_OBJ = -94,
67 /* entity path error */
68 ZW_API_ENT_PATH_ERROR = -121,
69 ZW_API_INVALID_ENT_PATH = -122,
71 /* command error */
72 ZW_API_CMMD_INIT_ERROR = -151,
73 ZW_API_CMMD_EXEC_ERROR = -152,
74 ZW_API_CMMD_DATA_ERROR = -153,
75 /* command register error */
76 ZW_API_FUN_REGISTER_ERROR = -160,
77 ZW_API_FUN_UNLOAD_ERROR = -161,
79 /* memory error */
80 ZW_API_MEMORY_ERROR = -181,
81 ZW_API_OUT_OF_RANGE = -182,
83 /* modeling data error */
84 ZW_API_MODELING_DATA_ERROR = -211,
85 ZW_API_BOOLEAN_ADD_BASE_ERROR = -212,
87 /* string error */
88 ZW_API_INVALID_NAME = -241,
89 ZW_API_INVALID_PATH = -242,
90 ZW_API_INVALID_STRING = -243,
91 ZW_API_PATH_LEN_OVER_RANGE = -244,
92 ZW_API_NAME_LEN_OVER_RANGE = -245,
93 ZW_API_PATH_LEN_LESS_RANGE = -246,
94 ZW_API_NAME_LEN_LESS_RANGE = -247,
96 /* UI */
97 ZW_API_FORM_CREATE_FAIL = -271,
98 ZW_API_FORM_SHOW_FAIL = -272,
99 ZW_API_FORM_EXIST_ERROR = -273,
100 ZW_API_FORM_INIT_ERROR = -274,
102 /* Table */
103 ZW_API_TABLE_SETDATA_ERROR = -281,
104 ZW_API_TABLE_GETDATA_ERROR = -282,
106 /* License */
107 ZW_API_LICENSE_NESTING_ERROR = -301,
109 /* Function */
110 ZW_API_FUNCTION_CB_GET_ERROR = -401,
111 ZW_API_FUCNTION_CB_EXIST_ERROR = -402,
112 ZW_API_FUCNTION_CB_EXECUTION_ERROR = -403,
114 /* cam operation error */
115 ZW_API_CAM_OPTYPE_ERROR = -1001,
116 ZW_API_CAM_GETOPNAME_ERROR = -1002,
117 ZW_API_CAM_GETOPBYTAC_ERROR = -1003,
118 ZW_API_CAM_GETOPERATION_ERROR = -1004,
120 /* cam data error */
121 ZW_API_CAM_GETVDATA_ERROR = -1011,
122 ZW_API_CAM_SETVDATA_ERROR = -1012,
123 ZW_API_CAM_UPVADTA_ERROR = -1013,
125 /* cam tactic error */
126 ZW_API_CAM_GETTACNAME_ERROR = -1021,
127 ZW_API_CAM_GETTACTIC_ERROR = -1022,
129 /* cam feature error */
130 ZW_API_CAM_GETFTRGRP_ERROR = -1031,
131 ZW_API_CAM_GETFTRDBNAME_ERROR = -1032,
132 ZW_API_CAM_GETFTR_ERROR = -1033,
134 /* cam setup error */
135 ZW_API_CAM_GETSETUP_ERROR = -1041,
137 /* cam machine error */
138 ZW_API_CAM_GETMACH_ERROR = -1051,
139 ZW_API_CAM_GETMACHNAME_ERROR = -1052,
141 /* cam folder error */
142 ZW_API_CAM_GETFOLDER_ERROR = -1061,
143 ZW_API_CAM_GETFOLDERNAME_ERROR = -1062,
144 ZW_API_CAM_GETFOLDERSUB_ERROR = -1063,
146 /* cam tool error */
147 ZW_API_CAM_GETTOOL_ERROR = -1072,
148 ZW_API_CAM_GETTOOLNAME_ERROR = -1073,
149 ZW_API_CAM_GETHOLDER_ERROR = -1073,
150 ZW_API_CAM_GETTOOLTYPE_ERROR = -1074,
151 ZW_API_CAM_GETTOOLSUBTYPE_ERROR = -1075,
152 ZW_API_CAM_GETTOOLID_ERROR = -1076,
153 ZW_API_CAM_GETTOOLLEN_ERROR = -1077,
154 ZW_API_CAM_GETTOOLDIA_ERROR = -1078,
156 /* cam component error */
157 ZW_API_CAM_GETCMCOMP_ERROR = -1081,
158 ZW_API_CAM_GETCOMPCLASS_ERROR = -1082,
159 ZW_API_CAM_GETCOMPINDEX_ERROR = -1083,
160 ZW_API_CAM_GETCOMPVDATA_ERROR = -1084,
162 /* cam frame error */
163 ZW_API_CAM_GETFRAME_ERROR = -1091,
164 ZW_API_CAM_GETACTFRAME_ERROR = -1092,
166 /* cam output error */
167 ZW_API_CAM_GETOUT_ERROR = -1101,
168 ZW_API_CAM_OUTCL_ERROR = -1102,
169 ZW_API_CAM_OUTNC_ERROR = -1103,
170 ZW_API_CAM_OUTOPLIST_ERROR = -1104,
171 ZW_API_CAM_OUTOPHTML_ERROR = -1105,
172 ZW_API_CAM_OUTOPXML_ERROR = -1106,
173 ZW_API_CAM_OUTTOOL_ERROR = -1107,
175 /* cam gui error */
176 ZW_API_CAM_GUITOTXT_ERROR = -1111,
177 ZW_API_CAM_GUIFROMTXT_ERROR = -1112,
179 /* cam form error */
180 ZW_API_CAM_GETFORMSTATE_ERROR = -1121,
181 ZW_API_CAM_FORMDEFINE_ERROR = -1122,
182 ZW_API_CAM_GETFORMITEM_ERROR = -1123,
183 ZW_API_CAM_SETFORMITEM_ERROR = -1124,
185 /* cam tool path error */
186 ZW_API_CAM_GETTPATH_ERROR = -1131,
187 ZW_API_CAM_GETTPATHINFO_ERROR = -1132,
189 /* cam spdfd error */
190 ZW_API_CAM_GETSPDFD_ERROR = -1141
192 } evxErrors;
193
194
195//====================================================================================================================
197//====================================================================================================================
202typedef char vxName[32];
203
204
209typedef char vxLongName[256];
210
211
216typedef char vxPath[256];
217
222typedef char vxRootName[256];
223
228typedef char vxExp[256];
229
234typedef char vxVarExp[1024];
235
240typedef char vxLongPath[512];
241
242
243//====================================================================================================================
245//====================================================================================================================
250typedef unsigned int vxUint32;
251
252
253//====================================================================================================================
255//====================================================================================================================
260#define V_PP_LEN 400
261
262
267typedef struct svxEntPath
268 {
269 int Count;
270 int Id[V_PP_LEN];
276 } svxEntPath;
277
278//====================================================================================================================
280//====================================================================================================================
285typedef struct svxPoint2
286 {
287 double x;
288 double y;
289 } svxPoint2;
290
295typedef struct svxPoint2f
296 {
297 float x;
298 float y;
299 } svxPoint2f;
300
305typedef struct svxPoint
306 {
307 double x;
308 double y;
309 double z;
310 } svxPoint;
311
316typedef struct svxPointf
317 {
318 float x;
319 float y;
320 float z;
321 } svxPointf;
322
327typedef struct svxVector2
328 {
329 double x;
330 double y;
331 } svxVector2;
332
337typedef struct svxVector
338 {
339 double x;
340 double y;
341 double z;
342 } svxVector;
343
348typedef struct svxAxis
349 {
350 svxPoint Pnt;
351 svxVector Dir;
352 } svxAxis;
353
358typedef enum evxAxisType
359 {
360 VX_AXIS_X = 1,
361 VX_AXIS_Y = 2,
362 VX_AXIS_Z = 3,
363 } evxAxisType;
364
369typedef struct svxTriangle
370 {
371 svxPoint Pnt[3];
372 svxVector Normal;
373 } svxTriangle;
374
375//====================================================================================================================
377//====================================================================================================================
382typedef enum evxUnitType
383 {
384 VX_UNIT_MICRON = 0,
385 VX_UNIT_MILLIMETER = 1,
386 VX_UNIT_CENTIMETER = 2,
387 VX_UNIT_METER = 3,
388 VX_UNIT_INCH = 4,
389 VX_UNIT_FOOT = 5,
390 VX_UNIT_YD = 6,
391 VX_UNIT_DM = 7,
392 VX_UNIT_MIL = 10
393 } evxUnitType;
394
399typedef enum evxMassUnitType
400 {
401 VX_UNIT_GM = 11,
402 VX_UNIT_KG = 12,
403 VX_UNIT_OZ = 13,
404 VX_UNIT_LB = 14
405 } evxMassUnitType;
406
411typedef enum evxDensityUnitType
412 {
413 VX_UNIT_DEN_KG_M3 = 0,
414 VX_UNIT_DEN_KG_MM3 = 1,
415 VX_UNIT_DEN_G_MM3 = 2,
416 VX_UNIT_DEN_G_CM3 = 3,
417 VX_UNIT_DEN_LB_IN3 = 4,
418 VX_UNIT_DEN_LB_FT3 = 5,
419 VX_UNIT_DEN_LB_YD3 = 6,
420 VX_UNIT_DEN_OZ_IN3 = 7,
421 VX_UNIT_DEN_OZ_FT3 = 8,
422 VX_UNIT_DEN_OZ_YD3 = 9,
423 VX_UNIT_DEN_KG_DM3 = 10,
424 VX_UNIT_DEN_G_DM3 = 11,
425 } evxDensityUnitType;
426
431typedef enum evxMassMomentUnitType
432 {
433 VX_UNIT_MASSMOMENT_KGMM2 = 0,
434 VX_UNIT_MASSMOMENT_KGM2 = 1,
435 VX_UNIT_MASSMOMENT_GMM2 = 2,
436 VX_UNIT_MASSMOMENT_GCM2 = 3,
437 VX_UNIT_MASSMOMENT_LBIN2 = 4,
438 VX_UNIT_MASSMOMENT_LBFT2 = 5,
439 VX_UNIT_MASSMOMENT_LBYD2 = 6,
440 VX_UNIT_MASSMOMENT_OZIN2 = 7,
441 VX_UNIT_MASSMOMENT_OZFT2 = 8,
442 VX_UNIT_MASSMOMENT_OZYD2 = 9,
443 VX_UNIT_MASSMOMENT_KGDM2 = 10,
444 VX_UNIT_MASSMOMENT_GDM2 = 11,
445 } evxMassMomentUnitType;
446
447//====================================================================================================================
449//====================================================================================================================
454typedef struct svxLimit
455 {
456 double min;
457 double max;
458 } svxLimit;
459
464typedef struct svxBndBox
465 {
466 svxLimit X;
467 svxLimit Y;
468 svxLimit Z;
469 } svxBndBox;
470
471//====================================================================================================================
473//====================================================================================================================
478typedef struct svxMatrix
479 {
480 char identity;
481 double xx, yx, zx, xt;
482 double xy, yy, zy, yt;
483 double xz, yz, zz, zt;
484 } svxMatrix;
485
490typedef struct svxMatEuler
491 {
492 double ang1st;
493 double ang2nd;
494 double ang3rd;
495 double x;
496 double y;
497 double z;
498 } svxMatEuler;
499
504typedef enum evxEulerAngSeq
505 {
506 /*
507 ** Proper Euler Angle - when the first and third rotation are around the same axes.
508 */
509 VX_XYX = 121,
510 VX_XZX = 131,
511 VX_YXY = 212,
512 VX_YZY = 232,
513 VX_ZXZ = 313,
514 VX_ZYZ = 323,
515 /*
516 ** Tait-Bryan or Roll-Pitch-Yaw Angles - when three rotations are around different axes.
517 */
518 VX_RPY = 123,
519 VX_RYP = 132,
520 VX_PRY = 213,
521 VX_PYR = 231,
522 VX_YRP = 312,
523 VX_YPR = 321
524 } evxEulerAngSeq;
525
526//====================================================================================================================
528//====================================================================================================================
533typedef enum evxGeomCritPnt
534 {
535 VX_NO_POINT,
536 VX_FREE_POINT = 0,
537 VX_START_POINT,
538 VX_END_POINT,
539 VX_CENTER_POINT,
540 VX_SPLINE_DEFINING_POINT,
541 VX_MIDDLE_POINT,
542 VX_ORIGIN_POINT
543 } evxGeomCritPnt;
544
549typedef struct svxPntOnEnt
550 {
551 int idEnt;
552 int idParent;
553 int useCritPnt;
554 evxGeomCritPnt critTyp;
555 int idControlPnt;
556 svxPoint pnt;
557 svxVector dir;
558 int useDir;
559 int flipDir;
560 }svxPntOnEnt;
561
566typedef struct svxPntOnEntPath
567 {
568 evxGeomCritPnt pntType;
569 int idControlPnt;
570 svxEntPath entPath;
571 svxPoint pnt;
572 }svxPntOnEntPath;
573
578typedef enum evxDirType
579 {
580 VX_START_DIR,
581 VX_END_DIR,
582 VX_PNT_DIR,
583 } evxDirType;
584
589typedef struct svxDirOnEntPath
590 {
591 svxEntPath entPath;
592 evxDirType dirType;
593 svxPoint pnt;
594 svxVector dir;
595 int flipDir;
596 }svxDirOnEntPath;
597
602typedef enum evxPntLocation
603 {
604 VX_PNT_OUT = -1,
605 VX_PNT_ON = 0,
606 VX_PNT_IN = 1,
607 VX_PNT_NULL = -2
608 } evxPntLocation;
609
610//====================================================================================================================
612//====================================================================================================================
617typedef struct svxColor
618 {
619 unsigned char r;
620 unsigned char g;
621 unsigned char b;
622 } svxColor;
623
628typedef struct svxColorf
629 {
630 float r;
631 float g;
632 float b;
633 } svxColorf;
634
635
640typedef enum evxColor
641 {
642 VX_COLOR_RGB = -1,
643 VX_COLOR_NULL = 0,
644 VX_COLOR_GREEN = 1,
645 VX_COLOR_RED = 2,
646 VX_COLOR_BROWN = 3,
647 VX_COLOR_GOLDENROD = 4,
648 VX_COLOR_MED_BLUE = 5,
649 VX_COLOR_DARK_MAGENTA = 6,
650 VX_COLOR_DARK_GREY = 7,
651 VX_COLOR_DARK_BLUE = 8,
652 VX_COLOR_VIOLET = 9,
653 VX_COLOR_LIGHT_GREEN = 10,
654 VX_COLOR_LIGHT_BLUE = 11,
655 VX_COLOR_ROSE = 12,
656 VX_COLOR_LIGHT_MAGENTA = 13,
657 VX_COLOR_LIGHT_GREY = 14,
658 VX_COLOR_WHITE = 15,
659 VX_COLOR_BLACK = 16,
660 VX_COLOR_YELLOW = 17,
661 VX_COLOR_MED_GREY = 18,
662 VX_COLOR_PURPLE = 19,
663 VX_COLOR_STANDARD_LAST = VX_COLOR_PURPLE,
664
665 VX_COLOR_INDEX_BEGIN,
666 VX_COLOR_INDEX20 = VX_COLOR_INDEX_BEGIN,
667 VX_COLOR_INDEX21,
668 VX_COLOR_INDEX22,
669 VX_COLOR_INDEX23,
670 VX_COLOR_INDEX24,
671 VX_COLOR_INDEX25,
672 VX_COLOR_INDEX26,
673 VX_COLOR_INDEX27,
674 VX_COLOR_INDEX28,
675 VX_COLOR_INDEX29,
676 VX_COLOR_INDEX30,
677 VX_COLOR_INDEX31,
678 VX_COLOR_INDEX32,
679 VX_COLOR_INDEX33,
680 VX_COLOR_INDEX34,
681 VX_COLOR_INDEX35,
682 VX_COLOR_INDEX36,
683 VX_COLOR_INDEX37,
684 VX_COLOR_INDEX38,
685 VX_COLOR_INDEX39,
686 VX_COLOR_INDEX40,
687 VX_COLOR_INDEX41,
688 VX_COLOR_INDEX42,
689 VX_COLOR_INDEX43,
690 VX_COLOR_INDEX44,
691 VX_COLOR_INDEX45,
692 VX_COLOR_INDEX46,
693 VX_COLOR_INDEX47,
694 VX_COLOR_INDEX48,
695 VX_COLOR_INDEX49,
696 VX_COLOR_INDEX50,
697 VX_COLOR_INDEX51,
698 VX_COLOR_INDEX52,
699 VX_COLOR_INDEX53,
700 VX_COLOR_INDEX54,
701 VX_COLOR_INDEX55,
702 VX_COLOR_INDEX56,
703 VX_COLOR_INDEX57,
704 VX_COLOR_INDEX58,
705 VX_COLOR_INDEX59,
706 VX_COLOR_INDEX60,
707 VX_COLOR_INDEX61,
708 VX_COLOR_INDEX62,
709 VX_COLOR_INDEX63,
710 VX_COLOR_INDEX64,
711 VX_COLOR_INDEX65,
712 VX_COLOR_INDEX66,
713 VX_COLOR_INDEX67,
714 VX_COLOR_INDEX68,
715 VX_COLOR_INDEX69,
716 VX_COLOR_INDEX70,
717 VX_COLOR_INDEX71,
718 VX_COLOR_INDEX72,
719 VX_COLOR_INDEX73,
720 VX_COLOR_INDEX74,
721 VX_COLOR_INDEX75,
722 VX_COLOR_INDEX76,
723 VX_COLOR_INDEX77,
724 VX_COLOR_INDEX78,
725 VX_COLOR_INDEX79,
726 VX_COLOR_INDEX80,
727 VX_COLOR_INDEX81,
728 VX_COLOR_INDEX82,
729 VX_COLOR_INDEX83,
730 VX_COLOR_INDEX84,
731 VX_COLOR_INDEX85,
732 VX_COLOR_INDEX86,
733 VX_COLOR_INDEX87,
734 VX_COLOR_INDEX88,
735 VX_COLOR_INDEX89,
736 VX_COLOR_INDEX90,
737 VX_COLOR_INDEX91,
738 VX_COLOR_INDEX92,
739 VX_COLOR_INDEX93,
740 VX_COLOR_INDEX94,
741 VX_COLOR_INDEX95,
742 VX_COLOR_INDEX96,
743 VX_COLOR_INDEX97,
744 VX_COLOR_INDEX98,
745 VX_COLOR_INDEX99,
746 VX_COLOR_INDEX100,
747 VX_COLOR_INDEX101,
748 VX_COLOR_INDEX102,
749 VX_COLOR_INDEX103,
750 VX_COLOR_INDEX104,
751 VX_COLOR_INDEX105,
752 VX_COLOR_INDEX106,
753 VX_COLOR_INDEX107,
754 VX_COLOR_INDEX108,
755 VX_COLOR_INDEX109,
756 VX_COLOR_INDEX110,
757 VX_COLOR_INDEX111,
758 VX_COLOR_INDEX112,
759 VX_COLOR_INDEX113,
760 VX_COLOR_INDEX114,
761 VX_COLOR_INDEX115,
762 VX_COLOR_INDEX116,
763 VX_COLOR_INDEX117,
764 VX_COLOR_INDEX118,
765 VX_COLOR_INDEX119,
766 VX_COLOR_INDEX120,
767 VX_COLOR_INDEX121,
768 VX_COLOR_INDEX122,
769 VX_COLOR_INDEX123,
770 VX_COLOR_INDEX124,
771 VX_COLOR_INDEX125,
772 VX_COLOR_INDEX126,
773 VX_COLOR_INDEX127,
774 VX_COLOR_INDEX128,
775 VX_COLOR_INDEX129,
776 VX_COLOR_INDEX130,
777 VX_COLOR_INDEX131,
778 VX_COLOR_INDEX132,
779 VX_COLOR_INDEX133,
780 VX_COLOR_INDEX134,
781 VX_COLOR_INDEX135,
782 VX_COLOR_INDEX136,
783 VX_COLOR_INDEX137,
784 VX_COLOR_INDEX138,
785 VX_COLOR_INDEX139,
786 VX_COLOR_INDEX140,
787 VX_COLOR_INDEX141,
788 VX_COLOR_INDEX142,
789 VX_COLOR_INDEX143,
790 VX_COLOR_INDEX144,
791 VX_COLOR_INDEX145,
792 VX_COLOR_INDEX146,
793 VX_COLOR_INDEX147,
794 VX_COLOR_INDEX148,
795 VX_COLOR_INDEX149,
796 VX_COLOR_INDEX150,
797 VX_COLOR_INDEX151,
798 VX_COLOR_INDEX152,
799 VX_COLOR_INDEX153,
800 VX_COLOR_INDEX154,
801 VX_COLOR_INDEX155,
802 VX_COLOR_INDEX156,
803 VX_COLOR_INDEX157,
804 VX_COLOR_INDEX158,
805 VX_COLOR_INDEX159,
806 VX_COLOR_INDEX160,
807 VX_COLOR_INDEX161,
808 VX_COLOR_INDEX162,
809 VX_COLOR_INDEX163,
810 VX_COLOR_INDEX164,
811 VX_COLOR_INDEX165,
812 VX_COLOR_INDEX166,
813 VX_COLOR_INDEX167,
814 VX_COLOR_INDEX168,
815 VX_COLOR_INDEX169,
816 VX_COLOR_INDEX170,
817 VX_COLOR_INDEX171,
818 VX_COLOR_INDEX172,
819 VX_COLOR_INDEX173,
820 VX_COLOR_INDEX174,
821 VX_COLOR_INDEX175,
822 VX_COLOR_INDEX176,
823 VX_COLOR_INDEX177,
824 VX_COLOR_INDEX178,
825 VX_COLOR_INDEX179,
826 VX_COLOR_INDEX180,
827 VX_COLOR_INDEX181,
828 VX_COLOR_INDEX182,
829 VX_COLOR_INDEX183,
830 VX_COLOR_INDEX184,
831 VX_COLOR_INDEX185,
832 VX_COLOR_INDEX186,
833 VX_COLOR_INDEX187,
834 VX_COLOR_INDEX188,
835 VX_COLOR_INDEX189,
836 VX_COLOR_INDEX190,
837 VX_COLOR_INDEX191,
838 VX_COLOR_INDEX192,
839 VX_COLOR_INDEX193,
840 VX_COLOR_INDEX194,
841 VX_COLOR_INDEX195,
842 VX_COLOR_INDEX196,
843 VX_COLOR_INDEX197,
844 VX_COLOR_INDEX198,
845 VX_COLOR_INDEX199,
846 VX_COLOR_INDEX200,
847 VX_COLOR_INDEX201,
848 VX_COLOR_INDEX202,
849 VX_COLOR_INDEX203,
850 VX_COLOR_INDEX204,
851 VX_COLOR_INDEX205,
852 VX_COLOR_INDEX206,
853 VX_COLOR_INDEX207,
854 VX_COLOR_INDEX208,
855 VX_COLOR_INDEX209,
856 VX_COLOR_INDEX210,
857 VX_COLOR_INDEX211,
858 VX_COLOR_INDEX212,
859 VX_COLOR_INDEX213,
860 VX_COLOR_INDEX214,
861 VX_COLOR_INDEX215,
862 VX_COLOR_INDEX216,
863 VX_COLOR_INDEX217,
864 VX_COLOR_INDEX218,
865 VX_COLOR_INDEX219,
866 VX_COLOR_INDEX220,
867 VX_COLOR_INDEX221,
868 VX_COLOR_INDEX222,
869 VX_COLOR_INDEX223,
870 VX_COLOR_INDEX224,
871 VX_COLOR_INDEX225,
872 VX_COLOR_INDEX226,
873 VX_COLOR_INDEX227,
874 VX_COLOR_INDEX228,
875 VX_COLOR_INDEX229,
876 VX_COLOR_INDEX230,
877 VX_COLOR_INDEX231,
878 VX_COLOR_INDEX232,
879 VX_COLOR_INDEX233,
880 VX_COLOR_INDEX234,
881 VX_COLOR_INDEX235,
882 VX_COLOR_INDEX236,
883 VX_COLOR_INDEX237,
884 VX_COLOR_INDEX238,
885 VX_COLOR_INDEX239,
886 VX_COLOR_INDEX240,
887 VX_COLOR_INDEX241,
888 VX_COLOR_INDEX242,
889 VX_COLOR_INDEX243,
890 VX_COLOR_INDEX244,
891 VX_COLOR_INDEX_LAST = VX_COLOR_INDEX244,
892 VX_COLOR_LAST
893 } evxColor;
894
895/*
896color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253;
897254 is necessary for the detail view
898*/
904typedef enum evxColorAppFlag
905 {
906 VX_COLOR_BYLAYER = 253,
907 } evxColorAppFlag;
908
909//====================================================================================================================
911//====================================================================================================================
916typedef enum evxEntType
917 {
918 VX_ENT_BREP = -4,
919 VX_ENT_OP = -3,
920 VX_ENT_POINT = -2,
921 VX_ENT_WIRE = -1,
922 VX_ENT_ALL = 0,
923 VX_ENT_SHAPE = 42,
924 VX_ENT_FACE = 43,
925 VX_ENT_EDGE = 46,
926 VX_ENT_FTR = 48,
927 VX_ENT_NRB_CRV = 54,
928 VX_ENT_LINE3 = 56,
929 VX_ENT_LINE2 = 58,
930 VX_ENT_CIRCLE3 = 60,
931 VX_ENT_CIRCLE2 = 61,
932 VX_ENT_ARC3 = 62,
933 VX_ENT_ARC2 = 63,
934 VX_ENT_POINT3 = 64,
935 VX_ENT_POINT2 = 65,
936 VX_ENT_LAYER = 67,
937 VX_ENT_SKETCH = 70,
938 VX_ENT_REF_GEOM = 72,
939 VX_ENT_TEXT = 76,
940 VX_ENT_DIMEN = 77,
941 VX_ENT_ANNO = 83,
942 VX_ENT_BLOCK = 86,
943 VX_ENT_DWG_VIEW = 87,
944 VX_ENT_COMP = 88,
945 VX_ENT_PART = 89,
946 VX_ENT_SHEET = 90,
947 VX_ENT_PACKET = 91,
948 VX_ENT_DATUM = 95,
949 VX_ENT_CRV_LIST = 102,
950 VX_ENT_PART_LINE = 106,
951 VX_ENT_HATCH = 111,
952 VX_ENT_LIGHT = 118,
953 VX_ENT_INT_CRV = 119,
954 VX_ENT_VAR = 120,
955 VX_ENT_EQN_SET = 121,
956 VX_ENT_SYMBOL = 123,
957 VX_ENT_TRACE = 133,
958 VX_ENT_TABLE = 144,
959 VX_ENT_VBREAKLINE = 182,
960 VX_ENT_RDTXT = 185,
961 VX_ENT_BALLOON = 168,
962 VX_ENT_DRAWING = 169,
963 VX_ENT_PMIENT = 190,
964 VX_ENT_BLOCK2D = 197,
965 VX_ENT_BLKREF = 198,
966 VX_ENT_AXIS = 311,
967 VX_ENT_CSYS = 312,
968 VX_ENT_AXIS_2D = 313,
969 } evxEntType;
970
975typedef struct svxEntPick
976 {
977 int idEntity;
978 int idParent;
980 } svxEntPick;
981
986typedef struct svxUid
987 {
988 int Time;
989 int Rand;
990 int Count;
991 } svxUid;
992
997typedef enum evxEdgeType
998 {
999 VX_EDGE_UNKNOWN = -1,
1000 VX_EDGE_STANDARD = 0,
1001 VX_EDGE_SEAM = 1,
1002 VX_EDGE_DEGEN = 2
1003 } evxEdgeType;
1004
1009typedef enum evxEntFind
1010 {
1011 VX_FIND_POINT = 1,
1012 VX_FIND_CURVE = 2,
1013 VX_FIND_EDGE = 3,
1014 VX_FIND_WIRE = 4,
1015 VX_FIND_FACE = 5,
1016 VX_FIND_SKETCH = 6,
1017 VX_FIND_CRV_LIST = 7,
1018 VX_FIND_SKETCH_OR_CRV_LIST = 8,
1019 VX_FIND_PROFILE = 9,
1020 VX_FIND_EDGE_OR_CRV = 10,
1021 VX_FIND_3D_BLOCK = 14,
1022 VX_FIND_DIM = 15
1023 } evxEntFind;
1024
1029typedef struct svxEntFind
1030 {
1031 /* input - basic parameters */
1032 evxEntFind Option;
1033 svxPoint RefPnt;
1035 /* input - filter parameters */
1036 evxColor Color;
1037 svxColor Rgb;
1038 int CheckLayer;
1039 int Layer;
1040 int idFeature;
1041 int isPlane;
1042 int isHole;
1043 int isLine;
1044 evxEdgeType edgeType;
1046 /* output */
1047 int idEntity;
1048 svxPoint Pnt;
1049 double Dist;
1050 } svxEntFind;
1051
1056typedef enum evxFindRule
1057 {
1058 /* stop condition, only for VX_FIND_CUSTOM (evxFaceFindType) type */
1059 VX_STOP_FACE_FILLET = 0x00000001,
1060 VX_STOP_EDGE_INNER_LOOP = 0x00000002,
1061 VX_STOP_CONVEX_FLLT = 0x00000004,
1062 VX_STOP_CONCAVE_FLLT = 0x00000008,
1063 VX_STOP_CONVEX_EDGE = 0x00000010,
1064 VX_STOP_CONCAVE_EDGE = 0x00000020,
1065 VX_STOP_ADJACENCY_LEVEL = 0x00000040,
1070 VX_STOP_BOUNDARY_FACE = 0x00000080,
1073 /* find rules, only for VX_FIND_FINDER (evxFaceFindType) type */
1074 VX_FIND_COAXIAL = 0x00000001,
1075 VX_FIND_TANGENT = 0x00000002,
1076 VX_FIND_COPLANAR = 0x00000004,
1077 VX_FIND_COPL_AXES = 0x00000008,
1079 VX_FIND_EQU_RAD = 0x00000010,
1081 VX_FIND_SYMMETRIC = 0x00000020,
1082 VX_FIND_OFFSET = 0x00000040,
1084 } evxFindRule;
1085
1086//====================================================================================================================
1088//====================================================================================================================
1093typedef enum evxVarType
1094 {
1095 VX_VAR_NUM = 0,
1096 VX_VAR_STR = 1,
1097 VX_VAR_PNT = 2,
1098 VX_VAR_VEC = 3
1099 } evxVarType;
1100
1105typedef enum evxVarNumType
1106 {
1107 VX_VAR_CONS = 0,
1108 VX_VAR_DST = 1,
1109 VX_VAR_ANG = 2,
1110 VX_VAR_MASS = 3,
1111 VX_VAR_DENSITY = 4,
1112 VX_VAR_AREA = 5,
1113 VX_VAR_VOLUME = 6,
1114 VX_VAR_MASS_MOMENT = 7
1115 } evxVarNumType;
1116
1121typedef struct svxVariable
1122 {
1123 vxName Name;
1124 double Value;
1125 svxPoint pnt_val;
1126 vxVarExp Expression;
1127 char type;
1128 char sub_type;
1129 char unit_type;
1130 } svxVariable;
1131
1132//====================================================================================================================
1134//====================================================================================================================
1139typedef struct svxFaceAt
1140 {
1141 unsigned char reflectance;
1142 unsigned char refraction;
1143 unsigned char exp;
1144 unsigned char trans;
1145 unsigned char ambient;
1146 unsigned char diffuse;
1147 unsigned char specular;
1148 unsigned char emission;
1149 svxColor front_color;
1150 svxColor back_color;
1151 svxColor spec_color;
1152 } svxFaceAt;
1153
1154//====================================================================================================================
1156//====================================================================================================================
1161typedef enum evxViewLineAttrIdx
1162 {
1163 VX_VIS_LINE_ATTR = 0,
1164 VX_HID_LINE_ATTR = 1,
1165 VX_TAN_LINE_ATTR = 2,
1166 VX_SECT_LINE_ATTR = 3,
1167 VX_DET_LINE_ATTR = 4,
1168 VX_CENT_LINE_ATTR = 5,
1169 VX_THRD_LINE_ATTR = 6,
1170 VX_VIEW_LINE_ATTR = 7,
1171 VX_WIRE_LINE_ATTR = 8,
1172 VX_TAN_HID_LINE_ATTR = 9,
1173 VX_WIRE_HID_LINE_ATTR = 10,
1174 VX_CENT_HID_LINE_ATTR = 11,
1175 VX_THRD_HID_LINE_ATTR = 12,
1176 VX_BEND_LINE_ATTR = 13,
1177 VX_BEND_HID_LINE_ATTR = 14,
1178 VX_THRD_END_LINE_ATTR = 15,
1179 VX_THRD_END_HID_LINE_ATTR = 16,
1180 VX_CROP_LINE_ATTR = 17,
1181 } evxViewLineAttrIdx;
1182
1187typedef struct svxWireAt
1188 {
1189 unsigned char color;
1190 unsigned char type;
1191 unsigned char size;
1192 char mode;
1201 } svxWireAt;
1202
1203//====================================================================================================================
1205//====================================================================================================================
1210typedef struct svxPrfAreaProp
1211 {
1212 svxPoint2 org;
1213 svxPoint2 centroid;
1215 double area;
1217 double Ix;
1218 double Iy;
1219 double Ir;
1220 double Ixy;
1222 double Kx;
1223 double Ky;
1224 double Kr;
1226 double Pmin;
1227 double Pmax;
1228 double Imin;
1229 double Imax;
1230 } svxPrfAreaProp;
1231
1232//====================================================================================================================
1234//====================================================================================================================
1239typedef enum evxTextureOpt
1240 {
1241 V_TEXTURE_NULL = 0,
1242 V_TEXTURE_BLEND = 1,
1243 V_TEXTURE_DECAL = 2,
1244 V_TEXTURE_MODULATE = 3,
1245 V_TEXTURE_REPLACE = 4
1246 } evxTextureOpt;
1247
1252typedef enum evxTextureLoc
1253 {
1254 V_TEXTURE_LOWER_LEFT = 0,
1255 V_TEXTURE_UPPER_LEFT = 1,
1256 V_TEXTURE_UPPER_RIGHT = 2,
1257 V_TEXTURE_LOWER_RIGHT = 3,
1258 V_TEXTURE_CENTER = 4
1259 } evxTextureLoc;
1260
1265typedef struct svxTextureAt
1266 {
1267 evxTextureOpt opt;
1268 vxPath file;
1269 unsigned char dimen;
1270 unsigned char repeat;
1271 float trans;
1272 double height;
1273 double width;
1274 double angle;
1275 svxPoint origin;
1276 int use_embed;
1281 evxTextureLoc location;
1282 } svxTextureAt;
1283
1284//====================================================================================================================
1286//====================================================================================================================
1291typedef enum evxAtItemId
1292 {
1293 /* The standard id of the part attribute item. */
1294 VX_AT_USER = 0,
1295 VX_AT_NAME = 1,
1296 VX_AT_NUMBER = 2,
1297 VX_AT_CLASS,
1298 VX_AT_DESIGNER,
1299 VX_AT_COST,
1300 VX_AT_SUPPLIER,
1301 VX_AT_DESCRIPT,
1302 VX_AT_KEYWORD,
1303 VX_AT_MANAGER,
1304 VX_AT_MATERIAL,
1305 VX_AT_START,
1306 VX_AT_END,
1307 VX_AT_DERIVED,
1308 VX_AT_NO_SECTION,
1309 VX_AT_NO_HATCH,
1310 VX_AT_NO_BOM,
1311 VX_AT_NO_ROOTSHOW,
1312 VX_AT_DENSITY = 18,
1313 VX_AT_FILEPATH = 20,
1314 VX_AT_SHEETPATH = 21,
1315 VX_AT_CAMPATH = 22,
1316 VX_AT_SHEETCODE = 23,
1318 VX_AT_AREA = 25,
1319 VX_AT_VOLUME = 26,
1320 VX_AT_MASS = 27,
1321 VX_AT_LENGTH = 28,
1322 VX_AT_WIDTH = 29,
1323 VX_AT_HEIGHT = 30,
1324 VX_AT_STOCK_SIZE = 43,
1325 VX_AT_REVISION = 47,
1327 /* The standard id of the sheet attribute item. */
1328 VX_AT_SHEET_SCALE = 200,
1329 VX_AT_SHEET_SEQUENCE = 201,
1330 VX_AT_SHEET_AMOUNT,
1331 VX_AT_SHEET_SIZE,
1332 VX_AT_SHEET_PROJECTION,
1333 VX_AT_SHEET_FILEPATH,
1334 } evxAtItemId;
1335
1340typedef enum evxAttributeType
1341 {
1342 VX_ATTR_STRING = 0,
1343 VX_ATTR_BOOL = 1,
1344 VX_ATTR_INT = 2,
1345 VX_ATTR_REAL = 3,
1346 VX_ATTR_DATE = 4,
1347 } evxAttributeType;
1348
1353typedef enum evxDateFormat
1354 {
1355 VX_DATE_FROMAT_SHORT = 0,
1356 VX_DATE_FROMAT_LONG = 1,
1357 VX_DATE_FROMAT1 = 2,
1358 VX_DATE_FROMAT2 = 3,
1359 VX_DATE_FROMAT3 = 4,
1360 VX_DATE_FROMAT4 = 5,
1361 VX_DATE_FROMAT5 = 6,
1362 VX_DATE_FROMAT6 = 7,
1363 } evxDateFormat;
1364
1369typedef struct svxAttribute
1370 {
1371 char label[64];
1372 char data[512];
1373 double dValue;
1374 char type;
1375 char sub_type;
1376 char unit;
1377 char strValue[2048];
1378 int has_eqn;
1379 } svxAttribute;
1380
1385typedef struct svxPartAttribute
1386 {
1387 int Version;
1388 int UserAttributeCount;
1389 svxAttribute UserAttribute[64];
1390 svxAttribute Name;
1391 svxAttribute Number;
1392 svxAttribute Partclass;
1393 svxAttribute Designer;
1394 svxAttribute Cost;
1395 svxAttribute Supplier;
1396 svxAttribute Description;
1397 svxAttribute Keyword;
1398 svxAttribute Manager;
1399 svxAttribute Material;
1400 svxAttribute Startdate;
1401 svxAttribute Enddate;
1402 svxAttribute Derived;
1403 svxAttribute No_section;
1404 svxAttribute No_hatch;
1405 svxAttribute Dimen[20];
1408 svxAttribute No_bom;
1409 svxAttribute File_path;
1410 svxAttribute No_rootshow;
1411 svxAttribute sheet_code;
1412 } svxPartAttribute;
1413
1414
1415//====================================================================================================================
1417//====================================================================================================================
1422typedef struct svxLineAt
1423 {
1424 evxColor color;
1425 unsigned char type;
1426 unsigned char size;
1427 }svxLineAt;
1428
1433typedef enum evxLineWidth
1434 {
1435 VX_WIDTH_UNDEFINED,
1436 VX_WIDTH_018,
1437 VX_WIDTH_025,
1438 VX_WIDTH_035,
1439 VX_WIDTH_050,
1440 VX_WIDTH_070,
1441 VX_WIDTH_100,
1443 VX_WIDTH_BYLAYER = 0xFF,
1444 } evxLineWidth;
1445
1446//====================================================================================================================
1448//====================================================================================================================
1453typedef struct svxTextAt
1454 {
1455 unsigned char bold;
1456 unsigned char underline;
1459 unsigned char italic;
1460 unsigned char word_wrap;
1461 char fontName[36];
1463 float char_height;
1464 float char_aspect;
1465 float multi_line_space;
1466 float char_spacing;
1468 evxColor color;
1469 unsigned char size;
1470 unsigned char precision;
1471 unsigned char font_type;
1473 unsigned char hor_align_type;
1474 unsigned char hor_align;
1475 unsigned char vert_align_type;
1476 unsigned char vert_align;
1478 float path;
1479 float text_angle;
1480 float char_slant;
1481 float text_expansion;
1483 float first_line_ind;
1484 float hanging_ind;
1485 float right_ind;
1486 }svxTextAt;
1487
1488//====================================================================================================================
1490//====================================================================================================================
1495typedef enum evxNumType
1496 {
1497 /* output type VeNumType*/
1498 VX_NUM_UNDEFINED = -1,
1499 VX_NUM_NULL = 0,
1500 VX_NUM_TO_FACE = 1,
1501 VX_NUM_FACE_BND = 2,
1502 VX_NUM_TO_PNT = 3,
1503 VX_NUM_THRU_PLUS = 4,
1504 VX_NUM_THRU_MINUS = 5,
1505 VX_NUM_CURVE_BND = 6,
1506 VX_NUM_DATA = 7,
1507 /* input type VeNumClass*/
1508 VX_UNDEF = 0,
1509 VX_NUM = 1,
1510 VX_DST = 2,
1511 VX_ANG = 3,
1512 VX_MASS = 4,
1513 VX_DENSITY = 5,
1514 VX_AREA = 6,
1515 VX_VOLUME = 7,
1516 VX_MASS_MOMENT = 8
1517 } evxNumType;
1518
1523typedef enum evxPntType
1524 {
1525 VX_PNT3_ABS = 0,
1526 VX_PNT3_ENT = 1,
1527 VX_PNT3_ON = 2,
1528 VX_PNT3_TO = 3,
1529 VX_PNT3_MID = 4,
1530 VX_PNT3_NUM = 5,
1531 VX_PNT3_DST = 6,
1532 VX_PNT3_ANG = 7,
1533 VX_PNT3_TAN = 8,
1534 VX_PNT3_FRAC = 9,
1535 VX_PNT3_REL = 10,
1536 VX_PNT3_DATA = 11,
1537 VX_PNT3_ABS_COMP = 12
1538 } evxPntType;
1539
1544typedef enum evxAngUnitType
1545 {
1546 VX_UNIT_DEG = 8,
1547 VX_UNIT_RAD = 9
1548 } evxAngUnitType;
1549
1554typedef struct svxData
1555 {
1556 /* flags indicating the types of data defined by this structure */
1557 char isPoint;
1558 char isEntity;
1559 char isNumber;
1560 char isDirection;
1561 char isText;
1562 char isPntOnCrv;
1569 char isEndPnt;
1573 char isPntOnFace;
1578 int idEntity;
1579 int idParent;
1580 evxNumType NumType;
1581 double Num;
1582 evxPntType PntType;
1583 svxPoint Pnt;
1584 svxVector Dir;
1585 double Param[3];
1586 char Text[512];
1587 int chkRepeatEnt;
1588 } svxData;
1589
1590//====================================================================================================================
1592//====================================================================================================================
1597typedef enum evxCurveType
1598 {
1599 VX_CRV_UNDEFINED = 0,
1600 VX_CRV_LINE = 1,
1601 VX_CRV_ARC = 2,
1602 VX_CRV_CIRCLE = 3,
1603 VX_CRV_NURB = 4
1604 } evxCurveType;
1605
1610typedef struct svxParameters
1611 {
1612 int closed;
1613 int degree;
1614 int num_knots;
1615 svxLimit bnd;
1616 double* knots;
1617 int free_mem;
1620 } svxParameters;
1621
1626typedef struct svxControlPoints
1627 {
1628 int rat;
1629 int dim;
1630 int plane;
1631 int num_cp;
1632 svxBndBox box;
1633 double* coord;
1635 int free_mem;
1638 } svxControlPoints;
1639
1644typedef struct svxCrvContinuityData
1645 {
1646 int idCrv1;
1647 int idCrv2;
1648 double position;
1649 int isPositionContinuous;
1650 double tangent;
1651 int isTangentContinuous;
1652 double curvature;
1653 int isCurvatureContinuous;
1654 double flow;
1655 int isFlowContinuous;
1656 } svxCrvContinuityData;
1657
1662typedef struct svxCrvContinuityTolList
1663 {
1664 double tolPosition;
1666 double tolTangent;
1668 double tolCurvature;
1670 double tolFlow;
1672 } svxCrvContinuityTolList;
1673
1678typedef struct svxCurve
1679 {
1680 evxCurveType Type;
1681 svxMatrix Frame;
1683 svxPoint P1, P2;
1684 double A1, A2;
1685 double R;
1687 svxParameters T;
1688 svxControlPoints P;
1689 } svxCurve;
1690
1691//====================================================================================================================
1693//====================================================================================================================
1698typedef enum evxSurfaceType
1699 {
1700 VX_SRF_PLANE,
1701 VX_SRF_SPHERE,
1702 VX_SRF_CONE,
1703 VX_SRF_GRID,
1704 VX_SRF_CYLINDER,
1705 VX_SRF_EXTRUDE,
1706 VX_SRF_REVOLVE,
1707 VX_SRF_SWEEP_NOT_USED,
1708 VX_SRF_GEN,
1709 VX_SRF_OFFSET,
1710 VX_SRF_MESH,
1711 VX_SRF_RULED,
1712 VX_SRF_HEMIS,
1713 VX_SRF_FRUSTRUM,
1714 VX_SRF_DRAFT,
1715 VX_SRF_DRAFT_NPLN,
1716 VX_SRF_DRAFT_NUV,
1717 VX_SRF_ELLIPSOID,
1718 VX_SRF_3PT_PLANE,
1719 VX_SRF_BILIN_CNVX,
1720 VX_SRF_EXTRUDE_DRFT,
1721 VX_SRF_REVOLVE_PLN,
1722 VX_SRF_TORUS,
1723 VX_SRF_SMD_THCK_FC,
1724 VX_SRF_BEND_GEN,
1725 VX_SRF_PLANE_STAT_FC,
1726 VX_SRF_GEN_STAT_FC,
1727 VX_SRF_CIR_OFF,
1728 VX_SRF_VAR_OFF,
1729 VX_SRF_THRD_THDFC,
1730 VX_SRF_THRD_NTHDFC,
1731 VX_SRF_THRD_CONFC
1732 } evxSurfaceType;
1733
1738typedef struct svxSurface
1739 {
1740 evxSurfaceType Type;
1741 int OutNormal;
1745 svxParameters U;
1746 svxParameters V;
1747 svxControlPoints P;
1748 } svxSurface;
1749
1754typedef enum evxSrfPrimType
1755 {
1756 VX_SF_PRIM_PLN,
1757 VX_SF_PRIM_SPH,
1758 VX_SF_PRIM_CON,
1759 VX_SF_PRIM_CYL,
1760 VX_SF_PRIM_NURB,
1761 VX_SF_PRIM_ELLSO,
1762 VX_SF_PRIM_TORUS
1763 } evxSrfPrimType;
1764
1769typedef struct svxPlane
1770 {
1771 double xlen;
1772 double ylen;
1773 svxMatrix form;
1774 } svxPlane;
1775
1780typedef struct svxSphere
1781 {
1782 double radius;
1783 svxMatrix form;
1784 int poleis01;
1786 } svxSphere;
1787
1792typedef struct svxCone
1793 {
1794 double radius1;
1795 double radius2;
1796 double length;
1797 svxMatrix form;
1801 int lindir;
1803 } svxCone;
1804
1809typedef struct svxCylinder
1810 {
1811 double radius;
1812 double length;
1813 svxMatrix form;
1818 int lindir;
1820 } svxCylinder;
1821
1826typedef struct svxTorus
1827 {
1828 double dPathRadius;
1829 double dProfRadius;
1830 svxMatrix form;
1833 int fSpineDir;
1835 int fApplemon;
1837 } svxTorus;
1838
1843typedef struct svxEllipsoid
1844 {
1845 double xlen;
1846 double ylen;
1847 double zlen;
1848 svxMatrix form;
1849 int poleis01;
1851 } svxEllipsoid;
1852
1857typedef struct svxSrfPrim
1858 {
1859 evxSrfPrimType srfType;
1860 union
1861 {
1862 svxPlane pln;
1863 svxSphere sph;
1864 svxCone con;
1865 svxCylinder cyl;
1866 svxSurface srf;
1867 svxEllipsoid ellso;
1868 svxTorus torus;
1869 } srfData;
1870 } svxSrfPrim;
1871
1872//====================================================================================================================
1874//====================================================================================================================
1879typedef struct svxShaderAt
1880 {
1881 vxName name;
1882 vxPath file;
1883 svxColor color[4];
1884 double param[10];
1885 } svxShaderAt;
1886
1891typedef struct svxFacets
1892 {
1893 int numTriStrip;
1894 int* TriStrip;
1908 int numVertex;
1909 svxPointf* Vertex;
1910 svxPointf* Normal;
1912 svxPoint2f* ST;
1914 svxFaceAt At;
1915 svxTextureAt Tx;
1916 svxShaderAt Sh;
1917 svxPoint2f* UV;
1919 svxColorf* RGB;
1925 } svxFacets;
1926//====================================================================================================================
1928//====================================================================================================================
1933typedef enum evxDimType
1934 {
1935 VX_DIM_LINEAR = 1,
1936 VX_DIM_BASELINE = 2,
1937 VX_DIM_CONTINUOUS = 3,
1938 VX_DIM_ORDINATE = 4,
1939 VX_DIM_LINEAR_OFFSET = 5,
1940 VX_DIM_LINEAR_CHAMFER = 6,
1941 VX_DIM_ANGULAR = 7,
1942 VX_DIM_RADIAL_DIAMETRIC = 8,
1943 VX_DIM_ARC_LENGTH = 9,
1944 VX_DIM_SYMMETRY,
1945 VX_DIM_HLCALL,
1946 VX_DIM_LABEL,
1947 VX_DIM_BALLOON,
1948 VX_DIM_DATUMF,
1949 VX_DIM_DATUMT,
1950 VX_DIM_FCS,
1951 VX_DIM_CLCM,
1952 VX_DIM_INTERSYM,
1953 VX_DIM_LAST
1954 } evxDimType;
1955
1960typedef enum evxDimTypeEx
1961 {
1962 VX_DIM_EX_FIRST = 0,
1963
1964 VX_DIM_EX_LH = 1,
1965 VX_DIM_EX_LV = 5,
1966 VX_DIM_EX_LA = 9,
1967 VX_DIM_EX_LR = 13,
1968 VX_DIM_EX_LP = 17,
1970 VX_DIM_EX_LHB = 2,
1971 VX_DIM_EX_LVB = 6,
1972 VX_DIM_EX_LAB = 10,
1973 VX_DIM_EX_LRB = 14,
1974 VX_DIM_EX_LPB = 18,
1976 VX_DIM_EX_LHC = 3,
1977 VX_DIM_EX_LVC = 7,
1978 VX_DIM_EX_LAC = 11,
1979 VX_DIM_EX_LRC = 15,
1980 VX_DIM_EX_LPC = 19,
1982 VX_DIM_EX_LHO = 4,
1983 VX_DIM_EX_LVO = 8,
1984 VX_DIM_EX_LAO = 12,
1985 VX_DIM_EX_LRO = 16,
1986 VX_DIM_EX_LPO = 20,
1987 VX_DIM_EX_LHVO = 88,
1989 VX_DIM_EX_LO = 21,
1990 VX_DIM_EX_LOS = 25,
1992 VX_DIM_EX_LSY = 90,
1993 VX_DIM_EX_ASY = 93,
1995 VX_DIM_EX_LCHV = 26,
1996 VX_DIM_EX_LCA = 29,
1997 VX_DIM_EX_LCL = 30,
1998 VX_DIM_EX_LCLP = 80,
1999 VX_DIM_EX_LCLA = 83,
2001 VX_DIM_EX_ANG = 48,
2002 VX_DIM_EX_ANGH = 52,
2003 VX_DIM_EX_ANGV = 56,
2004 VX_DIM_EX_ANGA = 60,
2005 VX_DIM_EX_ANG3PT = 74,
2007 VX_DIM_EX_RAD = 31,
2008 VX_DIM_EX_RADBG = 35,
2009 VX_DIM_EX_RADBK = 39,
2010 VX_DIM_EX_DIA = 44,
2011 VX_DIM_EX_RADL = 76,
2013 VX_DIM_EX_GDH = 70,
2014 VX_DIM_EX_GDV = 71,
2015 VX_DIM_EX_GDHS = 77,
2016 VX_DIM_EX_GDVS = 78,
2017 VX_DIM_EX_GDL = 81,
2018 VX_DIM_EX_GDLS = 82,
2020 VX_DIM_EX_GDTP = 72,
2021 VX_DIM_EX_GDTC = 73,
2022 VX_DIM_EX_GDTR = 84,
2023 VX_DIM_EX_GDTL = 85,
2025 VX_DIM_EX_LOB = 22,
2026 VX_DIM_EX_LOC = 23,
2027 VX_DIM_EX_LOO = 24,
2028 VX_DIM_EX_LCH = 27,
2029 VX_DIM_EX_LCV = 28,
2030 VX_DIM_EX_RADB = 32,
2031 VX_DIM_EX_RADC = 33,
2032 VX_DIM_EX_RADO = 34,
2033 VX_DIM_EX_RADBGB = 36,
2034 VX_DIM_EX_RADBGC = 37,
2035 VX_DIM_EX_RADBGO = 38,
2036 VX_DIM_EX_RADBKB = 40,
2037 VX_DIM_EX_RADBKC = 41,
2038 VX_DIM_EX_RADBKO = 42,
2039 VX_DIM_EX_RADS = 43,
2040 VX_DIM_EX_DIAB = 45,
2041 VX_DIM_EX_DIAC = 46,
2042 VX_DIM_EX_DIAO = 47,
2043 VX_DIM_EX_ANGB = 49,
2044 VX_DIM_EX_ANGC = 50,
2045 VX_DIM_EX_ANGO = 51,
2046 VX_DIM_EX_ANGHB = 53,
2047 VX_DIM_EX_ANGHC = 54,
2048 VX_DIM_EX_ANGHO = 55,
2049 VX_DIM_EX_ANGVB = 57,
2050 VX_DIM_EX_ANGVC = 58,
2051 VX_DIM_EX_ANGVO = 59,
2052 VX_DIM_EX_ANGAB = 61,
2053 VX_DIM_EX_ANGAC = 62,
2054 VX_DIM_EX_ANGAO = 63,
2055 VX_DIM_EX_LEAD = 64,
2056 VX_DIM_EX_BALL = 65,
2057 VX_DIM_EX_CM = 66,
2058 VX_DIM_EX_GF = 67,
2059 VX_DIM_EX_GFL = 68,
2060 VX_DIM_EX_GFP = 69,
2061 VX_DIM_EX_LCLS = 75,
2062 VX_DIM_EX_CLC = 79,
2063 VX_DIM_EX_CLBS = 86,
2064 VX_DIM_EX_ARCL = 87,
2065 VX_DIM_EX_INTSYM = 89,
2066 VX_DIM_EX_LORD = 91,
2067 VX_DIM_EX_DPLS = 92,
2068 VX_DIM_EX_CRVL = 94,
2069 VX_DIM_EX_RHO = 95,
2070 VX_DIM_EX_CRVL3D = 96,
2071 VX_DIM_EX_ELEV = 97,
2072 VX_DIM_EX_AUTO_LSY = 98,
2073 VX_DIM_EX_LAST = 99
2074 } evxDimTypeEx;
2075
2080typedef enum evxDimLineMode
2081 {
2082 VX_DIM_LINE_MODE_B = 2,
2083 VX_DIM_LINE_MODE_C = 3,
2084 VX_DIM_LINE_MODE_O = 4,
2085 } evxDimLineMode;
2086
2091typedef enum evxDimState
2092 {
2093 VX_DM_REVISION = -4,
2094 VX_DM_NOSCALE = -3,
2095 VX_DM_MODIFIED = -2,
2096 VX_DM_DANGLING = -1,
2097 VX_DM_NORMAL = 0,
2098 VX_DM_IN_OBJ = 1,
2099 } evxDimState;
2100
2105typedef enum evxFCSSymbol
2106 {
2107 VX_FCSSYM_NONE = 0,
2108 VX_FCSSYM_STRAIGHTNESS,
2109 VX_FCSSYM_FLATNESS,
2110 VX_FCSSYM_CIRCULARITY,
2111 VX_FCSSYM_CYLINDRICITY,
2112 VX_FCSSYM_PARALLELISM,
2113 VX_FCSSYM_PERPENDICULARITY,
2114 VX_FCSSYM_ANGULARITY,
2115 VX_FCSSYM_POSITION,
2116 VX_FCSSYM_CONCENTRICITY,
2117 VX_FCSSYM_SYMMETRY,
2118 VX_FCSSYM_PROFILE_OF_LINE,
2119 VX_FCSSYM_PROFILE_OF_SURFACE,
2120 VX_FCSSYM_CIRCULAR_RUNOUT,
2121 VX_FCSSYM_TOTAL_RUNOUT,
2122 } evxFCSSymbol;
2123
2128typedef enum evxFCSShapeSym
2129 {
2130 VX_SHP_NONE = 0,
2131 VX_SHP_DIAMETER,
2132 VX_SHP_SPHERICAL_DIA,
2133 VX_SHP_SQUARE,
2134 } evxFCSShapeSym;
2135
2140typedef enum evxFCSLmsOption
2141 {
2142 VX_LMS_NONE = 0,
2143 VX_LMS_MAX_MATERIAL,
2144 VX_LMS_MIN_MATERIAL,
2145 VX_LMS_FTR_SIZE_REGARDLESS,
2146 } evxFCSLmsOption;
2147
2152typedef struct svxFCSTol
2153 {
2154 int isValid;
2155 evxFCSShapeSym shapeSym;
2156 vxLongName tol;
2157 evxFCSLmsOption lmsOpt;
2158 int freeState;
2159 int tangentPlane;
2160 int projTolFlag;
2161 vxLongName projTol;
2162 int statisticalTol;
2163 } svxFCSTol;
2164
2169typedef struct svxFCSDatum
2170 {
2171 int isValid;
2172 vxLongName datum;
2173 evxFCSLmsOption lmsOpt;
2174 int freeState;
2175 } svxFCSDatum;
2176
2181typedef struct svxFCSData
2182 {
2183 evxFCSSymbol sym;
2184 svxFCSTol tol[2];
2185 svxFCSDatum datum[3][3];
2186 } svxFCSData;
2187
2192typedef enum evxTermType
2193 {
2194 VX_TERM_OFF = 0,
2195 VX_TERM_ARROW_15 = 1,
2196 VX_TERM_ARROW_30,
2197 VX_TERM_ARROW_60,
2198 VX_TERM_ARROW_H15,
2199 VX_TERM_ARROW_H30,
2200 VX_TERM_ARROW_H60,
2201 VX_TERM_ARROW_HF15,
2202 VX_TERM_ARROW_HF30,
2203 VX_TERM_ARROW_HF60,
2204 VX_TERM_TICK,
2205 VX_TERM_DOT,
2206 VX_TERM_DOTF
2207 } evxTermType;
2208
2213typedef enum evxHoleDimDataItem
2214 {
2215 VX_HOLE_DIM_ITEM_ORG,
2216 VX_HOLE_DIM_ITEM_QTY,
2217 VX_HOLE_DIM_ITEM_DIA,
2218 VX_HOLE_DIM_ITEM_DIA2,
2219 VX_HOLE_DIM_ITEM_LABEL,
2220 VX_HOLE_DIM_ITEM_DPTH,
2221 VX_HOLE_DIM_ITEM_DPTH2,
2222 VX_HOLE_DIM_ITEM_ANG,
2223 VX_HOLE_DIM_ITEM_THRD_DIA,
2224 VX_HOLE_DIM_ITEM_THRD_DPTH,
2225 VX_HOLE_DIM_ITEM_PITCH,
2226 VX_HOLE_DIM_THRD_STD,
2227 VX_HOLE_DIM_THRD_SIZ,
2228 } evxHoleDimDataItem;
2229
2234typedef struct svxDimAttr
2235 {
2236 char prefix[32];
2237 char suffix[32];
2238 char tolPlus[8];
2239 char tolMinus[8];
2240 char fontName[36];
2241 int extLnClr;
2242 int dimLnClr;
2243 int dimTxtClr;
2244 int symbolClr;
2245 int valFmt;
2247 int zeroSupp;
2248 int decPlc;
2249 double chHgt;
2250 double chAsp;
2251 double chLnSpc;
2252 double chSpc;
2253 double chSlant;
2254 double tolChHgtFac;
2255 int dimTxtOrient;
2256 int LeaderAlign;
2257 evxTermType trmTyp1;
2258 evxTermType trmTyp2;
2259 int dimLineSize;
2260 int extLineSize;
2261 int dimLineType;
2262 int extLineType;
2263 int dimTxtBold;
2264 int dimPrefixFlag;
2265 int altUnitFlag;
2266 int showUnit;
2267 int tolDecPlc;
2268 int altDecPlc;
2269 int altTolDecPlc;
2270 evxUnitType altUnitTyp;
2271 evxAngUnitType angAltUnitTyp;
2272 int suppLeader;
2273 int trmSuppFlg1;
2274 int trmSuppFlg2;
2275 double trmSize1;
2276 double trmSize2;
2277 } svxDimAttr;
2278
2279//====================================================================================================================
2281//====================================================================================================================
2286typedef struct svxCompName
2287 {
2288 vxLongPath File;
2289 vxRootName Part;
2290 } svxCompName;
2291
2292//====================================================================================================================
2294//====================================================================================================================
2299typedef enum evxExtendOpt
2300 {
2301 VX_EXTEND_UNDEFINED = 0,
2302 VX_EXTEND_LINEAR = 1,
2303 VX_EXTEND_CIRCULAR = 2,
2304 VX_EXTEND_REFLECT = 3
2305 } evxExtendOpt;
2306
2307//====================================================================================================================
2309//====================================================================================================================
2314typedef enum evxFairingType
2315 {
2316 VX_FAIRING_NONE = 0,
2317 VX_FAIRING_ENERGY = 1,
2318 VX_FAIRING_VARIATION = 2,
2319 VX_FAIRING_JERK = 3,
2320 VX_FAIRING_BEND = 4,
2321 VX_FAIRING_TENSION = 5,
2322 }evxFairingType;
2323
2328typedef struct svxCrvIntData
2329 {
2330 /* required inputs */
2331 int isClosed;
2332 int Degree;
2333 int Count;
2334 svxPoint* Points;
2337 /* optional inputs */
2338 int UseStartTan;
2339 svxVector StartTan;
2340 double StartScale;
2342 int UseEndTan;
2343 svxVector EndTan;
2344 double EndScale;
2346 int Fairing;
2347 } svxCrvIntData;
2348
2349
2354typedef enum evxContinuityTyp
2355 {
2356 VX_CONTIN_NONE = 0,
2357 VX_CONTIN_G1 = 1,
2358 VX_CONTIN_G2 = 2,
2359 VX_CONTIN_G3 = 3,
2360 } evxContinuityTyp;
2361
2366typedef struct svxSplinePnt
2367 {
2368 svxPoint Pnt;
2369 int UseCons;
2370 /* set following parameters when useCons = 1 */
2371 evxContinuityTyp ContinuityTyp;
2372 svxVector TangDir;
2373 int UseG1Manitude;
2374 double dG1Manitude;
2375 int UseG2Radius;
2376 double dG2Radius;
2377 int FlipDir;
2378 }svxSplinePnt;
2379
2384typedef enum evxPlacingType
2385 {
2386 VX_PLACING_NONE = -1,
2387 VX_PLACING_VIEW = 0,
2388 VX_PLACING_VECTOR = 1,
2389 VX_PLACING_WCS = 2,
2390 VX_PLACING_PLANE = 3,
2391 }evxPlacingType;
2392
2397typedef struct svxSplineData
2398 {
2399 /* ------------------common---------------- */
2400 int SplineTyp;
2401 int Count;
2402 svxSplinePnt* Pnts;
2403 int Degree;
2405 /* the following parameters used when SplineTyp = 0 */
2406 int CreateCrvOpen;
2407 int Fairing;
2408 /* the following parameters used when SplineTyp = 1 */
2409 int SingleSeg;
2411 /* -------------placing adjustment ------------------*/
2412 evxPlacingType PlacingTyp;
2413 svxVector PlacingDir;
2416 int UseOrient;
2418 svxEntPath PlacingPln;
2420 int PlacingPrj;
2423 /* --------------setting------------------*/
2424 /* the following parameters used when create 3d curve*/
2425 svxEntPath AlignPlane;
2426 int PrjToPln;
2427 int PntOnPln;
2428 int AlignTyp;
2429 }svxSplineData;
2430
2431//====================================================================================================================
2433//====================================================================================================================
2438typedef struct svxView
2439 {
2440 vxName Name;
2441 svxMatrix Matrix;
2442 float Extent;
2443 float FrontDist;
2444 float BackDist;
2445 float PRP_Dist;
2446 char Display;
2447 char Clip;
2448 char Project;
2449 } svxView;
2450
2455typedef enum evxViewStd
2456 {
2457 VX_VIEW_FRONT = 0,
2458 VX_VIEW_BACK = 1,
2459 VX_VIEW_TOP = 2,
2460 VX_VIEW_BOTTOM = 3,
2461 VX_VIEW_RIGHT = 4,
2462 VX_VIEW_LEFT = 5,
2463 VX_VIEW_ISO = 6,
2464 VX_VIEW_AUX = 7,
2465 VX_VIEW_PLANE = 8
2466 } evxViewStd;
2467
2468//====================================================================================================================
2470//====================================================================================================================
2471
2476typedef enum evxEnvironment
2477 {
2478 VX_ENV_Z3FILE = 2,
2479 VX_ENV_SKETCH,
2480 VX_ENV_SHEET,
2481 VX_ENV_PACKET,
2482 VX_ENV_CAM,
2483 VX_ENV_ANIMATION,
2484 VX_ENV_EXPLODEDVIEW,
2485 VX_ENV_3DSKETCH,
2486 VX_ENV_PART,
2487 VX_ENV_ECAD_PART,
2488 VX_ENV_ECAD_ASSEMBLY,
2489 VX_ENV_ASSEMBLY,
2490 VX_ENV_PIPING
2491 }evxEnvironment;
2492
2493//====================================================================================================================
2495//====================================================================================================================
2496
2501typedef enum evxCmAttrValueType
2502 {
2503 ZW_CAM_ATTR_VALUE_TYPE_INVALID = -1,
2504 ZW_CAM_ATTR_VALUE_TYPE_INTEGER = 0,
2505 ZW_CAM_ATTR_VALUE_TYPE_DOUBLE,
2506 ZW_CAM_ATTR_VALUE_TYPE_STRING
2507 }evxCmAttrValueType;
2508
2513typedef struct svxCmAttrValue
2514 {
2515 evxCmAttrValueType type;
2516 int cnt;
2517 void* data;
2518 }svxCmAttrValue;
2519
2524typedef enum evxCmPlanDispMode
2525 {
2526 CM_ACTIVE_LOCK = 0,
2527 CM_ACTIVE_PART = 1,
2528 CM_ACTIVE_PROCESS = 2,
2529 CM_ACTIVE_SETUP = 3,
2530 CM_ACTIVE_TOOLPATH = 4,
2531 CM_ACTIVE_MACHINE = 5,
2532 CM_ACTIVE_TOOL = 6,
2533 CM_ACTIVE_TACTIC = 7,
2534 CM_ACTIVE_SPDFD = 8,
2535 CM_ACTIVE_CMCOMP = 9,
2536 CM_ACTIVE_FTRGRP = 10,
2537 CM_ACTIVE_FTRSET = 11,
2538 CM_ACTIVE_NEST = 12,
2539 CM_ACTIVE_WIZARD = 13,
2540 CM_ACTIVE_PUNCH = 14,
2541 CM_ACTIVE_HOLDER = 15
2542 }evxCmPlanDispMode;
2543
2548typedef enum evxCmTreeType
2549 {
2550 CM_TREE_OP = 0,
2551 CM_TREE_COMP = 1,
2552 CM_TREE_FLD = 2,
2553 CM_TREE_FTR = 3,
2555 }evxCmTreeType;
2556
2557#ifdef __cplusplus
2558 }
2559#endif /* __cplusplus */
2560#endif /* ZW_API_UTIL_H */
VX_EDGE_SEAM
@ VX_EDGE_SEAM
seam edge
Definition: zwapi_util.h:1001
VX_EDGE_STANDARD
@ VX_EDGE_STANDARD
standard edge
Definition: zwapi_util.h:1000
VX_EDGE_UNKNOWN
@ VX_EDGE_UNKNOWN
unknown
Definition: zwapi_util.h:999
VX_EDGE_DEGEN
@ VX_EDGE_DEGEN
degenerate edge
Definition: zwapi_util.h:1002
evxPlacingType
evxPlacingType
placing adjustment type
Definition: zwapi_util.h:2385
VX_PLACING_WCS
@ VX_PLACING_WCS
WCS.
Definition: zwapi_util.h:2389
VX_PLACING_PLANE
@ VX_PLACING_PLANE
PLANE.
Definition: zwapi_util.h:2390
VX_PLACING_VECTOR
@ VX_PLACING_VECTOR
vector
Definition: zwapi_util.h:2388
VX_PLACING_VIEW
@ VX_PLACING_VIEW
view , 3d spline default value
Definition: zwapi_util.h:2387
VX_PLACING_NONE
@ VX_PLACING_NONE
none , 2d spline default value
Definition: zwapi_util.h:2386
vxLongName
char vxLongName[256]
long object name (null-terminated text string)
Definition: zwapi_util.h:209
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
V_PP_LEN
#define V_PP_LEN
maximum length of a non-persistent (i.e. evaluated) pick path
Definition: zwapi_util.h:260
evxCurveType
evxCurveType
curve types
Definition: zwapi_util.h:1598
vxUint32
unsigned int vxUint32
32 bit unsigned integer
Definition: zwapi_util.h:250
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
vxExp
char vxExp[256]
arithmetic expression (null-terminated text string)
Definition: zwapi_util.h:228
evxDirType
evxDirType
type of direction
Definition: zwapi_util.h:579
VX_END_DIR
@ VX_END_DIR
end direction of curve, (if the input is face, get tangent direction of (u.max, v....
Definition: zwapi_util.h:581
VX_PNT_DIR
@ VX_PNT_DIR
tangent direction of point on face
Definition: zwapi_util.h:582
VX_START_DIR
@ VX_START_DIR
start direction of curve, (if the input is face, get tangent direction of (u.min, v....
Definition: zwapi_util.h:580
evxDensityUnitType
evxDensityUnitType
system of density units
Definition: zwapi_util.h:412
VX_UNIT_DEN_G_CM3
@ VX_UNIT_DEN_G_CM3
g/cm3
Definition: zwapi_util.h:416
VX_UNIT_DEN_G_MM3
@ VX_UNIT_DEN_G_MM3
g/mm3
Definition: zwapi_util.h:415
VX_UNIT_DEN_KG_MM3
@ VX_UNIT_DEN_KG_MM3
kg/mm3
Definition: zwapi_util.h:414
VX_UNIT_DEN_OZ_YD3
@ VX_UNIT_DEN_OZ_YD3
oz/yd3
Definition: zwapi_util.h:422
VX_UNIT_DEN_OZ_FT3
@ VX_UNIT_DEN_OZ_FT3
oz/ft3
Definition: zwapi_util.h:421
VX_UNIT_DEN_LB_YD3
@ VX_UNIT_DEN_LB_YD3
lb/yd3
Definition: zwapi_util.h:419
VX_UNIT_DEN_OZ_IN3
@ VX_UNIT_DEN_OZ_IN3
oz/in3
Definition: zwapi_util.h:420
VX_UNIT_DEN_KG_DM3
@ VX_UNIT_DEN_KG_DM3
kg/dm3
Definition: zwapi_util.h:423
VX_UNIT_DEN_LB_IN3
@ VX_UNIT_DEN_LB_IN3
lb/in3
Definition: zwapi_util.h:417
VX_UNIT_DEN_LB_FT3
@ VX_UNIT_DEN_LB_FT3
lb/ft3
Definition: zwapi_util.h:418
VX_UNIT_DEN_KG_M3
@ VX_UNIT_DEN_KG_M3
kg/m3
Definition: zwapi_util.h:413
VX_UNIT_DEN_G_DM3
@ VX_UNIT_DEN_G_DM3
g/dm3
Definition: zwapi_util.h:424
evxFairingType
evxFairingType
fairing modes
Definition: zwapi_util.h:2315
VX_FAIRING_JERK
@ VX_FAIRING_JERK
jerk
Definition: zwapi_util.h:2319
VX_FAIRING_BEND
@ VX_FAIRING_BEND
bend
Definition: zwapi_util.h:2320
VX_FAIRING_ENERGY
@ VX_FAIRING_ENERGY
energy
Definition: zwapi_util.h:2317
VX_FAIRING_NONE
@ VX_FAIRING_NONE
none
Definition: zwapi_util.h:2316
VX_FAIRING_TENSION
@ VX_FAIRING_TENSION
tension
Definition: zwapi_util.h:2321
VX_FAIRING_VARIATION
@ VX_FAIRING_VARIATION
variation
Definition: zwapi_util.h:2318
evxAttributeType
evxAttributeType
attribute data type
Definition: zwapi_util.h:1341
VX_ATTR_INT
@ VX_ATTR_INT
integer
Definition: zwapi_util.h:1344
VX_ATTR_STRING
@ VX_ATTR_STRING
string
Definition: zwapi_util.h:1342
VX_ATTR_BOOL
@ VX_ATTR_BOOL
bool
Definition: zwapi_util.h:1343
VX_ATTR_DATE
@ VX_ATTR_DATE
date/time
Definition: zwapi_util.h:1346
VX_ATTR_REAL
@ VX_ATTR_REAL
real number
Definition: zwapi_util.h:1345
evxPntType
evxPntType
point input data types
Definition: zwapi_util.h:1524
VX_PNT3_ENT
@ VX_PNT3_ENT
entity "critical" point (start, end, mid, center)
Definition: zwapi_util.h:1526
VX_PNT3_FRAC
@ VX_PNT3_FRAC
point on curve defined as fraction of curve length
Definition: zwapi_util.h:1534
VX_PNT3_ON
@ VX_PNT3_ON
point on entity defined in entity parameter space
Definition: zwapi_util.h:1527
VX_PNT3_DST
@ VX_PNT3_DST
point object stores linear numeric input
Definition: zwapi_util.h:1531
VX_PNT3_ABS
@ VX_PNT3_ABS
defined by absolute coord. in object space
Definition: zwapi_util.h:1525
VX_PNT3_ANG
@ VX_PNT3_ANG
point object stores angular numeric input
Definition: zwapi_util.h:1532
VX_PNT3_NUM
@ VX_PNT3_NUM
point object stores dimensionless numeric input
Definition: zwapi_util.h:1530
VX_PNT3_TO
@ VX_PNT3_TO
point on entity for "tangent to" or "extend to"
Definition: zwapi_util.h:1528
VX_PNT3_ABS_COMP
@ VX_PNT3_ABS_COMP
defined by abs coord in space of active component
Definition: zwapi_util.h:1537
VX_PNT3_TAN
@ VX_PNT3_TAN
point on entity for "tangent to"
Definition: zwapi_util.h:1533
VX_PNT3_MID
@ VX_PNT3_MID
curve midpoint
Definition: zwapi_util.h:1529
VX_PNT3_DATA
@ VX_PNT3_DATA
point defined by a VDATA object
Definition: zwapi_util.h:1536
VX_PNT3_REL
@ VX_PNT3_REL
point defined relative to previous point
Definition: zwapi_util.h:1535
evxVarType
evxVarType
variable types
Definition: zwapi_util.h:1094
VX_VAR_NUM
@ VX_VAR_NUM
number
Definition: zwapi_util.h:1095
VX_VAR_PNT
@ VX_VAR_PNT
point
Definition: zwapi_util.h:1097
VX_VAR_STR
@ VX_VAR_STR
string
Definition: zwapi_util.h:1096
VX_VAR_VEC
@ VX_VAR_VEC
vector
Definition: zwapi_util.h:1098
evxEnvironment
evxEnvironment
zw3d environment
Definition: zwapi_util.h:2477
VX_ENV_CAM
@ VX_ENV_CAM
cam
Definition: zwapi_util.h:2482
VX_ENV_ASSEMBLY
@ VX_ENV_ASSEMBLY
Assembly.
Definition: zwapi_util.h:2489
VX_ENV_SHEET
@ VX_ENV_SHEET
sheet
Definition: zwapi_util.h:2480
VX_ENV_EXPLODEDVIEW
@ VX_ENV_EXPLODEDVIEW
explodedView
Definition: zwapi_util.h:2484
VX_ENV_ANIMATION
@ VX_ENV_ANIMATION
animation
Definition: zwapi_util.h:2483
VX_ENV_3DSKETCH
@ VX_ENV_3DSKETCH
3Dsketch
Definition: zwapi_util.h:2485
VX_ENV_PIPING
@ VX_ENV_PIPING
piping
Definition: zwapi_util.h:2490
VX_ENV_PACKET
@ VX_ENV_PACKET
packet
Definition: zwapi_util.h:2481
VX_ENV_PART
@ VX_ENV_PART
part
Definition: zwapi_util.h:2486
VX_ENV_ECAD_ASSEMBLY
@ VX_ENV_ECAD_ASSEMBLY
ECAD assembly.
Definition: zwapi_util.h:2488
VX_ENV_Z3FILE
@ VX_ENV_Z3FILE
Z3File.
Definition: zwapi_util.h:2478
VX_ENV_ECAD_PART
@ VX_ENV_ECAD_PART
ECAD part.
Definition: zwapi_util.h:2487
VX_ENV_SKETCH
@ VX_ENV_SKETCH
sketch
Definition: zwapi_util.h:2479
evxAtItemId
evxAtItemId
standard id of attribute item
Definition: zwapi_util.h:1292
VX_AT_SHEET_PROJECTION
@ VX_AT_SHEET_PROJECTION
projection
Definition: zwapi_util.h:1332
VX_AT_DESIGNER
@ VX_AT_DESIGNER
designer
Definition: zwapi_util.h:1298
VX_AT_SHEETPATH
@ VX_AT_SHEETPATH
corresponded drawing sheet: FILE NAME,SHEET ROOT NAME
Definition: zwapi_util.h:1314
VX_AT_SHEET_SCALE
@ VX_AT_SHEET_SCALE
scale
Definition: zwapi_util.h:1328
VX_AT_KEYWORD
@ VX_AT_KEYWORD
keyword
Definition: zwapi_util.h:1302
VX_AT_DERIVED
@ VX_AT_DERIVED
derived from
Definition: zwapi_util.h:1307
VX_AT_HEIGHT
@ VX_AT_HEIGHT
height
Definition: zwapi_util.h:1323
VX_AT_NAME
@ VX_AT_NAME
part name
Definition: zwapi_util.h:1295
VX_AT_FILEPATH
@ VX_AT_FILEPATH
file path
Definition: zwapi_util.h:1313
VX_AT_VOLUME
@ VX_AT_VOLUME
volume
Definition: zwapi_util.h:1319
VX_AT_AREA
@ VX_AT_AREA
area
Definition: zwapi_util.h:1318
VX_AT_REVISION
@ VX_AT_REVISION
revision
Definition: zwapi_util.h:1325
VX_AT_NO_ROOTSHOW
@ VX_AT_NO_ROOTSHOW
do not list in root manager
Definition: zwapi_util.h:1311
VX_AT_SHEETCODE
@ VX_AT_SHEETCODE
sheet code
Definition: zwapi_util.h:1316
VX_AT_WIDTH
@ VX_AT_WIDTH
width
Definition: zwapi_util.h:1322
VX_AT_NUMBER
@ VX_AT_NUMBER
part number
Definition: zwapi_util.h:1296
VX_AT_SHEET_FILEPATH
@ VX_AT_SHEET_FILEPATH
filepath
Definition: zwapi_util.h:1333
VX_AT_MANAGER
@ VX_AT_MANAGER
manager
Definition: zwapi_util.h:1303
VX_AT_STOCK_SIZE
@ VX_AT_STOCK_SIZE
stock size
Definition: zwapi_util.h:1324
VX_AT_NO_BOM
@ VX_AT_NO_BOM
do not list in BOM
Definition: zwapi_util.h:1310
VX_AT_CAMPATH
@ VX_AT_CAMPATH
corresponded CAM object: FILE NAME,CAM ROOT NAME
Definition: zwapi_util.h:1315
VX_AT_SUPPLIER
@ VX_AT_SUPPLIER
supplier
Definition: zwapi_util.h:1300
VX_AT_MASS
@ VX_AT_MASS
mass property
Definition: zwapi_util.h:1320
VX_AT_SHEET_SIZE
@ VX_AT_SHEET_SIZE
size
Definition: zwapi_util.h:1331
VX_AT_START
@ VX_AT_START
create time
Definition: zwapi_util.h:1305
VX_AT_DESCRIPT
@ VX_AT_DESCRIPT
description
Definition: zwapi_util.h:1301
VX_AT_LENGTH
@ VX_AT_LENGTH
length
Definition: zwapi_util.h:1321
VX_AT_NO_HATCH
@ VX_AT_NO_HATCH
do not hatch
Definition: zwapi_util.h:1309
VX_AT_END
@ VX_AT_END
last modified time
Definition: zwapi_util.h:1306
VX_AT_COST
@ VX_AT_COST
cost
Definition: zwapi_util.h:1299
VX_AT_DENSITY
@ VX_AT_DENSITY
density
Definition: zwapi_util.h:1312
VX_AT_SHEET_SEQUENCE
@ VX_AT_SHEET_SEQUENCE
sequence
Definition: zwapi_util.h:1329
VX_AT_SHEET_AMOUNT
@ VX_AT_SHEET_AMOUNT
amount
Definition: zwapi_util.h:1330
VX_AT_CLASS
@ VX_AT_CLASS
CAM class.
Definition: zwapi_util.h:1297
VX_AT_USER
@ VX_AT_USER
user defined attributes
Definition: zwapi_util.h:1294
VX_AT_MATERIAL
@ VX_AT_MATERIAL
material
Definition: zwapi_util.h:1304
VX_AT_NO_SECTION
@ VX_AT_NO_SECTION
do not section
Definition: zwapi_util.h:1308
evxCmPlanDispMode
evxCmPlanDispMode
cam plan display mode
Definition: zwapi_util.h:2525
CM_ACTIVE_SETUP
@ CM_ACTIVE_SETUP
setup
Definition: zwapi_util.h:2529
CM_ACTIVE_CMCOMP
@ CM_ACTIVE_CMCOMP
cmcomp
Definition: zwapi_util.h:2535
CM_ACTIVE_TOOLPATH
@ CM_ACTIVE_TOOLPATH
toolpath
Definition: zwapi_util.h:2530
CM_ACTIVE_PART
@ CM_ACTIVE_PART
part
Definition: zwapi_util.h:2527
CM_ACTIVE_PUNCH
@ CM_ACTIVE_PUNCH
punch
Definition: zwapi_util.h:2540
CM_ACTIVE_LOCK
@ CM_ACTIVE_LOCK
lock
Definition: zwapi_util.h:2526
CM_ACTIVE_SPDFD
@ CM_ACTIVE_SPDFD
spdfd
Definition: zwapi_util.h:2534
CM_ACTIVE_WIZARD
@ CM_ACTIVE_WIZARD
wizard
Definition: zwapi_util.h:2539
CM_ACTIVE_FTRGRP
@ CM_ACTIVE_FTRGRP
ftrgrp
Definition: zwapi_util.h:2536
CM_ACTIVE_PROCESS
@ CM_ACTIVE_PROCESS
process
Definition: zwapi_util.h:2528
CM_ACTIVE_FTRSET
@ CM_ACTIVE_FTRSET
ftrset
Definition: zwapi_util.h:2537
CM_ACTIVE_MACHINE
@ CM_ACTIVE_MACHINE
machine
Definition: zwapi_util.h:2531
CM_ACTIVE_TOOL
@ CM_ACTIVE_TOOL
tool
Definition: zwapi_util.h:2532
CM_ACTIVE_HOLDER
@ CM_ACTIVE_HOLDER
holder
Definition: zwapi_util.h:2541
CM_ACTIVE_TACTIC
@ CM_ACTIVE_TACTIC
tactic
Definition: zwapi_util.h:2533
CM_ACTIVE_NEST
@ CM_ACTIVE_NEST
nest
Definition: zwapi_util.h:2538
evxEdgeType
evxEdgeType
type of edge
Definition: zwapi_util.h:998
vxPath
char vxPath[256]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:216
evxFCSShapeSym
evxFCSShapeSym
FCS area shape symbol.
Definition: zwapi_util.h:2129
VX_SHP_NONE
@ VX_SHP_NONE
none
Definition: zwapi_util.h:2130
VX_SHP_SPHERICAL_DIA
@ VX_SHP_SPHERICAL_DIA
spherical diameter
Definition: zwapi_util.h:2132
VX_SHP_DIAMETER
@ VX_SHP_DIAMETER
diameter
Definition: zwapi_util.h:2131
VX_SHP_SQUARE
@ VX_SHP_SQUARE
square
Definition: zwapi_util.h:2133
vxRootName
char vxRootName[256]
root object name (null-terminated text string)
Definition: zwapi_util.h:222
evxMassUnitType
evxMassUnitType
system of mass units
Definition: zwapi_util.h:400
VX_UNIT_OZ
@ VX_UNIT_OZ
ounce
Definition: zwapi_util.h:403
VX_UNIT_LB
@ VX_UNIT_LB
pound
Definition: zwapi_util.h:404
VX_UNIT_GM
@ VX_UNIT_GM
gram
Definition: zwapi_util.h:401
VX_UNIT_KG
@ VX_UNIT_KG
kilogram
Definition: zwapi_util.h:402
evxExtendOpt
evxExtendOpt
curve/surface extension options
Definition: zwapi_util.h:2300
VX_EXTEND_UNDEFINED
@ VX_EXTEND_UNDEFINED
linear extend is the default when extension is undefined
Definition: zwapi_util.h:2301
evxDateFormat
evxDateFormat
date attribute format
Definition: zwapi_util.h:1354
VX_DATE_FROMAT1
@ VX_DATE_FROMAT1
yyyy/M/D
Definition: zwapi_util.h:1357
VX_DATE_FROMAT6
@ VX_DATE_FROMAT6
yy.M.D
Definition: zwapi_util.h:1362
VX_DATE_FROMAT5
@ VX_DATE_FROMAT5
yy-M-D
Definition: zwapi_util.h:1361
VX_DATE_FROMAT2
@ VX_DATE_FROMAT2
yyyy-M-D
Definition: zwapi_util.h:1358
VX_DATE_FROMAT_LONG
@ VX_DATE_FROMAT_LONG
long date
Definition: zwapi_util.h:1356
VX_DATE_FROMAT4
@ VX_DATE_FROMAT4
yy/M/D
Definition: zwapi_util.h:1360
VX_DATE_FROMAT_SHORT
@ VX_DATE_FROMAT_SHORT
short date
Definition: zwapi_util.h:1355
VX_DATE_FROMAT3
@ VX_DATE_FROMAT3
yyyy.M.D
Definition: zwapi_util.h:1359
vxVarExp
char vxVarExp[1024]
variable expression (null-terminated text string)
Definition: zwapi_util.h:234
evxAngUnitType
evxAngUnitType
system of angle units
Definition: zwapi_util.h:1545
VX_UNIT_RAD
@ VX_UNIT_RAD
radian
Definition: zwapi_util.h:1547
VX_UNIT_DEG
@ VX_UNIT_DEG
degree
Definition: zwapi_util.h:1546
evxSrfPrimType
evxSrfPrimType
3D NURB surface type
Definition: zwapi_util.h:1755
VX_SF_PRIM_CON
@ VX_SF_PRIM_CON
cone
Definition: zwapi_util.h:1758
VX_SF_PRIM_ELLSO
@ VX_SF_PRIM_ELLSO
ellipsoid
Definition: zwapi_util.h:1761
VX_SF_PRIM_PLN
@ VX_SF_PRIM_PLN
plane
Definition: zwapi_util.h:1756
VX_SF_PRIM_CYL
@ VX_SF_PRIM_CYL
cylinder
Definition: zwapi_util.h:1759
VX_SF_PRIM_SPH
@ VX_SF_PRIM_SPH
sphere
Definition: zwapi_util.h:1757
VX_SF_PRIM_NURB
@ VX_SF_PRIM_NURB
nurbs surface
Definition: zwapi_util.h:1760
VX_SF_PRIM_TORUS
@ VX_SF_PRIM_TORUS
torus
Definition: zwapi_util.h:1762
evxDimType
evxDimType
dimension type
Definition: zwapi_util.h:1934
VX_DIM_FCS
@ VX_DIM_FCS
feature control symbol
Definition: zwapi_util.h:1950
VX_DIM_CLCM
@ VX_DIM_CLCM
centerline/center mark
Definition: zwapi_util.h:1951
VX_DIM_DATUMT
@ VX_DIM_DATUMT
datum target
Definition: zwapi_util.h:1949
VX_DIM_SYMMETRY
@ VX_DIM_SYMMETRY
Symmetry dimension.
Definition: zwapi_util.h:1944
VX_DIM_ORDINATE
@ VX_DIM_ORDINATE
Ordinate dimension.
Definition: zwapi_util.h:1938
VX_DIM_HLCALL
@ VX_DIM_HLCALL
hole call out
Definition: zwapi_util.h:1945
VX_DIM_LABEL
@ VX_DIM_LABEL
leader label
Definition: zwapi_util.h:1946
VX_DIM_BALLOON
@ VX_DIM_BALLOON
balloon
Definition: zwapi_util.h:1947
VX_DIM_ANGULAR
@ VX_DIM_ANGULAR
Angular dimension.
Definition: zwapi_util.h:1941
VX_DIM_DATUMF
@ VX_DIM_DATUMF
datum feature
Definition: zwapi_util.h:1948
VX_DIM_INTERSYM
@ VX_DIM_INTERSYM
intersection symbol
Definition: zwapi_util.h:1952
VX_DIM_BASELINE
@ VX_DIM_BASELINE
Baseline dimension.
Definition: zwapi_util.h:1936
VX_DIM_CONTINUOUS
@ VX_DIM_CONTINUOUS
Continuous dimension.
Definition: zwapi_util.h:1937
VX_DIM_RADIAL_DIAMETRIC
@ VX_DIM_RADIAL_DIAMETRIC
Radial/Diametric dimension.
Definition: zwapi_util.h:1942
VX_DIM_LINEAR_CHAMFER
@ VX_DIM_LINEAR_CHAMFER
Linear Chamfer dimension.
Definition: zwapi_util.h:1940
VX_DIM_ARC_LENGTH
@ VX_DIM_ARC_LENGTH
Arc Length dimension.
Definition: zwapi_util.h:1943
VX_DIM_LINEAR_OFFSET
@ VX_DIM_LINEAR_OFFSET
Linear Offset dimension.
Definition: zwapi_util.h:1939
VX_DIM_LINEAR
@ VX_DIM_LINEAR
Linear dimension.
Definition: zwapi_util.h:1935
evxFindRule
evxFindRule
face search rules
Definition: zwapi_util.h:1057
VX_FIND_COPLANAR
@ VX_FIND_COPLANAR
find faces which are in the same plane with the seed
Definition: zwapi_util.h:1076
VX_FIND_OFFSET
@ VX_FIND_OFFSET
find face which has overlap regions with the seed and face normal is opposite, for a seed,...
Definition: zwapi_util.h:1082
VX_STOP_ADJACENCY_LEVEL
@ VX_STOP_ADJACENCY_LEVEL
stop when face region grows through a set number of cycles, a face region grows in cycles,...
Definition: zwapi_util.h:1065
VX_STOP_FACE_FILLET
@ VX_STOP_FACE_FILLET
stop at fillet faces (fillets are added)
Definition: zwapi_util.h:1059
VX_FIND_EQU_RAD
@ VX_FIND_EQU_RAD
find faces whose radius is equal to the seed, seed face support cylinder and sphere
Definition: zwapi_util.h:1079
VX_FIND_COAXIAL
@ VX_FIND_COAXIAL
find coaxial faces, seed face support cylinder,conical,sphere,torus
Definition: zwapi_util.h:1074
VX_FIND_TANGENT
@ VX_FIND_TANGENT
find faces which is tangent to the seed
Definition: zwapi_util.h:1075
VX_STOP_EDGE_INNER_LOOP
@ VX_STOP_EDGE_INNER_LOOP
stop at edges on inner loops on either face
Definition: zwapi_util.h:1060
VX_STOP_CONVEX_FLLT
@ VX_STOP_CONVEX_FLLT
stop at convex fillet faces (fillets are added)
Definition: zwapi_util.h:1061
VX_STOP_CONCAVE_FLLT
@ VX_STOP_CONCAVE_FLLT
stop at concave fillet faces (fillets are added)
Definition: zwapi_util.h:1062
VX_STOP_BOUNDARY_FACE
@ VX_STOP_BOUNDARY_FACE
stop at boundary faces
Definition: zwapi_util.h:1070
VX_FIND_SYMMETRIC
@ VX_FIND_SYMMETRIC
find symmetric faces, seed face support cylinder,conical
Definition: zwapi_util.h:1081
VX_STOP_CONVEX_EDGE
@ VX_STOP_CONVEX_EDGE
stop at convex edges
Definition: zwapi_util.h:1063
VX_FIND_COPL_AXES
@ VX_FIND_COPL_AXES
find faces whose axes are in the same plane with the seed, seed face support cylinder,...
Definition: zwapi_util.h:1077
VX_STOP_CONCAVE_EDGE
@ VX_STOP_CONCAVE_EDGE
stop at concave edges
Definition: zwapi_util.h:1064
evxEntFind
evxEntFind
entity search types
Definition: zwapi_util.h:1010
VX_FIND_EDGE
@ VX_FIND_EDGE
edge
Definition: zwapi_util.h:1013
VX_FIND_CURVE
@ VX_FIND_CURVE
curve
Definition: zwapi_util.h:1012
VX_FIND_WIRE
@ VX_FIND_WIRE
point, edge or curve
Definition: zwapi_util.h:1014
VX_FIND_SKETCH_OR_CRV_LIST
@ VX_FIND_SKETCH_OR_CRV_LIST
sketch or curve list
Definition: zwapi_util.h:1018
VX_FIND_DIM
@ VX_FIND_DIM
dimension
Definition: zwapi_util.h:1022
VX_FIND_SKETCH
@ VX_FIND_SKETCH
sketch
Definition: zwapi_util.h:1016
VX_FIND_POINT
@ VX_FIND_POINT
point
Definition: zwapi_util.h:1011
VX_FIND_FACE
@ VX_FIND_FACE
face
Definition: zwapi_util.h:1015
VX_FIND_PROFILE
@ VX_FIND_PROFILE
curve, edge, sketch or curvelist
Definition: zwapi_util.h:1019
VX_FIND_EDGE_OR_CRV
@ VX_FIND_EDGE_OR_CRV
edge or curve
Definition: zwapi_util.h:1020
VX_FIND_CRV_LIST
@ VX_FIND_CRV_LIST
3D curve list
Definition: zwapi_util.h:1017
VX_FIND_3D_BLOCK
@ VX_FIND_3D_BLOCK
3D point or STL block
Definition: zwapi_util.h:1021
evxTextureOpt
evxTextureOpt
texture map option
Definition: zwapi_util.h:1240
evxUnitType
evxUnitType
system of linear units
Definition: zwapi_util.h:383
VX_UNIT_DM
@ VX_UNIT_DM
decimeter
Definition: zwapi_util.h:391
VX_UNIT_YD
@ VX_UNIT_YD
yard
Definition: zwapi_util.h:390
VX_UNIT_METER
@ VX_UNIT_METER
meter
Definition: zwapi_util.h:387
VX_UNIT_MIL
@ VX_UNIT_MIL
mil
Definition: zwapi_util.h:392
VX_UNIT_MILLIMETER
@ VX_UNIT_MILLIMETER
millimeter
Definition: zwapi_util.h:385
VX_UNIT_FOOT
@ VX_UNIT_FOOT
foot
Definition: zwapi_util.h:389
VX_UNIT_INCH
@ VX_UNIT_INCH
inch
Definition: zwapi_util.h:388
VX_UNIT_MICRON
@ VX_UNIT_MICRON
micron
Definition: zwapi_util.h:384
VX_UNIT_CENTIMETER
@ VX_UNIT_CENTIMETER
centimeter
Definition: zwapi_util.h:386
evxEntType
evxEntType
entity types
Definition: zwapi_util.h:917
VX_ENT_PART
@ VX_ENT_PART
part
Definition: zwapi_util.h:945
VX_ENT_AXIS
@ VX_ENT_AXIS
Datum axis.
Definition: zwapi_util.h:966
VX_ENT_TABLE
@ VX_ENT_TABLE
table object
Definition: zwapi_util.h:958
VX_ENT_LINE2
@ VX_ENT_LINE2
2D line
Definition: zwapi_util.h:929
VX_ENT_BREP
@ VX_ENT_BREP
any brep entity (i.e. shape,face,loop,edge,vertex)
Definition: zwapi_util.h:918
VX_ENT_COMP
@ VX_ENT_COMP
assembly component
Definition: zwapi_util.h:944
VX_ENT_BALLOON
@ VX_ENT_BALLOON
Text balloon.
Definition: zwapi_util.h:961
VX_ENT_POINT2
@ VX_ENT_POINT2
2D point
Definition: zwapi_util.h:935
VX_ENT_PMIENT
@ VX_ENT_PMIENT
PMI entity.
Definition: zwapi_util.h:963
VX_ENT_FACE
@ VX_ENT_FACE
b-rep face
Definition: zwapi_util.h:924
VX_ENT_OP
@ VX_ENT_OP
any history operation
Definition: zwapi_util.h:919
VX_ENT_RDTXT
@ VX_ENT_RDTXT
Ready sketch text.
Definition: zwapi_util.h:960
VX_ENT_VBREAKLINE
@ VX_ENT_VBREAKLINE
Break line.
Definition: zwapi_util.h:959
VX_ENT_CRV_LIST
@ VX_ENT_CRV_LIST
curve list
Definition: zwapi_util.h:949
VX_ENT_AXIS_2D
@ VX_ENT_AXIS_2D
2D datum axis
Definition: zwapi_util.h:968
VX_ENT_VAR
@ VX_ENT_VAR
variable
Definition: zwapi_util.h:954
VX_ENT_REF_GEOM
@ VX_ENT_REF_GEOM
reference geometry
Definition: zwapi_util.h:938
VX_ENT_TRACE
@ VX_ENT_TRACE
sketch trace
Definition: zwapi_util.h:957
VX_ENT_LIGHT
@ VX_ENT_LIGHT
light source
Definition: zwapi_util.h:952
VX_ENT_BLOCK
@ VX_ENT_BLOCK
block
Definition: zwapi_util.h:942
VX_ENT_SHEET
@ VX_ENT_SHEET
drawing sheet
Definition: zwapi_util.h:946
VX_ENT_CIRCLE3
@ VX_ENT_CIRCLE3
3D circle
Definition: zwapi_util.h:930
VX_ENT_ARC2
@ VX_ENT_ARC2
2D arc
Definition: zwapi_util.h:933
VX_ENT_CSYS
@ VX_ENT_CSYS
Datum frame.
Definition: zwapi_util.h:967
VX_ENT_PACKET
@ VX_ENT_PACKET
drawing packet
Definition: zwapi_util.h:947
VX_ENT_BLKREF
@ VX_ENT_BLKREF
block reference (the instance of 2d sketch block)
Definition: zwapi_util.h:965
VX_ENT_BLOCK2D
@ VX_ENT_BLOCK2D
2D sketch block
Definition: zwapi_util.h:964
VX_ENT_ARC3
@ VX_ENT_ARC3
3D arc
Definition: zwapi_util.h:932
VX_ENT_LINE3
@ VX_ENT_LINE3
3D line
Definition: zwapi_util.h:928
VX_ENT_POINT3
@ VX_ENT_POINT3
3D point
Definition: zwapi_util.h:934
VX_ENT_SHAPE
@ VX_ENT_SHAPE
b-rep shape (i.e. faceset)
Definition: zwapi_util.h:923
VX_ENT_DRAWING
@ VX_ENT_DRAWING
Drawing under the sheet.
Definition: zwapi_util.h:962
VX_ENT_DATUM
@ VX_ENT_DATUM
datum plane
Definition: zwapi_util.h:948
VX_ENT_EQN_SET
@ VX_ENT_EQN_SET
equation set
Definition: zwapi_util.h:955
VX_ENT_SKETCH
@ VX_ENT_SKETCH
sketch
Definition: zwapi_util.h:937
VX_ENT_NRB_CRV
@ VX_ENT_NRB_CRV
NURBS curve.
Definition: zwapi_util.h:927
VX_ENT_FTR
@ VX_ENT_FTR
feature operation
Definition: zwapi_util.h:926
VX_ENT_DWG_VIEW
@ VX_ENT_DWG_VIEW
drawing view
Definition: zwapi_util.h:943
VX_ENT_CIRCLE2
@ VX_ENT_CIRCLE2
2D circle
Definition: zwapi_util.h:931
VX_ENT_TEXT
@ VX_ENT_TEXT
text
Definition: zwapi_util.h:939
VX_ENT_PART_LINE
@ VX_ENT_PART_LINE
parting line
Definition: zwapi_util.h:950
VX_ENT_WIRE
@ VX_ENT_WIRE
any wireframe entity (line, arc, curve)
Definition: zwapi_util.h:921
VX_ENT_DIMEN
@ VX_ENT_DIMEN
dimension
Definition: zwapi_util.h:940
VX_ENT_INT_CRV
@ VX_ENT_INT_CRV
interpolated curve
Definition: zwapi_util.h:953
VX_ENT_LAYER
@ VX_ENT_LAYER
layer
Definition: zwapi_util.h:936
VX_ENT_HATCH
@ VX_ENT_HATCH
cross-hatch
Definition: zwapi_util.h:951
VX_ENT_ANNO
@ VX_ENT_ANNO
annotation text
Definition: zwapi_util.h:941
VX_ENT_SYMBOL
@ VX_ENT_SYMBOL
2D symbol
Definition: zwapi_util.h:956
VX_ENT_EDGE
@ VX_ENT_EDGE
b-rep edge
Definition: zwapi_util.h:925
VX_ENT_ALL
@ VX_ENT_ALL
any entity type
Definition: zwapi_util.h:922
VX_ENT_POINT
@ VX_ENT_POINT
any point entity (2D or 3D)
Definition: zwapi_util.h:920
evxDimLineMode
evxDimLineMode
dimension Line Mode
Definition: zwapi_util.h:2081
VX_DIM_LINE_MODE_O
@ VX_DIM_LINE_MODE_O
lingrp ordinate
Definition: zwapi_util.h:2084
VX_DIM_LINE_MODE_B
@ VX_DIM_LINE_MODE_B
lingrp baseline
Definition: zwapi_util.h:2082
VX_DIM_LINE_MODE_C
@ VX_DIM_LINE_MODE_C
lingrp continuous
Definition: zwapi_util.h:2083
evxTermType
evxTermType
terminator types
Definition: zwapi_util.h:2193
VX_TERM_ARROW_HF15
@ VX_TERM_ARROW_HF15
arrowhead style: filled triangle with 15-degree angle
Definition: zwapi_util.h:2201
VX_TERM_ARROW_HF60
@ VX_TERM_ARROW_HF60
arrowhead style: filled triangle with 60-degree angle
Definition: zwapi_util.h:2203
VX_TERM_DOT
@ VX_TERM_DOT
arrowhead style: unfilled point
Definition: zwapi_util.h:2205
VX_TERM_ARROW_15
@ VX_TERM_ARROW_15
arrowhead style: arrow with 15-degree angle
Definition: zwapi_util.h:2195
VX_TERM_DOTF
@ VX_TERM_DOTF
arrowhead style: filled point
Definition: zwapi_util.h:2206
VX_TERM_TICK
@ VX_TERM_TICK
arrowhead style: tick
Definition: zwapi_util.h:2204
VX_TERM_ARROW_30
@ VX_TERM_ARROW_30
arrowhead style: arrow with 30-degree angle
Definition: zwapi_util.h:2196
VX_TERM_ARROW_H60
@ VX_TERM_ARROW_H60
arrowhead style: unfilled triangle with 60-degree angle
Definition: zwapi_util.h:2200
VX_TERM_ARROW_HF30
@ VX_TERM_ARROW_HF30
arrowhead style: filled triangle with 30-degree angle
Definition: zwapi_util.h:2202
VX_TERM_ARROW_H15
@ VX_TERM_ARROW_H15
arrowhead style: unfilled triangle with 15-degree angle
Definition: zwapi_util.h:2198
VX_TERM_ARROW_60
@ VX_TERM_ARROW_60
arrowhead style: arrow with 60-degree angle
Definition: zwapi_util.h:2197
VX_TERM_ARROW_H30
@ VX_TERM_ARROW_H30
arrowhead style: unfilled triangle with 30-degree angle
Definition: zwapi_util.h:2199
VX_TERM_OFF
@ VX_TERM_OFF
arrowhead style: suppressed
Definition: zwapi_util.h:2194
evxVarNumType
evxVarNumType
sub types of numeric variable
Definition: zwapi_util.h:1106
VX_VAR_MASS_MOMENT
@ VX_VAR_MASS_MOMENT
mass moment (evxMassMomentUnitType)
Definition: zwapi_util.h:1114
VX_VAR_ANG
@ VX_VAR_ANG
angle (evxAngUnitType)
Definition: zwapi_util.h:1109
VX_VAR_MASS
@ VX_VAR_MASS
mass (evxMassUnitType)
Definition: zwapi_util.h:1110
VX_VAR_DENSITY
@ VX_VAR_DENSITY
density (evxDensityUnitType)
Definition: zwapi_util.h:1111
VX_VAR_AREA
@ VX_VAR_AREA
area (evxUnitType)
Definition: zwapi_util.h:1112
VX_VAR_DST
@ VX_VAR_DST
distance (evxUnitType)
Definition: zwapi_util.h:1108
VX_VAR_CONS
@ VX_VAR_CONS
constant number (without unit)
Definition: zwapi_util.h:1107
VX_VAR_VOLUME
@ VX_VAR_VOLUME
volume (evxUnitType)
Definition: zwapi_util.h:1113
evxViewLineAttrIdx
evxViewLineAttrIdx
line type ids for view attribute line types
Definition: zwapi_util.h:1162
VX_THRD_END_HID_LINE_ATTR
@ VX_THRD_END_HID_LINE_ATTR
hidden thread end line attribute
Definition: zwapi_util.h:1179
VX_WIRE_LINE_ATTR
@ VX_WIRE_LINE_ATTR
visible 3D curve attribute
Definition: zwapi_util.h:1171
VX_SECT_LINE_ATTR
@ VX_SECT_LINE_ATTR
section line attribute
Definition: zwapi_util.h:1166
VX_VIS_LINE_ATTR
@ VX_VIS_LINE_ATTR
visible line attribute
Definition: zwapi_util.h:1163
VX_THRD_HID_LINE_ATTR
@ VX_THRD_HID_LINE_ATTR
hidden thread line attribute
Definition: zwapi_util.h:1175
VX_HID_LINE_ATTR
@ VX_HID_LINE_ATTR
hidden line attribute
Definition: zwapi_util.h:1164
VX_CROP_LINE_ATTR
@ VX_CROP_LINE_ATTR
crop line attribute
Definition: zwapi_util.h:1180
VX_TAN_LINE_ATTR
@ VX_TAN_LINE_ATTR
tangent line attribute
Definition: zwapi_util.h:1165
VX_WIRE_HID_LINE_ATTR
@ VX_WIRE_HID_LINE_ATTR
hidden 3D curve attribute
Definition: zwapi_util.h:1173
VX_CENT_LINE_ATTR
@ VX_CENT_LINE_ATTR
center line attribute
Definition: zwapi_util.h:1168
VX_BEND_HID_LINE_ATTR
@ VX_BEND_HID_LINE_ATTR
hidden bend line attribute
Definition: zwapi_util.h:1177
VX_THRD_END_LINE_ATTR
@ VX_THRD_END_LINE_ATTR
thread end line attribute
Definition: zwapi_util.h:1178
VX_THRD_LINE_ATTR
@ VX_THRD_LINE_ATTR
thread line attribute
Definition: zwapi_util.h:1169
VX_TAN_HID_LINE_ATTR
@ VX_TAN_HID_LINE_ATTR
hidden tangent line attribute
Definition: zwapi_util.h:1172
VX_BEND_LINE_ATTR
@ VX_BEND_LINE_ATTR
bend line attribute
Definition: zwapi_util.h:1176
VX_DET_LINE_ATTR
@ VX_DET_LINE_ATTR
detail border line attribute
Definition: zwapi_util.h:1167
VX_CENT_HID_LINE_ATTR
@ VX_CENT_HID_LINE_ATTR
hidden center line attribute
Definition: zwapi_util.h:1174
VX_VIEW_LINE_ATTR
@ VX_VIEW_LINE_ATTR
view line attribute
Definition: zwapi_util.h:1170
evxNumType
evxNumType
numeric input data types
Definition: zwapi_util.h:1496
VX_ANG
@ VX_ANG
angle (deg)
Definition: zwapi_util.h:1511
VX_MASS
@ VX_MASS
mass (kg)
Definition: zwapi_util.h:1512
VX_NUM_FACE_BND
@ VX_NUM_FACE_BND
boundary face
Definition: zwapi_util.h:1501
VX_VOLUME
@ VX_VOLUME
volume (m3)
Definition: zwapi_util.h:1515
VX_NUM_THRU_PLUS
@ VX_NUM_THRU_PLUS
"through all" in positive direction
Definition: zwapi_util.h:1503
VX_NUM_CURVE_BND
@ VX_NUM_CURVE_BND
boundary curve
Definition: zwapi_util.h:1505
VX_NUM_TO_FACE
@ VX_NUM_TO_FACE
distance/angle to face
Definition: zwapi_util.h:1500
VX_NUM_THRU_MINUS
@ VX_NUM_THRU_MINUS
"through all" in negative direction
Definition: zwapi_util.h:1504
VX_NUM_UNDEFINED
@ VX_NUM_UNDEFINED
undefined
Definition: zwapi_util.h:1498
VX_NUM_NULL
@ VX_NUM_NULL
undefined
Definition: zwapi_util.h:1499
VX_MASS_MOMENT
@ VX_MASS_MOMENT
mass moments (kg.mm2)
Definition: zwapi_util.h:1516
VX_UNDEF
@ VX_UNDEF
undefined
Definition: zwapi_util.h:1508
VX_DST
@ VX_DST
distance (mm)
Definition: zwapi_util.h:1510
VX_DENSITY
@ VX_DENSITY
density (kg/m3)
Definition: zwapi_util.h:1513
VX_NUM_TO_PNT
@ VX_NUM_TO_PNT
distance/angle to point
Definition: zwapi_util.h:1502
VX_NUM
@ VX_NUM
dimensionless number (e.g. curve degree)
Definition: zwapi_util.h:1509
VX_NUM_DATA
@ VX_NUM_DATA
number defined by a VDATA object
Definition: zwapi_util.h:1506
VX_AREA
@ VX_AREA
area (m2)
Definition: zwapi_util.h:1514
evxColor
evxColor
standard colors + index colors (see cvxColorRGB() for RGB color components)
Definition: zwapi_util.h:641
VX_COLOR_BROWN
@ VX_COLOR_BROWN
R=160, G=96, B=0.
Definition: zwapi_util.h:646
VX_COLOR_INDEX240
@ VX_COLOR_INDEX240
R=255, G=0, B=63
Definition: zwapi_util.h:886
VX_COLOR_INDEX39
@ VX_COLOR_INDEX39
R=76, G=57, B=38
Definition: zwapi_util.h:685
VX_COLOR_INDEX226
@ VX_COLOR_INDEX226
R=127, G=0, B=95
Definition: zwapi_util.h:872
VX_COLOR_INDEX71
@ VX_COLOR_INDEX71
R=191, G=255, B=127.
Definition: zwapi_util.h:717
VX_COLOR_INDEX98
@ VX_COLOR_INDEX98
R=0, G=76, B=0
Definition: zwapi_util.h:744
VX_COLOR_INDEX70
@ VX_COLOR_INDEX70
R=127, G=255, B=0
Definition: zwapi_util.h:716
VX_COLOR_INDEX38
@ VX_COLOR_INDEX38
R=76, G=38, B=0
Definition: zwapi_util.h:684
VX_COLOR_INDEX130
@ VX_COLOR_INDEX130
R=127, G=63, B=63, index color 17
Definition: zwapi_util.h:776
VX_COLOR_INDEX231
@ VX_COLOR_INDEX231
R=255, G=127, B=191.
Definition: zwapi_util.h:877
VX_COLOR_INDEX188
@ VX_COLOR_INDEX188
R=19, G=0, B=76
Definition: zwapi_util.h:834
VX_COLOR_INDEX93
@ VX_COLOR_INDEX93
R=102, G=204, B=102.
Definition: zwapi_util.h:739
VX_COLOR_INDEX103
@ VX_COLOR_INDEX103
R=102, G=204, B=127.
Definition: zwapi_util.h:749
VX_COLOR_INDEX213
@ VX_COLOR_INDEX213
R=204, G=102, B=204.
Definition: zwapi_util.h:859
VX_COLOR_INDEX235
@ VX_COLOR_INDEX235
R=153, G=76, B=114.
Definition: zwapi_util.h:881
VX_COLOR_INDEX94
@ VX_COLOR_INDEX94
R=0, G=153, B=0
Definition: zwapi_util.h:740
VX_COLOR_INDEX86
@ VX_COLOR_INDEX86
R=31, G=127, B=0
Definition: zwapi_util.h:732
VX_COLOR_INDEX236
@ VX_COLOR_INDEX236
R=127, G=0, B=63
Definition: zwapi_util.h:882
VX_COLOR_INDEX57
@ VX_COLOR_INDEX57
R=127, G=127, B=63
Definition: zwapi_util.h:703
VX_COLOR_INDEX173
@ VX_COLOR_INDEX173
R=102, G=102, B=204.
Definition: zwapi_util.h:819
VX_COLOR_INDEX137
@ VX_COLOR_INDEX137
R=63, G=127, B=127.
Definition: zwapi_util.h:783
VX_COLOR_INDEX203
@ VX_COLOR_INDEX203
R=178, G=102, B=204.
Definition: zwapi_util.h:849
VX_COLOR_INDEX45
@ VX_COLOR_INDEX45
R=153, G=133, B=76
Definition: zwapi_util.h:691
VX_COLOR_INDEX172
@ VX_COLOR_INDEX172
R=0, G=0, B=204.
Definition: zwapi_util.h:818
VX_COLOR_INDEX53
@ VX_COLOR_INDEX53
R=204, G=204, B=102.
Definition: zwapi_util.h:699
VX_COLOR_INDEX87
@ VX_COLOR_INDEX87
R=79, G=127, B=63
Definition: zwapi_util.h:733
VX_COLOR_INDEX34
@ VX_COLOR_INDEX34
R=153, G=76, B=0
Definition: zwapi_util.h:680
VX_COLOR_INDEX83
@ VX_COLOR_INDEX83
R=127, G=204, B=102.
Definition: zwapi_util.h:729
VX_COLOR_INDEX66
@ VX_COLOR_INDEX66
R=95, G=127, B=0
Definition: zwapi_util.h:712
VX_COLOR_INDEX214
@ VX_COLOR_INDEX214
R=153, G=0, B=153.
Definition: zwapi_util.h:860
VX_COLOR_INDEX80
@ VX_COLOR_INDEX80
R=63, G=255, B=0
Definition: zwapi_util.h:726
VX_COLOR_GOLDENROD
@ VX_COLOR_GOLDENROD
R=255, G=188, B=0.
Definition: zwapi_util.h:647
VX_COLOR_INDEX115
@ VX_COLOR_INDEX115
R=76, G=153, B=114.
Definition: zwapi_util.h:761
VX_COLOR_INDEX222
@ VX_COLOR_INDEX222
R=204, G=0, B=153.
Definition: zwapi_util.h:868
VX_COLOR_INDEX241
@ VX_COLOR_INDEX241
R=127, G=0, B=31, index color 246
Definition: zwapi_util.h:887
VX_COLOR_INDEX97
@ VX_COLOR_INDEX97
R=63, G=127, B=63
Definition: zwapi_util.h:743
VX_COLOR_VIOLET
@ VX_COLOR_VIOLET
R=140, G=140, B=235.
Definition: zwapi_util.h:652
VX_COLOR_INDEX28
@ VX_COLOR_INDEX28
R=76, G=19, B=0
Definition: zwapi_util.h:674
VX_COLOR_INDEX50
@ VX_COLOR_INDEX50
R=153, G=0, B=0, index color 14
Definition: zwapi_util.h:696
VX_COLOR_INDEX148
@ VX_COLOR_INDEX148
R=0, G=57, B=76
Definition: zwapi_util.h:794
VX_COLOR_INDEX232
@ VX_COLOR_INDEX232
R=204, G=0, B=102.
Definition: zwapi_util.h:878
VX_COLOR_INDEX164
@ VX_COLOR_INDEX164
R=0, G=38, B=153.
Definition: zwapi_util.h:810
VX_COLOR_INDEX239
@ VX_COLOR_INDEX239
R=76, G=38, B=57
Definition: zwapi_util.h:885
VX_COLOR_INDEX158
@ VX_COLOR_INDEX158
R=0, G=38, B=76
Definition: zwapi_util.h:804
VX_COLOR_INDEX152
@ VX_COLOR_INDEX152
R=0, G=102, B=204.
Definition: zwapi_util.h:798
VX_COLOR_INDEX182
@ VX_COLOR_INDEX182
R=51, G=0, B=204.
Definition: zwapi_util.h:828
VX_COLOR_INDEX215
@ VX_COLOR_INDEX215
R=153, G=76, B=153.
Definition: zwapi_util.h:861
VX_COLOR_INDEX233
@ VX_COLOR_INDEX233
R=204, G=102, B=153.
Definition: zwapi_util.h:879
VX_COLOR_INDEX194
@ VX_COLOR_INDEX194
R=76, G=0, B=153.
Definition: zwapi_util.h:840
VX_COLOR_INDEX202
@ VX_COLOR_INDEX202
R=153, G=0, B=204.
Definition: zwapi_util.h:848
VX_COLOR_DARK_BLUE
@ VX_COLOR_DARK_BLUE
R=0, G=0, B=255.
Definition: zwapi_util.h:651
VX_COLOR_PURPLE
@ VX_COLOR_PURPLE
R=102, G=0, B=153.
Definition: zwapi_util.h:662
VX_COLOR_INDEX44
@ VX_COLOR_INDEX44
R=204, G=102, B=102, index color 13.
Definition: zwapi_util.h:690
VX_COLOR_INDEX96
@ VX_COLOR_INDEX96
R=0, G=127, B=0
Definition: zwapi_util.h:742
VX_COLOR_INDEX157
@ VX_COLOR_INDEX157
R=63, G=95, B=127.
Definition: zwapi_util.h:803
VX_COLOR_INDEX178
@ VX_COLOR_INDEX178
R=0, G=0, B=76
Definition: zwapi_util.h:824
VX_COLOR_INDEX122
@ VX_COLOR_INDEX122
R=0, G=204, B=153.
Definition: zwapi_util.h:768
VX_COLOR_INDEX27
@ VX_COLOR_INDEX27
R=127, G=79, B=63
Definition: zwapi_util.h:673
VX_COLOR_INDEX59
@ VX_COLOR_INDEX59
R=76, G=76, B=38
Definition: zwapi_util.h:705
VX_COLOR_INDEX95
@ VX_COLOR_INDEX95
R=76, G=153, B=76
Definition: zwapi_util.h:741
VX_COLOR_INDEX85
@ VX_COLOR_INDEX85
R=95, G=153, B=76
Definition: zwapi_util.h:731
VX_COLOR_INDEX198
@ VX_COLOR_INDEX198
R=38, G=0, B=76
Definition: zwapi_util.h:844
VX_COLOR_INDEX207
@ VX_COLOR_INDEX207
R=204, G=102, B=127, index color 243.
Definition: zwapi_util.h:853
VX_COLOR_INDEX204
@ VX_COLOR_INDEX204
R=114, G=0, B=153.
Definition: zwapi_util.h:850
VX_COLOR_INDEX227
@ VX_COLOR_INDEX227
R=127, G=63, B=111.
Definition: zwapi_util.h:873
VX_COLOR_INDEX229
@ VX_COLOR_INDEX229
R=76, G=38, B=66
Definition: zwapi_util.h:875
VX_COLOR_INDEX126
@ VX_COLOR_INDEX126
R=0, G=127, B=95
Definition: zwapi_util.h:772
VX_COLOR_INDEX20
@ VX_COLOR_INDEX20
R=255, G=63, B=0
Definition: zwapi_util.h:666
VX_COLOR_INDEX184
@ VX_COLOR_INDEX184
R=38, G=0, B=153.
Definition: zwapi_util.h:830
VX_COLOR_INDEX183
@ VX_COLOR_INDEX183
R=127, G=102, B=204.
Definition: zwapi_util.h:829
VX_COLOR_INDEX104
@ VX_COLOR_INDEX104
R=0, G=153, B=38
Definition: zwapi_util.h:750
VX_COLOR_INDEX185
@ VX_COLOR_INDEX185
R=95, G=76, B=153.
Definition: zwapi_util.h:831
VX_COLOR_INDEX61
@ VX_COLOR_INDEX61
R=223, G=255, B=127.
Definition: zwapi_util.h:707
VX_COLOR_INDEX133
@ VX_COLOR_INDEX133
R=102, G=204, B=204.
Definition: zwapi_util.h:779
VX_COLOR_INDEX26
@ VX_COLOR_INDEX26
R=127, G=31, B=0
Definition: zwapi_util.h:672
VX_COLOR_INDEX219
@ VX_COLOR_INDEX219
R=76, G=38, B=76
Definition: zwapi_util.h:865
VX_COLOR_INDEX191
@ VX_COLOR_INDEX191
R=191, G=127, B=255.
Definition: zwapi_util.h:837
VX_COLOR_INDEX32
@ VX_COLOR_INDEX32
R=204, G=102, B=0
Definition: zwapi_util.h:678
VX_COLOR_INDEX123
@ VX_COLOR_INDEX123
R=102, G=204, B=178.
Definition: zwapi_util.h:769
VX_COLOR_INDEX127
@ VX_COLOR_INDEX127
R=63, G=127, B=111.
Definition: zwapi_util.h:773
VX_COLOR_INDEX140
@ VX_COLOR_INDEX140
R=0, G=191, B=255.
Definition: zwapi_util.h:786
VX_COLOR_INDEX177
@ VX_COLOR_INDEX177
R=63, G=63, B=127.
Definition: zwapi_util.h:823
VX_COLOR_INDEX200
@ VX_COLOR_INDEX200
R=191, G=0, B=255.
Definition: zwapi_util.h:846
VX_COLOR_INDEX74
@ VX_COLOR_INDEX74
R=76, G=153, B=0
Definition: zwapi_util.h:720
VX_COLOR_INDEX91
@ VX_COLOR_INDEX91
R=127, G=255, B=127.
Definition: zwapi_util.h:737
VX_COLOR_INDEX228
@ VX_COLOR_INDEX228
R=76, G=0, B=57
Definition: zwapi_util.h:874
VX_COLOR_INDEX154
@ VX_COLOR_INDEX154
R=0, G=76, B=153.
Definition: zwapi_util.h:800
VX_COLOR_INDEX181
@ VX_COLOR_INDEX181
R=159, G=127, B=255.
Definition: zwapi_util.h:827
VX_COLOR_INDEX101
@ VX_COLOR_INDEX101
R=127, G=255, B=159.
Definition: zwapi_util.h:747
VX_COLOR_INDEX58
@ VX_COLOR_INDEX58
R=76, G=76, B=0
Definition: zwapi_util.h:704
VX_COLOR_INDEX206
@ VX_COLOR_INDEX206
R=95, G=0, B=127.
Definition: zwapi_util.h:852
VX_COLOR_INDEX55
@ VX_COLOR_INDEX55
R=153, G=153, B=76
Definition: zwapi_util.h:701
VX_COLOR_INDEX29
@ VX_COLOR_INDEX29
R=76, G=47, B=38
Definition: zwapi_util.h:675
VX_COLOR_INDEX37
@ VX_COLOR_INDEX37
R=127, G=95, B=63
Definition: zwapi_util.h:683
VX_COLOR_INDEX143
@ VX_COLOR_INDEX143
R=102, G=178, B=204.
Definition: zwapi_util.h:789
VX_COLOR_INDEX242
@ VX_COLOR_INDEX242
R=127, G=63, B=79, index color 247
Definition: zwapi_util.h:888
VX_COLOR_INDEX138
@ VX_COLOR_INDEX138
R=0, G=76, B=76
Definition: zwapi_util.h:784
VX_COLOR_LIGHT_BLUE
@ VX_COLOR_LIGHT_BLUE
R=160, G=255, B=255.
Definition: zwapi_util.h:654
VX_COLOR_INDEX69
@ VX_COLOR_INDEX69
R=66, G=76, B=38
Definition: zwapi_util.h:715
VX_COLOR_INDEX145
@ VX_COLOR_INDEX145
R=76, G=133, B=153.
Definition: zwapi_util.h:791
VX_COLOR_INDEX136
@ VX_COLOR_INDEX136
R=0, G=127, B=127.
Definition: zwapi_util.h:782
VX_COLOR_INDEX107
@ VX_COLOR_INDEX107
R=63, G=127, B=79
Definition: zwapi_util.h:753
VX_COLOR_INDEX192
@ VX_COLOR_INDEX192
R=102, G=0, B=204.
Definition: zwapi_util.h:838
VX_COLOR_INDEX49
@ VX_COLOR_INDEX49
R=76, G=66, B=38
Definition: zwapi_util.h:695
VX_COLOR_INDEX46
@ VX_COLOR_INDEX46
R=127, G=95, B=0
Definition: zwapi_util.h:692
VX_COLOR_INDEX146
@ VX_COLOR_INDEX146
R=0, G=95, B=127.
Definition: zwapi_util.h:792
VX_COLOR_INDEX42
@ VX_COLOR_INDEX42
R=204, G=153, B=0
Definition: zwapi_util.h:688
VX_COLOR_INDEX144
@ VX_COLOR_INDEX144
R=0, G=114, B=153.
Definition: zwapi_util.h:790
VX_COLOR_MED_BLUE
@ VX_COLOR_MED_BLUE
R=0, G=255, B=255.
Definition: zwapi_util.h:648
VX_COLOR_RED
@ VX_COLOR_RED
R=255, G=0, B=0.
Definition: zwapi_util.h:645
VX_COLOR_INDEX150
@ VX_COLOR_INDEX150
R=0, G=127, B=255.
Definition: zwapi_util.h:796
VX_COLOR_INDEX189
@ VX_COLOR_INDEX189
R=47, G=38, B=76
Definition: zwapi_util.h:835
VX_COLOR_INDEX159
@ VX_COLOR_INDEX159
R=38, G=57, B=76
Definition: zwapi_util.h:805
VX_COLOR_INDEX197
@ VX_COLOR_INDEX197
R=95, G=63, B=127.
Definition: zwapi_util.h:843
VX_COLOR_INDEX65
@ VX_COLOR_INDEX65
R=133, G=153, B=76
Definition: zwapi_util.h:711
VX_COLOR_LIGHT_MAGENTA
@ VX_COLOR_LIGHT_MAGENTA
R=255, G=160, B=255.
Definition: zwapi_util.h:656
VX_COLOR_INDEX72
@ VX_COLOR_INDEX72
R=102, G=204, B=0
Definition: zwapi_util.h:718
VX_COLOR_INDEX21
@ VX_COLOR_INDEX21
R=255, G=127, B=127, index color 11.
Definition: zwapi_util.h:667
VX_COLOR_INDEX92
@ VX_COLOR_INDEX92
R=0, G=204, B=0
Definition: zwapi_util.h:738
VX_COLOR_INDEX199
@ VX_COLOR_INDEX199
R=57, G=38, B=76
Definition: zwapi_util.h:845
VX_COLOR_INDEX224
@ VX_COLOR_INDEX224
R=153, G=0, B=114.
Definition: zwapi_util.h:870
VX_COLOR_INDEX114
@ VX_COLOR_INDEX114
R=0, G=153, B=76
Definition: zwapi_util.h:760
VX_COLOR_INDEX208
@ VX_COLOR_INDEX208
R=57, G=0, B=76
Definition: zwapi_util.h:854
VX_COLOR_INDEX125
@ VX_COLOR_INDEX125
R=76, G=153, B=133.
Definition: zwapi_util.h:771
VX_COLOR_INDEX108
@ VX_COLOR_INDEX108
R=0, G=76, B=19
Definition: zwapi_util.h:754
VX_COLOR_INDEX119
@ VX_COLOR_INDEX119
R=38, G=76, B=57
Definition: zwapi_util.h:765
VX_COLOR_INDEX118
@ VX_COLOR_INDEX118
R=0, G=76, B=38
Definition: zwapi_util.h:764
VX_COLOR_INDEX212
@ VX_COLOR_INDEX212
R=204, G=0, B=204.
Definition: zwapi_util.h:858
VX_COLOR_INDEX134
@ VX_COLOR_INDEX134
R=0, G=153, B=153.
Definition: zwapi_util.h:780
VX_COLOR_INDEX35
@ VX_COLOR_INDEX35
R=153, G=114, B=76
Definition: zwapi_util.h:681
VX_COLOR_INDEX88
@ VX_COLOR_INDEX88
R=19, G=76, B=0
Definition: zwapi_util.h:734
VX_COLOR_INDEX225
@ VX_COLOR_INDEX225
R=153, G=76, B=133.
Definition: zwapi_util.h:871
VX_COLOR_INDEX82
@ VX_COLOR_INDEX82
R=51, G=204, B=0
Definition: zwapi_util.h:728
VX_COLOR_INDEX220
@ VX_COLOR_INDEX220
R=255, G=0, B=191.
Definition: zwapi_util.h:866
VX_COLOR_INDEX99
@ VX_COLOR_INDEX99
R=38, G=76, B=38
Definition: zwapi_util.h:745
VX_COLOR_INDEX167
@ VX_COLOR_INDEX167
R=63, G=79, B=127.
Definition: zwapi_util.h:813
VX_COLOR_INDEX216
@ VX_COLOR_INDEX216
R=127, G=0, B=127.
Definition: zwapi_util.h:862
VX_COLOR_INDEX25
@ VX_COLOR_INDEX25
R=153, G=95, B=76
Definition: zwapi_util.h:671
VX_COLOR_INDEX73
@ VX_COLOR_INDEX73
R=153, G=204, B=102.
Definition: zwapi_util.h:719
VX_COLOR_GREEN
@ VX_COLOR_GREEN
R=0, G=255, B=0.
Definition: zwapi_util.h:644
VX_COLOR_INDEX40
@ VX_COLOR_INDEX40
R=204, G=0, B=0, index color 12
Definition: zwapi_util.h:686
VX_COLOR_INDEX52
@ VX_COLOR_INDEX52
R=204, G=204, B=0
Definition: zwapi_util.h:698
VX_COLOR_WHITE
@ VX_COLOR_WHITE
R=255, G=255, B=255.
Definition: zwapi_util.h:658
VX_COLOR_INDEX23
@ VX_COLOR_INDEX23
R=204, G=127, B=102.
Definition: zwapi_util.h:669
VX_COLOR_INDEX156
@ VX_COLOR_INDEX156
R=0, G=63, B=127.
Definition: zwapi_util.h:802
VX_COLOR_INDEX217
@ VX_COLOR_INDEX217
R=127, G=63, B=127.
Definition: zwapi_util.h:863
VX_COLOR_INDEX84
@ VX_COLOR_INDEX84
R=38, G=153, B=0
Definition: zwapi_util.h:730
VX_COLOR_INDEX135
@ VX_COLOR_INDEX135
R=76, G=153, B=153.
Definition: zwapi_util.h:781
VX_COLOR_INDEX48
@ VX_COLOR_INDEX48
R=76, G=57, B=0
Definition: zwapi_util.h:694
VX_COLOR_INDEX155
@ VX_COLOR_INDEX155
R=76, G=114, B=153.
Definition: zwapi_util.h:801
VX_COLOR_INDEX111
@ VX_COLOR_INDEX111
R=127, G=255, B=191.
Definition: zwapi_util.h:757
VX_COLOR_INDEX141
@ VX_COLOR_INDEX141
R=127, G=223, B=255.
Definition: zwapi_util.h:787
VX_COLOR_INDEX171
@ VX_COLOR_INDEX171
R=204, G=0, B=51, index color 242
Definition: zwapi_util.h:817
VX_COLOR_INDEX175
@ VX_COLOR_INDEX175
R=76, G=76, B=153.
Definition: zwapi_util.h:821
VX_COLOR_YELLOW
@ VX_COLOR_YELLOW
R=255, G=255, B=0.
Definition: zwapi_util.h:660
VX_COLOR_DARK_GREY
@ VX_COLOR_DARK_GREY
R=96, G=96, B=96.
Definition: zwapi_util.h:650
VX_COLOR_INDEX211
@ VX_COLOR_INDEX211
R=153, G=76, B=95, index color 245
Definition: zwapi_util.h:857
VX_COLOR_INDEX124
@ VX_COLOR_INDEX124
R=0, G=153, B=114.
Definition: zwapi_util.h:770
VX_COLOR_INDEX210
@ VX_COLOR_INDEX210
R=153, G=0, B=38, index color 244
Definition: zwapi_util.h:856
VX_COLOR_INDEX121
@ VX_COLOR_INDEX121
R=127, G=255, B=223.
Definition: zwapi_util.h:767
VX_COLOR_DARK_MAGENTA
@ VX_COLOR_DARK_MAGENTA
R=255, G=0, B=255.
Definition: zwapi_util.h:649
VX_COLOR_INDEX165
@ VX_COLOR_INDEX165
R=76, G=95, B=153.
Definition: zwapi_util.h:811
VX_COLOR_INDEX149
@ VX_COLOR_INDEX149
R=38, G=66, B=76
Definition: zwapi_util.h:795
VX_COLOR_INDEX209
@ VX_COLOR_INDEX209
R=66, G=38, B=76
Definition: zwapi_util.h:855
VX_COLOR_INDEX116
@ VX_COLOR_INDEX116
R=0, G=127, B=63
Definition: zwapi_util.h:762
VX_COLOR_INDEX47
@ VX_COLOR_INDEX47
R=127, G=111, B=63
Definition: zwapi_util.h:693
VX_COLOR_INDEX234
@ VX_COLOR_INDEX234
R=153, G=0, B=76
Definition: zwapi_util.h:880
VX_COLOR_INDEX243
@ VX_COLOR_INDEX243
R=76, G=0, B=19, index color 248
Definition: zwapi_util.h:889
VX_COLOR_INDEX174
@ VX_COLOR_INDEX174
R=0, G=0, B=153.
Definition: zwapi_util.h:820
VX_COLOR_INDEX112
@ VX_COLOR_INDEX112
R=0, G=204, B=102.
Definition: zwapi_util.h:758
VX_COLOR_INDEX244
@ VX_COLOR_INDEX244
R=76, G=38, B=47, index color 249
Definition: zwapi_util.h:890
VX_COLOR_INDEX221
@ VX_COLOR_INDEX221
R=255, G=127, B=223.
Definition: zwapi_util.h:867
VX_COLOR_INDEX90
@ VX_COLOR_INDEX90
R=127, G=0, B=0, index color 16
Definition: zwapi_util.h:736
VX_COLOR_INDEX160
@ VX_COLOR_INDEX160
R=0, G=63, B=255.
Definition: zwapi_util.h:806
VX_COLOR_INDEX30
@ VX_COLOR_INDEX30
R=255, G=127, B=0
Definition: zwapi_util.h:676
VX_COLOR_INDEX139
@ VX_COLOR_INDEX139
R=38, G=76, B=76
Definition: zwapi_util.h:785
VX_COLOR_INDEX60
@ VX_COLOR_INDEX60
R=191, G=255, B=0
Definition: zwapi_util.h:706
VX_COLOR_INDEX196
@ VX_COLOR_INDEX196
R=63, G=0, B=127.
Definition: zwapi_util.h:842
VX_COLOR_INDEX64
@ VX_COLOR_INDEX64
R=114, G=153, B=0
Definition: zwapi_util.h:710
VX_COLOR_BLACK
@ VX_COLOR_BLACK
R=0, G=0, B=0.
Definition: zwapi_util.h:659
VX_COLOR_INDEX102
@ VX_COLOR_INDEX102
R=0, G=204, B=51
Definition: zwapi_util.h:748
VX_COLOR_INDEX100
@ VX_COLOR_INDEX100
R=0, G=255, B=63
Definition: zwapi_util.h:746
VX_COLOR_INDEX75
@ VX_COLOR_INDEX75
R=114, G=153, B=76
Definition: zwapi_util.h:721
VX_COLOR_INDEX110
@ VX_COLOR_INDEX110
R=0, G=255, B=127.
Definition: zwapi_util.h:756
VX_COLOR_INDEX43
@ VX_COLOR_INDEX43
R=204, G=178, B=102.
Definition: zwapi_util.h:689
VX_COLOR_INDEX193
@ VX_COLOR_INDEX193
R=153, G=102, B=204.
Definition: zwapi_util.h:839
VX_COLOR_INDEX79
@ VX_COLOR_INDEX79
R=57, G=76, B=38
Definition: zwapi_util.h:725
VX_COLOR_INDEX105
@ VX_COLOR_INDEX105
R=76, G=153, B=95
Definition: zwapi_util.h:751
VX_COLOR_INDEX24
@ VX_COLOR_INDEX24
R=153, G=38, B=0
Definition: zwapi_util.h:670
VX_COLOR_INDEX237
@ VX_COLOR_INDEX237
R=127, G=63, B=95
Definition: zwapi_util.h:883
VX_COLOR_MED_GREY
@ VX_COLOR_MED_GREY
R=135, G=160, B=130.
Definition: zwapi_util.h:661
VX_COLOR_INDEX187
@ VX_COLOR_INDEX187
R=79, G=63, B=127.
Definition: zwapi_util.h:833
VX_COLOR_INDEX22
@ VX_COLOR_INDEX22
R=204, G=51, B=0
Definition: zwapi_util.h:668
VX_COLOR_INDEX51
@ VX_COLOR_INDEX51
R=255, G=255, B=127.
Definition: zwapi_util.h:697
VX_COLOR_INDEX106
@ VX_COLOR_INDEX106
R=0, G=127, B=31
Definition: zwapi_util.h:752
VX_COLOR_INDEX201
@ VX_COLOR_INDEX201
R=223, G=127, B=255.
Definition: zwapi_util.h:847
VX_COLOR_INDEX109
@ VX_COLOR_INDEX109
R=38, G=76, B=47
Definition: zwapi_util.h:755
VX_COLOR_INDEX151
@ VX_COLOR_INDEX151
R=127, G=191, B=255.
Definition: zwapi_util.h:797
VX_COLOR_INDEX218
@ VX_COLOR_INDEX218
R=76, G=0, B=76
Definition: zwapi_util.h:864
VX_COLOR_INDEX179
@ VX_COLOR_INDEX179
R=38, G=38, B=76
Definition: zwapi_util.h:825
VX_COLOR_INDEX78
@ VX_COLOR_INDEX78
R=38, G=76, B=0
Definition: zwapi_util.h:724
VX_COLOR_INDEX67
@ VX_COLOR_INDEX67
R=111, G=127, B=63
Definition: zwapi_util.h:713
VX_COLOR_INDEX81
@ VX_COLOR_INDEX81
R=153, G=76, B=76, index color 15
Definition: zwapi_util.h:727
VX_COLOR_ROSE
@ VX_COLOR_ROSE
R=255, G=160, B=160.
Definition: zwapi_util.h:655
VX_COLOR_INDEX77
@ VX_COLOR_INDEX77
R=95, G=127, B=63
Definition: zwapi_util.h:723
VX_COLOR_INDEX163
@ VX_COLOR_INDEX163
R=102, G=127, B=204.
Definition: zwapi_util.h:809
VX_COLOR_INDEX120
@ VX_COLOR_INDEX120
R=0, G=255, B=191.
Definition: zwapi_util.h:766
VX_COLOR_INDEX205
@ VX_COLOR_INDEX205
R=133, G=76, B=153.
Definition: zwapi_util.h:851
VX_COLOR_INDEX68
@ VX_COLOR_INDEX68
R=57, G=76, B=0
Definition: zwapi_util.h:714
VX_COLOR_INDEX31
@ VX_COLOR_INDEX31
R=255, G=191, B=127.
Definition: zwapi_util.h:677
VX_COLOR_INDEX168
@ VX_COLOR_INDEX168
R=0, G=19, B=76
Definition: zwapi_util.h:814
VX_COLOR_LIGHT_GREY
@ VX_COLOR_LIGHT_GREY
R=160, G=160, B=160.
Definition: zwapi_util.h:657
VX_COLOR_INDEX128
@ VX_COLOR_INDEX128
R=0, G=76, B=57
Definition: zwapi_util.h:774
VX_COLOR_INDEX223
@ VX_COLOR_INDEX223
R=204, G=102, B=178.
Definition: zwapi_util.h:869
VX_COLOR_LIGHT_GREEN
@ VX_COLOR_LIGHT_GREEN
R=160, G=255, B=160.
Definition: zwapi_util.h:653
VX_COLOR_INDEX33
@ VX_COLOR_INDEX33
R=204, G=153, B=102.
Definition: zwapi_util.h:679
VX_COLOR_INDEX62
@ VX_COLOR_INDEX62
R=153, G=204, B=0
Definition: zwapi_util.h:708
VX_COLOR_INDEX176
@ VX_COLOR_INDEX176
R=0, G=0, B=127.
Definition: zwapi_util.h:822
VX_COLOR_INDEX162
@ VX_COLOR_INDEX162
R=0, G=51, B=204.
Definition: zwapi_util.h:808
VX_COLOR_INDEX142
@ VX_COLOR_INDEX142
R=0, G=153, B=204.
Definition: zwapi_util.h:788
VX_COLOR_INDEX180
@ VX_COLOR_INDEX180
R=63, G=0, B=255.
Definition: zwapi_util.h:826
VX_COLOR_INDEX36
@ VX_COLOR_INDEX36
R=127, G=63, B=0
Definition: zwapi_util.h:682
VX_COLOR_INDEX54
@ VX_COLOR_INDEX54
R=153, G=153, B=0
Definition: zwapi_util.h:700
VX_COLOR_INDEX129
@ VX_COLOR_INDEX129
R=38, G=76, B=66
Definition: zwapi_util.h:775
VX_COLOR_INDEX113
@ VX_COLOR_INDEX113
R=102, G=204, B=153.
Definition: zwapi_util.h:759
VX_COLOR_INDEX147
@ VX_COLOR_INDEX147
R=63, G=111, B=127.
Definition: zwapi_util.h:793
VX_COLOR_INDEX166
@ VX_COLOR_INDEX166
R=0, G=31, B=127.
Definition: zwapi_util.h:812
VX_COLOR_INDEX76
@ VX_COLOR_INDEX76
R=63, G=127, B=0
Definition: zwapi_util.h:722
VX_COLOR_INDEX230
@ VX_COLOR_INDEX230
R=255, G=0, B=127.
Definition: zwapi_util.h:876
VX_COLOR_INDEX190
@ VX_COLOR_INDEX190
R=127, G=0, B=255.
Definition: zwapi_util.h:836
VX_COLOR_INDEX89
@ VX_COLOR_INDEX89
R=47, G=76, B=28
Definition: zwapi_util.h:735
VX_COLOR_INDEX170
@ VX_COLOR_INDEX170
R=255, G=127, B=159, index color 241.
Definition: zwapi_util.h:816
VX_COLOR_INDEX63
@ VX_COLOR_INDEX63
R=178, G=204, B=102.
Definition: zwapi_util.h:709
VX_COLOR_INDEX56
@ VX_COLOR_INDEX56
R=127, G=127, B=0
Definition: zwapi_util.h:702
VX_COLOR_INDEX238
@ VX_COLOR_INDEX238
R=76, G=0, B=38
Definition: zwapi_util.h:884
VX_COLOR_INDEX169
@ VX_COLOR_INDEX169
R=38, G=47, B=76
Definition: zwapi_util.h:815
VX_COLOR_INDEX186
@ VX_COLOR_INDEX186
R=31, G=0, B=127.
Definition: zwapi_util.h:832
VX_COLOR_INDEX132
@ VX_COLOR_INDEX132
R=0, G=204, B=204.
Definition: zwapi_util.h:778
VX_COLOR_INDEX153
@ VX_COLOR_INDEX153
R=102, G=153, B=204.
Definition: zwapi_util.h:799
VX_COLOR_INDEX161
@ VX_COLOR_INDEX161
R=127, G=159, B=255.
Definition: zwapi_util.h:807
VX_COLOR_INDEX117
@ VX_COLOR_INDEX117
R=63, G=127, B=95
Definition: zwapi_util.h:763
VX_COLOR_INDEX195
@ VX_COLOR_INDEX195
R=114, G=76, B=153.
Definition: zwapi_util.h:841
VX_COLOR_INDEX41
@ VX_COLOR_INDEX41
R=255, G=223, B=127.
Definition: zwapi_util.h:687
VX_COLOR_INDEX131
@ VX_COLOR_INDEX131
R=76, G=38, B=38, index color 19
Definition: zwapi_util.h:777
evxMassMomentUnitType
evxMassMomentUnitType
system of mass moment units
Definition: zwapi_util.h:432
VX_UNIT_MASSMOMENT_OZFT2
@ VX_UNIT_MASSMOMENT_OZFT2
oz.ft2
Definition: zwapi_util.h:441
VX_UNIT_MASSMOMENT_OZIN2
@ VX_UNIT_MASSMOMENT_OZIN2
oz.in2
Definition: zwapi_util.h:440
VX_UNIT_MASSMOMENT_GMM2
@ VX_UNIT_MASSMOMENT_GMM2
g.mm2
Definition: zwapi_util.h:435
VX_UNIT_MASSMOMENT_GDM2
@ VX_UNIT_MASSMOMENT_GDM2
g.dm2
Definition: zwapi_util.h:444
VX_UNIT_MASSMOMENT_KGDM2
@ VX_UNIT_MASSMOMENT_KGDM2
kg.dm2
Definition: zwapi_util.h:443
VX_UNIT_MASSMOMENT_OZYD2
@ VX_UNIT_MASSMOMENT_OZYD2
oz.yd2
Definition: zwapi_util.h:442
VX_UNIT_MASSMOMENT_KGMM2
@ VX_UNIT_MASSMOMENT_KGMM2
kg.mm2
Definition: zwapi_util.h:433
VX_UNIT_MASSMOMENT_LBIN2
@ VX_UNIT_MASSMOMENT_LBIN2
lb.in2
Definition: zwapi_util.h:437
VX_UNIT_MASSMOMENT_LBFT2
@ VX_UNIT_MASSMOMENT_LBFT2
lb.ft2
Definition: zwapi_util.h:438
VX_UNIT_MASSMOMENT_GCM2
@ VX_UNIT_MASSMOMENT_GCM2
g.cm2
Definition: zwapi_util.h:436
VX_UNIT_MASSMOMENT_KGM2
@ VX_UNIT_MASSMOMENT_KGM2
kg.m2
Definition: zwapi_util.h:434
VX_UNIT_MASSMOMENT_LBYD2
@ VX_UNIT_MASSMOMENT_LBYD2
lb.yd2
Definition: zwapi_util.h:439
evxEulerAngSeq
evxEulerAngSeq
Two categories of rotation sequences for Euler angles: Proper Type and Tait-Byran Type.
Definition: zwapi_util.h:505
VX_XZX
@ VX_XZX
X-axis, Z-axis, X-axis.
Definition: zwapi_util.h:510
VX_XYX
@ VX_XYX
X-axis, Y-axis, X-axis.
Definition: zwapi_util.h:509
VX_YXY
@ VX_YXY
Y-axis, X-axis, Y-axis.
Definition: zwapi_util.h:511
VX_YRP
@ VX_YRP
Z-axis (Yaw), X-axis (Roll), Y-axis (Pitch)
Definition: zwapi_util.h:522
VX_RYP
@ VX_RYP
X-axis (Roll), Z-axis (Yaw), Y-axis (Pitch)
Definition: zwapi_util.h:519
VX_PRY
@ VX_PRY
Y-axis (Pitch), X-axis (Roll), Z-axis (Yaw)
Definition: zwapi_util.h:520
VX_RPY
@ VX_RPY
X-axis (Roll), Y-axis (Pitch), Z-axis (Yaw)
Definition: zwapi_util.h:518
VX_ZYZ
@ VX_ZYZ
Z-axis, Y-axis, Z-axis.
Definition: zwapi_util.h:514
VX_YZY
@ VX_YZY
Y-axis, Z-axis, Y-axis.
Definition: zwapi_util.h:512
VX_PYR
@ VX_PYR
Y-axis (Pitch), Z-axis (Yaw), X-axis (Roll)
Definition: zwapi_util.h:521
VX_ZXZ
@ VX_ZXZ
Z-axis, X-axis, Z-axis.
Definition: zwapi_util.h:513
VX_YPR
@ VX_YPR
Z-axis (Yaw), Y-axis (Pitch), X-axis (Roll)
Definition: zwapi_util.h:523
evxLineWidth
evxLineWidth
line width
Definition: zwapi_util.h:1434
VX_WIDTH_018
@ VX_WIDTH_018
0.18 mm
Definition: zwapi_util.h:1436
VX_WIDTH_035
@ VX_WIDTH_035
0.35 mm
Definition: zwapi_util.h:1438
VX_WIDTH_050
@ VX_WIDTH_050
0.50 mm
Definition: zwapi_util.h:1439
VX_WIDTH_BYLAYER
@ VX_WIDTH_BYLAYER
by layer
Definition: zwapi_util.h:1443
VX_WIDTH_070
@ VX_WIDTH_070
0.70 mm
Definition: zwapi_util.h:1440
VX_WIDTH_UNDEFINED
@ VX_WIDTH_UNDEFINED
undefined
Definition: zwapi_util.h:1435
VX_WIDTH_025
@ VX_WIDTH_025
0.25 mm
Definition: zwapi_util.h:1437
VX_WIDTH_100
@ VX_WIDTH_100
1.00 mm
Definition: zwapi_util.h:1441
evxContinuityTyp
evxContinuityTyp
Continuity option.
Definition: zwapi_util.h:2355
VX_CONTIN_G1
@ VX_CONTIN_G1
tangent
Definition: zwapi_util.h:2357
VX_CONTIN_NONE
@ VX_CONTIN_NONE
none
Definition: zwapi_util.h:2356
VX_CONTIN_G3
@ VX_CONTIN_G3
flow
Definition: zwapi_util.h:2359
VX_CONTIN_G2
@ VX_CONTIN_G2
curvature
Definition: zwapi_util.h:2358
evxSurfaceType
evxSurfaceType
surface types
Definition: zwapi_util.h:1699
evxAxisType
evxAxisType
type of axis
Definition: zwapi_util.h:359
VX_AXIS_Z
@ VX_AXIS_Z
z axis
Definition: zwapi_util.h:362
VX_AXIS_Y
@ VX_AXIS_Y
y axis
Definition: zwapi_util.h:361
VX_AXIS_X
@ VX_AXIS_X
x axis
Definition: zwapi_util.h:360
evxHoleDimDataItem
evxHoleDimDataItem
data sub-items of hole dimension
Definition: zwapi_util.h:2214
VX_HOLE_DIM_ITEM_THRD_DIA
@ VX_HOLE_DIM_ITEM_THRD_DIA
hole thread diameter: <H_TD>
Definition: zwapi_util.h:2223
VX_HOLE_DIM_ITEM_THRD_DPTH
@ VX_HOLE_DIM_ITEM_THRD_DPTH
hole thread depth: <H_TH>
Definition: zwapi_util.h:2224
VX_HOLE_DIM_ITEM_DPTH2
@ VX_HOLE_DIM_ITEM_DPTH2
hole depth H2: <H_H2>
Definition: zwapi_util.h:2221
VX_HOLE_DIM_ITEM_ORG
@ VX_HOLE_DIM_ITEM_ORG
original variable string
Definition: zwapi_util.h:2215
VX_HOLE_DIM_THRD_STD
@ VX_HOLE_DIM_THRD_STD
hole thread: <H_TS>
Definition: zwapi_util.h:2226
VX_HOLE_DIM_ITEM_QTY
@ VX_HOLE_DIM_ITEM_QTY
number of same holes: <H_Q>
Definition: zwapi_util.h:2216
VX_HOLE_DIM_THRD_SIZ
@ VX_HOLE_DIM_THRD_SIZ
hole thread size without pitch: <H_TZ>
Definition: zwapi_util.h:2227
VX_HOLE_DIM_ITEM_DIA
@ VX_HOLE_DIM_ITEM_DIA
hole diameter D1: <H_D1>
Definition: zwapi_util.h:2217
VX_HOLE_DIM_ITEM_DIA2
@ VX_HOLE_DIM_ITEM_DIA2
hole diameter D2: <H_D2>
Definition: zwapi_util.h:2218
VX_HOLE_DIM_ITEM_LABEL
@ VX_HOLE_DIM_ITEM_LABEL
hole label: <H_L>
Definition: zwapi_util.h:2219
VX_HOLE_DIM_ITEM_ANG
@ VX_HOLE_DIM_ITEM_ANG
hole angle: <H_A>
Definition: zwapi_util.h:2222
VX_HOLE_DIM_ITEM_DPTH
@ VX_HOLE_DIM_ITEM_DPTH
hole depth H1: <H_H1>
Definition: zwapi_util.h:2220
VX_HOLE_DIM_ITEM_PITCH
@ VX_HOLE_DIM_ITEM_PITCH
hole thread pitch: <H_TP>
Definition: zwapi_util.h:2225
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
ZW_API_CAM_GETHOLDER_ERROR
@ ZW_API_CAM_GETHOLDER_ERROR
fail to get tool holder index
Definition: zwapi_util.h:149
ZW_API_CAM_GUIFROMTXT_ERROR
@ ZW_API_CAM_GUIFROMTXT_ERROR
fail to interface parameter get from data base
Definition: zwapi_util.h:177
ZW_API_CAM_GETOPERATION_ERROR
@ ZW_API_CAM_GETOPERATION_ERROR
fail to get operation in cam plan
Definition: zwapi_util.h:118
ZW_API_CAM_OUTCL_ERROR
@ ZW_API_CAM_OUTCL_ERROR
fail to output cl
Definition: zwapi_util.h:168
ZW_API_FILE_ERROR
@ ZW_API_FILE_ERROR
the specified file does not exist in memory
Definition: zwapi_util.h:59
ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
@ ZW_API_ROOT_SINGLE_MULTI_TYPE_ERROR
wrong file type. either the file is single-object where a multi-object file is required,...
Definition: zwapi_util.h:47
ZW_API_FUNCTION_CB_GET_ERROR
@ ZW_API_FUNCTION_CB_GET_ERROR
Failed to get callback function.
Definition: zwapi_util.h:110
ZW_API_ENT_PATH_ERROR
@ ZW_API_ENT_PATH_ERROR
wrong entity pick path
Definition: zwapi_util.h:68
ZW_API_CAM_OUTTOOL_ERROR
@ ZW_API_CAM_OUTTOOL_ERROR
fail to output tool list
Definition: zwapi_util.h:173
ZW_API_GENERAL_ERROR
@ ZW_API_GENERAL_ERROR
general error
Definition: zwapi_util.h:42
ZW_API_CAM_GETCOMPCLASS_ERROR
@ ZW_API_CAM_GETCOMPCLASS_ERROR
fail to get component class
Definition: zwapi_util.h:158
ZW_API_NAME_LEN_OVER_RANGE
@ ZW_API_NAME_LEN_OVER_RANGE
the file name length is over range
Definition: zwapi_util.h:92
ZW_API_CAM_GETTPATHINFO_ERROR
@ ZW_API_CAM_GETTPATHINFO_ERROR
fail to get tool path information
Definition: zwapi_util.h:187
ZW_API_INVALID_STRING
@ ZW_API_INVALID_STRING
the string is empty
Definition: zwapi_util.h:90
ZW_API_CAM_GETOUT_ERROR
@ ZW_API_CAM_GETOUT_ERROR
fail to get output in cam plan
Definition: zwapi_util.h:167
ZW_API_CAM_GETFTRDBNAME_ERROR
@ ZW_API_CAM_GETFTRDBNAME_ERROR
fail to get ftr db name
Definition: zwapi_util.h:131
ZW_API_WRONG_ROOT_ENV
@ ZW_API_WRONG_ROOT_ENV
wrong type for the active root object (the root need to be part/sketch/drawing/cam,...
Definition: zwapi_util.h:46
ZW_API_CAM_GETOPBYTAC_ERROR
@ ZW_API_CAM_GETOPBYTAC_ERROR
fail to get operation in tactic
Definition: zwapi_util.h:117
ZW_API_OUT_OF_RANGE
@ ZW_API_OUT_OF_RANGE
out of the memory range
Definition: zwapi_util.h:81
ZW_API_INVALID_OBJ
@ ZW_API_INVALID_OBJ
the specified object can't be find in the current environment or inactive
Definition: zwapi_util.h:65
ZW_API_CAM_GETMACHNAME_ERROR
@ ZW_API_CAM_GETMACHNAME_ERROR
fail to get machine name in cam plan
Definition: zwapi_util.h:139
ZW_API_INVALID_ENT_PATH
@ ZW_API_INVALID_ENT_PATH
invalid entity pick path
Definition: zwapi_util.h:69
ZW_API_CAM_GETSPDFD_ERROR
@ ZW_API_CAM_GETSPDFD_ERROR
fail to get speed and feed
Definition: zwapi_util.h:190
ZW_API_CAM_OUTOPHTML_ERROR
@ ZW_API_CAM_OUTOPHTML_ERROR
fail to output html type operation list
Definition: zwapi_util.h:171
ZW_API_PATH_LEN_LESS_RANGE
@ ZW_API_PATH_LEN_LESS_RANGE
the file path length is less 512 bytes
Definition: zwapi_util.h:93
ZW_API_CAM_OUTNC_ERROR
@ ZW_API_CAM_OUTNC_ERROR
fail to output nc
Definition: zwapi_util.h:169
ZW_API_FILE_LOCATE_FAIL
@ ZW_API_FILE_LOCATE_FAIL
fail to locate the specified file. an error occurred when the file can't be found in the search path,...
Definition: zwapi_util.h:58
ZW_API_FUCNTION_CB_EXECUTION_ERROR
@ ZW_API_FUCNTION_CB_EXECUTION_ERROR
callback function execution failed
Definition: zwapi_util.h:112
ZW_API_ROOT_ERROR
@ ZW_API_ROOT_ERROR
the specified root can't be found
Definition: zwapi_util.h:49
ZW_API_NO_ERROR
@ ZW_API_NO_ERROR
no error
Definition: zwapi_util.h:37
ZW_API_CAM_GETMACH_ERROR
@ ZW_API_CAM_GETMACH_ERROR
fail to get machine in cam plan
Definition: zwapi_util.h:138
ZW_API_CAM_UPVADTA_ERROR
@ ZW_API_CAM_UPVADTA_ERROR
fail to update cam info
Definition: zwapi_util.h:123
ZW_API_ROOT_OBJ_ACT_FAIL
@ ZW_API_ROOT_OBJ_ACT_FAIL
could not activate the current root object
Definition: zwapi_util.h:45
ZW_API_CAM_GETCOMPVDATA_ERROR
@ ZW_API_CAM_GETCOMPVDATA_ERROR
fail to get component database
Definition: zwapi_util.h:160
ZW_API_CAM_GETTOOL_ERROR
@ ZW_API_CAM_GETTOOL_ERROR
fail to get tool in cam plan
Definition: zwapi_util.h:147
ZW_API_CAM_GETSETUP_ERROR
@ ZW_API_CAM_GETSETUP_ERROR
fail to get setup in cam plan
Definition: zwapi_util.h:135
ZW_API_CAM_OPTYPE_ERROR
@ ZW_API_CAM_OPTYPE_ERROR
wrong operation type
Definition: zwapi_util.h:115
ZW_API_FUCNTION_CB_EXIST_ERROR
@ ZW_API_FUCNTION_CB_EXIST_ERROR
callback doesn't exist
Definition: zwapi_util.h:111
ZW_API_CAM_GETCOMPINDEX_ERROR
@ ZW_API_CAM_GETCOMPINDEX_ERROR
fail to get component index
Definition: zwapi_util.h:159
ZW_API_FUN_UNLOAD_ERROR
@ ZW_API_FUN_UNLOAD_ERROR
function hasn't been registered and unload failed
Definition: zwapi_util.h:77
ZW_API_TABLE_SETDATA_ERROR
@ ZW_API_TABLE_SETDATA_ERROR
fail to set table info
Definition: zwapi_util.h:103
ZW_API_CAM_GETTOOLTYPE_ERROR
@ ZW_API_CAM_GETTOOLTYPE_ERROR
fail to get tool type
Definition: zwapi_util.h:150
ZW_API_CAM_GETTACNAME_ERROR
@ ZW_API_CAM_GETTACNAME_ERROR
fail to get tactic name
Definition: zwapi_util.h:126
ZW_API_CAM_GETTOOLNAME_ERROR
@ ZW_API_CAM_GETTOOLNAME_ERROR
fail to get tool name in cam plan
Definition: zwapi_util.h:148
ZW_API_INVALID_PATH
@ ZW_API_INVALID_PATH
invalid file path
Definition: zwapi_util.h:89
ZW_API_CAM_GETTACTIC_ERROR
@ ZW_API_CAM_GETTACTIC_ERROR
fail to get tactic in cam plan
Definition: zwapi_util.h:127
ZW_API_MEMORY_ERROR
@ ZW_API_MEMORY_ERROR
memory error. an error occurred while allocating memory
Definition: zwapi_util.h:80
ZW_API_OBJ_DATA_GET_ERROR
@ ZW_API_OBJ_DATA_GET_ERROR
wrong data of the object(fail to get the specified type data of the object, such as the parent featur...
Definition: zwapi_util.h:63
ZW_API_INPUT_ERROR
@ ZW_API_INPUT_ERROR
input error, an error occurred while preparing input data for zw3d command (cvxDataSet).
Definition: zwapi_util.h:53
ZW_API_CAM_GETFTR_ERROR
@ ZW_API_CAM_GETFTR_ERROR
fail to get feature in cam plan
Definition: zwapi_util.h:132
ZW_API_CAM_GETFOLDERNAME_ERROR
@ ZW_API_CAM_GETFOLDERNAME_ERROR
fail to get folder name
Definition: zwapi_util.h:143
ZW_API_TABLE_GETDATA_ERROR
@ ZW_API_TABLE_GETDATA_ERROR
fail to get table info
Definition: zwapi_util.h:104
ZW_API_CAM_GETFOLDER_ERROR
@ ZW_API_CAM_GETFOLDER_ERROR
fail to get folder in cam plan
Definition: zwapi_util.h:142
ZW_API_CAM_GETACTFRAME_ERROR
@ ZW_API_CAM_GETACTFRAME_ERROR
fail to get active frame
Definition: zwapi_util.h:164
ZW_API_FORM_EXIST_ERROR
@ ZW_API_FORM_EXIST_ERROR
form doesn't exist
Definition: zwapi_util.h:99
ZW_API_CAM_GETTOOLID_ERROR
@ ZW_API_CAM_GETTOOLID_ERROR
fail to get tool id
Definition: zwapi_util.h:152
ZW_API_CAM_OUTOPLIST_ERROR
@ ZW_API_CAM_OUTOPLIST_ERROR
fail to output excel type operation list
Definition: zwapi_util.h:170
ZW_API_CAM_FORMDEFINE_ERROR
@ ZW_API_CAM_FORMDEFINE_ERROR
fail to define a cam form
Definition: zwapi_util.h:181
ZW_API_INPUT_TYPE_ERROR
@ ZW_API_INPUT_TYPE_ERROR
the the input object doesn't match the required one
Definition: zwapi_util.h:54
ZW_API_CAM_GETFTRGRP_ERROR
@ ZW_API_CAM_GETFTRGRP_ERROR
fail to get feature group data
Definition: zwapi_util.h:130
ZW_API_MODELING_DATA_ERROR
@ ZW_API_MODELING_DATA_ERROR
geometric modeling data error
Definition: zwapi_util.h:84
ZW_API_CAM_GETTOOLSUBTYPE_ERROR
@ ZW_API_CAM_GETTOOLSUBTYPE_ERROR
fail to get tool sub type
Definition: zwapi_util.h:151
ZW_API_OBJ_DATA_SET_ERROR
@ ZW_API_OBJ_DATA_SET_ERROR
fail to set the specified type data of the object, such as the specified attribute of the shape etc.
Definition: zwapi_util.h:64
ZW_API_INVALID_OUTPUT
@ ZW_API_INVALID_OUTPUT
output parameter is invalid
Definition: zwapi_util.h:55
ZW_API_CAM_GETCMCOMP_ERROR
@ ZW_API_CAM_GETCMCOMP_ERROR
fail to get component in cam plan
Definition: zwapi_util.h:157
ZW_API_CAM_OUTOPXML_ERROR
@ ZW_API_CAM_OUTOPXML_ERROR
fail to output xml type operation list
Definition: zwapi_util.h:172
ZW_API_CMMD_EXEC_ERROR
@ ZW_API_CMMD_EXEC_ERROR
command execution failure
Definition: zwapi_util.h:73
ZW_API_CAM_GETFRAME_ERROR
@ ZW_API_CAM_GETFRAME_ERROR
fail to get frame in cam plan
Definition: zwapi_util.h:163
ZW_API_INVALID_NAME
@ ZW_API_INVALID_NAME
invalid name, name is empty or contains some of \/:*?"<>|
Definition: zwapi_util.h:88
ZW_API_OBJ_TYPE_ERROR
@ ZW_API_OBJ_TYPE_ERROR
the type of the specified object is wrong
Definition: zwapi_util.h:62
ZW_API_BOOLEAN_ADD_BASE_ERROR
@ ZW_API_BOOLEAN_ADD_BASE_ERROR
boolean add failure, more than one base shapes intersect with the operator shape
Definition: zwapi_util.h:85
ZW_API_CMMD_DATA_ERROR
@ ZW_API_CMMD_DATA_ERROR
wrong data container of the specified command(VDATA object)
Definition: zwapi_util.h:74
ZW_API_FORM_CREATE_FAIL
@ ZW_API_FORM_CREATE_FAIL
create form fails
Definition: zwapi_util.h:97
ZW_API_NAME_LEN_LESS_RANGE
@ ZW_API_NAME_LEN_LESS_RANGE
the file name length is less 512 bytes
Definition: zwapi_util.h:94
ZW_API_CMMD_INIT_ERROR
@ ZW_API_CMMD_INIT_ERROR
command initialization failure
Definition: zwapi_util.h:72
ZW_API_CAM_SETFORMITEM_ERROR
@ ZW_API_CAM_SETFORMITEM_ERROR
fail to set cam form item
Definition: zwapi_util.h:183
ZW_API_CAM_GETFORMSTATE_ERROR
@ ZW_API_CAM_GETFORMSTATE_ERROR
fail to get cam form state
Definition: zwapi_util.h:180
ZW_API_LICENSE_NESTING_ERROR
@ ZW_API_LICENSE_NESTING_ERROR
nesting license fails
Definition: zwapi_util.h:107
ZW_API_FORM_INIT_ERROR
@ ZW_API_FORM_INIT_ERROR
Initialization failed.
Definition: zwapi_util.h:100
ZW_API_CAM_SETVDATA_ERROR
@ ZW_API_CAM_SETVDATA_ERROR
fail to set cam info
Definition: zwapi_util.h:122
ZW_API_CAM_GETFOLDERSUB_ERROR
@ ZW_API_CAM_GETFOLDERSUB_ERROR
fail to get folder sub item
Definition: zwapi_util.h:144
ZW_API_PATH_LEN_OVER_RANGE
@ ZW_API_PATH_LEN_OVER_RANGE
the file path length is over range
Definition: zwapi_util.h:91
ZW_API_CAM_GETTPATH_ERROR
@ ZW_API_CAM_GETTPATH_ERROR
fail to get tool path index
Definition: zwapi_util.h:186
ZW_API_FORM_SHOW_FAIL
@ ZW_API_FORM_SHOW_FAIL
show form fails
Definition: zwapi_util.h:98
ZW_API_CAM_GETTOOLDIA_ERROR
@ ZW_API_CAM_GETTOOLDIA_ERROR
fail to get tool diameter
Definition: zwapi_util.h:154
ZW_API_CAM_GETTOOLLEN_ERROR
@ ZW_API_CAM_GETTOOLLEN_ERROR
fail to get tool length
Definition: zwapi_util.h:153
ZW_API_CAM_GETFORMITEM_ERROR
@ ZW_API_CAM_GETFORMITEM_ERROR
fail to get cam form item
Definition: zwapi_util.h:182
ZW_API_CAM_GETOPNAME_ERROR
@ ZW_API_CAM_GETOPNAME_ERROR
fail to get operation name
Definition: zwapi_util.h:116
ZW_API_FUN_REGISTER_ERROR
@ ZW_API_FUN_REGISTER_ERROR
function has been registered
Definition: zwapi_util.h:76
ZW_API_INVALID_INPUT
@ ZW_API_INVALID_INPUT
input parameter is invalid (pointer is NULL, object's id < 1, out of input vlaue.....
Definition: zwapi_util.h:52
ZW_API_CAM_GUITOTXT_ERROR
@ ZW_API_CAM_GUITOTXT_ERROR
fail to interface parameter change to data base
Definition: zwapi_util.h:176
ZW_API_CAM_GETVDATA_ERROR
@ ZW_API_CAM_GETVDATA_ERROR
fail to get cam info
Definition: zwapi_util.h:121
evxCmAttrValueType
evxCmAttrValueType
cam data attribute type
Definition: zwapi_util.h:2502
evxColorAppFlag
evxColorAppFlag
color is stored as a uchar - can't use negative numbers, so use 255 & 254 & 253; 254 is necessary for...
Definition: zwapi_util.h:905
VX_COLOR_BYLAYER
@ VX_COLOR_BYLAYER
color by layer.
Definition: zwapi_util.h:906
evxDimTypeEx
evxDimTypeEx
dimension type, more detailed than evxDimType
Definition: zwapi_util.h:1961
VX_DIM_EX_DIA
@ VX_DIM_EX_DIA
diametrical dimension
Definition: zwapi_util.h:2010
VX_DIM_EX_GDV
@ VX_DIM_EX_GDV
vertical datum (1982) dimension
Definition: zwapi_util.h:2014
VX_DIM_EX_RADBGC
@ VX_DIM_EX_RADBGC
big radial continuous dimension
Definition: zwapi_util.h:2034
VX_DIM_EX_GDHS
@ VX_DIM_EX_GDHS
horizontal datum symbol (1994) dimension
Definition: zwapi_util.h:2015
VX_DIM_EX_LOC
@ VX_DIM_EX_LOC
offset continuous dimension
Definition: zwapi_util.h:2026
VX_DIM_EX_LO
@ VX_DIM_EX_LO
offset dimension
Definition: zwapi_util.h:1989
VX_DIM_EX_LCL
@ VX_DIM_EX_LCL
leader chamfer dimension
Definition: zwapi_util.h:1997
VX_DIM_EX_LCA
@ VX_DIM_EX_LCA
aligned chamfer dimension
Definition: zwapi_util.h:1996
VX_DIM_EX_LCV
@ VX_DIM_EX_LCV
vertical chamfer dimension
Definition: zwapi_util.h:2029
VX_DIM_EX_LPB
@ VX_DIM_EX_LPB
projected baseline dimension
Definition: zwapi_util.h:1974
VX_DIM_EX_LVC
@ VX_DIM_EX_LVC
vertical continuous dimension
Definition: zwapi_util.h:1977
VX_DIM_EX_GF
@ VX_DIM_EX_GF
GD&T/feature symbol dimension.
Definition: zwapi_util.h:2058
VX_DIM_EX_GDVS
@ VX_DIM_EX_GDVS
vertical datum symbol (1994) dimension
Definition: zwapi_util.h:2016
VX_DIM_EX_LOO
@ VX_DIM_EX_LOO
offset ordinate dimension
Definition: zwapi_util.h:2027
VX_DIM_EX_ANGB
@ VX_DIM_EX_ANGB
baseline angular dimension
Definition: zwapi_util.h:2043
VX_DIM_EX_CLC
@ VX_DIM_EX_CLC
centerline curve
Definition: zwapi_util.h:2062
VX_DIM_EX_LH
@ VX_DIM_EX_LH
horizontal dimension
Definition: zwapi_util.h:1964
VX_DIM_EX_INTSYM
@ VX_DIM_EX_INTSYM
intersection symbol dimension
Definition: zwapi_util.h:2065
VX_DIM_EX_AUTO_LSY
@ VX_DIM_EX_AUTO_LSY
auto symmetric dimension
Definition: zwapi_util.h:2072
VX_DIM_EX_GDTC
@ VX_DIM_EX_GDTC
GD&T datum target area dimension.
Definition: zwapi_util.h:2021
VX_DIM_EX_GDTP
@ VX_DIM_EX_GDTP
GD&T datum target point dimension.
Definition: zwapi_util.h:2020
VX_DIM_EX_ANGHC
@ VX_DIM_EX_ANGHC
continuous horizontal-angular dimension
Definition: zwapi_util.h:2047
VX_DIM_EX_ANGO
@ VX_DIM_EX_ANGO
ordinate angular dimension
Definition: zwapi_util.h:2045
VX_DIM_EX_LRC
@ VX_DIM_EX_LRC
rotated continuous dimension
Definition: zwapi_util.h:1979
VX_DIM_EX_ANGH
@ VX_DIM_EX_ANGH
horizontal-angular dimension
Definition: zwapi_util.h:2002
VX_DIM_EX_ANGAC
@ VX_DIM_EX_ANGAC
continuous angular arc dimension
Definition: zwapi_util.h:2053
VX_DIM_EX_LCHV
@ VX_DIM_EX_LCHV
horizontal-vertical chamfer dimension
Definition: zwapi_util.h:1995
VX_DIM_EX_ANGAO
@ VX_DIM_EX_ANGAO
ordinate angular arc dimension
Definition: zwapi_util.h:2054
VX_DIM_EX_LVO
@ VX_DIM_EX_LVO
vertical ordinate dimension
Definition: zwapi_util.h:1983
VX_DIM_EX_LVB
@ VX_DIM_EX_LVB
vertical baseline dimension
Definition: zwapi_util.h:1971
VX_DIM_EX_RADBG
@ VX_DIM_EX_RADBG
big radial dimension
Definition: zwapi_util.h:2008
VX_DIM_EX_GDTL
@ VX_DIM_EX_GDTL
GD&T datum target line area dimension.
Definition: zwapi_util.h:2023
VX_DIM_EX_LOS
@ VX_DIM_EX_LOS
special offset dimension - point to line
Definition: zwapi_util.h:1990
VX_DIM_EX_LAO
@ VX_DIM_EX_LAO
aligned ordinate dimension
Definition: zwapi_util.h:1984
VX_DIM_EX_RADO
@ VX_DIM_EX_RADO
radial ordinate dimension
Definition: zwapi_util.h:2032
VX_DIM_EX_RADS
@ VX_DIM_EX_RADS
special radial dimension
Definition: zwapi_util.h:2039
VX_DIM_EX_RHO
@ VX_DIM_EX_RHO
conic ratio Rho
Definition: zwapi_util.h:2069
VX_DIM_EX_GFL
@ VX_DIM_EX_GFL
leader GD&T/feature symbol dimension
Definition: zwapi_util.h:2059
VX_DIM_EX_LHC
@ VX_DIM_EX_LHC
horizontal continuous dimension
Definition: zwapi_util.h:1976
VX_DIM_EX_LORD
@ VX_DIM_EX_LORD
leader coordinate dimension
Definition: zwapi_util.h:2066
VX_DIM_EX_ANGV
@ VX_DIM_EX_ANGV
vertical-angular dimension
Definition: zwapi_util.h:2003
VX_DIM_EX_ASY
@ VX_DIM_EX_ASY
Angular symmetry dimension.
Definition: zwapi_util.h:1993
VX_DIM_EX_CM
@ VX_DIM_EX_CM
centerline/centermark dimension
Definition: zwapi_util.h:2057
VX_DIM_EX_CRVL
@ VX_DIM_EX_CRVL
spline curve length dimension
Definition: zwapi_util.h:2068
VX_DIM_EX_LAC
@ VX_DIM_EX_LAC
aligned continuous dimension
Definition: zwapi_util.h:1978
VX_DIM_EX_GDTR
@ VX_DIM_EX_GDTR
GD&T datum target rectangle area dimension.
Definition: zwapi_util.h:2022
VX_DIM_EX_DIAC
@ VX_DIM_EX_DIAC
diametrical continuous dimension
Definition: zwapi_util.h:2041
VX_DIM_EX_RADBGO
@ VX_DIM_EX_RADBGO
big radial ordinate dimension
Definition: zwapi_util.h:2035
VX_DIM_EX_ANGVO
@ VX_DIM_EX_ANGVO
ordinate vertical-angular dimension
Definition: zwapi_util.h:2051
VX_DIM_EX_ANGC
@ VX_DIM_EX_ANGC
continuous angular dimension
Definition: zwapi_util.h:2044
VX_DIM_EX_DPLS
@ VX_DIM_EX_DPLS
datum projection dimension (line)
Definition: zwapi_util.h:2067
VX_DIM_EX_ANGVB
@ VX_DIM_EX_ANGVB
baseline vertical-angular dimension
Definition: zwapi_util.h:2049
VX_DIM_EX_RADB
@ VX_DIM_EX_RADB
radial baseline dimension
Definition: zwapi_util.h:2030
VX_DIM_EX_RADBKB
@ VX_DIM_EX_RADBKB
broken radial baseline dimension
Definition: zwapi_util.h:2036
VX_DIM_EX_RADBKO
@ VX_DIM_EX_RADBKO
broken radial ordinate dimension
Definition: zwapi_util.h:2038
VX_DIM_EX_LRO
@ VX_DIM_EX_LRO
rotated ordinate dimension
Definition: zwapi_util.h:1985
VX_DIM_EX_RADBKC
@ VX_DIM_EX_RADBKC
broken radial continuous dimension
Definition: zwapi_util.h:2037
VX_DIM_EX_BALL
@ VX_DIM_EX_BALL
balloon dimension
Definition: zwapi_util.h:2056
VX_DIM_EX_RADC
@ VX_DIM_EX_RADC
radial continuous dimension
Definition: zwapi_util.h:2031
VX_DIM_EX_LCH
@ VX_DIM_EX_LCH
horizontal chamfer dimension
Definition: zwapi_util.h:2028
VX_DIM_EX_LHO
@ VX_DIM_EX_LHO
horizontal ordinate dimension
Definition: zwapi_util.h:1982
VX_DIM_EX_LRB
@ VX_DIM_EX_LRB
rotated baseline dimension
Definition: zwapi_util.h:1973
VX_DIM_EX_LPO
@ VX_DIM_EX_LPO
projected ordinate dimension
Definition: zwapi_util.h:1986
VX_DIM_EX_ANGVC
@ VX_DIM_EX_ANGVC
continuous vertical-angular dimension
Definition: zwapi_util.h:2050
VX_DIM_EX_CRVL3D
@ VX_DIM_EX_CRVL3D
curve length
Definition: zwapi_util.h:2070
VX_DIM_EX_CLBS
@ VX_DIM_EX_CLBS
bisection centerline
Definition: zwapi_util.h:2063
VX_DIM_EX_ANGHB
@ VX_DIM_EX_ANGHB
baseline horizontal-angular dimension
Definition: zwapi_util.h:2046
VX_DIM_EX_LA
@ VX_DIM_EX_LA
aligned dimension
Definition: zwapi_util.h:1966
VX_DIM_EX_RADBGB
@ VX_DIM_EX_RADBGB
big radial baseline dimension
Definition: zwapi_util.h:2033
VX_DIM_EX_ANGAB
@ VX_DIM_EX_ANGAB
baseline angular arc dimension
Definition: zwapi_util.h:2052
VX_DIM_EX_LHVO
@ VX_DIM_EX_LHVO
horizontal and vertical ordinate dimension
Definition: zwapi_util.h:1987
VX_DIM_EX_ANG
@ VX_DIM_EX_ANG
angular dimension
Definition: zwapi_util.h:2001
VX_DIM_EX_RADL
@ VX_DIM_EX_RADL
radial leader dimension
Definition: zwapi_util.h:2011
VX_DIM_EX_LPC
@ VX_DIM_EX_LPC
projected continuous dimension
Definition: zwapi_util.h:1980
VX_DIM_EX_LCLS
@ VX_DIM_EX_LCLS
special chamfer leader dimension
Definition: zwapi_util.h:2061
VX_DIM_EX_LHB
@ VX_DIM_EX_LHB
horizontal baseline dimension
Definition: zwapi_util.h:1970
VX_DIM_EX_RADBK
@ VX_DIM_EX_RADBK
broken radial dimension
Definition: zwapi_util.h:2009
VX_DIM_EX_LP
@ VX_DIM_EX_LP
projected dimension
Definition: zwapi_util.h:1968
VX_DIM_EX_LSY
@ VX_DIM_EX_LSY
symmetry dimension
Definition: zwapi_util.h:1992
VX_DIM_EX_RAD
@ VX_DIM_EX_RAD
radial dimension
Definition: zwapi_util.h:2007
VX_DIM_EX_ELEV
@ VX_DIM_EX_ELEV
elevation dimension
Definition: zwapi_util.h:2071
VX_DIM_EX_ANGA
@ VX_DIM_EX_ANGA
angular arc dimension
Definition: zwapi_util.h:2004
VX_DIM_EX_LR
@ VX_DIM_EX_LR
rotated dimension
Definition: zwapi_util.h:1967
VX_DIM_EX_LOB
@ VX_DIM_EX_LOB
offset baseline dimension
Definition: zwapi_util.h:2025
VX_DIM_EX_LCLP
@ VX_DIM_EX_LCLP
leader chamfer dimension (always perpendicular)
Definition: zwapi_util.h:1998
VX_DIM_EX_LCLA
@ VX_DIM_EX_LCLA
leader chamfer dimension (always along the chamfered line)
Definition: zwapi_util.h:1999
VX_DIM_EX_ANGHO
@ VX_DIM_EX_ANGHO
ordinate horizontal-angular dimension
Definition: zwapi_util.h:2048
VX_DIM_EX_ANG3PT
@ VX_DIM_EX_ANG3PT
3 point angular dimension
Definition: zwapi_util.h:2005
VX_DIM_EX_GDH
@ VX_DIM_EX_GDH
horizontal datum (1982) dimension
Definition: zwapi_util.h:2013
VX_DIM_EX_DIAO
@ VX_DIM_EX_DIAO
diametrical ordinate dimension
Definition: zwapi_util.h:2042
VX_DIM_EX_GDL
@ VX_DIM_EX_GDL
leader datum (1994) dimension (circle, arc, curves)
Definition: zwapi_util.h:2017
VX_DIM_EX_LAB
@ VX_DIM_EX_LAB
aligned baseline dimension
Definition: zwapi_util.h:1972
VX_DIM_EX_ARCL
@ VX_DIM_EX_ARCL
arc length
Definition: zwapi_util.h:2064
VX_DIM_EX_LEAD
@ VX_DIM_EX_LEAD
leader dimension
Definition: zwapi_util.h:2055
VX_DIM_EX_DIAB
@ VX_DIM_EX_DIAB
diametrical baseline dimension
Definition: zwapi_util.h:2040
VX_DIM_EX_LV
@ VX_DIM_EX_LV
vertical dimension
Definition: zwapi_util.h:1965
VX_DIM_EX_GFP
@ VX_DIM_EX_GFP
profile GD&T/feature symbol dimension
Definition: zwapi_util.h:2060
VX_DIM_EX_GDLS
@ VX_DIM_EX_GDLS
leader datum (1994) dimension (line)
Definition: zwapi_util.h:2018
evxGeomCritPnt
evxGeomCritPnt
type of sketch geometry critical point
Definition: zwapi_util.h:534
VX_END_POINT
@ VX_END_POINT
end point of curve or line (if the input is face, get point of (u.max, v.max))
Definition: zwapi_util.h:538
VX_MIDDLE_POINT
@ VX_MIDDLE_POINT
middle point of curve or line
Definition: zwapi_util.h:541
VX_NO_POINT
@ VX_NO_POINT
set the entity not the critical point of entity
Definition: zwapi_util.h:535
VX_CENTER_POINT
@ VX_CENTER_POINT
center point, used only for arc or circle (if the input is face, get point of ((u....
Definition: zwapi_util.h:539
VX_FREE_POINT
@ VX_FREE_POINT
free point, non-critical point
Definition: zwapi_util.h:536
VX_ORIGIN_POINT
@ VX_ORIGIN_POINT
origin of datum plane and datum CSYS
Definition: zwapi_util.h:542
VX_START_POINT
@ VX_START_POINT
start point of curve or line (if the input is face, get point of (u.min, v.min))
Definition: zwapi_util.h:537
VX_SPLINE_DEFINING_POINT
@ VX_SPLINE_DEFINING_POINT
control point, used only for splines
Definition: zwapi_util.h:540
evxFCSSymbol
evxFCSSymbol
FCS MD&T symbol.
Definition: zwapi_util.h:2106
VX_FCSSYM_SYMMETRY
@ VX_FCSSYM_SYMMETRY
symmetry
Definition: zwapi_util.h:2117
VX_FCSSYM_PROFILE_OF_SURFACE
@ VX_FCSSYM_PROFILE_OF_SURFACE
profile of a surface
Definition: zwapi_util.h:2119
VX_FCSSYM_POSITION
@ VX_FCSSYM_POSITION
position
Definition: zwapi_util.h:2115
VX_FCSSYM_TOTAL_RUNOUT
@ VX_FCSSYM_TOTAL_RUNOUT
total run-out
Definition: zwapi_util.h:2121
VX_FCSSYM_STRAIGHTNESS
@ VX_FCSSYM_STRAIGHTNESS
straightness
Definition: zwapi_util.h:2108
VX_FCSSYM_CONCENTRICITY
@ VX_FCSSYM_CONCENTRICITY
concentricity
Definition: zwapi_util.h:2116
VX_FCSSYM_CIRCULARITY
@ VX_FCSSYM_CIRCULARITY
circularity
Definition: zwapi_util.h:2110
VX_FCSSYM_CYLINDRICITY
@ VX_FCSSYM_CYLINDRICITY
cylindricity
Definition: zwapi_util.h:2111
VX_FCSSYM_FLATNESS
@ VX_FCSSYM_FLATNESS
flatness
Definition: zwapi_util.h:2109
VX_FCSSYM_NONE
@ VX_FCSSYM_NONE
none
Definition: zwapi_util.h:2107
VX_FCSSYM_PROFILE_OF_LINE
@ VX_FCSSYM_PROFILE_OF_LINE
profile of a line
Definition: zwapi_util.h:2118
VX_FCSSYM_PERPENDICULARITY
@ VX_FCSSYM_PERPENDICULARITY
perpendicularity
Definition: zwapi_util.h:2113
VX_FCSSYM_PARALLELISM
@ VX_FCSSYM_PARALLELISM
parallelism
Definition: zwapi_util.h:2112
VX_FCSSYM_ANGULARITY
@ VX_FCSSYM_ANGULARITY
angularity
Definition: zwapi_util.h:2114
VX_FCSSYM_CIRCULAR_RUNOUT
@ VX_FCSSYM_CIRCULAR_RUNOUT
circular run-out
Definition: zwapi_util.h:2120
evxDimState
evxDimState
dimension state
Definition: zwapi_util.h:2092
VX_DM_NOSCALE
@ VX_DM_NOSCALE
not scale dimension
Definition: zwapi_util.h:2094
VX_DM_IN_OBJ
@ VX_DM_IN_OBJ
the dimension is in other object, only need text display data
Definition: zwapi_util.h:2098
VX_DM_NORMAL
@ VX_DM_NORMAL
default, normal state
Definition: zwapi_util.h:2097
VX_DM_MODIFIED
@ VX_DM_MODIFIED
modified dimension
Definition: zwapi_util.h:2095
VX_DM_DANGLING
@ VX_DM_DANGLING
dangling dimension
Definition: zwapi_util.h:2096
VX_DM_REVISION
@ VX_DM_REVISION
revision dimension
Definition: zwapi_util.h:2093
evxPntLocation
evxPntLocation
point location
Definition: zwapi_util.h:603
VX_PNT_OUT
@ VX_PNT_OUT
point lies outside the boundary
Definition: zwapi_util.h:604
VX_PNT_IN
@ VX_PNT_IN
point lies inside the boundary
Definition: zwapi_util.h:606
VX_PNT_NULL
@ VX_PNT_NULL
unable to classify point location
Definition: zwapi_util.h:607
VX_PNT_ON
@ VX_PNT_ON
point lies on the boundary
Definition: zwapi_util.h:605
evxTextureLoc
evxTextureLoc
texture map origin point with respect to texture map rectangle
Definition: zwapi_util.h:1253
evxCmTreeType
evxCmTreeType
cam tree type
Definition: zwapi_util.h:2549
CM_TREE_FTR
@ CM_TREE_FTR
ftr in tree
Definition: zwapi_util.h:2553
CM_TREE_COMP
@ CM_TREE_COMP
component in tree
Definition: zwapi_util.h:2551
CM_TREE_FLD
@ CM_TREE_FLD
folder in tree
Definition: zwapi_util.h:2552
CM_TREE_OP
@ CM_TREE_OP
opdef in tree
Definition: zwapi_util.h:2550
evxFCSLmsOption
evxFCSLmsOption
FCS LMS option.
Definition: zwapi_util.h:2141
VX_LMS_FTR_SIZE_REGARDLESS
@ VX_LMS_FTR_SIZE_REGARDLESS
regardless of feature size
Definition: zwapi_util.h:2145
VX_LMS_MAX_MATERIAL
@ VX_LMS_MAX_MATERIAL
maximum material condition
Definition: zwapi_util.h:2143
VX_LMS_MIN_MATERIAL
@ VX_LMS_MIN_MATERIAL
least material condition
Definition: zwapi_util.h:2144
VX_LMS_NONE
@ VX_LMS_NONE
none
Definition: zwapi_util.h:2142
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
svxSplinePnt
struct svxSplinePnt svxSplinePnt
Spline point.
svxEntPath
struct svxEntPath svxEntPath
entity pick path(sync with VsPickPath)
svxFaceAt
struct svxFaceAt svxFaceAt
face display attributes
svxSrfPrim
struct svxSrfPrim svxSrfPrim
3D NURB surface data
svxTriangle
struct svxTriangle svxTriangle
3D triangle
svxLimit
struct svxLimit svxLimit
limits
svxCylinder
struct svxCylinder svxCylinder
cylindrical surface data
svxCone
struct svxCone svxCone
conical surface data
svxWireAt
struct svxWireAt svxWireAt
wire display attributes
svxAxis
struct svxAxis svxAxis
3D axis
svxColorf
struct svxColorf svxColorf
RGB color (floating point components defined over 0.0 to 1.0)
svxBndBox
struct svxBndBox svxBndBox
3D bounding box
svxCrvContinuityTolList
struct svxCrvContinuityTolList svxCrvContinuityTolList
curve continuity tolerance list
svxTextureAt
struct svxTextureAt svxTextureAt
texture attribute
svxParameters
struct svxParameters svxParameters
curve parameter space data
svxSplineData
struct svxSplineData svxSplineData
Spline command data.
svxPointf
struct svxPointf svxPointf
3D point (single precision floating point)
svxPartAttribute
struct svxPartAttribute svxPartAttribute
part attribute structure
svxVariable
struct svxVariable svxVariable
numeric variable
svxMatrix
struct svxMatrix svxMatrix
3D transformation matrix or coordinate frame (local to world)
svxPoint2
struct svxPoint2 svxPoint2
2D point
svxControlPoints
struct svxControlPoints svxControlPoints
curve control point data
svxCmAttrValue
struct svxCmAttrValue svxCmAttrValue
cam data attribute value
svxDimAttr
struct svxDimAttr svxDimAttr
Dimension attributes structure.
svxColor
struct svxColor svxColor
RGB color (each component defined over 0 to 255)
svxPoint2f
struct svxPoint2f svxPoint2f
2D point(single precision floating point)
svxFCSTol
struct svxFCSTol svxFCSTol
FCS tolerance data.
svxLineAt
struct svxLineAt svxLineAt
Line attributes.
svxPntOnEntPath
struct svxPntOnEntPath svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
svxShaderAt
struct svxShaderAt svxShaderAt
shader attribute
svxAttribute
struct svxAttribute svxAttribute
standard attribute data
svxCrvContinuityData
struct svxCrvContinuityData svxCrvContinuityData
data of curve continuity.
svxEllipsoid
struct svxEllipsoid svxEllipsoid
ellipsoid surface data
svxEntFind
struct svxEntFind svxEntFind
entity search data
svxFCSDatum
struct svxFCSDatum svxFCSDatum
FCS datum data.
svxDirOnEntPath
struct svxDirOnEntPath svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
svxTextAt
struct svxTextAt svxTextAt
text attribute
svxSphere
struct svxSphere svxSphere
spherical surface data
svxMatEuler
struct svxMatEuler svxMatEuler
Euler angles and translate vector.
svxVector2
struct svxVector2 svxVector2
2D vector
svxFCSData
struct svxFCSData svxFCSData
FCS data.
svxCrvIntData
struct svxCrvIntData svxCrvIntData
2D/3D interpolated curve
svxUid
struct svxUid svxUid
entity unique identifier
svxCurve
struct svxCurve svxCurve
2D or 3D curvilinear geometry
svxTorus
struct svxTorus svxTorus
circular surface data
svxEntPick
struct svxEntPick svxEntPick
entity pick (includes optional parent entity)
svxPoint
struct svxPoint svxPoint
3D point
svxView
struct svxView svxView
view data(Z3PRT,Z3ASM)
svxSurface
struct svxSurface svxSurface
3D NURB surface (untrimmed)
svxData
struct svxData svxData
command input data item
svxFacets
struct svxFacets svxFacets
3D facets defined by triangle strips
svxCompName
struct svxCompName svxCompName
brief component info
svxPntOnEnt
struct svxPntOnEnt svxPntOnEnt
point on entity definition, also can use to set a dynamic point
svxPlane
struct svxPlane svxPlane
data of plane
svxVector
struct svxVector svxVector
3D vector
svxPrfAreaProp
struct svxPrfAreaProp svxPrfAreaProp
profile area property
svxAttribute::label
char label[64]
attribute label
Definition: zwapi_util.h:1371
svxAttribute::unit
char unit
unit type for non-constant real number (evxUnitType, evxAngUnitType...) or date format (evxDateFormat...
Definition: zwapi_util.h:1376
svxAttribute::data
char data[512]
attribute data
Definition: zwapi_util.h:1372
svxAttribute::sub_type
char sub_type
sub type for real number type (use input type of evxNumType)
Definition: zwapi_util.h:1375
svxAttribute::has_eqn
int has_eqn
flag to show whether there are some equations in "data/expression"
Definition: zwapi_util.h:1378
svxAttribute::strValue
char strValue[2048]
attribute value
Definition: zwapi_util.h:1377
svxAttribute::type
char type
attribute type (evxAttributeType)
Definition: zwapi_util.h:1374
svxAttribute::dValue
double dValue
value for bool, integer, real number, date type
Definition: zwapi_util.h:1373
svxAttribute
standard attribute data
Definition: zwapi_util.h:1370
svxAxis::Dir
svxVector Dir
direction
Definition: zwapi_util.h:351
svxAxis::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:350
svxAxis
3D axis
Definition: zwapi_util.h:349
svxBndBox::Z
svxLimit Z
the maximum and minimum values in the z direction of the boundle box
Definition: zwapi_util.h:468
svxBndBox::Y
svxLimit Y
the maximum and minimum values in the y direction of the boundle box
Definition: zwapi_util.h:467
svxBndBox::X
svxLimit X
the maximum and minimum values in the x direction of the boundle box
Definition: zwapi_util.h:466
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxCmAttrValue::cnt
int cnt
count of data
Definition: zwapi_util.h:2516
svxCmAttrValue::data
void * data
user is response to free this memory
Definition: zwapi_util.h:2517
svxCmAttrValue::type
evxCmAttrValueType type
cam data attribute type
Definition: zwapi_util.h:2515
svxCmAttrValue
cam data attribute value
Definition: zwapi_util.h:2514
svxColor::g
unsigned char g
green color component (0-255)
Definition: zwapi_util.h:620
svxColor::r
unsigned char r
red color component (0-255)
Definition: zwapi_util.h:619
svxColor::b
unsigned char b
blue color component (0-255)
Definition: zwapi_util.h:621
svxColor
RGB color (each component defined over 0 to 255)
Definition: zwapi_util.h:618
svxColorf::g
float g
green color component (0.0-1.0)
Definition: zwapi_util.h:631
svxColorf::b
float b
blue color component (0.0-1.0)
Definition: zwapi_util.h:632
svxColorf::r
float r
red color component (0.0-1.0)
Definition: zwapi_util.h:630
svxColorf
RGB color (floating point components defined over 0.0 to 1.0)
Definition: zwapi_util.h:629
svxCompName::File
vxLongPath File
name of file that contains "Part"
Definition: zwapi_util.h:2288
svxCompName::Part
vxRootName Part
name of part to instance as a component
Definition: zwapi_util.h:2289
svxCompName
brief component info
Definition: zwapi_util.h:2287
svxCone::form
svxMatrix form
cone centered about xform origin is at large radius z-axis points from large radius to apex....
Definition: zwapi_util.h:1797
svxCone::radius1
double radius1
bottom (lo u or v) radius
Definition: zwapi_util.h:1794
svxCone::length
double length
cone len between Max(radius1,radius2) and apex (length of the axis)
Definition: zwapi_util.h:1796
svxCone::radius2
double radius2
top (hi u or v) radius.
Definition: zwapi_util.h:1795
svxCone::lindir
int lindir
= 1 : u defines the linear direction. = 2 : v defines the linear direction.
Definition: zwapi_util.h:1801
svxCone
conical surface data
Definition: zwapi_util.h:1793
svxControlPoints::coord
double * coord
control point coordinates (possibly weighted)
Definition: zwapi_util.h:1633
svxControlPoints::plane
int plane
cp hyper plane type: 1:pnt, 2:line, 3:plane
Definition: zwapi_util.h:1630
svxControlPoints::rat
int rat
1=RATIONAL, 0=NONRATIONAL control points
Definition: zwapi_util.h:1628
svxControlPoints::dim
int dim
number of coordinates per control point (1-4)
Definition: zwapi_util.h:1629
svxControlPoints::free_mem
int free_mem
1 if memory referenced by "coord" should be free'd by cvxCurveFree()
Definition: zwapi_util.h:1635
svxControlPoints::num_cp
int num_cp
number of control points in list
Definition: zwapi_util.h:1631
svxControlPoints::box
svxBndBox box
bounding box of control points
Definition: zwapi_util.h:1632
svxControlPoints
curve control point data
Definition: zwapi_util.h:1627
svxCrvContinuityData::curvature
double curvature
Check this option to inquire the continuity of G2 curvature between the picked curves.
Definition: zwapi_util.h:1652
svxCrvContinuityData::tangent
double tangent
Check this option to inquire the continuity of G1 tangent between the picked curves.
Definition: zwapi_util.h:1650
svxCrvContinuityData::isFlowContinuous
int isFlowContinuous
1 is continuous flow, else 0.
Definition: zwapi_util.h:1655
svxCrvContinuityData::isTangentContinuous
int isTangentContinuous
1 is continuous tangent, else 0.
Definition: zwapi_util.h:1651
svxCrvContinuityData::flow
double flow
Check this option to inquire the continuity of G3 flow between the picked curves.
Definition: zwapi_util.h:1654
svxCrvContinuityData::idCrv1
int idCrv1
id of curve1
Definition: zwapi_util.h:1646
svxCrvContinuityData::idCrv2
int idCrv2
id of curve2
Definition: zwapi_util.h:1647
svxCrvContinuityData::position
double position
Check this option to inquire the continuity of G0 position between the picked curves.
Definition: zwapi_util.h:1648
svxCrvContinuityData::isCurvatureContinuous
int isCurvatureContinuous
1 is continuous curvature, else 0.
Definition: zwapi_util.h:1653
svxCrvContinuityData::isPositionContinuous
int isPositionContinuous
1 is continuous position, else 0.
Definition: zwapi_util.h:1649
svxCrvContinuityData
data of curve continuity.
Definition: zwapi_util.h:1645
svxCrvContinuityTolList::tolPosition
double tolPosition
tolerance of position.default:0.01 Judge whether the two curves are G0 continuous tolerance....
Definition: zwapi_util.h:1664
svxCrvContinuityTolList::tolTangent
double tolTangent
tolerance of tangent.default:0.5 Judge whether the two curves are G2 continuous tolerance....
Definition: zwapi_util.h:1666
svxCrvContinuityTolList::tolFlow
double tolFlow
tolerance of flew.default:0.05 Judge whether the two curves are G3 continuous tolerance.
Definition: zwapi_util.h:1670
svxCrvContinuityTolList::tolCurvature
double tolCurvature
tolerance of curvature.default:0.05 Judge whether the two curves are G2 continuous tolerance.
Definition: zwapi_util.h:1668
svxCrvContinuityTolList
curve continuity tolerance list
Definition: zwapi_util.h:1663
svxCrvIntData::UseEndTan
int UseEndTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2342
svxCrvIntData::Count
int Count
number of points to interpolate
Definition: zwapi_util.h:2333
svxCrvIntData::StartTan
svxVector StartTan
normalized start tangent direction vector
Definition: zwapi_util.h:2339
svxCrvIntData::EndScale
double EndScale
end tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2344
svxCrvIntData::UseStartTan
int UseStartTan
1 to use start tangent direction, else 0
Definition: zwapi_util.h:2338
svxCrvIntData::Degree
int Degree
curve degree (2 - 6)
Definition: zwapi_util.h:2332
svxCrvIntData::Points
svxPoint * Points
pointer to list of points to interpolate
Definition: zwapi_util.h:2334
svxCrvIntData::isClosed
int isClosed
1 if curve is closed, 0 if open
Definition: zwapi_util.h:2331
svxCrvIntData::StartScale
double StartScale
start tangent scale factor (0.1 - 10.0, 1.0 as default)
Definition: zwapi_util.h:2340
svxCrvIntData::EndTan
svxVector EndTan
normalized end tangent direction vector
Definition: zwapi_util.h:2343
svxCrvIntData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2346
svxCrvIntData
2D/3D interpolated curve
Definition: zwapi_util.h:2329
svxCurve::Type
evxCurveType Type
curve type
Definition: zwapi_util.h:1680
svxCurve::A2
double A2
arc start/end angles (degrees)
Definition: zwapi_util.h:1684
svxCurve::P2
svxPoint P2
line start/end points or center of 2D circle/arc
Definition: zwapi_util.h:1683
svxCurve::T
svxParameters T
NURB parameter space data.
Definition: zwapi_util.h:1687
svxCurve::R
double R
circle/arc radius
Definition: zwapi_util.h:1685
svxCurve::P
svxControlPoints P
NURB control point data (mm)
Definition: zwapi_util.h:1688
svxCurve::Frame
svxMatrix Frame
local frame (origin is center of 3D circle/arc)
Definition: zwapi_util.h:1681
svxCurve
2D or 3D curvilinear geometry
Definition: zwapi_util.h:1679
svxCylinder::length
double length
length
Definition: zwapi_util.h:1812
svxCylinder::radius
double radius
radius
Definition: zwapi_util.h:1811
svxCylinder::lindir
int lindir
= 1 : u defines the linear direction. = 2 : v defines the linear direction.
Definition: zwapi_util.h:1818
svxCylinder::form
svxMatrix form
cylinder centered about xform origin is at low parameter value z-axis points from low parameter t...
Definition: zwapi_util.h:1813
svxCylinder
cylindrical surface data
Definition: zwapi_util.h:1810
svxData::Pnt
svxPoint Pnt
point coordinates
Definition: zwapi_util.h:1583
svxData::isEndPnt
char isEndPnt
if "isPntOnCrv=1", set this flag to 1 if Param[0] is to be used to identify the closest endpoint on t...
Definition: zwapi_util.h:1569
svxData::isPoint
char isPoint
1 if "Pnt" is defined, else 0
Definition: zwapi_util.h:1557
svxData::Param
double Param[3]
pick parameters (i.e. t value or point id)
Definition: zwapi_util.h:1585
svxData::Num
double Num
numeric value
Definition: zwapi_util.h:1581
svxData::chkRepeatEnt
int chkRepeatEnt
1 if check whether the input entities are duplicated, else 0.default:0
Definition: zwapi_util.h:1587
svxData::isText
char isText
1 if "Text" is defined, else 0
Definition: zwapi_util.h:1561
svxData::isDirection
char isDirection
1 if "Dir" is defined, else 0
Definition: zwapi_util.h:1560
svxData::isPntOnCrv
char isPntOnCrv
1 if point on curve, else 0. idEntity="curve id"; Pnt="point coordinates"; Param[0]="curve t param"; ...
Definition: zwapi_util.h:1562
svxData::Text
char Text[512]
text string (expression if "isNumber=1")
Definition: zwapi_util.h:1586
svxData::idParent
int idParent
id of parent entity (0 if undefined)
Definition: zwapi_util.h:1579
svxData::NumType
evxNumType NumType
numeric input type (input and output)
Definition: zwapi_util.h:1580
svxData::isPntOnFace
char isPntOnFace
1 if point on face, else 0. idEntity="face id"; Pnt="point coordinates"; Param[0]="u parameter"; Para...
Definition: zwapi_util.h:1573
svxData::Dir
svxVector Dir
unit direction vector
Definition: zwapi_util.h:1584
svxData::PntType
evxPntType PntType
point input type (output only)
Definition: zwapi_util.h:1582
svxData::idEntity
int idEntity
entity/object id (0 if undefined)
Definition: zwapi_util.h:1578
svxData::isNumber
char isNumber
1 if "Num" is defined, else 0
Definition: zwapi_util.h:1559
svxData::isEntity
char isEntity
1 if "idEntity" is defined, else 0
Definition: zwapi_util.h:1558
svxData
command input data item
Definition: zwapi_util.h:1555
svxDimAttr::altTolDecPlc
int altTolDecPlc
tolerance precision, if altUnitFlag = 1, apply it
Definition: zwapi_util.h:2269
svxDimAttr::trmTyp2
evxTermType trmTyp2
arrowhead2 type
Definition: zwapi_util.h:2258
svxDimAttr::extLineSize
int extLineSize
extension line size(1-6)
Definition: zwapi_util.h:2260
svxDimAttr::dimPrefixFlag
int dimPrefixFlag
radial, diameter, and chamfer prefix on/off(0-on, 1-off)
Definition: zwapi_util.h:2264
svxDimAttr::chAsp
double chAsp
text character aspect ratio
Definition: zwapi_util.h:2250
svxDimAttr::showUnit
int showUnit
show unit,(0-both not, 1-show main dim unit, 2-show unit for alt., 3-both )
Definition: zwapi_util.h:2266
svxDimAttr::chLnSpc
double chLnSpc
text character multi-line spacing
Definition: zwapi_util.h:2251
svxDimAttr::suppLeader
int suppLeader
1 if suppress the leader, else 0
Definition: zwapi_util.h:2272
svxDimAttr::dimTxtClr
int dimTxtClr
dimension text color (evxColor)
Definition: zwapi_util.h:2243
svxDimAttr::trmTyp1
evxTermType trmTyp1
arrowhead1 type
Definition: zwapi_util.h:2257
svxDimAttr::decPlc
int decPlc
dimension text decimal places
Definition: zwapi_util.h:2248
svxDimAttr::LeaderAlign
int LeaderAlign
dimension line (or leader) justification(0-center, 1-top, 2-half, 3-bottom)
Definition: zwapi_util.h:2256
svxDimAttr::tolDecPlc
int tolDecPlc
tolerance precision
Definition: zwapi_util.h:2267
svxDimAttr::tolChHgtFac
double tolChHgtFac
tolerance text height scaling factor
Definition: zwapi_util.h:2254
svxDimAttr::trmSize1
double trmSize1
arrowhead1 size
Definition: zwapi_util.h:2275
svxDimAttr::altUnitFlag
int altUnitFlag
1 if use alternate unites, else 0
Definition: zwapi_util.h:2265
svxDimAttr::prefix
char prefix[32]
dimension prefix
Definition: zwapi_util.h:2236
svxDimAttr::fontName
char fontName[36]
font name
Definition: zwapi_util.h:2240
svxDimAttr::extLineType
int extLineType
extension line type(0-5)
Definition: zwapi_util.h:2262
svxDimAttr::extLnClr
int extLnClr
extension lines color (evxColor)
Definition: zwapi_util.h:2241
svxDimAttr::chSlant
double chSlant
slant angle of text
Definition: zwapi_util.h:2253
svxDimAttr::dimTxtBold
int dimTxtBold
dim. text bold flag (0-normal, 1-bold)
Definition: zwapi_util.h:2263
svxDimAttr::chHgt
double chHgt
text height
Definition: zwapi_util.h:2249
svxDimAttr::valFmt
int valFmt
dimension value text format (1-no tol, 2-limit, 3-unequal tol, 4-equal tol, 5-tol zone,...
Definition: zwapi_util.h:2245
svxDimAttr::dimLineType
int dimLineType
dimension line type(0-5)
Definition: zwapi_util.h:2261
svxDimAttr::altDecPlc
int altDecPlc
unit precision, if altUnitFlag = 1, apply it
Definition: zwapi_util.h:2268
svxDimAttr::trmSuppFlg2
int trmSuppFlg2
suppress arrowhead2 flag (0-on, 1-off)
Definition: zwapi_util.h:2274
svxDimAttr::altUnitTyp
evxUnitType altUnitTyp
alternate unit type
Definition: zwapi_util.h:2270
svxDimAttr::dimLnClr
int dimLnClr
dimension lines color (evxColor)
Definition: zwapi_util.h:2242
svxDimAttr::tolMinus
char tolMinus[8]
tolerance minus
Definition: zwapi_util.h:2239
svxDimAttr::symbolClr
int symbolClr
symbol color
Definition: zwapi_util.h:2244
svxDimAttr::suffix
char suffix[32]
dimension suffix
Definition: zwapi_util.h:2237
svxDimAttr::dimLineSize
int dimLineSize
dimension line size(1-6)
Definition: zwapi_util.h:2259
svxDimAttr::trmSize2
double trmSize2
arrowhead2 size
Definition: zwapi_util.h:2276
svxDimAttr::zeroSupp
int zeroSupp
zero suppression (1-none, 2-lead, 3-trail, 4-both)
Definition: zwapi_util.h:2247
svxDimAttr::angAltUnitTyp
evxAngUnitType angAltUnitTyp
angular alternate unit type
Definition: zwapi_util.h:2271
svxDimAttr::dimTxtOrient
int dimTxtOrient
dimension text orientation(>=1)
Definition: zwapi_util.h:2255
svxDimAttr::tolPlus
char tolPlus[8]
tolerance plus
Definition: zwapi_util.h:2238
svxDimAttr::chSpc
double chSpc
text character spacing ratio
Definition: zwapi_util.h:2252
svxDimAttr::trmSuppFlg1
int trmSuppFlg1
suppress arrowhead1 flag (0-on, 1-off)
Definition: zwapi_util.h:2273
svxDimAttr
Dimension attributes structure.
Definition: zwapi_util.h:2235
svxDirOnEntPath::flipDir
int flipDir
whether to flip direction (1 to flip, else 0). enable when the direction control support flip the dir...
Definition: zwapi_util.h:595
svxDirOnEntPath::entPath
svxEntPath entPath
entity path that defines the direction
Definition: zwapi_util.h:591
svxDirOnEntPath::dirType
evxDirType dirType
direction type, only used when entPath is a curve and not a circle or face
Definition: zwapi_util.h:592
svxDirOnEntPath::pnt
svxPoint pnt
point coordinates, only used when entPath is a face and dirType is VX_PNT_DIR
Definition: zwapi_util.h:593
svxDirOnEntPath::dir
svxVector dir
direction, only used when entPath is a invalid path (svxEntPath.Count < 2)
Definition: zwapi_util.h:594
svxDirOnEntPath
direction of point on entity path definition, also can use to set a dynamic direction
Definition: zwapi_util.h:590
svxEllipsoid::ylen
double ylen
length along y-axis
Definition: zwapi_util.h:1846
svxEllipsoid::poleis01
int poleis01
= 1 : poles (if they exist) are at extreme V parameters = 0 : poles (if they exist) are at extreme ...
Definition: zwapi_util.h:1849
svxEllipsoid::form
svxMatrix form
ellipsoid centered about xform
Definition: zwapi_util.h:1848
svxEllipsoid::zlen
double zlen
length along z-axis
Definition: zwapi_util.h:1847
svxEllipsoid::xlen
double xlen
length along x-axis
Definition: zwapi_util.h:1845
svxEllipsoid
ellipsoid surface data
Definition: zwapi_util.h:1844
svxEntFind::Layer
int Layer
entity layer number (0 to 255)
Definition: zwapi_util.h:1039
svxEntFind::Option
evxEntFind Option
type of entity to search for
Definition: zwapi_util.h:1032
svxEntFind::Pnt
svxPoint Pnt
projection of reference point onto entity
Definition: zwapi_util.h:1048
svxEntFind::RefPnt
svxPoint RefPnt
find entity closest to this reference point
Definition: zwapi_util.h:1033
svxEntFind::edgeType
evxEdgeType edgeType
edge type (VX_EDGE_UNKNOWN to ignore)
Definition: zwapi_util.h:1044
svxEntFind::Color
evxColor Color
entity color (0 to ignore, VX_COLOR_RGB to use RGB parameters)
Definition: zwapi_util.h:1036
svxEntFind::Dist
double Dist
distance from reference point to entity
Definition: zwapi_util.h:1049
svxEntFind::CheckLayer
int CheckLayer
1 to check layer number (0 to ignore)
Definition: zwapi_util.h:1038
svxEntFind::Rgb
svxColor Rgb
RGB color if "Color = VX_COLOR_RGB".
Definition: zwapi_util.h:1037
svxEntFind::isPlane
int isPlane
1 if face entity must be "planer" (0 to ignore)
Definition: zwapi_util.h:1041
svxEntFind::idEntity
int idEntity
id of entity found by search (0 if not found)
Definition: zwapi_util.h:1047
svxEntFind::isHole
int isHole
1 if face/edge must belong to a hole (0 to ignore)
Definition: zwapi_util.h:1042
svxEntFind::idFeature
int idFeature
parent feature id (0 to ignore)
Definition: zwapi_util.h:1040
svxEntFind::isLine
int isLine
1 if curve or edge must be linear (0 to ignore)
Definition: zwapi_util.h:1043
svxEntFind
entity search data
Definition: zwapi_util.h:1030
svxEntPath::Count
int Count
number of id's in the path
Definition: zwapi_util.h:269
svxEntPath::Id
int Id[V_PP_LEN]
list of id's that define the path to an entity Id[0] = -1; path begins with top-level parent file/o...
Definition: zwapi_util.h:270
svxEntPath
entity pick path(sync with VsPickPath)
Definition: zwapi_util.h:268
svxEntPick::idEntity
int idEntity
entity id
Definition: zwapi_util.h:977
svxEntPick::idParent
int idParent
id of entity's parent object (i.e. sketch) or "0" if the entity is a direct child of the target objec...
Definition: zwapi_util.h:978
svxEntPick
entity pick (includes optional parent entity)
Definition: zwapi_util.h:976
svxFCSData::datum
svxFCSDatum datum[3][3]
FCS's datum.
Definition: zwapi_util.h:2185
svxFCSData::tol
svxFCSTol tol[2]
FCS's tolerance.
Definition: zwapi_util.h:2184
svxFCSData::sym
evxFCSSymbol sym
FCS's MD&T symbol.
Definition: zwapi_util.h:2183
svxFCSData
FCS data.
Definition: zwapi_util.h:2182
svxFCSDatum::datum
vxLongName datum
datum
Definition: zwapi_util.h:2172
svxFCSDatum::isValid
int isValid
valid data (0-no, 1-yes)
Definition: zwapi_util.h:2171
svxFCSDatum::freeState
int freeState
free state (0-no, 1-yes)
Definition: zwapi_util.h:2174
svxFCSDatum::lmsOpt
evxFCSLmsOption lmsOpt
LMS options.
Definition: zwapi_util.h:2173
svxFCSDatum
FCS datum data.
Definition: zwapi_util.h:2170
svxFCSTol::tol
vxLongName tol
tolerance
Definition: zwapi_util.h:2156
svxFCSTol::lmsOpt
evxFCSLmsOption lmsOpt
LMS options.
Definition: zwapi_util.h:2157
svxFCSTol::isValid
int isValid
valid data (0-no, 1-yes)
Definition: zwapi_util.h:2154
svxFCSTol::shapeSym
evxFCSShapeSym shapeSym
area shape symbol
Definition: zwapi_util.h:2155
svxFCSTol::statisticalTol
int statisticalTol
statistical tolerance (0-no, 1-yes)
Definition: zwapi_util.h:2162
svxFCSTol::projTol
vxLongName projTol
projected tolerance
Definition: zwapi_util.h:2161
svxFCSTol::projTolFlag
int projTolFlag
projected tolerance flag (0-no, 1-yes)
Definition: zwapi_util.h:2160
svxFCSTol::tangentPlane
int tangentPlane
tangent plane (0-no, 1-yes)
Definition: zwapi_util.h:2159
svxFCSTol::freeState
int freeState
free state (0-no, 1-yes)
Definition: zwapi_util.h:2158
svxFCSTol
FCS tolerance data.
Definition: zwapi_util.h:2153
svxFaceAt::specular
unsigned char specular
specular reflection coeff. (0-100)
Definition: zwapi_util.h:1147
svxFaceAt::front_color
svxColor front_color
color of front side
Definition: zwapi_util.h:1149
svxFaceAt::reflectance
unsigned char reflectance
reflectance
Definition: zwapi_util.h:1141
svxFaceAt::exp
unsigned char exp
specular reflection exponent (0-128)
Definition: zwapi_util.h:1143
svxFaceAt::refraction
unsigned char refraction
refraction
Definition: zwapi_util.h:1142
svxFaceAt::trans
unsigned char trans
transparency setting (0-100)
Definition: zwapi_util.h:1144
svxFaceAt::emission
unsigned char emission
emission coeff. (0-100)
Definition: zwapi_util.h:1148
svxFaceAt::ambient
unsigned char ambient
ambient reflection coeff. (0-100)
Definition: zwapi_util.h:1145
svxFaceAt::spec_color
svxColor spec_color
specular color
Definition: zwapi_util.h:1151
svxFaceAt::back_color
svxColor back_color
color of back side
Definition: zwapi_util.h:1150
svxFaceAt::diffuse
unsigned char diffuse
diffuse reflection coeff. (0-100)
Definition: zwapi_util.h:1146
svxFaceAt
face display attributes
Definition: zwapi_util.h:1140
svxFacets::ST
svxPoint2f * ST
list of vertex texture coordinates (s,t from 0.0 to 1.0); ST is optional and may be NULL
Definition: zwapi_util.h:1912
svxFacets::Vertex
svxPointf * Vertex
list of vertex coordinates (x,y,z)
Definition: zwapi_util.h:1909
svxFacets::At
svxFaceAt At
optional display attributes
Definition: zwapi_util.h:1914
svxFacets::RGB
svxColorf * RGB
list of vertex colors (r,g,b components from 0.0 to 1.0; see cvxColorfToColor() for conversion to svx...
Definition: zwapi_util.h:1919
svxFacets::Sh
svxShaderAt Sh
optional shader attributes
Definition: zwapi_util.h:1916
svxFacets::Normal
svxPointf * Normal
list of vertex normals (i,j,k unit direction vector); Normal is optional and may be NULL
Definition: zwapi_util.h:1910
svxFacets::UV
svxPoint2f * UV
list of UV coordinates corresponding to vertex coordinates; UV is optional and may be NULL
Definition: zwapi_util.h:1917
svxFacets::Tx
svxTextureAt Tx
optional texture attributes
Definition: zwapi_util.h:1915
svxFacets::numVertex
int numVertex
number of vertices in Vertex list
Definition: zwapi_util.h:1908
svxFacets::TriStrip
int * TriStrip
list of integer indices that define triangle strips
Definition: zwapi_util.h:1894
svxFacets::numTriStrip
int numTriStrip
number of triangle strips in TriStrip list
Definition: zwapi_util.h:1893
svxFacets
3D facets defined by triangle strips
Definition: zwapi_util.h:1892
svxLimit::max
double max
minimum
Definition: zwapi_util.h:457
svxLimit::min
double min
maximum
Definition: zwapi_util.h:456
svxLimit
limits
Definition: zwapi_util.h:455
svxLineAt::type
unsigned char type
line/marker type (0-15)
Definition: zwapi_util.h:1425
svxLineAt::size
unsigned char size
line/marker size (1-6)
Definition: zwapi_util.h:1426
svxLineAt::color
evxColor color
line/marker color (VX_COLOR_NULL-VX_COLOR_LAST)
Definition: zwapi_util.h:1424
svxLineAt
Line attributes.
Definition: zwapi_util.h:1423
svxMatEuler::y
double y
y location
Definition: zwapi_util.h:496
svxMatEuler::ang3rd
double ang3rd
3rd rotate angle (Rad)
Definition: zwapi_util.h:494
svxMatEuler::ang1st
double ang1st
1st rotate angle (Rad)
Definition: zwapi_util.h:492
svxMatEuler::z
double z
z location
Definition: zwapi_util.h:497
svxMatEuler::x
double x
x location
Definition: zwapi_util.h:495
svxMatEuler::ang2nd
double ang2nd
2nd rotate angle (Rad)
Definition: zwapi_util.h:493
svxMatEuler
Euler angles and translate vector.
Definition: zwapi_util.h:491
svxMatrix::xt
double xt
cosines of X axis and origin X (xt)
Definition: zwapi_util.h:481
svxMatrix::zt
double zt
cosines of Z axis and origin Z (zt)
Definition: zwapi_util.h:483
svxMatrix::yt
double yt
cosines of Y axis and origin Y (yt)
Definition: zwapi_util.h:482
svxMatrix::identity
char identity
1 if identity matrix, else 0
Definition: zwapi_util.h:480
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxParameters::bnd
svxLimit bnd
boundaries of parameter space
Definition: zwapi_util.h:1615
svxParameters::knots
double * knots
array of knot values
Definition: zwapi_util.h:1616
svxParameters::num_knots
int num_knots
number of knots
Definition: zwapi_util.h:1614
svxParameters::degree
int degree
degree (order = deg + 1)
Definition: zwapi_util.h:1613
svxParameters::free_mem
int free_mem
1 if memory referenced by "knots" should be free'd by cvxCurveFree()
Definition: zwapi_util.h:1617
svxParameters::closed
int closed
1=closed curve, 0=open curve
Definition: zwapi_util.h:1612
svxParameters
curve parameter space data
Definition: zwapi_util.h:1611
svxPartAttribute::Cost
svxAttribute Cost
cost attribute
Definition: zwapi_util.h:1394
svxPartAttribute::Startdate
svxAttribute Startdate
start date attribute
Definition: zwapi_util.h:1400
svxPartAttribute::UserAttribute
svxAttribute UserAttribute[64]
user Attribute(Up to 64 user attributes).
Definition: zwapi_util.h:1389
svxPartAttribute::No_hatch
svxAttribute No_hatch
set "data" to "yes" or "no"
Definition: zwapi_util.h:1404
svxPartAttribute::Designer
svxAttribute Designer
designer attribute
Definition: zwapi_util.h:1393
svxPartAttribute::Material
svxAttribute Material
material attribute
Definition: zwapi_util.h:1399
svxPartAttribute::Dimen
svxAttribute Dimen[20]
dimension attribute, these attributes had been converted to a configuration table attributes or varia...
Definition: zwapi_util.h:1405
svxPartAttribute::No_rootshow
svxAttribute No_rootshow
set "data" to "yes" or "no"
Definition: zwapi_util.h:1410
svxPartAttribute::No_bom
svxAttribute No_bom
set "data" to "yes" or "no"
Definition: zwapi_util.h:1408
svxPartAttribute::No_section
svxAttribute No_section
set "data" to "yes" or "no"
Definition: zwapi_util.h:1403
svxPartAttribute::UserAttributeCount
int UserAttributeCount
count of UserAttribute
Definition: zwapi_util.h:1388
svxPartAttribute::Manager
svxAttribute Manager
manager attribute
Definition: zwapi_util.h:1398
svxPartAttribute::Number
svxAttribute Number
number attribute
Definition: zwapi_util.h:1391
svxPartAttribute::Version
int Version
attribute version
Definition: zwapi_util.h:1387
svxPartAttribute::Supplier
svxAttribute Supplier
supplier attribute
Definition: zwapi_util.h:1395
svxPartAttribute::Description
svxAttribute Description
description attribute
Definition: zwapi_util.h:1396
svxPartAttribute::Name
svxAttribute Name
name attribute
Definition: zwapi_util.h:1390
svxPartAttribute::Partclass
svxAttribute Partclass
part class attribute
Definition: zwapi_util.h:1392
svxPartAttribute::Enddate
svxAttribute Enddate
end date attribute
Definition: zwapi_util.h:1401
svxPartAttribute::File_path
svxAttribute File_path
file path
Definition: zwapi_util.h:1409
svxPartAttribute::Keyword
svxAttribute Keyword
keyword attribute
Definition: zwapi_util.h:1397
svxPartAttribute::Derived
svxAttribute Derived
derived attribute
Definition: zwapi_util.h:1402
svxPartAttribute::sheet_code
svxAttribute sheet_code
sheet code attribute
Definition: zwapi_util.h:1411
svxPartAttribute
part attribute structure
Definition: zwapi_util.h:1386
svxPlane::ylen
double ylen
extents in the XY plane
Definition: zwapi_util.h:1772
svxPlane::form
svxMatrix form
plane centered about xform
Definition: zwapi_util.h:1773
svxPlane::xlen
double xlen
extents of the XY plane
Definition: zwapi_util.h:1771
svxPlane
data of plane
Definition: zwapi_util.h:1770
svxPntOnEnt::pnt
svxPoint pnt
input point(useCritPnt = 1 to ignore)
Definition: zwapi_util.h:556
svxPntOnEnt::idParent
int idParent
entity parent id (-1/0 to ignore, profile/view id if idEnt is 2d entity)
Definition: zwapi_util.h:552
svxPntOnEnt::idControlPnt
int idControlPnt
id of the control point of the spline (starting from 0), only used when critPnt is VX_SPLINE_DEFINING...
Definition: zwapi_util.h:555
svxPntOnEnt::useDir
int useDir
1-use as a direction, else 0
Definition: zwapi_util.h:558
svxPntOnEnt::idEnt
int idEnt
entity id that the point on (-1/0 to ignore)
Definition: zwapi_util.h:551
svxPntOnEnt::dir
svxVector dir
direction of the input point
Definition: zwapi_util.h:557
svxPntOnEnt::flipDir
int flipDir
1-flip direction, else 0. enable when the direction control support flip the direction
Definition: zwapi_util.h:559
svxPntOnEnt::useCritPnt
int useCritPnt
1- use critTyp, else 0 (idEnt must be valid if useCritPnt is 1)
Definition: zwapi_util.h:553
svxPntOnEnt::critTyp
evxGeomCritPnt critTyp
type of critical point
Definition: zwapi_util.h:554
svxPntOnEnt
point on entity definition, also can use to set a dynamic point
Definition: zwapi_util.h:550
svxPntOnEntPath::entPath
svxEntPath entPath
entity path that the point on
Definition: zwapi_util.h:570
svxPntOnEntPath::pntType
evxGeomCritPnt pntType
point type
Definition: zwapi_util.h:568
svxPntOnEntPath::idControlPnt
int idControlPnt
id of the control point of the spline (starting from 0), only used when pntType is VX_SPLINE_DEFINING...
Definition: zwapi_util.h:569
svxPntOnEntPath::pnt
svxPoint pnt
point coordinates, only used when pntType is VX_FREE_POINT
Definition: zwapi_util.h:571
svxPntOnEntPath
point on entity path definition, also can use to set a dynamic point
Definition: zwapi_util.h:567
svxPoint2
2D point
Definition: zwapi_util.h:286
svxPoint2f
2D point(single precision floating point)
Definition: zwapi_util.h:296
svxPoint
3D point
Definition: zwapi_util.h:306
svxPointf
3D point (single precision floating point)
Definition: zwapi_util.h:317
svxPrfAreaProp::Ixy
double Ixy
Product of Inertia at org.
Definition: zwapi_util.h:1220
svxPrfAreaProp::Kr
double Kr
Radius of Gyration about z axis at org.
Definition: zwapi_util.h:1224
svxPrfAreaProp::Ir
double Ir
Inertia about z axis at org.
Definition: zwapi_util.h:1219
svxPrfAreaProp::Pmax
double Pmax
Principal axis of which inertia is maximum.
Definition: zwapi_util.h:1227
svxPrfAreaProp::Ky
double Ky
Radius of Gyration about y axis at org.
Definition: zwapi_util.h:1223
svxPrfAreaProp::Pmin
double Pmin
Principal axis of which inertia is minimum.
Definition: zwapi_util.h:1226
svxPrfAreaProp::area
double area
Area.
Definition: zwapi_util.h:1215
svxPrfAreaProp::Imin
double Imin
Inertia about Pmin.
Definition: zwapi_util.h:1228
svxPrfAreaProp::Kx
double Kx
Radius of Gyration about x axis at org.
Definition: zwapi_util.h:1222
svxPrfAreaProp::centroid
svxPoint2 centroid
Centroid.
Definition: zwapi_util.h:1213
svxPrfAreaProp::Iy
double Iy
Inertia about y axis at org.
Definition: zwapi_util.h:1218
svxPrfAreaProp::org
svxPoint2 org
Origin for calculating the properties.
Definition: zwapi_util.h:1212
svxPrfAreaProp::Ix
double Ix
Inertia about x axis at org.
Definition: zwapi_util.h:1217
svxPrfAreaProp::Imax
double Imax
Inertia about Pmax.
Definition: zwapi_util.h:1229
svxPrfAreaProp
profile area property
Definition: zwapi_util.h:1211
svxShaderAt::file
vxPath file
shader path/file name (blank if undefined)
Definition: zwapi_util.h:1882
svxShaderAt::color
svxColor color[4]
shader colors
Definition: zwapi_util.h:1883
svxShaderAt::name
vxName name
shader name (blank if undefined)
Definition: zwapi_util.h:1881
svxShaderAt::param
double param[10]
shader parameters
Definition: zwapi_util.h:1884
svxShaderAt
shader attribute
Definition: zwapi_util.h:1880
svxSphere::radius
double radius
radius
Definition: zwapi_util.h:1782
svxSphere::poleis01
int poleis01
= 1 : poles (if they exist) are at extreme V parameters = 0 : poles (if they exist) are at extreme U ...
Definition: zwapi_util.h:1784
svxSphere::form
svxMatrix form
sphere centered about xform
Definition: zwapi_util.h:1783
svxSphere
spherical surface data
Definition: zwapi_util.h:1781
svxSplineData::SingleSeg
int SingleSeg
single segment (0 as default)
Definition: zwapi_util.h:2409
svxSplineData::PntOnPln
int PntOnPln
1-points on align plane, else 0 (0 as default)
Definition: zwapi_util.h:2427
svxSplineData::PlacingDir
svxVector PlacingDir
Placing adjustment director (PlacingTyp = VX_PLACING_VECTOR)
Definition: zwapi_util.h:2413
svxSplineData::AlignPlane
svxEntPath AlignPlane
align plane (part entity path can be initialized as(alignEnt.Count = 2; alignEnt.Id={-1,...
Definition: zwapi_util.h:2425
svxSplineData::SplineTyp
int SplineTyp
0- through point, 1- control point (0 as default))
Definition: zwapi_util.h:2400
svxSplineData::Fairing
int Fairing
fairing type(0-None, 1-Energy, 2-Variation, 3-Jerk, 4-Bend, 5-Tension)
Definition: zwapi_util.h:2407
svxSplineData::CreateCrvOpen
int CreateCrvOpen
1-create curve open, 0-create close curve(1 as default)
Definition: zwapi_util.h:2406
svxSplineData::PlacingPln
svxEntPath PlacingPln
reference fram (part entity path can be initialized as(PlacingPln.Count = 2; PlacingPln....
Definition: zwapi_util.h:2418
svxSplineData::Degree
int Degree
degree (3 as default)
Definition: zwapi_util.h:2403
svxSplineData::PrjToPln
int PrjToPln
1-project to the align plane, else 0 (1 as default)
Definition: zwapi_util.h:2426
svxSplineData::PlacingTyp
evxPlacingType PlacingTyp
placing adjustment type
Definition: zwapi_util.h:2412
svxSplineData::UseOrient
int UseOrient
1-use orientation tool (0 as default, PlacingTyp = VX_PLACING_VIEW)
Definition: zwapi_util.h:2416
svxSplineData::Count
int Count
count of points
Definition: zwapi_util.h:2401
svxSplineData::AlignTyp
int AlignTyp
Align type, 0-auto, 1-select, (1 as default)
Definition: zwapi_util.h:2428
svxSplineData::PlacingPrj
int PlacingPrj
1-project to plane, else 0 (0 as default, PlacingTyp = VX_PLACING_PLANE)
Definition: zwapi_util.h:2420
svxSplineData::Pnts
svxSplinePnt * Pnts
point list
Definition: zwapi_util.h:2402
svxSplineData
Spline command data.
Definition: zwapi_util.h:2398
svxSplinePnt::ContinuityTyp
evxContinuityTyp ContinuityTyp
continuity type (VX_NONE as default)
Definition: zwapi_util.h:2371
svxSplinePnt::FlipDir
int FlipDir
1-flip the TangDir, else 0 (0 as default)
Definition: zwapi_util.h:2377
svxSplinePnt::dG2Radius
double dG2Radius
G2 radius(use this when UseG2Radius != 0)
Definition: zwapi_util.h:2376
svxSplinePnt::UseG1Manitude
int UseG1Manitude
1-use G1 magnitude, else 0 (0 as default)
Definition: zwapi_util.h:2373
svxSplinePnt::UseG2Radius
int UseG2Radius
1-use G2 radius, else 0 (0 as default)
Definition: zwapi_util.h:2375
svxSplinePnt::Pnt
svxPoint Pnt
point
Definition: zwapi_util.h:2368
svxSplinePnt::TangDir
svxVector TangDir
tangent direction at this point (ContinuityTyp != VX_CONTIN_NONE)
Definition: zwapi_util.h:2372
svxSplinePnt::UseCons
int UseCons
1-use the constraints data ,else 0 (0 as default)
Definition: zwapi_util.h:2369
svxSplinePnt::dG1Manitude
double dG1Manitude
G1 magnitude (use this when UseG1Manitude != 0 )
Definition: zwapi_util.h:2374
svxSplinePnt
Spline point.
Definition: zwapi_util.h:2367
svxSrfPrim::srf
svxSurface srf
nurbs surface data
Definition: zwapi_util.h:1866
svxSrfPrim::cyl
svxCylinder cyl
cylindrical surface data
Definition: zwapi_util.h:1865
svxSrfPrim::srfType
evxSrfPrimType srfType
surface type
Definition: zwapi_util.h:1859
svxSrfPrim::con
svxCone con
conical surface data
Definition: zwapi_util.h:1864
svxSrfPrim::pln
svxPlane pln
data of plane
Definition: zwapi_util.h:1862
svxSrfPrim::sph
svxSphere sph
spherical surface data
Definition: zwapi_util.h:1863
svxSrfPrim::ellso
svxEllipsoid ellso
ellipsoid surface data
Definition: zwapi_util.h:1867
svxSrfPrim::torus
svxTorus torus
circular surface data
Definition: zwapi_util.h:1868
svxSrfPrim
3D NURB surface data
Definition: zwapi_util.h:1858
svxSurface::Type
evxSurfaceType Type
surface type
Definition: zwapi_util.h:1740
svxSurface::OutNormal
int OutNormal
1 if the surface's natural normal points towards the outside of the shape it is associated with; 0 if...
Definition: zwapi_util.h:1741
svxSurface::P
svxControlPoints P
NURB control point data (mm)
Definition: zwapi_util.h:1747
svxSurface::U
svxParameters U
NURB parameter space data in U direction.
Definition: zwapi_util.h:1745
svxSurface::V
svxParameters V
NURB parameter space data in V direction.
Definition: zwapi_util.h:1746
svxSurface
3D NURB surface (untrimmed)
Definition: zwapi_util.h:1739
svxTextAt::multi_line_space
float multi_line_space
Vertical spacing between text.
Definition: zwapi_util.h:1465
svxTextAt::right_ind
float right_ind
right indent
Definition: zwapi_util.h:1485
svxTextAt::char_spacing
float char_spacing
Horizontal spacing between text.
Definition: zwapi_util.h:1466
svxTextAt::char_height
float char_height
text height
Definition: zwapi_util.h:1463
svxTextAt::char_slant
float char_slant
slant of text
Definition: zwapi_util.h:1480
svxTextAt::text_expansion
float text_expansion
Multiplier for text expansion.
Definition: zwapi_util.h:1481
svxTextAt::hor_align_type
unsigned char hor_align_type
horizontal text alignment type
Definition: zwapi_util.h:1473
svxTextAt::hor_align
unsigned char hor_align
horizontal text alignment
Definition: zwapi_util.h:1474
svxTextAt::precision
unsigned char precision
text precision
Definition: zwapi_util.h:1470
svxTextAt::path
float path
path of text as angle 0.0-360.0 degrees
Definition: zwapi_util.h:1478
svxTextAt::bold
unsigned char bold
bold flag 0-normal, 1-bold
Definition: zwapi_util.h:1455
svxTextAt::vert_align
unsigned char vert_align
vertical text alignment
Definition: zwapi_util.h:1476
svxTextAt::font_type
unsigned char font_type
font type (ex: proportional)
Definition: zwapi_util.h:1471
svxTextAt::size
unsigned char size
the width of line
Definition: zwapi_util.h:1469
svxTextAt::italic
unsigned char italic
italic flag 0-normal, 1-italic
Definition: zwapi_util.h:1459
svxTextAt::word_wrap
unsigned char word_wrap
fit method 0-none, 1-word wrap, 2-auto size text
Definition: zwapi_util.h:1460
svxTextAt::underline
unsigned char underline
underline flag 0x01-ul, overline flag 0x02-ol, delete line flag 0x04-dl
Definition: zwapi_util.h:1456
svxTextAt::text_angle
float text_angle
slope of text
Definition: zwapi_util.h:1479
svxTextAt::fontName
char fontName[36]
font name
Definition: zwapi_util.h:1461
svxTextAt::vert_align_type
unsigned char vert_align_type
vertical text alignment type
Definition: zwapi_util.h:1475
svxTextAt::first_line_ind
float first_line_ind
first line indent
Definition: zwapi_util.h:1483
svxTextAt::char_aspect
float char_aspect
width of text, char_aspect = width / height
Definition: zwapi_util.h:1464
svxTextAt::hanging_ind
float hanging_ind
hanging indent
Definition: zwapi_util.h:1484
svxTextAt
text attribute
Definition: zwapi_util.h:1454
svxTextureAt::trans
float trans
texture transparency (0 to 1.0)
Definition: zwapi_util.h:1271
svxTextureAt::file
vxPath file
texture path/file name (blank if undefined)
Definition: zwapi_util.h:1268
svxTextureAt::repeat
unsigned char repeat
1 to repeat texture, else 0
Definition: zwapi_util.h:1270
svxTextureAt::height
double height
texture height (mm)
Definition: zwapi_util.h:1272
svxTextureAt::use_embed
int use_embed
as an input, 1 means a pre-existing embedded image takes precedence over file, 0 means file repla...
Definition: zwapi_util.h:1276
svxTextureAt::dimen
unsigned char dimen
texture dimension (1-3)
Definition: zwapi_util.h:1269
svxTextureAt::angle
double angle
texture angle (deg)
Definition: zwapi_util.h:1274
svxTextureAt::width
double width
texture width (mm)
Definition: zwapi_util.h:1273
svxTextureAt::location
evxTextureLoc location
texture location relative to origin
Definition: zwapi_util.h:1281
svxTextureAt::opt
evxTextureOpt opt
texture option (zero if undefined)
Definition: zwapi_util.h:1267
svxTextureAt::origin
svxPoint origin
texture origin
Definition: zwapi_util.h:1275
svxTextureAt
texture attribute
Definition: zwapi_util.h:1266
svxTorus::fApplemon
int fApplemon
= 1 : Apple = 2 : Lemon
Definition: zwapi_util.h:1835
svxTorus::dPathRadius
double dPathRadius
revolve path or spine radius
Definition: zwapi_util.h:1828
svxTorus::form
svxMatrix form
torus centered about xform z-axis points out of plane x-axis point to seam
Definition: zwapi_util.h:1830
svxTorus::fSpineDir
int fSpineDir
= 1 : u defines the spine direction. = 0 : v defines the spine direction.
Definition: zwapi_util.h:1833
svxTorus::dProfRadius
double dProfRadius
xsect or profile radius
Definition: zwapi_util.h:1829
svxTorus
circular surface data
Definition: zwapi_util.h:1827
svxTriangle::Normal
svxVector Normal
outward-facing normal
Definition: zwapi_util.h:372
svxTriangle::Pnt
svxPoint Pnt[3]
triangle vertices
Definition: zwapi_util.h:371
svxTriangle
3D triangle
Definition: zwapi_util.h:370
svxUid::Time
int Time
base time
Definition: zwapi_util.h:988
svxUid::Count
int Count
entity count
Definition: zwapi_util.h:990
svxUid::Rand
int Rand
random number
Definition: zwapi_util.h:989
svxUid
entity unique identifier
Definition: zwapi_util.h:987
svxVariable::Name
vxName Name
variable name
Definition: zwapi_util.h:1123
svxVariable::Expression
vxVarExp Expression
optional expression (Expression[0]=0 if undefined)
Definition: zwapi_util.h:1126
svxVariable::Value
double Value
value is not required if Expression is defined
Definition: zwapi_util.h:1124
svxVariable::type
char type
variable type (value of evxVarType)
Definition: zwapi_util.h:1127
svxVariable::unit_type
char unit_type
unit type (see evxVarNumType), evxUnitType for point type
Definition: zwapi_util.h:1129
svxVariable::pnt_val
svxPoint pnt_val
the value of point is not required if Expression is defined
Definition: zwapi_util.h:1125
svxVariable::sub_type
char sub_type
sub type of numeric variable (value of evxVarNumType)
Definition: zwapi_util.h:1128
svxVariable
numeric variable
Definition: zwapi_util.h:1122
svxVector2
2D vector
Definition: zwapi_util.h:328
svxVector
3D vector
Definition: zwapi_util.h:338
svxView::Name
vxName Name
view name
Definition: zwapi_util.h:2440
svxView::Extent
float Extent
view extent
Definition: zwapi_util.h:2442
svxView::PRP_Dist
float PRP_Dist
distance from view origin to projection reference point (PRP)
Definition: zwapi_util.h:2445
svxView::BackDist
float BackDist
distance from view origin to back clip plane
Definition: zwapi_util.h:2444
svxView::Project
char Project
projection method, 0-parallel, 1-perspective
Definition: zwapi_util.h:2448
svxView::Matrix
svxMatrix Matrix
view matrix (i.e. transform)
Definition: zwapi_util.h:2441
svxView::FrontDist
float FrontDist
distance from view origin to front clip plane
Definition: zwapi_util.h:2443
svxView::Clip
char Clip
1-clip to front/back plane, 0-don't clip
Definition: zwapi_util.h:2447
svxView::Display
char Display
1-display this view, 0-don't display this view
Definition: zwapi_util.h:2446
svxView
view data(Z3PRT,Z3ASM)
Definition: zwapi_util.h:2439
svxWireAt::size
unsigned char size
line/marker size ( >= 1)
Definition: zwapi_util.h:1191
svxWireAt::type
unsigned char type
line/marker type ( >= 0)
Definition: zwapi_util.h:1190
svxWireAt::mode
char mode
display mode -3, permanently blanked -2, used for assembly alignment -1, blanked 0,...
Definition: zwapi_util.h:1192
svxWireAt::color
unsigned char color
color (0 if bundle undefined, else 1 through (VX_COLOR_LAST-1), ColorEnv[])
Definition: zwapi_util.h:1189
svxWireAt
wire display attributes
Definition: zwapi_util.h:1188
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_VAR_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_var.h
cvxEqGetDescById
cvxEqGetExpByName
cvxEqLoadFile
cvxEqRegen
cvxEqSetDescById
cvxPartEqnDelete
cvxPartInqEqnAssociatedSet
cvxPartInqEqnSetMembers
cvxPartVarSubstitute
cvxPartVarSubstituteResize
evxEqnSetOpt
evxEqnSetOpt

◆ ZW_API_VAR_H

#define ZW_API_VAR_H

Definition at line 17 of file zwapi_var.h.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_var.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_var.h
Go to the documentation of this file.
1
15#pragma once
16#ifndef ZW_API_VAR_H /* this ifndef surrounds entire header */
17#define ZW_API_VAR_H
18
19#include "zwapi_util.h"
20
21#ifdef __cplusplus
22extern "C" {
23#endif /* __cplusplus */
24
25//====================================================================================================================
27//====================================================================================================================
32typedef enum evxEqnSetOpt
33 {
34 VX_EQN_MANUAL_SET_EQN = 0,
35 VX_EQN_AUTO_OVERWRITE_ALL_EQN = 1,
36 VX_EQN_AUTO_NEW_ALL_EQN = 2,
37 VX_EQN_AUTO_CANCEL_ALL_EQN = -1
38 } evxEqnSetOpt;
39
40//====================================================================================================================
42//====================================================================================================================
43/******************************************************************************/
64extern evxErrors cvxPartInqEqnSetMembers(int idSet, int* count, int** idList);
65
66/******************************************************************************/
82extern evxErrors cvxPartInqEqnAssociatedSet(int idEqn, int* idSet);
83
84/******************************************************************************/
102extern evxErrors cvxEqGetExpByName(char* name, char* exp, int size);
103
104/******************************************************************************/
122extern evxErrors cvxEqGetDescById(int idEqn, char* desc, int size);
123
124/******************************************************************************/
141extern evxErrors cvxEqSetDescById(int idEqn, char* desc);
142
143
144//====================================================================================================================
146//====================================================================================================================
147/******************************************************************************/
184extern evxErrors cvxPartVarSubstitute(char* Str, int nBytes, int* Truncated);
185
186/******************************************************************************/
228extern evxErrors cvxPartVarSubstituteResize(char** Str);
229
230/******************************************************************************/
246extern evxErrors cvxEqLoadFile(const vxLongPath fullpath, evxEqnSetOpt option);
247
248/******************************************************************************/
263extern evxErrors cvxEqRegen(int idEqn);
264
265/******************************************************************************/
279extern evxErrors cvxPartEqnDelete(int idEqn);
280
281
282/*
283*********************************************************************
284** END HEADER FILE
285*********************************************************************
286*/
287
288#ifdef __cplusplus
289 }
290#endif /* __cplusplus */
291
292#endif /* ZW_API_VAR_H */
vxLongPath
char vxLongPath[512]
file path or file name (null-terminated text string)
Definition: zwapi_util.h:240
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
cvxEqSetDescById
evxErrors cvxEqSetDescById(int idEqn, char *desc)
cvxPartVarSubstitute
evxErrors cvxPartVarSubstitute(char *Str, int nBytes, int *Truncated)
cvxPartInqEqnAssociatedSet
evxErrors cvxPartInqEqnAssociatedSet(int idEqn, int *idSet)
cvxEqGetDescById
evxErrors cvxEqGetDescById(int idEqn, char *desc, int size)
cvxEqGetExpByName
evxErrors cvxEqGetExpByName(char *name, char *exp, int size)
evxEqnSetOpt
evxEqnSetOpt
equation set option
Definition: zwapi_var.h:33
VX_EQN_MANUAL_SET_EQN
@ VX_EQN_MANUAL_SET_EQN
manually set every equations
Definition: zwapi_var.h:34
VX_EQN_AUTO_CANCEL_ALL_EQN
@ VX_EQN_AUTO_CANCEL_ALL_EQN
auto cancel the operation for all repeated equations
Definition: zwapi_var.h:37
VX_EQN_AUTO_OVERWRITE_ALL_EQN
@ VX_EQN_AUTO_OVERWRITE_ALL_EQN
auto overwrite all repeated equations
Definition: zwapi_var.h:35
VX_EQN_AUTO_NEW_ALL_EQN
@ VX_EQN_AUTO_NEW_ALL_EQN
auto create copy for all repeated equations
Definition: zwapi_var.h:36
cvxPartVarSubstituteResize
evxErrors cvxPartVarSubstituteResize(char **Str)
cvxPartEqnDelete
evxErrors cvxPartEqnDelete(int idEqn)
cvxEqLoadFile
evxErrors cvxEqLoadFile(const vxLongPath fullpath, evxEqnSetOpt option)
cvxPartInqEqnSetMembers
evxErrors cvxPartInqEqnSetMembers(int idSet, int *count, int **idList)
cvxEqRegen
evxErrors cvxEqRegen(int idEqn)
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_VIEW_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_view.h
cvxCustomViewActivate
cvxCustomViewAdd
cvxCustomViewDel
cvxCustomViewId
cvxGetViewRect
cvxViewActivate
cvxViewExtent
cvxViewGet
cvxViewInqStandardType
cvxViewIsSection
cvxViewIsStandard
cvxViewOrigin
cvxViewSet
cvxViewSetBndBox
cvxViewStd

◆ ZW_API_VIEW_H

#define ZW_API_VIEW_H

Definition at line 15 of file zwapi_view.h.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_view.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_view.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_VIEW_H /* this ifndef surrounds entire header */
15#define ZW_API_VIEW_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
41extern int cvxViewIsSection(int idView);
42
43/******************************************************************************/
58extern int cvxViewIsStandard(int idView);
59
60/******************************************************************************/
76extern evxErrors cvxViewInqStandardType(int idView, evxViewStd* type);
77
78
79//====================================================================================================================
81//====================================================================================================================
82/******************************************************************************/
97extern evxErrors cvxViewActivate(int idView);
98
99/******************************************************************************/
107extern void cvxViewExtent(double Extent);
108
109/******************************************************************************/
122extern void cvxViewGet(svxMatrix* Frame, double* Extent);
123
124/******************************************************************************/
138extern void cvxViewSet(svxMatrix* Frame, double Extent);
139
140/******************************************************************************/
151extern void cvxViewOrigin(svxPoint* Origin);
152
153/******************************************************************************/
170extern void cvxViewStd(evxViewStd Type, double NullExtent);
171
172/******************************************************************************/
186extern evxErrors cvxViewSetBndBox(double Scale, const svxBndBox* BndBox);
187
188/******************************************************************************/
206extern evxErrors cvxGetViewRect(int includeFrame, int isGlobal, int* tlX, int* tlY, int* brX, int* brY);
207
208
209//====================================================================================================================
211//====================================================================================================================
212/******************************************************************************/
230extern evxErrors cvxCustomViewAdd(char* Name, int LyrVis, int ObjVis, int* idView);
231
232/******************************************************************************/
253extern evxErrors cvxCustomViewActivate(int idView);
254
255/******************************************************************************/
274extern evxErrors cvxCustomViewDel(int idView);
275
276/******************************************************************************/
293extern evxErrors cvxCustomViewId(vxName Name, int* idView);
294
295
296/*
297*********************************************************************
298** END HEADER FILE
299*********************************************************************
300*/
301
302#ifdef __cplusplus
303 }
304#endif /* __cplusplus */
305
306#endif /* ZW_API_VIEW_H */
evxViewStd
evxViewStd
standard 3D view orientations
Definition: zwapi_util.h:2456
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
cvxViewOrigin
void cvxViewOrigin(svxPoint *Origin)
cvxCustomViewDel
evxErrors cvxCustomViewDel(int idView)
cvxViewInqStandardType
evxErrors cvxViewInqStandardType(int idView, evxViewStd *type)
cvxViewActivate
evxErrors cvxViewActivate(int idView)
cvxViewExtent
void cvxViewExtent(double Extent)
cvxViewGet
void cvxViewGet(svxMatrix *Frame, double *Extent)
cvxCustomViewAdd
evxErrors cvxCustomViewAdd(char *Name, int LyrVis, int ObjVis, int *idView)
cvxCustomViewId
evxErrors cvxCustomViewId(vxName Name, int *idView)
cvxViewIsStandard
int cvxViewIsStandard(int idView)
cvxCustomViewActivate
evxErrors cvxCustomViewActivate(int idView)
cvxGetViewRect
evxErrors cvxGetViewRect(int includeFrame, int isGlobal, int *tlX, int *tlY, int *brX, int *brY)
cvxViewIsSection
int cvxViewIsSection(int idView)
cvxViewStd
void cvxViewStd(evxViewStd Type, double NullExtent)
cvxViewSetBndBox
evxErrors cvxViewSetBndBox(double Scale, const svxBndBox *BndBox)
cvxViewSet
void cvxViewSet(svxMatrix *Frame, double Extent)
svxBndBox
3D bounding box
Definition: zwapi_util.h:465
svxMatrix
3D transformation matrix or coordinate frame (local to world)
Definition: zwapi_util.h:479
svxPoint
3D point
Definition: zwapi_util.h:306
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN


ZWAPIOPEN: ZW_API_XN_H

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • api
  • inc
  • zwapi_xn.h
cvxOpCount
cvxPartNameLastOp
cvxUndoBundleEnd
cvxUndoBundleStart
cvxUndoRedo
cvxUndoRedoMarker
cvxUndoRedoTo
cvxXnBundle
cvxXnUndoCount

◆ ZW_API_XN_H

#define ZW_API_XN_H

Definition at line 15 of file zwapi_xn.h.
Generated at Sun Apr 23 2023 16:41:41 for the ZWAPIOPEN


ZWAPIOPEN: zwapi_xn.h Source File

ZWAPIOPEN
  • ZW3D Base
  • Introductions
  • Modules
  • Files
  • Examples
  • File List
  • api
  • inc
zwapi_xn.h
Go to the documentation of this file.
1
13#pragma once
14#ifndef ZW_API_XN_H /* this ifndef surrounds entire header */
15#define ZW_API_XN_H
16
17#include "zwapi_util.h"
18
19#ifdef __cplusplus
20extern "C" {
21#endif /* __cplusplus */
22
23//====================================================================================================================
25//====================================================================================================================
26/******************************************************************************/
35extern int cvxOpCount(void);
36
37/******************************************************************************/
43extern int cvxXnUndoCount();
44
45/******************************************************************************/
71extern evxErrors cvxUndoRedoMarker(vxName Name);
72
73/******************************************************************************/
86extern evxErrors cvxUndoRedo(int Undo);
87
88/******************************************************************************/
107extern evxErrors cvxUndoRedoTo(int Undo, vxName Name);
108
109/******************************************************************************/
130extern evxErrors cvxPartNameLastOp(vxName NewName);
131
132
133//====================================================================================================================
135//====================================================================================================================
136/******************************************************************************/
150extern evxErrors cvxXnBundle(int iCount, const char* xn_name);
151
152/******************************************************************************/
172extern void cvxUndoBundleStart(int DisableManager, int Settings[]);
173
174/******************************************************************************/
194extern void cvxUndoBundleEnd(int RefreshDisplay, int Settings[], int isError);
195
196
197/*
198*********************************************************************
199** END HEADER FILE
200*********************************************************************
201*/
202
203#ifdef __cplusplus
204 }
205#endif /* __cplusplus */
206
207#endif /* ZW_API_XN_H */
evxErrors
evxErrors
the return value of the API interfaces
Definition: zwapi_util.h:35
vxName
char vxName[32]
object name (null-terminated text string)
Definition: zwapi_util.h:202
cvxOpCount
int cvxOpCount(void)
cvxUndoRedoTo
evxErrors cvxUndoRedoTo(int Undo, vxName Name)
cvxUndoBundleStart
void cvxUndoBundleStart(int DisableManager, int Settings[])
cvxUndoBundleEnd
void cvxUndoBundleEnd(int RefreshDisplay, int Settings[], int isError)
cvxXnBundle
evxErrors cvxXnBundle(int iCount, const char *xn_name)
cvxXnUndoCount
int cvxXnUndoCount()
cvxUndoRedo
evxErrors cvxUndoRedo(int Undo)
cvxPartNameLastOp
evxErrors cvxPartNameLastOp(vxName NewName)
cvxUndoRedoMarker
evxErrors cvxUndoRedoMarker(vxName Name)
zwapi_util.h
Generated at Sun Apr 23 2023 16:41:35 for the ZWAPIOPEN